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Impulse Response Utility overview
Impulse Response Utility is a multi-track audio recording and deconvolution application. It 
enables you to create your own impulse response files for the Space Designer convolution-
based reverb effect. For information about Space Designer, see Logic Pro Effects. Although Space 
Designer comes with plenty of great sounding halls, delays, and other reverbs, you might want to 
create an impulse response of your own studio, kitchen, bathroom, or even teapot.

You are not limited to creating impulse responses from rooms and spaces. You can make an 
impulse response from any device that you can play a broadband sine sweep into and record the 
results. Two examples are guitar speaker cabinets and hardware processing devices, such as tube 
equalizers and reverb effects units.

Impulse Response Utility provides all tools needed to create an impulse response, such as a 
flexible sweep generator, powerful editing facilities, and one-click creation of Space Designer 
settings. All you need is your Mac, Impulse Response Utility, and an audio interface that is 
connected to speakers and microphones. 

All parameters and functions that you need to create impulse responses are contained in a 
single window.

Hardware I/O 
Assignment area

Editing area

Inputs/Track section

Monitor and Sweep 
Generator section

Impulse Response Utility 1
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Impulse Response Utility is divided into four areas:

 • Hardware I/O Assignment area: Contains pop-up menus that enable choice of the audio input 
and output device. See Set up audio I/O and monitoring.

 • Monitor and Sweep Generator section: Contains monitoring and sine sweep generation 
parameters, plus buttons to deconvolve your audio tracks into an impulse response and to 
audition your IR. See Sweep Generator.

 • Inputs/Track section: Lists all audio tracks used for your impulse response recordings. See Audio 
track parameters.

 • Editing area: Displays the audio information of the currently selected audio track. See Edit your 
impulse response.

Deconvolution and impulse responses
Space Designer combines, or convolves, an impulse response of an acoustic space with an audio 
signal. The end result is that your audio is placed “inside” the acoustic space, represented by 
that impulse response. Think of an impulse response as the total echoes (reflections) in a given 
physical space, following an initial signal spike. The impulse response file is an audio recording 
made in a space that contains these echoes.

There are two practical approaches to impulse response recording: the transients method and 
the sine sweep method.

Transients method
The transients method involves the recording of an impulse in a space, using a device such 
as a starter pistol. The gunshot is the impulse, and the audio file you record captures both the 
impulse (the gunshot) and the room response.

The advantage of this method is that the recorded audio file can be used in Space Designer 
without any further processing. You can use Impulse Response Utility to record your starter 
pistol impulses and then combine them into a Space Designer Impulse Response (.sdir) file and a 
Space Designer setting file.

The disadvantage of this method is that it is difficult to make a perfect, undistorted recording of 
a starter pistol shot. This is due to the extremely loud nature of the initial transient of the shot. A 
further issue is that starter pistol shots contain very little high or bass frequency information—
which, in turn, limits the usable frequency range of the convolved reverb.

Sine sweep method
Use of a sine sweep is the preferred method for creating impulse responses. You play a 
broadband audio sine wave sweep into a space and record the sweep (and space) at optimal 
levels. A sine sweep that covers the entire audible frequency range is used, resulting in a broad-
range, and often higher-quality, impulse response.

The recorded sine sweep audio file cannot directly be used as an impulse response. The recorded 
file contains all the echoes and reflections—in other words, the response—of the space, 
stretched out over the length of the sine sweep. This is very different from the starter pistol 
approach, where the response is contained at the beginning of the file in an impulse.

When you use a sine sweep, Impulse Response Utility uses a process called deconvolution to 
time align and level align all recorded reflections that are present over the entire recorded 
sine sweep—into the very beginning of the file. This results in an impulse response that Space 
Designer can use to combine, or convolve, with your audio signal. Impulse Response Utility can 
then generate an .sdir setting from the impulse response.
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Impulse response recording hardware overview
Prior to using Impulse Response Utility to create an impulse response, you need to set up your 
recording hardware—allowing playback and recording of the sine sweep that Impulse Response 
Utility will generate.

The impulse response of a space is never only the space’s impulse response. The recorded 
impulse response is always the response of the complete system—every piece of equipment you 
use in the recording process. This includes, in signal-flow order: the digital-to-analog converter, 
the amplifier and speakers (or powered speakers), the room characteristics, the microphones, and 
finally the microphone pre-amp and analog-to-digital converter. Of these elements, the choices 
of microphones and speakers are the most critical.

There are no rules as to which brand or make of microphone or speaker will result in the 
best impulse response. A general guideline is to use speakers and microphones with a flat 
response—the speakers and microphones should offer a very even signal at all frequencies. Tube 
microphones, which are generally valued for the tonal color that they add to the signal, may 
not be appropriate for recording impulse responses. In general, microphones that work well for 
recording ambience are good candidates.

The ideal impulse response recording setup
When making an impulse response recording, ideally you will have one speaker for each speaker 
location required by the chosen format if you are recording sine wave sweeps. For example, 
if you are recording a true stereo impulse response, you will need two speakers; if you are 
recording a six channel surround impulse response, you will need six speakers; and so on. If you 
are not generating sine wave sweeps, you do not need speakers to play them back (the sound is 
generated by the starter pistol).

Note:  In many cases, it is sufficient to record one speaker position (but all microphone positions 
required by the chosen impulse response format) and create a Mono to Omni discrete impulse 
response. This results in a less CPU-intensive impulse response in the required format. See Record 
a five channel mono to omni impulse response on page 18.

You will also ideally have one or more microphones to record the resulting audio from each 
speaker (or your starter pistol) combined with its echo reflections. The number of microphones 
you will need depends on the chosen impulse response format. For example, if you are recording 
a six channel surround impulse response, there are six microphone positions, so ideally you will 
have six microphones. If you are recording a six channel B-Format encoded impulse response—
where only one microphone position and four tracks are required—you will need fewer 
microphones. See B-Format surround encoding overview on page 25 for more information.

The final element in a perfect recording setup is an audio interface that provides enough 
outputs to send a broadband audio sine sweep into each speaker if you are using sine sweeps 
and enough inputs to record the resulting audio from each position.

Impulse response recording 
hardware 2
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Note:  You may also need additional microphone pre-amplifiers if your microphones cannot 
capture a sufficient signal level or your audio interface does not provide enough mic 
pre-amp inputs.

Example of speakers and microphones set up to capture a 5.1 multi-channel impulse response

Computer

Audio interfaceSurround
microphone

tree
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Alternative impulse response recording setup
It is possible to make discrete multi-track impulse responses even if you do not have enough 
speakers or microphones. In this situation, you record one sine sweep at a time in Impulse 
Response Utility, using as many speakers as you have, then move the speakers to new positions 
and repeat the process. For example, imagine you have a stereo pair of speakers but want to 
create a quadraphonic impulse response, which requires the recording of four tracks in four 
different speaker positions. You could set up your pair of monitors, record their output, then 
move them to record the other pair of tracks in the other two speaker positions.

This method of creating impulse responses is time-consuming, and not having all speakers 
required for the format makes optimal monitor placement—relative to each other—difficult. 
With time and careful planning, however, you can still achieve the same results as would be 
possible with an ideal complement of speakers.

You can also create multi-channel impulse responses in Impulse Response Utility through use 
of the Mono to Omni Discrete impulse response format. This requires you to record one speaker 
with the number of “channel” microphones required for the chosen format. The resulting impulse 
response places a lower strain on your CPU. See Record a five channel mono to omni impulse 
response on page 18.

If you have enough monitors but not enough microphones, you can set up the required 
speakers and move your available microphones between them. This makes optimal microphone 
placement—relative to other microphones—difficult, but you have the advantage of optimal 
speaker placement.

If your audio interface does not have the required number of inputs and outputs for the speakers 
and microphones you are using, you can still set up all mics and speakers. As you record different 
tracks in Impulse Response Utility, you will need to disconnect and reconnect the speakers and 
microphones in turn.

See Speaker and microphone placement overview on page 8. 
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Speaker and microphone placement

Speaker and microphone placement overview
Where you place your speakers and microphones in the recording space has a significant impact 
on the specific echoes and reflections that your impulse response captures.

There are no hard rules for recording and so you should experiment with different mic and 
speaker positions and try a variety of microphones and techniques. There are, however, some 
guidelines that may help when you make your initial recordings.

In environments with hard floors, made from materials such as concrete, you may find that 
a “chirp” is recorded at the beginning of your impulse response. This sound is actually the 
generated sine sweep resonating through the floor into the microphone stand, then into the 
microphone itself. The speed of sound through floors and concrete is much faster than through 
air, resulting in a pre-impulse response that starts before the impulse response you want to 
record. To circumvent this potential problem, you can use studio drum pedestals and specialized 
microphone mounts that have strong acoustic absorbers built into them. If you cannot transport 
drum pedestals or do not have access to microphone mounts, try a thick carpet under the 
speakers and microphone stands.

There are some specific approaches outlined in the sections referred to below that you might 
want to try when creating impulse responses. These contain suggestions only; there are no 
rules regarding how far the speakers need to be placed away from the microphone array, the 
best angles, ideal distances between speakers and microphones, and so on. You may want to 
try a number of different techniques and placements to find the ideal arrangement. See Virtual 
listener approach, Auralization approach, and Virtual echo chamber approach.
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Virtual listener approach
The virtual listener approach is perhaps the most common technique for placing speakers and 
microphones when you create impulse responses. The goal is to capture the effect of the echoes 
and reflections coming from all around the space—as heard at the listening position. In this 
approach, the speakers are set up at the edges of the room, and the microphone is placed in the 
listening position. 

The resulting impulse response should sound like your audio is being played back from the 
various speaker locations in the space. This method does not require multiple microphones; a 
single microphone can be turned toward each speaker in turn, and different audio recordings 
can be made from the same location. The image illustrates the virtual listener approach to 
setting up five speakers for a five channel surround impulse response, with one microphone 
placed centrally in the space.

C
RL

RsLs Surround
microphone

tree

This method can create the impression of the audio signal being completely immersed in the 
simulated space.
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Auralization approach
A common strategy for placing speakers and microphones in a space uses the auralization 
approach. This technique attempts to capture the reflections from the performer’s perspective. 
Place one or more speakers at the performer’s location (or another audio source) and place the 
microphone at the listening position. The resulting impulse response should sound like your 
audio is being played back from these specific speaker locations. For example, you can make a 
stereo impulse response of a particular stage using the auralization technique. When you then 
use the impulse response in Space Designer, your audio should sound like it is on that stage. The 
image illustrates use of the auralization technique to set up your speakers and microphones for a 
true stereo impulse response.

Stage

Audience

L R

To capture a surround impulse response that represents being in the audience of a space, set up 
two speakers in the performer’s position as above, but place a surround array of microphones 
around the room. This can create a realistic feeling (and effect) of being in the audience when 
the performance is coming from in front of you. This can also help to create a surround-like effect 
from a live stereo recording.
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Virtual echo chamber approach
An alternative to the auralization approach is placement of your speakers and microphones in 
a way that creates a virtual space that resembles a physical echo chamber. To create this kind of 
impulse response, face the loudspeakers toward the corners and the microphones toward the 
opposite corners. This is how microphones in a physical echo chamber would be placed. This 
eliminates a direct path from the speaker to the microphone and captures more reflections. The 
image illustrates how you could set up two speakers and two microphones to create a stereo 
impulse response using this virtual echo chamber approach.

L R

The resulting impulse response allows you to mix the reverb into the dry signal, without any 
phase cancelation issues caused by early reflections or direct signals. This approach works well 
if you want to keep your signal mostly dry, without any alteration or coloration from the reverb, 
but still want to add a high-fidelity reverb tail to your audio.

You can also use this method for surround or multi-channel reverbs. The main concept 
to remember is that the speakers should be pointing at the wall to eliminate direct paths 
between microphones and speakers. The illustration below offers a possible layout for a five 
channel reverb chamber. The loudspeakers, placed in a circle, are directed at the walls, and the 
microphone array is placed in the center of the circle.

Surround
microphone
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Impulse Response Utility workflow
Creating an impulse response in Impulse Response Utility consists of the following stages:

Create a new project
Configure your Impulse Response Utility project for the number of tracks your impulse response 
format requires. See Create an Impulse Response Utility project.

Set Impulse Response Utility parameters
Set the hardware I/O, monitor, and sweep parameters for your audio track recordings. See Set up 
audio I/O and monitoring and Sweep Generator.

Record audio
Use Impulse Response Utility to record the audio tracks needed for your impulse response. See 
Audio track parameters and Record audio in Impulse Response Utility.

Deconvolve your audio recordings
Assuming you have recorded sine sweeps, deconvolve after all audio tracks have been recorded. 
Impulse Response Utility will generate an impulse response from your tracks. See Deconvolve 
your impulse response.

Edit and audition your impulse response
Cut silent portions, apply fades, and so on, to optimize your impulse response. See Edit your 
impulse response and Audition window.

Create a Space Designer setting
When finished with the steps above, add the newly created impulse response to your list of 
available Space Designer settings. See Create a Space Designer setting.

Create impulse responses 3
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Create an Impulse Response Utility project
When you first open Impulse Response Utility, the New Impulse Response Project dialog appears. 
This is the first step in creating a new impulse response project. You can also create a new 
impulse response project by choosing File > New Project (or pressing Command-N).

Impulse Response Utility offers formats ranging from conventional stereo impulse responses, 
true stereo (where each channel is processed discretely), quadraphonic formats, or five, six, or 
seven channel surround formats. These latter formats can be in either traditional multi-track or 
B-Format encoding. See B-Format surround encoding overview on page 25 for more information.

You can also create multi-channel impulse responses in Impulse Response Utility by using the 
Mono to Omni Discrete impulse response format. This only requires the recording of one speaker 
by as many “channel” microphones as needed (for the chosen format). The resulting impulse 
response places a lower strain on your CPU. See Record audio in Impulse Response Utility on 
page 17.

Create a new impulse response project
 1 Choose an impulse response format from the Configuration pop-up menu.

In the window below the Configuration pop-up menu, the dialog displays the number of speaker 
and microphone positions required by the selected format.

 2  Click OK.

The required number of tracks (determined by the format you chose) are shown in the Inputs/
Track section of Impulse Response Utility.

Set up audio I/O and monitoring
You need to set up the audio input and output device before you can use Impulse Response 
Utility. 

The audio input selection determines the audio device used to record audio tracks. The audio 
output selection determines the audio device used to monitor the recorded signal and to play 
back the generated sine sweep.

Once you have recorded sine sweep tracks in Impulse Response Utility, you can monitor them 
through a stereo output of your choice. The monitor controls determine the monitor channel 
and level. You can also mute the monitor section.

Select an audio input device
 m Choose an audio interface driver from the Audio Input pop-up menu.
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Select an audio output device
 m Choose an audio interface driver from the Audio Output pop-up menu.

Note:  Although the Hardware I/O Assignment area also displays the current sample rate, you 
cannot change the sample rate of your impulse response project in Impulse Response Utility. 
If you want to record your audio tracks at a different sample rate, you need to change it in the 
Audio MIDI Setup utility or in the software for your audio interface (if applicable). Consult the 
documentation for your audio interface if you are unsure.

Select the stereo monitor output channels
 m  Choose the desired stereo output pair from the Monitor Channel pop-up menu.

Adjust the output level of the monitored signal
 1  Click inside the Monitor Level field.

 2  Do one of the following:

 •  Drag left (or down) to reduce the volume, or right (or up) to raise the volume.

 •  Enter a numeric value for the monitor level (any value above 0 dB sets the monitor level at 
0 dB).

Important:  To avoid audio feedback when recording, be sure to mute the monitor output.

Mute the monitor output
 m  Select the Monitor Mute checkbox or press the M key.

Audio track parameters
The Inputs/Track section is automatically filled with the number of tracks required for the 
impulse response recording, based on your selections in the New Impulse Response Project 
dialog. Every track lane in the Inputs/Track section has a number of parameters. Some are 
automatically configured by Impulse Response Utility; others you need to set before recording.

Track parameters
 • Speaker Position pop-up menu: Choose the speaker position label for the selected track. Both 

Impulse Response Utility and Space Designer use these labels to identify and process the 
audio files that comprise a multi-channel stereo or surround impulse response. Impulse 
Response Utility automatically sets the speaker position label for each track, but you can 
change these labels to any other position available in the current impulse response format.
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 • Mic Position pop-up menu: Choose the mic position label for the selected track. Both Impulse 
Response Utility and Space Designer use these labels to identify and process the audio files 
that comprise a multi-channel stereo or surround impulse response. Impulse Response Utility 
automatically sets the mic position label for each track, but you can change these labels to any 
other position available in the current impulse response format.

 • Input pop-up menu: Choose the physical input for each track. Be sure to select the correct input 
before recording.

 • S[olo] button: Click to hear the selected track in isolation. When the Solo button is on (yellow), 
the input signal is routed to the monitor section and the input level is displayed in the 
VU meter.

 • R[ecord-Enable] button: Click to place the selected track into record-ready mode. Clicking 
this button also turns on the Solo button for the selected track, allowing you to monitor the 
input signal before recording. You can record-enable several tracks at once, for multi-channel 
recording. When you click Sweep/Record, a recording is made on all record-enabled tracks. 

 • L[ock] button: Click to lock the selected track.

Note:  As soon as one track is locked, the sweep generator parameters are also locked. This 
ensures that any subsequent recordings will use identical sweep settings. This is necessary 
because every track must use an identical sine sweep to produce a phase coherent, accurate, 
multi-channel impulse response.

 • Peak field: Displays the peak level value in dB. If the level ever exceeds 0 dB, the peak value is 
held until cleared. Click the Peak column header to reset the Peak readout for all tracks.

 • Level: Displays input meters for each track. These level meters always show the current level of 
the physical inputs.

 • VU meter: Measures either the signal level present at the (soloed) track input or the sweep 
generator output. During playback of recorded audio, the VU meter displays the level of the 
selected track. A status message below the VU meter shows its current operating mode. The 
VU meter scale ranges from 0% to 100%, with 100% equaling 0 dB.  
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Sweep Generator
The Sweep Generator produces a sine wave that sweeps smoothly from 20 Hz up to 20 kHz.

Sweep Generator parameters
 • Sweep Channel pop-up menu: Choose the input channel you want to use.

 • Test Tone pop-up menu: Choose a test tone frequency for the sustained (non-sweeping) sine 
wave tone generator. Use this test tone to ensure that your hardware output channel is 
connected properly and that your speakers can reproduce the selected sine wave frequency.

 • On checkbox: Click to hear the test tone.

 • Sweep Level field: Drag vertically to set the level of the test tone.

 • Sweep Length pop-up menu: Choose one of three sweep durations. Ideally, you want your sine 
wave to be short because this can avoid recording artifacts caused by air motion, rattling of 
interiors, and other ambient noise. Unfortunately, short sweeps may not yield adequate signal-
to-noise ratios in some recording situations. If the results you attain from recording with a 
10-second sweep are not suitable, try the 50-second sweep.

 • 10s: A 10-second sine sweep

 • 50s: A 50-second sine sweep

 • Off: No sine wave sweep. Choose this setting if you are recording a starter pistol impulse.

 • Reverb Time field: Drag to set the maximum recording time for each track. To accurately capture 
the acoustic properties of a space, you should set a value that is long enough to capture the 
decay phase of all reverberations and echoes.

Note:  If you are using the Sweep Generator, the reverb time starts when the sine sweep ends. 
If you have set the Sweep Length parameter to Off to record a starter pistol impulse response, 
the Reverb Time parameter determines the entire length of the recording.

 • Preroll checkbox: Click to make sure that no operator noise, such as typing, adjusting 
microphones, and so on, is recorded. The pre-roll length is determined by the value set with 
the Reverb Time parameter.
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Record audio in Impulse Response Utility
Once you have made hardware assignments and configured the monitor and sine sweep 
parameters, it is time to start recording audio tracks. If you are using the Sweep Generator, you 
will hear the sine wave sweep up through its frequency range. Impulse Response Utility records 
the result on all record-enabled audio tracks. If you have turned off the Sweep Generator, click 
Record, and shoot your starter pistol. Impulse Response Utility records the resulting impulse 
response onto the selected track.

Impulse Response Utility records into your computer’s RAM, not to your hard disk. This means 
that nothing you have recorded is saved until you save your project. For your convenience, 
Impulse Response Utility automatically saves your project to disk after every recording. If you 
have not saved your project, the Save dialog appears, allowing you to name your project and 
choose a hard disk location. If you have already saved your project, the save process happens 
automatically. See Open, save, and revert to saved projects on page 24.

Select an audio track
Do one of the following:

 m  Click a track lane.

 m  Use the Up and Down Arrow keys to navigate through the track list.

Record in Impulse Response Utility
If you are using the Sweep Generator, the Sweep/Record button is labeled “Sweep.” If you have 
set the Sweep Length parameter to Off, the button is labeled “Record.”

 1  Select an audio track in the Inputs/Track section.

 2  Configure the audio track for recording.

 3  Repeat this step for each track required by the chosen format.

 4  Click the Sweep/Record button to begin recording.

 • If you click Sweep: The recording process starts automatically and generates the sine sweep. 
The VU meter is automatically switched to display the sweep generator output.

 • If you click Record: The recording process starts automatically. Shoot your starter pistol and 
Impulse Response Utility records the audio.

 5 Recording continues until the entire sine sweep (if the Sweep Generator is being used) and 
Reverb Length time have elapsed. The recording automatically ends. 

You can stop the recording process at any time by clicking the Sweep/Record button.

Note:  The Sweep/Record button is not available if no track is record-enabled.

Record a five channel surround impulse response
This task assumes that you have set up your speakers and microphones using the Virtual listener 
approach that requires five speakers and at least one microphone in the middle, which can 
be turned toward each speaker in turn. Ideally, you will have five identical, powered monitors. 
This will save you time when recording audio and will allow you to see all speakers at once to 
ensure they are each the same distance from the corners and walls, and so on. When all speakers 
have been positioned, you need to set up your microphone in the middle of the hall. Make sure 
everything is properly connected to your audio interface.

 1 Choose the 5 channel template from the Configuration pop-up menu in the New Impulse 
Response Project dialog, then click OK.
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As shown in the dialog, this format requires five speaker positions and five mic positions. After 
you click OK, 25 audio tracks appear in the Inputs/Track area, one for each speaker position, from 
every microphone position.

 2 Position your microphone toward the speaker you want to record (the left front speaker, for 
example).

 3 Set up the monitor section, Sweep Generator, and input for the selected track.

 4 Record-enable the selected track, and click the Sweep button.

Impulse Response Utility prompts you to name and save the new project after your 
first recording.

 5 Swivel the microphone to the second surround position, record-enable the track, and click the 
Sweep button. 

Once the recording is completed, the project is automatically saved.

 6 Repeat this process another 23 times, until you have recorded all 25 audio tracks needed to 
capture all possible microphone and speaker position combinations.

Record a five channel mono to omni impulse response
In many cases, it is sufficient to record one speaker position rather than multiple positions, thus 
creating a mono to omni impulse response. Mono to omni impulse responses are easier and 
faster to record and place a lower strain on the CPU when played.

 1  Choose the Mono to Omni to 5 channel template in the New Impulse Response Project dialog.

As shown in the dialog, Mono to Omni discrete projects require only one speaker.

 2  Aim your speaker toward the ceiling or a back wall.

 3  Point your microphone to the first surround position: to the front left, for example.

 4  Record the sweep.

 5  Repeat the process for all remaining microphone positions.

Record an impulse response from a guitar speaker
You are not limited to creating impulse responses from rooms and spaces. You can make an 
impulse response from any device that you can play a broadband sine sweep into and record 
the results, such as a guitar speaker cabinet. If you make an impulse response from a guitar 
speaker cabinet and then run a direct guitar amp signal through that impulse response in 
Space Designer (set to 100% wet), the direct signal will sound as if it was played through the 
speaker cabinet.

 1 Plug your audio interface output directly into an effects return input on your guitar amplifier. If 
your guitar amp does not have an effects return, you can either use a “re-amp” box that raises 
the impedance of your audio interface’s line out to the level required by your guitar amplifier at 
its input, or you can use a line level amplifier in place of your guitar amplifier to amplify the sine 
sweep through the guitar cabinet.

 2 Plug your guitar amp effects return output directly into your audio interface input.

 3 Choose the Mono or Stereo template in the New Impulse Response Project dialog.

 4 Position your microphone approximately one inch from the center of the speaker.
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If you have a multi-speaker cabinet, experiment with positions.

Guitar amplifier
with microphone

ComputerAudio interface

 5  Record the sweep.

Record an impulse response from a hardware effects unit
You are not limited to creating impulse responses from rooms and spaces. You can make an 
impulse response from any device that you can play a broadband sine sweep into and record 
the results, such as tube equalizers and reverb effects units. Imagine that you want to create an 
impulse response from your favorite tube microphone pre-amp, allowing you to use its unique 
color on your audio. This way, you can run a signal through this impulse response in Space 
Designer (set to 100% wet) and add the color of your microphone pre-amp to the signal.

 1 Plug your audio interface output directly into an effects unit input.

 2 Plug your effects unit output directly into your audio interface input.

 3 Choose the Mono or Stereo template in the New Impulse Response Project dialog.

 4  Record the sweep.

Note:  You should take care when making impulse responses from hardware effects devices that 
include modulation effects. Modulations such as phasing, chorus, and so on, interfere with the 
sine sweep itself, which makes deconvolution difficult or impossible. This is also true for some 
reverbs, such as classic Lexicon hardware reverb devices, in which the reverb tails are modulated. 
In these cases, it may be more effective to send a recorded impulse of a spike or gunshot 
through the hardware effects device instead of a sine sweep.
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Deconvolve your impulse response
Deconvolution is the process used to create impulse responses from (recorded) broadband audio 
sine sweeps. If you use the Sweep Generator, you need to deconvolve your audio recordings to 
make them usable as an impulse response.

Deconvolve your audio tracks
Do one of the following:

 m Click the Deconvolve button.

 m Choose Edit > Deconvolve (or press Shift-Command-D).

Following deconvolution, your audio tracks will be a single impulse response that you can 
audition, edit, and turn into an .sdir setting.

Note:  While it is possible to deconvolve each audio track once recorded, it is an inefficient way to 
work. It is far more efficient to wait until all tracks are recorded and then deconvolve them.

Edit your impulse response
When you have finished recording your audio tracks, you may need to remove silence at the 
beginning or end of the file, adjust fade out times, and so on. Impulse Response Utility enables 
you to cut, crop, and fade your audio files in the Editing area.

View an audio file in the Editing area
 m Select the audio file. 

Your audio file automatically appears in the Editing area.

You can select from three different display views with the buttons at the top of the Editing area. 
These views allow you to effectively analyze your waveforms, making it easy to identify material 
you need to cut or crop or that requires a fade. The Spectrogram mode, in particular, which 
simultaneously shows frequency, level, and time, allows for very detailed analysis of your audio.

 • Waveform button: Click to show the recorded audio as a standard waveform. The horizontal 
axis displays the elapsed time. The vertical axis displays the audio level as a percentage.

 • Energy button: Click to show the sound energy distribution over time. The horizontal axis 
displays the elapsed time. The vertical axis displays audio levels in dB.



 Chapter  3    Create impulse responses 21

 • Spectrogram button: Click to show the frequency distribution over time. The horizontal axis 
displays the elapsed time. The vertical axis displays the frequencies, which are color-coded by 
dB range. See the color legend in the upper-right corner of the Editing area.

Select and play part of an audio file in the Editing area
 1 Drag horizontally over an audio section.

 2 Click the Play button to audition your selection. Click the Cycle button to continuously play back 
the selected track.

Tip:  Use the Space bar to toggle playback or the C key to toggle cycle playback.

Edit the selected part of an audio file
 m  Select one of the editing operations using the buttons at the top-left corner of the Editing area:

 • Crop button: Click to remove audio to the right and left of your selection, without touching the 
selected audio. You can also choose Edit > Crop (or press Command-X) to crop. 

Note:  If you make a selection that does not extend to either the beginning or end of the 
audio, the left edit button activates the Crop function.

 • Cut button: Click to remove the selected audio, without touching the unselected audio. You can 
also choose Edit > Cut (or press Command-X) to cut.  

Note:  If you make a selection that extends to either the very beginning or very end of the 
audio, the left edit button activates the Cut function.

 • Fade button: Click to create a gradual fade over the length of the selection area. You can also 
choose Edit > Fade (or press Command-F) to fade. If you make a selection that includes either 
the very beginning or end of the audio, you can select the Fade function.

Important:  To maintain phase coherency between all tracks of your impulse response, edits are 
performed across all tracks equally. To ensure that your impulse response cannot include tracks 
that are not edited equally, you are prevented from recording further tracks once an edit has 
been made.
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Audition window
To hear how your impulse response will sound when used in Space Designer, you need to be 
able to listen to it in context. Impulse Response Utility includes an Audition window for this 
purpose, where the loaded impulse response can convolve test audio files. The Audition window 
is divided into three sections: the Impulse Response area, the Monitor area, and the Audio Test 
Files area.

The appearance of the Audition window changes slightly when using a B-Format impulse 
response. The B-Format Audition window removes the Output Channel parameter from the Track 
area and includes a Loudspeaker area.

Audition B-Format Impulse 
Responses window

Audition Impulse 
Responses window

Impulse Response Utility allows up to five audio files to be loaded/used as sources when 
auditioning your impulse response. The Audition window also includes four test source files.

Audition window parameters
 • Enable checkbox: Turns individual impulse response recordings on or off. Use these boxes to 

select the specific file (or files) you want to audition.

 • Input ID label: Identifies the specific impulse response file by its speaker > mic positions.

 • Output Channel pop-up menu (not available for B-Format Impulse Responses): Choose the 
physical output channel used for playback of the selected impulse response.

 • Mix field: Drag to set the ratio of the dry test source signal to the wet effect signal.

 • Monitor Level field: Drag to set the overall auditioning volume.

 • Test Audio Files buttons: Click to play one of the four included test source audio files.

 • Open buttons: Click to load an audio file for use as a test source. Any uncompressed audio file 
can be used.

 • Play buttons: Click to play the selected audio file through the enabled impulse response file (or 
files).
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Loudspeaker parameters (B-Format only)
 • Number of Loudspeakers field: Click the arrows to determine the number of loudspeakers that 

Impulse Response Utility will decode the impulse response into.

 • Loudspeaker Angle field: Drag to set the angle of each loudspeaker. The B-Format decoding 
takes this into account when re-creating the recorded space.

 • Output Channel pop-up menu: Choose the physical output channel for the 
selected loudspeaker.

Open the Audition window
 m  Click the Audition IR button.

The Audition window opens. None of the editing functions are available while the Audition 
window is open.

Create a Space Designer setting
Once you are satisfied with your impulse response, the final step is to generate an .sdir file and a 
plug-in setting. When done, your newly created impulse response can be used in Space Designer.

Create a Space Designer setting for your impulse response
Do one of the following:

 m  Click the Create Space Designer Setting button.

 m  Choose File > Create Space Designer Setting.

Impulse Response Utility generates an .sdir file of your impulse response and saves it in the 
following directory: ~/Library/Application Support/Logic/Impulse Responses. 

A plug-in setting file for your impulse response is also generated and saved in the following 
directory: ~/Library/Application Support/Logic/Plug-In Settings/Space Designer.

The next time you open Logic Pro, your newly created impulse response will be available in the 
Library and from the Space Designer Settings menu.
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Open, save, and revert to saved projects
The Impulse Response Utility project file is an OS X package file that contains all files associated 
with the project.

Impulse Response Utility automatically saves your project as soon as you record audio. You can 
manually save your project at any time, however. You can also open a previously saved project or 
revert the current project back to its last saved state.

Open a project
Do one of the following:

 m  Choose File > Open Project (or press Command-O), then navigate to your project file.

 m  Choose File > Open Recent to open a hierarchical menu of recently opened project files.

Save your project with its current name and location
 m  Choose File > Save Project (or press Command-S) to save your IR Project with its current name in 

its current location.

Save your project with a new name or location
 m  Choose File > Save As (or press Command-Shift-S).

Revert to a previously saved project version
If you are unhappy with the edits or recordings made in your current project and you have saved 
the project, you can return the project to its last saved version.

 m  Choose File > Revert to Saved.

Note:  Once you use the Revert to Saved command, you lose all unsaved changes.
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B-Format surround encoding overview
B-Format is a special way of encoding spatial information. It represents space using four audio 
streams: one to capture the sound pressure (W), and three to capture the X (front-to-back), Y 
(left-to-right), and Z (top-to-bottom) room coordinates. The illustration shows you how these four 
audio streams interact with each other to create a three-dimensional spatial image.
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Y

Z

Y
Left

X
Rear

W

Space Designer can decode and convolve these four streams into reverbs in all supported 
surround formats. Space Designer provides a comprehensive library of B-Format impulse 
responses that use all four streams (W, X, Y, and Z). Because impulse responses do not make use 
of Z-axis information, Impulse Response Utility only records and encodes information from the W, 
X, and Y positions, saving CPU resources and disk space. Impulse Response Utility allows you to 
encode all supported surround impulse response formats in B-Format.

See Advantages of B-Format surround encoding and Microphones for B-Format recording.

B-Format surround encoding 4
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Advantages of B-Format surround encoding
One advantage of the B-Format is that it can capture a surround image with fewer audio files. 
Normally, you need to record every speaker position from every microphone position to correctly 
record surround information. With B-Format, these four (or three, in Impulse Response Utility) 
audio streams are all you need to capture audio from each speaker.

For example, imagine you are using a five channel setup and want to use Impulse Response 
Utility to create a five channel impulse response. Using traditional methods, you need to record 
all five speakers from all five microphone positions, resulting in 25 audio files. If you choose to 
create your project as a five channel B-Format impulse response, you only need to record fifteen 
audio files—three audio recordings (W, X, and Y) from each of the five speaker positions. This 
clearly illustrates that B-Format encoded surround impulse responses require far fewer audio 
files, and therefore less hard drive space, as well as needing less RAM and CPU cycles when 
decoded in Space Designer.

A second advantage to B-Format encoding is phase coherency when using multiple 
microphones at once. Whenever you use multiple microphones, differences in the time it 
takes sound to reach each microphone can result in phase cancelations and phase shifts that 
can affect the quality of your impulse response. Because the point of reference is always the 
same when using B-Format encoding, there are no phase issues, even when using multiple 
microphones to record your impulse response.

Microphones for B-Format recording
The SoundField single point source microphone series is ideal as B-Format recording 
microphones. These microphones contain all the capsules you need to make a complete 
B-Format reference recording in one pass, and they include hardware to send the separate axis 
streams to individual Impulse Response Utility tracks. You only need to swivel the mic once 
toward each speaker position, and the mic and processing hardware do the rest. If you do not 
have access to SoundField mics, Impulse Response Utility provides additional microphone 
options for B-Format recording.

Capturing the W (sound pressure) signal requires an omnidirectional microphone. Capturing the 
X and Y axis signals requires a microphone with a figure-eight pattern that captures signal from 
the front and back of the mic. Therefore, with two figure-eight patterned microphones—one 
pointed directly at the speaker source (X) and another positioned perpendicularly (Y)—and an 
omnidirectional microphone for the sound pressure (W), you can record each speaker position 
in one pass. Be sure to arrange the microphones so that their capsules are as close as possible to 
each other. Ideally, you want to have a single, tight point of reference for each speaker position.

You need to swivel each of the figure-eight pattern microphones to each speaker position. The 
omnidirectional microphone does not need to be swiveled because it has a 360-degree capsule.

If you do not have three separate microphones, you can still create B-Format impulse responses 
by recording each audio stream separately in Impulse Response Utility. All you need is a single 
microphone that allows you to switch between omnidirectional and figure-eight patterns. You 
will need to do a significant amount of pattern-switching and microphone swiveling, but it can 
be done.
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