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An Introduction 
to Soundtrack Pro

 

Soundtrack Pro gives you the tools you need to create 
high-quality soundtracks for your video productions.

 

Recent years have seen a revolution in working with digital audio, matching the 
revolution in digital video editing and postproduction. Now, using a personal computer 
with a fast processor and enough RAM, video editors and other creative professionals 
can manipulate the audio for their video projects with the same power and flexibility as 
the video.

 

What Is Soundtrack Pro?

 

Soundtrack Pro is a new professional audio application for Macintosh computers that 
gives you the tools to perform a wide range of audio postproduction tasks. Using 
Soundtrack Pro, you can edit audio files, repair field recordings, perform multitrack 
arranging and mixing, synchronize audio and video, analyze and fix common audio 
problems, and perform creative sound design.

You can work in two kinds of projects in Soundtrack Pro:  

 

multitrack projects

 

 and 

 

audio 
file projects

 

. In multitrack projects, you add and arrange audio clips on the Timeline, 
where you can edit audio clips, synchronize audio and video, and automate volume, 
pan, and other changes over time using envelopes. You can also record audio directly 
to a track in the Timeline. You mix multitrack projects in the Mixer, which includes a 
channel strip for each track, bus, and output in the project. In both the Timeline and 
the Mixer you can add and adjust professional-quality realtime effects, including 
compression, EQ, and reverb. You can export your project mix to an audio file or to a 
QuickTime movie, export using Compressor, and also export individual tracks, busses, 
and outputs.
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In audio file projects, you can edit audio files in the Waveform Editor for tasks ranging 
from audio repair to sound design. In the Waveform Editor, you can perform precise 
edits down to the individual sample level. You can perform edits nondestructively 
using actions, which include processing effects and other operations, and can turn off 
or completely reorder actions. You can analyze audio files in the Waveform Editor for a 
range of common audio problems, including clicks and pops, hum, and phase issues, 
and automatically fix problems detected by analysis. 

Soundtrack Pro is designed to work with Final Cut Pro and with other Apple 
professional applications, allowing you to send video and audio files back and forth 
between the applications as you work on both the video and the audio. Soundtrack Pro 
also includes a large selection of Apple Loops that you can use to add Foley effects, 
background ambience, sound effects, and music transitions to your projects. Apple 
Loops tagged as looping files automatically match the tempo and key of the project, 
allowing you to use them in the same project.

Soundtrack Pro includes the following features:
Â Powerful audio editing:  You can edit audio files nondestructively in the Waveform 

Editor. You can edit audio files graphically with sample accurate precision, and 
process files using actions, which can be reordered and turned on or off individually.

Â Analysis and repair of common audio problems:  The Waveform Editor features analysis 
of audio files. You can choose which problems to analyze the file for, then fix the 
problems detected by analysis either individually or in a single operation. Selected 
problems are highlighted in the waveform display for easy viewing.

Â Advanced mixing capabilities:  You can mix multitrack projects in the Mixer, which 
displays a virtual mixing console for a project. Using the channel strips in the Mixer, 
you can adjust levels, mute and solo tracks, and add realtime effects. You can create 
submixes using busses, and send audio to multiple physical outputs using outputs.

Â Add professional-quality effects:  Soundtrack Pro includes high-quality effects plug-ins 
from the Logic Pro effects library that you can use in your projects, including the 
Space Designer convolution reverb. You can also install third-party effects in the 
Audio Units plug-in format.

Â Record and edit automation:  You can record movements to sliders and other 
onscreen controls, play back the automation, and edit it in the Timeline.

Â Support for control surfaces:  In addition to recording movements of onscreen 
controls, you can connect a supported control surface, and record automation of 
control surface movements.
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Â Synchronized video display:  You can add a video to a project and view it in the Video 
tab, or display the video on an external video monitor. Audio/video synchronization is 
accurate both onscreen and on the external monitor, up to HD resolutions. You can 
accurately place audio clips to sync with specific frames or points in time in the video.

Â Audio recording capability:  You can record audio directly in tracks in the 
Soundtrack Pro Timeline, including recording multiple takes.

Â Integrated workflow with Final Cut Pro:  You can send a clip from the Final Cut Pro 
Timeline to Soundtrack Pro and edit the clip in the Waveform Editor. When you save 
the clip, it is automatically updated in your Final Cut Pro project. You can also send 
clips or sequences to a Soundtrack Pro multitrack project.

Resources for Learning About Soundtrack Pro
This manual describes the Soundtrack Pro interface, commands, and menus, and gives 
step-by-step instructions for creating Soundtrack Pro projects and for accomplishing 
specific tasks. It also includes information on setting up your system and on audio 
basics. It is designed to provide the information you need to get up to speed quickly so 
you can take full advantage of the intuitive interface and powerful features of 
Soundtrack Pro.

If you want to start by learning how to set up audio hardware to use with 
Soundtrack Pro, read Chapter 1, “Setting Up Your System,” on page 13. If you want to 
learn about the features and controls in the Soundtrack Pro interface, read Chapter 2, 
“The Soundtrack Pro Interface,” on page 23. If you want to jump right in and start using 
the application, skip ahead to Chapter 3, “Getting Started With Soundtrack Pro,” on 
page 45. If you want to read about editing audio files in the Waveform Editor, turn to 
Chapter 7, “Working in the Waveform Editor,” on page 143.

In addition to this manual, Soundtrack Pro provides other sources of support.
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Soundtrack Pro Onscreen User Manual
The Soundtrack Pro onscreen user manual allows you to access information directly 
onscreen while you’re working in Soundtrack Pro. To view this information, choose 
Help > Soundtrack Pro User Manual. The Soundtrack Pro onscreen user manual is a fully 
hyperlinked version of the Soundtrack Pro User Manual, enhanced with many features 
that make locating information quick and easy.
Â The homepage provides quick access to various features, including Late-Breaking 

News, the index, and the Soundtrack Pro website.
Â A comprehensive bookmark list allows you to quickly choose what you want to see 

and takes you there as soon as you click the link.

In addition to these navigational tools, the Soundtrack Pro onscreen user manual gives 
you other means to locate information quickly:
Â All cross-references in the text are linked. You can click any cross-reference and jump 

immediately to that location. Then, you can use the Preview Back button to return to 
where you were before you clicked the cross-reference.

Â The table of contents and index are also linked. If you click an entry in either of these 
sections, you jump directly to that section of the user manual. 

Â You can also use the Find dialog to search the text for specific words or a phrase.

Apple Websites
There are a variety of Apple websites that you can visit to find additional information.

Soundtrack Pro Website
For general information and updates, as well as the latest news on Soundtrack Pro, go to:
Â http://www.apple.com/soundtrackpro

Apple Service and Support Website
For software updates and answers to the most frequently asked questions for all Apple 
products, including Soundtrack Pro, go to:
Â http://www.apple.com/support/soundtrackpro

You’ll also have access to product specifications, reference documentation, and Apple 
and third-party product technical articles.

http://www.apple.com/soundtrackpro
http://www.apple.com/support/soundtrackpro
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Other Apple Websites
Start at the Apple homepage to find the latest and greatest information about Apple 
products:
Â http://www.apple.com

QuickTime is industry-standard technology for handling video, sound, animation, 
graphics, text, music, and 360-degree virtual reality (VR) scenes. QuickTime provides a 
high level of performance, compatibility, and quality for delivering digital video. Go to 
the QuickTime website for information on the types of media supported, a tour of the 
QuickTime interface, specifications, and more:
Â http://www.apple.com/quicktime

FireWire is one of the fastest peripheral standards ever developed, which makes it great 
for use with multimedia peripherals, such as video camcorders and the latest high-
speed hard disk drives. Visit this website for information about FireWire technology and 
available third-party FireWire products:
Â http://www.apple.com/firewire

For information about seminars, events, and third-party tools used in web publishing, 
design and print, music and audio, desktop movies, digital imaging, and the media arts, 
go to:
Â http://www.apple.com/pro

For resources, stories, and information about projects developed by users in education 
using Apple software, including Soundtrack Pro, go to:
Â http://www.apple.com/education

Go to the Apple Store to buy software, hardware, and accessories direct from Apple 
and to find special promotions and deals that include third-party hardware and 
software products:
Â http://www.apple.com/store

http://www.apple.com
http://www.apple.com/quicktime
http://www.apple.com/pro
http://www.apple.com/education
http://www.apple.com/store
http://www.apple.com/firewire
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1 Setting Up Your System

The way you set up your system depends on the audio 
equipment you plan to use. 

You can use your computer’s speaker or headphone jack to monitor the audio output 
from Soundtrack Pro. For better results, you may want to connect external monitors or 
speakers to your system, so that you can monitor the audio output at a higher level of 
quality. You may want to connect other external audio equipment such as an audio 
interface or a mixer, particularly if you plan to record your own audio in Soundtrack Pro. 
Â For information on system and hardware requirements, see the Read Before You 

Install document on the installation DVD.
Â For information on installing the software, see the Installing Your Software booklet.

System Considerations
To achieve the most effective results, you should consider the following issues when 
setting up your system.

Processor Speed and RAM
Digital audio files require intensive processing by your computer. If you plan to work on 
longer or more complex projects, or use multiple effects plug-ins in your projects, a 
computer with a faster processor can facilitate your productivity.

Soundtrack Pro is optimized for use with computers that have a multiprocessor 
architecture. Working with Soundtrack Pro projects on a multiprocessor-equipped 
computer can make your workflow more efficient, especially when creating longer or 
more complex projects. 

If you plan to work on large projects, it’s useful to have extra random-access memory, 
or RAM, installed in your computer. Additional RAM allows you to play back more files 
simultaneously, use a greater number of effects plug-ins, and keep several multimedia 
applications open at the same time. 
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Hard Disk Space
It’s also a good idea to have a large hard disk with plenty of available space to store 
the media (audio and video) files you use with Soundtrack Pro. As you work with the 
application, you’ll likely want to acquire a large collection of sounds to use in your 
Soundtrack Pro projects. You can use audio files stored on a CD-ROM disc or other 
external media, but playback performance may not be as good as if the audio files are 
installed on a local hard disk, especially when using a large number of files. 

If you store media files on an external hard disk, make sure the disk has a fast enough 
seek time and a high enough sustained data transfer rate for use with multimedia files. 
Consult the manufacturer’s specifications. 

Dedicated Hard Disk
If you plan to record your own audio in Soundtrack Pro, remember that every minute of 
stereo digital audio (recorded using a 44.1 kHz sample rate and 16-bit depth) requires 
roughly 10 MB of hard disk space. If you plan to record large amounts of audio, you 
may want to record to a dedicated hard disk. 

Setting the Audio Input and Output
By default, Soundtrack Pro uses the input and output devices set in your computer’s 
System Preferences for audio input and output. You can set the default input and 
output devices for Soundtrack Pro in the Recording pane of the Soundtrack Pro 
Preferences window, and change them for individual recording sessions in the 
Recording tab. For information on changing the default input and output devices 
Soundtrack Pro uses, see “Setting Soundtrack Pro Preferences” on page 75.

Adding Audio Units Plug-Ins to Your Computer 
Soundtrack Pro includes an extensive set of professional-quality effects plug-ins. 
Soundtrack Pro uses effects in the Audio Units plug-in format, the native plug-in format 
of Mac OS X. 

Audio Units plug-ins are also available from third-party manufacturers. When adding 
third-party effects to your computer, be sure to read the documentation, including any 
Read Me and installation files, that came with the plug-in. Supported Audio Units 
effects plug-ins appear in the Effects window under the manufacturer’s name. 

Soundtrack Pro does not support VST, ASIO, MAS, or RTAS effects plug-ins. 
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Connecting Audio Equipment
You can use a variety of audio equipment with Soundtrack Pro for both recording and 
playback. For information on connecting a specific piece of equipment to your 
computer, read the documentation that came with the equipment. 

When using external audio devices, it’s a good idea to connect them before opening 
Soundtrack Pro.

Soundtrack Pro does not support video input from devices such as camcorders or 
videocassette decks. 

Audio Interfaces
You can connect an audio interface to your computer, and then connect microphones 
and musical instruments to the audio interface for recording. You can also connect 
output devices, such as monitors or speakers, a mixer, or an amplifier to the audio 
interface. 

When choosing an audio interface, check the manufacturer’s specifications to make 
sure the interface is compatible with Mac OS X v10.3. Some audio interfaces require 
driver software, while others are supported without the need for a driver. If the device 
requires a driver, make sure an up-to-date driver is included with the device, or is 
available from the manufacturer. 

All digital audio interfaces can be susceptible to latency, a noticeable delay between 
the time the audio signal is produced and the time you hear it. When connecting an 
audio interface, you should connect the interface directly to the computer, rather than 
connecting it through a hub or daisy-chaining it through another device. Connecting 
an audio interface through a hub or an intermediary device can cause an unacceptable 
amount of latency, particularly with slower protocols such as USB.

Soundtrack Pro supports input from digital audio interfaces up to a maximum sample 
rate of 96 kHz and a maximum bit depth of 24 bits. If you connect an interface that 
uses sample rates or bit depths outside the range supported by Soundtrack Pro, an 
alert message appears, telling you that data from the audio interface is not compatible 
with the application.
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FireWire (IEEE 1394)
FireWire is a professional and consumer standard for both audio and video equipment. 
The combination of fast data-transfer rates, high storage capacities, and plug-and-play 
connection makes FireWire an attractive choice for working with digital audio files. 
FireWire is included on all current Macintosh computers, and a number of FireWire 
audio interfaces are available. 

There are two kinds of FireWire connectors:  a 4-pin connector (typically found on 
video equipment) and a 6-pin connector (used for computer and audio equipment). 

USB (Universal Serial Bus) 
USB is a consumer standard used on computer peripherals and other devices. USB 
offers a lower data-transfer rate than FireWire, but supports plug-and-play operation 
and the ability to connect several devices in sequence (daisy-chaining). Some USB 
devices draw their power over the USB cable, while others require a separate power 
connection. USB is included on all current Macintosh computers. 

There are two kinds of USB connectors:  an A connector, typically used to connect a 
device to a USB hub, and a B connector, typically used to connect devices together, and 
also to connect a device to a computer. USB audio interfaces should always be directly 
connected to your computer, not connected via a hub or to the computer’s display, 
keyboard, or another peripheral.

FireWire 400 (6-pin)
(Sometimes labeled iLINK)

FireWire 400 (4-pin)

USB (Universal Serial Bus)
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PCI (Peripheral Connect Interface) 
PCI interfaces, unlike FireWire and USB interfaces, require that you install a dedicated 
sound card in your computer. PCI provides high bandwidth and fast data-transfer rates, 
allowing you to record and play back large numbers of files at the highest possible 
sample rates and bit depths. 

PCMCIA
PCMCIA is a consumer standard for connecting devices to a laptop computer. PCMCIA 
provides a lower data-transfer rate than FireWire or USB, but provides a compact, 
affordable solution for connecting an audio interface to your computer, while keeping 
your USB and FireWire ports available for other devices. Most current Macintosh laptop 
computers support PCMCIA connections via a built-in card slot.

Audio Cabling
There are several types of audio cables and connectors used on professional and consumer 
audio equipment, at a range of prices and levels of quality. When connecting microphones 
and musical instruments to an audio interface or a mixer, make sure the interface has the 
proper input jacks for the type of connectors and cables you plan to use.

XLR
XLR cables and connectors are used on professional-quality microphones, monitors, and 
other musical equipment. They provide a high-quality, balanced signal at +4 dB level. 

1/4-Inch Audio
1/4-inch connectors (sometimes called “phone plugs”) are used on a wide variety of 
professional and consumer musical equipment, including musical instruments and 
amplifiers, speakers, and external effects devices. They can be either balanced (+4 dB) 
or unbalanced (–10 dB). Some devices require Tip-Ring-Sleeve (TRS) connectors to 
transfer the audio signal.

XLR connector (balanced)  

1/4-inch Tip-Ring Sleeve (TRS) connector

1/4-inch Tip-Ring (TR) connector
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RCA
RCA connectors are used on consumer audio equipment such as home stereo systems 
and videocassette recorders. 

Optical Digital (AES-EBU and S/PDIF)
AES-EBU and S/PDIF are both used to provide an optical digital connection to 
professional and consumer audio equipment, including audio interfaces, DAT (digital 
audio tape) machines, hardware samplers. Both carry a stereo digital signal. AES-EBU is 
balanced, and has an operating level of 5 volts, while S/PDIF is unbalanced and has an 
operating level of roughly 1/2 volt. There are adapter cables available to convert 
between the two protocols. S/PDIF carries additional information with the audio signal, 
including SCMS copy-protection information. 

1/8-Inch Miniplug
Miniplug connectors are used for audio input and output to computers and on some 
consumer electronic devices, particularly portable ones. 

Audio Output 
Being able to monitor the audio output of your projects at a high level of quality is 
crucial to achieving professional results. In general, you should use the best output 
equipment your budget allows. 

Speakers and Monitors
You can play back audio through your computer’s speakers or headphone jack, but the 
audio output may not be high enough for you to evaluate your music at a professional 
level of quality. Connecting external speakers or monitors to your system allows you to 
hear the audio output with greater fidelity and a wider dynamic range. In general, you 
should use the highest-quality speakers or monitors you can afford in order to hear 
your projects at the highest level of audio quality. 

For detailed information on connecting external speakers to your audio interface, see 
the documentation that came with the speakers. 

RCA connector (unbalanced)

S/PIDF optical digital connector

Stereo miniplug connector (unbalanced)
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Amplifiers
If you are recording audio from microphones, and are not running the microphone’s 
signal through a mixer with a microphone pre-amplifier, you need to connect an 
amplifier to boost the microphone’s signal before sending it to the computer. If you are 
connecting monitors or speakers that are not self-powered, you also need to connect 
them through an amplifier. 

Mixers
Connecting a mixer to your system allows you to record audio from multiple 
microphones or instruments simultaneously, to play back the output from your 
computer through connected monitors or speakers, and to control the volume levels of 
both the audio input and output. Professional-quality mixers have a number of 
additional features, including equalization (EQ) controls, auxiliary sends and returns for 
adding external effects, and separate monitor and mix level controls. Mixers may also 
include inboard pre-amplification for microphones, making the use of a separate 
amplifier unnecessary.

Control Surfaces
Soundtrack Pro supports control surfaces that use the Mackie Control and Logic 
Control protocols. For information on connecting and using control surfaces, see 
Chapter 12, “Using Control Surfaces With Soundtrack Pro,” on page 243.

Example Hardware Setups
The following sections provide several examples of different hardware setups. 

Setting Up a System Using Powered Speakers
With this setup, you can monitor the audio output through a set of connected 
powered speakers. 

This setup uses the following equipment:
Â Your computer and display
Â A set of powered speakers, including speaker wire and a power adaptor

Computer

Speakers

Speaker cables

Power cables
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Setting Up a System Using a USB Audio Interface
With this setup, you can record audio input from microphones and musical 
instruments, and monitor audio output, through a USB audio interface.

This setup uses the following equipment:
Â Your computer and display
Â USB audio interface (from 2 to 8 channels) with USB cable to connect to your 

computer
Â Microphone
Â Musical instruments (guitar, bass, and keyboard)
Â Cables to connect microphones and instruments to the audio interface
Â Set of monitors or speakers

Monitors

Computer

Audio interface

USB
cable

Speaker
cables

Microphone

InstrumentComputer
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Setting Up a System Using a FireWire Interface 
and a Control Surface
With this setup, you can record audio input from several sources simultaneously, and 
monitor audio output channels independently, through a mixer connected to a 
FireWire audio interface.

This setup uses the following equipment:
Â Your computer and display
Â FireWire audio interface with FireWire cable to connect to your computer
Â Control surface and MIDI interface with USB cable to connect MIDI interface to your 

computer
Â MIDI cables to connect control surface to MIDI interface
Â Set of powered monitors or speakers
Â Speaker cables

Monitors

Control surface

Audio interface

FireWire 
cable

Speaker cables

Computer

Power cables

Midi interface
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Setting Up a System Using a Video Output Device
With this setup, you can play video and audio through an external video output device. 
Because using a video output device can result in increased latency, you may want to 
combine this setup with an audio-only setup (as shown in the preceding pages), and 
switch between the two setups.

This setup uses the following equipment:
Â Your computer and display
Â Video output device (Firewire device or PCI card)
Â High-quality video monitor
Â Audio speakers

Computer

Video output device

FireWire
cable

Audio monitors

Speaker
cables

Mixer

Video monitor
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2 The Soundtrack Pro Interface

In Soundtrack Pro, you work in four main windows:  
the Project window, the Mixer, the Media and Effects 
Manager, and the Utility window.

Â The Project window includes the Timeline, where you arrange audio clips, and the 
Waveform Editor, where you edit audio files. 

Â The Mixer is where you mix multitrack projects. It includes channel strips for each 
track, bus, and output, as well as other controls.

Â The Media and Effects Manager is where you locate and preview audio and video 
files to add to your project, and also where you add and adjust realtime effects. 

Â The Utility window has tabs where you can add and view a video in a project, see the 
master level meters, get details on clips and other items, and set up recording.

Media and Effects
Manager

Project window

Utility window
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Project Window
The Project window is the “canvas” where you work on your projects. For multitrack 
projects, the Timeline is where you arrange and edit audio clips. For audio file projects, 
the Waveform Editor is where you edit audio files.

Â Toolbar:  Includes tools for common functions. You can customize which tools appear 
in the Toolbar.

Â Tabs:  You can switch between any projects open in the Timeline or Waveform Editor. 
Â Transport controls:  Control playback and the position of the playhead, and turn 

recording on or off. (For more information, see “Transport Controls” on page 25.)
Â Master volume slider:  Adjusts the overall volume when you play the project. The 

volume level defaults to 0 dB when you create a project. Adjusting the master 
volume slider does not affect export volume.

Â Mono Mix button:  Click to listen to a temporary mono mix of the project.
Â Playhead Position value slider:  Displays the current playhead position. You can move 

the playhead by clicking the arrows, dragging, or typing a value.
Â Selection Length value slider:  Displays the length of the current Timeslice (in the 

Timeline) or selection (in the Waveform Editor). You can change the Timeslice or 
selection length by clicking the arrows, dragging, or typing a value.

Tabs

Playhead Position
value slider

Selection Length 
value slider

Master volume slider

Toolbar

Mono Mix button

Transport 
controls
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Toolbar
The Toolbar is located at the top of the Project window. When you first open 
Soundtrack Pro, the Toolbar includes buttons for creating a new project, creating a 
new audio file, showing the Mixer and the Utility window, managing layouts, adding 
markers, and other common functions. You can customize the Toolbar, adding buttons 
for functions you want to access frequently. For information about customizing the 
Toolbar, see “Customizing the Toolbar” on page 49.

Transport Controls
You use the transport controls to control playback, set the position of the playhead, 
start recording, and activate the playback region. 

Â Record button:  Starts and stops the recording process.
Â Play from Beginning button:  Starts playback from the beginning of the project.
Â Go to Beginning button:  Moves the playhead to the beginning of the project, or to 

the beginning of the playback region if it is active.
Â Play/Pause button:  Starts playback at the current playhead position. If the project is 

playing, stops playback. 
Â Go to End button:  Moves the playhead to the end of the project, or to the end of the 

playback region if it is active.
Â Cycle button:  Activates the playback region, if one is set in the Time ruler.
Â MIDI Sync button:  Synchronizes playback with incoming MIDI Clock and MIDI 

Timecode (MTC) signals.

For information on using the transport controls, see “Controlling Playback With the 
Transport Controls” on page 55.

Play from Beginning

Go to EndRecord

Cycle

MIDI Sync

Go to Beginning

Play
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Timeline
The Timeline gives you a visual representation of a multitrack project, showing the 
position of clips, the playhead, and other items in time. The Timeline is organized into 
three groups of horizontal rows called tracks, busses, and outputs. You can add and 
arrange audio clips in tracks, use busses to create submixes, and send audio to physical 
output channels using outputs. You can control the sound of each track, bus, and 
output using the controls in its header. 

Â Timeline editing tools:  Select items using the Selection (arrow) tool, or split audio 
clips using the Split (razor) tool.

Â Automation Mode pop-up menu:  Choose the mode for recording automation using 
either the onscreen controls or an external control surface.

Â Project controls:  Set the project’s time signature, tempo, key, sample rate, time 
format, and other properties using these controls.

Â Show pop-up menu:  Choose whether the video track, audio tracks, busses, outputs, 
and master envelopes are visible in the Timeline.

Â Global Timeline view:  Shows a miniature view of the entire Timeline and the playhead 
position, and lets you move quickly to different parts of a project.

Â Time display:  Shows the current playhead position in both Time-based and Beats-
based formats. You can set the playhead by typing a new playhead position in the 
time display.

Scroll bar

Audio tracks

Project controls

Track area

Level meters
Timeline editing tools

Time display

Global Timeline 
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Time ruler
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Â Level meters:  As the project plays, the level meters show the volume level of the first 
output (Output 1).

Â Time ruler:  You can precisely position clips, the playhead, and other items to a specific 
point in time (minutes, seconds, frames) or to a musical beat using the Time ruler.

Â Track area:  Includes horizontal rows for tracks, busses, and outputs. Also includes the 
playhead, envelopes, and markers.

Â Headers:  Each track, bus, and output has a header with an icon, name, volume slider, 
and other controls. (For more information, see “Headers” on page 27.)

Â Timeline controls:  Includes controls to show the master envelopes, turn snap on or 
off, set the track height, and zoom in or out. (For more information, see “Timeline 
Controls” on page 28.)

Â Scroll bar:  Moves the Timeline horizontally so you can see different parts of the 
project.

Headers
Each track, bus, and output in the Timeline has a header that includes the track name, 
track icon, and a set of track controls.

Â Drag handle:  Click to select the track, bus, or output and drag to reorder it in the 
Timeline. 

Â Icon:  You can choose an icon for the track, bus, or output, making it easy to quickly 
distinguish them in a large project.

Â Name field:  You can type a new name for the track, bus, or output in the name field.
Â Record Enable button:  Enables (or disables) the track for recording when you click the 

Record button. Only tracks have Record Enable buttons, not busses or outputs.
Â Mute button:  Mutes (or unmutes) the track, bus, or output.
Â Solo button:  Solos (or unsolos) the track, bus, or output. Soundtrack Pro supports 

both multiple solo and exclusive solo.
Â Effects button:  Displays the Effects tab of the Media and Effects Manager with the 

track, bus, or output effects settings.
Â Envelopes disclosure triangle:  Shows the track, bus, or output envelopes in the area 

directly below the track.

Name field

Mute button

Effects button

Drag handle
Output pop-up menu

Solo button

Record Enable button
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Â Volume slider:  Sets the track, bus, or output relative volume in the overall mix.
Â Output pop-up menu:  Choose an output for the track or bus, or choose the physical 

output channels for the output from the menu. 
Â Pan slider:  Sets the pan position of the track or bus. Appears in track and bus 

headers only, not in output headers.

For detailed information on using the track controls, see “Using the Track Controls” on 
page 102.

Timeline Controls
The lower-left corner of the Timeline contains controls for various aspects of Timeline 
display and operation.

 

Â Master Envelopes button:  Shows or hides the master envelopes.
Â Snap button:  Turns snap on or off.
Â Snap To Value pop-up menu:  Sets the value to which items in the Timeline snap.
Â Track Height control:  Sets the height of tracks, busses, and outputs to one of four 

settings, from Reduced to Large.
Â Zoom control:  Click the control or drag the slider to change the zoom level. You can 

zoom in to edit clips precisely, or zoom out to display more of the Timeline.

For information about using master envelopes, see “Master Envelopes” on page 220. 
For information about snap, see “Using Snap” on page 72. For information about using 
the Track Height control and zoom control, see “Moving Around in the Timeline” on 
page 94.

Master Envelopes button
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Snap To Value pop-up menu
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Mixer
You mix your project in the Mixer. Each track, bus, and output has a channel strip in 
the Mixer with volume controls, mute and solo buttons, slots for adding effects, and 
other controls. You can view the levels for each track, bus, and output using level 
meters in its channel strip. You can also record audio and automate volume and pan 
changes in the Mixer.

Â Project pop-up menu:  Choose which project to work on from the pop-up menu.
Â Automation Mode pop-up menu:  Choose the automation mode from the pop-up 

menu.
Â Channel Strip and Mixer pop-up menus:  Show or hide different sections of the channel 

strips and of the Mixer window.
Â Channel strips:  Each track, bus, and output has a channel strip with controls and 

level meters.

Project pop-up menu

Channel strips

Automation Mode
pop-up menu

Channel Strip and Mixer
pop-up menus
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Each channel strip includes the following controls:

Â Drag handle:  Click to select the channel strip and drag to reorder it in the Mixer.
Â Icon:  Icons let you visually distinguish channel strips in the Mixer. Click an icon to 

change it.
Â Effects slots:  Show the effects and sends for the channel strip, and let you add effects 

and sends.
Â Output pop-up menu:  Choose an output for the track or bus channel strip or choose 

the physical output channels for the output channel strip from the menu.
Â Pan slider and value slider:  Set the channel strip’s pan position by dragging the slider 

or changing the value in the value slider. You can automate pan changes by dragging 
the slider with the project set to the appropriate automation mode. Appear in track 
and bus channel strips only, not in output channel strips.

Â Volume fader and value slider:  Set the channel strip’s volume level by dragging the 
fader or changing the value in the value slider. You can automate volume changes by 
dragging the slider with the project set to the appropriate automation mode.

Â Level meters with peak indicator:  Show the volume level of the channel strip in real 
time as the project plays. The peak indicator shows the highest level played, and 
changes color to indicate that clipping has occurred.
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Output pop-up menu
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Â Record Enable button:  Click to enable the track for recording. When you click a track’s 
Record Enable button, the Recording tab of the Utility window appears, showing the 
track’s current recording settings. Appears in track channel strips only, not in bus or 
output channel strips.

Â Mute button:  Click to mute (or unmute) the channel strip.
Â Solo button:  Click to solo (or unsolo) the channel strip.
Â Name field:  You can type a new name for the channel strip.

Waveform Editor
You can edit audio files in the Waveform Editor using actions. Actions give you a 
powerful and flexible way to edit audio files nondestructively using professional audio 
processing effects and other operations. You can turn individual actions on or off, 
reorder actions, flatten actions, and compare the project with and without actions. You 
can also analyze audio files in the Waveform Editor and fix common audio problems, 
including clicks and pops, hum, and phase problems.

Â Waveform editing tools:  Includes the Selection, Sample Edit, Audio Stretching, and 
Zoom tools that you can use to graphically edit audio files. 

Â Automation Mode pop-up menu:  Choose the automation mode from the pop-up menu.
Â Previous and Next Selection buttons:  Move back and forward through selections 

you’ve made in the waveform display.
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Â Waveform View and Spectrum View buttons:  Change the display between Waveform 
view and Spectrum view.

Â Time display:  Shows the current position of the playhead.
Â Global Waveform view:  Shows you a miniature view of the entire waveform and the 

playhead position, and lets you move quickly to different parts of an audio file.
Â Waveform display (and editing area):  Shows the waveform of the audio file (or its 

frequency spectrum, in Spectrum view). You can select parts of the audio file to 
apply different actions to.

Â Level meters:  Show the levels of the audio file as it plays.
Â Transport controls:  Control playback and the position of the playhead, and turn 

recording on or off. (For more information, see “Transport Controls” on page 25.)
Â Playhead:  Shows the part of the audio file currently playing.
Â Actions and Analysis buttons:  Shows either the Actions list and related controls, or the 

Analysis Type, Parameter, and Analysis Results lists and related controls.

When the Actions button is active, the following items are available:

Â Effects button:  Shows the Effects tab, where you can add realtime effects to the 
project.

Â Actions pop-up menu:  Choose menu items to flatten actions, delete actions, and 
perform other operations.

Â Actions list:  Shows the actions you apply to the project.
Â Action Insert bar:   Shows where new actions will be added in the Actions list, and 

which actions are heard when you play the project.
Â Actions list:  You can add, select, and reorder actions in the list.

When the Analysis button is selected, the following items replace the Actions list:
Â Analysis Type list:  Lists the types of analysis you can select.
Â Parameters list:  Some analysis types (Click/Pop and Silence) have parameters you can 

adjust before analyzing the file. The parameters appear in this list.
Â Analyze button:  Click to analyze the file for the problems selected in the Analysis 

Type list.
Â Analysis Results list:  Lists items found by analyzing the file.

Action Insert bar

Actions

Actions/Analysis buttons Actions menu

Effects button
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Â Clear Fixed button:  Removes fixed items from the Analysis Results list.
Â Magnify button:  Zooms in on the selected item in the Analysis Results list for as long 

as you hold down the button.
Â Fix All button:  Fixes all items in the Analysis Results list.
Â Fix button:  Fixes the selected items in the Analysis Results list.

Media and Effects Manager
The Media and Effects Manager is where you locate and preview media (audio and video) 
to add to your project. It has five tabs:  The Browser, Favorites, and Search tabs give you 
three different ways to find media files; the Bin gives you quick access to media files for 
the current project; and the Effects tab is where you add and adjust effects.

Parameter list

Analysis Results list

Analyze button

Magnify
button

Fix All button

Fix buttonClear Fixed button
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Browser Tab
The Browser tab displays the disks connected to your computer in a view similar to 
the Finder’s list view. You can also preview files in the Browser tab, and drag them to 
the Timeline.

Â Back and Forward buttons:  Move through previously viewed levels of the folder 
hierarchy.

Â Computer button:  Displays your computer’s hard disk and other storage media 
connected to your computer.

Â Home button:  Displays the contents of your home directory.
Â Path pop-up menu:  Displays the levels of the file path to the current location, letting 

you move back to a previous level.
Â File list:  Displays the files and folders at the current location.
Â Preview controls:  Include Play and Mute buttons and a volume slider. For information 

on using the Preview controls, see “Using the Preview Controls” on page 69.
Â Media pop-up menu:  Choose menu items to add a Favorite, add a file to the Bin, 

open a file in the Waveform Editor, and perform other functions.

Preview controls

Path pop-up menu
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Favorites Tab
You can store frequently used items in Favorites, so that you can easily access them 
directly. You can also preview files in Favorites, and drag them to the Timeline.

Â Back and Forward buttons:  Move through previously viewed levels of the folder 
hierarchy.

Â Path pop-up menu:  Displays the levels of the file path to the current location, letting 
you move back to a previous level.

Â Favorites list:  Displays the files and folders at the current location.
Â Preview controls:  Include Play and Mute buttons and a volume slider. For information 

on using the Preview controls, see “Using the Preview Controls” on page 69.
Â Media pop-up menu:  Choose menu items to remove a Favorite, add a file to the Bin, 

open a file in the Waveform Editor, and perform other functions.

Favorites list

Preview controls Media pop-up menu
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Search Tab
The Search tab lets you locate audio files using a variety of criteria. You can perform 
text searches, and search for Apple Loops and other tagged file formats using 
keywords for instrument, genre, mood descriptors, and other categories. Matching files 
are displayed in the Search Results list. Once you locate the files you want to use, you 
can preview them in the Search Results list or drag them to the Timeline.

The Search tab has two views, Column view and Button view. Column view features a 
Keywords list containing keywords, and a Matches list with subcategories you can use 
to refine your searches. Button view displays a matrix of keyword buttons you can click 
to see matching files.
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Â Button and Column view buttons:   Change the view to either Button or Column view.
Â Category pop-up menu:  Restricts the available keywords to a particular category.
Â Setup button:  Displays the Search Setup dialog, from which you add items to the 

Search database.
Â Time Signature pop-up menu:  Restricts search results to files with the selected time 

signature.
Â File Type pop-up menu:  Choose whether to display all files, or only looping or non-

looping files.
Â Scale Type pop-up menu:  Restricts search results to audio files using the selected 

scale.
Â Keyword buttons (Button view only):  Displays files matching the keyword in the 

Results list.
Â Keywords list (Column view only):  Displays files matching the keyword in the Results 

list, and displays subcategories in the Matches list.
Â Matches list (Column view only):  Displays subcategories of the selected keywords.
Â Search Text field:  Type text in the field to display matching files whose filename or 

path contains the search text.
Â Nearby Keys button:  Restricts search results to keys within two semitones above or 

below the project key.
Â Search Results list:  Displays the files matching the selected search criteria, in 

alphabetical order. Includes columns displaying the tempo, key, and number of beats 
of each file. You can click files to preview them.

Â Add Favorite button:  Adds the selected item to Favorites.
Â Preview controls:  Include Play and Mute buttons and a volume slider. For information 

on using the Preview controls, see “Using the Preview Controls” on page 69.
Â Media pop-up menu:  Choose menu items to add a Favorite, add a file to the Bin, 

open a file in the Waveform Editor, and perform other functions.
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Bin Tab
The Bin tab lists the media files added to the project. You can drag files from the Bin 
tab to the Timeline. You can also add files to the Bin for easy access in a project. Files 
not currently added to the project appear dimmed, and offline files appear in red text.

Â File list:  Displays the media files in the current project.
Â Preview controls:  Include Play and Mute buttons and a volume slider. For information 

on using the Preview controls, see “Using the Preview Controls” on page 69.
Â Media pop-up menu:  Choose menu items to add a Favorite, add a file to the Bin, 

open a file in the Waveform Editor, and perform other functions.

File list

Preview controls Media pop-up menu
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Effects Tab
You add effects and sends to your project and adjust effect parameters in the Effects 
tab. When you click the Effects button on a track, bus, output, or audio file project, the 
Effects tab appears showing the item’s current effects settings and sends.

Â Category list:  Lists the categories of available effects, which are categorized by 
manufacturer. Click a category to see the effects for that category in the Effect list.

Â Effect list:  Lists the effects in the selected category. Double-click an effect to add it to 
the track, bus, or output.

Â Show pop-up menu:  Choose an item (a track, bus, or output) from the Show pop-up 
menu to display its effects settings.

Â Add Effect (+) button:  Adds the selected effect to the current effects chain.
Â Remove Effect (–) button:  Removes the selected effect from the current effects chain.
Â Effect Parameters area:  Displays the parameters for effects in the current effects 

chain. Click an effect’s disclosure triangle to see its parameters. You can adjust effect 
parameters using the controls in the Effect Parameters area.

Â Add Send button:  Adds a send to the end of the current effects chain for the track. 
You can add sends only to tracks, not to busses or outputs.

Â Reset Effect button:  Resets the selected parameter or group of parameters to its 
default value (or values).

Effect parameters area
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Effect list
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Utility Window
The Utility window features tabs for viewing a video in a project, observing project 
levels, viewing details, and setting up recording.

Video Tab
The Video tab is where you add a video to a project, view the video, and control 
video playback. 

Â Video Playback value slider:  Move the video to a specific frame by dragging, clicking 
the left or right arrow, or double-clicking and typing a value in the value slider.

Â Video Scale pop-up menu:  Choose the scale of the video in the Video tab from the 
pop-up menu.

Â Video viewing area:  You add a video by dragging it into the viewing area, and watch 
it play in the viewing area.

Â Video transport controls:  You control playback of the video with the project using the 
Play from Beginning, Previous Frame, Play/Pause, Next Frame, and Cycle buttons.

Video Playback

value slider

Video Scale pop-up menu

Video viewing area
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Recording Tab
The Recording tab is where you edit a track’s recording settings. When you click a 
track’s Record Enable button, the Recording tab appears, displaying the track’s current 
recording settings. 

Â Peak indicator:  Shows the highest level reached by the recording input signal. If the 
level rises above 0 dB, the peak indicator becomes red to indicate clipping.

Â Level meters:  Show the input volume for the selected track during recording.
Â Input pop-up menu:  Choose the input device and input channel (or channels) for 

recording.
Â Gain slider and field:  Drag the slider or type a number in the field to set the input 

gain for recording.
Â Stereo checkbox:  Select to record to a stereo file, or deselect to record to a mono file.
Â Monitor pop-up menu:  Choose the output device and output channel (or channels) 

for monitoring during recording.
Â Mute Project checkbox:  Select to mute the project during recording, so you hear only 

the sound being recorded.
Â Disk space indicator:  Shows the available disk space on the recording sessions 

location set in Recording Preferences.
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Meters Tab
The Meters tab displays stereo level meters that you can use to observe the volume of 
the first output in a multitrack project or the overall output for an audio file project. 

Â Peak indicator:  Shows the highest level reached as the project plays. If the level rises 
above 0 dB, the peak indicator becomes red to indicate clipping.

Â Level meters:  Show the output volume of the overall project as the project plays.
Â Peak Value and Location display:  For each channel, displays the highest (peak) value 

played, and its location.
Â Go to Peak buttons:  Move the playhead to the channel’s peak.
Â Reset button:  Resets the Peak Value and Location display and the peak indicator to 

their default values.
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Details Tab
The Details tab shows information about the currently selected media file, clip, marker, 
or envelope point, and gives you a way to edit clip, marker, and envelope point details. 
You can also view and edit details for a selection in the Waveform Editor.

Audio File Details
When you select an audio file, the Details tab displays information about the file, 
including the file icon, hints, tags for Apple Loops and other tagged audio files, sample 
rate, bit depth, file size, and whether the file is a looping or non-looping file.

Video File Details
When you select a video file, the Details tab displays information about the file, 
including the dimensions of the video, file size, length in seconds, frame rate, and other 
information. You can preview the video file in the Details window by clicking the Play 
button in the Media and Effects Manager preview controls.

Clip Details
Â Clip display:  Displays the waveform of the selected clip.
Â Playback buttons:  Set the clip playback mode to looping or non-looping.
Â Measure in pop-up menu:  Sets the units shown in the Position, Duration, and Offset 

value sliders.
Â Position value slider:  Set the position (start point) of the selected clip.
Â Duration value slider:  Set the duration (length) of the selected clip.
Â Offset value slider:  Set the offset of the selected clip.
Â Transpose pop-up menu:  Choose the number of semitones to transpose a looping 

clip from the pop-up menu. 
Â Clip Speed pop-up menu:  Choose the clip playback speed for a looping clip from the 

pop-up menu.

File Details Clip Details
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Marker Details
Â Type buttons:  Select whether the marker is a Beat marker or a Time marker.
Â Name field:  Type a name for the marker.
Â Position value slider:  Set the time position of the selected marker.
Â Measure in pop-up menu:  Choose the units for setting the marker position.

Envelope Point Details
Â Position value slider:  Set the time position of the selected envelope point.
Â Value value slider:  Set the value of the selected envelope point.
Â Measure in pop-up menu:  Sets the units shown in the Position value slider.
Â Copy from Previous Point button:  Set the value of the selected envelope point to the 

value of the preceding one in the envelope.
Â Copy from Next Point button:  Set the value of the selected envelope point to the 

value of the next one in the envelope.

Waveform Editor Selection Details
Â Measure in pop-up menu:  Sets the units shown in the Beginning, End, and Duration 

value sliders.
Â Beginning value slider:  Set the start position of the selection.
Â End value slider:  Set the end position of the selection.
Â Duration value slider:  Set the duration (length) of the selection.
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3 Getting Started 
With Soundtrack Pro

This chapter describes the two kinds of projects you 
can create in Soundtrack Pro, and describes how to 
work with windows, use layouts, play projects, and set 
Soundtrack Pro preferences.

Two Kinds of Projects
You can use Soundtrack Pro to create and work with two kinds of projects:  multitrack 
projects and audio file projects. The two project types have different project properties, 
and appear with different icons in the Finder. Multitrack projects and audio file projects 
appear as tabs in the Project window.

Multitrack Projects
Multitrack projects let you arrange audio clips in tracks in the Timeline and synchronize 
them to a video clip. You add clips to the Timeline from the Media and Effects Manager 
or from the Finder, and can also record audio directly into tracks. Each track has 
controls you can use to adjust volume and pan, mute or solo the track, add effects, 
and adjust effect parameters. The Timeline also includes busses and outputs with 
similar controls. You can automate volume, pan, and other controls using envelopes in 
the Timeline. 

You mix a multitrack project in the Mixer, which features a channel strip for each track, 
bus, and output in the Timeline. You can adjust volume and pan, mute and solo 
channel strips, record audio, and record automation in the Mixer. As you work on a 
multitrack project, you can view it in both the Timeline and the Mixer and switch 
between the two. 
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You can export a project mix to an audio file, which you can import into Final Cut Pro 
or another application. You can also export selected tracks, busses, and outputs, or 
export a project using the Compressor application.

For information about creating, saving, and working with multitrack projects, see 
Chapter 4, “Working With Multitrack Projects,” on page 81. For information about 
working in the Timeline, see Chapter 5, “Working in the Timeline,” on page 93. For 
information about working in the Mixer, see Chapter 6, “Working in the Mixer,” on 
page 123.

Note:  For multitrack projects, the audio files used in a project are not stored as part of 
the project file. The project file only saves references (pointers) to their location on disk. 
This keeps the size of the project file relatively small, and lets you use an audio file in 
multiple projects.

Audio File Projects
Audio file projects let you edit individual audio files using the powerful actions feature in 
the Soundtrack Pro Waveform Editor. Actions let you process an audio file or a selection 
nondestructively using a set of professional audio effects, perform noise reduction, add 
ambient noise, and perform other tasks. You can turn individual actions on or off, 
reorder actions, and bounce realtime effects to an action. You can analyze audio files 
for common problems, including clicks and pops, hum, and clipped signals, and have 
Soundtrack Pro fix the analyzed problems automatically. You can also cut, copy, and 
paste audio in the Waveform Editor. You can save an audio file as an audio file project, 
which lets you change action settings when you reopen the project in Soundtrack Pro.

For information about creating, saving, and working with audio file projects in the 
Waveform Editor, see Chapter 7, “Working in the Waveform Editor,” on page 143.
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Setting Up Your Workspace

 

There are several ways you can set up the Soundtrack Pro workspace to suit your 
display size and workflow, whichever type of project you are creating. You can arrange 
windows, reorder and detach tabs in the Utility window and the Media and Effects 
Manager, and add and reorder buttons in the Toolbar. You can create layouts for 
different tasks and switch between them.

 

Basic Window Controls

 

You can move, resize, or minimize a project’s windows. Most windows feature tabs, 
which give you flexibility in arranging the visual elements of a project.

 

To move a window:
m

 

Drag the window by its title bar to a new location.

 

To resize a window, do one of the following:
m

 

Drag the Size control in the lower-right corner of the window until the window is the 
desired size.

m

 

Hold the pointer near the edge of a window until it becomes a Resize Window pointer, 
then drag the window edge left or right to resize adjacent windows together.

 

To minimize a window to the Dock:
m

 

Click the minimize button in the window’s title bar.

 

To close a window:
m

 

Click the window’s close button (or press Command-W with the window active).

 

Using Tabs

 

Soundtrack Pro uses tabbed windows so you can quickly access different project views 
and controls. You can switch between projects and between different controls in the 
Media and Effects Manager and the Utility window. Clicking the tab you want makes it 
active and brings it to the front. You can reorder the tabs in a window to easily access 
the tabs you use frequently.

 

To reorder tabs:
m

 

Drag a tab left or right in the window’s tab area.

You can also detach a tab from its docked position in the Utility window or the Media 
and Effects Manager, which creates a separate draggable, resizeable window for the 
tab. For example, you can drag the Bin tab to a new location so that you can easily 
move items from the Browser tab to the Bin tab.
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To detach a tab from the Utility window or the Media and Effects Manager:
m Drag the tab out of its docked position in the window to create a separate window for 

the tab.

To reattach a tab:
m Drag the tab back to its original location at the top of its originating window.

Using Project Layouts
Soundtrack Pro lets you save and recall preset window arrangements called layouts, so 
that you can optimize your workspace for different tasks and different display sizes. You 
can show, hide, and resize windows, then save each window arrangement as a layout. 

To save a project layout:
1 Arrange the application windows as you want them to appear.

2 Choose Window > Save Layout.

3 In the Save dialog, type a name for the layout, then click Save.

The layout is saved, and appears in the Layouts submenu.

To switch to a saved project layout:
m Choose Window > Layouts, then choose the layout you want to use from the submenu.

To delete a saved layout:
1 Choose Window > Manage Layouts.

2 In the Manage Layouts dialog, select the layout you want to delete.

3 Click the – (minus) button to delete the layout, then click Done.
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Customizing the Toolbar
The Toolbar at the top of the Project window contains buttons for frequently used 
commands. You can customize the Toolbar, adding buttons for the actions you use 
most often, and can return to the default set later. 

The default set of Toolbar buttons includes buttons for creating new projects, opening 
project windows and tabs, adding markers, and other common commands. You can 
customize the Toolbar with additional buttons for adding fade ins and fade outs, 
processing an audio file, playing the current project through a video output device, and 
other commands. You can also hide the Toolbar to maximize available screen space. 
You customize the Toolbar by dragging items from the Customize sheet to the Toolbar.

To show the Customize sheet, do one of the following:
m Choose View > Customize Toolbar.

m Control-click the Toolbar, then choose Customize Toolbar from the shortcut menu.

The Customize sheet appears, and spaces between buttons in the Toolbar are outlined 
in gray.

To add a button to the Toolbar:
m Drag a button from the Customize sheet to the Toolbar.

If you drag a button between two existing buttons, the buttons move to make room 
for the new button.

To move a button in the Toolbar:
m Command-drag the button to a new location on the Toolbar.

You can also rearrange the Toolbar using set-width spaces, flexible spaces, and 
separators.

To add space or a separator to the Toolbar:
m Drag a space, flexible space, or separator from the Customize sheet to the Toolbar.

To return the Toolbar to the default set of buttons:
m Drag the default button set, located at the bottom of the Customize sheet, to the Toolbar. 

You can also change the Toolbar so that it shows only icons or only text.
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To show only icons in the Toolbar, do one of the following:
m Control-click the Toolbar, then choose Icon Only from the shortcut menu.

m In the Customize sheet, choose Icon Only from the Show pop-up menu.

To show only text in the Toolbar, do one of the following:
m Control-click the Toolbar, then choose Text Only from the shortcut menu.

m In the Customize sheet, choose Text Only from the Show pop-up menu.

To show both icons and text in the Toolbar, do one of the following:
m Control-click the Toolbar, then choose Icon & Text from the shortcut menu.

m In the Customize sheet, choose Icon & Text from the Show pop-up menu.

To dismiss the Customize sheet:
m When you are finishing customizing the Toolbar, click Done.

To hide the Toolbar:
m Choose View > Hide Toolbar. When the Toolbar is hidden, the menu item becomes 

Show Toolbar.

Playing Projects
You can play both multitrack and audio file projects as you work, so you can hear the 
audio in the project along with the changes you’ve made.

To play the project:
m Click the Play button in the transport controls (or press the Space bar). Click the Play 

button (or press the Space bar) again to stop playback.

As the project plays, the playhead shows the point in the project currently playing.

Soundtrack Pro lets you set the playhead and control playback of your projects in 
several different ways. You can use the transport controls or keyboard commands to 
start and stop playback and set the playhead to different points in time. You can also 
set a playback region to repeat playback of a specific part of the project.
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Setting the Playhead 
The playhead appears as a thin black line running vertically through the Timeline in 
multitrack projects, and through the waveform display in audio file projects. Where it 
crosses the Time ruler, the top of the playhead has a triangular handle that makes it 
easier to see its position onscreen and drag the playhead.

To set the playhead, do one of the following:
m Click anywhere in the Timeline (in a multitrack project) or the waveform display (in an 

audio file project) to set the playhead to that position. 

m Drag the triangular handle at the top of the playhead to the position you want to set it. 
As you drag the playhead, you hear the audio at the current playhead position.

When you set the playhead, it snaps to the nearest Snap To position if snap is turned on. 
For information on setting the Snap To value, see “Using Snap” on page 72. You can also 
set the playhead using the transport controls or using the Playhead Position value slider.

Drag the playhead where you
want it or click in the Timeline.

Drag the playhead where 
you want it or click in the 
waveform display.
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Setting the Playhead Using the Time Display
When a project is playing, the Time display constantly updates to show the current 
position of the playhead in both Time-based and Beats-based formats. You can also set 
the playhead to a new position by entering the position in the Time display. 

The arrangement of the Time-based and Beats-based positions in the Time display 
changes depending on the time format of the project. The position matching the time 
format of the project appears in large, white numerals in the upper part of the Time 
display, and the other position appears below it in smaller, gray numerals. Each position 
is labeled for quick visual recognition.

For information on setting the project time format, see “Setting Project Properties” on 
page 82.

To set the playhead using the Time display:
m Select either the Time or Beats position in the Time display, then enter a new position. 

You can select the entire position or part of the position.

Entering Time-Based Units
When you set the playhead by entering a Time-based position in the Time display, you 
don’t need to enter all of the punctuation. Soundtrack Pro automatically adds the 
correct punctuation for the format of the Time display. 

For example:
Â If you enter 01234321, and the Time ruler units are set to seconds, Soundtrack Pro 

interprets it as 01:23:43:21. This stands for 1 hour, 23 minutes, 43 seconds, and 21/100 
of a second.

If you enter a partial number, Soundtrack Pro formats it with the rightmost pair of 
numbers as fractions of a second (or frames if a timecode format is selected), and with 
each successive pair of numbers to the left as seconds, minutes, and hours. Numbers 
omitted from a complete time position are interpreted as zeros. For best results, always 
enter delimiters to separate each division of time.

Enter a time position 
in the Time area.

Enter a beat position 
in the Beats area.
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For example: 
Â If you enter 01.23, and the Time ruler units are set to seconds, Soundtrack Pro 

interprets it as 00:00:01.23. This stands for 1 second and 23/100 of a second. 
Â If you enter 0.12.34, Soundtrack Pro interprets it as 00:00:12.34. This stands for 12 

seconds and 34/100 of a second.

You can select only part of the position in the Time display and enter a new number for 
that position. For example, you can select only seconds, or minutes and seconds. The 
other categories keep their present values. You can enter a time position in timecode 
format, in a way similar to the way you enter timecode in Final Cut Pro.

Entering Beats-Based Units
When you set the playhead by entering a Beats-based position in the Time display, you 
enter periods between numbers to separate measures, beats, and beat divisions. 
Soundtrack Pro fills out the digits in the beat division category with zeros.

For example: 
Â If you enter 123, Soundtrack Pro interprets it as 123.1.000. This stands for the 123rd 

measure, 1st beat, with no added beat divisions. 
Â If you enter 12.3, Soundtrack Pro interprets it as 12.3.000. This stands for the 12th 

measure, the 3rd beat, with no added beat divisions.
Â If you enter 1.2.3, Soundtrack Pro interprets it as 1.2.300. This stands for the 1st 

measure, the 2nd beat, and 300/1000ths of a beat (because each beat division is 1/
1000 of a beat). 

You can select only part of the position in the Time display and enter a new number for 
that position. For example, you can select only measures, or measures and beats. The 
other categories keep their present values.

Setting the Playhead Using the Playhead Position Value Slider
Below and to the left of the transport controls is the Playhead Position value slider. 
When a project is playing, the Playhead Position value slider constantly updates to 
show the current position of the playhead. You can set the playhead by entering a new 
position in the Playhead Position value slider. 

The units shown in the Playhead Position value slider depend on the project time 
format. For projects set to Time-based time format, the units appear as timecode, using 
the currently selected Time ruler units. For projects set to Beats-based format, the units 
appear as measures, beats, and beat divisions at the current tempo.

You can change the value in a value slider in one of several ways:  you can enter a new 
value, by changing the value incrementally using the Decrement and Increment arrows, 
or by dragging the slider left or right.



54 Chapter 3    Getting Started With Soundtrack Pro

 

To change the playhead position by entering a value:
1 Double-click the value slider.

The value slider becomes a value field, with the current value selected.

2 Type a new value into the field, using appropriate punctuation.

3 Press Tab or Enter to confirm the new value.

 

To change the playhead position in increments:
m Click the Decrement arrow to move the playhead left (earlier in time) in increments, or 

click the Increment arrow to move the playhead right (later in time) in increments. 

To change the playhead position by dragging:
m Click in the center area of the value slider (where the numbers are), then drag left to 

move the playhead left (earlier in time) or drag right to move it right (later in time). 

For projects set to Time-based time format, the Decrement and Increment arrows move 
the playhead in seconds. For projects using Beats-based time format, the arrows move 
the playhead in beats.

Scrubbing a Project
You can scrub a multitrack project in the Timeline or scrub an audio file project in the 
Waveform Editor. Scrubbing the project lets you hear the audio at the playhead position 
as you drag the playhead, so you can find a particular sound or event in the audio file.

To scrub a project:
m In the Timeline or the Waveform Editor, drag the playhead left or right at the speed you 

want to scrub the audio file.

You can also scrub a selection in the Waveform Editor, which is useful for determining 
where you want the selection to end.

To scrub a selection in the Waveform Editor:
m Hold down the Control key as you select part of an audio file.

As you drag, you hear the selection.
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Controlling Playback With the Transport Controls 
You use the transport controls to control playback of your project. The transport 
controls let you set the playhead to various points in time, start and stop playback, 
activate the playback region, and start a recording session to record your own audio. 

Â Record:  Starts recording at the playhead position on the track you have enabled for 
recording. If no track is enabled, a new track is created when recording starts.

Â Play from Beginning:  Starts playback from the beginning of the project. Playback 
begins immediately, whether the project is playing or is stopped when you click the 
button.

Â Go to Beginning:  Sets the playhead to the beginning of the project. If the playback 
region is active, and the playhead is after the beginning of the playback region in 
time, the playhead is set to the beginning of the playback region.

Â Play:  Starts playing back the project from the current playhead position. Clicking the 
Play button again stops playback at the current playhead position.

Â Go to End:  Sets the playhead to the end of the project. If the playback region is 
active, and the playhead is before the end of the playback region in time, the 
playhead is set to the end of the playback region.

Â Cycle:  If a playback region is set, clicking the Cycle button toggles whether the 
playback region is active or inactive. If no playback region is set, clicking the Cycle 
button sets the project to repeat from the beginning when the playhead reaches the 
end of the project. For information on setting the playback region, see “Working With 
the Playback Region” on page 98.

Â MIDI Sync:  Synchronizes playback with incoming MIDI Clock and MIDI Timecode 
(MTC) signals.

MIDI SyncGo to
Beginning

Play

Go to EndRecord

CyclePlay from Beginning
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Controlling Playback Using Keyboard Shortcuts
There are a number of keyboard shortcuts you can use to control playback of your 
project. To use keyboard shortcuts, the pointer cannot be in a text field.
Â Space bar:  Plays back the project from the current playhead position. If the project is 

playing, pressing the Space bar sets the playhead back to the point from which the 
project started playing. This is equivalent to clicking the Play button.

Â Return:  Sets the playhead to the beginning of the project. If the playback region is 
active, pressing Return sets the playhead to the beginning of the playback region. 
This is equivalent to clicking the Go to Beginning button.

Â Shift-Return:  Sets the playhead to the beginning of the project, and starts playback if 
it is stopped. This is equivalent to clicking the Start from Beginning button.

For a complete list of Soundtrack Pro keyboard shortcuts, see Appendix B, 
“Soundtrack Pro Keyboard Shortcuts,” on page 279.

Locating and Adding Audio Files
You can locate media files to use in a project using the Media and Effects Manager, or 
drag files from the Finder. The Media and Effects Manager gives you three ways to 
locate audio files:  the Browser, Favorites, and Search tabs. You can also store media files 
for a project in the Bin for easy access in a project.

Supported Audio File Formats
You can add AIFF, WAV, MP3, and AAC (except protected AAC) files to a project. You can 
also add QuickTime (.mov) audio files. You can import audio files with any combination 
of the following sample rates and bit depths: 

Sample Rates
Â Any sample rate from 8 kHz to 192 kHz

Bit Depths
Â 8 bit
Â 16 bit
Â 24 bit
Â 32 bit (both integer and floating point)

Note:  Files with lower bit depths or sample rates do not have the same playback 
quality as do higher-rate formats.
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Looping and Non-Looping Files
Soundtrack Pro supports two types of audio files:  looping and non-looping files. Most 
audio files are non-looping files unless they contain tags for tempo, key, and other 
information.

Many of the Apple Loops that come with Soundtrack Pro, as well as other tagged audio 
files, can be looping files. Looping files may contain music, rhythmic sounds, or other 
repeating patterns. You can resize a looping file to fill any amount of time. Looping files 
adjust to the project tempo and key, letting you use loops recorded in different keys 
and at different tempos in the same project.

Non-looping files do not adjust to the project tempo and key. You can shorten or 
lengthen a non-looping file, but lengthening it beyond the size of the original file adds 
only silence to the lengthened part. You can search for non-looping files in the Search 
tab using the Search text field.

Both looping and non-looping files can contain tags with information about the file, 
including mood, genre, and musical instrument. Soundtrack Pro recognizes tags in 
audio files intended for use with loop-based music applications. You can open an audio 
file in Apple Loops Utility and add tags, and can convert a looping file to a non-looping 
file, or convert a non-looping file to a looping file. For information about tagging audio 
files using Apple Loops Utility, see Appendix A, “Using Apple Loops Utility,” on 
page 263.
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Using the Browser to Locate Files
The Browser tab shows the hard disks and other storage media connected to your 
computer, and lets you browse through the file hierarchy to find audio files located 
on disk.

To locate audio files using the Browser:
m Double-click a volume or folder in the Browser to view its contents. 

m You can move back through the previous locations in the Browser using the Forward and 
Back buttons, or through the levels of the file hierarchy using the Path pop-up menu.
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Using Favorites to Locate Files
Favorites let you store frequently used file locations, so that you can access them 
directly. You can add and remove Favorites from the Media pop-up menu at the lower-
right corner of the Media and Effects Manager.

To locate audio files in Favorites:
m Double-click the disk or folder you want to open. 

You can move back through the previous locations in the Favorites tab using the 
Forward and Back buttons, or through the levels of the file hierarchy using the Path 
pop-up menu.

Double-click an
item to open it.
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Using Search to Locate Files
Using Search, you can search for media files to add to your project. Search has two 
views:  Column view and Button view. You choose which view to display by clicking the 
Columns View or Button View button in the upper-left area of the window. In both 
views, the files matching your search criteria appear in the Search Results area, along 
with columns displaying additional information for tagged files. You can sort these 
columns by clicking the heading on top of each column. You can also perform text 
searches in both views, and refine your searches.

If you use Apple Loops or other tagged audio files in a project, you can search based 
on a variety of criteria, including musical instrument, genre, time signature, mood 
descriptor, and scale type. You can also search using specific keywords.

Click Search to display the Search tab in the Media and Effects Manager. 

Searching for Files in Column View
In Column view, the upper area of the Media and Effects Manager displays two 
columns:  Keywords shows the categories of files that meet the search criteria, and 
Matches shows the total number of matching files and any subcategories containing 
matching files, with the number of matching files in each. 

Clicking a keyword displays the files matching that keyword in the Search Results area. 
You can refine your search results by narrowing the criteria using the subcategories in 
the Matches column.
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To search for files in Column view:
1 Choose the type of keywords to display in the Keywords list from the Keywords pop-

up menu. 

You can use the Time Signature and Scale Type pop-up menus to restrict matches by 
those categories.

2 Select a keyword in the Keywords list to display matching files in the Search Results area. 

The hints, tempo, key, and number of beats for each matching file are also displayed.

You can also perform text searches, which can be especially helpful for non-tagged 
files. When you type text in the Search Text field, any files with the text in their file path 
or filename appear in the Search Results list. The number of files appears in the 
Matches column under “No Category.”

To search using the Search Text field:
m Enter text in the Search Text field.

As you type, files matching the characters you type appear in the Search Results field.

Select a keyword
to display the

matching files in the
Search Results area.
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Refining a Search in Column View
There are several ways you can refine your searches in Column view. You can select 
items in the Matches column to add the matching files for each category to the search 
results, and you can enter text in the Search Text field to narrow your search to files 
that include the text in their file path. Selecting multiple keywords in the Keywords list 
narrows the search results to files matching all the selected keywords.

To refine your search using the Matches column:
m Click to select a match category, or Command-click to select multiple match categories.

To refine your search by selecting multiple keywords:
m Shift-click to select adjacent keywords, or Command-click to select nonadjacent keywords.

Click a match category
to refine your search.

These are files that
match the category
selected above.
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Searching for Files in Button View
In Button view, the upper area of the Media and Effects Manager displays a grid of 
buttons, each of which is labeled with a keyword. The keywords displayed are 
determined by the Keywords pop-up menu; the choices are Best Mix, Instruments, 
Genre, Descriptors, and Custom. The keywords for each choice are fixed, and appear 
whether or not matching files for the keyword exist. Keywords for which no matching 
files exist are dimmed.

To search for files in Button view:
1 Choose the type of keywords to display on the keyword buttons from the Keywords 

pop-up menu. 

2 You can optionally use the File Type, Time Signature, and Scale Type pop-up menus to 
restrict matches by those categories.

3 Click a keyword button to display matching files in the Search Results area.

You can also perform text searches, which can be especially helpful for non-tagged 
files. When you type text in the Search Text field, any files with the text in their file path 
or filename appear in the Search Results list.

To search by file path or filename:
m Enter text in the Search Text field.

As you type, files matching the characters you type appear in the Search Results field.

Click a button to display
the matching files in the
Search Results area.
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Refining a Search in Button View
There are several ways you can refine your searches in Button view. You can select 
multiple keyword buttons to narrow your search results to files matching all the 
selected keywords, and you can enter text in the Search Text field to narrow your 
search to files that include the text in their file path.

To refine your search using multiple keywords:
m Command-click multiple keyword buttons. 

These are files that match 
both of the keywords 
selected above.

Select additional keywords 
to refine your search.
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Adding Custom Keywords
You can add custom keywords, which appear in the Keywords list in Column view and 
on the keyword buttons in Button view. Custom keywords can be added only in 
Button view.

To add a custom keyword:
1 Choose Custom from the Keyword Type pop-up menu. 

2 Control-click one of the buttons in the grid, then choose a custom keyword from the 
shortcut menu. 

Adding a Directory to the Search Database
Search looks through all indexed directories (volumes and folders) for files that match 
your search criteria. Before a file can appear in Search, you must add the directory 
containing the file to the Search database and index the directory.

Note:  The Search database does not update automatically. If you add files to an 
indexed directory, you must index the directory again before the files will appear in the 
Media and Effects Manager.

Choose Custom from
this pop-up menu.

Control-click a button, then
choose the desired keyword
from the submenu.
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To add a directory to the Search database:
1 Click the Setup button at the top of the Search tab.

2 In the Setup dialog, click the Add Directory button.

3 In the file dialog, navigate to the directory you want to add, then click Open. 

The directory appears in the list in the Setup dialog. You can resize the Search dialog if 
you need to see more items in the list.

4 Select the directory in the list, then click the Index Now button.

Note:  Indexing a large collection of files may take several minutes. The bottom of the 
Add Directory dialog displays the progress of the directory being indexed. If you need 
to interrupt the indexing process, click the Stop Indexing button. You can re-index the 
directory later. You can deselect items you do not wish to re-index.

5 When Soundtrack Pro is finished indexing the directory, click Done to return to the 
Media and Effects Manager.

Click here to display 
the Setup dialog.

Click the Add Directory
button, then select a

directory to add.

Click here to index
the directory.



Chapter 3    Getting Started With Soundtrack Pro 67

 

Removing a Directory From the Search Database
If you move or change your collection of audio files, you can remove a folder from the 
Search database. Removing unneeded folders from the database can shorten search 
times and eliminate extraneous results.

To remove a folder from the Search database:
1 Click the Setup button at the top of the Search tab.

2 In the Setup dialog, select the directory you want to remove, then click the Remove 
Directory button.

3 Click Done to return to the Media and Effects Manager.

Once you have added the folders containing your audio files to the Search database 
and indexed them, you can use Search to find the files. In both Column view and 
Button view, the audio files that match the search criteria appear in the Search Results 
area in alphabetical order. You can preview files in the File list and drag them to the 
Timeline. You can also add a folder to your Favorites from the Search tab.

Storing Files in the Bin
The Bin shows all of the clips added to the project. You can add audio files to the Bin 
for easy access to files you may want to add to the current project. Audio files appear in 
the Bin in alphabetical order.

To add a file to the Bin, do one of the following:
m Drag the file from the Finder to the Bin.

m Drag the file from the Browser, Favorites, or Search tab to the Bin.

Files added to the Bin but not included in the project appear dimmed in the Bin.

Click the Remove
Directory button to

remove the selected
directory.



68 Chapter 3    Getting Started With Soundtrack Pro

 

Previewing Audio Files
Once you locate an audio file you want to use in your project, you can preview the file 
in the Media and Effects Manager. When you preview files, Soundtrack Pro matches the 
sample rate of the file to the project sample rate. When you preview looping files, 
Soundtrack Pro matches their tempo and key to the project tempo and key. 

To preview an audio file:
m Select the file in the Media and Effects Manager.

The selected file starts playing. If the project is playing when you preview a file, 
Soundtrack Pro starts playback of the previewed file on the downbeat of the next 
measure of the project. You can turn preview playback on and off by holding down 
Option and pressing the Space bar.

Audio files tagged as loops play back repeatedly when previewed. You can control the 
playback of the file being previewed using the preview controls. You can only preview 
one audio file at a time.

You can also preview video files. When you double-click a video file in the Media and 
Effects Manager, the video appears in a small window in the Details tab. 

To preview a video file:
1 Click the Details tab in the Utility window to make the tab active.

2 Select the video file in the Media and Effects Manager.

3 Click the Play button in the Preview controls at the bottom of the Media and Effects 
Manager. To stop playback, click the Play button again.

For more information on working with video files, see Chapter 8, “Working With Video 
in Soundtrack Pro,” on page 183.

Select an audio file in the Media 
and Effects Manager to preview it.
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Using the Preview Controls
The preview area at the bottom of the Media and Effects Manager contains controls 
you can use when previewing audio files.

Â Play button:  Starts playback of the preview file. If the file is playing, stops playback.
Â Mute button:  Mutes playback of the preview file without stopping project playback. 

Clicking the button again unmutes the preview file.
Â Volume slider:  Sets the playback volume of the preview file.
Â Media pop-up menu:  Choose whether to add the file to Favorites, open it in the 

Waveform Editor or Apple Loops Utility, or reveal it in the Finder.

To preview an audio file with a project:
1 Click the Play button in the transport controls to play the project.

2 When the project reaches the point in time where you want to hear the preview file, 
select the file in the Media and Effects Manager. 

To preview a file without the project (solo):
1 If the project is playing, click the Stop button in the transport controls to stop playback 

of the project.

2 Select the file in the Media and Effects Manager to preview the file.

You can also preview a video file using the preview controls. For information about 
previewing a video file, see “Playing the Video” on page 185.

Play button

Volume 
slider

Media pop-up menu

Mute 
button
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Viewing Audio File Information
You can view information about an audio file in the Media and Effects Manager, the 
Timeline, or the Waveform Editor in the Details tab of the Utility window. 

When you select an audio file in the Media and Effects Manager, the Details tab 
displays the file path and other information about the file. The following information 
is displayed in the File tab of the Details tab:

Â Name:  The name of the file
Â Hints:  The hints provided for the file. Hints are file tags that are used to search for 

files or for tempo and key matching.
Â Instrument:  The instrument or instrument category to which the file belongs
Â Author:  The author of the file
Â Copyright:  The copyright information for the file
Â Path:  The path to the file’s location on disk
Â Tempo:  The original tempo of the file
Â Time Signature:  The time signature of the file
Â Beats:  The number of beats recorded in the file. For non-looping files, this field 

shows the duration (length) of the file in seconds.
Â Key:  The original key of the file
Â Sample Rate:  The sample rate at which the file was recorded
Â Bit Depth:  The bit depth at which the file was recorded
Â Channels:  The number of audio channels the file contains
Â Size:  The file size in kilobytes
Â Genre:  The musical category to which the file belongs
Â Length:  The duration of the file in seconds
Â Looping file:  Indicates whether the file is a looping file (Yes) or a non-looping 

file (No).
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Note:  The information that is displayed depends on whether or not the file is tagged. 
Untagged files may not display information for all categories. For more information on 
file tags, see Appendix A, “Using Apple Loops Utility,” on page 263.

You can also view and edit audio clip properties in the Details tab. For information 
about viewing and editing clip properties, see “Viewing and Editing Clip Properties” on 
page 89.

Using Undo and Redo 
As you edit clips and perform other operations in both multitrack and audio file 
projects, you might need to use the Undo and Redo commands. For example, if you 
don’t like the last change you’ve made to a project, it can usually be undone. Then, if 
you decide you prefer to keep the change you just undid, you can redo the command 
immediately after using Undo.

You can also use the Undo and Redo commands as a quick way of trying out changes 
to your project. You can make changes to any aspect of the project, then use Undo to 
step back through changes you don’t like to the project’s previous state. If you change 
your mind after undoing a change or set of changes, you can always use Redo to 
recover the changes. At any point, you can save a new version of the project using the 
File > Save As command.

You can use the Undo command repeatedly to undo every change made since the 
project was last saved.

To undo the last change:
m Choose Edit > Undo [item] (or press Command-Z).

The [item] in the menu changes to show the last command or operation.

You can use the Redo command repeatedly to redo every undone change since the 
project was last saved.

To redo the last change:
m Choose Edit > Redo [item] (or press Command-Shift-Z).

The [item] in the menu changes to show the last command or operation.
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Using Snap 
When you move and resize clips in the Timeline, or select part of an audio file in the 
Waveform Editor, you usually want them to start and end at a specific point in time. To 
synchronize clips with a video, you may want to position them in line with a specific 
frame. In a music-based project, you may want to align clips with measures and beats. 
Soundtrack Pro includes a snap feature that causes clips, the playhead, and other items 
in the Timeline and Waveform Editor to “snap” to the nearest Snap To position. 

Snap applies to the following operations:
Â Dragging audio clips to the Timeline
Â Moving audio clips
Â Resizing audio clips
Â Setting the playhead
Â Setting the playback region
Â Inserting markers
Â Moving markers
Â Selecting Timeslices
Â Adding envelope points
Â Moving envelope points
Â Moving crossfade edges

You can use snap to ensure that audio clips are synchronized to a measure or beat, that 
they begin playing back at a precise point in time, and that they are precisely aligned 
with other clips in the Timeline.

When you turn on snap, the item you are moving snaps to the nearest Snap To position 
in the Timeline. The available Snap To values depend on the time format of the project. 
For projects set to Time-based format, the available Snap To values are:
Â Ruler ticks
Â Seconds
Â Frames
Â Clips on Adjacent Tracks
Â Markers
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For projects set to Beats-based format, the available Snap To values are: 
Â Ruler ticks
Â 1/4 notes
Â 1/8 notes
Â 1/16 notes
Â 1/32 notes
Â 1/64 notes
Â Markers
Â Clips on Adjacent Tracks

To turn snap on:
m Choose View > Snap (or press G). 

A checkmark next to the menu item indicates that snap is turned on. Choose View > 
Snap again to turn snap off.

To set the Snap To value:
m Choose View > Snap To, then choose a value from the submenu. 

You can temporarily defeat snap while you work in the Timeline. When you defeat snap, 
you reverse the current snap state. 

To defeat snap:
m Select the item in the Timeline, then hold down the Command key as you drag the item. 

If snap is turned on, Command-dragging lets you move the item without having it 
snap to the nearest Snap To position. If snap is turned off, the item snaps to the nearest 
Snap To position. When you release the Command key, items moved in the Timeline 
follow the normal snap state. 
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Reconnecting Media Files
Because Soundtrack Pro multitrack projects contain references to media files, and not 
the files themselves, a multitrack project cannot play back if the media files it uses are 
erased or moved. When you open a multitrack project in Soundtrack Pro, the 
application checks to see if the media files it uses exist in the same location as they did 
when the project was last opened. If the media files are not in the expected location, 
Soundtrack Pro displays a Can’t Find File dialog, with three choices.
Â Skip File:  Opens the project without reconnecting the missing file.
Â Cancel:  Cancels the Open command.
Â Find File:  Presents a dialog that lets you locate the missing file and reconnect it to 

the project.
If you choose to open the project without reconnecting its files, you can reconnect 
individual audio files from the Bin tab, and reconnect a video file in the video track in 
the Timeline. 

To reconnect an audio file:
1 Do one of the following:

Â Control-click the audio file in the Bin tab, then choose “Reconnect [filename]” from 
the shortcut menu.

Â Select the clip in the Bin tab, then choose “Reconnect [filename]” from the Media 
pop-up menu.

Â Select the clip in the Timeline, then choose Clip > Reconnect.
Â Control-click the clip in the Timeline, then choose Reconnect from the shortcut 

menu.

2 In the dialog that appears, locate the audio file you want to reconnect.

3 Click Open to reconnect the file.

To reconnect a video file:
1 Control-click the video clip in the video track, then choose “Reconnect offline source” 

from the shortcut menu.

2 In the dialog that appears, locate the video file.

3 Click Open to reconnect the file.
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Setting Soundtrack Pro Preferences
You set preferences for various aspects of Soundtrack Pro that affect both the 
appearance and operation of the application in the Preferences window. Some 
preferences apply to the current project, and some apply to new projects you create. 
You may want to specify some preferences before you begin working in Soundtrack Pro. 

To open the Preferences window:
m Choose File > Preferences. 

General Preferences
The General preferences include program startup behavior, Media and Effects Manager 
options, and Timeline defaults for new multitrack projects.

Startup 
These preferences let you set the startup behavior when you open Soundtrack Pro.
Â Open Last Project button:  Reopens the last project on startup.
Â Open New Project button:  Creates a new, blank multitrack project on startup. This is 

the default behavior.

Timeline
These preferences let you set the default Snap To value, default track height, and other 
aspects of the Timeline.
Â Double-clicking Clip Opens New audio file project:  When selected, double-clicking a 

clip in the Timeline creates a new audio file project for the clip.
Â Double-clicking Clip Opens Existing audio file:  When selected, double-clicking a clip in 

the Timeline opens the audio file in the Waveform Editor.
Â Use ellipses(...) in clip names checkbox:  When selected, clips in the Timeline with long 

names are center-truncated with an ellipsis. “Use ellipses (...) in clip names” is 
deselected by default. 

Note:  Selecting “Use ellipses in clip names” can impact the speed at which the screen 
is redrawn during playback.
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Â Scrollwheel pop-up menu:  Choose whether an attached mouse with a scrollwheel 
scrolls the Timeline or zooms in or out at the playhead position. 

Â Automation Recording Sensitivity slider:  Drag to set the level of sensitivity with which 
onscreen and control surface movements are recorded. Setting the slider to High 
results in all movements being recorded.

Â Scratch Location button and display:  Click, then browse to the location of the disk or 
folder you want to use as the location for storing scratch files. The current location is 
shown in the Scratch Location display.

Project Preferences
These preferences let you set project properties and other default settings for new 
projects you create.

Â Tempo value slider:  Sets the default tempo for new projects in beats per minute 
(bpm). The range is 60 to 200 bpm. 

Â Key pop-up menu:  Sets the default key for new projects. The range is any key in the 
chromatic scale from A to G#, or None.

Â Time Signature pop-up menu:  Sets the default time signature for new projects. The 
choices are 3/4, 4/4, 5/4, 6/8, and 7/8.

Â Sample Rate pop-up menu:  Sets the default sample rate for new projects. The choices 
are 32 kHz, 44.1 kHz (CD-quality audio), 48 kHz (DVD-quality audio), and 96 kHz. 

Â Export Bit Depth pop-up menu:  Sets the export bit depth for the current project and 
new projects. The choices are 16-bit (CD-quality audio) and 24-bit.

Â Timescale pop-up menu:  Choose whether the overall project uses Time-based or 
Beats-based time format. 

Â Video Frames per Second pop-up menu:  Choose which video frame rate to use for 
new projects.

Â Tracks slider:  Sets the default number of tracks for new multitrack projects.
Â Snap buttons:  Turn snap on or off for new multitrack projects.
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Â Snap To pop-up menu:  Sets the default Snap To value for new multitrack projects. The 
choices are Ruler Ticks, Quarter notes, 8th notes, 16th notes, 32nd notes, 64th notes, 
and Clips on Adjacent Tracks.

Â Track Height pop-up menu:  Sets the default track height for new multitrack projects. 
The choices are Reduced, Small, Medium, and Large.

Â Overlap Mode pop-up menu:  Sets whether overlapped clips are crossfaded or 
truncated for new multitrack projects. 

Recording Preferences
These preferences let you specify settings for recording audio.

Â Input pop-up menu:  Displays the available devices for audio input. Choose an input 
device from the pop-up menu.

Â Monitor pop-up menu:  Displays the available devices for monitoring audio output. 
Choose an output device from the pop-up menu. 

Â Latency Compensation slider:  Sets the amount of latency compensation in 
milliseconds. If recorded audio is late, drag the slider right. If the recorded audio is 
early, drag the slider left.
For information on eliminating latency, see “Eliminating Recording Latency” on 
page 294.

Â Sessions Location display:  Displays the default location to which recording sessions 
are saved. You can set the save location by clicking the Choose button and 
navigating to a new location.
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Synchronization Preferences
These preferences let you specify synchronization settings.

Input
Â Sync To MIDI Clock checkbox:  Sets Soundtrack Pro to receive MIDI Clock signals from a 

MIDI application or external device. 
Â Sync To MIDI Time Code checkbox:  Sets Soundtrack Pro to receive MIDI Time Code 

(MTC) signals from a MIDI application or external device. 

Output
Â MIDI Clock pop-up menu:  Choose the device to send MIDI Clock to, or choose None. 
Â MIDI Clock Virtual MIDI Device checkbox:  Sets Soundtrack Pro to send MIDI Clock 

signals to MIDI applications as “Soundtrack Sync Source.”
Â MIDI Time Code pop-up menu:  Choose a device to send MTC signals to, or choose 

None. 
Â MIDI Time Code Virtual MIDI Device checkbox:  Sets Soundtrack Pro to send MTC signals 

to MIDI applications as “Soundtrack Sync Source.”
Â Frame Rate pop-up menu:  Sets the frame rate for outgoing MTC signals. (Note that 

Soundtrack Pro automatically detects the frame rate for incoming MTC signals.)
Time Code Offset
Â Bar 1 At field:  Sets the offset of Measure 1 of your Soundtrack Pro project in SMPTE 

format. The offset affects both incoming and outgoing MTC signals. This should be 
set to the same value in all applications and devices. 
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Control Surfaces Preferences
These preferences let you specify settings for communicating with attached 
control surfaces.

Â Control Surfaces field:  Shows the control surfaces connected to your computer. 
Channels and banks are assigned to control surfaces in the order they appear in the 
field, starting from the left.

Â Add and Delete buttons:  Add or delete the selected control surface so that 
Soundtrack Pro no longer connects to it. 

Â Previous and Next buttons:  Change the order of the selected control surface in the 
Control Surfaces field. 

Â Summary information:  Displays information about the selected control surface 
including type, input port, and output port. 

Â Control Surface Buttons button:  Click to show the Control Surface Mapping window, 
where you can assign control surface buttons and other controls to specific 
commands and operations. 

For information about connecting and using control surfaces, see Chapter 12, “Using 
Control Surfaces With Soundtrack Pro,” on page 243.
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Video Out Preferences
These preferences let you specify settings for video output from Soundtrack Pro.

Â Video Output Device pop-up menu:  Choose a video output device, or choose None. 
Â Use Quarter-size Frames checkbox:  Select to send video to the output device as 

quarter-size frames. Quarter-size frames require less data throughput and can be sent 
more efficiently than full-size frames.
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4 Working With Multitrack Projects

You can arrange and mix audio clips in a multitrack 
project. Multitrack projects include tracks, busses, and 
outputs you can use to create sophisticated mixes.

When you create a multitrack project, you can set the project’s properties and the 
project length. You locate and add media to your project using the Media and 
Effects Manager. 

Creating and Opening Multitrack Projects
When you open Soundtrack Pro, a new, blank project appears. You can change the 
default startup behavior in the Preferences window. For information about setting 
preferences, see “Setting Soundtrack Pro Preferences” on page 75.

To create a new multitrack project:
m Choose File > New > Multitrack Project (or press Command-N).

A new, untitled project appears. You can name the project when you save it. For 
information on saving projects, see “Saving Multitrack Projects” on page 86.

To open an existing project:
1 Choose File > Open (or press Command-O).

2 Optionally, to view only multitrack projects in the dialog, choose Multitrack Document 
from the File Type pop-up menu.

3 Locate and select the project, then click Open.

You can also open a recently open project by choosing it from the File > Open Recent 
menu, and can open a project by dragging it onto the Soundtrack Pro icon in the Dock.

You can have multiple projects open in Soundtrack Pro, and cut and paste between 
them, but you can only play one project at a time. You can open projects created with 
earlier versions of Soundtrack (with the extension .loop) but can only save them as 
multitrack projects (with the extension .stmp)
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Closing Multitrack Projects
To close a project:

m Select the project’s tab in the Project window, then choose File > Close Project (or press 
Command-Shift-W).

Setting Project Properties
Each project has a set of project properties, which include time format, sample rate, 
tempo, time signature, key, and overlap mode. Each project property has a default 
setting, described below. You can change the project properties using the project 
controls in the Project window in the Timeline. 

The most important project properties are time format and sample rate. The remaining 
properties (tempo, time signature, and key) are important for projects set to Beats-
based format. For projects set to Time-based format, you can usually leave the tempo, 
time signature, and key properties at their default settings.

You can change the default project properties for new projects in the Project pane of 
the Preferences window. For information on setting preferences, see “Setting 
Soundtrack Pro Preferences” on page 75.

Time Format
Each multitrack project has a project time format, which can be either Time-based or 
Beats-based format. Setting the time format controls the appearance of the Time 
display, Time ruler, Timeline gridlines, and available Snap To values. For projects set to 
Time-based format, time is displayed using the Time ruler units chosen in the View 
menu. For projects set to Beats-based format, the time is displayed in measures, beats, 
and beat divisions. The default format is Time-based.

Setting the format to Time-based lets you align clips and other items in the Timeline 
with specific points in time, for example, specific frames in a video file. Setting the 
format to Beats-based lets you align items in the Timeline with measures, beats, and 
other musical units of time, regardless of tempo. You can switch between Time-based 
and Beats-based format while working on a project. 
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To set the time format:
m Click the Time Format button to set the format to Time-based, or click the Beats Format 

button to set the format to Beats-based.

You can also set individual tracks to use a different time format than the project’s time 
format. For information on setting a track’s time format, see “Changing Track Time 
Format” on page 104.

Sample Rate
The project sample rate determines the number of samples per second Soundtrack Pro 
uses for audio playback and export. When you add audio files to your project, their 
sample rate is matched (upsampled or downsampled) on the fly to the project sample 
rate. The available sample rates are 32 kHz, 44.1 kHz, 48 kHz, 88.2 kHz, and 96 kHz. The 
default is 44.1 kHz, which is the standard for CD-quality audio recording. 

Note:  Digital video projects, including video for DVD, often use a 48 kHz sample rate. 
When creating a score for a video, be sure you save and export your project at the 
same sample rate the final video project will use. 

To set the sample rate:
m Choose the sample rate from the Sample Rate pop-up menu.

Note:  If you open your project on a computer that cannot support the project sample 
rate, the project is resampled to the nearest rate the hardware supports for playback. 
When you export your project, it is exported at the project sample rate, regardless of 
hardware limitations. For more information on hardware sample rates, see Chapter 1, 
“Setting Up Your System,” on page 13.

Time-based 
Format button

Beats-based
button

Sample Rate 
pop-up menu
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Tempo
The tempo sets the rate of the basic beat value for the project. When you add looping 
files to a project, their tempo is matched to the project tempo. The tempo range is 
from 60 to 200 beats per minute (bpm). The default tempo is 120 bpm (which equals 
two beats per second). You set the project tempo using the Tempo value slider in the 
project controls.

To set the project tempo, do one of the following:
m Click the left arrow in the Tempo value slider to decrease the tempo, or click the right 

arrow to increase the tempo.

m Click the value in the value slider, then drag the slider that appears left or right to 
change the tempo.

m Double-click the value in the value slider to select it, then type a new value.

You can change the project tempo over time using the Master Tempo envelope. For 
information about creating tempo changes, see “Master Envelopes” on page 220.

Time Signature
The time signature controls how measures and beats appear in the Time display and 
Time ruler. A project can have only one time signature, which lasts from the beginning 
to the end of the project. The default time signature is 4/4 (four beats per measure, 
with a quarter note as the beat value). 

To set the project time signature:
m Choose a time signature from the Time Signature pop-up menu. 

If you want to use a time signature not included in the list, choose Other, enter the 
time signature in the dialog that appears, then click OK. 

Note:  The project time signature affects the format of the Playhead Position value 
slider. For projects using Beats-based time format, it also affects the appearance of the 
Time ruler and the gridlines in the Timeline. It does not affect the rhythm of audio clips. 
If your project uses audio clips with music in a definite time signature, make sure that 
the project time signature matches the time signature of the clips used in the project.

Tempo value slider

Time Signature 
pop-up menu
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Key
The project key sets the root note (or tonic) for the project. When you add looping files 
to a project, their key is matched to the project key. You can set the project key to any 
note of the chromatic scale (from A through G#), or to None (–). The default key is A. 

Note:  The key does not determine the scale used (major, minor, or another scale), only 
the tonic or root note of the project.

To set the project key:
m Choose a key from the Key pop-up menu.

Overlap Mode
The project overlap mode determines what happens when you move an audio clip so 
that it partially or completely overlaps another clip on the Timeline. There are two 
overlap modes:  crossfade mode and truncate mode. 

In crossfade mode, when you drag an audio clip so that it partially overlaps another 
audio clip in a track in the Timeline, a crossfade is created for the overlapped part of 
the two audio files. You can adjust the boundaries of the crossfade in the Timeline. In 
truncate mode, when you drag an audio clip so that it partially overlaps another audio 
clip in a track in the Timeline, the overlapped part of the clip is truncated.

To set the project overlap mode:
m Click the Crossfade Mode button to set the project to crossfade mode, or click the 

Truncate Mode button to set the project to truncate mode.

Key pop-up menu

Truncate Mode
button

Crossfade Mode 
button
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Setting the Project Length 
By default, the length of a project depends on the media in the project. The project 
length is set to the end of the last clip in the project. If the project uses a time-based 
effect, and the effect extends past the end of the last clip, the project length extends to 
include the effect’s “tail.” Adding a clip to the end of the project, or adding an effect 
that produces a “tail,” extends the project length to include the new clip or the effect’s 
tail. You can optionally set the project to a definite length.

To set the project length:
m In the Timeline, place the playhead at the point where you want the project to end, 

then choose Mark > Set End of Project.

You can move the end-of-project marker to change the length of the project, or delete 
it if you decide you no longer want it in the project.

To delete the end-of-project marker:
m Select the marker in the Timeline, then choose Edit > Delete (or press the Delete key.)

Saving Multitrack Projects
To save your project:

m Choose File > Save. 

Multitrack projects are saved as documents with the extension .stmp. 

Important:  When you save a project, the audio files used by the project are not saved 
as part of the project file. To play a project on another computer, you must install the 
audio files the project uses on that computer, or on a disk it can access. If you remove 
the audio files used in a project so that your computer cannot access them, you cannot 
play back the project. 

You can save a project and the media files the project uses together. This makes it easy 
to move projects between computers, and ensures that all needed audio files are 
available for playback. 
Â When you select Collect Audio Files, the project file and all the audio files the project 

uses are saved in the same folder. 
Â When you select Collect Video File, the video file is included with the project and its 

audio files. 

End-of-project marker
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To save a project and its audio files together:
1 Choose File > Save.

2 In the dialog that appears, select the Collect Audio Files checkbox. 

3 Navigate to the folder in which you want to save the project and its audio files, then 
click Save. 

The project file, and a copy of every audio file the project uses, are saved to the 
selected location. 

4 You can optionally click the New Folder button to create a new folder for the collected 
project. It’s a good idea to save each collected project in its own folder.

5 If the project includes a video file, you can optionally select the Collect Video File 
checkbox to save the video to the selected location. 

If the folder already contains any of the media files, an alert appears, asking if you want 
to replace the existing files. 

Note:  Because video files are typically very large files, saving a copy of the video file 
may take several minutes and may require a large amount of disk space.

You can also save a compressed version of the project. When you save a project 
compressed, the data used to draw the audio waveforms in the Timeline is not saved. 
This reduces the size of the project, but means that the waveforms must be redrawn 
each time the project is opened.

To save a project compressed:
m In the Save dialog, select the Save Compressed checkbox.

Adding Audio Files to a Multitrack Project 
Once you’ve located and previewed an audio file you want to add, you drag the file to 
the Timeline to add it to the project. When you drag an audio file to the Timeline, 
Soundtrack Pro creates an audio clip from the audio file, and adds the clip to the project. 
An audio clip does not contain the actual audio data; instead, it contains a reference to 
the file stored on disk. Editing an audio clip in the Timeline does not change the source 
audio file.

Each audio clip has a playback mode. For untagged files and files tagged as non-
looping files, the clip playback mode is non-looping. For files tagged as looping files, 
the clip playback mode is looping. If the playback mode of a clip is looping, the clip 
appears with notched edges to indicate where the audio file repeats when you resize 
the clip. 
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To add an audio file from the Media and Effects Manager, do one 
of the following:

m Drag the file from the File list in the Media and Effects Manager to a track in the 
Timeline. 

m Drag the file from the File list between two existing tracks. 

A new track is created and the clip is added to the track.

m Drag the file from the File list to the empty part of the Timeline below the outputs. 

A new track is created and the clip is added to the track.

m Drag a file from the File list to a track or to the part of the Timeline below the 
existing tracks. 

If you have adjusted the preview volume, the track volume is automatically set to the 
preview volume of the file.

Drag the file from the 
Media and Effects Manager 
to the Timeline.
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To add an audio file from the Finder:
m Drag the file from the Finder to the Timeline to a track, between two existing tracks, or 

to the area below all existing tracks. 

When the Bin tab of the Media and Effects Manager is active, the Bin shows all of the 
audio clips in the project. You can drag a clip from the list to the Timeline to add a new 
clip from the same audio file at a different point in time, or to a different track.

To add an audio file from the Bin tab:
m Drag the file from the Bin tab to the Timeline, either to a track or to the area below the 

existing tracks. 

Note:  When you drag an audio file to the Timeline, the file snaps to the nearest Snap To 
position if snap is turned on. For information on setting the Snap To value, see “Using 
Snap” on page 72.

Viewing and Editing Clip Properties
When you create an audio clip by dragging an audio file to the Timeline, the audio clip 
has a set of properties. These properties are specific to the clip, and can be different for 
two clips created from the same source audio file. 

The following properties for the selected clip are displayed, and can be edited, in the 
Clip tab of the Details tab:
Â Playback buttons:  Set whether the clip is looping or non-looping. When you add an 

audio file to the Timeline, the clip will be non-looping unless the audio file is tagged 
as a looping file.

Â Measure in pop-up menu:  Sets the units shown in the Position, Duration, and Offset 
value sliders.

Â Position value slider:  Sets the start point for the clip in the Timeline.
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Â Duration value slider:  Sets the duration of the clip. The duration of looping files is 
displayed in number of beats; the duration of non-looping files is displayed in 
seconds.

Â Offset value slider:  Sets the number of beats (for looping files) or seconds (for non-
looping files) from the beginning of the source file at which the clip begins playing.

Â Transpose pop-up menu:  Sets the transposition in semitones for looping files; the 
range is –12 to +12 semitones.

Â Clip Speed pop-up menu:  Sets the playback speed for looping files, which can be 
Quadruple, Double, Normal, Half, or Quarter.

Some properties can be changed by editing the clip in the Timeline. For detailed 
information on editing audio clips, see “Editing Audio Clips in the Timeline” on 
page 107.

The name of an audio clip appears on the clip in the Timeline. By default, the entire 
name appears on the clip if the clip is long enough to display it. You can change the 
default behavior in the General pane of the Preferences window, so that long clip 
names are truncated from the center. For information on setting preferences, see 
“Setting Soundtrack Pro Preferences” on page 75.

Tracks, Busses, and Outputs
Multitrack projects contain tracks, busses, and outputs. Tracks, busses, and outputs 
appear as horizontal rows in the Timeline and as vertical channel strips in the Mixer. In 
both the Timeline and Mixer, tracks, busses, and outputs are grouped together, with a 
separator between each category. You can move each type within its own category, but 
cannot move one to either of the other categories. Each track, bus, and output has a 
header with its icon, name, and a set of controls. 

Tracks
Tracks contain the audio you add to your project in the Timeline. Each track has a drag 
handle, a name, an icon, and a set of controls that appear in the track’s header in the 
Timeline and in its channel strip in the Mixer. Track controls include a volume slider, a 
pan control, an output pop-up menu, and buttons to mute or solo the track, add 
effects, and enable the track for recording. In addition, each channel strip includes 
stereo level meters you can use to watch the track’s levels, and a set of effects slots 
where you can add and order track effects and sends.
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Busses
Using busses, you can create submixes, letting you adjust volume and pan and add 
effects to groups of related tracks. You use busses by adding sends to effects chains in 
the Effects tab or the Mixer, then routing audio from each send to a bus.

Each bus has a drag handle, a name, an icon, and a set of controls that appear in the 
bus’s header in the Timeline and in its channel strip in the Mixer. Bus controls are the 
same as track controls, except that a bus does not have a Record Enable button 
(because you can’t record audio to a bus.) The bus controls affect the audio of every 
track sent to that bus. 

For example, you could route every dialogue track for a particular actor to a bus with 
the actor’s name. You could adjust the volume of all the actor’s dialogue using the bus 
volume fader, and add an EQ effect that brings out the actor’s voice in the mix. You 
could then send (route) the bus to a particular output.

You route audio from a track to a bus by adding a send to the track in the Effects tab or 
in the Mixer. When you add a send, the send is assigned to a bus. You can change the 
bus to which a send is assigned, and can adjust the volume and pan for the send.

Outputs
Outputs let you route the audio from tracks and busses to physical outputs. If you are 
using external audio hardware that supports multiple physical outputs, you can add 
outputs to a project and choose the physical output to which each Mixer output sends 
its audio. You can also send audio from multiple tracks or busses to a single output, 
control volume and pan for all the tracks using the output’s controls, and add effects to 
the output.

For example, you could have a bus with the dialogue tracks for each actor, and route all 
the dialogue busses to a single output. You could route all sound effects tracks to 
another output, and adjust the volume or add effects to each output. For a final stereo 
mix, you could route both outputs to the same pair of physical output channels 
(channels 1 and 2, for example).
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Each output has a drag handle, a name, an icon, and a set of controls that appear in the 
output’s header in the Timeline and in its channel strip in the Mixer. Output controls 
include a volume slider, a pop-up menu where you can choose the physical output 
channels for the output, and buttons to mute or solo the output and add effects. Each 
output channel strip includes stereo level meters you can use to watch the output’s 
levels, and a set of effects slots where you can add and order effects and sends. 
Outputs do not have pan controls or Record Enable buttons.

For information about working with tracks, busses, and outputs in the Timeline, see 
“Working With Tracks, Busses, and Outputs in the Timeline” on page 99. For information 
about working with tracks, busses, and outputs in the Mixer, see “Working With 
Channel Strips in the Mixer” on page 125.

Tracks, busses, and outputs 
in the Timeline

Tracks, busses, and 
outputs in the Mixer



5

      93

5 Working in the Timeline

The Timeline is where you arrange audio clips to 
build your soundtrack. You can also adjust volume 
and panning, add effects, and edit envelopes to 
control automation. 

The Timeline displays a visual representation of a project, showing the point in time 
when audio clips start playing and their duration. You control when and how long clips 
play by moving and resizing them in the Timeline. 

The Timeline is arranged in three sets of horizontal rows:  tracks, busses, and outputs. 
You add audio clips to tracks, create submixes using busses, and send audio to physical 
output devices using outputs. For information about working with tracks, busses, and 
outputs, see “Tracks, Busses, and Outputs” on page 90.

The Timeline also displays vertical gridlines that make it easy to position clips precisely 
in time. The gridlines correspond to the divisions of time in the Time ruler. The units of 
time the gridlines display change depending on the time format and the current 
zoom level.
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Moving Around in the Timeline 
Soundtrack Pro provides several controls that let you change the view of the Timeline 
and move to different parts of your project. You can zoom in or out for a closer or wider 
view of the Timeline, control how many tracks are displayed in the Timeline, and 
change which part of the project is currently visible using the scroll bars and Timeline 
controls. You can split the Timeline view, and use the Global Timeline view to quickly 
move to different parts of your project. 

Using the Scroll Bars 
If the entire project cannot be displayed in the Timeline, you can scroll through the 
project using the horizontal scroll bar located at the bottom of the Timeline. Drag the 
horizontal scroll bar left or right to move the visible part of the Timeline.

If your project contains more tracks than can be displayed in the Timeline, a vertical 
scroll bar appears along the right edge of the Timeline. Drag the vertical scroll bar up 
or down to change which tracks are visible.

In the lower left of the Timeline are the Timeline controls, including the Track Height 
control and Zoom control. 

Vertical scroll bar

Horizontal scroll bar
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Using the Zoom Control
You can zoom in to make precise edits in the Timeline, or zoom out for a wider view of 
your project using the Zoom control.

The Zoom control features a slider on a graduated scale. Moving the slider to the left or 
clicking the left side of the control zooms in for a closer view, displaying a smaller area 
of the Timeline close up. Moving the slider to the right or clicking the right side of the 
control zooms out for a wider view, displaying a wider area of the Timeline. 

Timeline zoomed in

Timeline zoomed out
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You can also zoom in and out using menu commands or keyboard shortcuts. If your 
mouse has a scroll wheel, you can use it to zoom in and out. You can also fit the entire 
project in the visible area of the Timeline.

To zoom in, do one of the following:
m Move the Zoom slider to the left.

m Click the left side of the Zoom control.

m Choose View > Zoom In.

m Press the Up Arrow key.

m Press Command-plus (+).

m If the mouse connected to your computer has a scroll wheel, move the scroll wheel.

To zoom out, do one of the following:
m Move the Zoom slider to the right.

m Click the right side of the Zoom control.

m Choose View > Zoom Out.

m Press the Down Arrow key.

m Press Command-minus (–).

m If your mouse has a scroll wheel, move the scroll wheel.

By default, when you zoom in or zoom out using the scroll wheel, the playhead 
remains in the same position on your screen, and the Timeline zooms in or out on both 
sides of the playhead. You can change the default scrollwheel behavior in the General 
Preferences pane.

To fit the project in the visible area of the Timeline:
m Choose View > Fit in Window (or press Shift-Z).
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Setting Track Height
You set the height of tracks, busses, and outputs in the Timeline using the Track Height 
control. The Track Height control has four settings. The smallest rectangle sets the track 
height to a minimized setting, with each track (and track header) reduced to half-
height, allowing more tracks to be displayed in the Timeline. 

To set the height of tracks, busses, and outputs:
m Click one of the four rectangles on the Track Height control.

Using the Global Timeline View
The Global Timeline view, located above the Time display and Time ruler, shows a 
miniature view of the entire project. The playhead appears as a black vertical line with a 
triangular handle. The part of the project currently visible in the Timeline is indicated 
by a blue rectangle in the Global Timeline view.

To move to a new area of the Timeline using the Global Timeline view:
m Drag the visible area rectangle to a new position.

You can quickly move to different parts of the Timeline by dragging the blue rectangle. 
This is especially useful when working on longer projects. You can also drag the 
rectangle up or down to move vertically in the Global Timeline view. This is useful if 
your project contains more tracks, busses, and outputs than can be displayed in the 
Project window.

Reduced track height

Large track height

Drag this rectangle
to a new position.
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Using the Time Ruler
The Timeline has a Time ruler that shows the divisions of time in a project. You can set 
the playhead to a precise frame, point in time, or sample number using the Time-based 
units on the Time ruler, or to a specific musical measure or beat using the Beats-based 
units, to synchronize playback of audio clips in the Timeline.

The Time ruler changes depending on the time format of the project and the Time ruler 
units. If the project is currently set to Time-based format, Time-based units appear in 
the upper part of the ruler. If the project is set to Beats-based format, Beats-based units 
appear in the upper half of the ruler.

You can use the Time ruler to position clips or the playhead at a precise point in time, 
including synchronizing them to a specific timecode reference in a video file.

To set the playhead to a specific point in the Time ruler:
m Click the Time ruler at the point where you want to set the playhead.

Working With the Playback Region
You can create a playback region in a project, an area that plays back repeatedly. This is 
sometimes called “cycling” or “looping” playback. A project has only one playback 
region, but you can move and resize it as often as you want. 

You also use the playback region when recording multiple takes. For information on 
recording, see Chapter 11, “Recording Audio in Soundtrack Pro,” on page 235.

To set the playback region:
m Drag in the bottom half of the Time ruler from the beginning of where you want the 

playback region to the end. 

The playback region is lighter in color than the rest of the Time ruler, with triangular 
markers indicating its start and end points. If a playback region already exists, you can 
drag anywhere in the Time ruler outside of the current playback region to set the 
playback region to a new position. 

If cycling is turned off, you must turn it on for the playback region to be active. The 
Cycle button darkens to indicate that the playback region is activated.

Drag in the Time ruler to
set the playback region.

Playback region
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To activate the playback region:
m Click the Cycle button in the transport controls.

To move the playback region:
m Click in the bottom half of the playback region and drag it to a new position in the 

Timeline.

To resize the playback region:
m Select either the start point or end point handle in the Time ruler and drag to resize the 

playback region. 

To remove the playback region:
m Click in any part of the Time ruler outside of the current playback region.

Working With Tracks, Busses, and Outputs in the Timeline
The Timeline is arranged into three groups of horizontal rows:  tracks, busses, and 
outputs. You add audio to tracks in your project, use busses to create and control 
submixes, and send audio to physical output channels using outputs. Tracks, busses, 
and outputs are described in greater detail in “Tracks, Busses, and Outputs” on page 90.

The tracks in a project appear in the upper part of the Timeline. Busses appear below 
tracks, and outputs appear below busses. A separator between each group helps 
visually distinguish them, and disclosure triangles on each separator let you show or 
hide the groups.

Tracks, busses, and outputs in the Timeline correspond to channel strips in the Mixer. 
When you add a track, bus, or output, adjust its controls, or add effects, the same 
changes appear in the corresponding channel strip when you open the Mixer.

Adding Tracks, Busses, and Outputs
To add a track, do one of the following:

m Choose Multitrack > Add Track (or press Command-T).

m Control-click an open area of the Timeline, then choose Add Track from the 
shortcut menu.

m Control-click a track, then choose either Add Track Above or Add Track Below from the 
shortcut menu.
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To add a bus, do one of the following:
m Choose Multitrack > Add Bus.

m Control-click a bus, then choose either Add Bus Above or Add Bus Below from the 
shortcut menu.

To add an output, do one of the following:
m Choose Multitrack > Add Output.

m Control-click an output, then choose either Add Output Above or Add Output Below 
from the shortcut menu.

Selecting Tracks, Busses, and Outputs
You can select a track, bus, or output in order to move, copy, or remove it, and can also 
select tracks, busses, and outputs to export. The headers of selected tracks, busses, and 
outputs appear darker in the Timeline.

To select a track, bus, or output, do one of the following:
m Click the drag handle along the left edge of the header for the track, bus, or output.

m Click anywhere in the row for the track, bus, or output in the Timeline.

You can select multiple tracks, busses, or outputs in the Timeline.

To select adjacent tracks, busses, or outputs:
m Shift-click the drag handle in the header of each track, bus, or output.

To select nonadjacent tracks, busses, or outputs:
m Command-click the drag handle in the header of each track, bus, or output.

Drag handle
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Moving and Copying Tracks, Busses, and Outputs

 

As you work on your project, you may want to rearrange tracks, busses, and outputs. 
You can move and copy them to change their vertical arrangement in the track, bus, 
or output section of the Timeline. You cannot move one to the area for another 
(as indicated by the rows labeled “Tracks,” “Busses,” and “Outputs” in the Timeline).

You can only move or copy one track, bus, or output at a time.

 

To move a track, bus, or output:
m

 

Drag the track, bus, or output drag handle up or down to a new vertical position.

A light blue horizontal line in the header area indicates the place the track, bus, or 
output will be moved to when you release the mouse button.

 

To copy a track, bus, or output:
m

 

Option-click the drag handle in the header for the track, bus, or output, then drag it up 
or down.

A copy of the track, bus, or output appears when you release the mouse button.

 

Renaming Tracks, Busses, and Outputs

 

By default, tracks are numbered when created, and take the name of the first audio clip 
you add to them. Busses and outputs are numbered starting from one (Bus 1, Out 1, 
and so on). You can rename a track, bus, or output and use the names to distinguish 
the type of audio it contains (for example, dialogue, voiceovers, music, or sound 
effects), its part in the overall project, or to identify it in some other way. 

 

To rename a track, bus, or output:
m

 

Click the name field in the header for the track, bus, or output and type a new name.

 

Changing a Track, Bus, or Output Icon

 

You can choose a new icon from the icon grid, or add your own image to the grid. 

 

To change the icon for a track, bus, or output, do one of the following:
m

 

Click the icon, then select a new icon from the icon grid that appears.

m

 

Drag a graphics file from the Finder to the icon.
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Using the Track Controls
Tracks, busses, and outputs have headers, located along the left side of the Timeline. 
Each header contains track controls that you can use to mute or solo the track, bus, or 
output, adjust its volume level and pan position, add effects, and show or hide its 
envelopes. 

Adjusting Volume 
The volume slider controls the volume (the loudness relative to other tracks) of the 
track, bus, or output. 

To adjust the volume level of a track, bus, or output:
m Drag the volume slider left or right.

The range is –96 dB to +6 dB, with the default at 0 dB. Double-clicking the slider resets 
it to the 0 dB position.

Adjusting Pan Position
Tracks and busses also include a pan slider. The pan slider controls the pan position (the 
left-to-right placement in the stereo field) of the track. 

To adjust the pan position of a track or bus:
m Drag the pan slider left or right.

The range is –100 (full left) to +100 (full right), with the default at 0 (center position). 
Double-clicking the slider resets it to the center position. 

Drag the volume
slider left or right.

Drag the pan slider
left or right.
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Muting and Soloing Tracks, Busses, and Outputs
The Mute button mutes (silences) the track, bus, or output. You can mute multiple 
tracks, busses, and outputs, allowing you to hear only the remaining, unmuted ones. 
Muting lets you compare the sound of the project using different combinations of 
tracks, busses, and outputs, and hearing the result of changes you make to them.

To mute a track, bus, or output:
m Click the Mute button. Click the Mute button again to unmute the track, bus, or output.

Muted tracks, busses, and outputs appear darker in the Timeline, making it easy to 
identify which tracks are currently audible. 

The Solo button solos the track, bus, or output, muting all others. Soloing a track, bus, 
or output lets you quickly isolate it from the rest of the project, so you can adjust the 
sound of the soloed track, bus, or output and make changes.

Soundtrack Pro supports multiple solo and exclusive solo. Clicking the Solo button for 
multiple tracks, busses, or outputs solos them and mutes all others. When you 
exclusively solo a track, bus, or output, all others are muted, regardless of whether they 
are soloed. 

To solo a track, bus, or output (multiple solo):
m Click the Solo button. Click the Solo button again to unsolo the track, bus, or output.

To exclusively solo a track, bus, or output:
m Option-click the Solo button. Click the Solo button again to unsolo the track, bus, or output. 

When you solo tracks, busses, or outputs, the ones not soloed appear darker in 
the Timeline.

Click the Mute button to mute
the track, bus, or output.

Click the Solo button to solo
the track, bus, or output.
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Changing Track Time Format
By default, tracks use the same time format as the project (Time-based or Beats-based). 
You can change the time format of a track, which changes the behavior of tagged clips 
when you change the project tempo.

When the track time format is Time-based, clips remain at the same time position (the 
same second or frame) when you change the project tempo. When the track time 
format is Beats-based, clips remain at the same beat position (the same measure, beat, 
and beat division) when you change the project tempo.

When you set a track to Beats-based time format, a metronome appears in the corner 
of the track icon.

To change a track’s time format:
1 Select the track. 

2 Choose Multitrack > Track Time Base, then choose a format from the submenu.

Adding Effects to a Track, Bus, or Output
Clicking the Effects button in the header for a track, bus, or output displays the Effects 
tab, which you use to add effects. The Effects tab also displays any effects currently 
assigned to the track, bus, or output.

To add effects to a track, bus, or output:
1 Click the Effects button in the header for the track, bus, or output.

Click the Effects button
to show the Effects tab.
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2 In the Effects tab, select a category in the Category list to display the effects for that 
category in the Effect list.

3 In the Effect list, do one of the following: 

Â Double-click the effect you want to add.
Â Select the effect name, then click the Add Effect button. 
Â Drag the effect to the Effect Parameters area.

The effect now appears in the Effect Parameters area with its checkbox selected.

When you add effects to a track, bus, or output, the Effects button changes color to 
indicate that the track, bus, or output contains effects.

For detailed information about adding and adjusting effects, see Chapter 9, “Working 
With Audio Effects,” on page 195.

Select the category
of effects you want to

use from this list.

...to the Effect
Parameters area.

Drag the effect from
the Effect list...
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Showing and Hiding Track, Bus, and Output Envelopes 
Clicking the automation disclosure triangle for a track or bus shows the volume and 
pan envelopes, which you can use to automate changes to pan position and volume 
level over the course of the project. Clicking the triangle for an output shows the 
output’s volume envelope. The envelopes appear in the Timeline below the track, bus, 
or output. You can also add envelopes for effect parameters, which appear below the 
other envelopes. For information on adding envelopes for effect parameters, see 
Chapter 9, “Working With Audio Effects,” on page 195.

To show the envelopes for a track, bus, or output:
m Click the envelopes disclosure triangle in the header for a track, bus, or output. Click 

the disclosure triangle again to hide the envelopes.

Note:  If you automate controls or effects using envelopes, you hear the results whether 
or not the envelopes are visible. 

For information on automating changes to volume, pan, and other settings, see 
Chapter 10, “Working With Automation,” on page 219. 

Removing Tracks, Busses, and Outputs
You can remove a track, bus, or output if you decide you no longer want it in a project.

To remove a track, bus, or output, do one of the following: 
m Select the track, bus, or output, then choose Multitrack > Remove [item] (or press 

Command-Shift-T).

m Control-click in the track, bus, or output, then choose Remove [item] from the shortcut 
menu.

The [item] changes depending on whether a track, bus, or output is selected.

Click the envelopes
disclosure triangle.

The envelopes appear 
below the track in the 
Timeline.
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Editing Audio Clips in the Timeline
You can edit audio clips in a variety of ways in the Timeline. You can select, cut, copy, 
and paste clips, move, resize, transpose, split and join them, and edit them in other ways.

Selecting Audio Clips
You select the audio clips you want to edit. You can select a single clip or multiple clips, 
including clips in different tracks. When you select a clip, it appears darker than 
unselected clips. 

To select an audio clip:
m Click the clip in the Timeline. 

To select multiple audio clips in the same track, do one of the following:
m Command-click the clips in the Timeline.

m Drag from a point in the track before the first clip you want to select to a point after 
the last clip you want to select, encompassing the clips. 

m If the clips are adjacent, Shift-click the clips in the Timeline.

To select multiple audio clips in different tracks:
m Shift-click or Command-click the clips in the Timeline.

To select all clips using the same source audio file, do one of the following:
m Select the clip in the Timeline or the Bin tab, then choose Clip > “Select All Occurrences 

of [filename].”

m Control-click the source audio file in the Bin tab, then choose “Select All Occurrences of 
[filename]” from the shortcut menu. 



108 Chapter 5    Working in the Timeline

 

Cutting, Copying, and Pasting Audio Clips
You can cut, copy, and paste audio clips in the Timeline. You can also paste multiple 
copies of a clip. 

To cut an audio clip:
m Select the clip in the Timeline, then choose Edit > Cut (or press Command-X). 

The clip is removed from the Timeline and placed on the Clipboard.

To copy an audio clip, do one of the following:
m Select the clip in the Timeline, then choose Edit > Copy (or press Command-C). 

m Option-drag the clip to the position where you want to copy it.

To paste an audio clip:
m Set the playhead at the position where you want to paste the clip, then choose Edit > 

Paste (or press Command-V). 

The clip is pasted in the currently selected track, starting at the current playhead 
position. If no track is selected, the clip is pasted in the track from which it was cut or 
copied. 

When pasting clips cut or copied from different positions in the Timeline or from 
multiple tracks, the following conditions apply:
Â Pasting clips from different Timeline positions:  The clip closest to the beginning of the 

project is pasted at the current playhead position, and the remaining clips are pasted 
at the same positions in time relative to the first clip as when they were cut or 
copied.

Â Pasting clips from multiple tracks:  The clip from the topmost track is pasted in the 
currently selected track, and the remaining clips are pasted at the same positions 
relative to the first clip as when they were cut or copied. If there are not enough 
tracks to accommodate the clips being pasted, a dialog appears asking if you want to 
create new tracks for the clips. If you choose not to create new tracks, only the clips 
for which tracks already exist are pasted.

When pasting audio clips, you can choose to paste multiple copies of the clip in 
succession. Using the Paste Repeat command, you can paste any number of copies of a 
clip in the selected track.
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To paste multiple copies of a clip:
1 Cut or copy the clip.

2 Set the playhead to the point you want to paste the first copy of the clip.

3 If you want to paste the copies in a different track, select the track.

4 Choose Edit > Paste Special > Paste Repeat (or press Option-Command-V).

5 In the Paste Repeat sheet, enter the number of times you want to paste the clip. 

The copies are pasted in the selected track, starting at the current playhead position. If 
no track is selected, the copies are pasted in the same track as the cut or copied clip.

Moving Audio Clips
You can move an audio clip in the Timeline by dragging the clip to a new position. You 
can also move the clip to a different track. 

To move an audio clip to a new time position:
m Drag the clip left or right to a new position in the Timeline. 

Type the number of times you
want to paste the clip in the
Paste Repeat sheet.

The copies are pasted in the 
selected track, starting at the 
current playhead position.

Drag a clip up or down to
move it to a different track.

Drag a clip left or 
right to move it to a 
new position.
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To move an audio clip to a new track:
m Drag the clip up or down to a different track. 

You can also move an audio clip using the Left and Right Arrow keys with various 
modifier keys. Using the Option key with the Arrow keys moves the clip by one pixel at 
a time; using the Option and Shift keys with the Arrow keys moves the clip to the next 
gridline in the Timeline. 

When you move a clip by one pixel, the amount the clip moves in time depends on the 
current zoom setting. 

To nudge an audio clip in pixel increments:
m Hold down the Option key while you press the Left or Right Arrow key.

To nudge an audio clip to the next gridline:
m Hold down the Option and Shift keys while you press the Left or Right Arrow key.

Snapping Clips to Clips on Adjacent Tracks
If snap is turned on, you can snap a clip to the edges of a clip in an adjacent track (the 
track either directly above or directly below the track containing the clip). This is 
especially useful when the start and end points of clips do not fall on the current 
Snap To value.

To snap a clip to adjacent clips:
m Choose View > Snap To > Adjacent Tracks.

Resizing Audio Clips
You control the duration of an audio clip (the amount of time the clip plays back) by 
resizing the clip. When you add a clip to the Timeline, the clip has the same duration as 
the source audio file. You can shorten clips to play back only a part of the source file. 
When you lengthen a clip with looping playback mode, it repeats the source file 
multiple times. 
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To resize an audio clip:
1 Place the pointer at either the left or right edge of the audio clip. 

The pointer changes to a Clip Resize pointer.

2 Click the edge of the clip and drag left or right to resize it. 

When you lengthen a clip with looping playback mode, the notches at the top and 
bottom of the clip indicate the end of each repetition of the source audio file. 

When you resize a clip by shortening its left edge, you change the point in the source 
audio file at which the clip starts playing, making the earlier part of the source audio 
inaudible. When you resize a clip by shortening its right edge, the part you shorten 
becomes inaudible. You cannot lengthen the left edge of a clip with non-looping 
playback mode beyond the beginning of the source audio file.

When you resize a clip, the edge being resized jumps to the nearest Snap To position if 
snap is turned on. If you want to resize the clip independently of the Snap To value, 
change the Snap To value, or turn off snap before you resize the clip. For information 
about snap, see “Using Snap” on page 72.

Creating Crossfades Between Audio Clips
Soundtrack Pro lets you easily create crossfades between two audio clips in the 
Timeline. Crossfades let you create smooth transitions between one audio clip and the 
next, and avoid clicks or sudden changes in loudness that can result when placing 
audio files one after another.

To create a crossfade between audio clips, you set the project to crossfade mode, then 
drag an audio clip so that it overlaps another clip. A crossfade is created for the length 
of the overlapped area. 

Notches indicate the 
points where a looping 
clip repeats.

Drag the clip to the left
or right to resize it.
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To set the project to crossfade mode:
m Click the Crossfade Mode button, located above the Global Timeline view. 

In crossfade mode, when you drag an audio clip so that it partially overlaps another 
audio clip in a track in the Timeline, a crossfade is created for the overlapped part of 
the two audio files. You can adjust the boundaries of the crossfade in the Timeline.

To create a crossfade:
m In the Timeline, drag an audio clip so that it overlaps another audio clip.

The crossfade appears in the overlapped area of the two clips.

You can adjust crossfades in several ways. You can change the edges of the crossfaded 
clips or move the position of the crossfade without changing its length.

To adjust crossfade boundaries:
1 Move the pointer over the left or right edge of the crossfade.

The pointer becomes a crossfade pointer.

2 Drag the edge of the crossfade to adjust the crossfade boundary.

To move the crossfade without changing its length:
m Drag the lower area of the crossfade left or right.

As with other edits you make in the Timeline, creating a crossfade between two audio 
clips does not change the source audio files.

Truncate Mode 
button

Crossfade Mode 
button

Crossfade
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Truncating Overlapping Audio Clips
You can have Soundtrack Pro truncate the overlapping part of audio clips in the 
Timeline instead of crossfading them. To truncate audio clips, you set the project to 
truncate mode, then drag an audio clip so that it overlaps another clip. 

To set the project to truncate mode:
m Click the Overlap Mode button, located above the Global Timeline view. 

In truncate mode, when you drag an audio clip so that it partially overlaps another 
audio clip in a track in the Timeline, the overlapped part of the clip is truncated.

To truncate an audio clip:
m In the Timeline, drag another audio clip over part of the clip.

Splitting and Joining Audio Clips
You may want to use only part of the source audio file in an audio clip. Soundtrack Pro 
lets you split the clip into segments and use the segments in the Timeline as 
independent clips. You can move the segments, edit them, and split each one into 
additional segments. 

There are two ways to split clips:  using the Split (razor) tool, or using the Split menu 
item in the Edit menu with the playhead. Each method has advantages, depending on 
the situation. Using the Split tool, you can perform many splits consecutively without 
moving the playhead each time. Using the playhead, you can split clips in several tracks 
at once.

To split audio clips with the Split tool:
1 Click the Split Tool button above the Timeline.

2 Click a clip at the point where you want to split it.

Split Tool button
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To split audio clips with the playhead:
1 Set the playhead at the point where you want to split the clip, then select the clip or 

clips you want to split. 

You can split multiple clips in the same operation.

2 Choose Edit > Split (or press S). 

Every selected clip under the playhead is split into two segments. The first segment 
ends at the playhead position, and the second segment begins at the playhead 
position. 

You can join clips from the same original audio file, including segments of split clips. 
Clips being joined must be adjacent to each other and in the same track.

To join audio clips:
1 Place the clips next to each other in the same track. 

2 Select the clips, then choose Edit > Join (or press J). 

When you join looping files or segments of looping files, the joined file plays to the end 
of the source audio file before looping. The notches in the joined file indicate the end 
of the source audio file. 

Move the playhead to 
where you want to split 
the selected clip.

The clip is split into 
two segments, each of 
which plays part of the 
source audio file.
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Transposing Tagged Audio Clips
When you drag an audio file tagged with key information to the Timeline, 
Soundtrack Pro transposes the clip to the project key. You can transpose tagged clips to 
another key to create chord progressions from the same audio file or to achieve other 
musical effects. You can transpose a tagged clip to any interval from one octave above 
(+12 semitones) to one octave below (–12 semitones) its current key. 

Note:  Soundtrack Pro uses the key tag in the audio file to transpose it. In order to be 
correctly transposed, the file must be tagged.

To transpose a tagged audio clip, do one of the following:
m Select the clip, choose Clip > Transpose, then choose the number of semitones by 

which you want to transpose the clip up or down.

m Control-click the clip in the Timeline, choose Transpose from the shortcut menu, then 
choose the number of semitones by which you want to transpose the clip up or down.

When Soundtrack Pro matches audio clips to the project key, it transposes the clips 
using the smallest appropriate interval. For instance, when matching a clip recorded in 
the key of D with a project in the key of A, the clip is transposed down five semitones 
(–5) rather than being transposed up seven semitones (+7), although either 
transposition would put the clip in the project key.

Transposing clips can lead to undesirable results, such as when the sound of the 
instrument recorded in the clip is moved outside its natural range. If the sound of a clip 
changes in an unsatisfactory way, you can try transposing the clip up or down by an 
octave (12 semitones) and see if you like the result better.

Transpose the clip down
from 1 to 12 semitones.

Transpose the clip up
from 1 to 12 semitones.
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The following table shows the correspondence between semitones and musical 
intervals for transposing clips:

Changing the Offset of an Audio Clip
When you add an audio clip to the Timeline, the clip plays back from the beginning of 
the source audio file. The point in the audio file where the clip starts playing is called 
the offset. By default, a clip’s offset is zero, the beginning of the source audio file. You 
can change the offset so that the clip starts playing from a later point in the source 
audio file. This allows you to use the audio from a later part of the source file without 
splitting the clip. 

To change the offset of a clip:
m Select the clip, then Command-Option-drag left (toward the beginning of the project).

Once you have changed the offset by dragging to the left, you can also drag to the 
right to change the offset.

Note:  You can only drag the offset to a later part of the clip’s source audio file, not to a 
point before the beginning of the file.

Number of semitones (+/–) Musical interval

1 Minor second 

2 Major second 

3 Minor third 

4 Major third 

5 Perfect fourth 

6 Tritone (diminished fifth)

7 Perfect fifth

8 Minor sixth

9 Major sixth

10 Minor seventh

11 Major seventh

12 Octave 

Command-Option-drag left
to change the clip’s offset.

The waveform moves inside
the clip’s boundary to indicate
the change in offset.
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When you change the offset of a clip, the waveform moves inside the clip’s boundary to 
indicate the change in offset. The length of the clip stays the same. If the clip has not 
been resized, it will reach the end of the source audio file and start looping. As you 
move the offset by dragging, the clip’s notches move to show the point at which the 
clip will start looping. 

Changing a Clip’s Playback Mode
Audio files you add to the Timeline can be either looping or non-looping. Looping files 
are special audio files that can be used to create repeating patterns, and include 
musical phrases useful for creating music beds. Audio files containing discrete, non-
rhythmic sounds, sound effects, and other non-musical sounds such as dialogue or 
sound effects should be used as non-looping files in most cases. 

When you add an audio file to the Timeline, the audio file is added as a clip with non-
looping playback mode unless the audio file is tagged as a looping file. You can change 
the playback mode of a clip after you add it to the Timeline. 

To convert the playback mode to looping, do one of the following:
m Select the clip, then choose Clip > Convert to Looping.

m Control-click the clip in the Timeline, then choose Convert to Looping from the 
shortcut menu. 

To convert the playback mode to non-looping, do one of the following:
m Select the clip, then choose Clip > Convert to Non-Looping.

m Control-click the clip in the Timeline, then choose Convert to Non-looping from the 
shortcut menu. 

Replacing the Source Audio in a Clip 
Each audio clip in the Timeline has a set of properties specific to the clip, including 
duration, speed, and transposition. You can replace the source audio in the clip while 
preserving the clip’s properties. This feature has a variety of uses, such as letting you try 
out similar audio files (for example, music beds or sound effects) while maintaining the 
clip’s duration, position in the Timeline, and transposition.

For information about properties of audio clips, see “Reconnecting Media Files” on 
page 74.
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To replace the source audio file for a clip:
1 In the Timeline, select the clip for which you want to replace the source audio.

2 Do one of the following: 

Â In the Media and Effects Manager, select the audio file you want to replace the 
selected clip’s audio with, then choose Clip > “Replace Selected Loops With 
[filename].”

Â In the Media and Effects Manager, Control-click the audio file you want to replace the 
selected clip’s audio with, then choose “Replace Selected Loops With [filename]” from 
the shortcut menu.

When you replace the source audio in a clip, the clip’s duration and offset stay the 
same. Only the portion of the new source audio file equal to the clip’s length plays. If 
the new source audio file is shorter than the clip’s length, the clip loops when it reaches 
the end of the new source audio file. Notches appear on the clip to indicate the point 
at which the clip starts looping. 

You can replace the source audio in all clips using the same source audio file with 
another source audio file by using the Select All Occurrences and Replace Selected 
Loops commands together. 

Select a clip,
Control-click the audio

file that will replace the
original audio...

...then choose the 
replace option in the 
shortcut menu.
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To replace the source audio file in all clips using the same source file: 
1 Select all occurrences of the clip for which you want to replace the source audio file, 

following the steps described in “Selecting Audio Clips” on page 107.

Every clip using the same source audio file is selected.

2 Replace the source audio file with another source audio file, following the steps 
described in “Replacing the Source Audio in a Clip” on page 117. 

Removing Audio Clips
As you work on a project, you may decide that a clip that sounded great on its own no 
longer fits with the overall composition. You can remove clips from a project by 
deleting them from the Timeline.

To remove an audio clip:
m Select the clip, then choose Edit > Delete (or press the Delete key).

Working With Markers
Markers have a variety of uses in the Timeline and the Waveform Editor. For example, 
you can use markers to:
Â Mark the start and end points of major sections in your project
Â Indicate places you want to come back to and work on later
Â Mark points where you want to synchronize the audio with the picture in a video
Â Indicate where particular sounds begin and end in an audio file

Markers extend vertically through the Timeline, like the playhead. Each marker has a 
handle in the area above the Time ruler, letting you position the marker precisely in 
the Timeline.
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Types of Markers
Soundtrack Pro displays Final Cut Pro HD scoring markers, and lets you add your own 
markers to a project. You can add two kinds of markers:  time markers and beat 
markers. The two types can be distinguished by their handles:  Time markers have 
green handles, and beat markers have purple handles. Final Cut Pro HD scoring 
markers have orange handles. 

This section discusses how to work with time markers and beat markers in a project. 
For information about working with Final Cut Pro HD scoring markers, see “Using 
Final Cut Pro Scoring Markers” on page 191.

Inserting Markers
You can insert a beat marker or time marker at any point in the Timeline or 
Waveform Editor.

To insert a beat marker:
m Set the playhead to the point where you want to add the marker, then choose 

Project > Insert Beat Marker (or press the B key). 

To insert a time marker:
m Set the playhead to the point where you want to add the marker, then choose 

Project > Insert Time Marker (or press the M key). 

End-of-project
marker (red)Time marker (green)

Final Cut Pro HD scoring 
marker (orange)

Beat marker (purple)
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Naming Markers
You can name time markers and beat markers, so that each marker can provide a 
unique visual cue to a specific point in the Timeline or Waveform Editor. For example, 
you can name markers to define sections of your project (Introduction, Verse, or 
Chorus), to reflect what’s happening in the music (Latin Rhythm or Fast Groove), or to 
serve as reminders for your workflow (Add Horns Here, Transpose to D, Insert 
Delay Effect). 

To name a beat marker or time marker, do one of the following:
m Control-click the marker handle, choose Edit from the shortcut menu, type a name in 

the Marker Name field of the dialog that appears, then click OK.

m Make the Details tab active, select the marker, then type a name in the Name field of 
the Details tab.

To view marker titles in the Timeline:
m Choose View > Show Marker Titles.

Moving Markers
You can move a marker either by dragging the marker’s handle, or by entering a new 
position for the marker in an Edit dialog.

To move either a beat marker or time marker, do one of the following:
m Drag the marker by its handle, located in the area above the Time ruler, to a new 

position in the Timeline. 

m Show the Details tab, click the marker you want to move, then enter a new position in 
the Position field.

m Control-click the marker handle, choose Edit from the shortcut menu, then type a new 
position in the Time field.

You can also select and drag multiple markers. When you move a marker by dragging, 
the marker’s position snaps to the nearest Snap To position if snap is turned on. For 
information on setting the Snap To value, see “Creating Crossfades Between Audio 
Clips” on page 111.

Type a name in the
Marker Name field.

Enter a time position
here to move the marker
to that position.
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Deleting Markers
To delete a marker:

m Click the marker handle to select the marker, then choose Edit > Delete (or press 
Delete).

You can’t delete Final Cut Pro scoring markers in Soundtrack Pro.
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6 Working in the Mixer

The Mixer gives you the tools to create sophisticated 
mixes for your projects.

When you have added audio clips to your project and placed them in the Timeline, you 
mix the project. Mixing is where you balance different elements, such as dialogue, 
music, and sound effects, bring focus to key moments and events in the project, and 
create a sense of perspective by placing sounds in space. When you finish mixing, you 
have one or more final mixes that you can export.

Soundtrack Pro gives you professional mixing capabilities, including the ability to create 
submixes and to send audio to multiple physical outputs. The Mixer provides a visual 
representation of your project in a virtual mixing console, with channel strips where you 
control different aspects of the sound. You can adjust volume and pan, mute and solo 
tracks, choose track outputs, add effects, and observe levels as the project plays. 
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Steps in Mixing
Mixing a project typically involves the following steps:
Â Balancing relative volume levels
Â Panning tracks to create perspective
Â Adding EQ, compression, and other processing using effects
Â Using automation to create changes over time
Â Setting the overall project volume and eliminating clipping

You can perform these steps in any order, and move back and forth between them as 
you create the mix. In most situations, you finish mixing the individual tracks before 
making changes to the overall project. The following suggested order provides a 
guideline that may be useful for common situations:

Step 1:  Mix main voice tracks
Solo the main voice tracks and pan to center. Add any EQ, compression, or other 
processing. Adjust relative volume, leaving some headroom (typically around –6 dB) in 
case you need to raise levels later.

Step 2:  Mix other voice and middle ground tracks
With main voice tracks still soloed, solo the other dialogue, ADR, and voiceover tracks 
one at a time and adjust volume and pan relative to the main voice tracks. Add any 
processing if needed.

Step 3:  Mix background tracks
With the previously mixed tracks still soloed, solo the background tracks one at a time 
and adjust volume and pan relative to the other tracks. Add any processing if needed. 

Step 4:  Make changes to the overall mix
Once you have mixed all the individual tracks in your project, add any EQ, compression, 
or other processing to the overall project. Adjust the overall volume to an appropriate 
level and remove any clipping before exporting the project.
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Working With Channel Strips in the Mixer
The Mixer features a series of vertically arranged controls called channel strips, like the 
channel strips in a hardware mixing console. The channel strips in the Mixer correspond 
to the tracks, busses, and outputs in the project Timeline. 

The controls a channel strip contains depend on whether it is a track, bus, or output 
channel strip. The controls for each type are as follows:

Channel strip

Track channel strips Bus channel strips Output channel strips

Drag handle Drag handle Drag handle

Icon Icon Icon

Effects slots Effects slots Effects slots

Output pop-up menu Output pop-up menu Output pop-up menu

Pan slider and value slider Pan slider and value slider —

Volume fader and value slider Volume fader and value slider Volume fader and value slider

Level meters with peak indicator Level meters with peak indicator Level meters with peak indicator

Record Enable button — —

Mute button Mute button Mute button

Solo button Solo button Solo button

Name Name Name
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The channel strips in the Mixer make it easy to see the settings for all the tracks, busses, 
and outputs in your project at once, and to adjust those settings relative to each other 
as you create the overall mix.

In the Mixer, the channel strips appear in order corresponding to their order in the 
Timeline. Top-to-bottom order in the Timeline corresponds to left-to-right order in the 
Mixer. You can reorder tracks in the Mixer, and have the new order reflected in the 
Timeline. Changes you make to controls such as volume and pan also show up in the 
track controls when you open the project in the Timeline.

Adding Channel Strips to the Mixer
You can add a channel strip for a track, bus, or output in the Mixer in the same way you 
add a track, bus, or output in the Timeline. 

To add a track channel strip:
m Choose Multitrack > Add Track.

To add a bus channel strip:
m Choose Multitrack > Add Bus.

To add an output channel strip:
m Choose Multitrack > Add Output.

Selecting Channel Strips
You can select a channel strip in order to move, copy, or remove it. Selected channel 
strips appear darker in the Mixer.

To select a channel strip, do one of the following:
m Click the drag handle at the top of the channel strip.

m Click any empty part of the channel strip.

You can select multiple channel strips in the Mixer.

To select adjacent channel strips:
m Shift-click the channel strips you want to select.

To select nonadjacent channel strips:
m Command-click the channel strips you want to select.
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Reordering Channel Strips
You can change the order of channel strips in the Mixer. When you open the Mixer, the 
order of channel strips corresponds to the order of tracks, busses, and outputs in the 
Timeline. Because channel strips are oriented horizontally in the Mixer, top-to-bottom 
order in the Timeline corresponds to left-to right order in the Mixer. Reordering channel 
strips in the Mixer also changes their order in the Timeline. 

In the Mixer, as in the Timeline, channel strips of the same type (track, bus, or output) 
are grouped together. You can reorder a channel strip within its own group, but cannot 
move it to a group of a different type. You can only move one channel strip at a time.

To reorder a channel strip:
m Drag the channel strip by its drag handle left or right to a new position.

Copying Channel Strips
You can copy channel strips in the Mixer. You can copy a channel strip within its own 
group, but cannot copy it to a group of a different type. You can only copy one channel 
strip at a time.

To copy a channel strip:
m Option-click the channel strip’s drag handle, then drag it left or right.

A copy of the channel strip appears when you release the mouse button.

Setting Channel Strip Volume Levels
You set relative volume levels to balance the various parts of the project. You set the 
volume level of a channel strip using the channel strip volume fader or value slider.

Different sounds can have different apparent loudness at the same volume level, so 
perceived loudness does not precisely correspond to numeric values on the volume 
faders. You determine the appropriate volume level by listening to the track and 
adjusting its level in the overall mix. 
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To set the volume level of a channel strip, do one of the following:
m Drag the volume fader up to raise (increase) the volume, or drag it down to lower 

(decrease) the volume.

m Click along the length of the volume fader at the point you want to set the volume 
level.

m Click the left or right arrows on the edges of the volume value slider.

m With the pointer over the center of the volume value slider, hold down the mouse 
button and drag left or right.

m Click the center of the volume value slider, then type a new value. 

The scale is from –96 to +6 dB. The default level is 0 (zero) dB.

To return the volume fader to the default level:
m Double-click the knob in the volume fader.

As you adjust track volume, watch the level meters next to the volume fader to make 
sure that the track is not clipping. For information about preventing clipping, see 
“Setting the Overall Project Volume Level” on page 138.

Volume
fader

Volume value slider
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Setting Channel Strip Pan Position
You pan sounds to different positions to place them in the stereo field from left to 
right. You set the pan position of a track or bus channel strip using the channel strip 
pan slider or value slider. You can’t pan an output channel strip.

To set the pan position of a channel strip, do one of the following:
m Drag the pan slider left or right to the pan position you want.

m Click along the length of the pan slider at the point you want to set the pan position.

m Click the left or right arrow on the edges of the pan value slider.

m With the pointer over the center of the pan value slider, hold down the mouse button 
and drag left or right.

m Click the center of the pan value slider, then type a new value. 

The scale is from –100 to 100, with 0 (zero) as the center value. Negative values are left 
of center, and positive values are right of center. The default is 0.

To return the pan slider to the default level:
m Double-click the knob in the pan slider.

Setting Channel Strip Output
On a hardware mixing console, you can send signals to different physical outputs. You 
can create outputs in Soundtrack Pro, assign tracks and busses to different outputs, and 
assign outputs to physical output channels on connected audio devices. You can send 
audio from as many tracks and busses to the same output as you want.

To set the output for a track or bus:
m In the channel strip for the track or bus, choose the output from the Output pop-up 

menu.

For outputs in the Mixer, the Output menu lists the available physical output channels 
(and channel pairs) for audio output devices connected to your computer.

Pan slider

Pan value slider

Output pop-up menu
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To set the physical output channel for an output in the Mixer:
m In the channel strip for the output, choose the physical output channel, or pair of 

channels, from the Output pop-up menu.

Note:  You can create outputs independently of the audio hardware connected to your 
computer, and route audio to an output that does not correspond to a physical output. 
In most situations, each output in a project should correspond to a physical output on 
the audio interface or other hardware connected to your computer. Outputs that do 
not correspond to a physical output will not be heard. You may set as many outputs in 
a project to the same physical output device or output channel as you like.

Muting and Soloing Channel Strips
You can mute and solo channel strips in the Mixer in order to hear or silence specific 
tracks, busses, or outputs.

To mute a channel strip:
m Click the channel strip’s Mute button. Click the button again to unmute the channel 

strip.

To solo a channel strip:
m Click the channel strip’s Solo button. Click the button again to unsolo the channel strip.

To exclusively solo a channel strip:
m Option-click the Solo button. Click the Solo button again to unsolo the track, bus, or 

output. 

When you export a project, all unmuted tracks, busses, and outputs are included in the 
exported file. If you export a track, bus, or output that is muted (including being muted 
by having another track soloed), the exported file will contain no audio.

Solo button

Mute buttonRecord Enable button

Channel strip name
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Enabling Track Channel Strips for Recording
You can enable a track channel strip for recording. When you enable a track channel 
strip for recording, audio will be recorded on the track when you click the Record 
button in the transport controls. You can’t record to a bus or output channel strip.

To enable a track channel strip for recording:
m Click the Record Enable button in the channel strip. Click the button again to disable 

the channel strip for recording.

You can record only to a track, not to a bus or an output.

Renaming Channel Strips
You can rename a channel strip to help you remember its content or purpose in the 
overall mix.

To rename a channel strip:
m Click the channel strip’s name (at the bottom of the channel strip) to select it, then type 

a new name.

Changing a Channel Strip Icon
You can change the icon of a channel strip. Icons do not affect the sound, but are 
useful as a quick visual reference for the channel strip, particularly for projects with 
many tracks, busses, or outputs.

To change a channel strip icon:
m Press and hold the icon you want to change, then choose a new icon from the 

icon menu.

Channel strip icon
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Showing and Hiding Sections of the Mixer
You can show or hide sections of the Mixer window and of the channel strips. Hiding 
sections of the Mixer and the channel strips can be helpful especially when using 
Soundtrack Pro with a smaller computer display, or when working on projects with a 
large number of tracks, busses, or outputs. 

You can show or hide any of the following sections of the Mixer:
Â Navigation display (Time display and Global Timeline view)
Â Transport controls
Â Tracks
Â Busses
Â Outputs

To hide a section of the Mixer:
m Choose the section you want to hide from the Show pop-up menu, located at the 

upper right of the Mixer. 

You can show or hide any of the following sections of the channel strips:
Â Icons
Â Effects slots
Â Output pop-up menus
Â Pan controls
Â Volume faders and level meters

To hide a section of the channel strips:
m Choose the section you want to hide from the Channel Strip pop-up menu. 

The visible sections of the channel strips appear with a checkmark in the Channel 
Strips pop-up menu.

Show (Mixer) pop-up menu

Channel Strip 
pop-up menu
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Using the Channel Strip Level Meters
Each channel strip includes stereo level meters to the right of its volume fader. You can 
use the level meters to observe each channel strip’s level as the project plays. The level 
meters range from –96 dB to 0 dB, moving from bottom to top as the level increases. 
The segments of the level meters run from green through yellow to orange as the level 
increases. 

At the top of each set of level meters is a peak indicator. As the project plays, the value 
in decibels of the highest level reached appears in the peak indicator. If the level rises 
above 0 dB, the peak indicator becomes red and shows the value 0 (zero). The values 
shown in each peak indicator remain until you play the project again, close the project, 
or reset the peak indicator.

To reset a peak indicator:
m Click the peak indicator.

To reset all peak indicators, do one of the following:
m Option-click the peak indicator in any channel.

m Click the Reset button in the Meters tab of the Utility window.

The peak indicators can help identify where clipping occurs in the project. For 
information about removing clipping, see “Setting the Overall Project Volume Level” on 
page 138. 

Peak indicator

Level meters
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Removing Channel Strips
You can remove a channel strip from the Mixer if you decide you no longer want it in 
the project.

To remove a channel strip:
1 Select the channel strip.

2 Choose Multitrack > Remove [item].

The term indicated by [item] changes in the menu depending on whether a track, bus, 
or output is selected.

Note:  If audio from a track is sent to a bus or output, and you remove the bus or 
output, the audio from the track will not be heard when you play the project. 

Working With Effects and Sends in the Mixer
You can add effects to a channel strip in the Mixer, show effects settings, turn effects 
on and off, replace an effect, and delete effects. You can also adjust effects settings in 
the Effects tab or in the effect’s advanced settings window.

Adding Effects to a Channel Strip
You can add effects, turn effects off and on, and reorder effects in a channel strip. 

Note:  Before adding an effect to a track, its a good idea to solo the track so that you 
can hear how the effect changes its sound, separate from the other tracks in the 
project.

To add an effect to a channel strip:
m Control-click an empty effects slot in the channel strip, choose Add Effect from the 

shortcut menu, then choose one of the available effects from the categories in the 
submenu.
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Showing Channel Strip Effects Settings
Once you add an effect, you can view and adjust its settings in the Effects tab.

To show an effect’s settings in the Effects tab:
m In the channel strip, Control-click the effect, then choose Show [effect name] Settings 

from the shortcut menu.

The Effects tab becomes active, and shows the selected effect’s settings.

To show an effect’s settings in the Effects tab:
m In the channel strip, Control-click the effect, then choose Show [effect name] Settings 

from the shortcut menu.

The Effects tab becomes active, and shows the selected effect’s settings.

Some effects have a floating advanced settings window with sliders and other controls 
you can use to adjust effect parameters. 

To show advanced settings for an effect, do one of the following:
m Double-click the effect name in the channel strip.

m Control-click the effect, then choose Show [effect name] Advanced Settings from the 
shortcut menu.

The effect’s advanced settings window appears. 

For information on working in the advanced settings window, see “Advanced Settings 
for Realtime Effects” on page 215.

Reordering Effects in the Mixer
You can reorder effects in the Mixer as well as in the Effects tab. When you reorder 
effects, you change the order in which the audio is processed by each effect, which can 
change the sound drastically.

To reorder an effect in the Mixer:
m Drag the effect up or down in the effects slot area to change its order.
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Turning Effects Off and On
You can turn off a channel strip’s effects. Turning off an effect lets you hear the channel 
strip without the effect, while preserving the current effects settings.

To turn off an effect in a channel strip, do one of the following:
m Deselect the checkbox to the left of the effect name. 

m Control-click the effect, then choose Disable [effect name] from the shortcut menu.

To turn off all effects in a channel strip:
m Control-click an effects slot, then choose Disable All Effects from the shortcut menu.

To turn on an effect again, do one of the following:
m Select the checkbox to the left of the effect name.

m Control-click the effect, then choose Enable [effect name] from the shortcut menu.

To turn on all effects in a channel strip:
m Control-click an effects slot, then choose Enable All Effects from the shortcut menu.

Replacing an Effect
You can replace an effect in a channel strip with another effect. When you replace an 
effect with another effect, the new effect has its default settings, regardless of the 
settings of the previous effect. 

To replace an effect in a channel strip:
m Control-click the effect, choose Replace [effect name] from the shortcut menu, then 

choose a new effect from the submenu.

Deleting Effects From a Channel Strip
You can delete an effect if you decide you don’t want to use it in a channel strip. You 
can also delete all effects from a channel strip.

To delete an effect from a channel strip, do one of the following:
m Select the effect, then choose Edit > Delete (or press the Delete key.)

m Control-click the effect, then choose Delete [effect name] from the shortcut menu.

To delete all effects from a channel strip:
m Control-click an effects slot, then choose Delete All Effects from the shortcut menu.

For more information about working with effects, including information on uses of 
different effects and adjusting effect parameters, see Chapter 9, “Working With Audio 
Effects,” on page 195.
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Adding Sends to a Channel Strip
You can add sends to a channel strip, show send settings in the Effects tab, bypass a 
send, or remove a send in the Mixer.

To add a send to a channel strip:
m Control-click an empty effects slot in the channel strip, choose Add Send from the 

shortcut menu, then choose one of the available effects from the categories in the 
submenu.

When you add a send, the audio is routed from the send to a bus. By default, the first 
send you add to an effects chain is routed to Bus 1, the second send is routed to Bus 2, 
and so on, if the default bus exists. You can choose the bus to which a send is routed.

Reordering Sends in the Mixer
You can reorder sends in the Mixer as well as in the Effects tab. When you reorder 
sends, you change which effects are routed to the send, which can change the sound 
drastically.

To reorder a send in the Mixer:
m Drag the send up or down in the effects slot area to change its order.

Showing Send Settings
You can show the settings for a send in the Effects tab. Send settings include volume, 
pan, and the bus to which the send is routed. 

To show settings for a send:
m In the Mixer, Control-click the send, then choose Show Send Settings from the shortcut 

menu.

The Effects tab becomes active, with the settings for the send visible in the Effect 
Parameters area.

Turning Sends Off and On
You can turn sends off, and turn them back on. When you turn off a send, the audio is 
not routed to the send bus, and is not heard.

To turn off a send in a channel strip, do one of the following:
m Deselect the checkbox to the left of the send name.

m Control-click the send, then choose Disable Send from the shortcut menu.

To turn on an effect again:
m Select the checkbox to the left of the effect name.
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Setting the Overall Project Volume Level
As you finalize a project mix, you set the overall project volume to the appropriate 
level. Certain formats or methods of distribution may require that the project conform 
to a particular maximum level. In general, you set the overall volume of the project to 
the highest level at which no clipping occurs at any point in the project. 

Clipping occurs when the digital audio signal exceeds the maximum level that can be 
reproduced accurately. Unlike analog audio, digital audio is completely unforgiving of 
clipping, which creates sharp distortion of the audio signal. Soundtrack Pro projects 
clip whenever the output displayed in the level meters exceeds zero decibels (0 dB). It’s 
important to eliminate clipping from projects before exporting the final mix. For more 
information about digital distortion, see Appendix C, “Audio Basics,” on page 287.

You can monitor audio output levels using the level meters in the Mixer, the Project 
window, and the Meters tab. In the Mixer, each channel strip has stereo level meters 
that show the levels for that channel strip. In the Project window and the Meters tab, 
the level meters show the levels for the first output (Output 1). The Meters tab includes 
additional controls and displays to help you maintain proper audio levels and 
eliminate clipping. 

As a project plays back, the levels in each stereo channel change constantly with the 
rising and falling of the audio signal. The level meters show these changes both as bars 
rising to varying heights and as changes in color from green to yellow. 

In each stereo channel’s meter, a white horizontal bar displays the current signal level; 
colored bars below the white bar display successive levels in a scale that rises from 
green through yellow to orange as the signal increases. The meters peak at red when 
the signal clips (rises above 0 dB).

Go buttons

Value and Location 
display

Peak indicator
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The Meters tab also includes peak indicators, Value and Location displays and Go to 
Peak buttons for each stereo channel, and a Reset button. You can use these controls to 
locate and remove clipping from your project. 

Using the Peak Indicators
At the top of the level meters is a rectangular peak indicator, which lights red when 
that channel clips (exceeds 0 dB). The peak indicators are “sticky,” meaning that if 
clipping occurs in either channel, the peak indicator lights red and stays red until you 
reset it, or reset all peak indicators.

To reset a peak indicator:
m Click the peak indicator. 

To reset all peak indicators, do one of the following:
m Option-click any peak indicator in any of the level meters.

m Click the Reset button in the Meters tab of the Viewer.

Peak Value and Peak Location Display
To the right of the level meters in the Meters tab, the levels of each stereo channel are 
displayed in decibels (dB). As the project plays back, the Peak Value display shows the 
highest level reached by each channel since the start of playback. The Peak Location 
display shows the location in the Timeline where the peak occurs.

Go to Peak Buttons
The Go to Peak buttons move the playhead to the point in the Timeline where the 
highest level for each channel is reached. This makes it easy to find the point in the 
project where clipping occurs and should be removed. 

Reset Button
The Reset button located in the upper-right corner of the Meters tab display resets the 
Peak Value to a minimum value (–96 dB) and resets the Peak Location to the beginning 
of the project. 

To reset the Peak Value and Peak Location displays:
m Click the Reset button.

The steps you take to remove clipping depend on the cause of the clipping. You can 
lower the master volume of a project by the amount the highest point in the project 
(as shown in the Value display) exceeds 0 dB. You can also use the Go buttons to locate 
where clipping occurs, and use a different audio clip or lower the volume of individual 
tracks until clipping no longer occurs. Sometimes removing or adjusting effects can 
remove occurrences of clipping as well.
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Listening to a Temporary Mono Mix 
In some situations, even where the final mix is stereo, you may want to listen to the mix 
in mono as well as stereo. If the final project is likely to be viewed using equipment 
with mono audio output (for example, many television sets have mono output), you 
may want to make sure the mix is suitable for mono output. Listening to a mono mix 
can also help identify phase issues that can occur when a stereo project is played in 
mono. Soundtrack Pro makes it easy to listen to a temporary mono mix of the project 
so you can hear how it will sound in mono.

To listen to a temporary mono mix:
1 Start the project playing.

2 While the project plays, press and hold the Mono Mix button, located to the right of 
the master volume slider below the Mixer.

The Mono Mix button becomes darker to indicate that it is active. When you are 
finished listening to the temporary mono mix, release the button to hear the 
project mix.

Recording Audio in the Mixer
You can record audio while working in the Mixer. When you record audio in the Mixer, 
recording starts from the current playhead position. Although the playhead is not 
visible in the Mixer, you can set the playhead position using the transport controls or 
the Playhead Position value slider located at the bottom of the Project window. 

For more information about recording, see Chapter 11, “Recording Audio in 
Soundtrack Pro,” on page 235.

Recording Automation in the Mixer
You can record automation for volume and pan changes in the Mixer. You record 
automation in the Mixer by choosing either Touch or Latch automation mode in the 
project controls, then changing volume or pan settings as the project plays. You can 
record automation either using the onscreen volume and pan controls, or using a 
control surface connected to your computer.

For more information about working with automation, see Chapter 10, “Working With 
Automation,” on page 219.

Mono Mix button
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Creating Multiple Mixes
You might want to create multiple mixes of a project for one of the following reasons:
Â To optimize the project for different playback situations
Â To try out different settings of the various track and master controls using the same 

arrangement
Â To try out changes to the arrangement using the same basic material

You can easily create multiple mixes by giving the project a slightly different name 
when you save each mix, or by using different combinations of tracks, busses, and 
outputs for each mix. If you are saving the project and its media files together, the 
different versions can be saved to the same location if they all use the same media files. 
For information about saving projects and their media files together, see “Saving 
Multitrack Projects” on page 86.

Things to Keep in Mind While Mixing
The following are intended as guidelines or suggestions to follow when mixing your 
projects, not as “hard-and-fast” instructions.
Â Consider the importance of each element in the overall mix.
Â Keep related tracks close together (in the Timeline and the Mixer).
Â Don’t create a final mix until the picture is locked.
Â Listen to the mix with the best possible equipment.
Â Listen to the mix as the audience will hear it.
Â Don’t change output/monitor levels while mixing.
Â Mix by what you hear, not what you see.
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7 Working in the Waveform Editor

You can edit audio files nondestructively in the Waveform 
Editor, and analyze and fix common audio problems. 

The Soundtrack Pro Waveform Editor gives you extensive audio file editing capabilities. 
You can open an audio file in the Waveform Editor, view it in Waveform or Spectrum 
view, process the file using actions, analyze it for common audio problems, fix analyzed 
problems individually or together, then save the edited file as an audio file project or as 
a standard audio file. 

The Waveform Editor includes a set of graphical waveform editing tools, a Time display, 
a Global Waveform view, an Actions list, and a waveform display. 
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Getting Started With Audio File Projects
You can create audio file projects, open audio files in the Waveform Editor, create a new 
audio file, and save an audio file as an audio file project.

Supported Audio File Formats
You can open the audio files in the following formats in the Waveform Editor:
Â Audio file project 
Â AIFF
Â WAVE
Â MP3
Â AAC (except protected AAC files)
Â Sound Designer II
Â NeXT Sound File
Â QuickTime Movie
You can open audio files with any combination of the following sample rates and bit 
depths:

Sample Rates
Â Any rate between 8 kHz and 192 kHz

Bit Depths
Â 8-bit integer
Â 16-bit integer
Â 24-bit integer
Â 32-bit integer
Â 32-bit floating point
You can open audio files up to four hours in length in the Waveform Editor.

Note:  You can open audio files with any sample rate between 8 kHz and 192 kHz. When 
you edit the file in the Waveform Editor, it maintains its sample rate. When you play the 
file, it plays at the nearest sample rate your hardware can support.

The audio file project format is the native format of the Soundtrack Pro Waveform 
Editor. Audio files saved in this format have some special features, which are described 
in this chapter.
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Creating and Opening Audio File Projects
You start working in the Waveform Editor by creating an audio file project, opening an 
existing audio file project, or opening an audio file in the Waveform Editor. 

To create a new, blank audio file project:
m Choose File > New > Audio File.

To open an audio file project or audio file in the Waveform Editor, do one of 
the following:

m Choose File > Open (or press Command-O), locate and select the project or file, then 
click Open.

m Drag the project or file over the Soundtrack Pro icon in the Dock.

m In the Multitrack window or the Media and Effects Manager, Control-click a project or 
file, then choose Open in Editor from the shortcut menu.

When you open a clip from the Multitrack window, if the clip is part of a larger audio 
file, the Waveform Editor zooms in to the length of the clip. A marker is added to mark 
the start and end points of the clip.

When you open a stereo audio file in the Waveform Editor, the left channel appears in 
the upper part of the waveform display, and the right channel appears in the lower 
part. 

You can have multiple audio file projects open in Soundtrack Pro, and cut and paste 
between them, but only one project can play back at a time.

Closing Audio File Projects
You can close the project when you no longer want to work on it, or close the Project 
window and close all open projects (both multitrack and audio file projects).

To close a project:
m Choose File > Close Project. 

To close all open projects and close the Project window:
m Choose File > Close Window. 
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Saving Audio File Projects
You can save a project as an audio file project or as a standard audio file, and can 
choose other options when you first save the file. Audio file projects are saved with the 
extension .stap. Saving a project as an audio file project lets you make changes to 
actions and other edits when you reopen the project in the Waveform Editor. You can 
also save a project as a standard audio file. In this case, the edits you have made are 
rendered into the audio file, and cannot be changed or undone the next time you 
open the audio file in the Waveform Editor.

To save a project as an audio file project: 
1 Choose File > Save. 

2 In the Save dialog, type a name for the file and browse to the location where you want 
to save it.

3 Choose the file type for the project from the File Type pop-up menu.

The available choices in the Save dialog change depending on whether you choose 
Audio File Project or an audio file format as the file type.

4 Optionally, select the Flatten checkbox to flatten the project. Flattening a project 
flattens or coalesces the actions in the project, reducing project complexity and file 
size. Once you flatten a project, you can no longer edit existing action settings.

5 Optionally, select the Render checkbox to create a render file in the project. If you are 
working with a clip sent from Final Cut Pro, be sure this checkbox is selected.

6 Click Save.
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For audio file projects sent from Final Cut Pro or Motion and for reference movies, the 
original source media file (whether video or audio) is not saved in the project by 
default, but instead a reference to the media file is saved. You can save the source 
media file in the project. Saving the source media file in the project allows you to move 
the project to another computer or storage device and continue working, but can 
significantly increase project size.

To collect the original source media in the project:
m In the Save As dialog, select the Collect Source File checkbox.

You can save a project to any of the audio file formats listed in “Supported Audio File 
Formats” on page 144, except MP3 and AAC.

To save a project as an audio file: 
1 Choose File > Save. 

2 In the Save dialog, type a name for the file and browse to the location where you want 
to save it.

3 Choose the file type for the project from the File Type pop-up menu.

The available choices in the Save dialog change depending on whether you choose 
Audio File Project or an audio file format as the file type.

4 Choose the bit depth for the project from the Bit Depth pop-up menu.

5 Choose the sample rate for the project from the Sample Rate pop-up menu.

6 Optionally, select the Dither checkbox to dither the file. Dithering is useful when saving 
a project at a lower bit depth or sample rate. In general, you should dither a project 
only when saving it as an audio file, and only when you have finished all bit depth or 
sample rate conversions.
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7 Click Save.

When you save an audio file with the same name, location, and extension as the 
original audio file, you overwrite the existing audio file.

Setting the Time Ruler Units in the Waveform Display
You can set the Time Ruler units in the waveform display to any format in the Time 
Ruler Units submenu. 

To set the Time Ruler units in the waveform display:
m Choose View > Time Ruler Units, then choose a format from the submenu.
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Choosing the Sample Units in the Waveform Display
Along the left edge of the waveform display is a scale of sample units for the audio file. 
You can set this scale to any of the following sample units:
Â Sample Value
Â Normalized
Â Percent
Â Decibels

To set the sample units in the waveform display, do one of the following:
m Choose View > Time Ruler Units, then choose a format from the submenu.

m Control-click along the left edge of the waveform display where the sample units 
appear, then choose the sample units you want from the shortcut menu.

Zooming In and Out in the Waveform Editor
You can zoom in on a specific part of an audio file to make precise edits and perform 
other tasks.

To zoom in or out, do one of the following:
m Drag the Zoom control left to zoom in for a closer view, or drag right to zoom out for a 

wider view.

m Choose View > Zoom In to zoom in one level.

m Choose View > Zoom Out to zoom out one level.

If you have a mouse with a scrollwheel connected to your computer, you can set 
Soundtrack Pro to zoom in or out when you move the scrollwheel. You can select part 
of the audio file and zoom in on the selected area, zoom in to see individual samples in 
the waveform, or zoom out to peaks.

To set Soundtrack Pro to zoom the waveform display when you move the 
scrollwheel:

1 Choose Soundtrack Pro > Preferences.

2 If the General Preferences pane is not visible, click the General button.

3 In the Timeline section of the General Preferences pane, choose “Zooms at playhead” 
from the Scrollwheel pop-up menu.

To zoom in or out using a scrollwheel:
m Move the scrollwheel up to zoom in, or move it down to zoom out.

To zoom in on a selection:
1 In the waveform display, select the area you want to zoom in on.

2 Choose View > Zoom to Selection.
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To zoom in to see individual samples:
m Choose View > Zoom To Samples.

If you have previously zoomed in to a level where individual samples are visible in the 
waveform display, choosing Zoom To Samples zooms in to the same zoom level.

To zoom out to see the entire waveform:
m Choose View > Zoom To Peaks.

If you have previously zoomed out to a level where waveform peaks are visible in the 
waveform display, choosing Zoom To Peaks zooms out to the same zoom level.

To return to the original zoom level:
m Choose View > Zoom Normal.

You can also zoom in on a selected area using the Zoom tool. For information about 
using the Zoom tool, see “Zoom Tool” on page 160.

Using the Global Waveform View
The Waveform Editor includes a Global Waveform view, located directly above the main 
waveform display. The Global Waveform view displays a miniature view of the entire 
audio file, and shows the current playhead position. The part of the audio file visible in 
the waveform display appears inside a blue rectangle. You can quickly move to 
different parts of the audio file by dragging the visible area rectangle.

To move to a different part of the audio file using the Global Waveform view:
m Drag the blue visible area rectangle to a new position.

Drag this rectangle to 
a new position.
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Viewing an Audio File in Spectrum View
When you first open the Waveform Editor, it shows the audio file in Waveform view. You 
can also view and edit an audio file in Spectrum view. In Spectrum view, the display 
shows the frequency spectrum of each channel of a stereo audio file on a scale from 0 
Hertz (Hz) to half the sample rate of the file. For example, for a 48 kHz audio file, the 
scale progresses from 0 Hz to 24 kHz.

To view an audio file in Spectrum view:
m Click the Spectrum View button above the right corner of the Global Waveform view.

The display changes to show the audio file’s frequency spectrum.

You can select parts of the audio file, apply actions, and edit the audio file in Spectrum 
view in the same way as in Waveform view. You can also change the Spectrum view 
display to show the frequency spectrum linearly or logarithmically, use different 
window functions, and change the number of samples used to calculate the view.

Spectrum View buttonWaveform View button
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To show the frequency spectrum on a logarithmic scale:
m Control-click the Sample ruler along the left edge of the display, then choose 

Logarithmic from the shortcut menu.

To show the frequency spectrum on a linear scale:
m Control-click the Sample ruler along the left edge of the display, then choose Linear 

from the shortcut menu.

To display the audio file in Spectrum view, part of the audio data for each given point 
in time is analyzed. Each method of analysis represents a slightly different compromise 
between frequency resolution and spectral leakage. You can choose between several 
different analysis methods, called window functions, used to display the frequency 
spectrum in Spectrum view.

To choose a window function for Spectrum view:
m Control-click the spectrum display, then choose a window function from the upper part 

of the shortcut menu.

You can also choose the number of samples used to calculate the spectrum display.

To choose the number of samples used for Spectrum view:
m Control-click the spectrum display, then choose a number from the lower part of the 

shortcut menu.

To return to Waveform view:
m Click the Waveform View button.

Playing Audio Files in the Waveform Editor
You can play an audio file in the Waveform Editor, so you can hear the file and any 
changes you make to it.

To play an audio file:
m Click the Play button in the transport controls (or press the Space bar). Click the Play 

button (or press the Space bar) again to stop playback.

You can set the playhead in the Waveform Editor in the same way as you set it in the 
Timeline, by clicking in the waveform display or in the Time ruler, using the transport 
controls, or using the Playhead Position value slider. For more information, see “Setting 
the Playhead” on page 51.
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Scrubbing Audio Files in the Waveform Editor
You can also scrub the audio file in the Waveform Editor. Scrubbing the audio file lets 
you hear the audio at the playhead position as you drag the playhead, so you can find 
a particular sound or event in the audio file.

To scrub an audio file:
1 Press and hold the triangular part of the playhead.

2 While holding the playhead, drag left or right at the speed you want to scrub the 
audio file.

Scrubbing is useful to help identify the part of an audio file that you want to edit. While 
you are scrubbing an audio file, you can select the part of the file that you want to edit.

To make a selection while scrubbing:
m As you move the playhead, press and hold the Shift key.

Using the Timeline Controls in the Waveform Editor
You can use the Timeline controls, located at the lower-left corner of the Project 
window, while working in the Waveform Editor. Some of these controls have slightly 
different functions in the Waveform Editor than they do in the Timeline.
Â Master Envelopes button:  You can show or hide the envelopes for the audio file. 
Â Snap button:  You can turn snap on or off in the Waveform Editor.
Â Snap To button:  You can choose the Snap To value that the playhead and other items 

snap to. In the Waveform Editor, the choices for snap are Ruler Ticks and Zero 
Crossings.

Â Track Height control:  Sets the height of the envelope rows when you show envelopes 
in the Waveform Editor.
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Editing Audio Files in the Waveform Editor
You can edit audio files in many different ways in the Waveform Editor. You can edit the 
entire file, or select part of the file to edit. 

Selecting Part of an Audio File
When you apply an action to an audio file in the Waveform Editor, the action is applied 
to the entire file unless you select part of the file. You can select different parts of the 
audio file and apply different actions to each selection. 

To select part of an audio file:
m In the waveform display, drag horizontally across the part of the waveform you want to 

select.

Some actions can only be applied to a selection. The selection can contain the entire 
audio file.

Selected area
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To select the entire audio file:
m Choose Edit > Select All.

You can select one channel (left or right) of a stereo audio file, and apply actions to 
only the selected channel. You can also select only part of one channel.

To select the left channel of an audio file:
1 Move the pointer near the upper edge of the waveform display.

The pointer changes to the letter “L.”

2 Drag the pointer to select the part of the left channel you want to work with.

As you drag, the right (lower) channel of the audio file becomes darker in the waveform 
display. You can also double-click in the upper part of the waveform display to select 
the entire left channel.

Left channel selected
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To select the right channel of an audio file:
1 Move the pointer near the lower edge of the waveform display.

The pointer changes to the letter “R.”

2 Drag the pointer to select the part of the right channel you want to work with.

As you drag, the left (upper) channel of the audio file becomes darker in the waveform 
display. You can also double-click in the lower part of the waveform display to select 
the entire right channel.

When you play a selected left or right channel, the audio from that channel plays in 
both the left and right output channels of the output. The other channel is not heard.

If you have added time or beat markers to an audio file project, you can select the area 
between two markers.

To select the area between two markers:
m Double-click the waveform display in the area between the two markers. If there are 

additional markers, you can expand the selection by dragging toward them.

Right channel selected
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Moving Between Selections
You can select different areas of the audio file to apply different actions or to play 
different areas. Any selection can include the same part of an audio file as another 
selection. As you work on the audio file, you can move back and forth between 
selections.

To move to the previous selection:
m Click the Previous Selection button above the waveform display. 

The previous selection becomes the current selection. The selection area appears 
darker than the rest of the waveform.

To move to the next selection:
m Click the Next Selection button above the waveform display. 

The next selection becomes the current selection. The selection area appears darker 
than the rest of the waveform.

Cutting, Copying, and Pasting in the Waveform Editor
You can cut, copy, and paste audio in the Waveform Editor. Cutting, copying, and 
pasting can change the length of an audio file.

To cut part of an audio file in the Waveform Editor:
1 Select the part of the file you want to cut.

2 Choose Edit > Cut (or press Command-X).

The selected part of the file is removed, and the file shortens by the cut amount.

To copy audio in the Waveform Editor:
1 Select the part of the file you want to copy.

2 Choose Edit > Copy (or press Command-C).

3 You can paste audio in the Waveform Editor. You can paste at the playhead position, 
paste mix, or paste repeat.

Next Selection buttonWaveform View button
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To paste audio in the Waveform Editor:
1 Set the playhead to the point where you want to paste the audio.

2 Choose Edit > Paste (or press Command-V).

The cut or copied audio is pasted starting at the playhead position. The audio after the 
playhead in the file moves to accommodate the pasted audio, and the file lengthens by 
the pasted amount.

You can also paste mix in the Waveform Editor. When you paste mix, the pasted audio 
is mixed (or blended) with the existing audio in the audio file. You can control the mix 
of the pasted audio and existing audio, and can crossfade the pasted audio.

To paste mix audio in the Waveform Editor:
1 Set the playhead to the point where you want to paste the audio.

2 Choose Edit > Paste Special, then choose Paste Mix from the submenu.

3 In the Paste Mix sheet, drag the Original Material Level slider to set the mix level of the 
existing audio in the pasted area.

4 Drag the Clipboard Level slider to set the mix level of the pasted audio.

5 Optionally, you can crossfade the pasted audio by selecting the Crossfade In and Out 
Points checkbox and typing crossfade values (in milliseconds) in the Fade In Length 
and Fade Out Length fields.

6 Click OK.

The cut or copied audio is mixed with the existing audio.

You can also paste repeat in the Waveform Editor. When you paste repeat, the cut or 
copied audio is pasted the number of times you specify in succession, so that each 
copy starts at the end of the previous one.

To paste repeat in the Waveform Editor:
1 Set the playhead to the point where you want to paste the audio.

2 Choose Edit > Paste Special, then choose Paste Repeat from the submenu.

3 In the Paste Repeat sheet, type the number of copies you want to paste in the field.

4 Click OK.

The copies are pasted starting at the playhead position. The audio after the playhead 
in the file moves to accommodate the pasted audio, and the file lengthens by the 
pasted amount.
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Graphically Editing Audio Files
The Waveform Editor includes four waveform editing tools you can use to graphically 
edit the audio file in the waveform display. 

Selection Tool
You can use the Selection tool to select part of an audio file, as described in “Selecting 
Part of an Audio File” on page 154. When you open the Waveform Editor, the pointer is 
a selection pointer (arrow). When you are done using another waveform editing tool, 
you can return the pointer to a selection pointer by clicking the Selection Tool button.

Sample Edit Tool
You can graphically edit samples in the audio file using the Sample Edit tool. To use the 
Sample Edit tool, the waveform display must be zoomed in enough to see individual 
samples, which appear as small squares connected by a thin line.

To edit samples using the Sample Edit tool:
1 Click the Sample Edit Tool button above the time display.

The pointer becomes a Sample Edit pointer.

2 Zoom in on the part of the waveform you want to edit. 

3 To graphically edit samples, do one of the following:

Â Drag a sample up or down to a new value.
Â Click directly above or below a sample.
Â Drag left or right to reshape the waveform.
You can also edit samples numerically in the waveform display.

To edit samples numerically:
1 Control-click a sample, then choose Set Value from the shortcut menu.

2 In the sheet that appears, type a new value for the sample.

3 Click OK.

Selection Tool button

Sample Edit Tool button



160 Chapter 7    Working in the Waveform Editor

 

Stretch Tool
You can time stretch all or part of an audio file to change the amount of time it 
occupies. When you stretch an audio file, the length of time changes but not the pitch 
(letting you fill dialogue, music, or other audio to a specific amount of time). For audio 
files with music or other repeating patterns, stretching the file changes the tempo of 
the music without changing the key.

To graphically time stretch an audio file:
1 Click the Stretch Tool button above the time display.

2 In the waveform display, drag horizontally across the waveform to select the part you 
want to time stretch.

The pointer becomes a Stretch pointer.

3 Drag the right edge of the selection left to shorten the selected area, or drag it right to 
lengthen the selected area.

Note:  Stretching an audio file by a large amount can degrade the sound quality of the 
audio file.

Zoom Tool
You can zoom in on a specific part of the waveform display to make precise edits.

To zoom in using the Zoom tool:
1 Click the Zoom Tool button above the time display.

The pointer changes to a Zoom pointer.

2 In the waveform display, do one of the following:

Â Click to zoom in.
Â Option-click to zoom out.
Â Drag horizontally to select the part of the waveform you want to zoom in on.
The waveform display zooms in on the selected area.

For information on other ways to zoom in and out in the waveform display, see 
“Zooming In and Out in the Waveform Editor” on page 149.

Stretch Tool button

Zoom Tool button
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Processing Audio Files
You can process audio files in the Waveform Editor in a variety of ways. You can choose 
processing effects and other operations from the Process menu and apply them to an 
entire file, or select part of the file and apply the effect to the selection. When you 
choose an item from the Process menu, the item appears as an action in the Actions 
list. The Process menu contains the following items:

Effects Submenu
The Effects submenu contains an extensive set of professional audio effects you can 
apply to an audio file or a selection. The audio effects in the Effects submenu are the 
same as the realtime effects you can apply to tracks, busses, and outputs in the 
Timeline. For information about individual effects in the Effects submenu, see “Audio 
Effects Included With Soundtrack Pro” on page 196.

The effects included with Soundtrack Pro are categorized by type in the Effects 
submenu. Below these effect categories is a submenu for Mac OS effects. If you have 
installed third-party Audio Units effects on your computer, additional submenus for the 
third-party effects appear at the bottom of the Effects submenu.

When you apply a processing effect from the Effects submenu, the floating advanced 
settings window for the effect appears. The advanced settings window contains 
controls for previewing the effect in the Waveform Editor, bypassing, applying or 
canceling the effect, resetting effect parameters, and applying effect presets.

Â Play button:  Plays the audio file or selection with the effect.
Â Volume slider:  Controls the volume of the audio file or selection as you play it.
Â Bypass button:  Bypasses the effect so you can hear the difference in the sound of the 

audio file or selection with and without the effect.

Show/Hide Presets button

Bypass button

Play button

Volume slider

Reset button

Cancel button

Apply button
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Â Reset button:  Resets all effect parameters to their default values.
Â Cancel button:  Closes the advanced settings window without applying the effect.
Â Apply button:  Applies the effect to the audio file or selection and closes the 

advanced settings window.
Â Show/Hide Presets button:  Shows or hides the Presets drawer so you can apply effect 

presets.

For information about applying effect presets in the Waveform Editor, see “Working 
With Effect Presets” on page 217.

For information about the effects in the Effects submenu, see Chapter 9, “Working With 
Audio Effects,” on page 195.

Fade In
Choosing this command fades in the audio file or selection. The fade in progresses in 
linear fashion from the beginning to the end of the audio file or selection.

Fade Out
Choosing this command fades out the audio file or selection. The fade out progresses 
in linear fashion from the beginning to the end of the audio file or selection.

Normalize
Choosing this command normalizes (adjusts the gain of ) the audio file or selection to 
the decibel level shown in the Normalization Level field. The highest peak in the file is 
raised or lowered to the level you set, and the rest of the audio file is raised or lowered 
by the same amount. When you choose Process > Normalize, the level is set to 0 dB.

To set the normalization level:
1 Choose Process > Normalize.

2 In the Normalize dialog, drag the Normalization Level slider or select the value in the 
Normalization Level field and type a new value.

3 Click OK.

You can preview the audio file at the normalization level before closing the Normalize 
dialog. This makes it easy to set the level before normalizing the file.

To preview the file at the normalization level:
m In the Normalize dialog, select the Preview checkbox.
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Adjust Amplitude
Choosing this command raises or lowers the gain of the audio file or selection by the 
amount shown in the Amplitude Level field. When you choose Process > Adjust 
Amplitude, the level shown in the field is zero (0) dB, or unity gain.

To set the amplitude level:
1 Choose Process > Adjust Amplitude.

2 In the Adjust Amplitude dialog, drag the Amplitude Level slider or select the value in 
the Amplitude Level field and type a new value.

3 Click OK.

Silence
Choosing this command replaces the audio file or selection with complete silence. 

Invert
Choosing this command inverts the phase of each sample in the audio file or selection. 
Each sample’s amplitude is unchanged, but the phase is inverted. In the waveform 
display, the wave’s crests become troughs and vice versa.

Reverse
Choosing this command reverses the order of the samples in the audio file or selection 
so that the first sample becomes the last and vice versa.

Swap Channels
Choosing this command swaps the left and right channel of a stereo audio file or 
selection. If the file is mono, Swap Channels is disabled.

Insert
You can insert silence, noise, or a waveform in an audio file or selection. When you 
choose Process > Insert, then choose one of the three items from the Insert submenu, 
the silence, noise, or waveform is inserted at the current playhead position. The 
remainder of the audio file ripples so that it continues after the inserted silence, noise, 
or waveform.

Inserting Silence
When you choose Process > Insert, then choose Silence from the Insert submenu, the 
Insert Silence sheet appears. You can set the length of silence to insert, and choose the 
format for setting the length of the silence (any of the Time Ruler Units formats). 
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To set the length of the inserted silence:
1 In the Insert Silence sheet, choose the format you want to use from the Format pop-up 

menu.

2 In the “Length of silence to insert” value slider, do one of the following:

Â Click the left arrow to shorten the length of the inserted silence, or click the right 
arrow to increase the length.

Â Click the center of the value slider, then drag the slider that appears left or right to 
change the length of inserted silence.

Â Click the value in the value slider, then type a new value.

3 Click OK.

Inserting Noise
When you choose Process > Insert, then choose Noise from the Insert submenu, the 
Noise Generator dialog appears. You can set the type of noise to insert, set the length 
of the inserted noise, choose the format for setting the noise length (any of the Time 
Ruler Units formats), and set the volume of the inserted noise. 

The inserted noise can be white noise (emphasizing higher frequencies) or pink noise 
(equal distribution of frequencies).

To choose the type of noise to insert:
m In the Noise Generator dialog, choose the type of noise from the Waveform Type pop-

up menu.

To set the length of the inserted noise:
1 In the Noise Generator dialog, choose the format you want to use from the Duration 

pop-up menu.

2 In the Duration value slider, do one of the following:

Â Click the left arrow to shorten the length of the inserted noise, or click the right 
arrow to increase the length.

Â Click the center of the value slider, then drag the slider that appears left or right to 
change the length of inserted noise.

Â Click the value in the value slider, then type a new value.

3 Click OK.
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To set the volume level of the inserted noise:
m In the Noise Generator dialog, drag the Volume slider left or right to set the noise level. 

You can also type a level (in decibels) in the Volume field.

Inserting a Waveform
When you choose Process > Insert, then choose Waveform from the Insert submenu, 
the Wave Generator dialog appears. You can set the type of waveform to insert, set the 
length of the inserted waveform, choose the format for setting the waveform length 
(any of the Time Ruler Units formats), and set the volume of the inserted waveform. 

The inserted waveform can be a sine, sawtooth, square, or triangle wave.

To choose the type of waveform to insert:
m In the Wave Generator dialog, choose the type of waveform from the Waveform Type 

pop-up menu.

To set the frequency of the inserted waveform:
m In the Wave Generator dialog, drag the Frequency slider left or right to set the 

frequency. You can also type a frequency (in Hertz) in the Frequency field.

To set the length of the inserted waveform:
1 In the Wave Generator dialog, choose the format you want to use from the Duration 

pop-up menu.

2 In the Duration value slider, do one of the following:

Â Click the left arrow to shorten the length of the inserted waveform, or click the right 
arrow to increase the length.

Â Click the center of the value slider, then drag the slider that appears left or right to 
change the length of the inserted waveform.

Â Click the value in the value slider, then type a new value.

3 Click OK.
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Time Stretch
You can time stretch an audio file or selection. When you time stretch an audio file, you 
change the duration (length) of the file without changing the frequency (pitch) of the 
file. For example, for a file containing music, the tempo of the music is changed, but 
not the pitch. When you time stretch an audio file, you can choose the format for time 
values you enter.

To time stretch an audio file:
1 Select the part of the file you want to time stretch (it can be the entire file).

2 Choose Process > Time Stretch.

The Time Stretch sheet appears.

3 In the Time Stretch sheet, choose the format for setting the amount to time stretch the 
file from the Format pop-up menu.

4 In the “Length of selection” value slider, do one of the following:

Â Click the left arrow to shorten the length, or click the right arrow to increase the 
length.

Â Click the center of the value slider, then drag the slider that appears left or right to 
change the length.

Â Click the value in the value slider, then type a new value.

5 Click OK.

Adding Ambient Noise
When editing an audio file, you may want to remove some sounds from the file while 
preserving the room tone or other ambient background noise in the file. 
Soundtrack Pro features two commands, Set Ambient Noise Print and Apply Ambient 
Noise, that you can use together to add ambience to the file.

Set Ambient Noise Print
The Set Ambient Noise Print command lets you copy part of an audio file containing 
only ambient noise that you want to add to another part of the file (or another file). 

To copy part of an audio file to ambient noise:
1 In the waveform display, select the part of the audio file containing only ambient noise.

2 Choose Process > Set Ambient Noise Print.

The ambient noise is stored in a special buffer separate from the Clipboard, and is 
saved to the project.
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Apply Ambient Noise
The Apply Ambient Noise command applies the ambient noise stored in the ambient 
noise buffer to the audio file or selection. 

To apply ambient noise to an audio file:
1 In the waveform display, select the part of the audio file to which you want to apply the 

ambient noise.

2 Choose Process > Apply Ambient Noise.

The ambient noise replaces the selected part of the file. If the selection is longer than 
the copied ambient noise, the ambient noise repeats to fill the selection.

Convert to Mono
Choosing this command converts a stereo audio file to mono. You can choose whether 
to convert the file to mono by using only the left channel, using only the right channel, 
or combining the two channels. Combining the left and right channels sums them as 
an equal gain mix.

To select how a stereo file is converted to mono:
1 Choose Process > Convert to Mono.

2 In the Convert to Mono dialog, select the button corresponding to the method by 
which you want to convert the file to mono.

3 Click OK.

The Convert to Mono action converts the entire stereo file to mono. You cannot 
convert only a selection of a file to mono. The Convert to Mono action flattens the file, 
removing existing actions from the Actions list. For information about flattening 
actions, see “Flattening Actions” on page 174.

Resample
Choosing this command resamples the audio file to a new sample rate. 

To choose the new sample rate:
1 Choose Process > Resample.

2 In the Resample sheet, choose a sample rate from the Sample Rate pop-up menu. You 
can also type a sample rate (in Hertz) in the Sample Rate field.

3 Click OK.

The Resample action flattens the file, removing existing actions from the Actions list. 
For information about flattening actions, see “Flattening Actions” on page 174.
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Reducing Noise
Some audio files contain unwanted noise, making it difficult to hear the voices, music, 
or other content of the file. Soundtrack Pro features two commands, Set Noise Print 
and Reduce Noise, that you can use together to reduce noise in an audio file or 
selection. 

Set Noise Print
The Set Noise Print command lets you select part of an audio file containing only the 
noise that you want to remove as a “noise print.” The noise print provides a signature of 
the frequencies to reduce or remove from the file. 

Setting the noise print before reducing noise is optional. If you do not set a noise print 
before using the Reduce Noise command, Soundtrack Pro will extract a noise print 
from the selected part of the audio file.

To set part of an audio file as a noise print:
1 In the waveform display, select the part of the audio file containing only the noise you 

want to reduce. 

2 Choose Process > Set Noise Print.

The selected noise is stored as a noise print.

Reduce Noise
The Reduce Noise command uses the frequency content of the noise print to reduce 
noise in the audio file or selection. 

To reduce noise using the noise print:
1 In the waveform display, select the part of the audio file in which you want to reduce 

noise.

2 Choose Process > Reduce Noise.

The Reduce Noise dialog appears. In the Reduce Noise dialog, you can optionally set 
the noise threshold and tone for noise reduction. You can also preview the noise 
reduction with the dialog open.

The noise threshold determines the level below which audio in the noise print is 
considered to be noise. Lowering the threshold results in only very low signals being 
reduced, while raising the threshold results in more high level signals being reduced.
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To set the threshold of the noise reduction:
m In the Reduce Noise dialog, drag the Noise Threshold slider left to lower the threshold 

or drag it right to raise the threshold. You can also type a value (in decibels) in the 
Noise Threshold field.

To change the tone of the noise reduction:
m In the Reduce Noise dialog, drag the Tone Control slider left to preserve more low 

frequency content (bass) or drag it right to preserve high frequency content (treble) 
during noise reduction. 

You can preview noise reduction with the Reduce Noise dialog open, and adjust the 
threshold and tone of noise reduction. You can also hear the audio file or selection with 
and without noise reduction, and hear only the noise to be removed.

To preview the file with noise reduction:
m Click the Play button in the lower part of the Reduce Noise dialog.

To set the preview volume level:
m Drag the Volume slider in the lower part of the Reduce Noise dialog left to lower the 

volume or right to raise the volume. 

To compare the file with and without noise reduction:
m Click the Bypass button to hear the file without noise reduction. Click the button again 

to hear the file with noise reduction.

To hear only the noise to be removed:
m Select the Noise Only checkbox. 

To use a noise reduction preset:
1 In the Reduce Noise dialog, click Show Presets.

The Presets drawer appears.

2 In the Presets drawer, select a preset from either the Factory Presets or User Presets list.

3 Click Apply.
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Show Realtime Effects
In addition to processing effects, you can apply realtime effects to an audio file project.
The Show Realtime Effects command shows the Effects tab with any realtime effects 
applied to the current audio file project. You can apply realtime effects to the project in 
the Effects tab, and can automate realtime effect parameters in the Waveform Editor.

To show realtime effects for the current audio file project:
m Choose Process > Show Realtime Effects.

Bounce Realtime to Action
Choosing this command bounces any realtime effects applied to the audio file project, 
and the project’s envelopes, to an action in the Actions list, letting you turn these 
effects and envelopes on or off, and reorder them in the list.

To show realtime effects and envelopes to an action:
m Choose Process > Bounce Realtime to Action.

Once you bounce realtime effects and envelopes to an action, the realtime effects are 
deleted from the project, and the envelopes are reset to their default values.

Some effects, including reverb and delay, add audio that extends past the end of the 
file. This is called an effect “tail.” When you bounce realtime effects to an action, if any 
of the effects creates an effect tail that extends past the end of the audio file, the file 
lengthens to include the effect tail.

Working With Actions
Actions give you an extremely flexible and powerful way to edit audio files in the 
Waveform Editor. You can apply an action to an entire file or a selected part of the file, 
including applying an action to only one channel of a stereo audio file. You can turn 
individual actions on or off and reorder actions in the Actions list, changing the 
sequence in which the actions change the audio file. You can adjust action settings 
after applying the action, and can flatten actions.
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Applying Actions
You start working with actions by applying an action to the audio file or the currently 
selected part of the file.

To apply an action:
1 With the file open in the Waveform Editor, choose an item from the Process menu.

The item appears in the Actions list.

2 Some actions have a dialog that appears when you choose the item from the Process 
menu. Adjust the settings in the dialog, then click Apply.

The action is added to the Actions list, and the waveform display updates to show the 
change to the audio file. You can hear the change when you play the project. Some 
actions may take a moment to apply. In this case, a progress bar appears indicating 
that the action is being applied.

Some effects, including reverb and delay, add audio that extends past the end of the 
file. This is called an effect “tail.” When you apply a processing effect that produces an 
effect tail to an audio file in the Waveform Editor, the file is lengthened to include the 
tail until the point at which the tail falls below –96 dB. If you apply a processing effect 
that produces a tail to a selection, the tail is mixed with the audio following the 
selection. If the tail extends past the end of the file, the file is lengthened to include the 
effect tail until the point at which the tail falls below –96 dB.

Action Insert bar

Actions

Actions/Analysis buttons Actions menu

Effects button
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Editing Actions
Many actions have settings that you can edit. When you apply an action that has 
editable settings, a dialog or sheet appears, letting you edit the action’s settings. You 
can edit an action’s settings at any time you are working in the Waveform Editor.

To show an action’s settings, do one of the following:
m In the Actions list, select the action you want to edit, then choose “Edit Settings For 

[action name]” from the Actions pop-up menu.

m In the Actions list, Control-click the action you want to edit, then choose “Edit Settings 
For [action name]” from the shortcut menu.

m Double-click the action in the Actions list.

If the action has no editable settings, the Edit Settings menu item appears dimmed.

Turning Actions On and Off
You can turn individual actions on and off in the Actions list and hear the result when 
you play the audio file. The waveform display updates to show the change to the audio 
file. Depending on the length of the file, turning actions on and off can take time.

To turn an action off: 
m In the Actions list, deselect the checkbox next to the action name.

To turn an action on: 
m In the Actions list, select the checkbox next to the action name. 

Reordering Actions
You can reorder actions after applying them to an audio file. The order in which effects 
and other actions occur can drastically change the resulting sound of the audio file. 
Depending on the length of the file, reordering actions can take time.

To reorder actions:
m In the Actions list, drag the actions you want to reorder up or down to new positions. 

You hear the change when you play the audio file. The waveform display updates to 
show the change to the audio file.
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Using the Action Insert Bar
The Action Insert bar appears as a purple bar along the left side of the Actions list. As 
you apply actions, the Action Insert bar moves below the last action applied. 

You can move the Action Insert bar up or down to a new position in the Actions list. 
Only actions before the Action Insert bar are heard when you play the project, so you 
can control which actions are heard by moving the bar. The purple strip to the left of 
the checkboxes in the Actions list indicates the actions that are heard when you play 
the project.

When you choose an item from the Process menu, it is applied directly following the 
Action Insert bar. By moving the bar, you set where in the list the next action is applied.

To set the position of the next applied action:
m Drag the Action Insert bar up or down in the Actions list to the position you want.

Action Insert bar
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Reversing the Order of the Actions List
You can reverse the order in which actions are shown in the Actions list, so the last 
action applied appears at the top of the list. This is useful when your project has a large 
number of actions.

To reverse the order of the Actions list:
m Click the triangle at the upper-right corner of the Actions list. Click the triangle again to 

return the list to its default order.

When you reverse the order of the Actions list, the Action Insert bar appears at the top 
of the list instead of at the bottom. You hear actions below the Action Insert bar in the 
list, rather than above it. When you choose an item from the Process menu, it is applied 
directly above the position of the Action Insert bar.

Reversing the order of the Actions list affects only the visual appearance of the list. The 
order in which actions are applied to the audio file is unchanged.

Flattening Actions
You can flatten the actions in a project to a single action. Flattening actions renders 
the actions into the file, reducing the complexity of the file and the file size. When you 
flatten actions, all existing actions are removed from the Actions list, and you can no 
longer reorder the actions or edit their action settings, unless you undo flattening the 
actions. 

Some items in the Process menu, including Convert to Mono and Resample, flatten all 
actions in the project.

To flatten all audible actions:
1 Move the Action Insert bar directly below the last action you want to flatten.

2 Do one of the following:

Â Choose Process > Flatten Audible Actions.
Â Choose “Flatten audible actions” from the Actions pop-up menu.
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To flatten all actions, do one of the following:
m Choose Process > Flatten All Actions.

m Choose “Flatten all actions” from the Actions pop-up menu.

Comparing the Project With and Without Actions
When you are adding and adjusting actions, you may want to compare the results of 
your changes to the original file.

To hear the file without actions:
1 Choose “Play without actions” from the Actions pop-up menu.

2 Click Play or press the Space bar.

To hear the file with all actions:
1 Choose “Play with all actions” from the Actions pop-up menu.

2 Click Play or press the Space bar.

To hear the file with only selected actions:
1 In the Actions list, deselect the checkboxes for the actions you do not want to hear.

2 Click Play or press the Space bar.

When you deselect an action, its settings are saved and are available when you select 
the action again.

Comparing the Last Two Actions
You can quickly compare the last two actions applied to an audio file or selection. 
This is helpful when you want to try out two similar actions, and hear which one you 
like better.

To compare the last two actions:
1 Do one of the following:

Â Choose Process > A/B Last Two Actions.
Â Choose A/B from the Actions pop-up menu (or press Command-F1).

2 Click Play or press the Space bar.

You hear the first of the two actions. The checkbox of the second action appears 
deselected in the Actions list.

3 Do one of the following:

Â Choose Process > A/B Last Two Actions again.
Â Choose A/B from the Actions pop-up menu (or press Command-F1) again.
You hear the second of the two actions. The checkbox of the first action appears 
deselected in the Actions list.
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Deleting Actions
You can delete an action if you decide you no longer want it in the project.

To delete an action:
m Select the action in the Actions list, then press Delete.

Limitations of Actions That Change the File’s Length
Some actions change the overall length of the audio file by inserting or deleting audio. 
These include inserting silence, noise, or a waveform, time stretching, and deleting part 
of a file. Recording audio, pasting, and adding an effect with a “tail” can also change the 
file’s length. In the Actions list, the selection checkbox for each action that changes the 
file’s length appears red, making it easy to visually distinguish those actions.

Each selection you make in the Waveform Editor applies to a specific range of time, and 
each action applies to a range of time defined by the selection at the time the action is 
applied. Because selections and actions apply to a range of time, changing the file’s 
length can change the audio to which a selection or action applies. In the Waveform 
Editor, you see the selection remain in the same place (the same range of time as 
shown in the Time ruler) and see the waveform under the selection change.

When you apply an action that changes the file’s length, any existing selections apply 
to the same range of time, but the audio occupying that range of time may be different 
than when you applied the action. For example, if you select a range of time beginning 
five seconds after the start of an audio file, then insert one second of silence at the 
beginning of the file, the selection still begins five seconds after the start of the file, but 
the audio at the beginning of the selection corresponds to what was previously four 
seconds after the start of the file.

If a project includes an action that increases the file’s length, and you turn off or reorder 
that action, any selection that includes audio added by the length-changing action may 
extend past the end of the shortened file. In this case, the selection applies to the 
remaining audio in the selected range of time, but has no effect past the end of the file. 
For example, if you have a five-second project that includes a one-second Insert Silence 
action at the beginning of the project, and you select the last half-second of the project, 
then turn off the Insert Silence action, the selection applies to the last half-second of 
the project. However, the remaining half-second of the selection is empty.
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Analyzing an Audio File
Soundtrack Pro includes a set of audio analysis tools. You can analyze an audio file for 
common problems such as clicks and pops, hum, phase issues, and clipping, and fix 
them individually or in a single operation. When you analyze an audio file, you can 
select which types of analysis to perform.

To show the analysis lists and tools:
m In the Waveform Editor, click the Analysis button.

The Analysis Type list, Parameter list, and Analysis Results list replace the Actions list in 
the window. 

To analyze an audio file:
m Click the Analyze button, located below the Parameter list.

Analysis Type list Parameter list

Analyze button

Analysis Results list

Fix buttons and 
Magnify button
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Types of Audio Analysis
The following types of analysis can be performed in the Waveform Editor:

Clicks and Pops
Sudden, short peaks in the audio file can result from a variety of causes, including 
mechanical defects in analog recordings. You can set the threshold above which 
Soundtrack Pro considers peaks to be clicks or pops.

(Power Line) Hum
Power lines and other electrical equipment can produce a steady hum, often at 50 or 
60 Hz. The hum can also include low-order harmonics of the fundamental frequency.

DC Offset
DC offset is a shift in the audio, causing the positive and negative parts of the signal 
not to average to zero. DC offset can limit the dynamic range of an audio file.

Phase Issues
Phase issues can result from a distorted or inaccurate stereo image, caused by poor 
microphone placement or other issues. When converting a stereo file to mono, the 
presence of phase issues can cause the left and right channels to cancel each other out 
partially or completely.

Clipped Signal
A clipped or overloaded signal can result from several causes, including poor gain 
staging in a preamp during recording, bad electrical cables, or surface damage to an 
analog recording.

Silence
Silence detects parts of the audio file at which the audio signal falls to zero (0). You can 
set the threshold below which Soundtrack Pro considers the signal to be silence.

To select the types of analysis to perform:
1 In the Analysis Type list, select the checkboxes next to the types of analysis you want to 

perform on the audio file.

2 To analyze the file, click Analyze.
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Setting Analysis Parameters
The Clicks and Pops and Silence analysis types have parameters you can set. Each type 
has a Threshold slider you can drag to set the threshold for detecting clicks and pops or 
detecting silence.

To set analysis parameters:
1 In the Analysis Type list, click the disclosure triangle for the analysis types for which you 

want to set parameters.

2 Drag the Threshold slider left to lower the threshold or right to raise the threshold. You 
can also type a value in the Threshold field.

Reading Analysis Results
When you analyze an audio file, the problems detected through analysis are shown in 
the Results list. For each item, the following information appears in the Results list.

Â Status:  Shows whether the problem is fixed or not fixed.
Â Problem:  Shows the analysis type to which the problem belongs.
Â Start:  Shows the point at which the problem begins.
Â Length:  Shows the duration of the problem.
Â Channels:  Shows whether the problem occurs in the left channel (L), the right 

channel (R), or both channels (LR) of a stereo audio file.

You can select items in the Results list. When you select an item in the Results list, the 
part of the audio file to which the problem applies becomes red in the waveform 
display, making it easy to see where in the audio file the problem occurs. If you select 
multiple items, the parts of the audio file to which any of the selected problems apply 
become red.
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Zooming In on Analyzed Problems
You can zoom in on an item in the Results list using the Magnify button, so you can see 
the problem area of the audio file closely.

To zoom in on an item in the Results list:
1 In the Results list, select the item.

2 Press and hold the Magnify button, located at the bottom of the Results list.

The waveform display zooms in on the problem area for as long as you hold the 
Magnify button.

To zoom in and stay at the new zoom level:
1 In the Results list, select the item.

2 Command-click the Magnify button.

Fixing Analyzed Problems
You can select items in the Results list and fix them individually, in groups, or all 
together. When you select a single item, the part of the waveform where the item 
occurs becomes red. 

To fix an item:
m Select the item in the Results list, then click the Fix button. 

You can select multiple items to fix by Shift-clicking or Command-clicking. You can also 
fix all items in a single operation.

To fix all items in one operation:
m Click the Fix All button.

Once you have fixed a problem, you can remove it from the Results list, so that you can 
focus on remaining problems.

To clear fixed items from the Results list:
m Click the Clear Fixed button.

Magnify button
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Using Markers in the Waveform Editor 
You can insert markers in an audio file project in the same way as in a multitrack 
project. Markers can be useful for indicating where a specific sound, cue, or event 
begins or ends in the audio file. They can also be useful for indicating an area of an 
audio file you want to time stretch.

When an audio file project has two or more markers, you can select the area between 
two markers by double-clicking in the waveform display. For more information, see 
“Selecting Part of an Audio File” on page 154.

For information about inserting, naming, moving, and deleting markers, see “Working 
With Markers” on page 119.

Scripting Actions in the Waveform Editor
You can save a series of actions in the Waveform Editor as an AppleScript droplet, and 
use the droplet to modify other audio files. You can apply the actions in a saved droplet 
while you are working in Final Cut Pro using the Send To shortcut menu. You can also 
drag files or folders onto a droplet, making it easy to batch process files. 

You can edit the droplet in the AppleScript Script Editor to adjust action settings. This is 
especially helpful when you want to apply the same series of actions to multiple files, 
or when you want to apply actions repeatedly, changing one or several settings each 
time. You can apply a droplet to another audio file, or group of files, by dragging files or 
folders containing a group of files onto the droplet.

To save a series of actions as a droplet:
1 Open an audio file in the Waveform Editor.

2 Apply the actions to the audio file.

3 Choose File > Save as AppleScript.

4 In the Save dialog, type a name for the droplet.

By default, droplets are saved to the location user/Library/Scripts/Soundtrack Pro 
Scripts. Do not change the location or Soundtrack Pro and Final Cut Pro may not be 
able to find and use your saved droplets.
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Applying a Saved Droplet to a Clip in Final Cut Pro
You can apply a series of actions saved as a droplet to a clip in Final Cut Pro.

To apply a saved droplet to a clip in Final Cut Pro:
m In the Final Cut Pro Timeline or Bin, Control-click the clip, choose Send To > 

Soundtrack Pro Script from the shortcut menu, then choose the droplet you want to 
apply from the submenu.

Soundtrack Pro opens with the clip visible in the Waveform Editor. The actions are 
applied to the clip, the clip is saved with the changes, and the Waveform Editor moves 
to the background, behind the Final Cut Pro windows.
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8 Working With Video 
in Soundtrack Pro

You can import a video into a multitrack or audio file 
project, view the video as you work on your project, edit 
the video’s audio, and use markers to synchronize audio 
and video. 

When you import a video, the video appears in the Video tab of the Utility window. 
When you import a video into a multitrack project, a video clip appears in a video track 
in the Timeline. The video’s audio appears as a clip in an audio track in the Timeline, 
and can be moved and edited like other audio clips. You can mute, solo, and adjust the 
volume and pan of the video’s audio, add effects, and automate changes. You can also 
open the video’s audio in the Waveform Editor and perform actions or analysis on it.

When you import a video from Final Cut Pro, you can set the Time ruler units to match 
the timecode format of the video. Any Final Cut Pro scoring markers contained in the 
video appear as markers in the Timeline. You can also add markers in Soundtrack Pro 
and export them to Final Cut Pro with the video file. You can score markers to the 
playhead, using them to synchronize your soundtrack to the action in the video. 

You can work with video in Soundtrack Pro in several ways. You can add audio clips for 
dialogue and voiceover, music, ambience, and sound effects to the Timeline. You can 
make roundtrips between Final Cut Pro and Soundtrack Pro as you work on both the 
video and the soundtrack, or bring the final video into Soundtrack Pro to finalize the 
project. When your soundtrack is complete, you can export it as an AIFF file or save it as 
part of the video. 

Supported Video File Formats
Soundtrack Pro supports standard QuickTime-compatible file formats. You can import a 
QuickTime movie (.mov) video file into a Soundtrack Pro project, and can import an 
MPEG-2 (.m2v) if you have installed the QuickTime MPEG-2 Playback Component. Video 
files using NTSC, PAL, HD, and other formats supported by QuickTime can be imported 
into Soundtrack Pro. Imported video files can be up to four hours in length.
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Adding a Video to a Project
You can import a video file by dragging the file from the Media and Effects Manager or 
from the Finder. You can import only one video file into a project. 

To import a video file into a project, do one of the following:
m Drag the video file from the Media and Effects Manager or the Finder to the Video tab 

of the Utility window. 

m Drag the video file from the Media and Effects Manager or the Finder to the video track 
in the Timeline.

The video is displayed in the Video tab in its correct aspect ratio, and a video clip 
appears in the video track (the top track in the Timeline), letting you see the duration 
of the video in the project. The video clip starts at the beginning of the project and 
cannot be moved to another point in time. Any Final Cut Pro scoring markers included 
in the video file appear in the Timeline with an orange handle.

If the video contains audio, new audio tracks are added below the video track for each 
audio track in the movie, and the video’s audio tracks appear as audio clips in the new 
tracks. You can move, resize, and edit these audio clips like any audio clip in the 
Timeline, and can use the track controls to control volume and pan, mute or solo the 
track, and add effects or automation. 

Drag a video file to the
Video tab to import it

into the project.

The video’s audio 
appears in a new audio 
track.

A video clip appears on 
the video track.

The video appears 
in the Video tab.
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Playing the Video
When you play the project, the video plays in time with the audio in your project. You 
can also control playback of the video and the project using the video transport 
controls in the Video tab, or using keyboard shortcuts. 

Â Play from Beginning:  Starts playback from the beginning of the video.
Â Previous Frame:  Moves the video back one frame.
Â Play:  Plays the video from the current playhead position.
Â Next Frame:  Moves the video forward one frame.
Â Cycle:  Cycles playback of the video so that it repeats from the beginning each time 

the playhead reaches the end of the video.

To view the video, you can make the Video tab active or detach it from the Utility 
window and move it to another location onscreen. You can also view the video using 
an external video output device. 

Video transport 
controls
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Controlling Video Playback Using Keyboard Shortcuts
There are a number of keyboard shortcuts you can use to control playback of the video 
in the Video tab. To use keyboard shortcuts, the pointer cannot be in a text field.
Â Space bar:  Plays the video from the current playhead position. This is equivalent to 

clicking the Play button.
Â Return:  Sets the playhead to the beginning of the video. If the playback region is 

active, pressing Return sets the playhead to the beginning of the playback region. 
This is equivalent to clicking the Go to Beginning button in the transport controls.

Â Command-Left arrow:  Moves the video back (closer to the beginning) one frame. This 
is equivalent to clicking the Previous Frame button.

Â Command-Right arrow:  Moves the video forward (closer to the end) one frame. This 
is equivalent to clicking the Previous Frame button.

For a complete list of Soundtrack Pro keyboard shortcuts, see Appendix B, 
“Soundtrack Pro Keyboard Shortcuts,” on page 279.

Resizing the Video Tab
You can resize the Video tab (to any size, up to filling your entire screen), and can 
detach the Video tab.

To resize the Video tab, do one of the following:
m Drag the Resize handle at the lower-right corner of the Video tab until the tab is the 

size you want. 

m Drag the edge of the Video tab to resize it along with the other windows.

m Click the Resize button at the upper left of the Utility window while the Video tab is 
active. The Video tab resizes to fill the screen.
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Using Video Output Devices
You can connect an external video output device to your computer and play your 
project through the video output device. This can be especially useful in cases where 
you are using Soundtrack Pro as the final step in producing the overall project, or when 
you want to show the current version of the project to a client or other party while 
working on the project in Soundtrack Pro.

When you use an external video output device, the quality of the output is as high as 
the device can support. If you connect an output device capable of broadcast quality 
output, the video is displayed with more accurate colors than possible on a computer 
display, with true interlacing, correct pixel sizes, the correct aspect ratio, and broadcast 
quality refresh rates. 

Broadcast quality video output devices receive both the video and audio from a 
project, so you can connect high-quality monitors or speakers to hear the audio. 
However, using a video output device can introduce a greater amount of latency into 
the audio signal. The amount of latency may be higher than is acceptable for audio 
editing.

You can also play a project’s video externally using Digital Cinema Desktop. Using 
Digital Cinema Desktop, you can connect an Apple Cinema Display to your computer 
and play the video full-screen through the Cinema Display while using another monitor 
for editing. 

To play the video through a video output device, you must configure Soundtrack Pro to 
use the device in Soundtrack Pro Video Out Preferences.

To configure Soundtrack Pro for a video out device:
1 Choose Soundtrack Pro > Preferences, then click the Video Out button.

2 In the Video Out pane, choose the device you want to use from the Video Output 
Device pop-up menu.

The menu lists only devices that are connected to your computer.

3 Optionally, select the Use Quarter-size Frames checkbox to reduce the frames sent to 
the video output device. Sending quarter-size frames can result in better performance, 
especially for devices using FireWire DV output.

4 Click the Close button at the upper-left corner of the Preferences window to close the 
window.

You can switch the output to the video output device on or off when the project is not 
playing. The video appears in the Video tab whether output to the video output device 
is switched on or off.
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To switch off output to an external video output device:
m Choose View > Show > Show External Video.

If you have added the Video Out button to the Toolbar, you can also click the button to 
switch off the device.

To switch on output to an external video output device:
m Choose View > Show > Show External Video.

If you have added the Video Out button to the Toolbar, you can also click the button to 
switch on output to the device.

A video output device can only be controlled by one application at a time. If you hide 
Soundtrack Pro or bring another application to the foreground while playing video 
through a video output device, Soundtrack Pro maintains control of the output device 
and continues playing. If you hide Soundtrack Pro or bring another application to the 
foreground when video is not playing through a video output device, Soundtrack Pro 
releases control of the output device.

Viewing Video Details
You can view details of a video file, including the video file’s name, dimensions, length, 
frame rate, and other information. You can view details of a video file that has been 
added to a project, or a video file in the Media and Effects Manager.

To view details of a video file:
1 If the Details tab is not visible, click Details to make it active.

2 Select the video file in the Media and Effects Manager, or select the video clip in the 
Timeline.

The video file’s information appears in the Details tab.

You can preview a video file in the Details tab before you add it to a project.
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To preview a video file in the Details tab:
1 If the Details tab is not visible, click the Details button to make it active.

2 In the Media and Effects Manager, select the video file you want to preview.

3 In the Preview controls at the bottom of the window, click Play.

Working With a Video’s Audio
You can edit the audio clip of the video’s audio as with any audio clip in the project. You 
can move and resize the video’s audio, split and join it, or open it in the Waveform Editor 
for processing or analysis. You can also change the name or icon of the track containing 
the video’s audio, and use the controls in the track header to adjust volume and pan, 
mute or solo the track, change the time format, or enable the track for recording. 

If you remove the video from the project, the audio clip of the video’s audio is not 
deleted, but remains in the project. You can delete the clip separately if you want to 
remove it.

You can adjust the video’s 
audio using the controls in the 
track’s header.

The video’s 
audio track
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Using the Time Display and Time Ruler With Video
When you import a video file into a Soundtrack Pro project, the Time display and Time 
ruler adjust to show the timecode format of the video. The Time display and Time ruler 
can display time in seconds, frames, drop frames, or non-drop frames. You can choose 
the format for timecode display, and can set the video frame rate for projects not 
containing a video file. You can also set the default frame rate for new projects in the 
Project Preferences pane.

To choose the units shown in the Time display and Time ruler:
m Choose View > Time Ruler Units, then choose a time format from the submenu.

To choose the video frame rate for projects not containing a video file:
1 Choose View > Time Ruler Units > Set Video Frame Rate.

2 In the dialog that appears, choose a frame rate from the Frame Rate pop-up menu.

For more information on the Time ruler, see “Using the Time Ruler” on page 98.

The Time ruler units adjust 
to the video’s format.

The Time display adjusts to 
the video’s timecode.
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Using Markers With Video
Soundtrack Pro displays Final Cut Pro scoring markers included in a video file imported 
from Final Cut Pro. You can add time markers at points in time corresponding to 
specific timecode positions in the video clip, and align audio clips with markers using 
the snap feature. When you add a marker to a project containing a video, the video clip 
displays the frame of the video that occurs at the marker’s position in time.

For more information about adding and moving markers, see “Working With Markers” 
on page 119.

You can score both Final Cut Pro scoring markers and time markers to the playhead, 
letting you synchronize the audio with specific points in the video.

Using Final Cut Pro Scoring Markers
When you import a video file from Final Cut Pro or Final  Cut  Express  HD, 
Soundtrack Pro displays any Final Cut Pro scoring markers included in the video file in 
the Timeline. Scoring markers have an orange handle in the area above the Time ruler. 
You cannot move or edit Final Cut Pro scoring markers in Soundtrack Pro.

Using Markers to Align Audio Clips to Timecode 
You can add a time marker at a specific timecode position in a video clip, and align 
audio clips with the time marker or with a Final Cut Pro scoring marker. 

To add a time marker at a specific timecode position in a video clip, do one of 
the following:

m Type the timecode position where you want to add the marker in the Time display, 
press Return, then choose Mark > Insert Time Marker (or press M). 

m Add a time marker, Control-click the marker’s handle, then type the timecode position 
in the Edit dialog.

m Make the Details tab active, add a time marker, select the marker handle, then enter a 
new position in the Position value slider in the Details tab.

In order to add a marker at a specific timecode position, the Time ruler units must be 
set to the timecode format of the video in your project. 
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To align an audio clip with a marker:
m Make sure that snap is turned on and that Markers is selected in the View > Snap to 

menu, then drag the clip to the position of the marker in the Timeline.

Scoring a Marker to the Playhead
For tracks set to Beats-based time format, you can score a time marker or Final Cut Pro 
scoring marker to the playhead, so that you can synchronize the audio with the video. 
Scoring a marker to the playhead adjusts the tempo so that the required number of 
beats exactly fills the amount of time between the last tempo change and the marker’s 
position in the Time ruler. 

When you score a marker to the playhead, a set of special envelope points is created in 
the project’s tempo envelope, from the previous envelope point (or the beginning of 
the tempo envelope, if no previous envelope point exists) to the position of the marker. 
These special envelope points are locked and cannot be moved (but can be deleted). 
The locked envelope points, and the segment of the tempo envelope between them, 
appear red.

The tempo change created when you score a marker to the playhead is always 
instantaneous; that is, the tempo changes from the previous tempo immediately, 
without ramping. The distance between the two envelope points determines whether 
the resulting tempo change can be heard easily. If the resulting change in tempo 
sounds too abrupt, you can edit the tempo envelope to make the tempo change less 
noticeable.

With Markers selected, 
you can align a clip with 
a marker.
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To score a marker to the playhead:
1 Select the marker’s handle at the top of the Timeline, above the Time ruler.

2 Choose Mark > Score Marker to Playhead. 

You can also adjust the tempo relative to a marker’s position by Option-dragging the 
marker in the Timeline. As you drag, the red segment of the tempo envelope moves 
vertically as the tempo changes. By Option-dragging a marker, you can synchronize the 
marker’s position with the Beats-based units. 

Note:  If you score a marker to the playhead, and the tempo change resulting from the 
scoring operation sounds too noticeable or extreme, you can undo the scoring 
operation. After undoing the scoring operation, add an envelope point to the tempo 
envelope at a point after any audio clips you do not want to be affected by the tempo 
change, but before the marker to be scored, then repeat the scoring operation.

Click the marker handle at the 
top of the Timeline.

The marker is scored 
to the playhead.



Removing a Video From a Project
You can remove a video if you decide you no longer want to use it in the project.

To remove a video clip from a project, do one of the following:
m Select the video clip in the Timeline, then choose Edit > Delete (or press the Delete key).

m Control-click the video clip, then choose Remove Video from the shortcut menu.

When you remove the video from a project, the audio clip of the video’s audio is not 
deleted, but remains in the project. You can delete the clip separately if you want to 
remove it.

For information about using Soundtrack Pro with Final Cut Pro, including transferring a 
project back and forth between Soundtrack Pro and Final Cut Pro, see Chapter 14, 
“Using Soundtrack Pro With Apple Professional Applications,” on page 253.
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9 Working With Audio Effects 

You can modify the sound of your project in many ways 
using audio effects. Soundtrack Pro includes a complete 
set of professional-quality audio effects you can use in 
your projects.

You can use audio effects to add both subtle and dramatic changes to audio clips in a 
multitrack project or to an audio file project. Soundtrack Pro includes effects for 
equalization, compression, reverb, and other effects you can use to clean up audio, 
perform sound design, and enhance the sound of your audio. You can also use third-
party Audio Units effects plug-ins in both multitrack and audio file projects.

Realtime and Processing Effects
Soundtrack Pro gives you two ways to use audio effects in your projects: realtime 
effects and processing effects.

Realtime Effects
You can add realtime effects to tracks, busses, and outputs in a multitrack project, or to 
an audio file project. Realtime effects modify the audio as it passes through them, so 
you hear any changes you make, or any new audio you add, through the sound of the 
effect. Each realtime effect has effect parameters you can adjust to control how the 
effect modifies the audio. You can also automate effect parameters to create changes 
over time. 

You can create effects chains on a track, bus, output, or audio file using realtime effects. 
An effects chain is a series of effects that modify the audio in a set order. Using busses 
in the Timeline and Mixer, you can create submixes, and apply the effect to all the 
tracks in a submix with one set of controls.

For information on working with realtime effects in both multitrack and audio file 
projects, see “Working With Realtime Effects” on page 207.
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Processing Effects
You can apply processing effects to an audio file project. The Process menu includes 
an Effects submenu where you choose processing effects to add to your project. 
Processing effects are added as actions, which you can turn on or off, reorder, and 
adjust in the Actions list.

For information about working with processing effects in the Waveform Editor, see 
“Working With Processing Effects” on page 216. For information on working with 
actions, see “Working With Actions” on page 170.

Audio Effects Included With Soundtrack Pro
Soundtrack Pro includes the following types of audio effects:
Â Dynamics:  Dynamics effects let you shape the volume of your projects over time. 

Bundled dynamics effects include Compressor, Multipressor, Adaptive Limiter, and 
Noise Gate.

Â Distortion:  Distortion effects change the tone of the audio signal to recreate the 
sound of overdriven tube amplifiers or digital distortion. Bundled distortion effects 
include Bitcrusher, Clip Distortion, Distortion, Exciter, and Phase Distortion.

Â EQ and Filter:  EQ (short for equalization) effects let you change the level of selected 
frequencies. EQ provides a powerful way of shaping the sound of your projects. 
Bundled EQ effects include High Cut and Low Cut, High Pass and Low Pass filters, 
Channel EQ, Linear Phase EQ, Match EQ, and Parametric EQ.

Â Modulation:  Modulation effects delay an audio signal and shift (modulate) when the 
delayed signal plays back relative to the original signal. Bundled modulation effects 
include Chorus, Flanger, Modulation Delay, Phaser, Scanner Vibrato, and Tremolo.

Â Reverb and Delay:  Reverb effects can be used to simulate the sound of acoustic 
spaces, both realistic and unnatural. Delay effects can be used to add echoes and 
other recurring sounds. Bundled reverb and delay effects include PlatinumVerb, 
Soundtrack Pro Reverb, Stereo Delay, Tape Delay, and Space Designer, a powerful tool 
for sound design.

Â Meters and Diagnostic:  You can use realtime diagnostic effects to clean up audio files 
in a variety of ways, including pitch, intensity, and phase problems. Bundled 
diagnostic effects include Correlation Meter, MultiMeter, Test Oscillator, and Tuner. 
These are only available as realtime effects, not processing effects.

Â Miscellaneous:  Miscellaneous effects fall outside the other categories, providing 
additional ways to modify your audio. Bundled miscellaneous effects include 
Denoise, PitchShifter, Spectral Gate, Stereo Spread, SubBass, and Vocal Transformer.
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Dynamics Effects
Dynamics effects let you adjust the dynamic range (the range between the softest and 
loudest sounds) of your projects. You can use dynamics effects to make sounds more 
focused and to optimize the sound for specific playback situations. Dynamics effects 
include compressors, limiters, and noise gates. 

Compressors
Compressors work like an automatic volume control, lowering the volume whenever it 
rises above a certain level, called the threshold. But why would you want to reduce the 
dynamic level? By cutting the peak levels, the compressor lets you raise the overall 
volume of the signal. This gives the sound more focus by making the foreground parts 
stand out while preventing the background parts from becoming lost in the mix. 
Compression also tends to make sounds tighter or “punchier.” Because the peaks are 
lower, the maximum volume is reached more quickly. 

In addition, a compressor can make a project sound better when played back in 
different situations. For example, the speakers on a television set or in a car sound 
system typically reproduce a narrower dynamic range than does the sound system in a 
theater. Compressing the overall mix can help make the sound reproduce more clearly 
in lower-fidelity situations.

Compressors have two main parameters. The threshold lets you set the amplitude 
above which the compressor lowers the volume. The ratio lets you control the amount 
by which sounds above the threshold will be lowered, as a percentage of the original 
signal. 

For example, if you set the threshold to –12 dB, and the ratio to 2:1, a sound at –7 dB 
(5 dB above the threshold) is reduced by 2.5 dB, and a sound at –2 dB (10 dB above the 
threshold) is reduced by 5 dB. 

Compressors can also include parameters for attack and release. These parameters let 
you set how quickly the compressor reacts once the threshold is reached (for attack) or 
once the signal falls below the threshold again (for release). Use these parameters to 
make the compressor’s effect more subtle or more pronounced. Another parameter on 
some compressors is the knee (or soft knee), which lets you control how gradually the 
compressor transitions between no compression and the compression ratio at the 
threshold.

Compressors are typically used on vocal tracks to make the vocals prominent in the 
overall mix. They can also be used on music and sound effects tracks, but rarely on 
ambience tracks. 
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Limiters
Limiters (also called peak limiters) prevent the audio signal from exceeding a maximum 
volume level. A compressor gradually attenuates levels above the threshold, but a 
limiter puts a hard limit on any signal louder than the threshold. You use a limiter 
mainly to prevent clipping. 

Noise Gates
A noise gate alters the signal in the opposite direction from a compressor. While a 
compressor lowers the volume of sounds above the threshold, a noise gate lowers the 
sounds below the threshold. Loud signals pass through unchanged, but softer signals, 
such as the decay of a loud instrument, are cut off. Noise gates can be used to 
eliminate low-level noise or hum from an audio signal.

Distortion Effects
Distortion effects simulate the sound of analog and digital distortion. After working to 
eliminate the digital distortion caused by clipping from a project, why would you add 
distortion as an effect? The distortion produced by overdriven vacuum tubes (which 
were used in amplifiers and music recording equipment before the development of 
digital recording technology) produces an effect which many people find pleasing, and 
which is integral to many styles of popular music. Analog tube distortion adds a 
distinctive warmth and bite to the signal. 

There are also distortion effects which intentionally cause clipping and digital 
distortion of the signal. These can be used to modify vocal, music, and other tracks to 
produce an intense, unnatural effect, or for creating sound effects.

Distortion effects include parameters for tone, which let you shape the way in which 
the distortion alters the signal, and for gain, which let you control how much the 
distortion increases the output level of the signal. 

EQ and Filter Effects
EQ is likely the most common audio effect used in postproduction. You can use EQ to 
shape the sound of a project by adjusting specific frequencies or frequency ranges. 
Using EQ, you can create both subtle and extreme changes to the sound of your 
projects.

Most EQ effects make use of filters. As the name suggests, a filter allows certain 
frequencies to “pass through” to the output while stopping or attenuating other 
frequencies. EQ effects include highpass, lowpass, and band pass filters. 

When the audio signal passes through an EQ filter, the frequencies that pass through 
can be raised or lowered in volume. Raising and lowering frequencies using EQ is often 
referred to as boosting and cutting frequencies. You can create many changes to the 
sound of your project by boosting and cutting various frequencies. 
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Frequency Ranges Used With EQ
All musical sounds can be categorized into one of three basic frequency ranges: bass, 
midrange, or high (also called treble). These can be further divided to include low bass, 
low and high midrange, and low and high highs. The following table describes some of 
the sounds affected by each range:

Name Frequency range Description

High High 8–20 kHz Includes cymbal sounds and 
highest harmonics of 
instruments. Boosting 
frequencies in this range slightly 
can add sparkle and presence.

High 5–8 kHz This range corresponds roughly 
to the treble tone control on a 
stereo. Boosting frequencies in 
this range can add brightness 
and shine.

Low High 2.5–5 kHz Includes the higher harmonics of 
voices and musical instruments. 
This range is important for 
adding presence. Excessive 
boosting in this range can sound 
shrill or harsh.

High Midrange 1.2–2.5 kHz Includes the consonants of 
voices and the high harmonics 
of musical instruments, 
especially brass instruments. 
Excessive boosting in this 
range can create a pinched, 
nasal sound.

Midrange 750 Hz–1.2 kHz Includes the vowels of voices 
and the harmonics of musical 
instruments that create tone 
color. 

Low Midrange 250–750 Hz Includes the fundamentals and 
lower harmonics of voices and 
musical instruments; careful 
EQing of each can keep them 
from competing. Excessive 
boosting in this range can result 
in muddy and unclear audio; 
excessive cutting can produce 
thin-sounding audio.
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Note:  The frequencies shown for each range are approximate. Any division of sound 
into frequency ranges is somewhat arbitrary, and is meant only to give a general 
indication of each range. 

Roll-Off Filters
The simplest types of EQ effects are roll-off filters, which include lowpass, highpass, 
bandpass, and shelf filters. Lowpass filters affect all frequencies above a specific 
frequency, called the cutoff frequency. Frequencies above the cutoff are attenuated or 
“rolled off” gradually, usually by a fixed number of decibels per octave. Highpass filters, 
by contrast, affect all frequencies below their cutoff frequency. Bandpass filters exclude 
all frequencies close to their center frequency. You can set the center frequency, and also 
set the bandwidth or Q, which specifies how wide a range of frequencies around the 
center frequency are affected.

These EQs include parameters for setting the cutoff frequency. Shelf filters add 
parameters to control the gain (the amount of boost or cut). You can use roll-off filters 
as “broad brush” effects to boost or cut a large range of frequencies. 

Bass 50–250 Hz Corresponds roughly to the bass 
tone control on a stereo. 
Includes the fundamental 
frequencies of voices and of 
musical instruments. Excessive 
boosting in this range can 
sound boomy and thick.

Low Bass 50 Hz and below Also called sub bass. Very little of 
the sound of voices or musical 
instruments falls in this range. 
Many sound effects used in 
movies, such as explosions and 
earthquakes, fall in this range.

Name Frequency range Description
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Graphic EQs
Graphic EQs give you a set of filters (often with 10 or 31 filters), each with a set center 
frequency and bandwidth. Using a graphic EQ, you can shape a wide variety of 
frequencies throughout the frequency range. Graphic EQs can be used to shape the 
sound of the overall project mix. 

Parametric EQs
Parametric EQs are similar to bandpass EQs, but provide a greater amount of control, 
and can be used for extremely precise adjustments. With a parametric EQ, you can set 
the center frequency, the gain, and the bandwidth. Used carefully, a parametric EQ can 
help a track cut through the mix, or help a track or project sound fuller. Parametric EQs 
can also be used to remove specific, unwanted frequencies from a mix. 

Modulation Effects
Modulation effects begin with a delayed signal, like time-based effects, but vary (or 
modulate) the delay time, typically using an LFO. This can be used to double a sound, 
making it seem stronger and “fatter,” to simulate a group of voices or instruments 
playing together, or to add a distinctive character to the sound. Modulation effects 
include chorus, phase shifters, and flangers.

Chorus
Chorus effects play back multiple repetitions of the delayed signal (like reverbs), but 
vary the delay time for each one, using an LFO. As the name implies, this effect can 
strengthen the sound, and create the impression that the sound is being played by 
many instruments or voices in unison. The slight variations in delay time created by the 
LFO simulate the subtle differences in timing and pitch heard when several people play 
together. Using chorus also adds fullness or richness to the signal, and can add 
movement to low or sustained sounds. 
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Phase Shifters
Phase shifters produce a characteristic “whooshing” sound by combining the original 
signal with a copy of the signal that is slightly out of phase with the original. This 
means that the amplitudes of the two signals’ sound waves reach their highest and 
lowest points at slightly different times. The time between the two signals is 
modulated, typically using an LFO. As the two signals go in and out of phase, certain 
frequencies, called notch frequencies, are created, which give phase shifters their 
distinctive sound. 

The main difference between chorus and phase shifting is the amount of delay time. 
Chorus effects typically use delay times between 20 and 30 milliseconds (ms), while 
phase shifters (and flangers, discussed next) typically use shorter delay times, between 
1 and 10 ms. 

Flangers
Flangers work in much the same way as do phase shifters, but additionally change the 
pitch of the delayed signal slightly. Flanging is typically used to create a more extreme 
change than phase shifting, sometimes described as adding a “spacey” or “underwater” 
effect.

All of the modulation effects include parameters for the delay rate (also called speed or 
frequency), which let you set the minimum delay time; depth (also called width or 
intensity), which you use to set how much the LFO modulates the delay time; and mix, 
which you use to control the ratio of the effected (wet) signal to the original (dry) 
signal. They can also include parameters for feedback (or regeneration), which add part 
of the output back into the input signal. 

Reverb and Delay Effects
Reverbs and delays work by copying a part of the audio signal, delaying it for a brief 
period of time, and then playing it back with the original signal. The delayed signal can 
be played back multiple times, and can be modified in a variety of ways.

Delay
A delay effect stores the audio signal, and then plays back each repetition at a regular 
rate of time after the original signal. Delays can be used for doubling individual sounds 
(for example, making it sound as if a group of instruments is playing the same melody), 
to achieve echo effects (making it sound as though the sound was occurring in an 
immense space), and to enhance the stereo position of tracks in a mix. Delay effects are 
not commonly used on an overall mix except to achieve special effects (such as to 
create an “otherworldly” sound).
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Delay effects let you set the delay time, the time between the original signal and the 
delayed signal. Delays often provide parameters for feedback (also called regeneration), 
which let you set how much of the delayed signal is fed back into the delay’s input, 
creating more repetitions of the delay (like the number of “bounces” in an echo). 
Specific types of delay have other parameters: Tap tempo delays let you set the delay 
time by physically tapping a key or controller; stereo delays include parameters for the 
pan position of the output signal, which can be shifted over time using a low-
frequency oscillator (called an LFO). 

Reverb
Reverberation, usually shortened to reverb, simulates the sound of acoustic 
environments such as rooms, concert halls, caverns, or the sound of infinite space. In 
any acoustic space, sounds echo off the surfaces of the space (the floor, walls, and 
ceiling) over and over, gradually dying out until they become inaudible. Reverb effects 
consist of thousands of delays, of varying lengths and intensities, that simulate these 
natural echoes. Reverb helps define the sense of space in which sounds take place, and 
can be used to simulate both realistic and fantastic acoustic environments.

The first form of reverb actually used a room with hard surfaces (called an echo 
chamber) to add echoes to the signal. Mechanical devices, including plates and springs, 
were also used to add reverberation to the output of instruments and microphones. 
Digital sound recording has made it possible to use digital reverbs, which use complex 
algorithms (sets of equations) to simulate various acoustic environments with greater 
accuracy and flexibility.

Simple reverb effects provide parameters for the decay time or reverb time, which let 
you set how long the reverb lasts before dying away, and the mix or level, which you 
use to set the ratio of the effected signal (called the wet signal) to the original (the dry 
signal). More sophisticated reverbs can include the following parameters:
Â Room type:  Lets you set the type of space the reverb will simulate: a small or large 

room, a hall, or another type of acoustic space.
Â Predelay time:  In an acoustic space, there is a short period of silence between a 

sound and the time when the initial echoes of the reverb begin. Different spaces 
have different amounts of predelay, which helps “tell” our ears how large the space is. 
Longer predelay settings also help separate the original (dry) signal from the effected 
(wet) signal, making it sound clearer and sometimes larger.

Â Early reflections:  The first echoes to arrive from the surrounding surfaces in a space 
are determined by the size and shape of the space, and “tell” our ears what type of 
space it is. 

Â Diffusion:  Lets you set the number of the echoes in the reverb. Hall reverbs typically 
have low diffusion settings, while plate reverbs typically have high diffusion settings.



204 Chapter 9    Working With Audio Effects

 

Â High-frequency and low-frequency reverb time:  These parameters let you specify the 
decay of higher and lower frequencies separately. Different surfaces, such as wood 
floors and concrete walls, absorb high and low frequencies at different rates, and 
these parameters let you simulate the sound of different environments more closely.

Â Reverb envelope:  Lets you control how much the volume of the reverb changes over 
time. In natural acoustic situations, the reverb echoes decay gradually over time. You 
can re-create this gradual decay, or gate the reverb so that it cuts off more abruptly.

Meters and Diagnostic Effects
Diagnostic effects help you analyze and clean up audio in a variety of ways. Each type 
of diagnostic effect provides a different way to “look at” an audio clip or file, and each 
has a unique set of parameters. These effects are available only as realtime effects in 
the Effects tab and the Mixer, not as processing effects.

Correlation Meter
The Correlation meter displays the phase relationship of a stereo signal. A correlation of 
+1 (plus one, the far right position) means that the left and right channels “correlate” 
100% (that is, they are completely in phase). A correlation of 0 (zero, the center 
position) indicates the widest permissible left/right divergence, often audible as an 
extremely wide stereo effect. Correlation values less than zero indicate that out-of-
phase material is present, which can lead to phase cancellations if the stereo signal is 
combined into a monaural signal.

MultiMeter
The MultiMeter combines the functions of the Level Meter and Correlation Meter (as 
described above) with several other analysis tools: 
Â A Spectrum Analyzer
Â A Goniometer for judging the phase coherency in the stereo sound field

The control panel to the left of the display allows you to switch between the Analyzer 
and Goniometer and contains parameter controls for the MultiMeter. The Stereo Level 
and Correlation Meter are always visible. 
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Spectrum Analyzer
The Spectrum Analyzer divides the audio signal into 31 independent frequency bands. 
Each frequency band represents one third of an octave. The filter curves comply to IEC 
document 1260. 

You turn on the Spectrum Analyzer by clicking the Analyzer button. Turning on the 
Spectrum Analyzer turns off the Goniometer. The four buttons below determine what 
portion of the input signal the Analyzer is displaying. You can choose between Left or 
Right channel only. LR max shows the maximum band levels of either channel, while 
Mono displays the levels of the stereo signal summed to mono.

The View options determine the level represented by the top line of the scale in the 
display (Top; range: –40 to +20 dB) and the overall dynamic range of the Spectrum 
Analyzer (Range; range: 20 to 80 dB). These two parameters can also be set directly in 
the display: By dragging directly on the bar graph, you can shift the top line of the 
display. Dragging directly on the dB scale allows you to compress or expand the scale’s 
range. The View options are useful when analyzing highly compressed material as you 
can identify smaller level differences more easily by moving and/or reducing the 
display range. 

There are three display respond modes: RMS Slow, RMS Fast, and Peak. RMS Slow and 
RMS Fast modes show the effective signal average (Root Mean Square) and offer a 
good representation of the perceived volume levels. Peak mode shows level peaks 
accurately. 

Goniometer
The Goniometer helps you to determine the coherence of the stereo image. Using the 
Goniometer, you can see phase problems as trace cancellations along the center-line 
(M=mid/mono). Goniometers developed when early two channel oscilloscopes first 
appeared. Users would connect the left and right stereo channels to the X and Y inputs 
while rotating the display by 45 degrees, resulting in a useful visualization of the 
signal’s stereo phase.

The signal trace slowly fades to black, imitating the glow of the tubes found in older 
Goniometers, and at the same time enhancing readability. 

Clicking the Goniometer button turns on the Goniometer and turns off the Spectrum 
Analyzer. You can use the Auto Gain display parameter in order to obtain a higher 
readout on low-level passages. Auto Gain allows the display to automatically 
compensate for low input levels. You can set the amount of compensation with the 
Auto Gain parameter, or set Auto Gain by dragging directly in the display area of the 
Goniometer. 

Note:  Auto Gain is a display parameter only and increases the display for better 
readability. The actual audio levels are not touched by this parameter. 
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Miscellaneous Effects
Miscellaneous effects don’t fall into any of the other categories. They include denoising 
effects, pitch shifting effects, stereo enhancers, bass enhancers, and effects used to 
transform the sound of vocals. Each effect gives you a different way to modify the 
audio, and includes a unique set of parameters.

Denoiser
Using the Denoiser, you can eliminate or reduce many kinds of low-level noise (noise 
floor) from an audio signal. The main parameters of the Denoiser are Threshold, Reduce, 
and Noise Type. The Threshold parameter sets how high the noise floor is for the audio 
signal. The recommended method for setting the Threshold is to find a passage where 
you hear only noise, then set the Threshold so that signals at this volume level are 
filtered out.

The Reduce parameter sets the level to which amount the noise floor is reduced. You 
use the Noise Type parameter to set the type of noise that the Denoiser reduces. There 
are three choices of noise type:
Â Setting the Noise Type to 0 (zero) causes the Denoiser to reduce “white noise” (all 

frequencies reduced equally).
Â Setting the Noise Type to a positive value causes the Denoiser to reduce “pink noise” 

(harmonic noise; greater bass response).
Â Setting the Noise Type to a negative value causes the Denoiser to reduce “blue noise” 

(hiss, sibilants, tape noise).
The Denoiser recognizes frequency bands with a lower volume and less complex 
harmonic structure, and then reduces them to the desired dB value. This method is not 
completely precise, and neighboring frequencies are also reduced. Using the Denoiser 
at too-high settings can produce the “glass-noise” effect, which is usually less desirable 
than the existing noise. 

There are three smoothing parameters that you can use to minimize the “glass-noise” 
effect: Frequency smoothing, Time smoothing, and Level smoothing. Raising the 
Frequency smoothing slider results in a smoother transition of denoising to the 
neighboring frequencies. When the Denoiser recognizes that only noise is present in a 
certain frequency band, the higher the Frequency Smoothing parameter is set, the 
more it will also change the neighboring frequency bands to avoid glass noise.

By adjusting the Time smoothing slider, you can set the amount of time the Denoiser 
takes to reach maximum noise reduction. By adjusting the Level smoothing slider, you 
can set a factor for a smoother transition between adjacent volume levels. When the 
Denoiser recognizes that only noise is present in a certain volume range, the higher the 
Transition smoothing parameter is set, the more it will also change similar level values 
to avoid glass noise.
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Stereo Spread
The Stereo Spread plug-in is a useful effect for sound design or audio clean-up. It 
enhances the perception of stereo by extending the stereo base. Some stereo 
enhancing algorithms function by changing the phase of the signal, which can distort 
your mix and produce unpredictable results. Instead, the Stereo Spread plug-in extends 
the stereo base by distributing a selectable number of bands in the middle frequency 
range alternately left and right. This increases the perception of stereo without causing 
unnatural-sounding distortion of the mix.

The main parameters of the Stereo Spread plug-in are Order, Upper Intensity (Upper Int.), 
and Lower Intensity (Lower Int.). The Order parameter determines number of frequency 
bands into which the signal is divided. The Upper Intensity parameter controls the 
intensity of the base extension of the upper frequency bands. The Lower Intensity 
parameter controls the intensity of the base extension of the lower frequency bands.

Human beings perceive stereo placement of sounds mainly in the middle and high 
frequencies. If very low frequencies are distributed between the left and right speakers, 
the energy distribution for both speakers will be significantly worse. Therefore, it is 
always best to select a lower intensity setting for the lower frequency bands, and avoid 
setting the Lower Freq. below 300 Hz.

Working With Realtime Effects
You can add realtime effects to a track, bus, or output in a multitrack project, or to an 
audio file project, and then adjust the effect parameters to control the way in which 
the effects alter the sound of the track or project.

Working in the Effects Tab
The Effects tab is where you add realtime effects and adjust realtime effect parameters. 
When you click the Effects button in the header of a track, bus, output, or in the 
Waveform Editor, the Effects tab becomes active and displays the current effects 
settings for the track, bus, output, or project.

The upper part of the Effects tab contains lists of available effect categories. When you 
click an item in the Category list, the available effects in that category appear in the 
Effect list, where you can select and add them to the current effects chain.

The lower part of the Effects tab shows the effects and sends in the current effects 
chain. You can show and edit effect and send parameters in the Effect Parameters area.
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Adding Realtime Effects
You can add realtime effects in the Effects tab. You can create effects chains, which are a 
series of effects in a specific order. You can reorder effects in an effects chain at any 
time, and hear the results immediately. 

To add a realtime effect to a track, bus, or output in the Timeline:
1 Click the Effects button in the header of the track, bus, or output in the Timeline.

2 In the Effect list, select a category in the Category list to display the effects for that 
category in the Effect list.

3 In the Effect list, do one of the following: 

Â Double-click the effect you want to add.
Â Select the effect name, then click the Add Effect button. 
Â Drag the effect to the Effect Parameters area.

To add a realtime effect to a track, bus, or output in the Mixer:
m Control-click an effects slot in the channel strip of the track, bus, or output, choose Add 

Effect from the shortcut menu, then choose an effect from one of the submenus.

Select the effect you
want to add.

Click the Add Effect button, 
double-click the effect, 
or drag the effect into the 
Effect Parameters area to 
add it.

Select a category to
display its effects.
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To add a realtime effect to an audio file project in the Waveform Editor:
1 In the Waveform Editor, click the Effects button, located next to the Actions and 

Analysis buttons.

2 In the Effects tab, select a category in the Category list to display the effects for that 
category in the Effect list.

3 In the Effect list, do one of the following: 

Â Double-click the effect you want to add to the track.
Â Select the effect name, then click the Add Effect button. 
Â Drag the effect to the Effect Parameters area.
Some effects, including reverb and delay, add audio that extends past the end of the 
file. This is called an effect “tail.” When you export a project mix, or export a track, bus, 
or output with an effect that produces a tail, the exported file is lengthened to include 
the effect tail until the point at which the tail falls below –96 dB. Also, when you 
choose Process > Bounce Realtime to Action for an audio file project with a realtime 
effect that produces a tail, the rendered project is lengthened to include the effect tail 
until the point at which the tail falls below –96 dB.

Adjusting Realtime Effect Parameters
Once you’ve added a realtime effect, you can adjust the effect parameters to change 
the way the effect alters the sound of the track, bus, output, or audio file project. Each 
type of effect has its own parameters, as discussed earlier. Effect parameters are 
displayed in the Effect Parameters area of the Effects tab as a set of sliders, checkboxes, 
and pop-up menus.

To adjust realtime effect parameters:
1 Click the disclosure triangle next to the effect in the Effect Parameters area to display 

its parameters.

2 Adjust the effect parameter by dragging the slider, selecting the checkbox, or choosing 
an item from the pop-up menu. You can also adjust the parameter by entering a valid 
value in the field to the right of the parameter’s control.

Adjust a parameter by
dragging its slider.

You can also adjust the
parameter by entering a
value in the field.

Click the disclosure
triangle to display the

effect’s parameters.
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Chaining and Reordering Realtime Effects
You can add more than one realtime effect to a track, bus, output, or audio file project. 
Adding multiple effects to an effects chain is called chaining effects. 

When you add multiple effects, the effects are applied in sequence, meaning that the 
output of the first effect becomes the input for the next effect, and so on, for each 
effect in the chain. The order in which effects are applied is important, because each 
alters the input signal, which includes the output of previous effects in the chain. You 
can reorder effects and hear the difference in the way they alter the sound. 

To add multiple effects to an effects chain, do one of the following:
m Double-click the effect you want to add in the Effect list.

m Select the effect in the Effect list, then click the Add Effect button. 

The effect appears in the Effect Parameters area below any previously added effects. 
You can now set the parameters of the added effect.

Note:  Adding more than a few effects to an effects chain can cause extreme changes 
to the sound of a project. This may be what you want, but in some cases can produce 
undesirable results. Listen to the project as you add effects to be sure you are satisfied 
with the results.

Select the effect you
want to add, then click
the Add Effect button.

You can also drag the
effect to the Effect
Parameters area.
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To reorder effects in an effects chain:
m In the Effect Parameters area, drag the effect up or down in the list to change its order.

Bypassing Realtime Effects
You can turn off an effect in the Effects tab, which “bypasses” the effect in the effects 
chain. When you bypass an effect, the effect is not heard, but all effect parameters are 
retained. To hear the effect again, reselect the effect’s checkbox. This lets you hear how 
each effect in a chain alters the sound. 

To bypass an effect:
m In the Effects tab, deselect the checkbox next to the effect.

Drag effects up or down in
the list to reorder them.

Deselect the checkbox
next to the effect name

to bypass the effect.
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Adding Sends to Tracks
You can add sends to a realtime effects chain. When you add a send, the send is 
added at the end of the current effects chain. You can move the send to another place 
in the effects chain, choose the bus for a send, adjust send volume and pan, and 
bypass a send.

To add a send to a track:
m In the Effects tab, click the Add Send button.

A send appears below the last effect in the track’s effects chain. You can assign the 
send to a bus in the Effects tab or the Mixer.

Reordering Sends
You can reorder sends in the Effects tab or in the Mixer.

To reorder a send:
m In the Effect Parameters area or in the Mixer, drag the send up or down in the list to 

change its order.

Choosing the Bus to Which a Send Is Routed
When you add a send, the audio is routed from the send to a bus. By default, the first 
send you add to an effects chain is routed to Bus 1, the second send is routed to Bus 2, 
and so on, if the default bus exists. Once you add a send, you can choose the bus to 
which the send is routed.

To choose the bus to which a send is routed:
m In the Effect Parameters area of the Effects tab, choose a bus from the Send 

pop-up menu.

Add Send button

Send pop-up menu
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Adjusting Send Volume
You can adjust the volume level for the audio routed through a send.

To adjust send volume:
1 If the send volume slider is not visible, click the disclosure triangle for the send.

2 Drag the send volume slider left to lower the volume level, or drag it right to raise the 
volume level.

Adjusting Send Pan Position
You can adjust the pan position for the audio routed through a send.

To adjust send pan position:
1 If the send pan slider is not visible, click the disclosure triangle for the send.

2 Drag the send pan slider left to pan the send to the left, or drag it right to pan the send 
to the right.

Bypassing Sends
You can bypass a send. When you bypass a send, the audio is not routed to the bus for 
the send, and is not heard.

To bypass an effect:
m In the Effects tab, deselect the checkbox next to the send.

Automating Realtime Effect Parameters
You can automate realtime effect parameters using envelopes. When you automate an 
effect parameter, you can change the value of the parameter over time.

Auto checkboxes
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To automate a realtime effect parameter:
1 In the Effects tab, select the Auto checkbox next to the parameter’s control.

2 In the Timeline or in the Waveform Editor, show the envelopes for the track, bus, 
output, or audio file project.

In the Timeline, you show the envelopes for the track, bus, or output with the effect. In 
the Waveform Editor, you show the envelopes for the audio file project.

3 Add and adjust envelope points in the effect’s envelope.

For information on adding and adjusting envelope points, see Chapter 10, “Working 
With Automation,” on page 219.

When you automate an effect parameter with units of time (seconds or milliseconds) or 
beats per minute (BPM) for values, the parameter is linked to the project tempo. If the 
tempo changes, the value of the parameter changes to keep the same relationship to 
the new tempo. 

Resetting Realtime Effects to Their Default Settings
Every realtime effect has default parameter settings that are displayed in the Effect 
Parameters area when you first add the effect. You can reset an effect to its default 
parameter settings, or reset an individual parameter to its default setting.

To reset a realtime effect to its default settings:
m In the Effects tab, select the effect name in the Effect Parameters area, then click the 

Reset button.

To reset an individual effect parameter to its default settings:
m Select the parameter in the Effect Parameters area to select the parameter, then click 

the Reset button.

Removing Realtime Effects
You can remove a realtime effect from an effects chain.

To remove an effect:
m Select the effect name in the Effect Parameters area, then click the Remove Effect 

button on the right edge of the Effects tab (or press the Delete key).
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Advanced Settings for Realtime Effects
Many realtime effects have an advanced settings window. The advanced settings 
window appears as a floating window with related controls grouped together, and may 
provide an appearance that simulates a hardware effects device. Effects with an 
advanced settings window have an Advanced button at the top of the Effect 
Parameters area in the Effects tab.

To show the advanced settings window for a realtime effect, do one of the 
following:

m In the Effects tab, click the Advanced button for the effect.

m In the Mixer, double-click the effect name.

In the Mixer, Control-click the effect name, then choose Show [effect name] Advanced 
Settings.

When you show an advanced settings window, you can adjust the effect’s parameters 
by moving the controls in the window. Each advanced settings window may have 
unique controls in addition to sliders, buttons, and value fields. 

To adjust advanced effect controls:
1 In the advanced settings window, drag the sliders, type text, and operate the controls.

2 Click Apply.

Advanced settings windows can 
contain different kinds of controls.
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Working With Processing Effects
You can apply processing effects to an audio file or a selected part of a file in the 
Waveform Editor. In the Waveform Editor, you apply a processing effect by choosing the 
effect from the Effects submenu of the Process menu, as described in “Applying 
Actions” on page 171. Processing effects are applied as actions, and appear in the 
Actions menu of the Waveform Editor. You can reorder processing effects, turn them on 
or off, and perform all of the operations for actions described in “Working With Actions” 
on page 170.

Advanced Settings for Processing Effects
You adjust processing effect parameters in the advanced settings window for the 
processing effect. When you apply a processing effect by choosing the effect from the 
Process > Effects submenu, the advanced settings window for the effect appears in 
front of the Project window. You can also show the advanced settings window if you 
want to adjust processing effect parameters.

To show the advanced settings window for a processing effect:
m Double-click the effect in the Actions list.

When you open an advanced settings window for a processing effect, the window 
includes controls to play the project with the effect, adjust volume level, apply the 
effect, reset effect parameters, and cancel applying the effect. 

For information on using the preview controls in the advanced settings window, see 
“Effects Submenu” on page 161.

Automating Processing Effect Parameters
For the effects in the categorized submenus at the top of the Effects submenu of the 
Process menu (not including Mac OS effects), you can add an envelope for an effect 
parameter by Control-clicking the parameter in the advanced settings window. You can 
add envelope points to the envelope to automate changes to the effect parameter.
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Working With Effect Presets
Some effects have several combined parameter settings called presets. For example, 
the MatrixReverb effect (in the Mac OS category) has presets for various sizes of room, 
hall, and chamber settings, as well as Plate reverb and Cathedral settings. If an effect 
has presets, the presets appear in a Factory Presets pop-up menu in the list of effect 
parameters.

Realtime Effect Presets
For realtime effects, you can choose effect presets in the Effect Parameters area of the 
Effects tab.

To apply a preset to an effect:
m In the Effect Parameters area, choose the preset from the Presets pop-up menu.

Processing Effect Presets
For processing effects, you can select presets in the advanced settings window. You can 
show an effect’s presets, add and delete presets, apply a preset, adjust preset 
parameters, and create your own presets.

To show effect presets for a realtime effect:
m Click the Show Presets button in the advanced settings window.

To show effect presets for a realtime effect:
m Click the Show Presets button in the advanced settings window.

The Presets drawer appears to the right of the advanced settings window.

To add a preset:
1 Click the Add Preset (+) button.

A blank, untitled preset appears in the User Preset list.

2 Click the name “Untitled” and type a name for the preset.
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To apply an effect preset:
1 Select the preset you want to apply from either the Factory Preset or User Preset list in 

the Presets drawer.

2 Click the Load Preset button.

To adjust effect preset parameters:
m Adjust the controls in the advanced settings window for the preset.

To delete a preset:
1 Select the preset in the Presets drawer.

2 Click the Delete Preset (–) button.

To hide the Presets drawer:
m Click the Hide Presets button in the advanced settings window.
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10 Working With Automation

Using automation, you can create changes over time to 
volume, pan, effects, and other controls.

Automation offers a powerful way to add drama and interest to your projects. You can 
automate volume and pan changes to tracks, busses, and outputs and automate 
changes to effect and effect send parameters in multitrack projects. You can also 
automate volume, pan, and effects changes in audio file projects. 

Soundtrack Pro gives you three ways to work with automation: 
Â You can add and adjust envelope points on envelopes in the Timeline and in the 

Waveform Editor.
Â You can record changes to sliders, faders, and other controls in the Timeline, the 

Mixer, and the Effects tab.
Â You can record movements to controls on a control surface connected to your 

computer and mapped to Soundtrack Pro commands and functions.

Working With Envelopes
In the Timeline, each track, bus, and output has a set of envelopes. The envelopes 
appear as horizontal lines stretching across the length of the project directly below the 
track, bus, or output. You adjust an envelope by adding envelope points and moving the 
envelope points to new values at different points in the Timeline.

The Timeline also includes master envelopes for tempo and transposition. When you 
show the master envelopes, they appear below the last output in the Timeline.

For video editors accustomed to working in Final Cut Pro, envelopes provide the same 
type of functionality as keyframes. The difference is that you can edit envelopes at a 
finer level of precision than you can using keyframes, allowing extremely powerful 
control over automated changes. 



220 Chapter 10    Working With Automation

 

Track, Bus, and Output Envelopes
Each track and bus has envelopes for volume and pan, and each output has a volume 
envelope. By default, the envelopes are hidden. When you show the envelopes, they 
appear in rows below the track, bus, or output in the Timeline.

To show the envelopes for a track, bus, or output:
m Click the envelope disclosure triangle in the track header. Click the disclosure triangle 

again to hide the envelopes.

The ranges of volume and pan envelopes are equivalent to the ranges of the 
corresponding track controls: 
Â Volume envelopes:  The range is from –96 dB to +6 dB.
Â Track pan envelope:  The range is from 100% Left to 100% Right pan, with Centered at 

the midpoint, 0 (zero).

When you add effects to a track, bus, or output, you can automate the effect 
parameters by adding an envelope for any parameter to the envelopes for the track, 
bus, or output. The envelopes are different for each type of effect. For information on 
adjusting effect parameters, see “Working With Audio Effects” on page 195.

Master Envelopes
Each project has master envelopes for transposition and tempo. When you display the 
master envelopes, they appear below the outputs in the Timeline.

Click the envelope
disclosure triangle.

The envelopes are displayed 
below the track, bus, or output.

The master envelopes appear 
below the Outputs section.
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To show or hide the master envelopes, do one of the following:
m Choose View > Show Master Envelopes. 

m Click the Master Envelopes button in the lower-left corner of the Project window.

m Click the Master Envelopes disclosure triangle in the Timeline.

Repeat the procedure to hide the master envelopes.

The ranges of the master envelopes are as follows:
Â Master transpose envelope:  Ranges from –12 semitones to +12 semitones.
Â Master tempo envelope:  Ranges from 60 bpm to 200 bpm.

Adding Envelope Points
You create changes to an envelope by adding envelope points to the envelope, and 
moving the envelope points to different values.

To add an envelope point to an envelope:
m Double-click the envelope at the position where you want to add the envelope point. 

You may want to zoom in to work more precisely. 

When you add envelope points, they snap to the closest Snap To position if snap is 
turned on. For information on setting the Snap To value, see “Using Snap” on page 72.

Double-click an envelope 
to add an envelope point.
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Selecting Envelope Points
You can select a single envelope point or a group of adjacent or nonadjacent 
envelope points.

To select an envelope point:
m Click the envelope point.

To select multiple envelope points, do one of the following:
m Drag from an area in the automation row before the first envelope point you want to 

select to an area after the last envelope point you want to select. 

m If the envelope points are adjacent, Shift-click the first envelope point, then the last 
envelope point you want to select. All envelope points in between are also selected.

m Command-click each envelope point you want to select. You can select adjacent or 
nonadjacent envelope points by Command-clicking.

To deselect a selected envelope point, do one of the following:
m Command-click the selected envelope point.

m Click in the automation row or somewhere else in the Timeline to deselect all selected 
envelope points.

Moving Envelope Points
Once you add an envelope point, you can drag it up or down to change its value. As 
you drag an envelope point up or down, its value appears to the right of the pointer. 
You can drag an envelope point left or right to change its position in time. You can also 
select and move multiple envelope points.

When you move envelope points, the position of the envelope points snaps to the 
closest Snap To position if snap is turned on. For information on setting the Snap To 
value, see “Using Snap” on page 72.

Drag in the envelope’s row to 
select multiple envelope points.



Chapter 10    Working With Automation 223

 

To move an envelope point:
m Select the envelope point, then drag it to a new position.

Each envelope has an envelope point at the beginning of the Timeline. You can adjust 
the envelope by moving this envelope point up or down. If no envelope points have 
been added, dragging the envelope’s handle adjusts the envelope for the entire 
project.

If you add more than one envelope point to an envelope, you can move envelope 
points using the corresponding slider. When you move the slider, the envelope points 
closest to the playhead (the closest before and the closest after) move by the same 
amount as the slider.

Changing the Values of Envelope Points Numerically
You can also change the value of an envelope point numerically. 

To change the value of an envelope point numerically:
1 Control-click the envelope point, then choose Set Value from the shortcut menu.

2 Type a new value for the envelope point in the dialog that appears. 

The envelope point moves to the new value. You can set the envelope point to the 
same value as the previous or next envelope point on the envelope from the shortcut 
menu.

Changing the Position of Envelope Points Numerically
You can change the position of an envelope point in the Timeline numerically. 

To change the position of an envelope point numerically:
1 Control-click the envelope point, then choose Set Position from the shortcut menu.

2 In the dialog that appears, click the left or right arrow, click the center of the value 
slider and drag left or right, or double-click the value slider and type a new position. 

The envelope point moves to the new position. 
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Viewing and Editing Envelope Point Details
You can also view and edit the value, position, and other details for an envelope point 
in the Details tab.

To view envelope point details:
1 In the Utility window, click the Details tab.

2 Select the envelope point for which you want to view details.

The details for the envelope point appear in the Details tab, including its value and 
position. You can edit the value and position in the Details tab, change the format for 
the position, and copy the value of the previous or next envelope point (if one exists).

To change the value of an envelope point in the Details tab:
1 With the Details tab active, select the envelope point.

2 In the Details tab, do one of the following:

Click the left arrow in the Value value slider to decrease the value, or click the right 
arrow to increase the value.

Â Click the center of the value slider, then drag the slider that appears left or right to 
change the value.

Â Click the text in the value slider to select it, then type a new value.

To change the position of an envelope point in the Details tab:
1 With the Details tab active, select the envelope point.

2 In the Details tab, do one of the following:

Â In the Position value slider, click the left arrow to move the envelope point back 
(toward the start of the project) or click the right arrow to move the envelope point 
forward (toward the end of the project).

Â Click the center of the Position value slider, then drag the slider that appears left or 
right to change the position.

Â Click the text in the Position value slider, then type a new value.
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To change the units shown in the Position value slider:
m Choose the units you want to show from the pop-up menu next to the Position 

value slider.

To copy the value of the previous envelope point:
1 With the Details tab active, select the envelope point to which you want to copy 

the value.

2 In the Details tab, click Copy From Previous Point.

To copy the value of the next envelope point:
1 With the Details tab active, select the envelope point to which you want to copy 

the value.

2 In the Details tab, click Copy From Next Point.

Nudging Envelope Points
There are several ways in which you can nudge envelope points using the arrow keys:
Â Hold down the Option key and press the Left or Right Arrow key to move the 

envelope point by one pixel. 
Â Hold down the Option and Shift keys and press the Left or Right Arrow key to move 

the envelope point to the previous or next gridline. 
Â Hold down the Option key and press the Up or Down Arrow key to move the 

envelope point up or down by one pixel.
Â Hold down the Option and Shift keys and press the Up or Down Arrow key to move 

the envelope point up or down by five pixels.

Cutting, Copying, and Pasting Envelope Points 
You can cut and copy selected envelope points and paste them at a different position 
in the automation row. 

To cut envelope points:
m Select the envelope point, then choose Edit > Cut (or press Command-X).

To copy envelope points:
m Select the envelope points, then choose Edit > Copy (or press Command-C).
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To paste envelope points:
m Set the playhead to the point where you want to paste the envelope points, then 

choose Edit > Paste (or press Command-V).

When you paste envelope points into an automation row, the new envelope points 
replace any existing envelope points, and the automation takes the shape of the cut or 
copied envelope in the pasted area. 

When pasting envelope points, the following conditions apply:
Â Envelope points can only be pasted into an envelope of the same type as the 

envelope from which they were cut or copied. For example, envelope points from a 
volume envelope can only be pasted into a volume envelope, not a pan or tempo 
envelope.

Â Envelope points for an effect parameter can only be pasted into an envelope for 
exactly the same effect parameter in exactly the same type of effect. You cannot 
paste envelope points from one effect into another, even if they have parameters 
with the same name. 

Deleting Envelope Points
After listening to the results of your edits, you may decide to delete some envelope 
points. 

To delete envelope points:
m Select the envelope points, then choose Edit > Delete (or press the Delete key). 

When you delete envelope points, the envelope adjusts accordingly, moving evenly 
from the preceding envelope point to the next envelope point. If there are no other 
envelope points, the envelope becomes horizontal, maintaining its initial value for the 
entire project.

Pasting envelope points into 
an envelope replaces the 
existing area of the envelope 
with the cut or copied area.
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Automating Effect and Send Parameters
You can automate effect parameters for tracks, busses, and outputs, and for audio file 
projects by adding envelopes for the effect parameters, then adding and adjusting 
envelope points. You can also automate send parameters for tracks by adding an 
envelope for the send parameters, then adding and adjusting envelope points. 

To add an envelope for an effect or send parameter:
1 Open the Effects tab and select the effect you want to automate.

2 In the Effect Parameters area, select the Auto checkbox for the parameter. 

To remove an envelope for an effect parameter:
m Deselect the Auto checkbox for the parameter in the Effect Parameters area of the 

Effects window.

The range of values for an effect or send parameter envelope is the same as the range 
for the parameter in the Effects tab.

For detailed information on adjusting effect parameters, see “Adjusting Realtime Effect 
Parameters” on page 209.

Click the Auto checkbox for 
an effect parameter to add an
envelope for the parameter.
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Recording Automation Data
In addition to working with envelopes, you can record automation data in 
Soundtrack Pro. You can record movements you make to faders, sliders, and other 
onscreen controls using the pointer. You can also connect a supported control 
surface to your computer and record movements to controls on the control surface. 
When you record movements to onscreen controls or control surface controls, the 
corresponding envelope in the Timeline (or Waveform Editor) changes to display the 
recorded automation data. You can edit the envelope to fine tune the automation 
data after recording.

Automation Modes
Soundtrack Pro provides three modes for using and recording automation. The 
automation modes determine whether automation data is recorded, and what 
happens when you release the control being recording.
Â Read:  In Read mode, existing automation data is active when you play the project, 

but no new automation data is recorded.
Â Touch:  In Touch mode, movements to controls are recorded when you play the 

project, overwriting any existing automation data until you release the control. When 
you release a control in Touch mode, the control returns to the value it previously 
had at the point in the Timeline where you release the control. No envelope points 
after that point are added or changed.

Â Latch:  In Latch mode, movements to controls are recorded when you play the 
project, overwriting any data from the point you start recording until you stop 
playing the project. When you release a control in Latch mode, the control maintains 
the same value at which you released it.

To record automation data for movements to controls:
1 Choose either Touch or Latch from the Automation Mode pop-up menu.

2 Set the playhead to a position before the point where you want to start recording.

3 Click Play (or press the Space bar) to start the project playing.

4 While the project plays, move the control you want to record.

Once you have recorded automation data, you can show the envelope for the control 
and add and adjust envelope points on the envelope to fine tune the automation. For 
information on working with envelopes, see “Working With Envelopes” on page 219.

For more information on working with control surfaces, see Chapter 12, “Using Control 
Surfaces With Soundtrack Pro,” on page 243.
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Thinning Envelope Points in Recorded Automation Data
Recording automation data can generate a large number of envelope points. The 
number of envelope points recorded can make editing envelopes difficult, and in some 
cases affect playback performance.

You can reduce or “thin” the number of envelope points recorded from a control 
surface in the Project Preferences. You set the amount of thinning using the 
Automation Recording Sensitivity slider. The automation data is thinned when you 
finish recording automation.

To set the amount of thinning:
1 Choose Soundtrack Pro > Preferences, then click the Project button.

2 In the Project pane, drag the Automation Recording Sensitivity slider to adjust the 
amount of thinning. 

When the slider is set to High, no thinning occurs. The envelope contains every 
movement of the control. Dragging the slider to any position other than High results 
in some thinning of envelope points. By default, the slider is set to a moderate amount 
of thinning.

For more information about Soundtrack Pro project preferences, see “Project 
Preferences” on page 76.

Working With Timeslices 
Timeslices let you select the contents of a track, or of multiple tracks, and the track’s 
envelopes for a section of time. When you select a Timeslice, the Timeslice selection 
area is highlighted in blue. 

Selecting Timeslices
To select a Timeslice from a single track:

m Drag in the selection bar along the top of the track. 

The selection snaps to the nearest Snap To position if snap is turned on. For 
information about setting the Snap To value, see “Using Snap” on page 72.

Drag in the selection bar 
to create a Timeslice.
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To select a Timeslice from multiple tracks:
1 Click in the selection bar of the topmost track you want to include in the Timeslice, at 

one end of the area you want to select.

2 Shift-click in the selection bar of the bottom track you want to include in the Timeslice 
at the opposite end of the area you want to select, or Command-click in nonadjacent 
tracks to add those tracks to the Timeslice.

You can select a master Timeslice that includes the audio content and the envelopes of 
all tracks, including the video’s audio track.

Click in the selection bar of 
the topmost track you want 
to include in the Timeslice.

Shift-click in the selection bar
of the bottom track you want

to include in the Timeslice.
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To select a master Timeslice:
m Drag in the selection bar of the video track, located above the Time ruler. 

Cutting, Copying, and Pasting Timeslices
You can cut or copy a Timeslice and paste it at a different position in the Timeline.

To cut a Timeslice:
m Select the Timeslice, then choose Edit > Cut (or press Command-X). 

To copy a Timeslice:
m Select the Timeslice, then choose Edit > Copy (or press Command-C). 

To paste a Timeslice:
m Set the playhead at the position where you want to paste the Timeslice, then choose 

Edit > Paste (or press Command-V). 

If the Timeslice is from a single track, it is pasted in the same track at the current 
playhead position. If the Timeslice includes multiple tracks, the topmost track of the 
Timeslice is pasted in the currently selected track, and the remaining tracks are pasted 
in the tracks below the selected track. If not enough tracks exist for the number of 
tracks in the Timeslice, a dialog appears asking if you want to create additional tracks. 

Drag in the selection bar 
of the video track to 
create a master Timeslice.



232 Chapter 10    Working With Automation

 

Deleting Timeslices
To delete a Timeslice:

m Select the Timeslice, then choose Edit > Delete (or press the Delete key). 

Changing the Timeslice Selection Area 
You can change the length of a Timeslice selection area to include more of the 
Timeline, either graphically or numerically. 

To extend the Timeslice selection area graphically:
m Shift-click in any track included in the Timeslice at the point to which you want to 

extend it.

Below and to the right of the transport controls is the Selection Length value slider. 
When a Timeslice is active, the Selection Length value slider shows the length of the 
active Timeslice. 

The units shown in the Selection Length value slider depend on the project time 
format. For projects using Time-based format, the value slider shows the current Time 
ruler units, using the current frame rate. For projects using Beats-based time format, 
the value slider shows measures, beats, and beat divisions at the current tempo.

To change the length of a Timeslice numerically:
1 Click the value slider.

The field becomes a value field, with the current value selected.

2 Type a new value into the field, using appropriate punctuation.

3 Press Tab or Enter to confirm the new value.

Shift-click in the Timeline 
to extend a Timeslice.



Chapter 10    Working With Automation 233

 

To lengthen the Timeslice in increments:
m Click the left arrow to lengthen the beginning of the Timeslice in increments, or click 

the right arrow to move the end of the Timeslice in increments. 

To lengthen the Timeslice dynamically:
m Click the center area of the field (where the numbers are), then drag left to lengthen 

the beginning of the Timeslice, or drag right to lengthen the end of the Timeslice. 

For projects using Time-based format, the left and right arrows lengthen the Timeslice 
in seconds. For projects using Beats-based format, the arrows lengthen the Timeslice 
in beats.
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11 Recording Audio 
in Soundtrack Pro

You can record your own audio in a track in the 
Timeline, as well as recording audio in the Mixer and 
the Waveform Editor.

You get ready to record by setting recording preferences and checking that your audio 
equipment is working. For multitrack projects, you enable a track for recording, or 
record audio in a new track. You can record a single take or record multiple takes. If 
you record multiple takes, you can review them after recording and choose which one 
to use in your project, or assemble a composite take using segments of each 
recorded take.

For audio file projects, you record in the Waveform Editor. When you record in the 
Waveform Editor, the recording replaces (overwrites) any audio over which you record. 
If you record for a longer duration than the current length of the file, the file is 
lengthened to include the recorded audio.

Getting Ready to Record
Before you start recording, also make sure that any audio equipment you plan to use in 
your recording session (such as microphones, musical equipment, mixers, or external 
processors) is connected to your computer and is working. 

When you record, the recorded audio is saved to disk at the location set in the 
Recording pane of the Preferences window. Audio files, while smaller than video files of 
comparable duration, can be quite large (each minute of 16-bit, 44.1 kHz stereo audio 
requires roughly 10 MB of disk space), so you should make sure you have enough free 
disk space to store your recordings before you start. You can set the input device and 
output monitoring device for recording in the Preferences Recording pane, or change 
them in the Recording tab. For detailed information on Recording preferences, see 
“Recording Preferences” on page 77.
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Recording Audio in the Timeline
You record in the Timeline by enabling a track for recording, setting the playhead, then 
clicking Record. You can record a single take or record multiple takes by turning on 
cycling before you start recording. When you finish recording, your recorded audio 
appears in a track in the Timeline. If you record multiple takes, you can audition each 
take to choose which one you want to use in your project. You can also assemble 
composite takes by splitting and combining your recorded takes.

Enabling a Track for Recording
Before you start recording, you enable the track you want to record to. You can record 
audio only to a track, not to a bus or output. If no track is enabled for recording, a new 
track is created below the existing tracks, and the take appears on the new track when 
you click the Record button.

To enable a track for recording:
m Click the Record Enable button (the red circle) in the track’s header (or Mixer channel 

strip). 

The Recording tab becomes active, and shows the current recording settings. You can 
adjust recording settings before you start recording, or between recordings.
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To adjust recording settings:
1 In the Recording tab, choose the input device and channel (or pair of channels) from 

the Input Device pop-up menu.

2 Choose the device and channel (or pair of channels) to use for monitoring the recorded 
audio from the Monitor pop-up menu.

3 If you want to record without hearing the existing audio clips in the project, select the 
Mute Project checkbox.

4 If you want to record in mono, deselect the Stereo checkbox.

The level meters in the Recording tab show the level of the audio signal in the input 
channel. Before recording, you may want to watch the level meters and set the input 
level, to assure a high enough signal level and to avoid clipping.

Recording a Single Take
You record a single take by setting the playhead to the point where you want 
recording to start, then clicking the Record button. Recording starts at the playhead 
position, and ends when you click either the Record or Play button. 

To record a single take:
1 If you want to record to an existing track, enable the track.

2 Set the playhead to the point where you want recording to start. 

You can set the playhead using any of the procedures described in “Setting the 
Playhead” on page 51.

3 Click the Record button in the transport controls to start recording.

As you record, the level meters in the Recording tab show the levels of the input signal 
being recorded. If the input signal clips (rises above 0 dB), the peak indicator lights red.

4 To stop recording, do one of the following:

Â Click the Record button again.
Â Click the Play button.

You can punch in and punch out while recording a single take using the Record 
button. For example, you can start the project playing, then punch in at the point 
where you want to start recording by clicking the Record button. To punch out, click 
the Record button again. When you click the Record button while recording, recording 
stops, but the project continues playing. You can punch in and punch out multiple 
times while the project is playing.

When you click the Play button, both recording and playback stop.



238 Chapter 11    Recording Audio in Soundtrack Pro

 

Recording Multiple Takes
You can record multiple takes in the Timeline. You can record multiple takes using the 
playback region to define where each take starts and ends, or record for the duration of 
the project. When you record multiple takes, the takes are “stacked” in a single clip in 
the Timeline. You can audition each take, and can create composite takes by splitting 
the clip and choosing the take for each split segment.

To record multiple takes:
1 If you want to record to an existing track, enable the track.

2 If cycling is turned off, click the Cycle button in the transport controls to turn it on.

3 Set the playback region to the part of the Timeline where you want recording to start 
and end. 

For information on setting the playback region, see “Working With the Playback 
Region” on page 98.

If no playback region is set, recording starts at the beginning of the project and lasts 
until the end of the last clip in the project. If the project contains no clips, a single take 
is recorded, starting at the current playhead position.

4 Click the Record button in the transport controls to start recording.

As you record, the level meters in the Recording tab show the levels of the input signal 
being recorded. If the input signal clips (rises above 0 dB), the peak indicator lights red.

The playhead advances to the end of the playback region, then returns to the 
beginning of the playback region for the next take. 

5 To stop recording, click the Play button.

When you record multiple takes, the takes are recorded sequentially to an audio file in 
the recording location set in Recording Preferences. The takes appear in a single clip in 
the Timeline. The current take number appears in the lower-right corner of the clip. You 
can choose which take you hear when you play the project. When you finish recording, 
the current take number corresponds to the number of completed takes.
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To choose a take, do one of the following:
m Select the clip, choose Clip > Recording Take, then choose the take number from the 

submenu.

m Control-click the clip, choose Take from the shortcut menu, then choose the take 
number from the submenu.

You can split a recorded clip, and choose the take for each segment of the split clip to 
create a composite take. You can also copy a clip onto several tracks, split the copies, 
and choose the take for each split copy of the clip.

Saving Recorded Clips
You can save your recordings in the Timeline. When you save a clip, you can name the 
clip, choose where to save it, and save it as either a looping or non-looping file.

To save a recorded clip:
1 Do one of the following:

Â Select the clip in the Timeline, then choose Clip > Save Clip As.
Â Control-click the clip in the Timeline, then choose Save Clip As from the shortcut 

menu.

2 In the Save As dialog, type a name for the clip and browse to the location where you 
want to save it.

3 Select the Looping button to save the clip as a looping file, or click the Non-looping 
button to save the clip as a non-looping file.

4 Click Save.

You can use Apple Loops Utility, a companion application included with 
Soundtrack Pro, to add tags to your saved recordings to make them easier to find 
using the Search tab in Soundtrack Pro. 
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Recording Audio in the Mixer
You can record audio in the Mixer in a similar way to recording audio in the Timeline. 
You can record a single take or record multiple takes. If you want to record multiple 
takes using a playback region, you must set the playback region in the Timeline before 
you start recording in the Mixer.

To record audio in the Mixer, you follow the procedures described in “Recording Audio 
in the Timeline” on page 236, with the following differences:

Â To enable a track for recording in the Mixer, click the Record Enable button (the red 
circle) in the track’s channel strip.

Â In the Mixer, you can set the playhead using the transport controls or the Playhead 
Position value slider. Because the playhead is not visible in the Mixer, you cannot set 
it by clicking or dragging.

Recording Audio in the Waveform Editor
You can record audio to an audio file project in the Waveform Editor. When you record 
audio in the Waveform Editor, you replace (overwrite) any existing audio in the audio 
file or selection you record to.

You can select part of the file in the Waveform Editor to record to. When you record to a 
selection, recording starts at the beginning of the selection and ends at the end of the 
selection. The part of the file after the end of the selection is unchanged.

If no part of the file is selected, recording starts at the playhead position, and lasts until 
you stop recording. If your recording extends past the end of the audio file, the file is 
lengthened to include the recording.

To record audio in the Waveform Editor:
1 Select the part of the project you want to record to.

If no part of the audio file is selected, recording starts at the current playhead position 
and proceeds until you stop recording.

2 Click the Record button in the transport controls.
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As you record, the recorded area appears red in the waveform display. The level meters 
in the Recording tab show the levels of the input signal being recorded. If the input 
signal clips (rises above 0 dB), the peak indicator lights red.

Recorded area
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12 Using Control Surfaces 
With Soundtrack Pro

You can connect and use control surfaces to automate 
recording, mixing, and other tasks in Soundtrack Pro.

Control surfaces provide a set of hardware controls that let you mix and edit your 
projects with greater flexibility and precision than using a mouse to move onscreen 
controls. You can also change multiple parameters at once using a control surface. 

There are a variety of control surfaces available for use with video and audio 
production applications. Most control surfaces include faders, knobs, and buttons 
similar to those found on a hardware mixing console, including channel strip controls 
for volume, pan, mute, solo, and track selection, and a set of transport controls. Control 
surfaces also typically provide buttons for selecting parameters to edit and for selecting 
different tracks or banks of tracks, a jog wheel for moving the playhead precisely, and 
other controls. When you use a control surface with Soundtrack Pro, some controls are 
premapped to common functions. You can map other controls to Soundtrack Pro 
commands and functions in the Control Surfaces Preferences pane.

To use a control surface, you connect it to your computer, add it to Soundtrack Pro, 
map the controls you want to use to Soundtrack Pro commands, then record control 
surface automation data in your project. Recorded control surface automation data 
appears in the corresponding envelope in the Timeline.

Connecting Control Surfaces
Soundtrack Pro supports control surfaces that use the Mackie Control and Logic 
Control protocols to communicate with your computer. In order to use a control 
surface, you must first connect the control surface to a MIDI interface, and connect the 
MIDI interface to your computer, unless the control surface allows direct connection to 
the computer. Before connecting a MIDI interface, be sure your computer supports the 
MIDI interface you plan to use. Read the installation instructions included with the MIDI 
interface, and install the latest version of any appropriate firmware or driver software if 
needed. For more information, refer to the documentation that came with the control 
surface and with the MIDI interface.
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Adding and Deleting Control Surfaces
When you have connected the MIDI interface to your computer, and connected the 
control surface to the MIDI interface, you add the control surface in Soundtrack Pro 
Control Surface Preferences.

To add a connected control surface:
1 Choose Soundtrack Pro > Preferences, then click the Control Surfaces button.

2 Click the Add (+) button to add the control surface.

The visual representation of the control surface appears in the panel in the upper part 
of the window.

3 Choose the type of control surface you are adding from the Control Surface Type pop-
up menu.

4 Choose the MIDI input port to use for the control surface from the Input Connection 
pop-up menu.

5 Choose the MIDI output port to use for the control surface from the Output 
Connection pop-up menu.

6 Click the Close button to dismiss the Preferences window.

You can delete a control surface, if you decide you don’t want to use it any longer.

To delete a control surface:
1 Choose Soundtrack Pro > Preferences, then click the Control Surfaces button.

2 Select the control surface in the Control Surfaces display area.

3 Click the Delete (–) button.
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Premapped Controls
When you connect a control surface, many controls are premapped to work with 
specific Soundtrack Pro buttons and commands. Premapped controls include the 
following:

Mapping Commands to Control Surface Buttons
Many buttons on control surfaces are not directly assigned to a specific command in 
Soundtrack Pro. Some buttons, such as the bank and channel buttons, are premapped 
but can also be mapped to other commands. You can map these buttons in the Control 
Surface Buttons window and save the mappings or modify them later. 

To map a command to a control surface button:
1 Choose Soundtrack Pro > Preferences, then click the Control Surfaces button.

2 Click the Control Surface Buttons button to show the Control Surface Buttons window.

Control Soundtrack Pro button or command

Channel strip volume faders Track volume slider

Channel strip rotary knobs Track pan slider

Channel strip record ready 
buttons

Track Record Enable button

Channel strip select buttons Select the track.

Channel strip mute buttons Track mute button

Channel strip solo buttons Track solo button

Transport controls Transport controls (Move back, Move forward, Play, Stop, Record)

Jog wheel Moves playhead back or forward.
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3 In the Control Surface Buttons window, drag an action from the Available Commands 
list (on the right) to a button in the Control Surface Buttons list (on the left) to map the 
command to the button.

4 Optionally, you can search for commands and control surface buttons by typing text in 
the Search field, located at the upper-right corner of the window.

Recording Control Surface Automation
Once you have connected a control surface and mapped the controls you plan to use, 
you can use the control surface to control volume, pan, and other functions in your 
Soundtrack Pro projects. Using the automation modes described in “Automation 
Modes” on page 228, you can record control surface movements while a project plays. 

To record control surface movements, follow the procedures described in “Recording 
Automation Data” on page 228.

You can thin automation data recorded from a control surface. For information on 
thinning automation data, see “Thinning Envelope Points in Recorded Automation 
Data” on page 229.



13

      247

13 Exporting Multitrack Projects

Once you have created a final mix of a multitrack project, 
you can export the project mix. You can also export 
individual tracks, busses, or outputs, and export a 
multitrack project using Compressor.

You can export a project to a stereo audio file and set the exported file’s bit depth and 
sample rate. You can export selected tracks, busses, or outputs to either a stereo audio 
file or paired mono files. If your project includes a video, you can also export a project 
to a variety of formats using the Compressor application. 

You can import an exported audio file into Final Cut Pro (or another video application) 
to add to a video project, or into a digital audio application for further processing. You 
can also burn it on a CD or DVD, or open it in iTunes and convert it to MP3 or AAC 
format that you can distribute over the Internet.
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Exporting a Project Mix 
When you export a mix, all unmuted tracks routed to the first output (Output 1) are 
included in the exported file. You can exclude any tracks from the exported mix by 
muting those tracks. 

To export a project to a stereo audio file:
1 Choose File > Export > Export Mix.

The Export dialog appears.

2 Choose a bit depth for the exported file from the Bit Depth pop-up menu.

3 Choose a sample rate for the exported file from the Sample Rate pop-up menu.

4 Type a name for the exported file, and browse to the location where you want to save 
the file.

5 Click Export.

Remember that you can create as many mixes of your project as you like by muting 
tracks, adjusting controls, effects, and envelopes, and then exporting each version as a 
separate mix.

Exporting Selected Tracks, Busses, and Outputs
You can export selected tracks, busses, or outputs in a project. When you export 
selected tracks, busses, or outputs, each is exported to a stereo AIFF file. The output file 
is given the same name as the track, bus, or output being exported. You can also 
export a track, bus, or output to a pair of mono files; in this case, the letter L is 
appended to the filename of the left mono file, and the letter R is appended to the 
right mono file. 
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To export individual tracks, busses, or outputs:
1 In the Timeline or the Mixer, select the tracks, busses, or outputs you want to export, 

then choose File > Export > Export Selected [item]. 

The [item] shown in the menu changes depending on whether tracks, busses, or 
outputs are selected.

If nothing is selected, each unmuted track, bus, and output in the project is exported as 
an individual AIFF file. 

2 In the Export dialog, choose the sample rate for the exported files from the Sample 
Rate pop-up menu.

3 Choose the bit depth for the exported files from the Bit Depth pop-up menu.

4 Optionally, select the “Output dual mono files” checkbox to export the selected tracks, 
busses, and outputs as dual mono files, then click Save.

5 Browse to the location where you want to save the exported files.

6 Click Export.

Each selected track, bus, or output is exported as a single stereo AIFF file or as a pair of 
dual mono AIFF files. Muted and unselected tracks, busses, or outputs are not exported.

When you export a project, track, bus, or output that includes an effect (for example, a 
reverb or delay) that produces a tail that extends past the end of the project, the 
exported file lengthens to include the tail.

You can also select part of an audio file and add an effect to a selection. When you add 
an effect that produces a tail to a selection, the tail is blended with the audio following 
the selection until the effect level falls below –96 dB. The project lengthens to include 
the tail if necessary.
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Exporting With Compressor
You can export a project using the Apple Compressor application. When you export 
using Compressor, you can use the presets included with Compressor for your 
exported file. 

When you export a project using Compressor, you can preserve or encode the video. 
Preserving the video copies it to the exported file without transcoding. Encoding the 
video transcodes it to the new export format. Transcoding the video can take longer 
than copying, and can result in a loss of quality. In most cases, when the video format 
of the exported file is the same as the source video, you should preserve the video 
when exporting. If the video format of the exported file is different than the source 
video, you should encode the video when exporting.

To export a project using Compressor from within Soundtrack Pro:
1 Choose File > Export > Export with Compressor.

The Compressor Export Options dialog appears.

2 Type a name for the exported file in the Save As field.

3 Browse to the location where you want to save the exported file.
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4 Do one of the following:

Â To export the video in its original format, select Preserve Video, then choose an 
export preset from the adjacent preset pop-up menu.

Â To export the video in a different format, select Encode Video, then choose an export 
preset from the adjacent preset pop-up menu.

For information about using Compressor export presets, see “Using Compressor Export 
Presets” on page 251.

5 Optionally, for multichannel projects, click the Edit Channel Layout button to change 
the channel layout for the exported file. For information on exporting multichannel 
projects, see “Exporting Multichannel Projects With Compressor” on page 251.

6 Click Export.

Using Compressor Export Presets
Compressor includes a large number of export presets for a variety of media, including 
audio, video, and motion graphics. When you export a Soundtrack Pro project using 
Compressor, you can select an export preset in the Compressor Export Options dialog. 
Export presets appear in the pop-up menus to the right of the Preserve Video and 
Encode Video buttons. 

For more information on working with Compressor presets, see the Compressor User 
Manual. The manual is available from the Compressor Help menu, and is included in 
the Documentation folder installed with Soundtrack Pro.

Exporting Multichannel Projects With Compressor
You can export multichannel projects with up to seven output channels. When you 
export a multichannel project using Compressor, you can edit the channel layout to 
assign outputs in the project to physical output channels.

To edit the channel layout:
1 In the Compressor Export Options dialog, click the Edit Channel Layout button.

The Channel Layout dialog appears. The Channel Layout dialog includes pop-up menus 
for Left, Right, Center, LFE, Left Surround, Right Surround, and Center Surround outputs. 
You can choose the physical output channel (labeled “Channel 1,” “Channel 2,” and so 
forth) for each output. 

2 Choose the physical output channel for each channel in the exported project. 
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Distributing a Multitrack Project and its Media 
Files Together
You can save a multitrack project with all of the media files it uses together in the same 
folder. Saving the project and its media files together is useful when you want to move 
the project from one computer to another in order to continue working on it, or to 
archive the project and media for later use. 

To save a project and its audio files together:
1 Choose File > Save.

2 In the dialog that appears, select the Collect Audio Files checkbox. 

3 Navigate to the folder in which you want to save the project and its audio files, then 
click Save. 

The project file, and a copy of every audio file the project uses, are saved in the 
selected location. 

4 You can optionally create a new folder for the collected project. To create a new folder 
for the project, click the triangle next to the Where pop-up menu to expand the Save 
window, then click New Folder. It’s a good idea to save each collected project in its own 
folder.

5 If the project includes a video, you can optionally select the Collect Video File checkbox 
to save the video in the selected folder. 

If the folder already contains any of the media files, an alert appears, asking if you want 
to replace the existing files. 

Note:  Because video files are typically very large files, saving a copy of the video file 
may take several minutes, and may require a large amount of disk space.

For information on making roundtrips between Final Cut Pro and Soundtrack Pro, see 
Chapter 14, “Using Soundtrack Pro With Apple Professional Applications,” on page 253.

Select this option to 
save the video file 
with the project.

Select this option to save
the project and its audio

files together.
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14 Using Soundtrack Pro With 
Apple Professional Applications

You can work with media files from Final Cut Pro, 
Motion, DVD Studio Pro, and other applications in 
Soundtrack Pro projects. 

Soundtrack Pro gives you several ways to work with media files from Final Cut Pro, 
Motion, DVD Studio Pro, and other Apple professional applications. You can edit 
individual audio files (including QuickTime movies) in the Waveform Editor, and you 
can open a group of clips or a sequence as a multitrack project.

Using Soundtrack Pro With Final Cut Pro
You can edit a Final Cut Pro clip nondestructively in the Waveform Editor by sending 
the clip from Final Cut Pro to the Waveform Editor as an audio file project. Sending a 
clip to the Waveform Editor as an audio file project lets you edit the clip 
nondestructively, then update the clip with your changes in Final Cut Pro without 
reimporting the clip. 

You can edit a Final Cut Pro clip destructively in the Waveform Editor by opening a clip 
in the Waveform Editor, making your changes, and saving the clip as an audio file, or by 
sending the clip to a Soundtrack Pro script (either a script included with Soundtrack Pro 
or one you create). You can also send a select a group of clips or a sequence in 
Final Cut Pro and send them to Soundtrack Pro as a multitrack project.
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Editing a Final Cut Pro Clip Nondestructively in the 
Waveform Editor
You edit a Final Cut Pro clip nondestructively by sending it to the Waveform Editor as 
an audio file project. Sending a clip to the Waveform Editor as an audio file project lets 
you make roundtrips between Final Cut Pro and Soundtrack Pro. When you save your 
changes in the Waveform Editor, the clip is updated in Final Cut Pro without having to 
be reimported.

In order to edit a Final Cut Pro clip nondestructively in the Waveform Editor, you send 
the clip to the Waveform Editor as a new audio file project, edit the clip in the 
Waveform Editor, then save the audio file project. After following these steps, you can 
make roundtrips between Final Cut Pro and Soundtrack Pro so you can keep working in 
both applications.

When you send a clip from the Final Cut Pro Timeline to the Waveform Editor, 
Soundtrack Pro creates a new audio file project (with the file type .stap) for the clip. The 
clip can contain video and audio or contain only audio.

To edit a Final Cut Pro clip nondestructively in the Waveform Editor:
1 In the Final Cut Pro Timeline, Control-click the clip, then choose “Send To > 

Soundtrack Pro Audio File Project” from the shortcut menu. 

A new audio file project is created for the clip, and a Save As dialog appears.

2 In the Save As dialog, type a name for the new project, and browse to a location to 
save the project.

The new audio file project opens in the Soundtrack Pro Waveform Editor. If the clip 
includes video, the video appears in the Video tab. You can control playback of the 
video using the video transport controls in the Video tab or at the bottom of the 
Project window.

3 Edit the audio file project in the Waveform Editor. 

You can use the commands and functions described in Chapter 7, “Working in the 
Waveform Editor,” on page 143. You can graphically edit the file, apply actions, analyze 
the file, and fix analyzed problems. 

4 When you are finished editing the clip in the Waveform Editor, choose File > Save.

When you save an audio file project sent from Final Cut Pro, a render file is included in 
the project, which Final Cut Pro uses to update the clip in the Timeline. By default, 
saving a project sent from Final Cut Pro includes the render file. If you save the project 
using the Save As command, be sure to leave the Render checkbox selected each time 
you save the project, so the clip will be updated in the Final Cut Pro project. If you 
deselect the Render checkbox, you will not be able to reconnect the audio file project 
with the clip, and your changes will be lost.
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For any audio file project, regardless of whether it originated in Final Cut Pro or another 
application, you can select the Render checkbox when you save the project to save a 
render file with the project. 

When you have followed the steps described above, the clip is updated in Final Cut Pro. 
You hear the clip with the changes you made in the Waveform Editor without having to 
reimport the clip. You can make roundtrips between Final Cut Pro and Soundtrack Pro 
by Control-clicking the clip in Final Cut Pro and choosing Open in Editor from the 
shortcut menu, editing the audio file project in Soundtrack Pro, then saving the project. 
Each time you save the project, the clip is updated in Final Cut Pro.

Editing a Final Cut Pro Clip Destructively in the Waveform Editor
You can edit a Final Cut Pro clip destructively by opening it in the Waveform Editor. 
When you edit a clip destructively, you hear the clip with the changes you made in the 
Waveform Editor, without having to reimport the clip. You can save the clip as an audio 
file project in the Waveform Editor, so you can reopen it later and continue editing.

To edit a clip destructively in the Waveform Editor:
1 Control-click the clip in the Final Cut Pro Timeline or Bin, then choose Open in Editor 

from the shortcut menu.

Soundtrack Pro opens and the clip appears in the Waveform Editor.

2 Edit the clip in the Waveform Editor.

You can edit the audio file project in the Waveform Editor using the commands and 
functions described in Chapter 7, “Working in the Waveform Editor,” on page 143. You 
can apply actions or analyze the file and fix analyzed problems. 

3 When you are finished editing the clip, choose File > Save. 

4 Click Save.

You can also save the clip by choosing File > Save As. If you save the clip using the Save 
As command, be sure the name, location, and file type in the Save As dialog are the 
same as for the clip’s source file.

You can also save the clip as an audio file project. If you save the clip as an audio file 
project, you can reopen the project in the Waveform Editor and make further changes. 
To use the updated clip in Final Cut Pro you must save it as an audio file and import the 
audio file, replacing the existing clip.
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Editing a Clip Using a Soundtrack Pro Script
You can edit a Final Cut Pro clip destructively using a Soundtrack Pro script while 
working in Final Cut Pro. When you send a clip to a Soundtrack Pro script, the clip 
opens in the Waveform Editor, the actions in the script are performed, the clip is saved 
with the changes, and the Waveform Editor moves to the background so you can 
continue working in Final Cut Pro.

To edit a clip using a Soundtrack Pro script:
m Control-click the clip in the Final Cut Pro Timeline or Bin, choose Send To > 

Soundtrack Pro Script from the shortcut menu, then choose the script you want to use 
from the submenu.

Soundtrack Pro opens and the clip appears in the Waveform Editor. The actions in the 
script are performed and the clip is saved with the changes. The Soundtrack Pro 
window moves to the background, and the Final Cut Pro windows return to the 
foreground.

You can select multiple clips in Final Cut Pro to edit using a script. When you send 
multiple clips to a Soundtrack Pro script, each clip is opened, edited, saved, and closed 
in sequence.

You can also repeat the last script you used to edit a clip, making it easy to edit several 
clips with the same set of actions.

To edit a clip using the last script:
m Control-click the clip in the Final Cut Pro Timeline or Bin, then choose Send To > Last 

Soundtrack Pro Script from the shortcut menu.

For information about creating and saving AppleScripts in the Waveform Editor, see 
“Scripting Actions in the Waveform Editor” on page 181.

Creating a Multitrack Project From Final Cut Pro 
Clips or Sequences
You can create a Soundtrack Pro multitrack project from a group of Final Cut Pro 
clips or a sequence. When you send a group of clips or a sequence to a Soundtrack Pro 
multitrack project, the clips open in the Soundtrack Pro Timeline. You can arrange 
and edit the clips in the Timeline and mix them in the Mixer, then export the 
multitrack project.
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To create a multitrack project from a group of clips or a sequence:
1 Do one of the following:

Â Select the clips in the Final Cut Pro Timeline, Control-click one of the clips, then 
choose Send To > Soundtrack Pro Multitrack Project from the shortcut menu.

Â Control-click a sequence in the Bin, then choose Send To > Soundtrack Pro Multitrack 
Project from the shortcut menu.

A new multitrack project is created for the clips or sequence, and a Save As dialog 
appears. If you selected a group of clips, a sequence for the selected clips is created in 
Final Cut Pro.

2 In the Save As dialog, type a name for the multitrack project, and browse to a location 
to save the project.

3 If you want to open the project in the Soundtrack Pro Timeline, select the Open in 
Multitrack Editor checkbox.

4 If you want to include the video from the region of the Final Cut Pro Timeline where 
you selected the clips, select the Include Background Video checkbox.

5 Click Save.

If you selected the Open in Multitrack Editor checkbox, the new multitrack project 
containing the clips opens in the Soundtrack Pro Timeline. If you selected the Include 
Background Video checkbox, the video appears in the Video tab, and a video clip 
appears in the video track.

You can arrange and edit the clips in the Timeline and mix the project in the Mixer. For 
information about working in the Timeline, see Chapter 5, “Working in the Timeline,” on 
page 93. For information about working in the Mixer, see Chapter 6, “Working in the 
Mixer,” on page 123.

6 When you are finished working on the project, choose File > Save to save your 
changes.

When you have followed the steps described above, you can export a project mix of 
the multitrack project and replace the group of clips or sequence with the exported 
project mix in Final Cut Pro.

Note:  When you send Final Cut Pro clips to the Timeline, the clips’ volume level and any 
keyframes or crossfades are sent with the clip. For mono clips, the pan position is also 
sent. Clip-based Final Cut Pro effects such as filters and speed-changing envelopes, and 
Final Cut Pro generators are not included in the Soundtrack Pro multitrack project. 
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To update a Soundtrack Pro multitrack project sent from Final Cut Pro:
1

 

In Soundtrack Pro, choose Export > Export Mix.

 

2

 

Import the exported project mix into the Final Cut Pro Timeline, replacing the original 
clips or sequence.

 

3

 

When you want to work on the project in Soundtrack Pro again, Control-click the clip of 
the exported mix, then choose Open in Editor from the shortcut menu.

A dialog appears asking if you want to open the audio file or the original project.

 

4

 

In the dialog, click Open Project.

The multitrack project opens in the Soundtrack Pro Timeline so you can continue 
working. When you are finished working in Soundtrack Pro, be sure to save the 
multitrack project before exporting a project mix so your changes are retained.

By following the steps described in this procedure, you can make multiple roundtrips 
between Soundtrack Pro and Final Cut Pro.

 

Using Soundtrack Pro With Motion

 

You can edit a Motion audio track nondestructively by sending it to the Waveform 
Editor as an audio file project. Sending an audio track to the Waveform Editor as an 
audio file project lets you make roundtrips between Motion and Soundtrack Pro. When 
you save your changes in the Waveform Editor, the clip is updated in Motion without 
having to be reimported.

In order to edit a Motion audio track nondestructively in the Waveform Editor, you send 
the clip to the Waveform Editor as a new audio file project, edit the clip in the 
Waveform Editor, then save the audio file project. After following these steps, you can 
make roundtrips between Motion and Soundtrack Pro so you can keep working in both 
applications.

When you send an audio track from Motion to the Waveform Editor, a new audio file 
project (with the file type .stap) is created for the track. 
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To send an audio track from Motion to the Waveform Editor:
1 In the Motion Audio tab or Timeline Layer list, select the audio track.

2 Choose Edit > Send Audio to Soundtrack. 

A new audio file project is created for the audio track, and a Save As dialog appears.

3 In the Save As dialog, type a name for the new project, and browse to a location to 
save the project.

A new audio file project containing the audio track opens in the Soundtrack Pro 
Waveform Editor. 

4 Edit the audio file project in the Waveform Editor.

You can use the commands and functions described in Chapter 7, “Working in the 
Waveform Editor,” on page 143. You can graphically edit the file, apply actions, analyze 
the file, and fix analyzed problems. 

When you are finished editing the audio file project of the audio track, you save the 
project in Soundtrack Pro. 

5 In Soundtrack Pro, choose File > Save.

When you save an audio file project sent from Motion, a render file is included in the 
project, which Motion uses to update the audio track. If you save the project using the 
Save As command, be sure to leave the Render checkbox selected each time you save 
the project, so the clip will be updated in the Motion project. If you deselect the 
Render checkbox, you will not be able to reconnect the audio file project with the 
audio track, and your changes will be lost.

When you have followed the steps described above, the clip is updated in Motion. You 
hear the clip with the changes you made in the Waveform Editor, without having to 
reimport the clip. You can make roundtrips between Motion and Soundtrack Pro by 
opening the saved audio file project, making changes, then saving the project. Each 
time you save the project, the clip is updated in Motion.
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Using Soundtrack Pro With DVD Studio Pro

 

You can edit a DVD Studio Pro clip destructively by opening it in the Waveform Editor. 
When you edit a clip destructively, you hear the clip with the changes you made in the 
Waveform Editor without having to reimport the clip. You can save the clip as an audio 
file project in the Waveform Editor, so you can reopen it later and continue editing.

 

To edit a clip destructively in the Waveform Editor:
1

 

In DVD Studio Pro, Control-click the clip, then choose Open in Editor from the shortcut 
menu.

Soundtrack Pro opens and the clip appears in the Waveform Editor.

 

2

 

Edit the clip in the Waveform Editor.

You can edit the audio file project in the Waveform Editor using the commands and 
functions described in Chapter 7, “Working in the Waveform Editor,” on page 143. You 
can apply actions or analyze the file and fix analyzed problems. 

 

3

 

When you are finished editing the clip, choose File > Save. 

 

4

 

Click Save.

You can also save the clip by choosing File > Save As. If you save the clip using the Save 
As command, be sure the name, location, and file type in the Save As dialog are the 
same as for the clip’s source file.

You can also save the clip as an audio file project. If you save an audio file project as 
an AIFF file or a QuickTime movie, a link is included in the AIFF file or movie, letting you 
reopen the project in Soundtrack Pro and make changes to action settings and 
other edits.
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Using Soundtrack Pro With Other Applications
You can open an audio file exported from Soundtrack Pro (a project mix, an exported 
track, bus, or output, or an audio file project saved as an AIFF file or a QuickTime movie) 
in any application that supports audio files. 

When you save an audio file project using the Save As command, be sure the Render 
checkbox is selected in the Save As dialog.

If you save an audio file project as an AIFF file or a QuickTime movie, a link is included 
in the AIFF or movie, letting you reopen the project in Soundtrack Pro and make 
changes to action settings and other edits. 

When you reopen the AIFF or QuickTime movie in Soundtrack Pro, a dialog appears, 
asking if you want to open the audio file or the original project. In the dialog, click 
Open Project. The audio file project opens in the Soundtrack Pro Waveform Editor so 
you can continue working. When you are finished working in Soundtrack Pro, be sure 
to save the audio file project before saving it as an AIFF or QuickTime movie so your 
changes are retained.

If you export a saved multitrack project using Export > Export Mix, a link is included in 
the exported file, letting you reopen the multitrack project in Soundtrack Pro and make 
changes. The project must have been previously saved at least once before you export 
the project mix.

When you reopen the exported file, a dialog appears, asking if you want to open the 
audio file or the original project. In the dialog, click Open Project.

The multitrack project opens in the Soundtrack Pro Timeline so you can continue 
working. When you are finished working in Soundtrack Pro, be sure to save the 
multitrack project before exporting a project mix so your changes are retained.
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Some audio files you use in Soundtrack Pro can include metadata called tags. Tags 
provide information about the audio recorded in a file. Soundtrack Pro uses tags in one 
of two ways: 
Â To help locate files using the Search feature in Soundtrack Pro
Â To provide information that Soundtrack Pro uses when matching the file’s tempo and 

key to the project tempo and key, for the best possible playback quality

Both AIFF and WAV file formats can include tags. Libraries of audio files created for use 
with loop-based music software are usually tagged, and Soundtrack Pro recognizes the 
tags used in most popular file formats. 

What Is Apple Loops Utility?
Apple Loops Utility is a companion application to Soundtrack Pro that you can use to 
view and manage tags in audio files. You can add and change tags using 
Apple Loops Utility; you can also tag multiple files, a process known as batch tagging. 

Apple Loops Utility can read both AIFF and WAV file formats. When you save changes 
you make to either type of file, the file is saved as an AIFF file, the default file format for 
Soundtrack Pro. The set of tags you can work with using Apple Loops Utility includes all 
of the tags in WAV files tagged for use with Sony’s ACID music application, as well as 
additional tags.

Tagged audio files can also contain information about transients. Transients indicate 
where beats occur in the file, and Soundtrack Pro uses transients to play back audio 
files at the highest level of quality. Apple Loops Utility can detect transients present in 
an audio file, and you can use Apple Loops Utility to add markers for additional 
transients and move them to new locations.
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The Apple Loops Utility Interface
The Apple Loops Utility interface consists of a window with two tabs: the Tags tab and 
the Transients tab. The bottom of the window includes a set of playback controls and 
file management buttons. Apple Loops Utility also includes an Assets drawer, located to 
the right of the main window, where you manage open files.

Assets drawerPlayback controls

Tabs Main window
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Tags Tab
The Tags tab includes areas for different types of tags, and also includes a set of 
playback controls you can use to listen to a file open in Apple Loops Utility. Listening to 
a file can help you decide which tags are appropriate for the file. 

Property Tags
Â Number of Beats field:  Displays the number of beats in the file. 
Â File Type buttons:  Set the file type, which can be Non-looping or Looping.
Â Key pop-up menu:  Sets the key of the file. 
Â Scale Type pop-up menu:  Sets the file’s scale type. The choices are Major, Minor, Good 

for Both, and Neither.
Â Time Signature pop-up menu:  Sets the file’s time signature. The choices are 4/4, 3/4, 

5/4, 6/8, and 7/8.
Â Author field:  Displays the name of the file’s author. You can enter a new name by 

typing in the field.
Â Copyright field:  Displays the file’s copyright data, if it exists. You can enter new data 

by typing in the field.
Â Comment field:  Displays any comments about the file. You can enter comments by 

typing in the field.
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Search Tags
These tags are used by the Search feature in Soundtrack Pro when you search for files 
matching specific criteria.
Â Genre pop-up menu:  Displays choices for the musical genre of the file.
Â Instrumentation list:  Displays choices for the musical instrument or instrument 

category recorded in the file. Selecting an instrument category in the left column 
displays the list of instruments in that category in the right column.

File Info
This area of the Tags tab includes rows with Kind, Length, Date Modified, Sample Rate, 
Channels, Tempo, and File Location information. This information is for viewing only, 
and cannot be edited in the Tags tab.

Descriptors
Descriptors are complementary pairs of keywords describing the mood or character of 
the music recorded in the file. Each pair of keywords has a row of buttons, allowing you 
to choose either one keyword from the pair, or neither keyword.

Transients Tab
The Transients tab contains a large waveform display, with a Beat ruler and a horizontal 
scroll bar. Markers indicate the position of transients in the file. Typically, transients 
correspond to the peaks or most pronounced amplitude changes in a sound’s 
waveform. The Transients tab includes controls for the beat division and sensitivity with 
which Apple Loops Utility detects transients in the file. You can also listen to the file 
using the playback controls to help determine where transients occur.

Waveform of audio file

Transient marker

Sensitivity slider
Transient Division 
pop-up menu
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The Transients tab includes the following controls:
Â

 

Transient Division pop-up menu:

 

  Sets the beat value at which Apple Loops Utility 
detects transients.

Â

 

Sensitivity slider:

 

  Sets the degree of sensitivity at which Apple Loops Utility detects 
transients.

 

Assets Drawer

 

The Assets drawer lists the files open in Apple Loops Utility. The drawer, which is 
open when you open Apple Loops Utility, contains a Name column with the name of 
each open file, and a Changes column, which indicates any files to which you have 
applied changes. 

Add File and Remove 
File buttons

Changes column
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Playback and File Management Controls
The bottom of the Apple Loops Utility window contains a set of playback controls so 
that you can listen to the file in Apple Loops Utility. The playback controls do not affect 
the file’s tags, only the playback of the selected file. 

Â Go to Beginning button:  Starts playback from the beginning of the selected file.
Â Play button:  Plays back the selected file.
Â Stop button:  Stops playback of the selected file.
Â Key pop-up menu:  Transposes the selected file to a new key for playback.
Â Tempo slider:  Sets the playback tempo of the selected file. You can also enter a value 

in the field.
Â Volume slider:  Sets the playback volume of the selected file. You can also enter a 

value in the field.

When multiple files are selected, the playback controls are not available. You cannot 
play more than one file at a time.

There are two additional buttons at the bottom of the window, the Assets button and 
the Save button.
Â Assets button:  Shows and hides the Assets drawer.
Â Save button:  Saves your changes to the currently selected files in the Assets drawer.

Play button

Stop button

Assets button

Go to Beginning button

Tempo slider Volume slider

Key pop-up menu
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Opening Files in Apple Loops Utility
You can open audio files from within Apple Loops Utility, or directly from a 
Soundtrack Pro project. You can have up to 2000 files open at the same time. When 
you open files in Apple Loops Utility, the files are displayed in the File list of the 
Assets drawer.

To open an audio file in Apple Loops Utility, do one of the following:
m Choose File > Open, then select the file in the Open dialog.

m Choose File > Open Recent, then choose a file from the submenu.

m Click the Add File button in the Assets drawer.

m Drag files from the Finder to the Assets drawer.

To open an audio file from Soundtrack Pro into Apple Loops Utility:
m Control-click the file in Soundtrack Pro, then choose Open in Apple Loops Utility from 

the shortcut menu.

To open multiple files in Apple Loops Utility, do one of the following: 
m Choose File > Open, then Shift-click the files in the Open dialog.

m Drag the volume or folder containing the files from the Finder to the Assets drawer.

You can have multiple Apple Loops Utility windows open at the same time so that you 
can compare different files. Each time you open an Apple Loops Utility window, an 
Open dialog appears, letting you choose the file or files to open in that window. You 
can change the open window behavior in the Apple Loops Utility Preferences window. 
See “Apple Loops Utility Preferences” on page 274 for more information.
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Tagging Files in Apple Loops Utility
To tag files, you select the files in the Assets drawer, and then make changes to the 
selected files’ tags in the Tags tab. When you change the settings in the Tags tab, the 
changes are applied only to the currently selected files.

When you make changes to a file’s tags, a dot appears in the Changes column next to 
the filename to indicate that the file has been changed. You can select a file or group of 
files and make one or several changes, and then select another file or group of files and 
make different changes. Apple Loops Utility remembers all the changes you make as 
you work with different files. When you finish making changes, you can save changes 
to only the currently selected files, or save changes to all files marked in the Changes 
column of the Assets drawer.

Note:  Changing a file’s tags has no effect on the actual audio data recorded in the file. 
Changing the tag for the number of beats, for example, only changes the information 
used when Soundtrack Pro searches for files, not the actual number of beats recorded 
in the audio file. Similarly, changing the tag for key has no effect on the actual musical 
key of the audio file.

To tag a single audio file:
1 Select the file in the Assets drawer. (If the drawer is closed, click the Assets button to 

open it.)

Note:  When a single file is selected, you can use the Up and Down Arrow keys to move 
up and down the files in the Assets drawer. You can listen to the file using the playback 
controls.

2 Make the changes you want to the file’s tags in the Tags tab. 

See “Tags Tab” on page 265 for information about the options in the Tags tab.

3 Click Save to save changes to the selected file, or click Save All to save all changes. 
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Tagging Multiple Files
When multiple files are selected, only the tags that apply to all the selected files can be 
changed. Items in the Tags tab that do not apply to all the currently selected files are 
dimmed and unavailable. 

Each tag has a checkbox. Select the checkbox next to the tags for which you want to 
save changes.

To tag multiple files:
1 Select the files in one of the following ways:

Â Shift-click to select adjacent files in the Assets drawer.
Â Command-click to select nonadjacent files in the Assets drawer. 
Â Press Command-Shift-A to select all files in the Assets drawer.

2 Make the changes you want to the available tags for the selected files in the Tags tab. 

See “Tags Tab” on page 265 for information about the options in the Tags tab.

3 Select the checkboxes next to the tags for which you want to save changes.

4 Click Save to save changes to the selected files, or click Save All to save all changes. 

There are many keyboard shortcuts to simplify the task of tagging files. For a complete 
list of keyboard shortcuts, see “Apple Loops Utility Keyboard Shortcuts” on page 275.

Working With Transients
Transients are the points in an audio file where beats occur. Typically, transients occur 
at the widest areas of a waveform in the waveform display. During playback, 
Soundtrack Pro adjusts looping files using a technique called stretching to achieve the 
best audio quality, based on the loop’s transients. Non-looping files are not affected by 
stretching.

When you open a file in Apple Loops Utility, it looks for transients at every 16th note 
position, based on the file’s tags for tempo and the number of beats. You can change 
the beat value at which Apple Loops Utility detects transients using the Transient 
Division pop-up menu. 

To display a file in the Transients tab:
m Select the file in the Assets drawer, then click the Transients tab.

The Transients window can display only one file. If multiple files are selected, no 
waveform is displayed in the window. The waveform display in the Transients tab 
displays both the transients detected by Apple Loops Utility and transients you add to 
the file. You can add transients and move existing transients in the Transients tab.

To add a new transient:
m Click in the darker area above the Beat ruler in the waveform display.
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To move a transient marker:
m Drag the marker by its handle in the area above the Beat ruler.

To change the beat value of detected transients:
m Choose a beat value from the Transient Division pop-up menu.

Choosing a larger beat value results in fewer transients being detected. Choosing a 
smaller beat value results in more transients being detected, if they are present in the 
audio recorded in the file.

Sometimes transients occur at points in the audio file other than on a beat value. You 
can have Apple Loops Utility detect additional transients in the file using the Sensitivity 
slider. When you increase the sensitivity of transient detection, Apple Loops Utility 
considers points of higher amplitude in the waveform as transients, regardless of 
whether or not they occur at a beat value.

To change the sensitivity of transient detection:
m Drag the Sensitivity slider to the left to decrease the sensitivity, or to the right to 

increase the sensitivity of transient detection.

To remove a transient, do one of the following:
m Click the transient’s handle in the area above the Beat ruler, then press the Delete key.

m Drag the transient out of the area above the Beat ruler.
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Saving Changes to Files
When you save changes in Apple Loops Utility, you can save changes to only the 
currently selected files, or to all files marked in the Changes column of the Assets 
drawer. Any other file tags are unchanged. This is especially useful when working with a 
large group of files. 

When saving multiple files, the checkbox next to the tag must be selected if changes to 
that tag are to be saved. For information about tagging multiple files, see “Tagging 
Files in Apple Loops Utility” on page 270.

To save changes to the currently selected files:
m Click the Save button.

Saving changes to a large number of files may take several minutes. 

To save all changes:
m Click the Save All button in the Assets drawer.

To save multiple files to the same directory:
1 Choose File > Save As.

2 Navigate to the directory where you want to save the files, then click Save.

When you save multiple files using the Save As dialog, the files are saved to the 
selected directory, and their names are unchanged.

When you save changes to files in the WAV format, by default they are converted to the 
AIFF format and saved in the same location as the original WAV files. The new AIFF files 
have the same name as the WAV files, but with the .aiff file suffix. You can change this 
default behavior in the Apple Loops Utility Preferences window. See the following 
section, “Apple Loops Utility Preferences,” for more information.

Removing Files From the Assets Drawer
You can remove files from the Assets drawer.

To remove files:
m Select the file or files in the Assets drawer, then click the Remove File button at the top 

of the drawer (or press the Delete key).

If you remove files to which you have applied changes, a dialog appears letting you 
choose whether to save or discard your changes. 
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Apple Loops Utility Preferences
You can set preferences for the startup behavior and default file saving behavior in the 
Apple Loops Utility Preferences window. 

Startup
Â Show Open Panel On Launch: When selected, an Open dialog appears each time you 

open Apple Loops Utility.

Saving
Â When Converting a WAV to AIFF: 

Â Show Conversion Alert:  Shows the conversion alert dialog when you try to save a 
WAV file.

Â Close WAV and Edit AIFF:  Automatically converts the WAV to an AIFF, closes the WAV 
file, and opens the AIFF for editing.

Â Keep Working in WAV:  Leaves the WAV file open.
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Apple Loops Utility Keyboard Shortcuts

General and File

Navigation

Key command Function

Creates a new, blank Apple Loops Utility window and opens the 
Open dialog.

Opens the Open dialog, from which you open files in 
Apple Loops Utility.

Closes the current window.

Closes the selected files.

Saves changes to the currently selected files. If any of the files are 
WAV files, a dialog appears asking if you want to continue editing 
the files as WAV files or save them as AIFF files.

Opens the Save As dialog to save the currently selected file with a 
new name.

Saves all open files.

Selects the file above the current file in the Assets drawer.

Selects the file below the current file in the Assets drawer.

Selects all files in the Assets drawer.

+x N

+x O

+x W

+x +shift W

+x S

+x +shift S

+x option + S

+x +shift A

Key command Function

Makes the Tags tab active.

Makes the Transients tab active.

Makes the Assets drawer active.

F1

F2

F3
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Key and Scale Type Tagging

Key command Function

Turns on keyboard tagging.

Sets the key to A.

Sets the key to A# (A-sharp).

Sets the key to B.

Sets the key to C.

Sets the key to C# (C-sharp).

Sets the key to D.

Sets the key to D# (D-sharp).

Sets the key to E.

Sets the key to F.

Sets the key to F# (F-sharp).

Sets the key to G.

Sets the key to G# (G-sharp).

Sets the scale type to Major.

Sets the scale type to Minor.

Sets the scale type to Both.

Sets the scale type to Neither.

esc

A

+shift A

B

C

+shift C

D

+shift D

E

F

+shift F

G

+shift G

M

+shift M

+shift B

N
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Descriptor Tagging 
For the following descriptor keyboard shortcuts, pressing the key once selects the first 
(left) item, pressing the key again selects the second (right) item, and pressing the key 
a third time selects Neither (the center button).

Key command Function

Single/Ensemble

Part/Fill

Acoustic/Electric

Dry/Processed

Clean/Distorted

Cheerful/Dark

Relaxed/Intense

Grooving/Arrhythmic

Melodic/Dissonant

Sets Batch Tagging to All.

Sets Batch Tagging to None.

1

2

3

4

5

6

7

8

9

F5

F6
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Transients

Key command Function

Increases sensitivity.

Decreases sensitivity.

Increases sensitivity five times.

Decreases sensitivity five times.

Nudges the selected marker by one pixel to the left.

Nudges the selected marker by one pixel to the right.

Selects the previous marker.

Selects the next marker.

=

-

+shift =

+shift -

+x

+x
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B Soundtrack Pro 
Keyboard Shortcuts

General and File

Windows, Tabs, and Layouts

Key command Function

Creates a new, blank multitrack project.

Creates a new audio file. 

Opens the Open dialog.

Closes all open projects. 

Saves the current project.

Opens the Save As dialog to save the project with a new name.

Opens the Save As dialog to save a copy of the project with a 
different name. 

Adds the selected audio file to the Bin. 

Closes all projects and quits Soundtrack Pro. 

+x N

N+x +shift

+x O

shift W+x +

+x S

+x +shift S

Scontrolx ++

x B+

Q+x

Key command Function

Opens the Mixer for the current multitrack project.

Opens the Video tab of the Utility window.

Opens the Project window.

+x 1

+x 2

+x 3
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Project Playback and Setting the Playhead

Opens the Browser tab of the Media and Effects Manager.

Opens the Effects tab of the Media and Effects Manager.

Minimizes Soundtrack Pro.

Hides Soundtrack Pro. 

Hides all other windows.

Shows the Preferences window. 

Opens the Soundtrack Pro User Manual.

Moves to the previous (left) tab. 

Moves to the next (right) tab. 

Switches the project layout to the Basic layout. 

Key command Function

+x 4

+x 5

+x M

H+x

Hx option+ +

,+x

shift ?+x +

]x option+ +

]option+ ++x shift

F1

Key command Function

Starts playing the project.

If the project is playing, stops project playback.

Moves the playhead to the beginning of the project, or to the 
beginning of the playback region if it is active.

Starts playback from the beginning of the project. 

Moves the playhead to the position of the preceding marker.

Moves the playhead to the position of the next marker.

Moves the playhead to the position of the previous frame in the 
video clip.

Moves the playhead to the position of the next frame in the 
video clip.

space

space

return

return+shift

+option M

+shift M

+x

+x
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General Editing

Editing Audio Clips in the Timeline

Key command Function

Undoes the last command.

Redoes the last undone command.

Cuts the selected item.

Ripple cuts the selected item. 

Copies the selected item.

Pastes the cut or copied item.

Ripple deletes the selected item.

Duplicates the selected item.

Selects all items in the window.

Deselects all items in the window. 

Turns snap on or off. 

+x Z

+x +shift Z

+x X

X+x +shift

+x C

+x V

delete

+x D

+x A

A+x +shift

N

Key command Function

Opens the Paste Mix dialog so that you can paste audio and mix it 
with the existing audio. 

Opens the Paste Repeat dialog so that you can paste multiple 
copies of the cut or copied audio clip.

Splits the selected audio clips under the playhead.

Joins the selected clips.

Crossfades the selected clips.

shift V+x +

+x option + V

S

J

F+x
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Adjusting Audio Clips in the Timeline

Navigating in the Timeline

Trims the selected clips.

Double-click an audio clip. Opens the selected audio clip in the Waveform Editor as a new 
audio file project. 

Key command Function

Zx option ++

Key command Function

Nudges the clip or envelope point to the left by one pixel.

Nudges the clip or envelope point to the right by one pixel.

Nudges the envelope point up by one pixel.

Nudges the envelope point down by one pixel.

Shifts the clip or envelope point to the left by one gridline.

Shifts the clip or envelope point to the right by one gridline.

Shifts the envelope point up by five pixels.

Shifts the envelope point down by five pixels.

+option

+option

+option

+option

+ +shiftoption

+ +shiftoption

+ +shiftoption

+ +shiftoption

Key command Function

Zooms in horizontally to the next zoom level.

Zooms out horizontally to the next zoom level.

Zooms in vertically to the next zoom level. 

Zooms out vertically to the next zoom level. 

Zooms in on the current selection. 

or +x =

or +x -

+x +

shift _+x +

Z+option
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Editing Audio Files in the Waveform Editor

Returns to the default zoom level.

Fits the project in the display size.

Reduced track height

Small track height

Medium track height

Large track height

Key command Function

+x 0

+shift Z

+x 6

+x 7

+x 8

+x 9

Key command Function

Normalizes the audio file or selection. 

Adjusts the amplitude of the audio file or selection. 

Replaces the audio file or selection with complete silence. 

Saves the current actions in the Actions list as an AppleScript 
droplet. 

Flattens audible actions, as indicated by the position of the Action 
Insert bar. 

Flattens all actions in the project. 

Adjusts selection inward to zero crossing.

Adjusts selection outward to zero crossing.

Adjusts in point left to zero crossing.

Adjusts in point right to zero crossing.

Adjusts out point left to zero crossing.

Adjusts out point right to zero crossing.

Lx +

L+x +shift

+x delete

+ Soption+x

x E+

shift E+x +

I+shift

O+shift

[+shift

]+shift

]option +

]option+ +shift
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Tracks and Markers

Video Out

Key command Function

Adds a new track to the Timeline below the selected track.

Adds a new bus to the Timeline below the selected bus. 

Adds a new output to the Timeline below the selected output. 

Removes the selected track, bus, or output from the Timeline.

Inserts a beat marker at the current playhead position.

Inserts a time marker at the current playhead position.

Adds time markers at the beginning and end of selection. 

+x T

+x + Tcontrol

x + Toption+

+x +shift T

B

M

M+control

Key command Function

Play using external video output device. 
F12+x
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Recording

Key command Function

Makes Take 1 the active take for the selected clip. 

Makes Take 2 the active take for the selected clip. 

Makes Take 3 the active take for the selected clip. 

Makes Take 4 the active take for the selected clip. 

Makes Take 5 the active take for the selected clip. 

Makes Take 6 the active take for the selected clip. 

Makes Take 7 the active take for the selected clip. 

Makes Take 8 the active take for the selected clip. 

Makes Take 9 the active take for the selected clip. 

1+x option+

2+x option+

3+x option+

4+x option+

5+x option+

6+x option+

7+x option+

8+x option+

9+x option+
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C Audio Basics

You can create professional-sounding music projects in Soundtrack Pro without any 
background or training in music. This chapter describes the basic audio and music 
concepts you need to know to get started.

Basic Audio Concepts 
In order to understand how you can work with audio files and use the controls, effects, 
and envelopes included in Soundtrack Pro, it’s helpful to know some basic terms and 
concepts about audio. 

Sound Waves
What we hear as sounds are vibrations traveling through the air as sound waves. Sound 
waves move through the air like ripples in a pond, radiating outward from the sound’s 
source in a regular pattern of compression and rarefaction. 

Frequency and Amplitude
The rate at which a sound wave repeats (the time between two peaks of the wave) is 
called its frequency. Frequency is expressed in cycles per second, or Hertz (Hz). We hear 
a sound’s frequency as being relatively high (like a flute, a child’s voice, or a train 
whistle) or low (like a bass guitar, a man’s voice, or the rumble of a train on the tracks). 
The range of frequencies audible to human beings is roughly 20 Hz–20 kilohertz (kHz). 

The depth or intensity of a sound is called its amplitude, and is expressed in decibels 
(dB). We hear amplitude as the volume or loudness of a sound. The range of audible 
loudness is roughly 0–130 dB. Higher decibel levels are painful to human hearing. 

Frequency

Amplitude Time
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Musical Sounds
Musical sounds typically have a regular frequency, which we hear as the sound’s pitch. 
Pitch is expressed using musical notes, such as C, Eb, and F#. What we hear as the pitch 
is only the lowest, strongest part of the sound wave, called the fundamental. Every 
musical sound also has higher, softer parts called overtones or harmonics, which occur 
at regular multiples of the fundamental frequency. We don’t hear the harmonics as 
distinct pitches, but rather as the tone color (also called the timbre) of the sound, which 
lets us distinguish one instrument or voice from another, even when both are playing 
the same pitch. When you turn up the treble on your stereo, or adjust an EQ effect, you 
raise the volume of some of the harmonics in the music, but don’t change the 
fundamental frequencies. 

Fundamental

First harmonic

Second harmonic

Time

Time

Time



Appendix C    Audio Basics 289

 

Envelopes
Another aspect of sound that helps us to distinguish between instruments and voices 
playing the same pitch is a sound’s envelope. Every note played on a musical 
instrument has a distinct curve of rising and falling volume over time. Sounds 
produced by some instruments, particularly drums and other percussion, start at a high 
volume level but quickly decrease to a much lower level, and die away to silence 
quickly. Sounds produced by other instruments, for example, a violin or a trumpet, can 
be sustained at the same volume level, and can be raised or lowered in volume while 
being sustained. This volume curve is called the sound’s envelope, and acts like a 
signature to help our ears recognize what instrument is producing the sound. 

Phase Relationships
When two instruments or voices are playing the same pitch, the sound waves may 
have the exact same frequency and amplitude, but the peaks and troughs of the wave 
reach our ears, or a microphone recording the sound, at slightly different times. This is 
referred to as a difference in the phase of the sound waves. When two sound waves are 
completely in phase, the volume of the sound is doubled. When two sound waves are 
completely out of phase, they cancel each other out and we hear silence. Certain 
effects, such as phase shifters, make use of these properties of phase relationships to 
alter the sound of an audio signal.

Recording Sound
When a sound is recorded, the sound waves traveling through the air are converted to 
an electrical signal, using a device called a transducer. Sound can be recorded using 
either analog or digital recording technology.

Sustained envelopePercussive envelope

Time
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Analog Recording
When a sound is recorded using analog technology, the sound waves are recorded as a 
continuous electrical signal. Typically, the vibrations in the air contact the diaphragm of 
a microphone, setting the diaphragm in motion. A transducer in the microphone 
converts the diaphragm’s motion into an electric signal. The compressed parts of the 
sound wave are recorded as positive electrical voltages, and the rarefied parts of the 
wave are recorded as negative voltages. The voltage of the recorded signal is an analog 
of the wave’s frequencies and their relative amplitudes at any point in time. 

Analog recording technology was originally developed using mechanical means to 
etch the sound signal directly onto wax cylinders or lacquer disks. Its simplicity, and the 
rapid development of electronics during the twentieth century, led to its widespread 
use for recording music and for adding sound to motion pictures. 

However, analog audio recording is subject to several problems in achieving high-
fidelity reproduction of sound. These include noise, distortion, and loss of quality each 
time the audio signal is copied or reproduced.

Digital Recording
When a sound is digitally recorded, the sound waves are recorded as a series of samples 
onto a hard disk or other digital storage medium. A sample stores the voltages 
corresponding to the wave’s frequencies and their relative amplitudes as a series of 
binary numbers, or bits. Each sample is like a snapshot of the sound at a particular 
instant in time. 

Time

Time
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Digital recording technology offers several advantages over analog technology for 
recording sound, including lower noise, wider frequency response, and less distortion 
(if the sound is recorded at the proper level). In addition, digital recordings can be 
reproduced any number of times without any loss of audio quality. These advantages, 
combined with the popularity of personal computers, have led to the rapid 
development of digital audio as a leading technology for music production. 

Sample Rate and Bit Depth 
The audio quality of any digital recording depends on two factors: the sample rate and 
the bit depth used to record the signal. The sample rate is the number of samples 
recorded per second. The bit depth is the number of digital bits each sample contains. 
Together, these two factors determine the amount of information contained in a digital 
audio recording. The higher the sample rate and bit depth of a recording, the more 
accurately the recording reproduces the original sound. 

Recording music digitally requires a very high sample rate and bit depth to reproduce 
the nuances in the music satisfactorily. The Nyquist theorem states that sounds must be 
recorded at no less than double the rate of the highest frequency being sampled to 
accurately reproduce the original sound. Audio CDs are recorded at a sample rate of 
44.1 kHz and a bit depth of 16 bits (some CDs use a higher 20- or 24-bit depth). Audio 
for DVDs is often recorded using a slightly higher sample rate of 48 kHz. Soundtrack Pro 
lets you record and play back digital audio files at sample rates of up to 96 kHz, and at 
bit depths of up to 24 bits. 

Low sample rate

High sample rate

Time

Time
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Digital Distortion
To record sound with the widest possible dynamic range, the input level must be set 
high enough to capture the complete audio signal. When the input level of the signal is 
set too high, however, the signal exceeds the maximum level that can be sampled or 
reproduced accurately, resulting in digital distortion. Digital distortion is defined for 
most digital audio applications, including Soundtrack Pro, as any time the signal rises 
above 0 dB. Even a single sample above 0 dB can produce noticeable distortion, which 
you hear as a sharp crackling sound in the audio output. Digital distortion is nearly 
always undesirable, and Soundtrack Pro includes level meters and other controls so 
that you can identify and remove distortion from your projects. 

Time



 

    

 

 

 

293

 

D

 

A
pp

en
di

x

 

D

 

Solutions to Common Problems 
and Customer Support

 

If you run into problems while working with Soundtrack Pro, there are several resources 
you can use to find a solution.
Â

 

This appendix:

 

  This appendix includes information about some of the most frequent 
issues users encounter.

Â

 

Late-Breaking News:

 

  A late-breaking news page in the Soundtrack Pro Help menu 
provides last-minute information that didn’t make it into the manual. Be sure to 
consult this help page as soon as you install or upgrade Soundtrack Pro.

Â

 

AppleCare Knowledge Base:

 

  AppleCare Support maintains a database of common support 
issues that is updated and expanded to include new issues as they arise. This is an 
excellent, free resource for Soundtrack Pro users. To access the AppleCare Knowledge 
Base, go to the AppleCare support page at http://www.apple.com/support.

Â

 

AppleCare Support:  

 

There are a variety of support options available to Soundtrack Pro 
customers. For more information, see the 

 

Apple Professional Software Service & 
Support Guide

 

 that comes with your Soundtrack Pro documentation. 
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Solutions to Common Problems

Audio Files and Audio Interfaces
There are several factors that can affect performance when working with digital audio 
files. Observing the following guidelines will help you maintain the highest possible 
performance when working with Soundtrack Pro projects:
Â Because digital audio files require intensive processing by the computer’s processor, 

do not perform other processor-intensive tasks while working in Soundtrack Pro.
Â External audio interfaces connected to your computer can be susceptible to latency, 

a noticeable delay between the time the audio signal is produced and the time it 
reaches the computer. Some hardware and software manufacturers offer guidelines 
for reducing the amount of latency for their equipment. Be sure to read the 
documentation that came with your audio interface.

Â If you are using a USB audio interface, make sure the audio interface is directly 
connected to your computer. Do not connect a USB audio interface through a USB 
hub, or chain it through another USB device.

Â If you experience unwanted noise or hiss, check the connections between your 
computer and any external audio devices. Refer to the documentation that came 
with each device for any additional instructions on dealing with noise.

Eliminating Recording Latency
You can use the Latency Compensation setting in the Preferences Recording pane to 
eliminate any latency inherent in your recording device. You calculate the latency by 
playing a loop and recording it at the same time, as described below:

1 Use an appropriate cable to connect the audio output port you are using to the input 
port for the device from which you plan to record.

2 Choose a loop with a large number of transients, such as a drum loop. 

3 Set the tempo to 60 bpm (to simplify the latency calculation).

4 Click the Record Enable button in the header of the track to which you want to record. 

5 In the Recording tab, set the Input device to the recording device.

6 Set Monitor to None and ensure that hardware monitoring on your recording device is 
turned off. You may also need to reduce input or output volumes of your devices in 
order to avoid feedback.

7 Click the Record button and let the loop play for a few seconds. Then click Stop.
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8

 

Visually compare the original track and the newly recorded track. Zoom in to identify a 
place where the tracks have identical waveforms but are not lined up. Set the playhead 
at the corresponding identical points on the two waveforms and subtract the two 
Beats field values. This is the latency in milliseconds. If the recorded audio is late (to the 
right), you enter a positive value; if it’s early (to the left), you enter a negative value. For 
example, if the location in beats of the selected point in the source loop is 1.2.002 and 
the location in beats of the corresponding point in the recording is 1.2.008, the latency 
is 6 milliseconds.

 

9

 

Enter the latency value in the Recording Preferences pane.

 

10

 

Mute the recorded track and test record the loop again to make sure the latency 
is eliminated.

 

Calling AppleCare Support

 

Included in your Soundtrack Pro package is documentation about the support options 
available from Apple. Several levels of support are available, depending on your needs.

Whatever your issue, it’s a good idea to have the following information immediately 
available. The more of this information you have ready to give to the support agents, 
the faster they will be able to address your issue.
Â

 

The registration number that came with Soundtrack Pro. This number is different 
from the software serial number that is used to activate your copy of Soundtrack Pro.

Â

 

Which version of Mac OS X you have installed. This information is available by 
choosing About This Mac from the Apple menu. 

Â

 

The version of Soundtrack Pro you have installed, including updates if applicable. The 
version number can be viewed by choosing Soundtrack Pro > About Soundtrack Pro.

Â

 

The model of computer you are using
Â

 

How much RAM is installed in your computer, and how much is available to 
Soundtrack Pro. You can find out how much RAM is installed by choosing About This 
Mac from the Apple menu in the Finder. 

Â

 

What other third-party hardware is connected to or installed in the computer, and 
who are the manufacturers. Include hard disks, video cards, and so on. 

Â

 

Any third-party plug-ins or other software installed along with Soundtrack Pro

AppleCare Support can be reached online at: 
http://www.apple.com/support/soundtrackpro
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pasting in Waveform Editor  158
phase issues  178
pops  178
power line hum  178
recording. See recording audio
reducing noise in  168–169
silence in  163–164
silence threshold  178
temporary mono mix  140
in video clips  189
volume. See volume

audio analysis tools  177–180
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changing offset of  116–117
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crossfades between  111–112
cutting  108
described  87
duration of  110–111
editing  107–119
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keyboard shortcuts  281–282
moving  109–110
name of  90
overlapped  113
pasting  108–109
playback mode  117
properties  89–90
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removing  108, 119
replacing source audio in  117–119
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selecting  107
snapping  72–73, 110
splitting  113–114
transposing  115–116
truncating  113
undoing changes  71
zooming in/out  95–96

audio connectors  16, 17–18
audio effects. See effects
audio equipment, connecting  15–19
audio file project format  144
audio file projects

See also projects
closing  145
creating  145
editing in Waveform Editor  154–160
exporting. See exporting items

getting started with  144–152
importing video into  183, 184
opening in Waveform Editor  144–145
overview  8, 46
playing  50–56, 152
processing in Waveform Editor  161–170
recording. See recording audio
saving  146–148
saving projects as  146–147
scrubbing  54

audio files
AAC  56
adding to multitrack projects  87–89
adding to Timeline  87–89
AIFF  56
ambient noise in  166–167
amplitude  163
analyzing in Waveform Editor  177–180
on CD-ROM discs  14
on hard disks  14
common problems  294
editing in Waveform Editor  154–160
exporting projects to  248
finding. See finding items
formats for  56
gain of  163
graphically editing  159–160
information about  43
inserting noise in  164
length of  176
looping  57, 117
moving between selections  157
MP3  56
non-looping  57, 117
normalization  162
opening in Apple Loops Utility  269
opening in Waveform Editor  144–145
phase of  163
playing in Waveform Editor  152
previewing  68–69
processing in Waveform Editor  161–170
QuickTime  56
reconnecting  74
reducing noise in  168–169
sample rates  83
saving  147–148
saving with projects  87, 252
scrubbing in Waveform Editor  153
selecting in Waveform Editor  154–157
selecting parts of  154–156, 159
silence in  163–164
size of  235
source  107, 117–119
storing in Bin  67–68
supported formats  144
tagged  60
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tagging with Apple Loops Utility  263–278
time stretching  160, 166
unable to find  74
WAV  56

audio input  14
audio interfaces  15
audio output  14, 18–19
audio postproduction  7, 198
audio repair. See analysis tools
audio tracks. See tracks
Audio Units plug-ins  14, 195
Auto Gain parameter  205
automation  219–233

described  219
envelopes  219–227
modes for  228
processing effects  216
realtime effects  213
recording automation data  228–229
recording in Mixer  140
Timeslices  229–233

Automation Mode pop-up menu  26, 29, 31
automation modes

Latch  228
Read  228
Touch  228

automation recording sensitivity  76
automation sensitivity  229

B
Back button  34, 35
bandpass filters  200
bandwidth  200
bass frequency range  200
batch tagging  263
Beat display  52
beat divisions  82
beat markers  120–122
beats  82, 84, 98
Beats-based format  82, 83, 98, 104, 233
Beats-based time  52, 53, 192
Beginning value slider  44
Bin tab

adding audio files from  89
described  38
storing files in  67–68

bit depths  15, 56, 144, 291
boost  19, 198–200
Browser tab  34, 58
bus controls  91, 102–106
busses

adding  100
adjusting pan position  102
adjusting volume  102
changing icon for  101

copying  101
described  93
effects  104–105
envelopes for  106
exporting  248–249
moving  101
muting  103
numbered  101
overview  91
removing  106
renaming  101
selecting  100
sends routed to  212
setting height of  97
soloing  103
working with  99–106

buttons
control surface  245–246
mapping commands to  245–246
Toolbar  49

Button view  36, 37, 60, 63–65
Button View button  37, 60
bypass  211, 213
Bypass button  161

C
cables, audio  17–18
camcorders  15
Can’t Find File dialog  74
Cancel button  161
Category list  39
Category pop-up menu  37
CD-ROM discs  14
CDs

audio  76, 291
distributing projects on  247
sample rate  76, 291

center frequency  200
chaining effects  210–211
channel layout, editing  251
channels

selecting in Waveform editor  155–156
swapping  163

Channel Strip pop-up menu  29
channel strips  29–30

adding to Mixer  126
changing icon for  131
copying  127
described  125
effects  134–136
enabling for recording  131
muting  130
pan position  129
removing  134
renaming  131
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reordering  127
selecting  126
sends  137
setting outputs for  129–130
soloing  130
stereo level meters  133
volume levels  127–128
working with  125–134

chorus effects  201
Clear Fixed button  33
clicks  178
Clip display  43
clipped signals  178
clipping  138, 139, 198
clipping indicators  139
clips. See audio clips; video clips
Clip Speed pop-up menu  43
Collect Source File checkbox  147
Column view  36, 37, 60, 60–62
Column View button  37, 60
compressed, saving projects  87
compression  87, 197
Compressor application  46, 250–251
compressors  197
Computer button  34
connectors  17–18
controls  125, 245
control surfaces  243–246

adding  244
automation modes  246
connecting  243
deleting  244
described  243
FireWire audio interface  21
mapping commands to  245–246
preferences  79
premapped controls  245
recording movements  246
support of  19
types of  243
using  243

Control Surfaces preferences  79
Convert to Mono command  167
Copy from Next Point button  44
Copy from Previous Point button  44
copying items

audio clips  108
audio in Waveform Editor  157
channel strips  127
envelope points  225
Timeslices  231

Correlation meter  204
crossfade mode  85, 112
crossfades

adjusting  112
creating  85, 111–112

moving  112
customer support  293–295
Customize sheet  49, 50
cutoff frequency  200
cuts  204, 281
cutting items

audio clips  108
audio files  157
envelope points  225
frequencies  198, 199
peak levels  197
Timeslices  231

Cycle button  25, 55, 238
cycling playback  98–99

D
daisy-chaining  15
DC offset  178
decay time  203
delay  196
delay effects  196, 202
delay rate  202
delay time  203
deleting items

actions  176
audio clips  108, 119
beat markers  122
busses  106
channel strips  134
control surfaces  244
effects  136
envelope points  225–226
layouts  48
markers  122
outputs  106
realtime effects  214
scoring markers and  122
time markers  122
Timeslices  231, 232
tracks  106
unable to delete scoring markers  122
video clips from projects  193

Denoiser effect  206
depth  202
descriptors  266, 277
Details tab  43–44, 188–189
diagnostic effects  196, 204–205
digital audio  14

See also audio
digital audio connectors  18
digital audio interfaces  15
Digital Cinema Desktop  187
digital recording  290–291
digital video  83

See also video
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directories  65–67
disk space  14, 41, 235
disk space indicator  41
distortion  196, 198, 292
distortion effects  196
distributing projects  247, 252
dithering  147
Dock, minimizing windows to  47
downsampling  83
drag handles  27, 30, 91, 92
drop frames  190
droplets  181, 283
dry signal  203
dual mono files  248–249
Duration value slider  43, 44
DVDs

audio  76, 291
distributing projects on  247
sample rate  76, 291
video for  83

DVD Studio Pro, editing clips from  260
dynamic range  18, 178, 197, 205, 292
dynamics  196
dynamics effects  196, 197–198

E
editing items

actions  172
audio clips  107–119
audio files in Waveform Editor  154–160
channel layout  251
clip properties  89–90
destructive edits  253, 255, 260
DVD Studio Pro clips in Waveform Editor  260
envelope points  224–225
Final Cut Pro clips in Waveform Editor  253–255
keyboard shortcuts for  281–284
Motion audio tracks in Waveform Editor  258–259
nondestructive edits  253–255, 258
samples  159
with Soundtrack Pro scripts  256

education users  11
Effect list  39, 105, 207, 208
effect parameters  39, 207
Effect Parameters area  39, 105
effect presets  217–218
effects  195–214

adding  134
bus  104–105
channel strips  134–136
chorus  201
delay  196, 202
deleting  136
Denoiser effect  206
described  195

diagnostic  196, 204–205
distortion  196, 198
dynamics  196, 197–198
envelopes and  220, 227
EQ  196, 198–201
filter  196, 198–201
included with Soundtrack Pro  196–207
miscellaneous  196, 206–207
Mixer  134–136
modulation  196, 201–202
output  104–105
processing. See processing effects
realtime. See realtime effects
reordering  135
replacing  136
reverb  196, 203–204
settings  135
Stereo Spread plug-in  207
tail  170, 171
third-party  14
time-based  202–204
track  104–105
turning off  136
turning on  136, 137
types of  196–207

Effects button  27, 32, 104–105
effects chains  195, 210–211
effects slots  30
Effects submenu  161–162
Effects tab

adding effects to channel strips  135
adding effects to tracks/busses/outputs  104–105
overview  39
realtime effects  207–215

enabling track for recording  131, 236
end-of-project marker  86
End value slider  44
envelope points  221–226

adding  221
changing position of  223, 224
changing values of  223
copying  225
cutting  225
deleting  225–226
editing  224–225
information about  44
moving  219, 222
nudging  225
pasting  226
reducing number of  229
scoring markers and  192
selecting  222
viewing details  224

envelopes  219–229
adding  227
bus  106
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described  289
effects and  220, 227
hiding  106
master  219, 220–221
output  106
overview  219–220
percussive  289
removing  227
sends and  227
showing  106, 220
sustained  289
Timeslices  229–232
track  106, 220
track pan  220
volume  220

envelopes disclosure triangle  28
EQ (equalization)

frequency ranges used with  199–200
graphic  201
overview  198–201
parametric  201

EQ effects  196, 198–201
equipment

connecting audio equipment  15–19
example hardware setups  19–21
setting up. See system setup

exclusive solo  103
exporting items

busses  248–249
multitrack projects to Final Cut Pro  258
outputs  248–249
project mixes  248
projects with Compressor  250–251
projects to audio files  248
tracks  248–249

export presets, Compressor  251
external video output device  188

F
Fade In command  162
Fade Out command  162
fading audio in/out  162
Favorites  59
Favorites list  35
Favorites tab  35, 59
feedback  202, 203
File Browser. See Browser tab
file formats. See formats
File Info area  266
File list  34, 38
files

audio. See audio files
dual mono  248–249
finding. See finding items
keyboard shortcuts  279

looping  57, 114, 117, 239
media. See media files
mono  167, 248–249
non-looping  57, 117, 239
source  107, 117–119
stereo  167, 248–249
supported formats  56
tagged  60, 263–278
unable to find  74
video. See video files

File Type pop-up menu  37
filter effects  196, 198–201
filters  200
Final Cut Pro

exporting multitrack projects to  258
importing video from  183
saving droplets to clips in  182
scoring markers  191–193
Soundtrack Pro and  8
using Soundtrack Pro with  253–258
Waveform Editor and  146

Final Cut Pro clips
creating multitrack projects with  256–258
editing clips in Waveform Editor  253–255
editing with Soundtrack Pro scripts  256

Finder, adding audio files from  89
finding items

with Browser tab  58
with Favorites tab  59
keywords  36–37
with Search tab  60–67

FireWire audio interface  21
FireWire connectors  16
FireWire technology  16
FireWire website  11
Fix All button  33
Fix button  33
flangers  202
formats

audio  56, 144
audio file project  144
time  190
video  183

Forward button  34, 35
frame rates  190
frequencies  165, 198, 204, 287
frequency bands  205, 206, 207
frequency ranges  199–200
frequency spectrum  151–152
fundamental  288

G
gain  163, 198, 200, 205
Gain field  41
gain slider  41
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General preferences  75
Global Timeline view  26, 97
Global Waveform view  32, 150
Goniometer  205
Go to Beginning button  25, 55
Go to End button  25, 55
Go to Peak buttons  42, 139
graphic EQs  201
gridlines  93

H
hard disk  14
hardware

requirements  13
sample rates  83

harmonics  288
headers  27–28
help

keyboard shortcuts  280
onscreen  10

high frequency range  199
highpass filters  200
hints  43, 61, 70
hiss  294
Home button  34
hubs  15
hum, power line  178

I
icons

busses  27, 101
changing for channel strips  131
channel strips  30
headers  27
outputs  27, 101
showing in Toolbar  50
tracks  27, 101

IEEE 1394. See FireWire
importing items

QuickTime movies  183
video from Final Cut Pro  183
video into projects  183, 184

indexed directories  65–67
input devices  14
input signal  238
Input synchronization settings  78
Insert command  163–165
inserting noise  164
inserting silence  163–164
inserting waveforms  165
interface  23–44
Invert command  163

K
key (musical)  263, 265, 268, 276

key, project  85
keyboard shortcuts

Apple Loops Utility  275–278
listed  279–285
playback  56, 186

keyword buttons  36, 37, 64–65
keywords  36–37, 60–65
Keywords list  36, 37, 60

L
Latch mode  228
latency

described  15
eliminating  294
increased  22

layouts
choosing  48
deleting  48
described  48
keyboard shortcuts  279–280
saving  48

Level Meter  204
level meters

channel strips  133, 138
Meters tab  42
Mixer  30
Recording tab  41
Timeline  27
Waveform Editor  32

LFO (low-frequency oscillator)  201–202, 203
limiters  198
linear scale, showing frequency spectrum on  152
location buttons  139
Location display  42
logarithmic scale, showing frequency spectrum 
on  152
Logic Control protocol  19
.loop extension  81
Looping button  239
looping files  57, 114, 117, 239
looping playback  87, 98–99
looping playback mode  87
low-frequency oscillator (LFO)  201–202, 203
lowpass filters  200

M
.m2v files  183
Mackie Control protocol  19
Mac OS, version of  295
Magnify button  33
manual  10
markers

aligning audio clips to Timeline with  191
beat  120–122
deleting  122
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Final Cut Pro  191–193
information about  44
inserting  120
keyboard shortcuts  284
naming  121
scoring  190–193
time  120–122, 190, 191
types of  120
uses for  119
using in Waveform Editor  181
using with video  190–193
working with  119–122

marker titles, viewing  121
MAS plug-in  14
master envelopes  28, 219, 220–221
Master Envelopes button  28
mastering process  141
master Timeslice  230–231
master volume slider  24
Matches list  36, 37, 60, 62
Measure in pop-up menu  43, 44
measures  82, 84, 98
Media and Effects Manager  33–39

adding audio files from  88
described  23
locating files in  56–67
previewing files in  68–69
viewing audio file information in  70–71

media files
reconnecting  74
saving with projects  87, 252
storing  14
unable to find  74

Media pop-up menu  34, 35, 37, 38, 69
memory  13
meters, diagnostic  196
Meters tab  42, 138–139
microphones  15, 19
MIDI Clock signal  25, 55
MIDI input port  244
MIDI interface  21, 243
MIDI output port  244
MIDI Sync button  25, 55
MIDI Timecode (MTC) signal  25, 55
midrange frequency range  199
mini-plug connectors  18
miscellaneous effects  206–207
Mixer  123–141

adding channel strips to  126
adding realtime effects in  208
described  123
hiding  132
mixing multitrack projects in  7
overview  23, 29–31
recording audio in  240
showing  132

working in  123–141
working with channel strips  125–134
working with effects  134–136

Mixer pop-up menu  29
mixers  15, 19
mixes

exporting  248
final  141
multiple  141
temporary mono mix  140

mixing projects
described  123
exporting mixes  248
guidelines for  141
mastering process  141
procedure for  124

modulation  196
modulation effects  196, 201–202
Monitor pop-up menu  41
monitors  15, 18, 19
mono files  167, 248–249
mono mix  140
Mono Mix button  24, 140
Motion

using Soundtrack Pro with  258–259
Waveform Editor and  147

.mov extension  56, 183
movies

QuickTime  144, 183, 260
reference  147

MP3 files  56, 144
MPEG-2 files  183
MPEG-2 playback  183
MTC (MIDI Timecode) signal  25, 55
MultiMeter  204–205
multiple solo  103
multitrack projects  81–92

See also projects
adding audio files to  87–89
audio clip properties  89–90
closing  82
compressed version of  87
creating  81
creating from Final Cut Pro clips/sequences  256–
258
distributing  252
exporting. See exporting items
importing video into  183, 184
length of  86
opening  81
overlap mode  85
overview  7, 45–46
playing  50–56
properties  82–85
recently open  81
reconnecting media files  74
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recording. See recording audio
saving  86–87
saving with media files  87, 252
scrubbing  54
unable to find files  74

music, basic concepts  287–292
musical instruments  15
musical intervals  115–116
musical sounds  288
Mute button  27, 31, 69, 103
Mute Project checkbox  41
muting channel strips  130
muting tracks/busses/outputs  103

N
Name field  27, 31, 44
navigation

keyboard shortcuts  280, 282–283
playhead  280
scroll bars  94
Timeline  94–99, 282–283
Zoom control  95–96

Nearby Keys button  37
Next Selection button  31
NeXT sound files  144
noise

ambient  166–167
Denoiser effect  206
eliminating  206, 294
glass-noise effect  206
inserting in audio  164
pink  164
reducing  168–169, 206
white  164

noise gates  198
Noise Generator dialog  164
non-drop frames  190
non-looping files  57, 117, 239
non-looping playback mode  87
normalization level  162
Normalize command  162
notch frequencies  202
Nyquist theorem  291

O
offset  116–117
Offset value slider  43
onscreen help  10
optical digital connectors  18
output controls  92, 102–106
output devices  14, 187–188
Output pop-up menu  28, 30
outputs

adding  100
adjusting volume  102

changing icon for  101
channel strips  129–130
copying  101
described  93
effects  104–105
envelopes for  106
exporting  248–249
moving  101
muting  103
numbered  101
overview  91–92
removing  106
renaming  101
selecting  100
setting height of  97
soloing  103
working with  99–106

Output synchronization settings  78
Overlap mode  85, 113
overloaded signals  178
overtones  288

P
pan controls  102, 129
panning  102, 124
pan position  213
pan positions  102, 129
pan slider  28, 30, 102
Parameters list  32
parametric EQs  201
Paste Mix command  158
Paste Repeat command  158
pasting items

audio clips  108–109
audio in Waveform Editor  158
envelope points  226
Timeslices  231

Path pop-up menu  34, 35
PCI (Peripheral Connect Interface)  17
PCI interfaces  17
PCMCIA  17
peak  287
peak indicators  30, 41, 42, 139
peak information  205
peak levels  197
peak limiters  198
Peak Location display  139
peaks  149–150, 162, 178, 266, 289
Peak Value display  42, 139
performance  294
Peripheral Connect Interface. See PCI
phase  163
phase issues  178
Phaser effect  196
phase relationships  289
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phase shifters  202, 289
phone plug connectors  17
physical output channels  28, 30, 91, 92, 129, 251
pink noise  164
pitch  288
Play/Pause button  25
playback  50–56

audio files in Wave Editor  152
changing mode  117
controlling  25, 50–54, 98–99
cycling  98–99
keyboard shortcuts  56, 186, 280
looping  87, 98–99, 117
MPEG-2  183
non-looping  87, 117
starting  50
video  185–188

Playback buttons  43
playback mode  117
playback position  55, 280
playback region  98–99
Play button  50, 55, 69, 161, 237, 238
Play From Beginning button  25, 55
playhead

changing position  54
described  32
keyboard shortcuts  280
positioning with Time ruler  98
scoring marker to  192–193
setting  51–54
splitting audio clips with  113, 114

Playhead Position value slider  24, 53–54, 84
playing projects  50–56
plug-ins

Audio Units  14, 195
effects  13, 14
included with Soundtrack Pro  14
Stereo Spread  207
unsupported  14

pops  178
Position value slider  43, 44
postproduction  7, 198
power line hum  178
preferences

Apple Loops Utility  274
Recording  235
Soundtrack Pro  75–80

Preferences window  75
presets, effect  217–218
Presets drawer  162, 217, 218
preview controls  34, 35, 37, 38, 69
previewing items

audio files  68–69
in Media and Effects Manager  68–69
preview file information  70–71
video files  68, 189

Previous Selection button  31
processing effects

See also effects
advanced settings  216
applying  216
automation  216
overview  196
presets  217–218
working with  216

processor speed  13
project controls  26
project key  85
project length, setting  86
Project pop-up menu  29
Project preferences  76–77
project properties  82–85

key  85
overlap mode  85
sample rate  83
tempo  84
time format  82–83
time signature  84

projects
audio file. See audio file projects
collecting original source media in  147
controlling playback of  98–99
distributing  252
exporting mixes  248
exporting to audio files  248
importing QuickTime movies into  183
importing video into  183, 184
miniature view of  97
multitrack. See multitrack projects
overall volume of  138–139
playing  50–56
preferences  76–77
removing video clips from  193
saving as audio file projects  146–147
saving with media files  252
scrolling through  94
scrubbing  54
types of  45–46
undo/redo changes to  71

Project window  23, 24–33, 145
properties

audio clips  89–90
multitrack projects  82–85

property tags  265

Q
quarter-size frames  80, 187
QuickTime  11
QuickTime audio files  56
QuickTime movie files  144
QuickTime movies  183, 260
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QuickTime MPEG-2 Playback Component  183

R
RAM  13
RCA connectors  18
Read Before You Install document  13
Read mode  228
realtime effects  207–215

See also effects
adding  208–209
adjusting parameters  209
advanced settings  215
automation  213
bouncing  170
bypassing  211
chaining  210–211
overview  195
parameters  213
presets  217
removing  214
reordering  211
resetting to defaults  214
sends and  212–213
showing  170
working with  207–215

Record button  25, 55, 237, 238
Record Enable button  27, 31, 236, 240
recording audio  235–241

analog recording  290
digital recording  290–291
disk space and  235
eliminating latency  294
enabling channel strips for  131
enabling tracks for recording  236
keyboard shortcuts  285
in Mixer  140, 240
multiple takes  238–239
preferences  77
preparing for  235
procedure for  289–292
saving recorded clips  239
sessions location  77
single takes  237
in Timeline  236–239
in Waveform Editor  240–241

recording automation in Mixer  140
recording control surface automation  246
Recording pane  235
Recording preferences  77, 235
recording sessions, save location  77
Recording tab  41, 236, 238
Redo command  71
Reduce Noise command  168–169
reference movies  147
regeneration  202, 203

Remove Effect button  39
Render checkbox  146, 254, 255, 259, 260
render file for Final Cut Pro  254
rendering  146
Resample command  167
Reset button  42, 139, 161
Reset Effect button  39
resources  9
reverb  196
reverb effects  196, 203–204
reverberation  203
reverb time,  203
Reverse command  163
ripple cut  281
ripple delete  281
roll-off filters  200
root note  85
roundtrips  183, 254, 255, 258, 259
RTAS plug-in  14

S
Sample Edit tool  159
sample rates

audio files  83
choosing  167
described  83, 291
digital video  83
hardware  83
importing audio files  56
multiframe projects  83
Soundtrack Pro and  15
Waveform Editor  144, 167

Sample ruler  152
samples

described  290
editing  159
reversing  163

sample units  149
saving items

actions as AppleScript droplets  181
audio file projects  146–148
audio files  147–148
compressed project versions  87
multitrack projects  86–87
project and audio files together  87, 252
recorded clips  239

scale type  276
Scale Type pop-up menu  37
scoring markers  122, 190–193
scripting actions  181
scripts  181, 256
scroll bars  27, 94
scrubbing

audio files in Waveform Editor  153
described  153
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projects  54
selections  54

Search database  65–67
searches, keyword  36–37
searching. See finding items
Search Results list  37
Search tab  36–37, 60–67
search tags  266
Search Text field  37, 61
segments  113–114
Selection Length value slider  24
selections

audio files in Waveform Editor  154–156
moving between  157
next  157
previous  157

Selection tool  159
semitones  115–116
sends

adding to tracks  212
busses routed to  212
bypassing  213
channel strips  137
envelopes and  227
pan position  213
realtime effects and  212–213
reordering  137, 212
settings  137
turning on/off  137
volume level  213

Set Ambient Noise Print command  166
Set Noise Print command  168
setting up system. See system setup
Setup button  37
shelf filters  200
Show/Hide Presets button  162
Show pop-up menu  26, 39
Silence command  163
silence threshold  178
SMPTE (Society of Motion Picture and Television 
Engineers)  78
Snap button  28
Snap option  72–73
snapping

clips to adjacent clips  110
clips to markers  191
envelope points  222

Snap To Value pop-up menu  28
Snap To values  28, 72–73
Society of Motion Picture and Television Engineers 
(SMPTE)  78
Solo button  27, 31, 103
soloing channel strips  130
soloing tracks/busses/outputs  103
sound

See also audio

musical sounds  288
recording. See recording audio
volume. See volume

sound design  7, 8, 195, 196, 207
Sound Designer II files  144
Soundtrack Loop Utility. See Apple Loops Utility
Soundtrack Pro

education users and  11
features  8–9
Final Cut Pro and  8
getting started with  45–80
interface  23–44
keyboard shortcuts  279–285
learning about  9, 11
onscreen help  10
overview  7–9
preferences  75–80
resources  9
setting up. See system setup
software installation  13
specifications  11
system considerations  13–14
using with DVD Studio Pro  260
using with Final Cut Pro  253–258
using with Motion  258–259
using with other applications  260
website for  10

Soundtrack Pro scripts  181, 256
Soundtrack Pro User Manual  10
sound waves  287, 289, 290
source audio files  107, 117–119
source media  147
speakers  15, 18, 19
specifications  11
Spectrum Analyzer  205
Spectrum view  32, 151–152
Spectrum View button  32
Split menu item  113, 114
splitting audio clips  113–114
Split tool  113
.stap extension  146, 254
startup preferences  75
stereo, enhancing  207
stereo channels  138
Stereo checkbox  41
stereo delays  203
stereo files, converting to mono  167
Stereo Spread plug-in  207
.stmp extension  81, 86
stretching technique  271
Stretch tool  160
submixes  91
Swap Channels command  163
synchronization  78
Synchronization preferences  78
system requirements  13
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system setup  13–21
connecting audio equipment  15–19
control interface  21
example hardware setups  19–21
FireWire audio interface  21
overview  13
powered speakers  19
software installation  13
system considerations  13–14
USB audio interface  20
video output devices  22

T
tabs

described  24
detaching/reattaching  48
keyboard shortcuts  279–280
reordering  47

tagged audio clips  115–116
tagged audio files  60, 263–278
tags  263, 265, 266
Tags tab  264, 265–266
tail effect  86, 170, 171
takes. See recording audio
Tap tempo delays  203
tempo  84, 192–193, 263
temporary mono mix  140
text, showing in Toolbar  50
threshold  197
timbre  288
time-based effects  202–204
Time-based format  52–53, 82, 83, 98, 104, 233
timecode

aligning audio clips to  98, 191
MIDI Timecode  25
Time-based format  53
time markers and  190
Time ruler units and  183, 190

timecode format  190
Time Code Offset synchronization settings  78
Time display  26, 32, 52–53, 190
time format

described  190
projects  98
setting  82–83
tracks  104

Timeline
adding audio files to  87–89
controls  28
editing audio clips in  107–119
Global view  97
headers  27–28
keyboard shortcuts  282–283
moving audio clips in  109–110
navigating in  94–99

overview  26–27
preferences  75–76
recording audio in  236–239
scrubbing projects in  54
setting track height in  97
track controls  27–28
working in  93–122
zooming in/out  95–96

Timeline controls  27, 28, 153
Timeline editing tools  26
time markers  120–122, 190, 191
Time ruler  27, 98, 190
Time Ruler units  148
time signature  37, 84
Time Signature pop-up menu  37
Timeslices  229–233
Timeslice selection area, changing  232–233
Time Stretch command  166
time stretching audio files  160, 166
tip-ring (TR) connectors  17
tip-ring-sleeve (TRS) connectors  17
tone  198
tone color  288
tonic  85
Toolbar  24, 25, 49
Touch mode  228
TR (tip-ring) connectors  17
Track area  27
track controls  27–28, 90, 102–106
track envelopes  220
Track Height control  28, 97
track pan envelopes  220
tracks

adding  99
adding sends to  212
adjusting pan position  102
adjusting volume  102
changing icon for  101
copying  101
described  93
effects  104–105
enabling for recording  236
envelopes for  106
exporting  248–249
keyboard shortcuts  284
Motion  258–259
moving  101
moving audio clips between  110
muting  103
numbered  101
overview  90
pan positions  129
removing  106
renaming  101
routing to busses  91
selecting  100
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selecting audio clips in  107
setting height of  97
showing  220
soloing  103
time format  104
working with  99–106

transducers  289
transients  263, 266, 271–272, 278
Transients tab  264, 266–267, 271
transport controls  24, 25, 32, 55–56, 185–186
Transpose pop-up menu  43
treble  169, 199, 288
troubleshooting  180, 293–295
TRS (tip-ring-sleeve) connectors  17
truncate mode  85
Type buttons  44

U
Undo command  71
Universal Serial Bus. See USB
upsampling  83
USB (Universal Serial Bus)  15, 16
USB audio interface  20, 294
USB cables  16
USB connectors  16
USB devices  16, 294
USB hubs  16, 294
User Manual  10
Utility window  23, 40–44

V
Value display  139
value slider  30
Value value slider  44
video  183–193

for DVDs  83
encoding  250
frame rates  190
importing into projects  183, 184
playback of  185–188
preserving  250
removing from projects  193
supported formats  183
time format  190
transport controls  185–186
using markers with  190–193
using Time display with  190
using Time ruler with  190
working with  183–193
working with audio in  189

videocassette decks  15
video clips

importing into projects  184
reconnecting  74
removing from projects  193

timecode position  190, 191
viewing details of  188–189

video files
previewing  68, 189
reconnecting  74
saving with projects  87
size of  252
viewing details about  43, 188–189

video frame rate, choosing  76, 190
video out device  187
Video Out preferences  80
video output  80
video output devices  22, 187–188, 284
Video Playback value slider  40
Video Scale pop-up menu  40
Video tab  40, 184, 186
video timecode format  190
video transport controls  40
video viewing area  40
viewing area  40
volume

adjusting for busses  102
adjusting for outputs  102
adjusting for tracks  102
channel strips  127–128
described  288
overall  138–139
sends  213

volume envelopes  220
volume fader  30
volume slider  28, 69, 102, 161
VST plug-in  14

W
waveform display

described  32
sample units  149
Time Ruler units  148
zooming in/out  149, 160

waveform editing tools  31
Waveform Editor  143–182

adding realtime effects in  209
analyzing audio files in  177–180
closing projects  145
copying audio in  157
creating projects  145
cutting/pasting in  157–158
editing audio files in  8, 154–160
editing DVD Studio Pro clips in  260
editing Final Cut Pro clips in  253–255
editing Motion audio tracks in  258–259
moving between selections  157
opening projects  144–145
overview  31–33
playing audio file projects in  152
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processing audio files in  161–170
recording audio in  240–241
Sample units  149
saving projects  146–148
scripting actions in  181
scrubbing audio files in  153
scrubbing projects/selections in  54
selecting channels in  155–156
selecting parts of audio files  154–156, 159
selection details  44
supported audio formats  144
Time Ruler units  148
using markers in  181
using Timeline controls in  153
views  150–152
working with actions  170–176
zooming in/out  149–150

waveforms
clip offset and  117
frequency of  165
inserting in audio  165
length of  165

Waveform view button  32
WAV files  56, 144, 263–278
websites

AppleCare Support  295
Apple homepage  11
Apple Service and Support  10
Apple Store  11

Apple websites  11
FireWire  11
QuickTime  11
Soundtrack Pro  10

wet signal  203
white noise  164
windows  23–44

closing  47
keyboard shortcuts  279–280
minimizing to Dock  47
moving  47
resizing  47

workspace, setting up  47–50

X
XLR cables  17
XLR connectors  17

Z
Zoom control  28, 95–96, 149
zooming in/out

on analyzed problems  180
with scroll wheel  96, 149
waveform display  160
Waveform Editor  149–150
with Zoom control  95–96

Zoom tool  160
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