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Resources

Logic Pro 8 offers an extensive documentation collection that 
will help you to learn and make full use of all application 
features. 

Further information about Logic Pro, including data on updated versions and support 
texts, can be found on the Apple web site.

Logic Pro 8 ships with the following documentation:
Â Logic Pro 8 User Manual:  This book is the final arbiter on all things in Logic Pro, and 

covers all areas of the program in detail, with the exception of plug-ins. Print and in 
Help menu.

Â Logic Pro 8 Getting Started:  This book is designed to quickly get you up and running 
with Logic Pro. Print and in Help menu.

Â New Features in Logic Pro 8:  This document provides a high-level overview of the 
improvements and changes found in Logic Pro 8. You can find it in the Help menu 
and in the Documentation folder of the Logic Pro 8 Install DVD.

Â Logic Pro 8 Control Surfaces Support:  This document covers the use of control surfaces 
with Logic Pro 8. In Help menu and Documentation folder of the Logic Pro 8 Install 
DVD.

Â Logic Pro 8 TDM Guide and Logic Pro 8 Working With Apogee Hardware:  These 
documents cover the essential aspects of using TDM or Apogee hardware in 
Logic Pro 8. In Help menu and Documentation folder of the Logic Pro 8 Install DVD.

Â Logic Studio Instruments and Effects:  This book covers the use of all Logic Studio 
effect and instrument plug-ins. It is a universal guide for all Logic Studio applications 
that include instruments or effects, and does not cover the application-specific use of 
plug-ins—only the plug-in functions, parameters, and usage are discussed. Print and 
in Help menu.

Â Late-Breaking News:  This document is published online and may be updated as new 
versions of Logic Pro 8 are released, or new information becomes available
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Important:  All topics described in this manual were accurate at the date of printing. For 
up to date information on changes or additions made after printing, please refer to the 
Late-Breaking News document in the Logic Pro Help menu, and to the Update Info, 
included with each Logic Pro update.

Logic Pro 8 Documentation Conventions
The following section introduces you to conventions used throughout the Logic Pro 8 
documentation.

Menu Functions
For functions that can be reached via hierarchical menus, the different menu levels are 
illustrated as follows:  Menu > Menu entry > Function.

Important Entries
Some text will be shown as follows:

Important:  Information on function or parameter. 

These entries discuss a key concept or technical information that should, or must, be 
followed or taken into account. Please pay special attention to these entries.

Notes
Some sections provide additional information or tips that will assist your use of 
Logic Pro. These are displayed as shown below:

Note:  Information on function or parameter.

Key Commands
Many Logic Pro functions can be activated or accessed with key commands—
computer keyboard shortcuts. The key commands mentioned in this guide are based 
on the standard key command set.

Tips
A number of shortcuts, alternative methods, or general working tips are included 
throughout the documentation. These may help your workflow, or provide additional 
information on other uses for functions. Tips are shown as below:

∏ Tip:  Information on function or parameter.
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Warnings
A few warning messages are included for functions that are destructive, and could 
result in irretrievable data loss, or could cause damage to your equipment. Warnings 
are displayed as follows:

Please pay special attention to these entries, as they can save you from making costly 
mistakes.

Logic Pro Onscreen Help
The Logic Pro Help incorporates the Logic Pro 8 user documentation in electronic form. 
These documents have the advantage of being at your fingertips whenever you need 
them, and are searchable, making it quick to find the information you need.
Â The Logic Pro Help menu also provides additional features, including direct access to 

the Logic Pro pages on the Apple website.
Â A comprehensive bookmark list allows you to quickly choose (and tag) what you 

want to see, and navigates to the resource when the link is clicked.

Late-Breaking News
This document is published online and may be updated as new versions of Logic Pro 8 
are released, or new information becomes available.

To check for recent updates, choose Late-Breaking News from the Help menu. The Late-
Breaking News PDF file is downloaded. If Safari is the default web browser for your 
system, the Late-Breaking News PDF file is displayed directly in Safari. Other web 
browsers may not have the ability to display PDF files directly, in which case the PDF 
file is downloaded to the default download location.

Apple Websites
There are a variety of discussion boards, forums, and educational resources related to 
Logic Pro on the web. 

Logic Pro Websites
The following websites provide general information, updates, and support information 
for Logic Pro, as well as the latest news, resources, and training materials. 

For information about Logic Pro go to http://www.apple.com/support/logic.

For information on Apple Training Programs go to http://www.apple.com/training.

To provide comments and feedback to Apple about Logic Pro, go to the Apple 
discussion forums  http://discussions.apple.com/category.jspa?categoryID=156.

Warning:  Information on function or parameter.

http://www.apple.com/support/logic
http://www.apple.com/training
http://discussions.apple.com/category.jspa?categoryID=156
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Apple Service and Support Website
This is the place to go for software updates and answers to the most frequently asked 
questions for all Apple products, including Logic Pro. You’ll also have access to product 
specifications, reference documentation, plus Apple and third-party product technical 
articles.

To access Apple’s Service and Support web page:
m Open your Internet browser, and type in http://www.apple.com/support.

Other Websites
Â http://www.apple.com:  Start at the Apple home page to find the latest information 

on Apple products.
Â http://www.apple.com/quicktime:  QuickTime is Apple’s industry-standard technology 

for handling video, sound, animation, graphics, text, music, and 360-degree virtual 
reality (VR) scenes. QuickTime provides a high level of performance, compatibility, 
and quality for digital video delivery. Go to the QuickTime website for information on 
the types of media supported, a tour of the QuickTime interface, specifications, and 
more.

Â http://www.apple.com/firewire:  FireWire is one of the fastest peripheral standards 
ever developed, which makes it great for use with multimedia peripherals, such as 
audio interfaces, video camcorders, and the latest high-speed hard disk drives. Visit 
this website for information on the benefits of FireWire technology, FireWire software 
information, and details on third-party FireWire products.

Â http://www.apple.com/pro:  This website provides news, information, and other 
resources on seminars, events, and third-party tools used in web publishing, 
document design and printing, CAD, music and audio, desktop movies, digital 
imaging, modelling and animation, and the media arts.

Â http://store.apple.com:  Go here to buy software, hardware, and accessories direct 
from Apple. You can also find special promotions and deals that include third-party 
hardware and software products.

http://www.apple.com/support
http://www.apple.com:
http://www.apple.com/quicktime:
http://www.apple.com/firewire:
http://www.apple.com/pro:
http://store.apple.com:
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1 An Introduction to Logic Pro

Logic Pro is a sophisticated, fully-featured audio and MIDI 
application that provides all the tools you need to create 
professional-quality music productions. 

Logic Pro allows you to record audio and MIDI, edit audio loops plus MIDI and software 
instrument parts, add high-quality effects, and mix your music in stereo or Surround. 
The final mix can be exported to one or more standard audio files, or burned to an 
audio CD, or DVD that can be played on any computer, home stereo, or imported into 
other applications and devices.

Some of the things you can do with Logic Pro include:
Â Record MIDI information via connected MIDI input devices, such as keyboards, and 

play back this information via any connected MIDI device (such as a synthesizer 
keyboard or module) or the integrated Logic Pro software instruments.

Â Create, arrange, and edit MIDI projects, and print out musical notation via a printer 
connected to your computer.

Â Digitally record acoustic and electric instruments, or vocal performances, into your 
projects, and process these audio recordings with a huge array of built-in real time 
effects.

Â Make use of the integrated software instruments, including:  Sculpture, Ultrabeat, 
ES1, ES2, EVP88, EVB3, EVD6, EXS24 mkII, over a dozen high-quality GarageBand 
instruments, or third-party Audio Unit instruments.

Â Load projects or channel strips from GarageBand, and enhancing them with the 
additional processing and editing possibilities afforded by Logic Pro.

Â Mix your MIDI and audio tracks, including effects and software instrument settings, 
via a sophisticated total recall mix automation system. Logic Pro includes high-
quality effects that you can use in your projects. You can also install and use third-
party Audio Units effects and instruments.

Â Bounce (mix down) all audio data, including instruments, effects and mix automation 
settings, to stereo or multiple Surround format files for mastering or further 
processing,.
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Â Work in real time:  You can work on Logic Pro projects in real time; adding to, and 
editing audio and MIDI parts while the project is playing, and hearing the results of 
your changes immediately.

Â Use existing loop libraries:  Logic Pro directly supports Apple Loops files, and is 
compatible with a wide variety of existing audio file types, including those created in 
ReCycle.

Â Locate and preview files easily:  The Media area, part of the Logic Pro interface, 
provides powerful file browsing and search features, making it easy to locate audio 
files and other supported file types.

Creating Music in Logic Pro
Logic Pro can be used in a variety of ways, ranging from the simple to the incredibly 
sophisticated. The following section outlines a common workflow example that many 
projects adhere to. The structure of this manual will follow this basic workflow, where 
applicable.

Step 1:  Creating a project
You begin working in Logic Pro by creating a new project, or opening an existing one.

A project file contains MIDI data recordings plus information about the audio and other 
files used, including pointers to these files. 

All files (audio, video, samples, and so on) can be saved in a project folder. All project 
files are automatically placed into appropriate sub-folders within the project folder. 

More detail can be found in “The Basics:  Projects and Regions” on page 23.

Step 2:  Creating and importing your musical material
Getting musical material into Logic Pro can basically be broken down into two 
methods:
Â Making new audio or MIDI data recordings (the latter can be played back through 

either external MIDI synthesizers or software instruments).
Â Importing existing audio recordings (audio files, samples, loops) or MIDI (and other 

file data) into your projects. You can import existing audio recordings by simply 
dragging them from the Media area, shown at the right of the Arrange window.

Recordings are made through suitable MIDI or audio hardware that is connected to, or 
installed in, your Macintosh. 
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MIDI recordings are used to trigger (play back through) either external MIDI devices, 
such as synthesizers, or internal software instruments. Software instruments are 
calculated on the Macintosh CPU, and played back through your audio interface or the 
Macintosh audio outputs. Not only can you record the notes of your performance, but 
you can also record and play back information such as synthesizer parameter 
changes—all in real time.

Audio recordings can be made by playing an instrument (such as a guitar) or singing 
into a microphone, as examples. 

Step 3:  Arranging and editing
Once your musical material has been imported or recorded into Logic Pro, you will 
generally organize it into a “song structure.” This is done in the main Logic Pro window, 
called the Arrange window. 

Musical material appears as rectangular blocks, known as regions. These regions run 
from left to right across the Arrange area, and are positioned on vertically stacked 
lanes, known as tracks. You may freely copy, repeat, loop, move, shorten, lengthen, or 
delete regions—either on a track or across tracks. This grid-like layout and the use of 
building blocks (regions) makes it easy to see, and create, the overall song structure.

There will be many occasions where you’ll need to perform more detailed edits to your 
MIDI or audio data recordings than is possible at the region level. Logic Pro offers a 
number of editing windows that allow you to modify your musical material at a variety 
of levels. As examples of where this might be useful:
Â You have made a recording of a great main vocal performance, but can hear a thud 

in the silent passages between two phrases, where the vocalist kicked the 
microphone stand. It probably goes without saying that this isn’t a sound you’d like 
to have on the finalized CD. No problem. Simply edit the recording by inserting 
silence during the thud, or perhaps cut that portion out of the recording entirely.

Â You have made a MIDI keyboard recording that is perfect but for one note that 
should have been a C, but is a B. No problem. You can simply drag the MIDI note 
event from B to C.

More detail can be found in “The Basics:  Projects and Regions” on page 23.

Step 4:  Mixing, automating, using plug-ins
Following the creation of your arrangement and any edits that may have been 
required, you would commonly move on to the mixing phase of your project. Mixing, 
as a term, generally refers to balancing the relative levels of each song component. Put 
another way, the main vocal needs to be louder than the bass, guitars, drums, and 
keyboards, thus allowing the lyrics to be heard. 
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Mixing also entails the use of audio effects, which change, enhance, or suppress 
particular song components, adding up to a unified and polished final product. 
Logic Pro features numerous effects that can be used to turn your basic song into a 
professionally finished project.

Logic Pro enables you to record, or automate, changes you make to track, instrument, 
and effect parameters, such as volume, pan, filters, and other controls. This can be done 
in real time or offline with the mouse or an external MIDI device. These changes play 
back when you play the project, and can be edited independently of the musical 
material. This is very useful for a number of reasons:
Â You can only adjust one level or setting of a playback track, if using the computer 

mouse. The ability to record and play back multiple adjustments of all track elements 
allows for a sophisticated mix.

Â Performances are rarely consistent. To clarify, a vocalist will often sing louder or softer 
during different sections of their performance, so you may need to even out these 
level changes over the course of the song, or to balance the soft and loud vocal 
sections against the musical backing.

Â Song dynamics (the loud and soft sections of a song) benefit from animation. In 
other words, building the intensity of a song section can often be achieved by 
gradual or immediate level changes. Songs that are of a consistent level throughout 
tend to sound flat and lifeless.

Step 5:  Exporting and bouncing
The final step of the Logic Pro music creation process is exporting your final product. 
Logic Pro allows you to produce a stereo file of your completed mix in a variety of 
audio file formats. You can also produce several stem files, formatted for most common 
Surround encoding schemes. This is achieved in the Bounce window; simply choose 
the desired outcome(s) in the available menus and press the onscreen Bounce button. 
You can even burn a stereo mix directly to CD or DVD with one simple step.
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The Basics:  Projects and Regions
This section will provide you with an introduction to the basic elements and 
terminology of a Logic Pro project. Detailed, step-by-step instructions on working with 
projects, regions, and events are provided in later chapters. If you are an experienced 
user, you may wish to skip ahead to “A Tour of the Logic Pro Interface” on page 28.

Projects
You start working in Logic Pro by creating a project, or opening an existing one. This is 
similar to using a word processing application, that requires a document to be opened 
before you can begin typing. Logic Pro, like word processors, also allows you to have 
multiple documents (projects) open at the same time, and transfer media and other 
data between them.

A Logic Pro project file contains all MIDI events and parameter settings, information 
about the audio and video files to be played and all edits to MIDI and audio data. 

It is important to note that the project file points to your audio and video files, which 
are stored as separate entities on disk. You have the choice of including these, and 
other file types, in the project folder. 

This approach has two main benefits:
Â Saving a project without its assets (audio, video, sample files, and so on) minimizes 

the memory requirements for project (and project backup) file storage.
Â Saving a project with assets simplifies tasks such as archiving and transport to other 

Logic Pro-based studios—either physically or as email attachments. 

The Project Folder
A project can consist of the complete collection of files used, including the “song” (the 
project document) itself, “song” backups, all audio, sampler instruments, and samples 
for the EXS24 or Ultrabeat, Space Designer reverb impulse response files and video.

These are collectively known as the project assets.

When you create a new project, a project folder is created, named, and a hard disk 
location is specified. New recordings are automatically placed into an Audio Files sub-
folder within the project folder. 

If you choose to include the project assets, further sub-folders will be created 
automatically. These can include Audio Files, Project Backups, Samples, Video, ReCycle, 
and Sampler Instruments folders.



24 Chapter 1    An Introduction to Logic Pro

The sub-folder structure of all projects is identical, making it easy and consistent to 
navigate both your projects and those of other Logic Pro users. 

Regions
The main window of Logic Pro is known as the Arrange window. This is the window 
that you first see when you open the application, and a project is loaded. This is also 
the window that is used for recording, editing, and arranging your projects. Your audio 
and MIDI files appear in the Arrange window as rectangular areas called regions. Audio 
files are represented by audio regions, MIDI files by MIDI regions. 

Audio Regions and Audio Files
Audio regions simply refer to (point to) an underlying audio file. Audio regions are used 
as playback markers (start and end points) that can be as long as the entire audio file, 
or may only be a few seconds long, playing a small portion of the audio file that they 
point to.

Project Folder

Audio Files folder

Movie Files folder

Sampler Instruments folder

Impulse Responses folder 

Project assets

Project file (“song”)

Audio region 1

Audio file

Audio region 2

Audio
region 3
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Any audio file used in Logic Pro is automatically linked to at least one audio region that 
is, by default, the length of the entire audio file.

You can freely create as many audio regions as you require. To give you an example of 
where this may be useful, imagine a live stereo drum track that runs for the duration of 
your project. During the second chorus, the drummer played perfectly, but was a little 
sloppy during all other chorus sections. 

Logic Pro allows you to create an audio region that points to the second chorus section 
of the overall (drum track) audio file, and use this perfect take in multiple places in the 
project. 

This is achieved by creating one audio region (that points to chorus 2 in the drum track 
audio file), and copying it to each position that the chorus occurs in the Arrange area.

A great benefit of working with audio regions, rather than audio files is that they use 
very little memory, whereas multiple copies of the same section of the audio file would 
require a lot of hard disk storage space.

It is, of course, possible to directly edit, copy, and move audio files. This is achieved in 
the Sample Editor and Media area.

MIDI Regions and Events
MIDI regions, by comparison, actually contain MIDI data events. They are not related to 
information stored in external files. MIDI regions can be saved as individual files, but 
they can also be, and generally are, stored as part of the project. 

The MIDI data events stored within MIDI regions include; note, controller, program 
change, and other information. These data events represent MIDI performances that 
you have recorded into Logic Pro. MIDI performances are generally created with a MIDI 
keyboard, but can certainly be generated with MIDI controllers, MIDI guitars, your 
computer keyboard or the mouse.

MIDI data events can be affected as a group by processing the MIDI region that 
contains them. Such processing includes; transposition, quantization (timing correction, 
which is similar to the spell checker of a word processor, when dealing with the 
language of music), timing delays, and more.

MIDI region 

MIDI note events MIDI controller events 
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You can also edit individual events within a MIDI region. This is achieved by opening 
the region in one of the MIDI editors. These windows allow you to precisely alter the 
position, length, and pitch of MIDI note events. Other MIDI event types can also be 
altered in various ways. You may freely enter MIDI data with your MIDI keyboard, the 
mouse, and/or computer keyboard in these editors.

More information on MIDI and MIDI event types can be found in Chapter 15, 
“Introduction to MIDI Editing,” on page 391.
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2 Overview of the 
Logic Pro Interface

The Logic Pro interface features several areas, each 
specialized for particular tasks. The main workspace is the 
Arrange window, which can incorporate all areas and editors.

This chapter introduces you to the Arrange window. You’ll learn how it interacts with 
other Logic Pro windows and editors. Detailed information about these editors and 
their functions can be found in cross referenced chapters. 

You are encouraged to open Logic Pro to view these windows and familiarize yourself 
with them. Click and explore the various parts of the Logic Pro interface as they are 
discussed. This will give you a feel for where things are, a brief overview of what they 
do, and how they work with each other.

To open Logic Pro:
m In the Finder or Dock, double-click the Logic Pro icon in the Applications folder.

When you open Logic Pro for the first time, the Templates dialog is displayed, allowing 
you to select a template for the project type you want to create (for more information 
on the New dialog, see “Creating Projects” on page 136). The setup of the Logic Pro 
interface depends on the chosen template. 
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A Tour of the Logic Pro Interface
The following section will introduce you the various elements of the Logic Pro 
interface. This is principally a “getting to know you” exercise, where the fundamentals of 
each area are covered. Full details on all options, functions, and uses are covered in 
dedicated chapters that appear later in the user manual.

The Arrange Window
The Arrange window can incorporate all working areas and editors. It features a Toolbar 
at the top and a Transport bar at the bottom. 

You have the choice of displaying additional areas, as follows:
Â Editing area, horizontally tiled, below the Arrange area.
Â Media or Lists area, vertically tiled, right of the Arrange (and editing) area.
Â Inspector, vertically tiled, left of the Arrange (and editing) area.

If an area is not visible, clicking on the appropriate Toolbar or Arrrange area button will 
open it, and resize any existing areas to accommodate the new area. 

∏ Tip:  Many of the editor and other areas can also be opened as separate windows, 
independent of the Arrange window. This is done in the Window menu (or with the 
corresponding key commands).

Â Arrange area:  This is where you record audio and instrument parts as regions, and 
arrange these audio and MIDI regions into a song structure.

Click this button to
display the Inspector

Arrange window

Transport bar

Arrange area

Click this button to 
display the Lists area

Click this button to 
display the Toolbar

Media area
 Inspector

Toolbar

Click these buttons to 
display one of the editors
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Â Media or Lists area:  Use the various tabs to locate and preview audio files (Browser 
tab), select effects, instruments, and their settings (Library tab), and more, when the 
Media button in the Arrange Toolbar is clicked. When the Lists button is clicked, you 
have the choice of viewing MIDI events (Event List), tempo events (Tempo List), and 
more. You can also enable the Media or Lists area via the Arrange window View 
menu (or use the corresponding key commands).

Â Editing area:  You can open or close the Mixer, Piano Roll Editor, Hyper Editor, Score 
Editor, or Sample Editor directly in the Arrange window by clicking any of the 
buttons along the lower edge of the Arrange area. These windows allow you to 
precisely modify, delete, or add different types of data. 

Â Transport bar:  Used to navigate through your project. The current playback, 
recording, or editing position is indicated by the playhead—the thin, vertical line 
that appears in all Logic Pro windows that offer real time display of playback—
namely the Arrange and editor windows.

Â Inspector:  Used to set track and region parameters when working in the Arrange 
area, or the parameters of the editing window with key focus. As examples:
Â Clicking the Score Editor area at the bottom of the editor area shows all scoring 

symbols in the Inspector. 
Â Clicking the Hyper Editor area displays the parameters of the currently selected 

hyper definition (selected row in the Hyper Editor window). 

The Arrange Toolbar
The Toolbar appears at the top of the Arrange window. It contains buttons for 
frequently used commands. 

The Toolbar can be customized to include buttons that show the Inspector, Media, and 
Lists areas, create new tracks, add audio files, and other common functions. For more 
information, see “Customizing the Arrange Window Toolbar” on page 73.

The Transport Bar
The Transport bar spans the entire lower edge of the Arrange window. You can use it to 
move through your project and start recording. It contains buttons that will be 
immediately familiar if you’ve used a tape recorder or CD/DVD player, such as Play, 
Rewind, Pause, and so on. The Transport bar also incorporates a number of features that 
simplify tasks you will perform in Logic Pro, such as recording over a repeatedly cycled 
section, or listening to a part in isolation.
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The Transport bar consists of three parts:

Â Transport buttons:  Used to navigate your project.
Â Display area:  Provides information that helps with project navigation.
Â Mode buttons:  Enable advanced recording and playback functions.
You can alter the Transport bar by adding or removing buttons and displays, providing 
faster access to the functions you need most often. You can also open an independent 
SMPTE or Bar display window. For more information, see “Customizing the Transport 
Bar” on page 73.

Arrange Area
The Arrange area is shown directly below the Toolbar. It is used to record, import, 
collate, and organize MIDI and audio data containers, known as regions, in a project.

Â Bar ruler:  A linear bar divided into bar and beat segments. The Bar ruler can also 
display time in hours, minutes, seconds, and finer divisions. It offers a number of 
facilities that can be used to mark project sections for different playback and 
recording tasks. More detail in Chapter 5, “Navigating Your Project,” on page 105.

Â Arrange grid: This where all MIDI and audio regions are displayed on horizontal lanes, 
called tracks, aligned to time positions in a grid-like layout.

Â Track list: This is where you set the destination channel strip for playback of the MIDI 
or audio regions on each horizontal track lane. The headers of each track list lane can 
display the track name, icons, and several track buttons.

Transport buttons Display area Mode buttons

Bar ruler

Arrange grid

 Track list
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Media Area
The Media area can be opened or closed by clicking on the Media button in the 
Toolbar. The Media area is where you manage all files associated with your project, 
including audio, video, and plug-in settings. It has four tabs:
Â Audio Bin:  Helps you to manage all audio files used in the project.
Â Loop Browser:  Used to search for loop files (Apple Loops, for example).
Â Library  This is where you search for (and can directly assign) plug-in, channel strip, 

and MIDI instrument settings. 
Â Browser:  Used to search for all Logic Pro related files.

Getting to Know the Audio Bin
The Audio Bin shows all audio files used in the project. You can picture the Audio Bin as 
an audio file catalog for the project. It also provides an overview of regions that are 
derived from each audio file. 

You can define new, edit, delete, or rename existing audio files and regions in the 
Audio Bin. All audio files and regions can be dragged directly from the Audio Bin into 
the Arrange area, where you can edit, move, and copy them. You can also add files that 
aren’t yet used in the arrangement to the Audio Bin, allowing easy access during song 
construction. 
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Â Name column:  Displays all audio files in the current project by name. The disclosure 
triangle to the left of the file name reveals all regions associated with the selected 
audio file. 

Â Info column:  Displays audio file and region information. Horizontal bars indicate the 
overall audio file length. Colored sections of these bars indicate the location and size 
of regions within the audio file. Additional data, including the sample rate, bit depth, 
mono, stereo, or surround status, and file size are also shown in the Info column. 
Mono files are identified by a single circle symbol, stereo files by a double, 
interlocked circle symbol, and surround files by five circle symbols. 

Â Play button:  Click to hear the selected audio file or region. Click a second time to 
stop playback.

Â Loop button:  Click to hear the selected audio file or region repeatedly. Click a second 
time to stop playback.

When you open the Audio Bin as an independent window, and resize it, the Audio Bin’s 
Info column can display waveform overviews of audio files and regions.
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Getting to Know the Loop Browser
The Loop Browser is designed to make finding Apple Loops intuitive and fast.

You can search for loops by using keywords, perform text searches, preview loops, view 
information about loops, and limit the display to loops from a specific Jam Pack or loop 
library. Matching files are displayed in the Search Results list. When you find files you 
want to use, you can add them to your project by dragging them into the Arrange area. 

The Loop tab has three views:  Column view, Music view, and Sound Effects view. The 
default Music view displays 54 buttons, each featuring a musically-related category. 
Simply click on the desired buttons in the matrix to narrow your search for appropriate 
Apple Loops. Activated buttons are highlighted.

Category buttons

Click to narrow the 
search for appropriate 
loops

Search Results list

Displays all loops that 
match the set search 
criteria

Volume slider

View menu View buttons

Search field
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The Sound Effects view offers effect-related category buttons such as Explosions, Foley, 
or People.

Column view offers a standard Mac OS X column file menu that is hierarchically 
separated into All, By Genres, By Instruments, By Moods, and Favorites search criteria. 

Â View buttons:  Click to switch between the three views. The left button switches to 
Column view, the second button (featuring the note icon) switches to Music view, 
and the third button (featuring the FX icon) switches to Sound Effects view. 

Â View pop-up menu:  Restricts displayed loops to a specific loop library.
Â Search field:  Type text in the field to display files with names that contain the search 

text string.
Â Category buttons (Music and Sound Effects view only):  Click to display files matching 

the category in the Search Results list. 
Â Category columns (Column view only):  Choose a category column to display its 

subcategories. 
Â Search Results list:  Displays all loops that match the set search criteria.
Â Volume slider:  Adjusts the playback level of the selected file. 

Category columns
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Getting to Know the Library
The Library is a powerful tool that you can use to access the following file types. 
Â Channel strip settings (.cst)
Â Plug-in settings (.pst)
Â EXS instruments (.exs)
Â Environment instruments, and programs or banks of MIDI instruments created in the 

Audio MIDI Setup utility
Â ReWire MIDI instruments, and active ReWire hosts 

The Library automatically displays setting files that match the selected channel strip 
type and section (Channel Strip Settings menu, Insert slot, Instrument slot). A white 
frame indicates the selected section of the Arrange channel strips. 

You can browse for files by opening folders, or search by performing text searches. 
Matching files are displayed in the Search Results list. When you find a file you want to 
use, you can simply load it by selecting it. 
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Getting to Know the Browser
The Browser allows you to navigate to, or search for all file types that can be used in 
Logic Pro, enabling easy access to (and use) of this data during production. It displays 
the following file types on any connected media volume:
Â Logic project files
Â Song files of older Logic versions
Â GarageBand projects
Â All project interchange file formats Logic Pro is compatible with (OMF, AAF, OpenTL, 

XML, MIDI files)
Â Audio files
Â QuickTime movies

Â Back and Forward buttons:  Move through previously viewed levels of the folder 
hierarchy.

Â Path pop-up menu:  Displays the levels of the file path to the current location, 
allowing you to move back to a previous level. 

Back and Forward
buttons

Play button

Action pop-up menuVolume slider

Search field

Search filters

File list

Path menu
Computer, Home,

and Project buttons View buttons
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Â Computer button:  Displays the contents of the local hard disk, optical drive, and other 
storage media connected to your computer, if applicable.

Â Home button:  Displays the contents of your home directory.
Â Project Folder button:  Displays the contents of the current project folder.
Â View buttons:  Switches the file list between column and list view modes. 
Â Search field:  Type text in the field to display files with a name that contains the 

search text. In addition to searching for files by name, you can search by other 
criteria (further information stored with your files). Click the plus button to display 
additional search filters. Logic Pro always searches at the displayed location.

Â Search filters:  Use the menus to narrow down your search to specific file types, file 
formats, date, size, and other criteria.

Â File list:  Displays Logic-related files and folders at the current location. In column 
view, you can browse folder contents by clicking the desired folders.

Â Action pop-up menu:  Choose menu items to add a selected audio file to the Audio 
Bin, or show the file location in the Finder. 

Â Volume slider:  Adjust the playback volume. 
Â Play button:  Click to play the selected audio file. 

Lists Area
The Lists area can be opened or closed by clicking the Lists button in the Toolbar. It 
provides four independent tabs that show a listing of the following types of data:
Â Event List:  Displays regions or MIDI events. 
Â Marker List:  Lists all markers in your project. 
Â Tempo List:  Displays all tempo changes. 
Â Signature List:  Shows all time signature and key change events in the project. 

The list tabs are well suited for a number of precise editing tasks, and when a complete 
view of all data is required. 
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Getting to Know the Event List
The Event List presents a list of all events in your project, such as MIDI note events or 
region start events. Use it whenever you need to make precise alterations to recorded 
data, and where the graphic display of the other editors is not as well-suited to the 
task. You can restrict the types of events that are shown, making it easier to find 
specific event types.

The Event List can display two types of data:  Region related or event related. The 
information that is displayed depends on the current hierarchy level—in other words, 
whether you are viewing information at the Arrange level, or looking inside one or 
more MIDI regions in the Arrange area. Further information about the display hierarchy 
can be found in “Working at Different Hierarchy Levels” on page 65.

Â Hierarchy button:  Click to move up one level in the Event List hierarchy. This allows 
you to see all regions in the current project. 

Â Create and Filter buttons:  Determine the function of the event type buttons. When 
you enable the Create button, clicking the event type button adds the selected event 
type. When you activate the Filter button, you can use the event type buttons to 
filter specific event types from the display. This merely hides the events from the 
display, it does not affect playback.

Hierarchy button
Create and Filter buttons

Event type buttons

List area

Region display Event display
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Â Event type buttons:  Click to filter specific event types from the display, or add them 
(depending on the status of the Create and Filter buttons).

Â List area:  Shows the actual list of events or regions, separated into columns. Details 
in Chapter 18, “Editing MIDI Events in the Event List.”

Getting to Know the Marker List
The Marker List displays all markers in the project. You can use it to create new markers, 
edit existing ones, and to select markers for text editing. It also serves as a navigation 
aid—you can click on a marker name to jump to (move the playhead to) a marker 
position.

Â Create button:  Creates a new marker. 
Â Marker list area:  Displays all markers in your project. 
Â Marker Text Area button:  Click to display the optional Marker Text area, allowing you 

to enter or edit marker text. 
Â Marker Text area:  Enter text for the selected marker here.

Create button

Marker list area

Marker Text area

Marker Text Area button
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Getting to Know the Tempo List
The Tempo List displays all tempo changes in the project. You can also use it to create 
new tempo events, or to edit existing ones.

Â Create button:  Click to create a new tempo event.
Â Tempo list:  Displays all tempo changes, and their position in a project.

Create button

Tempo list
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Getting to Know the Signature List
The Signature List shows all time and key signature events in the project. Score 
symbols, if present in the score of the project, are also shown. These include:  Repeat 
signs and double bar lines (including end of score events), half/short bar lines, hidden 
bar lines and manually inserted bar lines.

You can use the Signature List to create, copy, move, and delete time and key signature 
events.

The initial time and key
signature of the project is

always displayed at the
top of the list, without
bar position indicators.
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The Inspector
The Inspector can be displayed or hidden by clicking on the Inspector button in the 
Toolbar. The Inspector content depends on the area in key focus:  Either the Arrange or 
one of the editing areas below it. The following screenshot shows the Inspector when 
the Arrange area is in key focus.

Â Track Parameter box:  Used to alter various aspects of track channel strips. All regions 
on the track lane will be affected by any changes made here (as all regions are 
routed through this channel strip). Clicking on the small triangle to the left of the 
name shows or hides the contents of the box. Closing the box provides room for the 
elements below. 

Â Region Parameter box:  Used to set playback parameters, such as transposition and 
quantization, for individual regions on track lanes. None of the parameters in the 
Region Parameter box actually alters the original data in the region. They only affect 
the way the region (and events within the region) are played back. These parameter 
alterations occur in real time, as the region is played. Clicking on the small triangle to 
the left of the name shows or hides the contents of the box. 

Region Parameter box

Track Parameter box

Arrange channel strips
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Â Arrange channel strips:  The left-hand channel strip controls the output of the 
selected arrange track. The right-hand channel strip can vary, dependent on actions 
performed in the left channel strip. As examples, the right channel strip can display 
the first aux or output destination channel strip for the left-hand channel strip. This 
facility makes it quick and easy to set up flexible effects and audio routing schemes. 
It also provides an at-a-glance view of processing and routing for the selected 
arrange track, and you can access all of the mixer channel functions (volume, pan, 
sends, inserts, and so on) directly from the Arrange area. Any adjustments you make 
to a track’s arrange channel strip will be reflected in the corresponding Mixer channel 
strip, and vice-versa.

Note:  The horizontal size of the Inspector can not be altered. In situations where the 
area in key focus does not provide a parameter area, the Inspector for the Arrange area 
is displayed.

As the Inspector updates to display the parameters of the window with key focus, 
usage details are found in the chapters for each window.
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The Editing Area
You can open the Mixer, Sample Editor, Piano Roll Editor, Score Editor, and Hyper Editor 
directly in the Arrange window by clicking the corresponding button at the bottom of 
the Arrange window. Here’s a brief overview of what each window offers. 

Getting to Know the Mixer
The Mixer is where you mix your project. Each track is played back through a channel 
strip. You can adjust the level and pan position of a channel strip, add effects, mute and 
solo tracks, and send the output of a channel strip to other channel strip types, such as 
output and auxilliary channels. 

Â Channel strips:  Use the channel strip controls to adjust the level and other aspects of 
the audio signal played through the channel strip. 

Â View buttons:  Switch the Mixer between the Single, Arrange, and All Mixer views, 
limiting the Mixer view to channel strips required for the task at hand. 

Â Filter buttons:  Filter the display of specific channel strip types. 

Full details can be found in Chapter 25, “Mixing,” on page 541.

Channel strips

Filter buttonsView buttons
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Getting to Know the Sample Editor
The Sample Editor displays the contents of audio files as waveform graphics. You can 
use the Sample Editor to precisely edit audio files (and regions). The Sample Editor also 
features a number of useful destructive processing tools—these allow you to time 
stretch and pitch shift audio, change sample rates, extract MIDI grooves from the audio, 
and even quantize audio.

Â Ruler:  Shows the position of the region in the arrangement. If you have not yet 
added the audio file to the arrangement, the position marker lines are dotted, 
indicating no time connection exists. 

Â Info display:  Shows the start point and length of the selected area.
Â Waveform overview:  Displays a miniature view of the entire waveform. The white 

frame shows the extent of the section visible in the waveform display. The dark gray 
frame shows the currently selected area. 

Â Waveform display:  Provides a detailed waveform display. If you’re dealing with a 
stereo file, both channels are displayed, with the left side on top, and the right side 
below. Left of the waveform display is the amplitude scale. 

Â Playhead:  The gray line in the waveform display shows the current position of the 
playhead. 

Â Anchor:  Sets a temporal reference point for an audio region. When you move a 
region in the Arrange area, Logic Pro displays the position of the anchor in the help 
tag, and snaps the region’s anchor to the selected Snap menu grid division.

Â Region area:  Edit this beam to adjust the length of the region. 

 Ruler

Info displayWaveform overview

 Waveform display

 Anchor

PlayheadRegion area
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Getting to Know the Piano Roll Editor
The Piano Roll Editor displays MIDI notes as beams on a grid. The piano keyboard to the 
left is aligned with the note pitches represented by each beam. Note length is 
indicated by the relative length of each beam. Note position is displayed from left to 
right—a ruler and vertical grid lines make it easy to see where notes begin and end. 
Note velocity (how hard a note is struck, and usually how loud) is indicated by color. 

Full details can be found in Chapter 16, “Editing MIDI Events in the Piano Roll Editor,” on 
page 397.

Getting to Know the Score Editor
The Score Editor uses traditional music notation to display the MIDI note events (plus 
pedal and other event types) of MIDI regions. You can insert and edit MIDI note events 
in staffs, and use musical symbols to clarify their meaning in this editor. Text, such as 
lyrics, titles, and comments, can also be integrated into the score. The Print function 
allows you to print complete scores, with staff numbers only limited by the paper size. 
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Details on Score Editor use can be found in Chapter 33, “Working With Notation,” on 
page 667.

Getting to Know the Hyper Editor
The Hyper Editor displays MIDI note or controller events as vertical beams, placed along 
a user-defined time grid. This makes the Hyper Editor the ideal place to:
Â Add or edit controller data, such as note velocities. It makes some editing tasks—

such as data scaling—much faster. 
Â Quickly create and edit MIDI drum parts. 

Â Event definition:  Each horizontal row (or lane) provides an event definition, which 
determines the type of event displayed/affected. When you select a row in the name 
column, its event definition is shown in the Inspector’s Event Definition Parameter 
box.

Â MIDI events:  Each MIDI event is represented by a vertical beam, aligned with a 
particular time position. The value of the controller, or velocity of the note, is 
indicated by the height of the beam. Taller beams indicate higher values.

 Event definitions

 Event Definition
Parameter box

MIDI events
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Common Features of Logic Pro Windows
All Logic Pro windows, including the Arrange area, feature a number of common 
elements. This consistent approach between windows makes your life easier, as you will 
find these elements in the same place throughout the application.

Local Menu Bars
A window’s local menu bar contains buttons that access functions which are specific to 
the window. As an example, the Score Editor provides an enharmonic shift function, 
which is relevant to notation, but not to Piano Roll editing. 

Tool Menus
The tools available in the Tool menus of each window are specific to tasks performed in 
the window. As examples:  the Arrange area provides tools for different arrangement 
tasks, such as cutting or moving regions, and automation editing. The Score Editor 
provides tools used for score layout, and tasks such as voice separation.

The left Tool menu assigns the default tool. The right menu assigns a secondary tool. A 
further tool menu will appear if the right mouse button is not assigned to other tasks. 
For more information, see “Working With Tools” on page 166.

Local menu bar
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Catch, Link, and Hierarchy Buttons
Most windows contains Catch, Link, and Hierarchy buttons. These are used to tie or 
associate Logic Pro windows, and can aid in navigating through different levels of your 
song structure. As an example of where this is useful, if you click on a region in the 
Arrange area, the contents of a linked window (the Piano Roll editor, for example) will 
update immediately to show the events within the region. 

Scroll Bars
Vertical and horizontal scroll bars are shown at the right and bottom edges of the 
window. These enable you to view sections that fall outside the visible display area.

Zoom Sliders
Vertical and horizontal sliders are shown at the bottom right corner of the window. 
These allow you to horizontally or vertically resize the contents of the window, 
enabling a closer or more distant view of data.

Bar Ruler
All linear editing windows feature a Bar ruler at the top. The position of regions and 
events within a project are aligned with Bar ruler positions. The Bar ruler displays 
markers and locators, and reflects time signature changes. It also indicates three 
important operational modes—solo, recording, or synchronized.

Hierarchy button Link button

Catch button
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Global Tracks
All linear editing windows also feature global tracks, which are displayed just below the 
Bar ruler, when opened. Click the disclosure triangle to the left of the Bar ruler (labeled 
Global tracks) to view the global tracks. 

Â Marker track:  Contains markers, which are used to label bar positions and parts of the 
project. Their length, text, and color can be edited freely (for details, see “Working 
With Markers” on page 123). 

Â Tempo track:  Contains all tempo changes in the project. For further information, see 
“Using the Tempo Track” on page 642. 

Â Beat Mapping track:  Allows you to assign the desired bar position to any musical 
event (both MIDI notes and distinct accents in audio regions). This makes it possible 
to adjust the musical timeline to the original timing of a MIDI or audio region that 
has been recorded rubato (free time, including speeding up and slowing down), or 
just without a metronome click. The audible outcome remains unchanged, but the 
resulting display will fit the musical timeline.

Â Signature track:  Contains the basic key of the project, along with all time and key 
signatures, as they are displayed in the Score Editor.

Â Chord track:  Contains chord symbols that can be derived from MIDI regions or 
created with the mouse. These chord symbols may also be inserted into the score. 
The root note of the chords determines the transposition (pitch shifting) of all Apple 
Loops, and can also affect the playback of MIDI regions.

Â Transposition track:  Shows global transposition events. It is linked to the progression 
of the chord root notes in the Chord track:  Changing a chord root will be reflected in 
the Transposition track, and vice-versa.

Â Video track:  Displays frames of a QuickTime movie as thumbnails that are perfectly 
synchronized with the music, making it ideal for film scoring. Cuts in the movie can 
be automatically detected and marked. 
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Interactions Between Arrange Window Areas
The Arrange window contains various sections that interact with each other. These 
provide you with access to all files, editing methods, track and channel strip parameters 
in one place, making your workflow much faster. Please follow the steps outlined 
below to learn how these Arrange window elements work in harmony, to accelerate 
music production.

To see how Arrange window areas interact:
1 Open the Media area by clicking the Media Browser button in the Toolbar.

2 Click the Browser tab, then browse to a folder that contains audio files. 

3 Click-hold the audio file name, and drag it onto an audio track lane in the Arrange area.

Release the mouse button when the help tag displays position 1 1 1 1. A region will be 
created in the Arrange area.

4 Click the Sample Editor button at the bottom of the Arrange area. 
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The Sample Editor is shown, displaying the contents of the region you just created in 
the Arrange area.

5 Click the Audio Bin tab.

The Audio Bin contains the audio file you just added to the project. 

6 Click the Loops tab, then click a category button to see matching loops in the Loops 
tab’s Search Results list.
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7 Select a loop with a green icon and drag it to a software instrument track in the 
Arrange area. 

Release the mouse button when the help tag displays position 1 1 1 1. A MIDI region 
will be created in the Arrange area.

∏ Tip:  If no software instrument track exists, you can also drag the Apple Loop from the 
Loop Browser directly into the blank Arrange area. A track and corresponding channel 
strip are automatically created, and the Apple Loop is loaded.

8 Click the Piano Roll button at the bottom of the Arrange area. 

The Piano Roll Editor is shown, displaying the contents of the region you just created in 
the Arrange area.

9 Move the playhead to the beginning of your project by clicking the Go to Beginning 
button in the Transport bar.

10 Play your project by clicking the Play button in the Transport bar.

You will hear the audio file and instrument loop you added to the project. You may like 
the melody of the software instrument loop, but not its sound. Utilize the Library to 
assign another sound to the software instrument track.
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11 Select the software instrument track, then click the Inspector button.

The left channel strip displays the software instrument, and effect of the selected track.

12 Click the Library tab, and browse through the displayed channel strip settings. 

As this is a software instrument track/channel strip, only software instrument channel 
strip settings are shown in the Library.

13 Select one of the channel strip settings to load it.

14 Start playback again to audition the new sound. 
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Using Logic Pro Interface Elements
You can access all of the buttons, switches, sliders, and menus discussed above with 
the mouse and computer keyboard. Use of these Logic Pro interface elements is 
outlined below:

Checkboxes and Buttons
Checkboxes are square boxes that are turned on when you click them, in order to 
activate an option (or function). Click the checkbox a second time to turn it off, and 
deactivate the option. 

Some buttons behave in a similar fashion, where the function they represent is 
temporarily enabled (while the button is pressed, and usually illuminated). 

A second click on the button will disable the function. Good examples of these types of 
buttons include the Mute and Solo buttons.

A different type of checkbox is the round radio button. A number of grouped buttons 
(each representing a different option) are available, and you need to select one of 
them. They differ from checkboxes and other button types in that only one of them can 
be activated at any given time. A good example are the Type radio buttons in the New 
Tracks dialog.
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Pull-Down and Pop-Up Menus
Pull-down menus open when you click on the desired menu item. Pop-up menus open 
when you click on certain input fields or buttons. 

In some menus, an arrow is shown beside one or more items, indicating a sub-menu. 
To choose an item from a sub-menu, move the mouse in the direction of the arrow, 
and then move vertically over the desired item. Click to activate the chosen command 
or setting.

If you wish to select an item that is outside the visible section of the menu, move the 
mouse over the arrow at the top or bottom edge of the menu. The menu will scroll.

Shortcut Menus
Shortcut menus (also called contextual menus) are accessed by Control-clicking or 
right-clicking in different areas of various Logic Pro windows. These offer a number of 
selection, editing, and other area-specific commands, providing quick access to 
commonly used functions.

Note:  Right-click functionality is dependent on the Right Mouse Button: Opens 
Shortcut Menu option being chosen in the Logic Pro > Preferences > Global > Editing 
tab.
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Using the Computer Keyboard
You can access most Logic Pro functions with key commands. Whenever this manual 
mentions a key command, this refers to a function or option that can be accessed with 
a computer keyboard keystroke (or keystroke combination, such a pressing both the 
Control and W keys on your keyboard).

Use of key commands, rather than the mouse, can greatly accelerate your Logic Pro 
workflow. Throughout this manual, you will encounter a number of practical usage 
examples, often in step form, that include the default key commands for particular 
functions.

It is recommended that you follow the steps outlined in the manual, and make use of 
these default key commands while familiarizing yourself with Logic Pro. Not only will 
this help you to remember them, but will also aid you in developing good (and faster) 
working practices from the outset.

Once you have a good understanding of Logic Pro fundamentals, and how you like to 
work, you can freely assign your own set of key commands. Logic Pro functions and 
options that can be assigned to key commands can also be assigned to MIDI 
commands, sent from your MIDI controller. More detail on these advanced topics can 
be found in “Working With Key Commands” on page 158.
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3 Customizing Your Window Setup

Logic Pro allows you to customize your window setup to fit 
both your working style and the task at hand. 

While you will perform most of your work in the Arrange, you can open different 
combinations of windows (even several of the same type) and adjust each individually. 
It is also easy to save different window arrangements (called screensets, discussed in 
“Using Screensets” on page 78), and recall them by pressing a key.

All open windows in a project are constantly updated, following the position of the 
playhead. Alterations made in one window are immediately reflected in all other open 
windows. As an example, if the pitch of a note event is changed in the Score Editor, this 
change is instantly shown in an open Piano Roll Editor window.

This chapter outlines how you can customize and save your overall window setup. The 
display options of individual windows or editors are not covered in this chapter.

Window Types
There are two different types of windows in Logic Pro:  normal windows and floating 
windows. 

Normal Windows
You can open as many normal windows as desired, including several of the same type. 
Even though the contents of all windows are constantly updated, only one window 
ever has the status of being the top, or active window. This is the window that is in the 
foreground when several normal windows overlap. It is referred to as having key focus.

Key focus windows can be recognized by a title bar that is illuminated, and black title 
bar text (the project name).

To assign key focus to a window or area, do one of the following:
m Click on the window title bar, or within the working area. 

Take care with the latter, as you may accidentally insert an event or region, if the Pencil 
tool is active in the window.
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m Choose Window > Cycle Through Windows (or use the corresponding key command). 

This assigns key focus to the next open window, if it is fully obscured by other 
windows.

The Arrange window can obviously incorporate several other windows in different 
areas. These can be given key focus by clicking the background or title bar of the 
window (the area of the Arrange you want to use), or by using a tool in the window.

∏ Tip:  You can also use Tab or Shift-Tab to cycle through the Arrange window areas:  Tab 
cycles forward, Shift-Tab cycles backwards.

The main characteristic of the key focus window (or area of the Arrange window) is 
that key commands only affect this window, and not any of the others. 

Handling Background Windows
Background windows are not fully obscured, and are identified by a dimmed title bar 
(they can be positioned next to the top window, or tiled underneath it) and a faded 
name.

In background windows, you can not only observe changes, but make almost any kind 
of change, without needing to give the window key focus before making alterations. 

Independent tool selection is memorized for each window, allowing you to directly edit 
the contents of any window, whether it has key focus or not. As soon as any such edits 
are made, the window is automatically made the key focus window. As an example, an 
Arrange window with Piano Roll and Event List editor visible:  the Pointer is active in 
the Arrange area, the Pencil tool is active in the Piano Roll, and the Eraser tool is active 
in the Event List editor. The tool automatically becomes active as you drag the mouse 
cursor across the boundaries of each window. 
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Floating Windows
Floating windows are so named because they always float in the foreground, even 
above the key focus window (opening numerous float windows inevitably leads to 
them covering each other—just click on the desired one to move it to the foreground). 

In general, most of the Logic Pro helper windows, such as the Preferences or Project 
Settings windows, are floating windows.

Floating windows are usually recognizable by their narrower, gray title bar (except the 
plug-in window, which has a different title bar style). Mouse operations performed in 
floating windows behave in the same way as in normal windows.

Opening and Closing Windows
You can open all main Logic Pro windows by choosing the window type (Arrange, 
Score, and so on) in the main Window menu. Each window type has a corresponding 
key command that opens the window, without using the mouse. As examples, 
Command-1 opens the Arrange window, Command-2 opens the Mixer, and so on. The 
key command designations are shown beside each window name in the Window 
menu. It is highly recommended that you learn and use these key commands, rather 
than the mouse, as they will speed up your workflow.

You can open multiple windows of the same type, if required. This may be useful when 
you want to individually display and alter the contents of several regions in a particular 
editor type.

You can also open all Logic Pro editors in the Arrange window by clicking the buttons 
at the bottom of the Arrange window.
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Double-clicking an Arrange audio region opens the Sample Editor at the bottom of the 
Arrange window. Double-clicking an Arrange MIDI region opens the default editor at 
the bottom of the Arrange window. You can determine the default editor with the 
“Double-clicking a MIDI region opens” menu in the Global preferences window. 
Option–double-click on a region to open the default editor as a separate window.

The Toggle … Window key commands allow you to define one key command to open 
or close the window or area of the assigned type in the active Arrange window. If the 
window is not available as Arrange window area, it will be opened as an independent 
window. As examples in the Arrange window:  You can open and close (toggle) the 
Lists and Media areas with the Toggle File Browser, Toggle Library, and so on key 
commands.

You can close the window with key focus (usually the topmost, or foreground window) 
by choosing File > Close in the main menu bar (or by using the Close Window key 
command, default:  Command-W).

Windows can also be closed by clicking the close symbol at the top left. 

Option-click the close symbol to close all windows of the active project. 

Note:  If you close all open windows of a project, Logic Pro assumes that you want to 
close the project, and asks if you want to save your changes. 



Chapter 3    Customizing Your Window Setup 63

Moving and Resizing Windows
You can move and resize all open windows individually, even across multiple monitors. 
You can also alter the size of all window elements that feature the resize bar.

The size relationship of the editing and Arrange areas within the Arrange window can 
also be adjusted, by clicking between them, and dragging vertically. The cursor 
changes to a Resize pointer. The vertical height of the Mixer area is memorized 
independently. All other editing areas share the same height.

You can not resize the other Arrange window elements (the Inspector and Media or 
Lists area). You may only open or close these areas. 

Here is an example of a possible window setup:  Imagine you want to edit the MIDI 
notes of various MIDI regions. You may want to increase the height of the Piano Roll 
Editor to work at a high zoom level, thus decreasing the height of the Arrange area. 
You would then reduce the Arrange area zoom level, as it only needs to be used for 
region selection duties. 

To move a window:
m Click-hold the title bar and drag the window to the desired position. 

Resize pointer
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To adjust the size of a window, do one of the following:
m Drag the lower right-hand corner of the window, as with any window in the Finder.

m Position the mouse pointer over the window edge. When the mouse pointer turns into 
the Resize pointer, drag in the desired direction. 

To adjust the size of window elements:
1 Move the mouse over the resize bar. 

2 When the mouse pointer turns into the Resize pointer, drag the window element into 
the desired direction. 

To maximize a window, do one of the following:
m Select the window, the choose Window > Zoom. 

m Click the zoom button (the rightmost button of the three window controls) in the top 
left corner of the window title bar. 

A second click on the icon will restore the original window size.

To minimize a window, do one of the following:
m Select the window, then choose Window > Minimize (or use the corresponding key 

command, default:  Command-M). 

m Click the minimize button (the middle button of the three window controls) in the top 
left corner of the window title bar.

This places an icon (minimized version of the window) in the Dock. The window can be 
restored by clicking on the icon in the Dock.
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Working at Different Hierarchy Levels
Logic Pro allows you to view projects at an overview level (Arrange level) and also at 
the microscopic level (editor level). These different hierarchical levels are designed for 
different types of tasks, such as arranging project sections or refining instrument parts, 
as examples. In many cases, you can switch between these different display levels 
directly, without needing to open or access another window.

Clicking the Hierarchy button in the top left corner of a window or window area moves 
the displayed view up one level (generally to the Arrange level).

Note:  Double-clicking on the background of the editing area of a window also moves 
up one display level.

About Display Levels in the Editors
Normally, the editors are at the lowest display level, which shows individual events 
within the selected region. 

In the Piano Roll and Hyper Editors, a step up the display hierarchy will show the events 
of all regions in the Arrange area. 

Clicking the Hierarchy button in the Event List moves you up one level in the display 
hierarchy, just like the other editors. In the Event List, however, the display remains 
much the same but shows a list of regions, rather than a listing of individual events—
along with region positions, names, track numbers, and lengths. The MIDI region that 
you were just editing will be selected within the list of region names.

Double-clicking on a MIDI region (or using the Go Into Folder or Region key command) 
returns you to the lowest display level, and shows the contents of the MIDI region.

Double-clicking on an audio region opens it in the Sample Editor. 

In the Score Editor, clicking on the Hierarchy button takes you to the higher display 
level. Unlike the other editors, individual events can also be edited while in higher 
display levels in the Score Editor. Double-clicking on a staff (at an empty point), reverts 
to a lower display level.
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Selecting the Working Area
The scroll bars at the right and bottom edges of a window enable you to move 
through the working area in either the vertical or horizontal dimension. 

You can move the visible section by clicking the arrows, or dragging the scroller. There 
are two points to note:
Â The size relationship of the scroller to the overall scroll bar length corresponds to the 

size of the visible section of the window, in relation to the overall window size.
Â The visible section changes as you move the scroller.

Scroll bar

Scroll bar
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Use the Page Up, Page Down, Page Left, and Page Right key commands to scroll one 
page up, down, left, or right, as if you had clicked in the gray area (in the scroll bar) 
above or below the vertical scroller, or to the left or right of the horizontal scroller.

The Page Top, Page Bottom, Page Left-Most, and Page Right-Most key commands move 
the visible section of the working area to the top, bottom, left, or right, just as if you 
had grabbed one of the scrollers, and moved it to one of its extreme positions.

In the Arrange area, Event List, Hyper and Piano Roll Editors, View > Scroll to Selection 
moves the visible section of the edit window to the first set of selected events. This 
function is available as key command and works in the currently active window.

To scroll both vertically and horizontally at the same time, do one of the following:
m Press Shift-Control, click-hold the Arrange window background, then drag into the 

desired direction.

m Click-hold the Arrange window background with the third mouse button (the mouse 
wheel, for example), then drag into the desired direction.

The distance of the mouse pointer position from the initial clicked position determines 
the scrolling speed.

Note:  This only works if you haven’t assigned the third mouse button to a global 
command, such as Expose, for example,

Zooming
The zoom controls are used to zoom in and out on the working display area. Selection 
of different zoom values reduces or increases the size of events or regions in the 
displayed screen section. This allows you to:
Â See more events or regions in the same amount of screen space (zoom out). 
Â See a detailed display of events or regions (zoom in).

Click the gray area below 
the vertical scroller to 
scroll one page down
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While zooming, the top-left (and selected) event or region is kept in the visible area of 
the screen. In other words, the first selected region or event will be retained in the 
zoomed window. If no selected region or event is visible, zooming is centered around 
the playhead. It the playhead isn’t visible, the current center of the window will be 
retained.

The horizontal and vertical zoom controls are located to the bottom-right of the 
working area of the window. 

To zoom out:
m Click on the more closely spaced bars to decrease the zoom level. 

To zoom in:
m Click on the widely spaced bars to increase the zoom level. 

You can drag the zoom sliders to step through several zoom levels. Any relative size 
differences between tracks will be retained when zooming. 

Command-clicking a value in the zoom control sets the zoom slider to the respective 
zoom level. 

Zooming With the Scroll Bars
The scroll bars not only allow you to move through your arrangement and editing 
windows. They can also be used for zooming.

To zoom with the scroll bars:
m Click-hold on the zoom handles at either end of the scroll bar, and drag:

Â Up or down on the vertical scroll bar.
Â Left or right on the horizontal scroll bar.

Vertical zoom control

Horizontal zoom control
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As you drag, the window contents will be zoomed.

Zooming the Waveform of Audio Regions
The Arrange area offers a unique Waveform Zoom tool, found to the left of the 
horizontal zoom slider. This allows you to visually resize the waveform, making it easier 
to determine hit points, which can be useful for some editing tasks.

To zoom the waveform of audio regions:
1 Click-hold on the Waveform Zoom button, and a slider is shown.

2 Drag the slider, and as you do so, the waveform shown in all audio regions is increased 
or decreased in size.

An active Waveform Zoom button is displayed in dark gray. Click it to switch off the 
Waveform Zoom display.

Note:  This is a purely visual function. The amplitude (level) of the waveform is not 
affected.

Storing and Recalling Zoom Settings
You can store three different zoom settings for each window via use of the Save as 
Zoom 1–3 key commands. Use the Recall Zoom 1–3 key commands to recall your 
zoomed settings. These commands only apply to the active window or window area.

Zooming in on One Section of the Screen
To enlarge a section of the screen to fill the whole window, rubber band select the 
desired area with the Zoom tool. 
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You can do this repeatedly, if you need to zoom in further.

∏ Tip:  You can access the Zoom tool when other tools are selected by holding Control-
Option.

Reverting to the Previous Zoom Setting
Click on the background with the Zoom tool. This will return the zoom level to the 
original setting, or will backtrack through previous zoom steps if the tool was used 
multiple times. 

Zoom Navigation Key Commands
You can set, and recall, up to thirty zoom level and window scroll-bar positions for each 
window. These allow you to navigate through a number of window zoom levels, and 
scroll bar positions, making repetitive editing tasks much faster.

You can use the following commands to zoom selected events, or a region defined by 
the locators, to fit the screen. The use of all zoom commands creates a new step in the 
navigation path.
Â Zoom to fit Selection vertically and horizontally, store Navigation Snapshot:  Displays the 

current selection as large as possible, and saves it in the navigation path.
Â Zoom to fit Selection horizontally, store Navigation Snapshot:  Displays the current 

selection as large as possible horizontally, and saves it in the navigation path.
Â Zoom to fit Locators, store Navigation Snapshot:  Displays the current locator area as 

large as possible, and saves it in the navigation path.

The navigate key commands allow you to recall the previous or next zoom settings.
Â Store Navigation Snapshot:  The current zoom and scroll bar (window position) 

settings are saved as a step in the navigation path.
Â Navigation: Back:  Recalls the previous step in the navigation path.
Â Navigation: Forward:  Advances to the next step in the navigation path.

As an example of where the navigation path commands could be useful, imagine 
cutting and pasting sections of an audio region to several other locations, in a project 
with hundreds of tracks. One step in your navigation path would be a zoomed view of 
the audio region. Another step could be a vertically zoomed in version of several tracks 
(the target tracks for the pasted region sections). A further step could be a horizontally 
zoomed out section of the project, allowing you to paste the region segments to a later 
position.

Note:  There are no default key commands for most of these navigation options, so you 
will need to assign them in the Key Commands window. Choose Logic Pro > 
Preferences > Key Commands and type “nav” in the Find field. This will display the 
entries described above. For more information about assigning key commands, refer to 
“Assigning Key Commands to Computer Keys” on page 162.
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Relationships Between Windows
Logic Pro allows you to independently link or unlink windows, providing you with 
flexible viewing options. This enables you to set up two Event List windows for 
example, with one showing Arrange regions, and the other showing the contents of 
the regions. You can simply click on the desired region name to update the contents of 
the second event list.

The two buttons at the top left of most windows determine its relationship to:
Â The playhead position (Catch)
Â Other windows (No Link, Same Level Link, or Content Link)

Catch
Enable the Catch button to ensure that the visible section of a window follows the 
playhead during playback or recording. 

If the button is disabled, the display does not update, even when the playhead moves 
past the right edge of the visible portion of the window.

The “Catch when Logic starts” (Logic Pro > Preferences > Global > Catch) option 
enables Catch mode whenever you press Play or Pause.

The “Catch when moving playhead” preference enables Catch mode whenever you 
move the playhead. 

Scroll in Play
The View menus of all windows that display time horizontally (Arrange area, Score 
Editor, Piano Roll Editor, and Hyper Editor) offer the View > Scroll in Play setting. If the 
Catch function of the window is also activated, the playhead will remain in the middle 
of the window, while the background scrolls smoothly from right to left. 

No Link, Same Level Link, and Content Link Modes
These display options allow you to define how information is shown when working 
with related editor windows.

To set any of these modes:
m Control-click (or right-click) the Link button, and choose the required mode from the 

menu.

Â No Link:  Unlinks the window from others.
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Â Same Level Link:  When activated in a given window, this window always displays the 
same contents as the key focus window. The display updates whenever the selection 
(of data) in the key focus window changes. Here’s an example:  Imagine the key focus 
window is a Piano Roll Editor. In Same Level Link mode, the Score Editor and Event 
List will display the same data in another form.

Â Content Link:  This mode results in the window always showing the contents of the 
region selected in the key focus window. The display is therefore always one level 
below that of the top window. Here’s a Content Link example:  If the Arrange area is 
the active window, any opened MIDI editor window will show the events of the 
selected MIDI region. Selecting a different MIDI region in the Arrange area will 
update the display of the linked editor to show the contents of the newly-selected 
region. You could also use Content Link mode in one Arrange area, to display the 
folder contents of another Arrange area.

∏ Tip:  You can also quickly switch between these modes by clicking the Link 
button:  clicking it once switches between No Link and Same Level Link mode. Double-
clicking the Link button switches to Content Link mode. 

The symbol on the Link button reflects the chosen display mode:

Content Catch Mode
Content Catch mode is commonly used in the Arrange area, with linked MIDI editor 
windows updating to show the events within the MIDI region that is currently being 
played (on the selected Arrange track).

Initially, this is equivalent to Content Link mode, but when the playhead reaches the 
next region on the same track, the contents of this region are then displayed. 

To enable Content Catch mode:
1 Click the Catch button to turn it on.

2 Control-click (or right-click) the Link button, and choose Content Link mode.

Same Level Link mode Contents Link mode
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Customizing the Transport Bar
You can customize the Transport bar by adding or removing buttons and displays, 
allowing access to the functions you need most often. This in turn, has an impact on 
the size of the Transport window. You can also open an independent SMPTE or Bar 
display window. For more information, refer to “Customizing the Transport Bar” on 
page 117.

Customizing the Arrange Window Toolbar
You can customize the Toolbar by adding buttons for the commands you use most 
often. You can also configure the display to show only the button’s icons, or only their 
labels. 

To add a button to the Logic Pro Toolbar:
1 Control-click (or right-click) the Arrange window Toolbar, and choose Customize 

Toolbar from the shortcut menu.

2 Drag the buttons you want to add from the Customize Toolbar dialog to any empty 
area along the top of the window. 

If you drag a button to a location between two existing buttons, they will move to 
make space for the new button.

Note:  You may also choose to drag the entire default set from the bottom of the 
Customize Toolbar dialog, if your customizations don’t work out as well as you’d hoped.

3 Click Done when finished.
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To remove a Toolbar button:
m Control-click (or right-click) the desired button, then choose Remove Item from the 

menu.

To change the appearance of Toolbar items:
m The shortcut menu and Show menu in the Customize Toolbar dialog also allow you to 

view Toolbar items as Icon & Text, Icon Only, or Text Only. Simply choose the preferred 
viewing option.

When you resize the Arrange window, the Toolbar may not offer enough space to keep 
all buttons visible. 

To keep a Toolbar button visible when you resize the Arrange window:
m Control-click (or right-click) the desired button, then choose Keep Item Visible from the 

menu.

Hiding or Revealing the Inspector
You can hide the entire Inspector area to the left of the Arrange and editor windows, 
providing more workspace for regions, events, and other data.

To hide or show the Inspector in the Arrange window, either:
m Click the Inspector button in the Toolbar.

m Choose View > Inspector (or use the Hide/Show Inspector key command).

To hide or show the Inspector in the editing windows:
m Choose View > Inspector (or use the Hide/Show Inspector key command).

If there is not enough vertical room to display all areas of the Inspector, you can click 
the disclosure triangles to hide the individual boxes.

Adjusting the Bar Ruler Display
You can switch the Bar ruler between four display modes:
Â Time:  Displays a SMPTE time ruler, divided into hours, minutes, seconds, and frames.
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Â Bar:  Displays a Bar ruler, divided into bars, beats, divisions, and ticks. Dependent on 
the zoom settings (see “Zooming” on page 67), the bars are shown at the top edge in 
units of 1, 4, 8, or 16. Changes in time signature are also shown here. In the bottom 
third, there is a vertical line for each bar. The shorter lines represent one beat, but are 
not always visible (depending on the zoom setting).

Â Bar and Time:  Displays the Bar ruler above the SMPTE ruler. 

Â Time and Bar:  Displays the SMPTE ruler above the Bar ruler. 

To set the Bar ruler display mode:
m Click on the small down arrow icon to the right of the Bar ruler, and choose the desired 

display mode in the shortcut menu.

The Marquee Stripe setting hides or shows the marquee stripe—a tool used for 
selection tasks. For further information see “Selecting Parts of a Region” on page 305.

You can also use the following key commands to switch the ruler display:
Â Event Position and Length in SMPTE Units:  Switches between the Bar and SMPTE ruler 

if one ruler is displayed, and switches the position of the Bar and SMPTE ruler if both 
are displayed. 

Â Secondary Ruler:  Switches the display of the second ruler. 
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Displaying Global Tracks
All linear editing windows can display global tracks just below the Bar ruler. You can 
limit the display to particular global tracks, resize, and move them. 

To hide or show global tracks, do one of the following ways:
m Click the Global Tracks disclosure triangle to the left of the Bar ruler.

m Choose View > Global Tracks (or use the Toggle Global Tracks key command). 

m Use one of the following key commands:

Â Hide All Global Tracks
Â Show All Global Tracks

Showing and Hiding Individual Global Tracks
By default, the global Marker, Signature, and Tempo tracks will be visible when you use 
any of the methods above to open the global tracks lanes.

To hide or show particular global tracks:
1 Do one of the following:

Â Control-click (or right-click) anywhere in the global tracks header area, and choose 
Configure Global Tracks from the shortcut menu.

Â Choose View > Configure Global Tracks (or use the Configure Global Tracks key 
command).

2 Do one of the following in the Configure Global Tracks dialog:

Â Click the corresponding checkboxes to display or hide each global track type.
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Â Click the Enable All or Disable All buttons to show or hide all global tracks, 
respectively. 

The choices made in the Configure Global Tracks dialog only affect the active window. 
Each window can have an independent global track display configuration. 

Note:  You can also assign, and use, any of the following Toggle key commands for each 
individual global track:  Marker, Transposition, Chord, Signature, Tempo, Beat Mapping, 
and Video. This will have an immediate impact, and will not open the Configure Global 
Tracks dialog.

Resizing and Moving Global Tracks
You can resize global tracks individually, and can resize the entire global tracks area.

To resize individual global tracks, do one of the following:
m Click the disclosure triangle in the upper left corner of each global track. 

The track height is expanded and additional controls become visible. A further click on 
the triangle reduces the track height.

m Position the mouse pointer over the lane dividers between global tracks in the header 
area, then drag up or down.

To resize the entire global tracks area:
m Position the mouse pointer over the dividing line between the global tracks and the 

Arrange tracks, then drag up or down.

To change the order of global tracks:
m Grab anywhere (except on the control elements) in the header area of the global track 

you want to move, and drag up or down. 

The display order of global tracks is saved independently for each window. 

∏ Tip:  If the Track Protect buttons are visible (View > Configure Track Header > Protect 
Buttons), you can prevent unintentional changes to individual global tracks by clicking 
on the corresponding Protect button. 
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Using Screensets
You will position windows in a way that suits your working methods. This layout of 
various windows, including the display size, zoom levels, and position of each window 
(and other settings) is called a screenset. Once defined, you can save, and freely switch 
between different screensets, much as you might swap between different computer 
monitors.

Saving and Recalling Screensets
Screensets are numbered from 1 to 99 (using only the 1 to 9 computer keys—the 0 key 
is assigned to the Stop command by default). 

You don’t need to save screensets with an explicit command. It happens automatically, 
as soon as you switch to another screenset. Thus, without any effort, your current 
working view is always stored as the current screenset.

To create a screenset:
1 Press a numerical key, say 7. 

For two-digit screensets, hold down Control while entering the first digit.

2 Arrange your windows as desired, including changes to zoom settings, relationship of 
the Arrange area and editor areas, open or closed Inspector and Media or Lists areas, 
and so on.

Note:  When you choose a screenset number that has not been saved, a maximized 
Arrange window opens.

To recall, or switch between screensets, do one of the following:
m Input the number of the desired screenset (1 to 9). 

For two-digit screensets, hold down Control while entering the first digit.

m Choose the desired screenset from the Screenset menu.

m Use the Next Screenset or Previous Screenset key commands. 

Recalling Screensets 1 to 9 via Key Commands
Screensets 1 to 9 can be recalled by freely-defined key commands, not only the 
number keys on your computer keyboard. This allows you to use the number keys for 
other purposes, such as opening or closing windows. The 1 to 9 key commands are 
called Recall Screenset 1 (… 9, respectively) in the Key Commands window.

Sequencer Controlled Screenset Switching
You can automatically switch screensets through the use of meta event # 49—just add 
it to a MIDI region in the Event List.

To switch a screenset automatically:
1 Select the MIDI region into which you want to insert the meta event.
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2 Set the playhead to the point where you’d like the screenset to change.

3 Click the Create button in the Event List, then click the Meta Events button.

The inserted meta event has a default value of 50 (Project Select).

4 Alter the number in the Num column from 50 to 49.

This changes the name to screenset.

5 Input the desired screenset number in the Val column.

You can stop screenset switching by muting the MIDI region that contains the meta 49 
event.

Protecting, Copying, Renaming, and Deleting Screensets
Logic Pro allows you to protect, copy, rename, and delete a screenset, making it easy to 
manage screensets.

To prevent the current screenset from being altered:
m Choose Screensets > Lock Screenset (or use the Lock/Unlock Current Screenset key 

command, default:  Shift-L).

A bullet appears in front of the screenset number to indicate that it is locked. Reuse the 
key or menu command to unlock the screenset.

Important:  The File > New command deactivates all screenset locks.

To copy screensets:
1 Switch to the screenset you would like to copy, and choose Screensets > Duplicate (or 

use the corresponding key command).
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2 In the Duplicate Screenset window that opens:  Type in the target screenset number 
(the screenset number that you want to copy to), and enter a name.

To rename the current screenset:
m Choose Screensets > Rename (or use the corresponding key command), and type the 

desired name in the Rename Screenset window.

Click the Auto Name button to automatically name the screenset. This defaults to the 
visible window names (“Arrange/Piano Roll” or “Arrange/Mixer” as examples). The name 
is automatically updated whenever a window or view is opened or closed. 

To delete the current screenset:
m Choose Screensets > Delete (or use the corresponding key command).

Importing Screensets From Another Project
You can import screensets from another project. 

To import all screensets from another project:
1 Open the Import Settings window by doing one of the following:

Â Choose File > Project Settings > Import Settings (or use the Import Settings key 
command). 

Â Click the Settings Toolbar button, then choose Import Settings from the pop-up 
menu. 

2 In the Import dialog, click the Screensets option.

3 Browse to, and select, the desired source project (the one that you wish to import 
from). 

4 Click Open (or double click on the source project name). 

The settings are imported into the active project.

Reverting to Saved Screensets
The Revert to Saved Screenset (or the corresponding key command) resets your screen 
to its original state—prior to changing any aspect of the current screenset.
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4 Setting Up Your System

Logic Pro automatically finds and configures supported audio 
and MIDI hardware when first installed and run. There are 
many circumstances where you may wish to enhance or 
extend this basic automatic configuration. 

This chapter will help you to optimize your hardware for use with Logic Pro. It also 
includes a lot of background information about components your music production 
system can incorporate. If you’re new to Logic Pro, and would like to get “hands on” 
with the application, please skip ahead. You can always return to the following sections 
when considering the addition of a device to your system, but this isn’t essential to 
know before using Logic Pro.

Designing Your Music Production System
Your music production system can incorporate far more than your computer and 
Logic Pro software. 

A complete Logic Pro studio could conceivably consist of any, or all, of the following 
components:
Â A Macintosh computer and related peripherals, such as a mouse or other pointing 

device, keyboard, displays, and so on
Â Additional Macintosh computers, which can be used to boost the processing power 

of your Logic Pro system via network connections. These are referred to as Logic Pro 
Nodes.

Â Audio and MIDI interfaces
Â External MIDI sound generators, such as samplers and synthesizers
Â External audio devices, such as mixers, audio converters, pre-amplifiers, channel 

strips, effects units, and more
Â External MIDI control surfaces and keyboards. Even external MIDI-controlled lighting 

can be driven by Logic Pro.
Â Amplification and speakers for stereo or multi-channel surround mixes
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Â Additional software that runs alongside, and integrates with, Logic Pro. This includes 
a range of ReWired applications and audio or MIDI software

Â Additional effect and instrument plug-ins, including those that are DSP-accelerated, 
such as PowerCore.

Read this section if considering components that you want to integrate into your 
Logic Pro music production system. If you already have all components, and their 
integration meets your needs, feel free to skip this section. 

Computer
This section outlines several computing factors that you should consider for your 
Logic Pro system. System requirements are covered in the Before You Install document, 
found in the Documentation folder of the Logic Pro installation discs.

Note:  System requirements may change between Logic Pro releases, so you should 
always check the Apple website and the latest Before Your Install document included 
with Logic Pro updates.

How Fast Your Computer Should Be
Audio processing is complex, so the general rule is:  the more powerful your computer, 
the better. This involves not only the speed of the CPU(s) of your Macintosh, but also 
includes larger main memory sizes, the speed of busses, and the general efficiency of 
communication with connected devices.

A Portable or Fixed Studio?
You may be wavering between a desktop or portable Macintosh as the basis for your 
Logic Pro system, or perhaps considering the viability of a laptop machine for on-the-
road composition. The good news is that portable Macintosh computers are ideal for 
Logic Pro use. They offer excellent audio and MIDI hardware expansion capabilities in 
the form of FireWire and USB connectors, and are fast enough to allow extensive 
software instrument and effect use. Due to the power-saving nature of portable 
computers, slower hard disk drives are usually included, resulting in a lower track count 
than is possible with a desktop equivalent.

Obviously, desktop computers offer additional expansion slots, extending the range of 
MIDI and audio hardware possibilities available to notebook computers, and can 
incorporate multiple processors. CPU and hard disk speeds are generally higher, thus 
allowing higher track playback counts, and the simultaneous use of more software 
instruments and effects.

∏ Tip:  If you have both a portable and desktop Macintosh, you can easily transfer 
projects and other data between them, and take advantage of the Node functionality, 
which harnesses the processing power of both computers for your projects.
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Hard Drives and Storage Locations
Music production generates a huge number of large files. These include samples for 
audio instruments, loop libraries, audio recordings, video files, and more.

Consider buying a separate, large capacity hard drive (or several) for your audio files 
and sample libraries. 

You should also look at a reliable, high-capacity backup system, and should automate 
your backup routine, preferably as a daily occurrence.

Audio and MIDI Interfaces
An audio interface is required—to get sound signals into, and out of, your computer. A 
MIDI interface is required for MIDI input and output signals. 

When using optional audio and MIDI interfaces, you should install their drivers before 
starting Logic Pro. This will allow Logic Pro to find and use these devices at startup. 

Audio interfaces should be supported by a Core Audio driver and MIDI interfaces 
should be supported by a Core MIDI driver. Check with the manufacturer of your 
equipment for details on Mac OS X support.

Audio Interface
When an analog audio signal arrives at the inputs of your audio interface, it must be 
converted into digital information before the computer can deal with it. This process is 
called analog to digital conversion and is handled by the analog to digital converter of 
the audio interface. 

There are countless optional audio interfaces available, and at least as many ways that 
they can be set up and used with Logic Pro and external audio gear. Given the differing 
requirements and working methods of people across the world, there is no one size fits 
all audio interface solution. In the simplest scenario, you would use the internal audio 
interface of your computer to monitor and record audio.

When choosing an audio interface, ensure that it is certified to run on Macintosh 
hardware. If the device requires a driver, check that it is compatible with the Mac OS X 
version required by Logic Pro.

Logic Pro supports input from digital audio interfaces up to a maximum sample rate of 
192 kHz, and a maximum bit depth of 24 bits. 

Full details on setting up your audio interface hardware, including information on 
optimizations, drivers, and more can be found in “Configuring Your Audio Hardware” on 
page 96, and the topic areas that follow this section.
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MIDI Interface
Your Macintosh computer does not provide MIDI in or outputs. If you want to use MIDI 
devices equipped with MIDI ports, a MIDI interface is required for communication with 
your computer. MIDI interfaces are generally connected to your Macintosh USB ports. 
Some MIDI interfaces require the installation of driver software, and others are 
automatically recognized by your Macintosh.

Note:  Many modern MIDI devices, particularly keyboards, include a USB or FireWire 
connection port that enables MIDI (and audio, in some cases) communication with 
your computer. Such devices do not require an additional MIDI (or audio) interface. 
Some require the installation of driver software, and others are automatically 
recognized by Mac OS X. Check the websites of MIDI device manufacturers for further 
information.

Types of MIDI Devices
A vast array of MIDI equipped devices exist. These include MIDI keyboards and sound 
modules, control surfaces, effect processors, mixers, lighting controllers, and more.

MIDI Keyboard
The most likely candidate for inclusion in your Logic Pro system will be a MIDI 
keyboard. MIDI keyboards are used to input note (and controller) information into 
Logic Pro. Some MIDI keyboards are simply input devices (often called controller 
keyboards) and some also include their own synthesis engines (synthesizer and 
sampling keyboards). Logic Pro can be used to record keyboard performances as MIDI 
data, and can play them back through any connected MIDI device or internal software 
instrument.

If you don’t have a MIDI keyboard handy, don’t fret! Logic Pro offers the Caps Lock 
Keyboard, which allows you to use the computer keyboard for MIDI note entry. See 
“Using the Caps Lock Keyboard” on page 389.

Control Surfaces
Control surfaces are hardware devices that feature a variety of controls, which can 
include faders, rotary knobs, switches, and displays. These controls can be mapped to 
functions in Logic Pro, allowing you to change parameters with more precision and 
speed than by using your mouse and computer keyboard. You can also control multiple 
parameters at the same time. Detailed information on the setup and use of control 
surfaces can be found in the Control Surfaces Support manual.
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Synthesizers and MIDI Controlled Effects
Logic Pro provides plenty of software instruments and effects, and can also act as a 
host for Audio Unit plug-ins from other manufacturers. More information on the use of 
plug-in instruments and effects can be found in Chapter 10, “Working With Instruments 
and Effects,” on page 207.

You can also incorporate hardware MIDI instruments and MIDI controlled effects units 
to your Logic Pro music production system. These are connected via a MIDI interface, 
using MIDI cables (see “Connecting Your Audio and MIDI Devices” on page 88). 

MIDI controlled effects units do not process MIDI data. Rather, they are audio 
processors (such as reverb or multi-effect devices) that can be controlled via MIDI 
messages. This allows you to automate the parameters of these devices—such as delay 
time or flanger speed—from Logic Pro.

Typically, you would connect all external devices, such as synthesizers and MIDI 
controlled effects units to either your audio interface or a hardware mixing console. 
MIDI controlled effects units would be connected in a send/return loop, using either:
Â A pair of audio ins and outs (or auxiliary in/out, if available) on your audio interface
Â An auxilliary in/out (sometimes called FX send/return) pair on your mixing console

Both methods allow the use of Logic Pro’s In/Out plug-in, enabling you to freely route 
audio information through the external effects unit—and the MIDI connection 
provides control over the effects parameters. In many ways, this is much like using one 
of Logic Pro’s internal effect plug-ins.

Note:  It is only practical to use the In/Out plug-in for external device routing when 
you’re using an audio interface equipped with multiple in and out ports.

Both MIDI instruments and effects will allow remote patch (preset) selection from 
Logic Pro. This (and control) information can be stored as part of Logic Pro project files, 
ensuring perfect playback from your MIDI devices the next time the project is loaded.

Ancillary Audio Devices
No discussion of a Logic Pro audio system would be complete without covering a 
number of options that you should seriously consider, in order to make the most of the 
application.

Audio Playback System
Your audio interface provides inputs and outputs between the real world and your 
computer. When performing audio playback, the audio interface translates computer 
data into something you can hear and understand—sound and music.

To facilitate this, an amplifier and speakers are required. You can certainly use 
headphones, connected to the headphone jack of your audio interface, or the home hi-
fi to monitor Logic Pro playback, but this is not recommended in the long term.
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You should look at a dedicated set of reference monitors (speakers), and a matching 
reference amplifier. Many monitoring systems today have powered speakers, negating 
the need for a separate amplifier.

Note:  Reference monitors are specially designed speakers that offer a flat frequency 
response across a wide range (usually 20 Hz to 20 kHz). These are not your average 
home hi-fi speakers, and are usually only available from professional music and studio 
equipment dealers.

This type of system is recommended due to the precision it offers. Logic Pro is capable 
of delivering CD or higher quality audio, and creating your mixes on a home hi-fi will 
generally result in music that is not properly balanced. 

Put another way, most home hi-fi speakers tend to enhance particular areas of the 
frequency spectrum, resulting in mixes that have too much bass, mid, or treble 
frequency when played back on other systems. Reference monitors and amplifiers are 
designed to provide a flat frequency response, avoiding emphasis of particular areas of 
your mix. This translates to a final product that will sound good (or at least, passable) 
on most monitoring systems—car stereos, home hi-fi, portable players, and so on.

Headphones
A good set of studio headphones is handy for particular tasks, such as precise EQ-ing 
and sample editing. Given the design of most headphones, and the fact that they’re 
used so close to the ears, most people find that headphone mixes tend to be too 
bright or too bass-heavy. 

As such, they are not recommended for general monitoring duties, but they are useful 
tools nonetheless. If you are recording groups of people, you will probably need several 
pairs of headphones, a headphone distribution amplifier, and a mixing console.

∏ Tip:  You should not use headphones for longer than ten or twenty minutes at a time, 
as they can cause listening fatigue, resulting in you making poor choices for your mix.

Audio Mixing Consoles
The inclusion of an audio mixer—analog or digital—is heavily based on your typical 
studio use. It is also dependent on the number of inputs and outputs provided by your 
audio interface and your working preferences. 

To explain, if you are most likely to record bands, several MIDI synthesizers, or drum kits 
in your studio, you will need numerous microphone and line-level inputs to 
simultaneously record the performances of the musicians and vocalists in the group.

Microphone inputs differ from line level inputs in that they provide power (known as 
phantom power), which is used to amplify the incoming signal from condenser 
microphones.
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Multiple mixer outputs and a headphone distribution amplifier are also beneficial in 
group recording situations, as different signals can be sent to each performer. As 
examples:  a click track to the drummer, a light drum mix and click track to the bass 
player, a composite mix to the vocalist and guitarist, with a touch of reverb for the 
singer, and so on. This different strokes approach is commonly used as it facilitates the 
best performances from each group member.

Mixers can also include several auxilliary or bus channels that can be used to simplify a 
number of jobs. As examples, sending different signals (or mixes, if you like) to multiple 
locations—such as a front of house P.A. and a multitrack recorder, adding individual 
effects to multiple channels, re-routing processed audio back to a different position in 
the signal path and much more.

Many of these mixing tasks can be performed with a multi input/output audio 
interface—using Logic Pro (and the interface control software, if applicable) to adjust 
levels and routings. The catch-22 with this is twofold:  it is not as immediate as 
physically moving a slider or knob on a mixing console, and your computer generally 
needs to be turned on, to allow control. To balance the equation, you can add a control 
surface to your Logic Pro system, enabling hands-on operation. On the latter point, a 
number of current audio interfaces can be used in standalone mode, but the problem 
of level control remains unless the computer is turned on. 

Microphones
If you are recording acoustic performances—spoken, sung, or played—into Logic Pro, 
you need one or more microphones. The array of microphones available these days is 
mind-boggling, but to simplify things, they basically fall into two categories:  
condenser and dynamic. 
Â In general terms, condenser microphones are more sensitive, and are commonly 

used for vocal recording. They are also used for ambience recording, and for 
instruments such as guitars and woodwinds. 

Â Dynamic microphones are often used for recordings with high sound pressure levels 
(loud signals, in other words), such as drums and percussion.

Ultimately, either microphone type can be used for any recording job, but each will 
offer a distinct advantage—sonically—in different recording situations. To further 
clarify, both condenser and dynamic microphones come in a variety of forms, with 
many specifically designed for the recording of certain instruments. As such, there’s no 
one size fits all microphone for every recording you will make, so purchasing or hiring 
several microphones for different projects is advisable.

Note:  Condenser microphones require power to function. This can be provided by a 
separate pre-amplifier or a phantom powered mixing console.
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Connecting Your Audio and MIDI Devices
You need to connect your external audio and MIDI devices to your computer to allow 
communication between Logic Pro and the devices. The following section introduces 
you to Macintosh expansion capabilities, audio and MIDI cabling, and other things you 
should consider when connecting audio and MIDI interfaces to your system. 

Computer Expansions
Current Macintosh computers offer the following expansion capabilities, which can be 
used for audio and MIDI interfaces:
Â FireWire
Â USB
Â PCI
Â ExpressCard

Note:  Data transfer rates discussed in the following sections are theoretical maximums. 
In real-world use, this will be reduced due to system overheads. In general, protocols 
with faster theoretical maximums will deliver data more quickly than slower protocols.

FireWire (IEEE 1394)
FireWire is a professional and consumer standard that can be used for both audio and 
MIDI devices, plus hard disks and other peripherals. It combines fast data-transfer rates, 
high storage capacities, and plug-and-play connection. All current Macintosh 
computers offer FireWire connectors, and a number of FireWire audio and MIDI 
interfaces are available. FireWire 1.0 transfers data at 400 MBits per second. FireWire 2.0 
transfers data at 800 MBits per second.

There are two kinds of FireWire connectors:  a 4-pin connector (typically found on 
video equipment, such as camcorders) and a 6-pin connector (used for computer and 
audio equipment). 

USB (Universal Serial Bus) 
USB is a consumer standard used for computer peripherals and other devices. USB 1.1 
offers a much lower data-transfer rate than FireWire (11 Mbits per second). USB 2.0, 
however, transfers data at 480 MBits per second. It supports plug-and-play operation 
and the ability to connect several devices in sequence (daisy-chaining). Some USB 
devices draw their power over the USB cable, while others require a separate power 
connection. USB 2.0 ports are included on all current Macintosh computers. 

FireWire 400 (6-pin)
(Sometimes labeled iLINK)

FireWire 400 (4-pin)
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There are two kinds of USB connectors:
Â A connector, typically used to connect a device to a USB hub.
Â B connector, typically used to connect devices together, and also to connect a device 

to a computer. 

Note:  USB audio interfaces should always be directly connected to your computer, not 
via a hub or to the computer’s display, keyboard, or another peripheral.

PCI
PCI (Peripheral Component Interconnect) interfaces, unlike FireWire and USB interfaces, 
require that you install a dedicated card in your computer. PCI provides extremely high 
bandwidth and fast data-transfer rates, allowing you to record and play back large 
numbers of files at the highest possible sample rates and bit depths. 

ExpressCard
ExpressCard is an updated version of PC Card (PCMCIA) or CardBus, found on MacBook 
Pro computers. ExpressCard is much like the PCI interfaces described above, but the 
cards slide into a slot on the outside of your notebook. Express Cards and PC Cards 
available include audio interfaces, hard disks, networking, and SCSI interfaces, wireless 
adapters, and more.

Audio Cabling
The following types of audio cables and connectors are usually used on professional 
and consumer audio equipment:
Â XLR
Â 1/4-Inch audio and 1/8-Inch miniplug
Â RCA (Cinch)
Â Toslink
Â AES-EBU, S/PDIF, ADAT

XLR
XLR cables and connectors are used on professional-quality microphones, monitors, 
and other musical equipment. They provide a high-quality, balanced signal at +4 dB 
level.

USB (Universal Serial Bus)

XLR connector (balanced)  
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1/4-Inch Audio
1/4-inch connectors (sometimes called phono or phone plugs) are used on a wide 
variety of professional and consumer musical equipment, including musical 
instruments and amplifiers, speakers, and external effects devices. They can be either 
balanced or unbalanced. Some devices require Tip-Ring-Sleeve (TRS) connectors. These 
three-contact connectors are used for balanced mono signals and unbalanced stereo 
signals.

1/8-Inch Miniplug
Miniplug connectors are used for audio input and output to computers, and on some 
consumer electronic devices, particularly portable ones. 

RCA (Cinch)
RCA connectors are used on consumer audio equipment such as home stereo systems 
and videocassette recorders. 

AES/EBU, S/PDIF, and ADAT
The AES/EBU, S/PDIF, and ADAT protocols provide a digital connection between 
professional and consumer audio equipment, including audio interfaces, DAT (digital 
audio tape) machines, mixing consoles, hardware samplers, and more. 

S/PDIF and AES/EBU provide two channels of audio, and ADAT optical provides eight 
channels of audio. You can use optical TOSLINK connectors to carry digital audio 
streams between S/PDIF and ADAT components. 

1/4-inch Tip-Ring Sleeve (TRS) connector 

1/4-inch Tip-Sleeve (TS) connector

Stereo miniplug connector (unbalanced)

RCA connector (unbalanced)

Toslink optical digital connector
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Connecting Your Audio Interface
Logic Pro supports plug and play for audio interfaces, making it possible to connect 
and switch on a new audio interface while Logic Pro is running. An alert appears when 
you connect a new device, and will prompt you to select and confirm the audio 
interface and driver that you would like to use. 

All digital audio interfaces can be susceptible to latency—a noticeable delay between 
the time the audio signal is produced, and when you hear it. You should always attach 
your audio interface directly to the computer, rather than through a hub, or daisy-
chaining it through another device. Doing so can cause an unacceptable amount of 
latency, particularly with slower USB 1.1 devices.

MIDI Cabling
MIDI is an abbreviation for Musical Instrument Digital Interface—a universal 5-pin 
connection standard and computer language—that allows communication between 
MIDI devices.

Connecting Your MIDI Keyboard and Modules
If using a simple MIDI master keyboard, without internal tone generation facilities, you 
only need to connect the MIDI Out port of the keyboard to a MIDI In port on your MIDI 
interface—using a MIDI cable. 

MIDI Connector 

Computer
MIDI interface

Out port 

Keyboard

In port 
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If the keyboard can generate its own sounds, you should also connect the MIDI Out 
port of the MIDI interface to the keyboard MIDI In port. If your MIDI interface offers 
more than one MIDI output, connect any other tone generators (or other MIDI devices, 
such as control surfaces that require bi-directional MIDI communication) to these.

If the MIDI interface connected to your computer only offers one MIDI output, you 
need to connect the MIDI In of the second tone generator to the keyboard MIDI Thru 
port. A third device can be connected to the MIDI Thru of the second unit, and so on.

The MIDI Thru port replicates the signals coming into the MIDI In port of the device. It 
is preferable to use a direct connection from the computer MIDI Out to a device, rather 
than chaining too many units, one after the other. Doing so can cause timing problems 
in the chain, if numerous MIDI commands are sent quickly. This is due to the slight 
delays introduced by each MIDI In to MIDI Thru transaction. As such, a multi input/
output MIDI interface is recommended in studios with several MIDI tone generators 
and controllers.

Computer
MIDI interface Tone generator

Out port 

Out port 

Keyboard

In port 

In port 

In port 

Computer
MIDI interface

Out port 

Out port 

Keyboard

In port 

In port 

In port 

In port 

MIDI Thru port 

Tone generator 2

Tone generator 3
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Using Multi-Channel MIDI Devices
Most modern MIDI tone generators can simultaneously receive MIDI data on multiple 
MIDI channels (multi-timbral MIDI devices). Each MIDI channel can be assigned a tone/
sound, such as piano, strings, bass, and so on. 

To take full advantage of the capabilities of each connected multi-timbral device, you 
need to use separate MIDI Out ports (from the computer MIDI interface to the MIDI In 
ports) for each device. To explain further, imagine a scenario where:
Â There are four MIDI tone generators that are capable of receiving data on multiple 

channels.
Â All devices can receive on all 16 MIDI channels
Â There is only one MIDI Out from the computer, and all devices are daisy-chained via 

MIDI Thru to MIDI In connections

Logic Pro is capable of channelizing MIDI data (routing it to MIDI channels 1 to 16) and 
is also capable of sending this channelized data to specific MIDI Out ports. 
Unfortunately, in the scenario above, there is only one MIDI Out port available. 

As such, all data sent on MIDI channel 1 will be sent to all four of the daisy-chained 
MIDI tone generators. Each MIDI tone generator will play the incoming data with the 
sound assigned to channel 1, which may be:
Â Bagpipes on module 1
Â A drumkit on module 2
Â A helicopter effect on module 3 and so on

While this would be colorful, it would hardly be musical, unless your tastes lean 
towards the avante-garde. The same applies to the other 15 MIDI channels.

MIDI, as you can see from the example, can be separated onto 16 different channels, 
but it can’t be separated between devices, unless a multi output MIDI interface is used.

Using the scenario above, but substituting a single output MIDI interface with a 4 
output MIDI interface—connected from MIDI Out ports A, B, C, and D—to the 
respective MIDI In ports of each device. There are no MIDI Thru connections, which 
allows Logic Pro to assign and send:
Â A recording/performance on MIDI channel 1 to port A/module 1. 
Â A separate recording/performance—also on MIDI channel 1—can be sent to port B/

module 2.
Â A further recording/performance on MIDI channel 1 to port C/module 3, and so on 

with subsequent channels and modules.

In effect, having a multi output MIDI interface is somewhat like having more MIDI 
channels. In this scenario, it would be like having 64 independent MIDI channels—with 
16 channels per port (A, B, C, and D).
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Not only does this allow you to play up to 64 different sounds simultaneously through 
your tone generators, it also allows full MIDI control for each channel of each device. 
This becomes increasingly important when arranging and orchestrating such a large 
number of instrument parts.

If your computer offers several MIDI inputs, you can connect the MIDI outputs of other 
MIDI expanders and controllers to it.

USB MIDI Keyboards
If using a MIDI keyboard fitted with a USB connector, you don’t require a separate MIDI 
interface, as it is already built into the keyboard. Just be sure to install the driver, if 
needed, and connect the keyboard to your computer with a USB cable. Some modern 
USB keyboards and controllers are automatically recognized by Mac OS X. 

Separating a MIDI Keyboard From Its Sound Generator
If your MIDI keyboard has an internal sound source, it is important that you stop the 
keyboard from generating sounds directly from its own keyboard. 

To explain:  If you buy a new keyboard that is to be used without a sequencer, and 
connect it to an amplifier, you would expect the device to make a sound when you 
press its keys—in other words, the keyboard is directly connected to the sound 
generator.

When using the MIDI keyboard with Logic Pro, however, this is not desirable. In this 
situation, the keyboard is used as a computer input device, and Logic Pro will pass the 
incoming performance information back to the keyboard’s sound generator (or to an 
internal software instrument or another connected sound module, if you wish). 

If the direct connection between the keyboard and its tone generator isn’t cut, this will 
result in a doubling of each note—one played directly from the keyboard to the 
internal tone generator, and another sent through Logic Pro back to the tone 
generator. 

Not only does this cause a phased sound, but it also halves the polyphony of the 
keyboard’s tone generator. In situations where you want to control or record another 
sound module or software instrument with your keyboard, you would hear both the 
keyboard sound (due to the direct keyboard to tone generator connection) and the 
sound of the software or MIDI instrument. This is why the keyboard must be separated 
from its own internal sound generator.

This function is known as Local Off, and is set directly on your keyboard. Don’t worry 
about losing the ability to use the tone generator of your keyboard. Logic Pro will still 
be able to communicate with your keyboard tone generator just like any other 
connected, keyboardless, sound module or software instrument.
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Note:  If you cannot find the Local Off function in the MIDI menu of your keyboard, 
consult its manual on sequencer use. Some keyboards allow you to select from:  Local, 
MIDI, or Both for each of their Parts (individual MIDI channels/sounds in multi-timbral 
MIDI devices). The MIDI setting, if applicable to your keyboard, is the equivalent of Local 
Off.

Using External MIDI Devices
Logic Pro recognizes all MIDI devices set up in the Audio MIDI Setup (AMS) utility, the 
integrated audio and MIDI configuration tool of Mac OS X. You can find the AMS utility 
in the Applications/Utilities folder. For more information on use, see the AMS Help. 

The Library tab displays all MIDI devices found by the AMS utility (separated into MIDI 
channels, if multi-channel devices) when an External MIDI track is selected. You can 
simply select the desired MIDI device/sub-channel to assign it to the track. 

You can configure external MIDI devices in the Inspector. For more information, see 
“Standard Instruments” on page 880, “Multi Instruments” on page 883, and “Mapped 
Instruments” on page 888. 

Using External Audio Effects
If you want to send audio to an external (MIDI controlled) audio effect device, you need 
to insert the In/Out plug-in into one of the Insert slots of the audio channel you want 
to process. For further information, see “Working With External Audio Effects” on 
page 251. 

Note:  It is only practical to use the In/Out plug-in for external device routing when you 
have an audio interface equipped with multiple in and out ports.
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Configuring Your Audio Hardware
To use particular audio interfaces with Logic Pro, the driver for the device needs to be 
installed, activated, and configured correctly. Drivers are software programs that enable 
various pieces of hardware and software to be used with Mac OS X. This allows the 
device to be recognized by applications, such as Logic Pro, and enables data routing 
between software and hardware, in a format understood by both.

Selecting, activating, and configuring a particular audio driver in Logic Pro is achieved 
in the Audio Devices preferences.

To open the Audio Devices preferences, do one of the following:
m Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key 

command), then click the Devices tab.

m Click the Preferences Toolbar button, choose Audio from the pop-up menu, then click 
the Devices tab. 

The Devices tab offers three different tabs:  Core Audio, DAE, and Direct TDM.

In Mac OS X, all audio devices (with the exception of DAE and Direct TDM devices) are 
accessed via Core Audio, an integral part of the operating system. Core Audio is a high-
performance, low-latency audio system that allows audio interface hardware to be 
used by several applications at the same time. 

Logic Pro is compatible with all audio hardware that offers a Core Audio driver. 

Logic Pro also supports DAE (Digidesign Audio Engine) and Direct TDM. These drivers 
are used for the operation of Digidesign HD system hardware, and allow Logic Pro to 
access the on-board DSP chips of these devices.
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All information about the DAE and Direct TDM panes can be found in the 
Logic Pro 8 TDM Guide. 

Setting Up Core Audio Devices
Logic Pro automatically recognizes any installed Core Audio hardware, and will use the 
default settings—as defined in the Audio MIDI Setup utility (Applications/Utilities/
Audio MIDI Setup). It can, however, be advantageous to optimize the settings for your 
individual hardware setup, particularly if you use several audio interfaces or a multiple 
input/output device. This is done in the Logic Pro > Preferences > Audio > Core Audio 
tab. 

Enabled
Click this box to enable the Core Audio driver. 

Note:  In situations where the preferred hardware is unavailable, such as when your 
audio interface is not connected (or is turned off ), Logic Pro will automatically select 
the built-in audio hardware of your Macintosh.

System Memory Requirement 
The amount of free RAM required (outside the memory assigned to Logic Pro) is 
indicated here. The requirement value changes as you alter the parameters described 
below. 

Device
Allows you to choose between any installed Core Audio device, including the internal 
sound hardware. This also includes aggregate audio devices, consisting of several audio 
interfaces. See the Audio MIDI Setup Help for information on aggregate devices.

I/O Buffer Size
This parameter determines the size of the buffer used by the audio hardware—for both 
input and output. The smaller the buffer size, the less latency you will encounter when 
monitoring while recording, or using software instruments. 

Some points to note:
Â As this parameter value is reduced, it places a higher strain on the CPU(s) of the 

system.
Â There may be a point where the selected I/O Buffer Size is too small for your system, 

and begins to affect playback. This usually takes the form of clicks, pops, and crackles 
in your audio. 

Â You should, therefore, aim for the lowest possible I/O Buffer Size value that doesn’t 
introduce these types of artefacts. 

∏ Tip:  If you find a higher I/O Buffer Size setting provides suitably low latency during 
record monitoring and software instrument playback, you should use it. This will 
minimize the impact on the CPU(s) of your system.
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Recording Delay
This parameter allows you to delay the recording of audio by a certain fixed value, 
helping you to compensate for any information delays that are caused by the audio 
driver. 

Note:  You should not normally need to touch this parameter.

Universal Track Mode
Universal Track Mode is switched on by default. It allows you to play back stereo and 
mono regions on a single track. It should be left on.

You should only turn off Universal Track Mode if using DAE or TDM hardware. For more 
information, see the Logic Pro 8 TDM Guide.

24 Bit Recording
When this setting is turned on, Logic Pro can record 24 bit files. 20 or 24 bit recordings 
offer a significant improvement in the available dynamic range, but require high quality 
peripheral components such as microphones and pre-amps, not to mention high 
quality analog to digital/digital to analog converters. 

20 and 24 bit files use one and a half times the disk space of comparable 16 bit files.

Note:  Turning on this parameter only makes sense if you are actually using a 20 or 24 
bit interface.

Software Monitoring
This option allows you to switch Software Monitoring (listening to the actual input 
signal) on or off. In most situations, you should leave it on.

Note:  When Software Monitoring is active, the audio signal is processed via software—
and a certain amount of audible delay (commonly referred to as latency) is inevitable. 

If you are listening to the recorded signal through your mixing console, or your audio 
interface supports hardware monitoring, you should switch this option off.

Independent Monitoring Level for Record Enabled Channel Strips
Turn on this checkbox to enable the use of an independent monitoring level for record 
enabled audio channel strips. After record-enabling a track, you can adjust the fader to 
the desired level. The original level will be restored when you turn off the record-
enable button.

Note:  Adjustments to the fader do not affect the recording level, they only affect the 
monitoring level.

Process Buffer Range
This parameter determines the size of the buffer used to compute mixes and effects. 
You can choose between Small, Medium, and Large buffer sizes. 
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Note:  Larger buffer sizes increase latency. Dependent on CPU speed, buffer sizes that 
are too small might compromise real time audio processing.

ReWire Behavior
Use this menu to configure the ReWire behavior when sending MIDI data to a ReWire 
compatible software instrument:
Â Playback mode:  Use when playing back MIDI tracks via ReWire. This setting requires 

less CPU power.
Â Live mode:  Use when playing a ReWire instrument live. This setting uses more CPU 

resources, but has lower latency.

Maximum Scrub Speed 
This pop-up menu allows you to set the maximum scrubbing speed. You can choose 
between the following options:
Â Normal:  The normal playback speed is used for scrubbing.
Â Double:  The scrubbing playback speed is twice as fast. 

Scrub Response 
This menu determines the reaction time for audio scrubbing. Choose the value that 
works best for your system configuration. Options are:  Slow, Normal, Fast, Faster.

DAE and TDM 
All information on using the DAE (Digidesign Audio Engine) and TDM hardware with 
Logic Pro can be found in the Logic Pro 8 TDM Guide.

Using Distributed Audio Processing
Distributed audio processing allows you to expand the processing capacity of your 
Logic Pro system. It does this by offloading calculations for software instruments or 
effects to additional Macintosh Node computers, connected via Gigabit Ethernet. This is 
perfect when using numerous instances of CPU-intensive software synthesizers or 
effects, such as Sculpture or Space Designer.

Additional Macintosh computers do not require further copies of Logic Pro, nor any 
MIDI or audio hardware.

You can find the Logic Pro Node Installer on the Logic Pro Installation DVD—simply run 
it, and set the system volume of your Node machine as the destination. The Logic Pro 
Node application has no parameters or GUI elements. It simply needs to be running on 
the Node machine before you start Logic Pro.
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∏ Tip:  If you plan to use a Macintosh solely as a Node machine, you may wish to place 
the Logic Pro Node application in the Startup Items folder. You may also consider the 
use of Apple Remote Desktop to control additional Macintosh computers from your 
primary system. In this scenario, your Node machines don’t need their own monitors or 
keyboards.

Considerations for Distributed Audio Processing
Distributed audio processing actually uses the built-in networking capabilities of 
Mac OS X. You will need to set up an Ethernet network connection between all 
computers, via the Network pane of the System Preferences. Please consult the Online 
Help for details on setting up a network.

Networking Considerations
The primary (host) computer will be a single or dual processor G4, G5, or Intel-based 
Macintosh, equipped with a 1 Gigabit Ethernet port. Ideally, node machines need one 
or more G5 or Intel processors (a 1 Gigabit Ethernet port is standard on all G5 and Intel 
Macintosh computers). 

If you want to run multiple nodes, a 1 Gigabit Ethernet switch is required.

It is recommended that you only use the network for distributed audio processing 
when Nodes are active—other activities will affect performance!

Note:  You must disable the software firewall. Should you wish to access the Internet via 
your network, use of a router with a hardware firewall (or separate computer with a 
firewall), is recommended. 

Plug-in Considerations
Some Audio Unit effects may not support the Node functionality of Logic Pro. You can 
disable the Node processing for incompatible Audio Unit effects in the AU Manager 
application.

A number of Node-compatible third-party Audio Unit effect plug-ins may open a 
dialog on the Node machine. You will not see this dialog box on the host machine 
(unless Remote desktop is in use). The open dialog will lead to timing errors, and the 
connection to the Node will be disrupted.

Important:  You can only process a plug-in on Node machines when all Nodes have an 
identical version of this plug-in installed.
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Enabling Distributed Audio Processing
The following presumes that you have correctly installed the Logic Pro Node 
application (and have an identical plug-in set) on all Node machines, and that it is 
running.

To set up, and activate, nodes in Logic Pro:
1 Open the Nodes preferences by doing one of the following:

Â Choose Preferences > Audio (or use the Open Audio Preferences key command), 
then click the Nodes tab.

Â Click the Preferences Toolbar button, choose Audio from the pop-up menu, then click 
the Nodes tab. 

2 Click the Enable Logic Nodes checkbox, and select the desired computers in the list 
below:

Â Checked, active (non grayed-out) Nodes are used by the host (Logic Pro system).
Â Grayed-out (inactive) Nodes are due to one of the following; 

Â The machine is not connected to the network.
Â The machine does not have the Logic Pro Node application running.
Â The machine is in use by other hosts. They can remain checked for future use 

(when Logic Pro is next opened).
Â Unchecked Nodes are not used by the host—they are, however, available to other 

hosts.
Â The list retains a history of previously connected Nodes. You can remove Nodes by 

clicking the Remove button. This is useful if you’ve renamed a Node machine, or if 
you’re sure that a Node machine will never be used again.

3 In the Arrange area, configure the track header to display the Track Node buttons:

a Open the Track Configuration window by choosing View > Configure Track Header. 
You can also Control-click (or right-click) any track header in the track list. 

b Enable the Track Node button’s checkbox. 
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The Track Node buttons have four possible status indicators:

Â Disabled:  The track is calculated on the local host (in Logic Pro, as per usual).
Â Enabled/Inactive:  This track can potentially be calculated on the Node.
Â Enabled/Active (glowing):  The track is actually being calculated on the Node.
Â Sync Pending:  Data synchronization between the host and Node has not yet been 

established (if the Node is not running, for example). 

4 Click on the desired Track Node button in the track list, to offload that track’s 
processing duties to a Node.

∏ Tip:  You can use track button slide activation to enable distributed audio processing 
on multiple tracks (see “Using Track Button Slide Activation” on page 206).

5 Click on an active Track Node button to disable distributed audio processing for the 
track.

Important Information on Using Nodes
Logic Pro will automatically determine if enabled tracks are actually calculated on a 
Node (and which Node, if multiple Node machines are available), or on the host 
computer. This is dependent on system resources and network traffic. 

The distribution of tasks to Nodes is based on an estimate of the processing resources a 
certain stream will cost the host CPU. While the CPU load of audio effects is relatively 
constant, the performance of software instruments may vary greatly, depending on the 
chosen setting, and on the number of simultaneously played voices.

Compensation of latencies caused by the network and processing occurs on playback 
tracks—audio or software instrument, resulting in perfect timing—but this is obviously 
not possible for live performance tracks.

Disabled

Enabled/Inactive

Enabled/Active

Sync Pending
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What Can’t Be Processed on a Node
The Node buttons are available for all audio and software instrument tracks. There are, 
however, some exceptions:
Â EXS instruments:  These are always calculated on the host. The reason for this is the 

potentially demanding transfer of samples via the network, resulting in a slowdown 
of audio processing over the network. The sample library needs to be present on the 
host computer itself. 

Â Multi output instruments such as Ultrabeat:  Further to this, Ultrabeat also has a similar 
problem to the EXS24 with sample-based kits. 

Â Audio Unit software instruments:  When an Audio Unit software instrument track is 
selected, the Node button is automatically turned off. 

The Logic Pro Node application can process Audio Unit effects.

It is possible, however, that some Audio Unit effects may not support the Node 
functionality of Logic Pro. You can disable the Node processing for incompatible Audio 
Unit effects in the Audio Units Manager. 

It is not possible to calculate input, output, bus, or aux channels on a Node.
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5 Navigating Your Project

In this chapter, you will learn how to play, repeat, and move 
to different parts of your projects.

Logic Pro offers a number of methods to control playback and navigate to different 
sections of your project. 

You can use the Transport bar, key commands, the Bar ruler, and can also take 
advantage of markers to tag sections of your project, and quickly move between them. 
The playhead indicates the current playback position. 

This chapter concentrates on the use of the Transport bar and Bar ruler for navigation. 
Information on the use of markers can be found in Chapter 6, “Working With Markers,” 
on page 123.

Setting the Playhead Position
The playhead is a vertical line which indicates the current position in all horizontal, 
time-based windows. 

Playhead

Right locatorLeft locator
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To place the playhead in the Bar ruler:
m Click the desired position in the lower third of the Bar ruler.

Double-clicking on the bottom third of the Bar ruler repositions the playhead, and also 
toggles between playback (or record) and stop modes.

The top of the Bar ruler contains two locators which are shown as a semi-transparent 
gray stripe when inactive, and a green stripe when Cycle mode is active. The start point 
of the stripe is determined by the left locator position, and the end point, by the right 
locator position. You’ll learn more about the use of locators for playback and recording 
duties in this, and following, chapters.

Setting the Playhead With the Position Display
The Transport bar’s Position display shows the current playhead position in two 
formats:

Â SMPTE Time:  The upper row displays the playhead position in SMPTE time format; 
hours : minutes : seconds : frames / subframes.

Â Musical division of time:  The lower row displays the playhead position in bars, beats, 
division, and ticks.

A beat corresponds to the denominator in the time signature.

The division value is set in the Transport bar, below the time signature. 

A tick is the smallest possible bar sub-division—it is equal to 1/3840th of a note.

To set the playhead position in the Position display, do one of the following:
m Click-hold on any of the numbers in the Position display, and move the mouse up or 

down. 

m Double-click on either display field, and then type in a new position. 

Division value
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The playhead will move to match the display position. 

Adjusting the first number in the Bar display will move the playhead by bars, and by 
hours in the SMPTE display. 

Adjusting the second number will move by beats in the Bar display, and by minutes in 
the SMPTE display, and so on at increasingly small divisions with the other values 
shown in the Position display.

When typing in a full position, using the Bar display, for example, you should type in 
the following manner:
Â 3 Space 3 Space 2 Space 2, Enter key to exit text entry mode.
Â 3.3.2.2, Enter key to exit text entry mode.

If you simply type in 3322, followed by the Enter key, the playhead will be moved to bar 
3322, rather than bar 3, beat 3, division 2, tick 2. This allows you to quickly navigate to 
the beginning of a bar by simply inputting the first digit.

Setting the Playhead at a Marker
If you have labeled a passage with a marker, clicking anywhere on the marker while 
holding down Option, positions the playhead at the start of the marker. If Logic Pro is 
stopped, Command–double-clicking it begins playback at the start of the marker.

Adjusting the Size of the Playhead 
You can adjust the thickness of the playhead in the General Display preferences.

To adjust the playhead display:
1 Open the Display preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key 
command).

Â Click the Preferences Toolbar button, then choose Display from the menu.
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2 Click the General tab, and turn on the Wide Playhead checkbox. 

Using the Transport Buttons
You can use the transport buttons in the Transport bar to control playback, or to set the 
playhead position. You can click the buttons to activate or deactivate functions, or 
better yet, make use of the corresponding key commands (computer keyboard 
shortcuts) to speed up your workflow. 

Note:  The screenshot below shows all transport buttons. The buttons available in the 
Transport bar of your project may differ, as you can customize the Transport bar. For 
further information see “Customizing the Transport Bar” on page 117.

From left to right:
Â Go to Beginning:  Moves the playhead to the beginning of the project. Default key 

command:  Return.
Â Go to Position:  Opens a dialog that allows you to type in the desired playhead 

(target) position numerically. 
Â Go to Left Locator:  Moves the playhead to the left locator position.
Â Go to Right Locator:  Moves the playhead to the right locator position.
Â Go to Selection Start:  Moves the playhead to the start point of the first selected 

region or event in the active window. Default key command:  Shift-Return.
Â Play from Beginning:  Starts playback at the beginning of the project.
Â Play from Left Window Edge:  Plays from the leftmost point of the visible display area 

in the active window. 
Â Play from Left Locator:  Moves the playhead to the left locator position, and begins 

playback.

Default playheadThick playhead
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Â Play from Right Locator:  Moves the playhead to the right locator position, and begins 
playback.

Â Play from Selection:  Moves the playhead to the start point of the selected regions or 
events, and begins playback. Default key command:  Shift-Enter.

Â Rewind and Fast Forward:  A click on either button will move the playhead one bar 
forward or backward. Command-clicking moves the playhead to the next or previous 
marker. Click-holding either button will rewind or fast-forward. Click-holding (on 
either button) and dragging to the left or right will shuttle forward or backwards 
(both buttons allow forward/reverse shuttling when used in this way).

Â Stop:  Stops recording or playback. Clicking the Stop button a second time moves the 
playhead to the project start point, or to the left locator position, if Cycle mode is 
active. Default key command:  0.

Â Play:  Starts playback at the current playhead position, or from the left locator 
position when in Cycle mode. Default key command:  Enter.

Â Pause:  Pauses recording or playback, until you click either the Pause or Play button. 
Â Record:  Click to begin recording (if a track is record-enabled). Default key 

command:  *. Control-click or right-click the button to open the Recording menu. 
Â Capture Recording:  Allows the most recent performance to be kept, even if Logic Pro 

was not in record mode while you were playing.

Note:  All of the transport button key commands listed above—with the exception of 
Rewind and Fast Forward—use the numeric keypad of your computer keyboard.

Using Transport Key Commands
There are a number of transport functions that are only available as key commands. 
Most of the key commands for these functions are not assigned by default, so you will 
need to set up key commands for them. See “Assigning Key Commands to Computer 
Keys” on page 162.
Â Play or Stop:  Switches between playback and stop, depending on the play or stop 

status when the command is used. Default key command:  Space bar.

∏ Tip:  The Space bar can be used to start or stop playback of audio files or regions in the 
Sample Editor, Audio Bin, and Loop Browser, when these windows have key focus. This 
makes it a handy key command to remember!

Â Play from Previous Bar:  Starts playback at the start of the previous bar. 
Â Stop and Go to Left Locator:  Stops playback, and moves the playhead to the left 

locator position.
Â Go to Last Play Position:  Moves the playhead to the last position reached with a 

positioning command, or direct positioning of the playhead, using the mouse or 
ruler.

Â Stop and Go to Last Play Position:  As above, but stops playback. 
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Â Shuttle Rewind and Shuttle Forward:  Repeated key presses will increase the winding 
speed. Repeated hits of the opposing shuttle key will slow down the shuttle speed, 
and eventually change the winding direction. Shuttle disables Cycle mode. Shuttling 
is halted by the Stop command.

Â Go to Selection End:  Moves the playhead to the end of the first selected region or 
event in the active window.

Note:  There are also as a large number of Go To key commands for markers available. 
For further information, see “Navigating With Markers” on page 133.

Using Cycle Mode
You can use Cycle mode to repeatedly play a selected passage. This is useful for:
Â Composing a section of a project (a verse or chorus, for example).
Â Practicing, before making a recording.
Â Recording individual tracks consecutively.
Â Editing events.
Â Recording multiple takes.

The cycle area is defined by the position of the left and right locators. When Cycle 
mode is active, it is shown as a green stripe in the top part of the Bar ruler. 

Left locator Right locator

Cycle area
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To switch Cycle mode on and off, do one of the following:
m Click the Cycle button in the Transport bar (or use the Cycle Mode key command).

m Click on the top part of the Bar ruler (on the gray locators stripe).

How Logic Pro behaves in Cycle mode:
Â The playhead jumps from the end of the cycle to the beginning.
Â The Play command starts playback from the beginning of the cycle.
Â To start playback from another position, hit Pause twice, or Pause and then Play.
Â At the cycle jump point, you can use the Chase Events function—File > Project 

Settings > MIDI > Chase > Chase on Cycle Jump. For more information about chasing 
events, see “Using the Chase Events Function” on page 115.

Â You can determine the way recording works in Cycle mode, by using the various 
options in the File > Project Settings > Recording pane.

Defining the Cycle
There are a number of different ways to define a cycle. You can:
Â Directly draw the cycle in the Bar ruler (effectively setting the left and right locator 

positions).
Â Use the Transport Locator displays.
Â Create a cycle based on selected regions.
Â Create a cycle based on markers.

Defining and Adjusting a Cycle in the Bar Ruler
Click-hold in the top third of the Bar ruler, and define the desired cycle area by 
dragging the mouse from left to right.

The cycle area appears as a green stripe in the Bar ruler, and Cycle mode is 
automatically switched on. 

To move the cycle:
m Grab the green cycle stripe in the middle (the cursor will turn into a hand), and drag it 

to the left or right. 

Two lines extend down the screen from the beginning and end points of the cycle. 
These make it easy to align the cycle with regions in the Arrange area, or events in the 
Piano Roll Editor.
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To resize the cycle:
m Grab the handles (triangles) at either end of the cycle to move the start or end points 

(you can even do this while Logic Pro is running.). 

Note:  You can set either the start or end point of a cycle (whichever is closest) by Shift-
clicking the desired position in the Bar ruler. This works even when the stripe is outside 
the visible range, or Cycle mode is switched off.

When you set the size of a cycle graphically in the Bar ruler, its start and end points 
(and therefore, overall size) is quantized to the setting chosen in the Snap menu. For 
more information, see “Snapping Region Edits to Time Positions” on page 295.

Defining a Cycle With the Transport Locator Displays
You can enter the locator positions—therefore setting the cycle boundaries—
numerically in the Transport bar Locator display. The locators are shown to the right of 
the Position display:  The top value denotes the left locator position, and the bottom 
one, the right locator position.

To define the locator positions in the Transport, do one of the following:
m Double-click on either locator display field, and directly type in a left or right position 

value. 

Type in all bar, beat, sub-beat, and tick values (using space or a period between 
numbers), and press Return to close the entry box and set the locator. 

Note:  You can quickly set the locator to the beginning of a bar by simply inputting the 
first digit.

m Click-hold on any of the left or right locator number fields in the Transport, and move 
the mouse up or down. 

The corresponding cycle boundary (if shown in the Bar ruler) will move to match.

Right locator

Left locator

Position display
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Using the Transport Bar Mode Buttons to Define Locators
You can use the following commands, available as Transport bar buttons, to define the 
locator positions. You can click on the buttons to activate or deactivate functions, or 
better yet, make use of the corresponding key commands (computer keyboard 
shortcuts) to speed up your workflow. 

Note:  The screenshot below shows all relevant buttons. The buttons available in the 
Transport bar of your project may differ, as you can customize the Transport bar. For 
further information see “Customizing the Transport Bar” on page 117.

Â Set Left Locator and Set Right Locator:  These allow you to directly enter either of the 
locator points in a dialog. Also available as key commands. 

Â Set Left Locator by Playhead and Set Right Locator by Playhead:  The current playhead 
position is used to define the left or right locator value.

Â Move Locators Forward by Cycle and Move Locators Backwards by Cycle Length:  Move 
the cycled passage by its own length. Also available as key command.

Using Regions or Events to Define a Cycle
You can use the following key commands to set the locators at the start and end points 
of selected regions or events:
Â Set Locators by Regions/Events:  Sets the locators at the start and end points of the 

selected regions or events. 
Â Set Locators and Play:  Sets the locators at the start and end points of the selected 

regions (or events) and starts playback.
Â Set Rounded Locators by Regions/Events:  Rounds the position of the locators to the 

barline that is nearest to the beginning and end points of the selected regions or 
events.

Â Set Rounded Locators and Play and Set Rounded Locators and Record:  Rounds the 
position of the locators to the barline that is nearest to the beginning and end points 
of the selected regions or events, and starts playback or recording.

Â Set Rounded Locators and Cycle Play and Set Rounded Locators and Cycle 
Record:  Rounds the position of the locators to the barline that is nearest to the 
beginning and end points of the selected regions or events, and switches to cycle 
play or record mode.
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Defining a Cycle With Markers
Dragging a marker into the top part of the Bar ruler creates a cycle with the marker’s 
length. Details on creating and using markers is covered in Chapter 6, “Working With 
Markers,” on page 123.

You can also use one of the following key commands:
Â Set Locators by Marker and Enable Cycle:  Sets the cycle to the currently selected 

marker and activates Cycle mode. The length of the cycle is determined by the 
marker length.

Â Set Locators by Next Marker and Enable Cycle:  Sets the cycle to the next marker and 
activates Cycle mode.

Â Set Locators by Previous Marker and Enable Cycle:  Sets the cycle to the previous 
marker and activates Cycle mode.

Note:  These commands are ideally suited for repeating passages during live 
performances. Define markers for all parts of the project that you might want to repeat 
in this way during your performance.

Skip Cycle
You can skip a passage in play mode, which is useful for trying out the musical effect of 
various transitions, from one song section to another, without needing to physically 
move regions. This is a very handy feature when arranging.

Skip Cycle is also useful when editing, to leave out parts of the project that you don’t 
want to be affected by the edit.

To set up a skip cycle, do one of the following:
m Drag the Skip Cycle area from right to left in the Bar ruler. 
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m If a (normal) Cycle area already exists, you can swap the left and right locator by 
clicking the Swap Left and Right Locators button in the Transport bar (or using the 
Swap Left and Right Locator key command).

The Skip Cycle area is shown as a green candy striped area in the Bar ruler.

When the playhead reaches the right locator position, it skips to the left locator (in 
essence, the right and left locators swap positions).

Using the Chase Events Function
If you start playback in the middle of a project, some events might not be heard (such 
as notes, sustain pedal events, and pitch bend events that start before the point where 
playback begins). Using the Chase Events function, you can have Logic Pro analyze the 
project and include some or all of these events when the project plays back.

To set up the Chase Events function:
1 Open the MIDI project settings by doing one of the following:

Â Choose File > Project Settings > MIDI (or use the corresponding key command).
Â Click the Settings Toolbar button, then choose MIDI.
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2 Click the Chase tab, then turn on the checkboxes of all events the Chase Events 
function should look for before the playback start point. You can choose from:

Â Notes:  Any notes due to start playing at the playback start point.
Â Sustained:  Any notes that are still playing at playback start point—due to a sustain 

pedal event.
Â In “No Transpose” Instrument Channel Strips:  Instrument channel strips (particularly 

drums) can be assigned No Transpose status in the Inspector. This is a playback 
parameter, which would be ignored if the region containing the instrument notes 
was started mid-way through.

Â Program Change:  Any program changes in regions that fall across the playback start 
point will be sent, when this checkbox is turned on.

Â Pitch-bend:  Pitch bend events that immediately precede the playback start point will 
be sent.

Â Control changes 0–15, 64–71, All Other:  Click to search for continuous controllers 0 to 
15, continuous switch controllers 64 to 71, or all other controllers.

Â Aftertouch:  Click to look for monophonic (channel) aftertouch messages.
Â Polyphonic Aftertouch:  Turn on to scan for polyphonic aftertouch messages.
Â System Exclusive:  The most recent SysEx message before the playback start point is 

transmitted.
Â Text Meta Events:  The most recent Text Meta Event message before the playback start 

point is transmitted.
Â Chase separate channels in ‘All Channels’ instruments:  Multi-instruments (found in the 

Environment) have a global channel, and can have up to 16 MIDI sub-channels. Turn 
on this option to scan for events on each MIDI sub-channel, rather than the global 
multi-instrument channel.

Â Chase on Cycle Jump:  Scans for, and sends, all event types if the cycle start and end 
points fall across regions.
Â Notes:  Limits cycle jump scan to note events.

Â Send full MIDI reset before chasing:  Sends a MIDI reset message before chasing, 
ensuring that all MIDI devices being triggered are set to their defaults.

There is a potential problem when chasing notes that are used to trigger a drum loop 
in a sampler. Unless you are lucky enough to start the MIDI region precisely at the 
beginning of the sample loop, the sample will be triggered at the wrong time and will, 
therefore, be played out of sync with other regions (at least until the next trigger note). 

The problem occurs because most samplers can only play samples from the beginning, 
and cannot synchronize them to the beat when started in the middle.
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To avoid triggering a sampler’s drum loops when chasing note events:
1 Activate the No Transpose parameter of your drum loop instrument, in the Track 

Parameter box of the Inspector.

2 Turn off the In ‘No Transpose’ Instrument Channel Strips option in the Project Settings > 
MIDI > Chase tab. 

These settings prevent your sampler’s drum loops from playing until they reach the 
next trigger note, whenever the project jumps to a new position.

The No Transpose parameter actually prevents transposition by the region playback 
parameters, which is also not desirable for drum sounds or loops.

Customizing the Transport Bar
The Transport bar offers a default set of buttons, displays, and sliders. These are the 
most commonly used, and most useful, options for the majority of users.

You, however, may need to regularly access particular functions that are not part of the 
default set, due to:
Â The type of project you are working on; a film soundtrack, for example.
Â A unique working style
Â A desire to have everything at your fingertips

Whatever the motivation, you can easily customize the Transport bar to meet your 
needs.

Hiding and Showing Transport Bar Functions
You can hide or show different parts of the Transport bar independently. This in turn, 
allows you to control the width of the Transport bar.

You should limit the Transport bar to functions you actually need to access regularly, or 
better yet, configure and memorize all of the corresponding transport or mode key 
commands. This will allow you to expand the display area of the Transport bar, 
providing more at-a-glance information.

Note:  If you want all commands and options to be visible in the Transport bar, you will 
need either a second computer monitor, or a single monitor with an exceptionally high 
horizontal resolution.

∏ Tip:  Logic Pro allows an unlimited number of Transport bar windows to be 
simultaneously opened. Additional Transport bar windows can be individually 
customized, allowing you to view and access additional functions that will not fit on 
the standard Transport bar at the bottom of the Arrange window. Customized 
Transport bars (and other windows) can be saved as part of a screenset.
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To customize the Transport bar:
1 Control-click (or right-click) the Transport bar, and choose Customize Transport Bar from 

the menu.

2 Turn on or turn off the desired functions by clicking on the checkboxes in the 
Customize dialog. 

Transport Buttons
This area contains checkboxes for buttons that literally transport the playhead through 
the project. Please see “Using the Transport Buttons” on page 108 (in this chapter) for 
an explanation of the individual functions and commands.

Display Area
This section primarily serves to inform you of the playhead and locator positions, but 
can also be used to navigate through the project. 

Â Positions (SMPTE/Bar):  Indicates the current position of the playhead. The top row 
shows the position in SMPTE format (hours : minutes : seconds : frames), the bottom 
row in bars, beats, divisions, and ticks. 

Â Locators (Left/Right):  The top row indicates the left locator position, the bottom row 
the right locator position. Locators are used to define a particular section of the 
project for a number of recording or playback tasks.
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Â Sample Rate or Punch Locators:  Shows the current project sample rate, or punch 
recording in/out locators (when punch recording mode is enabled). As with other 
Transport bar display fields, you can set the sample rate or punch locators with the 
mouse or via direct numerical entry.

Â Tempo/Project End:  The Tempo display indicates the current playback or recording 
speed. The Project End display shows the total number of bars or time. It behaves as 
stop playback/recording marker for the project.

Â Signature/Division:  The (Time) Signature display indicates the current playback or 
recording time signature in a standard musical format; 4/4, 5/4, and so on. The 
Division display determines the current display (and editing) resolution. A value of 
/16 means that a 4/4 bar is divided into 16 sub-sections, or 4 sub beats for each beat 
in the bar.

Â MIDI Activity (In/Out):  Displays incoming and outgoing MIDI data. The MIDI In display 
(top) will show chord names for incoming MIDI note data.

Â Load Meters (CPU/HD):  Click to show CPU load and hard disk throughput load meters. 
Double-click to open the load meters as a separate window. 

Modes and Functions
The mode buttons and Master Level slider to the right are used for several advanced 
recording and playback functions, including repeating project sections, soloing, and 
punch recording. The buttons do not immediately trigger an action. Rather, they switch 
operating states. The relevant button will illuminate to indicate that the mode is 
activated.

Â Software Monitoring:  Enables software monitoring, allowing you to process external 
sources via Logic Pro effects. It also enables you to hear external sources while 
recording.

Â Auto Input Monitoring:  Automatically allows you to hear external sources at the audio 
inputs.

Â Pre Fader Metering:  Switches all of the mixer channel meters between pre-fader (the 
Level fader on each channel) and post fader modes (when turned off ).

Â Low Latency Mode:  Enables Low Latency mode, allowing you to limit the amount of 
delay (latency) caused by some effects. 

Â Set Left Locator and Set Right Locator:  These allow you to directly enter either of the 
locator points in a dialog. Also available as key commands. 

Â Set Left Locator by Playhead and Set Right Locator by Playhead:  The current playhead 
position is used to define the left or right locator value.

Â Move Locators Forward by Cycle and Move Locators Backwards by Cycle Length:  Move 
the cycled passage by its own length. 
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Â Move Locators Left by Cycle:  Retains the existing cycle, but moves it to the left by the 
cycle length. As an example, if the cycle is 4 bars long, and spans bars 12 to 16, using 
this command will move the cycle four bars to the left, resulting in a cycle from bar 8 
to 12.

Â Move Locators Right by Cycle:  As above, but moves the cycle to the right.
Â Cycle:  Enables or disables repeated playback or recording over a project section. The 

cycle boundaries are reflected (or set) by the left and right locator values.
Â Autopunch:  Enables or disables a recording start and end point. It is commonly used 

in conjunction with the left and right autopunch locators to automatically record 
over a particular project section. This method is often used to fix a mistake in a vocal 
or instrumental recording.

Â Set Left Autopunch Point by Playhead:  The current playhead position is used to define 
the left autopunch locator value.

Â Set Right Autopunch Point by Playhead:  The current playhead position is used to 
define the right autopunch locator value.

Â Replace:  Enables a new recording to overwrite an existing recording.
Â Solo:  Only selected regions are played, all other regions are muted.
Â Sync:  Activate to synchronize Logic Pro with an external source (make Logic Pro the 

synchronization slave to another device). Control-click or click-hold this button to 
open the Synchronization menu.

Â Click:  Used to turn the Logic Pro internal metronome on and off. Control-click or 
click-hold this button to open the Metronome menu.

Â Master Level:  Click to display a volume slider at the right of the Transport bar. This 
slider is directly tied to the Master channel in the Mixer, and acts as a master level 
control for all audio and software instrument tracks.

Using a Giant SMPTE or Bar Display
You can configure the Transport bar to display a giant SMPTE or Bar display in place of 
the standard Transport bar display area.

Alternately, you can spawn a new giant SMPTE or bar display window.

To replace the standard Transport bar display area with a SMPTE or bar display:
m Control-click the display area of the Transport bar, and choose Big Bar Display or Big 

SMPTE Display, as required.

The Transport display area will be replaced with the chosen big display.

Repeat the step above to return to the standard display.
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To open a new SMPTE or bar display window:
m Control-click the display area of the Transport bar, and choose Open Giant Bar Display or 

Open Giant SMPTE Display, as required.

A new, floating, transparent window will open. 

This can be freely positioned and resized. 

To resize the SMPTE or bar display window:
1 Move the cursor over one of the edges, or lower corners.

2 When the cursor changes into a Resize pointer, click-drag into the desired direction.

To close the chosen giant display, click the close icon at the top left of the window.

Note:  Logic Pro allows an unlimited number of Transport (and Giant SMPTE or Bar 
Display) windows to be simultaneously opened.

Customizing the Bar, SMPTE, and Tempo Display
You can customize the Bar, SMPTE, and Tempo display in the Display preferences. 

To customize the Bar, SMPTE, or Tempo display:
1 Open the General Display preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key 
command).

Â Click the Preferences Toolbar button, then choose Display from the menu.
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2 Choose one of the following settings in the Clock Format menu:

Â Clock Format  1  1  1  1
Â Clock Format  1. 1. 1. 1
Â Clock Format  1  1  1  0
Â Clock Format  1. 1. 1. 0
Â Clock Format  1  1. _    1
Â Clock Format  1. 1. _ 1
Â Clock Format  1  1. _ 0
Â Clock Format  1. 1. _ 0

3 Choose one of the following settings in the Display SMPTE menu:

Â With Bits:  Subframes (SMPTE bits 0 to 79) are shown.
Â Without Bits:  Subframes are not shown.
Â With Quarter Frames:  Quarter frames are shown.
Â As Feet Frames, 35 mm film:  The display is displayed in feet and frames, for 35 mm 

film.
Â As Feet Frames, 16 mm film:  The display is displayed in feet and frames, for 16 mm 

film.
Â With Milliseconds:  The frame fractions are displayed in milliseconds instead of SMPTE 

bits (also called subframes). Don’t forget that this value is dependent on the frame 
rate:  at 25 fps, a frame is 40 milliseconds long, at 30 fps, approximately 33 ms.

Â With Samples:  Frame fractions are shown as sample values.
Â With Frames and Samples:  Both fractional frame and sample values are shown.

4 Turn on the Zeros as spaces checkbox if you want zero values to appear as blank 
spaces, rather than the number 0 in SMPTE time displays.

5 Choose one of the following settings in the Display Tempo As menu:

Â Beats Per Minute (BPM, Maelzel):  Beats per minute, to four individually adjustable 
decimal places.

Â BPM without Decimals:  Beats per minute, with no decimal places.
Â Frames Per Click with Eights:  Frames per beat with eighths. After the value, you will 

see fpc.
Â Frames Per Click with Decimals:  Frames per beat, to four decimal places. Take care, this 

display can easily be confused with the bpm display.
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6 Working With Markers

The main purpose of markers is to tag different parts of a 
project, and to enable the quick selection of these parts for 
playback, editing, and arranging. 

Markers serve as a kind of project road map, representing the form of a project 
graphically.

You can see and edit markers in the following window areas:

Marker track

Marker Text area

Marker List 
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Â Marker track:  Displays markers as (optionally) colored sections. If the Marker track is 
hidden, you can see markers as short text strings in the Bar ruler of all linear editing 
windows. The main advantage of the Marker track over the marker display in the Bar 
ruler, is that it allows you to select, copy, move, or resize markers directly with the 
mouse. Click the disclosure triangle in the upper left corner of the Marker track name 
column to expand the track height, thereby displaying additional controls. You can 
freely adjust the lower border of the Marker track by dragging it up or down with the 
mouse.

Â Marker List:  Lists the names of all markers, inclusive of bar position and length 
information. 

Â Marker Text area and Marker Text window:  Show text associated with a marker. This 
makes markers suitable for use as notepads, allowing text comments to be saved 
with the project. Marker text can be typed in, and edited, as you would in any text 
editor. The Cut, Copy, Paste, Clear, and Select All commands can be used to import or 
export text to and from other software applications (such as word processors).

Apart from the text functions, markers can also be regarded as storage areas for locator 
positions—each of which can be individually named.

Opening Marker Areas and Windows
As mentioned in the chapter introduction, there are many ways to interact with, create, 
and delete markers in Logic Pro.

To open the Marker track:
1 Click the disclosure triangle in the Global Tracks header area. 

2 Click the disclosure triangle for the Marker track.

You can also assign, and use, the Toggle Marker Track key command.

To open the Marker List, do one of the following:
m Click the Lists button in the Arrange Toolbar, then click the Marker tab (or use the 

Toggle Marker List key command).

m Choose Options > Marker > Open Marker List (or use the Open Marker List key 
command).

Note:  Double-clicking a marker (with the Pointer tool) in the Marker track toggles the 
List area. The clicked marker is selected in the list.

To open the Marker Text window:
m Option–double-click on any marker in the marker track with the Pointer tool. The 

clicked marker is selected in the list.

Note:  Ensure that you do not (Option–) double-click in the Marker track with the Pencil 
tool selected, or a new marker will be created.
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The Marker Text window is also available at the bottom of the Marker List window. It is 
known as the Marker Text area in the Marker List window.

Using the Marker Shortcut Menu
Many marker selection, editing, and other commands can be accessed by Control-
clicking (or right-clicking) anywhere in the marker areas. Make use of this to accelerate 
your workflow.

Note:  The right-click shortcut menu can only be accessed if the Right Mouse Button: 
Opens Shortcut Menu pop-up menu option is chosen in the Logic Pro > Preferences > 
Global > Editing tab.

Creating Markers
You can create markers at any project position. The following section describes all 
marker creation options. 

To create a marker at the beginning of the nearest bar, do one of the following:
m In the Marker track:

Â Set the playhead to the desired position, then click the Create button.
Â Select the Pencil tool, and click at the desired position. 

m In the Bar ruler:  Place the Pointer over the lower third of the Bar ruler, and Option-
Command-click at the desired project position. This only works if the Marker track isn’t 
displayed.

m In the Marker List:

Â Choose Options > Create.
Â Select the Pencil tool, and click in the Marker List. 
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Â Click the Create button in the Marker List.

m In any window:  Choose Options > Marker > Create from the main menu bar (or use 
the Create Marker key command). 

The marker is created at the beginning of the nearest bar. If a marker already exists at a 
bar position (or up to a quarter note before or after it), no new marker will be created. 

The length of the marker automatically extends to the start point of the next marker, or 
to the end of the project or folder, if no ensuing markers exist. 

∏ Tip:  You can use the Create Marker key commands to add markers on the fly during 
playback. 

To create a marker that is not rounded to the nearest bar:
m In any window:  Choose Options > Marker > Create Without Rounding (or the Create 

Marker Without Rounding key command).

m In the Marker List:  Choose Options > Create Without Rounding.

To create a marker and determine its position:
m Click the beginning or end of the Marker List’s marker area with the Pencil tool, then 

input the desired position in the position input field. 

To create markers at the positions of all currently selected regions:
m In the Marker track:  Click the From Regions button, or drag a region from an Arrange 

track onto the Marker track. 

m Choose Options > Marker > Create by Regions from the main menu bar (or use the 
Create Markers by Regions key command). 
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Markers created in these ways are automatically assigned the names, bar position, 
length and color of the regions they are derived from.

To create a marker that corresponds exactly to the length and position of a cycle:
m Drag the cycle down into the Marker track or into the lower third of the Bar ruler. 

Dragging the cycle in the Bar ruler is limited to either horizontal or vertical movements. 
This ensures that you do not accidentally:
Â Move the cycle when creating markers (by dragging the cycle into the lower third of 

the Bar ruler or into the Marker track).
Â Create markers when moving the cycle area. 

The following explains how marker movements and the cycle interact:
Â When dragging the cycle to the marker area in the Bar ruler, the pointer turns into a 

hand with up/down arrows. As soon as you move the pointer horizontally in the 
marker area of the Bar ruler, the pointer becomes a hand (without arrows). The Copy 
Cycle to Marker action is canceled.

Â If you first move the cycle horizontally, and then try to drag it to the Marker area of 
the Bar ruler, no Marker is created.

Â When you hold Shift, after click-holding on the cycle, the cycle can be moved 
horizontally, and then dragged to the marker area in one go. 

Note:  When you hold Shift, before clicking on the cycle, the nearest cycle border is set 
to the clicked position.

To copy a marker:
m In the Marker track:  Option-drag the marker, or use the standard Copy (Command-C) 

and Paste (Command-V) commands.

m In the Marker List:  Use the standard Copy and Paste commands. 
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Selecting Markers
You can use the usual selection techniques to select markers. For more information, see 
“Selection Techniques” on page 172.

Deleting Markers
You can delete markers at any time. Once deleted, they no longer appear in the Bar 
ruler, Marker track, Marker List, or Marker Text window. 

To delete markers:
m Do one of the following in the Marker track and Marker List:

Â Click the markers with the Eraser tool.
Â Select the markers, then choose Edit > Delete (or use the corresponding key 

command, default:  Backspace).
m In the Bar ruler:  Grab the marker you want to delete, and drag it out of the Bar ruler. 

Release the mouse button when the cursor turns into a hand holding two arrows.

m At the current project position:  Choose Options > Marker > Delete (or use the Delete 
Marker key command). 

Naming Markers
Newly created markers are automatically named “Marker ##” (unless derived from 
regions, as described above). The “##” indicates a numerical value which reflects the 
order of appearance of the markers along the Bar ruler (resulting in “Marker 1”, “Marker 
2”, and so on). The allocated number is dependent on the actual order of all markers in 
the project, including markers that have been renamed.

Automatically assigned names can be changed directly in the Bar ruler, Marker track, 
Marker List, or in the Marker Text window.

The length of the name displayed in the Marker track, Bar rule, and Marker List depends 
on available screen space, or the position of the following marker.
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If you want to edit a marker name when creating it, hold Control-Option-Command 
while clicking on the desired Marker track position:  A text field will open, allowing you 
to type the desired name. Press Return to complete the naming operation. You can also 
Control–Shift–Command–double-click the Bar ruler (if the Marker track isn’t visible). 

To edit a marker name in the Bar ruler:
1 Do one of the following:

Â Choose Options > Marker > Quick Edit Marker (or use the corresponding key 
command).

Â Shift–Control–double-click on the marker. 

2 Type the desired name in the text field. 

To edit a marker name in the Marker track:
1 Do one of the following:

Â Choose Options > Marker > Quick Edit Marker (or use the corresponding key 
command).

Â Select the Text tool, then click a marker. 
Â Shift–Control–double-click on the marker. 

2 Type the desired marker name in the text field.

To edit a marker name in the Marker List:
1 Click the desired marker in the Marker Name column.

2 Click and/or drag anywhere on the “Marker ##” entry in the Marker Text area at the 
bottom of the window, and type in the desired name. As you type, the text shown in 
the Marker Name column (and Marker Track) will update.

To edit a marker name in the Marker Text window:
m Open the marker in the Marker Text window, then type the marker text in. 

Any normal computer keystroke (with or without Shift held) will be interpreted as text 
input if the Marker Text window is the window with key focus, even if a key command 
is defined for the key. 

The first paragraph in the window will be used as the marker name. 
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Note:  If you use Return to create paragraphs in the Marker Text window or area, the 
first paragraph of the text will be displayed in a separate title line (of the marker) in the 
Marker track.

Unlike the marker display in the Bar ruler, all text below the first paragraph will also be 
displayed in the Marker track, depending on available space (you might want to 
change the height of the Marker track to view all text). This can be used for musical or 
technical notes, as an example. In this scenario, the marker color is only shown in the 
title line, with the remaining text displayed white on gray.

Changing the Appearance of Marker Text
You can change the appearance of marker text in the Marker Text window and area. 
You can assign a different font, size, and style to any selected portion of the marker 
text. All fonts installed on your system can be used. Different colors can be assigned to 
all, or selected parts, of the text, and to the Marker Text window and area background. 

To change the appearance of marker text:
1 Select the marker text you want to change. 

2 Click the Font button in the Marker Text window or Marker Text Area of the Marker List 
window.
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3 Choose the desired settings in the Font window.

Editing Markers
Markers can be edited in various ways. Common tasks include changing marker 
positions, coloring markers, and adjusting marker lengths.

To change the position of a marker, do one of the following:
m In the Marker track:  Drag it to the left or right. 

m In the Bar ruler:  Command-drag the marker to the left or right. 

m In the Marker List:  Use the mouse as a slider on the bar position display, or double-click 
on a position value and enter the new value with the computer keyboard.

Note:  The smallest movements that can be achieved in the Marker track and Bar ruler 
are dependent on the division setting in Transport area, the Snap menu setting, and 
the horizontal Zoom level (including sample accurate placement at the highest zoom 
levels). Watch the help tag for precise feedback on movements. The alternative for fine 
position adjustments is the Marker List.

There are times where you will want to protect markers from being moved. Thankfully, 
Logic Pro has a feature that preserves the absolute time position of events.

To protect the position of selected markers:
1 Choose Options > Lock SMPTE Position in the Marker List (or use the corresponding key 

command).

This locks (fixes) the SMPTE position of markers. To indicate this status, a lock symbol is 
displayed at the beginning of the marker name. 
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These markers always retain their absolute time position:  if the project tempo is 
changed, the bar positions will change to keep the markers at the same SMPTE 
positions.

∏ Tip:  You can also lock/unlock the SMPTE positions of markers from the Arrange area’s 
Region menu, and the Functions menu of the Piano Roll and Hyper Editor windows, if 
you enable the display of global tracks.

To unprotect the position of selected markers:
m Choose Options > Unlock SMPTE Position in the Marker List (or use the corresponding 

key command).

Note:  You can not unlock the SMPTE position of scene markers (see “Working With 
Scene Markers” on page 800). 

To change the length of a marker:
m In the Marker track:  Place the Pointer over the desired marker border. When the cursor 

changes to a Resize pointer, drag the marker border to the desired position. 

m In the Marker List:  Use the mouse as a slider on the bar position display, or double-click 
on a position value and enter the new value with the computer keyboard. 

The marker border can also be the beginning of the subsequent marker, especially if 
the length of the second marker hasn’t been defined. Markers cannot overlap.

To adjust a marker to fit a cycle:
m Drag a cycle onto an existing marker (with a right or left border—or both—that falls 

inside the cycle boundaries). 

Dragging the cycle area in the Bar ruler is limited to either horizontal or vertical 
movements. This ensures that you do not accidentally:
Â Move the cycle when creating markers (by dragging the cycle into the lower third of 

the Bar ruler or into the Marker track).
Â Create markers when moving the cycle. 
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∏ Tip:  When you hold Shift, after click-holding on the cycle, the cycle can be moved 
horizontally, and then dragged onto a marker in one go. 

Note:  When you hold Shift, before clicking on the cycle, the nearest cycle border is set 
to the clicked position.

To assign a color to a marker:
m Select a marker in the Marker track, choose View > Colors, then click the desired color 

in the palette. 

If dark colors are used, the marker text will automatically be shown in an inverse color. 
If you create markers from regions, the corresponding marker uses the region color. 

Navigating With Markers
You can navigate through your project with markers. This is useful when you want to 
quickly jump to—and edit regions or events—at a specific project position, for 
example.

To move the playhead to a marker, do one of the following:
m In the Marker track:  Press Option and click the marker.

m In the Bar ruler:  Press Command and click the marker.

m In the Marker List:  Click on a marker with the Finger tool.

∏ Tip:  If you press Option and click a marker in the Marker List with the Finger tool, the 
locators are set to the beginning and end points of the selected marker.

m Use the Go to Marker Number 1 to 20 key commands (20 different commands). 

The marker numbers in these commands refer to the (serial) order of all markers in the 
project.

m Use the Go to Marker key command to open a window that allows you to type in any 
marker number. 

This will move the playhead to the beginning of the chosen marker.

To move to the next or previous marker:
m Use the Go to Previous Marker and Go to Next Marker key commands). 

The locators are set to the beginning and end points of the selected marker. 

To start playback at a marker start position, do one of the following:
m In the Bar Ruler:  Command–double-click on a marker.

m In the Marker List:  Click-hold on a marker with the Finger tool.

Logic Pro continues playing until the mouse button is released.
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To create a cycle from a marker, do one of the following:
m Drag a marker up into the top third of the Bar ruler.

This will set a cycle with the same position and length as the marker. If Logic Pro is 
stopped when performing this action, the playhead will be placed at the start point of 
the cycle. 

m Select the marker, then use one of the following key commands:

Â Set Locators by Marker and Enable Cycle
Â Set Locators by Previous Marker and Enable Cycle
Â Set Locators by Next Marker and Enable Cycle

Customizing the Marker Display in the Marker List
There are two display options for marker position and length in the Marker List:
Â View > Event Position and Length in SMPTE Units:  Switches the marker position and 

length display between bar positions and SMPTE time positions. 
Â View > Length as Absolute Position:  Switches the marker length display between 

actual (relative) length and (absolute) display of the marker’s end position (shown as 
a bar position).
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7 Working With Projects

Logic Pro projects provide flexible options for storing and 
retrieving your music productions.

This chapter will provide you with information on all aspects of creating and handling 
Logic Pro projects.

Learning About Projects
Logic Pro requires a project to be opened or created before you can begin working. 
This is similar to using a word processing application, that requires a document to be 
opened before you can begin typing. Logic Pro, like word processors, also allows you to 
have multiple documents (projects) open simultaneously.

A project file is the main Logic Pro document type. It contains all MIDI events and 
parameter settings (apart from the preferences and key commands) plus information 
about the audio and video files to be played. It is important to note that a project file 
points to your audio and video files, which are stored as separate entities on disk. The 
audio and video files are not saved with the project. 

When you create a new project (or use the Save function, in general), you can choose 
to also save all associated files (assets). 
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Logic Pro creates a project folder that contains the project file, along with separate 
folders for files used in the project (audio files and so on). 

The choice of saving projects without assets minimizes the memory requirements for 
project storage, allowing you to transport them easily to other Logic-based studios—
either physically or as email attachments. This also means that the project will not be 
able to load the referenced audio and video files when moved, unless these other file 
types are also moved (the project is saved with its assets, in other words). 

Project folders help you to keep track of your work:  they ensure that all files related to 
a particular project are neatly saved in one location. This makes it easy to back up and 
transfer projects between computers or disks, and helps to avoid embarrassing 
problems such as missing audio files, or samples that you need to search for, or 
reconstruct, in the studio. 

Creating Projects 
You start working in Logic Pro by creating a new project. 

To create a project:
1 Choose File > New (or use the corresponding key command; default 

assignment:  Command-N). 

Project Folder

Audio Files folder

Movie Files folder

Sampler Instruments folder

Impulse Responses folder 

Project assets

Project file (“song”)
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2 Choose the desired template in the Templates dialog. 

The Templates dialog is broken down into two areas:  Collection and Template. 
Â Click a collection folder to display the associated template in the Templates area.
Â Click a template to load it. A Save As dialog will automatically launch. 

3 Browse to the location where you want to store the project, then type a name for the 
project in the name field.

4 Click the Include Assets checkbox if you wish to include the audio and other files in the 
project folder (see “Handling Project Assets” on page 149). 
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∏ Tip:  It is recommended that you enable the Include Assets checkbox, as this makes the 
project “safe,” allowing you to move or copy the project folder without losing any file 
references that point to items within the folder.

5 Click the Advanced Options disclosure triangle to view, and choose the file types you 
would like to save in the project folder. 

You can change these settings at any time by choosing File > Project Settings > Assets. 
Details on these project assets are found in “Handling Project Assets” on page 149.

6 Click Save. 

Â A named folder—containing several sub-folders, dependent on selections made in 
steps 3 and 4—is created at the target location. 

Â By default, an Audio Files sub-folder is created within the project folder, even if you 
have not turned on the Include Assets checkbox. This folder is used for any new 
audio recordings.

Â Also by default, the audio recording path is automatically routed to the new Project/
Audio Files sub-folder.

If you decide not to create a project folder in the first instance but would like to at a 
later stage, simply choose the Save As command.

∏ Tip:  You can quickly create an empty default project by holding Option while choosing 
File > New. 
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Opening Projects
Logic Pro requires a project to be opened before you can commence working.

A project can also consist of data created in other applications, including songs from 
earlier versions of Logic Pro or Final Cut Pro XML files, as examples.

To open an existing project, do the following:
1 Choose File > Open (or use the corresponding key command, default:  Command-O).

If a project is already loaded, you will be asked if the currently-loaded project should be 
closed or not. You can disable this prompt by unchecking the Logic Pro > Preferences > 
Global > Project Handling > “When opening a project, ask to ‘Close current project(s)?’” 
option.

The Open dialog features a File Type menu, which allows you to choose from the 
following options:
Â All Logic Document Types:  Displays all document types supported by Logic Pro
Â Logic Projects:  Projects created with current or earlier Logic versions
Â GarageBand Projects:  Projects created in GarageBand
Â Notator SL Songs:  Songs created in C-Lab/Emagic Notator or Creator SL
Â MIDI Files:  Standard MIDI files in either format 0 or 1
Â AAF Files:  Advanced Authoring Format used by other DAW applications such as 

Pro Tools.
Â OMF Interchange Files:  Open Media Framework files used by other DAW applications 

such as Pro Tools
Â OpenTL Files:  OpenTL (Open Track List) files used in devices such as Tascam hard disk 

recorders
Â XML (Final Cut Pro):  An open source standard, supported by Final Cut Pro and 

Soundtrack Pro

For more information about the individual file types, see Chapter 29, “Project and File 
Interchange,” on page 625.



140 Chapter 7    Working With Projects

2 To limit your view to certain file types in the file selector box, choose the desired file 
type in the File Type menu. Choose All Logic Document Types to see, and access, all 
supported file types.

3 Browse to, and select, the desired file, then click Open.

To open a recent project:
m Choose the project name directly from the File > Open Recent menu. 

This bypasses the Open dialog. You can clear all items in the Open Recent menu by 
choosing Clear Menu.

∏ Tip:  If you set the Startup Action in the Project Handling preferences to the Open Most 
Recent Project option, Logic Pro loads your last project automatically on startup (see 
“Opening and Creating Projects Automatically” on page 141).

Opening Projects Using Drag and Drop
Projects and Standard MIDI files can be opened by dragging them from the Finder into 
the Arrange area. The mouse cursor position—when the mouse button is released—
determines the placement of the imported file. 

This includes the position (rounded to the nearest bar) and destination of the first track. 
For more information about Standard MIDI files, take a look at “Working With Standard 
MIDI Files” on page 632.

You can also open a Logic Pro project or MIDI file by dragging it onto the Logic Pro 
icon in the Dock.

Opening Pre Version 8 Songs
You can open Logic Pro 5, Logic Pro 6, and Logic Pro 7 songs in Logic Pro 8. When 
loading a song or project created in a pre-version 8 Logic variant, the format will be 
converted to the version 8 format. A Save As dialog will open, allowing you to save the 
project with a new name. The original version song will be retained.

Important:  Projects saved in Logic Pro 8 are not backward-compatible with older 
Logic Pro versions.

Switching Between Multiple Projects
You can open several projects simultaneously, allowing you to copy or move data 
between them, or perhaps to compare different versions of one project.

To switch between projects:
m Choose the project name at the bottom of the Window menu—the active project is 

marked with a tick. 
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Opening and Creating Projects Automatically
You can configure Logic Pro to open or create projects automatically—on startup—by 
choosing a startup action in the Logic Pro > Preferences > Global > Project Handling 
tab.

Â Do Nothing:  As the name suggests, this does nothing. Logic Pro is opened and 
requires you to create a new project, or open an existing project or template.

Â Open Most Recent Project:  Automatically opens the project you were working on 
when you last quit Logic Pro.

Â Open Existing Project:  Automatically shows the Open dialog, allowing you to browse 
for an existing project.

Â Create New Project from Template:  Automatically opens the Templates dialog.
Â Create New Empty Project:  Automatically loads an empty project and opens the Save 

As dialog, allowing you to name and save your project. 
Â Create New Project using Default Template:  Automatically opens the default template, 

and launches the Save As dialog, allowing you to name and save your project. 

To determine the default template:
1 Click the Choose button below the Default Template field in the Project Handling 

preferences tab.

2 Browse to, and choose, the desired template (or project).

The full path and name of the chosen template or project is displayed in the Default 
Template field. You can assign any template or project as the default template.

Importing Settings From Other Projects
You can import the following settings from other projects:
Â Screensets
Â Transform sets
Â Hyper sets
Â Score sets
Â Score staff styles
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Â Score settings (all project settings that pertain to the score, such as Numbers & 
Names or Clefs & Signatures.)

Â Score text styles

To import settings from another project:
1 Choose File > Project Settings > Import Settings (or use the Import Settings key 

command). 

2 Select the desired settings by clicking the checkboxes at the bottom of the Import 
Settings window.

3 Browse to, and select, the desired source project (the one that you wish to import 
from). 

4 Click Open (or double click on the source project name).

The settings are imported into the active project.

Checking and Repairing Projects
On occasion, you may need to know how many regions are in a project, how much 
memory is being used, and so on. This data is available in the Project Information 
window. Very rarely, a project may become corrupted due to driver or memory 
conflicts, or may feel sluggish. Should any corruptions occur, a warning message will 
advise you of the existence and nature of the problem. These problems can generally 
be rectified in the Project Information window.



Chapter 7    Working With Projects 143

To open the Project Information window:
m Choose Options > Project Information. 

The Project Information window also provides the Reorganize Memory function which 
allows you to increase the amount of free memory, and to rectify a number of potential 
project corruptions or problems. 

To reconfigure the memory:
m Click the Reorganize Memory button in the Project Information window. 

At the same time, the current project will be checked for any signs of damage, 
structural problems, and unused blocks.

If any unused blocks are found—which normally shouldn’t happen—you will be able 
to remove these, and repair the project.

Note:  This reorganization is also carried out automatically after saving or loading a 
project. A common (and good) use of this feature is to free up memory after closing a 
project, if two or more projects were open prior to the close operation. 

Setting Project Properties
Following the creation of a project, a number of project properties should be checked, 
and changed if necessary. This is a great working practice as it will limit any morning 
after corrections that will need to be made later, such as sample rate conversions on a 
hundred or more audio files! This section outlines the project properties that you 
should take into consideration before commencing any work.

Setting the Sample Rate
The project’s sample rate determines the number of samples Logic Pro uses for audio 
playback. When you add or record audio files to your project, the sample rate of these 
files is automatically matched to the project sample rate.

Important:  The “Convert audio file sample rate when importing” project setting must 
be active for automatic sample rate matching. You can turn on this setting in the File > 
Projects Settings > Assets pane. 
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To set the project sample rate, do one of the following:
m Choose File > Project Settings > Audio (or use the Open Audio Project Settings key 

command), then choose the desired sample rate in the Sample Rate menu.

m Click the Sample Rate display in the Transport bar, then choose the desired sample rate 
from the pop-up menu.

Note:  If your Transport bar does not include the Sample Rate display, Control-click on it 
and choose Customize Transport Bar in the pop-up menu. Turn on the Sample Rate or 
Punch Locators checkbox in the Customize Transport Bar dialog. 

You may find that audio files in your project do not match the newly selected sample 
rate. The playback of files that do not match the project’s sample rate is slower (file’s 
sample rate is higher) or faster (file’s sample rate is lower) than it should be.

To match a file’s sample rate with the project sample rate, you can:
m Use the Audio Bin’s Copy/Convert File command, then replace the file in the project.

Logic Pro performs a real time, native sample rate conversion. Any sample rate available 
in Logic Pro (via Audio > Sample Rate) can be used for the conversion—even if your 
audio hardware does not support the selected sample rate.

The native software sample rate conversion facility matches the sample rate of any 
audio hardware, thereby allowing the playback of projects on virtually any audio 
system—even if the hardware is—in sample rate terms—not compatible. Nothing is 
lost in the process. Any internal processing and bouncing is always performed at the 
original sample rate, and at the highest quality, even in cases where the hardware does 
not support a particular sample rate. This facility allows you to work on projects 
originally created on high-end audio systems, with lower-end setups.
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Example:  A project was created with audio hardware set to operate at 96 kHz. Moving 
this project to a notebook computer, or setup that does not support the original 
project’s sample rate, will commonly result in the wrong playback speed. The native 
real time sample rate conversion facility will counteract this effect, allowing correct 
playback of the project on the laptop, at any sample rate.

Note:  High sample rates not only eat drive space, but also result in more CPU load.

Setting the Project Tempo
You can set the basic project tempo in the Transport, the Tempo track, or the Tempo 
List. Logic Pro displays tempo as quarter notes per minute, or beats per minute (bpm). 
It ranges from 5 to 9999 bpm, and is adjustable to four decimal places after the whole 
value.

To set the project tempo, do one of the following:
m Click-hold the Transport tempo value and drag up or down, or double-click the tempo 

field, then type a new value.

m Click-hold the tempo value in the Tempo List and drag up or down, or double-click the 
tempo field, then type a new value.

m Open the Tempo track, and drag the tempo line up or down with the Pointer tool.

For more information about advanced tempo operations, please refer to Chapter 30, 
“Advanced Tempo Operations,” on page 641.
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Setting the Project Time Signature
The time signature defines how many beats a bar contains in the Bar ruler and what 
note value constitutes one beat. 

Time signatures do not affect the playback of your project, but determine the editing 
grid in the Arrange area and MIDI editors as you can see in the following images. Both 
show the same MIDI region, with the first at a time signature of 2/8, and the second at 
6/8.

You can set the time signature of the project in the Transport, the Signature List, or the 
Signature track. The Transport displays the time signature in the following format:  
numerator : bar denominator : division value.

Bar denominatorNumerator

Division value
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The division value defines the division in all position displays (such as in the event 
editors), and forms the grid for various length and placement operations. The division 
value is normally set to 1/16 notes, but has a value range of 1/4 to 1/192 note. If the 
note value of the division is equal to or greater than the bar denominator, the third 
value of the position display is automatically removed.

∏ Tip:  You can use the Set Next Higher/Lower Division key command to switch to the 
next highest or lowest division.

The tempo indicator in the Transport window always relates to quarter notes, even if 
eighth notes are chosen as the denominator for the time signature.

To change the time signature, do one of the following:
m Click-hold on either of the Transport time signature values and drag up or down, or 

double-click the numbers in the field, and type a new value.

m Click-hold the value in the Signature List and drag up or down, or double-click the 
signature value, then type in a new value.

m Open the Signature track, and double-click the value shown. Set the Numerator and 
Denominator values (and other settings, if desired).

For more information on time signatures, refer to “Working With Time and Key 
Signatures” on page 723. 
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Setting the Start and End Points of a Project
A project normally starts at position 1 1 1 1. You can move the project start point to an 
earlier position, allowing upbeats or program change commands to be played before 
the first downbeat.

To define a project’s start point:
m Drag the project start marker in the Bar ruler to the left or right. 

To define a project’s end point, do one of the following:
m Drag the project end marker in the Bar ruler to the left or right. 

m Set the desired value in the Transport bar’s numerical Project End display.

Note:  If your Transport bar does not include the Project End display, Control-click on it 
and choose Customize Transport Bar in the pop-up menu. Turn on the Tempo/Project 
End checkbox in the Customize Transport Bar pane. 

As soon as Logic Pro reaches the project end point, it will stop automatically, except 
when recording. In this situation, the project end point is automatically moved to the 
end of the recording.

Setting the Basic Project Playback Level
You can set the basic project playback level by dragging the Master Level slider found 
at the right of the Transport bar. This slider is directly tied to the Master channel in the 
Mixer, and acts as a master level control for all audio and software instrument tracks.

Project End display
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Important:  This slider not only sets the playback level of your project, but also affects 
the overall level of your mix. 

Click the speaker symbol to the right of the Master Level slider to set the master slider 
to 0 dB. 

Click the speaker symbol to the left of the Master Level slider to turn on Dim Level 
mode:  This sets the playback volume to the Dim Level value set in the Logic Pro > 
Audio > General preferences. 

Click the button again to deactivate Dim Level mode, and set the playback level to the 
current Master Level slider value. 

Adjusting Project Settings
The project settings encompass a number of options that can have a dramatic impact 
on the behavior of Logic Pro. Project settings are saved independently with each 
project, which means that different projects can have different project settings. You can 
change project settings at any time, but it is generally best if you start off with the 
required settings, as this will make your workflow smoother.

To open the project settings, do one of the following:
m Choose the desired File > Project > Settings (Synchronization, MIDI, Score, and so on) 

menu entry (or use the corresponding key command).

m Click the Settings button in the Toolbar, then choose the desired menu entry.

Detailed information on all project settings can be found in “Project Settings” on 
page 940.

Handling Project Assets
The project settings also include an Assets tab. If you saved your project with its assets, 
you can use this tab to determine how files imported from external locations (locations 
outside the project folder) should be handled. 

To open the Assets project settings, do one of the following:
m Choose File > Project Settings > Assets (or use the Open Assets Project Settings key 

command).
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m Click the Settings button in the Toolbar, then choose Assets from the pop-up menu.

Â Turn on any of the copy checkboxes to copy the respective file types into the project 
folder. 

Â Turn on the “Convert audio file sample rate when importing” checkbox to 
automatically convert the sample rate of all imported files (with a different sample 
rate) to match the project sample rate.

Â If you turn off the Copy EXS Samples to Project Folder option, only EXS instrument 
files will be copied to the project folder when saving, not the samples associated 
with the EXS instrument files.

Files are only copied into the project folder when the project is saved. 

Once saved, the project is “safe,” allowing you to move or copy the entire project folder 
without losing any references that point to files within the folder.

Managing Projects
This section outlines some housekeeping that may be required to keep your projects in 
great shape.

Copying or Moving a Project Folder
A project folder can be freely moved or copied to another location by using any of the 
standard operating system methods. This is great for archiving and transport of 
projects to other studios or facilities.

All files in the target (copy) folder will still be found correctly, provided that they are all 
in the root (or sub-folders of ) the project folder—audio files are found in the Audio 
Files sub-folder, samples in the Samples sub-folder, sampler instruments in the Sampler 
Instruments sub-folder, and so on.
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Cleaning Up Projects
Should there be any unused project files in your project folder, make use of the File > 
Project > Clean Up command. If any unused files are found, the following dialog will be 
displayed:

Turn on the checkboxes in the first column to choose files for removal. The name and 
path of the file to be deleted is shown in the last two columns. 

Only files with active checkboxes in the first column will be deleted. All unchecked 
entries will remain as they are.

If multiple rows are selected, a click on any checkbox will switch all selected rows to the 
new state (either checked or unchecked).

Note:  The Clean Up command will only delete unused files (all types, except movie 
files). Clean Up takes into account the project currently loaded, and all other Logic Pro 
project files in the project folder—only files that are not used by any of these projects 
will be displayed in the Clean up list.

Consolidating Project Settings
If your project contains files that are not in the correct sub-folders within the project 
folder, you can use the Consolidate command to automatically organize them into the 
standardized project file structure.

To consolidate your project:
1 Choose File > Project > Consolidate (or use the Consolidate Project key command). 
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2 Choose the desired menu option for the different file types in the Consolidate dialog, 
to either move, leave, or copy the existing files. 

The two shortcut buttons at the lower left of the window make project consolidation 
quick and easy.

Â Click Copy All to set all menus to the copy option.
Â Click Move All to set all menus to the move option.

3 Activate the “Delete empty folders after moving” checkbox to remove the empty 
folders in the source project, after files have been moved to the target project.

4 Activate the “Create folders for audio file groups” checkbox to creates group folders 
within the Audio Files sub-folder of the target project. 

The groups must first be created in the Audio Bin of the source project. See “Grouping 
Files in the Audio Bin” on page 531. 

5 Press OK, when you’re done.

ReCycle Import Handling in Projects
EXS instruments created via a ReCycle import are placed in a Sampler Instruments/
ReCycle sub-folder of the project folder. All audio data generated by a ReCycle import is 
placed in the ReCycle Audio folder, alongside the project file.

Note:  This happens automatically and can’t be changed. If no project folder exists, 
ReCycle files are saved in ~Music/Logic/ReCycle Audio.

Saving Projects
When you choose File > Save (or use the corresponding key command, 
default:  Command-S), the current project will be saved—with its current name intact.

If you don’t wish to overwrite the most recent version of the project file saved with this 
name (which will happen if you use File > Save or Command-S), make use of the File > 
Save As or File > Save a Copy As commands. In the ensuing file selector dialog, you can 
enter a new name for the project, set Asssets as desired, (and select a new directory or 
even create a new folder).
Â File > Save As:  The next time you save using the straight Save (Command-S) 

command, the new file name and path will be used.
Â File > Save a Copy As:  The next time you save with the straight Save (Command-S) 

command, the existing file name and path will continue to be used. The copy is a 
replica of the existing project, stored in a different location. It does not update the 
file save path. Save a Copy As is ideal for archiving and moving data.
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Automatic Backup Files
When you save a project, Logic Pro will automatically make a safety copy (a backup) of 
the project file. Backup files are saved in the project folder, and are named after the 
project, but feature the “~” character after the project name. 

Reverting to the Saved Version
Any time you make a mistake, you can undo it by choosing Edit > Undo (Command Z).

If you have made some really serious blunders (as unlikely as that may be), or you 
decide that in the 15 minutes since you last saved, your creative efforts have resulted in 
material too unpleasant to describe politely, you may find the File > Revert to Saved 
function (or the corresponding key command) very helpful. This replaces the current 
project with the previously saved version.

Saving a Project as a Template
You can save a project as template, creating starting points for new projects. Not all 
projects have the same needs, so customizing several projects to meet these needs 
offers an ideal starting point for different jobs. As examples:
Â A template that is software instrument-focussed, for dance music projects. This 

would feature 32 software instrument tracks, and say eight audio tracks.
Â An audio track-centric template, featuring say 64 audio tracks, would be ideal for live 

recording.
Â A specific live performance template that makes the job of quickly switching 

between parts faster, or perhaps makes heavy use of Environment processing.
Â Several scoring templates for:  choirs, a rock band, symphony orchestra, string 

quartet, jazz combo, and so on.
Â A template containing modified synchronization settings for control of ADAT 

hardware.
Â A template for video work:  This would typically contain a Video track plus specific 

dialog, foley, and music tracks. 
Â A second video template could be used for jobs where the video is running on an 

external video tape machine that is synchronized with Logic Pro via SMPTE.

Screensets can be customized for each template, or you can make use of the File > 
Project Settings > Import Settings command to copy them between templates.

To save a project as a template:
m Choose File > Save as Template (or use the Save as Template key command), then type 

in the desired name.

The project will be saved in the ~/Library/Application Support/Logic/Project Templates 
folder. The next time you open the Templates dialog, you will see your template in the 
My Templates collection, below the factory template collections. 
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You can create collections under My Templates by creating sub-folders in the ~/Library/
Application Support/Logic/Project Templates folder. This can be done in the Finder, or 
with the Create Folder button in the Save As Template dialog. When all user templates 
are placed in sub-folders, the sub-folder names will be shown below the factory 
collections.

∏ Tip:  You can add a descriptive text to your templates by adding a comment to the 
project file in the Finder. The Templates dialog displays the icon assigned to a template 
file, making it easy for you to change a template’s icon. For more information on how to 
add a comment to a file, or change the icon of a file, see the Finder Help. 

Closing and Quitting
Following the creation or playback of a project, you’ll want to close it and Logic Pro. 
Here’s how you do it:

To close the currently active project:
m Choose File > Close Project (or use the corresponding key command, default:  Option-

Command-W). 

If you have made any changes since the last save operation, Logic Pro will ask you if the 
project should be re-saved before closing, to preserve any changes you have made.

To close the open window:
m Choose File > Close (or use the corresponding key command).

This will only close the uppermost window, not the whole project. The project will only 
be properly closed when all windows are closed.

To quit the application:
m Choose Logic Pro > Quit Logic Pro (or use the corresponding key command, 

default:  Command-Q). 

If you’ve made changes, but haven’t saved them, you will be asked if you want to do so 
before quitting (press Enter to save).

If multiple projects are open, you will be asked if you want to review any changes, or 
simply close and discard any changes.

The Close Project without Saving key command closes the currently active project 
without saving it—and you will not be asked to do so. This command was included at 
the request of many experienced Logic Pro users. Please only use it if you’re sure that 
this is what you want to do.
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8 Basic Operations

The following chapter will introduce you to the basic operating, selection, and editing 
techniques available in Logic Pro.

You will learn about input techniques, correcting errors, and a number of shortcuts and 
features that will accelerate your workflow, and assist you while learning about 
Logic Pro.

Using the Mouse
If you’re unfamiliar with mouse use in Logic Pro, which differs from mouse use in other 
applications, the following section will be of use. It outlines how the mouse can be 
used in Logic Pro. If you’re comfortable with mouse use in Logic Pro, skip ahead to the 
next section. 

Clicking
Place the mouse pointer on the element (region, event, button, menu, input field, and 
so on) and press the mouse button once.

Double-Clicking
The same as clicking on an element, but you press the mouse button twice—in quick 
succession. You can set a suitable interval between clicks in the System Preferences 
(Keyboard & Mouse pane).

Grabbing or Clicking and Holding
The same as clicking on an element, but you keep the mouse button held down. 

Moving or Dragging
Grab the element, and move the mouse (keeping the mouse button held down) to the 
desired position.

Right-Clicking
The same as clicking, but you press the right mouse button, if available. This will open a 
shortcut menu, open the toolbox, or select an assigned tool.
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Modifier-Clicking or Dragging
Many commands, functions, additional tools, or finer adjustments are accessed by 
holding a modifier key:  Control, Shift, Option, or Command while clicking or dragging. 
As examples:  Option-dragging a region will copy it. Option-clicking on a fader or knob 
will reset it to its default, or centered, value.

Mouse Wheel Events
You can use the mouse wheel to scroll vertically in Logic Pro. There are also some 
modifiers supported:
Â If you press Command, the mouse wheel scrolls horizontally.
Â If you press Option, the mouse wheel zooms in or out vertically.
Â If you press Option-Command, the mouse wheel zooms in or out horizontally.
Â If you press Option-Control, the mouse wheel zooms in or out in both directions.

Note:  Logic Pro also supports mice that feature an x and y axis on one scroll wheel 
(such as the Apple Mighty Mouse). On a 2 axis mouse, the Command modifier (that 
switches a single axis mouse between horizontal and vertical orientation) is not used.

Mouse as a Slider
You can set most numerical parameters (even note values or names) by grabbing the 
parameter value, and moving the mouse up or down. If the parameter consists of 
several separate numbers (project position, for example), you can adjust each number 
individually using this method.

Entering Numerical Values
You can use numerical input in many areas of the program. Double-clicking a 
numerical parameter value opens an input field. The existing value is highlighted, and 
ready to be overwritten by a new entry. This method is ideal for quickly setting a 
parameter value in the Inspector, or instantly navigating to a bar, when used in the 
Transport. As a usage example of the latter, double-click on the Position display in the 
Transport, and type in 45, followed by the Return key. This will move the playhead to 
the beginning of bar 45.

You can also use the mouse to make a partial selection in an input field, so that only 
the highlighted part is overwritten. As long as the input field is open, the computer 
keyboard may only be used for data entry, and may not be used for key commands 
(with the exception of the main menu functions).
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Here are some of the possible methods. You can type in:
Â Decimals:  1, 01, 2, 3, 4, 127, …
Â Hexadecimals:  $1, $01, $2, $3, $A, $0A, $7F
Â Notes:  “C3”, “C#3”, “Cb3”, “C##2” (equivalent to D2), “Dbb2” (equivalent to C2). If you 

double-click on the note “E3”, you can enter a decimal value such as “64” or a hex 
value of “$40” instead of the note name.

Â ASCII Code:  You can also input numbers as ASCII code:  just place a ` or " in front of 
the selected key, and the ASCII code will be input as a number. 
As an example:  "! results in a value of 33; "a results in a value of 97.
This function is particularly useful for entering text in SysEx strings.

Arithmetical Operations
In many parts of Logic Pro, mathematical operations can also be used to change values. 
As examples:
Â You can subtract from the existing value by entering “–5”.
Â You can sum two values by entering “38+17”.
Â You can multiply two values by entering “7∗8”.
Â You can divide two values by entering “80/5”. 

Canceling Numerical Input
You can cancel numerical input by entering no text at all, and pressing Enter or Return.

Entering Text
You can input text names in the same way as numbers, but you only need to click once 
on a name field to allow input. You can directly click on a region (or Mixer channel 
strip) with the Text tool to rename it.

Any number of selected objects (such as regions) can be assigned the same name. If 
the name ends with a number, this number will automatically be incremented by 1 for 
each subsequent object. This allows you to quickly, and uniquely, name all of the 
regions on a track, for example.

Note:  To turn off automatic numbering, place a space after the number at the end of 
the name you type in. All selected objects will then end with the same number. This 
may be useful for identifying all main vocal regions recorded in another session, for 
example (rename to “mainvox 030707”, followed by the space, to identify the regions by 
date).
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Working With Key Commands
You can execute nearly every Logic Pro function with a key command or MIDI message. 
Whenever this manual mentions a key command, this refers to a function, command, 
or option that can be accessed by either:  a computer keyboard keystroke (or keystroke 
combination—such as Option-R—which opens the Recording project settings), or a 
MIDI message.

Use of key commands, rather than the mouse, can greatly accelerate your workflow. 
Throughout this manual, you will encounter a number of practical usage examples, 
often in step form, that include the default key command assignments for particular 
functions.

∏ Tip:  It is recommended that you make use of these default key commands while 
getting to know the application, by following the steps outlined in the guide. Not only 
will this help you to remember them, but will also aid in developing good (and faster) 
working practices from the outset.

Once you have a good understanding of Logic Pro fundamentals, and how you like to 
work, you can freely assign your own key command set—for functions that you use 
most often.

The Key Commands window is used to assign Logic Pro functions to computer 
keyboard keys, or to MIDI messages. This allows you to completely customize the 
application to suit your own working style.

Note:  A number of functions are only available as key commands. Some of these may 
not have a default key command assignment. In such cases, you will need to create a 
suitable key command, in order to make use of the function.

If you’re new to Logic Pro, and would like to get “hands on” with the application, please 
skip ahead to “Working With Tools” on page 166. You can always return to the following 
section when you’re ready to create or customize your own key command set, but this 
isn’t essential to know before using Logic Pro.

Saving Key Commands
Your personal key assignment sets are stored in a separate file located in ~Library/
Application Support/Logic/Key Commands. You should:
Â Make a backup of your user-defined key command set at another hard disk location 

before changing any key commands.
Â Make a backup on removable media (a CD-ROM or USB flash drive, for example), or 

on a networked Macintosh (using Bonjour) or a .Mac account (see “Sharing Logic Pro 
Data Over a Network” on page 625). These back up options make it easy to transfer 
your key commands when using Logic Pro on another computer.
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Whenever you install Logic Pro updates, your personal key commands will remain 
unaltered.

Note:  Almost all key commands are user-definable. Some of the default assignments 
for standard commands such as Undo, Save, Quit, New, Open, Cut, Copy, and Paste 
follow Mac OS X conventions, and probably shouldn’t be altered. Some keys are “hard-
wired” to specific functions or commands, and can not be changed. These are dimmed 
in the key command listing, to indicate this fixed status. See the section below.

Special Keys
Some keys have special functions:
Â The Shift, Control, Option, and Command modifier keys can only be used in 

conjunction with other keys.
Â The Backspace key has the fixed “delete selected objects” function. It can only be 

assigned to another function in conjunction with the modifier keys.
Â The key combinations assigned to the commands in the main menu bar can be 

reassigned, but it is generally recommended that you leave them at their defaults. 
The key command assignment is displayed after the main menu items. As examples:  
Command-1 opens the Arrange window, Shift-L locks the current screenset.

Â The Plus and Minus keys are assigned to the Increase/Decrease Last Parameter by 1 
key commands. As the name suggests, this will increase or decrease any selected 
parameter value in single units. 

Â Using Shift in conjunction with the Plus and Minus keys accesses the Increase/
Decrease Last Parameter by 10 key commands.

The Key Commands Window
The Key Commands window is used to assign Logic Pro functions to computer 
keyboard keys or MIDI messages. This allows you to completely customize the 
application to suit your working style.

To open the Key Commands window, do one of the following:
m Choose Logic Pro > Preferences > Key Commands (or use the Open Key Commands key 

command, Option-K).

m Click the Preferences Toolbar button, then choose Key Commands from the shortcut 
menu. 
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∏ Tip:  Pressing Control—and choosing a command in a menu—opens the Key 
Commands window, with the respective command selected. This also works with 
shortcut menus.

Â Key Commands list:  Lists all available key commands. The bullet indicates key 
commands that are not available as menu items. 

Â Key and Assignment column:  Show the currently assigned key, and MIDI message (if 
applicable). 

Â Find field:  Use this to find key commands by name or partial name.
Â Key combination area:  Displays the key combination associated with the selected key 

command. 
Â Assignments area:  Displays the control surface assignment associated with the 

selected command. 
Â Learn buttons:  Use these to teach Logic Pro to use a particular key, or key 

combination, to perform a function.

Key Command Groups and Hierarchies
The global key commands are always functional, regardless of the currently active 
window. Non-global commands require the corresponding window to have key focus 
(in the foreground, or on top of other windows). This allows you to assign the same key 
command (or combination of keys) to different functions in different windows. 

Key Commands list

Key and Assignment columns Key combination area Find field

Learn buttons

Assignments area

Learn button
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Important:  There is a hierarchy of key command classes, which are not merely 
separated into global and local key commands. As an example, there is a key command 
class that applies to all windows that display regions. This class has higher priority than 
global key commands, but a lower priority than local (Arrange, Score, Piano Roll, and so 
on) window key commands.

Choosing Key Command Sets
The Options menu offers commands that allow you to switch between key command 
sets, or import and export them. This is particularly useful if you need to work 
temporarily on another user’s Logic Pro system; allowing use of your personal key 
assignments, without altering the settings of the other system.
Â Options > Preset menu:  Displays all key command sets saved in the ~Library/

Application Support/Logic/Key Commands folder, allowing you to quickly switch 
between key command sets. 

Â Options > Import Key Commands:  Opens a file selector box, allowing you to import 
key command sets from any folder location. The existing file (on the target system) is 
automatically saved as a *.bak file. This file contains the old key commands. You don’t 
need to restart Logic Pro to begin using the new key command set.

Â Options > Export Key Commands:  Opens a file selector box, allowing you to save the 
current key command assignments to any desired location. 

Browsing Key Commands
Key commands are grouped in various categories. You can extend or collapse groups 
by clicking the respective disclosure triangle. 

The Options > Expand All command displays the contents all key command groups. 
Options > Collapse All hides the contents of all key command groups. 

When you expand key command groups, your key command selection may no longer 
be visible. You can quickly return to the selected key command by choosing Options > 
Scroll to Selection. When the list has key focus, you can use a key command (or key 
command combination) to select the associated function in the list.

Finding Key Commands
You can use the Key Command window’s Find field to find key commands by name or 
partial name:
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Â The search is performed as you enter text. There is no need to press the Return key, 
unless you wish to retain a history of key command searches. 

Â The Cancel button to the right (that appears as soon as any text is entered) clears any 
entered text, and displays all key commands.

Â The Find menu to the left (the magnifying glass) retains a history of recently used 
search terms. The Clear menu item erases the Find history.

Note:  The Find history is limited to searches that were completed by pressing the 
Return key. 

Assigning Key Commands to Computer Keys
This section shows you how you assign particular computer keyboard keys to Logic Pro 
functions. 

To assign a function to a key:
1 Select the desired command in the Command column.

2 Activate the Learn by Key Label button.

3 Press the desired key, along with the desired modifier key or keys (Shift, Control, 
Option, or Command).

4 If you want to make another assignment, repeat steps 1 to 3.

5 Deactivate the Learn by Key Label button. 

The Learn by Key Position function works in the same way, but differs in that it’s not 
just a reference to an ASCII code that is stored, but the actual scan code of the key that 
is pressed.

In practice, this means that you can, for example, assign different commands to the 
number keys on the numeric keypad and the number keys above the keyboard.

This also means that the key position remains the same if you switch between different 
operating system language settings, or different keyboards. As an example, using a 
scan code for a function assigned to the Y key on an English keyboard would function 
in the same way if you switched to a German keyboard—which has a Z key in the same 
position as the Y key on an English keyboard.

The only disadvantage is that the key code (a number), rather than the ASCII symbol, is 
displayed in the Key Commands window. The ASCII symbol is more useful for reference 
purposes.
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To clarify the difference between these two functions, here’s a short comparison:
Â If you use the Learn by Key Label function, and define only one key command for the 

key, it will be used, no matter which of the two keys (either number 7 key, for 
example) is pressed.

Â If you use the Learn by Key Position function, and define two key commands (one for 
the alphanumeric keyboard, one for the numeric keypad), then the appropriate key 
command will be used (one for each number 7 key, for example).

Using Existing Key Commands
In circumstances where an existing local key command combination is used, when 
assigning a new global key command, the following warning message will appear:

You have three options:  Cancel, Replace, or OK. 
Â Cancel:  Does not alter existing assignments. 
Â Replace:  Replaces the existing shortcut (assigned to the chosen key command 

combination) with the selected function. 
Â OK:  Assigns the key command combination to the selected function, while retaining 

the existing key command or function.

To delete key assignments:
1 Select the function with a key assignment that you’d like to delete.

2 Activate the Learn by Key Label or Learn by Key Position button.

3 Press Backspace.

4 To erase more assignments, repeat the first and third steps.

5 Deactivate the Learn by Key Label or Learn by Key Position button.
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Assigning Key Commands to Control Surfaces
The Learn New Assignment button allows you to assign control surface messages to 
particular commands—effectively teaching Logic Pro to understand these messages. 

To learn a controller assignment:
1 Click the Learn New Assignment button.

2 Select the command in the Command column.

3 Send the desired MIDI message from your controller.

The Assignments field displays the learned assignment. This may show one or all of the 
following:

Â The name of the control surface—or the MIDI string, if the assignment is from an 
unsupported control surface.

Â The name of the control.
Â The zone and mode that the assignment belongs to, if applicable.

Note:  The Learn New Assignment button is automatically turned off when the entire 
message has been received. This avoids reception of further messages (that may be) 
sent by the device when you release the button. To ensure reliable reception, hold the 
button for a short period before releasing it.

4 If you want to make another assignment, repeat steps 2 and 3.
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If you want to assign functions—other than key commands—to a control surface, 
make use of the Controller Assignments window. You can open it by double-clicking on 
a row in the assignment section, or choosing Logic Pro > Preferences > Control 
Surfaces > Learn Assignment for xxx command (Open Controller Assignments key 
command). This is detailed in the Control Surfaces Support manual. 

Initializing Key Assignments
You can reset all key commands to their default assignments. You will lose your existing 
key command assignments, so ensure that you have created a copy of your key 
commands file before doing so.

To initialize all key command assignments:
m Choose Options > Initialize all Key Commands in the Key Commands window.

Printing a Key Command List
You can use the Options > Copy Key Commands to Clipboard function to copy your 
key command assignments into the Clipboard as text. From here, it’s a simple matter of 
pasting the results into any word processor, formatting as desired, and printing them 
out.

The Copy to Clipboard command only copies the currently visible key command 
assignments. You could, therefore, export a certain group of key commands (those 
containing a particular character string, for example). What you see in the window 
display is exactly what’s exported.

The Copy to Clipboard 
command only copies 
the currently visible key 
command assignments 
into the Clipboard
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Working With Tools
Each editor provides different tools—that are suitable for the tasks performed in the 
window.

Tools are only effective in the working area of the window in which they are chosen. 
You can define individual tools for each window.

A tool (the Scissors, for example) basically affects the regions or events that you click 
on. If multiple regions are selected, they are all affected by the tool (the Scissors would 
cut all selected regions at the same playhead position).

Tools are accessed in the Tool menus, found at the upper-right corner of all windows 
that allow direct region, event, or file editing and handling operations.

You may freely assign at least two tools—one in each Tool menu. In some windows, 
additional tool menus may appear after two tools have been assigned.

To assign the left-click (or default) tool:
m Click the left Tool menu to open it, and choose the desired tool.

To assign the Command-click (alternate) tool:
m Click the right Tool menu, and choose the desired tool.

When editing regions, events, or files, both tools are available at the mouse pointer 
position. The left menu tool is active by default.

To switch between the default and alternate tools:
1 Hold down Command to activate the alternate (right menu) tool. 

2 Release the Command key to revert to the default (left menu) tool.

The mouse pointer adopts the shape of the active tool, allowing you to instantly 
identify it by looking at the cursor graphic. 
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Assigning the Right Mouse Button
If you have a suitable mouse, you can also assign the right mouse button to any of the 
following:
Â A third tool
Â Tool menu
Â Shortcut menu (default)

To set the behavior of the right mouse button:
1 Open the Global preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Global (or use the corresponding key command).
Â Click the Toolbar Preferences button, then choose Global from the pop-up menu.

2 Click the Editing tab, then choose the desired setting from the Right Mouse Button 
pop-up menu.

Â Is Assignable to a Tool:  When this option is selected, a third Tool menu appears (to 
the right of the default and alternate Tool menus) in the working window. Choose 
the appropriate menu item to assign the right mouse button tool. Right-clicking 
activates the third tool in the working window.

 Left-click Tool menu Right-click Tool menu

Command-click Tool 



168 Chapter 8    Basic Operations

Â Opens Tool Menu:  Right-clicking in the working area of the active window opens the 
Tool menu at the mouse cursor position. Simply choose the desired tool by clicking 
on it. When the Tool menu is open, you can also use the key shown next to a tool to 
select it.

Â Opens Shortcut Menu:  Right-clicking in the working area of the active window will 
display a menu that offers a number of area-specific selection and editing commands 
(see “Using the Shortcut Menu” on page 171). 

Using Key Commands to Select Tools
You can also use the following key commands to select tools:
Â Set Next Tool and Set Previous Tool:  Switch to the neighboring tool in the active 

window.
Â Show Tool menu:  Open the Tool menu at the cursor position. When the Tool menu is 

open, you can also use one of the number keys shown next to a tool to select it. 
(default key command:  Esc)

Â Set X tool:  You can select each tool via a specific key command. Key commands 
assigned to a specific tool switch between this tool, and the previously selected tool.
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Learning About Common Tools
The following section describes the most common tools available in Logic Pro. Tools 
that are specific to particular editing windows are covered in the respective chapters.

Pointer Tool 
The Pointer is the default tool when Logic Pro is first opened. The mouse cursor also 
takes on this shape outside the working area, when making a menu selection or 
entering a value. 

Within the working area, you can use the Pointer tool for:
Â Selecting individual or multiple events, regions, or other elements by clicking on 

them. See “Selection Techniques” on page 172.
Â Moving (by grabbing and dragging).
Â Copying (by Option-dragging).
Â Changing lengths (by grabbing the bottom right or left corner and dragging).
Â Looping regions (by grabbing the upper right corner, and dragging).

Pencil Tool
The Pencil is used to add new regions or events. You can also select, drag, loop regions, 
and alter the length of regions or events while the Pencil tool is active. 

Eraser Tool
The Eraser deletes selected regions or events. When you click a region or event with the 
Eraser, all of the currently selected regions or events are deleted (as if you had used 
Backspace). The Eraser can also delete an unselected region or event by clicking on it.

Text Tool
The Text tool is used to name regions, or add text to a musical score.

Scissors Tool
The Scissors tool is used to split regions and events, allowing individual sections to be 
copied, moved, or deleted.
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Glue Tool
The Glue tool performs the reverse operation of the Scissors tool. All selected regions 
or events are merged into a single region or event. 

Solo Tool
Click-holding a region with the Solo tool allows you to listen to the selected region or 
event in isolation. Moving the mouse horizontally also outputs (scrubs) any events the 
cursor touches.

Mute Tool
Clicking an event or region with the Mute tool prevents it from playing. You can 
unmute the region or event by clicking it a second time with the Mute tool. If multiple 
regions or events are selected, the mute status of the clicked region or event applies to 
all selected regions or events.

Zoom Tool
The Zoom tool allows you to zoom (up to the full window size) by making a rubber-
band selection. You can revert to the normal zoom level by clicking on the window 
background with this tool. You can also access the Zoom function—even when other 
tools are active—by holding down Control-Option.

Working With Help Tags
A help tag appears just below the mouse cursor position—for as long as the mouse 
button is held down—when using many of the tools. The help tag provides useful 
feedback on the operation you are performing.

Note:  You must enable the Logic Pro > Preferences > Display > General > Show Help 
Tags option in order to view help tags during editing operations. 

During operations involving regions, the help tag will look something like this:

From left to right (and from top to bottom), the values indicate:
Â Name of the operation.
Â Mouse (or region) position.
Â Region/event name.
Â Track number.
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Â Length of the region.

During operations involving events, the help tag looks something like this:

From left to right, the values indicate:
Â Name of the operation.
Â Mouse (or event) position.
Â Event type.
Â Event MIDI channel.
Â First data byte (note pitch, for example).
Â Second data byte (note velocity, for example).
Â Event length (note length, for example).

Using the Shortcut Menu
Control-clicking anywhere in the Arrange, Piano Roll Editor, and all List Editors, launches 
a shortcut menu (also known as the context menu) that can be used for a number of 
selection and editing tasks.

The shortcut menus differ between (and within) windows, based on both the selection 
status of events or regions within the window, and also the type of information that 
the editor deals with.

The items that appear in the menu will update to reflect the current context. As 
examples in the Arrange area:
Â An Arrange window with no regions or no selected regions:  A number of Select and 

Paste commands, plus Scroll in Play are available.
Â With one or more regions selected in the Arrange:  Cut, Copy, and Delete, Nudge, 

Lock/Unlock SMPTE Position and Region Name and Color commands become 
available.

Note:  You can always access the shortcut menu with a Control-click, but can also make 
use of the right mouse button to open it. To do so, ensure that the Right Mouse Button: 
Opens Shortcut Menu pop-up menu item is chosen in the Preferences > Global > 
Editing tab. 
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Selection Techniques
Whenever you want to perform an operation on one or more regions or events (or 
other elements, such as Mixer channel strips), you first need to select them. Selected 
elements, regions, or events are:  displayed in an inverted color scheme, with a 
highlighted name, or will flash (note events in the Score Editor, for example).

A region or event selected in one window will also be selected in all other windows 
that display that region or event. As examples, a note event selected in the Piano Roll 
Editor will also be selected in the Score Editor and Event List. The region that contains 
the selected event will also be selected in the Arrange area.

Changing the window with key focus doesn’t affect the selection (as long as you don’t 
click on the window background, which deselects everything). Be sure to click on 
window title bars when switching between windows.

∏ Tip:  Don’t forget about the Zoom functions when making your selections, as high 
zoom levels can make precise selections much simpler.

Selecting Individual Regions, Events, and Other Elements
You can select individual regions or events (or other elements, such as Mixer channel 
strips) by clicking on them with the Pointer tool. 

You can deselect them by clicking on the window background, or by selecting another 
region, event, or element.

The Select Next Region/Event key command (default assignment:  Right Arrow key) 
and the Select Previous Region/Event key command (default assignment:  Left Arrow 
key) provide a quick way to step between (and individually select) regions or events.

In the Arrange area, pressing any letter key selects the first region with a name that 
begins with the chosen letter (as in the Finder), provided that no key command is 
assigned to this key.
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Selecting Several Regions, Events, and Other Elements
You will often need to select multiple regions, events, or other elements, in order to 
move, process, or copy them, for example. 

To select all regions, events, or elements in a window:
m Choose Edit > Select All (or use the corresponding key command, 

default:  Command-A)

To deselect all regions, events, or elements in a window:
m Choose Edit > Deselect All (or use the corresponding key command, 

default:  Shift-Command-A)

To select several non-contiguous regions, events, or elements in a window:
m Shift-click on them, one-by-one. 

As subsequent regions or events are selected, the previous selections are retained. 

Making Horizontal Selections
Horizontal selections can be made in a number of editing windows, allowing you to 
quickly select all regions, or events that are horizontally aligned on a lane.

To select all regions on a track in the Arrange area, do one of the following:
m Click on the track name in the track list.

m Choose Edit > Select All Following of Same Track (or use the corresponding key 
command). All regions following (after) the selected region will be selected.

To select all events (of a specified event definition) in the Hyper Editor, do one of the 
following:

m Click on the event definition name.

m Choose Edit > Select All Following of Same Pitch (or use the corresponding key 
command). All events after the selected event will be selected.

To select all notes of a certain pitch in the Piano Roll Editor, do one of the following:
m Click the relevant key on the Piano Roll keyboard.
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m Choose Edit > Select All Following of Same Pitch (or use the corresponding key 
command).

Important:  The selection techniques covered above only affect regions or events that 
fall within the cycle area defined in the Bar ruler, when Cycle mode is on.

Making Rubber-Band Selections
To select consecutive regions or events (or other elements, such as Mixer channel 
strips), click on the background and drag a rubber-band over them.

All regions or events touched, or enclosed, by the rubber-band (shaded area) will be 
selected.

Switching the Selection Status
When you make any selection (including by rubber-band or horizontal selection) while 
holding down Shift, the active selection status of the regions or events will be reversed.

You can also reverse the selection status of all regions or events by using Edit > Toggle 
Selection (default key command:  Shift-T). 

As an example:  If you want to select all regions in a project, with the exception of a 
few, you can first select the regions that you do not want to choose, and then use the 
Toggle Selection command.

Selecting Following Regions or Events
To select all regions or events that follow the currently selected region or event (or, if 
none are currently selected, to select all regions or events after the playhead position), 
choose Edit > Select All Following (default key command:  Shift-F).

To add the following region or event to your selection:
m Use the Toggle Next Region/Event key command (default:  Shift–Right Arrow)

To add the previous region or event to your selection:
m Use the Toggle Previous Region/Event key command (default:  Shift–Left Arrow).
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Selecting Regions or Events Within the Locators
Choose Edit > Select Inside Locators (default key command:  Shift-I) to select all regions 
or events lying wholly, or partly, inside the locator positions.

Edit > Deselect Outside Locators (or the corresponding key command) deselects all 
regions or events outside the locators. Region or event selections within the locator 
boundaries are unchanged.

Selecting Specific Regions and Events
You can use the following commands to select regions or events that match a specific 
condition, or have a particular characteristic.
Â Edit > Select Empty Regions (default key command:  Shift-U):  Use to select all empty 

regions.
Â Edit > Select Overlapped Regions/Events:  Use to select all overlapping regions or 

events.
Â Edit > Select Muted Regions/Events (default key command:  Shift-M):  Use to select all 

muted regions or events.
Â Edit > Select Equal Colored Regions/Events (default key command:  Shift-C):  If you have 

selected a region or event of a certain color, you can use this command to select all 
regions or events of the same color. This is a useful option when replacing song 
sections and other group editing tasks.

Â Deselect All Regions Except on Selected Track key command:  Deselects any regions not 
on the currently selected track. This command is especially handy when used after 
other special selection commands—limiting the effects of ensuing commands to the 
recording track.

Selecting Similar or Identical Objects, Regions, or Events
If you have selected a region, event, or Environment object, you can use the Edit > 
Select Similar Objects/Regions/Events function to select all similar regions, events, or 
objects (default key command:  Shift-S). 

The Select Equal Regions/Events/Object function selects all identical objects, regions, or 
events (default key command:  Shift-E).

The table outlines the differences between similar and identical (equal) objects.

Element Similar Identical

Region Region type (audio or MIDI) Â MIDI regions:  Identical content and size
Â Audio region:  All regions of the same 

length and position

Controller events Controller number equal, any 
data byte (control value)

Controller number and data byte (control 
value) equal

Note event Note equal, any octave Note and octave equal

Environment object Same object type (e.g. fader) Same fader type (e.g. text)
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Selecting Events With the Same MIDI Channel
Following selection of an event, you may select all other events that share the same 
MIDI channel by using the Edit > Select Equal Channels command (default key 
command:  Shift-K).

As an example:  Imagine you’re editing a MIDI region that contains volume and pan 
controller information for 16 MIDI channels. 

To select all events on channels 1 and 3:
1 Shift-select one event on channel 1 and another event on channel 3.

2 Choose Edit > Select Equal Channels (or use the corresponding key command, 
default:  Shift-K). 

All other events on these two channels will be selected.

Selecting Regions or Events With an Equal Subposition
You can select all regions and events with a certain relative position, such as all snare 
drums on the off-beat. Select a region or event at the desired relative position, and 
choose Edit > Select Equal Subpositions (default key command:  Shift-P). All regions or 
events with the same relative position will be selected.

Accelerating Edit Operations With Selection Commands
As you can see, there are many different ways to make selections, based on different 
criteria. These can be used to speed up many editing operations, in conjunction with 
key commands. Here are a few examples:

If you want to delete all similar regions, events, or objects, make your selection and use 
the Delete Similar Object key command.

Conversely, if you want to keep all similar regions, events, or objects, and delete all 
others, use the Delete but Keep Similar Objects key command.

You can use the Event Channel +1 key command or the Event Channel –1 key 
commands to alter the channel number of the selected event (or events) by one, 
making it easy to reassign it/them to another MIDI channel.

Working With the Clipboard
The Clipboard is an invisible area of memory, into which you can cut or copy selected 
information (such as regions or events), allowing them to be pasted to a different 
location.

The Clipboard is universal, which means that it can be used to exchange information 
between projects. 

All of the following options are available in the Edit menu.



Chapter 8    Basic Operations 177

Cut
All selected elements are removed from their current position, and placed in the 
Clipboard. Any existing content in the Clipboard is overwritten in the process (default 
key command:  Command-X).

Copy
A copy of all selected elements is placed in the Clipboard. The selected elements are 
left in place. As with Cut, the contents of the Clipboard are overwritten (default key 
command:  Command-C).

Paste
All content from the Clipboard is copied into the window with key focus. The Clipboard 
contents are not erased in the process (default key command:  Command-V).

Paste at Original Position
This command works in a similar way to Paste, but the regions or events in the 
Clipboard are always pasted to the position they were originally cut from, regardless of 
the current playhead position (which is where regions or events would be placed with 
the standard Paste function).

Paste Replace
This function only works in the Arrange and editor windows. It resembles Paste, but all 
existing regions or events in a given location are replaced by the regions or events 
being pasted.

Undoing and Redoing Editing Operations
A simple change of mind or editing mistake is an inevitable part of music production. 
Fortunately, you can backtrack your edits easily in Logic Pro—by using the Undo 
command to reverse your previous editing operation. 

To undo your last step:
m Choose Edit > Undo (default key command:  Command-Z) immediately after making 

the error.

Virtually all edits, including moves, deletions, renaming, parameter changes, creation of 
new events, regions, or channels, and more, can be undone.

The Number of Undo Steps setting in the Logic Pro > Preferences > Global > Editing 
tab determines the maximum number of possible undo steps.

The Undo History is saved with the project, making it available when reopened.

Warning:  When using this function, all regions or events that lie within the time 
period occupied by the regions or events on the Clipboard are erased.
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To open the Undo History window:
m Choose Edit > Undo History (or use the corresponding key command, 

default:  Option-Z).

The Undo History shows you a list of all actions that can be undone. The most recent 
step (editing operation), which will be the first to be undone, is selected.

To undo or redo multiple steps:
m Click on any entry to undo or redo all steps between the clicked and highlighted 

entries.

To undo or redo an isolated step:
m Command-click on the desired step.

This will undo or redo an isolated step—without influencing all steps between the 
clicked and highlighted entries. 

To erase the Undo History:
m Choose Edit > Delete Undo History.

Warning:  Please take care with this command. No undos or redos are possible for the 
deleted steps, once the Undo History has been erased.
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9 Working With Tracks

Tracks contain the audio regions and MIDI regions of a 
project.

Tracks are listed from top to bottom in the Arrange track list and extend horizontally 
across the Arrange area in lanes.

Each track is assigned to a particular channel in the Mixer. In other words, the output of 
a track is sent to a channel strip. If a track is not sent to a channel strip, regions on it 
will not be heard. 

Note:  The exception to this rule is folder tracks. For more information about folders, see 
“Using Folders” on page 338.
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Once assigned to a particular type of mixer channel, the functionality of the track is 
limited as follows:

As you can see, each track type handles different sorts of data and has a special 
purpose. This is due to the routing of each track to a specific channel type in the Mixer. 

The parameters of a track are displayed in the Inspector’s Track Parameter box. 

Important:  The parameters belong to the channel strip (or object) the track is routed 
to, not to the track per se, so if you alter the parameters here, it will affect all tracks 
assigned to this channel strip. 

Most of the functions described in this chapter are identical for external MIDI, software 
instrument, and audio tracks.

In addition to these track types, there are also tracks with very specific functions, such 
as global tracks. Global tracks—found at the top of linear editing windows—are used 
to view and edit global events, such as tempo, which affect all tracks in the 
arrangement. These track types are not covered in this chapter.

Track type Assigned to Mixer Track used for

Audio Audio channels Playback, recording, and automation of audio regions.

Instrument Instrument channels Playback, recording, and automation of MIDI data sent to 
software instruments

MIDI MIDI channels Playback, recording, and automation of MIDI data sent to 
external MIDI devices

Folder Not assigned Used as lanes for folder regions. Folder regions are simply 
containers for other regions, and are not assigned to a Mixer 
channel.

 Track Parameter box
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Configuring the Track Header
The track header of each track (shown in the Arrange area’s track list) can display a 
number of buttons beside the track name and icon. By default, this includes the Record 
Enable, Mute, and Solo buttons on all tracks, with the Input Monitoring button also 
shown on audio tracks. 

You can use the Track Configuration dialog to show or hide these, and other, track 
header elements. 

To determine the elements that are shown in the track header:
1 Open the Track Configuration dialog by doing one of the following:

Â Choose View > Configure Track Header in the Arrange area. 
Â Control-click on any track header in the track list, then choose Configure Track 

Header from the pop-up menu. 

2 Enable the desired track header elements in the Track Configuration dialog. 

Â Track Control Bars:  Turn this on to view the track control bars. These bars indicate 
tracks that are accessed by control surfaces connected to your system. Each control 
surface can be assigned a different color in the Device Parameter box. For more 
information, see the Control Surfaces Support manual. 

Node button

Protect buttonFreeze button

Input Monitoring button

Record Enable button

Solo button

Mute button

Track Color bar
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Â Track Numbers/Level Meters:  Turn on this checkbox to display a track’s number. 
During playback, a small level meter replaces the track number. For external MIDI or 
software instrument tracks, this meter indicates the velocity of the recording, and 
turns red to denote a maximum velocity value. For audio tracks, the level meter 
denotes the output level.

Â Track Icons:  Click to display or hide the track icons in the track header.
Â Names section:  Use the menus in this section to determine the names displayed in 

the track header. For more information, see “Naming Tracks” on page 191.
Â Buttons section:  Activate the checkboxes of the buttons you want to display in the 

track header. 
Â Track Color Bars:  Turn on this checkbox to show a thin color strip at the right edge of 

each track. This is a visual aid that can help you to keep track of regions that have 
been moved between tracks.

Reclaiming Workspace Used by the Track Header
Obviously, enabling all of the buttons, icons, track names, and so on can result in a lot 
of information being shown in the track header. 

To see all of this information, you can resize the track list, by dragging the top left 
corner of the Arrange area. The mouse cursor will change to a resize icon.

The downside of resizing the track list is that this reduces your working space in the 
Arrange and editing areas.

To reclaim a little more room to move, you can hide the entire Inspector area to the left 
of the Arrange and editor windows, providing more workspace for regions, events, and 
other data.

To hide or show the Inspector in the Arrange window, do one of the following:
m Click the Inspector button in the Toolbar.

m Choose View > Inspector (or use the Hide/Show Inspector key command, default:  I).
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Creating Tracks and Channels
If you want to record or play back MIDI, software instrument, or audio data in Logic Pro, 
you must first create a track. Corresponding channel strips are automatically created in 
the Mixer.

If channels of a particular type (audio channels, for example) already exist in the Mixer, 
newly created tracks will be assigned to these matching channels. 

Important:  Some of the track creation options create new channels, and others do not. 
Each is used for a different type of task. These commands have been separated below, 
and are separated by a line in the Track menu of the application.

To explain a little further:
Â You create 8 new audio tracks in the Arrange area of a project that has 24 audio 

channels already set up in the Mixer.
Â These new audio tracks are assigned to audio channels 1 to 8 in the Mixer.
Â You create a further 16 audio tracks as your project develops. These are assigned to 

audio channels 9 to 24 in the Mixer.
Â If no, or not enough, channels of the matching type exist in the Mixer, they are 

automatically created when you create new tracks. 
Â You need a further 8 audio tracks to complete your project, but have used all 24 

Mixer audio channels. No problem. Simply create the extra 8 audio tracks, and 
Logic Pro will automatically generate the corresponding audio channels in the Mixer. 
These tracks (25 to 32) will automatically be assigned to audio channels 25 to 32.

Note:  The automatic creation of corresponding channels applies to all track types—up 
to the maximum allowable number of channels!

This restriction is in the hundreds for audio and instrument channels, and in the 
thousands for MIDI channels. Your computer is likely to run out of processing power 
well before you reach this limit for each channel type.

∏ Tip:  Given the simplicity and speed of creating new channels—by creating tracks—
there’s no need to create hundreds of channels of each type in the Mixer before you 
start making music.
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Track and Channel Creation Commands
The commands and methods discussed in this section will create both tracks and 
corresponding channel strips.

To create one or more new tracks (and channels):
1 Do one of the following:

Â Choose Track > New in the Arrange area’s local menu bar (or use the Create New 
Tracks key command).

Â Click the Create Track button (the button with the plus icon above the track list).

2 In the New Tracks dialog that launches, choose the type, and type in the number, of 
tracks you want to create.

3 Activate the Open Library checkbox (if not already enabled) to automatically open the 
Library tab in the Media area. This allows you to immediately select settings for the 
track type that you have created. 

4 Click Create.

The new track is created at the currently selected track position, and all ensuing tracks 
(below it) are moved down the track list.

Using the New Tracks Dialog
The New Tracks dialog offers different options for each track type, when generating 
tracks. These are outlined below. 
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External MIDI Track Creation in the New Tracks Dialog
External MIDI tracks offer no additional options, but if External MIDI is chosen in the 
New Tracks dialog, the following applies:
Â A new MIDI multi instrument object will be created in the Environment for the first 

track, and the track will be assigned to sub-channel 1.
Â Subsequent tracks will be assigned to sub-channels of the MIDI multi instrument 

object (up to the maximum of 16).
Â If more than 16 External MIDI tracks are created, they will automatically roll-around to 

channel 1, 2, 3, and so on. These can be freely reassigned to any sub-channel. If you 
have more than one MIDI port available on your system, you can reassign additional 
tracks (above the first 16) to a second MIDI multi instrument object.

Â A channel strip is automatically generated in the Mixer for each sub-channel of each 
MIDI multi instrument object.

∏ Tip:  Once tracks are created, you can quickly reassign them to the sub-channels of any 
MIDI multi instrument object with the Library, or by Control-clicking on the track list, 
and making your choice from the Reassign Track Object menu.

Full details on setting up external MIDI sound modules and keyboards are found in 
“Setting Up External MIDI Instruments” on page 237.

Audio Track Creation Options in the New Tracks Dialog

Â Driver:  This pop-up menu allows you to select the audio hardware driver that you 
wish to use for your newly-created tracks. If you use only one hardware playback 
device, this menu won’t appear.

Â Format:  Choose Mono, Stereo, or Surround in this pop-up menu, to create multiple 
mono, stereo, or surround audio tracks. 

Â Input:  Choose the desired input or input pair. Choose Surround if you want to record 
in one of the available surround formats.
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Â Ascending checkbox:  Enable to assign these inputs—in order, from lowest to 
highest—to each track, when multiple tracks are created. This option has no effect 
when a single track is created. Should you create more tracks than you have inputs—
creating 8 tracks, when using a 4 input device, for example—tracks 1 and 5 will be 
assigned to Input 1, tracks 2 and 6 will be assigned Input 2, tracks 3 and 7 will be 
assigned Input 3, tracks 4 and 8 will be assigned Input 4. 

Â Output:  Choose the desired output or output pair. Choose Surround if you want to 
set the output to the project’s surround format.

Â Input Monitoring and Record Enable checkboxes:  Activate to switch on the track’s 
Input Monitoring and Record Enable buttons. This is handy if you intend to start 
recording immediately after track creation, for example.

Software Instrument Track Creation Options in the New Tracks Dialog

Â Multi-timbral checkbox:  Turn on to create up to 16 tracks with ascending MIDI 
channel settings (starting from MIDI channel 1, on the first track, MIDI channel 2 on 
the second track, and so on).
Â These tracks are independent of the first track, and can be individually automated, 

have different regions, and so on, but all tracks are associated with (and routed 
through) the same instrument channel in the Mixer.

Â As such, the software instrument inserted into the instrument channel must be 
multi timbral (capable of playing different sounds on different MIDI channels) for 
this option to be useful. None of the included Logic Pro instruments are multi 
timbral.

Â Output:  Choose the desired output or output pair. Choose Surround if you want to 
set the output to the project’s surround format.
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Transferring a Channel Strip Setting to a New Track
You can create a new track that uses the same channel strip assignment and settings as 
the selected track. This is a quick and easy way to create a duplicate of an existing track 
and channel strip, without replicating the data on the track.

To transfer the channel assignment to a new track:
1 Select the source track (the one with the channel strip and settings that you want to 

duplicate). 

2 Do one of the following:

Â Choose Track > New with Duplicate Setting in the Arrange area.
Â Click the Duplicate Track button above the track list in the Arrange area. 

Logic Pro creates the new track that uses the same channel assignments and settings 
directly below the source track. The data on the track (if any exists) is not duplicated.

If you want to copy a track, inclusive of any data, but do not want to copy the channel 
strip, please see “Copying Tracks and Moving Regions” on page 189.

∏ Tip:  You can double-click in the empty space below the track header of the last track, 
to create a new track. This will be of the same type as the selected track. 

Creating Tracks by Adding Apple Loops
You can also create tracks by dragging Apple Loops from the Loop Browser directly into 
a blank Arrange window area. A track and corresponding channel strip are 
automatically created, and the Apple Loop is loaded. For more details on adding Apple 
Loops, see “Finding Apple Loops in the Loop Browser” on page 262.

Creating Tracks by Adding Audio Files
You can also create tracks by dragging audio files from the Media Browser directly into 
a blank Arrange window area. A track and corresponding channel strip are 
automatically created, and a region (that is the full length of the audio file) is added to 
the new Arrange track. The audio file (and corresponding region) is also automatically 
added to the Audio Bin.
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Track Creation Commands
The commands and methods discussed in this section only create new tracks. The 
current (selected track) channel strip is used as the target for the new track.

Creating a Track With the Same Channel Assignment
There may be situations where you would like to have multiple copies of a track that 
address the same Mixer channel. 

As an example:  You may want to create multiple tracks that address a software 
instrument, such as the EXS24 mkII, with a drum kit loaded. Each track can contain MIDI 
regions that trigger individual drum sounds (kick, snare, hi-hat, and so on). Having a 
separate track for each sound allows you to independently mute or solo sounds in the 
kit. 

∏ Tip:  Use a multi output version of the EXS24 mkII if you want to individually process 
each sound in the drum kit with different effects.

To create a track with the same channel strip or instrument assignment:
1 Select the track you want to copy.

2 Do one of the following:

Â Choose Track > New with Same Channel Strip/Instrument command (default key 
command:  Control-Return) to create a new track below the selected track.

Â Use the Append Track to Track List key command to create a new track at the bottom 
of the track list.

Creating a Track With the Next Channel Assignment
The Track > New with next MIDI Channel command (default key command:  Shift-
Control-Return) creates a new track below the selected track, and assigns the next 
instrument or MIDI channel to it. If the MIDI channel of the currently selected track 
channel is 16, the first channel is re-used. 

This command is dimmed if audio tracks (or tracks that don’t provide a MIDI channel 
parameter, such as those assigned to aux channels) are selected. 

Creating Tracks With the Next Channel Strip/MIDI Channel
The Track > New with Next Channel Strip/Instrument command can either create a new 
track, or both a new track and a new channel strip. The behavior of the command is 
dependent on the selected track type:
Â If the selected track is an audio or software instrument track:  The command creates 

a new track below the selected track, and assigns the next channel strip to it. If no 
next channel strip exists, it is automatically created. 

Â If the selected track is a MIDI track:  The command behaves exactly as Track > New 
with next MIDI Channel:  A new track is created, and assigned to the next MIDI 
channel.
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Copying Tracks and Moving Regions
Hold down Option when moving a track vertically (click-drag the track number) to 
create a copy of the track at the destination position. All selected regions on the source 
track are moved to the new track. 

Note:  If you hold down Option before grabbing the track number, no further regions 
on the track will be selected. If no regions were selected in the first place, an empty 
track (assigned to the same channel as the original track) is created at the destination 
position. 

If the Cycle function is switched on, all regions within the cycle are moved from the old 
track to the new track. The musical result is unchanged, as the new track is a copy, and 
therefore inherits the channel strip output setting of the source track.

In other words, only one channel strip is used for multiple tracks. This allows you to 
double-track parts to thicken them up. It also makes tasks such as creating unison 
voicings (an octave apart) simple and quick for software or MIDI instrument tracks.

To do this, Option-drag the regions on the destination track to replicate/restore them 
on the source track.

Note:  Altering the level (or other parameters) of the channel strip, regardless of which 
track is selected, will affect all tracks routed to the channel strip.

Creating Tracks for Overlapping Regions
The Track > New for Overlapped Regions function creates new tracks for wholly or 
partly overlapped regions. The regions are redistributed across the newly created 
tracks. The number of new tracks is equal to the number of overlaps. All tracks use the 
same channel assignment as the original track. 

As above, only one channel strip is used for all tracks.

Creating Tracks for Selected Regions
The Track > New for Selected Regions function creates a new track for the selected 
regions on a track. The selected regions are moved to the new track, and removed from 
the source track. All new tracks use the same channel assignment as the original track.

If you use this command when multiple regions are selected across several tracks, a 
new track will be created for each source track. As an example:
Â Two regions are selected on track a, one region is selected on track b, four regions 

are selected on track c.
Â Following use of the command, the two regions on track a are moved to the newly 

created track a copy, the region on track b is moved to b copy, and the four regions 
of track c to c copy.
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Â If you want to create individual tracks for the two track a regions (now on track a 
copy), simply select the a copy track, which will automatically select all regions on 
the track, and repeat the command.

Deleting Tracks
If you delete a track, the channel strip assigned to the track is also deleted, and 
removed from the Mixer (unless assigned to another track that is in use). 

To delete a track, do one of the following:
m Select the track, then choose Track > Delete. 

∏ Tip:  If no regions are selected in the Arrange area, you can delete the selected track by 
pressing Backspace.

m Grab the track, and remove it from the track list by dragging it to the left.

To delete all tracks that do not contain regions:
m Choose Track > Delete Unused in the Arrange area.

Selecting a Track
You can select a track by clicking on its name or icon in the track list. 

This selects all regions on the track (or selects the regions that fall within the defined 
cycle, if Cycle mode is turned on).

∏ Tip:  If you Option-click a track, the track will be selected without affecting the existing 
selection of regions (on the selected, or other, tracks). 

You can also use the following two key commands to select the track above or below 
the selected track in the track list:
Â Select Next Track (default assignment:  Up Arrow key)
Â Select Previous Track (default assignment:  Down Arrow key)
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Rearranging Tracks
You may want to shuffle the position of tracks in the track list on occasion, to visually 
group related tracks (string section or percussion parts, for example).

To change the position of a track in the track list:
m Move the cursor over the track number. When the mouse pointer changes to a hand 

graphic, click the track number, and drag it up or down the track list. When you’ve 
reached the desired position, release the mouse button.

Subsequent tracks (if any) will be moved down the screen.

You can also sort tracks by choosing one of the following commands in the Track > 
Sort Tracks By menu:
Â MIDI Channel
Â Audio Channel
Â Output Channel
Â Instrument Name
Â Track Name

Naming Tracks
In the Track Configuration dialog, you can determine which of the following names are 
displayed in the track header:
Â Track Name:  This option allows you to manually enter a track name in the track list. 
Â Channel Strip Setting Name
Â Software Instrument Setting Name
Â Channel Strip Name
Â Channel Strip Type and Number
Â Automatic Track Name:  This option (the default) intelligently names the track, based 

on the following actions, and order:
Â If you enter a track name manually, the track name is displayed. 
Â If you loaded a channel strip setting or software instrument, the name of the 

channel strip setting or software instrument is displayed.
Â If you did none of the above, the channel strip name is displayed.
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To determine the track names you want to view:
1 Open the Track Configuration dialog by doing one of the following:

Â Choose View > Configure Track Header in the Arrange area. 
Â Control-click on any track header in the track list, then choose Configure Track 

Header from the pop-up menu. 

2 Choose the desired track name option in the first pop-up menu.

3 Enable the checkbox of the second pop-up menu to view two track names, then 
choose the desired name option.

The option chosen in the first pop-up menu is always shown to the left if both names 
are shown, divided by a line. 

You can move this dividing line by dragging the mark at the top of the track list. 

To create a track name:
m Choose Track > Create Track Name, then type in the text input field that appears.

m If the track name is already visible in the track header:  Double-click on the channel 
strip name in the track list, then type in the text input field that appears.

The new track name is displayed in place of the channel strip name, and will be used as 
the default name for newly recorded regions.

The name of the channel strip (that the selected track is routed to) is also shown in the 
Track Parameter box of the Inspector. You can rename the channel strip by clicking on 
the name.

 Channel strip name



Chapter 9    Working With Tracks 193

To delete a track name, do one of the following:
m Choose Track > Delete Track Name.

m Double-click on the track name to open the track name input box, and press Backspace 
to delete the name. 

The track (instrument or audio) channel strip name will then be used as the default 
name shown in the track list (and for newly recorded regions).

Important:  AutoName must be selected in the Track Configuration header for this 
functionality to work.

Assigning Tracks to Channels
In general, you will create new tracks when you want to record or play back new 
regions. Corresponding channel strips are automatically created in the Mixer.

In some situations, however, you may want to reassign an existing track to a different 
channel strip. As an example, reassigning the output of a software instrument track to 
another instrument channel strip. The MIDI regions on the track will be played back 
through the inserted software instrument plug-in of the second channel strip.

To reassign a track to a specific channel strip:
m Control-click the track icon or name, and choose the desired destination for the track in 

the hierarchical Reassign Track Object menu. 

Â If you want to use a track for audio region recording or playback, choose a Mixer > 
Audio channel strip as the track destination.

Â If you want to use a track for MIDI region recording or playback (via a software 
instrument), choose a Mixer > Software Instrument channel strip as the track 
destination.
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Â If you want to use a track for MIDI region recording or playback (via a MIDI sound 
generator), choose a MIDI Instr. > Model/Instrument name channel strip as the track 
destination.

To globally reassign multiple tracks that share a channel strip destination:
m Hold down Option when reassigning a track channel strip, then confirm the dialog by 

clicking the Reassign All Tracks button.

The new track destination (reassigned channel strip) will be used for every track that 
shared the original track destination in the current project (including tracks in folders). 
As an example:
Â Tracks 1 to 4 are assigned to instrument channel 6.
Â You Option-reassign one of these tracks to instrument channel 15.
Â Tracks 1 to 4 will be reassigned to instrument channel 15.

Assigning Tracks to Environment Objects
Strictly speaking, tracks don’t need to be routed to an instrument or audio channel 
strip, as you can assign any Environment object as the track destination. The track 
data could conceivably be sent to a fader object, or directly to a MIDI port, as 
examples. 

Environment objects are software representations of individual data processing 
elements. As examples of Environment objects; arpeggiators, knobs, faders, chord 
memorizers, channel splitters, and many more. These individual objects can be 
connected with each other, using virtual cables. The end result of cabling multiple 
objects is real time processing and manipulation of MIDI (and some audio) data. This 
can be as simple as a fader to control the volume of a connected MIDI synthesizer, or 
a complex rhythm generator or step sequencer—which exists as a virtual machine 
within the Environment. This machine can be called into service whenever you need 
it. (For more information, see Chapter 39, “Working in the Environment,” on 
page 857.)

Obviously, audio signals would not be understood by a MIDI sound module, so there 
is no point in routing a track that contains audio regions to an instrument channel 
strip. or vice-versa.
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Special Destinations
In addition to the normal channel strips, there are two other possible track output 
destinations:
Â No Output:  Tracks assigned as No Output send no data. This can be useful in 

situations where you want to store data (such as SysEx) that you don’t wish to send 
from Logic Pro.

Â Folder:  This setting is used when you want the track to play a folder region (see 
“Using Folders” on page 338). Normal regions will not play on a track set up for folder 
playback.

Zooming Individual Tracks
Tracks in the Arrange area can be zoomed individually—in conjunction with, or 
independent of, the global zoom tools (and waveform zoom tool) for the window. 
There is a default zoom setting for tracks, which is automatically chosen when a 
window is first opened. This is a good compromise between visibility of text and 
regions, and working space in the Arrange area.

To zoom in or out on a track:
1 Move the Pointer to the bottom left corner of a track. 

The mouse pointer will change to an index finger.

2 Click and drag to zoom in or out on this track.

The individual track zoom factor, compared to the overall window zoom level, is shown 
in the help tag while the mouse button is held.

∏ Tip:  You can zoom all MIDI or audio tracks of your project at the same time by pressing 
Command when zooming. Pressing Shift when zooming a track resets all tracks to the 
default zoom setting. 

Zooming the Selected Track Automatically
You can use the View > Auto Track Zoom setting (also available as a key command) to 
automatically enlarge the currently selected track. Use the technique described above 
to set the desired zoom level on a track. Any subsequently selected track will 
automatically zoom to this level.
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Zooming Tracks With Key Commands 
You can assign, and use, the following key commands to zoom tracks:
Â Individual Track Zoom In and Individual Track Zoom Out:  Increases or decreases the 

“individual track zoom” factor of the selected track by one. 
Â Toggle Individual Track Zoom:  Switches the selected track between its individual 

zoom level and the window zoom level. This would be useful for zooming in on a 
track to edit its automation data. After editing, use the Toggle Individual Track Zoom 
key command to return to the original zoom level. 

Â Individual Track Zoom Reset:  Resets the selected track to the window zoom level.
Â Individual Track Zoom Reset for All Tracks:  Resets all zoomed tracks to the window 

zoom level.

Assigning Track Icons
Logic Pro offers high resolution, scalable (from 128 x 128 pixels downwards), and user-
definable track icons.

To assign an icon to a track:
m Click-hold on an existing track icon in the track header or in the Track Parameter box, 

and choose the desired icon from the menu.

Note:  The Track Icons checkbox must be turned on in the Track Header Configuration 
dialog for icons to be visible. Activate the Allow Large Icons checkbox to display large 
track icons. Large icons are automatically resized and repositioned when tracks are 
zoomed.

Creating Your Own Icons
You can create your own icons for tracks. User created icons are saved in the following 
folder:  ~/Library/Application Support/Logic/Images/Icons.

These icons must have the following attributes:
Â 128 x 128 pixels in size
Â An alpha channel for transparency
Â Must be saved in the portable network graphics format (with the .png suffix)
Â Must be given a file name that starts with a three-digit number



Chapter 9    Working With Tracks 197

Note:  If this number is identical to the number of one of the built-in Logic Pro icons, 
the icon found in the user folder is given priority. 

You also have the option of directly replacing the built-in Logic Pro icons, which are 
found in the /Contents/Resources/Images folder in the Logic Pro package. 

To open the Logic Pro package:
m Right-click the Logic Pro icon in the Finder, and choose the Show Package Contents 

item from the pop-up menu.

Muting Tracks
You can use a track’s Mute button to stop it from playing. Use the Track Header 
Configuration window to show or hide the track Mute buttons.

Mute states can be independent for tracks and channel strips, through use of the 
respective M buttons in the track header, or corresponding channel strip (Arrange or 
Mixer).

The behavior of these buttons depends on the Track Mute/Solo setting chosen in the 
Logic Pro > Preferences > Audio > General tab:
Â Fast (Remote Channel Strips):  Clicking a channel strip’s Mute button switches the state 

of the associated track button, and vice-versa. 
Â CPU-saving (Slow Response):  Choose to save processing resources, and to make the 

track Mute buttons independent of the corresponding channel strips.

Note:  The Mute states of multiple tracks that are routed to the same channel strip 
are linked:  Muting the channel strip mutes all associated tracks.
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Muting When the Mute Buttons Are Hidden
If the Mute buttons are hidden—to save space—you can still mute a track to the left of 
the track number.

If you move the mouse to the left edge of the track list by the track number, the mouse 
pointer turns into a hand; a brief mouse click mutes the track (or cancels the mute if 
the track is already muted). Muted tracks are indicated by a bullet beside the track 
name.

You can also use the Toggle Track Mute key command (default:  Control-M) to mute a 
track.

Muting Multiple Tracks
If you hold Command while clicking a Track Mute button, all Track Mute buttons that 
match the status (muted or unmuted) of the clicked button are also switched. As an 
example:  If you click an unmuted Track Mute button, this track and all other unmuted 
tracks are muted.

You can also use the Toggle Track Mute of all Tracks of Folder key command.

Muting Multiple Tracks With the Same Channel Strip Destination
If you mute a track while holding Command-Option, all tracks assigned to the same 
track destination channel strip (including those in folders) are muted.

You can also use the Toggle Track Mute of all Tracks with Same Instrument of Project 
key command.

You can also click-hold the Mute button of one track, and drag the mouse up or down. 
The Mute buttons of all swiped tracks will switch to the same state. 
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Soloing Tracks
Both MIDI and audio tracks (and folders) offer Track Solo buttons. Soloing a track 
isolates it while playing—and mutes all other tracks. Use the Track Header 
Configuration window to show or hide the track Solo Buttons.

In a practical, musical situation, it can be useful to hear several tracks in isolation (bass 
and drum parts, for example) to make it easier to fit other musical parts.

Connecting the Track Solo and Channel Strip Solo Buttons
Solo states can be independent for tracks and channel strips, through use of the 
respective S buttons in the track header, or corresponding channel strip (Arrange or 
Mixer).

The behavior depends on the Track Mute/Solo setting chosen in the Logic Pro > 
Preferences > Audio > General tab:
Â Fast (Remote Channel Strips):  Clicking a channel strip’s Solo button switches the state 

of the associated track button, and vice-versa. 
Â CPU-saving (Slow Response):  Choose to save processing resources, and to make the 

Track Solo buttons independent of the corresponding channel strips.

Note:  The Solo states of multiple tracks that are routed to the same channel strip are 
linked:  Soloing the channel strip, soloes all associated tracks. 

Soloing Tracks in CPU-saving Mode
If the Track Mute/Solo preference is set to CPU-saving (Slow Response), activating any 
Track Solo button enables Solo Lock mode, and adds all regions on that track to the 
Solo Lock group. (Solo Lock mode locks the solo status of all selected regions—for full 
details, see “Using Solo Lock” on page 301.) The Transport Solo button turns yellow and 
displays a padlock icon to indicate Solo Lock mode.

Deactivating a Track Solo button removes all regions on the track from the Solo Lock 
group and—in cases where no other track’s Solo button is active—disables Solo Lock.

Disabling the global Solo (Lock) button on the Transport, sets all individual Track Solo 
buttons to the Off position.
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Soloing When the Track Solo Buttons Are Hidden
If the Track Solo buttons are hidden—to save space—you can still solo a track with the 
Solo button on the Transport bar.

Simply press the Transport Solo button, and click on the desired track.

Soloing Multiple Tracks
If you hold down Shift while the Transport Solo button is active, and click on the 
desired track names, you will solo them (when the track Solo buttons are hidden).

If you hold any modifier (except Control) while clicking on a Solo button in the track 
list, all tracks in the currently-selected display level are soloed. If they were already 
soloed, they will be unsoloed.

You can also click-hold the Solo button of one track, and drag the mouse up or down. 
The Solo buttons of all swiped tracks will switch to the same state. 

Record-Enabling Tracks
You can use a track’s Record Enable button to arm a track for recording. For more 
information about enabling tracks for recording, see Chapter 14, “Recording in 
Logic Pro,” on page 351.

Freezing Tracks
The Freeze function saves almost 100% of the CPU power required for software 
instrument and effect plug-in calculations. You can individually freeze audio or software 
instrument tracks. 

About the Freeze Function
Internally, Freeze performs individual offline bounce processes for each frozen track. All 
plug-ins of a track (including software instrument plug-ins, if applicable, along with all 
related automation data) are rendered into a freeze file.

As long as a track is frozen—following the freeze process—the freeze file will play back 
in place of the original track (and its CPU-hungry plug-ins). The original track and plug-
ins are temporarily deactivated, and use no CPU resources.

∏ Tip:  The Freeze facility also works with DSP hardware such as the PowerCore, 
LiquidMix, Duende, and UAD devices. This enables you to combine Logic Pro 
instruments and effects with those provided by the DSP hardware—even if the 
processing capacity of your computer, the DSP hardware, or both, are exceeded.
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The Freeze function always bounces the complete channel signal. If you are using more 
than one track for the same audio or instrument channel in the Arrange, then all 
(sub)tracks of this channel will be frozen, and cannot be edited independently. In other 
words, it is the channel strip that is frozen, not the track.

When to Freeze a Track
In real-world situations, Freeze allows you to:
Â Use additional effect plug-ins or software instruments in further audio or instrument 

tracks, which would normally be impossible as it would exceed the CPU processing 
limits of your computer.

Â Play back projects created on computers with greater CPU power.

Freeze is designed to circumvent very CPU-intensive processes, which are generally 
outlined as follows (from highest to lowest demand):
Â Software instruments with a complex voice architecture
Â Plug-ins with a complex structure (reverbs, filter banks, or FFT-based effects)
Â Software instruments with a simple voice architecture
Â Software sampler with active filter
Â Software sampler with inactivate filter
Â Plug-ins with a simple structure

If your computer is able to calculate all active processes in real time, it’s unnecessary to 
freeze tracks.

Freeze is recommended whenever your system processing power runs short and one, 
or multiple, existing tracks with CPU-intensive software instrument or effect plug-ins 
are in a finalized state, or at least seem to require no further changes for the 
meantime—in other words, a close to final mix.

As long as a track is frozen, its CPU usage is reduced to that of a high resolution audio 
playback track, without any effect plug-ins inserted—regardless of the number, or 
processing demands, of the plug-ins that were originally used on the track.
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How to Freeze a Track
It’s extremely easy to freeze a track:  simply activate the Freeze button—the button 
that features a small ice crystal icon (white when active). Use the Track Header 
configuration window to show or hide the Track Freeze buttons.

If you hold Command while clicking on a Freeze button in the track list, all tracks that 
contain data in the currently-selected display level (or folder) will be frozen. If the 
Freeze buttons were already enabled, they will be disabled.

You can also click-hold the Freeze button of one track, and drag the mouse up or 
down. The Freeze buttons of all swiped tracks will switch to the same state. 

Logic Pro will create freeze files after receiving the next Play command. This allows you 
to activate the Freeze buttons of multiple tracks, and render their freeze files in one go.

You can abort freeze processes by pressing Command-Period—in this scenario, the 
portion of the frozen tracks that has already been rendered will remain in the freeze 
files, and will be used for playback. Frozen tracks will remain silent beyond this point.

What Happens During a Freeze
During the Freeze process, the playhead will follow the currently rendered position. A 
floating progress bar window is also displayed.

Freeze files are always rendered between the project start and end marks—it is 
recommended that you check the project end mark in the Bar ruler before starting a 
Freeze process. 

∏ Tip:  You should adjust the end mark of the project to include feedback-dependent 
delay repetitions or reverb tails. Empty areas (digital zero) at the end of freeze files are 
automatically removed after the Freeze process.

The freeze process uses 100% of available CPU power. If, for example, a track uses 40% 
of the CPU for real time plug-in calculations, its freeze file will be created two and a half 
times faster than the real time playback speed. If the original track uses 100% of the 
CPU power, the freeze process will happen in (approximately) real time—even if offline 
bouncing is used.
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Working With Frozen Tracks
Once a track is frozen:
Â It is not possible to cut and rearrange freeze files in any way, nor is it possible to mix 

the freeze files with their originals on a single track—you can use one or the other, 
not both!

Â It is also not possible to record audio on frozen tracks. In fact, the Record Enable 
button is hidden when a track is frozen.

Â You can not edit any instrument or plug-in parameters (or related automation data). 

You can, however, still edit the following parameters of frozen tracks:
Â Effect send levels and destinations
Â Panorama and surround parameters
Â Volume, mute, and solo

This includes automation data for these parameters.

Whenever you try to edit forbidden parameters of frozen tracks, (such as plug-in 
parameters that were rendered into the freeze file), Logic Pro will display an error 
message:

Unfreezing and editing a track:
1 Click Unfreeze to deactivate the Freeze button of the track. 

The freeze file will be deleted.

Note:  The track will now use the amount of CPU processing power that it originally 
required, if you press Play.

2 You can now perform your edits, and activate the Freeze button again, if required.

Freeze Files
The temporary freeze files are saved in a folder named Freeze Files which is created in 
the root directory of your project folder. You usually won’t need to access these freeze 
files directly.

Logic Pro manages these freeze files automatically in the background:  They are created 
during the Freeze process, will play back in place of the original tracks (as long as these 
tracks are frozen), and will be deleted as soon as the Freeze button of the 
corresponding track is turned off.
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Refresh Freeze Files
The Options > Audio > Refresh All Freeze Files command refreshes the current freeze 
files. This may become necessary when global changes are made that also affect the 
playback of the frozen tracks (tempo changes, for example). 

Hiding Tracks
If there are tracks in the Arrange area that do not need to be visible (useful when 
working on very large arrangements), you can use the Hide Track function to hide 
them. Hidden tracks play back as per usual.

There is a global Hide View button in the upper left corner of the Arrange area. This is 
the H button to the right of the Catch button. 

To hide tracks:
1 Click the Hide View button to activate the Hide Track function.

Small Hide (H) buttons will appear on each track.

2 Turn on the individual Hide buttons on the desired tracks. 

3 Click the global Hide View button, and all tracks (with enabled Hide buttons) will 
disappear from the Arrange window. 

The H in the global Hide View button appears highlighted, denoting that one or more 
tracks (with active Hide buttons) are hidden.

To show hidden tracks:
m Simply re-activate the Hide View button when you wish to see the hidden tracks again.
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Hide Menu and Key Commands
There are a a couple of menu functions and key commands that relate to the Hide 
Tracks feature. 

Even when the global Hide View button is deactivated, you can still hide an individual 
track with the View > Hide Current Track and Select Next Track command (default key 
command:  Control-H). 

View > Unhide all Tracks (default key command:  Shift-Control-H) will reset the Hide 
buttons of each track, making them all visible.

Note:  Hiding tracks does not affect their playback in any way. You can also link the Hide 
functions of all tracks belonging to a group by selecting Hide in the Group Property 
Settings (for further information on groups, see “Working With Groups” on page 562). 
Another thing to keep in mind is that there is no Unhide Selected Arrange Track key 
command because there is no way that you can select a hidden Arrange track—it is 
hidden, after all …

Protecting Tracks
Tracks can be protected, thus preventing any alterations:
Â Existing regions (and their contents) cannot be altered.
Â No recording is possible on protected tracks.
Â New regions cannot be created on protected tracks.

If the Track Protect button is not visible in the track list, you can switch it on via the 
Track Header configuration window. 

Clicking the Track Protect buttons toggles between locked and unlocked mode.

Command-clicking a Track Protect button in the track list will protect all tracks in the 
currently-selected display level (or folder). If tracks were already protected, they will be 
unprotected.
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Using Track Button Slide Activation
Track buttons on arrange tracks (Solo, Mute, Hide, Track Protect, Node, Freeze) support 
slide activation, which is similar to running your finger across several channel strip 
buttons on good hardware mixing consoles. 

As a usage example of slide activation in Logic Pro, click-hold on the Mute button of 
one track, and drag the mouse up or down. The Mute buttons of all swiped tracks will 
switch to the same state. 

Simply drag over the Mute buttons of the same tracks to undo the Mute.
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10 Working With Instruments and 
Effects

Logic Pro offers an extensive range of software instruments 
and effect processing plug-ins that are inserted into channel 
strips. You can also make use of external MIDI instruments 
and effects units.

This chapter covers all important steps required for instrument and effect use in 
Logic Pro.
Â Inserting, deleting, and bypassing plug-ins
Â Loading and removing entire channel strip plug-in configurations
Â Using the plug-in window header
Â Choosing and managing plug-in settings
Â Setting up and using external MIDI instruments and effects
Â Setting up and using external ReWired applications and instruments

The relationship of Arrange window tracks and channel strips is covered at the 
beginning of Chapter 9, “Working With Tracks,” and is also touched on here.

Some additional background information on plug-in routing, and use of plug-ins from 
other manufacturers is also included in this chapter. 

Detailed coverage of the included instrument and effect plug-ins—including the use of 
all plug-in parameters—can be found in the Logic Studio Instruments and Effects 
manual.
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A Quick Mixer and Channel Strip Primer
Before discussing the use of plug-ins, a basic understanding of some key channel strip 
functions is required. Full details on all channel strip and Mixer functions can be found 
in Chapter 25, “Mixing,” on page 541.

The Mixer and Arrange channel strips deal with audio and instrument (software or 
MIDI) tracks shown in the Arrange window, plus auxiliary and output channels. Each 
track in the Arrange is represented and controlled by a channel strip. Put another way, 
the Arrange tracks are routed to specific channel strips:
Â Audio channel strips control audio tracks.
Â Instrument channels control instrument tracks (software instrument plug-ins are 

inserted into the Instrument slot of instrument channels).
Â External MIDI channels control external MIDI tracks. Data on these tracks is routed to 

a MIDI output port and channel, for control of MIDI sound modules and keyboards. 
Either the entire instrument or MIDI sub-channels can be represented and controlled. 

Mixer channels are generated automatically when you create new audio, instrument, or 
external MIDI tracks in the Arrange window.

The Arrange channel strips, shown at the bottom of the Inspector, display the audio or 
instrument channel strip of the selected track on the left hand side, and the primary 
(first) destination for this channel strip on the right hand side.
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The destination will be either:
Â An output channel strip, which represents a physical audio output (or output pair) of 

your audio interface.
Â An auxiliary channel strip (this is where you insert send effects).

For example, if send 1 of the left-hand channel strip is routed to auxiliary channel 4, the 
fourth auxiliary channel strip will be shown. Clicking Send slot 2 on the left-hand 
channel strip (routed to auxiliary 7) will update the right-hand channel to show the 
seventh aux channel strip. Selection of a particular output in the Output slot of the left-
hand channel strip will display the chosen output channel strip to the right. If the left-
hand channel strip is simply routed to an output channel, the output channel strip is 
shown by default.

You will perform most plug-in insertion, channel routing, and channel configuration 
tasks as part of your creative workflow in the Arrange window. As such, you should use 
the Arrange channel strips for all related functions discussed in this chapter, rather than 
accessing the Mixer. 

The Arrange channel strip (for the selected track) is a “mirror” of its counterpart in the 
Mixer. You can view it as a remote control for this Mixer channel, if you like.

∏ Tip:  As a shortcut, you can open the Mixer by double-clicking the icon of any track in 
the Arrange track list. The corresponding channel strip (of the clicked track) will be 
selected in the Mixer.
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Before continuing, there are three main things you need to know about audio or 
instrument channel strips:  the channel input format, the Pan control, and the Level 
fader.

Setting the Channel Input Format
The channel input format determines the mono, stereo, or surround status of the 
channel.

 Software instrument and external MIDI channels do not have a format button.

The chosen input format has an impact on two things:
Â The plug-ins shown on the channel strip will be available as:

Â Mono to mono or mono to stereo versions on mono channel strips
Â Stereo to stereo versions on stereo channel strips
Â Surround or multi-mono versions on surround channel strips

Â The Pan control determines the position of the channel signal in the stereo field.
Â On mono channels (this includes left and right input format channels), the Pan 

control determines the left/right position of the signal.
Â On stereo channels, the Pan control determines the balance between the left and 

right channel signals.

Note:  To access the surround panner, you must first set the channel output format, via 
the Output menu on the channel strip.

Format button

Pan/Balance control

Level fader

Channel Strip Settings 
menu

Instrument slot
 Output slot

 Send slot

 Insert slot
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To set the channel strip input format for the selected audio track:
m Click-hold the button directly below the level meter on the Arrange channel strip, and 

choose the desired input format from the menu.

∏ Tip:  On a stereo or mono channel, you can simply click the button to switch between 
mono or stereo. 

Â Mono:  One circle represents a mono input format. The level meter shows a single 
column.

Â Stereo:  Two, interlocked circles represents a stereo input format. The level meter 
divides into two independent columns when a stereo input format is chosen.

Â Left:  Two circles, left one filled, indicates a left channel input format. When this input 
format is chosen, the channel strip only plays the left channel of an audio file. 

Â Right:  Two circles, right one filled, indicates a right channel input format. When this 
input format is chosen, the channel strip only plays the right channel of an audio file.

Â Surround:  Five circles indicates the surround channel input format. The level meter 
divides into multiple linked columns (the number matches the project surround 
format) when the surround input format is chosen.

LeftStereo Right SurroundMono
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Setting the Channel Pan or Balance and Playback Level
You use the Pan control and Level fader to set a channel’s pan position and playback 
level.

To set the pan position (for mono input format channels) or balance (for stereo 
format channels), do one of the following:

m Click-hold on the center of the Pan control, and drag vertically. 

Â Drag upwards to move the pan or balance towards the right channel.
Â Drag downwards to move the pan or balance towards the left channel.

m Option-click on the center of the Pan control to reset it to the center position.

To set the playback level, do one of the following:
m Vertically click-drag the Level fader handle.

m Option-click on the handle to reset it to the center (0.0 dB) position.

How Mono, Stereo, and Surround Effects Are Handled
You can insert mono, stereo, or surround instances of effects into channel strips.

Only versions of the plug-in that match the channel strip input format can be inserted 
(mono to mono or mono to stereo plug-in versions in mono input format channels, for 
example).

To insert plug-ins that do not match the channel format:
m Option-click a channel Insert slot.

The Plug-in menu will display all formats the plug-in has to offer, rather than being 
limited to the matching format. Any down or up mixing that may be necessary 
happens automatically. 

Inserting, Moving, and Removing Plug-ins
Plug-ins are, broadly speaking, broken down into two categories:
Â Software instruments, which respond to MIDI note messages
Â Audio effects, which do not respond to MIDI note messages

The Audio Units format also offers two further plug-in types:
Â Generators 
Â MIDI controlled effects

As the name suggests, Generator Audio Unit plug-ins generate audio signals. In 
contrast to software instruments, however, they do not require a MIDI note message to 
be triggered.

Audio Unit MIDI controlled effects can be controlled via MIDI, unlike standard audio 
effect plug-ins. As such, they are used differently.
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Note:  Logic Pro also supports the non real time AudioSuite plug-in format in the 
Sample Editor window. For details, please see “Using AudioSuite Plug-ins” on page 518. 
Details on the use of TDM plug-ins can be found in the Logic Pro 8 TDM Guide.

Where Different Plug-in Types Can Be Used
Â Effect plug-ins can be placed in the Insert slots of all audio channel strip types (audio, 

instrument, auxiliary, output). 
Â Software instruments can only be inserted into instrument channel strips. These 

channel strips feature an Instrument slot, directly above the Output slot, which is 
used for software instrument insertion.

Â Audio Unit Generators can only be inserted into instrument channel strips.
Â Audio Unit MIDI controlled effects are inserted into the Instrument slot of instrument 

channels. The audio signal that you would like to process is then selected via the 
plug-in’s Side Chain menu. 

To insert an effect plug-in:
1 Click a channel strip Insert slot.

The Plug-in-menu appears, showing all available effect plug-ins, sorted into different 
categories.

2 Browse through the different levels of the menu and choose a plug-in name by clicking 
on it. This will load a plug-in version that matches the chosen channel strip input 
format. 

You also have the option of choosing a mono or mono to stereo version of the plug-in, 
for example, by clicking on the appropriate entry. 

Logic Pro effects are displayed in various categories such as Delay and Reverb, Audio 
Unit and TDM effects can be found in the corresponding submenus (these sub-menus 
are only displayed if plug-ins in these formats are installed on your system). 
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To insert a software instrument, Audio Unit Generator, or MIDI controlled effect:
m Click the Instrument slot of an Instrument channel strip, and choose the desired 

software instrument, Audio Unit Generator, or MIDI controlled effect (name and type) 
from the Plug-in menu.

∏ Tip:  You can simply choose an instrument name to insert the instrument in stereo on a 
stereo format channel. 

The plug-in window of the chosen instrument, effect, or generator is opened 
automatically. If you do not want the plug-in window to open automatically after 
insertion, turn off the “Open plug-in window on insertion” preference in the Logic Pro > 
Preferences > Audio > General tab. 

You can adjust all plug-in parameters in the plug-in window. For further information 
please read the section on “Adjusting Plug-in Parameters” on page 223. 

To remove a plug-in:
m Click the desired Insert or Instrument slot, and choose No Plug-in from the menu.

To replace a plug-in:
m Click on the Insert slot, and browse to the desired plug-in type.

Accessing Multiple Instrument Outputs
Logic Pro supports the multiple outputs of the EXS24 mkII, Ultrabeat, and all Audio Unit 
instruments.

One or more Multi Output options may be displayed in addition to the Mono and 
Stereo versions shown in the Instrument Plug-in menu. 
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The Plug-in menu offers additional information about an output configuration. As 
examples:
Â Instrument Name:  Multi Output (2 x stereo, 4 x mono)
Â Instrument Name:  Multi Output (4 x stereo)

Note:  Not all instruments (Logic Pro or third-party) are multi-output capable. If the 
instrument does not provide a Multi Output option, it is not equipped with multiple 
output facilities. 

To insert and set up a multi output instrument:
1 Choose the desired multi output instance in the Plug-in menu. 

Â The first two outputs of a multi output instrument are always played back as a stereo 
pair by the instrument channel that the plug-in is inserted into. 

Â Additional outputs (3 and 4, 5 and 6, and so on) are accessed via aux channel strips.

2 Within the instrument interface, you will need to set up the output routing for 
individual sounds or samples. This is generally done via a menu, that shows entries 
such as:  Main, 3-4, 5-6, and so on.
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3 Open the Mixer, and click the + button of the instrument channel that you have 
inserted the multi output instrument in (Ultrabeat, for example). 

Note:  The + button only appears on multi output instrument channels. 

An aux channel strip appears to the right of the instrument channel, already assigned 
to the inserted multi output instrument. 

4 Repeatedly click the + button to create more aux channels, for all stereo or mono 
outputs available to the instrument plug-in. 

You should only create as many aux channels as required for the number of outputs 
used by the multi output instrument.

Following the creation of the first aux channel strip for your multi output instrument, a 
– button appears beside the + button.

Click the – button to remove aux channels.
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Using the Channel EQ
The Channel EQ is an insert effect, like any other. In most mixing situations, it is used as 
the first effect on a channel, allowing you to sculpt the sound of the channel signal 
before applying other effect types.

To insert the Channel EQ, do one of the following:
m On channel strips where Insert slot 1 is not used:  Double-click the EQ area on the 

upper portion of the channel strip to place the Channel EQ in the first Insert slot.

The EQ area will change to a thumbnail view of the Channel EQ display. The thumbnails 
provide an overview of the EQ settings used in each individual channel.

m On channel strips where Insert slot 1 is used:  Option–double-click the EQ area to insert 
the Channel EQ as the first plug-in, and move all existing plug-ins of the channel strip 
one slot down (and redirecting their automation data accordingly, if necessary).

Double-clicking the EQ area on channel strips with an occupied Insert slot 1 will insert 
the Channel EQ into the next available (unused) slot.

You may freely insert the Channel EQ into any desired Insert slot as per other plug-ins. 
You’ll find it in the EQ section of the Plug-in menu. It should be noted that only the first 
(topmost) Channel EQ is displayed as a thumbnail graphic in the EQ area.

More information about the parameters of the Channel EQ can be found in the 
Logic Studio Instruments and Effects manual. 

Moving Effects and Instruments
You can use the Hand tool to move effects and instruments between channel strips. 

To move a plug-in to another Insert or Instrument slot:
1 Open the Mixer and choose the Hand tool.
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Important:  Select the plug-in name (shown on a blue label) in any used Insert or 
Instrument slot, and drag it to the desired (unused) target slot. 

During the drag and drop operation, the potential destination is displayed as an orange 
rectangle (empty slot) or line (when placing an effect between two Insert slots, see 
below). 

To copy a plug-in to another slot:
m With the Hand tool selected, Option-drag the plug-in name from any used slot to the 

desired unused target slot. 

To swap an effect plug-in with another in the same channel strip:
m With the Hand tool selected, drag the effect plug-in name from any used Insert slot to 

the desired used target slot. 

This will swap the plug-in slot positions. As an example, on a channel strip with a 
reverb, chorus, and delay inserted into slots 1 through 3, respectively; dragging the slot 
1 plug-in to slot 3 will place the reverb in slot 3, and the delay will be moved to slot 1. It 
goes without saying that altering effects positions will change the sound of the 
channel.

Note:  When the Hand tool is used to drag plug-ins between channel strips, the existing 
plug-in on the destination channel is replaced, not swapped. 

To place an effect plug-in between two Insert slots:
1 Select the Hand tool. 

2 Click-drag the plug-in name of any used Insert slot between two used Insert slots, and 
release the mouse button.

The effect is inserted into a newly created slot between the two used slots. The effects 
below the drop position (new slot) are shifted down by one.

Note:  If all 15 Insert slots are used, you can not insert any further plug-ins into the 
channel, unless replacing an existing plug-in. 

Using the Hand Tool With Modifiers
The Hand tool is the second default tool in the Mixer. Pressing Command while clicking 
switches from the Pointer tool to the Hand tool, allowing you to move plug-ins by 
Command-dragging them. Option-Command-drag plug-ins to copy them. You can also 
use the Hand tool in the Arrange channel strip by pressing Command when the cursor 
is placed over an Instrument or Insert slot.
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Loading and Removing Entire Channel Strip Configurations
The Library tab in the Media area allows you to load and save multiple plug-ins 
(inclusive of their parameter settings) into a channel strip. 

You can also do the same thing by clicking on the Settings button found at the top of 
channel strips.

You can use this facility in a number of ways, such as:
Â Setting up and storing complex multi-effect configurations—on any type of channel.
Â Setting up particular routing configurations for use with multi-output software 

instruments.
Â Copying a routing or effect configuration between projects.
Â The rapid creation of new project templates.

Channel strip settings (CST files) are channel type specific. Put another way, instrument 
channels feature a number of instrument settings (or presets), such as Bright Pop Piano 
and Hard Flanging Clav, separated into instrument, GarageBand, and Jam Pack 
categories. Audio channels offer effect routings optimized for particular instrument, 
vocal, and other processing tasks. Similarly, output and auxiliary channels provide 
channel strip settings for particular mastering or sweetening processes.

To load a channel strip setting with the Settings menu:
1 Click the Settings button at the top of a channel strip. 

A menu appears, displaying all channel strip settings available for the channel strip 
type.

2 Browse to, and select the desired setting by clicking on its name. 

To load a channel strip setting with the Library tab:
1 First, select the channel strip that you wish to use (in the Mixer, or by selecting an 

Arrange track). 
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2 Click the Library tab in the Media area to view the Library. Click the Arrange Toolbar 
Media button if the area is not visible.

The Library displays all channel strip settings available for the selected channel strip, 
sorted into category menus.

3 Browse through the category menus, then click on the desired setting name to insert 
all associated plug-ins into the selected channel strip.

To reset a channel strip setting:
m Choose Reset Channel Strip from the Channel Strip Settings menu.

To return to the previously loaded channel strip setting:
m Click the Revert button at the bottom of the Library tab. 

To delete a channel strip setting:
m Choose Delete Channel Strip Setting from the Channel Strip Settings menu. 

To select the next or previous channel strip setting, do one of the following:
m Click the Setting button and choose the Previous or Next Channel Strip Setting 

command. 



Chapter 10    Working With Instruments and Effects 221

m Use one of the following key commands:

Â Next Channel Strip Setting
Â Previous Channel Strip Setting
Â Next Channel Strip or Plug-in Setting or EXS Instrument
Â Previous Channel Strip or Plug-in Setting or EXS Instrument
This will load the previous or next channel strip setting shown in the list. This feature is 
handy when trying to find the right delay or clavinet sound, for example.

To copy and paste a channel strip setting:
m Click the Setting button and choose the Copy or Paste Channel Strip Setting item from 

the menu, as applicable.

You can also use the Copy Channel Strip Setting and the Paste Channel Strip Setting 
key commands. 

Note:  When you paste channel strips (instead of loading them), the Level fader, 
Panorama Send Level, and all routing destinations are also set according to the channel 
strip setting in the Clipboard.

To save a channel strip setting:
1 Click the Setting button and choose Save Channel Strip Setting As (or use the 

corresponding key command). 

2 In the Save Channel Strip Setting As dialog, select the appropriate sub-folder (if 
applicable), and type in a name for the channel strip setting.

As there are different classes of channel strips, a number of channel type specific sub-
folders are available in the Channel Strip Settings folder. These sub-folder structures are 
reflected in the Settings menu for each type of channel strip:

Please do not attempt to change the Channel Strip Settings folder structure. But you 
may create a new folder, if desired, and save into it. If no folder is selected, the saved 
channel strip setting will be shown directly in the Channel Strip Setting menu, below 
the functions.

You can remotely switch between channel strip settings by sending MIDI program 
change messages. This allows you to select your favorite sounds (consisting of a 
complete channel strip setting that can contain a software instrument and effect plug-
ins) by pushing a button on your MIDI keyboard. This facility is named channel strip 
performances, and is designed for live use of Logic Pro.

Important:  Only program change messages sent on MIDI channel 1 will switch 
between Channel Strip Performances. All program change messages sent on other 
MIDI channels are forwarded to Audio Units instruments, if applicable.
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Channel strip performances can be used for all audio channel strip types. They are 
saved in the Performances subfolder (in ~/Library/Application Support/Logic/Channel 
Strip Settings/Channel Strip name). The performance names start with the 
corresponding program change number (as examples:  001Piano, 045FlangeGuitar, 
111ArcoCelloHall). There are 128 performances (corresponding to 128 available program 
change events).

To create a performance setting:
1 Configure a channel strip that you would like to have available as a performance (by 

opening a channel strip setting from the factory library and making changes according 
to your needs, for example).

2 Click the Setting button, then choose Save as Performance.

3 In the ensuing dialog, enter a performance name, choose a program change number, 
and click OK. 

4 Send the program change number from your MIDI controller.

When a channel strip receives a program change message (on MIDI channel 1) that 
corresponds to an assigned performance number, it will load this performance. 

Note:  If an unassigned program change value is sent, the channel strip ignores the 
message, and the currently loaded channel strip performance setting remains in place.

All saved performance settings appear in the Performances folder of the Channel Strip 
Settings menu.
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Using the Plug-in Window
Hands-on operation of plug-ins takes place in the plug-in window. This window allows 
access to all plug-in parameters. Each instance of a plug-in has its own plug-in window, 
allowing each to have discrete settings.

The plug-in window is automatically opened when you insert a plug-in. This behavior 
can be overridden by turning off the “Open Plug-in window on insertion” checkbox in 
the Logic Pro > Preferences > Audio > General tab.

To close a plug-in window:
m Click on the X icon at the top left of the plug-in window.

Note:  Closing the plug-in window does not deactivate the plug-in.

To open a closed plug-in window:
m Double-click on an assigned Insert or Instrument slot (the name of the plug-in is shown 

on the slot).

To hide or show all open plug-in windows:
m Use the Hide/Show All Plug-in Windows key command (default:  V).

Adjusting Plug-in Parameters
This section briefly touches on interaction with common parameter elements you will 
find in Logic Pro plug-in windows. Full details on the parameters of each individual 
plug-in can be found in the Logic Studio Instruments and Effects manual.

To switch plug-in window buttons:
m Click on the button. 
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It switches to the next or previous option, or will be turned on or off. 

To adjust a parameter slider:
m Click-hold anywhere on the slider and drag up, down, left, or right. 

m Command-click anywhere in the slider’s value range to set it to the clicked value.

To adjust rotary knobs:
m Click-hold on the center of the rotary knob and drag the mouse up and down. 

m Command-click anywhere in the value circle surrounding the knob to set it to the 
clicked value.

To adjust numerical fields, do one of the following:
m Click-hold on the panel’s numerical value and drag up or down. 

m Input numerical values with the keyboard, by clicking (or double-clicking) in the field, 
and typing.

m If there are up and down arrows alongside such panels, click them to increment or 
decrement the value by one step.

m If the numerical panel opens a pop-up menu of values, choose the desired one.

To reset any parameter to its default (or centered) value:
m Option-click on it.

To make finer parameter adjustments:
m Hold Shift before clicking and dragging a control.

You can also use the mouse wheel to adjust Logic Pro plug-in parameters.
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To adjust plug-in parameters with the mouse wheel:
1 Select the desired Logic Pro plug-in parameter by clicking on it.

2 Move the mouse wheel.

∏ Tip:  You can also use the mouse pad of a MacBook or PowerBook instead of the mouse 
wheel.

Common Plug-in Window Functions
The header area at the top of the plug-in window is common to all plug-ins. It offers a 
number of important functions for plug-in use. 

To hide or show the plug-in window header:
m Click the icon at the top right of the plug-in window.

Linking the Plug-in Window
The button to the extreme left (with a chain on it) is called the Link button. 

When the Link Button Is Switched On
Â A single plug-in window will be used to display all opened plug-ins. Each time you 

open a new plug-in, the window will update to reflect the newly chosen plug-in.
Â Choosing a different Arrange track will update an open plug-in window to display 

the corresponding slot number of the newly-selected track/channel strip. 
As an example:
Â Track 1, assigned to instrument channel strip 1, has an ES1 instance loaded (in the 

Instrument slot).
Â Track 11, assigned to instrument channel strip 2, has an EXS24 mkII instance 

loaded.
Â Switching between tracks 1 and 11 will automatically update the plug-in window 

to show the ES 1 or EXS24 mkII, respectively.

When the Link Button Is Switched Off 
You can open several plug-in windows simultaneously, and these will not update to 
reflect any track or plug-in choices you may make. Each open plug-in window will, of 
course, continue to show all parameter updates and changes.

Turning Link off is handy when you want to compare the settings of two plug-ins, or 
adjust the parameters of several open plug-in windows at the same time.
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Bypassing Plug-ins
If you want to deactivate a plug-in, but don’t want to delete it or remove it from a 
channel, you can bypass it. Bypassed plug-ins do not drain system resources. 

To bypass a plug-in, do one of the following:
m Click on the Bypass button at the left of the plug-in window header.

m Option-click the appropriate Insert or Instrument slot on the desired channel strip (in 
the Mixer or Inspector). 

The Insert slot of the bypassed plug-in turns from blue to gray, indicating that the plug-
in is currently bypassed. 

Using the Settings Functions
All current plug-in parameter settings are stored with the project file, and are 
automatically recalled the next time it is loaded. You can also save and recall any 
changes you make to plug-in parameters. These are stored and recalled as individual 
settings (or presets, if you prefer) via the Settings area.

The Settings area appears to the right of the Bypass button. 

Â Next and Previous Setting buttons:  Click to load the previous or next plug-in setting.
Â Settings field:  Displays the name of the current plug-in setting. Click to access the 

Settings menu.
Â Compare button:  Click to compare a changed plug-in setting with the setting saved 

with the project. 
Â Copy and Paste buttons:  Click to copy or paste a plug-in setting. 
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To load a setting:
1 Open the Settings menu (of the plug-in window, not the Channel Strip Settings menu) 

by clicking the Settings field.

2 Do one of the following:

Â Browse to, and choose the setting you want to use from the menu or category sub-
menus.

Â Choose the Load Setting command. When used, a file selector box will open. Only 
settings for compatible plug-in types are shown. Each plug-in has its own set of 
parameters, and therefore its own file format.

Note:  You can also choose plug-in settings from the Library tab of the Media area in 
the Arrange window. See “Using the Library to Choose Plug-in Settings” on page 232.

To choose the next or previous setting, do one of the following:
m In the plug-in header, click the left arrow to choose the previous setting, or the right 

arrow to choose the following setting. 

m Make use of the following key commands:

Â Next Plug-in Setting
Â Previous Plug-in Setting 
Â Next Plug-in Setting or EXS Instrument 
Â Previous Plug-in Setting or EXS Instrument
Â Next Channel Strip or Plug-in Setting or EXS Instrument
Â Previous Channel Strip or Plug-in Setting or EXS Instrument

To replace a setting, do one of the following:
m Browse to, and choose the setting you want to use from the Plug-in settings menu.

m Choose the Load Setting command, and choose the desired setting from the file 
selector box.
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Replacing Setting-Compatible Plug-ins
When you replace a plug-in with another plug-in that is setting-compatible, the new 
plug-in automatically uses the setting of the replaced plug-in. 

As an example:  When you replace an ES2-based GarageBand instrument with the ES2, 
the inserted ES2 uses the same setting as the replaced ES2-based GarageBand 
instrument. It also works for most EXS-based GarageBand instruments, with two 
exceptions:  Hybrid Morph and Hybrid Basic.

To compare changed plug-in parameters with the original settings:
1 Make adjustments to the desired plug-in parameters.

2 Click the Compare button to switch between the originally loaded (with the project) 
and tweaked parameter settings.

This feature allows you to audition your audio or instrument track playback through 
two variations of a plug-in. The tweaked version can be saved as a new plug-in setting 
via the Settings menu, if you decide to keep it.

The Compare button compares the tweaked setting with the reference setting that was 
stored when you last saved your project—even if you have saved the setting since 
opening the project. 

This approach means that you can quickly change the reference setting by saving the 
project.

To revert to a plug-in’s factory default setting:
m Choose Reset Setting in the Settings menu.

To copy the current plug-in parameters:
m Click the Copy button in the plug-in header (or choose Copy Setting in the Settings 

menu).

This copies all parameter settings into a plug-in settings Clipboard, which is 
independent from the global Logic Pro Clipboard.

To paste copied plug-in parameters:
m Click the Paste button in the plug-in header (or choose Paste Setting in the Settings 

menu).

Note:  This only works between plug-ins of the same type (two Compressor instances, 
for example). Some plug-ins, such as the ES2 and some ES2-based GarageBand 
instruments, have a number of shared parameters, allowing you to freely copy and 
paste parameter settings between them (see “Switching the Contents of the Plug-in 
Window” on page 229).
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To save a setting, do one of the following in the Settings menu:
m Choose Save Setting:  Saves the current plug-in parameter values as the setting. This will 

overwrite the existing setting. 

m Choose Save Setting As:  Allows you to name and save a setting, inclusive of a folder 
location. You may also create a new folder in the Save As dialog, if you wish.

Note:  The folder location (existing or newly-created) must be in the associated plug-in 
folder. As an example, you could save a setting called Euro Lead in the Lead Synths sub-
folder of the ES2 folder.

To create a default setting:
m Save a setting called #default in the Settings folder of any plug-in type. 

It will always be loaded when that plug-in type is opened. The #default setting is also 
useful as a starting point when creating new plug-in settings, or fallback position when 
you’ve been experimenting.

To delete a setting:
m Choose Delete Setting in the Settings menu.

Switching the Contents of the Plug-in Window
You can reassign any open plug-in window—in two different ways—via the Show 
Channel Strip and Show Insert menus:
Â Click the Show Channel Strip menu to switch the plug-in window between all 

channels that use the same plug-in. If you have inserted the ES2 on tracks 1 and 6, 
for example, you can switch between these channel strips and adjust the parameters 
of each ES2 instance, respectively.

Â Click the Show Insert menu to switch between the plug-in slots of the selected 
channel. As an example, if a particular channel uses an equalizer and an ES2 plug-in, 
you can switch between these plug-ins. 
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Switching the Plug-in Window View Mode
Plug-in parameters can be viewed in two forms:  Controls view and Editor view. The 
Editor view shows the plug-in’s graphical interface, if it offers one. 

The Controls view displays all plug-in functions as a set of horizontal sliders, with 
numerical fields to the left of each parameter. These fields are used for both the display 
and entry of data values.

To switch between view modes:
m Choose the Controls or Editor item in the plug-in header’s View menu. 

Side Chaining Plug-ins
All plug-ins that support side chain inputs, feature an additional Side Chain menu at 
the right of the plug-in window header. This allows you to route any audio channel, 
input channel, or auxiliary channel into the plug-in, via a side chain. 

You can also route an instrument channel as the side chain signal by following these 
steps:

1 Create a send to an aux channel (say Aux 3) on the instrument channel (Instrument 5, 
for example).

2 On the audio channel that you want to process, choose the selected aux channel (Aux 
3) in the plug-in Side Chain menu. 

Once the side chain input is chosen, the plug-in processes the audio of the channel it is 
inserted in, using the trigger impulses provided by the side chain. 

Controls view Editor view
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The signal peaks of the side chain input (the sent instrument signal), combined with 
the Threshold parameter of the plug-in, determine when the plug-in is triggered.

Some Side Chaining Examples
Â A sustained pad sound is sent through a noise gate, which is triggered by a drum 

track being used as the side chain input signal. This results in a rhythmic pad sound 
which follows the signal peaks of the drum track.

Â A noise gate inserted into a bass guitar channel is triggered by the kick drum track 
via the side chain. This can tighten the timing of the bass guitar, as it follows the kick 
drum signal.

Â Side chains can also be used to blend a music mix with a voice-over. To achieve this, 
the mix needs to be routed through a compressor which, in turn, is side chained, 
using the voice-over track. In this type of setup, the music becomes softer when the 
narrator is speaking, and louder, when not. The effect is also known as ducking. 
Please note that in order for this to function, the Automatic Gain Make-up or Auto 
Gain control (if applicable to the compressor plug-in) must be disabled.

Hiding and Showing Extended Parameters
Some Logic Pro plug-ins may have additional parameters that don’t appear in the 
Editor view (the graphical interface of the plug-in). 

This is indicated by a disclosure triangle that appears at the bottom left of the plug-in 
window. 

If no disclosure triangle is visible, the plug-in has no additional parameters.

To hide or reveal the extended parameters:
m Click the disclosure triangle at the bottom of the plug-in window. 
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Using the Library to Choose Plug-in Settings
An alternative to using the Settings menu found in the plug-in window header is the 
Library tab of the Media area. 

To load a plug-in setting from the Library:
1 Click the Media button on the Arrange window Toolbar, if the Media Area is not visible, 

then click the Library tab.

2 Select the Arrange track that is routed to the channel strip that you want to adjust the 
settings of. 

3 Click the Insert or Instrument slot of the desired plug-in on the Arrange channel strip. 

The Library displays all settings available for the chosen plug-in type, sorted into 
category menus. As examples for the Compressor plug-in:  Drum Compressors, 
Instrument Compressors, Vocal Compressors.

4 Click the appropriate category menu, then click on the desired setting name to change 
the setting for the selected plug-in.

Note:  You can click the Revert button to return to the previous plug-in setting.

5 Clicking on further Insert or Instrument slots, if used, will update the Library tab to 
show all settings for the chosen plug-in type.

6 If you click on an unused Insert or Instrument slot, the plug-in menu will be shown, as 
usual. Choose a plug-in and the Library tab will update to reflect your selection. 

Library Folder and Menu Structure
Each plug-in type has a specific sub-folder (named after the plug-in) which is 
automatically created in the Plug-In Settings folder. Further sub-folders, used for 
categories, can be created inside these sub-folders. 

These folder structures are reflected in the Library tab (and Settings menu) for each 
plug-in. The Plug-In Settings folders are located in the following locations:
Â ~/Library/Application Support/Logic:  User-defined or edited plug-in settings are 

stored here. 
Â /Library/Application Support/Logic:  Factory settings are always stored here.

Plug-in settings are identified by the pst file extension.

 A white frame indicates
the Library focus.
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Learning About Effect Routings
There are two ways of sending audio to effects:  via an insert, or via an aux send.

Insert Effects
When a plug-in is inserted directly into a channel, it is termed an insert effect. All of the 
signal is processed, or put another way, 100% of the signal flows through the effect. 
This one hundred percent behavior is suitable for equalizers or dynamic effects, such as 
compressors. 

If you have enough processing capacity, you can use up to 15 insert effects on each 
channel strip. 

By default, only two Insert slots are shown on channel strips. An extra blank Insert slot 
is automatically created, as soon as all of the currently displayed Insert slots are used, 
up to the maximum allowed. 

Put another way, if you insert an effect plug-in into Insert slot 2, a third slot will be 
shown automatically. If you insert a plug-in into slot 3, a fourth will be shown, and so 
on.

Send Effects
When you use send effects, a controlled amount of the signal is sent to the effect. 
Sends are typically used for effects that you want to apply to several signals at the 
same time.

Send effects are also called bus effects, bus send or bus returns, auxiliary send or 
auxiliary returns, or simply send or returns. 

In Logic Pro, the send effect is placed in an Insert slot of an aux channel. The signals of 
the individual channels that you want to process are sent to this aux channel, using a 
bus. The amount of signal is controlled by a Send knob on each channel. The audio is 
processed by the effect inserted in the aux channel, and is mixed with the stereo 
output.

The primary advantage of this approach, over inserting effects on tracks, is efficiency. 
This method allows multiple channels to be processed by one inserted effect, which 
saves vast amounts of processing power (and your time) when compared with the 
alternative of inserting the same effect directly into multiple channels. 

Another bonus is that you can quickly switch between wet and dry versions of all 
channels that are sent to an aux channel, by simply bypassing the effect on the aux.

Similarly, you can completely change the effects configuration for multiple sent 
channels by choosing different effects for the aux channel.
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For computationally-intensive effects such as reverb, it’s always advisable to insert 
them into an aux channel. Chorus, flanger, and delay effects should also be inserted 
into an aux, if they are going to be used on more than one track.

In some cases, however, it may make musical sense to patch an effect such as a delay 
or chorus, directly into the Insert slot of an individual channel. This allows you to use 
precise settings, and colors, on individual elements of your mix.

The golden rule is that you should use whatever sounds right in your mix. There are no 
restrictions as to where effects may be used in Logic Pro.

To send a channel signal to an aux:
1 Click on a Send slot (of an audio channel, for example), and choose a bus from the 

menu.

2 Drag the Send knob to set the amount of signal that you would like to send to the aux 
channel. 

As you do so, the (send amount) value will be shown on the Send slot.

The send amount, when set to 100%, routes the entire signal from the audio or 
instrument channel to the auxiliary destination channel (see Pre and Post information 
below).

3 Insert the desired effect plug-ins, and set the required level, pan, and output settings 
for the destination aux channel.
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∏ Tip:  This is easiest to accomplish with the Arrange channel strips in the Inspector:  The 
left channel strip is the source (the audio channel from the example), and the right 
channel strip is the destination (the aux channel) for the source. If you work in the 
Mixer, you can double-click a Send slot to jump to the allocated aux channel. 

To remove a send:
m Click an active Send slot, then choose No Send from the menu.

To bypass a send:
m Option-click the Send slot. 

The Send slot background turns gray.

To normalize (reset) the send level:
m Option-click on the Send knob.

This resets the send level to 0 dB.

Post, Post Pan, and Pre Fader Aux Sends
Sends can be positioned either before (pre) or after (post) the (source) channel strip 
level fader. 

A post fader signal level, routed to a send, changes along with volume fader 
movements. If you are using the send to route a signal from the channel to a reverb 
inserted on an auxiliary channel, this means that the relationship between the original 
signal and the effect signal remains constant. When you pull the channel’s volume 
fader all the way down, the reverb disappears as well. This setting is generally the most 
useful, and is the default in Logic Pro.

If a send is set to pre fader mode, the level of the signal routed to the send remains 
constant, regardless of any volume fader movements on the source channel. The signal 
is still fed to the selected aux channel—even if the source channel’s volume fader is 
completely pulled down. Pre fader sends are mainly used for monitoring tasks; 
headphone monitoring in the studio, or foldback monitoring on stage. Pre fader sends 
are also useful when you want to hear the effect signal in isolation (without the original 
signal). The equalizer still affects the sends in pre fader mode (pre fader, post EQ).

Pre fader send Post pan send

Post fader send
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If you choose Post Pan, the signal is not only post fader, but also post pan. This means 
that the pan position of the send signal on the aux (which needs to be stereo or multi-
channel) will follow the Pan/Balance, or Surround Panner position of the channel strip.

To select one of these options in Logic Pro:
m Click on a used Send slot, and choose Post Pan, Post, or Pre at the top of the menu.

Parallel and Series Send Routings
When multiple effects are inserted into a channel strip, they are said to be routed in 
series. This term refers to the serial nature of the effects chain, where the output of one 
effect is fed into the input of the next, and so on.

When a channel strip is routed to multiple auxiliary channels via sends—with reverb, 
chorus, and delay effects assigned to aux channels 1, 2, and 3, respectively—it is said to 
be a parallel routing. 

This means that the output of the channel strip is split, and routed to three separate 
effects; one on each auxiliary channel strip. These three independent signals are sent 
back from the respective aux channels, and recombined into an output stream from 
the channel strip.

You can also direct the audio signal from the auxiliary channel strips to individual 
output channels (or other aux channels)—independently, or in combination with—the 
mixed channel strip output.

Further possibilities are afforded by combining both series and parallel routings for 
individual channels. 

Why would you route a channel strip to multiple auxiliary channels, routed back to the 
channel, to outputs, or to further aux channels?

Put simply, the sonic results of each, or combined, approaches can be very different. So 
start exploring and experimenting!
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Working With Instruments
This section deals with the use of software instruments and external MIDI sound 
generators. 

Both software and external MIDI instrument tracks are handled in an almost identical 
fashion. In fact, the MIDI regions on tracks routed to either type of channel (software 
instrument or External MIDI) can be used interchangeably. 

You can also completely reassign a track routed to an external MIDI synthesizer to one 
using software instruments, or perhaps copy the data of an external MIDI track to a 
software instrument track, resulting in layered playback of the part through both 
instruments.

Software instruments use instrument channel strips. MIDI instruments use External 
MIDI channel strips.

ReWired instruments are handled through auxiliary channel strips. Set up and use of 
ReWired instruments is covered in “Working With ReWire Applications” on page 249.

∏ Tip:  Many of the set up and routing tasks described in this section can be done once, 
and saved with a template. This means that all of these preliminary tasks can be 
bypassed the next time you load the template, so you can concentrate on creating 
music. Please see “Saving a Project as a Template” on page 153 for more information.

Setting Up External MIDI Instruments
There are several ways that you can set up, and use, external MIDI keyboards and 
modules with Logic Pro. The best way to illustrate these is with working examples. 
Please follow the steps outlined below. 

To create a new external MIDI instrument from the Arrange:
1 Click the New Tracks button (the plus sign above the track list) in the Arrange window.

2 Choose the External MIDI option, and click the Create button. 

Note:  The Open Library checkbox in the New Tracks dialog is turned on by default. 
Leave it alone, as the Library tab (that automatically opens) will make your life much 
easier.

A new track will be created in the track list, assigned to GM Device 1. 
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When you create a new External MIDI track in a project, Logic Pro will automatically 
generate a new External MIDI Multi Instrument object. This is placed on the MIDI Instr. 
layer of the Environment window. 

Choose Window > Environment to take a look at this object (see Chapter 39, “Working 
in the Environment,” on page 857 for details). 

Another thing that happens in the background is the automatic creation of Mixer 
channel strips for each of the Multi Instrument sub-channels. Click the Mixer button at 
the bottom of the Arrange window, and click the All button in the Mixer menu bar. 
You’ll see 16 channel strips, assigned to GM Device 1 to 16 (plus a couple of others for 
audio channels). 

To the right of the Arrange area, you’ll see the Library tab. It shows a list of your MIDI 
ports and other objects. Among the items listed, you’ll see the GM Device. 
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3 Click GM Device in the left column of the Library tab, and you’ll see 16 entries in the 
right column:  1 (Grand Piano), 2 (Polysynth), and so on.

4 Click the disclosure triangle to the left of the GM Device 1 entry in the Inspector (if the 
Track Parameter box is not already open). If the Inspector isn’t visible, click the 
Inspector button in the Arrange Toolbar. 

There are two parameters of particular note here:  Port and Channel (see “Setting 
External MIDI Channel Parameters” on page 244). 

5 Click on All beside the Port parameter. You will see all of your MIDI interface Out ports 
listed. As examples:  Port 1 (Unitor 8), Port 2 (Unitor 8), MIDI1 (mLan Network). If you 
choose a specific Port, say Port 1 (Unitor 8), the GM Device Multi Instrument object will 
be routed to this specific MIDI port. This mirrors the port listing shown in the left 
column of the Library tab.
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6 You’ll note that the Channel parameter is set to 1. Create a few new External MIDI tracks 
by following steps 1 and 2. You’ll note that these new tracks are called GM Device 2, 
GM Device 3, GM Device 4, and so on. Click on each of these tracks in the track list, and 
keep an eye on the Channel parameter in the Track Parameter box of the Inspector. 
Each of these tracks is routed to a sub-channel of the GM Device Multi Instrument 
object. The selection of each track is mirrored by the 16 sub-channel entries shown in 
the right column of the Library tab.

It is important to note that Logic Pro did not create a new Multi Instrument object for 
each new External MIDI track. Rather, it assigned each subsequent track to sub-
channels of the GM Device Multi Instrument object. You can create up to 16 tracks that 
are assigned on a one-to-one basis with each sub-channel of a Multi Instrument Object.

So, what happens if you need more channels, for more external MIDI synthesizers and 
modules?

You have a couple of options. The easiest way is to use the Library tab to reassign 
newly created tracks to particular MIDI ports and channels.

To reassign tracks to channels with the Library tab:
1 Create a few new External MIDI tracks in the Arrange window, following steps 2 and 3 

in the example above.

2 Click on a track, and then click on a Port and sub-channel entry in the Library tab. 

Â If you choose a sub-channel of the GM Device you will reassign the selected track to 
this sub-channel.

Â If you choose a sub-channel of a different MIDI Port, the track will be reassigned 
accordingly (Unitor 8 Port 5, sub-channel 4 as an example). Take a look at the new 
Multi Instrument object (Unitor 8 Port 5) in the Environment. 

Note:  The first time you do this for each port or sub-channel, a new multi instrument 
object will be created in the Environment (along with corresponding Mixer channels). 
Once objects have been created for all ports, the reassignment of tracks to ports or 
channels does not create new objects.

An alternative to using the Library tab for multi instrument object creation is the 
Environment.

To create a new external MIDI instrument in the Environment:
1 Open the Environment window by choosing Window > Environment (or using the 

corresponding key command, default:  Command-8). 

2 This should default to the MIDI Instr. layer, but if not, click the down arrow to the left of 
the Link button, and choose the MIDI Instr. entry.

3 Click the New menu, and take a look at the commands available. These are all 
environment objects that you can create. For now, choose Multi Instrument.
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4 The newly created multi instrument object is called (Multi Instr.). You can rename it 
later (usually after your synthesizer name; JV5080, Microwave, and so on). 

Â You will note that there are diagonal lines running through each of the 16 sub-
channel boxes. 

Â Also note that the Port and Channel parameters are shown to the left of the 
Environment window.

5 Click on the Port menu, and choose a new MIDI Out port for the Multi Instr. object. 
Ensure that this is a different port to that used by the GM Device object.

6 The last step is to activate each sub-channel. To do so, simply click on each sub-channel 
box. As you do so, the diagonal line will disappear from each.

7 Click the Mixer button at the bottom of the Arrange window, and you’ll see 16 new 
(Multi Instr.) channel strips.

∏ Tip:  Once an object has been created in the Environment (using any of the methods 
described), you can Control-click on track names in the track list. Choose the desired 
port and sub-channel from the Reassign Track Object menu to quickly reassign tracks.



242 Chapter 10    Working With Instruments and Effects

Setting Channel Parameters for Instruments
When you choose a track that is assigned to either a MIDI or software instrument 
channel strip, the Inspector’s Track Parameter box displays the parameters outlined in 
this section.

Changes to these parameters affect the entire channel strip, and all tracks routed to the 
channel strip are affected. This is an important distinction to make, as some 
parameters, such as transposition are available as both a channel and region 
parameter. To put this into context, imagine a project with 6 tracks routed to the 
EXS24 mkII (with a drum kit loaded) on instrument channel 1. You would like to 
transpose the snare drum part (played by regions on track 2) by two semitones. This 
will trigger a different snare drum sample.
Â If you use the Region Parameter box Transposition parameter for all regions on track 

2, things will go according to plan.
Â If you use the Track Parameter box Transposition parameter, the entire EXS24 mkII 

drum kit (instrument channel 1) will be affected. This will result in all regions on the 
six tracks being played back by other drum samples.

Common Instrument Parameters
The following parameters are available for both software instrument and MIDI 
instrument channel strips.

Icon
The icon used by the instrument can be changed to suit your tastes or needs. Simply 
click the icon, and choose another from the menu. A default icon is used for all internal 
Logic Pro instruments when inserted, so you can instantly recognize an EXS24 mkII or 
ES1 track.

Transposition
The Transposition parameter allows you to define the number of semitones that all 
note events will be transposed by, on output. Negative values transpose downwards.



Chapter 10    Working With Instruments and Effects 243

Velocity
The Velocity parameter allows you to increase or decrease the note on velocities of all 
note events by an amount between –99 and 99.

Key Limit
The two note values of the Key Limit parameter define a pitch range. All notes outside 
this range are ignored by the instrument.

Vel Limit
The two values of the Vel Limit parameter define a velocity range. All notes with a 
velocity that falls outside this range will not be played by the instrument.

Delay
The Delay parameter causes all MIDI events to be sent early or late, by the defined 
number of ticks (range:  from –99 to 99). This allows you to compensate for any 
differences in reaction time between your various MIDI devices, or to create offsets 
between channels. 

If you’re after rhythmic delay effects on individual parts, use the Region Parameter box 
Delay, as this allows for longer delay times, and does not affect the channel playback 
timing (all regions on the track, or other tracks routed to the same channel).

No Transpose
Turn on the No Transpose parameter to protect all MIDI regions (on any tracks routed 
to this channel) from transposition. In other words, the Region Parameter box 
Transpose parameter is ignored. This is very useful for instruments assigned to drum or 
other multi-timbral samples, as transposition will change the sounds (rather than 
merely the pitches) of these instruments.

No Reset
Turn on the No Reset parameter to prevent reset messages from being sent to this 
channel. This can be useful if controllers are being used for non-musical purposes, such 
as mixer automation. The Logic Pro > Preferences > MIDI > Reset Messages tab 
determines what reset messages are normally sent, but these messages are not sent to 
No Reset instruments.

Style 
Whenever a MIDI region is created on one of the tracks routed to a given channel, it 
will be assigned the staff style set in the Style pop-up menu. If Auto is chosen, 
Logic Pro will pick an appropriate style based on the pitch range of the notes in the 
region.

∏ Tip:  You can change a MIDI region’s staff style at any time in the Display Parameter box 
of the Score Editor. 
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Setting Software Instrument Channel Parameters
The following parameters are specific to instrument channel strips. 

MIDI Channel
This parameter sets the MIDI channel used by the software instrument. 

Value as
This switches the channel strip displays (meters and other parameters) between decibel 
(dB) and numerical (Num) values. The decibel display is the default.

Setting External MIDI Channel Parameters
The following parameters are specific to External MIDI channel strips.

MIDI Channel and Port Connection
The Port parameter defines the physical MIDI output that data is sent to. Your MIDI 
sound module is connected to this MIDI output connector. 

The MIDI channel is set with the Channel parameter. This defines the channel used for 
MIDI output by the instrument track, allowing your “real” instrument to receive the 
data.

Setting the MIDI Channel:  Multi Instruments
You can also alter the MIDI channel of an external MIDI instrument part by choosing 
another sub-channel of the current multi instrument.

A sub-channel is one of 16 possible MIDI channels or parts that can be played by a 
multi instrument object. It goes without saying that the external MIDI synthesizer 
(represented by the multi instrument object) needs to be capable of playing on more 
than one MIDI channel for sub-channel selection to be useful.



Chapter 10    Working With Instruments and Effects 245

You can’t actually change the receive channel of a sub-channel in the multitimbral 
synthesizer. This is only possible in a few models (and is not particularly useful when 
using Logic Pro, at any rate). 

If the MIDI channel is set to All, you can edit the parameters of the whole multi 
instrument object. A useful facility for globally changing the MIDI port (Port A, B, and 
so on), for example.

Program, Volume, and Pan
The Program, Volume, and Pan parameters transmit program changes, volume 
controller (CC #7), and pan controller (CC #10) information. 

If the respective box is unchecked, the default value of the MIDI device itself is used.

A program change (a preset or patch number in your MIDI module) may be selected on 
the right, via a pop-up menu. When dealing with multi instrument sub-channels, 
sounds can be selected from a pop-up menu by name. 

As an alternative, you can double-click on the track name (GM Device 1, for example). 
This launches the Multi Instrument window.

Simply click on the name of the sound (synthesizer patch) that you want to use. Click 
the close button at the top left to exit the window, or press Command-W. More details 
on this window, including customization of patch names, can be found “Using the 
Multi Instrument Window” on page 885.

To the right of the program number, there is an extra parameter which is used for Bank 
Select. If your sound source receives Bank Select messages (MIDI controller #0 or #32—
check your synth manual for format details), you can switch between different banks, 
each containing a maximum of 128 sounds. 

For more on the other instrument parameters, see “Standard Instruments” on page 880.



246 Chapter 10    Working With Instruments and Effects

Adding Program Change, Volume, and Pan Settings to a MIDI Region
The MIDI > Insert Instrument MIDI Settings as Events command allows you to insert the 
program change, volume, and pan settings (from the Track Parameter box in the 
Inspector) as actual MIDI events into one, or more, selected MIDI regions. The events 
are placed a quarter note before the beginning of the relevant MIDI regions. Only the 
activated (checked) settings in the Track Parameter box(es) are added as events. If any 
events of the same kind already exist in the region(s), they are overwritten.

The values of the Program, Volume, and Pan parameters will not be updated every time 
such control change events are played back. These parameters are initial values, when 
you load a project, or choose the MIDI > Insert Instrument MIDI Settings as Events 
command—before you begin to record mixer automation data.

Processing External MIDI Instruments With Effects
You can route external MIDI sound generators through the Logic Pro Mixer, allowing 
you to process them with Logic Pro effects. This is achieved through use of the External 
Instrument plug-in. Ideally, you will use a multi input and output audio interface, to 
avoid constant re-patching of devices.

To process external MIDI instruments with effects:
1 Connect the output (or output pair) of your MIDI module with an input (pair) on your 

audio interface.

Note:  These can be either analog or digital connections if your audio interface and 
effects unit are equipped with either, or both.

2 Create an instrument channel.

3 Click the Instrument slot, and choose External Instrument from the pop-up menu.

4 Choose the MIDI Destination from the menu in the External (instrument) plug-in 
window. 

The MIDI Destination menu will show all sub-channels of all multi instruments in the 
Environment.

5 Choose the input (of your audio interface) that the MIDI sound generator is connected 
to from the Input pop-up menu.

6 Adjust the Input Volume, if necessary.

7 Insert the desired effects in the Insert slots of the channel.
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As the track is routed to an instrument channel (which is being used for an external 
MIDI sound module), it behaves just like a standard software instrument track, which 
means that you can record and play back MIDI regions on it—with the following 
benefits:
Â You can take advantage of the sounds and synthesis engine of your MIDI module, 

with no overhead on your Macintosh CPU (apart from the effects used on the 
channel).

Â You can use insert effects, obviously, but can also use Send effects by routing the 
Instrument channel to aux channels.

Â You can bounce your external MIDI instrument parts—with or without effects—to an 
audio file, in real time. This makes the creation of a mix, inclusive of all internal and 
external devices and tracks, a one step process.

Note:  You can not use the Freeze function on such tracks, nor can you perform an 
offline bounce. 

Playing Software Instruments
Software instrument plug-ins respond to MIDI note messages, whereas effect plug-ins 
do not. 

The output signal of a software instrument is fed into the input (the Instrument slot) of 
the instrument channel strip, where it can be processed via inserted effect plug-ins, or 
sent to busses. 

Logic Pro supports up to 255 discrete instrument channels. The number of software 
instruments that you can run simultaneously is dependent on the computer processing 
resources available. 

Following the insertion of an instrument plug-in, the instrument channel can be driven 
by a recorded MIDI region, or direct MIDI input—playing your MIDI keyboard, in other 
words!

Switching Instruments to Software Instrument Live Mode
When you select a (software) instrument track, it does not immediately switch into live 
or performance mode. You must send a MIDI event before live mode is activated, but 
this takes around 100 milliseconds to engage, which is more than enough to destroy 
the timing of your first played note.

If you require perfect timing for the first played note, you need to send silent MIDI 
events in advance; press the sustain pedal, make a small move of the pitch bender or 
modulation wheel as examples. This will switch on live mode.
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Why Live Mode is Necessary
Live mode instruments need to stay in live mode while the audio engine is running 
(when Logic Pro is in play or record mode), as switching a software instrument track 
out of live mode will create a gap (or noise) in the audio stream. Obviously, this is 
unacceptable.

Software instruments that are live (ready for playing) require considerably more CPU 
power than those that are merely playing back existing regions. If the act of selecting a 
software instrument track automatically activated live mode, switching between 
multiple instrument tracks would compound the problem, possibly resulting in CPU 
overloads.

The Record button of selected software instrument tracks gives visual feedback of the 
current state of a software instrument:

Saving Software Instrument Processing Resources
The Bounce function allows the entire instrument track to be recorded as an audio file. 
This bounced audio file can then be used (as an audio region) on a standard audio 
track, allowing you to reassign the available processing power for further software 
instrument tracks. For details, please refer to Chapter 27, “Bouncing Your Project,” on 
page 601.

You can also make use of the Freeze function to capture the output of a software 
instrument track, again saving processing power. For details, please refer to “Freezing 
Tracks” on page 200.

Tuning Software Instruments
The File > Project Settings > Tuning > Software Instrument Pitch parameter remotely 
controls the main tuning parameter for all software instruments (the ES1 or EXS24 mkII, 
for example) by ±50 Cents.

By default, it is set to concert pitch A at 440 Hz. Simply drag the slider to the desired 
value. As you do so, the cent and Hz values will update.

 Instrument in live mode

 Selected instrument, not
yet in live mode
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Note:  Some Audio Unit instruments do not recognize this remote command.

No Hermode Tuning
Logic Pro allows all software instruments to be globally tuned to different tempered 
scales, including Hermode Tuning (see “What Is Hermode Tuning?” on page 947). There 
may, however, be occasions where you want individual software instruments to be 
exempt from this global tuning system. 

When File > Project Settings > Tuning > Hermode Tuning is active, a No HMT checkbox 
is visible in the Inspector Parameter boxes of all instrument channels. 

Simply click in this box to prevent the selected software instrument from following the 
global Hermode Tuning scale.

A software instrument track with an active No HMT checkbox will be played back at 
equal temperament.

This facility is ideal for an EXS drum kit that you don’t want tuned like your melodic 
software instrument parts, for example.

Working With ReWire Applications
Logic Pro acts as a host for ReWired applications such as Ableton Live and 
Propellerhead Reason. 

Important:  Start Logic Pro first, and then start your ReWire application(s). 

When these applications are run alongside Logic Pro, synchronized audio information is 
routed out of them in to aux channel strips in the Logic Pro Mixer, where it can be 
combined with other tracks, run through effects and bounced to new audio files. 

In essence, the output of these ReWired programs is handled in much the same way as 
you would deal with internal Logic Pro audio data. Synchronization is automatic, so you 
don’t really need to do much to ReWire the applications, beyond setting up aux 
channels, if desired.
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Beyond routing the outputs of ReWired applications into Logic Pro, you can also 
directly play, record, and play back the software instruments available in these 
programs. Propellerhead Reason, for example, is the software equivalent of a rack of 
synthesizers and samplers.

You can directly play each synthesizer in the Reason rack, and can record these parts as 
MIDI regions on Logic Pro tracks, much as you would with Logic Pro’s internal, or 
external MIDI, instruments.

To access a ReWired instrument:
1 Create an External MIDI track in the Arrange window.

2 Double-click the ReWire application name in the Library tab (Reason or Ableton Live, 
for example). 

This will launch the ReWired application, and a list of all available ReWire instruments 
appears in the Library.

3 Click the desired instrument track in the Library.

To manually set up an aux channel for ReWire use:
1 Click the Mixer button at the bottom of the Arrange window. In the Mixer window, 

choose Options > Create New Auxiliary Channel Strips.

2 Create as many aux channel strips as required, with the appropriate Format, Input, and 
Output settings. For this example, create a stereo channel strip, routed to Input/
Outputs 1-2. 

3 Choose the desired ReWire channel in the Input menu of the aux channel strip.

Individual RW Channel entries are available in the Channel menu. These can be 
assigned individually, to allow each ReWired channel to be routed to a particular aux 
channel in the Logic Pro Mixer. This provides extended mixing and processing options.
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Setting the ReWire Behavior
In Logic Pro > Preferences > Audio > Devices, you can choose between the following 
modes when using ReWired applications:
Â Playback Mode (Less CPU Load):  Use this mode when streaming channels via ReWire. 

This setting requires less CPU power, and should be used when playing back tracks in 
ReWired applications.

Â Live Mode (Higher CPU Load):  Use this mode when you want to play a ReWire 
instrument (an instrument running in an external ReWired application) in real time. 
This setting requires more CPU resources, but reduces latency, ensuring that the 
ReWired instrument is playable.

Working With External Audio Effects
You can use external audio effects units in a similar way to the internal Logic Pro 
effects. This is achieved with the I/O plug-in, in conjunction with a multi input/output 
audio interface.

To integrate and use an external effects unit in Logic Pro:
1 Connect an output (or output pair) of your audio interface with the input (pair) on your 

effects unit.

2 Connect the output (or output pair) of your effects unit with an input (pair) on your 
audio interface.

Note:  These can be either analog or digital connections if your audio interface and 
effects unit are equipped with either, or both.

3 Click an Insert slot of the channel you want to process with the external effects unit, 
and choose Utility > I/O.

4 In the I/O plug-in window, choose both the Output and Input (shown as numbers) that 
your effects unit is connected to.

5 Adjust the Input or Output volume as required.

When you start playback, the signal of the audio channel will be processed by the 
external effects unit.
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Some Tips for Using External Effects
Some audio interfaces feature their own routing software, which you may need to use 
to set up the chosen inputs and outputs for this type of use. Please consult the 
documentation provided by your audio interface manufacturer.

Most hardware effects units are MIDI controlled. If this is the case with your effects unit, 
you can connect its MIDI input and output cables to your MIDI interface. This enables 
you to choose effects presets, and may also allow you to remotely control, record, and 
automate the parameters of the effects unit from Logic Pro.

Using Plug-ins From Other Manufacturers
Logic Pro can act as a host for (compliant, correctly installed and authorized) Audio 
Unit effect and instrument plug-ins from other manufacturers. 

Note:  Logic Pro can also control TDM plug-ins when Pro Tools audio hardware is used. 
Details on the use of TDM plug-ins can be found in the Logic Pro 8 TDM Guide.

Important:  Logic Pro can not act as a host for plug-ins in VST or RTAS format. There are, 
however, utilities such as the VST to Audio Unit Adapter (http://www.fxpansion.com), 
that “wrap” Mac OS X versions of VST plug-ins to create virtual Audio Units. Once 
wrapped, most of these plug-ins behave, and can be used, just like Audio Units.

Loading Presets
Many plug-ins from other manufacturers use a proprietary storage format for their 
presets (the equivalent of Logic Pro plug-in settings).

In most cases, a separate Preset (or similarly named) menu will be available in the plug-
in interface. Once loaded, you can save any of these presets as a Logic Pro setting.

In all cases, the global Compare, Copy, and Paste options of the plug-in window header 
will work as they do with the native plug-ins of Logic Pro.

Working With the Audio Units Manager
Logic Pro uses the Apple AU Validation Tool to ensure that only plug-ins which fully 
comply with the Audio Unit specification are used in Logic Pro. This minimizes 
problems that may be caused by third-party Audio Unit plug-ins.

The validation process takes place automatically when:
Â Logic Pro is first opened.
Â An updated version of Logic Pro is installed.
Â You install new Audio Unit plug-ins, or update existing ones. 

You can see the results of the validation scan (for all Audio Unit and “wrapped” VST 
plug-ins) in the Audio Units Manager. 

http://www.fxpansion.com
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To open the Audio Units Manager:
m Choose Logic Pro > Preferences > Audio Units Manager in the main menu bar (or use 

the Start Audio Units Manager key command).

The results of the test are shown in the Compatibility column.

Important:  The first thing you should do is check the manufacturer’s website for 
updated versions of Audio Units plug-ins that fail validation. 

Manually Enabling Plug-ins
Audio Units plug-ins that failed the validation test, can be manually enabled by 
activating the checkboxes in the Logic and Nodes columns—but be aware that these 
plug-ins can cause problems.

If you encounter problems with manually activated failed plug-ins, click the Disable 
Failed Audio Units button.

Warning:  Use of plug-ins that have failed the validation can negatively affect the test 
results of subsequently scanned plug-ins. They can also prevent Logic Pro from 
launching, cause it to quit unexpectedly, or even lead to data loss (destroyed project 
files)!
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Disabling Plug-ins
The Audio Units Manager also allows you to disable Audio Units plug-ins that you don’t 
want to use in Logic Pro, even if they pass the validation scan. Simply uncheck the 
corresponding checkbox in the Logic or Nodes column to disable any plug-in. You can 
store your choice of Audio Units plug-ins by clicking the Done button.

Click the Reset & Rescan Selection button to rescan a selection of plug-ins, after 
installing plug-ins/updaters or moving components in the Finder, while Logic Pro or 
the Audio Units Manager are open. They will be enabled automatically, if they pass the 
validation scan.

Note:  If you press Control-Shift while opening Logic Pro, the Audio Units Safe mode 
will be used:  Only plug-ins that pass the validation test will be available; manually 
activated plug-ins that failed the validation test will not be available.
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11 Adding Pre-Recorded Media

Pre-recorded media plays an important role in modern audio 
production. Combining existing audio loops and other files 
provides a quick method for laying down song foundations. 

Logic Pro ships with a large collection of audio loops, offering a great starting point for 
many of your projects. This chapter explains how you can add pre-recorded media in 
Logic Pro, including audio and MIDI files, Apple Loops, and other common loop 
formats.

Supported File Formats
Logic Pro allows you to access any digitally stored audio recordings (audio files) on your 
hard drives, in the most common Macintosh, and several other, file formats.

Audio files imported into a Logic Pro project can be at any supported bit depth and 
sample rate. Logic Pro supports bit depths of 16, 20, and 24 bits, and sample rates of 
44.1, 48, 88.2, 96, 176.4, and 192 kHz. Logic Pro can use the file’s sample rate, or can 
perform a real time sample rate conversion (see “Setting the Project Tempo” on 
page 145).

In addition to audio files, Logic Pro can also import MIDI and project information.

You can add the following pre-recorded media file types to a Logic Pro project:
Â WAV (including Broadcast Wave), AIFF, and SDII (Sound Designer II) files
Â CAF
Â MP3 files
Â Apple Lossless files
Â AAC (MPEG Layer 4) files
Â Apple Loop files (audio and software instrument types)
Â ReCycle audio (REX, RCY)
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Logic Pro can also import Standard MIDI files (type 0 and 1), GarageBand, OMF 
Interchange, AAF, OpenTL, and XML files. These file types are usually used to exchange 
projects, however, and are therefore outside the scope of this chapter. Full details on 
importing these file types can be found in Chapter 29, “Project and File Interchange,” 
on page 625.

About Pre-Recorded Media Types Supported by Logic Pro
The following section describes all media file types supported by Logic Pro.

WAVE and AIFF Files
Wave (WAV) and Audio Interchange File Format (AIFF) audio files are very similar. They 
can be stored at different bit depths (16 and 24 bit are supported by Logic Pro), in 
mono, stereo, or surround, and at sample rates up to 192 kHz. 

Logic Pro also supports Broadcast Wave files, which can contain time stamp 
information. Files that provide time stamp information can be recognized by a clock 
symbol, shown alongside the audio region name in the Audio Bin window. 

The file extension of broadcast wave files is .wav, allowing them to be read by any 
application that supports the standard wave file format. In such programs, the 
additional Broadcast Wave file information is ignored.

Core Audio Format Files
Core Audio Format (CAF) files are containers that support integer and float PCM 
formats, A-law, u-law, and a number of others including AAC and the Apple 
Lossless Audio Codec (ALAC). Unrestricted file sizes are possible, at high sample rates 
and bit depths.

Sound Designer
Sound Designer I and II (SDII) audio files are similar in structure to AIFF files, and can 
contain time stamped region information. Use of Sound Designer format files can make 
transfers between Logic Pro and Digidesign Pro Tools software more convenient.

MP3, Apple Lossless, and AAC
MP3 and AAC files contain compressed audio information. They are usually far smaller 
than equivalent WAV, AIFF, or SDII files. This reduction in file size is due to different 
encoding techniques that “throw away” some of the audio information. As a result, MP3 
and AAC files do not sound as good as their WAV, AIFF, or SDII audio counterparts, 
dependent on the source audio material. 

Apple Lossless files also contain compressed audio information. As the name suggests, 
the compression used (ALAC) does not discard audio information in the same fashion 
as MP3 files. The sound of the compressed audio file is identical to the original 
recording.
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Apple Loops
Apple Loops are audio files that contain additional identification information; time and 
date, category, mood, key and tempo, amongst others. They also contain a number of 
transient markers, which break them down into small time slices. The standout 
advantage of Apple Loop audio files is their ability to automatically match the tempo 
and key of a Logic Pro project.

A second Apple Loop file type is also supported by Logic Pro. These contain MIDI note 
information that triggers a musical phrase or riff. The motif will be played, as is, when 
these types of Apple Loops are added to an audio track. When added to an instrument 
track in Logic Pro, however, the MIDI note information can be edited, as you would 
with any MIDI region.

ReCycle
ReCycle (REX, RCY) files are generated in Propellerhead ReCycle software. These are 
similar to Apple Loop audio files, in that they contain a number of slices, and match the 
project tempo. When imported, a small folder that contains several regions—one for 
each slice—is created. Each of these slice regions can be handled like any audio region. 
ReCycle files, unlike Apple Loop files, do not follow the project key.

Standard MIDI Files
Standard MIDI files (SMF) are, as the name suggests, a standard file format used in MIDI 
sequencers. They can be read and saved in Logic Pro. SMFs may contain note, lyric, 
controller, and SysEx data. They are added to MIDI or software instrument tracks in 
Logic Pro.

Accessing Media Files in the Browser
You first need to locate your audio and other files, before you can add them to your 
projects. The Browser is your first port of call for browsing, previewing, and searching 
for pre-recorded media.

Note:  While all supported media types can be accessed in the Browser, Apple Loops 
are best handled in the Loop Browser. Usage is covered in “Finding Apple Loops in the 
Loop Browser” on page 262.

To access the Browser in the Arrange window:
m Click the Media button in the Arrange Toolbar, then click the Browser tab (or use the 

Toggle File Browser key command).

To open the Browser as independent window:
m Choose Window > File Browser (or use the Open File Browser key command).
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Navigating in the Browser
You can switch the Browser between two views:  List and Browser view. 

Â List view displays folders and their contents in a list. You enter a folder by double-
clicking it.

Â Browser view exposes the contents of a folder in new frames to the right of the 
selected folder. You only need to click once on a folder to enter it.

To switch between List and Browser view:
m Click on the Browser button to access the Browser view. Click on the List button to 

access List view.

Navigation in the Browser is much like using the Mac OS X Finder. The method of 
navigation is the same for all file types. The the bookmark buttons, Path menu, and 
Back and Forward buttons aid navigation.

To navigate in the Browser using the bookmark buttons:
m Click one of the bookmark buttons:  Computer, Home, or Project. 

Browser viewList view

Browser buttonList button
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Â Computer:  Shows all volumes (hard disks, CDs, or DVDs) in, or attached to, the 
computer.

Â Home:  Shows all folders in your home folder.
Â Project:  Shows the contents of your project folder.

To navigate in the Browser using the Path menu:
1 Click the Path menu to display the path taken to the current folder or file. 

2 Click one of the entries in the Path menu to navigate back to clicked folder. 

To step backwards or forward through the navigation history:
m Click the Back button or the Forward button.

Searching for Files in the Browser
The Browser tab features a very sophisticated (and fast) search facility. You can use it to 
find any type of file supported by Logic Pro, on local or network attached storage 
devices.

To perform a basic search in the Browser:
1 Click the Path menu (alone, or in conjunction with the bookmark buttons) to determine 

what you’d like to search; a particular folder, the entire hard drive, user root, the 
computer, and so on. 

Restricting the search to a particular folder or volume speeds things up.

2 Type the search term into the Search field and press Return. 
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As an example, typing in 80s, with Macintosh HD chosen in the Path menu will result in 
a number of Apple Loop files being displayed in the view area.

To sort the search results:
m Click on any of the column titles to sort the file list by name, date, or size. 

∏ Tip:  You can resize columns by dragging the vertical lines between column titles. 

To clear a search term:
m Click on the small X icon at the right-hand side of the Search field.

To view recent search terms:
1 Click the magnifying glass icon at the left-hand side of the Search field. 

2 Choose any search term from the menu to display the search results.

To clear all recent search terms:
m Click the magnifying glass icon at the left-hand side of the Search field, and choose 

Clear Recent Searches from the menu. 

To perform an advanced search:
1 Click the Path menu (alone, or in conjunction with the Computer, Home, and Project 

buttons) to determine what you’d like to search.

2 Click on the + icon to the right of the Search input field. 

This will expand the search area. The menus shown in the expanded search area are 
used to narrow down, or restrict, your search to specific file types, file formats, date, 
size, and other criteria.
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By default, the Match menu specifies that all of the advanced search conditions that 
you specify must be met, in order to display matching files. You can set the Match 
menu to any if you want to display all files that match one of the specified conditions. 

3 Click the File Type menu, and change this to Format. 

Note that the right-hand menu updates (AIFF is displayed) to reflect the left-hand 
menu selection.

4 Click the + icon to the right of the AIFF menu. 

A further set of search condition menus is shown below.

5 Click the File Type menu in this second row of search conditions, and change this to 
Length. 

The updated right-hand field and menu displays 30.0 sec.

6 Highlight the 30.0 field, and type in 8.

7 Now click on the Search field, input the desired term, and press Return.

A much shorter list of AIFF files, with a length of 8 seconds, and a name that contains 
the search term will be shown.

To remove a single advanced condition row:
m Click on the – icon beside the row. 

This feature is handy when you’ve been a little too specific in your searches, and have 
received no search results. 

Note:  The row is hidden and deactivated, rather than removed completely. It can be 
restored by clicking on the + icon to the right of the row.

To return to a basic search, when several advanced condition rows are shown:
m Click the – icon to the right of the Search input field. 

All advanced condition rows will be hidden. 

To restore all advanced search condition rows:
m Click the + icon to the right of the Search input field.
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Further Information on Conditional Searches
It goes without saying that searching for a particular file in the Browser can be much 
faster than navigating to it. You can define up to ten advanced condition rows to refine 
your searches. The search rows offer the following conditions.

Finding Apple Loops in the Loop Browser
The Loop Browser only displays Apple Loop format files. You can search for Apple 
Loops, using key words for instrument, genre, mood, and other descriptors. You can 
also browse for Apple Loops in the Loop Browser.

In comparison with standard audio loops, Apple Loops have a significant 
advantage:  they can contain additional information that Logic Pro uses for a variety of 
purposes, including automatic time and pitch shifting, indexing, and searching. 

First menu Second menu Additional menus/fields

Comment contains, does not contain, is, is 
not, starts with, ends with

Input field

File Type is, is not Menu, in which you can choose between Audio, 
Movie, Project.

Format is, is not Menu, in which you can choose between the 
following options:  AIFF, Apple Loop, WAV (BWF), 
Apple Lossless, AAC, MP3, CAF, Sound Designer I, 
Sound Designer II, Logic Project, MIDI File, 
ReCycle, OMF File, AAF File, Open TL File, XML 
File, Notator SL Song
Note that AIFF format searches do not include 
Apple Loops.

Length is, is not, is less than, is greater 
than

• Numerical input field 
• Additional menu in which you can choose 
between seconds, minutes, and hours.

Modified Date is, is not, after, before Input field

Name contains, does not contain, is, is 
not, starts with, ends with

Input field

Sample Rate is, is not, is less than, is greater 
than

Menu, in which you can choose between the 
following options:  44.1 kHz, 48 kHz, 88.2 kHz, 
96 kHz, 176.4 kHz, 192 kHz.

Size is, is not, is less than, greater 
than

Â Input field 
Â Additional menu, in which you can choose 

between bytes, kilobytes, megabytes, 
gigabytes, terabytes.

Bit Depth is, is not, is less than, is greater 
than

Menu, in which you can choose between 8 Bit, 
16 Bit, and 24 Bit.
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Two important data types that Apple Loops may include are metadata tags and 
transient markers. Logic Pro uses metadata tags to help locate files when using the 
Search features of the Loop Browser. Transient markers indicate where beats occur in 
the file. Logic Pro uses this information, in conjunction with the metadata tags, to 
match the file’s tempo and key to the project tempo and key, thus ensuring the best 
possible playback quality. This functionality allows you to play back several Apple 
Loops simultaneously, and have them sound good, even if they have different tempos 
and keys.

To access the Loop Browser in the Arrange window:
m Click the Media button in the Arrange Toolbar, then click the Loop tab (or use the 

Toggle Loop Browser key command).

To open the Loop Browser as an independent window:
m Choose Window > Loop Browser (or use the corresponding key command).

Green and Blue Apple Loops
The Loop Browser contains two types of Apple Loops:  those featuring a blue sound 
wave icon and others with a green note icon. 

Both contain audio data, and both can contain additional information for time 
stretching, transposition, indexing, and searching. 

Green and blue
Apple Loops in the

Loop Browser
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Green and blue Apple Loops can be added to audio tracks, or directly to an empty 
Arrange area or track. In the Arrange area, they look like normal audio regions, but can 
be easily identified by the Apple Loop symbol in the upper right corner. They differ 
from standard audio regions in that they follow the project key and tempo. 

You can drag blue (audio) Apple Loops directly into a blank Arrange window (with no 
tracks), or to a blank area below existing tracks. An audio track and corresponding 
channel strip are automatically created, and the Apple Loop region (that is the full 
length of the file) is placed on the track. In addition, the Apple Loop file is added to the 
Audio Bin, and a corresponding region is automatically created.

Green Apple Loops are known as Software Instrument Apple Loops (SIALs). They differ 
from the blue (audio) Apple Loops in that they also contain a MIDI region plus software 
instrument and effect settings.

When Software Instrument Apple Loops are placed on instrument tracks, the region 
shown in the Arrange area can be edited just like other MIDI regions, including 
individual note editing. 

If dragged onto a blank instrument track (one with an empty channel strip), the 
corresponding instrument and effect(s) settings are automatically inserted.

You can also drag Software Instrument Apple Loops directly into a blank Arrange 
window (with no tracks), or to a blank area below existing tracks. An instrument track 
and corresponding channel strip are automatically created, and the Apple Loop is 
loaded (the instrument is inserted into the instrument channel, along with any effects, 
and the Apple Loop region is placed on the track).

Stereo Apple Loop
symbol

Mono Apple Loop 
symbol

Green Apple Loop placed on 
a software instrument track
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When you place Software Instrument Apple Loops on audio tracks, they are imported 
as audio regions (and behave like blue Apple Loops). Processing load is reduced when 
green Apple Loops are added to audio tracks.

Note:  Blue Apple Loops will not play if placed on instrument tracks.

Before Browsing or Searching for Apple Loops
When thousands of loops are installed on your hard disks, this can make finding a 
particular Apple Loop a rather daunting prospect. Fortunately, a number of options 
allow you to restrict your searching or browsing results with a number of key criteria. 

These can be used in conjunction with each other, and directly affect the results of the 
browsing and search facilities available in the Loop Browser.

To limit the loop display to a particular Jam Pack or other category:
m Choose the desired setting from the View menu. You can choose between:

Â Show All:  Choose this default option to display all Apple Loops on your system. This 
option is handy if you are unable to locate a loop that you know is installed and 
indexed on your system, but do not know what Jam Pack it belongs to.

Â My Loops:  Choose this option to display all Apple Loops in the ~/Library/Audio/
Apple Loops/User Loops/Single Files folder (~ denotes the user name).

Â Shared Loops on my Mac:  Choose this option to display all Apple Loops in the /
Library/Audio/Apple Loops/User Loops/Single Files folders. This setting is only visible 
if Apple Loops are shared with GarageBand on your system.

Â GarageBand:  Choose this option to display all Apple Loops installed with 
GarageBand.

Â Jam Pack x:  Choose this option to display all Apple Loops from a specific Jam Pack. 
Jam Packs are professionally-created genre or instrument-specific Apple Loop 
collections, available from Apple.

Â Vendor x:  Choose this option to display all Apple Loops from a specific third-party 
vendor.

Â Other:  Choose this option to display all loops that you manually added to the loop 
library by dragging them into the Loop Browser.

To limit the Loop Browser display to a particular scale:
m Click the Scale pop-up menu, and choose from:  Any, Minor, Major, Neither, and Good 

for Both. 

Use of these options limits the search for Apple Loops to the selected scale type, within 
the chosen category. As an example, if Country, Acoustic, and Relaxed categories were 
selected, you would be presented with twenty or so files that matched your choices. 
Selection of the Minor Scale setting would reduce this list to ten possible Apple Loops, 
making the task of auditioning and selecting the most appropriate material faster.
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To limit the Loop Browser display to a particular time signature:
m Choose the desired time signature from the Signature pop-up menu.

Browsing for Apple Loops
There are three browsing views available in the Loop Browser. These are the:  Column 
view, Music view, and Sound Effects view.

To switch between browsing modes:
m Click on one of the view buttons at the top right of the Loop Browser. 

The left button activates Column view, the middle button activates Music view, and the 
third button, Sound Effects view.

The Music view displays a matrix of 54 buttons, each featuring a musically-related 
category. The Sound Effects view offers effect-related category buttons such as 
Explosions, Foley, or People.

Music view Sound Effects view
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Column view offers a standard Mac OS X column file menu that is hierarchically 
separated into All, By Genres, By Instruments, By Moods, and Favorites search criteria. 

To browse for Apple Loops in Column view:
1 Click on any of the category folders shown in the left column of the folder view area. 

In this example, By Genres is chosen.

2 Click on Electronic in the second column.

3 Click on Beats in the third column. 

The value in brackets indicates the number of files that fall into this sub-category 
(Beats). The files are shown in the file list below.

To browse for Apple Loops in Music and Sound Effects view:
1 Click on any of the category buttons. 

The file list displays all Apple Loops that fall into the chosen category. The number of 
matching files is shown at the bottom of Loop Browser.

Category columns
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2 Click another category button. 

The file list updates to display all Apple Loops that fall into both categories. 

3 Click on other category button to further refine categorization. 

The number of files that match all three criteria (Guitars, Acoustic, and Country) will be 
further reduced.

Note:  A second click on any chosen category button will deselect it.

As you can see from this example, the use of multiple category buttons makes it easy 
to restrict the number of Apple Loops that are shown in the file list. This, in turn, makes 
the task of finding an Apple Loop that has a particular vibe or flavor much simpler.

To clear all category selections:
m Click the Reset button to clear all selected category buttons.

You can replace a displayed category via the shortcut menu that opens when you 
Control-click (or right-click) on any category button. 

To customize the Music or Sound Effects view:
m Control-click (or right click) on any category button, then choose from:

Â Genre:  This sub-menu offers musical categories, such as:  Rock/Blues and Electronic.
Â Instruments:  Bass, FX, Vocals, and the Textures and Jingles settings are available, 

amongst others. 
Â Descriptors:  The items in this sub-menu cover the mood of Apple Loops, and include 

Dark, Relaxed, Grooving, and others.

Auditioning Apple Loops in the Loop Browser
Regardless of the browsing (or searching) method used to find Apple Loops, you can 
preview the results in the Loop Browser.

To audition Apple Loops:
1 Click on any file name in the search results list.

It will automatically start playing in a continuous loop.

2 Click on another file name, and it will start playback. 

The Apple Loop that was playing will stop. Only one Apple Loop can be auditioned at a 
time.
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To adjust the playback level:
m Drag the level fader at the bottom of the file view area.

To adjust the playback key:
m Click the “Play in:” menu to the right of the level fader at the bottom of the file view 

area, and choose the desired key. 

This defaults to the project key, but you can also choose to audition the loop in its 
original key or any key from C to B.

To stop playback:
m Click on the speaker icon to the left of the selected Apple Loop name.

Sorting Apple Loops in the Loop Browser
You can sort the results of your search or browsing in the Loop Browser:
Â Click on any of the column titles to sort the list of results by:  Name, Match, Tempo, 

Key, and so on. 

Â Click on the arrow in any selected column title to sort the list in ascending or 
descending alphabetical, match percentage, tempo, key, beat, or favorite order.

∏ Tip:  You may freely swap column positions by click-dragging on the column name 
field, and moving it left or right. Column widths may be resized by click-dragging on 
the vertical lines that separate the column name fields.

Creating a Collection of Your Favorite Apple Loops
The Fav (Favorites) column offers a checkbox for every displayed loop. Simply check this 
box to add the loop to the Favorites category. 

This facility is ideal for compiling a collection of Apple Loops that you use regularly. As 
a producer of dance-floor music, you may often construct projects by starting with 
drum loops. You could conceivably have a basic four on the floor kick pattern, eighth 
and sixteenth note hi-hats, two or four beat snare or clap patterns, and so on, and use 
these favorite loops as a groove construction kit—at least while creating your shell 
arrangement.
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These loops can be easily replaced or added to as your project advances, but the use of 
favorites may form a great starting point for many of your songs.

Searching for Apple Loops
The Search field is used to find Apple Loops by name or partial name. It works in 
conjunction with the options discussed in “Before Browsing or Searching for Apple 
Loops” on page 265.

To search for an Apple Loop:
m Type the desired search term into the Search text field, and press the Return key. 

The search term can be alphabetical or numerical. Any files that match your search 
term will be displayed in the file list.

The Cancel button to the right (which appears as soon as any text is entered) clears any 
entered text. It also clears the search history.

The Find menu to the left (the magnifying glass) retains a history of recently used 
search terms. Click on it to select a previous search term.

Adding and Removing Audio Files
You can add audio directly to the Arrange area, or to the Audio Bin, using any of the 
methods covered in this section. 
Â The Audio Bin acts as a central repository for all audio files added to the project, 

whether or not they are used in the Arrange area. This is useful for keeping all takes 
associated with the project in one location, even if not all are actually used in the 
final production. 

Â When you add audio files to the Arrange area, they are automatically added to the 
Audio Bin—and they appear as audio regions in your arrangement. These regions 
have a default length that encompasses the entire audio file. You can resize, cut, and 
move these regions as desired in the Arrange area. 

All methods outlined in this section can be used to import:  WAV, AIFF, CAF, MP3, SDII, 
AAC, Apple Lossless, and Apple Loop files.

Apple Loops offer a few special features when added to your arrangement. For details 
see “Green and Blue Apple Loops” on page 263.

Find menu

Cancel button
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ReCycle files are handled differently. Details in “Adding ReCycle Files to Your Project” on 
page 276. 

Adding Audio Files to Your Arrangement
You can use any of the following methods to add audio files directly to your 
arrangement:
Â You can Shift-click at any position on an Arrange audio track with the Pencil tool. 
Â You can use the Import Audio File command.
Â You can simply locate (browse to or search for) the desired file names in the Browser, 

Audio Bin, or Loop Browser—or the Mac OS X Finder—and drag them into the 
Arrange area. Double-clicking a file name in the Browser will add the file at the 
current playhead position on the selected arrange track.

To add audio files to your arrangement using the Pencil tool:
1 Select the Pencil tool in the Arrange area.

2 Shift-click an audio track at the desired Arrange area position. 

3 Browse to, and select the file that you wish to insert in the Open File dialog. 

4 Click the Play button to preview the selected audio file.

The Play button is renamed to Stop. Press it to halt playback.

5 Click the Open button to add the file to the selected track, at the clicked position, in 
the Arrange area.

To add audio files to your arrangement using the Import Audio File command:
1 Select an audio track in the Arrange area.

2 Choose File > Import Audio File (or use the Import Audio File key command). 

3 Browse to, and select the file that you wish to insert in the Open File dialog. 

4 Click the Play button to preview the selected audio file.

The Play button is renamed to Stop. Press it to halt playback.

5 Click the Open button to add the file to the selected track, at the playhead position, in 
the Arrange. 

To add an audio file to your arrangement by dragging:
m Drag the desired file directly onto an audio track in the Arrange area from either the 

Browser, Loop Browser, or the Finder. 

You can drag audio files onto all track types, but playback is only possible on audio 
tracks. 
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With Automatic Track and Channel Creation
You can drag audio files directly into a blank Arrange window (with no tracks), or to a 
blank area below existing tracks. An audio track and corresponding channel strip are 
automatically created, and an audio region (that is the full length of the file) is placed 
on the track. In addition, the file is added to the Audio Bin, and the corresponding 
region is automatically created.

To add multiple audio files to your arrangement by dragging:
1 Shift-click contiguous files, or Command-click non-contiguous audio files in the Audio 

Bin, Finder, or Browser. 

2 Drag them to the desired Arrange area position, and release the mouse button.

Note:  If adding files from the Audio Bin, you can also use the Audio File > Add File to 
Arrange menu item. The playhead position determines where the first audio region is 
created.

3 Select any of the following options shown in the Add Selected Files to Arrange dialog:

Â Create new tracks:  Creates new tracks (and audio channel strips) for each dragged 
file.

Â Use existing tracks:  Sequentially places the dragged files (as regions) onto existing 
tracks, starting with the currently selected track. As an example, if three audio files 
are dragged into the Arrange area (where track 4 is selected), the first file will be 
placed on track 4, and the following two files will be placed on tracks 5 and 6.

Â Place all files on one track:  Does just this, with all files being placed sequentially (one 
after the other) on the track they are dragged on.

Â Copy audio file names to track names:  Uses the file names to rename tracks. This 
option is only available when used in conjunction with the “Create new tracks” and 
“Use existing tracks” functions.

Â Create new audio regions:  Adds the files to the Arrange area, and creates a new audio 
region for each. A numeric value will be appended to each audio region in the 
Arrange area, and a new region will be created for each file in the Audio Bin. As an 
example, a region called folk-04 will become a new region called folk-04.1. The 
original region will be retained in the Audio Bin (and Arrange, if used).
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Adding and Removing Project Audio Files
The Audio Bin acts as a central repository for all audio files added to the project, 
whether or not they are used in the Arrange area. This is useful for keeping all takes 
associated with the project in one location, even if not all are actually used in the final 
production. 

All audio file addition methods covered above will automatically place the files in the 
Audio Bin. For methods that add files directly to the Arrange area, a region associated 
with the file is automatically created in the Audio Bin.

The Audio Bin also provides facilities that allow you to add files to your project (into the 
Audio Bin), and from the Audio Bin into the Arrange area.

To use the Browser or Finder to add audio files to your project:
1 Shift-click contiguous files, or Command-click non-contiguous audio files in the Finder 

or Browser. 

2 Drag them into the Audio Bin, and release the mouse button.

Note:  If adding files from the Browser, you can also choose Add Selected Audio File to 
Bin in the action menu. 

To use the Audio Bin to add one or more files to your project:
1 Choose Audio File > Add Audio File (or use the Add Audio File key command). 

The Audio Bin file selector box opens.

2 Browse to, and select, an audio file. 

You may audition it by clicking the Play button. 

3 Click the Add button. 

The file is shown in the file view area below.



274 Chapter 11    Adding Pre-Recorded Media

4 Browse to, and select, another audio file, and click the Add button.

5 Repeat the process until all desired files are in the file view area.

6 If you accidentally add a file, select it in the file view area, and click the Remove button.

Note:  You can also add all files in a folder by selecting the folder and clicking the Add 
All button. If you accidentally add all files from the wrong folder, press the Remove All 
button to remove them from the list. This does not remove them from the hard disk.

7 Click Done to add the selected files to the Audio Bin.

Note:  Files that have already been added to the Audio Bin are dimmed, and can not be 
selected. This helps to avoid confusion, and duplication.

To remove one or more files from the current project:
1 Select the file names in the Audio Bin 

2 Press Backspace.

This deletes the file from the project, but not from the hard disk.

The only way that you can totally remove an audio file from a project is in the Audio 
Bin. Removing an audio region in the Arrange (Eraser tool, pressing Backspace) does 
not remove it from the project—it merely removes the reference to the audio file.

A Note on Importing Compressed Audio Files
Logic Pro allows you to directly play back the following compressed audio file formats:
Â AAC

Â Compression format:  MPEG4 AAC
Â Sample rates:  8 kHz, 11.025 kHz, 12 kHz, 16 kHz, 22.05 kHz, 24 kHz, 32 kHz, 44.1 kHz, 

48 kHz, 64 kHz, 88.2 kHz, or 96 kHz
Â MP3

Â 44.1 kHz files
Â Stereo files encoded at 48 or higher kbps, mono files encoded at 32 or more kbps 
Â iTunes/Logic encoded files

Â Apple Lossless files

These files are not automatically converted when imported into Logic Pro. The 
compressed audio file is added to the Arrange area, and a region that encompasses the 
complete audio file is created. You can edit this region in the same fashion as a normal 
audio region in the Arrange area:  You can cut it, loop it, rename it, and so on. 

Warning:  Take extreme care when using the Audio File > Delete File(s) command (or 
key command, default:  Control-Backspace). This not only deletes the selected file 
from the project, but also from the hard disk! Deleted audio files are moved to the 
Trash—where they remain until you empty the Trash. 



Chapter 11    Adding Pre-Recorded Media 275

Note:  It is not possible to assign fades to compressed audio files, nor can you 
destructively edit them. 

Audio regions that point to compressed audio files are denoted by the following 
symbol:

You can convert compressed AAC, MP3, and Apple Lossless audio files by doing one 
of the following:

m Select the audio regions pointing to the desired audio file in the Arrange area, then 
choose Audio > Convert Regions to New Audio Files in the local Arrange area menu 
(or use the Convert Regions to New Audio Files key command; 
default:  Option-Command-F).

The part of the audio file spanned by the audio region is converted to a new audio file. 

m Select the audio files in the Audio Bin, then choose Audio File > Copy/Convert File(s) in 
the local Audio Bin menu (or use the Copy/Convert File(s) key command).

Important:  Compressed audio files protected by the DRM (Digital Rights Management) 
scheme can not be opened in Logic Pro. Music bought in the iTunes Store is usually 
protected by DRM. 

Overview Calculation
When you add an audio file to your project, Logic Pro will automatically create an 
overview of the audio file. This is a graphic file that is used to display the waveform.

The calculation of audio file overview data is shown in a window. This calculation 
occurs in the background, allowing you to continue working with Logic Pro.

Compressed audio file 
symbol 

Waveform overview
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Enabling the “Faster overview calculation” option considerably speeds up the 
calculation, at the cost of slowing down other operations, but not blocking user 
interaction completely. Logic Pro remembers the state of the “Faster overview 
calculation” option between projects.

You can manually refresh the overview of selected files with Options > Audio > Refresh 
Overview(s) in situations where you have replaced file recordings (and used regions), or 
made edits in an external sample editor.

Adding ReCycle Files to Your Project
ReCycle is the name of a software application from manufacturer Propellerhead, which 
mainly serves as an editing and production tool for loops (repeatedly cycled audio 
files). ReCycle uses specific file formats that can be imported, and used directly by 
Logic Pro, or ReCycle files can be converted to Apple Loops.

Note:  You need to install the REX Shared Library © Propellerhead Software when using 
ReCycle files within Logic Pro. For more information on ReCycle files, see the 
Propellerhead website. 

Logic Pro can import the following ReCycle file formats:
Â Old ReCycle file:  These files have the suffix .rcy. The abbreviation for this file type 

is RCSO.
Â Old ReCycle export file:  These files have the suffix .rex. The abbreviation for this file 

type is  REX.
Â ReCycle 2.0 file:  These files have the suffix .rx2. The abbreviation for this file type 

is REX2.

To import a ReCycle file into the Arrange area:
1 Select the ReCycle file you want to import by doing one of the following:

Â Choose File > Import Audio File and select a ReCycle file instead of an AIFF, SDII, MP3, 
or WAV audio file.

Â Shift-click on an audio track with the Pencil tool and select a ReCycle file.
Â Drag a ReCycle file from the Finder onto an audio track.

2 Choose the desired settings in the Import ReCycle file dialog, then click OK.

Â Don’t Fix:  Imports the file as is. All slices of the file will overlap, to match the tempo 
of Logic Pro.
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Â Add tracks:  Distributes the slices across multiple audio tracks, allowing you to adjust 
the position or delete slices freely. The “Number of Additional Audio Tracks” field 
determines how many tracks are used for the distribution of the slices. These tracks 
are in addition to the original track that the ReCycle file was added to.

Â Crossfade:  All slices of the file are imported to the same track, and are automatically 
crossfaded. The length of the crossfade is determined by the value (shown in 
milliseconds) displayed in the Crossfade Length field. 

Â Render into single file:  This function writes all ReCycle slices into a single audio file. 
The current Logic Pro project tempo is used for the rendering process.

Â Render to Apple Loop:  Imports the ReCycle file as an Apple Loop. 

If you do not import the ReCycle file as an Apple Loop or audio file, Logic Pro will 
create a ReCycle file folder on an audio track. This folder contains slices (you can view 
them as miniature regions in the folder) of the ReCycle file at appropriate positions.

Each of these slices references the same audio file, which can be found in the Audio 
Bin.

Note:  If you move the ReCycle file folder to another audio track, the audio channel strip 
destination (of the track inside the folder) will not change accordingly! You will need to 
open the folder and change the audio channel strip destination manually, to hear the 
ReCycle audio data.

To convert a ReCycle file to an Apple Loop, do one of the following:
m Use the Render to Apple Loop option in the ReCycle file import dialog.

m Choose the Convert ReCycle Files/Folders to Apple Loops command in the Browser’s 
Tool menu.

The latter option allows you to choose one or more folders in the Browser, and perform 
a batch conversion on all ReCycle files contained in them.

ReCycle slices

ReCycle folder
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Moving Audio Between Logic Pro and ReCycle
You can transfer data from Logic Pro to ReCycle, and back, without using any file 
selector dialogs.

To copy audio regions into the Clipboard for use in ReCycle:
1 Select an audio region in the Arrange area.

2 Choose Audio > Copy as ReCycle Loop in the Arrange menu. 

The data of the selected audio region is copied into the Clipboard.

3 Use the “Paste as new Document” command in ReCycle to create a new ReCycle 
document (containing the audio data selected in the Arrange area).

Note:  The size of the transferred audio region is limited to 10 MB, which should be 
sufficient for most ReCycle loops (an eight bar stereo loop in 4/4 at 70 bpm uses 
approximately 5 MB, for example).

To paste ReCycle loops from ReCycle into the Arrange area:
1 Use the Copy Loop command in ReCycle. 

This copies the loop currently being edited in ReCycle into the Clipboard.

2 Choose Audio > Paste ReCycle Loop in the Arrange menu to paste this loop into the 
Arrange area. 

The result is the same as the ReCycle file import options.

Adding MIDI and Project Files
You can also add MIDI and project files (such as OMF Interchange, AAF, OpenTL, and 
XML files) to your arrangement. These file types are usually used to exchange projects, 
however, and are therefore outside the scope of this chapter. Full details on importing 
these file types can be found in Chapter 29, “Project and File Interchange,” on page 625.
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12 Getting to Know Regions

When audio or MIDI files are added to, or recorded in, the 
Arrange area, they are displayed as regions.

This chapter covers the similarities and differences between audio and MIDI regions, 
and provides advanced information on region handling. Details on using regions to 
construct your songs can be found in Chapter 13, “Creating Your Arrangement,” on 
page 293.

What Are Regions?
Audio and MIDI data handling is very similar in the Arrange area, via rectangular blocks 
called regions. These blocks are graphical representations of data. Audio regions 
represent audio data. MIDI regions represent MIDI data.
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Audio Regions and Audio Files
Audio regions simply refer to (point to) an underlying audio file. Audio regions are 
merely used as playback markers (start and end points) that can be as long as the 
entire audio file, or may only be a few seconds long, playing a small portion of the 
audio file that the (region) start and end markers encompass. 

Any audio file used in Logic Pro (added to the project, and therefore the Audio Bin) is 
automatically linked to at least one audio region that defaults to the length of the 
entire audio file.

Audio regions contain a temporal reference point called the anchor. When you move 
an audio region, it’s not the start point that is displayed in the help tag (as with MIDI 
regions)—it’s the anchor point.

You can freely create as many audio regions as needed. To give you an example of 
where this may be useful, imagine a live stereo drum track that runs for the duration of 
your project. During the second chorus, the drummer played perfectly, but was a little 
sloppy during all other chorus sections. 

Logic Pro allows you to create an audio region that points to the second chorus section 
of the overall (drum track) audio file, and use this perfect take in multiple places in the 
project. 

This is achieved by creating one audio region (that points to chorus 2 in the drum track 
audio file), and copying it to each position that the chorus occurs in the Arrange area.

A great benefit of working with audio regions, rather than audio files is that they use 
very little memory, whereas multiple copies of the same section of the audio file would 
require a lot of hard disk storage space.

Audio region 1

Audio file

Audio region 2

Audio
region 3
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It is, of course, possible to directly edit, copy, move, and manage audio files. This is 
achieved in the Sample Editor and Audio Bin. Details found in Chapter 24, “Managing 
Audio Files,” on page 529.

MIDI Regions and Events
MIDI regions actually contain MIDI data events. They are not related to information 
stored in external files. MIDI regions can be saved as individual files, but they can also 
be, and generally are, stored with the Logic project. 

The MIDI data events stored within MIDI regions can include; note, controller, system 
exclusive, and other information. These data events represent MIDI performances that 
you have recorded or imported into Logic Pro. MIDI performances are generally created 
with a MIDI keyboard, but can certainly be generated with MIDI controllers, MIDI 
guitars, your computer keyboard or the mouse.

MIDI data events can be affected as a group by processing the MIDI region that 
contains them. Such processing—which takes place in the Inspector Region Parameter 
box—includes; transposition, quantization, timing delays, and more.

You can also edit individual events within a MIDI region. This is achieved by opening 
the region in one of the MIDI editors available in Logic Pro. These editors allow you to 
precisely alter the position, length, and pitch of MIDI note events. Other MIDI event 
types can also be altered in various ways. You can also enter MIDI data with your MIDI 
keyboard, the mouse, or computer keyboard in these editors.

Folder Regions
A folder is a region that can contain other regions, much like a folder in the Finder can 
contain other folders or files.

One way to visualize a folder is as a project within a project. A folder can contain as 
many tracks, featuring regions, as required. 

A folder is placed on a track assigned to a folder in the track list, rather than an 
instrument or audio track. Folder regions look like MIDI regions, but have a folder icon 
before the folder name. 
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When opened, folders look just like the Arrange area and track list of a project.

Cloned and Alias Regions
Aliases can be created for MIDI regions and folder regions. A MIDI or folder region alias 
is like an alias in the Finder. It looks like a region, but contains no actual data. It is just a 
reference to the data of the original region—a virtual reflection of the original. You can 
easily recognize an alias because its name is written in italics.

If the data in the original (source) region is altered, this immediately affects all aliases of 
the region. Each alias has independent region parameters, however. 

Clones can be created for audio regions (by Option-Shift-dragging). These are 
comparable to MIDI region aliases, but differ in that adjustments to the start or end 
points of any cloned region will affect all other cloned regions in the same way. 
Adjustments to the source region do not affect clones.

You can, of course, create independent copies of audio regions (by Option-dragging), 
which can be adjusted without affecting other copies or the source region.

Please see Chapter 13, “Creating Your Arrangement,” on page 293, for further details.
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MIDI and Audio Regions Compared
The following overview sums up the main differences between audio and MIDI regions. 
There are some notes at the bottom of the table to clarify the most important points.

Naturally, some of the Inspector playback parameters (such as Transposition) that can 
be applied to MIDI events have no effect on audio signals. Equivalent operations for 
most of these are available as destructive edit operations in the Sample Editor.

Feature MIDI regions Audio regions

Composed of discrete data Yes No. Audio regions are just references to parts of 
audio files.

Can be named Yes Yes

Loop option available Yes Yes

Quantize parameter available Yes No, but the position of regions themselves can be 
quantized, using the Event List (when at the 
Arrange display level). You can also quantize 
audio files destructively in the Sample Editor.

Transposition parameter available Yes No, but you can use the Time Machine and Pitch 
Shifting functions (in the Sample Editor and 
Arrange). Audio Apple Loops can be transposed.

Velocity parameter available Yes No

Dynamics parameter available Yes No

Gate Time parameter available Yes No

Delay parameter available Yes Yes

Can be freely positioned Yes Yes

Left or right corner edit Yes Yes, and this affects the audio region, but not the 
position of the audio waveforms relative to the 
time axis of the sequencer

Can be cut with the Scissors tool Yes Yes, creates a new audio region.

Can have aliases made of them Yes Yes, although these are known as cloned (audio) 
regions, to differentiate them from alias (MIDI) 
regions.

Left corner may be dragged to 
conceal data at beginning

No Yes

Have a variable musical reference 
point

No Yes, a variable anchor. This affects all regions 
derived from a given audio file, and can change 
the position of the audio, relative to the time axis 
of the sequencer

Can be turned off with the Mute 
function

Yes Yes

Can be placed in folders Yes Yes

Can be soloed Yes Yes
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The fundamental functions (such as a freely determinable position and length, the 
ability to create complex arrangements with the aid of folders, and the ability to name, 
mute, and solo) are generally available to all types of regions (MIDI regions, audio 
regions, folder regions, or copies of these, and alias or cloned regions).

Handling Regions in the Audio Bin and Sample Editor
You can use the Audio Bin to manage your regions and to make rough edits to the 
region (or regions) associated with an audio file. The graphic display in the Audio Bin is 
optimized for quick and simple organization of audio files and regions. 

The finest resolution for positioning the region start and end markers, or the anchor, is 
limited to 256 sample steps in the Audio Bin. This is usually adequate, particularly if 
search zero crossings is switched on. 

On occasion, however, you will need to make very accurate adjustments—down to the 
individual sample word level. Drum loops are a good example. The Sample Editor is 
best-suited to these types of precision editing tasks. 

To open the Sample Editor for a particular region:
m Double-click on the region in the Audio Bin or Arrange area.

The Sample Editor will open—with the entire region selected. 

Managing Regions in the Audio Bin
The Audio Bin lists all audio files and regions that have been added to or recorded in 
your project. 

This section covers region handling options available in the Audio Bin tab and the 
Audio Bin window. 

The audio file operations and options of the Audio Bin are discussed in Chapter 24, 
“Managing Audio Files,” on page 529, although some of the basics are covered here.
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Which Audio Bin Should You Use?
The Audio Bin tab is ideal for quickly adding files to the Arrange area, as it doesn’t 
obscure your workspace. A bar is shown for each audio file, which represents the 
overall length of the file. A colored area within the bar represents the region length. 
Tasks such as resizing or moving regions within the audio file can not be performed in 
the Audio Bin tab. If you need to make these types of adjustments, use the Audio Bin 
window.

The Audio Bin window, which can be freely resized, displays audio files as waveform 
graphics. Regions within audio files are highlighted. Further file details, including the 
full file path, are shown in the Audio Bin window. Also displayed is the Options menu, 
which contains the Strip Silence command.

In short, the Audio Bin tab is best-suited to tasks such as adding audio files and regions 
while creating your arrangement. The Audio Bin window is your first port of call for 
audio file and region management tasks.

To open the Audio Bin tab:
m Click the Audio Bin tab in the Media area of the Arrange window.

Audio Bin tab Audio Bin window
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To open the Audio Bin:
m Choose Window > Audio Bin (or use the corresponding key command, 

default:  Command-9).

To view a region associated with an audio file:
m Click the disclosure triangle beside the audio file name. 

All regions are listed below the parent audio file name.

Â Regions that are used in the Arrange area are indicated by a colored bar to the right 
of the region name. The bar color is derived from the Arrange region color. The 
length of the region (colored section) is shown proportionately against the audio file 
bar.

Â Regions that are not used in the Arrange area are gray.

To see all regions in the Audio Bin, do one of the following:
m Choose View > Show All Regions (or use the Show All Regions key command).

m Option-click the disclosure triangle beside any audio file. 

This instantly displays all regions—of all audio files in the Audio Bin.

Choosing View > Hide all Regions (using the corresponding key command), or a 
second Option-click (on any audio file disclosure triangle) will hide all regions.

To sort an audio file’s regions:
m Select the desired audio file, then choose View > Sort Regions By:

Â Start Point:  The regions are sorted according to their time position in the audio file. 
Â Length:  The regions are sorted according to their respective lengths.
Â Name:  The regions are sorted alphabetically. This is the default setting.

To change the length display of regions in the Audio Bin window:
m Choose one of the following settings in the View > Show Length As menu:

Â None:  The length is not displayed.
Â Min : Sec : Ms:  Displays the absolute time of the region in hours, minutes, seconds, 

and milliseconds.
Â Samples:  Displays the number of sample words in the region.
Â SMPTE Time:  Displays the SMPTE length, which unlike absolute time, uses frames and 

bits in place of milliseconds.
Â Bars/Beat:  The region is displayed in musical units:  bars : beats : divisions : ticks. If 

the project tempo, time signature, or division settings are altered, the display is 
automatically recalculated.

To check the number of times a region is used in your arrangement:
m Activate the View > Show Region Use Count setting. 
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Creating and Removing Regions
When you add an audio file to your project, Logic Pro automatically creates a region 
that encompasses the entire file length. You can create as many regions as desired from 
the same audio file. There are no length limitations to regions, as long as they don’t 
exceed the length of the source audio file.

Creating multiple regions from the same audio file is beneficial for many tasks, such as 
using different portions of a vocal take that spans the length of the project, for 
example.

You can create regions in the Audio Bin, the Sample Editor, and the Arrange. This 
section concentrates on the Audio Bin and Sample Editor options. 

Note:  Full details on all Arrange window region editing options are found in 
Chapter 13, “Creating Your Arrangement,” on page 293.

To create a region from an audio file in the Audio Bin, either:
m Select the desired audio file in the Audio Bin, then choose Audio File > Add Region (or 

use the Add Region key command, default:  Control-R). 

m Choose Edit > Copy (Command-C) in the main menu bar, then choose Edit > Paste 
(Command-V).

The new region will appear below the existing region(s) in the list.

Each region is assigned a unique numerical appendix. As an example, organ.wav is the 
parent audio file. The automatically created region is simply called organ, and newly 
created regions are called organ.1, organ.2, and so on.

To create a region from an audio file in the Sample Editor:
m Choose Edit > Create New Region (Command-R).

The newly created region will appear in the Audio Bin list.

To delete a region from the Audio Bin, do one of the following:
m Select one or more regions, and press Backspace.

Removing a region does not remove the parent audio file.

To remove an audio file from the current project:
1 Select the audio file name (not a region name) in the Audio Bin.

2 Choose Audio File > Delete Files (or use the corresponding key command). 

This deletes the file from the project, but not from the hard disk.

Warning:  If any of the deleted regions exist in the Arrange area, they will be removed 
as well. You should, therefore, be careful when deleting a region (or parent audio file). 
The Undo function is always available, however, should you inadvertently remove a 
required region.
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Auditioning Regions in the Audio Bin
The playback modes outlined below only apply to regions in the Audio Bin (when the 
window has key focus), and have no effect on project playback.

To play an entire region:
1 Highlight the region name in the list.

2 Click the speaker button at the bottom of the Audio Bin (or press the Space bar) to 
start playback. 

Click the button (or press the Space bar) again to stop playback.

Note:  The Environment’s Prelisten channel is used for monitoring in the Sample Editor. 
You can access the Prelisten channel in the Environment’s Mixer layer—you can find it 
to the right of the highest numbered audio channel strip.

To loop region playback:
m Click the loop playback button (featuring the circular arrow symbols) at the bottom of 

the Audio Bin. Click the button a second time to stop looped playback. 

To play a region from a specific position in the Audio Bin window:
m Click-hold the desired region in the region display or with the mouse. 

A speaker icon replaces the mouse pointer.

Playback starts at the click point. This allows you to play specific sections. Playback 
stops as soon as you release the mouse button.

Note:  This only works in the Audio Bin window.
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Resizing a Region
You can resize regions in the Audio Bin window, the Sample Editor, and the Arrange. 
This section concentrates on the Audio Bin and Sample Editor options. 

Note:  Full details on all Arrange window region editing options are found in 
Chapter 13, “Creating Your Arrangement,” on page 293.

To resize a region in the Audio Bin window, do one of the following:
m Click-hold the lower third of the left or right region boundary, and drag in the desired 

direction.

To precisely resize a region:
m Drag the start or end points of regions in the Sample Editor, not the Audio Bin, when 

accuracy is required. Ensure that Edit > Search Zero Crossings is disabled for the 
Sample Editor (see below).

The small markers on the lower edge of the Sample Editor’s waveform display provide 
direct access to the boundaries of the region. 

Snapping Edits to Zero Crossings
If Edit > Search Zero Crossings is switched on, adjustments to the start or end positions 
of a region are snapped to the nearest point where the wave form crosses the zero axis. 
Put another way, there are certain crossover points in a sample (a drum loop, for 
example) that are closely matched in level to other points in a sample. If two closely 
matched points are used for the start and end points of the sample, the loop will play 
back without noticeable glitches in the audio. 

When adjusting the start point, the area preceding the selected point is scanned for a 
smooth crossover point. When adjusting the end point, the area that follows the region 
is scanned for a smooth crossover point.

Region markers
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To snap audio edits to zero crossings:
1 Click on the title bar of either the Audio Bin or Sample Editor to give the window key 

focus. 

2 Enable Edit > Search Zero Crossings (or use the Search Zero Crossings key command).

Note:  The Search Zero Crossings option can be set independently for the Sample Editor 
and Audio Bin.

Moving a Region Within an Audio File
You can also move an entire region within an audio file in the Audio Bin window.

To move the region area within the audio file:
1 Position the cursor over the center of a region.

2 When the cursor turns into a two-headed arrow, drag the region to the left or right. 

Note:  If you want to adjust the boundaries of the region without moving the anchor 
(see next section), hold down Option during the operation. This applies to moving the 
start or end points, as well as moving the whole region.

Editing the Audio Region Anchor
The anchor is the temporal reference point of an audio region. When you move an 
audio region, it’s not the start point that is displayed in the help tag (as with MIDI 
regions)—it’s the anchor point.

In many cases, the anchor should be placed on the amplitude peaks, rather than at the 
start of the sound’s attack phase. A good example would be recordings of brass 
instruments, which may take some time to build to a peak. Moving the anchor to these 
peaks forces the region to snap to the grid of your arrangement, using the anchor as 
the pivot point. The flexible zoom settings allow you to be as precise as needed, going 
right down to the level of single bits, at the highest magnification factor.

As another example, to guarantee perfect synchronization between a one-bar drum 
loop and MIDI regions, the anchor must be assigned to a well-defined musical point. If 
the loop begins with a significant level peak (say a kick drum beat), set the anchor to 
the point where the volume of that beat is at its precise peak.

Whenever you record audio or add an audio file, the anchor and region start points are 
always at the beginning of the audio file. Moving the region start point also moves the 
anchor, as the anchor can not precede the region’s start position.

Two-headed arrow cursor
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You can edit the anchor of a region in the Audio Bin window and Sample Editor. The 
anchor is represented by a black indicator (orange in the Sample Editor) below the 
region waveform.

To move the anchor in the Sample Editor or Audio Bin window:
m Grab the small indicator below the region, then move the anchor to the desired 

position. 

Any changes to the anchor point will change the relative position of the audio region 
in the project. Given that the start point of a region is the default position for the 
anchor, you must also take care when changing the region start point.

Protecting the Anchor Point When Moving the End Position
If you move the start or end points of a region past the anchor point, the anchor point 
will also move. This is often not what you want to happen!

Hold down Option while moving the end marker to prevent the anchor from moving.

Note:  The anchor can never be to the left of (before) the region start point, so it will 
move if you drag the region start past the anchor (to the right), even with Option 
pressed.

Updating Arrange Position
When you change the anchor point in the Sample Editor, you can use the Compensate 
Region Position feature to ensure that the position of a given audio region stays at the 
same place in the arrangement. 

To switch the Compensate Region Position feature on or off:
1 Click on the title bar of the Sample Editor, to ensure that it has key focus.

2 Choose Edit > Compensate Region Position.

Â If Compensate Region Position is active, moving the anchor won’t change the audible 
result. Moving the anchor in the Sample Editor will lead to the same result as 
dragging the region start point in the Arrange area. 

Â If Compensate Region Position is not active, moving the anchor changes the position 
of audio regions in the Arrange area. The region will shift in relation to the time axis, 
while the anchor remains tied to the same bar value, and is marked by a dotted line.

AnchorAnchor
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Protecting Regions
You can protect regions against accidental alterations to start and end points, or the 
anchor position, by locking them in the Audio Bin window. 

To protect region start, end, and anchor positions:
m In the Audio Bin window, click the padlock icon beside a region to close (lock) it. Click a 

second time to unlock the region.

If locked, you can play the region, but can’t edit it.

The Audio Bin tab shows the status of locked audio regions (in the column between 
the file/region Name and Info columns), but you can’t lock or unlock audio regions in 
the Audio Bin tab.

Protected region

Unprotected region

Warning:  Don’t confuse this function with delete protection:  A protected (locked) 
region can still be deleted!
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13 Creating Your Arrangement

Once you have added your audio and MIDI regions to the 
Arrange area, you can edit and reorganize them to create an 
overall arrangement, or song.

The Arrange area provides a visual overview of your song structure:  it shows when 
audio and MIDI regions start to play, and their duration. You control when and how 
regions play by moving, cutting, copying, resizing, and joining them in the Arrange 
area. 

Regions are positioned horizontally—on track lanes that run from left to right in the 
Arrange area. Their positions along these lanes determine when they play, aligned with 
the Bar (and Time) ruler along the top of the window.

The track lanes are stacked vertically, creating a grid of track lanes and particular bar or 
time positions. 

To view the Arrange area grid:
m Enable the Grid setting in the Arrange area’s View menu. 

You may also wish to enhance the grid contrast by altering the color of the Arrange 
area background. 

Arrange area with grid Arrange area without grid
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To alter the Arrange area background color:
1 Open the Display preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Display (or use the Open Display preferences key 
command).

Â Click the Preferences button in the Arrange Toolbar, and choose Display from the 
menu.

2 Click the Arrange tab in the Preferences window.

3 Choose Bright in the Background Color menu.

4 Alternately, choose Custom from the menu, and click the color field to the right. 

5 In the Colors window that launches:  Use the mouse on the color palette wheel, 
contrast and opacity sliders to create a custom color. 

6 Click the close button at the top left to exit the Colors window and assign your custom 
Arrange area background color.

Most arranging and editing techniques work identically for both audio and MIDI 
regions. Apple Loops are also handled in a similar fashion. Where handling differs, 
variations are pointed out in the appropriate sections of this chapter. 

All operations described with a pluralized heading (regions, for example), apply to one 
or more selected region(s).
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Making Region Edits Faster and Easier
This section provides information on several options that can accelerate and simplify 
region editing, helping you to focus on the musical aspects of your arrangement.

Snapping Region Edits to Time Positions
You move and resize regions in the Arrange area because you want them to start and 
end at a specific point in time. As an example:  In a music-based project, you may want 
to align the start points of regions with measures and beats.

Logic Pro offers a snap feature that automatically aligns region start and end points to 
a selected grid value, when you move or resize them.

∏ Tip:  Turn on the View > Grid menu item, as this will help you to visualize how the Snap 
menu items automatically align regions to specific grid positions. 

To snap regions to a grid:
m Choose one of the following values in the Snap menu at the top of the Arrange area:

Â Smart:  Edit operations will snap to the nearest bar, beat, sub beat, and so on, 
dependent on the current Bar ruler division value, and the zoom level.

Â Bar:  Edit operations will snap to the nearest bar.
Â Beat:  Edit operations will snap to the nearest beat in a bar.
Â Division:  Edit operations will snap to the nearest division value (this is the time 

signature shown in the Transport and Bar ruler).
Â Ticks:  Edit operations will snap to the nearest clock tick (1/3840th of a beat).
Â Frames:  Edit operations will snap to the nearest SMPTE frame.
Â QF (Quarter Frames):  Edit operations will snap to the nearest SMPTE quarter frame.
Â Samples:  Edit operations will snap to the nearest sample. 

Note:  Sample accurate editing is directly tied to the zoom level. If the zoom level is 
insufficient, sample-accurate edits are not possible. Make use of the Zoom slider at the 
bottom of the Arrange window, and take advantage of the Save and Recall Zoom 
Setting key commands to speed up your workflow.
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The Snap functionality is relative, which means that the edit operation will be snapped 
to the nearest bar, beat, and so on—retaining the region’s distance from its original 
position. As an example, if a region is placed at position 1.2.1.16, and you move this 
region forward to around bar 2 (with the Snap menu set to Bar), it will automatically 
snap to position 2.2.1.16—rather than 2.1.1.1 (the bar 2 start point). You can override 
relative snaps with the Snap to Absolute Value option.

To snap to an absolute, not relative, position:
m Choose the Snap to Absolute Value option in the Snap menu. 

A tick will appear to the left of this function name when enabled. This feature works in 
conjunction with the chosen snap grid division. 

To explain, if Bar is chosen in the Snap menu, when Snap to Absolute Value is active, 
moving a region (from position 1.2.1.16) to around bar 2 will result in it being snapped 
to position 2.1.1.1 (the bar 2 start point), rather than its relative position (2.2.1.16).

The Snap menu setting applies to the following edit operations:
Â Moving and copying regions.
Â Resizing regions.
Â Cutting regions.
Â Moving, adding, and resizing markers. 
Â Setting cycle boundaries.

Overriding the Snap Grid
You can temporarily override the snap grid, allowing finer edits and adjustments. 

To override the snap grid:
m Hold Control while performing the editing operation.

Â The division value chosen in the Transport (1/16, for example) determines the editing 
grid scale at lower zoom levels (macroscopic or wide view).

Â If the zoom level is higher (microscopic or close up view), holding Control while 
editing will scale by a certain factor.

m Hold Control-Shift while performing the editing operation:

Â The editing grid switches to ticks if editing at lower zoom levels (macroscopic or 
wide view).

Â At higher zoom levels (microscopic or close up view), the editing grid will switch to 
samples.

Notes on the Relationship Between the Zoom Level and Snap Menu Setting
In cases where the zoom level is so high (microscopic), that the chosen Snap value 
would result in extremely large movements or edits, the Snap value is temporarily 
dimmed, and Smart snap is used instead.
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In cases where the zoom level is extremely low (macroscopic), and a fine Snap value 
(such as Division or Frames) is chosen, normal mouse movements will result in larger 
grid units. In these situations, either alter the zoom level, or hold Control to actually use 
the chosen Snap value.

Using Control-Shift breaks the 1:1 relationship between mouse cursor and region (or 
edit tool) movements. This means that you may need to move the mouse a long way 
(horizontally) to make the region (or edit tool) move one pixel. Watch the help tag for 
exact numerical readouts.

Imagine you want to shorten a region in a 4/4 bar so that the 4 is played, but not the “4 
and” of the last bar. 

To shorten a region by one division value when Snap is set to Beat:
1 Horizontally zoom the screen display until you can see quarter notes in the Bar ruler. 

2 Grab the bottom right corner of a region, and move the mouse to the left, until the 
region is shortened by one quarter note. 

3 Press Control, and move the mouse carefully to the right, until the region has become 
one division longer. 

While you’re doing this, the help tag shows the region start position, track number, and 
the current length of the region in bars, beats, divisions, and ticks. The three right-hand 
numbers should be 3 1 0.

Using Drag Modes
Logic Pro provides several drag modes that determine the behavior of regions when 
you edit them. You can set the drag mode in the Drag menu, available in the Arrange 
area and several other editor windows.

Note:  The Drag menu options discussed in this section refer to regions. The behaviors 
outlined below (for regions) are identical for dragged events in the editor windows. The 
Drag menu setting of the Arrange and each editor window is independent.

To change the drag mode:
m Choose one of the following settings in the Drag menu:

Â Overlap:  This mode is the default, and allows you to drag a region over another one. 
The original region borders are preserved. 
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Â No Overlap:  Use in situations where you don’t want regions to overlap. In this mode, 
the first region (the one positioned earlier on the track) will be reduced in length so 
that no overlap occurs.

Â X-Fade:  In this mode, Logic Pro automatically crossfades two audio regions when 
they are moved to an overlapping position.

Note:  This option does not work for MIDI regions or Apple Loop regions.

Â Shuffle L and Shuffle R:  Choose to automatically align regions (to the left or right, 
respectively) when you move, resize, or delete them.
Â When you use Shuffle R (or Shuffle L), moving a region to the right (or left) aligns 

the region end point with the start point of the following region, ensuring that 
there is no space between the two regions.

Â Regions that are dragged over each other will swap positions.
Â When deleting regions, the remaining regions (those left or right of the deleted 

region) are moved to the left or to the right by the length of the deleted region.
Â If a region is stretched or shortened when either Shuffle option is active, the other 

regions on the track will be moved to accommodate the new length. 
Â In Shuffle L mode, the right side of the region will be stretched or shortened, and 

the regions to the right of the edited region will be moved. 
Â In Shuffle R mode, the left side of the region will be stretched or shortened, and 

the regions to the left of the edited region will be moved. The regions that precede 
the edited region can only be moved as far as the project start point. If the 
stretching of a region results in preceding regions being forced to the project start 
point, and exceeding the space available, the edited region will overlap the 
existing content.

Note:  Only one audio region can be played at a time through a track’s channel strip. 
When two audio regions overlap each other on a track, the later region has priority.

Scrubbing Your Arrangement
Scrubbing allows you to hear the audio and MIDI signals of regions at the playhead 
position, helping you to find a particular sonic event. This makes it easy to zero in on a 
particular kick or snare hit, for example, before cutting an audio region. 

Note:  Before MIDI scrubbing can occur, you need to turn on File > Project Settings > 
MIDI > General > Scrubbing with Audio in Arrange.

To scrub your project:
1 Set a zoom level that provides the best view of the section you want to scrub (turning 

on View > Region Content may be useful).

2 Enable the Pause button on the Transport.
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3 Grab the playhead in the Arrange or Bar ruler, and move it back and forth through the 
parts of the project you want to hear, at the speed you want to scrub the section (or 
use the Scrub Rewind and Scrub Forward key commands). 

Audio and MIDI data playback is perfectly synchronized when scrubbing. 

Note:  Scrubbing is automatically activated when you’re dividing regions (with the 
Scissors tool) in the Arrange, making it easier to identify the cut position.

Scrubbing Particular Regions
The following list outlines the relationship between scrubbing and region selection:
Â If no regions are selected, all regions are scrubbed.
Â If you select a specific audio region, only it will be scrubbed.
Â If you rubber-band or Shift-select audio regions on different tracks, only the selected 

audio regions are scrubbed.
Â MIDI regions (software and external MIDI) are always scrubbed, regardless of the 

selection status (provided that the Scrubbing with Audio in Arrange project setting is 
active).

Â The Mute or Solo (see next section) status of all tracks and regions has an effect on 
what you hear when scrubbing, so you can make use of them to scrub audio parts in 
isolation (or with particular software or external MIDI instrument tracks).

MIDI Controlled Scrubbing
The Scrub by MIDI value (-2-) function (available in the Controller Assignments Editor; 
see the Logic Pro 8 Control Surfaces Support manual) is designed to allow scrubbing via 
external MIDI control. You can assign any MIDI controller number to this function. Data 
bytes over 64 scrub forwards, and those under 64, scrub backwards.

Muting Regions
Often, when arranging, you’ll want to test musical ideas by muting certain regions. 

To mute or unmute individual or selected regions, do one of the following:
m Select the Mute tool, then click the desired regions with the Mute tool. 

 

m Select the desired regions with the Pointer tool, then use the “Mute/unmute selected 
Notes/Regions/Folders” key command (default:  M).

Mute tool



300 Chapter 13    Creating Your Arrangement

Muted regions are indicated by a dot that precedes the region name.

Clicking muted regions with the Mute tool, or selecting them and using the “Mute/
unmute selected Notes/Regions/Folder” key command reverses this state (unmuting). 

Soloing Regions
Soloing allows you to hear one or more selected regions in isolation, making it easier to 
identify particular elements that may need to be edited.

To solo a region with the Solo tool:
1 Select the Solo tool.

2 Click-hold on the desired region with the Solo tool. 

The region (outlined in yellow) will be heard in isolation from the click point, until you 
release the mouse button, which will stop solo playback. 

To solo several regions with the Solo tool:
1 Rubber-band or Shift-select the desired regions.

2 Click-hold on any of the selected regions with the Solo tool. 

To scrub with the Solo tool:
1 Select the Solo tool, then drag the mouse horizontally.

2 Release the mouse button to end solo scrubbing.

To solo one or more regions using Solo mode:
1 Click the Solo button in the Transport (or use the Solo Mode key command, default:  S).

Solo tool

Solo button
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When the Solo function is activated, the Bar ruler is shaded in yellow, making it easy to 
see that Solo mode is engaged.

2 Rubber-band or Shift-select the regions you want to solo with the Pointer tool. 
Selected regions have a yellow outline.

Click the Transport Solo button again (or use the Solo Mode key command) to turn off 
Solo mode, and hear all regions again.

Using Solo Lock
On occasion, you may want to lock the solo status of several regions. As an example, 
this would be especially useful when you want to make changes to the playback 
parameters of a region, while listening to a specific group of soloed tracks. 

To retain the solo status of several selected regions (can be done in play mode):
1 Select several regions with the Pointer tool.

2 Option-click the Transport Solo button (or use the Set Solo Lock Mode key command, 
default:  Option-S) to lock the soloed status of the selected regions. 

The Transport Solo button displays a padlock icon to indicate Solo Lock mode.

The Reselect Solo-Locked Regions key command (default:  Shift-Option-S) selects all 
currently solo-locked regions. This command is very useful if you want to remove 
several regions from your solo-locked selection.

Transport Solo button
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Naming a Region
Identifying regions by name can make arranging much easier. This can be done on a 
per-region basis, or you can name several regions simultaneously. 

To name a region with the Text tool:
1 Select the Text tool.

2 Click on a region with the Text tool. 

A text input box will appear. 

3 Type in the desired name and press Return, or click another region or the Arrange area 
background to exit the text input box.

To name a region using the Region Parameter box:
1 Click the top line of the Region Parameter box in the Inspector. 

This line displays the name of the selected region. A text input field appears, allowing 
you to edit the region name. 

2 Type in the desired name. 

3 Press Return, or click anywhere outside the text input box to exit text input mode.

To assign the same name to multiple regions:
1 Select a group of regions (rubber-band or Shift-click) with the Pointer tool.

2 Do one of the following:

Text tool
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Â Select the Text tool, then click any of the selected regions with the Text tool. 
Â Click the top line of the Region Parameter box (displaying x selected:  x indicates the 

number of selected regions).
A text input box will appear. 

3 Type in the desired name and press Return, or click another region or the Arrange area 
background to exit the text input box. 

All regions are assigned the same name.

To assign a name with incrementing numbers to multiple regions:
m Follow the steps outlined above, but end the name with a number. 

As an example, bassline 1. All selected regions are assigned the same name, but are 
incrementally numbered (bassline 1, bassline 2, bassline 3, and so on). 

Region numbering follows the temporal (time) positions of regions within the project, 
so renaming the region on bar 8 as bassline 1 (when seven regions are selected in the 
preceding bars) will still result in each region being numbered sequentially from bar 1 
through to 8 as bassline 1, bassline 2, and so on. 

If you want all regions to end with the same number:
m Perform the same steps, but press Space after the number. 

This is useful for identifying takes made on a particular date, for example—bassline 
030806.

You can name regions after the track on which they are placed. 

To assign regions the name of their parent track:
1 Select the track name in the track list. 

All regions on the track are automatically selected.

2 Choose Region > Track Names to Regions (or use the Track Names to Region key 
command, default:  Shift-Option-N) in the Arrange area.

The track name is assigned to all selected regions.
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Assigning Colors to Regions
Color is useful for identifying sections of your arrangement, or particular track types. 
Newly recorded or added regions initially adopt the color of the track channel strip. 

By default:
Â Audio track channel strips are blue.
Â Software instrument channel strips are green.
Â ReWire and external MIDI channel strips are red.
Â Auxiliary, Input, and Output channel strips are yellow.

To change the color of one or more regions:
1 Select the desired regions (rubber-band or Shift-click, for example).

2 Do one of the following:

Â Click the Colors button in the Arrange Toolbar.
Â Choose View > Colors in the Arrange area (or use the corresponding key command, 

default:  Option-C).

3 In the Color palette that opens, click on the desired color.

Â If you’d like to create a custom color:  Double-click on any color square in the Color 
palette to open the Colors window:  Use the mouse on the color wheel, contrast, and 
opacity sliders to create a custom color. Click the OK button to replace the color 
square in the Color palette, and exit the Colors window. 

Note:  Custom colors are memorized, and are available for all projects.

To assign channel strip colors to regions:
1 Select the desired regions. 

∏ Tip:  If all regions are on a single track, click the track name in the track list to select all 
regions.

2 Choose Region > Channel Strip/Instrument Colors to Regions (or use the Channel Strip/
Instrument Colors To Regions key command,  default Shift-Option-C).

This replaces the colors of all selected regions with the colors of the corresponding 
channel strips. 

∏ Tip:  This feature is handy after copying or moving regions between tracks, when you 
may find that the Arrange area resembles a patchwork quilt.
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Using the Shortcut Menu
Many selection, editing, and other commands can be accessed by Control or right-
clicking anywhere in the Arrange area. Make use of this to accelerate your workflow.

Note:  Right-click functionality is dependent on the Right Mouse Button:  Opens 
Shortcut Menu option being chosen in the Logic Pro > Preferences > Global > Editing 
tab. 

Selecting Regions
You must select a region before you can perform any edits, functions, or operations on 
it. You can select a single or multiple regions, including regions on different tracks and 
of different types. When selected, a black bar runs across the upper portion of the 
region to indicate its selected status.

Logic Pro provides a number of sophisticated selection methods. For more information 
on this, please refer to “Selection Techniques” on page 172.

Selecting Parts of a Region
The Marquee tool, which looks like a crosshair, allows you to select and edit parts of 
one or more regions. 

Marquee tool
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To use the Marquee tool:
1 Select the Marquee tool.

2 Click-hold on the Arrange area background or on regions to begin your selection, 
which is indicated by a shaded selection rectangle. 

3 Drag the marquee rectangle to make selections—independent of existing region 
boundaries. 

4 Release the mouse button. 

Only the area that falls inside the marquee is selected. 

In other words, you can use the Marquee tool to make selections inside, or across 
portions of, existing regions; your selection is determined completely by the selected 
marquee area. Within the selected area, you can perform almost all Arrange editing 
options, including deletions, moves, cuts, and copies. 

Shift-click a track to exclude (or add) its contents from the Marquee selection.

Note:  When using the Marquee tool on a region, the selected area will become a new 
region once an operation is applied.

If your selected area falls between musically relevant values, the Marquee tool selection 
rectangle will automatically snap to the nearest musically relevant position. The snap 
resolution is determined by the current Snap menu setting.

To snap to the finest possible resolution in the chosen snap mode:
m Hold Control-Shift while making your marquee selection.

This will snap to ticks or samples when editing MIDI or audio regions, dependent on 
the current zoom level (see “Overriding the Snap Grid” on page 296).

To snap to the division value shown in the Transport:
m Hold Control while making your marquee selection.

As above, the zoom level can impact on this.

To adjust an existing marquee selection:
m Hold Shift to alter the current marquee selection; from either the left or right side, or up 

or down.
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To set locators with a marquee selection:
m Choose the Region > Set Locators by Regions function (or key command). 

This sets the locators to the marquee selection boundaries, rather than the whole 
region.

To remove all parts of regions outside the marquee selection:
m Use the Crop Regions outside Marquee Selection key command.

This removes all unselected areas from regions which are partly marquee-selected.

Adding and Recording Regions
It goes without saying that adding and recording regions is essential for song creation. 
Given the extensive region and file import options available, and the advanced 
recording techniques possible with Logic Pro, please refer to the following chapters:
Â “Adding Pre-Recorded Media” on page 255.
Â “Recording in Logic Pro” on page 351.

Removing and Restoring Regions
As you work on a project, you may decide that a region no longer fits into your 
arrangement. You can remove regions by deleting them from the Arrange area.

Note:  Removing audio regions and MIDI regions from the Arrange has different 
consequences (see “Restoring Removed Regions” on page 308). 

To remove a region from your arrangement, do one of the following:
m Click the region with the Eraser tool.

m Select the desired region with the Pointer tool, then choose Edit > Delete (or press 
Backspace).

To remove multiple regions from your arrangement:
1 Select the desired regions with the Pointer tool.

2 Do one of the following:

Â Click one of the selected regions with the Eraser tool.
Â Choose Edit > Delete (or press Backspace).

Eraser tool
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To remove all muted regions from your arrangement:
1 Select all muted regions by choosing Edit > Select Muted Regions/Events (or using the 

Select Muted Regions/Events key command, default:  Shift-M). 

2 Do one of the following:

Â Click one of the regions with the Eraser tool.
Â Choose Edit > Delete (or press Backspace).

To delete all selected regions, and automatically select the next one:
1 Select the region (or regions) you want to delete. 

2 Use the Delete and Select Next Region/Event key command.

All selected regions are deleted, and the next (obviously, not deleted) region is 
automatically selected.

Restoring Removed Regions
Although similarly handled for most editing operations, audio and MIDI regions are 
treated differently when removed from the Arrange window. 
Â Audio regions are merely removed from arrangement, not from the project. They 

remain in the Audio Bin, and can be restored from here, or with the Undo functions.
Â MIDI regions are deleted. They can be restored by using the Edit > Undo History 

function.

Restoring Removed Audio Regions
When you remove an audio region that you have recorded since opening the project, 
Logic Pro will ask if you also want to delete the corresponding audio file. This avoids 
the unnecessary wastage of hard disk space that would occur if bad takes and 
unwanted recordings were retained.

If the recording was made beforehand (a pre-recorded file), and imported into the 
current project, this dialog box will not appear. This prevents you from accidentally 
deleting valuable recordings (that may be used in other projects). 

Note:  When you remove a pre-recorded audio file from your project (by pressing 
Backspace in the Audio Bin), all regions that point to the file are also removed. The only 
way to restore the file to the project is by manually adding it to the Audio Bin. 
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To restore a deleted audio region, either:
m Choose Edit > Undo History, and click on the appropriate step.

m Manually add it back into the Arrange area from the Audio Bin.

Moving Regions
You can move regions horizontally on tracks, and vertically between tracks. You can 
also move regions between two Arrange windows, or even between different projects.

To move one or more regions:
m Select the desired regions and drag them to a new position.

Dragged regions automatically snap to increments defined by the Snap menu setting 
(see  “Snapping Region Edits to Time Positions” section on page 295). If dragged over 
other regions, the Drag menu setting will have an impact on behavior.

To move regions precisely (overriding the Snap menu setting):
m Hold Control while dragging regions, to move them in steps of one division (in 

sixteenths, for example). 

m Hold Control-Shift while dragging regions, to move them by single ticks or samples 
(remember that the maximum resolution is zoom dependent).

Moving Regions Between Projects
If you move a region from one project into the Arrange area of another, the region is 
automatically copied, in much the same way that Mac OS X automatically copies files 
when dragged and dropped between hard disks.

Limiting Region Movements
You can limit the initial movement of regions to either the horizontal or vertical axis. To 
do so, activate the Logic Pro > Preferences > Global > Editing > Limit Dragging to One 
Direction In Arrange checkbox. If your first movement is to the left or right after 
grabbing a region, you can only move it on the horizontal plane. If you actually wanted 
to move it between tracks, release the mouse button, reselect the region, and drag it 
up or down.

Note:  You can override this direction limiting preference by pressing Shift while 
moving regions.
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Changing the Playback Position of Regions Numerically
You can edit the playback position of a region (and its length) numerically. This can be 
done in the Event List, configured to view regions at the Arrange level (see “Changing 
the Event List View Level” on page 438). 

To move regions by adjusting positions in the Event List:
1 Open the Event List by doing one of the following:

Â Choose Window > Event List.
Â Click the Lists button in the Arrange Toolbar, and click the Event List tab. 
Â Choose Options > Open Event Float (or use the Open Event Float key command). 

This opens a new single line Event List window, set to the Arrange level view. 

2 Click on the Hierarchy button in the top left corner of the Event List (not applicable to 
the Event Float window—a miniature Event List) to move up one level in the hierarchy. 

3 Edit the desired region’s Position value. As you select regions in the Arrange area, the 
Event List (or Event Float) window will update to reflect this selection.

∏ Tip:  You can instantly move a region start point to the beginning of a bar by typing in 
a value, and pressing Return. As an example, typing in 9 will move the selected region 
to the beginning of bar 9. Typing in 112 will move the region to bar 112. Typing in 1 
space 1 space 2 will move the region to bar 1, beat 1, sub-beat 2.

You can display the start position of regions as SMPTE values in the Event List and 
Event Float windows. This is especially handy if you work with video or film.

To display region positions in SMPTE values, either:
m Click the note icon button to the left of the first (or only, in the case of the Event Float 

window) region event. 

The icon will change to a clock, and the SMPTE position and length of the event will be 
shown.

m Turn on the View > Event Position and Length in SMPTE Units setting in the Event List 
(or use the corresponding key command).

This enables you to set the required SMPTE positions when synchronizing music to 
picture. 

You can also display, and adjust, the end points of regions as a SMPTE time value. To do 
this, choose View > Length as Absolute Position in the Event List.
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Moving Regions to the Current Playhead Position
You can use the Pickup Clock (Move Event to Playhead Position) key command to move 
the selected region (or the first of several selected regions) to the current playhead 
position. If more than one region is selected, all subsequent regions are moved.

Note:  If you use this command on audio regions, the anchor of the region is placed at 
the current playhead position (see “Editing the Audio Region Anchor” on page 290).

Moving Audio Regions Back to Their Original Record Positions
You can move any selected audio region back to its original recorded position by 
choosing Audio > Move Region to Original Record Position (or using the Set Region(s) 
to Recording Position key command). 

Note:  This command only works if the audio file includes a time stamp. Examples of 
time stamped files include those recorded in the current project, and imported 
Broadcast Wave or SDII files. Time stamped files are indicated by a clock symbol to the 
right of the file name in the Audio Bin window (not Audio Bin tab).

Nudging Regions
You can use the following key commands to nudge (move to the right or left) selected 
regions by the corresponding grid amount:
Â Nudge Region/Event Position Right by SMPTE Frame 
Â Nudge Region/Event Position Left by SMPTE Frame
Â Nudge Region/Event Position Right by 1/2 SMPTE Frame
Â Nudge Region/Event Position Left by 1/2 SMPTE Frame
Â Nudge Region/Event Position Right by 5 SMPTE Frames 
Â Nudge Region/Event Position Left by 5 SMPTE Frames
Â Nudge Region/Event Position Right by SMPTE Bit
Â Nudge Region/Event Position Left by SMPTE Bit
Â Nudge Region/Event Position Right by Tick
Â Nudge Region/Event Position Left by Tick
Â Nudge Region/Event Position Right by Division

Time stamped audio file
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Â Nudge Region/Event Position Left by Division
Â Nudge Region/Event Position Right by Beat
Â Nudge Region/Event Position Left by Beat
Â Nudge Region/Event Position Right by Bar
Â Nudge Region/Event Position Left by Bar
Â Nudge Region/Event Position Right by Nudge Value
Â Nudge Region/Event Position Left by Nudge Value

The selected regions are shifted one step right (+1) or left (–1), by whatever unit is 
referred to in the particular command name.

Shifting the Playback Position of Regions
The Delay parameter in the Region Parameter box of the Inspector allows you to shift 
the playback position of regions on a track. Positive values correspond to a delay (laid-
back playing style or dragging), and negative values cause a pre-delay (driving or 
rushing the music).

The Delay amount is shown in milliseconds or note values, dependent on the View > 
Delay menu setting. You can also use the “Delay in ms” key command to switch the 
display.

To delay or advance all selected regions on a track:
m Set the Region Parameter box Delay parameter to the desired value. 

The Delay parameter in the Inspector is mainly used for creative musical purposes, such 
as rhythmically offsetting musical parts (regions). It can also be used to fix timing 
problems that may occur for a variety of reasons. Some examples of these are:
Â The attack phase of the sound is too slow. A good musician will automatically 

compensate for this by playing the notes slightly early. With very slow sounds, you 
may need a pre-delay of over 100 ms to even them out.

Â The sound generator is reacting too slowly to the incoming note-on messages. Older 
multitimbral sound generators often take tens of milliseconds before outputting a 
voice. 

Â The delay in output is not constant, as it is dependent on the order of notes arriving 
at the external MIDI sound generator. You should therefore try pre-delaying 
rhythmically important tracks by as little as one tick—it can work wonders on timing!
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Moving Regions to a Track
The Region > Move Selected Regions to Current Track command (also available as a key 
command, default:  Shift-Command-T) moves all selected regions (from different 
tracks) onto the selected track. The time positions of all regions are retained.

Resizing Regions
You can reduce or extend the length of any region by dragging the start or end point 
of the region, thus determining what part of the source (audio file or MIDI events) is 
played back in your project. 

The data in regions is never deleted when they are reduced in length; playback simply 
stops at the end of the region.

To resize a region:
1 Select the Pointer or Pencil tool, then place the cursor over the lower left or right hand 

corner. 

The cursor changes to a Resize pointer.

2 Click the corner and drag to the left or right. 

Note:  If Hyper Draw or automation is enabled, you’ll need to grab the left or right sides 
of the region title area.

To simultaneously resize two adjacent regions (using the Junction pointer):
1 Select the Pointer or Pencil tool, then place the cursor over the upper left or right hand 

corners of two side-by-side regions. 

The cursor changes to the Junction pointer. 

Note:  If there is a gap between the regions, the Loop tool will be shown when the 
mouse pointer is moved over the upper right corner of the earlier region.

2 Click-drag to the left or right. 

Both regions will be resized accordingly, with no gaps between them.
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Note:  You cannot make an audio region longer than the underlying audio file when 
using either of the resize operations covered above. 

Adjusting the Start Point of Audio Regions
Adjusting the start point of an audio region may also move the region anchor point, 
thus affecting its temporal reference point, and making it play back out of sync with 
other tracks. It is better, and simpler, to move the entire region to the right, if you want 
playback to start later. 

If you actually want to cut out the early portion of the region, you have several options, 
such as:
Â Marquee selection and muting.
Â Cutting and muting or deleting.
Â Creating a new region, and resizing it in the Audio Bin window.
Â Using the Sample Editor to resize, and replace, the Arrange region.

To resize an Arrange audio region from the Sample Editor:
m Directly edit the start and end markers (in the Region row at the bottom of the Sample 

Editor window); this affects the size of the corresponding Arrange region immediately.

To resize and replace an Arrange audio region from the Sample Editor:
1 Select the desired portion of the audio file in the Sample Editor by dragging directly 

across the waveform display.

2 Choose Edit > Selection → Region (or use the corresponding key command). 

This enables you to define an audio passage as a selection, and then convert it to a 
region, in place of the originally selected region.

You can also do the reverse …

To resize the Sample Editor selection from the Arrange:
1 Select the desired region in the Arrange (presumably of a different length to the 

current Sample Editor selection).

2 Click the Sample Editor title to make sure that the Sample Editor has key focus

3 Choose Edit > Region → Selection (or use the corresponding key command).
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Adjusting the Grid to Zero Crossings
If Audio > Search Zero Crossings is turned on, any length adjustments to audio region 
start or end points will snap to the nearest zero crossing point of the waveform.

The disadvantage of this option is that altered start or end points never land exactly on 
the selected musical grid. 

Should this ever cause a problem, you can simply switch off the Audio > Search Zero 
Crossings setting. The primary reason for activation of the Search Zero Crossings 
setting, is that it prevents clicks and pops at region start and end points.

Adjusting the Start or End Point of MIDI Regions
You can move the left corner beyond the first event in a MIDI region—which hides 
events from the beginning of the MIDI region, but these hidden events will continue to 
play back. 

If you actually want to remove the information from the start of a MIDI region, you 
need to cut it and mute or delete the new start segment (new MIDI region).

The hide facility is useful in situations where you might want to trigger MIDI controller 
events (such as sustain) before the musical phrase begins, but do not want to use a 
MIDI region that doesn’t fit into the current Arrange grid (based on bars), as this would 
make arrangement far more complicated.

Note Handling Options When Changing MIDI Region Lengths
The Clip Length setting in the Extended Region Parameters (only visible if the View > 
Extended Region Parameters setting is turned on in the Arrange area) determines 
whether:
Â Notes sounding when the region ends are abruptly cut off (active)
Â Notes should be played to their normal end point (inactive:  default), regardless of 

where the region ends

The point of this function is to allow you to alter the length of the last notes in a region 
directly from the Arrange area, by adjusting the length of the MIDI region. Clip length 
has no effect on folder regions.

Making Multiple Regions the Same Length
You can change the length of multiple regions to the same absolute amount, making 
them the same length, even if originally a different size.

To make all selected regions the same absolute length:
m Hold Option-Shift while changing the length with the Pointer tool.
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Setting Region Start and End Points to the Playhead Position
You can move the start or end point of a selected region to the current playhead 
position with the following key commands:
Â Set Region/Event Start to Playhead Position
Â Set Region/Event End to Playhead Position

Note:  The anchor point is also moved when using Set Region/Event Start to Playhead 
Position on an audio region. 

Adjusting Region Lengths to Fit Other Regions
On occasion, you may want to reduce or extend the length of all regions on a track, or 
between locators, ensuring that they directly adjoin each other without gaps.

To reduce the length of overlapping regions on a track:
1 Select the overlapping regions on a track, or select all regions on a track by clicking the 

track name in the track list.

2 Choose Region > Remove Overlaps (or use the Remove Overlaps key command). 

This function searches all selected regions in a track for overlaps. If an overlap is found, 
the earlier (in time) region is reduced in length, thus removing the overlap.

You can “tie” selected region(s), making them end exactly at the start point of the next 
region on the track.

To tie regions (removing gaps between regions):
1 Select the regions you want to tie.

2 Choose Region > Tie Regions by Length Change (or use the corresponding key 
command).

The selected regions are increased in length, making them end exactly at the start 
point of the next region on the track.

You can limit the length change to all selected regions within the locator boundaries.
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To tie selected regions between locators:
1 Set the left and right locator positions by doing one of the following:

Â Drag from left to right across the desired portion of the Bar ruler. 

Â Set the desired value in the Transport’s Locator fields.

2 Select the desired regions within the locator boundaries. 

∏ Tip:  You can quickly select all regions inside the locators by choosing Edit > Select 
Inside Locators (or using the corresponding key command, default:  Shift-I).

3 Choose Region > Tie Regions within Locators (or use the corresponding key command).

This function lengthens all selected regions (within the locator boundaries), closing the 
gaps between them. The last region on each track (within the locator boundaries) is 
not affected.

Time Stretching the Contents of a Region When Changing Length
In normal use, the position of events within MIDI regions is not affected by changes to 
the region length. Similarly, changes to audio region lengths have no impact other 
than starting and stopping playback at particular song positions.

You can, however, time stretch or compress the contents of regions when altering their 
length.

To time stretch or compress the position of events within a MIDI region:
m Option-drag the end of a MIDI region. 

The events within the region are stretched or compressed, proportionately, by the 
amount that the MIDI region is altered in length.

You can make a rhythmic MIDI region play in half-time by stretching it to twice the 
original length, or in double-time by shortening it to half the original length.
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To time stretch or compress audio regions:
m Option-drag the end of an audio region.

This stretches or compresses the audio by the amount that the region is altered in 
length, and replaces the original region with a new PCM audio file (in the original file 
format, or AIFF, if the original was not PCM). 

Note:  The current Snap menu setting has an impact on length changes.

You can make an audio region play at half-speed by stretching it to twice the original 
length, or at double-speed by shortening it to half the original length. Great for Darth 
Vader or Munchkin impressions.

You can choose the time stretch/compression algorithm used for this function in the 
Arrange area’s Audio > Time Machine Algorithm menu. Details on each algorithm are 
found in “Using the Time and Pitch Machine” on page 505.

Time Stretching or Compressing Multiple Regions
Modifier keys have an impact on how time stretching or compression works when 
multiple regions are selected. The following table outlines all modifier options, and their 
impact (or otherwise) when multiple region lengths are changed:

MIDI Region-Specific Length Change Operations
The following functions only apply to MIDI regions.

To round a MIDI region start point to a bar:
m Use the MIDI > Snap Region Start to Bar command (or the corresponding key 

command) to round the start point of the selected MIDI region to the nearest bar.

Adjusting the Length of MIDI Regions to Fit Contents
The MIDI > Set Optimal Region Sizes Rounded by Bar command (or the corresponding 
key command, default:  Control-B) reduces or increases the length of a selected MIDI 
region, making it just large enough to contain the events (or regions, if a folder) within 
it. The region borders are rounded to the nearest bar.

Hold down Option when using this function to round the region borders to the nearest 
denominator value (or use the Set Optimal Region Sizes rounded by denominator key 
command).

Modifier Result

None Same absolute length change, no time correction

Shift Same absolute end position, no time correction

Option Same absolute length change, with time correction

Option-Shift Same absolute region length, with time correction

Control Can be used after clicking for finer resolution length changes, but can not be used in 
conjunction with Option, no time correction
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Cutting, Copying, and Pasting Regions
You can select, remove, or replicate one or more regions from one part of an 
arrangement to another. In fact, you can use the Cut, Copy, and Paste commands 
between the arrangements of two projects, if you wish.

To cut a region:
m Select the region, then choose Edit > Cut (or use the Cut key command, 

default:  Command-X). 

This removes the region from the Arrange and places it in the Clipboard.

To copy a region (method 1):
m Option-drag the region to the desired Arrange position.

If Hyper Draw or automation is enabled, you’ll need to grab the region name area in 
order to copy it.

To copy a region (method 2):
1 Select the region, then choose Edit > Copy (or use the Copy key command, 

default:  Command-C).

This copies the selected region to the Clipboard. 

2 Set the desired playhead position by clicking on the Bar ruler.

3 Choose Edit > Paste (Command-V) to paste the contents of the Clipboard into the 
Arrange. The paste will occur on the selected track at the playhead position. 

If several regions are selected, their relative time and track positions are retained.

To paste a region at the same position as the copied region:
m Select the track you want to paste the region into, then choose Edit > Paste at Original 

Position (or use the Paste at original Position key command).

Logic Pro inserts the copied region into the selected track, at the same position as the 
source region. This is useful if you want to copy a region to the same spot on a different 
track, to independently process or thicken the part, for example. This function is also 
ideal for creating layered MIDI and/or software instrument parts.

Information About Copied Regions
Copied regions are actually true, independent replicas of original regions. Changes 
made to a parent region will not affect child copies. 

If you want this type of behavior—where changes to the parent region affect child 
regions—make use of the Loop function (see “Looping Regions” on page 329), or 
create cloned or alias regions (see “Repeating Regions” on page 324).
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When you copy an audio region, a new region is automatically created in the Audio Bin. 
The new region will retain the name of the original, with a sequential number added. 
As an example, kickingloop.1 will be the name of a region copy, if the original region is 
called kickingloop. A second copy will be named kickingloop.2, a third kickingloop.3, 
and so on.

Adding or Removing Song Passages
There are many occasions where you will want to remove an entire passage from an 
arrangement—a chorus or verse, which encompasses the regions of all tracks between 
bars 16 and 20, for example. All existing regions, bar changes, tempo changes, and 
global score symbols (from bar 21 onwards) are moved 4 bars to the left, closing the 
gap left by the cut operation. 

You can also insert a gap into your arrangement—creating several blank bars, for use 
as a middle eight, to create space for another chorus or verse, or perhaps a bridge. As 
with cutting time, all existing tempo changes and so on are moved accordingly (to the 
right by the number of inserted bars). 

You can, of course, simply use the standard Edit menu Cut, Copy, and Paste commands 
to remove or re-use a section of your arrangement, such as a chorus, from one location 
to another.

You can limit changes to a few selected regions as well. If you choose to do this, rather 
than moving all regions within a song section, you need to decide whether or not any 
bar changes, tempo changes, and global score symbols should also be shifted. This is 
done in the dialog box shown below.

Press Return if you do not want to move tempo changes and global score symbols.

The abovementioned global edit is performed on all regions, when used. These 
functions are otherwise restricted to tracks that contain selected regions (or at least 
those that fall between the locator points).
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Using the Arrange Section Editing Buttons
The Arrange Toolbar features a number of section editing buttons that can be used to 
perform some of the operations covered below. Whenever these Toolbar buttons are 
used, the operation will affect all regions that fall between the locators, regardless of 
the selection status of regions in this area. If you want to perform these operations on 
selected regions within the locators, you should not use the Arrange Toolbar buttons. 
Make use of the appropriate Region > Cut/Insert Time menu command (or key 
command), after making your region selection.

To insert a gap into the arrangement, using the locators (the cycle length):
1 Set the left and right locator positions by doing one of the following:

Â Drag from left to right across the desired portion of the Bar ruler.
Â Set the desired values in the Transport’s Locator fields.

2 Select the regions you want to move by the cycle length. If no selection is made (or 
you use the Insert Silence button, in a customized Arrange Toolbar), all regions that fall 
between the locators will be affected.

3 Choose Region > Cut/Insert Time > Insert Silence Between Locators (or use the 
corresponding key command).

Â For selected regions that are longer than the cycle length:  This cuts them at the left 
locator position, and moves the second region (newly-created from the cut) to the 
right right locator position, creating a gap between the regions.

Â For selected regions that fall wholly within the locators:  Regions which began at the 
left locator position now begin at the right locator position.

Â For a combination of partially and wholly selected regions that fall within the 
locators:  The encompassed section will be cut, and moved to the right locator 
position.

You can also remove empty space between selected regions, creating seamless joins 
between them.

To remove gaps between regions:
1 Select the desired regions.
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2 Choose Region > Tie Regions by Position Change (or use the Tie Regions by Position 
Change key command).

The first region remains unchanged, and all subsequent regions are moved to the left.

Note:  You can use this feature to speed up the playback of spoken word recordings 
that have been processed with strip silence (by closing the gaps between words).

To remove a section of your arrangement, using the locators:
1 Set the locators to span the section you want to remove (bar 5 to 8, for example).

2 To cut all regions that fall between the locators:  Click the Cut Section button in the 
Arrange Toolbar, or use the Region > Cut/Insert Time > Snip: Cut Section Between 
Locators (or corresponding key command). 

3 To cut selected regions that fall between the locators:  Choose Region > Cut/Insert 
Time > Snip:  Cut Section Between Locators (or use the corresponding key command).

Any regions that span the cycle area (as an example, a 16 bar long region that starts at 
bar 1, and ends at the start of bar 17) are cut.

The section between the locators (bars 5 to 8) is deleted from all selected regions (in 
fact, it is copied to the Clipboard and removed from the arrangement). 

All regions to the right of the right locator are moved to the left by the length of the 
cycle (4 bars). This includes newly-created regions that result from the operation. 
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To use the example 16 bar region. It is cut into two regions:
Â One spanning bars 1 to 4.
Â The other is now an 8 bar long region that is placed from bar 5 to the start of bar 13.

∏ Tip:  The Snip command is ideal for situations where you want to remove an entire 
section of your arrangement, such as a chorus.

To insert a cut section into your arrangement:
1 Follow the steps outlined above.

2 Set the playhead to the position that you want to insert the cut section.

3 Either click the Insert Section button in the Arrange Toolbar (to affect all tracks, 
regardless of selection), or choose Region > Cut/Insert Time > Splice:  Insert Snipped 
Section at Playhead.

All selected regions are cut at the left locator, and a passage of one cycle length is 
inserted. Regions currently in the Clipboard are then pasted at the playhead position.

∏ Tip:  The Splice command is perfect when you want to insert a part (a chorus, for 
example) at another point in your arrangement. To ensure all tracks are shifted, 
including tempo, time signature changes, and markers, please select everything 
beforehand (with Command-A or Shift-I).

To repeat a section of your arrangement, using the locators:
1 Set the locators to span the section you want to repeat (bar 5 to 8, for example).

2 Select the regions that you want to repeat. If no selection is made (or you use the 
Repeat Section button in the Arrange Toolbar), all regions that fall between the locators 
will be affected.
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3 Choose Region > Cut/Insert Time > Snip: Repeat Section Between Locators (or use the 
corresponding key command).

The portions of all regions that are wholly, or partially, encompassed by the locators 
will be copied, and pasted to the right locator position.

Repeating Regions
Logic Pro provides a number of ways to repeat a region, through use of loops, aliases, 
and clones. These options make arranging faster and simpler.

Using MIDI Region Aliases
An alias in Logic Pro is like an alias in the Finder. It looks like a region, but contains no 
actual data. It is just a reference to the data of the original region—a virtual reflection 
of the original. 

The Relationship Between Parent and Alias Regions
If the data in the original region is altered, this immediately affects all aliases of the 
region. As examples of how aliases can be used:
Â If a riff or phrase reoccurs throughout an arrangement, it’s quicker to use aliases, 

rather than creating copies of the original region.
Â If a part is not quite right, you only need to alter the original, and the correction will 

automatically take effect throughout the whole arrangement. 

If, however, you want to alter a detail at one point in the arrangement (a pitch shifted 
verse, for example), you can turn that particular alias into an independent region (a 
region copy).

Aliases do have a level of independence from their parent region:
Â Aliases have their own set of region parameters.
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Â Aliases can be individually named. Alias region names are shown in italics. If you 
name an alias region, its parent region name will be shown below the alias name 
(provided that the zoom level is adequate). 

Any changes made to the parent region name will be reflected on all alias regions. 

Note:  MIDI region aliases can not be edited. If you double-click on an alias, Logic Pro 
assumes that you either; want to edit the original, or turn the alias into a real region. A 
dialog asks whether you want to create and edit a real copy, or to edit the original.

Creating MIDI Region Aliases
Aliases can be created for MIDI regions and folders. The term region only refers to MIDI 
regions and folders in this section.

Note:  Only cloned audio regions (or independent region copies) can be created for 
audio regions (see the “Cloning Audio Regions” section on page 327).

To create an alias, do one of the following:
m Option-Shift-drag the region to the desired position for the alias.

m Select the track you want to create the alias on, position the playhead, select the region 
you want to create an alias from, then choose MIDI > Alias > Make (or use the Make 
Alias key command).

The alias appears on the selected track, beginning at the current playhead position.

If several regions are selected, their relative time and track positions are retained. The 
selected track is the destination track for the first region along the time line.

You can also use the Repeat Regions command (see “Making Multiple Copies of 
Regions” on page 328).
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Reassigning MIDI Region Aliases
You can assign a new original region to an existing alias. This is exceptionally handy for 
arranging tasks where the structure is right, but the part is wrong. You can certainly 
copy a region to the appropriate position on a new track, create an alias, mute the 
existing region, and hit play, or use the far simpler method below:

To re-assign an alias:
1 Select both the alias and the intended new original region.

2 Choose MIDI > Alias > Re-Assign (or use the Reassign Alias key command).

Searching for an Original or Alias
If you have forgotten where the original is for a certain alias, you can search for it. 

To find and select the original region of an alias:
m Select the alias, and choose MIDI > Alias > Select Original (or use the Find Original of 

Alias key command). 

To find any aliases you’ve made from a region:
m Choose MIDI > Alias > Select All Aliases of Region (or use the corresponding key 

command, default:  Shift-A). 

All existing aliases will be found, and selected.

Selecting and Deleting Orphan Aliases
If you delete a source region that one or more aliases were derived from, Logic Pro will 
display the following warning message:

Â Cancel:  Click to cancel the erase procedure. 
Â Convert:  Click to change all alias MIDI regions into real copies. 
Â Keep:  Click to delete the parent region, and retain all (orphaned) alias regions. 

Although such orphan aliases serve no useful purpose, Logic Pro doesn’t 
automatically delete them, as you might decide to re-assign them to new originals at 
a later stage.

If your project file contains several unneeded aliases, you can quickly tidy up by 
selecting and deleting all orphan aliases. 

To select all orphan aliases:
m Choose MIDI > Alias > Select All Orphan Aliases (or use the Select All Orphan Aliases 

key command). 
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To delete all orphan aliases:
m Choose MIDI > Alias > Delete All Orphan Aliases (or use the Delete All Orphan Aliases 

key command). 

Converting an Alias Into a Real Region
You can use MIDI > Alias > Convert to a Region Copy (or the Convert Alias to a Region 
Copy key command) to make a real region from an alias; its contents will be identical to 
those of the original region referenced by the alias, but its playback parameters will be 
those of the alias. As a real region, you may freely edit it (or the original parent region, 
without affecting the new real region).

Note:  You can also double-click an alias to produce a dialog that asks whether you 
want to create and edit a real copy, or to edit the original.

Cloning Audio Regions
You can create another version of an audio region in the Arrange area—a cloned 
region, if you will—which is comparable to a MIDI region alias.

To create a cloned region:
m Hold Option-Shift while dragging an audio region. 

Whenever you adjust the start or end points of any of these cloned regions, all other 
cloned regions will also be adjusted in the same way. 

To make several cloned regions independent ofeach other:
m Select the desired (cloned) regions and choose Audio > Convert Regions to New 

Regions (or use the corresponding key command, default:  Option-Command-R) in the 
Arrange area. 

Cloned regions that are made independent in this way can have their start or end 
points altered, without all other cloned regions being affected.

To convert several selected regions into audio files:
1 Choose Audio > Convert Regions to New Audio Files (or use the corresponding key 

command, default:  Option-Command-F).
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2 In the dialog:  Set the desired sample rate, bit depth, file format, stereo conversion, and 
dither type for the destination files. 

The new audio files are created in the same folder as your original audio file. The files 
are also added to the Audio Bin, and all references to these new arrange regions are 
changed—to correspond with the newly created files. 

These newly created files can be independently edited, allowing you to reverse, time 
stretch, and more, without affecting other regions based on the same original file.

Making Multiple Copies of Regions
You can make multiple copies of both audio and MIDI regions using the Repeat 
Regions command. 

To make multiple copies of a region:
1 Select the region you want to make multiple copies of.

2 Choose Region > Repeat Regions in the Arrange area menu (or use the Repeat 
Regions/Events key command).

3 Set the following parameters in the Repeat Regions/Events window:

Â Number of Copies:  This is where you enter the number of copies (excluding the 
original).

Â Adjustment:  Choose whether you want a copy to begin at the end of the original 
(setting:  None), or whether you want the start point to be quantized (to the bar, 
beat, tick, and so on). 

Â As:  Copies/Aliases or Clones:  Here you set whether the repeats are copies, aliases 
(MIDI regions), or clones (audio regions) of the original.
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Looping Regions
The Loop function enables you to repeat a region automatically, without needing to 
copy it. A looped region will repeat until it encounters another region on the same 
track, or the project ends. A loop will also terminate at the end marker of a folder, if the 
looped region is inside a folder (see “Using Folders” on page 338).

Loop repeats are displayed as extended segments of the original region. Each segment 
is the same length as the original region, and will change if the length of the original 
region is changed. 

∏ Tip:  If you want to create polyrhythmic structures, try experimenting with the length of 
the original region.

To loop a region with the Loop parameter:
1 Select the region in the Arrange area.

2 Click (turn on) the Loop option in the Region Parameter box of the Inspector (or use 
the Toggle Loop key command, default:  L).

The region is looped until it encounters another region on the same track (or the 
project or folder ends).

To turn off the Loop parameter:
m Click the Loop option in the Region Parameter box (or use the Toggle Loop key 

command, default:  L). 

Region loops
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To loop a region with the mouse:
1 Move the cursor to the end of the region that you want to loop. 

The cursor will change into a circular arrow (the loop length editing tool) when 
positioned in the upper area of the region.

2 Click-hold and drag the end of the region to the right, as desired, to set the length of 
the looped region. 

The loop repeats are shown as segments (of the same length as the original region) 
within the overall looped region. The Loop parameter of the Region Parameter box is 
automatically enabled. 

Note:  Deactivation of the Loop parameter resets the manually created loop length. The 
next time the Loop parameter is used, the region is repeated until it encounters 
another region on the same track or the end of the project (or folder) is reached.

The cursor will only turn into the circular arrow (and offer the loop length editing 
functions), when the track is of sufficient height. Use any of the zooming options to 
resize.

If you want to select the looped region (to move it, for example), click in the lower half 
of the looped area, or Shift-click in the upper loop area. 

Note:  Most of the other tools can also be used to set the loop length (they take on the 
circular arrow shape when held over the top right of regions). You should use the 
Pointer tool, however, as clicking the wrong spot on a region with the Eraser tool 
selected will delete the region, rather than set the loop you intended to create.

Loop repetitions are merely pointers to the original region. They can not be transposed 
and don’t have any playback parameters in the Region Parameter box, shown in the 
Inspector. Only a real region (or a copy) offers playback parameters and may be 
transposed. If you’d like to use different playback settings for each of the loop 
repetitions, you need to turn them into real copies.

To convert an existing loop into a real copy:
1 Select the original region.

2 Choose Region > Loops > Convert to Real Copies (or use the corresponding key 
command, default:  K). New regions will replace the loop repeat segments. 
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The advantage of real copies is that they can be independently resized. This may be 
useful in situations where you would like to resize a few loop copies among hundreds 
that span the song length.

To convert a loop into aliases or clones:
1 Select the original region.

2 Choose Region > Loops > Convert to Aliases (or use the corresponding key command).

MIDI region loop repeats are converted into aliases. Audio region loop repeats are 
converted into cloned audio regions.

As such, any alterations to the length of the original region affect all aliases and cloned 
regions. 

Dividing, Demixing, and Merging Regions
There are often occasions where some portions of regions may be suitable for use, and 
others may not be. This section concentrates on functions that help you to split regions 
and reuse portions of them (or entire regions) to create new, combined regions. 

∏ Tip:  Don’t forget the Marquee tool (see “Selecting Parts of a Region” on page 305) for 
similar region editing tasks.

Dividing Regions
You can divide one or more selected regions with the Scissors tool. 

To divide one or more regions:
1 Make your region selections.

2 Select the Scissors tool.

3 Click-hold on the desired regions. 

The help tag shows the current divide position.

4 Release the mouse button.

All selected regions are cut at the position shown in the help tag. 

When selecting a cut point with the Scissors tool, you can move backwards and 
forwards in steps of one division. The grid is based on the Snap menu setting. 
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To make finer resolution divisions (overriding the current Snap value):
m Hold Control after you have selected the region with the Scissors to divide in the 

division value (1/16th, 1/32nd, and so on, as shown in the Transport). 

m Hold Control-Shift to divide regions with even more precision (ticks or samples).

The newly created segments of an audio region are named after the original, with a 
sequential number appended to the end of the name.

Divided MIDI regions are named after the original, with no sequential numbering. Each 
MIDI region resulting from the division is independent and contains data.

To divide a region into several portions with the same length:
m Hold Option while cutting a region with the Scissors tool. 

A plus symbol appears next to the Scissors tool, and the help tag shows Divide 
Multiple.

The selected region will be cut into several pieces—each the same length as the first 
segment.

As an example:  To divide a 16-bar region into eight 2-bar regions, cut the region at the 
start of bar 3, while holding down Option.

To divide regions at the locator positions:
1 Set the left and right locator positions as desired. 

2 Select the regions you want to divide within the locator boundaries. 
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3 Choose Region > Split/Demix > Split Regions by Locators (or use the corresponding 
key command). 

All selected regions located wholly, or partly, between the locators are cut at the left 
and right locator positions. All regions created between the locator positions as a result 
of the split operation, are then automatically selected.

∏ Tip:  You can achieve the same effect by defining a cycle with the mouse in the Bar 
ruler, while holding down Command. 

To divide regions at the playhead position:
1 Select the regions you want to divide. 

2 Choose Region > Split/Demix > Split Regions by Playhead (or use the corresponding 
key command). 

This splits all selected regions exactly at the playhead location. 

∏ Tip:  To cut at the nearest bar, use the Split Regions/Events by Rounded Playhead 
Position key command.

Handling Overlapping Notes in Divided MIDI Regions
If any notes in a divided MIDI region overlap other notes by more than a 1/16 note, the 
following dialog will appear:

Â Keep:  Click to leave all notes unaltered. The MIDI region is cut as expected, but you 
can end up with notes in the left-hand half (earlier region) that are much longer than 
the MIDI region containing them. Such notes will play normally, unless Clip Length is 
enabled (see “Note Handling Options When Changing MIDI Region Lengths” on 
page 315).

Â Shorten:  Truncates (shortens) all overlapping notes, so that they end at the point 
where the original MIDI region was divided.



334 Chapter 13    Creating Your Arrangement

Â Split:  Divides overlapping notes across the two MIDI regions; two notes are created, 
with the same pitch and velocity as the original, and with the same total length as 
the original note.

About Zero Crossings When Dividing Audio Regions
The Audio > Search Zero Crossings setting in the local Arrange menu has no effect 
when dividing audio regions, using any of the methods outlined above.

Audio > Search Zero Crossings, when enabled, only applies to alterations of the start or 
end point of a region, not divide operations.

If you want to automatically divide an audio file into multiple regions, make use of the 
Strip Silence function.

Dividing Audio Regions With Strip Silence
The Audio > Strip Silence function in the Arrange menu launches a window which 
allows you to slice an audio recording into different audio regions. This division is based 
on analysis of amplitude levels within the audio file. A detailed description of this 
function can be found in Chapter 22, “Removing Silent Passages From Audio Regions,” 
on page 519.

Merging Regions
You can merge two or more selected regions (of the same type—audio or MIDI) into a 
single region, making region handling easier, or as a creative option.

To merge two or more regions with the Glue tool:
1 Select the Glue tool.

2 Click the regions that you wish to merge (if necessary, use Shift during selection).

To merge two or more regions with the Merge Regions command:
1 Select the regions you’d like to merge with the Pointer tool.

2 Choose Region > Merge > Regions (or use the corresponding key command). 

This merges all selected regions, even those on different tracks, into a single region.

Glue tool
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To create several merge files—each on their own track:
1 Select the regions that you want to merge on each track with the Pointer tool. 

Shift-clicking, rubber-band selection, or Command-A may be useful for this.

2 Choose Region > Merge > Regions per Tracks (or use the corresponding key 
command).

The selected regions are combined into one region per track. As an example, tracks 1 to 
4 have regions that you’d like to merge. Make your region selections in each track lane, 
press Shift-J, and four merged regions will be created—one for each track.

What Happens When MIDI Regions Are Merged
When you merge MIDI regions:
Â All events from each individual MIDI region retain their original time positions. 
Â The new (merged) MIDI region adopts the name and track of the first (along the time 

line) of the original MIDI regions.
Â The Transposition, Velocity, and Dynamics region parameters—if not identical in all 

selected regions—are normalized before the merge. This means that all parameter 
values are written as data changes for each region before the merge. The parameters 
of the newly created (merged) MIDI region are all set to neutral (default) values.

Â If one of the region parameters (the Transposition value, for example) is set 
identically in all selected regions, that value is preserved in the Region Parameter box 
for the merged region, and the events remain unchanged from their original values.

Note:  Be aware that the individual MIDI channels of events (if applicable) are replaced 
by the MIDI channel of the current track Instrument channel strip.
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Merging Audio Regions
Merging audio regions is a non-destructive operation, as Logic Pro always creates a 
new file for the merged audio material (sometimes called a mixdown). 

This new audio file is stored (in the project folder) on your hard drive and is 
automatically added to the Audio Bin. The merged region replaces the original regions.

No Mixdown Situation
If there are several regions (mono or stereo) in a row on the same track, which have 
been cut out of one region with the Scissors tool, no mixdown happens. In this 
situation, a single region is simply created over the entire area. This delivers the desired 
result, without using any additional disk space.

Note:  Logic Pro can recognize associated regions, even if there are gaps between 
them. The determining factor is that the relative position of the regions in the Arrange 
corresponds to the relative position of the regions in the underlying audio file.

No mixdown occurs when you try to mix two regions on tracks that are panned to 
opposite sides, as the two resulting mixdown files would be identical to the original 
audio files (in the areas used for the regions). 

Genuine Mixdown With Clipscan
If you combine audio data (in regions) from two or more tracks, the current pan and 
volume values for the individual tracks will define the pan and volume settings in the 
new audio file. 

If you want to combine both sides of a stereo audio file (a mono channel on each of 
two tracks), first set the pan controls of the component mono sides to hard left and 
hard right, respectively.

Following the digital clipping scan (Clipscan) and completion of the mixdown, 
Logic Pro replaces the previously selected regions with one region that contains the 
entire mixed-down audio file. 

You can use the Edit > Undo function (Command-Z) to restore the original audio 
regions, if desired. If you do so, you’ll be asked if you’d like to keep, or delete, the newly 
created mixed audio file. If you decide to keep it, it will remain in the Audio Bin, and 
can be further used and processed.

During a mixdown, the 32-Bit resolution Clipscan function ensures that the highest 
possible level is maintained, without clipping.
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Mixdown of Audio Regions on a Track
If several overlapping audio regions are selected on a single track, no mixdown occurs. 
You are asked to create a new audio file, which is named after the first region on the 
track. The selected regions are then mixed together, with no changes to volume, and 
without clip scanning.

If there are empty sections between two regions, these are added into the new audio 
file—as silent passages.

Audio Crossfades in Digital Mixdown
The Digital Mixdown supports crossfades between selected regions.

The crossfade parameters are defined in the General Audio preferences tab, which can 
be opened either by choosing Logic Pro > Preferences > Audio > General (or the Audio 
Crossfade Options for Merge key command).

There are two faders:
Â Crossfade Time [ms]:  This is the length of the entire crossfade. To switch off the 

crossfade, set this value to zero.
Â Crossfade Curve:  To obtain a linear crossfade, set this value to zero. Other values 

(positive or negative), produce various exponential fades. The fade-outs and fade-ins 
are always symmetrical, to avoid deviations in level. The preset values are:  Time = 
0 ms, Curve = 0 (linear).

Demixing MIDI Regions
You can split MIDI regions (or Standard MIDI File Formats 1 or 0) by event channels or 
note pitches.

To split MIDI regions by event channels:
1 Select the desired MIDI regions.

2 Choose Region > Split/Demix > Demix by Event Channel (or use the corresponding key 
command)

Logic Pro searches the selected MIDI regions for events with different MIDI channels. 
Â A separate MIDI region, containing all matching events, is created for every MIDI 

channel that is found. 
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Â Each of these regions is created on a track with an instrument channel that matches 
the MIDI channel. 

Â If no such tracks exist, new tracks are created for each channel.

To split MIDI regions by note pitches:
1 Select the desired MIDI regions.

2 Choose Region > Split/Demix > Demix by Note Pitch (or use the corresponding key 
command). 

Logic Pro searches the selected MIDI regions for notes with different note numbers. 
Â A different MIDI region of the same length is created for every note number found.
Â Tracks are created for these MIDI regions, and all are assigned to the same channel 

strip as the original MIDI region. 

This feature is especially useful for separating drum parts that have been recorded into 
Logic Pro from a drum machine—where all notes are on the same MIDI channel. Each 
note region can then be assigned to another channel strip, or perhaps some can be 
deleted, to thin out the original drum pattern.

Using Folders
A folder is a region that can contain other regions, much like a folder in the Finder can 
contain other folders or files. In principle, you can edit folders as you would edit MIDI 
regions.

One way to visualize a folder is as an arrangement within an arrangement. A folder can 
contain as many tracks, featuring regions, as required. A closed folder looks like a MIDI 
region, but is placed on a track assigned to a folder in the track list, rather than a 
channel strip.

When opened, folders look just like the Arrange area and track list in a project.
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All regions in the folder are routed to, and played by, the channel strips set in the 
folder’s track list—as they would at the top level of the Arrange window.

Note:  If you drag a folder to a track that is set to an instrument channel strip, its entire 
contents (all MIDI regions within the folder) are played by this instrument. This usually 
only makes sense if the folder contains tracks for a given instrument or instrument 
type, such as a drum kit or generic string sound. This could be a quick way of listening 
to a string arrangement, if some of the intended sound sources are unavailable, for 
example.

As examples; a brass section folder could contain trumpet, saxophone, and trombone 
tracks, or perhaps 14 tracks of drum instruments, which you may want to treat as a 
single drum pattern region.

In the same way, your entire project, including all tracks and regions, could itself be a 
folder, appearing as a gray beam in an arrangement. In this way, you could arrange 
several projects for a concert.

This is not all that folders can do. You can use folders to represent song choruses and 
verses, for example. As in the Finder, you can place as many folders as you like within 
other folders, and within yet more folders (for the instrument groups within the 
different parts of the song, as an example), with no limit to the number of levels you 
can create.

Another possible use might be to store different arrangements of a project in different 
folders, allowing you to switch between them rapidly. 

Packing and Unpacking Folders
You can pack selected regions into a folder, or create an empty folder and add regions 
to it.

To pack selected regions into a folder:
1 Select the desired regions.

2 Choose Region > Folder > Pack Folder (or use the corresponding key command, 
default:  Command-F).

This places all selected regions into a folder. Logic Pro creates a track, and places the 
folder region on it. If an existing folder track is selected, Logic Pro copies the regions 
into this folder. 

If no region is selected, Logic Pro creates an empty folder. It contains no regions—just 
tracks assigned to all channel strips from the current level.
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To unpack a folder:
1 Select the folder.

2 Choose one of the following commands:

Â Choose Region > Folder > Unpack Folder command. The Arrange window will 
update to display the contents (the tracks and regions) of the folder.

Â Choose Region > Folder > Unpack Folders (Create New Tracks), or use the 
corresponding key command. 
Logic Pro will create new tracks on the same level that the folder was located on 
(below the former folder track). 

Â Choose Region > Folder > Unpack Folders (Use existing tracks).
The regions contained within it are placed on tracks assigned to appropriate channel 
strips.

Entering and Exiting Folders
Once you have packed a folder, you will generally enter and exit it to alter data, as your 
arrangement grows. You can easily differentiate when inside, or outside of the folder 
display in the Arrange window:
Â When at the top Arrange level (outside the folder), the folder itself will be visible on a 

track, the Arrange window title bar will show the project name, and the Hierarchy 
button is grayed out.

Â When inside a folder, the folder track can’t be seen, the Arrange title bar will show 
the project name, followed by the folder name (Untitled: Chorus Folder, for example), 
and the Hierarchy button will not be grayed out.

To enter a folder, do one of the following:
m Double-click the folder region.

m Select the folder you want to enter, then use the Go Into Folder or Region key 
command.

You should ensure that the folder is selected before using the command. If a MIDI 
region is selected, the Event List editor (showing the MIDI region content) is opened.

Double-clicking on a folder track name in the track list opens the Mixer.

To exit a folder, do one of the following:
m Double-click on the (folder) Arrange area background (or use the Go Out of Folder or 

Region key command).

m Click the Hierarchy button at the left end of the Arrange window menu bar. The help 
tag shows Leave Folder.

This will move you one level up the display hierarchy, and the contents of the Arrange 
window (showing the closed folder) will be visible.
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Adding and Removing Regions
You can easily add regions to, or remove regions from, an existing folder. This is fairly 
commonplace as you will often experiment with your arrangement, and find that you 
need to add or remove parts.

To move regions into a folder:
m At the top level of the Arrange hierarchy (outside the folder):  Drag the desired regions 

onto the folder, at the desired position.

If the folder does not already contain a track that uses the same channel as the source 
region, Logic Pro creates one. If it does, this channel will be used. When you enter the 
folder, you will see the dragged regions at the drop position.

To drag individual regions out of folders:
1 Open a second Arrange window from the Window menu, or with the default key 

command:  Command-1. 

2 Enter the folder that you want to remove the region from in one of the two Arrange 
areas.

3 Drag the region from the folder into the other Arrange area.

You can also cut a region from a folder, using the Edit > Cut command. This transfers 
the region to the Clipboard. You can then copy the region to the desired Arrange 
Arrange area position using the Edit > Paste command.
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Creating an Alias Folder
You can create a copy of a folder that contains aliases and clones of the regions in the 
original folder. The advantage is that, within this folder, you can (for example) mute 
regions, and alter program, instrument, or playback parameters, as desired. This 
provides you with an alternate mix folder—don’t forget that folders can be muted and 
soloed, like other regions—allowing you to quickly switch between different 
arrangement versions.

To create an alias folder:
1 Select a folder.

2 Choose MIDI > Alias > Make but Copy Folder.

Creating Crossfades and Fades on Audio Regions
You will often create fade ins or fade outs on audio regions, or use crossfades to 
smoothly segue between two adjacent (or overlapping) audio regions on a track.

The latter type of fade, the crossfade, can be performed automatically on overlapping 
audio regions by Logic Pro. 

To enable automatic crossfades:
m Simply choose the X-Fade setting in the Drag menu  (see “Using Drag Modes” on 

page 297).

The other fade types—fade ins and fade outs—as well as crossfades can be manually 
created with the Crossfade tool, or the Fade parameters in the Region Parameter box of 
the Inspector. 

∏ Tip:  You should make use of both methods, as each has advantages. When combined, 
the process of creating and editing fades is quicker and easier.

You can simultaneously adjust the fade parameters for all selected audio regions.

Note:  These fade parameters are non-destructive (they don’t change the original audio 
file), as opposed to the fade functions available in the Sample Editor. 
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Creating Fades With the Fade Tool
As you’d perhaps expect, a fade in starts at the beginning, and a fade out occurs at the 
end of an audio region. Fades are only visible if you are sufficiently zoomed in to see 
the waveform in the audio region. 

Important:  You can not create fades on Apple Loop files, represented as regions in the 
Arrange window. In fact, the Fade parameters are not shown in the Inspector when an 
Apple Loop region is selected.

To create a fade in or fade out:
1 Select the Crossfade tool.

2 Click-drag over the start or end point of an audio region. 

This creates a fade in or fade out. The length of the fade drag area determines the 
length of the fade, so a longer drag area will result in a longer fade time, and a shorter 
drag area, a quick fade.

To create a crossfade between two files:
m Drag over the end point of one audio region, or the start point of the following region 

with the Crossfade tool.

This works, even if the two sections don’t directly adjoin each other.

To delete a fade:
m Option-click on an existing fade area with the Crossfade tool.

To change an existing fade:
m Simply drag over the start or end point of a region with the Crossfade tool. The curve 

shape (see below) of the previous fade is retained.
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To adjust the fade curve shape:
m Hold Control and Shift while using the Crossfade tool. 

In the example below, a positive Curve is shown for both the fade in and fade out.

In the example below, a negative Curve is shown for the fade in, and a linear fade (no 
curve) is shown for the fade out.

Creating and Modifying Fades in the Region Parameter Box
You can also create and edit fades in the Region Parameter box.

To create a fade or crossfade:
1 Select the desired regions.

2 Set the desired value for the Fade In or Fade Out setting in the Inspector. Use the 
mouse as a slider, or double-click and type in the desired value.

As you do so, a fade is created at the beginning or end of the selected regions.

Note:  The fade value determines the length of the fade, so a higher value results in a 
longer fade time, and a low value, a short fade.

To delete a fade:
m Set the Fade In or Fade Out parameter to 0.

To change an existing fade:
m Edit the Fade In or Fade Out value.
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To adjust the fade curve shape:
m Edit the Curve value in the Region Parameter box. 

The fade curve is instantly reflected in the region. 

Changing the Fade Type
If you click the Fade Type menu (the up/down arrow beside the Fade parameter in the 
Inspector), you’ll see four options:
Â Out (default):  Creates a standard fade out whenever the Fade tool or Fade parameter 

is used.
Â X:  Crossfades the selected region with the following region when you use the Fade 

tool or Fade parameter. 
Â EqP:  Results in an Equal Power crossfade. This minimizes volume dips between audio 

regions, resulting in a more even crossfade between regions that may be slightly 
different in level.

Â X S:  Delivers an S-curve crossfade. The fade curve, as the name suggests, is S shaped. 

Note:  The latter three options can only be applied to two consecutive regions.

You should also note that the Fade In (and corresponding Curve) parameters are made 
redundant when any of the X, EqP, or X S options is chosen.

Deleting Fade Files
Use of the Options > Audio > Delete All Fade File command deletes the fade file. No 
information will be lost by doing this, because Logic Pro automatically creates a new 
fade file the next time playback is started, based on the fade parameters of each audio 
region. 

Fading Apple Loops
Apple Loops do not support fades, so you can’t directly assign a fade to them. As you 
can’t apply fades to an Apple Loop, no fade parameters are displayed in the Region 
Parameter box when an Apple Loop is selected. 

If you’d like to achieve a fade effect, you need to export the Apple Loop (choose File > 
Export > Region as Audio File in the main menu bar). Import this file into the Arrange 
area and apply the fade to it.
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Setting Region Parameters
The parameters displayed in the Inspector’s Region Parameter box depend on the 
region type selected in the Arrange area. There are parameters that are:
Â Available for audio and MIDI regions.
Â Only available for audio regions.
Â Only available for MIDI regions. 

Note:  The MIDI region parameters also apply to folders, and globally affect all MIDI 
regions within them. 

Common Audio and MIDI Region Parameters
There are only two common parameter which are available when either audio or MIDI 
regions are selected.

Loop
The playback of all region types can be continuously repeated by activating the Loop 
checkbox, or through use of the Loop tool (see “Looping Regions” on page 329). 

Delay
The playback of all region types can be delayed or advanced (this can be a positive or 
negative value) by ticks, or a musical format variable. As examples:  1/96, 1/16, 1/192, 
and so on (for more information, see “Shifting the Playback Position of Regions” on 
page 312).

There are also some default behaviors of the Region Parameter box:

MIDI Thru:  MIDI Region Defaults
If no region is selected, the upper line of the Region Parameter box will display MIDI 
Thru. Any live MIDI input (in stop mode, as well as during recording or playback) will be 
played with the settings chosen here. When you record a new MIDI region, the settings 
in the MIDI Thru Parameter box are carried across to the new MIDI region’s Parameter 
box. The MIDI Thru Parameter box can be viewed as an adjustable default Parameter 
box.

The MIDI Thru parameters can be adjusted when no regions are selected. Click on the 
Arrange window background to deselect all regions.

Note:  The Set Track & MIDI Thru Parameters by Region/Folder key command allows you 
to set the MIDI Thru parameters to match those of a selected MIDI region. This action 
also selects the region’s track.
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Editing Several Regions Simultaneously
If several regions are selected, the number of selected regions is displayed, in place of a 
region name. If you alter any region parameter, all selected regions will be affected. If a 
given parameter is set differently in the individual regions, a * appears in the Parameter 
field. You can alter this parameter for all selected regions, and the value differential will 
be retained (relative alteration). If you want to set all selected regions to the same 
value, hold down Option while changing the value (absolute alteration).

Audio Region Parameters
Audio region parameters vary, dependent on the type of audio region selected:  
basically this is broken down into Apple Loops or standard audio regions.

The Fade parameters are only available when standard audio regions are selected.

When Apple Loops (either green or blue) are added to audio tracks, the Follow Tempo 
and Transposition parameters are shown.

Follow Tempo
This parameter (on by default) allows Apple Loops to follow the project tempo.

Transposition
This parameter adjusts the pitch of the Apple Loop audio region up or down by the 
chosen amount.

MIDI Region Parameters
If you select a MIDI region (on a software or external MIDI track), the Region Parameter 
box displays the following MIDI region specific parameters. 

These parameters are also shown when a green Software Instrument Apple Loop is 
added to a track routed to an instrument channel (the Apple Loop instrument is loaded 
into the Instrument slot of the channel strip).

Quantize
All note events contained in the MIDI region are time corrected to the (quantize) grid 
format chosen in the menu. Full details on all quantization functions available in 
Logic Pro are found in Chapter 19, “Quantizing MIDI Events,” on page 453.

MIDI Region Parameter box
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Transposition
All note events contained in the MIDI region are transposed up or down by the 
selected amount during playback. Even complete folders can be instantly transposed in 
this way. If several individual MIDI regions within the folder have already been 
transposed, the relative differences between them are retained.

If you want to transpose by octaves, click on the arrows to the right of the 
Transposition parameter. This opens a pop-up menu that allows direct octave 
transpositions.

To guard against drum notes, and so on being transposed, an instrument channel’s 
Parameter box contains a No Transpose checkbox. If you activate this option, the 
transpose parameter is ignored in all MIDI regions played by this instrument channel 
strip (including green Apple Loops added to tracks routed to instrument channels).

Velocity
All notes in the relevant MIDI region are offset by the selected value. Positive values 
add to the originally recorded velocity, and negative ones subtract from it, although 
naturally it is impossible to go outside the limits defined by the MIDI Standard (0–127). 
If you select a velocity offset that exceeds the maximum or minimum possible value for 
a particular note, that note will play at the extreme possible range. As an example, a 
setting of +20 will cause a note with a velocity of 120 to play at 127.

Dynamics
This parameter also affects the velocity values of notes, but instead of adding or 
subtracting a fixed amount, the differences between soft and loud notes (the 
dynamics) are increased or decreased. This works in a similar way to a compressor or 
expander. Values above 100% expand the dynamics, thereby increasing the difference 
between loud and soft, while values below 100% compress the dynamics, reducing the 
differences between loud and soft.

The Fixed setting causes all notes to be transmitted at a velocity value of 64. When 
used in conjunction with the Velocity parameter (see above), it is possible to set any 
fixed velocity value.



Chapter 13    Creating Your Arrangement 349

Gate Time
The term gate time stems from the technology used in analog synthesizers, and refers 
to the time between pressing and releasing a key. This parameter affects the absolute 
note duration or length. This should not be confused with the musical note value, 
which normally refers to the amount of time until the next note. The practical effect is 
to make the notes in the region more staccato or legato. The parameter range is related 
to the original note lengths. Fix produces extreme staccato. Values below 100% shorten 
the note lengths. Values above 100% lengthen the notes. The “legato” setting produces 
a completely legato effect for all notes, no matter what their original lengths, 
eliminating all space between notes in the affected region. If this is used on a folder, all 
notes in all MIDI regions in the folder will be affected.

Fixing MIDI Region Parameters
You can normalize the MIDI region parameter settings of all selected MIDI regions and 
folders with the MIDI > Region Parameters > Normalize Region Parameters command. 

This means that all settings are actually written as data, and playback parameters revert 
to normal values. The audible result remains the same. The Loop parameter and 
extended MIDI region parameters are not affected. Use of this function is effectively like 
saying “make these MIDI region/instrument parameter values permanent.” In most 
circumstances, it is better not to do this, as leaving the original data untouched 
provides more flexibility. This includes unlimited opportunities to change your mind 
about MIDI region edits.

Normalize and MIDI Channels
As per the Merge function or the Glue tool, the Normalize function is intelligent in the 
way it handles stored MIDI channel numbers. If all stored events have the same MIDI 
channel number, the channel will be changed to that of the Instrument assigned to the 
current track. If the events are on different channels, Logic Pro will ask whether or not 
you would like to convert the event channels.

The following Normalize options are also available in the MIDI > Region Parameters 
menu:
Â Normalize without Channel:  Leaves the stored channel number untouched.
Â Normalize without Channel & Delay:  Leaves the stored channel number and Delay 

parameters untouched.

If the playback Instrument has a channel setting of All, or you’re dealing with a 
completely different type of Environment object (a channel splitter used as A-Playback 
for example), the stored MIDI channel numbers are also unaffected by the usual 
Normalize function.

Note:  If you’re editing MIDI regions that appear as notation on a polyphonic staff style, 
it is recommend to use the Normalize without Channel function, as the event channel 
is used to assign notes to individual polyphonic voices in the Score Editor.
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14 Recording in Logic Pro

This chapter covers all aspects of audio and MIDI recording 
in Logic Pro.

You will learn how to set up Logic Pro for audio and MIDI recording, and how to make 
use of several workflow features. These include cycle, multiple take, and punch 
recording methods.

Recording Audio
This section covers all information related to audio recording. Given the similarities in 
recording methods and region handling for both audio and MIDI data, many of the 
general audio recording techniques may also apply to MIDI recordings. MIDI-specific 
recording information is covered in “Recording MIDI,” from page 378 onwards.

A Quick Overview of the Recording Steps
The basic steps required to create an audio recording are listed below. Detailed 
descriptions of each step follow the overview.

To create an audio recording:
1 Check the setup of your recording system (see the ensuing section) to ensure that your 

hardware and software are communicating correctly.

2 In the Arrange track list:  Select the name of the audio track that you want to record to.

The corresponding channel strip is shown in the Inspector. 

3 Set the desired channel strip format.

4 Click-hold the Input slot of the channel strip, and choose the appropriate inputs of your 
audio interface from the pop-up menu. 

5 Arm the track by clicking the Record Enable button.

6 Drag the Level fader of the armed channel to the desired position, to set the 
monitoring level.
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Note:  The Software Monitoring checkbox must be enabled in the Audio preferences to 
hear incoming audio through Logic Pro (whether you are recording or not).

7 Click the Record button on the Transport, and start playing or singing.

8 Press Stop to end recording.

Preparations for Recording
You should check the setup of your system prior to recording. 

Make sure that any sound source you plan to use in your recording session—a mixer, 
CD player, or microphone, for example—is connected to the audio inputs of your 
system, and is working correctly. 

Check the hardware settings that are important for recording—such as the I/O buffer 
setting. Please refer to “Configuring Your Audio Hardware” on page 96 for details.

The quality, or precision, of the recorded audio file is directly tied to the sample rate 
and bit depth (and the quality of the converters in the audio hardware). All audio files 
are recorded at the project’s sample rate. You should ensure that the chosen sample 
rate (see below) fits your needs. 

You should also ensure that the preferred file type (AIFF, WAV, SDII, CAF) is chosen in 
the Recording File Type menu of the Logic Pro > Preferences > Audio > General 
preferences.

When you record audio into Logic Pro, the following happens:
Â An audio file is created on the hard disk.
Â An audio region, which represents the entire recorded audio file, is automatically 

created on the selected Arrange track. 
Â The audio file (and region) are added to the Audio Bin. The audio file will also appear 

in the Browser.

Setting the Sample Rate
You should set the sample rate when you start a project, and should avoid making 
changes to this after-the-fact. 

Note:  Any audio that does not match the project sample rate is automatically 
converted when it is imported, if the “Convert audio file sample rate” option in the 
Assets project settings is switched on. 
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To set a project’s sample rate, do one of the following:
m Choose File > Project Settings > Audio (or use the Open Audio Project Settings key 

command), and choose the desired sample rate in the Sample Rate menu.

m Click the Sample Rate display in the Transport bar, and choose the desired sample rate 
from the pop-up menu.

If you can’t see the Sample Rate display, this is probably because it has been replaced 
with the punch locators. Disable the Cycle button on the Transport bar to view the 
Sample Rate display. Another possibility is that you have not switched on the Sample 
Rate or Punch Locators checkbox in the Customize Transport Bar dialog. 

The Importance of the Sample Rate
Digital audio plays at a different speed when played at a non-matching sample rate. 
Digital audio needs to play at its original sample rate, or be converted to a different 
one, before playback at another sample rate. To explain; when a file which was created 
by sampling 96,000 times per second (96 kHz sampling rate), is played back at a rate of 
48,000 samples per second, it will play back slowly (half the speed).

In general, any bounces created for use within a project should be at the project’s 
original sample rate. You will gain nothing by bouncing at 96 kHz but then importing 
and converting to 44.1 kHz.

When finished with your project, bounce it at the desired sample rate. As suggestions 
for different situations:
Â If the bounced file is destined for an audio CD (assuming you’re not sending it to an 

external studio or application for mastering), there’s no need to go any higher than 
44.1 kHz, as this is the standard CD sampling rate.

Â If you work in the film or television industry, you will probably use the 48 kHz 
sampling rate for audio.

Â If recording classical or jazz groups (smaller ensembles), or archiving 75 year old 
recordings, you may find some benefits to recording at 96 kHz or higher. 
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Playback of 96 kHz (or higher rate) audio files places a far greater throughput burden 
on your system, and uses much more hard disk space. Recording at a 44.1 kHz sampling 
rate and 24 bit depth is recommended for most situations.

Setting the Bit Depth
Logic Pro defaults to 16 bit audio file recording. If you have suitable audio hardware, 24 
bit recordings offer a significant improvement in the available dynamic range. 24 bit 
files use one and a half times the disk space of comparable 16 bit files.

If you require 24 bit recording:
1 Open the Audio preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key 
command).

Â Click the Preferences button in the Arrange Toolbar, then choose the Audio 
command.

2 Click the Devices tab, then click the Core Audio tab. 

3 Turn on the 24 Bit Recording option.

Note:  If you use the DAE, click the DAE tab and choose the 24 (bit) option in the Global 
Bit Depth menu. 

Setting Up the Metronome
If you would like to hear the metronome (click) while recording, you can set this up in 
the Metronome project settings. 

To open the Metronome project settings, do one of the following:
m Choose File > Project Settings > Metronome (or use the Open Metronome Project 

Settings key command).

m Click the Settings button in the Arrange Toolbar, and choose Metronome from the pop-
up menu.
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m Control-click the Metronome button in the Transport, and choose Metronome Settings 
from the pop-up menu.

The Metronome Project Settings window combines all settings for:
Â A software instrument metronome sound source called KlopfGeist, which is turned 

on by default. You can disable it with the Software Click Instrument (KlopfGeist) 
checkbox.

Â The Environment’s MIDI Click object (see “MIDI Click Object” on page 913). You can 
specify the MIDI Port it is sent to (All, by default). To turn off the MIDI metronome 
output, choose Off in the MIDI Port pop-up menu.

You can use these click sources in isolation, or in combination with each other.

KlopfGeist is a software instrument found in the Plug-in menu of Instrument slots. 
KlopfGeist is inserted into instrument channel 128, by default. Logic Pro will 
automatically create instrument channel 128 (with KlopfGeist inserted) when the 
KlopfGeist checkbox is turned on. Theoretically, any other Logic Pro or third-party 
instrument could be deployed as a metronome sound source—using instrument 
channel 128. For more information about the KlopfGeist instrument, please refer to the 
Logic Studio Instruments and Effects manual. 

To set up the metronome for recording:
1 Define when you want to hear the metronome click:  on every bar, beat, or division by 

activating the corresponding (Bar, Beat, and Division) checkboxes.

2 Turn on the “Click while recording” option (it is active by default). Also set the “Only 
during count-in” and “Click while playing” options to meet your needs. It is suggested 
that you leave the Polyphonic Clicks option enabled, as this allows for overlapping 
clicks.
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3 Click the Recording button at the top of the Project Settings window, to open the 
Recording project settings.

4 Enable the Count-in radio button (active by default). 

5 Choose the desired count-in period that will precede recording. These options are 
available in the pop-up menu.

Â None:  The recording begins with no count-in.
Â x Bars:  X bars of count-in.
Â x/4:  The count-in time signature may be set here. These settings are useful when the 

count-in (and, presumably the recording) falls across a bar line.

For more information on the Metronome project settings, please see “Metronome 
Settings” on page 941.

Using Software Monitoring
The Software Monitoring function allows you to monitor incoming audio through any 
effects plug-ins that are inserted into an armed audio channel. Audio inputs must be 
assigned on the record-enabled tracks for software monitoring functionality.

The effect plug-ins are monitored but not recorded. This can be useful during a 
recording session. As an example:  During vocal recording, many singers prefer hearing 
their performance with a little reverb, but the track is recorded dry (without effects).

To monitor a track with effect plug-ins during recording:
1 Turn on the Logic Pro > Preferences > Audio > Devices > Core Audio > Software 

Monitoring option. 

Note:  No monitoring of any kind will occur if this option is switched off for the 
currently active audio hardware. 

2 Insert the desired effect into the audio channel, arm the track, and start recording. 

The effect will be part of the monitor mix, but will not be recorded.
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Auto Input Monitoring
If Auto Input Monitoring is switched on, you will only hear the input signal during the 
actual recording—before and afterwards, you’ll hear the previously recorded audio on 
the track, while the sequencer is running. This helps you to judge punch in and punch 
out points when punch recording. If Auto Input Monitoring is switched off, you will 
always hear the input signal. Auto Input Monitoring, when switched on, also allows you 
to hear the input source when Logic Pro is stopped, making it easy to set levels.

To switch auto input monitoring on, do one of the following:
m Choose Options > Audio > Auto Input Monitoring from the main menu bar (or use the 

Toggle Auto Input Monitoring key command).

m Control-click the Record button in the Transport, and turn on the Auto Input 
Monitoring setting in the pop-up menu.

There are a couple of circumstances that can be problematic when using auto input 
monitoring with record-enabled tracks:
Â Singers cannot hear themselves while Logic Pro is in play or record mode. All they 

can hear is the old recording. Switch off Auto Input Monitoring in this situation.
Â The track cannot be heard, even though Logic Pro is not in record mode. Switch on 

Auto Input Monitoring to hear audio on the track.

Depending on the situation, both options can be useful. Normally, Auto Input 
Monitoring will be turned on, and only switched off in specific circumstances.

Using the Input Monitoring Buttons
You can use the Input Monitoring buttons to monitor audio tracks that are not armed. 
Simply enable the Input Monitoring button on an audio track (or channel strip in the 
Arrange or Mixer windows). This works when Logic Pro is stopped or playing.

To determine what signal (input) is monitored:
m Choose the appropriate input (or input pair) from the Input slot menu of the 

corresponding audio channel strip.
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∏ Tip:  As a general workflow tip, you can leave the Input Monitoring button turned on, 
before, after, and during recording. When the Input Monitoring button is switched on, 
the Record Enable button or Auto Input Monitoring facility do not affect software 
monitoring. When punch recording, however, you should use the Auto Input 
Monitoring function rather than the Input Monitoring buttons.

Possible Problems With Input Monitoring
You should note that input monitoring always involves a little latency. Latency is 
entirely dependent on the audio hardware’s capabilities, and driver settings. In certain 
configurations, you may be best served by not monitoring through Logic Pro at all, 
thus obtaining the best possible timing. Route the signal that you want to record 
directly to headphones or the monitoring amplifier for monitoring purposes (and to 
the audio interface inputs, for recording). You won’t accidentally overdrive your A/D 
converters, as the input level meters of Logic Pro will display a clip warning if an 
overload occurs.

Setting the Monitoring Level
If the Independent Monitoring Level (for Record Enabled Channel Strips) preference in 
the Logic Pro > Preferences > Audio > Devices > Core Audio tab is enabled, an 
independent monitoring level is available when an audio channel is record enabled. 
After arming the track, set the fader to the desired level. The original playback level will 
be restored when the channel’s Record button is disabled. 

Important:  The Level fader only controls the playback (or monitoring) level, not the 
recording level, when a track is record enabled. Recording levels must be set 
externally—on your mixer, or at the original sound source. Care must be taken when 
setting input levels, as digital audio will clip when overloaded. Clipping results in a 
particularly harsh, metallic distortion, so unless you have a penchant for heavier 
musical styles, overloading the inputs isn’t recommended  (see “Understanding the Clip 
Detector” on page 548)!

Setting the Recording Folder
You should define a target (on your hard disks) for audio data before recording.

Note:  If you save your project with its assets, Logic Pro saves your project file (the 
“song”) into a project folder. The project folder contains an automatically created “Audio 
Files” folder—which is used as the default recording folder. 

If you prefer to save your projects without assets, however, the following section will be 
of interest.
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You can set a different “recording” folder for each project. You can also define different 
paths for each audio hardware system that is running (if applicable to your Logic Pro 
system). As an example, Core Audio could use the internal Macintosh hard disk and 
your DAE hardware could be set to use an external FireWire hard drive. You define the 
recording folder in the Recording project settings. 

To define the recording folder:
1 Open the Recording project settings by doing one of the following:

Â Choose File > Project Settings > Recording (or use the Open Recording Project 
Settings key command). 

Â Click the Settings button in the Arrange Toolbar, and choose Recording from the 
pop-up menu.

Â Control-click the Record button, and choose Recording Settings from the pop-up 
menu.

2 Click the Set button to open a file selector, and browse to the desired recording folder. 

Maximum Recording Size
The AIFF and SDII file formats can not handle audio file recordings larger than 2 GB:
Â For 16 bit, 44.1 kHz stereo files, this equals a recording time of about 3 hours and 15 

minutes. 
Â For 24 bit, 96 kHz, 5.1 surround files, this equals a recording time of about 20 minutes.

The WAV file format can not handle audio file recordings larger than 4 GB:
Â For 16 bit, 44.1 kHz stereo files, this equals a recording time of about 6 hours and 30 

minutes.
Â For 24 bit, 96 kHz, 5.1 surround files, this equals a recording time of about 40 minutes.

If the size of your recording will exceed these limits, you should choose CAF as the 
recording file type. CAF can handle the following recording times:
Â About 13 hours and 30 minutes at 44.1 kHz
Â About 6 hours at 96 kHz
Â About 3 hours at 192 kHz

The bit depth and channel format (mono, stereo, surround) do not affect the maximum 
recording size of CAF files. 

You can define the preferred file type in the Recording File Type menu of the Logic Pro 
> Preferences > Audio > General preferences.
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Audio Recording Names
The track name is used as the default file name for a recording. Subsequent recordings 
made on this track will be assigned an ascending numerical suffix. “Audio 1” will be 
named “Audio 1_01”, “Audio 1_02”, and so on. If the track is not named, the name of the 
channel strip that the track is routed to will be used. You can rename tracks in the 
Arrange track list and Mixer windows (see “Naming Tracks” on page 191 and “Renaming 
Tracks in the Mixer Window” on page 577).

Setting Up Track Channels
If you want to make adjustments to audio channel strips, you can do it directly in the 
Arrange channel strip. You can also use the Mixer window to adjust channel strip 
settings. Full details in “Setting Channel Strip Levels” on page 546.

Making Mono, Stereo, or Surround Recordings
Logic Pro allows you to make mono, stereo, or surround recordings.

To switch the recording format of a channel:
m Click-hold the Format button of the channel strip, and choose the desired format from 

the pop-up menu.

The symbol on the button indicates the current status as follows:

Â Mono:  One circle represents a mono input format. The level meter shows a single 
column.

Â Stereo:  Two, interlocked circles represents a stereo input format. The level meter 
divides into two independent columns when a stereo input format is chosen.

LeftStereo Right SurroundMono
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Â Left:  Two circles, left one filled, indicates a left channel input format. When this input 
format is chosen, only the left channel of a stereo audio file is played back. The level 
meter shows a single column.

Â Right:  Two circles, right one filled, indicates a right channel input format. When this 
input format is chosen, only the right channel of a stereo audio file is played back. 
The level meter shows a single column.

Â Surround:  Five circles indicates the surround channel input format. The level meter 
divides into multiple, linked columns (the number matches the project surround 
format).

Enabling One or More Tracks for Recording
Audio tracks must be manually record-enabled (armed) before recording, just as you 
would with tracks on a tape recorder. The Record Enable button turns red to indicate 
this armed state. 

You can only make audio recordings on armed tracks, irrespective of which track name 
is selected in the Arrange track list.

If several Arrange tracks are routed to the same channel strip (“Audio 1”, for example), 
the new audio file will be recorded to the selected track (routed to “Audio 1”). If none 
are selected, audio will be recorded to the first (top) of these tracks.

Space is reserved on the hard disk for armed tracks, and will no longer be available for 
Undo files. For this reason, Logic Pro will automatically disarm audio tracks when 
editing in the Sample Editor, or if the hard disk is nearly full.

Important:  You can only activate the Record Enable buttons of audio tracks that have a 
unique input. Simultaneous arming of multiple tracks that use the same input (selected 
in the Input slot) is not possible.

To enable one or more audio tracks for recording, do one of the following:
m Click the Record Enable button on the desired track (or tracks) in the track list. 

m Click the Record Enable button of all track channels (in the Mixer) that you wish to 
record to. 

m Select the desired track (or tracks) in the Arrange area and use the Record Enable Track 
key command. 
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Note:  If these buttons are not visible in the track list, choose View > Configure Track 
Header. In the dialog, click the Record Enable checkbox. If this checkbox is active, but 
the switch is still not visible, you should activate the relevant audio hardware in 
Logic Pro > Preferences > Audio > Audio Hardware & Drivers.

To disable a record enabled track:
m Click the (illuminated) Record Enable button a second time in either the track list or 

Mixer.

To disarm all record enabled tracks:
m Option-click on the flashing Record Enable button of any record-enabled track channel.

Enabling Simultaneous MIDI and Audio Track Recording
There may be occasions where you want to simultaneously record audio and MIDI 
tracks—perhaps to capture a live band recording, with the keyboard player using one 
or more Logic Pro software instruments.

You can simultaneously record to multiple MIDI tracks and several audio tracks (see 
“Recording on Multiple MIDI Tracks” on page 382). 

Note:  You can only activate the Record Enable buttons of audio tracks that have a 
unique input. Simultaneous arming of multiple tracks that use the same input (selected 
in the Input slot) is not possible.

To enable multiple audio and MIDI tracks for recording:
1 Click the Record Enable button on the audio tracks you want to record to. 

2 Click the Record Enable buttons of the MIDI tracks.

Making an Audio Recording
Logic Pro offers several recording modes or methods, that are suited to different 
recording situations and tasks. These are:
Â Standard recording:  Arm a track and click the Transport bar’s Record button.
Â Take recording:  Much like standard recording, but multiple recordings over the same 

section of a single track are automatically packed into “take folders.”
Â Punch recording:  You can manually or automatically “punch-in” and “punch out” at 

particular project positions, allowing you to record over an existing region.
Â Replace recording:  Generally combined with punch recording mode, where the new 

recording replaces the original recording (or a portion of it).

All recording modes can work in conjunction with Cycle mode, allowing you to record 
over a continuously repeated section of your project.
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Standard Recording With a Count-in
You can start recording at any point in a project by setting the playhead to the desired 
location. Presuming that the recording tracks are correctly set up (the desired audio 
hardware inputs are connected, adjusted, and selected as the input source on the 
channel), and the track is armed:

To start recording:
m Click the Record button on the Transport or (or use the Record key command, 

default:  *).

The count-in x defined in File > Project Settings > Recording is heard. Any audio 
present during the count-in will be recorded. During recording, a progress indicator 
displays the remaining recording time and the elapsed time.

To stop recording:
m Click the Stop button on the Transport.

Logic Pro will automatically create an audio region in the Arrange area, and will create 
an overview of the audio file. This is a graphic file that is used to display the waveform. 
You can play the new recording while the overview is being created.

Note:  If you paused recording (by pressing the Pause button), you can resume the 
recording by clicking the Record, Pause, or Play button. Recording begins at the current 
playhead position.

Advanced Recording Commands
Several advanced recording commands can make the recording process much faster. 
You should take advantage of these, as applicable, during your recording sessions.
Â Record:  The (default) Record command initiates recording. When used while 

recording, it does nothing, and recording continues. You will need to press Stop to 
end the recording (default key command:  Asterisk key on numeric key pad). 
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Â Record/Record Toggle:  When used while recording, recording is temporarily 
suspended, but playback continues. Use this command again, to resume recording 
from the current playhead position.

Â Record/Record Repeat:  When used while recording, the running recording is deleted, 
the playhead is moved back to the (recording) start position, and a new recording 
begins immediately.

Â Discard Recording and Return to Last Play Position:  This key command discards the 
running recording, deletes the corresponding files from the Audio Bin, and moves 
the playhead back to the last play position (default key command:  Command-
Period). 

It differs from Record/Record Repeat in that it doesn’t automatically start a new 
recording immediately. This allows talkback communication while Logic Pro is stopped. 
You will need to manually start a new recording (with any “Record” command).

Configuring the Transport Bar’s Record Button
You can change the Transport bar’s Record button functionality from Record (default) 
to Record Toggle, or Record Repeat. 

To configure the Transport bar’s Record button:
m Control-click the Record button, and choose the desired option from the menu.

The active command is indicated by a checkmark.

Recording Takes
Logic Pro provides advanced take management facilities. A take is a part (a guitar solo, 
for example) that is performed and recorded multiple times. You can record several 
consecutive versions of a solo, and pick the best “take,” for example. Takes are usually 
created by recording in Cycle mode, but can also be created by simply recording over 
existing regions. 

Takes also form the basis for comping tasks, where the best performances (from several 
takes) are compiled into a single “super take.” This comp(ilation) will be used as the 
final version of your take. Full details on comping are found in “Creating Comps” on 
page 374.
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The preparation for take recording is identical to that for audio recording. No special 
setup is required, so you can start take recording as you would for any audio recording. 
See “Standard Recording With a Count-in” on page 363.

The first take appears as an audio region, as per usual. Once a recording takes place 
over an existing region (the second pass of a cycle recording ends, and the third cycle 
begins, or you manually stop recording after the first bar, for example), a take folder is 
created. 
Â The whole recording (all takes) is stored as a single audio file.
Â The take folder only occupies a single track (but it can be opened, more on this 

shortly).

Note:  Take folders are only created when Replace mode is disabled (which is the 
default).

How Take Folder Recording Works
This section outlines how takes are handled in different recording circumstances.

Recording Over a Region
When you record over an existing region, a take folder is created—the longer of the 
two regions determines the take folder size.

When cycle recording:
Â Manually stopping a recording inside the first bar of a cycle repeat (a four bar 

recording is stopped half-way through bar one, on the fourth pass of a cycle 
recording, as an example) will result in this small section being discarded. Logic Pro 
assumes you stopped recording a little late, and views this as an “accidental” 
recording.
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Â Manually stopping a recording after the first bar of a cycle repeat (a four bar 
recording is stopped half-way through bar two, on the fourth pass of a cycle 
recording, as an example) will automatically create a “comp” consisting of the last 
take and the second last take.

Note:  Take recordings that are longer than one bar, but not the full length of the take 
folder (or region) are automatically “comped.”

Recording Over a Take Folder
When you record over an existing take folder, the new recording is added to the take 
folder (and selected for playback). 
Â If the new recording starts earlier or ends later, the take folder extends to match its 

size. 
Â If the new recording starts later or ends earlier, a new comp is created, consisting of 

the former take or comp, supplemented by the new recording.

Recording Over Multiple Take Folders
When recording over multiple existing take folders—placed one after the other on a 
track lane—the new recording is split at the beginning of each take folder (after the 
first take). 
Â Each section will be assigned as a new take in each take folder. 
Â Earlier take folders are extended in length until they reach the start point of the 

ensuing take folder (if there is a gap between take folders).

Adding Existing Recordings to Take Folders
While not a recording function per-se, you can also drag and drop other recordings 
(regions or audio files) onto an existing take folder:
Â If the dragged region is of the same length as the take folder, it will be added as a 

new take. The new region will be selected for playback. 
Â If the dragged region is longer than the take folder, the take folder is resized. The new 

region will be selected for playback.
Â If the dragged region is shorter than the take folder, a new comp will be created. The 

new comp consists of the former take or comp, supplemented by the new region.

Important:  Take folders are only created when a recording has been made. If you 
attempt to drag a region onto another region that was originally imported (not 
recorded), this will not create a take folder. You can, however, “pack” a take folder from 
any selected regions—recorded or imported (see “Packing a Take Folder” on page 377).
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Viewing the Contents of the Take Folder
You may need to access the contents of the take folder during take recording (to delete 
a take, for example).

To open a take folder, do one of the following:
m Click the disclosure triangle on the upper left corner of a take folder. 

m Double-click the take folder.

The contents of the take folder will be displayed on temporary Arrange track sub 
lanes—below the take folder itself. The most recently completed (or nearly completed) 
take is selected by default. The selected take will be heard during playback.

To select different takes when viewing an open take folder:
m Click on the corresponding take header.
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To select different takes when viewing a closed take folder:
m Choose the desired take from the Take Folder menu, that opens when you click the 

arrow at the top right corner of the take folder.

The waveform data of the selected take is displayed in the take folder.

Creating Comps in Real Time
You can mark good take sections while recording, resulting in a perfect comp 
immediately after recording has finished. 

To mark a good take during recording:
m Use the Select Previous Section for Realtime Comping key command.

This places a (non-visible) tag in the current take, at the position the key command was 
used. All audio that preceded use of the key command is tagged as a good take, which 
will be used in the final comp.

Multi Track Take Recording
Take recording (and comping) is also possible when recording multiple tracks.

Usually, the take folders on multiple tracks are edited independently, but they can be 
handled as a group. Simply add multiple tracks to an Edit Group (use the Group menu 
on the respective channel strips, and enable the Editing group property, see “Defining 
Group Settings” on page 564).

When grouped in this way, all take editing is synchronized between all member tracks. 
Any of the take folders can be opened, and any edits or comps performed in the open 
folder are immediately reflected in all other take folders at the same position (on tracks 
in the edit group).

Ideally, you should group tracks before recording, or at least before comping. You can, 
however, group tracks after editing one or two of them. This can be useful when a few 
take folder comps need special attention, but all following edits will be applied to all 
takes in the group. 
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Note:  If you attempt to edit one of the (pre-group) edited tracks, Logic Pro will offer to 
remove it from the edit group.

Coloring Takes While Recording
Selected take folders (or take regions in an open take folder) can be independently 
colored, as you would with standard regions or folders, when Logic Pro is not 
recording.

When recording is taking place, however, changing the color of the take folder will 
color the take region (being recorded), not the folder!

Punch Recording
Punch recording is a term used to describe overwriting a portion of a previously 
recorded passage while Logic Pro is running, in order to fix a mistake in an otherwise 
good recording. You “punch-in” just before the mistake, then “punch out” of the 
recording, once the mistake is corrected (you’ve recorded over it).

This allows you to play a recording up to a certain point, make a new recording over a 
section of the original, and continue playback in one continuous process. The ability to 
hear the part you want to replace (within the context of the music that precedes it) 
enables you to capture a better feel with your punch recording. 

Logic Pro offers two ways to punch record:
Â You can use a key command to engage recording while in playback mode (this is 

commonly known as punching “on the fly”).
Â You can use the Autopunch feature of Logic Pro to start and stop recording at 

predefined punch-in and punch-out points.

Note:  Only record-enabled tracks are affected by punch recording.

Punch on the Fly
The Punch on the Fly feature allows you to engage recording while in playback 
mode—in real time, or “on the fly.” 

This function is technically difficult to perform for hard disk recorders, due to the 
unavoidable delay involved in switching between read and write modes (creating a file 
and so on). To avoid this delay, you need to switch on Punch on the Fly mode, which 
readies Logic Pro for a recording at any time.

In practice, “recording” is happening in the background from the moment you start 
playback—when Punch on the Fly mode is active.

To punch in to a recorded passage on the fly:
1 Switch on the Punch on the Fly mode by doing one of the following:

Â Control-click the Record button in the Transport, and switch on Punch on the Fly in 
the ensuing pop-up menu. 
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Â Choose Options > Audio > Punch on the Fly in the main menu bar (or use the Toggle 
Punch on the Fly key command).

2 Start playback and use the Record Toggle key command at the point where you want 
to start recording. 

Audio recording will start immediately. Recording can be halted at any time, by 
pressing Stop or by using the Record Toggle key command a second time. If you use 
the latter option, recording ends, but playback will continue.

Note:  You can also use the Record Toggle key command when Logic Pro is not in 
Punch on the Fly mode, but this will cause a delay when switching between playback 
and recording modes. 

Pre-Programmed Punch-Recording
Autopunch describes the automatic activation and deactivation of recording at 
predefined positions. The advantage of the Autopunch function is that you can 
concentrate on your playing, rather than controlling Logic Pro. Another advantage is 
that starting and stopping recordings can be set far more precisely than would be 
possible if you manually activated and deactivated record mode. 

The Autopunch function can be used for audio, instrument, or MIDI tracks. 

To record in Autopunch mode:
1 Turn on the Autopunch button in the Transport.

The left and right autopunch locators serve as punch-in and punch-out points. The 
Autopunch recording area is indicated by a red stripe in the middle third of the Bar 
ruler. 

If both Cycle and Autopunch modes are active, you will see a pair of locators in the 
Autopunch area. Two stripes are shown in the Bar ruler; the top (green) one represents 
the Cycle area, and the bottom (red) one, the Autopunch area. These can be adjusted 
independently.

2 Set the Autopunch area by doing one of the following:
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Â Use the autopunch locator fields in the Transport to set the Autopunch area 
numerically. Please note that the Sample Rate or Punch Locators setting in the 
Customize Transport Bar dialog must be active, before you can see and set the 
Autopunch locators (to the right of the standard locators).

Â Alter the Autopunch range graphically in the Bar ruler, just as you would with a cycle. 

3 Place the playhead at any position before the punch-in point. 

4 Start recording.

5 Stop recording. 

A region that exactly matches the length of the autopunch stripe will be created. Any 
audio input received before the punch-in or after the punch-out points streams 
through Logic Pro as per usual, but is not recorded. 

Logic Pro will begin recording about a bar before the punch-in locator. This allows the 
start point of the region to be adjusted later, enabling you to hear the lead-in, if 
desired.

You can also recover the beginning of the recording if the performer slightly 
anticipates the autopunch area. Any such adjustments to the lead-in portion of the 
region do not change the position of the recording, relative to the time axis of the 
project. 

Recording automatically begins at the punch-in locator, following the count-in, even if 
the playhead is positioned after the right locator when recording starts. 

If Autopunch is enabled during recording, the Record button will flash while the 
playhead is outside the area encompassed by the punch in/out locators. This indicates 
that no recording is currently taking place. 

Combining Cycle and Autopunch Recording
If you want to improve a difficult part of a certain passage, you can use a combination 
of the Cycle and Autopunch functions. Cycle mode recording allows you to practice as 
many times as you like before performing the final take. On each cycle pass, only 
events or audio that falls within the autopunch stripe is recorded. This allows you to 
make use of the preceding song section to “get into the groove.”

Recording With Skip Cycle
If Skip Cycle is switched on, the cycle area is bypassed during recording.
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Replace Mode Recording
In Replace mode, newly recorded data is stored in a new region, as per a standard 
recording. In addition, any existing region on the destination track is cut at the punch 
in and out points of the recording, and data between these points is deleted.

To activate Replace mode:
m Switch on the Replace button on the Transport. 

Combining Cycle and Replace Recording
When cycle recording in Replace mode, existing regions (or portions of them) are only 
deleted during the first cycle pass—from the punch-in point to either; a punch-out 
point or the end of the cycle. 

When the second cycle pass begins, recording continues, but no further regions (or 
portions of them) are deleted. If you want to replace the end of an existing region, you 
don’t need to stop recording before the second cycle pass begins:  the start of the 
existing region remains intact.

Handling Audio Recordings
After creating one or more recordings, you may wish to delete one or more of them, or 
perhaps merge or create a comp with several takes. These types of tasks are often 
performed immediately after recording. 

Region editing and arrangement tasks are discussed in Chapter 13, “Creating Your 
Arrangement.”

A Note About Tempo and Audio Recordings
Audio recordings made in a given project can follow the project tempo by enabling the 
Follow Tempo checkbox in the Region Parameter box (for more information, see “Using 
the Follow Tempo Function” on page 526).
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Note:  Follow Tempo is not available for take folders. If you want a take folder recording 
to follow the project tempo, you need to flatten and merge it (see “Flatten and Flatten 
and Merge” on page 377).

Audio regions created in another project, or audio files imported from another 
application, can not automatically adjust to the project tempo (the Follow Tempo 
checkbox is not shown in the Region Parameter box).

Such audio files have a fixed playback rate, and can only be matched to new tempos by 
doing one of the following:
Â Time stretching or compressing the files (or regions):  Logic Pro’s time compression/

expansion algorithms only permit you to match audio to new tempos when the 
tempo differences involved are relatively small; if you try to significantly change the 
tempo of your recordings, audio quality may be compromised (see “Time Stretching 
Regions” on page 525).

Â Changing the audio files into Apple Loop format files. This file type makes 
transposition and time stretching tasks much easier (see Chapter 28, “Creating Apple 
Loops,” on page 615).

Deleting Audio Recordings
Deleting an audio region is handled a little differently for files that are recorded in the 
current session, and those that are imported from an earlier session.

To delete an audio region that you have recorded since opening the project:
m Select the audio region, and press Backspace. 

A dialog asks if you also want to erase the corresponding audio file. This saves hard 
drive space used by bad takes and unwanted recordings.

To delete an audio recording that was made before the current session:
m Select the audio region, and press Backspace. 

This will only remove the audio region from the arrangement, not the audio file (from 
the Audio Bin). No dialog appears. This prevents you from accidentally deleting 
recordings that may be used in other projects. 

If you actually want to delete the corresponding audio file, you can do so by choosing 
Audio File > Delete File(s) in the Audio Bin. The deleted audio files remain in the Trash 
until you empty the Trash. 
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Creating Comps
Compiling various sections of different takes is known as comping or creating a comp. 
Logic Pro provides special options which fundamentally streamline this standard 
editing practice by allowing comps to be created without having to make cuts or mute 
tracks and regions.

The different take sections of a comp are automatically crossfaded between each other, 
in accordance with the default crossfade settings. These are defined in the General 
Audio preferences tab. You can quickly open this tab via the Audio Crossfade options 
for Merge and Take Comping key command.

Typically, you will double-click on a take folder to open, and edit, it. You can, however, 
perform many comp editing operations when the take folder is closed (see below). 

To compile sections of different takes, do one of the following:
m In an opened take folder, select the desired take sections by click-dragging over them 

with the Pointer tool. 

As a result of Logic Pro’s innovative Quick Swipe Comping feature, selecting a section in 
one take automatically deselects the same section in all other takes. Only one take 
track in a take folder can play at any given point in time.
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The top track in the take folder displays a composite waveform overview of all selected 
take sections. The vertical lines in the waveform overview indicate the transitions 
between different takes.

m In a closed take folder, you can quickly replace a take section by Control-clicking the 
folder section, and choosing a different take from the pop-up menu.

Important:  Before performing any edits on a comp, you should save it (see below). Any 
subsequent changes will automatically create a new comp.

To edit a comp:
m Change the borders of the existing take sections by click-dragging the start or end 

points (the length change icon is shown).

When you extend a section (move the beginning to the left or move the end to the 
right), adjacent selections in other takes are automatically shortened.

When you shorten a section (move the beginning to the right or move the end to the 
left), adjacent sections on different take tracks are automatically extended. This ensures 
that you do not create silence between different sections

Dragging the edge while holding Shift shortens the section without extending 
adjacent sections on different takes. The cursor turns into a Resize pointer.

This allows you to create breaks (silence between different sections).

∏ Tip:  You can listen to your comp edits in real time by creating a cycle that spans the 
comp folder, and starting playback. 
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To move the selected comp area to the left or right:
m Click-drag it (a two headed arrow icon is shown).

To move a selected comp area to another take:
m Click on the waveform of an unselected area to move the existing “comp” from another 

take.

This is a quick way to compare a comp area on one take with the same comp area on 
another take. 

To remove a comp selection:
m Shift-click the comp. 

To remove all comp sections from a take:
m Shift-click in the region header of a take. 

If the take does not contain any comp selections, all unselected areas in other takes are 
selected in the take you clicked.

To remove a complete take from a take folder, do one of the following:
m Select it by clicking in its track header, then choose Delete Take from the Take Folder 

menu (or press Backspace).

m Click it with the Eraser.

To store a comp, do one of the following:
m Close the take folder by clicking its disclosure triangle in the upper left corner.

m Choose New Comp from the Take Folder menu. 

The comp is stored in the Takes and Comps menu (and is given a default name “Comp 
nn”). 

To rename a comp or take:
m Choose Rename Comp or Rename Take (dependent on whether a comp or take is 

selected) from the Takes and Comps menu.

Type the desired name in the dialog that opens.

Managing Take Folders
The following section outlines a number of commands that can be performed on take 
folders. These don’t affect the playback result, but do have an impact on editing 
options.
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Flatten and Flatten and Merge
The Take Folder menu—accessed by clicking the arrow at the top right corner of the 
take folder—allows you to flatten and merge take folders.

Â Flatten:  Replaces the take folder with regions that represent the current comp 
selections. This allows you to move individual sections back or forth in time.

Â Flatten and Merge:  Creates a new audio file which replaces the take folder in the 
Arrange. The newly created audio file exactly matches the size of the take folder 
(independent of the start position of the first region or end position of the last 
region).

Note:  It is not possible to merge take folders as you would merge regions (with the 
Glue tool, for example). The reason for this is that the number of takes and comps 
would multiply, making edits difficult, if not unusable. 

Opening Take Folders in the Sample Editor
It is possible to open take regions in the Sample Editor, but they are locked, making it 
impossible to move the anchor or redefine start or end points.

Such actions would destroy take timing if made in the Sample Editor, but you can 
perform fine edits of start and end points in the Arrange, when zoomed in. The timing 
of individual sections can be adjusted after the take folder has been “flattened.”

Packing a Take Folder
The Arrange menu Region > Folder > Pack Take Folder command creates a take folder 
for multiple selected regions. Each region appears as an individual take in the resulting 
take folder.
Â If the selected regions are located on different tracks (using different channel strips), 

the playback result may change (a take folder uses a single channel strip). The 
channel strip (and track) of the topmost “packed” track is used for take folder 
playback. If the topmost track is muted, the next unmuted track will be chosen for 
playback.
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Â If the selected regions are placed after each other on a single track, the take folder 
will default to one automatically created comp. Playback is unaffected. If only one 
region is “packed,” it is selected as the take, and no comp is created.

In situations where the newly created take folder overlaps other (initially unselected) 
regions (which would change the playback result of these unselected regions), 
Logic Pro creates a new audio track for the take folder.

Unpacking Take Folders
The Arrange menu offers the following two commands:
Â Region > Folder > Unpack Take Folder 
Â Region > Folder > Unpack Take Folder to New Tracks

These commands are also available in the Take Folder menu (where they only affect 
that folder, not all selected take folders).

Both commands replace the (or all) selected take folder(s) with new audio tracks for 
each take and each comp. The order of takes and comps shown in the take folder 
menu is mirrored by the track order.

The Unpack command uses the same (the original) channel strip for all new tracks. All 
take/comp regions (except the originally activated one) are muted, ensuring that the 
playback result is unchanged.

The New Tracks command uses different channel strips for each new track, but 
automatically assigns the original channel strip setting to all of them. None of the 
takes/comps are muted—all play simultaneously—again ensuring that the playback 
result is not changed.

Recording MIDI
MIDI regions are used on (software) instrument and external MIDI tracks. MIDI regions 
are recorded in real time, or by using a number of “step input” methods.

To record MIDI regions in Logic Pro, you need to either:
Â Connect a MIDI keyboard to your computer. For more information on this, please 

refer to “Connecting Your MIDI Keyboard and Modules” on page 91.
Â Activate the Caps Lock Keyboard by pressing the Caps Lock key. For more 

information, see “Using the Caps Lock Keyboard” on page 389.
Â You can also use MIDI Step Input to “record” notes into Logic Pro, one at a time. Full 

details in “MIDI Step Input Recording” on page 384.

MIDI recording works similarly to audio recording. There are only a few differences you 
need to be aware of. These are outlined in the following sections. 
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General recording info such as recording commands, configuration of the Transport bar 
Recording button, setting count-ins, and so on, is covered in “Recording Audio,” from 
page 351 onwards.

Recording MIDI Regions in Real Time
You can record a single MIDI region or multiple MIDI take regions on a track. If 
recording multiple MIDI take regions, they can be reviewed after recording, and used as 
you see fit. You can also assemble a composite MIDI region by using segments of 
several MIDI regions. 

You can also simultaneously record multiple MIDI regions on multiple MIDI tracks. See 
“Recording on Multiple MIDI Tracks” on page 382, for more information.

To record a single MIDI region:
1 Select the instrument or external MIDI track that you want to record on. 

Note:  These track types are automatically record-enabled when selected. 

2 Move the playhead to the point that you want to start recording. 

3 If you would like to hear the metronome while recording, Control-click the Metronome 
button in the Transport bar, and activate the Click While Recording setting in the menu.

For further information on metronome use, see “Setting Up the Metronome” on 
page 354.

4 Click the Transport bar’s Record button (or press the asterisk key on the numeric 
keypad; the default Record key command) to start recording. 

Recording starts at the playhead position (following a count-in, if enabled in the 
Recording project settings), and ends when you click the Stop or Play button. 

A MIDI region is created on the selected track. The MIDI region begins at the start of 
the bar in which the first event was recorded, and stops at the end of the bar in which 
the last event was recorded.

You can change the record track, without stopping recording—just select a new track 
with the mouse, or the Select Previous/Next Track key commands (default key 
assignments:  Up or Down Arrow).

To record several MIDI takes in Cycle mode:
1 Open the Recording project settings by doing one of the following:

Â Choose File > Project Settings > Recording (or use the Open Recording Project 
Settings key command, default:  Option-Asterisk)

Â Click the Settings button in the Arrange Toolbar, and choose Recording from the 
menu. 
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2 Choose “Create take folders” in the Overlapping recordings menu (see “How MIDI Take 
Recording Works” on page 380).

3 Set a cycle by dragging from left to the right in the Arrange Bar ruler (or use the locator 
fields in the Transport). 

4 Start recording.

5 Allow Logic Pro to continue running. 

After reaching the right cycle boundary, the playhead will jump back to the left cycle 
boundary. Logic Pro will create a new MIDI take folder. 

A new take track is automatically created inside the take folder for every cycle 
repetition.

Each previous take track is automatically muted while recording. When you stop 
recording, you can listen to the individual takes in the take folder by selecting them.

How MIDI Take Recording Works
Activation of the “Create take folders” option in the “Overlapping recordings” menu has 
the following effects:
Â Recording over an existing MIDI region will create a MIDI take folder.
Â Recording over an existing MIDI take folder will add a MIDI take to it.
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Â Recording over multiple existing MIDI regions will merge them (per track) before 
creating the take folder. All existing MIDI regions will appear as the first take, while 
new recordings will appear as the second, third, and so on takes.

Â Recording over multiple existing MIDI take folders will flatten them individually, and 
merge them per track, before creating a new take folder (which spans the combined 
length of all take folders). All material which existed prior to recording will appear as 
the first take, with subsequent recordings appearing as the second, third, and so on 
takes. 

Note:  All takes that were not playing in the take folders (which existed prior to 
recording) are lost, although Undo is possible.

Only the actual recording of MIDI events qualifies them as overlapping. To provide an 
example:  Imagine you are recording over existing take folders 1, 2, and 3. You don’t 
play any MIDI events before the start, or after the end of take folder 2. This will result in 
the new recording being added as further take of take folder 2. Logic Pro will even 
tolerate Note Off events in the first bar of take folder 3, without merging the take 
folders (2 and 3).

Important:  MIDI take folders do not have the comping functionality available to audio 
take folders. The MIDI Take Folder menu does not provide the New Comp or Flatten 
and Merge commands. For information on the other commands in the MIDI Take Folder 
menu, see “Packing a Take Folder” on page 377 and “Flatten and Flatten and Merge” on 
page 377. 

Recording Into or Replacing a Selected MIDI Region
You can incorporate newly recorded data into an existing (and selected) MIDI region. 
This works in both normal and cycle record modes.

To combine several recording takes into one MIDI region:
m Choose the “Overlapping recordings:  Merge with selected regions” option in the File > 

Project Settings > Recording tab.

To replace the events in a MIDI region recording:
m Choose the “Overlapping recordings:  Merge with selected regions” option in the File > 

Project Settings > Recording tab, and turn on the Transport’s Replace button. 

This will replace the events in existing (and selected) MIDI regions with newly recorded 
events.

You can also use the Merge/Replace combination in conjunction with the Autopunch 
and Cycle functions.

To limit merge recording to Cycle mode:
m Choose the “Overlapping recordings:  Merge only in Cycle record” option in the File > 

Project Settings > Recording tab.
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MIDI region recording will behave as per usual, with new regions created for each 
recording. When the Transport’s Cycle button is turned on, however, all MIDI region 
recording will result in a single, merged region. 

Retrospective Recording of MIDI Regions
If you played a great solo while playback was running, but weren’t in record mode—
don’t worry. Simply use the Capture as Recording key command. All events you played 
(after the last playhead change) will be added to the recorded MIDI region—just as if 
you had been in record mode.

Note:  If you move the playhead before executing this command, the next incoming 
event will delete all previously played events (and your solo will be lost forever).

Recording on Multiple MIDI Tracks
You may occasionally want to record multiple MIDI tracks at the same time. Often, this 
will be data recorded from an external sequencer, or played from a keyboard that is 
split across multiple MIDI channels. 

You can also simply play the same MIDI channel information from your keyboard, but 
record it to multiple tracks. One reason why you would do this is to create layered 
instrument parts.

To record regions on several MIDI tracks:
m Switch on the Record Enable buttons of the tracks you wish to record to.

Note:  Selecting an external MIDI or instrument track which is not record-enabled will 
turn off the record-enabled status of all other external MIDI or instrument tracks. 
Record-enabled audio tracks are not affected.

There are two operating modes available for simultaneous recording of multiple MIDI 
tracks:  Layer or Multiplayer recording.
Â When Layer Recording:  Incoming MIDI events are sent to all record-enabled MIDI 

tracks. You can listen to all selected instruments before, and during, recording. 
Â A MIDI region is created on the selected track after recording. 
Â Aliases of the MIDI region on the selected track are recorded on the other tracks.
The advantage of this approach is that any subsequent edits to the “parent” MIDI 
region will affect all aliases, ensuring that all layered tracks remain identical.

Â When Multiplayer Recording:  Incoming MIDI events are distributed to the various 
record-enabled tracks, in accordance with transmitted MIDI channel numbers. 
Â The channel of the incoming event must correspond to the channel of a record-

enabled track, in order for this functionality to work. 
Â If no track with a corresponding channel number is found, the event will be routed, 

and recorded, onto the selected track. 
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You should ensure that each of your MIDI controllers transmit on different channels. If 
this is not possible, simply use different inputs on your MIDI interface, and change the 
MIDI channel of each input, using a transformer object between the Physical Input and 
Sequencer Input (see “Physical Input and Sequencer Input Objects” on page 911).

To switch from the Layer recording mode (default) to Multiplayer recording mode:
m Switch on the File > Project Settings > Recording > “Auto demix by channel if 

multitrack recording” option.

Switching Instruments to Software Instrument Live Mode
When you select a (software) instrument track, it does not immediately switch into live 
or performance mode. You must send a MIDI event before live mode is activated, but 
this takes around 100 milliseconds to engage, which is more than enough to destroy 
the timing of your first played note.

If you require perfect timing for the first played note, you need to send silent MIDI 
events in advance; press the sustain pedal, make a small move of the pitch bender or 
modulation wheel as examples. This will switch on live mode. Fur further information, 
see “Why Live Mode is Necessary” on page 248. 

Filtering MIDI Input
The MIDI protocol can contain a broad range of MIDI messages, beyond note-on and 
note-off messages. These include controller information such as pitch bend, 
modulation, and aftertouch (pressure) commands.

There may be situations where you don’t want to record all information being sent by 
your MIDI controllers. This is done with several “MIDI filters” that allow you to define 
what event types will be accepted or rejected at the sequencer input.

To filter incoming MIDI events:
1 Choose File > Project Settings > MIDI, and click the Input Filter tab.

2 Enable the checkboxes that correspond with the MIDI event types that you would like 
to filter at the Logic Pro sequencer input. 
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Switching MIDI Thru Off
When an External MIDI instrument track is selected in the Arrange, its Record Enable 
button is automatically switched on, and the instrument will pass events through the 
computer (MIDI Thru function). You can switch off the MIDI Thru function by simply 
deactivating the Record Enable button.

There are, however, situations where you may want to record to a track that is not 
automatically routed to a MIDI port. As an example, when performing a system 
exclusive (SyEx) dump from a device. While many MIDI devices require a bi-directional 
(in and out) MIDI connection to allow this type of communication, some devices will 
react strangely to incoming data (sent from Logic Pro’s MIDI Thru). This can result in 
data loss. 

If you want to record a memory dump from a device that is problematic when 
connected bi-directionally, disable the instrument’s MIDI Thru function.

To assign an instrument with a permanently disabled MIDI Thru function:
1 Open File > Project Settings > MIDI > General

2 Choose the desired instrument in the Instrument Without MIDI Thru Function menu. 

MIDI Step Input Recording
The Step Input functions allow you to insert MIDI notes when Logic Pro is not in a real 
time recording mode. 

Step Input enables you to create note runs that may be too fast for you to play, or may 
be useful if replicating sheet music, but you don’t sight read. You can use either one or 
more of the following for step entry:
Â The Step Input Keyboard
Â Keyboard Input key commands
Â A MIDI keyboard
Â The computer keyboard (Caps Lock Keyboard)

Notes are inserted at the current playhead position using all input modes. You can, and 
should, combine methods to make full use of the features that each option offers. Here 
is an example:  You can set the note length in the Step Input Keyboard window, insert 
notes via a MIDI keyboard and position the playhead with key commands.

Use the mouse while familiarizing yourself with the Step Input Keyboard. To make the 
most of it, however, you will need to learn and use the Step Input key commands. 
These provide a number of navigation and note entry options, such as step forward/
back and rest insertion, which are not available to the Step Input Keyboard. See “Step 
Input With Key Commands” on page 386.
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Activating MIDI Step Input Mode
MIDI Step Input mode is available in the Event List, Piano Roll, and Score Editors. 

To activate Step Input mode:
m Click the In button found next to the local menu bar of the Event List, Piano Roll, or 

Score Editor. 

Disengage the button to exit Step Input mode.

Using the Step Input Keyboard
You can open the Step Input Keyboard window by choosing Options > Step Input 
Keyboard.

Â Keys:  Click to insert a note of the desired pitch. The insert range bar above the 
keyboard updates to display the selected octave.

Â Note length and velocity buttons:  Determine the length or velocity of the inserted 
note. There are eight velocity values—represented by the traditional volume 
indicators ppp, pp, p, mp, mf, f, ff, and fff. These correspond to MIDI velocity values 16, 
32, 48, 64, 80, 96, 112, and 127, respectively. 

Â Triplet button:  Click to make the next three notes you enter a triplet group. The 
rhythmic value of the triplets is based on the currently selected note value.

Â Dot button:  Works in a similar way as the Triplet button. A pair of complementary 
notes will be inserted:  a dotted eighth and a sixteenth note, for example.

Â Sustain Inserted Notes button:  Lengthens the selected (usually the most recently 
inserted) note by the selected note length value (the active note length button).

Â Quantize button:  Quantizes the start of the next inserted note to the nearest bar or 
beat line. Positioning of the playhead is critical when using this option.

Note length buttons

Dot button Triplet button

Velocity buttonsChord button
Sustain Insert Note 
button
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Â Channel field:  Determines the MIDI channel of an inserted note. The channel settings 
of individual notes usually have no effect on the playback channel, and therefore the 
sound, of the MIDI region. The channel settings of individual notes are mainly used 
for polyphonic score display.

Â Chord button:  When active, you can insert notes of different pitches and lengths. 
These are “stacked” at the same position, resulting in a chord. The playhead does not 
advance until the Chord button is deactivated.

To insert a note with the Step Input Keyboard:
1 Open the MIDI region in the editor you wish to work in.

2 Move the playhead to the desired insert location.

3 Set the buttons for note length, velocity, and other parameters as desired. 

4 Click on the desired key in the Step Input Keyboard to insert a note of the key’s pitch.

A note of the chosen pitch, note length, and velocity is inserted. The playhead will 
automatically advance to the end of the inserted note. The following note can be 
inserted immediately, following the step above.

Chord mode prevents the playhead from moving after the insertion of a note, allowing 
you to insert as many notes as desired at the same bar position.

To insert several notes at the same bar position:
m Turn on Chord mode by switching on the Chord button at the far left of the window (or 

using the Chord Mode key command), then follow the procedure outlined above.

A second click on the Chord button (or Chord mode key command) will deactivate 
Chord mode (this should be done before inserting the last note into the chord), and 
the playhead will advance as per usual, after note insertion.

Step Input With Key Commands
Note input with Step Input key commands follows the same principles as input via the 
Step Input Keyboard. Where it differs is that key commands are used for all functions, 
rather than choosing pitch, velocity, note length, and so on with mouse clicks. 

All step input key commands are user definable. They can be found in the Keyboard 
Input folder of the Key Commands window.

Note:  It is also possible to enter note data in real time with the computer keyboard 
(see “Using the Caps Lock Keyboard” on page 389).

Pitch Key Commands
The twelve “Note C” to “Note B” key commands insert a note of the selected pitch—
with the set length and velocity—at the current playhead position, in the selected MIDI 
region. Use the Chord Mode key command if you wish to insert chords. You can disable 
Chord mode with the same key command.
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Rather than assigning key commands to all twelve pitches, you also have the option of 
defining key commands for the seven pitches of the C major scale. These can be used 
in conjunction with the Next Note Will be Sharp and Next Note Will be Flat key 
commands, allowing you to insert the other pitches.

When creating a system for these key command assignments, two approaches seem 
most obvious:
Â Lay out these commands on the computer keyboard to resemble a piano keyboard 

(C D E F G A B in one row, next to each other and C# D# F# G# A# above these at 
corresponding positions).

Â Assign alphabetical keys to pitches of the C major scale—in accordance with their 
note names—especially when the second approach mentioned above is used.

Octave Range Key Commands
The octave of an inserted note depends on the current position of the insert range bar. 
There is a small horizontal bar (that spans one octave) above the piano keyboard in the 
Step Input Keyboard. The chosen note will always be inserted inside the range 
indicated by this bar.

This bar continuously changes its position in accordance with the last inserted 
note:  The center of the insert range bar is always aligned with the last inserted note. 
The next note will be inserted within this octave range—unless the range bar is moved 
via key commands or with the mouse.

An example:  If a G is inserted immediately after inserting a C, the G will be placed 
below the C. Inserting the C places the insert range bar between G (left end) and F# 
(right end), with the C in the center. Regardless of which note is chosen next, it will 
always be inserted inside this range. The range bar will, however, move as further notes 
are inserted, with the (range bar) center always aligned to the most recently inserted 
note.

Further key commands allow you to place the range bar in different octaves:  Octave 0 
to Octave 6, and also Octave +1/–1/+2/–2, which moves the range bar up or down one 
or two octaves. The range bar can also be moved with the mouse.

Note Length and Velocity
Note Length and Velocity are determined before a pitch command is used to actually 
insert a note. The currently selected values can be seen in the Step Input Keyboard 
window.
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Rests, Correction, Moving Forward and Back
The Rest key command moves the playhead forward (in accordance with the currently 
set note value) without inserting a note, thereby creating a rest. 

The Step Backwards and Step Forward key commands also move the playhead forward 
or back by the length of the selected note value.

The Delete key command will delete the most recently inserted note, and move the 
playhead back to the position where the note (previously) began. This allows for quick 
corrections—another note can be inserted immediately, replacing the erased one.

Triplets, Dotted Note Groups
The Next Three Notes are Triplets key command is self-explanatory. The rhythmic value 
of the triplets corresponds to the currently selected note value in the Step Input 
Keyboard window. If an eighth note is selected, an eighth note triplet will be created. 
After three notes have been inserted, binary values will be inserted, unless the 
command is reused.

The Next Two Notes are a Dotted Group key command works in a similar way. The 
special thing about this key command is that a pair of notes that complement each 
other will be inserted:  a dotted eighth and a sixteenth note, for example.

Interaction With Other Key Commands
If Step Input mode (the In button) is activated in the Score, Piano Roll, or Event List 
editors, these key commands have priority over all other key commands.

This means that you may assign keys or key combinations to these functions, even if 
these keys/key combinations are already assigned to other functions. As long as Step 
Input mode is active, these key assignments will apply; if Step Input mode is switched 
off, any other assignments (for the same keys) will have priority.

Note:  As you can use key assignments that are already in use for other functions, care 
should be taken to avoid using keys that are assigned to functions that you might also 
want to use when working in Step Input mode. As an example, the Space bar is used 
for Play/Stop/Continue, so assigning it to rest entry could be problematic.

Using a MIDI Keyboard for Step Input
Note input via MIDI works as per input via the Step Input Keyboard (see “Using the Step 
Input Keyboard” on page 385). Obviously, you press keys on your real-world MIDI 
keyboard, rather than clicking on-screen keyboard notes.

MIDI note velocity information (how hard you strike the keys on your MIDI keyboard) is 
sent when using MIDI Step Input. 

Chords can be inserted by simply playing the chord on the MIDI keyboard. You don’t 
need to switch on Chord mode in order to insert a chord.
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It is recommended that you keep the Step Input Keyboard window open when first 
using these functions, to make the learning process easier. Once familiar, you can leave 
the Step Input Keyboard window closed as it is an aid, not a requirement, for MIDI step 
input.

It is also recommended that you make use of the Input key commands (see “Step Input 
With Key Commands” on page 386) to quickly switch values such as the note length, or 
to determine the insert position. 

Using the Caps Lock Keyboard
The Caps Lock Keyboard enables you to use the computer keyboard as a real time 
virtual MIDI keyboard. It can also be used for MIDI Step Input. This makes it ideal for 
situations where no external MIDI or USB keyboard is available, such as when travelling 
with your portable Macintosh computer.

The Caps Lock Keyboard spans more than ten octaves, and even includes support for 
sustain and velocity information.

To enable the Caps Lock Keyboard:
m Press the Caps Lock key on your computer keyboard. 

An illuminated Caps Lock LED indicates that it is active.

It goes without saying that many keys will have different functions, overriding their 
usual key command assignments, while in this mode.

This is the English version of the Caps Lock Keyboard—other language versions will 
appear, dependent on your Mac OS X Keyboard setting.

The Escape key sends an All Notes Off command, should you encounter hanging notes.

The numeric keys (above the QWERTY keyboard) are used to define the octave for the 
MIDI keyboard.

The two rows below the numeric keys function as counterparts for MIDI keyboard keys, 
starting with the note C, assigned to the alphabetical A key (or Q, as would be the case 
if using a French keyboard, for example). 

See the black and white keys in the image above for details.
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The lowest row of letter keys sets the velocity for MIDI notes. There are preset values—
ranging from pianissimo to forte fortissimo. Each value can be finely adjusted via the 
two keys to the right of this row (these are assigned to the comma and period keys on 
an English QWERTY keyboard). This keyboard configuration allows you to send any 
MIDI velocity value from 1 to 127.

The Space bar provides a Sustain function—played with your thumbs rather than your 
feet. You can freely trigger new notes or switch between octave or velocity values while 
notes are sustained.

The current octave and velocity values of MIDI notes are displayed at the upper edge of 
the Caps Lock Keyboard window. A Transparency fader is also available for this window, 
making visualization clearer or allowing the window to be “ghosted” over the 
background.

Caps Lock Keyboard Preferences
The Enable Caps Lock Keys option allows you to completely enable or disable the Caps 
Lock Keyboard functionality.

Should you wish to use the Space bar key command to start, stop, or continue 
Logic Pro playback, rather than as the Sustain function for the Caps Lock Keyboard 
(when active), you can disable the “Space bar acts as sustain pedal” option.

Additional Caps Lock Keyboard Info
Due to technical limitations of computer keyboards, a maximum number of six notes 
can be played simultaneously. There are further limitations regarding timing precision, 
and when trying to play certain note clusters (which are musically unusual, at any rate). 

Please keep in mind the original intention of this facility—as a useful aid when 
composing on a train or plane—not as a full-on replacement for a real MIDI keyboard.
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15 Introduction to MIDI Editing

This chapter provides an overview of where you can best edit 
different types of MIDI events in Logic Pro.

Logic Pro offers several MIDI event editors:  the Score, Piano Roll, and Hyper Editors, 
and the Event List and Transform window. Each editor provides a different view of MIDI 
events and offers unique editing functions. These differences make particular MIDI 
editing tasks easier, and you will often switch between multiple editors to get a part 
just right. The following outlines the strengths of each editor:
Â Score Editor:  Used to create printed notation. Ideal if you like working with dots, 

dashes, and lines.
Â Piano Roll:  Perfectly suited for making changes to the pitch and length of MIDI note 

events. Note events are represented as horizontal rectangles on a grid. The length of 
the rectangle is directly proportional to the note length. The pitch of the note is 
indicated by the vertical position of the rectangle, with higher notes being placed 
towards the top of the screen.

Â Hyper Editor:  Useful for creating MIDI drum parts, and altering the levels of individual 
note events. It can also be used to create and edit MIDI controller information, 
allowing you to draw curves that result in a filter sweep in an external synthesizer, for 
example.

Â Event List:  Shows all MIDI event types as a list. This is the go to editor when you need 
to make precise changes to any aspect of a MIDI event.

Â Transform window:  This is not really an editor, in the same way that the other 
windows are. You use the Transform window for MIDI processing tasks, using 
mathematical variables. While this might sound a little overwhelming, you can use 
the Transform window to create a crescendo in a region, double or halve the speed 
of notes in a region, and more. Many processes are available as presets, and you can 
create your own.

Important:  You can not perform any event editing operations—in the Arrange area or 
the editors—unless the MIDI data resides in a MIDI region that exists in the Arrange 
area!
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Opening the Editors
All editors can be opened from the Window menu. This launches the editor in a 
separate window. 

To open an editor from the Window menu:
m Choose the editor window name from the Window menu (or use the corresponding 

key command). 

In general, you’ll access the editors directly in the Arrange window, but it can be useful 
to have multiple copies of the same editor open at the same time. As an example:  Two 
Event Lists—one set to display at the Arrange level (showing regions), and the other 
displaying events within the regions. When you click on region names in the Arrange 
level Event List, the contents of the selected region are updated and shown in the 
other Event List window.

To access the Score, Piano Roll, and Hyper Editor in the Arrange window, either:
m Click the appropriate button at the bottom of the Arrange window editing area. 

The contents (the events) of the selected MIDI region are shown in the selected editor 
window.

m Double-click on a MIDI region (see below).

You can use the Toggle Score Editor, Toggle Piano Roll, and Toggle Hyper Editor key 
commands. The repeated use of the key command will open or close (toggle) the 
chosen editor at the bottom of the Arrange window.

∏ Tip:  Hold Option while double-clicking a MIDI region, to open the chosen editor in a 
separate window.

Editor window Default key command

Event List

Score Editor Command-3

Transform Command-4

Hyper Editor Command-5

Piano Roll Editor Command-6
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To access the Event List in the Arrange window, do one of the following:
m Click the Lists button at the right-hand side of the Arrange window Toolbar, then click 

the Event List tab. 

m Use the Toggle Event List key command (default assignment:  E). 

m Double-click on a MIDI region (see below).

The contents (the events) of the selected MIDI region are shown in the Event List, to 
the right of the Arrange window.

To define the editor accessed by double-clicking on a MIDI region:
1 Open the Global preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Global (or use the Open Global Preferences key 
command).

Â Click the Preferences button in the Arrange Toolbar, and choose Global from the 
menu.

2 In the Editing tab, choose the preferred editor in the “Double-clicking a MIDI Region 
opens” pop up menu.

To access the Transform window, either:
m Choose Window > Transform (or use the corresponding key command, 

default:  Command-4). 

m When in a MIDI editing window:  Choose Functions > Transform.
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Hearing MIDI Events When Editing
It goes without saying that MIDI editing is made much easier if you can hear every 
event and edit you make, whether you are scrolling through the Event List (automatic 
selection) or transposing a note by dragging it. 

To hear MIDI event edits in real time:
m Click the MIDI Out button at the top left of each editor window.

This is an independent setting for each editor, which will transmit MIDI events 
whenever they are added, selected, or edited.

Editing MIDI Events in the Arrange Area
You can not perform any event editing operations—in the Arrange area or the 
editors—unless the MIDI data resides in a MIDI region that exists in the Arrange area 
(although you can use the Clipboard functions to create a MIDI region in the Arrange).

To create an empty MIDI region:
m Click at the desired position in the Arrange area with the Pencil tool. 

This inserts an empty MIDI region, allowing you to manually enter events into it.

In general, event-level editing can not be performed on regions in the Arrange area, 
but there are a few exceptions. In some cases, it may actually be more efficient to 
perform your edits (or operations) on MIDI regions in the Arrange area, rather than in a 
MIDI editor. As examples:
Â Altering note lengths by resizing the region (see “Note Handling Options When 

Changing MIDI Region Lengths” on page 315).
Â Deleting or moving portions of regions (and therefore the events) with the Marquee 

tool.
Â Adjusting the playback of all events in a region by altering the region playback 

parameters.
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Copying Events via the Clipboard in the Arrange Area
You can use the Clipboard to add MIDI events directly to the selected track in the 
Arrange area, at the current playhead position. This also works for events from another 
project. 

To copy MIDI events in the Arrange area:
1 Select the events you want to copy in one of the event editors. 

2 Choose Edit > Copy (or use the Copy key command, default:  Command-C).

3 Select the track (and MIDI region, if applicable) you want to copy the events to.

4 Choose Edit > Paste (or use the Paste key command, default:  Command-V).

Logic Pro adds the Clipboard contents (MIDI events) to the selected MIDI region. 

Note:  If no MIDI region is selected, Logic Pro will create a new MIDI region on the 
selected track, at the current playhead position.

Monitoring and Resetting MIDI Events
The top line of the Transport bar’s MIDI Activity display shows the last MIDI message 
received. The bottom line shows the most recently transmitted MIDI message. The 
monitor is mainly used for checking MIDI connections.

When Logic Pro receives more than one MIDI note simultaneously; the respective, held 
intervals (between notes) are interpreted and displayed as chords.

To switch off stuck notes:
m Click on the lower MIDI Activity display section, or click the Stop button twice in rapid 

succession. 

In both cases, reset messages are sent, as defined in Logic Pro > Preferences > MIDI > 
Reset Messages.

On occasion, MIDI modules continue to sound, even when no note data is being sent 
to them. This indicates that your sound sources have not responded to the All Notes 
Off messages sent by Logic Pro. 

MIDI Activity display
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To stop hung notes:
m Double-click on the MIDI Activity display in the Transport bar (or use the Send Discrete 

Note Offs key command). 

Separate Note Off messages will be sent for every note, on all channels of every MIDI 
port, which should do the trick!

To stop unwanted modulation:
m Choose Options > Send to MIDI > Reset Controllers (or use the corresponding key 

command).

This transmits control change message #121, with a value of 0 (reset all controllers), on 
all MIDI channels and outputs used by defined instruments. This neutralizes all MIDI 
controllers, such as modulation or pitch bends.

To set all MIDI channels to their maximum volume:
m Choose Options > Send to MIDI > Maximum Volume (or use the corresponding key 

command). 

This transmits a control change message #7 (main volume), with a value of 127, on all 
MIDI channels and outputs used by defined instruments. 

To send all program, volume, and pan settings from all external MIDI instrument 
Parameter boxes:

m Choose Options > Send to MIDI > Used Instrument MIDI Settings (or use the 
corresponding key command). 

This resets your sound sources, if unexpected program changes occur mid-
performance.

To automatically send instrument settings after loading a project:
m Turn on the “Send After Loading Project:  Used Instrument MIDI Settings” option, in the 

File > Project Settings > MIDI > General tab.



16

     397

16 Editing MIDI Events in the 
Piano Roll Editor

The Piano Roll Editor shows the note events of a MIDI region 
as horizontal rectangles. This resembles the holes cut in paper 
pianola rolls.

The Piano Roll Editor can display the MIDI note events of one MIDI region, or all MIDI 
regions in a folder or project, if desired (see “Displaying and Editing Multiple MIDI 
Regions” on page 399). You will generally work on one region at a time in the Piano 
Roll Editor, however.

Learning the Piano Roll Editor Interface
MIDI note events are represented by horizontal rectangles, aligned on a grid of 
horizontal and vertical lines.

Â The horizontal placement of note events indicates their temporal (bar, beat, and sub-
beat) positioning within the region, and project. 

MIDI note event
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Â The vertical position of note events indicates their pitch, with those nearer the top of 
the Piano Roll grid being higher in pitch. Chords are displayed as a vertical stack of 
note rectangles. The alignment of notes in chords is not always identical, as not all 
notes in a chord may be struck, or end, at the same time. 

Â The length of MIDI note events is directly related to the length of the rectangles, so 
notes such as; hemidemisemiquavers (1/64th note), quavers (1/8th note), crotchets 
(1/4 note), minims (1/2 note), whole notes, and so on can be easily recognized. 

Making Use of the Grid
The grid provides a valuable reference for note lengths:  You can see both the start and 
end positions of note events, aligned with the time values shown in the Bar ruler. This 
simplifies note length editing.

The default grid lines shown are:
Â A black line at every bar and beat.
Â A light gray line at every division value (you can alter the division value in the 

Transport).

You can alter the appearance of this grid and other aspects of the Piano Roll Editor  
(see “Customizing the Piano Roll Editor” on page 416).

The vertical keyboard on the left side of the Piano Roll Editor indicates note pitches. 
Horizontal black lines run across the screen between notes B and C, and notes E and F. 
These lines are very helpful when transposing notes by dragging them up or down.

Understanding Note Velocities
Each note event features a horizontal line that runs through the rectangle. The length 
of the line—in relation to the total length of the note—corresponds to the velocity 
value of the note (up to the maximum value of 127). Velocity denotes how hard the 
MIDI keyboard was struck when the note was recorded. This also usually indicates how 
loud the note is, within the range of 127 possible values, with 127 being the “loudest.”

The Piano Roll Editor also indicates note velocities with different colors.

This makes it very easy to see the overall range of (and individual note) velocities in a 
MIDI region. As you change the velocity of MIDI notes, the color of selected notes 
changes in real time.
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Note:  When View > Region Colors is activated, the notes will be displayed in the color 
of the MIDI regions that contain them. This makes notes easier to identify when 
viewing the notes of multiple regions.

Displaying and Editing Multiple MIDI Regions
The Piano Roll Editor can simultaneously display the contents of all MIDI regions in a 
folder, all regions in a project, or several selected MIDI regions. 

You can freely select note events that belong to different MIDI regions, and process, 
move, or resize them as required. A help tag indicates the number of selected events 
and parent MIDI regions. As an example:  8/2 means that eight notes are selected from 
two MIDI regions.

To show the note events of all MIDI regions in a project:
m Ensure that View > Show Selected Regions Only is switched off, then double-click on 

the background of the Piano Roll Editor.

The start point of each MIDI region is indicated by a vertical line of the same color as 
the MIDI region itself.

Double-click on a note event to revert to a display of the contents of a single parent 
MIDI region (the region that contains the note). 

To limit the display to note events of selected MIDI regions:
m Switch View > Show Selected Regions Only on. 

This restricts the Piano Roll display to the note events of MIDI regions selected in the 
Arrange area. Logically, this hides the events of non-selected regions, making multi-
region editing simpler.
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Creating and Editing Note Events
Handling note events in the Piano Roll Editor is very similar to region handling in the 
Arrange area. Many of the same techniques used to lengthen, cut, and move regions 
apply to note events, so you should find much of this section familiar.

Snapping Edits to Time Positions
You move and resize events in the Piano Roll Editor because you want them to start 
and end at a specific point in time. 

Logic Pro offers a snap feature that automatically aligns event start and end points to a 
selected grid value, when you move or resize them.

To snap events to a grid:
m Choose one of the following values in the Snap menu at the top of the Piano Roll 

window:

Â Smart:  Edit operations will snap to the nearest bar, beat, sub beat, and so on, 
dependent on the current Bar ruler division value and the zoom level.

Â Bar:  Edit operations will snap to the nearest bar.
Â Beat:  Edit operations will snap to the nearest beat in a bar.
Â Division:  Edit operations will snap to the nearest division (this is the time signature 

shown in the Transport and Bar ruler).
Â Ticks:  Edit operations will snap to the nearest clock tick (1/3840th of a beat).
Â Frames:  Edit operations will snap to the nearest SMPTE frame.

The Snap functionality is relative, which means that the edit operation will be snapped 
to the nearest bar, beat, and so on—retaining the event’s distance from its original 
position. As an example, if an event is placed at position 1.2.1.16, and you move it to 
around bar 2 (with the Snap menu set to Bar), it will automatically snap the event to 
position 2.2.1.16—rather than 2.1.1.1 (the bar 2 start point). You can override relative 
snaps with the Snap to Absolute Value option.
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To snap to an absolute, not relative, position:
m Choose the Snap to Absolute Value setting in the Snap menu. 

A tick will appear to the left when enabled. This feature works in conjunction with the 
chosen snap grid format. 

To explain, if Bar is chosen in the Snap menu, when Snap to Absolute Value is active, 
moving an event (from position 1.2.1.16) to around bar 2 will result in it being snapped 
to position 2.1.1.1 (the bar 2 start point), rather than its relative position (2.2.1.16).

The Snap menu setting applies to the following edit operations:
Â Moving and copying events
Â Resizing events
Â Cutting events
Â Moving, adding, and resizing markers
Â Setting cycle boundaries

You can temporarily override the snap grid, allowing finer edits and adjustments. 

To override the snap grid:
m Hold Control while performing the editing operation.

The division value chosen in the Transport (1/16, for example) determines the editing 
grid scale.

m Hold Control-Shift while performing the editing operation:

The editing grid switches to ticks.

Using the Info Display
The Piano Roll Editor’s info display indicates the current position and pitch of the 
mouse pointer within the region. 

You should refer to this real time display whenever making a selection.

∏ Tip:  Activate the MIDI Out button next to the Piano Roll Editor’s local menu bar to hear 
your edits as you make them.

Info display
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Using the Shortcut Menu
Many selection, editing, and other commands can be accessed by right-clicking 
anywhere in the Piano Roll Editor. Make use of this to accelerate your workflow.

Note:  The right-click shortcut menu can only be accessed if the Right Mouse Button:  
Opens Shortcut Menu pop-up menu option is chosen in the Logic Pro > Preferences > 
Global > Editing tab.

Selecting Notes
You must select note events before you can edit them. The usual selection methods—
clicking, Shift-clicking, and rubber-band selection with the Pointer tool also apply to 
the Piano Roll Editor. 

The following selection options—unique to the Piano Roll Editor—are also available:

To select all notes of the same pitch in a MIDI region:
m Click the corresponding key of the onscreen keyboard. 

This is similar to selecting all regions on a track lane, by clicking on the track name.

To select a range of note pitches in a MIDI region:
m Click-drag over the desired key range of the onscreen keyboard. 

All MIDI notes that fall within this pitch range are selected.

The info display will show the number of selected notes. The MIDI region name is 
shown beside the number of selected notes. As an example:  3/Piano means three 
notes are selected from a MIDI region called Piano. 

When you select multiple overlapping notes, the info display shows the chord name.

When no notes are selected, the info display shows the name of the most recently 
selected MIDI region. 

Creating Notes
You will often create note events with the mouse in the Piano Roll Editor; to replace a 
deleted note or to add a note to a chord or region. This facility is also handy when a 
keyboard is unavailable, or even when one is available, but it’s faster to insert a note 
with the mouse.

You can also create note events with your computer keyboard. Details in “Using the 
Step Input Keyboard” on page 385.
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To create a note event:
1 Select the Pencil tool.

2 Click at the desired position in the Piano Roll Editor.

The note that is created will match the length of the most recently inserted note. 

To create a note event of the desired length:
m Click-hold at the desired position in the Piano Roll Editor with the Pencil tool, then drag 

to the right or left. 

A help tag will indicate the length change in real time.

Finer adjustments can be made by holding down Option or Control while altering the 
note length (see “Snapping Edits to Time Positions” on page 400).

To replicate an existing note at another position or pitch:
1 Click the original note with the Pencil tool.

2 Click at the desired Piano Roll Editor position with the Pencil tool.

The new note length and velocity will be identical to the original note.

Deleting Notes
You can delete selected notes by pressing Backspace, or clicking on them with the 
Eraser.

To delete notes, do one of the following:
m Select the Eraser tool, then click on the desired note. 

m Select the desired notes, then click one of the selected notes with the Eraser (or press 
Backspace). 

This deletes all selected events.
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To delete similar or equal events:
1 Select one of the notes you want to delete.

2 Choose Edit > Select Similar Events or Edit > Select Equal Events (notes of the same 
pitch, for example), and then delete the selected events by pressing Backspace.

For more information about similar and equal events, see “Selecting Similar or Identical 
Objects, Regions, or Events” on page 175.

You can also delete events by choosing one of the Delete MIDI Events commands from 
the Piano Roll Editor’s local menu bar.

To delete doubled events:
m Choose Functions > Delete MIDI Events > Duplicates (or use the Delete Duplicated 

Events key command, default:  D). 

Any events occurring twice or more at the same position (and pitch) are deleted, 
allowing one to remain. 

Points to Note About Duplicated, Identical, and Similar Events
Duplicated events may have different second data bytes (velocity, aftertouch, or 
controller values); Logic Pro only looks at the event type and position, when 
determining whether or not two or more events are duplicated. 

Events of the same type, but on different MIDI channels, are not viewed as being 
identical. 

The “same time position” includes two notes which are output simultaneously because 
of the current quantization setting. Full details on all quantizating options are covered 
in Chapter 19, “Quantizing MIDI Events.”

To delete events inside or outside the locators:
1 Set the left and right locator positions as desired.

2 Do one of the following:

Â Choose Functions > Delete MIDI Events > Inside Locators.
Â Choose Functions > Delete MIDI Events > Outside Locators.
This deletes all events between or outside the locator positions. 

When copying events or reducing the length of MIDI regions, events can sometimes 
end up outside the limits of a MIDI region. These technically still belong to this MIDI 
region, although they won’t be played or heard. 

To delete events outside the MIDI region:
m Choose Functions > Delete MIDI Events > Outside Region Borders.
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To delete unselected events within the selection:
m Choose Functions > Delete MIDI Events > Unselected Within Selection.

All unselected notes between the (start point of the) first, and the (end point of the) 
last selected note are deleted.

To delete all selected events and select the next one:
1 Select the event you want to delete. 

2 Use the Delete and Select Next Region/Event key command. 

Restoring Deleted Notes
Accidental deletions of one or more notes, or a simple change of mind or editing 
mistake is an inevitable part of song creation. Fortunately, you can backtrack your edits 
easily in Logic Pro. You also have the option of simply recreating an event with the 
Pencil tool.

To undo the last note editing step or deletion:
m Choose Edit > Undo from the main menu, or press Command-Z immediately after 

making the error.

To undo or redo multiple steps:
1 Choose Edit > Undo History. This launches the Undo History window. The most recent 

editing step (at the bottom of the list) is highlighted.

2 Click on any entry to undo or redo all steps between the clicked and highlighted 
entries. All steps are animated during this process. 

Important:  A Redo list is not displayed until an Undo operation has been performed.
The Redo list appears below the Undo items. The first item that can be redone is 
indicated by gray text.

To undo or redo an isolated step:
1 Command-click on the desired step. A warning dialog will launch. 

2 Click Apply to undo or redo the step. Click Cancel to abort the step.

This will undo or redo an isolated step without influencing all steps between the 
clicked and higlighted (most recent) entries. 
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Moving Notes
You can move selected notes by grabbing them (near the middle) and dragging them. 
If you move notes vertically, they will be transposed, and if you move them horizontally, 
they will be moved in time. 

The current position and pitch are shown in a help tag while dragging. The deviation 
from the original pitch is shown as a positive or negative number of semitone steps at 
the bottom left of the help tag. The original pitch remains in the info display of the 
Piano Roll Editor.

When you move notes horizontally, they snap to the division defined in the Snap menu 
(you can alter this setting at any time). 

To make finer adjustments:
1 Select the desired notes.

2 Press Control, and drag the notes to the desired position. 

The resolution of the drag steps is dependent on the current Snap menu setting and 
zoom level (see “Snapping Edits to Time Positions” on page 400).

Alternately, you can follow the procedure above, but press Control-Shift as you drag to 
move the notes in tick steps, completely overriding the Snap menu setting.

To limit note movements to one direction:
1 Open the Global preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Global (or use the Open Global Preferences key 
command).

Â Click the Preferences button in the Arrange Toolbar, and choose Global from the 
menu.

2 In the Editing tab, enable the Limit Dragging to One Direction in Piano Roll and Score 
option.

When active, this option helps you to avoid accidental transpositions of notes when 
moving them horizontally, or changing the position of notes when you’re trying to 
change their pitch. The initial movement—vertical or horizontal—restricts further 
movements to this plane, while the mouse button is held. Release the mouse button 
and click on the event to move in the other direction.
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Moving Events via Key Commands
Editing can be greatly accelerated by assigning, and using, the following key 
commands to move one or more events. 
Â Nudge Region/Event Position Right by SMPTE Frame 
Â Nudge Region/Event Position Left by SMPTE Frame 
Â Nudge Region/Event Position Right by 1/2 SMPTE Frame
Â Nudge Region/Event Position Left by 1/2 SMPTE Frame
Â Nudge Region/Event Position Right by 5 SMPTE Frames 
Â Nudge Region/Event Position Left by 5 SMPTE Frames
Â Nudge Region/Event Position Right by SMPTE Bit
Â Nudge Region/Event Position Left by SMPTE Bit
Â Nudge Region/Event Position Right by Tick
Â Nudge Region/Event Position Left by Tick
Â Nudge Region/Event Position Right by Division
Â Nudge Region/Event Position Left by Division
Â Nudge Region/Event Position Right by Beat
Â Nudge Region/Event Position Left by Beat
Â Nudge Region/Event Position Right by Bar
Â Nudge Region/Event Position Left by Bar
Â Nudge Region/Event Position Right by Nudge Value
Â Nudge Region/Event Position Left by Nudge Value

The selected events are shifted one step right or left, by whatever unit is referred to in 
the particular command name.

Including Non-Note MIDI Events
Turn on Functions > Include Non-Note MIDI Events setting to tie other data (such as 
pitch-bend, modulation, aftertouch, or poly pressure) in a region to the region’s notes. 
This may be useful when a region contains note-related controller data that you want 
to copy or move.
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Changing the Length of Notes
You can use the Pointer, Finger, or Pencil tool to alter note lengths. 

∏ Tip:  It’s advisable to use the Pointer or Finger tool, as these avoid the accidental 
creation of new notes, which is possible with the Pencil tool.

To alter the end point (and length) of a note:
1 Position the Pointer, Finger, or Pencil tool over the lower right-hand edge of a note 

event. The tool icon will change to a length change icon when positioned correctly.

2 Drag the event to the required length. A help tag will inform you about the precise end 
point and length of the note while dragging. 

∏ Tip:  It can sometimes be difficult to grab the bottom right corner of very short notes. 
In this situation, you should use the Finger tool, which allows you to grab notes 
anywhere, in order to alter their end point (and therefore, length).

To change the start point (and length) of a note:
m Position the Pointer or Pencil tool over the lower left-hand edge of a note event, and 

drag it to the desired start position. 

Note:  The original end point of the note is retained when adjusting the start point. 

Altering the Lengths of Several Notes Simultaneously
You can adjust the lengths of several selected notes at once (in a chord, for example), 
by simply altering the length of one of them. The relative differences between the 
(selected) note lengths will be maintained.

To set the same end point for several notes:
m Press Shift while altering the length of one of the selected notes. 

To make several notes the same length:
m Hold Option-Shift while dragging one of several selected notes

Setting Note Start and End Points to the Playhead Position
You can move the start or end point of one or more selected notes to the playhead 
location with the following key commands:
Â Set Region/Event Start to Playhead Position 
Â Set Region/Event End to Playhead Position 
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Advanced Note Length Functions
The Functions > Note Events sub-menu in the Piano Roll Editor menu bar contains 
commands that change the length of selected notes. These changes are influenced by 
the notes surrounding or overlapping them. This is ideal for tidying up the start and 
end points of notes.

To remove note overlaps:
1 Select the notes you wish to affect.

2 Choose one of the following commands in the Functions > Note Events submenu 
(these commands are also available as key commands):

Â Note Overlap Correction (selected/any):  This command removes overlaps for all 
selected notes, regardless of whether the following overlapped notes are selected or 
not.

Â Note Overlap Correction (selected/selected):  This command removes overlaps for all 
selected notes, but only if the following overlapped notes are selected.

Â Note Overlap Correction for Repeated Notes:  This command removes overlaps for all 
selected notes, but only if the following overlapped notes have the same note 
number (are of the same pitch). 

The Overlap Correction functions view vertically stacked notes (notes in the same 
location, but of different pitches) as a chord. A dialog will indicate that the overlapping 
notes appear to be part of a chord, and you will be asked to choose one of the 
following options:
Â Keep:  Simultaneously-sounding notes will be reduced in length (moved to the same 

end point).
Â Delete:  Simultaneously-sounding notes will be removed, leaving a monophonic line 

behind.
Â Shorten:  Simultaneously-sounding notes will be individually reduced in length, 

resulting in a number of short notes in a monophonic line remains.

To make notes legato:
1 Select the notes you wish to affect.

2 Choose one of the following commands in the Functions > Note Events submenu:

Â Note Force Legato (selected/any):  This command forces legato for (lengthens) all 
selected notes, regardless of whether the following note is selected or not.

Â Note Force Legato (selected/selected):  This function forces legato for all selected notes, 
but only if the following note is selected.

The end of the MIDI region is treated as a non-selected note:
Â Note Force Legato (selected/any) lengthens the last note to the end point of the 

MIDI region. 
Â Note Force Legato (selected/selected) does not alter the length of the last note.
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If Logic Pro finds a chord, the following dialog is shown:

Â Click the Delete button to erase any incorrect notes in a poorly played monophonic 
line. 

Â Click the Keep button to even out (shorten) the start points and durations of all 
(intentionally played/recorded) notes in chords.

To convert sustain pedal events to note lengths:
m Choose the Functions > Note Events > Sustain Pedal to Note Length command. 

All sustain pedal events (controller #64) used on selected note events are analyzed, and 
the note events are actually increased in length. This increase matches the controller 
#64 (sustain pedal) off message position. 

The pedal events (controller #64 on and off ) are erased after use of this command.

Copying or Moving Notes
You can copy selected notes by pressing Option and dragging the notes to the desired 
position.

∏ Tip:  You can use this method to copy or move notes between two Piano Roll Editor 
windows (showing different regions, for example), or even between the Piano Roll 
Editor windows of different projects.

You can also use the Clipboard to copy and move notes:
Â Edit > Copy (or Command-C) copies notes into the Clipboard.
Â Edit > Cut (or Command-X) moves the notes into the Clipboard.
Â Edit > Paste (or Command-V) pastes them at the current playhead position, at their 

original pitch.

Advanced Note Copy and Move Options
You can also perform advanced copy and move operations within the Piano Roll Editor. 
These allow you to directly swap events, or to merge a group of notes from one section 
of a region to the same, or another, region, as examples.

To copy or move a range of MIDI events:
1 Define the area that you want to move or copy with the left and right locators. 

As an optional step:  Select the track you want to copy the events to, if you want to 
copy or move the events to another track.

2 Set the playhead to the desired insert position.
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3 Choose Functions > Copy MIDI Events. The Copy MIDI events dialog opens.

4 Choose the desired settings in the Copy MIDI Events dialog:

Â Mode menu:  Determines how MIDI events are copied or moved. You can choose 
from the following options:
Â Copy Merge:  The copied data is blended with any data present at the destination 

position.
Â Copy Replace:  The data at the destination position is deleted, and replaced with 

the copied data.
Â Copy Insert:  All data at the destination position is moved to the right, by the length 

of the source area.
Â Move Merge, Move Replace, Move Insert:  These three modes work similarly to the 

Copy modes, but actually move the selected events, removing them from their 
original positions. 

Â Rotate:  The source events are moved to the destination position. The data that 
was previously at the destination position, and the data that falls between the 
source and destination positions are all moved towards the source position. This 
rotates the data around a central pivot point (halfway between the source and 
destination positions).

Â Direct Swap:  Exchanges the source data with data of the same length, starting at 
the target position. This allows you to swap the notes in bar 1 of a four bar MIDI 
region with the notes in bar 3 of the same region, for example.

Â Remove:  Removes the MIDI data from the source region, but leaves the region at 
its original position. 

Â Left Locator and Right Locator:  These enable you to edit the source area you defined 
with the left and right locators.

Â Destination:  Defines the destination position independently of the playhead 
position.

Â Number of Copies:  Defines the number of copies.
Â Create New Region:  When set to on, a new MIDI region is created at the destination 

position. It contains the copied (or moved) events.
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Protecting the Position of Events
There are times where you will want to protect certain events from being moved. As an 
example, several note events may be used to trigger footstep samples that match an 
actor walking down a corridor, in a video soundtrack. 

You have already created the music for this scene, but have been asked to increase the 
tempo to match several cuts of different camera angles in the corridor. Obviously, a 
change in the tempo will move the events, resulting in out of sync footstep samples. 
Thankfully, Logic Pro has a feature that preserves the absolute time position of events.

To protect the position of one or more selected events:
m Choose Functions > Lock SMPTE Position (or use the corresponding key command).

This ensures that events that fall at a particular absolute time position:  1 hour, 3 
minutes, 15 seconds, 12 frames, for example, will remain at this position when tempo 
changes are made.

To unprotect the position of one or more events:
m Choose Functions > Unlock SMPTE Position (or use the corresponding key command).

Changing the Velocity of Notes
Note velocity is usually tied to the level of the note, and given the use of color to 
indicate different velocities, you can quickly identify the “loud” and “soft” notes in a 
region. 

Note:  Velocity can also be used as a controller for other synthesizer parameters, such as 
filter resonance or cutoff, either alone or in conjunction with level. As such, you may 
find that changes to note velocity not only affect the level of the note, but also tonality.

To alter the velocity value of a note:
1 Choose the Velocity tool.

2 Click-hold, and vertically drag on a note. 

A help tag will indicate the velocity value of the note you have clicked on. This value 
changes as you drag.

If the MIDI Out function is switched on (and it should be!), the note will be output as 
you alter the velocity.
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All selected notes can be altered simultaneously; the differences in their respective 
velocity values will be retained. If the velocity value of any of the selected notes 
reaches an extreme value (0 or 127), none of the other selected notes can be adjusted 
further.

You can override this behavior by holding Option while dragging. This allows you to 
continue altering the velocity values until the selected (clicked) note reaches an 
extreme value. It goes without saying that this will alter the velocity relationship of this 
note to the other notes.

To assign the same velocity value to all selected notes:
m Hold down Option-Shift while dragging on one of the notes with the Velocity tool.

Muting Notes
The Piano Roll Editor features a Mute tool that allows specific notes in a MIDI region to 
be muted. 

To mute/unmute a note:
m Click the note with the Mute tool. 

Muted notes are grayed out (shown without color).

To mute or unmute all notes of a particular pitch in a MIDI region:
m Click on a piano key to the left of the Piano Roll Editor with the Mute tool. 

This will mute or unmute all notes of that particular pitch, which is ideal for muting the 
high-hats in a MIDI region that is triggering an entire drum kit, for example.

To mute or unmute multiple notes:
m Select the desired notes, then click one of the selected notes with the Mute tool

The Select Muted Regions/Events key command is also available in the Piano Roll 
Editor. It allows the selection of all muted notes in a MIDI region. The next logical 
operation would be to delete these muted notes by pressing Backspace.

Splitting Chords
These functions divide chords horizontally (by pitch), making the Piano Roll Editor the 
ideal place to perform chord splitting tasks.
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To select the top or bottom note of one or more selected chords:
m Choose Functions > Note Events > Select Highest Notes to select the highest notes in 

the chords.

m Choose Functions > Note Events > Select Lowest Notes to select the lowest notes in 
the chord(s). 

The latter command may be perfect for separating a walking bass line in a piano 
region, as an example. Once separated, the lowest notes can be cut and pasted into a 
new region, which is played on a track assigned to an EXS24 mkII Upright Bass 
instrument channel.

Note:  Select Highest Notes and Select Lowest Notes are purely selection commands, 
which can be used in conjunction with any of the editing commands, such as Cut, to 
move a voice into another MIDI region, as per the example above. 

To assign individual note pitches to different MIDI channels:
1 Select the note pitch(es) you want to affect by clicking on the Piano Roll keyboard. 

Â Shift-click to select multiple non-contiguous pitches.
Â Drag across the keyboard to select a range of contiguous pitches.

2 Choose Functions > Note Events > Voices to Channels.

Logic Pro assigns MIDI channel numbers (in ascending order) to individual note pitches 
in the selected MIDI region. The highest note pitch in each chord will be assigned as 
MIDI channel 1, the next note down in each chord channel 2, and so on. 

Note:  Use of these commands results in changes to the MIDI region, which will contain 
information spread across multiple MIDI channels, following the operation. 

Regions split in this way enable you to create a new MIDI region for each note by using 
the Region > Split/Demix > Demix by Event Channel menu option in the Arrange 
window. 

Each region created from this process can then be assigned to a different track (and 
channel), allowing different instruments to be assigned for each voice.

For more information on the Functions > Note Events > Assign Channels Based on 
Score Split command, see “Using a Split Point” on page 753.

Using Hyper Draw
You can directly create and edit MIDI controller information in the Piano Roll Editor. 
These types of edits are made easier when you can see the notes that will be affected.

To view and create controller events:
1 Open a Hyper Draw display in the Piano Roll Editor by doing one of the following:
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Â Choose the desired View > Hyper Draw command.
Â Click the Hyper Draw button at the lower-left corner of the Piano Roll Editor, then 

choose the desired MIDI controller by clicking the arrow button to the left. 

The selected controller type (volume, for example) is shown in a gray field below the 
Piano Roll grid.

2 Click at different points in the gray area to create Hyper Draw nodes. 

A connecting line is automatically created between the nodes.

To resize the Hyper Draw area:
m Grab, and vertically move the dividing line that separates it from the Piano Roll grid 

area.
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For more information see “Using Hyper Draw” on page 596.

Customizing the Piano Roll Editor
The View menu offers various options that allow you to customize the display of the 
Piano Roll Editor.
Â Bright Background:  Switches between a bright and dark background. 

Â Piano Roll Colors:  Opens the Display preferences, allowing you to adjust the colors of 
the Piano Roll grid, background, lines, and so on for both the bright, and dark 
background views. For further information see “Other Preferences” on page 968. 

Piano Roll Editor Shortcuts
The Piano Roll Editor also provides a way to “quick-launch” the Event List and Score 
Editor. 

To quickly open the Event List:
m Double-click on any event. 

The Event List will be shown in the Media area to the right of the Arrange window. If 
already open, the contents of the parent region (of the note selected in the Piano Roll 
Editor) will be displayed.

Note:  If using an independent Piano Roll Editor window, double-clicking an event will 
launch an independent Event List window.

To quickly open the Score Editor:
m Option–double-click on any event.

The Score Editor will open in a new window. The Piano Roll Editor will remain docked in 
the Arrange window’s editing area.
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17 Editing MIDI in the Hyper Editor

You can use the Hyper Editor to view and edit different MIDI 
event types, shown as vertical beams along a timeline within 
a region.

Each beam represents an event. The value of the event is denoted by its height, 
providing an at-a-glance view of one, or dozens, of different events and their values.

Each MIDI event type, be it a note or MIDI controller, is arranged from top to bottom in 
horizontal lanes, much like the track lanes shown in the Arrange area. The location of 
each event within the region is vertically aligned with a Bar ruler position.

Each lane offers individual display and other parameters, that are assigned and 
adjusted in the Inspector.

The type of event shown, and controlled, on each lane is freely configurable. This is 
done by setting an event definition (see “Working With Event Definitions” on page 427) 
for each lane in the Inspector.

 Event definitions

Event

 Hyper Set menu
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You can save groups of event definitions (several lanes that you have defined) as hyper 
sets (see “Working With Hyper Sets” on page 434). Hyper sets are accessed via an 
Inspector menu.

The Hyper Editor features two default hyper sets:  MIDI Controls and the GM Drum Kit. 
The MIDI Controls hyper set provides hyper definition lanes for Volume, Pan, 
Modulation, and several other commonly used controller types. The GM Drum Kit hyper 
set offers lanes that match the note names of the General MIDI (GM) drum map. This is 
perfect for creating drum (or other instrument) parts, by pencilling or drawing in note 
events. This is similar to the use of pattern-based drum machines, where each beat is 
manually entered on a grid.

To switch between the default MIDI Controls and GM Drum Kit hyper sets:
m Click the arrow button next to the Hyper Set Name field in the Inspector, then choose 

the desired hyper set from the pop-up menu.

This is also how you switch between any hyper sets that you create. Each hyper set can 
be named, making it easy to select the one you need.

These event definition and hyper set facilities allow you to customize the Hyper Editor, 
with only the required MIDI event types being displayed. As an example:  Imagine you 
have recorded a synthesizer lead MIDI region. You could create a hyper set that 
contained several customized event definition lanes for the note events in the region.
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Each note event lane in the example is restricted to the display and control of a single 
note pitch. By default, each beam that represents note events can be adjusted in level, 
by dragging vertically with the Pointer tool. Within the same hyper set, you could 
create two event definition lanes that control the filter cutoff and filter resonance 
parameters of the lead synthesizer, enabling you to create or precisely edit filter tweaks.

Creating and Editing Events in the Hyper Editor
The Hyper Editor, like the other MIDI editors, can be used for event input duties. In 
some situations, manual entry of note and controller events is more efficient than 
performing and recording them. One example would be the creation of 1/16th note hi-
hats in a region when the tempo is 160 bpm, which would be difficult to play.

You can, of course, record events with a MIDI keyboard, and then refine your 
performances in the Hyper Editor.

Changing the Grid and Beam Display
The Grid parameter in the Event Definition Parameter box of the Inspector is important 
when creating events in the Hyper Editor. Newly created events are automatically 
added at grid positions. This makes it easy to create a drum pattern, with 4 divisions on 
one lane, 8 divisions on another lane, and 16 divisions on another lane; assigned to 
kick, snare, and hi-hat sounds, for example.

To define the Grid value for the selected event definition lane:
m Choose the desired grid type in the Event Definition Parameter boxes’ Grid parameter 

menu. 

Any events that you add will automatically snap to the nearest grid position. The 
positions of existing events are not affected.
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∏ Tip:  When editing or constructing complex rhythm patterns, it can be useful to create 
several event definitions (see “Selecting and Creating Event Definitions” on page 427) 
for one drum note, each with a different quantization grid. As an example, if there are 
two lanes for a snare drum, one with a 1/16th and the other with a 1/96th grid, you can 
use the Pencil tool to add individual hits in the coarser grid, and drum rolls in the finer 
grid.

When defining the Grid parameter to add a succession of controllers use the motto, “as 
coarse as possible, and as fine as necessary” to minimize data output. Logic Pro can 
deal with very large amounts of data, but unfortunately the same cannot be said of 
MIDI itself.

You can also alter the width and style of event beams to make event creation and 
editing easier.

To set the width of event beams:
m Choose the desired Pen Width menu value in the Event Definition Parameter box.

The exact event position is always marked by the left edge of the beam, regardless of 
the beam width.

When you set the Pen Width parameter to Note Length, note event beams are 
displayed at their actual length. The Status parameter must be set to Note for this to 
work!
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To change the style of beams displayed:
m Choose the desired setting in the Style menu. 

Â No Frames:  Shows the value of the event as a colored beam.
Â Framed Values:  Shows a hollow frame beam that is the full height of the event 

definition lane. The value of the event is displayed as a colored beam within the 
frame beam.

Creating Events
The Hyper Editor provides several unique methods for the creation (and editing) of 
MIDI events.

To add an event:
1 Choose the Pencil tool.

2 Click at the desired time position, on the appropriate event definition lane.

3 Drag up or down to alter the event value before you release the mouse button. 

To add multiple events:
m With the Pencil tool, drag horizontally over the desired time position on the 

appropriate event definition lane. 

This results in a freehand curve of new events that follows the (vertical and horizontal) 
Pencil tool movements in the lane.

 Framed Value event

 No Frame event
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To create multiple events in a linear fashion:
1 Select the Line tool.

2 Click at the desired position, on the appropriate event definition lane. 

A help tag appears, showing the exact position and event value in the top line.

3 Move the mouse to the desired end point of the line (to the right or left). 

As you do so, you will see the line trailing behind the Line tool pointer, with the exact 
position and event value shown in a help tag.

4 Click at the desired end point to create several event beams, aligned along the line.

New events are created at each grid position (in accordance with the Grid parameter), 
within the line start and end points.

To create or alter a linear series of events in sections:
m Follow the steps above, but hold Shift when clicking at the end point position. 

This immediately draws another line from the end point of the original line. 

To create new events when other events already exist in a lane:
m Follow the procedure above, and hold down Option when you click for the last time.

The values of existing events in the area between the line start and end points are 
aligned along the line (creating a crescendo, for example). New events are created at 
every (unoccupied) grid value. 

Using a Fixed Value When Creating Events
The Fix Value checkbox in the Inspector, when on, prevents any event value from being 
altered with the Pointer or Pencil tools. 

This is ideal when adding events with the Pencil, as all are assigned the value of the 
previously-selected event. This allows you to draw a succession of events with the same 
value. Perfect for drawing in a row of 16th note hi-hats, for example.

Line tool
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To assign a fixed event value:
1 Enable the Fix Value checkbox in the Inspector.

2 Click any existing event with the Pencil tool to use its value as a preset. 

In fix value mode, it is impossible to alter an event value by clicking on it.

Note:  When adding events with the Line tool in fix value mode, the preset value is 
always used as the starting value of the line.

Changing the Length of Added Notes and Events
You can use the Length parameter to set the length of events (this primarily applies to 
note events) to be added, measured in divisions (the left number), and ticks (the right 
number).

You should avoid the use of small tick values. Many MIDI devices do not respond 
quickly enough when note on/note off messages are sent in quick succession, resulting 
in no note being heard.

Selecting Events
You can use any of the usual selection techniques (see “Selection Techniques” on 
page 172), with the following differences:

To select individual events:
m Hold Shift, and click on the desired events.

To select several contiguous events:
m Hold Shift, and make a rubber band selection.

Ensure that you do not click on any events. If you simply click or drag with the Pointer 
tool, the selected event values will be changed, so make sure Shift is held!

To select all events on a lane:
m Click the event definition name. 

To select all events on multiple lanes:
m Shift-click on the appropriate event definition names. 

Deleting Events
Events can be deleted individually by clicking on them with the Eraser tool. The 
following techniques cover deletion of multiple events.
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To delete several contiguous events in a lane:
m Drag across the events with the Eraser tool.

To delete several non-contiguous events:
m Select the events you want to remove, then press Backspace.

To delete similar or equal events:
1 Select one of the notes you want to delete.

2 Choose Edit > Select Similar Events or Edit > Select Equal Events (notes of the same 
pitch, for example), and then delete the selected events by pressing Backspace.

For more information about similar and equal events, see “Selecting Similar or Identical 
Objects, Regions, or Events” on page 175.

You can also delete events by choosing one of the Delete MIDI Events commands from 
the Hyper Editor’s local menu bar. For further information, see “Deleting Notes” on 
page 403.

Restoring Deleted Events
Accidental deletions of one or more events, or a simple change of mind or editing 
mistake is an inevitable part of song creation. Fortunately, you can backtrack your edits 
easily in Logic Pro. You also have the option of simply recreating an event with the 
Pencil tool.

To undo the last event editing step or deletion:
m Choose Edit > Undo from the main menu, or press Command-Z immediately after 

making the error.

To undo or redo multiple steps:
1 Choose Edit > Undo History. 

This opens the Undo History window. The most recent editing step (at the bottom of 
the list) is highlighted.

2 Click on any entry to undo or redo all steps between the clicked and highlighted 
entries. 

All steps are animated during this process. 

Important:  A Redo list is not displayed until an Undo operation has been performed.
The Redo list appears below the Undo items. The first item that can be redone is 
indicated by gray text.

To undo or redo an isolated step:
1 Command-click on the desired step. 

A warning dialog will open.

2 Click Apply to undo or redo the step. Click Cancel to abort the step.
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This will undo or redo an isolated step without influencing all steps between the 
clicked and higlighted (most recent) entries. 

Changing Event Values
Events can be altered individually or as a group. When adjusted as a group, the 
absolute differences between the event values remain constant. 

To alter individual event values:
m Grab the event beam (with the Pointer or Pencil tool), and drag vertically. 

The current value is shown in a help tag as you drag.

To alter several contiguous event values:
m Drag across the events with the Pointer tool. 

The current value is shown in a help tag as you drag across each event.

To alter the values of multiple events:
1 Use any of the selection techniques discussed above to select the events you want to 

edit.

2 Grab one of the grouped (and highlighted) beams, and drag vertically. 

The values of all events are adjusted. If any of the beams in the group reaches the 
maximum or minimum value, you will not be able to go any further in that direction.

To adjust event values when one grouped event has reached an extreme value:
m If you hold Option while doing so, you can keep raising or lowering the values of all 

events in the group, until the grabbed event beam reaches the maximum or minimum 
value.

Moving and Copying Events
Events can be moved or copied to other positions in the same, or other, lanes. When 
moved or copied between lanes, the event values are retained, but are converted to 
the target event definition. As an example, moving several events from the Volume 
lane into the Pan lane will result in the Volume values being used for Pan position 
changes.

To move selected events:
m Hold Shift, and drag to the desired position and lane. 

As you do so, a help tag will inform you of the position, event definition type and value 
(if applicable).
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Moving Events via Key Commands
Editing can be accelerated by assigning, and using, the following key commands to 
move one or more events. 
Â Nudge Region/Event Position Right by SMPTE Frame 
Â Nudge Region/Event Position Left by SMPTE Frame 
Â Nudge Region/Event Position Right by 1/2 SMPTE Frame
Â Nudge Region/Event Position Left by 1/2 SMPTE Frame
Â Nudge Region/Event Position Right by 5 SMPTE Frames 
Â Nudge Region/Event Position Left by 5 SMPTE Frames
Â Nudge Region/Event Position Right by SMPTE Bit
Â Nudge Region/Event Position Left by SMPTE Bit
Â Nudge Region/Event Position Right by Tick
Â Nudge Region/Event Position Left by Tick
Â Nudge Region/Event Position Right by Division
Â Nudge Region/Event Position Left by Division
Â Nudge Region/Event Position Right by Beat
Â Nudge Region/Event Position Left by Beat
Â Nudge Region/Event Position Right by Bar
Â Nudge Region/Event Position Left by Bar
Â Nudge Region/Event Position Right by Nudge Value
Â Nudge Region/Event Position Left by Nudge Value

The selected events are shifted one step right (+1) or left (–1), by whatever unit is 
referred to in the particular command name.

To copy selected events:
m Hold Option, and drag to the desired position and lane. 

As you do so, a help tag will inform you of the position, event definition type and value 
(if applicable).

You can also use the Clipboard to copy and move notes:
Â Edit > Copy (or Command-C) copies notes into the Clipboard.
Â Edit > Cut (or Command-X) moves the notes into the Clipboard.
Â Edit > Paste (or Command-V) pastes them at the current playhead position, at their 

original pitch.

You can also perform advanced copy and move operations within the Hyper Editor. 
These allow you to directly swap events, or to merge a group of events from one 
section of a region to the same, or another, region, as examples. For more information, 
see “Advanced Note Copy and Move Options” on page 410.
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Protecting the Position of Events
There are times where you will want to protect certain events from being moved. As an 
example, several note events may be used to trigger footstep samples that match an 
actor walking down a corridor, in a video soundtrack. You have already created the 
music for this scene, but have been asked to increase the tempo to match several cuts 
of different camera angles in the corridor. Obviously, a change in the project tempo will 
move the events, resulting in out of sync footstep samples. Thankfully, Logic Pro has a 
feature that preserves the absolute time position of events.

To protect the position of one or more selected events:
m Choose Functions > Lock SMPTE Position (or use the corresponding key command). 

This ensures that events that fall at a particular absolute time position:  1 hour, 3 
minutes, 15 seconds, 12 frames, for example, will remain at this position when tempo 
changes are made.

To unprotect the position of one or more events:
m Choose Functions > Unlock SMPTE Position (or use the corresponding key command).

Working With Event Definitions
The event definition determines the event type shown on each Hyper Editor lane. 
Events are shown as vertical beams on each lane, aligned with a particular time 
position in the Bar ruler.

There are many ways of altering the way the beams are displayed, making it easier to 
create or adjust particular event types (see “Changing the Grid and Beam Display” on 
page 419). You can also alter the grid resolution for each event definition lane in a 
hyper set, which is very useful when creating drum patterns. The height and horizontal 
size of the lanes is adjusted with the zoom bars.

Selecting and Creating Event Definitions
You can select an event definition by clicking the name column with the Pointer or 
Pencil tool. 

This allows you to create new definitions, and to view and change the event definition 
parameters in the Inspector (see “Changing Event Definitions” on page 430).

To select multiple event definitions:
m Shift-click on each event definition with the Pointer or Pencil tool. 

You can make concurrent changes to the parameters of several selected event 
definitions (see “Adjusting Multiple Event Definitions Simultaneously” on page 433).
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To create a new event definition:
1 Select an event definition lane by clicking on one of the names shown. 

The selected lane is highlighted.

2 Choose Hyper > Create Event Definition (or use the corresponding key command, 
default:  Option-Command-N). 

This creates a new event definition lane. The original, and all subsequent, event 
definition lanes are moved downwards. The new event definition parameters are 
identical to the originally selected event definition.

3 Adjust the event definition parameters in the Inspector (more on this shortly).

You can use the Auto Define feature to automatically create event definitions for 
specific event types in your project.

To create an event definition for a specific event:
1 Select the desired event type (controller #71 Resonance, for example) in one of the 

other MIDI editors. 

∏ Tip:  The Event List is highly recommended for this task as it can display all MIDI event 
types.

2 Enable the Auto Define checkbox in the Hyper Editor’s Inspector (or use the Toggle 
Auto Define key command, default:  Control-A).

3 Choose Hyper > Create Event Definition in the Hyper Editor (or use the Create Event 
Definition key command, default:  Option-Command-N).

If the hyper set already contains a matching event definition (controller #71 Resonance, 
from the example), Logic Pro won’t create a superfluous double definition. The existing 
event definition is moved into the visible area of the Hyper Editor in this situation.

Note:  Don’t forget to switch off Auto Define immediately after completing your input. 
If you don’t do this, you may inadvertantly select an event type in another editor, and 
this will be used as the basis for new event definitions. This could be frustrating, and 
surprising, when using the Control-Return key command, in particular, to create new 
definitions.

To create several event definitions at once:
1 Select the events that you want to create event definitions for in one of the other MIDI 

editors. 

As above, the Event List is recommended. 
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2 Do one of the following

Â Choose Hyper > Create Multiple Event Definitions (or use the corresponding key 
command), then click the Selected button in the dialog.

Â Choose Hyper > Create Hyper Set for Current Events (or use the corresponding key 
command). 

This creates a new hyper set that contains event definition lanes for each of the 
selected event types. This is especially useful for quick hyper set creation of all Hyper 
Draw (MIDI controller) events in a region. Open the Event List, filter the note events, 
select all remaining events, and use Hyper > Create Hyper Set for Current Events.

To create event definitions for all event types in a region:
1 Select the region.

2 Choose Hyper > Create Multiple Event Definitions (or use the corresponding key 
command). 

3 Click the All button in the dialog to confirm that you want to create event definitions 
for all types of events in the region.

∏ Tip:  It’s a good idea to create a new hyper set before creating a group of new 
definitions. For more information, see “Creating a Hyper Set” on page 434. 

Copying, Deleting, and Rearranging Event Definitions
The following functions make the creation and organization of hyper sets much easier 
and faster. 

To copy an event definition between two hyper sets:
1 Select the event definition that you want to copy.

2 Choose Hyper > Copy Event Definition (or use the corresponding key command, 
default:  Control-C). 

3 Switch to the destination hyper set, by choosing the hyper set name in the pop-up 
menu at the top of the Inspector.

4 Choose Hyper > Paste Event Definition (or use the corresponding key command, 
default:  Control-V).
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To delete event definitions:
m Select the desired event definitions, then choose Hyper > Delete Event Definition (or 

use the corresponding key command, default:  Control-Backspace).

To reorganize the order of event definition lanes:
m Grab the name of the event definition you want to move, and drag it (vertically) to the 

desired position.

Changing Event Definitions
You use the Event Definition Parameter box in the Inspector to alter the settings of the 
selected event definition lane. The most important parameters are Status (and First 
Data Byte). All display related parameters are covered in “Changing the Grid and Beam 
Display” on page 419. Information on all other parameters is found later in this section.

Altering the Event Status
The event status determines the type of event controlled by each event definition lane. 
Click-hold the arrows to the right of the Status line, and choose one of the following 
from the pop-up menu:
Â Fader:  To define a fader event lane. Fader event data can be used to control any 

possible parameter (except channel volume and pan, which use controllers). Fader 
data can also be used to create meta events.

Â Meta:  To define a meta event lane. Meta events are internal Logic Pro commands 
that can perform tasks such as screenset switching.

Â Note:  If you want to define a lane for a particular note pitch (perfect for drum 
programming).

Â Control:  If you want to define a MIDI controller lane.
Â C- Press (Channel Pressure):  To define a lane for channel pressure (also known as 

aftertouch, a feature of many synthesizers that adds vibrato, for example, when you 
press down on MIDI keyboard keys that are already held).
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Â P-Press (Polyphonic Pressure):  As above, but each note can be independently 
modulated.

Â Program Change:  To define a lane that is used to create and send MIDI program 
change events, allowing you to switch between sounds (electric piano and clavinet, 
for example) midway through a region.

Â Pitch Bend:  To define a lane for pitch bend information.

Important:  The choice made in the Status line directly affects the behavior (and 
appearance) of the First Data Byte parameter.

As an example, if Note is chosen in the Status parameter line, you can use the first data 
byte to determine the pitch (MIDI note number) of the selected event definition lane. If 
the MIDI region is played by a mapped instrument, a pop-up menu of input note 
names (drum sound names) appears here.

Using the First Data Byte Parameter
The First Data Byte checkbox and menu is shown on the bottom row of the Event 
Definition Parameter box in the Inspector. You use them to determine the value of the 
first data byte (of the displayed event type).

The First Data Byte checkbox determines whether or not events with the defined first 
data byte should be displayed (if on), or whether the setting should be ignored (if off ). 
In the case of note events, the velocity values of all notes (regardless of pitch) would be 
displayed in the relevant event definition lane.

The name of the First Data Byte parameter reflects the chosen Status parameter, as 
follows:
Â Fader, Meta, Control, Program:  Number is shown as the First Data Byte.
Â Note, P-Press:  Pitch is shown as the First Data Byte.
Â C-Press and PitchBd:  The First Data Byte is dimmed, as it has no function.

If Control is chosen in the Status line, you can use a pop-up menu shown in the First 
Data Byte parameter line, to determine the controller type (controller number).

Similarly, if Meta or Fader are chosen in the Status line, the First Data Byte menu 
determines the meta or fader event type (meta or fader message number).

First Data Byte checkbox 
and menu
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If channel aftertouch (C-Press), or program change events (Program) are chosen in the 
Status line, the First Data Byte parameter setting is ignored, and the first data byte is 
displayed as a beam height. 

When pitch bend data (PitchBd) is chosen in the Status line, the First Data Byte 
parameter setting is also ignored, because both data bytes are used to display the 
beam height.

Naming an Event Definition
The name of the selected event definition is shown beside the disclosure triangle in the 
Event Definition Parameter box in the Inspector. This is mirrored in the name column in 
the Hyper Editor. 

To name an event definition:
m Click on the name to open a text entry field, type in the desired name, then press 

Return.

Note:  If you define a named MIDI controller, or a note from a mapped instrument in 
the Status and First Data Byte parameter lines, the relevant name will be offered as a 
preset.

Note:  Altering a note name in the event definition also alters the corresponding note 
name in the mapped instrument.

Delaying Events
The Inspector’s Delay parameter is very useful for drum programming (flams, for 
example), as only individual event types or note numbers are affected. It is also useful 
for tightening up or sliding notes in a region, without resorting to quantization.

To delay or advance the selected event definition:
m Set the Delay parameter to the desired value. 

Position changes are immediately reflected by the events in the lane. New events 
(inserted when a grid was active) are offset from the grid positions by the Delay 
parameter value.

∏ Tip:  In general, you should transmit controller data slightly before or after note events, 
to improve the timing of notes. In other words, place controllers before (use a negative 
Delay value) the grid positions of the notes lying exactly on the grid positions.
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MIDI Channel
Next to Channel, you’ll see a checkbox, and to the right of this you can set a MIDI 
channel number, by dragging vertically. If you click this box (turn it on), the display is 
restricted to events on the set channel. If the box is unchecked, the channel parameter 
is ignored, and matching events on all channels are displayed.

Adjusting Multiple Event Definitions Simultaneously
Just as you can adjust the parameters for several MIDI regions at once, you can set the 
parameters of several event definitions simultaneously. Select several event definitions 
in the name column, by holding down Shift and clicking on them. You can also use 
Hyper > Select All Event Definitions to select all event definitions, and then deselect 
some of them by Shift-clicking on them.

Any alterations you make in the Event Definition Parameter box will affect all selected 
event definitions.

Converting Event Definitions
You can redefine an event definition (along with all events). The values of the events 
are retained, but the event type is changed to the new event definition. 

To convert an event definition and all events:
1 Select the event definition you want to convert.

2 Do one of the following:

Â Choose Hyper > Convert Event Definition (or use the corresponding key command).
Â Double-click on the name column of the event definition that you want to convert.

3 Choose the desired settings in the Convert Definition dialog, and press the Convert 
button.

On the left (Convert), you can see the parameters of the selected event definition, and 
on the right you can define the parameters of the destination event type. The current 
settings (of the source) are used as default values for the destination.
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Enable the Quantize Events checkbox to quantize the event positions to the Grid value 
chosen in the right-hand parameter field. If any Delay value is shown on the right, this 
is taken into account by the quantization.

If you simply open the Convert Definition dialog, change the Grid value in the right-
hand field, turn on the Quantize Events checkbox (and make no further alterations), the 
event positions of the selected event definition lane will be quantized.

Working With Hyper Sets
You can store a combination of simultaneously displayed event definitions as a hyper 
set. When a hyper set is saved, the vertical zoom setting of the Hyper Editor is stored 
(this determines the number of event definitions that can be displayed simultaneously). 
You can save as many hyper sets as you need in each project.

The commands discussed in this section are available directly in the Hyper Set menu, 
shown in the Inspector. Simply click the Hyper Set menu, and choose the desired 
command to create or clear hyper sets.

Creating a Hyper Set
To create a new hyper set, choose Hyper > Create Hyper Set (or use the Hyper Set 
menu, or corresponding key command). The preset event definition in the new hyper 
set is the volume controller (#7). Any alterations that you make, such as adding or 
redefining event definitions, or adjusting the vertical zoom setting, are automatically 
stored in the current hyper set (as with screensets).

Choose Hyper > Create Hyper Set for Current Events (or use the Hyper Set menu, or 
corresponding key command) to create a new hyper set, consisting of the currently 
selected event types. 
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Creating a GM Drum Hyper Set
General MIDI has an established keyboard assignment pattern (a MIDI note map) for 
drum and percussion sounds. This mapping standard is often followed in non GM, GS, 
or XG compliant sound modules, samplers, and synthesizers. In some cases, however, 
you will need to make a few changes.

As the Hyper Editor is ideally suited for drum track creation and editing, you may wish 
to create a hyper set that is specifically tailored for your drum sets, including the 
correct drum names and hi hat modes. 

To create a hyper set for a GM drum kit:
m Choose Hyper > Create GM Drum Set (or use the Hyper Set menu, or respective key 

command).

You can change the names, positioning, and hi-hat modes of each event definition 
(drum or percussion lane) in the hyper set. See “Naming an Event Definition” on 
page 432, for information on renaming each drum sound in your kit, if it doesn’t match 
the GM mapping standard.

Using Hi Hat Mode
In hi hat mode, event definitions can be grouped together. Only one event from each 
group can be played at any Bar ruler position. This function is typically used to prevent 
different hi hat notes (open, closed, pedal) from being inserted at the same time 
position. This mirrors the real world behavior of hi-hats, which can’t be simultaneously 
opened and closed.

To define a hi hat group:
1 Click the dot shown to the left of the desired name column (kick 1, for example).

2 Click the dot shown to the left of other (adjacent) name columns (kick 2, for example).

A dotted line links the two instrument lanes in the the left-hand edge of the column.

3 Click the dots of each lane to switch off hi hat mode. 

All lanes in a hi hat group must be vertically adjacent to each other. If you want to 
group several events in non-adjacent lanes, simply move them by dragging the names 
up/down the Hyper Editor window.

If you add an event to any lane in a hi hat group, all existing events at this time position 
are deleted. 
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You can create as many hi hat groups as needed in a hyper set, but they must all be 
separated by at least one line in which hi hat mode is switched off.

Naming a Hyper Set
By default, a new hyper set is named MIDI Controls or GM Drum Kit. 

To re-name a hyper set:
m Double-click the name shown in the Hyper Set menu of the Inspector, type in the 

desired name and press Return.

Clearing and Deleting a Hyper Set
Clearing a hyper set resets a hyper set to its default, containing the preset event 
definition for the volume controller.

To clear the current hyper set:
m Choose Hyper > Clear Hyper Set (or use the Hyper Set menu, or corresponding key 

command).

To delete the current hyper set:
m Choose Hyper > Delete Hyper Set. 

Loading a Hyper Set
You can switch the Hyper Editor display to the desired event types by loading a saved 
Hyper Set.

To load a hyper set:
m Click the Hyper Set menu in the Inspector, and choose the desired hyper set from the 

pop-up menu.
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18 Editing MIDI Events in the 
Event List

The Event List is the most powerful, flexible, and complete 
MIDI editor in Logic Pro.

All MIDI event types are displayed as an alphanumerical list in the Event List. All aspects 
of events—start and end points, length, channel, and values—can be altered in this 
window.

You can view all events in one or more regions, and can filter the list to restrict this 
view to one or more event types, such as notes, pitch bend events, or both, for 
example. This makes the selection and editing of events faster and simpler.

The Event List also offers a number of advanced selection criteria that can be used in 
conjunction with, or independent of, the view filters. These allow you to select all equal 
or similar events, among others. 

As a practical example of where these facilities could be used:  Imagine a lead 
synthesizer solo that spans eight bars. You went crazy with the pitch bend while 
recording, but have found that every pitch bend event with a value of 55 sounds out of 
tune with the pad sound on another track. Filter the view so that only pitch bend 
events are visible, select one of the events with a value of 55, and choose Edit > Select 
Equal Regions/Events (Shift-E). All pitch bend events with a value of 55 are selected, 
allowing you to simultaneously change their values, or delete them.

As with the other MIDI editors, you can also create events directly in the Event List.
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Learning and Using the Event List Interface
All functions and options are shown at the top of the Event List area. The events 
themselves are shown in the list area below.

To open or close the Event List, either:
m Press the E key (the default Toggle Event List key command).

m Click the Lists button at the top right of the Arrange Toolbar, and click the Event tab, if 
it’s not already active.

The lists area is displayed (or hidden, if already open) on the right side of the Arrange 
window. The active tab is memorized when the lists area is closed.

Changing the Event List View Level
By default, the Event List will show all events in the selected MIDI region or regions. The 
Event List can also display a list of all regions (and folders) in the Arrange window.

To view a list of Arrange regions (and folders):
m Click the Hierarchy button at the top left of the Event List window. 

This button is only accessible when the Event List view is showing the contents of a 
region (it’s showing events, in other words).

To view the events within a region:
m Double-click on the name of the region with the Pointer tool. 

Its contents (the events) are shown in the list.

Note:  It is possible to pack folders within folders in the Arrange window. Simply use 
the procedures outlined above multiple times to navigate up or down through the 
most complex folder hierarchy.
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Filtering Event Types
When viewing events in the selected MIDI region or regions, you can make use of the 
event type buttons to filter the display. These buttons hide specific event types from 
the list below, thus limiting the view to events that you want to edit.

Important:  All selection, editing, and processing functions performed in the Event List 
only affect the displayed events, which protects any non-visible events from changes 
you may make.

To filter the event view:
1 Click the Filter button to turn on filter mode.

2 Click the desired event type buttons (Notes, Pitch Bend, and so on). 

Events which match the active buttons will disappear from the list display. 

Enhancing the Display of Events
The Event List display is normally restricted to one line per event. When the Additional 
Info button is on, however, all information stored along with the event is also shown. 

This is particularly important for editing SysEx messages. When examining note events 
in the Event List, you will also notice Rel Vel (release velocity or note off messages), 
which can be directly edited. 
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Score layout information is also included in the list when additional info is shown. You 
can edit this in the Event List if you wish, but it is handled far more efficiently in the 
Score Editor.

Note:  The Additional Info button is only visible when the Filter button is on. Once 
activated, the enhanced event list will be shown (in Filter or Create mode) until the 
Additional Info button is turned off.

Viewing Events Outside the Display Area
You will often find that the number of events shown in the list exceeds the amount of 
screen space. The list will automatically scroll when the Logic Pro transport is engaged, 
and the event at (or nearest to) the playhead position being indicated by a white line. 

Note:  The Catch button must be turned on for the Event List to automatically scroll 
through events during playback or recording.

To view events outside the display area, try the following:
m Use the event type buttons to filter the list, thus reducing the number of displayed 

events.

m Drag the scroll bar to the right of the list area.

m Choose View > Scroll to Selection (or use the corresponding key command).

Using the Shortcut Menu
Many selection, editing, and other commands can be accessed by right-clicking 
anywhere in the Event List. Make use of this to accelerate your workflow.

Note:  The right-click shortcut menu can only be accessed if the Right Mouse Button: 
Opens Shortcut Menu pop-up menu option is chosen in the Logic Pro > Preferences > 
Global > Editing tab.

Selecting and Creating Events
You can use any of the standard selection techniques in the Event List:  individual 
selection by clicking on events, multiple selection using the rubber band, or both of 
these (without altering the previous selection), in conjunction with the Shift key. Full 
details on all selection techniques are discussed in “Selection Techniques” on page 172.

∏ Tip:  When selecting events with the Pointer, you should click on the event name in the 
Status column, to avoid any unintentional parameter alterations.

Playhead position
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To make a selection (and navigate the list) with the Left or Right Arrow key:
m Press the Left Arrow key to select the previous event, or the right Arrow key to select 

the next event. Hold down the respective Arrow key to scroll through the list.

To select multiple events with the arrow keys:
m Hold Shift and press the Left or Right Arrow keys. Keep the Arrow key held down to 

select multiple events (with Shift held).

Note:  If the MIDI Out button is switched on (it is on by default), every newly selected 
event will be played. This allows you to scroll (or play) through the list and audibly 
monitor events as they are selected.

Refining Event Selection
First up, use of the event type buttons to filter the list of displayed events will make 
selection faster and easier.

You can use these filter buttons alone, or in conjunction with, specific selection 
commands available in the Edit menu and as key commands. These include:
Â Select All (default key command:  Command-A):  Selects all visible events.
Â Select All Following (default key command:  Shift-F):  Selects all events after (below) 

the currently selected event.
Â Select Inside Locators (default key command:  Shift-I):  Selects all events that fall within 

the locator boundaries.
Â Select Overlapped Regions/Events:  Selects all events that overlap one another. This is 

usually the end of one event, and the start of the following event.
Â Select Muted Regions/Events (default key command:  Shift-M):  Selects all muted 

events. This selection command is usually a precursor for deletion (Backspace).
Â Select Similar Regions/Events (default key command:  Shift-S):  Selects all C#3 note 

events, for example.
Â Select Equal Regions/Events (default key command:  Shift-E):  Selects identical events 

(same event type, and value).
Â Select Equal Channels (default key command:  Shift-K):  Selects events on the same 

MIDI channel.
Â Select Equal Subpositions (default key command:  Shift-P):  Selects events that start at 

the same position.

Details on what constitutes equal or similar events can be found in “Selecting Similar or 
Identical Objects, Regions, or Events” on page 175.
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Creating Events
The Event List accepts real time and step recording of MIDI events, as described in 
Chapter 14, “Recording in Logic Pro,” on page 351. You can also manually add events.

To add an event manually:
1 Move the playhead to the desired insert position. 

The current playhead position will be used as the insert position if not moved.

2 Click the Create button.

3 Click the desired event type button. 

The event is added at the playhead position, and is automatically selected.

Important:  Events can only be created in an existing region. If no region is selected, or 
exists, on the selected Arrange track, an alert is shown.

To duplicate an existing event:
1 Click on the original (source) event name in the Status column with the Pencil tool. 

2 An input box appears—use it to enter the position for the duplicate event. If you press 
Return, the duplicate will appear at the same position as the original.

The duplicate function is useful for creating a copy of an event with a different value. 
As an example, creating one or more notes of a particular length and velocity at the 
same position as another note. You could then alter the Pitch (Num column) of the 
duplicate notes to create a chord, or a new chord voicing. 

To add one or more events from the Clipboard:
1 Following a copy operation from another editor, choose Edit > Paste (default key 

command:  Command-V). 

2 A position input box will appear, allowing you to type in a destination position for the 
first event. If you press Return, the original position of the first event is retained and 
used. The relative positions of other copied events are maintained.

Important:  The position input box is unique to the Event List. Pasted events are not 
automatically added at the playhead position, as is the case in the graphical editors. 
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Copying and Moving Events
You can perform advanced copy and move operations within the Event List. These 
allow you to directly swap events, or to merge a group of notes from one section of a 
region to the same, or another, region, as examples. For more information, see 
“Advanced Note Copy and Move Options” on page 410.

Protecting the Position of Events
There are situations where you will want to protect certain events from being moved. 
As an example, several note events may be used to trigger footstep samples that match 
an actor walking down a corridor, in a video soundtrack. 

You have already created the music for this scene, but have been asked to increase the 
tempo to match several cuts of different camera angles in the corridor. Obviously, a 
change in the project tempo will move the events, resulting in out of sync footsteps. 
Thankfully, Logic Pro has a feature that preserves the absolute time position of events.

To protect the position of one or more selected events:
m Choose Functions > Lock SMPTE Position (or use the corresponding key command).

This ensures that events that fall at a particular absolute time position:  1 hour, 3 
minutes, 15 seconds, 12 frames, for example, will remain at this position when tempo 
changes are made.

To unprotect the position of one or more events:
m Choose Functions > Unlock SMPTE Position (or use the corresponding key command).

Editing Events
The list area features several columns:  Position, Status, Ch(annel), Num(ber), Val(ue), 
and Length/Info:  These columns display all details of all event types. In most cases, you 
can directly edit the data displayed (with the exception of the Status column, which 
merely indicates the event type). 

Not all columns are used for every type of event. As examples, system exclusive 
messages are not MIDI channel specific, so the Ch(annel) column is unused. Channel 
and polyphonic pressure messages have no length, so the Length/Info column is left 
blank.
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In some instances, clicking on the information in the Num(ber) or Val(ue) column will 
open a pop-up menu, allowing you to choose an option. As an example, clicking on 
the Num(ber) column of a MIDI controller event (Control is shown in the Status 
column) will open a pop-up menu of numbered and named standard MIDI controller 
types. These include:  Controller numbers 3 = Solo, 7 = Volume, 10 = Pan, and so on.

Full details on the different event types, the parameters shown in the columns, and the 
impact of changes—on both the event itself, and other columns—is found in “Learning 
About Event Types” on page 447.

Changing the Position and Length of Events
The units shown in the Position and Length/Info columns represent bars, beats, 
divisions, and ticks. Counting begins at 1 for each unit (first bar, first beat, first division, 
first tick:  1 1 1 1), and continues until it is carried over to the next largest unit.

Numerical input starts from the left (which means you can simply enter the bar 
number, and press Return, if you want to move an event to the beginning of a specific 
bar, when typing in a value). The units can be separated by either spaces, dots, or 
commas, allowing you to type:  3.2.2.2 or 3, 2, 2, 2 or 3 space 2 space 2 space 2.

Note:  For the sake of clarity, when the length begins with one or more zeros, a period 
(“.”) is used in place of the zeros. The minimum possible length is 1 tick (. . . 1) not 0 
ticks, as simultaneously switching a note (or other event) on and off wouldn’t make 
sense!

To move an event in time, either:
m Double-click on the position indicator (in the Position column), and type in a new 

position. Press Return to exit the position entry field.

m Click-hold on the specific position unit, and drag vertically. Release the mouse button 
when you’re done. 

If another editor, such as the Piano Roll is open, you will see the note event move as 
you change the value. As soon as you alter the position of an event, the list is 
automatically re-sorted. The currently selected event remains highlighted.

To change the length of an event:
m Use either of the methods above in the Length/Info column.
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Changing the Appearance of the Position and Length Columns
Not every project is bar/beat oriented. These View menu commands may make 
changing the position and length of events much easier when you’re working with film 
or video, for example.
Â View > Event Position and Length in SMPTE Units:  Choose to display the position and 

length columns in SMPTE units.
Â View > Length as Absolute Position:  Allows you to make the length display show the 

absolute position of the note off event, rather than its length from the note on 
position.

Â View > Relative Position:  If active, the event positions don’t refer to their absolute 
location within the project, but to their relative positions within the MIDI region 
(their distance from the start of the MIDI region).

Altering Event Values
Event parameter values can be changed by using the mouse as a slider or with text 
input, as per changes to position or length—on the values shown in the Val(ue), 
Num(ber) or Ch(annel) columns. 

You cannot directly alter the event type in the Status column. 

To alter the event type, either:
m Choose Functions > Transform to open a Transform window, and transform the event.

See Chapter 20, “Editing MIDI Events in the Transform Window.”

m Add an event of the desired type, and delete the original event.

If a parameter of one of several selected events is altered, it will affect the same 
parameter in all events within the selection group. When you alter parameter values in 
a group of selected events, the relative differences between parameter values remain 
unchanged.

Parameter values can only be altered until the (same) parameter value of one of the 
selected events has reached its maximum or minimum value.

To override the maximum or minimum value limitation:
m Option-drag on the value, or press Return to confirm a numerical input. 

This allows you to continue altering a parameter value in a multiple selection, even 
when one of the selected events has reached its maximum or minimum value. 

To set a parameter to the same value for all selected events:
m Hold Shift-Option, while using the mouse as a slider, or press Return to confirm a 

numerical input.
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Note:  It is possible to select different event types, and simultaneously alter the 
Num(ber) or Val(ue) parameters. Needless to say, this can lead to unexpected, and 
disastrous, results. It is highly recommended that you make use of the event filtering 
buttons to hide non-matching event types. The enhanced selection functions may also 
be of use when creating or editing groups of events.

Deleting and Muting Events
These two functions go hand in hand. It stands to reason that you will often want to 
remove events that you have muted.

To mute or unmute a note event:
m Click a note event with the Mute tool.

A dot appears in the Status column of muted note events.

The Edit > Select Muted Regions/Events command is also available in the Event List. It 
allows the selection of all muted notes in a MIDI region, making them easy to delete.

To delete events, do one of the following:
m Click them with the Eraser tool.

m Select the events, using any of the techniques and functions discussed earlier, and 
press Backspace.

m Choose one of the commands in the Functions > Delete MIDI Events menu.

Â Duplicates (default key command:  D):  Erases all duplicate events.
Â Inside or Outside Locators:  Erases all MIDI events within/outside the locators.
Â Outside Region Borders:  Erases all MIDI events that completely fall outside the 

region borders, which can happen when regions are resized.
Â Unselected Within Selection:  Erases all unselected MIDI events within a selection, 

such as between locators.

Soloing and Renaming Regions or Folders
Although the Solo tool can be used to hear events in isolation, it is most useful when 
viewing a list of Arrange window regions and/or folders (Event List at Arrange-level 
view).

To solo a region, folder (or event):
m Choose the Solo tool from the Tool menu, and click-hold on the region or folder name 

(or event) in the Status column.

The playhead will automatically jump to the beginning of the selected region or folder 
(or event), and soloed playback will start.
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To rename a region or folder:
1 Choose the Text tool from the Tool menu, and click on the region or folder name in the 

Status column.

2 Type in the desired name, and press Return to exit the text field.

The corresponding region or folder is renamed in the Arrange window.

Note:  The Text tool has no effect on events, as these cannot be renamed.

Learning About Event Types
This section covers the different types of events that can be viewed, and changed, in 
the Event List.

Note Events
Note events are used to trigger (play) software instruments and external MIDI sound 
modules or keyboards.

Â Num(ber):  MIDI note number (or pitch). The range is from C –2 (note #0) to G8 (note 
#127). Middle C is note #60. It’s known as C3 in MIDI terminology. On some keyboards 
and synthesizer modules (notably those made by Korg and Roland), the note range is 
from C –1 (note #0) to G9 (#127). Middle C is called C4 on such devices. The Display 
Middle C As menu in the Logic Pro > Preferences > Display tab allows you to alter the 
display to match your device.

Â Val(ue):  Velocity of a note from 1 to 127. The zero value (0) acts as a note off message, 
and cannot be used.

Â Length/Info:  Length of the note. Although MIDI can only transfer note on or note off 
messages, Logic Pro actually stores the position and length of all notes, which makes 
them easier to access musically. The note off message is generated automatically 
during playback.
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Mapped Instrument Notes
If the edited MIDI region is played through a mapped instrument, the names defined 
for each individual note appear in the Status column. A small note symbol to the left of 
each name aids in identifying these named events as note events.

Viewing and Changing Note Release Velocity
You can edit the release velocity of a note event when the Additional Info button is 
active. 

To view release velocity data:
m Turn on the Additional Info button (only available in filter mode).

Control Change Events
These event types are used to transfer MIDI controller information (modulation, sustain, 
volume, and pan, as examples) to software instruments or external MIDI keyboards and 
modules.

Â Num(ber):  The number of the controller. Each MIDI controller (such as the 
modulation wheel or sustain pedal) is assigned a specific Continuous Controller (CC) 
number (CC#1 or CC#64 respectively). This can vary from device to device. Several 
controllers (apart from the two above) are defined in the same way by most 
manufacturers; these standardized controllers include volume (CC#7) and pan 
(CC#10).

Â Length/Info:  Shows the name of standardized controllers defined in the MIDI 
Specification.
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Â Val(ue):  Value of the controller. Continuous controllers have a range of 0 to 127. 
Switch controllers (CC#64—CC#90) transfer two states:  off (val = 0) and on (any value 
between 1 and 127).

Pitch Bend Events
Pitch bend events are used to continuously vary the pitch. They are usually generated 
by a centered pitch bend wheel or joystick on your keyboard.

Â Num(ber):  Fine pitch bend division (LSB:  Least Significant Byte). Many keyboards 
transmit a value of 0. If the pitch bend wheel has an 8-bit resolution, you will see 
values of 0 or 64 in this column.

Â Val(ue):  The effective pitch value (MSB:  Most Significant Byte), ranging from 0 to 127. 
A value of 64 corresponds to the half-way setting of the wheel.

Â Length/Info:  The 14-bit value is displayed in this column as a decimal figure ranging 
from –8192 to 8191 (if your keyboard transmits 14-bit pitch bend data). The value in 
this column may be edited in the usual ways.

Program Change Events
Program change events transmitted to connected MIDI devices are used for patch 
(preset or setting) selection. These may be sounds in a synthesizer, programs in an 
effects unit, or snapshots in an automated mixing desk, as examples.

Â Val(ue):  A program number between 0 and 127. 
Â Some manufacturers (such as Yamaha) number the programs in their devices from 

1 to 128, not 0 to 127. If you have devices that follow this numbering protocol, you 
will need to subtract 1 from the program number shown on the device itself, when 
adding or altering a program change event. 

Â Other manufacturers use various methods of dividing internal memory locations 
into groups (or banks), and sounds. The most common is divisions into 8 groups of 
8 sounds, each numbered 1 to 8. These devices respond to program numbers 0 to 
63 by addressing storage locations 11 to 88. The instruction manuals for these 
devices should contain conversion tables to assist you.

Â Num(ber):  Bank select. Normally you will see this symbol (–), which means no bank 
select message will be sent. If you assign a number between 0 and 126, a bank select 
event is sent before the program change event. 
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This allows you to address the different sound banks (preset, internal, card, and so on) 
of connected MIDI keyboards and modules. The synthesizer must be able to recognize 
controller 32 as bank select, but unfortunately this standard is not used by all 
manufacturers. 

If you have any problems with bank select, check your synthesizer’s manual to see 
whether, and how, it responds to bank select commands. 

Note:  You can change the type of bank select messages sent by Logic Pro (see 
“Defining Custom Bank Selects” on page 887), if necessary for your devices.

Aftertouch Events
Aftertouch (or channel pressure) events are generated by a mechanical pressure sensor 
beneath some MIDI keyboards. These events can be used to modulate the synthesizer 
sound. All note events on a particular MIDI channel are affected. This means that 
applying pressure to one note in a held chord will affect all notes in the chord.

Â Num(ber):  This column is unused, as aftertouch events only have one data byte.
Â Val(ue):  Displays the amount of pressure on the keyboard (0 to 127).

Poly Pressure Events
Poly(phonic) pressure events are generated by mechanical pressure sensors beneath 
each individual key on some MIDI keyboards. The resulting sound modulation only 
affects the particular note that is pressed harder (after the initial keystrike). Only a few 
keyboards offer this capability.

Â Num(ber):  Displays the MIDI note name (C3, G4, and so on).
Â Val(ue):  Displays the amount of pressure on the key (0 to 127).
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SysEx Events
System exclusive data (SysEx) is unique to individual MIDI devices. You can record these 
events by using the dump utilities of your synthesizers. This enables you to save patch 
information, or other data, outside of the MIDI device (in a Logic project or MIDI file). 
The arrows in front and behind EOX are used to add or remove bytes.

SysEx Data in Hex Format
You can choose whether SysEx data is displayed in hexadecimal or decimal, in the 
Event List or the SysEx fader editors, with the View > SysEx in Hex Format command.

Hexadecimal digits are preceded by a $ symbol in Logic Pro.

For more information on manually programming a SysEx message, read “SysEx Faders” 
on page 931.

Meta Events
Meta events are control messages that are specific to Logic Pro. They are used to 
automate specific Logic Pro functions, and to organize and arrange Score Editor 
elements (particular notation symbols and formatting) which can’t be represented by 
MIDI events.

The Num(ber) determines the meta event function, and Val(ue) determines the value 
that is sent. You should only ever insert and edit the following Num(ber) column values 
in the Event List.
Â Num = 47 (Send Byte to MIDI):  This sends the track instrument any byte value (Val) 

between 0 and 255 ($00–$FF). As a usage example of this meta event; if you send 
246 as the byte, this is equivalent to a MIDI tuning request message. The display will 
show Send Byte $F6. Only use this meta event if you know what you’re doing—if you 
don’t, your sound modules and synths may start to behave very oddly indeed. 

Warning:  Editing SysEx Events requires a thorough understanding of the data format 
used by the MIDI device in question. Incorrect edits can lead to the corruption, or loss, 
of sound or other data.
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Â Num = 48 (Switch Fader):  This will send MIDI events to a particular output number 
(Val) on a cable switcher (see the Environment chapter for details). You first need to 
connect a cable between a track instrument and the cable switcher in question.

Â Num = 49 (Go to screenset):  This event selects a screenset. Val determines the 
screenset number. 

Â Num = 50 (Project Select):  This event will switch projects on a MIDI data filer/player. 
Val determines the stored project number. 

Â Num = 51 (Go to Marker):  When this event is sent, playback will jump to another 
marker. Val determines the marker number. 

Â Num = 52:  This meta event stops playback.

Meta events can also be generated by fader objects in the Environment.

The Event Float Window
The Event Float window provides information on the currently selected event (or 
region), and can be compared to a single line of the Event List. You can edit all 
parameters in this window.

To open an Event Float window:
m Choose Options > Event Float in the main menu bar.

You can also use the Toggle Event Float key command. 

Â The start point of the selected event or region in bars, beats, divisions, and ticks
Â The type or name of the selected event or region
Â The recorded MIDI channel and first data byte (if an event), the name of notes, and 

the second data byte (if it exists for the event type)
Â Length of the selected event or region in bars, beats, divisions, and ticks

To switch the Event Float between SMPTE time and the bar/beat display:
m Click the note symbol (to the left).
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19 Quantizing MIDI Events

Quantization is the rhythmic correction of notes to a specific 
time grid. Any inaccurately played notes are moved to the 
nearest position on this grid.

As an example, if the shortest notes in a passage are 1/16th notes, you would use 1/
16th quantization to move all notes to their ideal rhythmic position on the grid. This 
will only work, however, if no note was played more than 1/32nd from an ideal 
position. Any very loosely played notes will be moved 1/16th later or earlier than the 
desired position.

You have the choice of quantizing complete MIDI regions or individual events:
Â Region-based quantization affects all note events in a MIDI region. It is used on MIDI 

regions in the Arrange area.
Â Event-based quantization can be applied to any individual MIDI event (not only note 

events) within a MIDI region. Individual event quantization is performed in the MIDI 
editors. 

1 32 4 1 2 3 4

1 32 4 1 2 3 4

Unquantized note events

Quantized note events, aligned to the nearest beat position
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Important:  Event-based quantization destructively alters the position of all MIDI event 
types, except note events.

Quantizing Regions
You can quantize selected MIDI regions by changing the value of the Quantize 
parameter in the Region Parameter box of the Inspector. Region-based quantization 
only works on notes, not on other MIDI data event types, such as MIDI controllers.

The Quantize parameter determines the division of the quantization grid. The extended 
region parameters contain advanced quantization parameters, allowing you fine-tune 
the quantization grid. 

Important:  The (region) Quantize parameter is non-destructive. It adjusts the playback 
positions of notes in the region on-the-fly when Logic Pro is in play (or record) mode. It 
does not actually move the notes permanently. 

To change the quantization grid division:
m Set the Quantize parameter in the Inspector’s Region Parameter box to the desired 

value. 

You can also step through the available Quantize values, one at a time, with the Set 
Quantize Parameter to Next Value and Set Quantize Parameter to Previous Value key 
commands. 

This can be done at any time, including when Logic Pro is in play (or record) mode. The 
new value is immediately used to alter note playback positions. 

The Quantize grid options are:
Â Quantization Off:  The Off setting plays the notes at the finest possible timing 

resolution:  1/3840 note, which is unquantized playback, in practical terms.
Â Normal Quantization:  The 1/1, 1/2, 1/4, 1/8, 1/16, 1/32, and 1/64 note settings 

quantize the MIDI region to the equivalent note value.
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Â Triplet Quantization:  The 1/3, 1/6, 1/12, 1/24, 1/48, and 1/96 note settings quantize 
the MIDI region to triplet note values. A 1/6 note is equivalent to a quarter triplet, 1/
12 note to an eighth triplet, 1/24 note to a sixteenth triplet and 1/48 note to a thirty-
second triplet.

Â Mixed Quantization:  The 8 & 12 setting corresponds to eighths and eighth triplets, 16 
& 12 to sixteenths and eighth triplets and 16 & 24 to sixteenths and sixteenth triplets. 
Mixed quantization always applies to both note values, and requires greater playing 
precision when recording.

Â Odd Quantization:  The 9-Tuplet setting denotes novetuplets (1 bar = 9 beats), 7-
Tuplet is septuplets (1 bar = 7 beats), 5-Tuplet/4 is quarter quintuplets (1 bar = 5 
beats), and 5-Tuplet/8 is eighth quintuplets (1 bar = 10 beats). 

Â Swing Quantization:  The 8F, 8E, 8D, 8C, 8B, 8A, and 16F to 16A Swing settings delay 
the position of every second point in the quantization grid by a fixed percentage. 
The 8 or 16 denotes an eighth or sixteenth note quantize value. You can also 
manually alter the swing factor of any quantize value (see “Fine-Tuning the 
Quantization Grid” on page 456).

If you want to quantize various parts of a MIDI region differently:
1 Divide the MIDI region with the Scissors tool, and use different quantization settings on 

each segment (each new region). 

2 You can then recombine the segments of the original region with the Glue tool.

This maintains the quantize values of each segment. 

An alternate method is to perform event-level quantization in the MIDI editing 
windows (see “Event and Note Quantization” on page 459).

Quantize setting Swing percentage

8F or 16F 71%

8E or 16E 66%

8D or 16D 62%

8C or 16C 58%

8B or 16B 54%

8A or 16A 50%
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Some Points to Note When Using Region Quantization
The quantization grid always begins at the start of a MIDI region. If the MIDI region 
does not start at the beginning of a bar, neither does the quantization grid. If you alter 
the start point of a MIDI region, you also alter the quantization grid.

Important:  Unlike other region playback parameters (Delay, Transposition, and so on), 
Quantize affects the way notes are displayed in the MIDI editors. This allows you to see 
the effect of the chosen Quantize value by looking at the note positions in the Piano 
Roll Editor, for example.

Region quantization affects the whole MIDI region. To quantize individual notes or 
other event types, use event quantization in one of the editors (see “Event and Note 
Quantization” on page 459).

Fine-Tuning the Quantization Grid
You can use the extended region parameters to fine-tune your quantization grid. This 
provides a number of additional facilities that allow you to create and apply a swing or 
other quantize feel to your MIDI and software instrument parts.

To view the extended region parameters:
m Choose View > Extended Region Parameters.

Once enabled in one window, the extended region parameters are available to all MIDI 
editing windows, provided that the Inspector is open.

Unquantized MIDI events Quantized MIDI events
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The following quantization options appear below the standard set of region 
parameters. They can be applied to any quantization value (except Off ).

Â Q-Swing:  This percentage value alters the position of every second point in the 
current quantization grid. Values over 50% delay the beats. Values under 50% pre-
delay them. The most practical settings fall between 50% and 75%, imparting a 
swing feel to strictly quantized (or tightly-played) MIDI regions.

Â Q-Strength:  This percentage value determines how far a note is shifted towards the 
nearest grid position. 100% results in full quantization, 0% leaves the note at its 
recorded position.

Â Q-Range:  Q-Range is a very musical quantization strategy that requires a certain 
amount of technical musical prowess. It is ideal for recordings which already have the 
right groove, but are too hurried or laid back in places. It allows you to retain the 
original feel, but positions the rhythmic center precisely in the groove. A value of 0 
means that every note is quantized. If you enter negative Q-Range values, only notes 
that fall outside the set range are moved to ideal quantization grid positions; while 
notes closer to an ideal position remain unquantized. This moves the most poorly 
played notes (those outside the range) to perfect timing positions on the 
quantization grid, or at least towards these positions, depending on the Q-Strength 
setting. 

∏ Tip:  To obtain the best Q-Range results, use a low, even quantize value, such as 1/4 
note. Set the Q Range parameter to compensate for the maximum error in the 
recording.

Â Q-Flam:  Notes with the same time position (chords) are spread out by this 
parameter. Positive values produce an ascending (upwards) arpeggio, negative values 
a descending (downwards) arpeggio. The position of the first note (either the bottom 
or top note, assuming all notes start at the same position) in the arpeggio is 
unaltered.
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Â Q-Velocity:  This parameter (expressed as a percentage) determines the amount that 
the velocity values of quantized notes are affected by the velocity values of a 
template MIDI region (see “Creating Groove Templates” on page 461). At a value of 
0%, the notes retain their original velocity. At 100%, they adopt the velocity values of 
the template. Negative values alter the velocity, making the deviation from the 
template even greater.

Â Q-Length:  This parameter (also expressed as a percentage value) determines how the 
lengths of quantized notes are affected by the equivalent note lengths (notes at the 
same position) of a template MIDI region. A value of 0% has no effect, while at 100%, 
the notes adopt the exact note lengths of the template region. Negative values alter 
note lengths further, resulting in a more significant deviation from the template.

Making Quantization Permanent
In the same way that other region parameters can be normalized, the quantization 
settings can also be applied permanently to one or more regions. The Apply 
Quantization Settings Destructively function is especially well suited to pre-
quantization. 

As an example, if a recorded MIDI region cannot be quantized to a 16D Swing value 
without producing a few incorrectly timed notes, quantize it to 1/16th notes and then 
use Apply Quantization Settings Destructively. You can now use swing quantization on 
this cleaned-up version of the MIDI region.

As another example:  If you are recording a hi-hat pattern consisting of 1/16 notes and 
one single 1/32 note, first play the rhythm (quantized to 1/16 notes) without the 1/32 
note and choose Apply Quantization Settings Destructively. You can now raise the 
Quantization parameter value to 1/32 notes, and add the extra note without incorrectly 
quantizing any badly-played 1/16 notes.

To permanently quantize a region:
1 Choose the desired quantization settings (including extended region parameter 

quantize options, if desired).

2 Choose the MIDI > Region Parameters > Apply Quantization Settings Destructively 
command, or use the equivalent key command (default:  Control-Q).

Note:  Once this is done, it is impossible to revert to the original recording, unless you 
use Undo immediately after performing the operation (or use the Undo History).
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Event and Note Quantization
The menu bar of the Piano Roll Editor and Event List offer a Quantization menu and 
Quantize button. This is a separate quantization function, which can be applied to 
selected events, rather than entire regions. 

The Piano Roll Editor also offers a Quantize tool.

Further quantize operations are also available in the Transform window. These can be 
applied to events in one or more selected regions that match very specific criteria. 
Details in Chapter 20, “Editing MIDI Events in the Transform Window.”

Note:  Event-level quantization irreversibly alters the positions of all event types, with 
the exception of notes. Note events can be returned to their original record positions.

To quantize events in a region (Piano Roll and Event List):
m Choose the desired quantization value in the Quantization menu.

This menu provides the same grid values available in the Quantization menu of the 
Region Parameter box, shown in the Arrange window. 

m Do one of the following, dependent on the options available in the window:

Â Choose Functions > Quantize Selected Events, or use the corresponding key 
command (Score, Piano Roll, and Event List Editors).

Quantization menu

Quantize button

A Special Note About Quantization in the Score Editor
The primary purpose of the Score Editor is to produce readable (and printable) 
notation. While you can certainly edit MIDI note data in the Score Editor, and quantize 
it with the Quantize tool (or Functions > Quantization menu commands), it is best to 
perform individual note quantize operations in the Piano Roll or Event List editors.

The Quantize parameter shown in the Inspector of the Score Editor serves a purely 
graphical function. It alters the way notes are displayed, but does not affect note 
playback in any way.
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Â Select the events that you want to quantize, then click the Quantize button (Piano 
Roll and Event List Editors). The most recently selected (or active) quantize value is 
used on all selected events.

Â Select the Quantize tool, then click all notes you want to quantize (Score and Piano 
Roll Editors). The most recently selected (or active) quantize value is used on all 
selected notes.

To set a quantize value with the Quantize tool:
1 Click-hold on a single note (or a selected group of notes) with the Quantize tool, and 

the Quantization menu will open at the clicked position.

2 Choose the desired quantization value for the event(s).

To rubber band select, and quantize, several note events at once:
m Click-hold on the background of the Score or Piano Roll Editor with the Quantize tool, 

and drag across the desired notes. 

The most recently selected (or active) quantize value is used on all selected notes.

To return note events to their original positions:
1 Select all notes you want to undo the quantization for.

2 Do one of the following, dependent on the options available in the editor:

Â Choose Functions > De-Quantize, or use the De-Quantize key command (Score, 
Piano Roll, and Event List Editors).

Â Choose the Off setting in the Quantization menu, then click the Quantize button 
(Piano Roll and Event List Editors).

Â Option-click the Quantize button (Piano Roll and Event List Editors).
Â Option-click on one of the selected notes with the Quantization tool (Score and 

Piano Roll Editors).

Important:  Use of region-based quantization after you have individually quantized 
note events within a MIDI region will override your event-based quantizations, so take 
care! It may be worthwhile writing such changes into the region by following the 
instructions outlined in “Making Quantization Permanent” on page 458. This way, all of 
your hard work creating a number of individual event quantizations will not be lost by 
quantizing the wrong region.
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Creating Groove Templates
You can create quantization grids based on the rhythms of other MIDI regions. These 
are referred to as groove templates. Groove templates make it possible to capture the 
small timing deviations which give a MIDI region its feel, and apply them to other MIDI 
regions.

You can even take the feel from an audio region, and apply it to a MIDI region, helping 
a MIDI clavinet part to sit well with a funk guitar Apple Loop, for example (see “Creating 
an Audio to MIDI Groove Template” on page 462).

To create your own groove template:
1 Select the MIDI region you want to create a groove template from. 

∏ Tip:  As a rule of thumb, two-bar MIDI regions work particularly well as models for this 
function, but you can use MIDI regions of any length. Make sure that the source MIDI 
region actually contains a note at every desired quantization value.

2 Choose Options > Groove Templates > Make Groove Template (or use the Make Groove 
Template key command). 

This creates a quantization template which appears in the Quantization menu of the 
Piano Roll and Event List Editors, and the Region Parameter box of the Inspector, when 
in the Arrange window. 

Groove templates are named after the MIDI region they were derived from.

In essence, this command transforms the exact timing of notes in the selected MIDI 
region into a groove template that can be accessed, and used, like any Quantization 
menu value.

Important:  The source MIDI region used for a groove template must remain in your 
project! If you delete the source region from the project, the groove template name is 
not removed from the Quantization menu, nor can you use this quantization value. If 
chosen, nothing will happen.

To remove groove template entries from the Quantization menu:
1 Select the source MIDI region in the Arrange area.

2 Choose Options > Groove Templates > Remove Groove Template from List (or use the 
corresponding key command).



462 Chapter 19    Quantizing MIDI Events

This deletes the selected source MIDI region from the list of possible quantization 
templates, thus removing it from the Quantization menu. It does not remove the 
region.

Using Groove Templates Across Projects
If you wish to create and retain a number of quantization templates for use in several 
projects, follow these steps:

To use a groove template in several projects:
1 Copy or create your source MIDI regions in one project. 

2 Name these regions as desired, with the Text tool.

3 Use the Options > Groove Templates > Make Groove Template function on each source 
region.

4 Pack all of these regions into a folder (and rename the folder to Grooves, for example).

5 Use File > Save As Template.

Use this template as your project starting point, whenever you wish to access these 
quantization templates.

Importing Groove Templates
You can also import third-party groove templates, such as those made by the Canadian 
firm WC Music Research (DNA Groove Templates). 

To import third-party groove templates:
1 Choose Options > Groove Templates > Import DNA Groove Templates (or use the 

corresponding key command). 

2 Select the desired DNA Groove Templates in the file selector, then click Import.

The groove templates are added to the Quantization menu.

The the quantization templates are saved with the project and can be used, even when 
the project is played on another computer that doesn’t have the corresponding DNA 
Groove Templates on its hard disk.

Creating an Audio to MIDI Groove Template
You can create MIDI groove templates from digital audio material. This allows you to 
extract the feel from drum loops or rhythmic samples (Apple Loops are the obvious 
example), and use the resulting groove template to quantize MIDI regions.

Note:  You should switch off the Edit > Search Zero Crossings option in the Sample 
Editor window menu.

To extract a MIDI groove template from a one bar drum loop:
1 Add the drum loop audio region to the Arrange area using any of the methods 

discussed in Chapter 11, “Adding Pre-Recorded Media,” on page 255.
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2 Double-click on the region to open the Sample Editor, or select the Sample Editor tab 
at the bottom of the Arrange window.

3 Choose Factory > Audio to MIDI Groove Template (default key command:  Control-M). 

4 Choose the desired settings in the Audio to MIDI Groove Template tab:

Â Preset menu:  This menu contains various presets for the Audio to MIDI parameters, 
which are suited to specific types of audio material. You can use these presets as 
starting points for your own processing.

Â Granulation (ms):  Use Granulation to determine the time span of louder components 
in the audio material. Logic Pro uses these peak signals (or transients) to derive 
information for velocity points in the groove template. The most useful values are 
usually between 50 and 200 milliseconds, depending on the tempo of the audio 
material.

Â Attack Range (ms):  This tells Logic Pro how long the attack phases of the sounds in 
the audio material are. As examples of how you might use this parameter; drum and 
percussion instruments have short attack times of less than 20 ms, while string 
instruments have longer attack phases. The best values for the majority of 
instruments are usually between 5 and 40 ms; with most around 20 ms.

Â Smooth Release (%):  This parameter is specifically designed to process audio material 
that contains sounds with a long release or reverb tail. This makes it easier to convert 
these sounds into suitable quantization points. The value you choose here should 
generally be between 0 and 5%, except when processing passages that contain 
sustained notes, distorted guitars, or similar sounds.

Â Velocity Threshold:  This parameter sets the threshold level. All signals that fall below 
this value are ignored. In most cases, you should choose a value of 1, except when 
processing very dense, loud material with soft background noises.

Â Basis Quantize:  This function enables you to add artificial trigger points at positions 
where there are no trigger points present. Groove templates created with this 
method are suitable in situations where you need more quantization points than are 
contained in the audio material. The automatic identification of trigger points in the 
audio material is not affected by use of this parameter.
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Â Time Correction:  This parameter allows you to compensate for any time delays that 
may occur when external samplers or synthesizers are triggered by MIDI notes. These 
time delays are sometimes very noticeable, particularly if the connected device is 
playing a MIDI region (that was quantized with an Audio-to-MIDI groove template) at 
the same time as the original audio material. You should be able to compensate for 
this effect by using settings between –20 ms and 0 ms.

At the bottom of the Sample Editor, you’ll see three fields labeled:  Audio, Quantize, and 
Result.

Â Audio:  Displays the quantization points identified in the audio file.
Â Quantize:  Shows the quantization points selected as the Basis Quantize.
Â Result:  Shows the quantization positions in the new groove template, which are 

produced by the combination of the two values above.

5 Click on any audio trigger point to prevent it from being transferred to the template. 

Manually selected (unused) points will be dimmed.

6 Click the Try button in the Audio to MIDI Groove Template to apply the new groove 
template to all selected MIDI regions, 

7 Listen to the results.

8 Adjust the parameters until you are happy with the resulting groove, and then click 
Use.

This saves the new groove template, and adds it to the bottom of the Quantization 
menu. The quantize template name is derived from the audio file name.
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20 Editing MIDI Events in the 
Transform Window

The Transform window allows you to define a set of 
conditions and operations that are used to select, and alter, 
specific MIDI events. 

The Transform window is so-named because it transforms MIDI events—based on 
conditions, operations, and values chosen by you—into different types of events, or 
events with different values.

The Transform window is immensely powerful, and is the ideal tool for edits that would 
otherwise be impossible (or at least, incredibly tedious). As an example, imagine an 
orchestral project that has been sent to you to work your magic on. The individual 
violin and viola parts were recorded with a different string library, and feature 
aftertouch information (in 200 MIDI regions!) that introduces a weird pitch modulation, 
and some sample layer switching artefacts when played with your string samples. After 
looking at this aftertouch information, you discover that only a small range of values 
are causing the problem. You have a few options; edit your sampler instruments, 
manually strip out all aftertouch information (region by region, or globally, thus losing 
the performance benefits that the aftertouch information provides) or alter the 
problematic values in the Transform window. Option three sounds like the way to go!

A number of preset transform sets are available for many common editing tasks. These 
may be all you’ll ever require, but should the need arise, you can freely create and save 
your own transform sets, and recall them later.

∏ Tip:  The Environment contains a similar transformer object that you can use for real 
time transformations of MIDI events. For details, see the information on the 
“Transformer Object” on page 899.
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To open the Transform window, do one of the following:
m Choose Window > Transform from the main menu bar (or use the corresponding key 

command, default:  Command-4). 

m If you want to transform events (that you have selected in one of the MIDI editors) 
choose a preset from the Functions > Transform menu.

You can certainly choose the Window > Transform command while you are in a MIDI 
editor, but you will need to manually select a preset.

Choosing and Using Transform Sets
At the top left of the Transform window, you will find a Presets menu. The first fourteen 
items in the menu are write-protected presets. These presets provide templates for 
common editing tasks, such as; creating crescendos or fixing note lengths. 

You can temporarily change the used parameters of a preset, but all changes will be 
discarded when you exit the preset.

Dependent on your needs, it may be worthwhile spending some time creating your 
own transform sets. These can be freely configured and saved as part of a project 
(Doing this in your template projects makes your transform sets available in all 
projects). Your transform sets will appear at the bottom of the Presets menu (see 
“Creating Your Own Transform Sets” on page 482).

To use a transform preset:
1 Select the MIDI regions or events that you want to transform.

2 Click the arrow button to the right of the Preset menu, and choose a transform set from 
the pop-up menu. 

Note:  You can create a new transform set by choosing **Create Initialized User Set!** in 
the Preset menu, but more on this later. 
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3 In the Mode menu, choose how you want to transform the selected events within the 
regions. 

4 Set the desired selection conditions.

5 Define the operations you want to perform.

Note:  You can click on the “Hide unused parameters” checkbox (turn it off ) to show all 
conditions and operations, allowing you to make more advanced choices.

6 Do one of the following:

Â Click the Select Only button to select all events that meet the selection conditions. 
The events will not be transformed. You can use this option to refine your selection, 
and ensure that your conditions only affect the events that you truly want to 
transform.

Â Click the Operate Only button to transform all selected events, in accordance with 
the operations settings (The selection conditions have no effect). This is useful if you 
want to edit events that you’ve already selected manually.

Â Click the Select and Operate button to select all events that match the conditions, 
and transform them as per the Operations settings.

Note:  The number of selected regions and events (that match the conditions) are 
displayed above the selection and operation buttons.

Learning About the Transform Presets
This section covers the purpose of the fourteen transform presets, and provides tips on 
their use.

Crescendo
Used to gradually increase the velocities of a group of notes from low to high values (or 
vice versa—decrescendo or diminuendo). 

Â Select the area (Position column) that contains the note events that you want to 
perform a crescendo on.
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Â Set the desired velocity values in the Operations area, ranging from 1 to 127. 
Â If you want a less dynamic crescendo, set a smaller value range. 
Â To perform a diminuendo, set a higher value in the top Velocity field, and a lower 

value in the bottom field.

Scale 14 Bit PitchBd
Scales pitch bend data, keeping the 14 bit information intact. The length of pitch bend 
events is expressed as a decimal value ranging from –8192 to 8191, and this is the 14 bit 
information that is retained. 

Â Choose the desired multiplication factor for the fine pitch bend (LSB) and effective 
pitch values (MSB) in the top value field shown in the Operations area

Â Set the (14 bit) value in the lower field, which is then added to the scaled (multiplied) 
events.

Double Speed
Doubles the tempo by halving event positions and lengths. By default, the Div(ision) 
value fields for the Position and Length operations are set to 2.0000.

Change the values in both fields to 4.000 to quadruple the tempo.
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This preset is a great creative option for drum regions. The following example presumes 
that a “four-on-the-floor” kick, snare, hi-hat, and other percussion sounds region is 
being viewed in the Hyper Editor.

To experiment with the Double Speed preset in the Hyper Editor:
1 Click on the name column of one of the drum sounds. 

This selects all note events of a particular pitch in the region.

2 Change the Length field to a value that does not match the Position field, or vice versa.

3 Repeat the steps with other drum or percussion sounds.

This can lead to interesting polyrhythms that you may not have thought of. 

As you can see from this example, you can use the same transform operation multiple 
times on the same region, and can also combine the different transform presets to 
achieve an end result, by using them one after the other.

Half Speed
Halves the tempo by doubling event positions and lengths. The Mul(tiply) value fields 
for the Position and Length operations are set to 2.0000 by default. 

Set both Mul operation value fields to 1.5000 to reduce the tempo by around a third.
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Humanize
Adds a random value to the position, velocity, and length of selected note events. This 
preset is useful on rhythmic parts, such as clavinet or piano accompaniments, and 
drum and percussion regions (or events). It can add life to strictly quantized material, or 
notes that were manually entered (see “MIDI Step Input Recording” on page 384).

Alter the values for Position, Velocity, or Length to increase or decrease the random 
factor for each of these event parameters.

Reverse Position
Reverses the positions of events (usually notes) within a section.

Change the Position condition values to alter your selection range.
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Reverse Pitch
Inverts the pitch of all note events.

Change the Flip operation value to set a pivot point note number, around which note 
event pitches will be reversed.

Transposition
Transposes all note events. 

Â Change the Add operation value to the desired amount (in semitone steps).
Â You can achieve downward transpositions by setting a negative value in this field.
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Exponential Velocity
Alters the scaling of the velocity curve. This preset is of particular use on software or 
MIDI instrument parts. Velocity is generally used to control the initial volume of 
instruments, but is often used to trigger filter envelopes, making the sound brighter or 
darker. Transforming regions is much faster than changing the velocity scaling or filter 
parameters of your MIDI or software instruments.

Change the Velocity value field in the Operations area to change the velocity curve. 
This is instantly reflected in the map area below.



Chapter 20    Editing MIDI Events in the Transform Window 473

Velocity Limiter
Limits the velocity to a maximum value. This is perfect for transforming instrument 
parts that are too strident, by limiting the velocity.

Change the Max operation field value to limit the velocity to a maximum value. This is 
instantly reflected in the map area below.

Fixed Note Length
Creates constant note lengths. Useful on many instruments, particularly drums and 
other rhythmic parts, such as pianos, clavinets, and basses.

Change the Length value field in the Operations area to change the lengths of all 
selected events to the chosen length. Both shorter and longer events are changed to 
match the length value you have defined.
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Maximum Note Length
Sets the maximum length of all note events. 

Change the Length value field in the Operations area to define the maximum note 
length. Existing note lengths—which are shorter than the length defined here—are 
retained. Events that are longer than the defined value are shortened.

Minimum Note Length
Sets the minimum note length. 

Change the Min value field in the Operations area to define the minimum note length. 
Existing note lengths—that are longer than the length defined here—are retained. 
Note events that are shorter than the defined value are increased in length.
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Quantize Note Length
Quantizes the note length. This preset actually quantizes the note end position.

Change the Length value field—in the Operations area—to define the length that note 
end positions will be quantized to.

Using the Transform Window Parameters
This section discusses the use of the individual Transform window elements, providing 
an overview of what each option does. Examples towards the back of the chapter (see 
“Usage Examples” on page 483) will give you an idea of how each can be used, but 
these are only the tip of the iceberg. Ultimately, your imagination and creativity are the 
only restrictions on how MIDI events can be manipulated in the Transform window.

Mode menuPreset menu

Operations area

Selection Conditions area

Map
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Global Parameters
These parameters globally affect the Transform window appearance and operating 
mode.
Â Mode menu:  Choose one of the following settings menu options to determine how 

events are transformed.
Â Apply operations to selected events:  Choose this mode to apply the operations to all 

selected events. The selected events are determined by the selection conditions.
Â Apply operations and delete unselected events:  Choose this mode to transform the 

selected events, and delete all non-selected events. Only events that match the 
selection conditions will remain after the transform operation. This mode allows 
you to use the Transform window as a programmable filter—where only events 
that match the conditions survive.

Â Delete selected events:  Choose this mode to delete selected events. This mode 
enables you to use the Transform window as a programmable erase function. All 
events that match the conditions are deleted, and all other events remain 
unchanged. The operation settings are irrelevant in this mode.

Â Copy selected events, then apply operations:  Choose this mode to retain the 
selected events in their original form, copy them, and apply the operations. 

Â Preset menu:  Choose one of the transform presets or one of your own transform sets. 
Â “Hide unused parameters” checkbox:  Hides all unused menus in the Selection 

Conditions and Operations areas. This provides a better overview of the settings in 
use. It also prevents you from making accidental alterations.

Setting the Selection Conditions
You can define conditions that determine which events are selected for transform 
operations. This done in the Selection Conditions area of the Transform window. 

Each column represents a different MIDI event parameter.
Â Position:  Determines the time position of the event, referenced to the start point of 

the MIDI region (not the start point of the project). 
Â Status:  Determines the event type.
Â Channel:  Recorded MIDI channel of the event.
Â Data Byte 1/Pitch:  First data byte (controller number) or note pitch.
Â Data Byte 2/Velocity:  Second data byte (controller value) or note velocity.

Note:  The parameters displayed in the Data Byte fields are dependent on the chosen 
Status menu setting. Certain Status menu settings will not show the Data Byte fields at 
all!

Â Length:  Length of the note or event.
Â Subposition:  Time position of the event, within a bar.
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The condition is considered to be fulfilled when an event matches the defined effective 
range, and values, of all event parameters. These ranges and values are determined in 
the pop-up menus and fields found under each of the event parameter columns. 

To choose the event type:
m Click on the Status pop-up menu to determine which events will be selected. You have 

a choice of just two settings here:

Â All:  All event types fulfil the condition.
Â =:  A further pop-up menu is displayed below the Status pop-up menu, in which you 

can define the desired event type. These include:  note, poly pressure, control 
change, program change, channel pressure, pitch bend, meta, and fader. 

To set all other selection conditions:
m Click on the desired pop-up menus (in each column that is needed) to define the 

selection criteria for events. 

One or two value fields will appear below the pop-up menu, unless Map is chosen. You 
can assign one of the following value conditions for each of the parameter columns:
Â “=”:  The event must be equal to the value in the field, for the condition to be 

fulfilled. As an example, only note C#3 events will meet the condition.
Â Unequal:  The event must not be equal to the value in the field, for the condition to 

be fulfilled. All events that are not C#3 will meet the condition, for example.
Â Smaller/Equal (<=):  The event value must be less than, or equal to, the value in the 

field (a note velocity less than, or equal to 98, for example) for the condition to be 
fulfilled. 

Â Larger/Equal (>=):  The event value must be larger than, or equal to, the value in the 
field (a note pitch higher than, or equal to C#3, for example), for the condition to be 
fulfilled.

Â Inside:  The event must fall within the value range (of event positions or note pitches, 
for example) of both fields, for the condition to be fulfilled.

Â Outside:  The event must be outside the value range (of event positions or note 
pitches, for example) of both fields, for the condition to be fulfilled.

Â Map:  Most conditions are numerical relationships, and the condition is met if the 
incoming MIDI event value satisfies the condition. The last condition, Map, works a 
little differently. Two numerical parameters are specified, and the incoming value is 
first converted by the map, to create a mapped value. The mapped value is then 
compared with the two parameters to see if it falls inside them. Incoming events 
with a mapped value that falls within the range will fulfil the condition—all other 
events will not fulfil the condition (see “Using the Map” on page 480). 

To set the values for a selection condition:
m Use the mouse as a slider, or directly type the desired value into the field. 
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Defining Operations
The Operations area is used to define the changes you would like to make—to events 
that meet the selection conditions. As with the selection condition pop-up menus, you 
choose an operation in the appropriate event parameter columns. One or two value 
fields may appear, dependent on the chosen operation. 

To define the operation for the status event parameter column:
m Click the pop-up menu, and choose one of the following operations for the Status 

condition:

Â Thru:  The event type passes through unaltered.
Â Fix:  The event type is altered. Choose a new event type in the pop-up menu that 

appears below the Status Operations menu. Choices include; fader, meta, note, poly 
pressure, control change, program change, channel pressure, or pitch bend. This 
effectively converts one type of event to another.

Note:  When you convert note events, two events are created:  one for the note on 
event, and one for the note off event.

Â MapSet:  Choosing this setting means that events which match the Status condition 
(note events, for example) are used to control the map of a subsequent operation—
in the Channel, Data Byte 1, Data Byte 2, and Length columns.
Â The Data Byte 1 value selects the position in the map.
Â The Data Byte 2 value determines the value at this map position.

Internally, Logic Pro sends a meta event pair:  #123 for the position, and #122 for the 
value at this position. These types of meta events can also be created in other ways.

To define the operation for all other event parameter columns:
m Choose one of the following operations for the Channel, First or Second Data Byte, and 

Length columns (as required). One or more value fields will appear below the 
respective operations pop-up menus. 

Â Thru:  The event passes through unaltered.
Â Fix:  Fixes the event parameter to the set value. You could use this to set the pitch of 

all note events to a specific note value, making it easy to convert a bass groove into a 
hi-hat pattern, for example.

Â Add:  Adds the value to events. As an example, a value of 8 could be added to all 
incoming note velocity events, thus making the notes louder.

Â Sub:  Subtracts the value from events. You could use this to reduce all controller 10 
(Pan) events, thereby narrowing the stereo spread of an electric piano part, for 
example.

Â Min:  Parameter values lower than the defined value are replaced (by this value). 
Larger parameter values are not altered. You could use this to replace all note 
velocity messages below 45, thereby reducing the dynamic range of a MIDI region—
or put another way, making the soft notes louder.
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Â Max:  Parameter values that exceed the set value are replaced by it. Smaller event 
parameter values remain unaltered. This could be used to restrict filter resonance 
modulation events above a value of 100, for example, resulting in a softer filter 
sound.

Â Flip:  All parameter values that match the conditions are reversed around a pivot 
point (the value defined here). Events above this value are moved by the same 
distance below it and vice versa. As an example, you could move a note from E3 to 
G#2, if the pivot point value was set to C3. Effectively, the E3 event, which is 4 (pitch) 
values above the C3 pivot point is flipped to 4 values below (G#2). This can also be 
used to reverse selected note positions around a particular bar or beat, as another 
example.

Â Mul:  The parameter value is multiplied by the set value (accurate to four decimal 
places). The effect, and use, of this operation is best illustrated by the Half Speed 
preset.

Â Div:  The parameter value is divided by the set value (accurate to four decimal 
places). The effect, and use, of this operation is best illustrated by the Double Speed 
preset.

Â Scale:  The parameter value is multiplied by the top value, and the bottom value is 
then added. This is a combination of Mul and Add. If you enter a negative number 
here, values can be subtracted from—rather than added to—the value resulting 
from the multiplication.

Â Range:  Parameter values outside the set value range are replaced by the values of 
the (range) limits (combination of Min and Max).

Â Random:  Random values are generated within the set limits.
Â +—Rand.:  A random value between zero and the set value (positive or negative) is 

added.
Â Reverse:  The parameter value is reversed within its value range (no value can be set 

here).
Â Quantize:  The parameter value is quantized to a multiple of the set value.
Â Qua & Min:  Like Quantize, but the quantization does not fall below the set value (a 

combination of the Quantize and Min functions, with the same set value).
Â Expon.:  The parameter value is scaled exponentially. The extreme values (0 and 127) 

remain unaltered. The set value determines the shape of the curve. Positive values 
result in the exponential scaling of data (increasing input values remain lower for 
longer, and then rise quickly), and negative values result in the logarithmic scaling of 
data (decreasing input values remain higher for longer, and then drop off more 
quickly).

Â Crescendo:  This only works if the Inside Position selection condition is selected 
(crescendos need start and end points.). Crescendo creates a smooth alteration of 
the current parameters, between the set value boundaries.
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Â Rel.Cres:  This only works if the Inside Position selection condition is selected. The 
effect is similar to that achieved by Crescendo, but the previous values of the 
parameters being altered are taken into account when the crescendo is created, 
preserving the relative feel of the original.

Â Use Map:  The set map will be used when this operation is selected (see below).

To set the values for an operation:
m Use the mouse as a slider, or directly type the desired value into the field. 

Using the Map
128 vertical bars reflect the full MIDI value range (from 0 to 127), and provide a visual 
overview of the transformation. 

Essentially, each bar represents a particular MIDI value—which can be mapped to a 
different value. The type of event, and operations, are determined in the Selection 
Conditions and Operations areas. 

To give you an example that may help your understanding:
Â Each of the bars could represent a MIDI note number (from 0 to 127) value.
Â By default, there is a 1:1 relationship for each bar, where value 1 = value 1, value 15 = 

value 15, and so on, throughout the 128 bars. Applying this to MIDI note numbers, 
bar 60 = C3 (middle C), bar 61 would represent C#3, bar 62 = D3, and so on.

The default and mapped values are shown in the two fields to the lower-left of the 
map graphic. 
Â You can alter these values directly in the fields, or by dragging any of the bars 

vertically. As you do so (using either method), the corresponding field/bar is updated.
Â If you alter the bar 60 (middle C) value to show 72 in the “mapped to” field, this value 

will be remapped accordingly when the transform operation is applied. 

This will result in all MIDI note number 60 messages being transformed into MIDI note 
number 72 messages (if you’re a mathematics whiz, you will have worked out that this 
would effectively transpose all C3 notes to C4).
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Some Points to Note About the Map
The map is only visible when chosen in one of the Operations pop-up menus. 
Appropriate selection conditions must also be set, or the map will not be shown.

The map is universal, which means that it remaps one MIDI value to another. 

It does not know what type of MIDI data is sent to it. It is only concerned with the value 
of the data.

This means that one map can be used to simultaneously alter the pitch, velocity, and 
length values of incoming note events, for example.

Exchanging Parameter Values
You can re-route the value of each of the three event parameters:  Channel, Data 
Byte 1, and Data Byte 2 to the value of a different parameter from this group. 

To replace the source (Condition value) with the target parameter value:
m Click the dots on the lines between the Selection Conditions and Operations areas.

Repeated clicks will cycle between different targets.

Note:  The value is exchanged before the operation is performed.
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Creating Your Own Transform Sets
You can store your own transform settings in a user transform set.

To create a user transform set:
1 Choose **Create Initialized User Set** from the Presets pop-up menu. 

2 Set the desired conditions. 

3 Set the desired operations.

4 Switch on the “Hide unused parameters” checkbox. This helps to avoid changes to 
conditions and operations that aren’t required for (or may mess up) your transform set.

5 Click on New Parameter Set (Number) in the Presets menu. Type in a new name for 
your transform set.

This transform set will now appear at the bottom of the Presets list in all Transform 
windows—for this project! You should consider saving your user transform sets in one 
or more template projects. This way, they will always be available to you in all future 
projects.

∏ Tip:  Renaming an existing transform set creates a new transform set that is identical to 
the original. The existing (source) transform set is retained.

Importing Transform Sets From Other Projects
You can import transform sets from other projects, allowing fast access to a transform 
preset you created earlier. This facility also makes it easy to add existing transform sets 
to new template projects.

To import all transform sets from another project:
1 Choose File > Project Settings > Import Settings from the main menu bar (or use the 

corresponding key command, default:  Option-Command-I).

2 Clear all checkboxes—except Transform Sets—at the bottom of the Import Settings 
dialog.

3 Browse to, and select, the project that contains the transform sets you want to import.

4 Click the Open button, and the transform sets will be imported into the current project. 
The names of these imported transform sets are retained, and added to the bottom of 
the Presets list.

5 Repeat the steps above to import transform sets from other projects.
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6 Save your project or template.

Usage Examples
The following section provides several usage examples for the Transform window. 

To add a mod wheel controller event (#1), with a value that matches the note’s 
velocity:
This is automatically placed one tick after each note start and end, thus avoiding 
potential conflicts with the note events themselves.

1 Choose the following settings in the Transform window:

Â Mode menu:  Copy selected events, then apply operations
Â Selection Conditions area:  Set Status to Note.
Â Operations area 

Â Set Position to Add and enter a value of 1 in the field below it. 
Â Set Status to Fix and choose Control in the menu below it.

Note:  When you convert MIDI note events to controller events, two controller events 
are created:  one for the note on event, and one for the note off event. 

Â Set Pitch to Fix and enter a value of 1 in the field below it. This means “the first data 
byte receives the value of 1” (the first data byte defines the controller number for 
controller events, and mod wheel events happen to be #1).

If you analyze these settings, you’ll see that all note events will be selected for 
operation. A copy of each will be made, then moved 1 tick later than the original, and 
converted to CC#1 (mod wheel)—with a value that corresponds to the velocity of the 
original note. This is because the second data byte (Vel) is left unaltered.

2 Click Select and Operate.

To create a transform set that fixes all note velocities to a defined amount:
1 Select **Create Initialized User Set** from the Preset pop-up menu. 

2 Set the Status menu in the Selection Conditions area to “=”. 
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3 Choose Note from the pop-up menu below.

4 Choose the Fix setting in the Velocity menu of the Operations area.

5 Change the amount to 127 in the value field below the Velocity menu.

To convert MIDI note events to MIDI controller 1 events:
1 Choose the following settings in the Transform window:

Â Mode menu:  Apply operations to selected events.
Â Selection Conditions area:  Set Status to Note.
Â Operations area:

Â Set Status to Fix, and choose Control in the menu below it.

Note:  When you convert MIDI note events to controller events, two controller events 
are created:  one for the note on event, and one for the note off event. 

Â Set Pitch to Fix, and enter a value of 1 in the field below it.

2 Click Select and Operate.

To randomly change the pitch of MIDI note events:
1 Choose the following settings in the Transform window:
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Â Mode menu:  Apply operations to selected events,
Â Selection Conditions area:  Set Status to Note.
Â Operations area:  Set Pitch to +–Random, and set the max deviation from the root 

note in the field below. If you set a value of 12, you’ll achieve a deviation of one 
octave up and one down (two octaves, around the root note, in other words).

2 Click Select and Operate.

∏ Tip:  To restrict the randomness to one direction—up or down, as opposed to both—
use the other Random Option, which limits the range that notes fall into.

To make note selections for edit operations:
1 Choose the following settings in the Transform window:

Â Selection Conditions area:
Â Set Status to Note.
Â Set Position to Inside, and choose the desired range. 

2 Click the Select Only button.

All notes in the defined range will be selected for you to cut, move, or whatever …

To delete volume events (MIDI CC#7) from a MIDI region:
1 Choose the following settings in the Transform window:

Â Mode menu:  Delete Selected Events.
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Â Selection Conditions area:
Â Set Status to Control.
Â Set Data Byte 1 to a value of 7.

2 Click Select And Operate.

To delete all controller events from a region:
1 Choose the following settings in the Transform window:

Â Mode menu:  Delete selected events.
Â Selection Conditions area:  Set Status to Control.

2 Select the MIDI region you want to transform, then click Select and Operate.

To create an ascending pitch pattern from notes of one pitch:
1 Choose the following settings in the Transform window:

Â Mode menu:  Apply operations to selected events.
Â Selection Conditions area:

Â Set Status to Note.
Â Set Position to Inside, and define the desired range (Cresc. only works if the Inside 

Position selection condition is chosen, as crescendos need start and end points). 
Â Operations area:  Set Pitch to Cresc., and enter a value of D0 and G6 in the fields 

below. 

2 Click Select and Operate.
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21 Editing Audio in the 
Sample Editor

You can precisely select, refine, and process audio recordings 
in the Sample Editor.

The Sample Editor allows you to make incredibly accurate adjustments to audio files, 
right down to individual samples. This makes it the ideal tool for the removal of pops 
and clicks in audio material, or setting accurate crossover points for looped playback.

The Sample Editor also features a number of audio processing tools, collectively known 
as the Digital Factory. These include time stretching and pitch shifting, audio 
quantization, and extraction of pitch and rhythmic information from audio—which can 
be applied to other audio or MIDI parts.

Other sample manipulation processes, such as; reversal, automatic slicing of audio—
based on silent areas, and setting optimal levels are also available. 

Important:  All edits and processes performed in the Sample Editor are destructive! This 
means that the audio file is actually altered. While you can certainly undo edits and 
processing commands, you should get into the habit of working on copies of your 
audio files, rather than the originals. It’s better to be safe, than sorry.

 Ruler

Info display

 Waveform display

 Anchor

PlayheadRegion area Waveform overview

Play button Loop button
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Playing Audio Files
There are various ways to play back the audio sections visible in the Sample Editor, 
allowing you to hear audio during edits. Playback occurs independently of the project 
playhead position. If you’d like to hear the selected audio passage in the context of the 
project, just use the Transport playback controls, as usual.

The Mixer’s Prelisten channel is used for monitoring in the Sample Editor. You can 
access the Prelisten channel in the Environment Mixer layer—you can find it to the 
right of the highest numbered audio channel strip.

Basic Playback Commands
As mentioned above, audio playback in the Sample Editor is independent of the 
project playhead position. This enables you to hear the audio in a number of ways, 
making selection and editing tasks simpler.

To start playback in the active selection area:
m Click on the Play button (or use the Play/Stop Selection key command). 

If you double-click at any position on the ruler, the audio file will play back from this 
point, to the end of the current selection. If you double-click on a point beyond the 
selected area, the audio file will play until its end point is reached.

To continuously repeat the selected area:
1 Click the Loop button next to the Play button. 

When you turn this on, the currently selected audio section will cycle continually when 
playback is engaged.

2 Click on the Play button (or use the Play/Stop Selection key command). 
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You can change the start and end points of the selected area while looped playback is 
happening. This makes it easy to edit the start and end points of a drum loop, for 
example, until it loops perfectly. When you’re satisfied with the loop, you can make the 
selected area a new region with the Edit > Selection → Region function.

To control playback with the overview:
m Simply click-hold at the point you want playback to begin. Release the mouse button 

to stop playback. 

You can also start monitoring from any position by double-clicking on the overview.

To scrub audio:
m Click-hold on the ruler and move the mouse. 

The audio playback will follow the speed and direction of your mouse movements.

Advanced Playback Commands
You can use the following key commands for a number of advanced playback options:
Â Play/Stop All (default:  Shift-Control-Option-Space bar):  Plays back the whole audio 

file, regardless of the current selection area.
Â Start/Stop Region:  Toggles between playback of the audio file’s region start and end 

points—regardless of the selection area. 
Â Play/Stop Region to Anchor (default:  Shift-Control-Space bar) and Play/Stop Region 

from Anchor (default:  Control-Option-Space bar):  These key commands allow you to 
check the region anchor position, by listening to the parts just before and after the 
anchor.
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Navigating Audio Files
The Sample Editor offers a number of navigation facilities that make it easy to move to, 
and enhance the view of, specific parts of an audio file—making selection and editing 
far simpler, faster, and more accurate.

The scroll bars along the bottom and right edges of the Sample Editor scroll through 
the detailed waveform display in the usual way. 

The zoom controls are also used in the same fashion as in other windows.

Click on the overview to display the area surrounding the Sample Editor playhead in 
the detailed waveform display. The overview always displays the entire audio file, 
regardless of the zoom level (and selected area) shown in the waveform display.

Quickly Navigating to Specific Positions in Audio Files
If you’re trying to reach a specific point in the audio file, some of the commands listed 
below may also be of use to you. These are available in the Sample Editor’s Edit menu, 
and as key commands. 
Â Go to Selection Start (default key command:  Left Arrow key)
Â Go to Selection End (default key command:  Right Arrow key)
Â Go to Region Start
Â Go to Region End
Â Go to Region Anchor (Down Arrow key)

To navigate to the loudest point in an audio file:
m Choose Functions > Search Peak (or use the corresponding key command, 

default:  Shift-P) to scan the currently selected region for the sample bit with the 
greatest amplitude value. 

The playhead is placed on this bit in the waveform display.

To navigate to silent passages in your audio file:
m Choose Functions > Search Silence (or use the corresponding key command, 

default:  Shift-S) to scan the selected audio file (or selection area) for sections 
containing silence (digital zero).

The playhead is moved to the start point of the first silent section. 

This command can be used repeatedly, to select and remove, or modify, silent sections 
in your audio files.
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Changing the X and Y Axis Scales
The Sample Editor’s vertical Y axis scale can show the waveform amplitude in 
percentage units or in sample units. 

To display the amplitude scale in sample units:
m Enable the View > Amplitude Sample Value setting.

To display the amplitude scale in percentage units:
m Enable the View > Amplitude Percentage setting.

You can also access the amplitude view settings by Control-clicking on the amplitude 
scale itself.

The horizontal X axis (the ruler) shows the course of the audio file over time. 

To change the time (horizontal) scale:
m Choose one of the following scaling units in the View menu or the time scale shortcut 

menu (Control-click on the ruler):

Â View > Samples:  Displays the sample word number from the beginning of the 
project or audio file.

Â View > Min : Sec : Ms:  Shows the scale in Hours : Minutes : Seconds : Milliseconds, 
from the beginning of the project or audio file.

Â View > SMPTE Time:  Shows the scale in SMPTE time in Hours : Minutes : Seconds : Frames).
Â View > Bars/Beats:  Shows the scale in bars, beats, divisions, and ticks, just like the Bar 

ruler in other windows. The zero point is represented by “1 1 1 1”, but lengths are 
measured from “0 0 0 0”.

Note:  Changes to display format options affect the information shown in the help tag, 
and the info display.

Percentage scale Sample units scale
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Absolute and Relative Time
The different axis scales in the Sample Editor can be displayed in two ways:
Â By reference to the time axis of the project (absolute position)
Â By reference to the beginning of the audio file (relative position)

The units in the ruler (between the overview and the waveform display) are displayed 
with dotted lines when viewing the relative position. 

To enter the relative display mode, do one of the following:
m Open the Sample Editor from the Audio Bin.

m Activate Link mode in the Sample Editor, and select a region in the Audio Bin.

The beginning of the section is automatically assigned to the zero value, or in bar/beat 
terms, position:  1 1 1 1. The position marker lines are dotted, indicating no time 
connection exists.

Note:  This will not necessarily match the actual playhead position. The calculation of all 
remaining musical sections uses the current project tempo at corresponding positions.

To enter the absolute display mode, do one of the following:
m Open the Sample Editor from the Arrange window.
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m Activate Link mode in the Sample Editor, and select a region in the Arrange area.

Time is measured from the start of the project, which is assigned a value of zero (or 
position:  1 1 1 1 in bar/beat terms). In this viewing mode, the absolute (project) time is 
shown in the ruler.

Displaying the Waveform as Sample Bits
You can switch from the usual representation of the waveform to one that shows the 
structure of the recorded digital data—at high magnification levels on the detailed 
waveform display. This viewing mode is useful when eliminating clicks and pops from 
your recordings, for example.

To display the waveform as sample bits:
m Enable the View > Show as Sample & Hold. 
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Making Selections
Sample Editor commands only affect the currently selected area of the audio file. The 
start point, and length, of the current selection area are shown in the info display 
above the overview.

The format of the information shown in the start point and length display fields 
matches the chosen View menu display settings.

∏ Tip:  Make use of the navigation options discussed in the previous section to accelerate 
selection.

To select the entire audio file:
m Choose Edit > Select All (or use the corresponding key command, 

default:  Command-A).

To select a particular section of an audio file:
m Click-hold on the start or end of the area you want to select in the waveform display, 

and drag to the right or left.

The start point and length are displayed (as sample words) in a help tag while making 
your selection.

To change the start or end point of an existing selection area:
m Shift-click on a selection area to change its start or end point. 

The proximity of your click—to the beginning or end of the selection—determines 
whether you change the start or end point boundary. The closest one wins …

Info display
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∏ Tip:  If you hold down Option-Shift, the more distant selection boundary is changed 
(rather than the nearer). 

To move the selection area:
m Option-click, and drag to shift the whole selection, without changing its length.

To define the selection area using a region:
1 Select a region in the Audio Bin or Arrange area.

2 Choose Edit > Region → Selection. 

This function is useful if you want to reselect the entire region for cycled playback, after 
performing a number of edits, for example.

The reverse can also be done, allowing you to redefine the length of an existing region 
by choosing Edit > Selection → Region.

Copying, Pasting, Deleting, and Cutting
Once you have selected an area of an audio file, you can use the usual Cut, Copy, Paste, 
and Delete commands in the Edit menu to cut, copy, paste, or remove the selected 
area.

Important:  All of these commands (except Copy) actually change the data of the audio 
file itself; in other words, they behave destructively. 

Cut
Cuts a selected passage out of an audio file, and copies it to the Clipboard. All following 
audio sections move forward (towards the start point of the audio file) to fill the gap.

Copy
Copies a selected passage to the Clipboard, leaving the selected area in its original 
location.

Paste
Inserts the contents of the Clipboard at the clicked position. All audio data that follows 
the paste (insert) point is moved back (towards the end of the audio file) to make room 
for the Clipboard contents.

Delete
Erases the selection, without placing it in the Clipboard. All data beyond the deleted 
passage is moved forwards (towards the start point of the audio file) to fill the gap.

Warning:  Anything selected at the time of the paste is deleted, and replaced by the 
Clipboard contents.
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Destructive Audio Editing and Processing
The following section covers the use of several standard audio processing commands 
and tasks. These include normalizing, reversing, fading, and changing the level of audio 
files. Advanced audio processing options are discussed in “Working With the Digital 
Factory” on page 504.

You are normally asked to confirm all sample editing functions executed with a key 
command. 

To disable this safety feature:
m Turn off the Preferences > Audio > Sample Editor > Warning before processing function 

by key command checkbox.

Correcting Pops and Clicks With the Pencil
The Pencil tool allows you to correct clicks and pops or clipping, by manually drawing 
in the detailed waveform display. 

To correct pops and clicks with the Pencil:
1 Navigate to the desired section of the waveform by clicking on the overview.

∏ Tip:  Pops and clicks are often the loudest part of an audio file, so you may find the 
Functions > Search Peak command useful when looking for them.

2 Use the zoom controls to magnify the section of the waveform that you want to 
correct.

3 Use the Arrow tool to scrub the audio around the pop or click. 

This will help you to identify exactly where you need to draw.

4 Select the Pencil tool, and drag from left to right (including up or down movements) to 
draw in a new shape to the waveform spike. The edges of drawn sections are 
automatically smoothed. Press Option to affect both sides of stereo waveforms.
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As long as the mouse button is held down, the drawn waveform can be replaced by 
the original waveform—by moving the mouse to the left.

Changing the Level of an Audio File
You can use the Change Gain command to change the level of an audio file. You would 
typically use it on an entire audio file, but can certainly boost portions of it. 

To raise or lower the level of the selected audio file (or area) by a specific amount:
1 Choose Functions > Change Gain.

2 Choose the desired settings in the Change Gain dialog:

Â Set the required level change by clicking on the up or down arrows, or by directly 
typing in either Change Relative field. You have a choice of a percentage or decibel 
increase or decrease. 

Â Click on the Search Maximum button to search for the highest peak level. This 
automatically sets a value that is used to alter the level of the audio file. The Results 
in Absolute fields displays the maximum level that will be achieved by changing the 
gain (by the amount shown in the Change Relative fields).

3 Click Change (or press Return) to perform the gain change.

Important:  You should never make a gain change that results in a value over 100%, as 
this will result in digital clipping.

Fading Audio Files
You can destructively fade in or out on entire, or selected areas of, audio files. The fade-
in or out time is determined by the current selection area within the audio file.

To create a fade in or fade out:
1 Use any of the selection techniques outlined earlier in the chapter to determine the 

length of the fade-in or fade-out area. 

Â Fade-in:  Volume is set to zero at the start point of the selection area, and the fade-in 
occurs over the length of the selection.

Â Fade-out:  Volume is set to zero at the end point of the selection area, and the fade-
out occurs over the length of the selection.

2 Do one of the following:

Â Choose Functions > Fade In (default key command:  Control-I) to create a fade in.
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Â Choose Functions > Fade Out (default key command:  Control-O) to fade passages 
out automatically. 

∏ Tip:  If you use the Silence function (see “Silencing an Audio File Section” on page 498) 
to remove unwanted background noise from silent passages, small jumps in volume 
can sometimes appear at the silence start and end points. In this situation, zoom in, 
and select a small area surrounding (just before and after) the start point of the signal, 
then use the fade-in function.

To adjust the fade curves:
1 Open the Functions Settings window by choosing Function > Settings.

2 Edit the Curve value to change the shape of the fade-in or fade-out curve.

3 Turn on the S Curve checkbox if you want to create s-shaped curves.

These settings are automatically stored in the Preferences when Logic Pro is closed, and 
apply to all projects.

∏ Tip:  Common fades (such as a fade-out at the end of a track) can also be achieved with 
Mixer, automation, or Hyper Draw functions. The Arrange window Crossfade tool offers 
a further, flexible, non-destructive fade option (see “Creating Crossfades and Fades on 
Audio Regions” on page 342). 

Silencing an Audio File Section
You can use the Silence command to set all amplitude values to zero, rather than 
removing (with Cut or Delete) all data from the selected area of an audio file. This 
function is generally used to silence unwanted background noise in quiet passages.

To silence the selected area of an audio file:
m Choose Functions > Silence (or use the corresponding key command, default:  Control-

Backspace). 
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Reversing the Selected Area of an Audio File
The Reverse command is most commonly used on an entire audio file, to reverse a 
cymbal sound, for example. It can also be used as a creative option on selected 
portions of audio files. As an example, the reverb tail at the end of a file can be 
reversed, copied, and pasted to the beginning of the file.

To reverse the selected area of the audio file:
m Choose Functions > Reverse (or use the corresponding key command, 

default:  Shift-Control-R)

Trimming Audio Regions
You can use the Trim command to remove unimportant passages (generally silence) 
from the start and end of your audio files. Trim can also be used to remove portions of 
audio files that are not used by regions.

To erase all unselected portions of an audio file:
m Choose Functions > Trim (or use the corresponding key command:  Control-T)

Important:  Make sure that the areas you are about to delete do not contain any 
regions that you may need. Regions outside the selection area will be lost. Portions of 
regions that fall partly outside the selection area are also removed, resulting in a length 
reduction of the region. If any such regions are being used in the Arrange area, a 
warning dialog will give you the option of cancelling the trim command.

Normalizing Audio Files
Normalization is a process that raises the maximum level of a digital signal to a 
specified amount—typically to its highest possible level, without introducing 
distortion.

∏ Tip:  The start and end points for the section being normalized should generally not fall 
within a continuous section of audio, as this will result in abrupt increases in volume 
after normalization. The start and end points should therefore be located in sections 
that occur just after, or before, musical gaps.

To normalize the selected area in an audio file:
m Choose Functions > Normalize (or use the Normalize key command, 

default:  Control-N).

Logic Pro finds the point with the highest volume in the current selection area, and 
determines how far this is from the maximum possible level. The level of the selected 
area is then raised by this amount. The dynamic relationships of sample levels within 
the audio passage remain unaltered. 
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You can set the desired maximum level in the Function Settings window, which you 
can open by choosing Functions > Settings (or by clicking the Settings button in the 
Normalize dialog).

Set the desired maximum level (as a percentage or in decibels) in one of the Peak at 
fields. 

∏ Tip:  You should not choose 100% (0 dB) in these fields, as this may result in clipping 
should you wish to increase the gain of the overall signal afterwards, say with an EQ. As 
a good rule of thumb, you should leave yourself at least 3 to 6 dB of headroom, to 
allow for further audio processing tasks, such as mixing and effects processing. 

These settings are automatically stored in the Preferences when Logic Pro is closed, and 
apply to all projects.

Reversing the Phase of a Selection Area
You will find the Invert command extremely useful for correcting phase cancellation 
errors, or when several out of tune signals (or several signals processed through chorus 
effects), are to be mixed down to mono. 

To completely reverse the phase of all currently-selected audio material:
m Choose Functions > Invert. 

All negative amplitude values become positive, and vice versa. 

Note:  This doesn’t audibly change the file, if heard in isolation. The process depends 
heavily on the audio material.

∏ Tip:  You can also use the Invert function to decode mono/stereo recordings, but it’s far 
easier to use the Direction Mixer plug-in for this task. For more information on this 
plug-in, see the Logic Studio Instruments and Effects manual.

Removing DC Offsets
Some audio interface hardware can layer direct current (DC) over the audio signal. This 
results in a vertical shift in the waveform position, which can be clearly seen in the 
Sample Editor. 

During playback, this can cause crackling sounds at the start and end of the audio 
region.
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To center the waveform around the zero amplitude line:
m Choose Functions > Remove DC Offset.

Adjusting the Project Tempo
Just like automatic tempo matching functions in the Arrange, the Functions > Adjust 
Tempo by Selection and Locators command adjusts the project tempo, in accordance 
with the current locator positions and selection area in the Sample Editor.

The operation is similar to the Arrange function (see “Setting the Project Tempo to 
Match an Audio Region” on page 524); but only applies to the selected area of the 
audio file in the Sample Editor, rather than the overall length of the region.

Sample Loop Functions
The Edit > Sample Loop → Selection, Edit > Selection → Sample Loop, and Edit > Write 
Sample Loop to Audio File functions are ideal for use with the EXS24 mkII sampler. 
Please see the Logic Studio Instruments and Effects manual for details on the EXS24 mkII.

They can also be used to generate audio files that contain the loop settings in the file 
header. This allows you to make full use of these files in any application that can read 
the loop information in the file header.

Simply use either selection command to choose an area of the open audio file, and the 
Write command to save an audio file—inclusive of loop information—stored in the file 
header.

Undoing Editing Steps in the Sample Editor
Almost all of the Sample Editor functions are destructive, and change the files stored 
on your hard drive. You can, of course, use the Undo function should things go awry.

To compare (or undo) your edits with the original audio file:
m Choose Edit > Undo (or use the corresponding key command, default:  Command-Z).

As the Undo function in the Sample Editor works independently from the rest of the 
program, you can try out an edit in the arrangement, and make changes there. As soon 
as you open the Sample Editor again (or make it the key focus window), the Undo 
function is available for the last destructive sample edit.

Data altering processes can be cancelled while underway by pressing Command-
period. The audio file will be retained in its original state, even if it appears that a 
portion of the editing function has occurred.
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Setting Undo Preferences
You can configure the Sample Editor’s undo functionality in the Preferences > Audio > 
Sample Editor tab:

Â Clear Undo History when quitting:  Switch this on to automatically delete the Undo 
History for all edited audio files, when you quit Logic Pro.

Â Record selection changes in Undo History:  Switch on if you wish to undo and redo 
changes to selected areas in the Sample Editor.

Â Record Normalize operations in Undo History:  Turn off if you don’t want to create any 
undo files once the Normalize function is invoked. As normalization is generally the 
last step in sample editing, this parameter (if active) can destroy the undo history. As 
a safety feature, a warning pops up if an undo history exists (and the switch is on), 
providing you with the opportunity to create an undo file.

Â Number of Undo Steps:  Sets the maximum number of undo steps. 
Â Store undo files in project folder:  Switch this parameter on (on by default) if you would 

like the Undo History to be stored in a sub-folder of the current project.
Â Global Undo File Path:  All Undo History files are saved into a global location (a user-

defined folder) if the “Store undo files in project folder” option is not switched on.

Creating Manual Backups
You can make manual backups of the file you’re editing, or replace it with a backup 
version at any time—using a variety of functions.

Although the Undo History and standard Undo functions are available, it’s a good 
working practice to create backups before processing or editing. This provides a safety 
copy of your precious audio recordings, should something unexpected happen, due to 
a processing error or other unforeseen event.



Chapter 21    Editing Audio in the Sample Editor 503

To duplicate the audio file you’re working on:
m Choose Audio File > Create Backup (default key command:  Command-B)

This creates a copy of the audio file (with the extension .dup) in the same folder as the 
source file.

To revert to a backup file:
m Choose Audio File > Revert to Backup (default key command:  Shift-Command-B). 

This function completely replaces the current audio file with the backup (provided one 
exists, of course). 

Important:  You can not reverse this function with Undo.

To save a copy with a different name—to the location of your choice:
1 Choose Audio File > Save A Copy As.

2 Choose the desired settings in the Save A Copy As dialog:

You can set the desired sample rate, bit depth, file format, stereo conversion, and dither 
type for the destination file. The dialog also features an “Add resulting files to Audio 
Bin” option, allowing you to add the file to the Audio Bin, following the save. 

3 Browse to the location (hard drive and folder) that you want to store the audio file in, 
then type a name for the audio file in the name field.

4 Click the Save button.
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To save the selected area as a new audio file:
m Choose Audio File > Save Selection As (or use the corresponding key command, 

default:  Shift-Command-S). 

The Save Selection As dialog offers the same file conversion menus as the Save A Copy 
As dialog. You can also choose to add the file to the Audio Bin, following the save.

Working With the Digital Factory
The Sample Editor features a number of audio processing tools, collectively known as 
the Digital Factory. These include time stretching and pitch shifting, audio quantization, 
and extraction of pitch and rhythmic information from audio—which can be applied to 
other audio or MIDI regions or events.

You access the Digital Factory functions via the Sample Editor’s Factory menu. The 
Digital Factory functions have number of common aspects, outlined below:
Â Digital Factory processes only affect the selected area of an audio file. The selected 

area of the audio file is replaced by the processed audio material.
Â You can play the file while a Factory process is taking place. This will slightly slow 

down processing. A progress bar is displayed during processing.
Â Some Digital Factory functions offer a Prelisten button that provides a rough idea of 

the expected result. (Not available for all digital audio hardware).

The Digital Factory functions are divided into two categories, and window types—
Machines (large float window) and Functions (small float window). 

Each function has its own tab. This allows you to quickly switch between the functions 
contained in a window by clicking the corresponding tab. 
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Using the Time and Pitch Machine
You can use the Time and Pitch Machine to radically alter the time structure of audio 
files, including time compression or expansion, and pitch transposition. When changing 
the pitch, you can also correct any alteration of the formants. Pitch shifting without 
formant correction causes a phenomenon commonly known as the Mickey Mouse 
effect.

To open the Time and Pitch Machine, do one of the following:
m Choose Factory > Time and Pitch Machine (or use the corresponding key command, 

default:  Control-P). 

The Technology of the Time and Pitch Machine
The Time and Pitch Machine analyzes the spectral components and dynamics of the 
digital audio material, and processes the result. The algorithm endeavors to retain as 
much spectral and dynamic information as possible, and minimizes phase variations. 
In stereo files, the phase relationship between the left and right channels is fixed, and 
not altered. Doubled sound events are kept to a minimum. 

You should, however, bear in mind that apart from resampling (transposition), the 
Time and Pitch Machine has to achieve the “physically impossible”:  When a sample is 
lengthened, information needs to be invented. This should be as realistic as possible. 
Conversely, when a sample is shortened, information has to be cut out. This cut 
information should be as unimportant to the overall character of the sound as 
possible. Lengthening is more difficult than shortening, and if you have a choice, it’s 
better to speed up a drum loop than to slow it down.

There’s always a small deviation between the set stretch or compression factor, and 
the actual result. This is because the algorithm needs some freedom to optimize the 
spectral and dynamic integrity (the sound quality). The deviation from the set value is 
only a few milliseconds (or fractions of a bpm). This shouldn’t present a problem, as 
the absolute deviation is independent of the length of the processed section. Put 
another way, this means the deviation is no greater in longer files.
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m Click the Time and Pitch Machine tab if another Digital Factory processor is visible.

You don’t need to enter, or adjust, all of the Time and Pitch Machine parameters to get 
a good result. Most are linked, so an adjustment to the Tempo parameter will result in 
changes to the Length values, and vice-versa. 

Choosing the Mode and Algorithm 
The Time and Pitch Machine’s Mode and Algorithm menus define the operating mode, 
and algorithm, used when performing the time stretch or pitch shift.

Time and Pitch Machine Modes
You can choose between Free and Classic (default) in the Mode menu. 
Â Free is the most common setting when using the Time and Pitch Machine. It results 

in a free compression/expansion or transposition of the audio material, where the 
pitch and tempo are completely independent of one another.

Â The Classic mode is for situations where you want to transpose a selected region, 
and also affect its tempo. This produces an effect that you’re probably familiar with, 
as it simulates the sound of changing tape speed. This mode changes the pitch, sonic 
character, and playback speed of the audio material.

Time and Pitch Machine Algorithms
The Algorithm menu allows you to choose the algorithm that is best suited to the 
audio material you want to process. Your choices are:
Â Version 5:  This algorithm was inherited from Logic 5. It can be used on most types of 

audio material, and has a particular color, which may be useful as a creative option.
Â Any Material:  This is the most universal algorithm. It is able to handle most material. 
Â Monophonic:  A specialized algorithm for monophonic material—an individual voice, 

brass, or woodwind instrument, for example.
Â Pads:  Use this algorithm on polyphonic material with harmonic content—choirs or 

string sections are good examples.
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Â Rhythmic Material:  Use this algorithm on rhythmic material—can be drums and 
percussion, but less obviously; rhythm guitar, clavinet, and piano comp parts.

Â Beats Only:  This algorithm perfectly maintains the timing of percussive material. It 
should be your first choice for all kinds of dry drum loops.

Â Universal:  This high-quality algorithm is able to handle any kind of audio material, 
and is generally recommended for most time stretching tasks. The following two 
algorithms can, however, deliver better results in cases where the audio material 
exactly matches the outlined specifications. 

Â Complex:  Choose this algorithm to obtain natural sounding results when time 
stretching complex musical material—orchestral music or final mixes. 

Â Percussive:  The Percussive algorithm perfectly maintains the timing of rhythmic 
material, making it a good choice for drum loops and percussive, non-harmonic 
signals. In comparison to the Beats Only algorithm, the Percussive algorithm is better 
suited for percussive material that has been processed through a reverb (or contains 
a long tail). This may also apply to percussive playing styles, such as a staccato 
electric piano or clavinet parts. Beats Only may be the better alternative for dry drum 
recordings. 

Tempo Parameters
The Tempo section is divided into two columns. The left column (Original) displays the 
current values of the selected area in the audio file. The right column (Destination) is 
used to set the desired target values.

Tempo Change (%)
Determines the tempo alteration, displayed as a percentage (no original value is 
shown).

Tempo
Displays the tempo in bpm (beats per minute). Ensure that you set the right length in 
bars, or the correct original tempo will not be shown on the left!

Length in Samples
Displays the length of the selected area in samples.

Support of Third Party Algorithms
Logic Pro allows you to access the pitch shift and time stretch algorithms of the 
following third party plug-ins in the Time and Pitch Machine:
Â Serato:  Pitch’n Time 
Â Izotope:  Radius

Note:  These algorithms can only be accessed in the Time and Pitch Machine if the 
corresponding Audio Unit plug-ins are installed, and authorized, on your system. 
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Length in SMPTE
Displays the length of the selected area in SMPTE time format.

Length in Bars
Displays the length of the selected area in musical values (bars, beats, divisions, and 
ticks). If you have already adjusted the project tempo to match the region that you’re 
about to edit, the original value will automatically be set correctly. If not, you need to 
manually enter the original length here.

Pitch Parameters
You use the pitch parameters to determine the amount of transposition in cents, and 
also the strength of harmonic correction, if used.

Transposition (Cent)
Transposition of the sound material in 1/100th semitone units (cents). A value of 100 
will result in an upwards transposition by one semitone. A value of –1200 will result in 
the audio material being transposed down an octave.

Harmonic Correction
The entire spectral structure is shifted when audio is transposed. During this process, 
not only is the fundamental pitch transposed, but all of the resonances (formants) are 
shifted as well—as though the whole instrument or singer is being reduced or 
enlarged. This, of course, is not natural. Voices transposed up will sound like Mickey 
Mouse, or like Darth Vader if transposed down.

You can use the Harmonic Correction feature of the Time and Pitch Machine to correct 
this unnatural spectral shifting of formants.

Turn on the Harmonic Correction checkbox to correct the formants that define the 
timbre (sonic character). In other words, the formants in the transposed material are 
not changed. 

This means that the original timbre (or the physical size of the resonance body) is 
maintained, resulting in a more natural sounding transposition. The only trade-off is 
that calculation takes more time.

Note:  The quality of Harmonic Correction is heavily dependent on the source material, 
because the algorithm has to make intelligent decisions between tonal and atonal 
components of the recording, and handle them separately. This is not an exact science, 
and is more accurate on monophonic material than complex stereo material, but you 
can certainly use it on a complete mix. The phase correlation of stereo recordings is 
maintained. 
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Harmonic
If Harmonic Correction is turned on, you can also use the Harmonic (Shift) parameter to 
independently alter timbre. The units are shown in cents—100 cents per semitone.
Â If you select the same value in both the Harmonic and Transposition fields, no 

correction occurs, and the result is as if Harmonic Correction is switched Off.
Â If you set Harmonic to zero, the formants don’t change. This avoids the unwanted 

side effects of traditional pitch shift algorithms.

∏ Tip:  If you need to find the exact transpose value by trial and error, switch off Harmonic 
Correction. As soon as you’ve found the right transposition value, do an independent 
Harmonic Correction, with the same value, in a second step.

Shifting Formants Without Transposition
You can also use Harmonic Correction to shift the formants without transposition. This 
means you can alter the physical size of the sound source’s resonance body—to give 
female voices a male character and vice versa, for example—while keeping the pitch in 
tune. 

This remarkable effect (sometimes known as gender-bending) allows you to change 
sounds so that they appear to have been made by unusually small or large instruments. 
It is useful for beefing-up thin or brittle sounding parts, such as guitars, or instruments 
and vocals that were recorded through a microphone with a limited frequency 
response.

As a usage example on a vocal part:  If you set Harmonic Shift to –300, and the 
Transposition value to zero, the sonic character of the singer will be changed as though 
transposed three semitones down—but without an actual transposition in pitch. This 
means that a musical C remains a C, but the timbre of the vocal becomes darker.

Using the Groove Machine
You can use the Groove Machine to alter the feel, swing, or groove of digital audio 
material, in percentage steps. Put another way, the Groove Machine can quantize 
straight audio!

You can also strictly quantize audio that “grooves a little too much” with the Quantize 
Engine (see “Using the Quantize Engine” on page 516).

Important:  Before you open the Groove Machine, make sure that the tempo of 
Logic Pro exactly matches that of the selected audio material, or the Groove Machine 
won’t work accurately. You can, however, set the tempo and length directly in the 
Groove Machine, using the Corresponds with Tempo and To Bar Length parameters.

To open the Groove Machine, do one of the following:
m Choose Factory > Groove Machine in the Sample Editor (or use the corresponding key 

command). 
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m Click the Groove Machine tab if another Digital Factory processor is visible. 

Swing
This parameter is used to set the swing factor. At 50% there is no change—you will 
generally achieve the best results with values around 55% to 65%.

Based on Period
You can determine whether the audio material should be edited (quantized) on the 
basis of eighth note, or sixteenth note swing.

Down Beat Level and Off Beat Level
You use this parameter to determine whether the down beats (or off beats) in the 
audio material should be raised or lowered. Positive values increase the level, negative 
values reduce the level. Bear in mind that raising the level of normalized audio material 
can cause distortions (particularly on the down beats, which are usually louder).

Corresponds with Tempo
If you change this value, you will set the project tempo at the current playhead 
position.

To Bar Length
Use this parameter to define the length of the selected audio material in musical values 
(bars, beats, divisions, and ticks).

Using the Audio Energizer
The purpose of the Audio Energizer is to increase the perceived volume of audio 
material, while altering the sound as little as possible, and without causing clipping. 
Digital distortion (which would be the inevitable result of simply increasing the level) is 
avoided by using this algorithm.
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You could compare the effect to an analog tape which has been saturated with a high 
recording level. The distortion factor and effect on the audio material is much lower 
than that of analog tape saturation, however.

Here’s an example of the effect. If a normalized audio file (audio data which is already 
at the maximum dynamic range) is processed with the Audio Energizer, and played 
back through an audio channel:  the channel meter will show a higher level, indicating 
increased average energy in the signal, but the peak level display will not change, as 
the maximum signal level has not been altered.

Note:  If the material contains anomalies such as noise, these will also be increased, and 
can become audible. If necessary, you can process the energized audio file with the 
Silencer (use a low setting), or make use of the Denoiser effect plug-in.

To open the Audio Energizer, do one of the following:
m Choose Factory > Audio Energizer in the Sample Editor (or use the corresponding key 

command). 

m Click the Audio Energizer tab if another Digital Factory processor is visible.

Factor 
Set the amount of average level boost. A value of 0% means no alteration, while higher 
values produce an increase in energy. The setting you make here will depend on the 
audio material, situation, and personal taste.
Â Begin by trying values in the 40 to 100% range. 
Â Values below 10% will have little effect.
Â Values over 100% can lead to undesirable alterations in the sound, depending on the 

material. 
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Â Values over 200% are not recommended with normalized files, because they will 
have detrimental effects on the sound and its dynamics. They can also greatly 
increase the required computation time. On non-normalized audio data, however, 
even high values can be effective because the overall level is initially increased to its 
maximum, without affecting the dynamic range.

Attack and Decay
These parameters control the steepness of the algorithm’s filter. Try values of 2 to 4 
times the default, if the result sounds too digital or raw. This can happen if smaller 
elements among the main events in the signal are boosted. As an example, the reverb 
portion of a sound can become louder.

Using the Silencer
The Silencer consists of two component functions which can be used separately, or in 
conjunction:
Â Noise Reduction lowers the level of any noise in the signal, such as tape noise. 
Â Spike Reduction tries to identify and reduce signals such as pops or clicks.

You will probably use Noise Reduction more often than Spike Reduction.

To open the Silencer, do one of the following:
m Choose Factory > Silencer from the Sample Edit or menu (or use the corresponding key 

command). 

m Click the Silencer tab if another Digital Factory processor is visible.

Noise Reduction
The purpose of Noise Reduction is to reduce the noise components of the signal, and 
also affect the main signal, particularly the high frequency elements.
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The process is single ended, meaning it affects material which is already recorded, and 
there is no need to decode the signal during playback. This means that even noise 
present in the original signal can be processed.

To use noise reduction:
1 Turn the Spike Reduction function off, by moving the Sensitivity slider to the extreme 

right. 

This ensures that only the Noise Reduction function is used. 

2 Drag the Strength slider to the desired position. 

Â Off means no edit.
Â Min is the smallest possible edit. Values closer to Min have a small effect.
Â Max results in the maximum possible reduction of the noise component. 

The “correct” value depends on the quality of the material, and your own personal 
taste. Good quality material should be edited using Min or values close to it. You will 
probably only notice minor changes in the sound. Bad (noisy) quality material should 
be processed at higher values, or even Max. If the setting is too high, the treble 
component of the signal will be reduced.

3 Click the Process button to execute the function.

Note:  The Silencer function is optimized for normalized data. Low level material should 
be normalized before processing.

Spike Reduction
The aim of Spike Reduction is to identify and reduce signals such as pops, clicks, or 
digital spikes, in order to reconstruct a hypothetical original signal.

To use spike reduction:
1 Turn the Noise Reduction function off, by moving the Strength slider to the extreme 

right. 

This ensures that only the Spike Reduction function is active. 

2 Drag the Sensitivity slider to the desired position. This parameter determines the 
threshold level used for the recognition of spikes (loud bits) in the audio file.

Â When set to High (sensitivity), relatively small signal spikes are identified. 
Â When set to Auto, the threshold is controlled automatically. Useful on most 

material.
Â Use Low to identify most signal peaks as spikes.

3 Drag the Method slider to determine how spikes are processed. 

Â Gentle is the weakest algorithm, and only slightly smooths the original signal.
Â Aggressive is the strongest, and has a very noticeable impact on the audio. 
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Â The Re-build setting completely replaces the (often unusable) original signal with 
an artificially generated estimate of the original signal, at the identified points. This 
synthesized signal is created by analyzing the audio material surrounding these 
points.

All of these algorithms filter the original signal at the identified spike points.

4 Click the Process button to execute the function.

Experiment with the parameters. If the Sensitivity slider is set to High (or close to it), 
there’s a danger that very sharp transients in the main signal will be identified as spikes. 
Depending on the audio material, it’s sometimes impossible for the Silencer to 
distinguish between signals you want to keep, and signals you want to eliminate. This 
is particularly the case if the decision between spike or main signal is merely a matter 
of taste—with some click-like bass drum sounds, for example. The attack phase of 
these sounds can have similar characteristics to static on vinyl records.

∏ Tip:  Don’t forget that pops and clicks can also be manually removed with the Pencil 
tool, if the Silencer doesn’t produce satisfactory results.

Converting Audio to MIDI:  Using Audio to Score
This function transforms a monophonic audio recording into musical notation, by 
creating a MIDI region that corresponds to the recorded melody. This allows you to play 
a MIDI sound module in unison with an audio recording or—transposed—as a second 
voice. 

Note:  This function is best-suited to producing melody notes from a clearly sung non-
legato vocal line. It works best on unprocessed (no effects) audio.

To open and use the Audio to Score function:
1 Select the destination MIDI or software instrument track in the Arrange window. 

The MIDI region generated by the Audio to Score function will be placed on this track.

2 In the Sample Editor, choose Factory > Audio to Score (or use the corresponding key 
command).
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3 Set the desired parameter values in the Audio to Score tab.

4 Click the Process button.

A Score Editor window, containing the transcription of the audio file, opens 
automatically. 

Setting the Audio to Score Parameters
The following section outlines the parameters you can set in the Audio to Score tab.

Preset
This menu contains various presets for the Audio to Score parameters, which are suited 
to specific types of audio material. You can use these presets as starting points for your 
own processing.

There are also four User presets. Choose any of the User 1–4 presets, and make the 
desired parameter changes. They will be memorized.

Granulation
Use Granulation to determine the time span of louder components in the audio 
material. Logic Pro uses these peak signals (or transients) to discriminate between 
notes that it should—or should not—analyze. The most useful values are usually 
between 50 and 200 milliseconds, depending on the tempo of the audio material.

Attack Range
This tells Logic Pro how long the attack phases of the sounds in the audio material are. 
As examples of how you might use this parameter:  drum and percussion instruments 
have short attack times of less than 20 ms, while string instruments have longer attack 
phases. The best values for most instruments are usually between 5 and 40 ms; with 
most around 20 ms.

Smooth Release
This parameter is specifically designed to process audio material that contains sounds 
with a long release or reverb tail. This makes it easier to convert these sounds into 
notes. The value you choose here should generally be between 0 and 5%, except when 
processing passages that contain sustained notes, distorted guitars, or similar sounds.

Note:  The quality of the Audio to Score results will benefit from non-legato 
performances, so the audio material should contain few, if any, reverb or release tails, if 
you can avoid them.

Velocity Threshold
This parameter sets the threshold level. All signals that fall below this value are ignored. 
In most cases, you should choose a value of 1, except when processing very dense, 
loud material with soft background noises.
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Minimum Quality
You can choose between normal or high quality processing in this pop-up menu. 
Â The Normal setting is more tolerant of audio trigger points that aren’t perfectly in 

tune, but it can generate wrong notes. 
Â When set to High, only audio trigger points of a clearly identifiable pitch will be 

accepted and used. Indistinct trigger points are replaced by notes with a pitch of C3 
and MIDI channel 3. These are labeled as an “undetected mark.”

When analyzing audio material containing clearly identifiable pitches, you will find that 
good results can be obtained from either setting.

Time Correction
This parameter allows you to compensate for any time delays that may occur when 
external samplers or synthesizers are triggered by MIDI notes. These time delays are 
sometimes very noticeable, particularly if the connected device is playing a MIDI region 
(that was generated by the Audio to Score function) alongside the original audio 
material. You should be able to compensate for this effect by using settings between 
–20 ms and 0 ms.

Your parameter settings are stored in the Logic Pro preferences.

A few tips on getting the best results from the Audio to Score function:
Â You will only get good results with clearly identifiable, monophonic audio material. 

Solo voices, strings, and piano can be easily analyzed, as can any recordings with 
distinct pitches.

Â Experiment with different parameter settings for data processing. Be prepared to 
make several attempts, to determine the optimum settings for a particular audio 
recording.

Using the Quantize Engine
This Digital Factory function allows you to use a MIDI region template (within reason), 
to quantize an audio recording. 

This is done by using a dynamic time compression or expansion algorithm. The 
function is similar to the Groove Machine, except that the quantize template can reflect 
values other than just 8th or 16th note swing grooves. Even user-defined MIDI grooves 
can be used!
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To use the Quantize Engine on an audio region:
1 Select the audio region that you want to quantize in the Arrange area.

2 In the Sample Editor, choose Factory > Quantize Engine.

3 Set the desired parameters in the Quantize Engine tab.

4 Click the Process button.

Setting the Quantize Engine Parameters
The parameters available to the Quantize Engine are almost identical to those available 
for the Audio to Score function (see “Converting Audio to MIDI:  Using Audio to Score” 
on page 514). This section only outlines the parameters that differ from the Audio to 
Score function. 

Preset
Choose a preset that best matches the characteristics of the audio material.

Quantize by
Click on this pop-up menu to set the required quantization grid. The same values 
available for MIDI data (including user quantization templates) are found here.

Maximum Range
This is where you set the maximum time (in milliseconds) that an audio peak can 
deviate from a quantization point—in the chosen quantization grid template (Quantize 
by menu). 
Â Small values are suitable for quantizing audio material with a similar groove. 
Â Large values allow you to use a quantization grid that deviates more from the 

original groove of the audio material. This, however, increases the risk of 
misinterpretation. 

Start by experimenting with smaller values for the Maximum Range parameter (as 
small as possible, and as large as necessary).



518 Chapter 21    Editing Audio in the Sample Editor

Audio to MIDI Groove Template
For detailed information on the Audio to MIDI Groove Template function, see “Creating 
an Audio to MIDI Groove Template” on page 462.

Using an External Sample Editor
You can configure Logic Pro to open an audio region or file in an external sample 
editing application. 

To use an external sample editing application:
m Click the Set button below the Logic Pro > Preferences > Audio > Sample Editor > 

External Sample Editor preference. 

A file dialog opens, allowing you to browse for, and select an external sample editing 
program. 

To open a selected audio file in the external sample editor:
m Choose Options > Audio > Open in “name of external sample editor” (or use the 

corresponding key command).

Using AudioSuite Plug-ins
The Sample Editor allows the use of AudioSuite plug-ins. These plug-ins work 
destructively—the result of the editing process is written into the audio file.

Note:  AudioSuite plug-ins can only be used with hardware addressed by the DAE 
(Digidesign Audio Engine). Any properly installed AudioSuite plug-in will be displayed 
in the AudioSuite menu.

AudioSuite > Buffer Size allows you to set the buffer size of the Preview mode. A 
smaller buffer size results in a faster response to plug-in setting changes while 
previewing, but requires more processing power.
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22 Removing Silent Passages From 
Audio Regions

You can use the Strip Silence function to automatically 
remove silent passages from audio regions. 

The basic premise of the Strip Silence process is simple:  all amplitude values below a 
threshold value are interpreted as silence, and removed. New regions are created from 
the remaining passages. 

How You Can Use Strip Silence
Strip Silence is the ideal tool for the following tasks:

Removing Background Noises
The most conventional use for Strip Silence is simulation of the classic noise gate effect. 
When used on long recordings with numerous gaps—such as vocals or instrumental 
solos—you can obtain better results by setting a low threshold value. Background 
noise is removed, without affecting the main signal.
Â For short percussive regions (drum loops), you can simulate time compression/

expansion by simply altering the tempo.
Â You can even quantize the individual segments in an audio recording.

Creating Segments of Spoken Recordings
You can use Strip Silence to divide long spoken passages into several convenient 
segments, like sentences, words, or syllables. For film synchronization or jingles, you 
can move or reposition the speech segments by simply dragging them around in the 
Arrange area.

Tempo changes allow you to simulate a time compression or expansion effect, as the 
syllables automatically move closer together, or further apart.

Creating Segments for Drum Loops
Dividing drum loops into small segments is a good way of perfectly synchronizing 
them. As an example, in audio passages where the bass drum and snare are completely 
separate, you can often use Strip Silence to isolate each individual beat.
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Optimizing Synchronization Over Long Time-Spans
Different computers, different synchronization sources (internal or SMPTE code), 
different tape machines and—in theory—even different samplers or hard disk 
recording systems, will exhibit slight variations in clock speed. Changing just one 
component can lead to a loss of synchronization between recorded audio material and 
MIDI. This is particularly applicable to long audio regions. 

This is another situation where the Strip Silence function can help, by creating several 
shorter audio regions, with more trigger points between the audio and MIDI events.

As an example, you can use this method to roughly split up a whole audio file, and 
then divide the new regions, using different parameters. The new regions can then be 
processed again with the Strip Silence function—and so on.

Optimizing Files and Regions
Automatic region creation from an audio file that contains silent passages, such as a 
single vocal take that runs the length of a project. The unused regions or portions of 
the audio file can be deleted, saving hard disk space, and simplifying (file and) region 
management.

Extracting Audio Files From a Disc
Many sample library discs (CD or DVD) contain thousands of audio recordings stored as 
AIFF or WAV files. Strip Silence can be used to split these into individual regions, which 
can be used directly in the Arrange area. Regions can also be converted into individual 
audio files (samples), which can be used in the EXS24  mkII.
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Using Strip Silence
This section outlines the steps, and parameters, involved in the Strip Silence process.

To remove silent passages from a selected region:
1 Do one of the following:

Â In the Arrange area, choose Audio > Strip Silence (or use the Strip Silence key 
command, default:  Control-X).

Â In the Audio Bin window, choose Options > Strip Silence (or use the Strip Silence key 
command, default:  Control-X).

2 In the Strip Silence window, set the following parameters by using the mouse as a 
slider, direct numerical entry, or clicking on the up and down arrows.

Â Threshold:  Use this to define the amplitude level (shown as a percentage) that a 
passage must exceed, in order to be defined as a region. In terms of the number and 
length of regions created by the process, this is the most important parameter. As a 
general rule:  a higher Threshold value leads to numerous short regions. Low values 
create fewer large regions.

Â Minimum Time to accept as Silence:  Use this to define the length of time that a 
section must be below the Threshold value, before it is considered a gap. Very small 
values tend to increase the number of regions, because even short dips in amplitude 
are interpreted as silence. Higher values prevent sections of audio from being 
interrupted by fluctuating amplitudes. 

Â Pre Attack Time:  You can add a defined amount of pre-roll to the beginning of all 
regions created by the Strip Silence process, if desired. High threshold values prevent 
any amplitudes with slower attack times from being chopped. This function is useful 
for non-percussive material such as vocals, wind instruments, strings, and so on. 
Overlaps are permitted—the pre-delayed start point of a region can extend back to 
the end of the previous region—but only if the Threshold value is not exceeded. The 
Pre Attack Time doesn’t affect the anchor position, which means the absolute 
position of the audio data (in the project) is retained.
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Â Post Release Time:  Use this parameter to define an automatic release time for the end 
points of all regions. You can avoid abrupt cut offs to amplitudes that fade out 
gradually (particularly if you have set a high Threshold value). As examples:  Cymbals, 
open hi hats, snares with long reverb tails, vocals, and so on. The Post Release Time 
parameter does not allow overlaps. This means that region end points cannot extend 
beyond the start point of the following region. Adjusting the Post Release Time 
doesn’t affect the anchor position, which means the absolute position of the audio 
data (in the project) is retained.

Â Search Zero Crossings:  Turn on this checkbox to automatically snap the region start 
and end points to the nearest waveform zero crossings.

Note:  Depending on the audio material, all parameters can have an effect on the 
number and division of regions. You may need to experiment a little to obtain the 
desired results. Every time you alter a parameter, the graphic display of the region 
changes accordingly.

3 Click OK. 

If you selected a region that is used in the Arrange area, a dialog asks if you want to 
replace the original region in the Arrange area with the new regions.

4 Do one of the following:

Â If you want to replace the region in the Arrange area with regions created by the 
Strip Silence function, click Replace or press Return. This ensures that the relative 
timing of the individual audio segments remains unaltered.

Â If you only want the new regions to appear in the Audio Bin, click No. You can then 
add them to the Arrange window, using any of the methods available.

Automatic Anchor Creation
When you create new regions with Strip Silence, a separate anchor—based on the 
division value set in the Transport (1/16, 1/8, and so on)—is automatically created for 
each new region. 

These rounded anchor values are shown in the help tag when you move any of the 
newly created regions, rather than an absolute anchor point that is placed at a 
particular sample position. 

If you require this sort of precision, open the regions in the Sample Editor, and adjust 
the anchor point manually.
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23 Adjusting the Tempo of 
Audio Regions

The length of imported audio regions and the project tempo 
are directly linked. If you change the tempo at a particular 
project position, the length of regions at, and after, this 
position will change.

You won’t hear a difference in the playback speed of the imported audio, but all MIDI 
or software instrument regions will be out-of-sync with all audio regions. Audio regions 
that are lengthened (by increasing the tempo) may overlap with other regions on the 
same track, resulting in the earlier region being played in full, at the expense of the 
front end of the following region. All audio region loop lengths (set with the Inspector 
Loop parameter) will change, resulting in irregular loops, and strange polyrhythms 
between tracks.

Fortunately, Logic Pro has a few tricks up its sleeve that can circumvent these problems.

Automatic Tempo Matching
The following audio files will automatically match the project tempo, and will follow 
any tempo changes made in the global Tempo track (see “Using the Follow Tempo 
Function” on page 526).
Â Audio recordings made in Logic Pro (7.0 and above)
Â Apple Loop files
Â Audio bounces made in Logic Pro (7.0 and above)
Â Audio files exported from Logic Pro (7.0 and above)

Imported ReCycle files can also follow the project tempo (see “Adding ReCycle Files to 
Your Project” on page 276). 

All other imported audio requires adjustment of either the region or the project tempo. 
You also have the option of converting imported audio to Apple Loops.
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To convert a selected audio region into an Apple Loop, please use either of the 
following options:

m Choose Region > Add to Apple Loops Library in the Arrange area. 

This method sets transients that are based on the project’s tempo information. For 
more details, see “Creating Apple Loops in Logic Pro” on page 616. 

m Choose Audio > Open in Apple Loops Utility in the Arrange area.

This functionality allows you to set the transients manually—independent of the 
project tempo. More information can be found in “Creating Apple Loops in the Apple 
Loops Utility” on page 618). 

Setting the Project Tempo to Match an Audio Region
You can adjust your project’s tempo to match the tempo of an audio region. The length 
of the region remains constant, but the sequencer tempo is varied automatically.

Imagine you have imported a drum loop that is exactly one bar long, but you don’t 
know the drum loop’s tempo. When added to the Arrange area, and the project tempo 
does not match that of the drum loop, you’ll see that the drum loop is shorter or longer 
than one bar. You can use the Adjust Tempo using Region Length command to set the 
project tempo to match that of the audio loop 

To match the project tempo to an audio region:
1 Select the audio region that you want to match the project tempo to, in the Arrange 

area.

2 Create a cycle in the Bar ruler.

This should closely match the length of the region—usually to the nearest bar.

3 Choose Options > Tempo > Adjust Tempo using Region Length and Locators (or use 
the corresponding key command, default:  Command-T). 
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A dialog will ask if you want to change the tempo of the entire project, or create a 
tempo change for the section of the project occupied by the selected region. 

4 Do one of the following:

Â Click Globally to adjust the tempo of the complete project to the audio region.
Â Click Create to create a tempo change that spans the length of the audio region.

The project tempo is recalculated to conform with the audio length (and locators).

Time Stretching Regions
Logic Pro allows you to change the length of audio regions (without changing their 
pitch) directly in the Arrange area—using menu or key commands.

When applying these functions to a region in the Arrange area, a new file—consisting 
of the resulting material—will be created, leaving the original intact. Both new and old 
files are accessible in the Audio Bin.

Logic Pro offers different time stretching and compression algorithms in the Arrange 
area’s Audio > Time Machine Algorithm menu. The different algorithms are best suited 
for particular types of musical material. For more information, see “Using the Time and 
Pitch Machine” on page 505.

Note:  You can also time stretch selected audio regions directly in the Sample Editor, 
using the Time and Pitch Machine. 

To adjust the region length to match the locator positions:
1 Set the left and right locator positions.

2 Choose Audio > Adjust Region Length to Locators to stretch or compress the selected 
audio region to fit between the locators. 

The region start point is not changed by this function—so it doesn’t matter if the 
locators are not directly above the region.
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To adjust the region length to the nearest bar:
m Choose Audio > Adjust Region Length to Nearest Bar.

This adjusts the length of the selected region to the closest whole bar.

This function is ideal for fitting previously trimmed drum loops into projects where 
there is a small tempo discrepancy between loop and project.

Using the Follow Tempo Function
Audio files recorded in Logic Pro can follow the project tempo—inclusive of tempo 
changes—set in the global tracks.

Note:  These audio files can also follow the first key signature set in the global tracks. 
For more information, see “Working With Time and Key Signatures” on page 723.

As an example:  If you record a bass solo at 100 bpm, you can change the project 
tempo to 120 bpm and the bass solo will automatically be played back at the new 
tempo.

The function works with all audio files that were recorded in, or bounced/exported 
from, Logic Pro.

The function only works in the parent project (the project the audio files were created 
in). If you drag a file recorded in a given project to another project with the Finder, the 
file can not follow the project tempo.

Bounced or exported files can only follow the project tempo if the “Add resulting files 
to Audio Bin” option was enabled in the Export or Bounce window—prior to the 
bounce or export.

Files copied between two projects retain the ability to follow the project tempo. 

The project’s tempo information is used to tag the beats in the recording. The function 
works best if your audio files match the project tempo as precisely as possible. The 
longer your audio files are, the more RAM is required for this functionality to work 
properly. 
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To make recorded audio files follow the project tempo (and first key signature):
m Select the audio region in the Arrange area, and turn on the Follow Tempo option in 

the Region Parameter box in the Inspector. 

The Follow Tempo option is synchronized for all regions that make use of the same 
audio file.

All audio files that follow the project tempo (and first key signature) are indicated by 
the following symbols in Logic Pro:

Note:  The Follow Tempo option does not create an Apple Loop! Remember:  Apple 
Loops follow chord changes—should you record a solo over an arrangement consisting 
of Apple Loops with transposition changes over time, you might want to enable Follow 
Tempo for your solo, but you won’t be happy with the double transpositions that will 
occur …
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24 Managing Audio Files

Most audio file management takes place in the Audio Bin. 
Several individual file management functions are found in 
the Sample Editor and Arrange window.

This chapter covers all audio file management facilities available in Logic Pro. These 
options help you to keep track of your audio files, and make tasks such as file copying, 
moving, renaming, and backing up both easy and efficient.

Details on audio region handling is found in Chapter 11, “Adding Pre-Recorded Media,” 
and Chapter 13, “Creating Your Arrangement.”

Sorting, Grouping, and Renaming Files in the Audio Bin
The Audio Bin lists all audio files in your project, along with information about file 
sampling rate, bit depth, format (mono/stereo), and size. It is the ideal place to sort, 
rename, copy, or move your audio files.

Note:  Detailed information on the methods used to add audio files to the Audio Bin 
(and your project) are found in “Adding and Removing Audio Files” on page 270.
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Sorting Audio Files
Information on every currently loaded audio file is shown in the Info column of the 
Audio Bin. You can switch this display on or off by choosing View > Show File Info.

To sort audio files:
m Choose any of the following View > “Files sorted by” criteria to reorganize the listing of 

audio files:

Â None:  The audio files are listed in the order that they were loaded or recorded.
Â Name:  The audio files are listed in alphabetical order.
Â Size:  The audio files are listed by size, with larger files at the top of the list.
Â Drive:  The audio files are sorted by storage medium (the hard disk, removable drive, 

or partition they are stored on).
Â Bit Depth:  The audio files are listed by Bit depth, in decreasing order.
Â File type:  The audio files are listed by file type (AIFF, WAV, SDII, MP3, and so on).

∏ Tip:  You can quickly sort all audio files by name by clicking the Name column header.
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Grouping Files in the Audio Bin
You can group audio files together, making handling of large numbers of files easier 
and faster. In the image, you will see a Guitars and Vocals group, with several files in 
each. 

This separation into categories simplifies handling, particularly if all files are similarly 
named. As an example, audio imported from another application may be named 
“audio01”, “audio02”, “audio03”, and so on, regardless of whether a vocal, guitar, or drum 
part. When creating a large arrangement, grouping files into categories can be a life-
saver.

Guitars group

Vocals group
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To group audio files:
1 Select the files you want to group in the Audio Bin. 

2 Choose View > Create Group (or use the Create Group key command).

3 Type the desired group name in the Group Name field (labeled “Enter name for new 
group”), then press Return.

To group audio files by their location, attributes, or selection status:
1 Select the files you want to group in the Audio Bin.

2 Do one of the following:

Â Choose View > Group Files by > Location to create groups that are alphabetically 
sorted by the names of the parent folders of selected files. These folder names are 
automatically used as group names.

Â Choose View > Group Files by > File Attributes to create groups based on the 
attributes of selected files (file type, stereo/mono, Bit depth). Group names are 
displayed as a summary of the file attributes (“16 bit AIFF Stereo”, for example).

Â Choose View > Group Files by > Selection In Arrange to create groups based on 
regions selected in the Arrange area. Group names are based on the first of the 
selected regions.
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Note:  If existing groups have been created, a dialog will ask if you want to add all files 
to one of these groupings, thereby deleting the existing groups, or if you would like to 
only add files that are not yet group members. Click the appropriate button.

To open or close one or more groups:
m Click on the disclosure triangle to the left of a group name to open or close it.

m Option-click on the disclosure triangle to the left of any group name to open or close 
all groups. 

To select all files in a group:
m Option-click on a group name to select all files in the group. 

To delete a group:
m Select the desired group, then choose View > Delete selected Groups (or press 

Backspace). 

The audio files of deleted groups reappear in the upper level of the Audio Bin list. 

Renaming Audio Files
To rename audio files in the Audio Bin, just double-click the file name in the list. A text 
input box will appear, allowing you to type in a new name.

Important:  Before renaming audio files, you should check if the audio file that you 
want to rename is used by another project. If it is, do not rename the file, or it won’t be 
found or played by other projects that use the file.

Logic Pro helps you in these situations:
Â Logic Pro alters the name of an audio file in all currently opened projects that use 

this file.
Â If the file is half of a split stereo pair, Logic Pro automatically assigns the new name to 

the other half of the stereo pair.
Â Logic Pro also renames any backup files on the same drive.

If you rename a stereo file, Logic Pro automatically assigns the new name to up to five 
files (both the mono files used in Logic Pro, their backups, and the stereo file). In this 
situation, it’s a good idea to store all files in the same location.

Note:  You can freely rename regions whenever you like, but you should note that 
regions named after their parent audio files automatically adopt the new name of 
renamed audio files. This does not occur when regions have been given a new name.
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Moving Audio Files
The Audio Bin’s Audio File > Move File(s) command (default key command assignment:  
Control-M) enables you to move selected audio files to another location on your 
system. 

If the source drive or partition is the same as the target drive or partition, the files are 
simply moved to the other folder. This is a very quick and convenient way of organizing 
the drive and the project.

This function is useful when you want to move all audio files used in a project to a new 
folder, for example. 

To move all used audio files to a new folder:
1 Choose Edit > Select Used from the Edit menu. 

This selects all audio files (in the Audio Bin) that are being used in the Arrange area.

2 Choose Audio File > Move File(s) in the Audio Bin menu. 

An alert will indicate the number of files to be moved. 

3 Click the Move button. 

4 In the ensuing file selector box, select the desired folder (or create a new one), then 
click Save. All audio files used in the Arrange area are saved in the selected folder.

It may be useful to choose the Audio File > Show Files in Finder command before 
moving any audio files. This command opens a Finder window that displays the path 
and location of the selected files. The folder name or notes or other files in the folder 
may provide clues as to whether or not it’s safe to move the files. If you’re not sure, it’s 
better to use the Copy/Convert command (see below).

∏ Tip:  Logic Pro updates the path information for all open projects that use a given audio 
file. This makes projects easier to manage when moving audio files. Following the 
movement of files to the new location, save each open project to update all audio file 
storage references.

Warning:  Be very careful when using this function as files are removed from their 
original location. Other projects may use the same audio files. This can lead to you 
being prompted to search for the files that were moved when opening other projects 
(see “Finding and Replacing Orphaned Audio Files” on page 539).
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Copying or Converting Audio Files
You can create copies of audio files in a different hard disk (or other storage medium) 
location. The source files remain in their original storage location, unlike the Move 
File(s) function discussed above.

To copy or convert audio files in the Audio Bin:
1 Select the desired file or files.

Note:  You can not use this command to convert compressed multi-channel files (AAC, 
ALAC, MP3). 

2 Choose Audio File > Copy/Convert File(s) in the Audio Bin. 

3 Choose the desired settings in the Save A Copy As dialog:

You can set the desired sample rate, bit depth, file format, stereo conversion, and dither 
type for the destination file. 

4 Browse to, and choose the target folder for the new audio files. You may also create a 
new folder, by clicking the New Folder button. 

5 If you’re only copying one file, you can enter a name for the new audio file. When 
simultaneously copying several audio files, existing file names are used for the copies 
derived from them. The Hide Extension checkbox hides or shows file extensions (wav, 
aif, and so on) in the Save As field.

6 Click the Change file reference in Bin option to replace the audio file used in the 
project with the copied file. 

If unchecked, both the copy and original audio file are shown in the Audio Bin (the 
original is still used for any regions).

7 Click the Save button. 
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Note:  If a file of the same name exists in the target location, Logic Pro asks whether or 
not you want to replace it. Click Replace to do so, or type in a different name, and click 
Save.

To copy or convert audio files in the Sample Editor:
1 Choose Audio File > Save A Copy As.

2 Choose the desired settings in the Save A Copy As dialog.

You can set the desired sample rate, bit depth, file format, stereo conversion, and dither 
type for the destination file. The dialog also features an “Add resulting files to Audio 
Bin” option, allowing you to add the file to the Audio Bin, following the save. 

3 Browse to the location where you want to store the audio file, then type a name for the 
audio file in the name field.

4 Click the Save button.

Deleting Audio Files
Audio files are displayed and organized by Mac OS X in exactly the same way as all 
other Macintosh files. You can therefore delete or copy them in the Finder. This has the 
following disadvantages, however:
Â You may not know if an audio file is needed in a project, when using the Finder for 

deletions.
Â Deleted audio files can not be found when you load a project. This results in 

orphaned files (and regions) in the Audio Bin and Arrange area regions which refer to 
the missing audio file (see “Finding and Replacing Orphaned Audio Files” on 
page 539). 

Important:  For these reasons, you should only perform audio file deletions in the Audio 
Bin. 

To delete audio files in the Audio Bin:
1 Select the audio files that you want to delete. 

2 Choose Audio File > Delete File(s) or (or use the corresponding key command, 
default:  Control-Backspace).

An alert message, informing you of the number of audio files about to be deleted, will 
appear.

3 Click Cancel to abandon the deletion process, or click Delete to move the audio files 
into the Trash.
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Optimizing Audio Files
Beyond deleting unused audio files, Logic Pro also allows you to delete unused 
portions of audio files. This usually frees up a lot of wasted space on the hard disk.

To delete sections of audio files that are no longer used in the project:
1 Select the audio files that you want to optimize in the Audio Bin.

The Edit > Select Used menu should be your first port of call. Optimize Files can be 
used on any number of audio files.

2 Choose Audio File > Optimize Files (or use the corresponding key command, 
default:  Control-O) in the Audio Bin. 

The following happens during the Optimize Files function:
Â Logic Pro determines which (file) segments are not contained in any of the regions 

used in the Arrange area. 
Â These segments are deleted, and the remaining portions of the audio file (those used 

by regions) are retained. These file segments are aligned side-by-side in the file.

Note:  For safety reasons, the Optimize Files function uses a pre and post roll area of 
one second of audio data before and after each (used) region.

Â The regions in the Audio Bin are redefined.
Â The project is automatically saved.

Saving Regions as Individual Audio Files
You can create one (or more) independent audio files from selected regions in the 
Audio Bin and Arrange area.

To convert selected regions into independent audio files:
1 Do one of the following:

Â Choose Audio File > Save Region(s) As in the Audio Bin. 
Â Choose Audio > Convert Regions to New Audio Files in the Arrange area (or use the 

corresponding key command, default:  Option-Command-F).
Â Choose File > Export Region as Audio File in the main menu bar (or use the 

corresponding key command).

2 Choose the desired settings in the ensuing dialog boxes.

3 Browse to, and choose the target folder for the new audio files. You may also create a 
new folder, by clicking the New Folder button. 

Warning:  As this process physically deletes data from the storage medium, it cannot 
be undone.
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4 If you’re only saving one region, you can enter a name for the new audio file. The Hide 
Extension checkbox hides or shows file extensions (wav, aif, and so on) in the Save As 
field.

5 Click the Save button.

Note:  If you want to simultaneously save several regions as audio files, you should 
name the regions before using the Save Region(s) as command, as existing region 
names are applied to the audio files derived from them.

Exporting Tracks as Audio Files
It is also possible to export one or more tracks (all audio regions on tracks) to a new 
audio file, or several audio files—one for each Arrange track.

To export all audio regions on a track to a new audio file:
1 Click on the desired track name.

2 Choose File > Export > Track as Audio File from the main menu bar (or use the 
corresponding key command, default:  Command-E).

3 Provide a name and destination, and make other choices in the Save As dialog, then 
click Save.

To export all tracks to several new audio files:
1 Choose File > Export > All Tracks as Audio Files (or use the corresponding key 

command). 

2 Make your choices in the Save As dialog, and click Save. 

Exported audio files are named after the source tracks, so if track 1 is called “Drums,” 
track 2 “Bass,” track 3 “Guitar,” the resulting files will be named accordingly.
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Dealing With SDII Files
Logic Pro allows you to access the regions in SoundDesigner II files. (The SDII data 
format lets you store region definitions).

You can import the regions of SDII files into the Audio Bin. This is useful if you want to 
play regions from a long recording made in Pro Tools. 

To import SDII regions:
1 Select an audio file in the Audio Bin.

2 Choose Audio File > Import SDII Regions (or use the corresponding key command, 
default:  Control-I).

Logic Pro also allows you to export one or more selected regions (in an audio file) from 
the Audio Bin into an SDII file. 

To export all regions from an audio file to an SDII region:
1 Select the desired audio files in the Audio Bin. 

2 Choose Audio File > Export SDII Regions (or use the corresponding key command, 
default:  Control-E).

Finding and Replacing Orphaned Audio Files
Sometimes, Logic Pro can’t find a file which was previously used in the project. This 
could be due to one of the following:
Â You have not connected the relevant hard disk, or you have renamed the volume.
Â You have stored the files in a different volume, or moved them to another volume.
Â You have renamed the files in the Finder, or renamed them in the Audio Bin of 

another project.
Â You have deleted the files.

In these situations, Logic Pro opens the following dialog.

You can respond in any of the following ways:
Â Search:  The current volume is searched for filenames. If the search is unsuccessful, 

Logic Pro asks you if you want to search other volumes for these files. This enables 
you to assemble projects, even if you have copied or moved the relevant files onto 
other media.
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Â Skip:  Use this function if you know that this audio file no longer exists, or was 
renamed. This button changes to Skip All if further audio files aren’t found.

Â Manually:  You can manually define where to search for the file. A file selector, 
containing the names of the audio files being searched for, appears onscreen.

If more than one file with a matching name is found, you can select the correct file in a 
dialog box.

If Logic Pro can not find one or more audio files—when skipping them during the 
search process, for example—the regions are shown as blank gray areas. 

To assign a replacement file later on:
1 Do one of the following:

Â Double-click the relevant region in the Arrange area.
Â Choose Audio File > Update File Information in the Audio Bin.

2 Click Locate in the dialog, and a file selector box opens, allowing you to load the 
desired audio file. 
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25 Mixing

Once you’re happy with the project arrangement, the 
Mixer is used to refine the overall sound, levels, and spatial 
positioning of your tracks.

This chapter covers the use of the Mixer, and also touches on automation facilities. The 
latter forms an integral part of Logic Pro’s mixing facilities, with detailed information 
available in Chapter 26, “Working With Automation,” on page 581.

To open the Mixer area of the Arrange window:
m Click the Mixer tab at the bottom of the Arrange window (or use the Toggle Mixer key 

command). 

∏ Tip:  As a shortcut, you can open the Mixer area by double-clicking the icon of any track 
in the Arrange track list. The corresponding channel strip (of the clicked track) will be 
selected in the Mixer.
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To open the Mixer as a separate window:
m Choose Window > Mixer (or use the matching key command, default:  Command-2). 

The Mixer displays channel strips that correspond with audio and instrument (software 
or MIDI) tracks shown in the Arrange area, plus the master channel, auxiliary, and 
output channels. Additional channel strip types, such as busses and inputs, can also be 
shown, but their inclusion is primarily for compatibility with projects created in earlier 
Logic Pro versions.

Â Audio channel strips control audio tracks. Data on audio tracks (audio regions) is 
routed to audio channels.

Â Instrument channels control instrument tracks (software instrument plug-ins are 
inserted into the Instrument slot of instrument channels). Data on instrument tracks 
(MIDI regions) is routed to instrument channels.

Â External MIDI channels control “external MIDI” tracks. Data on these tracks (also MIDI 
regions) is routed to a MIDI output port and channel, for control of MIDI sound 
modules and keyboards. Either the entire instrument or MIDI sub-channels can be 
represented and controlled.

Â Auxiliary channels act as “send/returns” or output destinations for instrument and 
audio channel strips, or other auxiliary channels.

Â Output channels represent the physical outputs of your audio interface, and act as a 
destination for audio, instrument, and auxiliary channels.

Instrument channel stripsAudio channel strips

Aux channel strips

Output channel strip

Master channel strip MIDI channel strips



Chapter 25    Mixing 543

Â The master channel strip is a global level control for all output channels. You can 
view it as the main volume control for Logic Pro.

Important:  Mixer channels are generated automatically when you create new audio, 
instrument, or external MIDI tracks in the Arrange window, provided that File > Project 
Settings > Audio > Automatic Management of Channel Strip Objects is turned on (it is 
turned on by default, and should be left on in most cases).

If several Arrange tracks address the same instrument channel, the instrument is 
represented by a single channel in the Mixer (this behavior can be overridden by the 
Same Instrument Tracks setting in the local View menu).

Basic Mixing Steps
Generally speaking, mixing takes place in the following order (although there are 
always exceptions to this):
Â Set the relative levels and pan positions for each channel strip, to control the volume 

relationships between your project’s parts (regions on tracks), and where they are 
positioned in the stereo or surround field.

Â Sculpt the sound of each part (if needed) with equalization, which enables you to 
precisely alter the tone or color of each channel. You will probably need to revisit 
step 1, as EQ-ing generally has an impact on levels, and possibly on phase 
relationships.

Â Once the basic sound and levels are as you like them, the mix can be polished with 
effect processes, such as the addition of reverb or chorus to your musical parts. Once 
again, you may need to revisit step 1.

Â You may find that some parts will benefit from real time changes to levels, effects, or 
instrument settings. This is best achieved with track automation.

Â The last phase—which is not a mixing task, per se—is to render or “bounce” your 
project to one or more files. This aspect is covered in Chapter 27, “Bouncing Your 
Project,” on page 601.

In your normal workflow, you will access the Mixer or Arrange channel strips to insert 
software instruments and effects, and set relative levels and pan positions—both 
before and after recording musical parts. This type of Mixer or Arrange channel strip 
usage during the creative phase of your project helps you to build an arrangement and 
rough mix, where basic levels and sounds are set.

Once all parts have been recorded, you would typically move onto the mixing phase of 
your project. This is when you focus your efforts on refining the sound of each musical 
element, to create a unified mix. This generally follows the order outlined above, but 
your approach, or the project, may differ. 
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You will regularly find that the settings chosen for instruments and effects can be 
improved by changing a few parameters, to “tighten up” parts, or provide a looser feel, 
or perhaps to radically change the tonal color of the chorus, for example. You may 
often completely swap one instrument sound for another, replace effects 
configurations for tracks, or use tracks without effects (“dry”). You may also set up 
complex routings to one or more auxiliary channels, or perhaps set up “mastering” 
processors on output channels (see “Channel Strip Types” on page 566).

∏ Tip:  Make use of the save facility often during mixing, to provide backups, should you 
lose your way. Backups also provide a great comparison point, and are a good guide for 
whether or not your mix is heading in the right direction.

In many situations, you will find mix automation of use. Logic Pro provides a flexible 
automation system that enables you to mute, bypass, solo, and alter all channel strip 
parameters, including those of any inserted effects and software instruments. Use of 
automation can provide motion to parts of the mix, and is very useful for “evening out” 
overly dynamic performances, or making less dynamic performances more lively. 
Automation can be viewed as someone “riding the faders” on a hardware mixing 
console (and all effects units and synthesizers in the studio), albeit with many more 
hands.

Automation should be considered an integral part of the mixing process, but if your 
mix doesn’t need it, you can certainly “set and forget” your Mixer settings. 

As you can see, the Logic Pro Mixer can be used in a traditional way, but you will 
probably find yourself accessing it (or the Arrange channel strips) throughout all 
project phases. 
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Channel Strip Elements
The controls displayed on a channel strip vary with the channel strip type.

The table below indicates the elements that are available in each channel strip type 
(MIDI channel strips are not listed, as they work differently. See “MIDI Channel Strips” 
on page 570). Details on individual channel strip types, and their general roles in the 
Mixer, can be found in “Channel Strip Types” on page 566.

(Input) Format button

Instrument channel stripsAudio channel strips

Aux channel strips

Output channel strip

Master channel strip MIDI channel strips

Channel Strip Settings
menu

Channel EQ

Output slot
Group menu

Pan/Balance control
Level meter

Clip detector

Level fader

Solo button
Mute button

Insert slots

Sends

Bounce button

Record enable 
button

Input Monitoring button

Automation 
Mode menu

Input slot
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Two additional channel types not shown in the table—input and bus (see “Channel 
Strip Objects” on page 935)—are primarily retained for compatibility with projects 
created in earlier Logic Pro versions.

Setting Channel Strip Levels
You use the Level fader of a channel strip to set its playback or monitoring volume. The 
segmented level meters of the channel strip display the level in real time. The clip 
detector above the level meter shows you the available headroom of a track in decibels 
(dB).

To set the playback, or monitoring level of a channel strip:
m Drag the Level fader of the desired channel up or down 

The maximum boost is +6 dB. You can reset the Level fader to 0 dB (90) by Option-
clicking on it.

If the Independent Monitoring Level (for Record Enabled Channel Strips) preference of 
the Logic Pro > Preferences > Audio > Devices > Core Audio tab is enabled, an 
independent monitoring level is available when an audio channel is record enabled. 
For further information, see “Setting the Monitoring Level” on page 358.

Element Audio Instrument Aux Output Master

Channel Strip Settings menu X X X X X

Channel EQ X X X X

Insert slots X X X X

Sends X X X

Input slot X X X

Output slot X X X

Group menu X X X X X

Automation Mode menu X X X X X

Pan/Balance control X X X X

Level meter X X X X

Clip detector X X X X

Level fader X X X X X

Mute button X X X X X

Solo button X X X

(Input) Format button X X X

Input Monitoring button X

Record Enable button X

Bounce button X
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Quickly Switching Between Two Levels
You can use the following key commands to switch the level of all channel strips of a 
specific type between two different level values. Each channel may be set to any value 
for both toggle positions, allowing you to quickly switch between two basic mixes.
Â Mute/Unmute Audio Channel Strips
Â Mute/Unmute Input Channel Strips
Â Mute/Unmute Auxiliary Channel Strips
Â Mute/Unmute Output Channel Strips

Understanding the Channel Strip Meters
All channel strips feature segmented level meters that display the playback or input 
monitoring level. When you arm an audio track, in preparation for recording, the 
associated Mixer channel meter displays the input (incoming audio) level.

The colors of the level meter segments provide an at-a-glance overview of individual 
channel monitoring levels. Signals in the amber and yellow zones are safe, and will not 
clip the channel output. Signal peaks that trigger the red segments of the meters are 
considered “hot” levels, but the occasional peak is nothing to worry about, unless the 
clip detector is continually or regularly lit (see section below).

Peak values are “held” on the level meter display for a few seconds, making them easier 
to read. The most recent maximum (peak) level is always reliably displayed.
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The level meters can be switched between a Sectional dB-linear scale, and an 
Exponential scale. Exponential provides higher display resolution in the upper range. 
Sectional dB-linear provides the best possible display resolution across the entire level 
range. Both metering systems display a range from –60 to 0 dBfs.

To change the scale:
1 Open the Display preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Display (or use the corresponding key command).
Â Click the Preference Toolbar button, then choose Display from the menu. 

2 Click the General tab, then choose the desired value in the Scale menu.

Understanding the Clip Detector
The Clip Detector above the level meter shows you the available headroom of a track in 
dB.

When a signal clips, the Clip Detector turns red; the value shown indicates the amount 
that the peak level (the loudest bit) of the signal needs to be reduced, in order to 
prevent clipping. 

The peak value is shown once the entire signal has been played, and provides a guide 
that should be used to set the Level fader of the channel.

Exponential scale Sectional dB-linear scale

Clip Detector
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Clipping occurs when too much (too loud a) signal is fed through a channel strip, 
thereby exceeding the limit of what can be accurately reproduced, resulting in a 
distorted sound known as clipping. 

Up to + 6 dB will be shown. If a track clips now and then, it doesn’t really matter—as 
long as the master channel (output destination for the channel) doesn’t clip. Clicking 
on any clip detector will reset all clip detectors. The Clear Overload Flag in Audio 
Channel Display key command has the same effect.

To avoid clipping:
1 Look at the Clip Detector value of a channel strip that is clipping (lit red). 

As an example, 1.5 dB is shown on the Clip Detector when the Level fader is set to a 
value of 0.0 dB.

2 Grab the Level fader, and reduce it to a value of –1.5 or so.

∏ Tip:  You may find that a Level fader value of –1.2 sounds “best” in the context of the 
overall mix, and only clips once (by 0.3 dB) during playback. As mentioned, this is 
nothing to worry about, and you should use your ears, rather than your eyes as a guide.

Setting the Pan, Balance, or Surround Position
Mono channels feature a Pan control, which determines the position of a signal in the 
stereo image. Stereo channels, on the other hand, display Balance controls. The Balance 
control differs from the Pan control in that the former controls the relative levels of two 
signals (Left and Right) at their outputs. The latter merely apportions one signal 
between two outputs.

To adjust the Pan or Balance control:
m Grab the control and drag up and down, or to the left or right.

Option-click on the Pan or Balance control to reset it to the centered (0) position.

When a channel strip output is set to Surround, the Pan or Balance control is replaced 
by a Surround Panner. Full details on using surround channels, effects, and the 
surround panner are found in Chapter 35, “Working With Surround,” on page 807.
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Soloing and Muting Channels
Soloing or muting channels enables you to hear musical parts in isolation, or in 
conjunction with other selected parts. This simplifies particular tasks, such as setting 
precise equalization parameters.

Soloing Channels
All channel strips feature a Solo button (denoted by an S). 

Click it to mute all other channel strips that access the same hardware device driver.

The solo button turns yellow, and the M on the Mute buttons of all muted (non-soloed) 
channels will flash. 

Note:  MIDI channels are not muted.

You can solo several channels by clicking on their respective Solo buttons.

Option-clicking a previously unsoloed channel releases other active Solo buttons, 
allowing the selected channel to be heard in isolation.

Option-clicking any activated Solo button disables the solo status of all channel strips.

Using Solo Safe
If you want to hear the signal of a soloed channel with any send effects, the effect 
return channels (the auxiliary channels used for the sends) obviously can’t be muted, as 
they constitute part of the signal path. The same applies when you solo an effect return 
signal (an aux channel). All channels fed into the effect (aux channel) are muted, but 
their effect sends remain open, ensuring that the effect continues to receive a signal.

Logic Pro intelligently scans the entire signal path, and leaves the effect return 
channels open.

This automatic mute-suppression only applies to the internal effect returns. If you are 
using external effect units via aux channels, the scan will keep the effect master sends 
open. Logic Pro cannot, however, know which of the channels you are using as effect 
returns for external effect units. You need to manually switch these channels to solo 
safe—which prevents them from being muted when you solo another channel.

Better yet, make use of the I/O plug-in when you want to use external effects units. This 
allows you to use external effects just as you would use internal ones. For more 
information, see “Working With External Audio Effects” on page 251.
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To make a channel strip solo safe:
m Control-click an inactive Solo button.

The channel strip is not muted when you solo another channel. Solo safe status is 
indicated by a red slash on the solo button.

A second Control-click defeats the solo safe status.

Muting Channels
You can mute any channel strip by clicking the Mute button (marked with an M). 
Pressing the button a second time restores the previous level.

You can mute several channels by clicking on their respective Mute buttons.

Option-clicking a channel Mute button in the Mixer will activate the corresponding 
Track Mute button in the Arrange. A second click will deactivate the Track Mute button. 

Note:  When the Audio > General > Track Mute/Solo preference is set to Fast, clicking a 
channel Mute button will always activate the corresponding Track Mute button in the 
Arrange.

Why Track and Channel Muting is Independent
The separation of track and associated channel mute functionality is included because 
multiple tracks can be routed to the same channel strip. 

As an example, an EXS24 mkII drum kit inserted in an instrument channel may have 
several Arrange tracks routed to it; each playing a different sound (kick, snare, cymbals, 
and so on). 

The ability to view “same instrument track” channels in the Mixer enables you to 
independently mute each instrument in the “kit.”
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Adding Effects:  Using Inserts
Insert slots are shown, and used, in the same way on all channel strip types (except the 
master channel strip). If you have enough computer processing capacity, you can insert 
up to 15 effect plug-ins per channel strip. An extra blank Insert is created, as soon as all 
of the currently displayed Insert slots are used, up to the maximum allowed.

Software instrument plug-ins are inserted much like effect plug-ins, but they can only 
be inserted into the Instrument slot of instrument channels. For full details on adding 
instrument and effect plug-ins, see “Inserting, Moving, and Removing Plug-ins” on 
page 212.

Working With Sends
The Mixer provides auxiliary channel strips, which are used as effect send/returns. Each 
individual channel strip can be routed via one or more send/returns (auxiliary channel 
strips), in addition to being routed to a particular output. This allows each channel strip 
to share the effects processor connected to the mixer’s send/returns (inserted in the 
auxiliary channel strip, in the Logic Pro Mixer). Full details about working with send 
effects can be found in “Send Effects” on page 233. 

Working With Channel Strip Settings
The Channel Strip Settings menu allows you to load and save the entire routing 
configuration of a single channel strip, including all loaded plug-ins and settings. This 
feature is covered in “Loading and Removing Entire Channel Strip Configurations” on 
page 219.
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Monitoring With Effect Plug-ins
The Software Monitoring function allows you to hear incoming audio through effects 
plug-ins inserted into an armed audio channel. Audio inputs must be assigned on these 
record-enabled tracks for software monitoring functionality. You can also use the Input 
Monitoring buttons to monitor audio tracks that are not armed. Simply enable the 
Input Monitoring button on a channel strip. This works when Logic Pro is stopped or 
playing.

Software monitoring is especially handy in Logic Pro setups without an external mixer, 
and is useful during an overdub session, for example. For further information, see 
“Using Software Monitoring” on page 356.

Arming Channel Strips
You will generally “arm” audio tracks in the Arrange window by clicking the Record 
Enable button of an audio track. This button corresponds to the Record Enable button 
of audio channel strips in the Mixer. 

For more information on recording, see Chapter 14, “Recording in Logic Pro,” on 
page 351.

Changing the Channel Input Format
The Format button determines the input format (mono, stereo, or surround) of a 
channel.

For further information, see “Setting the Channel Input Format” on page 210.

Record Enable button appearance Status/comments

Flashing red Armed

Constantly illuminated (solid red) Recording



554 Chapter 25    Mixing

Setting the Automation Mode
You can set the automation mode of a channel strip in the Automation menu. For full 
details on all automation modes, and use of the automation system, please see 
Chapter 26, “Working With Automation,” on page 581. 

Handling Mixer Inputs and Outputs
The Input slot of audio channel strips allows you to choose the physical inputs of your 
audio hardware. This input (or input pair) supplies an audio signal to the track when 
recording.

If Input monitoring is switched on, the signal of this audio input will be routed to the 
output chosen in the Output menu, when the track is record enabled. 

Note:  Do not confuse the Input slot with the input format of channel strips. They are 
different things entirely.

Output Routing and Sub Groups (Using Aux Channels)
The slot directly below the Input slot determines where the signal of the channel strip 
will be sent. The number of available outputs is determined by the audio hardware in 
use.

You can select between output channels, Binaural (see “Using the Binaural Panner” on 
page 555), and aux channels, which can function as mixer subgroups. If the channel 
strip is mono, the aux will also be mono, but can be set to stereo. If both aux and 
channel strip are stereo, the entire (Mixer) signal flow will be in stereo. If surround is 
chosen, and the channel strip is routed to an aux (using a Send), the aux channel is 
automatically set to surround.

Hold Option while selecting the inputs or outputs of a single channel to change all 
selected channel strips to the same input/output. Please note that inputs are only 
changed on (selected) channel strips of the same status:  mono, stereo, or surround. 
This facility allows you to easily select a common input source for all (selected, stereo) 
audio tracks, for example.

∏ Tip:  Double-clicking on the Output slot of any audio channel will jump to the assigned 
Output channel fader, accelerating navigation in the Mixer. 
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Using the Binaural Panner
The Binaural Panner is a psychoacoustic processor that is able to simulate arbitrary 
sound source positions (including up and down information) by means of a standard 
stereo signal. This emulates human hearing, which is capable of interpreting positional 
information (where a sound is coming from), despite the fact that only two “receivers” 
(your ears) are used to capture the sound.

The signal that results from Binaural Panner use is best suited for headphone playback. 
You can, however, process the Binaural Panner output with the Binaural Post Processing 
plug-in. This enables you to play back the binaural pan effect through loudspeakers.

To use the Binaural Panner:
m Choose Binaural from the Output slot menu (on mono or stereo channels).

The Binaural Pan control replaces the Pan/Balance control on the channel strip, and the 
Binaural Panner window opens. This window behaves much like a plug-in window, and 
can be closed by clicking the top-left icon, and linked with the chain icon. Once closed, 
you can reopen the Binaural Panner window by double-clicking on the Binaural Pan 
control.

Note:  The Binaural Panner is only available in mono to stereo and stereo to stereo 
format.
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The Binaural Panner Window
The panning effect is controlled by positioning the panning pucks on the panning 
plane at the top of the window, and adjusting a few additional parameters.

To position signals on the panning plane:
1 Drag the left or right puck to make the stereo image wider or narrower. 

The two are linked. The panning pucks also work on a second axis—up and down—
relative to the direction puck.

2 Drag the third puck to determine the forward and backwards direction (or in front and 
behind the listening position, if you prefer). 

As you adjust this puck, the panning pucks will move accordingly.

Keep an eye on the Angle, Elevation, Distance, and Spread fields at the top of the 
window. These update whenever adjustments are made to puck positions. You can also 
directly interact with the Spread field, by dragging on the numerical value. The puck 
positions will update to reflect changes.

The 3D image represents the resulting position of the audio signal. This is purely a 
visual aid, that cannot be interacted with directly.

The buttons and fields below the panning plane work as follows:
Â Mode buttons:  Determine the virtual shape of the panning plane. 

Â If set to Planar, the panning results are shown on a flat circular plane. Additional 
controls are available when in this mode (see below). 

Â In Spherical mode, the results are placed on a virtual sphere. If it helps, imagine the 
sphere as a virtual head. When the “direction puck” is placed in the top half of the 
circular plane, the sound is in front of the listener. As the direction puck is moved 
towards the lower half of the plane, the sound passes up, and over your head, and 
ends up behind you.
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Â Size:  Determines the size of the plane or sphere (expressed as the radius of the 
circular plane).

Â Doppler button:  Click to enable or disable the Doppler effect. The Doppler effect—
put very simply—is a change in the pitch of a signal perceived by a person who is 
moving, relative to the source of the signal. 

Using the Extended Parameters
Â Global: Diffuse-Field:  Turn this parameter on (default) to ensure a neutral sound for 

headphone playback, utilizing diffuse-field compensation. When using multiple 
Binaural Panners (on several channels), you should turn this option off, and route the 
output of the Binaural Panners to an aux channel—in which you should insert the 
Binaural Post-Processing plug-in. The Binaural Post Processing plug-in allows you to 
apply diffuse-field compensation to all Binaural Panner outputs at once, saving CPU 
power. 

Â The other three parameters are only available in Planar mode. You can use these to 
control the vertical offset and tilt of the circular plane—watch the 3D image when 
changing them to get a clear idea of their functions. 
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The Binaural Post-Processing Plug-in
The Binaural Post-Processing plug-in is available in aux and output channels. This plug-
in allows you to apply various compensation modes on a stereo bus or output (through 
which several, or all, binaural signals are routed). This saves CPU power, and makes it 
easy to switch between compensation modes:

The Compensation menu offers the following choices:
Â Headphone FF - optimized for front direction:  Setting for headphone playback, utilizing 

free-field compensation. In this compensation mode, sound sources placed in front 
of the listening position will have neutral sound characteristics.

Â Headphone HB - optimized for horizontal directions:  Setting for headphone playback. 
Optimized to deliver the most neutral sound for sources placed on, or close to, the 
horizontal plane.

Â Headphone DF - averaged over all directions:  Setting for headphone playback, utilizing 
diffuse-field compensation. In this compensation mode, the sound will (on average) 
be most neutral for arbitrarily placed, or moved, sources.

Â Speaker CTC - Cross Talk Cancellation:  Setting for speaker playback, which allows you 
to play back binaurally panned signals via a stereo loudspeaker setup. Good spatial 
reproduction is restricted to a limited range of listening positions (on the 
symmetrical plane) between the speakers. If you choose the Speaker CTC setting 
there is an additional parameter:  CTC Speaker Angle. To achieve the best binaural 
effect, enter the angle that your stereo speakers are turned towards the center 
(listening position).

Note:  When using the Binaural Post-Processing plug-in, the integrated conditioning of 
individual Binaural Panners should be deactivated. This is done via the menu in the 
extended parameters section of the Binaural Panner.



Chapter 25    Mixing 559

Binaural Hearing—Binaural Recording—Binaural Panning
An important part of mixing audio signals is the placement of individual sound 
sources at different spatial positions. Most common recording and mixing techniques 
simply send a given signal (at different levels) to the available loudspeakers—two for 
stereo, or more for quadraphonic or surround setups—in order to create a virtual 
sound stage.

This approach is somewhat flawed, however, as human beings are able to locate 
sound sources at different positions with just two ears. Virtually all spatial information 
for all sounds is included in the two signals arriving at the two ear-drums. From these 
signals, human beings can determine characteristics such as; inter-aural time and 
level differences and—based on the listening experience—information about the 
spatial origin of the sounds being heard. Are they coming from in front, behind, to 
the left or right or above or below? This ability to perceive where a sound originated 
from is referred to as binaural hearing.

In theory, the spatial positioning of any sonic experience can be reproduced during 
playback, so no special techniques need to be employed during recording. There is, 
however, one drawback to this approach:  every person has differently shaped ears, 
and different body and head proportions. All of these influence the way sound 
signals arrive at the ear-drum—not to mention aspects such as hearing loss, 
experiences of the sounds being heard, and so on. Given these physical differences, 
each person listening to the same sound source (while standing/sitting at the same 
position) will hear slightly different binaural signals.

Therefore, perfect reproduction would only be possible if you could make a recording 
with tiny microphones placed inside your auditory canals. As this is impractical, 
binaural hearing has been emulated in sound laboratories by using mannequin heads 
with built-in microphones. This approach has led to average person binaural 
recordings, that are more or less compatible with the way most people hear. 

Playback of binaural recordings is best suited to headphones, ideally combined with 
signal conditioning (processing) that ensures the signals are accurately reproduced. 
Given a specialized listening environment, it is also possible to reproduce these 
signals with loudspeakers, utilizing a process known as cross-talk cancellation.

As you are unlikely to have the technology required to make binaural recordings, 
your best chance of simulating binaural signals is by processing the sound signal on 
playback. This is known as the HRTF (Head-Related Transfer Function), which 
approximates the change that a signal undergoes on its way from the source to the 
ear-drum.
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Surround
Logic Pro allows mixdowns in several surround formats, even if your audio hardware 
only offers two outputs. Obviously, it would be difficult to mix or record in surround 
with this limitation, so you’re probably best served not selecting this option if you’re 
using stereo hardware. 

All track, instrument, and aux channels can be individually set to different surround 
formats. 

To set a channel output to surround:
m Click-hold the Output slot of the desired channel strip, and choose Surround in the 

menu.

The Pan control is replaced by a Surround Panner. The loudspeakers are represented by 
colored dots, and the pan position is indicated by a white dot that can be grabbed and 
moved. 

Full details on use of the Surround facilities can be found in Chapter 35, “Working With 
Surround,” on page 807.

Adjusting Elements of Multiple Channel Strips
You can select multiple channel strips in the Mixer. Once selected, all channels behave 
as a temporary group, allowing you to quickly adjust a number of settings on all 
selected faders by performing an operation on one of the grouped faders. Logic Pro 
also offers the group functionality for channel strips (see “Working With Groups” on 
page 562), but this method is often much quicker than setting up groups for many 
operations.

To select multiple channel strips, do one of the following:
m Shift-click the desired channel strips. 

m Click a channel background and drag over the desired channel strips (drag horizontally 
across multiple channel strips over the word Inserts, or I/O text, for example). 

These selection methods work on all channel types (instrument, audio, aux, and so on).

To deselect multiple channels, do one of the following:
m Click on any unselected channel or on the Mixer window background. 

m Select a previously unselected track in the Arrange window.

As with individual controls on a single channel, Option-clicking a fader or knob resets 
the control to a neutral value. As examples:  Option-clicking a Level fader sets it (and all 
grouped faders) to 0 dB, Option-clicking Send knob 3 sets it (and the third Send knob 
of all grouped channels) to 0 dB (90).
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To adjust the Level slider on all selected channels:
m Drag the Level slider of any selected channel. 

All level changes are relative and logarithmic. To explain:  Movements are dB-
proportional, with the mix ratio of the selected channels remaining constant. Put 
another way, if channel 1 is set to 90 dB and channel 2 is set to 60 dB, reducing either 
Level fader will retain the relative distance between the channels:

Â At half the original level, channel 1 will be at 45 dB and channel 2 at 30 dB.
Â At a quarter of the original level, channel 1 will be at 22.5 dB and channel 2 at 15 dB, 

until both channels simultaneously arrive at 0 dB.
Â When either channel is returned to its original value, the 60/90 dB relationship will 

be restored.

To adjust the Pan or Balance knob on all selected channels:
m Drag the Pan or Balance knob on any selected channel. 

All Pan or Balance knobs change accordingly (changes are relative).

To adjust the mute or solo status of all selected channels:
m Click the Mute or Solo button on any selected channel. 

The buttons of all selected channels will mirror the status of the clicked button.

To adjust the Record Enable button of all selected channels:
m Click the Record Enable button on any selected channel. 

The Record Enable buttons of all selected channels (typically, audio channels) will 
switch to the new mode. You should note that only channels with different input 
sources can be record enabled simultaneously.

To adjust the Send level of all selected channels:
m Drag the Send level knob on any selected channel. 

All Send level knobs of the corresponding Send slots change accordingly (relative 
changes).

To adjust the send destination of all selected channels:
m Click on any of the selected channel’s unused Send slots, and make your choice from 

the list of Bus destinations (aux channels). 

The corresponding Send slots of all selected channels will be routed to the chosen 
destination.

To adjust the inserts of all selected channels:
m Click on any of the selected channel’s unused Insert slots, and make your choice from 

the list. 

The selected effect will be inserted into the corresponding Insert slot on all selected 
channels.
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To adjust the input and output routing of all selected channels:
m Click on any selected channel’s Input or Output slot, and make your choice from the 

list. 

All selected channels will be set to the chosen input or output. 

To adjust the automation mode and group setting of all selected channels:
m Click any selected channel’s Automation mode or Group menu, and make your 

selection from the list. All selected channels will be switched to the chosen setting.

Important:  You can only perform the multi-channel (insert) Send and Insert options if 
no active Send or Insert is in the same slot on any selected channel. In other words, 
ensure that all selected channels have an unused Send 3, or Insert slot 4, for example, 
before using this facility.

Adjusting Channel Strips in Record or Playback Mode
You can prevent the track selection from changing, when making an adjustment to a 
channel. This can be done while Logic Pro is in recording or playback mode, allowing 
you to adjust a particular Mixer channel, even if a different track is being recorded.

To prevent the track selection from changing when recording:
m Make sure the Mixer’s Options > Change Track in Record Mode setting is disabled. 

To prevent the track selection from changing when playing back your project:
m Make sure the Mixer’s Options > Change Track in Playback Mode setting is disabled. 

Working With Groups
The Group slot allows you to assign a channel strip to a group.

A group combines multiple channel strips, linking some of their properties—their 
volume faders and Mute buttons, for example. If multiple audio tracks (with individual 
choir voices) are assigned to one group, changing the volume of one choir track 
changes the volume of all choir tracks. Individual level relationships—at the time the 
channels were assigned to the group—are retained.

The Group Settings allows you to define the behavior of each group. As an example, 
you could define a group that links the selection of channels in the Arrange window, 
thereby linking all edit operations you perform on grouped tracks. 
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You can create up to 32 groups. Each channel can be a member of multiple groups.

To assign a channel to a group:
1 Click the Group slot to open the Group menu.

2 Choose one of the 32 groups. 

When you choose an inactive group number, the Group Settings window will open 
automatically (see next section). Individual channels can belong to more than one 
group. 

To add a channel to an additional group:
m Press Shift while choosing a group in the Group menu.

The Group slot displays all groups a channel is assigned to. 

To remove a channel from a group:
1 Click the Group slot to open the Group menu.

2 Choose No Group. 

To alter the settings of an active group number:
1 Click the Group slot to open the Group menu.

2 Choose Open Group Settings. 

To quickly assign the most recent group setting to another channel strip:
m Press Option and click the Group display of the desired channel strip. 

The most recently accessed Group setting—including overlapping groups—will be 
applied to the current channel, without opening the Group menu.
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Defining Group Settings
You can define the behavior of each group in the Group Settings window.

Â Enable checkbox:  Click to completely enable or disable a group. Disabled groups 
appear in black. 

Â Name field:  Click to name the selected group. As examples:  Strings, Drum Sub-Mix, 
and so on.

Â Region Selection (Edit) checkbox:  Selecting a region on one group member track 
selects the same horizontal range of all group member tracks.

Â Track Zoom checkbox:  Zooming an individual group member track will zoom all 
member tracks.

Â Hide Track checkbox:  Hiding an individual group track will hide all group member 
tracks.

Â Record Enable checkbox:  Clicking the Track Record Enable button of an individual 
track in a group will switch on/off the Track Record Enable button of all group 
member tracks.

Important:  Multiple track channel strips can only be simultaneously record enabled 
if they use different inputs. 

Â Automation Mode checkbox:  Changing the automation mode of an individual track in 
a group will change the automation mode for all group members.

Â Channel Strip Color:  Changing the color of one group member channel will assign 
this color to all group member channels. Using color makes it easier to identify the 
string or brass sections, for example.

Â Volume checkbox:  Changing the volume fader of one group member channel will 
change the volume of all member channels—while maintaining the level 
relationships between them. Use a volume fader with a high initial setting, if 
possible, as this will allow you a greater range of movement, and therefore, control.

Â Mute checkbox:  The mute status of all member channels is synchronized, with all 
group members being muted or unmuted if one group channel is muted/unmuted.
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Â Pan checkbox:  The panorama setting of all member channels is linked. As per 
volume, their initial relationships are maintained.

Â Send 1 to 8 checkboxes:  You can link the Send knobs individually for Send slots 1 to 8. 
Different initial levels will be maintained.

A Note on Group Automation
Any group member can act as a master for mix automation of an automated 
parameter, such as volume. When an automation parameter value is written, the 
corresponding value of all other group members is also written, depending on their 
automation mode (Touch or Latch, for example). The data is written individually for 
each channel. As a result, you can disable the group later, without affecting the 
automation of any group member—and can obviously edit or change channels 
individually, once removed from the group.

Disabling Groups Temporarily (Group Clutch)
It is possible to temporarily disable all group parameter links—in order to change the 
volume of an individual channel, for example. 

To temporarily disable all groups:
m Choose Options > Group Clutch (or use the Toggle Group Clutch key command, default 

assignment:  Command-G). 

As long as the group clutch is active, all group displays will change color—from yellow 
(normal) to a light gray (clutch active, all groups temporarily disabled). 
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Channel Strip Types
Channel strips are the building blocks of the Mixer. In the following section, you will 
learn about the differences between channel strip types, and how you can use them. 

Audio Channel
The audio channel strip is used for playback and recording of the audio signals (in 
regions) on Arrange window audio tracks. You can control all sonic elements of audio 
tracks with the audio channel strip.

Instrument Channel
The instrument channel strip allows you to use, and control, software instruments in 
Logic Pro. Currently, the included Logic Pro and GarageBand software instruments and 
Audio Unit compatible instruments, including the QuickTime synthesizer (DLS Music 
Device) are supported. 

Logic Pro allows the simultaneous use of up to 255 discrete instrument channel strips, 
dependent on available CPU resources and system RAM. 

The Instrument slot of the instrument channel (just above the Output slot) serves as 
the insert point for software instruments. Simply click on the Instrument slot and 
choose the name of the instrument plug-in from the menu. 

Instrument channel stripsAudio channel strips

Aux channel strips

Output channel strip

Master channel strip MIDI channel strips
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After inserting a software instrument plug-in, the instrument channel can be accessed, 
or driven, if you prefer, by MIDI regions on one or more Arrange window tracks. These 
tracks are routed to the instrument channel. 

Software instruments inserted into an instrument channel can, of course, also be 
played directly from a MIDI keyboard, provided that a corresponding Arrange track 
(one that is routed to the instrument channel) is selected.

The instrument channel type can also receive MIDI data from other sources, such as 
Environment objects. This is useful for creating sound layers of hardware MIDI 
instruments and software instruments, arpeggiating the instrument, and more. 

Accessing Multiple Software Instrument Outputs
Logic Pro supports the multiple outputs of the EXS24 mkII, Ultrabeat, and all Audio Unit 
instruments. One or more multi output options may be displayed in addition to the 
mono and stereo versions shown in the Instrument Plug-in menu. 

The first two outputs of a multi output instrument are always played back as a stereo 
pair by the instrument channel that the plug-in is inserted into. Additional outputs (3 
and 4, 5 and 6, and so on) are accessed via auxiliary channels. Please see “Accessing 
Multiple Instrument Outputs” on page 214 for more information on how to set up multi 
output instruments.

Auxiliary Channel
Auxiliary (or aux) channels can be used as send returns, sub groups, and as additional 
destination channels for multi-channel (multi output:  software) instrument channels. 
When you assign aux channels (as sends, for example), more are automatically made 
available. To explain:  When four aux channels are in use, a fifth is automatically created 
when assigned. 

Creating Auxiliary Channels
Typically, you will create aux channels as you need them. There are three ways to do 
this:
Â An aux channel is created automatically when a send assignment is made from a 

channel strip. 
Â When a multi output instrument, such as the EXS24 mkII is inserted into an 

instrument channel, several aux channel assignments are made “behind-the-scenes.” 
It is up to you to create the required number of aux channel strips. This is done by 
clicking on the plus button (“+”) at the bottom of the instrument channel. Each time 
you click it, a new aux channel strip is created (and automatically assigned to 
particular instrument outputs).
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Â The third way to create aux channels is by clicking on the plus button at the left-
hand side of the Mixer window, or by choosing Options > Create New Auxiliary 
Channel Strips. Both methods launch the dialog shown below.

This is very similar to the New Tracks dialog shown in the Arrange window. 

Simply type in the desired number, set the required format, input and output routings, 
and click the Create button. The Input and Output Ascending checkboxes, when active, 
result in multiple, sequentially assigned or routed auxiliary channels being created. To 
explain, if you type 6 into the Number field, and assign Bus 2 in the Input menu 
(Ascending checkbox active) 6 aux channels—assigned to busses 2 through to 7—will 
be created. The same applies for the Output pop-up menu.

Note:  The number of physical inputs and outputs shown in these menus is limited by 
your audio hardware. 

Manually Choosing the Input Source for Aux Channels
The input source of an aux channel can be selected with the Input menu. Possible 
input sources are:
Â Buses—when the aux channel is used as a send return (see below).
Â Inputs (dependent on the available physical inputs of the audio interface in use).
Â Software instrument outputs provided by instrument plug-ins (Logic or Audio 

Unit):  These additional outputs are only available to multi output instruments, 
inserted into an instrument channel (see “Accessing Multiple Instrument Outputs” on 
page 214).

Using Aux Channels as Send Returns
The Send slot on audio and instrument channels is used to route part (or all) of the 
signal to an auxiliary channel. Effects such as reverb and delay are generally inserted 
into aux channels when used as effect send/returns. 

Aux channels can also be set as the input source for other aux channels. When used in 
this way, the sends of these aux channels can be returned on additional aux channels, 
allowing the construction of complex effect routings. (In most cases, you won’t want to 
monitor the signal twice, so set the respective aux channel output assignments to “No 
Output”).

Note:  When an aux channel is used as a send/return destination from another channel 
strip, the Input menu will display Bus (number). 
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Using Aux Channels for External Audio Processing
You can route audio signals to external devices via the individual outputs of the audio 
hardware. This allows you to change their level and pan settings, and apply plug-ins, if 
you wish. This is achieved through use of the I/O plug-in.

The advantage of inserting the I/O plug-in into an aux channel, is that any effects units 
(or hardware mixing consoles) integrated into the Logic Pro Mixer, become available to 
all track and instrument channels via sends.

Using Aux Channels as Subgroups
Aux channels can be used as subgroup channels, which control the level of several 
audio channels at once. As an example, all drum tracks or all different vocal takes could 
be routed to a stereo aux channel, allowing control of their overall level—while still 
retaining the relative differences between the individual channels.

Simply choose the desired aux channel as the output destination for the channels you 
want to include in the subgroup.

As auxes can also be routed to other auxes, several effect returns (sends) can be routed 
to the same subgroup, in order to adjust the level of all effects in the mix at once. This 
approach makes it much easier to handle the mixdown (particularly if automated).

To record the signal of a particular subgroup (for later use as a stereo track in the 
arrangement), route the “subgroup” aux to an unused output channel, and use the 
Bounce function (see “Bouncing Your Project” on page 601).

Output Channels
Output channels represent the physical audio outputs of your audio interface. These 
channels are used to adjust the overall level and stereo balance (or pan position, if a 
mono output channel) of all track or instrument channels routed into them. The 
number of available output channels is determined by the audio interface in use.

The Insert slots of output channels allow signal processing during the mastering 
process (bouncing), as well as during normal playback. Typical “mastering” tools are the 
compressors, de-essers, and equalizers. Due to technical reasons, you can only use 
plug-ins that don’t require mono to stereo conversions. In other words, you can use 
stereo to stereo plug-ins on stereo output channels, and mono to mono plug-ins on 
mono output channels. Surround (or Multi Mono) versions of plug-ins can be used on 
mono or stereo output channels. Mono to multi-mono variants can be used on mono 
output channels. Stereo to surround, stereo to multi-mono, and true surround versions 
of plug-ins are accessible in stereo output channel strips.

Output channels also provide the Bounce button. For more information, see “Bouncing 
Your Project” on page 601.
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Master Channel
The master channel strip changes the gain of all output channels. It acts as a separate 
attenuator stage; the level relationships between output channels are not affected. This 
is very helpful as a proportional output volume control and is particularly useful for 
surround mode in Logic Pro (fades of the complete surround mix).

In some cases, you might want to prevent individual output channels from being 
controlled by the master channel—outputs used as effect sends to external hardware 
devices, for example. Simply switch such output channels to Solo Safe mode by 
Control-clicking their Solo button, and they won’t be affected by the master channel.

Moving the master channel fader does not affect the position of output channel faders, 
but rather, the signal levels directly. These level changes are reflected in the level 
meters of each output channel. 

∏ Tip:  The Transport bar also offers a master fader. This is a remote control for the master 
channel strip shown in the Mixer, which allows quick and easy control of the overall 
level from the Arrange window.

MIDI Channel Strips
This section deals with the MIDI channel strips of the Mixer, as well as those of the GM 
Mixer (see “GM Mixer” on page 892).

The MIDI channel strips work as remote controls for the mixing parameters of your 
MIDI-controlled sound modules and synthesizers (volume and pan, for example). 

Important:  The controls send MIDI Control Change messages. They do not control any 
audio signal flow within Logic Pro. 
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Switch on all settings in the View > MIDI Track Components menu of the Mixer, so you 
can see all of the parameters described below. The basic channel Level, Pan, and Mute 
controls are always shown on MIDI channel strips.

Â Instrument Name:  Displays the name of the instrument object assigned to the MIDI 
channel strip. 

Â Program button:  Allows you to select a sound by name—click it to open a menu that 
contains all GM sound names. Each channel has its own menu.

Â Bank fields:  If your sound source “understands” bank select events, you can choose 
the bank number for each of the MIDI channels. The lower value sends controller 
value 32, and the upper value sends controller value 0; this is for MIDI instruments 
that have 127 x 127 banks. You can use several different bank select formats (see 
“Defining Custom Bank Selects” on page 887), if your device does not use the 
standard controller 0/32 messages. Please remember that not all synthesizers 
support bank select events.

Â Assign 1 to 5:  Choose to display up to five knobs that you can freely assign to any 
MIDI controller number. 

Adjusting the Level of a Channel
The Level fader controls the output level of a MIDI channel. Adjusting it sends 
controller #7 via your MIDI interface.

To adjust the output level of a channel:
m Drag the Level fader up or down. 

 Program
Bank

Instrument Name

Assign 1 to 5
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Muting a Channel
The Mute button switches the volume of the channel between zero and the current 
Level fader position. In practice, this means that if the button is “down,” the channel is 
muted. If you switch the Mute button off, the current Level fader position (and value) is 
used.

To mute or unmute a channel:
m Click the Mute button of the desired channel.

Controlling the Pan Position
The Pan knob allows you to directly control the pan position of the sound. Controller 10 
is sent via your MIDI interface.

To control the pan position of a sound:
1 Click-hold the Pan knob.

2 Move the mouse up and down or left and right. The knob moves according to the 
mouse position.

Resetting Controls
Clicking a fader or knob while holding Option resets the value to a neutral value. The 
neutral value is zero for all controls except the following:
Â Volume (Controller 7):  Default value is 100.
Â Panorama (Controller 10), Balance (Controller 8), Resonance (Controller 71), Release 

Time (Controller 72), Attack Time (Controller 73), and Cutoff Frequency (Controller 
74):  All have a default value of 64 (center position).

Sending Other Controllers
You can send any controller data (different MIDI Continuous Controllers)—to control 
different parameters of your sound source—with each of the Assign 1 to 5 knobs.

To assign a controller to one of the knobs:
1 Click on the label above the knob.

2 Choose the desired controller from the menu.

Here’s a description of the pre-defined General MIDI functions. Not all MIDI instruments 
will understand these controllers:
Â Reverb (Controller Number 91):  Controls the reverb level. The further right you turn 

the knob, the louder the effect signal becomes.
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Â Chorus Depth (Controller Number 93):  This knob controls the depth of the chorus 
effect. The further right you turn the knob, the stronger the effect becomes.

Â LPF Frequency (Controller Number 74):  This knob controls the overtone content of the 
sound. Higher values make the sound brighter.

Saving and Restoring MIDI Channel Strip Settings in the Mixer
The Mixer MIDI channel settings directly affect the Track Parameter box shown in the 
Arrange window Inspector. The current settings of all channel strips are saved with the 
project. 

If the active settings of your sound module are not maintained when you switch it off 
(some devices reset to “default” values), any Logic Pro Mixer settings that affect the unit 
will be lost. Thankfully, Logic Pro Mixer settings are automatically restored (and 
transmitted to all MIDI devices) when you reload the project. 

On occasion, however, this may not happen, due to MIDI communication issues with 
some devices. In this situation, you can manually resend the Logic Pro MIDI channel 
strip settings by choosing the Options > Send All MIDI Mixer Data command. 

Extended GM, GS, and XG Functions
In addition to the GM Standard, there are extended standards created by Roland (GS) 
and Yamaha (XG).

GS and XG mode allow you to select different effect programs, and to control the level 
of the reverb and chorus effects.

To display the GS or XG effects:
m Enable the Add GS/XG Effects setting in the Mixer’s View menu.

The GS/XG configuration control is displayed on the right of the Mixer window, 
allowing you to select different effect programs.

To configure GS or XG effects:
1 Choose the desired standard in the first menu. 

Depending on your selection, the controllers for the extended effects will appear.

2 Select the desired reverb or chorus effect from the second menu. 

3 Program the desired reverb or delay time (Time parameter).
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Moving to Particular Types of Channel Strips
You can choose one of the commands in the View > Scroll To menu to scroll the Mixer 
display to the selected channel type, when multiple channel types are visible. This 
feature is handy when your Mixer view contains dozens, or hundreds, of channel strips.

To move to specific channel strip types:
m Choose the desired command in the View > Scroll To menu (Outputs, for example). 

The entire Mixer view will be shifted, to display the first of these channels at the right of 
the visible Mixer window area. 

Customizing the Mixer
The Mixer offers the Single, Arrange, and All Mixer views. You can use these views to 
restrict the display to channel strips that you actually need for the current mixing task. 
This accelerates and simplifies your workflow.

The Arrange and All views can work in conjunction with the channel strip filter buttons, 
allowing you to filter specific channel strip types. You can use different filter button 
settings for both views. 

Working With Single, Arrange, and All View
You can use the Single, Arrange, and All buttons in the Mixer’s menu bar (or the Cycle 
Through Mixer Modes (Single, Arrange, All) key command) to switch the Mixer between 
the views:

Â Single View:  The Mixer display is limited to the selected arrange track, and its signal 
flow—if the Add Signal Flow Channel Strips setting in the View menu is active.

Â Arrange view:  Displays all channel strips that correspond to tracks (audio, instrument, 
or external MIDI) used in the Arrange window—and their signal flow. The signal flow 
channel strips are only displayed if the View menu’s Add Signal Flow Channel Strip 
setting is active.

Â All View:  The Mixer displays all MIDI instruments and all audio channel strips that 
exist in your project. 

Single View
In Single view, the Mixer display is limited to the selected arrange track, and its signal 
flow:
Â If applicable:  The channel strip which is used as the input source of an audio track.

View buttons
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Â The channel strip which is assigned to the selected arrange track.
Â If the selected track is a multi output software instrument:  The aux channel strips 

assigned to the individual output signals are displayed beside the software 
instrument channel strip. These are placed in ascending order, in accordance with the 
output number.

Â All aux channel strips, with other auxes as their input source—used as send 
destinations for the arrange track’s channel strip (or other displayed auxes)—are 
shown in an ascending order that follows aux channel numbering.

Â All output channel strips used as a routing destination for the Arrange track’s 
channel strip (or other displayed channel strip) are shown in an ascending order that 
follows output numbering.

Note:  The signal flow channel strips are only displayed if the View menu’s Add Signal 
Flow Channel Strip setting is active.

Arrange View
The Arrange view displays the signal flow of all channel strips that correspond to tracks 
(audio, instrument, or external MIDI) used in the Arrange window.

The entire signal flow is laid out from left to right:
Â All channel strips that are assigned to Arrange tracks are shown in ascending order. 
Â Aux channel strips—used for the individual output signals of multi output software 

instruments—are displayed beside the software instrument channel strip. These are 
placed in ascending order, in accordance with the output number. An auxiliary 
channel with outputs 3 and 4 will be to the left of an aux channel routed to outputs 
7 and 8, for example.

Â All aux channel strips with buses as the input source—used as send or routing 
destinations for other channel strips used in the Arrange, or displayed in the Mixer—
are shown in an ascending order that follows bus numbering.

Â All output channel strips which are used as send or routing destinations for other 
channel strips (used in the Arrange, or displayed in the Mixer) are shown in an 
ascending order that follows output numbering.

The signal flow channel strips are only displayed if the View menu’s Add Signal Flow 
Channel Strip setting is active.

You can use the following two settings in the View menu to further refine the Arrange 
view:
Â Other Tracks:  Enable to show (or disable, to filter) track channels that do not offer any 

mixing parameters, such as volume or pan control. These “other tracks” include the 
No Output and Metronome tracks. This is useful for setting the level and routing 
assignment for the Metronome, with the latter option being handy if you need to 
provide a click track to a specific output (for a musician or synchronization purposes).
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Â Same Instrument Tracks:  Enable to show (or disable, to filter) Arrange window tracks 
that address the same instrument channel strip. These tracks have redundant settings 
for volume, pan, and so on (as they address the same channel strip), so it’s usually 
unnecessary to display more than one channel strip for each track. 

All View
The All view can display channel strips that don’t exist in the track list of the Arrange 
area. In this situation, it’s impossible to select such tracks for recording. 

To automatically create a track for a selected channel strip in the Arrange area:
m Choose Options > Create Arrange Track for Selected Channel Strip in the Mixer’s menu 

bar. 

This command is primarily intended for use with aux or output channel strips, which 
are not usually shown in the Arrange, but may be needed for automation purposes. 

Note:  This function can not be used to duplicate Arrange tracks:  If the selected 
channel strip is already available as an Arrange track, the Arrange track will be selected, 
and shown in the visible window area.

Refining the Mixer View
You can use the channel strip filter buttons to limit the display of the Mixer to 
particular types of channels. 

These buttons work in conjunction with the Arrange and All views discussed above. 
You can use different filter button settings for both views:
Â Click a button to enable or disable the view of this channel strip type.
Â Option-click a button to enable it, and to disable all other buttons (all other channel 

strip types). 

Channel strip filter buttons



Chapter 25    Mixing 577

Customizing the Display of Channel Strips
You can individually switch the display of the following audio channel strip 
components on or off, by enabling or displaying the corresponding setting in the View 
menu:
Â EQ Thumbnails
Â Inserts
Â Sends
Â I/O
Â Track Name
Â Track Number

You can also switch the display of the MIDI channel strip components on or off, by 
enabling or disabling the respective setting in the View > MIDI Track Components 
menu:
Â Instrument name
Â Program (change numbers)
Â Bank (select numbers) 
Â User-defined knobs (Assign 1 to 5)

You can also choose to hide or show the track name and track number of all channel 
types, thus creating more space onscreen.

Renaming Tracks in the Mixer Window
Presuming that View > Track Name is enabled in the Mixer window, double-clicking the 
display of the track name (or channel strip name, which is used as the default track 
name) opens a text field. Type in a new track name, or change an existing one, and 
press Return to exit the text field.

Assigning Colors to Channel Strips
The Colors option in the View menu launches a Color palette that allows you to assign 
colors to channels. These color assignments are also reflected by Arrange window 
regions, and simplify the task of mixing (particularly groups).

To assign a color to a selected channel strip:
m Choose View > Colors, and click on the desired color in the palette. Close the palette by 

clicking the close button at the top left. 

You can define custom colors by double-clicking on any color in the palette. A Color 
wheel will open, allowing you to define the hue. Click OK to replace the selected color 
square of the palette.
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Displaying Folder Tracks
The Mixer can display the channel strips associated with the contents of folder tracks, 
or tracks on the highest Arrange window display level. 

If a folder track is selected—or the Arrange is showing the contents of a folder when 
you open the Mixer—it will only show the channel strips associated with the tracks 
within the folder. 

If you click the Hierarchy button (to the left of the Mixer Link button), you will switch 
the Mixer display up to the next level in the Arrange hierarchy; in this case, the level 
containing the folder. 

Double-clicking the folder channel will return to displaying the channels within the 
folder. The View > Folder Tracks option must be switched on for this to work.

Folder track
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Using the I/O Labels Window
You can use the I/O Labels window to define names for all channel strip Input, Output, 
and Send menu items, which can be used in place of defaults such as; “Input 1” or 
“Output 8”. 

To open the I/O Labels window:
m Do one of the following:

Â Choose Options > Audio > I/O Labels in the main menu bar.
Â Choose Options > I/O Labels in the Mixer window. 

Choose the desired Device from the menu, if you have multiple audio interfaces. I/O 
labels can be individually defined for each hardware driver type (Core Audio or DAE, as 
examples), but are valid for all projects. These labels are stored in a separate file, 
located in the ~/Library/Application Support/Logic folder. The file is called “IOLabels 
xxx”, with “xxx” being the name of the hardware type.

To create new I/O labels for the Input, Output, and Send menus of channel strips:
1 Click the button in the User column, aligned on the Channel row (Output 1-2, for 

example).

2 Double-click the “–” in the Long (name) column and type in a new name for Output 
1-2. MLAN 1-2, for example. Click outside the row, or press Return.

3 Repeat the process for the Short (name) column. Type in 1-2, for example. 

The short name is used in the Send slots. 

Output 1-2, if used, will be replaced with MLAN 1-2 in the Output menu slot of all 
channel strips.
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To revert to default channel I/O labels, do one of the following:
m Click the corresponding button in the Channel column.

m Choose the desired Reset menu command to reset the following channel strip types to 
their “default” names (as shown in the Channel column):

Â All Labels
Â Input Labels
Â Output Labels
Â Bus Labels

To use the I/O labels provided by the hardware driver:
m Click the corresponding button in the Provided by Driver column.
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26 Working With Automation

Logic Pro features a sophisticated, yet simple to use, track-
based automation system that allows you to create and play 
back fully automated mixes.

Mix automation refers to recording, editing, and playing back the movements of faders, 
knobs, and switches on a mixing console—providing real time control of volume, pan, 
EQ, and aux send controls, amongst others.

You can automate all mix functions in Logic Pro, without restriction. This also applies to 
all plug-ins—the parameters of all effects and software instruments, plus all third-party 
plug-ins can be totally automated (with one or two exceptions, such as several Space 
Designer parameters, which cannot be automated in real time).

Automation is independent of MIDI and audio regions, and takes place on Arrange 
window tracks. 

Automation is also independent of the play or record status of Logic Pro, allowing you 
to create automation at any time.

The Logic Pro track automation system is sample accurate, which is precise, but very 
processor-intensive. You can partially or completely switch off the sample accurate 
mode in the Sample Accurate Automation menu of the Logic Pro > Preferences > 
Audio > General tab.

Note:  You can also use MIDI controller values to automate parameters. This is done on 
a per region basis, and is known as Hyper Draw (see “Using Hyper Draw” on page 596).
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Displaying Track Automation
Track automation data is displayed on a transparent gray shaded area—an automation 
track—that runs the length of your project. The audio waveforms of audio regions, and 
notes in MIDI regions, can be seen at a reduced contrast level in the shaded area. 

The automation data is represented by colored curves, dots (known as nodes) and lines 
that are shown in the gray area.

Numerical values are also automatically displayed at each node on automation tracks. 
Numerical values are context-sensitive—which means the centered pan position is 
displayed as 0 (not 64), and volume is displayed in dB, as examples.

To display track automation in the Arrange area, do one of the following:
m Choose View > Track Automation in the Arrange area (or use the View Track 

Automation key command, default:  A).

m Click the Automation button in the Toolbar (if visible).

The gray automation area appears on all tracks, and the Automation Parameter menu is 
displayed in the track header. This allows you to choose the visible automation 
parameter. It is automatically set to Volume.

 Automation Parameter
menu
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Automation can only be displayed when a track is of a sufficient height. Turning on 
track automation will automatically set a suitable vertical zoom level. 

To resize one or more tracks:
m Click-drag the lower-left corner of a track header (the track list) to resize it. Alternately, 

you can use the vertical zoom bars to resize all tracks, if automation is not visible. 

This can happen if you have manually resized a track, or changed the zoom level after 
activating automation.

Displaying Different Automation Parameters
You can choose the parameter that you wish to view, and edit, in the Automation 
Parameter menu. This appears below track names in the Arrange track list. 

This can be the volume fader, pan pot, or any other parameter of the track’s channel 
strip. The parameters are represented by different preset colors when displayed as a 
curve in the automation track. As examples:
Â Yellow for Volume automation
Â Green for Pan automation
Â Orange for Solo automation

Only parameters which actually control something in the selected track’s channel strip 
(or its plug-ins) are displayed in the Automation Parameter menu. Parameters that 
already exist in the track (as automation data) are displayed in bold lettering in the 
menu.

To choose an automation parameter:
m Click on the Automation Parameter menu, and browse to the desired parameter. 

A sub-menu is shown for each plug-in inserted in the channel strip. These are 
numbered and named after the slot position and plug-in (1 EXS24, for example). 
Further sub-menus may be shown inside the plug-in menus. Volume, Pan, Solo, Mute, 
and Bypass are shown in the Main sub-menu.

To hide all automation parameters on a track:
m Click on the Automation Parameter menu, and choose Display Off.
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To hide all automation parameters on all tracks, do one of the following:
m Choose View > Track Automation (or use the View Track Automation key command, 

default:  A).

m Click the Automation button in the Toolbar (if visible).

Viewing the Automation Data of Multiple Parameters
The automation track shows all automation data (not only the currently active 
parameter) at a lower contrast level. Volume is a muted yellow, Pan is a muted shade of 
green, and so on. 

To change the transparency level of regions and automation data:
m Adjust the Regions and Other Data sliders in the Automation Transparency section of 

the Logic Pro > Preferences > Display > Arrange tab.

You also have the option of viewing each automation parameter on its own sub-track, 
making it easier to see what is being controlled.

To view automation data on sub-tracks:
m Click the disclosure triangle to the lower left of a track name. 

This opens a separate automation sub-lane, below the track. 

Logic Pro will automatically set the automation parameter type of the new automation 
lane to a type that’s already recorded, but not currently shown. The active automation 
parameter remains on the top track. Repeated clicks on the disclosure triangle will 
open further automation sub-tracks.
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To view all recorded automation data on sub-tracks:
m Option-click the (closed) triangle to open up to 30 automation sub-tracks, which will 

display existing (already recorded) automation data. 

Only as many automation sub-tracks as required will open, so if you have recorded 
automation data for ten parameters, nine sub-tracks will be opened. The active 
automation parameter remains on the top track.

Option-click the open triangle to collapse all automation sub-tracks. The automation 
data remains active, and will play if the automation mode of the main track is not set to 
Off or Write—even if the track is not visible. 

Setting an Automation Mode
Automation modes determine how automation tracks are handled. Essentially, 
automation is either:  off, being read, or being written. You can independently choose 
the automation mode for every channel strip.

To set the automation mode for a track, do one of the following:
m Choose the desired mode in the track header’s Automation Mode menu.

m Choose the desired mode in the Automation Mode menu on a channel strip—in either 
the Mixer or Arrange channel strip.

To set the same automation mode for all tracks:
m Press Option, and choose the desired automation mode in the Automation Mode menu 

in the Mixer or Arrange channel strip.
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To set the same automation mode for selected channel strips:
1 Choose the desired channel strips by Shift-clicking on their names in the Mixer.

2 Choose the desired automation mode in the Automation Mode menu of one of the 
selected channel strips.

Setting the Automation Mode Via Key Commands
You can also set the automation mode with the following key commands. 
Â Toggle Current Track Automation Off/Read
Â Set Current Track to Automation Read
Â Toggle Current Track Automation Touch/Read 
Â Toggle Current Track Automation Latch/Read
Â Toggle Current Track Automation Write/Read
Â Set All Tracks to Automation Off (default:  Shift-Control-Command-O)
Â Set All Tracks to Automation Read (default:  Shift-Control-Command-R)
Â Set All Tracks to Automation Touch (default:  Shift-Control-Command-T)
Â Set All Tracks to Automation Latch (default:  Shift-Control-Command-L)
Â Set All Tracks to Automation Write

Choosing Automation Modes
You can choose from the following automation modes in any channel strip:

Off
Off will disable the current track automation data without deleting it. No automation 
data will be written, read, or played back. If the current automation mode is Off, any 
edits to track automation data in the Arrange area will automatically switch the 
automation mode to Read. This ensures that the data, as currently edited, will be 
played.

Given that track automation can be recorded during playback mode, Off is the default 
setting, as any mix automation recording may prove disconcerting while arranging.

Read
Read mode will automate the current track, using the existing automation data.

The data can not be changed by moving the channel strip controls, or using an 
external automation controller, when in Read mode.
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Touch
Touch mode plays back automation data in the same fashion as Read mode.

Should a channel strip or an external (touch-sensitive) automation controller be 
touched, the existing track automation data of the active parameter will be replaced by 
any controller movements—for as long as the fader or knob is touched. When you 
release the controller, the automation parameter will return to its original (recorded) 
value. The time required by a parameter to return to its previously recorded setting, is 
set via Logic Pro > Preferences > Automation > Ramp Time.

Touch is the most useful mode for creating a mix, and is directly comparable to “riding 
the faders” on a hardware mixing console. It allows you to correct and improve the mix 
at any time, when automation is active. 

Latch
Latch mode basically works like Touch mode, but the current value will replace any 
existing automation data, after releasing the fader or knob—when Logic Pro is in 
playback (or record) mode.

To finish, or to end parameter editing, stop playback (or recording).

Write
In Write mode, existing track automation data is erased as the playhead passes it.

If you move any of the Mixer’s (or an external unit’s) controls, this movement will be 
recorded—if you don’t, existing data is simply deleted as the playhead passes it.

To determine the type of data that should be erased:
m Enable the desired checkboxes in the “Write Automation for” section of the Logic Pro > 

Preferences > Automation tab.

The Write Mode Changes To menu determines the mode that Logic Pro switches to 
after a Write operation has been executed.

Warning:  Be careful with Write mode (and its settings), to ensure that you don’t erase 
your pan, bus, and plug-in automation data by mistake, if your intention was only to 
erase volume fader information!
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You’ll rarely need the Write mode when working with the track automation features of 
Logic Pro. It’s mainly there to complete the selection of automation modes. It’s easier to 
erase automation data by choosing Options > Track Automation > Delete All 
Automation Data of Current Track (or Delete All Automation Data of All Tracks, 
respectively). 

In earlier analog mix automation systems, Write mode was the only way to erase 
automation data from tape when beginning a new project. The Options > Track 
Automation > Write to End and Write to Right Locator commands are self explanatory. 
One writes track automation data to the end of the project, and the other to the right 
locator position.

Writing Track Automation Data
You have the following write options for track automation data:
Â Move any fader or control of the selected channel strip with the automation mode 

set to Touch, Latch, or Write. In real world usage, you’ll rarely (if ever) use the 
destructive Write mode, which erases all automation data. The standard write modes 
are Touch and Latch.

Â Choose a parameter in the Arrange track list, and move the value slider to the right 
of the track list, with one of the write modes turned on.

Â Move the faders or knobs of a connected hardware controller, with one of the write 
modes turned on (see “Writing Track Automation With External Controllers” on 
page 594).

Â Use the Pointer or Pencil tool to draw your automation data.

When one of the write modes is active, you can record track automation data when 
Logic Pro is in record or play mode. The Arrange window track selection or audio 
record ready status is irrelevant. Whatever you touch or move will be recorded, when a 
channel strip is set to one of the write modes. The movement of Mixer controls (when 
in a write mode) can be used to overwrite or edit existing automation data, in real time.

When Logic Pro is in stop mode, the automation write modes are ignored, and no data 
is written if the fader is moved. There is, however, one exception:  If there are no 
dynamic changes (no automation data), the current fader setting becomes valid for the 
whole project. This is the default behavior for all mix parameters, when you start a fresh 
project.
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Editing Track Automation in the Arrange Area
You can edit track automation data directly in the Arrange area.

Selecting Automation Nodes and Lines
You can use the Automation Select tool to rubber band any selection (of nodes) in the 
automation data. 

Â Click on a region to select all currently visible automation events that fall within the 
region borders.

Â Shift-click to select other areas, in addition to an existing selection. This enables you 
to simultaneously edit non-contiguous selections.

Â Shift-click on a node—in front, or following a selected area—to extend the current 
selection.

You can also select nodes with the Pointer tool:
Â Shift-click on a node to toggle selection (of the node).
Â Shift-click on a line to toggle selection (of the line).
Â Click outside of all track automation lanes (on the Arrange area background) to 

deselect all automation data.
Â Click-drag a selected area to move all selected nodes (and connecting lines). Moved 

automation data will automatically erase any data which exists in the destination 
area.

Â Shift-dragging allows rubber-band selection. The selected area will toggle.
Â Option-clicking, when no automation data is selected, will select all data behind 

(following) the current mouse position, allowing you to drag this selection.
Â Option–double-clicking, when no automation data is selected, will select all data.

Creating Automation Nodes
Click on, or just outside, an automation line (not on a node) with the Pointer or Pencil 
to create a new node.

The very first click in an empty automation track creates a new node at that position, 
and another node at the beginning of the track. This ensures that you can’t create 
parameter controls with gaps in the middle of a region, and have full control over the 
parameter from the beginning of the automation track.

Automation Select tool
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To freely draw automation:
m Draw the desired automation lines (and curves) with the Pencil tool.

Nodes will be created along the line.

To create a new node on each side of a rubber band area:
m Option-Shift-click and drag with the Pointer tool to make a rubber band selection.

This creates a new node on each side of the rubber band area.

∏ Tip:  With Option-Control-Shift held, two new nodes will be created on each side.

To create nodes at region borders:
m Select the desired region and choose either of the following commands:

Â Options > Track Automation > Create 2 nodes at region border. This creates one 
node at each end of the selection area.

Â Options > Track Automation > Create 4 nodes at region border. This creates two 
nodes at each end of the selection area.

Deleting Track Automation Data
You can choose one of the following commands in the Options > Track Automation 
menu (or the corresponding key command) to delete track automation data:
Â Delete currently visible Automation Data of Current Track:  Removes the active 

automation parameter data (default key command assignment:  Control-Command-
Backspace).

Â Delete All Automation Data of Current Track:  Removes all types of automation data 
from the selected track (default key command assignment:  Shift-Control-Command-
Backspace).

Â Delete Orphan Automation Data of Current Track:  Removes all orphaned automation 
data from the selected track. Automation data can be orphaned when copied 
between tracks.

Â Delete All Automation Data of All Tracks:  Removes all types of automation data from 
all tracks.
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You can also delete multiple nodes by doing one of the following:
Â Shift–Option–double-click anywhere on an automation track to open a dialog that 

allows all automation data (of the current type) to be deleted. This is as per the 
Delete All Automation Data of Current Track command.

Â Press Backspace to delete a selection of automation nodes. Ensure that no regions 
are selected when using this function. Any selected regions will also be deleted!

To delete a single node:
m Click on it with the Pencil or Eraser tool.

Copying, Moving, and Changing Automation Data
Following the creation or selection of automation nodes and lines, you can easily 
change things to meet you needs.

To move or copy automation data:
m Select the nodes or lines you want to move, then drag them to the left or right.

m Option-drag the selection to copy it to a different location. 

Note:  Both operations will delete all nodes in the destination area.

It’s possible to move regions with, or independent from, track automation data. 

To move regions with, or without, automation data:
m Choose the desired Move Automation with Regions option in Logic Pro > Preferences > 

Automation:

Â Never:  Does not move automation when you move regions.
Â Always:  Always moves automation when you move regions. The automation data 

area encompassed by the region boundaries is moved.
Â Ask:  A dialog will prompt you to move the automation data—or leave it where it 

is—whenever you move a region.

To copy or convert the automation data of one parameter to another:
1 Select the automation parameter that you want to copy, or convert, in the Automation 

Parameter menu.

2 Command-click on the Automation Parameter menu and choose a destination 
parameter.
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A dialog will ask if you want to convert, or “copy and convert,” the source parameter 
data into automation data for the destination parameter. A “copy and convert” results in 
the source parameter automation data being retained, and replicated for the 
destination parameter.

You can use the Automation Curve tool to bend the line between two nodes, or any 
selection.

To bend an automation line:
m Drag the desired automation line with the Automation Curve tool. 

∏ Tip:  This function is also available when using the standard Pointer tool, by pressing 
Option-Control.

Relative and Absolute Value Changes of Selections
There are two choices available when changing the values of several selected nodes:
Â Clicking on a line or node enables you to change all values by the same absolute 

amount.
Â Clicking outside a line, within the selected area (a node or outside a node), changes 

all values proportionately, by a percentage value.

Editing Automation Data With the Track Header’s Value Displays
Command-clicking on either the value fader or numerical value display in the track list 
with the Pointer allows the following:
Â A Command-click selects all (current parameter) automation data of the track.
Â Command-dragging scales all (current parameter) automation data of the track.

Automation Curve tool
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Snapping Automation to Grid Positions
You can snap both track-based and HyperDraw (region-based) automation to grid 
positions.

To automatically snap automation nodes to the chosen Snap grid value:
m Enable Snap Automation in the Snap menu. 

Note:  Automation edits always snap to an absolute position, regardless of whether or 
not the Snap to Absolute Value option is enabled.

Offsetting Automation
Although automation in Logic Pro can be sample-accurate, it may be affected by audio 
hardware latencies, excessive CPU loads, or plug-in delays. To ensure that your 
automation happens “on-the-money,” you can move it slightly forwards or backwards 
in time (if Snap Automation is enabled). 

To offset your automation when Snap Automation is active:
1 Open the Automation preferences by doing one of the following:

Â Choose Automation Snap Offset in the Snap menu.
Â Choose Logic Pro > Preferences > Automation (or use the corresponding key 

command).
Â Click the Preferences Toolbar button, then choose Automation from the menu. 

2 Adjust the (Automation) Snap Offset parameter in tick values (these can be either 
positive or negative). 

All automation, on all tracks (or regions containing HyperDraw automation), will be 
offset by the chosen number of ticks.
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Editing Track Automation Data in an Event List
Logic Pro allows track automation data to be altered in a dedicated event editor 
window, which can only be opened via the Automation Event List key command 
(default:  Control-Command-E). 

Each automation event is displayed as a MIDI controller event, and can be adjusted in 
length, value, and so on.

∏ Tip:  If you launch another Arrange window (Command-1) while the Automation Event 
List window is open, you will see all automation data as folder regions in a separate 
Arrange window. These can be handled just like MIDI regions, but only affect 
automation data.

Note:  This functionality generally won’t be required in most automation editing 
situations, but is there if you need it. 

Writing Track Automation With External Controllers
Logic Pro provides support for a number of dedicated control surfaces that make 
writing and editing track automation data fast, efficient, and easy. Dependent on the 
facilities available, you can simultaneously write automation data for several channels, 
or multiple plug-in parameters. Full details on all supported devices can be found in 
the Logic Pro 8 Control Surfaces Support manual.

Any MIDI controller—such as the modulation wheel, or a front panel slider or knob on 
your MIDI keyboard—can be used to write automation data. You can use one such 
controller for all automation writing duties (see below), or can assign individual 
controllers (if available on your MIDI keyboard) to different parameters (see the 
Logic Pro 8 Control Surfaces Support manual). 
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Using Automation Quick Access
The Automation Quick Access feature makes track automation extremely fast and 
simple if you only have one hardware MIDI controller available (one fader on your MIDI 
keyboard, or maybe just the modulation wheel). You can use this single hardware 
controller to access (and automate) the currently active automation parameter of the 
selected track in the Arrange window.

To set up Automation Quick Access:
1 Open the Automation preferences, by doing one of the following:

Â Choose Logic Pro > Preferences > Automation (or use the Open Automation 
Preferences key command, default:  Option-A).

Â Click the Preferences button in the Toolbar, and choose Automation from the menu.

2 Enable Automation Quick Access, by clicking the On button in the Automation Quick 
Access section.

A dialog will prompt you to assign the desired controller. 

3 Click the Assign button and slowly move the hardware controller that you’d like to use 
for Automation Quick Access. Ensure that it’s moved through its entire range.

4 Confirm your selection, by clicking the Done button below the Off/On buttons in the 
Automation Quick Access section. 

The Done button turns into a Learn Message button. Clicking the Learn Message 
button allows you to assign a new controller for Automation Quick Access. 

A click on the Edit button opens the Controller Assignments Editor, where you can 
assign the desired controller manually. See the Logic Pro 8 Control Surfaces Support 
manual for more information.

Once set up, you will have hardware control over the active automation parameter on 
the current Arrange track.

Enabling and Disabling Automation Quick Access
Should you choose the modulation wheel for Automation Quick Access, you might 
want to switch between using it for Automation Quick Access and normal modulation 
wheel duties—as MIDI controller 1.

This is most efficiently done with the Toggle Automation Quick Access key command 
(default:  Control-Option-Command-A). 
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Using Hyper Draw
Hyper Draw works much like track automation, with a couple of key differences:
Â Hyper Draw data is restricted to MIDI regions.
Â Hyper Draw data uses MIDI controller values (rather than the internal meta events 

used by the track automation system), which are represented as lines between 
nodes. 

You can edit nodes and lines in a similar way to track automation data. 

You can record MIDI controller events in real time on MIDI tracks—or use Hyper Draw 
to create and edit controller events in the Arrange area, Piano Roll, and Score Editor. 
The Hyper Editor is purpose-built for MIDI controller editing, providing more precision 
and flexibility than the Hyper Draw options of other windows.

Numerical MIDI controller values are automatically displayed as Hyper Draw nodes. 
These values are context-sensitive—the centered pan position is displayed as 0 (not 
64), and volume is displayed in dB, as examples. If no events exist, Logic Pro will 
automatically create a horizontal line (of the current value, if available).

You can use any of the 127 MIDI controller values to automate parameters such as 
volume or pitch, for example.

To activate Hyper Draw for the currently selected regions or events in the Arrange 
area, Piano Roll, or Score Editor:

m Choose the desired event type directly from the View > Hyper Draw menu:

The chosen event type is displayed as a controller number, or by name, in the upper 
left corner of the Hyper Draw area. You can choose different Hyper Draw parameters for 
each MIDI region in the Arrange, if needed. You can use multiple types of Hyper Draw 
information for each region.
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If activated in the Piano Roll or Score Editor, a gray Hyper Draw section is displayed 
below the editing area. 

The Piano Roll and Score Editor feature a Hyper Draw button at the lower left corner. 
Click this button to open or close the Hyper Draw section. When the gray Hyper Draw 
area is visible, you can choose the desired controller type from the menu (Down Arrow) 
shown to the left of the Hyper Draw scale.

To switch off Hyper Draw:
Choose View > Hyper Draw > Disable.

To set the MIDI Channel:
m Choose the desired channel number from the View > Hyper Draw > Channel sub-

menu.

The chosen channel number will also be displayed alongside the event type.

To define other MIDI controllers in Hyper Draw:
m Choose View > Hyper Draw > Other, and select the number of the controller and the 

MIDI channel in the Hyper Draw window. 

Use this option if you want to use Hyper Draw to edit a controller that isn’t directly 
available in the Hyper Draw menu.

 Hyper Draw menu

 Hyper Draw button
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Using the Autodefine Mode
The Autodefine mode sets the Hyper Draw parameters automatically, making the first 
event in the region visible.

Autodefine is not limited to switching the Hyper Draw display to the first incoming 
controller, but it can also respond to other types of events as well. It responds in this 
order:
Â Controller
Â Aftertouch
Â Pitch Bend
Â Program Change
Â Note Velocity

Recording of MIDI Automation Data
You can record MIDI automation just like regular MIDI events. Logic Pro must be in 
Record mode to capture this type of automation.

To record MIDI automation data, do one of the following:
m Move any Environment fader to record the fader’s MIDI events to the currently selected 

track. For more information see “Recording and Playback of Fader Movements” on 
page 922.

m Record events via external MIDI controllers, such as the modulation wheel or filter 
cutoff control of your MIDI synthesizer, for example.

Editing MIDI Automation Data
As MIDI automation data consists solely of MIDI events, you can edit it just like any 
other MIDI events, using the Event List, Hyper Editor, or the Transform window.
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Using the Note Velocity Mode
Hyper Draw also offers the Note Velocity mode, which is perfect for creating crescendos 
or diminuendos across a range of notes. You can use it at any point in a region (on a 
note in the Piano Roll window, for example).

To use the Note Velocity mode:
1 Choose View > Hyper Draw > Note Velocity.

2 Click, and hold until you see the (Start Line) help tag, and release the mouse button. 
The (End Line) help tag is shown, along with a green line, which can be visually 
positioned onscreen. Keep an eye on the help tag while moving the line. 

3 Click at the desired end point—both vertical and horizontal—to automatically scale all 
note velocities, aligned with the inserted line. 

Note:  Use of this mode only makes sense when the region actually contains notes.

The Note Velocity Line tool works in different modes:
Â Absolute:  With no modifier key pressed, the velocity of notes will be changed to 

match the values of the line.
Â Relative:  Command-click, the original and new note velocity will be analyzed. The 

resulting velocity is an average of both values. 
Â Just Selected:  With Option pressed, only selected notes will be affected.

Both Relative and Just Selected modes can be combined.

 Piano Roll Editor in
Note Velocity mode
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Using Hyper Draw Key Commands
The following Arrange window key commands can speed up use of Hyper Draw:
Â Hyper Draw: Disable
Â Hyper Draw: Volume
Â Hyper Draw: Pan
Â Hyper Draw: Modulation
Â Hyper Draw: Pitch Bend
Â Hyper Draw: Note Velocity
Â Hyper Draw: Other …
Â Hyper Draw: Autodefine

Conversion of Automation Data
You can convert track automation data into MIDI controller events (Hyper Draw data, in 
other words), and vice-versa. This allows you to move control data from regions in the 
Arrange area to the track-based automation system, or the reverse. This is useful for 
mirroring the Hyper Draw information—being used to control filter cutoff (on an 
external MIDI synthesizer)—with an identical automation curve that controls the 
Intensity parameter of a Flanger plug-in on an Apple Loop drum track, as an example.

To convert region controller events to track automation:
1 Select the region.

2 Choose one of the following commands in the Options > Track Automation menu:

Â Move Current Region Data To Track Automation:  Moves the currently visible MIDI 
controller data (volume, for example) of the selected region to the track automation 
system.

Â Move All Region Control Data To Track Automation:  Moves all MIDI controller data of 
the selected region to the track automation system.

To convert track automation data into controller events:
1 Select the region that you want to copy the controller events into. 

2 Choose one of the following commands in the Options > Track Automation menu:

Â Move Current Track Automation Data To Region:  Converts the active track automation 
parameter into MIDI controller events, and copies it to the selected region.

Â Move All Track Automation Data To Region:  Converts all track automation parameters 
into MIDI controller events, and copies them to the selected region

Note:  Only track automation data that falls within the boundaries of the selected 
region is converted.
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27 Bouncing Your Project

You can render all or specific channels to one or more audio 
files, and even burn directly to CD or DVD with the Bounce 
function.

Output channels feature Bounce buttons.

Bounces for output channels 1 and 2 can also be initiated by choosing File > Bounce 
from any Logic Pro window (although the Arrange would be the most appropriate).

The Bounce process allows you to create an audio file (in several different file formats 
simultaneously, if desired), or multiple surround audio files, based on all channel strips 
routed to the selected output channel. 

All parameters, including volume, pan, and effects are recorded as part of the bounced 
file. Automation, if used, also impacts on the resulting bounce file.

Bouncing takes place in either real time, or faster than real time (offline bounce).

Once bounced, files can be:
Â Reused in Logic Pro, either creatively, or to save processing resources by replacing (or 

bypassing) the regions, instruments, and effects on source channels.
Â Used in other applications or devices. This makes it easy to send your files to 

mastering facilities, use them on the Internet (on web pages, or in the iTunes Store, 
for example), or even upload them to your iPod.

Â Burned directly to CD or DVD (this can actually be done directly from the Bounce 
window, making bouncing and burning a one step process).
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Creating a Bounce
This section outlines the basic steps required to create a bounced audio file. Detailed 
descriptions of each step follow.

To create a bounce file:
1 Route all channels that you want to bounce to a particular output channel (see the 

following section).

2 Define the desired bounce range (see “Defining the Bounce Range” on page 603).

3 Do one of the following:

Â Click the Bounce button on the desired output channel.
Â Choose File > Bounce from the main menu bar to bounce output channels 1 and 2. 

4 Set the parameters in the Bounce window (see “Using the Bounce Window” on 
page 603).

5 Enter a destination name (and folder) for the bounced file (or files).

6 Press the Bounce (or Bounce & Burn) button in the Bounce window.

Note:  Mono bouncing is possible when the output channel is set to mono. In this 
situation, a mono audio file is generated.

Routing Channels to an Output
If you’re only routing one or two channels to a particular output channel strip, simply 
click the Output slot of the channels, and choose the desired output channel from the 
pop-up menu.

To route a number of channels to an output channel strip:
1 Rubber-band select (or Shift-select) the desired channels.

2 Click the Output slot of one of the selected channels, and choose the desired output 
channel. 

All selected channels will be routed to the chosen output channel strip.
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Defining the Bounce Range
Before bouncing, it is best to define a range of your project that you would like to 
bounce. 

The default values for the Start and End position fields in the Bounce window will 
encompass the entire Logic Pro project if no regions are selected, or the Cycle function 
is inactive.
Â If the Cycle function is engaged, the bounce start and end positions will match the 

locator positions.
Â If a selection (of one or more regions) is made in the Arrange window, the bounce 

start and end positions will match the selected area.

Note:  You can manually set the bounce start and end positions in the Bounce window, 
if none of the options above are appropriate.

Using the Bounce Window
Following the range definition, press the Bounce button on the output channel, or 
choose File > Bounce. This will open the Bounce window.

Global Bounce Window Options
Several global options are available in the Bounce window, regardless of the file types 
being bounced.
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Destination
You can choose from several destination file formats for your audio bounce:
Â PCM file:  SDII, AIFF, (Broadcast) Wave, or CAF format
Â Compressed file:  MP3 or M4A: AAC

All options are activated by simply clicking in the desired checkboxes. You can select 
multiple checkboxes, if you wish. If you do so, multiple files will be created, with the 
appropriate file extension:  filename.aif, filename.mp3, filename.m4a.

If you click on the destination name, rather than click the checkbox, you can set a 
number of preferences in the panel to the right. As examples:
Â PCM, MP3, and M4A:  AAC files can be individually bounced and added to the iTunes 

library if “Add to iTunes library” is turned on in the sub-pane (for each format).
Â PCM files in SDII, AIFF, Wave, or CAF format:  Can be added to the Audio Bin if the Add 

to Audio Bin checkbox is enabled in the PCM sub-pane.

Note:  All bounced wave file recordings are in Broadcast Wave format. 

To burn a DVD or CD:
1 Click the Burn name (Burn: CDDA or Burn: DVD-A) to view the panel to the right.

2 Choose CDDA or DVD-A from the Mode menu, dependent on the type of disc you want 
to burn.

3 Click the Burn:CDDA destination checkbox to enable disc burning after the bounce. The 
Bounce button will be renamed to Bounce & Burn when Burn is selected.

Note:  When Burn is selected, you may see a dialog informing you about changes to 
stereo interleaved or surround files. This is dependent on other settings made in the 
dialogs for each file type. 

Start and End Position
These fields define the boundaries of the project segment that you want to write to the 
bounced file. The defaults for these fields are set in the following way:
Â If the Cycle function is engaged, they will be set to the locator positions. 
Â If a selection is made in the Arrange window, they will be set to the selected area.
Â If neither of the above is valid, they will encompass the entire Logic Pro project. 

In any case, you can adjust the start and end positions manually. As an example, should 
you want to take into account a MIDI sound module (mixed via an aux channel) that 
falls outside the bounce start and end positions.

∏ Tip:  It’s often a good idea to set the end position of the bounce a little bit past the end 
of the last region. This ensures that reverb tails and echoes from delay plug-ins are not 
chopped off. The amount of extra time needed will, of course, depend on the effect 
settings used.
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As you adjust the Start and End position parameters, you are shown the hard disk 
space requirements for the bounced file above the Cancel and Bounce (Bounce & Burn) 
buttons.

(Bounce) Mode
Â Realtime:  Creates the bounce file in real time. Use it whenever you wish to bounce 

audio and instrument tracks, plus external MIDI sound sources that are routed into 
the Logic Pro Mixer via aux channels.

Â Offline:  Accelerates the bounce process—depending on the complexity of your 
arrangement, and available CPU processing power. It also allows you to bounce 
arrangements that would normally exceed the processing power of your CPU, if 
trying to play them in real time. 

Note:  Offline bouncing is limited to internal sources (audio or instrument tracks). 
External MIDI tracks and audio channel inputs are deactivated during offline bounces.

The offline bounce mode is only available to the output channels of devices that use 
native audio driver systems (Core Audio). DSP-based audio hardware can not make use 
of offline bouncing due to the nature of its stream-oriented technology (these devices 
only work in real time, in other words). 

Other software applications that are fed into your Logic Pro Mixer via ReWire can be 
bounced offline.

Normalize
Turn on this option if you want to normalize your files before the bounce. Normalizing 
scans the incoming audio for the highest amplitude peak. The level of this peak is 
increased to the maximum possible level (without clipping), and all other incoming 
audio is also increased by this amount.
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PCM Options in the Bounce Window
Choose the PCM name (and activate the checkbox) in the Destination pane to access 
the following options:

File Format
Choose from the SDII, AIFF, (Broadcast) Wave, or CAF format.

PCM files in these formats can be automatically added to the Audio Bin by enabling the 
Add to Audio Bin checkbox.

Resolution
This is where you define the resolution of the bounced file. The options are 16 Bit (for 
CD delivery), 8 Bit (for multimedia productions,) or 24 Bit (for mastering to DVD).

Sample Rate
This menu allows you to choose the sample rate for your bounced audio file(s). Options 
range from 11,025 to 192,000 Hz, and include the three most commonly used sample 
rates:  44,100 (CD-DA), 48,000 (DAT), and 96,000 (DVD).

File Type
You can choose between Split (for use in Pro Tools), or Interleaved (for further use in 
Logic Pro, or for CD writing software).

Note:  Choosing Split disables Burn, if chosen in the Destination pane.

Dithering
Dithering is recommended when bouncing 24 bit recordings into 16 bit files.

Surround Bounce
Turn on Surround Bounce to bounce all outputs in the project surround format (File > 
Project Settings > Audio > Surround Format).

Each Surround channel is bounced to a separate file.
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All surround outputs are bounced simultaneously, regardless of which output channel 
Bounce button is clicked (or if the Bounce window was launched via File > Bounce).

The Logic Pro > Preferences > Audio > Surround tab accesses the surround settings. 
Â You can determine the surround output assignments in the Output tab.
Â The Bounce Extensions tab displays the extensions that are added to the file names 

resulting from a surround bounce. Click on the various fields to edit the extensions. 

Note:  Enabling the Surround Bounce option disables the MP3, M4A: AAC, and Burn 
checkboxes in the Destination pane (following a warning message).

“Add to” Options
The Add to Audio Bin option adds the bounced PCM file(s) to the Audio Bin.

The Add to iTunes library option adds the bounced PCM file to the iTunes library. 

Note:  iTunes does not support SDII or CAF format files. If the File Format menu is set to 
SDII or CAF, this checkbox is dimmed, and can’t be used.

MP3 Options in the Bounce Window
Logic Pro allows the bouncing of MP3 (MPEG-2, Layer-3) format files. This well-known 
data reduction format for digital audio signals was developed by the Fraunhofer 
Institute, and allows high compression rates while maintaining reasonable audio 
quality (depending on the compression rate). MP3 is a widely used standard for audio 
file exchange via the Internet.

Due to the fact that encoding an MP3 file equates to a loss of audio quality, you should 
not use MP3 files during production if you have access to the same audio data in linear 
formats such as:  AIFF, WAV, or SDII.

Bounced PCM files are also used for encoding to MP3/M4A: AAC. It should be noted 
that this occurs before dithering takes place. 

Note:  Should the selected sample rate be higher than 48 kHz, a temporary copy of the 
bounced PCM file is created—with an automatic sample rate conversion to 48 kHz 
before encoding. This conversion takes place because the MP3 format does not support 
sampling rates higher than 48 kHz.

If the PCM option is disabled in the Destination pane, a temporary PCM file is bounced 
as a source for encoding to MP3/M4A: AAC and/or burning to a CD—in accordance 
with the options selected in the PCM page.

Enabling the MP3 option in the Destination dialog automatically disables the PCM > 
Surround option (following a warning message). This is because the MP3 format does 
not support surround. Split Stereo format is, however, possible—even if the encoded 
MP3 file is set to Joint Stereo mode.
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Choose the MP3 name (and activate the checkbox) in the Destination pane to access 
the following options:

Bit Rate (Mono/Stereo)
MP3 bit rates are selectable between 32 kbps and 320 kbps, but default to 80 kbps 
mono, and 160 kbps stereo. These rates offer acceptable quality and good file 
compression. 

To enhance audio quality, provided you can afford the extra file size, choose:
Â 96 kbps for mono streams
Â 192 kbps for stereo streams

You can, of course, choose even higher rates, but the quality improvement afforded by 
bit rates above 96/192 kbps is nominal.

Use Variable Bit Rate Encoding (VBR)
Variable Bit Rate encoding compresses simpler passages more heavily than passages 
that are (more) harmonically rich, generally resulting in better quality MP3 files.

Unfortunately, not all MP3 players can accurately decode VBR-encoded MP3s, which is 
why this option is turned off by default. If you know that your target listeners can 
decode VBR-encoded MP3s, you can switch this option on.

Quality
Keep this set to Highest (the default) whenever possible. Reducing the quality 
accelerates the conversion process, but at the expense of audio quality.

Use Best Encoding
Again, like the Quality parameter, if you uncheck this option, you will gain encoding 
speed at the price of audio quality. This should always be kept on, unless conversion 
time is an issue.
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Filter Frequencies Below 10 Hz
When this option is checked (the default), frequencies below 10 Hz (which are usually 
not reproduced by speakers, and are not audible to human ears at any rate) will be 
removed. This leaves slightly more data bandwidth for the frequencies that we can 
hear, resulting in an improvement of the perceived quality. Only uncheck this option if 
you’re experimenting with subsonic test tones, or exporting MP3s for whales!

Stereo Mode
You can select Joint Stereo or Normal stereo mode. Depending on the original file, 
these settings may (or may not) offer any audible difference. Experiment with both 
settings to determine your preference.

Write ID 3 Tags/ID3 Settings
When the Write ID3 Tags option is enabled, ID3 tags are written to the file. 

These tags can be edited/configured in a dialog which you can open by clicking the 
ID3 Settings button. 

All entries are made by double-clicking on the desired Content column fields to the 
right of the corresponding ID 3 Frame column entry, and typing in your text.

Enable the Use default values checkbox (on by default) to display default settings for 
certain Content column entries. As examples, the Project Title and Tempo (Beats Per 
Minute) are automatically filled in.

Enabling the “Use default values checkbox” also sets the Initial Key: menu to the first 
entry shown in the global Signature track. This will be “default:C” if no key has been set 
for the project.

You may freely choose another key from the menu.

Add to iTunes Library
The Add to iTunes library option adds the encoded MP3 file to the iTunes library.
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M4A:  AAC Format Options
Choose the M4A: AAC name (and activate the checkbox) in the Destination field to 
access the following options:

Encoding
Choose Advanced Audio Codec (AAC) or Apple Lossless to determine how your .m4a 
(commonly referred to as MP4) file will be encoded. Both encoding algorithms provide 
high quality audio, with the AAC format using a higher compression ratio, resulting in 
smaller file sizes.

Bit Rate
You can choose a rate between 16 kbps and 320 kbps.

Note:  This parameter is only available when the AAC Codec is chosen.

Encode With Variable Bit Rate (VBR)
Variable Bit Rate encoding compresses simpler passages more heavily than passages 
that are (more) harmonically rich, generally resulting in better quality files.

Unfortunately, not all media players can accurately decode VBR-encoded files, which is 
why this option is turned off by default. If you know that your target listeners can 
decode VBR-encoded files, you can switch this option on.

Note:  This parameter is only available when the AAC Codec is chosen.

Add to iTunes Library
The Add to iTunes library option adds the encoded file to the iTunes library.

Enabled the M4A: AAC option in the Destination dialog disables PCM > Surround 
(following a warning message). Split Stereo is, however, possible.

Should the selected sample rate be higher than 48 kHz, a copy of the bounced PCM file 
is created—with an automatic sample rate conversion to 48 kHz before encoding. This 
conversion takes place because the M4A: AAC format does not support sampling rates 
higher than 48 kHz.
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Burn Options
Choose the Burn: (CDDA or DVD-A) name (and activate the checkbox) in the 
Destination pane to access the following options:

Logic Pro can directly burn Red Book audio to blank CDs or DVD-Audio to blank DVDs.
Â When CDDA is chosen:  If the selected sample rate (chosen in the PCM panel) is higher 

than 44.1 kHz, a copy of the bounced PCM file is created—with an automatic sample 
rate conversion to 44.1 kHz before encoding. This conversion takes place because the 
CD Audio format (Red Book) does not support sampling rates higher than 44.1 kHz.

Â When DVD-A is chosen:  Any sample rate up to 192 kHz can be used for stereo files, 
and up to 48 kHz for surround files.

Note:  Enabling the Burn option automatically disables the PCM > Surround and Split 
Stereo options (following a warning message). This is because CD or DVD-Audio only 
makes use of interleaved stereo files.

Simulate Write Only
The “Simulate write only” option, as the name suggests, simulates a CD/DVD burn, but 
does not write data to the blank media. This can be used either alone, or in conjunction 
with, the “Write as multi session” option (if burning a CD).

Write As Multi Session (Only Available When CDDA is Chosen in the Mode Menu)
The “Write as multi session” option allows you to add a data session to the same CD at 
a later date—to add the project folder, for example.

Device
This menu allows you to choose between any recognized CD/DVD burners connected 
to your system. 

Note:  If your system contains multiple burners, the first one detected is chosen as the 
default.
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Speed
The first time you use the Speed pull-down menu, a request is made to the burning 
mechanism, which may take a while. Once the scan is complete, you may freely select 
from the available speeds.

Dithering (Only Available When CDDA is Chosen in the Mode Menu)
Use of the Dithering parameter is recommended when bouncing 24 bit recordings into 
16 bit files. 

Note:  If you attempt to switch the PCM Resolution to 16 Bit when in DVD-A Burn Mode, 
DVD burning is automatically disabled (following a warning).

Bounce & Burn
Clicking the Bounce & Burn button initiates the bounce, and burns the audio to CD or 
DVD.

Note:  Following confirmation of the file location(s), you may encounter further dialogs 
that will ask if you want to overwrite existing files. Use these as required.

Media Status and Information Fields
The Media Status field indicates the type of media in the chosen Device. 

The field below indicates the current PCM page settings (if applicable).

A further field, above the Cancel and Bounce & Burn button, indicates the amount of 
disk space required, and the time (length, shown in hours, minutes, and seconds) of the 
bounce area.

Note:  You can not directly alter any information shown in these areas.
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Setting the Bounce File Name and Folder
By default, bounce files are:
Â Named after the chosen output channel strip (the Bounce button you clicked), or 

Output 1-2, if the Bounce window was opened with the File > Bounce command.
Â Saved in the Bounces sub-folder of the project folder, but you can choose any folder 

on any Volume.

To set the bounce file name and folder:
1 Simply type the desired file name in the Save As: field to change the default file name, 

and choose another folder, if you like.

2 Click the New Folder button at the lower left of the Bounce window to create a new 
folder, if desired.

3 Click the Bounce (or Bounce and Burn) button.

All files (if multiple files are created) are saved in the chosen folder, and assigned the 
name you entered, with appropriate file extensions:  wav, aif, m4a, and so on.

Bouncing and POW-r Dithering
Logic Pro provides you with the professional POW-r dither algorithm, designed to 
convert 24 bit recordings to 16 bit files—as required for CD burning, for example. 

POW-r (Psychoacoustically Optimized Wordlength Reduction) is licensed from the 
development team of the POW-r Consortium LLC.

POW-r dithering can be applied when:
Â Bouncing audio files to disk
Â Exporting OMF files (see “Exporting OMF Files” on page 635).

POW-r offers three distinct dithering modes. 
Â None  No dithering is applied.
Â POW-r #1:  Uses a special dithering curve to minimize quantization noise.
Â POW-r #2: (Noise Shaping):  Uses additional noise shaping over a wide frequency 

range, which can extend the dynamic range of the bounced file by 5 to 10 dB.
Â POW-r #3: (Noise Shaping):  Uses additional, optimized noise shaping, which can 

extend the dynamic range by 20 dB within the 2 to 4 kHz range—the range the 
human ear is most sensitive to.

Note:  Noise Shaping minimizes the side effects caused by bit reduction. It does this by 
moving the quantization noise spectrum to the frequency range above 10 kHz—the 
range the human ear is least sensitive to. Technically, this process is known as spectral 
displacement.
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The dithering mode which will sound best to you is primarily dependent on the audio 
material, and your personal taste. Audition the audio material with each of the 
dithering modes to determine the right setting. In some cases, you may find that the 
best results are achieved by using no dithering at all!

Important:  Dithering the same audio signal multiple times should be avoided.
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28 Creating Apple Loops

You can save both audio and software instrument regions as 
Apple Loops in Logic Pro. 

For audio regions, a default set of transients—based on the project’s tempo 
information—is automatically created. For more information on this method, see the 
following section. 

You can also use the Apple Loops Utility to create Apple Loops from audio regions. The 
Apple Loops Utility is a companion application to Logic Pro that allows you to manage 
metadata tags and transients in audio files. The Apple Loops Utility offers sophisticated 
tag editing functions for audio files. You can, for example, set the transients manually—
independent of the project tempo (for more information, see “Creating Apple Loops in 
the Apple Loops Utility” on page 618). The Apple Loops Utility does not allow you to 
create Software Instrument Apple Loops (SIALs).

Which Tool to Use, and When to Use it?
As mentioned above, Logic Pro offers Apple Loop creation facilities, and the separate 
Apple Loops Utility also allows you to construct your own Apple Loops. 

You have a fairly simple decision path to follow:
Â If you want to create an Apple Loop based on an audio file that matches the project 

tempo, use the Apple Loop creation utilities available in Logic Pro. 
Â If you want to create a Software Instrument Apple Loop (SIAL), use the Apple Loop 

creation utilities available in Logic Pro.
Â If you want to create a non-looped Apple Loop based on an audio file that does not 

match the project tempo, use the Apple Loop creation utilities available in Logic Pro. 
Non-looping Apple Loops (or one-shots) do not follow the project tempo and key. 
This is useful if you want to add discrete, non-musical sounds (such as sound effects) 
to the loop library, which should not be altered by the tempo and key properties. 

Â If you want to create a looped Apple Loop based on an audio file that does not match 
the project tempo, use the Apple Loops Utility. 
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Read the following section if you want to create Apple Loops in Logic Pro. Information 
on “Creating Apple Loops in the Apple Loops Utility” can be found on page 618.

Creating Apple Loops in Logic Pro
When you save a region as an Apple Loop in Logic Pro, the region is added to the loop 
library and appears in the Loop Browser, allowing its use in other projects. 

The tempo information of the project is used to tag the transients of user-created 
Apple Loops. This function works best if your audio files match the project tempo as 
precisely as possible.

Note:  User-created Apple Loops behave exactly like the Apple Loops that ship with 
Logic Pro, GarageBand, and Jam Packs:  They follow the tempo of your project and 
match the project key (as defined by the initial key signature). Apple Loops will also 
follow any chord transpositions in the Chord track. For further information, see the 
section on “Global Tracks and Apple Loops” on page 621.

To create an Apple Loop in Logic Pro:
1 Select the desired audio or software instrument region in the Arrange area. 

2 Choose Region > Add to Apple Loops Library in the local Arrange menu.

3 In the Add Region to Apple Loops Library dialog:

Â Type in a name for the loop, choose the scale, genre, instrument category, 
instrument name, and appropriate mood descriptions—to simplify searches.

Â Set the file type, which can be One-shot or Looped. If the length of the audio file is 
not precisely trimmed to contain a number of whole bars, One-shot is selected 
automatically, and the file type buttons are dimmed (and inaccessible). 
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Note:  One-shots do not follow the project tempo and key. This is useful if you want to 
add discrete, non-musical sounds (such as sound effects) to the loop library. It would 
generally not be desirable to have such sounds affected by the tempo and key 
properties of the project. These types of loops still contain metadata tags, allowing easy 
searching and categorization in the Loop Browser. 

4 Click Create.

The loop is added to the Loop Browser. It will be stored in ~/Library/Audio/Apple 
Loops/User Loops/SingleFiles. You can find it by using the category buttons, menus, or 
by typing the (whole or partial) name in the Search field. If you drag the loop into the 
Arrange area, the Apple Loops symbol is shown beside the file name. 

As one-shots are handled like normal audio files, the usual stereo or mono region 
symbol is shown alongside the file name (rather than the Apple Loops symbol).

If you want to create a looped Apple Loop from an audio file that does not match the 
project tempo, you should use the Apple Loops Utility. The Apple Loops Utility allows 
you to define the intended length of the loop, regardless of the project tempo, by 
manually setting the Number of Beats and Time Signature tags. 

Note:  The Apple Loops Utility only works with audio regions—not with MIDI regions 
on instrument tracks. For further information about the Apple Loops Utility, see 
“Creating Apple Loops in the Apple Loops Utility” on page 618.

You can also adjust the project tempo to the file length. Logic Pro offers an automatic 
function that matches the length of an audio region with the intended musical length. 
The length of the region remains constant, but the sequencer tempo is varied 
automatically, with the region playing back at the intended length.

To adjust the project tempo to an audio file:
1 Create an audio region that spans the complete audio file. 

2 Construct a cycle in the Arrange window Bar ruler. Set the length to match the 
intended musical length of the region. As an example:  If the audio region is one bar 
long, set a cycle length of one bar. 

3 Choose Options > Tempo > Adjust Tempo using Region Length and Locators from the 
main menu bar (or use the corresponding key command, default:  Command-T).

The tempo is recalculated, and the region (and the referenced audio file) matches the 
project tempo.
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Send Effects in Software Instrument Apple Loops
If you create a SIAL from a region on a software instrument track that uses sends to bus 
effects, and then drag the saved loop to another (empty) instrument track, the new 
loop will sound different to the original source region. This happens because the 
effects sends in the original track are not saved with the loop. 

Logic Pro does not automatically assign effects to busses, because doing so would 
potentially interfere with bus configurations that you’ve already set up in your project. 
Effects that are inserted directly into the software instrument channel will, however, be 
automatically recalled when the loop is dragged into the Arrange area from the Loop 
Browser. 

You can use one of the following options to ensure that loops created from software 
instrument regions will sound the same as the original regions:
Â Drag your SIAL (the original of which was assigned to bus sends) to an audio track 

instead of an instrument track. When you create a software instrument loop, the 
audio file that is rendered will include any bus processing. This will sound identical to 
the original. 

Â When creating a loop from a software instrument region, you should directly insert 
all effects needed to reproduce the desired sound into the instrument’s channel strip. 
This will allow all sound elements to be faithfully recreated when you add the loop to 
an instrument track. 

Â When using SIALs on an unassigned channel strip, manually set up the sends and 
bus effects needed to reproduce the sound of the original region. 

Creating Apple Loops in the Apple Loops Utility
The Apple Loops Utility provides sophisticated functions for creating Apple Loops from 
audio regions. It can detect transients present in an audio file, and you can add markers 
for additional transients. You can also move these transient markers to new locations.

To create an Apple Loop in the Apple Loops Utility:
1 Select an audio region in the Arrange area.

2 Choose Audio > Open in Apple Loops Utility from the local Arrange menu (or use the 
Open in Apple Loops Utility key command). 

If the length of your audio file does not match the beats, the following dialog appears:

There are two possible reasons for the wrong length:
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Â The audio recording was recorded at the project tempo, but not cut correctly. In this 
situation, you can reduce the length of the recording, via the dialog.

Â The loop uses a different tempo. In this case, you can set the length of the audio loop 
in the “Loop length” box and choose “Use set length”.

For more information on the Apple Loops Utility, please refer to the Apple Loops Utility 
User Manual.

Converting ReCycle Files Into Apple Loops
Logic Pro allows you to convert ReCycle files into Apple Loops. You can either import 
ReCycle files as Apple Loops or convert multiple ReCycle files with the Batch Convert 
function found in the Browser. 

To import single ReCycle files as Apple Loops:
1 Initiate a ReCycle import by using the same options as for audio files:

Â Choose File > Import Audio File (or use the Import Audio File key command). You can 
also Shift-click an audio track with the Pencil (or Command-Shift-click with the 
Pointer tool).
Select the desired ReCycle loop in the ensuing file selector box.

Â Drag the ReCycle loop from the Browser onto an audio track.
Â Drag the ReCycle loop from the Finder onto an audio track. 

2 Choose the Render into Apple Loop setting in the Fix menu of the ensuing ReCycle File 
Import dialog.

The ReCycle loop is converted to an Apple Loop (the slice points are converted to 
transient positions) and copied to the ~/Library/Audio/Apple Loops/User Loops/Single 
Files folder. The Apple Loop is added to your Logic Pro project. You can find it in the 
Audio Bin. 

As an alternative, you can use the Batch Convert function found in the Browser to 
simultaneously convert multiple ReCycle files into Apple Loops. 

To convert multiple ReCycle files into Apple Loops:
1 Select the desired ReCycle files in the Browser.

2 Open the action menu, and choose Convert ReCycle Files/Folder to Apple Loops. 

3 In the ensuing file selector box, select a location for the converted files. 



620 Chapter 28    Creating Apple Loops

The ReCycle files are converted to Apple Loops (the slice points are converted to 
transient positions) and copied to the chosen location.

Adding Apple Loops to the Loop Browser
Logic Pro must index Apple Loops before they are shown in the Loop Browser. Loops 
can reside in any directory, but you need to tell Logic Pro where to find them.

To add Apple Loops to the Loop Browser:
1 Open a Finder window alongside Logic Pro.

2 Navigate to the folder that contains the Apple Loops.

3 Select the Apple Loops in the folder and drag them into the Loop Browser.

The loops are added to the Apple Loops library and indexed. When this process is 
finished, the loops will be available directly in the Loop Browser.

If you drag a single loop to the Loop Browser, the loop will be copied to ~/Library/
Audio/Apple Loops/User Loops/SingleFiles. 

If you drag a folder of loops that are located on the same drive and partition as the 
Loop Browser, the loops will be left at their current location, and an alias of the folder 
will be created in ~/Library/Audio/Apple Loops/User Loops. 

If the loops are located on a different drive or partition, you’ll be asked whether you 
want to copy them to the loop library, or index them at their current location (loops 
added from optical media will always be copied). 
Â If you choose to copy them, the folder containing the loops will be copied to ~/

Library/Audio/Apple Loops/User Loops/. 
Â If you choose to index them at their current location, an alias to the folder will be 

created in ~/Library/Audio/Apple Loops/User Loops/. 

Acid Loops in the Loop Browser
The Loop Browser also displays Acid Loops. Acid Loops don’t contain tags like Apple 
Loops. In Acid Loops, this information is derived from the surrounding folder structure 
(especially the names of folders), which must comply with certain standards. This 
means that it’s not possible to drag an individual Acid Loop file into the Loop Browser.

As such, you need to drag the entire CD (or folder) that contains the Acid Loops into 
the Loop Browser.
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Global Tracks and Apple Loops
You can use the global tracks to change global events such as tempo, time signature, 
and key during a project. The following section summarizes how these changes in the 
global tracks affect the playback of Apple Loops. 

Tempo and Beat Mapping Track
Apple Loops adjust automatically to the tempo of these tracks.

Signature Track
Apple Loops can contain information about their original key, and can be transposed 
automatically. They will be played back at the project key by default, which is defined 
by the first key signature event. No distinction is made between major and minor keys 
for these global transposition functions; in fact, only the root of the initial key signature 
is relevant for playback of Apple Loops.

Note:  When you change the key signature after importing Apple Loops, the playback 
of SIALs is not affected. They behave like normal MIDI regions. The playback of MIDI 
regions is not affected by key signature changes, only the display in the Score Editor!

The playback transposition for Apple Loops is controlled by the root note of chords in 
the Chord track. These root notes determine the global playback transposition—
relative to the current key signature—shown in the Signature track. If no chords are 
available in the Chord track, the global playback key for Apple Loops is determined by 
the very first key signature in the Signature track (default:  C major). 

Chord Track
The root notes of chords in the Chord track determine the transposition (pitch shifting) 
of all Apple Loops.

The Change Display Only mode does not work with Apple Loops used on audio tracks. 
This shouldn’t pose a problem, as you won’t normally need this function when working 
with Apple Loops. There is one exception, however:  some Apple Loops contain chord 
progressions. These chord progressions are not displayed in the Chord track. 
Unfortunately, you can’t use the Chord track’s Change Display Only mode to match the 
displayed chords to what is actually being heard. All changes in the Chord track will 
affect the transposition of (audio, not instrument) Apple Loops. Activating the Change 
Display Only option doesn’t help. 



622 Chapter 28    Creating Apple Loops

There is, however, a solution:
1 Cut the (audio) Apple Loop at the precise positions of any chord changes.

2 Match the chords displayed in the Chord Track with the chord progression in the cut 
Apple Loop files by manually entering the chords of each section in the Chord track. 
The individual Apple Loop parts will then be transposed accordingly.

3 Enter the inverted Transposition values of the chord root note changes in the Region 
Parameter box of each section, so that playback of the Apple Loop parts will match the 
original Apple Loop file.

As an example, assuming a default project key of C:
Â The (audio) Apple Loop contains a chord progression with root notes of:  C, F, G, and 

C. Cut it at these chord change positions. This will result in four regions.
Â Enter C, F, G, and C at the corresponding positions in the Chord track. Assuming the 

original key is C, this is equivalent to a transposition of the second region by +5 and 
the third region by +7 semitones. If you played the entire part at this point, the 
original audio material would be transposed by the amounts just entered in the 
Chord track, which isn’t what you want!

Â Set the Transposition value of the second region to –5, and of the third region to –7 
in their respective Region Parameter boxes.

Playback of the whole part will now sound as it did before the cuts, and the correct 
chords are displayed in the Chord track.

Transposition Track
Transposition events are closely linked to the progression of the chord root notes in the 
Chord track:  Changing a chord root will be reflected in the Transposition track and 
vice-versa. Any alteration or creation of a transposition event will generate or alter the 
corresponding chord in the Chord track. All Apple Loops and MIDI regions will be 
pitch-shifted accordingly. 

Note:  Standard audio regions (audio regions that are not Apple Loops) will not be 
affected. Nor will Apple Loops that do not have a Key definition (drum loops, for 
example). 

The global Transpose track transposes Apple Loops used on audio tracks by a 
maximum of ±36 semitones. This is a designed limitation, as Apple Loops don’t sound 
that great when transposed over a greater range. This is also true for the Transposition 
parameter of the Region Parameter box.
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Apple Loops Transpose to the Wrong Octave
Transposing an Apple Loop to a higher pitch may result in the loop being played back 
at a lower pitch, and vice-versa. 

Example:  If an Apple Loop is transposed to sound seven semitones higher, it will 
actually play back five semitones lower. This is harmonically-correct transposition, but 
it’s probably not to the intended octave. 

Transposing audio material is a technically complicated process which always implies a 
certain loss in quality. The greater the transposition range, the more significant the loss 
in quality. This is why Apple Loops are always transposed by the smallest possible 
value. 

You should note that sound quality is dependent on the transposition amount of the 
Apple Loop’s original key—not the project key, which defines the zero line of the 
Transposition track. As an example; if the project key is already five semitones above 
the original key of an Apple Loop, setting the transposition value to +2 will transpose 
the Apple Loop downwards by ten semitones. This is because the transposition value is 
only five semitones below its original key (rather than seven semitones above it). 

In the classical European music system, an octave is divided into 12 semitones. As +7 
semitones is harmonically equal to –5 semitones, a value of –5 is used as the 
transposition amount. The same happens with other settings:  A transposition value of 
–9 will result in +3, and +12 will result in ± 0. The use of the nearest harmonically equal 
transposition option is based on delivering the best sonic results, with smaller 
transpositions being desirable.

Converting Apple Loops to Audio Files 
When you convert an Apple Loop into an audio file, the resulting file may not play at 
the project’s current tempo and key settings. Rather, the new audio file will play at the 
original tempo and key of the Apple Loop.

This happens when you select an Apple Loop and choose Audio > Convert Regions to 
New Audio Files from the local Arrange menu, and change the File Format parameter in 
the ensuing window from “Original file type” to either WAVE or SDII. This creates a copy 
of the original Apple Loop file, but without the transient and category tags. The lack of 
these tags restricts file playback to the originally recorded tempo and key of the Apple 
Loop—not the tempo and key of the project.

If you want to turn an Apple Loop into an audio file that uses the project’s tempo and 
key settings, select the loop (or loops) and choose File > Export > Region as Audio File. 
Be sure to select the “Add resulting files to Audio Bin” checkbox to use the new file in 
your current project. 
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This will export the Apple Loop as a new audio file with all plug-in effect processing of 
the track/channel on which the Apple Loop is placed. To export the Apple Loop 
without these effects, bypass them before exporting the region. 

You should note that although this new file will play at your project’s current tempo 
and key, it can’t follow subsequent tempo or key changes like other Apple Loops; such 
files are fixed at the project tempo and key—in use when the file was exported. 

∏ Tip:  If you enable the Follow Tempo option for the audio file, it will follow the project 
tempo and the first key signature set in the global tracks. For further information, see 
“Using the Follow Tempo Function” on page 526.

Apple Loops and Sample Rates
The method used to convert the sample rate of audio files also applies to Apple Loops. 
This sample conversion method also includes correction of transient positions. 

To convert the sample rate of an Apple Loop:
1 Select the desired Apple Loop in the Audio Bin.

2 Choose Audio File > Copy/Convert File(s) from the local menu (or use corresponding 
key command, default:  Control-C).

3 Choose the desired sample rate (and all other file conversion settings) in the ensuing 
dialog, select the folder location, then click Save. 

If the “Change file reference in Bin” option is activated, the sample rate converted Apple 
Loop is automatically added to the project. It will follow the project tempo and key 
changes (provided that the Key tag was set in the original loop). 

Note:  If a new Apple Loop is created, it will need to be indexed to make it visible in the 
Loop Browser. Loops can reside in any directory, but you need to tell Logic Pro where 
to find them.

You will probably not need to convert Apple Loops as often as standard audio files 
when working with Logic Pro, as Apple Loops offer a major advantage:  If the sample 
rate of your project is changed, the playback speed of all Apple Loops currently used in 
the project will automatically be adapted to the newly selected sample rate.
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29 Project and File Interchange

Moving project data between programs and devices in your 
own or external studios is commonplace these days. 

Unfortunately, not every application or device talks the same language. 

Logic Pro is compatible with a huge number of applications and devices, courtesy of 
advanced export and import facilities that allow you to use parts of, or entire, projects 
in other applications, such as Final Cut Pro and Pro Tools. Even hardware devices, such 
as workstation keyboard sequencers and digital recorders are supported.

Logic Pro can export and import the following file formats:
Â Audio files (derived from regions or tracks):  These can be saved in WAV, AIF, SDII, 

Apple Lossless, MP3, and AAC formats.
Â GarageBand projects
Â OMF (Open Media Framework, also known as OMFI—Open Media Framework 

Interchange)
Â AAF (Advanced Authoring Format)
Â OpenTL  (Open Track List) 
Â Final Cut Pro XML
Â MIDI Files (derived from selected, or all, MIDI regions)

Logic Pro makes it easy to create a complete project archive. This simplifies transfers to 
other storage media, and transport to other users or facilities—either physically or via a 
network.

You can also share settings information with other Logic Pro users on a local or remote 
network. 

Sharing Logic Pro Data Over a Network
Logic Pro allows you to share or back up your data over a network, making it easier to 
collaborate on projects with other Logic Pro users. This can be:
Â Via a local network—using Bonjour.
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Â Over the Internet—using .Mac (requires a .Mac account).

You can share and back up the following data types:
Â Plug-in settings
Â Channel strip settings
Â Key command Sets

Note:  Due to potential licensing issues with sample libraries, you can not share EXS 
instruments, Ultrabeat, or Space Designer settings.

Setting Sharing Preferences
You use the Sharing preferences to define which settings you want to share, and to 
back up your data on .Mac. 

To open the Sharing preferences, do one of the following:
m Choose Logic Pro > Preferences > Sharing 

m Click the Preferences button in the Arrange Toolbar, then choose Sharing from the 
menu.

m Click the Action menu at the bottom of the Library and choose Sharing Preferences.

Sharing is essentially broken down into two tasks:
Â Data Access:  Browse your, or other user, data on a local network or a .Mac account.
Â Data Sharing:  Share your data over a local network or via a .Mac account.

You can access data shared on a .Mac account even when the user who provided the 
data is not online.

When data is shared over a local network, the user who provided the data—or more 
accurately, the computer (user account) that the shared data originated from—must be 
online.
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To share your data:
m Turn on the appropriate checkboxes in the Bonjour or .Mac columns.

Â .Mac column:  All settings of the enabled type on your personal iDisk in /Public/
MusicAudioData are shared. 

Â Bonjour column:  All settings of the enabled type in the corresponding ~/Library/
Application Support/Logic folders are shared.

Note:  Your .Mac URL can be accessed through a web browser, if you want to browse 
outside of Logic Pro. Typically, this address will take the following form:
http://idisk.mac.com/DOTMACUSERNAME/Public/MusicAudioData

To access shared data on the local network:
m Turn on the “Look for shared data on the local network” checkbox.

This will automatically search the local network for the ~/Library/Application Support/
Logic folders of all networked machines.

To create a backup of your personal data on your .Mac account:
m Turn on the Backup all my settings on .Mac checkbox. 

This creates a copy of all of your settings data on .Mac, as a personal backup solution.

Note:  The sharing master can be different to the one used for backups. To explain:  You 
may have a studio computer that is the master for backups, and also use a MacBook to 
share (and edit) data while on the road.

Backup (and sharing) via .Mac uses a simple and straightforward push/pull concept:  
Data being backed up (or shared) always overwrites the data that exists on the .Mac 
account.
Â When you backup to .Mac for the first time, the machine being used becomes the 

master of the .Mac content.
Â When you try to back up/share data from another computer, a warning dialog 

explains that only the master machine can “push” data. This dialog includes an option 
to make the current machine the new master.

Â When you switch off the Backup all my settings on .Mac preference on the master 
machine, all backup data is removed from .Mac and the “master” is set as undefined.

Note:  When you switch off the Backup all my settings on .Mac preference, all backup 
data is removed from the .Mac account.

To restore a backup of your personal data:
1 Click the Restore Backup button. 

A confirmation dialog will launch. 

2 Click the Restore button to replace your existing settings and key commands with the 
.Mac backup.
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Note:  If the Restore process is interrupted for some reason (network problems), the 
pre-restore data is retained, ensuring that you don’t wipe out all of your settings, or end 
up with a partially restored collection. The same behavior occurs when one of the 
folders on the .Mac account is empty. 

Sharing Settings Data in the Library
When you share plug-in settings or channel strip settings by turning on the 
appropriate Sharing preferences checkboxes, additional indicators are displayed in the 
Library tab, to the left of folder and setting file icons:

Â .Mac sharing is indicated by a blue dot.
Â Bonjour sharing is indicated by a red dot.

By default, all items of the matching data type (plug-in or channel strip settings) are 
marked as shared. 

To disable or enable sharing on a per setting or folder basis:
m Control-click on individual settings or folders, and turn on or turn off the Share via 

Bonjour and Share via .Mac options as applicable. 

Note:  When the sharing status of a folder is turned on or off for either Bonjour or .Mac, 
all items in the folder are switched to the same state.
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Settings shared by other users appear as follows in the Library:

Â Bonjour folder:  Shows all shared settings on the local network. 
Â .Mac folder:  Shows all settings of .Mac accounts you are connected to.

To connect to a .Mac account:
1 Choose Connect to .Mac in the Action menu of the Library.

2 Do the following in the Connect to .Mac account:

Â Select the .Mac account you want to connect to.
You have the choice of your own account (this accesses the backup folder) or 
another account (which accesses the Public folder).

Â Input the name of the .Mac account.

∏ Tip:  You can access your own public .Mac folder by choosing another account, and 
typing in your own user name.

3 Click OK when you are done.

Note:  Data accessed through .Mac is downloaded in an on demand fashion, and is only 
stored (on the local hard disk) if you decide to do so. This is similar to settings which 
exist in a project, but are not saved as files on the hard disk.

To disconnect the active .Mac account:
m Choose Disconnect .Mac in the Action menu of the Library. 

This allows you to connect to another account, or to perform a local refresh or other 
operation, without impacting on the .Mac data.
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To refresh the Library:
m Choose Refresh Library in the Action menu of the Library. 

This refreshes both the local library and the .Mac accounts you are connected to.

Sharing Key Commands
You can access shared key command sets in the Key Commands window.

To browse for shared key command:
m Choose Options > Presets, then browse the .Mac or Bonjour folders. 

Backing Up Audio Files
The backup functions available in the Audio Bin and Sample Editor create a duplicate 
of the selected audio file (or files) in the same storage location as the originals. Backup 
files inherit the name of the source file, and are easily identified by the “.dup” file 
extension.

To create a backup of one or more selected files in the Audio Bin:
m Choose the Audio File > Backup File(s) command. Click the Duplicate button in the 

dialog.

Back up (duplicate) files can be directly added to the Audio Bin (or Arrange), just as you 
would with the original audio files.

To create a backup of the selected file in the Sample Editor:
m Choose the Audio File > Create Backup command (or use the corresponding key 

command, default:  Command-B). Click the Create button in the dialog.

Use this feature before performing a destructive editing operation in the Sample Editor, 
as it provides a “fallback” position if the audio processing produces undesirable results.

To restore the backed up file in the Sample Editor:
m Choose the Audio File > Revert to Backup command (or use the corresponding key 

command, default:  Shift-Command-B). Click the Paste button in the dialog.

Backing Up and Sharing Projects
Project folders help you to keep track of your work:  they ensure that all files related to 
a project are neatly saved in one location. This makes it easy to back up your projects 
and enables easy transfer between computers. This avoids problems such as missing 
instruments, audio files, or samples that you need to search for, or reconstruct, in the 
studio. 
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The File > Save as Project function allows you to save a project with all associated files. 
These are collectively known as the project assets.

Activation of the Include Assets checkbox in the Save As dialog will include the file 
types chosen in the Advanced Options. 

The Advanced Option checkboxes determine how files imported from external 
locations (locations outside the project folder) should be handled. 

They either:
Â Stay where they are (if the respective “Copy” checkbox is turned off ).
Â Or are copied into the project folder (if the “Copy” checkbox is turned on). 

To choose the desired project assets:
m Turn on the “Copy external audio files to project folder” checkbox to create copies of 

these files in your project folder. 

m Turn on the “Copy EXS instruments to project folder” and “Copy EXS samples to project 
folder” checkboxes do just that. If you turn off the “Copy EXS samples to project folder” 
option, only EXS instrument files will be copied to the project folder when saving, not 
the samples associated with the EXS instrument files.

m Turn on the “Copy Ultrabeat samples to project folder” and “Space Designer impulse 
responses to project folder” checkboxes to create copies of these files in the project 
folder.

m Turn on the “Copy movie files to project folder” checkbox if you want to copy the 
QuickTime movie used in the project.

Files are only copied into the project folder when the project is saved. 

Once saved, the project is “safe,” allowing you to move or copy the entire project folder 
without losing any references that point to files within the folder.

To access the project asset checkboxes at any time, do one of the following:
m Choose File > Save As.

m Choose File > Project Settings > Assets (or use the corresponding key command).
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m Click the Settings button in the Arrange Toolbar, then choose Assets from the menu.

Working With Standard MIDI Files
Standard MIDI files are not specific to a particular sequencing program, hardware 
sequencer, or type of computer. They contain the following information:
Â MIDI events, including time positions and channel assignments
Â Names of the individual tracks
Â Names and positions of markers
Â Tempo changes
Â Copyright marks

Logic Pro allows you to import, open, and export Standard MIDI file formats 0 and 1:
Â Format 0 contains all data in one track.
Â Format 1 can contain multiple tracks, each with independent data.

Neither format recognizes any division of a track (into several MIDI regions, for 
example).

Opening and Importing Standard MIDI Files
An import only loads MIDI region data (notes, controller, SysEx, pitchbend, specific meta 
events) into an opened project, with global data (such as tempo events, signatures, 
chords, track names, SMPTE start, and so on) being ignored. 

Important:  If you want to load all information contained in a MIDI file, you must open 
it. 

To import a MIDI file at the playhead position, do one of the following:
m Choose File > Import from the main menu bar (or use the Import key command), then 

select the desired MIDI file in the ensuing file selector box. 

m Locate and select the MIDI file in the Browser, then click the Import button.

The MIDI file is placed at the playhead position, rounded to bars. 

To import a MIDI file at the mouse position:
m Drag the desired MIDI file from the Browser or Finder into the Arrange area. 

The mouse position—when the mouse button is released—determines the position 
(rounded to the nearest bar) and destination of the first track in the imported file.

To open a MIDI file:
1 Choose File > Open from the main menu bar (or use the Open key command), then 

select the desired MIDI file in the ensuing file selector box. 

Note:  If you choose the MIDI files option in the File Type menu, only MIDI files will be 
displayed in the file selector box. 
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If a project is loaded, a dialog will ask if you want to create a new environment or copy 
the current environment for the MIDI file.

2 Do one of the following:

Â Click Copy to replicate the existing environment. The tracks of the MIDI file are 
automatically assigned to suitable instruments. 

Â Click New to load the environment of the default project template. 
The MIDI file is loaded as a new project that contains all MIDI events—inclusive of time 
positions and channel assignments, names of individual tracks, names and positions of 
markers, tempo changes, and copyright marks. The copyright mark is read as marker 
text.

Note:  As a default behavior, Logic Pro will automatically create software instrument 
tracks for each MIDI track, and assign an appropriate GarageBand instrument to each, 
when you open a MIDI file. If you want to use external MIDI tracks for each MIDI track, 
press Option while opening the MIDI file. 

Saving Standard MIDI Files
If you want to play a Logic MIDI project on another sequencer, you can do so by saving 
it as a Standard MIDI file. Consult the manual of the other sequencer to determine what 
Standard MIDI file formats it supports. 

Due to limitations of the Standard MIDI file format (in comparison to the Logic project 
format), you need to prepare your Logic project for export by following these steps:

To prepare all MIDI regions for a Standard MIDI file export:
1 Select all MIDI regions by choosing Edit > Select All (or using the Select All key 

command, default:  Command-A), 

2 Neutralize all playback parameters by choosing MIDI > Region Parameters > Normalize 
Region Parameters in the Arrange area (or use the Normalize key command, 
default:  Control-N). 

3 Convert all playback quantization by choosing MIDI > Region Parameters > Apply 
Quantization Settings Destructively (or use the respective key command, 
default:  Control-Q)

4 Convert all aliases into real copies by choosing MIDI > Alias > Convert to a Region Copy 
(or using the Convert Alias to a Region Copy key command).

5 Convert all loops into real copies by choosing Region > Loops > Convert to Real Copies 
(or using the Convert Loops to Real Copies key command, default:  K).

6 Convert all MIDI regions on each track into a continuous MIDI region by choosing 
Region > Merge > Regions per Tracks (or use the Merge Regions per track key 
command).
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Note:  As Standard MIDI file type 0 format files can only save one MIDI region, you must 
also merge all MIDI regions into one if you want to export in file format 0. You can do 
this by choosing Region > Merge > Regions.

7 Insert all instrument MIDI settings as events by choosing MIDI > Insert Instrument MIDI 
settings as Events.

To save MIDI regions as a Standard MIDI file:
1 Select all of the required MIDI regions.

2 Choose File > Export > Selection as MIDI File (or use the Export Selection as MIDI File 
key command, default:  Command-E). 

3 Choose the destination directory, enter the desired name, then click Save. The selected 
MIDI regions are saved as a Format 1 MIDI file.

Note:  Remember that most hardware sequencers can only read MS-DOS formatted 
disks, so limit your file name to an 8.3 character name. As an example:  “proj0001.MID”.

To save a MIDI region in file format 0:
m Enable the “‘Export MIDI File…’ saves single MIDI Regions as Format 0” checkbox in the 

Project Handling tab of the Global preference pane (Logic Pro > Preferences > Global).

When this preference is turned on, choosing File > Export > Export Selection as MIDI 
File when only one MIDI region is selected will automatically export the region as file 
format 0 MIDI file.

Importing GarageBand Projects
You can open a GarageBand project in Logic Pro just as you would open a Logic Pro 
project. The GarageBand project translates 1:1 into Logic Pro:
Â Logic Pro will automatically create the required number, and type, of tracks to mirror 

those used in the GarageBand project.
Â The project uses the tempo of the GarageBand project.
Â The initial key signature is set in accordance with the “project key” of the GarageBand 

project. 
Â Software instrument parts will be played by GarageBand instruments in Logic Pro. 

GarageBand instruments are automatically installed with Logic Pro. Further to this, 
any mixing data and effects (plus their settings) used by software instruments or 
Apple Loops-based tracks in GarageBand will also be imported into Logic Pro.

Â The Channel Strip settings of GarageBand translate 1:1 into Logic Pro—with the nice 
exception that you can now access the individual plug-ins that are inserted into a 
GarageBand channel strip. 

Â The two bus effects of GarageBand (Reverb and Echo) are also translated when 
opened in Logic Pro. They are replaced by the PlatinumVerb and Echo on busses 1 
and 2.
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Once the GarageBand project is loaded into Logic Pro, you may freely change parts, 
mixing levels, instrument, and effect parameters as in any Logic Pro project.

Note:  You can not open Logic Pro projects in GarageBand, nor can you export a 
Logic Pro project in a format that can be read by GarageBand (apart from as an audio 
file).

Working With OMF Files
The OMF file format is typically used to exchange data with Digidesign Pro Tools 
software. The OMF format only supports the exchange of audio data (audio media and 
the use of this audio media in a project)—MIDI and automation data is ignored when 
using the export functions. 

Exporting OMF Files
m To export the current project as an OMF file, choose File > Export > Project as OMF File 

(or use the Export Project as OMF File key command). 

Choose the required options in the dialog that launches:

Â OMF File Version:  You can choose to export the file in OMF Version 1 or Version 2 
format. You will usually choose Version 2 here. Version 1 is only useful for backwards 
compatibility with older software versions.

Â Include audio:  Turn this on to integrate all exported audio files into the OMF file 
itself. This can result in a very large file, and can make file export times lengthy. Turn 
off this checkbox to only write file references to the OMF file. 

Note:  If the later option is chosen and you wish to copy the OMF file to another hard 
disk, you will need to ensure that all referenced audio files are also copied.

Â Convert interleaved to split stereo:  As some applications don’t support interleaved 
stereo files, Logic Pro can convert interleaved stereo files to split stereo (when 
exporting an OMF file for a Pro Tools session, for example). Turn on this checkbox if 
this is the desired behavior. 

Note:  This only works if the “Include audio” option is turned on.

Â Convert 24 bit files to 16 bit:  Turn on this option to convert all 24 bit files to 16 bit, 
using the chosen dithering type. This might be necessary when using older versions 
of Pro Tools.
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Â Dithering:  When exporting 24 bit recordings as 16 bit audio files that are included in 
the OMF file, dithering is recommended (see “Bouncing and POW-r Dithering” on 
page 613).

Importing and Opening OMF Files
The following procedure is identical for both importing and opening OMF files. 
Importing copies the OMF data into the current project, whereas opening an OMF file 
will create a new project.

To import or open an OMF file:
1 Do one of the following:

Â Choose File > Import (or use the corresponding key command, default:  Command-I).
Â Choose File > Open (or use the corresponding key command, default:  Command-O).
Â Locate the Open TL file in the Browser, then click the Open button. 

2 Choose the desired OMF file from the file selector box. 

∏ Tip:  If you choose the OMF files option in the File Type menu, only files with the “.TL” 
extension will be shown. 

After choosing and confirming the file import, a further dialog allows you to define the 
target location for audio data extracted from the OMF file. 

3 Choose an existing folder (this defaults to the open project folder), or create a new one.

The OMF file is imported into the currently open project. New audio tracks are 
generated for every track contained in the OMF file, and the audio parts are placed 
appropriately on these tracks (as regions).

Working With OpenTL Files
The OpenTL format is mainly used for data exchange with Tascam hard disk recorders, 
such as the MX2424. It only supports the exchange of audio data (audio media and the 
use of this audio media in a project)—MIDI and automation data is ignored when using 
the export functions. 

Exporting OpenTL Files
1 To export the current project’s audio in the OpenTL format, choose File > Export > 

Project as OpenTL File. 

2 This will launch a file selector dialog, where you can specify the destination folder, and 
file name, of the resulting OpenTL file. After confirming this dialog, Logic Pro will ask if 
you want to create a dedicated folder for the OpenTL export.

3 Click Create to have all exported files placed in one folder, which is named after the 
exported file. This is the convention used by the Tascam MX recorders, so it is 
recommended.
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4 Next, Logic Pro will ask if the project’s SMPTE start time should be added to event start 
positions. In this scenario, audio parts in the resulting OpenTL file will have the same 
SMPTE start time as in the Logic project. If you click Don’t Add, the part positions are 
calculated relative to the project start position (an audio part that starts at bar 1 will 
have a start time of 00:00:00:00.00).

5 At the next step, Logic Pro will ask if a copy of all audio files should be made. You 
should choose Make Copy if you want to copy the resulting OpenTL file, including all 
audio data, to another hard disk. 

Logic Pro will then create two sub-folders in the folder that contains the OpenTL file:  
namely Audio Files and Track Files (which is the suggested structure for OpenTL 
exports). The Audio Files folder will contain copies of all exported audio files. If you 
choose Don’t Copy, the file references in the OpenTL file will point to the original audio 
files.

Opening and Importing OpenTL Files
The following procedure is identical for both importing and opening OpenTL files. 
Importing copies the OpenTL data into the current project, whereas opening an 
OpenTL file will create a new project.

To import or open an OpenTL file:
1 Do one of the following:

Â Choose File > Import (or use the corresponding key command, default:  Command-I).
Â Choose File > Open (or use the corresponding key command, default:  Command-O).
Â Locate the Open TL file in the Browser, then click the Open button. 

2 Choose the desired OpenTL files from the file selector box. Note that if you choose the 
Open TL files option in the File Type menu, only files with the “.TL” extension will be 
shown. 

3 Dependent on where the first event in the imported project starts, one of the following 
dialogs will appear:

Â If the first event in the imported project starts at a time greater than 1 hour:
Set SMPTE start time of project so that events start at the same SMPTE time as they do in 
the imported project? 

Choose Set if you want the SMPTE start time of the project to be changed 
accordingly, or click Don’t Set if you don’t want to change the SMPTE start time of 
the project.

Â Should the first audio part found by the OpenTL import have a start time greater 
than zero (less than zero is impossible), but less than 1 hour:
Set the start time of first imported event to start of project? 

If you choose Set, the first audio part imported will be placed precisely at the project 
start position. 
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This solves the problem of the project on the Tascam machine starting at a large time 
value, but less than 1 hour (such as 59 minutes). In this situation, you can’t immediately 
see the imported audio parts because they may be imported beyond the project’s end 
point, and almost certainly outside the visible window area.

Opening, Importing, and Exporting AAF Files
AAF (Advanced Authoring Format) is used by other DAW applications such as Pro Tools. 
You can use it to import multiple audio tracks, inclusive of references to tracks, time 
positions, and volume automation.

To export the current project as an AAF file:
1 Choose File > Export > Project as AAF File (or use the Export Project as AAF File key 

command). 

2 In the Save AAF File As dialog, choose the following pop-up menu options:

Â Sample Rate:  Choose 44.1 kHz, 48 khz, 88.2 kHz, or 96 kHz.
Â Bit Depth:  Choose either 16 or 24 bit.
Â File Format:  Choose WAVE or AIFF.
Â Dither Type:  Choose None or any of the three POW-r algorithms (see “Bouncing 

and POW-r Dithering” on page 613).

3 Choose a location, enter a name for the file, then click OK. 

The export includes all used regions, inclusive of track and position references, and 
volume automation.

To import an AAF file:
m Do one of the following:

Â Choose File > Import (or use the Import File key command), then choose the AAF file 
in the Import dialog. 

Â Locate the AAF file in the Browser, then click the Open button. 

To open an AAF file:
1 Choose File > Open. 

2 Choose the AAF file in the Open dialog.
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Importing and Exporting Final Cut Pro XML Files
The Final Cut Pro XML format is used to import and export audio data between Final 
Cut Pro and Logic Pro. The Final Cut Pro XML format supports automation data.

To export the current project as a Final Cut Pro/XML file:
m Choose File > Export > Project to Final Cut Pro/XML. 

This will launch a standard file selector dialog, allowing you to name the export file.

Note:  Audio Instrument tracks are always bounced to audio files. MIDI tracks are 
ignored. Bouncing will automatically switch to real time mode, if necessary (such as 
when an I/O or External Instrument plug-in is used).

To import Final Cut Pro XML files, do one of the following:
m Choose File > Import, then choose the file in the Import dialog. 

m Locate and select the file in the Browser, then click the Open button. 

Changing or Retaining the Final Cut Pro Sample Rate
The XML import procedure allows you to retain the sample rate of audio files used in 
your Final Cut sequences. If you import sequences that use audio files with different 
sample rates, the following dialog appears:

Click one of the buttons to choose if you want to:
Â Alter the sample rate of your Logic Pro project to match all imported Final Cut 

sequence audio files. 
Â Retain the sample rate of your Logic Pro project. All Final Cut sequence audio files 

that use a sample rate that differs from the selected one are converted.

Note:  A Final Cut sequence is an arrangement of video, audio, and graphic clips, edit 
information, and effects—which combined, create a movie. Use of XML to import Final 
Cut sequences into Logic Pro allows you to exchange multiple audio tracks, with all 
positional region information, region names, volume and pan automation data, 
retained.
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Exporting Regions
The File > Export menu also features several Export functions for regions and tracks. 
These allow you to render audio or software instrument tracks with all active effects 
and automation data (except volume and pan) into a new audio file. 

Note:  Rendering with no volume and pan automation is generally desirable, as the 
export functions are most commonly used to transfer your tracks or regions to an 
external application for processing, mixing, or editing. 

To export an audio or software instrument region as an audio file:
1 Select the region in the Arrange area.

2 Choose the File > Export > Region as Audio File command in the Arrange area. 

3 Choose the desired options by clicking on the pop-up menus in the Save Region As 
dialog.

4 Use the file selector to browse to, and choose the target folder for the new audio files. 
You may also create a new folder, by clicking the New Folder button. 

5 Enter a name for the new audio file. The Hide Extension checkbox hides or shows file 
extensions (wav, aif, and so on) in the Save As: field.

6 Click the “Add resulting files to Audio Bin” checkbox if you want to add the file(s) to the 
Audio Bin, following the save. 

7 Click the Save button.

Exporting Tracks as Audio Files
It is also possible to export one or more tracks (all audio or software instrument regions 
on one or more tracks) to a new audio file, or several audio files—one for each Arrange 
track.

To export all audio or software instrument regions on a track to a new audio file:
1 Click on the desired track name.

2 Choose File > Export Track as Audio File.

3 Provide a name and destination, and make other choices in the Save As dialog, then 
click Save.

To export all audio or software instrument tracks to several new audio files:
1 Choose File Export All Tracks as Audio Files. No track selection is required.

2 Make your choices in the Save As dialog, and click Save. 

Exported audio files are named after the source track(s), so if track 1 is called “Drums,” 
track 2 “Bass,” track 3 “Guitar,” and so on, the resulting files will be named accordingly.



30

     641

30 Advanced Tempo Operations

Logic Pro provides several different tools and methods for the 
creation and editing of tempo events.

This chapter discusses these tools, and covers the relationship between tempo events 
and MIDI and audio regions.

Tempo can be changed or edited in the Transport bar, the global Tempo track, the 
Tempo List (in the Lists area), with the Tempo fader in the Environment, or with the 
Tempo Operations window. In most cases, the global Tempo track or Tempo List will be 
your first port of call.

Tempo Display
The current tempo (at the playhead position) is always displayed on the Transport bar, 
even if you’re using programmed tempo changes or external synchronization.

To set a constant project tempo:
m Use the mouse as a slider or double-click, and directly type in a value, on the Tempo 

field. 

To change the format of the tempo display:
m Open the Logic Pro > Preferences > Display > General preferences tab, and choose the 

desired item from the Display Tempo As pop-up menu.

Tempo display
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Using the Tempo Track
Tempo changes are controlled by tempo events, which are stored in a special Tempo 
track. This track can be displayed in the Arrange, Piano Roll, Hyper, and Score Editor 
windows. The Tempo track applies to the whole project. The tempo track also 
determines the relationship between incoming time code and the current playhead 
position.

To view the Tempo track, do one of the following:
m Choose View > Global Tracks (or use the corresponding key command, default:  G).

m Click the disclosure triangle to the left of the Bar ruler in any of the linear editing 
windows.

Note:  By default, the global Marker, Signature, and Tempo tracks will be visible when 
you use any of the methods above to open the global tracks lanes. If the Tempo track is 
not visible, you can configure the global track display to fit your needs. For more 
information, see “Showing and Hiding Individual Global Tracks” on page 76.

The Tempo track displays tempo changes as nodes:  dots connected by lines. By 
default, these dots are followed by horizontal lines that continue to the next node, 
which is aligned with a project position (shown in the Bar ruler). At this point, a vertical 
line is connected to the node of the ensuing tempo change. This creates a series of hills 
and valleys that represent the project tempo.

Note:  The tempo will be indicated numerically (in bpm) alongside each node, if the 
vertical height of the Tempo track is adequate.

To resize the Tempo track:
m Drag the horizontal line that separates the Tempo track lane from the editing window 

or the global track (Transposition, for example) above it.

Creating and Deleting Tempo Change Events
You can create tempo change events by inserting them into the Tempo track at the 
desired project position. 

To insert a tempo change event, do one of the following:
m Double-click at the desired position with the Pointer tool.
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m Click at the desired position with the Pencil tool. 

Keep an eye on the help tag when using the Pencil tool, and don’t release the mouse 
button until the intended tempo and position are indicated. No help tag appears when 
the Pointer double-click method is used.

m Hold Control-Option-Command and click at the desired position in the Tempo track. 

A text field opens, allowing you to type in the desired bpm value. Press Return, and a 
tempo event of this value will be created.

To delete a tempo change, do one of the following:
m Select it, by either clicking the node itself or the line to the right, then choose Edit > 

Delete (or press Backspace). 

m Double-click on the node with the Pointer Tool.

m Click on the node with the Eraser tool. 

Creating Tempo Curves
To create a continuous transition between two tempi, click-hold and drag the tip of the 
right angle line (the corner) above or below the second node. 

A curve or diagonal line will result (a Move Curve Node help tag is shown), which can 
be dragged as desired—horizontally and vertically—to alter the curve shape. You’ll find 
that this is quite similar to drawing track automation curves with the mouse.

To make a tempo curve more, or less, precise:
m Choose the desired value from the Resolution pop-up menu in the Tempo track to 

define the number of tempo changes that are actually performed when using curves.
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When set to 1/16, there will be four tempo changes per quarter note, 1/1 will only 
generate one tempo change per bar, which will result in a coarser transition. A different 
resolution can be defined for each node.

To delete a tempo curve:
m Click the handling node (at the tip of the right angle) with the Eraser tool, or double-

click on it with the Pointer.

Moving, Altering, and Copying Tempo Changes
To move a tempo change event, grab the node (or the line to the right) and drag it left 
or right.

To make finer tempo change movements:
m Hold Shift while dragging the desired node left or right.

To move the selected tempo event to the current playhead position:
m Use the Pickup Clock Position key command.

To change the value of a tempo change event:
m Simply drag the node (or line) up or down. A help tag will display the tempo value.

The display range (the scale shown to the left) of the tempo track is automatically 
adjusted when you choose a value that exceeds the current minimum or maximum 
value (see below).

Note:  To prevent unintentional changes, nodes are restricted to either vertical or 
horizontal movement for each operation. Put another way, you can either change the 
value or position of a tempo change event, but not both at once. 

To copy a tempo change event, do one of the following:
m Hold Option, while dragging a node. 

m Use the standard Copy and Paste procedure (via the Edit menu or the corresponding 
key command). The playhead will determine the target position for the first pasted 
event. 

To copy or move multiple tempo events:
m Shift-click or rubber-band select (while pressing Control), and drag all nodes to the 

target position. 

Note:  Any tempo events at the target positions will be replaced by the moved or 
copied events.

Adjusting the Display Range
The display range for tempo events is, as mentioned above, adjusted automatically. 
Dragging a node beyond the current maximum or minimum scale boundaries will 
result in an automatic adjustment of the range. 
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To manually define the maximum and minimum ranges of the tempo display, do 
one of the following:

m Grab the maximum and minimum values in the tempo scale and drag them vertically.

m Double-click on either range value and type the desired numerical value into the text 
field.

These user-defined values are displayed in yellow. If you want to return to the 
automatic scaling mode, use the procedure described above, and leave the text fields 
empty.

Switching Between Tempo Alternatives
The Alternative pop-up menu in the Tempo track allows you to switch between 
different tempo maps. Put another way, you can create up to nine different tempo track 
versions per project, and switch between them.

The original tempo track is automatically assigned to Alternative 1.

To create an alternate tempo map:
m Choose an unused number (2 through to 9), and create the desired tempo events.

This will be a blank tempo map, that contains one tempo event at the beginning of the 
project.
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To copy all tempo events from one tempo alternative to another:
m Hold Option, and choose the target tempo alternative from the pop-up menu.

This creates a replica tempo map, which can be adjusted slightly, allowing you to 
experiment with small tempo variations, while retaining a fallback map.

The Relationship Between the Tempo and Beat Mapping Track
Actions performed in the Beat Mapping track result in changes to the Tempo track. 
These include alterations to existing, or the creation of new, tempo change events.

Given this behavior, you should avoid making changes in the Tempo track after using 
Beat Mapping functions. If you do so, the timing derived from the Beat Mapping 
functions will be destroyed. For more information about the Beat Mapping track, see 
Chapter 31, “Beat Mapping Regions,” on page 655. 

Recording Tempo Changes
All tempo alterations made when Logic Pro is in record mode are automatically stored 
as tempo events on the Tempo track. These events can be created with external MIDI 
controllers, the Environment tempo fader, or external synchronization signals. You can 
edit recorded tempo events in the Tempo track or one of the tempo editors, discussed 
later in this chapter. 

To enable tempo change recording:
m Turn on the “Allow tempo change recording” checkbox in File > Project Settings > 

Recording. 

Adjusting the Tempo to Fit Audio Regions
The Options > Tempo > Adjust Tempo using Region Length and Locators command 
adjusts the project tempo, by creating a tempo change event at the start point of the 
selected audio region. This ensures that the length of the selected audio region exactly 
matches the distance between the locators.

For more information on this function, see “Setting the Project Tempo to Match an 
Audio Region” on page 524.

Using the Tempo List
The Tempo List displays all tempo events in your project. You can open the Tempo List 
in the Arrange window, and as independent window. 

To open the Tempo List, do one of the following:
m Click the Lists button in the Arrange Toolbar, then click the Tempo tab (or use the 

Toggle Tempo List key command).
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m Choose Options > Tempo > Open Tempo List (or use the Open Tempo List key 
command).

Creating and Editing Events in the Tempo List
The layout, and way you use the Tempo List, are very similar to the Event List. The 
following section only outlines the most important Tempo List operations. For more 
information on general (and identical) Event List operations, see Chapter 18, “Editing 
MIDI Events in the Event List,” on page 437.

To create a tempo event in the Tempo List:
1 Move the playhead to the desired project position.

2 Click the Create button, or click below the bottom tempo event with the Pencil tool.

A tempo event (which uses the current project tempo value) appears. You can alter the 
value in the Tempo column.

To delete a tempo event in the Tempo List, do one of the following:
m Click the tempo event with the Eraser tool.

m Select the tempo event, then choose Edit > Delete (or press Backspace). 

To change the position of a tempo change event:
m Use the mouse as a slider, or double-click and directly type in the desired values in the 

Position or SMPTE columns. 

To move any selected tempo event to the current playhead position:
m Use the Pickup Clock Position key command.
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To copy tempo changes from a passage:
1 Set the locators to the passage containing the correct tempo change.

2 Choose Edit > Select Inside Locators.

3 Copy the tempo events to the Clipboard (Command-C).

4 Deselect all tempo events (by clicking the background).

5 Paste the tempo events from the Clipboard (Command-V).

6 The paste position will default to the current playhead position, but this can be 
changed. A position input box appears alongside the first of the pasted tempo events, 
allowing you to alter the bar position. If the first tempo change is not at the start of the 
bar in the passage, be sure to alter the bar number, and leave the beat, sub beat, and 
frame or tick values unaltered.

7 Press Return. The copied tempo changes will be selected, and you can undo the 
operation if necessary.

Using the Shortcut Menu
Many selection, editing, and other commands can be accessed by Control-clicking or 
right-clicking anywhere in the window. Make use of this to accelerate your workflow.

Note:  Right-click functionality is dependent on the Right Mouse Button: Opens 
Shortcut Menu option being chosen in the Logic Pro > Preferences > Global > Editing 
tab.

Alternative Tempo Lists
You can use up to nine different Tempo List variations per project. This is useful in 
projects with tempo changes, as it allows you to:
Â Temporarily slow down the tempo when recording MIDI regions.
Â Temporarily disable tempo changes.
Â Try out different tempo variations.

To switch between the different Tempo Lists:
m Choose Options > Tempo Alternatives, and choose the desired Tempo List.

Synchronization and Video Options
The Tempo List window features a SMPTE Frame Rate menu and Detect checkbox. By 
default, the Detect checkbox is turned on, which means that Logic Pro will 
automatically detect the frame rate of incoming synchronization signals. 

As a general rule, this is ideal when working with external video and film playback 
devices.
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When working with a video file stored on a connected hard disk, Logic Pro will 
(generally) not be receiving an external synchronization signal. Even in this situation, 
you can leave the Detect checkbox turned on.

When Logic Pro is the master synchronization device, however, you do not want it to 
accept incoming time code signals. In this situation, turn off the Detect checkbox, and 
choose a suitable rate from the Frame Rate pop-up menu.

Note:  The Detect checkbox mirrors the “Auto detect format of MTC” project setting, 
and the Frame Rate menu mirrors the Sync project setting menu of the same name. For 
more information, see Chapter 36, “Synchronizing Logic Pro,” on page 829.

Using the Tempo Operations Window
The Tempo Operations window is used to edit existing tempo changes, and to create 
new ones. The window automatically displays the area you’ve selected for editing, and 
changes are displayed graphically, in real time, as the tempo curve is processed, so you 
can see what’s happening. 

To open the Tempo Operations window:
m Choose Options > Tempo > Tempo Operations from the main menu bar (or use the 

Open Tempo Operations key command.

m Control-click the Sync button in the Transport bar (if visible), then choose Open Tempo 
Operations from the shortcut menu. 



650 Chapter 30    Advanced Tempo Operations

Choosing a Tempo Operation
The Operation menu provides several interesting tempo change editing functions, 
which also alter the sync reference. The lock symbol allows certain parameters to be 
fixed, preventing them from being changed. 

Create Tempo Curve
The Create Tempo Curve operation lets you create numerous tempo change events 
with just a few parameters, and provides a smooth overall change in tempo.

To create a tempo change in the Tempo Operations window:
1 Use the Position or Time fields to define the area that the tempo change should take 

place across:  the left field sets the curve start point and the right field, the curve end 
point.

2 Enter the desired start and end tempos in the Tempo line.

3 Select the desired curve type.

Three kinds of tempo curves are available from the Curve Type menu. Each of these 
offers a Curvature parameter (the field to the right of the Curve Type menu), which 
determines if the tempo should speed up or slow down, dependent on whether 
positive or negative curvature values are entered.

4 Adjust the Curvature parameter.

5 Alter the concentration of graphical tempo events with the Density parameter.

Values of 1/8 and finer should only be used if really necessary (with very slow or fast 
tempo changes, for example). Don’t select a resolution higher than 1/8 or finer, just to 
make the curve look smoother. This results in an unnecessary amount of processing, 
and the creation of more tempo events than are needed.

∏ Tip:  Watch the graphic display, as you change the values:  The displayed tempo curve 
(which is calculated from the tempo settings you’ve made) is shown in red.

Note:  The “Continue with new Tempo” checkbox determines whether the original 
tempo resumes after the tempo curve ends (unchecked), or the new tempo (the last 
tempo change event in the curve) is maintained (checked). 

6 Click Apply when you are done. 
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Create Constant Tempo
The Create Constant Tempo operation creates a constant tempo in any selected area. 
The default setting assigns an average tempo for the selected project section (based on 
existing tempo change events).

If you want to remove all tempo variations between two points, without changing the 
SMPTE time for the right-most position, just click the Apply button.

Don’t forget the “Continue with new Tempo” checkbox, which retains the new tempo 
or returns to the initial tempo.

Scale Existing Tempo Changes
The Scale Existing Tempo operation alters existing tempo changes proportionally 
(scales them). This enables you to speed up an entire project section, without losing 
the relationships between any subsequent tempo changes within the area. Scaling is 
done by percentage. Positive percentage values speed up sections, and negative ones 
slow them down.

Stretch Existing Tempo Curve
The Stretch Existing Tempo Curve operation stretches or compresses an existing tempo 
curve. The Position or Time parameters are used to define the start point of the area 
that you want to change. You can then enter either the new end point of the tempo 
curve as a bar position or SMPTE value, or set a Stretch value for the curve (as a 
percentage).

Thin Out Existing Tempo Changes
The Position or Time fields define the start and end points of the area to be processed. 
Density determines the number of tempo events that will remain per bar after 
processing. You can select values between one tempo change event per bar (1/1) and 
32 per bar (1/32).

Randomize Tempo
Use the Position or Time parameters to define the start and end points of the area to 
be processed. Use Randomize to determine the amount of deviation from the current 
tempo, in beats per minute (bpm).

Density defines how often the new tempo events will occur. You can select values 
between one per bar (1/1), and 32 times per bar (1/32).
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Using the Tempo Interpreter
You can use the computer keyboard or incoming MIDI events to set the project tempo. 
Put another way, Logic Pro will chase a manual synchronization signal (also known as 
human sync). This method of synchronization is fairly loose, in that if the manual sync 
impulses stop coming in, Logic Pro will continue at the last tempo it received.

You use the Tap Tempo command to generate tempo timing events, by literally tapping 
a computer or MIDI keyboard key.

To enter manual synchronization mode, do one of the following:
m Choose Manual in the Sync Mode menu of the File > Project Settings > Synchronization 

> General tab.

m Turn on the “Auto enable external sync” checkbox (on by default) in the Project Settings 
> Synchronization > General tab. 

If Logic Pro “hears” a Tap Tempo command, it will automatically follow this tempo.

The parameters that control how Logic Pro responds to tap tempo commands can be 
found in the Tempo Interpreter window.

To open the Tempo Interpreter window, do one of the following:
m Choose Options > Tempo > Tempo Interpreter (or use the Tempo Interpreter key 

command).

m Control-hold on the Transport’s Sync button (if visible), and choose the Open Tempo 
Interpreter item.

Note:  Only the selected software instrument track, and all external MIDI tracks, can play 
when the Tempo Interpreter window is open.

Changing the Tempo Interpreter Parameters
You will find the following parameters in the Tempo Interpreter window. 

Tap Step
This parameter sets the note value that Logic Pro will assign to manual taps. You will 
achieve the best results with larger, rather than smaller, values. 1/4 note usually works 
well.
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Window 
This parameter determines the time span (or window) that tap notes can be entered 
(set in ticks, or 1/3840 note). Only taps made within this time window are used to 
determine the tempo. Any taps outside it are ignored.
Â The narrower the window, the more effectively Logic Pro will be able to withstand 

the influence (on the tempo) of any taps that fall between the note values—set with 
the Tap Step parameter. 

Â The larger the window is set, the easier it becomes to create drastic tempo changes.
Â If you set the window parameter to 0, the tap window will disappear altogether, and 

all taps will be accepted as tempo-determining information. Logic Pro will also come 
to a halt, if taps are not generated.

Tempo Response
This parameter sets the sensitivity to tempo changes:  the larger the value, the greater 
the sensitivity. You should set this value to 4, for most situations. If you find that your 
tap timing is imprecise, but want Logic Pro to play at a relatively constant tempo, 
reduce this value to 2 or so.

Max. Tempo Change
Use this parameter to set the maximum tempo change possible per tap (in bpm). To 
obtain the most regular, or even tempo curve, follow this rule:  set the smallest possible 
value (in other words, only as large as necessary).

Tap Count-In
This sets the number of taps used as a count-in. Logic Pro will start following the 
tempo on the first tap after the count-in taps.

Smoothing
Switching on this function smooths out jumps in tempo, resulting from incoming taps 
(which could prove useful when using Logic Pro live). You should switch it off, if you 
want Logic Pro to follow your taps precisely and quickly.

Tempo Recording
The Tempo Recording function creates a tempo list that follows your taps, when in 
record mode. This Option should normally be switched off.

Pre and Post
These are the ways your tap signals are displayed:
Â Pre:  Displays every incoming tap.
Â Post:  Displays every accepted tap that occurs within the time window (as defined by 

the Window parameter), or close to, or on, a tap step.

The Pre/Post tap signals flash yellow if the taps are within the allowed range, and red if 
they are out of range.
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Using the Tempo Fader
You can create a real time tempo fader in the Environment window by choosing New > 
Fader > Specials > Tempo Control. This fader can control the project tempo (using Meta 
event #100). There is no need to connect this fader to anything, unless you want to 
record its output.

A tempo fader has a range of possible values from 50 to 177 bpm. External MIDI data 
can be used to control it, with an input value of 0 resulting in a tempo of 50, and an 
input value of 127, resulting in a tempo of 177.

If you place a tempo fader between the Physical Input and Sequencer Input objects in 
the Environment, you will be able to:
Â Record tempo changes.
Â Control the tempo with any desired MIDI event types.

This way, new Tempo track data can be recorded intelligently. The original tempo data 
will only be erased in areas that actually contain tempo changes.

If a tempo fader is moved during playback or recording, all data defined in the Tempo 
List is switched off, until Logic Pro is stopped.

Movements of a tempo fader are ignored when external SMPTE sync is active. A tempo 
fader can therefore be used to deactivate the sync reference during playback or 
recording, if you wish.

Note:  The tempo fader’s Parameter box displays pitch bend events as the Input 
definition (by default). This allows control of the project tempo with your keyboard’s 
pitch bend wheel.
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31 Beat Mapping Regions

You will generally play to a metronome click when recording 
in Logic Pro. There are, however, instances where you’ll want 
to record without a click, playing rubato, or at least not at a 
strict same tempo throughout. 

Another situation may be where you have an existing audio recording—that wasn’t 
recorded to a metronome click, and therefore contains slight tempo variations—that 
you want to add additional tracks to. In this scenario, the Beat Mapping track helps to 
make the display of these free recordings rhythmically meaningful. It does this by 
defining the bar positions of existing musical events, without changing their absolute 
time position, thereby preserving the audible result with its original timing. 

Musical events, in this context, refer to:
Â MIDI notes in MIDI regions.
Â Transients in audio regions—which correspond to the beginning of strongly 

accented notes.

Beat mapping involves two steps:  First, you graphically connect musical events to the 
desired bar positions in the Beat Mapping track—by drawing lines between them with 
the mouse (a more detailed description of this procedure follows). Logic Pro will 
automatically insert a tempo change event for each of these bar position locations. This 
results in the note/event being played at its previous absolute time position, despite its 
altered bar position. A beat mapped Logic Pro project will contain the same tempo 
variations as the original recording.

Presuming accurate beat mapping, everything will be in time with the metronome 
tempo, affording you a number of advantages for further project development:
Â The metronome click can be used when recording additional regions.
Â Quantize functions can be applied to newly recorded regions.
Â Loops (both MIDI and Apple Loops) will automatically adjust to the tempo when 

used in the arrangement.
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Â MIDI regions recorded without a click will be displayed in a musically meaningful 
way in the Score Editor.

Â Additional MIDI regions can also be created via the Step Input function, without 
sounding too stiff. This looser feel is due to the parts being played back with all of 
the tempo changes created by the beat mapping process.

By default, the global Marker, Signature, and Tempo tracks are visible when you enable 
the display of global tracks. If the Beat Mapping track is not displayed, choose View > 
Configure Global Tracks, and enable the Beat Mapping checkbox. For detailed 
instructions, see “Showing and Hiding Individual Global Tracks” on page 76. 

Beat Mapping With MIDI Regions
The following section takes a look at the beat mapping procedure in the Arrange 
window. Beat mapping is also possible in the Piano Roll, Score, and Hyper Editor 
windows, where you have the added advantage of directly seeing the corresponding 
notes. To use (or test) beat mapping, you’ll need at least one MIDI region that doesn’t fit 
the current tempo. You can simply record one without a metronome click, if none are 
available.

In the upper part of the Beat Mapping track, you can see a ruler which contains a 
graphical representation of musical bars, beats, and sub-divisions. These reflect the 
division value set in the Transport bar (and are also dependent on the current zoom 
level). 

To allocate note events to particular bar positions:
1 Select the regions that you want to use for beat mapping. Once selected, short 

horizontal lines will appear at the lower edge of the Beat Mapping track. These 
represent the notes in the selected regions.

2 Start from the left. At the first bar position you want to assign to a MIDI note:  Click-
hold at the exact position in the Bar ruler. 

A yellow vertical line will appear. 

3 With the mouse button still held, drag the cursor down towards the line that represents 
the chosen note. 
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A second, slightly darker, yellow line—which is still connected to the same position in 
the Bar ruler—will appear. This line will follow the movement of the mouse cursor into 
the lower part of the track, forming an angle. Once this line is connected to the desired 
note, release the mouse button.

Logic Pro will automatically calculate, and insert, a tempo change—which can be seen 
in the Tempo track. This ensures that the allocated note (and all other notes) will be 
played back at the same absolute time position as before, despite their altered bar 
positions.

4 Move from left to right, adjusting further events along the time axis, to obtain the best 
beat mapping results.

If you make a mistake, you can erase any beat allocation by:  double-clicking on it, 
using the Eraser tool, or by selecting it and pressing Backspace. Take care when using 
Backspace, to avoid the accidental deletion of other currently selected events or 
regions.

To erase all beat allocations, click anywhere in the track header of the Beat Mapping 
track (except on the buttons and menus). This selects all data in the track, allowing you 
to press Backspace to delete all events.

Note:  If you want to draw a connecting line from a bar position to a particular position 
in the original recording—where no note exists—hold Control while drawing the 
connecting line with the mouse. This will allow the line to snap to any sub-division.
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Beat Mapping With Audio Regions
This works in a similar fashion to that described above for MIDI regions. The main 
difference is that Logic Pro must first analyze audio regions in order to find rhythmically 
prominent spots, which can subsequently be linked to a bar position. Logic Pro 
searches for transients when analyzing audio regions. Transients are positions where 
the audio recording becomes a lot louder—over a very short time span (a signal spike, 
in other words). This is typical of drum recordings, but the analysis of other instruments 
or complete mixes (depending on the musical context), can also produce usable 
results. 

To detect transients in an audio region:
m Select the desired audio region, and click the Analyze button in the track header of the 

Beat Mapping track. 

Following analysis, the transients are displayed as small vertical lines at the bottom of 
the Beat Mapping track. The remaining steps of the beat mapping procedure are as 
described above for MIDI regions.

It is also possible to analyze several selected audio regions at once. An alternative 
method for audio region analysis is to drag them directly onto the Beat Mapping track.

Improving Beat Mapping Accuracy
The Detection Sensitivity value field in the track header allows you to retrigger the 
analysis procedure if the results are not as expected. A higher Detection Sensitivity 
setting will detect more transients, which can be useful if dealing with less distinct 
accents in the music (such as soft drums in a loud mix). On the other hand, a higher 
Detection Sensitivity setting might lead to the detection, and display, of transients that 
have no meaning for the rhythmic structure of a region. In general, you should begin 
with a lower Detection Sensitivity setting, and only switch to a higher setting if obvious 
rhythmic elements in the music aren’t recognized correctly.

Note:  The detection ability is independent of the overall volume of an audio region. In 
other words, the results will be the same if you normalize a region.
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On occasion, your recordings may contain (MIDI note) events that fall onto musically 
useful positions, and should remain there when beat mapping is used for audio 
recordings. Such situations are catered for by the inclusion of the Protect MIDI option, 
found in the track header of the Beat Mapping track. Simply activate this option to 
keep existing MIDI events at their current positions when beat mapping.

Beats From Region
The Beats from Region button in the Beat Mapping track header activates an automatic 
Beat Mapping method that uses a self-recorded metronome region.

To use the automatic Beat Mapping feature:
1 Create, or use an existing instrument track.

2 Insert the KlopfGeist instrument (or perhaps the EXS24 mkII with an appropriate sound, 
such as a closed hi-hat or cross-stick).

3 Record a one note per beat metronome click that fits the music in the existing regions. 

If some of the metronome region notes are not in time with the original recording, you 
can edit their positions in any of the MIDI editors—in order to get them in sync with 
the music. 

4 Select the metronome region, and click the Beats from Region button.

5 Choose the most appropriate note value in the Set Beats by Guide Region(s) dialog 
(default:  1/4 Note), and click OK to perform the beat mapping operation.

Logic Pro will map all beats to the notes in this region, and insert tempo changes to 
preserve the original timing, starting with the first beat in bar one. Although the 
audible result doesn’t change, the music will be displayed correctly—with regard to bar 
positions. 
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Beat Mapping to Scene Markers
If the global Video track is visible, a QuickTime movie is loaded, and the Detect Cuts 
function (in the Video track) is used, the detected scene markers appear as available 
mapping positions (vertical lines) at the bottom of the Beat Mapping track. You can 
easily define a scene cut position as the first downbeat of a bar—by allocating it to the 
bar position, as described above.

Beat Mapping to Markers
If the Marker track is visible, you can use the desired marker as a mapping position 
(vertical line at the bottom of the Beat Mapping track) by clicking on it. Shift-click to 
assign multiple markers as beat mapping positions. Once done, you can hide the 
Marker track.
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32 Editing Transposition With the 
Chord and Transposition Track

You can use the Transposition and Chord track to edit the 
playback transposition of MIDI events and Apple Loops over 
time.

The Transposition track contains nodes that are connected by vertical and horizontal 
lines. Each node represents a global transposition event, which determines the global 
transposition value until the playhead reaches the next transposition event during 
playback.

Transposition events are closely linked to the chord root notes in the Chord track:  If 
you create or alter a transposition event, the amount of pitch shift will immediately be 
reflected by the the chord root notes in the Chord track—and vice versa.

The zero position of the Transposition and Chord track is determined by the current key 
signature in the Signature track. If the key signature changes during a project, the zero 
position of the Transposition and Chord track change accordingly. 
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How MIDI Events and Apple Loops Are Transposed
Transposition events (and their chord counterparts) pitch-shift MIDI events and Apple 
Loops.

MIDI Events
Transposition events change the actual MIDI events themselves. As an example:  If you 
create a MIDI region that contains a C3 note event, copy the MIDI region, and then 
create a transposition event of +2 at the start of the copied MIDI region, the 
transposition event changes the note event to a D3. 

Despite this data change to events, the Transposition track works non-destructively, as 
you can change the transposition of MIDI events multiple times. Imagine you copy the 
D3 of the example above to a position where the Transposition track is set to +2; the 
MIDI event will by played back as D3. But if the Transposition track is set to a different 
playback interval at the target position, the MIDI event will be pitch-shifted to the new 
playback transposition.

Transposition events only affect MIDI events already in your project. They do not affect 
MIDI events that you create or record after editing the transposition events. 
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MIDI events will only be transposed if the No Transpose checkbox is inactive in the 
respective Track Parameter boxes. 

Apple Loops
Apple Loops can contain information about the key they are in, and can be transposed 
automatically. Regular audio regions (audio regions that are not Apple Loops) will not 
be affected. Nor will Apple Loops that do not have a key definition (drum loops, for 
example). For full details, see the Chord track description in the Apple Loops chapter on 
page 621.

Creating and Editing Transposition and Chord Events
Creating and editing of transposition events works similar to standard MIDI events.

To create a transposition event in the Transposition track, do one of the following:
m Click with the Pencil tool at the desired position in the Transposition track.

m Hold Control-Option-Command, click the desired position in the Transposition track, 
enter the desired transposition value in the text field, then press Return.

A transposition event of the typed value will be created at the clicked position.

To change the transposition value of a transposition event, select it by clicking it, then 
drag it up or down.
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To create a chord event in the Chord track:
m Click with the Pencil tool at the desired position in the Chord track, then define in 

chord symbol in the Define Chord dialog.

If you want to edit a chord event, just double-click on it. The Define Chord dialog will 
open, allowing free changes to the chord symbol properties.

To select a chord or transposition event:
m Click the chord or transposition event with the Pointer tool.

Use Shift-click or the rubberband selection method to select multiple events.

To move a chord or transposition event along the timeline:
m Select the event, then drag it to the left or right. 

Watch the help tag during these procedures to see the exact transposition value and 
bar position of that particular event.

To delete a transposition or chord event, do one of the following:
m Select it by clicking it with the Pointer, then press Backspace. 

m Click the event with the Eraser tool.

Transposition events can be copied using the standard Copy and Paste procedure or by 
dragging them with the mouse while holding Option. 

You can also copy or move multiple transposition events simultaneously, which can be 
useful for repeated project sections
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Analyzing MIDI Regions
You can use the Analyze button in the Chord track to analyze the chords in a MIDI 
region. Select the desired MIDI region (preferably one containing complete chords) and 
click the Analyze button in the Chord track header. The MIDI region will be analyzed, 
with the resulting chords appearing in the Chord track. This also works for several 
subsequent regions. Alternatively, you can drag the desired regions onto the Chord 
track.

Note:  Keep in mind that the chords in the Chord track are events, they affect the 
playback transposition of MIDI events and Apple Loops. Make sure that you only use 
the Chord track if you really want to use it consequently; once you use it, it always 
affects your composition. As an example:  When you analyze your project, then copy a 
region without copying the chord track events …; you should not use it if you only 
want to display the chords in your project; use the Marker track then—or the Score 
Editor text chord symbols. 

Working in the Change Display Only Mode
You might come across situations where there are incorrect or missing chords in the 
Chord track. As an example:  You record a MIDI region, select it and use the Chord 
track’s Analyze button. Normally this should work fine, as the analysis algorithm is 
rather intelligent and knows all about harmonics. If the result of the analysis process 
unexpectedly doesn’t comply with your recording, Logic Pro provides you with an easy 
solution:  The Chord track’s Change Display Only mode. If you activate this mode by 
clicking the Change Display Only option in the Chord track, you will be able to adjust 
the chords to match what you’re actually hearing (the transposition events in the 
Transposition track are adapted accordingly). All changes applied to chords in the 
Chord track while the Change Display Only mode is active, will have no result on the 
playback of the corresponding MIDI regions—these changes will only adapt the chords 
displayed in the Chord track to match the chords played in the MIDI region.

The Change Display Only mode does not work with Apple Loops used on audio tracks. 
For further information, see the Chord track description in the Apple Loops chapter on 
page 621. 
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Inserting Chord Symbols in the Score
The chord symbols displayed in the Chord track can be inserted into the Score Editor 
(and printed):

To insert chords from the Chord track into the Score Editor:
m Select the staff that you would like to use for the chord symbols in the Score Editor, 

then choose Functions > Insert Chords From Global Chord Track.

Inserted chord symbols are displayed in blue (printout will be black), and can only be 
moved within the boundaries of the chord on the Chord track. Double-clicking such a 
chord will launch the Define Chord dialog of the Chord track.
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33 Working With Notation

The Score Editor allows you to view and edit MIDI regions as 
traditional music notation.

This chapter covers the tools and features available for score and lyric entry, editing, 
layout, and printing. Following a general Score Editor overview, you’ll learn how to:
Â Input notes, musical symbols, and text in the score.
Â Use the extensive display settings to transcribe MIDI recordings.
Â Edit notes and musical symbols in your score.
Â Lay out and print your score.
Â Customize the Score Editor display.

This chapter will not teach you music theory, nor how to read or write music notation. 
Its purpose is to introduce you to the way Logic Pro allows you to create, edit, lay out, 
and print music—in notation form.
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Learning About the Score Editor
The Score Editor displays MIDI regions as staffs, played by track instruments. 

Each staff or (Arrange area) track can contain an unlimited number of MIDI regions. If 
the MIDI regions on one track directly follow one another in the Arrange area (with no 
gaps between them), they are displayed as one continuous staff in the score—unless 
you have limited the view to a single MIDI region, by engaging Content Link mode. 

Selected MIDI regions are displayed with blue staff lines, unless this option is 
deactivated in the Score preferences (see “Score Preferences” on page 795). This makes 
it easy to identify the currently selected part.

 Display Parameter box

 Event Parameter box

Part box
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A High Level Workflow Example
This section is designed to provide an overview of how you would approach the 
creation of a musical score in Logic Pro.

Step 1:  Getting Notes into the Score
There are basically three ways you can do this:
Â Real time recording from your MIDI keyboard (see “Recording MIDI” on page 378).
Â Step recording, using either your MIDI keyboard or the Caps Lock keyboard (see 

“MIDI Step Input Recording” on page 384).
Â Manual entry with the computer keyboard or mouse (discussed later in this chapter).

As mentioned earlier, the Score Editor displays the contents of MIDI regions, which act 
as containers for note (and other) events. As such, you need to create, and select, a MIDI 
region in the Arrange area if you’d like to work in the Score Editor.
Â Click the Score tab at the bottom of the Arrange window to view the Score Editor 

area, or choose Window > Score (default key command assignment:  Command-3) to 
open a Score Editor window. The currently selected track or region will be displayed 
as a staff. 

Â Double-click on the background of the Score Editor (with the Pointer tool) if you 
would like to see the regions of all MIDI tracks (software and external MIDI) as staffs. 

Step 2:  Using the Display Settings to Create Readable Notation
Logic Pro interprets MIDI regions for the score display, using a variety of user-defined 
methods.

Note events are obviously represented as crotchets, quavers, and so on. Spaces 
between notes are represented as rests. Sustain pedal data can also be represented in 
your score.

Your goal should be to retain the feel of real time recordings (if this is how you added 
note data to Logic Pro), while still rendering a score that is readable by other musicians.

If you like the sound of playback, but not the way the score looks, you can usually 
obtain the desired results by changing a few settings in the Display Parameter box (see 
“Transcribing MIDI Recordings” on page 728), and the overall Score project settings.
Â Display Parameter box:  The parameters of the Display Parameter box mainly affect 

the rhythmic display of selected MIDI regions. They only apply to the score display, 
and do not affect the playback of MIDI regions. They can be different for each region. 
Some of these (region-based) parameters can be overridden for individual notes, by 
using note attributes.

Â Project settings:  You can set general display options that affect the whole project in 
the Score project settings window (see “Project Settings for Score Display” on 
page 776). These include spacing between notes, page margins, line thickness, 
display of instrument names, bar and page numbers, and a lot more.
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Important:  Score display parameters have absolutely no effect on MIDI playback, just 
on the way MIDI data is shown in the Score Editor. This separate notation display 
system allows you to adjust the look of the notation, without changing the original 
MIDI region data (and therefore, the performance).

You can further control the display by selecting or creating staff styles, text styles, and 
score sets, that best fit your music.
Â Staff styles exist for most common single and multi-staff types, and can be chosen 

from the Display Parameter box’s Style menu. These include:  Piano, Guitar, Horn in 
Eb, Organ, and even Drum styles. Simply choose the one that best represents the 
instrument part as notation. If none of the existing styles are appropriate, you can 
easily create your own (see “Working With Staff Styles” on page 741).

Â Score sets allow you to determine which instruments are displayed (and printed) in a 
score. You can include as many (or few) of the existing track instruments into a score 
set as you wish (see “Using Score Sets to Create Scores and Parts” on page 762). This 
makes it easy to create separate sheet music for the violinists, or french horn players, 
for example.

Â Text styles are used to control several different text elements of your score, such as:  
the title, lyrics, copyright information, instrument names, and so on. Each of these 
text elements can be assigned a font style, size, and more within the overall text style  
(see “Working With Text” on page 710).

Step 3:  Editing Note Events
Even with all of the display options discussed above, you may need to adjust the 
appearance of some notes. This is done with the functions in the Note Attributes menu. 
These commands allow you to adjust individual note events, allowing enharmonic 
shifts, accidentals, ties, beaming, and much more.

This facility can also be used on multiple selected notes, which is useful on those rare 
occasions when the display settings don’t deliver the desired results.

Single staff style

Staff style consisting 
of two staffs
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Step 4:  Inputting Events, Symbols, and Text
Few scores consist solely of note (and rest) events.

The Part box contains a number of symbols (pedal markings, slurs, and so on) that can 
be inserted into the score by dragging them into position with the mouse. The Part box 
also contains all types of note events, clefs, bar line markers, and more. Again, these 
can easily be added by drag and dropping (see “Working With the Part Box” on 
page 678).

Rests are usually displayed automatically in Logic Pro, and don’t need to be manually 
inserted—but can be, if needed—from the Part box (see “Creating and Inserting Rests” 
on page 704).

The entry of lyrics, title, and other text elements is performed from the Part box, or with 
the Text tool (see “Working With Text” on page 710).

Step 5:  Editing the Whole Score
Once you’ve recorded or inserted all (or most) of the notes and symbols into your 
score, and edited individual elements, the next step is to polish the score’s layout. 

This would typically include use of tools to reposition staffs, and changing the Score 
project settings—to adjust the number of bars per line, set page margins, and more. All 
project layout options are discussed in “Project Settings for Score Display” on page 776. 

Layout work is done in Page view, which displays as many facing pages as possible 
(dependent on the size of the Score Editor window and current zoom level).
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To switch between the default score display (called the linear view) and Page view:
m Click the Page view button (to the left of the Layout menu button).

∏ Tip:  You should use the linear view for editing, as screen redraws are much faster, 
especially on slower computers. Page view should only be used for layout work, in 
preparation for printing. Further details on Page view can be found in “Customizing the 
Score Editor’s Appearance” on page 775.

Step 6:  Printing a Score
The last step is printing your score. The printed result always corresponds to what you 
see in the Score Editor window (Page view must be activated). 

To print the score:
1 Choose File > Print (or use the corresponding key command, default:  Command-P). 

This opens the Print dialog.

2 Choose the desired printing options (including printing to PDF), and click the Print 
button.

Before printing, you may want to activate Print view, which shows the page margins 
onscreen. 

To activate Print view:
m Choose View > Page Display Options > Print View (only accessible when Page view is 

active). 

More information can be found in “Printing the Score” on page 769. 

Entering Notes and Symbols in the Score Editor
You can add notes and symbols in the following ways:
Â Real time MIDI recordings (notes and sustain pedal markings only).
Â MIDI step input (notes only). This can be done with the computer, or a MIDI 

keyboard.
Â Dragging notes or symbols from the Part box to the staff.
Â Fast input of symbols by assignment to selected notes with key commands. These 

are available for some symbols which are attached to notes (accents, jazz symbols, 
and so on), and slurs or crescendi. Information on key commands is shown 
throughout the chapter, where applicable.
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Â Hyper Draw (see “Using Hyper Draw in the Score Editor” on page 677) allows you to 
insert and edit MIDI events that aren’t normally displayed in the Score Editor, such as 
continuous controller data (volume, pitch bend, and so on).

The display of input notes (and symbols) depends on the Score Editor’s display settings, 
especially those in the Display Parameter box (see “Transcribing MIDI Recordings” on 
page 728), and the note attributes (see “Using Note Attributes to Change Individual 
Notes” on page 735). 

MIDI playback is also influenced by the settings in the Region Parameter box and Track 
Parameter box. Settings in the Environment may also affect MIDI playback, if 
configured to do so.

Real Time MIDI Recording
Although real time MIDI recordings are usually made in the Arrange area, you can also 
start recording directly from the Score Editor. You must first select the destination track 
in the Arrange area’s track list. This can be done directly from the Score Editor, by 
clicking on a staff associated with the desired track. If no MIDI regions exist on the 
track, you will need to switch to the Arrange area for recording, because the track won’t 
be displayed in the score (the Score Editor only shows regions and folders). More 
information about MIDI recording can be found in “Recording MIDI” on page 378.

Step Input
Step input in the Score Editor works in the same way as other editor windows (see 
“MIDI Step Input Recording” on page 384).

The Score Editor (and Piano Roll Editor), however, allows the content of several regions 
to be displayed, and edited, at once. This results in some differences regarding step 
input:
Â The MIDI region that you want to insert notes into must be selected (click on the 

staff ). If no staff is visible, you must first create an empty MIDI region in the Arrange 
area.

Â Simultaneous step input into several regions is not possible. If more than one MIDI 
region is selected, the notes will be only be inserted into one of them.

Â If several MIDI regions follow one another on the same arrange track (even those 
with gaps in-between them), you can step input notes from one MIDI region to the 
next. As soon as the playhead reaches the beginning of the next MIDI region, 
Logic Pro will automatically insert the notes into it.
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Preparing for step input:
1 Make the following adjustments to the display settings for the selected MIDI region:

Â Interpretation should be turned off (see “Interpretation” on page 732). 
Â The Display Quantize setting should be set to the smallest note value that you intend 

to insert (see “Quantize” on page 730).

2 Set the first playhead insert position by Option-clicking the staff at the desired point. 
The selected position is displayed in the help tag while the mouse button is pressed.

This function is especially helpful in Page view, where no Bar ruler is displayed. 

Note:  You can only set the playhead position when the sequencer is stopped.

Mouse Input (Using the Part Box)
A staff must exist before notes, symbols, and text elements (called objects in the 
following sections) can be inserted. Each staff (including empty staffs) represents one 
or more regions. 

To input notes or symbols with the mouse:
1 Select an object in the Part box (see “Selecting Part Box Objects” on page 679).

2 Do one of the following:

Â Drag it to the desired staff position, and release the mouse button. 
Â Select the Pencil tool in the Toolbox and click at the desired staff position. If you 

click-hold the mouse button, you will insert the previously selected symbol. 

As a positioning aid, you will see a help tag while the mouse button is held. Drag until 
the desired position is shown in the help tag, and release the mouse button. The help 
tag is especially important for positioning when working at smaller zoom levels.
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When working in full score view (when more than one MIDI region is displayed), and 
inserting objects between the staffs (such as dynamic symbols), you should make sure 
that these symbols have been inserted into the desired MIDI region. The target MIDI 
region is automatically selected (blue staff lines) once the object has been inserted. You 
can also see the name of the selected region in the top line of the Display Parameter 
box.

∏ Tip:  It’s generally better to change to single staff display (linear view) when inserting 
objects that are positioned between staffs—especially lyrics. 

Although it doesn’t matter which MIDI region (staff ) an object belongs to in full score 
mode (as they stay where they are placed), such objects can be displayed with the 
wrong instrument, when single instrument parts are later displayed and printed.

To switch to single region display:
m Double-click the desired MIDI region (staff ).

To switch back to the full score display:
m Double-click in the empty space below or above the staff. 

This displays the full score, including all MIDI regions in the project.

For full details on all Part box objects and features, see “Working With the Part Box” on 
page 678.

MIDI Channel and Velocity of Inserted Objects
The MIDI channel, and velocity, of objects inserted with the mouse are determined by 
the Insert Defaults settings in the Event Parameter box. These are visible (and can be 
edited), when no object is selected. 
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To display the Insert Defaults settings:
m Click anywhere on the background of the working area. 

When inserting events into a staff which uses a polyphonic staff style (see “Adding 
Staffs to a Staff Style” on page 747), only MIDI channels that correspond to those of the 
voices can be used.

Many symbols display a MIDI channel in the Event List. For most objects, the MIDI 
channel determines the staff (theoretically, up to 16) that the symbol belongs to, in 
polyphonic staff styles. 

Note:  If this parameter is set to a value that exceeds the number of staffs in the staff 
style, the symbol will disappear.

Insert Quantization
To make positioning of notes and symbols easier, objects can only be inserted at 
certain bar positions:
Â There is an invisible note positioning grid. Imagine the whole bar—beginning at 

beat one—is filled with notes of the chosen value. As an example:  In an empty 4/4 
measure, half notes can only be inserted on beats one and three, eighth note triplets 
only on the first, second, or third eighth note triplet of every beat.

Â All binary and dotted values can be inserted at any position of an automatically 
displayed rest. This means that if there is an eighth note on (count) one, you can 
insert a quarter or a dotted quarter note at the second eighth’s position. In this 
situation, Interpretation must be disabled in the Display Parameter box, to allow the 
display of the eighth note rest on the “and” of beat one (see “Interpretation” on 
page 732). The Syncopation setting determines how the inserted note is displayed, in 
this example.

Â Symbols (except those directly attached to notes) can be inserted at any 
Quantization parameter grid position. For hybrid quantization values (such as 8,12), 
the insert quantization is determined by the binary value (1/8 in this example).

Simultaneous Input of Objects Into Several Regions
Press Shift to insert an object from the Part box into all currently selected regions—at 
the same position. The help tag shows Insert Multi while you’re doing this. This 
technique allows you to insert notes, symbols, and even text elements, into several 
regions at once.
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You may make the multiple MIDI region selection in either the Arrange area or the 
Score Editor. Shift-click all desired regions or staffs, or use the rubber band selection 
method. 

Following selection, the top line of the Display Parameter box will indicate the number 
of staffs (regions) that have been chosen.

Note:  Key changes, signature changes, and global signs are automatically inserted into 
all staffs of the project, and can not be inserted into individual, selected staffs.

Using Hyper Draw in the Score Editor
You can directly create and edit MIDI controller information in the Score Editor. These 
types of edits are made easier when you can see the notes that will be affected.

To view and create controller events:
1 Open a Hyper Draw display in the Score Editor by doing one of the following:

Â Choose the desired View > Hyper Draw command.
Â Click the Hyper Draw button at the lower-left corner of the Score Editor, then choose 

the desired MIDI controller by clicking the arrow button to the left. 

The selected controller type (volume, for example) is shown in a gray field below the 
Score Editor area. An event value scale is displayed in the instrument name column if 
View > Instrument Names is activated. 
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2 Click at different points in the gray area to create Hyper Draw nodes. 

A connecting line is automatically created between the nodes.

To resize the Hyper Draw area:
m Grab, and vertically move the dividing line that separates it from the Score Editor area.

For more information see “Using Hyper Draw” on page 596.

Note:  Hyper Draw can only be activated in linear score view, and when a single MIDI 
region is displayed. If you switch to another mode (Page view, or full score), the Hyper 
Draw area disappears. The view settings are stored, however, so when you return to 
single MIDI region and linear view, the previous Hyper Draw setting is recalled.

Working With the Part Box
The objects available in the Part box (notes, symbols, text objects) are organized into 
groups. The top section contains small squares, with each representing a group. You 
can view this as the group menu, if you like. All groups (with all available symbols) are 
shown in a panel below.

To change the arrangement of groups:
m Click on one of the squares in the group menu. 

The corresponding group moves to the top of the panel, allowing easy access to its 
symbols.

Group menu

Groups
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Note:  Any symbol can be selected and inserted from any group panel, at any time. The 
group rearrangement function simply makes it easier to work with the Part box, 
especially on smaller screens, or when using small Score Editor windows.

To lock Part box group positions:
m Choose View > Partbox > Lock Group Positions.

Choose the command a second time to unlock group positions.

To show only the symbols of the currently selected group in the Part box:
m Disable the View > Part box > Show All Groups setting. 

Selecting Part Box Objects
You can select any Part box object (a note, slur, clef, or whatever) by simply clicking on 
it. If a particular object group isn’t visible in the Part box, click on the corresponding 
square in the group menu to move the desired object group to the top of the panel.

To select an object directly from the group menu:
m Click-hold on one of the squares that represent the Part box groups, and choose the 

desired object from the shortcut menu that appears.

To open a small Part box group window:
m Double-click on one of the group menu squares. 

This opens a small floating window that contains all objects in the group. This palette 
window can be freely moved. Objects can be dragged directly from palette windows 
into any position in the score. You can simultaneously open as many palette windows 
as needed.

Note:  Unlike the regular Part box, the selected object is not highlighted in the palette 
windows.
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The palettes can have different shapes, depending on the modifier pressed while 
opening a floating palette with a double-click:
Â Normal (Control)
Â Vertical (Option)
Â Horizontal (Command)

The default shape of palette windows (opened with a simple double-click) can be 
predefined in the Logic Pro > Preferences > Score > Floating Palette View pop-up 
menu.

Selecting Part Box Objects With Key Commands
The following unassigned key commands select the corresponding note values in the 
Part box. These can then be quickly inserted with the Pencil tool:
Â Partbox: 1/1 Note
Â Partbox: 1/2 Note
Â Partbox: 1/4 Note
Â Partbox: 1/8 Note
Â Partbox: 1/16 Note
Â Partbox: 1/32 Note

If you execute any of these key commands more than once, the following applies:
Â Twice in succession, the corresponding triplet value is selected.
Â Three times selects the dotted value.
Â Four times returns to the original value.
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Further key commands can also change the selection inside the Part box:
Â Next Partbox Symbol and Previous Partbox Symbol:  The Next Partbox Symbol key 

command selects the symbol to the right of the selected object. The Previous 
Partbox Symbol key command selects the object to the left. When the last object in a 
group is reached, selection cycles back to the first object in the group.

Â Next Partbox Group and Previous Partbox Group:  The Next Partbox Group key 
command selects the object group below the current (selected) one. Previous 
Partbox Group moves one group up. The most recently selected object within each 
group is retained when switching between groups.

Note:  As the group display can be reordered, the current display order of groups 
determines the previous and next group. 

Learning About Part Box Groups
The following section provides a basic overview of the individual part box groups. 
Detailed information on note and other object editing (as applicable) is found in 
“Editing Notes and Symbols:  Basic Operations” on page 690.

Notes
The group menu square that represents notes, in the top section of the Part box, is 
divided into three parts:  notes, dotted notes, and triplet notes. These correspond to 
three note object groups.

To move the note, dotted note, or triplet note group to the top of the group panel:
m Click on the corresponding symbol (note, dot, or 3) within the note square.

Inserting any of these symbols creates a MIDI note event, of the exact note length 
value. For display purposes, however, all of these MIDI notes are interpreted by 
Logic Pro as if they were recorded in real time. 

Adjust the Display Parameter box settings to correctly display inserted notes. See the 
Display Parameter box section in “Transcribing MIDI Recordings” on page 728.
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Sustain Pedal Symbols

These two symbols are the only score symbols—apart from notes—that directly 
represent MIDI events (MIDI controller #64, sustain pedal on and off ), and thus affect 
MIDI playback. Logic Pro intelligently inserts the on or off version of the symbol, 
depending on the status of the type that preceded it (a sustain off always follows a 
sustain on, and vice versa).

Clefs

The clefs in the Part box are generally intended for clef changes in the middle of a part, 
for a short section of the music. An example would be cello or bassoon parts, when the 
part changes to a higher register. Inserted clefs change the score display, starting at the 
precise insert position (which can even be in the middle of a bar).

Note:  You shouldn’t use the Part box clefs to change the clef of a whole MIDI region. In 
this situation, choose an appropriate staff style (see “Working With Staff Styles” on 
page 741) for the region.
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Dynamic Symbols

These symbols can be inserted at any position in the score. They are purely graphic 
symbols, and have no effect on the playback of regions they are placed in.

Note Heads

If you drag one of these symbols onto a note, the note head changes to that of the 
selected symbol. If multiple notes are selected, dragging the note head onto any one of 
the notes will attach it to all notes in the selection. Altered note heads do not affect 
MIDI playback.

If you want to return an altered note head to a standard display, use the same method, 
with the black, round note head selected.

Invisible Note Heads
Use of the gray note head will make a note’s head, and associated ties, invisible. This 
note is displayed with a gray note head onscreen, allowing further edits. Nothing but 
the stem will be visible in the printout. 

Invisible note head
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If you combine this feature with Attributes > Stem > Hide, you can completely hide 
these notes in the printed score.

Symbols Attached to Notes

This group contains symbols which usually only refer to one note at a time. This 
includes fermatas, accents, phrasing symbols, and bow markings, for example (trills are 
in a separate group).

To assign any of these symbols to a note:
m Drag the desired symbol onto a note head (watch the help tag to ensure accurate 

placement).

These symbols are automatically positioned when assigned to a note. They also move 
with their parent notes, when transposed or otherwise graphically altered.

To insert a symbol that remains independent of any note:
m Press Option during insertion. 

This allows you to place a fermata above an automatically created rest, for example.

Note:  The symbols in this Part box group can affect the velocity and playback length of 
notes they are assigned to. 

If you want these symbols to affect playback:
m Define the effect of each symbol, separately, in File > Project Settings > Score > MIDI 

Meaning (see “MIDI Meaning” on page 792).



Chapter 33    Working With Notation 685

Slurs, Crescendi

These symbols are graphic only, and have no impact on MIDI playback. 

To insert a slur or crescendi object:
1 Drag it to the intended (left) starting point. 

After insertion, the object remains selected, and small black square handles are visible 
at its end points (or along its length, in the case of slurs). 

2 Grab and drag these handles to change the object’s shape

You can also use several key commands to quickly input slurs, crescendo, and 
decrescendo symbols. For details on these, and editing options, see “Editing Slurs and 
Crescendi” on page 707.

Key Signatures
Key signatures inserted in the Score Editor (or global Signature track or Signature List) 
affect all instruments on all display levels. This is reflected both visually and in MIDI 
playback.

Natural symbols are automatically displayed with a new key signature, when necessary 
(when changing from A flat major to F major or A major, for example).

The display of key signatures and key signature changes depends on:
Â The Score project settings in the Clefs & Signatures tab (see “Clefs & Signatures” on 

page 788).
Â The Key parameter in the Staff Style window (for each staff style).

Detailed information about key signatures can be found in “Working With Time and 
Key Signatures” on page 723.
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Time Signatures
Time signatures inserted in the Score Editor globally affect all MIDI regions, on all 
display levels. Time signature changes only affect the display, however, not playback. 

Apart from 2/4, 3/4, 4/4, 6/8, and the alternative display options for 4/4 and 2/2, there 
are also Part box objects for freely-definable time signatures (A/B), and compound time 
signatures (A+B/C). When you insert one of these, the Time Signature dialog box opens, 
allowing you to set the desired time signature. For more information see “Working With 
Time and Key Signatures” on page 723. 

Repeat Signs and Bar Lines

These objects can be inserted at any visible bar position (at the position of any 
graphically displayed note or rest). Usually, however, these objects are inserted at the 
beginning or end of bars. 

In this situation, they replace the regular bar line (except first and second ending 
symbols). They are global symbols, and are displayed in all staffs, on all display levels. 

Note:  These symbols are purely visual, and have no impact on MIDI playback.

Details on editing these symbols is found in “Editing Repeat Signs and Bar Lines” on 
page 709.
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Trills, Tremolo, and so on

The symbols in this group can be positioned anywhere, and are not attached to notes. 
The trill line and arpeggio lines can be set to any length, by dragging their end points. 
The trill line can also span line breaks. 

The accidental symbols in this Part box group are purely graphical, and do not affect 
the MIDI playback of notes. They are mainly intended as a supplement to trill symbols.

Rests, Bar Repeat Signs

Rests are displayed automatically in Logic Pro. The way this works is pretty 
straightforward:  existing notes and automatic rests always add up to complete bars, 
that match the given time signature. 

Note:  The only exception to this is when a staff style with a deactivated rest display 
(Hide Rest) or with beat slashes (instead of rests) is used.

In certain situations, you might want to insert rests manually. These manually inserted 
rests (also called user rests) can be used if you don’t like the way a particular automatic 
rest is displayed. See “Creating and Inserting Rests” on page 704.
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Text Objects, Chord Symbols

You will find descriptions of the extensive range of text objects and chord symbols in 
“Working With Text” on page 710.

D.S., D.C., Segno, Coda Signs

These symbols can be inserted at any position in the score. They are graphic symbols, 
and do not affect MIDI playback. They can be resized with the Resize tool.

Tempo and Swing Symbols

You can insert these symbols at any position. The font, size, and style of the tempo 
indicator is determined in the Text Style window (see “Working With Text Styles” on 
page 715).

The tempo indicator value is automatically derived from the playback tempo at the 
corresponding bar position. 
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Note:  The tempo indicators in the Transport bar and the Tempo List always refer to 
quarter notes, even if a time signature with another denominator is used. As such, the 
displayed tempo differs, depending on the symbol being used.

Jazz Symbols

Jazz symbols, as the name suggests, are typically used for Jazz notation. They generally 
indicate a particular playing technique or style, emphasis, or mode.

To assign any of these symbols to a note:
m Drag the desired symbol onto a note head (watch the help tag to ensure accurate 

placement).

These symbols are automatically positioned when assigned to a note. Additional space 
is created as needed, to avoid overlaps with other notes or symbols. Jazz symbols also 
move with their parent notes, when transposed or otherwise graphically altered.

Jazz symbols can also be inserted with the Attach Symbol:  Jazz 1–6 key commands. 
The numbers (1 to 6) indicate the positions of the symbols in the Part box (from top left 
to bottom right). 

To insert a jazz symbol that remains independent of any note:
m Press Option during insertion. 

These unattached symbols can be moved freely; and unlike normally inserted jazz 
symbols, do not affect the spacing of notes.
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Page Break and Line Break Symbols

Break symbols (and No Line Break and No Page Break objects) can be inserted as 
events. Once inserted, they can not be moved automatically (when you alter the Layout 
project settings, resize the window, and so on).

You can overrule the Line Break, Page Break, No Line Break, and No Page Break events 
with the Layout tool.

Line breaks and individual staff margins can be determined for each score set, and also 
for each of the extracted parts.

Editing Notes and Symbols:  Basic Operations
This section covers basic editing methods that are used in the Score Editor. For general 
MIDI editing information, please refer to Chapter 15, “Introduction to MIDI Editing,” on 
page 391. 

Using the Shortcut Menu
Many selection, editing, and other commands can be accessed by Control-clicking in 
the Score Editor. Make use of this shortcut menu to accelerate your workflow.

Note:  The shortcut menu can also be accessed with a right-mouse click if the Right 
Mouse Button: Opens Shortcut Menu option is chosen in the Logic Pro > Preferences > 
Global > Editing tab.

The shortcut menu contents change when different objects are selected. The Score 
Editor provides the following shortcut menu types:
Â Notes
Â Clefs
Â Key signatures
Â Time signatures
Â Bar lines
Â Background
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Changing Several Objects Simultaneously
If several objects are selected, this is indicated in the Event Parameter box title line, as 
follows:  “X Notes/Symbols/Events/Texts/Chords selected”. “X” indicates the number of 
selected objects. The terms Notes, Texts, and Chords are only used if the current 
selection is limited to objects of that particular type.

If—as in most cases—parameter fields are visible while multiple events are selected, all 
corresponding values can be edited simultaneously. When the “*” value is shown, it 
indicates that the selected objects have different values for that particular parameter. 
There are different options for changing these values:
Â Relative change (preserving differences):  Grab the “*” with the mouse, and use the 

mouse as a slider. The value shown during this process belongs to the first of the 
selected objects. The other objects are altered by the same amount (while retaining 
their relative values). You can also double-click the value, and insert the desired 
change (a number with a plus or minus in front of it) in the entry field (see above).

Â Absolute Change (all values set to an equal value):  Press Option during the procedure 
described above:  as soon as you move the mouse, the parameter is set to the same 
value for all selected objects. This enables you to set all notes of a chord to the same 
length or velocity, or set all selected objects to the same height (Vertical Pos), as 
examples.

To set the vertical and horizontal position of all selected objects to the same value:
m Use any of the following key commands.

Â Align Object Positions Vertically
Â Align Object Positions Horizontally
Â Align Object Positions (affects both parameters)

These key commands set all objects to the value of the first selected object. If only one 
object is selected when you use one of these key commands, a dialog will ask if the 
parameters of all similar objects should be set to the same value. 

This affects all displayed regions and instruments.

∏ Tip:  This is very useful for aligning lyrics and chord symbols.



692 Chapter 33    Working With Notation

Deleting Objects From the Score Editor
You can only delete events that are actually displayed in the Score Editor. As an 
example, if you erase notes from a real-time recording in the Score Editor, MIDI 
controller events or pitch bend data that was recorded with these notes will not be 
deleted.

To delete an object, do one of the following:
m Click the object with the Eraser tool.

m Select the object, then choose Edit > Delete (or press the Backspace key). 

Note:  Repeat signs and special bar lines cannot be selected. They can only be deleted 
with the Eraser tool.

Moving or Copying Objects With the Mouse
You can move or copy notes and symbols with the mouse, just as in the Piano Roll 
Editor. 

Note:  It’s easy to unintentionally change a symbol’s bar position with the Pointer tool. 
Choose the Layout tool to limit changes to an event’s vertical and horizontal position. 
See “Changing the Graphical Position of Objects” on page 696.

To move a symbol or note with the mouse:
m Select one or more notes or symbols, then drag it to the desired position. 

To copy a symbol or note with the mouse:
m Select one or more notes or symbols, press Option, then drag it to the desired position.

Watch the help tag during this process. It shows the operation (drag or copy), the 
current difference from the original position (transpose and time shift), and the current 
cursor position (bar position and—for notes—pitch).

You can simultaneously move or copy objects from different regions/staffs. Each event 
will be moved/copied to its new position, within the original (source) MIDI region.
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Note:  You can not use the Option-drag method to copy or move events between MIDI 
regions in the Score Editor. You can, however, copy and paste (see “Copying Objects via 
the Clipboard” on page 694) between regions/staffs.

To restrict movement to one direction (vertical or horizontal):
m Hold Shift while dragging. 

There is also a general preference for this:  Logic Pro > Preferences > Global > Editing > 
Limit Dragging to One Direction In: Piano Roll and Score.

The Impact of the Display Quantization Parameter
Movement along the time axis (horizontal) is affected by the display quantization grid 
(Quantize) setting. 

If a hybrid quantize value is selected (16,24 for example), the grid corresponds to the 
binary value (16, in this example). 
Â If note positions are not aligned with this time grid (because they were recorded in 

real time), their relative offset is retained when they are moved or copied. 
Â This allows you to move or copy unquantized passages within the Score Editor, 

without losing the original feel of the performance. 

Moving Objects With Key Commands
A group of key commands are found in the Nudge Region/Event Position section of the 
Key Commands window. These functions move all selected objects (by various steps) 
along the time axis. The following Nudge commands are the most useful for score 
work:
Â Nudge Region/Event Position Left by Bar and Nudge Region/Event Position Right by 

Bar:  Moves the selected notes forward or back one bar.
Â Nudge Region/Event Position Left by Beat and Nudge Region/Event Position Right by 

Beat:  Moves the selected notes forward or back one beat.
Â Nudge Region/Event Position Left by Division and Nudge Region/Event Position Right by 

Division:  Moves the selected events forward or back one division step (as set in the 
Transport).

Moving Global Symbols and Symbols Attached to Notes
You can not copy or move the following symbols in the Score Editor:
Â Global symbols, such as repeat signs, time and key signature changes—except in the 

Signature List and Signature track (see “Working With Time and Key Signatures” on 
page 723)—and global text elements (headers and so on).

Â Symbols directly attached to notes, such as accents, fermatas, note heads, and so on.
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Copying Objects via the Clipboard
When you copy objects via the Clipboard, the first object is pasted at the target bar 
position. The relative positioning of other copied objects (to the first object) is retained.

You can simultaneously paste the Clipboard contents into several regions, at the 
original position. 

To paste the Clipboard contents into several regions:
1 Select all desired regions (either in the Arrange area, or Score Editor), by Shift-clicking 

all desired staffs/regions, or rubber banding adjacent regions.

The Display Parameter box (see “Transcribing MIDI Recordings” on page 728) title line 
always indicates the number of regions that are currently selected.

2 Choose Edit > Paste Multiple (or use the Paste Multiple key command.) 

Automatic Insert Quantization
When you paste (or paste multiple) objects from the Clipboard, the position of the first 
inserted event is automatically quantized, in accordance with the current division value 
(set in the Transport bar). As an example, if the current bar position is 4.1.1.37, and the 
division value is set to 1/16, the pasted object will be inserted at position 4.1.1.1, 
whether it’s a note or a symbol. When the Clipboard contains more than one object, 
their relative positions from the first object are retained.

If you don’t want this behavior (because you want to preserve the unquantized timing 
of the original), you are better served by other copy methods.

Pasting Passages at the Same Time Position 
You can use the Paste at Original Position and Paste Multiple at Original Position 
commands to quickly copy passages from one MIDI region to another—at the same 
time position. No insert position is required, and no automatic insert quantization takes 
place.

To copy an entire musical passage to the same time position in another region:
1 Select the notes and symbols of the passage.

2 Select the staff you want to paste the passage to.

3 Choose Edit > Paste at Original Position (or use the Paste at Original Position key 
command).

The notes and symbols are pasted at the position they were originally copied from, 
regardless of the current playhead position. 

The Paste Multiple at Original key command works in a similar way, but allows you to 
paste a musical passage to the staffs of other instruments. All destination staffs need to 
be selected before the Paste Multiple command is executed.
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∏ Tip:  You can use these commands in combination with the Select Similar function, to 
quickly copy all dynamic symbols from one staff into other staffs/instruments, for 
example.

Repeating Events
The Repeat Events command is especially useful for copying complete bars (or multiple 
copies), without setting any bar positions. 

As an example, to copy a bar that begins with a rest on one:
1 Select all notes and symbols.

2 Choose Edit > Repeat Events (or use the Repeat Regions/Events key command).

3 Insert the number of desired copies, set Adjustment to Bar, and press Enter.

For more information on the Repeat Events command, please refer to “Making Multiple 
Copies of Regions” on page 328. 

Working With Aliases in the Score Editor
Alias is a term used for dependent MIDI regions and folders in the Arrange area. Alias 
regions mirror other MIDI regions and folders at different positions. Wherever an alias 
exists, it acts as a playback marker that points to the parent (original) MIDI region or 
folder. It is actually the parent region (or folder) that is played back.

Aliases are also displayed in the Score Editor, and can be printed. The display of aliases 
can be switched on in the Global tab of the Score project settings (File > Project 
Settings > Score > Global).

An alias can be assigned a different staff style  (see “Working With Staff Styles” on 
page 741) to its parent region. As an example, imagine a melody that you would like 
played in unison by several instruments:
Â This can be done quickly by creating several aliases of a regular MIDI region (the 

melody). 
Â Different staff styles can be used for each of the different instruments, including 

transposing staff styles (as examples, Horn in Eb, Alto Sax, and so on). 
Â If you decide to change something in the melody, you don’t need to edit all copies 

(aliases) of it. Just make the change in the parent MIDI region, which will 
automatically be reflected in all aliases.
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Editing Aliases
You can directly edit the notes and symbols in an alias if the Allow Alias Editing 
checkbox in File > Project Settings > Score > Global is switched on. 

Note:  Changes to aliases alter the data of the original MIDI region (and all aliases 
created from it), because only the original region can actually contain MIDI data.

If Allow Alias Editing is switched off and you try to edit an alias, this dialog appears. 
Choose the appropriate option:

Â Cancel:  The aliases and original MIDI region are not changed.
Â Enable Alias Editing:  Alias editing is enabled; remember that this actually edits the 

parent MIDI region.
Â Create a Copy:  A copy of the original MIDI region replaces the selected alias. You can 

edit the notes independently of the original MIDI region, as the selected alias is now 
a real region.

Changing the Graphical Position of Objects
You can change the graphical position of objects to improve the layout of your score 
(by creating space for a grace note, for example).

Using the Layout Tool
The Layout tool is used to graphically move events in the Score Editor, in order to 
optimize the display, without altering the timing of MIDI events.

Â Symbols and text:  When symbol or text objects are moved with the Layout tool, the 
bar position is retained. The Horizontal Position and Vertical Position parameters, 
however, are changed (as indicated in the help tag during the process).

Â Notes:  The Layout tool can only edit the horizontal position of a note in relation to its 
bar position, not its vertical position. Dragging the note to the right or left changes 
the displayed distance from the adjacent notes or rests. The bar position (and 
playback) are unaltered. 
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Note:  The bar position determines playback timing—as this is the actual MIDI event 
position. Remember that the Score Editor is primarily designed to deliver notation, and 
that most (but not all) editing functions are graphical, rather than physical, in nature.

Changing the Graphical Position of Symbols and Text
You can change the graphical position of Score Editor objects in the Event Parameter 
box by editing the Vertical Pos. and Horizontal Pos. parameters. 
Â Vertical Pos.:  Determines the vertical position (height) above or below the staff. Zero 

means a position exactly on the top line of the staff, in most cases. Positive values are 
above, negative values below it. In staff styles with more than one staff, the Staff 
parameter determines the staff that the Vertical Position parameter refers to.

Â Horizontal Pos.:  Determines the horizontal offset of the object’s bar position. A value 
of zero corresponds to the left edge of a note, at that particular position.

∏ Tip:  To adjust a number of selected symbols to the same height above (or below) the 
staff, use the Align Object Positions Vertically key command.

Changing the Graphical Position of Independent Score Symbols 
You can use the following key commands to move any score symbol that can be 
positioned independently of notes or staffs, as well as text events and chord symbols:
Â Nudge Position Up
Â Nudge Position Down
Â Nudge Position Left
Â Nudge Position Right

These functions do not alter the bar position of the affected symbols and text events. 
They alter the Horizontal Position and Vertical Position parameters by ±1.

Resizing Notes and Symbols
You can change the size of any notes, and most symbols, with the Resize tool. 

To change an object’s size:
m Grab the object with the Resize tool, and move the mouse up or down. 

To reset an object to its original size:
m Double-click it with the Resize tool (and click OK in the dialog). 
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Editing Notes and Symbols:  Advanced Operations
This section covers more advanced usage of notes and other objects in the Part box.

Editing Notes
Given the different types of notes (tuplets, dotted, grace notes, and so on), this section 
outlines a number of note-related editing operations that will help you to get your 
score looking just right. 

Note:  If your editing requirements extend beyond those covered in this section, see 
“Using Note Attributes to Change Individual Notes” on page 735.

Editing the Velocity, Length, or Pitch of a Note
You can edit the velocity, length, or pitch of one or more selected notes in the Score 
Editor.

To change a note’s velocity, do one of the following:
m Select the note, then edit the Velocity parameter displayed in the Event Parameter box.

m Grab one (or several) notes with the Velocity tool, and move the mouse up or down.

The value change can be seen in the help tag, and can also be heard if the MIDI Out 
button is activated. 

∏ Tip:  Grabbing a note with the Pointer tool—while holding down Option-Control—
activates the Velocity tool, saving you a trip to the Tool menu. Once you release these 
modifier keys, the cursor returns to its previous shape and function. 
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To change the length of a note:
m Select the note, then do one of the following:

Â Edit the Length parameter in the Event Parameter box (shown as bars, beats, and 
ticks). 

Â Use one of the Nudge Region/Event Length key commands. 

To change the pitch of a note:
m Select the note, then do one of the following:

Â Drag it to the desired staff line (keep an eye on the help tag).
Â Edit the Pitch value in the Event Parameter box.
Â Use the Event Transpose +1 or the Event Transpose –1 key command.

Allowing Diatonic Input Only
If your composition falls into a consistent key, you should turn on the Diatonic Insert 
feature:  it helps you to place notes at the correct pitch—by limiting input to notes that 
are diatonically correct, for the current key. 

To turn on the Diatonic Input feature:
m Choose Options > Diatonic Insert in the Score Editor.

Notes can be altered chromatically, once they have been inserted.

Note:  If you protect (lock) your screensets, this function’s setting will also be locked.

Creating Tied Notes
Notes which are displayed as several graphical notes, connected with ties, only 
represent one actual MIDI note event. 

Ties can not be inserted directly into Logic Pro, but are created and displayed 
automatically, in accordance with the length of the MIDI note. As such, you need to 
approach the creation of ties as follows:

To create tied notes:
1 Insert a shorter note value than the one you want to insert.

2 Change the note length in the Event Parameter box, the Event List, or the Event Float 
window.
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To change the tied note display with a user rest:
m If you don’t like the way particular tied notes are displayed, you can change the display 

by inserting a user rest at the position you want to see a graphic note. 

The rest’s length is not important, but you should use a shorter one (an eighth note 
rest), if possible. Watch the help tag, for exact positioning. As soon as the rest is 
inserted, it will no longer be visible in the score display, but the note display will 
change accordingly. 

Note:  If you want to delete, or change the position of a (now invisible) user-inserted 
rest, use the Event List.

To change the up/down direction of a tie:
m Choose the desired setting in the Attributes > Ties menu.

Creating and Editing N-Tuplets
The symbol for N-tuplets is found in the triplet group. N-tuplets are groups of notes 
that are evenly spaced (by condensing or expanding them) over a specific time period. 
The most common tuplet is the triplet, a group of three notes. As an example:  A group 
of three eighth notes played within the space of one quarter note. 

Dependent on the situation, Logic Pro usually recognizes and notates regular triplets 
correctly. This requires that you choose an appropriate display quantize value in the 
Display Parameter box  (see “Quantize” on page 730). You need to use the N-tuplet 
object for the display of other N-tuplets.

N-tuplet symbol
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To change the display of existing notes:
1 Drag the N-tuplet symbol onto the first note. 

The target note must be indicated in the help tag, before you release the mouse 
button. The Tuplet window will open, allowing you to define the N-tuplet attributes:

Â Tuplet note number:  The number of tuplet notes is defined in the upper left field.
Â Tuplet denominator:  The value shown in the upper right numerical field.
Â Tuplet note values:  Choose from 1/8, 1/16, 1/32 (and so on) tuplets.
Â Hide Bracket:  The bracket is not displayed.
Â Hide Numbers:  The N-tuplet’s number will not be printed. It will, however, be 

displayed in parentheses. This is necessary for further edits to the N-tuplet.
Â Show Denominator:  The N-tuplet display also contains the denominator (the second 

number in the dialog box). This is 5:4 in the example above.
Â Direction:  The direction of the bracket and number. Auto refers to the setting in the 

staff style being used.
Â Allow Double Values:  If this option is activated, N-tuplets can contain note values that 

are twice as long as the regular tuplet value. 
Â Allow Half Values:  If this option is activated, N-tuplets can contain note values that 

are half the length of the regular tuplet value. 

∏ Tip:  Most changes made to the parameters listed above are reflected in the tuplet 
graphic.

2 Define the required settings in the Tuplet window.

In the example above, five tuplet eighth notes should be displayed, in place of four 
regular eighth notes. 

3 Click OK. 

In the score, the above would correspond to:
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To insert N-tuplets with the mouse:
1 Insert the first note at the desired position.

2 Drag the N-tuplet symbol onto it. 

If you hold down Option as you insert the N-tuplet symbol, the most-recently inserted 
N-tuplet settings will be used, without the dialog.

3 Define the required settings in the N-tuplet window.

The display will initially show a series of rests—the number of which corresponds to 
the N-tuplet value. You can insert other notes at these rest positions. Simply select a 
note value which approximately matches the length of the desired N-tuplet notes.

If you want to hear these notes played back with legato phrasing, and the notes are too 
long or too short, you will need to change their (MIDI) lengths. The fastest way to do 
this is to select all notes, and then choose Functions > Note Events > Note Force Legato 
(Selected/Any). You can also use the corresponding key command.

The method described above also allows you to create N-tuplets which contain rests or 
syncopated note values (double length).

∏ Tip:  If you want an N-tuplet to begin with a rest, you first need to insert a user rest 
from the Part box, then drag the N-tuplet symbol onto the rest. Automatically displayed 
rests can not function as starting points for N-tuplets.

To edit tuplets:
m Double-click the N-tuplet number, then select the desired settings in the Tuplet 

window. 

To delete a tuplet, do one of the following:
m Click the tuplet number with the Eraser.

m Double-click the N-tuplet number, then click the Delete button in the Tuplet window. 

Using Artificial N-Tuplets to Bypass Display Quantization
You can bypass the display quantization value by using hidden, artificial N-tuplets. 

As an example, if there is a single 32nd note run in a MIDI region that otherwise only 
contains eighth notes or longer values, you can set (Display) Quantize to 1/8, and drag 
the N-tuplet symbol onto the first note of the 32nd figure. 

In the resulting dialog box, use the 8:8/32 setting, with Hide Brackets and Hide 
Numbers checked. The number (8) will be visible on screen, but not in the printout.

Although this is not the way that tuplets are normally used, it is a handy way to force 
the display of runs (of shorter notes—1/32nd notes, in this case), with a display 
Quantize value set for longer note values (1/8 notes, in this example).
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Creating Grace Notes and Independent Notes
Independent notes are notes that aren’t included in the automatic rhythmic (and 
graphic) display calculation of a measure, but are still played back via MIDI. There are 
two types:

Â Independent:  These are displayed at their original length, as long as they are binary 
or dotted note values that can be displayed as a single (not tied!) note. After 
insertion, you can change the stem direction, enharmonic interpretation, accidental 
distance, and note head, using the Note Attributes functions (see “Using Note 
Attributes to Change Individual Notes” on page 735).

Â Independent Grace:  These are always displayed as miniature eighth notes, with a 
slash across the stem, and a tie. The tie direction, stem direction, enharmonic 
interpretation, accidental distance, and note head can be changed.

Both types of independent notes can only appear as single notes—without beams to 
other notes.

To convert regular notes to independent notes (and vice versa):
m Select the desired notes, then choose Attributes > Independent > Independent or 

Independent Grace, or use the corresponding key commands. 

Choose Attributes > Independent > Not Independent to convert independent notes 
back into regular notes.

To insert an independent note directly:
m Option-select a note from the Part box, and drag it to the desired position. 

Independent grace notes cannot be inserted directly. They need to be created by 
converting regular or independent notes.

In most situations, you will need to create additional space between the grace note 
and the note it is associated with. The best way to do this is with the Layout tool, which 
can be used to move the main note away from the grace note (see “Using the Layout 
Tool” on page 696). 

∏ Tip:  If you want to create beamed grace notes, try using a polyphonic staff style (see 
“Adding Staffs to a Staff Style” on page 747) with no rests displayed for the second 
voice. Assign the desired grace notes to the second voice, and resize them with the 
Resize tool.

Independent grace noteIndependent note
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Creating and Inserting Rests
In certain situations, you may want to insert rests manually. These manually inserted 
rests (also called user rests) can be used if you don’t like the way a particular automatic 
rest is displayed. As examples:  to avoid dotted rests, or for the syncopated display of 
rests, even when Syncopation (see “Syncopation” on page 733) is turned off.

In rhythmic display terms, user rests behave like notes—with enabled Syncopation and 
disabled Interpretation parameters (see “Interpretation” on page 732). User rest 
interpretation is affected by the display quantize setting (see “Quantize” on page 730), 
just as notes are.

Properties of User Rests
Â They replace automatic rests, but unlike automatic rests, are listed as events in the 

Event List. These events have a MIDI channel and a velocity value. The velocity value 
determines their vertical position in the staff (normal middle position is achieved 
with velocity value 64).

Â They can be moved vertically. Automatic rests can not be moved.
Â They can be resized with the Resize tool. Automatic rests can not be resized.

Using Multi Bar Rests
Rests with a duration of several bars can be indicated by these two symbols.

These are most suitable for single instrument parts.

Note:  In the full score view (where multiple regions/staffs are displayed), they are only 
visible when all staffs contain multi bar rests at the same position. 

To insert church or modern rests, either:
m Choose the desired rest type from the Rests Part box, and click at the desired position 

with the Pencil tool.

m Drag the desired rest type (from the Part box) to the required position.

Church rests (the older form of display) default to a length value of 2 bars. 

The default length of normal multi bar rests is Auto (a value of 0 in the Event List). The 
duration of the rest is automatically calculated with respect to the position of the next 
note, user rest, or global symbol (repeat signs, double bar lines, and so on). 

Church restModern rest
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To change the rest type or duration:
m Double-click on the rest symbol in the score with the Pointer tool.

In the dialog that opens, choose the shape (modern or church) and activate or 
deactivate the automatic length function. You can only determine the length (in the 
Bars field), if Auto Length is switched off.

Note:  Church rests can not be longer than nine bars. If this length is exceeded, the 
modern symbol automatically replaces the church rest.

Multi bar rests can not be moved with the mouse. You can, however, change their bar 
position in the Event List or Event Float window. You can also alter the length of the 
rest (shown in the VAL column) in these windows.

Using Beat Slashes
Beat slashes can be used in place of automatic rests, or they can be manually inserted. 
Both single and double slashes (commonly used to indicate a pause) are available in 
the Part box. 

You can freely place slashes on top of the staff.

Editing Clefs
The clefs in the Part box are intended for clef changes in the middle of a part, for a 
short section of the music. Inserted clefs change the score display, starting at the 
precise insert position (which can even be in the middle of a bar).

Note:  If you need to change the clef of the entire region, choose an appropriate staff 
style (see “Working With Staff Styles” on page 741).

When you insert a C-clef, please watch the help tag carefully, as this clef can be 
positioned at five different heights, depending on the register (alto, tenor clef, and so 
on).

The four symbols below the clefs do exactly what you expect them to:  they mark a 
section to be played either one or two octaves higher (or lower). The length of the 
section can be edited after insertion, by grabbing the end of the line and moving it 
horizontally.
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To change an existing clef:
1 Double-click the clef. 

2 Select the desired clef in the selection box shown below.

Note:  The same applies to the basic clef of a region, but changing this clef affects the 
staff style itself, as well as all regions that use the same staff style.

To change the size of clef changes:
1 Open the Clefs and Signatures project settings by doing one of the following

Â Choose Layout > Clefs and Signatures (or use the Settings:  Clefs and Signatures key 
command).

Â Choose File > Project Settings > Score (or use the corresponding key command), 
then click the Clefs and Signatures tab.

Â Click the Settings Toolbar button, choose Score from the menu, then click the Clefs 
and Signatures tab

2 Choose the desired value in the Smaller Clef Changes menu.

All clefs, except the first one in every staff, will be reduced in size, depending on the 
value chosen here. This will happen regardless of whether the clef changes are the 
result of a different staff style in the same staff, or clefs have been inserted from the 
Part box.
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Editing Slurs and Crescendi
Given their nature, slur and crescendi objects are edited in a very different way to other 
Part box symbols.

Fast Slur and Crescendo Input With Key Commands
You can use the following key commands to quickly input slurs, crescendo, and 
decrescendo symbols:
Â Insert: Slur Up
Â Insert: Slur Down
Â Insert: Crescendo
Â Insert: Decrescendo

These commands place the corresponding object below or above (Slur Up) the 
currently selected notes. The start point is determined by the first selected note—and 
the length of the object, by the most recently selected note. The shape, and vertical 
position, of each object is determined by the settings of the most recently edited 
object—of the same type.

Changing the Position
All objects can be moved by simply click-dragging the mouse from the object’s left 
hand starting point. The last six objects in the group are moved by click-dragging each 
of their corners (handles) separately.

Changing the Length of Symbols
All of these symbols can be as long as desired, and can be displayed (in several parts) 
across line and page breaks.
Â As an example, if you want to extend a slur to a position which is not visible in the 

Score Editor (in linear view), you can grab its right end, and pull the cursor to the 
right border of the Score Editor—the score will automatically scroll. As soon as the 
desired end position for the slur appears in the window, move the mouse a little to 
the left, to stop scrolling. Now position the end of the slur. It is important that you do 
not release the mouse button during the entire process.

Â In Page view, you can simply drag the right end to the desired destination in one of 
the lower staffs. The slur will be displayed in several sections. The same principle 
applies to the other symbols in this group.

Â The length of these objects can also be changed in the Event List or Event Float, by 
changing the numerical length parameter. The end point is moved horizontally by 
this procedure. Slanted objects, such as arrows, will be displayed at a 
correspondingly varied angle.

Â The length can exceed the end of the MIDI region—it’s possible to drag the right end 
of a crescendo object to a position in the next MIDI region on the same track.
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Particular Attributes of Certain Symbols
Â Crescendo:  The tip determines the general position. At the upper right end, length 

and opening angle can be adjusted. At the lower right, length and overall angle can 
be altered. 

Â Decrescendo:  At the upper left end you can alter the bar position, and opening 
angle. At the lower left end, bar position, and overall angle can be set. At the tip 
(right end), vertical position and length are adjusted.

Â Lines and arrows:  Can be moved (in their entirety) by dragging the start point. At the 
other end, length and overall angle can be altered. The slanted line symbol denotes a 
line that can be altered freely. The other two line objects (vertical and horizontal) can 
only be extended in the corresponding direction.

Â Slurs:  Slurs have five editing points, used to change their shape. The last two slur 
symbols in the slur group are mainly intended for slurs across staffs (in piano parts).

Note:  These are slurs, not ties (see “Creating Tied Notes” on page 699). Ties cannot be 
inserted manually, but are displayed automatically if a MIDI note’s length requires it.
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Editing Repeat Signs and Bar Lines
Repeat signs and bar lines cannot be moved with the mouse. You can, however, move 
these symbols (along with time and key signatures) to a certain extent, in the Arrange 
window. 

Once a region is selected in the Arrange window, alterations to its end point (or 
position) will affect existing repeat signs and bar lines in the score. Inserting, deleting, 
and moving key and/or time signatures in the Arrange window global tracks also have 
an impact on these score elements.

To delete repeat signs and bar lines:
m Click them with the Eraser tool.

Invisible Bar Lines
The dotted bar line is invisible in the printout. When used in conjunction with hidden 
time signature changes, this enables you to create bars and musical passages which 
don’t seem to have a fixed meter. Another use for the invisible bar line is to force a 
graphical split of a note into two notes connected with ties—in all staffs of a score 
simultaneously—if it is inserted in the middle of a bar.

To hide all automatically displayed bar lines:
m Activate the Hide Bar Lines checkbox in the File > Project Settings > Score > Clefs and 

Signatures tab.

This only affects automatic bar lines. Manually inserted bar lines, double bar lines, and 
so on will still be displayed and printed, regardless of the preference setting. 

1st and 2nd Endings
Following the insertion of one of the repeat endings, text entry mode is automatically 
activated. The default text is “1.” and “2.”. If suitable, confirm with Return. If unsuitable, 
you can freely enter any text into these brackets. The bracket which defaults to “2.” is 
open—without a vertical end line, like the “1.” ending. 

As the text can be changed, you also can create a 2nd ending with a vertical line, for 
example. The font, text size, and style of these numbers or text elements is set in the 
Text Styles window (see “Working With Text Styles” on page 715). To edit the text, 
double-click directly on it, which activates text entry mode, indicated by a flashing text 
cursor.

A 1st or 2nd ending can be moved by dragging its upper left corner. The length can be 
changed by dragging the right end. If a repeat ending is selected, it can be deleted by 
pressing Backspace.

First and second endings are only displayed on staffs with bar lines that aren’t 
connected to the staff above.
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The Alternate Repeat Symbols (for the whole project) option in File > Project Settings > 
Score > Global activates a real book style display of repeat signs. 

Bar Repeat Signs
The one or two bar repeat symbols replace all notes and rests in the corresponding 
measures. All other symbols remain visible. This does not affect MIDI playback, so 
hidden notes can still be heard. These signs can only be moved in the Event List or 
Event Float window.

Double Repeat Sign
The double repeat sign behaves as expected, unless it is positioned at a line break. In 
this situation, it is automatically displayed as two back to back repeat signs.

Working With Text
You can use text for a number of purposes in musical notation:  to add performance 
indications or display chord notation, as examples. Each text object in the Part box 
serves a specific purpose:

Â Standard text object:  Use to add standard text. The basic functions for moving the 
cursor, deleting parts of the text, and so on, are as per most word processors.

Â Lyrics object:  Use to quickly add lyrics to a song. The cursor position is automatically 
moved from note to note. 

Â Chord object:  Use to add chord notation. 
Â Automatic Text objects:  Use to display text that is updated automatically. There are 

four automatic text objects:
Â Region:  Drag this object onto the staff to automatically display the region name.
Â Instr:  Drag this object onto the staff to automatically display the instrument name.
Â Song:  Drag this object onto the staff to automatically display the project name.
Â Date:  Drag this object onto the staff to automatically display the current date.
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Inserting Text
You can add text in the same way as other score symbols:  By dragging the desired 
object from the Part box to the score. Alternately, you can use the Text tool to enter 
text.

To insert text in the score:
1 Select the desired text object in the Part box.

2 Do one of the following:

Â Drag the text object to the desired position. 
Â Select the Text tool (or use the Set Text Tool key command), then click at the desired 

position. 

A flashing text cursor appears at the target position. (If you choose one of the 
automatic text objects, the respective text will be inserted automatically.) 

3 Enter the desired text with the computer keyboard. 

As long as you are in text entry mode (indicated by the flashing text cursor), you can 
click at any position in the text field. You can select parts of the text by dragging the 
mouse in the text field, and apply the usual Cut, Copy, or Paste commands. Press 
Return, or click anywhere outside the text field, to exit text entry mode.



712 Chapter 33    Working With Notation

Each text object (except text in the header, or at—or outside—the page margins) is 
saved as a meta event within a particular MIDI region, at a certain bar position. This 
position can be seen in the help tag, as you insert the text object. Text events are also 
visible in the Event List, allowing you to change their position, but not the text itself. 

∏ Tip:  You can simultaneously add text to several staffs. This is handy if you want to 
insert the text “accelerando al fine,” for example, into all instruments. Text entry into 
several staffs at once works as per other objects (see “Simultaneous Input of Objects 
Into Several Regions” on page 676).

Editing Text
In general, you can edit text objects in the same way as other objects (see “Editing 
Notes and Symbols:  Basic Operations” on page 690). If a text object is selected, you can 
set its parameters in the Event Parameter box. If you want to edit the text itself, either 
click on it with the Text tool, or double-click on it with the Pointer tool. The flashing text 
cursor will appear.

To set the selected text font, size, and face:
m Choose Text > Fonts, then make the desired settings in the Fonts window.

Score text event
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Setting Special Text Object Parameters
You can set the following options for the selected text object in the Event Parameter 
box:

Staff
Only relevant in multiple staff styles. It determines the staff that the text object is 
assigned to. The Vertical Pos. parameter indicates the vertical distance to the top line of 
the staff. The Horizontal Pos. indicates the graphical horizontal deviation of the selected 
text object from its actual bar position (also in relation to the Align parameter). 

Lyric
Defines the text object as a lyric event (song text). If a lyric event is placed at the same 
bar position as a note (above or below it), the horizontal distance to the previous and 
subsequent notes or rests is automatically expanded, providing enough space for the 
text.

Note:  This checkbox can not be used on automatic text objects.

Style
Determines the text style of the selected text object. 

Align 
Determines the horizontal alignment of a text object. The first three settings relate to 
the bar position, the last five to the position on the page. 

Using Musical Symbol Fonts
Musical symbol fonts do not contain letters. They only contain musical symbols (such 
as special percussion symbols). You can use text objects (set to a musical symbol font) 
to freely create, and position, musical symbols anywhere in the score.



714 Chapter 33    Working With Notation

Learning About Text Styles
All text elements refer to user-definable format settings called text styles. A text style 
contains all text attributes, such as font, size, and style, which saves you the time and 
effort of manually setting them whenever you insert a new text object. 

About the Text Styles Window
All text styles used in a project are listed in the Text Styles window. This window allows 
you to edit existing text styles, or create new ones. 

To open the Text Styles window, do one of the following:
m Choose Text > Text Styles in the Score Editor.

The first twelve lines contain the default text styles, which exist in every project (but 
can be edited, according to your needs). Below these, you will find user-created text 
styles. User text styles are saved with the project file, allowing them to be different for 
each project.

Each line shows the name, and an example, of the text style. Double-clicking the 
Example line opens the Font window, allowing you to edit both the default and user 
text styles. Any fonts installed on your system can be used.

About the Default Text Styles
The default text styles have been designed for specific text elements, and are 
automatically assigned when inserted. 
Â Plain Text:  This is the default setting for regular text.
Â Page Numbers, Bar Numbers, Instrument Names:  The text styles for automatic page 

and bar numbering, and display of instrument names. These functions are described 
in the Numbers & Names section (see “Numbers & Names” on page 781). These styles 
can also be edited in the Numbers & Names tab of the Score project settings 
window. Changes in either window automatically updates the settings in the other 
window, and affects the entire project.

Â Tuplets:  This text style is used for triplet and other tuplet numbers.
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Â Repeat Endings:  The text style for anything written into the repeat ending boxes 
(usually just numbers, but text can also be entered).

Â Chord Root, Chord Extension:  Used for the display of chord symbols. The Root covers 
the root and (optional) extra bass note in chord symbols. The Chord Extension is 
used for everything else. 

Â Multiple Rests:  The text style for the number above multiple rests.
Â Tablature:  Used for the display of fret numbers in guitar tablature (see “Guitar Tab” on 

page 784).
Â Tempo Symbols:  Used for the display of numbers in tempo symbols (see “Tempo and 

Swing Symbols” on page 688).
Â Octave Symbols:  Used for the display of octave symbols (see “Octave Symbol 

Parameters” on page 790). 

Working With Text Styles
This section outlines how you can create, edit, and assign text styles.

To create a new text style:
m Choose New > New Text Style in the Text Styles window.

A new line appears below the bottom text style entry, allowing you to define the 
attributes of the new text style. The names of any new style can be edited in the text 
entry field, which opens when you double-click on the name of the text style.

To assign a text style to a text object:
1 Select the text object.

2 Choose the desired text style from the Style pop-up menu in the Event Parameter box. 

Importing Text Styles From Other Projects
You can add text styles created in another project to the current project.

To import text styles from another project:
1 Choose File > Project Settings > Import Settings.

2 Click the Text Styles checkbox at the bottom of the Import Settings window. Uncheck 
all other settings types, if you don’t wish to import them.

3 Browse to the project that contains the text styles you want to import.

4 Click Open, and all user text styles from the selected project will be added to the 
current project.
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Working With Global Text
Global text objects appear in all score sets of a project (score, parts, and so on), 
although they are inserted just once. 

Score sets determine which instrument tracks are included in the score display. Each 
project can contain as many score sets as required. Full details on score sets can be 
found in “Using Score Sets to Create Scores and Parts” on page 762.

The position of global text does not relate to bar positions (unlike regular text objects), 
but is defined as a graphic position on the page. Given this behavior, global text can 
only be inserted and seen in Page view. The most obvious example of a global text 
object is a song name (in the page header).

To create global text:
m Insert text into one of the following areas of the page:

Â In the header space (which is set in Layout > Global Format).

Â Outside, or directly on, any of the page margin lines.

Text objects inserted in one of these areas are automatically made global.

Positioning of Global Text
Following insertion into one of the margin areas, global text can be moved anywhere 
on the page. The Pointer tool only allows vertical movement of global text objects. 
Hold down Option to move global text horizontally.
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Global Text Parameters
When a global text object is selected, the Event Parameter box contains some 
additional parameters:

Pages
Defines the pages that the global text object will be displayed on. You can choose 
between the following options:
Â 1:  The text will only be displayed on the first page.
Â 2:  The text will be displayed on all pages except the first one.
Â Odd:  The text will be displayed on all pages with odd numbers.
Â Even:  The text will be displayed on all pages with even numbers.
Â All:  The text will be displayed on all pages.

Zone
The margin area that the text belongs to/is associated with:  You can choose between 
Top, Header, Side, and Footer. 

Align
Although alignments relating to bar positions are shown in the pop-up menu, they 
cannot be selected here.

Working With Automatic Text Objects
The text group in the Part box contains four objects which represent names that are 
automatically displayed, if inserted:
Â REG (Region/Folder):  Displays the name of the current display level. This can be a 

MIDI region, a folder, or even the name of the project file (on the highest level). 
Â INSTR (Instrument):  Displays the name of the currently displayed instrument or score 

set (see “Using Score Sets to Create Scores and Parts” on page 762). 
Â SONG:  Displays the name of the project file.
Â DATE:  Displays the current date (at the time of printout).
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These automatic text objects can be inserted as both global text (in the margin areas), 
or as text objects that are related to a bar position (in one of the staffs/regions). As an 
example:  You can insert the INSTR object as a global object—to display the name of 
the current score set on all pages. The appearance, and exact positioning, of these 
objects can be set in the Event Parameter box.

Creating Lyrics
The text group in the Part box contains an object named LYRIC, which allows you to 
create lyrics—aligned to note events. When you use the LYRIC object to input text, 
pressing Tab moves the text cursor to the beginning of the next MIDI note. 

To create lyrics:
1 Do one of the following:

Â Drag the lyric object below the first note of the melody.
Â Select the lyric object in the Part box, then click at the position of the first note with 

the Text tool. 

Note:  Watch the help tag:  each lyric object must be at the same bar position as the 
note it belongs to (taking display quantization into account).

2 Enter the text for the first note—and press Tab, not Return—which automatically 
moves the text cursor to the beginning of the next MIDI note. 

If a MIDI note is displayed as several tied (graphic) notes, press Shift-Tab to move the 
cursor to the next graphic note. This allows you to write several syllables below one 
longer note. This method enables you to enter all lyrics in one process, although each 
syllable is saved as an independent lyric object.

Editing lyrics is just like editing regular text. The Event Parameter box displays the same 
parameters (the Lyric checkbox is activated).

Apart from the fact that cursor movement is bound to notes in lyric input mode, the 
only difference between regular text objects and lyric objects is that the latter affect 
the distance between the notes they are assigned to. This provides enough space for 
the text to be displayed properly, without overlapping. If the text (or text style) is 
changed later on, the note distance will be recalculated accordingly.

To convert a standard text object to lyrics:
m Select the text, and click the Lyric checkbox in the Text Event Parameter box.
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Setting All Words and Syllables to the Same Height
If you don’t enter the lyrics in one continuous process, it is unlikely that the lyric objects 
will be set to the same vertical position (they won’t be aligned). 

To quickly align all Lyric objects:
1 Select at least one lyric object.

2 Choose Edit > Select Similar Objects, which will select all lyric objects. 

3 Use the Align Object Positions Vertically key command. 

Note:  You do not want to use this method if there are multiple lines of lyrics for 
different verses. Doing so would set them all to the same height.

Several Verses Written Below Each Other
You can assign multiple lyric objects to the same note, allowing you to insert several 
verses for a song, one below the other. 

To create several verses for the same note:
1 Drag the first lyric object to the position of the desired note, then input the first verse.

2 Drag the second lyric object to the same note position below the first verse, and type 
in the second verse. 

As long as you remain in fast lyric input mode, all lyric objects for the second verse will 
stay at the same height as the initial object—in this case, the first word of the second 
verse.

Working in Single MIDI Region Display Mode
It is important that lyric objects are assigned to the right MIDI region, if you’re working 
in a full score display (remember:  selected staffs are displayed with blue staff lines). It’s 
generally recommended that you insert lyrics in linear view, and single MIDI region 
display mode—especially if inserting more than one verse. Linear view also makes it 
easier to rubber band select several lyric objects, to change their positions, for example.

Creating Chord Symbols
Chord symbols are text objects designed for fast chord entry. Logic Pro uses special 
text attributes to display chord symbols, and also offers additional editing tools. 

To create a chord symbol:
1 Do one of the following:

Â Drag the chord symbol from the Part box to the desired position in your score.
Â Select the chord symbol in the Part box, then click at the desired position with the 

Text tool. 
Â Select any text symbol in the Part box, then Option-click at the desired position with 

the Text tool. 
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Note:  Ensure that you insert chord symbols at the correct bar position. Watch the help 
tag while inserting the chord object.

2 Enter the text for the chord.

A chord symbol can include a root note, a separate bass note, and two lines of 
extensions. As you enter the text for the chord in the Score Editor, you can influence 
the way the inserted text is distributed:
Â First, enter the root, then the extensions, then—after typing a slash—the (optional) 

additional bass note.
Â As soon as you enter a number, everything following it will be placed in the upper 

extension line. If you write “G7(b9/b13)”, the whole “7(b9/b13)” will be placed in the 
upper line, and the lower line remains blank.

Â If you write letters before a number (FMAJ7/9, for example), Logic Pro places the 
letters in the lower line, and everything after the first number, in the upper line. 

Â You can influence this automatic placement by entering a comma in the text:  
everything before the comma will be placed in the lower line, and everything after it, 
into the upper line. Only one comma can be used. Blank spaces can be entered, to 
create additional horizontal space between the extension and the root. 

To edit a chord symbol, do one of the following:
m Double-click on the root, then edit the chord symbol in the Chord Symbol window.

There are four entry fields for the different parts:  one for the root, one for an additional 
bass note, and two for extensions—which are placed above each other.
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m Double-click directly on one of the extensions. 

A text cursor will appear in the extension line, allowing you to edit the extension as per 
regular text.

The appearance of chord symbols can be edited in the Text Styles window (see 
“Working With Text Styles” on page 715), by changing the text styles assigned to the 
chord root and extensions.

To change the appearance of chord symbols:
1 Open the Text Styles window by choosing Text > Text Styles in the Score Editor.

2 Edit the text style for the chord root (named Chord Root)—and for the extensions 
(named Chord Extensions)—as desired. 

Inputting Several Chord Symbols 
If you want to insert several chord symbols into the same staff, there is a shortcut 
(similar to the lyric input mode) available. Following text entry of the first chord, press 
Tab, rather than Return. The text cursor automatically moves to the position of the next 
(displayed) note or rest. Enter the desired chord and repeat the process, or press Tab 
several times, to move to the target position for the next chord symbol.

∏ Tip:  If you want to insert one chord per bar into a very busy part, it’s much faster to 
create an empty MIDI region, and enter the desired chords into it (the cursor moves to 
the next bar when you press Tab in empty regions). Following chord entry, you can 
either merge the MIDI region with the original MIDI region in the Arrange area, or copy 
and paste all chords at once. 

Enharmonically Changing Chord Symbols
You can change the roots of chord symbols enharmonically. Only additional bass notes 
need to be edited directly in the Chord Symbol window. When changing a chord 
enharmonically, the chord’s spelling changes, but the pitches of the chord notes remain 
identical. As an example:  When changing the “Gb7” enharmonically, it becomes “F#7”. 

To enharmonically change the root of chord symbols:
1 Select the chord.

2 Do one of the following:
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Â Choose Attributes > Accidentals > Enharmonic Shift: # (or use the Enharmonic 
Shift: # key command, default:  Shift-H).

Â Choose Attributes > Accidentals > Enharmonic Shift: b (or use the 
Enharmonic Shift: b key command, default:  Shift-B). 

Transposition of Chord Symbols
Chord symbols inserted into transposing staff styles are automatically transposed, just 
like notes. Further to this, if the Transposition parameter (for playback transposition) in 
the Region Parameter box is changed, all chord symbols in the MIDI region will be 
affected accordingly.

German Chord Symbols:  H Instead of B
If you choose one of the German Chord Symbol settings in the Chord Symbol 
Language menu of the Score project settings’ Global tab, the note B in all chord 
symbols is displayed with its German name H. The English B flat is written as B or Bb, 
when German chord symbols are displayed. 

Note:  The German (H, B, F#) setting is activated automatically, as soon as the letter H is 
used during chord symbol input.

Graphical Position of Chord Symbols
Each chord symbol is stored at a certain bar position in a MIDI region (there will often 
also be a note at that same bar position). 

The Event Parameter box Align option determines which part of the chord symbol is 
aligned to the bar position:  the left edge, center, or right edge of the letter 
representing the chord root. The setting for newly inserted chord symbols is always 
“def.“:  this default alignment matches the setting chosen in the Chord Symbol 
Alignment menu—found in the Layout tab of the Score project settings.

Rhythm Section Parts
Typically, rhythm section parts are notated with chord symbols and beat slashes. If you 
want to create this type of part, choose a staff style with a Rest parameter set to Slash. 
For more information, see “Rest” on page 752.
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Working With Time and Key Signatures
Signatures are global events, which affect all tracks in your project. You can view and 
edit time and key signatures in the Signature track, in the Signature List, and in the 
Score Editor. 

Note:  The Signature track must be visible—and must not be protected—in order to 
select and copy signatures.

To view the Signature track:
m Choose View > Global Tracks.

By default, the global Marker, Signature, and Tempo tracks will be visible when you 
enable the display of global tracks. If the Signature track is not visible, choose View > 
Configure Global Tracks, and enable the Signature checkbox.

To view the Signature List:
m Shift–double-click in the Signature track.

m Choose Options > Open Signature/Key Change List Editor. 

The Signature List displays time and key signatures in a list style editor, along with 
other global score symbols such as repeat signs, double bar lines, and so on.

Time Signatures
A time signature determines the number of beats in a bar (shown in the Bar ruler), thus 
defining the editing grid in the Arrange area and MIDI editors. A time signature does 
not affect the playback of audio or MIDI regions. 

Time signatures do, however, affect the score display. All functions reliant on the 
chosen time signature and bar positions (such as MIDI metronome click or Transform 
window functions) are affected—if bar positions are used to restrict a function to a 
certain part of the project.

Key Signatures
Key signature changes only affect the display of MIDI notes in the Score Editor—they 
do not have an effect on MIDI playback. The first key signature, however, affects the 
playback of audio Apple Loops. For more information, see “Global Tracks and Apple 
Loops” on page 621.

You can create as many key signatures as you wish. If your project already contains 
other key signature changes, any newly inserted key signature will change the key from 
the insertion point forward—until the next key signature change is reached. 

You can store up to nine signature alternatives in the Signature track.
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Creating Time Signatures
You can create as many time signatures as needed in a project. 

To create a time signature change, do one of the following:
m Move the playhead to the target bar, and set the new time signature in the Transport 

bar.

m In the Score Editor, drag the desired time signature from the Part box to the target bar 
position.

m Set the Signature track to a sufficient height, so that it displays both the key and time 
signature areas. Click the target bar in the Signature track’s time signature area with the 
Pencil tool, then choose the desired settings in the Time Signature dialog. 

Note:  If you perform this procedure when the track height is reduced, a time signature 
change will be created. 

Â The Beat Grouping entry field allows you to determine the grouping of beats in 
compound time signatures. It is sufficient to enter the numbers—223, for example. 
This becomes “2+2+3” automatically. The total number of beats in the bar is 
calculated automatically by the sum in this field. The Print Compound Signature 
checkbox needs to be activated, in order to display the defined grouping as the 
nominator. If not activated, only the total sum will be displayed as the numerator. 
Beat Grouping, however, affects the way the notes are beamed together—in both 
cases. You can also change the automatic beaming in normal time signatures. In 4/4-
time “1+1+1+1” produces four beamed groups (one for every beat), instead of the 
two groups displayed as a default.

Â Activate the Hide Signature checkbox to hide the corresponding time signature 
change in the printout. The signature will still be displayed onscreen, but it will be 
crossed out, and won’t be included in the calculation of spacing between notes and 
symbols. As a result, signatures may overlap notes on the screen, but not in the 
printout. This function can be used for notating cadenza-like passages, that contain 
more notes than would normally fit the time signature.

m Click the Create Time Signature button in the Signature List.
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Creating Key Signatures
You can create as many key signatures as needed in your project. 

To create a key signature, do one of the following:
m Click the desired position in the Signature track’s key signature area with the Pencil 

tool, then choose the desired key in the Key Signature window. 

Note:  You can disable the use of double flats and sharps by activating the “Disable bb, 
x” checkbox.

m In the Score Editor, double-click on the desired staff, between the clef and time 
signature, then choose the desired key in the Key Signature window. You can also drag 
the desired key signature from the Part box to the appropriate bar position. 

m Click the Create Key Signature button in the Signature List. 

Selecting Signatures
You can select signatures in the Signature List and Signature track by clicking them. 
Multiple selections are possible by Shift-clicking. 

In the Signature track—you can even select multiple signatures in conjunction with 
regions, which is very useful when you want to copy or move complete parts of a song 
(along with signature changes). The Edit > Select Inside Locators command can be 
helpful in this situation.
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Copying Signatures
You can copy time signatures and key signatures in the Signature List, or Signature 
track. It is also possible to copy all time and key signatures from one project to another.

Subsequent signatures are inserted at bar positions that correspond to their original 
distance from the first copied signature.

To copy signatures in a project via drag and drop:
m Press Option, then drag the signature (in the Signature track) to the target bar position. 

To copy signatures in a project via the Clipboard:
1 Select the time and key signatures in the Signature Editor or Signature track by clicking 

on them (Shift-click for multiple selections).

2 Choose Edit > Copy (Command-C) to copy them to the Clipboard.

3 Do one of the following:

Â In the Signature track:  Move the playhead to the desired insert position, then choose 
Edit > Paste (Command-V).

Â In the Signature List:  Choose Edit > Paste (Command-V), type in the desired insert 
position in bar position box, then close the box by pressing Return. 

To copy signatures between projects:
1 Select the desired signatures in the Signature track or Signature List.

2 Choose Edit > Copy (or press Control-C). 

All signature changes of the source project are copied to the Clipboard.

3 Switch to the desired target project.

4 Activate the Signature track or Signature List, then choose Edit > Paste (or press 
Control-V). 

The copied meter changes are pasted into the target project. 

Note:  As any copied time and key signature changes are mixed with those of the 
destination project when pasted, this procedure should only be used to copy such 
changes to a blank project (one that contains no time and key signature changes, 
except the initial settings). 
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Editing Signatures
You can edit existing signatures in the Score Editor and Signature track by double-
clicking on them. The Time or Key Signature window appears, allowing you to make 
the desired changes. Moves are achieved by selecting, and dragging, signatures.

Editing Time Signatures by Cutting and Merging Bars
You can use the Scissors tool in the Signature track to cut bars. As an example; to divide 
one 5/4 measure into a 3/4 and a 2/4 measure, cut it at the fourth beat of the 5/4 bar. 

If you make a cut in the middle of a bar—in a section where the time signature doesn’t 
change—two corresponding shorter measures will be inserted, with the original time 
signature resuming after the cut.

Likewise, it is also possible to merge two subsequent measures into one longer 
measure, by using the Glue tool in the Signature track.

Deleting Signatures
You can delete all signatures in a project, except the initial time and key signature. 

To delete a signature, do one of the following:
m Select the signature in the Score Editor, Signature List, or Signature track, then choose 

Edit > Delete (or press Backspace). 

∏ Tip:  To erase all time signature events, choose Edit > Select Similar Objects after 
selecting a signature, then press Backspace. 

m Click the signature with the Eraser tool in the Score Editor, Signature List, or Signature 
track. 

Creating and Choosing Signature Alternatives
Signature alternatives are just that:  alternative versions of all signatures on the 
signature track.

To create an alternative signature track:
1 Choose a number from the Alternative pop-up menu on the Signature track.
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If the signature track is not tall enough to show the Alternative menu, drag the lower 
lane line.

2 Insert the desired signatures, using the methods outlined above.

No save operation is necessary.

To switch between signature alternatives:
m Choose the desired number from the Alternative pop-up menu. 

All MIDI regions are affected, resulting in the appropriate changes to your score.

Transcribing MIDI Recordings
In this section, you’ll learn how to use the Score Editor’s display parameters to correctly 
notate your performances.

Traditional music notation is only an approximate description of the musical content in 
a piece. The actual performance depends heavily on the interpretation of notes by 
musicians. Quarter notes, for example, are hardly ever held for exactly one beat.

The rhythmic interpretation of MIDI regions (recorded in real time, to a metronome 
click) presents a similar problem, especially when you consider that Logic Pro records 
MIDI events at a resolution of 960 ticks per quarter note. Nobody will play a downbeat 
at the exact time of the metronome click. 

The Score Editor’s display parameters allow you to adjust the appearance of notation, 
without changing the playback (and feel) of the original MIDI region. You can use 
different display settings for each region.

As such, it’s important that you have some idea of what your printed music should look 
like. This will help to determine the display settings that will best fit your music. 

If you can’t seem to find the appropriate display parameters for a particular MIDI 
region, divide the region with the Scissors tool. This will leave MIDI playback unaltered, 
but allows you to assign different display parameters (display quantization) for each of 
the shorter regions that result from the cut operation. 

Even though these divided regions are separate, they adjoin each other, and will be 
displayed as a continuous staff in the score.

As a general working tip, you should merge MIDI regions (or insert blank regions) to fill 
the gaps between MIDI regions before altering the display settings. The Score Editor will 
display nothing if no region is present, resulting in blank spaces in your score.
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Default Settings for New MIDI Regions
If a new MIDI region is created with the Pencil tool in the Arrange area, or through MIDI 
recording, Logic Pro applies a set of default parameters to it. These defaults can be seen 
and edited in the Display Parameter box, when no MIDI region (no staff ) is selected. 
The title line shows Insert Defaults to indicate this status. These settings will remain as 
set, until you quit Logic Pro, but can be changed at any time. 

Click on any empty spot on the Score Editor background to display the Insert Defaults. 
Edit any of the parameters as desired—Set Quantize to the value that you will use for 
most regions in the project, for example. From this point on, all new regions will 
automatically use these settings when created. If Quantize is set to “default”, the display 
Quantize setting of newly recorded or created regions will match the division value 
shown in the Transport bar.

Note:  The default setting for staff styles (Style) is not defined here. This is separate for 
each track, and is set in the bottom line of the Arrange area’s Track Parameter box.

Simultaneously Changing the Settings of Several Selected MIDI Regions 
The top line of the Display Parameter box indicates the number of regions or objects (if 
the selection includes folders) currently selected (“3 Regions sel.”, for example), instead 
of the MIDI region name. If these regions have differing values for any of the 
parameters, a “*” will be displayed in the corresponding parameter line. If you change 
this value, all selected regions will be set to the same value for that particular 
parameter.

Selecting Multiple Regions in the Score Editor
You can use two special functions to select multiple regions in the Score Editor:
Â Click on the title line in the Display Parameter box to select all regions that are visible 

in the current display. 
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Â Click an instrument name, in the column between the parameters and score, to 
select all regions for that particular instrument track (even regions spread across 
different tracks that are assigned to the same software or MIDI instrument channel), 
at the current display level. Remember, the instrument name column is only 
displayed if View > Instrument Names is activated. 

Display Parameters
This section outlines all of the display parameters available in the Score Editor. To 
reiterate the point, these only affect the appearance of events in the score, not the 
playback of events!

Quantize
This parameter applies visual quantization to notes:  it determines the shortest note 
value that can be displayed in the currently selected MIDI region (exception:  artificial 
N-tuplets, see “Creating and Editing N-Tuplets” on page 700).

As an example:  If you insert a short note, such as a 32nd note, it can only be displayed 
at its original length if Quantize is set to 32 or shorter. If Quantize is set to 8, the 32nd 
note will be displayed as an eighth note (although it will still be played back as a 32nd 
note). 

The Quantize value is selected from a pop-up menu, which contains all available 
display quantization options. 

Among these are binary quantizations (displayed as one binary value—16 or 128), and 
hybrid quantizations (two values combined, a binary and a ternary value—16,24 or 
32,96 as examples).
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Binary values always correspond to the note value with the same denominator—as an 
example:  32 corresponds to thirty-second notes, and so on. Ternary values refer to 
triplets. Here is a list of the ternary values, and their corresponding triplet values:

When binary display quantizations are used, automatic triplets are not displayed at all 
(except for triplets inserted with the mouse, using an N-tuplet object). 

Important:  Therefore, a hybrid quantization value must be assigned to the Quantize 
parameter, to enable the automatic display of triplets.

Quantize Default Setting
The Quantize parameter’s Default option can only be set with the Insert Defaults (see 
“Default Settings for New MIDI Regions” on page 729). It cannot be set to its Default 
value in existing regions. If Default is chosen, the Quantize setting of any new MIDI 
region will be dependent on the current division value in the Transport. In this 
situation, the Quantize value will always be a hybrid value:  The division value currently 
set in the Transport window plus—in the case of a binary division value—the next 
highest ternary value. In the case of a ternary division value—the binary value, which is 
divisible by that particular ternary value.

As examples:  A global division value of 1/8 will result in an 8,12 Quantize setting for 
new regions, a global division value of 1/12 will become a 4,12 Quantize value, a global 
division value of 1/16 will result in a Quantize value of 16,24, 1/24 in 8,24, and so on.

Note:  If a particular Quantize value has already been set in the Insert Defaults, all new 
regions will be assigned this value, regardless of the division value in the Transport bar. 
You may, of course, change any of these values at any time.

Quantize setting Corresponding note length

3 1/2-note triplets

6 1/4-note triplets

12 1/8-note triplets

24 1/16-note triplets

48 1/32-note triplets

96 1/64-note triplets

192 1/128-note triplets

384 1/256-note triplets
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Choosing a Quantize Value for Swing Notation
For regular swing notation, 8,12 should be used as Quantize parameter. This enables 
the display of eighth-note triplets, and also displays two uneven notes on one beat 
(dotted eighth and sixteenth), as regular eighth notes. 

For double-time passages containing sixteenth notes, you either need to:
Â Cut the MIDI region in the Arrange area, and assign a higher quantize value to the 

new MIDI region (that contains the double-time figure).
Â Use hidden artificial N-tuplets for the sixteenth notes  (see “Creating and Editing N-

Tuplets” on page 700).

For swinging sixteenth notes (shuffle funk, hip hop, and so on), the same principle 
applies. In this case, Quantize would be set to 16,24.

Fixing the Score Quantize Value
The Functions > Quantization > Fix Displayed Note Positions and Fix Displayed Note 
Positions and Durations commands can be used to fix the display quantization of all 
MIDI events in the project. These commands may be useful for exporting projects 
(complete with display quantize settings) to other notation programs that don’t feature 
display quantization.

Interpretation
If Interpretation is enabled, notes are generally displayed with longer length values than 
their actual length, in order to avoid short rests. Short notes on a downbeat in 4/4 time, 
for example, are displayed as quarter notes. The score becomes less precise as a result, 
but is easier to read.

If Interpretation is disabled, note lengths are displayed as close as possible to their real 
values, as determined by the Quantize value. In the following example, the same MIDI 
region is shown twice, the first with Interpretation disabled, the second enabled:

The Interpretation function is intended to produce an easy-to-read score display of real 
time recordings. You should generally switch it off when using step or mouse input. 
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You can use note attributes to switch Interpretation on and off for each individual note, 
overriding the Display Parameter box setting (see “Using Note Attributes to Change 
Individual Notes” on page 735).

To switch interpretation on or off for a selected note, do one of the following:
m Choose Attributes > Interpretation, then choose the desired setting.

m Double-click the note, then choose the desired setting in the Note Attributes window. 

m Use one of the following key commands:

Â Default Interpretation
Â Force Interpretation
Â Defeat Interpretation

Syncopation
If Syncopation is enabled, each (MIDI) note will be notated as one graphic note (not 
displayed as several tied notes), regardless of position—if possible. (This also depends 
on the Max. Dots setting, see below.) If this isn’t possible, the note is graphically divided 
into the minimum possible number of notes, connected by ties.

This facility is usually used for the display of syncopated notes. The following example 
shows the same two bars displayed differently, the first with Syncopation disabled, then 
enabled:

Syncopation can also be enabled and disabled for each note, independent of the 
Display Parameter box setting. This can be via note attributes (see “Using Note 
Attributes to Change Individual Notes” on page 735).

If an unwanted display of ties and notes results from the Syncopation function, it is 
possible to change the graphic display of notes connected with ties. 

m Insert a user rest from the Part box (preferably a short one, but the length isn’t 
important) at the bar position where you want the tie subdivided. 

Once the rest is inserted, it will disappear, but the note display will change. The inserted 
rest can only be seen and edited in the Event List.
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This trick works for all notes, not just syncopated ones (see “Creating Tied Notes” on 
page 699). In polyphonic staff styles, the MIDI channel of the rest and the 
corresponding note must be identical.

No Overlap
No Overlap, when turned on, prevents the overlapped display of notes in melodies that 
are played with an exaggerated legato. The displayed length of notes is truncated 
(shortened) to the beginning of the next note (unless a polyphonic staff style is used—
see “Working With Staff Styles” on page 741 for details). Notes beginning 
simultaneously (chords, in other words) are displayed with the (note) length of the 
shortest note in the chord.

When set to off, the score display shows the lengths of the notes fairly precisely. The 
music is definitely harder to read this way, however.

The effect can be seen in the following example, which shows the same MIDI region, 
first without, then with, overlap correction:

No Overlap should only be deactivated in rare cases. If, for example, a piano player 
arpeggiates a chord and holds the notes, the score displays the following result with 
No Overlap on:

Although you can’t see that all notes continue to sound here, the result looks like this if 
No Overlap is deactivated:

The solution typically involves switching No Overlap on, and using sustain pedal 
markings. Logic Pro will automatically display pedal markings if notes are recorded in 
real time with a MIDI keyboard, and sustain pedal.



Chapter 33    Working With Notation 735

Max Dots
This parameter determines the maximum number of dots that Logic Pro will allow for 
the display of single notes. Unwanted dotted notes or rests can be changed by 
inserting user rests (which remain invisible, if notes). Take a look at the information on 
changing the way notes with ties are displayed (see “Creating Tied Notes” on page 699).

Score
This parameter is accessed via the Arrange window’s Region Parameter box (only 
visible if the View > Extended Region Parameters setting is enabled). If Score is set to 
Off here, the MIDI region will not be displayed in the score at all. This is mainly used to 
prevent the score display of particular regions—namely those that only contain MIDI 
events which can’t be displayed in the score, such as controller or SysEx data. 

Hidden MIDI Regions
In some situations, certain MIDI regions will not be displayed in the Score Editor.
Â Muted MIDI regions, if Hide Muted Regions is enabled in the Global tab of the Score 

project settings.
Â MIDI regions on muted tracks, if Hide Muted Tracks is activated in the Global tab of 

the Score project settings.
Â MIDI regions with a Score parameter set to “off” in the extended region parameters.

Using Note Attributes to Change Individual Notes
You can use note attributes to set individual display parameters for each note, 
regardless of the settings in other windows and boxes.

You can set the following note attributes:
Â Form of the note head, and note size.
Â Horizontal position.
Â Change of accidental distance.
Â Enharmonic changes.
Â Settings for interpretation and syncopation, independent of the settings in the 

Display Parameter box.
Â Stem direction, tie direction, and beaming, independent of the settings in the staff 

style being used.
Â Display as an independent note, which excludes the note from the measure’s overall 

rhythmic calculation.

You can change note attributes in the Note Attributes window, via the Attributes menu, 
or the respective key commands. 
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Note:  Please ensure that the Note Attributes setting is chosen in the “Double-click note 
to open” menu of the Logic Pro > Preferences > Score window. It is on by default.

To change note attributes, do one of the following:
m Double-click a note head to launch the Note Attributes window. 

Only one note can be changed at a time in the Note Attributes window.

m Select one or more notes, and choose the desired command from the Attributes menu. 

The Attribute menu (and corresponding key commands) allows a group of selected 
notes to be assigned new attributes.

You can also change specific note attributes via the Part box, and with tools. 

The following section lists all note attributes, and provides information on accessing 
and altering various attribute options.

Changing Note Head
The default setting for note heads is normal (round and black).

To change the attributes of a note head, do one of the following:
m Drag the desired note head from the Part box to the respective note.

m Choose the desired note head from the Note Head menu in the Note Attributes 
window.

Changing Note Sizes
The default note size is set with the Size parameter in the Staff Style window.

To change a note’s size, do one of the following:
m Click-hold the note with the Resize tool and drag up (increase) or down (decrease). 

m Choose the desired size in the Size menu of the Note Attributes window.
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Changing the Horizontal Position of Notes
You can set the horizontal position of each note, individually.

To change a note’s horizontal position, do one of the following:
m Click-hold the note with the Layout tool, and drag to the left or right. 

m Choose the desired value in the Horizontal Position menu of the Note Attributes 
window.

Changing the Position of Accidentals
This note attribute defines the deviation from the Acc./Note Distance value, chosen in 
the Layout tab of the Score project settings.

To change the accidental distance from the note:
m Choose the desired value in the Accidental Position menu of the Note Attributes 

window.

Changing the Display of Accidentals
By default, the display of accidentals depends on the chosen key signature.

To change the display of accidentals, do one of the following:
m Choose the desired value in the Enharmonic Shift or Accidental Type menu (see list of 

settings below) of the Note Attributes window.

m Choose the desired value from the Attributes > Accidentals menu. 

You can choose between the following display options:
Â Default Accidental:  The display of accidentals depends on the chosen key signature. 
Â Enharmonic Shift: #:  Converts G flat to F sharp, or F to E sharp, for example.
Â Enharmonic Shift: b:  Converts D sharp to E flat, or B to C flat, for example.
Â Flats To Sharps:  Similar to Enharmonic Shift #, but leaves notes without flats 

unaltered (useful for multiple selection).
Â Sharps To Flats:  Similar to Enharmonic Shift b, but leaves notes without sharps 

unaltered (useful for multiple selection).
Â Force Accidental:  Forces the display of accidentals (and naturals).
Â Hide Accidental:  Displays the note without accidentals (MIDI playback is not affected).
Â Guide Accidental:  Forces the display of the accidentals (and naturals) in parentheses.

m Use one of the following key commands:

Â Default Accidentals
Â Enharmonic Shift: #
Â Enharmonic Shift: b
Â Flats To Sharps
Â Sharps To Flats
Â Force Accidental
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Â Hide Accidental
Â Guide Accidental

Changing the Stem Direction and Length
By default, a note’s stem direction and length depends on the respective setting in the 
Staff Style window.

To change a note’s stem direction and length:
m Choose the desired value in the Stem Direction menu of the Note Attributes window.

Note:  The stem length can not be changed in the Note Attributes window.

m Choose the respective item in the Attributes > Stems menu.

Â Default:  The stem direction is set in accordance with the default (staff style) setting.
Â Up:  The note’s stem is forced upwards.
Â Down:  The note’s stem is forced downwards. 
Â Hide:  Hides a note’s stem, and the corresponding beam or flag.
Â Stem End: Default Length:  Default setting.
Â Stem End: Move Up:  Moves the stem end upwards. Depending on the direction, this 

shortens or lengthens the stem.
Â Stem End: Move Down:  As above, but moves the stem end downwards.

m Use one of the following key commands:

Â Stems: default
Â Stems: up
Â Stems: down
Â Stems: hide
Â Stem End: Default Length
Â Stem End: Move Up
Â Stem End: Move Down

Changing the Beaming of Notes 
By default, the beaming of notes depends on the chosen time signature, the Beat 
Grouping setting in the Time Signature dialog, and on the staff style’s Beam parameter.

To change the beaming of notes, do one of the following:
m Choose one of the following items in the Attributes > Beaming menu:

Â Beam Selected Notes:  Forces a beam to the following note.
Â Unbeam Selected Notes:  Interrupts the beam to the following note.
Â Default Beams:  Uses the default setting.

m Use one of the following key commands:

Â Beam Selected Notes
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Â Unbeam Selected Notes
Â Default Beams

Changing the Voice or Staff Assignment
You can change the voice or staff assignment for cross staff beaming in the Attributes 
> Ties menu (see “Advanced Staff Style Usage” on page 756).

You can choose between the following options (requires a polyphonic multi staff style):
Â Default Staff:  According to voice assignment.
Â Staff Above Voice:  Moves the selected notes to the staff above the assigned voice.
Â Staff Below Voice:  Moves the selected notes to the staff below the assigned voice.

Changing the Tie Direction
By default, the tie direction is set in accordance with the setting in the Staff Style 
window.

To change a note’s tie direction, do one of the following:
m Choose the desired setting in the Attributes > Ties menu.

m Choose the desired tie direction in the Tie Direction menu of the Note Attributes 
window.

m Use one of the following key commands:

Â Ties: default
Â Ties: up
Â Ties: down

Changing the Syncopation of Notes
By default, note syncopation is set in accordance with the setting in the Display 
Parameter box.

To change a note’s Syncopation setting, do one of the following:
m Choose the desired setting in the Attributes > Syncopation menu.

m Choose the desired setting in the Syncopation menu of the Note Attributes window.

m Use one of the following key commands:

Â Default Syncopation 
Â Force Syncopation
Â Defeat Syncopation
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Changing the Interpretation of Notes
By default, note interpretation matches the setting chosen in the Display Parameter 
box.

To change a note’s Interpretation setting, do one of the following:
m Choose the desired setting in the Attributes > Interpretation menu.

m Choose the desired setting in the Interpretation menu of the Note Attributes window.

m Use one of the following key commands:

Â Default Interpretation
Â Force Interpretation
Â Defeat Interpretation

Changing the Independent Status of a Note
Notes are not displayed as independent notes by default.

To change the independent status of a note, do one of the following:
m Choose the desired setting in the Attributes > Independent menu:

Â Independent Grace:  The note is displayed as a single (independent) grace note.
Â Independent:  The note is displayed independent of the rhythmic context.
Â Not Independent:  The note is displayed in the regular rhythmic context.

m Use one of the following key commands:

Â Not Independent
Â Independent
Â Independent Grace

Changing the Color of a Note
You can assign different colors to individual notes, in accordance with the three color 
palettes.

To assign a color to a note:
1 Select the note.

2 Choose one of the 16 colors in the Attributes > Colors menu.

You can also enable the Velocity or Pitch Color mode in this menu. Pitch colors can be 
diatonically or chromatically mapped. Note velocity colors match particular MIDI 
velocity ranges.

You can edit the 16 color options of the Attributes menu, the Velocity, and Pitch, colors 
in the Color tab of the Score project settings. For more information see “Colors” on 
page 793.
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Note:  As note attributes, these settings have priority over the staff style settings, but 
they only apply if the color mode is set to Normal in the Score Editor’s View > Colors 
menu.

Resetting Note Attributes
You can reset all note attributes to their default settings by choosing Attributes > Reset 
All Attributes (or using the Reset Note Attributes key command). 

Working With Staff Styles
Staff styles store multiple attributes, such as the clef, staff size, vertical distance 
between staffs, instrument transposition, and so on. It’s simply a case of choosing a 
new staff style to alter the score layout of any existing, or newly created, MIDI region. 
The chosen staff style has no effect on MIDI playback. It only affects the way Logic Pro 
displays the score.

On occasion, the included set of predefined staff styles will not meet your needs, and 
you will need to create your own. This is done in the Staff Styles window (see “Creating 
Your Own Staff Styles” on page 744).

Staff styles are saved with the project file, allowing different staff styles in different 
projects. 

∏ Tip:  Create some empty template projects with (among other things) the staff styles, 
and other score settings, that you would normally use as a basis for your work.

Assigning Staff Styles to MIDI Regions
You can assign a different staff style to each individual MIDI region. In most 
circumstances, the predefined staff styles will meet your needs (see the table below). 
Changing staff styles enables you to quickly:
Â Create parts for transposing instruments.
Â Display the same MIDI region at different sizes—perhaps to print out a full score, and 

individual parts for the different instruments.
Â Change between different display forms in one staff. This would be done by cutting a 

MIDI region, and assigning different staff styles to the resulting shorter regions. This 
might be used to alternate between passages that are completely transcribed, and 
improvised passages—using only beat slashes and chord symbols—for example.

Warning:  Take care when doing this:  all symbols directly attached to notes (accents, 
fermatas, jazz symbols, and so on) will be deleted when you reset note attributes!
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To assign a staff style (predefined or user-created) to a MIDI region:
1 Select the MIDI region.

2 Choose the desired staff style from the Style parameter pop-up menu in the Display 
Parameter box.

You can also simultaneously assign a staff style to several selected regions.

Automatic Staff Style Assignment
When you create a new MIDI region, either by making a real time recording or with the 
Pencil tool in the Arrange area, the MIDI region will be assigned the staff style selected 
in the bottom line of the Track Parameter box. 

When you create template projects, or begin work on a new project, you may wish to 
change these settings for tracks that are likely to use a specific staff style. This ensures 
that regions recorded on these tracks will immediately be displayed with the correct 
staff style

If Auto Style is chosen in the bottom line of the Track Parameter box, every new MIDI 
region will automatically be assigned a staff style that fits the register of the recorded 
notes. In other words, a Bass staff style will be selected automatically if your region 
consists of notes played in a low octave. Similarly, two-handed parts will be assigned a 
Piano staff style.

Note:  Auto Style can only be chosen in the Arrange area’s Track Parameter box, and 
does not appear in the list of staff styles in the Score Editor’s Display Parameter box.
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Predefined Staff Styles
Logic Pro contains a number pre-defined staff styles. The table lists them all, and their 
parameters:

Staff style Clef type Transposition

Bass Bass clef —

Lead Sheet Treble clef —

Piano (two staffs) Treble/Bass clef —

Treble Treble clef —

Treble +8 Treble (+8) clef –1 octave

Treble –8 Treble (–8) clef +1 octave

Alto Sax Treble clef Eb (+9) 

Baritone Sax Bass clef Eb (+21)

Contrabass Bass (–8) clef +1 octave

Guitar Tablature display —

Guitar Mix (Tablature display 
and one staff )

Tablature display/Treble (–8) clef —

Horn in Eb Treble clef Eb (–3)

Horn in F Treble clef F (+7)

Organ 1+2/3+4/5 (3 staffs) Treble/Bass/Bass clef —

Organ 1+2/3/5 (3 staffs) Treble/Bass/Bass clef —

Organ 1/1/5 (3 staffs) Treble/Bass/Bass clef —

Organ 1/3+4/5 (3 staffs) Treble/Bass/Bass clef —

Organ 1/3/5 (3 staffs) Treble/Bass/Bass clef —

Piano1+2/3 (2 staffs) Treble/Bass clef —

Piano1+2/3+4 (2 staffs) Treble/Bass clef —

Piano 1/3 (2 staffs) Treble/Bass clef —

Piano1/3+4 (2 staffs) Treble/Bass clef —

Piccolo Treble clef –1 octave

Soprano Sax Treble clef Bb (+2)

Tenor Sax Treble clef Bb (+14)

Trumpet in A Treble clef A (+3)

Trumpet in Bb Treble clef Bb (+2)

Viola Alto clef —

Violoncello Bass clef —

# Drums Percussion Clef Mapped
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Creating Your Own Staff Styles
You can create new staff styles, and edit, delete, and duplicate existing staff styles in 
the Staff Style window. 

A staff style includes the following editable parameters:
Â Number of staffs (for the display of one MIDI region).
Â For polyphonic, multiple staff styles:  configuration of brackets and bar lines that 

connect the staffs.
Â For every staff:  Staff size, distance to the next (higher and lower) staffs, number of 

independent (polyphonic) voices in the staff, clef, display transposition, key signature 
on/off.

Â For every independent (polyphonic) voice:  Automatic rest display on/off, stem 
direction of notes, tie direction, direction of N-tuplet brackets and numbers, 
beaming.

Â MIDI channel assignment for the voice, or definition of a split point pitch—for 
separation of the different voices, note color, number of staffs used to display a MIDI 
region (usually one, but two when using the Piano styles, and three when using the 
Organ styles), the clefs, and display transposition.

To open the Staff Style window:
m Choose Layout > Staff Styles (or use the Open Staff Style Window key command).

Â Link Button:  If the Link button is activated while the Staff Style window is open, you 
will always see the parameters of the currently selected MIDI region’s staff style. If 
you switch to a different MIDI region, the Staff Style window will reflect the new 
selection.

 Hierarchy button

Link button Tools

 Name box

Voice parametersStaff parameters Assign parameters
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Â Hierarchy button:  Click to switch the Staff Style window between single staff style 
view and list views (the latter shows a list of all available staff styles). 

Â Tools:  Contains the Pointer tool, the Pencil tool (for creating new staffs and voices) 
and the Eraser tool (for deleting staff styles, staffs, or voices).

Â Name box:  The field shows the name of the selected staff style. Click the arrow 
button next to it to open a pop-up menu that lists all styles available in the current 
project. Switch to another staff style by choosing the desired entry

Â Staff parameters:  The parameters for staffs. Each line below the word Staff represents 
one staff in the score display. 

Â Voice parameters:  The parameters for independent voices. Each line below the word 
voice represents one independent voice. The term voice only relates to the 
simultaneous display of rhythmically independent, polyphonic passages in the 
music—not the number of notes that can be displayed simultaneously. One voice 
can consist of as many simultaneous notes (chords) as desired. Only notes which 
should be displayed as rhythmically independent (from the other notes in the same 
staff ) need to be assigned to separate voices.

Â Assign parameters:  The parameters for the assignment of notes to the different 
voices. Every staff can contain several independent voices (up to 16), but one voice 
can not be displayed across different staffs. Therefore, a staff style must contain at 
least as many voices as staffs.

The Staff Style window features the single staff style view shown above, and a list view. 
The list view is mainly intended for copying staff styles between projects (see below), 
or for deleting styles.

To switch the Staff Style window to list view, do one of the following:
m Double-click in the empty space below the parameters to switch to the list view. 

Another double-click on one of the listed staff styles switches to the single view of that 
particular Style. 

m Click on the Hierarchy button to the left of the menu line.
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Creating a New Staff Style
In single view, you can create a new staff style by choosing New > Single Staff Style or 
New > Dual Staff Style. The parameters of styles created this way are very basic, and 
need to be edited (see below) to meet your requirements, in most cases.

The default name of styles created in this fashion is “*New Style”. A double-click on the 
name box opens a text entry field, where any name can be typed in.

Creating New Staff Styles Based on Existing Ones
You’ll often need a new staff style that is almost identical to an existing one. In this 
situation, just make a copy of the close style, and edit the copy. 

To copy a staff style, do one of the following:
m Choose New > Duplicate Style in the Staff Style window’s single view.

m Click the arrow button next to the Staff Style window’s Name box, then choose 
****DUPLICATE!**** in the pop-up menu.

∏ Tip:  You can copy the current staff style, and assign it to a selected MIDI region in one 
go:  Select the desired MIDI region in the Score Editor, click the Style parameter in the 
Display Parameter box, then choose the “****DUPLICATE!****” command in the Staff 
Style pop-up menu. 

Any of these methods will result in a new style—named after the staff style it is derived 
from—with “*copied” appended to its name. This text can be edited in the name box of 
the Staff Style window.
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Adding Staffs to a Staff Style
You can add a staff to your staff style. This allows you to create a two-staff piano style 
from a single staff style, for example.

Each staff is represented by a number in the first column. These numbers are assigned 
automatically, and cannot be changed. 

To add a staff to a staff style:
m Determine the staff insert position by clicking in the narrow column to the left of the 

staff numbers in the Staff Style window, then choose New > Insert Staff. 

The new line is inserted at the insert mark (>) position.

Adding Voices to a Staff Style
You will need polyphonic staff styles (staff styles with independent voices) to display 
rhythmically different melodic lines in the same staff (typical for choirs). Theoretically, 
you can create up to 16 independent voices in a staff style. 

To add a voice to a staff style:
m Choose New > Insert Voice. 

The new voice will be inserted at the insert mark (>) position, set with a click in the 
narrow column to the left of the staff numbers (this is important if you want to insert a 
new voice between existing voices).

The newly inserted voice will inherit the parameters of the voice above it. These can be 
freely edited. The staff field in the first column remains empty. 

The default project contains a number of polyphonic staff styles for piano (Piano 1+2/
3+4, for example) and church organ (Organ 1+2/3+4/5, with three staffs, for example).
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Copying Voices or Staffs Into Other Staff Styles
You can copy one (or several) voices and staffs, inclusive of their parameters, into other 
staff styles. 

To copy a voice or staff into another staff style:
1 Select the voices or staffs you want to copy, by dragging the mouse vertically in the 

margin column to the left of the staff numbers. 

The selection will be indicated by a dark gray vertical beam.

2 Choose Edit > Copy (or use the Copy key command, default:  Command-C). 

3 Switch to the target staff style that you want to paste these voices into (this also works 
between different projects). 

4 Set the insert mark, then choose Edit > Paste (or use the Paste key command, 
default:  Command-V). 

Note:  If a voice is selected in the destination staff style (indicated by a black beam in 
the left column), it will be replaced by the pasted voices.

Copying Staff Styles Between Projects
At some point, you’ll probably want to use staff styles that exist in another project. 

To import all staff styles from another project:
1 Choose Options > Import Settings in the Score Editor (or use the Import Settings key 

command).

2 In the Import Settings window, select the project that contains the desired staff styles, 
activate the Staff Styles checkbox (and disable all other settings that you don’t want to 
import), and click Import. 

This imports all staff styles from another project into the current one.

To copy particular staff styles from other projects:
1 In the project that contains the staff styles you want to copy:  Open the Staff Style 

window (single view will be shown).

2 Double-click in the space below the staff style parameters to show a listing of all staff 
styles.

3 Select the desired staff styles.

4 Choose Edit > Copy (or use the Copy key command, default assignment:  Command-C).

5 Open the Staff Style window in the target project.
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6 Choose Edit > Paste (or use the Paste key command, default assignment:  Command-V).

Automatic Staff Style Copying
If you copy a MIDI region from one project to another, and the staff style used by the 
original MIDI region doesn’t exist in the target project file, it is automatically copied, 
along with the MIDI region.

Deleting Voices or Staffs From a Staff Style
To delete voices or staffs from a staff style, select them and press Backspace, or choose 
Edit > Delete.

Deleting Staff Styles 
You can delete staff styles in both the single view, and list view. The latter allows you to 
select, and delete, several staff styles simultaneously. 

To delete a staff style in single view:
m Choose New > Delete Style.

To delete multiple staff styles in List view:
m Shift-click the (un)desired staff styles, then choose Edit > Delete (or press the Backspace 

key).

∏ Tip:  In list view, you can use the Edit > Select Unused command, to select all staff 
styles that are currently not assigned to any regions or track instruments in the project.

Changing Staff Style Parameters
Once you have created or imported a staff style, and set the desired number of voices 
and staffs, you can edit the following parameters in the Staff Style window. 

Name
Double-clicking on the name box to the left of the staff and voice columns allows you 
to input the desired staff style name.

About Key Range
Notes that fall outside the key range (defined to the left of the Staff Style window) are 
not displayed in the Score Editor. This allows you to hide notes that are used for key 
switching duties (as an example, VSL sample libraries loaded into the EXS24 mkII).
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Brackets and Bar Line Connections
You can only edit this parameter in styles with multiple staffs:  It lets you determine 
which staffs are bracketed (two bracket types available) or connected by bar lines (only 
at the beginning of each staff line, or at every bar line). Simply click-drag in the 
corresponding column until you see the appropriate display, for any of these 
connections. 

If a staff style consists of more than two staffs, the brackets and bar lines can be set to 
only connect certain parts of the overall staff style—they can be interrupted in-
between staffs. If you want to delete any connections, grab the symbol at its end 
(bottom), and drag it up, until it disappears.

Space
These values determine the distance to the next (higher and lower) staff, or the page 
margins, for the top and bottom staffs in a full score.

The first value increases or decreases the space above staffs, and the second value, the 
space below staffs.

This parameter is helpful when you need to create additional space above or below a 
staff, allowing symbols to be inserted between staffs.

You can also change the vertical distance above the staff directly in the score, by 
dragging the staff up or down (at the clef ).

The distance below the staff can also be edited in the score, but only for the bottom 
staff in the score display, or if only one staff is displayed. The bottom line of the score 
display area is dragged with the mouse.

These editing procedures change the settings of the corresponding staff style. All 
regions which use the same staff style will be affected. 

Size
Use this parameter to determine the size of the staff, and the notes and symbols 
(including slurs and ties) it contains.

There are 16 sizes available (0–15). Here are some size recommendations:
Â For regular instrument parts and lead sheets, use size 7 or 8. 
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Â The staff size you should use in full scores depends on the number of staffs in the 
score, and the size and format of the paper being used. When using A4 or US letter 
paper:  full orchestra:  2, big band:  3, wind quintet:  4.

Note:  The size of all staffs in a score set can also be affected by the Scale parameter 
(see “Using Score Sets to Create Scores and Parts” on page 762) in the Score Set 
window. This makes it possible to use the same sizes for both the whole score, and 
parts of a piece.

Clef
You can select the clef to be used in the staff style from a pop-up menu. This menu 
offers some special options, in addition to the usual clefs:
Â Drum.0 to Drum.8:  Staffs with 0 to 8 lines and a neutral percussion clef. The 

relationship of MIDI note pitches to the top line of all staffs corresponds to the top 
line in a regular bass clef (A2). No accidentals will be displayed in these drum staffs. 
Drum.0 also omits any ledger lines. These clefs are often used in mapped drum styles 
(see “Drum Notation With Mapped Staff Styles” on page 758), where the vertical 
position of a note on the staff doesn’t correspond to pitch, but is determined by 
different drum map parameters.

Â no clef.0 to no clef.8:  Is like the Drum.0 to Drum.8 staffs, but without a clef.
Â TAB Guitar … and TAB Bass …:  12 different options for displaying notes as guitar or 

bass tablature. Tablature tuning sets are defined and edited in the Tablature window 
(Layout > Guitar Tablature).

Transpose
The display transposition, measured in half steps up or down. This parameter does not 
affect MIDI playback. If a staff contains chord symbols, these will also be transposed 
accordingly. If the Automatic Key Transposition project setting, in the Clefs & Signatures 
tab is activated (which is the default), key signatures will also be transposed (with one 
exception, see next paragraph).

Key
If this parameter is set to Hide, the corresponding staff is displayed without a key 
signature. All sharps and flats are indicated directly beside notes. This parameter will 
usually be set to show the key signature. The Hide option is mainly used for transposed 
french horn parts, which are sometimes written without a key signature.

Note:  The Automatic Key Transposition project setting affects the whole project, but 
still indicates the non-transposed basic key signature. Hide Key suppresses any key 
signature display. 
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Rest
The automatic rest display can be switched off (Hide), or set to display beat slashes 
(slash) instead of rests. This is useful for rhythm section parts, and improvised solos. In 
this situation, the number of slashes per bar is determined by the nominator in the 
time signature (4 slashes in 4/4-time, 6 slashes in 6/8-time, and so on). Inserted notes 
and symbols are still displayed, but automatic rests are only shown if shorter than one 
beat. You can insert user rests manually, to replace individual beat slashes, if needed.

Stem
This controls the direction of stems. The default setting is Auto. Up or Down forces all 
stems, regardless of pitch, in the corresponding direction. Hide makes all stems (and 
beams and flags) invisible.

Tie
Determines the vertical direction of automatically displayed ties. The default setting is 
Auto. Up or Down forces all ties in the corresponding direction.

Tuplet
Controls the direction of N-tuplet brackets and numbers. The default setting is Auto. Up 
or Down forces all N-tuplet brackets and numbers in the corresponding direction. Hide 
prevents the automatic display of triplet brackets and numbers. In this situation, the 
numbers are still displayed in brackets on the screen, to allow edits to these triplets. 
These bracketed numbers will not appear, however, on the printout.

If you set this parameter to Hide, you can still make particular triplets visible:  Double-
click on the bracketed number (3) to open a tuplet dialog box. If you close this box by 
clicking OK, you will convert the automatically displayed triplet to a forced triplet, 
which will be displayed in accordance with the parameters set in the dialog box.

Beam
Controls the appearance of beams. The default Slant setting allows slanted beams. 
Horiz. only allows horizontal beams. Vocal prevents the display of beams, as is typical in 
classical vocal parts, where notes are only displayed with flags.

Color
Sets the color of the voice’s notes. The color options are:  Black (“---”), Pitch, Velocity, 
and the 16 colors of the user palette (see “Colors” on page 793).

These settings only affect regions if the View > Colors > Normal item is enabled in the 
Score Editor (default setting).

Assign Parameters
The Chan and Split parameters of the Staff Style window are covered in the following 
section on note assignment.
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Assigning Notes to Voices and Staffs
You can use two different methods for assigning notes to voices and staffs:  by defining 
a fixed split point, or MIDI channels for each voice of a staff. 

Using a Split Point
You can use a fixed split point to assign notes to voices. This is a defined pitch, which 
determines the absolute border between two voices. Notes above it, or at the same 
pitch, are assigned to the upper voice. Notes below it are assigned to the lower cross 
the border. Quite often, in real life situations, the border between voices needs to be 
flexible. A piano piece’s right hand part may dip below middle C (the defined split 
point), or the left hand may go above. It’s not possible to notate this properly using a 
fixed split point, but you can use this facility to create an almost right version.

To separate voices by split point:
m In the Staff Style window’s Split column, choose the desired note pitch. 

Using MIDI Channels 
You can use MIDI channels (Chan) to assign notes to voices. Every note belongs to the 
voice that “owns” its MIDI channel. The different MIDI channels have no impact on MIDI 
playback, as the playback channel is determined by the Track Parameter box setting 
(Arrange window). Given the use of MIDI channels for voice assignment, notes that 
aren’t assigned to channels will not be displayed at all. This can, however, be used to 
your advantage, as it allows you to exclude certain notes from the display (improvised 
parts, trill notes, and so on).

To separate voices by MIDI channel:
m In the Staff Style window’s Chan column, assign the desired MIDI channel to each voice.

When you use MIDI channels to assign notes to staffs or voices:
Â You can edit the MIDI channel in the same way as for all other events:  by selecting 

the events and changing the MIDI channel in the Event Parameter box or the Event 
List.

Â You can quickly change the MIDI channel of selected note events with the Event 
Channel +1 and Event Channel –1 key commands. These can be especially useful 
when used in combination with the Select Next Region/Event and Select Previous 
Region/Event key commands, which allow you to move the selection from note to 
note.

In addition, you can also use Score Editor functions designed to speed up the process 
of changing the MIDI channel settings of notes, in order to assign them to the desired 
voices:  These include the Auto Split preference and the Voice Separation Tool. 
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Splitting MIDI Channels Automatically
If you record polyphonic voices as separate passes in real time, you can set your 
keyboard or MIDI controller to the appropriate MIDI channel for each voice. This saves 
you from editing the channels after the fact. The same applies to step input.

Alternately, you can automatically split MIDI notes using the “Auto split notes in multi 
staff chord styles” Score preference. 

If this is activated, and the default staff style in the selected Track Parameter box is a 
polyphonic style, all played notes are automatically assigned MIDI channels that match 
the staff style’s voice assignments. Notes at, and above, the split point are assigned the 
channel of the first voice. Notes below are assigned the second voice’s channel (this 
feature only works for two voices at a time). This creates a rough, but usable, voice 
assignment, which can be edited later.

To split regions that have already been recorded:
1 Select the region.

2 Choose Functions > Note Events > Assign Channels based on Score Split (or use the 
corresponding key command). 

This assigns the region’s notes to voices in the staff style—according to the Auto Split 
pitch in the Score preferences.

Using the Voice Separation Tool
The Voice Separation tool allows you to draw a separation line between notes on a a 
staff, thereby assigning them to the MIDI channels of the voices. MIDI channels have to 
be pre-defined for each of the voices that you want to separate. This is because 
Logic Pro needs to know which MIDI channels are assigned to each note.

To use the Voice Separation tool to change the MIDI channel of notes:
1 Select the Voice Separation tool.

2 Draw a line (between notes) where you want to separate the voices. 



Chapter 33    Working With Notation 755

Notes below the line are moved to the MIDI channel below their current assignment.

3 If you make a mistake, just move the mouse back slightly to the left

This erases the separation line to the right of the tool, allowing you to try again.

Staff Style Examples
The following sections illustrate how you can use the staff style facilities to meet 
specific notation needs.

Creating a Staff Style for Two Independent Voices
If there are two independent voices throughout the piece, the parameters might be set 
as follows:  Stem, Tie, and N-tuplet direction are set to Up for the top voice and Down 
for the bottom voice. Note that even with these general parameters, note attributes 
(see “Using Note Attributes to Change Individual Notes” on page 735) can be changed 
for each note. Both voices are displayed with automatically displayed rests (Rest 
parameter:  Show). 

Creating a Single-Staff Style With Optional Polyphony
Sometimes you need to add a second voice to a staff that usually only requires one 
voice, in order to properly notate a short, rhythmically-independent passage. This is not 
uncommon with orchestral scores, where the unison part for a group of instruments is 
temporarily separated from the other parts. 

One solution is to use a staff style with a main voice and a secondary voice. The 
parameters for the main voice should be set as per a non-polyphonic style. The 
secondary voice is set to channel 16, and is displayed without automatic rests:
Â The stem, tie, and tuplet directions for the main voice are set to Auto, which is 

necessary for the proper notation of unison parts. No MIDI channel is defined for the 
main voice, so all notes with a channel other than 16 will be assigned to the main 
voice. As long as no notes or rests with MIDI channel 16 are used, the score display 
looks the same as with a simple, non-polyphonic staff style.

Â For the second voice, the stem, tie, and tuplet direction parameters are set to Down, 
and the automatic rest display is deactivated (Hide). Only MIDI channel 16 note 
events will be assigned to this voice. 

The following additional steps are necessary to improve the score’s appearance:
Â Rests in the second voice need to be inserted manually where needed. The MIDI 

channel of inserted rests must match the second voice’s channel (16, in this case). 
This can be edited in the Event List.

Â In the polyphonic passages, the stems of the main voice need to be forced upwards 
by selecting the corresponding notes, and changing their individual stem parameters 
(see “Using Note Attributes to Change Individual Notes” on page 735).
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An advantage of this approach is that you don’t need to worry about MIDI channels 
during recording or input, and notes won’t disappear unintentionally. There is, however, 
the disadvantage that the Voice Separation tool cannot be used to assign notes to 
voices. 

Other applications for this method would include the display of beamed grace notes, 
occasional polyphony in a guitar part, or the indication of rhythmic accents above or 
below beat slashes in rhythm section parts.

Don’t forget that you can add further voices to a staff, to display more complex parts 
(up to 16).

Advanced Staff Style Usage
This section contains information on a number of features, techniques, and tips that 
will help you to make better use of the staff styles functions.

Mouse Input in Polyphonic Staff Styles
Mouse input into polyphonic staff styles is very easy, if you activate View > Explode 
Polyphony (also available as a key command). This forces all voices to be displayed on 
separate staffs, regardless of staff style settings (the other voice parameters remain 
valid). 

If you insert a note into a staff style that uses MIDI channels for voice separation, it is 
automatically assigned the corresponding MIDI channel (of the staff that you add the 
note to). Following input, turn off the Explode Polyphony setting. This will display all 
voices correctly in one staff, as per the staff style settings. 

You can, of course, also insert notes directly into polyphonic staffs without activating 
the Explode Polyphony setting. In this situation, inserted notes are assigned the MIDI 
channel set in the Insert Defaults of the Event Parameter box (but only if that particular 
channel is used by one of the voices in the staff ).

Changing the Staff Assignment of Symbols
There is a Staff parameter in the Event Parameter box, for most symbols inserted into 
multiple staff styles. This parameter determines which staff the symbol belongs to. 
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Cross Staff Beaming
Music for keyboard instruments or harp (which is notated in two staffs) sometimes 
contains passages where notes in the upper and lower staff (played by the left and 
right hand) are connected with a beam, to emphasize the continuing musical phrase.

In the Score Editor, notes can only be connected with beams if they belong to the 
same voice. Notes that belong to the same voice, however, will be displayed in the 
same staff. You will need to use the Score Editor’s Staff Assignment commands to 
display same voice notes in separate staffs.

As an example:  The following screenshot depicts a piano passage, displayed in the 
Piano staff style. The notes in the upper staff belong to voice one, using MIDI channel 
one. The notes in the lower staff belong to voice two, using MIDI channel two. Imagine 
that you want to connect the eight notes in the first bar with beams, to emphasize the 
continuing musical phrase. 

To beam notes that do not belong to the same staff:
1 Change the voice assignments for the notes that you want to connect with beams (in 

the lower staff ) by doing one of the following:

Â Draw a line below these notes with the Voice Separation tool.

Cross staff beamed notes
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Â Select all notes, and change their MIDI channel to match that of the upper voice (in 
the Event Parameter box).

All notes are displayed in the upper staff, probably accompanied by a lot of ledger 
lines. 

2 Select the notes that you want to define a beaming connection for, then choose 
Attributes > Beaming > Beam Selected (or use the corresponding key command).

3 Select the notes that you want displayed in the bottom staff, and choose Attributes > 
Voice/Staff Assignment > Staff below Voice (or the corresponding key command). 

This moves all selected notes down to the lower staff, although they still remain part of 
the upper voice.

You could also use the reverse approach—first assigning all notes to the lower voice, 
then moving some notes to the upper staff with Attributes > Voice/Staff Assignment > 
Staff Above Voice. 

To display all selected notes in their original staff, use Attributes > Voice/Staff 
Assignment > Default Staff. 

Rest Display
As always, rests are displayed automatically in Logic Pro, as per the Rest settings in the 
staff style. Given the cross-staff beaming situation described above, however, most (or 
all) notes belong to the voice of the top staff, and the lower staff will contain rests—
some even at positions occupied by notes. To avoid this potential issue, you should use 
a staff style where the automatic rest display is deactivated for the bottom staff’s voice. 
Wherever rest display is desired, insert it/them from the Part box, with the mouse.

Drum Notation With Mapped Staff Styles
In MIDI regions that are assigned to drum instruments, each MIDI note usually triggers 
a different sound. If such MIDI regions are displayed with a regular staff style, you’ll see 
notes with no apparent relationships to the sounds represented by them.

If you want to notate these musically meaningless pitches as a readable drum part—
which uses special percussion note heads—you should use mapped instruments and 
mapped staff styles. 
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Mapped staff styles allow you to assign individual voices to drum groups. Drum groups 
use specific drum notation head shapes to display note events. You can define the 
respective drum note head shapes in a Mapped Instrument window. 

The best way to create drum notation for an existing MIDI region, is to open the Score 
Editor (to display the MIDI region), the Mapped Instrument window, and the Staff Style 
window. This way, you can directly see how parameter changes affect the score display. 

Prior to defining the details of a mapped staff style, you should set up all drum groups, 
note head shapes, and relative note position parameters in the Mapped Instrument 
window. 

To create a mapped staff style for drum notation:
1 Create a mapped instrument in the Environment (see “Mapped Instruments” on 

page 888), then double-click its icon.

The Mapped Instrument window opens. Its default settings correspond to the General 
MIDI drum note assignments, but they can be edited.

In the columns to the far right, there are three parameters relevant to notation:
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2 In the Head menu, choose the shape of the note head for notes triggered by this 
particular pitch. 

A note must be assigned to a drum group to be displayed in a mapped staff style. If it’s 
not, it won’t be visible.

3 Choose a drum group in the Group menu.

A number of groups are pre-defined for the most commonly used drum sounds (Kick, 
Snare, Hi-Hat, Toms, Cymbals, and so on). 

Note:  If you want to define a new drum group for another instrument sound (such as 
tambourine), choose New Group in the pop-up menu, and double-click on this entry to 
name the new drum group.

4 Set the Rel. Pos. (relative position) parameter as desired. 

The Rel. Pos. parameter assigns the note to a line in the staff. The note position is 
relative to the top line of the staff. Integer values make the note fall on a line, fractional 
values result in a note position between two lines.

Note:  Positions can also be influenced in the Staff Style window, but this affects all 
notes of a particular drum group.

These options allow you to have two different MIDI notes (different bass drum sounds, 
for example) displayed in the same way in the score, or on the same line, but with 
different note heads.
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5 Create a new mapped staff style by choosing New > Mapped Style in the Staff Style 
window, and inserting all desired staffs, voices, and drum groups—as described above, 
and in “Working With Staff Styles” on page 741.

Â Staff section:  Everything is identical to non-mapped staff styles (with the exception 
of the missing Transpose and Key parameters, which wouldn’t make sense here).

Â Voice section:  Below Voice (in the top header line), you’ll see a separate Voice column, 
where the different voices are numbered automatically. The staff style shown above 
contains one staff with five independent voices. 

Â The horizontal lines display the Staffs-Voices-Drum Groups hierarchy, indicating the 
borders between these elements. Each drum group belongs to the voice at the same 
horizontal position. The Pos parameter affects the vertical positioning of all notes in 
the corresponding drum group. The value shown here is an offset—which is added 
to, or subtracted from—the relative positions (if defined for individual notes in the 
Mapped Instrument window). 

Mapped staff style names are preceded by the # character in the Staff Styles window. 

Using Multiple Drum Maps in a Project
If you are using several MIDI instruments with different drum assignments, you can 
create a separate drum map (in the Mapped Instrument window) for each instrument. 
The list of drum groups, however, is the same for all instruments in a project. This 
enables you to display different drum tracks with the same mapped staff style. All snare 
drums, for example, will be displayed in the same way.

To override this behavior:
1 Create additional drum groups (Kick2, Snare2, and so on).

2 Create a second mapped staff style to display these drum groups.
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Using Score Sets to Create Scores and Parts
You can use score sets to determine which instrument tracks should be included in the 
score display. Each project can contain as many score sets as required. Score sets allow 
you to:
Â Produce both the full score and individual parts (such as particular groups of 

instruments).
Â Arrange the (vertical) order of instrument tracks in the score, independent of the 

order of tracks in the Arrange area.
Â Assign a name (and an abbreviated name, if desired) to each instrument track, which 

will be displayed and printed as instrument names in the score.
Â Determine which staffs will be connected by brackets or bar lines.
Â Exclude the display of tracks that are only relevant for playback, but not for the score 

(tracks that only contain MIDI controller data, for example).
Â Simultaneously reduce or enlarge all staffs in each staff set, by using the Scale 

parameter. This allows you to use the same staff styles for printout of full scores and 
individual parts.

Â Select from two different parameter sets (Score or Part) for page margins, header 
space height, vertical distance between staff systems, and the maximum number of 
bars per line.

The Relationship Between Score Sets and Display Modes
A score set will only be shown as defined if an appropriate display mode is chosen. 
Content Link and Content Catch only allow the display of one MIDI region at a time, 
making them unsuitable for work with score sets. It’s usually best to deactivate Link, 
once the desired score set is fully displayed. If only one MIDI region is displayed, 
double-click below the staff, which will display the full score, then deactivate Link.

∏ Tip:  It is possible to work with several open Score Editor windows, each showing 
different display levels or different score sets.

Choosing a Score Set
A score set is chosen in the Inspector’s Score Set menu. 

Click the menu to show all available score sets. New projects will only show the All 
Instruments score set which will display all instruments—dependent on the display 
level. 
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The Score Set Window
You can create and edit score sets in the Score Set window. 

To open the Score Set window, do one of the following:
m Choose the Open Score Set window command in the Score Set menu (or use the Open 

Score Set window key command, default:  Control-Command-I). 

m Choose Layout > Score Sets in the Score Editor.

If you open the Score Set window when the default All Instruments score set is 
selected, a warning indicates that the All Instruments score set cannot be edited. 

Name of Score Set
You can edit the name of a score set by double-clicking on the name in the left column 
of the Score Set window, which opens a text entry field. 

Insert Mark 
The narrow column to the left allows you to set an insert mark (>) with a mouse click, 
or make multiple selection marks by dragging the mouse vertically. 

Instrument
This column is used to determine which instruments are included in the score set, and 
their (vertical) order of appearance in the score. Track instrument icons are also 
displayed in this column, at the highest zoom level.
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Full Name
A click on any line in this column opens an entry field that contains the default 
“@(reference)”. If you don’t change this, the name of the track’s instrument will be used 
as the name for the instrument in the score. As the track’s instrument name is often 
identical to the corresponding synthesizer patch (Solo Strings High, for example), you’ll 
probably want to assign another name here. This name is automatically displayed in 
the score as the full name:  “Violin 1”, for example. Display parameters for instrument 
names are set in the Numbers & Names tab of the Score project settings (see “Numbers 
& Names” on page 781).

Short Name
You can also define an abbreviated name for each instrument, which is used if Short 
Names is selected in the 1st Staff and Other Staffs pop-up menus of the Numbers & 
Names tab, in the Score project settings. 

Brackets and Bar Lines
You can define which staffs in the score set are connected by brackets or bar lines 
(either at the beginning of each staff, or throughout), in the last four columns. Any of 
these connections can be set by dragging vertically in the column, until you see the 
appropriate display.

Brackets and bar lines can also be interrupted between staffs, enabling you to form 
groups of connected instruments in a score. If you want to delete a line or bracket, 
grab the corresponding symbol at its end point (bottom), and drag it upwards, until it 
disappears. You can use the same method to shorten lines.
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Bar line connections can also be edited directly in the score. Just click on the upper end 
of a bar line to connect it to the next (higher) staff. Repeating the procedure 
disconnects the bar lines.

Creating and Deleting Score Sets
When you open a Score Editor window, while several regions are selected in the 
Arrange area, Logic Pro automatically creates and displays a score set that only contains 
the instruments of the selected regions. 

You can also use one of the following methods to create a score set manually.

To create an empty score set:
m Choose New > New Empty Set in the Score Set window.

You can insert the desired instruments into the empty score set, one-by-one.

To create a copy of the currently selected score set:
m Choose New > Duplicate Set in the Score Set window.

To create a score set for all selected instruments:
1 Select at least one MIDI region for all instrument tracks you want to include in the score 

set.

2 Choose Layout > Create Score Set from Selection (or use the corresponding key 
command) in the Score Editor. 

Logic Pro creates and displays a new score set, which consists of all instruments used 
by the currently selected MIDI regions. 

Score sets created this way are automatically named after the instruments they contain.

To create a score set that contains all instrument tracks used in the Arrange window:
m In the Score Set window, choose New > New Complete Set. 

∏ Tip:  If several instruments or staffs use the same MIDI sound for playback (with the 
same MIDI channel on the same MIDI instrument), and you want to display these staffs 
with different instrument names in the score, you need to create a separate track 
instrument for each staff, in the Arrange area.

All score sets are saved with the project file.

To delete a score set:
m Select the score set in the Score Set window, then choose New > Delete Set.
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Editing Score Sets
Once you have created a score set, you can change the assignment of instrument 
entries, add instruments, or change their order.

To assign another instrument to an existing score set entry:
m Click-hold the name of the instrument you want to replace in the Instrument column, 

then choose the desired instrument from the pop-up menu.

To add an instrument to the middle of the list:
m Set the insert mark to the desired position, then choose New > Add Instrument Entry.

A new instrument entry is added at the insert mark. 

To add an instrument at the bottom of the list:
m Double-click below the instrument list.

A new instrument entry is added at the bottom of the list. 

Reordering Instruments
You can use the usual Cut, Copy, and Paste commands to reorder the instrument 
entries in a score set. If pasted, they will be placed at the insert mark position, which 
must be set beforehand.

Scaling Score Sets
You can scale any score set to a desired size between 50 and 200 percent of the 
original size. 

To scale a score set:
m Select the score set in the Score Set window, then set the Scale parameter to the 

desired value.
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The Scale parameter affects:
Â All staffs
Â The distance between the staffs
Â All symbols associated with staffs (all notes, rests, and other symbols)
Â All local text, including lyrics
Â Slur and Tie thickness

The Scale parameter does not affect global text objects (header text, text inserted 
outside the margins) and text such as page numbers, and so on.

Scaling doesn’t take place on instrument parts that were created by Option-clicking on 
the Score Set menu—and choosing the instrument from the pop-up menu (as 
described below, see “Filtering Single Instruments” on page 768). As such, you can use 
the same staff styles for full scores and parts:  in extracted parts, the staffs will appear 
at their original size, in the full score, their size is defined by the Scale parameter.

Note:  The All Instruments set can not be edited (and therefore, can not be scaled), so 
you’ll need to create a dedicated score set for the full score, in most cases.

Creating Separate Layouts for Parts and Score
You can use separate layout parameters for the full score, and parts, in the Global tab of 
the Score project settings. The Format parameter in the Score Set window determines 
which layout parameters a score set uses. 

To create separate layout parameters for the full score, and parts:
1 Open the Global Score project settings by choosing File > Project Settings > Score (or 

using the Open Score Project Settings key command), then click the Global tab.

The Global tab offers separate page layout parameters for score and parts. 

2 Set the separate score and part layout parameters as desired. 
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To determine the layout parameters used by a score set:
m In the Score Set window, choose the desired setting from the Format menu. 

For the default All Instruments set, the score settings will always be used, except when 
a single MIDI region is displayed. In this situation, the part settings will be used. 

Filtering Single Instruments
You can quickly extract a single instrument from the score, by choosing it from the 
pop-up menu that appears when you Option-click on the Score Set menu. 

This way, you don’t need to create a score set for every instrument, in order to produce 
parts. You should note, however, that only the track instrument names will be used as 
instrument names in the score. So, if you use this method for printout of your parts, 
you will see the real instrument names of the Arrange window track instruments.

Importing Score Sets From Other Projects
You can import score sets from other projects.

To import score sets from other projects:
1 Choose File > Project > Import Settings (or use the Import Settings key command, 

default:  Option-Command-I). 

2 In the Import Settings window:

a Select the project you want to import the score sets from.
b Select the Score Sets option.
c Click Open. 
Logic Pro imports all score sets from the selected project into the current project.
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Printing the Score
This section covers the display options available when readying a score for printing, 
and also concentrates on a number of global layout facilities that will help you to get 
the score (and your sheet music) looking just right.

Preparing the Score Layout for Printing
This (and the following) section outlines a number of changes you can make to the 
overall score layout. These primarily involve display customizations, and use of the 
Score project settings or preferences. Full details on all “Project Settings for Score 
Display” on page 776, and “Score Preferences” on page 795.

Using Page View
You should use Page view for layout work, when preparing for printing. In Page view, 
Logic Pro automatically displays as many facing pages as possible, dependent on the 
size of the Score Editor window and current zoom level.

To switch to Page view:
m Choose View > Page view in the Score Editor (or use the corresponding key command).

m Click on the Page View button in the Score Editor’s upper left corner.

You should use linear view for editing, as screen redraws are much faster, especially on 
slower computers. 

You can jump directly to any page, using the View > Go to Page menu item (or 
corresponding key command), when working in Page view mode. The playhead is 
automatically set to the beginning of the selected page, unless the sequencer is 
running when you choose the command. In this situation, Catch mode will be turned 
off.

Additional Page Display Options
The View > Page Display Options menu offers a number of additional settings that are 
useful for printing or layout tasks.
Â Print View:  Print view shows the score as it will be printed. Print view can only be 

activated when Page view is active. 
Â Show Margins:  Displays page margins onscreen. These are not printed.
Â Show Pages in Pairs:  As the name suggests, this shows facing pages. This setting is 

reliant on the zoom settings, and score scale.
Â Show Page Rulers:  Displays a horizontal and vertical ruler (in centimeters or inches) 

that makes precise layout tasks easier.

Note:  The yellow area on the screen represents the printable area (which also depends 
on the printer being used), not the actual sheet of paper. The grayish yellow area 
surrounding the page—in Print view—shows how the page will actually be printed.
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Setting Breaks
You can set line, link, and page breaks individually for each score set, and also for each 
of the extracted parts. Logic Pro saves breaks with the project file. 

Line Breaks
The automatic line break calculations are based on the Spacing and Max.Bars/Line 
settings in the Global Score project settings. The Maximum Bars/Line project setting 
determines the maximum number of bars Logic Pro will allow in one staff or staff 
system. You can override the automatic line break with the Layout tool (when in Page 
view). You can also create a line break by inserting the Link Break symbol in any view 
mode, using the standard insert methods. 

As an example, you can set Maximum Bars/Line to 6, and still move additional bars into 
a line with the Layout tool. Any subsequent lines will contain no more than six bars. 
The full number of bars set here will only be displayed if the spacing settings are low 
enough to allow the proper display of that many bars.

Note:  Dragging more bars into a line than would be displayed when employing the 
automatic line break function can result in overlapping notes and symbols!

To move one or more bars of a staff system down into the next staff:
m In Page view, grab the bar with the Layout tool, and drag it down (the mouse icon 

changes to a hand with a downwards-pointing thumb), then release the mouse button. 

The bar is moved to the next staff system, and the remaining bars in the line are 
distributed evenly over the entire width of the page. 

You also can move the first bars of a staff upwards into the preceding staff, by dragging 
them up with the Layout tool.

Preserving Manual Line Breaks
When you move a bar with the Layout tool, as described above, all manually edited line 
breaks in subsequent lines are deleted, and the (automatic) line breaks are recalculated 
from that line downwards. If you want to prevent this, perhaps because you only want 
to change one detail and keep the other staffs as they were, hold Option while moving 
the bars with the Layout tool. Line breaks edited in this way will only affect the two 
(directly concerned) staff systems. All other staff systems are unchanged.
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Page Breaks 
You can use the Page Break symbols to insert a page break. This moves all bars that 
follow the page break insertion point to the following page. All preceding, and 
following, bars are automatically adjusted in accordance with the Score project settings 
(discussed in the Line Breaks section above). All staffs in the score are affected.

Editing Local Margins
You can move the left and right margin of each individual staff system with the Layout 
tool, so that they do not align horizontally with the page margins. Like manual line 
breaks, these local margins are also saved as part of the current score set, allowing 
different settings for each score set.

To move the left and right margin of a staff system:
1 Turn on the following settings in the Score Editor’s View menu:

Â Page View
Â Page Display Options > Print View
Â Page Display Options > Show Margins

2 Click-hold (with the Layout tool) a little inside the beginning or end of the staff, and 
drag to the left or right.

During this process, Left/Right Staff Margin will appear in the help tag.

Note:  When altering margins, Logic Pro automatically adapts the number of bars per 
line (unless you have manually adjusted line breaks beforehand):  if the line is 
shortened, bars may be moved down to the next line, depending on the Spacing 
parameters in the Global tab of the Score project settings (see “Global Score Settings” 
on page 776).

To realign a changed staff margin with the other staffs:
m Double-click at its end (or beginning) with the Layout tool. 

To delete all line breaks and (locally) changed margins in the current score set:
m Choose Layout > Reset Line Layout.



772 Chapter 33    Working With Notation

Changing the Margin and Header Values in Page Print View
You can change the Margin and Header Space project settings directly with the mouse 
in Page Print view. 

To change the margin and header space values with the mouse:
1 Turn on the following settings in the Score Editor’s View menu:

Â Page View
Â Page Display Options > Print View
Â Page Display Options > Show Margins

2 Set the margin values by dragging the orange lines.

3 Set the header space value by dragging the purple line. 

This only affects the setting (score or part) which is currently displayed.

Printing the Score
The printout of scores created in Logic Pro is identical to the Score Editor’s Page view 
display. The following items are not printed, but are visible on the screen:
Â The dashed lines that represent page and header margins, and borders between staff 

systems.
Â Mouse cursor and playhead
Â Colors (page margins, staff lines of selected MIDI regions)
Â Hidden time signature changes
Â Hidden note heads (displayed in gray on the screen) and their ties
Â Hidden bar lines (displayed as dashed lines on the screen)
Â Hidden N-Tuplet numbers
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To print your score:
1 Choose the appropriate paper size and format in the File > Page Setup window.

2 Ensure that the Score Editor (containing the intended print view) is the active window.

3 Start printing by choosing File > Print (or using the corresponding key command, 
default:  Command-P). 

A dialog box, which may vary slightly from printer to printer, is shown. Choose from the 
available options, such as which page numbers you would like to print, the number of 
copies, or click the PDF button to “print to” (Save as) a PDF file. 

4 Make your selections, and click the Print button.

You should work at high zoom levels when doing layout work that requires precision, 
such as positioning symbols and text elements.

It’s very easy to switch back and forth between a normal and enlarged view of the 
display, by using the Zoom tool (shortcut:  rubber band selection while holding down 
Control, to enlarge the selected area). 

Using External Symbol Fonts for Display and Printout of Notes and Symbols
You can use the Sonata font from Adobe™, the Jazzfont, and the Swingfont (not 
included with Logic Pro), instead of the internal Logic Pro score font, for display and 
printout of notes and symbols. The external font must be properly installed on your 
system. Activate Logic Pro > Preferences > Score > “Use external symbol font (if 
available)” and choose the font you wish to use in the corresponding pop-up menu.
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Exporting the Score as a Graphic File
You can save a part of a Logic Pro score page (or a whole page) as an image (PDF 
format), or copy it into the Clipboard. This allows you to paste it into graphic editing 
programs, or documents created in word processing or desktop publishing 
applications. 

Preparing the Export
Before you export the score as an image, you should choose the appropriate Camera 
Tool settings in the Logic Pro > Preferences > Score pane.

Write to:
Â Clipboard:  The image is copied to the Clipboard, and can be pasted directly into 

other applications, without saving it as a separate file.
Â PDF File:  The image will be saved as a PDF file. A file selector box allows you to 

assign a file name and path—when the Camera tool is used to take a snapshot of the 
score.

Exporting the Score
You use the Camera tool to export the score as an image file.

To export the score as an image:
1 Select the Camera tool.

2 Drag across the desired score section. A selection rectangle is shown as you do this.

As soon as you release the mouse button, Logic Pro creates a PDF file (or copies the 
selection to the Clipboard—see option above), encompassing the area you dragged 
the Camera tool over. 

Note:  This function is only available in Page view. 
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Customizing the Score Editor’s Appearance
The following section outlines the various options for changing the general 
appearance of the Score Editor. The different view modes can accelerate editing, or are 
required for particular operations.

Choosing a Color Mode
The settings in the Score Editor’s View > Colors menu set the color mode for the active 
Score Editor window. These settings have priority over all other color settings.
Â Normal:  Colors are assigned in accordance with the color settings in staff styles and 

note attributes. As long as these settings haven’t been changed in new projects, this 
will result in a regular black and white printout—and black notes on a yellow 
background onscreen.

Â Show Pitch:  Applies colors in accordance with note pitches. The colors of notes can 
be edited in the Layout > Colors window. This window also allows you to determine 
whether notes with accidentals will match the color of those without accidentals, or 
if each note in the chromatic scale will have its own color.

Â Show Velocity:  Applies eight different colors, in accordance with MIDI velocity. These 
colors can also be edited in Layout > Colors.

Â Show Voice Assignment:  Assigns different colors to different voices. This only makes 
sense in staff styles that contain more than one voice. This mode employs the colors 
of the user palette, which can also be found and edited in Layout > Colors.

Â Force Black & White:  Does exactly what the name implies. This mode is useful when 
color options have been used in staff styles, or have been assigned to notes using 
note attributes—but you want to print a regular black and white score—and then 
return to the colored display.

Displaying Folders
If the current display level allows more than one MIDI region to be viewed 
simultaneously (linked or unlinked), the View > Explode Folders setting will affect how 
things are shown:  unlike the other editor windows, the Score Editor can display (or 
even print) the contents of different display (Folder) levels at once. 

If the current display level contains folders, their contents are also displayed in the 
score.

Note:  If this setting is not activated, folders will appear as gray beams in linear view, 
and won’t be shown at all in Page view.
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Displaying Global Tracks
Enable the View > Global tracks setting to view the global tracks in the Score Editor. 
You can only enable this setting in linear view mode. The Configure Global Tracks 
command allows you to choose which global track types are shown.

Displaying Instrument Names 
Enable the View > Instrument Names setting to show the names of (used) track 
instruments, to the left of the score display.

Project Settings for Score Display
There are seven pages of score-related project settings. You can switch between these 
and other project settings, by using the tabs at the top of the Project Settings window. 

These settings affect the whole project (in all score sets). They are saved with the 
project file, allowing each project to have different settings.

You can import the Score project settings from another project into the current project.

To import Score project settings:
1 Do one of the following:

Â Choose File > Project Settings > Import from the main menu bar (or use the Import 
Settings key command, default:  Option-Command-I).

Â Choose Options > Import Settings in the Score Editor. 

2 In the Import Settings window, choose the Score Settings option, then click Import 
(uncheck all other settings that you don’t want to import). 

This imports all Score project settings into the current project.

Global Score Settings
The Global Score project settings define global formatting options such as page 
margins, spacing between notes, bars per line, and more.

To open the Global Score project settings, do one of the following:
m Choose File > Project Settings > Score in the main menu bar (or use the Open Score 

Project Settings key command), then click the Global tab (if not already displayed).
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m Click the Settings button in the Arrange Toolbar, choose Score from the menu, then 
click the Global tab. 

m Choose Layout > Global Format in the Score Editor.

m Use the Settings: Global Format key command (default:  Control-Option-Command-F).

m Double-click on the page margins in Page view.

Distance values can be displayed in inches or centimeters in the Global Score settings 
tab. 

To switch the distance value display between inches and centimeters:
m Choose the respective value in the pop-up menu at the top of the Global Score settings 

tab.

Settings that affect the general page layout (margins, for example) can be set 
independently for a part or the full score. This is indicated by the two input boxes. This 
allows you to print out single voices with a page layout that differs from the full score 
(see “Creating Separate Layouts for Parts and Score” on page 767).

The following sections describe the settings in detail.
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Top, Bottom, Left, and Right Margin
These values show the margin distances to the outer border of the printable area on 
the page. A “Top Margin 0.0 inches” value means that printing will start as close to the 
top of the paper as the selected printer driver will allow. This also means that the size of 
the printable area can vary between printers, although the difference should be 
minimal.

Margins are only visible in Page Print view, where they are displayed as orange lines on 
the screen. These lines are not printed. It is also possible to change them directly in the 
score, by dragging them with the Pointer or Layout tool.

Add Bracket Space
Creates additional space between the left margin line and the beginning of staffs, for 
braces and brackets. If this option is deactivated, staffs will be aligned directly along 
the left margin line.

Alternating Margins
If activated, the left and right page margin settings will be swapped on every second 
page. This can be useful if a score is going to be bound as a book:  the inner margin 
usually needs to be a little bigger than the outer one. It’s possible that the opposite 
might be preferable, in cases where extra space is needed for remarks that may be 
added to the score at a later date.

Header Space
Defines the height reserved for headers, between the top margin of the first page, and 
the top margin of the first staff on the page (as per the assigned staff style).

Note:  Text objects inserted directly into this area automatically become global text 
elements (see “Working With Global Text” on page 716), and are displayed as headers in 
all score sets (full scores and parts).

This value can also be changed directly in the score, by dragging the purple line above 
the first staff.

Line Distance
Defines additional vertical distance between staff systems (single, multiple, or 
bracketed staffs can constitute a system) on the same page. It applies to full scores, as 
well as single staff parts.

Maximum Bars/Line
This parameter can be useful when using small spacing values (see below), to prevent 
too many bars from being displayed on one line. The number set here limits the 
number of bars that can be displayed per line.

Note:  This setting can be overridden when using the Layout tool to change line breaks 
(see “Setting Breaks” on page 770).
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Constant Spacing and Proportional Spacing
These parameters determine the amount of horizontal distance between notes. 
Â Constant Spacing affects the distance from note to note, regardless of rhythmic 

value.
Â Proportional Spacing takes the note durations into consideration. 

If you only use Proportional Spacing (and set Constant to 0), every bar receives (more 
or less) the same amount of (horizontal) space. A whole note uses as much space as 
four quarter notes. In the opposite situation (high constant value, proportional value is 
set to 0), the distance from one note to the next is always the same, regardless of note 
duration. A half note takes the same amount of space as an eighth note. Other factors, 
such as accidentals, ties, and so on, are also considered for note distance calculations.

The settings you should use depend on both your personal preference, and the style of 
the piece. You should aim for a good balance between these two parameters, so try 
different combinations when working on the final score layout.

Slash Spacing
This is the distance parameter for slashes (used in staff styles that display beat slashes 
instead of automatic rests). This is especially important when inserting notes into staffs 
that display slashes. As an example, musical styles such as funk use a lot of sixteenth 
notes, so you are likely to choose a higher slash distance than you would for music that 
doesn’t go beyond eighth notes. This way, the proper relationships between notes and 
passages (containing only slashes and chord symbols) can be maintained.

Beaming Slant Factor, Minimum Slant, and Maximum Slant
These three parameters affect the slant angle of beams. As with the Spacing 
parameters, these parameters work together. Appropriate settings need to be found by 
trying different combinations. The final settings will vary, depending on the style of the 
music, and on personal preference.
Â Beaming Slant Factor:  Determines the general amount of beam slanting, in relation 

to the intervals of the notes connected by beams.
Â Minimum Slant:  Determines the minimum interval of notes that causes beams to be 

slanted.
Â Maximum Slant:  Determines the maximum beaming slant angle.

These parameters work relatively to a particular scoring situation, which is why no 
explicit settings can be given. Again, it is essential to try different combinations when 
working on the final layout of a piece.
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Default Pedal Position
This determines the vertical position of automatic pedal symbols (those created when 
you use the MIDI sustain pedal during a real time recording). If this parameter is set to 
zero, recorded MIDI sustain pedal events are hidden in the score. Pedal marks that you 
manually insert from the Part box are not affected by this parameter.

“Open” Single Staffs
Displays single staffs without vertical lines at their start point (left side of the clef ).

Justify Last Staff
Lengthens the last line (the last staff system, in full scores) to the right page margin.

Hide Muted Regions, Hide Muted Tracks, and Hide Muted Notes
Excludes muted regions, or regions on muted tracks, or muted notes, from the score 
display. If these options are not activated, muted tracks, regions, and notes will be 
displayed in the score, even though they won’t be heard during MIDI playback.

Show Alias
Switches the display of aliases (see “Working With Aliases in the Score Editor” on 
page 695) in the score on or off.

Allow Alias Editing
Switches alias editing on or off  (see “Working With Aliases in the Score Editor” on 
page 695).

Alternate Repeat Symbols
If this option is activated, all repeat signs in the project will be displayed with real book 
style brackets.

Chord Symbol Language
This pop-up menu allows you to choose between
Â International (B, Bb, F#, …):  Default setting
Â German (H, B, F#, …):  B → H, Bb → B 
Â German (H, Bb, F#, …):  B → H, Bb → Bb
Â German (H, B, Fis, …):  C# → Cis, Eb → Es, and so on …
Â Roman (Do, Re, Mi, …):  CDEFGAB → Do Re Mi Fa So La Ti

In all Chord Symbol Language formats, the current format is also accepted for the input 
of new chords.

The #, b, x, and bb characters are also active in the German (H, B, Fis, …) mode, 
allowing for quick entry. In the Roman format, the second root string character can be 
omitted (typing D7 or Do7 in Roman mode will both result in Do 7). 

Changing the Chord Language automatically affects all chord symbols in the project. It 
is not possible to mix chord languages. 
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Numbers & Names
These settings affect the automatic display of page numbers, bar numbers, and 
instrument names in the score. 

To open the Numbers & Names Score project settings:
m Choose File > Project Settings > Score in the main menu bar (or use the Open Score 

Project Settings key command), then click the Numbers & Names tab (if is not already 
displayed).

m Click the Settings button in the Arrange Toolbar, choose Score from the menu, then 
click the Numbers & Names tab. 

m Choose Layout > Numbers & Names in the Score Editor.

m Use the Settings: Numbers & Names key command.

m Double-click on any bar or page number.

Automatic page and bar number display, and automatic display of instrument names 
can be switched on and off for the whole project—by activating or deactivating the 
corresponding checkboxes in this tab.

For each of these options, you can set the font, size, and face by clicking the Choose 
button.

The corresponding text styles in the Text Styles window (see “Working With Text Styles” 
on page 715) are automatically updated if you edit these settings. 
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Page Number Parameters
The Page Numbers checkbox must be activated for the following parameters to have 
an effect.

Horizontal Position
Alters the horizontal alignment on the page. Choose from:
Â Alternating:  Alternating, beginning on the right side.
Â Left, Right, or Centered:  These are self-explanatory.
Â Rev. Alternating:  Alternating, beginning on the left side.

Vertical Position
Alters the vertical alignment on the page. You can choose either:  Top or Bottom.

Page Offset
This value is added to each actual page number, for display purposes. This can be 
useful when writing a piece consisting of several parts, which are saved as separate 
project files. To retain continuous page numbers throughout the score, you can set this 
parameter to the number of pages contained in all preceding parts (project files).

Horizontal Distance
The horizontal distance from the outermost printing position on the page. This is only 
relevant for page numbers with the Horizontal Position parameter set to Alternating or 
Rev. Alternating. 

Vertical Distance
The vertical distance to the highest or lowest printing position on the page (dependent 
on whether Vertical Position is set to Top or Bottom). 

Hide 1st Page Number
Prevents the display (and printout) of the page number on the first page (all others are 
displayed and printed).

Prefix
Allows you to enter text which will be displayed with every page number.

Example:  If you use the prefix Page—the word Page, followed by a space and the 
actual page number—will be displayed on each page. This means that page three will 
display Page 3. If you want the page number in the middle of the prefix, you need to 
use the # symbol as a variable for the page number. An example:  “- pg.# -” on the 
second page prints as “- pg.2 -”.

You can also use the following text symbols to include automatically generated text in 
the prefix:
Â “\ i” for the score set name.
Â “\ n” for the project (file) name.
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Â “\ s” for the name of the currently shown display level, which can be the MIDI region 
or folder name (or even the project name, on the highest level).

Â “\ d” for the current date (at the time of printout).

Bar Number Parameters
The Bar Numbers checkbox must be activated for the following parameters to have an 
effect. Bar numbers can be placed above or below bar lines, and at the beginning of 
the line, above or below the clef (they are automatically moved to a position where 
they won’t overlap the clef ).

Horizontal Position
Choose either:  At Bar Line or At Bar Center.

Vertical Position
The height above the staff. If a negative value is set here, the bar numbers are placed 
below the staff.

Step
This value controls the interval (in bars) between the display of bar numbers. A value of 
4, for example, results in bar numbers at the first, fifth, ninth bar, and so on. If you only 
want bar numbers to be displayed at the beginning of each staff line, set this 
parameter to 0.

Bar
This value is added to all actual bar numbers, for display.

Start With
Automatic numbering begins at the bar indicated here.

Hide Bar Numbers in Linear View
Does exactly what it says. Linear view refers to non-Page view.

Count Multiple Rests
Displays the first and last bar number below multiple rests. This makes sense if a 
negative Vertical Position value is chosen, causing bar numbers to be shown below 
staffs.

Show at Double Bars
Displays bar numbers at every double bar line and repeat sign, independent of the 
chosen Step setting. As an example, if Step is set to 0 (and Double Bars is activated) bar 
numbers will be displayed at the beginning of each staff line, and above or below all 
double bar lines and repeat signs.
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Top/Bottom Staff only
In full scores, the bar number is only displayed above the top staff, if this option is 
activated (a negative Vertical Position value results in the number being shown below 
the bottom staff ).

Instrument Name Parameters
The Instrument Names checkbox must be activated for the following parameters to 
have an effect. These parameters determine the appearance of names—defined for 
instruments in the score set (see “Using Score Sets to Create Scores and Parts” on 
page 762) window—in both the full name and short name columns. If nothing is 
defined here, or if All Instruments is used as the current score set, the names of the 
track instruments (as displayed in the Arrange window) will be used in the score.

Position
Choose from above or beside staffs.

Align
This refers to the space preceding staffs. Choose either:  Left (at the left margin), or 
Right (at the right margin).

1st Staff
Choose one of the following to display the instrument name at the first staff:  No 
Names, Short Names, or Full Names.

Other Staffs
As above, for other staffs.

Guitar Tab
Guitar tablature is an alternative method of notating music for fretted string 
instruments—especially for guitar and electric bass—but also for other fretted 
instruments, with four to six strings (or courses of strings).

In this system, the horizontal lines represent the strings of the instrument. Notes are 
always written on the line/string at which they are played. The fret numbers are shown 
instead of regular note heads. 

Logic Pro automatically converts notes into tablature, if a staff style containing a Clef 
parameter set to one of these tuning sets, is used. The exact characteristics of these 
tuning sets are determined in the Guitar Tablature tab. 

To open the Guitar Tablature tab, do one of the following:
m Choose File > Project Settings > Score in the main menu bar (or use the Open Score 

Project Settings key command), then click Guitar Tab (if not already displayed).
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m Click the Settings button in the Arrange Toolbar, choose Score from the menu, then 
click Guitar Tab. 

m Choose Layout > Guitar Tablature.

m Use the Settings: Guitar Tablature key command.

m Double-click on the TAB clef, at the beginning of any staff that uses tablature in the 
score.

Twelve different tuning sets can be defined. Each of them corresponds to one line in 
this tab. The regular guitar and bass tunings are already included as defaults (first line 
and last five lines), as are some of the more common guitar tunings. 

Parameters Available for Every Tuning Set
Â Name:  Can be changed in the text entry field that opens when you double-click on 

the Name field.
Â Strings:  Number of strings (four, five, or six)
Â Assign:  The method Logic Pro uses for automatically assigning notes to strings (see 

Assign section below).
Â 1 to 6:  The pitches that the open strings are tuned to.

Other Common Parameters:
Â Font button:  Click to choose a font, font size, and face for the display of fret numbers.
Â Alignment buttons:  Click to determine the alignment of numbers to the stem:  You 

can choose:  to the side, or centered.
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Â Bass String buttons:  Click to determine the display of the lowest string. It may be the 
same as other strings, or slightly thicker. 

Â Circle 1/1, 1/2 Notes checkbox:  If this option is activated, half and whole notes will be 
displayed with a circle around the fret number. As the note head is always a number, 
there would be no visible difference between a half note and a quarter note, if this 
parameter wasn’t available. 

Determining the Assign Method
As most notes can be played at different positions (frets) on different strings, the Assign 
parameter performs an essential role. In most cases, the MIDI channels of the individual 
notes determine the string assignment.

Note:  The MIDI channel parameter of an individual note has no impact on MIDI 
playback. The playback channel is determined in the track instrument’s Parameter box 
in the Arrange window.

Click in the Assign column (for the corresponding Tuning Set), and choose from the 
following string assignment options:

Pitch
Logic Pro assigns each note to the string on which it is playable, at the lowest possible 
position. In order to influence the string assignment, there is a rule (in Pitch mode only) 
that a note’s fret position cannot be lower than its MIDI channel. 

This method is generally used when notes are recorded from a MIDI keyboard:
Â An A3 (on MIDI channel 1) is displayed on the second fret of the G string. If you want 

the note to be displayed at a higher position (to correctly display the proper 
fingering of a passage), you need to set its channel to 3 or higher. 

Â This means that the fret position cannot be lower than 3, so the note will be 
displayed at the D string’s seventh fret. 

Â If the channel is between 8 and 12, the A3 is assigned to the A string on the 12th fret, 
and to the low E string (17th fret) for channels 13 to 16. 

If you want to force even higher positions, you’ll need to use one of the other 
assignment modes.

Channel
In this mode, the number of the string (1 to 6, counted from the lowest string) simply 
corresponds to the MIDI channel. Channels 7 to 16 are assigned to the highest string. 

Inv. Channel
Like Channel, but counted from the highest string (1) to the lowest (6 and above). This 
way of numbering the strings is generally used in traditional guitar literature. 
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Note:  As most Guitar-to-MIDI-Converters send notes (played on different strings) on 
different MIDI channels, the Channel and Inv. Channel modes are suitable if you’re 
using a MIDI guitar to record MIDI regions. The tablature notation is displayed exactly 
as the music was played during recording. 

Inv. Channel –1 and Inv. Channel –2
These modes should be used when recording and notating electric bass parts with 
Guitar-to-MIDI-Converters. 
Â “–2” is designed for four-string bass.
Â “–1” is designed for five-string bass (with an additional high B string). 

The principle is the same as Inv. Channel mode, but the number of the MIDI channel is 
reduced by 1 or 2, in order to properly convert the channels for bass string assignment.

The string assignment for a four-string bass will be 3 to 6, and 2 to 6 (counted from 
highest to lowest string in both cases) for a five-string bass, just as with guitar strings 
that sound one octave higher. Notes on channel 1 will be assigned to the highest 
string.

Further Information on Tablature Notation
In all of these assign modes, notes below the lowest string are not displayed at all. 

A further point to note is that notes can generally only be assigned to strings on which 
they are actually playable (F2 can only be played on the lowest string of a guitar, so the 
channel assignment is completely ignored in this case.

You can create a two-staff style that displays the MIDI region twice:  once using regular 
music notation, and once as tablature. The indicated split point can be ignored in this 
situation. A default style for this (named Guitar Mix) is found in the Logic Pro default 
project.

You cannot insert clef changes in tablature staffs. If you want to change between 
tablature and regular notation in the same staff, you need to cut the MIDI region, and 
assign the desired staff styles to the resulting regions.

Guitar tablature relates to a regular treble clef. If you use the octave-transposing treble 
clef (Treble-8) for guitar notation (as done in most guitar music, and in the example), 
you need to set the tablature’s Transpose parameter to +12 in the Staff Style window.
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Clefs & Signatures
These are general display options for clefs, key signatures, and time signatures. 

To open the Clefs and Signatures project settings, do one of the following:
m Choose File > Project Settings > Score in the main menu bar (or use the Open Score 

Project Settings key command), then click the Clefs & Signatures tab (if is not already 
displayed).

m Click the Settings button in the Arrange Toolbar, choose Score from the menu, then 
click the Clefs & Signatures tab. 

m Choose Layout > Clefs & Signatures.

m Use the Settings: Clefs and Signatures key command. 

m Option–double-click on any clef or time signature in the score.

Common Parameters
The following display parameters are available for clefs, key signatures, and time 
signatures:
Â Every Staff
Â First Staff on Every Page
Â First Staff on Page 1
Â Hide All
Â Display Warnings at Line Breaks:  This causes warning clefs, time signatures, or key 

signature changes to be displayed at the end of a staff or staff system—if the actual 
change is at the beginning of the subsequent staff or staff system.



Chapter 33    Working With Notation 789

Smaller Clef Changes
Clef changes (whether caused by a change of staff style, or by a new clef inserted from 
the Part box) can be displayed at a smaller size than the clefs at the beginning of staffs, 
depending on this setting.

Automatic Key Transposition
This setting enables the automatic transposition of key signatures in transposing staff 
styles. It will usually be activated. An exception would be for the notation of atonal 
music. If deactivated, all sharps and flats are displayed directly with the notes. 

Note:  There is a similar option in the Staff Style window (Key parameter), which allows 
you to switch off the key signature for individual staff styles, or even for individual staffs 
in multi-staff styles.

Minimize Transposed Accidentals
This enables the use of enharmonically changed key signatures, if this results in a 
signature with fewer accidentals. As an example, if a piece is written in B major (5 
sharps), the Bb instruments are notated in Db major (5 flats) instead of C# major (7 
sharps). 

Note:  Logic Pro does not display key signatures with more than seven flats or sharps, 
whether this option is activated or not.

Show Naturals
This displays naturals at key signature changes, where preceding accidentals are no 
longer valid (when changing from E major to G major, or to C minor, for example).

Show Grace Accidentals
If this option is activated, courtesy accidentals are automatically displayed. This means:  
wherever a diatonic note is altered by an accidental, another accidental (a natural 
symbol, in many cases) will be displayed when that note appears (unaltered) in a 
subsequent bar. 

Size
This parameter alters the appearance of the meter (often much larger, for conducting 
purposes) on the staff. It is expressed as regular and percentage values.

Single systems will show both numbers (4/4, for example) on the system. Double 
systems will show the upper number on the upper system, lower number on the lower 
system.

Hide Bar Lines
This option allows you to hide all bar lines, which can be useful for educational 
material, gregorian plain chant notation, and other special situations.

Only automatically displayed bar lines are hidden, so it’s still possible to insert bar lines 
from the Part box, including the regular bar line, which will be displayed and printed.
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Octave Symbol Parameters
These settings enable you to edit the text string (and text formatting) of the different 
octave symbols. Simply click on the appropriate field, and type in the desired text. Click 
the Choose button to select a different font, font face, or size.

Layout
The Layout tab is where you can define a number of display settings for the whole 
project, such as staff line thickness, stem length, distance between notes and ties, or 
notes and dots, and so on.

To open the Layout project settings, do one of the following:
m Choose File > Project Settings > Score in the main menu bar (or use the Open Score 

Project Settings key command), then click the Layout tab (if is not already displayed).

m Click the Settings button in the Arrange Toolbar, choose Score from the menu, then 
click the Layout tab. 

m Choose Layout > Extended Layout Parameters.

m Use the Settings: Extended Layout key command.

Line Thickness Parameters
The first eight parameters determine the line thickness of the following objects:  staff 
lines, stems, ledger lines, bar lines, repeat and end lines, tuplet brackets, text boxes (for 
boxed text styles), and crescendi/decrescendi (this last parameter also affects line 
objects and arrows).
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Note:  If you have a high resolution printer, you should try to use smaller line thickness 
settings (2, or maybe even 1). Smaller staff lines, in particular, look much better. The 
other parameter settings are more a matter of personal preference. These changes are 
only visible at high zoom levels on the screen. To really judge the results, try some 
printouts with different settings.

Other Parameters
Â Bar Start Spacing and Bar End Spacing:  Changes the relative distance between the 

first and last note of a bar, and the preceding or subsequent bar line. Please note:  
Changing the default settings of these parameters only makes sense if rather 
extreme values have been chosen for the general Spacing parameters in the Global 
Score project settings tab.

Â Dot/Note Distance and Dot/Dot Distance:  Determines the distance between the note 
heads and dots, for dotted notes. Dot/Dot Distance refers to double dotted notes.

Â Acc./Note Distance:  Allows you to globally alter the horizontal distance of accidentals 
from the corresponding note heads. The default setting should only be changed if 
very small values are used for the Spacing parameters, which results in a tiny 
distance between notes. This global setting can also be combined with the 
Accidental Distance parameter of individual notes, in the Note Attributes window.

Â Acc./Acc. Distance:  Allows you to globally alter the horizontal distance between 
several accidentals, in chords.

Â Stem Length:  This determines the default setting for stem length.
Â Horizontal Tie Position and Vertical Tie Position:  Determine the distances between note 

heads and related ties (which are displayed automatically). 
Â Tie Thickness:  Determines the thickness of ties.
Â Slur Thickness:  Determines the thickness of slurs.

Note:  The Slur and Tie Thickness parameters are affected by the Scale parameter in 
score sets, and the Size parameter in staff styles. 

Â Chord Symbol Alignment:  Determines the general horizontal alignment of chord 
symbols—with an Align parameter set to def (default)—in relation to their bar 
position.

Â Chord Symbol Accidental Scale:  Changes the accidental size, in relation to the font 
size setting:  Positive values result in an increased size, negative values in a 
diminished size of chord symbol accidentals.

Click the Factory Defaults button to reset all parameters to their default settings. 
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MIDI Meaning
The settings in the MIDI Meaning tab determine if, and to what extent, the insertion of 
the listed symbols affect the MIDI playback of notes (that these symbols are attached 
to).

To open the MIDI Meaning tab, do one of the following:
m Choose File > Project Settings > Score in the main menu bar (or use the Open Score 

Project Settings key command), then click the MIDI Meaning tab (if is not already 
displayed).

m Click the Settings button in the Arrange Toolbar, choose Score from the menu, then 
click the MIDI Meaning tab. 

m Choose Layout > MIDI Meaning.

m Use the Settings: MIDI Meaning key command.

Two parameters can be determined for each symbol. These symbols change the MIDI 
output of all notes they are attached to:
Â Velocity:  This value is added to, or subtracted from, the original velocity value of the 

corresponding note.
Â Length:  The original note length is shortened by the percentage chosen here. This 

only affects the playback of the note, not the score display. The note length change 
can be seen in the Event Parameter box or in the Event List.
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How the MIDI Meaning Functions Works
The MIDI Meaning functions are most useful when you’re inserting notes with the 
mouse. This makes it possible to work as if writing music on paper. 
Â First, you write/insert the notes. They will all have the same velocity, and identical 

rhythmic note values will have exactly the same length. 
Â Accents and phrasing marks are then attached to some of the notes, which changes 

the velocity and (playback) length of these notes. 

This makes playback sound much more realistic and alive.

The default settings in the MIDI Meaning tab (in new projects) are 0 for velocity, and 
100% (no change) for length. If you don’t change these values, the symbols will remain 
purely graphical, and will not affect MIDI playback. 

If you record your regions in real time (from a keyboard), it’s better to leave these 
settings at the defaults, as the notes probably already sound the way you want them 
to.

Important:  If you do use MIDI Meaning, you need to adjust the settings before you 
begin to insert accents and so on. This is because the settings have no influence on 
accents and phrasing marks that have already been inserted.

Once set, the velocity and length of notes will be changed as soon as you attach one of 
these symbols to a note. When you delete the symbol, note velocity and length are 
reset to their initial values.

Colors
The Colors tab determines the color palette for the currently active project.

To open the Colors tab, do one of the following:
m Choose File > Project Settings > Score in the main menu bar (or use the Open Score 

Project Settings key command), then click the Colors tab (if is not already displayed).

m Click the Settings button in the Arrange Toolbar, choose Score from the menu, then 
click the Colors tab. 

m Choose Layout > Colors.
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m Use the Settings: Score Colors key command. 

The color palettes are used by different color modes (see “Choosing a Color Mode” on 
page 775). Clicking on any color opens the standard Colors window, allowing this 
particular color to be changed.

Colors are saved with the project, and can be different for each project. 

There are three palettes, and some additional options in this window:
Â Pitch Colors:  Each note of the octave is assigned a color. They are arranged like piano 

keys. The Diatonic and Chromatic radio buttons determine whether there are twelve 
or seven different colors.

Â Velocity Colors:  These eight colors are applied in accordance with the MIDI velocity of 
notes, from left (minimum) to right (maximum).

Â User Palette:  These colors can be freely edited and named, using the text entry boxes 
beside them. These names are displayed as color options in different color selection 
menus (staff styles, note attributes).

Â Note Color Options:  These options determine whether accidentals, dots, and rests, are 
displayed in color (according to their note associations), or in black. Rest colors only 
apply to user rests, which are mainly used in polyphonic staff styles.

Â Factory Defaults:  Click this button to reset all changes you have made in the Colors 
window.
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Score Preferences
The Score preference settings are global, and affect all project files. They can, however, 
be changed at any time, with an immediate effect on all open projects. All preferences 
are automatically saved when you exit Logic Pro.

To open the Score preferences, do one of the following:
m Choose Logic Pro > Preferences > Score from the main menu bar (or use the Open 

Score Preferences key command).

m Click the Preferences button in the Arrange Toolbar, and choose Score.

m Choose Options > Open Score Preferences in the Score Editor.

Â Show region selection colored:  If this option is activated, the staff lines of the currently 
selected MIDI region are displayed in color (blue). All other regions are displayed with 
black staff lines. This can be useful when changing the display parameters of regions, 
as the parameters in the Display Parameter box only affect the currently selected 
regions. If this option is turned off, all staffs are displayed in black, whether selected 
or not. 

Â Display distance values in inches:  This relates to the measurement units in the project 
settings and page rulers (Page view only), which can be in inches or centimeters. If 
not selected, the Page view defaults to centimeters.

Â Floating Palette View:  This menu defines the default shape of Part box palette 
windows (see “Selecting Part Box Objects” on page 679).

Â Double-click note to open:  This setting determines the window that will open when 
you double-click on a note head:  Note Attributes, Event List, Hyper Editor, or Piano 
Roll Editor.

Â Use external symbol font (if available):  This option enables the use of external fonts in 
the score  (see “Printing the Score” on page 769).
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Â Choose Font:  This pop-up menu allows you to choose from any installed scoring 
(symbol) fonts, such as the Sonata font.

Â Camera Tool:  Write to:  Choose either the Clipboard or a PDF File as the destination 
for image exports with the Camera tool (see “Exporting the Score as a Graphic File” 
on page 774).

Â Split preferences:  The “Auto split notes in multi staff chord styles” preference is only 
relevant if the chosen default staff style (on the recording track) is polyphonic, and is 
using MIDI channels for voice assignment. In this situation, newly recorded notes are 
automatically saved with the different MIDI channels used in the corresponding staff 
style. They are allocated as per the split point set with the “Split notes at” preference.
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34 Working With Video

Logic Pro allows QuickTime movie files to be synchronously 
viewed, making film and TV scoring quick and easy.

You can open a QuickTime movie in a separate Movie window, or can display the single 
frames of a QuickTime movie in the global Video track. When a movie is opened in a 
project, the upper part of the Inspector shows a closed Movie area—which can be 
opened by clicking the disclosure triangle.

Movie playback follows the playhead position, and vice-versa, in the Inspector movie 
area, and the Movie window. 

Note:  You will need a fast hard disk, and fast Macintosh, to ensure smooth movie 
playback. If you want to record and edit your own QuickTime movie (using iMovie or 
Final Cut Pro or Express) from a video recorder or digital camera, you may need 
specialized hardware.

Important:  You can not record or edit video in Logic Pro. You can, however, replace the 
soundtrack of a movie file—with music, foley, and dialog arranged in Logic Pro.
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To open a QuickTime movie, do one of the following:
m Choose Options > Movie > Open Movie command (or use the corresponding key 

command, default:  Option-Command-O).

m Click the Open Movie button in the global Video Track.

m Click at any position on the Video track with the Pencil tool.

m Locate and select the movie file in the Browser, then click the Open button.

The video is opened in the floating Movie window, in its correct aspect ratio.

Note:  Only one QuickTime movie can be opened in a project! Using the Open Movie 
command in a project that already contains a movie, reopens a Movie window with the 
same film clip. This is particularly useful if you want to open the video clip in a different 
screenset. Choosing the command—while the Movie window is open—launches a file 
selector box, allowing you to choose a new movie file.

To remove a movie from a project:
m Choose Options > Movie > Remove Movie. 

All references to the movie are deleted from the project. 

Using the Movie Window
You can drag the position slider at the bottom of the Movie window, or use the 
QuickTime transport buttons to the right, to navigate to any position in the video file. 
Logic Pro (the playhead) will “chase” to the corresponding project position. All 
QuickTime transport functions interact with those of Logic Pro.
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Resizing the Movie Window
You can resize the Movie window by dragging its lower right corner.

Control-clicking the movie itself (the actual image) opens a shortcut menu, where you 
can set various image formats.

You can also select one of the following:
Â Original Size:  Displays the movie in its original size. 
Â Fullscreen:  Expands the Movie window to fill the full screen. 
Â Keep Aspect Ratio:  If enabled, the proportions of the image are retained when 

resizing the Movie window.
Â Center:  Choosing this option places the video image in the center of your screen.

Using the Video Track
The global Video track displays the loaded QuickTime movie as thumbnails. If the Video 
track is not visible, see “Showing and Hiding Individual Global Tracks” on page 76.

The number of frames displayed in the Video track depends on the track height, and 
the zoom level of the window. All frames are aligned left, with only the very last frame 
aligned to the right. This guarantees that you can always see at least the first and last 
frames of a video, independent of the current zoom level. Given the left alignment of 
frames, the left margin of a frame will always be displayed at the exact position of that 
particular frame (except the very last frame in the movie).
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Changing Video Track Settings
The settings of the Video track can be adjusted in Logic Pro > Preferences > Video.

Â Cache Resolution pop-up menu:  Choose the resolution of the thumbnails held in the 
temporary internal memory (cache). Higher resolutions display more detail, but take 
up more space in the cache.

Â Maximum Cache Size slider:  Sets the amount of memory reserved for the thumbnail 
cache. 40 MB is recommended for medium resolution. Use a higher value for higher 
resolutions. The cache memory will only be used when actual movie data is 
displayed.

Working With Scene Markers
Scene markers are SMPTE-locked markers:  They remain at the same absolute time 
position, regardless of any tempo changes, and they are automatically deleted if the 
current movie is removed from the project. Scene markers are identified by a movie 
frame symbol.
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Creating Scene Markers
You can use the Create Scene Markers function to search the movie for significant 
content changes (scene cuts), and automatically generate scene markers for each of 
them. 

The Create Scene Markers function uses a fixed threshold value, which works quite well 
for most types of movies (cartoons, real life, CGI, and so on). 

To search a movie for scene cuts, do one of the following:
m Choose the desired movie range in the Options > Movie > Create Scene Markers menu. 

The Auto Range setting follows the decision path outlined below, when determining 
which part will be evaluated:
Â Marquee selection.
Â Cycled project part.
Â Selected regions.
Â All—if none of the above criteria are met.

To quickly search a movie for scene cuts, using the Auto Range setting:
m Click the Detect Cuts button in the Video track.

m Use the Create Scene Markers (Auto Range) key command.

To remove scene markers, do one of the following:
m Choose the desired command in the Options > Movie > Remove Scene Markers menu. 

m Use the Remove all Scene Markers (Auto Range) key command.

Converting Scene Markers
You can use the Marker List to convert a scene marker into a standard marker, and vice 
versa.

To convert a scene marker into a normal marker:
m Select the scene marker in the Marker List, and choose Options > Convert to Standard 

Marker. 

To convert a normal marker into a scene marker:
m Select the marker in the Marker List, and choose Options > Convert to Scene Marker. 
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Handling QuickTime Movie Audio Tracks
Once a movie has been opened in a project, you can make use of the Import Audio 
from Movie, or Export Audio to Movie commands—found in the Options > Movie 
menu.

You can adjust the audio level and output device in the Video project settings (see 
“Changing the Sound Output Device and Level” on page 804).

Importing Audio Tracks From QuickTime Movies
Choose Options > Movie > Import Audio from Movie to open a dialog that allows you 
to select the desired audio tracks of the movie file. 

Once you’ve made your selection, and clicked OK, the selected audio tracks will be 
bounced to an AIFF file, and placed in the Audio Bin. The movie name will be retained, 
and used for the resulting audio files.

Note:  When extracting audio from a movie file that only contains a single audio track, 
the selection dialog is made redundant. Use of the Import Audio from Movie command 
will automatically import the audio (as an AIF file), and add it to the Audio Bin. 

You can also use the Options > Movie > Import Audio to Arrange function, which 
places the extracted audio (as a region) on the selected Arrange window track.

Exporting Audio to QuickTime Movie
You can export audio from the part of your project that is encompassed by the 
QuickTime movie—to the movie file itself—effectively overwriting the original movie 
soundtrack. This is useful for sending a rough mix of your film soundtrack to other 
members of the production team, for example.

To export your project to the QuickTime movie:
1 Choose Options > Movie > Export Audio to Movie. 
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2 Choose the desired format options for the bounced audio file, and click OK.

3 In the ensuing file selector box, enter a name and target folder for the movie, and click 
Save.

A dialog appears, allowing you to choose which of the original movie’s audio tracks 
should be used in the new movie. 

4 Select the audio track that you want to retain in the new movie, then click OK.

The QuickTime movie is exported to the selected folder; it contains all selected audio 
tracks—plus the part of your project that is encompassed by the start and end points 
of the QuickTime movie. 

Video Project Settings
In the Video project settings, you can define the video output, determine the video 
sound output, and offset the video from the project. 

To open the Video project settings, do one of the following:
m Choose File > Project Settings > Video (or use the corresponding key command, 

default:  Option-V).

m Click the Settings button in the Arrange Toolbar, and choose Video from the menu.

m Control-click the Movie window, then choose Video project settings. 

Choosing the Video Output
The Video Output pop-up menu (in the Video settings tab) allows you to choose from 
the following output modes:
Â Window:  Outputs the QuickTime video file to a Movie window. 
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Â DVCPRO HD:  Choose this option to output the QuickTime video file to a DVCPRO HD 
device, which is connected to your system. 

Â Digital Cinema Desktop:  Choose this option to preview your video on any available 
display unit that is connected to an AGP graphics card. (Displays connected to a PCI 
graphics card cannot be used by Digital Cinema Desktop.) If you have two computer 
displays, one can be used to view the Logic Pro interface, while the other can be 
used as a dedicated video monitor.

Â FireWire:  Choose this mode to output QuickTime movies from your project to a 
FireWire device (your FireWire DV device must be connected at the time). For 
technical reasons, only QuickTime movies in DV format are supported.

Changing the Format of Video Output
When either the Digital Cinema Desktop or FireWire options are chosen as the Video 
Output, the Video Format pop-up menu can be accessed. 
Â Digital Cinema Desktop mode offers three choices:  Preview, Full Screen, and Raw.
Â FireWire mode offers several PAL and NTSC format options, at different frame rates 

and resolutions. Choose the most appropriate format for your project.

Changing the Sound Output Device and Level
The Video settings tab offers three choices in the Sound Output pop-up menu:
Â Mute:  The audio track of the video file is disabled.
Â System Sound:  The audio track of the video is played through the System Sound 

device (as defined in the Audio MIDI Setup utility).
Â External Device:  Choose this option to route the audio track of the video file to an 

external device. In general, you would be most likely to use this option when 
FireWire is selected in the Video Output pop-up menu.

The Movie Volume slider sets the level of the video file audio track.

Offsetting Video From a Project
You can directly enter the SMPTE offset value in the Movie Start field. This is 
independent of the SMPTE offset for the project.

This enables you to work from bar one (1 1 1 1 in the Transport), even if the video time 
code—at a particular point in the video—is several minutes into the movie file. Put 
simply, this makes your life easier when creating a soundtrack for all, or part of, a movie 
file.

You can fine-tune the offset of internal and external video in the Video preferences. 
These globally affect all projects (see “Video Preferences” on page 969).

Click the Video Preferences button in the Video settings tab to open the Video 
preferences. 
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Activating Follow Tempo
Turn on the Follow Tempo checkbox and set a basis tempo in the field below to make 
the QuickTime movie run at the chosen tempo value until it receives a tempo change 
message (from the Tempo track).

Video Preferences
The Video preferences determine how Logic Pro handles video memory and video 
hardware settings. You can also make timing adjustments here.

To open the Video preferences, do one of the following:
m Choose Logic Pro > Preferences > Video (or use the corresponding key command). 

m Click the Preferences button in the Arrange Toolbar, and choose Video from the pop-up 
menu.

Â Adjustments:  Video to Project:  A global setting for fine tuning the start point of a 
movie.

Â Adjustments:  External Video to Project:  The same setting as above, but for external 
FireWire Video devices. This setting compensates for the latency of the video 
hardware in use, if applicable.

Â Video Track:  Cache Resolution:  Resolution of the thumbnails kept in the temporary 
internal memory (cache). Higher resolutions display more detail, but take up more 
space in the cache.

Â Video Track:  Maximum Cache Size:  Amount of memory reserved for the thumbnail 
cache. 40 MB is recommended for medium resolution. For higher resolutions use a 
higher value. This section of reserved memory will only be occupied when actual 
movie data is displayed.

Â Video Output:  Release output device in background:  Enable this checkbox to release 
the chosen output device (set in the Video Project Settings), when it is not being 
used in Logic Pro.

Â Video Project Settings:  Click to open the Video Project Settings window.
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35 Working With Surround

Logic Pro offers extensive surround processing and mixing 
functions—for all major surround formats.

This chapter will introduce you to all surround processing options in Logic Pro.

To work with surround in Logic Pro you will need:
Â An audio interface that has the number of output channels required by the chosen 

surround format. As an example, six outputs if the 5.1 surround format is used.
Â The same number of speakers (along with appropriate amplification) to hear the 

channels when mixing.

All audio signals can be positionally mixed, allowing you to place them anywhere in the 
surround field.

You can insert surround plug-ins into audio and instrument ªchannel strips, which can 
be routed to surround auxes or outputs. 

Logic Pro records incoming multi-channel audio as interleaved multi-channel files, 
when creating a surround project. Imported split multi-channel files will be converted 
automatically. For more information, see Chapter 38, “Working With Split Channel Audio 
File Formats,” on page 853 chapter. 

You can also upmix or downmix non-matching signals (mono to multi-mono, or stereo 
to surround, as examples), allowing the use of any audio material in your surround 
projects. In most cases, the upmixing or downmixing is automatic, but it can be 
performed manually, if needed.

You can bounce multi-channel projects as split and interleaved surround files. For more 
information see “Bouncing Surround Audio Files” on page 828.

Surround encoding or decoding does not take place in Logic Pro. The Logic Studio 
package does, however, include Compressor, which allows you to encode surround 
files. Please see the Compressor manual for more information.
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Surround Formats Supported by Logic Pro
This section outlines the supported surround formats, and provides details on the 
channels used by each.

Quadraphonic
Four full bandwidth channels, arranged as front left and right and rear left and right 
(left surround and right surround). Old format used for music delivery. Mike Oldfield’s 
“Tubular Bells” is probably the most popular release in this format.

LCRS
Stands for left, center, right, and surround channel. This is the original Dolby Pro Logic 
format. The surround channel (placed directly behind the listener) is a bandwidth 
limited (the treble content is reduced) monophonic channel.
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5.1 (ITU 775)
5.1 (ITU 775) is used for a few surround standards. This is the most common of the 
surround formats, and is the one you are most likely to use. The 5.1 channels are left, 
center, right, left surround (left rear), right surround (right rear), and LFE. 

6.1 (ES/EX)
The 6.1 (ES/EX) format is used for Dolby Digital EX or DTS ES. The 6.1 channels are left, 
center, right, left surround, surround (rear center), right surround, and LFE. 
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7.1 (3/4.1)
7.1 (3/4.1) uses the same speaker configuration as 5.1, but adds two additional side 
channels (left mid and right mid), placed directly to the left and right of the listening 
position. It is designed for a big cinema, in other words.

7.1 (SDDS—Sony Dynamic Digital Sound)
7.1 (SDDS—Sony Dynamic Digital Sound) adds two additional speakers to 5.1 (left 
center and right center). As with the other 7.1 format, this is designed for use in a large 
cinema, equipped with Sony decoding and playback hardware.
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Channels Used By Surround Formats

Table Key:
Â L = (Front) Left
Â Lc = Left Center
Â C = Center
Â Rc = Right Center
Â R = (Front) Right
Â Lm = Left Mid
Â Rm = Right Mid
Â Ls = Left Surround (Rear Left)
Â S = Surround (Rear Center)
Â Rs = Right Surround (Rear Right)
Â LFE = Low Frequency Effects

Surround format L Lc C Rc R Lm Rm Ls S Rs LFE

Quadraphonic X X X X

LCRS (Pro Logic) X X X X

5.1 (ITU 775) X X X X X X

6.1 (ES/EX) X X X X X X X

7.1 (3/4.1) X X X X X X X X

7.1 (SDDS) X X X X X X X X
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Configuring Logic Pro for Surround
Before you can create a project in surround, you need to tell Logic Pro which outputs of 
your interface are connected to which speaker. If actually recording in surround, you’ll 
also need to define what inputs of your audio interface will be used. This is done in the 
Input and Output tabs of the Surround preferences.

To open the Surround preferences, do one of the following:
m Choose Logic Pro > Preferences > Audio, then click the Surround tab.

m Click the Preferences button in the Arrange Toolbar, choose Audio from the menu, then 
click the Surround tab.

m Use the Open Surround Preferences key command.

Setting the Surround Preferences
The Surround Preferences window features three tabs:  Input, Output, and Bounce 
Extensions. All three surround tabs are linked, but can be adjusted independently.

Note:  As a general rule, the default settings for each surround format should meet your 
needs in all but the rarest circumstances.

To set the Surround channel assignment:
1 Click either the Input or Output tab.

2 Choose the Surround format you want to work in from the Show As menu.

This automatically sets the input and output channel menus in the Assignment 
sections of both the Input and Output tabs. 
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Note:  The surround format chosen here only alters the layout/routing of channels to 
speakers in the assignment section. The actual project surround format is determined 
by the Surround format Audio project setting (see “Setting the Project Surround 
Format” on page 815).

To determine what speakers the Logic Pro outputs are sent to, do one of the 
following in the Output tab:

m Choose the desired output of your audio interface from each of the active pop-up 
menus; Left, Center, Right, and so on.

You can choose outputs that don’t exist for your hardware, allowing you to work on, or 
create, a surround project with a computer that is not equipped for surround playback. 
These are shown in brackets. As examples:  (Output 17) or (Output 32).

m Click one of the three buttons below the Show As menu. 

Â Default:  Click to activate the default setup of Logic Pro. As an example:  For the 5.1 
format, this means that output 1 is routed to the left speaker, output 2 to the right 
one, output 3 is assigned to left surround, output 4 to right surround, output 5 to the 
center speaker, and output 6 to the LFE channel. 

Â ITU:  Click to assign the International Telecommunications Union standard, used by 
many professionals.

Â WG -4:  Click to use the WG-4 standard, set by the DVD Forum for DVD-Audio. 

To determine what inputs are used for each surround channel:
m Open the Input tab, and use the procedures outlined above for the Output tab.
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To change the bounce extensions:
1 Click the Bounce Extensions tab.

2 Click in any of the active fields, and type in the new extension name. 

As examples:  The default left extension “.L” could be renamed to “.Left”, or the left 
surround extension “.Ls” could be changed to “.LSurr”. Don’t forget the period before 
the extension!

If you change your mind, simply click the Reset Extensions button to revert to the 
defaults.

Note:  Changing the extension has no impact on the files—it simply makes them easier 
to identify. If you find the defaults clear enough, there’s no need to change them.
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Setting the Project Surround Format
You can determine the surround format you want to use for a project in the Audio 
project settings. By default, a new project is set to 5.1.

To determine the project surround format:
1 Open the Audio project settings by doing one of the following:

Â Choose File > Project Settings > Audio (or use the corresponding key command, 
default:  Option-P)

Â Click the Setting Toolbar button, and choose Audio in the pop-up menu. 

2 In the Audio project settings, choose the desired format from the Surround Format 
menu.

∏ Tip:  Save a project that has been set up for surround format work as a template. This 
way you won’t have to set the surround format every time you want to create a new 
surround project. Start with the included templates, modify, and save them as your 
own templates.
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Setting the Channel Input Format
The channel input format determines the mono, stereo, or surround status of the 
channel.

To set the channel strip input format for the selected audio track:
m Click-hold the button directly below the level meter on the Arrange channel strip, and 

choose the desired input format from the menu.

The symbol on the button indicates the current status as follows:

Â Mono:  One circle represents a mono input format. The level meter shows a single 
column.

Â Stereo:  Two interlocked circles represents a stereo input format. The level meter 
divides into two independent columns when a stereo input format is chosen.

Â Left:  Two circles, left one filled, indicates a left channel input format. When this input 
format is chosen, only the left channel of a stereo audio file is played back. The level 
meter shows a single column.

Â Right:  Two circles, right one filled, indicates a right channel input format. When this 
input format is chosen, only the right channel of a stereo audio file is played back. 
The level meter shows a single column.

Â Surround:  Five circles indicates the surround channel input format. The level meter 
divides into multiple linked columns (the number matches the project surround 
format) when the surround input format is chosen.

LeftStereo Right SurroundMono
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Changing the Appearance of Surround Level Meters
You can use the Channel Order menu in the General Display preferences to determine 
the order of channels in multi-channel (surround) level meters. You can choose 
between the following options.

To change the multichannel level meter order:
1 Open the Display preferences by doing one of the following:

Â Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key 
command).

Â Click the Preferences Toolbar button, then choose Display from the menu. 

2 Click the General tab.

3 Choose the desired option from the Channel Order menu in the Level Meters area.

Note:  The setting you choose here does not apply to metering plug-ins, such as the 
Levelmeter or Multimeter. 

Channel order Meter 1 Meter 2 Meter 3 Meter 4 Meter 5 Meter 6

Internal Left  Right L Surround R Surround Center LFE

ITU Left Right Center LFE L Surround R Surround

Centered L Surround Left Center Right R Surround LFE

LCR Grouped Left Center Right L Surround R Surround LFE
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Setting the Output Format of a Channel Strip
You can set the output of all audio, instrument, input, output, and aux channels to the 
chosen project surround format. 

To set a channel strip output to surround:
m Click-hold the Output slot of the desired channel strip, and choose Surround in the 

pop-up menu.

The Pan control of the channel strip is replaced by a two-dimensional surround control. 
The loudspeakers are represented by colored dots, and the pan position is indicated by 
a white dot that can be grabbed and moved. 

You can also simultaneously change the output format of multiple selected channels to 
surround (or another format). 

To change the surround status of multiple channels:
1 Select all channels that you want to set to surround output.

2 Click the Output slot of one of the selected channels, and choose Surround from the 
pop-up menu.

Automatically Determining the Output Format of Channel Strips
Logic Pro automatically sets the output format of specific channel types, based on a set 
of rules for each.
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Audio Channels
The channel strip of an empty audio track is automatically set to the format of the first 
audio file added to it. 

If you add an audio file to a track assigned to a different output format (adding a stereo 
file to a track routed to a surround output, for example), the audio file is automatically 
up or down mixed to match the output format of the channel strip. 

Note:  The highest possible surround format is determined by the project surround 
format. 

Instrument Channels
Instrument channels automatically adopt the channel format of the inserted 
instrument.

If you insert a stereo instrument, the channel strip output will be stereo. 

If you insert a surround instance of a software instrument (ES2 or Sculpture, for 
example), the channel output will match the project surround format.

Aux Channels
Automatically created aux channels adopt the format of their input source (if a stereo 
channel is routed to an aux, the aux will be stereo). If you manually change the output 
format of an aux channel, Logic Pro automatically upmixes or downmixes the signal to 
the required format.

Working With the Surround Panner
You use the Surround Panner to place track output signals at desired speaker positions. 
You can manipulate the Surround Panner directly in the Mixer window or Arrange 
channel strip, but it is far better to open it in a separate window. 

To open the Surround Panner window:
m Double-click on the Surround Panner of a channel strip.

The Surround Panner window provides a magnified view of the channel strip’s 
Surround Panner, and contains additional parameters. 

Note:  It is possible to open multiple Surround Panner windows simultaneously, and to 
save them in screensets. The Surround Panner window also provides a Link button. If 
enabled, the window will update to reflect the surround settings of the selected 
channel strip.

The Surround Panner offers different functionality in mono to surround and stereo to 
surround channels. When used on surround to surround channels, it acts as a balance 
control.
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Using the Mono to Surround Panner
If the source input is set to mono, the Mono to Surround Panner appears.

The most obvious element of the Surround Panner window is the surround field. You 
can use it to control the surround routing of the input signal to the speaker outputs. 
The level sliders and fields (shown below the surround field) provide independent 
control of the Center and LFE channel levels. The extended parameters allow you to 
precisely control the separation between channels.

Surround Field
The surround field consists of the following:
Â Two real time display fields, for angle and diversity. You can directly interact with 

these fields by using the mouse as a slider.
Â A circular grid, comprised of four concentric circles, divided into eight segments—

each of 45 degrees. The outer circle represents the minimum amount of diversity, 
with the center circle representing the maximum amount of diversity.

Â A further circle encloses the grid. This is actually the Diversity/Angle display (or 
meter, if you prefer). As the diversity (or angle) changes, a portion of the diversity 
display will be highlighted.

Â A square is overlaid on the grid. This is an indicator of the separation between left 
and right channels, and also front and rear (surround) channels. You can directly 
interact with the corners or edges of this separation square by dragging them. 
Alternately, you can use the sliders or display fields in the lower section of the 
Surround Panner window.

Surround field

Level controls

Extended parameters
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Â A number of speaker icons, that surround the circular grid. You can change the 
channel surround format directly in the Surround Panner window by clicking on the 
speaker icons. This will activate or deactivate the respective channels. Blue speakers 
indicate active channels, and gray speaker icons denote inactive channels.

Â The blue dot controls the routing of the signal to the speaker outputs. You can drag 
the blue dot in the surround field. 

The movement of the surround position (indicated by the blue dot) is made easier with 
these functions:
Â Hold Command to lock diversity.
Â Hold Command-Option to lock the angle.
Â Option-click the blue dot to reset angle and diversity.

Level Controls
The Center Level slider, and field, determine the volume relationship of the (front) 
center channel—typically used for dialog in film and TV productions.

The LFE Level slider, and field, control the volume of the LFE output. The abbreviation 
stands for Low Frequency Enhancement or Low Frequency Effects, as the LFE output is 
most commonly sent to a subwoofer channel. The use of a subwoofer speaker is not a 
must. 

∏ Tip:  If you only want low frequency signals to reach the output, insert a multi mono 
surround EQ into the surround master channel. Use this to set the LFE (or subwoofer) 
output. A cutoff frequency of 120 Hz is standard for most surround applications.

Separation Controls
The sliders in the lower section of the Surround Panner window determine the amount 
of separation between various channels. As you alter these parameters away from 
values of 1.00, the separation square will change (to a trapezoid or rectangle) in the 
surround field, providing visual feedback on how the channel is being affected.
Â Separation XF:  Applies to the Left and Right (front) channels. Reducing Separation 

from 1.00 down to 0.00 mixes the right signal into the left channel, and vice versa, 
until both channels output a mono signal. 

Â Separation XR:  Applies to the Left and Right Surround (rear) channels. Works as 
above, for the surround speakers.

Â Separation Y:  Affects the mix relationship of the front and rear channels (in front or 
behind the listening position, in other words). It mixes the Left/Left Surround and 
Right/Right Surround channels. When Separation Y is set to 0.00, the front and rear 
channels will output in mono. 
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The separation square is visible if the extended parameter section is open. If the 
extended parameter section is closed, it will remain visible if any of the separation 
values does not equal 1.00. It also stays visible when the default values are reached by 
editing the square graphically. Closing the extended parameter section (with all 
separation values at 100%) will make the square disappear.

You can Option-click on the value field or sliders shown in the extended parameters (or 
on the separation square lines) to reset them to default values.

Note:  In 7.1 ITU surround formats, the Separation of Left Middle and Right Middle is 
determined by the average separation value of the Front and Rear channels. 

Stereo to Surround Panner
If the source input is set to stereo, the Stereo to Surround Panner appears. It is similar 
to the Mono to Surround Panner, but features three pan pucks:  a puck for the L(eft) 
signal, a puck for the R(ight) signal, and a third puck, that controls both the L and R 
pucks as a group. It also offers a Spread field in the upper right corner, which controls 
the stereo width of the signal. 

Moving the L or R puck in the surround field will move the second puck in a 
symmetrical fashion. Dragging the third puck moves both the L and R pucks, while 
maintaining a given spread. 

A left/right movement changes the angle of both, an up/down movement changes the 
diversity. The circular bars around the panner indicate which speakers will carry the 
respective signal source; the closer to the center a puck is moved, the wider the 
corresponding bar gets (the greater the diversity, in other words).
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Surround Balancer
If the source is set to surround, the surround panner acts as a surround balance control.

Source channels are passed on to their respective output channels without any cross-
panning or mixing. The pan control is represented by a single puck, which affects the 
multi-channel source signal as a whole. In other words, only the relative volume 
balance of the source signal is changed. 

The separation parameters are not available in this surround panner mode.

Inserting Surround Plug-ins
Logic Pro offers a number of surround effect plug-ins, and also includes surround 
versions of the Sculpture and ES2 synthesizers. Your Audio Unit instruments and effects 
may also work in surround.

Important:  The project surround format determines the surround format of plug-ins.

To insert a surround effect plug-in:
1 Set the channel strip’s output to Surround.

2 Click on any Insert slot, and browse to the Mono → Surround (on mono channels), 
Stereo → Surround (on stereo channels), or Surround version (on surround channels) of 
the desired plug-in. 

Â As an example on a stereo format channel:  Delay > Delay Designer > Stereo → 5.1 
(ITU 775). 

Â If the project surround format is set to 7.1 (SDDS), the plug-in menu of a stereo 
channel is displayed like this:  Delay > Delay Designer > Stereo → 7.1 (SDDS).

∏ Tip:  It is possible to release the mouse on the plug-in name, instead of navigating all 
the way through the hierarchy to the channel format. This will automatically open the 
plug-in using the default channel strip format. 
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To insert plug-ins that do not match the channel format:
m Option-click a channel Insert slot.

The Plug-in menu will display all formats the plug-in has to offer, rather than being 
limited to the matching format. 

Any down or up mixing that may be necessary will happen automatically. 
Â The default format of software instruments is stereo (if available). Mono and the 

project surround format are offered as additional formats.
Â The default format of effect plug-ins is the current channel format (at the insert point 

in the signal path). 
Â In addition, all plug-in format variations (based on the current channel input format, 

and all available plug-in output formats) are offered—up to the maximum allowed 
by the project surround format. 

Â Logic Pro effect plug-ins can also be operated in a multi-mono configuration, based 
on the project surround format.

Note:  Logic Pro automatically performs surround down and upmixes whenever the 
format of the input and output channels don’t match. As an example, if you insert a 
quad plug-in into a 5.1 bus, Logic Pro will perform a downmix from 5.1 to Quad, 
followed by an upmix back to 5.1.

Down Mixer Plug-in
You can use the Down Mixer plug-in to adjust the input format of the surround master 
channel strip. This allows you to quickly check the surround mix in stereo, for example.

Channel mapping, panning, and mixing is handled behind the scenes. You do, however, 
have some control over the mix:

Â Destination Format:  Choose the desired surround format from the menu, which 
includes:  To Stereo, To Quad, To LCRS.

Â Generic level sliders:  These sliders control the respective channel levels. The number, 
and names, of sliders is dependent on the chosen plug-in format.
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Working With Multi-Channel Effects
Effects that are not available as true surround effects can be inserted as multi-channel 
effects on surround channels:  Logic Pro matches the surround format of a channel by 
automatically providing the required number of stereo and mono instances of the 
plug-in. 

Learning About the Advanced Plug-in Header
Multi-channel effect plug-ins offer an advanced plug-in header.

It can include a tab for each effect instance, an LFE tab, and a Configuration tab. The 
effect tab labels indicate if effect instances are loaded in stereo or mono. Channels 
joined with a “–” are loaded as a stereo instance. Channels separated with a “ | ” are 
mono. To explain:
Â L-R|Ls-Rs|C denotes left/right stereo, left/right surround stereo, and mono center.
Â L-R|Rs|C (a separate left surround tab is shown) denotes left/right stereo, mono right 

surround, mono center.
Â L-R, C, and Ls-Rs shown on three separate tabs denotes left/right stereo, center 

mono, left/right surround in stereo.

Each effect tab is, in essence, a discrete effect unit for each channel (or channel pair). As 
such, you can have different plug-in parameters for the L-R tab, the C tab, the Ls-Rs tab, 
and the LFE tab. When you save plug-in settings, the parameter values of each tab are 
saved.

You can assign these different mono or stereo configurations in the Configuration tab.
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Configuring Multi-Channel Effects
The Configuration tab allows you to determine how parameter changes affect the 
plug-in instances.

Â Link menu:  Determines which effects are linked. If you link effects, parameter 
changes apply to all effects in the linked group. You can choose between three 
groups:  A, B, and C. Channels set to none (“–”) operate independently. Each group 
features its own tab.

Â Bypass button:  Click to bypass the channel:  It is routed around the effect. This is 
useful when individual channels should be exempt from processing by a particular 
plug-in. 

Note:  If the Bypass button of a grouped channel is clicked, all channels in the group 
are routed around the effect.

When a multi-channel plug-in is first inserted into a surround channel, it is 
automatically pre-configured to match the channel’s surround format, and to make the 
best use of the plug-in’s capabilities. As an example:  A plug-in with mono and stereo 
capabilities is inserted into a 5.1 bus. It is pre-configured as two stereo pairs, with the 
addition of a mono center and mono LFE channel. The necessary links and tabs are 
created automatically.

Linking Channels
When you link channels, keep the following in mind:
Â If you link two channels as a stereo pair, the left channel is always assigned as the 

master.
Â If one or more channels are added to an existing group, the new members adopt the 

values of the group.
Â If you assign several channels to an unused group, the setting of the (front) Left 

channel is used for all group members.

 Link menu

 Bypass button
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Working With Side Chains
When inserting a side chain capable plug-in, the side chain source (selected in the 
plug-in header) is routed to all surround instances.

The detection circuits of grouped plug-in instances are linked, and react as one unit. 
This ensures that the spatial surround image is not skewed or deformed. 

Note:  This is also true when no side chain input is selected. In this case, the group’s 
combined individual inputs are used to feed the linked detection circuit—effectively 
acting like a side chain source.

Working With the Surround Master
When you set the output of a channel to surround, a surround master channel strip is 
automatically created in the Mixer. The surround master channel strip processes the 
signals routed to the outputs, as configured in the Surround preferences (taking the 
project’s surround format into account, of course).

You can insert surround plug-ins into this master channel strip. 

Important:  As soon as the master channel strip appears, the Insert slots of the 
individual output channels are hidden, and any existing effects in the Insert slots (of 
output channel strips) are no longer processed. Logic Pro remembers the Insert 
configuration, so when you remove all Surround outputs, the original output channel 
configuration will be restored. 
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Bouncing Surround Audio Files
Bouncing a surround mix can create more audio files than your usual stereo bounce. 
Each file is identified by a unique extension. 

Setting the Bounce Extensions
The Bounce Extensions preference tab lets you define the file name extensions that will 
be added to the files resulting from a surround bounce. See page 814, for steps.

To perform a surround bounce:
1 Do one of the following:

Â Click the Bounce button at the bottom right of any output (or the surround Master) 
channel. 

Â Choose File > Bounce from the main menu bar (or use the corresponding key 
command). 

All outputs selected in the surround settings will be bounced simultaneously, 
regardless of which output channel Bounce button is pressed.

2 Click the Surround Bounce checkbox, below the Dithering pop-up menu in the Bounce 
window.

3 Choose the other bounce settings, as required. 

Further details can be found in Chapter 27, “Bouncing Your Project,” on page 601.

4 Click the Bounce button.

Note:  You can not use the Bounce command to create compressed surround files (AAC, 
ALAC, MP3). 

Burning Surround Mixes to DVD-A
Logic Pro can burn a surround mix of the current project to a DVD-A (DVD-Audio) disc. 
This can be:
Â As many as 6 channels (5.1) at 24 bit depth, and 48 kHz sampling rate.
Â High definition stereo at 24 bit depth, and 192 kHz sampling rate. 

As with CD burning, DVD-A burning is performed in the Bounce window. All steps are 
identical to those described above, with the following differences.
Â Click the Burn DVD-A checkbox in the Destination panel.
Â Click the Bounce and Burn button.

Note:  Logic Pro surround bounces are not encoded. Surround bounce files can, 
however, be encoded in Compressor, which is included in the Logic Pro package. 
Please see the Compressor documentation for instructions on surround encoding.
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36 Synchronizing Logic Pro

Logic Pro can be synchronized with external hardware and 
software via a number of different synchronization protocols.

This chapter discusses the use of Logic Pro—as both synchronization master and 
slave—in a number of different situations.

Logic Pro supports the following synchronization protocols:
Â MIDI Time Code (MTC):  Translation of a SMPTE time code signal into a MIDI standard 

time code signal.
Â MIDI Clock:  Short MIDI message for clock signals. It is used to provide a timing pulse 

between MIDI devices. Logic Pro can send MIDI Clock signals to synchronize external 
devices. It can not receive MIDI Clock synchronization signals.

Â SMPTE time code:  An audio signal that is translated into MTC by some MIDI interfaces, 
such as the Unitor8.

Â Word Clock:  This is a signal that is carried by all digital audio interface formats (ADAT, 
FireWire Audio, S/P-DIF, AES-EBU, T-DIF). It is used to maintain the timing integrity of 
sample words in audio signals that are transmitted digitally between Logic Pro and 
external hardware or software.

Â ReWire:  Logic Pro can act as a ReWire host. It acts as the master synchronization 
source for ReWire-enabled applications such as Reason and Ableton Live. This 
chapter does not cover the use of Logic Pro as a ReWire host (see “Working With 
ReWire Applications” on page 249 for more information).

∏ Tip:  Logic Pro also supports manual or “human” sync, when slaved. This is not a 
synchronization protocol per-se, but enables Logic Pro to follow tempo changes in real 
time. As an example, it could chase a live drummer. See “Using the Tempo Interpreter” 
on page 652 for more information. 
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The Synchronization Master and Slave Relationship
In all synchronization situations, regardless of the simplicity or complexity of your 
studio configuration, the following rules apply:
Â There can only be one synchronization master.
Â The synchronization master sends time code information (synchronization signals) to 

one or more synchronization slaves.

Logic Pro is capable of acting as master or slave, as are many devices. 

Important:  In many (if not most) cases, you will need to manually set each 
synchronization-capable device—including Logic Pro itself—to act as master or slave. If 
you don’t do this, there will be multiple master devices in your system, which will result 
in synchronization errors.

Using External Synchronization
When you first open Logic Pro, manual synchronization mode is automatically switched 
off—and Logic Pro is in Internal Sync (master) mode. Activation of the Transport bar’s 
Sync button synchronizes Logic Pro to the chosen synchronization source. 

If Logic Pro is running by itself (no devices or applications capable of synchronization 
are in use), or is acting as the synchronization source, it is the synchronization master 
device. In this situation, the Transport bar’s Sync button should not be activated. 

The Transport bar Sync button is not displayed by default. 

To view the Transport bar Sync button:
1 Control-click on the Transport bar, then choose Customize Transport Bar from the 

shortcut menu.

2 Activate the Sync checkbox towards the bottom of the Modes and Functions column 
(right-hand column), and click OK.
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Using the Sync Button
You can use the Sync button to turn external synchronization on or off at any time, 
without changing the selected synchronization source. This allows you to temporarily 
disengage Logic Pro (running as a slave) from an external synchronization master 
device. This could prove useful if you need to quickly edit a MIDI region while the 
external synchronization source (tape machine, VTR, and so on) is still running, for 
example.

When Logic Pro Is Running as a Slave
The Transport bar Sync button is lit/depressed, when active.

Click the upper (MIDI In) section of the MIDI Activity display—while receiving an 
external synchronization signal—to view the frame rate of incoming MIDI time code.

Note:  When you click the Record button during external synchronization, Logic Pro 
enters record mode, but does not actually start recording until it detects an external 
time code signal.

Accessing Synchronization Settings With the Sync Button
Control-click the Transport bar Sync button to open a shortcut menu, where the 
following options are available:
Â Setting the type of external synchronization.
Â Determining whether or not MMC commands (see “MIDI Machine Control” on 

page 844) should be transmitted by the Transport buttons of Logic Pro, allowing 
remote control of MIDI-controlled tape machines.

Â Direct access to the Synchronization settings.
Â Direct access to the tempo editors (see “Advanced Tempo Operations” on page 641).

MTC Interpretation
As the MIDI standard only supports four of the six commonly used time code formats 
(the 30 fps and 29.97 fps formats are not differentiated in the MIDI specification), 
Logic Pro needs to decide which format is intended, when it encounters incoming time 
code.

Incoming MTC (MIDI Time Code) is interpreted as follows:
Â 24 fps is interpreted as 24 fps.
Â 25 fps is interpreted as 25 fps.
Â 30 fps drop frame is interpreted as 29.97 drop fps.
Â 30 fps is interpreted as 29.97 fps. 
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You can, however, manually set the format in the File > Project Settings > 
Synchronization > General > Frame Rate pop-up menu. 

Note:  MIDI Time Code (MTC) is the MIDI equivalent of the audio-based SMPTE (Society 
of Motion Picture and Television Engineers) time code format.

Synchronization Project Settings
The Synchronization project settings allow you to specify all parameters relevant for 
synchronization. 

To open the Synchronization project settings, do one of the following:
m Choose File > Project Settings > Synchronization from the main menu bar (or use the 

Open Synchronization Settings key command, default:  Option-Y).

m Click the Settings button in the Arrange Toolbar, then choose Synchronization from the 
pop-up menu. 

m Control-click the Sync button in the Transport bar, and choose Synchronization Settings 
from the pop-up menu. 

The Synchronization project settings consists of four tabs:
Â General:  This tab contains the major synchronization settings, used when running 

Logic Pro as a synchronization slave. For further information, see the section below.
Â Audio:  This tab contains all parameters relevant to synchronizing audio and MIDI.
Â MIDI:  This tab configures Logic Pro to send time code via MIDI, when it is in play or 

record mode. This enables you to synchronize external slave devices to Logic Pro, 
which acts as the master.

Â Unitor:  This tab is used to set the major synchronization parameters for the Unitor8 
MIDI interface.
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General
The General tab of the Synchronization project settings offers the following 
synchronization parameters (used when running Logic Pro as a slave).

Sync Mode
This parameter defines the master (time code type) that Logic Pro is synchronized to:
Â Internal:  The internal timer of Logic Pro. Logic Pro is the master. External devices can 

be synchronized via MIDI Clock or MTC (the relevant settings are made in the MIDI 
tab).

Â MTC:  MIDI Time Code mode. Logic Pro runs as a slave. MIDI time code can either 
arrive at a MIDI in port, or be generated by a MIDI interface that translates it from 
incoming SMPTE time code (the Unitor8, for example).

Â Manual:  Tempo Interpreter mode. Manual synchronization or human sync mode. 
Logic Pro runs as a slave to impulses that are recognized as valid beats by the Tempo 
Interpreter. The Tempo Interpreter can be controlled by MIDI events, or a key on the 
computer keyboard. See “Using the Tempo Interpreter” on page 652. 

Auto Enable External Sync
When this option is activated, Logic Pro runs as the master (Internal sync mode), until it 
receives a synchronization signal—either in the form of MTC, or from the Tempo 
Interpreter.

Logic Pro automatically locks to the first synchronization signal it receives. 

Important:  Ensure that different synchronization signals don’t arrive simultaneously—
remember that there can only be one time code master!
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Frame Rate
This is where you set the frame rate (in fps, frames per second). This frame rate applies 
to both transmitted and received time code.

Note:  In drop frame formats, certain frames are left out (this follows a regular pattern). 
To distinguish between formats, those without dropped frames are sometimes referred 
to as “nd” or “non drop”.

Auto Detect Format of MTC
This checkbox, when active, analyzes the incoming time code and automatically sets 
the correct frame rate. You should generally leave this option switched on.

Please note that it is not possible to automatically distinguish between the 29.97 and 
30 fps MTC frame rates because:
Â The MTC standard does not allow a distinction.
Â A measured rate of 30 fps could also be 29.97 fps time code running too fast, and 

vice versa.

Logic Pro automatically interprets frame rates of “approximately 30 fps” as either 29.97 
(drop frame) or 30 fps (non drop), depending on whether or not the drop frame format 
is used. This interpretation will usually be correct, because these two formats are used 
as a standard.

“Auto detect format of MTC” only switches to 29.97 (drop frame) or 30 fps (non drop) if 
one of the other conventional formats was previously set. If you want to synchronize 
Logic Pro to one of these unconventional frame rates, you need to define the format 
manually. This setting will not be altered by the “Auto detect format of MTC” function.

Frame rate Typically used for

24 fps Film, high definition video.

25 fps PAL video/television broadcasts.

30 fps (drop frame) NTSC video/television broadcast; rarely used.

30 fps High definition video; early black-and white NTSC video; older rate that is 
rarely used today.

29.97 fps (drop frame) NTSC video/television broadcasts.

29.97 fps Standard definition NTSC.

23.976 fps 24 fps slowed down by 99.9%, which facilitates easier transfer of film to 
NTSC video. 
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Validate MTC
The Validate MTC menu allows you to specify how often Logic Pro checks for incoming 
time code, in order to ensure synchronization integrity. In general, you should leave 
this menu option on the “always” setting. 

There are some devices, however, that generate time code pulses that may require a 
specific number of frames to be set, in order to maintain synchronization. The “never, 
Jam Sync” setting basically sets Logic Pro to free-wheel if the synchronization signal is 
lost. In other words, Logic Pro will run on its own internal clock (at the most recently 
received tempo) if the synchronization pulse is lost. This approach ensures that 
recording will continue, even if the incoming timing pulse fails. 

SMPTE Offset (Top Bar Position Row)
This is where you set the SMPTE offset for the project. As songs don’t always need to 
start precisely at bar 1, you can select any bar position to be played at the set SMPTE 
time.

The default is Bar Position:  1 1 1 1 plays at SMPTE 01:00:00:00. 

The SMPTE offset of 01:00:00:00 (one hour) is normally used, because it allows you to 
pre-roll an amount of time code.

SMPTE View Offset (Lower Bar Position Row)
If you want to see the absolute time from the start of the project in the time display, 
rather than the actual SMPTE time, select the Enable Separate SMPTE View Offset 
checkbox.

Then choose Bar Position 1 1 1 1 displayed at SMPTE 00:00:00:00 (preset). If necessary, 
you can set other view offset values here.

The Tempo List always shows the real SMPTE time, never the SMPTE View Offset. The 
SMPTE View Offset is used in all other windows (including the Transport).

∏ Tip:  It is a common practice in many video (and audio) post production houses to set a 
one hour SMPTE offset (01:00:00:00). This avoids a problem commonly referred to as 
midnight, where a pre-roll passes through SMPTE time 00:00:00:00, which causes issues 
with some tape machines (such as the ADAT). 
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Audio
Use the Audio tab of the Synchronization project settings to keep your audio and MIDI 
tracks synchronized.

Current Sync Status
Â MTC (fps):  This real time display shows the deviation between the incoming MTC, 

and its nominal frame rate. If the deviation is significant, make sure that the right 
frame rate is set in the General tab of the Synchronization project settings. If in 
doubt, set the frame rate to 24 fps and switch on “Auto detect format of MTC”. If the 
frame rate is correct, you can use this display to adjust the tape speed of the master 
machine to the nominal value (the same speed used when the time code was 
recorded). Adjust the varipitch control on the master machine, until the slider is 
centered.

Â Sample Rate (Hz):  This display shows the deviation of the sample rate from its 
nominal value. You should note that some audio hardware will not allow any 
variation in the sample rate.

Â Deviation (ms):  This display shows the current phase deviation of the Word Clock 
from the time code master—in other words, the deviation between audio and MIDI. 
Varying time code signals shown in this display indicate how Logic Pro regulates the 
sample rate of the hardware, when in MTC Continuous sync mode. Even large time 
code variations result in no deviation between audio and MIDI synchronization. Your 
audio hardware must be capable of continuously variable sample rates, for this to 
function. Small deviations between audio and MIDI are unavoidable, because MIDI 
can (and should) follow the time code master directly.

Note:  The real time sample rate conversion facility of Logic Pro allows it to follow an 
external MTC signal (MTC Continuous), while maintaining the correct audio playback 
pitch and speed. This even works when recording in MTC-slave mode.
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Audio Sync Mode
This is where you define how each individual piece of audio hardware should be 
synchronized to an external time code master.

Not all audio hardware can work in every sync mode described below. This is 
particularly dependent on whether or not the hardware’s sample rate can be 
controlled.

There are two pop-up menus available, for Core Audio and DAE/TDM hardware. Use 
one or both, as applicable to the hardware installed on your system. You can choose 
the following options:
Â MTC Continuous (default):  Audio regions are started in sync, and the sample rate is 

continuously regulated to match variations in the time code master signal. Even very 
long audio regions stay in sync in this mode.

Â MTC Trigger + Auto Speed Detection:  Similar to MTC Trigger (see below), but the 
tempo of the time code master is constantly monitored while Logic Pro is running. 
The next time you start Logic Pro, it will use an adapted sample rate. This mode 
keeps long regions in better sync with the time code master, although not as closely 
as MTC Continuous. It does, however, use a constant sample rate, which is not 
affected by variations in the time code master signal.

Â MTC Trigger:  Audio regions are started in sync, but are then played at a constant 
sample rate, regardless of any variations in the time code master signal. Logic Pro 
always uses the set nominal sample rate (44.1, 48, 88.2, 96, 192 kHz). This mode is 
suitable when it is vital to retain the absolute pitch of a recording. If the speed of the 
time code master deviates from the nominal value, you may need to split long audio 
regions into shorter sections.

Â External or Free:  Logic Pro has no influence on the sample rate. The audio hardware is 
responsible for ensuring that the position and sample rate of audio regions match. 
This mode is only advisable if you are sure that the Word Clock and time code master 
are running in sync—by using an external SMPTE or Word Clock synchronizer, for 
example.

Â Digital:  Similar to External or Free, but the DAE/TDM hardware is also set up to 
synchronize to the sample rate of the incoming digital signal.

Â SSD/VSD Type:  Exactly the same as Digital, but a SMPTE Slave Driver (SSD) or Video 
Slave Driver (VSD) is used in addition—to synchronize with the sample and frame 
rates used in Logic Pro. The SMPTE slave driver is a device which synchronizes Pro 
Tools hardware to incoming time code or word clock signals.
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MIDI
The MIDI tab of the Synchronization project settings configures Logic Pro to send time 
code via MIDI, when running (record or play mode). This enables you to synchronize 
external devices as slaves to Logic Pro, which acts as the master.

Transmit MIDI Clock
The checkboxes activate transmission of MIDI Clock. The two Destination menus allow 
you to determine two discrete MIDI output ports for the MIDI Clock signal.

Every time you start, a Song Position Pointer (SPP) message is also sent. As not all 
devices can process SPP, the MIDI system real time Continue message is also sent. The 
exception to this is when you start at position 1 1 1 1. In this situation, the real time 
Start message is sent.

MIDI Clock can easily be sent with other normal MIDI events (notes, controllers). When 
using multi-port MIDI interfaces (such as the Unitor8), better timing is achieved by 
sending MIDI Clock to All ports, rather than to several individual ports.

If MIDI Clock is transmitted to all ports, the events are only sent once from the 
computer to the interface. If you address individual ports, one event needs to be sent 
for each port, placing a higher strain on the bandwidth of all ports.

Delay Transmission By
This parameter allows you to delay the transmission of MIDI Clock signals. Negative 
values mean that the MIDI Clock signal is transmitted earlier. This enables you to 
compensate for any reaction delays in external MIDI Clock slaves.
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Transmit MTC (MIDI Time Code)
The checkbox activates transmission of MIDI time code. The menu determines the MIDI 
output port for the MTC signal.

If you can avoid it, you shouldn’t send MTC to all ports, as it is very data-intensive. If 
possible, use a MIDI port that isn’t being used for anything else.

Transmit MMC (MIDI Machine Control)
Turn on this checkbox to enable transmission of MIDI Machine Control (see “MIDI 
Machine Control” on page 844). These commands are then sent whenever you operate 
the transport functions (Start, Stop, Rewind, and so on) of Logic Pro.

MMC is normally used when Logic Pro is running as a slave to an external master (such 
as an ADAT), and you want to control the external master’s transport functions from 
Logic Pro. Logic Pro therefore acts as MMC master, and MTC slave simultaneously.

If you want to use the external master’s transport controls, you don’t need to use MMC. 
In this situation, Logic Pro will follow the MTC master as a slave.

You can also use MMC to place tracks on the MMC slave device into record-enabled 
mode.

Listen to MMC Input
If this checkbox is activated, Logic Pro can be controlled by MMC (MIDI Machine 
Control) and so-called Full Frame Messages. 

Logic Pro recognizes these commands when listening to MMC Input:
Â Play
Â Deferred Play
Â Stop

Deferred Play is a special command for mechanically slow synchronization slaves such 
as reel-based tape recorders. Rather than having the machine play immediately, it is 
asked to reach the desired SMPTE position before playback is started. You’ll find no 
difference in Logic Pro’s response to the Play and Deferred Play commands, as Logic Pro 
can locate to any position almost instantly.

Logic Pro ignores these messages when incoming external MTC (MIDI Time Code) 
commands are detected.

Logic Pro also obeys Full Frame Messages, and sets the playhead to a new location, 
without starting playback. Once again, incoming MTC data has higher priority, if 
conflicting information is received.
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Some synchronizers send Full Frame Messages (instead of MTC) to locate the slave 
device (Logic Pro in this case) to a new position, without implicitly starting playback. 
This is useful when in slow shuttle or single frame advance modes with video 
machines, because the slave device is perfectly located, without being in playback 
mode.

MIDI Sync Preferences Button
The MIDI Sync Preferences button opens the Sync tab of the MIDI preferences (see 
“MIDI Preferences” on page 963).

Unitor
The Unitor tab of the Synchronization project settings is used to set the major 
synchronization parameters for the Unitor8 MIDI interface.

SMPTE Mode
You can instruct the Unitor8 to read or write SMPTE. You must switch from Read (the 
default) to Generate, and set the frame rate and SMPTE start time in the General tab 
(top Bar Position row). 

Click the Refresh checkbox to enable refresh mode, where fresh time code is 
generated—in sync with received time code. Refresh mode works with both VITC and 
LTC (see below).

You should always use refresh mode whenever you need to copy an LTC track, because 
you cannot directly copy LTC without a considerable loss of quality. When copying 
entire multitrack tapes, you should patch all tracks directly, but refresh the time code 
track via the Unitor8.

Note:  You should only use refresh mode if you are copying time code.
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SMPTE Type
This is where you define the SMPTE format that you want to use:
Â LTC:  Longitudinal (also called Linear) Time Code is written to a tape track.
Â VITC:  Vertical Interval (or Vertically Integrated) Time Code is written invisibly to a 

video tape.

Freewheel
You can set the freewheel time (in frames) for LTC and VITC. The freewheel parameter 
affects the SMPTE reader, and specifies how long the synchronizer continues 
transferring MTC to the sequencer, after time code ceases to be read.

Long freewheel times can maintain synchronization, even if there are drop outs in the 
time code, but they also increase the reaction time of Logic Pro—after the time code 
master stops. In practice, you should set a value that is as large as necessary (for 
sustained operation), and as small as possible (to reduce waiting times).

TV Format
Allows you to define the television format for time code burn-in:
Â PAL:  The video format used in Europe, South America, most Asian and African 

countries, and Oceania. If you are working with video in SECAM format (used in 
France and French-speaking nations in Africa), select PAL.

Â NTSC:  The video format used in the USA, Central America, Japan, and Canada.

VITC Line 1, VITC Line 2
VITC is written into two lines of the video picture, which are normally invisible. The lines 
should not be adjacent, and are usually situated between 12 and 20.

If the Scan option is enabled, the VITC lines are automatically recognized. You should 
only enter the lines manually if there are problems with Scan mode.

Visible Time Code Display
The parameters allow you to set the position, size, and style of the time code counter 
window, which is burned-into the video picture.
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Displaying and Using SMPTE Positions
The Bar ruler of each linear editing window can independently display a SMPTE time 
ruler or bar/beat ruler. For further information, see “Adjusting the Bar Ruler Display” on 
page 74.

Choosing View > Event Position and Length in SMPTE Units in the Event List switches 
the display of all positions and lengths to SMPTE times, rather than bar/beat values.

Positioning Objects to Frames (Pickup Clock)
You can use the Pickup Clock (Move Event to Playhead Position) key command to move 
selected objects (an individual event, tempo event, or a region, as examples) to the 
current playhead position. 

To position objects to frames:
1 Set the playhead position to the required SMPTE time, by going to a specific frame of 

the film in the Video track, for example. 

Note:  In addition to the usual position commands, you can also use the Rewind One 
Frame and Forward One Frame key commands to move one frame backwards or 
forwards.

2 Select the object that you want to place at this time position.

3 Use the Pickup Clock (Move Event to Playhead Position) key command to align the start 
point of the object with this time position.

The Pickup Clock & Select Next Event key command selects the next object, after the 
first object is moved. 

Note:  When using Pickup Clock with audio regions, it is the region’s anchor (not the 
region start point) that is moved to the playhead position. 

Fixing Objects to Frames
In situations where you’re working with synchronized film, you often want specific 
sound effects to play at a specific SMPTE time, rather than a particular bar position.

If the tempo of the piece needs to be altered at a later stage, the SMPTE time location 
of events that have already been positioned will change. The Lock SMPTE Position 
function prevents this from happening.

You can SMPTE-lock individual events in the Event List, or entire regions (along with all 
events they contain). Objects locked to a SMPTE position display a small padlock 
symbol in front of their name.
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To lock an object to its current SMPTE position:
1 Select the desired object.

2 Do one of the following:

Â In the Event List, Hyper and Piano Roll Editor:  Choose Functions > Lock SMPTE 
Position.

Â In the Arrange window:  Choose Region > Lock SMPTE Position.
Â Use the Lock SMPTE Position key command.

Note:  Copies of locked objects do not preserve their locked status, whether copied or 
pasted via the Clipboard, or by Option-dragging.

To unlock the SMPTE position of a locked object:
1 Select the desired object.

2 Do one of the following:

Â In the Event List, Hyper and Piano Roll Editor:  Choose Functions > Unlock SMPTE 
Position.

Â In the Arrange window:  Choose Region > Unlock SMPTE Position.
Â Use the Unlock SMPTE Position key command.

All selected objects that were locked to their SMPTE position are now fixed to their 
current bar position, just like normal events. This means they can be shifted by any 
future tempo changes. The padlock symbol in front of the name disappears.

Positioning Bars to Frames
If you want a particular bar in the project to coincide with a specific SMPTE time, you 
need to alter the tempo of the preceding passage.

The following procedure will save you from having to do this by trial and error:
1 Open the Tempo List (see “Using the Tempo List” on page 646).

2 Create a tempo event at the desired bar position.

3 Set the desired time position for this tempo event in the SMPTE Position column.

The preceding tempo event is automatically adjusted, to generate the correct bar and 
time position for the inserted tempo event.

4 You can then delete the tempo event you inserted, if you want to keep the same 
tempo for the following passage.
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MIDI Machine Control
MMC is a set of MIDI commands that Logic Pro uses to control the transport functions 
of any MMC-capable tape machine. The recording process can also be controlled and 
automated from Logic Pro via MMC. This tape machine then provides the SMPTE signal 
that Logic Pro uses as a synchronization source (with Logic Pro as the slave).

You can control connected devices from Logic Pro by using the normal transport 
functions (including direct positioning and cycle jumps). Don’t forget that Logic Pro 
needs to wait for the connected device to finish rewinding or forwarding. If MIDI 
Machine Control is enabled, dragging the playhead will send MMC Locate commands 
continuously, until the mouse button is released.

To switch on MMC, do one of the following:
m Control-click the Transport bar Sync button and enable the MIDI Machine Control 

(MMC) setting in the shortcut menu. 

m Choose File > Project Settings > Synchronization, and enable the Transmit MMC option 
in the MIDI tab.

Logic Pro supports up to 64 MMC tracks, allowing devices such as the Alesis ADAT to be 
operated via MIDI machine control.

Each Arrange track can act as a tape (control) track, by selecting an instrument with the 
tape deck icon (#305).

You only need to create one instrument with the tape deck icon, and you may then 
assign that same instrument to as many tracks as needed, to control your external 
recorder. It’s a good idea to group these tracks together in their own folder. These 
tracks must be placed at the top of the Arrange window track list. If you pack them into 
a folder, this must be the first track in the list.

The tape deck icon is the only icon that actually affects the way an object behaves. All 
other icons are purely graphical in nature.

If the tape track is the current record track, the following functions apply:
Â Selecting the tape track switches the corresponding track on the tape machine to 

record ready, and deactivates the record ready status of any other tracks. To select 
several tracks for recording, use Shift when clicking.
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Â The Record button in the Transport bar sends the record strobe command to the 
tape machine. This also puts Logic Pro into MIDI record mode, and sends an MMC 
Play command to the tape machine. Logic Pro doesn’t start until it receives time code 
back from the MMC device.

Â If you use the Autopunch function, the tape machine goes into record mode at the 
punch in locator, and stops recording at the punch out locator positions.

Â If you click on any track—not just a tape track—while holding down Control-Shift, 
you can individually toggle the record ready status for each track of the tape 
machine (selected tracks are switched on, and non-selected tracks are switched off ). 
Control-clicking on a track switches all other tracks out of record ready mode. If the 
current record track was assigned a tape deck icon (see above), you must not use the 
Control modifier.

Â The Record Toggle key command is used to toggle record status, if a tape track is the 
currently selected record track.

Â Following an MMC-controlled recording, Logic Pro automatically creates an empty 
MIDI region on the tape track. This is to let you know that a recording has taken 
place on the tape machine. This applies to all MMC recordings, including those 
controlled by the Autopunch function. If you activate several tape tracks (by Shift-
clicking), the corresponding number of regions are created. If a MIDI region with an 
identical start point already exists on a tape track, no new MIDI region is created on 
that track. This avoids overlapping regions.

Â A double stop command sets the project back to the beginning.

The MMC Record Buttons also offer you a simple way to arm tracks on your tape 
machine with Logic Pro (see “MMC Record Buttons” on page 895). 

You should finish all MMC-controlled recordings with Stop or Space. Some tape 
machines react differently to a series of MMC Record commands. Sometimes, this can 
result in Logic Pro showing a track as recording, when the tape is actually playing back 
(or even worse, the opposite situation). As such, you should always finish a recording 
with Stop or Space, just to be on the safe side.
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Synchronization Problems and Solutions
Given the number of different synchronization types that are available, and different 
implementations by various manufacturers, you may occasionally encounter timing 
issues when running Logic Pro synchronously with other devices or applications. This 
section will help you to overcome some common synchronization problems.

Faulty Digital Synchronization
If Logic Pro is synchronized to external Word Clock (Audio Sync Mode:  External or 
Free), you must ensure that a valid digital signal is always available. If you encounter 
error messages such as “Sample Rate xxx kHz recognized” it may be that the DAT 
recorder (or whatever clock source you have connected to your audio hardware’s 
digital input) does not transmit Word Clock in stop or pause mode (or has switched 
itself off ).

Faulty Synchronization to an External Tape Machine
Create a new project, make a new recording and see if that does the trick. Why? If an 
old recording on tape was not properly synchronized to time code, you won’t be able 
to use it. One basic rule:  the playback situation must be identical to the recording 
situation.

If everything is working fine with the new recording, this means the present setup is 
okay. Next, check whether anything has changed in your global setup. Has the frame 
rate changed? Has the tape speed changed? If you have changed a 30 fps setting, try 
variations such as 30 drop or 29.97.

If MIDI and Audio Are not Synchronized
Open the File > Project Settings > Synchronization > Audio tab and select the MTC 
Continuous or MTC Trigger + Auto Speed Detection mode.

If your audio hardware doesn’t support either mode, you should cut extremely long 
regions into shorter sections.

If MIDI and SMPTE Are not Synchronized
Check all frame rate settings. The frame rate of all connected devices must be identical, 
including the time code on the tape machine, the synchronizer, and in Logic Pro itself.

Some synchronizers encode the wrong frame rate in MTC. In this situation, open the 
Tempo Editor, switch off the Detect option, and set the correct frame rate manually.
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37 Working With Plug-in Latencies

Audio processed through plug-ins is subject to small timing 
delays, known as latency.

Fortunately, Logic Pro provides a number of advanced features that can compensate 
for these timing differences, ensuring that all track and channel output is perfectly 
synchronized.

This chapter discusses the technical aspects of plug-in latency, and how to circumvent 
these timing anomalies in Logic Pro.

About Latency
Each digital process—plug-in processing, changing the volume or pan level, and so 
on—adds an amount of latency (a small delay). Each of these processing latency values 
is added to each other.

To explain, a software instrument running inside Logic Pro will only have an output 
latency, because it is generated inside the application. An audio recording that is being 
monitored in real time will have both an input, and an output, latency. These two 
values are summed, resulting in an overall monitoring latency figure.

Each process—such as the use of an effect plug-in, for example—will also add an 
amount of latency, which is combined with the input and output latency figure, 
dependent on whether a software instrument or audio channel is in use. As an 
example, if a recorded vocal is routed through a compressor effect (with a 10 
millisecond latency) and the audio interface output latency is 40 milliseconds, the total 
latency figure would be 50 milliseconds (10 + 40 = 50). If three plug-ins (reverb, chorus, 
and compressor, for example) that also introduced a 10 millisecond latency were used 
for this track, the latency would be 70 milliseconds (10 + 10 + 10 + 40 = 70).

The audio interface input and output latency is handled by the settings in the Logic Pro 
> Preferences > Audio > Devices tab (see “Configuring Your Audio Hardware” on 
page 96). Internal latencies introduced by plug-ins are dealt with in a different way, 
which is the focus of this chapter.
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Working With the Low Latency Mode
The Low Latency mode allows you to limit the maximum delay time caused by plug-
ins. Plug-ins will be bypassed to ensure that the maximum delay that can occur across 
the entire signal flow (of the current track) remains under the chosen value. The Low 
Latency mode is extremely useful when you need to play a software instrument (or to 
monitor through an audio channel) when plug-ins with high latencies are already in 
use—at any point in the signal flow for the selected track/channel.

To set the maximum delay time allowed in Low Latency mode:
1 Choose Logic Pro > Preferences > Audio, then click the General tab.

2 Set the Limit slider to the desired value. 

To activate Low Latency mode, do one of the following:
m Click the Low Latency Mode button in the Transport bar. 

m Switch on the Low Latency Mode checkbox in the General Audio preferences tab. 

This limits the latency generated by plug-ins to the value set with the Limit slider. Plug-
ins will be bypassed, ensuring that the maximum delay that can occur across the entire 
signal flow (of the current track’s signal path) remains under the Limit slider value. 
Â Bypassed plug-ins may be on the selected track, any auxes in the signal path, or even 

output channels. 
Â Plug-ins with the highest latencies will be bypassed first.

Note:  The sound may change in Low Latency mode. Depending on the plug-ins in use, 
the changes can be anything from subtle to dramatic. If plug-ins being used do not 
exceed the total latency limit, there will be no audible difference.
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Working With Plug-in Delay Compensation
The Compensation menu in the Logic Pro > Preferences > Audio > General tab allows 
you to either disable plug-in delay compensation (Off ), or activate it for:
Â Audio and software instrument tracks.
Â All channels (audio, instrument, aux, output, bus, and ReWire).

About Plug-in Delay Compensation
Logic Pro provides plug-in delay compensation for all channels:  If activated, Logic Pro 
compensates for latency introduced by plug-ins, ensuring that audio routed through 
such plug-ins is synchronized with all other audio. 

Logic Pro achieves this by calculating the amount of latency caused by plug-ins, and 
then delaying audio streams by an appropriate amount—or shifting instrument and 
audio tracks forward in time. The compensation method depends on the type of 
channel that the latency-inducing plug-in is inserted into. 
Â If latency-inducing plug-ins are inserted into aux or output channels (or ReWire 

channels, if used), Logic Pro delays all other audio streams by an appropriate amount. 
Â If latency-inducing plug-ins are inserted into audio or instrument channels, Logic Pro 

automatically shifts these tracks forward in time. The advantage of this method is 
that other channels (that do not contain latency-inducing plug-ins) do not need to 
be delayed. 

As an example:  Imagine a simple song with a few bass, guitar, vocal, and drum tracks. 
The bass track is routed through an audio channel that contains an effect that 
introduces a latency of 10 ms. All guitar tracks are routed to an aux channel that 
contains several inserted effects. The combined latency introduced by these effects is 
30 milliseconds (ms). The vocals are routed through another aux channel that has a set 
of effects that introduce 15 ms of latency. The drum tracks are routed straight to the 
main outputs, without being routed through any effects. If latencies were not 
compensated for, the drum tracks would play 30 ms ahead of the guitar tracks. The 
bass track would play 20 ms ahead of the guitar track, but 10 ms behind the drums. The 
vocals would play 15 ms before the guitar track, but 15 ms behind the drums and 5 ms 
behind the bass. Needless to say, this isn’t ideal.
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With plug-in delay compensation set to All, Logic Pro shifts the bass track forward by 
10 ms, thus synchronizing the bass and drum tracks. Logic Pro will then delay both 
streams routed to the output channel by 30 ms, aligning them with the guitar tracks. 
The aux channel that the vocals are streamed to is also delayed by 15 ms, aligning it 
with the drum and guitar streams (in other words, the 15 ms delay is increased to 
30 ms). The precise calculations required for each stream are handled automatically.

As you can see in the table, all output is effectively delayed by 30 milliseconds—to 
match the largest amount of compensation required (by the effects in aux channel 1, 
which the guitar tracks are routed to). This has the effect of perfectly aligning all tracks 
routed to the output, and circumventing any delays introduced by plug-ins, regardless 
of where they are used in the signal path.

Plug-in Delay Compensation Limitations
Plug-in delay compensation works seamlessly during playback and mixing. The delay 
that is introduced—to compensate for latency-inducing plug-ins in output and 
auxiliary channels—can be applied to non-delayed streams, before they are played 
back. Instrument and audio tracks (that contain latency-inducing plug-ins) can also be 
shifted forward in time, before playback starts. 

There are, however, some limitations if you use plug-in delay compensation with live 
tracks. Shifting pre-recorded instrument and audio tracks forward in time is possible 
when the audio is streaming live. So, recording while plug-in delay compensation is set 
to instruments and tracks will work fine—as long as you do not try to record through 
latency-inducing plug-ins:  A live track can not be shifted forward in time (as Logic Pro 
can’t position live audio before it happens!). 

Important:  Delaying a live stream, in order to synchronize it with other delayed audio 
channels is not possible.

This may lead to problems if you decide to make further recordings after setting plug-
in delay compensation to All, and inserting latency-inducing plug-ins in auxes and 
outputs. If Logic Pro needs to delay streams to compensate for plug-in latencies, you 
will be listening to delayed audio streams while recording. As such, your recording will 
be late by the number of samples that the audio streams were delayed by. 

Track Uncompensated Compensated

Bass (effect directly inserted in 
audio channel)

10 ms delay 10 ms → (audio channel) then ← 30 ms 
(output channel)

Guitars (routed to aux 1) 30 ms delay Not changed.

Drums (direct to output) No delay 30 ms ← (output channel)

Vocal (routed to aux 2) 15 ms delay 15 milliseconds ← (aux channel 2)
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For these same reasons, you may encounter increased latency if playing software 
instrument tracks live, when plug-in delay compensation is set to All. This issue can be 
mitigated to some extent by using the Low Latency mode (see “Working With the Low 
Latency Mode” on page 848).

Dealing With Latency Issues
To avoid these potential pitfalls, you should try to complete any audio and software 
instrument recording before inserting latency-inducing plug-ins. If you need to record 
a software instrument or audio track after setting up a latency-inducing signal routing, 
the following procedure will help you to get around any possible problems.

To record after setting up a latency-inducing signal routing:
1 Switch the plug-in delay compensation setting from All to Audio and Software 

Instrument Tracks in the Logic Pro > Preferences > Audio > General tab.

You can also use the Toggle Plug-in Delay Compensation:  All/Audio and Instrument 
Tracks key command to quickly switch compensation between All or only Audio and 
Software Instrument Tracks. 

The Audio and Software Instrument Tracks plug-in delay compensation method shifts 
tracks that contain latency-inducing plug-ins forward in time—so any audio and 
instrument tracks that contain such plug-ins will be synchronized with non-delayed 
tracks. There is only one exception:  Live tracks can not be shifted forward in time. 

The next step is to eliminate any latency introduced by plug-ins in your recording track. 

2 Bypass any latency-inducing plug-ins on the recording track by Option-clicking on the 
respective Insert slots.

In the Audio and Software Instrument Tracks plug-in delay compensation mode, 
bypassing plug-ins eliminates the latency that they create. Latency caused by plug-ins 
in audio and software instrument tracks is compensated for. 

The last thing to do is to get around the latency introduced by plug-ins on aux and 
output channels. 

3 Bypass any latency-inducing plug-ins on auxes and outputs.

At this point, all audio streams will be synchronized, allowing you to proceed with your 
recording.

When you’ve finished recording, re-enable all latency-inducing plug-ins, and switch the 
delay compensation setting to All.

Note:  In the All mode, bypassing plug-ins on busses, auxes, and outputs will not 
eliminate the latency that they create. You must actually remove these plug-ins from 
the Insert slots to eliminate latency.
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If you are recording audio, another strategy would be to disable the Software 
Monitoring checkbox in the Logic Pro > Preferences > Audio > Drivers tab. This would 
necessitate monitoring your recording via an external mixer. When Logic Pro is not 
providing software monitoring of incoming audio, it can correctly position audio 
recordings—even when full delay compensation is active. Obviously, you can’t use 
external monitoring when recording software instruments. 

Note:  As Logic Pro has no direct control over the audio outputs of external devices, 
plug-in delay compensation can not work for MIDI tracks that trigger external sound 
modules. If you activate full plug-in delay compensation and insert latency-inducing 
plug-ins, external MIDI signals will be out of sync with the delayed audio streams. 
Logic Pro allows you to circumvent this issue with the External Instrument plug-
in:  Insert it (as you would insert a software instrument plug-in on instrument channels) 
to route the audio outputs of your external MIDI devices to the inputs of your audio 
hardware—and monitor them through Logic Pro. This enables you to compensate for 
the delays of any audio streams coming from MIDI devices during playback.
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38 Working With Split Channel Audio 
File Formats

You can store multi-channel audio as interleaved or split 
channel audio files. 

An interleaved audio file contains all channel information, stored in an alternating 
single “stream.” 
Â For stereo files, this would be left channel, right channel, left, right, and so on.
Â For surround files, this would be channel 1, channel 2, channel 3, and so on, then 

back to channel 1. Put into the context of a 5.1 surround mix:  left, center, right, left 
surround, right surround, LFE (then back to left, center, and so on) in a six channel 
interleaved file. 

Split channel audio files couple separate audio files, allowing you to deal with each 
channel (file) independently. 
Â For stereo files, two separate files are created, where one file contains the left 

channel samples, and the other file contains the right channel samples. The files are 
generally identified by a .L and .R suffix. The two files are linked, and are edited as a 
pair. You can, however, disconnect them (in the Audio Bin), allowing each to be 
handled independently.

Â For multi mono (or split surround) files, multiple mono files are created:  one for each 
surround channel. As with split stereo, each file is identified by a suffix. This is 
commonly as follows for a 5.1 surround mix:  .L, .C, .R, .Ls, .Rs, and .LFE. Each file is 
independent. 

Logic Pro, and most other audio applications, support the import and recording of 
interleaved files when using Core Audio hardware. 

A handful of audio applications (including Pro Tools) only support split file formats, and 
will automatically separate interleaved files when you import them. This is also true of 
Logic Pro when importing interleaved stereo files using DAE/TDM hardware (Logic Pro 
does not support split surround files).

∏ Tip:  You should use interleaved audio files if your audio hardware supports them. Split 
channel audio files require significantly more hard disk I/O performance. 
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Importing Split Channel Files
Nothing special needs to be done to import either split or interleaved files into 
Logic Pro. What happens when you do import such files is slightly different, depending 
on the audio interface hardware in use.

If You Are Using Core Audio Hardware in Logic Pro
When split channel files are imported, they are automatically converted to interleaved 
files. If you want to add several split channel files simultaneously, Logic Pro asks 
whether all files should be converted at once.

If You Are Using DAE/TDM Hardware in Logic Pro
When split stereo files are imported into Logic Pro, they are used as is. Split surround 
files are not supported.

Working With Split Stereo Files
Logic Pro treats audio files with a name that ends in .L or .R as stereo files. This applies 
to all file management functions, such as Rename, Create, or Revert to Backup. The 
following list outlines how split stereo files are handled in Logic Pro:
Â When you select an independent mono file (one side of a split stereo file “pair”) in 

the file selector box, both channels are imported. Split stereo regions are indicated 
by the stereo symbol:  two adjoining circles. 

Â You can see both files in the Audio Bin. They have the same name—apart from the 
channel suffix (L and R). If you rename one channel of a split stereo audio file, the 
other channel file is automatically renamed as well. This also applies when renaming 
regions associated with the files.

Â File edits performed in the Sample Editor apply equally to both files.
Â If you use the Add Region command to create a new region, Logic Pro does this for 

both audio files.
Â Any alteration made to either region is automatically mirrored by the other. This 

applies to region start point, end point, and anchor position changes.
Â If the region of either file is moved into (or within) the Arrange area, the other region 

is also moved.
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Disconnecting Split Stereo Files
Both sides of a split stereo file are normally edited together, as discussed above. On 
occasion, however, you may need to edit one side individually.

To disconnect a split stereo file:
1 Select (either side of ) the split stereo file in the Audio Bin.

2 Choose Edit > Disconnect Selected Split Stereo File.

You can now edit both sides of the recording as individual mono files. This function will 
only disconnect one split stereo file at a time. 

Important:  If you want to reconnect the files, don’t define any new regions!

To reconnect all split stereo files in your project:
m Choose Edit > Reconnect All Split Stereo Files in the Audio Bin. 

Logic Pro reconnects all disconnected stereo files in the project. Only files that were 
previously part of a split stereo “pair” are reconnected.

Converting Split Stereo Files to Interleaved Stereo
You can convert two (split stereo) audio files into an interleaved stereo file—in the SDII, 
AIFF, or WAV format. This is useful if you want to use a split stereo file in another 
application, such as the WaveBurner CD mastering software, which only supports 
interleaved files.

To convert split stereo files into interleaved stereo files:
1 Select the audio files in the Audio Bin.

2 Choose Audio File > Copy/Convert File(s).

3 Choose Split to Interleaved in the Stereo Conversion menu.

4 Type in the desired file name, browse to a folder location, then click Save.

Note:  This only works for split stereo files. You can’t use these commands to combine 
two mono files into a stereo file. 
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Exporting Split Channel Files
You can bounce stereo files from Logic Pro—in interleaved or split stereo formats. 
Surround files can be bounced as interleaved, or multiple mono files.

Essentially, there are only two parameters of importance for creating split format files in 
the Bounce window:
Â File Type pop-up menu:  Choose Split.
Â Surround Bounce checkbox:  Turn this on when performing a surround bounce (either 

interleaved or split).

Full details on all Bounce window options are found in Chapter 27, “Bouncing Your 
Project,” on page 601.

When Would You Create an Interleaved or Split Bounce File?
Â Interleaved bounce:  Do this when you want to use the file in another audio 

application that supports interleaved files (most audio applications or devices do).
Â Perform a split channel bounce when you want to use the file in Pro Tools software, 

or another application that only supports the “split stereo” format.
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39 Working in the Environment

The Environment controls all MIDI input and output, and also 
allows you to integrate and process the data of MIDI and 
software instruments.

This chapter will help you to understand how the Environment window works, and 
how to use objects to alter MIDI data in real time.

It is not essential to know about—or even open—the Environment window in order to 
make music with the instruments of Logic Pro or your external MIDI sound generators 
and keyboards.

When you create new instrument or external MIDI tracks (as discussed in “Working 
With Instruments” on page 237), Logic Pro automatically generates Mixer channels, and 
will also create and configure any Environment objects that are needed for basic input 
and output. 

Note:  This also true of audio tracks (and other audio channel types, such as auxilliaries 
and outputs), but you will rarely need to access these objects in the Environment, as 
you have full control over them in the Mixer and Arrange channel strips.

If your needs don’t extend further than basic access and control of your external MIDI 
devices, then this chapter will be of little interest. As a recommendation, however, it 
may be worthwhile exploring the “Multi Instruments” section on page 883. Some small 
customizations to these objects can make your workflow much easier and faster.

Beyond basic MIDI input and output handling, the Environment can be used to alter 
MIDI data in real time, enabling you to create processing machines, such as virtual 
rhythm generators and step sequencers, or complex synthesizer editors. 

This processing can be done on any MIDI data, which means that you can manipulate 
both external MIDI instruments and your software instrument channels.

Ultimately, it’s up to you to decide how to, or indeed if, you use any of the 
Environment’s facilities.
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Using the Environment
This section outlines all general concepts and techniques needed to use the 
Environment. If you require detailed descriptions of the Environment objects, please 
see “The Environment Objects” on page 880. 

An Introduction to the Environment
The Environment refers to the virtual environment of Logic Pro inside your computer. It 
was developed to allow complete control over your MIDI setup.

The Environment window provides a virtual view of your MIDI studio. It can include:
Â Physical Input and Sequencer Input objects, which represent the physical MIDI inputs 

of your MIDI interface and the Logic Pro input.
Â Instrument objects, which are virtual representations of each MIDI device 

(synthesizers and samplers, as examples) in your MIDI rig.
Â Numerous other objects, such as faders, knobs, switches, arpeggiators, and more. 

These are used to create new data, or to control and modify the MIDI signal flow in 
real time. 

You determine the MIDI signal flow by connecting Environment objects with virtual 
cables.

The connection of objects with virtual cables makes it easy to follow the signal flow, 
but also allows near limitless routing and MIDI data processing possibilities. Use your 
imagination, and logically plan (and implement) the signal path, to take advantage of 
the functionality offered by each object type. If you can think of a way to manipulate 
your MIDI data, you can do it in the Environment!
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Most objects can be remotely controlled by other MIDI events (using the sliders or 
modulation wheel of your keyboard, for example). You can even record these 
movements, if you wish. 

In addition, there are specialized objects which can split a MIDI signal into different 
channels, make pre-programmed alterations, or even re-route the signal path. These 
enable you to use the same MIDI data (note events, for example) for several processes, 
or can be used to provide controller keyboard functionality to the most basic MIDI 
keyboard.

As you might imagine, the Environment can quickly fill up with a large number of 
objects. To keep things organized, you can assign them to different display levels, 
referred to as layers. Think of these layers as being different, partial views of the overall 
Environment. Naturally, you can easily connect objects between different layers.

To open the Environment window:
m Choose Window > Environment (or use the corresponding key command, 

default:  Command-8). 

You can also use the Toggle Environment key command to:

Â Bring an open Environment window to the front
Â Open an Environment window.
Â Close an Environment window, if it is the active window.

Working With Layers
Layers are display levels of the Environment window. They allow you to view and work 
with specific groups of related objects (all instrument objects, for example), rather than 
dealing with all Environment objects at the same time. The name of the current layer is 
displayed in the Layer menu.

The distribution of objects across different layers has no effect on their functionality—
it’s simply a better way to organize (potentially thousands of ) objects. There are two 
exceptions:
Â Objects in the Global Objects layer also appear on all other layers. 
Â The All Objects layer shows a list of all Environment objects.

Layer menu
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To switch between layers:
m Click the arrow button next to the Layer menu, and choose the desired layer from the 

menu.

To switch back to the most recently opened layer:
m Choose Options > Go to Previous Layer (or use the Go to Previous Layer key command) 

in the Environment.

To create a new layer, do one of the following:
m Choose Create Layer from the Layer menu (or use the corresponding key command). 

m Choose Options > Layer > Create.

The new, empty layer called “(unnamed)” is inserted above the currently selected layer. 

To name a layer:
1 Click on the layer name field, and type in the desired name.

2 Press return to confirm the new name and exit text entry mode.

To delete a layer, do one of the following:
m Choose Delete from the Layer menu to remove the current (displayed) layer from the 

list.

m Choose Options > Layer > Delete (or use the Delete Layer key command).

An alert appears, to warn against the unwitting deletion of all objects on the layer. 
Click Delete to complete the operation. 
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The position (and existence) of the first two layers—All Objects and Global Objects—is 
protected, and they can not be deleted:
Â All Objects:  This layer displays all objects in the Environment. The objects in this layer 

are normally shown as a list.

Â If you turn off the Logic Pro > Preferences > Display > Other > “Allow ‘All Objects’ 
layer” option, the All Objects layer will disappear from the Layer menu. Enable this 
preference if you need access to the All Objects layer.

Â You can choose the Options > Go to Layer of Object command, in the Environment 
menu, to switch to the selected object’s layer.

Â Global Objects:  You can place objects that you want to be visible in all layers in the 
second layer from the top. These will appear at the same position in all layers. It is 
recommended that you place as few objects as possible on this layer, due to the on-
screen clutter that global objects can create.



862 Chapter 39    Working in the Environment

Customizing the Environment Display
You can customize the display of the Environment, using the options in the View menu.

To hide the Inspector, which contains the Layer menu and Object Parameter box:
m Choose View > Inspector (or use the corresponding key command, default:  I). 

This will create more room onscreen for the Environment workspace display.

To view objects graphically or as a list:
m Choose View > By Text to switch between the graphical display of objects to a listing.

Cables are not shown in the list display. This type of display is most useful in the All 
Objects layer.

Customizing the Display of Cables
You can arrange your Environment objects more clearly by hiding cables, or coloring 
them. 

To hide or show cables:
m Choose View > Cables to display or hide cables between objects. 

This also hides or shows the positioning bar (used for moving and resizing) to the right 
of some object types.

∏ Tip:  You can prevent the accidental alteration of the position, size, and cable 
connections of all objects by choosing View > Protect Cabling/Positions.

If the cabling and object positions are protected, and the cables are hidden, the 
background color changes. This usually looks better for virtual mixing desks and fader 
setups.

To view colored cables:
m Enable the View > Colored Cables setting.

Cable colors are derived from the color of the source object (the object that the cable 
runs from, into another object).

To assign a color to the selected object:
m Choose View > Colors (default key command:  Option-C), and click on the desired color 

in the Color palette.

Double-click on any color in the palette to open the Colors window, which allows you 
to define custom colors.

These color edits are stored in the preferences file, and are available for all projects. The 
color of an Environment object is used as the default color for any newly created region 
in the Arrange window.
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Viewing a Frameless Environment Window
There may be occasions where you would like to have access to particular Environment 
objects while working in the Arrange window. As an example, a few buttons that are 
used to control a tape machine.

Rather than needing to open (or indeed viewing) a full Environment window every 
time you need to control the tape machine, you can create a mini window that floats 
on top of other windows. 

Typically, this would be the approach:
1 Create a new layer.

2 Create the objects, cable them if necessary, and adjust their parameters as needed.

3 Reposition the objects, and resize the Environment window so that it is just large 
enough to accomodate the objects.

4 Choose View > Frameless Floating Window. 

This will create the mini Environment window, which floats above other windows.

5 Position it as desired (above the Arrange window would be the most obvious use), and 
press Shift-L to lock this as a screenset.

6 Simply choose this screenset to access to the tape controls whenever you need them.

Working With Objects
As with all windows, you interact with onscreen elements and data by using different 
tools. The Environment window Tool menus offer the standard Pointer, Pencil, and 
Eraser tools found in other windows. These are used to select, create, and delete 
objects in the Environment. In addition, the following tools are available in the 
Environment:

Â Text tool:  Clicking an object with the Text tool allows you to rename it. Click 
anywhere outside the text field, or press Return, to complete the naming operation.
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Â MIDI Thru tool:  Clicking an object in the Environment with the MIDI Thru tool assigns 
the object to the selected track in the Arrange window. 

Creating and Deleting Objects
Choose an object type from the New menu to create an object of this type on the 
current layer. You can also use the corresponding key commands.

Clicking on a layer background with the Pencil tool creates a new instrument object.

To delete objects, do one of the following:
m Click the object with the Eraser tool.

m Select all objects you want to delete, and choose Edit > Delete (or press Backspace).

Moving Objects
You can move objects by grabbing their icon or name, and dragging them to the 
desired position on the layer. The surface of keyboard and fader objects is used for their 
operation. You must therefore either grab the name (if available), or the positioning bar 
to the right of the object in order to move them. If you hold down Shift, you can also 
grab keyboard or fader objects by their surface.

Note:  You can Shift-click on any Environment object to select, and move it. When doing 
so, remember to first deselect any other selected objects by clicking on the layer 
background, to avoid moving them as well.

Moving Objects Between Layers
The Layer menu and the Clipboard allow you to move objects between layers. You can 
also open a second Environment window, and drag the objects to the desired layer.

To use the Layer menu to move objects to a different layer:
1 Select the desired objects. 

2 Hold down Option, and select the desired layer in the Layer menu. 

This moves the selected objects to the chosen layer.

To use the Clipboard to move objects to a different layer:
1 Select the objects that you want to move and choose Edit > Cut (or use the 

corresponding key command, default:  Command-X).

2 Switch to the destination layer.

3 Make sure that no objects are selected (by clicking on the layer background).

Positioning bar
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4 Choose Edit > Paste (or use the corresponding key command, default:  Command-V).

Note:  If any objects are selected when attempting to paste objects to the current layer, 
a dialog asks if you want to “Replace current selection? No/Replace”. If you press Enter 
or click Replace, the selected objects will be replaced by the objects in the Clipboard. 
The existing cabling remains intact.

To drag objects to a different layer:
1 Open a second Environment window that displays the target layer.

2 Select the objects you want to move in the first Environment window, and drag them 
from one window to the other. 

∏ Tip:  You can also use this method to copy objects between layers (by holding Option).

Copying Objects
You can copy an object on a layer by Option-dragging it with the Pointer tool.

To copy an object between layers using the Clipboard:
1 Select the objects that you want to move and choose Edit > Copy (or use the 

corresponding key command, default:  Command-C).

2 Switch to the destination layer.

3 Make sure that no objects are selected (by clicking on the layer background).

4 Choose Edit > Paste (or use the corresponding key command, default:  Command-V).

Cabling is preserved; so groups of objects copied in this way will be connected in the 
same way as the originals (When you copy a single object, only its output cables are 
preserved).

Note:  If any objects are selected when attempting to paste objects to the current layer, 
a dialog asks if you want to “Replace current selection? No/Replace”. If you press Enter 
or click Replace, the selected objects will be replaced by the objects in the Clipboard. 
The existing cabling remains intact.

To use drag and drop to copy objects to a different layer:
1 Open a second Environment window that displays the target layer.

2 Select the objects you want to copy in the first Environment window, press Option, and 
drag them from one window to the other. 
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Tidying Up Moved or Copied Objects
Objects can be freely placed, which is flexible, but can lead to overlaps or 
misalignments—particularly when pasting between layers. Fortunately, you can quickly 
clean up object positions.

To snap objects to a grid:
m Enable View > Snap Positions to align the objects to an invisible grid. 

It’s a good idea to leave snap positions switched on. You only need to switch it off if 
you want to manually move an object by a few pixels.

You can also use the following key commands to move all selected objects one pixel in 
the relevant direction, even when the grid is switched on:
Â Object Move Left
Â Object Move Right 
Â Object Move Up
Â Object Move Down

To align several selected objects horizontally or vertically:
m Choose Options > Clean up > Align Objects (or use the corresponding key command). 

The top left object stays where it is. The position of the next object determines 
whether the objects are aligned in a column or a row. If it is to the right of the top left 
object, all objects are aligned horizontally (row). If it is below the top left object, all 
objects are aligned vertically (column).

To align selected objects to the invisible grid:
m Choose Options > Clean up > Positions by Grid.

Adjusting the Size of Objects
You can adjust the size of fader, keyboard, and monitor objects by grabbing and 
dragging the bottom right corner (just as with windows).

Changing sizes when multiple objects are selected (by rubber-banding or Shift-
clicking) will alter each object’s size, while preserving their sizes, relative to each other.



Chapter 39    Working in the Environment 867

To set the size of the selected object to its default value:
m Choose Options > Clean up > Size by Default.

You can also use the following key commands to decrease or increase the width or 
height of all selected objects by 1 pixel
Â Object Width –1 Pixel 
Â Object Width +1 Pixel 
Â Object Height –1 Pixel
Â Object Height +1 Pixel

Special Selection Commands
You can make moving and copying tasks faster and easier by using the selection 
commands outlined below.

Selecting All Used Instruments
The Edit > Select Used Instruments function selects all objects that are assigned to the 
selected track in the Arrange window (or tracks that contain regions), or are connected 
to such objects via cables.

Selecting All Unused Instruments
The Edit > Select Unused Instruments function selects all objects that are neither used 
in the Arrange window (as tracks which contain regions), nor connected to any such 
objects via cables.

Selecting Cable Destination or Origin Objects
The Edit > Select Cable Destination command highlights the destination object of a 
selected cable connection. This is particularly useful in two cases:
Â The destination object is on a different layer. You can use the function to select and 

display the destination object (and layer).
Â When in the list display (View > By Text), you can locate the destination object of a 

source object, because selecting the source object also selects its cable connections.

This function allows you to follow the cabling from one (serially-cabled) object to the 
next. If several objects are connected in parallel, or several cable connections are 
selected, the path of the top cable is followed.

The Edit > Select Cable Origin command essentially performs the reverse task, where 
the MIDI signal flow is back-tracked to the source (or origin) object. This is particularly 
useful for troubleshooting, or when you want to make changes to a number of serially 
cabled objects (by changing the original).

Toggling Your Selection
Just as in the Arrange and editor windows, you can change the status of any selected 
objects in the current layer by choosing Edit > Toggle Selection.
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The MIDI Signal Path
Before any MIDI events received at your computer’s MIDI inputs can be recorded by 
Logic Pro, there must be a connection between two Environment objects, namely the:
Â Physical Input object:  This represents the MIDI In port(s) of your MIDI interface.
Â Sequencer Input object:  This represents the door in to Logic Pro for incoming MIDI 

events.

In Logic Pro, incoming MIDI events (which arrive at the Sequencer Input object) are 
always directed to the selected track in the Arrange area’s track list, where they can be 
recorded in MIDI regions. 

The events played by the track region are mixed with incoming events (if any), and sent 
to the Environment object that the track is routed to. 

From here (the multi instrument object), the events are directed to a MIDI output (see 
“Creating Direct Output Assignments” on page 869).

You can insert objects into the signal path between the Physical Input and the 
Sequencer Input object if you wish (a MIDI monitor object, for example, which allows 
you to see incoming MIDI events).

You can also insert objects between the Arrange track, and its destination object, 
enabling other Environment processing. The Arrange track itself is not represented by 
an Environment object, but you can use the Track Assignment menu to route the 
track’s output to an Environement object. 
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As an example, the output of an Arrange track (the note events in a MIDI region) 
routed to (software) instrument channel 1 can be arpeggiated. To do this, you would 
create an arpeggiator object (this will be easiest on the Mixer layer of the Environment), 
assign the arpeggiator to the Arrange track (Control-click the track header to access the 
Track Assignment menu, and browse to the arpeggiator object), then cable the 
arpeggiator out to instrument channel 1. 

On playback, the note events in the region will be processed by the arpeggiator object, 
and routed (via the cable) into the instrument channel, which plays back the processed 
(arpeggiated) MIDI note data.

Creating Direct Output Assignments
You can create a direct output connection to a physical MIDI output from any of the 
following object types:
Â Instrument 
Â Multi Instrument
Â Mapped Instrument
Â Touch Tracks
Â GM Mixer
Â MIDI Metronome Click
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To make a direct output connection:
m Click the Port menu in the object’s Parameter box, and choose the desired MIDI output.

The Port menu lists all MIDI Outputs, plus the following options. 
Â The Off setting completely disables the connection to the MIDI interface port. 
Â The All option routes the object’s output to all available MIDI ports. This may be 

useful if the device is sending a pulse, for example. 

Note:  If you have a MIDI interface with more than one output port (or even several 
interfaces which can be stacked), you can set up a direct connection to one of the 
individual ports (1 to 63) of that (or those) interfaces. 

Any object with a directly assigned output is indicated by a white triangle on its right-
hand side. The triangle is hollow when there is no direct assignment.

Object with direct output 
assignment

Object without direct 
output assignment
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Cabling
The cabling between Environment objects provides control over the entire MIDI signal 
path. A cable is normally shown as a gray or colored line between a source and 
destination object. 

Cables are assigned the same color as the source object, which makes following the 
signal path much easier. You can, however, switch off cable coloring, and render them 
in gray with the View > Colored Cables function.

Objects always have an (invisible) input on the left, and an output on the right-hand 
side. The output of an object is shown as a small triangle, pointing to the right.

To make a connection between two objects—method 1:
1 Click-hold the triangle of the source object. 

The mouse pointer turns into a plug (patch cord) that represents a cable connection 
coming from the object’s output. 

2 Move the cable plug over the destination object, and release the mouse button when 
the object is highlighted (this happens automatically when you touch it). 

A cable connection will be created between the two objects.

If the source object has already been directly assigned to a MIDI output port, a dialog 
will ask if you want to replace the direct assignment. You have three options:
Â Cancel:  The connection is not made, and the direct output assignment of the source 

object remains intact.
Â No:  Your cabling takes place, but the direct output assignment remains intact. This 

means that the source object is connected to two destinations—one to another 
object via the cable, and one via the direct output assignment.

Â Remove:  Your cabling occurs, and the direct output assignment is removed (This is 
the default selection, because you generally won’t want an object connected to two 
different destinations).
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To make a connection between two objects—method 2:
1 Option-click the triangle, which will open a hierarchical menu.

2 Browse to the layer that the destination object is on, and choose the object name. 

A cable connection will be created between the two objects.

This method is ideal for creating connections between layers, but can also be useful 
when a large number of closely-spaced objects exist on a single layer.

You can also open a second Environment window (showing the destination layer), and 
connect the objects graphically between the windows.

A cable connection to another layer looks like this:

To remove a cable connection, do one of the following:
m Click the cable with the Eraser.

m Select the cable and press Backspace. 

m Grab the cable, and plug it back into (drag it over) the triangle of the source object.

m Use Edit > Clear Cables Only to remove all selected cables, without also clearing any 
objects that happen to be selected. 

This is handy when you want to clear all cables leading to (or from) one or more 
objects, given that selecting objects also selects all associated cable connections.

Making Multiple Cable Connections
There is no limit to the number of cables that you can plug in to a destination object. 
All MIDI signals are mixed at the object’s input.

To make multiple output connections from an object:
1 Connect the object to the desired destination object, following one of the two 

methods outlined above. 
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Once an output from an object is used (cabled to another object), another output 
triangle automatically appears. 

2 Use the second output triangle to create a second cable connection to a further 
destination object. 

Once this is done, a third output triangle will appear, and so on.

Some objects have special outputs, and are exceptions to this rule. This includes 
channel splitters (see “Channel Splitter Object” on page 896), which features several—
functionally different—outputs. Other special objects include cable switchers (see 
“Cable Switchers” on page 929) and the Physical Input object (see “Physical Input and 
Sequencer Input Objects” on page 911). In these objects, each output can only be used 
once. 

To route the signal of the special output objects outlined above to several 
destinations:

1 Create a monitor object (see “Monitor Object” on page 896) by choosing New > 
Monitor. 

2 Plug the cable from the desired object output into the monitor object. 

3 Cable from the monitor object to as many other destinations as you’d like. 

The monitor object allows you to view the MIDI events flowing through it.

To select a common destination for several existing cables:
1 Select the cables. 

∏ Tip:  If the cables are already connected to a common destination, the simplest way of 
doing this is to select the destination object.
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2 Next, grab one of the cables and plug it into the new destination object. 

The following dialog is shown:

3 Click Connect, or press Enter.

Cabling Serially and in Parallel
You can cable objects in series or in parallel. Cabling objects in series is handy for 
quickly connecting groups of faders used to control a MIDI mixing console, for 
example.

To cable a group of objects serially:
m Select all objects you want to cable, then choose Options > Cable serially. 

The objects will be cabled in series, starting with the top-left object.

To cable a group of the same type of object (transformers, faders, and so on) to a 
common destination:

1 Cable one of the source objects to the destination. 

2 Select the destination object and choose Edit > Copy. 

3 Select the other objects that you want to connect to the same destination, and choose 
Options > Apply Buffer Template to > Cable(s).

You can copy more complex cabling configurations this way, too. Just ensure that the 
type(s) of objects in the group that you wish to copy matches the type(s) of objects in 
the group that you apply the buffer template to.
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Common Environment Object Parameters
Each Environment object has several parameters that control its operation. These 
parameters can be viewed and changed in the Object Parameter box, shown in the 
Inspector when an object is selected. 

The Object Parameter box also appears in the Arrange window Inspector when you 
select a track assigned to the object. These are the same parameters—changes in one 
location will be reflected in the other. There is one type of object, however, that differs 
slightly in this regard:  the audio channel strip.

A cut down Object Parameter box is shown for audio channel strips when displayed in 
the Arrange window. The full parameter set for these objects is only available in the 
Mixer layer of the Environment window. The differences are as follows:
Â Icon checkbox is removed.
Â Device menu function is removed (display only).
Â Channel is renamed to Type/#:  The menu function is removed (display only).
Â Show EQs:  Removed (always displayed in Arrange channel strips).
Â Show Inserts:  Removed (always displayed in Arrange channel strips).
Â Show Sends:  Removed (always displayed in Arrange channel strips).
Â Show I/O:  Removed (always displayed in Arrange channel strips).

There are two main reasons why the Arrange and Environment representations of 
audio channnel strips differ:  to save onscreen space, and to provide the tools you need 
for music creation, rather than setup tasks. 

This separation is made even clearer—for all audio, instrument, and external MIDI 
channels—by the use of two terms throughout the manual:
Â Track Parameter box (in the Arrange window, to illustrate that the channel is 

controlling the corresponding track).
Â Object Parameter box (in the Environment, where you are interacting with the 

underlying object).

Object Parameter box
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Opening and Closing the Object Parameter Box
By clicking the triangle at the top left, you can hide all parameters except the object 
name and type. This reduces the box to its minimum vertical size.

You can also hide or show the Inspector by choosing View > Inspector (default key 
command:  I).

Common Parameters
The following parameters are shared by all object types:

Name
The name of the object is shown next to the triangle, and can be selected for editing 
by clicking on it. You can also edit the name by clicking directly on the object with the 
Text tool.

Object Type
The object type is shown in brackets, and cannot be edited.

Display Filter for the Track Assignment Menu
Turn on the checkbox beside Icon to make the object visible in the Arrange area’s Track 
Assignment menu (see “Assigning Tracks to Environment Objects” on page 194). This is 
obviously useful for instrument objects, but can also be handy for other objects such as 
arpeggiators, touch tracks, and chord memorizers.

Once made visible, you can Control-click an Arrange track, and reassign the track to 
one of these objects. The object, in turn, can be routed into an instrument channel, for 
example.

The upshot of this, is that selecting an arpeggiator object (routed into a software 
instrument channel) in the track list, results in a real time arpeggiation of the 
instrument sound when you play chords on your keyboard while Logic Pro is running.

Objects not in the Track Assignment menu can still be assigned to tracks by dragging 
them from the Environment onto the track list, or by using the Environment’s MIDI Thru 
tool.

If you move a multi instrument object into the track list, the selected sub-channel is set 
as the track instrument. If no sub-channel is selected, all initialized (sub-channels that 
are not crossed out) sub-channels are set for the destination track, and the tracks 
below that. If there are no tracks below the destination track, new tracks are 
automatically created and assigned to sub-channels of the multi instrument object.

If the checkbox is not active, the object and its icon will still appear in the Environment. 
You should only activate the icon checkbox if the object will be used as a track 
destination.
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Icon 
Click the icon in the Object Parameter box to choose an icon to represent the object in 
the Environment and Arrange window track list.

Exchanging Environments
One of the main advantages of the Environment is the ability to customize Logic Pro to 
fully control your MIDI studio. This can, however, present a problem when sharing 
projects with other musicians, or using different studio setups. 

It also presents a problem when you return to older projects after you’ve changed your 
studio. Logic Pro offers several functions to make these transitions as easy as possible.

Whenever you want to exchange Environments between projects, there is a source 
project containing the desired Environment, and a destination project with an 
Environment that you want to change. 

The destination Environment must be in memory, and must be the active project (one 
of its windows must be active). The source project can also be in memory, or it can be a 
file on your hard drive (or any other media). 
Â If there are two projects in memory, Logic Pro will assume the active project is the 

destination, and the other project is the source. 
Â If there are more than two projects in memory, Logic Pro will assume the active 

project is the destination, and the most recently active of the other projects is the 
source. 

Â If there is only one project in memory, Logic Pro will launch an Open dialog, allowing 
you to select the source project when importing an Environment.

Importing, Replacing, and Swapping Environments
This section covers the different types of Environment import procedures that can be 
performed in Logic Pro.

Importing Single Purpose Environments
A single purpose Environment patch might be an editor for a specific piece of MIDI 
equipment, an Environment for a single MIDI processing task (such as a MIDI LFO), or a 
complex arpeggiator/delay line configuration. 

To import an Environment patch contained on a single layer:
1 Choose Options > Import Environment > Layer.

2 Choose the desired layer in the dialog that appears. 

This layer—inclusive of all objects on the layer—will be inserted in the destination 
project, at the same layer position (the same place in the Layer pop-up menu) that it 
occupied in the source project. Any existing layers will be shifted as needed.
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You can also move selections of Environment objects (inclusive of cabling) between 
projects by dragging or copy and pasting. This is made even simpler by first combining 
the objects into a macro.

To import an Environment patch that is spread across several Environment layers:
m Choose Options > Import Environment > Merge. 

All Environment objects from the source project will be added to the Environment of 
the destination project. 

One thing to watch out for here is that merged objects will be placed on the same 
layer as their source, which can create a mess if objects already occupy that layer in the 
destination project. 

To avoid this issue, create blank layers (in the destination project) at the same layer 
positions of the source project, before importing.

Something to be careful of in both cases, is the treatment of unique objects in the 
Environment, including the Physical Input and Sequencer Input objects. If imported, 
they will replace their counterparts in the destination Environment and any cables 
leading into them will be lost. 

It is best to temporarily delete these from the source Environment, before importing.

Another thing to be aware of is that when you import an object, all objects cabled 
from the imported object are also imported.

Replacing an Older Environment With a Current One
If you have only added things to the Environment, but not deleted anything, you can 
update older projects by choosing Options > Import Environment > Update. 
Only the new objects will be imported—the older objects (along with their cabling and 
track assignments) will remain in place.

Swapping Environments
In the complex situation where you want to swap the Environment of one MIDI setup 
with the Environment of another, Logic Pro offers three options:
Â Replace by Port MIDI/Channel:  This option replaces all objects in the destination 

project with objects that address the same port and MIDI channel in the source 
project. 

Â Replace by Name:  This option replaces all objects in the destination project with 
objects of the same name in the source project. This affords you some degree of 
control, by renaming objects in the source project accordingly.

Â Total Replace:  This completely replaces the destination project’s Environment with 
the source project’s Environment. If you use this option, you’ll have plenty of work to 
do, including reassigning Arrange window tracks to objects, but sometimes it’s the 
only way!
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Note:  This complex task involves a lot of guess work on Logic Pro’s part, and the results 
almost always require some manual fine tuning on your part.

Replacement by Assignment
The most flexible (and most time consuming) method of exchanging Environments is 
to manually choose whether each Environment object is kept, deleted, or replaced. If 
you choose to replace an object, you must also define the replacement object. This 
method is accessed via Options > Import Environment > Custom.

When you select custom import, an Environment window listing all objects in the 
destination Environment is shown in a column on the left, and the chosen action for 
each object is shown in a column on the right.

You can assign the replacements one at a time, by clicking on items in the right hand 
list and selecting the desired replacement object from a pop-up menu. This menu 
includes all objects in the track list of the source project.

Alternately, you can select one or more rows in the list, and make a choice from the 
Import menu. In addition to keep and delete, this menu offers several automated 
selection techniques, as described below.

The first Import menu option is Import Environment using current Assignment. No 
importing can take place until you make this selection. The other choices (including the 
pop-menus in the right column) determine how things will be imported.

Import Options
The last two items on the Import menu provide additional options for the import 
process:
Â Import > Copy Layer Names:  The layer names of the source (second) Environment are 

transferred to the current one.
Â Import > Copy selected Objects from 2nd Environment:  All objects selected in the 

source Environment are copied into the destination Environment, even if they don’t 
appear on the assignment list.

Automatic Assignment Functions
The assignment functions described below are immediately applied to all selected rows 
in the import list. The assignments appear in the right column, and all rows are then 
deselected.
Â Import > Assign as ‘Keep’:  These objects are unaltered.
Â Import > Assign as ‘Delete’:  These objects are deleted.
Â Import > Assign by Identical:  These objects are assigned to objects from the source 

project that match the type, icon, name, port, and MIDI channel. objects with the 
same Unique ID have priority.
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Logic Pro maintains an internal list of all Environment objects. An object’s position in 
the list is its Unique ID—as long as the object is not deleted, its Unique ID never 
changes.

When objects are deleted, their position in this list becomes available for a new object.

Whenever an object is added to the Environment, it is placed in the first available 
position on the list (if there are no empty positions, it is added to the end of the list). 
Â Import > Assign by Unique ID:  Objects are assigned to objects from the source project 

with the same Unique ID. This option is useful for updating an Environment when 
objects have only been added. 

Â Import > Assign by Port/MIDI Channel:  Objects are replaced by objects with the same 
Port/MIDI channel. If a match can’t be found for an object, an object set to Port 0 and 
the same MIDI channel is assigned. If a match still can’t be found, an object with the 
same MIDI channel is assigned.

Â Import > Assign by Name:  Objects are replaced by objects with the most similar 
name (At least 80% of the name must be the same).

Â Import > Assign by Icon/Name:  as above, except the object icons must also match.

The Environment Objects
This section covers each type of Environment object in detail, outlining what each is 
designed to do, and how to use the parameters of the object.

Standard Instruments
Logic Pro provides standard instrument objects to handle MIDI devices that only use 
one MIDI channel (typically, older synthesizers, MIDI controlled effect units or drum 
machines). Standard instruments transmit MIDI data on a single MIDI channel.

To create a standard instrument, do one of the following:
m Choose New > Instrument (or use the New Standard Instrument key command).
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m Click the Environment background with the Pencil tool.

A standard instrument is created, and its parameters are displayed in the Inspector. 
Here, you can set a number of playback parameters, including program bank and 
number, initial volume and pan, transposition, velocity scaling, and MIDI delay.

Port
Use to set a direct connection to one of your MIDI output ports. Remember that you 
can also directly cable an instrument object to (or from) other Environment objects, 
allowing MIDI processing.

Channel
Sets the MIDI channel for the instrument’s output. If you set this parameter to All, all 
events will be sent with their original channel settings.

Program, Volume, and Pan 
The Program, Volume, and Pan parameters transmit program changes, volume 
controller (#7), and pan controller (#10) data.

No data will be sent until you activate the corresponding checkbox. If the box is already 
activated, any value alterations will be sent immediately, and the values will also be 
sent whenever the track is selected. 
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To the left of the program number, directly to the right of the checkbox, you’ll see the 
Bank Select parameter. If your MIDI sound source recognizes bank select messages 
(check the device manual), you will be able to switch between sound banks. If your 
sound source responds to the standard Bank Select message (Controller #32), you will 
be able to use this parameter directly. If not, you may define your own Bank Select 
commands (see “Defining Custom Bank Selects” on page 887).

Transposition
Defines the number of semitones that all note events will be transposed by, on output. 
Negative values transpose downwards.

Velocity
Allows you to increase or decrease the note on velocities of all note events, by an 
amount between –99 and 99.

Key Limit
The two note values of the Key Limit parameter define a pitch range. All notes outside 
this range will be ignored by the instrument when it plays a MIDI region. In other 
words, this range of notes will not be played.

Vel Limit
The two values of the Vel Lim parameter define a velocity range. All notes with a 
velocity that falls outside this range will not be played by the instrument.

Delay
The Delay parameter causes all MIDI events to be sent early or late. This allows you to 
compensate for any differences in reaction time between your various MIDI devices. 
Use the region Delay parameter (in the Track Parameter box shown in the Arrange) to 
create rhythmic delay effects, as this allows longer delay times.

No Transpose
If the No Transpose parameter is active, all regions on any tracks played by this 
instrument object are protected from transposition. In other words, the transpose 
region parameter is ignored. This is very useful for instruments assigned to drum or 
other samples—mapped across the keyboard on a single MIDI channel—as 
transposition will trigger different sounds (rather than pitches) in these instruments.

No Reset
If the No Reset parameter is active, no reset messages will be sent to the instrument. 
This can be useful if controllers are being used for non-musical purposes, such as when 
using the instrument object for mixer automation tasks. The Logic Pro > Preferences > 
MIDI > Reset Messages settings determine what reset messages are sent. These 
messages are not sent to No Reset instruments.
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Style 
The Style parameter can be set to any of the available staff styles. Whenever a region is 
created on one of the instrument’s tracks, it will be assigned the staff style displayed 
here. If the Auto style is chosen (the default), Logic Pro will pick an appropriate style 
based on the pitch range of the notes in the region. For more information on staff 
styles, see “Working With Staff Styles” on page 741. 

Multi Instruments
A multi instrument is like a collection of 16 standard instruments (see above) in one 
package. 

There is a separate sub-instrument (or sub-channel, if you prefer) that mirrors the 16 
MIDI channels—as indicated by the numbered squares on the multi instrument object. 
Clicking on any of these numbered squares selects the corresponding sub-channel, and 
displays its parameters in the Object (or Track) Parameter box.

Each sub-instrument has a complete set of instrument parameters (identical to those 
outlined in the Standard Instrument section). 

Multi instruments have 15 name banks—each of which can hold 128 preset names. All 
sub-instruments share the 15 banks of program names, and use the same format for 
their bank select message. All sub-instruments of a multi instrument use the same 
output port.

You will generally use multi instrument objects to address multi-timbral hardware 
synthesizers or samplers. A multi-timbral sound module is one that can receive on 
several MIDI channels at once—playing back a different sound on each channel. 

As most modern MIDI devices are multi-timbral, the multi instrument will probably be 
the most commonly used instrument object in your Environment.
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To create a new multi instrument object:
m Choose New > Multi Instrument (or use the New Multi Instrument key command).

The Multi Instrument’s Parameter Box
The multi instrument parameters are, as mentioned, identical to those of the standard 
instrument object (see “Standard Instruments” on page 880). The settings you make 
here apply globally to all sub-channels.

To view the multi instrument’s Parameter box:
m Click the icon or name field at the top of the multi instrument object.

This selects the whole multi instrument object, allowing you to set the Port parameter, 
for example.

Activating and Selecting Sub-Instruments
To select a sub-instrument (to address a specific MIDI channel number within the multi 
instrument), click the appropriately numbered square (button) on the multi instrument 
object. The first time you click it, the sub-instrument is activated, making it available in 
the Track Assignment menu of the Arrange track list (accessed by Control-clicking a 
track). To avoid menu clutter, you should only activate as many sub-instruments as you 
actually need, or the external MIDI device supports.

As with any other Environment object, you can remove sub-instruments from the Track 
Assignment menu, by deactivating the Icon checkbox in the Object Parameter box. The 
button for the sub-instrument channel will be shown with a diagonal line through it 
when deactivated.

In the above screenshot, sub-instrument 1 is selected, sub-instruments 1 to 8 are 
activated, and sub-instruments 9 to 16 have been removed from the Track Assignment 
menu.

Note:  If you want to select the entire multi instrument (to reassign the Port parameter, 
for example), rather than a particular sub-instrument channel, click the top edge (icon) 
or name field of the multi instrument object.
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The Sub-Instrument’s Parameter Box
The sub-instrument parameters are the same as those of standard instrument objects 
(see “Standard Instruments” on page 880). The only parameter you can not change is 
the MIDI channel.

If you try to change the channel, you’ll see the following warning:

You can, however, change the channel in the Arrange window’s Track Parameter box to 
any sub-instrument of the multi instrument, and the track will be assigned to the 
selected sub-instrument. This allows you to redirect the (regions on the) track to 
another sub-instrument, making it easy to play multiple parts with a particular 
channel/sound.

Note:  If you change the Output port parameter of any sub-instrument, this will affect 
the entire multi instrument and all other sub-instruments. 

Cabling Directly to a Sub-Instrument
To connect the output of an Environment object directly to the input of a sub-
instrument, Option-click the source object’s output triangle and choose the sub-
instrument in the Track Assignment menu (see “Cabling” on page 871). 

Note:  You can not drag a cable to a sub-instrument. Any dragged cables can only be 
connected to the entire multi instrument object, not one of its sub-instrument 
channels.

Using the Multi Instrument Window
Double-clicking a multi instrument opens the Multi Instrument window:

Device Name and Short Name
At the top left, under Device Name, you can enter the full name of the multi 
instrument. Directly below, under Short Device Name, you can also enter a short name. 
This short name is used in the Arrange window track list, when the program name is 
displayed. 
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Depending on whether or not you have activated the sub-instrument’s Program 
parameter, the following information will appear in the Arrange area’s track list:
Â The name of the multi instrument and channel number (if the parameter is not 

activated).
Â The short name, channel number, and program name (if the parameter is activated).

Program Names
There are 128 program names in the Multi Instrument window. A total of 15 banks of 
128 program names are available. There are several ways of entering program names:
Â By double-clicking on the name (via the text input field).
Â By copying (via the Clipboard) from a different multi instrument, or from a word 

processing program. The Clipboard functions for a whole sound bank are available in 
the Options pop-up menu. 
Â First, copy the program numbers or General MIDI names to the Clipboard, and add 

them to a word processor document. 
Â You can then edit the names and copy the whole section back again.

Â If you want to use program numbers instead of names, choose Init Names as 
Numbers from the Options menu.

Â If you want to use General MIDI program names, choose Init General MIDI Names. If 
the Use GM Drum Program Names for Channel 10 checkbox at the bottom of the 
window is activated, the standard GM drum set names will be shown in the Program 
menu of the Parameter box for sub-instrument 10.

If the Program box in the selected sub-instrument’s Parameter box is checked, you can 
send a program change message by selecting a program name in the Multi Instrument 
window.

Banks
The Bank pop-up menu allows you to choose one of 15 available sound banks (0 to 14). 
The top item (No Bank specified. Names of Bank 0 used.) can be used if your sound 
generator does not understand bank select messages, or only has 128 sound programs.
Â Bank 0 is always initialized. 
Â The first time you choose one of the banks numbered 1 to 14, you will be asked 

whether or not you want to initialize this bank. 
Â Non-initialized banks use the names of the equivalent program numbers from 

bank 0.

Note:  You should only initialize additional banks if you want to enter program names 
for those banks, because each initialized bank uses more memory.

In the pop-up menu to the right, labeled Bank Message, you can define the MIDI events 
that are sent when you switch between the banks of the multi-instrument. 
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Different bank select formats are used by different MIDI instrument manufacturers—
please consult your MIDI instrument’s manual to see whether or not it supports bank 
select messages, and if so, what format it uses. 

With modern synths, there’s a good chance the format will match one of the top items 
in the menu:  either controller# 32 or controller# 0. There are also presets to 
accommodate several of the more common types of synth. If your synth doesn’t use 
one of the formats listed, see the following section on defining your own bank select 
commands.

Defining Custom Bank Selects
Logic Pro provides 15 bank numbers (0 to 14) for each standard instrument, multi 
instrument (including sub-instruments), or mapped instrument object. You can create 
custom lists, consisting of as many events (of any kind, even SysEx) as you wish—for 
each of these banks. 

Whenever you change the bank manually, or send a standard bank change message 
from Logic Pro, the entire list for that bank will be transmitted to your sound module.

To set up custom bank select messages:
1 Select the instrument you want to define bank select messages for. 

2 Choose Options > Define Custom Bank Messages. 

A window similar to the Event List will open, with a single, default, bank select message 
for banks 0 to 15. (The default used is a MIDI controller #0 message, with a value equal 
to the bank number).
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You can create MIDI events here as you would in the Event List, by cutting, copying, 
inserting, and editing (see Chapter 18, “Editing MIDI Events in the Event List,” on 
page 437). The only difference is that you enter the desired bank number, rather than a 
time position.

The letter in parentheses next to the bank number allows you to control the order of 
transmission, when a bank select requires more than one message.

If there are no events defined for a particular bank, a standard bank select message will 
be sent for that bank.

For bank messages that need a channel (MIDI controller messages, for example), the 
channel of the instrument is used. This feature is especially useful for multi instruments, 
as you only need to create one set of bank messages for all 16 sub-instruments. If an 
instrument’s channel is set to All, channel 1 is used. 

Note:  The custom bank select information becomes part of the instrument, and is 
automatically copied with it, should you replicate the instrument object.

Mapped Instruments
This instrument is particularly useful for drum instruments or any drum-mode MIDI 
device. A drum-mode device has different sounds assigned to different MIDI notes, but 
only uses a single MIDI channel. As examples, a drum kit loaded into the EXS24 mkII, or 
MIDI channel 10 of a GM-compliant sound module, or a drum machine.

To create a new mapped instrument:
m Choose New > Mapped Instrument (or use the New Mapped Instrument key 

command).

A mapped instrument is used just like a standard instrument, but each individual input 
note can be:
Â Named (snare, hi hat, and so on)
Â Mapped to an output note 
Â Given a velocity offset
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Â Assigned its own MIDI channel
Â Sent to one of up to 16 output cables (this allows you to create a single instrument 

that addresses multiple sound sources).
Â Given its own notation parameters:  note head shape, relative vertical position in the 

staff, and drum group assignment (see “Drum Notation With Mapped Staff Styles” on 
page 758.

The Mapped Instrument’s Parameter Box
The mapped instrument’s parameters are a subset of the standard instrument (see 
“Standard Instruments” on page 880) parameters. The missing settings are available on 
a note-by-note basis in the Mapped Instrument window.

Using the Mapped Instrument Window
To open the Mapped Instrument window, double-click on the mapped instrument icon. 
The rows correspond to input notes, and the columns contain the various parameters 
available for each note. The window is automatically opened when creating a new 
mapped instrument.

Keyboard (Selecting Notes)
The keyboard on the left represents the input notes. It can be played by clicking on it. 
You can also select individual notes or note ranges, by dragging the mouse over the 
notes you want to use. To select multiple notes, Shift-click on them. Any value 
alterations will apply to all selected notes.

Input Name
In the first column, you can click on the input note name (E6, for example), and type in 
a name of up to 12 characters. Press Return or click outside the text entry field to 
confirm the new name.

You can initialize the names of the selected notes to:
Â Pitch descriptions (C#3, for example) by choosing Initialize > Names as Notes.
Â The names of GM Standard drum sounds by choosing Initialize > Names as General 

MIDI.
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If a MIDI region (on a track routed to a mapped instrument object) is displayed in the 
Piano Roll Editor, the names of the notes being played will appear on the vertical 
keyboard.

Output Note
This column is used to set the output note. This is done by either:
Â Double-clicking on the note description and editing the text
Â Dragging the beam to the right of the output note name. 

MIDI notes are sent while changing the value, allowing you to hear what you’re doing.

Use the Initialize > Output Notes command to match the output notes of the selected 
pitches to the input note pitches.

Velocity
Used to set a velocity offset which is added to, or subtracted from, the velocity of the 
incoming note. Click-hold the number and drag the mouse up or down to create a 
velocity offset. You can also click the desired point on the beam. 

Initialize > Output Velocities resets all velocity offsets to 0 (no offset).

Channel
Sets the MIDI channel of individual notes. This allows you to play individual sounds 
from different drum sets in the same sound generator. 

You will normally use the Base setting. This means that the notes are sent on the 
channel set in the mapped instrument’s Parameter box. If you choose All in the 
Parameter box, the channel information of the incoming notes is used. This is useful if 
you want to place the mapped instrument after a multi instrument or standard 
instrument in the signal path. 

To set all selected notes to Base, choose Initialize > Output Channels. 
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Cabling Mapped Instruments
You can send individual notes from a mapped instrument object to (up to) 16 different 
output cables, enabling you to play sounds from different sound sources. If you select a 
cable that doesn’t exist, the note will not be sent out. 

Initialize > Output Cables resets all cables to #1 (the top outlet of the Mapped 
Instrument).

Notation Parameters
The last three columns define the notation parameters of individual notes. 
Â Head:  This pop-up menu allows you to change the note head.
Â Rel. Pos:  This field is used to alter the relative position of the note on the staff. This 

does not alter the pitch, only the vertical positioning of the note head on a staff in 
the Score Editor. Simply click-hold and drag vertically to alter the note position.

Â Group:  As the mapped instrument object is typically used for percussion 
instruments, click-holding the Group field opens a menu of grouped drum families:  
Kick, Snare, and so on. MIDI sound modules can have drum sounds mapped across 
127 possible notes, which would result in an interesting staff (to say the least!). Assign 
several related percussion sounds (tom drums, for example) to the Toms group to 
place all related sounds on a single staff line. As with the relative position, the pitch 
of grouped notes is not affected by grouping them on a single line.

Choosing Initialize > Score Parameters neutralizes the settings of the Head, RelPos., and 
Group parameters.
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GM Mixer
The GM mixer is a collection of 16 fader modules, configured to emulate a virtual 
mixing desk for 16 MIDI channels. Each module has controls for volume, mute, preset, 
bank, and four assignable knobs (one of which is typically used for pan). There are 
optional controls for standard XG and GS effects. 

To create a new GM mixer:
m Choose New > GM Mixer. 

The GM mixer is intended for controlling the 16 channels of a MIDI device which 
conforms to the GM, XG, or GS standard. This includes the GM set of 128 program 
names (with variation banks for XG or GS), MSB/LSB bank select messages, and 
standard controller names (#1 for mod wheel, #2 for breath, #7 for volume, #10 for pan, 
#11 for expression, and so on).

The Parameter Box of the GM Mixer
Most of the GM mixer’s set up is done in the mixer itself, but there are also a few 
parameters in its Parameter box. 

Port and Channel 
Like the instrument and multi instrument objects, the GM mixer can also have a direct 
MIDI output connection. It is set with the Port parameter. 

The Channel parameter determines the channel number of the lowest GM mixer 
module. You can use this (coupled with resizing the GM mixer) to create sub-mixers for 
any continuous string of MIDI channels (1 to 4, for example). 



Chapter 39    Working in the Environment 893

Legend
The Legend parameter switches the display of the legend along the left edge of the 
GM Mixer on and off. 

The Legend not only indicates what the rows of controls do, it is used to set the 
function of the top four rows of knobs. After the GM mixer is set up, you can hide the 
legend to save space.

Bank
The Bank parameter hides or shows the bank MSB/LSB display at the bottom of the GM 
mixer. You can save space by hiding the bank display, unless you need to select 
program banks numerically.

Working With the GM Mixer Channel Strips
The MIDI channel strips work as a remote control for the mixing parameters of the 
controlled sound modules and synthesizers (volume and pan, for example). 

Choosing a Program or Bank
If your sound source understands bank select events, you can choose the bank number 
with the Bank parameter field at the bottom of each channel strip (only visible if Bank 
parameter in Object Parameter box is enabled). Please remember that not all 
synthesizers support bank select events. You can use several different bank select 
formats (see “Defining Custom Bank Selects” on page 887). 

The Program button allows you to select a sound by name—click it to open a menu 
that contains all GM sound name. Each channel has its own menu.
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Adjusting the Level of a Channel
The Level fader controls the output level of a MIDI channel. Adjusting it sends 
controller 7 via your MIDI interface.

To adjust the output level of a channel:
m Drag the Level fader up or down. 

Muting a Channel
The Mute button switches the volume of the channel between zero and the current 
Level fader position. In practice, this means that if the button is down, the channel is 
muted. If you switch the Mute button off, the current Level fader position (and value) is 
used.

To mute or unmute a channel:
m Click the Mute button of the desired channel.

Assigning the Knobs to Controllers
You can assign any controller to each of the knobs.

To assign a controller to one of the knobs:
1 Click on the label next to the knob.

2 Choose the desired controller from the menu.

Extended GM, GS, and XG Functions
In addition to the GM Standard, there are extended standards created by Roland (GS) 
and Yamaha (XG).

GS and XG mode allow you to select different effect programs, and to control the level 
of the reverb and chorus effects.

To display the GS or XG effects:
m Choose the GS or XG setting in the menu in the mixer’s lower right corner.

The GS/XG configuration control is displayed on the right side of the Mixer, allowing 
you to select different effect programs.

To configure GS or XG effects:
1 Choose the desired standard in the first menu. 

Depending on your selection, the controllers for the extended effects will appear.

2 Select the desired reverb or chorus effect from the second menu. 

3 Program the desired reverb or delay time (Time parameter).

Reseting All Controllers
The Reset button transmits a GS On or XG On command, and resets all controllers to 
neutral positions. This allows you to reset all connected sound modules to their 
standard settings, and begin a mix from scratch. 
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MMC Record Buttons
The MMC record buttons object allows you to control the record enable status of 
external MMC-compatible recording devices (see “MIDI Machine Control” on page 844).

To create an MMC record buttons object:
m Choose New > MMC Record buttons.

Resizing the object allows you to determine the layout and number of track record 
buttons.

Enable the Extra checkbox in the Parameter box to display the “V TC A1 A2” extra tracks:
Â V for Video
Â TC for Time code 
Â A1 for Aux Track 1 (or A) 
Â A2 for Aux Track 2 (or B)

Keyboard
You can use a keyboard object to create notes with the mouse. A keyboard object also 
displays all notes passing through it. In this sense, you can think of it as a real time, 
MIDI note-on monitor. Although you can record the output of the keyboard in 
Logic Pro, its main purpose is for testing and monitoring in the Environment.

To create a keyboard object:
m Choose New > Keyboard (or use the New Keyboard key command).

Apart from the Icon parameter, you can also set the following in the Object Parameter 
box:
Â MIDI channel
Â Velocity:  Determines a fixed velocity value for all notes.
Â Lowest:  Defines the octave of the lowest note on the keyboard object. You can resize 

the keyboard to control its range above the lowest note.
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Monitor Object
A monitor objects displays all events (MIDI and meta) passing through it. It remembers 
the last 32 events, with the newest events shown at the bottom of the list. You can 
resize it to show from 1 to 32 events. Clicking anywhere in the body of the monitor 
clears all events.

To create a monitor object:
m Choose New > Monitor (or use the New Monitor key command). 

Monitors are very handy as both testing and branching devices. When coupled with 
objects that have functionally different outputs (channel splitters and mapped 
instruments, for example), monitor objects can be used to attach more than one 
output cable to the same function.

Channel Splitter Object
A channel splitter routes MIDI events by channel. Every MIDI event received at the 
channel splitter input is automatically routed to the output that corresponds to its MIDI 
channel. 

If no cable is connected to the corresponding output channel, the event is re-routed to 
the SUM output (at the top). 

To create a new channel splitter object:
m Choose New > Channel Splitter (or use the New Channel Splitter key command). 
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Arpeggiator
An arpeggiator object turns chords into arpeggios. It plays the currently held notes—
individually—in a selectable pattern (up, down, random, and so on), and at a selectable 
speed that ranges between whole-notes and 768th-notes.

To create a new arpeggiator:
m Choose New > Arpeggiator (or use the New Arpeggiator key command. 

An arpeggiator features parameters for direction, velocity, speed (Resolution), note 
length, start quantize (Snap), repeats, octaves, and velocity offset (Crescendo). All 
parameters can be MIDI controlled in real time, which adds immensely to its versatility.

To use an arpeggiator object, you must place it in the MIDI signal path, and Logic Pro 
must be running. (For technical reasons, the arpeggiator resets on cycle jumps). 

Typically, you would assign an arpeggiator to an Arrange track, and cable its output to 
an instrument. You can, of course, insert it where needed in the MIDI signal path. 

Once set up, you can use the arpeggiator with live MIDI input, or for MIDI region 
playback. You can also record the output of the arpeggiator by cabling it into the 
Sequencer Input object. 

If you do this, be sure you either record to a no output track, or break the arpeggiator’s 
connection to a MIDI output. 

The Arpeggiator’s Parameter Box 
The Parameter box of an arpeggiator contains the following parameters:

Direction
Determines the direction of the arpeggiated chord. You can choose between the 
following settings:
Â Up:  Lowest note to highest note.
Â Down:  Highest note to lowest note.
Â Up/Down:  Up and down—highest and lowest notes repeat.
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Â Auto:  Up or down, depending on whether the second chord note arrived before, or 
after, the first chord note.

Â Up/Down2:  Up and down—highest and lowest notes don’t repeat.
Â Random:  Notes play in random order.
Â All:  All notes play at once (useful when Repeat is on).

Velocity
Determines the velocity values of the arpeggiated notes. You can choose between the 
following settings:
Â 1 to 127:  Fixed velocities
Â Original:  The velocities of the recorded notes are retained.
Â Random:  Random velocities between 1 and the original value.

Key Limit
This is where you can define the pitch range for the chord arpeggiation. Any chord 
notes outside this range are passed directly to the output. This is useful when you want 
to solo above, or play a bass line below an arpeggiated chord.

Resolution
This is where you set the rhythmic note value (the speed in note divisions) of the 
arpeggio. The None setting deactivates the arpeggiator.

Length
This is where you define the length of the arpeggiated notes. The Original setting 
retains the lengths of incoming (or recorded) notes.

Snap To
Unless this value is set to None, the arpeggiator will wait for Logic Pro to reach the next 
indicated note division before starting the arpeggio. This is useful for rhythmically 
synchronizing the arpeggio with other MIDI data.

Repeat 
Enabling this option continues the arpeggio for as long as the chord is held down. If 
the option is disabled, the arpeggio will only play through once.

Octaves 
The arpeggio can be repeated over 1 to 10 octaves.

Crescendo
The velocity value set here is added every time the arpeggio is repeated (if the Repeat 
parameter is turned on, of course).
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Controller Base
All ten parameters of the arpeggiator object can be remote-controlled with MIDI 
continuous controller events. The Controller Base parameter determines the controller 
number for the first parameter (Direction). The other parameters will be controlled by 
subsequent controller numbers. 

When Controller Base is set to Off, MIDI control of the arpeggiator is disabled.

Transformer Object
You can use a transformer object to select, filter, and alter MIDI events in real time. 

Transformers can also process meta events, as long as they are not the meta events 
that affect transformers. These particular meta events change the transformer, rather 
than being processed by it. For more information, see “Controlling the Condition and 
Operation Values via Meta Events” on page 902.

To create a new transformer object:
m Choose New > Transformer (or use the New Transformer key command). 

How the Transformer Object Works
A transformer object checks whether or not an incoming event matches certain 
conditions. If it does, then certain operations are carried out. 

Events which do not meet the conditions may pass unchanged to the output, or may 
be discarded. 

The transformer can also make copies of matching events before altering them, and 
can split the selected (matching) events from the unselected ones, via its two top 
cables.

You must place the transformer in the MIDI signal path in order to use it. 

If you wish to alter the output of an instrument, for example:
1 Cable the instrument output into the transformer (removing the instrument’s internal 

port assignment in the process). 

2 You will need to create a New > Instrument, and assign it to the desired MIDI output 
port. 
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3 Cable the output of the transformer object into this newly created instrument (which, 
in essence, is simply acting as a MIDI output port.

Configuring a Transformer Object
Double-clicking a transformer icon opens the Transformer window, where you can set 
the conditions and operations. 

Setting the Operation Mode
Use the pop-up menu at the top of the Transformer window, to define how a 
transformer handeles MIDI events. You can choose between the operation modes 
outlined below.

Apply operation and let non-matching events pass thru
MIDI events that match the condition are processed. MIDI events that don’t conform to 
the condition are passed thru. 

Apply operation and filter non-matching events
MIDI events that conform to the condition are processed. MIDI events which do not 
conform to the condition are not passed through.

Filter matching events
All MIDI events which match the condition are filtered out. MIDI events that don’t 
conform to the condition are passed through.
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Copy matching events and apply operation
All MIDI events which conform to the condition are copied, and the copy is processed. 
The original and transformed copy (plus any MIDI events that don’t conform to the 
condition) are passed through. The unchanged original is parsed (processed) before the 
transformed copy.

Copy matching events and apply operation (reverse order)
This is the same as above, except the original is parsed after the processed copy. You 
might want to use this when converting note events to pan controllers, for example. 
This causes the pan message to be sent before the note. (Many synths don’t alter the 
pan position of notes that are currently playing).

Condition splitter (true → top cable)
Events that match the conditions are altered by the operations, and sent to a 
transformer’s top output. Events that don’t match the conditions are sent, unaltered, to 
a transformer’s second output. Do not use the other outputs—as nothing ever appears 
there.

Alternating split
Events entering the transformer will be alternated between the top two outlets. No 
conditions or operations apply.

SysEx mapper (data byte 1 → position, data byte 2 → value)
This transformer mode is used to create and edit SysEx messages. The Transformer 
window operations are replaced by value fields that allow you to enter the structure of 
the SysEX message—including its length, whether or not a checksum is required, and 
the values of bytes you don’t want to change in real time.

In the Conditions area, you select the type of MIDI event that will affect the data bytes 
in the SysEx message. (Typically, you’ll use MIDI controller events.) Incoming MIDI 
events will then change the SysEx message data bytes, according to the following rules:
Â The data byte 1 value sets the position of the data byte.
Â The data byte 2 value sets the value of the data byte.
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Â The channel controls the action to be taken:
Â Channel 1:  The changed SysEx message is sent.
Â Channel 2:  The changed SysEx message is not sent.
Â Channel 3:  The unchanged SysEx message is sent.
Â Channels 4 to 16:  No meaning (reserved for future use).

The “Filter non-matching” checkbox prevents incoming MIDI events (that don’t control 
the SysEx message) from being passed through. Typically, you will want this feature 
turned on, to prevent interloping controller data from invading the SysEx data stream.

Track Automation Splitter (true → to cable)
If the condition matches, incoming events will be sent to the track automation of the 
object connected to the top cable of the transformer—after passing through the 
Operation field. With the appropriate Operation field settings, incoming MIDI data is 
transformed into Fader event data—allowing the automation of any possible 
parameter of the connected Mixer object. Exception:  Channel volume and channel pan 
uses Control events.

Defining Conditions and Operations
The conditions and operations are the same as those found in the Transform window. 
For more information, see “Editing MIDI Events in the Transform Window” on page 465. 
The only differences arise from the fact that a transformer objects work in real time and 
therefore, position and note length have no useful meaning. 

Editing Pitch Bend Events
A transformer object can process 14-bit pitch bend events, which contain two discrete 
data bytes:  If byte 1 is changed (by addition or scaling with the -1- operation), the 
change will also affect the second byte. 

Set the Data Byte 2 operation to Thru to ensure that 14-bit pitch bend data is processed 
properly. 

Controlling the Condition and Operation Values via Meta Events
You can control the values of any transformer conditions or operations by using meta 
events. Meta events are internal Logic Pro messages—their form is similar to MIDI 
controller events, but they have no MIDI meaning, they never leave Logic Pro, and 
control internal Logic Pro parameters. 

Like MIDI controller events, meta events have two data values:  The first one indicates 
the type of meta event (49 to 127, but not all are used), and the second one is the event 
value (0 to 127).

Meta events 122 to 127 affect transformer parameters.
Â Meta event #127 sets the first (top) operation value.
Â Meta event #126 sets the second (bottom) operation value (if available).
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Â Meta event #125 sets the first (top) condition value.
Â Meta event #124 sets the second (bottom) condition value (if available).

Note:  Transformers can also process meta events, as long as they are not the meta 
events listed above. 

Note that all numerical condition and operation parameters that are used (conditions 
not set to All and operations not set to Thru) will be affected by the same meta event. 
The status condition and operation are not affected by meta events. 

If you want to set numerical parameters individually, or leave some fixed, use separate 
transformers in series.
Â Meta event #123 sets the transformer map position. 
Â Meta event #122 sets the transformer map value for the current map position. (Use 

meta event #123 to set the position first).

Note:  You can use a transformer’s Map Set operation to create these two meta events 
simultaneously. When the operation status is set to Map Set, the Data Byte 1 parameter 
specifies the map position, and the Data Byte 2 parameter specifies the map value at 
that position (a meta event #122 is sent with the Data Byte 1 value, followed by a meta 
event #123 with the Data Byte 2 value).

You can create meta events with a fader object; you can transform MIDI events into 
meta events with a transformer, and you can add meta events to a MIDI region from 
the Event List. When you use a fader, set the Output definition to meta, then set the 
Data Byte 1 value to the meta event number. 

You can remote-control any fader by changing its Input definition, allowing you to use 
faders (as well as other transformers) to convert MIDI events to meta events—for 
remote-control of transformers.
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Delay Line Object
A delay line object repeats (echoes) MIDI events passing through it—at intervals 
ranging from one tick to 256 whole notes.

To create a new delay line object:
m Choose New > Delay Line.

As with the arpeggiator, you will need to place a delay line object in the MIDI signal 
path, and Logic Pro must be in play mode. The echoes of each incoming event are 
sent—sequentially—to each cabled output of the delay line object; event 1 to cable 1, 
event 2 to cable 2, and so on. Obviously, if only one cable is connected, then all events 
are sent to this output.

The delay line can send up to 99 repeats, at intervals ranging from one tick to 256 
whole notes. You can also suppress the original note events. 

The Delay Line’s Parameter Box
The delay line’s Parameter box offers the following parameters:

Thru Original
If this parameter is turned on, the original events are passed thru. If the parameter is 
turned off, the original events are suppressed—which means that only the echoes will 
be heard.

Repeats
Defines the number of event repeats. The 0 setting switches the delay line off.

Delay
The delay time between the individual repeats. The left value is in divisions, and the 
right value in ticks.

Transpostion
Defines the transposition of note events per repeat.

Velocity
Defines the change in the velocity values of note events per repeat.
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Voice Limiter Object
A voice limiter object restricts the number of MIDI notes (1 to 32) that can be held 
simultaneously.

It does this by note stealing—newly arriving notes will cause (some of the) currently 
held notes to be turned off, once the voice limit is reached.

To create a new voice limiter:
m Choose New > Voice Limiter (or use the New Voice Limiter key command).

Normally, you will assign a voice limiter to an Arrange track, and cable its output to the 
instrument object that you want to voice limit. Alternately, you could cable it between 
the instrument object that you want to voice limit and an instrument object used to 
represent a MIDI Out port.

Voice Limiter Parameters
The voice limiter’s parameter box offers the following:

Voices
Defines the maximum number of voices that can be played simultaneously.

Priority
This is where you define which notes are stolen (are turned off ) when the number of 
held notes exceeds the limit (determined by the Voices parameter). 
Â Top:  The lowest (pitched) notes are turned off first. 
Â Bottom:  The highest (pitched) notes are turned off first. 
Â Last:  The earliest notes (those played first) are turned off first.
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Chord Memorizer Object
A chord memorizer maps individual notes to chords. You can assign one chord to each 
pitch class (to C, C#, D, and so on).

The octave of the incoming note determines the octave of the resulting chord. A chord 
can have zero to twelve notes in it. (Zero and one note chords can be useful for 
creating scale-filters and scale-correctors).

The easiest way to use a chord memorizer is to connect its output to the instrument 
that you want to play the chords through, and assign it to an Arrange track. You can, of 
course, place it anywhere else in the MIDI signal path.

To create a new chord memorizer:
m Choose New > Chord Memorizer from the local Environment menu (or use the New 

Chord Memorizer key command).

Setting Chord Memorizer Parameters
You can set the following parameters in a chord memorizer’s Object Parameter box:

Channel
All chord notes will be sent to the defined channel.

Key Limit
Notes within this range are mapped to chords. Notes outside the range are passed 
through unaltered. 

Transposition
The output chords are transposed by the amount set here. Example:  If you map C to a 
chord consisting of CEG, and set Transposition to 1, then C will be mapped to C#FG#.

Key
The entire chord map is transposed by the amount set here. Example:  If you map C to 
CEG, and set Key to 1, then C# will be mapped to C#FG#. 

Cable Split
Enable to send all notes triggered by a chord assignment to different chord memorizer 
object outputs (different cables). 
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Working in the Chord Memorizer Window
Double-clicking on a chord memorizer opens the Chord Memorizer window, where you 
can set up chord definitions.

The top keyboard is used to input and display the incoming note, and the lower 
keyboard is used to input and display the assigned chords. Notes can be entered with 
the mouse, or a MIDI keyboard.

Remember to only use notes that fall within the Key Limit range on the top keyboard. 
Also remember that you can only define one chord for each of the 12 pitch classes (C, 
C#, D, and so on). You can, of course, use more than one chord memorizer object to 
define more chord types for each pitch class.

To enter chords with the mouse
1 Click the input note on the top keyboard. 

All notes in the associated chord will be inverted on the bottom keyboard.

2 Click notes on the bottom keyboard until the inverted notes of the desired chord are 
shown. 

You don’t need to stay within the same octave as the input note.

When you have entered the desired notes for your chord, select another input note (on 
the top keyboard), or close the Chord Memorizer window.

To enter chords from your MIDI keyboard:
1 Play the input note.

2 Click the Listen checkbox in the Chord Memorizer window.

The lower keyboard is inverted, indicating its readiness to record.

3 Play the notes of the desired chord. 

You can play them one at a time, or as a chord. If you make a mistake, deactivate the 
Listen checkbox, then activate it again to start over.
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When you’ve entered the desired notes for your chord, deactivate the Listen checkbox 
and play a new input note, or close the Chord Memorizer window.

Touch Tracks Object
A touch tracks object allows you to trigger MIDI regions or folders with single notes. 
This can be used to create a new arrangement in real time, ideal for live performances.

You can not use touch tracks to trigger audio. In the following section, any references 
to regions mean folders and MIDI regions, not audio regions. Despite this limitation, 
you could conceivably load your audio regions (as files) into the EXS24 mkII, and trigger 
it with a touch tracks object.

To create a touch tracks object, do one of the following:
m Drag a MIDI region or folder from the Arrange area into the Environment.

m Choose New > Touch Tracks from the Environment menu. 

To use a touch tracks object, do one of the following
m Assign the touch tracks object to an Arrange track.

m Place the touch tracks object anywhere in the MIDI signal path. 

Here are some things to remember:
Â Only the touch tracks input has meaning—trigger notes must appear here. Although 

the object features an output triangle, it has no use, as events never appear here.
Â MIDI regions and folders triggered by touch tracks play exactly as they would from 

the Arrange window—they play back through the instruments assigned to their 
tracks.

Â Logic Pro must be running for touch tracks to work.
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Using the Touch Tracks Window
You open the Touch Tracks window by double-clicking on a touch tracks object. 

This window is similar to the Mapped Instrument window (see “Mapped Instruments” 
on page 888)—the input note is selected via the keyboard on the left, and the output 
region assignment and parameters are set in the columns of the corresponding row.

A vertical gray line means that the setting is the same as the line above. If you change 
a vertical gray line that is above another vertical gray line, the lower one will change to 
display its previous value (it will no longer be the same as the line above.)

Region Note Assignment
Dragging a MIDI region or folder into the Environment automatically creates a touch 
tracks object. All notes (initially) trigger this region. Middle C plays the region or folder 
at its original pitch, and all other notes transpose it—relative to middle C. 

In the Input Name column, you can see the input notes, and to the right, in the Region/
Folder column, the names of the assigned regions or folders. On the vertical keyboard 
to the left, you can select individual notes or pitch ranges, by dragging across several 
keys. If you then drag a MIDI region or folder from the Arrange window, it will only be 
assigned to the selected note (or note range).

Group
Groups behave as they do in the Hyper Editor—when you trigger a region, any other 
(currently playing) region in the same group will stop.

The Off setting means that the region is not assigned to any group.

Transpos (Transposition)
When you drag a region to a key in the Touch Tracks window, that key triggers the 
region at its original pitch (without transposition). If you want to transpose the region, 
you can set the amount in the Transpos column. 

If a key range is selected when you drag the region into the Touch Tracks window, 
incremental transpositions will automatically be set for adjacent keys (within the key 
range). 
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When you create a touch tracks object by dragging a region into the Environment, C3 
triggers the region at its normal pitch, and all other keys trigger it—transposed relative 
to C3.

Velocity
In the Velocity column, you can set the sensitivity of regions to the velocity value of the 
trigger note:  by 100% (very sensitive), 50% (somewhat sensitive) or off (not velocity 
sensitive).

Trigger Modes
The Trigger column determines how region playback is handled:
Â Multi:  Playing the trigger note starts the region. Playing it again restarts the region, 

without stopping playback of the originally triggered version.
Â Single:  Playing the trigger note once starts the region. Playing it again stops 

playback, and restarts the region.
Â Gate:  The region plays until the trigger note is released (or until the region ends).
Â Gate Loop:  The region loops until the trigger note is released.
Â Toggle:  Playing the trigger note starts the region. Playing it again stops playback.
Â ToggleLoop:  Playing the trigger note starts region looping. Playing it again stops 

playback.

Start
This column allows you to quantize region start and stop. Free means no quantization. 
The Next 1/16, Next 1/4, or Next 1/1 settings start or stop the region at the next 1/16 or 
1/4 note, or at the beginning of the next bar, when a trigger note is played.

Delay
This column allows you to assign a delay to the region start point. The delay is set on 
the right side of the column in ticks, or on the left side in note values.

You can use both Delay and Start to make regions start at any position in the measure. 
As an example:  Set Start to 1/1 and Delay to 480 ticks to commence playback at the 
second 8th note in the measure.
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Physical Input and Sequencer Input Objects
The Physical Input object represents the physical inputs of your MIDI interface; the 
Sequencer Input object represents the MIDI input of Logic Pro. You can only have one 
of each of these objects in the Environment.

To create a Physical Input object:
m Choose New > Physical Input.

To create a Sequencer Input object:
m Choose New > Sequencer Input.

To make use of an existing object, drag it onto the relevant layer. This will not affect its 
cabling.
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Physical Input Object
The Physical Input object receives MIDI signals from the inputs of the MIDI interface(s) 
connected to your computer. This object has a total of 65 outputs.

The outputs follow the input assignment of all connected MIDI interfaces. The top 
output (SUM) carries the MIDI events for all individual outputs that are not cabled 
separately. 

Remote control events are intercepted at the Physical Input object, and are not passed 
through to its outputs. As such, remote control events will not reach the Environment, 
or be recorded on Arrange window tracks. 

Sequencer Input Object
MIDI events arrive at Arrange window tracks thru the Sequencer Input object. If 
nothing is cabled into the Sequencer Input object, nothing can be recorded in 
Logic Pro.

Typically, the Physical Input object is cabled directly to the Sequencer Input object but 
other objects can be inserted between them. Typical candidates are a monitor, 
keyboard, or cable switcher object—feeding various processors such as an arpeggiator, 
a delay line, and so on. 

You can also cable the output of simple or complex Environment processes into the 
Sequencer Input object, in order to record the processed signal.

By default, the Sequencer Input object records on the MIDI channel (or channels) that 
the keyboard or MIDI controller (which is sending the MIDI events) is set to. 

If you activate the Sequencer Input object’s Channelize parameter, the MIDI channel 
assigned to the MIDI object (of the selected Arrange track) is used, and recorded. This 
effectively means that if your keyboard is set to MIDI channel 7, and the Arrange track 
object is set to MIDI channel 3, all incoming data will be channelized to (and recorded 
on) MIDI channel 3.
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MIDI Click Object
The MIDI Click object is used to create note events at bar, beat, and division intervals. 
These can be sent to either a MIDI port or the internal speaker. 

To create a MIDI Click object:
m Choose New > MIDI Metronome Click in the local Environment menu.

Each project can have only one MIDI Click object. You only need to create a MIDI Click 
object if the one that existed when the project was created has been deleted. 

There is a button on the Transport bar that turns the MIDI click on and off.

A Control-click on this button will allow you to open the File > Project Settings > 
Metronome  (see “Metronome Settings” on page 941). In this pane, you can also set the 
MIDI click to play during recording or playback. This dialog mirrors the settings in the 
Parameter box of the MIDI Click object:  Checkboxes for Bar, Beat, and Division allow 
you to generate note events separately for bars, beats, and divisions. The Channel, 
Note, and Velocity parameters define the MIDI channel, note number, and velocity of 
generated notes. The MIDI Port parameter allows you to set a direct output port for the 
metronome.

Internal Objects
Internal objects include instruments located inside your Macintosh (such as software 
synthesizers and other musical applications). Although communication with sound 
sources inside the computer does not actually use MIDI, it still conforms to the MIDI 
communication protocol. 
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Internal objects have an input, but no output. They therefore act like extra output 
ports, which are hard-wired to the relevant sound generator (software instrument or 
application).

Apple QuickTime
The QuickTime system extension offers a software-based GM sound generator. The 
QuickTime Musical Instruments file must be present on your system.

To create a virtual representation of the QuickTime synth:
m Choose New > Internal > Apple QuickTime.

This software synth is 16-part multi-timbral. As usual, you can switch sounds via 
program changes; these are arranged according the GM table. Channel 10 is always set 
to drum sounds, with GM key assignments. The QuickTime synthesizer reacts to notes 
and program change commands, as well as to pitch bend (±2 semitones) and the main 
volume controller (#7).

The first note is used to initialize the relevant MIDI channel of the QuickTime 
synthesizer, and is not played.

ReWire
You can use ReWire objects to send MIDI data to ReWire compatible applications and 
their software instruments. To connect to a ReWire compatible software instrument, 
first open Logic Pro and then the ReWire application. When shutting down, first quit 
the ReWire application, then Logic Pro.

You can use the Library to create ReWire objects automatically (see Chapter , “Working 
With ReWire Applications,” on page 249).

To manually create a ReWire object in the Environment:
m Choose New > Internal > ReWire.

Apart from common parameters, the Rewire object offers three settings:
Â Device:  This setting refers to the ReWire application(s) that Logic Pro can connect to. 

If one or more ReWire applications are running, it will display the names of these 
applications. 
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Â Bus:  Lets you choose the ReWire Bus from all available ReWire busses. If a ReWire 
application provides bus names, they will be shown. If using Reason, the names of 
the instruments available in the Reason Rack will be shown from Bus 6 upwards, in 
place of numbers.

Â Channel:  Sets the MIDI channel of the ReWire object.

Alias
You can create an alias of any Environment object, and it will behave exactly like the 
original. In the case of faders, the alias has its own value—which can be different to the 
value of the original object. This is particularly useful if using text faders, as they 
consume a lot of memory—if you need several text faders of the same name, make 
several aliases of one original object.

To create an alias of any object:
m Select the object, then choose New > Alias.

Aliases can be reassigned with meta events. A special fader, known as the alias assigner 
(which works something like the cable switcher), is used to accomplish this.

To create an alias assigner:
m Choose New > Fader > Specials > Alias Assigner. 

This will create a meta fader, with a -1- definition set to 46.

To use the alias assigner, cable its top output to the alias, and cable subsequent 
outputs to the various originals that you want to assign to the alias. If you set the alias 
assigner’s maximum range to match the number of originals and its minimum range to 
1, you can then connect the next cable to a new alias, and subsequent cables to 
originals for the alias. In this way, the alias assigner can be used to assign multiple 
aliases simultaneously. 
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One situation where you might use an alias assigner is when switching a delay line alias 
between different originals (different delay line objects), each set to different delay 
times. This method is one of several ways to provide MIDI control over delay time.

Alias Parameters
Aliases share the parameters of their parent (original) objects, but they also have their 
own, special parameters:

Reference
The Reference menu is used to select the original on which the alias is based.

Channel
The Channel parameter rechannelizes all events (except fader events) leaving the alias 
to the selected channel. If the Channel setting is All, existing channelized events are 
not changed.

For faders, the Channel parameter causes the alias to act as if the original fader’s Input 
and Output definitions are both set to the specified channel. (An All setting results in 
no change.)

Share Name and Share Size
These two parameters do just what they say—when checked, the alias shares the size 
and name of the original. If unchecked, it can be resized and given its own name.

Copying Aliases
If you copy an alias, you will create a new alias of the same original. If you select and 
copy both an alias and its original, you will create a copy of the original with its own, 
separate alias.

Ornament
Ornaments are simply solid backgrounds behind other Environment objects. An 
ornament never covers other objects, allowing you to continue to select multiple 
objects by rubber-banding them, without selecting the ornament itself.

To create an ornament:
m Choose New > Ornament. 

Macros
Macros are not actually Environment objects. Rather, they are collections of other 
Environment objects and their cabling. 

To create a new macro:
m Select all Environment objects that you wish to include, then choose New > Macro.
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Logic Pro will enclose all selected objects in a frame with a gray background. 

If some of the objects selected when creating a macro have cables leading to 
unselected objects, these cables will be deleted when the macro is created. A warning 
will notify you of this. In this situation, the macro is made from a copy of the original 
selection of objects, and the original collection of objects remains unchanged. 

Macros are limited in size—the limit is dependent on the memory usage of the 
individual objects within the macro. This limit is typically between 100 and 200 objects.

You can nest macros—a macro can contain other macros as objects.

To unpack a macro:
m Double-click any empty (blank) section of the macro object. 

This reverts the macro back into its component objects and cables.

Macros have a lot in common with standard Environment objects—you can connect 
cables to and from them, they can be resized, they have their own parameters and 
icon, they can be chosen as destinations in the Arrange window track list, and they can 
be copied or dragged between Environment layers (including between projects). 

Defining a Macro’s Input and Output
As a macro is a collection of objects, individual objects need to be specified as the 
macro’s input and output. This can be done in two ways:  by name or by default. 
Â If you name one object “Macro-In”, and another “Macro-Out”, these will automatically 

become the macro’s input and output. 
Â If there is no object named “Macro-In”, the upper-leftmost object will become the 

macro’s input. 
Â If there is no object named “Macro-Out” then the lower-rightmost object will become 

the macro’s output. 

Cables leading into the macro deliver events to the macro’s input object, and cables 
leading from the macro’s outlets carry events leaving the macro’s output object.
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Macro Parameters
Macros have the following parameters:

Auto Fader
If you select a group of faders, and create a macro from them, checking this box will 
make them behave as if they were cabled serially.

Show All
This checkbox determines which objects remain visible when integrated into a macro. 
When checked, all objects will be visible (assuming the macro is not resized to hide 
some of them). When unchecked, only fader, monitors, ornament, and keyboard 
objects will be visible. You can change this checkbox at any time.

No Reset
This checkbox, when active, prevents the macro from responding to reset messages 
(set in Preferences > MIDI > Reset Messages).

Protected
Enable to protect a macro. Protected macros can not be unpacked, so ensure that 
you’ve made a copy of the objects and cabling before creating a protected macro.

Faders
Faders are used to send MIDI events by clicking or click-dragging on them. Faders 
come in different forms (knobs, sliders, numerical, and buttons). Fader objects respond 
to incoming MIDI events.

To create a new fader:
m Choose New > Fader. 

A sub-menu appears, where you may select the style of fader you want. There’s also a 
sub-menu at the bottom named Special, used to select various special fader types 
(cable switcher, meta-fader, and so on).

The style of a fader determines its onscreen appearance (slider, knob, menu, numerical), 
and how it responds to the mouse (click and drag, double-click and type a number, 
click, and select from a menu). 

 Horizontal fader
Knob

ButtonVertical fader
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The auto style fader—the default style if you create a fader with a key command—
changes styles as you alter its shape and size. 

The type of fader determines what events the fader sends out and responds to. In two 
cases, however, the fader doesn’t send out events at all:
Â The cable switcher routes events to its different outputs. Clicking on a cable switcher 

object makes it step sequentially through the outputs.
Â The alias assigner changes the references (to an original, or parent object) of fader 

aliases.

In general, a fader’s style is completely independent of its type. A cable switcher can 
look like a button, a knob can send out MIDI or meta or SysEx events, and so on. The 
one exception is the vector style fader—these behave in a special way, by sending out 
two (or four, in special cases) messages at a time, depending on the mouse location 
within their 2-dimensional, vector window.

Don’t worry about selecting the wrong fader style or type from the New menu—you 
have complete control of a fader’s style and type via the Object Parameter box.

Fader Operation
Normally, you’ll grab the surface of a fader, and drag it vertically or horizontally, 
depending on its style. When using the fader itself as a slider, values may jump in larger 
increments, depending on the size of the fader and dragging speed. You can also 
change values in single steps by dragging on the slider or knob while holding down 
Control.

Some of the fader styles have numerical displays. When there is a numerical display, 
you can double-click it, and type in the desired values. When you drag on any of the 
sliders or knobs, the series of values that are sent out depends on the fader size and 
scrolling speed—not every consecutive value is sent out at smaller sizes. If you drag 
slowly on the numerical field, however, you will send consecutive values.

Knobs can be dragged either vertically or horizontally.

Buttons only send two values, the lowest and highest of their range set in the Object 
Parameter box. You change a button’s state by clicking on it.
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The default appearance of the text fader is like a value field that can be scrolled. 
Double-click to open a window that allows you to enter text for each menu position. 
Enable the Behaves as Menu checkbox to use the text fader as a pop-up menu.

A vector fader allows you to scroll in two directions, and sends out two values—one 
corresponding to the vertical position, and the other to the horizontal position.

Working With Object Groups
When building a virtual mixing desk or synthesizer control panel in the Environment, 
you often need to deal with large groups of fader objects which have the same size, 
regular spacing, or a similar definition. 

To save time on the definition and alignment of these groups, you can choose (one or 
more) objects as prototypes (templates) by copying them into the Clipboard (Edit > 
Copy). You may then apply certain characteristics of these template objects to selected 
objects.

To transfer the size of the prototypes to the selected objects:
m Choose Options > Apply Buffer Template to > Size.

To transfer the alignment template of selected objects:
m Choose Options > Apply Buffer Template to > Position.

The selected target objects will be positioned at the top left corner of the Environment 
layer, in accordance with the layout of the template.

The Options > Apply Buffer Template to > Position and Size command combines both 
of the above functions.

Definition
The Options > Apply Buffer Template to > Definition function transfers the parameters 
of a copied template to all selected objects. If several templates of the same type are 
available, the one that is closest in size is used.

The Options > Apply Buffer Template to > “Definition, channel increment” increases the 
channel number from object to object, beginning with the top left object. It is not 
necessary for the selected objects to have the same Input or Output definition as the 
template.

The Options > Apply Buffer Template to > “Definition, number increment” increases the 
first data byte of the definition (controller number, for example).

Cabling Serially
The Options > Cable serially function connects all selected objects in series, beginning 
with the object at the top left.
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Names With Numbers
If you name one object in a selected group of objects with a name that ends in a 
numeral, the remaining objects will adopt the name, but with sequentially increasing 
numbers. As an example:  Selecting several objects and naming one of them “Object 1” 
will result in the ensuing objects being renamed as “Object 2”, “Object 3”, “Object 4”, and 
so on.

Special Functions
This section outlines several behaviors and commands that enhance the use of fader 
objects.

Temporarily Grouping Faders
If you (rubber-band, or Shift-click) select several faders, and move one of them, all 
selected faders will move proportionately. 

As long as all faders remain selected, their relative positions will be retained (even after 
one or more of the faders has reached its minimum or maximum position).
Â Option-dragging any fader in the group changes all values in a linear fashion (the 

absolute value differences are maintained).
Â Shift-Option-dragging any fader in the group changes all faders to the same value.

Sending Fader Values
You can use Options > Send All Fader Values (or the corresponding key command) to 
make all fader objects send their current values.

Use Options > Send Selected Fader Values (or the corresponding key command) to 
make all selected fader objects send their current values. 

Use of these commands in conjunction with the Record/Pause mode allows you to 
record a snapshot of all current fader positions. This is especially useful for virtual 
mixing desks, or synthesizer panels. 

The File > Project Settings > MIDI > General > “Send After Loading Project: All fader 
values” option automatically sends all fader values after a project is loaded.

Resetting Fader Values
Choose Options > Reset Selected Faders to set all selected fader values to zero, and 
transmit this data.
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Recording and Playback of Fader Movements
As with the channel strips in the Mixer, you can record fader object movements to 
tracks, and play them back. 

Recording Fader Movements
You don’t need any special cabling to record the data generated by a fader. All data 
generated by faders is recorded on the selected track when Logic Pro is in record or 
record/pause mode. 

Playing Back Fader Movements
Any fader will react to incoming events that match its Input definition. The fader must, 
of course, be in the MIDI signal path. 

Typically, you would accomplish this by cabling the track instrument into the fader. 

For fader object automation tasks, however, it is useful to create a new (standard) 
instrument for the sole purpose of fader automation. Ensure that the instrument:
Â Has no direct MIDI output.
Â Uses the Channel setting All.
Â Is connected to the first fader in any chain of serially-cabled faders (if cabled this 

way).

Fader Styles
The fader’s style is shown in the line under the icon. It can be changed by clicking on 
the current style name, and selecting the new style from the pop-up menu.

Remember that a fader’s style does not usually affect its function—you can select the 
most convenient style for the desired use of the object.

The following section provides notes on some of the fader styles.

Vertical/Mute
This is exactly like the Vertical 4 fader style, with an added mute button.

When you click the mute button, the fader sends an event (with a value of 0) that 
matches the Output definition. 
Â The fader’s movements are not sent while the mute button is on. 
Â The current fader value is sent when you turn the mute switch off. 
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Buttons
Button style faders can only send two possible values:  the minimum and maximum 
values of their range. 

Â When on, the maximum value is sent. 
Â When off, the minimum value is sent. 

If the minimum and maximum range parameters are set to the same value, the button 
sends this value each time it is clicked. 

Text
Text faders function like numerical faders, but can display text for each of the 128 
possible MIDI values (0 to 127). Double-clicking on the surface of a text fader opens the 
Text Fader window.

Â Clicking on a position in this window will cause the corresponding fader value to be 
sent. (This is similar to selecting programs by name in the Multi Instrument window).

Â Double-click on a position in the window to type in the desired text. By default 
(when you create a text style fader), the text positions contain numerical values. You 
can use this feature to create numerical style faders with colored backgrounds.

Clipboard Functions
The Options menu at the top right of the Text Fader window provides Cut, Copy, and 
Paste functions. You can use these facilities to transfer the entire list of names to a text 
editor, for more convenient editing. 
Â Empty lines (and lines that only contain spaces) are ignored. 
Â If you want to insert blank positions in the list, use Option–Space bar.

Behave as Menu
Click the Behave as Menu checkbox to make the text fader act like a pop-up menu. 
When this box is unchecked, the text fader acts like a scrolling menu.
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Text Fader Range
The Range parameter determines the number of names that can be entered into a text 
style fader object. If you set a text style fader’s range to 0, 1 you can only enter two 
values. 

You should always set the minimum necessary range for a text fader, as this saves 
memory. In any case, remember that the first name corresponds to the lowest value in 
the range (not necessarily 0), and the last name corresponds to the highest value (not 
necessarily 127).

If you force a text fader to a value outside its range (with MIDI input) it will display “---” 
for values below its range and “+++” for values above. The one exception is when the 
fader’s range is 0/1:  In this case, all values above 1 will display the name for value 1.

Fader Functions:  MIDI Events
Each fader has an Input and an Output definition. 
Â The Input definition determines the types of MIDI events that can remote control the 

fader (the event types it reacts to). 
Â The Output definition determines the types of MIDI events the fader sends out. 

A fader can, therefore, convert one type of MIDI event to another.

Most MIDI events consist of three bytes. 
Â The first byte indicates the type and channel of the MIDI event (a note on channel 3, 

for example). 
Â The second byte indicates the first data value (the pitch of a note event, for example).
Â The third byte indicates the second data value (the velocity of a note event, for 

example). 

A few MIDI events only use two bytes (program change and aftertouch). Some objects, 
such as Faders (and Transformers) always provide for 3 bytes, with the second byte 
being discarded when these special, 2-byte messages are received. 

Fader parameters are provided for setting the message type, MIDI channel, and the first 
data value. Note that the message type and MIDI channel are actually combined in the 
resulting MIDI event. The second data value is determined by the fader setting, or if the 
fader is being remotely MIDI-controlled, by the incoming MIDI event.

The Input and Output Definition Parameters
These are used to define the Input and Output parameters:
Â Output (or Input):  Defines the event type.
Â Channel (1 to 16):  Defines the MIDI channel of the event.
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Â -1- (0 to 127):  Defines the first data byte of the event. In some cases, such as pitch 
bend, this is an actual data value. In other cases (MIDI controllers), this indicates the 
controller type (volume, pan, and so on, as examples). In other cases, such as 
aftertouch, this byte is unused.

Setting the -1- Parameter and Fader Position
This section outlines each of the -1- parameter options, and explains how the fader 
position affects them (for both the Input and Output definitions):
Â Note On:  The -1- parameter sets the pitch, and the fader position sets the velocity. 

This is most useful as an Input definition—for trapping specific notes and converting 
them to other MIDI events, or simply monitoring their velocity. If you move a fader 
with an Output definition set to Note On, a note-off MIDI event will immediately 
follow the note-on. This might be useful for creating onscreen drum pads from 
button style faders, for example. 

Â P-Press:  The -1- parameter sets the pitch, and the fader position sets the amount of 
Poly Pressure (key pressure or polyphonic aftertouch). 

Â Control:  The -1- parameter sets the MIDI controller number (the controller type), and 
the fader position sets the controller value. The controller type can actually be 
selected by name, via the pull-down menu that appears when you click-hold on the 
-1- parameter.

Â Program Change:  The -1- parameter is ignored. The fader position determines the 
program number.

Â C-Press:  The -1- parameter is ignored. The fader position sets the channel pressure 
(monophonic aftertouch) amount.

Â PitchBd:  The -1- parameter sets the pitch bend LSB, and the fader position sets the 
MSB. Typically, you would set the -1- parameter to 0, and use the fader to control the 
coarse pitch bend amount. A -1- setting of 0, and a fader position of 64 results in no 
pitch bend.

SysEx and Switcher/Meta are special functions of the faders.

Fader Functions:  Range, Val As
These parameters determine the minimum and maximum values of a fader, and how 
the fader displays these values.

Range
The range parameter contains two numbers—the left one sets the lowest possible 
fader value, and the right one sets the highest. Note that these limits can be exceeded 
by MIDI remote control. When the fader style is a button, the range determines the in 
and out position values of the button. 
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For text style faders, the first name always corresponds to the low end of the range, 
and subsequent names correspond to incremental range values, up to the top range. 
The number of names that can be entered into the window is limited by the range.

Val As
This parameter determines the way that numerical values are displayed by the fader:
Â Num:  The fader value is displayed as a number (0 to 127).
Â Pan:  Fader value 64 is displayed as “0”; smaller values appear as negative numbers 

and larger values as positive numbers (–64 to 63).
Â Hz, Oct, dB, ms:  These display formats are tailored to various DSP functions.
Â bpm:  An offset of 50 is added to the fader value. This displays the correct tempo 

settings for the Special > Tempo Control fader.

If none of the above formats is suitable, consider using a text style fader, and entering 
the desired display values as text. Examples include:  percentages, note names, and 
program names.

Fader Functions:  Filter
This parameter provides various filtering options for MIDI events:

Off
All incoming MIDI events are allowed to pass through. All events that match the input 
definition are converted, in accordance with the output definition.

Other
All MIDI events that do not correspond to the input definition are filtered. All events 
that match the input definition are converted in accordance with the output definition, 
and allowed to pass through.

Match
All MIDI events that match the input definition are filtered, all others are allowed to 
pass.

All
All incoming MIDI events are filtered.

Thru
All MIDI events coming from the Physical Input object are filtered. This is the same as 
turning off all events coming from Logic Pro (from regions or the Environment).

Use this filter mode to prevent MIDI feedback, by blocking incoming MIDI events from 
being sent back out.

Shot
When the fader is moved with the mouse, only the final value (the value when the 
mouse button is released) is sent.
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14 Bit
Â Used in conjunction with pitch bend, this allows 2-byte (fine tuning) pitch bend 

events.
Â Used with controller messages, this causes the fader to send two MIDI controller 

messages—one for the MSB (Most Significant Byte) and one for the LSB (Least 
Significant Byte).

Note:  The fader’s Input and Output definitions must be the same or the 14 Bit setting 
will not work. 

For controllers, the MSB uses the Input definition controller number, and the LSB uses 
the controller number 32 higher. This conforms to the MIDI standard for sending 14-bit 
controller data.

When this filter setting is chosen, the fader’s Range can be set to a maximum value of 
16,383. A fader value of 8192 represents no pitch bend.

Feedback
When the Feedback parameter is turned off (unchecked), the fader will automatically 
prevent feedback loops resulting from circular cabling (the fader remembers when a 
specific MIDI event has passed through it and will not allow it to pass through again). 

In some instances, you may want to enable feedback—to allow a MIDI event to change 
a Cable Switcher’s position after it has passed through the switch, for example. 
Checking the Feedback checkbox will allow this.

Vector Fader
Vector faders function like joysticks—they can be moved in two dimensions:  up/down 
and left/right. Each dimension generates its own MIDI events, so each time you change 
the position of the crosshair with the mouse, two MIDI events are sent. 

Most faders have Input and Output definitions (see “Fader Functions:  Range, Val As” on 
page 925) which determine the MIDI events sent by the fader (Output), and those it 
reacts to (Input). 
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The vector style fader replaces these with Vert and Horz definitions, which determine 
the MIDI events that correspond to vertical and horizontal motion. If corresponding 
MIDI events are received by the vector style fader, its crosshair display will update 
accordingly.

4-Channel Vector Mode
If you set a vector fader’s Vert and Horz definitions to the same MIDI event (the same 
MIDI controller and channel), the vector fader will send out four MIDI events each time 
the crosshair is moved. 

These will be the same MIDI event (a controller, for example), sent on four consecutive 
MIDI channels, starting with the channel set in the Vert definition. 
Â Upper-left for the lowest channel (channel 3, for example)
Â Upper-right (channel 4)
Â Lower-left (channel 5)
Â Lower-right (channel 6)

The values of these MIDI events corresponds to the proximity of the crosshair to the 
vector fader’s four corners:
Â In the center, all channels receive a value of 32. 
Â At the corners, the corresponding channel receives a value of 127 and all remaining 

channels receive a value of 0 (if using the default range of 0 to 127). 

If you alter the range, the center and corners will behave differently, with the four 
values always totalling 125.

Special Faders Overview
The Environment provides a number of special fader objects that are purpose-built to 
perform certain functions.

Switchers, Alias Assigners, and Meta Faders
These are two types of faders that do not generate MIDI events. They share the same 
Output definition type, either:  Switch (see “Cable Switchers” on page 929) or Meta, 
depending on the current -1- value setting:
Â If the -1- value is 48, the fader will be a cable switcher
Â If the -1- value is 46, the fader will be an alias assigner (see “Meta Event Faders” on 

page 930).
Â If the -1- value is any other value, the fader will send out meta messages (see “Meta 

Event Faders” on page 930) of a type that corresponds to the -1- value.

To create a cable switcher, either:
m Choose New > Fader > Specials > Cable Switcher.

m Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to 48.



Chapter 39    Working in the Environment 929

To create an alias assigner, either:
m Choose New > Fader > Specials > Alias Assigner.

m Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to 46.

To create a meta type fader, either:
m Choose it from the New > Fader > Specials menu.

m Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to the 
desired meta event number.

Cable Switchers
Cable Switcher objects route events, rather than generating them. Any kind of MIDI or 
meta event can be routed by a cable switcher. The only exception is events that match 
the cable switcher’s Input definition. These events will change the switch position (the 
routing), rather than passing through the cable switcher.

A cable switcher can be assigned to any fader style. It is practical to use the text fader 
style, as it allows you to label the switcher’s various routes. Use the Auto-style to 
actually display the switch routing, as shown here.

A cable switcher can have up to 128 separate cable outputs—a new output is 
generated each time an existing output is cabled to another object. You can click on an 
auto-style cable switcher to step through the outlets (including the last, uncabled one). 

Incoming events that match the cable switcher’s Input definition will change the switch 
position to that of the incoming data value. (If the data value is greater than the 
number of switch positions, the last, uncabled outlet will be selected). 

Data values of 126 and 127 have a special effect:
Â An event with a value of 127 increases the output number. If you’re on the switcher’s 

last output when this event is received, you’ll jump back to the first output. This is 
just like clicking on the fader.

Â An event with a value of 126 decreases the output number. If you’re on the switcher’s 
first output when this event is received, you’ll jump to the last output.
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Meta Event Faders
Meta faders generate special meta events, which are used to control certain Logic Pro 
functions, but have no MIDI meaning, and are never sent to the MIDI output. 

In some cases (such as Go to Screenset, Go to Project, and so on), you do not need to 
cable meta faders into another object for them to work. Even in these cases, you can 
use cabling to process meta events in the Environment, and alter their effect. 

In the majority of cases, however (Set fader range minimum, Bang!, Set Transformer 
Operation Minimum, and so on), the meta fader must be cabled to the object being 
affected.

Here’s a quick summary of the currently implemented meta events that can be 
generated by faders:

For more on Meta events 124 to 127, read the section on Remote Controlling the 
Condition and Operation Values (see “Transformer Object” on page 899).

Meta event Controlled Logic Pro function

46 Assign Alias

49 Go to Screenset

50 Go to Project

51 Go to Marker

52 Stop Playback

96 Set fader range minimum

97 Set fader range maximum

98 Set the fader value without sending.

99 Bang! Causes the fader to re-send its current value. The bang data value can be used 
to make the fader increment-without-rollover (127), decrement-without-rollover (125), 
increment-with-rollover (123) or decrement-with-rollover (121). Use values one less 
than those shown, to have the bang” passed through to all connected faders.

100 Tempo Control (see “Using the Tempo Fader” on page 654)

122 Set transformer map value for the currently selected map position.

123 Select transformer map position.

124 Set transformer condition maximum (bottom) parameter, if any. (This applies to all 
conditions not set to All).

125 Set transformer condition minimum (top) parameter, if any. (This applies to all 
conditions not set to All).

126 Set transformer operation maximum (bottom) parameter, if any. (This applies to all 
operations not set to Thru).

127 Set transformer operation minimum (top) parameter, if any. (This applies to all 
operations not set to Thru).
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Go to Marker, Screenset, or Project
Choosing New > Fader > Special > Go to Marker creates a fader which allows you to 
enter a marker number (Meta event 51). 

The playhead moves instantly to the chosen marker number. Markers are numbered 
sequentially, throughout the project, even if you have renamed them (from the default 
numbers assigned when each marker was created).

Choosing New > Fader > Special > Goto Screenset creates a Screenset fader (Meta 
event 49), allowing you to switch to the screenset number chosen with the fader.

Meta event 50 has no effect within Logic Pro, but you can use it to switch between 
songs on an external hardware sequencer.

Meta event 52 allows you to interrupt playback at any position.

Note:  To make the most efficient use of these faders, we recommend that you limit the 
value range to suit your particular circumstances. As an example, to limit the faders to 
the number of screensets, projects, or markers you’re actually using.

SysEx Faders
The SysEx fader type is slightly different to other fader types. It allows you to create a 
list of MIDI events that will be sent whenever the fader is moved or remote controlled. 

You can enter the messages that you want to send in a window that resembles the 
Event List. The positions of events in the list only control the order in which they are 
sent—they are not sent at specific times, nor with any delay between them.

The SysEx fader type is primarily designed to send MIDI System Exclusive (SysEx) 
messages—messages that are exclusive to individual manufacturers’ MIDI devices. 
There are a number of features in the SysEx fader window (see below) that facilitate the 
creation of SysEx messages. 

Note:  SysEx faders can actually be used for any kind of MIDI event, making them handy 
for sending ordered batches of messages, such as mixer or control panel snapshots—
with one click of the mouse.

You can also specify SysEx as an Input definition, but this has limited usefulness 
because the incoming message (presumably SysEx) must be very short, in order to be 
recognized. This is a side-effect of the fact that SysEx messages can be of any length, 
and Logic Pro must break them into small packets, to avoid interrupting other MIDI 
activities.

Opening the SysEx Fader Window
When you set a fader’s Output or Input definition to SysEx, the SysEx fader window 
automatically opens. You can also open this window at any time by double-clicking on 
the word SysEx in the fader’s Parameter box.
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An important thing to remember about the SysEx fader is that only selected events will 
have their value altered by the fader value, when the SysEx fader window is closed. 
Events that are not selected will be sent exactly as they appear in the window.

The value shown in the Val column (of selected events) is altered, if normal MIDI events 
(controllers, program change, aftertouch, and so on). 

For SysEx messages, you can determine:
Â Which bytes are altered
Â The format (MSB/LSB, BCD, nibbles, and so on) of the value

You can also specify a checksum format, if necessary. 

Creating a SysEx Message
There are two ways of entering SysEx messages in the SysEx fader window. One way is 
to have the fader learn the SysEx string. 

To learn a SysEx string:
1 Click the MIDI In button at the top left of the SysEx window. If the button is pressed, 

this means it is ready to receive incoming MIDI data.

2 Alter the parameter on your device. 

3 The corresponding SysEx message will be displayed and the MIDI In button will switch 
off automatically.

Another way is to type the SysEx string into the event list. (Consult your MIDI device 
manual for SysEx documentation). Use of this method qualifies you as a confirmed MIDI 
freak. 

To manually enter SysEx strings:
m Enable the Create button, then click the SysEx button.
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A generic SysEx message appears.

Â The first data byte in the top line (directly after the word SysEx in the Num column) is 
the manufacturer’s ID. This may be several data bytes long (as there are more than 
128 manufacturers of MIDI devices).

Â The manufacturer’s ID is usually followed by a device type ID, an individual device ID, 
a data type ID (which could be several bytes) and, if necessary, the number of the 
multi-timbral sub channel, the identification number(s) of the sound parameters plus 
the value of the sound parameter. There are no uniform standards that apply here. 

Â Data bytes are normally input as decimal numbers. To enter them in hex, place a $ in 
front of values when you type them in. View > SysEx in Hex Format allows you to see 
all values in hexadecimal.

Â The last data byte (the EOX indicating the end of the SysEx message) is entered 
automatically by Logic Pro. The number of data bytes in the SysEx message can be 
decreased or increased by clicking the plus and minus symbols before and after the 
word <EOX>.

Although you can have any number of messages (of any kind) in the SysEx fader’s 
event list there is only one fader value, and all selected messages will adopt this value.

You can use a similar method to create any kind of MIDI or meta event in the SysEx 
fader window. Command-clicking any of the eight event type buttons (note, program 
number, pitch bend, controller, channel pressure, poly pressure, SysEx, and meta event) 
creates a new event of that type. Meta events can be created by using the expanded 
view button—featuring the 0’s and 1’s on its face.

Setting the SysEx Data Format
The terms SUM for the checksum and VAL for the fader value being sent are displayed 
within the SysEx string. 

To set the checksum and value of a SysEx event:
1 Select the events you want to alter.
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2 Choose the desired options in the Checksum and Value menus (found in the lower 
right corner of the window) to set the format of these bytes. 

Checksum Format
A checksum can be created in any of the following formats:
Â Roland
Â Yamaha
Â Regular Checksum
Â 2’s complement
Â 1’s complement

If you don’t know which one works with your MIDI device, try “off” (= no checksum) 
first or “2’s complement”.

Value Byte Position
Position allows you to determine the position of the value byte. This position is 
specified in bytes, counted from the end of the message:  “last” refers to the position 
directly before the EOX byte, “Last-1” indicates the byte before that, and so on.

Auto ensures that the value byte is inserted at the last position in the SysEx string if no 
checksum was selected, or—if a checksum value was entered—that the value is 
inserted as the second to last byte.

Value Byte Format

Value option Result

Auto The value is sent as one byte if the value range maximum is 127 or less. If the 
maximum is higher than 127, the value is sent as two bytes, the MSB (most 
significant byte) first.

One Byte The value is sent as one byte.

MSB/LSB The value is sent in two bytes, with the MSB (most significant byte) first.

LSB/MSB The value is sent in two bytes, with the LSB (least significant byte) first.

BCD 4 LSB The value is sent as Binary Coded Decimal in four bytes, in the order 1, 10, 100, 
1000.

BCD 4 MSB The value is sent as Binary Coded Decimal in four bytes, in the order 1000, 100, 
10, 1.

2 Nibbles L The value is sent in two nibbles, with the least significant nibble first.

3 Nibbles L The value is sent in three nibbles, with the least significant nibble first.

4 Nibbles L The value is sent in four nibbles, with the least significant nibble first.

2 Nibbles M The value is sent in two nibbles, with the most significant nibble first.

3 Nibbles M The value is sent in three nibbles, with the most significant nibble first.

4 Nibbles M The value is sent in four nibbles, with the most significant nibble first.
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The unused bits of the transfer in nibbles (X in 0XXXNNNN) are sent with the 
information at the relevant positions of the SysEx strings. If you want to transfer these 
deleted bits, you will need to enter zeros in the SysEx string.

Channel Strip Objects
The Environment’s channel strip object (see “Channel Strip Types” on page 566) is the 
building block of the Environment’s Mixer layer, the Mixer window, and the Arrange 
channel strips. 

The audio and (software) instrument tracks you see in the Arrange window are actually 
routed to channel strip objects on the Environment Mixer layer.

2 ASCII M The value is sent in two nibbles, the most significant nibble first; the nibbles are 
sent in ASCII format for the hex value. As an example, the value $7F (= 127 in 
decimal) will be transmitted as a 7 and F.

3 ASCII M same as 2 ASCII M, but in 3 nibbles.

4 ASCII M same as 2 ASCII M, but in 4 nibbles.

Value option Result
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The Mixer channel strips and Arrange channel strips are simply remote controls for the 
underlying channel strip objects in the Environment Mixer layer. Their inclusion in these 
other windows makes your workflow faster and easier.

As mentioned near the beginning of this chapter, the Arrange channel strips are cut 
down versions of the corresponding channel strip objects in the Environment. The 
channel strips shown in the Mixer window are more configurable, but the only place 
you can access all channel strip options is the Environment Mixer layer.

Important:  If File > Project Settings > Audio > Automatic Management of Channel 
Strip objects is active (it is on, by default), you can not create channel strips in the 
Environment. This setting, when active, means that use of the track and channel 
creation options in the Arrange window will automatically create a corresponding 
channel strip object in the Environment (and therefore, remote control channel strips in 
the Mixer and Arrange).

In a general music-making sense, you will not need to access the underlying channel 
strips shown in the Environment. In fact, the only time you will open the Environment 
Mixer layer is when you need to reconfigure channel strips at a system level; re-routing 
them to different audio hardware, or perhaps to other applications.

Although channel strip objects are not part of the MIDI signal flow, they still allow MIDI 
messages to control aspects of audio and software instrument playback in Logic Pro. 
Any MIDI object can be cabled into a channel strip object, thereby feeding control data 
into it.

Channel Strip Parameters
When you click on a channel strip of any type (audio, instrument, aux, output, master, 
and input or bus channels, discussed below), the following common parameters are 
accessible:

Icon
Enable the checkbox to make the channel strip accessible in the Arrange Track 
Assignment menu (Control-click the track list).

Choose the desired icon for the channel strip from the pop-up menu accessed by 
clicking on the icon.

Device
Click the visible device name (CoreAudio, for example) to reassign the selected channel 
strips to a different hardware device.
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Channel
Click the visible channel name (Audio 1, for example), and choose the channel strip 
type from the sub-menus. This is how you can reassign a (newly-created or existing) 
channel strip object (an audio channel strip is the default for new objects) to other 
channel strip types. You can choose from:
Â Audio:  The default channel strip type, used as the destination for Arrange audio 

tracks.
Â Input:  Primarily used for compatibility with projects created in earlier Logic Pro 

versions (see “Input Channel” on page 938). 
Â Aux:  Auxilliary channel strip, used as send returns for all channel strips (via Sends), as 

sub-group channels, and as individual output destinations for multi-channel software 
instruments (EXS24 mkII, for example).

Â Instrument:  Used as the destination for Arrange (software) instrument tracks.
Â Output:  These channel strips represent the physical outputs of your audio interface. 

You can choose either mono or stereo (paired) outputs. 
Â Bus:  Primarily retained for compatibility with projects created in earlier Logic Pro 

versions. The functions of bus objects are performed with (the more flexible) aux 
channel strips in Logic 8.

Â Master:  Only one master channel can exist in a project. This is the master volume 
control for all channel strip types (except external MIDI channel strips).

MIDI Channel
Allows you to choose a MIDI channel which can be used to control the channel strip.

Value As
Choose from either dB (decibels) or Value (a numerical range). This simply affects the 
appearance of meters and other displays on the channel strip. 

Show Options
Enable the corresponding checkbox to show EQs, Inserts, Sends, and I/Os on the 
selected channel strip(s).
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Input Channel
You can only create input channel strip objects in the Environment. In general, you will 
not need to do so, as all audio hardware inputs are automatically seen by audio 
channel strips, and can be monitored and recorded. 

It is primarily included for compatibility with older Logic Pro versions, and for use with 
certain audio hardware devices. The Input channel strip allows you to directly route 
and control signals from your audio hardware’s inputs. Once an Input channel is 
assigned to an audio channel, it can be monitored and recorded directly into Logic Pro, 
along with its effect plug-ins.

The signal is processed—inclusive of plug-ins even while Logic Pro is stopped. In other 
words:  Input channels can behave just like external hardware processors. Aux sends 
can be used pre or post-fader.

Input channels can be used as live inputs that can stream audio signals from external 
sources (such as MIDI synthesizers and sound modules) into a stereo mix (by bouncing 
an output channel).

Note:  An alternative to using input channels in this way is the use of the I/O plug-in, or 
simply click the Input Monitoring button on an audio channel strip (and choose the 
input(s) you want to monitor—or record—via the Input slot).

Bus Channel
You can only create bus channel strip objects in the Environment. In general, you will 
not need to do so, as all audio bussing (send/return routing via the Send slots of 
channel strips) is handled by aux channel strips. 

It is primarily included for compatibility with older Logic Pro versions, and for use with 
certain audio hardware devices.

Note:  File > Project Settings > Audio > Automatic Management of Channel Strip 
Objects must be deactivated if you want to create Input channel strips (it is on, by 
default).

Prelisten Channel Strip
The Environment’s Prelisten audio channel strip is used for monitoring in the Sample 
Editor, Audio Bin, Loop Browser, and Browser. It is created automatically in each 
project—you can find it to the right of the highest numbered audio channel strip.
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40 Project Settings and Preferences

The project settings and preferences allow you to define 
many of Logic Pro’s basic operating parameters. This section 
explains each of these options.

Unless otherwise indicated, the descriptions of the various parameters apply when the 
selection box beside the option is checked (in other words, when it’s active).

Project settings and preferences are accessible via the File > Project Settings and 
Logic Pro > Preferences menu items (plus several other access methods, outlined 
throughout the chapter). When either is selected, a Preferences or Project Settings 
window will be launched. 

Each window features a number of icons and tabbed panes. These behave much like 
menus and sub-menus. To adjust a given preference, simply select the desired icon, 
then the appropriate tab. Once the panel or window is shown, activate or deactivate 
the preference or setting, or make your selection from a pop-up menu. Close the 
window once you’ve made your selections.

In some instances, you will find a button that links to related parameters in the Project 
Settings window, while you are in the Preferences window (and vice-versa). Clicking on 
this button will open the Project Settings window, and will automatically select the 
relevant pane. As an example, the Logic Pro > Preferences > MIDI > Sync tab features a 
MIDI Sync Project Settings button. Clicking this button will open the Project Settings > 
Synchronization > MIDI tab.

Both the Project Settings and Preferences windows can be visible at the same time, 
making set up of operating parameters faster and clearer.

Some of these can also be reached directly from Logic Pro’s local menus (in the Score 
Editor, for example), or from the Transport buttons, via shortcut menus.
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Saving Project Settings and Preferences
The project settings are stored with the project file. If you want to start Logic Pro with 
certain settings, simply adjust the desired settings in your default template, and save it. 

Project settings can be transferred between projects, through the use of several import 
functions. You can use these to accelerate template creation, or when you would like to 
integrate aspects (such as score text styles) from another project into the one you’re 
currently working on. For details on all project import options, see “Importing Settings 
From Other Projects” on page 141. 

The preferences are automatically saved whenever you quit Logic Pro. There are two 
preference files (one for Logic Pro, and one for control surfaces), which are stored in the 
 ~/Library/Preferences/Logic folder. Logic Pro preference files begin with 
“com.apple.logic”.

Note:  All choices made in the Project Settings window are specific to the saved project. 
All items selected in the Preferences window globally affect all projects.

Project Settings
Project settings, as mentioned, are saved with each project, which means that different 
projects can have different project settings. You can save your preferred settings in a 
default template, which can be used to automatically create a new project when you 
open Logic Pro.

To specify the project options when Logic Pro is opened:
1 Open the Logic Pro > Preferences > Global > Project Handling tab.

2 Choose the desired behavior from the Startup Action pop-up menu.

To start Logic Pro with a specific project:
m Double-click on a specific project file in the Finder.

As an alternative, you can choose the Open Existing Project setting in the Startup 
Action menu discussed above. When you open Logic Pro by clicking on the application 
icon, a file selector box is automatically displayed, allowing you to choose the desired 
project.

Synchronization Settings
All Synchronization project settings are described in the Synchronization chapter (see 
“Synchronizing Logic Pro” on page 829).
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Metronome Settings
The Metronome project settings combine all speaker click, MIDI click, and KlopfGeist—
a virtual metronome sound source—parameters. (See the KlopfGeist chapter in the 
Logic Studio Instruments and Effects manual for details). KlopfGeist can be used in 
addition to, or in place of, the speaker and MIDI click sources.

To open the Metronome project settings, do one of the following:
m Choose File > Project Settings > Metronome (or use the corresponding key command).

m Click the Toolbar Settings button, then choose Metronome from the menu. 

m Control-click the Metronome button in the Transport bar, and choose Metronome 
Settings from the shortcut menu. 

MIDI Click Settings
The MIDI Click settings mirror those in the Parameter box of the MIDI Click object:
Â Bar, Beat, and Division checkboxes:  Switch on to generate separate note events for 

bars, beats, and divisions. 
Â Channel, Note, and Velocity parameters:  Define the MIDI channel, note number, and 

velocity of generated notes. 
Â MIDI Port menu:  Allows you to set a direct MIDI output port (or all ports) for the 

metronome.
Â Metronome plays through built-in speakers:  This sends the metronome click to the 

computer’s loudspeaker. The System Preferences > Sound pane must be set to 
Internal Speakers (Port:  Built-in Audio) in order for the speaker click function to work. 
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Software Click Instrument (KlopfGeist) Settings
Â Software Click Instrument (KlopfGeist) checkbox:  Click to activate or deactivate the 

KlopfGeist metronome. It is active by default.
Â Bar, Beat, and Division checkboxes:  Switch on to generate separate note events for 

bars, beats, and divisions. 
Â Note and Velocity parameters:  Define the note number, and velocity, of generated 

notes. 
Â Tonality slider:  Changes the sound of the virtual metronome from a short click to a 

pitched percussion sound, similar to a wood block or claves.
Â Volume slider:  Sets the output level of the virtual click sound. 
Â Output menu:  Provided the audio hardware used by Logic Pro offers more than two 

outputs, this menu allows you to route the KlopfGeist metronome sound to a 
different set of hardware outputs. 

Note:  KlopfGeist is a software instrument found in the Plug-in menu of instrument 
channels. KlopfGeist is inserted into instrument channel 128, by default. Logic Pro 
automatically creates instrument channel 128 (and inserts KlopfGeist) when the 
Software Click Instrument (KlopfGeist) checkbox is activated. Theoretically, any other 
Logic Pro or third-party software instrument could be used as a metronome sound 
source—on instrument channel 128.

Other Settings
In addition to the MIDI Click object and KlopfGeist settings, the Metronome project 
settings pane also offers the following options:
Â Click while recording:  The metronome click is automatically switched on for 

recording. This is the same as activating the Metronome button in the Transport bar 
during recording.

Â Only during count-in:  When this option is active, the recording click is only audible 
during the project count in, and is then switched off. 

Â Click while playing:  The metronome click is automatically switched on for playback. 
This is the same as activating the Metronome button in the Transport bar during 
playback.

Â Polyphonic Clicks:  The metronome sends notes, as defined for:  bars, beats, and 
divisions. As an example, two or three notes may be sent simultaneously at the 
beginning of each measure. If this option is unchecked, the metronome will only 
transmit one note at a time.
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Recording Settings
The Recording project settings determine how Logic Pro responds while in record 
mode.

To open the Recording project settings, do one of the following:
m Choose File > Project Settings > Recording (or use the corresponding key command, 

default:  Option-*).

m Click the Toolbar Settings button, then choose Recording from the menu. 

m Control-click the Record button in the Transport bar, then choose Recording Settings 
from the menu.

Allow Tempo Change Recording
All tempo changes made while in record mode are recorded. For details on editing 
these tempo recordings, please see Chapter 30, “Advanced Tempo Operations,” on 
page 641.

When Beginning:  Count In
If enabled, the pop-up menu allows you to set the desired count in period that 
precedes a recording.
Â None:  The recording begins with no count in.
Â x Bar:  X bars of count-in.
Â x/4:  The count-in’s time signature may be set here. These settings are useful when 

the count-in falls across a bar change.

When Beginning:  Record Pre-Roll
If enabled, this parameter allows you to set a pre-roll time in seconds and milliseconds. 
When recording, this value will be deducted from the current project position.
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Overlapping Recordings
This pop-up menu provides the following settings:
Â Create take folders:  As the name suggests, a new take folder is created when 

recording over an existing MIDI region. Details on take recording and handling are 
covered in “Recording MIDI Regions in Real Time” on page 379.

Â Merge with selected regions:  Newly-recorded data is merged with all selected regions, 
to form a single region. This takes place after each recording is completed.

Â Merge only in Cycle record:  When recording in Cycle mode, this function merges the 
data recorded in all cycle passes into a single region. If not in Cycle mode, each 
newly-recorded MIDI region will be independent (not merged).

Auto Demix by Channel if Multi Track Recording
This setting switches between the Layer recording and Multi-player recording modes. 
See “Recording on Multiple MIDI Tracks” on page 382.

MIDI Data Reduction
Controller events are thinned out during recording, to reduce the data load on the MIDI 
bus during playback. This improves the timing of dense arrangements when using 
interfaces with only a few MIDI ports. The function actually reduces the duration of 
controller events, using an intelligent algorithm which retains the value at the end of a 
series of controller messages.

Recording Folder
This setting is only really applicable if you prefer to record all audio data into a single 
location. If your working methods are geared towards projects, all recordings (and 
other project assets) are saved in the project folder itself. To set a universal recording 
folder, click the Set button, and choose or create a new folder location in the file 
selector box. 

Tuning Settings
Logic Pro includes a real time tuning system, for use with the included software 
instruments. You can configure the tuning system in the Tuning project settings.

To open the Tuning project settings, do one of the following:
m Choose File > Project Settings > Tuning (or use the corresponding key command).

m Click the Toolbar Settings button, then choose Tuning from the menu. 
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About Tuning
Before looking at the Tuning settings, some basics and background information.

About Alternate Tunings
The twelve tone scale used in Western music is a development that took centuries. 
Hidden in-between these twelve notes are a number of other microtones—different 
frequency intervals between tones.

To explain, by looking at the harmonic series:  Imagine that you have a starting (or 
fundamental) frequency of 100 Hz (100 vibrations per second). The first harmonic is 
double that, or 200 Hz. The second harmonic is found at 300 Hz, the third at 400 Hz, 
and so on. Musically speaking, when the frequency doubles, pitch increases by exactly 
one octave (in the 12 tone system). The second harmonic (300 Hz) is exactly one 
octave—and a pure fifth—higher than the fundamental frequency (100 Hz). 

From this, you could assume that tuning an instrument so that each fifth is pure would 
be the way to go, right? In doing so, you would expect a perfectly tuned scale, as you 
worked your way from C though to the C above or below. Close, but no cigar.

To simplify this example:  Imagine that you are tuning an instrument, beginning with a 
note called C at a frequency of 100 Hz (a real C would be closer to 130 Hz). The first fifth 
would be tuned by adjusting the pitch until a completely clear tone is produced, with 
no beats (beats are cyclic modulations in the tone). This will result in a G at exactly 
150 Hz. This is derived from this calculation:
Â The fundamental (100 Hz) x 3 (= 300 Hz for the second harmonic).
Â Divided by 2 (to drop it back into the same octave as your starting pitch).

This frequency relationship is often expressed as a ratio of 3:2. 

For the rest of the scale:  Tune the next fifth up:  150 x 3 = 450. Divide this by 2 to get 
225 (which is more than an octave above the starting pitch, so you need to drop it 
another octave to 112.5).

Note Frequency (Hz) Notes

C 100 x 1.5 divided by 2.

C# 106.7871 Divide by 2 to stay in octave.

D 112.5 Divide by 2 to stay in octave.

D# 120.1355 Divide by 2 to stay in octave.

E 126.5625 Divide by 2 to stay in octave.

F (E#) 135.1524

F# 142.3828 Divide by 2 to stay in octave.

G 150 (x 1.5) divided by 2.

G# 160.1807
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As you can see from the table above, there’s a problem! 

Although the laws of physics dictate that the octave above C (100 Hz) is C (at 200 Hz), 
the practical exercise of a (C to C) circle of perfectly tuned fifths results in a C at 
202.7287 Hz. This is not a mathematical error. If this was a real instrument, the results 
would be clear.

To work around the problem, you need to choose between the following options:
Â Each fifth is perfectly tuned, with octaves out of tune.
Â Perfectly tuned octaves with the final fifth (F to C) out of tune. 

It goes without saying that detuned octaves are more noticeable to the ears.

The Comma
The difference between a perfectly tuned octave, and the octave resulting from a 
tuned circle of fifths, is known as the comma. 

Over the centuries, numerous approaches have been tried to solve this mystery, 
resulting in a range of scales (before arriving at equal temperament—the 12 tone 
scale). 

Other historical temperaments that have been devised emphasize different aspects of 
harmonic quality. Each compromises in some way or another. Some maximize pure 
thirds (Mean Tone) while others emphasize pure fifths, at the expense of the thirds 
(Kirnberger III, for example). 

Every temperament has its own character, and a given piece of music may sound fine 
in one key, but awful in another. Transposing a piece to a new key can completely 
change its character. 

Careful attention must be paid to the selection of temperaments for authentic 
performances of historic keyboard music. The wrong choice could result in an 
unsatisfactory and historically inaccurate musical experience. 

About Equal Temperament
Equal temperament takes the tuning error (the comma), and spreads it equally 
between each step of a chromatic scale. The result is actually a scale of equally mis-
tuned intervals, with no interval grossly out of tune, but none in perfect tune. Equal 
temperament has become the de-facto standard for two main reasons:

A 168.75

A# 180.2032

B 189.8438

C 202.7287

Note Frequency (Hz) Notes
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Â Convenience:  Retuning an instrument to a temperament that is better suited for a 
particular piece of music is a hassle. Many instruments are not capable of being 
alternately tuned (fretted string instruments, for example). 

Â Portability:  All Western musical pieces can be performed (adequately) on an 
instrument tuned to equal temperament. Obviously, some of the nuances may be 
missing in pieces that were originally performed in another temperament. 

What Is Hermode Tuning?
Hermode Tuning automatically controls the tuning of electronic keyboard instruments 
(or the Logic Pro software instruments) during a musical performance. 

In order to create clear frequencies for every fifth and third interval, in all possible 
chord and interval progressions, a keyboard instrument would require far more than 12 
keys per octave. 

Hermode Tuning can help with this problem:  it retains the pitch relationship between 
keys and notes, while correcting the individual notes of electronic instruments—
ensuring a high degree of tonal purity. This process makes up to 50 finely graded 
frequencies available per note, while retaining compatibility with the fixed tuning 
system of 12 notes per octave.

How Hermode Tuning Works
Frequency correction takes place on the basis of analyzed chord structures. 

The positions of individual notes in each chord are analyzed, and the sum of each 
note’s distance to the tempered tuning scale is zeroed. In critical cases, different 
compensation functions help to minimize the degree of re-tuning—at the expense of 
absolute purity, if necessary.

As an example:
Â The notes C, E, and G form a C Major chord.
Â To harmonically tune these, the third (the E) needs to be tuned 14 cents higher (a 

cent is 1/100th of a tempered semitone) and the fifth (the G), needs to be 2 cents 
higher.

It should be noted that Hermode Tuning is dynamic, not static. It is continuously 
adjusted in accordance with the musical content. This is done for the following reason:

As an alternative to tempered, or normal, tuning—fifth and third intervals can also be 
tuned to ideal frequency ratios:  the fifth to a ratio of 3:2, the major third to 5:4. Major 
triads will then sound strong. 

With clean (scaled) tuning, Hermode Tuning changes the frequencies to values that are 
partly higher or partly lower. 
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Tuning Project Settings
The Tuning project setting parameters are listed below.

Tune
This parameter determines the global tuning of all software instruments. The default is 
concert pitch A (440 Hz). Detuning is in cent (1/100th of a semitone) steps.

Alternate Tuning Scales
Activation of alternate tuning scales is achieved by clicking the appropriate radio 
button in the Software Instrument Scale section. The selected tuning scale is saved 
with the project when saved, and reloaded the next time the project is opened.

Equal Tempered
This mode (active by default) disables any tuning, and uses an equal tempered scale.

Fixed Tuning
This mode activates a number of fixed tuning scales and keys. The Type pop-up menu 
offers the most important historic tuning scales, and a few others.

The Root Key menu allows you to choose a global key (C–B) for the chosen scale. This 
provides an easy way to reference the chosen scale to any root note. 

Fixed Tuning mode tunes musical keys (to different degrees) for scaled tuning systems, 
and delivers a key signature character. To explain:

Â When playing mostly white keys (in the Pure setting, and with C as the root key), C 
major will be the main focus, and tuning will be scaled to that chord. 

Â An A major chord that is played immediately after a C major (and is therefore subject 
to C major scaled tuning) will be affected somewhat by the scaled tuning effect, but 
will not sound completely tempered. If you normally play polyphonic music, this 
mode (when using the Pure setting) will sound most pleasing to your ears.
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The Fixed Tuning scales are ideal for a number of Baroque and Medieval instruments, 
and styles of music.

User
Each semitone can be detuned (moved away) from equal temperament in semitone 
steps. To do so, just click-drag—vertically—on each semitone box until the desired 
value is reached. 
Alternately, you can double-click in each semitone box, and type in a value. Press Enter 
or click on another box to exit the text entry mode.

The Reset button resets all of your tuning adjustments to their default values.

The Stretch Lower and Upper sliders can be used to stretch the tuning in the bass and 
treble, to simulate the stretched tuning of some instruments (acoustic pianos, for 
example). 
Â Stretch Lower determines the deviation (from the equal-tempered scale) in the bass 

end of the sound. The higher the value, the further down the low notes are tuned. A 
setting of 0 results in an equal-tempered scale tuning. 

Â The Stretch Upper parameter does the same in the treble end of the sound. 

Hermode Tuning (HMT)
As all tuning requirements cannot be satisfied simultaneously with any one Hermode 
Tuning setting, different modes can be selected in the Type menu. Further to this, 
degrees of effect between 0% and 100% can be set with the Hermode Tuning Depth 
slider.

You can choose between the following settings in the Type menu:
Â Classic (3/5–all):  This mode proves a broad, and regular, tuning of pure 5ths and 3rds. 

In cases of conflict, the degree of purity is temporarily reduced. This mode can be 
used for all types of music. The value of the Depth parameter indicates the degree of 
the 5th and 3rd purity. A setting of 100% determines maximum purity. A 10% value is 
the lowest purity setting. Off sets the tuning to an equal tempered scale.

Â Pop/Jazz (3/5/7–all):  5ths, 3rds, and 7ths are changed in this mode. It is great for Pop 
and Jazz styles, especially when using sustained chords. It is less suitable for 
polyphonic music, as the de-tuning of the natural 7th is significant. This mode should 
always be used with a Depth of 90% or 100%, as other values will render the natural 
7th acoustically ineffective.

Â Baroque (3/5–adaptive):  This mode tunes pure 5ths and 3rds—with changing 
characteristics. In tonal music, with a clear harmonic center, the middle chords are 
tuned very purely, whereas more distant chords are tuned with less purity. If the 
harmonic center becomes unclear, all chords are tuned with equal purity. As with the 
other mode parameters, a Depth value of 100% determines the highest purity, and a 
value of 10%, the lowest purity. 
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Audio Settings
The Audio project settings determine audio-specific project parameters.

Automatic Management of Channel Strip Objects
This option (active by default) makes setting up, and using, tracks and channel strips a 
transparent experience. It automatically creates and manages channel strips when new 
tracks are created. You should only deactivate this setting when you need to make 
manual changes to channel strips in the Environment window.

Playback Pre-Roll
When this option is enabled, all start commands force Logic Pro to start playback a 
little earlier (shifted to the left). The exact pre-roll value is dependent on the current 
delay compensation value for plug-ins. This option ensures that transients which fall 
exactly on the start position are played back correctly. If this option is disabled, 
transients that fall precisely on the start position can be missed, or seem to fade in.

Sample Rate
Choose the desired sample rate for the project in this pop-up menu.

Pan Law
The Pan Law value determines the amount of volume reduction on signals that are 
panned to the center position. You can choose from the following settings:
Â 0 dB:  Signals will seem louder when panned to the center position, in comparison 

with extreme left or right pan positions. 
Â –3 dB:  A full scale signal (0 dBfs) will have a level of –3 dB when panned to the 

center position. 
Â –3 dB compensated:  A full scale signal (0 dBfs) will have a level of 0 dB when panned 

to the center position (or +3 dB when panned to extreme left or right positions). 

Surround Format
Choose the desired surround format for the project in this pop-up menu.
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MIDI Settings
The MIDI project settings determine the behavior of the MIDI inputs and outputs. The 
MIDI project settings comprise the General, Input Filter, and Chase tabs.

General Tab

Send After Loading Project
Â Used instrument MIDI settings checkbox:  Sends the active instrument MIDI settings 

automatically after loading a project (see “Adding Program Change, Volume, and Pan 
Settings to a MIDI Region” on page 246).

Â All fader values checkbox:  Sends all Environment fader values automatically, once a 
project is loaded.

Scrubbing with Audio in Arrange
You must enable this setting if you want to simultaneously scrub MIDI and audio 
regions in the Arrange window.

SysEx with MIDI Thru function
Incoming SysEx messages are passed through the computer to the MIDI outputs, along 
with other MIDI data. This is particularly important when using hardware programmers, 
as you can immediately monitor parameter changes to the synthesizer you are editing. 

If you want to record SysEx dumps, do not select this checkbox. It rarely makes sense to 
divert dumps through the computer unless you want to record a dump, and 
simultaneously transmit it to a second device of the same type.

Instrument Without MIDI Thru Function
The instrument selected here will not pass events through the computer, when the 
instrument is assigned to the selected Arrange track. Normally, you would set the No 
Output instrument here (it is chosen by default).
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If your master keyboard does not have a Local Off setting, you can use this feature to 
avoid unwanted note doubling when recording:
Â With multi timbral sound sources, assign the instrument (usually channel 1) which 

plays the part that is heard when playing with the computer turned off.
Â With mono timbral sound sources, assign the instrument which represents the sound 

generating part of your master keyboard.

In either case, you should turn down the volume control of your master keyboard 
whenever you are recording tracks for any other instrument.

It is possible to disable MIDI Thru for any MIDI track in the Arrange window, by simply 
disabling the Record Enable button beside the track name.

Input Filter Tab
The Input Filter tab is used to screen certain event types at the sequencer input. For 
further information on the individual checkboxes, see “Filtering MIDI Input” on 
page 383.

Chase
The Chase MIDI project settings tab (see “Using the Chase Events Function” on 
page 115) offers a number of checkboxes that determine which event types are chased. 
If a checkbox is ticked, it indicates that chase events is activated for that event type. 

Score Project Settings
All Score project settings are described in “Project Settings for Score Display” on 
page 776.

Video Project Settings
All Video project settings are described in “Video Project Settings” on page 803.

Assets Project Settings
The project assets refer to all audio files, EXS instruments, and other data associated 
with the project. Ideally, you should save all project assets with the project file, but may 
prefer not to. Full details on project handling, including information on the Assets 
project settings, is found in “Working With Projects” on page 135.
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Preferences
The settings made in the Preferences window are saved in a general preference file, 
stored in the ~/Library/Preferences/Logic folder. Preference settings apply to all 
projects.

A separate preference file, also stored in the same location, is made for control surfaces.

Note:  You can’t open either preference file directly. Any changes must be made in 
Logic Pro.

If you accidentally or intentionally erase the preference files, Logic Pro will create new 
preferences files the next time it is opened. All parameters will be reset to their default 
values. 

To initialize all preferences (but not your key commands) directly in Logic Pro:
m Choose Preferences > Initialize All Except Key Commands (or use the corresponding 

key command).

Global Preferences
The Global preferences contain the Project Handling, Editing, Cycle, Catch, and Caps 
Lock Keys tabs. 

To open the Global preferences, do one of the following:
m Choose Logic Pro > Preferences > Global (or use the corresponding key command). 

m Click the Preferences button in the Arrange Toolbar, and choose Global from the pop-
up menu.

∏ Tip:  You can also use the default Open Preferences key command to open the 
Preferences window (the most recently accessed preference pane is shown).

Project Handling Preferences
The Project Handling preferences determine how Logic Pro handles projects.
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Startup Action
The Startup Action menu allows you to choose from a number of project options—that 
happen automatically when Logic Pro is opened. You can choose from:
Â Do Nothing:  As the name suggests, this does nothing. Logic Pro is opened and 

requires you to create a new project, or open an existing project or template.
Â Open Most Recent Project:  Automatically opens the project you were working on 

when you last closed Logic Pro.
Â Open Existing Project:  Automatically shows the Open dialog, allowing you to browse 

for an existing project.
Â Create New Project from Template:  Automatically opens the Templates dialog.
Â Create New Empty Project:  Automatically loads an empty project and opens the Save 

As dialog, allowing you to name and save your project. 
Â Create New Project using Default Template:  Automatically opens the default template, 

and launches the Save As dialog, allowing you to name and save your project. 

You can determine the default template by clicking the Choose button below the 
Default Template field. The full path and name of the chosen template or project is 
displayed in the Default Template field. You can assign any template or project as the 
default template.

When Opening a Project, Ask to “Close Current Project(s)?”
Whenever you load a new project before closing the old one, a dialog box will appear, 
and ask whether or not the current project should be closed. If this option is left 
unchecked, you will not be asked the question, and the current project will remain 
open.

‘Export MIDI File…’ Saves Single MIDI Regions as Format 0
If only one MIDI region is selected when you make use of the File > Export > Selection 
as MIDI File command, the contents of the region are saved in MIDI file format 0. This 
file format is guaranteed to be compatible with every MIDI file player.
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Editing Preferences

Â Right Mouse Button:  This pop-up menu determines the right mouse button behavior, 
assuming you have a suitable mouse. By default, this is assigned to Opens Shortcut 
Menu (which can also be accessed by Control-clicking with the left mouse button). 
The Is Assignable to a Tool setting allows any tool to be assigned to the right mouse 
button. The Opens Tool menu setting does just that, when the right mouse button is 
clicked.

Â Limit Dragging to One Direction In: Piano Roll and Score:  When this checkbox is turned 
on, you can only move notes in one direction (horizontally or vertically), per 
operation, when editing in the Piano Roll or Score Editors. This means that a note 
may be either transposed, or moved in time, but not both at once. This prevents 
accidental alterations of one or the other parameter.

Â Limit Dragging to One Direction In: Arrange:  This restricts the direction you can move 
regions (including folders) in the Arrange area, in a similar way to, and for the same 
reasons, as the option above.

Â Double-clicking a MIDI Region opens:  This menu determines the editor that is opened 
when you double-click on a MIDI region in the Arrange area. Settings are the Score, 
Event, Piano Roll (default), and Hyper Editors.

Â Number of Undo Steps:  Determines the number of undo steps. 
Â Add ‘Last Edit Function’ to Region Name:  After performing any edit operation (cutting, 

for example), the description of the edit operation is added to the name of the 
region (or resulting regions).

Â ‘Living Groove’ Connection:  When active, this option breaks the living connection 
between a MIDI region and a quantization template derived from it (if applicable). If 
the MIDI region is edited, this has no effect on the quantization template. If there is 
no check in the box, editing the original MIDI region will also alter the quantization 
template, which will in turn affect all MIDI regions that are quantized with this 
template.

Â SmartLoop handling of Scissor and ‘Split by Playhead’:  This option determines how 
Logic Pro handles the cutting of looped regions. 
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Â If you activate the option, you can cut the looped area of regions (using the 
Scissors or Marquee tool, or Split by Playhead commands). Logic Pro automatically 
creates regions after—and, if necessary—before the cut, ensuring that these areas 
remain identical. This allows you to split looped regions without altering playback 
in the looped area. 

Â If the “SmartLoop handling of Scissor and Split by playhead option is switched off, 
you can not cut looped areas. Cutting the looped region itself deactivates the Loop 
parameter in the Region Parameter box. 

Cycle Preferences

Â Cycle Pre-Processing:  In order to ensure a smooth cycle jump (from the end point of a 
cycle back to the start point of a cycle), the cycle jump is processed slightly before its 
actual position. This preference allows you to change the pre-processing time. A 
value of 1/96 is chosen by default, which should be suitable for most uses.

Â Smooth Cycle Algorithm:  This improves the timing of cycle jumps, making it easier to 
set the length of sample loops while in Cycle mode—although this is somewhat 
mitigated through the use of Apple Loops. If your computer has a very slow CPU, this 
setting reduces the processing requirements for graphic operations. In general, you’ll 
want to keep this on, whenever possible, especially if you’re working in a style which 
involves frequent cycling of musical sections. If you find that your cycled sections are 
not as smooth as you’d like (assuming that your loops are actually perfect), you 
might achieve better results by disabling this parameter.
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Catch Preferences

Â Catch when Logic starts:  Every time you start playback (including paused playback), 
the Catch function is automatically switched on, in all windows. 

Â Catch when moving playhead:  Activation of this option ensures that whenever you 
move the playhead, the Catch function is automatically switched on. This makes it 
easier to perform edits—as moving the playhead in the Arrange will be reflected in 
the open editor window, and vice-versa.

Â Catch content by position if Catch and Link are enabled:  If the Catch and Link buttons 
are active (Content Catch mode), the contents of the region at the current playhead 
position are shown. If this option is turned off, the window view still follows the 
playhead position within the displayed region, but does not update to show the 
contents of subsequent regions as the playhead passes them (in play or record 
mode).

Caps Lock Keys Preferences
Full details on the use of your computer keyboard for MIDI note entry is discussed in 
“Using the Caps Lock Keyboard” on page 389. The Caps Lock Keys preferences are 
covered in “Caps Lock Keyboard Preferences” on page 390.

Audio Preferences
The Audio preferences contain the following tabs:
Â Devices
Â General 
Â Sample Editor
Â Surround
Â MP3
Â Reset
Â Nodes
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To open the Audio preferences, do one of the following:
m Choose Logic Pro > Preferences > Audio (or use the corresponding key command). 

m Click the Preferences button in the Arrange Toolbar, and choose Audio from the pop-up 
menu.

Device Preferences
The Device preferences determine how your audio interface hardware is addressed by 
Logic Pro. Details are found in “Configuring Your Audio Hardware” on page 96.

General Audio Preferences

Display Audio Engine Overload Message
If switched off, playback will simply stop in an overload situation instead of displaying 
an alert box.

Open Plug-in Window on Insertion
With this setting on, the window of an effect or software instrument plug-in is 
automatically opened after inserting it in the appropriate channel strip slot.

Track Mute/Solo
This menu determines the linking relationship of the Track Mute and Solo buttons with 
the corresponding channel strip buttons. 
Â Fast (Remote Channel Strips):  Clicking a channel strip’s Mute or Solo button switches 

the state of the associated track button, and vice-versa. 
Â CPU-saving (Slow Response):  Choose to save processing resources, and to make the 

track Mute and Solo buttons independent of the corresponding channel strip 
buttons.
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Sample Accurate Automation
As the name implies, sample accurate automation is the most precise type of 
automation. It places higher overheads on system resources, which may affect 
performance (dependent on the nature of your projects, and available computing 
power). This is most likely to happen during heavy project sections—where a lot of 
software instruments and effects are in use. Logic Pro offers three settings:
Â Off:  Minimal overhead on system performance for automation playback. Automation 

is less precise when this setting is active.
Â Volume, Pan, Sends:  Only these parameters are automated with sample accuracy.
Â Volume, Pan, Sends, Plug-in Parameters:  All of these parameters are automated with 

sample accuracy. Please note:  Not all Audio Unit plug-ins can be automated in this 
way.

Recording File Type
Lets you the determine the file type for recorded audio. The settings are:
Â SDII:  The SDII (Sound Designer II) file format can not handle audio recordings larger 

than 2 GB.
Â AIFF:  The AIFF file format can not handle audio recordings larger than 2 GB. 
Â WAVE (BWF):  Most common audio format on Windows PCs. Files are stored as 

Broadcast Wave files, which contain time stamp information in the file header. The 
WAV file format can not handle audio file recordings larger than 4 GB:

Â CAF:  Choose this setting if you are going to record files larger than 4 GB in size. For 
more information, see “Maximum Recording Size” on page 359.

Dim Level
This slider enables you to set a discrete level for the Dim function, accessible with the 
Master Level slider on the Transport. You can set a dim level from 0 dB to –30 dB. The 
level chosen here is used when the Dim function is activated.

Plug-in Delay Compensation
Plug-in delay compensation is useful for software effect plug-ins, and is particularly 
important for DSP accelerator hardware (TC PowerCore, Universal Audio UAD-1, as 
examples). It compensates for audio delays that can be introduced when using plug-
ins. 

A pop-up menu allows you to activate plug-in delay compensation for either:
Â Audio and software instrument tracks.
Â All (Audio, instrument, auxiliary, and output channels).

You can also turn off compensation entirely. Details are found in “Working With Plug-in 
Delay Compensation” on page 849.
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Low Latency Mode Checkbox and Limit Slider
You need to turn on the Low Latency Mode checkbox, in order to activate Low Latency 
mode, and to use the Limit slider. The Limit slider determines a maximum amount of 
allowable delay that can be caused by plug-ins when Low Latency mode is enabled (by 
clicking the Low Latency Mode button on the Transport). In Low Latency mode, plug-
ins are bypassed, to ensure that all delays (across the entire signal flow of the current 
track) remain under the Limit slider value. This is useful when you want to play a 
software instrument with several latency-inducing plug-ins inserted in the channel. For 
more information, see “Working With the Low Latency Mode” on page 848.

Crossfade Time
Determines a default time value for all crossfade operations in the Arrange area.

Crossfade Curve
Determines a global curve type for all crossfade operations in the Arrange area.

Sample Editor Preferences

Â Warning before processing function by key command:  Switch this on if you want to be 
warned before carrying out a destructive edit in the Sample Editor—using a key 
command. This gives you the opportunity to cancel the edit operation, before 
altering the data.

Â Clear Undo History when quitting:  Switch this on to automatically delete the Undo 
History for all edited audio files, when you close Logic Pro.

Â Record selection changes in Undo History:  Switch this on if you wish to undo and redo 
changes to selected areas in the Sample Editor.

Â Record Normalize operations in Undo History:  Disable this setting if you don’t want to 
create undo files once the Normalize function is invoked. 
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Â Number of Undo Steps:  Determines the maximum number of undo steps that are 
retained. 

Â Store undo files in project folder:  Activate this preference if you would like the edited 
audio files to be stored in a sub-folder of the current project. This is switched on by 
default if the project is saved with its assets.

Â Global Undo File Path:  All files (used by the Undo History) are saved into a global 
location—a user-defined folder—if the “Store undo files in project folder option” is 
not switched on. Click the Set button, and browse to the desired folder.

Â External Sample Editor:  You can use an external application for sample editing 
operations, effectively replacing the Logic Pro Sample Editor. Click the Set button, 
and browse to the desired application.

Surround Preferences
The Surround preferences are covered in “Setting the Surround Preferences” on 
page 812.

MP3 Preferences

Â Bit Rate (Mono/Stereo):  The bit rates are selectable between 32 kbps and 320 kbps, 
but default to 80 kbps mono, and 160 kbps stereo. These rates offer acceptable 
quality and good file compression. If you can afford the extra file size, you should 
select 96 kbps for mono, and 192 kbps for stereo streams. These will deliver better 
audio quality. You can, of course, choose even higher rates, but the quality 
improvement in bit rates above 96/192 kbps is minimal.
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Â Use Variable Bit Rate Encoding (VBR):  Variable Bit Rate encoding compresses simpler 
passages more heavily than harmonically rich passages, generally resulting in better 
quality MP3s. Unfortunately, not all MP3 players can accurately decode VBR-encoded 
MP3s, which is why this option is off by default. If you know that the audience for 
your MP3 can decode VBR-encoded MP3s, you can switch this option on.

Â Quality:  Keep this set to Highest whenever possible. Reducing the quality will 
accelerate the conversion process, but at the expense of audio quality. This option is 
only accessible when the VBR checkbox is turned on.

Â Use Best Encoding:  Again, like the Quality parameter, if you uncheck this option, you 
will gain encoding speed at the price of audio quality. This should always be left on, 
unless conversion time is an issue.

Â Filter Frequencies Below 10 Hz:  When this option is checked, frequencies below 10 Hz 
(which are usually not reproduced by speakers, and are not audible to human ears at 
any rate) are removed, leaving slightly more data bandwidth for the frequencies 
which humans can hear, resulting in an improvement in perceived quality. Only 
uncheck this option if you’re experimenting with subsonic test tones, or exporting 
MP3s for whales.

Â Stereo Mode:  You can choose between Joint Stereo or Normal Stereo in this pop-up 
menu. Depending on the original file, these settings may (or may not) offer any 
audible difference. Experiment with both settings to determine your preference.

Reset Preferences
Activate the appropriate checkboxes for “Control 64 off (Sustain)”, “Control 1 
(Modulation) to zero”, and “Pitch Bend to center position” to send reset messages of the 
specified type to all active instrument channels.

This can be useful if you are encountering hung notes, or are finding that controller 
settings are incorrect when in Cycle mode (or when returning to the beginning of a 
section or the project start point).

Node Preferences
The Node preferences are covered in “Enabling Distributed Audio Processing” on 
page 101.
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MIDI Preferences
These tabs determine how Logic Pro communicates with your MIDI interface and other 
applications or devices. All active Core MIDI drivers are automatically made available to 
Logic Pro. There is no need for further settings. 

To open the MIDI preferences, do one of the following:
m Choose Logic Pro > Preferences > MIDI (or use the corresponding key command). 

m Click the Preferences button in the Arrange Toolbar, and choose MIDI from the pop-up 
menu.

General Preferences

Â External stop message ends recording:  If you are using external synchronization, and 
the time code stops while recording, record mode is switched off. If this checkbox is 
turned off, Logic Pro stops, but remains in record mode (record mode is paused).

Â Always stop when opening project:  With this setting on, a project will always be 
opened in stop mode, even if it was saved in play mode.

Â Reset All MIDI Drivers:  Click to reset all MIDI drivers. This can help if you experience 
MIDI communication problems.
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Sync Preferences

Â All MIDI Output Delay field:  Delays or advances the MIDI output for all ports, allowing 
you to compensate for any timing differences between MIDI tracks and audio or 
(software) instrument tracks. 

Â MIDI Clock: Allow Song Position Pointer while playing:  Song Position Pointer data is not 
normally sent while the sequencer is in play mode (this is in accordance with the 
MIDI Standard). This option allows Logic Pro to send SPP while the sequencer is 
running. The advantage is that external devices can also follow Logic Pro in Cycle 
mode. If your external devices cannot process SPP, you should switch this option off. 
If your devices can follow MTC (MIDI Time Code), you should leave this option 
unchecked, and use the MTC functions of Logic Pro.

Â MTC Pickup Delay:  This parameter should generally be set to zero, to ensure the 
quickest possible pickup time while Logic Pro is in MTC (MIDI Time Code) sync mode. 
There are, however, some devices which seem to transmit imprecise MTC commands 
when first started. As a result, synchronization may be unreliable, and there could be 
an offset every time synchronization is established. In such situations, you can set a 
delay time before incoming MTC is picked up. Essentially, Logic Pro will ignore the 
incoming MTC commands that occur in this time period. A (frame) value of 25 to 30 
corresponds to a delay of about a second, depending on the frame rate. Use this 
parameter when synchronized to hard disk recorders and other devices, if 
synchronization doesn’t appear to be consistent.

Â Delay MTC Transmission by:  This parameter allows you to delay the transmission of 
MIDI time code. Negative values result in MTC being transmitted earlier. This facility 
enables you to compensate for any reaction delays (to incoming MIDI time code) in 
external MTC slave devices.

Â MMC Uses:  This menu allows you to choose between the following settings:
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Â MMC standard messages:  The MIDI MMC specification is strictly followed.
Â Old Fostex Format:  The old Fostex format is used for MIDI Machine Control. 

Â Output ID (Transport):  The All checkbox sends MMC to all ports. The field to the right 
allows you to specify an output port ID. 

Â Input ID (Transport):  The All checkbox sends MMC to all ports. The field to the right 
allows you to specify an input port ID. 

Â Transmit Locate Commands When: Pressing Stop twice:  This checkbox enables 
transmission of MMC Locate commands when the Stop command is pressed twice 
(on the Transport Stop button, or with the Stop key command).

Â Transmit Locate Commands When: Dragging regions or events:  If this option is enabled 
and Logic Pro is stopped (not in Play or Record mode), MMC locate commands are 
sent with the position of a region that is dragged in the Arrange area. 

Â Transmit Record enable commands for audio tracks:  If this option is enabled, MMC 
record enable/disable commands are also sent when audio tracks are record enabled 
(armed) or disabled. In addition, any received MMC Record enable commands will set 
the record enable status of audio tracks.

Â MIDI Sync Project Settings:  Click this button to open the MIDI Sync Project Settings 
window.

Reset Messages Preferences 
This tab is only included for compatibility with older MIDI hardware. Logic Pro handles 
MIDI Reset Messages automatically and intelligently, so you should generally make sure 
that all of these options are switched off (this the default).

All selected checkboxes will send a reset message—for the selected controller type—to 
all MIDI outputs. This reset message is sent on cycle jumps and when playback begins, 
but the use of these options shouldn’t be necessary. 
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Display Preferences
These preferences alter the general appearance of Logic Pro.

To open the Display preferences, do one of the following:
m Choose Logic Pro > Preferences > Display (or use the corresponding key command). 

m Click the Preferences button in the Arrange Toolbar, and choose Display from the pop-
up menu.

General Preferences
This tab allows you to alter the appearance of several onscreen components that are 
used throughout the program.

Windows Section
Â Large local window menus:  The title and items of the local menus are displayed in the 

normal System font. If unchecked, a smaller font is used.
Â Wide Playhead:  A thicker playhead is used in all windows.
Â Show Help Tags:  This enables help tags throughout Logic Pro. As the mouse cursor 

hovers over parameters and tools, a small pop-up description (and/or value) of the 
item will appear onscreen. When editing, the function name, region or event name/
number, position and parameter values are shown.

Â Show default values:  When enabled, this option will display default values for 
parameters in help tags. This makes it easier to determine the amount of variance 
from the default value.
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Level Meters Section
Â Scale menu:  Switches level meters between a Sectional dB-linear scale, and an 

Exponential scale. Exponential provides higher display resolution in the upper range 
of the meter. Sectional dB-linear provides the best possible display resolution across 
the entire level range.

Â Channel Order menu:  Determines the order of channels in multi-channel (surround) 
level meters.

Displays Section
Â Display Middle C As Menu:  This menu affects the description of notes in the editors. 

The bottom C on a five-octave keyboard (note # 36) is labeled C1, and middle C (note 
# 60) is labeled C3. According to this standard, the lowest MIDI note (note # 0) is 
called C –2. This is the official standard used by most manufacturers. Use of the C3 
(Yamaha) setting will set Logic Pro to this standard mode. Should you select the C4 
(Roland) setting, the bottom C on a five-octave keyboard is labeled C2, and middle C 
is labeled as C4. In this standard, the lowest MIDI note is C –1.

Â Display SMPTE Menu, Display Tempo As, and Clock Format Menu:  You can use these 
menus to customize the Bar, SMPTE, and Tempo display in the Transport bar. For 
further details, see “Customizing the Bar, SMPTE, and Tempo Display” on page 121.

Arrange Preferences
These preferences specifically affect the appearance of the Arrange area.

Â Background Color:  Choose one of three Arrange background color settings:  Dark, 
Bright, and Custom. When the latter is chosen, you can set the custom color by 
clicking the color field to the right. This will open the Colors window, where you may 
define a custom color for the Arrange background.

Â Automation Transparency: Regions:  Higher values increase the color intensity of 
regions—in comparison to the track automation lane.

Â Automation Transparency: Other Data:  Brightens the display of (non-active) 
automation data. Note that this functionality is dependent on the zoom level of the 
region.
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Other Preferences
These preferences affect the appearance of specific windows.

Environment:  Allow ‘All Objects’ Layer
A layer, showing every object in your Environment, is accessible from the Layer menu in 
the Environment. If this checkbox is not active, the All Objects layer will not be 
available.

Piano Roll Background Colors:  Background Type
These radio buttons allow you to select a dark or bright Piano Roll Editor background 
color. 

Piano Roll Background Colors:  Color Setup Panel
The Piano Roll Editor features a grid that follows the pattern of the keyboard keys 
shown on the left hand side. The parameters in this recessed panel can alter the colors 
of the Piano Roll Editor grid, background, lines, and so on—for both the bright and 
dark background views.
Â White Keys:  Double-click on the color field to open the Colors window. Select or 

determine the desired color for the grid lines, aligned with the white keyboard keys.
Â Black Keys:  As above, for the black keyboard keys.
Â C, D, E Key Brightness:  This slider allows you to intensify the brightness of these 

specific keys in all octaves, making transposition easier by providing a consistent 
reference point.

Â Bar Lines/Dotted:  Determines the transparency of the bar lines. The Dotted checkbox 
changes the appearance of the solid bar line to a dotted line.

Â Beat Lines/Dotted:  As above for beat lines.
Â Division Lines/Dotted:  As above for division lines.
Â Reset:  This button resets all user changes to default values.
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Score Preferences
The Score Preferences are described in detail in the Score chapter (see “Score 
Preferences” on page 795).

Video Preferences
All Video preferences are covered in the Video chapter (see Chapter , “Video 
Preferences,” on page 805).

Automation Preferences
The Automation preferences globally affect all automation tracks.

To open the Automation preferences, do one of the following:
m Choose Logic Pro > Preferences > Automation (or use the corresponding key 

command).

m Click the Preferences button in the Arrange Toolbar, and choose Automation from the 
pop-up menu.

Â Move Automation with Regions:  Determine what happens to track automation data 
when you move regions. You can choose between Never, Always, and Ask.

Â Snap Offset:  This parameter enables a specific number of ticks to be added to, or 
subtracted from, the current snapped position of all automation data (as set in the 
Arrange window Snap menu).

Â Ramp Time:  Determines the time required by a parameter to return to its previously 
recorded setting.

Â ‘Write’ Mode Changes To:  Determines the mode that faders automatically switch to 
once track automation data recording has been completed. 

Â Write Automation for:  The checkboxes in this section determine the types of track 
automation data that can be written in Touch, Latch, and Write modes.

Â Automation Quick Access:  These parameters are discussed in detail in the Automation 
Quick Access section (see “Using Automation Quick Access” on page 595).
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Control Surfaces Preferences
The Control Surface preferences are discussed in the Control Surfaces Support 
document.

Sharing Preferences
The Sharing preferences are covered in “Setting Sharing Preferences” on page 626.
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AAC  Abbreviation for Advanced Audio Codec. A compression and decompression 
algorithm and file format for audio data.

AAF  Abbreviation for Advanced Authoring Format. A cross-platform project exchange 
file format that you can use to import multiple audio tracks, inclusive of references to 
tracks, time positions, and volume automation.

accelerando  A gradual increase in tempo (see tempo).

AD converter or ADC  Short for analog to digital converter; a device that converts an 
analog signal to a digital signal.

ADAT  Abbreviation for Alesis Digital Audio Tape. The ADAT is an eight track digital 
multitrack cassette recorder that uses an S-VHS video tape to record audio at 16 or 
20 bit depth.

ADAT optical  Optical interface for parallel transmission of eight audio channels via 
fiber-optic cable. It is a well-established standard for digital multi-channel interfaces. 

AES/EBU  Short for Audio Engineering Society/European Broadcasting Union. This 
association has a standard transmission format for professional stereo digital audio 
signals called AES/EBU. The format is similar to S/P-DIF, but uses balanced line drivers at 
a higher voltage. Depending on the type of devices involved, AES/EBU and S/P-DIF 
coaxial interfaces can communicate directly.

aftertouch  MIDI data-type generated by pressure on keys after they have been struck. 
There are two types:  Channel aftertouch, the value of which is measured by a full 
length keyboard sensor. It affects all played notes. Polyphonic aftertouch (rare) is 
individually measured and transmitted for each key. Aftertouch is also known as key 
pressure or pressure sensitivity. 

AIFF  Abbreviation for Audio Interchange File Format. A cross-platform file format 
supported by a large number of digital audio and video editing applications. AIFF 
audio can use a variety of bit depths, most commonly 16 and 24 bit. 

AKAI  Common sample data format that the EXS24 mkII is compatible with.
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ALAC  Abbreviation for Apple Lossless Audio Codec, an encoding/decoding algorithm 
that delivers lossless audio compression.

alias  A pointer to a MIDI region in the Arrange area. An alias does not contain any 
data. It simply points to the data of the original MIDI region. You can create an alias by 
Shift-Option-dragging the original MIDI region to a new location. An alias can not be 
edited directly. Any change to the original region will be reflected in the alias. 

aliasing  A digital artefact that occurs when the sample material contains frequencies 
higher than one-half of the sample rate. 

amplifier  Device which increases the level of a signal.

amplitude  This term is used to describe the amount of a signal. If you have an audio 
signal, amplitude refers to the volume of the sound, measured in decibels (dB).

amplitude peak  The loudest point of an audio signal.

analog signal  A description of data that consists of an endlessy varying voltage level, 
that represents audio information. Analog signals must be digitized, or captured, for 
use in Logic Pro. Compare with digital.

anchor point  The start point of the audio file that an audio region is based on. Also 
see Sample Editor.

Apple Loops  An audio file format, commonly used for recurring rhythmic musical 
elements or elements suitable for repetition. Apple Loops contain tags and transients 
that are used by Logic Pro for time stretching and pitch shifting tasks. These tags also 
allow you to quickly locate files by instrument, genre, or mood in the Loop Browser.

Apple Loops Utility  The Apple Loops Utility allows you to create your own Apple 
Loops. To use the Apple Loops Utility, select an audio region in the Arrange and choose 
Audio > Open in Apple Loops Utility. 

Arrange area  The primary working space of Logic Pro. It is used to record, edit, move, 
and arrange the audio and MIDI regions of a project. Also used for automation 
recording and playback.

Arrange window  The primary working window of the application. It also shows the 
Arrange area (see above), and can incorporate all other working areas and editors. 

ASCII  Acronym for American Standard Code for Information Interchange. Standard 
computer character set, allowing computers to deal with text characters. When you 
type ASCII characters from the keyboard, the computer interprets them as binary so 
they can be read, manipulated, stored, and retrieved. Also see scan code.

attack  Start phase of a sonic event. Also part of an envelope (see envelope).
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attenuate  The act of lowering the level of an audio signal (see boosting and cutting).

Audio Bin  Window (or tab in the Media area of the Arrange window) used for project 
audio file and region management, and conversion, tasks. See Media area.

audio file  Any digital recording of sound, stored on your hard drive. You can store 
audio files in the AIFF, WAV, Sound Designer II (SDII), and CAF formats in Logic Pro. All 
recorded and bounced WAV files are in Broadcast Wave format.

audio interface  Device used to get sound into and out of your computer. An audio 
interface converts digital audio data, sent from your computer, into analog signals that 
speakers can broadcast. In the other direction, an audio interface converts analog 
signals (such as a vocal performance) into digital audio data that can be understood by 
your computer.

Audio MIDI Setup (AMS)  The Audio MIDI Setup (AMS) utility is used to configure the 
audio and MIDI input and output devices connected to your computer. Logic Pro uses 
the settings defined in the Audio MIDI Setup utility, which can be found in the 
Applications/Utilities folder. 

audio region  Chosen area of an audio file which can be placed on audio tracks in the 
Arrange, just like a MIDI region can be placed on MIDI tracks. Audio regions are aliases 
(or pointers) to portions of audio files. They can be as short as a single sample, or the 
full length of the underlying audio file. Logic Pro allows you to edit audio regions 
without affecting the original audio file. Also see region and MIDI region.

audio track  A track in the Arrange window that is used for playback, recording, and 
editing of audio regions. It is routed to an audio channel in the Mixer.

audio channel strip  Channel strip in the Mixer, used as a target for audio tracks in the 
Arrange. All data on the audio track is automatically routed to the audio channel strip 
that was assigned in the Arrange track list.

Audio Units (AU)  Audio Units is the standard Mac OS X format for real time plug-ins. It 
can be used for audio effects, software instruments, and Generators. The Audio Unit 
format is incorporated into the operating system, and installed Audio Unit plug-ins can 
be simultaneously accessed by all applicable programs. Logic Pro supports all Audio 
Unit format plug-ins.

Auto Track Zoom  Function in the View menu that automatically enlarges the currently 
selected track.

Autopunch button  Button (with the up/down arrows) in the Transport, used to 
activate the Autopunch function.



974 Glossary

Autopunch function  Autopunch refers to an automatic entry and exit of record mode 
at predefined positions. Autopunch mode is most commonly used to re-record a badly 
played section of an otherwise flawless recording. The advantage is that you can 
concentrate on playing, not the mechanics of driving Logic Pro. Autopunch is activated 
by clicking the Autopunch button in the Transport bar. 

automation  Automation is the ability to record, edit, and play back the movements of 
all knobs, controls, and buttons, including:  volume faders, pan, EQ, and aux send 
controls, plus most effect and instrument plug-in parameters.

aux channel (strip)  Aux channels are found in the Mixer (and to the left of the Arrange 
window), and can be used as send/returns (buses) and sub-group controls. 

Balance control  Rotary knob directly above the Level fader of stereo channels. It 
controls the relative level of the left and right signals at their outputs.

bar  In musical notation, a bar is a measure that contains a specified number of beats, 
and establishes the rhythmic structure of a musical piece.

Bar ruler  Ruler found at the top of the Arrange, Piano Roll, Hyper, and Score windows. 
It displays musical time units, including:  bars, measures, beats, and beat divisions. It is 
used to set and display the project position, the cycle and autopunch locators. Also see 
playhead, Cycle, and Autopunch.

batch tagging  The process of simultaneously tagging (marking) several audio files in 
the Apple Loops Utility.

bass  A musical instrument. The term also refers to low frequency sounds or 
components within a sound. See frequency.

beat  A musical time interval:  “The beat is the regular rhythmic pulse in a composition 
that people tap their feet to.” Usually a quarter note.

Beat Mapping track  Global track used to analyze audio or MIDI regions, and create 
tempo events based on note or transient events in these regions. This allows you to 
more easily synchronize existing free recordings (those made without a metronome 
click) in other projects.

beats per minute  See bpm.

Bezier curve  A curve created from a line that contains two points. These points affect 
the line, allowing it to be pulled into a curve. In a computer application, Bezier curves 
are created by moving handles at these two points, thus adjusting the curve shape. 
Named after Pierre Bezier, who discovered the mathematical formula for these curves. 
In Logic Pro, Bezier curves are used to adjust automation curves, for example.
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binaural hearing  A description of the way human beings process audio positioning 
information, allowing the direction of a signal source to be recognized (in front, behind, 
above, below, and to the left or right of the listening position). 

binaural panning  A process that emulates binaural hearing.

bit depth  The number of bits used by a digital recording or digital device. The number 
of bits in each sample determines the (theoretical) maximum dynamic range of the 
audio data, regardless of sample rate. 

bit rate  Bit rate, when talking about MP3 files, refers to the transfer bit rate at which 
the files are encoded. Conversationally, the term is more often used to describe the 
relative quality of the file, with lower bit rates resulting in less defined audio.

bit resolution  Alternative term for bit depth. See bit depth and sample rate entries.

boosting  The act of raising an audio level (see cutting). 

bounce  To process MIDI or audio regions with any applied effects, such as delay or 
compression, and combining them into one audio file. In Logic Pro, you can choose 
between real time and offline bouncing. Offline bouncing is faster, but doesn’t allow 
you to apply live automation or record real time audio input. You may also bounce to 
several files when performing a Surround bounce. See Surround.

Bounce button  You can bounce the output of any output channel to an audio file by 
clicking the Bounce button. Also see bounce.

bpm  Abbreviation for beats per minute, a measure of the tempo of musical piece. As 
an example:  120 bpm means that in one minute, there will be 120 musical beats 
(quarter notes).

Broadcast Wave  See Wave.

Browser  A Logic Pro window (or tab in the Media area of the Arrange window) used to 
browse, select, and manage all media types supported by Logic Pro. Also see Media 
area.

bus  Busses are used to send audio to aux channel strips for processing or submixing 
tasks. 

bus channel strip  The bus channel type is primarily included for backwards 
compatibility with older Logic Pro versions. The bus channel strip functions of earlier 
versions are performed with aux channel strips in Logic Pro 8.

bypass  To deactivate a plug-in. Bypassed plug-ins do not drain system resources. In 
Logic Pro you can bypass a plug-in by either clicking its Bypass button in the plug-in 
window or by Option-clicking on the appropriate plug-in slot of a channel strip.
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cable  In Logic Pro, the term is used to describe the virtual cables that represent a MIDI 
connection between Environment objects.

CAF  Abbreviation for Core Audio Format. This file format can be used as a container for 
compressed or uncompressed audio files of (almost) any size, sample rate, or bit depth. 
The CAF file format can handle audio recordings of around 3 hours in length (at a 
44.1 kHz sample rate—shorter at higher sample rates).

Camera tool  The Camera tool is used to select, and export, sections of the Score Editor 
display as PDF files.

Caps Lock Keyboard  Logic Pro function that allows the use of the computer keyboard 
as a real time MIDI keyboard. It is primarily intended for use while travelling with a 
portable Macintosh.

Catch button  The button at the top left of most windows featuring the running man 
icon. Activate this button to enable horizontal scrolling during playback. This ensures 
that the area of the project which surrounds the current playhead position is always 
visible.

CD Audio  Short for Compact Disc—Audio; a standard for stereo music CDs:  44.1 kHz 
sampling rate and 16 bit depth.

cent  A tuning division of a semitone. There are one hundred cents in a semitone. Many 
of the Logic Pro software instruments contain a Fine parameter that allows sounds to 
be tuned in cent steps.

channel strip  A channel strip is a virtual representation of a channel strip on a mixing 
console. Each channel strip contains a number of similar controls, which can include 
some or all of the following:  a Mute button, Level fader, Pan/Balance control, Input slot, 
Output slot, Send slots, Insert slots, Format button. The channel strips shown to the left 
of the Arrange window, and in the Mixer window, are used to process audio or MIDI 
information that is routed from Arrange tracks. 

channel strip setting  Logic Pro allows the routing of a channel strip, including all 
inserted effects or instruments (plus their settings) to be saved and recalled. This 
simplifies the task of recreating complex serial effect routings between channels or 
projects.

checkbox  A small box. You click a checkbox to select or deselect (or turn on/off ) an 
option.

Chord track  One of the global tracks. Contains chord symbols that can be derived 
from MIDI regions or created with the mouse. These chord symbols may also be 
inserted into the score. The root note of the chords determines the transposition (pitch 
shifting) of all Apple Loops, and can also affect the playback of MIDI regions.
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chorus effect  Effect achieved by layering two identical sounds with a delay, and 
slightly modulating the delay time of one, or both, of the sounds. This makes the audio 
signal routed through the effect sound thicker and richer, giving the illusion of multiple 
voices.

click  Metronome, or metronome sound.

Clipboard  The Clipboard is an invisible area of memory, into which you cut or copy 
selected data, using the Edit menu. Data stored in the Clipboard can be pasted to 
different positions. In Logic Pro, the Clipboard can be used to exchange data within a 
single project or between projects.

clipping (in digital recording)  Feeding too much signal through a channel strip, 
thereby exceeding the limit of what can be accurately reproduced, results in a distorted 
sound known as clipping. Logic Pro audio channel strips feature a clip detector, which 
indicates signal level peaks above 0 dB. 

clock  Electrical synchronization impulse, transmitted every 1/96 note. Was used in 
older drum machines before the advent of MIDI (MIDI Clock is a modern 
implementation of simple clock signals. It runs at 24 ppqn—pulses per quarter note—
or 96 pulses per note).

cloned audio region  A cloned audio region is a pointer to the original region. 
Whenever you adjust the start or end points of any of these cloned regions, all other 
cloned regions will also be adjusted in the same way. 

comb filter effect  A short delay of feedback that emphasizes specific harmonics in a 
signal is generally termed a comb filter. The name is derived from the appearance of a 
frequency spectrum graphic, which resembles the teeth of a comb.

compressor  An effect that restricts the dynamic range of an audio signal (also see 
expander). 

comping  A process where multiple recording takes are compiled into a single perfect 
take (see takes).

Content Link mode  The chain link button found at the top left of most Logic Pro 
windows features three modes. Content Link mode is useful for situations where 
multiple MIDI regions are horizontally aligned along a single track, and you are viewing 
the MIDI region contents in the Piano Roll Editor, for example. In this scenario, the 
Piano Roll Editor will only show the contents of the selected MIDI region. Should you 
wish to view the contents of each MIDI region (selected or not) in the Piano Roll Editor 
as the project plays, you will need to activate Content Catch mode.

controller  MIDI data type. As examples:  sliders, pedals, or standard parameters like 
volume and panning. The type of command is encoded in the first data byte, the value 
being sent or received is encoded in the second data byte.
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control surface  A hardware device that communicates with Logic Pro via MIDI (or USB, 
FireWire, or via a networking connection). It can be used to write automation data and 
control Logic Pro parameters, such as mixing levels and panning, effects and 
instruments, plus transport and navigation functions, amongst others.

Controls view  All Logic Pro plug-ins (and Audio Units) offer a non-graphical alternative 
to the Editor views of effect and instrument parameters. The Controls view is accessed 
via the Controls item in the plug-in header’s View menu at the top of each plug-in 
window. This view is provided to allow access to additional parameters and to use less 
onscreen space.

Core Audio  Standardized audio driver system for all Macintosh computers running 
Mac OS X version 10.2 or higher. Core Audio is an integral part of Mac OS X, allowing 
access to all audio interfaces that are Core Audio compatible. Logic Pro is compatible 
with any audio hardware that offers Core Audio drivers/support.

Core MIDI  Standardized MIDI driver system for all Macintosh computers running 
Mac OS X version 10.2 or higher. Core MIDI is an integral part of Mac OS X, allowing the 
connection of all MIDI devices that are Core MIDI compatible. Logic Pro is compatible 
with any MIDI hardware that offers Core Audio drivers/support.

count-in  Beats heard prior to the start of a recording (or playback).

cueing  Monitoring (hearing playback) while fast-forwarding or rewinding.

cutoff frequency  Frequency at which the audio signal passing through a low or 
highpass filter is attenuated by 3 dB. 

cutting  The act of reducing a level, or frequency, when using EQ or other filters. Also 
used to describe physically dividing and removing sections of files, regions, and so on 
(see boosting and attenuation).

Cycle function  A function in Logic Pro which constantly repeats the area between the 
locator positions. To turn on Cycle mode, click the Cycle button in the Transport. The 
Cycle function is useful for composing a part of a project or editing events, as 
examples. The cycle area is shown as a green stripe in the top part of the Bar ruler. 

DA converter or DAC  Short for digital/analog converter; a device that changes an 
analog signal into a digital signal.

data bytes  These define the content of a MIDI message. The first data byte represents 
the note, or controller number; and the second the velocity, or controller value.

DAW  Acronym for Digital Audio Workstation. A computer used for recording, mixing, 
and producing audio files.
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dB  Abbreviation for decibels, a unit of measurement that describes the relationships of 
voltage levels, intensity, or power, particularly in audio systems.

DC offset  An error that can result in direct current (DC) being layered over the audio 
signal, resulting in a vertical shift in the waveform position shown in the Sample Editor.

decay  An envelope parameter that determines the time it takes for a signal to fall from 
the maximum attack level to the sustain level. See envelope.

deesser  A signal processor that removes hissing or sibilance in audio signals.

default  The preset parameter value.

delay  In the Environment, an object that can create a series of repeats. In the Arrange, 
a region parameter which can delay or advance a selected region by a given number of 
milliseconds. Delay is also an effect process that delays the incoming audio signal, 
resulting in subtle chorusing effects through to endless repeats of the signal.

destructive  Destructive audio processing means that the actual data of an audio file is 
changed, as opposed to just editing peripheral or playback parameters.

Devices tab  In Logic Pro, the Logic Pro > Preferences > Audio > Devices tab is used to 
select and configure your audio hardware devices. In essence, you are altering the 
driver configuration of your devices when using the Devices tab parameters. Also see 
driver.

DFS  An abbreviation for Digital Full Scale. Sometimes expressed as 0 dB DFS. This 
(zero dB—as shown on the Logic Pro channel strip level meters) is the maximum 
theoretical level that a digital signal can reach before clipping and other types of 
distortion may be introduced. 

dialog  A window containing a query or message. You must interact with it (by pressing 
a button) before you can continue.

digital  A description of data that is stored or transmitted as a sequence of ones and 
zeros. Most commonly, refers to binary data represented by electronic or 
electromagnetic signals. All files used in Logic Pro are digital. Also see analog for 
comparison.

Digital Full Scale  See DFS.

disclosure triangle  A small triangle you click to show or hide details in the user 
interface.

distortion  The effect that occurs when the limit of what can be accurately reproduced 
in a digital signal is surpassed, resulting in a sharp, crackling sound. 
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division value  Adjustable value (shown in notes) for the grid used in displays and 
operations. Third number displayed in the Transport bar’s Position display. The division 
value is set in the Transport bar, below the time signature. 

Drag menu  A pop-up menu found in the local menu of linear editing windows. It 
determines the behavior of regions or events when dragged to an overlapping 
position.

drag & drop  Grabbing objects with the mouse, moving them, and releasing the mouse 
button.

driver  Drivers are software programs that enable various pieces of hardware and 
software to be recognized by computer applications. If the proper driver is not 
correctly installed for your audio hardware, your computer may not recognize or work 
properly with it. See Devices tab.

DSP (digital signal processing)  In Logic Pro, the mathematical processing of digital 
information to modify a signal. An example is the Insert slot of channel strips, which 
assigns DSP effects such as dynamic compression and delay to a channel signal. Even 
simple operations such as changing volume and pan are DSP calculations.

dynamics  Refers to changes in volume, or other aspects of a piece of music, over time.

dynamic range  The dynamic range is the difference in level between the highest 
signal peak that can be reproduced by an audio system (or device in the system) and 
the amplitude of the highest spectral component of the noise floor. Put another way, 
the dynamic range is the difference between the loudest and softest signals that the 
system can reproduce. It is measured in decibels (dB). See decibels.

editor  Window for editing MIDI or audio data. Logic Pro offers the Hyper, Piano Roll, 
Event List, and Score editors for MIDI event data, and the Sample Editor for audio data. 
The Event List can also be used for region editing and positioning tasks.

Editor view  Almost all Logic Pro plug-ins (and Audio Units) offer a graphical view of 
effect and instrument parameters. The Editor view is the default, but can be accessed 
via the Editor item in the View menu at the top of each plug-in window, should the 
Controls view be visible.

effect  A type of software algorithm that alters the sound of an audio signal in a variety 
of ways. Logic Pro includes a set of EQ, dynamics, time-based, modulation, and 
distortion effects in the Logic Pro native and Audio Unit plug-in formats.

envelope  The envelope graphically represents the variation that a sound exhibits over 
time. An envelope, used as a controlling device, basically determines how a sound 
starts, continues, and ends. Synthesizer envelopes usually consist of attack, decay, 
sustain, and release phases.
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Environment  The Logic Pro Environment graphically reflects the relationships between 
hardware devices outside your computer and virtual devices within your computer. 
Beyond basic input and output handling, the Environment can be used to process MIDI 
data in real time, and can even be used to create processing machines, such as virtual 
rhythm generators and step sequencers or complex synthesizer editors.

Environment layer  A page in the Environment, used to organize objects. Objects of 
the same type (MIDI objects, for example) are generally placed on the same layer, 
making usage easier.

Environment Mixer  See Mixer layer.

EQ  Shortened form of equalizer. Equalizers are used to boost or cut frequencies in an 
audio signal. There are several types of EQ available in Logic Pro. 

equalization  See EQ.

Eraser  A tool used for deleting items. Click a selected item to delete it. All other 
currently selected items are also deleted.

event  Individual MIDI command, such as a note on command. Continuous controller 
movements (modulation wheel, for example) produce a quick succession of individual 
events—each with an absolute value. 

event definition  Parameters used to define the event type displayed in the lanes of 
the Hyper Editor (also see hyper set).

Event List  A list that shows all events or regions in a project. It allows you to directly 
manipulate events and regions in a precise, numerical way. It also allows you to add 
different types of events. 

expander  An effect process that increases the dynamic range of an audio signal. It is 
the antithesis of the compression effect (see compressor). 

export  To create a version of a file, such as a Logic Pro project, in a different format 
that can be distributed and used by other applications.

Fade tool  Tool in the Arrange area, used to create a cross-fade. 

filter effect  Filters are effects designed to reduce the energy of a specific frequency 
within a signal. The names of the individual filters illustrate their function. As an 
example:  A low pass filter allows frequencies that are lower than the cutoff frequency 
to pass (see cutoff frequency). 

Filter button  Buttons in the Event List and Mixer, that allow you to hide or show 
specific event types or channel strip types.
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filter slope  The filter slope is the steepness, or severity, of filter attenuation (level 
reduction). As examples, a filter slope of 6 dB per octave would sound much softer than 
a filter slope of 12 dB per octave.

Find field  In many Logic Pro windows you find a field with rounded corners and a 
magnifying glass to the left. This field allows you to perform text searches. As examples, 
the Find fields in the Key Commands window or Loop Browser.

Finger tool  Tool (as used in the Piano Roll Editor, for example) that looks like a hand 
with an extended index finger. This tool allows you to manipulate the length of events 
or perform other operations in other areas of the program. 

FireWire  Apple trademarked name for the IEEE 1394 standard. A fast and versatile serial 
interface, often used to connect audio interfaces, and audio processing units to 
computers. FireWire is well suited to applications that move large amounts of data, and 
can be used to connect hard disks, scanners, and other kinds of computer peripherals. 
There are two versions of FireWire:  FireWire 400 and FireWire 800. The latter is a faster 
variant, which uses a different connector type. Use of FireWire 400 devices on a 
FireWire 800 port is possible with suitable cabling, but it effectively halves the 
bandwidth to all devices on the port (also see M-LAN).

flanger  The flanger effect is similar to the chorus effect, where a slightly delayed signal 
(which is shorter than that of the chorus) is fed back into the delay line input. Flanging 
makes a sound thicker, and slightly out of phase.

float window  See window type.

folder  A folder is a container for regions in the Arrange. It can contain other folders or 
regions, much like a folder in the Finder can contain other folders or files. You can 
imagine a folder as a project within a project. The inside of a folder looks just like the 
Arrange area and track list in a project. 

Format button  Button on audio channel strips (below the level meter), used to 
indicate the input format of the channel strip. Click-hold this button to access the 
format menu.

frame  Unit of time. A second in the SMPTE standard is divided into frames that 
correspond to a single still image in a video file or on video tape. 

Freeze function  The Freeze function performs individual offline bounce processes for 
each frozen track, saving almost 100% of the CPU power used for software instruments 
and effect plug-ins. All plug-ins of a track (including software instrument plug-ins, if 
applicable, along with all related automation data) are rendered into a freeze file. 

frequency  The number of times a sound signal vibrates each second, measured in 
cycles per second, or Hertz (Hz). 



Glossary 983

global tracks  Global tracks are available at the top of all linear editing windows. They 
allow you to view, create, and edit markers, tempo events, and key changes, plus beat 
mapping and other operations.

Glue tool  This tool can be used to merge regions or events by simply clicking on two 
(or more) of them. 

GM  Abbreviation for General MIDI. A standard for MIDI sound modules that specifies a 
uniform set of instrument sounds on the 128 program numbers, a standardized key 
assignment for drum and percussion sounds on MIDI channel 10, 16-part multi-timbral 
performance and at least 24 voice polyphony. The GM specification is designed to 
ensure compatibility between MIDI devices. A musical sequence generated by a GM 
instrument should play correctly on any other GM synthesizer or sound module.

grab (an object)  Positioning the mouse cursor over an object, then pressing and 
holding the mouse button down.

grid  The Logic Pro grid is represented by vertical lines that are used to indicate the 
positions of measures, beats, and sub-beats in various editors. 

GS  Extended GM standard developed by Roland Inc.

Hand tool  A tool used to move regions in the Arrange or events in editors, or plug-ins 
between Insert slots in the Mixer. It automatically appears when the mouse cursor is 
placed over a region or event while the Pointer tool is selected. 

headroom  An alternate term for dynamic range. See dynamic range. 

help tag  A small text window which appears when the mouse cursor is placed over an 
interface element. It indicates the name or value of the element. When editing 
operations such as moving or cutting a region are performed, a larger help tag will 
display the current (and starting) position of the region or function—in real time.

hierarchical menu  Structured menus that open cascading sub-menus when an 
individual entry is chosen at a higher level.

Hierarchy button  In the top left corner of many Logic Pro windows, you will find a 
button featuring an upwards pointing, right-angled arrow. Clicking this Hierarchy 
button takes you to the next, higher display level (one level up, in other words). As an 
example, if you are looking at the events of a MIDI region inside a folder, clicking the 
Hierarchy button will switch the display to a view of the MIDI region in the parent 
folder. A further click will take you up to display the folder itself.

Hyper Draw function  This function allows you to record, manually create, and edit 
controller data graphically. Hyper Draw data appears as a set of points (or nodes), 
which are connected by lines. Hyper Draw can be used in the Arrange and MIDI editors.
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Hyper Editor  Graphical editor that can be used to create or edit MIDI note and 
controller data. The Hyper Editor is ideal for drawing drum parts and creating crescendi, 
amongst other tasks. See entry below and also see event definition.

hyper set  All simultaneously displayed event definitions in the Hyper Editor are 
collectively referred to as a hyper set. Also see event definition.

icon  Small graphic symbol. In Logic Pro, an icon may be assigned to each track.

importing  The process of bringing files of various types into a Logic Pro project. 
Imported files can be created in another application, captured from another device, or 
taken from another Logic Pro project.

In button  Button used to activate Step Input mode in the editors. Also see Step Input 
function. 

input monitoring  This function allows you to hear incoming audio, when audio tracks 
are playing, record-enabled, or recording. Simply click the Input Monitoring button on 
Arrange audio tracks to enable or disable input monitoring.

input channel strip  Channel strip type in the Environment Mixer layer which is 
included for backwards compatibility with projects created in older Logic Pro versions. 
An input channel strip represents the physical inputs of your audio interface and 
directs input from your audio interface into Logic Pro. In general, you will not need to 
access this channel strip type in Logic Pro 8.

Insert slot  A panel on Logic Pro channel strips where you can patch in (insert) an 
effect plug-in.

Inspector  Area at the left edge of the Arrange and editors, containing the Parameter 
boxes and channel strips (Arrange) of the selected track. Also see Parameter boxes. The 
Inspector area updates to reflect the parameters relevant to the window with key focus.

instrument channel  Logic Pro supports the use of software based instruments. 
Software instrument plug-ins are inserted into the Instrument slot of instrument 
channels. Software instrument recording takes place on instrument tracks in the 
Arrange. Playback of these tracks is routed via the instrument channel shown in the 
Mixer (or to the left of the Arrange window).

instrument object  An object in the Logic Pro Environment designed to communicate 
with a single-channel MIDI device. An instrument object represents a physical or virtual 
device which handles MIDI information. Also see multi instrument object.
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interface  1) A hardware component such as a MIDI or audio device that allows 
Logic Pro to interface (connect) with the outside world. You need an audio or MIDI 
interface to get sound or MIDI into and out of your computer. Also see audio interface. 
2) A term that is used to describe graphical elements within Logic Pro that you can 
interact with. An example would be the Arrange, where graphical interface elements 
such as regions are interacted with to create a project, within the overall Logic Pro 
interface.

interleaved audio file  Logic Pro typically handles multi-channel (stereo or surround) 
audio files as interleaved (unless using DAE hardware). Edits to interleaved files affect 
both (or all, if surround) channels equally. Also see split channel audio files.

key  The scale used in a piece of music, centered around a specific pitch. The specified 
pitch is called the root of the key. Can also refer to a black or white key on a musical 
(MIDI) keyboard.

key command  Function which can be executed by pressing a specific key (or key 
combination) on your computer keyboard or MIDI controller.

Key Commands window  The Key Commands window is used for the assignment of 
key commands to computer keys or to MIDI messages. 

key focus  The selected, active window, is said to have key focus in Logic Pro. Many key 
commands will only function when a window has key focus. The Inspector also updates 
to reflect the parameters of a window with key focus.

latency  You may notice a delay between playing your keyboard and hearing the 
sound. This is a form of latency. A variety of factors contribute to latency, including the 
audio interface in use, audio and MIDI drivers. One factor under your control, however, 
is the I/O buffer size, which is set in the Devices preferences. 

legato  Method of musical performance that smoothly connects one note to the next.

level meter   A meter that monitors audio input or output levels to or from your 
computer. You use the level meters in Logic Pro when recording, arranging, and editing 
audio files, and when creating a mix. 

Library  Window (or tab in the Media area of the Arrange window) used to handle all 
settings files for channel strips, effects, and instruments. 

Link button  Button in the top left corner of most Logic Pro windows that features the 
chain link icon. It controls the linking between different windows.

Lists area  Area in the Arrange window, providing four independent tabs that show a 
listing of the following types of data:  events, regions, markers, tempo changes, and 
time/key signatures.
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local menu bar   Menu in a window that only contains functions that are relevant to 
that particular window.

Local Off mode  Operating mode on a MIDI keyboard where the keyboard does not 
directly play its own integrated sound generator. This is useful when using it as a 
master keyboard for Logic Pro.

locators  Lower two sets of numbers, displayed to the right of the position indicators in 
the Transport bar. The number on top is the left locator; the number below is the right 
locator. The left and right locators define the cycle time-range, useful for cycle or skip 
playback operations and cycle recording. The locators are also used to define the 
editing area for certain functions.

loop  An audio file that contains recurring rhythmic musical elements, or elements 
suitable for repetition. Logic Pro supports Apple Loops, amongst other file formats. 

Loop Browser  Window (or tab in the Media area of the Arrange window) used to 
access and manage Apple Loop and ReCycle files.

Loop function  The Loop region parameter Logic Pro creates loop repeats for an audio 
or MIDI region. These repetitions will continue until the project end point is reached, or 
another region or folder (whichever comes first) is encountered on the same track in 
the Arrange area. 

main menu bar  The bar at the top of the screen, offering global functions such as 
opening, saving, exporting, or importing projects. It does not offer access to local 
window functions. It does, however, contain an Edit menu—with commands that apply 
to the window with key focus.

marker  A marker is an indicator, or bookmark, that is tied to a specific time position in 
a project. It can contain text which act as notes for different versions of a project, for 
example. Markers can also be used for a number of selection and navigation tasks.

Marker List  Window (or tab in the Lists area of the Arrange window) that shows an 
alphanumeric listing of all marker events. It also includes a Marker Text area that allows 
you to add text information (notes) to particular marker events.

Marker track  One of the global tracks, used for the creation, editing, and display of 
marker events.

marker text  Text information (notes) attached to particular marker events. Added in 
the Marker Text window or Marker Text area of the Marker List.

Marquee tool  Crosshair-shaped tool in the Arrange Toolbox, used to select and edit 
parts of audio and MIDI regions.
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master channel strip  Channel strip in the Mixer that acts as a separate attenuator 
stage, changing the gain of all output channel strips without affecting the level 
relationships between them.

Media area  Area shown at the right-hand side of the Arrange window when the Media 
button is clicked in the Arrange Toolbar. Contains the Bin, Loops, Library, and Browser 
tabs, providing access to all media types supported by Logic Pro.

merge  Mix, or combine, two or more MIDI events or regions into a single event or 
region.

metadata  Metadata is additional descriptive information that is stored in the file 
header of a number of file types (AAF, for example). It is used to reference external 
media, to simplify searches, and more.

metronome  A device that produces a sound that taps out the beat. In Logic Pro, it can 
configured in the Metronome project settings.

MIDI  Abbreviation for Musical Instrument Digital Interface. Standardized, 
asynchronous, serial, event-oriented hardware and software interface for electronic 
musical instruments. MIDI is an industry standard that allows devices such as 
synthesizers and computers to communicate with each other. It controls the pitch, 
length, and volume of a musical note event, among other characteristics.

MIDI channel  A MIDI channel is a “tube” for MIDI data, which flows through MIDI ports. 
Up to 16 separate MIDI channels can pass through a port simultaneously. Tracks 
recorded in Logic Pro can be directed to different tubes (channels), which can contain 
different information, and play back through different sounds, assigned to each 
channel. As examples, channel 1:  piano, channel 2:  bass, channel 3:  strings, and so on. 
This presumes that the recieving devices are capable of receiving data on more than 
one channel, and that they are capable of playing back different sounds simultaneously 
(see multi timbral).

MIDI Clock  Short MIDI message for clock signals. It is used to provide a timing pulse 
between MIDI devices. It is accurate to 24 ppqn (pulses per quarter note), although 
some devices interpolate these pulse values, resulting in a more precise clock signal if 
each device is capable of interpreting this additional information correctly. Also 
see:  SPP.

MIDI message  A message transmitted via MIDI that consists of one status byte and 
none, one, two, or many data bytes (with system exclusive commands). See event.
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MIDI Multi mode  Multi-timbral operating mode on a MIDI sound module where 
different sounds can be controlled (polyphonically) on different MIDI channels. A multi 
mode sound module behaves like several polyphonic sound modules. General MIDI 
describes a 16-part multi mode (the ability to control 16 different parts individually). 
Most modern sound generators support multi mode. In Logic Pro, multi mode sound 
modules are addressed via multi instrument objects. This MIDI mode and multi mode 
sound modules are generally referred to as multi timbral (see multi timbral).

MIDI region  Data container for MIDI events, shown in the Arrange as a named 
horizontal beam. 

MIDI Time Code (MTC)  Translation of a SMPTE time code signal into a MIDI standard 
time code signal. MTC is used to synchronize Logic Pro with MIDI devices, other 
sequencers, video and audio tape or hard disk machines that support MIDI Time Code. 
MTC determines absolute time positions and supports start, stop, and continue 
messages.

mixdown  A term commonly used to describe either bouncing (see bounce) or 
merging of tracks (see merge).

Mixer  The Mixer window displays all (or the desired) track, instrument, and MIDI 
channel strips. These channels allow you to control all aspects of track output and 
processing, including level, panning, effect and instrument processing, routing, and 
more.

Mixer layer  An Environment layer that shows all channel strips in a project (except 
MIDI channel strips). In general, you will not need to access this Environment layer as all 
mixing duties can be performed in the Mixer window.

mixing  The process of shaping the overall sound of a project by adjusting the volume 
levels, pan positions, adding EQ and other effects, and using automation to 
dynamically alter these and other aspects.

M-LAN  A Yamaha designed variant of the FireWire interface. It enables Yamaha digital 
mixers and other devices to be directly connected to a Macintosh FireWire port (see 
FireWire). 

modifier key  Computer keyboard keys used in conjunction with alphabetical keys to 
change functionality. Modifier keys include Control, Shift, Option, and Command.

modulation wheel  A MIDI controller found on most MIDI keyboards.

mono  Short for monophonic sound reproduction. The process of mixing audio 
channels into a single track, using equal amounts of the left and right audio channel 
signals. Compare with stereo.

movie  See video.



Glossary 989

MP3  Abbreviation for MPEG-2 Audio Layer 3. A compressed audio file format, 
frequently used to distribute audio files over the Internet. 

MTC  See MIDI Time Code.

multi instrument object  An object in the Logic Pro Environment that represents a 
multi timbral hardware or software device that reacts to MIDI. The multi instrument 
object is essentially 16 instrument objects rolled into a single package. Each of these, 
called sub-instrument, has a fixed MIDI channel. All sub-channels share the same MIDI 
port. All other parameters can be set individually. The purpose of the multi instrument 
object is to address multi-channel MIDI devices, which can receive MIDI data (and play 
different sounds) on separate MIDI channels.

multi-timbral  This term describes an instrument or other device that can play several 
different sounds at the same time, using multiple MIDI channels. See MIDI multi mode.

mute  Switch off the audio output of a channel or track. You can mute a track or 
channel by clicking the Mute button in the track list or at the bottom of the channel 
strip).

Mute tool  This tool allows you to stop a region or events from playing, by clicking on it 
or them. 

native  Native refers to host-based processing of effects and software instruments in 
Logic Pro. The computer CPU natively calculates the effects and instruments. Native 
also refers to the internal Logic Pro plug-in format, which differs from the Audio Unit 
format. Logic Pro native plug-ins only work in Logic Pro.

nodes  Positions in Hyper Draw and automation tracks that mark the beginning or end 
of data manipulation. Occasionally referred to as (automation) points.

Nodes  Refers to additional Macintosh computers that are used as external processing 
nodes, effectively increasing the CPU resources of your main Logic Pro computer. 

normalize  This function applies the current Parameter box settings to the selected 
MIDI events (by altering the actual events themselves), and clears existing parameter 
settings. When it comes to audio, a different Normalize function raises the volume of a 
recorded audio file to the maximum digital level, without altering the dynamic content.

note attributes  Describes functions found in the Attributes menu of the Score Editor. 
These determine aspects such as the stem direction, color, enharmonic position, and 
further options for the display (and printing) of note events.

note number  Pitch of a MIDI note, controlled by the first data byte of a MIDI note 
event.
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object  The term is used to refer to the graphical representation of elements in the 
Logic Pro Environment. These elements can be used to create and process MIDI data in 
real time, and can even be used to create processing machines, such as virtual rhythm 
generators or step sequencers. Examples of Environment objects include instruments, 
multi instruments, faders and arpeggiators, amongst others. The Environment Mixer 
layer contains objects that process audio data. 

Object Parameter box  The Object Parameter box displays the properties of any 
selected Environment object. 

offset  The playback point in a source audio file can differ from the start point (anchor) 
of the file. This is known as an offset or start point offset. Offset is also used in 
conjunction with video time code, where the start time of the Logic Pro project and 
QuickTime movie file can be offset (different) from each other. A further use of the term 
is when the amplitude of a waveform is off-axis from the center line (due to a recording 
error caused by hardware). This can be rectified with the DC Offset function in the 
Sample Editor. See DC Offset.

OpenTL  Abbreviation for Open Track List. This file format, typically used for data 
exchange with Tascam hard disk recorders, such as the MX 2424, can be imported and 
exported by Logic Pro. The OpenTL file format only supports the exchange of audio 
data (audio regions, inclusive of track position information). MIDI and automation data 
are ignored when using the Logic Pro OpenTL export function. 

option  Alternative function, often in the form of a checkbox, sometimes also available 
as a menu entry. 

Option  Modifier key, also known as the Alt key in MS Windows.

output channel strip  Channel strip type in the Mixer that controls the output level and 
pan/balance for each physical output of your audio interface. 

Page view  A display mode in the Score Editor, used to view and lay out notation as it 
will appear on the printed page.

pan, pan position  The placement of mono audio signals in the stereo field, by setting 
different levels on both sides (see Balance).

Pan control  Rotary knob (directly above the Level fader) on mono channel strips, that 
determines the position of the signal in the stereo image.

Parameter box  Field on the left side of Logic Pro windows (or in the Inspector). It is 
used to adjust the parameters of the selected track, regions, events, or objects. Also see 
Inspector.

peak meter  A digital audio meter that displays the absolute volume of an audio signal 
as it plays. So named because every peak in the signal can be accurately seen.
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peak  1) The highest level in an audio signal. 2) Portions of a digital audio signal that 
exceed 0 dB, resulting in clipping. You can use the Logic Pro level meter facilities to 
locate peaks and remove or avoid clipping. The Search Peak command in the Sample 
Editor Functions menu searches for the sample bit with the greatest amplitude value. 

Pencil tool  Tool used to create empty MIDI regions in the Arrange. It can also be used 
to add audio regions to the Arrange, when used in conjunction with the Shift key. In 
the Sample Editor, the Pencil can be used to draw out transient signal spikes (pops and 
clicks) in signals. 

Piano Roll Editor  A MIDI event editor that displays note events as horizontal beams. 
Events can be cut, copied, moved, and resized in a similar fashion to regions in the 
Arrange. 

pitch  The perceived highness (treble) or lowness (bass) of a musical sound. 
Corresponds to the frequency of the sound wave.

pitch bend message  MIDI message transmitted by the pitch bend wheel of a MIDI 
keyboard.

playback  Playing an audio or MIDI region, an audio file, or an entire arrangement, 
allowing you to hear it.

playhead  The playhead is a vertical white line which indicates the current playback 
position in all horizontal, time-based Logic Pro windows (the Arrange, for example). The 
playhead can be directly grabbed and moved with the mouse (see scrubbing).

plug-in  Software application that enhances the functionality of the main program (in 
this case, Logic Pro). Logic Pro plug-ins are typically software instruments or effects.

plug-in window  A window that opens when a plug-in is inserted, or the Insert/
Instrument slot is double-clicked. Allows you to interact with the plug-in parameters.

Pointer tool  Tool used to select or edit regions, events, menu or interface items, and 
more in Logic Pro.

post fader  Sends in analog mixers are positioned either before (pre) or after (post) the 
fader. Post fader means positioned after the volume fader in the signal flow, with the 
level of a signal going to the send changing along with the fader movements. 

pre fader  Sends in analog mixers are positioned either before (pre) or after (post) the 
fader. Pre fader means positioned before the volume fader in the signal flow, so the 
level of a signal routed pre-fader to a send remains constant, regardless of any fader 
movements.

Preferences window  A window that is accessed via the Logic Pro > Preferences menu. 
All Logic Pro preferences can be set in this window.
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preset  Set of plug-in parameter values that can be loaded, saved, copied, or pasted via 
the Settings menu in the plug-in window header. See setting and Settings menu. 

pressure  See aftertouch

project  The Logic Pro “song” document, that contains pointers to audio files and 
regions, plus actual MIDI data (in MIDI regions). Further settings and preferences are 
also stored with the project document.

project folder  In Logic Pro, the top-level folder that can contain all media associated 
with a project, including audio files, sampler instruments and samples, video, and other 
data.

project settings  The project settings are a collection of program settings that are 
specific to the current project. These are different to the global preferences that affect 
all Logic Pro projects (see Preferences Window).

protected track  A protected track cannot have its contents moved or changed.

punch in, punch out  Going into and out of record to replace a section of an existing 
recording. This process can be automated in Logic Pro. Also see Autopunch.

quantization  Time-correction of note positions by moving them to the nearest point 
on a selectable grid (this is chosen in the Quantization menu). When quantization is 
applied to any selected event or region, Logic Pro will move all note events to align 
perfectly with the nearest grid position. Logic Pro quantization is a non-destructive 
playback operation, allowing different quantize values to be auditioned while listening 
to your music.

Quantization menu  Menu found throughout Logic Pro that determines the current 
quantization grid. See entries below. 

Quantize button  Button labeled with a Q. Performs the quantize operation (chosen in 
the Quantization menu) on selected events. Also see Quantize tool and quantization. 

Quantize tool  Tool labeled with a Q. It is used to apply quantization to specific 
(selected) events, using the quantize value specified in the Quantization menu of the 
Piano Roll or Event List editors.

QuickTime  QuickTime is an Apple cross-platform standard for digitized, data-
compressed video playback and encoding. QuickTime movies can be run in a Logic Pro 
window or on a global Video track, in sync with the project. Whenever you move the 
playhead, the film follows and vice versa. 

RAM  Abbreviation for random-access memory. Computer memory capacity, measured 
in megabytes (MB), determines the amount of data the computer can process and 
temporarily store at any given moment.
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real-time effects  Effects that can be applied to regions in real time, during playback. 
Real-time effects can be used on any Macintosh computer qualified to run Logic Pro. 

recording  The act of capturing a performance as audio or MIDI data into Logic Pro. The 
term is also commonly used when referring to the actual data (in Logic Pro, this is 
delineated by the use of the words region or file to make things clearer when 
discussing recordings).

record-enable  Audio tracks musty be manually armed (record-enabled) before you can 
record on them. MIDI and software instrument tracks are automatically record-enabled 
when selected.

ReCycle  ReCycle is the name of an application from software manufacturer 
Propellerhead, which mainly serves as an editing and production tool for loops 
(repeated audio samples). ReCycle uses specific file formats (.rex) which can be 
imported by Logic Pro.

region  Regions can be found on Arrange tracks:  They are rectangular beams that act 
as containers for audio or MIDI data. There are three different types of regions:  audio 
regions, MIDI regions, and folder regions (usually referred to as folders). Also see:  audio 
region, MIDI region, and folder.

Region Parameter box  Box in the upper left corner of the Arrange, used to non-
destructively set the playback parameters for individual regions, including quantization, 
transposition, velocity, compression, and delay. These parameters do not alter the 
stored data. Rather, they affect how the events are played back. 

Replace mode  A type of overwrite recording mode where the currently specified 
audio region in the Arrange is replaced with the incoming signal. To activate Replace 
mode, click the Replace button in the Transport. 

reverb  Reverb(eration) is the sound of a physical space. More specifically, the 
reflections of soundwaves within a space. As an example, a handclap in a cathedral will 
reverberate for a long time as sound waves bounce off the stone surfaces within a very 
large space. A handclap in a broom closet will hardly reverberate at all. This is because 
the time it takes for the soundwaves to reach the walls and bounce back to your ears is 
very short, so the reverb effect will probably not even be heard.

ReWire  An audio streaming and synchronization technology from Propellerhead 
software. The output of ReWired applications can be routed into (and processed with) 
the Logic Pro Mixer. Logic Pro can also control the transport operations of ReWired 
programs. Further to these functions, Logic Pro instrument tracks can drive the 
software instruments of ReWire applications.

ritardando  A gradual slowdown of tempo (see tempo).
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routing  Generally refers to the way audio is sent through processing units. Also often 
used to describe specific input and output assignments.

rubber band selection  Technique for selecting consecutive regions, objects, or events 
by click-holding and dragging the mouse cursor around the desired items. A rubber 
band selection envelope (an outline) will expand from the starting position of the 
mouse cursor. All objects touched or enclosed by the rubber band selection envelope 
will be selected.

sample  A digital recording of a sound at a particular instant in time.

Sample Editor  The Logic Pro Sample Editor allows audio files to be destructively cut, 
reversed, shortened, changed in gain, and processed in a number of other ways. It 
allows editing of individual samples within an audio file consisting of thousands, or 
millions, of samples. The Sample Editor also provides access to a number of special 
sample processing tools, collectively known as the Digital Factory.

sampler  Device used for sampling. In Logic Pro, this generally refers to the EXS24 mkII 
software-based sampler.

sample rate  When an analog audio signal is converted to a digital signal, this term 
refers to the number of times per second the audio file is sampled. Logic Pro can record 
and edit audio at sample rates ranging from 44.1 kHz (44,100 times per second) up to 
192 kHz (192,000 times per second).

sample rate converter  Device or algorithm that translates one sample rate to another. 

sampling  The process of converting analog audio into digital information. The sample 
rate of an audio stream specifies the number of samples that are captured per second 
(see sample rate). Higher sample rates yield higher quality audio. 

saturation  A term most commonly associated with a slight tape distortion or the 
characteristics of tube amplifiers. It basically describes a very high gain level that causes 
a slight distortion of the incoming signal, resulting in a warm, rounded sound.

scale  A group of related musical notes (or pitches) that forms the basis of the melody 
and harmony in a piece of music. The most common scales are the major scale and 
minor scale.

scan code  Each key on a computer keyboard has a scan code rather than an ASCII 
symbol associated with it. As an example:  The plus and minus keys on the numeric 
keypad and the corresponding keys above the keyboard have a different scan code, 
but use the same ASCII symbol.

scene marker  Logic Pro can automatically extract information from (abrupt) transitions 
in QuickTime movie files, and create a marker, making the process of scoring to film 
much faster and easier. Such transitions in video generally indicate a scene change.
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Score Editor  Logic Pro editor that deals with standard musical notation. MIDI note 
events are represented as quavers, crotchets, minims, and so on. The Score Editor 
allows you to adjust and edit the layout of the score, and print it.

score set  A collection of various staff styles, staffs, and other elements shown in the 
Score Editor can be saved as a score set. This facility allows you to quickly switch 
between (and edit and print) different portions of the score, such as a brass section, in 
isolation to the entire score. It also simplifies experimentation with different layouts.

screenset  A layout of various windows, inclusive of all display parameters (zoom, 
position, size of each window, and so on) is called a screenset. You can swap between 
different screensets, much as you might swap between different computer monitors. 

scroll bar and scroller  Gray beam at the edge of a window. A movable box inside the 
beam is used to select the displayed project section in the window.

SDII  Sound Designer II audio file format. Very similar in structure to the AIFF file format.

semitone  Smallest interval between two pitches in the standard diatonic scale, equal 
to a half tone. A semitone is also called a half step or half tone. 

send  Abbreviation for auxiliary sends. An output on an audio device used for routing a 
controlled amount of the signal to another device. Sends are often used to send several 
signals to the same effect, which is useful for computationally-intensive effects such as 
reverb.

Send slot  A panel shown on mixer channel strips that enables you to send (via a bus) a 
portion (or all) of the audio signal to an auxiliary channel strip. You may use multiple 
sends on channels.

sequencer  A sequencer is these days considered to be a computer application that 
allows you to record both digital audio and MIDI data and blend the sounds together 
in a software mixing console. In earlier times, a sequencer controlled synthesizers via a 
series of control voltages and gates, or via MIDI only. No audio recording or control was 
available.

setting  1) A parameter value. 2) A set of plug-in parameter values that can be loaded, 
saved, copied, or pasted via the Settings menu. A plug-in setting is also known as 
preset. Also see preset and Settings menu.

Settings menu  Found in the gray header at the top of all plug-in windows. Allows you 
to save, load, copy, and paste settings:  the parameter values of effects and software 
instruments.

sharing  Channel strip settings, plug-in settings, and key commands can be stored and 
accessed (shared) on a local network or .Mac account.
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side chain  A side chain is effectively an alternate input signal—usually routed into an 
effect—that is used to control an effect parameter. As an example, you could use a side 
chained track containing a drum loop to act as the control signal for a gate inserted on 
a sustained pad track, creating a rhythmic gating effect of the pad sound.

Signature track  Global track that shows all time and key signatures of a project.

Signature List  A Logic Pro window that lists all time and key signatures of a project.

Single Trigger mode  This term is associated with synthesizers such as the ES1. In this 
mode, envelopes are not retriggered when tied (legato) notes are played. 

SMF  See Standard MIDI File. 

SMPTE  Abbreviation for Society of Motion Picture and Television Engineers. The 
organization responsible for establishing a synchronization system that divides time 
into hours, minutes, seconds, frames, and subframes (SMPTE time code). SMPTE time 
code is also used for synchronizing different devices. The MIDI equivalent of SMPTE 
time code is MIDI Time Code (MTC). See MTC.

SMPTE ruler  In addition to the standard bar/beat display, the Logic Pro Bar ruler can 
display time units in SMPTE format:  hours, minutes, seconds, and frames, and can 
display time code if a video is imported into the project.

Snap menu  A pop-up menu found in the local menu of linear editing windows. It 
determines the behavior of regions or events when edited; lengths and cuts will snap 
to the nearest possible position (as determined by the chosen Snap menu value), for 
example.

software instrument  Software counterpart to hardware samplers or synthesizer 
modules, or acoustic sound sources such as drumkits or guitars. The sounds generated 
by software instruments are calculated by the computer CPU, and played via the audio 
interface outputs. Often colloquially called softsynths or softsamplers.

solo  A way to temporarily highlight one or more tracks or regions or events, allowing 
them to be heard in isolation. 

Solo tool  Click-holding on individual regions or events with the Solo tool temporarily 
allows them to be heard in isolation. All other objects are muted.

SPP  Abbreviation for Song Position Pointer, a MIDI clock timing pulse sub-message 
that indicates the current “song” (project) position. It is accurate to bars (and beats for 
some devices), but is not as accurate as MIDI Time Code (MTC). If you have a choice of 
these two when synchronizing Logic Pro, choose MTC (see both the MIDI clock and 
MTC entries).
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S/P-DIF  Short for Sony/Philips Digital Interface, a standard transmission format for 
professional stereo digital audio signals. The format is similar to AES/EBU, but uses 75 
ohm coaxial or optical connectors and cabling. Depending on the type of devices 
involved, AES/EBU and S/P-DIF coaxial interfaces can communicate directly. Most digital 
audio interfaces available today will feature S/P-DIF connectors.

split channel audio files  Each channel of multi-channel audio files (stereo or surround) 
are usually dealt with together. These files are said to be interleaved. Edits to one 
channel will affect the others equally. Logic Pro allows you to separate these files, 
making them split channel audio files, enabling independent edits to each. Also see 
interleaved audio file.

staff style  A staff style determines the appearance of notation on a musical staff. You 
can define note sizing and spacing, number of staff lines, fonts, and more for each staff 
style.

Standard MIDI file (SMF)  Standard file format for exchanging songs between different 
sequencers or MIDI file players. Standard MIDI files are not specific to a particular 
sequencer program, type of computer, or device. Any sequencer should be able to 
interpret at least the type 0 MIDI file format. Standard MIDI files contain information 
about MIDI events, including time positions and channel assignments, names of 
individual tracks, instrument names, controller data, tempo changes, and more.

status byte  First byte in a MIDI message, which determines the type of message.

Step Input function  The Step Input function allows you to insert MIDI notes—one at a 
time—into a MIDI region, when Logic Pro is not in a real-time recording mode. This 
allows you to input notes that may be too fast for you to play, or may be useful if 
replicating sheet music, but you don’t sight read. Step input can be performed 
onscreen with the mouse or with the computer or MIDI keyboard, or any combination 
of these devices. Also see In button.

step sequencer  While all sequencers, including Logic Pro, step through a series of 
events, this term is used to describe a device from the seminal years of analog 
synthesisers. Essentially, two rows of knobs (usually 8) were individually adjusted to 
control the gate time (note length) and pitch of a connected synthesizer. The 
sequencer would step through these knob settings once, or repeatedly. Many modern 
software instruments, particularly drum synthesizers, include an integrated step 
sequencer that synchronizes with Logic Pro playback. Ultrabeat incorporates a step 
sequencer which is considerably more flexible than its ancient analog cousins.

stereo  Short for stereophonic sound reproduction of two different audio channels. 
Compare with mono.

subframe  A sub-division of a SMPTE frame, corresponding to the individual bits of a 
SMPTE frame. One frame consists of 80 bits.
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surround  Surround indicates playback systems that make use of multiple speakers. The 
most common surround format is 5.1 channels (front left, front center, front right, left 
surround, right surround, and an LFE, or subwoofer, channel), typically used in home 
theater systems and in cinemas. Logic Pro supports all common surround formats, and 
provides surround recording, plug-in, and mixing facilities.

Surround Panner  Replaces the standard Pan/Balance control of channel strips, set to 
Surround in the Output slot. Allows you to control the relative positioning of the 
channel signal between the speakers available (in the chosen project surround format).

sustain pedal  A momentary footswitch that is connected to MIDI keyboards. It 
transmits MIDI controller number 64, which is recorded and played back by Logic Pro.

Swing parameter  Alters the rigid timing of a quantization grid by delaying every other 
note of a specified sub-division by a definable amount. 

Sync button  This button, found on the Transport bar, activates/deactivates external 
synchronization mode.

synchronization  Method of keeping several recording or playback devices time locked 
with one another. In virtually all synchronized setups, there will be one master device 
and one or more slave devices that derive their synchronization clock from the master.

synchronizer  Central unit used to control the synchronization of several devices. In 
most situations, Logic Pro will act as the master synchronizer.

synthesizer  A device (hardware or software) that is used to generate sounds. The word 
is derived from early attempts with mechanical and electronic machines to emulate (or 
synthesize) the sounds of musical instruments, voices, birdsong, and so on. Logic Pro 
features several software synthesizers, including the ES1, ES2, EFM 1, ES E, ES P, and 
ES M.

SysEx  Abbreviation for System Exclusive data. SysEx data forms the top tier in the 
hierarchy of MIDI commands. These messages are tagged with an identification 
number for each manufacturer (the SysEx manufacturer ID number). The actual 
contents of these MIDI commands is left to the manufacturer. SysEx data is often used 
to transfer individual (or banks of ) sound programs or system settings, or to address 
individual sound generation or signal processing parameters. 

takes  A take, put simply, is a recording. Logic Pro allows you to create several takes, 
one after the other, without leaving record mode. These takes can then be compiled 
into a super take (see comping). 

template  A project that contains settings and preferences that you have defined. 
Templates serve as a starting point for new projects (scoring tasks, audio only projects, 
MIDI only projects, and so on, as your personal needs require). Any project can be used 
as a template, and you can create and save multiple templates.
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tempo  The playback speed of a piece of music, measured in beats per minute. 
Logic Pro allows you to create and edit tempo changes in the Tempo track.

tempo change  An event inserted into the Tempo track (as a node) that indicates a 
change in tempo at a particular bar/beat position.

Tempo track  One of the global tracks that displays tempo changes as nodes. 

tick  The smallest unit of timing resolution in a MIDI sequencer. In Logic Pro, this is 1/
3840th of a note. Logic Pro can go down to single sample accuracy (at sufficient zoom 
levels) for edits and positioning, but the MIDI protocol is not fast enough to support 
this.

time code  A format (and signal) for assigning a unique, sequential time unit to each 
frame of video or project position. The SMPTE time code format, for example, is 
measured in hours : minutes : seconds : frames and subframes.

timing  Measure of the ability to play notes at the right time. Timing can also refer to 
synchronization between events, regions, and devices.

toggle  To switch between two states such as on or off (applies to windows, parameter 
values, and so on).

Toolbar  The top of the Arrange window features the Toobar, which is used to access or 
hide certain onscreen areas, such as the Media or Lists area or Inspector. It also contains 
a number of buttons for key functions, such as Locking/Unlocking SMPTE positions. You 
may freely customize the Toolbar to meet your needs.

Tool menu  Available in the local menu bar of a window, containing tools for editing, 
zooming, cropping, and otherwise manipulating items in the window. 

track  A horizontal row in the Arrange that contains either audio or MIDI regions that 
can be played back over time. Each track has a specified destination (a channel strip) 
that data is routed to. Logic Pro allows hundreds of tracks to be used in a project.

track arming  See record enable.

track list  Situated to the left of the Arrange. Displays the channel strips assigned to 
various tracks as well as Track Solo, Mute, and other buttons. 

Track Parameter box  See Object Parameter box. 

Track Protect button  The button featuring the lock icon, shown in the Arrange track 
list, protects or unprotects tracks from further editing. Also see protected track. 
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transform set  A collection of transform operations (performed in the Transform 
window) can be saved as a transform set. Saved transform sets can be quickly accessed 
via the Presets menu at the top left of the Transform window. You may also import 
transform sets from other projects. See entry below.

Transform window  Logic Pro editor that lets you define a set of conditions and 
operations that are used to select and manipulate specific MIDI events.

transient  Position in an audio recording where the signal becomes a lot louder—over 
a short time span (a signal spike, in other words). As this is typical for drum recordings, 
transients can be used to indicate where beats occur in an audio signal. 

Transport bar  A field shown at the bottom of the Arrange window, used to control 
recording and playback functions. The Transport bar offers Record, Pause, Play, Stop, 
and Rewind/Forward buttons plus other functions. You can also open independent 
Transport bar windows by choosing Window > Transport (Command-7).

transpositon  Transposition is the act of changing the pitch of an audio or MIDI region 
(or event) by a number of semitones. 

Transposition track  Global track component that shows transposition events.

treble  Refers to high frequency sounds or components within a sound. See frequency.

Undo function  Function which reverses the previous editing operation. The Undo 
History allows multiple undo steps to be made.

unicode  Fundamentally, computers just deal with numbers. They store letters and 
other characters by assigning a number for each one. Unicode provides a unique 
number for every character, no matter what the platform, no matter what the program, 
no matter what the language.

velocity  Force at which a MIDI note is struck; controlled by the second data byte of a 
note event.

Velocity tool  This tool, found in the Logic Pro MIDI editors, allows the velocity of 
individual, or grouped, note events to be adjusted.

Video track  A global track component that allows the viewing of video clips.

virtual memory  Area of the hard disk used as an extension of RAM memory by the 
computer. The disadvantage is its very slow access time, in comparison to physical 
RAM.

Voice Separation tool  You can separate polyphonic voices onto different staffs in the 
Score Editor by drawing a dividing line with the Voice Separation tool (provided you 
are using a polyphonic staff style).
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VU meter  Abbreviation for Volume Unit meter. An analog meter used to monitor audio 
levels.

WAV, WAVE  The primary audio file format used by Windows-compatible computers. In 
Logic Pro, all recorded and bounced WAV files are in Broadcast Wave format, which 
includes high-resolution timestamp information that stores positional information. This 
makes it easy to align these files in other audio and video applications.

waveform  A visual representation of an audio signal. Waveform graphics run from left 
to right, and are centered on a horizontal line. Louder portions of the waveform 
(amplitude peaks) are indicated as taller spikes or higher curves in the waveform.

wet/dry mix  Refers to the ratio of a signal that effects have been added to (wet), and 
the original, unprocessed signal (dry). 

window type  Status of the window as a float window or a normal window. Float 
windows always float in the foreground and can not be hidden by normal windows. 
Also see float window.

Word Clock  Clock signal required by digital audio interfaces to ensure the sampling 
rates of connected devices run synchronously. When two devices are connected via a 
standard digital audio interface (such as S/P-DIF or ADAT optical), Word Clock is 
transmitted via the audio circuit. If you want more than two digital audio devices to 
communicate with each other, you will need to use separate Word Clock ports for 
synchronization, in most cases. 

word length  See bit depth.

XG  Extended General MIDI standard from Yamaha, compatible with Roland GS.

zero crossing  A point in an audio file where the waveform crosses the zero amplitude 
axis. If you cut an audio file at a zero crossing there will be no click at the cut point.

zoom  An action that enlarges (zooms in on) or shrinks (zooms out from) the display in 
a Logic Pro window. The Zoom tool, and the zoom controls found in the lower left and 
upper right corners of windows, are both used for zooming tasks. Also see zoom 
control and zoom level. 

zoom control  The control that appears at the bottom right of some windows, such as 
the Arrange. The zoom control slider allows you to navigate through the entire length 
of the currently displayed project. The lines on the left and right of the slider can be 
clicked to zoom in and out by a fixed percentage. 

zoom level  The amount that window contents (tracks and regions, for example) are 
magnified. Zooming in to a high level allows you to make more precise edits. 
Conversely, you can zoom all the way out to see the entire project and work on very 
large sections. 
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Zoom tool  This tool allows you to zoom in on any part of the active Logic Pro window. 
You can choose this tool from the Toolbox, or activate it when using other tools by 
holding down the Control key and clicking. 



     1003

In
de

xIndex

5.1 (ITU 775) format  809
6.1 (ES/EX) format  809
7.1 (3/4.1) format  810
7.1 (SDDS—Sony Dynamic Digital Sound) format  810

A
AAC. See Advanced Audio Codec (AAC)
AAF file

described  971
exporting  638
opening/importing  638

accelerando  971
accents (notation)  684
Acid Loops in Loop Browser  620
ADAT  90, 971
AD converter  971
Advanced Audio Codec (AAC)

applying to audio file  535, 610
described  971
direct playback in Logic  274
file  256

AES/EBU  90, 971
aftertouch event  450, 971
AIFF file  256, 971

See also audio file
bouncing  606

AKAI  971
ALAC. See Apple Lossless Audio Codec
alias (MIDI region)  282, 324, 972

converting into real region  327
creating  325
deleting  327
editing in Score Editor  695
finding original  326
reassigning  326
searching  326
selecting  326

alias assigner object  929
aliasing  972
alias object  915
All Notes Off message  395
All Objects layer  861
All view (Mixer)  576

amplifiers  85
amplitude

described  972
display in Sample Editor  491

AMS. See Audio MIDI Setup (AMS) utility
analog  972
Analyze button (Beat Mapping track)  658
Analyze button (Chord track)  665
anchor  280

editing  290
protecting  291

Apogee hardware  15
Apple Loops

adding  264
to blank Arrange area  187

blue sound wave icon  264
browsing  266

from particular Jam Pack  265
in particular scale  265
with particular time signature  266

converting to audio file  623
creating  615

from ReCycle files  619
in Apple Loops Utility  618
in Logic  616

described  257, 263
fading  345
Favorites collection  269
global tracks  621
green note icon
one-shot  616
previewing  268
sample rate  624
searching  270
SIAL (Software Instrument Apple Loop)  264

send effects  618
Apple Loops Utility  618
Apple Lossless Audio Codec

applying to audio file  535, 610
described  972
file, described  256

Apple QuickTime object  914
Apple Store  18



1004 Index

 

Apple websites  17
arpeggiator object  897
Arrange area

changing background  294
displaying grid  293
Drag menu  297
editing automation data  589
editing MIDI events  394
editing regions  295–349
overview  30
shortcut menu  305
Snap menu  295

overriding snap grid  296
time stretching regions  317, 525

Arrange channel strips  43, 208
Hand tool  218

arrangement
inserting cut section  323
inserting gap  321
removing gap  321
removing section  322
repeating section  323

Arrange view (Mixer)  575
Arrange window

Audio Bin. See Audio Bin
Browser. See Browser
channel strips  43, 208
editing area  44
Event List. See Event List
Inspector. See Inspector
interaction between areas  51
Library. See Library
Lists area  37
Loop Browser. See Loop Browser
Marker List. See Marker List
Media area  31
overview  28
Signature List. See Signature List
Tempo List. See Tempo List
Toolbar. See Toolbar
Transport bar. See Transport bar

ASCII  972
assets  136
attack  972
attenuating  973
Audio  308
Audio Bin

anchor editing  291
audio file

adding  273
copying/converting  535
moving to another location  534
optimizing  537
removing from project  274, 287
renaming  533
sorting  530

viewing associated regions  286
audio file group  531

deleting  533
opening  533

changing length display  286
opening

as window  286
in Arrange window  285

overview  31
region

auditioning  288
creating  287
deleting  287
locking  292
managing  284
moving within audio file  290
resizing  289
saving as audio file  537
sorting  286
viewing all  286

showing file info  530
showing region use count  286
tab versus window  285

audio cables and connectors  89
audio channel strip  566
audio file

adding  271
adding multiple  272, 273
adding to blank Arrange area  187
adding to iTunes library  604
backup

creating  503
reverting to  503

bouncing  601
changing level  497
copying/converting  535
copying selection  495
creating fade  497
creating from Apple Loop  623
creating from region  537
creating from track  538
cutting selection  495
deleting (moving to Trash)  536
deleting selection  495
deleting unselected portions  499
displaying as sample bits  493
extracting groove template  462
following project tempo  526
grouping in Audio Bin  531, 533
increasing perceived volume  510
managing  529
moving to another location  534
normalizing  499
opening in external sample editor  518
optimizing  537
pasting selection  495
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pitch shifting  505
playback of compressed formats  274
pop and click removal  496
quantizing  509, 516
reducing noise  512
removing DC offset  500
removing from project  274, 287
removing silent passages  519
renaming  533
reversing  499
reversing phase  500
saving

copy  503
sample loop settings in file header  501
selection as audio file  504

searching  259
file previously used in project  539
peak  490
silence  490

silencing selection  498
smoothing  496
sorting  530
supported formats  255
time stamp  311
time stretching  505, 525
transforming into MIDI region  514
viewing associated regions  286
viewing information  530

audio interface  83
configuring  96
connecting  91

Audio MIDI Setup (AMS) utility  95
audio recording. See recording
audio region. See region
AudioSuite plug-ins  518
Audio to MIDI Groove Template command  463
audio track

creating  185
described  180
exporting to movie  802
importing from movie  802

Audio Unit plug-in  252
loading preset  252
Node application  103

Audio Units Manager  252
disabling Node processing  103
opening  253
Safe mode  254

AU See Audio Unit plug-in
Auto Define checkbox (Hyper Editor)  428
Auto Input Monitoring setting  357
automation  581, 974

changing transparency level of data/regions  584
choosing parameter  583
converting  600

copying data  591
copying data between parameters  591
creating/writing data  588

with external controller  594
deleting data  588, 590
displaying data  582
editing data  589, 592
editing data in Event List  594
hiding all automation data  584
hiding a track’s automation data  583
Latch mode  587
moving data  591
moving data with regions  591
node  582

creating  589
deleting  591
selecting  589

Off mode  586
offsetting data  593
preferences  969
Read mode  586
relative/absolute value changes  592
sample accurate mode  581
scaling data  592
selection methods  589
setting mode  585

via key commands  586
snapping data to grid positions  593
Touch mode  587
viewing all existing automation data  585
viewing multiple parameters  584
with one hardware MIDI controller  595
Write mode  587

Automation Curve tool  592
Automation Event List  594
Automation Parameter menu  582
Automation Quick Access function  595
Automation Select tool  589
Autopunch button  370
Autopunch function. See punch recording
Auto Track Zoom function  195, 973
auxiliary channel strip  567

choosing input  568
creating  567
using as send return  568
using as subgroup  569
using for external audio processing  569

auxiliary return/send. See send effect

B
background color

Arrange area  294
Piano Roll Editor  416

background noise, removing  519
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backup
audio file  503, 630

reverting to  503
on .Mac account  625

creating  627
restoring  627

project  630
automatic safety copy  153

Balance/Pan control  212, 549
bank select message  882, 887
bar, described  974
bar line (notation). See notation
Bar ruler  49, 974

display modes  74
beat  974
beat mapping  655–660

improving accuracy  658
to markers  660
to scene markers  660
with audio region  658
with MIDI region

Beat Mapping track  655–660
Analyze button  658
Apple Loops  621
Beats from Region button  659
Detection Sensitivity parameter  658
Protect MIDI checkbox  659
relationship to Tempo track  646

beat slashes (notation)  705
beats per minute  975
Bezier curve  974
Big SMPTE/Bar Display setting  120
binaural hearing, described  559
Binaural Panner  555
Binaural Post-Processing plug-in  558
bit depth  975

described  975
supported by Logic  83, 255
when recording  354

bit rate  608, 975
bit resolution. See bit depth
boosting  975
Bounce function  601–614

adding audio file to iTunes library  604
Advanced Audio Codec (AAC)
Apple Lossless Audio Codec (ALAC)  610
bounce range  603
creating bounce file  602
described  975
file format  604
normalizing file  605
Offline mode  605
Realtime mode  605
setting bounce folder and name  613
Start/End Position  604
surround audio files  606, 828

Bounce window
Burn options  611
global options  603
M4A:AAC options  610
MP3 options  607
PCM options  606

bow markings (notation)  684
bpm. See beats per minute
Broadcast Wave file  256

bouncing  604
recording  959
timestamp  311

Browser
advanced search  260
Back button  259
bookmark buttons  258
Browser view  258
Forward button  259
List view  258
Minus/Plus icon  260
navigating  258
opening  257
overview  36
Path menu  259
searching files  259

clearing search term  260
defining conditions  262
viewing recent search term  260

sorting files  260
buffer size

audio hardware  97
AudioSuite plug-ins  518
processing  98

burning
DVD-Audio  611
Red Book audio CD  611

bus (Mixer), described  87, 975
bus channel strip  938
bus effect/return/send. See send effect
bypassing

described  975
plug-in  226
send effect  235

C
cable switcher object  928
CAF file

bouncing  606
creating  535
described  256, 976
maximum recording size  359
recording  352

Camera tool  774, 976
Caps Lock Keyboard  389

preferences  390
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Catch function  71, 976
CD burning  611
cent  976
Change Display Only mode (Chord track)  665
Change Gain command  497
Channel EQ  217
channel splitter object  896
channel strip  976

adjusting multiple  561
assigning color  577
audio. See audio channel strip
auxiliary. See auxiliary channel strip
Balance/Pan control  212, 549
Channel EQ thumbnail  217
Channel Strip Settings menu  219
Clip Detector  548
creating  183–187
customizing display  577
Group slot. See group (Mixer)
in Mixer  542
input format  210, 816

effect on Plug-in menu  212
Input slot  554
instrument. See instrument channel strip
Instrument slot  566
level

setting  546
switching between two values  547

Level fader  212
level meter  547

determining order  817
switching display scale  548

list of elements  545
loading configuration. See channel strip setting
master. See master channel strip
MIDI. See MIDI channel strip
moving to particular types in Mixer  574
Mute button  551
output. See output channel strip
Output slot  554
overview  208
selecting input  554
selecting multiple  560
selecting output  554, 602
setting output to surround  560, 818
Solo button  550
types  566

filtering from Mixer display  576
channel strip object  935

parameters  936
channel strip setting

copying  221
deleting  220
described  976
loading  219

by sending MIDI message  221

performance  221
resetting  220
saving  221
switching to next/previous  220

Channel Strip Settings menu  219
Chase Events function  115
checkbox  55, 976
chord event

changing display only  665
creating  664
creating by analyzing MIDI region  665
deleting  664
moving  664
selecting  664

highest/lowest note  414
splitting  413

chord memorizer object  906
Chord Memorizer window  907
chord symbol in score  719
Chord track  661–666

Analyze button  665
Apple Loops  621
Change Display Only mode  665
inserting chord into score  666

chorus effect  977
clefs (notation). See notation
clicking and holding (mouse use)  155
clicks, removing  496, 513
Clipboard  176, 977
Clip Detector  548
clipping  549
clone (audio region)  282

converting into new audio file/region  327
creating  327

coda sign (notation)  688
color

assigning to channel strip  577
assigning to region  304
in Piano Roll Editor  398, 416

showing region color  399
in Score Editor  775, 793

comb filter effect  977
Command-click tool  166
Compare button (plug-in window)  226
Compensate Region Position function  291
comping  374

editing a comp  375
in real time  368
moving comp  376
naming comp  376
removing comp  376
saving comp  376

compressor  977
Configure Global Tracks command  76
Configure Track Header command  181
Content Catch mode  72
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Content Link mode  72
context menu. See shortcut menu
control change event  448
controller

described  977
resetting  396
using for automation  595

Controller Assignments window  165
control surface

assigning key command  164
preferences  970
setup  84
support  15

Controls view (plug-in)  230, 978
converting

alias into audio file/region  327
Apple Loops to audio files  623
audio file  535
automation  600
event definition  433
marker into scene marker  801
ReCycle files to Apple Loops  619
region loop into alias/clone  331
region loop into copy  330
split stereo file to interleaved stereo  855
sustain pedal event to note length  410

Core Audio  83, 96, 978
preferences  97

Core MIDI  83, 978
count-in. See recording
Create take folders setting  379
Create Track button  184
crescendo

applying to MIDI events  467
notation. See notation

Crossfade tool  343
cross staff beaming  757
cueing  978
cutting (removing)

audio file section  495
event  177, 426
note event  410
region  319
section between locators  322

Cycle function
cycle area

defining by marker  114, 134
defining by regions  113
defining graphically  111
defining numerically  112
defining via commands/buttons  113

described  110, 978
preferences  956
skipping cycle  114
switching on  111

Cycle Through Windows command  60

D
D.S./D.C. sign (notation)  688
DA converter  978
DAE  15, 96
DAW. See digital audio workstation
dB. See decibel
DC offset, removing  500
decibel  979
delay line object  904
deleting

audio file (moving to Trash)  536
audio file section  495
audio recording  308, 373
audio region  287
automation data  588, 590
channel strip setting  220
chord event  664
Environment layer  860
Environment object  864
event definition  430
fade  343, 344
hyper set  436
key command  163
marker  128
MIDI event  423, 446
note event  403
orphaned alias  327
plug-in setting  229
region  307
score object  692
score set  765
screenset  80
signature  727
staff style  749
track  190
transposition event  664

Demix by Event Channel function  414
De-Quantize command  460
destructive editing

described  979
in Sample Editor  487, 496

Detection Sensitivity parameter (Beat Mapping 
track)  658
dialog  979
digital  979
digital audio workstation  978
Digital Factory

Audio Energizer  510
Audio to MIDI Groove Template  463
Audio to Score  514
Groove Machine  509
Quantize Engine  516
Silencer  512
Time and Pitch Machine  505

digital signal processing  980
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Dim Level preference  149
Direct TDM  96
Discard Recording and Return to Last Play 
Position  364
distributed audio processing  99
division value  106, 147, 980
DNA Groove Template. See groove template
documentation  15

conventions  16
websites  17

Dolby Pro Logic format  808
double-clicking  155
Double-clicking a MIDI Region opens menu  393
Down Mixer plug-in  824
dragging (mouse use)  155
Drag menu  297
driver  980
drum

hi hat mode  435
notation  758

drum loop, isolating individual beats  519
drum-mode device  888
DSP. See digital signal processing
ducking  231
Duplicate Track button  187
DVD-Audio burning  611, 828
dynamic range  980
Dynamics parameter (Region Parameter box)  348
dynamic symbols (notation)  683

E
Edit menu

Copy function  177
Cut function  177
Paste at Original Position function  177
Paste function  177
Paste Replace function  177

editor, described  980
Editor view (plug-in)  230, 980
effect plug-in  212

See also plug-in
adding  213

Channel EQ  217
multi-channel effect. See surround
routing  233

envelope  980
Environment  857–938

All Objects layer  861
assigning object to track  194
cables

coloring  862
hiding  862

cabling  871
in parallel  874
object to sub-instrument input  885

serially  874
described  981
exchanging  877
frameless floating window  863
Global Objects layer  861
hiding Inspector  862
importing  877

multi-layer Environment  878
options  879

layers  859
choosing  860
creating  860
deleting  860
naming  860

macro  916
mapped instrument  888
MIDI signal path  868
Mixer layer  935
object

aligning horizontally/vertically  866
common parameters  875
copying  865
creating  864
deleting  864
filtering in Track Assignment menu  876
moving  864
resizing  866
selecting  867
setting output  870
snapping to grid  866

object types  880–938
opening  859
overview  858
Prelisten channel strip  938
swapping  878
viewing objects as list  862

equal temperament  946
Eraser tool  169, 307, 403, 981
event. See MIDI event
event definition  427, 981

converting  433
copying between hyper sets  429
creating  428

for a region’s event types  429
for a specific event  428
several  428

delaying  432
deleting  430
editing  430

event status  430
first data byte  431
multiple  433

naming  432
reorganizing lanes  430
selecting  427

Event Float window  452
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Event List
Additional Info button  439
aftertouch event  450
control change event  448
creating event  442
deleting event  446
displaying release velocity  439, 448
displaying score layout information  440
display of mapped instrument notes  448
duplicating event  442
editing event  443

length  444
position  444
type  445

filtering event types  439
length as absolute position  445
meta event  451
muting event  446
note event  447
opening

as window  392
from Piano Roll Editor  416
in Arrange window  393, 438

overview  437
pasting event  442
pitch bend event  449
poly pressure event  450
program change event  449
protecting event position  443
region

moving  310
naming  447

Rel Vel event  439, 448
selecting event  441

via key command  441
shortcut menu  440
soloing event  446
switching to SMPTE value display  310, 445
SysEx event  451

in hexadecimal format  451
viewing

events/regions  438
viewing all information stored with events  439
viewing events outside the display area  440
viewing relative event position  445
view level  438

exponential level meter scale  548
exporting

AAF file  638
audio tracks to movie  802
Final Cut Pro/XML file  639
key commands  161
OMF file  635
Open TL file  636
region as audio file  640
Standard MIDI file  633

track as audio file  640
Express Card  89
extended parameters (plug-in window)  231
external audio effect  251
External Instrument plug-in  246
external MIDI instrument

processing with Logic effects  246
setting Inspector parameters  244
setting up  237

external sample editor  518

F
fade

adjusting fade curve  498
applying to audio file  497
assigning to Apple Loops  345
automatic crossfade  342
changing  343, 344
creating  343, 344
curve shape  344, 345
deleting  343, 344
type  345

fade file, deleting  345
fader object  918

alias assigner  929
cable switcher  928
Filter parameter  926
grouping temporarily  921
input definition  924
meta event fader  929, 930
operation  919
output definition  924
recording movements  922
resetting  921
sending values  921
styles  922
SysEx fader  931
Vector fader  927
working with groups  920

Fade tool  343, 981
Fade Type menu  345
fermatas (notation)  684
file

audio. See audio file
searching  259

Filter button (Event List)  439
filter effect  981
filter slope  982
Final Cut Pro/XML

exporting  639
importing  639
retaining sample rate  639

Find field  982
Finger tool  133, 408, 982
FireWire technology  88, 982
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First Data Byte checkbox (Hyper Editor)  431
Fixed Value checkbox (Hyper Editor)  422
folder (region)  281, 338, 982

adding region  341
creating alias  342
displaying in Mixer  578
displaying in Score Editor  775
entering  340
exiting  340
naming  447
packing  339
removing region  341
soloing  446
unpacking  340

folder track  180
Follow Tempo function  372, 526
Format button  210
forwarding  109
frame rate

detecting automatically  648, 834
setting  834

Freeze function  200, 982
freeze files  203
refreshing freeze files  204

From Regions button (Marker track)  126

G
GarageBand project, opening  634
Gate Time parameter (Region Parameter box)  349
General MIDI. See GM
Generator plug-in

adding  214
described  212

Giant Bar/SMPTE Display command  121
Global Objects layer (Environment)  861
global tracks

Apple Loops  621
Beat Mapping. See Beat Mapping track
Chord. See Chord track
hiding/showing  76
in Score Editor  776
Marker track. See Marker track
overview  50
protecting  77
reordering  77
resizing  77
Signature. See Signature track
Tempo. See Tempo track
Toggle key commands  77
Transposition. See Transposition track
Video. See Video track

Glue tool  170, 334, 983
GM Drum Kit hyper set  418
GM mixer object  892

GM standard, described  983
Go to Position button  108
grabbing (mouse use)  155
grace note (notation)  703
groove template  461–464

creating  461
from audio file  462

importing  462
removing  461
using across projects  462

group (Mixer)  562–565
assigning  563
disabling temporarily  565
settings  564

group (of audio files)  531
deleting  533

GS effect  573

H
Hand tool  217–218, 983
hard drive  83
headphones  86
headroom  548
help tag  170

displaying  170, 966
Hermode Tuning  947
Hide unused parameter checkbox (Transform 
window)  476
Hide View button  204
hiding

all open plug-in windows  223
global tracks  76
Inspector  74
track  204

Hierarchy button  65, 983
hi hat mode  435
Hyper Draw function  596, 983

activating  596
Autodefine mode  598
choosing event type  596
editing  598
in Piano Roll Editor. See Piano Roll Editor
in Score Editor  677
key commands  600
Note Velocity mode  599
recording  598
setting MIDI channel  597

Hyper Editor  417–436
Auto Define checkbox  428
beam display  420
copying event  426
creating event  421

with value of previous event  422
deleting event  423
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editing event
length  423
value  425

event definition. See event definition
First Data Byte checkbox  431
Fixed Value checkbox  422
grid  419
hi hat mode  435
moving event  425

via key commands  426
opening

as window  392
in Arrange window  392

overview  47, 417
Pen Width menu  420
protecting event position  427
restoring deleted event  424
selecting event  423

hyper set  418, 984
choosing  418, 436
clearing  436
copying event definition  429
creating  434
creating GM drum kit  435
default  418
deleting  436
naming  436

I
I/O Buffer Size setting  97
I/O plug-in  251
icon

assigning to template file  154
track/instrument  196, 242

ID3 tags  609
importing

AAF file  638
audio file. See audio file (adding)
audio track from movie  802
Environment  877
Final Cut Pro/XML file  639
GarageBand project  634
groove template  462
key commands  161
movie file. See movie file (opening)
OMF file  636
Open TL file  637
project settings  141
ReCycle file  276
score set  768
screenset  80
split channel audio file  854
staff style  748
Standard MIDI file  632

text style  715
transform set  482

In button  385
Include Assets checkbox  137
Include Non-Note MIDI Events setting  407
Independent Monitoring Level (for Record Enabled 
Channel Strips) preference  358
independent note (notation)  703
input (audio hardware), selecting  554
input channel strip  938
input monitoring. See recording
Input Monitoring button  357
Input slot (channel strip)  554
insert effect  233
Insert Instrument MIDI Settings as Events 
command  246
Inspector

described  984
hiding/showing  74, 182
instrument parameters  242
Movie area  797
Object Parameter box  875
overview  42
Region Parameter box. See Region Parameter box
Track Parameter box. See Track Parameter box

instrument channel strip  566
instrument plug-in  212

See also plug-in
adding  214
defining pitch range  243
defining velocity range  243
delaying  243
icon  242
increasing/decreasing note velocity  243
Inspector parameters  242
live mode  247, 383
multiple outputs  214, 567
playing  247
preventing from following Hermode Tuning  249
preventing transposition  243
transposing  242
tuning  248

Instrument slot (channel strip)  566
instrument track  180

creating  186
multi-timbral  186
Record Enable button states  383

interface  27, 985
Interpretation setting (Score Editor)  732
iTunes, adding audio file to library  604

J
jazz symbol (notation)  689
Junction pointer  313
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K
keyboard object  895
key command  57

Append Track to Track List  188
Apply Quantization Settings Destructively  458
Automation Event List  594
Capture as Recording  382
Clear Overload Flag in Audio Channel Display  549
Close Project without Saving  154
Close Window  62
Configure Global Tracks  76
Delete and Select Next Region/Event  405
Deselect All Regions Except on Selected Track  175
Duplicate Screenset  79
Event Channel -1  176
Event Position and Length in SMPTE Units  75
Go Into Folder or Region  65, 340
Go to Marker Number 1—20  133
Go to Next/Previous Marker  133
Go to Selection End  110
Hide/Show All Plug-in Windows  223
Hide/Show Inspector  74
Hide All Global Tracks  76
Individual Track Zoom In/Out  196
Individual Track Zoom Reset  196
Individual Track Zoom Reset for All Tracks  196
Lock/Unlock Current Screenset  79
Make Groove Template  461
Move Selected Regions to Current Track  313
Mute/unmute selected Notes/Regions/
Folders  299
Next Note Will be Flat  387
Next Note Will be Sharp  387
Next Screenset  78
Next Three Notes are Triplets  388
Next Two Notes are a Dotted Group  388
Nudge Region/Event Position by …  311, 407, 426
Open File Browser  257
Page Top/Bottom/Left-Most/Right-Most  67
Page Up/Down/Left/Right  67
Play or Stop  109
Previous Screenset  78
Recall Screenset 1 to 9  78
Recall Zoom 1–3  69
Rename Screenset  80
Reselect Solo-Locked Regions  301
Rest  388
Save as Zoom 1–3  69
Scrub Rewind/Forward  299
Secondary Ruler  75
Select Next/Previous Region/Event  172
Select Next/Previous Track  190
Select Previous Section for Realtime 
Comping  368
Set Locators and Play  113

Set Next Tool and Set Previous Tool  168
Set Rounded Locators and Play/Record  113
Set Rounded Locators by Regions/Events  113
Set Track & MIDI Thru Parameters by Region/
Folder  346
Set X tool  168
Show All Global Tracks  76
Show Tool menu  168
Shuttle Rewind/Forward key command  110
Step Backward  388
Step Forward  388
Stop and Go to Last Play Position  109
Stop and Go to Left Locator  109
Store Navigation Snapshot  70
Swap Left and Right Locator  115
Toggle … Window  62
Toggle Automation Quick Access  595
Toggle File Browser  257
Toggle Global Tracks  76
Toggle Group Clutch  565
Toggle Individual Track Zoom  196
Toggle Loop Browser  263
Toggle Marker Track  124
Toggle Next/Previous Region/Event  174
Toggle Track Mute  198
Toggle Track Mute of all Tracks of Folder  198
Toggle Track Mute of all Tracks with Same 
Instrument of Project  198
Unhide all Tracks  205
View Track Automation  582, 584
Zoom to fit Locators, store Navigation 
Snapshot  70
Zoom to fit Selection horizontally, store 
Navigation Snapshot  70
Zoom to fit Selection vertically and horizontally, 
store Navigation Snapshot  70

key commands  158
assigning  162

to control surface message  164
browsing  161
copying to clipboard  165
deleting assignment  163
exporting  161
file location  158
Find history  162
groups  160
hard-wired  159
hierarchies  160
importing  161
initializing  165
presets  161
printing  165
saving  158
searching  161
special keys  159
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Key Commands window  159
Learn by Key Label button  162
Learn by Key Position button  162
Learn New Assignment button  164
opening  159

key signature  723
alternative  727
copying  726
creating  725
deleting  727
editing  727
in Part box  685
selecting  725

KlopfGeist. See metronome

L
Late-Breaking News  17
latency  847, 985

Low Latency mode  848
plug-in delay compensation  849

Layer recording  382
Layout tool  696
LCRS  808
left locator  106, 112

See also locators
legato  985

chord handling  410
forcing for notes  409
forcing in region  349

level
setting for channel strip  546
switching between two values  547

Level fader  212
level meter (channel strip)  547

display scale  548
LFE (Low Frequency Enhancement)  821
Library

assigning MIDI channel  240
loading channel strip setting  219
loading plug-in setting  232
overview  35
refreshing  630
Revert button  220

linear view (Score Editor)  672, 769
line break symbol (notation)  690
Lines to Channels function  414
Line tool  422
Link button  49, 71

described  985
plug-in window  225
Staff Style window  744
Surround Panner  819

Lists area, overview  37
live mode (instrument plug-in)  247, 383
Live mode (ReWire)  251

local menu bar  48
Local Off function  94
Locator display  112
locators  106, 112

setting by events/regions  113
setting by marker  114
swapping  115

Logic, opening  27
Logic interface  28
Logic website  17
Loop Browser

Acid Loops  620
adding loops  620
blue sound wave icon  264
category buttons  266

customizing  268
resetting  268

Column view  267
Fav column  269
green note icon
limiting display

to particular Jam Pack  265
to particular scale  265
to particular time signature  266

Music view  266
opening

as independent window  263
in Arrange window  263

overview  33
previewing Apple Loops  268
Reset button  268
sorting loops  269
Sound Effects view  266
view buttons  266

Low Latency mode  848
LTC (Longitudinal Time Code)  841
lyrics. See notation

M
mapped instrument object  888

note display in Event List  448
Mapped Instrument window  889
marker  123

assigning to beat  660
coloring  133
converting into scene marker  801
copying  127
creating  125

during playback  126
from cycle  127
from regions  126

deleting  128
editing  131
length  126

adjusting to cycle  132
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as absolute position  134
editing  132
in SMPTE units  134

locking to SMPTE position  131
moving  131
naming  128
navigating

moving to next/previous  133
moving to particular marker number  133
playback at start position  133
playhead to marker  133

selecting  128
text  124

changing appearance  130
Marker List  124

customizing display  134
opening  124
overview  39

Marker Text area/window  124
Marker track

From Regions button  126
opening  124

Marquee tool  305
master channel strip  570

in surround projects  827
Master Level slider  148
Max Dots setting (Score Editor)  735
Media area, overview  31
memory

reconfiguring  143
size (computer)  82

meta event  451
controlling transformer object  902
list of  930

meta event fader  929, 930
metronome

See also MIDI Click object
KlopfGeist  355
setting up  354

microphone  87
MIDI Activity display  395
MIDI automation. See Hyper Draw
MIDI cabling  91
MIDI channel

changing for event  176
setting to maximum value  396

MIDI channel strip  570
GM/GS/XG functions  573
saving settings  573

MIDI Click object  913
MIDI Clock

activating transmission  838
delaying transmitted time code  838

MIDI controlled effect
adding  214
described  212

MIDI Controls hyper set  418
MIDI device

connecting  91
multi-timbral  93

MIDI event  281
aftertouch event  450
channel  176, 433
control change event  448
copying  395, 426

range  410
creating  442

controller events  596
in Hyper Editor. See Hyper Editor
in Piano Roll Editor. See Piano Roll Editor

delaying  432
deleting  446

duplicates  404
in reference to locator positions  404
outside MIDI region  404
similar  424
unselected within selection  405

described  981
duplicating  442
editing

in Arrange area  394
overview  391
type  445
via Clipboard  395

end/start point
setting to playhead position  408

event types  447–452
filtering  383
hearing when editing  394
humanizing  470
inserting program, volume, and pan from 
Inspector  246
length

changing randomly  484
editing  423, 444
restricting  474
setting multiple to constant value  473

meta event  451
moving  425

via key commands  407, 426
muting  446
note event. See note event
pitch bend event  449
poly pressure event  450
position

editing  444
protecting  412, 427, 443
reversing  470

program change event  449
quantizing. See quantization
restoring deleted event  405, 424
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selecting  423, 441
identical  404
inside a range  485
similar  404

sending
pan  396
program  396
used MIDI instrument settings  396
volume  396

soloing  446
SysEx event  451
tempo

doubling  468
halving  469

transforming  465–486
transposing

in Transform window  471
with Chord/Transposition track  662

velocity
changing randomly  484
increasing gradually  467
limiting  473

MIDI instrument (external)
processing with Logic effects  246
setting Inspector parameters  244
setting up  237

MIDI interface  84
MIDI keyboard  84

Local Off function  94
stopping internal sound source  94
USB connector  94

MIDI Machine Control  844
activating transmission  839, 844
controlling Logic  839

MIDI Out button  394
MIDI recording. See recording
MIDI region. See region
MIDI signal path (Environment)  868
MIDI Thru function  346

disabling for instrument  384
MIDI Thru port  92
MIDI Thru tool  864
MIDI Time Code

activating transmission  839
described  988
detecting automatically  834
interpretation  831
validating  835

MIDI track  180
creating  185

mini-plug connectors  90
Mixer

All view  576
Arrange view  575
Binaural Panner  555
Binaural Post-Processing plug-in  558

channel strip. See channel strip
filtering channel strip types from display  576
folder track  578
groups. See group (Mixer)
Hand tool  217
moving to particular channel strip types  574
opening  209, 541, 542
overview  44, 542
renaming track  577
Single view  574
views  574

mixing  541
basic steps  543

mixing console  86
MMC. See MIDI Machine Control
MMC record buttons object  895
modifier key  988
monitoring. See recording
monitoring system  86
monitor object  896
Mono to Surround Panner  820
mouse use  155
mouse wheel

adjusting plug-in parameter  225
scrolling/zooming  156

Move Automation with Regions menu  591
movie

displaying in Inspector  797
exporting audio track to movie  802
importing audio track from movie  802
opening  798
QuickTime, described  992
removing  798
scene marker. See scene marker
SMPTE offset  804

Movie window  798
MP3 file  256

bit rate  608
bouncing  607
creating  535
described  989

MTC. See MIDI Time Code
multi instrument object  883

activating sub-instrument  884
sub-instrument parameters  885

Multi Instrument window  885
multi output instruments  214

Node application  103
Multiplayer recording  382
multi-timbral  93, 883, 989
Multi-timbral checkbox  186
Mute button (channel strip)  551
Mute tool  170, 299, 413, 989
muting

channel strip  551
described  989
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MIDI event  446
multiple tracks  198
note event  413

of particular pitch  413
region  299
selected notes/regions/folders  299
track  197
tracks with same destination  198

N
naming

audio file  533
comp  376
Environment layer  860
event definition  432
folder  447
hyper set  436
marker  128
region  302, 447

after track  303
multiple  302

score set  763
screenset  80
take  376
track  191

native processing  989
New Tracks dialog  184
Node application  99–103

Audio Unit effects  100
Audio Unit instruments  103
enabling  101
Ethernet network  100
EXS instruments  103
multi output instruments  103
network considerations  100
preferences  101

No HMT checkbox (Inspector)  249
noise reduction  512
No Overlap setting (Score Editor)  734
No Reset checkbox (Inspector)  243
normalizing

audio file  499
MIDI region parameters  349

notation
See also Score Editor
accents  684
accidental  687

changing display  737
distance from note  737

bar line
deleting  709
in Part box  686
invisible  709

beat slashes  705
bow markings  684

breaks  770
changing graphical position of objects  696
chord symbol

changing enharmonically  721
editing  720
inserting  719
inserting from Chord track  666

clef
choosing  751
editing  705
in Part box  682

coda sign  688
color  793
copying object  692, 694
copying section  694
D.C/D.S symbols  688
deleting object  692
displaying instrument names  776
displaying only particular instruments. See score 
set
display parameters  728
display quantization  730

fixing  732
drums  758
dynamic symbols  683
editing several objects  691
entering notes/symbols  672

insert quantization  676
into several regions  676
MIDI channel/velocity  675
using the Part box  674
via step input  673

exporting as graphic file  774
fermatas  684
full score display  675
German chord symbols  722
global text  716
grace note  703
independent note  703

changing status  740
Insert Defaults settings  676
inserting

chord from Chord track  666
current date  717
name of display level  717
name of score set  717
project name  717

Interpretation setting  732
jazz symbol  689
key signature. See key signature
limiting input to diatonically correct notes  699
linear view  672, 769
line break symbol  690
lyrics  718
margins  771
MIDI aliases  695
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moving global object  693
moving object  692

impact of display quantization  693
restricting movement to one direction  693
with key commands  693

moving symbol attached to note  693
No Overlap setting  734
note

beaming  738, 757
changing individual  736
color  740
hiding key switch notes  749
horizontal position  737
in Part box  681
length  699
maximum number of dotes  735
pitch  699
resizing  736
staff assignment  739
velocity  698
voice assignment  739

note attributes. See note attributes
note head  683

changing  736
invisible  683

page break symbol  690
Page view  672, 769
Part box  678

arranging groups  678
group menu  678
group overview  681
locking group positions  679
opening floating Part box window  679
selecting objects  679
selecting objects via key commands  680
showing only symbols of selected group  679

parts. See score set
phrasing symbols  684
printing  772
repeating sections  695
repeat sign  687

deleting  709
editing  709
in Part box  686

resizing objects  697
rests

changing type/duration  705
in Part box  687
inserting manually  704

Score parameter  735
score set. See score set
slur/crescendi

changing length  707
changing position  707
in Part box  685
inserting with key commands  707

particular attributes  708
staff style. See staff style
stem direction and length  738
sustain pedal events  682
swing symbol  688
Syncopation setting  733
tempo symbol  688
text

automatic text objects  717
global text  716
parameters  713

text style  714
creating  715
importing  715

Text Style window  714
ties  699

changing direction  739
time signature. See time signature
trill/tremolo  687
tuplet  700
using musical symbol fonts  713
voice separation  754
workflow  669

note attributes  735–741
changing  736
resetting  741

Note Attributes window  736
note event

See also MIDI event
copying  410

range  410
deleting. See MIDI event
editing

length  408
velocity  412

forcing legato  409
individual pitches to different MIDI channels  414
interpreting for easy-to-read display  732
keeping when cutting  333
moving  406

via key commands  407
muting  413

multiple  413
of particular pitch  413

pitch
changing randomly  484
reversing  471

protecting position  412
removing overlaps  409
selecting

 See also MIDI event
highest/lowest in chord  414
muted  413

shortening when cutting  333
splitting when cutting  334
switching off stuck notes  395



Index 1019

 

tying to other event data  407
Note Force Legato function  409
note head (notation)  683
Note Overlap Correction function  409
Note Velocity mode  599
No Transpose checkbox  243
NTSC  841
Number of Undo Steps preference  177
numerical input  156

O
Object Parameter box  875, 990
OMF file

exporting  635
importing/opening  636

one-shot  616
onscreen help  17
opening

AAF file  638
GarageBand project  634
movie file  798
old songs  140
OMF file  636
Open TL file  637
project  139
Standard MIDI file  632

Open TL file
exporting  636
importing/opening  637

Optimize Files function  537
ornament object  916
output (audio hardware), selecting  554
output channel strip  569

Bounce button  601
Output slot (channel strip)  554
Overlapping recordings menu  379
overview creation  275

P
Pack Take Folder command  377
page break symbol (notation)  690
Page view button (Score Editor)  672, 769
PAL  841
Pan/Balance control. See Balance/Pan control
parallel effect routing  236
Part box (Score Editor). See notation
Paste at Original Position function  177
Paste Replace function  177
patch selection  449
Pause button  109
PCI (Peripheral Connect Interface)  89
peak

described  991
searching in audio file  490

peak level  548

Pencil tool  169, 496, 991
phase, reversing  500
phone plug connectors  90
phrasing symbols (notation)  684
Physical Input object  912
Piano Roll Editor  397

background  968
customizing colors  416, 968
grid  398
Hyper Draw  414

creating  415
resizing display  415
viewing  414

info display  401
interface  397
limiting drag direction  406
note

changing length  408
color  398
copying  410
creating  402
deleting  403
editing velocity  398, 412
moving  406
muting  413
protecting position  412
removing overlaps  409
selecting  402
setting end/start point  408

opening
as window  392
in Arrange window  392

overview  46
shortcut menu  402
snap grid

overriding  401
using  400

splitting chords  413
tying other events to note events  407
viewing

multiple MIDI regions  399
selected MIDI regions only  399

pitch, described  991
pitch bend event  449

scaling  468
pitch shift/time stretch algorithm  506

third party support  507
pitch shifting audio file  505
playback  991

controlling
via key commands  109
via transport buttons  108

from beginning of project  108
from left/right locator  108
from left window edge  108
from marker position  133
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from previous bar  109
from selection  109
pausing  109
shuttling  110
starting  109
stopping  109

playhead
adjusting size  107
moving by note length  388
positioning  105

at beginning of project  108
at last play position  109
at locator  108, 109
at marker  107, 133
at selection end  110
at selection start  108
numerically  106, 108

plug-in
adding  213–214

configurations that do not match channel 
input format  212
in surround  823

adjusting parameter  223
high resolution  224
resetting  224
with mouse wheel  225

bypassing  226
effect. See effect plug-in
extended parameters  231
Generator. See Generator plug-in
instrument. See instrument plug-in
moving between channel strips  217
multi-channel effect. See surround
removing  214
replacing  214
setting. See plug-in setting
side chaining  230

plug-in delay compensation  849
plug-in setting  226

comparing  228
copying  228
creating default  229
deleting  229
folder structure  232
loading  227, 232
resetting  228
saving  229
switching to next/previous  227

plug-in window  223–231, 991
Bypass button  226
closing  223
Compare button  226
Controls view  230
disclosure triangle  231
Editor view  230
extended parameters  231

hiding/showing all open plug-in windows  223
linking  225
opening  223

on insertion  214, 223
Settings area  226
Show Channel Strip menu  229
Show Insert menu  229
Side Chain menu  230
switching contents  229
view mode  230

Pointer tool  169, 991
poly pressure event  450
pops, removing  496, 513
pop-up menu  56
position display  106
post fader  991
Post Pan setting  236
POW-r dithering  613
pre fader  991
preferences

Audio  957
Device  96
General  958
MP3  961
Nodes  101
opening  958
Reset  962
Sample Editor  960
Surround  812

Automation  969
Automation Quick Access section  595
Move Automation with Regions menu  591
opening  969
Ramp Time parameter  587
Write Mode Changes To menu  587

Control Surfaces  970
Display  966

Arrange  967
General  966
opening  966
Other  968

Global  953
Caps Locks Keys  390
Catch  957
Cycle  956
Editing  955
opening  953
Project Handling  953

initializing  953
MIDI  963

General  963
opening  963
Reset Messages  395, 965
Sync  964

overview  939
saving  940
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Score  795
Sharing  626
Video  805

Prelisten channel strip  938
preset. See plug-in setting
Process Buffer Range preference  98
program change event  449

sending  245
project

assets  136
including  137
managing  149

backup file  153
backward-compatibility  140
cleaning up  151
closing  154
consolidating  151
creating  136

automatically  141
definition  135
importing settings  141
length  148
moving/copying project folder  150
opening  139

automatically  141
via drag and drop  140

playback level  148
repairing  142
reverting to saved version  153
sample rate  143
saving  152

as template  153
start/end markers  148
surround format  815
switching between open projects  140
tempo  145, 641
time signature  146

Project Information window  143
project settings

Assets  149
Audio  950
importing  141
Metronome  941
MIDI  951

Chase  115
General  951
Input Filter  383

overview  939
Recording  943
saving  940
Score  776

Clefs & Signatures  788
Colors  793
Global  776
Guitar Tab  784
Layout  790

MIDI Meaning  792
Numbers & Names  781

Synchronization  832
Audio  836
General  833
MIDI  838
opening  832
Unitor  840

Tuning  944
Video  803

Protect MIDI checkbox (Beat Mapping track)  659
pull-down menu  56
punch in/out  992
punch recording

Autopunch  370
in Cycle mode  371
Punch on the Fly setting  369

Q
Quadraphonic  808
quantization  453, 992

applying MIDI region template to audio file  516
event-based

in Score Editor  459
Quantize tool  460
resetting  460

groove template. See groove template
region-based

applying destructively  458
choosing quantization grid  454
extended parameters  456
fine-tuning quantization grid  456

swing  455
Quantization menu  459
Quantize button  459
Quantize parameter (Region Parameter box)  454
Quantize tool  460, 992
Quick Swipe Comping feature  374
QuickTime. See movie

R
radio button  55
RAM  992
Ramp Time parameter  587
RCA connectors  90
Record Enable button  361
recording

audio  351
arming track  361
Autopunch function. See punch recording
bit depth  354
deleting  373
file name  360
file type  359
format (channel)  360
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in Cycle and Replace mode  372
maximum file size  359
monitoring  356–358
mono  360
overview  351
preparations  352
project tempo  372
recording folder  358
Replace function  372
sample rate  352
starting  363
stereo  360
surround  360
takes. See take recording

Broadcast Wave file  959
count-in  363
Discard Recording and Return to Last Play 
Position command  364
during external synchronization  831
in Cycle and Autopunch mode  371
metronome  354
MIDI  378

controller events  598
into existing region  381
multiple tracks  382
recapturing  382
Record Enable button states  383
single MIDI region  379
software instrument live mode  383
takes  379
via step input  384

overview creation  275
preventing track selection change  562
Record/Record Repeat command  364
Record/Record toggle command  364
Record button, configuring  364
simultaneous audio and MIDI recording  362
tempo event  646

Recording Delay parameter  98
Recording File Type menu  359
Recording Folder setting  359
ReCycle file  257

converting into Apple Loop  277, 619
Copy as ReCycle Loop function  278
importing  276
Paste ReCycle Loop function  278
transferring between Logic and ReCycle  278

Red Book audio CD  611
redoing an editing step  178
region  279

adjusting to fit other regions  316
audio

adjusting start point  314
anchor. See anchor
auditioning  288
beat mapping  658

clone  282
creating in Audio Bin  287
creating in Sample Editor  287
deleting  287
exporting as audio file  538
fading. See fade
finding transients  658
locking  292
managing  284
moving to recording position  311
moving within audio file  290
opening in external sample editor  518
opening in Sample Editor  284
removing silent passages  519
resizing  289
resizing from Sample Editor  314
saving as audio file  537
snapping to zero crossings  289
sorting  286
tempo. See tempo
viewing  286

audio and MIDI compared  283
coloring  304
copying  319
cutting  319
dividing  331

at locator positions  332
at playhead position  333
into several portions of same length  332
overlapping notes  333

drag modes  297
exporting as audio file  640
folder. See folder (region)
loop

converting into alias/clone  331
converting into real copy  330

looping  329
making multiple copies  328
merging  334
MIDI

adjusting length to content  318
adjusting start/end point  315
alias  282, 324
analyzing for chords  665
assigning staff style  741
creating  394
defining editor opened by double-click  393
demixing by event channel  337
demixing by note pitch  338
hiding in Score Editor  735
normalizing parameters  349
rounding start point to nearest bar  318
selecting multiple in Score Editor  729
transcribing  728

moving  309
between projects  309
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by specific grid amount  311
limiting to horizontal/vertical axis  309
numerically  310
onto selected track  313
to playhead position  311

moving into folder  341
muting  299
naming  302, 447

after track  303
multiple  302

quantizing. See quantization
removing from arrangement  307
removing gaps between regions  316
removing overlaps  316
resizing  313

adjacent regions  313
making multiple the same length  315

restoring removed  308
selecting  305
selecting/editing sections  305
setting start/end point to playhead  316
shifting playback position  312
snapping to time position  295
soloing  300, 446

locking status  301
staccato/legato  349
time stretching  317, 525

Region Parameter box  42, 346–349, 993
Clip Length parameter  315
Delay parameter  312
Dynamics parameter  348
editing regions simultaneously  347
Gate Time parameter  349
MIDI Thru  346
name  302
Quantize parameter  454

release velocity, viewing  439, 448
Remove Overlaps function  316
removing

background noise  519
DC offset  500

Reorganize Memory function  143
Repeat Regions function  328
repeat sign (notation). See notation
replace recording  372
reset messages  243, 395
Resolution menu (Tempo track)  643
rests (notation). See notation
reverb effect  993
rewinding  109
ReWire  249

accessing audio streams  250
accessing instruments  250
choosing ReWire mode  251
settings

Live mode  251

Playback mode  251
ReWire object  914
right-click (mouse use)  155

assigning to tool  167
right locator  106, 112

See also locators
Right Mouse Button preference  167
routing  994
rubber band selection  174, 994

S
S/PDIF  90
Same Level Link mode  72
sample. See audio file
sample accurate editing  295, 493
Sample Editor

absolute and relative time axis  492
adjusting tempo to audio file selection  501
amplitude

in percentage units  491
in sample units  491

anchor editing  291
audio file

changing level  497
copying selection  495
cutting selection  495
deleting selection  495
deleting unselected portions  499
increasing perceived volume  510
normalizing  499
pasting selection  495
pitch shifting  505
quantizing  509, 516
reducing noise  512
removing clicks/pops  513
removing DC offset  500
reversing  499
reversing phase  500
time stretching  505
transforming into MIDI region  514

Audio Suite plug-ins  518
creating audio region  287
creating fade  497
creating silence  498
customizing

amplitude display  491
time display  491
waveform display  493

destructive editing  487, 496
Digital Factory. See Digital Factory
going to

first silent section  490
loudest point in audio file  490
region start/end/anchor  490
selection start/end  490
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navigating  490
overview  45, 487
Pencil tool  496
playback  488

controlling with overview  489
key commands  489
looping  488

resizing region  289, 314
Sample Loop commands  501
scrubbing  489
searching peak  490
searching silence  490
selecting  494

audio file section  494
changing selection area  494
entire audio file  494

stereo file  45
undoing edits  501
using external  518

Sample Loop commands  501
sample rate  143, 994

matching file with project sample rate  144, 150
when recording  352

sampling  994
saturation  511, 994
Save Region(s) as function  537
saving

audio file copy  503
channel strip setting  221
comp  376
key commands  158
MIDI channel strip setting  573
plug-in setting  229
preferences  940
project  152
project settings  940
screenset  78
template  153
zoom setting  69

scale, described  994
scan code  994
scene marker  800

assigning to beat  660
converting into normal marker  801
creating  801
removing  801

Scissors tool  169, 331
score. See notation
Score Editor  667–796

colors  775
customizing  775
Diatonic Insert setting  699
displaying folders  775
displaying one/all MIDI regions  675
full score display  675
global tracks  776

hiding region  735
Hyper Draw function  677
limiting drag direction  693
linear view  672, 769
notation. See notation
opening

as window  392
from Piano Roll Editor  416
in Arrange window  392

overview  46, 668
Page view button  672, 769
Part box. See notation
quantization  459
selecting multiple MIDI regions  729
shortcut menu  690

Score parameter (extended region parameters)  735
score set

choosing  762
copying  765
creating  765

for all selected instruments  765
separate layouts for parts  767

deleting  765
determining included instruments  763, 766
displaying single instrument  768
importing  768
naming  763
scaling  766

Score Set window  763
screenset  78

copying  79
deleting  80
importing  80
protecting  79
recalling  78
renaming  80
reverting  80
saving  78
sequencer controlled switching  78

scroll bar  66
zooming  68

scrolling
using mouse wheel  156
vertically and horizontally at once  67

Scroll in Play setting  71
Scroll to Selection function  67, 161
scrubbing  298, 299

maximum scrub speed  99
only particular regions  299
Scrub by MIDI value (-2-) function  299
Scrub Response menu  99
with Solo tool  300

SDDS—Sony Dynamic Digital Sound format  810
SDII file  539

bouncing  606
creating  535
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importing/exporting  539
searching

alias  326
Apple Loops  270
audio file used in project  539
key command  161
Logic-related file  259
peak in audio file  490
zero crossings  289, 315

sectional dB-linear level meter scale  548
selecting  172

all following objects  174
all objects  173
all objects on a track  173
empty regions  175
events with the same MIDI channel  176
identical objects  175
individual objects  172
inside the locator positions  175
muted regions/events  175
next/previous track  190
note event

highest/lowest in chord  414
of certain pitch  173

objects with equal subpositions  176
overlapping regions/events  175
regions/events of certain color  175
rubber band  174
several objects  173
similar objects  175
toggling selection status  174

Select Previous Section for Realtime Comping key 
command  368
Send Discrete Note Offs message  396
send effect  233

bypassing  235
creating  234
determining position in signal flow  235
normalizing send level  235
post/pre fader  235
Post Pan setting  236
removing  235
setting send level  234

Send to MIDI functions  396
separation controls  821
sequencer, described  995
Sequencer Input object  912
serial effect routing  236
service and support  18
setting (plug-in). See plug-in setting
setup  81

amplifier  85
audio cables and connectors  89
audio interface  83

configuring  96
components  81

computer  82
CPU  82
hard drive  83

connecting devices  88
audio interface  91
expansions  88
MIDI devices  91

control surface  84
external MIDI instrument  237
headphones  86
microphone  87
MIDI cabling  91
MIDI interface  84
MIDI keyboard  84

USB  94
MIDI Thru port  92
mixing console  86
speakers  85

sharing  625
accessing shared data  627
connecting to .Mac account  629
key commands  630
preferences  626
refreshing settings  630
your settings  627

shortcut menu  56, 171
in Event List  440
Piano Roll Editor  402
Score Editor  690
Tempo List  648

Show Channel Strip menu (plug-in window)  229
Show Help Tags preference  170
Show Insert menu (plug-in window)  229
shuttling  110
SIAL. See Apple Loops
Side Chain function  230

described  996
using instrument signals  230

Signature List  723–727
opening  723
overview  41

Signature track  723–728
cutting bars  727
displaying  723

silence
applying to audio file selection  498
inserting between locators  321
removing from audio region  519
searching in audio file  490

Single Trigger mode  996
Single view (Mixer)  574
Skip Cycle function  114
Slide Activation function  206
slur (notation). See notation
SMPTE

described  996
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display in Event List  310, 445
display in Marker List  134
display in Transport bar  106

customizing  122
resizing  120

frame rate
detecting automatically  648
setting  648

locking position
event  427, 443, 842
marker  131
note event  412
region  842

LTC  841
positioning

bar to frame  843
object to frame  842

setting offset  804, 835
time code counter parameters  841
VITC  841

SMPTE time ruler  74
Snap menu

Arrange area  295
automation settings  593
in Piano Roll Editor  400, 401
overriding snap grid  296

software instrument. See instrument plug-in
software instrument track. See instrument track
Software Monitoring setting  356
Solo (Lock) button (Transport bar)  300
soloing

channel strip  550
folder  446
MIDI event  446
region  300, 446
track  199

multiple  200
Track Mute/Solo setting  199

Solo Lock mode  199, 301
Solo Safe mode (channel strip)  550
Solo tool  170, 300
song, opening old songs  140
Sound Designer file. See SDII file
speakers  85
spike reduction  513
split channel audio file  853

exporting  856
importing  854
stereo  854

converting to interleaved stereo  855
disconnecting  855
reconnecting  855

spoken recording, dividing into sentences, words, or 
syllables  519
staccato, forcing in region  349

staff style  757
adding staffs  747
adding voices  747
assigning to MIDI region  741
automatic assignment  243, 742
bracketing staffs  750
connecting staffs by bar lines  750
creating  746
deleting  749
deleting staffs/voices  749
examples  755
importing from another project  748
mapped  759
parameters  749
presets  743
resizing staffs  750
splitting staffs/voices  753

Staff Style window  744
views  745

standard instrument object  880
Standard MIDI file  257, 632

exporting  633
format 0  632
format 1  632
importing  632
opening  632

Startup Action menu  141
step input

activating  385
notation  673
via key commands  386
via MIDI  388

Step Input Keyboard  385
Stereo to Surround Panner  822
Stop button (Transport bar)  109
Strip Silence function

described  519
using  521

Style parameter (Inspector)  243
support website  18
surround  807–828

5.1 (ITU 775) format  809
6.1 (ES/EX) format  809
7.1 (3/4.1) format  810
7.1 (SDDS—Sony Dynamic Digital Sound) 
format  810
adding plug-in  823
Bounce function  606, 828

file extensions  814
burning to DVD-A  828
channel input/output assignment  812
channel strip output  560, 818
configuring Logic  812
Dolby Pro Logic format  808
Down Mixer plug-in  824
encoding  807



Index 1027

 

LCRS format  808
master channel strip  827
multi-channel effects  825

bypassing channels  826
configuring  826
linking channels  826
plug-in header  825
side chains  827

order of multi-channel level meters  817
preferences  812
Quadrophonic format  808
setting channel input format  816
setting project format  815
supported formats  808–811

used channels  811
Surround Balancer  823
Surround Panner  819–823

level controls  821
mono to surround  820
opening as window  819
separation controls  821
stereo to surround  822
surround to surround  823

sustain pedal event
converting to note length  410
notation  682

swing symbol (notation)  688
Sync button  831
synchronization  829–846

defining sync master  833
enabling automatically  833
external source  830
manual sync signal  652
master  830
MIDI Clock. See MIDI Clock
MMC. See MIDI Machine Control
MTC. See MIDI Time Code
optimizing over long time-spans  520
preferences  964
problems and solutions  846
project settings  832
recording during external synchronization  831
setting frame rate  834
slave  830
status display  836
tape machine  844
TV format  841

Syncopation setting (Score Editor)  733
synthesizer, described  998
SysEx event  451, 998

creating  932
viewing in hexadecimal format  451

SysEx fader  931
system requirements  82

T
take folder. See take recording
take recording

audio  364–369
adding file to take folder  366
comping. See comping
on multiple tracks  368
opening take folder  367
over a region  365
over a take folder  366
selecting take  367
take folder in Sample Editor  377

coloring  369
flattening take folder  377
merging take folder  377
MIDI  379–381
naming take  376
packing take folder  377
removing take  376

tape machine, synchronizing  844
TDM hardware  15
temperament, equal  946
template

creating  153
defining default  141

Templates dialog  137
tempo  641–654, 999

adjusting
to audio file selection  501
to audio region  524

alternative  645, 648
audio file

automatic tempo matching  523
following project tempo  526

controlling with tempo fader object  654
creating constant tempo  651
display  641
randomizing  651
setting project tempo  145, 641
speeding up/slowing down project section  651
tapping in  652
tempo curve  643

scaling  651
stretching  651
thinning out  651

Tempo Alternative menu  645
tempo change. See tempo event
tempo event

changing value  644
copying  644, 648
creating  647, 650
deleting  643, 647
described  999
inserting  642
moving  644, 647
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moving to current playhead position  644, 647
recording  646

tempo fader object  654
Tempo Interpreter window  652–653

opening  652
parameters  652

Tempo List  646–649
opening  646
overview  40
shortcut menu  648
SMPTE Frame Rate menu  648

Tempo Operations window  649–651
choosing tempo operation  650
opening  649

tempo symbol (notation)  688
Tempo track  642–646

adjusting display range  644
Apple Loops  621
displaying  642
relationship to Beat Mapping track  646
resizing  642
Resolution menu  643
Tempo Alternative menu  645

text (notation). See notation
text fader object  923
text input  157
text style. See notation
Text Style window. See notation
Text tool  157, 169, 302
tick  999
Tie Region by Length Change function  316
Tie Regions by Position Change function  322
Tie Region within Locators function  317
time code, described  999
time signature  723

alternative  727
copying  726
copying between projects  726
creating  724
creating compound signatures  724
deleting  727
editing  727
in Part box
selecting  725
setting project time signature  146

time stamp  311
time stretch/pitch shift algorithm  506

third party support  507
time stretching audio file  505
time stretching region  317, 525
timing, described  999
tool

alternate tool  166
Camera  774, 976
effective range  166
Eraser  169

Glue tool  170
Mute tool  170
Pencil  169
Pointer  169
right mouse button  167
Scissors  169
selecting  166

next/previous  168
with key commands  168

Solo tool  170
Text tool  169
Voice Separation tool  754, 1000
Zoom tool  69, 170, 773

Toolbar
customizing  73
overview  29

Tool menu
described  166, 999
displaying at cursor position  168

TOSLINK connector  90
touch tracks object  908
Touch Tracks window  909
track  179

arranging  191
assigning channels  193
assigning Environment objects  194
assigning to folder  195
copying  189
creating  183–190

by adding Apple Loops  187
by adding audio file  187
for overlapped regions  189
for selected channel strip  576
for selected regions  189
New Tracks dialog  184
with next channel  188
with same channel  188

deleting  190
duplicating  187
exporting as audio file  538, 640
freezing  202
hiding  204
icon

assigning  196
creating  196
displaying  196

muting  197
multiple  198
Track Mute/Solo setting  197

naming  191
in Mixer  577

No Output destination  195
preventing selection change  562
protecting  205
selecting  190
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soloing  199
multiple  200
Track Mute/Solo setting  199

sorting  191
transferring channel strip setting to new 
track  187
unfreezing  203
unhiding  205
zooming  195

automatically  195
with key commands  196

track button  182
Freeze  202
Hide  204
Mute  197
Node  101
Protect  205
Slide Activation function  206
Solo  199

track color bar  182
track control bar  181
track header  181
track level meter  182
track list

described  999
resizing  182

Track Mute/Solo setting  197, 199
track number  182
Track Parameter box  42, 180, 242–245, 875
transformer object  899

configuring  900
controlling via meta events  902

transform set
choosing  466
creating  482
importing  482
naming  482

Transform window  465–486, 1000
Hide unused parameter checkbox  476
map  480
Mode menu  476
opening  392, 393, 466
operations  478
preset  467

Crescendo  467
Double Speed  468
Exponential Velocity  472
Fixed Note Length  473
Half Speed  469
Humanize  470
Maximum Note Length  474
Minimum Note Length  474
Quantize Note Length  475
Reverse Pitch  471
Reverse Position  470
Scale 14 PitchBd  468

Transposition  471
Velocity Limiter  473

re-routing column values  481
selection conditions  476
transform set. See transform set
usage examples  483

transient
described  1000
finding in audio region  658

Transport bar
Autopunch button  370
big SMPTE/Bar display  120
customizing  117

Bar display  121
SMPTE display  122
Tempo display  122

display area  118
Locator display  112
Master Level slider  148
MIDI Activity display  395
mode buttons  119
overview  29
Pause button  109
position display  106
Record button, configuring  364
Replace button  372
Solo (Lock) button  199, 300
Stop button  109
transport buttons  108

transposing
Apple Loops  622
described  1000
MIDI event  662

transposition event
creating  663
deleting  664
moving  664
selecting  664

Transposition track  661–665
Apple Loops  622

tremolo/trill (notation)  687
tuning

alternate  945
Hermode  947

tuplet (notation)  700

U
Undo function  177

number of undo steps  177
undoing multiple steps  178

Undo History  177
erasing  178
un/redoing isolated step  405

Unitor synchronization  840
Universal Track Mode  98
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Unpack Take Folder commands  378
USB (Universal Serial Bus)  88
USB keyboard  94

V
Variable Bit Rate encoding  608, 610
velocity, described  1000
Velocity tool  412, 1000
video. See movie
Video track  799–800

resolution of thumbnails  800
thumbnail cache  800

virtual memory  1000
VITC  841
voice limiter object  905
Voice Separation tool  754, 1000
Voices to Channels command  414
VU meter, described  1001

W
Wave file  256

bouncing  606
Broadcast Wave file  256

bouncing  604
timestamp  311

Wide Playhead setting  108
window

active  59
background  60
Catch function  71
closing  62
Content Catch function  72
float  61
following playhead  71
hierarchy levels  65

linking  71
maximizing  64
minimizing  64
moving  63
opening  61
resizing  64
resizing window elements  64
scrolling one page  67
selecting working area  66
setup  59
switching  60
toggling  62
type  59

Word Clock, described  1001
word length. See bit depth
Write Mode Changes To menu  587

X
XG effect  573, 1001
XLR cables and connectors  89

Z
zero crossing

described  1001
searching  289, 315

when dividing audio regions  334
zoom control  67, 1001
zooming  67–70, 1001

reverting to previous setting  70
saving zoom setting  69
screen section  69
storing navigation snapshot  70
waveform of audio regions  69
with scroll bar  68

Zoom tool  69, 170, 773
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