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What’s new in Final Cut Pro?

1

What’s new in Final Cut Pro 10.1.2?

Final Cut Pro 10.1.2 introduces new features and enhancements, detailed below.
Media management improvements
New features provide you with more flexibility and control over media management.
••

Store optimized, proxy, and rendered media outside the library, at the location you choose.

••

Easily delete optimized, proxy, and render files from within Final Cut Pro.

••

View and set storage locations for media, cache files, and library backup files using the Library
Properties inspector.

For more information, see Manage storage locations on page 434, Manage optimized and proxy
media files on page 425, and Manage render files on page 429.
Organization enhancements
Final Cut Pro 10.1.2 provides streamlined organizing tools.
••

You now have the option to show only unused media in the Browser.

••

Used media indicators now work with compound clips, multicam clips, and synced clips.

••

You can now sort events in the Libraries list by date or name.

For more information, see Find clips and projects in events on page 72, Colored lines marking
event clips on page 72, and Merge, split, and sort events on page 63.
Support for wide-dynamic-range imagery from professional 4K cameras
•• The new Apple ProRes 4444 XQ codec is the highest-quality version of Apple ProRes for 4:4:4:4
image sources (including alpha channels), with a very high data rate to preserve the detail
from today’s highest-quality digital image sensors. See Supported media formats on page 46
and Supported export formats on page 402.
••

You can apply a standard broadcast color space (Rec. 709) look in real time to high-dynamicrange and wide-color-gamut video shot on ARRI, Blackmagic Design, Canon, and Sony
cameras. See Turn log processing on or off on page 391.

Audio workflow improvements
Speed up your audio workflow with these enhancements:
••

You can now adjust the relative or absolute volume of a clip or range selection by entering a
specific dB value. See Adjust volume on page 174.

••

Final Cut Pro 10.1.2 provides improved speed and accuracy when syncing clips. See Sync audio
and video on page 204.

••

New live audio recording features include an automatic countdown and automatic grouping
of multiple takes into auditions. See Record voiceovers and other audio on page 166.

••

The new Basic Surround preset simplifies panning for surround sound audio. See Pan audio on
page 179.
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Import and export features
•• Export and import entire libraries as single XML files using XML 1.4. See Use XML to transfer
projects and events on page 326.
••

Create keywords from Finder tags when you import media from a storage device. See Import
from a hard disk on page 38 and Organize files while importing on page 42.

••

Quickly export cuts-only projects containing XDCAM media.

Other notable features
•• You can now import media by dragging it from the Finder to the Browser (rather than to the
event in the Libraries list). See Import from a hard disk on page 38.
••

Nudging a clip in the Timeline now works like a slide edit. See Arrange clips in the Timeline on
page 117.

••

You can now break apart an audition. See Create auditions to try out clips on page 294.

What’s new in Final Cut Pro 10.1?

Final Cut Pro 10.1 introduces numerous new features and enhancements, detailed below.
Performance and Mac Pro optimizations
Final Cut Pro 10.1 brings the following performance improvements:
••

Optimization to take advantage of multiple GPUs in the new Mac Pro

••

HDMI and Thunderbolt output at frame sizes up to 4K (UltraHD and DCI 4K)

••

Better playback and rendering performance, plus faster opening of the application and projects

••

Improved performance when modifying or keywording large numbers of clips at the same time

••

Selected titles, effects, and other media content scaled for 4K projects

Project and media management
Project and media media management tools have been enhanced to deliver:
••

Improved media management with the introduction of libraries, a new way to organize
multiple events and multiple projects in a single container

••

Project snapshots: on-demand backups that allow you to quickly return to an earlier version of
a particular project

••

Media file storage on disk locations external to the Final Cut Pro X library, making your media
accessible in specific folders on a wide range of SANs

••

Direct importation of MTS/M2TS files into Final Cut Pro

••

Used clip range indicators that show you at a glance which clips are already in a project

••

Direct import of photos from iOS devices using the Media Import window

••

Support for portrait/landscape metadata in still images

For more information, see Organizing libraries overview on page 56, Media management
overview on page 417, and Editing overview on page 87.
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Playback and effects
Significant improvements in the Final Cut Pro playback interface and powerful new effects
features will empower your workflow.
••

Improved retiming lets you set custom speeds easier than ever—by typing frame rates directly
in the interface. You can also create jump cuts at specific frames, replace and retime in one
step, and retime clips without rippling the Timeline. For more information, see Retiming clips
overview on page 300.

••

A new stabilization method called InertiaCam has been optimized to smooth video footage
containing camera moves such as pans and zooms. Tripod Mode creates the effect of a static
camera, as if it were mounted on a tripod.

••

An improved optical flow algorithm makes retiming and frame rate conform speedier than
ever. In addition, for Macs with two GPUs, the optical flow algorithm now makes use of both
GPUs, providing a more than 2x speed increase over a single GPU.

••

You can now create custom project resolutions for web video, digital signage, and other
nonstandard frame sizes.

••

New controls in the Viewer menu let you switch between better playback quality and better
playback performance. There’s also a control to switch between proxy media and original or
optimized media.

••

And you can now view all pixels of a 2K frame on a MacBook Pro with Retina display.

Editing
Improved editing tools give you more creative flexibility than ever.
••

Through edits are now supported in all types of clips. The new Join Clips command removes
cuts from bladed Timeline clips.

••

You can detach the audio portion of multicam clips in the Timeline to manipulate audio and
video separately. You can also make video-only or audio-only edits into the Timeline with
multicam clips as sources.

••

You can blade audio cuts in J- and L-cuts separately from the video. And you can now roll the
audio in open split edits.

••

If no clips are selected in the Timeline, a white dot now appears on the playhead to indicate
the clip whose attributes are shown in the Inspector.

••

Moving clips with transitions is now easier.

For more information, see Editing overview on page 87.
Share
When it’s time to export your project, there are several new Share options:
••

You can share 4K finished videos directly to YouTube.

••

You can share videos directly to the Chinese video sharing websites Youku and Tudou.

••

And you can receive notifications on the status of items you shared.

For more information, see Sharing projects overview on page 399.
Audio
Audio fade handles have been added to individual audio channels in the Timeline. For more
information, see Fade audio in or out on page 176.
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Third-party support
Final Cut Pro 10.1 also features several new third-party support options:
••

Developers can utilize a new API for customizing Share operations.

••

FXPlug 3 has been updated to include the ability to design custom effects interfaces.

••

Effect parameters, fonts, and text size information are now preserved in XML files.

General application
You can now hide the Browser to free up more screen area for color grading and other
operations that are improved by larger video images.

What’s new in Final Cut Pro 10.0.6?

Final Cut Pro 10.0.6 includes numerous new features and enhancements, detailed below.
Advanced multichannel audio editing
Final Cut Pro automatically groups audio channels into audio components according to how the
channels are configured for the clip. You can now expand the audio portion of clips to view and
edit audio components down to the individual channel level. You can edit audio components in
a variety of ways, including any of the following:
••

Adjust volume or pan.

••

Disable or delete ranges within an audio component to quickly edit out unwanted sounds.

••

Apply and adjust audio effects.

••

Add or remove audio components in a multicam clip.

For more information, see Audio editing overview on page 170.
Streamlined sharing and export
Sharing your finished work is easier and more flexible in Final Cut Pro 10.0.6. Destinations—sets
of preconfigured export settings—allow you to quickly publish a project or clip to a sharing
website, export it for viewing on iPad or iPhone, or burn it to a disc. Final Cut Pro comes with a
variety of destinations, and you can also modify destinations and create new destinations.
The simplified and streamlined sharing workflow includes these enhancements:
••

Simplified and consolidated menus that you can easily populate with customized destinations

••

Reusable destination bundles that allow you to share to multiple output formats and locations
at once

••

Automatic sharing of project and clip metadata, with the ability to customize the metadata
that is shared

••

Support for multiple accounts at video-sharing websites such as YouTube

••

Faster sharing and export using the GPU and background processing

••

Sharing of a selected range in a project in the Timeline or in a clip in the Browser

For more information, see Sharing projects overview on page 399.
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Unified import
Simplified and easier to use, the new unified Media Import window provides one place to go for
all your importing needs. Final Cut Pro 10.0.6 offers dedicated areas for connected cameras and
devices, both file-based and tape-based, as well as a new Favorites section, where you can add
frequently used folders for file import from your hard disk or an external drive. Other new import
features include list view to see multiple columns of metadata, multiple range selections within
individual clips from file-based cameras, and complete archive-management tools.
For more information, see Importing overview on page 23.
Dual viewers
The Event Viewer is a separate video display that appears next to the main Viewer so you can
compare shots to match action and color. With the Event Viewer and the Viewer open, you can
display two clips at the same time: one from the Browser and one from the Timeline, each with
its own video scope display.
For more information, see Play back and skim media in the Event Viewer on page 82.
Native REDCODE RAW (R3D) support
Final Cut Pro 10.0.6 provides native support for REDCODE RAW (R3D) files. You can now import
RED files directly, make nondestructive RAW settings adjustments, and save those adjustments
as metadata, all within Final Cut Pro. This allows you to take advantage of the full latitude and
dynamic range contained in the REDCODE RAW source files.
For more information, see Import and adjust REDCODE RAW video files on page 47.
Improved range selections
Start and end points in clips in the Browser now stay in place when you click elsewhere. You can
also create multiple range selections in one or more clips.
For more information, see Select a range on page 94 and Manage multiple range selections in
event clips on page 97.
Other notable features
•• Chapter markers and chapter marker thumbnails allow you to prepare chapters and their
representative poster frame images directly within Final Cut Pro for output to DVD, Blu-ray
disc, iTunes, QuickTime Player, and Apple devices.
••

The new Paste Attributes window is a powerful way to transfer specific effects and other
settings between clips.

••

You can now add freeze frames quickly and easily with a single keyboard shortcut.

••

Titling is significantly improved, including support for the new title markers feature in Motion.

••

Flexible connection points improve manual control over connected clips as you slip, slide, or
move clips in the primary storyline.

••

New compound clip architecture makes compound clips easier to reuse in multiple projects
and provides improved performance.

••

You can now import and export MXF files using third-party plug-ins. For a list of supported
media files, see Supported media formats on page 46.

••

Final Cut Pro 10.0.6 provides improved support for anamorphic media.
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What’s new in Final Cut Pro 10.0.3?

Final Cut Pro 10.0.3 includes major new features and enhancements, detailed below.
Multicam editing
You can now use multicam clips to edit footage from multicamera shoots or other synchronized
footage in real time. Working with multicam clips in Final Cut Pro is a flexible and fluid process.
While the active angle plays in the Viewer, you can also view all angles playing simultaneously in
the Angle Viewer and easily cut and switch between them. You can create multicam clips from
diverse media sources and modify existing multicam clips during the editing process.
For more information, see Multicam editing overview on page 327.
A/V output
You can now connect your computer to an external video monitor for audio and video (A/V)
output. In addition to showing you how video and audio look and sound on an NTSC/PAL or HD
broadcast monitor, this feature also allows you to test output with more sophisticated devices
such as vectorscopes and waveform monitors.
A/V output is available only with OS X Lion v10.7.2 or later and requires compatible thirdparty video interface hardware and software. FireWire DV devices are not supported. For more
information, contact the device manufacturer or go to the Final Cut Pro X Resources webpage at
http://www.apple.com/finalcutpro/resources.
For more information, see View playback on an external video monitor on page 83.
Manual relinking of clips to media files
Now you can manually relink event clips and project clips to media files. Manual relinking gives
you more control over your post-production workflow.
For more information, see Relink clips to media files on page 421.
Other notable features
•• Layered graphics files, such as Adobe Photoshop (PSD) files, can now be edited so that each
layer appears as a connected clip in the Timeline.
••

Advanced Keyer controls are now available.

••

Keyframing controls are improved in the Video and Audio Animation Editors.

What’s new in Final Cut Pro 10.0.1?

Final Cut Pro 10.0.1 includes a number of new features, enhancements, and changes. The most
significant features are introduced below.
Roles
You can use the new roles metadata labels to organize clips in your events and projects, control
the appearance of the Timeline, and export separate video or audio files (also known as media
stems) for broadcast delivery, audio mixing, or post-production. For example, you can export
roles as media stems in a combined, multitrack QuickTime file, or as separate audio or video
files. During the export process you can assign mono, stereo, or surround output for your
audio channels.
For more information, see Roles overview on page 318 and Destinations preferences on page 447.
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Storage area network (SAN) locations
You can now add network volumes as storage locations for events and projects. When you
remove SAN locations in Final Cut Pro, other users on the network can work with the events and
projects stored on those locations.
XML export and import
Final Cut Pro now supports XML import and export so that you can transfer your project and
event information to and from systems and third-party applications that don’t recognize
Final Cut Pro projects and events.
For more information, see Use XML to transfer projects and events on page 326.
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Final Cut Pro basics

2

What is Final Cut Pro?

Final Cut Pro X is a revolutionary application for creating, editing, and producing the highestquality video. Final Cut Pro combines high-performance digital editing and native support
for virtually any video format with easy-to-use and time-saving features that let you focus
on storytelling.
In Final Cut Pro, you can:
••

Edit everything from uncompressed standard-definition video to HDV, DVCPRO HD, and
uncompressed high-definition video—as well as file-based formats such as AVC-Intra, AVCHD,
and XDCAM HD.

••

Play back and skim resolution-independent media up to 1920 x 1080, 2K, 4K, and even 5K
resolution. You can also play your video full screen or on a second display.

••

Assemble clips with ease using the Magnetic Timeline, which fluidly adjusts clips around the
clip you’re dragging to eliminate gaps, collisions, and sync problems.

••

Edit quickly with the complete set of professional editing and trimming tools. Fine-tune edits
with the inline Precision Editor.

••

Have Final Cut Pro analyze your video and nondestructively fix common problems such as
camera shake, excess hum, or loudness. You can also have Final Cut Pro detect the presence of
people or the shot type, and automatically apply keywords such as One Person or Wide Shot.

••

Organize your media using Keyword Collections, which automatically group clips based on
keywords, and Smart Collections, which automatically group clips based on criteria you specify.

••

Try out clips in your project using auditions—sets of alternate takes, effects, or text
treatments—and then choose the best clip for the edit.

••

Create compound clips to group any combination of clips, and nest clips within other clips.
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••

Use connected clips and storylines to add cutaway shots, superimposed titles, and sound
effects to your project. Connected clips and storylines always stay in sync.

••

Add special effects to video, audio, and photos, and adjust them using keyframes and onscreen
controls. You can also change clip speed to create fast-motion or slow-motion effects.

••

Automatically balance and match color, or use the color correction tools to precisely control
the look of any clip in your project.

••

Publish your project directly to websites such as YouTube and Facebook, or send your project
to iTunes for syncing with Apple devices such as iPhone, iPad, and Apple TV.

What are libraries?

In Final Cut Pro 10.1 or later, you organize your work in libraries. A library contains multiple events
and projects in the same location. The first time you open Final Cut Pro 10.1, it creates a library
file in the Movies folder. When you create a new project or event, it’s automatically included
in the active library. The library tracks all your media files, your editing decisions, and the
associated metadata.

Library

Library

Event
Clip

Clip

Library

Event
Clip

Clip

Clip Project

Library

Event
Project Project Project

You can have multiple libraries open at the same time, and you can easily copy events and
projects between libraries. This makes it simple and quick to move media, metadata, and creative
work to another system for mobile work, work with multiple editors, or archiving. You can open
and close libraries as needed so that you never have too many libraries open at once.
The following concepts are important to understand when you work with libraries.
Managed and external media
Media that you import into a specific library is stored inside the library and is referred to as
managed media. Media can also be imported or copied to any location on a connected volume
and linked to the library as external media. Multiple users can access this external media instantly
on shared storage.
Managed media can be made external at any time if you want to share access, and external
media can be collected as managed media inside the library for easy transport or archiving. For
more information, see Consolidate projects, events, and libraries on page 424.
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Generated media
Render files, optimized files, proxy files, and analysis files are all considered generated media
because the system creates them in the background after the original media has been imported.
You can store generated media inside your Final Cut Pro library or in an external location you
define in the Library inspector. For example, to organize media in a large facility more efficiently,
you can put generated media on a SAN or on a storage device outside the library. For more
information, see Manage storage locations on page 434.
To reduce a library’s size, and to move, copy, or archive a library more quickly, you can delete all
the generated media (proxy, optimized, or render files) in one step. For more information, see
Manage optimized and proxy media files on page 425 and Manage render files on page 429.
Note:  By default, copying a project between libraries does not copy the associated proxy,
optimized, or render files because these files can be quickly regenerated. However, you have the
option to include proxy or optimized media when you copy a project to another library.

Final Cut Pro workflow overview

To give you an idea of the possibilities, the overall process for putting together a movie with
Final Cut Pro is described below. You don’t have to do every step, and you might do others that
aren’t listed. The workflow isn’t necessarily linear. You could, for example, go all the way through
editing and adding effects, and then import more new media for your project.
Import your media into Final Cut Pro
To use Final Cut Pro, you need to transfer your media (video, audio, and still images) from your
recording device to your computer or an external disk. You can import media from many kinds of
cameras and other devices, or from other applications such as iMovie.
Organize your media
Final Cut Pro automatically organizes your imported media into events. An event is similar
to a folder that can hold dozens, hundreds, or even thousands of video clips, audio clips, and
still images, as well as projects. In Final Cut Pro, your media appears as clips, which link to the
media files stored on a disk. You can reorganize your clips by creating or renaming events and
moving clips between events. For example, you could create an event for all the media shot for a
specific client.
As you review your footage, you can easily rate clips as Favorite or Rejected. These ratings make
it easier to focus on your best footage. Final Cut Pro also offers other useful organizing tools, such
as Keyword Collections and Smart Collections.
Create a project and add clips to it
Your project is the movie you create using clips from your events and from the Final Cut Pro
media browsers. Start creating your movie by adding clips to the Timeline. You make all your edits
in the project; your original media files remain untouched (this is known as nondestructive editing).
Arrange and edit your clips
Now your movie can really begin to take shape. To assemble a rough cut, rearrange and trim
clips in the Timeline. You can also try out different clips using auditions. Use connected clips
and storylines to add cutaway shots, titles, background music, and sound effects to your project.
Create compound clips to group any combination of clips and nest clips within other clips. You
can simplify a complicated project by creating a separate compound clip for each major section.
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Add effects and transitions
Add special effects from the ample collection of video and audio effects in the Final Cut Pro
media browsers. Give your movie titles and credits, and apply video or audio transitions. Adjust
clip speed settings to create fast-motion or slow-motion effects.
To further polish your project, you can fine-tune cuts and transitions with the Precision Editor,
keyframe video and audio effects, correct color, and composite motion graphics.
Share your movie
When your project is finished, you can publish your movie right from Final Cut Pro to the web, or
send it to iTunes, iPhone, iPad, iPod, or Apple TV. You can also burn a disc to give to others.

Final Cut Pro interface overview

The Final Cut Pro window has three main areas:
Browser: Access all
the source media you import.

Viewer: Play back
clips and projects.

Magnetic Timeline: Edit your
movie in this area.
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Organize media in the Libraries list and the Browser
Your imported media is available in events in your library. (An event is like a folder that contains
clips and projects.)
When you select an event in a library, its clips and projects appear in the Browser on the right.
Libraries list: Select an event
to view its media on the right.

Browser: View and sort clips
and projects in the selected event.

You can reorganize your media however you like at any time, and you can use the Libraries list
and the Browser to manage, rate, sort, and add keywords to your imported media. For more
information, see Organizing libraries overview on page 56.
Play back clips and projects in the Viewer
The Viewer is where you play back your video, including clips and projects with up to 1920 x 1080,
2K, 4K, and even 5K resolution. You can play back events, projects, or individual clips in full-screen
view or on a second display. With the Event Viewer, a separate video display that can be shown
next to the main Viewer, you can display two clips at the same time: one from the Browser and
one from the Timeline. For information about ways to play media, see Play back media on page 78.
Dual viewers: Display event clips
and project clips side by side.

Onscreen controls:
Adjust effects such as
Transform, Crop, and Distort.

Resolution-independent playback:
Play back video files up to 5K.

Full-screen playback:
Play your video full screen,
or on a second display.

You can also use onscreen controls, superimposed over the video in the Viewer, to adjust settings
for a wide array of effects and transitions.
Edit your project in the Magnetic Timeline
The bottom portion of the Final Cut Pro window contains the Timeline, where you create your
movie by adding and arranging clips and making all your edits. The Timeline in Final Cut Pro
“magnetically” adjusts clips to fit around clips that you drag into place. If you drag clips out of
place, the surrounding clips close up to fill the space.
Chapter 2    Final Cut Pro basics

21

A Final Cut Pro project holds all of the information for your final movie, including your editing
decisions and links to all the source clips and events. For more information about editing your
project, see Adding clips overview on page 99 and Arrange clips in the Timeline on page 117.
Toolbar: Perform
common tasks by
clicking a button.

Connected clips: Add titles and
cutaway shots. In the Magnetic
Timeline, everything stays in sync.

Primary storyline: Add and
arrange clips to construct
your movie.

Audio clips: Add music
and sound effects as
connected clips.

Media files and clips

After you import media into your Final Cut Pro library, clips representing the source media files
appear in the Browser. A large event may hold many clips.
Media files are the raw materials you use to create your project. A media file is a video, audio,
still-image, or graphics file on your hard disk that contains footage transferred from a camcorder
or recording device or originally created on your computer. Media files can contain multiple
video and audio components. Because media files—especially video files—tend to be quite
large, projects that use a lot of footage require one or more high-capacity hard disks.
Clips represent your media, but they are not the media files themselves. The clips in a project
simply point to (link to) the source media files on your hard disk. When you modify a clip, you
are not modifying the media file, just the clip’s information in the project. This is known as
nondestructive editing, because all of the changes and effects you apply to clips in Final Cut Pro
never affect the media itself. Trimmed or deleted pieces of clips are removed from your project
only, not from the source clips in your library or from the source media files on your hard disk.
Media files on your hard disk

Toy1.mov

Browser clips

Toy1

Project 1

Project 3

Project 2

Toy1

Toy1
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Import media

3

Importing overview

Importing media into Final Cut Pro is the first step toward making your movie.

With Final Cut Pro, you can:
••

Import from a file-based (tapeless) camera or device

••

Import from iPhone, iPad, or iPod touch

••

Import from a tape-based camcorder or device

••

Import from iMovie

••

Import from iPhoto and Aperture

••

Import from iTunes

••

Import from a hard disk

••

Import from a camera archive

During import, you assign your media to an event. You can also transcode your media and
analyze your media for a variety of issues, such as color balance, the presence of people and shot
type, and audio problems.
When you import clips (video, audio, or still images), Final Cut Pro assigns one of five default roles
to the video and audio components of each clip: Video, Titles, Dialogue, Music, and Effects. For
more information, see View and reassign roles on page 318.
If you want to quickly back up your media (instead of taking the time to import it), you can
create an archive.
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If it’s your first import

The first time you open Final Cut Pro, it contains no media and one library containing a single
event. You can use the event to quickly import media from your hard disk or directly from a
connected camera, and then create a project to start editing.

Import media into an empty event
mm To import files from a connected camera or from a hard disk: Click the Import Media button and
follow the instructions for importing files from a connected file-based camera, from a hard disk,
from a tape-based camera, or from a camera archive.
mm To create a new project: Choose File > New > Project, and follow the instructions for creating
new projects.

Import from connected cameras
Import from file-based cameras
File-based camcorders and cameras can record video, audio, and still images. These kinds of
devices, which record to flash-based storage media, hard disk drives (HDD), and so on, usually
connect to your computer via a Thunderbolt or USB cable. Some devices have removable
memory cards that you can insert into your computer instead.
If your file-based device provides a clip-spanning feature, you can import all of the media as one
spanned clip.
To check whether your camera is compatible with Final Cut Pro, go to the Final Cut Pro X
Supported Cameras webpage at http://help.apple.com/finalcutpro/cameras.
Import from a file-based camcorder, camera, or device
1 Do one of the following:
••

Connect your camcorder, camera, or device to your computer, using the cable that came with
the device, and turn it on.
If you’re using a camcorder, set it to PC Connect mode. (The name of this transfer mode may
be different on your device.) Your camcorder may automatically go into “connect” mode if you
turn it on in playback mode while it’s connected to your computer. For more information, see
the documentation that came with your camcorder.
Note:  Connecting a DVD camcorder to your Mac can cause the DVD Player application to
open. If that happens, simply close DVD Player.
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••

Remove the memory card from your camcorder or device and insert it into the card slot on
your Mac (if it has one) or into an external card reader.
For more information about memory cards, see About memory cards and cables on page 45.

Note:  Some cameras require that you download and install an additional software plug-in. For
more information, see the documentation that came with your camera.
2 To open the Media Import window, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.

3 If necessary, select your camcorder, camera, or device from the Cameras section on the left.
The Media Import window displays all the media on your device. In this window you can preview
the media by either playing it using the playback controls or skimming it by moving the pointer
forward or backward over a filmstrip.
Playback controls

The media on the
device appears here.

Change the way clips appear
using these controls.

Note:  Most modern digital cameras can shoot still images and video interchangeably. In many cases,
the video clips and still images in those cameras appear side by side in the Media Import window.
4 Do any of the following:
••

To change which device to import from: Click the device in the Cameras section.

••

To change the way the clips appear: Click the Clip Appearance button in the bottom-right
corner of the Media Import window.

••

To switch between filmstrip view and list view: Click the List View and Filmstrip View buttons at the
bottom of the Media Import window. (Connected file-based cameras and camera archives only.)
Note:  When you select a clip in list view, a filmstrip for the selected clip appears at the top of
the Browser. The filmstrip is fully interactive, allowing access to start and end points, markers,
and keywords.
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••

To sort clips in list view by data such as duration, creation date, rating, keyword, and so on: Click
the column headings at the top of list view. For more information about list view, see Import
from a hard disk on page 38.

••

To add folders of frequently used media to the Favorites section: Drag them from list view.
To remove a folder from the Favorites section, Control-click the folder and choose Remove
from Sidebar in the shortcut menu.

••

To automatically close the Media Import window when the import begins: Select the “Close
window after starting import” checkbox.

••

To add a folder to the list view by dragging: Drag the folder from the Finder to the list view and
browse its contents in list view.

5 Do one of the following:
••

To import all clips: Click Import All.

••

To import only some of the clips: Select each clip you want to import by Command-clicking each
clip, and click Import Selected (the Import button changes its name).
Tip:  To select several clips located together, you can drag around the clips to enclose them
with the selection rectangle.

••

To import portions of clips: Drag inside the filmstrip to select the range that you want, and click
Import Selected. You can also select multiple ranges in each clip. For more information, see
Select a range on page 94.
Tip:  You can also select a clip, press the Space bar to play the clip, and press either I to set a
start point or O to set an end point.

6 In the window that appears, choose how you want to organize the imported media in your library:
••

To add the imported clips to an existing event: Select “Add to existing event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new event in,” use the pop-up menu to choose the library
in which you want to create the event, and then type a name (for example, “Chris and Kim
Wedding”) in the text field.

To learn more about events, see Organizing libraries overview on page 56.
Note:  You can set storage locations for each of your libraries using the Library Properties
inspector. For more information, see Manage storage locations on page 434.
7 If you want to create optimized or proxy media, analyze the video, or analyze the audio, select
the relevant checkboxes in the Transcoding, Keywords, Video, and Audio sections.
If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it
later (if necessary) in the Browser.
Note:  Some import options are available only when you import files from a storage device. For more
information, see Organize files while importing on page 42 and Import from a hard disk on page 38.
8 Click Import.
By default, the Media Import window closes when you click Import. You can begin working with
your clips in the Browser. Final Cut Pro imports your media in the background.
If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the
files after the import process is complete. You can view the progress of the import and other
background tasks in the Background Tasks window.
9 When background tasks are completed, disconnect the camcorder, camera, or device.
You can create an archive from your file-based or tape-based camera or device. For more
information, see Create and manage camera archives on page 435.
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Reimport a clip
Two situations warrant reimporting a clip:
••

If the clip was not completely imported: If you cancel or quit Final Cut Pro before an import is
finished, a Camera icon appears on the bottom-left corner of the clip. This icon indicates that
Final Cut Pro is using the media on the camera for playback (instead of using the QuickTime
file that was created during import).

Camera icon

To play a clip with a Camera icon, Final Cut Pro locates the media on either a connected
camera or in a connected, available camera archive. (See Access media on an archive or disk
image on page 41 for more information.) If Final Cut Pro can’t locate the media in one of those
locations, the clip will go offline and display the Missing Camera alert icon.
••

If the clip’s source media file is not available: If a clip’s source media file is moved or deleted, or
the volume it is located on is disconnected from the computer, a Missing File icon is displayed
on the clip. To restore the clip, you can reimport it.

See Alert icons on page 438 for more information about alert icons.
When you reimport a clip, Final Cut Pro automatically connects to the necessary camera or
camera archive. There is no need to manually mount a camera archive before reimporting.
1 Do one of the following:
••

Connect the camera that contains the clip to your computer, and turn it on. This will bring the
clip online, but the clip will still display the Camera icon in the lower-left corner.

••

Insert the memory card that contains the clip in your computer or connected card reader.
See About memory cards and cables on page 45 for more information.

••

Make sure the camera archive that contains the clip is located in one of the Final Cut Pro
camera archives.
See Create and manage camera archives on page 435 for more information.

2 In Final Cut Pro, do one of the following:
••

To reimport one clip: Select the clip in the Browser.

••

To reimport all clips in an event: Select the event in the Libraries list.

3 Choose File > Import > Reimport from Camera/Archive.
The clip or clips are reimported.
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Import spanned clips
Some file-based camcorders or devices that have more than one memory card slot can record
one shot over multiple memory cards. The resulting shot is called a spanned clip.
A good way to import a spanned clip into Final Cut Pro is to attach your camera or card reader to
your local system and create a camera archive for each memory card. You can store the camera
archives on your local system or on an external storage device until you are ready to import the
spanned clip. (Even if you are importing the spanned clip immediately, it’s useful to make the
camera archive so you have a backup of the footage that makes up the spanned clip.) Then, when
you’re ready to import, you can mount all of the camera archives and import the spanned clip.
Create a camera archive for each memory card
1 Connect your camcorder or camera to your computer and turn it on, or connect your card
reader and memory card to your computer. If you’ll be saving the camera archives to an external
storage device, connect that as well.
Note:  Some cameras require that you download and install an additional software plug-in. For
more information, see the documentation that came with your camera.
2 In Final Cut Pro, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.

The Media Import window appears.
3 Select a memory card to archive from the list of cameras on the left.
4 Click the Create Archive button at the bottom-left corner of the window.
5 In the “Create Camera Archive as” field, type a name for the archive.
6 Choose a location to save the archive from the Destination pop-up menu, and click OK.
Note:  To protect your media, it is recommended that you save your archive to a disk or partition
different from the one where you store the media files used with Final Cut Pro.
7 Repeat steps 3 through 6 to create camera archives for each of the memory cards that contain a
portion of the spanned clip.
See Create and manage camera archives on page 435 for more information about creating
camera archives.
Import a spanned clip
1 If the media you want to import is on an external storage device or memory card, connect the
device to your computer and turn it on.
2 To open the Media Import window, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.
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3 In the Devices section on the left side of the Media Import window, select your computer’s hard
disk or the connected external storage device or memory card that contains the spanned clip
camera archives.
4 Use the list view at the bottom of the window to navigate to and open the camera archives.
Important:  If the camera archives that make up the spanned clip are not all available, you can
import each camera archive separately. Each portion of the spanned clip will be imported into
Final Cut Pro as a separate clip.
If all portions of the spanned clip are available, all the mounted camera archives show a clip
with the same duration. An icon indicating that the spanned clip is complete appears on the
spanned clip.
If one or more camera archives are missing, an icon appears on the spanned clip to indicate
which part of the spanned clip is available—the beginning, middle, or end. You can select each
camera archive to see the different icons.
Indicates that all
portions of the spanned
clip are available.

Indicates that the
beginning portion of the
spanned clip is available.

Indicates that the middle
portion of the spanned
clip is available.

Indicates that the end
portion of the spanned
clip is available.

5 Click Import All to import the spanned clip.
6 Choose how you want to organize the imported media in your library:
••

To add the imported media to an existing event: Select “Add to existing event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new event in,” use the pop-up menu to choose the library
in which you want to create the event, and then type a name (for example, “Chris and Kim
Wedding”) in the text field.

To learn more about events, see Organizing libraries overview on page 56.
Note:  You can set storage locations for each of your libraries using the Library Properties
inspector. For more information, see Manage storage locations on page 434.
7 If you want to create optimized or proxy media, analyze the video, or analyze the audio, select
the relevant checkboxes in the Transcoding, Keywords, Video and Audio sections.
If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it
later (if necessary) in the Browser.
Note:  Some import options are available only when you import files from a storage device. For
more information, see Organize files while importing on page 42 and Import from a hard disk on
page 38.
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8 Click Import.
By default, the Media Import window closes when you click Import. You can begin working with
your clips in the Browser. Final Cut Pro imports your media in the background.
If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the
files after the import process is complete. You can view the progress of the import and other
background tasks in the Background Tasks window.

Import from iPhone, iPad, or iPod touch
Importing media from iPhone, iPad, or iPod touch is the same as importing it from a file-based
camcorder, camera, or device.
Import from iPhone, iPad, or iPod touch
1 Connect your iPhone, iPad, or iPod touch to your computer using the Dock Connector to USB
cable that came with it. (If another application opens, close it.) Then turn on your device and
unlock it.
2 In Final Cut Pro, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.

The Media Import window appears.
3 If necessary, select your iPhone, iPad, or iPod touch from the Cameras section on the left.
The Media Import window displays all the media on your device. In this window you can preview
the media by either playing it using the playback controls or skimming it by moving the pointer
forward or backward over a filmstrip.
You can also do any of the following:
••

To change which device to import from: Click the device in the Cameras section.

••

To change the way the clips appear: Click the Clip Appearance button in the bottom-right
corner of the Media Import window.

••

To switch between filmstrip view and list view: Click the List View and Filmstrip View buttons at the
bottom of the Media Import window. (Connected file-based cameras and camera archives only.)
Note:  When you select a clip in list view, a filmstrip for the selected clip appears at the top of
the Browser. The filmstrip is fully interactive, allowing access to start and end points, markers,
and keywords.

••

To sort clips in list view by data such as duration, creation date, rating, keyword, and so on: Click
the column headings at the top of list view. For more information about list view, see Import
from a hard disk on page 38.
Tip:  If your iPhone, iPad, or iPod contains both video clips and still images and you want
see one or the other, click the File Type column heading to separate the video clips and
still images.
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••

To add folders of frequently used media to the Favorites section: Drag them from list view.
To remove a folder from the Favorites section, Control-click the folder and choose Remove
from Sidebar in the shortcut menu.

••

To automatically close the Media Import window when the import begins: Select the “Close
window after starting import” checkbox.

••

To add a folder to the list view by dragging: Drag the folder from the Finder to the list view and
browse its contents in list view.

4 Do one of the following:
••

To import all clips: Click Import All.

••

To import only some of the clips: Select each clip you want to import by Command-clicking each
clip, and click Import Selected (the Import button changes its name).
Tip:  To select several clips located together, you can drag around the clips to enclose them
with the selection rectangle.

••

To import portions of clips: Drag inside the filmstrip to select the range that you want, and click
Import Selected. You can also select multiple ranges in each clip. For more information, see
Select a range on page 94.
Tip:  You can also select a clip, press the Space bar to play the clip, and press either I to set a
start point or O to set an end point.

5 In the window that appears, choose how you want to organize the imported media in your library:
••

To add the imported clips to an existing event: Select “Add to existing event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new event in,” use the pop-up menu to choose the library
in which you want to create the event, and then type a name (for example, “Chris and Kim
Wedding”) in the text field.

To learn more about events, see Organizing libraries overview on page 56.
Note:  You can set storage locations for each of your libraries using the Library Properties
inspector. For more information, see Manage storage locations on page 434.
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6 If you want to create optimized or proxy media, analyze the video, or analyze the audio, select
the relevant checkboxes in the Transcoding, Keywords, Video, and Audio sections.
If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it
later (if necessary) in the Browser.
Note:  Some import options are available only when you import files from a storage device. For
more information, see Organize files while importing on page 42 and Import from a hard disk on
page 38.
7 Click Import.
By default, the Media Import window closes when you click Import. You can begin working with
your clips in the Browser. Final Cut Pro imports your media in the background.
If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the
files after the import process is complete. You can view the progress of the import and other
background tasks in the Background Tasks window.
8 When background tasks are completed, disconnect the iPhone, iPad, or iPod touch.

Import from a digital still camera
You can import video and still images from digital still cameras. The steps below describe how
to import video and still images directly into Final Cut Pro. You can also import your photos into
Aperture or iPhoto and access them through the Photos Browser in Final Cut Pro.
To check whether your camera is compatible with Final Cut Pro, go to the Final Cut Pro X
Supported Cameras webpage at http://help.apple.com/finalcutpro/cameras.
Import still-image clips and video clips from a digital still camera
1 Connect your camera to your computer using the cable that came with the camera, and turn
it on.
If your camera doesn’t appear on the left side of the Media Import window (either in the
Cameras or Devices section), remove the camera’s memory card and insert it into the card slot on
your Mac (if it has one) or into an external card reader.
2 In the Finder, locate the DCIM folder inside the camera folder, and then locate the still-image or
video files. The files may be in the DCIM folder, or in a folder one or two levels down. Devices and
file structures vary by model and manufacturer.
3 In Final Cut Pro, do one of the following:
••

Choose File > Import > Media (or press Command-I) and follow the instructions in Import
from a hard disk on page 38.

••

Drag the files from the Finder into an event or Timeline in Final Cut Pro. The files will be
imported using the import settings you configured in Import preferences. See Import from a
hard disk on page 38.

After import, you may have separate audio files that you want to use to replace the video’s audio
track. To do this, you can automatically synchronize the video and audio clips.
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Import from tape-based cameras
You can import media from a tape-based camcorder or tape-based device. To determine
which clips you want to import (rather than importing all of them), you can view them using
Final Cut Pro before you import them.
Final Cut Pro supports tape-based import of the following formats: DV (including DVCAM,
DVCPRO, and DVCPRO50), DVCPRO HD, and HDV.
To check whether your camera is compatible with Final Cut Pro, go to the Final Cut Pro X
Supported Cameras webpage at http://help.apple.com/finalcutpro/cameras.
Import media from a tape-based camcorder or device
1 Connect the camcorder to your computer using the cable that came with it, and configure your
device for remote control over FireWire, if necessary.
If your computer does not have a FireWire port but does have a Thunderbolt port, you can
connect the FireWire cable using an Apple Thunderbolt to FireWire Adapter or an Apple
ThunderBolt Display (which also has a FireWire port).
Note:  For best results when importing from a tape-based camcorder, it is recommended that you
import the video using the same camcorder that you used to record it.
2 Turn on the camcorder and set it to VTR or VCR mode. (This mode may have a different name on
your camera. For more information, see the documentation that came with your camcorder.)
3 In Final Cut Pro, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.

The Media Import window appears.
4 If you have multiple devices connected to your computer, choose the device you want to import
from in the list of cameras on the left.
The Media Import window displays the image from the current position of the tape.
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5 Use the playback controls (or use the J, K, and L keys) to set your tape to the point where you
want to begin importing, and click Import.
6 In the window that appears, choose how you want to organize the imported media in your library:
••

To add the imported clips to an existing event: Select “Add to existing event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new event in,” use the pop-up menu to choose the library
in which you want to create the event, and then type a name (for example, “Chris and Kim
Wedding”) in the text field.

To learn more about events, see Organizing libraries overview on page 56.
Note:  You can set storage locations for each of your libraries using the Library Properties
inspector. For more information, see Manage storage locations on page 434.
7 If you want to create optimized or proxy media, analyze the video, or analyze the audio, select
the relevant checkboxes in the Transcoding, Keywords, Video, and Audio sections.
If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it
later (if necessary) in the Browser.
Note:  Some import options are available only when you import files from a storage device. For
more information, see Organize files while importing on page 42 and Import from a hard disk on
page 38.
8 Click Import.
Final Cut Pro begins importing immediately from the current location on the tape. It will
continue to import (and save the resulting media file to the event you specified) until one of the
following occurs:
••

It reaches the end of the tape.

••

The hard disk you are importing to is full.

••

You stop the import session by clicking Stop Import or Close (to close the Media Import
window) or by pressing Escape.

The video plays as it’s being imported. It takes as long to import the video as it takes to watch it
at normal speed.
9 When the section of video you want to import has been imported, click Stop Import (or press Escape).
If you selected any options in step 8, Final Cut Pro transcodes and optimizes the files after
the import process is complete. You can view the progress of the background tasks in the
Background Tasks window.
10 Use the import controls to set your video to a point where you want to begin importing again,
and repeat steps 5 through 10.
11 When you’re done importing, click Close to close the Media Import window.
You can also create an archive from your tape-based device, recording everything on the tape
from beginning to end and saving the captured clips as an archive. For more information, see
Create and manage camera archives on page 435.
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If your camera or device isn’t recognized
If you’ve connected your camera or device to your computer but the Media Import window
doesn’t open, or Final Cut Pro can’t control your device, there are several things you can do to try
to establish the connection.
Check your equipment and system
1 Make sure that you’re using the correct equipment configuration:
••

Your camcorder or camera must be compatible with Final Cut Pro. For a list of
compatible devices, go to the Final Cut Pro X Supported Cameras webpage at
http://help.apple.com/finalcutpro/cameras.

••

Your device must be connected properly to your computer.

••

Your camcorder must be set to the correct output mode. On some camcorders, this is called VTR
or VCR mode, but not all camcorders use the same terminology, so check the documentation
that came with your device. On some camcorders you must set the output to DV mode or HDV
mode, depending on whether the content is standard (DV) or high definition (HDV).

••

If you’re connecting a tape-based camcorder to your computer, you should be using a FireWire
cable (also called IEEE 1394, or i.LINK), not a USB cable.
See About memory cards and cables on page 45 for more information.

••

If you’re importing video clips from a still camera or other flash memory device, make sure
the file format of your video is MPEG-2, MPEG-4, or AVCHD, all of which are compatible with
Final Cut Pro.

••

If your still camera is not supported by Final Cut Pro, try importing the media as files, using a
card slot on your Mac computer or an external card reader.
See Import from a hard disk on page 38 for more information.

••

If you’ve enabled Fast User Switching, make sure no one else is trying to use the camcorder
from a different account at the same time.

2 If you still can’t import media after checking the items above, try the following:
••

Turn the device off and on again.

••

Disconnect the cable from both the device and the computer, and then reconnect it.

••

Quit and then reopen Final Cut Pro.

••

Restart your computer.

••

Try using a different cable.

••

Try using a different computer with Final Cut Pro installed.

••

If you’re using a file-based camcorder, use the Finder to copy the mounted volume to a local
disk. Then open the files in Final Cut Pro in the same way that you open an archive.

Note:  When you see red frames and a yellow alert triangle in a Timeline or event, Final Cut Pro is
alerting you that part of your project or event is missing. For more information, see Alert icons on
page 438.
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Import from other applications
Import from iMovie
You can send an iMovie project to Final Cut Pro. You initiate the process from within iMovie. The
project file and the media used in the project are copied to your Final Cut Pro library.
For more information, see iMovie Help at http://help.apple.com/imovie.
Note:  If you want to send an iMovie trailer project, you first need to convert it to a movie project.
For more information, see iMovie Help.
Note:  If you send a movie project from iMovie to Final Cut Pro and it contains a clip with the
“Lower volume of other clips” audio adjustment, that adjustment appears in Final Cut Pro as
the Gain filter. For information about adjusting audio effects in Final Cut Pro, see Adjust audio
effects on page 192.

Import from iPhoto and Aperture
When you import photos and video clips from iPhoto or Aperture into Final Cut Pro, the media is
imported using the import settings you defined in Import preferences. For more information, see
Import from a hard disk on page 38.
Import photos and video clips from iPhoto or Aperture
1 In Final Cut Pro, do one of the following:
••

Choose Window > Media Browser > Photos.

••

Click the Photos button in the toolbar.

2 If necessary, navigate to the iPhoto or Aperture section of the Photos Browser.

3 To use one or more photos or video clips in your project, drag the items from the Photos Browser
to an event icon in the Libraries list or a project in the Timeline. To select multiple clips, you can
Command-click them or drag a selection rectangle around them.
You can also drag photos and video clips from iPhoto or Aperture directly to an event in the
Libraries list or a project in the Timeline, without using the Photos Browser.
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Import from iTunes
You can import music and sound from your existing iTunes library into Final Cut Pro.
Import music and sound from iTunes
1 In Final Cut Pro, do one of the following:
••

Choose Window > Media Browser > Music and Sound.

••

Click the Music and Sound button in the toolbar.

2 In the Music and Sound Browser, choose iTunes from the pop-up menu at the top.
Tip:  If the folder you’re looking for doesn’t appear, you can add it to the source list by dragging it
from the Finder or desktop to the Music and Sound Browser.
3 In the list that appears, find the music or sound you want:
••

To search for an item: Type text in the search field. To filter your search, click the Filter button
and choose a filter.

••

To preview an item: Double-click the item, or select the item and click the Play button

••

To select more than one item: Command-click each item.

.

4 Drag the sound file or files to the Timeline.
Note:  For better import and playback performance, Final Cut Pro automatically transcodes
all MP3 audio files to WAV audio files and retains the original MP3 files for future use. For
information about where to find original and transcoded media files, see Locate source media
files on page 421.

Import from Motion
You can build and modify video effects, titles, transitions, and generators in Motion 5 for use in
Final Cut Pro. When you save a template in Motion, it is “published” and becomes available in its
respective media browser in Final Cut Pro.
See the information about Final Cut Pro X templates in Motion Help at
http://help.apple.com/motion.
For more information, see the following:
••

Create specialized versions of transitions in Motion on page 220

••

Create specialized versions of the video effects in Motion on page 248

••

Create specialized versions of the generators in Motion on page 252
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Import from devices
Import from a hard disk
You can import media—video, audio, still images, and graphics files—from your computer’s hard
disk, a connected external storage device, a memory card inserted in your computer’s card slot
or a card reader, or a network attached volume. You can import media using the Media Import
window or by dragging files from the Finder.
When you drag media from the Finder into Final Cut Pro, the media is imported using the import
settings in Final Cut Pro preferences. If you don’t want to use the Media Import window to
manage your import, and if you want to always use the same file storage, transcoding, keyword,
and analysis settings, importing by dragging files into Final Cut Pro is a good option. For more
information, see Import preferences on page 444.
Note:  Some file-based devices allow you to copy the recorded media (with its original directory
structure) to a folder on your computer’s hard disk via the Finder. To import media copied in this
way, see Access media on an archive or disk image on page 41.
Import media from a hard disk using the Media Import window
1 If the media you want to import is on an external storage device or memory card, connect the
device to your computer and turn it on.
2 To open the Media Import window, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.

3 In the Devices section on the left side of the Media Import window, select your computer’s
hard disk or the connected external storage device or memory card from which you want to
import media.
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4 Use the list view at the bottom of the window to navigate to a file or folder and select it. (When
you import from a hard disk, filmstrips are visible for individual selected clips only.)
Tip:  Command-click to select multiple files or folders to import.
Add favorite import folders.

Play back the
selected clip.
Skim the
selected clip.
Click a column
heading to sort
items by that
category.

Navigate to the files and folders.

5 Do any of the following:
••

To preview the selected clip: Play it using the playback controls or skim it by moving the pointer
forward or backward over the filmstrip.

••

To change which hard disk to import from: Select the hard disk in the Devices section or select
the location in the Favorites section.

••

To sort clips in list view by data such as duration, creation date, rating, keyword, and so on: Click
the column headings at the top of list view.

••

To add folders of frequently used media to the Favorites section: Drag a folder from the list on the
right to the Favorites section on the left.
To remove a folder from the Favorites section, Control-click the folder and choose Remove
from Sidebar in the shortcut menu.

••

To automatically close the Media Import window when the import begins: Select the “Close
window after starting import” checkbox.

••

To add a folder to the list view by dragging: Drag the folder from the Finder to the list view and
browse its contents in list view.

6 When you’re ready to import, click Import Selected.
7 In the window that appears, choose how you want to organize the imported media in your library:
••

To add the imported clips to an existing event: Select “Add to existing event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new event in” and use the pop-up menu to choose the
library in which you want to create the event; then type a name (for example, “Chris and Kim
Wedding”) in the text field.

To learn more about events, see Organizing libraries overview on page 56.
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8 Choose a storage location for the media files:
••

To copy the files to the current library: Select “Copy to library” to duplicate the files and place
the copies in the current library storage location. You can set the storage location for a library
using the Library Properties inspector. For more information, see Manage storage locations on
page 434.
Note:  The name of this option changes to “Copy to library storage location: location name“
when the current library is set to an external storage location.

••

To link to the files at their current location: Select “Leave files in place.”
Note:  If you select this option, Final Cut Pro creates symbolic links (also known as symlinks),
which are special files that point to the media files. If you later copy or move clips between
events, Final Cut Pro copies or moves the symbolic links only (not the source media files). To
replace the symbolic links with the actual source media files, select the events and choose
File > Consolidate Event Files. For more information about files and clips, see Media files and
clips on page 22.

9 If you want to organize your media, create optimized or proxy media, analyze the video, or
analyze the audio, select the relevant checkboxes in the Transcoding, Keywords, Video, and
Audio sections.
If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it
later (if necessary) in the Browser.
10 Click Import.
By default, the Media Import window closes when you click Import. You can begin working with
your clips in the Browser. Final Cut Pro imports your media in the background.
If you selected any options in the previous step, Final Cut Pro starts to transcode and optimize
the files after the import process is complete. You can view the progress of the import and other
background tasks in the Background Tasks window.
If you imported media from an external device and you chose to have Final Cut Pro copy the
media files to the library file (rather than just link to them in their original location), you can
disconnect the device when the background tasks are completed.
Import media by dragging from the Finder
Do one of the following:
mm Select a file, Command-click to select multiple files, or select a folder of files, and drag the file or
files from the Finder to the event.
The clip or clips appear in the event.
mm Select a file, Command-click to select multiple files, or select a folder of files and drag the file or
files from the Finder to a Keyword Collection.
The clip or clips appear in the event, and the keyword is automatically added to the clip or clips.
Important:  If you selected “From Finder tags” and “From folders” in the Keywords section of
Final Cut Pro Import preferences, a Keyword Collection is created for each folder name and each
tag, and the corresponding files are assigned that keyword.
mm Select a file or Command-click to select multiple files, and drag the file or files to a project in
the Timeline.
The clip or clips appear in the Timeline, and in the corresponding event.
The file or files are imported using your default import settings.
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Access media on an archive or disk image
If you’ve created a camera archive, you can use the media in the archive in two ways:
••

You can connect to the camera archive, making the media available to Final Cut Pro.

••

You can import the media from the archive, or import media from disk images previously
archived with the Final Cut Pro Log and Transfer window in Final Cut Pro 7 or earlier. When you
do this, copies of the media are created on your local disk.

Some file-based devices allow you to copy the recorded media (with its original directory structure)
to a folder on your computer’s hard disk via the Finder. To import media copied in this way (or to
import from disk images previously archived with the Final Cut Pro Log and Transfer window in
Final Cut Pro 7 or earlier) follow the instructions in “Import media from a disk image,” below.
Import media from a camera archive
1 To open the Media Import window, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.

2 In the Devices section on the left side of the Media Import window, select your computer’s hard
disk or the connected external storage device or memory card from which you want to import
media, and then use the list at the bottom of the window to navigate to the camera archive.
The archive is connected to Final Cut Pro, and its media is displayed in the Media Import window.
3 Click the disclosure triangle to the left of the camera archive icon to reveal the list of clips in the
archive, or double click the camera archive to open it.
4 To import the media, see Import from file-based cameras on page 24.
Import media from a disk image
1 In the Finder, double-click the disk image (.dmg) file to open it.
2 To open the Media Import window in Final Cut Pro, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.

3 Select the disk image in the Cameras section on the left side of the Media Import window.
Note:  If the disk image doesn’t have a file structure typical of a video camera, it appears in the
Devices section instead.
The open disk image is connected to Final Cut Pro, and its media is displayed in the Media
Import window.
4 To import the media, see Import from file-based cameras on page 24.
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Organize files while importing
You can choose how to organize your media when you import it into Final Cut Pro.
You can copy the source files into the library or link to them at their current location. If your
source files have Finder tags or the folders containing the files have meaningful names, you can
choose to have the tags and folder names applied to the files as keywords during import.
If your source footage contains shots of people, you can have Final Cut Pro analyze the footage
during import and apply keywords for the number of people in each shot and the shot type.
A Keyword Collection is created for each keyword added to your clips during import. Select a
Keyword Collection in the Libraries list to see all the clips with that keyword applied.
Organize your files during import
1 To import a file, choose File > Import > Media, navigate to the file you want to import, select the
file, and click Import.
For more information, see Importing overview on page 23.
2 In the window that appears, choose how you want to organize the imported media in your library:
••

To add the imported media to an existing event: Select “Add to existing event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new event in,” use the pop-up menu to choose the library
in which you want to create the event, and then type a name (for example, “Chris and Kim
Wedding”) in the text field.

To learn more about events, see Organizing libraries overview on page 56.
3 In the Files section, select a file storage option:
••

Copy to library: This option duplicates the media files and places the copies in the current
library storage location.
Note:  The name of this option changes to “Copy to library storage location: location name“
when the current library is set to an external storage location.
You can set the storage location for a library using the Library Properties inspector. For more
information, see Manage storage locations on page 434.

••

Leave files in place: This option links to the source media files at their current location. If you
import files with this option selected, Final Cut Pro creates symbolic links (also known as
symlinks), which are special files that point to the media files without copying them. When you
move, copy, or back up events and projects that use these files, Final Cut Pro moves or copies
the symbolic links only (not the source media files). If, after you move or copy your project
or event, you want to replace the symbolic links with the actual source media files, select the
events and choose File > Consolidate Event Files. For more information about files and clips,
see Media files and clips on page 22.
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4 In the Keywords section, select any of the following options:
••

From Finder tags: Creates a keyword for each Finder tag in the files you’re importing.
Additionally, a Keyword Collection is created for each keyword. For more information about
Finder tags, see the help for OS X (available from the Help menu when the Finder is active).

••

From folders: Creates a keyword for each folder name and applies the keyword to all the files in
the folder during import. Additionally, a Keyword Collection is created for each keyword.

After import, these clips
will have “B-roll” and
“Callaway” keywords.
After import, these clips
will have “Interviews” and
“Callaway” keywords.

••

Find people: Analyzes video clips and still images for the number of people present and
shot types. After analysis, any of the following keywords are added to the clip: One Person,
Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot. Additionally, a Keyword
Collection is created for each keyword. The “Consolidate find people results” checkbox
simplifies and summarizes all of the “find people” analysis keywords. If you’re analyzing to find
people, it’s recommended that you also select the “Create Smart Collections after analysis”
checkbox. For more information, see Analyzing media overview on page 50.

5 If you want to create optimized or proxy media, analyze the video, or analyze the audio, select
the relevant checkboxes in the Transcoding, Video, and Audio sections.
If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it
later (if necessary) in the Browser.
6 Click Import.
By default, the Media Import window closes when you click Import. You can begin working with
your clips in the Browser. Final Cut Pro imports your media in the background.
If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the
files after the import process is complete. You can view the progress of the import and other
background tasks in the Background Tasks window.

Import while recording

You can record video directly into Final Cut Pro using your computer’s built-in camera or an
external iSight camera.
Record live video and audio into Final Cut Pro
1 Do one of the following:
••

To record using the built-in camera: Click the Import Media button in the toolbar.

••

To record using an external iSight camera: Connect the iSight camera to your computer with a
FireWire cable, and click the Import Media button in the toolbar.

2 In the Cameras list on the left side of the Media Import window, select the camera you want to
import from.
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A live video image from the camera appears in the Media Import window.

3 Click Import.
4 In the window that appears, choose how you want to organize the imported media in your library:
••

To add the imported clips to an existing event: Select “Add to existing event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new event in,” use the pop-up menu to choose the
library in which you want to create the event, and type a name (for example, “Chris and Kim
Wedding”) in the text field.

To learn more about events, see Organizing libraries overview on page 56.
Note:  You can set storage locations for each of your libraries using the Library Properties
inspector. For more information, see Manage storage locations on page 434.
5 If you want to create optimized or proxy media, analyze the video, or analyze the audio, select
the relevant checkboxes in the Transcoding, Keywords, Video, and Audio sections.
If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it
later (if necessary) in the Browser.
Note:  Some import options are available only when you import files from a storage device. For
more information, see Organize files while importing on page 42 and Import from a hard disk on
page 38.
6 When you’re ready to begin recording, click Import.
The camera begins recording immediately.
7 When you want to stop recording, click Stop Import.
A new video clip is created. You can click Import to begin recording again. You can repeat this
process as many times as necessary.
Tip:  You can also capture live video from some video camcorders over a FireWire cable using
QuickTime X. For more information, see QuickTime Player Help (available from the Help menu
when QuickTime Player is open).
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About memory cards and cables

To import media from your recording device to your computer, you need to remove the memory
card from your device and insert it into either your computer or a memory card reader. You can
also connect your device directly to your computer using the appropriate cable. Then you can
import the media on the memory card or device using the Media Import window. For more
information, see Import from a hard disk on page 38 and Import from file-based cameras on
page 24.
••

Memory cards: Many file-based camcorders and devices record media on a removable memory
card. You can connect a card reader to your computer and use that to transfer the contents of
your memory card onto your computer. Some Mac computers feature an SD (Secure Digital)
or SDXC (SD extended capacity) card slot that allows these computers to read and write data
to SD media inserted in the slot. If your Mac has a card slot, you can remove the card from the
camera, insert the card into your Mac, and then import the files.
For more information, go to http://support.apple.com/kb/ht3553.

You can also connect your device to the computer using a FireWire or USB cable. The kind of
cable you need depends on the kind of device you’re using:
••

USB device: You use a USB cable for file-based camcorders, digital still cameras that record video,
and iPhone, iPad, and iPod touch. The USB cable should have at least one connector that plugs
into your Mac (at the top in the illustration below). The other end of the USB cable, which plugs
into your recording device, might look different (on the bottom in the illustration below).

••

FireWire device: For most camcorders that record to tape, you use a FireWire cable with a 6-pin
connector on one end that plugs into your Mac (at the top in the illustration below) and
a 4-pin connector on the other end that plugs into your camcorder (on the bottom in the
illustration below).

Or you might have a FireWire 800 cable, with a different end that plugs into your camcorder
or computer.
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••

Thunderbolt device: Devices that use Thunderbolt I/O technology use a connector that plugs
into the mini display port on your Mac and looks like the connector below.

If your device didn’t come with a cable and you’re not sure what kind of device you have, you
can check the logo near the cable ports on your device to see if it matches the USB or FireWire
logo, both shown above. Otherwise, check the documentation that came with your device.
Note:  Not all Mac computers include a FireWire port. Check your system configuration to confirm
that your Mac includes FireWire support before attempting to connect a standard (DV) or
HDV camcorder.
To check whether your camera is compatible with Final Cut Pro, go to the Final Cut Pro X
Supported Cameras webpage at http://help.apple.com/finalcutpro/cameras.

Supported media formats

You can import and work with the following video, audio, and still-image formats in Final Cut Pro:
Video formats
•• Apple Animation codec
••

Apple Intermediate codec

••

Apple ProRes (all versions)

••

AVC-Intra

••

AVCHD (including AVCCAM, AVCHD Lite, and NXCAM)

••

DV (including DVCAM, DVCPRO, and DVCPRO50)

••

DVCPRO HD

••

H.264

••

HDV

••

iFrame

••

Motion JPEG (OpenDML only)

••

MPEG IMX (D-10)

••

REDCODE RAW (R3D)

••

Uncompressed 10-bit 4:2:2

••

Uncompressed 8-bit 4:2:2

••

XAVC

••

XDCAM HD/EX/HD422

••

QuickTime formats
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Audio formats
•• AAC
••

AIFF

••

BWF

••

CAF

••

MP3

••

MP4

••

WAV

Still-image formats
•• BMP
••

GIF

••

JPEG

••

PNG

••

PSD (static and layered)

••

RAW

••

TGA

••

TIFF

Container formats
•• 3GP
••

AVI

••

MP4

••

MTS/M2TS

••

MXF (requires third-party plug-in)

QuickTime
For information about formats you can export your movie to, see Supported export formats on
page 402.
••

Import and adjust REDCODE RAW video files

You can import and work with REDCODE RAW (R3D) files in Final Cut Pro.
RAW format video files require some additional steps before and after import.
After the R3D RAW files are imported, you can make nondestructive color correction adjustments
directly within Final Cut Pro.
Import REDCODE RAW (R3D) files
1 Install the appropriate plug-in.
In order for Final Cut Pro to recognize the R3D RAW files, you must download and install the
corresponding plug-in. For more information, go to http://www.red.com.
2 Import the media.
Important:  When you import the media, make sure to deselect the “Create optimized media”
and “Create proxy media” options, because any transcoding work done during import will be
discarded if you adjust the RAW settings in the next step.
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For more information about importing media, see Import from file-based cameras on page 24
and Import from a hard disk on page 38. For more information about transcoding media, see
Manage optimized and proxy media files on page 425.
Note:  If you are importing files from the RED ONE camera, it is recommended that you import
the R3D RAW files only. The RED ONE camera typically generates a set of up to four QuickTime
reference movie (.mov) files for each R3D RAW file. If you select both the R3D file and the
reference movies during the import process, Final Cut Pro imports the R3D file only. If you need
to import a reference movie, select only the reference movie, not the R3D file.
3 Adjust the RAW settings (with Final Cut Pro or with an external application such as
REDCINE–X PRO).
You can apply a nondestructive “one-light” color correction to the R3D RAW clips immediately
after import, to give your footage a more finished look for editing and review.
If you have a professional production with sophisticated color correction needs, you can revisit
these RAW settings during the finishing stage. For more information, see “Adjust RED RAW
settings,” below.
4 If you like, generate optimized or proxy media from the R3D RAW files.
For more information, see “Transcode clips after import” in Manage optimized and proxy media
files on page 425.
To control whether Final Cut Pro displays optimized, proxy, or original media in the Viewer, and
whether video playback is optimized for quality or performance, choose the corresponding
options from the Viewer Options pop-up menu in the upper-right corner of the Viewer. For more
information, see Control playback quality and performance on page 85.
5 Add the R3D RAW clips to your project and edit them as you would any other clips.
Adjust RED RAW settings
You can adjust REDCODE RAW (R3D) files using the RED RAW Settings window.
Metadata about REDCODE RAW (R3D) files can be stored in two locations:
••

Internal (embedded) settings: This is metadata information recorded by the camera and
embedded in the R3D RAW file. It always remains with the file. These camera settings can be
superseded by settings in the external RMD file, but they are never overwritten. You can revert
to these camera settings by deleting any existing RMD file or by choosing Original Camera
Settings from the Revert To pop-up menu in the RED RAW Settings window.

••

External RMD file: This is an external metadata file with the file extension .RMD. This file is
created by Final Cut Pro, REDCINE-X PRO, or similar software applications. If you adjust RED
RAW settings in Final Cut Pro and an RMD file already exists, the existing file is overwritten
when the changes are saved. The embedded camera settings remain intact.

1 Install the appropriate plug-in.
In order for Final Cut Pro to recognize the R3D RAW files, you must download and install the
corresponding plug-in. For more information, go to http://www.red.com.
2 In the Browser or the Timeline, select the clip or clips you want to adjust.
Note:  Compound clips cannot be adjusted.
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3 Do one of the following:
••

Choose Window > Show Inspector (or press Command-4).

••

Click the Inspector button in the toolbar.

4 Click the Info button at the top of the pane that appears.
5 In the Info inspector, click the Modify RED RAW Settings button.
6 In the RED RAW Settings window, adjust the settings.
Your changes are saved nondestructively to an external metadata file with the file extension
.RMD, overwriting any existing RMD metadata file. Unlike video effects that are applied to a clip,
these adjustments are associated with the file (via the RMD metadata file). Any changes you
make to these settings are applied to all copies of the selected clip or clips.
Note:  Final Cut Pro supports the RED ROCKET card, a PCI card that provides a significant boost
in performance.
For more information about REDCODE RAW (R3D) files and the RED ROCKET card, go to
http://www.red.com.
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4

Analyze media

Analyzing media overview

You can have Final Cut Pro analyze your media and automatically correct common problems it
may find in your video, still images, and audio. For example, you can balance color and remove
excess hum or loudness.
You can also analyze clips to identify their contents. Analysis can detect the number of people in
a shot and identify if the shot is a close-up, medium, or wide shot. This is helpful if you need to
quickly find a certain type of clip while viewing footage or editing a project. For complete lists of
the video and audio analysis options, see Video and still-image analysis options on page 51 and
Audio analysis options on page 51.
You can analyze media during the import process or after you import the media into
Final Cut Pro. You can also set Final Cut Pro to automatically analyze clips you drag directly to the
Final Cut Pro Timeline from the Finder.
After certain types of analysis, keywords are automatically added to clips or clip ranges based on
the results of the analysis. For example, a clip showing several people might have the Group and
Medium Shot keywords assigned. In the Browser, clips with analysis keywords have a purple line at
the top. (Clips with keywords you add manually or keywords imported from Finder tags or folder
names have a blue line at the top. For more information, see Add keywords to clips on page 67.)
Keyword
Collection

A blue line indicates manually
applied keywords or keywords
imported with the media files.

A purple line indicates
analysis keywords.

Note:  This section covers analysis and automatic correction options for event clips only. For
information about correcting shaky video and rolling shutter distortion in clips in the Timeline,
see Correct excessive shake and rolling shutter issues on page 154.
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Video and still-image analysis options

Final Cut Pro provides video and still-image analysis options that can automatically balance color
in video and detect people and shot angles in video or still images. You can analyze video during
import, or analyze video clips in the Browser after import. Analysis keywords are added to clips or
clip ranges based on the results of the analysis.
Final Cut Pro provides these video and still-image analysis options:
••

Analyze for balance color: Analyzes video clips to detect color balance and contrast. Color is
automatically balanced when you add the clip to the Timeline. You can turn automatic color
adjustments on and off at any time.

••

Remove pulldown: Analyzes video clips and removes pulldown patterns.
Important:  This option is available only when importing from a tape-based camera or device.

••

Find people: Analyzes video clips and still images for the number of people present and shot
types. After analysis, any of the following keywords are added to the clips or clip ranges: One
Person, Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot.
Note:  If you’re analyzing to find people, it’s recommended that you also select the “Create
Smart Collections after analysis” checkbox so that you can easily locate clips with “find people”
analysis keywords.

••

Consolidate find people results: Consolidates all of the “find people” analysis keywords into one
shot type keyword and one people keyword for every 2-minute segment of video. The shot
type keyword chosen is the one for the widest shot type, and the people keyword chosen is
the one representing the most people. For example, if a video segment contains Medium Shot,
Wide Shot, One Person, and Group keywords, the segment’s analysis keywords are reduced to
Wide Shot and Group during consolidation.

••

Create Smart Collections after analysis: Creates a Smart Collection for each keyword applied
when analyzing video clips and still images for the presence of people. The Smart Collections
are listed alphabetically in a People folder inside the event in the Libraries list.

When you drag a media file from the Finder to a Final Cut Pro event or the Timeline, the import
begins automatically, without displaying a window of import options. You can set automatic
import options in the Final Cut Pro Import preferences pane.

Audio analysis options

Final Cut Pro provides automatic analysis options that can fix common audio problems, analyze
and group audio channels, and remove silent channels. You can analyze audio during import, or
analyze video clips with audio issues in the Browser or in the Timeline.
Final Cut Pro provides these audio analysis options:
••

Analyze and fix audio problems: Analyzes the audio for hum, noise, and loudness. Final Cut Pro
automatically fixes problems that are considered severe (marked in red) and flags problems
that are considered moderate (marked in yellow). For more information, see Enhance audio on
page 201.

••

Separate mono and group stereo audio: Audio channels are analyzed and grouped as dual
mono or stereo, depending on the results of the analysis. Automatically corrected audio
channels are marked as Autoselected. For more information about audio channels, see
Configure audio channels on page 171.
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••

Remove silent channels: Audio channels are analyzed, and silent channels are automatically
removed. Clips that have had channels removed are marked as Autoselected. For more
information about audio channels, see Configure audio channels on page 171.

When you drag a media file from the Finder to a Final Cut Pro event or the Timeline, the import
begins automatically, without displaying a window of import options. You can set automatic
import options in the Final Cut Pro Import preferences pane.

Analyze your media

You can analyze clips during the import process, analyze clips in the Browser after import, or set
Final Cut Pro to analyze clips automatically when they are dragged to a Final Cut Pro event or
the Timeline.
Analyze clips during import
1 Do one of the following:
••

To import a file from a compatible camcorder or camera, iPad, iPhone, iPod, or other device:
Connect the device to your computer, turn on the device, and choose File > Import > Media
(or press Command-I). In the window that appears, select the file you want to import, and click
the Import button.

••

To import a file from a tape-based camcorder: Connect the camcorder to your computer, turn
on the camcorder, and set it to VTR or VCR mode. Then choose File > Import > Media (or press
Command-I) and click the Import button.

••

To import a file from a memory card: Insert the memory card into the card slot on your Mac or
into a card reader that’s connected to your computer, and choose File > Import > Media (or
press Command-I). In the window that appears, select the file you want to import, and click
the Import button.

••

To import a file located on your hard disk or a connected external storage device: Choose File >
Import > Media (or press Command-I). In the window that appears, select the file you want to
import, and click the Import button.

••

To import from an archive: Choose File > Import > Media (or press Command-I). In the window
that appears, select the archive you want to import from, select the files in the archive you
want to import, and click the Import button.

2 In the window that appears, choose how you want to organize the imported media in your library:
••

To add the imported media to an existing event: Select “Add to existing Event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new Event” and type a name (for example, “Chris and Kim
Wedding”) in the text field. Use the “Save to” pop-up menu to choose the disk where you want
to store the event.

To learn more about events, see Organizing libraries overview on page 56.
3 Select any of the video and audio analysis options that you want to apply.
For descriptions of the video and audio analysis options, see Video and still-image analysis
options on page 51 and Audio analysis options on page 51.
Final Cut Pro will analyze the files in the background, after the import process is complete.
4 Click Import.
The import may take a while, depending on the options you selected in step 3. You can see the
status of all the background processes currently running in the Background Tasks window.
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Analyze clips after import
1 To select the clip you want to analyze, do one of the following:
••

Click the clip in the Browser. (To select multiple clips, you can Command-click them or drag a
selection rectangle around them.)

••

Control-click a clip in the Timeline and choose “Reveal in Browser” from the shortcut menu.

2 In the Browser, Control-click the clip or clips and choose “Analyze and Fix” from the
shortcut menu.
3 In the window that appears, select any or all of the video analysis and audio analysis options that
you want to apply, and click OK.
The transcoding process may take a while, depending on the analysis options you selected.
You can see the status of all the background processes currently running in the Background
Tasks window.
Automatically analyze media files when they are dragged to an event or the Timeline
1 Choose Final Cut Pro > Preferences.
2 In the Preferences window, click Import and select each of the video and audio analysis options
that you want to apply.
For more information, see Import preferences on page 444.
When you’re finished, close the Preferences window.
3 To import one or more files, select a file (or Command-click multiple files) in the Finder and drag
the selection to an event or the Timeline.

View analysis keywords on clips

If you analyzed media to find people, analysis keywords such as One Person, Close Up Shot, and
so on are automatically added to clips or clip ranges. Clips or ranges with analysis keywords are
marked with a purple line in the Browser.
A clip with a purple
line has one or more
analysis keywords.

You can view a clip’s analysis keywords in several locations in Final Cut Pro.
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View keywords in the Skimmer Info window
1 Choose View > Show Skimmer Info (or press Control-Y).
2 Skim the clip in the Browser.
Keywords, including analysis keywords, are displayed in the Skimmer Info window when you
hold the pointer over the clip.

To turn off Skimmer Info, choose View > Hide Skimmer Info (or press Control-Y).
View keywords in list view in the Browser
1 Click the List View button.

2 To see a clip’s keywords, click the disclosure triangle next to the clip.
The analysis keywords are
listed next to the purple gear.
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View the contents of a Smart Collection
If you chose to create Smart Collections after analysis, clips that have analysis keywords are
automatically grouped in Smart Collections within the event in the Libraries list. A Smart
Collection is created for each analysis keyword and placed in a People folder in the event.
mm In the Libraries list, select an analysis keyword Smart Collection inside an event.
The clips with that analysis keyword appear in the Browser. For example, if you select the
Medium Shot Smart Collection, all the clips in the event that have the Medium Shot keyword
appear in the Browser.
Medium Shot Smart Collection

These clips contain the
Medium Shot analysis keyword.
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5

Organize your library

Organizing libraries overview

A library contains multiple events and projects in the same location. When you import video,
audio, and still images, or record directly into Final Cut Pro, the source media files (your raw
footage) appear as clips in one or more events in the library. An event is similar to a folder that
can hold projects as well as dozens, hundreds, or even thousands of video clips, audio clips, and
still images. Each event in the library refers to media on your hard disk, and a database file keeps
track of where everything is.
As your library grows, you can rename, copy, move, and delete your clips, events, and projects as
necessary. You can have multiple libraries open at the same time, and you can easily copy events
and projects between these libraries. You can open and close libraries as needed. For more
information about managing multiple libraries, see Managing libraries overview on page 431.
When you select an event in the library, the media it contains appears as clips in the Browser.
You select clips or portions of clips in the Browser to work with them. You can sort clips in the
Browser by creation date, as well as by date imported, reel, scene, clip duration, and file type.
Click the disclosure
triangle for a library to
show or hide its events.

The Browser displays clips and
projects in the selected event.

Select an event
in the Libraries list.

When you import video into a new event, you name the event. By giving your events meaningful
names, such as “Smith Wedding 2013,” you can organize all of your media so that it’s readily
accessible. You can organize your libraries in other ways, and you can also hide the Libraries list
to give yourself more room to work. The Libraries list is also the home for Final Cut Pro Keyword
Collections and Smart Collections, which provide a powerful way to organize your video editing
projects using keywords and persistent search filters.
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Organize your projects, events, and media
Create a new event
After importing your source media files into Final Cut Pro, you may find that you need to
create additional events to organize your media. For example, after importing media shot for
a production, you may decide to split the media into events defined by useful categories—
shooting locations, scenes, episodes, and so on.
Create a new event in your library
1 If you don’t see the Libraries list, click the button at the bottom-left corner of the Browser.

2 If you have more than one library, select the library

in which you want to create a new event.

3 Choose File > New Event (or press Option-N).
4 In the window that appears, type a name for the event, use the Library pop-up menu to choose a
library to hold the event, and click OK (or press Return).
If you want to include a new, untitled project, you can select the Create New Project checkbox.
To customize settings for the new project, click Use Custom Settings. For more information, see
Modify a project’s settings on page 89.
The new event appears in the selected library.
5 Move clips from other events into the new event, as necessary.

Rename clips, events, and projects
You can rename clips in the Browser, the Timeline Index, or the Info inspector at any time. You
can rename projects in the Browser and in project settings.
Renaming a clip affects only that instance of the clip. For example, if you add a clip from the
Browser to the Timeline, copy clips between events, or copy clips within the Timeline, each of
these clip instances (copies) is independent of the others and can have its own name.
As your project evolves, you may want to rename an event so that it more accurately reflects the
clips it contains. You can rename events in the Libraries list.
Important:  Renaming a clip in Final Cut Pro does not rename the clip’s source media file on disk.
Rename a clip or a project in the Browser
mm To rename a clip or project in filmstrip view: Click the clip’s or project’s name, and type a new name.
mm To rename a clip or project in list view: Click the clip’s or project’s name, press Return, and type a
new name.
You can also rename a project in project settings. For more information, see Modify a project’s
settings on page 89.
Rename an event
1 In the Libraries list, select the event whose name you want to change.
2 Do one of the following:
••

Click the event’s name and type a new name.

••

Press Return and type a new name.
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Rename a clip in the Timeline Index
1 To open the Timeline Index, click the Timeline Index button in the lower-left corner of the
Final Cut Pro main window (or press Shift-Command-2).

2 Click the Clips button at the top of the Timeline Index.
Clips button

3 Click the Name field for a clip, and type a new name.
Rename a clip in the Info inspector
1 Select a clip in the Browser or the Timeline.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 In the Name section of the Info inspector, click the Name field and type a new name.
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View and sort clips and projects
You can display your clips and projects in the Browser in two views:
••

Filmstrip view: Displays the clips in the selected event as a connected series of thumbnail
images. Projects appear as thumbnail images with a superimposed clapboard design. Filmstrip
view is useful when you want to visually locate your clips and projects.

••

List view: Displays a list of your clips and projects with associated file and settings information.
Use this view when you want to view or sort clips and projects by data such as duration,
creation date, rating, keyword, and so on. When you select a clip in list view, a filmstrip for the
selected clip appears at the top of the Browser. The clip filmstrip is fully interactive, allowing
access to start and end points, markers, and keywords.
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Switch between filmstrip and list views
Do one of the following:
mm Click the Filmstrip View button in the bottom-left corner of the Browser.

mm Click the List View button in the bottom-left corner of the Browser.

Customize filmstrip view
mm To adjust the time represented by each thumbnail in a clip’s filmstrip: At the bottom-right corner of
the Browser, drag the Duration slider.

Slider set to 5 seconds

Slider set to 30 seconds

Adjusting the Duration slider expands and contracts the amount of detail shown in each clip’s
filmstrip. The longer each thumbnail’s duration, the fewer thumbnails each clip displays, and the
more clips are displayed in the Browser.
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mm To adjust the filmstrip height: At the bottom-right corner of the Browser, click the Clip Appearance
button and drag the Clip Height slider.

mm To turn audio waveforms on and off: At the bottom-right corner of the Browser, click the Clip
Appearance button and deselect the Show Waveforms checkbox.

When audio waveforms are on, they appear at the bottom of each clip’s filmstrip, increasing the
height of all clips in the Browser.
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Customize list view
mm To choose what type of information is displayed in list view columns as well as customize the columns
themselves: In the Browser, Control-click a column heading, and choose a category option from
the shortcut menu.
mm To rearrange columns in list view: In the Browser, drag a column heading to move the column to a
new position.
mm To sort clips in list view by a category: Click a column heading in the Browser to sort clips by
that category.
mm To view an item’s keywords or rating in list view: Click the disclosure triangle to the left of the
clip’s name.

Keyword
Rating

If a disclosure triangle appears to the left of a clip in list view, it means a keyword, rating, or both
have been applied to that item.
Sort and group clips and projects in the Browser
You can sort clips and projects in the Browser into an order that makes it easier to visually
locate them.
1 In the Libraries list, select the event whose items you want to sort.
2 Do one or both of the following:
••

To group clips by category: Choose Group Clips By from the Action pop-up menu
below
the Libraries list, and choose a category from the submenu. Choose to set the sort order as
Ascending or Descending from the same submenu.

••

To set the sort order of the clips and projects in the event without grouping them: Choose Sort
By from the Action pop-up menu below the Libraries list, and choose a category from
the submenu.

Note:  You can both group clips and set their sort order (arrangement) independently.
Reset the sort order in the Browser to its default state
1 In the Libraries list, select the event that contains the items whose sort order you want to reset.
2 Choose Group Clips By > None and Group Clips By > Ascending from the Action pop-up menu
below the Libraries list.

Chapter 5    Organize your library

62

Merge, split, and sort events
You can merge (combine) two or more events in a library (for example, if the media and projects
they contain are very closely related). If you find an event is getting bulky and unmanageable,
you can split it into multiple events.
You can also sort events in the Libraries list by name or date.
Merge multiple events
1 In the Libraries list, do one of the following:
••

Drag one or more events that you want to combine to a new event.

••

Select the events you want to combine, and choose File > Merge Events.

Final Cut Pro merges the selected events into a single event in the library. The corresponding
source media files remain in their original locations: either in the library file or linked from
external folders.
2 Select the merged event and type a new name.
Split an event into multiple events
1 Create the new events you need.
2 Drag the clips and projects you want to relocate from the original event to the new events.
The corresponding source media files remain in their original locations: either in the library file or
linked from external folders.
Sort events by name or date
1 Do one of the following:
••

To sort events by name: Choose View > Sort Events By > Name.

••

To sort events by date: Choose View > Sort Events By > Date.

2 To change the sort order, do one of the following:
••

To set an ascending sort order: Choose View > Sort Events By > Ascending.
This option sorts the events in alphabetical or chronological order.

••

To set a descending sort order: Choose View > Sort Events By > Descending.
This option sorts the events in reverse alphabetical or chronological order.

Chapter 5    Organize your library

63

Copy or move clips and projects between events in the same library
You can copy and move clips and projects from one event to another.
For information about copying and moving clips, projects, and events to other libraries, see Copy
or move items between libraries and hard disks on page 432.
Copy or move clips or projects to a different event in the same library
1 In the Libraries list, select the event that contains the clips or projects you want to copy.
2 In the Browser, select the clips or projects you want to copy or move.
Note:  You cannot select clips and projects at the same time.
3 Do one of the following:
••

To copy the items: Option-drag the items from one event to the other by first starting to drag
and then holding down the Option key as you drag.

••

To move the items: Drag the items from one event to the other.

The event to which you copy or move the clips may be re-sorted in the library.

Duplicate projects and clips
Duplicating projects and clips is a fundamental technique in your editing workflow. For example,
you can simply duplicate a project to work on a new version of it.
Duplicating projects containing compound clips or multicam clips may require the Duplicate
as Snapshot command. The Duplicate as Snapshot command allows you to quickly return to
an earlier version of a project, effectively creating a self-contained backup version that includes
referenced compound clips or multicam “parent” clips. Changes you make to other instances of
the compound clips or multicam clips do not affect the versions in the snapshot, so your project
is protected from accidental changes. For more information about compound clips and multicam
clips, see Compound clips overview on page 269 and Multicam editing overview on page 327.
Duplicate projects and clips
1 In the Libraries list, select the event that contains the clips or projects you want to copy.
2 In the Browser, select the clips or projects you want to copy.
Note:  You cannot select clips and projects at the same time.
3 Choose Edit > Duplicate (or press Command-D).
The duplicate items appear in the Browser next to the originals.
Duplicate projects as snapshots
The Duplicate as Snapshot command creates a self-contained copy of a project containing
compound clips or multicam clips. Specifically, duplicating a project as a snapshot makes
copies of the compound or multicam “parent” clips and embeds them in the project so that any
changes to other instances of the clips do not affect the snapshot. For more information, see
Compound clips overview on page 269 and Multicam editing overview on page 327.
1 In the Libraries list, select the event that contains the project you want to duplicate as
a snapshot.
2 In the Browser, select the project you want to copy.
3 Choose Edit > Duplicate Project as Snapshot (or press Shift-Command-D).
The duplicate project appears in the Browser with the word “Snapshot” and the date and time
appended to the project name.

Chapter 5    Organize your library

64

Delete clips, events, and projects
You can delete unwanted clips and projects. You can also delete an entire event from your library
in order to free up storage space. When you delete a clip or a project from an event, or delete
an entire event, Final Cut Pro moves the source media files to the Trash. There is one exception:
media that is being used by other projects in your library always remains in the library.
Note:  Libraries must contain at least one event.
Delete clips or projects from an event, or delete an entire event
1 In the Libraries list, select the event you want to delete or delete items from.
2 Do one of the following:
••

To delete items from the event: Select the clips or projects you want to remove, and choose
File > Move to Trash (or press Command-Delete).
Note:  You cannot select clips and projects at the same time.

••

To delete the entire event: Choose File > Move Event to Trash (or press Command-Delete).

The selected items are deleted. To permanently delete the source media files from your hard disk,
empty the Trash.
WARNING:  After the Trash is emptied, the deleted clips and all of the associated source media
files cannot be restored.

Organize clips
Rate clips as Favorite or Rejected
If your clips contain sections that you don’t like or that you might never want to use in a
project—because they’re blurry, for example—you can mark them as Rejected. You can easily
rate the clips you like and the clips you don’t like as you review them. When you’re ready to
make a project or play your clip for your client, you can focus on your best footage by choosing
to display only those clips you marked as Favorite. You can also delete your rejected clips’ source
media files to free up space on your hard disk.
Favorite
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Rate clips
1 In the Browser, select a range, a clip, or multiple clips you want to rate.
2 Do one of the following:
••

If you like the selection: Press the F key or click the Favorite button in the toolbar.

In the Browser, a green line appears at the top of frames you’ve marked as Favorite.

••

If you don’t like the selection: Press the Delete key or click the Reject button in the toolbar.

A red line appears at the top of frames you’ve marked as Rejected.

Note:  If you chose Hide Rejected from the Filter pop-up menu at the top of the Browser, clips
marked as Rejected disappear from view.
Remove ratings from clips
1 Make sure the clips you want to work with appear in the Browser.
You might need to choose a new option, such as All Clips, from the Filter pop-up menu at the
top-left corner of the Browser so that all the clips you need to access are visible.
Choose All Clips to
show all the clips in
the event regardless
of rating.
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2 In the Browser, select the clips whose rating you want to remove, and press the U key or click the
Clear Rating button in the toolbar.

The green or red line at the top of the clips disappears.
Clips with all
ratings removed

Note:  An orange line along the bottom of an event clip indicates the clip is being used in the current
project (open in the Timeline). To turn this view on or off, choose View > Show Used Media Ranges.

Add keywords to clips
You can apply keywords to your clips to help you quickly locate the clips you need to compose
your movie. After you apply a keyword to a clip or clip range, the clip or range is marked with
a blue line in the Browser. (Clips that have analysis keywords, which are automatically applied
after certain types of analysis, are marked with a purple line. For more information, see Analyzing
media overview on page 50.)
Additionally, when a keyword is applied to a clip or clip range, a Keyword Collection appears in
the Libraries list. A Keyword Collection contains pointers (aliases) to clips tagged with a specific
keyword. For example, if you apply the keyword “Nicholas” to all clips containing Nicholas, you
can then select the Nicholas Keyword Collection in the Libraries list to view all clips containing
the “Nicholas” keyword in the Browser.
Keyword
Collections

A blue line indicates that
a clip has keywords.

You can apply one or more keywords to a range within a clip, a whole clip, or a group of clips in
an event.
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Note:  If you used project folders in the Project Library in previous versions of Final Cut Pro X
and you updated those projects to Final Cut Pro 10.1, the projects have keywords reflecting the
names of the project folders.
Apply keywords using the Keyword Editor
1 In the Browser, select a range or one or more clips to which you want to add keywords.
2 To open the Keyword Editor, click the Keywords button in the toolbar.

3 At the top of the Keyword Editor, type the keyword or keyword phrase you want to apply to the
selection, and press Return.

Type a keyword
or keyword phrase,
and press Return.

4 Repeat step 3 for each keyword or keyword phrase you want added to the selection.
A blue line appears at the top of the selection in the Browser, indicating that keywords have
been applied to it.

5 When you’re finished adding keywords, close the Keyword Editor.
Assign keywords using keyboard shortcuts
To add keyword phrases to your clips using keyboard shortcuts, you must first assign keywords
and keyword phrases to the keyboard shortcuts.
1 If the Keyword Editor isn’t open, click the Keywords button in the toolbar.

2 In the Keyword Editor, click the disclosure triangle to the left of Keyword Shortcuts.
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3 Type a keyword or phrase in each shortcut field, and press Return.
To reassign a keyboard shortcut, select the shortcut text in the field and type the new keyword.

Enter keywords
or a keyword phrase
here to assign them
to keyboard shortcuts.

4 To use a keyboard shortcut, select a range or one or more clips to which you want to add
keywords, and press Control and the corresponding number key (1 through 9).
View keywords applied to clips
mm To quickly identify clips that have keywords: Select an event in the Libraries list.
Clips that have one or more keywords appear in the Browser marked with a blue line at the top.
mm To view all keywords applied to a clip: Choose View > Show Skimmer Info (or press Control-Y), and
skim the clip in the Browser.

You can also view a clip’s keywords by selecting the clip in the Browser and clicking
the Keywords button in the toolbar. The keywords applied to the clip are shown in the
Keyword Editor.

mm To view all the clips that have a specific keyword: Select a Keyword Collection in the Libraries list.
The clips with that keyword appear in the Browser.
Remove all keywords from a selection
1 In the Browser, select a range or one or more clips from which you want to remove keywords.
A blue line at the top of the clips indicates the portions of the clips that have keywords applied.
2 Choose Mark > Remove All Keywords (or press Control-0).
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Remove a subset of keywords from a selection
1 In the Browser, select a range or one or more clips from which you want to remove
specific keywords.
A blue line at the top of the clips indicates the portions of the clips that have keywords applied.
Each keyword assigned to a clip is also shown in list view.
2 Click the Keywords button in the toolbar to open the Keyword Editor, select the keyword or
keywords you want to remove, and press Delete.
Select the keyword
or keywords that you
want to remove from
the selection, and
press Delete.

Add or edit clip and project notes
As you review your clips and projects, you can add and edit notes about them in the Browser
(or, in the case of Timeline clips, in the Timeline Index). You can quickly find these items later by
entering the note text in the search field in the Browser or the Timeline Index, or in the Text field
in the Filter window. For information on text searches, see Find clips and projects in events on
page 72.
Note:  You can add notes to each instance of a clip or project. For example, if you copy clips or
projects between events or libraries, add a clip from the Browser to the Timeline, or copy clips
within the Timeline, each of these clip or project instances (copies) is independent of the others.
Add or edit clip and project notes in the Browser
1 Click the List View button in the bottom-left corner of the Browser.

2 Select the clip or project for which you want to add or edit notes.
Note:  Notes are applied to clips and projects as a whole, not to range selections.
3 Click the Notes field for the clip, and type or edit the notes for that clip.
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Add or edit clip notes in the Timeline Index
1 To open the Timeline Index, click the Timeline Index button in the lower-left corner of the
Final Cut Pro main window (or press Shift-Command-2).

2 To open the Clips pane, click the Clips button at the top of the Timeline Index.
Clips button

3 If the Notes column is not visible in the Clips pane, Control-click a column heading and choose
Notes from the shortcut menu.

4 Click the Notes field for the clip, and type or edit the notes for that clip.

Enter notes
for a clip here.
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Organize clips by roles
You can organize clips by roles, which are metadata text labels assigned to clips.
When you import clips (video, audio, or still images), Final Cut Pro automatically assigns one of
five default roles to the video and audio components of each clip: Video, Titles, Dialogue, Music,
and Effects. You can also create custom roles and subroles and assign them to clips.
You can view and reassign roles in the Browser, the Timeline Index, or the Info inspector. For
example, you could easily identify all your dialogue clips and play them back in isolation from
other audio clips. See View and reassign roles on page 318.

Colored lines marking event clips
Colored lines appear on clips and ranges in the Browser to help you see at a glance if they’re
marked as Favorite or Rejected, have keywords applied, or are being used in the current project.
Color

Description

More information

A green line indicates that you’ve
marked a clip as Favorite.

See Rate clips as Favorite or
Rejected on page 65.

A red line indicates that you’ve
marked a clip as Rejected.

See Rate clips as Favorite or
Rejected on page 65.

A blue line indicates that a clip
has manually applied keywords
or keywords imported with the
media file.

See Add keywords to clips on
page 67.

A purple line indicates that a clip
has one or more analysis keywords.

See View analysis keywords on
clips on page 53.

An orange line along the bottom
of an event clip indicates that the
clip is being used in the project
currently open in the Timeline.

See Adding clips overview on
page 99.
To turn this view on or off, choose
View > Show Used Media Ranges.

Find items using search, keywords, and Smart Collections
Find clips and projects in events
In Final Cut Pro, you can search for media in two ways:
••

Quickly filter clips by marking: Use the Filter pop-up menu in the Browser to quickly locate
individual clips by rating, or the absence of ratings and keywords.

••

Search using a combination of criteria in the Filter window: Use the Filter window to perform
complex searches for clips and projects, also known as weighted searches. You can search
by a wide variety of criteria, including clip or project name, rating, media type, used media,
excessive shake, keywords, the presence of people, format information, date, roles, and item
type (audition, synchronized clip, compound clip, multicam clip, layered graphic, or project).
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Filter clips quickly by rating
Use the Filter pop-up menu in the Browser to quickly find clips by rating.
1 In the Libraries list, select one or more events you want to search.
2 Choose an option from the Filter pop-up menu at the top of the Browser.

••

All Clips: Shows all clips in the event.

••

Hide Rejected: Shows all clips or range selections except those you’ve rated Reject.

••

No Ratings or Keywords: Shows only the clips or range selections without ratings or keywords.

••

Favorites: Shows only the clips or range selections you’ve rated Favorite.

••

Rejected: Shows only the clips or range selections you’ve rated Reject.

Search for clips and projects by a combination of criteria
The Filter window allows you to combine multiple search criteria. For example, you can search for
video clips or projects that contain the text “exterior” or “wide shot” in their metadata.
1 In the Libraries list, select the event or folder you want to search.
2 Click the Filter button

at the top of the Browser.

3 In the Filter window, choose search criteria, or rules, from the Add Rule pop-up menu.
Add Rule pop-up menu

••

Text: Find clips or projects by their name or any notes applied to them in list view. You can add
multiple Text rules to search using more than one word or phrase, as well as exclude specific
words and phrases from the search.

••

Ratings: Find clips based on the rating (Favorite or Reject) assigned to them.

••

Media Type: Find clips whose source media files are of a specific type, such as video, audio, or
still images.

••

Type: Find items matching one of the following types: audition, synchronized clip, compound
clip, multicam clip, layered graphic, or project.
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••

Used Media: Find clips based on whether or not they are used in a project, a compound clip, a
multicam clip, or a synchronized clip.

••

Stabilization: Find video clips that Final Cut Pro has identified as having excessive shake.

••

Keywords: Find clips by any of the keywords that you’ve assigned to them. You can select one
or more keywords to search for.

••

People: Find clips that Final Cut Pro has identified as having people in them. Options include
One Person, Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot.

••

Format Info: Find clips or projects using format information, such as video frame rate or
scene number.

••

Date: Find clips or projects by either the date the item was created or the date the media was
imported into Final Cut Pro.

••

Roles: Find clips by their assigned roles.

To remove a rule, click the Remove button
to the right of the rule. To exclude a rule from your
search without removing it, deselect the checkbox to the left of the rule.
4 Further refine your search by choosing items from the pop-up menus for the rules you’ve added.
5 Do one of the following:
••

To specify that an item must match at least one of the criteria or keywords: Choose Any from the
pop-up menu in the upper-left corner of the Filter window.

••

To specify that an item must match all the criteria and keywords: Choose All from the pop-up
menu in the upper-left corner.

The items that match the search criteria are displayed in the Browser, and icons indicating the
search status appear to the right of the Filter button at the top of the Browser.

If you wish, you can save your search results as a Smart Collection, which gathers items
automatically based on the search criteria.
To clear a weighted search, click the Reset button to the right of the search status icons in the
upper-right corner of the Browser.

Search for clips or projects by name and notes
You can use the search field to quickly find clips or projects by name and any notes applied in
list view without having to open the Filter window.
1 In the Libraries list, select one or more events you want to search.
2 In the search field, enter the clip’s or project’s name or notes applied to the clip or project you’re
looking for.
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Find clips using both searching and filtering
Performing a weighted search and then filtering the results in the Browser by rating is a powerful
way to quickly find clips. This is also the best method of finding specific clips that you haven’t
rated and comparing them against the clips you have rated.
1 In the Libraries list, select the event or folder you want to search.
2 Search for clips using a combination of search criteria, as described in “Search for clips and
projects by a combination of criteria,” above.
However, do not apply a ratings filter using the Filter window.
3 Use the Filter pop-up menu, as described in the “Filter clips quickly by rating” steps above, to
quickly filter the clips by rating.
4 Repeat step 3 until you find the clips you’re looking for.

Save searches as Smart Collections
When you search for clips or projects in an event using the Filter window, you can save your
results by creating a new Smart Collection that gathers items matching the search criteria.
Anytime a new item that matches the Smart Collection’s search criteria is brought into the event,
the new item is automatically added to the Smart Collection.
Clips and projects that appear in Smart Collections are not duplicates. Smart Collections filter
items in an event to help you focus on the items you need to use for a specific task.
Create a Smart Collection based on search criteria
1 In the Libraries list, select an event.
2 Use the Filter window to search for clips or projects based on specified criteria.
3 In the Filter window, click the New Smart Collection button.
A new, untitled Smart Collection appears in the event.
4 Type a name for the Smart Collection, and press Return.
When you add items to the event that match the Smart Collection’s search criteria, they’re
automatically added to the Smart Collection.
Change the contents of a Smart Collection
1 In the Libraries list, double-click the Smart Collection whose contents you want to change.
The Filter window for the Smart Collection appears.

Smart Collection

2 Revise the search criteria in the Filter window.
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3 When you’re finished specifying search criteria, close the Filter window.
Note:  Modifying a clip’s ratings or keywords in such a way that it no longer matches a Smart
Collection’s search criteria results in the clip no longer appearing in the Smart Collection.
Delete a Smart Collection
mm In the Libraries list, select the Smart Collection you want to delete, and choose File > Delete
Smart Collection (or press Command-Delete).
The Smart Collection is removed from the library, but its associated items (the clips and projects
that appeared in it) are unaffected.

Organize Keyword and Smart Collections
You can organize Keyword Collections and Smart Collections in events using folders.
Organize collections with folders
1 In the Libraries list, select the event containing the collections you want to organize, and choose
File > New Folder.
2 Type a name for the new folder that appears within the event and press Return.

3 Select the Smart Collections and Keyword Collections you want to organize, and drag them into
the new folder.
You can show and hide the contents of the folder by clicking the disclosure triangle to the left of
the folder’s name.

Restore a library from automatic backups

By default, Final Cut Pro makes automatic library backups at 15-minute intervals. Backups include
the database portion of libraries only, not the media files. Backups are saved with the time and
date in the filename.
By default, Final Cut Pro saves backups to the Final Cut Pro Backups folder in the Movies folder,
but you can change the backup location using the Library Properties inspector. For more
information, see Manage storage locations on page 434.
Final Cut Pro automatically deletes library backups that are more than several days old.
Restore from a library backup
1 In the Libraries list, select the library

you want to restore.

2 Choose File > Open Library > From Backup.
3 In the “Restore from” pop-up menu, choose a backup from a specific time and date, or click Other
and navigate to a different backup file to open.
The backup is added as a library in the Libraries list.
Note:  The backups are standard Final Cut Pro library files, so you can also open them by doubleclicking them in the Finder. For more information, see Managing libraries overview on page 431.
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Play back and skim media

6

Playback and skimming overview

Final Cut Pro makes it easy to view and listen to your media, whether it’s located in the Browser
or the Timeline. Its dynamic previewing capabilities let you find what you need quickly without
being distracted from the task at hand.
You use two tools to preview and play back media in Final Cut Pro:
••

The playhead marks the current position in the Timeline or the Browser. You can move the
playhead by dragging it or clicking another area of the Timeline or Browser. You use the
playhead to scrub, or play back from its current position.
The playhead appears as a gray vertical line that is fixed in place unless you move it or
click elsewhere.

••

The skimmer lets you preview clips in the Timeline and the Browser without affecting the
playhead position. You use the skimmer to skim, or freely move over clips to play back at the
position and speed of the pointer.
The skimmer appears as a pink vertical line as you move the pointer over the area you’re
skimming. If you have snapping turned on, the skimmer turns orange when it snaps to
a position.
Playhead

Playhead

Skimmer

Skimmer

When skimming is turned on, you can skim to see what’s in other clips, but still keep your
playhead position in the Timeline. If both the playhead and skimmer are present in the same clip,
the skimmer becomes the default position for playback or editing.
When skimming is turned off or the skimmer is not present in a clip, the playhead assumes the
default position.
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Play back media

You can play back projects and clips in Final Cut Pro. Playback options include playing from the
beginning, playing from a certain point, looping playback, and playing at different speeds. You
can also play back video in full-screen view.
To control whether Final Cut Pro displays optimized, proxy, or original media in the Viewer, and
whether video playback is optimized for quality or performance, choose the corresponding
options from the Viewer Options pop-up menu in the upper-right corner of the Viewer. For more
information, see Control playback quality and performance on page 85.
Play back video and audio clips
mm To play a project or clip from the beginning: Select the project or clip and choose
View > Playback > Play from Beginning (or press Control-Shift-I).
mm To play a section of a project, selected clips, or a frame range from the beginning: Select the project,
clips, or all or part of a clip, and choose View > Playback > Play Selection, or press the Slash (/) key.
When you select a clip or a portion of a clip or project, the selected area is marked with a
yellow border.
Yellow border

mm To play a project or clip from a specific point: In the Browser or the Timeline, click a point in a
project or within a clip where you want to begin (or move the playhead to the point in the
Timeline), and either press the Space bar or click the Play button in the Viewer (or press L).

The clip or project begins
playing at the skimmer
or playhead position.

mm To play around the playhead or skimmer: Choose View > Playback > Play Around, or press ShiftQuestion Mark (?).
Skimmer

mm To stop playback: Press the Space bar.
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Use the J, K, and L keys for playback
You can use the J, K, and L keys on your keyboard to play through a project or clip. Playback
begins at the location of the playhead (on a project) or the skimmer (on a clip). You can also use
the J, K, and L keys to control a video playback device.

Moves through
reverse speeds

Pause

Moves through
forward speeds

You can use these keys to speed playback up to 32x normal speed.
mm To begin forward playback at normal (1x) speed: Press L.
mm To begin reverse playback at normal (1x) speed: Press J.
mm To pause playback: Press K.
mm To double the current playback speed: Press L or J twice.
mm To immediately reverse the playback direction: Press J to play in reverse, or press L to play forward.
mm To move the playhead one frame at a time: Hold down the K key, and press J or L.
mm To move the playhead at 1/2x speed: Hold down the K key while holding down J or L.
When you use keyboard shortcuts to control a device (like a camcorder or camera), the speed of
forward (L) and reverse (J) playback may differ depending on your video equipment.
Play back media in a loop
You can turn on looping so that a project or a clip (or any portion of either) plays in a
continuous loop.
1 To enable looping, choose View > Playback > Loop Playback (or press Command-L).
2 Do any of the following:
••

To loop your entire project: Click the Timeline to make it active and press the Space bar.

••

To loop a clip in the Browser: Select the clip and press the Space bar.

••

To loop a portion of a clip or project: Select a range in the Browser clip or the Timeline, or select
a Timeline clip, and choose View > Playback > Selection, or press the Slash (/) key.
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Play video in full-screen view
1 Open a project in the Timeline or select a clip in the Browser, and position the playhead where
you want the video to begin.
2 Do one of the following:
••

Choose View > Playback > Play Full Screen (or press Shift-Command-F).

••

Click the Play Full Screen button

below the Viewer.

The item plays in full-screen view starting at the playhead position.
Tip:  You can use all the playback shortcut keys during full-screen playback, including J-K-L and
others. For a full list of the available shortcuts, see Playback/Navigation on page 467.
3 To leave full-screen view, press the Esc (Escape) key.
When you play back clips, the frames under the playhead or skimmer play in the Viewer. If
you need to compare two clips at once, you can use the Event Viewer, a separate viewer for
playing back event clips only. The Event Viewer appears to the left of the main Viewer. For more
information, see Play back and skim media in the Event Viewer on page 82.

Skim media

You can quickly skim your video and audio to preview it, search for a particular shot, or make an
edit. When skimming is turned on and you move the pointer forward or backward over a clip in
the Browser or the Timeline, the content under the pointer plays in the Viewer.
You can also use the Blade, Trim, and Range Selection editing tools to skim clips in the Timeline
or in the Precision Editor.
As you’re editing in Final Cut Pro, you may find skimming distracting when you move the pointer
from one location to another. You can disable all skimming (or just audio skimming).
Skim clips
mm Move the pointer forward or backward over a clip in the Browser or the Timeline.
The skimmer (a vertical pink line) indicates exactly where the pointer is as you skim, and the
corresponding frames are displayed in the Viewer.
Skimmer

Tip:  You can also press the Space bar at any time to play forward from the skimmer position.
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Skim clips with editing tools
You can skim clips when you use the Blade, Trim, and Range Selection tools in the Timeline or in
the Precision Editor. The tools behave as skimmers as you move the pointer over a clip.
1 Select a clip in the Timeline or open the Precision Editor.
2 Select either the Blade, Trim, or Range Selection tool from the Tools pop-up menu in the toolbar.

3 Move the tool forward or backward over a clip.
When using an editing tool as a skimmer, you can skim and add markers to clips under
connected clips in the Timeline.

Turn skimming on and off
mm To turn all skimming on or off: Click the Skimming button, choose View > Skimming, or press S.
mm To turn audio skimming on or off: Click the Audio Skimming button, choose View > Audio
Skimming, or press Shift-S.
When skimming is turned on, the skimming buttons appear blue.

Audio skimming is turned off.
Skimming is turned on.

Note:  When skimming is turned off, you can still skim with the Blade, Trim, and Range Selection
editing tools.
Skim audio for individual clips or audio components
You can turn on clip skimming to limit audio skimming to an individual clip. This is useful if you
have a connected clip in the Timeline and want to skim it without also hearing audio from the
clip in the primary storyline.
Important:  Audio skimming must also be turned on in order to use this feature.
You can also use clip skimming to skim and listen to an individual audio component when
editing clips that show expanded audio components. If clip skimming is turned off, you hear
combined audio for all components in the clip as you skim.
Tip:  To view expanded audio components, select the clip in the Timeline and choose Clip >
Expand Audio Components (or press Control-Option-S).
mm To turn clip skimming on or off, choose View > Clip Skimming (or press Option-Command-S).
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Play back and skim media in the Event Viewer

Sometimes, you may need two viewers so that you can play back and skim event clips separately
from Timeline clips. The Event Viewer is a separate video display that appears next to the main
Viewer. With the Event Viewer and the Viewer open, you can display two clips at the same time:
one in the Browser and one in the Timeline.
Event Viewer

Viewer

You use the Event Viewer to play clips in the Browser only. As with the main Viewer, you can
show video scopes, color channels, title and action safe zones, and multicam angles (with the
Event Viewer set to show angles). Playback and adjustment controls are identical in the Viewer
and the Event Viewer. Other viewer-related operations (including onscreen controls and built-in
effects) are done with the main Viewer.
The dual-viewer interface is derived from linear tape-based systems, which included both source
and record monitors. The source monitor was for previewing source clips and making selections
in them. The record monitor was for playing back the edited program.
Open the Event Viewer
mm Choose Window > Show Event Viewer (or press Control-Command-3).
To close the Event Viewer, choose Window > Hide Event Viewer (or press Control-Command-3).
Note:  If you’re using video scopes with the Event Viewer, you may find it convenient to display
the scopes below the video image rather than on the left side (the default). To display scopes
below the video image, choose Vertical Layout from the Settings pop-up menu in the Event
Viewer. For more information, see Use the video scopes on page 392.

View playback on a second display

If you have a second display connected to your computer, you can show the Viewer on the
second display to play video, or the Browser on the second display to view clips in an event,
thereby expanding your workspace in the Final Cut Pro main window.
Show the Viewer on a second display
1 Connect a second display (a second computer monitor connected to the PCI video card), and
make sure it is connected to power and turned on.
2 In Final Cut Pro, choose Window > Show Viewers on Second Display.
The Viewer appears on the second display. All Viewer features (including onscreen controls) are
now available on the second display.
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Note:  If the Event Viewer is also visible, both viewers appear on the second display.

3 To return the Viewer to the Final Cut Pro main window, choose Window > Show Viewers in the
Main Window.
Show the Libraries list and the Browser on a second display
1 Connect a second display (a second computer monitor connected to the PCI video card), and
make sure it is connected to power and turned on.
2 In Final Cut Pro, choose Window > Show Events on Second Display.
The Libraries list and the Browser appear on the second display. All event features (including
selection capabilities, markers, keywords, and so on) are now available on the second display.

To return the Libraries list and Browser to the Final Cut Pro main window, choose Window >
Show Events in the Main Window.

View playback on an external video monitor

Final Cut Pro includes an A/V Output option to send video and audio from your computer to
an external video monitor. The A/V Output feature shows you how video and audio look and
sound on an NTSC/PAL, HD, or 4K monitor. In addition, this feature allows you to test output with
sophisticated external devices such as vectorscopes and waveform monitors.
NTSC or PAL output requires compatible third-party video interface hardware and software.
4K output requires a third-party video interface or a 4K-capable Mac with an HDMI output.
FireWire DV devices are not supported. For more information about third-party devices and
software, contact the device manufacturer or go to the Final Cut Pro X Resources webpage at
http://www.apple.com/finalcutpro/resources.
View playback on an external monitor using a third-party video interface
1 Install the video interface hardware and software according to the manufacturer’s instructions.
2 Connect an external video monitor to the video interface, and make sure the monitor and all
other external devices are connected to power and turned on.
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3 To select an A/V output device, choose Final Cut Pro > Preferences (or press Command-Comma),
click Playback, and choose the external monitor from the A/V Output pop-up menu.
4 In Final Cut Pro, choose Window > A/V Output.
The Viewer contents appear on the broadcast monitor. Viewer features (such as onscreen
controls and the title-safe and action-safe overlays) can be viewed only in Final Cut Pro.
Note:  Video and audio are synced at the video frame (not audio sample) level.

To turn off A/V output, choose Window > A/V Output.
View playback on an external monitor using HDMI
If you’re using Final Cut Pro 10.1 or later on a 4K-capable Mac with an HDMI port, you can play 4K
or HD 1080 video on an external video monitor connected to the HDMI port.
For a list of compatible Mac computers, go to http://support.apple.com/kb/HT6057.
1 Use an HDMI cable to connect the external (HDMI) video monitor to the HDMI port on your Mac,
and make sure the monitor is connected to power and turned on.
2 To configure the HDMI monitor, choose Apple menu > System Preferences, and click Displays.
3 In Displays preferences, set the HDMI monitor to be a secondary display.
4 Select Scaled, and in the list that appears, select 4096 x 2160, 3840 x 2160, 1080i, or 1080p.
Note:  You may need to press the Option key while you click Scaled to see additional resolutions
for the HDMI monitor.
5 To select the monitor in Final Cut Pro, choose Final Cut Pro > Preferences (or press CommandComma), click Playback, and choose the HDMI monitor from the A/V Output pop-up menu.
6 In Final Cut Pro, choose Window > A/V Output.
The Viewer contents appear on the HDMI monitor. Viewer features (such as onscreen controls
and the title-safe and action-safe overlays) can be viewed only in Final Cut Pro.
Note:  Video and audio are synced at the video frame (not audio sample) level.

To turn off A/V output, choose Window > A/V Output.
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Control playback quality and performance

There are two settings that affect visual quality and playback performance in the Viewer: the
Quality setting and the Media setting. Both are found in the Viewer Options pop-up menu in the
upper-right corner of the Viewer.
Set playback quality
In the Quality section of the Viewer Options pop-up menu, choose one of the following:
mm Better Quality: Choose this option to display full-resolution video frames in the Viewer. This
setting may decrease playback performance for high-quality, large-frame-size video.
mm Better Performance: Choose this option to display video in the Viewer at reduced resolution.
Decreasing the size of the media maintains playback performance even for very large media files.
Choose the type of playback media
In the Media section of the Viewer Options pop-up menu, choose one of the following:
mm Optimized/Original: Choose this option to use the optimized media (in the Apple ProRes 422 format)
for playback. If optimized media is not available, Final Cut Pro uses the original media for playback.
mm Proxy: Choose this option to use medium-quality proxy media (converted to one-half resolution)
rather than full-resolution media for playback. Choosing this option increases playback
performance but lowers the video quality. In Final Cut Pro, proxy media is in the Apple ProRes
422 Proxy format.
You can use the Info inspector to determine whether optimized or proxy media files exist for a
given clip. For more information, see View a clip’s information on page 420. If you choose Proxy
in the Viewer Options pop-up menu and no proxy media file exists, a Missing Proxy File alert icon
appears in the Viewer.
Important:  If you use proxy media for playback, make sure to switch back to optimized/original
media before sharing your project. This ensures the highest quality in the exported file. For more
information, see Share projects, clips, and ranges on page 400.
For more information about optimized and proxy media, see Manage optimized and proxy
media files on page 425.

Chapter 6    Play back and skim media

85

About background rendering

Rendering is the process of creating temporary video and audio render files for segments of your
project that Final Cut Pro cannot play in real time. When you add effects, transitions, generators,
titles, and other items that require rendering for playback at high quality, the render indicator (an
orange bar) appears below the ruler at the top of the Timeline.
Render indicator

By default, rendering begins in the background 5 seconds after you stop working and
moving the pointer in Final Cut Pro. Background rendering continues while you work in
a different application. You can turn off background rendering or adjust this setting in
Final Cut Pro preferences.
You can also manually control rendering for a project or a portion of a project, and you can
delete render files for one or more projects, events, or libraries to free up storage space. For more
information, see Manage render files on page 429.
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7

Edit your project

Editing overview

The term video editing refers both to broader stages of a project workflow and to very specific
manual tasks that you do with clips in a project Timeline.
••

Create a project: To create a movie in Final Cut Pro, you first create a project, which provides a
record of your editing decisions and the media you use. See Create a new project on page 88.

••

Make selections and add clips to the Timeline: Adding and arranging clips in your project is the
fundamental step in creating a movie with Final Cut Pro. You move and reorder clips in the
Timeline. See Adding clips overview on page 99, Arrange clips in the Timeline on page 117, and
Audio overview on page 156.

••

Cut and trim clips: Final Cut Pro provides a wide variety of tools for adjusting the start and
end points of clips in the Timeline and for controlling pacing from one shot to the next. See
Trimming overview on page 122.

••

Further refine and adjust your project: Final Cut Pro provides many advanced editing tools to
finish a highly polished movie with ease. See topics in the advanced editing section.

••

Add effects and color correction: Finishing touches include visual effects and color correction.
See Transitions, titles, effects, and generators overview on page 210 and Color correction
overview on page 376.
Toolbar: Perform
common tasks by
clicking a button.

Primary storyline: Add and
arrange clips to construct
your movie.

		

Connected clips: Add titles and
cutaway shots. In the Magnetic
Timeline, everything stays in sync.

Audio clips: Add music
and sound effects as
connected clips.
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Create and manage projects
Create a new project
To create a movie in Final Cut Pro, you first create a project, which provides a record of your
editing decisions and the media you use. Then you add clips to the Timeline and edit them.
When you create a new Final Cut Pro project, you do the following:
••

Name the project.

••

Specify the event where the project is stored.
Often, you store projects in events that contain the media used to create the project. When
you drag media from the Finder or a Final Cut Pro media browser to the Timeline, that media
is automatically located in the same event as the project.

Optionally, you can also set the starting timecode and define the video, audio, and render
properties for the project.
After creating your project, you add clips to it from an event in the library.
Note:  If you’re creating a project and you haven’t yet imported media into Final Cut Pro, you
should do so. For more information, see Importing overview on page 23.
Start a project
1 If you don’t see the Libraries list, click the button at the bottom-left corner of the Browser.

2 In the Libraries list, select the event where you want to create the project.
3 Choose File > New Project (or press Command-N).
4 In the window that appears, type a name for the project in the Name field.
5 If you want to store the project in an event other than the selected event, choose a different
event from the In Event pop-up menu.
If you drag any media files from the Finder directly to the project in the Timeline, or add media
to the project from one of the media browsers, that media is automatically stored in the same
event with the project.
6 If you want to further customize settings for your project, click Use Custom Settings.
Note:  Final Cut Pro shows the Automatic Settings by default, but it retains the settings you used
last, so this step may be unnecessary.
7 If you want your project’s timecode to start at a value other than 00:00:00:00, type a starting
timecode value in the Starting Timecode field.
8 If you want to make any changes to the project’s video or audio properties, select Custom and
use the pop-up menus.
Unless you have a specific requirement for the project you’re creating, it’s best to leave “Set
automatically based on first video clip” selected. For information about project settings, see
Modify a project’s settings on page 89.
9 Click OK.
The new project appears in the Browser with the name you gave it in step 4.

Chapter 7    Edit your project

88

You can now add clips from the Browser and begin to edit your project in other ways, adding
titles, special effects, background music, sound effects, and more.
You can change a project’s properties at any time. For more information, see Modify a project’s
settings on page 89.

Open an existing project
You can open an existing project at any time.
Open a project
1 If you don’t see the Libraries list, click the button at the bottom-left corner of the Browser.

2 In the Libraries list, select the event containing the project you want to open.
3 Locate the project you want to open and double-click it.
Note:  You may have to scroll up to the top of the event to see the project.

Modify a project’s settings
As your project evolves, you may decide you want to change its settings.
In most cases, Final Cut Pro manages project settings automatically based on the properties of
the first clip you add to a project, but you can change almost all settings of an existing project.
If you must modify the project settings, choose video and audio project settings based on how
you intend to share your final movie with your audience.
Change a project’s settings
1 In the Libraries list, select the event that contains the project you want to modify, and select the
project (or double-click it to open it in the Timeline).
2 Do one of the following:
••

Choose Window > Project Properties (or press Command-J).

••

Click the Inspector button in the toolbar.

3 Click the Info button at the top of the pane that appears.
Info button

4 Click the Modify Settings button.
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5 In the window that appears, change the settings as appropriate.

Change the project’s
video, audio, and
render properties.

Project Name
••

Project Name: Type a name for the project.

Starting Timecode
••

Starting Timecode: If you want your project’s timecode to start at a value other than
00:00:00:00, type a starting timecode value.

Drop Frame Timecode
••

Drop Frame: Select the checkbox to turn on drop frame timecode (this option appears only for
29.97 and 59.94 fps media).
In non-drop frame timecode, the timecode counter counts at a consistent rate without
dropping any numbers from the count. Non-drop frame timecode is available as a display
option for every frame rate.
In drop frame timecode, frames 0 and 1 are skipped the first second of every minute, unless
the minute number is exactly divisible by 10.

Video Properties
••

Format: Choose the video format (a specific method of encoding the video).

••

Resolution: Choose the frame size of the video. Available frame sizes are dependent on the
format. To enter an arbitrary frame size, choose Custom in the Format pop-up menu.

••

Rate: Choose the frames per second (fps).
Note:  Unless the Timeline is completely empty, you cannot change the frame rate of an
existing project.

Audio and Render Properties
••

Audio Channels: Choose whether to present the audio as multichannel surround sound or
as stereo.

••

Audio Sample Rate: Choose the audio sample rate for your project (the number of times a
signal is measured—or sampled—per second). A higher sample rate produces higher-quality
audio and larger file sizes, and a lower sample rate produces lower-quality audio and smaller
file sizes. The sample rate you choose depends on the source material you’re working with and
the final destination of your audio.

••

Render Format: Choose the codec to use for your project’s background rendering.

6 Click OK.
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Save, back up, and make versions of your projects
Final Cut Pro automatically saves all the changes you make as you work on a project, which
means you never have to save changes manually. Also, you can undo all of your changes up
to the last time you quit and reopened Final Cut Pro by choosing Edit > Undo (or pressing
Command-Z).
You can create multiple versions of a project by duplicating it. For more information, see
Duplicate projects and clips on page 64.
Changes you make to a clip in a project do not affect the clip’s source file. Thus, if you’ve made a
lot of changes to a clip but want to start fresh, you can easily restore the clip to its original state
by adding a new copy of the clip (located in an event in the library) to your project.
In addition, Final Cut Pro makes automatic backups of your library at 15-minute intervals. Backups
include the database portion of libraries only, not the media files. Backups are saved with the
time and date in the filename. For more information, see Restore a library from automatic
backups on page 76.

Select clips and ranges
About selections and filmstrips
A fundamental step in editing a video project is choosing what you want to include in your final
movie. In Final Cut Pro you indicate what clips or portions of clips you want to act on by making
a selection. Final Cut Pro provides a variety of powerful tools for making selections with both
speed and precision, including filmstrips, which are connected series of thumbnail images. Your
video clips appear as filmstrips in the Timeline (where you build projects) and in the Browser
(where your source media is displayed). A single video filmstrip might represent several seconds
of video encompassing hundreds of video frames (individual images). Audio-only clips appear as
audio waveforms, showing the change in the audio volume over time.
When you add clips from the Browser to a project in the Timeline, you can add one or more
whole clips, or you can add a range within a clip. Then you can fine-tune the clips individually in
the Timeline, adding video effects to them, for example, or inserting transitions between them.
You can adjust the appearance of filmstrips in the Browser and the Timeline so that it’s easier to
make selections. For example, expanding the width of a filmstrip (by showing shorter durations
per thumbnail) helps you make more precise selections.

Filmstrip expanded
in the Browser for
precise selections
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You can also adjust the filmstrip appearance in the Timeline to make it easier to view and select
audio waveforms.

Filmstrip appearance
changed for easy
viewing and selection
of audio waveforms

Select one or more clips
Clips represent your video, audio, and graphics files and allow you to work with your media in
Final Cut Pro without changing the files themselves. To add clips to your project, rearrange them,
or trim them, you first need to select them. You can select a single clip or multiple clips at a time.

Selecting multiple clips allows you to move them as a group within your project, or from one
event to another. It’s also useful if you’ve made adjustments to a clip and you want to paste the
same adjustments onto several other clips.
Select an entire clip
Do one of the following:
mm Click the clip once.
mm Move the skimmer (or the playhead) over a clip and press X.
Note:  This results in a range selection that matches the boundaries of the clip.
mm In the Browser, press Up Arrow or Down Arrow to move the selection to a neighboring clip.
mm In the Browser, Option-drag from the start point to the end point of the clip.
mm In the Timeline, move the skimmer (or the playhead if skimming is turned off) over the clip you
want to select and press C. This method selects the clip in the primary storyline.
Connected clips and storylines are attached to clips in the primary storyline, and they appear
above and below the primary storyline. To select a connected clip or storyline with this keyboard
shortcut method, position the pointer on the connected clip and press C. For more information,
see Connect clips to add cutaway shots, titles, and synchronized sound effects on page 103 and
Add storylines on page 277.
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A yellow border appears around the clip, indicating that it is selected.

Note:  A Timeline clip selection (shown above) is different from a Timeline range selection,
which has visibly distinct range handles for adjusting the selection start point and end point. All
selections in the Browser are actually range selections (with adjustable start and end points).
Select multiple clips in the Browser or the Timeline
mm To select a number of individual clips: Hold down the Command key as you click the clips you want
to select.
Note:  Command-clicking a Browser clip with preexisting ranges selects the ranges rather than
the whole clip.
mm To select all clips and ranges in the Browser or the Timeline: Click the Browser or Timeline to make it
active, and choose Edit > Select All (or press Command-A).
mm To select multiple clips by dragging: Drag a selection rectangle over the Timeline or event clips you
want to select.

Deselect clips in the Browser or the Timeline
mm To deselect a single selected clip: Command-click the clip or click outside it (or select a different clip).
mm To deselect multiple selected clips: Hold down the Command key and click the clips you don’t
want selected.
mm To deselect all clips and ranges: Choose Edit > Select > None (or press Shift-Command-A).
mm To deselect all clips and clear all selected ranges in the Browser: Press Option-X.
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Select a range
Instead of selecting whole clips, you can select a range within any clip in the Timeline or the
Browser. In the Timeline, you can also select a range that spans multiple clips. You can trim range
selections, mark them with ratings and keywords, and modify them in other ways. You can adjust
the range selection start and end points by dragging either side of the selection. You can also
create multiple range selections in one or more clips in the Browser.

Range handles

Note:  This illustration shows a Timeline range selection. Browser range selections have straight
range handles.
Select a range
Do one of the following:
mm In the Browser, drag across any clip (filmstrip).
A yellow border appears around the range you selected.
If the filmstrip wraps onto two lines, you can select a range extending over the break simply
by continuing to drag across the break. When you reach the edge, the pointer jumps to the
next line.
Tip:  In the Browser, Option-drag across any clip (filmstrip) with existing ranges to replace those
ranges with a new range.
mm In the Timeline, choose Range Selection from the Tools pop-up menu in the toolbar (or press R).

The pointer changes to the Range Selection tool

.

Drag the Range Selection tool across one or more clips in the Timeline to select a range.
To adjust the range selection start and end points, drag the range handles on either side of
the range.
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Tip:  To temporarily turn on the Range Selection tool, hold down the R key. When you release the
R key, the tool reverts to the previously active tool.

Range handles

mm Use the I and O keys to set the range selection start and end points. For more information, see
the instructions below.
mm In the Browser or the Timeline, move the skimmer (or the playhead) over a clip and press X.
Final Cut Pro sets the range selection start and end points at the clip start and end points.
Tip:  To use this X key method with connected clips or clips in a connected storyline, position the
pointer on the clip and press X.
mm Command-click a colored marker line at the top of a clip.
These marker lines can indicate any of the following: Favorite (green), Rejected (red), manually
applied keywords (blue), or analysis keywords (purple).
Set a range start point or end point
mm To set the start point: Position the skimmer (or the playhead, if skimming is turned off) where you
want the selection to start, and choose Mark > Set Range Start (or press I).
To remove the range start point, press Option-I.
mm To set the end point: Position the skimmer (or the playhead, if skimming is turned off) where you
want the range to end, and choose Mark > Set Range End (or press O).
To remove the range end point, press Option-O.
mm To set the range start point or end point while a clip or your project is playing back: Press the Space
bar to start playback, and then press the I or O key when you want to set the start or end point.
Tip:  In the Browser, you can press Shift-Command-I and Shift-Command-O to set multiple ranges
during playback.
If you’re using the Blade, Trim, and Range Selection tools in the Timeline or in the Precision Editor,
you can use the I and O keys to set selection start and end points in a connected clip or storyline,
as well as in clips underneath connected clips and storylines. Move the pointer directly over a clip
and press I to set a selection start point or O to set a selection end point.
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Extend or shorten the range selection
mm To adjust where the range starts or ends: Drag the left or right edge of the yellow selection border.
mm To reset the start point or end point for a range within the same event clip or project: Move the
skimmer and press I or O.
Tip:  You can also press the I or O key while a clip is playing back.
mm To extend or shorten a range within an event clip: Move the skimmer to any frame that you want
the range to begin or end with, and then hold down the Shift key and click (or drag).
mm To extend or shorten a range using timecode: Choose Modify > Change Duration (or press
Control-D), and enter a new duration. (This method works with single range selections only.)
The range selection is lengthened or shortened accordingly.
If you require the skimmer and it is not present, you can turn on skimming at any time.
Set multiple ranges in event clips during playback
You can set multiple ranges in clips in the Browser during playback.
1 Play back an event clip.
2 While the clip is playing, do any of the following:
••

To add a range start point: Press Shift-Command-I.

••

To add a range end point: Press Shift-Command-O.

Note:  To set multiple ranges in the same clip, repeat these keyboard shortcuts while
continuing playback.
Set the range selection to match the boundaries of the clip
mm Move the skimmer (or the playhead) over a clip and press X.
Final Cut Pro sets a range selection from the start point to the end point of the clip. Any
preexisting ranges are removed.
Clear ranges
You can remove one or more ranges from the Browser or the Timeline.
Note:  This operation does not affect the clip media in either the Browser or the Timeline.
mm To remove an individual range in an event: Option-click the range.
mm To remove a range in the Timeline: Click outside of the range or select a different range.
mm To clear one or more ranges in the Browser or the Timeline: Select the range or ranges and choose
Mark > Clear Selected Ranges (or press Option-X).
Note:  Selected ranges have a thick yellow border. Unselected ranges (available only in the
Browser) have a thin orange border.
mm To remove all ranges in an event: Choose Edit > Select All (or press Command-A) to select all
ranges in the current event, and choose Mark > Clear Selected Ranges (or press Option-X).
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Manage multiple range selections in event clips
In the Browser, you can set multiple ranges within one or more clips, and you can select and
deselect ranges after you set them. For example, you might set multiple ranges in a long event
clip, and then deselect some of the ranges before adding all of the selected ranges to the
Timeline at once.
Note:  Selected ranges have a thick yellow border. Unselected ranges have a thin orange border.
Editing commands operate on yellow selections only.
Selected ranges

Unselected ranges

Note:  The commands described in this section require the Browser to be the active portion of
the Final Cut Pro interface. You can make the Browser active by moving the pointer over it or
clicking it. When the Browser is active, its background has a lighter gray color.
Set multiple ranges in an event clip
1 In the Browser, select a range within a clip.

2 To set an additional range, do one of the following:
••

Command-drag in a different section of the clip.

••

Move the skimmer (or the playhead) to the frame where you want the additional range to
start and press Shift-Command-I. Move the skimmer or playhead to the frame where you want
the additional range to end and press Shift-Command-O.
Note:  These keyboard shortcuts also work during playback, so you can set additional ranges
on the fly.

••

Option-drag over or within existing ranges to replace them with a new range.

••

Command-click a colored marker line at the top of a clip.
These marker lines can indicate any of the following: Favorite (green), Rejected (red), manually
applied keywords (blue), or analysis keywords (purple).
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The additional range selection appears in the clip.

To remove a range selection, Option-click it.
Select and deselect ranges and clips in an event
You can set, select, or deselect multiple ranges within event clips or within events.
Important:  Editing commands operate on yellow selections only. Editing commands ignore
orange (unselected) ranges.
Selected ranges

Unselected ranges

mm To select an individual range: Click the range.
mm To select or deselect a range: Command-click the range.
mm To select all ranges in a clip: Click an area of the clip that has no range.
mm To select all ranges and clips in the current event: Choose Edit > Select All (or press Command-A).
The ranges (and all clips with no ranges) are selected with a yellow border.
mm To deselect all ranges and clips in the current event: Choose Edit > Deselect All (or press
Shift-Command-A).
The ranges turn orange.
Remove ranges from clips in an event
You can remove individual ranges, multiple ranges, or all ranges from the current event.
mm To remove an individual range in an event: Option-click the range.
mm To remove selected ranges in an event: Select the ranges you want to remove, and choose Mark >
Clear Selected Ranges (or press Option-X).
mm To remove all ranges in an event: Choose Edit > Select All (or press Command-A) to select all
ranges in the current event, and choose Mark > Clear Selected Ranges (or press Option-X).
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Navigate between selections in an event
mm To go to the start of the range selection: Choose Mark > Go to > Range Start (or press Shift-I).
Repeat this command to go to the start of the previous range selection, or to the start of the clip.
mm To go to the end of the range selection: Choose Mark > Go to > Range End (or press Shift-O).
Repeat this command to go to the end of the next range selection, or to the end of the clip.
mm To select the previous clip (or its ranges): Press Up Arrow.
To add to the selection, press Shift–Up Arrow.
mm To select the next clip (or its ranges): Press Down Arrow.
To add to the selection, press Shift–Down Arrow.

Add and remove clips
Adding clips overview
You build a movie project by adding clips to the Timeline in a chronological arrangement. To suit
your particular editing style or need, you can choose from a wide variety of tools and techniques
for adding clips. You can change the arrangement of the clips in the Timeline at any time.
In Final Cut Pro, you can edit your projects without worrying about maintaining clip connection
or synchronization. For example, when you drag a clip into the Timeline, Final Cut Pro
automatically rearranges the Timeline to fit each new clip without disturbing your existing work.
This is true for all kinds of clips: video, audio, titles, generators, still images, and so on.
You can use clips from multiple events in a single project. You can also add clips from the
Final Cut Pro media browsers and from the Finder. Deleting clips from the Timeline does not
affect clips or files in the Browser, the media browsers, or the Finder.
Connected clips and storylines remain attached to, and synchronized with, clips in the primary
storyline until you explicitly move or remove them.
Connected clip

Primary storyline
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In the Browser, an orange line along the bottom of an event clip indicates the clip is being used
in the current project (open in the Timeline). To turn this view on or off, choose View > Show
Used Media Ranges.
An orange line along the bottom
of an event clip indicates it is being
used in the current project.

Drag clips to the Timeline
You can add clips to the Timeline by dragging them from the Browser, from a Final Cut Pro media
browser (such as the Photos Browser or the Generators Browser), or from the Finder.
Drag clips from the Browser or a media browser
1 Do one of the following:
••

In the Libraries list, select an event containing the clips you want to add to your project.

••

Open the media browser containing the media you want to add to your project.

2 Drag one or more clips to the Timeline from the Browser or a media browser.
Depending on where you drag the clips in the Timeline, your actions may result in an append, an
insert, a connect, or a replace edit. Final Cut Pro automatically adjusts surrounding clips to fit in
place around any clips you’ve dragged.
Tip:  You can add one clip to your project at a time, or sometimes it’s easier to add a number of
clips to the project at once, and then rearrange them in the Timeline.
Drag files from the Finder
1 Arrange the windows onscreen so that you can see both the Final Cut Pro main window and the
files in the Finder.
2 Drag the files from the Finder to the Timeline.
Depending on where you drag the clips in the Timeline, your actions may result in an append, an
insert, a connect, or a replace edit.
Note:  If you add clips to the Timeline from a Final Cut Pro media browser or the Finder, you are
effectively importing the media into the event that contains the current project. In this scenario,
Final Cut Pro applies the default optimization and analysis settings to the new clips. You can set
default optimization and analysis processes in Final Cut Pro preferences.
If you add still images to the Timeline, they will have a duration of 4 seconds by default. You can
change this default duration in Final Cut Pro preferences.
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Append clips to your project
A simple way to add a clip to your project is an append edit, in which you add one or more clips
to the end of a project or storyline.
Append clips to your project in the Timeline
1 Select one or more clips in the Browser.
2 To add the clips to the Timeline, do one of the following:
••

Choose Edit > Append to Storyline (or press E).

••

Click the Append button in the toolbar.

If there is no selection, the clip appears at the end of the primary storyline in the Timeline. If a
storyline is selected, the clip appears at the end of the selected storyline.

Insert clips in your project
An insert edit places the source clip so that all clips after the insertion point are moved forward
(or rippled) in the Timeline to make room for the clip being added. No clips are removed from
your project. An insert edit makes the project longer by the duration of the inserted clip.

D

A

B

C

Before edit
A

D

B

C

After edit

You might use insert edits when you want to add a new shot in the beginning or the middle of
your project. You can also use an insert edit to interrupt the action in an existing clip with the
action in the newly inserted clip. The action in the original clip then resumes after the inserted clip.
Note:  You can use three-point editing to make insert edits. For more information, see Three-point
editing overview on page 287.
Insert Browser clips in the Timeline
1 Select one or more clips in the Browser.
2 Move the playhead to the point in the primary storyline or a selected storyline (or make a range
selection) where you want to insert the clip.
3 Do one of the following:
••

Choose Edit > Insert (or press W).
Note:  If you use the keyboard shortcut and the skimmer is present in the Timeline, the edit
will occur at the skimmer position.

••

Click the Insert button in the toolbar.
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The clip appears in the Timeline and all clips after the insertion point are rippled forward. If the
skimmer is not present, the clips are inserted at the playhead position. If you perform an insert
edit in the middle of an existing Timeline clip, that clip is cut at the insertion point, and the
second half is moved to the end of the newly inserted clip, along with the rest of the footage to
the right of the insertion point.
Insert a gap clip or a placeholder clip in the Timeline
Sometimes you need to reserve space in the Timeline for a clip that you don’t yet have.
Final Cut Pro provides two possible solutions to this problem: placeholder imagery or a blank
and silent clip called a gap clip that can be adjusted to any duration.
1 Move the playhead to the point in the primary storyline or a selected storyline (or make a range
selection) where you want to insert the gap clip or placeholder clip.
2 Do any of the following:
••

To insert a placeholder clip: Choose Edit > Insert Generator > Placeholder (or press
Option-Command-W).
Final Cut Pro inserts gray placeholder imagery that you can customize. For more information,
see Use a placeholder on page 249. You can adjust placeholder clips to any duration.
Placeholder clip

••

To insert a gap clip: Choose Edit > Insert Generator > Gap (or press Option-W).
Final Cut Pro inserts a blank clip (containing blank video and silent audio) that you can adjust
to any duration. (The film industry term for this is slug.)
Gap clip

Note:  Gap clip color is determined by the current background color in Final Cut Pro. To
adjust the background color, choose a Player Background option in the Playback pane
of the Final Cut Pro Preferences window. If you want a different color, consider using a
solid generator.
The clip appears in the Timeline, and all clips after the insertion point are rippled forward (to
the right).
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Insert clips by dragging them from the Browser, a media browser, or the Finder
You can insert clips between clips in the Timeline by dragging them from the Browser, another
Final Cut Pro media browser, or the Finder.
mm Drag the clip you want to insert to an edit point (between two clips) in the Timeline.

The clip appears in the Timeline, and all clips after the insertion point are rippled forward (to
the right).

Connect clips to add cutaway shots, titles, and synchronized sound effects
You can attach clips to other clips in the Timeline. Connected clips remain attached and
synchronized until you explicitly move or remove them.
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After edit

Some uses for connected clips include:
••

Cutaway shots: Add a cutaway shot by connecting it to a video clip in the Timeline.

••

Superimpose titles: Add a title or a lower third to a video clip or range.

••

Spot sound effects and background music: Synchronize audio clips to clips in the primary
storyline. The clips will remain synchronized even if you move the primary storyline clips.

Chapter 7    Edit your project

103

When you use the Connect menu command, keyboard shortcut, or toolbar button, video clips
(blue) are connected above the primary storyline and audio clips (green) are connected below
the primary storyline:
Connected clip

Primary storyline

Connected
audio-only clip

Note:  You can use three-point editing to make connect edits. For more information, see Threepoint editing overview on page 287.
Connect clips in the Timeline
1 If your project is empty, add clips to the dark gray primary storyline area in the Timeline to build
your initial sequence.

The clips in the primary storyline serve as a foundation on which you connect (attach) clips to
further build your project. Connect edits are slightly different than the other edit types in that
they never add clips to the primary storyline. If you perform a connect edit in an empty Timeline,
Final Cut Pro first adds a gap clip to the primary storyline and attaches the new connected clip
to it.
2 Select one or more clips or a range in the Browser.
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3 Do one of the following to indicate where you want to connect the selected source clip:
••

Position the playhead over the frame of the clip in the primary storyline.

••

Make a range selection in the primary storyline.

4 To connect the selected clips to the clips in the primary storyline, do one of the following:
••

Choose Edit > Connect to Primary Storyline (or press Q).
Note:  If you use the keyboard shortcut and the skimmer is present in the Timeline, the clip will
be connected at the skimmer position.

••

Click the Connect button in the toolbar.

••

Drag the clips to the gray area above or below the primary storyline.

The first frame of the source selection is connected to the clip in the primary storyline at the
playhead or skimmer position. If you dragged the selection to the Timeline, the first frame of
the source selection is connected to the primary storyline at the point where you released the
mouse button.
Connected clip

Primary storyline

Connection point
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When you rearrange, move, ripple, or remove clips in the primary storyline, any clips connected
to them will move (or be deleted) along with the primary storyline clips.

When you connect clips by dragging them, you have the option to put video clips below the
primary storyline or put audio clips above the primary storyline.
Title

Connected
audio-only clip

Connected
audio/video clip

Note:  In Final Cut Pro, if you connect clips, the topmost video clips block out any video clips
below them. Exceptions to this rule are clips with some type of transparency, keying, or
compositing settings. For more information, see Compositing overview on page 372. Audio clips
never affect video output, even when they are placed above video clips in the Timeline.
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Adjust the connection point of a connected clip
By default, connected clips and storylines are connected to the primary storyline at their first
frame, but you can move the “connection point” of a connected clip or storyline. This is useful
when you want to connect a specific frame or audio sample in the connected clip or storyline
with a specific frame or audio sample in the primary storyline.
mm Hold down the Command and Option keys, and click the connected clip (or the gray border of
the storyline) at the point where you want to position the connection point.
The connection point is moved to the point where you clicked.

New connection
point position

Default
connection point

Move, trim, or delete clips in the primary storyline without affecting connected clips
If you need to move or trim clips in the primary storyline but want to keep any connected clips
where they are, you can hold down the Grave Accent (`) key while editing to preserve the timing
and position of connected clips.
mm To move a clip without affecting connected clips: While holding down the Grave Accent (`) key, drag
the clip to another location in the Timeline (using either the Select tool or the Position tool).

Hold down the Grave Accent (`)
key and drag the clip.

The connected clip
remains in place.
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mm To trim a clip without affecting connected clips: While holding down the Grave Accent (`) key, trim
the clip using any method, including ripple edits, roll edits, slip edits, and slide edits.
mm To delete a clip without affecting connected clips: While holding down the Grave Accent (`) key,
select the clip and press Delete (or press Option-Command-Delete).
For more information about removing clips or ranges that have connected clips, see Remove
clips from your project on page 114.
mm To switch to an alternate clip in an audition without affecting connected clips: While holding down
the Grave Accent (`) key, select the pick in the Audition window.
For more information, see Use auditions to try out clips in your project on page 297.
In all of these cases, the connected clip (or clips) remains exactly in the same position, with its
timing preserved.
If you remove clips or ranges involved with connected clips and storylines without holding down
the Grave Accent (`) key, special rules apply. For more information, see Remove clips from your
project on page 114.

Overwrite parts of your project
In an overwrite edit, one or more source clips overwrite any clips in the primary storyline or
a selected storyline, starting at a range selection start point or at the playhead or skimmer
position. No clip items are rippled forward, so the duration of your project remains the same.

D

A

B

C

Before edit
A

D

B

C

After edit

Overwriting media is different from replacing it. Overwriting works with range selections only,
not entire clips, and it is not constrained by clip boundaries. Use an overwrite edit when you
want to edit media for a specific span of time, rather than specific shots.
Note:  You can use three-point editing to make overwrite edits. For more information, see Threepoint editing overview on page 287.
Overwrite clips in the Timeline with clips from the Browser
1 Select one or more clips in the Browser.
If there are multiple source clips in the selection, the clips will appear in the Timeline in the order
in which they were selected.
2 To define where you want the overwrite clip to start in the Timeline, do one of the following in
the primary storyline or a selected storyline:
••

Position the playhead.

••

Select a range involving one or more clips in the Timeline.

Note:  The overwrite command ignores whole clip selections in the Timeline. If you don’t select
a range in the Timeline, Final Cut Pro positions the start of the overwrite clip at the playhead or
skimmer position.
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3 Choose Edit > Overwrite (or press D).
The source clip appears in the primary storyline and overwrites any clips for the duration of the
source clip.
Note:  If you use the keyboard shortcut and the skimmer is present in the Timeline, the edit will
occur at the skimmer position.
To overwrite from the playhead back, so that the overwrite clip’s end point (rather than its start
point) is aligned at the target position, press Shift-D.

Replace a clip in your project with another clip
You can replace clips in your project with clips from the Browser, other Final Cut Pro media
browsers, or the Finder. In contrast to overwrite edits, replacing works on whole Timeline clips
only and can change the duration of your project.
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After edit

Replace options include using the start or end of the source clip, retiming the source clip to fit
the duration of the Timeline clip, as well as automatically creating or adding to auditions.
Replace a clip in the Timeline with one or more clips by dragging
1 Do one of the following to make a source selection:
••

Select a clip or range in the Browser.

••

Select a media item in one of the Final Cut Pro media browsers or in the Finder.

2 Drag the source selection over the clip in the Timeline you want to replace.
The target clip in the Timeline is highlighted with a white outline.
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3 Release the mouse button and choose an option from the shortcut menu:

••

Replace: The target clip is replaced with the source clip selection. The duration is determined
by the duration of the source clip selection. If the source clip selection and the target clip have
different durations, the subsequent clips ripple.

••

Replace from Start: The target clip is replaced with the source clip selection, starting from
the beginning of the source selection. The duration is determined by the duration of the
Timeline clip.

••

Replace from End: The target clip is replaced with the source clip selection, starting from the
end of the source selection. The duration is determined by the duration of the Timeline clip.

••

Replace with Retime to Fit: The target clip is replaced with the entire source clip selection,
retimed to fit the duration of the Timeline clip.

••

Replace and add to Audition: The target clip is replaced with an audition that has the source
clip selection as the pick and the target clip as an alternate. The duration is determined by
the source clip selection. If the source clip and the target clip have different durations, the
subsequent clips ripple.

••

Add to Audition: The target clip is replaced with an audition that has the target clip as the pick
and the source clip selection as an alternate.

••

Cancel: The replace edit is canceled.

The source clip selection appears in the Timeline, in place of the original clip.

The source clip selection
appears in the Timeline.

Note:  In the case of Replace from Start and Replace from End, if the source clip selection is a
range selection with a shorter duration than that of the target clip and there is sufficient extra
media, Final Cut Pro extends the duration of the source selection to match the target clip
duration. The resulting storyline duration does not change.
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Replace a clip in the Timeline using keyboard shortcuts
1 In the Browser, select the source clip or range.
2 In the Timeline, select the clip you want to replace.
Note:  This must be a whole clip selection, not a range selection. For more information, see About
selections and filmstrips on page 91.
3 Do one of the following:
••

To perform a standard replace edit: Press Shift-R.
The target clip is replaced with the source clip selection. The duration is determined by the
duration of the source clip selection. If the source clip selection and the target clip have
different durations, the subsequent clips ripple.

••

To perform a Replace from Start edit: Press Option-R.
The target clip is replaced with the source clip, starting from the beginning of the source clip.
The duration is determined by the duration of the Timeline clip.
Note:  In the case of Replace from Start, if the source clip selection is a range selection with a
shorter duration than that of the target clip and there is sufficient extra media, Final Cut Pro
extends the source selection to match the target clip duration. The resulting storyline duration
does not change.

The source clip selection appears in the Timeline, in place of the original clip.

Add and edit still images
In Final Cut Pro, you can add and edit a variety of still-image formats in your projects, including
photos and graphics files.
Add a still image to the Timeline
You can add still images to your project from the Browser or the Photos Browser.
mm To add a still image from the Browser: Import the still image into an event, and then select all or
part of the still-image clip and drag it from the Browser to the Timeline.
Note:  Once a still image is imported, it functions like any other clip in Final Cut Pro. You can use
any of the techniques described in this chapter to add still-image clips to the Timeline.
mm To add a still image from the Photos Browser: Open the Photos Browser, select a still image, and
drag it directly into the Timeline.
The default initial duration for range selections in still images is 4 seconds, but you can change
this setting in the Editing pane of Final Cut Pro preferences.
There is no limit on the duration of a still-image clip. To adjust the duration of a still-image clip in
the Timeline, use any of the trimming techniques described in this chapter. To adjust the duration
of multiple still-image clips at once, select the clips and choose Modify > Change Duration (or
press Control-D).
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Add layered graphics files to the Timeline
You can add layered graphics files, such as Adobe Photoshop (PSD) files, created with another
image editing application to the Timeline.
1 Import the layered graphics file into an event.
Important:  If the layered graphics file has a transparent background, make sure your project’s
render format is set to Apple ProRes 4444 to preserve the transparency when rendering. See
Modify a project’s settings on page 89.
2 In the Browser, Control-click the layered graphics image and choose Open in Timeline from the
shortcut menu.
Each layer appears in the Timeline as a connected clip that you can edit as you would any other
clip. For example, you can animate layers by fading them in or out.
Layered graphics image in the Viewer

Clips representing individual layers

The default duration for a layered graphics file is one minute. To adjust the duration of one of the
layers in the Timeline, use any of the trimming techniques described in this chapter. To adjust the
duration of all the layers, select them and choose Modify > Change Duration (or press Control-D).
For more information on creating layered graphics files for Final Cut Pro, go to
http://support.apple.com/kb/HT5152.
Edit a still image with an external image editing application
You can modify a still image with an external image editing application, and the changes appear
automatically in the clip in Final Cut Pro.
1 To add a still-image clip to the Timeline, follow the steps above.
2 To locate the clip’s source media file in the Finder, press Shift-Command-R.
3 Open the source media file in the external image editing application.
4 In the image editing application, modify the image and save the changes.
5 Switch back to Final Cut Pro.
The changes appear automatically in the still-image clip in Final Cut Pro.
You can also create freeze frames from your video clips. For more information, see Create freeze
frames on page 113.
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Create freeze frames
You can easily create freeze-frame clips from any video clip. Freeze-frame clips hold a particular
frame in place, temporarily stopping the action onscreen.
You can create freeze-frame clips from clips in the Timeline or the Browser. If you create a freezeframe clip from the Browser, it is attached to the primary storyline at the playhead location as a
connected clip.
You can create freeze frames on the fly during playback or by navigating to a specific frame in
a clip.
Note:  A freeze-frame clip preserves any attributes that were applied to the source clip, such as
settings and effects.
Create a freeze-frame clip
1 In the Timeline or the Browser, do one of the following:
••

Move the skimmer or playhead to the frame you want to freeze.

••

Begin playback of the clip.

2 Choose Edit > Add Freeze Frame (or press Option-F).
How the freeze frame is added to the project depends on whether the freeze frame was created
from the Timeline or the Browser.
••

If you created the freeze frame from a clip in the Timeline: A new freeze-frame clip is inserted at
the skimmer or playhead location in the Timeline.

••

If you created the freeze frame from a clip in the Browser: A new freeze-frame clip is attached as a
connected clip at the playhead location in the Timeline.

Change the default duration of freeze-frame clips
Freeze-frame clips have the same default duration as still-image clips: 4 seconds. You can change
the default duration in Final Cut Pro preferences.
1 Choose Final Cut Pro > Preferences (or press Command-Comma), and click the Editing button at
the top of the window.
2 Adjust the Still Images value slider.
If you don’t want to create a separate clip for freeze frames, you can create a hold segment using
the Retime pop-up menu. For more information, see Create a hold segment on page 313.
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Add clips using video-only or audio-only mode
By default, whenever you add clips from an event to the Timeline, all of the video and audio
components of the event clip are included in the edit. However, you can also add just the video
portion or just the audio portion of event clips to the Timeline, even if the event clips contain
both video and audio.
Make video-only or audio-only edits
1 To set the edit mode, do one of the following:
••

To add just the video from your selection to the Timeline: Choose Video Only from the Edit
pop-up menu in the toolbar (or press Shift-2).

••

To add just the audio from your selection to the Timeline: Choose Audio Only from the Edit
pop-up menu in the toolbar (or press Shift-3).

The edit buttons in the toolbar change their appearance to indicate the mode you selected:
Video-only mode

Audio-only mode

2 Add clips to the Timeline as you normally would.
The video-only or audio-only clip appears in the Timeline.
To return to the default (video and audio) mode, choose All from the Edit pop-up menu in the
toolbar (or press Shift-1).

Remove clips from your project
When you remove clips from a project in the Timeline, the source media in events, the
Final Cut Pro media browsers, and the Finder is not affected.
Delete clips or ranges from the Timeline
1 In the Timeline, select the clips or the range you want to remove.
2 Choose Edit > Delete (or press the Delete key).
The selected clips or portions of clips are removed from the Timeline and any clips to the right of
the selection ripple to close the resulting gap.
To undo the deletion immediately, choose Edit > Undo (or press Command-Z).
Note:  Normally, if you select an entire Timeline clip (for example, with the C key) or a range
that consists of an entire clip (for example, with the X key) and delete it, any connected clips or
storylines are also deleted. However, it’s possible to delete a clip without affecting its connected
clips by holding down the Grave Accent (`) key while pressing the Delete key. For more
information, see “Move, trim, or delete clips in the primary storyline without affecting connected
clips” in Connect clips to add cutaway shots, titles, and synchronized sound effects on page 103.
Also, if you delete a partial range of a clip that includes a connected clip or storyline, the
connected items are not deleted but are instead shifted to the closest primary storyline clip.
Chapter 7    Edit your project

114

Delete clips or ranges without affecting the total project duration and timing
If you want to remove clips from the Timeline but still maintain the total project duration and
timing, you can replace clips with gap clips. This method prevents any ripple edits.
1 Select the clips or range you want to remove.

2 Choose Edit > Replace with Gap (or press Shift-Delete).
Final Cut Pro replaces the selection in the Timeline with a gap clip.

Note:  This method preserves connected clips. When you replace a clip with a gap clip, any
connected clips will be attached to the resulting gap clip.

Solo, disable, and enable clips
Sometimes, it’s helpful to compare how a sequence plays with and without certain clips. In
Final Cut Pro, you can quickly play one clip’s audio, excluding audio from other clips. This feature,
called solo, works by disabling the audio in all unselected clips in the Timeline. You can also
disable (rather than delete) selected clips, making them invisible and silent during playback.
Disabled clips do not appear in any output. You can just as easily reenable them.
Solo selected items
When you want to focus on a subset of clips in the Timeline in isolation, you can select the clips
and solo them.
1 In the Timeline, select the clips you want to isolate.
2 Do one of the following:
••

Choose Clip > Solo (or press Option-S).

••

Click the Solo button in the upper-right corner of the Timeline.
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When solo is turned on, the Solo button turns yellow, and nonsoloed clips are shown in black
and white, making the soloed clips outlined in yellow easy to identify.

3 To turn off solo, click the Solo button again.
Disable and reenable one or more clips
1 Select one or more clips in the Timeline.
2 Choose Clip > Disable (or press V).
Disabled clips are dimmed in the Timeline and are invisible and silent during playback.

Disabled clip

Enabled clip

3 To reenable the disabled clips, select them in the Timeline and choose Clip > Enable (or press V).

Find a Timeline clip’s source clip
You can quickly find the source event clip for any clip you’re using in your project in the Timeline.
This is particularly useful if you want to duplicate a clip in your project or add the same clip to a
different project.
Find and reveal the source event clip for a Timeline clip
1 In the Timeline, select the clip whose source event clip you want to locate.
2 Do one of the following:
••

Choose File > Reveal in Browser (or press Shift-F).

••

Control-click the clip and choose Reveal in Browser from the shortcut menu.

A selection border appears around the source clip or range in the Browser, and the playhead
position in the source clip matches the playhead position in the Timeline clip. An orange line
along the bottom of the source clip indicates that the clip is being used in the current project
(open in the Timeline).
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Arrange clips in the Timeline

In Final Cut Pro, you can arrange and reorder the clips in your project however you want. If you
add or move a clip in the Timeline by dragging, Final Cut Pro moves other clips to make room for
it. Other reordering techniques include moving clips numerically by entering a timecode value,
nudging clips with keyboard shortcuts, overwriting with the Position tool, and moving clips
vertically from and to the primary storyline.
Move clips by dragging horizontally
mm In the Timeline, select one or more clips and drag them to a new location in the project.
As you drag your clips, you see an outline of your selection at the new position in the Timeline.
When you release the mouse button, the repositioned clip (or clips) appears at the new location.
Final Cut Pro ripples clips (and any connected clips) in the Timeline to make room for the
repositioned clips and to close the gap left by the clips that were repositioned. You can also drag
clips vertically in and out of the primary storyline.

Note:  This method of moving clips horizontally is the functional equivalent of a shuffle edit in
Final Cut Pro 7, just easier.
Move clips by entering a timecode value
You can move selected clips in the Timeline by entering an amount of time you want the clips
to move.
1 Select one or more clips in the Timeline.
2 Do any of the following:
••

To move the clips forward: Press the Plus Sign (+) key, and type a timecode duration for the move.

••

To move the clips back: Press the Hyphen (-) key, and type a timecode duration for the move.

Note:  For more information and tips on entering timecode, see Navigate using timecode on
page 143.
The timecode entry field (with blue numbers) appears in the Dashboard in the toolbar as
you type.
Timecode entry field
in the Dashboard
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3 Press Return.
The clips move forward or back by the duration you entered. The adjacent clips are trimmed to
accommodate the change in the clip’s position. If you prefer to fill in the vacated parts of the
storyline with a gap clip, select the Position tool by pressing P before entering a timecode value.

The clip moves forward or
back by the duration
you entered.

Adjacent clips are trimmed
to accommodate the change
in the clip’s position.

Note:  Moving clips by entering a timecode value is similar to making a slide edit. For more
information, see Make slide edits with the Trim tool on page 135.
Nudge clips with keyboard shortcuts
The nudging feature in Final Cut Pro allows you to move selected items by very small amounts,
such as frames or subframes (for connected audio-only clips).
1 Select one or more clips in the Timeline.
2 To nudge the clips, do any of the following:
••

To move the selection left by one frame: Press Comma (,).

••

To move the selection left by 10 frames: Press Shift-Comma (,).

••

To move the selection right by one frame: Press Period (.).

••

To move the selection right by 10 frames: Press Shift-Period (.).

3 If you want to nudge connected audio clips by one or more subframes, do any of the following:
••

To move the selection left by one subframe: Press Option-Comma (,).

••

To move the selection left by 10 subframes: Press Option-Shift-Comma (,).

••

To move the selection right by one subframe: Press Option-Period (.).

••

To move the selection right by 10 subframes: Press Option-Shift-Period (.).

For more information about subframes, see View audio waveforms at the audio sample level on
page 162.
The nudged clip appears at the new position in the Timeline. The adjacent clips are trimmed to
accommodate the change in the clip’s position. If you prefer to fill in the vacated parts of the
storyline with a gap clip, select the Position tool by pressing P before nudging clips.
Note:  Nudging clips in the Timeline is similar to making a slide edit. For more information, see
Make slide edits with the Trim tool on page 135.
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Overwrite clips using the Position tool
You can move clips by dragging them in the Timeline to overwrite other clips. This allows you to
place clips precisely without causing other clips to move to make room.
1 Choose the Position tool from the Tools pop-up menu in the toolbar (or press P).

The pointer changes to the Position tool

icon.

Tip:  To switch to the Position tool temporarily, hold down the P key. When you release the P key,
the tool reverts to the previously active tool.
2 Select the clip you want to move.

3 Drag the clip to a new position in the Timeline.

The moved clip overwrites any clips at the new position. A gap clip fills in the vacated part of
the Timeline.
Note:  If you prefer to move clips left or right in the Timeline without leaving a gap, you may want
to perform a slide edit.
To return to the Select tool (the default), choose it from the Tools pop-up menu in the toolbar (or
press A).
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Drag clips from and to the primary storyline
You can drag clips from and to the primary storyline. This technique employs ripple edits, which
affect the total duration of your project. When you move a clip out of the primary storyline, it
becomes either an individual connected clip or part of a connected storyline.
1 If the Select tool is not the active tool, choose it from the Tools pop-up menu in the toolbar (or
press A).

2 Select one or more clips (either clips in the primary storyline or connected clips).
3 Do any of the following:
••

To move clips out of the primary storyline: Drag the clips from the primary storyline to their new
position as connected clips (above or below the primary storyline).
The subsequent clips in the primary storyline ripple left to close the gap left by the clips
you moved.

Drag the clip to its
new position as
a connected clip.
••

Subsequent clips
ripple left to close
the gap.

To move clips to the primary storyline: Drag the clips from their position as connected clips to an
edit point between two clips in the primary storyline.
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The result is effectively an insert edit: the former connected clips are inserted in the primary
storyline and subsequent clips ripple right to make room for the new clips.

Note:  You can drag clips from and to the primary storyline as long as there are no clips
connected to them. If there is a connected clip, you must first move or remove the connected
clip or use the Lift from Primary Storyline or Overwrite to Primary Storyline command.
Move clips from and to the primary storyline without rippling the project
You can move clips from and to the primary storyline without affecting the total duration of
your project.
1 Select the clips you want to move.
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2 Do any of the following:
••

To move selected clips from the primary storyline to connected clips at the same Timeline position:
Choose Edit > Lift from Primary Storyline (or press Option–Command–Up Arrow).
New connected clip at the
same Timeline position

A gap clip fills in the vacated
part of the primary storyline.

Gap clips fill in the vacated parts of the primary storyline, as needed.
••

To move selected connected clips to the primary storyline: Choose Edit > Overwrite to Primary
Storyline (or press Option–Command–Down Arrow).
Depending on the amount of overlap on the connected clip, the Overwrite to Primary
Storyline command either creates a split edit or overwrites any video clips at the new location
and converts the audio portion of the overwritten clip to a connected clip. The Overwrite to
Primary Storyline command is not available for audio-only clips.
Note:  The Overwrite to Primary Storyline command works on individual connected clips only. To
use this command on a clip in a connected storyline, first move the clip out of the storyline.

You can achieve the same results by dragging clips with the Position tool.

Cut and trim clips
Trimming overview
After you’ve roughly assembled your clips in chronological order in the Timeline, you begin to
fine-tune the cut point (or edit point) between each pair of contiguous clips. Any time you make
a clip in a project longer or shorter, you’re trimming that clip. However, trimming generally refers
to precision adjustments of anywhere from one frame to several seconds. If you’re adjusting clip
durations by much larger amounts, you’re still trimming, but you may not be in the fine-tuning
phase of editing yet.
In Final Cut Pro, you can use a variety of techniques to trim Timeline clips and edit points,
including ripple edits, roll edits, slip edits, and slide edits.
No matter how you trim or make other edits in Final Cut Pro, the underlying media is never
touched. Trimmed or deleted pieces of clips are removed from your project only, not from the
source clips in your library or from the source media files on your hard disk.
Tip:  You can see a “two-up” display in the Viewer as you trim edit points in the Timeline. For more
information, see Show detailed trimming feedback on page 137.
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Cut clips with the Blade tool
Once you’ve added clips to the Timeline, you can easily cut them to adjust their durations or to
remove unwanted sections.
The most basic edit is a straight cut. The term comes from the film editing process of cutting a
filmstrip with a razor and attaching a new “clip” with glue.
Each time you cut a clip in your project, it is split into two clips. You can cut one clip at a time or
multiple clips at a time.
Cut a clip in the Timeline
1 Choose the Blade tool from the Tools pop-up menu in the toolbar (or press B).

The pointer changes to the Blade tool icon

.

Tip:  To switch to the Blade tool temporarily, hold down the B key. When you release the B key,
the tool reverts to the previously active tool.
2 Move the skimmer to the frame in the clip where you want to cut, and click.

Blade tool

Tip:  You can also cut clips while playing back your project. To cut clips on the fly, press
Command-B at any time while your project plays back.
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An edit point appears as a dotted line where you clicked, and the clip is divided into two clips.
The dotted line indicates a through edit, in which the media content on either side of the edit
point is continuous.

Dotted line indicates
through edit point.

To remove a through edit, do one of the following:
••

Select either or both sides of the through edit point, and choose Trim > Join Clips (or press Delete).

••

Select the clips on both sides of the through edit, and choose Trim > Join Clips.

Cut all clips at once
You can use the Blade All command to cut all primary storyline clips and connected clips at the
skimmer or playhead location simultaneously.
1 In the Timeline, move the skimmer to the frame where you want to cut.
2 Choose Trim > Blade All (or press Shift-Command-B).
All clips at the skimmer position are cut.
Cut multiple selected clips at once
You can use the Blade command to cut selected primary storyline clips and connected
clips simultaneously.
1 In the Timeline, select the clips you want to cut.
2 Move the skimmer to the frame where you want to cut.
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3 Choose Trim > Blade (or press Command-B).
The selected clips are cut at the skimmer position.

Note:  If you don’t make a selection, this command acts only on the clip in the primary storyline.

Extend or shorten a clip
You can trim a clip in your project by adjusting the start point or end point of the clip.
The default type of trim in Final Cut Pro is a ripple trim, which adjusts a clip’s start point or end
point without leaving a gap in the Timeline. The change in the clip’s duration ripples outward,
moving all subsequent clips earlier or later in the Timeline.
A

B

C

Before edit
A

B

C

After edit

Similarly, if you delete a clip from the Timeline, subsequent clips ripple earlier to close the gap.
Ripple edits affect the trimmed clip, the position of all subsequent clips in the Timeline, and the
total duration of your project.
You can see a “two-up” display in the Viewer as you trim edit points in the Timeline. This display
shows a more detailed view of each side of an edit point. For more information, see Show
detailed trimming feedback on page 137.
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Drag edit points with the Select tool
1 In the Timeline, move the pointer to the start point or the end point of the clip you want to trim.
The pointer changes from an arrow icon to a trim icon. The look of the trim icon changes to
indicate whether the trim will affect the end point of the left clip or the start point of the right clip.

Trim the left
clip’s end point.

Trim the right
clip’s start point.

2 Drag the start point or the end point in the direction you want to trim the clip.
As you drag, the clip shortens or lengthens. Numerical timecode fields indicate the duration of
the clip and the amount of time you are moving the edit point.

Any clips to the right of the edit point are rippled accordingly.
When you extend a clip to its maximum length in either direction, the clip edge turns red.
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Enter a new duration for a clip using timecode
You can change the total duration of one or more selected clips by entering a timecode value.
1 Select one or more clips in the Timeline.
2 Do one of the following:
••

Choose Modify > Change Duration (or press Control-D).

••

Double-click in the center of the Dashboard in the toolbar.

The timecode entry field appears in the Dashboard.

3 Enter a new duration for the selected clip.
Final Cut Pro moves the end point of the clip to the duration you entered, and any subsequent
Timeline clips ripple accordingly.
For more information about entering timecode values, see Navigate using timecode on page 143.
Note:  If you enter a duration longer than the available media in the clip, Final Cut Pro extends
the duration to the maximum length of the clip.
Trim to a selection
1 In the Timeline, select the part of a clip that you want to keep.
Range selection

Original clip

For information about making range selections, see Select a range on page 94.
2 Choose Trim > Trim Selection.
Final Cut Pro trims the clip start and end points to the range selection.

Trimmed clip

The unwanted sections are removed from the clip and the project, and the subsequent clips in
the project ripple accordingly.
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Nudge edit points with keyboard shortcuts
You can fine-tune the start or end point of a clip using keyboard shortcuts. You can move the
edit point by one or more video frames, and you can also move the edit points of connected
audio clips (those not in the primary storyline) by subframes.
1 In the Timeline, select the start or end point of the clip you want to trim.

2 To move the edit point, do any of the following:
••

To move the edit point left by one frame: Press Comma (,).

••

To move the edit point left by 10 frames: Press Shift-Comma (,).

••

To move the edit point right by one frame: Press Period (.).

••

To move the edit point right by 10 frames: Press Shift-Period (.).

3 If you want to move the edit point of connected audio clips by one or more subframes, do any of
the following:
••

To move the edit point left by one subframe: Press Option-Comma (,).

••

To move the edit point left by 10 subframes: Press Option-Shift-Comma (,).

••

To move the edit point right by one subframe: Press Option-Period (.).

••

To move the edit point right by 10 subframes: Press Option-Shift-Period (.).

For more information about subframes, see View audio waveforms at the audio sample level on
page 162.
The clip is trimmed and the Timeline updates accordingly.
Move edit points to the playhead
You can adjust selected edit points in the Timeline, either as a ripple edit or a roll edit, using
keyboard shortcuts.
1 In the Timeline, select the edit point you want to adjust.

Selected end point

Note:  For a roll edit, select both sides of the edit point with the Trim tool.
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2 Position the playhead or the skimmer at the point in the Timeline to which you want to move
the edit point.

Skimmer

3 Choose Trim > Extend Edit (or press Shift-X).
The edit point is extended (or shortened) to the playhead or skimmer position.

The clip’s end point is extended
to the skimmer position, and
subsequent clips ripple right.

In the example above, if you selected the end point of the clip, subsequent clips in the Timeline
are rippled accordingly. If you selected both sides of the edit point with the Trim tool, the right
clip is shortened (with a roll edit) and no clips ripple.
Trim edit points using timecode
You can trim clips numerically by entering timecode values.
1 If the Select tool is not the active tool, choose it from the Tools pop-up menu in the toolbar (or
press A).

2 In the Timeline, select the start point or the end point of the clip you want to trim.
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3 To trim the edit point, do one of the following:
••

To move the edit point forward: Press the Plus Sign (+) key, type a timecode duration for the
trim, and press Enter.

••

To move the edit point back: Press the Minus Sign (–) key, type a timecode duration for the trim,
and press Enter.
The timecode entry field (with blue numbers and the plus or minus sign) appears in the
Dashboard in the toolbar as you type.
Timecode entry field

The clip is shortened or extended by the amount of time you entered, and subsequent clips in
the Timeline are rippled accordingly.
Note:  You cannot use this feature to extend a clip beyond its maximum duration.
For more information and tips on entering timecode, see Navigate using timecode on page 143.
Cut the start or end of a clip at the playhead
Some of your video clips may have sections at the beginning or the end that you don’t want to
include in your project. You can easily trim off these ranges with a single command, even while
playing back the project. No selections are required. This type of edit is sometimes called a top
and tail edit.
1 In the Timeline, position the playhead or the skimmer on the frame at which you want to trim
the clip.
Original clip

Skimmer
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2 Do one of the following:
••

To trim off the start of the clip: Choose Trim > Trim Start, or press Option–Left Bracket ([).

••

To trim off the end of the clip: Choose Trim > Trim End, or press Option–Right Bracket (]).

••

To trim the edit point closest to the playhead: Choose Trim > Trim to Playhead, or press Option–
Backslash (\).

The clip is trimmed to the playhead (or skimmer) position, and the Timeline updates accordingly.
New end point
of the trimmed clip

Trimmed clip

In the case of connected clips or storylines, Final Cut Pro trims the selected clip. If there is no
selection, Final Cut Pro trims the topmost clip.

Make roll edits with the Trim tool
A roll edit adjusts the start point and the end point of two adjacent clips simultaneously. If you
like where two clips are placed in the Timeline, but you want to change when the cut point
happens, you can use the Trim tool to roll the edit point between the two clips. No clips move in
the Timeline as a result; only the edit point between the two clips moves. No other clips in the
project are affected.
When you perform a roll edit, the overall duration of the project stays the same, but both clips
change duration. One gets longer while the other gets shorter to compensate.
A

B

C

Before edit
A

B

C

After edit

In the example above, clip B gets shorter while clip C becomes longer, but the combined
duration of the two clips stays the same.
You can see a “two-up” display in the Viewer as you trim edit points in the Timeline. This display
shows a more detailed view of each side of an edit point. For more information, see Show
detailed trimming feedback on page 137.
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Roll an edit point
1 Choose the Trim tool from the Tools pop-up menu in the toolbar (or press T).

The pointer changes to the Trim tool icon

.

Tip:  To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the
tool reverts to the previously active tool.
2 In the Timeline, click the center of the edit point you want to roll so that both sides of the edit
point are selected.

3 Do one of the following:
••

Drag the edit point left or right.

••

Press the Plus Sign (+) key or the Minus Sign (–) key followed by the timecode duration to add
or subtract from the current edit, and press Return.
The timecode entry field (with blue numbers) appears in the Dashboard in the toolbar as
you type.
For more information about entering timecode values, see Navigate using timecode on
page 143.

••

Position the playhead or skimmer at a point in the Timeline to which you want to move the
edit point, and choose Trim > Extend Edit (or press Shift-X).
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The edit point is rolled to the new location. The combined duration of the two clips stays
the same.

If you can’t roll the edit point any farther and one side of the edit point appears red, you’ve
reached the end of the media for one of the two clips.

Make slip edits with the Trim tool
Performing a slip edit doesn’t change a clip’s position or duration in the Timeline, but instead
changes what portion of the clip’s media appears in the Timeline. A slip edit allows you to
change a clip’s start and end points simultaneously.
Whenever you arrange clips in the Timeline so that edit points line up with musical beats or
other fixed sync points in a movie, you want to keep your clips in position to maintain the
alignment. These situations leave you with very little room to adjust a clip because you cannot
change its duration or move it elsewhere in the Timeline. All you can do is move both the start
and end points of the clip simultaneously, keeping the clip’s position and duration fixed.
The portion of the clip seen in the project changes, but its position in the Timeline stays the
same. Surrounding clips are not affected, and the overall duration of your project doesn’t change.
00:00:10:00

A

00:00:30:00

B

C

Before edit
00:00:17:00

A

00:00:37:00

B

C

After edit

In the example above, the slip edit changes the start and end points of clip B, but not its duration
or position in the Timeline. When the project plays back, a different portion of clip B’s media
is shown.
Note:  To slip a clip, it must have media handles on both sides, meaning that there must be
additional media available on both the head and the tail of the clip. If you’re having trouble
slipping a clip, check that the clip has media handles on both sides. You can double-click any edit
point to view or adjust its media handles in the Precision Editor.
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If there are no media handles available, consider using the Position tool instead. For more
information about the Position tool, see Arrange clips in the Timeline on page 117.
For more accurate visual feedback on edits involving contiguous clips, you can turn on “Show
detailed trimming feedback” in Final Cut Pro preferences. For a slip edit, this “two-up” display in
the Viewer shows the start and end points of the clip you’re slipping. For more information, see
Show detailed trimming feedback on page 137.
Slip a clip in the Timeline
1 Choose the Trim tool from the Tools pop-up menu in the toolbar (or press T).

The pointer changes to the Trim tool icon

.

Tip:  To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the
tool reverts to the previously active tool.
2 Drag a clip left or right.
As you drag, a timecode field indicates the amount of time you’re moving the start point and the
end point. Yellow edge selections on the start point and end point indicate a slip edit.
Yellow edge selections on the start
point and end point indicate a slip edit.

Original position of frame

New position of frame
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When you release the mouse button, the slipped clip appears in the Timeline with a new start
point and a new end point.
With the current selection, you can also slip the clip with keyboard shortcuts by doing either of
the following:
••

Nudge the start and end points (one frame or 10 frames) to the left or right.

••

Enter an amount of time to slip the clip left or right.

Note:  If either the start point or the end point turns red as you drag, you’ve reached the end of
the available media for that side of the clip.

Make slide edits with the Trim tool
Performing a slide edit allows you to move a clip’s position in the Timeline between two other
clips without creating a gap. The clip’s content and duration remain the same; only its position
in the Timeline changes. When you slide a clip, the adjacent clips get longer and shorter to
accommodate the change in the clip’s position. The combined duration of these three clips stays
the same, and the project’s total duration remains unchanged as well.
A

B

C

Before edit
A

B

C

After edit

Note:  To slide a clip between two others, the preceding clip and the following clip must have
media handles, additional media available beyond the edit point. You can double-click any edit
point to view or adjust its media handles in the Precision Editor.
If there are no media handles available, consider using the Position tool instead. For more
information about the Position tool, see Arrange clips in the Timeline on page 117.
For more accurate visual feedback on edits involving contiguous clips, you can turn on “Show
detailed trimming feedback” in Final Cut Pro preferences. For a slide edit, this “two-up” display
in the Viewer shows the two edit points you are adjusting: the end point of the preceding clip
and the start point of the subsequent clip. For more information, see Show detailed trimming
feedback on page 137.
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Slide a clip in the Timeline
1 Choose the Trim tool from the Tools pop-up menu in the toolbar (or press T).

The pointer changes to the Trim tool icon

.

Tip:  To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the
tool reverts to the previously active tool.
2 Option-drag a clip to the left or right.
Yellow selections on the neighboring clips indicate a slide edit.
Yellow selections on the neighboring
clips indicate a slide edit.

Original Timeline position

As you drag, a timecode field indicates the amount of time you’re moving the clip in
the Timeline.
This clip is shorter.

This clip is longer.

New Timeline position

This clip’s duration is the same.

When you release the mouse button, the slide clip appears at the new position in the Timeline.
The adjacent clips are trimmed to accommodate the change in the clip’s position.
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With the current selection, you can also slide the clip with keyboard shortcuts by doing either of
the following:
••

Nudge it (one frame or 10 frames) to the left or right.

••

Enter an amount of time to slide the clip left or right.

For more information, see Arrange clips in the Timeline on page 117.
Note:  If either edit point turns red as you drag, you’ve reached the end of the available media for
that side of the clip.

Note:  You can also make slide edits by entering a timecode value to move clips or by nudging
clips with keyboard shortcuts. For more information, see Arrange clips in the Timeline on page 117.

Show detailed trimming feedback
For more accurate visual feedback on edits involving contiguous or connected clips, you can turn
on “Show detailed trimming feedback” in Final Cut Pro preferences. For example, for a simple
ripple trim, this “two-up” display in the Viewer shows the end point of the left clip and the start
point of the right clip.

This display is available for ripple, roll, slip, and slide edits as well as for trimming in the
Precision Editor.
Turn on detailed trimming feedback
1 Choose Final Cut Pro > Preferences, or press Command-Comma (,).
2 Click Editing.
3 In the Timeline section, select the “Show detailed trimming feedback” checkbox.
The “two-up” display appears in the Viewer whenever you use a supported edit type or when
trimming in the Precision Editor.
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Tip:  You can use the Option key to change the detailed trimming feedback display on the fly. If
detailed trimming feedback is enabled, press the Option key to disable it. If detailed trimming
feedback is disabled, press the Option key to switch the view between the end point of the left
clip and the start point of the right clip.

View and navigate
Zoom and scroll in the Timeline
Being able to see and get to any point in your project is critical to efficient editing and
storytelling. There are many ways to adjust the view of the Timeline. Learning keyboard shortcuts
can save you time.
Fit the entire contents of the Timeline into the available window size
Whether you’re zoomed in to a single clip or zoomed out so far that all the clips in your project
appear on the left side of the Timeline, you can quickly change the view so that all the clips fill
the visible part of the Timeline and no scrolling is required.
mm Choose View > Zoom to Fit (or press Shift–Z).

Before choosing Zoom to Fit

After choosing Zoom to Fit

Zoom in to and out of the Timeline using the Zoom slider
mm To zoom in to the Timeline: Drag the Zoom slider to the right, or press Command–Plus Sign (+).
mm To zoom out of the Timeline: Drag the Zoom slider to the left, or press Command–Minus Sign (–).
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Zoom in to and out of the Timeline using the Zoom tool
1 Choose the Zoom tool from the Tools pop-up menu in the toolbar (or press Z).

The pointer changes to the Zoom tool icon

.

Tip:  To switch to the Zoom tool temporarily, hold down the Z key. When you release the Z key,
the tool reverts to the previously active tool.
2 Do one of the following:
••

To zoom in to the Timeline: Click the section of the Timeline you want to zoom in to. (You can
also drag over an area of the Timeline to zoom in to just that area.)
Click multiple times to continue zooming in.

••

To zoom out of the Timeline: Option-click the section of the Timeline you want to zoom out of.
Option-click multiple times to continue zooming out.

Scroll a zoomed-in Timeline
1 Zoom in to the Timeline until you see a portion of the project only.
2 Do one of the following:
••

Drag the slider at the bottom of the Timeline left or right.

••

Drag the slider at the right side of the Timeline up or down.

••

Choose the Hand tool from the Tools pop-up menu in the toolbar (or press H), and drag in the
Timeline.

Tip:  To switch to the Hand tool temporarily, hold down the H key. When you release the H key,
the tool reverts to the previously active tool.
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Adjust Timeline settings
In Final Cut Pro, it’s very easy to adjust the Timeline display options. For example, you can show
clips with or without video filmstrips or audio waveforms. Or you can change the vertical height
of the clips or the size of filmstrips or audio waveforms in relation to the video thumbnails that
appear in the filmstrip of each clip in the Timeline. You can also show only the clip labels.
The snapping behavior makes it easier and quicker to do things like line up a video clip with an
audio clip, or align the playhead to a particular marker. When snapping is turned on, items you
move in the Timeline appear to jump, or “snap,” directly to certain points in the Timeline. This can
help you quickly line up edits with other items in the project.
Snapping affects the functions of many of the editing tools in Final Cut Pro, including the
Select tool, the Trim tool, the Position tool, the Range Selection tool, and the Blade tool. Several
elements trigger snapping in the Timeline:
••

Clip boundaries (start and end points)

••

The playhead and the skimmer

••

Markers

••

Keyframes

••

Range selections

Adjust Timeline clip appearance and height
1 Click the Clip Appearance button in the lower-right corner of the Timeline.

The Clip Appearance window appears.

2 Do one of the following:
••

To display clips with large audio waveforms only: Click the leftmost Clip Appearance button (or
press Control-Option-1).

••

To display clips with large audio waveforms and small filmstrips: Click the second Clip
Appearance button from the left (or press Control-Option-2).
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••

To display clips with audio waveforms and video filmstrips of equal size: Click the third Clip
Appearance button from the left (or press Control-Option-3).

••

To display clips with small audio waveforms and large filmstrips: Click the third Clip Appearance
button from the right (or press Control-Option-4).

••

To display clips with large filmstrips only: Click the second Clip Appearance button from the right
(or press Control-Option-5).

••

To display clip labels only: Click the rightmost Clip Appearance button (or press
Control-Option-6).

Tip:  To increase the size of audio waveforms for Timeline clips, press Option–Control–Up Arrow.
To decrease the size of audio waveforms for Timeline clips, press Option–Control–Down Arrow.
3 To adjust the vertical height of clips in the Timeline, drag the Clip Height slider to the left to
decrease the clip height, or to the right to increase the clip height.
4 To turn connection lines for connected clips and storylines on or off, select or deselect the Show
Connections checkbox.
5 To adjust the clip label display, choose an option from the Show pop-up menu:
••

To view clips by name: Choose Clip Names.

••

To view clips by role: Choose Clip Roles.

••

To view multicam clips by the name of the active video angle and the active audio angle: Choose
Clip Names or Angles.
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Enable or disable snapping
While snapping is extremely useful, it can also be a hindrance if you’re trying to move a clip only
a few frames among a series of markers and clip boundaries, and you don’t want it to snap to
any of these points. Fortunately, you can turn snapping on or off at any time, even while you’re
dragging a clip.
Do one of the following:
mm Choose View > Snapping (or press N).
A checkmark indicates that snapping is on. You can press N to turn snapping on or off while
you’re dragging a clip.
mm Click the Snapping button in the upper-right corner of the Timeline.

When snapping is on, the Snapping button appears blue.
Tip:  To turn snapping on or off temporarily, hold down the N key. When you release the N key,
snapping reverts to the previous state.

Navigate within your project
The ability to jump to any point in the Timeline instantly is one of the main benefits of a
nonlinear editing environment. Final Cut Pro provides a variety of quick and easy ways to
navigate your project.
You can also use a text-based view of the Timeline to navigate and search your project. For more
information, see Use the Timeline Index to view, navigate, and search your project on page 145.
You can use the J, K, and L keys to play through a project with different speeds or directions. For
more information, see Play back media on page 78.
Navigate by skimming, clicking, or dragging
mm To skim to a frame in your project: Move the skimmer left and right over the clips in the Timeline
to quickly view them in the Viewer.
mm To move the playhead to a frame in your project: Move the playhead by clicking or dragging in the
ruler at the top of the Timeline, or by clicking in the Timeline background.
Tip:  To prevent the playhead from moving while you select a clip in the Timeline, press Option as
you click.
Navigate frame by frame
To make it easier to find specific frames in a clip, you can step through the filmstrip frame by
frame, rather than skimming it.
1 In the Timeline or the Browser, move your pointer

over a filmstrip and click.

2 Do any of the following:
••

To move backward in one-frame increments: Choose Mark > Previous > Frame (or press the Left
Arrow key).

••

To move forward in one-frame increments: Choose Mark > Next > Frame (or press the Right
Arrow key).
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Navigate by subframe
You can navigate clips by subframe. A subframe has 1/80 the duration of a video frame and is a
more precise unit of reference when viewing or editing audio waveforms that are zoomed in to
the sample level.
Note:  You can’t make edits to video at the subframe level.
1 In the Timeline or the Browser, move your pointer

over a clip and click.

2 Do any of the following:
••

To move backward in one-subframe increments: Press Command-Left Arrow.

••

To move forward in one-subframe increments: Press Command-Right Arrow.

Note:  You can change the time display in the Dashboard to show subframes. For more
information, see Editing preferences on page 442.
Navigate by jumping
Use the following techniques to move the playhead quickly from point to point in the Timeline.
mm To go to the next edit point: Choose Mark > Next > Edit (or press the Down Arrow key), or click the
Next Edit
button below the Viewer.
mm To go to the previous edit point: Choose Mark > Previous > Edit (or press the Up Arrow key), or click
the Previous Edit
button below the Viewer.
mm To go to the start of the project: Choose Mark > Go to > Beginning (or press the Home key).
mm To go to the end of the project: Choose Mark > Go to > End (or press the End key).
mm To go to the next marker: Choose Mark > Next > Marker, or press Control–Apostrophe (‘).
mm To go to the previous marker: Choose Mark > Previous > Marker, or press Control–Semicolon (;).
For more information about markers, see Markers overview on page 148.

Navigate using timecode
Timecode is a signal recorded with your video that uniquely identifies each video frame. When
you play a clip from the Browser, its timecode signal appears in the Dashboard, in the center of
the Final Cut Pro toolbar, using this format:
Timecode

Hours

Seconds
Minutes

Frames

Timecode supports a variety of functions in Final Cut Pro, including Timeline playback,
synchronizing video and audio clip items, and adding, trimming, and moving clips. In addition,
timecode allows you to navigate through projects in the Timeline and see the duration of clips,
range selections, and projects.
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Navigate by entering timecode
To move the playhead to a new Timeline location, do any of the following:
mm To move the playhead to a specific Timeline location: Click once in the center of the Dashboard (or
press Control-P), enter the new timecode value, and press Return.
For example, to move the playhead to 01:40:31:03, press Control-P, and then enter “1403103” and
press Return.

mm To move the playhead by a timecode duration: Make sure no clips are selected, and press the Plus
Sign (+) or Minus Sign (–) key, enter the number of frames, seconds, or minutes you want to
move the playhead, and press Return.
For example, if you type “+1612” and press Return, the playhead moves ahead 16 seconds and 12
frames.

The new timecode values appear in the Dashboard as you enter them. When you press Return,
the playhead moves to the new Timeline location.
Here are some tips for entering timecode values:
••

You don’t have to enter the separator characters (colons). Final Cut Pro adds them
automatically after each set of two digits. For example, if you enter “01221419,” Final Cut Pro
interprets it as 01:22:14:19 (1 hour, 22 minutes, 14 seconds, and 19 frames).

••

If the leftmost fields are zeroes, you don’t have to enter them. For example, if you enter “1419,”
Final Cut Pro interprets it as 00:00:14:19. If you enter “253407,” Final Cut Pro interprets it as
00:25:34:07.

••

If the rightmost fields are zeroes, you can use periods instead. For example, to move to
timecode 00:00:03:00, type “3.” (3 and a period). To move to 03:00:00:00, type “3...” (3 and three
periods). Instead of a period, you can also use a comma, colon, or semicolon.

Note:  You can change the time display in the Dashboard to show timecode, timecode and
subframes, just frames, or just seconds. For more information, see Editing preferences on
page 442.
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Use the Timeline Index to view, navigate, and search your project
The Timeline Index provides a text-based view of the clips and tags (various kinds of markers and
keywords) used in your project in the Timeline. You can easily filter the Timeline Index to show
only the items you want to see.

Clips are listed in their
order of appearance
in the Timeline.

You can also use the Timeline Index to navigate in the Timeline. The Timeline Index playhead
appears in the list of items. When you play a project, the playhead moves down the list of items
in the Timeline Index. When you select an item in the Timeline Index, the playhead automatically
moves to the beginning of the item.
Show or hide the Timeline Index
mm Click the Timeline Index button in the lower-left corner of the Final Cut Pro main window (or
press Shift-Command-2).

The Timeline Index appears in the lower-left corner of the Final Cut Pro window.
Timeline playhead

The Timeline Index playhead
moves in tandem with the
Timeline playhead.
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View a list of items in the Timeline Index
1 If the Timeline Index is not already open, click the Timeline Index button in the lower-left corner
of the Final Cut Pro main window (or press Shift-Command-2).

2 Do any of the following:
••

To view a list of the clips used in the Timeline, ordered chronologically: Click the Clips button at
the top.

You can do any of the following:
••

Rename clips.

••

See a list of clips by timecode in the Position column.

••

View, reassign, and edit roles in the Roles column.

••

View and add notes in the Notes column.

••

View the active angles of multicam clips in the Active Angle column.

You can specify which columns are displayed by Control-clicking a column heading and
choosing an option from the shortcut menu.

You can specify which items are displayed by clicking the All, Video, Audio, or Titles button at
the bottom of the Timeline Index.
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••

To view a list of all the tags on the clips in the Timeline, ordered chronologically: Click the Tags
button at the top.
Keyword
Incomplete to-do item

Completed to-do item
Chapter marker
Standard marker

All of the tags are shown by default. You can specify which items are displayed by clicking
a button at the bottom of the Timeline Index. You can show markers, keywords, analysis
keywords, incomplete to-do items, completed to-do items, and chapter markers.

Note:  To-do items are types of markers.
••

To view a list of clips in the Timeline, organized by role: Click the Roles button at the top.

Select a role name in the list to highlight all clips in the Timeline with that role assigned. Select
or deselect the checkboxes next to the roles you want to turn on or off in the Timeline. When a
checkbox is deselected, you can’t see or hear clips with that assigned role when you play back
your project. For more information, see View clips by role in the Timeline on page 324.
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Change a To Do marker
In the Timeline Index, you can quickly change a To Do marker’s state from incomplete to completed.
1 If the Timeline Index is not already open, click the Timeline Index button in the lower-left corner
of the Final Cut Pro main window (or press Shift-Command-2).

2 Click the checkbox for the To Do marker.
••

If the marker was red (an incomplete to-do item), it turns green (completed).

••

If the marker was green (a completed to-do item), it turns red (incomplete).

Search for items in the Timeline Index
1 If the Timeline Index is not already open, click the Timeline Index button in the lower-left corner
of the Final Cut Pro main window (or press Shift-Command-2).

2 Click Clips to search for clips, or click Tags to search for tags.
3 Enter a term in the search field

at the top of the Timeline Index.

You can search for clips, keywords, and markers (including to-do items).
Tip:  With the Timeline active, choose Edit > Find (or press Command-F). The Timeline Index
opens with the search field active and ready for your search term.

Work with markers
Markers overview
Markers are reference points you can place within clips to locate, identify, annotate, and navigate
to specific frames. In editing, markers are particularly useful for synchronizing two or more clips at
a specific point. For example, you can use a marker to label the frame where a door slams and then
snap a sound effect to that marker. You can use markers to flag a specific location in a clip with
editing notes or other descriptive information. When you add chapter markers to specific points
in your project, viewers can use the markers to quickly jump to those points in the movie after it’s
been exported or burned to DVD or Blu-ray disc. You can also use markers for task management.
Markers are classified as standard markers (blue), chapter markers (orange), to-do items (red), or
completed to-do items (green).
Standard marker

Chapter marker

To-do item

Completed
to-do item

You work with markers in the same way for clips in the Browser and clips in the Timeline.
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Add and remove markers
It’s easy to add and remove markers. If you add markers to clips in the Browser, the markers are
visible in both filmstrip view and list view. When you add clips with markers to the Timeline, the
markers are visible in both the Timeline and the Timeline Index.
Add a marker to a clip in the Browser or the Timeline
1 To specify where you want to add a marker, do one of the following:
••

Skim to the location.

••

Play the clip, and when the playhead reaches the location where you want to add a marker,
press the Space bar to stop playback.

For more information about positioning the skimmer and the playhead, see Navigate within your
project on page 142.
2 Do one of the following:
••

To add a marker: Choose Mark > Markers > Add Marker (or press M).
Tip:  To add markers on the fly, just press M while playing a clip.

••

To add a marker and show the marker’s information: Choose Mark > Markers > Add Marker and
Modify (or press Option-M).
Adding a marker this way automatically shows the marker’s information.

The marker appears at the top of the clip in the Browser or the Timeline.

Note:  Event clip markers also appear in the list view filmstrip and text list.
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Remove a marker
Do one of the following:
mm Navigate to a marker and choose Mark > Markers > Delete Marker (or press Control-M).
mm Select one or more clips, and choose Mark > Markers > Delete Markers in Selection.
mm Double-click a marker to open the Marker window, and click the Delete button.
mm Control-click the marker you want to remove, and choose Delete Marker from the shortcut menu.

Edit, move, and navigate to markers
You can view and edit marker information, and you can move markers within a clip or to
different clips.
Edit marker information and change marker types
By default, new markers are blue standard markers with placeholder text. You can change the
text at any time, and you can change the marker type to other marker types, including chapter
markers, to-do items, and completed to-do items.
1 To view a marker’s information, do one of the following:
••

Select the marker and choose Mark > Markers > Modify Marker (or press Shift-M).

••

Control-click the marker and choose Modify Marker from the shortcut menu.

••

Double-click the marker.

The marker’s information appears above the marker.
To-Do Item button
Standard Marker button

Chapter Marker button

2 To modify the marker, do any of the following:
••

To change the descriptive text for the marker: Type the new text in the text field. (The text is
automatically selected when the marker information appears, so you don’t need to select it.)

••

To make the marker a chapter marker: Click the Chapter Marker button.
The marker turns into an orange chapter marker. For more information, see Manage chapter
markers and their thumbnail images on page 152.

••

To make the marker a to-do item: Click the To-Do Item button.
The marker turns red.
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••

To indicate that a to-do item is completed: Select the Completed checkbox.
The marker turns green.
To-Do Item button

Select the Completed checkbox.
••

To make the marker a standard marker: Click the Standard Marker button.
The marker turns blue.

3 Click Done.
Move or copy a marker
You can move or copy markers with the familiar Mac commands Cut, Copy, and Paste.
1 Control-click the marker you want to move or copy, and choose an option from the
shortcut menu.
••

To move the marker: Choose Cut Marker.

••

To copy the marker: Choose Copy Marker.

2 Position the skimmer or the playhead where you want to move or copy the marker.
3 Choose Edit > Paste (or press Command-V).
The marker appears at the new location.
Nudge a marker one frame at a time
1 Click a marker to select it.
2 Do one of the following:
••

To nudge the marker one frame to the right: Choose Mark > Markers > Nudge Marker Right, or
press Control-Period (.).

••

To nudge the marker one frame to the left: Choose Mark > Markers > Nudge Marker Left, or press
Control-Comma (,).

Move between markers
You can move quickly from marker to marker in the Timeline or the Browser.
mm To go to the next marker: Choose Mark > Next > Marker, or press Control-Apostrophe (‘).
mm To go to the previous marker: Choose Mark > Previous > Marker, or press Control-Semicolon (;).
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Manage chapter markers and their thumbnail images
Chapter markers are a standard feature in DVDs, Blu-ray discs, and podcasts. You can add chapter
markers to your project so that when you share your finished movie, viewers can use the
markers to quickly jump to those points in the movie. Applications and devices that recognize
Final Cut Pro chapter markers during playback include iTunes, iPod, iPhone, iPad, Apple TV,
QuickTime Player, DVD Player, and most standard DVD and Blu-ray players.
Chapter markers make it easy for viewers to skip ahead to the section they want. They also allow
Compressor, Apple’s professional transcoding application, and other DVD and Blu-ray authoring
applications to create a navigable chapter list or menu, such as a chapter index menu. But even
in simple projects without menus (such as podcasts), chapter markers provide viewers and
listeners with the ability to quickly skip through sections of a program by using the Previous and
Next buttons on their playback application or device.
A chapter marker thumbnail is a still image that represents a particular chapter. Final Cut Pro
allows you to choose a specific video frame from the clip or storyline you’re marking as the
chapter marker thumbnail image. In supported playback applications or devices, the chapter
marker thumbnail images represent their corresponding chapters.
Create a chapter marker
1 Add a marker to a clip in the Timeline where you want the chapter to begin.
By default, Final Cut Pro creates a blue standard marker.
2 To change the marker to a chapter marker, double-click it and, when the marker’s information
appears, click the Chapter Marker button.
To-Do Item button
Standard Marker button

Chapter Marker button

The marker changes to an orange chapter marker.
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Set the chapter marker thumbnail image
After you set a chapter marker, you can choose an appropriate video frame to represent that
particular chapter.
1 Click the chapter marker once in the Timeline to select it.
The marker enlarges slightly to show that it’s selected, and a chapter marker thumbnail pin
appears to the right of the selected chapter marker. By default, the chapter marker thumbnail pin
appears 11 frames after the chapter marker.
Chapter marker
Chapter marker
thumbnail pin

2 To set the video frame for the chapter marker thumbnail image, drag the pin left or right in
the Timeline.
As you drag, the Viewer displays the corresponding video frame.
Drag the pin left
or right in the Timeline.

Note:  The chapter marker thumbnail image is the composited image from that location in the
Timeline and includes titles and any other superimposed imagery.
If the chapter marker is in the primary storyline, you can drag the chapter marker thumbnail
pin as far as the beginning or the end of the primary storyline. If the chapter marker is in a
connected storyline, you can drag the chapter marker thumbnail pin as far as the beginning or
the end of the connected storyline.
For information about sharing your completed movie, see Sharing projects overview on
page 399.
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Correct excessive shake and rolling shutter issues

You can smooth a clip’s shaky footage by correcting the stabilization, rolling shutter, or both.
The stabilization feature in Final Cut Pro reduces the camera motion in your video so that shaky
parts can be played back more smoothly. At any time, you can turn off stabilization for any clip so
that it plays as originally recorded.
Many camcorders and still cameras include CMOS image sensors that expose the picture they’re
recording progressively, instead of all at once. As a result, if the camera moves a lot during recording,
or if the camera is recording fast motion, image distortion can occur. This causes the picture to appear
wobbly or skewed. Final Cut Pro has a rolling shutter feature that can reduce this motion distortion.
Fix a clip with excessive shake or rolling shutter distortion
1 If the clip is not already in your project, add it to the Timeline and select it.
Note:  These operations act on whole clip selections, not on range selections. To get the highestquality and fastest results, isolate the problem section by cutting the clip with the Blade tool in
the Timeline. Then apply the correction to just the video footage that needs correcting.
2 To open the Video inspector, click the Inspector button in the toolbar (shown below), and click
the Video button at the top of the pane that appears.

3 In the Video inspector, do any of the following:
••

To reduce the shake: Select the Stabilization checkbox.

••

To reduce rolling shutter distortion: Select the Rolling Shutter checkbox.

When you turn on Stabilization or Rolling Shutter, its checkbox turns blue.

4 To view the fix, play the clip in the Timeline.
To turn off stabilization or rolling shutter corrections for a clip, deselect the Stabilization or
Rolling Shutter checkbox.
You can refine the corrections by adjusting the stabilization settings or the Rolling Shutter
Amount setting.
Adjust stabilization settings
You can adjust how much of a correction is applied by the stabilization feature.
The stabilization feature has two independent phases:
••

When you apply the stabilization feature to a clip, Final Cut Pro analyzes the pixels in
successive frames to determine the direction of camera movement.
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••

During playback and rendering, Final Cut Pro uses the motion analysis data to apply a
transform effect to each frame, compensating for camera movement.

Use any of the three independent stabilization parameter sliders in the Video inspector to control
the steadiness of your shot. When you apply stabilization to a clip, all three parameters are set to an
average value of 2.5 by default. Each parameter can be set to a value between 0.0 and 5.0. A value
of 0.0 turns off the parameter, and a value of 5.0 applies the strongest possible transformation. The
higher you set each parameter, the more camera motion is compensated for in that axis.
x

x

x
z

y

Translation

y

Rotation

y

Scale

1 Select a clip in the Timeline, and open the Video inspector.
2 Move the pointer over the Stabilization item in the Inspector and click Show to reveal the
Stabilization settings.
3 Do any of the following:
••

To adjust left, right, up, and down movement of a shot (x and y axes): Drag the Translation
Smooth slider.

••

To adjust rotation around the center point of the image: Drag the Rotation Smooth slider.

••

To adjust forward or backward camera or lens movement (z axis): Drag the Scale Smooth slider.

For example, if you want to remove horizontal, vertical, and rotational shake, you should set
the Translation Smooth and Rotation Smooth parameters to a value above 0. You may need to
experiment to see which values steady your shot the best.
4 Optionally, choose a different stabilization method from the Method pop-up menu:
••

Automatic: Allows Final Cut Pro to choose the most appropriate stabilization method.

••

InertiaCam: Applies stabilization optimized for video footage that has camera moves such as
pans and zooms. Use the Smoothing slider to adjust the amount of the InertiaCam effect.
Note:  When you choose InertiaCam, Final Cut Pro analyzes your video footage and if it
determines there is an opportunity, it also offers the Tripod Mode checkbox. Select the
checkbox to create the effect of a static camera that is mounted on a tripod.

••

SmoothCam: Applies the default stabilization method described above, allowing you to adjust
the translation, rotation, and scale parameters.

Note:  When a clip has too much motion (excessive panning, for example), stabilizing the clip
may result in black bars on the edges of the video.
To avoid the black bars, you can:
••

Reduce the values for the Translation Smooth, Rotation Smooth, and Scale Smooth parameters.

••

Cut or trim the clip in the Timeline to remove the sections with the most shake. (You can
locate the sections with excessive shake in the Tags pane of the Timeline Index. Click the
individual Excessive Shake tags to select the corresponding ranges in the Timeline.)

••

Crop the edges of the stabilized video to remove the black bars.
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8

Edit audio

Audio overview

Final Cut Pro has many features designed to make processing and editing audio easier. For
example, you can analyze and automatically enhance audio to address problems such as noise
or hum, add effects to your clips, sync video and audio clips automatically, and match audio
between two clips.

Audio portion of a video clip

Audio-only clip

You can make the following changes to clips or to audio components within a clip:
••

Edit multiple audio channels: You can expand the audio portion of clips to reveal and edit
audio components down to the single channel level. This allows you to apply different effects
to different components or channels, and streamlines the process for making quick sound
cutouts or other adjustments. See Audio editing overview on page 170.

••

Adjust volume: Quickly adjust a clip’s volume directly in the Timeline or in the Audio inspector.
See Adjust volume on page 174.

••

Pan audio: Take advantage of built-in pan presets for both stereo and surround sound. See Pan
audio on page 179.

••

Add audio effects: Add Audio Units effects, Logic Effects, or custom effects included with
Final Cut Pro, such as reverb, to clips. See Add audio effects on page 190.

••

Add keyframes to automate volume and effects: Vary volume or effect settings as a clip plays. See
Adjust audio effects using keyframes on page 195.

••

Fade audio in or out: Fade audio in at the beginning or out at the end of a clip or an audio
component with easy-to-use fade handles. See Fade audio in or out on page 176.
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You use the same tools used for video editing when you edit audio clips in Final Cut Pro. The
following editing features are covered elsewhere in Final Cut Pro Help:
••

Change edit mode: Set the edit mode for a clip to video only or audio only. See Add clips using
video-only or audio-only mode on page 114.

••

Add markers to clips: Add markers to mark specific reference points within an audio clip. See
Markers overview on page 148.

••

Trim audio: Make precision edits to the audio waveform—for example, to take out an
unwanted sound in the recording. See Trimming overview on page 122.

••

Add audio crossfades: Create a smooth transition when connecting two separate audio
waveforms. See Add transitions to your project on page 214.

••

Use compound clips: Compound clips let you combine any video or audio clips into a single
compound clip. From an audio standpoint, compound clips let you apply the same audio
effect or enhancement to a group of clips, similar to applying an effect or adjustment to the
overall mix. See Compound clips overview on page 269.

••

Export audio: You can export your project as an audio file in either mono, stereo, or surround
sound. You can also export media by role. See Sharing projects overview on page 399.

Audio editing basics
About audio waveforms
Audio waveforms are visual representations of the actual sound. Audio waveforms appear in clips
in the following ways:
••

As the bottom portion of a video clip, colored blue

••

As a detached or an audio-only clip, colored green

Audio portion of a video clip

Audio-only clip

An audio waveform’s amplitude and length change according to the underlying sound’s volume
and duration. A short, loud sound such as a drum beat has a sharp, peaked waveform, whereas
low-level crowd noise has a lower, more uniform waveform. These properties make it easier to
find specific edit points when trimming clips or keyframing effects.
In Final Cut Pro, audio waveforms change according to a clip’s volume level or applied effects.
The waveform appears larger when the volume is high and smaller when the volume is low.
You edit audio clips in the Timeline by first listening to a clip’s audio through playback and
skimming, and then applying changes to the clip, using the waveform as a reference.
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About audio channels and audio components
Audio files can contain a single audio channel or multiple audio channels. Channels usually
correspond to microphone inputs during recording or to speakers for multichannel output. For
example, a stereo audio file usually contains left and right channels that match what you hear
from the left and right speakers during playback.
Final Cut Pro automatically groups channels into audio components according to how the
channels are configured for the clip. You can expand the audio portion of clips to view and edit
audio components down to the individual channel level. You can then make separate volume
or pan adjustments or apply and keyframe different audio effects for each component. For more
information, see Audio editing overview on page 170.
The number of audio components you see corresponds to the number of channels you’ve
configured in your source clip.
Note:  Many popular digital audio file formats, such as AAC and MP3, use interleaved stereo files,
which do not contain separate left and right channels. A stereo clip with interleaved left and
right channels appears as a single audio component in the Audio inspector and the Timeline. If
you change the clip’s channel configuration from Stereo to Dual Mono, the channels appear as
two separate audio components.

Audio components

For more information about configuring audio channels, see Configure audio channels on
page 171.

Ways to view audio clips
When you work with audio waveforms in the Timeline, you can zoom in or out or change the clip
appearance to make the waveform taller or shorter.
Final Cut Pro also includes several ways of viewing and working with audio and video within
clips. You can:
••

Expand a clip to view and edit audio components down to the individual channel level.

••

Expand a clip to see separate audio and video.

••

Detach audio from a video clip to work on the audio and video as separate clips.

••

Change the background appearance of a clip to show reference waveforms, which make it
easier to see audio waveforms when the volume is diminished.
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Show expanded audio components
You can expand the audio portion of clips in Final Cut Pro to view and edit audio components.
You can show expanded audio components for synchronized clips, multicam clips, and
compound clips.
Do one of the following:
mm Select the clip in the Timeline, and choose Clip > Expand Audio Components (or press
Control-Option-S).
mm Double-click the audio portion of the clip in the Timeline while holding down the Option key.

Normal clip view

Audio components

Collapse audio components
Do one of the following:
mm Select either the clip or one of its audio components in the Timeline, and choose Clip > Collapse
Audio Components (or press Control-Option-S).
mm Double-click any of the audio components in the Timeline while holding down the Option key.
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Show expanded audio and video
You can view audio and video separately in the same clip in the Timeline by expanding clips that
have both audio and video. This can be useful if you need to zoom in to the audio portion to
make edits.
Note:  If you create a split edit so that audio portions overlap, you won’t clearly see the
overlapped waveforms unless you choose to show expanded audio for split clips.
mm To expand a single clip: Double-click the audio waveform of the clip.
mm To expand a clip or clips you’ve selected in the Timeline: Choose Clip > Expand Audio/Video (or press
Control-S).
mm To expand all clips in the Timeline: Choose View > Expand Audio/Video Clips, and choose for all
clips or for split clips.
Normal clip view

Clip with expanded audio

When you show expanded audio, the audio and video portions of the clip remain attached to
each other. To create a separate connected audio clip, detach the audio. You can also use the
Precision Editor to see a detached view of the video and audio portions of the clip.
Collapse audio and video
You can collapse the expanded audio/video view for a single clip, multiple clips, or all clips in
the Timeline.
mm To collapse a single clip: Double-click the audio waveform of the clip.
mm To collapse a clip or clips you’ve selected in the Timeline: Choose Clip > Collapse Audio/Video (or
press Control-S).
mm To collapse all expanded clips in the Timeline: Choose View > Collapse All Clips.
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Detach audio from video
By default, Final Cut Pro imports audio and video from the same source into one clip. You
can easily detach the audio from a video clip so that you can edit the audio clip separately in
the Timeline.
mm Select the clip in the Timeline, and choose Clip > Detach Audio.
A new audio clip appears as a connected clip beneath the video clip.

Detached audio

To reattach an audio clip to its original video clip, you need to create a compound clip.
Show or hide reference waveforms
A reference waveform shows the maximum visual resolution possible for the actual audio
waveform. By factoring out loudness changes, reference waveforms let you see the details of the
sound more clearly.
1 Choose Final Cut Pro > Preferences, and click Editing.
2 Select the “Show reference waveforms” checkbox.

Reference waveform

When the actual waveform changes shape (for example, when it is diminished because a clip’s
volume level is low), its full reference waveform is still visible for easy reference when editing.
Tip:  You can place any clip with audio either above or below the primary storyline in the
Timeline. If your clip contains video and is placed below the primary storyline, the video may
be obscured by the video in the primary storyline, but the audio will play. If you put the clip
above the primary storyline, the audio plays and the video also plays (instead of the video in the
primary storyline).
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View audio waveforms at the audio sample level
For even more precise editing, you can zoom in to audio clips at the audio sample level. Audio
samples show the audio waveform at a fraction of a second (for example, 1/48,000 for audio
recorded at a sample rate of 48 kHz). Sample-accurate editing resolution is available only for
connected audio clips (that is, audio clips not in the primary storyline) or compound clips that
contain only audio.
Tip:  For reference when working with video, you can view subframes (1/80 the duration of a
video frame) in the timecode display of the Dashboard. In the General pane of Final Cut Pro
preferences, choose the subframe option in the Time Display pop-up menu.
Zoom to audio samples
1 Choose View > Zoom to Samples (or press Option-Z).
2 Select the clip in the Timeline.
3 Zoom in until the clip shows the waveform within the borders of a video frame.
Frame borders

You can continue to zoom in for closer detail of the waveform.
Frame borders

4 Make edits to the clip or adjustments to audio effects using keyframes.
To turn off zooming to audio samples, choose View > Zoom to Samples (or press Option-Z).
Navigate by subframe
1 In the Timeline or the Browser, move your pointer

over a clip and click.

2 Do any of the following:
••

To move backward in one-subframe increments: Press Command-Left Arrow.

••

To move forward in one-subframe increments: Press Command-Right Arrow.
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View and correct audio levels
The Audio meters let you see and track the audio levels of clips in Final Cut Pro and warn you if a
particular clip or section of a clip reaches peak levels, which may result in audible distortion.
The number of audio meters you see depends on how many channels are configured for the
clip you’re playing. For example, when you play back a surround clip in the Browser, six surround
audio meters are displayed, but if you drag that same clip into a stereo project in the Timeline,
Final Cut Pro automatically mixes down the surround audio into stereo, and only two audio
meters are displayed. For more information, see Configure audio channels on page 171.
When an audio clip is approaching peak levels during playback, the level color changes from
green to yellow.
When an audio clip exceeds peak levels, the level color changes from yellow to red, and the peak
indicator lights red for the respective audio channel or channels. The peak indicators reset when
you stop and start playback again.
To avoid having clip volume exceed peak levels, adjust the volume. Although the proper level
for a clip depends upon the overall mix you want, it’s important to make sure that the combined
level for all concurrent clips does not exceed 0 dB during the loudest sections.
Final Cut Pro includes two meters, a small Audio Meter icon in the Dashboard in the toolbar and
a larger Audio Meters pane.
Show or hide the Audio meters
To show the Audio meters, do one of the following:
mm Choose Window > Show Audio Meters.
mm Click the Audio Meter icon in the Dashboard in the toolbar.

You can drag the edges of the meters to see an expanded view with additional information.
Peak indicators

Level

Surround channels

To hide the Audio meters, choose Window > Hide Audio Meters, or click the Audio Meter icon in
the Dashboard in the toolbar.
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Reset and correct peak levels
mm Select the clip in the Timeline, readjust the level, and play back the clip again to test for peaks.
In the Timeline and Browser, the waveform section or sections of a clip turn yellow when a level
is approaching peak levels and red when a level exceeds 0 dB.

Solo and mute audio clips
The solo feature temporarily disables audio playback of all clips in the Timeline except for
selected ones. It is especially useful in audio editing if you have more than one audio clip layered
in the Timeline (dialogue and background music, for example) but need to listen and make edits
to just certain clips.
You can also mute clips by disabling them. Disabled clips are both invisible and silent and will
not appear in any output.
Solo clips in the Timeline
1 Select one or more clips in the Timeline.
2 Do one of the following:
••

Choose Clip > Solo (or press Option-S).

••

Click the Solo button in the Timeline.
Solo button

The soloed clip appears highlighted, while other clips appear dimmed.

Soloed clip

To turn off solo, click the Solo button, or choose Clip > Solo (or press Option-S) again.
Disable clips
1 Select one or more clips in the Timeline.
Note:  If the selected clips contain both video and audio, and you want to mute the audio only,
choose Clip > Detach Audio, and select the detached audio portion only.
2 Choose Clip > Disable (or press V).
Disabled clips are silent and appear dimmed in the Timeline.
3 To reenable the disabled clips, select them in the Timeline and choose Clip > Enable (or press V).
You can solo video clips in Final Cut Pro. For more information, see Solo, disable, and enable
clips on page 115.
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Add audio
Add music and sound
You can add music and sound files directly to your project from your iTunes library or
other sources.
Final Cut Pro also includes a number of built-in Foley and other sound effects that you can insert
as connected audio clips.
If you have a clip that contains both audio and video, you can change the edit mode to audio
only to insert only the audio portion of the clip.
Add music and sound to a project in the Timeline
1 Click the Music and Sound button in the toolbar.

2 In the Music and Sound Browser, choose a source folder from the pop-up menu at the top. For
example, choose iTunes to browse your iTunes collection.
Tip:  If the folder you’re looking for doesn’t appear, you can add it to the source list by dragging it
from the Finder or desktop to the Music and Sound Browser.
3 In the sound list that appears, find the sound or music you want:
••

To search for an item: Type text in the search field. To filter your search, click the Filter button
, and choose a filter.

••

To preview an item: Double-click the item, or select the item and click the Play button

••

To select more than one item: Command-click each item.

.

4 Drag the sound file or files to the Timeline.
Note:  For better import and playback performance, Final Cut Pro automatically transcodes
all MP3 audio files to WAV audio files and retains the original MP3 files for future use. For
information about where to find original and transcoded media files, see Locate source media
files on page 421.
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Record voiceovers and other audio
It’s easy to record voiceover narration or other live audio directly in Final Cut Pro from input
sources such as built-in and external microphones.
By default, Final Cut Pro includes an automatic countdown when you record, and also
automatically groups multiple takes into auditions so that you can quickly preview recordings
and choose the best one. The recorded audio files appear both in the Browser and as connected
clips in the Timeline.
Record live audio
1 Position the playhead where you want to start recording in the Timeline.
2 Choose Window > Record Voiceover.
Tip:  To start recording immediately without adjusting settings, press Option-Shift-A and go to
step 7.
Click the Record button
to start or stop recording.

3 To adjust the input level of the microphone, do one of the following:
••

Drag the Input Gain slider right to increase the input level, or left to decrease it.

••

Type a dB value in the Input Gain field.

Use the Audio meter to make sure the volume doesn’t exceed peak levels (colored red), which
may result in audible distortion.
Note:  If the Input Gain slider is dimmed for a selected input device, try adjusting the gain on the
device itself or its software utility (if available).
4 To name your voiceover clip, click the Name field and type a new name.
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5 To specify other voiceover settings, click the Advanced disclosure triangle and do any of the
following:
••

To change the input device or the number of input channels (mono or stereo): Choose an option
from the Input pop-up menu. The default choice of System Setting uses the first channel of
the input device currently selected in OS X Sound preferences.
Tip:  If you always want to record with a particular device or a particular channel on a
multichannel audio device, choose that device/channel pair from the Input pop-up menu
instead of System Setting. Final Cut Pro remembers the setting and indicates in the Input
pop-up menu whether the device is available.

••

To listen to your microphone input as you record: Set Monitor to On. The microphone audio plays
from the output device currently selected in OS X Sound preferences. There is no input signal
when monitoring is off.
Tip:  To listen to a live mix of both microphone and project audio, set Monitor to On and
deselect the “Mute project while recording” checkbox below.

••

To adjust the monitoring level: Drag the Gain slider right to increase the monitoring level, or left
to decrease it (or type a dB value in the Gain field).
Note:  If the built-in microphone is selected, the Gain slider automatically resets to zero to
prevent feedback from the built-in speakers when monitoring is turned on. To avoid feedback,
use headphones or external speakers placed away from the microphone.

••

To turn off the automatic countdown before recording: Deselect the “Countdown to record”
checkbox.

••

To unmute project audio while recording: Deselect the “Mute project while recording” checkbox.

••

To turn off automatic grouping of multiple voiceover takes into auditions: Deselect the “Create
Audition from takes” checkbox.

••

To change where the recording is saved: Choose an event in the current library from the Event
pop-up menu.

6 To start recording, click the Record button (or press Option-Shift-A).
7 To stop recording, click the Record button (or press the Space bar or Option-Shift-A).
Your audio recordings are attached to the primary storyline at the playhead position.
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Record multiple voiceover takes
You can record multiple versions, or “takes,” of voiceover recordings for the same section of your
project. By default, Final Cut Pro creates an audition from all the takes you record. After you’ve finished
recording, you can review the different takes in the audition and choose the one you want to use.
1 To record your first voiceover take, follow the instructions above.
2 Without moving the playhead, click the Record button (or press Option-Shift-A) to record
another take for the same section of your project.
3 To stop recording, click the Record button again (or press the Space bar or Option-Shift-A).
By default, Final Cut Pro creates an audition containing both recordings.

Voiceover audition clip

To add another take to the audition, repeat steps 2 and 3. Each new take you record is added to
the audition.
To learn more about auditions, see Add and remove clips in auditions on page 295.
Preview and select a voiceover take
1 In the Timeline, select the audition containing the voiceover takes you want to review, and open
it by choosing Clip > Audition > Open (or pressing Y).

Click to preview different voiceover
takes, then select one to use.

2 In the audition window, select the take and press the Space bar (or press Control-Command-Y)
to play it.
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3 When you decide on the take you want to use, make sure it’s selected under the spotlight, and
click Done.
4 If you’re sure of your decision and want to finalize the audition, choose Clip > Audition > Finalize
Audition (or press Option-Shift-Y).
The audition is dissolved, leaving the voiceover clip in the Timeline.
To learn more about previewing auditions, see Use auditions to try out clips in your project on
page 297.
Combine audio from multiple takes
By default, an audition lets you choose only one voiceover take to use in your project. If you want
to combine portions of two separate takes into one “comp” take, you can break the audition into
separate audio clips, which you can then edit and combine as needed.
1 Select an audition in the Timeline, and choose Clip > Break Apart Clip Items (or press
Shift-Command-G).
Final Cut Pro replaces the audition selected in the Timeline with the individual recordings that
made up the audition.

To edit voiceover
takes separately,
break apart the
audition clip.

2 Edit the clips as needed.
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Edit audio clips or audio components
Audio editing overview
Final Cut Pro includes tools for editing audio clips or multiple audio channels. You edit audio in
two ways, detailed below.

Volume control

Clip-level audio editing
You can make audio adjustments and edits to whole clips. At this level, audio adjustments and
effects are applied to the entire clip, including any audio channels within the clip. Final Cut Pro
preserves any adjustments you make to individual audio channels. This means that if you reduce
the volume for a single channel but raise the volume for the whole clip, the volume of the single
channel is raised but stays in proportion to the volume of other channels in the clip.
If your source media contains only one or two audio channels or you’re editing an audio-only
clip, you’ll probably only need to make adjustments and edits at this level.
Advanced multichannel audio editing
Final Cut Pro automatically groups channels into audio components according to how the
channels are configured for the clip. You can expand the audio portion of clips to reveal and edit
audio components down to the individual channel level. This allows you to apply different effects
to different components and streamlines the process for making quick sound cutouts to a single
microphone input or other fine adjustments.
Important:  Many digital audio file formats, such as AAC and MP3, use interleaved stereo files,
which do not contain separate left and right channels. These files appear as a single audio
component unless you change the clip’s channel configuration.
Keep in mind the following when editing audio components in Final Cut Pro:
••

You view and change the audio channel configuration of your clips in the Audio inspector.
You can change audio component names, add or remove audio components, and configure
channels in mono, stereo, and surround formats. See Configure audio channels on page 171.

••

With the Range Selection tool (the default editing tool), you can quickly select ranges within
an audio component to target the audio you want to edit.

••

You can edit audio components for synchronized clips, multicam clips, and compound clips.

••

You edit audio components in the same way you edit whole clips. You can:
••

Skim individual components when clip skimming and audio skimming are turned on. See
Skim media on page 80.

••

Adjust the volume of a component. See Adjust volume on page 174.
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••

Mute a component’s audio by disabling all or a portion of the component. This is the fastest
way to remove unwanted sounds from a component. See Solo, disable, and enable clips on
page 115.

••

Use fade handles to fade audio in at the beginning or out at the end of an audio
component. See Fade audio in or out on page 176.

••

Pan the sound for individual components. See Pan audio on page 179.

••

Assign a role such as Dialogue, Music, or Effects to a component in the Info inspector (or by
using the Modify menu when the clip that contains the audio component is in the Timeline).
See Use roles to organize clips and export audio files on page 189.

••

Add or adjust audio effects for individual components. See Add audio effects on page 190 or
Adjust audio effects on page 192.

••

Adjust audio effects for individual components using keyframes. See Adjust audio effects
using keyframes on page 195.

For examples of multichannel audio editing workflows, see Multichannel audio editing
examples on page 183.

Configure audio channels
Final Cut Pro assigns a default channel configuration for audio clips when they are imported
or added to a project. You can change the channel configuration if, for example, you want to
convert a stereo dialogue clip to two mono channels.
Final Cut Pro automatically groups channels into audio components according to how the
channels are configured for the clip. For more information, see About audio channels and audio
components on page 158.
In addition to changing the channel configuration, you can view and listen to audio components,
add or remove audio components from a clip, and rename audio components.
Change the channel configuration
The number of channel options you can configure depends upon how many channels are in
your source clip or compound clip. You can configure channels in several formats, including:
••

Mono: Single channel. In a surround sound setup, you can assign a mono channel to any
surround channel.

••

Stereo: Left and right channels.

••

5.1 surround: Left, center, right, left surround, right surround, and low-frequency effects
(subwoofer bass) channels.

••

7.1 surround: Left, center, right, left surround, right surround, left back, right back, and lowfrequency effects (subwoofer bass) channels.

If you configure more than six surround channels, Final Cut Pro automatically adjusts the channel
mix down to 5.1 surround during playback.
Important:  Changing the channel configuration resets all adjustments and edits made to audio
components (including applied effects, disabled ranges, keyframe adjustments, and custom
names).
1 Select the clip in the Timeline.
2 In the Channel Configuration section of the Audio inspector, choose an option from the
Channels pop-up menu.
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The channels appear in the Audio inspector as separate audio components, each with its
own waveform.

If you have a clip with surround channels and want to assign a mono channel to a specific
surround channel, select the mono channel waveform and choose a surround channel from the
Channels pop-up menu.
Note:  To change the channel configuration of a compound clip, first deselect Use Event Clip
Layout from the Channels pop-up menu, and then choose another configuration.
To reset a configuration, click the Reset button

.

View and listen to an audio component
1 Select the clip in the Timeline.
2 In the Channel Configuration section of the Audio inspector, click the disclosure triangle next to
the clip name to reveal its audio components, and then skim over a component or play it back
using the Space bar or the J, K, and L keys.

Skim to preview.

Add or remove an audio component
You can add or remove audio components in a clip. For example, you may want to remove
unused components from a clip, or add components from inactive angles to the active angle in a
multicam clip.
By default, all active audio components in a clip appear as selected in the Audio inspector and
are arranged in the same order when the clip is expanded to show audio components in the
Timeline. To learn more about viewing audio components, see Ways to view audio clips on
page 158.
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When you remove an audio component, it appears dimmed in the Audio inspector but is
removed from the clip’s component arrangement in the Timeline.
1 Select the clip in the Timeline.
2 In the Channel Configuration section of the Audio inspector, click the disclosure triangle next to
the clip name to reveal the clip’s audio components.
3 Do one of the following:
••

To remove a component: Deselect the checkbox next to a component waveform.

••

To add a component: Select the checkbox next to a component waveform.

Select to add or remove
an audio component.

Rename a component
Do one of the following:
mm In the Channel Configuration section of the Audio inspector: Click the disclosure triangle next to the
clip name to reveal the clip’s audio components, and then double-click a component’s name and
type a new name.

Type a new audio
component name
in the field.

mm In a clip in the Timeline with expanded audio components shown: Control-click the audio
component, choose Rename Component from the shortcut menu, and type a new name.
To learn more about viewing audio components, see Ways to view audio clips on page 158.
Important:  If you subsequently change the channel configuration, all custom audio component
names are reset to the original name.
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You can also choose a channel configuration when exporting roles as audio stems for mixing or
post-production. For more information, see Use roles to organize clips and export audio files on
page 189. If you choose an export file channel configuration that is different from that of your
source files, the channels are exported in the following ways:
••

Stereo source exported as surround: The left and right channels are exported to the left and
right channels of the surround file.

••

Surround source exported as stereo: The surround source is exported as a stereo (left and right
channel) mix.

••

Stereo or surround source exported as mono: The stereo or surround source is exported as a
mono (one channel) mix.

Adjust volume
You can adjust the volume levels of audio clips from the Browser, the Timeline, the Audio
inspector, or the Modify menu. Volume adjustments you make in the Audio inspector or from
the Modify menu are applied to the entire selection. To make more precise adjustments, you
can create keyframes in the clip, and then make adjustments to points between keyframes. See
Adjust audio effects using keyframes on page 195.
You can make sure the volume doesn’t exceed peak levels, which may result in audible distortion,
by using the Audio meters.
Adjust volume in the Timeline
mm Drag the volume control (the horizontal line across the audio waveform) up or down.
As you drag, the level reading in dB appears, and the waveform changes shape to reflect
your adjustments.

Volume control

If you adjust the volume between two keyframes, the volume line slopes to show the change in
volume between the keyframes.
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Adjust volume from the Modify menu or the keyboard
1 Select one or more audio clips or video clips with audio in the Timeline.
2 Do one of the following:
••

To adjust the volume in +1 or –1 dB increments: Choose Modify > Adjust Volume, and choose Up
or Down, or press Control–Equal Sign (=) or Control-Hyphen (-).

••

To adjust the volume using an absolute dB value: Choose Modify > Adjust Volume > Absolute (or
press Control-Option-L).
The Dashboard display changes to show Absolute dB.
To change the volume, type
a positive or negative dB value.

Click to change to
Relative volume.

Type a positive or negative value to change the absolute volume. The volume across the entire
selection is set to one dB level, and any keyframe adjustments are deleted.
••

To adjust the volume using a relative dB value: Choose Modify > Adjust Volume > Relative (or
press Control-L).
The Dashboard display changes to show Relative dB.
To change the volume, type
a positive or negative dB value.

Click to change to
Absolute volume.

Type a positive or negative value to change the relative volume. The volume is adjusted by the
same amount throughout the selection, preserving any fades or other keyframe adjustments.
If multiple clips are selected, the volume is adjusted for all clips.
Adjust volume in the Audio inspector
1 Select one or more audio clips or video clips with audio in the Browser or the Timeline.
2 In the Audio inspector, do one of the following:
••

Enter a value in the Volume field.
If multiple clips are selected, the volume for all clips is set to the value you entered.

••

Drag the Volume slider right to increase the volume, or left to decrease it.
If multiple clips are selected, the volume for all clips is adjusted relative to each clip’s
original volume.

Volume slider
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Adjust volume automatically across a selected area
For volume adjustments of a clip in the Timeline, you can use the Range Selection tool to add
keyframes automatically across a selected range.
1 Select the clip in the Timeline.
2 Choose Range Selection from the Tools pop-up menu in the toolbar (or press R).

The pointer changes to the Range Selection tool icon

.

3 Drag across the area where you want to adjust the volume.
4 Adjust the volume within the range by dragging the horizontal control up or down.
Keyframes are automatically created along the adjustment points within the range.
Reset all volume adjustments
1 Select an audio clip or video clip with audio in the Browser or the Timeline.
2 Click the Reset button

in the Volume and Pan section of the Audio inspector.

Fade audio in or out
There are several ways to create fade-ins or fade-outs on the audio portion of a clip or an audio
component in Final Cut Pro:
••

Automatic crossfades during transitions: When you add a transition to a video clip with attached
audio, Final Cut Pro automatically applies a crossfade transition to the audio. If the audio is
detached or expanded from the video, the audio is not affected by the video transition. See
Add transitions to your project on page 214.

••

Crossfades: When trimming the audio waveform in clips, you can apply a crossfade to the edit
point. See Trimming overview on page 122.

••

Fade handles: You can quickly create fade-ins and fade-outs on the audio portion of a clip or an
audio component in the Timeline by using fade handles, which appear in the top-left or topright corner of the audio waveform when you place the pointer over the clip.

Fade handle
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You can also change the fade’s shape by choosing one of several predefined options.
Changing the fade shape changes the sound of the fade.
Note:  Fades created using fade handles override crossfades created by a transition.
Create a fade using fade handles
mm Drag the fade handle to the point in the clip where you want the fade to begin or end.
Fade handles from the beginning of a clip create a fade-in, while fade handles at the end of a clip
create a fade-out.

Fade-in

Fade-out

Fades complement any volume adjustments you’ve already made to a clip. For example, if you
previously adjusted the volume lower at the beginning of a clip, the fade-in increases the volume
from silence (–∞ dB) to the level you’ve already specified.
Create a crossfade manually using fade handles
1 Select two adjacent clips in the Timeline, and choose Clip > Expand Audio/Video (or press Control-S).
The clips appear expanded.

2 Drag the end point of the first clip to the right and the start point of the second clip to the left
so that the audio portions of the clips overlap.
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Note:  Make sure to adjust the audio overlap to the length you want.

3 Drag the fade handles of each clip to the points where you want the fade to begin and end.

Crossfade

Fade handle

To change the fade shape for each clip, follow the instructions immediately below.
Change the fade shape when using fade handles
mm Control-click a fade handle, and choose a fade option from the shortcut menu:
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••

Linear: Maintains a constant rate of change over the length of the fade.

••

S-curve: Eases in and out of the fade with the midpoint at 0 dB.

••

+3dB: Starts quickly and then slowly tapers off toward the end. This is the most useful setting
for quick fades.

••

–3dB: Starts slowly and then moves quickly toward the end. This is the default setting and is
best for maintaining a natural volume when crossfading between two adjacent clips.

Change the fade shape of a transition crossfade
1 Select a transition in the Timeline, and do one of the following:
••

Choose Window > Show Inspector (or press Command-4).

••

Click the Inspector button in the toolbar.

2 In the Audio Crossfade section of the Transition inspector, choose a fade option from the Fade In
Type and Fade Out Type pop-up menus:
••

Linear: Maintains a constant rate of change over the length of the fade.

••

S-curve: Eases in and out of the fade with the midpoint at 0 dB.

••

+3dB: Starts quickly and then slowly tapers off toward the end. This is the most useful setting
for quick fades.

••

–3dB: Starts slowly and then moves quickly toward the end. This is the default setting and is
best for maintaining a natural volume when crossfading between two adjacent clips.

Pan audio
Panning audio lets you distribute sound across the stereo or surround spectrum to create
balance or a special effect. For example, you can place more sound in the right channel of a
stereo clip or less sound in the center channel of a surround clip.
Final Cut Pro includes a built-in surround sound decoder that lets you choose among several
stereo and surround preset pan modes that you can apply to clips from the Audio inspector.
Using the pan mode presets, you can dynamically re‑create surround sound fields from stereo
source content.
Note:  To display surround channels in the Audio meters, make sure you set your project’s audio
and render properties to surround before you decode stereo content to surround channels. For
more information, see Modify a project’s settings on page 89.
When you change the pan mode in the Audio inspector, the setting is applied to the entire
selection. To make more precise adjustments, you can add keyframes using the Audio Animation
Editor or the Audio inspector, and then make adjustments to them in the Audio inspector.
Pan audio for stereo
1 Select the audio clip.
2 In the Audio inspector, choose Stereo Left/Right from the Pan Mode pop-up menu.
3 Move the sound left or right by doing one of the following:
••

Type a value in the Pan Amount field.

••

Drag the Pan Amount slider left or right.
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Pan audio for surround sound
1 Select the audio clip.
2 In the Audio inspector, choose one of the following options from the Pan Mode pop-up menu:
••

Basic Surround: Positions the signal in its default channels, with a stereo signal in the right
and left channels, and a mono signal in the center channel. The Pan Amount slider setting
distributes portions of the signal to other channels and can be adjusted from –100 (left
channels) to 100 (right channels).

••

Create Space: Distributes the signal across the surround spectrum, with more signal to the
center and front left and right channels. This setting is useful for making a general-purpose
surround mix from any stereo source. The Pan Amount slider setting can be adjusted from 0
(no effect) to 100 (total surround field).

••

Dialogue: Pans more signal to the center channel of the surround spectrum so that the direct
sound is in the center, while ambient sound is distributed to the other channels. This setting is
best used for voiceover or other dialogue clips. The Pan Amount slider setting can be adjusted
from 0 (no effect) to 100 (all sound to the center channel).

••

Music: Distributes a stereo mix signal evenly across the surround spectrum. This setting is best
used for converting stereo music to a surround mix. The Pan Amount slider setting can be
adjusted from 0 (no effect) to 100 (total surround field).

••

Ambience: Pans across the surround spectrum with more signal toward the surround channels
and less signal to the front and center channels. This setting is useful for effects such as crowd
noise or other outdoor environments. The Pan Amount slider setting can be adjusted from 0
(no effect) to 100 (total surround field).

••

Circle: Pans the sound in a circle around the surround spectrum like a bee buzzing around the
listener’s head. The Pan Amount slider adjusts the direction to the listener in degrees (–180 to 180).

••

Rotate: Pans around the surround spectrum as if the listener is turning in a circle. The Pan
Amount slider adjusts the listener rotation in degrees (–180 to 180).

••

Back to Front: Pans from back to front across the surround spectrum. The Pan Amount slider
setting can be adjusted from –100 (back) to 100 (front).

••

Left Surround to Right Front: Pans from left surround to right front across the surround
spectrum. The Pan Amount slider setting can be adjusted from –100 (left surround) to 100
(right front).

••

Right Surround to Left Front: Pans from right surround to left front across the surround
spectrum. The Pan Amount slider setting can be adjusted from –100 (right surround) to 100
(left front).

3 If you want to adjust the pan amount, do one of the following:
••

Type a value in the Pan Amount field.

••

Drag the Pan Amount slider left or right.

The Pan Amount settings vary according to the pan mode you choose.
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Adjust surround sound using the Surround Panner
In the Audio inspector, you can use the Surround Panner to change the surround sound field or
make advanced adjustments using sliders.
Using the Surround Panner, you can change the panning levels by moving a control
that represents where the sound would appear to originate in an actual surround sound
speaker setup.
1 Choose a surround preset from the Pan Mode pop-up menu.
2 To open the Surround Panner, click the disclosure triangle next to Surround Panner in the
Volume and Pan section of the Audio inspector.

Click to display the
Surround Panner.

3 Do any of the following:
••

To make adjustments in the Surround Panner: Drag the control within the surround field to pan
toward or away from any of the surround channels (left, center, right, left surround, or right
surround) represented by the speaker icons. Click a speaker icon to turn it on or off.

Drag to move the
sound source.

To move the control back to the center position, double-click it.
••

To make advanced adjustments: Click the Advanced disclosure triangle below the Surround
Panner, and drag the sliders left or right for any of the following parameters:
••

Original/Decoded: Adjusts the balance between the original and decoded signals. The slider
can be adjusted from –100 (original signal only) to 100 (decoded center and surround signals
only). At 0, the signal is balanced evenly between the original and decoded signals.

••

Ambient/Direct: Adjusts the balance between decoded surround and center signals. The
slider can be adjusted from –100 (surround signal only) to 100 (center signal only). At 0, the
signal is balanced evenly between the center and surround signals.
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••

Surround Width: Specifies how much separation (in dB) is between the decoded surround
signals. At 0 dB, there is complete separation between the center and surround signals, but
each surround signal is mono. To increase the stereo effect in the left and right surround
channels, you can increase the parameter value. This also results in some signal being
diverted from the center channel to the surround channels.

••

LFE Balance: Adjusts the low-frequency effects (subwoofer) signal from –1 (no signal sent to
the LFE channel) to 1 (all signal sent to the LFE channel). When the slider is centered at 0, the
signal is distributed evenly among the five channels and the LFE channel.

••

Rotation: Rotates all surround signals to the left or right in a circular manner. When the slider
is at the extreme left or right (–180 degrees or 180 degrees, respectively), the surround signal
is rotated to the center channel and the center signal is rotated to the surround channels. At
0 degrees (the center of the slider), there is no rotation.

••

Stereo Spread: Adjusts the amount of stereo effect from the left and right channels to the
center and surround speakers.

••

Attenuate/Collapse: Adjusts the way the panning effect is implemented. At 0, the source
signals are attenuated (meaning that the original channel signals get louder and softer
but are not actually diverted to other channels). At 100, the source signals are collapsed
(meaning that the original channel signals aren’t changed in volume, but instead are moved
to other channels in the panning direction).

••

Center Balance: Adjusts the balance between the center and surround signals. The slider can
be adjusted from –100 (all center signal sent to the surround channels) to 100 (all surround
signals sent to the center channel). At 0, the signal is balanced evenly between the center
and surround channels.

When you make adjustments to advanced parameters, the Pan Mode indicates that it has
been edited.
Reset pan adjustments
mm To reset an edited pan mode: Choose another preset from the Pan Mode pop-up menu. The Pan
Amount slider is not affected.
mm To reset adjustments to the Surround Panner only: Click the Reset button
section of the Audio inspector.
mm To reset all adjustments: Click the Reset button
Audio inspector.

in the Surround Panner

at the top of the Volume and Pan section of the

You can monitor stereo and surround sound channel levels using the Audio meters.
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Multichannel audio editing examples
Below are examples of some multichannel audio editing workflows in Final Cut Pro.
Example: Remove unwanted noise from a specific audio component
Note:  To skim audio for an individual audio component, make sure both clip skimming and
audio skimming are turned on. For more information, see Skim media on page 80.
1 Select a clip in the Timeline, and choose Clip > Expand Audio Components (or press
Control-Option-S).

Audio components

2 Skim or play back the audio component to find the specific place where the noise occurs.
3 Drag within the component to select the range where the noise occurs.
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4 Do one of the following:
••

To disable the portion of the component where the noise occurs: Press the V key (or press the
Delete key).
Disabling a selected range mutes all sound within the range. To unmute (enable) the range,
press the V key (or press Command-Z).
Note:  When you disable a range in an audio component, fade handles become available on
either side of the disabled range. For more information on fade handles, see Fade audio in or
out on page 176.

••

To adjust the volume within the range: Drag the horizontal control up or down.

Keyframes are automatically created along the adjustment points within the range.

5 Play back the clip to listen to your adjustments.
6 To collapse the audio components after you complete your adjustments, choose Clip > Collapse
Audio Components (or press Control-Option-S).
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Example: Trim audio within an audio component
1 Select a clip in the Timeline, and choose Clip > Expand Audio Components (or press
Control-Option-S).

Audio components

2 Position the pointer at the edge of the audio component you want to trim.
The pointer changes to the Trim tool icon

.

3 Drag to trim that section.
The trimmed section is disabled (muting all sound in that section) and appears dimmed in
the Timeline.
To undo your trim, press Command-Z.

4 Play back the clip to listen to your adjustments.
5 To collapse the audio components after you complete your adjustments, choose Clip > Collapse
Audio Components (or press Control-Option-S).
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Example: Make a roll edit to all audio components
1 Select a clip in the Timeline, and choose Clip > Expand Audio Components (or press
Control-Option-S).

Audio components

2 Position the pointer at the edge of the audio portion of the clip you want to roll.
The pointer changes to the Trim tool icon

.

3 Hold down the Shift key and drag to roll back the edit point for the audio portion of the clip.
The edit point is rolled to the new location, cutting the audio at the end of the clip. The video
portion of the clip is not affected.
To undo your edit, press Command-Z.

4 Play back the clip to listen to your adjustments.
5 To collapse the audio components after you complete your adjustments, choose Clip > Collapse
Audio Components (or press Control-Option-S).
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Example: Add or remove audio components in a multicam clip
When you create a multicam clip that contains multiple audio components, you can use the
Angle Viewer or the Audio inspector to add audio components from inactive angles to the active
angle. This makes it easy to add audio from different source clips in your multicam clip while
maintaining the active video angle. You can also remove audio components from the active
angle to eliminate unwanted or unused audio.
Before you start, you can make adjustments to the channel configuration of audio components
in your source clips in the Browser using the Audio inspector. For more information, see
Configure audio channels on page 171.
1 Drag a multicam clip from the Browser to the Timeline.
2 To open the Angle Viewer, do one of the following:
••

Choose Window > Viewer Display > Show Angles (or press Shift-Command-7).

••

Choose Show Angles from the Viewer Options pop-up menu in the top-right corner of
the Viewer.
The active angle appears highlighted in yellow.
Active angle
in the Angle Viewer

3 To enable audio-only switching in the Angle Viewer, click the right switch mode button in the
upper-left corner.
Click to enable
audio-only switching.

4 To open the Audio inspector, do one of the following:
••

Choose Window > Show Inspector (or press Command-4), and click the Audio button at the
top of the Inspector pane.

••

Click the Inspector button in the toolbar (shown below), and click the Audio button at the top
of the Inspector pane.

The audio corresponding to the active angle in the Angle Viewer appears highlighted in the
Channel Configuration section of the Audio inspector.
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5 To reveal the audio components for the active angle, click the disclosure triangle next to the
active angle’s source clip name.

Click to reveal audio components
for the active angle.

6 To add audio components from inactive angles, do one of the following:
••

In the Angle Viewer: Hold down the Command and Option keys and click an inactive angle
or angles.

••

In the Audio inspector: Select the checkbox next to each audio component you want to add.

In this example, the angle whose audio you added is highlighted in green in the Angle Viewer,
and the audio components you added are highlighted in the Audio inspector.
Audio components
added to the active angle

Audio components
added to the active angle

Chapter 8    Edit audio

188

The added audio components also appear in the multicam clip’s component arrangement in the
Timeline. (To show expanded audio components, choose Clip > Expand Audio Components, or
press Control-Option-S.)

Audio components
added to the Timeline

7 To remove an audio component from the active angle, do one of the following:
••

In the Angle Viewer: Hold down the Command and Option keys and click the angle (highlighted
in green) whose audio you want to remove.

••

In the Audio inspector: Deselect the checkbox next to the audio component you want
to remove.

When a component is removed, it appears dimmed in the Audio inspector and the angle is
no longer highlighted in green in the Angle Viewer. The component also disappears from the
multicam clip’s component arrangement in the Timeline.

Use roles to organize clips and export audio files
Final Cut Pro assigns an audio role (Dialogue, Music, or Effects) to the audio portion of all clips
on import.
Role assignments make it easy to organize clips by audio type, but their most powerful benefit
is the ease with which you can export separate files (called media stems) from Final Cut Pro for
all dialogue, music, or effects clips. This process is often used when delivering stems to match
broadcast specifications or when handing off stems for mixing or post-production.
You can use roles for the following workflows:
••

Reassign roles: You can view and reassign clip roles in the Timeline Index, the Browser, the Info
inspector, or the Modify menu. You can also view and reassign a role for an audio component
in the Info inspector (or by using the Modify menu when the clip that contains the audio
component is in the Timeline). See View and reassign roles on page 318. You can also create
custom roles and subroles to further organize your clips.

••

View and organize clips by role: In the Timeline Index, you can organize clips by role, turn roles
on or off, and highlight or minimize clips for viewing in the Timeline. For example, you could
easily identify all your dialogue clips and play them back in isolation from other audio clips.
See View clips by role in the Timeline on page 324.

••

Export media stems: You can export roles as media stems in a combined, multitrack QuickTime
file, or as separate audio or video files. During the export process you can assign mono, stereo,
or surround output for your audio channels. See Sharing projects overview on page 399.
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Add and adjust audio effects
Add audio effects
In addition to the built-in audio enhancement features of Final Cut Pro, you can take advantage
of 64-bit OS X built-in and third-party Audio Units (AU) effects for your audio processing tasks.
Final Cut Pro also comes with an extensive range of custom audio effects and professional Logic
Effects, which are digital signal processing (DSP) effects and processors that are used to color or
tonally shape existing audio recordings and audio sources—in real time.
Some of the most common processing options include noise reduction, pitch correction,
EQs, dynamic processors, and reverbs. Further advanced features include delays, modulations,
distortions, bass enhancement, and time-altering processors and utilities. Some custom effects
included with Final Cut Pro combine multiple effects to create a particular sound environment,
such as a cathedral.
You can add effects to individual clips or to a compound clip. Once you add an effect, you can
adjust its settings using the Audio inspector.
Add audio effects to a clip
1 Click the Effects button in the toolbar.

2 In the Effects Browser, select an audio effect, and do any of the following to help you make the
selection:
••

To preview what the effect sounds like using the audio from the currently selected Timeline clip:
Move the pointer over the audio effect thumbnails.

••

To preview changing the effect’s primary control: Hold down the Option key while moving the
pointer over an audio effect thumbnail.

••

To filter the list of effects that appear: Type text in the Effects Browser search field.

3 Do one of the following:
••

Drag the effect to an audio clip (or a video clip with audio) in the Timeline.

••

Double-click the effect icon to apply it to the selected clip.

The effect appears in the Effects section of the Audio inspector and in the Audio Animation
Editor. You can now adjust the effect.
Turn off a clip effect
After you apply an audio effect to a clip, you can turn off the effect (but retain its settings) in the
Audio inspector or the Audio Animation Editor.
1 Select the clip with the effect in the Timeline.
2 Do one of the following:
••

In the Effects section of the Audio inspector, select the effect and click its blue checkbox.

••

In the Audio Animation Editor, select the effect and click its green checkbox.
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Remove a clip effect
After you apply an audio effect to a clip, you can remove the effect from the clip in the Audio
inspector or the Audio Animation Editor.
1 Select the clip with the effect in the Timeline.
2 Do one of the following:
••

In the Effects section of the Audio inspector, select the effect and press Delete.

••

In the Audio Animation Editor, select the effect and press Delete.

Change the order of effects
After you apply audio effects to a clip, you can change the order in which they appear in the
Audio inspector or the Audio Animation Editor.
1 In the Timeline, select a clip for which you’ve added effects.
2 Do one of the following:
••

In the Effects section of the Audio inspector, drag an effect up or down.

••

In the Audio Animation Editor, drag an effect up or down.

Copy all of a clip’s effects to another clip
You can copy effects and their settings from one clip to another. This can be especially useful if
you’ve made adjustments to effects in a clip that you want to preserve and use with other clips.
1 Select a clip in the Timeline, and choose Edit > Copy (or press Command-C).
2 Select the clip or clips to which you want to apply the effects, and choose Edit > Paste Effects (or
press Option-Command-V).
If a clip has more than one effect applied to it, all of the effects and their settings are applied to
the other clip.
Copy selected clip attributes to another clip
You can copy a clip’s audio attributes, such as settings and effects, from one clip to another.
For example, you can copy pan settings, or any effects you’ve added to a clip, including any
keyframe adjustments.
This feature lets you select which clip attributes you want to apply.
1 Select a clip in the Timeline, and choose Edit > Copy (or press Command-C).
2 Select the clip or clips to which you want to apply the attributes, and choose Edit > Paste
Attributes (or press Shift-Command-V).
3 Do any of the following:
••

To apply all audio attributes from the source clip: Select the Audio Attributes checkbox.

••

To apply individual attributes: Select the checkbox or checkboxes for each attribute you want
to apply.
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••

If you made any keyframe adjustments to the source clip: Choose either Maintain Timing or
Stretch to Fit from the Keyframes pop-up menu. If you choose Stretch to Fit, Final Cut Pro
adjusts the keyframes in time to match the duration of the destination clip.

4 Click Paste.
For more information about using the Logic Effects that are included with Final Cut Pro, see the
Final Cut Pro X Logic Effects Reference at http://help.apple.com/finalcutpro-logiceffects/mac.

Adjust audio effects
You can adjust an effect’s parameters using controls in the Audio inspector or the effect’s window.
If you’re using Audio Units effects or Logic Effects, you can show an expanded interface by
opening the effect’s window.
For more information about using the Logic Effects that are included with Final Cut Pro, see the
Final Cut Pro X Logic Effects Reference at http://help.apple.com/finalcutpro-logiceffects/mac.
Adjust an audio effect
1 In the Timeline, select the clip with the effect you want to adjust.
2 Locate the effect in the Effects section of the Audio inspector.

Controls button
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3 To see an effect’s parameters, do one of the following:
••

Click the Controls button (to the right of the effect’s name) to show a larger window with
advanced controls.

••

Click the disclosure triangle next to Parameters to show controls in the Audio inspector.

Tip:  You can adjust effects over time using keyframes in the Audio inspector or in the Audio
Animation Editor.
4 Select effect parameters and adjust their settings as needed. You can preview your adjustments
by using the skimmer or playing the clip in the Timeline.
To return the effect’s values to their default settings, click the effect’s Reset button

.

Use effect presets
Many Audio Units and Logic effects include built-in presets that are tailored for specific settings
or environments, such as reverb presets that simulate the acoustics of a small room or a large
cathedral. Presets make it easy to preview and apply effects quickly.
1 Locate the effect in the Effects section of the Audio inspector.
2 Choose a preset from the Preset pop-up menu.

You can preview your presets by using the skimmer or playing the clip in the Timeline.
To return the effect to its default settings, choose Default from the Preset pop-up menu.
Edit and save custom presets
You can edit preset parameters by adjusting the effect’s controls. If you want to keep your
changes, you can save them as as a custom preset.
1 Locate the effect in the Effects section of the Audio inspector.
2 Choose a preset from the Preset pop-up menu.
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3 To see an effect’s parameters, do one of the following:
••

Click the Controls button (to the right of the effect’s name) to show a larger window with
advanced controls.

••

Click the disclosure triangle next to Parameters to show controls in the Audio inspector.

4 Select effect parameters and adjust their settings as needed. You can preview your adjustments
by using the skimmer or playing the clip in the Timeline.
When you adjust a preset’s parameters, the Preset pop-up menu indicates that the preset has
been edited.

Edited preset

5 To save an edited preset, choose Save Preset from the Preset pop-up menu, and type a name for
the new preset.

Saved presets appear in the Preset pop-up menu.

To return the effect to its default settings, choose Default from the Preset pop-up menu.
Delete custom presets
1 Locate the effect in the Effects section of the Audio inspector.
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2 Choose Reveal User Presets in Finder from the Preset pop-up menu.

3 Select the preset or presets you want to delete in the Finder window, and drag them to the Trash.
After a custom preset has been deleted, it no longer appears in the Preset pop-up menu.

Adjust audio effects using keyframes
With Final Cut Pro, you can use keyframes to create simple changes to audio over time, such as
fading the volume or an effect in or out in the middle of a clip.
You place keyframes at specific points in a clip to change the parameter value of an audio
enhancement or effect at those points. For example, you can keyframe specific points for volume
or for an effect such as reverb or distortion.
You can set keyframes to adjust a clip’s volume directly in the Timeline or in the Audio
inspector. To see keyframes in the Timeline for all other effects, you need to display the Audio
Animation Editor.
For information about keyframes for video clips, see Adjust video effects using keyframes on
page 259.
Add keyframes to a clip
1 Do one of the following:
••

Select the clip in the Timeline, and choose Clip > Show Audio Animation (or press Control-A).

••

Control-click the clip in the Timeline, and choose Show Audio Animation from the shortcut menu.

If you’re adding keyframes for volume adjustment only, go to step 4.
Each effect in the Audio Animation Editor has a separate area for adding keyframes.
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Some effects have more than one parameter and allow you to add keyframes to individual
parameters separately. They appear in the Audio Animation Editor with a triangle next to the
effect’s name or in the Audio inspector as additional parameter controls.
2 Select the effect for which you want to add keyframes in either the Audio Animation Editor or
the Effects section of the Audio inspector.
3 Do one of the following:
••

To see expanded parameters in the Audio Animation Editor: Click the triangle to choose an
individual parameter from the pop-up menu, or choose All to see all keyframes.

••

To see expanded parameters in the Audio inspector: Click the disclosure triangle next to
Parameters for the effect.

4 Do one of the following for each effect parameter:
••

In the Audio Animation Editor (or the audio clip for volume only): Option-click (or press Option-K)
at a point on the horizontal effect control where you want to add a keyframe.
Keyframes for volume adjustment appear as white diamonds.

Keyframe marking where a change
in volume level occurred

For effects with more than one parameter, keyframes for the selected parameter appear as
white diamonds, while keyframes for other parameters appear gray.

Keyframes appear as white diamonds for all parameters when you choose All from the effect
pop-up menu. Double diamonds indicate that you added a keyframe for more than one
parameter at that point.
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••

In the Audio inspector: Position the playhead in the Timeline at the point where you want to
add a keyframe, and click the Keyframe button (or press Option-K).

Keyframe button

Once you add a keyframe, the Keyframe button changes to yellow, indicating that the
playhead currently sits on this keyframe.
When you move the playhead in the Timeline, arrows appear next to the Keyframe button
in the Audio inspector to indicate which side of the playhead has keyframes. To go to the
previous keyframe, click the left arrow or press Option-Semicolon (;). To go to the next
keyframe, click the right arrow or press Option-Apostrophe (‘).

Click an arrow to go to the
previous or next keyframe.

5 Add keyframes as needed.
Tip:  After you’ve added one keyframe, you can add another automatically by moving the
playhead in the Timeline and then adjusting the effect parameter (or the Volume slider when
keyframing volume) in the Audio inspector.
Add keyframes automatically across a selected area
For volume adjustments to a clip in the Timeline, you can use the Range Selection tool to add
keyframes automatically across a selected range.
If an effect appears in the Audio Animation Editor with a disclosure button, you can use either
the Select or Range Selection tool to add keyframes across a selected area.
1 Do one of the following:
••

Select the clip in the Timeline, and choose Clip > Show Audio Animation (or press Control-A).

••

Control-click the clip in the Timeline, and choose Show Audio Animation from the shortcut menu.

If you’re adding keyframes for volume adjustment only, go to step 3.
2 Select an effect, and click the disclosure button to expand it in the Audio Animation Editor.

Disclosure button
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3 In the Timeline, do one of the following:
••

If you’re adjusting volume only: Choose Range Selection from the Tools pop-up menu in the
toolbar (or press R).

The pointer changes to the Range Selection tool icon
••

.

If you’re adjusting an effect in the Audio Animation Editor: Choose either Select or Range Selection
from the Tools pop-up menu in the toolbar (or press A for Select, or R for Range Selection).

4 Drag across the area where you want to adjust the volume or effect.

5 Adjust the volume or effect within the range by dragging the effect’s horizontal control up or down.
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Keyframes are automatically created along the adjustment points within the range.

Adjust keyframes in the Audio Animation Editor
You can move keyframes left or right in the Audio Animation Editor. If an effect appears with a
disclosure button, you can expand the effect view and move keyframes up or down to change
the parameter value.
1 Select a keyframe.
2 Do one of the following:
••

To change its position in time, drag a keyframe left or right.
As you drag, the timecode value appears.

••

If an effect appears with a disclosure button, click the button (or double-click the effect) to
expand the effect view.

Disclosure button

With the effect view expanded, you can drag the keyframe up or down to change the effect’s
parameter value.
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To add another keyframe, Option-click (or press Option-K) at a point on the effect control
where you want to add the keyframe. To add a keyframe and change the effect’s parameter
value at the same time, Option-click while dragging the effect control up or down.
Adjust keyframes in the Audio inspector
For many effects, you adjust the parameter value of individual keyframes using the
Audio inspector.
1 Select a keyframe or position the playhead on a keyframe, and adjust the parameter value in the
Audio inspector.
2 To change the value at the next keyframe, go to the next keyframe and adjust the value again.
Adjust all keyframes at once in the Audio Animation Editor
mm Hold down the Command and Option keys, and drag either a keyframe or the effect control up
or down.
All keyframes are adjusted by the same amount, preserving the original shape created by any
keyframe adjustments.
However if you “flatten” the curve by dragging all the way to the top or bottom of the graph, the
keyframe values remain in that flattened state, with all keyframes sharing the same value.

Before

After

View only one effect at a time in the Audio Animation Editor
You can collapse the Audio Animation Editor to view only one effect at a time. This can be useful
if you have multiple effects applied to a clip and want to preserve screen space.
1 Choose Clip > Solo Animation (or press Control-Shift-V).
2 In the Audio Animation Editor, click the triangle next to the displayed effect’s name to choose an
effect from the pop-up menu.
Note:  When Solo Animation is turned on, you can’t delete effects from the Audio
Animation Editor.
To turn off Solo Animation, choose Clip > Solo Animation (or press Control-Shift-V).
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Delete keyframes
Do one of the following:
mm Select a keyframe in the Audio Animation Editor, and press Option-Shift-Delete.
mm Navigate to a keyframe in the Audio inspector, and click the Keyframe button.

Keyframe button

Hide audio animation
Do one of the following:
mm Select the clip in the Timeline, and choose Clip > Hide Audio Animation (or press Control-A).
mm Click the close button

in the upper-left corner of the Audio Animation Editor.

mm Control-click the clip in the Timeline, and choose Hide Audio Animation from the shortcut menu.
In addition to the tasks described above, you can manipulate multiple keyframes simultaneously.
This works the same way for audio keyframes as it does for video keyframes. See Modify groups
of keyframes on page 264.
You can also copy specific keyframes between different attributes or between different clips. See
Copy and paste keyframes on page 246.

Audio tools and techniques
Enhance audio
Final Cut Pro includes several powerful tools for both analyzing and enhancing the audio portion
of clips, including:
••

Loudness: Improves the main audio signal and makes it more uniform.

••

Background Noise Removal: Reduces background noise.

••

Hum Removal: Reduces common electrical hum noise at either 50 or 60 Hz.

You can analyze audio and adjust loudness, background noise, and hum using the Audio
Enhancements inspector. You can also analyze and fix audio problems when you import a clip.
The Audio Enhancements section of the Audio inspector also includes:
••

Equalization: Enhances the high-end (treble), midrange, or low-end (bass) frequencies.

All enhancements are designed to correct most common audio problems automatically or with
minor adjustments.
Note:  When you import a clip, the analyze and fix audio function only corrects severe audio
problems. If the clip contains moderate problems, these appear in yellow next to Audio Analysis
in the Audio Enhancements section of the Audio inspector after the clip is imported. To correct
these, you need to automatically enhance audio in the Audio Enhancements inspector.
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Analyze audio
1 Select an audio clip or video clip with audio in the Timeline.
2 To analyze the audio, do one of the following:
••

Choose Window > Go To > Audio Enhancements (or press Command-8).

••

Choose Show Audio Enhancements from the Enhancements pop-up menu in the toolbar.

••

In the Audio inspector, click the Audio Enhancements Inspector button
next to Audio
Analysis in the Audio Enhancements section. (The button changes color if any adjustments
have been made.)

The Audio Enhancements inspector appears. After analysis, indicators appear next to each
enhancement to show results:
••

A red sign indicates severe problems.

••

A yellow warning triangle indicates potential problems.

••

A green checkmark indicates OK.

3 To close the Audio Enhancements inspector, click the back button

.

You can automatically or manually change enhancement settings to correct any problems.
Automatically enhance audio
You can automatically enhance audio to analyze for and correct loudness, background noise,
and hum.
1 Select an audio clip or video clip with audio in the Timeline.
2 Do one of the following:
••

Choose Modify > Auto Enhance Audio.

••

Choose Auto Enhance Audio from the Enhancements pop-up menu in the toolbar.

••

Click the Auto Enhance button at the bottom of the Audio Enhancements inspector.

3 To close the Audio Enhancements inspector, click the back button

.

After analysis, a green checkmark next to an enhancement indicates that the clip was analyzed
for that enhancement. Details appear if a correction was automatically applied.
A blue checkbox appears next to each enhancement that was turned on to apply a correction.
Deselect the checkbox to turn off an enhancement.
Apply enhancements manually
After you analyze audio, you can adjust the enhancements manually.
1 Select an audio clip or video clip with audio in the Timeline.
2 To show the Audio Enhancements inspector, do one of the following:
••

Choose Window > Go To > Audio Enhancements (or press Command-8).

Chapter 8    Edit audio

202

••

Choose Show Audio Enhancements from the Enhancements pop-up menu in the toolbar.

••

In the Audio inspector, click the Audio Enhancements Inspector button
next to Audio
Analysis in the Audio Enhancements section. (After you make any adjustments, the button
changes color.)

3 To turn on an enhancement, click its icon or select its checkbox (when the enhancement is
turned on, its checkbox is blue).
Blue checkbox

4 If necessary, do any of the following:
••

To change Loudness settings: Drag the Amount and Uniformity percentage sliders. The
Amount slider increases or decreases the overall loudness (compression) of the clip, while the
Uniformity slider increases or decreases the dynamic range affected.

••

To change the percentage of Background Noise Removal: Drag the Amount slider.

••

To remove hum: Select either 50 Hz or 60 Hz for Hum Removal.

5 To close the Audio Enhancements inspector, click the back button

.

Adjust equalization
1 Select the clip in the Timeline.
2 In the Audio Enhancements section of the Audio inspector, choose an Equalization preset from
the Equalization pop-up menu, or click the Controls button to make manual adjustments.
Choose a preset from
this pop-up menu.

Controls button

If you want a clip to sound like another clip, you can match the audio.
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Sync audio and video
Final Cut Pro can automatically analyze and sync the audio and video clips in your project.
For example, if you select two video clips and three audio clips from different sources that were
all recorded during the same take, Final Cut Pro automatically analyzes and syncs the clips
together into a new clip in the Browser. Final Cut Pro analyzes the clips for sync points such as
markers you’ve added, timecode, file creation date, and audio content. If no sync points can be
found, the clips are synced at their respective starting points.
For finer control of the syncing process, you can use custom settings to adjust several
different parameters.
Selected clips in the Browser

New clip containing synchronized clips

Synchronized
clip contents

Primary storyline
for the synchronized clip

Connected
clips

Sync clips automatically
1 In the Browser, select the audio or video clips you want to sync.
2 Do one of the following:
••

Choose Clip > Synchronize Clips (or press Option-Command-G).

••

Control-click the selection and choose Synchronize Clips from the shortcut menu.

3 In the window that appears, type a name for the synced clip in the Synchronized Clip Name field.
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4 Use the In Event pop-up menu to choose the event in which you want to create the new
synced clip.
5 To sync clips using audio waveform data, select “Use audio for synchronization.”
This option makes precision sync adjustments using audio waveforms.
Sync point

Note:  Some audio recordings are not suited for use with this feature. Selecting this option may
result in long processing times during which Final Cut Pro is not available for editing.
6 If the automatic settings are not shown, click Use Automatic Settings.
The automatic settings appear.

Note:  The automatic settings are shown by default, but if the last synced clip you created used
custom settings, those settings are shown.
7 Click OK.
Final Cut Pro creates a new synced clip in the event you specfied.
Sync clips using custom settings
1 In the Browser, select the audio or video clips you want to sync.
2 Do one of the following:
••

Choose Clip > Synchronize Clips (or press Option-Command-G).

••

Control-click the selection and choose Synchronize Clips from the shortcut menu.

3 In the window that appears, type a name for the synced clip in the Synchronized Clip Name field.
4 Use the In Event pop-up menu to choose the event in which you want to create the new
synced clip.
5 To show the custom settings, click Use Custom Settings.
The custom settings appear.
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Note:  The automatic settings are shown by default, but if the last synced clip you created used
custom settings, those settings are shown.
6 In the Synchronization pop-up menu, choose how the clips are synced:
••

Automatic: Final Cut Pro syncs the clips automatically.

••

Timecode: Final Cut Pro syncs the clips using timecode recorded in the clips. If you recorded
timecode in your clips, choose this option. It’s the fastest and most frame-accurate method of
syncing clips.
Sync point
01:00:00:00
01:00:00:00
01:00:00:00
01:00:00:00

••

Content Created: Final Cut Pro syncs the clips using the date and time information recorded by
your camcorder or video recording device.
Sync point
12:59 PM
12:59 PM
12:59 PM
12:59 PM

The Content Created method can sync clips within 1-second accuracy (because in most
camcorders the smallest unit in date and time information is 1 second). If you choose this
syncing method, consider doing any of the following to make the sync frame-accurate:
••

Select “Use audio for synchronization.” (See step 7.) Final Cut Pro uses the Content Created
data as a starting point and then further refines the sync.

••

Manually adjust the sync. (See “Manually adjust or slip a synced clip,” below.)

Note:  At any time, you can change the Content Created date and time of your source clips in
the Browser. Just select one or more clips and choose Modify > Adjust Content Created Date
and Time.
••

Start of First Clip: Final Cut Pro uses the first frame in each clip as the sync point.
Sync point

Tip:  The Start of First Clip method is useful if you want to use specific range selections of your
source clips only. In the Browser, add keywords or the Favorite rating to the ranges you want
to use, and then filter or search for the clips. When you create your synced clip, Final Cut Pro
uses only the media showing in the filtered view.
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••

First Marker on the Clip: Final Cut Pro uses the first marker in each clip as the sync point.
Sync point

Tip:  With this method, you can use the first marker to define a region that can be fine-tuned
with the “Use audio for synchronization” option (described in the next step). In other words,
you don’t need to place the marker exactly—just close enough so that the automatic audio
sync feature can sync the clips the rest of the way.
7 To sync clips using audio waveform data, select “Use audio for synchronization.”
This option makes precision sync adjustments using audio waveforms.
Sync point

Note:  Some audio recordings are not suited for use with this feature. Selecting this option may
result in long processing times during which Final Cut Pro is not available for editing.
8 If you want the synced clip’s timecode to start at a value other than the earliest timecode value
in the selected clips (the default), type a timecode value in the Starting Timecode field.
9 If you want to change the video properties for the synced clip, select Custom in the Video
Properties section and change the settings as appropriate.
Note:  By default, Final Cut Pro analyzes the selected clips and configures these settings
according to the most common clip properties among the clips.
10 If you want to change the audio or render settings for the synced clip, select Custom in the
Audio and Render Properties section and change the settings as appropriate.
11 Click OK.
Final Cut Pro creates a new synced clip in the event you defined.
Manually adjust or slip a synced clip
You may need to adjust a synced clip (by slipping the sync, for example). You can do this by
opening the contents of the synced clip in the Timeline.
1 Select the clip in the Browser or the Timeline.
2 Do any of the following:
••

Choose Clip > Open in Timeline.

••

Control-click the synced clip and choose Open in Timeline from the shortcut menu.

The Timeline displays the contents of the clip.
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3 Make adjustments to the contents of the synced clip.
The contents of a synced clip include a clip in the primary storyline and one or more connected
clips. You can adjust or slip the sync by dragging the connected clips left or right to change
the points at which they connect to the clip in the primary storyline. For more information, see
Connect clips to add cutaway shots, titles, and synchronized sound effects on page 103.
4 When you’re done, click the left arrow in the upper-left corner of the Timeline to save your
changes and close the contents of the synced clip.
Synced clips appear in the Browser. The original clips are not affected. To easily view all synced
clips, you can create a Smart Collection that uses the Type search category set to Synchronized
as one of the search criteria. For more information, see Save searches as Smart Collections on
page 75.
If your synced clip contains audio channels that aren’t being used, you can turn them off. See
Configure audio channels on page 171.

Match audio equalization settings
The Match Audio function uses equalization (EQ) to let you match a selected clip’s sound to
another clip. This is particularly useful when you have multiple audio clips recorded in different
environments but want the clips to sound similar to each other.
Match audio
1 Select the clip or clips you want changed in the Timeline.
2 Do one of the following:
••

Choose Modify > Match Audio.

••

Choose Match from the Equalization pop-up menu in the Audio Enhancements section of the
Audio inspector.

••

Choose Match Audio from the Enhancements pop-up menu in the toolbar.

3 Click to select the clip whose sound you want to match.
4 Click Apply Match.
Once you match a clip, you can make adjustments to settings in the Audio Enhancements
section of the Audio inspector.
Remove audio matching
1 Select the clip in the Timeline.
2 In the Audio Enhancements section of the Audio inspector, choose a different equalization
setting from the Equalization pop-up menu.
To remove all equalization, choose the Flat setting.
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Preserve pitch when retiming clips
By default, Final Cut Pro preserves pitch when retiming clips so that the pitch doesn’t sound
higher when the clip is faster or lower when the clip is slower. You can turn this feature on or off
before or after a clip has been retimed.
Turn Preserve Pitch on or off
1 In the Timeline, select an entire clip, or a range within a clip, whose speed you plan to change.
2 Choose Preserve Pitch from the Retime pop-up menu in the toolbar.

A checkmark to the left of the command name indicates that Preserve Pitch is turned on. To turn
it off, choose Preserve Pitch again.
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Add transitions, titles, effects,
and generators

9

Transitions, titles, effects, and generators overview

You can easily add special effects to video, audio, and photos in your projects.

Final Cut Pro provides several kinds of effects and controls:
••

Transitions: Add an effect between clips to control how they change from one to the next. See
Transitions overview on page 211.

••

Titles: Use to add text at any point in your project. See Titles overview on page 220.

••

Effects: Use to do a wide variety of things to your video and audio clips, from subtle (add film
grain or a color effect to the video, or a graphic equalizer to the audio) to not so subtle (add
droplet ripples or an insect-eye view to the video, or apply an exaggerated pitch shift to the
audio). There are two main types of effects:
••

Built-in effects: Use these standard effects to resize, move, rotate, trim, skew, crop, or apply
the Ken Burns zooming effect to a video clip. These effects are already part of each Timeline
clip—you just need to adjust them. See Built-in effects overview on page 228.

••

Clip effects: Use these effects to change your video and audio clips to either correct issues or
create stunning new looks or sounds. See Clip effects overview on page 241.

••

Generators: Add a special element like a placeholder clip, a timecode generator, or a
countdown timer, or add colors, patterns, or animated backgrounds to your project. See
Generators overview on page 249.

••

Onscreen controls: Customize many of your effects using onscreen controls. See Onscreen
controls overview on page 253.

••

Video Animation: Vary effect settings as a clip plays. See Video animation overview on
page 258.
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Effects can be added to any clips in the Timeline. Once they have been added (or in the case of
built-in effects, adjusted), you can customize the effects using controls in an inspector, onscreen
controls in the Viewer, and controls in the Video Animation Editor and Audio Animation Editor.
You can also try out multiple versions of an effect using auditions.
Most of the effects and generators can be opened in Motion, an Apple application designed to
work with Final Cut Pro, where you can customize and save specialized versions of them.
Note:  If you are using a transition, title, effect, or generator created in Motion that utilizes a thirdparty plug-in, and that plug-in is not installed on your Final Cut Pro system, the Final Cut Pro
project may render incorrectly or incompletely. To verify if this is the cause, open the template
in Motion; if there are offline elements, you will see a warning dialog. For more information on
how to open a template in Motion, see Create specialized versions of transitions in Motion on
page 220, Create specialized versions of the video effects in Motion on page 248, or Create
specialized versions of the generators in Motion on page 252.

Add and adjust transitions
Transitions overview
You can add cross dissolves and other transition effects between cuts to make your program
more interesting.
Transitions replace one shot with another over a specified period of time; when one shot ends,
another one replaces it. Three very common video transitions occur over time: fades, cross
dissolves, and wipes.
You can add audio-only transitions to audio edits in a connected storyline. These transitions can
be either a fade-in, fade-out, or crossfade.
Note:  When a transition is added to a video clip with attached audio, a crossfade transition is
automatically applied to the audio. If the audio is detached or expanded from the video, the
audio is not affected by the video transition.
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How transitions are created
Transitions require overlapping video from the clips on each side of the edit point. A onesecond transition requires one second of video from the end of the left clip and one second of
video from the start of the right clip. When you apply a transition to an edit point, Final Cut Pro
attempts to use additional video from each of the clips to create the overlap. These additional
(unused) sections of clips are known as media handles. The following image shows a clip with
media handles on each end and a clip with no extra video, or media handle, at its start.
Clip selected in the Browser

Start media handle

End media handle

No start media handle

End media handle

The media handle video may not be appropriate for use in a transition. For example, if the video
includes unusable video such as a slate, it will be visible in the project.
You can set the default duration for transitions. See Set transition defaults on page 213.
The illustration below shows how transitions are created when the clips on either side of the
edit point have media handles. The transition is placed so that it spans the clips; one half of the
transition overlaps each clip. Unused media from the end of each clip is added to fill out the
transition. The total duration of your project is unchanged.
Edit with no transition
Clip 1

Clip 2

Edit with transition (media handles used)
Clip 1
Media handle

Media handle
Clip 2

If one or both of the clips do not have enough extra content (media handles) to support a
transition of the default duration, you are given the option to overlap media in your project to
create the transition.
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Final Cut Pro uses any available media handles and then overlaps media as necessary to create
the transition. The illustration below shows a transition created without media handles. The
two clips are made to overlap, and the transition is placed over the overlapping region. This is
effectively a ripple trim edit, and the total duration of your project decreases.
Edit with no transition
Clip 1

Clip 2

Edit with transition (no media handles used)
Clip 1
Clip 2

Set transition defaults
You can set the default transition that is used with the Command-T keyboard shortcut. You can
also set the default duration for transitions.
Set the default transition
1 Click the Transitions button in the toolbar.

2 Control-click a transition, and choose Make Default from the shortcut menu.
Set the default duration
You set the default duration for transitions in Final Cut Pro preferences.
1 Choose Final Cut Pro > Preferences, or press Command-Comma (,), and click Editing.
2 Use the “Duration is x seconds” value slider to set the duration, in seconds, of all transitions you
add to the Timeline.
You can adjust the duration of a transition after it is in the Timeline.
Note:  Some transitions have a set duration and are not affected by this setting.
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Add transitions to your project
There are several methods you can use to add transitions to your project. Once a transition is
added, you can adjust its parameters. You can also modify the transition effect in Motion.
Add a cross dissolve
1 Choose the Select tool from the Tools pop-up menu in the toolbar (shown below), and click the
edge of a clip (an edit point) in the Timeline.

One or both clip edges are highlighted.

Note:  If you select a whole clip in the Timeline instead of just an edit point, transitions are added
at each end of the selected clip.
2 Choose Edit > Add Cross Dissolve (or press Command-T).
The cross dissolve is inserted using the “Apply transitions using” setting. For more information,
see Set transition defaults on page 213. If the video clip has attached audio, a crossfade transition
is applied to the audio.
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Add or change a transition using the Transitions Browser
1 Click the Transitions button in the toolbar.

2 Select a transition.
Move the pointer over the transition thumbnails to see an example of what the transition looks
like. Additionally, you can type text in the search field to filter the list of transitions that appear.
3 Do one of the following:
••

To apply the transition to an edit point: Drag the transition to it.

••

To replace an existing transition in your project: Drag the transition to it.

Tip:  Alternatively, you can select the edit point first, and double-click a transition in the
Transitions Browser to apply it.
The transition is added to the edit using the “Apply transitions using” setting. For more
information, see Set transition defaults on page 213. If the video clip has attached audio, a
crossfade transition is applied to the audio.
Add an automatic audio crossfade
When a video clip has attached audio, the audio automatically has a crossfade transition applied
when a video transition is applied. If the audio is detached or expanded from the video, the
audio is not affected by the video transition. Follow these steps to add an audio crossfade
between detached audio clips that are in a connected storyline.
1 Create an audio-only storyline that is connected to the primary storyline.
For information on creating storylines, see Add storylines on page 277.
2 Using the Select tool, click the edge of a clip (an edit point) in the storyline.
One or both clip edges are highlighted.

Note:  If you select a whole clip in the storyline instead of just an edit point, transitions are added
at each end of the selected clip.
3 To insert a crossfade, choose Edit > Add Cross Dissolve (or press Command-T).
The crossfade is inserted using the “Apply transitions using” setting. For more information, see
Set transition defaults on page 213. You can configure the fade-in and fade-out settings in the
Transition inspector.
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Copy a transition to other edit points using the Edit menu
1 Select a transition in the Timeline, and choose Edit > Copy (or press Command-C).
2 Using the Select tool, click the edge of a clip (an edit point) in the Timeline, and choose Edit >
Paste (or press Command-V).
Note:  If you copy a transition to an edit point that already has a transition, the existing transition
is overwritten.
Copy a transition to other edit points by dragging
mm Select a transition in the Timeline, press the Option key, and drag the transition to another
edit point.
Note:  If you copy a transition to an edit point that already has a transition, the existing transition
is overwritten.

Delete transitions from your project
You can easily delete a transition, restoring the edit point to a simple cut.
Delete a transition
1 Select one or more transitions in the Timeline.
2 Press Delete.
The selected transitions are removed and their edit points are converted to simple cuts.
Important:  If a transition you deleted used Full Overlap, the edit point is now at the center point
of the transition that was removed, not at its original location before the transition was applied.
You can use Edit > Undo to remove the transition and return the clips to their original length. For
more information, see How transitions are created on page 212.

Adjust transitions in the Timeline
You can adjust a transition’s duration and move it in the Timeline. You can also trim either of the
clips under the transition.
Change the transition duration
1 Select a transition in the Timeline.
2 Do one of the following:
••

Choose Modify > Change Duration (or press Control-D), type the duration (it appears in the
Dashboard in the toolbar), and press Return.

••

Drag one end of the transition away from the transition’s center to make it longer or toward
the center to shorten it.

Drag either transition edge
to trim its duration.

The transition maintains its center point and equally trims both ends, with the number showing
how many frames have been added to or subtracted from the transition duration.
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Move the transition
Moving a transition actually rolls the edit under the transition, adding content to one underlying
clip while removing content from the other clip. The overall duration of the project is not
affected. Additionally, you can only move the transition as long as sufficient media handles are
available for the clip that is being extended.
Edit with transition
Clip 1

Media handle

Media handle

Clip 2

Edit with transition moved right
Clip 1

Media handle

Media handle

Clip 2

1 Select a transition in the Timeline.
2 Drag the transition trim icon in the upper-center area of the transition.

Drag to roll the edit
under the transition.

The edit under the transition is rolled, with one clip being extended and the other shortened. A
number appears showing the number of frames to the left (negative numbers) or to the right
(positive numbers) you have rolled the transition.
You can also use the Precision Editor to roll the transition.
Trim a clip under a transition
The transition includes icons that make it easy to trim the left or right clip without affecting
the transition.
1 Select a transition in the Timeline.
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2 Drag one of the trim icons in the upper-left or upper-right area of the transition.
Drag to trim the end point
of the clip on the left.

Drag to trim the start point
of the clip on the right.

Dragging the trim icon in the upper left adjusts the right clip’s start point, and dragging the
trim icon in the upper right adjusts the left clip’s end point. A number appears showing how
many frames you have added to (negative numbers) or subtracted from (positive numbers) the
clip’s duration. Trimming the clip doesn’t affect the transition’s duration, but it does affect the
project’s duration.
You can also use the Precision Editor to trim the clips under the transition.

Adjust transitions in the Transition inspector and Viewer
You can adjust a transition using the controls in the Transition inspector and Viewer.
Adjust a transition using the Transition inspector and Viewer
1 If the Transition inspector is not already visible, choose Window > Show Inspector (or press
Command-4).
2 In the Timeline, select the transition to adjust.
For this example, use the Circle transition.
The Viewer shows any onscreen adjustments you can make by dragging the handles. The
Transition inspector shows the other parameters available for you to adjust. Additionally,
some transitions have an image well for you to select a video frame that appears as part of
the transition.
Drag onscreen controls
to adjust selected
transition settings.
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In the above example, you can drag the white circle in the Viewer (an onscreen control) to
position the circle wipe’s center and the square to set the border width (in this case, its softness).
The Transition inspector includes a setting for the circle wipe’s aspect ratio and edge treatment
(including the border color if you choose a hard edge).
Additionally, many transitions have parameters that you can animate using keyframes. For
example, you could have the center of the Circle transition move as you play the clip.
For more information on adjusting audio crossfades in the Transition inspector, see Fade audio in
or out on page 176.

Adjust transitions with multiple images
Several transitions include areas that are filled with still images from the clips on either side
of the transition. For example, this is the Pan Far Right transition (one of the Bulletin Board
transitions).
This image is set by handle
number 4 in the Timeline.

The areas are numbered and correlate to numbered points around the transition in the Timeline.

Adjust transitions with numbered points
1 Select the transition with numbered points in the Timeline.
2 Move the playhead over the transition until you see an area with the same number as one of the
numbered handles in the Timeline.
3 Drag the numbered handle to select the image to fill the area.
4 Continue until you have selected images for all of the areas.
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Create specialized versions of transitions in Motion
Many of the transitions were created using Motion, an Apple application designed to work
with Final Cut Pro. You can open these transitions in Motion, make modifications, and save the
changes as a new transition file that appears in the Transitions Browser.
Important:  The following steps require you to have Motion 5 installed on your computer.
Modify a transition in Motion
1 Click the Transitions button in the toolbar.

2 In the Transitions Browser, Control-click the transition you want to modify, and choose “Open a
copy in Motion” from the shortcut menu.
Motion opens and the transition’s project appears.
3 Modify the transition project.
For more information, see Motion Help at http://help.apple.com/motion.
4 Choose File > Save As (or press Shift-Command-S), enter a name for this new transition (referred
to as a Template in Motion), assign it to a category (or create a new category), choose a theme (if
needed), and click Publish.
Note:  If you choose File > Save, the transition is saved using the same name with “copy”
appended to its end.

Add and adjust titles
Titles overview
Titles play a critical role in movies, providing important bookends (such as opening titles
and closing credits) and conveying time and dates within the movie. Titles, especially in the
lower third of the screen, are also used in documentaries and informational videos to convey
details about subjects or products onscreen. You can also add notes and placeholders within
your project while you edit. Subtitles can be a critical element for movies originating in a
different language.
You can create titles and credits within Final Cut Pro with title effects. Titles are synthesized clips
(similar to generators) generated by Final Cut Pro. Title clips don’t refer to any media on your
hard disk. When you add a title as a connected clip directly above another clip, the underlying
clip appears as the title’s background, sparing you the need to perform any further compositing
to create that effect.
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Add titles to your project
You add titles to clips in your project using the Titles Browser. Once you have added text, you can
modify the title’s text style.
Add a title to a project clip
1 Drag the playhead in the Timeline to the point where you want to add the title.
2 Click the Titles button in the toolbar (or press Command-5).

3 Do any of the following:
••

To add a title from the Titles Browser: Double-click the title.
A title clip is added at the playhead location.

••

To add a basic title: Choose Edit > Connect Title > Basic Title (or press Control-T).
A title clip named Basic Title (with no effects or animations) is added at the playhead location.

••

To add a lower-third title: Choose Edit > Connect Title > Basic Lower Third (or press
Control-Shift-T).
A lower-third title clip named Basic Lower Third (with no effects or animations) is added at the
playhead location.

The title clip is connected to the clip in the primary storyline at the position of the playhead.
Visually, the title is superimposed over the clip in the primary storyline at the playhead position.
If the playhead is not over a clip, the title is superimposed over the default background.
Add a title as a clip in the primary storyline
There are two ways to add a title as a clip in the primary storyline. You can either insert a title
clip at the edit point between two clips or replace an existing clip in the primary storyline with a
title clip.
mm To add a title between clips in the Timeline: Drag a title from the Titles Browser to the edit point
between the clips where you want the title clip to appear.
mm To replace an existing Timeline clip with a title clip: Drag a title from the Titles Browser to the clip in
the Timeline that you want to replace, and choose Replace from the shortcut menu.
Enter text for your title
After you add a title clip to your project in the Timeline, you can type text for your title in
the Viewer.
1 Select a title clip in the Timeline.
2 Move the playhead over the selected title clip.
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3 In the Viewer, double-click the title text, and type text for your title.
Previous Text Layer button
Next Text Layer button

Double-click the text box
to type text for the title.

4 To select a different text object, do one of the following:
••

Click the Previous Text Layer or Next Text Layer button.

••

Double-click a different text object.

5 Type new text as necessary.
6 To exit text editing, press Command-Return.
Note:  The Previous Text Layer and Next Text Layer buttons also support Motion text edit markers.
For more information, see Motion Help at http://help.apple.com/motion.

Adjust titles
You can edit text in the Viewer, and adjust a title’s text appearance using the Title and Video
inspectors. For example, you can adjust a title’s opacity or modify the text’s font, alignment, color,
glow, and drop shadow.
Edit title text
1 Double-click a title clip in the Timeline.
2 Do one of the following:
••

Double-click a text object in the Viewer.

••

Select the text in the Text inspector.

3 Edit the text.
4 To exit text editing, press Command-Return.
Adjust a title’s position onscreen
1 Select a title clip in the Timeline.
2 Move the playhead over the selected title clip.
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3 Do one of the following:
••

In the Viewer, drag the text object to the new position.

••

Double-click the text object and drag the position button to the new position.
Click the position button
(the small circle) and drag
the title to the new position.

Adjust a title clip’s opacity
If you’re placing a title over an existing clip, you can adjust the title clip’s transparency.
1 Double-click a title clip in the Timeline.
2 Choose Window > Show Inspector (or press Command-4), and click the Video button at the top
of the pane that appears.
Opacity slider

3 In the Compositing section, adjust the opacity settings.
4 To edit text editing, press Command-Return.
Note:  You can also keyframe a title’s opacity setting.
Adjust a title’s settings
You can modify a title’s settings in the Title inspector.
You can build and modify titles in Motion 5 for use in Final Cut Pro. When you save a title template
in Motion, you can choose which parameters to publish in the Title inspector in Final Cut Pro. For
this reason, the parameters that you can adjust in the Title inspector vary from title to title.
See the information about Final Cut Pro X templates in Motion Help at http://help.apple.com/motion.
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1 Select a title clip in the Timeline.
2 Choose Window > Show Inspector (or press Command-4), and click the Title button at the top of
the pane that appears.

3 Adjust the available settings as needed.
Note:  You can also keyframe many of the settings in both the Title and Text inspectors.
Modify a title’s text style
You can modify the text style for a title.
1 Double-click a title clip in the Timeline.
The title appears in the Viewer, and the text in the first text object in the title clip is selected.
Note:  To modify a different text object in the same title, select it in the Viewer.
2 Choose Window > Show Inspector (or press Command-4).

3 Adjust the available settings as needed in the sections listed below.
Note:  To reveal the controls in each of the sections, you may need to scroll down in the Text
inspector and double-click each section name.
••

Basic: Sets the basic font controls such as font, size, alignment, tracking, and line spacing.

••

Face: Sets the text color, opacity, and blur.
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••

Outline: Sets the text outline color, opacity, blur, and width.

••

Glow: Sets the text glow color, opacity, blur, and radius.

••

Drop Shadow: Sets the text drop-shadow color, opacity, distance, and angle.

4 To exit text editing, press Command-Return.
Note:  You can also keyframe many of the settings in both the Title and Text inspectors.
Adjust multiple text objects in a title clip at once
You can adjust the settings of more than one text object at once.
1 Select a title clip in the Timeline.
2 Move the playhead over the selected title clip.
3 In the Viewer, do one of the following:
••

Holding down the Command key, select the text objects you want to modify.

••

Drag to select the text objects you want to modify.

4 Choose Window > Show Inspector (or press Command-4).
5 Adjust the available settings as needed.
Use the ruler to lay out and align paragraph text objects
Text created in Motion and some titles in the Titles Browser contain paragraph text. You can use
a ruler and tabs to control the layout of paragraph text. For more information, see Motion Help at
http://help.apple.com/motion.
1 Double-click a paragraph text object in the Viewer.
2 In the Viewer, click the Show Ruler button.
Note:  The Show Ruler button appears only when you edit a paragraph text object.
A ruler appears above the paragraph text object in the Viewer. Tabs in the ruler show how
tabbed text will be aligned in the selected text.
Left tab

Center tab

Decimal tab

Right tab

3 Do any of the following:
••

To add a tab: Click in the ruler.

••

To change the type of tab added when you click in the ruler: Control-click in the ruler and choose
a tab type from the shortcut menu.

••

To move a tab: Drag it to another position on the ruler.

••

To delete a tab: Drag it out of the ruler.

••

To change a tab to another tab type: Control-click the tab and choose a tab type from the
shortcut menu.
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Apply preset text styles
Final Cut Pro comes with a set of preset text styles that you can apply to text. A text style is
a group of style settings. You can also create your own custom text styles and save them as
presets. You apply preset text styles using the pop-up menu at the top of the Text inspector.

Choose a preset text style
from the pop-up menu.

Apply preset text styles to titles
1 Double-click a title clip in the Timeline.
The title appears in the Viewer, and the text in the first text object in the title clip is selected.
2 Choose Window > Show Inspector (or press Command-4), and click the Text button at the top of
the pane that appears.
3 Click the pop-up menu at the top of the Text inspector and choose a text style.

The text style is applied to the selected text.
Save and apply custom text styles
1 Double-click a title clip in the Timeline.
The title appears in the Viewer, and the text in the first text object in the title clip is selected.
2 Choose Window > Show Inspector (or press Command-4), and click the Text button at the top of
the pane that appears.
3 Make any custom changes to the font or style in the Text inspector.
For more information, see “Modify a title’s text style” in Adjust titles.
4 In the pop-up menu at the top of the Text inspector, choose one of the following:
••

Save Format Attributes: Saves basic font controls, including font, size, alignment, tracking, and
line spacing.

••

Save Style Attributes: Saves effects such as text color, outline color, glow, drop shadow, and
so on.

••

Save All Format + Style Attributes: Saves both format attributes and style attributes.
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5 In the Save Preset to Library window, type a name for your new custom preset.
The custom text style is saved and appears in alphabetical order in the pop-up menu at the top
of the Text inspector.

Custom preset

6 To apply the new preset to another title, select the title in the Timeline and choose the preset
from the pop-up menu at the top of the Text inspector.

Remove titles from your project
You can remove a title from your project at any time.
Remove a title
mm In the Timeline, select the title you want to remove, and press Delete.

Find and replace text in your project
If your project contains multiple instances of a particular word or phrase displayed in multiple
title clips, such as names, company names, or job titles, you can find the specific word or phrase
and quickly change each instance of it.
Find and replace title text
1 Choose Edit > Find and Replace Title Text.
2 In the Find and Replace Title Text window that appears, type the text you want to search for in
the Find field.

3 In the Replace field, type the text you want to replace the text you’re looking for.
4 To choose where to search, do one of the following:
••

To search for text in the selected title clip: Choose Selected Title from the “Search in”
pop-up menu.
This option is useful for searching in title clips that have a lot of text, such as credits.

••

To search for text across all the title clips in your project: Choose All Titles In Project from the
“Search in” pop-up menu.
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5 Do any of the following:
••

To match how letters are capitalized in your search string: Select the “Match case” checkbox.

••

To locate whole words rather than a group of letters within words: Select the “Whole words”
checkbox.

••

To have the search start over from the beginning of the searched item once it’s reached the end:
Select the “Loop search” checkbox.

6 Do one of the following:
••

To replace all instances of the text at once: Click the Replace All button.

••

To replace this single instance of the text only: Click the Replace button.

••

To replace this instance of the text and locate the next place the text appears: Click the Replace &
Find button.

••

To cycle forward and backward through each instance of the text you’re looking for: Click the
Previous and Next buttons.

Adjust built-in effects
Built-in effects overview
Final Cut Pro includes several video effects that are part of each Timeline clip and directly
accessible from the Viewer—all you need to do is select them and start making adjustments. You
can use these to:
••

Create a composited image from several clips

••

Reposition or reframe a clip by zooming in on it

••

Crop a clip to remove unwanted items, such as microphones or lighting equipment, that
accidentally appear in the video

••

Configure a Ken Burns effect to add life to your still images (and video clips as well)

You can use more than one of the built-in effects at the same time. For example, you can use
Transform to reduce the image’s size and position, Trim to remove a portion of the video, and
Distort to give the video a skewed look.
You can animate any of these effects so that they change as the clip plays. For example, you can
have an image shrink and move offscreen. To configure an animation, you change settings at
two or more points in the clip. When you play the clip, Final Cut Pro creates smooth animated
transitions between the points.

Resize, move, and rotate clips
The Transform built-in effect allows you to resize, move, and rotate an image. This effect is
commonly used on a clip placed over a primary storyline clip, which becomes the background
of the resized clip. It is also often used to zoom in on a clip, allowing you to reframe a shot
if needed.
Adjust the Transform effect
Controls in the Viewer and Video inspector allow you to adjust this effect. However, some
controls are found in only one or the other.
1 Select a clip in the Timeline.
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2 To access the Transform controls, do one of the following:
••

Choose Transform from the pop-up menu in the lower-left corner of the Viewer (or press Shift-T).

••

Control-click in the Viewer and choose Transform from the shortcut menu.

3 To adjust the effect using the onscreen controls:
••

Blue handles at each corner: Drag these to adjust the image’s size while maintaining its current
aspect ratio.

••

Blue handles in the middle of each side: Drag these to independently adjust the vertical and
horizontal image size, changing the aspect ratio of the image.
Note:  These controls aren’t available in the Video inspector.

••

White circle in the center: Shows the rotation anchor point. Drag anywhere inside the image to
adjust the image’s position.

••

Blue handle extending from the center circle: Drag this to rotate the image.
Tip:  For finer precision when rotating the image, drag the rotation handle farther away from
the anchor point in the center.
Drag a corner handle
to change the image’s
size without changing
its aspect ratio.

Drag a side’s handle
to change the aspect
ratio of the image.

Drag anywhere inside the
image to set its position.

Drag this handle
to rotate the image.

4 Use the Transform controls in the Video inspector as follows:
••

Position X and Y: Use these to move the image left and right (X) and up and down (Y).

••

Rotation: Use this to rotate the image around its anchor point.

••

Scale: Use this to change the image’s size.

••

Anchor X and Y: Use these to move the image’s center point. This defines the point that the
image rotates around.
Note:  This control isn’t available in the onscreen controls.
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5 When you are finished adjusting the effect and no longer need the onscreen controls, click Done.
You can animate the effect and have it appear over a background. For details on working with
built-in effects, see Work with built-in effects on page 235.

Trim clips
Trim controls allow you to independently trim each of the image edges, creating a window look.
This effect, often used along with the Transform effect, is commonly used on a clip placed over a
primary storyline clip, which becomes the background of the trimmed clip.
Adjust the Trim effect
1 Select a clip in the Timeline.
2 To access the Trim controls, do one of the following:
••

Choose Crop from the pop-up menu in the lower-left corner of the Viewer (or press Shift-C).

••

Control-click in the Viewer and choose Crop from the shortcut menu.

3 Click the Trim button at the bottom of the Viewer.
4 To adjust the effect using the onscreen controls:
••

Blue handles at each corner: Drag these to adjust the position of two trim window sides at the
same time.

••

Blue handles in the middle of each side: Drag these to independently adjust the position of
each side.

••

Anywhere inside the window: Drag anywhere inside the window to adjust its position.
Drag a handle in the middle of
a side to change only one side.

Drag a corner handle to
change two sides at once.

Drag anywhere in the image
to position the trim window.

5 To individually adjust each edge using the Crop area of the Video inspector, use the Trim controls.
6 When you are finished adjusting the effect and no longer need the onscreen controls, click Done.
You can animate the effect and have it appear over a background. For details on working with
built-in effects, see Work with built-in effects on page 235.
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Crop clips
The Crop effect makes it easy to remove unwanted areas of the image. It automatically expands
the cropped image so that it fills the screen.
Adjust the Crop effect
1 Select a clip in the Timeline.
2 To access the Crop controls, do one of the following:
••

Choose Crop from the pop-up menu in the lower-left corner of the Viewer (or press Shift-C).

••

Control-click in the Viewer and choose Crop from the shortcut menu.

3 Click the Crop button at the bottom of the Viewer.
4 To adjust the effect using the onscreen controls:
••

Blue handles at each corner: Drag these to adjust the crop of that corner. The cropped image
always maintains the original aspect ratio.

••

Anywhere inside the window: Drag anywhere inside the crop window to adjust its position.
Click Done to crop the image
and expand it to full size.

Drag a corner handle to
change the crop window’s
size (but not its aspect ratio).

Drag anywhere inside
the image to position
the crop window.

5 To individually adjust each edge using the Crop area of the Video inspector, use the
Crop controls.
Note:  While you can use these controls to change the crop window’s aspect ratio, the final image
still matches the original image’s aspect ratio, with additional content being cropped out so that
the final image fits the original aspect ratio.
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6 Click Done to have the crop applied and see the image zoomed to fill the screen.

You can animate the effect, creating the illusion of a pan and zoom camera move (effectively,
a manual Ken Burns effect). For details on working with built-in effects, see Work with built-in
effects on page 235.

Pan and zoom clips with the Ken Burns effect
The Ken Burns effect creates a pan and zoom effect using the start and end positions you define.
The Ken Burns effect is actually a Crop effect with two crop settings, one at the clip start and
another at its end.
You can further customize the Ken Burns effect by controlling the smoothness of the animation.
The motion applied to a clip when you create a Ken Burns effect is automatically smoothed so
that the movement accelerates slowly as the animation starts, and decelerates slowly as the
clip comes to rest at the end of the animation. This simulates the effects of friction and inertia
that occur in the real world. In visual effects software, this trick is commonly called ease out and
ease in.
By default, a Ken Burns animation performs both of these smoothing operations (Ease Out and
Ease In), but you can customize the effect to limit the result to just easing out, just easing in, or
making a linear movement with no simulated inertia or friction.
Adjust the Ken Burns effect
1 Select a clip in the Timeline.
2 To access the Ken Burns controls, do one of the following:
••

Choose Crop from the pop-up menu in the lower-left corner of the Viewer (or press Shift-C).

••

Control-click in the Viewer and choose Crop from the shortcut menu.
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3 Click the Ken Burns button at the bottom of the Viewer.
Two rectangles appear in the Viewer: a green one that defines the position and size for the start
of the clip and a red one that defines the position and size for the end of the clip.
Click the Swap button
to exchange the Start
and End positions.

Click the Play Loop
button to play the
clip in a loop.

Select the green Start or
red End rectangle to adjust
the crop size and position.

The default start and end settings result in a small zoom to the center of the image.
4 To choose the part of the image that appears at the start of the effect, drag the green handles to
change the crop size of the image, and drag the window to set its position.
5 To choose the part of the image that appears at the end of the effect, drag the red handles to
change the crop size of the image, and drag the window to set its position.
A superimposed arrow shows the direction the image travels when the clip is played.
6 To have the clip with the effect play in a loop, click the Play Loop button.
7 To exchange the start and end positions, click the Swap button.
8 Click Done.
Customize the smoothness of a Ken Burns animation
By default, a Ken Burns animation performs both smoothing operations (Ease Out and Ease In),
but you can customize the effect.
1 In the Timeline, select a clip with the Ken Burns effect applied.
2 In the Viewer, Control-click anywhere in the image and choose an option from the shortcut menu:
••

Ease In and Out: Applies the easing effect to the beginning and the end of the animation.

••

Ease In: Limits the easing effect to the end of the animation.

••

Ease Out: Limits the easing effect to the beginning of the animation.
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••

Linear: Removes all easing effects.

Tip:  Use the Crop effect and intermediate keyframes to create a Ken Burns–style effect that
follows a more complicated path.
For details on working with built-in effects, see Work with built-in effects on page 235.

Skew a clip’s perspective
The Distort effect is similar to the Transform effect, except that you can drag each of the corners
independently of the others, allowing you to create a skewed look or add a 3D perspective to
the image.
Note:  The Distort effect alters the shape of the video but does not actually move the video. To
move the video to a different position, use the Transform effect.
Adjust the Distort effect
1 Select a clip in the Timeline.
2 To access the Distort controls, do one of the following:
••

Choose Distort from the pop-up menu in the lower-left corner of the Viewer (or press
Option-D).

••

Control-click in the Viewer and choose Distort from the shortcut menu.

3 To adjust the effect using the onscreen controls:
••

Blue handles at each corner: Drag these to adjust the position of each corner, adding a 3D
perspective to the image by making parts of it appear closer to you than other parts.

••

Blue handles in the middle of each side: Drag these to adjust the position of each side. You can
create a skewed look by dragging them in the same direction as their edge (as opposed to
toward or away from the center).
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••

Anywhere inside the window: Drag anywhere inside the window to adjust its position.
Drag the center handles
to set a side’s position.

Drag each corner
to set its position.

4 To individually adjust each corner using the Video inspector, use the Distort controls.
5 When you are finished adjusting the effect and no longer need the onscreen controls, click Done.
You can animate the effect and have it appear over a background. For details on working with
built-in effects, see Work with built-in effects on page 235.

Work with built-in effects
Following are ways you can work with built-in effects.
Turn off or reset the effect
1 Select the clip with the effect in the Timeline.
2 Do one of the following:
••

To turn off the effect and retain its settings: Click the blue checkbox next to the effect used
(Transform, Crop, or Distort) in the Video inspector.
You can click the checkbox again to turn the effect back on, making it easy to compare how
the clip looks with and without the effect.
Move the pointer to this
area and click Show to
see an effect’s settings.

Click an effect’s icon to show
or hide its onscreen controls.
Click an effect’s Reset
button to return its settings
to their default values.
Click a checkbox to turn
an effect on or off.
••

To return all values for that effect to their default state: Click the Reset button
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••

To turn off the effect in the Video Animation Editor: Open the Video Animation Editor by
choosing Clip > Show Video Animation (or pressing Control-V), and click the checkbox next to
the effect you want to turn off.
Click an effect’s checkbox
to turn the effect on or off.

Animate built-in effects
Use keyframes to have the effect’s settings change as the clip plays. This applies to all built-in
effects except the Ken Burns effect.
1 Select a clip in the Timeline.
2 Choose the effect you want to animate from the pop-up menu in the lower-left corner of
the Viewer.
For this example, choose Transform (or press Shift-T).
3 Place the Timeline’s playhead at the start of the clip.
4 Adjust the effect’s onscreen controls to set the start position.
5 Click the Add Keyframe button in the upper part of the Viewer.
Click the Add Keyframe
button to add the first
keyframe to the animation.

6 Move the playhead to the end of the clip.
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7 Adjust the effect’s controls to set the end position.
A keyframe is automatically added. Additionally, for Transform effects, a line showing the image’s
path appears.
Click Done when you
are finished creating
the animation.

Click the Left Arrow
button to jump back
to the first keyframe.

The red line shows the
path of the image’s center.

8 To finish, click Done in the upper-right corner of the Viewer.
When you play the clip, the video moves smoothly between the keyframes, creating an animated
effect. You can actually add multiple keyframes by moving the playhead to a new position and
changing the effect’s controls. For more information on working with keyframes, see Video
animation overview on page 258.
Smooth position keyframes
You can modify the shape of a clip’s path in the Viewer by setting individual keyframes to be
smooth. This adds a set of Bezier handles that allow you to create intricate, complex shapes and
enables more control over the way your clips move. You can also remove the curves and the
handles used to create them by setting a keyframe to be linear.
1 In the Viewer, select a clip that has keyframes applied.
To learn how to add keyframes to a clip, see “Animate built-in effect,” above.
2 Click the Transform button to display the position keyframes.
3 Control-click any individual keyframe, and choose an option from the shortcut menu:
••

To convert the keyframe to a smooth keyframe: Choose Smooth.
Bezier handles appear, and you can drag those handles to control the curved shape of
the path.

••

To convert the keyframe to a corner point: Choose Linear.
Bezier handles are removed from the keyframe, and the keyframe becomes a corner point.
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Adjust the Transform effect animation path
Transform animations have additional keyframe controls you can use to fine-tune the animation
path. To show these, you first need to create a simple three-corner effect.
The Add Keyframe button
changes to a Delete Keyframe
button when you are
positioned on a keyframe.

The center keyframe

1 Select a clip in the Timeline and put the playhead at its start.
2 Choose Transform from the pop-up menu in the lower-left corner of the Viewer (or press Shift-T),
and drag the onscreen controls to reduce the image’s size and place it in the upper-left corner.
3 Click the Add Keyframe button.
4 Move the Timeline playhead to the middle of the clip.
5 Use the Transform onscreen controls to move the image to the upper-right corner.
A keyframe is automatically added, and a red line appears showing the animation’s path so far.
6 Move the Timeline playhead to the end of the clip.
7 Use the Transform onscreen controls to move the image to the bottom center.
A keyframe is automatically added, and the red line extends to this new point.
8 To jump between the keyframes, click the white squares along the red line.
The first and last keyframes have white arrows.
By default, the red line indicates a smooth path (indicated by how it curves).
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9 To control the curve of the path, click the starting or middle keyframe and drag the
curve handles.
The starting keyframe

The ending keyframe

Drag these handles
on a middle keyframe to
adjust the path’s curve.

10 Control-click a keyframe and choose an option from the shortcut menu:
••

Linear: Use for direct, non-curved paths in and out of that keyframe.

••

Smooth: Use for curved paths in and out of that keyframe, providing a more
natural movement.

••

Delete Point: Use to delete that keyframe.

••

Lock Point: Use to prevent that keyframe from being adjusted. It changes to Unlock Point
once set.

••

Disable Point: Use to ignore that keyframe, but keep the keyframe in place in case you want to
use it later. It changes to Enable Point once set.

Composite effects over a background
Often, Transform, Trim, and Distort effects result in the image being less than full size, with
the empty areas filled with black. You can replace the black with a background by placing the
transformed clip over a background clip, known as compositing.
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Do one of the following:
mm Add a clip to the Timeline as a connected clip and then add the effect to that clip.
This places the clip above the primary storyline clip, which automatically becomes the
effect’s background.
A clip that’s composited
over the primary storyline

The clip in the primary
storyline that is the
background

mm If the clip is already in the primary storyline, drag it above the primary storyline, positioning it
over the clip you want to be the background.
The result is a composited image.
The Transform and Trim effects
were used to composite this
image over the background.

For more information about working with connected clips, see Add storylines on page 277. For
more information about compositing clips, see Compositing overview on page 372.
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Add and adjust clip effects
Clip effects overview
In addition to the built-in effects, Final Cut Pro includes a wide variety of video effects that
you can apply to your project’s video clips. Many of the effects modify the look of your video,
from adding a blur or glow to severe distortions. Some effects overlay camcorder or timecode
graphics. There is also an effect for keying one video clip over another.
Final Cut Pro also includes a broad range of audio effects that you can apply to your project’s
audio clips. Many of the effects modify the sound of your audio, from subtle echoes to severe
pitch distortions.
Once you have added an effect, you can adjust its parameters. Some effects have few
adjustments, while others provide a comprehensive set, allowing you a lot of control over how
the effects look. Effects can even be animated, with their settings changing as the clip plays.
You can apply multiple effects to your clips, creating a stack of effects. The order that you apply
the effects, however, can affect how the final video looks.
Additionally, many of the video effects can be opened and changed in Motion, allowing you to
create specialized versions for use in your projects.

Add effects to your project
You add effects to clips in your project using the Effects Browser.
Add an effect to a project clip
1 Select a clip in the Timeline and click the Effects button in the toolbar.

2 In the Effects Browser, select an effect, using any of the following to help you make the selection:
••

To preview what the effect looks like using the video from the currently selected Timeline clip: Move
the pointer over the video effect thumbnails.

••

To preview changing the effect’s primary control: Hold down the Option key while moving the
pointer over a video effect thumbnail.

••

To filter the list of effects that appear: Type text in the Effects Browser search field.

3 Do one of the following:
••

Drag the effect to the Timeline clip to which you want to apply it.

••

Double-click the effect thumbnail to apply it to the selected clip.

You can now adjust the effect.
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Adjust effects in Final Cut Pro
Most effects have one or more parameters that you can adjust using the Video inspector or
Audio inspector, the Viewer, or the Video Animation Editor or Audio Animation Editor. You can
also control how the effect is applied to the clip, either gradually or constantly.
Adjust an effect in the Video inspector and Viewer
1 In the Timeline, select the clip with the effect you want to adjust.
2 Locate the effect in the Video inspector or Audio inspector.
Click to turn the
effect on and off.

Click to reset the
effect’s adjustments.

In the above example, there are several settings for the Censor effect. Many effects also have
adjustments that appear in the Viewer, known as onscreen controls.
Tip:  For audio effects, you can click the Controls button (to the right of the effect’s name) to
show a custom control window.
Click to show the effect’s
custom control window.

3 Select effect parameters and adjust their settings as needed.
To return the effect’s values to their default settings, you can click the effect’s Reset button

.

Adjust an effect in the Video Animation Editor
Many effect parameters can be adjusted in the Video Animation Editor. Additionally, you can set
these parameters to fade in and out, allowing you to gradually apply the effect’s settings.
1 Select the clip with the video effect in the Timeline.
2 Choose Clip > Show Video Animation (or press Control-V).
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The effect appears as one of the animations in the Video Animation Editor above the clip. You
can click its checkbox to turn the effect off and on. Effects that have more than one adjustable
attribute also have a pop-up menu for you to choose the attribute to show and adjust.
Click to turn the
effect on and off.

Choose a specific
effect adjustment from
this pop-up menu.

Double-click
effects with this
icon to vertically
expand them.

3 To vertically expand the effect’s adjustment area, choose a specific effect adjustment from the
pop-up menu (if present) and double-click it.
This applies only to effect adjustments that have a single value. An icon appears on the right side
of the effect’s section if the adjustment can be expanded.
4 To have the effect’s setting fade in and out of the clip, drag the handles on either end of
the effect.
Drag the fade handles to
gradually apply the effect.

Drag this line
to adjust the
selected value.

You can also drag the horizontal line up and down to control the effect’s selected setting
(Amount, in the above example). Any keyframes you add also appear.
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Show the audio effects applied to a clip
1 Select the clip with the audio effect in the Timeline.
2 Choose Clip > Show Audio Animation (or press Control-A).

The audio effect appears as one of the animations in the Audio Animation Editor. You can click its
green checkbox to turn the effect off and on.

Change clip effect order
You can apply multiple clip effects to a Timeline clip. The order that you apply them can affect
the final output. For example, applying the Artifacts effect, which by default adds random white
circles to the video, before the Aged Paper effect results in the white circles also being aged;
applying it after Aged Paper results in the circles remaining white.
You can easily change the order of the clip effects in the Video inspector, Audio inspector, Video
Animation Editor, or Audio Animation Editor.
Note:  You cannot change the order of the built-in effects or color correction.
Change video and audio clip effect order using the Video or Audio inspector
1 Select a clip in the Timeline that has multiple video or audio clip effects applied, and do one of
the following:
••

To see the video effects: Open the Video inspector.

••

To see the audio effects: Open the Audio inspector.

2 In the Video inspector or Audio inspector, drag the effects to change their order.

Drag clip effects to
rearrange their order.
Built-in effects and color
correction cannot be
rearranged.
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Change video and audio clip effect order using the Video Animation or Audio Animation Editor
1 Select a clip in the Timeline that has multiple video or audio clip effects applied, and do one of
the following:
••

To see the video effects: Choose Clip > Show Video Animation (or press Control-V).

••

To see the audio effects: Choose Clip > Show Audio Animation (or press Control-A).

2 In the Video Animation Editor or Audio Animation Editor, drag the effects to change their order.

Drag clip effects to
rearrange their order.

Built-in effects
and color correction
cannot be rearranged.

Copy effects and attributes between clips
Final Cut Pro offers two ways to copy effects between clips. The Paste Attributes command lets
you copy selected clip attributes to another clip and provides more control over individual
effects, settings, and keyframes. The Paste Effects command lets you copy all of a clip’s effects to
another clip and is the fastest way to copy effects and attributes.
You can also copy and paste individual keyframes from one parameter to another. See Copy and
paste keyframes on page 246.
Copy selected clip attributes to another clip
You can copy a clip’s attributes, such as settings and effects, from one clip to another. For
example, you can copy video crop settings, audio pan settings, or any effects you’ve added to a
clip, including any keyframe adjustments.
The Paste Attributes feature allows you to select which clip attributes you want to apply.
1 Select a clip in the Timeline, and choose Edit > Copy (or press Command-C).
2 Select the clip or clips to which you want to apply the attributes, and choose Edit > Paste
Attributes (or press Shift-Command-V).
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3 Do any of the following:
••

To apply all video or all audio attributes from the source clip: Select the Video Attributes or Audio
Attributes checkbox.

••

To apply individual attributes: Select the checkbox or checkboxes for each attribute you want
to apply.

4 If you made any keyframe adjustments to the source clip, choose either Maintain Timing or
Stretch to Fit from the Keyframes pop-up menu. If you choose Stretch to Fit, Final Cut Pro adjusts
the keyframes in time to match the duration of the destination clip.
5 Click Paste.
Copy all of a clip’s effects to another clip
1 In the Timeline, select the clip you want to copy the effects from, and choose Edit > Copy (or
press Command-C).
2 Select the clip or clips to which you want to apply the effects, and choose Edit > Paste Effects (or
press Option-Command-V).
All the source clip’s effects and their settings are applied to the destination clip. For more control
over individual attributes, follow the instructions in “Copy selected clip attributes to another
clip,” above.

Copy and paste keyframes
You can copy and paste individual keyframes from one parameter to another. This allows you to
move or duplicate a specific effect (or part of an effect) from one clip to another. For example,
you can copy and paste an animated color correction effect or an audio filter adjustment.
You can also move or copy keyframes from one parameter to another within the same clip. For
example, you can copy the center point keyframes from a kaleidoscope effect and paste them in
the center point of a radial blur effect so that both effects follow identical paths.
You can even copy and paste keyframes within a single parameter, allowing you to create a
repeating pattern, or to move an animation from the beginning of a clip to a point later in time.
Keyframes can be copied from any parameter, including parameters in clip effects (such as
opacity, position, and audio volume), parameters in effects applied from the Effects Browser (such
as Gaussian Blur or Channel EQ), and even published parameters for a title. Any keyframes you
can select can be cut, copied, and pasted.
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Note:  Some parameters’ keyframes can be pasted only onto a similar parameter. For example,
you can paste audio volume keyframes from one clip to another clip’s volume animation, but you
cannot paste those keyframes to a clip’s opacity animation.
Keyframes are always pasted beginning at the location of the playhead or skimmer, and a
specific parameter must be selected before you choose the Paste command. If the playhead or
skimmer is not currently over the selected clip, no keyframes are pasted.
Note:  Pasted keyframes replace any keyframes already applied to the destination parameter
within the time range of the pasted keyframes. Keyframes outside the time range being pasted
are not affected. For example, if you select a range of opacity keyframes covering a 5-second
range, and paste them to a new clip’s opacity setting, keyframes within the 5 seconds beginning
at the playhead or skimmer are replaced with the copied keyframes. Any keyframes before or
after that range remain the same.
Copy or move keyframes from one clip to another
1 Select the clip in the Timeline containing the keyframes you want to copy.
2 To display the specific parameter you want to copy from, do one of the following:
••

To show the Video Animation Editor: Choose Clip > Show Video Animation (or press Control-V).

••

To show the Audio Animation Editor: Choose Clip > Show Audio Animation (or press Control-A).

3 Double-click the graph of the parameter containing the keyframes you want to copy.
The graph expands, revealing keyframes arranged along a curve.
Note:  Some parameters allow you to select keyframes without expanding the graph.
4 Shift-click the keyframes you want to copy or drag a selection rectangle around them.
The selected keyframes are highlighted in yellow.
5 Do one of the following:
••

To duplicate the keyframes: Choose Edit > Keyframes > Copy (or press Option-Shift-C).

••

To move the keyframes: Choose Edit > Keyframes > Cut (or press Option-Shift-X).

The keyframes are copied to the Clipboard.
6 Select the clip into which you want to paste the keyframes, and show the Video Animation Editor
or Audio Animation Editor for that clip.
7 Click the name or keyframe graph for the parameter you want to paste the keyframes to.
When selected, the graph becomes highlighted.
8 Position the playhead or skimmer on the frame where you want the new keyframes to begin.
9 Choose Edit > Keyframes > Paste (or press Option-Shift-V).
The keyframes are added to the selected parameter.
Copy or move keyframes from one parameter to another
1 In the Video Animation Editor or Audio Animation Editor, select the keyframes you want to copy.
Shift-click to select multiple keyframes or drag a selection rectangle around the keyframes you
want to select.
2 Do one of the following:
••

To duplicate the keyframes: Choose Edit > Keyframes > Copy (or press Option-Shift-C).

••

To move the keyframes: Choose Edit > Keyframes > Cut (or press Option-Shift-X).
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3 Select the parameter to which you want to paste the keyframes.
If Solo Animation is turned on, click the parameter pop-up menu and choose the graph for the
parameter you want to copy or move the keyframes to. For more on using Solo Animation, see
Adjust video effects using keyframes on page 259.
Note:  Some parameters’ keyframes can be pasted only onto a similar parameter. For example,
you can paste audio volume keyframes from one clip to another clip’s volume animation, but you
cannot paste those keyframes to a clip’s opacity animation.
4 Position the playhead or skimmer on the frame where you want the pasted keyframes to begin.
5 Choose Edit > Keyframes > Paste (or press Option-Shift-V).
The keyframes are added to the selected parameter.

Turn off or remove an effect from a clip
When you apply an effect to a clip, you can either turn off the effect (but retain its settings) or
remove the effect from the clip.
Turn off a clip effect
1 Select the clip with the effect in the Timeline.
2 Do one of the following:
••

Choose Clip > Show Video Animation (or press Control-V) to see video effects or choose Clip >
Show Audio Animation (or press Control-A) to see audio effects, select the effect, and click
its checkbox.

••

Select the effect in the Video inspector or Audio inspector, and click its blue checkbox.

The effect no longer affects the video or audio. You can click the checkbox again to turn the
effect back on, with its settings still intact.
Remove an effect from a clip
1 Select the clip with the effect in the Timeline.
2 Do one of the following:
••

Choose Clip > Show Video Animation (or press Control-V) to see video effects or choose Clip >
Show Audio Animation to see audio effects, select the effect, and press Delete.

••

Select the effect in the Video inspector or Audio inspector, and press Delete.

Create specialized versions of the video effects in Motion
Many of the supplied video effects were created using Motion, an Apple application designed
to work with Final Cut Pro. You can open any of these effects in Motion, make modifications, and
save the changes as a new effect that appears in the Effects Browser.
Important:  The following steps require you to have Motion 5 installed on your computer.
Modify a video effect in Motion
1 Click the Effects button in the toolbar.

2 In the Effects Browser, Control-click the effect you want to modify, and choose “Open a copy in
Motion” from the shortcut menu.
Motion opens and the effect’s project appears.
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3 Modify the effect’s project.
For more information, see Motion Help at http://help.apple.com/motion.
4 Choose File > Save As (or press Shift-Command-S), enter a name for this new effect (referred to
as a Template in Motion), assign it to a category (or create a new category), choose a theme (if
needed), and click Publish.
Note:  If you choose File > Save, the effect is saved using the same name with “copy” appended to
its end.

Add generators
Generators overview
Final Cut Pro includes a number of video clips, called generators, that you can use in your project
for a variety of purposes. For example, you can use generators to add the following elements:
••

Placeholder content: If your project is missing content that hasn’t yet been shot or delivered,
you can add a placeholder clip. The placeholder generator allows you to add a clip to the
Timeline with a suitable silhouette to represent the missing content. See Use a placeholder on
page 249.

••

Timecode counter: You can add a generated timecode clip to your project to superimpose
a timecode counter over a portion or the entire project. See Use a timecode counter on
page 250.

••

Shape clip: You can choose from a wide variety of shapes for adding graphical elements to
your project. See Use a shape on page 251.

••

General-purpose background clip: Final Cut Pro includes a variety of still and animated
backgrounds over which you can superimpose titles or keying effects. See Use a
background on page 252.

All of the generators are added as clips to the project, using their default duration. You can
change their duration and position the same way you would any other video clip in the Timeline.
Note:  Generator clips do not appear in the Effects Browser.

Use a placeholder
Generated placeholders are useful in many situations where you want to fill a gap in the project
with something that provides a hint about what the final content will include. You can configure
placeholder clips to represent a wide variety of standard shots, such as close-ups, groups, wide
shots, and so on.
Insert and configure a placeholder clip
1 Drag the playhead in the Timeline to the point where you want to add the placeholder clip.
2 Do one of the following:
••

Choose Edit > Insert Generator > Placeholder (or press Option-Command-W).

••

Open the Generators Browser by clicking the Generators button in the toolbar, and doubleclick the thumbnail named Placeholder.
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3 Select the placeholder clip in the Timeline.
4 Configure the shot for the clip to represent using the settings in the Generator inspector.

5 Select View Notes to add a text area in the Viewer where you can type text that pertains to
this clip.
If you prefer to fill a gap in your Timeline with a blank clip, you can insert a gap clip. For more
information, see Insert clips in your project on page 101.

Use a timecode counter
When sending your project for review, it can be useful to superimpose timecode over it, making
it easier for the reviewer to precisely specify sections when providing feedback.
Insert and configure a timecode counter
1 Open the Generators Browser by clicking the Generators button in the toolbar.

2 Drag the Timecode generator above the primary storyline.
Usually the Timecode generator clip is placed at the start of the project, but you can place it
anywhere you want it to appear and adjust its length to match the project’s length.
3 Configure the Timecode settings in the Generator inspector.

You can click the Reset button

to return the generator to its default settings.
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Use a shape
You can configure the Shapes generator to be any of a number of shapes, such as a star, a
diamond, an arrow, and a heart. These are most often used above the primary storyline to add a
graphical element to your project that you can animate.
Insert and configure a shape
1 Open the Generators Browser by clicking the Generators button in the toolbar.

2 Drag the Shapes generator above the primary storyline so that it is over the video clip you want
the shape to appear over.
The default shape is a white circle.
3 Choose the shape to use from the Shape pop-up menu in the Generator inspector.
4 Set the shape’s fill color, outline color and width, and drop shadow.
You can click the Reset button

to return the generator to its default settings.

5 To change the shape’s size, position, and rotation, use the Transform or Distort built-in effect.

Use the Transform effect
to change the size, position,
and rotation of the shape.

Using these effects also makes it possible to animate the shape. For example, you can have an
arrow follow a person across a room.
6 To make the shape partially transparent, select it in the Timeline and adjust its Opacity setting in
the Video inspector.
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Use a background
Many of the generators provide a general background over which you can place built-in effects,
titles, keys, and clips with an alpha channel. Some are solid colors while others are textures
such as wood or stone. Some generators even have animated movement, providing a more
interesting background.
Insert and configure a background clip
1 Drag the playhead in the Timeline to the point where you want to add the background clip.
2 Open the Generators Browser by clicking the Generators button in the toolbar.

3 In the Generators Browser, double-click the background thumbnail you want to use.
4 Select the background clip in the Timeline.
5 Configure the background (if applicable) using the settings in the Generator inspector.

Create specialized versions of the generators in Motion
Many of the generators were created using Motion, an Apple application designed to work
with Final Cut Pro. To further customize the generators, you can open them in Motion, make
modifications, and save the changes as a new file that appears in the Generators Browser.
Important:  The following steps require you to have Motion 5 installed on your computer.
Modify a generator or background in Motion
1 Open the Generators Browser by clicking the Generators button in the toolbar.

2 In the Generators Browser, Control-click a thumbnail, and choose “Open a copy in Motion” from
the shortcut menu.
Motion opens and the clip’s project appears.
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3 Modify the clip’s project.
For more information, see Motion Help at http://help.apple.com/motion.
4 Choose File > Save As (or press Shift-Command-S), enter a name for this new generator, and
click Save.
Note:  If you choose File > Save, the generator is saved using the same name with “copy”
appended to its end.

About themes

Final Cut Pro includes a number of generators, transitions, and titles, grouped into themes. The
generators, transitions, and titles in each theme use related shapes and colors, which result in a
visual style unique to each theme.
Theme names—such as Boxes, Comic Book, or Documentary—suggest elements used by the
theme, or the type of project in which a theme might be used. Each theme may contain multiple
video generators, video transitions, and titles.
To access the Themes Browser, click the Themes button in the toolbar.

For more information about video generators, see Generators overview on page 249.
For more information about video transitions, see Transitions overview on page 211.
For more information about titles, see Titles overview on page 220.

Use onscreen controls
Onscreen controls overview
Many effects, transitions, and other items use onscreen controls, superimposed over the video
in the Viewer, to make it easier to adjust a variety of parameters. In many cases, these onscreen
controls duplicate controls in the inspectors, although in some cases the controls are unique and
provide the only way to adjust a particular parameter.
The controls can be as simple as defining the center of a fisheye effect or defining the more
complex diameter, width, and position of a vignette effect.
This section focuses on the types of onscreen controls found in clip effects and transitions.
Onscreen controls are also available in other areas of Final Cut Pro, including the following:
••

Built-in effects: Onscreen controls are used extensively for all built-in effects. See Built-in effects
overview on page 228.

••

Chroma keying: You use specialized onscreen controls when configuring a chroma keyer. See
Use chroma keys on page 355.

••

Color corrections: Color corrections can contain onscreen controls used for creating color masks
and shape masks. See Manual color correction overview on page 380.
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Show or hide onscreen controls
The onscreen controls for transitions appear when a transition is selected. The onscreen
controls for clip effects appear when an effect is selected, or when the playhead is positioned
over a clip or title in the Timeline that has a video effect applied. You can also show or hide the
onscreen controls.
Note:  Onscreen controls are always hidden when you play clips in the Timeline.
Show or hide a transition’s onscreen controls
mm To show the transition’s onscreen controls: Select the transition in the Timeline.
mm To hide the transition’s onscreen controls: Deselect the transition in the Timeline.
Show or hide a clip effect’s onscreen controls
mm To show the effect’s onscreen controls: Position the playhead over a clip with the effect, or select
the clip with the effect in the Timeline, and then select the effect in either the Video Animation
Editor or the Video inspector.
mm To hide the effect’s onscreen controls: Deselect the clip with the effect in the Timeline, or deselect
the effect in the Video Animation Editor or Video inspector.
Note:  If a clip contains multiple effects that use onscreen controls, only the topmost effect’s
onscreen controls appear when the playhead is positioned over the clip.

Onscreen control examples
Following are a few examples of the onscreen controls you might use while working with
clip effects and transitions. Many other clip effects and transitions use these same or similar
controls—the examples are intended to provide general information about using the
onscreen controls.
Keep the following in mind while going through these examples:
••

These examples assume you are familiar with applying clip effects to clips in the Timeline.

••

You can apply multiple clip effects to the same clip, but for the purpose of these examples, it’s
best to either apply each clip effect to a different Timeline clip or remove the clip effect before
applying a different one.

••

These examples also assume you are familiar with adding transitions to edit points in
the Timeline.

••

Most of the effects and transitions have additional adjustments in the Video inspector or
Transition inspector.
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Example: Use onscreen controls to apply a Censor effect
1 Open the Effects Browser and drag the Censor effect to a clip in the Timeline.
2 To adjust the effect’s onscreen controls, do any of the following:
••

To position the effect: Drag the center circle.

••

To set the effect’s size: Drag the outer circle.
Drag this center circle to
position the effect.

Drag this circle to
set the effect’s size.

Example: Use onscreen controls to apply a Droplet effect
1 Open the Effects Browser and drag the Droplet effect to a clip in the Timeline.
2 To adjust the effect’s onscreen controls, do any of the following:
••

To position the effect: Drag the center circle.

••

To set the effect’s outer limit: Drag the outer circle.

••

To set the effect’s inner limit: Drag the inner circle.

••

To set the effect’s overall size: Drag any area in between the inner and outer circles. A shaded
area appears when the pointer is in this area.
Drag this center circle
to position the effect.

Drag the outer circle to
set the outer boundary.

Drag any area between the
circles (becomes shaded)
to set the overall effect size.

Drag the inner circle to
set the inner boundary.
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Example: Use onscreen controls to apply a Prism effect
1 Open the Effects Browser and drag the Prism effect to a clip in the Timeline.
2 To adjust the direction of the effect, drag the arrow.
Because the effect has no center setting, the circle in the center cannot be dragged.
This center circle cannot
be dragged since the effect
has no center setting.

Drag the arrow to set
the effect’s direction.

Example: Use onscreen controls to apply a Scrape effect
1 Open the Effects Browser and drag the Scrape effect to a clip in the Timeline.
2 To adjust the effect’s onscreen controls, do any of the following:
••

To position the effect: Drag the center circle.

••

To set the effect’s direction: Drag the rotation handle.
Drag the center circle to set
the effect’s start position.
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Example: Use onscreen controls to apply a Center transition
1 Open the Transitions Browser and drag the Center transition to an edit point in the Timeline.
2 To adjust the transition’s onscreen controls, do any of the following:
••

To position the transition: Drag the center circle.

••

To set the transition’s direction: Drag the arrow.

••

To set the transition’s border width (softness in this case): Drag the outer handle toward or away
from the center circle.
Drag this center circle to
position the transition.

Drag this arrow to set the
transition’s direction.

Drag this handle to set
the border width (softness
amount in this case).

Example: Use onscreen controls to apply a Star transition
1 Open the Transitions Browser and drag the Star transition to an edit point in the Timeline.
2 To adjust the transition’s onscreen controls, do any of the following:
••

To position the transition: Drag the center circle.

••

To set the number of points on the star: Drag the longer handle.

••

To rotate the star: Drag the shorter handle.
Drag this center circle to set
the transition’s position.

Drag this handle to set the
number of points on the star.

Drag this handle to rotate
the star transition.
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Example: Use onscreen controls to apply a Zoom & Pan transition
1 Open the Transitions Browser and drag the Zoom & Pan transition to an edit point in
the Timeline.
2 To adjust the transition’s onscreen controls, do any of the following:
••

To set the transition’s start point: Drag the green circle.

••

To set the transition’s end point: Drag the red circle.
Drag the red circle
to set the end point.

Drag the green circle
to set the start point.

Use the Video Animation Editor
Video animation overview
With Final Cut Pro, you can create simple changes to video over time, such as fading the video
from invisible to visible at the beginning of a movie. Or you can make sophisticated and precise
adjustments over time to many individual parameters of video effects, transitions, motion paths,
and so on.
In Final Cut Pro, you use keyframes and fade handles in the Video Animation Editor to change
effects over time.
The word keyframe comes from the traditional workflow in the animation industry, where only
important (key) frames of an animated sequence were drawn to sketch a character’s motion over
time. Once the keyframes were determined, an in-between artist drew all the frames between
the keyframes.
With Final Cut Pro, you can set parameters to specific values at specific times (represented by
keyframes) and Final Cut Pro acts as an automatic, real-time in-between artist, calculating all
the values between your keyframes. For example, to animate a parameter, such as a rotation or
scale setting, you need to create at least two keyframes in the clip. Final Cut Pro figures out the
setting’s value between the keyframes, creating a smooth motion as the setting changes.
You can keyframe and animate both video and audio effects in Final Cut Pro, including individual
effect parameters and clip properties. To learn more about keyframing audio, see Adjust audio
effects using keyframes on page 195.
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Adjust video effects using keyframes
You place keyframes at specific points in a clip to change parameter values at those points.
For example, if you want a clip in your project to fade to black, you set two opacity keyframes at
two different times: one with the value of 100 (fully visible) and a second with the value of 0 (fully
transparent). Final Cut Pro interpolates the values between 100 and 0, creating a smooth fade
to black.
You can set keyframes in the Timeline or in the Video inspector. To see keyframes in the Timeline,
you need to display the Video Animation Editor for the clip.
Additional keyframing controls appear with the Final Cut Pro built-in effects. See Work with
built-in effects on page 235.
For information about keyframes for audio clips, see Adjust audio effects using keyframes on
page 195.
Add keyframes
1 Do one of the following:
••

Select a clip in the Timeline, and choose Clip > Show Video Animation (or press Control-V).

••

Control-click a clip in the Timeline, and choose Show Video Animation from the shortcut
menu.

Each effect in the Video Animation Editor has a separate area for adding keyframes.

Some effects have more than one parameter and allow you to add keyframes to individual
parameters separately. They appear in the Video Animation Editor with a triangle next to the
effect’s name or in the Video inspector as additional parameter controls.
2 Select the effect for which you want to add keyframes in either the Video Animation Editor or the
Effects section of the Video inspector.
3 Do one of the following:
••

To see expanded parameters in the Video Animation Editor: Click the triangle to choose
an individual parameter from the pop-up menu, or choose All to add keyframes for
all parameters.

••

To see expanded parameters in the Video inspector: Click Show when you position the pointer
over the effect.
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4 Do one of the following for each effect:
••

In the Video Animation Editor: Option-click (or press Option-K) at a point on the horizontal effect
control where you want to add the keyframe.
Keyframes for the parameter you chose appear as white diamonds, while keyframes for other
effect parameters appear gray.

Keyframe for the
selected parameter

When you choose to view all parameters in the Video Animation Editor, keyframes appear as
white diamonds for all parameters. Double diamonds indicate you added a keyframe for more
than one parameter at that point.

Double diamonds
••

In the Video inspector: Position the playhead in the Timeline at the point where you want to
add a keyframe, and click the Keyframe button (or press Option-K).
Once you add a keyframe, the Keyframe button changes to yellow, indicating that the
playhead currently sits on this keyframe.

Keyframe button

When you move the playhead in the Timeline, arrows appear next to the Keyframe button
in the Video inspector to indicate which side of the playhead has keyframes. To go to the
previous keyframe, click the left arrow or press Option-Semicolon (;). To go to the next
keyframe, click the right arrow or press Option-Apostrophe (‘).

Arrows

5 Add keyframes as needed.
Tip:  After you’ve added one keyframe, you can add another automatically by moving the
playhead in the Timeline and then adjusting the effect parameter value in the Video inspector.
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Add keyframes automatically across a selected area
If an effect appears in the Video Animation Editor with a disclosure button, you can use either
the Select or Range Selection tool to add keyframes automatically across a selected area.
1 Do one of the following:
••

Select a clip in the Timeline, and choose Clip > Show Video Animation (or press Control-V).

••

Control-click a clip, and choose Show Video Animation from the shortcut menu.

2 Select an effect, and click the disclosure button to expand it in the Video Animation Editor.

Disclosure button

3 In the Timeline, choose either Select or Range Selection from the Tools pop-up menu in the
toolbar (or press A for Select, or R for Range Selection).
4 Drag across the area in the Video Animation Editor where you want to adjust the effect.
Tip:  To deselect the range, click anywhere on the Timeline background.

5 Adjust the effect within the range by dragging the effect’s horizontal control up or down.
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Keyframes are automatically created along the adjustment points within the range.

Adjust keyframes in the Video Animation Editor
You can move keyframes left or right in the Video Animation Editor. If an effect appears with a
disclosure button, you can expand the effect view and move keyframes up or down to change
the parameter value.
1 Select a keyframe.
2 Do one of the following:
••

To change its position in time, drag a keyframe left or right.
As you drag, the timecode value appears.

Drag the keyframe
left or right.

••

If an effect appears with a disclosure button, click the button (or double-click the effect) to
expand it.

Disclosure button
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With the effect expanded, you can drag the keyframe up or down to change the effect’s
parameter value.
Drag the keyframe up or down.

To add another keyframe, Option-click (or press Option-K) at a point on the effect control
where you want to add the keyframe. To add a keyframe and change the effect’s parameter
value at the same time, Option-click while dragging the effect control up or down.
If an effect appears with a disclosure button in the Video Animation Editor, you can also fade
video effects in or out, or change the shape of the effect curve between keyframes.
Adjust keyframes in the Video inspector
For many effects, you adjust the parameter value of individual keyframes using the
Video inspector.
When you move the playhead in the Timeline, arrows appear next to the Keyframe button in
the Video inspector to indicate which side of the playhead has keyframes. To go to the previous
keyframe, click the left arrow or press Option-Semicolon (;). To go to the next keyframe, click the
right arrow or press Option-Apostrophe (‘).

Arrows

1 Select a keyframe or position the playhead on a keyframe, and adjust the parameter value in the
Video inspector.
2 To change the value at the next keyframe, go to the next keyframe and adjust the value again.
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Delete keyframes
Do one of the following:
mm Select a keyframe in the Video Animation Editor, and press Option-Shift-Delete.
mm Navigate to a keyframe in the Video inspector, and click the Keyframe button.
After navigating to
a keyframe, click the
Keyframe button to
delete the keyframe.

View only one effect at a time in the Video Animation Editor
You can collapse the Video Animation Editor to view only one effect at a time. This can be useful
if you have multiple effects applied to a clip and want to preserve screen space.
1 Choose Clip > Solo Animation (or press Control-Shift-V).
2 In the Video Animation Editor, click the triangle next to the displayed effect’s name to choose an
effect from the pop-up menu.
Note:  When Solo Animation is turned on, you can’t delete effects from the Video
Animation Editor.
To turn off Solo Animation, choose Clip > Solo Animation (or press Control-Shift-V).
Hide video animation for a clip
Do one of the following:
mm Select the clip in the Timeline, and choose Clip > Hide Video Animation (or press Control-V).
mm Click the close button

in the upper-left corner of the Video Animation Editor.

mm Control-click the clip in the Timeline, and choose Hide Video Animation from the shortcut menu.

Modify groups of keyframes
There are many ways you can modify keyframes to create simple or complex animations. In
addition to modifying individual keyframes as described in the previous section, you can also
modify keyframe groups, effect curves (the line segments between keyframes), or the entire set
of keyframes for a given parameter, and you can make all of these changes with great precision.
Select and modify multiple keyframes
1 To select multiple keyframes in the Video Animation Editor, the Audio Animation Editor, or
directly in the body of the clip (for audio level keyframes), do one of the following:
••

Shift-click more than one keyframe.
All intermediate keyframes are selected. You cannot select nonadjacent keyframes.

••

Drag a selection rectangle around the keyframes you want to select.
Note:  In the Video Animation Editor or Audio Animation Editor you can select a range by
dragging with the Select tool or the Range Selection tool. To select a range of keyframes
displayed in the clip body (such as audio keyframes) you must use the Range Selection tool.

2 To modify the selected keyframes, do any of the following:
••

To move the group to a different place in time: Drag any individual keyframe horizontally.

••

To change the value of all the keyframes: Drag any individual keyframe vertically.
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Keyframe values remain relative to one another while dragging; however, if you “flatten” the
curve by dragging all the way to the top or bottom of the graph, the keyframe values remain
in that flattened state with all keyframes sharing the same value.
••

To increase the relative values by 1: Press Option–Up Arrow.

••

To decrease the relative values by 1: Press Option–Down Arrow.

••

To move both keyframes earlier in time by 1 frame: Press Comma (,).

••

To move both keyframes later in time by 1 frame: Press Period (.).

Tip:  You can also modify any two keyframes simultaneously by selecting the line segment in
between them, then performing any of the steps above.
Adjust all keyframes on a curve
mm In the Video Animation Editor, the Audio Animation Editor, or directly in the body of the clip (for
audio level keyframes), hold down the Command and Option keys, and drag either a keyframe or
a curve up or down.
All keyframes are adjusted by the same amount, preserving the original shape of the curve.
However, if you “flatten” the curve by dragging all the way to the top or bottom of the graph, the
keyframe values remain in that flattened state with all keyframes sharing the same value.

Before

After

You can also copy specific keyframes between different attributes or between different clips. See
Copy and paste keyframes on page 246.
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Adjust effect curves using fade handles or keyframe animation
Some effects in the Video Animation Editor include fade handles, which allow you to adjust how
long it takes for an effect to fade in or out. For example, you can use fade handles to adjust how
long it takes for an opacity effect to fade in, how long it takes to fade up from black, or how long
it takes to fade to black.
You can also move keyframes up or down to create a curve for the effect parameter and change
the curve shape (interpolation) between keyframes.
Creating a fade or an effect curve smooths the transition so that the effect changes appear more
natural when the clip plays.
Change an effect using fade handles
1 Click the disclosure button to expand the effect in the Video Animation Editor.

Disclosure button

Note:  If an effect doesn’t have a disclosure button, it doesn’t have fade handles.
2 Drag the fade handle to the point in the clip where you want the fade to begin or end.
Fade handles from the beginning of a clip create a fade-in, while fade handles at the end of a clip
create a fade-out.
Fade-in

Fade-out

Chapter 9    Add transitions, titles, effects, and generators

266

Change an effect using keyframes
mm Click the disclosure button to expand the effect in the Video Animation Editor, and do any of the
following:

Disclosure button

Note:  If an effect doesn’t have a disclosure button, you can’t move keyframes up or down.
••

To add a keyframe: Option-click (or press Option-K) at a point on the effect control where you
want to add the keyframe.
Tip:  To add a keyframe and change the effect’s parameter value at the same time, Option-click
while dragging the effect control up or down.

••

To change the effect’s parameter value at a particular keyframe: Select a keyframe and drag it up
or down.
Tip:  To adjust values with greater precision, hold down the Command key while dragging the
keyframe up or down.
Drag the keyframe up or down.
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Change the curve shape (interpolation) between keyframes
Do one of the following:
mm Command-Drag the line horizontally between the keyframes to create a curve.
mm Control-click the line between keyframes, and choose a curve option from the shortcut menu.

••

Linear: Maintains a constant rate of change over the duration of the fade.

••

Ease: Eases in and out of the fade with the midpoint set between the beginning and
end values.

••

Ease In: Starts quickly from the beginning value and then moves slowly toward the end value.

••

Ease Out: Starts slowly from the beginning value and then moves quickly toward the
end value.

Note:  You can change the curve shape between keyframes for video effects only. For audio
volume only, you can change the curve shape for fades created using fade handles, but not
keyframes. See Fade audio in or out on page 176.
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Group clips with compound clips
Compound clips overview
With Final Cut Pro, you can create compound clips, which allow you to group any combination of
clips in the Timeline or the Browser and nest clips within other clips.
Compound clips can contain video and audio clip components, clips, and other compound clips.
Effectively, each compound clip can be considered a mini project, with its own distinct project
properties. Compound clips function just like other clips: you can add them to your project,
trim them, retime them, and add effects and transitions. Icons appear on compound clips in the
Browser and the Timeline.
Compound clip
icon for a clip
in the Browser

Compound clip
icon for a clip
in the Timeline

Compound clips have many uses. You can:
••

Simplify a complicated project by creating a separate compound clip for each major section.

••

Synchronize a video clip with one or more audio clips and then combine the clips into a
compound clip, to avoid inadvertently moving them out of sync.

••

Open any clip, edit its contents in the Timeline, and then close it.

••

Quickly create a compound clip containing the clips in an event, based on the Browser
sort order.

••

Use a compound clip to create a section of a project with settings different from those of the
main project.
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The following diagram shows how a project in the Timeline could be simplified using
compound clips:
Selected clips in the Timeline

New compound clip

Compound clips have the following characteristics:
••

You create compound clips in the Browser or in the Timeline.

••

Every compound clip in the Timeline has a “parent” compound clip in the Browser.
Browser clips

Parent compound clip

Project 1

Child clip

••

Project 2

Child clips

Project 3

Child clip

When you edit the contents of any compound clip, you are in fact editing the parent
compound clip from the Browser. Any changes you make to the compound clip are inherited
by all of its child clips. For example, if you delete a title clip from the contents of a parent
compound clip, the title clip is deleted from all child clips.
You can create an independent compound clip from an existing compound clip. For example,
you might have a compound clip of a standard title sequence for your TV or podcast series.
You can create unique (independent) instances of the compound clip for each episode
without affecting other instances of the title sequence.
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You can also create a snapshot of the entire project. Project snapshots are self-contained
backup versions that include compound or multicam parent clips. Duplicating a project as a
snapshot makes copies of the compound or multicam parent clips and embeds them in the
project so that any changes to other instances of the clips do not affect the snapshot. For
more information, see Duplicate projects and clips on page 64.
Note:  Compound clips in Final Cut Pro X provide all the functionality of the nested sequence
feature in Final Cut Pro 7, with more flexibility and ease of use.

Create and break apart compound clips
You can create a compound clip from existing clips in the Timeline or the Browser, or you can
create a new, empty compound clip in the Browser and add clips to it in the Timeline. You can
also break a compound clip into its component parts in the Timeline, so that the items are no
longer grouped.
Create a compound clip from existing clips
1 Select one or more clips in the Timeline or the Browser.
The selected clips can be any combination of contiguous or noncontiguous clips, compound
clips, primary storyline clips, or connected clips.
2 Do one of the following:
••

Choose File > New Compound Clip (or press Option-G).

••

Control-click the selection and choose New Compound Clip from the shortcut menu.

Note:  When you add a compound clip to the Timeline or create a compound clip from existing
clips in the Timeline, you create a direct and active relationship between a parent compound clip
in the Browser and the child compound clip in the Timeline. If the parent clip doesn’t already
exist in the Browser, Final Cut Pro creates one automatically. When you edit the contents of a
compound clip (for example, by trimming or adding effects to clips within the compound clip),
you are in fact editing all instances of that compound clip, including the parent compound clip
in the Browser.
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The way clips are grouped within the compound clip depends on where you selected the clips:
••

If you selected clips in an event: Final Cut Pro creates a new compound clip in the event
(in addition to the selected clips) and places duplicates of the selected clips in the new
compound clip horizontally, in the order in which you selected them. (For further instructions
on creating a compound clip in the Browser, see “Create an empty compound clip,” below.)
Selected clips in the Browser

New compound clip

Compound
clip contents
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••

If you selected clips in the Timeline: Final Cut Pro places the selected clips in the new compound
clip exactly as they are laid out in the Timeline. The new compound clip inherits the frame size
and frame rate of the current Timeline.
Selected clips in the Timeline

New compound clip

Compound
clip contents

Create an independent compound clip from an existing compound clip
1 Select a compound clip in the Timeline.
2 Choose Clip > Reference New Parent Clip.
Final Cut Pro creates a new parent compound clip in the Browser. This command breaks the
relationship between the selected compound clip in the Timeline and its original parent
compound clip (as well as any child clips of the original parent clip, in all projects).
Note:  You can also select multiple clips in step 1 and Final Cut Pro will make one or more parent
clips, depending on the existing parent clip references.
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Create an empty compound clip
You can create new, empty compound clips and then add clips to them. Each compound clip can
be considered a mini project, with its own distinct project properties.
1 In a library, select an event to which you want to add the compound clip.
2 Choose File > New Compound Clip.
In the window that appears, type a name for the compound clip in the Name field.
3 Click Use Custom Settings to further customize settings for your compound clip.
Note:  Final Cut Pro shows the Automatic Settings by default, but it will remember the settings
you used last, so this step may be unnecessary.
4 By default, Final Cut Pro sets the Starting Timecode field to the lowest timecode value in the
selected clips. If you want the compound clip’s timecode to start at a different value, type that
starting timecode value in the Starting Timecode field.
5 To adjust video, audio, and render settings, click Custom. Unless you have a specific requirement
for the compound clip you’re creating, it’s best to leave “Set automatically based on first video
clip” and “Use default settings” selected.
6 Click OK.
The new compound clip appears in the event.
Edit the contents of a standard clip in the Timeline
You can edit the contents of a standard clip.
mm Select a clip in the Browser or the Timeline, and choose Clip > Open in Timeline.
The Timeline displays the contents of the clip. Most standard clips include a video component, an
audio component, or both. You cannot edit the contents of these video and audio components.
You can add media to the contents of this clip (by adding clips to this Timeline). To close this clip,
navigate up one level in the Timeline history.
Note:  Because editing in Final Cut Pro is nondestructive, any changes you make to the contents
of standard or compound clips do not affect the corresponding source media files, which remain
unchanged on your computer’s hard disk. For more information about the difference between
media files and clips, see Media files and clips on page 22.
Break apart clip items
You can break apart a compound clip or a standard clip to convert its contents to individual clips
in the Timeline.
mm Select a compound clip or a standard clip in the Timeline, and choose Clip > Break Apart Clip
Items (or press Shift-Command-G).
Final Cut Pro replaces the clip selected in the Timeline with the individual items that made up
the clip.
If you selected a compound clip, its contents revert back to the original clips that made up the
compound clip. However, the parent compound clip remains in the Browser.
If the selected clip is a standard clip, the contents appear as individual clips in the Timeline. Most
standard clips include a video component or an audio component or both. The audio will appear
as a connected clip.
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Manage compound clips
There are many ways to manage and edit compound clips. For example, you can open up
compound clips (and edit their component parts) in a separate Timeline. You can easily navigate
up and down a series of compound clip levels. And you can open and edit a compound clip from
within an event.
Note:  When you edit the contents of a compound clip (for example, by trimming or adding
effects to clips within the compound clip) you are in fact editing all instances of that compound
clip, including the parent compound clip in the Browser. Any changes you make to the internal
parts of the compound clip are inherited by all of its child clips, in all projects. These changes can
include added or deleted clips, trimming adjustments, and video or audio effects such as color
correction, clip speed retiming, and so on. For example, if you delete a title clip from a parent
compound clip, the title clip is deleted from all child compound clips.
Open a compound clip for editing
Do one of the following:
mm Select a compound clip in the Timeline or the Browser, and choose Clip > Open in Timeline.
mm Double-click the video portion of a compound clip in the Timeline or the Browser.
mm Click the compound clip icon in the upper-left corner of a compound clip in the Timeline.
The compound clip opens in a new Timeline view, with its contents ready for editing.
Compound clip in a project in the Timeline
Project

Compound clip opened in a new Timeline view
Project

Compound clip

Note:  Because editing in Final Cut Pro is nondestructive, any changes you make to the contents
of standard or compound clips do not affect the corresponding source media files, which remain
unchanged on your computer’s hard disk. For more information about the difference between
media files and clips, see Media files and clips on page 22.
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Navigate compound clip levels using menu commands and keyboard shortcuts
You can navigate up or down one or more levels of a compound clip.
mm To move forward (down one level): Choose View > Timeline History Forward, or press Command–
Right Bracket (]).
mm To move back (up one level): Choose View > Timeline History Back, or press Command–Left Bracket
([).
Navigate compound clip levels using the arrow buttons
Do one of the following:
mm Click the left and right arrows in the upper-left corner of the Timeline.

mm Click and hold the right or left arrow in the upper-left corner of the Timeline, and choose a level
from the pop-up menu.

The left arrow effectively closes the current compound clip and opens its parent, with the top
level being the project or event containing the compound clip. If there is no history available to
navigate, both the left and right arrows are dimmed.
Make sure all contents of a compound clip appear in your movie
When you’re editing the contents of a compound clip, Final Cut Pro indicates the boundary of
the compound clip with a dark gray, cross-hatched area to the left of the start point of the clip
and to the right of the end point of the clip.
If you add clips to the contents of the compound clip, any parts of any clips that extend into the
dark gray area do not appear in your project.

Any clips in the dark gray,
cross-hatched area do not
appear in your final movie.
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To have the new clip material appear in your project, do one of the following to make room for
the new material:
mm Reduce the total duration of the other clips inside the compound clip. For example, you could
trim one or more clips inside the compound clip.
mm Close the compound clip to navigate up one level, and extend the total duration of the parent
clip (the “outside shell” of the compound clip) in the Timeline.
For more information, see Trimming overview on page 122.

Add storylines

Storylines are sequences of clips connected to the primary storyline. They combine the
convenience of connected clips with the precision editing capabilities of the primary storyline.
You can use storylines for the same purposes as connected clips (such as creating cutaways,
compositing titles and other graphics, and adding sound effects and music).
The unique advantage of storylines is the ability to edit a sequence of connected clips within the
context of the other clips in the Timeline. For example, you can add cross dissolve transitions to a
series of superimposed titles in a storyline and then adjust the timing of the titles to match clips
in the primary storyline. Like connected clips, storylines can contain both video and audio, or
they can be video only or audio only. For more information about connected clips, see Connect
clips to add cutaway shots, titles, and synchronized sound effects on page 103.
Storyline

Primary storyline

Audio-only storyline

You edit storylines using the same methods you use to edit the primary storyline. You can:
••

Add clips: Drag clips to the storyline to add them, or use the standard append, insert, replace,
and overwrite commands.

••

Add transitions, titles, effects, and generators: Add effects to a storyline by dragging them or by
using any of the standard commands and keyboard shortcuts.
Note:  When you apply a transition to a clip connected to the primary storyline, a storyline is
automatically created for that clip.
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••

Trim clips: Use any of the standard trim edits in a storyline, including ripple, roll, slip, and slide.
You can also trim or move clips within storylines by entering timecode values.

••

Create split edits: Set separate video and audio start and end points in an individual clip to
create split edits (L-cuts and J-cuts) in a storyline.

Create or break apart storylines
You can quickly create storylines from existing connected clips.
1 In the Timeline, select two or more connected clips.

2 Choose Clip > Create Storyline (or press Command-G).
A gray border appears around the clips, indicating a storyline.
The gray border
indicates a storyline.

Note:  If the original connected clips are not contiguous, Final Cut Pro inserts a gap clip to fill the
space between the clips.
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You can also create a storyline by holding down the G key as you drag a clip to a connected clip
so that their edges touch:
Hold down the G key as you
drag a clip to a connected clip.

3 To convert a storyline back to its component clips, do one of the following:
••

Select the storyline (by clicking the gray border), and choose Clip > Break Apart Clip Items (or
press Shift-Command-G).

••

Drag the storyline into the primary storyline.

Select and move storylines
You can select or move entire storylines as if they were standard clips or compound clips. They
have the connection properties of connected clips.
mm To select an entire storyline: Click the gray border of the storyline.
mm To move a storyline by dragging it: Click the gray border of the storyline, and drag it left or right to
connect it to a different point along the primary storyline.

Drag the storyline left or right.

mm To move a storyline with timecode values or keyboard shortcuts: Use the same techniques you
would use with standard clips.
For more information, see Arrange clips in the Timeline on page 117.
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Fine-tune edits with the Precision Editor

You can fine-tune the edit point between two clips in the Timeline using the Precision Editor,
which provides an expanded view of the clips on either side of the edit point as well as the
unused portions of each clip. You can trim or extend the end of one clip and the beginning of
the next, either separately or together. As you make changes, you can instantly see how your
edits affect the cut or transition from one clip to the next.
You can see a “two-up” display in the Viewer as you trim edit points in the Timeline. For more
information, see Show detailed trimming feedback on page 137.
Adjust the edit point between clips with the Precision Editor
1 Choose either the Select tool or the Trim tool from the Tools pop-up menu in the toolbar,
and double-click the edit point you want to trim in the Timeline.

Double-click the edit point
you want to trim.

The Precision Editor appears, presenting an expanded view of your outgoing and incoming
shots. The edit point is represented by a vertical line in the center of the Precision Editor. The
outgoing clip and the clips before it appear in the top part of the storyline. The incoming clip
and the clips after it appear in the bottom part.
The dimmed portions of clips to the right and left of the edit line are the unused portions of
media that are available for trimming (called media handles). You can skim over these areas to
view and play back the media to help you decide where to trim.
Outgoing clip end point

Edit line handle

Chapter 10    Advanced editing

Edit line

Skimmer

Incoming clip start point

280

2 To adjust the edit point, do any of the following:
••

Move the edit line in the center of the Precision Editor by dragging its handle left or right.

Drag the edit line
handle left or right.

Moving the entire edit line performs a roll edit.
••

Drag the end point of the outgoing clip or the start point of the incoming clip. This performs a
ripple edit.
Note:  You can drag the edit line or individual edit points to the extent that there are media
handles available. When you extend a clip to its maximum length in either direction, the clip
edge turns red.
Drag the end point of the
outgoing clip or the start
point of the incoming clip.
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••

Skim over and click the outgoing clip or the incoming clip at any point.
Click either clip at any point.

The clip’s edit point is adjusted to the frame you click. This is the equivalent of a ripple edit.
The clip’s edit point moves
to the frame you click.

You can also enter a timecode value to adjust the edit point numerically. If you select either
the end point of the outgoing clip or the start point of the incoming clip, a ripple edit is
performed. Otherwise, a roll edit is performed.
3 To navigate to another edit point, do one of the following:
••

To go directly to an edit point: Click the other edit point.

••

To go to the next or previous edit point: Press the Up Arrow or Down Arrow key.

4 To close the Precision Editor, do one of the following:
••

Double-click the current edit point, or press the Esc (Escape) key.

••

Click the Close Precision Editor button at the bottom-right corner of the Timeline.
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Create split edits

Final Cut Pro allows you to set separate video and audio start and end points in an individual
clip. These edits, known as split edits, can be used in many different situations—in dialogue
scenes, when cutting to illustrative B-roll footage during an interview, or when transitioning from
one scene to another.
You can use a split edit to introduce the sound of a new shot or scene before cutting to the
video of that shot or scene. Conversely, you can use a split edit to extend the audio of a shot
over a subsequent shot. For example, you could cut from a clip of a person talking to video of a
person listening, while the audio from the first clip continues.
The split edit technique results in L-shaped and J-shaped clips with audio extending to the left
or the right. These are known as L-cuts and J-cuts.
Note:  Whenever you use split edits in a project, it’s recommended that you choose View >
Expand Audio/Video Clips > For Splits (so that there’s a checkmark next to the menu item). This
setting provides you with the most accurate display of all your split edits.
Create a split edit by dragging
To create the split edit, you extend the audio of one clip over a neighboring clip. In this example,
the audio from the close-up of the man is extended over the close-up of the woman to create a
J-cut.
1 Add clips to the Timeline in the order in which you want them to appear in your movie.

2 To show separate audio for the clip you want to edit, do one of the following:
••

In the Timeline, select the clip whose audio you want to expand, and choose Clip > Expand
Audio/Video (or press Control-S).

••

Double-click the clip’s audio waveform.

The audio and video portions of the clip appear as discrete components that you can change
individually. They are still attached and will remain in sync.
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3 Drag the start point (left edge) of the video portion of the clip to the right, effectively trimming it
with a ripple edit.
The example below shows the video start point of the close-up of the man being dragged to
the right.

This creates a J-shaped split edit, with the start point of the audio overlapping the preceding clip.
4 To complete the split edit, show separate audio for the preceding clip, and do one of the
following:
••

Drag the preceding clip’s end point to the left so that the two audio clips no longer overlap.

••

Adjust the audio (fade) level of either clip so that the audio overlap sounds natural.

5 If you want to turn off the separate audio view to “clean up” the affected clips, do one of the
following:
••

Choose View > Collapse All Clips.

••

Select the clip in the Timeline, and choose Clip > Collapse Audio/Video (or press Control-S).

Chapter 10    Advanced editing

284

••

Double-click the clip’s audio waveform.

When you play back this section of the Timeline, you hear the man begin to speak before the
video cuts to the close-up of him. In this way, you can use split edits to create seamless edits
from one shot to the next.
Create a split edit using keyboard shortcuts
You can create split edits quickly using keyboard shortcuts. In this example, the audio from the
close-up of the man is extended over the close-up of the woman to create a J-cut.
1 Confirm that the two adjacent clips have sufficient media handles. If not, trim the clips (shorter)
to create the media handles.
2 To expand (show separate audio) for the two adjacent clips, do one of the following:
••

In the Timeline, select the clips whose audio you want to expand, and choose Clip > Expand
Audio/Video (or press Control-S).

••

Double-click the clip’s audio waveform.

3 Move the playhead to the edit point between the two clips.

Playhead at edit point

To ensure accurate playhead placement, use keyboard shortcuts:
••

To move the playhead to the previous edit point: Press Semicolon (;) or the Up Arrow key.

••

To move the playhead to the next edit point: Press Apostrophe (‘) or the Down Arrow key.
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4 Do one of the following:
••

To select both sides of the audio edit point: Press Shift-Backslash (\).

••

To select both sides of the video edit point: Press Backslash (\).

Selected audio edit point

5 To roll the audio edit point or the video edit point, do any of the following:
••

To nudge the edit point left or right: Press Comma (,) or Period (.), respectively.

••

To nudge the edit point 10 frames left or right: Press Shift-Comma (,) or Shift-Period (.),
respectively.

••

To add or subtract from the current edit using timecode: Press Plus Sign (+) or Minus Sign (–)
followed by the timecode duration, and press Return.
The timecode entry field (with blue numbers) appears in the Dashboard in the toolbar as you
type. For more information about entering timecode values, see Navigate using timecode on
page 143.

Shifted edit point

Original edit point

When you play back this section of the Timeline, you hear the man begin to speak before the
video cuts to the close-up of him. In this way, you can use split edits to create seamless edits
from one shot to the next.
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Make three-point edits
Three-point editing overview
Three-point editing allows you to use start and end points in the Browser and the Timeline to
specify the duration of a clip and where it should be placed in the Timeline. Three-point editing
gets its name from the fact that only three edit points are necessary to determine the portion
of the source clip to use and where to place that clip in the Timeline. Final Cut Pro infers the
fourth edit point automatically. The result of the edit depends on which three points are set in
the Browser and in the Timeline: two start points and one end point or one start point and two
end points.
You can use three-point editing with the following types of edits:
••

Insert

••

Connect

••

Overwrite

With each of these edit types, you can also perform backtimed three-point edits, in which the
end point (rather than the start point) is aligned with the skimmer or playhead position in either
the Browser or the Timeline. You can also make two-point edits in which start and end points are
inferred from the skimmer position and the clip duration.
To make three-point edits, it’s important to know how to make selections and how to use the
skimmer and the playhead. For more information about making selections, see Select a range on
page 94 and Select one or more clips on page 92. For more information about the skimmer and
the playhead, see Playback and skimming overview on page 77.
Basic three-point editing has three stages:
Stage 1: Set source selection edit points in the Browser
Specify which part of a clip you want to place in the Timeline. You do this by setting the start and
end points. If you want to set just a start point in the Browser, position the skimmer (or playhead)
at the point where you want the edit to begin. In this case, the end point is determined by the
start and end points set in the Timeline or by the end of the clip. You can also select multiple
clips in the Browser, and their aggregate source media duration determines the start and
end points.
Stage 2: Set edit points in a storyline in the Timeline
Specify where you want the clip to appear in the Timeline by setting start and end points in the
primary storyline or in a connected storyline. If both start and end points are set in the Timeline,
these edit points determine the edit duration, regardless of the duration set in the Browser. If no
start or end points are set in the Timeline, Final Cut Pro uses the skimmer position for the start
point of the edit. If the skimmer is not present, Final Cut Pro uses the playhead position.
Important:  With few exceptions, three-point editing requires range selections (rather than clip
selections).
Stage 3: Add the source clip or selection to the Timeline
Choose to either insert, connect, or overwrite.
Important:  Timeline start and end points always take precedence over start and end points set
in the Browser. This means that if you set both a start point and an end point in the Timeline, the
Timeline start and end points determine the duration of the edit, regardless of the start and end
points in the Browser. This allows you to limit your edit to a specific section of the Timeline.
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There are a few key things to keep in mind when making three-point edits.
Edit points set
••

••

••

••

••

••

••

••

Results

Source selection start and end
points in the Browser
Destination start point in the
Timeline

The start point of the source selection in the Browser is aligned with the
destination start point in the Timeline, and the duration of the edit is
determined by the source selection start and end points in the Browser.

Source selection start point in
the Browser
Destination start and end
points in the Timeline

The start point of the source selection in the Browser is aligned with the
destination start point in the Timeline, and the duration of the edit is
determined by the destination start and end points in the Timeline.

Source selection start and end
points in the Browser
Destination end point in the
Timeline

The end point of the source selection in the Browser is aligned with the
destination end point in the Timeline, and the duration of the edit is
determined by the source selection start and end points in the Browser.

Source selection end point in
the Browser
Destination start and end
points in the Timeline

The end point of the source selection in the Browser is aligned with the
destination end point in the Timeline, and the duration of the edit is
determined by the destination start and end points in the Timeline.

Note:  This edit requires a range selection in the Timeline. You can use
or the I and O keys for this purpose. For
the Range Selection tool
more information about making range selections, see Select a range on
page 94.

This is known as “backtiming” an edit. Use this method when you want to
make sure a clip ends at a specific point in the project.

This is known as “backtiming” an edit. Use this method when you want to
make sure a clip ends at a specific point in the project.
Note:  This edit requires a range selection in the Timeline. You can use
or the I and O keys for this purpose. For
the Range Selection tool
more information about making range selections, see Select a range on
page 94.

Three-point edit examples
In Final Cut Pro, you can make precise edits using a combination of three (or sometimes two)
edit points set in the Browser and the Timeline. For more information, see Three-point editing
overview on page 287.
Here are a few examples of ways to make three-point edits.
Example: Make a three-point edit
The simplest way to perform a three-point edit is to specify start and end points for the
source selection in the Browser, and then specify the destination start point in your project by
positioning the skimmer (or the playhead) in the Timeline.
1 Set start and end points for the source selection in the Browser.
Start point
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2 In the Timeline, position the skimmer (or the playhead, if the skimmer is not present) at the
location in your project where you want the clip to start (the destination start point).

Position the skimmer at the
location in the project where
you want the clip to start.

3 To add the source selection to the project using an overwrite edit, press D.

The new clip starts where
the skimmer was positioned.

The portion of your source selection between the start and end points appears in the Timeline,
starting at the skimmer position.
By defining only three points—the source selection start and end points in the Browser and the
destination start point in the Timeline—you have total control of the edit.
Example: Make a backtimed three-point edit
You can make a three-point edit by defining source selection start and end points in the Browser
and a destination end point (instead of a destination start point) in the Timeline. This is called
backtiming a clip. You can use this method when you want to make sure a particular clip ends at
a specific point in a project, on a musical beat. In the resulting edit, the end point of the media
in the Browser selection is aligned with the end point you set in the Timeline, and the rest of the
source selection appears to the left.
1 Set start and end points for the source selection in the Browser.
Start point
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2 In the Timeline, position the skimmer (or the playhead, if the skimmer is not present) at the
location in your project where you want the clip to end.

Position the skimmer at
the location where you
want the clip to end.

3 Do any of the following:
••

To backtime the selection using a connect edit: Press Shift-Q.

••

To backtime the selection using an overwrite edit: Press Shift-D.

Your source selection is edited into the project so that the end point of the media in your source
selection lines up with the end point you specified in the Timeline.

The new clip ends where the
skimmer was positioned.

The rest of your clip has overwritten any material to the left of the end point for the duration
defined by the source selection start and end points set in the Browser.
Example: Make a three-point edit with multiple clips
You can make three-point edits with multiple clips at a time.
1 In the Browser, select two or more clips. (Don’t select a range within a single clip.)
For information about selecting multiple clips, see Select one or more clips on page 92.

Three clips are selected
to be placed in the storyline.
No range selection is set.
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2 In the Timeline, define a destination start point by positioning the skimmer at the location in
your project where you want the clip or group of clips to start.

Position the skimmer at the
location where you want the
group of clips to begin.

3 To add the selected clips to the project using an overwrite edit, press D.
The new group of clips
begins where the skimmer
was positioned.

The playhead moves to the
end of the new clips.

The entire group of clips selected in the Browser has been edited into the project.
Note:  The clips are added in the order in which you selected them.
Because you used an overwrite edit, any clip items already in the project are overwritten by the
clips selected in the Browser for the duration of the Browser clips.
You can also make a three-point edit involving multiple clips in the Timeline. To select a range
across multiple clips in the Timeline, you use the Range Selection tool
or the I and O keys. For
more information about range selections, see Select a range on page 94.
Example: Make a two-point edit
You can make an edit without any selections in either the Browser or the Timeline. This is known
as a two-point edit. In this case, Final Cut Pro acts on the current clip in the Browser from the
position of the skimmer or playhead to the end of the clip, and on the project in the Timeline
from the position of the skimmer or playhead forward.
You can also make backtimed two-point edits, in which Final Cut Pro acts on the current clip in
the Browser and the project in the Timeline from the skimmer or playhead position back.
In either case, the duration of the edit is determined by the skimmer or playhead position and
the end of the clip in the Browser.
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1 To specify a source selection start point in the Browser, move the skimmer or playhead to the
location where you want the edit to start (but don’t make any selections).
The Browser playhead
position determines the
source selection start point.

2 To specify a destination start point in the Timeline, move the skimmer or playhead to the
location where you want the edit to start (but don’t make any selections).
The skimmer position in the Timeline
is the destination start point.

3 To add the clip to the project using an overwrite edit, press D.
The new clip starts where the skimmer was positioned.
The new clip starts where
the skimmer was positioned.
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Try out clips using auditions
Auditions overview
In Final Cut Pro you can organize related clips into sets, called auditions, from which you can
choose one clip to use. You can create an audition composed of different clips to try out multiple
takes, or you can create an audition composed of multiple versions of the same clip to preview
different effects.
An audition’s filmstrip displays the currently selected clip, called the pick. All other clips in the
audition are referred to as alternates. You can open an audition to see the selected clip and
the alternates.
Alternate clips

Selected clip

Auditions allow you to preserve your alternate edits without affecting the other clips in the
Timeline. When you’re not auditioning the clips in an audition, the audition functions like an
individual clip. You can trim an audition, apply transitions between auditions and other clips, and
add keywords and markers. You can keep your audition containing your alternate clips for as
long as is necessary.
After you’ve reviewed the clips in the audition and decided which one works best in your project,
you can finalize the audition, which dissolves it and leaves the pick as an individual clip in the
Timeline. The pick retains the audition’s position in the Timeline and all keywords and markers
applied to the audition.
Note:  Auditions appear in the Browser and Timeline as clips with an Audition icon in the
upper-left corner.
Icon for an audition
in the Browser

Icon for an audition
in the Timeline
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Create auditions to try out clips
You can create auditions in the Browser and then add them to the Timeline, or you can create
auditions directly in the Timeline. When you create auditions in the Timeline, you can either
group related clips or group multiple versions of the same clip (for example, to try out multiple
effect treatments or lower-third titles).
Icon for an audition
in the Browser

Icon for an audition
in the Timeline

Create auditions in the Browser
mm Select the clips you want to include in the audition, and choose Clip > Audition > Create (or
press Command-Y).
Create auditions in the Timeline
mm To create an audition with related clips: Drag a clip or a group of clips from the Browser onto a clip
in the Timeline, and choose an audition option from the shortcut menu.
Choosing Add to Audition creates an audition with the current Timeline clip as the pick.
Choosing Replace and Add to Audition makes the clip you’re dragging the pick.
Important:  If a transition is applied to the current clip in the Timeline and the pick for the new
audition lacks sufficient media for the transition, the transition is either shortened or removed.
mm To create an audition with a duplicate version of a clip, including applied effects: Select a clip in the
Timeline, and choose Clip > Audition > Duplicate as Audition.
An audition is created containing the selected clip and a duplicate version that includes any
effects applied to the original.
mm To create an audition with a duplicate of the original version of a clip, without applied effects:
Select a clip in the Timeline, and choose Clip > Audition > Duplicate from Original (or press
Shift-Command-Y).
An audition is created containing the selected clip and a duplicate version without any
applied effects.
mm To create an audition with a duplicate of the original version of a clip, with effects and attributes from
another clip: Select a clip in the Timeline that has the attributes you want to copy, and choose
Edit > Copy (or press Command-C). Then select the clip you want to make into an audition and
choose Clip > Audition > Duplicate and Paste Effects (or press Option-Command-Y).
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An audition is created containing the selected clip and a duplicate version with effects and
attributes copied from the first clip.
Open an audition
After you create an audition, it’s easy to open it and review its contents.
Do one of the following:
mm Choose Clip > Audition > Open (or press Y).
mm Click the Audition icon.
Audition icon

The Audition window appears, and you can preview your clips to choose a pick.
Break apart an audition
You can break apart an audition to convert its contents to individual clips in the Timeline.
mm Select an audition in the Timeline, and choose Clip > Break Apart Clip Items (or press
Shift-Command-G).
Final Cut Pro replaces the audition selected in the Timeline with the individual items that made
up the audition.
You can also break apart compound clips, storylines, and standard clips. For more information,
see Create and break apart compound clips on page 271 and Add storylines on page 277.

Add and remove clips in auditions
When building auditions to try out different clips or versions of a clip with different effects, you
can add and remove clips at any time. In the Browser and the Timeline, you can add new clips
to the audition as well as duplicate clips within an audition. When an audition in the Timeline
contains the clips you want to try out, you can use the audition to preview the clips or effects in
your project.
Add clips to an audition in the Browser
mm To add new clips to an audition in the Browser: Select the audition and the clips you want to add to
it, and choose Clip > Audition > Create (or press Command-Y).
Select clips to add
to the audition.
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mm To duplicate a clip within an audition in the Browser: Click the icon in the upper-left corner of the
audition to open the Audition window, select the clip you want to duplicate, and click Duplicate.
Select the clip you
want to duplicate,
and click Duplicate.

A new version of the selected clip appears in the Audition window.
Add new clips to an audition in the Timeline
mm To add a new clip to an audition and maintain the current clip in the Timeline as the pick: Drag a
clip from the Browser to the audition in the Timeline, and choose Add to Audition from the
shortcut menu.
mm To add a new clip to an audition and make the clip you’re adding the pick: Drag a clip from the
Browser to the audition in the Timeline, and choose Replace and Add to Audition from the
shortcut menu.
Important:  If a transition is applied to the current clip in the Timeline and the pick for the new
audition lacks sufficient media for the transition, the transition is either shortened or removed.
mm To duplicate a clip within an audition: Click the Audition icon in the upper-left corner of the
audition to open the Audition window, select the clip you want to duplicate, and click Duplicate
(or press Shift-Command-Y).
Select the clip you
want to duplicate,
and click Duplicate.

A new version of the selected clip appears in the Audition window.
mm To add a duplicate of the original version of an audition pick, with effects and attributes from another
clip: Select a clip in the Timeline that has the attributes you want to copy, and choose Edit > Copy
(or press Command-C). Then select the audition and choose Clip > Audition > Duplicate and
Paste Effects (or press Option-Command-Y).
Remove a clip from an audition
1 To open the audition containing the clip you want to remove, click the icon in the upper-left
corner of the audition.
2 In the Audition window, select the clip you want to remove, and press Delete.
The clip is removed from the audition.
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Use auditions to try out clips in your project
You create an audition to try out the clips within it and find the one that works best for your
project. Although the auditioning workflow may differ from project to project, the general
process is the same. You create an audition that contains a set of alternate takes, effects, or
text treatments, and then you choose the best clip for the edit by making it the pick. When
you’re sure of your decision, you finalize the audition, which dissolves it and leaves the pick in
the Timeline.
Depending on your workflow, you may try out the clips within your auditions and flatten the
auditions as you go, or you may leave the auditions in the Timeline for the purpose of showing
alternate edits to a client.
Note:  You can use audition commands only with one selected audition at a time. For example,
you can’t finalize multiple selected auditions.
Review clips within an audition in the Timeline
1 In the Timeline, select the audition containing the clips you want to review, and open it by
choosing Clip > Audition > Open (or pressing Y).
The clip under the spotlight
in the center of the window
is the pick.

2 In the Audition window, select the pick and press the Space bar (or press Control-Command-Y)
to play it.
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3 To play an alternate clip in the Viewer, select a clip to the right or left of the pick (or press the
Right Arrow or Left Arrow key).
The alternate becomes
the new pick and plays
back in the Viewer.

The star icon indicates
the previous pick.

Tip:  To quickly move through and play alternate clips, select a closed audition in the Timeline,
press the Space bar, and press Control-Left Arrow to play clips to the left of the current pick, or
Control-Right Arrow to play clips to the right.
4 When you decide on the clip you want to use, make sure it’s selected under the spotlight, and
click Done.
5 If you’re sure of your decision and want to finalize the audition, choose Clip > Audition > Finalize
Audition (or press Option-Shift-Y).
The audition is dissolved, leaving the pick in the Timeline. The clip selected as the pick retains any
keywords or markers assigned to the audition.
Try out multiple effects on a clip in the Timeline
You can try out effects on a clip in the Timeline by creating an audition and adding individual
effects to duplicates of the same clip. This technique allows you to view each effect in relation to
the clips that precede and follow the audition in the Timeline.
1 In the Timeline, select the clip you want to try different effects on.
2 Choose Clip > Audition > Duplicate as Audition (or press Option-Y).
3 Repeat step 2 for each effect that you want to audition.
4 To open the Audition window, click the icon in the upper-left corner of the audition (or press Y).
5 To open the Effects Browser, click the Effects button in the toolbar (or press Command-5).

6 In the Audition window, select the version of the clip you want to apply the effect to.
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7 In the Effects Browser, select the effect you want to try out, and drag it to the clip in the
Audition window.
Drag an effect from the
Effects Browser to a clip
in the Audition window.

8 Repeat steps 6 and 7 until you’ve applied all the effects you want to audition.
9 Review each effect’s impact on the clip in the Timeline by selecting a clip to the right or left of
the pick.
Click an alternate clip
to play it in the Viewer.

Tip:  To quickly move through and play alternate clips, press Control-Left Arrow to play clips to
the left of the current pick, or Control-Right Arrow to play clips to the right.
10 When you decide on the effect you want to use, select the clip with that effect in the Audition
window, and click Done.
11 If you’re sure of your decision, and want to finalize the audition, choose Clip > Audition > Finalize
Audition (or press Option-Shift-Y).
The audition is dissolved, leaving the clip with your chosen effect applied to it in the Timeline.
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Tip:  To save time, you can have Final Cut Pro automatically duplicate a clip in the Timeline and
apply an effect to the duplicated clip by holding down the Control key while you drag an effect
from the Effects Browser to the clip in the Timeline. You can also apply an effect to every clip in
an audition by holding down the Option key and the Control key while you drag the effect from
the Effects Browser to the audition in the Timeline. In both cases, you must start dragging the
effect from the Effects Browser and then press the keys as you add the effect to the clip.

Retime clips to create speed effects
Retiming clips overview
You can adjust a clip’s speed settings to create fast-motion or slow-motion effects. You can also
reverse a clip, rewind a segment of a clip, apply variable speed effects (also called speed ramping)
to a clip selection, and create instant replays and jumpcuts. By default, Final Cut Pro maintains
the audio pitch of any speed adjustment, but you can turn off this feature to accentuate the
speed effect.

You can’t apply speed changes to still images, generators, titles, and themes in Final Cut Pro.

Change clip speed
In Final Cut Pro you can make both constant and variable speed changes to your clips while
preserving the audio’s pitch.
Note:  Speed settings are applied to the specific instance of the selected clip only. They are not
applied to that clip’s source media file on disk. To create a media file with the applied speed
effects, export the clip as a QuickTime movie. For more information, see Share projects, clips, and
ranges on page 400.
Apply a constant speed change
Applying a constant speed change to a range selection or a whole clip alters the selection’s
playback speed by a uniform percentage. For example, applying a speed setting of 25 percent to
the selection makes the entire selection play in slow motion.
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Constant speed changes also usually alter the duration of a clip. By default, if a constant speed
change causes the duration of a clip to become longer or shorter, all clips coming after it ripple
forward or backward. If you change the speed to 50 percent, your clip becomes twice as long,
and subsequent clips are moved to the right; if you change the speed to 200 percent, the clip
becomes half as long, and subsequent clips ripple left. For example, if you set a 5-second clip
to play back at 50 percent speed, Final Cut Pro adds frames to the clip so that the clip becomes
10 seconds long and plays back more slowly. If you increase the clip’s speed to 200 percent,
Final Cut Pro removes frames and the clip plays back in only 2.5 seconds.
5-second clip

Same clip with speed
changed to 50 percent
(now 10 seconds long)

1 In the Timeline, select a range, a whole clip, or a group of clips whose speed you want to change.
2 Do one of the following:
••

To apply a preset speed setting: Choose Slow or Fast from the Retime pop-up menu in the
toolbar (shown below), and choose a speed from the submenu.

••

To apply a manual speed setting: Choose Show Retime Editor from the Retime pop-up menu (or
press Command-R) to display the Retime Editor above the selection in the Timeline, and drag
the retiming handle.
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If you drag the retiming handle to the right, the speed of the selection decreases, the duration
of the selection increases, and the bar above the Timeline selection turns orange.
Drag the retiming handle
to the right to create
a slow-motion effect.

If you drag the retiming handle to the left, the speed of the selection increases, the duration of
the selection decreases, and the bar above the Timeline selection turns blue.
Drag the retiming handle
to the left to create a
fast-motion effect.

••

To apply a custom speed setting: Choose Custom from the Retime pop-up menu, and in the
Custom Speed window that opens, select a direction (forward or reverse) and enter a rate
or duration.

Apply a constant speed change without rippling the sequence
You can also create speed changes that don’t cause the downstream clips to ripple. In this case,
if you slow down a clip (which ordinarily makes the clip longer), the clip remains at its current
length, but a shorter piece of the action will be seen. For example, if you slowed a 5-second
shot of a football being thrown and caught to 50 percent, you would see the ball being thrown
(slowly), but because the action would now take twice as long, the clip would end before the ball
was caught.
Note:   If there is a gap to the right of a clip that is being slowed down, the clip’s duration is
lengthened to cover the gap.
When a clip is sped up, the duration of the clip is shortened and a gap fills the space between
the changed clip and the remainder of the project.
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1 In the Timeline, select a range, a whole clip, or a group of clips whose speed you want to change.
2 Choose Custom from the Retime pop-up menu in the toolbar.

3 Select a direction (Forward or Reverse), deselect the Ripple checkbox, and type a percentage in
the Rate field.

4 Press Return.
The speed effect is applied to the clip, and the rest of the project remains in place.
Preserve audio pitch in retimed clips
By default, Final Cut Pro is set to preserve the audio pitch of a clip that has been retimed.
However, if you want to accentuate the retiming adjustment’s effect by allowing the pitch to
change in accordance with the retiming adjustment, you can turn this feature off.
1 In the Timeline, select a range, a whole clip, or a group of clips whose speed you plan to change.
2 Choose Preserve Pitch from the Retime pop-up menu in the toolbar.

A checkmark to the left of the command name indicates that Preserve Pitch is turned on. Choose
Preserve Pitch again to turn it off.
Conform a clip’s speed to match the project’s speed
If you’ve applied speed effects using your camera, the native speed of the source media may
not match the native speed of the source media for the rest of the clips in your project in the
Timeline. However, you can change the clip with the differing native speed to match the rest of
the clips in the Timeline.
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1 In the Timeline, select the clip whose speed you want to change to match the rest of the clips in
your project.
2 Choose Automatic Speed from the Retime pop-up menu in the toolbar.

Smooth out a slow-motion clip with video quality presets
To smooth out the apparent motion of a clip playing back in slow motion, you can apply frame
blending or optical flow analysis to the retimed clip.
1 In the Timeline, select a range, a whole clip, or a group of clips whose video quality you want
to change.
2 Choose a Video Quality setting from the Retime pop-up menu in the toolbar.

••

Normal: The default setting. Frames are duplicated, and no frame blending is applied to the
slow-motion clip. No rendering is required.

••

Frame Blending: Adds in-between frames by blending individual pixels of neighboring frames.
Slow-motion clips created with Frame Blending appear to play back more smoothly than
those created with the Normal (duplication) setting. Rendering is required.

••

Optical Flow: Adds in-between frames using an optical flow algorithm, which analyzes the clip
to determine the directional movement of pixels and then draws portions of the new frames
based on the optical flow analysis. Only the portion of the clip used in the project (the media
between the clip start and end points) is analyzed. Rendering is required.
Note:  The more motion contained in a clip, the longer the analysis and rendering takes.

Create variable speed effects
In addition to constant speed changes, you can create variable speed effects in which the
playback speed of a clip changes dynamically. For example, a clip might start in slow motion,
speed up to fast motion, and then slow back down to regular speed. You create variable speed
changes by identifying ranges of a clip as speed segments, each with its own constant speed
setting. Speed segments can be set to any speed value, forward or backward, and you can create
abrupt shifts between speed segments, or gradual transitions (also called ramps).
Note:  You can’t create smooth transitions between a speed segment set to a forward speed and
a speed segment set to reverse speed (and vice versa).
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Apply a preset variable speed change
You can apply preset variable speed effects that break your clip into multiple speed
segments automatically.
1 In the Timeline, select either a range within a clip or a whole clip to which you want to apply a
speed ramp effect.
2 Do one of the following:
••

To ramp the speed down: Choose Speed Ramp > “to 0%” from the Retime pop-up menu in
the toolbar.

••

To ramp the speed up: Choose Speed Ramp > “from 0%” from the Retime pop-up menu in
the toolbar.
The selection is segmented into four parts with different speed percentages, creating the
ramp effect. If more precision is required, you can manually drag any one of the four retiming
handles to set the speed you want.
Drag a retiming handle to
modify the speed percentage
of a speed ramp segment.

You can modify the transitions between segments to control how fast each segment transitions
to the next. For more information, see Add transitions between speed segments on page 307.
Change the end frame of a speed segment
You can change the end frame of a speed segment in the Timeline.
When you drag the retiming handle of a speed segment, you’re adjusting the speed of the
segment, not trimming it. The Change End Source Frame command allows you to trim the end
point (end frame) of a segment.
1 In the Timeline, select a clip that has speed segments.
2 Choose Show Retime Editor from the Retime pop-up menu in the toolbar (or press Command-R).

3 Double-click the transition between two speed segments in the Retime Editor in the Timeline.
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4 In the Speed Transition window, click the Edit button.
A filmstrip icon appears over the end frame of the speed segment.
5 To change the end frame, drag the filmstrip icon left or right.
Filmstrip icon

As you drag, the Viewer displays the current end frame.
Create custom variable speed changes
You can manually divide a clip into segments and assign each segment its own speed setting.
1 In the Timeline, position the playhead or the skimmer at the frame where you want to begin a
new speed segment.
2 Choose Blade Speed from the Retime menu in the toolbar (or press Shift-B).

The Retime Editor appears above the clip (If it wasn’t already shown), and the clip is divided into
two speed segments.

3 To set the speed for the newly created segments, do one of the following:
••

Double-click the Retime Editor above one of the speed segments. Then, in the Custom Speed
window, set a new speed by selecting either rate or duration and entering a speed percentage
or a duration. Click anywhere outside the Custom Speed window to close it.

••

Drag the right edge of the speed segment in the Retime Editor to change the
segment’s speed.

4 To create and modify additional speed segments, repeat steps 1 to 3.
You can modify the transitions between segments to create smooth adjustments from one
speed to another. For more information, see Add transitions between speed segments on
page 307.
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Add transitions between speed segments
When two adjacent speed segments are set to play at different speeds, you can control how
smoothly the video switches between the playback speeds. When there’s no transition between
the segments, playback shifts suddenly from one speed to another. By adding a transition
between the segments, you can create a more gradual, or ramped, effect. You can also control
how quickly that transition takes place.
When you apply effects that automatically create speed segments in a clip (such as Speed
Ramp, Instant Replay, and Hold), transitions are automatically added between the newly
created segments. A transition appears as a shaded bar on either side of the border between
speed segments.

When you create speed segments manually, you can add speed transitions individually, or you
can add them to all the speed segments in a clip at once.
Note:  You cannot add transitions between forward-playing segments and reverse-playing
segments (or vice versa).
Add transitions between all speed segments in a clip
1 In the Timeline, select a clip that has speed segments.

2 Choose Speed Transitions from the Retime pop-up menu in the toolbar, so that there’s a
checkmark next to the menu item.
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Transitions are automatically added to the boundaries between speed segments.

Remove transitions from all speed segments in a clip
1 In the Timeline, select a clip that has speed transitions.

2 Choose Speed Transitions from the Retime pop-up menu in the toolbar, so that the checkmark
is removed.

Speed transitions are removed from all speed segments in the clip.
Remove individual speed transitions
To add transitions between some speed segments in a clip and not others, you must turn on
Speed Transitions in the Retime pop-up menu, and then remove the transitions you don’t want.
1 In the Timeline, select a clip that has speed segments.
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2 Choose Speed Transitions from the Retime pop-up menu in the toolbar, so that there’s a
checkmark next to the menu item.

Speed transitions are added to all speed segments in the clip.
3 To remove a transition between speed segments, double-click the last frame of the outgoing
speed segment in the Retime Editor.

4 Deselect the Speed Transition checkbox in the Speed Transition window, and then click
anywhere outside the window to dismiss it.
The transition is removed.

Change the duration of a speed transition
After a speed transition is applied, you can change its duration. The shorter the transition, the
more quickly the speed ramps from one value to another. The longer the transition, the slower
the ramp.
1 In the Timeline, select a clip that has a speed transition.
2 If the Retime Editor is not showing, choose Show Retime Editor from the Retime pop-up menu
(or press Command-R).
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3 Drag the left or right edge of the shaded bar in the Retime Editor.

Reverse or rewind clips
In addition to changing the speed of a clip, you can also add directional effects:
••

Reverse: Reverses the order of frames in the clip, so that the last frame plays first.

••

Rewind: Appends a duplicate of the range selection or clip as a segment, rewinds the
duplicated segment at 1x, 2x, or 4x speed, and then plays the original clip segment again in
forward motion at normal speed.

Reverse a clip
1 In the Timeline, select a clip or a group of clips whose contents you want to reverse.
2 Choose Reverse Clip from the Retime pop-up menu in the toolbar.

The green bar with arrows pointing to the left above the selection in the Timeline indicates that
the clip is reversed.
3 If you want to adjust the speed of the reversed clip, drag the retiming handle to the left to
increase the speed or to the right to decrease it.

Drag the retiming
handle to change
the speed of the
reversed clip.

Reversed segment

4 To see the reverse effect, play back the reversed clip or selection.
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Rewind a range selection or clip
1 In the Timeline, select a range, a whole clip, or a group of clips whose contents you want
to rewind.
2 Choose Rewind from the Retime pop-up menu in the toolbar (shown below), and choose a
speed from the submenu.

The selection is duplicated, added to the end of the original selection, and then reversed
according to the speed choice. An additional duplicate of the Timeline selection follows the
reversed section and plays back in forward motion at the selection’s original speed.
3 If you want to adjust the speed of the rewound section or the sections that precede and follow
the rewound section, drag the section’s retiming handle to the left to increase the speed or to
the right to decrease it.
Drag a retiming handle
to change the speed.

4 Play the clip back to review the rewind effect.

Create instant replays
You can apply an instant replay to a range selection within a clip or a whole clip. Final Cut Pro
duplicates the range or clip, appending the duplicated frames to the end of the selection as a
new segment. You can then modify the speed of the new segment to achieve the instant replay
effect you’re looking for.
Create an instant replay
1 In the Timeline, select a range or a whole clip whose contents you want to use to create an
instant replay.
2 Choose Instant Replay from the Retime pop-up menu in the toolbar.

A duplicate of the range or clip is appended to the end of the selection and plays back in
forward motion at the selection’s original speed. (By default, the instant replay is set to play back
at 100 percent speed.)
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3 If you want to adjust the speed of the instant replay segment, drag the retiming handle to the
left to increase the speed or to the right to decrease it.
Original clip
(now a segment)

Instant replay segment set to
a manual slow-motion setting

Drag the retiming handle to
change the speed of the
instant replay segment.

4 To see the instant replay effect, play back the original selection and the instant replay segment.

Create jump cuts at specified frames
To compress time in a long clip without playing the clip at fast speed, you can create jump cuts
to periodically skip over a specific number of frames. For example, if you have a 10-second shot
of a person walking down a hallway, rather than playing the entire 10 seconds, you can create
jump cuts every two seconds that skip 30 frames each, so the action happens in twice the time.
Speed up a clip with jump cuts
1 In the Timeline, select the clip that you want to speed up, and add a marker at each frame where
you want a jump cut to occur.

2 Choose Jump Cut at Markers from the Retime pop-up menu in the toolbar (shown below), and
choose a number of frames from the submenu.
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You can skip 3, 5, 10, 20, or 30 frames.

Create a hold segment
In Final Cut Pro, you can hold on a particular frame to create a still image, temporarily stopping
the action onscreen. By default, Final Cut Pro adds a 2-second still frame, called a hold segment, at
the location of the skimmer or playhead, but you can change the duration of the hold segment
at any time.
Alternatively, you can create separate freeze-frame clips in Final Cut Pro. One key difference
between freeze frames and hold segments is that hold segments remain part of the original
clip and their duration can be adjusted within the clip. For more information, see Create freeze
frames on page 113.
Important:  Adding a hold segment to a clip increases its duration.
Create a still-image hold segment
1 In the Timeline, do one of the following:
••

Select the clip with the frame you want to hold, and move the skimmer or playhead to
that frame.

••

Select a range within a clip in the Timeline.

2 Choose Hold from the Retime pop-up menu in the toolbar (or press Shift-H).

If you selected a clip, a 2-second hold segment is added to the clip at the position of the
skimmer or the playhead.
If you selected a range, a hold segment is created for the duration of the range. The frame used
as the still frame is the first (leftmost) frame in the range.
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3 If you want to adjust the duration of the hold segment, drag the segment’s retiming handle to
the right to increase the duration, or to the left to decrease it.
Drag the retiming handle
to change the duration
of the hold segment.

4 To see the effect of the hold segment, play back the clip in the Timeline.

Reset retimed clips to play at normal speeds
You can reset a range selection or a clip to play back at normal (100 percent) speed at any time.
Resetting the speed removes any directional effects and Holds applied to the selection at the
same time.
Reset a range or a clip to play forward at 100 percent
1 In the Timeline, select a range, a whole clip, or a group of clips that you want to reset to their
original speed.
2 Choose Normal 100% from the Retime pop-up menu in the toolbar (or press Shift-N).

Conform frame sizes and frame rates

Final Cut Pro manages project settings automatically. This means you can work with multiple
media types with differing frame sizes (also referred to as resolution) and frame rates in the same
project. When you add the first video clip to your project, Final Cut Pro automatically sets the
format, frame size, and frame rate for the entire project based on the properties of that first clip
(or, more precisely, on the properties of the clip’s source media file).
You can modify the project’s settings at any time, and you can control, on a clip-by-clip basis,
how Final Cut Pro conforms an individual clip’s frame rate and frame size to match the project
settings. All of the project information in this section applies equally to compound clips, which
can have their own distinct project settings.
You can add interlaced clips to progressive (non-interlaced) projects and progressive clips to
interlaced projects. To add an interlaced clip to a progressive project, see the instructions below.
Final Cut Pro accepts progressive clips in interlaced projects automatically.
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Here are things to keep in mind when working with multiple formats and frame sizes:
••

Choose video and audio project properties based on how you intend to share your final movie
with your audience. For example, if you’re editing a project with mixed-format media and you
intend to share it as 1080p HD, you should set your project’s video properties to 1080p HD.

••

If you’re unsure of the final distribution format, the most important decision you can make
before creating your project is choosing your project’s frame rate. It’s easy to change the
format and the frame size of your project at any time, but changing the frame rate can cause
all the edit points in your project to shift in time.

••

If you have a clip that matches the video and audio properties of the format in which you
intend to share your project, add this clip to your project first. Final Cut Pro automatically
creates matching project settings. This saves you time by preventing you from having to
change your project settings later.
Tip:  If the first clip you add to a project is an audio clip or a still-image clip, Final Cut Pro
prompts you to choose the video properties for your project. Cancel the edit, add a video clip
whose source media file has the video properties you require for your project, and then add
the non-video clip to your project.

Choose a method of conforming frame size
You can choose how Final Cut Pro modifies the frame size of a clip to match the project’s frame
size settings. For example, you can have Final Cut Pro change the frame size of the clip to fit
within the longest dimension of the project’s frame dimensions, fill the entire frame of the
project (which usually results in cropping), or leave the clip’s frame size as is.
1 Add a clip to the Timeline with a frame size that doesn’t match the current project’s frame size
(resolution) settings.
2 Select the clip in the Timeline.
3 To open the Video inspector, click the Inspector button in the toolbar (shown below), and click
the Video button at the top of the pane that appears.

4 Choose a method of conforming frame size from the Type pop-up menu in the Spatial Conform
section of the Video inspector.

••

Fit: The default setting. Fits the clip within the project’s frame size setting without cropping the
clip’s video. Black bars appear on the sides of the frames that don’t match the project’s frame
size (resolution). In the case of a standard-definition (SD) clip in a high-definition (HD) project,
Final Cut Pro scales up the SD clip to fit the HD project’s frame size. In the case of an HD clip in
an SD project, Final Cut Pro scales down the HD clip to fit the SD project’s frame size.
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••

Fill: Makes the clip’s video fill the project’s frame size. In the case of an SD clip in an HD project,
Final Cut Pro scales up the SD clip to fit the HD project’s frame size. Cropping occurs along the
clip’s longer dimension to allow the shorter dimension to fill the screen. In the case of an HD
clip in an SD project, Final Cut Pro scales down the HD clip to fit the SD project’s frame size.
Cropping occurs along the clip’s shorter dimension to allow the longer dimension to fill the
screen.

••

None: Leaves the clip’s frame size unchanged. If the clip’s frame size is larger than the project’s
frame size, the clip appears cropped. If the clip’s frame size is smaller than the project’s frame
size, black bars surround the clip.

Choose a method of conforming frame rate
When a clip’s frame rate differs from the project’s frame rate, Final Cut Pro employs a framesampling method to change the clip’s frame rate to match that of the project. You can choose
which frame-sampling method Final Cut Pro uses to modify the clip’s frame rate. The method you
choose depends on how important it is to you to eliminate visual stuttering and visual artifacts.
1 Add a clip to the Timeline with a frame rate that doesn’t match the current project’s frame
rate settings.
2 Select the clip in the Timeline.
3 To open the Video inspector, click the Inspector button in the toolbar (shown below), and click
the Video button at the top of the pane that appears.

4 Choose a method of conforming frame rate from the Frame Sampling pop-up menu in the Rate
Conform section of the Video inspector.
Note:  If the selected clip has the same frame rate as the project frame rate settings, the Rate
Conform section does not appear in the Video inspector.

••

Floor: The default setting. Final Cut Pro truncates down to the nearest integer during its
calculation to match the clip’s frame rate to the project’s frame rate.

••

Nearest Neighbor: Final Cut Pro rounds to the nearest integer during its calculation to match
the clip’s frame rate to the project’s frame rate. The Nearest Neighbor option reduces artifacts
at the expense of visual stuttering. Rendering is required.

••

Frame Blending: Creates in-between frames by blending individual pixels of neighboring
frames. Slow-motion clips created with Frame Blending appear to play back more smoothly
than those created with the Floor or Nearest Neighbor setting. This setting provides better
reduction of visual stuttering, but you may see some visual artifacts. Rendering is required.

••

Optical Flow: A type of frame blending that uses an optical flow algorithm to create new
in-between frames. Final Cut Pro analyzes the clip to determine the directional movement
of pixels, and then draws portions of the new frames based on the optical flow analysis.
Choosing the Optical Flow option results in better reduction of visual stuttering, and
Final Cut Pro spends a significant amount of time to fix visual artifacts.
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Add an interlaced clip to a non-interlaced (progressive) project
Some video formats use an interlaced scanning method that divides a video frame into two
fields, each consisting of alternating odd and even lines that are scanned at different times.
If you want to add an interlaced clip to a progressive project, you can have Final Cut Pro
deinterlace the clip so that it plays at full resolution, free of the alternating jagged lines
associated with interlaced clips in progressive projects.
1 Do one of the following:
••

In the Browser, select the interlaced clips you want to add to a progressive project.

••

In the Timeline, select interlaced clips you’ve added to a progressive project.

2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 In the Info inspector, choose Settings View from the Metadata View pop-up menu.
4 Select the Deinterlace checkbox.
Note:  Selecting the Deinterlace setting causes the frame rate of the selected clips to double. For
example, if the original interlaced clips have a frame rate of 29.97 fps, the deinterlaced clips will
have a frame rate of 59.94 fps. Keep this in mind when you choose the video and audio settings
for your project.
Tip:  To confirm the absence of interlacing artifacts, you can press the Left Arrow and Right Arrow
keys to step through the clips in the Timeline one frame at a time.
5 To display full-resolution frames during playback, choose Better Quality from the Viewer Options
pop-up menu in the upper-right corner of the Viewer.
The clips now play back and function as progressive clips. Depending on your specific computer
configuration, background rendering may be necessary.
Adjust anamorphic footage
Some video camcorders and recording devices shoot at a widescreen 16:9 aspect ratio but record
the data using a 4:3 aspect ratio. Sometimes the metadata tag specifying 16:9 playback in the
video file is missing or set incorrectly. In Final Cut Pro, you can set this tag so that the video plays
correctly with a widescreen 16:9 aspect ratio.
Note:  This option applies only to (and appears only with) standard-definition (SD) formats.
1 In the Browser or the Timeline, select the SD clips whose anamorphic setting you want to adjust.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 Choose Settings View from the Metadata View pop-up menu at the bottom of the Info inspector.
4 In the Anamorphic Override pop-up menu, choose Widescreen.
The clips now play back and function with the widescreen 16:9 aspect ratio.
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Use roles to manage clips
Roles overview
Roles are metadata text labels that you assign to clips in the Browser or the Timeline, and
they provide a flexible and powerful way to manage your editing workflow. You can use roles
in Final Cut Pro to organize clips in your events and projects, control the appearance of the
Timeline, and export separate video or audio files (also known as media stems) for distribution,
audio mixing, or post-production.

Selected role

Clips assigned a selected
role appear highlighted.

When you import clips (video, audio, or still images), Final Cut Pro analyzes existing clip metadata
to assign one of five default roles to the video and audio components of each clip: Video, Titles,
Dialogue, Music, and Effects. For example, if a source media file has an iTunes “genre” metadata
tag, Final Cut Pro assigns the Music role to the resulting clip. Final Cut Pro assigns the Video and
Dialogue roles to clips that contain both video and audio.
You can use roles for the following workflows:
••

Reassign roles: You can view and reassign clip roles in the Timeline Index, the Browser, the Info
inspector, or the Modify menu. See View and reassign roles on page 318. You can also create
custom roles and subroles to further organize your clips.

••

View clips by role: In the Timeline Index, you can organize clips by role, turn roles on or off, and
highlight or minimize clips for viewing in the Timeline. For example, you could easily identify
all your dialogue clips and play them back in isolation from other audio clips. See View clips by
role in the Timeline on page 324.

••

Export media stems: You can export roles as media stems in a combined, multitrack QuickTime
file, or as separate audio or video files. During the export process you can assign mono, stereo,
or surround output for your audio channels. See Destinations preferences on page 447.

View and reassign roles
You can view and change the roles that are assigned to clips in the Browser, the Timeline Index,
the Info inspector, or the Modify menu.
Keep in mind the following when using roles:
••

Every clip must have at least one assigned role (clips with audio and video always have one
audio and one video role). Still images are assigned the Video role by default, but you can
create a custom (still image) role and assign it to your still images.

••

Video roles can’t be assigned to audio-only clips, and audio roles can’t be assigned to
video-only clips.
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••

Roles can be assigned to audio or video components of a clip, but can’t be assigned to a clip
range or a portion of a clip.

••

You can view and reassign the role of an audio component in the Info inspector (or by using
the Modify menu when the clip that contains the audio component is in the Timeline).

••

You can assign different roles to each instance of a clip. For example, if you add a clip from the
Browser to the Timeline, copy clips between events, or copy clips within the Timeline, each of
these clip instances (copies) is independent of the others.

View and reassign roles in the Browser
1 In the Browser in list view, select one or more clips.
Note:  If the Roles column isn’t visible in the Browser, Control-click a column heading and choose
Roles from the shortcut menu.
2 In the Roles column, click the assigned role for a clip to see a shortcut menu listing the
available roles.

3 To change the role assignments for the selected clips, choose different roles from the
shortcut menu.
View and reassign roles in the Info inspector
1 Select one or more clips in the Browser or the Timeline.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 In the Info inspector, click the Roles pop-up menu to see the available roles.
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4 To change the role assignments for the selected clips, choose different roles from the Roles
pop-up menu.
View and reassign roles in the Timeline Index
1 To open the Timeline Index, click the Timeline Index button in the lower-left corner of the
Final Cut Pro main window (or press Shift-Command-2).
2 To open the Clips pane, click the Clips button at the top of the Timeline Index.
3 If the Roles column is not visible in the Clips pane, Control-click a column heading and choose
Roles from the shortcut menu.

4 Select one or more clips in the Clips pane.
5 To change the role assignments for the selected clips, click the assigned role and choose different
roles from the shortcut menu.

View and reassign roles with the Modify menu
1 Select one or more clips in the Browser or the Timeline.
2 Choose Modify > Assign Roles, and choose a role from the submenu.
A checkmark appears next to the role you chose.
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View and reassign the role of an audio component
1 Select a clip in the Timeline, and choose Clip > Expand Audio Components (or press
Control-Option-S).

Audio components

2 Select an audio component.
3 To change the role assignment for the selected component, do one of the following:
••

Choose Modify > Assign Roles, and choose a role from the submenu.
A checkmark appears next to the role you chose.

••

Open the Info inpector, and choose a different role from the Roles pop-up menu.
A checkmark appears next to the role you chose.

For more information about audio components, see About audio channels and audio
components on page 158.
View and reassign roles in compound clips
Compound clips reflect the roles of the original clips that make up the compound clip. You can
view and reassign the roles of clips inside a compound clip, but you cannot assign roles to the
compound clip itself.
1 Select a compound clip in the Browser or the Timeline.
2 To view the assigned roles or to assign a role to every clip inside the compound clip, use the
following methods:
••

Roles column in the Browser in list view: Follow the instructions in “View and reassign roles in the
Browser,” above.

••

Roles pop-up menu in the Info inspector: Follow the instructions in “View and reassign roles in
the Info inspector,” above.

••

Roles column in the Clips pane of the Timeline Index: Follow the instructions in “View and
reassign roles in the Timeline Index,” above.

••

Assign Roles command: Follow the instructions in “View and reassign roles with the Modify
menu,” above.

When you assign a role to a compound clip (the container), the role is assigned to every clip
inside the compound clip. If you want to assign different roles to specific clips within the
compound clip, you can open the compound clip for editing and then assign roles to individual
clips inside the compound clip.
For more information about compound clips, see Compound clips overview on page 269.
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Create custom roles and subroles
You can create custom roles and subroles in addition to the five default roles (Video, Titles,
Dialogue, Music, and Effects).
Important:  Create custom roles and subroles with care. Custom roles (and the names of custom
roles) cannot be edited or removed from the roles list. However, you can change the role
assignments of clips at any time.
Create custom roles
1 To open the Role Editor, do one of the following:
••

Choose Modify > Edit Roles.

••

In the Browser in list view or the Clips pane of the Timeline Index, click a role in the Roles
column and choose Edit Roles from the shortcut menu.

••

With a clip selected in the Browser or the Timeline, open the Info inspector and choose Edit
Roles from the Roles pop-up menu.

2 Choose the role type from the Add Role pop-up menu in the lower-left corner of the Role
Editor window.

The new role appears at the bottom of the Role column.
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3 Type a name for the new role.
Once you have created a new role, it appears in the roles list so that you can assign it to any clip.

Create subroles
Subroles allow you to organize roles within a role; for example, you could create a Foley Effect
subrole within the Effects role, or a Spanish Subtitles subrole within the Titles role.
1 To open the Role Editor, do one of the following:
••

Choose Modify > Edit Roles.

••

In the Browser in list view or the Clips pane of the Timeline Index, click a role in the Roles
column and choose Edit Roles from the shortcut menu.

••

With a clip selected in the Browser or the Timeline, open the Info inspector and choose Edit
Roles from the Roles pop-up menu.

2 Select a role in the Role column, and click the Add Subrole button (with a plus sign) below the
Subrole column.
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3 Type a name for the subrole.
The new subrole remains in the Subrole list and appears below its parent role in roles lists
elsewhere in Final Cut Pro. When you assign subroles to clips in the Timeline, the subroles also
appear in the Timeline Index.

Subroles

View clips by role in the Timeline
You can use the Roles pane of the Timeline Index to view and play back clips by role in
the Timeline.
All video and audio clips are organized by the default roles of Video, Titles, Dialogue, Music, or
Effects, or by a custom role or subrole you’ve created. You can turn off roles to suspend playback
for all clips with those roles assigned. For example, you could turn off all roles except Dialogue to
play back only dialogue clips, and then turn on the Music role to listen to the movie soundtrack
along with the dialogue.
Roles give you a powerful way to organize and preview clips before exporting them as files for
broadcast or audio post-production.
Note:  Turning roles on or off in the Timeline Index does not affect export settings or clip settings
in the Browser, the Timeline, or the inspectors.
Turn roles on or off
1 In the Timeline Index, click the Roles button.
2 In the Roles pane, select the checkboxes next to the roles or subroles you want to turn on.
Deselect the checkboxes next to the roles or subroles you want to turn off.
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Active roles appear in color in the Timeline, and inactive roles appear gray. If you turn off all video
or all audio roles, the respective portion of audio-video clips also appears gray.
Active roles

Clips assigned an active
role appear in color.

Clips assigned an inactive
role appear in gray.

3 To preview clips by role, play back your project.
Only clips with active roles assigned play back.
Highlight roles in the Timeline
1 In the Timeline Index, click the Roles button.
2 In the Roles pane, click the name of the role you want to highlight.
The clips with this role assigned are highlighted in the Timeline. This includes both active (color)
clips and inactive (gray) clips.

Selected role

Clips assigned a selected
role appear highlighted.

Tip:  To highlight more than one role at a time, Shift-click to select contiguous items and
Command-click to select noncontiguous items.
Minimize clips by role
To make more space to view and work with clips in the Timeline, you can minimize clips with a
particular role assigned. Minimized clips appear smaller in the Timeline.
1 In the Timeline Index, click the Roles button.
2 In the Roles pane, click the Minimize button next to the role whose clips you want to minimize.
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Roles that have
been minimized

Minimize button

Minimized clip

You can also customize the display of clips in the Timeline by changing the clip appearance
and height, and you can choose whether to view clips by name or role. See Adjust Timeline
settings on page 140.

Use roles to export media stems
When you export your work, you can use roles to define the details of your output media files.
This process is often used when delivering files to match broadcast specifications or when
handing off media stems for mixing or post-production.
You can export roles in a combined, multitrack QuickTime file, or as separate audio or video
files. During the export process you can assign mono, stereo, or surround output for your
audio channels.
For more information, see Share roles as files on page 412.

Use XML to transfer projects and events

Final Cut Pro can import and export XML (Extensible Markup Language) files. You can use XML
documents (plain ASCII text files with tagged elements) to transfer the details of your libraries,
events, projects, and clips between Final Cut Pro and third-party applications, devices, and media
asset management tools that do not recognize Final Cut Pro documents and files.
The XML import and export options are described in detail in the Final Cut Pro XML developer
documentation. For more information, visit the Apple Applications page at the Apple Developer
website at http://developer.apple.com/appleapplications.
Import XML into Final Cut Pro
You can generate XML files with other applications and then import them into Final Cut Pro.
When you import an XML file, Final Cut Pro generates clips, events, projects, and a library,
depending on the contents of the XML file.
1 In Final Cut Pro, choose File > Import > XML.
2 Navigate to the XML file you want to import, and click Import.
Final Cut Pro processes the XML and generates the corresponding clips, events, projects, and
library, depending on the contents of the XML file.
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Tip:  You can also import XML files by double-clicking them in the Finder or dragging them to
the Final Cut Pro application icon.
Export XML from Final Cut Pro
You can export events and projects as XML files.
1 In Final Cut Pro, select a library, or select one or more events, projects, or clips that you want to
export as XML files.
To export the project currently open in the Timeline, click in the Timeline to make it active.
2 Choose File > Export XML.
3 In the window that appears, navigate to a folder on your hard disk where you want to store the
XML files, and click Save.

Edit with multicam clips
Multicam editing overview
You can use Final Cut Pro to edit footage from multicamera shoots or other synchronized
footage in real time. For example, if you shot a live concert or a wedding with four different
cameras, you can synchronize the footage from each camera angle into a single multicam clip
and cut between the angles in real time.
The angles in a multicam clip are synchronized by a common sync point, a frame that you can
recognize (visibly or audibly) in each of the angles you are synchronizing. When you add a
multicam clip to the Timeline, the angle that appears in the Viewer when you play your project
is called the active angle. While the active angle plays in the Viewer, you can also view all angles
playing simultaneously in the Angle Viewer and easily cut and switch between them.
Sync point
Multicam clip
Angle 1
Angle 2

Active angle

Angle 3
Angle 4

Working with multicam clips in Final Cut Pro is a flexible and fluid process. At any time, you can
add angles to or remove angles from a multicam clip, and easily adjust the synchronization
between angles.
You can also group unrelated footage together for real-time montage editing (such as for music
videos). For example, if you’re editing a music video, you could add several angles of abstract
visuals and cut to those angles at specific places in the music. You can even use photos (from
a still camera) in a multicam clip. If the date and time (Content Created) information matches
the contents of the other angles, the photos are automatically adjusted in duration to “fill in”
the angle.
Multicam clips have the following characteristics:
••

You create multicam clips in the Browser only, from existing event clips.

••

You edit and adjust multicam clips in the Angle Editor, which looks similar to the Timeline.
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••

When you add a multicam clip to the Timeline, you create a direct and active relationship
between the “parent” multicam clip in the Browser and the “child” multicam clip in
the Timeline.
Browser clips

Parent multicam clip

Project 1

Child clip

••

Project 2

Child clips

Project 3

Child clip

When you open any multicam clip in the Angle Editor (whether from the Browser or the
Timeline) you are in fact opening the parent multicam clip from the Browser. Any changes
you make to a multicam clip in the Angle Editor are inherited by all of its child clips, in all
projects. These changes include sync or trimming adjustments, clip speed retiming, video
or audio effects such as color correction, and added or deleted angles. For example, if you
delete an angle from a parent multicam clip, the angle is deleted from all child clips. For
more information about the Angle Editor, see Sync and adjust angles and clips in the Angle
Editor on page 343.
Tip:  You can create a “snapshot” backup of the entire project to protect it from accidental
changes. Project snapshots are self-contained backup versions that include multicam or
compound parent clips. Duplicating a project as a snapshot makes copies of the multicam
or compound parent clips and embeds them in the project so that any changes to other
instances of the clips do not affect the snapshot. For more information, see Duplicate projects
and clips on page 64.

Multicam editing workflow
The process for creating a multicam project is outlined below. The procedures are presented in
rough chronological order, but you can rearrange the order to suit your workflow.
Shoot an event with multiple cameras and record appropriate sync information
A multicamera shoot uses multiple cameras to record the same subject or event from different
angles and distances.
For multicam projects, it’s a good idea to set the date, the time, and the time zone on your
camcorder or recording device before you shoot footage for your multicam project. This provides
useful information to Final Cut Pro during the automatic multicam clip creation process.
In professional multicamera shoots, each camcorder or VTR receives the same timecode from
a master timecode generator, or you can jam sync the timecode generator of each camera at
the beginning of the shoot. If you’re using consumer camcorders, which cannot accept external
timecode, you need to record a visible or audible cue, such as a clapboard closing or a camera
flash, on all cameras. You can use this cue to synchronize the angles in your multicam clips.
Because you can use the sophisticated automatic audio sync feature in Final Cut Pro to help ensure
multicam synchronization accuracy, it makes sense to record audio on every camcorder and
recording device in your multicam production. (Clear audio recordings provide the best results.)
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Import media for a multicam edit
Although importing media for multicam projects is the same as importing for any other project,
there are steps you can take during importing to help streamline the multicam workflow.
Assign camera names and multicam angles
You can use the Camera Name and Camera Angle metadata tags to automate and organize your
multicam workflow. It’s recommended (but not required) to apply these tags to your event clips
before you create an actual multicam clip.
Create multicam clips
You create multicam clips from selected event clips (similar to the way you create auditions and
compound clips in the Browser). Whether you do it manually or have Final Cut Pro do it for you
automatically, creating a multicam clip involves three fundamental steps:
••

Create angles (containing one or more clips each).

••

Arrange the order of clips within each angle.

••

Synchronize the angles using a common sync point.

If you know what kind of metadata your source media has, you can create multicam clips using
manual methods even faster than with the automatic methods. For more information, see Assign
camera names and multicam angles on page 330 and Create multicam clips in the Browser on
page 331.
Cut and switch between angles in the Angle Viewer
After you create a multicam clip, you can watch all angles simultaneously in the Angle Viewer
while switching or cutting to different angles in real time. You can cut and switch video and
audio at the same time or independently. For example, you can use the audio from angle 1 while
switching the video between angles 1 to 4.
Sync and adjust angles in the Angle Editor
At any time, you can open multicam clips in the Angle Editor to adjust the synchronization and
the angle order, or to add or delete angles. You can also use the Angle Editor to make edits to
the individual clips inside a multicam clip (such as trimming, making color corrections, adding
transitions, and so on).
Edit multicam clips in the Timeline
You can switch multicam angles directly in the Timeline or the Inspector, without opening the
Angle Viewer. Although multicam clips have some unique properties, you can edit them in the
Timeline in the same way you edit any other clips.

Import media for a multicam edit
When you import media for a multicam project, you can give the camcorder or file-based
recording device a name. Final Cut Pro uses this Camera Name tag to sort the source clips within
a multicam clip during the automatic multicam clip creation process.
If you anticipate having multicam clips with numerous angles, select “Use proxy media” in
Playback preferences to maintain top performance during your multicam edit. You can generate
the necessary proxy versions of your clips during the import process.
If you have only a few angles in your multicam edit, you can make optimized versions of
your media during import, using the Apple ProRes 422 codec. Or, if you prefer, you can select
“Create optimized media for multicam clips” in Playback preferences to generate optimized
media automatically every time you create a multicam clip. For more information, see Playback
preferences on page 443.
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Name your camera
The following instructions cover how to add the Camera Name property when you import media
from a connected file-based device. You can also add the Camera Name property at a later time.
1 Connect your camera or recording device to your computer.
2 In Final Cut Pro, choose File > Import > Media (or press Command-I).
3 In the Media Import window, select your camcorder or recording device from the list of devices
on the left, if it’s not already selected.
4 Click it again, and enter a name.
Final Cut Pro uses the name you enter as the Camera Name metadata property for all clips that
you import from this device.
Note:  Most modern camcorders and recording devices (including all iOS devices) record a
Camera ID tag. Final Cut Pro imports the Camera ID metadata automatically when you import
from a file-based device and can use this information to automatically build multicam angles.

Assign camera names and multicam angles
The Camera Angle and Camera Name properties are flexible metadata tags that you can use to
organize your multicam workflow.
Although you can assign metadata to clips at any time, it makes the most sense to assign the
Camera Angle and Camera Name tags before you use the clips to create multicam clips. The
Camera Angle tag can help you determine and track which clips appear in which angles. The
Camera Name tag can be applied during import and is useful in a variety of scenarios, such as in
color correction.
Final Cut Pro allows you to create multicam clips automatically or manually. If you use the
automatic method for creating angles in the multicam clip, Final Cut Pro looks for metadata in
the selected clips in the following order:
••

Camera Angle metadata

••

Camera Name metadata

••

Camera ID metadata
Note:  The Camera ID tag is generated by most modern camcorders and recording devices
(including all iOS devices). Final Cut Pro imports the Camera ID metadata automatically when
you import from a file-based device.

Final Cut Pro uses the Camera Angle, Camera Name, and Camera ID metadata to place clips in
the correct angle. If it doesn’t find any of this information, Final Cut Pro creates a separate angle
for each selected clip.
Assign camera names and angles to selected clips
Do one of the following:
mm Select one or more clips in the Browser or the Timeline, open the Info inspector, and enter text in
the Camera Angle field or the Camera Name field.
mm In the Browser in list view, enter text in the Camera Angle column or the Camera Name column
for any clip.
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Note:  If you use the automatic method for creating angles, Final Cut Pro uses any Camera Angle
tags in the selected clips to name the angles in the resulting multicam clip. If no Camera Angle
tags are present, Final Cut Pro uses Camera Name, Name (clip name), or Camera ID metadata to
name angles. You can rename angles in the Angle Editor. For more information, see Sync and
adjust angles and clips in the Angle Editor on page 343.

Create multicam clips in the Browser
Creating multicam clips is similar to creating auditions and compound clips in the Browser.
Multicam clips can be made up of diverse media sources (different formats, frame rates, and so
on). You can have multiple clips in any given angle of a multicam clip.
You can have Final Cut Pro create multicam clips for you automatically, or you can create the
clips manually.
If you know what kind of metadata your multicam media has, you can create multicam clips
using manual methods faster than with the automatic methods. The automatic methods use
sophisticated automatic audio sync technology to ensure synchronization accuracy (but at the
expense of processing time). It’s best to turn off the “Use audio for synchronization” feature when
it’s not needed. For example, if you’ve recorded accurate timecode in every clip, Final Cut Pro can
create your multicam clip automatically without the audio sync feature.
Create a multicam clip automatically
1 In the Browser, select the clips you want to include in the multicam clip.
2 Do one of the following:
••

Choose File > New Multicam Clip.

••

Control-click the selection and choose New Multicam Clip from the shortcut menu.

3 In the window that appears, type a name for the multicam clip in the Name field.
4 Use the In Event pop-up menu to choose the event in which you want to create the new
multicam clip.
5 If the multicam automatic settings are not shown, click Use Automatic Settings.
The multicam automatic settings appear.

Note:  The automatic settings are shown by default, but if the last multicam clip you created used
custom settings, those settings are shown.
6 To sync angles automatically using audio waveform data, select “Use audio for synchronization.”
This option makes precision sync adjustments using audio waveforms in each angle. This is
the same audio sync technology that you can use to automatically sync clips together into a
compound clip.
Sync point
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Note:  Some audio recordings are not suited for use with this feature. Selecting this option may
result in long processing times during which Final Cut Pro is not available for editing.
7 Click OK.
Final Cut Pro creates a new multicam clip in the event and places duplicates of the selected clips
in the new multicam clip.
Multicam clip icon

Create a multicam clip with custom settings
1 In the Browser, select the clips you want to include in the multicam clip.
2 Do one of the following:
••

Choose File > New Multicam Clip.

••

Control-click the selection and choose New Multicam Clip from the shortcut menu.

3 In the window that appears, type a name for the multicam clip in the Name field.
4 If the multicam custom settings are not shown, click Use Custom Settings.
The custom settings appear.

Note:  The automatic settings are shown by default, but if the last multicam clip you created used
custom settings, those settings are shown.
5 In the Angle Assembly pop-up menu, choose how the angles in the multicam clip are created:
••

Automatic: Final Cut Pro creates the angles automatically.

••

Camera Angle: Final Cut Pro creates angles in the multicam clip based on the Camera Angle
property of the selected clips.

••

Camera Name: Final Cut Pro creates angles in the multicam clip based on the Camera Name
property of the selected clips.

••

Clips: Final Cut Pro creates a separate angle for each selected clip, using the Name property in
each clip to name the angle.
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6 In the Angle Clip Ordering pop-up menu, choose how angles are ordered within the multicam clip:
••

Automatic: Final Cut Pro orders the clips within each angle automatically. If there is more than
one clip per angle, Final Cut Pro inserts gap clips between the clips, as needed, to achieve the
correct timing and spacing.

••

Timecode: Final Cut Pro orders the clips within each angle using timecode recorded in the clips.
If you recorded timecode in your clips, choose this option. It’s the fastest and most frameaccurate method of ordering clips.

••

Content Created: Final Cut Pro orders the clips within each angle using the date and time
information recorded by your camcorder or video recording device.
The Content Created method can position clips within 1-second accuracy (because in most
camcorders the smallest unit in date and time information is 1 second). If you choose this
clip-ordering method, consider making your multicam clip frame-accurate by selecting “Use
audio for synchronization” (described in step 8) or manually synchronizing your angles in the
Angle Editor.
Note:  At any time, you can change the Content Created date and time of your source clips in
the Browser. Just select one or more clips and choose Modify > Adjust Content Created Date
and Time.

7 In the Angle Synchronization pop-up menu, choose how angles are synchronized in the
multicam clip:
••

Automatic: Final Cut Pro synchronizes the angles automatically (using one or more of the
following methods).

••

Timecode: Final Cut Pro synchronizes the angles based on the timecode recorded in the clips.
For more information about recording timecode, see Multicam editing workflow on page 328.
Sync point
01:00:00:00
01:00:00:00
01:00:00:00
01:00:00:00

••

Content Created: Final Cut Pro synchronizes the angles based on the date and time information
recorded by your camcorder or video recording device.
Note:  At any time, you can change the Content Created date and time of your source clips in
the Browser. Just select one or more clips and choose Modify > Adjust Content Created Date
and Time.
Sync point
12:59 PM
12:59 PM
12:59 PM
12:59 PM
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••

Start of First Clip: Final Cut Pro uses the first frame in each angle as the sync point.
Sync point

Tip:  The Start of First Clip method is useful if you want to use specific range selections of your
source clips only. In the Browser, add keywords or the Favorite rating to the range selections
you want to use and then filter or search for the clips. When you create your multicam clip,
Final Cut Pro uses only the media showing in the filtered view.
••

First Marker on the Angle: Final Cut Pro uses the first marker in each angle as the sync point.
Sync point

Tip:  With this method, you can use the first marker to define a region that can be fine-tuned
with the “Use audio for synchronization” option (described below). In other words, you don’t
need to place the marker exactly—just close enough so that the automatic audio sync feature
can synchronize the angles the rest of the way.
8 To sync angles automatically using audio waveform data, select “Use audio for synchronization.”
This option makes precision sync adjustments using audio waveforms in each angle. This is
the same audio sync technology that you can use to automatically sync clips together into a
compound clip.
Sync point

Note:  Some audio recordings are not suited for use with this feature. Selecting this option may
result in long processing times during which Final Cut Pro is not available for editing.
9 If you want the multicam clip’s timecode to start at a value other than the earliest timecode
value in the selected clips (the default), type a timecode value in the Starting Timecode field.
10 If you want to change the video properties settings, select Custom in the Video Properties
section and change the settings as appropriate.
Note:  By default, Final Cut Pro analyzes the selected clips and configures these settings
according to the most common clip properties among those clips.
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11 If you want to change the audio or render settings, select Custom in the Audio and Render
Properties section and change the settings as appropriate.
12 Click OK.
Final Cut Pro creates a new multicam clip in the event and places duplicates of the selected clips
in the new multicam clip.
Multicam clip icon

Cut and switch angles in the Angle Viewer
After you create a multicam clip, you can watch all angles simultaneously in the Angle Viewer
while switching or cutting to different angles in real time. This allows you to cut an entire
movie as if it were live, and then fine-tune your edits in the Timeline just as you would for any
other project.
The Angle Viewer is both a display and an interactive interface for making quick cut and switch
decisions as you play back your multicam clips and projects. Angles appear in banks of 2, 4, 9, or
16 angles.
Angle Viewer

Play back a multicam clip in the Angle Viewer
1 To open the Angle Viewer, do one of the following:
••

Choose Window > Viewer Display > Show Angles (or press Shift-Command-7).

••

Choose Show Angles from the Viewer Options pop-up menu in the top-right corner of
the Viewer.

If you’re viewing a multicam clip in the Browser, you have the option to show the Event Viewer
next to the Viewer. To show multicam angles in the Event Viewer, do one of the following:
••

Choose Window > Event Viewer Display > Show Angles.

••

Choose Show Angles from the Viewer Options pop-up menu in the top-right corner of the
Event Viewer.
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2 Use the skimmer or the playhead to play back a multicam clip in the Browser or the Timeline.
The Angle Viewer appears in the upper part of the Final Cut Pro window.
Play back a multicam
clip in the Browser
or the Timeline.

Active angle

The multicam clip’s
angles appear in the
Angle Viewer.

Cut and switch angles in the Angle Viewer
You can cut and switch angles “on the fly” (while playing back your project), or you can skim to
specific points in the Timeline and then cut and switch. You can also use a combination of those
two methods.
1 To open the Angle Viewer, choose Window > Viewer Display > Show Angles (or press
Shift-Command-7).
2 Add the multicam clip you want to cut and switch to the Timeline.
Note:  The cut and switch feature works on Timeline clips only.
3 Do one of the following:
••

Position the playhead and press the Space Bar to play back the multicam clip.

••

Skim the Timeline to the frame where you want to cut and switch to a different angle.

4 In the Angle Viewer, move the pointer over the angle that you want to switch to.
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As you move the pointer over the angles in the Angle Viewer, the pointer changes to the Blade
tool, indicating that a cut (and switch) will occur when you click.
The active angle
is highlighted.

The pointer changes
to the Blade tool.

5 Do one of the following:
••

To cut and switch: Click the angle you want to switch to. (Or press any number key to cut and
switch to the corresponding angle of the current bank. For example, press 5 to cut and switch
to angle 5 of the current bank.)
In the Timeline, the current multicam clip is cut at the playhead position. The section of the
clip to the right of the playhead is replaced with a new instance of the clip, with the angle
you clicked as the active angle. A special through edit point appears at the Timeline playhead
position. For more information, see Edit multicam clips in the Timeline and the Inspector on
page 349.

••

To switch: Option-click the angle you want to switch to. (Or hold down the Option key and
press any number key to switch to the corresponding angle of the current bank. For example,
press Option-5 to switch to angle 5 of the current bank.)
Note:  The pointer changes to a pointing hand icon when you hold down the Option key,
indicating a switch-only edit.
In the Timeline, the multicam clip under the playhead changes to show the angle you
switched to as the active angle.

In either case, the Viewer switches to the angle you selected. The active angle is highlighted in
yellow, blue, or green, depending on the switch mode you’re using. For more information, see
“Switch video or audio separately,” below.
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Switch video or audio separately
By default, Final Cut Pro switches the video and audio of a multicam clip at the same time. But
you can set Final Cut Pro to switch the video and audio separately.
1 To open the Angle Viewer, choose Window > Viewer Display > Show Angles (or press
Shift-Command-7).
2 To change the switch mode, do one of the following:
••

To enable video and audio switching: Click the left switch mode button in the upper-left corner
of the Angle Viewer. This is the default setting.
Click to enable video
and audio switching.

Yellow highlighting indicates
that both the active video
and the active audio are
contained in one clip.

The bank switcher
shows the active angle.

••

To enable video-only switching: Click the middle switch mode button. Only the video switches.
The audio from the original angle remains active.
Click to enable
video-only switching.

••

To enable audio-only switching: Click the right switch mode button. Only the audio switches.
The video from the original angle remains active.
Click to enable
audio-only switching.

3 Do one of the following:
••

To cut and switch: Click an angle in the Angle Viewer.

••

To switch: Option-click an angle in the Angle Viewer.
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If you selected the video-only or audio-only switch mode, blue highlighting indicates the active
video angle and green highlighting indicates the active audio angle.
Switch Video
Only button

Switch Audio
Only button

The active video angle
is highlighted in blue.

The active audio angle
is highlighted in green.

The bank switcher
shows the active angles.

Tip:  With audio-only switching enabled, you can add audio components from inactive angles to
the active angle or remove audio components from the active angle. Simply Option-Commandclick an inactive angle to add its audio to the active angle. Or Option-Command-click an active
angle to remove its audio. For more information, see “Example: Add or remove audio components
in a multicam clip” in Multichannel audio editing examples on page 183.
View and navigate banks of angles
Depending on the Angle Viewer display setting you choose, you can show 2, 4, 9, or 16 angles at
once. These sets of angles are known as banks. The bank switcher in Final Cut Pro is an efficient
tool for displaying and navigating banks of angles in a multicam clip.
1 To open the Angle Viewer, choose Window > Viewer Display > Show Angles (or press
Shift-Command-7).
2 Position the skimmer or the playhead over a multicam clip in the Browser or the Timeline.
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The bank switcher appears as a grid of squares at the bottom of the Angle Viewer. Yellow, blue, or
green highlighting indicates the currently active angle.

The bank switcher shows
the number of angles
and which is active.

3 In the Settings pop-up menu (in the upper-right corner of the Angle Viewer), choose the number
of angles you want to display in each bank.
Settings pop-up menu
in the upper-right corner
of the Angle Viewer

If the number of angles in your multicam clip exceeds the current Angle Viewer display setting,
Final Cut Pro creates additional banks and displays them as separate grids of squares.
Here are a few examples of different angle bank combinations:
••

Three banks of 4 angles each, with the last angle in the third bank as the active angle, and the
third bank as the currently displayed bank:

••

One bank of 16 angles, with the last angle as the active angle:
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••

One bank of 9 angles and another bank of 7 angles, with the first bank as the currently
displayed bank:

4 To navigate banks of angles, do any of the following:
••

To display a bank’s angles in the Angle Viewer: Click the bank switcher icon for the bank.

••

To display the previous bank: Press Option-Shift-Semicolon (;).

••

To display the next bank: Press Option-Shift-Apostrophe (‘).

Show overlays in the Angle Viewer
For each angle that appears in the Angle Viewer, you can display video overlays showing
timecode and either the clip name or the angle name.

Angle name

Timecode

1 To open the Angle Viewer, choose Window > Viewer Display > Show Angles (or press
Shift-Command-7).
2 To choose a display option, do one of the following:
••

To display timecode for the clips in each angle: Choose Timecode from the Settings pop-up
menu in the upper-right corner of the Angle Viewer. (Choose Timecode again to turn off the
timecode display.)
Settings pop-up menu
in the upper-right corner
of the Angle Viewer

••

To display the names of the clips in each angle: In the Settings pop-up menu, choose Display
Name > Clip.

••

To display the name for each angle: In the Settings pop-up menu, choose Display Name > Angle.

••

To turn off display names: In the Settings pop-up menu, choose Display Name > None.
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Adjust the Angle Viewer display
You can adjust the Angle Viewer display to suit your needs.
mm To adjust the number of angles in the Angle Viewer: In the Settings pop-up menu in the upper-right
corner of the Angle Viewer, choose either 2 Angles, 4 Angles, 9 Angles, or 16 Angles.
Settings pop-up menu

Angle Viewer in the
9 Angles display setting

mm To adjust the size of the Angle Viewer and the main Viewer: Drag the boundary between them.

Drag the boundary to the right.

Drag the boundary to the left.
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mm To make the Angle Viewer a vertical column: Drag the boundary to the left, and drag the Final Cut
Pro toolbar downward to expand the Viewer quadrant vertically. (This vertical column view is
available only in the 2 Angles and 4 Angles views.)

Drag the boundary to the left.

Drag the toolbar down.

Sync and adjust angles and clips in the Angle Editor
At any time, you can open multicam clips in the Angle Editor to adjust the synchronization and
the angle order, set the monitoring angle, or add or delete angles.
Note:  When you open any multicam clip in the Angle Editor (whether from the Browser or the
Timeline) you are actually opening the parent multicam clip. Any changes you make in the
Angle Editor are propagated to all child clips of that multicam clip, in every project. For more
information, see Create multicam clips in the Browser on page 331.
You can use the Angle Editor to edit the individual clips inside a multicam clip (similar to
how you can edit the contents of a compound clip). The many changes you can make in the
Angle Editor include basic edits and trimming as well as effects you would normally add in the
Timeline, such as color corrections and transitions.
You can copy and paste clips in the Angle Editor. Clips are pasted sequentially as overwrite edits,
and in the monitoring angle only.
Tip:  Before you edit multicam clips in the Angle Editor, duplicate them in the Browser to
maintain clean backup copies.
You cannot cut and switch between angles in the Angle Editor. You also cannot connect clips,
solo clips, use the Precision Editor, perform ripple deletes, or use the Detach Audio and Break
Apart Clip Items commands.
Open a multicam clip in the Angle Editor
Do one of the following:
mm Double-click a multicam clip in the Browser.
mm Control-click a multicam clip in the Browser or the Timeline, and choose Open in Angle Editor
from the shortcut menu.
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The Angle Editor opens in the Timeline area at the bottom of the Final Cut Pro window. Although
similar to the Timeline, the Angle Editor provides a separate interface dedicated to editing angles
and clips inside multicam clips. Each angle in the multicam clip appears as a separate row in the
Angle Editor.

The Angle Editor appears
in the Timeline area.

Set video and audio monitoring in the Angle Editor
In the Angle Editor, you can set any one angle to be the monitoring angle. This is the angle
you see in the Viewer when the multicam clip is playing back in the Angle Editor. You can also
monitor the audio of any number of angles at once.
You use the monitoring angle to synchronize angles in the Angle Editor. The monitoring angle
is not the same thing as the active angle (which you see in the Timeline). You cannot cut and
switch between angles in the Angle Editor.
Note:  Setting the correct monitoring angle is important for the two synchronization commands
described later in this section: Sync to Monitoring Angle and Sync Angle to Monitoring Angle.
1 To open the Angle Editor, do one of the following:
••

Double-click a multicam clip in the Browser.

••

Control-click a multicam clip in the Browser or the Timeline and choose Open in Angle Editor
from the shortcut menu.

2 To set an angle as the monitoring angle, do any of the following:
••

Click the Video Monitor icon at the left side of the angle.

••

Choose Set Monitoring Angle from the pop-up menu next to the angle name.

••

Press Shift-V while skimming the angle.
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The Video Monitor icon turns white, and the entire angle is highlighted in light gray. The angle
plays in the Viewer when you play back the multicam clip in the Angle Editor. Only one angle can
be the video monitoring angle at a time.

Click to set the monitoring angle.

3 To turn on audio monitoring for an angle, do one of the following:
••

Click the Audio Monitor icon once. (To turn off audio monitoring, click the icon again.)

••

Choose Monitor Audio from the pop-up menu next to the angle name. (To turn off audio
monitoring, choose Monitor Audio again.)

••

Press Shift-A while skimming the angle. (To turn off audio monitoring, press Shift-A again.)
Audio monitoring on

Audio monitoring off

The monitoring settings do not affect any of your active angles. They simply change what is
playing back in the Viewer while you’re working in the Angle Editor.
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Tip:  You can use audio monitoring to double-check the synchronization of individual angles
in a multicam clip. Open the clip in the Angle Editor, and turn on audio monitoring for two or
more angles at a time. You will hear immediately if the angles are in sync or if you need to adjust
them further.
Manually adjust the synchronization of a multicam clip
A primary function of the Angle Editor is to provide an easy way to correct out-of-sync angles in
your multicam clips. The instructions below describe how to synchronize angles by locating sync
points and then manually dragging them into alignment.
1 To open the Angle Editor, do one of the following:
••

Double-click a multicam clip in the Browser.

••

Control-click a multicam clip in the Browser or the Timeline and choose Open in Angle Editor
from the shortcut menu.

2 Locate a sync point in one of the out-of-sync angles by skimming the angle in the Angle Editor.
As you skim, the angle is displayed in the left side of the Viewer (in place of the Angle Viewer).
The sync points could be video or audio cues (such as a clapboard closing or a door slam).
3 Locate the corresponding sync point in one or more angles that you want to synchronize to the
original angle.
To simplify this process, you can add markers at the sync points, to guide you visually and to
provide snap points.
4 Drag the clips left or right in the rows of the Angle Editor so that the sync points align vertically.
Sync point

Drag the clip to align
the sync points.

Sync point
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If an angle contains more than one clip, you can easily select all clips in the angle so that you can
move them all at once. To do this, choose Select Clips in Angle from the pop-up menu next to
the angle name.
To select all clips in an angle,
choose Select Clips in Angle
from the pop-up menu.

You can then drag the clips left or right to move them all by the same amount.
When all clips in the angle
are selected, you can drag
them all at once.

Automatically adjust the synchronization of a multicam clip
The instructions below describe two automatic methods for synchronizing angles in a
multicam clip.
1 To open the Angle Editor, do one of the following:
••

Double-click a multicam clip in the Browser.

••

Control-click a multicam clip in the Browser or the Timeline and choose Open in Angle Editor
from the shortcut menu.

2 In the out-of-sync angle, click the pop-up menu to the right of the angle name and choose one
of the following:
••

Sync to Monitoring Angle: This option opens a two-up display in the Viewer, showing the frame
at the skimmer position on the left and the frame at the playhead position of the monitoring
angle on the right. In the out-of-sync angle, skim to a frame and click to sync the angle to the
playhead position. All the clips in the angle move together to align the frame you clicked with
the playhead. To close the two-up display in the Viewer, click Done.

••

Sync Angle to Monitoring Angle: This option compares the audio waveforms in the selected
angle to the waveforms in the monitoring angle, and then moves the clips in the selected
angle to synchronize them with those in the monitoring angle. This is the same audio
sync technology that you can use to automatically analyze and sync clips together into a
compound clip.
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If you select clips in one or more angles before choosing this option, the command name
in the pop-up menu changes to Sync Selection to Monitoring Angle. When you choose this
option, Final Cut Pro moves all of the selected clips to synchronize them with those in the
monitoring angle. If there is a selection in the monitoring angle, this option is not available.
WARNING:  This option does not ripple clips forward. If clips are moved to a Timeline location
that is already occupied by existing clips, the moved clips overwrite the existing clips.
Note:  Some audio recordings are not suited for use with this feature. Choosing this option
may result in long processing times during which Final Cut Pro is not available for editing.
Adjust the order of angles in a multicam clip
You can adjust the order in which angles appear in the Angle Viewer and the Angle Editor.
Note:  If you’ve already started a multicam edit on a multicam clip in the Timeline, changing the
angle order does not affect which angle is chosen for each cut and switch edit.
1 To open the Angle Editor, do one of the following:
••

Double-click a multicam clip in the Browser.

••

Control-click a multicam clip in the Browser or the Timeline and choose Open in Angle Editor
from the shortcut menu.

2 At the right side of the Angle Editor, use the drag handles to drag the angle rows up or down to
reorder them.

Use the drag handles
to reorder the angles.

The angles in the Angle Editor and the Angle Viewer change to the new order.
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Add, delete, or rename angles in a multicam clip
1 To open the Angle Editor, do one of the following:
••

Double-click a multicam clip in the Browser.

••

Control-click a multicam clip in the Browser or the Timeline and choose Open in Angle Editor
from the shortcut menu.

2 Do any of the following:
••

To delete an angle: Choose Delete Angle from the pop-up menu to the right of the angle name.
The angle is removed from the Angle Editor, the Angle Viewer, and all child clips of the
multicam clip.
Important:  Deleting an active angle affects the edits in your projects. The deleted angle is
replaced with black filler in all projects.

••

To add an angle: Choose Add Angle from the pop-up menu to the right of the angle name.
A new, empty angle appears in the Angle Editor and the Angle Viewer.

••

To rename an angle: At the left side of the Angle Editor, click the name of the angle you want
to rename. When the text becomes highlighted, type the new name.
The new name appears in the Angle Editor and (if overlays are turned on) in the Angle Viewer.

Edit multicam clips in the Timeline and the Inspector
You can switch multicam clip angles directly in the Timeline or the Info Inspector, without having
to open the Angle Viewer.
Multicam clips generally function in the Timeline like any standard clips. You can add video and
audio effects, transitions, and markers; attach connected clips; and apply retiming effects. You can
apply split edits to multicam clips and edit them in the Precision Editor. You can nest multicam
clips in compound clips and storylines.
However, multicam clips do have some unique characteristics in the Timeline:
••

You can display the names of the active video angle and the active audio angle in the
multicam clip in the Timeline.
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••

Cut and switch edit points appear as dotted lines in the Timeline. These are through edits (in
which the video or audio content on either side of the edit point is continuous). In the case
of multicam editing, through edits indicate that the content on either side of the edit point
comes from the same multicam clip. A black dotted line indicates that different angles from
the same multicam clip are on either side of the edit point.
Before the cut,
the angle is “car left.”

After the cut,
the angle is “car right.”

A through edit point appears
at the playhead position.
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In the case of video-only or audio-only cuts and switches, the edit point can be mixed (with
both black and white dotted lines). For example, when you cut and switch video only, you see
a black dotted line for the video and a white dotted line for the audio.
Black dotted lines indicate that different
angles from the same multicam clip are
on either side of the edit point.

A white dotted line indicates
that the same angle is on
either side of the edit point.
••

When you move the pointer over a multicam through edit, the pointer changes to the Trim
tool, indicating that the edit will be a roll edit (because any other type of edit breaks the
relationship between the clips on either side of the cut and switch edit point in the Timeline).

••

Many edits (such as split edits, markers, connected clips, and retiming effects) remain in
place on a multicam clip in the Timeline even after you switch the angle. But certain editing
operations are associated directly with the specific angle and are not retained when you
switch angles:
••

Video and audio effects

••

Keyframing (including audio volume and panning)

••

Role assignments

Switch angles in the Timeline
1 In the Timeline, Control-click the multicam clip you want to switch.
2 Do one of the following:
••

To switch the video angle: Choose Active Video Angle from the shortcut menu, and choose the
angle you want to switch to from the submenu.

••

To switch the audio angle: Choose Active Audio Angle from the shortcut menu, and choose the
angle you want to switch to from the submenu.

The clip switches to the video or audio angle you chose.
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Switch angles in the Inspector
Switching angles in the Inspector allows you to switch angles for multiple selected multicam
clips at once.
1 Select one or more multicam clips that you want to switch.
2 Open the Info inspector.
3 In the Info inspector, do one of the following:
••

To switch the video angle: In the Active Video Angle pop-up menu, choose the angle you want
to switch to.

••

To switch the audio angle: In the Active Audio Angle pop-up menu, choose the angle you want
to switch to.

Display the names of the active video and audio angles in the Timeline
You can have Final Cut Pro display the names of the active video angle and the active audio
angle in the multicam clip in the Timeline, in the following format: V: video angle name | A: audio
angle name.
Active video angle
Active audio angle

mm Click the Clip Appearance button in the lower-right corner of the Timeline and choose Clip
Names or Angles from the Show pop-up menu.
Remove multicam through edit points
mm To remove an individual multicam through edit: Select it and press Delete.
mm To remove multiple through edits at once: Select the edit points (or select the clips on both sides of
the through edits) and choose Trim > Join Clips.

Multicam editing tips and tricks
The following tips can help you streamline your multicam workflow:
••

Set the date, the time, and the time zone on your camcorder or recording device before you
shoot footage for your multicam project. This provides useful information to Final Cut Pro
during the automatic multicam clip creation process.
Note:  At any time, you can change the Content Created date and time of your source clips in
the Browser. Just select one or more clips and choose Modify > Adjust Content Created Date
and Time.

••

Because you can use the sophisticated automatic audio sync feature in Final Cut Pro to
help ensure multicam synchronization accuracy, it makes sense to record audio on every
camcorder and recording device in your multicam production. (Clear audio recordings provide
the best results.)

••

Before you edit multicam clips in the Angle Editor, duplicate them in the Browser to maintain
clean backup copies.

••

To double-check the synchronization of individual angles in a multicam clip, open the clip in
the Angle Editor and turn on audio monitoring for two or more angles at a time. You will hear
immediately if the angles are in sync or if you need to adjust them further.
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••

••

If performance becomes an issue while you’re working on a multicam project, do any of the
following:
••

Set Final Cut Pro to use proxy media by choosing Proxy in the Media section of the Viewer
Options pop-up menu (in the upper-right corner of the Viewer). Proxy playback allows you
to play back more angles at a time. To use proxy playback, you must have proxy versions of
your media available, or you must create proxy versions. For more information, see Manage
optimized and proxy media files on page 425.

••

Make sure that “Create optimized media for multicam clips” is selected in Playback
preferences. For more information, see Playback preferences on page 443. This option
transcodes video to the Apple ProRes 422 codec format, which provides better performance
during multicam editing. This option is turned on by default. If the original camera format
can be edited with good performance, you can deselect this checkbox.

••

Make sure that the hard disk holding your multicam source clips is fast enough to play back
all of your media at once. You can check hard disk performance by choosing Final Cut Pro >
Preferences and selecting “Warn when frames are dropped due to hard disk performance.”
To find out if something else is causing playback issues, select “Warn when dropping frames
during playback.”

You can use photos (from a still camera) in a multicam clip. If the date and time (Content
Created) information matches the contents of the other angles, the photos are automatically
adjusted in duration to “fill in” the angle.
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Keying and compositing

11

Keying
Keying overview
There are times when you need to combine two clips to create an image with bits of both. A
common way to combine two clips is to use a keying process, where the video of the top, or
foreground, clip is processed to eliminate either a color or luma value in areas of the video and
then is combined with the bottom, or background, clip.

For example, keying allows you to take a video clip of a person standing in front of a green
background and replace that green with a street scene, making it appear as though that person
is standing on the street.
This type of keying is accomplished using one of two keyer effects in Final Cut Pro:
••

Keyer: This general purpose chroma-keying effect is optimized for blue- or green-screen keying
but can key any range of color you choose. See Use chroma keys on page 355.

••

Luma Keyer: This is designed to generate mattes based on the image’s lightness—you choose
to remove the white or black areas and whether or not the gray areas should be partially
transparent. See Use luma keys on page 363.

In addition to these keying effects, you may need to use a matte, a positioning effect, and color
correction to ensure the foreground video looks natural when keyed over the background. For
more information, see Finalize the key on page 368.
Another way to combine two clips is for the foreground clip to have an alpha or matte
channel that defines which parts of the foreground clip to keep and which to replace with the
background clip. This is common when working with computer-generated logos or animated
graphics. For more information, see Compositing overview on page 372.
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Use chroma keys
A challenging part of creating a good chroma key is shooting the chroma key video, and in
particular, using a good, well-lit background that provides a uniform color to remove. A wide
variety of specialized chroma key background options are available, from chroma key paint
that includes highly reflective additives to chroma key cloth or paper sheets. Additionally, it is
important to use the best camera you can access and avoid using a highly compressed video
format such as DV or MPEG-2.
For the following examples, this woman will be keyed over a street scene. The light stands will be
handled in Finalize the key on page 368.

Apply the chroma key effect
1 In the Timeline, add the foreground clip (the chroma key clip with the color you want to remove)
to the primary storyline.
2 Drag the background clip (the clip you want to superimpose the chroma key clip over) so that it
is connected below the foreground clip in the primary storyline.

Foreground

Background
attached as a
connected clip

For more information about connected clips, see Connect clips to add cutaway shots, titles, and
synchronized sound effects on page 103.
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3 Select the foreground clip in the Timeline, and click the Effects button in the toolbar.

Tip:  For best results, also position the playhead at a point within the foreground clip that shows
the maximum amount of the color to be keyed.
4 In the Effects Browser, select the Keyer effect.
Tip:  Type “keyer” in the Effects Browser’s search field to quickly find the Keyer effect.
5 Do one of the following:
••

Drag the effect to the Timeline foreground clip to which you want to apply it.

••

Double-click the effect thumbnail to apply it to the selected clip.

The Keyer effect automatically analyzes the video to detect a green or blue dominant color
and configures itself to remove that color. If the resulting key is not right or you would like to
improve it, you can adjust the chroma key effect.
Adjust the chroma key effect
The following steps assume you have applied the chroma key effect.
1 In the Timeline, select the foreground clip with the Keyer effect, and open the Video inspector.
Controls for modifying and improving the Keyer effect appear.
2 If the Select tool is not the active tool, choose it from the Tools pop-up menu in the toolbar (or
press A).

3 To improve the key using controls in the Viewer, use the Refine Key and Strength controls to do
any of the following:
••

To identify areas of the foreground clip that might still have some of the chroma key color showing:
Click the Sample Color thumbnail image in the Video inspector and draw a rectangle in the
Viewer over the area where the chroma key color needs to be removed.
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Note:  By default, the Keyer effect applies spill removal, which causes any leftover fringing of
the blue- or green-screen background color you’re making transparent to appear as gray. To
see the original color, set the Spill Level parameter to 0%.
Drag over an area where
the chroma key color
is not being removed.

To improve the key, you can drag the rectangle to adjust its position or drag its corners to
change its size, and you can drag additional rectangles over any areas with the chroma key
color still showing.
Tip:  Select Matte (the center button) in the View area in the Video inspector to see the matte
that the chroma keyer is creating. This can make it much easier to see areas that are not
keying well.
••

To refine any difficult areas, such as hair and reflections: Click the Edges thumbnail image in
the Video inspector, draw a line across the difficult area in the Viewer (with one end in the
area to keep and the other in the area to remove), and drag the line’s handle to adjust the
edge softness.

Drag to set the edge softness.

You can use the following keyboard shortcuts to work directly in the Viewer:
••

To make a Sample Color adjustment: Draw a rectangle while holding down the Shift key.

••

To make an Edges adjustment: Draw a line while holding down the Command key.

••

To delete a Sample Color or Edges adjustment: Click a Sample Color rectangle or Edges line
while holding down the Option key, or select the control and press the Delete key.
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••

To choose a different color if the Keyer effect chose the wrong color: Set the Strength parameter
to 0 (to override the automatic initial color sampling). Then use Sample Color to choose the
color to remove. Select Composite (the left button) in the View area to see the foreground clip
combined with the background clip.

••

To adjust how strongly the Keyer matches a color in the foreground image to the default chroma
key color: Use the Strength slider to adjust the tolerance (core transparency) of the Keyer
effect’s automatic sampling. The default value is 100%. Reducing this value narrows the range
of color sampled, resulting in less transparency in the keyed image. Increasing the Strength
value expands the range of color sampled, resulting in more transparency in the keyed image.
The Strength parameter is useful to retrieve areas of semitransparent detail such as hair,
smoke, or reflections.

4 To help fine-tune the key, use the View options:
Composite
(foreground combined
with background)

Original
(unprocessed
foreground)
The name of the currently
selected View button
Matte (foreground-based
alpha signal created
by the keyer)

••

Composite: Shows the final composited image, with the keyed foreground subject over the
background clip. This is the default view.

••

Matte: Shows the grayscale matte, or alpha channel, that’s being generated by the keying
operation. White areas are solid (the foreground video is opaque), black areas are transparent
(the foreground is not seen at all), and varying shades of gray indicate varying levels
of transparency (the background video can be seen mixed with the foreground video).
Viewing the matte makes it easier to spot unwanted holes in the key or areas that aren’t
transparent enough.

••

Original: Shows the original, unkeyed foreground image.

5 To further refine the matte, use the following controls:
••

Fill Holes: Increasing this parameter value adds solidity to regions of marginal transparency
within a key. This control is useful when you’re satisfied with the edges of your key, but you
have unwanted holes in the interior that you can’t eliminate via the Strength parameter
without ruining your edges.

••

Edge Distance: Lets you adjust how close to the edge of your keyed subject the effect of the Fill
Holes parameter gets. Reducing this parameter value brings the filled area of the matte closer
to the edge of the subject, sacrificing translucency at the edges. Raising this parameter value
pushes the filled area of the matte farther from the edge. Too much edge distance can result
in unwanted translucency within parts of the subject that should be solid.
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6 To suppress any of the background color that is appearing (spilling) on the foreground image,
adjust the Spill Level control.
7 To reverse the keying operation, retaining the background color and removing the foreground
image, select Invert.
8 To mix the keyed effect with the unkeyed effect, adjust the Mix control.
For information about making advanced chroma key adjustments, see the following instructions.
Make advanced chroma key adjustments
The following controls are available for use in difficult keying situations or for fine-tuning specific
problems:
••

Color Selection: These controls are meant to be used after you begin creating a key using
automatic sampling or the Sample Color and Edges tools. (However, you can skip those tools
and create a key using Manual mode, described below.) The graphical Chroma and Luma
controls provide a detailed way of refining the range of hue, saturation, and image lightness
that define the keyed matte.

••

Matte Tools: These controls are for refining the transparency matte generated by the previous
sets of parameters. These parameters don’t alter the range of values sampled to create the
keyed matte. Instead, they alter the matte generated by the Keyer effect’s basic and advanced
controls, letting you shrink, expand, soften, or invert the matte to achieve a better composite.

••

Light Wrap: These controls are for blending color and lightness values from the background
layer of your composite with the keyed foreground layer. Using these controls, you can
simulate the interaction of environmental lighting with the keyed subject, making it appear as
if background light wraps around the edges of a subject.

The following steps assume you have applied the chroma key effect.
1 In the Timeline, select the foreground clip with the Keyer effect, and open the Video inspector.
Controls for modifying and improving the Keyer effect appear.
2 Click Color Selection to reveal the following controls:

••

Graph: Provides two options to set how the adjustable graphs in the Chroma and Luma
controls are used to fine-tune a key:
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••

Scrub Boxes: Select to limit the Chroma and Luma controls to adjusting softness (edge
transparency) in the matte you are creating. In this mode, you cannot manually adjust
tolerance (core transparency), which is determined by the Keyer effect’s automatic sampling,
plus any Sample Color rectangles you’ve added in the Viewer. (To increase matte tolerance,
add more Sample Color rectangles or adjust the Strength slider.)

••

Manual: Select to use the Chroma and Luma controls to adjust the softness (edge
transparency) and tolerance (core transparency) in the matte you are creating. Make sure the
Strength slider is set to a value greater than 0 before you switch to Manual mode; otherwise
the Chroma and Luma controls are disabled. When you switch to Manual mode, the Refine
Key tools and Strength slider become disabled, but samples you’ve made with those
controls continue to contribute to the matte.

Important:  When you switch to Manual mode, it’s best not to switch back to Scrub Boxes
mode. For best results, begin keying an image using the Sample Color and Edges tools in
Scrub Boxes mode. Switch to Manual mode afterward if you feel it’s necessary to refine your
matte using the Chroma and Luma controls. However, if you switch back to Scrub Boxes mode,
you may experience unexpected combinations of additionally sampled and keyframed values
that might be difficult to control.
••

Chroma: Drag the two graphs in this color wheel control to adjust the isolated range of hue
and saturation that help define the keyed matte. The selected mode governs which graphs
in the color wheel are adjustable. The outer graph controls the softness (edge transparency)
of the matte you’re creating, and can be adjusted in either Scrub Boxes or Manual mode. The
inner graph controls tolerance (core transparency), and is only adjustable when in Manual
mode. Drag any side of either graph to expand or contract the graph’s border, which adds to
or subtracts from the range of hue and saturation contributing to the key. In Manual mode,
you can also drag inside the tolerance graph to adjust its overall position in the color wheel.
To the left of the color wheel, a small graph displays the slope of chroma rolloff, the relative
softness of matte edges in regions most affected by the Chroma control. Dragging the Chroma
Rolloff slider (described below) modifies the shape of this slope.
Tip:  It’s possible to zoom in to and pan around the Chroma control to more precisely adjust
the graphs. To zoom in to the Chroma control, move the pointer over the color wheel, and,
holding down the Z key, drag to the left to zoom out or to the right to zoom in. To pan in the
Chroma control, hold down the H key and drag in the color wheel in the direction you want
to move it. To reset the zoom and recenter the Chroma control, move the pointer over the
Chroma control and press Shift-Z.

••

Luma: Drag the adjustable handles in this grayscale gradient to modify the isolated range
of the luma channel (the range of lightness and darkness) that also helps define the keyed
matte. The upper handles (which appear only in Manual mode) adjust the tolerance (core
transparency) of the luma channel’s contribution to the key. The lower handles adjust the
softness (edge transparency) of the luma channel’s contribution to the key. The Graph mode
governs which handles are adjustable. In Scrub Boxes mode, you can adjust only the lower
softness handles, which modify the range of lightness and darkness affecting the edge
transparency of the matte. In Manual mode, you can also adjust the upper tolerance handles,
which modify core transparency within the luma channel of the matte. By default, the slope of
the left and right sides of the Luma graph has a slight “S” curve. You can modify the shape of
the curve by adjusting the Luma Rolloff slider (described below).
Note:  The luma softness handles may extend past the outer boundaries of the Luma control.
This is due to the floating-point precision of the Keyer effect and is expected behavior. To
reveal and move out-of-bounds handles, drag the slope line of the Luma graph.
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••

Chroma Rolloff: Use this slider to adjust the linearity of the chroma rolloff slope (displayed
in the small graph to the left of the Chroma control). Chroma rolloff modifies the softness
of the matte around the edges of regions that are affected most by the Chroma control.
Lowering this value makes the slope of the graph more linear, which softens the edges of the
matte. Raising this value makes the slope of the graph steeper, which sharpens the edges of
the matte.

••

Luma Rolloff: Use this slider to adjust the linearity of the luma rolloff slope (the ends of the
bell-shaped luma curve displayed in the Luma control). Luma rolloff modifies the softness of
the matte around the edges of regions that are affected most by the Luma control. Lowering
this value makes the slope between the upper and lower handles in the Luma control more
linear, which increases edge softness in the matte. Raising this value makes the slope steeper,
sharpening the edges of the matte and making them more abrupt.

••

Fix Video: Select this checkbox to apply subpixel smoothing to the chroma components of the
image, reducing the jagged edges that result from keying compressed media using 4:2:0, 4:1:1,
or 4:2:2 chroma subsampling. Although selected by default, this checkbox can be deselected if
subpixel smoothing degrades the quality of your keys.

3 Click Matte Tools to reveal the following controls:

••

Levels: Use this grayscale gradient to alter the contrast of the keyed matte, by dragging three
handles that set the black point, white point, and bias (distribution of gray values between the
black point and white point). Adjusting the contrast of a matte can be useful for manipulating
translucent areas of the key to make them more solid (by lowering the white point) or more
translucent (by raising the black point). Dragging the Bias handle right erodes translucent
regions of the key, while dragging the Bias handle left makes translucent regions of the key
more solid.

••

Black, White, Bias: Click the disclosure triangle in the Levels row to reveal sliders for the Black,
White, and Bias parameters. These sliders, which mirror the settings of the Levels handles
described above, allow you to keyframe the three Levels parameters (via the Add Keyframe
button to the right of each slider). Keyframing the Black, White, and Bias parameters may yield
a better key, one that adapts to changing blue-screen or green-screen conditions.

••

Shrink/Expand: Use this slider to manipulate the contrast of the matte to affect matte
translucence and matte size simultaneously. Drag the slider left to make translucent regions
more translucent while simultaneously shrinking the matte. Drag the slider right to make
translucent regions more solid while simultaneously expanding the matte.

••

Soften: Use this slider to blur the keyed matte, feathering the edges by a uniform amount.

••

Erode: Drag this slider right to gradually increase transparency from the edge of the solid
portion of the key inward.
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4 Click Spill Suppression to reveal the following controls:

••

Spill Contrast: Use this grayscale gradient to adjust the contrast of the color being suppressed,
using Black and White point handles (and corresponding sliders). Modifying spill contrast can
reduce the gray fringing surrounding a foreground subject. The Black point handle (on the left
side of the gradient control) lightens edge fringing that is too dark for a successful composite.
The White point handle (on the right side of the gradient control) darkens edge fringing that
is too light. Depending on how much spill is neutralized by the Spill Level slider, these controls
may have a greater or lesser effect on the subject.

••

Black, White: Click the disclosure triangle in the Spill Contrast row to reveal sliders for the
Black and White point parameters. These sliders, which mirror the settings of the Spill
Contrast handles described above, allow you to keyframe the Black point and White point
parameters (via the Add Keyframe button to the right of each slider).

••

Tint: Use this slider to restore the natural color of the keyed foreground subject. Because the
Spill Suppression controls eliminate blue or green spill by desaturating subtle blue or green
fringing and reflection on the subject, the Tint slider lets you add hues to restore the natural
color of the subject. Overdoing this parameter results in over-tinting the subject with the
complementary color of the hue being suppressed—magenta if green, and orange if blue.

••

Saturation: Use this slider to alter the range of hues introduced by the Tint slider (when the
Tint slider is used at moderate levels).

5 Click Light Wrap to reveal the following controls:

••

Amount: Use this slider to control the overall light wrap effect, setting how far into the
foreground the light wrap extends.

••

Intensity: Use this slider to adjust gamma levels to lighten or darken the interaction of wrapped
edge values with the keyed foreground subject.

••

Opacity: Use this slider to fade the light wrap effect up or down.
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••

Mode: Use this pop-up menu to choose the compositing method that blends the sampled
background values with the edges of the keyed subject. There are five modes:
••

Normal: Evenly blends light and dark values from the background layer with the edges of the
keyed foreground layer.

••

Lighten: Compares overlapping pixels from the foreground and background layers, and then
preserves the lighter of the two. Good for creating a selective light wrap effect.

••

Screen: Superimposes lighter portions of the background layer over wrapped areas of the
keyed foreground layer. Good for creating an aggressive light wrap effect.

••

Overlay: Combines the background layer with the wrapped areas of the keyed foreground
layer so overlapping dark portions become darker, light portions become lighter, and colors
become intensified.

••

Hard Light: Similar to the Overlay composite mode, except that colors become muted.

Animate the chroma key effect
To compensate for changing conditions in the foreground clip, you can make Sample Color and
Edges adjustments at multiple points in the clip.
The following steps assume you have applied the chroma key effect.
1 Place the Timeline’s playhead at the start of the clip.
2 Use Sample Color and Edges (described above) to create a good chroma key.
3 Move the Timeline’s playhead to a point later in the clip where the lighting or background
conditions change, resulting in the chroma key no longer being acceptable.
4 Use Sample Color and Edges to once again create a good chroma key.
5 To add additional adjustments at other playhead positions, repeat steps 3 and 4 as needed.
6 To move the playhead between each adjustment point you add, use the Jump to Sample arrows.
When you play the clip, the Sample Color and Edges settings smoothly change from one sample
point to the next. For even greater control, you can add keyframes for most of the other settings
in the Keyer section of the Video inspector. For more information about working with keyframes,
see Video animation overview on page 258.
Note:  Keyframes for the chroma and luma graphs in the Color Selection controls appear only in
the Video inspector and not the Video Animation Editor in the Timeline.

Use luma keys
Luma keys provide a way to composite a foreground clip over a background clip based on the
luminance levels in the video. This is most often useful for still images, such as a picture of a logo
over a black background, or computer-generated graphics.
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For the following examples, this speedometer image will be keyed over an outdoor car scene,
creating a reflected look.

Apply the luma key effect
1 In the Timeline, move the playhead to the point in the background clip (the clip you want to
superimpose the luma key clip over) where you want the key to start.
2 In the Browser, select the part of the foreground clip (the luma key clip with the black or white
you want to remove) you want to key over the background, and choose Edit > Connect to
Primary Storyline (or press Q).

Foreground clip

Background clip

For details about connecting clips in this way, see Connect clips to add cutaway shots, titles, and
synchronized sound effects on page 103.
3 Select the foreground clip in the Timeline and click the Effects button in the toolbar.

4 In the Effects Browser, select the Luma Keyer effect.
Tip:  Type “keyer” in the Effects Browser’s search field to quickly find the Luma Keyer effect.
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5 Do one of the following:
••

Drag the effect to the Timeline foreground clip to which you want to apply it.

••

Double-click the effect thumbnail to apply it to the selected clip.

The Luma Keyer effect automatically configures itself to remove black video. If the resulting key is
not right or you would like to improve it, you can adjust the luma key effect.
Adjust the luma key effect
The following steps assume you have applied the Luma Keyer effect.
1 In the Timeline, select the clip with the Luma Keyer effect.
2 Open the Video inspector.
The Effects section of the Video inspector shows the parameters available for adjusting the Luma
Keyer effect.

3 To reverse the key and remove white instead of black areas of the foreground clip, select Invert.
4 To adjust the white and black clip values, drag the handles at either end of the gradient
thumbnail image.
By default, these handles are set to provide a linear key where the luma level linearly controls the
transparency of the foreground—100% white is fully opaque, 0% black is completely transparent,
and 25% gray retains 25% of the foreground image. Dragging the white and black controls
changes the values that result in fully opaque or fully transparent foreground video.
5 To adjust the softness of the edges, adjust the Luma Rolloff control.
Higher values make the edges harder, removing any partial transparency, while lower values take
advantage of any anti-aliasing or softness the edges might have.
6 To help fine-tune the key, use the View options:
Composite
(foreground combined
with background)

Original
(unprocessed
foreground)
The name of the
currently selected
View button

Matte (foreground-based
alpha signal created
by the keyer)
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••

Composite: Shows the final composited image, with the keyed foreground subject over the
background clip. This is the default view.

••

Matte: Shows the grayscale matte, or alpha channel, that’s being generated by the keying
operation. White areas are solid, black areas are transparent, and varying shades of gray
indicate varying levels of transparency. Viewing the alpha channel makes it easier to spot
unwanted holes in the key or areas that aren’t transparent enough.

••

Original: Shows the original, unkeyed image.

7 To leave smoothly aliased text or graphics in the image visually intact, which can improve the
edges, select Preserve RGB.
8 To mix the keyed effect with the unkeyed effect, adjust the Mix control.
For information about making advanced luma key adjustments, see the following instructions.
Make advanced luma key adjustments
The following controls are available for use in difficult keying situations or for fine-tuning specific
problems:
••

Matte Tools: These controls are for refining the transparency matte generated by the previous
sets of parameters. These parameters don’t alter the range of values sampled to create the
keyed matte. Instead, they alter the matte generated by the Keyer effect’s basic and advanced
controls, letting you shrink, expand, soften, or invert the matte to achieve a better composite.

••

Light Wrap: These controls are for blending color and lightness values from the background
layer of your composite with the keyed foreground layer. Using these controls, you can
simulate the interaction of environmental lighting with the keyed subject, making it appear as
if background light wraps around the edges of a subject.

The following steps assume you have applied the luma key effect.
1 In the Timeline, select the clip with the Luma Keyer effect.
2 Open the Video inspector.
The Effects section of the Video inspector shows the parameters available for adjusting the Luma
Keyer effect.

Chapter 11    Keying and compositing

366

3 Click Matte Tools to reveal the following controls:

••

Fill Holes: Increasing this parameter value adds solidity to regions of marginal transparency
within a key. This control is useful when you’re satisfied with the edges of your key, but you
have unwanted holes in the interior that you can’t eliminate via the Luma Rolloff parameter
without ruining your edges.

••

Edge Distance: Lets you adjust how close to the edge of your keyed subject the effect of the Fill
Holes parameter gets. Reducing this parameter value brings the filled area of the matte closer
to the edge of the subject, sacrificing translucency at the edges. Raising this parameter value
pushes the filled area of the matte farther from the edge, potentially introducing regions of
unwanted translucency within parts of the subject that should be solid.

••

Levels: Use this grayscale gradient to alter the contrast of the keyed matte, by dragging three
handles that set the black point, white point, and bias (distribution of gray values between the
black point and white point). Adjusting the contrast of a matte can be useful for manipulating
translucent areas of the key to make them more solid (by lowering the white point) or more
translucent (by raising the black point). Dragging the Bias handle right erodes translucent
regions of the key, while dragging the Bias handle left makes translucent regions of the key
more solid.

••

Black, White, Bias: Click the disclosure triangle in the Levels row to reveal sliders for the Black,
White, and Bias parameters. These sliders, which mirror the settings of the Levels handles
described above, allow you to keyframe the three Levels parameters (via the Add Keyframe
button to the right of each slider). Keyframing the Black, White, and Bias parameters may yield
a better key, one that adapts to changing blue-screen or green-screen conditions.

••

Shrink/Expand: Use this slider to manipulate the contrast of the matte to affect matte
translucence and matte size simultaneously. Drag the slider left to make translucent regions
more translucent while simultaneously shrinking the matte. Drag the slider right to make
translucent regions more solid while simultaneously expanding the matte.

••

Soften: Use this slider to blur the keyed matte, feathering the edges by a uniform amount.

••

Erode: Drag this slider right to gradually increase transparency from the edge of the solid
portion of the key inward.

4 Click Light Wrap to reveal the following controls:

••

Amount: Use this slider to control the overall light wrap effect, setting how far into the
foreground the light wrap extends.
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••

Intensity: Use this slider to adjust gamma levels to lighten or darken the interaction of wrapped
edge values with the keyed foreground subject.

••

Opacity: Use this slider to fade the light wrap effect up or down.

••

Mode: Use this pop-up menu to choose the compositing method that blends the sampled
background values with the edges of the keyed subject. There are five modes:
••

Normal: Evenly blends light and dark values from the background layer with the edges of the
keyed foreground layer.

••

Lighten: Compares overlapping pixels from the foreground and background layers, and then
preserves the lighter of the two. Good for creating a selective light wrap effect.

••

Screen: Superimposes lighter portions of the background layer over wrapped areas of the
keyed foreground layer. Good for creating an aggressive light wrap effect.

••

Overlay: Combines the background layer with the wrapped areas of the keyed foreground
layer so overlapping dark portions become darker, light portions become lighter, and colors
become intensified.

••

Hard Light: Similar to the Overlay composite mode, except that colors become muted.

Finalize the key
Quite often your foreground image will have objects that you don’t want to appear in the
composited output. These could be production items like microphone booms and light stands
or the edges of the chroma key backdrop. Additionally, you might need to resize or reposition
the foreground object to better fit with the background. As a final step, you can use the color
corrector to adjust the foreground so that it matches the look of the background.
Final Cut Pro includes effects that you can use for these purposes.
Use the Mask effect
1 In the Timeline, move the playhead to the point in the background clip (the clip you want to
superimpose the chroma key clip over) where you want the key to start.
2 In the Browser, select the part of the foreground clip (the chroma key clip with the color you
want to remove) you want to key over the background, and choose Edit > Connect to Primary
Storyline (or press Q).

Foreground

Background
attached as a
connected clip

For details about connecting clips in this way, see Connect clips to add cutaway shots, titles, and
synchronized sound effects on page 103.
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3 Select the foreground clip.

In the above example, the light stands need to be removed.
4 Click the Effects button in the toolbar.

5 In the Effects Browser, double-click the Mask effect to apply it to the selected foreground clip.
Tip:  Type “mask” in the Effects Browser’s search field to quickly find the mask effect.
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6 Adjust the four corners of the mask to crop out the objects you want to remove, in this case, the
light stands.

When adjusting the mask, be sure to leave shadows and other details that can help make the key
more realistic later.
7 Apply the appropriate keyer effect to the foreground clip.

The foreground is composited over the background.
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Use Transform to position the foreground image
The following steps assume you have already configured a key but need to reposition the
foreground image.

1 Select the foreground clip in the Timeline.
2 In the lower-left corner of the Viewer, choose Transform from the pop-up menu and move the
image to the position you want. In the above example, you might want to move the woman to
the left.
You can also resize the image.

3 Click Done in the Viewer when you are finished repositioning the foreground image.
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Compositing
Compositing overview
Compositing refers to combining parts of two or more video clips into a single image.

There are a number of ways to combine video images in Final Cut Pro:
••

Transitions: All video transitions involve combining the end of one clip with the start of a
second clip, which results in a combination of the two clips appearing at the same time during
the transition.

••

Keying: All keys involve compositing a foreground image over a background image.

••

Alpha channels: Many computer-generated video clips have an alpha channel—a built-in
mask—that defines precisely the areas of the clip that are composited over a background
clip. These require no key setup and generally just automatically work. Many effects, such as
Transform and Distort; generators, such as Shapes and Timecode; and titles use alpha channels.

••

Compositing: Each video clip in the Timeline has a set of Compositing settings. These are used
when you want to combine clips without using the key effects.

Use alpha channels
Alpha channels provide an easy way to composite one image over another. Using an application
like Motion, an Apple application designed to work with Final Cut Pro, you can create still images
and video clips that have alpha channels. Alpha channels can be thought of as having a built-in
keyer—when you use the key effects you are creating a mask that is used in the same way a clip
with an alpha channel is used for compositing.
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Below is an example of a clip with an alpha channel, showing the image that fills the
alpha channel.

Below is the alpha channel image—the white areas define the video areas that are composited
over the background. The gray areas (which define the shadow in this example) define parts of
the image that are partially transparent.

This is what the final composite looks like over a background clip.
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Use a clip with an alpha channel
1 Position the playhead in the Timeline where you want to add the alpha channel clip.
2 Select the clip that has an alpha channel in the Browser, and choose Edit > Connect to Primary
Storyline (or press Q).
3 To see the composited clips, position the playhead within the clip that was just added above the
primary storyline.
Connected clip
(composite foreground)

Primary storyline clip
(composite background)

The clip is composited over the primary storyline video clip, with the alpha channel controlling
the opacity of its clip.
You can also use the Opacity adjustment’s fade handles to dissolve the foreground clip on
and off.

Use Compositing settings
The Compositing settings provide a wide variety of options for combining two images. You can
make a simple adjustment to evenly combine two images, or you can choose from settings that
use the video content to determine how to combine the images.
Use the Opacity adjustment
1 Position the playhead in the Timeline where you want to add a clip above the primary storyline.
2 Select the clip to add in the Browser, and choose Edit > Connect to Primary Storyline (or press Q).
3 To see the composited clips, position the playhead within the clip that was just added.
By default, the new clip completely obscures the clip on the primary storyline.
4 To make the new clip partially transparent, select it in the Timeline and adjust the Opacity
control in the Compositing section of the Video inspector.
The closer you set Opacity to 0 percent, the more transparent the clip above the primary
storyline becomes. Additionally, you can use the Opacity fade handles in the Video Animation
Editor to have the composited clip dissolve on and off, or add keyframes to have the opacity
value change at specified points.
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Choose a blend mode
1 Position the playhead in the Timeline to where you want to add a clip above the
primary storyline.
2 Select the clip to add in the Browser, and choose Edit > Connect to Primary Storyline (or press Q).
3 To see the composited clips, position the playhead within the clip that was just added.
By default, the new clip completely obscures the clip on the primary storyline.
4 Choose an option from the Blend Mode pop-up menu in the Compositing section of the
Video inspector.
There are many blend mode settings to choose from—the correct one to use depends on the
video content and the sort of look you are aiming for. Additionally, you can adjust the Opacity
control to make the blend mode setting more subtle.
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12

Color correction

Color correction overview

In any post-production workflow, color correction is generally one of the last steps in finishing an
edited program. There are a number of reasons to color correct your footage:
••

Make sure that key elements in your program, such as flesh tones, look the way they should

••

Balance all the shots in a scene to match

••

Correct errors in color balance and exposure

••

Achieve a look, such as making the scenes warmer or cooler

••

Create contrast or special effects by manipulating the colors and exposure

Final Cut Pro color correction tools give you precise control over the look of every clip in your
project, including still images, by letting you adjust each clip’s color balance, shadow levels,
midtone levels, and highlight levels.
Click to return to the
Video inspector.
Choose the correction
to work with.
Click the Reset button to
remove the adjustments
in this pane.

Drag the controls to
change the values.

Use value sliders to
change the values.

Use the Action pop-up menu
to create or choose a color
correction preset.

Final Cut Pro also includes several automatic tools you can use to quickly balance and match the
color in clips. You can:
••

Automatically balance colors: With one click, neutralize any color casts and maximize image
contrast. See Color balance overview on page 377.

••

Automatically match a clip’s color and look: With two clicks, make one or more clips match
the color look of any clip that you choose. See Match color between clips automatically on
page 379.
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••

Manually adjust color, saturation, and exposure: Manually correct a clip’s overall color, or use
color or shape masks to limit a correction to a particular color range or area in the image.
You can even add multiple manual color corrections to one clip. See Manual color correction
overview on page 380.

••

Save color correction settings and apply them to other clips: Save a clip’s color correction settings
and apply them to other clips in the project or in other projects. See Save and apply color
correction presets on page 390.

Although these features are independent of one another—you can turn any of the features
off and on to see its effect—the order in which you use them matters. In general, you should
use these features in the order of Balance Color, Match Color, and (if necessary) manual
color correction.
Final Cut Pro also includes several video scopes you can use when manually color correcting
your video. The scopes make it possible to precisely monitor the luma and chroma levels of your
video clips.

Analyze and balance color automatically
Color balance overview
Final Cut Pro includes an automatic color-balancing feature. When you use the color-balancing
feature, Final Cut Pro samples the darkest and lightest areas of the image’s luma channel and
adjusts the shadows and highlights in the image to neutralize any color casts. In addition,
Final Cut Pro adjusts the image to maximize image contrast, so that the shot occupies the widest
available luma range.
The video frame used as the reference frame depends on whether the clip has already been
color analyzed:
••

If the clip has been color analyzed, either during import or while in the Browser: The analysis
process extracts color balance information for the entire clip. Whether you add a portion of
the clip or the entire clip to a project, the color-balancing feature chooses the frame within
the project clip that is closest to being correctly balanced. This means that if you add multiple
partial clips from the same Browser clip to the project, each clip is balanced based on analysis
information for its own section of media.

••

If the clip has not been color analyzed and you balance its color: You can determine the reference
frame for a clip selected in the Timeline by moving the playhead to that frame in the clip. If
the playhead is on a different clip or you’ve selected a clip in the Browser, the clip’s middle
frame is used.

Analyze a clip for color balance
To automatically balance a clip’s color, Final Cut Pro uses a single frame from the clip as a
reference and calculates a correction for it that is then applied to the entire clip. Analyzing a clip
for color balance allows Final Cut Pro to choose a representative frame as the clip’s color balance
reference frame.
You can have a clip’s color balance analyzed when you import it, whether importing from a
camera, importing a file, or dragging a clip directly to the Timeline from a Finder window. You
can also analyze a clip’s color balance at any time in the Browser.
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Analyzing a clip for color balance can take from a few seconds for shorter clips to a minute
or more for longer clips. The analysis process takes longer if you also analyze for people and
stabilization issues.
After a clip has been analyzed for color balance, you can turn the color balance correction
on or off at any time. By default, color balance correction is off for clips in the Browser and on
for clips in the Timeline, if they have been analyzed. For information about turning the color
balance correction on and off, in either the Browser or the Timeline, see Balance a clip’s colors on
page 379.
Analyze color balance during file import
1 Choose File > Import > Media (or press Command-I).
2 Select the files to import, and select “Analyze for balance color” in the Video section of
the window.
3 Click Import.
The files are imported and analyzed for color balance issues.
Analyze color balance for clips dragged to the Timeline from the Finder
1 Choose Final Cut Pro > Preferences, or press Command-Comma (,).
2 In the Final Cut Pro Preferences window, click the Import button and select “Analyze for balance
color” in the Video section.
All clips that you drag directly to the Timeline from the Finder are now analyzed.
Note:  When you change this setting in the Preferences window, the setting is also changed in all
other windows with an “Analyze for balance color” option.
Analyze color balance for clips in the Browser
When you analyze the color balance of clips in the Browser, any clips that were analyzed during
import are skipped.
1 Select one or more clips in the Browser.
2 Do one of the following:
••

Choose Modify > Analyze and Fix.

••

Control-click one of the selected clips and choose Analyze and Fix from the shortcut menu.

3 In the window that appears, select “Analyze for balance color” in the Video section and click OK.
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Balance a clip’s colors
Clips in Final Cut Pro have a Balance setting that turns automatic color balance correction on and
off, whether the clip is in the Browser or the Timeline. The frame used as the reference frame is
either a frame chosen during color balance analysis, the frame the playhead is on in the Timeline,
or the middle frame. For more information, see Color balance overview on page 377.
Turn a clip’s color balance correction on and off
1 Select one or more clips in the Timeline or the Browser.
2 Do one of the following:
••

Choose Modify > Balance Color (or press Option-Command-B).

••

Choose Balance Color from the Enhancements pop-up menu in the toolbar.

••

In the Color section of the Video inspector, select or deselect the Balance checkbox.

Balance analysis status
Click to turn Balance on or off.

Match color between clips automatically

Your project likely uses video from a wide variety of sources. The Match Color feature makes it
easy to ensure that all scenes that take place in the same location have the same look.
Match color between clips
1 Select one or more clips in the Timeline that you want to adjust.
2 Do one of the following:
••

Choose Modify > Match Color (or press Option-Command-M).

••

Choose Match Color from the Enhancements pop-up menu in the toolbar.

••

In the Color section of the Video inspector, click the Choose button next to Match Color.
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The Viewer changes to display the Timeline playhead’s frame on the right and the frame the
pointer is over on the left.
The clip that the pointer is
over is the color match source.
Click to preview the color match.

The selected
Timeline clip is the
color match target.

3 Skim any clip in the Timeline or the Browser to find a frame with the color look you want to
match, and click to preview that look applied to the selected clip.
You can click a variety of clips until you find the look you want.
Tip:  You may want to import a still image that has the look you want, even if it’s not related to
your project, so that you can match its color look.
4 To accept the current look, click Apply Match in the Match Color window.
The Viewer returns to its normal configuration, and the selected Timeline clips change to the
new look.
Turn match color corrections on or off
You can turn off the color match corrections that have been applied to a clip. This is useful for
viewing the difference between the original clip and the corrected clip.
1 In the Timeline, select a clip with match color corrections applied.
2 Click the Color Match checkbox in the Color section of the Video inspector.

Adjust color manually
Manual color correction overview
Final Cut Pro includes a powerful manual color correction tool that you can use to accomplish a
wide variety of color correction or enhancement effects:
••

Apply a color correction to the whole image: Adjust the color tint, color saturation, and exposure
for the whole clip image. See Color correct the whole image on page 381.

••

Choose a specific color in the image to correct: For example, choose a brightly colored object,
such as a shirt or car, and use the color correction settings to mute or change the color. See
Target a specific color using a color mask on page 383.

Chapter 12    Color correction

380

••

Choose an area of the image to correct: Draw one or more shape masks, and then choose
whether the correction applies inside or outside the masks. You can even have the position of
the masks change as the clip plays. See Target specific areas using shape masks on page 385.

You can also apply multiple color corrections to a single clip and use shape masks in
combination with a color mask. For example, you could use one correction to set the clip’s overall
color look, a second to target and alter a specific color, and a third to target a different color or an
area defined by a shape mask. See Apply multiple color corrections on page 388 and Add shape
masks to a color mask on page 387.
You make manual color adjustments using the Color Board.

Color correct the whole image
You use the Color Board to manually adjust a clip’s color, saturation, and exposure.
Manually color correct the whole clip image
1 Select a clip in the Timeline, and do one of the following:
••

Choose Window > Go To > Color Board (or press Command-6).

••

Choose Show Color Board from the Enhancements pop-up menu in the toolbar.

••

Click the Color Board button
in the Color section of the Video inspector. (After you make
any Color Board adjustments, the button changes color.)

••

Click the upper-left corner of a clip in the Timeline and choose Color Adjustment from the
pop-up menu.
Click to return to the
Video inspector.
Choose the correction
to work with.
Click the Reset button to
remove the adjustments
in this pane.

Drag the controls to
change the values.

Use value sliders to
change the values.

Use the Action pop-up menu
to create or choose a color
correction preset.

2 If the clip has multiple corrections applied to it, choose the correction to adjust from the
Correction pop-up menu in the Color Board’s upper-right corner.
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3 To add or remove a color tint, click Color (or press Control-Command-C), and drag the controls in
the Color pane.
••

To adjust the tint for the whole image: Drag the Global control (the large gray control).

••

To adjust the tint in the darker areas of the image: Drag the Shadows control (the black control).

••

To adjust the tint in the midtones: Drag the Midtones control (the small gray control).

••

To adjust the tint in the brighter areas of the image: Drag the Highlights control (the white
control).

Dragging the controls up adds the color to the video, and dragging them down subtracts the
color (effectively adding the opposite color). Dragging the controls left and right chooses the
color to add or subtract.
You can also select the control and enter values numerically using the corresponding value slider.
Tip:  To move the selected Color Board control up or down, press the Up Arrow or Down Arrow
key. In the Color pane, you can also use the Left Arrow or Right Arrow key to move the selected
control left or right.
4 To adjust the clip’s chroma level, click Saturation (or press Control-Command-S), and drag the
controls in the Saturation pane.
••

To adjust saturation for the whole image: Drag the Global control on the left.

••

To adjust saturation in the darker areas of the image: Drag the Shadows control.

••

To adjust saturation in the midtones: Drag the Midtones control.

••

To adjust saturation in the brighter areas of the image: Drag the Highlights control.

Dragging the controls up increases the chroma level, and dragging them down reduces the level.
These controls do not move left and right.
You can also select the control and enter values numerically using the corresponding value slider.
5 To adjust the clip’s luma level, click Exposure (or press Control-Command-E), and drag the
controls in the Exposure pane.
••

To adjust exposure for the whole image: Drag the Global control on the left.

••

To adjust exposure in the darker areas of the image: Drag the Shadows control.

••

To adjust exposure in the midtones (similar to a gamma control): Drag the Midtones control.

••

To adjust exposure in the brighter areas of the image: Drag the Highlights control.

Dragging the controls up increases the luma level, and dragging them down reduces the level.
These controls do not move left and right.
You can also select the control and enter values numerically using the corresponding value slider.
You can use the Command Editor to assign a keyboard shortcut to turn color corrections on
and off while making adjustments in the Color Board, and to assign keyboard shortcuts to many
other Color Board functions. For more information, see View keyboard shortcuts in the Command
Editor on page 472.
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Reset and turn off Color Board color corrections
1 In the Timeline, select a clip whose color corrections you want to remove.
2 In the Color Board, do any of the following:
••

To reset the currently selected control to its neutral state: Press Delete.

••

To reset all of a pane’s controls to their neutral state: Click the Reset button
upper-right corner.

••

To reset all three Color Board panes back to their neutral state: In the Color section of the Video
inspector, click the Reset button to the right of the Correction setting.

Click here to turn the
correction on or off.
••

in the pane’s

Color Board
Reset button

To turn Color Board corrections off without resetting them: In the Color section of the Video
inspector, deselect the checkbox for the correction.
Turning the corrections off and on makes it easy to quickly see the effect of your adjustments.

Target a specific color using a color mask
A color mask isolates a particular color in the image. You can apply a color mask to a clip to
correct a specific color, or to exclude that color from corrections to the rest of the image, or both.
For example, you could mute a brightly colored shirt in the background that distracts attention
from a clip’s main subject.
Using a color mask to control the color correction allows you to pick a color and then
independently adjust that color (reduce, enhance, or change it) or adjust everything except that
color (for example, add a tint or reduce the brightness or chroma levels).
Add a color mask to a color correction
1 In the Timeline, select a clip with a color that you want to mute or enhance.
2 Click the Add Color Mask button in the Color section of the Video inspector.

Click here to add
a color mask.

The Color Mask section appears.

When the button is
highlighted, use the
eyedropper to select the
mask color in the Viewer.
Selected mask color
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3 In the Viewer, position the eyedropper on a color in the image that you want to isolate, and drag
to select the color.

Drag to select the
color to mask.

As you drag, two concentric circles appear. The size of the outer circle determines the range of
variations in the selected color that are included in the color mask. As you change the outer
circle size, the image becomes monochrome except for the color you are selecting. You can drag
a new selection circle as many times as you like to try for better results.
Note:  When you stop dragging, the picture returns to its original look, but you’ll see the effects
of the color mask you have created as soon as you start making adjustments in the Color Board.
You can then return to the Video inspector and use the eyedropper to make any adjustments to
the color mask.
4 To change the range of color variations included in the mask, do any of the following:
••

To add color shades: Hold down the Shift key, position the eyedropper on a color you want to
add to the mask, and drag to select the color.

••

To subtract color shades: Hold down the Option key, position the eyedropper on a color you
want to remove from the mask, and drag to select the color.

5 To adjust the color mask edges, drag the Softness slider.
To have the Viewer temporarily show the color mask, hold down the Option key and then drag
the Softness control: white indicates fully opaque mask areas, black indicates areas outside the
mask, and levels of gray indicate transparent mask areas.
6 To adjust the color correction settings for this color mask, click the Color Board button
in the
Video inspector. (After you make any Color Board adjustments, the button color changes.)
7 Do one of the following:
••

To apply a color correction to the selected color: Click Inside.

••

To apply a color correction to everything except the selected color: Click Outside.

You can make corrections to both the inside and outside areas of the mask—each area
effectively has its own complete set of Color Board controls. For example, you could select Inside
Mask and enhance the targeted color, and then select Outside Mask to darken everything else.
8 Adjust the Color Board controls to create the effect you want.
For more information about working with the Color Board, see Color correct the whole image on
page 381.
To limit the area of the image affected by a color mask, you can add a shape mask. For more
information, see Add shape masks to a color mask on page 387.
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Target specific areas using shape masks
A shape mask defines an area in the image so that you can apply color corrections either inside
or outside that area. For example, you might want to emphasize a subject’s face by darkening the
area around the face.
You can add multiple shape masks to define multiple areas, and you can also animate the shapes
so that they follow an area while a camera pans or an object moves as the clip plays.
Add a shape mask
1 In the Timeline, select a clip with an area whose color you want to mute or enhance.
2 Click the Add Shape Mask button in the Color section of the Video inspector.

Click here to add
a shape mask.

A Shape Mask area appears.

Click here to show or
hide the shape mask
onscreen controls.

3 To adjust the default shape that appears in the Viewer, do any of the following:
Drag this handle to make
the shape rectangular.
Drag the outer edge
to control the softness.
Drag the center circle
to move the shape.
Drag this handle
to rotate the shape.
Drag any of these
handles to change the
shape’s width or height.
••

To position the shape: Drag the center.

••

To adjust the shape’s width or height: Drag any of the four handles at the 90-degree points (top,
bottom, left, or right) of the inner circle. You can hold down the Shift key while dragging to
force all sides to scale proportionally.

••

To control the roundness of the shape: Drag the handle to the left of the inner circle’s top handle.
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••

To rotate the shape: Drag the rotation handle (extending from the center).

••

To control the softness of the shape’s edge: Drag the outer circle. Setting the outer circle close
to the inner circle creates a hard edge and an abrupt transition to the corrections you apply,
and dragging the outer circle away from the inner circle creates a softer edge and a more
gradual transition.

••

To hide the mask’s controls: Click the Shape Mask onscreen controls button in the Shape Mask
area of the Color section of the Video inspector.

4 To adjust the color correction settings for this shape mask, click the Color Board button
in the
Video inspector. (After you make any Color Board adjustments, the button color changes.)
5 Do one of the following:
••

To apply a color correction to the shape area: Click Inside.

••

To apply a color correction to everything except the shape area: Click Outside.

You can make corrections to both the inside and outside areas of the mask—each area
effectively has its own complete set of Color Board controls. For example, you could select Inside
Mask and enhance the shape’s area, and then select Outside Mask to darken everything else.
6 Adjust the Color Board controls to create the effect you want.
For more information about working with the Color Board, see Color correct the whole image on
page 381.
7 To add additional shapes to the correction, click the Add Shape Mask button in the color
correction’s area in the Video inspector again.
Another default shape appears in the Viewer, and the original shape is dimmed. You can select
and continue configuring the original shape by clicking its center.
Delete a shape mask
1 In the Video inspector, select the Shape Mask item you want to delete.

Select a Shape Mask
item and press Delete.

2 Press Delete.
Note:  If you delete all shape masks in the correction, the Inside Mask corrections are applied to
the whole image.
Animate a shape mask
You can use keyframes to animate a shape mask so that it follows the movement of an
onscreen object.
1 To add a shape mask, follow the instructions in “Add a shape mask,” above.
2 In the Timeline, position the playhead on the clip with the shape mask at the frame where you
want the shape to begin moving.
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3 Position the shape mask to its starting position in the Viewer.
4 In the Video inspector, click the Keyframe button.

Click here to add
a keyframe.

A keyframe is added at the position of the playhead. You can see it in the Timeline by pressing
Control-V to open the Video Animation Editor. The keyframe appears in the Color section as a
diamond at the playhead position.

Keyframe indicator

5 Move the playhead to the next point in the clip where you want to define the shape mask’s
position, reposition the shape mask, and add the second keyframe.
6 To reposition the shape mask throughout the clip, continue adding keyframes until you’ve
defined the shape movement you want.
When you’ve added all the keyframes, you can play the clip to see the shape mask move
between them. For more information about working with keyframes, see Video animation
overview on page 258.

Add shape masks to a color mask
Often when you create a color mask, more areas of the video are affected by it than you would
like. For example, there might be a red car on the left side of the screen that you want to color
correct, and a red stop sign on the right that you don’t want to affect. In this situation, you can
add one or more shape masks to restrict the color mask to the areas defined by the shape masks.
Add a shape mask to a color mask
1 Select a clip in the Timeline, and use the Video inspector to add a color mask to it.
2 Apply a color correction using the Color Board, and note areas of the video that you don’t want
the color mask to affect.
For more information about working with the Color Board, see Color correct the whole image on
page 381.
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3 In the Video inspector, click the Add Shape Mask button in the correction that has the
color mask.

Click here to add
a shape mask
to the correction.

4 Adjust the shape mask so that it overlaps the part of the color mask you want to use.
5 To adjust the color correction settings, click the Color Board button
in the Video inspector.
(After you make any Color Board adjustments, the button color changes.)
6 Do any of the following:
••

To make color correction adjustments that apply only to the areas of overlap between the color
mask and shape mask: Select Inside Mask, at the bottom of the Color Board.

••

To make color correction adjustments that apply outside the areas of overlap between the color
mask and shape mask: Select Outside Mask.

If necessary, you can add additional shape masks, and even animate them.

Apply multiple color corrections
You can apply multiple color corrections to a clip to target specific issues. For example, you could
have one color correction that mutes a bright orange shirt and a second one that enhances the
green in the lawn.
Color masks are created based on the original colors in the clip. For example, if the first color
correction removes all chroma from the clip, the second color correction can still create a color
mask based on a color originally in the clip.
Apply multiple color corrections to a clip
1 Select a clip in the Timeline.
2 To add an additional color correction item, click the Add Correction button in the
Video inspector.
Click here to add a correction.

By default, the Color section contains the first manual color correction item (Correction 1)
along with the Balance and Match Color items. Color correction items that you add are named
Correction 2, Correction 3, and so on. Each correction item has its own Color Board button—
clicking one of these opens the Color Board with that correction’s settings. You can also choose a
correction in the Color Board using the pop-up menu in the upper-right corner.
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Note:  If you have applied multiple corrections to a clip, you can drag them in the Video inspector
to change their order. Rearranging the processing order can provide different results.
View color correction keyframes in the Timeline
If a clip has multiple corrections with animated shape masks, you can view a correction’s shape
mask keyframes in the Video Animation Editor above the clip in the Timeline.
1 In the Timeline, select a clip that has multiple color corrections with animated shape
masks applied.
2 Choose Clip > Show Video Animation (or press Control-V).
3 Choose the color correction you want to view from the Color pop-up menu:
••

To see a composite of keyframes from all corrections: Choose the correction, and if it contains
multiple shape masks, choose the one you want to see.

••

To see keyframes from a specific shape mask in a correction: Choose the correction, and if it
contains multiple shape masks, choose the one you want to see.
When you choose a specific correction, such as Correction 2, you see its keyframes in white
and the keyframes of other corrections in dark gray.

Add a transition between color corrections
You can have a video clip change from one color correction to another using a transition.
For example, if you want a scene to gradually highlight the two main characters, you can use
a transition to dissolve between the normal clip and the clip with shape masks and a color
correction applied that darkens the image outside of the masks.
Important:  Make sure that Available Media is chosen from the “Apply transitions using” pop-up
menu in the Editing pane of Final Cut Pro preferences. For more information about this setting,
see How transitions are created on page 212.
Configure a clip to change transitions
1 Temporarily switch to the Blade tool by holding down the B key.
2 In the Timeline, click a video clip at the point where you want to change between
color corrections.
The clip splits into two clips.
3 Apply a different color correction to each clip.
You can also leave one clip uncorrected and apply a color correction to the other.
The color correction could be an exaggerated tint, an exposure change, or any other
noticeable adjustment.
4 Select the edit point between the two clips, and press Command-T to insert a cross dissolve.
When you play the clip, one color correction dissolves into the other as the edit point is passed.
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Save and apply color correction presets

With Final Cut Pro, you can save a clip’s color correction settings as a preset, making it easy to
apply those settings to other clips in the same project or a different project.
Final Cut Pro includes several presets you can use in addition to any that you create.
Note:  Color correction presets save the current Color, Saturation, and Exposure settings only.
They do not save the mask settings, including whether you have Inside Mask or Outside
Mask selected.
Save a color correction preset
1 In the Timeline, select a clip that has the color correction look you want to save, and open the
Color Board.
2 Choose Save Preset from the Action pop-up menu
Color Board.

in the lower-right corner of the

3 Type a name for the preset and click OK.
Apply a color correction preset
1 Select a clip in the Timeline, and open the Color Board.
2 Choose a preset from the Action pop-up menu

in the lower-right corner of the Color Board.

The preset’s adjustments are applied to the selection. After the preset has been applied, you can
modify the settings using the Color Board.

Turn iMovie adjustments on or off

When editing a project in iMovie, you can adjust several video attributes, such as exposure,
brightness, and saturation, in the Project Browser. If you import an iMovie project that has these
adjustments into Final Cut Pro, the adjustments are retained and appear in the Color area of the
Video inspector as an iMovie item.
Although you cannot modify the adjustments added in iMovie, you can choose whether they are
applied to the clip or not.
Note:  Video adjustments you make to clips in the iMovie Browser are not retained and do not
appear in Final Cut Pro.
Turn a clip’s iMovie adjustments on or off
mm In the Timeline, select a clip with iMovie adjustments applied, and select or deselect the iMovie
checkbox in the Color area of the Video inspector.
Click here to turn the iMovie
adjustments on or off.

Note:  The iMovie adjustments appear only in the Timeline, not in the Browser.
For more information about importing iMovie projects, see Import from iMovie on page 36.
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Turn log processing on or off

Many modern cameras have a log or wide-dynamic-range recording option that provides more
f-stops of exposure latitude in the image. You can apply log processing to this footage to convert
its appearance to a standard broadcast look. Some cameras embed metadata in the media file
that enables Final Cut Pro to turn on the appropriate log processing setting automatically. Many
cameras do not embed this metadata, and sometimes the metadata may simply be lost if the
material is transcoded. In any case, you can change this setting at any time.
Turn a clip’s log processing on or off
1 Select a clip recorded with the log option.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 In the Info inspector, choose Settings View from the Metadata View pop-up menu.
4 In the Log Processing pop-up menu, choose an option for converting the appearance of your footage:
••

None: Turns off log processing.

••

ARRI Log C: Applies ARRI Log C linearization with a default tone mapping.

••

ARRI Log C (3DLUT): Uses the 3DLUT embedded in the media to apply a custom look.

••

BMD Film: Applies the appropriate linearization for the Blackmagic Cinema Camera and the
Blackmagic Pocket Cinema Camera.

••

BMD Film 4K: Applies the appropriate linearization for the Blackmagic Production Camera 4K.

••

Canon Log: Applies the appropriate linearization for Canon Log.

••

Sony S-Log2: Applies the appropriate linearization and 709(800%) MLUT tone mapping for
footage shot with the S-Log2/S-Gamut setting on Sony cameras such as the F5 and F55.

••

Sony S-Log3: Applies the appropriate linearization and 709(800%) MLUT tone mapping for
footage shot with the S-Log3/S-Gamut3.Cine setting on Sony cameras such as the F5 and F55.

Note:  Final Cut Pro properly displays Apple ProRes media captured with the ARRI ALEXA camera
Log C recording option and imported with Final Cut Pro X 10.0.8 or later. If Log C media was
imported into an earlier version of Final Cut Pro X, Log C processing is disabled by default for
that media.
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Measure video levels
Video scopes overview
Broadcast facilities have limits on the maximum values of luma and chroma that are allowable
for broadcast. If a video program exceeds these limits, distortion can appear in the form of colors
bleeding into one another, the whites and blacks of your program washing out, or the picture
signal bleeding into the audio signal and causing audible distortion. In all these cases, exceeding
standard signal levels can result in unacceptable transmission quality. As you’re color correcting
clips in your project, you can use the Final Cut Pro video scopes to make sure that the luma
and chroma levels of your video stay within the parameters referred to as broadcast-safe, or
acceptable for broadcast.
Even if your project is not intended for broadcast, using the video scopes is an important part
of your workflow. If the monitors you’re using don’t display color accurately or you’ve been
working with the same clips for a while, you can easily get used to seeing a color cast or blacks
that are not quite right. The scopes provide exact measurements of the luma and chroma levels
of your clips so that you can make more informed decisions about adjusting Final Cut Pro color
correction settings.
Final Cut Pro provides the following video scopes:
••

Waveform Monitor

••

Vectorscope

••

Histogram

Use the video scopes
By default, the video scopes appear to the left of the video image in the Viewer and the Event
Viewer. Each viewer displays only one scope at a time.
Open a scope
1 Do one of the following:
••

To open a video scope in the Viewer: Choose Window > Viewer Display > Show Video Scopes (or
press Command-7).

••

To open a video scope in the Event Viewer: Choose Window > Event Viewer Display > Show
Video Scopes.

In either the Viewer or the Event Viewer, you can also choose Show Video Scopes from the
Viewer Options pop-up menu in the top-right corner.
You can use the same commands to close the video scope.
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2 Choose the scope to display from the top section of the Settings pop-up menu.
Choose the scope you
want to use from the
Settings pop-up menu.

Viewer Options
pop-up menu

3 After you choose a scope, choose the display options from the bottom section of the Settings
pop-up menu.
Note:  You may find it convenient to display scopes below the video image in the Event Viewer.
To do so, choose Vertical Layout from the Settings pop-up menu in the Event Viewer. For more
information, see Play back and skim media in the Event Viewer on page 82.

Waveform Monitor display options
The Waveform Monitor shows the relative levels of luma and chroma in the clip currently being
examined. These values are displayed from left to right, mirroring the relative distribution of luma
and chroma levels from left to right in the image. Spikes and dips in the displayed waveforms
correspond to light and dark areas in your picture. The waveforms are also tinted to match the
color of items in the video.
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The Settings pop-up menu in the upper-right corner of the Waveform Monitor provides a variety
of display options:
••

RGB Parade: Presents three side-by-side waveform displays that display your video as three
separate red, green, and blue components. The waveforms are tinted red, green, and blue so
that you can easily identify them.

The RGB Parade view is useful for comparing the relative levels of red, green, and blue
between two clips. If one clip has more blue than another, the Waveform Monitor displays an
elevated blue waveform for the clip with more blue and a depressed blue waveform for the
other clip.
••

RGB Overlay: Combines waveforms for the red, green, and blue color components in
one display.

••

Red: Shows only the red color channel.

••

Green: Shows only the green color channel.

••

Blue: Shows only the blue color channel.

••

Luma: Shows only the luma component of the video.
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••

Chroma: Shows only the chroma component of the video, and is tinted to match the
video’s colors.

••

Y’CbCr Parade: Presents three side-by-side waveform displays for the separate luma, Cb (the
blue color difference channel), and Cr (the red color difference channel) components. The
waveforms are tinted white (for luma), magenta (for Cb), and yellow (for Cr) so that you can
easily identify the waveform for each component.

••

IRE: Displays the video range in IRE units.

••

Millivolts: Displays the video range in millivolts.

••

Guides: Turns the Waveform Monitor’s grid and numeric values on or off.

••

Monochrome: Dims and desaturates the scope display to prevent visual distractions and color
perception issues in your color-finishing suite.

••

Brightness: Sets the relative lightness or darkness of the scope display.
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Vectorscope display options
The Vectorscope shows the distribution of color in your image on a circular scale. The color in
your video is represented by a series of connected points that fall somewhere within this scale.
The angle around the scale represents the hue displayed, with targets indicating the primary
colors of red, green, and blue and the secondary colors of yellow, cyan, and magenta. The
distance from the center of the scale to the outer ring represents the saturation of the color
being displayed. The center of the scale represents zero saturation, and the outer ring represents
maximum saturation.

The Vectorscope shows you, at a glance, the hue and intensity of the various colors in your
image. Once you learn to identify the colors in your clips using the Vectorscope, you can more
easily see where two images differ and correct them so that they match as closely as possible.
The Settings pop-up menu in the upper-right corner of the Vectorscope provides a variety of
display options:
••

100%: Sets the reference chroma level for the color bar targets (the squares representing each
color in a standard color bar test signal) at 100 percent saturated chroma. Use this when your
source media uses 100 percent color bars as its reference.

••

133%: Sets the reference chroma level for the color bar targets at 75 percent saturated chroma.
Use this when your source media uses 75 percent color bars as its reference.

••

Vector: Uses a normal chroma hue reference, with red near the top.

••

Mark3: Uses a 90-degree rotated chroma hue reference, with red on the right side.

••

Show/Hide Skin Tone Indicator: Shows or hides the diagonal line that represents the human skin
tone chroma phase, which is between the yellow and red color bar targets.

••

Monochrome: Dims and desaturates the scope display to prevent visual distractions and color
perception issues in your color-finishing suite.

••

Brightness: Sets the relative lightness or darkness of the scope display.
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Histogram display options
The Histogram provides a statistical analysis of the image by calculating the total number of
pixels of each color or luma level and creating a graph that shows the number of pixels at
each percentage of luma or color. Each increment of the scale from left to right represents a
percentage of luma or color, and the height of each segment of the Histogram graph shows the
number of pixels that correspond to that percentage.
The Settings pop-up menu in the upper-right corner of the Histogram provides a variety of
display options:
••

Luma: Shows only the luma component of the video. The height of the graph at each step on
the scale represents the number of pixels in the image at that percentage of luma, relative to
all the other values. For example, if an image has few highlights, the Histogram shows a large
cluster of values in the midtones.

Using the Luma Histogram view, you can quickly compare the luma of two shots so that you
can adjust their shadows, midtones, and highlights to match more closely.
The shape of the graph also helps you determine the amount of contrast in an image. A
low-contrast image has a concentrated clump of values nearer to the center of the graph. By
comparison, a high-contrast image has a wider distribution of values across the entire width of
the graph.
••

RGB Overlay: Combines waveforms for the red, green, and blue color components in one
display. If the image being examined has equal levels of two or more colors, you see the
combined color:
••

Equal levels of green and blue appear as cyan.

••

Equal levels of green and red appear as yellow.

••

Equal levels of red and blue appear as magenta.
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••

••

Equal levels of red, green, and blue appear as gray.

RGB Parade: Presents three graphs that display your video as separate red, green, and
blue components. The waveforms are tinted red, green, and blue so that you can easily
identify them.

You can use the RGB Parade view to compare the relative distribution of each color channel
across the tonal range of the image. For example, images with a red color cast have either a
significantly stronger red graph or weaker green and blue graphs.
••

Red: Shows only the red color channel.

••

Green: Shows only the green color channel.

••

Blue: Shows only the blue color channel.

••

Brightness: Sets the relative lightness or darkness of the scope display.
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13

Share your project

Sharing projects overview

Final Cut Pro provides a variety of destinations, or preconfigured export settings, that you can
use to output your project or clip. For example, you can export a project or clip as a QuickTime
movie, export it for viewing on Apple devices such as iPhone and iPad, publish it to websites
such as Facebook and YouTube, or burn it to a disc. You can also save a frame from your movie or
export an image sequence. Each of these options uses a different destination.
When you first open Final Cut Pro, a default set of destinations appears in the Share submenu of
the File menu and in the Share pop-up menu.

Details about each destination in the default set are listed in the table below.
Destination

Use to

DVD

Burn your project to a standard-definition (SD) DVD.

Master File (default)

Export your project as a QuickTime movie file.

Apple Devices 720p

Export files for iPhone and iPod.

Apple Devices 1080p

Export files for iPad.

Facebook

Publish your project to your account on any of these
websites.

YouTube
Vimeo
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You can easily add destinations or replace the default set of destinations with your own
customized destinations. For example, if you want to save a frame from your movie as a
Photoshop file, you need to add the Save Current Frame destination to your set and specify that
the destination export a Photoshop file. You create and modify destinations in the Destinations
pane of Final Cut Pro preferences.
You can also create a bundle of destinations to export several types of output at once. For more
information, see Create and modify share destinations on page 403.
The default destination is Master File. You can quickly share to that destination by pressing
Command-E. To change which destination is the default (and will be activated by that keyboard
shortcut), see Create and modify share destinations on page 403.
To further customize your output, you can use Compressor, the professional transcoding
application. For more information, see Export your project using Compressor on page 414.

Share projects, clips, and ranges

You can share an entire project, an entire clip, or a portion of a project or clip (indicated with a
range selection). You share using one of the built-in destinations provided with Final Cut Pro, or
using a custom destination that you create in the Destinations pane of Final Cut Pro preferences.
For more information, see Destinations preferences on page 447.
You can also share a project’s roles, exporting each role as a separate media stem. If you want to
export the same roles from another project or clip later, you can save your settings as a preset.
Because the transcoding required to create the shared file happens in the background, you can
continue working on your projects in Final Cut Pro after sharing. (Keep in mind that changes you
make to a project after the transcoding process begins are not reflected in the output files.)
For information about output formats, see Supported export formats on page 402.
Share a project, clip, or range
1 Do one of the following:
••

Select a project or a clip in the Browser.

••

Select a range in a project in the Timeline or in a clip in the Browser.
Note:  To share just a portion of a project, you must make a range selection. A clip selection is
not sufficient. For example, you can use the I and O keys to set the range start and end points.

2 If you’re sharing a project that is set to use proxy media for playback, open it in the Timeline and
choose Optimized/Original from the Viewer Options pop-up menu in the upper-right corner of
the Viewer.
This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro
uses optimized media to create the shared file. If optimized media doesn’t exist, the original
media is used.
3 Do one of the following:
••

Choose File > Share, and choose a destination from the submenu.

Chapter 13    Share your project

400

••

Click the Share button in the toolbar, and choose a destination.

Important:  If the destination that you want to use doesn’t appear in the menu, you need to
manually add it to your set of destinations. See Destinations preferences on page 447.
4 In the Share window that appears, do any of the following:
Move the pointer over the
image to skim the video.

Project
attributes

File
information

••

Move the pointer over the image to skim the video.

••

In the Info pane on the right, view and modify project or clip attributes, such as the title
and description.
For more information, see Modify share attributes on page 409. All of the attributes associated
with the project or clip are included in the output file.
Important:  By default, the title field lists the project or clip name. Changing the title does not
change the project or clip name, which is the name used for the exported file.

••

At the bottom of the window, view information about the file that will be exported, including
frame size and frame rate, audio channels and sample rate, duration, output file type, and
file size.
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For some destinations, you can also view a list of devices that will play the exported file.
To view the compatible devices, move the pointer over the Compatibility icon in the
lower-right corner.

Move the pointer
over the icon to view
compatible devices.

5 To view the destination’s settings, click Settings.
The settings for the destination are displayed in the Settings pane. If necessary, modify the
destination’s settings.
Note:  If you change the destination’s settings, the changes are saved as the default settings for
the destination. For more information, see Destinations preferences on page 447.
6 Click Share or Next.
The button you see changes depending on the destination you chose. If you click Next, follow
the instructions to complete the sharing process.
You can monitor the progress of the transcode in the Background Tasks window, and you can
continue to work in Final Cut Pro while the file is transcoded.
When transcoding is complete, a notification appears. You can view and locate shared projects in
the Share inspector. For more information, see View the status of shared projects on page 415.
Note:  If you added chapter markers to your project, chapter marker thumbnails are placed at the
appropriate location when sharing to disc (DVD and Blu-ray disc) and MV4, QuickTime, and MP4
formats (for playback using iTunes, QuickTime Player, and Apple devices). For more information,
see Manage chapter markers and their thumbnail images on page 152.

Supported export formats

You can export to a number of formats natively using the Master File share destination. For
information about exporting, see Share projects, clips, and ranges on page 400. You can export
to additional formats using settings in Compressor. For more information, see Export your project
using Compressor on page 414.
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Master File destination
You can export to the following formats using the Master File share destination:
••

Apple Intermediate Codec

••

Apple ProRes (all versions)

••

DV (including DVCAM, DVCPRO, and DVCPRO50)

••

DVCPRO HD

••

H.264

••

HDV

••

MPEG IMX (D-10)

••

Uncompressed 10-bit 4:2:2

••

Uncompressed 8-bit 4:2:2

••

XDCAM HD/EX/HD422

Compressor setting
You can export to the following formats using a Compressor setting:
••

Apple Animation codec

••

AVC-Intra (requires a third-party plug-in)

••

QuickTime formats

Note:  Depending on the format of your source media files, some of the export formats listed
above may not be available.

Create and modify share destinations

In the Destinations pane of the Final Cut Pro Preferences window, you can modify existing
destinations, add new destinations, delete destinations, and create destination bundles, which
allow you to export multiple types of output at once. You can also revert to the default set of
destinations that were available when you first opened Final Cut Pro.
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For information about sharing projects and clips from Final Cut Pro, see Sharing projects
overview on page 399.
Create a new destination
1 Do one of the following:
••

Choose File > Share > Add Destination.

••

Choose Final Cut Pro > Preferences, click the Destinations button at the top of the window,
and, if necessary, select Add Destination in the Destinations list on the left.

••

Select a clip or project, click the Share button in the toolbar, and choose Add Destination from
the pop-up menu.

2 In the Destinations pane of the Preferences window, do one of the following:
••

Drag a destination from the area on the right to the Destinations list on the left (or doubleclick a destination on the right).
Destinations list

••

Drag a destination
to the Destinations list.

Control-click a destination in the Destinations list and choose Duplicate from the
shortcut menu.

The new destination appears selected in the list on the left, and the settings for the destination
appear on the right.

Chapter 13    Share your project

404

3 Choose the settings you want for the new destination.
New destination

Modify the settings for
the new destination.

For descriptions of the controls in each destination, see Destinations preferences on page 447.
Here are some tips for setting up various types of destinations:
••

If you chose a web destination: Enter your user name and password in the window that appears,
and click OK. Depending on the destination you’re setting up, you may need to verify your
account or your device. To do so, follow the onscreen instructions.
If you select the “Remember this password in my keychain” checkbox, your user name and
password are saved so that you don’t have to enter your password every time you share to
the destination.

••

If you chose the Compressor Settings destination: Select a Compressor setting in the window that
appears, and click OK. The settings that are displayed include the Compressor settings that
come with Final Cut Pro as well as any settings you added.
Important:  You can use the Compressor Settings destination only if you have Compressor
installed or someone gives you a Compressor setting.

You can adjust the destination at any time. For example, you can type a new name or use the
controls on the right to change the destination settings. As you customize the destination, your
changes are saved automatically.
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Modify existing destinations
Note:  You can also modify an existing destination’s settings while you’re sharing a project or clip.
For more information, see Share projects, clips, and ranges on page 400.
1 Choose Final Cut Pro > Preferences, and click Destinations.
The Destinations pane appears, with a list of destinations on the left.
2 Do any of the following:
••

To change a destination’s settings: Select a destination, and modify the destination’s settings on
the right.
Select a destination
in the Destinations list.

••

Modify the settings for
the selected destination.

To use a different web account: Select a web destination and click the Details button to the right
of the account name. In the window that appears, enter a new account name and password,
and click OK. Follow the onscreen instructions to verify your identity and enable your device,
and click Done.
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To have multiple accounts available for the same web destination, create additional instances
of the web destination, enter the other account name and password, and click OK.

••

To restore a destination to its original settings: Control-click a destination in the Destinations list
and choose Revert to Original Settings from the shortcut menu.
The destination’s settings are restored to their original values and the settings are
saved automatically.

••

To rename a destination: Double-click a destination in the list on the left and type a new name.

••

To change the order of destinations in the list: Drag a destination to a different location in the
Destinations list.

For descriptions of the controls in each destination, see Destinations preferences on page 447.
As you modify destinations, your changes are saved automatically.
Create a bundle of destinations
Bundles make it easy to create several types of output in a single step. A bundle holds a set of
destinations. When you share a project or clip using the bundle, a file for each destination in the
bundle is output automatically.
1 In the Destinations pane of the Preferences window, select Add Destination in the Destinations
list and then double-click the Bundle destination (or drag it from the area on the right to the
Destinations list on the left).
An empty bundle appears in the Destinations list.
2 To add destinations to the bundle, drag existing destinations into it from the Destinations list, or
select Add Destination and drag destinations from the area on the right into the bundle.
Tip:  To quickly make a bundle from destinations in the Destinations list, select one or more
destinations in the Destinations list, Control-click in the Destinations list, and choose New Bundle
from Selection from the shortcut menu.
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Delete a destination
Do one of the following:
mm Control-click a destination in the Destinations list, and choose Delete from the shortcut menu.
mm Select a destination in the Destinations list, and press Delete.
mm Select a destination in the Destinations list, and click the Remove (–) button below the list.
Assign a default destination
After you set the default destination, you can quickly share to that destination by pressing
Command-E. If a clip in the Browser is selected, that clip will be shared; if the Timeline is active,
the project will be shared. By default, this shortcut is assigned to the Master File destination. You
can change this so that keyboard shortcut will share to any destination (or destination bundle) of
your choice.
mm Control-click the destination or bundle you want to make the default, and choose Make Default
from the shortcut menu.
The name of the new default destination is appended with “(default).”
Revert to the default set of destinations that came with Final Cut Pro
mm Control-click in the Destinations list and choose Restore Default Destinations from the
shortcut menu.
Any custom destinations are deleted, and the default set of destinations appears. For a list of the
default destinations, see Sharing projects overview on page 399.
Share destinations between Final Cut Pro users
mm To export destinations from your copy of Final Cut Pro: Drag one or more destinations from the
Destinations list in the Destinations pane of Final Cut Pro preferences to a location in the Finder.
The destination file is appended with the .fcpxdest extension.
mm To import destinations into your copy of Final Cut Pro: Drag a destination file from a location in the
Finder to the Destinations list.
The destination you added appears in the Destinations list, the Share submenu of the File menu,
and the pop-up menu that appears when you click the Share button in the toolbar.
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Modify share attributes

Share attributes are project and clip metadata that is included with exported files. You can view
and modify share attributes in the Share inspector.

Attribute fields

Show and modify share attributes for a clip or project
1 Select a clip or project.
2 To open the Share inspector, click the Inspector button in the toolbar (shown below), and click
the Share button at the top of the pane that appears.

3 If the attributes for the selection aren’t shown, move the pointer over Attributes and click Show.

Click Show.

4 Type new text in an attribute field.
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If you type a word or phrase that has been defined as an attribute, the attribute (a word or
phrase in a blue bubble) appears after you finish typing.

Attribute fields

Modify the attribute fields that are displayed in the Share inspector
1 Select a clip or project.
2 Open the Share inspector.
The Share inspector contains a pop-up menu you can use to customize attribute fields.

Click to view options
for customizing
attribute fields.

3 Using the Attributes pop-up menu, do any of the following:
••

To add an attribute field: Choose the field name (so that there’s a checkmark next to it).

Chapter 13    Share your project

410

Fields with a checkmark are shown in the Share inspector and exported with your clip or project.

Fields that are shown
in the Share inspector
have a checkmark.

••

To remove an attribute field: Choose the field name (so that there’s no checkmark next to it).

••

To show only the Final Cut Pro default attribute fields: Choose Show Default Fields.
Choosing this option displays only the Title, Description, Creator, and Tags fields.
Important:  The default fields cannot be removed.

••

To save the selected attribute fields as your default set: Choose Save as Default.

••

To display your default set of attribute fields: Choose Update to Default.

Modify attributes automatically displayed in a Share inspector field
You can set the attributes that appear automatically in an attribute field.
1 In the Share inspector, choose Edit Share Fields from the Attributes pop-up menu.
2 In the Edit Share Fields window, select an attribute field from the list on the left.
The attributes assigned to the selected field appear in the Format field.
Select an attribute field.

Format field

Options for the field appear
in the middle of the window.
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3 To edit the selected attribute field, do any of the following:
••

To add an attribute: Drag an attribute (a word or phrase in a blue bubble) from the middle of
the window to the Format field. You can also type the attribute name in the field.

••

To add text: Type a word or phrase in the Format field at the top of the window.

••

To create a custom name attribute: Enter a word or phrase in the Custom Name field at the
bottom of the window, and drag the Custom Name attribute to the Format field.
Tip:  Because the custom name attribute appears in the Format field as “Custom Name,” you
can use it for long phrases or sentences and still easily view the other attributes and text in the
Format field.

••

To remove an attribute or text: Select the attribute or text and press Delete.

As you add and remove attributes, the example (below the Format field) shows your changes.
4 When you’re done, click OK.

Share roles as files

You can share a project’s roles, exporting each role as a separate media stem. If you want to
export the same roles from another project or clip later, you can save your settings as a preset.
Share roles as separate files
You can export one or more of a project’s or clip’s roles as media stems. For example, you can
export a project’s dialogue, music, and sound effects as separate media files by assigning roles
to the dialogue, music, and sound effects, and then exporting the roles. You can export roles as a
combined, multitrack QuickTime file or as separate audio or video files, and you can assign mono,
stereo, or surround output for your audio channels. For more information, see Roles overview on
page 318.
1 Do one of the following:
••

Select a project or a clip in the Browser.

••

Select a range in a project in the Timeline or in a clip in the Browser.

2 Choose File > Share > Master File (or click the Share button in the toolbar and choose Master File).
Note:  You can also choose another destination you created based on the Master File or Export
File destination.
3 Click the Settings button, and then specify the following settings (available settings depend on
your source media):
••

Format: Choose a mastering format (Video and Audio, Video Only, or Audio Only).

••

Video codec: The source codec is listed by default. Depending on your source media, you can
choose another codec.

••

Resolution: The resolution (based on the source footage) is provided. Depending on your
source media, you can choose another resolution.

••

Audio file format: The source format is listed by default. Depending on your source media, you
can choose another audio format.

••

Include chapter markers: Select the checkbox to include chapter markers with the exported file
(or files).

••

Open with: Choose what you want to happen after the export is complete.

4 In the “Roles as” pop-up menu, choose how you want the roles exported.
Note:  The options available in this pop-up menu change based on your choices in the Format
and “Audio file format” pop-up menus.
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••

QuickTime Movie: Exports all of the roles in the project as a single QuickTime movie.
If you choose this option, skip step 5.

••

Multitrack QuickTime Movie: Exports the roles you specify as a single QuickTime movie.

••

Separate Files: Exports each of the video and audio roles you specify as a separate file.

••

Video Only as Separate Files: Exports each of the video roles you specify as a separate file.

••

Audio Only as Separate Files: Exports each of the audio roles you specify as a separate file.

5 If you want to add or remove roles, do any of the following:
••

To add a role to the export files: Click the Add Video File or the Add Audio File button, and
choose a role from the pop-up menu that appears.
If you’re adding an audio role, you can also choose the channel format for the role (Mono,
Stereo, or Surround). For more information, see Configure audio channels on page 171.

••

To remove a role from the export files: Move the pointer over the role you want to remove, and
click the Remove (–) button that appears to the right of the pop-up menu.

These roles will be exported.

6 Click Next, enter file information in the window that appears, and click Save.
You can monitor the progress of the transcode in the Background Tasks window, and you can
continue to work in Final Cut Pro while the file is transcoded.
When transcoding is complete, a notification appears. You can view and locate shared projects in
the Share inspector. For more information, see View the status of shared projects on page 415.
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Create and modify custom presets
If you’ve created a customized list of roles to share, you can save it as a preset.
1 Configure your share options using the instructions in “Share roles as separate files,” above.
2 In the “Roles as” pop-up menu, do any of the following:
••

To save a new preset: Choose Save As, type a name for the preset, and click Save.

••

To save changes to an existing preset: Select the preset and make your changes, and then
choose Save.

••

To save a modified preset as a new preset: Select the preset and make your changes, and then
choose Save As, type a name for the preset, and click Save.

••

To rename a preset: Select the preset, choose Rename, type a new name for the preset, and
click Save.

Custom presets that you create appear in the “Roles as” pop-up menu.
Custom presets are stored in /Users/username/Library/Application Support/ProApps/Export
Presets/. To access them quickly, choose Reveal User Presets in Finder from the “Roles as”
pop-up menu.
Delete custom presets
You can delete custom presets that you no longer need.
1 Select a project or clip, and then click the Share button in the toolbar and choose Master File.
2 In the Share window, click the Settings button, and in the “Roles as” pop-up menu, choose the
custom preset that you want to delete.
The custom presets are listed in the pop-up menu.
After you choose a preset, a checkmark appears next to its name.
3 In the “Roles as” pop-up menu, choose Delete.

Export your project using Compressor

The destinations available in Final Cut Pro provide many options for exporting projects and clips.
If you need more options, you can use Compressor, the professional transcoding application
designed to work directly with Final Cut Pro, to create highly customized export settings. For
example, you can use the Compressor frame resizing and retiming controls to make high-quality
frame size and frame rate adjustments in your output files.
Important:  To export using Compressor, you must have Compressor 4.1 installed. Compressor 4.1
must be purchased separately.
Send your project to Compressor
1 Select a project or a clip in the Browser, or a range in a project or a clip.
2 Choose File > Send to Compressor.
Note:  The Send to Compressor command is dimmed if Compressor is not installed on the same
computer as Final Cut Pro.
Compressor opens with a new batch that contains a job with the project’s or clip’s media file.
3 Configure the job by clicking Add Outputs and following the instructions, then click Start Batch.
For more information about configuring jobs and settings, see Compressor Help at
http://help.apple.com/compressor.
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View the status of shared projects

The Share inspector displays when and where a project or clip was shared. If you share your
project or clip to a web destination, you can also use the Share inspector to go to the website
where the video was shared, send an email that includes the URL where the video was shared,
or remove the video from the sharing site. If you share your project or clip using the Master File
destination (or any custom destinations you make based on the Master File destination), you can
locate the shared file in the Finder.

Click to open the shared
item’s pop-up menu.
View the exported file
in the Finder.

Open the Share inspector
1 In the Libraries list, select the event that contains the shared clip or project you want to inspect.
2 In the Browser, select the shared clip or project you want to inspect.
3 To open the Share inspector, click the Inspector button in the toolbar (shown below), and click
the Share button at the top of the pane that appears.

A summary of the project’s or clip’s information appears at the top of the window, share
attributes appear in the middle, and information about where the project or clip has been shared
appears at the bottom.

Summary

Attributes

Where the clip
has been shared
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You can do any of the following in the Share inspector:
••

Click the magnifying glass icon to reveal the exported files in the Finder.

••

Click the shared item’s pop-up menu to access more options, such as visiting the shared item’s
website or emailing a link to a friend.

Visit the website where a project or clip has been shared
mm In the Share inspector, choose Visit from the shared item’s pop-up menu.
Note:  Not all shared items have a pop-up menu.
Create an email to announce that a project or clip was shared to a website
1 In the Share inspector, choose Tell a Friend from the shared item’s pop-up menu.
2 In Mail, complete the email that was created and click Send.
The email includes a link to the website where the project or clip was shared.
Locate a shared project or clip in the Finder
In the Share inspector, do one of the following:
mm If the project or clip has been shared once and only one shared item is displayed: Click the
magnifying glass icon.
mm If the project or clip has been shared two or more times: Click Show to view the shared items, and
click the magnifying glass icon for the item you want to locate.
For more information about shared files, see Locate source media files on page 421.
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Manage media, libraries, and archives

14

Media management overview

Final Cut Pro provides you with flexible and powerful tools to manage your media files.
The first time you open Final Cut Pro, it automatically creates a library file in the Movies folder.
You can import media into the library file or have Final Cut Pro access media files in other
locations. The Final Cut Pro library database tracks your edit decisions, the associated metadata,
and all your events, projects, and clips (as well as any optimized or rendered media files). The
library database also keeps track of all your source media files (video files, audio files, or stillimage files), whether they are stored in the Final Cut Pro library file or in other locations. As
your library grows, you can rename, copy, move, and delete your clips, events, and projects
as necessary.

You can use multiple libraries and events to organize media and projects to suit your workflow.
For example, copying or moving events is useful if you want to work on a project using another
Mac that has Final Cut Pro installed, or if you want to free up space on your computer’s hard
disk. Use other media management tools such as the Consolidate command for backups and
managing shared storage.
The following are some common media management tasks:
••

Transcoding your source media files to optimized or proxy formats that are high quality and
easy to work with. See Manage optimized and proxy media files on page 425.

••

Backing up your work. See Back up projects, events, and libraries on page 425.

••

Consolidating source media files in one location. See Consolidate projects, events, and
libraries on page 424.

••

Locating source media files. See Locate source media files on page 421.

••

Relinking clips to media files. See Relink clips to media files on page 421.
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••

Managing multiple libraries, including copying and moving items between libraries. See
Managing libraries overview on page 431.

••

Creating camera archives to save the contents of your camera or camcorder as readily
available backups on any computer. See Create and manage camera archives on page 435.

Importing media from cameras, an external storage disk, or another device is also generally
considered a form of media management. See Importing overview on page 23.

Update your projects and events to Final Cut Pro 10.1

Final Cut Pro 10.1 includes some fundamental changes that will accelerate all of your future work.
In Final Cut Pro 10.1, events and projects are organized within libraries (for more information,
see What are libraries? on page 18). To work with projects and events created in earlier versions
of Final Cut Pro X, you must update them to version 10.1. You can update existing projects and
events when you first open Final Cut Pro 10.1, or you can update them later.
For more information, go to Final Cut Pro X 10.1: Frequently Asked Questions About Libraries at
http://support.apple.com/kb/HT5958.
Important:  It’s a good idea to make a backup copy of your files before permanently updating
them to the new format. After your projects and events are updated to Final Cut Pro 10.1, they
cannot be used with earlier versions of Final Cut Pro. Backing up your current copy of the Final
Cut Pro application will allow you to move your files to another Mac and continue working
on these projects as needed using version 10.0.9 of Final Cut Pro. For more information about
backing up your files and the Final Cut Pro application, go to “Final Cut Pro X 10.1: How to back
up important files before updating” at http://support.apple.com/kb/HT5550 and the Final Cut Pro
Support webpage at http://www.apple.com/support/finalcutpro.
When updating projects and events, Final Cut Pro does the following:
••

For each connected volume that contains folders named Final Cut Projects or Final Cut Events,
Final Cut Pro creates a new library named with the volume name. Existing projects and events
are moved into the new library.

••

Collects all projects on each connected volume in a new event named Updated Projects, and
places this event in the newly created library for that volume.

••

Creates keywords for project folders. If you had project folders in the Project Library before
updating, the names of the project folders are assigned as keywords to the projects that were
in those folders.

••

Copies any existing compound clips or multicam clips on other volumes into the current
library. This makes the new library self-contained.

••

Creates a folder called Final Cut External Media on each volume that contains event media
linked to an event or project on another volume. After updating, you can use the Consolidate
command to copy the linked media to the same volume as the linking event.

••

Asks if you want to move the old project and event files to the Trash after the update is
complete. If you choose to move them to the Trash and need to go back to them for any
reason, you can restore them to their original location using the File > Put Back command
in the Finder. However, after the Trash is emptied, the deleted project and event files cannot
be restored.
Note:  Media files are never moved to the Trash or deleted.
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Select options for updating projects and events
If you have any existing projects and events in Final Cut Pro, you are presented with options for
updating them when you open Final Cut Pro 10.1 for the first time.
In the window that appears, choose one of the following options:
mm Update All: Click Update All to allow Final Cut Pro to organize your existing projects and events
into libraries. This is the simplest option. The projects and events on each volume are combined
into a single library for that volume. After the update, you may want to organize your libraries
and events to suit your particular workflow. For more information, see Organizing libraries
overview on page 56.
mm Update Later: If you’re not sure what to do, you can defer the update. When you choose this
option, a new library is created. You can immediately start using Final Cut Pro 10.1 to create new
events and projects. You can always update your existing events and projects later, by choosing
File > Update Projects and Events.
mm Locate: If you’ve been using SAN locations on an Xsan volume, you can click Locate to navigate
to and then update SAN location folders. You can select a volume, a SAN location, or any folder
containing a Final Cut Projects or Final Cut Events folder, and update it. This creates a new library
next to the folder where the original projects and events were located. This manual update can
be done at any time; for example, a SAN location may not be connected when you first open
Final Cut Pro 10.1.
During the update process, Final Cut Pro asks whether you want to move the old versions of
your updated projects and events to the Trash. If you do this and then later need the old projects
for any reason (for example, if you have multiple users on your system who have not updated),
you can restore the files to their original location by opening the Trash, selecting the files, and
choosing File > Put Back. However, after the Trash is emptied, the deleted projects and events
cannot be restored.
Note:  The Put Back command cannot be used for SAN locations.
Manually update projects and events
There are a few scenarios where you’ll need to update events and projects after the initial
update, including:
••

Events and projects on volumes that weren’t connected during the initial update, or events
and projects in SAN locations

••

Events and projects that were not stored on the root level of the connected volumes

••

Projects, events, or sets of events that were offline when using Intelligent Assistance’s Event
Manager X application

••

All projects and events, if you clicked Update Later when first presented with update options

You can update these projects and events at any time.
1 If necessary, connect the volumes that contain the projects and events you want to update, and
then open Final Cut Pro.
2 Choose File > Update Projects and Events.
3 When the update window appears, click one of the update options described in “Select options
for updating projects and events,” above.
You can rename libraries and drag events between libraries. You can also create new libraries
from a collection of events. For more information, see Create a new library on page 432 and Copy
or move items between libraries and hard disks on page 432.
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During the update process, Final Cut Pro does not automatically copy your media across volumes
(in order to avoid unnecessary copies). Therefore consolidating the source media files for each
library at a logical location on your hard disks or network is a great starting point after updating.
For more information, see Consolidate projects, events, and libraries on page 424.

Manage your media files
View a clip’s information
The Info inspector provides a summary of a clip’s information. Here you can view status
information about a clip’s source media file, including the file’s location, available media
representations for the file, the event the clip is located in, and the event the clip references.

View a clip’s information
1 Select a clip in the Browser or Timeline.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 In the Info inspector, scroll down until you see the File Information section.
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For information about using optimized or proxy media for playback, see Control playback quality
and performance on page 85. For more general information about optimized and proxy media,
see Manage optimized and proxy media files on page 425.

Locate source media files
You can locate the source media file (on the hard disk) for any clip in your library.
Locate the source media file for an event clip
1 If you don’t see the Libraries list, click the button at the bottom-left corner of the Browser.

2 In the Libraries list, select the event that contains the clip.
3 Select the clip in the Browser.
4 Choose File > Reveal in Finder (or press Shift-Command-R).
A Finder window opens, with the source media file selected.
You can also quickly find the source event clip for any clip in the Timeline. For more information,
see Find a Timeline clip’s source clip on page 116.

Relink clips to media files
In Final Cut Pro, clips represent your media, but they are not the media files themselves.
Final Cut Pro keeps track of the links between clips and media files automatically. However, there
are times when you need to manually relink clips to media files.
One common scenario that requires relinking is when files are altered or re-created outside of
your copy of Final Cut Pro. For example, if you send files out for color correction, you may need to
relink the clips in your event to the color-corrected versions of the files when you receive them.
Another case requiring manual relinking is missing media files. For example, if you move or
rename externally linked files in the Finder, or you move an event or a project to a different
location, you need to relink the event or project clips (which appear as red frames with yellow
alert triangles) to the files.
In either case, manually relinking connects the clips in Final Cut Pro to the correct files on your
hard disk. Metadata in the relinked clips remains unchanged.
The new (relinked) files can have a different resolution and codec than the original files, but
they must be the same media type. (In other words, you can’t relink a video clip to an audio file.)
Relinked files must also have the same frame rate and similar audio channels as the original files.
The new (relinked) files can also be trimmed versions of the original files, but they must be long
enough to cover all the clips that refer to the files.
When you relink clips to media files on your hard disk, all instances of the clips in the current
library (including those in other projects or events) are updated to link to the new media files. In
other words, if you used a clip in multiple projects or events, each of those projects and events is
relinked to the new media file.
Note:  You cannot undo the Relink Files command.
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Relink clips to media files
1 Do one of the following:
••

In the Browser or the Timeline, select the clips or the projects containing the clips you want
to relink.

••

In the Libraries list, select an event or an entire library containing the clips you want to relink.

••

In the Timeline, select the clips you want to relink.

2 Choose File > Relink Files.
The Relink Files window appears. By default, this window shows missing clips or events only.
3 If you want to show all items in the selection, select All.

4 Do one of the following:
••

To locate all the matching files: Click Locate All.

••

To locate some of the matching files: Select items in the list and click Locate Selected.

5 In the window that appears, navigate to one of the files you want to link to, or to the folder that
contains it.
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Text at the bottom of the window indicates how many potential matches to items in your
original list were found (based on the filenames only).

Text indicates how many
matches were found.

Note:  Final Cut Pro identifies matches based on proximity in the directory structure and related
filenames. For example, if your original files were in two adjacent folders, Final Cut Pro looks in
folders adjacent to the folder containing the file you chose and relinks all matching files in the
relative path. If your original files were named “File1,” “File2,” “File3,” and so on, and you chose to
relink to a file named “File1_A,” Final Cut Pro looks for files named “File2_A,” “File3_A,” and so on
to relink the remaining items in your list.
6 Click Choose.
Final Cut Pro analyzes the files to confirm that all attributes (in addition to the filename) match
items in the original selection. Analysis results are shown below the Original Files list (for
example, “3 of 3 files matched”).
7 Click the disclosure triangle next to the analysis results to show a list of old files (on the left) and
the new matching files (on the right).

If a file was matched incorrectly, select it in the list and press Delete. The item is placed back in
the original list at the top of the Relink Files window.
Items with no matches remain in the original list above. You can continue to locate those by
selecting them and repeating steps 4 through 6.
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8 To link the event clips to the new media files, click Relink Files.
All matched clips (including those in other projects or events) are updated to link to the new
media files.

Consolidate projects, events, and libraries
In the course of creating a project, you might use media files from a variety of locations,
including your local computer and external storage devices. If the media used in a project, an
event, or a library is located in multiple folders or on multiple hard disks, you can consolidate all
the media in one location (on one storage device). This process facilitates archiving and makes it
easier for others to access the media (using shared storage, for example).
The consolidate command places the files in the current library storage location. You view and
set storage locations for media, cache files, and library backup files using the Library Properties
inspector. For more information, see Manage storage locations on page 434.
The Consolidate command follows these rules:
••

When you consolidate files out of a library to an external folder, the files are moved.

••

When you consolidate files into a library from an external folder, or from an external folder to
another external folder, the files are copied.

These rules prevent broken links from other libraries.
Note:  If the media is already external, and no other libraries are using it, you can manually delete
the original media after consolidating to save storage space.
Collect the source media files for a library, an event, or a project in one location
1 If you don’t see the Libraries list, click the button at the bottom-left corner of the Browser.

2 To select files to consolidate, do one of the following:
••

Select a library in the Libraries list.

••

Select one or more events in the Libraries list.

••

Select an event in the Libraries list, and then select one or more projects in the Browser.

3 Choose File > Consolidate [item].
4 In the window that appears, confirm the library to consolidate the files into.
5 If you want to include optimized and proxy media, select the checkboxes in the window
that appears.
6 Click OK.
Final Cut Pro copies the media into the current library storage location. To view or change library
storage locations, see Manage storage locations on page 434.
If a message appears stating that there is nothing to consolidate, all of your media files are
already consolidated at one location, on one storage device.
Note:  If you have customized any Final Cut Pro effects, transitions, titles, generators, or themes,
you must manually back up and move the Motion Templates folder located in your Movies
folder. Similarly, you must manually track and move any third-party effects, because they are not
managed within the Final Cut Pro library.
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Back up projects, events, and libraries
Backing up your work and your media consistently is an essential part of your workflow. Some
people back up daily or weekly; others back up when a project is complete. To protect your
media, it’s recommended that you back up to a storage device or partition different from the one
where you store the media files used with Final Cut Pro.
Final Cut Pro provides both automatic and manual tools that let you:
••

Back up projects, events, and libraries manually. See Copy or move items between libraries and
hard disks on page 432.

••

Enable automatic backups of the database portion of Final Cut Pro libraries. See Restore a
library from automatic backups on page 76 and Manage storage locations on page 434.

••

Back up projects by duplicating them as snapshots. See Duplicate projects and clips on
page 64.

••

Collect the source media files for a library, event, or project in one location. See Consolidate
projects, events, and libraries on page 424.

Important:  When you import media into Final Cut Pro, you can select the “Leave files in place”
option to link to the files in their current location rather than copy them into the library. In that
case, Final Cut Pro creates symbolic links (also known as symlinks), which are special files that
point to the media files. When you copy or move clips between events, Final Cut Pro copies or
moves the symbolic links only (not the source media files). To replace the symbolic links with the
actual source media files, select the events and choose File > Consolidate Event Files. For more
information about files and clips, see Media files and clips on page 22.
Note:  If you have customized any Final Cut Pro effects, transitions, titles, generators, or themes,
you must manually back up and move the Motion Templates folder located in your Movies
folder. Similarly, you must manually track and move any third-party effects, because they are not
managed within the Final Cut Pro library.

Manage optimized and proxy media files
Final Cut Pro can play back many media formats. For a complete list, see Supported media
formats on page 46. Final Cut Pro also provides options for transcoding your media (converting it
to a different format or changing its settings) to make it suitable for editing.
••

Create optimized media: This option transcodes video to the Apple ProRes 422 codec format,
which provides better performance during editing, faster render times, and better color quality
for compositing. If the original camera format can be edited with good performance, this
option is dimmed.

••

Create proxy media: This option creates video and still-image proxy files. Video is transcoded to
the Apple ProRes 422 Proxy codec format, which provides high-quality files useful for offline
editing at the original frame size, frame rate, and aspect ratio. Final Cut Pro creates mediumquality (one-half resolution) proxy versions that increase editing performance. Video proxy
files often take up considerably less storage space than optimized files, which can allow you to
work on a portable computer instead of a desktop computer with significantly more memory
and processing power. Still images are transcoded to either JPEG (if the original file doesn’t
have alpha channel information) or PNG files (if the file has alpha channel information).
Still-image proxy files facilitate faster processing and rendering when the original image is
very large.
Note:  For better import and playback performance, Final Cut Pro automatically transcodes
all MP3 audio files to WAV audio files. When transcoding files, Final Cut Pro always retains the
original media for future use.
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You can create optimized and proxy media during the import process or in the Browser, after the
media has been imported. You can also create a proxy file for a clip using the Info inspector. After
transcoding is complete, the optimized and proxy files are stored in your Final Cut Pro library or
in an external location you define in the Library inspector. For more information, see Manage
storage locations on page 434.
To control whether Final Cut Pro displays optimized, proxy, or original media in the Viewer, and
whether video playback is optimized for quality or performance, choose the corresponding
options from the Viewer Options pop-up menu in the upper-right corner of the Viewer. For more
information, see Control playback quality and performance on page 85.
Important:  If you use proxy media for playback, make sure to switch back to optimized/original
media before sharing your project. This ensures the highest quality in the exported file. For more
information, see Share projects, clips, and ranges on page 400.
Create optimized and proxy files during import
During import, Final Cut Pro either creates an alias file that points to the media file in its original
location, or creates a copy of the original media file. After the files are imported, transcoding,
optimization, and analysis are performed in the background.
1 Do one of the following:
••

To import a file from a compatible file-based recording or storage device, or from your computer:
Connect your device to your computer, turn it on, choose File > Import > Media (or press
Command-I), navigate to and select the media you want to import, and click Import.

••

To import a file from a tape-based camcorder: Connect your device to your computer, turn
on the device, and set it to VTR or VCR mode. Then choose File > Import > Media, and
click Import.

••

To import from an archive: Choose File > Import > Media. Select a camera archive from the list
on the left, click Open Archive and navigate to the files you want to import, and click Import.

For more information, see Importing overview on page 23.
2 In the window that appears, choose how you want to organize the imported media in your
library:
••

To add the imported media to an existing event: Select “Add to existing event,” and choose the
event from the pop-up menu.

••

To create a new event: Select “Create new event in,” use the pop-up menu to choose the library
in which you want to create the event, and then type a name (for example, “Chris and Kim
Wedding”) in the text field.

To learn more about events, see Organizing libraries overview on page 56.
3 Choose a storage location for the media files:
••

To copy the files to the current library: Select “Copy to library” to duplicate the files and place the
copies in the current library storage location. You can set storage locations for each of your
libraries using the Library Properties inspector. For more information, see Manage storage
locations on page 434.

••

To link to the files at their current location: Select “Leave files in place.”
Note:  If you select this option, Final Cut Pro creates symbolic links (also known as symlinks),
which are special files that point to the media files. If you later copy or move clips between
events, Final Cut Pro copies or moves the symbolic links only (not the source media files). To
replace the symbolic links with the actual source media files, select the events and choose
File > Consolidate Event Files. For more information about files and clips, see Media files and
clips on page 22.
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4 Select one or both of the transcoding options.
Final Cut Pro will transcode the files in the background, after the import process is complete.
5 Click Import.
The import may take a while, depending on the option you selected in step 3. You can see the
status of all the background processes currently running in the Background Tasks window.
Create optimized and proxy files after import
1 Control-click one or more clips in the Browser and choose Transcode Media from the
shortcut menu.
2 In the window that appears, select the “Create optimized media” checkbox, the “Create proxy
media” checkbox, or both, and click OK.
Note:  If the original camera format can be edited with good performance, the “Create optimized
media” option is dimmed.
The transcoding process may take a while, depending on the options you select. You can see the
status of all the background processes currently running in the Background Tasks window.
Note:  MP3 audio files from projects created with versions of Final Cut Pro earlier than 10.0.4 can
be manually transcoded to WAV audio files using this process.
Create optimized and proxy files when importing by dragging
When you drag media from the Finder into an event or the Timeline in Final Cut Pro, it is
automatically organized, transcoded, and analyzed based on the import settings that you specify
in Final Cut Pro preferences.
1 To specify import settings, choose Final Cut Pro > Preferences, click Import, and select the import
settings you want to apply to your media.
For detailed information about import settings, see Import preferences on page 444.
2 To import one or more files, select a file (or Command-click multiple files) in the Finder and drag
the selection to the Timeline or to an event in the Libraries list.
Generate a proxy file from the Info inspector
You can create a proxy file for a clip using the Info inspector. You can check to see whether a
proxy file exists for a clip by viewing the clip’s information in the Info inspector. If the file you’re
viewing in the Info inspector doesn’t have a proxy file, you see a red triangle.

If a proxy has not been
created for a clip, a red
triangle is shown.
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1 Select a clip in the Browser.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 Scroll down to the File Information section of the Info inspector, and click the Generate
Proxy button.

The proxy file is created, and a green circle appears next to the proxy item in the Available Media
Representations section, indicating that the proxy file for the clip is available.
To control whether Final Cut Pro displays the proxy media in the Viewer, choose an option from
the Viewer Options pop-up menu in the upper-right corner of the Viewer. For more information,
see Control playback quality and performance on page 85.
Delete optimized or proxy files
You can delete optimized or proxy media files at any time, no matter where they are stored.
Original media files are not deleted, so you can always regenerate optimized and proxy files from
the original media.
1 Do one of the following:
••

To delete optimized or proxy files for one or more projects: In the Browser, select one or
more projects.

••

To delete optimized or proxy files for one or more events: In the Libraries list, select one or more
events in the same library.

••

To delete optimized or proxy files for a library: Select a library in the Libraries list.

2 Choose File > Delete Generated [item] Files.
3 In the window that appears, select any of the following:
••

Delete Optimized Media

••

Delete Proxy Media

4 Click OK.
The selected files are deleted from your storage device.

Chapter 14    Manage media, libraries, and archives

428

Note:  The Delete Generated Library Files command is unique among media management
commands in Final Cut Pro in that it affects external media as well as managed media (in the library).

Manage render files
Rendering is the process of creating temporary video and audio render files for segments of your
project that Final Cut Pro cannot play in real time. When you add effects, transitions, generators,
titles, and other items, they require rendering before you can play them back at high quality.
In the Timeline, an orange render indicator appears above clips that need rendering.
Render indicator

By default, background rendering begins 5 seconds after you stop working and moving the
pointer in Final Cut Pro, and it continues while you work in a different application. You can
turn off background rendering or adjust this setting in Final Cut Pro preferences. You can also
manually start rendering for a project or a portion of a project.
Render files are stored in your Final Cut Pro library or in an external location you define in the
Library inspector. For more information, see Manage storage locations on page 434.
Over time, render files can accumulate and take up storage space. If you want to free up storage
space, you can either delete unused render files in selected events or delete all of the render
files for selected projects or events. You can also delete all render files for a given library. Original
media files are not deleted, so you can always regenerate render files from the original media.
Render all or part of a project
In the Timeline, areas of your project that need rendering have an orange render indicator.
Do one of the following:
mm To render a portion of your project: In the Timeline, select the clip or clips that you want to render
and choose Modify > Render Selection (or press Control-R).
Note:  The selection must be a clip selection, not a range selection.
mm To render all portions of your project that need rendering: Choose Modify > Render All (or press
Control-Shift-R).
Final Cut Pro renders the portions of the project that you defined and removes the
corresponding orange render indicator. You can view the progress of rendering in the
Background Tasks window.
Delete project render files
1 Select one or more projects in the Browser.
2 Choose File > Delete Generated Project Files.
3 In the window that appears, select Delete Render Files and click OK.
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Delete event render files
1 In the Libraries list, select one or more events in the same library.
2 Choose File > Delete Generated Event Files.
3 In the window that appears, select Delete Render Files.
4 Select whether to delete unused render files or all render files, and click OK.
Note:  If you choose to delete all render files in an event, any project render files in that event are
also deleted.
Delete render files from a library
1 Select a library in the Libraries list.
2 Choose File > Delete Generated Library Files.
3 In the window that appears, select Delete Render Files.
4 Select whether to delete unused render files or all render files, and click OK.

View background tasks
Many Final Cut Pro tasks take place in the background:
••

Importing

••

Transcoding

••

Video and audio optimization and analysis

••

Rendering

••

Sharing

Final Cut Pro manages background tasks automatically, so you don’t need to do anything to
start or pause them. If you want to see the progress of any of the background processes, you can
open the Background Tasks window. The tasks being performed and a percentage of completion
are shown in the window.
Important:  If you actively use Final Cut Pro while background tasks are running, the background
tasks will pause. The tasks resume when you stop using Final Cut Pro.
View tasks that are running in the background
1 Do one of the following:
••

Choose Window > Background Tasks (or press Command-9).

••

In the toolbar, click the Background Tasks button.
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2 To view the tasks that are running in each section, click a disclosure triangle.

Pause or resume a task in the Background Tasks window
mm Click the Pause button
or Resume button .
Cancel a task in the Background Tasks window
mm Click the Cancel button .

Manage libraries
Managing libraries overview
Final Cut Pro allows you to work with multiple libraries. You can easily copy events and projects
between libraries, which makes it simple and quick to move media, metadata, and creative work
to another system so that you can edit on a portable computer, collaborate with other editors, or
archive your projects and media. You can open and close libraries as needed so that you never
have too many libraries open at once.
Click the disclosure
triangle for a library to
show or hide its events.

The Browser displays clips and
projects in the selected event.

Select an event
in the Libraries list.

You can also manage storage locations for media files, cache files, and library database backups
on a per-library basis. For more information, see Manage storage locations on page 434.
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Create a new library
You can create new (empty) libraries, or you can create libraries from existing events. For
example, you can select multiple events and copy them all to a single new library by choosing
File > Copy Events to Library > New Library.
Create a library
1 If you don’t see the Libraries list, click the button at the bottom-left corner of the Browser.

2 Do one of the following:
••

To create an empty library: Choose File > New > Library, and navigate to a location on your hard
disk where you want to save the library.

••

To create a library from existing events: Select one or more events in an existing library, and
choose File > Copy Events to Library.

The new library appears in the Libraries list.

Open and close libraries
You can open and close libraries in the Libraries list as needed, so that you never have too many
libraries open at once.
The Close Library command is particularly important if you want to disconnect an external hard
disk containing an open library.
Tip:  To open specific libraries open when you open Final Cut Pro, option-click the Final Cut Pro
application icon in the Dock, then select one or more libraries in the list and click Choose. To
select more than one library: Command-click the libraries in the list.
To open or close libraries in the Libraries list
1 If you don’t see the Libraries list, click the button at the bottom-left corner of the Browser.

2 Do any of the following:
••

To open an existing library: Choose File > Open Library and choose a library from the submenu,
or double-click a library file in the Finder.

••

To close a library: Select the library

in the Libraries list and choose File > Close Library.

Copy or move items between libraries and hard disks
You can copy or move clips, projects, or entire events between libraries on the same hard disk or
on different hard disks. When you copy an item from one library to another, the corresponding
files are duplicated on the disk that contains the receiving library. When you move an item from
one library to another, the corresponding files are moved from one library file to the other
on disk.
For information about copying and moving items between events in the same library, see Copy
or move clips and projects between events in the same library on page 64.
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Here are some ways to use this feature to enhance your workflow:
••

Use multiple libraries on the same hard disk to organize a large number of active projects and
media assets.

••

Work on your project and media files on a different Mac that has Final Cut Pro installed.

••

Back up your project and its media files to a hard disk, a network volume, or other
storage media.

••

Allow multiple users to access your media in an external folder on shared storage.

••

Free up space on your computer’s hard disk.

Note:  If you have customized any Final Cut Pro effects, transitions, titles, generators, or themes,
you must manually back up and move the Motion Templates folder located in your Movies
folder. Similarly, you must manually track and move any third-party effects, because they are not
managed within the Final Cut Pro library.
Copy clips, projects, or events between libraries
1 In the Libraries list, select the event you want to copy, or select the event that contains the clips
or projects you want to copy.
2 If you’re copying clips or projects, select them in the Browser.
Note:  You cannot select clips and projects at the same time.
3 Do one of the following:
••

If the library you want to copy to is present in the Libraries list: Drag the items to the library. If
you’re copying an event, drag it to the library icon . If you’re copying clips and projects, drag
them to a specific event icon.

••

If the library you want to copy to is not present in the Libraries list: Do any of the following:
••

Choose File > Open Library to open it from the submenu, and follow the instructions above.

••

Choose File > Copy [item] to Library and choose the library from the submenu, or choose
New Library to create a new library and choose a location for it.

If your selection contains optimized or proxy media, a window appears with more options. Select
the checkboxes you want for copying optimized or proxy media, and click OK.
Move clips, projects, or events between libraries
1 In the Libraries list, select the event you want to move, or select the event that contains the clips
or projects you want to move.
2 If you’re moving clips or projects, select them in the Browser.
Note:  You cannot select clips and projects at the same time.
3 Do one of the following:
••

If the library you want to move the items to is present in the Libraries list: Command-drag the
items to the library by first starting to drag and then holding down the Command key as
you drag. If you’re copying an event, drag it to the library icon . If you’re copying clips and
projects, drag them to a specific event icon.

••

If the library you want to move the items to is not present in the Libraries list: Do any of the following:
••

Choose File > Open Library to open it from the submenu, and follow the instructions above.

••

Choose File > Move [item] to Library and choose the library from the submenu, or choose
New Library to create a new library and choose a location for it.

If your selection contains optimized or proxy media, a window appears with more options. Select
the checkboxes you want for copying optimized or proxy media and click OK.
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Important:  When you import media into Final Cut Pro, you can select the “Leave files in place”
option to link to the files in their current location rather than copy them into the library. In that
case, Final Cut Pro creates symbolic links (also known as symlinks), which are special files that
point to the media files. When you copy or move clips between events, Final Cut Pro copies or
moves the symbolic links only (not the source media files). To replace the symbolic links with the
actual source media files, select the events and choose File > Consolidate Event Files. For more
information about files and clips, see Media files and clips on page 22.

Manage storage locations
You can set storage locations for each of your libraries. You view and define storage locations for
media, cache files, and library backup files using the Library Properties inspector. You can store
these files within the library or in external folders of your choosing. You can also collect all files
as managed media inside the library for easy transport or archiving. See What are libraries? on
page 18 for more information about managed and external media.
View and set library storage locations
1 Select a library in the Libraries list.
2 To open the Library Properties inspector, do one of the following:
••

Choose File > Library Properties (or press Control-Command-J).

••

Click the Inspector button in the toolbar (shown below).

The inspector shows the storage location settings for the selected library. The Media Locations
section shows a list of storage devices for the selected library, including the total amount of
original, optimized, and proxy media stored on each device. (This is media that was previously
imported or generated for the selected library.)
3 To view or change storage location settings, click Modify Settings.
A window appears with three pop-up menus that you can use to set storage locations. By
default, media and cache files are stored within the library, and backups of the library database
are stored in your Movies folder.
4 To change a storage location, choose “Choose” from the appropriate pop-up menu, navigate to a
folder for the new storage location, and click Choose.
••

Media: Set the location for imported files, proxy and optimized files, and consolidated files.

••

Cache: Set the location for render files, analysis files, thumbnail images, and audio
waveform files.

••

Backups: Set the location for backups of the library database.
If you don’t want Final Cut Pro to back up your library, choose Do Not Save from the Backups
pop-up menu.
Note:  By default, Final Cut Pro makes automatic library backups at 15-minute intervals.
Backups include the database portion of libraries only, not the media files. Backups are saved
with the time and date in the filename. To open a backup from a specific time and date and
add it to the current Libraries list in Final Cut Pro, choose File > Open Library > From Backup.
For more information, see Restore a library from automatic backups on page 76.
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5 When you’re finished setting storage locations, click OK.
Final Cut Pro uses your new storage locations for future source media file imports, cache files,
and backups.
Important:  Existing source media and backup files remain in their original locations. If you
changed the cache storage location, Final Cut Pro offers to move your existing active render files
and other cache files (such as thumbnail images and audio waveform files) to the new location.
Consolidate media files for a library
1 Select a library in the Libraries list.
2 To open the Library Properties inspector, do one of the following:
••

Choose File > Library Properties (or press Control-Command-J).

••

Click the Inspector button in the toolbar (shown below).

3 In the Library Properties inspector, click Consolidate.
4 If you want to include optimized and proxy media, select the checkboxes in the window that
appears, and click OK.
Final Cut Pro copies the media into the selected library file, or to the external storage location. To
view or change library storage locations, see the instructions above.
For more information about consolidating media files, see Consolidate projects, events, and
libraries on page 424.

Create and manage camera archives

You can make a camera archive (backup copy) of the contents of your camera or camcorder.
(Note that you cannot make an archive from a live video signal, such as the signal produced by
an iSight camera.) To protect your media, it is recommended that you save your archive to a disk
or partition different from the one where you store the media files used with Final Cut Pro.
Because you can import media into Final Cut Pro from an archive, archiving the media on your
device can be useful if you want to:
••

Quickly empty the contents of your camera or camcorder so that you can record more media
right away, rather than wait for it to import into Final Cut Pro, which can take time.

••

Import the archived media on multiple computers without having to keep it on the camcorder

••

Keep a browsable, “near-line” archive of media from a camera without having to import the
media into Final Cut Pro

See Access media on an archive or disk image on page 41 for information on how to import
media into Final Cut Pro from a camera archive.
Archive the media on your file-based camera or camcorder
1 If you want to save the archive to an external storage device, connect it to your computer.
2 Connect the camera or camcorder to your computer using the cable that came with it, and turn
it on.
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If you’re using a camcorder, set it to PC Connect mode. The name of this transfer mode may be
different on your device. Your camcorder may automatically go into “connect” mode if you turn
it on in playback mode while it’s connected to your computer. For more information, see the
documentation that came with your camcorder.
Note:  Connecting a DVD camcorder to your Mac can cause the DVD Player application to open. If
that happens, simply close DVD Player.
3 In Final Cut Pro, click the Import Media button on the left end of the toolbar (or press
Command-I).

4 In the Media Import window that appears, select the device whose content you want to archive
from the list of cameras on the left.
Playback controls

The media on the
device appears here.

Change the way clips appear
using these controls.

5 Click the Create Archive button at the bottom-left corner of the window.
6 In the “Create Camera Archive as” field, type a name for the archive.
7 Choose a location to save the archive from the Destination pop-up menu, and click OK.
Note:  It is recommended that you save your archive to a disk or partition different from the one
where you store the media files used with Final Cut Pro.
The camera archive is stored on your hard disk. You can mount the archive as if it were a filebased camcorder and browse the archive’s contents, or import the media on the camera archive
into Final Cut Pro. For more information, see Access media on an archive or disk image on
page 41.
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Archive the media on your tape-based camera or camcorder
1 If you want to save the archive to an external storage device, connect it to your computer.
2 Connect the camera or camcorder to your computer using the cable that came with it, and turn
it on.
If you’re using a camcorder, set it to PC Connect mode. The name of this transfer mode may be
different on your device. Your camcorder may automatically go into “connect” mode if you turn
it on in playback mode while it’s connected to your computer. For more information, see the
documentation that came with your camcorder.
3 In Final Cut Pro, do one of the following:
••

Choose File > Import > Media (or press Command-I).

••

Click the Import Media button on the left end of the toolbar.

4 In the Media Import window that appears, select the device whose content you want to archive
from the list of cameras on the left.

5 Click the Create Archive button at the bottom-left corner of the window.
6 In the “Create Camera Archive as” field, type a name for the archive.
7 Choose a location to save the archive from the Destination pop-up menu, and click OK.
Note:  To protect your media, it is recommended that you save your archive to a disk or partition
different from the one where you store the media files used with Final Cut Pro.
Final Cut Pro begins archiving from the current location on the tape. It will continue to archive
until one of the following occurs:
••

It reaches the end of the tape.

••

You manually stop the archiving process by clicking Stop Import or Close (to close the Media
Import window).
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The camera archive is stored on your hard disk. You can mount the archive as if it were a filebased camcorder and browse the archive’s contents, or import the media on the camera archive
into Final Cut Pro. For more information, see Access media on an archive or disk image on
page 41.
Move or copy a camera archive
1 In the Finder, select the camera archive that you want to move or copy.
2 Do one of the following:
••

To move the camera archive on your local disk: Drag the camera archive to a new location.

••

To copy the camera archive on your local disk: Hold down the Option key and drag the camera
archive to a new location on your local disk.

••

To copy the camera archive to an external storage device: Drag the camera archive to a location
on the external storage device.

Delete a camera archive
Camera archives are very small relative to other media files, and often don’t warrant being
deleted. However, you can delete a camera archive at any time.
1 In the Finder, select the camera archive.
2 Hold down the Control key and choose Move to Trash from the shortcut menu that appears.
3 Control-click or click and hold the Trash icon in your Dock, and choose Empty Trash from the
shortcut menu.
Important:  Emptying the Trash permanently deletes the camera archive.

Solutions to common media management issues
Alert icons
When you see red frames and a yellow alert triangle in the Timeline or an event, Final Cut Pro
is alerting you that part of your project or event is missing. There are many reasons that clips,
events, media files, and effects can be missing: moving projects, events, and files between
computers and actively managing your media using the Finder are two common reasons.
Final Cut Pro events and clips
Icon

Alert

Description

Missing Event

The event media is not available.
You may see this alert if you
moved an event to the Trash,
moved an event to another
location, moved a project to
another location, or moved
another project’s media.

Missing Clip

A clip used in a Final Cut Pro
project or in an event is not
available.
You may see this alert if you
moved the clip to the Trash,
moved a clip (or event), moved a
project to a different location, or
consolidated a different project’s
media.
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Icon

Alert

Description

Missing Camera

A camera that contains files used
in Final Cut Pro is not connected to
your system.
To avoid getting this alert, create
a copy of the media when you
import it. See Organize files while
importing on page 42.

Media files
Icon

Alert

Description

Missing File

A file is not available in the Finder.
You may see this alert if you
moved or renamed a file in
the Finder, moved an event or
project to a different location, or
consolidated a different project’s
media.

Modified File

A media file has been changed
by an application other than
Final Cut Pro.

Missing Proxy File

A proxy file created by
Final Cut Pro is not in its expected
location in the Finder.
See Manage optimized and proxy
media files on page 425.

Final Cut Pro effects
Icon

Alert

Description

Missing Effect

An effect in Final Cut Pro is
missing.

Missing Generator

A generator in Final Cut Pro is
missing.

Missing Title

A title in Final Cut Pro is missing.

Missing Transition

A transition in Final Cut Pro is
missing.
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Common media management issues
This section describes common media management issues and solutions.
If you import a file directly from a hard disk and change the name in the Finder
You may see a missing file alert if you move or rename a file in the Finder.

If you renamed the file, do either of the following:
mm In the Finder, change the filename back to the filename used in the Browser.
mm Quit and reopen Final Cut Pro. The file will be relinked to the clip when Final Cut Pro opens.
If you canceled an import
If you canceled an import and didn’t import an entire clip, the clip will have a Camera icon on its
bottom-left corner.

Camera icon

mm Follow the instructions in “Reimport a clip” in Import from file-based cameras on page 24.
If your DSLR camera isn’t recognized by Final Cut Pro
mm Follow the instructions in Import from a digital still camera on page 32.
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Preferences and metadata

15

Preferences and metadata overview

In Final Cut Pro, you can modify preference settings to specify how your source media is
imported into the application, how your clips play back, and how you edit your clips in
the Timeline.

You can also view and change the information associated with a clip, referred to as a clip’s
metadata. Metadata includes information about a clip’s source media files as well as information
you add to a clip, such as notes. For more information, see Display and change clip metadata on
page 452.

Final Cut Pro preferences
Change preference settings
A preference modifies how a particular Final Cut Pro feature behaves. Most preference settings
can be turned on or off at any time. The following sections describe Final Cut Pro preferences
in detail.
Open Final Cut Pro preferences
mm Choose Final Cut Pro > Preferences (or press Command-Comma), and click a pane’s button at the
top of the window to open it.
Copy Final Cut Pro preferences between computers
You can copy Final Cut Pro preference settings to another Mac that has Final Cut Pro installed so
that the settings are the same on both computers.
1 Find the preference settings file in the following location:
/Users/username/Library/Preferences/com.apple.FinalCut.plist
2 Copy the preference settings file to the same location on another Mac.
If necessary, overwrite any existing version of the file at that location.
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General preferences
General preferences are basic settings in Final Cut Pro.

Time Display
•• Time Display: Use this pop-up menu to choose the time mode for Final Cut Pro. Changes in
this setting affect the time display (for the position of the skimmer or the playhead) in the
Dashboard in the center of the toolbar, as well as trimming and navigation operations in
Final Cut Pro. You have the following options:
••

Timecode display

••

Timecode display including subframes

••

Duration in frames

••

Duration in seconds

Dialog warnings
•• Reset All: Click this button to reset all warning dialogs that you dismissed by selecting the “Do
not remind me again” checkbox.
Note:  For information about library backups, see Restore a library from automatic backups on
page 76 and Manage storage locations on page 434.

Editing preferences
Editing preferences affect editing behaviors in Final Cut Pro.

Timeline
•• Show detailed trimming feedback: Select this checkbox to show the “two-up” display in the
Viewer for more accurate feedback on an edit point involving two contiguous clips. For
example, for a simple ripple or roll edit, this display shows the end point of the left clip and the
start point of the right clip.
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••

Position playhead after edit operation: Select this checkbox to have the playhead automatically
positioned in the Timeline at the end of your last edit. For example, if you insert a clip between
two clips in the Timeline, the playhead is automatically positioned between the inserted clip
and the clip that follows it.

Inspector Units
•• Inspector Units: Use this pop-up menu to choose how values are displayed in inspector controls
for Transform, Crop, and Distort effects.
••

Pixels: Choose this setting to display values as pixels.

••

Percentages: Choose this setting to display values as percentages.

Audio
•• Show reference waveforms: Select this checkbox to change the background appearance of
the audio portion of a clip to show reference waveforms. A reference waveform shows the
maximum visual resolution possible of the actual audio waveform. By factoring out loudness,
reference waveforms let you see the shape of the sound more clearly. When the actual
waveform changes shape (for example, it is diminished when a clip’s volume level is low), you
can continue to see its reference waveform in full for easy reference when editing.
Still Images
•• Editing duration is x seconds: Use this value slider to set the default editing duration of stillimage and freeze-frame clips in seconds.
Transitions
•• Duration is x seconds: Use this value slider to set the default duration of transitions in seconds.

Playback preferences
Playback preferences affect playback and rendering performance in Final Cut Pro.

Note:  For information about controlling playback quality and performance, including switching
between original or optimized media and proxy media, see Control playback quality and
performance on page 85.
Rendering
•• Background render: Select this checkbox to turn on Final Cut Pro rendering operations when
the system is idle.
••

Start after: Use this value slider to set the amount of time your system is idle, in seconds, before
Final Cut Pro begins background rendering.
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Playback
•• Create optimized media for multicam clips: Select this checkbox to automatically transcode
multicam clip video to the Apple ProRes 422 codec, which provides better performance during
editing and faster render times.
••

If a frame drops, stop playback and warn: Select this checkbox to have Final Cut Pro warn you
when frames are dropped during playback.

••

If frames drop due to disk performance, warn after playback: Select this checkbox to have
Final Cut Pro warn you if frames were dropped specifically because of hard disk performance.

Pre-Roll Duration
•• Pre-Roll Duration: Use this value slider to set the amount of time to play before an audition or
before the skimmer or playhead position when using the Play Around command.
Post-Roll Duration
•• Post-Roll Duration: Use this value slider to set the amount of time to play after an audition or
after the skimmer or playhead position when using the Play Around command.
Player Background
•• Player Background: Use this pop-up menu to choose a background for the Viewer. The color
you choose will be visible in the case of partially or completely transparent clips, or clips that
do not fill the frame completely.
A/V Output
•• A/V Output: Use this pop-up menu to choose an external audio/video device or monitor for
output. A/V output requires third-party video interface hardware and software and is available
only with OS X Lion v10.7.2 or later. For more information, see View playback on an external
video monitor on page 83.

Import preferences
When you import media into Final Cut Pro using the Media Import window, you can customize
your import settings each time you import files. However, if you drag media directly from the
Finder into Final Cut Pro, Final Cut Pro uses the import settings you selected in the Import pane
of the Final Cut Pro Preferences window.
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Files
Choose a storage location for the media files:
••

Copy to library storage location: This option duplicates the media files and places the copies
in the current library storage location. You can set storage locations for each of your libraries
using the Library Properties inspector. For more information, see Manage storage locations on
page 434.

••

Leave in place: If you import files with this option selected, Final Cut Pro creates symbolic links
(also known as symlinks), which are special files that point to the media files without copying
them. When you move, copy, or back up events and projects that use these files, Final Cut Pro
moves or copies the symbolic links only (not the source media files). If, after you move or copy
your project or event, you want to replace the symbolic links with the actual source media
files, select the events and choose File > Consolidate Event Files. For more information about
files and clips, see Media files and clips on page 22.

Transcoding
•• Create optimized media: This option transcodes video to the Apple ProRes 422 codec, which
provides better performance during editing, faster render times, and better color quality for
compositing. If the original camera format can be edited with good performance, this option
is dimmed.
••

Create proxy media: This option transcodes video to the Apple ProRes 422 Proxy codec, which
provides high-quality files useful for offline editing. Video proxy files can use considerably less
disk space, often enough to allow you to work on a portable computer instead of a desktop
computer that has significantly more memory and processing power. This option transcodes
still images to either JPEG files (if the original file doesn’t have alpha channel information) or
PNG files (if the file has alpha channel information).

For more information, see Manage optimized and proxy media files on page 425.
Note:  To control whether Final Cut Pro displays optimized, proxy, or original media in the Viewer,
and whether video playback is optimized for quality or performance, choose the corresponding
options from the Viewer Options pop-up menu in the upper-right corner of the Viewer. For more
information, see Control playback quality and performance on page 85.
Keywords
•• From Finder tags: Creates a Keyword Collection for each Finder tag assigned to the files
you’re importing. If the files you’re importing have tags, select this option to keep the tag
organization that exists in the Finder. For more information about Finder tags, see the help for
OS X (available from the Help menu when the Finder is active).
Note:  For REDCODE RAW files only, Keyword Collections are based on tags assigned to the
enclosing folder.
••

From folders: Creates a Keyword Collection for each folder in the files you’re importing. Select this
option to preserve the file organization that exists in the Finder. (Note that although Keyword
Collections do not appear in a hierarchy in the Libraries list, every file in a folder is assigned a
keyword for each folder it’s in, whether it’s one, two, or more levels deep in that folder.)
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••

Find people: Analyzes clips with video for the presence of people and shot types. After analysis,
any of the following keywords are added to the clip: One Person, Two Persons, Group, Close Up
Shot, Medium Shot, and Wide Shot. The “Consolidate find people results” checkbox simplifies
and summarizes all of the “find people” analysis keywords. For more information, see Video and
still-image analysis options on page 51. If you’re analyzing to find people, it’s recommended
that you also select the “Create Smart Collections after analysis” checkbox.

••

Create Smart Collections after analysis: Creates Smart Collections for each keyword applied
when video clips are analyzed for image stabilization problems or the presence of people. The
Smart Collections appear in a folder inside the event.

Video
•• Analyze for balance color: Analyzes video clips and detects color cast and contrast issues. Color
is automatically balanced when you drag the clip to the Timeline. You can fix color balance for
a clip in an event by turning on Balance in the Color section of the Video inspector.
You can turn off the automatic color adjustments at any time to display the colors that were
originally recorded.
Audio
•• Analyze and fix audio problems: Analyzes audio and automatically corrects it for hum, noise, and
loudness. You can turn off automatic audio corrections at any time; after you do so, the audio
will play as originally recorded.
••

Separate mono and group stereo audio: Analyzes and groups audio channels as dual mono or
stereo, depending on the results of the analysis. For more information about audio channels,
see Configure audio channels on page 171.

••

Remove silent channels: Audio channels are analyzed, and silent channels are
automatically removed.
Note:  You can retrieve the original audio configuration after import. See Configure audio
channels on page 171.
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Destinations preferences
You modify share destinations in the Destinations pane of the Final Cut Pro Preferences window.
The destinations in the Destinations list (on the left side of the Destinations pane) also appear in
the Share submenu of the File menu and in the pop-up menu that appears when you click the
Share button in the toolbar.
When you first open Final Cut Pro, a default set of destinations appears in the Destinations list,
but you can add other destinations and customize destinations. To see the destinations you
can add, select Add Destination in the Destinations list. When you select a destination in the
Destinations list, its settings appear on the right.

The settings available for each destination are described below. For information about adding
and modifying destinations, see Create and modify share destinations on page 403.
DVD and Blu-ray
Use these destinations to burn your project or clip to a standard-definition (SD) DVD or a Blu-raycompatible disc, or to create a disk image (.img) file you can copy to an external drive or burn to
disc later.
Note:  The Blu-ray destination does not appear by default. To add it to the Destinations list, see
Create and modify share destinations on page 403.
The DVD and Blu-ray destinations include the following settings:
••

Output Device: Displays your system’s suitable output devices, including optical drives and the
computer’s hard disk.
You can use your hard disk to create a disk image (.img) file that you can copy to an external
drive or burn to DVD media later.
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••

Layers: Displays the available layers on the destination media.
••

Automatic: Automatically detects the type of disc you can use.

••

Single-layer: Identifies the disc as a single-layer disc. You can use this option to force a duallayer disc to be treated as a single-layer disc.

••

Double-layer: Identifies the disc as a double-layer disc. You can use this option to force the
disk image to be formatted for a double-layer disc when you choose Hard Drive as your
output device.

Important:  Depending on the project’s length, choosing Double-layer when using a singlelayer disc may result in an error while burning the disc.
••

Disc template: Displays the available disc templates.

••

When disc loads: Displays the automatic action taken when you play the disc.
••

Show Menu: Displays the main menu.

••

Play Movie: Begins playing the movie immediately.

••

Markers: Not available for Blu-ray when using an AVCHD output device. Select the checkbox
to include chapter marker text as subtitles on the output disc. Users can navigate between
the chapter markers by pressing the Next Chapter or Previous Chapter button on the DVD or
Blu-ray player. For more information about chapter markers, see Manage chapter markers and
their thumbnail images on page 152.

••

Loop: Available for Blu-ray only. Select this checkbox to add a loop icon to the menu.

••

Background: Click the Add button to add a background graphic.

••

Logo graphic: Available for Blu-ray only. Click the Add button to add a logo graphic.

••

Title graphic: Available for Blu-ray only. Click the Add button to add a title graphic.

••

Preview: Click Main Menu to preview the main menu; click Chapter Menu to preview the
chapter menu.

Email
Use this destination to email your project or clip using Mail, Apple’s email program. The Email
destination automatically creates an email message that includes the exported file.
Note:  The Email destination does not appear by default. To add it to the Destinations list, see
Create and modify share destinations on page 403.
The Email destination includes the following settings:
••

Resolution: Choose a resolution from the pop-up menu.

••

Compression: Choose “Better quality” if you want the highest-quality compression; choose
“Faster encode” if you’re willing to sacrifice quality for faster processing.

YouTube, Vimeo, Facebook, CNN iReport, Youku, and Tudou
Use these destinations to publish your project or clip to your YouTube, Vimeo, Facebook, CNN
iReport, Youku, or Tudou account.
Note:  The CNN iReport, Youku, and Tudou destinations do not appear in the Share menu by
default. To add them to the Destinations list, see Create and modify share destinations on
page 403.
Important:  If you have two or more accounts for the same website, you must make a separate
destination for each account. After you enter the account information, the destination name is
appended with the account name in parentheses; for example, “YouTube (myusername).” If you
want, you can rename the destination with a more descriptive name.
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The web destinations include the following settings:
••

Sign In: The first time you view a web destination, a window for entering your account
information appears. If you enter your account name and password and select the “Remember
this password in my keychain” checkbox, you won’t need to enter your account name or
password again. For detailed instructions, see Create and modify share destinations on
page 403.
After the initial setup, you can click the Sign In button in the destination’s settings to reenter
or change your account information.

••

Resolution: Choose the default resolution for the destination. If the destination is used with
a project or clip that has a lower resolution than the resolution you chose, the resolution
changes to match that of the project or clip.

••

Compression: Choose “Better quality” if you want the highest-quality compression; choose
“Faster encode” if you’re willing to sacrifice quality for faster processing.

••

Viewable by: Choose a privacy setting for your shared movie. The privacy settings that appear
in the menu change based on the web destination (YouTube, Vimeo, Facebook, and so on)
you’re modifying.
Important:  When you provide a password for a Youku account, you must enter your password
and then deselect the password field (by pressing the Tab key or clicking elsewhere in the
window). If you don’t do this, Youku does not receive the account information.

••

Category: Choose the category your movie will appear in. The category options change based
on the web destination you’re modifying.

Save Current Frame and Export Image Sequence
Use these destinations to save a still image of any video frame in your project or to save a set of
sequentially numbered still-image files.
Note:  The Save Current Frame and Image Sequence destinations do not appear by default.
To add either of them to the Destinations list, see Create and modify share destinations on
page 403.
The Save Current Frame and Image Sequence destinations include the following settings:
••

Export: Choose a file format for the exported file.

••

Scale image to preserve aspect ratio: Select this checkbox to scale the output file to use square
pixels and maintain the original aspect ratio (which results in an increase or decrease in the
number of horizontal and vertical pixels).
The checkbox affects only projects with formats that use non-square pixels, such as NTSC
and PAL formats. If the checkbox is not selected (the default setting), the output file uses
the same pixel aspect ratio and has the same number of horizontal and vertical pixels as the
original video.

Export File
Note:  This destination is used as the basis for three of the destinations in the default set: Master
File, Apple Devices 720p, and Apple Devices 1080p. When you create and modify destinations in
Final Cut Pro preferences, this destination is called Export File.
Use this destination to export your project or clip as a movie file with video and audio, as a video
file (with no audio), or as an audio file (with no video). This destination is used to export files for
Apple devices, computers, and web hosting.
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You can customize the Export File destination by choosing one of several resolutions, depending
on the intended playback device. For example, choose 1280 x 720 resolution for iPhone and iPod,
and 1920 x 1080 resolution for iPad. You can also export one or more of the roles used in your
project into one or more files, also known as media stems.
The Export File destination includes the following settings:
••

Format: Lists mastering formats (Video and Audio, Video Only, Audio Only) and publishing
formats (Apple Devices, Computer, Web Hosting). Your choice of format determines the
options in the pop-up menus below.
Important:  When sharing a project or clip, you can change the resolution only for
publishing formats.

••

Video codec: Choose a codec to use for the exported file. (Available choices are based on the
source clip or project media format.)

••

Resolution: Choose the default resolution for the destination. If the destination is used with
a project or clip that has a lower resolution than the resolution you chose, the resolution
changes to match that of the project or clip.

••

Audio file format: If you chose Audio Only from the Format pop-up menu, choose an audio
format for the exported file. If you chose another option from the Format pop-up menu, this
item lists the audio format that will be used for the exported file.

••

Include chapter markers: Select the checkbox to include chapter markers that were added to
the project in the output file. Users can navigate between the chapter markers by clicking the
Next Chapter or Previous Chapter button in iTunes or QuickTime Player.

••

“When done,” “Open with,” or “Add to playlist”: Choose what should happen when the export is
complete. You can choose to open the exported file in an application, add it to your iTunes
library, or publish it to the Media Browser. The name of the pop-up menu changes depending
on what you choose.
••

Do Nothing: Choose this option if you don’t want to automatically open the exported file.

••

QuickTime Player, iTunes, or another application: Choose this option to open the exported
file in the default application associated with the file. You can set or change the default
application in the Finder. For more information, see OS X Help, available from the Help menu
when the Finder is active.

••

Compressor: Choose this option to open the exported file in Compressor. The exported file
will appear as the source in a new batch, making it easy to continue to process the project’s
movie. For example, you can create the compressed versions needed for distribution,
without involving Final Cut Pro.

Note:  This option is available only if Compressor is installed on the same computer as
Final Cut Pro.

••

••

Other: Choose this option to specify another application to open the exported file. Select the
application in the window that appears, and click Open.

••

Library: Choose this option to add the exported file to your iTunes library.

Roles as: Available only if you chose a mastering format (Video and Audio, Video Only, or Audio
Only) from the Format pop-up menu. If you need to export your project as separate media
files (for example, if you want to export the dialogue, music, and sound effects from your
project separately), you can export one or more of your project’s roles as media stems. You
can create a combined, multitrack QuickTime file or separate audio or video files using your
project’s audio and video roles, and you can assign mono, stereo, or surround output for your
audio channels. For more information about roles, see Roles overview on page 318.
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Compressor Settings
Use this destination to export a project or clip using settings from Compressor, the professional
transcoding application designed to work directly with Final Cut Pro.
Note:  The Compressor Settings destination does not appear by default. To add it to the
Destinations list, see Create and modify share destinations on page 403.
Exporting a project with a Compressor setting provides many of the benefits of Compressor
without actually opening your project in Compressor. You can use Compressor to create multiple
output files in one share operation, or create custom settings that modify your output file (for
example, to add a watermark to the video). If you have Compressor installed on your system, you
can use any of your Compressor settings with Final Cut Pro.
If you don’t have Compressor installed on your system and you receive a Compressor setting
from someone else, put the setting in this location so that Final Cut Pro and Compressor can
access it:
/Users/username/Library/Application Support/Compressor/Settings/
You may need to create the Compressor and Settings folders using Finder.
Tip:  In OS X Lion v10.7 and later, the Library folder within your home folder is hidden by default.
You can access it in the Finder by choosing Go > Go to Folder and entering ~/Library/ in the “Go
to the folder” field. For more information, see OS X Help, available from the Help menu when the
Finder is active.
Export for HTTP Live Streaming
Use this destination to send audio and video to iPhone, iPad, iPod touch, and Mac using a
web server.
Note:  The HTTP Live Streaming destination does not appear by default. To add it to the
Destinations list, see Create and modify share destinations on page 403.
Because HTTP live streaming dynamically adjusts movie playback quality to match
the available speed of wired or wireless networks, it’s a great way to deliver streaming
media to your iOS-based app or HTML5-based website. For detailed information about
implementing HTTP live streaming, see the Apple Developer HTTP Live Streaming website at
http://developer.apple.com/resources/http-streaming.
The HTTP Live Streaming destination includes the following setting:
••

Versions to export: Select the checkbox for each type of network connection you want to
support for streaming. You can export files for use with devices that use cellular, Wi-Fi, and
broadband data connections.

Bundle
You can group sets of destinations together in a bundle to create several types of output in a
single step. When you share a project or clip using the bundle, a file for each destination in the
bundle is output automatically. To learn how to create a bundle, see Create and modify share
destinations on page 403.
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Work with metadata
Display and change clip metadata
Information about your source media files, information recorded by the camera, and descriptive
information about a clip are called metadata. In Final Cut Pro, you can create your own
combinations of metadata to display with your clips, called metadata views. You can either create
new metadata views or modify the ones that come with Final Cut Pro.
In Final Cut Pro, you work with three types of metadata:
••

Exchangeable Image File (EXIF) data: Information recorded by the camera and stored in the
media at the time it was shot, such as camera make and model, file size, color profile, and bits
per sample.

••

International Press Telecommunications Council (IPTC) data: Standardized data used by media
organizations to embed keywords, captions, copyright notices, and other information in the
media files themselves.

••

Final Cut Pro metadata: Data you apply to clips within Final Cut Pro, such as clip name, ratings,
and keywords.

You can use the Info inspector to view and change the metadata for a clip or group of clips
selected in the Browser or Timeline.
Info button

The Share inspector also displays metadata that is exported with a shared clip or project. For
more information, see Modify share attributes on page 409.
View a clip’s metadata
1 Select a clip.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

Metadata for the selected clip or group of clips is displayed in fields in the Info inspector.
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Switch metadata views in the Info inspector
You can change the metadata fields shown in the Info inspector by choosing a different
metadata view from the Metadata View pop-up menu.
1 Select a clip.
2 Open the Info inspector.
3 Choose a metadata view from the Metadata View pop-up menu.

Metadata View pop-up menu

Note:  If you create custom metadata views, they also appear in the pop-up menu.
Change a clip’s metadata
1 Select a clip.
2 Open the Info inspector.
3 In the Metadata View pop-up menu, choose a metadata view that contains fields for the
metadata you want to change.
4 Do any of the following:
••

Click in a text field to make it active, and enter the text you want to include.
Note:  If you can’t click in a text field, the field can’t be edited. Some EXIF metadata fields, for
example, can’t be edited.

••

Choose an option from the pop-up menu for the metadata you want to change.

Tip:  You can also change the Content Created date and time of your source clips in the Browser.
Just select one or more clips and choose Modify > Adjust Content Created Date and Time.
Rearrange the fields in a metadata view
mm In the Info inspector, drag the metadata labels into a different order.

Modify metadata views
You can create new metadata views or modify the ones that come with Final Cut Pro.
Create a new metadata view
1 Select a clip.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 In the Info inspector, choose Edit Metadata View from the Metadata View pop-up menu.
4 In the Metadata Views window, choose New Metadata View from the Action pop-up menu
at the bottom-left corner of the window.
5 Enter a name for the new metadata view, and press Return.
6 To limit the number of properties to a specific group, such as EXIF or video properties, choose a
property group from the Properties pop-up menu at the top of the window.
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7 To add a property to the metadata view, select the checkbox to the left of the property.
Click a checkbox to add a
property to the metadata view.

Action pop-up menu

8 When you are satisfied with the metadata fields assigned to the metadata view, click OK.
The new metadata view is added to the Metadata View pop-up menu in the Info inspector.
Modify an existing metadata view
You can change the combination of metadata that appears in an existing metadata view. You
can rename metadata fields, add or remove metadata fields, create custom metadata fields, and
rearrange the order in which the metadata fields are displayed.
1 Select a clip.
2 Open the Info inspector.
3 In the Info inspector, choose Edit Metadata View from the Metadata View pop-up menu.
4 In the Metadata Views window, select the metadata view you want to change, and do any of the
following:
••

To rename the metadata view: Double-click the metadata view name in the column on the left,
enter a new name, and press Return.

••

To remove properties (metadata fields) from the metadata view: In the Property column, click the
checkmark to the left of the property you want to remove.

••

To add properties (metadata fields) to the metadata view: In the Property column, select the
checkbox to the left of the property you want to add.

••

To add a custom property (metadata field) to the metadata view: Choose Add Custom Metadata
Field from the Action pop-up menu
, enter a name and description for the new property,
and click OK.

5 When you are satisfied with the metadata fields assigned to the selected metadata view, click OK.
Duplicate a metadata view
If you want to create a new metadata view that contains most of the metadata fields in an
existing metadata view, you can save time by duplicating the existing metadata view and then
modifying it.
1 Select a clip.
2 Open the Info inspector.
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3 In the Info inspector, choose the metadata view you want to duplicate from the Metadata View
pop-up menu, and then choose Save Metadata View As from the Metadata View pop-up menu.
4 In the window that appears at the top of the Final Cut Pro window, enter a name for the new
metadata view and click OK.
The new metadata view appears in the Metadata View pop-up menu in the Info inspector.
Modify the new metadata view as needed.
Delete a metadata view
1 Select a clip.
2 Open the Info inspector.
3 In the Info inspector, choose Edit Metadata View from the Metadata View pop-up menu.
4 In the Metadata Views window, select the metadata view you want to delete in the column
on the left, and choose Delete Metadata View from the Action pop-up menu
in the
lower-left corner.
The metadata view is removed from the left column of the Metadata Views window and from
the Metadata View pop-up menu in the Info inspector.
Note:  Deleting a metadata view does not delete metadata applied to a clip or its source media.

Batch rename clips
When you import media into Final Cut Pro, the clips often contain meaningless names, such
as those assigned by the camera. Although you can rename clips individually, you can also
automatically rename a selection of clips as a batch in the Browser, after the media has been
imported into Final Cut Pro. Final Cut Pro provides customizable naming presets that make
renaming large numbers of clips efficient and easy.
Batch rename clips using a naming preset
1 In the Browser, select the clips you want to rename.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the
Info button at the top of the pane that appears.

3 Choose Apply Custom Name from the Action pop-up menu
from the submenu.

and choose a naming preset

The clips selected in the Browser are renamed.
Create a new naming preset
In most cases, you’ll want to create a new naming preset and customize it.
Tip:  The easiest way to create a new naming preset is to duplicate an existing one. See the
following task for more information.
1 In the Browser, select the clips you want to rename.
2 Open the Info inspector.
3 Choose Apply Custom Name from the Action pop-up menu
the submenu.
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4 In the Naming Presets window, double-click Untitled, type a name for the new preset, and
press Return.
The new naming preset appears in the Apply Custom Name submenu of the Action
pop-up menu.
Duplicate an existing naming preset
The simplest way to create a new naming preset is to duplicate an existing preset—one that
contains most of the name format options you want to include—and modify it.
1 In the Browser, select the clips you want to rename.
2 Open the Info inspector.
3 Choose Apply Custom Name from the Action pop-up menu
the submenu.

and choose Edit from

4 In the Naming Presets window, Control-click the preset that you want to duplicate, and choose
Duplicate from the shortcut menu.

The duplicate naming preset appears below the original preset.
5 Enter a name for the duplicate preset, and press Return.
You can now modify the preset to suit your needs.
Modify an existing naming preset
1 In the Browser, select the clips you want to rename.
2 Open the Info inspector.
3 Choose Apply Custom Name from the Action pop-up menu
the submenu.
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4 In the Naming Presets window, add name tokens by dragging the elements from the Clip Info,
Date/Time, Format, and Camera areas to the Format field.

To remove a naming token, select it in the Format field, and press Delete.
5 Rearrange the tokens in the Format field by dragging them into new positions.
6 If you like, add text characters between naming tokens in the Format field, such as underscores
(_) and spaces.
7 When you are satisfied with the naming preset’s new format, click OK.
Remove a naming preset
1 Select a clip.
2 Open the Info inspector.
3 Choose Apply Custom Name from the Action pop-up menu
the submenu.

and choose Edit from

4 In the Naming Presets window, select the naming preset you want to remove, and click the
Remove Presets button (with a minus sign).
The naming preset is removed from the Naming Presets window.
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Keyboard shortcuts and gestures

16

Keyboard shortcuts and Multi-Touch gestures overview

Final Cut Pro provides several ways to increase your efficiency while you put together your project:
••

Standard keyboard shortcuts: Many common tasks, such as opening a specific window or
adding a clip from the Browser to the Timeline, can be accomplished very quickly by pressing
one or more keys. See Keyboard shortcuts on page 458.

••

Multi-Touch gestures: If you have a Multi-Touch trackpad or mouse, you can take advantage of
Multi-Touch gestures to quickly perform many tasks while creating your project. See MultiTouch gestures on page 472.

••

Custom keyboard shortcuts: You can add to the standard keyboard shortcuts by creating your
own custom keyboard shortcuts for features that you use frequently, such as Color Board
controls. Or if you’re more familiar with keyboard shortcuts from another application, you can
use the Command Editor to substitute those keyboard shortcuts in place of the default set in
Final Cut Pro. See View keyboard shortcuts in the Command Editor on page 472.

Keyboard shortcuts

You can use keyboard shortcuts to quickly accomplish many tasks in Final Cut Pro. To use a
keyboard shortcut, press all the keys in the shortcut at the same time. Shortcuts for common
commands are listed in the table below.
Application
Command

Shortcut

Action

Hide Application

Command-H

Hide Final Cut Pro

Hide Other Applications

Option-Command-H

Hide all applications except
Final Cut Pro

Keyboard Customization

Option-Command-K

Open the Command Editor

Minimize

Command-M

Minimize Final Cut Pro

Open Library

Command-O

Open an existing library or a new
library

Preferences

Command-Comma (,)

Open the Final Cut Pro Preferences
window

Quit

Command-Q

Quit Final Cut Pro

Redo Change

Shift-Command-Z

Redo the last command

Undo Change

Command-Z

Undo the last command
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Editing
Command

Shortcut

Action

Adjust Volume Absolute

Control-Option-L

Adjust the audio volume across all
selected clips to a specific dB value

Adjust Volume Relative

Control-L

Adjust the audio volume across
all selected clips by the same dB
value

Append to Storyline

E

Add the selection to the end of the
storyline

Audition: Add to Audition

Control-Shift-Y

Add the selected clip to the
audition

Audition: Duplicate and Paste
Effects

Option-Command-Y

Duplicate clips in the audition and
add effects

Audition: Duplicate as Audition

Option-Y

Create an audition with a Timeline
clip and a duplicate version of the
clip, including applied effects

Audition: Duplicate from Original

Shift-Command-Y

Duplicate the selected audition
clip without applied effects

Audition: Replace and Add to
Audition

Shift-Y

Create an audition and replace
the Timeline clip with the current
selection

Blade

Command-B

Cut the primary storyline clip (or
the selection) at the skimmer or
playhead location

Blade All

Shift-Command-B

Cut all clips at the skimmer or
playhead location

Break Apart Clip Items

Shift-Command-G

Break the selected item into its
component parts

Change Duration

Control-D

Change the duration of the
selection

Connect to Primary Storyline

Q

Connect the selection to the
primary storyline

Connect to Primary Storyline
- Backtimed

Shift-Q

Connect the selection to the
primary storyline, aligning the
selection’s end point with the
skimmer or playhead

Copy

Command-C

Copy the selection

Create Audition

Command-Y

Create an audition from the
selection

Create Storyline

Command-G

Create a storyline from a selection
of connected clips

Cut

Command-X

Cut the selection

Cut and Switch to Viewer Angle 1

1

Cut and switch the multicam clip
to angle 1 of the current bank

Cut and Switch to Viewer Angle 2

2

Cut and switch the multicam clip
to angle 2 of the current bank

Cut and Switch to Viewer Angle 3

3

Cut and switch the multicam clip
to angle 3 of the current bank
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Command

Shortcut

Action

Cut and Switch to Viewer Angle 4

4

Cut and switch the multicam clip
to angle 4 of the current bank

Cut and Switch to Viewer Angle 5

5

Cut and switch the multicam clip
to angle 5 of the current bank

Cut and Switch to Viewer Angle 6

6

Cut and switch the multicam clip
to angle 6 of the current bank

Cut and Switch to Viewer Angle 7

7

Cut and switch the multicam clip
to angle 7 of the current bank

Cut and Switch to Viewer Angle 8

8

Cut and switch the multicam clip
to angle 8 of the current bank

Cut and Switch to Viewer Angle 9

9

Cut and switch the multicam clip
to angle 9 of the current bank

Delete

Delete

Delete the Timeline selection,
reject the Browser selection, or
remove a through edit

Delete Selection Only

Option-Command-Delete

Delete the selection and attach
the connected clip or clips to the
resulting gap clip

Deselect All

Shift-Command-A

Deselect all selected items

Duplicate

Command-D

Duplicate the Browser selection

Enable/Disable Clip

V

Enable or disable playback for the
selection

Expand Audio/Video

Control-S

View audio and video separately
for selected clips

Expand/Collapse Audio
Components

Control-Option-S

Expand or collapse audio
components for the selection in
the Timeline

Extend Edit

Shift-X

Extend the selected edit point to
the skimmer or playhead position

Extend Selection Down

Shift–Down Arrow

In the Browser, add the next item
to the selection

Extend Selection Up

Shift–Up Arrow

In the Browser, add the previous
item to the selection

Finalize Audition

Option-Shift-Y

Dissolve the audition and replace
it with the audition pick

Insert

W

Insert the selection at the skimmer
or playhead position

Insert/Connect Freeze Frame

Option-F

Insert a freeze frame at the
playhead or skimmer location
in the Timeline, or connect a
freeze frame from the skimmer
or playhead location in the event
to the playhead location in the
Timeline

Insert Gap

Option-W

Insert a gap clip at the skimmer or
playhead position

Insert Placeholder

Option-Command-W

Insert a placeholder clip at the
skimmer or playhead position
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Command

Shortcut

Action

Lift from Storyline

Option–Command–Up Arrow

Lift the selection from the storyline
and connect it to the resulting gap
clips

Lower Volume 1 dB

Control-Hyphen (-)

Lower the audio volume by 1 dB

Move Playhead Position

Control-P

Move the playhead by entering a
timecode value

New Compound Clip

Option-G

Create a new compound clip (if
there’s no selection, create an
empty compound clip)

Nudge Audio Subframe Left

Option-Comma (,)

Nudge the selected audio edit
point left by one subframe,
creating a split edit

Nudge Audio Subframe Left Many

Option-Shift-Comma (,)

Nudge the selected audio edit
point left by 10 subframes, creating
a split edit

Nudge Audio Subframe Right

Option-Period (.)

Nudge the selected audio edit
point right by one subframe,
creating a split edit

Nudge Audio Subframe Right
Many

Option-Shift-Period (.)

Nudge the selected audio edit
point right by 10 subframes,
creating a split edit

Nudge Down

Option–Down Arrow

Nudge down the value of
the selected keyframe in the
Animation Editor

Nudge Left

Comma (,)

Nudge the selection one unit to
the left

Nudge Left Many

Shift-Comma (,)

Nudge the selection 10 units to
the left

Nudge Right

Period (.)

Nudge the selection one unit to
the right

Nudge Right Many

Shift-Period (.)

Nudge the selection 10 units to
the right

Nudge Up

Option–Up Arrow

Nudge up the value of the selected
keyframe in the Animation Editor

Open Audition

Y

Open the selected audition

Override Connections

Grave Accent (`)

Temporarily override clip
connections for the selection

Overwrite

D

Overwrite at the skimmer or
playhead position

Overwrite - Backtimed

Shift-D

Overwrite from the skimmer or
playhead position back

Overwrite to Primary Storyline

Option–Command–Down Arrow

Overwrite at the skimmer or
playhead position in the primary
storyline

Paste as Connected

Option-V

Paste the selection and connect it
to the primary storyline

Paste Insert at Playhead

Command-V

Insert the Clipboard contents at
the skimmer or playhead position
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Command

Shortcut

Action

Previous Angle

Control–Shift–Left Arrow

Switch to the previous angle in the
multicam clip

Previous Audio Angle

Option–Shift–Left Arrow

Switch to the previous audio angle
in the multicam clip

Previous Pick

Control–Left Arrow

Select the previous clip in the
Audition window, making it the
audition pick

Previous Video Angle

Shift–Command–Left Arrow

Switch to the previous video angle
in the multicam clip

Raise Volume 1 dB

Control–Equal Sign (=)

Raise the audio volume by 1 dB

Replace

Shift-R

Replace the selected clip in
the Timeline with the Browser
selection

Replace from Start

Option-R

Replace the selected clip in
the Timeline with the Browser
selection, starting from its start
point

Replace with Gap

Shift-Delete

Replace the selected Timeline clip
with a gap clip

Select All

Command-A

Select all clips

Select Clip

C

Select the clip under the pointer in
the Timeline

Select Left Audio Edge

Shift–Left Bracket ([)

For audio/video clips in expanded
view, select the left edge of the
audio edit point

Select Left Edge

Left Bracket ([)

Select the left edge of the edit
point

Select Left and Right Audio Edit
Edges

Shift-Backslash (\)

For audio/video clips in expanded
view, select the left and right
edges of the audio edit point

Select Left and Right Edit Edges

Backslash (\)

Select the left and right edges of
the edit point

Select Next Angle

Control–Shift–Right Arrow

Switch to the next angle in the
multicam clip

Select Next Audio Angle

Option–Shift–Right Arrow

Switch to the next audio angle in
the multicam clip

Select Next Pick

Control–Right Arrow

Select the next clip in the Audition
window, making it the audition
pick

Select Next Video Angle

Shift–Command–Right Arrow

Switch to the next video angle in
the multicam clip

Select Right Audio Edge

Shift–Right Bracket (])

For audio/video clips in expanded
view, select the right edge of the
audio edit point

Select Right Edge

Right Bracket (])

Select the right edge of the edit
point
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Command

Shortcut

Action

Set Additional Selection End

Shift-Command-O

Set an additional range selection
end point at the playhead or
skimmer location

Set Additional Selection Start

Shift-Command-I

Set an additional range selection
start point at the playhead or
skimmer location

Show/Hide Precision Editor

Control-E

When an edit point is selected,
show or hide the Precision Editor

Snapping

N

Turn snapping on or off

Solo

Option-S

Solo the selected items in the
Timeline

Source Media: Audio & Video

Shift-1

Turn on audio/video mode to add
the video and audio portion of
your selection to the Timeline

Source Media: Audio Only

Shift-3

Turn on audio-only mode to add
the audio portion of your selection
to the Timeline

Source Media: Video Only

Shift-2

Turn on video-only mode to add
the video portion of your selection
to the Timeline

Switch to Viewer Angle 1

Option-1

Switch the multicam clip to angle
1 of the current bank

Switch to Viewer Angle 2

Option-2

Switch the multicam clip to angle
2 of the current bank

Switch to Viewer Angle 3

Option-3

Switch the multicam clip to angle
3 of the current bank

Switch to Viewer Angle 4

Option-4

Switch the multicam clip to angle
4 of the current bank

Switch to Viewer Angle 5

Option-5

Switch the multicam clip to angle
5 of the current bank

Switch to Viewer Angle 6

Option-6

Switch the multicam clip to angle
6 of the current bank

Switch to Viewer Angle 7

Option-7

Switch the multicam clip to angle
7 of the current bank

Switch to Viewer Angle 8

Option-8

Switch the multicam clip to angle
8 of the current bank

Switch to Viewer Angle 9

Option-9

Switch the multicam clip to angle
9 of the current bank

Toggle Storyline Mode

G

Turn on or turn off the ability to
build storylines when dragging
clips in the Timeline

Trim End

Option–Right Bracket (])

Trim the end of the selected or
topmost clip to the skimmer or
playhead position

Trim Start

Option–Left Bracket ([)

Trim the clip start point to the
skimmer or playhead position

Trim to Selection

Option-Backslash (\)

Trim clip start and end points to
the range selection
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Effects
Command

Shortcut

Action

Add Basic Lower Third

Control-Shift-T

Connect a basic lower-third title to
the primary storyline

Add Basic Title

Control-T

Connect a basic title to the
primary storyline

Add Default Transition

Command-T

Add the default transition to the
selection

Color Board: Reset Current Board
Controls

Option-Delete

Reset the controls in the current
Color Board pane

Color Board: Switch to the Color
Pane

Control-Command-C

Switch to the Color pane in the
Color Board

Color Board: Switch to the
Exposure Pane

Control-Command-E

Switch to the Exposure pane in the
Color Board

Color Board: Switch to the
Saturation Pane

Control-Command-S

Switch to the Saturation pane in
the Color Board

Copy Effects

Option-Command-C

Copy the selected effects and their
settings

Copy Keyframes

Option-Shift-C

Copy the selected keyframes and
their settings

Cut Keyframes

Option-Shift-X

Cut the selected keyframes and
their settings

Enable/Disable Balance Color

Option-Command-B

Turn Balance Color corrections on
or off

Match Audio

Shift-Command-M

Match the sound between clips

Match Color

Option-Command-M

Match color between clips

Next Text

Option-Tab

Navigate to the next text item

Paste Attributes

Shift-Command-V

Paste selected attributes and their
settings to the selection

Paste Effects

Option-Command-V

Paste effects and their settings to
the selection

Paste Keyframes

Option-Shift-V

Paste keyframes and their settings
to the selection

Previous Text

Option-Shift-Tab

Navigate to the previous text item

Retime Editor

Command-R

Show or hide the Retime Editor

Retime: Create Normal Speed
Segment

Shift-N

Set the selection to play at normal
(100 percent) speed

Retime: Hold

Shift-H

Create a 2-second hold segment

Retime: Reset

Option-Command-R

Reset the selection to play forward
at normal (100 percent) speed

Solo Animation

Control-Shift-V

Show one effect at a time in the
Video Animation Editor
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General
Command

Shortcut

Action

Delete

Delete

Delete the Timeline selection,
reject the Browser selection, or
remove a through edit

Find

Command-F

Show or hide the Filter window (in
the Browser) or the Timeline Index
(in the Timeline)

Go to Event Viewer

Option-Command-3

Make the Event Viewer active

Import Media

Command-I

Import media from a device, a
camera, or an archive

Library Properties

Control-Command-J

Open the Library Properties
inspector for the current library

Move to Trash

Command-Delete

Move the selection to the Finder
Trash

New Project

Command-N

Create a new project

Project Properties

Command-J

Open the Properties inspector for
the current project

Render All

Control-Shift-R

Start all rendering tasks for the
current project

Render Selection

Control-R

Start rendering tasks for the
selection

Reveal in Finder

Shift-Command-R

Reveal the selected event clip’s
source media file in the Finder

Command

Shortcut

Action

Add Marker

M

Add a marker at the location of the
skimmer or playhead

All Clips

Control-C

Change the Browser filter settings
to show all clips

Add Marker and Modify

Option-M

Add a marker and edit the
marker’s text

Apply Keyword Tag 1

Control-1

Apply keyword 1 to the selection

Apply Keyword Tag 2

Control-2

Apply keyword 2 to the selection

Apply Keyword Tag 3

Control-3

Apply keyword 3 to the selection

Apply Keyword Tag 4

Control-4

Apply keyword 4 to the selection

Apply Keyword Tag 5

Control-5

Apply keyword 5 to the selection

Apply Keyword Tag 6

Control-6

Apply keyword 6 to the selection

Apply Keyword Tag 7

Control-7

Apply keyword 7 to the selection

Apply Keyword Tag 8

Control-8

Apply keyword 8 to the selection

Apply Keyword Tag 9

Control-9

Apply keyword 9 to the selection

Clear Selected Ranges

Option-X

Clear the range selection

Clear Range End

Option-O

Clear the range’s end point

Marking
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Command

Shortcut

Action

Clear Range Start

Option-I

Clear the range’s start point

Delete Marker

Control-M

Delete the selected marker

Delete Markers in Selection

Control-Shift-M

Delete all of the markers in the
selection

Deselect All

Shift-Command-A

Deselect all selected items

Favorite

F

Rate the Browser selection as
Favorite

Favorites

Control-F

Change the Browser filter settings
to show Favorites

Hide Rejected

Control-H

Change the Browser filter settings
to hide rejected clips

New Keyword Collection

Shift-Command-K

Create a new Keyword Collection

New Smart Collection

Option-Command-N

Create a new Smart Collection

Range Selection Tool

R

Make the Range Selection tool
active

Reject

Delete

Mark the current selection in the
Browser as rejected
Note:  The Delete key will remove
selected items if the Timeline is
active instead of the Browser.

Rejected

Control-Delete

Change the Browser filter settings
to show rejected clips

Remove All Keywords From
Selection

Control-0

Remove all keywords from the
Browser selection

Roles: Apply Dialogue Role

Control-Option-D

Apply the Dialogue role to the
selected clip

Roles: Apply Effects Role

Control-Option-E

Apply the Effects role to the
selected clip

Roles: Apply Music Role

Control-Option-M

Apply the Music role to the
selected clip

Roles: Apply Titles Role

Control-Option-T

Apply the Titles role to the
selected clip

Roles: Apply Video Role

Control-Option-V

Apply the Video role to the
selected clip

Select All

Command-A

Select all clips

Select Clip Range

X

Set the range selection to match
the boundaries of the clip below
the skimmer or playhead

Set Additional Range End

Shift-Command-O

Set an additional range selection
end point at the playhead or
skimmer location

Set Additional Range Start

Shift-Command-I

Set an additional range selection
start point at the playhead or
skimmer location

Set Range End

O

Set the end point for the range
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Command

Shortcut

Action

Set Range End

Control-O

Set the end point for the range
while editing a text field

Set Range Start

I

Set the start point for the range

Set Range Start

Control-I

Set the start point for the range
while editing a text field

Unrate

U

Remove ratings from the selection

Command

Shortcut

Action

New Event

Option-N

Create a new event

New Folder

Shift-Command-N

Create a new folder

Reveal in Browser

Shift-F

Reveal the selected clip in the
Browser

Reveal Project in Browser

Option-Shift-Command-F

Reveal the open project in the
Browser

Synchronize Clips

Option-Command-G

Synchronize the selected event
clips

Command

Shortcut

Action

Audio Skimming

Shift-S

Turn audio skimming on or off

Audition: Preview

Control-Command-Y

Play the pick in context in the
Timeline

Clip Skimming

Option-Command-S

Turn clip skimming on or off

Cut/Switch Multicam Audio Only

Option-Shift-3

Turn on audio-only mode for
multicam cutting and switching

Cut/Switch Multicam Audio and
Video

Option-Shift-1

Turn on audio/video mode for
multicam cutting and switching

Cut/Switch Multicam Video Only

Option-Shift-2

Turn on video-only mode for
multicam cutting and switching

Down

Down Arrow

Go to the next item (in the
Browser) or the next edit point (in
the Timeline)

Down

Control–Down Arrow

While editing a text field, go to the
next item (in the Browser) or the
next edit point (in the Timeline)

Go Back 10 Frames

Shift–Left Arrow

Move the playhead back 10 frames

Go Forward 10 Frames

Shift–Right Arrow

Move the playhead forward 10
frames

Go to Beginning

Home button

Move the playhead to the
beginning of the Timeline or the
first clip in the Browser

Go to End

End button

Move the playhead to the end of
the Timeline or to the last clip in
the Browser

Organization

Playback/Navigation
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Command

Shortcut

Action

Go to Next Bank

Option-Shift-Apostrophe (’)

Display the next bank of angles in
the current multicam clip

Go to Next Edit

Apostrophe (’)

Move the playhead to the next
edit point in the Timeline

Go to Next Field

Option–Right Arrow

Move the playhead to the next
field in an interlaced clip

Go to Next Frame

Right Arrow

Move the playhead to the next
frame

Go to Next Subframe

Command–Right Arrow

Move the playhead to the next
audio subframe

Go to Previous Bank

Option-Shift-Semicolon (;)

Display the previous bank of
angles in the current multicam clip

Go to Previous Edit

Semicolon (;)

Move the playhead to the previous
edit point in the Timeline

Go to Previous Field

Option–Left Arrow

Move the playhead to the previous
field in an interlaced clip

Go to Previous Frame

Left Arrow

Move the playhead to the previous
frame

Go to Previous Subframe

Command–Left Arrow

Move the playhead to the previous
audio subframe

Go to Range End

Shift-O

Move the playhead to the end of
the range selection

Go to Range Start

Shift-I

Move the playhead to the
beginning of the range selection

Loop Playback

Command-L

Turn looped playback on or off

Monitor Audio

Shift-A

Turn on or turn off audio
monitoring for the angle being
skimmed

Negative Timecode Entry

Hyphen (-)

Enter a negative timecode value to
move the playhead back, move a
clip earlier, or trim a range or clip,
depending on your selection

Next Clip

Control–Command–Right Arrow

Go to the next item (in the
Browser) or the next edit point (in
the Timeline)

Next Marker

Control-Apostrophe (’)

Move the playhead to the next
marker

Play Around

Shift–Question Mark (?)

Play around the playhead position

Play Forward

L

Play forward (press L multiple
times to increase the playback
speed)

Play from Playhead

Option–Space bar

Play from the playhead position

Play Full Screen

Shift-Command-F

Play full screen from the skimmer
or playhead position

Play Reverse

J

Play in reverse (press J multiple
times to increase the reverse
playback speed)
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Command

Shortcut

Action

Play Reverse

Control-J

Play in reverse while editing a
text field (press J multiple times
to increase the reverse playback
speed)

Play Reverse

Shift–Space bar

Play in reverse

Play Selection

Slash (/)

Play the selection

Play to End

Control-Shift-O

Play from the playhead to the end
of the selection

Play/Pause

Space bar

Start or pause playback

Play/Pause

Control–Space bar

Start or pause playback while
editing a text field

Positive Timecode Entry

Equal Sign (=)

Enter a positive timecode value to
move the playhead forward, move
a clip later, or trim a range or clip,
depending on your selection

Previous Clip

Control–Command–Left Arrow

Go to the previous item (in the
Browser) or the previous edit point
(in the Timeline)

Previous Marker

Control-Semicolon (;)

Move the playhead to the previous
marker

Set Monitoring Angle

Shift-V

Set the angle being skimmed as
the monitoring angle

Skimming

S

Turn skimming on or off

Start/Stop Voiceover Recording

Option-Shift-A

Start or stop recording audio from
the Record Voiceover window

Stop

K

Stop playback

Stop

Control-K

Stop playback while editing a text
field

Timeline History Back

Command–Left Bracket ([)

Go back one level in the Timeline
history

Timeline History Forward

Command–Right Bracket (])

Go forward one level in the
Timeline history

Up

Up Arrow

Go to the previous item (in the
Browser) or the previous edit point
(in the Timeline)

Up

Control–Up Arrow

While editing a text field, go to
the previous item (in the Browser)
or the previous edit point (in the
Timeline)

Command

Shortcut

Action

Share to Default Destination

Command-E

Share the selected project or clip
using the default destination

Select (Arrow) Tool

A

Make the Select tool active

Blade Tool

B

Make the Blade tool active

Share and Tools
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Command

Shortcut

Action

Crop Tool

Shift-C

Make the Crop tool active and
display onscreen controls for the
selected clip or the topmost clip
under the playhead

Distort Tool

Option-D

Make the Distort tool active and
display onscreen controls for the
selected clip or the topmost clip
under the playhead

Hand Tool

H

Make the Hand tool active

Position Tool

P

Make the Position tool active

Transform Tool

Shift-T

Make the Transform tool active
and display onscreen controls for
the selected clip or the topmost
clip under the playhead

Trim Tool

T

Make the Trim tool active

Zoom Tool

Z

Make the Zoom tool active

Command

Shortcut

Action

Clip Appearance: Clip Labels Only

Control-Option-6

Depending on the clip name
setting, display Timeline clips with
clip names, role names, or active
angle names only

Clip Appearance: Decrease
Waveform Size

Control–Option–Down Arrow

Decrease the size of audio
waveforms for Timeline clips

Clip Appearance: Filmstrips Only

Control-Option-5

Display Timeline clips with large
filmstrips only

Clip Appearance: Increase
Waveform Size

Control–Option–Up Arrow

Increase the size of audio
waveforms for Timeline clips

Clip Appearance: Large Filmstrips

Control-Option-4

Display Timeline clips with small
audio waveforms and large
filmstrips

Clip Appearance: Large Waveforms

Control-Option-2

Display Timeline clips with large
audio waveforms and small
filmstrips

Clip Appearance: Waveforms and
Filmstrips

Control-Option-3

Display Timeline clips with audio
waveforms and video filmstrips of
equal size

Clip Appearance: Waveforms Only

Control-Option-1

Display Timeline clips with large
audio waveforms only

Decrease Clip Height

Shift-Command-Hyphen (-)

Decrease the Browser clip height

Increase Clip Height

Shift–Command–Equal Sign (=)

Increase the Browser clip height

Show Fewer Filmstrip Frames

Shift-Command-Comma (,)

Show fewer filmstrip frames in
Browser clips

Show/Hide Audio Animation

Control-A

Show or hide the Audio Animation
Editor for the selected clips

Show/Hide Skimmer Info

Control-Y

Show or hide clip information
when skimming in the Browser

View
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Command

Shortcut

Action

Show/Hide Video Animation

Control-V

Show or hide the Video Animation
Editor for the selected Timeline
clips

Show More Filmstrip Frames

Shift-Command-Period (.)

Show more filmstrip frames in
Browser clips

Show One Frame per Filmstrip

Option-Shift-Command-Comma (,)

Show one frame per filmstrip

View Clip Names

Option-Shift-N

Show or hide clip names in the
Browser

View Browser as Filmstrip

Option-Command-1

Switch the Browser to filmstrip
view

View Browser as List

Option-Command-2

Switch the Browser to list view

Zoom In

Command–Equal Sign (=)

Zoom in to the Timeline, Browser,
or Viewer

Zoom Out

Command-Hyphen (-)

Zoom out of the Timeline, Browser,
or Viewer

Zoom to Fit

Shift-Z

Zoom the contents to fit the size of
the Browser, Viewer, or Timeline

Zoom to Samples

Control-Z

Turn zooming in to audio samples
on or off

Command

Shortcut

Action

Background Tasks

Command-9

Show or hide the Background
Tasks window

Go to Audio Enhancements

Command-8

Make the Audio Enhancements
inspector active

Go to Color Board

Command-6

Make the Color Board active

Go to Browser

Command-1

Make the Browser active

Go to Inspector

Option-Command-4

Make the current inspector active

Go to Timeline

Command-2

Make the Timeline active

Go to Viewer

Command-3

Make the Viewer active

Next Tab

Control-Tab

Go to the next pane in the
Inspector or the Color Board

Previous Tab

Control-Shift-Tab

Go to the previous pane in the
Inspector or the Color Board

Record Voiceover

Option-Command-8

Show or hide the Record Voiceover
window

Show Histogram

Control-Command-H

Show the Histogram in the Viewer

Show Vectorscope

Control-Command-V

Show the Vectorscope in the
Viewer

Show Video Waveform

Control-Command-W

Show the Waveform Monitor in the
Viewer

Show/Hide Angles

Shift-Command-7

Show or hide the Angle Viewer

Show/Hide Audio Meters

Shift-Command-8

Show or hide the Audio meters

Windows
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Command

Shortcut

Action

Show/Hide Browser

Control-Command-1

Show or hide the Browser

Show/Hide Effects Browser

Command-5

Show or hide the Effects Browser

Show/Hide Libraries list

Shift-Command-1

Show or hide the Libraries list

Show/Hide Event Viewer

Control-Command-3

Show or hide the Event Viewer

Show/Hide Inspector

Command-4

Show or hide the Inspector pane

Show/Hide Keyword Editor

Command-K

Show or hide the Keyword Editor

Show/Hide Timeline Index

Shift-Command-2

Show or hide the Timeline Index
for the open project

Show/Hide Video Scopes

Command-7

Show or hide the video scopes in
the Viewer

Multi-Touch gestures

If your computer has a Multi-Touch trackpad, you can use the Multi-Touch gestures listed in the
table below when working with Final Cut Pro.
For more information about Multi-Touch gestures, see the documentation that came with
your computer.
Gesture

Action
Scroll (two-finger): Moves the Timeline left, right, up, or down.

Scroll (three-finger): Swipe up to move the playhead to the beginning
of the Timeline. Swipe down to move the playhead to the end of the
Timeline. Swipe left or right to move the playhead left or right.

Customize keyboard shortcuts
View keyboard shortcuts in the Command Editor
Final Cut Pro provides a wide variety of menu commands and keyboard shortcuts that let you
control almost every aspect of your project, from playback to displaying windows and inspectors
to working with tools. You can use the Command Editor to modify existing shortcuts, create new
shortcuts, and save multiple sets of keyboard shortcuts that you can export for others to use. You
can also import a set of shortcuts that someone else created. And if you’re more familiar with
keyboard shortcuts from other applications, you can use the Command Editor to substitute those
shortcuts in place of the default set for Final Cut Pro.
The Command Editor provides a set of keyboard shortcuts for Final Cut Pro in English, Japanese,
French, and German. The language that is shown is determined by your computer’s operating
system. To learn how to change the language used by Final Cut Pro, see OS X Help, available from
the Help menu when the Finder is active.
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View keyboard shortcuts
1 Choose Final Cut Pro > Commands > Customize (or press Option-Command-K).
The Command Editor appears.

2 To find keyboard shortcuts in the Command Editor, do any of the following:
••

Click one or more keys on the virtual keyboard (or click one of the four modifier buttons at the
top of the Command Editor).
The Command groups associated with the selected key or keys appear in the bottom-left
corner of the window, and a list of all the keyboard shortcuts associated with the key you
selected appears in the bottom-right corner of the window.
Select a key to see the Command
groups associated with the key.

When you hold down any modifier buttons on the keyboard, the key colors update. Key colors
correspond with command classifications; for example, playback commands, such as Play/
Pause (Space bar), are blue. The Command Groups window on the left side of the Command
List contains a clickable color key for reference.
••

Enter a command name, description keywords, or a key name in the search field at the topright corner of the window.
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The commands that match the search term are listed in the Command List at the bottom of
the window.
Tip:  To show the keys that correspond with the items in the Command List, click the Keyboard
Highlight button to the left of the search field.
Click any command in the list to view its details in the Command Detail area in the bottomright corner of the window.
Enter a term to
search for here.

Commands located
by the search
••

Click a Command group to quickly filter the Command List to display only the commands and
keyboard shortcuts in that group.
Click any command in the list to view its details in the Command Detail area in the bottomright corner of the window.

Click a Command group to
quickly filter the Command List.

View shortcuts from a different command set
If your system has multiple command sets, you can easily switch between them. For more
information, see Export and import command sets in the Command Editor on page 476.
Do one of the following:
mm Choose Final Cut Pro > Commands, and then choose a command set from the submenu.
The Command Editor window appears, showing the command set you chose.
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mm If you’ve already opened the Command Editor, choose a command set from the pop-up menu at
the top-left corner of the window.

Command sets are
listed in the bottom
of the pop-up menu.

Modify keyboard shortcuts in the Command Editor
You can quickly and easily customize keyboard shortcuts in the Command Editor. If you want to
add a few custom commands to the default set in Final Cut Pro, you can duplicate the default set
and assign keyboard shortcuts to some of the unassigned commands. You can also create a new
set that contains only your commands.
Duplicate a command set
1 Choose Final Cut Pro > Commands > Customize (or press Option-Command-K).
2 If the command set that you want to duplicate is not shown, choose a different command set
from the pop-up menu in the top-left corner of the Command Editor.
3 Choose Duplicate from the pop-up menu.
4 In the window that appears, type a name for the command set, and click OK.
The duplicate set is added to the Command submenu of the Final Cut Pro menu and to the
pop-up menu in the Command Editor.
Modify a command set
You can add keyboard shortcuts to a command set or reassign keyboard shortcuts.
1 Choose Final Cut Pro > Commands > Customize (or press Option-Command-K).
2 If the command set that you want to modify is not shown, select a different different command
set from the pop-up menu at the top of the Command Editor.
3 Select the command to which you want to assign a new keyboard shortcut by doing one of the
following:
••

Type a command name in the search field at the top-right corner of the Command Editor window.

••

Browse the command list to find the command you want.

4 Press the combination of keys you want to use for the command (for example, Option-Shift-T, or
any other keys).
Note:  Keys on the Command Editor virtual keyboard that are shaded with diagonal lines are
reserved for system use and cannot be assigned.
If the key combination is not already assigned to a command, the virtual keyboard updates to
show the new key assignment. A gray dot appears on a newly assigned key (or keys), and a color
is applied if the command belongs to a color-coded Command group.
If the key combination is already assigned to a command, Final Cut Pro displays the current
setting, and prompts you to confirm the change.
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5 To save your changes to the command set, click the Save button in the lower-right corner of the
Command Editor.
If you close the Command Editor with unsaved changes, Final Cut Pro prompts you to save
your changes.
Delete a command set
1 Choose Final Cut Pro > Commands > Customize (or press Option-Command-K).
2 If the command set that you want to delete is not shown, select a different command set from
the pop-up menu at the top of the Command Editor.
3 Choose Delete from the pop-up menu in the top-left corner of the Command Editor.
4 In the window that appears, click Delete.
The command set is removed.

Export and import command sets in the Command Editor
After you save a command set, you may want to export it to create a backup or to share the new
set with another user. Exported command sets are saved in a file that can be imported back into
Final Cut Pro at a later time.
Export a set of custom keyboard shortcuts
1 Choose Final Cut Pro > Commands > Customize (or press Option-Command-K).
2 If the command set that you want to export is not shown, select a different command set from
the pop-up menu at the top of the Command Editor.
3 Do one of the following:
••

Choose Final Cut Pro > Commands > Export.

••

Choose Export from the pop-up menu in the top-left corner of the Command Editor.

4 Type a name for the exported command set in the Save As field, and navigate to the location
where you want to save the exported set and click Save.
The file is saved in the location you chose, with the filename extension .commandset.
Import a command set
1 Do one of the following:
••

Choose Final Cut Pro > Commands > Import.

••

Open the Command Editor by choosing Final Cut Pro > Commands > Customize, and choose
Import from the pop-up menu in the upper-left corner of the Command Editor.

2 In the window that appears, navigate to the location where you’ve stored a command set file,
select it, and click Open.
If you’re already using a command set with the same name, a window appears and prompts you
to rename the command set.
The new command set is added to the Commands submenu of the Final Cut Pro menu and to
the pop-up menu in the Command Editor.
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Glossary

4:3 The aspect ratio for standard-definition (SD) broadcast video. The ratio of the width to the
height of the visible area of the video frame is 4:3, or 1.33. See also standard-definition (SD).
16:9 A widescreen aspect ratio for video. The ratio of the width to the height of the visible area
of the video frame is 16:9, or 1.78. The 16:9 aspect ratio is used for high-definition video. See also
high-definition (HD).
AAC (Advanced Audio Coding) Also called MPEG-4 Audio. A standard way of compressing and
encoding digital audio. AAC-encoded files rival the quality of audio CDs and generally sound as
good as or better than MP3 files encoded at the same or even a higher bit rate.
AC3 (Audio Codec 3, Advanced Codec 3, Acoustic Coder 3) A Dolby Digital compressed audio
format often used for encoding surround sound.
AIFF (Audio Interchange File Format) A cross-platform audio file format developed by Apple.
Like WAV files, AIFF files contain “chunks” of information such as the Sound Data Chunk, which
contains the actual sample data, and the Common Chunk, which contains sample rate and bit
depth information.
alpha channel An image channel in addition to the R, G, and B color channels that is used
to store transparency information for compositing. Alpha channels are often 8-bit, but some
applications support 16-bit alpha channels. In Final Cut Pro, black represents 100 percent
transparency, and white represents 100 percent opacity. Only certain formats, such as Targa, TIFF,
PNG, PSD, Apple ProRes 4444, and the QuickTime Animation codec, support alpha channels. See
also compositing, RGB.
Angle Editor You can open multicam clips in the Angle Editor to adjust the synchronization and
the angle order, or to add or delete angles. You can also use the Angle Editor to make edits to
the individual clips inside a multicam clip (such as trimming, making color corrections, adding
transitions, and so on). See also multicam clip.
Angle Viewer A viewer used to watch all angles of a multicam clip simultaneously while
switching or cutting to different angles in real time. You can cut and switch video and audio
at the same time or independently. For example, you can use the audio from angle 1 while
switching the video between angles 1 to 4. See also multicam clip.
Animation Editors See Audio Animation Editor, Video Animation Editor.
Apple ProRes Apple codecs that provide an unparalleled combination of multistream, realtime editing performance, impressive image quality, and reduced storage rates. Apple ProRes
codecs take full advantage of multicore processing and feature fast, reduced-resolution decoding
modes. All Apple ProRes codecs support any frame size (including SD, HD, 2K, and 4K) at full
resolution. The data rates vary based on codec type, image content, frame size, and frame rate.
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Apple ProRes 4444 XQ The highest-quality version of Apple ProRes for 4:4:4:4 image sources
(including alpha channels), with a very high data rate to preserve the detail in high-dynamicrange imagery generated by today’s highest-quality digital image sensors. Apple ProRes 4444 XQ
preserves dynamic ranges several times greater than the dynamic range of Rec. 709 imagery—
even against the rigors of extreme visual effects processing, in which tone-scale blacks or
highlights are stretched significantly. Like standard Apple ProRes 4444, this codec supports up to
12 bits per image channel and up to 16 bits for the alpha channel. Apple ProRes 4444 XQ features
a target data rate of approximately 500 Mbps for 4:4:4 sources at 1920 x 1080 and 29.97 fps.
Apple ProRes 4444 An extremely high-quality version of Apple ProRes for 4:4:4:4 image
sources (including alpha channels). This codec features full-resolution, mastering-quality 4:4:4:4
RGBA color and visual fidelity that is perceptually indistinguishable from the original material.
Apple ProRes 4444 is a high-quality solution for storing and exchanging motion graphics and
composites, with excellent multigeneration performance and a mathematically lossless alpha
channel up to 16 bits. This codec features a remarkably low data rate compared to uncompressed
4:4:4 HD, with a target data rate of approximately 330 Mbps for 4:4:4 sources at 1920 x 1080 and
29.97 fps. It also offers direct encoding of, and decoding to, both RGB and Y’CBCR pixel formats.
Apple ProRes 422 HQ A higher-data-rate version of Apple ProRes 422 that preserves visual
quality at the same high level as Apple ProRes 4444, but for 4:2:2 image sources. With
widespread adoption across the video post-production industry, Apple ProRes 422 HQ offers
visually lossless preservation of the highest-quality professional HD video that a single-link
HD-SDI signal can carry. This codec supports full-width, 4:2:2 video sources at 10-bit pixel depths,
while remaining visually lossless through many generations of decoding and reencoding. The
target data rate of Apple ProRes 422 HQ is approximately 220 Mbps at 1920 x 1080 and 29.97 fps.
Apple ProRes 422 A high-quality compressed codec offering nearly all the benefits of Apple
ProRes 422 HQ, but at 66 percent of the data rate for even better multistream, real-time editing
performance. The target data rate of Apple ProRes 422 is approximately 147 Mbps at 1920 x 1080
and 29.97 fps.
Apple ProRes 422 LT A more highly compressed codec than Apple ProRes 422, with roughly 70
percent of the data rate and 30 percent smaller file sizes. This codec is perfect for environments
where storage capacity and data rate are at a premium. The target data rate of Apple ProRes 422
LT is approximately 102 Mbps at 1920 x 1080 and 29.97 fps.
Apple ProRes 422 Proxy An even more highly compressed codec than Apple ProRes 422
LT, intended for use in offline workflows that require low data rates but full-resolution video.
The target data rate of Apple ProRes 422 Proxy is approximately 45 Mbps at 1920 x 1080 and
29.97 fps.
aspect ratio A film or video frame’s width-to-height ratio on any viewing screen. Standarddefinition (SD) video (used for regular television screens) has an aspect ratio of 4:3. Highdefinition (HD) video has an aspect ratio of 16:9.
Audio Animation Editor You can show the Audio Animation Editor for clips in the Timeline
to adjust effect parameters, create fade-ins or fade-outs, or change effects over time
using keyframes.
audio components Audio files can contain a single audio channel or multiple audio channels.
Final Cut Pro automatically groups audio channels into audio components according to how the
channels are configured for the clip. In Final Cut Pro, you can expand the audio portion of clips to
view and edit audio components down to the individual channel level.
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audio sample rate The number of times an audio signal is measured, or sampled, per second. A
higher sample rate produces higher-quality audio and larger file sizes, and a lower sample rate
produces lower-quality audio and smaller file sizes.
Audio Units The standard real-time audio filter format for audio applications used with OS X.
audio waveforms Audio waveforms are visual representations of the actual sound. An audio
waveform’s amplitude and length change according to the underlying sound’s volume and
duration. A short, loud sound such as a drum beat has a sharp, peaked waveform, whereas lowlevel crowd noise has a lower, more uniform waveform. These properties make it easier to find
specific edit points when trimming clips or keyframing effects.
audition In Final Cut Pro you can organize related clips into sets, called auditions, from which
you can choose one clip to use. You can create an audition composed of different clips to try out
multiple takes, or you can create an audition composed of multiple versions of the same clip to
preview different effects. Auditions appear in the Browser and Timeline as clips with an Audition
icon in the upper-left corner.
automatic audio sync The “Use audio for synchronization” option in the multicam clip creation
process makes precision sync adjustments using audio waveforms in the angles of a multicam
clip. This is the same audio sync technology that you can use to automatically analyze and sync
clips together into a compound clip.
AVCHD A high-definition (HD) video format that uses Advanced Video Coding (AVC)
compression (also known as MPEG-4 part 10 or H.264). Many Blu-ray players can play red laser
discs with AVCHD format content, making this a common way to distribute short HD video
projects using a standard red laser disc.
Background Tasks window The Background Tasks window shows the progress of importing,
transcoding, analysis, rendering, sharing, and other tasks.
batch Compressor uses a batch to contain one or more source media files that you want to
convert, or transcode, to another format. Each source media file creates its own job. This means
that a batch can contain multiple jobs, with each job based on its own source media file. Each
job also has at least one setting that defines the format of the transcoded file.
Bezier curves A parametric curve used to create smooth movement for keyframes and animated
objects in the Viewer. Bezier curves contain two kinds of points: smooth points with handles that
can be manipulated to curve the adjacent line segment, and corner points that have no handles
and therefore their adjacent line segments are straight (or linear).
bit rate The number of bits per second that makes up a digital video or audio asset. The higher
the bit rate, the better the quality. However, higher bit rates require larger file sizes.
Blade tool The editing tool that allows you to cut clips in the Timeline. You can select the Blade
tool by pressing the B key.
blue laser media Blu-ray burners and players use a blue laser when working with Blu-ray media.
The blue color has a shorter wavelength, making it possible to store more data on a disc when
compared to red lasers.
blue or green screening See chroma key.
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broadcast-safe Broadcast facilities have limits on the maximum values of luma and chroma that
are allowable for broadcast. If a video exceeds these limits, distortion can appear, resulting in
unacceptable transmission quality. You can use the Final Cut Pro video scopes to make sure that
the luma and chroma levels you set stay within acceptable limits.
B-roll A term used to describe alternate footage shot to intercut with the primary shots used in
a program. B-roll is frequently used for cutaway shots.
Browser The Browser displays the clips and projects for the item selected in the Libraries list.
You select clips or portions of clips in the Browser to work with them. Open projects by doubleclicking them in the Browser. You can sort or group items in the Browser by creation date, name,
and duration. You can also view your clips as filmstrips or in a list.
BWF (Broadcast Wave Format) An extension of the WAV file format that includes additional
metadata such as timecode and production information.
CAF (Core Audio Format) Apple’s Core Audio Format (CAF) is a flexible file format for storing
and manipulating digital audio data. It is fully supported by Core Audio APIs on Mac OS X v10.4
and later and on Mac OS X v10.3 with QuickTime 7 or later. CAF provides high performance and
flexibility, and is scalable to future ultra high-resolution audio recording, editing, and playback.
chroma The color information contained in a video signal, consisting of hue, which represents
the color itself, and saturation, which represents the intensity of the color.
chroma key A special effects technique that allows you to derive an alpha channel or matte
from the blue or green background of a video clip in order to make it transparent for the
purpose of compositing it against other clips. Blue-screen technology is what makes weather
forecasters appear to be standing against an animated map, when in reality they’re standing in
front of a blue wall. Also known as blue or green screening. See also alpha channel.
clip The term used to describe a video or audio asset, especially after it has been imported
into Final Cut Pro. Clips appear in the Browser, the Timeline, and the media browsers. Clips in
Final Cut Pro point to (link to) source media files stored on a disk. When you modify a clip, you
are not modifying the media file, just the clip’s information in Final Cut Pro. (This is known as
nondestructive editing.)
clipping Distortion occurring during the playback or recording of digital audio because of a
signal that exceeds the maximum sample value of 0 dBFS.
clip selection A selection of whole clips in the Browser or the Timeline. In contrast to a range
selection, a clip selection is limited to clip boundaries. You cannot adjust a clip selection to
include portions of clips. However, you can add or remove whole clips.
codec Short for compressor/decompressor, or encode/decode. A software component used to
translate video or audio from its current form to the digital compressed form in which it is
stored on a computer’s hard disk. DV, Photo JPEG, and Apple ProRes are common QuickTime
video codecs.
color balance Refers to the mix of red, green, and blue in a clip. In Final Cut Pro, you can adjust
the color balance of the highlights (bright areas), midtones, or shadows (dark areas) of your clip
using the Color Board.
color bars A standard color test signal displayed as columns, often accompanied by a reference
audio tone. Color bars are used to adjust the video signal of the incoming source to maintain
proper color from import through output.
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Color Board The Color Board allows you to manually adjust a clip’s color properties. It contains
separate panes for adding or subtracting a color tint, controlling the intensity of the color, and
controlling the brightness of the video. In addition to an overall control, each pane has individual
controls for the highlight, midtone, and shadow areas of the image.
color cast An unwanted color tint in the image, usually caused by lighting issues.
color correction A process in which the color of clips used in an edited program is evened out
so that all shots in a given scene match. Color correction is generally one of the last steps in
finishing an edited program. The color correction tools in Final Cut Pro give you precise control
over the look of every clip in your project by allowing you to adjust the color balance, black
levels, midtones, and white levels of individual clips.
color difference In video formats that store color information in the Y’CbCr color space, color
channels are derived by subtracting Y (luma) from the R (red) and B (blue) signals and are
sometimes referred to generally as B-Y and R-Y. See also Y’CbCr.
compositing A process in which two or more images are combined into a single frame. This
term can also describe the process of creating various video effects.
compound clip You can use compound clips to group any combination of clips in the Timeline
or the Browser, and nest clips within other clips. You can open any compound clip, edit its
contents in the Timeline, and then close it. Compound clips can contain video and audio clip
components, clips, and other compound clips. Effectively, each compound clip can be considered
a mini project, with its own distinct project settings. Compound clips function just like other
clips: you can add them to your project, trim them, retime them, and add effects and transitions.
compression The process by which video, graphics, and audio files are reduced in size. “Lossy”
compression refers to a process of reducing video file sizes through the removal of redundant
or less noticeable image data. Lossless compression reduces file sizes by mathematically
consolidating redundant image data without discarding it.
connected clip Connected clips are attached to clips in the primary storyline in the Timeline.
They are useful for cutaway shots, superimposed or composited images, and sound effects.
Connected clips remain attached and synchronized until you explicitly move or remove them. A
sequence of connected clips is a storyline.
contrast The difference between the lightest and darkest values in an image. High-contrast
images have a large range of values from the darkest shadow to the lightest highlight. Lowcontrast images have a more narrow range of values, resulting in a “flatter” look.
corner point A point with no curves applied in a Bezier path. Adjacent line segments are linear.
cross dissolve A common type of video transition, in which the first shot fades out while the
second shot simultaneously fades in. During the cross dissolve, the two shots are superimposed
as they fade.
crossfade A common type of audio transition, in which the first shot’s audio fades down while
the second shot’s audio simultaneously fades up. During the crossfade, audio from both shots
is heard.
cut An edit in which one clip immediately follows another, with no transition effect. This is the
simplest type of edit.
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cutaway shot A shot that is related to the current subject and occurs in the same time frame
(for example, an interviewer’s reaction to what is being said in an interview). Often, a cutaway
shot is used to eliminate an unwanted visual section of another shot. The audio usually remains
continuous during the cutaway, helping to make the edit less noticeable.
Dashboard The Dashboard appears in the center of the toolbar and provides a timecode display
as well as icons showing audio levels and the status of background tasks.
data rate The speed at which data can be transferred, often described in megabytes per second
(MB/sec.) or megabits per second (Mbps). The higher a video file’s data rate, the higher quality it
is, but the more system resources (processor speed, hard disk space, and performance) it requires.
Some codecs allow you to specify a maximum data rate for a movie during capture.
decibel (dB) Unit of measurement for sound levels; a logarithmic scale used to describe the
loudness of sound as perceived by the human ear. (1 dB corresponds to approximately the
smallest volume change that the average human ear can perceive.) For digital audio, dBFS is the
standard decibel unit of sound level measurement.
destination A set of preconfigured export settings that you can use to share a project or clip
from Final Cut Pro. Destinations make it easy to export your movie for viewing on Apple devices
such as iPad and iPhone, publish your movie to websites such as YouTube or Facebook, or burn
your movie to a disc. Final Cut Pro comes with a variety of destinations, and you can also modify
destinations and create new destinations. You add and modify destinations in the Destinations
pane of Final Cut Pro preferences.
Disk Utility Disk Utility is an Apple application that performs disk-related tasks in OS X. It’s
located in the Utilities folder inside the Applications folder.
downmixing The process used to combine multiple audio channels into a single stereo (or dual
mono) pair. Also referred to as mixing down.
downstream Refers to clips to the right of the current clip in the Timeline. When you perform
actions that ripple the project, downstream clips are affected; upstream clips are not.
drop frame timecode NTSC timecode that skips ahead in time by two frame numbers each
minute, except every tenth minute, so that the timecode agrees with the actual elapsed clock
time. (Timecode numbers are skipped, but actual video frames are not skipped.) This skipping
corrects for NTSC’s actual frame rate of 29.97 fps, which causes non-drop frame timecode to lag
behind actual elapsed time by 3 seconds and 18 frames per hour. To avoid confusion, drop frame
timecode should be avoided in film-based productions. See also non-drop frame timecode.
drop shadow An effect that creates an artificial shadow behind an image. Typically used with
graphics and text.
DV A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1
compressed component video signal with 4:1:1 color sampling (PAL uses 4:2:0). Supports two
tracks of audio with 16-bit, 48 kHz audio sampling, or four tracks of audio with 12-bit, 32 kHz
audio sampling.
DVCAM A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1
compressed component video signal with 4:1:1 color sampling (PAL uses 4:2:0). Supports two
tracks of audio with 16-bit, 48 kHz audio sampling, or four tracks of audio with 12-bit, 32 kHz
audio sampling.
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DVCPRO A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1
compressed component video signal using 4:1:1 color sampling (PAL uses 4:2:0). Supports two
tracks of audio with 16-bit, 48 kHz audio sampling.
DVCPRO50 A standard-definition (SD) digital videotape recorder format that records an 8-bit,
3.3:1 compressed component video signal with 4:2:2 color sampling. Supports four tracks of
audio with 16-bit, 48 kHz audio sampling.
DVCPRO HD A high-definition (HD) video format that records an 8-bit, compressed component
video signal with 4:2:2 color sampling. Both 720p and 1080i are supported. Includes up to eight
tracks of audio with 16-bit, 48 kHz audio sampling. The total data rate is 115 Mbps.
DVD A disc that is the size of a CD but that uses higher-density storage methods to significantly
increase its capacity. Although usually used for video distribution, DVD-ROM discs can also be
used to store computer data.
dynamic range The difference, in decibels, between the loudest and softest parts of a recording.
ease in An effect in which an object in motion decelerates slowly until it comes to a stop, rather
than ending its movement abruptly. This simulates the effect of friction in the real world and
generally creates a more natural, organic-looking effect than a linear movement would.
ease out An effect in which an object in motion accelerates from its starting position slowly
rather than beginning its movement at full speed. This simulates the effect of inertia and friction
in the real world and generally creates a more natural, organic-looking effect than a linear
movement would.
editing tools The seven tools from which you can choose when you’re working in the Timeline:
Select tool, Trim tool, Position tool, Range Selection tool, Blade tool, Zoom tool, and Hand tool.
When you choose a tool, the pointer changes to the icon for that tool.
edit point Edit points define the part of a clip you want to use in an edited project. Edit points
include start points, which specify the beginning of a section of a clip or project, and end points,
which specify the end of a section of a clip or project. An edit point is also a point in the Timeline
where the end point of one clip meets the start point of the next clip. This edit point can be
selected for various operations.
Effects Browser A media browser in Final Cut Pro that contains video and audio clip effects.
equalization An equalizer (commonly abbreviated as EQ) shapes the sound of incoming audio
by changing the level of specific frequency bands. Equalization is one of the most commonly
used audio processes, both for music projects and in video post-production work. You can use
EQ to subtly or significantly shape the sound of an audio file, instrument, or project by adjusting
specific frequencies or frequency ranges.
event When you import video, audio, and still images, or record directly into Final Cut Pro, the
source media files (your raw footage) are stored in events. An event is similar to a folder that can
hold dozens, hundreds, or even thousands of video clips, audio clips, and still images, as well as
projects. Each event in the library refers to media on your hard disk, and a database file keeps
track of where everything is.
Event Viewer The Event Viewer is a separate video display that appears next to the main Viewer
and is used to play clips in the Browser only.
exposure The amount of light in video or film images. Exposure affects the overall brightness of
the image as well as its perceived contrast.
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fade A common type of transition in both video and audio. For video, a fade-out begins with
a shot at full intensity and reduces until it is gone. A fade-in begins with a shot at no intensity
and increases to full intensity. These are the common “fade to black” and “fade up (from black)”
transitions. Audio fade-ins begin with silence and increase to full volume, and fade-outs begin at
full volume and decrease to silence.
filmstrip Your video clips appear as filmstrips in the Timeline (where you build projects) and
in the Browser (where your source media is displayed). A single video filmstrip might represent
several seconds of video encompassing hundreds of video frames (individual images). Audioonly clips appear as audio waveforms, showing the change in the audio volume over time.
FireWire The trademarked Apple name for the IEEE 1394 standard. A fast and versatile interface
used to connect DV camcorders to computers. FireWire is well suited to applications that move
large amounts of data, and it can also be used to connect hard disks, scanners, and other kinds of
computer peripherals.
Foley effects Foley effects are custom sound effects that are heavily synchronized to picture,
such as footsteps on different surfaces, clothes rustling, fight sounds, and the handling of various
noisy objects. Final Cut Pro includes a number of built-in Foley and other sound effects that you
can insert as connected audio clips.
frame A single still image. Film and video are made up of a series of these images. Although a
film frame is a single photographic image, an interlaced video frame contains two fields. See also
interlaced video, non-interlaced video.
frame blending Duplicating frames to create slow motion can result in a strobing, jittery effect.
To minimize this, you can turn on Frame Blending in the Retime pop-up menu in the toolbar.
Frame blending creates new in-between frames, each a composite of two neighboring frames.
frame rate The number of images photographed per second for a video clip.
frame size See resolution.
frequency The number of times a sound or signal vibrates each second, measured in cycles per
second, or hertz (Hz). Audio recordings are made up of a vast collection of waveforms, using
many different frequencies of sound. Each frequency in a recording is associated with an audio
pitch. For example, the note generated by each key of a piano has a specific frequency.
Front Row Front Row, an application that comes with OS X, is a way to navigate through your
iTunes, iLife, and Final Cut Pro media using an Apple remote control or the Remote app. You can
also open Front Row by pressing Command-Escape.
gain The amount an audio or video signal is boosted. In video, this increases the white level; in
audio, this increases the volume.
gamma A curve that describes the intensity of an image. Gamma is a nonlinear function often
confused with brightness or contrast. Gamma adjustment is often used to compensate for
differences between Mac and Windows video graphics cards and displays.
gap clip A blank clip (containing blank video and silent audio) that you can adjust to any
duration. (The film industry term for this is slug.) Gap clip color is determined by the current
background color in Final Cut Pro. You can adjust the background color using the Player
Background pop-up menu in the Playback pane of the Final Cut Pro Preferences window.
generators Clips that are synthesized by Final Cut Pro. Generators can be used as different kinds
of backgrounds, titles, and elements for visual design.
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Generators Browser A media browser in Final Cut Pro that provides access to all video
generators included with Final Cut Pro.
Hand tool The editing tool that allows you to scroll in the Timeline. You can select the Hand tool
by pressing the H key.
H.264 H.264/MPEG-4 Part 10 or AVC (Advanced Video Coding) is a video compression standard
in widespread use for recording, distribution, and Internet streaming of high-definition video.
HDCAM A high-definition (HD) digital videotape recorder format that records an 8-bit, 7.1:1 DCTcompressed component video signal with 3:1:1 color sampling. Recorded using 1/2-inch tape.
Supports four tracks of audio.
HDV A format for recording high-definition video on DV tape. HDV uses MPEG-2 video
compression with 8-bit samples and 4:2:0 chroma subsampling. HDV has a video bit rate of 18.3
Mbps for 720p (1280 x 720) and a bit rate of 25 Mbps for 1080i (1440 x 1080).
high-definition (HD) Refers to any video with a higher resolution than standard-definition NTSC
or PAL video. The most common high-definition resolutions are 1280 x 720 (720p) and 1920 x
1080 (1080i or 1080p). See also NTSC format, PAL format, standard-definition (SD).
Histogram A video scope in Final Cut Pro that provides a statistical analysis of the image by
graphing the number of pixels at each percentage of luma or color. It’s useful for comparing two
clips in order to match their brightness values more closely.
hue An attribute of color perception, also known as color phase. Red, blue, yellow, and green are
all hues.
import The process of bringing media files of various types into events in Final Cut Pro. You can
import files from connected camcorders and other devices, other applications, or connected
storage devices.
IMX A standard-definition (SD), all-I-frame MPEG-2 format stored on tape, XDCAM optical disc, or
disk drive. Some IMX decks can play back and convert formats such as Digital Betacam, Betacam
SX, and Betacam SP to IMX. The data rate of IMX can be set to 30, 40, or 50 Mbps.
incoming clip The clip to which a transition segues. For example, if Clip A dissolves to Clip B, Clip
B is the incoming clip. See also outgoing clip.
Info inspector The Info inspector displays information (called metadata) about a clip or group
of clips selected in either the Browser or the Timeline. You can display different combinations
of metadata with your clips, such as codecs, media start and end times, reel, scene, take, EXIF
information, and IPTC information. You can also use the Info inspector to change the metadata
for a selected clip or group of clips, and you can create custom sets of metadata for display using
the Metadata Views window, accessed from the Info inspector.
In point See edit point.
insert edit An insert edit places the source clip so that all clips after the insertion point are
moved forward (or rippled) in the Timeline to make room for the clip being added. No clips
are removed from your project. An insert edit makes the project longer by the duration of the
inserted clip.
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inspectors Final Cut Pro provides a number of inspectors you can use to view and change the
attributes of selected items. For example, you can adjust video effects and apply color corrections
in the Video inspector. Other inspectors include the Audio, Audio Enhancements, Info, Transition,
Title, Text, Generator, Library Properties, and Share inspectors. The inspectors appear in the
Inspector pane in the upper-right corner of the Final Cut Pro main window.
interlaced video A scanning method that divides a video frame into two fields, each consisting
of alternating odd and even lines that are scanned at different times.
IRE An analog video signal unit of measurement for luma, established by the Institute of
Radio Engineers.
J-cut See split edit.
job Each media file added to a batch in Compressor is a job. Each job has one media file and
one or more settings that define the type of file to render. See also batch.
JPEG A popular image file format that lets you create highly compressed graphics files. The
amount of compression used can be varied. Less compression results in a higher-quality image.
keyframe A control that denotes the value of a video or audio effect parameter at a particular
point in the project. When two keyframes with different values are set in Final Cut Pro, a
transition from one value to another is calculated, resulting in a dynamic change to that
parameter. The word keyframe comes from the traditional workflow in the animation industry,
where only important (key) frames of an animated sequence were drawn to sketch a character’s
motion over time. Once the keyframes were determined, an in-between artist drew all the frames
between the keyframes.
keying See chroma key, luma key.
Keyword Collection When you apply a keyword to a clip, a Keyword Collection is automatically
created in the event in the library. When you select the Keyword Collection, each clip tagged
with that keyword is displayed.
keywords Keywords add descriptive information to a clip or clip range. You can use keywords to
organize, sort, and classify media. You can add keywords to a clip manually, and Final Cut Pro can
also add keywords automatically during import or clip analysis. See also Keyword Collection.
L-cut See split edit.
Libraries list The area of the Final Cut Pro sidebar that lists the libraries and events that contain
your imported media (video, audio, and still images) and your projects. When you select an event
or a library in the Libraries list, its media appears as clips in the Browser, and its projects appear
as thumbnails. The Libraries list is also the home for Final Cut Pro Keyword Collections and Smart
Collections, which provide a powerful way to organize your media using keywords and persistent
search filters.
linear editing Before digital video editing, programs were edited together by copying shots
from the original source tapes to a master tape, one by one. Because the assembly was linear, any
changes in duration made to an earlier point of the tape required reassembling the movie from
that point forward. See also nonlinear editing.
looping A playback mode in which clips and projects go back to the beginning whenever the
playhead reaches the end of the media. You can turn looping on or off from the View menu or by
pressing Command-L.
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lower third A television industry term for a graphic placed in the lower area of the screen,
usually to convey details about subjects or products. A common use of lower thirds is to identify
individuals on the screen with their names and job titles.
luma A value describing the brightness of a video image. A luma channel is a grayscale image
showing the range of brightness across the whole clip.
luma key An effect used to key out pixels of a certain luma value (or a range of luma values),
creating a matte based on the brightest or darkest area of an image. Keying out luma values
works best when your clip has a large discrepancy in exposure between the areas that you want
to key out and the foreground images you want to preserve, such as a white title on a black
background. See also chroma key, matte.
Mail Mail is the email application that comes with OS X.
markers Markers flag a specific location in a clip with editing notes or other descriptive
information. You can also use markers for task management. Markers are classified as standard
markers (blue), chapter markers (orange), to-do items (red), or completed to-do items (green).
mask An image or clip used to define areas of transparency in another clip. Similar to an alpha
channel. The color correction tools can create masks based on a color you choose or a shape you
create. See also alpha channel.
matte Sometimes referred to as a holdout matte. An effect that uses information in one layer of
video to affect another layer. Mattes are useful when you want to use one clip to selectively hide
or reveal part of another; for example, you could use a round spotlight shape to reveal parts of
a video layer. Matte effects can be used by themselves to mask out areas of a clip or to create
alpha channel information for a clip in order to make a transparent border around the clip that
can be composited against other layers. See also alpha channel, compositing.
media A generic term for elements such as movies, sounds, and pictures.
media browsers Media that you import into events in Final Cut Pro is accessed from the
Libraries list and the Browser, but Final Cut Pro also includes a collection of media browsers you
can use to add clips to your project. The media browsers provide access to the effects, titles, and
transitions supplied with Final Cut Pro as well as to video, audio, and still-image files in other
applications on your computer. For example, you can use the Photos Browser to access video and
still-image files in the iPhoto and Aperture libraries. Other media browsers include the Effects,
Music and Sound, Transitions, Titles, Generators, and Themes Browsers. The media browsers
appear in the Media Browser pane in the lower-right corner of the Final Cut Pro main window.
media handle Additional media available before a clip start point or after a clip end point.
media stems Audio or video files that are usually exported separately for audio mixing or postproduction, or to match specifications when delivering files to broadcast networks. For example,
you may need to deliver a multitrack QuickTime file along with separate dialogue, music, and
effects stems.
mixing The process of adjusting the audio levels of all audio clips in an edited program,
including the production audio, music, sound effects, voiceovers, and additional background
ambience, to turn all of these sounds into a harmonious whole.
monochrome An image presented in shades of a single color, most often as the shades of gray
in a black-and-white image.
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MP3 Refers to the MPEG-1 or MPEG-2 Audio Layer 3 compression standard and file format. Like
AAC, MP3 uses perceptual audio coding and psychoacoustic compression to remove superfluous
information that the human ear doesn’t hear.
MPEG (Moving Picture Experts Group) A group of compression standards for video and audio,
which includes MPEG‑1, MPEG‑2, and MPEG‑4.
multicam clip A set of clips grouped together and synchronized by a common sync point. You
can use multicam clips to edit footage from multicamera shoots or other synchronized footage
in real time. While the active angle plays in the Viewer, you can also view all angles playing
simultaneously in the Angle Viewer and easily cut and switch between them.
Music and Sound Browser A media browser in Final Cut Pro that allows you to access your
iTunes content as well as sound effects and loops from Final Cut Pro and iLife.
nested sequence See compound clip.
NLE Short for nonlinear editor. See also nonlinear editing.
nondestructive editing No matter how you edit clips in Final Cut Pro, the underlying media is
never touched. This is known as nondestructive editing, because all of the changes and effects you
apply to your footage never affect the original source media files. Clips represent your media,
but they are not the media files themselves. The clips in a project simply point to (link to) the
source media files on your hard disk. When you modify a clip, you are not modifying the media
file, just the clip’s information in the project. Trimmed or deleted pieces of clips are removed from
your project only, not from the source clips in your library or from the source media files on your
hard disk.
non-drop frame timecode Timecode in which frames are numbered sequentially and no
timecode numbers are dropped from the count. When discussing NTSC video, the video frame
rate is actually 29.97 fps, and non-drop frame timecode is off by 3 seconds and 18 frames per
hour in comparison to actual elapsed time. See also drop frame timecode.
non-interlaced video The standard representation of images on a computer. Also referred to as
progressive scan. The monitor displays the image by drawing lines, one after another, from top
to bottom.
nonlinear editing A video editing method in which edits within a program can be changed
at any time without having to re-create the entire program. When you use a nonlinear editing
application to edit a program, all footage used is stored on a hard disk rather than on tape. This
allows random access to all video, audio, and images as you edit. See also linear editing.
NTSC format The video standard defined by the National Television Standards Committee, the
organization that originally defined North American broadcast standards. Analog NTSC video has
525 interlaced lines per frame, a frame rate of 29.97 fps, and a limited color gamut. Digital NTSC
video has a frame size of 720 x 486 pixels (720 x 480 for DV and DVD), and a frame rate of 29.97
fps. See also PAL format.
offline editing A post-production process in which raw footage is copied and edited without
affecting the original camera media (film, tape, or file-based media). After a program has been
completed in the offline edit (typically using proxy media at a lower resolution), an online edit is
performed to re-create the edit using the original media.
opacity The level of a clip’s transparency.
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outgoing clip The clip a transition segues from. For example, if Clip A dissolves to Clip B, Clip A is
the outgoing clip. See also incoming clip.
Out point See edit point.
overwrite edit In an overwrite edit, one or more source clips overwrite any clips in the primary
storyline or a selected storyline, starting at a range selection start point or at the skimmer or
playhead position. No clip items are rippled forward, so the duration of your project remains the
same. Overwriting is purely duration-based and works on range selections only, irrespective of
clip boundaries.
PAL format Acronym for Phase Alternating Line, a 25 fps (625 lines per frame) interlaced video
format used by many European countries. Digital PAL video has a frame size of 720 x 576. See
also NTSC format.
Photos Browser A media browser in Final Cut Pro that allows you to access your iPhoto and
Aperture photo libraries.
pitch Sounds are perceived as high or low depending on their frequency, or the number of
times per second a sound wave cycles from positive to negative and back to positive. The word
that musicians most commonly use for frequency is pitch. The higher the frequency, the higher
the pitch. Modifying the speed of a clip affects the pitch of the audio. Slow motion creates low
pitch, and fast motion creates high pitch.
pixel One dot in a video or still image. The more pixels in an image, the higher the resolution.
playhead The playhead marks your project’s current position in the Timeline or the Browser. You
can move the playhead by dragging it or clicking another area of the Timeline or Browser. You
use the playhead to scrub, or move through your project and play it back from different locations.
The playhead appears as a gray vertical line that is fixed in place unless you move it or click
elsewhere. See also skimmer.
Position tool The editing tool that allows you to place items in the Timeline. You can select the
Position tool by pressing the P key.
post-production The phase of film or video editing in which all of the production elements are
organized, assembled, and output.
project A project provides a record of your editing decisions and the media you use. You build
your project by adding clips and editing them in the Timeline. A project is also defined by
its video, audio, and render properties. In most cases, Final Cut Pro manages project settings
automatically based on the properties of the first clip you add to a project.
project properties A project’s video, audio, and render properties. In most cases, Final Cut Pro
manages a project’s properties automatically based on the properties of the first clip you add to
a project. If you must modify the project properties, choose video and audio project properties
based on how you intend to share your final movie with your audience. You set a project’s
properties when you create a Final Cut Pro project, and you can change them at any time.
proxy files You can use Final Cut Pro to transcode your original media to create proxy files,
which are smaller files with a lower data rate. Proxy files can be used for offline editing or for
editing when using a slower computer. Final Cut Pro creates video proxy files using the Apple
ProRes 422 Proxy codec, and still-image proxy files using the JPEG format (if the original file
doesn’t have alpha channel information) or the PNG format (if the file has alpha channel
information). See also alpha channel.
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QuickTime Cross-platform multimedia technology from Apple. Widely used for production, postproduction, and distribution of video, audio, and interactive programs.
range Instead of selecting whole clips, you can select a range within any clip in the Timeline or
the Browser. You can trim range selections, mark them with ratings and keywords, and modify
them in other ways. You can adjust the range start and end points by dragging either side of the
selection. In the Timeline, you can also select a range that spans multiple clips. In the Browser,
you can set multiple ranges within one or more clips, and you can select and deselect ranges
after you set them.
Range Selection tool The editing tool that allows you to select a range in the Timeline. You can
select the Range Selection tool by pressing the R key.
Rec. 709 Short for ITU-R Recommendation BT.709, the standard broadcast format for
high-definition television.
red laser media Traditional DVD burners and players use a red laser when working with DVD
media. Blu-ray burners and players use a blue laser when working with Blu-ray media. The blue
color has a shorter wavelength, making it possible to store more data on a disc when compared
to red lasers.
render To process video and audio with any applied effects or transitions, and store the result on
disk as a render file. These render files are stored with your Final Cut Pro event and project files.
When you publish or export a project, it is similarly rendered to create the output files.
replace edit In a replace edit, a source selection replaces a clip in your project in the Timeline.
In contrast to overwrite edits, replacing works on whole Timeline clips only and can change the
duration of your project.
resolution Image resolution refers to the number of pixels in an image. Resolution is expressed
in terms of the width and height of the image in pixels (for example, 640 x 360 pixels). Higherresolution images contain more detail but also create larger files that take longer to download.
Your electronic devices (computer, iPhone, iPad, iPod, and so on) also have screen resolution.
Ideally, you should match the image resolution of your media to the resolution of your
playback device.
reverb Reverberation, or reverb, refers to the reflection pattern created by bouncing sound
waves off the surfaces—walls, ceilings, windows, and so on—of any space, or off objects within
a space, gradually dying out until they are inaudible. Final Cut Pro includes a variety of audio
effects that add reverb to the sound of a clip.
RGB Abbreviation for Red, Green, Blue. A color space commonly used on computers, in which
each color is described by the strength of its red, green, and blue components. This color space
directly translates to the red, green, and blue phosphors used in computer displays. The RGB
color space has a very large gamut, meaning it can reproduce a very wide range of colors. This
range is typically larger than the range that can be reproduced for broadcast.
ripple edit The default type of trim in Final Cut Pro is a ripple trim, which adjusts a clip’s start
point or end point without leaving a gap in the Timeline. The change in the clip’s duration ripples
outward, moving all subsequent clips earlier or later in the Timeline. Similarly, if you delete a
clip from the Timeline, subsequent clips ripple earlier to close the gap. Ripple edits affect the
trimmed clip, the position of all subsequent clips in the Timeline, and the total duration of
your project.
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roles Metadata text labels that you assign to clips in the Browser or the Timeline. Roles provide
a flexible and powerful way to manage your editing workflow. You can use roles in Final Cut Pro
to organize clips in your events and projects, control the appearance of the Timeline, and export
separate video or audio files (also known as media stems) for broadcast delivery, audio mixing, or
post-production.
roll edit An edit that affects two clips that share an edit point. For example, if Clip A cuts to Clip
B, a roll edit simultaneously adjusts the end point of Clip A and the start point of Clip B by the
same amount. The overall duration of the project stays the same.
rough edit The first editing pass. The rough cut is an early version of a movie that pulls together
its basic elements. Often, a rough edit is performed prior to adding transitions, titles, and
other effects.
saturation A measurement of the intensity of color in the video signal.
scene A series of shots that take place at the same time in the same location. A series of scenes
make up a program.
Select tool The default arrow-shaped pointer that allows you to select items in the Timeline. For
example, you use it to select a clip or edit point. You can select the Select tool by pressing the
A key.
sequence See project, Timeline.
shortcut menu A menu you access by holding down the Control key and clicking an item on
the screen, or by pressing the right mouse button. Sometimes called a contextual menu.
shot A segment of continuously recorded video. A shot is the smallest unit of a program.
skimmer The skimmer lets you preview clips in the Timeline and the Browser without affecting
the playhead position. You use the skimmer to skim, or freely move over clips to play back at
the position and speed of the pointer. The skimmer appears as a pink vertical line as you move
the pointer over the area you’re skimming. If you have snapping turned on, the skimmer turns
orange when it snaps to a position.
slate A shot at the beginning of a scene, which identifies the scene with basic production
information such as the take, date, and scene number. A clapper provides an audiovisual cue for
synchronization when video and audio are recorded separately.
slide edit An edit in which an entire clip is moved, along with the edit points on its left and
right. The duration of the clip being moved stays the same, but the clips to the left and right of
it change in length to accommodate the new position of the clip. The overall duration of the
project and of these three clips remains the same.
slip edit An edit in which the location of both start and end points of a project clip are changed
at the same time, without changing the position or duration of the clip. This is referred to as
slipping, because you slip the clip’s start and end points inside the available footage. The portion
of the clip seen in the project changes, but its position in the Timeline stays the same.
Smart Collection When you search for clips in an event using the Filter window, you can save
your results by creating a new Smart Collection that gathers clips matching the search criteria.
Whenever a new clip that matches the Smart Collection’s search criteria is brought into the
event, the new clip is automatically added to the Smart Collection. Clips that appear in Smart
Collections are not duplicates. Smart Collections filter clips in an event to help you focus on the
clips you need to use for a specific task.
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snapping When the snapping feature is turned on in Final Cut Pro, items you move in the
Timeline (including the playhead, the skimmer, and selected clips) appear to jump, or “snap,”
directly to certain points in the Timeline. This can help you quickly line up edits with other
items in the project. Snapping affects the functions of many of the editing tools in Final Cut Pro,
including the Select tool, the Trim tool, the Position tool, the Range Selection tool, and the Blade
tool. You can disable snapping when frame-by-frame precision editing is required.
sound effects Specific audio material, such as the sound of a door closing or a dog barking, from
effects libraries or from clips you recorded. Sound effects can be used to replace sounds in the
location audio of a program, or to add sound that wasn’t originally recorded.
source media files The original files (video, audio, and still images or graphics) that you import
into Final Cut Pro. A clip you use in Final Cut Pro points to the location where the source media
file is stored (either on a disk or on a camcorder, camera, or device). Changes made to clips
within Final Cut Pro do not affect the source media files.
special effects Visual effects applied to clips and projects, such as motion effects, compositing,
keying, and retiming effects.
spill suppression Spill suppression is a color correction operation that applies the
complementary (opposite) color of the color that’s being made transparent to neutralize any
green or blue fringing or light bounce that’s tinting the subject being keyed. The Spill Level slider
controls how much spill suppression is applied to the keyed subject.
split edit Final Cut Pro allows you to set separate video and audio start and end points in an
individual clip. These edits, known as split edits, are a common technique in most dialogue scenes
in films and television shows. You can use split edits to introduce the sound of a new shot or
scene before cutting to the video of that shot or scene. Conversely, you can use a split edit to
extend the audio of a shot over a subsequent shot.
standard-definition (SD) Refers to the original NTSC and PAL video frame sizes. NTSC uses 480
or 486 active lines per frame, and PAL uses 576 active lines. See also high-definition (HD).
stereo Short for stereophonic, in which audio contains two different channels. Audio level
changes are automatically made to both channels at the same time.
storylines All instances of the Timeline contain a primary storyline, which is the main sequence
of clips that you build to create your movie. Storylines are sequences of clips connected to the
primary storyline. You can use storylines for the same purposes as connected clips (such as
creating cutaways, compositing titles and other graphics, and adding sound effects and music).
straight cut A cut in which both the video and audio clip items are cut at the same time.
subframe A subframe has 1/80 the duration of a video frame and is thus a more precise unit of
reference when editing audio at the sample level.
sync (synchronization) The relationship between the image of a sound being made in a video
clip (for example, a person talking) and the corresponding sound in an audio clip. Maintaining
audio sync is critical when editing dialogue. In Final Cut Pro X, connected clips and compound
clips help maintain sync in your program.
Themes Browser A media browser in Final Cut Pro that provides access to all transitions and title
effects supplied with Final Cut Pro, grouped into related themes.

Glossary

492

three-point editing An editing technique in which three out of four edit points are set in a
source selection and a project. When the edit is performed, the fourth edit point is calculated
automatically by Final Cut Pro.
through edit An edit point in which the video or audio content on either side of the edit
is continuous.
TIFF (Tagged Image File Format) A widely used bitmapped graphics file format, developed by
Aldus and Microsoft, that handles monochrome, grayscale, 8- and 24-bit color. Can have alpha
channels. See also alpha channel.
timecode A signal recorded with your video that uniquely identifies each frame. By default,
timecode appears in Final Cut Pro in the format hours: minutes: seconds: frames. Timecode
supports a variety of functions in Final Cut Pro, including Timeline playback, synchronizing
video and audio clip items, navigating through projects in the Timeline, and moving and
trimming clips.
Timeline The bottom portion of the Final Cut Pro window contains the Timeline, where you
create your movie project by adding and arranging clips and making all your edits.
Timeline Index You can view a text-based, chronological list of the clips, keywords, and markers
in a project using the Timeline Index. When you select an item in the Timeline Index, the
playhead jumps to that item in the Timeline.
tint A color shade added to an image, usually to create an effect, such as sepia.
Titles Browser A media browser in Final Cut Pro that provides access to all the title effects
included with Final Cut Pro.
toolbar The toolbar is a collection of buttons and tools located in the middle of the Final Cut Pro
main window. The toolbar also includes the Dashboard, which displays the timecode for the clip
selected in the Browser and for the playhead’s position in the Timeline.
transcode All media files use a format. Video format examples include DV, H.264, and MPEG-2.
Video files also have a variety of properties, such as video frame size and frame rate, data rate,
and audio sample rate. When you need to convert a media file to a different format or change its
properties, you transcode it to the new format or properties. Compressor, an Apple application
designed to work with Final Cut Pro, makes transcoding media files a fast and easy process.
transitions Effects that are applied to edit points to smooth out a change from clip to clip. In
Final Cut Pro, you can choose from a variety of video transitions, such as a dissolves or wipes, or
you can add an audio crossfade between audio clips.
Transitions Browser A media browser in Final Cut Pro that provides access to all the video
transitions included with Final Cut Pro.
trim After you’ve assembled your clips in rough chronological order in the Timeline, you begin
to fine-tune the cut point (or edit point) between each pair of contiguous clips. Any time you
make a clip in a project longer or shorter, you’re trimming that clip. However, trimming generally
refers to precision adjustments of anywhere from one frame to several seconds. If you’re
adjusting clip durations by much larger amounts, you’re still trimming, but you may not be in
the fine-tuning phase of editing yet. In Final Cut Pro, you can use a variety of techniques to trim
Timeline clips and edit points, including ripple edits, roll edits, slip edits, and slide edits.
Trim tool The editing tool that allows you to trim items in the Timeline. You can select the Trim
tool by pressing the T key.
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uncompressed 8- and 10-bit 4:2:2 These video formats can be used to store 8-bit or 10-bit
4:2:2 Y’CbCr video without employing data compression. Bypassing compression reduces the
computer’s processing load but increases the data rate considerably. A large-capacity RAID
storage system is typically required to work effectively with uncompressed video. In many cases,
Apple ProRes is a better choice. The data rate of uncompressed 4:2:2 video varies according to
frame size and frame rate. As an example, at a frame size of 1920 x 1080 and a frame rate of 29.97
fps, the data rate is 1.0 Gbps for uncompressed 8-bit 4:2:2 video and 1.3 Gbps for uncompressed
10-bit 4:2:2 video.
Upstream Refers to clips that are to the left of the current clip in the Timeline. When you
perform actions that ripple the project, upstream clips are not affected.
value slider A value slider is a type of numerical slider control that appears as a number, often
to the right of a basic slider. There are two ways to adjust a value slider: by dragging over the
number to decrease or increase the parameter value, or by double-clicking the number and
entering a new value.
variable speed Speed that varies dynamically, in forward or reverse motion, in a single clip.
VCR Abbreviation for videocassette recorder. Generally refers to consumer equipment used for
recording video from various sources. Sometimes referred to as a VTR. See also VTR.
Vectorscope A video scope in Final Cut Pro that shows the distribution of color in your image on
a circular scale. The Vectorscope is useful for comparing the hue and intensity of colors between
two clips for the purposes of color correction.
Video Animation Editor You can show the Video Animation Editor for clips in the Timeline
to adjust effect parameters, create fade-ins or fade-outs, or change effects over time
using keyframes.
Viewer When you play clips selected in the Browser and the Timeline, they appear in the Viewer.
VTR Abbreviation for videotape recorder. Generally refers to professional equipment used for
recording video from various sources.
watermark A visible graphic or text overlay applied to an image or video clip to indicate that it
is protected by a copyright. Watermarks are used to discourage the use of images or video clips
without the copyright holder’s explicit permission.
WAVE (or WAV) An audio file format most commonly used for storing uncompressed linear
pulse code modulation (LPCM) audio data.
Waveform Monitor A video scope in Final Cut Pro that displays the relative levels of luma
and chroma in the clip currently being examined. Spikes and dips in the displayed waveforms
correspond to light or dark areas in your picture.
widescreen Any movie presentation that has an aspect ratio wider than 4:3. In movie theaters,
1.85 is considered standard and 2.40 is considered widescreen. For video, 4:3 is considered
standard and 16:9 (which is almost the same aspect ratio as 1.85) is considered widescreen. See
also 4:3, 16:9.
wipe A common type of video transition. In a wipe, the screen splits, moving from one side
of the image to the other to gradually reveal the next shot. A wipe is more obvious (and
customizable) than a fade or cross dissolve.
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XDCAM Sony optical disc format for recording DVCAM and IMX video within MXF container files.
See also DVCAM, IMX.
XDCAM EX A member of the Sony XDCAM product family that uses MPEG-2 video compression
with 4:2:0 chroma sampling. In contrast to XDCAM HD, XDCAM EX supports 720p and records
full HD resolution (either 1920 x 1080 or 1280 x 720). Its maximum bit rate is 35 Mbps. Instead
of optical discs, XDCAM EX camcorders use solid-state memory cards known as SxS cards. See
also HDV.
XDCAM HD422 A member of the Sony XDCAM product family featuring 4:2:2 chroma sampling
and a video bit rate of 50 Mbps. Like XDCAM EX, it uses MPEG-2 video compression at full HD
resolution (either 1920 x 1080 or 1280 x 720). See also HDV.
Y’CbCr The color space in which many digital video formats store data. Three components are
stored for each pixel—one for luma (Y) and two for color information (Cb for the blue difference
signal and Cr for the red difference signal). Also referred to as YUV. See also pixel.
Zoom tool The editing tool that allows you to zoom in to or out of the Timeline. You can select
the Zoom tool by pressing the Z key.
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