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What’s new in Logic Pro X
Logic Pro X includes major new features and enhancements, briefly described below:

User interface
Modern interface: The Logic Pro X interface is redesigned for increased functionality. The transport 
controls are now at the top of the window for better visibility and access, the Library is relocated 
next to the track headers, and multiple tracks can now be selected and moved in one operation. 
Menus are reorganized and streamlined, and there are a host of other ergonomic improvements. 
Groups of features can be turned on or off in the Advanced preferences pane, letting you 
optimize the interface to suit your way of working.

Quick Help: View brief descriptions of windows, controls, and other elements of the Logic Pro 
interface without leaving the application or interrupting your workflow. You can view Quick Help 
either in the inspector, or in a movable floating window.

Projects
New project structure: In Logic Pro X, project assets can be saved directly in the project or in a 
project folder, and can also be referenced from a location outside the project. For information 
about handling project assets, see Manage project assets. You can also save project alternatives 
in different states, including different cuts or mixes, and go back to earlier, automatically saved 
versions of a project using backups.

New sharing options: You can share Logic Pro X projects to SoundCloud, and share them the 
Media Browser, to distribute and use with other applications on your Mac. For more information, 
see Sharing overview.

Auto Save: Logic Pro regularly saves your work in the background. In the event of an unplanned 
interruption, you can reopen your project with the latest changes and continue working.

Tracks area
Drummer: Select from a variety of virtual drummers, each with its own drum kit and playing style, 
to add to your projects. Adjust performance parameters including loudness, complexity, and kit 
piece focus for each Drummer region. Drummer can respond interactively to other tracks and 
regions in a project. For more information about Drummer, see Drummer overview.

Smart Controls: Quickly adjust the sound of a track using a set of visual screen controls. You 
can customize Smart Controls by mapping their screen controls to channel strip or plug-in 
parameters, then manipulate them using external MIDI hardware. For more information about 
using Smart Controls, see Smart Controls overview.

Track Stacks: Easily organize complex arrangements by collapsing multiple tracks into one. Create 
layered instruments with multiple software instruments. Create submixes to manage complex 
Mixer setups. For more information about working with Track Stacks, see Track Stacks overview.

What’s new in Logic Pro X 1
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Patches: Save and recall complex, multiple channel strip configurations along with their Smart 
Controls. Patches contain the instrument, effects, and routing settings that control the sound of a 
track. For information about patches, see Patches overview.

Arrangement track: Organize a project into sections, then move or copy the sections to build an 
arrangement. For information about using the arrangement track, see Add arrangement markers.

Groove tracks: Set one track in the project as the groove track, then select other tracks you want 
to follow the timing of the groove track. For more information, see Control timing with the 
groove track.

Editing
Flex Pitch: Manipulate pitch and other parameters of vocal and monophonic instrument 
recordings. You can make quick pitch corrections in the Tracks area, or use the full Flex Pitch 
functionality to quantize and edit pitch and adjust other parameters in the Audio Track Editor. 
For more information about using Flex Pitch with audio tracks, see Flex Time and Pitch overview.

Audio Track Editor: Edit audio regions nondestructively in a close-up view of a single track, 
including making Flex Time and Flex Pitch edits. For information about the Audio Track Editor, 
see Audio Track Editor overview. 

The Piano Roll Editor and Score Editor have been redesigned and improved. For more 
information, see Piano Roll Editor overview and Notation overview.

Mixing
New Mixer options: The redesigned Mixer now includes gain reduction meters and new panning 
mode options. The new multi-functional Effect slot design simplifies choosing, opening, and 
bypassing plug-ins. For information about the Mixer, see Mixing overview.

Instruments and effects
Drum Kit Designer plug-in: Customize or build drum kits to use with Drummer, or to play 
and sequence drum tracks manually. You can choose multiple drums, then adjust individual 
parameters for each drum. For more information about using Drum Kit Designer, see Drum Kit 
Designer overview.

Arpeggiator/MIDI plug-ins: Create sophisticated arpeggiator patterns for any software instrument 
using the Arpeggiator. Use other MIDI plug-ins to perform a variety of real-time operations. 
For more information about working with MIDI plug-ins, see Plug-ins overview. For complete 
information about MIDI plug-in parameters, see the MIDI plug-ins section of the Logic Pro 
Effects manual.

Redesigned vintage instruments: The three vintage instrument plug-ins (EVP88, EVB3, and EVD6) 
have been redesigned and renamed Vintage Electric Piano, Vintage B3, and Vintage Clav. For 
more information, see the relevant sections of the Logic Pro Instruments manual.

Retro Synth: Retro Synth is a flexible, easy-to-use 16-voice synthesizer that can produce a wide 
variety of sounds. This instrument plug-in provides four synthesizer types—Analog, FM, Sync, and 
Wavetable—each of which can generate unique sounds. For more information, see the Retro 
Synth section of the Logic Pro Instruments manual.

Bass Amp Designer: This effect plug-in emulates the sound of famous bass guitar amplifiers and 
the speaker cabinets used with them. For more information, see the Bass Amp Designer section 
of the Logic Pro Effects manual.
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Get started overview
Welcome to Logic Pro X. For users new to Logic Pro, this chapter introduces the main working 
areas of the application, and presents some basic tasks to help you start working in Logic Pro.

Logic Pro X is a full-featured music and audio application you can use for every aspect of music 
creation: recording, arranging, mixing, and more–everything from sketching your initial ideas to 
producing a polished final mix (or multiple mixes). You can use Logic Pro for any type of music 
project, from simply recording yourself singing or playing all the way to complex multi-track, 
multi-section compositions. 

For a quick tour of the Logic Pro interface, see Get started with the Logic Pro main window, then 
choose topics from the list on the left that introduce specific features and working areas, with 
basic tasks to help you get started.

Open Logic Pro
Do one of the following:

mm Click the Launchpad icon in the Dock, then click the Logic Pro icon in Launchpad.

mm Double-click the Logic Pro icon in the Applications folder.

The first time you open Logic Pro, it downloads basic content, including software instrument 
presets and Apple Loops, that you can use in your projects. After the download is complete, the 
Project Chooser opens so you can create a new project or open an existing one.

To learn more about creating and opening projects, see Get started with projects.

Tip:  If you’re using Logic Pro on a portable computer or with a smaller display, you can hide the 
Dock to maximize available screen space. To hide the Dock, Control-click the area in the Dock 
between the last application icon and the Downloads icon, then choose Turn Hiding On from the 
shortcut menu.

Get started with Logic Pro X 2
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Get started with the Logic Pro main window
The Logic Pro main window is where you work on your projects. You can access all of the major 
working areas of Logic Pro in the main window.

Tracks areaControl bar

Smart ControlsInspector

The central part of the main window is the Tracks area. You record and arrange the musical 
material in your project on the tracks in the Tracks area. There are several different track types, 
including audio, software instrument, and Drummer tracks. When you make a recording, or add an 
Apple Loop or other media file, it appears as a rectangular region on the selected track.

Across the top of the main window is the control bar, which includes buttons that let you access 
different parts of Logic Pro, transport controls for controlling project playback, a Master Volume 
slider to adjust the overall project volume, and other controls. In the center of the control bar 
is the LCD, where you can view the current playhead position, move the playhead, and set the 
project tempo, key, and time signature.

To start working with audio tracks, see Get started with audio tracks. To start working with 
software instrument tracks, see Get started with software instrument tracks. To start working with 
your recordings and other material in the Tracks area, see Get started arranging regions in the 
Tracks area.

You can open the following working areas of Logic Pro by clicking their buttons in the control 
bar:

Inspector button

Library button

Smart Controls button

Mixer button

Editors button

Apple Loops button

Browsers button
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••   Library: You can audition patches and choose a patch for the selected track in the Library. 
A patch contains the instrument, effects, and routing settings that control the sound of a 
track. When you choose a patch, those settings are applied to the currently selected track. The 
Library shows available patches for the selected track. You can choose a category on the left to 
see available patches or subcategories on the right.

In addition to patches, you can view and select plug-in presets and other settings in the 
Library, when the corresponding item is selected. For information about choosing patches and 
other items in the Library, see Patches overview.
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••   Inspector: You can view and edit parameters for the selected region, the selected track, and 
other items in the inspector. The available inspectors and parameters change, depending on 
which working area has focus, and what is selected. The channel strips for the selected track 
and its output appear in the lower part of the inspector, so you can view and quickly edit 
channel strip parameters and plug-ins.

The Quick Help area at the top of the inspector shows a brief description of whatever part of 
the Logic Pro interface you move the pointer over. Some Quick Help descriptions contain links 
to more detailed information.

For information about editing region and track parameters, see Region inspector and Edit 
track parameters.

••   Smart Controls: Smart Controls let you quickly adjust the sound of the selected track 
using a set of onscreen controls. When you open the Smart Controls pane, you see the screen 
controls for the the selected track. Screen controls can control both channel strip and plug-in 
parameters, including software instruments and effects. Move the knobs and other screen 
controls, and hear how sound changes.

To start working with Smart Controls, see Get started with Smart Controls. For more 
information, see Smart Controls overview.
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••   Mixer: The Mixer is where you adjust volume, pan, and other channel strip settings, mute 
and solo channel strips, add and edit plug-ins assigned to a channel strip, and control the 
signal flow of your project.

The Mixer shows the channel strips for every track in your project, including auxiliary and 
output channel strips, and the master channel strip. This makes it easy to see and adjust 
relative levels and other track settings. You can adjust the level and pan position of each 
channel strip, insert instrument and effect plug-ins and edit their parameters, mute and solo 
tracks, and send the output to auxiliary or output channel strips.

To start working in the Mixer, see Get started with mixing. For more information, see 
Mixing overview.

••   Editors: Logic Pro includes a set of a set of editors you can use to edit individual tracks 
and regions, and manipulate their contents precisely. The available editors depend on the type 
of track or region selected.

•• The Piano Roll Editor shows notes in selected MIDI regions on software instrument (or 
external MIDI instrument) tracks. Each note appears as a bar that indicates the point in time 
where it starts playing, how long the note plays, and the note’s pitch.

To start working in the Piano Roll Editor, see Get started with the Piano Roll Editor. For more 
information, see Piano Roll Editor overview.

•• The Audio Track Editor displays the audio waveform of the regions on an audio track. In the 
Audio Track Editor, you can copy, paste, move, trim, split, and join audio regions. You can also 
quantize and edit the timing and pitch of audio material using Flex Time and Flex Pitch. 
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To start working in the Audio Track Editor, see Get started with the Audio Track Editor. For 
more information, see Audio Track Editor overview and Flex Time and Pitch overview.

•• The Score Editor displays MIDI regions in a project as music notation, including notes, rests, 
and other MIDI events such as sustain pedal markings. You can add and edit notes and other 
musical symbols. 

For more information about the Score Editor, see Score Editor overview.

••   Loop Browser: Logic Pro includes an extensive collection of prerecorded Apple Loops that 
you can add to your projects. You browse or search for loops in the Loop Browser, where you 
can preview them to choose the ones you want to use.

To start working with Apple Loops, see Get started with Apple Loops. For more information, 
see What are Apple Loops?.
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••   Media Browser: Browse your computer and connected storage devices for audio files 
and movies.

For more information about working with media files, see Prerecorded media overview.

  When Show Advanced Tools is selected in the Advanced preferences pane, additional 
features, browsers, and editors are available.
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Get started with projects
You create your music in a Logic Pro project. A project is the document that contains all of your 
recordings, the media files you add, and all the edits you make. You start working in Logic Pro 
by creating a project or opening an existing one. GarageBand users can open their GarageBand 
projects in Logic Pro and continue working, with the expanded capabilities of Logic Pro.

Logic Pro includes a demo project that you can use to try out the tasks presented in the 
following Get Started topics. You can also create a new project, or open an existing one.

Open the demo project
mm Choose Help > Logic Pro Demo Project.

Create a project from a template
	 1	 Choose File > New from Template to open the Project Chooser.

	 2	 In the Project Chooser, click New Project on the left, then double-click a template on the right.

The project opens. If you choose Empty Project, the New Tracks dialog appears so you can add 
a track.
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Open an existing project
	 1	 Choose File > Open.

	 2	 Browse to the location of the project, select it, then click Open.

Save your project
mm Choose File > Save (or press Command-S).

For more information about working with projects, see Projects overview. For information about 
creating projects, see Create projects.
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Get started with playback and navigation
You can play back the project at any time to hear your latest changes. You control playback and 
navigate the project using the playhead, the ruler, and the transport buttons, located in the 
control bar.

The playhead extends from the top to the bottom of the Tracks area, and moves as the project 
plays, showing the currently playing point in the project. At the top of the playhead is a triangle 
that you can drag to move the playhead to a different time position, or scrub the project by 
moving the playhead across the Tracks area to quickly locate a particular musical passage.

At the top of the Tracks area, the ruler shows units of time in bars, beats, and beat divisions 
(depending on the zoom level).

The control bar contains a group of buttons called transport buttons that you can use to control 
playback, move the playhead, and start recording. The transport buttons include the following:

Record button

Go to Beginning button

Play button

Forward button

Rewind button

You can use the cycle area to define part of a project to play back repeatedly. The cycle area 
can be used for composing, practicing a part before recording, recording multiple takes, and 
other purposes. When you turn on the cycle area, it appears as a yellow strip in the upper part of 
the ruler.

Start and stop playback
mm To start playback: Click the Play button (or press the Space bar).

When the project is playing, the Go to Beginning button becomes a Stop button.

mm To stop playback: Click the Stop button (or press the Space bar again).

mm To start playback from the clicked position: Double-click the lower part of the ruler. Double-click 
again to stop playback.
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Move the playhead
Do any of the following:

mm Drag the playhead to a new position.

mm Click the lower part of the ruler to move the playhead to the clicked position. If the project is 
playing, playback continues from the clicked position.

mm While the project is playing, click the Rewind or Forward button.

Each time you click Rewind, the playhead jumps back to the previous bar. Each time you click 
Forward, the playhead jumps forward to the next bar.

mm In the LCD, click-hold one of the numbers in the Position display and drag vertically.

Move the playhead to the start of the project
mm Click the Go to Beginning button in the control bar (or press Return).

Play a section repeatedly with the cycle area

	 1	 Click the Cycle button  in the control bar (or press C) to activate the cycle area.

The cycle area appears in the ruler.

	 2	 Hold the pointer over either the left or right edge of the cycle area, then drag to resize it.

The left and right edges of the cycle area are called locators.

	 3	 Press the Space bar to start playback.

The playhead loops continually within the cycle area.

Move the cycle area
mm Grab the cycle area by the middle (the pointer turns into a hand) and drag it left or right. 

For iPad users, a separate application is available that you can use to navigate Logic Pro projects, 
and perform mixing, editing, and other functions, on your iPad. The Logic Remote app is available 
on the App Store.

For more information about playback and navigation, see Play a project and Control playback 
with the transport buttons. For information about using the cycle area, see Use the cycle area.



	 Chapter  2    Get started with Logic Pro X	 32

Get started with the project tempo, key, and time signature
Each project has a set of properties, including tempo, key signature, and time signature. For new 
projects, the default project tempo is 120 beats per minute (bpm), the key is C, and the time 
signature is 4/4. You can change these project properties when you create a project, or later 
while you’re working.

The project tempo, key, and time signature are displayed in the LCD in the center of the control 
bar, along with the current playhead position.

Tempo
The project tempo defines the musical speed of the project, expressed as the number of beats 
per minute (bpm). Changing the tempo can affect the playback speed of audio and software 
instrument recordings, Drummer regions, and Apple Loops, in the project.

Key
The project key defines the central note (called the tonic), and whether the project uses the 
major or minor scale. Changing the key affects the playback of Apple Loops in the project, and 
the display of MIDI notes in the Score Editor.

Time signature
The project time signature defines how musical time is divided into measures and beats. The 
time signature contains two numbers separated by a slash (/), which looks similar to a fraction. 
The first number controls the number of beats in each bar, and the second number controls 
the beat value (the note that counts as one beat). Changing the time signature does not affect 
playback, but does affect the units displayed in the ruler and the bars in the Score Editor.

Show project properties in the LCD
mm Click the icon on the left side of the LCD, then choose Beats & Project  from the 

pop-up menu.

Set the project tempo in the LCD
mm Click-hold the tempo value (above the letters “bpm”) and drag up or down.

Set the project key in the LCD
mm Click-hold the key, then choose a new key from the pop-up menu.

Set the project time signature in the LCD
mm Click-hold either of the numbers above the word “signature,” then drag up or down.

For more information about working with project properties, see Project properties overview.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can add 
tempo, key, and time signature changes in a project.
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Get started with tracks

Get started with audio tracks
You can record sound from a microphone, or from an electric instrument (such as an electric 
guitar) connected to your computer, on an audio track in the Tracks area. The recording appears 
as an audio region on the selected audio track, showing an audio waveform. You can arrange and 
edit audio regions in the Tracks area, and edit them in a close-up view in the Audio Track Editor.

When you add a track, you can choose a patch for the track in the Library. You can quickly 
audition patches to find the one you want to use, and change the effects for an audio track by 
choosing a different patch. Each audio patch contains one or more audio effects, and can include 
sends and other routing settings.

Logic Pro includes a metronome, which plays a steady beat to help you play in time while 
recording. You can have the metronome play as you record, or only play a one-bar count-in 
before recording starts.

Add an audio track
	 1	 Click the Add Tracks button  in the toolbar.

	 2	 Click one of the two Audio icons at the top of the New Tracks dialog.

•• To create an audio track for recording from a microphone: Click the Microphone icon.

•• To create an audio track for recording a guitar or bass connected to your computer: Click the 
Guitar icon.

	 3	 If necessary, click the Details triangle to open the bottom of the dialog.

	 4	 Choose the audio device and input channel (or stereo pair) from the Input pop-up menu on 
the left.

	 5	 Make sure that “Output 1-2” appears on the Output pop-up menu on the right.

	 6	 Click Create.
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Choose an audio patch
	 1	 In the Library, click a category on the left.

	 2	 Click a patch name on the right.

You can audition audio patches by clicking them, then playing your instrument, singing, or 
making sound, to find the one you want to use. For more information about choosing patches, 
see Patches overview.

Prepare for audio recording
Before you start recording audio, do the following:

mm Make sure that your microphone or instrument, and any other audio equipment you’re using, 
such as an audio interface, is connected to the audio input on your computer, and is working.

mm Make sure there is enough free storage space on your computer or connected storage device.

mm Sing or play, and check the input level meter in the track header to be sure that the track is 
receiving the audio signal.

mm To hear the sound from your microphone or instrument while you’re recording, click the Input 
Monitoring button in the track header.

Input Monitoring button

Record on an audio track
	 1	 Select the header of the audio track you want to record on.

	 2	 Move the playhead to the point where you want to start recording.

	 3	 Click the Record button  in the control bar (or press R) to start recording.

	 4	 Start singing or play your instrument.

After a one-bar count-in, recording starts. The recording appears as a new audio region on the 
track as you record.

	 5	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.
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You can record multiple takes simultaneously, and quickly create comps (composite takes) of 
the best moments from each take. For more information about recording on an audio track, 
see Recording overview and Record sound from a microphone or an electric instrument. 
For information about connecting microphones and other audio devices, see Audio 
devices overview.

Get started with software instrument tracks
If you have a USB or MIDI keyboard (or another type of MIDI controller) connected to your 
computer, you can play and record software instruments. Logic Pro features a complete library 
of professional-quality software instruments, including synthesizers and other keyboards, guitars, 
drums, world instruments, and more.

A patch contains the instrument, effects, and routing settings that control the sound of the track. 
You can change the sound of a software instrument track by choosing a different patch from the 
Library. In the Library, you can also audition patches to find the one you want to use.

You record a software instrument on a software instrument track in the Tracks area. The 
recording appears as a MIDI region on the selected software instrument track. You can arrange 
MIDI regions in the Tracks area, and edit them in the Piano Roll Editor and other editors.

Logic Pro includes a metronome, which plays a steady beat to help you play in time while 
recording. You can have the metronome play as you record, or play only a one-bar count-in 
before recording starts.

Play a software instrument
mm Select a software instrument track, then play notes on your music keyboard.

mm If your music keyboard has pitch bend and modulation wheels, move them as you play, to see 
how the sound changes. If your music keyboard has other controls, such as faders, knobs, or 
drum pads, try using them as well.
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Add a software instrument track
	 1	 Click the Add Tracks button  in the toolbar.

	 2	 Click the Software Instrument & MIDI icon (the keyboard) at the top of the New Tracks dialog.

	 3	 If necessary, click the Details triangle to open the bottom of the dialog. 

	 4	 Make sure that “A Software Instrument” appears on the pop-up menu on the left, and “Output 
1-2” appears on the Output pop-up menu on the right.

	 5	 Make sure the Open Library checkbox is selected.

	 6	 Click Create.

The new track appears in the Tracks area, and the Library opens on the left.

Choose a software instrument patch
mm In the Library, click a category on the left, then click a patch name on the right.

You can audition software instrument patches by clicking them in the Library, then playing your 
music keyboard, to find the one you want to use. For more information about choosing patches, 
see Patches overview.

Record a software instrument
	 1	 Select the software instrument track you want to record to.

	 2	 Move the playhead to the point where you want to start recording.

	 3	 Click the Record button  in the control bar (or press R) to start recording.

	 4	 After a one-bar count-in, recording starts. The recording appears as a new software instrument 
region on the track as you record.

	 5	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.

For more information about recording software instruments, see Recording overview and 
Record software instruments. For information about connecting a music keyboard, see MIDI 
devices overview.



	 Chapter  2    Get started with Logic Pro X	 37

Get started with track header controls
Each track has a track header that shows the track name and icon, and features a number of 
track controls including Mute, Solo, and Record Enable buttons. Audio tracks also feature an 
Input Monitoring button. The track headers are located along the left side of the Tracks area, so 
you can easily see the mute, solo, and other settings for all tracks while working.

Some track header controls, including volume, pan, mute, and solo controls, correspond to 
channel strip controls on the track’s channel strip in the Mixer—changing one (for instance, 
dragging the Volume slider in a track header) produces a corresponding change in the other (in 
this case, the Volume fader on the track’s channel strip). 

Mute button

Solo button

Volume slider

Pan/Balance knob

Mute a track
mm Click the track’s Mute button  in the track header.

Solo a track
mm Click the track’s Solo button  in the track header.

The Solo button turns yellow, and the Mute buttons of all unsoloed tracks flash blue. Click the 
button a second time to restore the track to its previous state.

Adjust a track’s volume level
mm In the track header, drag the Volume slider left to lower the volume level, or drag it right to raise 

the volume level. 

Option-click the slider to return it to a neutral level (0 dB gain).

Adjust a track’s pan or balance position
mm In the track header, drag the Pan/Balance knob counterclockwise to pan to the left, or drag 

clockwise to pan to the right. The dot on the wheel indicates the current position.

Option-click the Pan/Balance knob to return it to the center position.

Note:  You might have to resize the track header in order to see the Pan/Balance knob.

Change track buttons on multiple tracks
mm Click-hold a button on a track header, then drag the pointer up or down over additional tracks.

The corresponding buttons on all the swiped tracks switch to the same state.

For more information about working with tracks, see Tracks overview. For information about 
using the track controls, see Use the track header controls.
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Get started arranging regions in the Tracks area
The Tracks area is where you arrange the recordings, Apple Loops, and other musical material 
in your project, organizing them into sections such as intro, verse, and chorus to build an 
arrangement. The Tracks area shows a visual representation of time moving from left to right. 
You build a project by arranging regions in rows called tracks, that run horizontally across the 
Tracks area.

Regions are the building blocks of a project, representing your recordings, Apple Loops, and 
other media files you add to the project. Regions appear as rounded rectangles in the Tracks 
area. There are several different types of regions, depending on the track type. The two primary 
region types are audio regions, which show the audio waveform, and MIDI regions, which show 
note events as thin rectangles.

You can arrange regions in a variety of ways in the Tracks area, by moving, looping, resizing, 
splitting, joining, and deleting them. Try following the tasks below, using regions in the project.

Move a region
Do any of the following:

mm Drag a region left or right to move it to a new time position.

mm Drag an audio region up or down to another audio track.

mm Drag a MIDI region up or down to another software instrument track.

Resize a region
	 1	 Move the pointer over the lower-right edge of the region.

The pointer becomes a Resize pointer.

	 2	 Drag the edge of the region horizontally to shorten or lengthen it.

Resize pointer
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Loop a region
	 1	 Place the pointer over the upper-right edge of the region.

The pointer becomes a Loop pointer.

Loop pointer

	 2	 Drag the right edge of the region several bars to the right.

When you drag the edge of the region out by its full length, rounded corners indicate the 
beginning and end of each complete repetition of the region.

Split a region using the playhead
	 1	 Select the region you want to split.

	 2	 Move the playhead over the point in the region where you want to split it, then choose Edit > 
Split.

Playhead

Only the selected region is split, even if an unselected region on another track is under the 
playhead as well. If multiple regions are selected and are under the playhead, they are all split.

Split a region using the Scissors tool
	 1	 Select the region you want to split.

	 2	 Select the Scissors tool, then click-hold the region. 

The help tag shows the current split position.

	 3	 Release the mouse button.

When selecting a cut point with the Scissors tool, you can move backward and forward in steps 
of one division. The grid is based on the Snap pop-up menu setting. For information about using 
Snap, see Snap items to the grid.

Delete a region
mm Select the region, then choose Edit > Delete (or press the Delete key).

For more information about arranging a project, see Arranging overview. For information about 
working in the tracks area, see Tracks area overview.
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Get started editing regions

Get started with the Piano Roll Editor
The Piano Roll Editor shows the notes in MIDI regions on a software instrument track as colored 
bars in a time grid. On the grid, a note’s horizontal position indicates where the note starts 
playing, while its vertical position indicates its pitch. A keyboard graphic along the left edge of 
the Piano Roll Editor provides an easy guide to the pitches of notes.

On the left are controls for quantizing the timing and pitch of MIDI notes, and editing their 
velocity. Along the top of the Piano Roll Editor, a ruler shows time divisions, based on the time 
format chosen in the LCD. The header shows the name of the selected region, or the number 
of regions (if more than one is selected), as well as the pitch and position of the pointer in 
the region.

Open the Piano Roll Editor 
mm Select a software instrument (or external MIDI instrument) track, then click the Editors 

button .

Add a note
mm Select the Pencil tool from the Tool menu, then click a position in the Piano Roll 

Editor background.

Note:  You can change the note length as you add a note, by holding down the mouse button 
and dragging left or right.

Select a group of notes
mm Drag over the keys on the keyboard graphic for the notes you want to select. 
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Move notes 
mm Select one or more notes, then drag left or right.

Copy notes
mm Hold down Option while dragging notes to a new position.

Resize notes
mm Position the pointer over the left or right edge of a note, then drag when the pointer changes to 

a length change icon.

While you drag, a help tag shows the precise end point and length of the note.

Tip:  It might sometimes be difficult to grab the corner of very short notes. You can use the Finger 
tool, which allows you to grab notes anywhere to alter their length, or zoom in for a closer view. 

Change the pitch of notes
mm Drag notes up or down to a new pitch.

Edit the velocity of notes
Do one of the following:

mm Select one or more notes, then drag the Velocity slider left or right.

mm Drag a note vertically with the Velocity tool.

A help tag indicates the velocity value of the note you clicked, with the value changing as 
you drag. The color of the note event changes and the horizontal line inside the event either 
lengthens or shortens.

For more information about working in the Piano Roll Editor, see Piano Roll Editor overview.
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Get started with the Audio Track Editor
The Audio Track Editor shows a close-up view of part of an audio track in the Tracks area, 
displaying the audio waveforms of the regions on the track.

In the Audio Track Editor, you can move and trim, split, and join audio regions, play a region 
in isolation, and edit regions in other ways. Edits you make in the Audio Track Editor are 
nondestructive, so you can always return to your original recordings.

You can also quantize and edit the pitch of audio material in the Audio Track Editor using Flex 
Pitch. When you choose a Flex Pitch algorithm, the contents of the audio track are analyzed for 
pitch, and the results are displayed as a pitch curve overlaid on the waveform.

Open the Audio Track Editor
Do one of the following:

mm Select an audio track, then click the Editors button .

mm Double-click an audio region to open it in the Audio Track Editor.

The Audio Track Editor opens below the Tracks area. Along the top of the Audio Track Editor is a 
ruler showing time divisions, based on the time format chosen in the LCD, and a menu bar with 
local menus. The main area of the Audio Track Editor shows the audio waveform of the regions in 
the selected audio track.
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Trim an audio region
	 1	 Place the pointer over the lower-left or lower-right edge of the region.

The pointer changes to a trim pointer.

	 2	 Drag the pointer to trim the beginning or end of the region.
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Split an audio region
Do one of the following:

mm Select the Scissors tool, then click the point where you want to split the region.

You can scrub regions to find the point where you want to cut by dragging across the regions 
with the Scissors tool.

mm Select the region, move the playhead over the time position where you want to split the region, 
then choose Edit > Split.

Before moving or deleting a segment of a split audio region, click to select it.

Join regions
	 1	 Select the split regions.

	 2	 Do one of the following:

•• Choose Edit > Join > Regions.

•• Select the Glue tool, then click the selected regions.
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Turn on flex in the Audio Track Editor
	 1	 Open the Audio Track Editor by doing one of the following:

•• Select an audio track in the Tracks area, then choose View > Show Editors.

•• Select an audio track in the Tracks area, then click the Editors button  in the control bar.

•• Double-click an audio region.

	 2	 Click the Flex button  in the Audio Track Editor menu bar.

Note:  Click the Audio Track Editor’s workspace before using the key command, to make sure that 
the Audio Track Editor has key focus.

A Flex pop-up menu appears to the right of the Flex button in the Audio Track Editor menu bar.

	 3	 Choose Flex Pitch or one of the Flex Time algorithms from the Flex pop-up menu.

Change the pitch of a note
	 1	 Turn on Flex in the Audio Track Editor, then choose Flex Pitch from the Flex pop-up menu.

	 2	 Drag a note vertically to a new pitch.

For more information about working in the Audio Track Editor, see Audio Track Editor overview.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can also edit 
the timing of individual notes, chords, or sounds in the Audio Track Editor using Flex Time. For 
more information about Flex Time and Flex Pitch, see Flex Time and Pitch overview. You can also 
open the Audio File Editor to make permanent (destructive) edits to the source audio file for 
a region.
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Get started with Smart Controls
Smart Controls let you quickly adjust the sound of a track, without having to edit channel strip 
settings or open individual plug-in windows.

Each Smart Control includes a set of screen controls that you can adjust to control the sound 
of the patch. Smart Controls typically include EQ or tone controls, reverb and other effects 
controls, and controls specific to the type of track or instrument. For example, the Smart Control 
for a synthesizer might include screen controls for choosing the waveform and adjusting the 
resonance and filter cutoff, while one for a string instrument might include controls for changing 
the articulation.

When you open the Smart Controls pane, you see the screen controls for the selected track. Each 
screen control is labeled to make its function easy to understand.

Open the Smart Controls pane

mm Select a track, then click the Smart Controls button  in the control bar.

Manipulate screen controls
mm Turn the knobs, click the switches, and move the other screen controls to see how they affect the 

sound of the patch.

Each screen control has a text label indicating what aspect of the sound it controls.

You can also change the layout for a Smart Control, save your own Smart Controls, map screen 
controls to channel strip and plug-in parameters, and assign controllers on your MIDI devices to 
screen controls. For more information about using Smart Controls, see Smart Controls overview.
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Get started with mixing
Mixing a project involves balancing the different parts of the project and blending them into a 
cohesive whole.

In the Mixer, each track has a channel strip that corresponds to its track type. You can control 
the sound of the track using its channel strip controls, which include Mute and Solo buttons, a 
Volume fader and level meter, a Pan/Balance knob, and others. You can also add effects plug-
ins, change plug-in settings, and control the signal flow using sends and auxiliary (aux) channel 
strips. 

The channel strip for the currently selected track also appears in the lower-left part of the 
inspector, along with the channel strip for its output. You can try out the following tasks using 
either the inspector channel strips or the channel strips in the Mixer.

Channel Strip setting button

Effect slots

Send knob

Volume fader

Pan/Balance knob

Level meter

Mute button

Solo button
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Open the Mixer
mm Click the Mixer button  in the control bar (or press X).

The Mixer opens below the Tracks area.

Mute and unmute a channel strip
mm Click the channel strip’s Mute button (with an “M”).

Click the button again to unmute the channel strip.

Solo and unsolo a channel strip
mm Click the channel strip’s Solo button (with an “S”).

When you solo a channel strip, the Mute buttons of all unsoloed channel strips flash.

Click the button again to unsolo the channel strip.

Adjust track volume using a channel strip
mm Drag the Volume fader up or down. 

Adjust track pan or balance using a channel strip
mm Drag the Pan control vertically.

Choose a channel strip setting
mm Click-hold the Setting button at the top of the channel strip, then choose a setting from the 

pop-up menu.
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Choose a different plug-in
Do one of the following:

mm Click the rightmost part of the Effect slot (with the Up and Down arrows), then choose a plug-in 
from the pop-up menu.

mm Place the pointer above or below an existing slot, click the blue line that appears, then choose a 
plug-in from the pop-up menu.

Open a plug-in window
mm Click the center area of the plug-in slot.

For detailed information about mixing a project, see Mixing overview. For more information 
about channel strip controls, see Channel strip controls.
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Get started with Apple Loops
Apple Loops are prerecorded musical patterns that you can use to quickly add drum beats, 
rhythm parts, and other musical phrases to a project. Apple Loops contain musical patterns 
that can be repeated over and over, seamlessly. After you add a loop to the Tracks area, you can 
extend it to fill any amount of time. When you add an Apple Loop to a project, it automatically 
matches the project tempo and key.

Apple Loops are available in a variety of instruments, genres, and moods in the Loop Browser.

There are two types of Apple Loops:

•• Audio Apple Loops: You add audio loops to audio tracks, and edit them like other audio regions.

•• Software Instrument Apple Loops: You add software instrument loops to software instrument 
tracks, and edit them like other MIDI regions.

Open the Loop Browser

mm Click the Apple Loops button  in the control bar (or press O).

Browse for loops
mm Click the Button View button, then click keyword buttons to see matching loops in the results 

list. Keywords with no matching loops are dimmed.
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Preview loops
mm Click a loop in the results list.

You can adjust the preview volume, and choose a different key for the loop.

To stop preview playback, click the loop again.

Add a loop to the Tracks area
Do one of the following:

mm Drag the loop to a track of the same type to add it to that track.

mm Drag the loop to an empty part of the Tracks area to create a new track with the loop.

After you add the loop to the Tracks area, you can drag it left or right to adjust the point where it 
starts playing.

You can also search for loops by name, key, or time signature. For more information about using 
Apple Loops in your projects, see What are Apple Loops?.
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Get started with Drummer
Using Drummer, you can add a virtual drummer to your project. You can choose from different 
genres, and choose different drummers in each genre. Each drummer has a specific drum kit and 
playing style. You can choose a drummer preset, edit drum settings to adjust the playing style, 
exchange drum kits, and choose individual drum sounds.

To work with Drummer, you add a Drummer track to the project. A Drummer track is similar to a 
software instrument track, but it contains only Drummer regions, rather than MIDI regions. Both 
track and region parameters can be edited using the dedicated Drummer Editor.

Add a Drummer track
	 1	 Click the Add Tracks button  in the toolbar.

	 2	 Click the Drummer icon (the drum kit) at the top of the New Tracks dialog.

	 3	 Click Create.

A Drummer Track Stack is added, along with two 8-bar regions on the main track. The Library 
opens, and a default patch is loaded to the track. 
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Choose a genre and drummer
	 1	 Click the genre name on the left side of the Drummer Editor to see all genres.

	 2	 Click a genre.

The available drummers for the selected genre appear below the genre name.

	 3	 Select a drummer.

A drummer card appears, showing the drummer’s name, a description of the drummer’s style, 
and the drum kit for that drummer.

Choose a different drummer preset
Each drummer includes a variety of presets, which appear to the right of the drummer card.

mm Click a preset.

A preset consists of a number of region settings, visible to the right of the presets area.
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Play the selected Drummer region using the current preset
mm Click the Play button in the ruler at the top of the Drummer Editor.

Play button

Adjust the complexity and loudness of a preset
mm Reposition the puck in the XY pad.

The farther right you place the puck, the more complex the sound becomes; the higher you 
place the puck, the louder the sound plays.

Choose a pattern variation for a drum or percussion instrument
Do any of the following:

mm For Tambourine, Shaker, and Handclap: Click an instrument, then drag the Percussion slider or 
choose an increment.

mm For Cymbals, Toms, and Hi-Hat: Click a kit piece, then drag the kit piece slider or choose 
an increment.

mm For Kick and Snare: Drag the Kick & Snare slider or choose an increment.
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Exchange a drum
	 1	 Click a drum.

The Exchange panel opens to the left if exchange pieces are available for that kit piece.

	 2	 Click the Info button of a selected kit piece to view its description.

	 3	 Click the kit piece that you want to exchange in the Exchange panel. You may need to scroll in 
order to find the one you want to use.

The piece is exchanged and the respective drum sound is loaded.

Note:  The toms and crash cymbals can only be exchanged as a group.

	 4	 Click anywhere in the plug-in window background to close the panels.

Edit other performance parameters
Do any of the following:

mm Drag the Fills knob downward to reduce, or upward to increase, the number and length of fills.

You can click the lock to prevent any changes to the fills setting when switching presets 
or drummers.

mm Drag the Swing knob vertically to adjust the shuffle feel of the currently playing pattern.

You can click the lock to prevent any changes to the swing setting when switching presets 
or drummers.

mm Click the Details button to reveal the following knobs:

•• Drag the Feel knob to the right to have the drummer play ahead of the beat (Push), or to the 
left to play behind the beat (Pull).

•• Drag the Ghost Notes knob to adjust the level of ghost notes—syncopated snare and kick 
hits—in the beat.
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Note:  The presence of ghost notes depends on the chosen drummer and the 
complexity setting.

•• Drag the Hi-Hat knob to adjust the degree to which the Hi-Hat is opened and closed during 
the drum performance.

Note:  This is only relevant if the hi-hat is selected in the drum kit representation.

Any changes or selections you make in the Drummer Editor affect only the selected region, 
not the entire track. For more information about using Drummer in your projects, see 
Drummer overview.
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Get started with Track Stacks
Track Stacks provide a convenient way to organize and control multiple tracks, to manage 
projects with high track counts, and to create audio subgroups. There are two types of Track 
Stacks:

•• Folder stacks let you combine multiple tracks and control them as a unit, without changing 
their individual routing.

•• Summing stacks let you combine multiple tracks and route their output to an audio subgroup.

Both types have a main track and one or more subtracks. The track header for the main track 
features a disclosure triangle that lets you show or hide the subtracks. When you close the stack, 
only the main track appears in the Tracks area.

In the demo project, the Backing Vocals, Synthesizers, and Song FX tracks are folder stacks, and 
the Outro Vocal Stack is a summing stack.

Create a Track Stack
	 1	 Select the tracks you want to include in the Track Stack. The selected tracks can be adjacent 

or nonadjacent.

	 2	 Choose Track > Create Track Stack.

	 3	 In the Track Stack dialog, do one of the following:

•• To create a folder stack: Select Folder Stack, then click OK. 

•• To create a summing stack: Select Summing Stack, then click OK. 

Show the subtracks for a Track Stack
mm Click the disclosure triangle to the left of the track icon in the main track.

To hide the subtracks, click the disclosure triangle again.
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Add a track to a Track Stack
mm Drag the header of the track you want to add between two of the subtracks in the Track Stack.

Note:  When you add a track to a summing stack, its routing changes to the aux assigned to the 
main track.

Reorder subtracks
mm Drag a subtrack by its header up or down inside the Track Stack.

Remove a subtrack from a Track Stack
mm Drag the subtrack outside of the Track Stack (below the last subtrack, or above the main track).

When you remove a subtrack from a summing stack, the track’s output routing changes from the 
aux used by the main track to the main outputs. 

For more information about using Track Stacks in your projects, see Track Stacks overview.
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Get started with sharing
You can share a project to your iTunes library, or to the Media Browser to use in other Apple 
applications, such as Final Cut Pro or iMovie. If you have a SoundCloud account, you can share a 
project to SoundCloud, choose the quality and visibility level, and set permissions for the shared 
project from within Logic Pro.

Share the project to your iTunes library
	 1	 Choose File > Share > To iTunes.

	 2	 To rename the shared file, select the name in the Title field, then enter a new name.

	 3	 Type artist, composer, and album information for the shared file in the respective text fields.

	 4	 Choose the quality level for the shared file from the Quality pop-up menu.

	 5	 Click Share.

When you share a project to iTunes, the entire project, from the beginning to the end of the last 
region, is exported. Any silence at the beginning or end of the project is trimmed. If Cycle mode 
is on when you share the project, the part of the project between the start and end of the cycle 
region is exported.

The shared project appears in the iTunes library, where you can add it to playlists, convert it, or 
burn it to a CD. The format of the shared project is determined by the iTunes import settings.

Share a project to the Media Browser
	 1	 Choose File > Share > To Media Browser.

	 2	 To rename the shared file, select the name in the File name field, then enter a new name.

	 3	 Choose the quality setting for the shared file from the Quality pop-up menu.

	 4	 Click Share.

The entire project, from the beginning to the end of the last region, is exported. Any silence at 
the beginning or end of the project is trimmed. If Cycle mode is on when you share the project, 
the part of the project between the start and end of the cycle region is exported.
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Share a project to SoundCloud
	 1	 Choose File > Share > To SoundCloud.

	 2	 If you aren’t currently logged in to your SoundCloud account, enter your email address and 
password, then click Connect.

Alternatively, you can log in to your Facebook account.

	 3	 In the Share to SoundCloud dialog, do the following:

•• To sign in to a different SoundCloud account, click Change, then enter the login information 
for the account.

•• To share the current project, select Bounce as the Source.

•• To share an audio file, select File as the Source, click Browse, then browse to the location of 
the file.

•• Type title, artist, composer, and album information for the project in the respective text fields.

Projects must have a title in the Title field. The remaining information is optional.

•• Choose the quality level for the project from the Quality pop-up menu.

•• Choose the visibility level for the project from the Visibility pop-up menu.

•• Set download and streaming permissions for the project in the Permissions section.

	 4	 Click Share.

To return to Logic Pro without sharing the project, click Close.

You can also burn a project to a CD or DVD and share projects in other ways. For full details 
about sharing your projects, see Sharing overview.
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Overview
Welcome to Logic Pro X. The latest version of Apple’s award-winning music and audio creation 
software has a refreshed interface, the power and flexibility of earlier versions, and many new 
and updated features to help make creating music and audio productions easier and more 
rewarding than ever.

The following topics may be of particular interest to users upgrading from previous versions of 
Logic Pro:

•• Advanced tools and additional options, and how to make use of these advanced features in 
your projects.

•• New concepts in Logic Pro X

•• New and changed terms in Logic Pro X

•• New features included in Logic Pro X, with links to Help topics covering the features in detail

•• How to get help using the new Quick Help system, the included Help documents, online Help 
documents, and the Logic Remote iOS app

Work with advanced tools and additional options
Logic Pro X provides the power and flexibility of previous versions of Logic Pro, while allowing 
users to turn groups of features on or off to streamline their workflow. Advanced tools and 
additional options can be turned on or off in the Advanced preferences pane.

For experienced users who have upgraded from Logic Pro (8 or 9) or Logic Express (8 or 9), all 
advanced tools and additional options are turned on by default. When you open an existing 
project in Logic Pro X, any additional options used by the project are turned on automatically.

You turn on advanced tools by selecting Show Advanced Tools in the Advanced preferences 
pane. Turning on advanced tools (without turning on any of the specific additional options) lets 
you do the following:

User interface
•• Access the Event, Marker, Tempo, and Signature Lists.

•• Access the Project Audio Browser and All Files Browser.

•• Access the Step Editor (formerly Hyper Editor) to graphically edit MIDI events.

•• Customize the control bar and toolbar with additional buttons and controls.

•• Access the Marker, Signature, and Beat Mapping global tracks.

•• Customize key commands in the Key Commands window.

•• Access additional preferences and project settings.

•• Access additional track header controls in the Tracks area: On/Off switches, Hide and Protect 
buttons, track numbers, and color bars.
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Editing
•• Use MIDI Draw (formerly Hyper Draw) to graphically edit MIDI notes and 

controller information.

•• Use step input recording to manually enter MIDI events rather than recording them in 
real time.

•• Export MIDI regions as standard MIDI files.

•• Use additional recording functionality: Punch-on-the-fly, advanced recording commands, 
automatic coloring of takes when recording).

•• Use drum replacement and doubling.

Mixing
•• Choose between different views in the Mixer.

•• Access additional channel strip controls: Gain Reduction meter, EQ display, Group slot, and 
Automation Mode button.

Score
•• View and edit multiple tracks.

•• Access additional score view options.

•• Add notes and symbols from the Part box.

•• Add lyrics and other text.

•• Customize staff styles and score sets.

•• Edit the score layout.

Projects
•• Open and work on multiple projects.

•• Manage different versions of projects called alternatives.

•• Revert to automatically saved versions of a project called backups.

•• Save assets either inside the project or in a project folder with subfolders for different 
asset types.

When Show Advanced Tools is selected, additional options providing further expert capabilities 
become available, and can be selected individually depending on the type of tasks you want 
to perform.

Additional options include:

•• Audio: Audio File Editor for destructive editing of audio files and advanced configuration 
options

•• Surround: Surround mixing and processing capabilities, including a collection of surround 
plug-ins

•• MIDI: Environment window that allows for MIDI signal flow control and real-time processing of 
MIDI data

•• Score: Additional features in the Score Editor, including the ability to assign staff styles to 
individual regions and customize the chord grid library

•• Control Surface: Create and edit control surface assignments

•• Advanced edit: Advanced editing capabilities including the Tempo Interpreter and the ability to 
create aliases
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While you’re working, if you find that any advanced features you need are not available, open 
the Advanced preferences pane and select the Show Advanced Tools checkbox, then select any 
additional options to turn them on.

In Logic Pro Help, features that require Show Advanced Tools to be selected have this 

icon . Features that require Additional Options to be selected have this icon . For more 
information, see Advanced tools and additional options.

New concepts in Logic Pro X
Logic Pro X introduces some new concepts, while others are updated from earlier versions of 
Logic Pro.

Projects
Logic Pro X projects are organized in a new way. Project assets can be saved directly in the 
project, or in a separate project folder. As in earlier Logic Pro versions, assets can also be 
referenced from a location outside the project, allowing you to access media files without 
copying or moving them into the project. For detailed information about managing project 
assets, see Manage project assets.

You can have Logic Pro create a project folder to organize the project file and project assets, 
and also specify a recording path for audio files outside the project, in File > Project Settings 
> Record > Audio Recording Path. For more information about Recording project settings, see 
Recording settings.

Alternatives and backups
There are two new ways to manage Logic Pro X projects:

Project alternatives let you save “snapshots” of a project in different states, including different cuts 
or mixes. Each project alternative has a unique name, and can have different settings. Alternatives 
are saved as part of the project, and share the same assets.

Backups let you go back to earlier saved versions of a project. Each time you save a project, a 
backup of the current project alternative is saved, and can be accessed from the File menu.

Autosave saves your work so that you don’t lose important changes if the application quits 
unexpectedly. The next time you reopen Logic Pro, a dialog appears from which you can choose 
to open the auto-saved version, or the last manually saved version of the project.

For information about managing projects using alternatives and backups, see Use project 
alternatives and backups. For information about saving projects, see Save projects.
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Patches
Patches contain the instrument, effects, Smart Controls, and routing settings that control the 
sound of a track. You can choose a patch for a track in the Library when you create the track, and 
choose a different patch at any time while you’re working. The patches available in the Library 
depend on the selected track type.

Patches can include one or more channel strip settings, and can also contain routing information 
(auxes) and metadata (for Smart Controls and controller mapping). Patches for audio tracks can 
include default effects settings. Patches for software instrument tracks include an instrument 
plug-in as well as effects settings.

You can edit patches by changing channel strip settings, adding plug-ins, or editing plug-in 
parameters, and save your own custom patches in the Library.

Channel strip settings also appear in the Library. If you have saved channel strip settings from 
a previous version of Logic Pro, they appear along with patches when the corresponding track 
type is selected.

For information about working with patches, see Patches overview.
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Smart Controls
With Smart Controls, you can quickly view and adjust the sound of a track using a set of visual 
screen controls. Each patch contains a Smart Control. You can customize Smart Controls by 
mapping their screen controls to channel strip or plug-in parameters, then manipulate them 
using external MIDI hardware. 

For more information about using Smart Controls, see Smart Controls overview.

Track Stacks
In the Tracks area, Logic Pro X features a new way to organize tracks and create audio subgroups 
using Track Stacks. You can create a Track Stack from a group of existing tracks, and use the 
controls on the master track to control all the subtracks in the Track Stack.

There are two types of Track Stacks: folder stacks and summing stacks. Both types have a main 
track and one or more subtracks. The track header for the main track features a disclosure triangle 
that lets you show or hide the subtracks. When you close the stack, only the main track appears 
in the Tracks area.

Subtracks can include any track type: audio, software instrument (including layered and multi-
output software instruments), external MIDI instrument, or aux tracks. Folder stacks can also 
include summing stacks as subtracks.

For Track Stacks, the patches available in the Library vary, depending on the Track Stack type, and 
which track in the Track Stack is selected. For more information, see Track Stacks and the Library. 
For information about using Track Stacks, see Track Stacks overview.
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Audio editing
You can now edit audio regions nondestructively in a dedicated Audio Track Editor, as well as 
edit the underlying audio files destructively in the Audio File Editor. The Audio Track Editor lets 
you move, trim, split, and join audio regions and make other edits, without having to zoom the 
Tracks area, or change your view of the larger arrangement. 

In addition to editing the timing of audio material using Flex Time, you can quantize and edit the 
pitch of audio material using Flex Pitch. You edit the pitch of audio material by choosing a Flex 
Pitch algorithm. The contents of the audio track are analyzed using a pitch detection process, 
and the results are displayed as a pitch curve.

You can use Flex Pitch in both the Tracks area and the Audio Track Editor. In the Tracks area, 
the deviation of notes from their perfect semitone pitch is shown using bars overlaying the 
audio waveform. In the Audio Track Editor, sections of the audio material identified as notes are 
displayed like notes in the Piano Roll Editor. You can edit the pitch, time position, and length of 
notes in much the same way as you would in the Piano Roll Editor. You can also split notes and 
join multiple notes together. Each individual note in the Audio Track Editor contains “hotspots,” 
which you can use to edit pitch, vibrato, gain, and other parameters.

For information about editing audio regions in the Audio Track Editor, see Audio Track Editor 
overview. For information about editing audio files in the Audio File Editor, see Audio File 
Editor overview.
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New and changed terms in Logic Pro X
Logic Pro X includes some new terms, while others have changed from earlier versions of Logic Pro. 

Former term Logic Pro X term Details

Arrange window Logic Pro main window Encompasses the former Arrange 
area as well as the inspectors, 
Library, editors, Lists, Notes, Loop 
Browser, and other browsers.

Arrange area Tracks area

-- arrangement track A global track where you can 
organize a project into sections, 
then move or copy sections to 
build an arrangement.

Transport bar control bar The Transport bar (and some 
toolbar controls) have been 
integrated into the control bar, 
now at the top of the main 
window.

Media area Browsers The Browsers area includes the 
Project Audio, Media, and All Files 
Browsers.

Audio Bin Project Audio Browser

-- Media Browser Lets you quickly find audio and 
movie files and add them to a 
project.

File Browser All Files Browser

project folder project file or project folder Project assets can now be saved in 
the project, or in a project folder. 
You can also reference assets 
stored in another location.

-- project alternatives Alternatives let you save 
“snapshots” of a project in different 
states.

-- project backups Backups let you recall earlier, 
automatically saved versions of a 
project.

Insert slot/menu Effect slot/menu

Hyper Draw MIDI Draw

Hyper Editor Step Editor

Sample Editor Audio File Editor The Audio File Editor can be 
opened in the main window or as 
a separate window.

Caps Lock keyboard Musical Typing keyboard The Musical Typing window can 
also show the onscreen keyboard.

EVP88 Vintage Electric Piano Includes new plug-in settings; can 
also open existing user-created 
settings.

EVB3 Vintage B3 Includes new plug-in settings; can 
also open existing user-created 
settings.

EVD6 Vintage Clav Includes new plug-in settings; can 
also open existing user-created 
settings.
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What is Logic Pro?

Logic Pro is a powerful, full-featured music application with all the tools you need to create 
professional-quality music productions. You can record, arrange, and edit audio and MIDI regions, 
add high-quality effects, mix your music in stereo or surround, and export the final mix in a 
variety of formats for distribution.

With Logic Pro you can create many different kinds of projects, from simple songs to complex 
ensemble arrangements. Logic Pro gives you the flexibility to customize the application to suit 
your way of working.

Some of the things you can do in Logic Pro include:

•• Record instruments, vocals, or any sound that can be captured by a microphone, including 
recording takes and comps.

•• Play and record the included Logic Pro software instruments, using a USB keyboard or other 
MIDI controller. You can also play and record third-party Audio Units software instruments.

•• Add virtual drummers to your projects to create detailed, realistic virtual drum performances 
that adjust dynamically to the genre, the content of the project, and other parameters.

•• Add Apple Loops and other prerecorded media files to your projects.

•• Arrange regions containing your musical material in the Tracks area. You can also define 
sections of the project and quickly rearrange them using arrangement markers.

•• Edit audio and MIDI regions using a set of editors optimized for different tasks and 
region types.

•• Edit the timing and pitch of audio regions, and of individual notes, chords, and sounds.

•• Mix your project in the Mixer, where you can view and edit channel strip controls, customize 
routing options, and add and edit plug-ins.
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•• Automate changes over time for mix, effects, and plug-in settings using total recall mix 
automation. You can record automation changes in real time and edit them later.

•• View MIDI regions in a project as music notation, add and edit notes and other musical 
symbols, and print the finished score as well as individual parts.

Logic Pro workflow overview
To give you an idea of the possibilities, some major steps in putting together a Logic Pro project 
are described below. You don’t have to do every step, and you might perform some steps in a 
different order. You could, for example, go all the way through mixing and adding effects, then 
add more recordings or media files to your project before finalizing the mix and sharing the 
finished project.

Create a project
You start working in Logic Pro by creating a new project to hold your musical material and all the 
changes you make. You can save media files and other assets in the project, or reference them in 
their current location.

Record your material
Add musical material by recording your performances in the Tracks area. You can record vocals, 
instruments, and other sounds on audio tracks. Using a USB keyboard or other MIDI controller, 
you can play and record a wide variety of software instruments on software instrument tracks. 
You can also record MIDI regions to play back on external MIDI devices, such as synthesizers and 
sound modules.

Add Apple Loops and other media files
Add Apple Loops from the large collection included with Logic Pro. Apple Loops are prerecorded 
audio and MIDI files optimized to create repeating patterns that can be extended to fill any 
amount of time. You can also add audio, movies, and other prerecorded media files to a project.

Create the arrangement
Organize your recordings and other media to build an arrangement in the Tracks area. 
Recordings, loops, and other media files appear in the Tracks area as regions that you can can 
copy, move, resize, loop, and edit in other ways. You can also use arrangement markers to define 
and easily rearrange entire sections of a project.

Edit regions
Logic Pro offers a set of editors you can use to edit both audio and MIDI regions in a variety 
of ways. For audio regions, you can also precisely edit the timing of individual notes and other 
events using Flex Time, and adjust the pitch of notes using Flex Pitch.

Mix and add effects
As your project takes shape, you mix it to balance the individual parts and blend them into 
a cohesive whole. In the Mixer, you can adjust volume levels and pan (balance) positions of 
tracks, and use routing and grouping to control the signal flow. Logic Pro features a set of 
professional-quality effects that you can use to enhance particular song components and create 
a polished final mix. You can control changes to mix, effects, and other parameters over time 
using automation.
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Make global changes
You can manipulate different aspects of an overall project using global tracks, including the 
Arrangement track, Marker track, Signature track, Tempo track, Transposition track, and Beat 
Mapping track. For movie projects, you can also access the Movie track to view video frames and 
synchronize them with musical events.

Share your project
When your project is ready to share, you can export a stereo file of your final mix in one of 
several standard audio file formats. You can also produce multiple stem files, formatted for most 
common surround encoding schemes. Projects can also be burned directly to a CD or DVD.

Logic Pro interface overview

Logic Pro main window
You create and play projects in the Logic Pro main window. The main window is organized 
into different areas to help you focus on different aspects of your project, such as recording, 
arranging, and mixing. Buttons in the control bar show or hide different areas of the application.

Tracks areaControl bar

Inspector Editor area

Library button

Toolbar button

Inspector button

QuickHelp button

Mixer button

Smart Controls button

Editors button

Apple Loops button

List Editors button

Note Pad button

Browsers button
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The main areas of the Logic Pro window include:

•• Tracks area: Where you record audio and MIDI regions, add Apple Loops and other media files, 
and arrange the regions to build your project.

•• Control bar: Includes the transport controls you use to control playback of your project, 
buttons to show and hide the different areas of Logic Pro, and buttons for other frequently 
used commands. You can customize the control bar to suit your way of working.

•• Toolbar: Contains additional buttons and controls for the Tracks area and other areas of Logic 
Pro. You can show and hide the toolbar to optimize available screen space.

•• Inspector: Shows parameters for selected regions, tracks, and other items. The available 
parameters change depending on the area in which you are working, and what type of item 
is selected.

•• Smart Controls: A simplified set of visual controls that you can use to quickly modify the sound 
of the current patch without having to edit individual channel strip or plug-in settings.

•• Mixer: Shows channel strips for each track in the project, as well as auxiliary, output, and master 
channel strips. You can view and edit channel strip controls, customize routing options, and 
add and edit plug-ins in the Mixer.

•• Editors: Logic Pro features a set of editors, including the Audio Track Editor, Piano Roll Editor, 
Score Editor, Step Editor, and Audio File Editor, which you use to make precise changes to 
individual regions and their contents.

•• List Editors: An area where you can view and edit MIDI events, markers, tempo, and time 
signature events numerically.

•• Note Pad: Features text areas where you can create, view, and edit project and track notes.

•• Loop Browser: Gives you access to the included Apple Loops library so you can search for loops 
and preview them, then add them to your project.

•• Browsers: You can view the audio files in your project in the Project Audio Browser, add audio 
and movie files from the Media Browser, and browse your computer and connected storage 
devices using the All Files Browser.

You can show or hide different areas as part of the main window. Some can also be opened 
as separate, movable windows. You can also open multiple instances of the main window, and 
configure each one differently.

Open an instance of the Logic Pro main window
mm Choose Window > Open Main Window (or press Command-1).
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Tracks area
The Tracks area is the primary workspace of Logic Pro, where you record and arrange audio and 
MIDI regions to create your project. The main elements of the Tracks area include:

Tracks area menu bar Ruler

Track headers Playhead Workspace

•• Tracks area menu bar: Contains local Tracks area menus as well as tool menus, controls for 
showing track automation and Flex edits, a Catch Playhead button, Snap and Drag pop-up 
menus, a Waveform Zoom button, and scroll and zoom sliders.

•• Ruler: Shows divisions of time, either in bars and beats or in hours, minutes, and seconds. The 
ruler lets you align items in the Tracks area and mark project sections, and has additional uses 
for various playback and recording tasks. 

•• Track headers: Each track has a header that shows the track name and icon, and includes 
controls for muting and soloing the track, arming the track for recording, and other functions.

•• Workspace: All audio and MIDI regions appear on horizontal lanes called tracks, aligned to time 
positions in a grid. The workspace is the primary area for recording and arranging audio and 
MIDI regions.

•• Playhead: The thin vertical line extending from the top to bottom of the Tracks area, the 
playhead shows the part of the project currently playing or where playback starts. You 
can use the playhead to help align regions and other items, and for editing tasks, such as 
splitting regions.

For information about working in the Tracks area, see Tracks area overview.
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Library
You can view available patches for the currently selected track, and choose a new patch, in the 
Library. Categories appear on the left, and patches for the selected category are displayed on the 
right. You can search for patches, create, save, and delete patches, and choose routing options.

Track icon

Search field

Options pop-up menu

Revert button

Delete button

Save button

Category and Patch lists

•• View pop-up menu: Choose whether to view all available patches or to limit the patches 
displayed to a particular subset.

•• Track icon: The icon for the selected track is displayed in the upper part of the Library.

•• Search field: Quickly search for patches by name.

•• Category and Patch lists: Select a category on the left, then select a patch on the right.

•• Options pop-up menu: Define the default patch and merge patches.

•• Revert button: Revert to the saved settings for a patch, erasing any changes you have made.

•• Delete button: Delete a saved patch.

•• Save button: Save the patch with its current settings as a new custom patch.

You can also access the following file types in the Library, when the corresponding item is 
selected:

•• Channel strip settings (.cst)

•• Plug-in presets (.pst)

•• EXS instruments (.exs)

•• Environment instruments, and programs or banks of MIDI instruments created in the Audio 
MIDI Setup utility

•• ReWire MIDI instruments, and active ReWire hosts
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Open the Library
Do one of the following:

mm Click the Library button  in the control bar.

mm Choose View > Show Library.

For information about using the Library, see Patches overview.

Inspector
You can view and edit parameters for regions, tracks, and other items in the various inspectors. 
The parameters displayed depend on the type of item selected, and which working area has key 
focus. When you’re working in the Tracks area, the inspector displays region and track parameters 
and the inspector channel strips, as shown below:

Inspector channel strips Region inspector

Track inspector

•• Region inspector: View and edit playback parameters, including transposition and quantization, 
for selected regions. Region parameters affect the playback of regions, but don’t alter the data 
in the region itself. If you change region parameters while the project is playing, you hear the 
changes immediately.

•• Track inspector: View and edit various track parameters, including transposition, velocity, and 
delay. All regions on the track are affected by the track parameters.

•• Inspector channel strips: The left channel strip is the channel strip for the selected track. The 
right channel strip shows the output for the left channel strip by default, but can also show 
an aux used by the left channel strip (if one exists). You can adjust the level, pan, sends, and 
inserts, change effects, and control audio routing for these channel strips without opening 
the Mixer.
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Inspectors for other working areas, such as the Event inspector, Display Parameters inspector, and 
Score inspector are described in their respective chapters.

Open the inspector
Do one of the following:

mm Click the Inspector button  in the control bar.

mm Choose View > Show Inspector (or press I).

Open an inspector as a separate window
mm Drag an individual inspector by its title bar out of the main window.

Open the Region inspector as a separate window
mm Press Option-R.

Mixer
The Mixer shows the channel strips for every track in your project, including auxiliary and output 
channel strips, and the master channel strip. This makes it easy to see and adjust relative levels 
and pan (balance) positions. You can also add effects, mute and solo tracks, use busses and sends 
to control the signal flow, and use groups to control multiple channel strips.

View buttons Filter buttons

Channel strips

•• Channel strips: Use to process audio or MIDI information that is routed from tracks.

•• Channel strip controls: Adjust the level and other aspects of the audio signal played through 
the channel strip. 

•• View buttons: Use to switch between Single, Tracks, and All views, limiting the Mixer view to 
channel strips required for the task at hand. 

•• Filter buttons: Use to limit the channel strips displayed in the Mixer to specific types.

Open the Mixer
Do one of the following:

mm Click the Mixer button  in the control bar.

mm Choose View > Show Mixer (or press X).
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Open the Mixer as a separate window
mm Choose Window > Open Mixer (or press Command-2).

For more information about the Mixer, see Mixing overview on page 483. For information about 
using channel strip controls, see Channel strip controls.

Smart Controls
Smart Controls let you quickly view and adjust the most important parameters of the selected 
track, without opening the Mixer or individual plug-in windows. Each Smart Control features a 
set of screen controls. Adjusting a single screen control can modify one or more channel strip or 
plug-in parameters for the track.

Inspector button

Screen controlsSmart Control inspector

•• Smart Control inspector: Choose a different layout, view existing mappings, map screen controls 
to parameters, and assign hardware controllers to screen controls.

•• Screen controls: Visual controls that modify aspects of the sound of the track. Each Smart 
Control has a set of screen controls optimized for the type of track or instrument. Screen 
controls are labeled to make their functions easier to understand.

Open the Smart Controls pane
Do one of the following:

mm Click the Smart Controls button  in the control bar.

mm Choose View > Show Smart Controls.

Open the Smart Controls as a separate window
mm Choose Window > Open Smart Controls.

For information about working with Smart Controls, see Smart Controls overview.
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Editors

Audio Track Editor
The Audio Track Editor displays the audio waveform of the regions on an audio track. In the 
Audio Track Editor, you can copy, paste, move, trim, split, and join audio regions. Using the Audio 
Track Editor grid, you can precisely align edits with specific points in time.

RulerAudio Editor menu bar Playhead

Waveform display

•• Audio Track Editor menu bar: Contains menus with region editing commands and functions, as 
well as buttons for Flex editing, selecting editing tools, and zooming the editor.

•• Audio Track Editor inspector: When Flex Pitch is turned on, contains controls for quantizing time 
and pitch, correcting pitch, and adjusting gain.

•• Waveform display: Shows the audio waveform for the region on a time grid.

•• Ruler: Shows time divisions so you can align regions and make edits at precise time positions.

•• Playhead: Reflects the current playback position.

When Flex Pitch is turned on, you can quantize the timing and pitch of audio regions, and adjust 
their pitch and gain in the Audio Track Editor inspector. All edits in the Audio Track Editor are 
nondestructive, so you can always return to your original recordings.

Open the Audio Track Editor
mm Do one of the following:

•• Double-click an audio region in the Tracks area.

•• Select an audio track, then click the Editors button  in the control bar.

•• Select an audio track, then choose View > Show Editors.

For more information about using the Audio Track Editor, see Audio Track Editor overview. For 
information about making Flex Time and Flex Pitch edits, see Flex Time and Pitch overview.
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Piano Roll Editor
The Piano Roll Editor shows notes in MIDI regions as rectangles on a time grid. The position of 
each note on the grid shows the time position where it starts playing, its duration (length), and 
pitch. Note velocity is indicated by color.

You can edit individual notes by moving them, resizing them, dragging them vertically to change 
their pitch, and in a variety of other ways.

Piano Roll Editor menu bar Ruler Playhead

Piano Roll Editor inspector Display area

•• Piano Roll Editor menu bar: Contains menus with region editing commands and functions, as 
well as buttons for selecting editing tools and zooming the editor.

•• Piano Roll Editor inspector: Contains controls for quantizing note timing and adjusting note 
pitch and velocity.

•• Display area: Shows the notes in the MIDI region or regions as bars on a time grid.

•• Ruler: Shows time divisions so you can align and edit notes at precise time positions.

•• Playhead: Reflects the current playback position. 

Open the Piano Roll Editor
Do one of the following:

mm Double-click a MIDI region in the Tracks area.

You can change this default behavior for opening the Piano Roll Editor in Logic Pro > Preferences 
> General.

mm Select a software instrument or external instrument track, then click the Editors button  in 
the control bar.

mm Select a software instrument or external instrument track, then choose View > Show Editors.

Open the Piano Roll Editor as a separate window
mm Do one of the following:

•• Choose Window > Open Piano Roll (or press Command-6).

•• Drag the Piano Roll Editor by its title bar out from below the Tracks area.

For more information about using the Piano Roll Editor, see Piano Roll Editor overview on 
page 345.
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Drummer Editor
If you add a Drummer track to a project, you can view and edit Drummer track and region 
parameters in the Drummer Editor.

The left side of the Drummer Editor shows settings for the Drummer track, including genres and 
drummers. On the right side are parameters for the selected Drummer region, including presets, 
an XY pad for adjusting the complexity and loudness of the region performance, and controls for 
editing performance parameters, including kit piece pattern variations and fill settings.

Genres and drummers XY pad

Drummer presets Drum kit controls

Performance controls

•• Genres and drummers: Select a genre to view the drummers for that genre, then select the 
drummer for the track. 

•• Drummer presets: Choose a preset for the selected Drummer region. A preset consists of all 
region settings, visible to the right of the presets area. You can use the default settings, or you 
can edit them and save your own presets.

•• XY pad: Adjust the complexity and loudness of the region performance.

•• Drum kit controls: Turn on different instruments, and choose between different variations for 
the drum and percussion pieces. You also have the option to play half time or double time for 
kick and snare.

•• Performance controls: Adjust the number and length of fills using the Fills knob. Adjust the 
shuffle feel of the region performance using the Swing knob. Click the Details button to reveal 
additional performance controls.

Open the Drummer Editor
Do one of the following:

mm Double-click a Drummer region on a Drummer track.

mm Select one or more Drummer regions on a Drummer track, then click the Editors button  in 
the control bar.

mm Select a Drummer track, then click the Editors button .

The Drummer Editor opens below the Tracks area.
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Score Editor
The Score Editor displays MIDI regions as music notation, including notes, rests, and other MIDI 
events such as sustain pedal markings. You can add and edit notes and other musical symbols. 
Lyrics, titles, and other text can also be included in the score. You can control the display of 
individual staffs, extract parts from the score, modify the overall score layout, and print or export 
complete scores, partial scores, and parts.

Score working area

Region inspectorEvent inspector

Part box

•• Score working area: Displays music notation for selected MIDI regions, tracks, or the 
entire project.

•• Region inspector: Choose visual quantization and other display settings for selected regions.

•• Event inspector: Control appearance and position settings for individual notes and other items 
in the score.

•• Part box: Displays available musical symbols, organized in groups. Select musical symbols to 
add to the score, and customize the order of symbols in the Part box.

Open the Score Editor
mm Double-click a MIDI region in the Tracks area, then click Score.

Open the Score Editor as a separate window
Do one of the following:

mm Choose Window > Open Score Editor (or press Command-3).

mm Drag the Score Editor by its title bar out from below the Tracks area.

For more information about using the Score Editor, see Notation overview on page 607.
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Step Editor
The Step Editor displays notes or controller events for selected MIDI regions as beams in a user-
defined time grid. You can easily add or edit note velocities or other controller data (making 
some editing tasks, such as data scaling, much faster), or quickly create and edit MIDI drum parts.

Lane parameters

MIDI events

•• Lane parameters: Determine the type of event displayed or modified. When you select a row in 
the name column, its event definition is shown in the Lane inspector.

•• MIDI events: Represented by vertical beams in a time grid. Controller values, note velocity, and 
other values are indicated by the height of each beam (taller beams indicate higher values).

Open the Step Editor
mm Double-click a MIDI region in the Tracks area, then click Step Editor.

Open the Step Editor as a separate window
Do one of the following:

mm Choose Window > Open Step Editor (or press Command-5).

mm Drag the Step Editor by its title bar out from below the Tracks area.

For more information about using the Step Editor, see Step Editor overview on page 422.
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Audio File Editor

  The Audio File Editor is only available when Additional Options for both Audio and 
Advanced editing are selected in the Advanced preferences pane. It displays the audio waveform 
of regions on an audio track. In the Audio File Editor, you can destructively edit audio files (and 
regions), and use audio processing tools to quantize audio, change sample rates, and extract 
MIDI grooves from audio files.

Ruler Waveform overview

Anchor Playhead Region area Waveform display

Info display

The Audio File Editor has its own ruler, playhead, and zoom slider.

•• Ruler: Indicates the position and length of the region selected in the Tracks area, or in the 
Project Audio Browser. 

•• Info display: Displays the start point and length of the selected area.

•• Waveform overview: Displays a miniature view of the entire audio waveform.

•• Waveform display: Provides a detailed view of the area selected in the waveform overview.

•• Playhead: Reflects the current playback position. 

•• Anchor: Displays the absolute start point of the audio file.

•• Region area: Edit this beam to adjust the region length. 

Open the Audio File Editor
Do one of the following:

mm Select an audio region, then choose Window > Open Audio File Editor.

mm Option-double-click an audio region in the Project Audio Browser.

For more information about using the Audio File Editor, see Audio File Editor overview on 
page 442.
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Note Pads

Project notes
You can create, view, and edit notes for a project in the Project Notes pane. Each project can 
contain one set of project notes.

Project Text edit button

Project Text area

•• Project Text area: View and edit project notes in the Project Text area.

•• Project Text Edit button: Use to add or edit project-specific text in the Project Text area. You can 
also double-click the Project Text area.

•• Project name: Shows the name of the project.

Open the Project Notes pane
Do one of the following:

mm Click the Note Pads button  in the control bar.

mm Choose View > Show Note Pads.

Track notes
You can create, view, edit, and delete track-specific notes in the Track Notes pane. Each track that 
appears in the Tracks area can have its own set of track notes.

•• Track Text area: View and edit notes for the selected track in the Track Text area.

•• Track Text Edit button: Use to add or edit track-specific text in the Track Text area. You can also 
double-click the Track Text area.

•• Track number and name: Shows the number and name of the selected track.

Open the Track Notes pane
Do one of the following:

mm Click the Note Pads button  in the control bar, then click Track.

mm Choose View > Show Note Pads, then click Track.

For more information about track notes, see Add track notes on page 529
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List Editors

Event List
The Event List shows all the events in your project, such as MIDI note events or region start 
events, in a vertical list format. You can use it to make precise edits, and for other tasks better 
suited to numeric rather than graphic edits. You can display all events or limit them by category.

Display Level button

Add Event button and 
Type pop-up menu

Event Type buttons

List area

•• Display Level button: Click to move up one display level in the Event List. This view lets you see 
all regions in the current project.

•• Add Event button and Type pop-up menu: Add an event, and choose the type of event to add.

•• Event Type buttons: Click to show or hide specific event types, depending on the state of the 
Filter and Create buttons.

•• List area: Shows the list of events or regions, organized in columns.

Open the Event List
Do one of the following:

mm Click the List Editors button  in the control bar, then click Event.

mm Choose View > Show List Editors, then click Event.

Open the Event List as a separate window
mm Choose Window > Open Event List (or press Command-0).

For more information, see Event List overview on page 406.
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Marker List
The Marker List displays all the markers in the project. You can create, select, and edit markers in 
the Marker List, and click a marker name to move the playhead to that marker position.

Create button

Marker Text Area button
Marker Set pop-up menu

Marker List area

Marker Text area

•• Create button: Creates a marker at the playhead position.

•• Marker List area: Lists all the markers in your project, showing the name, bar position, and 
length of each marker. Drag vertically in the Position column to edit a marker’s position, or 
double-click and enter a new value.

•• Marker Text Area button: Shows or hides the Marker Text area. Use this area to enter or edit text 
for the selected marker.

•• Marker Text area: Enter text for the selected marker by double-clicking the area or clicking the 
Marker Text Area button.

•• Marker Set pop-up menu: Choose the marker set to view and edit.

Open the Marker List
Do one of the following:

mm Click the List Editors button  in the control bar, then click Marker.

mm Choose View > Show List Editors.

For more information, see Markers overview on page 560.
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Tempo List
The Tempo List displays all the tempo events in the project, and lets you create and edit 
tempo events.

Create button

Tempo Set pop-up menu

Tempo List area

•• Create button: Click to create a new tempo event.

•• Tempo List area: Displays all tempo changes, and their position in a project.

•• Tempo Set pop-up menu: Choose the tempo set to view and edit.

Open the Tempo List
Do one of the following:

mm Click the List Editors button  in the control bar, then click Tempo.

mm Choose View > Show List Editors, then click Tempo.

For more information, see Tempo List overview on page 586.
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Signature List
The Signature List shows all the time and key signature changes in your project, as well as any 
score symbols in the project score. You can create, copy, move, and delete time and key signature 
events in the Signature List.

Create button

Signature List area

Signature Set pop-up menu

•• Create button: Click to create a new signature event.

•• Signature List area: Displays all time and key signature changes, and their position in a project.

•• Signature Set pop-up menu: Choose the signature set to view and edit.

Open the Signature List
Do one of the following:

mm Click the List Editors button  in the control bar, then click Signature.

mm Choose View > Show List Editors, then click Signature.

For more information, see Time and key signatures overview on page 576.
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Loop Browser
The Loop Browser makes it easy to find Apple Loops and add them to your project. You can 
browse for loops or search using various criteria, preview matching loops, and add them to your 
project by dragging them into the Tracks area.

View pop-up menu Search field Category columns

Keyword buttons Results listVolume slider

View buttons

•• View buttons: Switch between column view, button view, and sound effects view.

•• View pop-up menu: Choose which loops to display. You can display all available loops, or filter 
loops by Jam Pack or the user’s loop library.

•• Search field: Type text to search for loops by name.

•• Keyword buttons: Filter loops by clicking keyword buttons. Matching loops appear in the results 
list below.

•• Category columns: Filter loops by choosing categories and subcategories from left to right. 
Matching loops appear in the results list below.

•• Results list: Displays all loops that match the search criteria. Click a loop to preview it, and drag 
a loop from the results list into the Tracks area to add it to your project.

•• Volume slider: Adjusts the volume of loops you are previewing.

Open the Loop Browser
Do one of the following:

mm Click the Apple Loops button  in the control bar.

mm Choose View > Show Apple Loops

For more information about using the Loop Browser, see What are Apple Loops?
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Browsers

Project Audio Browser
The Project Audio Browser shows the audio files used in the project, and displays an overview 
of the regions derived from each audio file. You can add, edit, delete, and rename audio files and 
regions in the Project Audio Browser. 

  The Project Audio Browser is available when Show Advanced Tools is selected in the 
Advanced preferences pane.

File path

Cycle button

Play button

Volume slider

•• File path: Shows the location of the audio file.

•• Name column: Displays audio files by name. Click the disclosure triangle to the left of an audio 
file to reveal regions associated with the file.

•• Icon column: Displays icons to indicate missing or timestamped files, files that follow the 
project tempo, or files that contain tempo information.

•• Info column: Shows sample rate, bit depth, input format, and file size details. Also indicates file 
length using horizontal bars. Colored sections indicate the location and size of regions within 
the audio file. The Info column can also display waveform overviews.

•• BPM column: Shows the original tempo of audio files.

•• Play button: Plays the selected audio file or region. Click again to stop playback.

•• Cycle button: Loops playback of the selected audio file or region. Use in combination with the 
Play button.

•• Volume slider: Sets the playback volume.

Open the Project Audio Browser
Do one of the following:

mm Click the Browsers button  in the control bar, then click Project.

mm Choose View > Show Browsers, then click Project.
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Open the Project Audio Browser as a separate window
mm Choose Window > Open Project Audio (or press Command-9).

For more information about using the Project Audio Browser, see Project Audio 
Browser overview.

Media Browser
Using the Media Browser, you can find and import songs from your iTunes library and movies 
from your Movies folder into a Logic Pro project. You can also import GarageBand projects into 
the current project.

Play button Search field

Results list

View buttons

•• View buttons: Switch between Audio and Movies view.

•• Audio tab: Shows the audio files in your iTunes library and Music folder.

•• Movies tab: Shows the movie files in your Movies folder and iPhoto library. If you have 
Final Cut Pro X installed on your computer, your Final Cut Pro projects also appear in the 
Movies tab.

•• Results list: Displays the media files in the selected location.

•• Play button: Click to play the selected media file, or stop playback if the file is playing.

•• Search field: Enter text to search for media files by name.

Open the Media Browser
Do one of the following:

mm Click the Browsers button  in the control bar, then click Media.

mm Choose View > Show Browsers, then click Media.

For more information about using the Media Browser, see Import media files.
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All Files Browser
  The All Files Browser is available when Show Advanced Tools is selected in the Advanced 

preferences pane. You use the All Files Browser to locate all file types that can be used in a Logic 
Pro project.

Back and Forward 
buttons

Computer, Home, and 
Project buttons

View buttons

Search field

File list

Action Pop-up menu

Play button

Volume slider

Search filters

The All Files Browser displays the following file types found on your computer or any connected 
storage device:

•• Logic Pro project files (including projects created with previous versions of Logic Pro)

•• GarageBand projects

•• Audio files

•• QuickTime movies

•• All file formats that can be imported into a Logic Pro project
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The All Files Browser includes the following features and controls:

•• Back and Forward buttons: Move back and forward through previously viewed levels of the 
folder hierarchy.

•• Computer, Home, and Project buttons: Choose the location to browse for files.

•• View buttons: Switch the file list between List view and Column view.

•• Search field: Search for files by name. Click the plus button to display additional search filters 
that allow you to narrow your search further. Results are displayed in the File list below.

•• Search filters: Narrow your search according to specific file types, file formats, length, date, size, 
and other criteria.

•• File list: Shows folders and files at the current location, or folders and files that match the 
search criteria.

•• Action pop-up menu: Use to add a selected audio file to the Project Audio Browser, show the 
file location in the Finder, use Quick Look, create a new folder, or convert ReCycle files to 
Apple Loops.

•• Play button: Plays the selected file. Click again to stop playback.

Open the All Files Browser
Do one of the following:

mm Click the Browsers button  in the control bar, then click All Files.

mm Choose View > Show Browsers, then click All Files.

For more information about using the Media Browser, see Search for media files.
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Logic Pro project basics
You start working in Logic Pro by creating a new project, or opening an existing one. A project is 
the document that contains all your recordings, the location of media files you add, and all the 
changes you make. You can have multiple projects open at the same time, and transfer media 
and other data between them.

Each project has a set of properties, including a tempo, time signature, and key signature, which 
you can define when you create the project, and change later while you’re working. Projects can 
also contain assets, including audio files, a movie file, instruments, and other files. You can save 
assets with the project or reference them in another location. For information about managing 
project assets, see Manage project assets.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can save 
a project as either a single file (package), or as a project folder containing the project file and 
subfolders for project assets. For information about saving projects, see Save projects.

For more information about working with projects, see Projects overview. For information about 
creating Logic Pro projects, see Create projects. 

The basic elements of a Logic Pro project include the following:

Tracks
The horizontal rows in the Tracks area are called tracks. Tracks help you organize and control the 
sound of the recordings, loops, and other material in a project. You record your performances on 
tracks, and arrange the regions representing the recordings, loops, and other material in a project 
on tracks. There are several types of tracks you can use in a Logic Pro project:

•• Audio tracks: Can contain audio recordings, audio Apple Loops, and imported audio files.

•• Software instrument tracks: Can contain software instrument recordings, software instrument 
Apple Loops, and imported MIDI files.

•• Drummer tracks: Can contain Drummer regions. Used in conjunction with the Drum Kit 
Designer plug-in and Drummer Editor.

•• External MIDI tracks: Can contain MIDI recordings that send MIDI data to external MIDI devices, 
such as synthesizers and sound modules.
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•• Track Stacks: Track Stacks let you organize and control multiple tracks, and create 
audio subgroups.

•• Folder tracks: Can contain folders, which are containers for other tracks. Folder tracks are not 
assigned to a channel strip in the Mixer.

There are additional track types that do not contain regions, including auxiliary (aux) and output 
tracks, used for routing the output of other tracks; global tracks, used to control aspects of the 
overall project; and the master track, which you can use to control the overall volume level of 
the project.

For more information about working with tracks, see Tracks overview. For information about 
working in the Tracks area, see Tracks area overview. For information about working with global 
tracks, see Global tracks overview.

Regions
Regions are the building blocks of a project. Each time you make a recording, drag an Apple 
Loop to the Tracks area, or add a media file to your project, a region representing the recording 
or file appears in the Tracks area.

Regions appear as rounded rectangles in the Tracks area. Different types of regions correspond to 
different track types and types of material.

•• Audio regions refer to (point to) an underlying audio file (a recording made in Logic Pro, an 
audio Apple Loop, or an imported audio file). An audio region can represent the entire audio 
file or only a portion of one. When you edit the region in the Tracks area or the Audio Track 
Editor, the original audio file is not changed.

•• MIDI regions contain MIDI data for notes and other MIDI events, such as controller and 
program change information. They are stored as part of the project, but can also be saved as 
individual files.

In the Tracks area, you can move, copy, and work with both audio and MIDI regions in a variety 
of ways to build your arrangement. You can also edit audio regions in the Audio Track Editor, 
and edit MIDI regions in the Piano Roll Editor (and the Score Editor).   When Show Advanced 
Tools is selected in the Advanced preferences pane, you can edit the source audio files for audio 
regions in the Audio File Editor.
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For more information about arranging regions in the Tracks area, see Arranging overview. 
For information about editing audio regions in the Audio Track Editor, see Audio Track Editor 
overview. For information about editing MIDI regions in the Piano Roll Editor, see Piano Roll 
Editor overview.

For more information about working with regions, see Regions overview

Patches
You can control the sound of the tracks in your project using patches. A patch can contain one or 
more channel strips, each with its own settings and plug-ins, as well as a set of Smart Controls. 
Patches can also contain auxiliary channel strips for more complex routing. You can choose a 
patch for a track in the Library when you create the track, and choose a different patch later 
while you’re working. Custom patches can be saved in the Library.

For more information about working with patches, see Patches overview.

Channel strips
Each track in a project is represented and controlled by a channel strip corresponding to the 
track type. Channel strips contain controls to adjust the volume level and pan position of the 
track, mute and solo the track, insert plug-ins, route the output signal, and control the track in 
other ways.

You can view and edit the channel strips for a project in the Mixer. The inspector displays channel 
strips for the selected track, and also for the primary destination (output) for the selected track’s 
channel strip.

In addition to track channel strips, projects contain output channel strips and a master channel 
strip (which controls the overall volume of the project). They can also contain auxiliary channel 
strips, which are used to route the output from multiple tracks to a single destination.

For more information about working with channel strips in the Mixer, see Mixing overview.

Plug-ins
Logic Pro includes a collection of professional-quality plug-ins you can use to shape the sound of 
your recordings and other material. There are several types of plug-ins used in Logic Pro channel 
strips: MIDI plug-ins, effects plug-ins, and instrument plug-ins.

•• MIDI plug-ins are inserted in software or external instrument channel strips and process or 
generate MIDI data—played from a MIDI region or a MIDI keyboard—in real time.

•• Effects plug-ins can be used in audio, instrument, auxiliary, and output channel strips. In 
general, they modify the sound (the input signal) of the channel strip.

•• Instrument plug-ins can be used on software instrument channel strips. They respond to MIDI 
note messages and so can be played using a USB music keyboard or another MIDI controller.

For more information about working with instrument and effects plug-ins, see Plug-ins overview. 
For complete information about individual plug-ins, see the Logic Pro Instruments and Logic Pro 
Effects manuals.
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Advanced tools and additional options
In Logic Pro, you can turn some advanced features on or off to suit your way of working.

Users new to Logic Pro can start working with basic features and a streamlined interface. 
In particular, users familiar with GarageBand will find a direct match for nearly all 
GarageBand features.

Upgrading Logic Pro users have access to the full power and flexibility of Logic Pro. Advanced 
tools and additional options are turned on by default, and can be controlled using the Show 
Advanced Tools and Additional Options checkboxes in the Advanced preferences pane:

  Show Advanced Tools
When you turn on Show Advanced Tools, Logic Pro’s full music production capabilities become 
available. All windows, views, menus, and key commands required for standard music production 
tasks are accessible in the application.

For existing Logic Pro users upgrading to Logic Pro X, Show Advanced Tools and all additional 
options are turned on by default.

  Additional Options
The Additional Options preference gives you access to extra capabilities for special tasks beyond 
the needs of usual music productions. When Show Advanced Tools is selected in the Advanced 
preferences pane, the following additional options are available:

•• Audio: Use the Audio File Editor, for destructive editing of audio files and advanced 
configuration options.

•• Surround: Use surround capabilities (in the Mixer) with a surround speaker setup.

•• MIDI: Use the Environment for MIDI signal flow control and real-time processing of MIDI data.

•• Score: Use additional features in the Score Editor, including the ability to assign staff styles to 
individual regions and create chord grids.

•• Control Surface: Create and edit control surface assignments.

•• Advanced edit: Use advanced editing functions including the Tempo Interpreter, and 
create aliases.

For users upgrading to Logic Pro X, any additional options used by an existing project are turned 
on by default when you open the project.

Turn on Show Advanced Tools
	 1	 Choose Logic Pro > Preferences > Advanced.

	 2	 Select the Show Advanced Tools checkbox.

Turn on Additional Options
	 1	 Choose Logic Pro Preferences > Advanced.

	 2	 Select any of the specific additional options you want to use.

Some features are only available when Show Advanced Tools is turned on, or when the 
corresponding Additional Options checkbox is selected. If a project makes use of features (for 
example, Track Stacks) that can only be created or edited when the Show Advanced Tools 
checkbox is selected, items using the feature will still play when Show Advanced Tools is 
turned off.
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Work with Logic Pro windows

Open and close windows
You can open editors and other working areas as separate windows, open multiple windows 
simultaneously, customize your window setup, and save different window arrangements as 
screensets. The contents of each window update to show your latest changes.

Only one window can have key focus at a given time, this is called the active window. When 
several normal windows overlap, the active window is the window in the foreground. The title of 
the window with key focus is black (the titles of other open windows are gray). Inside a window, 
the area with key focus (for example, the Tracks area) is bordered by a blue frame.

In the Logic Pro main window, different areas can be given key focus by clicking the background 
or title bar of the window, or by using a tool in the window. Key commands only affect the 
window or area with key focus.

Some areas, including the Preferences and Project Settings windows, can be opened as floating 
windows, which “float” in the foreground, above even the key focus window. When one floating 
window covers another, click the one you want to move to the foreground.

Open a window
mm Choose the window you want to open from the Window menu.

If the window is open, but in the background, comes to the foreground. If it’s already in the 
foreground, another window of the same type opens.

Tip:  The key commands for opening different working areas as separate windows are shown 
beside the window name in the Window menu.

Give a window key focus
mm Click the window title bar, or within the working area.

When clicking in the working area, be careful not to accidentally insert an event or region if the 
Pencil tool is active in the window.

Cycle through open windows
mm Choose Window > Cycle Through Windows (or use the corresponding key command).

This command assigns key focus to the next open window, if it is fully obscured by 
other windows.

You can also cycle through the window areas using Tab or Shift-Tab: Tab cycles forward, Shift-Tab 
cycles backward.

Close a window
Do one of the following:

mm Click the close button at the top-left corner of the window.

mm Choose File > Close (or press Command-W).

The window with key focus closes.
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Close all windows (of the active project)
mm Option-click the close button to close all windows of the active project.

Note:  If you close all open windows of a project, Logic Pro asks if you want to save your changes.

Move and resize windows
You can move and resize open windows individually, even across multiple monitors. You can also 
change the size of all window elements that feature a resize bar.

The size relationship of the Tracks area and editors in the Logic Pro main window can also be 
adjusted, by clicking between them and dragging vertically. The pointer changes to a Resize 
pointer. The vertical height of the Mixer is independent of the height you set for the editors.

Move a window
mm Drag the window to a new position. 

Adjust the size of window elements
	 1	 Move the pointer over the resize bar. 

	 2	 When the pointer turns into the Resize pointer, drag the window element. 
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Zoom windows
You can also zoom in to see regions or events in closer detail, or zoom out to see more of the 
project. Most Logic Pro windows zoom sliders.

When you zoom in or out, the top-left (and selected) event or region remains in the visible area 
of the screen. If no selected region or event is visible, zooming is centered around the playhead. 
If the playhead isn’t visible, the current center of the window is retained.

You can store three different zoom settings for each window using the Save as Zoom 1–3 key 
commands. Use the Recall Zoom 1–3 key commands to recall your zoomed settings. These 
commands only apply to the active window or window area.

Zoom the Tracks area or editor
mm Do one of the following:

•• To zoom vertically: Drag the vertical zoom slider left or right. Dragging left zooms in, while 
dragging right zooms out.

•• To zoom horizontally: Drag the horizontal zoom slider left or right. Dragging left zooms in, 
while dragging right zooms out.

Zoom the Tracks area or editor using the playhead
mm Click-hold in the lower section of the ruler, then drag the top of the playhead up or down. 

Dragging down zooms in, while dragging up zooms out.

Zoom using your computer trackpad
mm Pinch on the trackpad using two fingers. Pinch open to zoom in, or pinch closed to zoom out.
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Zoom a section of the Tracks area using the Zoom tool
	 1	 Choose Tools > Zoom (or press and hold Control-Option).

When the pointer is over an empty part of the Tracks area, you can access the Zoom function by 
pressing and holding the Option key.

	 2	 Drag to select the area you want to zoom with the Zoom tool. 

The selected area fills the window. You can repeat the process to zoom in further.

Save and recall zoom settings
	 1	 Adjust the zoom setting you want to store.

	 2	 Use one of the Save as Zoom key commands (1–3).

	 3	 To recall a saved zoom setting, use the corresponding Recall Zoom key command (1–3).

Revert to the previous zoom setting
mm Click the background with the Zoom tool.

This action returns the zoom level to the original setting, or backtracks through previous zoom 
steps if the tool was used multiple times.

Scale plug-in windows
You can adjust the size of individual plug-in windows to increase their readability. You can also 
adjust the size at which all plug-in windows open in the Mixer Display preferences pane.

Adjust the size of an individual plug-in window
Do one of the following:

mm Drag the lower-right corner of the plug-in window.

mm Choose the window size in the plug-in window’s View pop-up menu.

Set the size at which all plug-in windows open
mm Choose Logic Pro > Preferences > Display, then click the Mixer tab.

mm In the Plug-in Window section, choose the size from the Default Size pop-up menu.
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Move through display levels
The windows in a Logic Pro project have several display levels, with the Tracks area at the 
highest level, and the editors normally at the lowest level. You work on different types of tasks, 
such as arranging the overall project or refining individual regions, at different levels. In many 
cases, you can switch between these different levels directly, without needing to open or access 
another window.

Move one display level higher
Do one of the following:

mm Click the Display Level button  in the upper-left corner of a window.

mm Double-click the background area of a window.

In the Piano Roll and Step Editors, a step up the display hierarchy shows the events of all regions 
in the Tracks area. 

In the Event List, clicking the Display Level button moves you up one level in the display 
hierarchy. The display remains much the same but shows a list of regions, rather than a list of 
individual events, along with region positions, names, track numbers, and lengths. The MIDI 
region that you were just editing is selected within the list of region names.

In the Score Editor, clicking the Display Level button takes you to the higher display level. 
Double-clicking a staff (at an empty point), reverts to a lower display level.

Control how windows change as the playhead moves
You can control how windows update to reflect changes to the playhead position using Catch 
modes. When you work in Catch mode, the visible section of a window follows the playhead 
during playback or recording.

If the Catch button is inactive, the display does not update, even when the playhead moves past 
the right edge of the visible portion of the window.

In the Logic Pro > Preferences > General > Catch pane, you can set the following options:

•• Catch when Logic starts: Turns on Catch mode whenever you click Play or Pause.

•• Catch when moving playhead: Turns on Catch mode whenever you move the playhead.

You also have the option of using Catch mode together with the Scroll in Play setting. The View 
menus of all windows that display time horizontally (Tracks area, Score Editor, Piano Roll Editor, 
and Step Editor) offer the View > Scroll in Play setting. If the Catch function of the window is 
also activated, the playhead remains in the middle of the window, while the background scrolls 
smoothly from right to left. 

Turn on Catch mode
mm Click the Catch button  in the Tracks area (or editor) menu bar.

Turn on Content Catch mode
	 1	 Click the Catch button  to turn on Content Catch mode.

	 2	 Choose View > Link > Content Link.

	 3	 Turn on the Logic Pro > Preferences > General > Catch > “Catch content by position if Catch and 
Link are enabled” preference.



	 Chapter  4    Logic Pro basics	 102

Control window relationships using Link mode
  When Additional Advanced Editing Options is selected in the Advanced preferences pane, 

you can independently link or unlink windows (including the Tracks area, Score Editor, and Event 
List) to control the relationship between what they display. For example, you could set up two 
Event Lists, one showing arrange regions, and the other showing their contents, then click a 
region in the first Event List to update the contents of the second one.

The Link mode options—Off, Same Level, and Content—allow you to control how information is 
displayed when working with related editor windows.

Set the Link mode
mm Choose View > Link, then choose one of the following:

•• Off: Unlinks the window from other windows.

•• Same Level: When selected, the editor window always displays the same contents as the 
window with key focus, and updates whenever the window with key focus changes. For 
example, if the Score Editor has key focus, in Same Level Link mode, the Event List displays the 
same data as the Score Editor (numerically, of course).

•• Content: When selected, the editor window always shows the contents of the region selected 
in the window with key focus. In this case, the display level is always one level lower that of 
the top window. For example, if the Tracks area is the active window, any open MIDI editor 
shows the events of the selected MIDI region. You can also use Content Link mode in one 
Tracks area, to display the folder contents of another Tracks area.

The Score Editor also includes a Link button that you can use to set the Link mode, and view 
the current Link mode. The Link button is purple when the Link mode is set to Same Level, and 
yellow when set to Content.



	 Chapter  4    Logic Pro basics	 103

Control windows using screensets

Create, recall, and switch screensets
You position windows in a layout that suits the way you work. This layout of various windows, 
including their display size, zoom levels, position, and other settings, is called a screenset. Once 
defined, you can save, and freely switch between different screensets, much as you might 
between different computer displays.

Screensets are numbered from 1 to 99 (using only the 1 to 9 computer keys—the 0 key is 
assigned to the Stop command by default). 

You don’t need to save screensets with an explicit command. It happens automatically, as soon 
as you switch to another screenset. Thus, without any effort, your current working view is always 
stored as the current screenset.

Create a screenset
	 1	 Press any numerical key except 0; for example, 7. 

For two-digit screensets, hold down Control while entering the first digit.

	 2	 Arrange your windows, including changes to zoom settings, the relationship of the Tracks area 
and editor, open or closed inspector and Browsers or List Editors areas, and so on.

Note:  When you choose a screenset number that has not been saved, a maximized main 
window opens.

Recall or switch between screensets
Do one of the following:

mm Type the number of the screenset (1 to 9). 

For two-digit screensets, hold down Control while entering the first digit.

mm Choose the screenset from the Screenset menu.

mm Use the Next Screenset or Previous Screenset key commands. 

Note:  Screensets 1 to 9 can be recalled by freely defined key commands, not only the number 
keys on your computer keyboard. This allows you to use the number keys for other purposes, 
such as opening or closing windows. The 1 to 9 key commands are called Recall Screenset 1–9 in 
the Key Commands window.
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Switch a screenset automatically
	 1	 Select the MIDI region into which you want to insert the meta event.

	 2	 Set the playhead to the point where you want the screenset to change.

	 3	 Click the Create button in the Event List, then click the Meta Events button.

The inserted meta event has a default value of 50 (Project Select).

	 4	 Alter the number in the Num column from 50 to 49.

This changes the name to screenset.

	 5	 Enter the screenset number in the Val column.

You can stop screenset switching by muting the MIDI region that contains the meta 49 event.

Protect, copy, rename, and delete screensets
You can protect, copy, rename, and delete a screenset.

Prevent the current screenset from being altered
mm Choose Screensets > Lock (or use the Lock/Unlock Current Screenset key command).

A bullet appears in front of the screenset number to indicate that it is locked. Repeat the key or 
menu command to unlock the screenset.

Important:  The File > New command unlocks all screenset locks.

Copy screensets
	 1	 Switch to the screenset you want to copy, then choose Screensets > Duplicate (or use the 

Duplicate Screenset key command).

	 2	 In the Duplicate Screenset dialog, enter the target screenset number (the screenset number that 
you want to copy to), and give it a name.

	 3	 Click OK.
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Rename the current screenset
	 1	 Choose Screensets > Rename (or use the Rename Screenset key command).

	 2	 In the Rename Screenset dialog, do one of the following:

•• Enter a new name.

•• Click the Auto Name button to automatically name the screenset. The default is the visible 
window names. The name is automatically updated whenever a window or view is opened 
or closed.

	 3	 Click OK.

Delete the current screenset
mm Choose Screensets > Delete (or use the Delete Screenset key command).

Import screensets from another project
You can import screensets from another project. 

Import all screensets from another project
	 1	 Do one of the following:

•• Choose File > Project Settings > Import Project Settings.

•• Click the Browsers button, then click All Files to open the All Files Browser.

	 2	 Navigate to and select the project file that you want to import screensets from, then click the 
Import button.

Note:  If accessing this feature via the All Files Browser, you also need to click the Import Settings 
button, which appears after clicking the Import button.

	 3	 In the Import Settings dialog, select the Screensets option.

	 4	 Click the Import button. 

The settings are imported into the active project.

Revert to saved screensets
You can easily revert to saved screensets.

Revert to a saved screenset
mm Choose Screensets > Revert to Saved (or use the Revert to Saved Screenset key command).

Your screen is reset to its original state.
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Work with tools in Logic Pro

Tools overview
Logic Pro includes a set of tools that you can select and use for various tasks. When you select a 
tool, the pointer changes to show the selected tool. Some tools are common to all working areas, 
while other tools are specific to one or more particular working areas.

A tool (the Scissors, for example) basically affects the regions or events that you click. If multiple 
regions are selected, they are all affected by the tool (the Scissors tool would cut all selected 
regions at the same playhead position).

Tools are accessed from the Tool menus, found in the upper-right corner of all windows that 
allow direct region, event, or file editing and handling operations.

You can assign separate tools to the Left-click and Command-click Tool menus. If you have a 
suitable mouse, you can also assign the right mouse button. For information about assigning 
tools, see Assign tools.
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Assign tools
You can assign tools to the Left-click and Command-click Tool menus. The pointer adopts the 
shape of the active tool, allowing you to identify it by looking at the pointer graphic.

Command-click Tool menu

Left-click Tool menu

The Command-click Tool menu is located on the right, by default, but is located in the middle 
when a third (Right-click) tool is assigned. You can assign the Right-click tool in the Logic Pro 
General > Editing preferences pane. See General preferences on page 846.

If you have a suitable mouse, you can also assign the right mouse button to any of the following:

•• A third tool (Right-click tool)

•• Tool menu

•• Shortcut menu (default setting)

You can set two different behaviors for the Pointer tool when using it in the Tracks area.

Assign the Left-click tool
mm Click the Left-click Tool menu to open it, then choose a tool.

Press the Esc key twice to return to the default Pointer tool.

Assign the Command-click tool
mm Click the Command-click Tool menu, then choose a tool.

Releasing the Command key reverts to the Left-click tool.

Set the behavior of the right mouse button
	 1	 Choose Logic Pro > Preferences > General (or use the corresponding key command).

	 2	 Click the Editing tab, then choose a setting from the Right Mouse Button pop-up menu.
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•• Is Assignable to a Tool: When this option is chosen, a third Tool menu (Right-click Tool menu) 
appears to the right of the Left-click and Command-click Tool menus. Choose the appropriate 
menu item to assign the tool, which is available when the right mouse button is pressed 
while editing.

Left-click Tool menu

Right-click Tool menu

Command-click Tool menu

•• Opens Tool Menu: Right-clicking in the working area of the active window opens the Tool menu 
with the Pointer tool (and not the currently selected tool) located under the pointer position. 
Choose a tool by clicking it. When the Tool menu is open, you can also use the key shown next 
to a tool to select it. 

Note:  When you choose a tool from the Tool menu by right-clicking, the tool is assigned to the 
left mouse button. Right-double-clicking in the working area of the active window resets the 
assigned tool to the Pointer tool.

•• Opens Shortcut Menu: Right-clicking in the working area of the active window displays a menu 
that contains a number of area-specific selection and editing commands.



	 Chapter  4    Logic Pro basics	 109

Set the behavior of the Pointer tool in the Tracks area
	 1	 Choose Logic Pro > Preferences > General (or use the corresponding key command).

	 2	 Click the Editing tab, then select the behavior you want for the Pointer tool.

•• Fade Tool Click Zones: When selected, placing the pointer over the upper-left and upper-right 
edges of a region activates the Fade pointer and behavior. The Loop pointer and behavior can 
still be accessed in these click zones by holding down Option.

•• Marquee Tool Click Zones: When selected, placing the pointer over the lower half of a region 
(with the exception of the lower-left and lower-right edges) activates the Marquee pointer 
and behavior.

Common tools
The most common tools are briefly described in the following section. Tools for specific working 
areas or editors are covered in the respective chapters.

Pointer tool
The Pointer is the default tool when you open Logic Pro. You can use the Pointer tool to:

•• Select events, regions, or other items by clicking them.

•• Move items (by grabbing and dragging).

•• Copy items (by Option-dragging).

•• Change the length of items (by grabbing the bottom-right or bottom-left corner and 
dragging).

•• Loop regions (by grabbing the upper-right corner and dragging).

The pointer also takes the shape of this tool when outside the working area, when making a 
menu selection, or entering a value. 

Pencil tool
The Pencil tool is used to add new regions or events. You can also select, drag, loop, and alter the 
length of regions or events using the Pencil tool. 

Eraser tool
The Eraser tool is used to delete selected regions or events. When you click a region or event 
with the Eraser tool, all of the currently selected regions or events are deleted (similar to pressing 
the Delete key). The Eraser tool can also delete an unselected region or event by clicking it. 

Text tool
The Text tool is used to name regions and other items, or add text to a musical score. 

Scissors tool
The Scissors tool is used to split regions and events, allowing individual sections to be copied, 
moved, or deleted. 
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Glue tool
The Glue tool joins selected regions or events into a single region or event. 

Solo tool
Click-holding a region with the Solo tool lets you listen to the selected region or event apart 
from the rest of the project. Moving the mouse horizontally also scrubs any events the pointer 
touches. 

Mute tool
Clicking an event or region with the Mute tool prevents it from playing. You can unmute the 
region or event by clicking it a second time with the Mute tool. If multiple regions or events are 
selected, the mute state of the clicked region or event applies to all selected regions or events. 

Zoom tool
The Zoom tool allows you to zoom (up to the full window size) by dragging to select a specific 
region. You can revert to the normal zoom level by clicking the window background with this 
tool. You can also access the Zoom function—even when other tools are active—by pressing 
and holding Control-Option. When the pointer is over an empty part of the Tracks area, Piano 
Roll Editor, Score Editor, or Step Editor, you can access the Zoom function by pressing and 
holding Option.

Flex tool
The Flex tool provides you with quick access to fundamental Flex editing functionality, without 
having to turn on Flex view in the Tracks area. 
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Undo and redo edits in Logic Pro
You can undo one or more edit operations if you change your mind, and redo edits you have 
undone. Logic Pro includes an Undo History window where you can see all edits that can be 
undone in a time-ordered list. You can also change the number of steps that can be undo in 
Logic Pro preferences.

Undo your last edit operation
mm Choose Edit > Undo (or press Command-Z) immediately after making the error.

Virtually all edits, including moves, deletions, renaming, and parameter changes; and the creation 
of new events, regions, channel strips, and more, can be undone.

Open the Undo History window
mm Choose Edit > Undo History (or press Option-Z).

The Undo History window displays a list of all actions that can be undone. The most recent step 
(editing operation), which will be the first to be undone, is selected.

Undo or redo multiple steps
mm Click any entry to undo or redo all steps between the clicked and highlighted entries.

Undo or redo an isolated step
mm Command-click the step.

This will undo or redo an isolated step without influencing all steps between the clicked and 
highlighted entries. 

Erase the Undo History
mm Choose Edit > Delete Undo History.

WARNING:  Take care with this command. No undos or redos are possible for the deleted steps, 
once the Undo History has been erased.
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Change the number of undo steps
	 1	 Choose Logic Pro > Preferences > General > Editing, then click the Edit tab. 

	 2	 Change the number in the Number of Undo Steps value slider.

Download additional content
After you install Logic Pro on your computer, additional content, including software instruments, 
Drum Kit Designer drum kits, loops, and compatibility content, may be available. You can view 
the available content not installed on your computer, and select content to download, any time 
you are working, using the Additional Content window.

Jam Packs and some other content packages have a disclosure triangle, which you can click to 
show and select individual content types (instruments or loops) to download.

Some additional content may be needed to perform certain tasks. In these instances, a dialog 
appears, informing you that additional content is needed, and asking if you want to download 
it. In the Drum Kit Designer plug-in, drum kits not yet installed include a Download button that 
opens the Additional Content window.

View the Additional Content window
mm Choose Logic Pro > Download Additional Content.

Select and download additional content
	 1	 Do one of the following:

•• In the Additional Content window, select the checkbox for each content package you want 
to download.

•• To download all installed content, click the Select All Uninstalled button.

	 2	 Click Install.
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How to get help
Logic Pro provides several ways for you to get answers to questions, learn about controls 
and functions while you're working, and view detailed information about all aspects of 
the application. You can also view information directly in the application using the Quick 
Help feature.

In addition to being available from the Logic Pro Help menu, the full suite of help documents is 
available online in both HTML and PDF formats.

Quick Help
You can view a brief description of windows, controls, and other elements of the Logic Pro 
interface without leaving the application or interrupting your workflow. You can view Quick Help 
either in the inspector, or in a movable floating window.

•• To view Quick Help in the inspector, open the inspector, then choose Help > Quick Help.

•• To view Quick Help in a floating window, close the inspector, then choose Help > Quick Help.

Logic Pro Help
Describes the Logic Pro interface, commands, and menus and gives step-by-step instructions for 
creating Logic Pro projects and for accomplishing specific tasks.

•• To view Logic Pro Help from within Logic Pro, choose Help > Logic Pro Help.

•• To view Logic Pro Help online, browse to http://help.apple.com/logicpro/mac/10/.

•• To view Logic Pro Help in PDF format, browse to http://www.apple.com/support/logicpro/.

Logic Pro Instruments
Provides comprehensive instructions for using the powerful collection of instruments included 
with Logic Pro.

•• To view the Logic Pro Instruments manual from within Logic Pro, choose Help > Logic 
Pro Instruments.

•• To view the Logic Pro Instruments manual online, browse to 
http://help.apple.com/logicpro-instruments/mac/10/.

•• To view the Logic Pro Instruments manual in PDF format, browse to 
http://www.apple.com/support/logicpro/.

Logic Pro Effects
Provides comprehensive instructions for using the powerful collection of effects included with 
Logic Pro.

•• To view the Logic Pro Effects manual from within Logic Pro, choose Help > Logic 
Pro Instruments.

•• To view the Logic Pro Effects manual online, browse to 
http://help.apple.com/logicpro-effects/mac/10/.

•• To view the Logic Pro Effects manual in PDF format, browse to 
http://www.apple.com/support/logicpro/.

http://help.apple.com/logicpro/mac/10/
http://www.apple.com/support/logicpro/
http://help.apple.com/logicpro-instruments/mac/10/
http://www.apple.com/support/logicpro/
http://help.apple.com/logicpro-effects/mac/10/
http://www.apple.com/support/logicpro/
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Logic Pro Control Surfaces Support
Provides comprehensive instructions for configuring and using control surfaces with Logic Pro.

•• To view the Logic Pro Control Surfaces Support manual from within Logic Pro, choose Help > 
Logic Pro Control Surface Support.

•• To view the Logic Pro Control Surfaces Support manual online, browse to 
http://help.apple.com/controlsurfacessupport/mac/10/.

•• To view the Logic Pro Control Surfaces Support manual in PDF format, browse to 
http://www.apple.com/support/logicpro/.

Logic Remote
For iPad users, a separate application is available that lets you view detailed Help information on 
your iPad while you work in Logic Pro. The Logic Remote app is available on the App Store.

http://help.apple.com/controlsurfacessupport/mac/10/
http://www.apple.com/support/logicpro/
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Connecting overview
You can use Logic Pro with a wide variety of audio and MIDI devices, including microphones, 
keyboards and other musical instruments, mixers, and other audio equipment.

To connect audio devices to your computer, you can use an audio interface. Keyboards and 
other MIDI devices can be connected directly, or using a MIDI interface. Some audio and MIDI 
interfaces require that you install a device driver before opening Logic Pro, so the application can 
find and use the device at startup.

•• For information about connecting audio devices, see Audio devices overview.

•• For information about connecting MIDI devices, see MIDI devices overview.

Connect audio devices

Audio devices overview
Logic Pro works with Core Audio–compliant audio devices, including Thunderbolt, FireWire, 
USB, ExpressCard, and PCI audio interfaces. You can connect microphones, electric musical 
instruments, and other musical equipment to your computer, or to an audio interface or other 
audio device. Logic Pro supports input from digital audio interfaces up to a maximum sample 
rate of 192 kHz, and a maximum bit depth of 24 bits.

If you use an audio interface to connect instruments or other audio devices, check the 
manufacturer’s specifications to make sure the interface is compatible with the Mac OS X version 
required by Logic Pro. Also make sure the audio interface uses a format supported by your 
computer. Follow the manufacturer’s instructions, which may include installing the correct driver 
on your computer. Check the documentation that came with the device, and the manufacturer’s 
website, for more information.

Logic Pro automatically recognizes any installed Core Audio hardware, and uses the default 
settings as defined in the Audio MIDI Setup utility (Applications/Utilities/Audio MIDI Setup). 
However, you may want to optimize the settings for your individual hardware setup, particularly 
if you use several audio interfaces or a multiple input/output device. If possible, you should avoid 
using different audio devices for input and output.

For details about setting up your Core Audio device preferences (in the Logic Pro > Preferences > 
Audio > Core Audio pane), see Devices preferences on page 851.

Connect external devices 5
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Connect a microphone
You can connect a microphone to your computer to record your voice, an instrument, or any 
other sound to an audio track. You can connect a microphone to your computer’s audio input 
port, a USB port, or to an audio interface connected to your computer. You can also use your 
computer’s built-in microphone to record sound.

Connect a microphone to your computer
Do one of the following:

mm Connect the microphone to an input on the audio interface using a standard XLR cable.

XLR connector (balanced)  

mm Connect a USB microphone to your computer’s USB port on your computer. Choose the USB 
microphone as the track’s input source.

USB (Universal Serial Bus)

mm Connect an audio interface to your computer’s USB or FireWire port, then connect a microphone 
to the audio interface for recording.

mm Connect an audio mixer or console to an audio interface, then connect the interface to 
your computer.

mm If your computer has an audio input port, connect the microphone to the audio input, then 
choose Built-in Input as the track’s input source.

Stereo miniplug connector (unbalanced)

mm If you’re using your computer’s built-in microphone, choose Built-in Microphone as the input 
source in Logic Pro > Preferences > Audio > Devices. 

After you connect a microphone, you choose the input source for the track you want to record 
to; you can also turn on monitoring to hear sound from your microphone as you play. You can 
choose the input source in the New Tracks dialog when you create a new track, or choose it from 
the Input slot on the track’s channel strip in the Mixer or the inspector.
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Connect an electric instrument
You can connect an electric instrument, such as an electric guitar or bass, to your computer to 
play and record in an audio track. You can record the sound from your guitar to an audio track, 
and use the amps and pedalboard effects to shape your guitar sound. There are several ways to 
connect an electric instrument to your computer.

Connect an electric instrument to your computer
Do one of the following:

mm Connect an audio interface to your computer’s USB or FireWire port, then connect an electric 
instrument to the audio interface.

USB (Universal Serial Bus)

FireWire 400 (6-pin)
(Sometimes labeled iLINK)

FireWire 400 (4-pin)

FireWire 800 (9-pin)

mm Connect the electric instrument to a channel on the audio interface or the adapter cable, using a 
standard 1/4-inch tip-sleeve instrument cable.

1/4-inch Tip-Ring Sleeve (TRS) connector

1/4-inch Tip-Sleeve (TS) connector

mm If your computer has an audio input port, connect an electric instrument to the audio input port 
using an adapter cable. Choose Built-in Input as the track’s input source.

Stereo miniplug connector (unbalanced)

After you connect an electric instrument, you choose the input source for the track you want to 
record to; you can also turn on monitoring to hear your instrument as you play. You can choose 
the input source in the New Tracks dialog when you create a new track, or choose it from the 
Input slot on the track’s channel strip in the Mixer or the inspector.

If you connect your electric instrument to an audio interface, check the manufacturer’s 
specifications to make sure the interface is compatible with Mac OS X and Core Audio. Also make 
sure the audio interface uses a format supported by your computer. Follow the manufacturer’s 
instructions, which might include installing the correct driver on your computer.

Connecting some electric instruments, such as electric guitars, to your computer’s audio input 
port may result in a low-level input signal. To increase the input signal, you can connect the 
guitar to a preamplifier, and connect the preamplifier to your computer.
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Connect an audio interface
Using an audio interface, you can connect microphones, instruments, and other music 
equipment to your computer and record the output to an audio track. You can also connect a 
mixer, speakers or monitors, headphones, and other equipment to hear the audio output from 
Logic Pro.

Logic Pro supports plug-and-play for audio interfaces, making it possible to connect and turn on 
a new audio interface while Logic Pro is open. An alert appears when you connect a new device, 
and prompts you to select and confirm the audio interface and driver you want to use. 

All digital audio interfaces can be susceptible to latency—a noticeable delay between the 
time the audio signal is produced, and when you hear it. You should always attach your audio 
interface directly to the computer, rather than through a hub, or daisy-chaining it through 
another device. Doing so can cause an unacceptable amount of latency, particularly with slower 
USB 1.1 devices.

Connect an audio interface to your computer
Do one of the following:

mm Connect an audio interface to your computer’s USB or FireWire port.

USB (Universal Serial Bus)

FireWire 400 (6-pin)
(Sometimes labeled iLINK)

FireWire 400 (4-pin)

FireWire 800 (9-pin)

mm Connect an audio interface to a PCIe (Peripheral Component Interconnect Express) card installed 
in your computer. PCIe provides extremely high bandwidth and fast data transfer rates, allowing 
you to record and play back large numbers of files at the highest possible sample rates and bit 
depths. 

mm Connect an audio interface to an ExpressCard/34 slot installed in your computer. ExpressCard/34 
supports both PCIe and USB 2.0 connectivity. ExpressCards available include audio interfaces, 
hard disk controller (eSATA) cards, networking, wireless adapters, and more. 

After connecting an audio interface to your computer, be sure to set the audio interface as 
your audio input. You can then set the individual inputs on the audio interface as the input 
source for the audio tracks you want to record to. For details on choosing the audio input, see 
Devices preferences.
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Connect speakers and other audio devices
You can connect speakers or monitors to your computer to hear your projects with better 
audio quality. A variety of speakers is available that you can connect to your computer or audio 
interface. The way you connect them depends on your system and the type of speakers you use.

Surround projects require a surround speaker system. For information about using speakers in a 
Surround project, see Speaker placement.

 After connecting speakers or monitors to your computer, be sure to set them as your audio 
output. For details, see Devices preferences.

Configure a connected audio device
Many Core Audio–compliant devices don’t require a driver to work with Logic Pro. For other 
audio devices, you may need to install, select, activate, and configure the driver for the 
device. Check the instructions that came with the device, and the manufacturer’s website, for 
more information.

For devices that do require an audio driver, you configure the driver in Audio 
Devices preferences.

Open Audio Devices preferences
mm Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key command), 

then click the Devices tab.

Logic Pro automatically recognizes any installed Core Audio hardware, and uses the default 
settings as defined in the Audio MIDI Setup utility (Applications/Utilities/Audio MIDI Setup). In 
most cases, however, you may want to optimize the settings for your individual hardware setup, 
particularly if you use several audio interfaces or a multiple input/output device. If possible, you 
should avoid using different audio devices for input and output.

For details about setting up your Core Audio device preferences, see Devices preferences.

Configure Apogee and Euphonix audio devices
You can configure Apogee Digital or Euphonix audio hardware in the utilities provided 
by these manufacturers. The configuration utilities for connected devices can be opened 
directly from Logic Pro. Consult the documentation provided with the device for specific 
configuration instructions.

Open the Apogee Control Panel
mm Choose Mix > Open Apogee Control Panel.

Open the EuControl Settings
mm Choose Mix > Open EuControl Settings.
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Connect MIDI devices

MIDI devices overview
Logic Pro works with many USB and MIDI keyboard controllers and with other MIDI devices 
including sound modules, control surfaces, effects processors, mixers, lighting controllers, pedals, 
and switches. 

Logic Pro recognizes all MIDI devices set up in the Audio MIDI Setup (AMS) utility, the integrated 
audio and MIDI configuration tool of Mac OS X. You can find the AMS utility in the Applications/
Utilities folder. For more information on use, see AMS Help. 

Many controllers and other MIDI devices connect to your Mac via a USB port. If a MIDI device has 
MIDI In and Out ports rather than a USB port, you can connect it to a MIDI interface and connect 
the MIDI interface to your computer. Some MIDI interfaces are automatically recognized by your 
Mac, but others may require you to install driver software. Check the documentation that came 
with the device, and the manufacturer’s website, for more information.

Connect a USB music keyboard
You can connect a USB music keyboard to your computer to play and record software 
instruments, or record MIDI regions to use with external MIDI devices such as synthesizers or 
sound modules.

Connect a USB music keyboard to your computer
mm Connect the USB cable from the keyboard to your computer.

USB (Universal Serial Bus)

If the keyboard has MIDI ports instead of a USB port, see Connect MIDI keyboards and modules.

Be sure to follow the instructions that came with the keyboard, which may include installing the 
correct driver on your computer. Check the manufacturer’s website for the latest driver software. 
If you’re using a MIDI interface, be sure to follow the instructions that came with the interface.
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Connect MIDI keyboards and modules
You can connect a MIDI keyboard to your computer to play and record software instruments, or 
record MIDI regions to use with external MIDI devices such as synthesizers or sound modules.

Connect a MIDI keyboard
Do one of the following:

mm Connect the MIDI Out port to a MIDI In port on a MIDI interface, and connect the MIDI In port 
on the keyboard to a MIDI Out port on the MIDI interface using MIDI cables. Connect the MIDI 
interface to your computer.

MIDI Connector

mm For keyboard controllers without tone generators: You only need to connect the MIDI Out port of 
the keyboard to a MIDI In port on your MIDI interface, using a MIDI cable. 

In port 

Keyboard

Out port 

MIDI interface

Computer

mm For keyboards with tone generators: You should also connect the MIDI Out port of the MIDI 
interface to the keyboard MIDI In port. If your MIDI interface offers more than one MIDI output, 
connect any other tone generators (or other MIDI devices, such as control surfaces that require 
bidirectional MIDI communication) to these.

Keyboard

In port 

In port Out port 

Tone generatorIn port Out port 

MIDI interface

Computer
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mm If your MIDI interface has only one MIDI output: You need to connect the MIDI In of the second 
tone generator to the keyboard MIDI Thru port. A third device can be connected to the MIDI Thru 
of the second unit, and so on.

Keyboard

In port Out port 

In port Out port 

MIDI interface

Computer

Tone generator

Tone generator

MIDI Thru port 

MIDI Thru port 

In port 

In port 

The MIDI Thru port replicates the signals coming into the MIDI In port of the device. It’s better to 
use a direct connection from the computer MIDI Out port to a device, rather than chaining too 
many units, one after the other. Doing so can cause timing problems in the chain if numerous 
MIDI commands are sent quickly, due to the slight delays introduced by each MIDI In to MIDI 
Thru transaction. As such, a multi input/output MIDI interface is recommended in studios with 
several MIDI tone generators and controllers.
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About multichannel MIDI devices
Multi-timbral MIDI tone devices can simultaneously receive MIDI data on multiple MIDI channels. 
Each MIDI channel can be assigned a tone or sound, such as piano, strings, bass, and so on. 

To take full advantage of the capabilities of such multi-timbral devices, you should use separate 
MIDI Out ports (from the computer MIDI interface to the MIDI In ports) for each device. For 
example:

•• There are four MIDI devices that are capable of receiving data on multiple channels. All devices 
can receive on all 16 MIDI channels.

•• There is only one MIDI Out from the computer, and all devices are daisy-chained via MIDI Thru 
to MIDI In connections.

Logic Pro is capable of channelizing MIDI data (routing it to MIDI channels 1 to 16) and sending 
the channelized data to specific MIDI Out ports. However, in the scenario above, there is only one 
MIDI Out port available. 

In this situation, all data sent on MIDI channel 1 is sent to all four of the daisy-chained MIDI 
devices. Each device plays the incoming data with the sound assigned to channel 1.

As this example illustrates, MIDI can be separated onto different channels, but cannot be 
separated between devices, unless you use a multi-output MIDI interface. If you use a multi-
output MIDI interface rather than a single-output one, you can specify the MIDI ports on each 
device. There are no MIDI Thru connections, so Logic Pro can assign and send:

•• A recording/performance on MIDI channel 1 to port A/module 1 

•• A separate recording/performance—also on MIDI channel 1—to port B/module 2

•• A further recording/performance on MIDI channel 1 to port C/module 3, and so on with 
subsequent channels and modules

In effect, having a multi-output MIDI interface is something like having more MIDI channels. In 
this scenario, it would be like having 64 independent MIDI channels, with 16 channels per port 
(A, B, C, and D).

Not only does this allow you to play up to 64 different sounds simultaneously through 
your tone generators, it also allows full MIDI control for each channel of each device. This 
becomes increasingly important when arranging and orchestrating such a large number of 
instrument parts.

If your computer offers several MIDI inputs, you can connect the MIDI outputs of other MIDI 
expanders and controllers to it.
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Separate a MIDI keyboard from its sound generator
If your MIDI keyboard has an internal sound source, it’s important that you stop the keyboard 
from generating sounds directly from its own keyboard. 

For example, if you buy a new keyboard to be used without a sequencer, and connect it to an 
amplifier, you would expect the device to make a sound when you press its keys—in other 
words, the keyboard is directly connected to the sound generator.

When using the MIDI keyboard with Logic Pro, however, this is not what you want to happen. 
In this situation, the keyboard is used as a computer input device, and Logic Pro passes the 
incoming performance information back to the keyboard’s sound generator (or to an internal 
software instrument or another connected sound module, if you like). 

If the direct connection between the keyboard and its tone generator isn’t cut, a doubling of 
each note results—one played directly from the keyboard to the internal tone generator, and 
another sent through Logic Pro back to the tone generator. 

Not only does this cause a phased sound, but it also halves the polyphony of the keyboard’s tone 
generator. In situations where you want to control or record another sound module or software 
instrument with your keyboard, you would hear both the keyboard sound (due to the direct 
keyboard–to–tone generator connection) and the sound of the software or MIDI instrument. This 
is why the keyboard must be separated from its own internal sound generator.

This function is known as Local Off, and is set directly on your keyboard. Don’t worry about losing 
the ability to use the tone generator of your keyboard. Logic Pro will still be able to communicate 
with your keyboard tone generator just like any other connected, keyboardless sound module or 
software instrument.

Note:  If you can't find the Local Off function in the MIDI menu of your keyboard, check its 
manual on sequencer use. Some keyboards allow you to select from Local, MIDI, or Both for each 
of their Parts (individual MIDI channels/sounds in multi-timbral MIDI devices). The MIDI setting, if 
applicable to your keyboard, is the equivalent of Local Off.
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Projects overview
A project is a Logic Pro document that contains all of your recordings, the location of media files 
you add, and all the changes you make. You start working in Logic Pro by creating a project, or 
opening an existing project. You can have multiple projects open at the same time, and transfer 
media and other data between them.

Each project has project properties including tempo, key and time signature, and more. You can 
set project properties when you create a project, or later while you’re working. You can preview 
projects in the Finder using Quick Look, clean up and rename projects, and share data and 
settings between projects.

A project can include assets, such as audio and video files, sampler instruments and samples 
for the EXS24 or Ultrabeat, and Space Designer reverb impulse response files. You can manage 
project assets in a variety of ways.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can save 
a project as either a single file (package), or as a project folder containing the project file and 
subfolders for project assets. You can also create and save project alternatives, each with a 
unique name and different settings, and access saved backups of a project. 

Work with projects 6
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Create projects
You start working in Logic Pro by creating a new project. In the Project Chooser, you can choose 
a template to use as the starting point for a new project.

Each project has project properties including the project tempo, time and key signature, and 
more. You can edit some project properties in the Project Chooser when you create a project, 
and change them later while you’re working. For full details about project properties, see Project 
properties overview.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can choose 
to have Logic Pro create a project folder that contains the project file, along with subfolders 
for assets and other files used in the project (including audio files, impulse responses, sample 
instruments, samples, and Ultrabeat samples).

When you create a project folder for a new project, the project file is saved in the project folder, 
and the file types selected in the Save dialog are saved to the corresponding subfolder in the 
project folder. 

Create a project
	 1	 Choose File > New (or press Command-N). 

	 2	 In the Project Chooser, select an option from the list on the left: 

•• To see all available project templates: Click New Project.

•• To see recently open projects: Click Recent.

•• To see user-created templates: Click My Templates.

	 3	 Select the type of project you want to create.

	 4	 To edit project settings for the project, click the Details triangle in the lower-left part of the 
Project Chooser and do any of the following:
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•• To set the project tempo: Drag the Tempo slider, enter a tempo in the Tempo field, or click the 
Tap Tempo button several times.

•• To have regions in the project use the musical grid: Select the “Use musical grid” checkbox.

•• To set the key signature: Choose a key from the Key Signature pop-up menu, then click Major 
or Minor.

•• To set the time signature: Click the arrows to change the number of beats, or double-click the 
time signature and enter a new time signature.

•• To set the audio input: Choose an input source from the Audio Input pop-up menu (for audio 
tracks only).

•• To set the audio output: Choose an output (device) from the Audio Output pop-up menu.

•• To set the project sample rate: Choose a sample rate from the Sample Rate pop-up menu.

•• To set the project frame rate: Choose a frame rate from the Frame Rate pop-up menu.

•• To set the surround format for surround projects: Choose a surround format from the Surround 
Format pop-up menu.

	 5	 Click Choose.

The new project opens. 

When you create a project, the project is automatically saved. The first time you close the project, 
close Logic Pro, or create a project alternative, the Save dialog appears, so you can set the project 
name and location.   When Show Advanced Tools is selected in the Advanced preferences 
pane, you can also choose whether to save the project as a single file (package) or folder, and 
select which assets are saved in the project. For more information about saving projects, see 
Save projects.

Create an empty default project
mm Hold down Option while choosing File > New.

You can also set Logic Pro to create a project automatically on startup by choosing a startup 
action in the Logic Pro > Preferences > General > Project Handling pane. For more information, 
see General preferences.
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Open projects
You can open an existing project to continue working. You can also open several projects 
simultaneously, allowing you to copy or move data between them, or to compare different 
versions of a project.

Opening projects created in earlier Logic Pro versions
You can open projects created in Logic Pro 5 or later. Projects saved in Logic Pro X are not 
backward-compatible with earlier Logic Pro versions.

When you open a project created in an earlier version of Logic Pro, the project is converted to a 
Logic Pro X project. In the Save dialog, you can select whether to save the converted project as a 
project package or a project folder.

•• Project package: Project assets are copied to the project package, or are referenced from 
another location, depending on which asset types are selected in the Save dialog. By default, 
the converted project is saved inside the existing project folder, if one exists.

•• Project folder: Project assets are copied to the appropriate subfolders of the project folder, or 
are referenced from another location, depending on which asset types are selected in the 
Save dialog. By default, the existing project folder and subfolders are used, if present, and any 
additional subfolders needed for project assets are created.

Important:  After a project is saved as a Logic Pro X project, it can no longer be opened in earlier 
versions of Logic Pro.

You can configure Logic Pro to open a project automatically on startup by choosing a startup 
action in the Logic Pro > Preferences > General > Project Handling pane. For more information, 
see General preferences.

Open an existing project
	 1	 Choose File > Open (or press Command-O).

If another project is open, a dialog appears, asking whether you want to close the open project. 
You can turn off this prompt in the Logic Pro > Preferences > General > Project Handling tab.
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	 2	 To limit your view to a specific file type, choose the file type in the File Type pop-up menu:

•• All Logic Document Types: View all document types supported by Logic Pro.

•• Logic Projects: View projects created with the current version of Logic Pro or earlier versions.

•• GarageBand Projects: View projects created in GarageBand.

•• MIDI Files: View Standard MIDI files in either format 0 or 1.

•• AAF Files: View Advanced Authoring Format files used by other DAW applications such as 
Pro Tools.

•• XML (Final Cut Pro): View XML files supported by Final Cut Pro X.

	 3	 Locate and select the file, then click Open.

You can also open a Logic Pro project (or a MIDI file) by dragging it onto the Logic Pro icon in 
the Dock.

Open a recent project
Do one of the following:

mm Choose File > Open Recent, then choose your project.

mm In the Project Chooser, click Recent, then double-click the project.

You can clear all items in the Open Recent submenu by choosing Clear Menu.

Tip:  If you set the Startup Action in Logic Pro > Preferences > General > Project Handling to 
Open Most Recent Project, Logic Pro reopens the last open project automatically.

Open multiple projects
	 1	 Open one project, then open one or more additional projects.

	 2	 In the dialog that appears, click Don’t Close.

Switch between open projects
mm Choose the project name at the bottom of the Window menu. The active project is marked with 

a checkmark. 
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Save projects
When you save a project in Logic Pro, your recordings and all the changes you make are saved 
with the project.

Logic Pro auto-saves your work so that you don’t lose important changes if the application quits 
unexpectedly. Logic Pro shows a dialog when you reopen the project, asking if you want to use 
the auto-saved version. If you choose not to, Logic Pro opens the last manually saved version of 
the project.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can save 
a project as a package, or save it as a project folder that contains the project file, along with 
subfolders for assets and other files used in the project (including audio files, impulse responses, 
sample instruments, samples, and Ultrabeat samples).

When you save a project as a project folder, the project (package) is saved in the project folder, 
and the asset types selected in the Save or Save As dialog are saved to the corresponding 
subfolders in the project folder. 

When you save a project, you can choose whether to copy audio files and other assets in the 
project or reference them in another location. Saving assets in the project makes it safer to move 
or copy the project without losing the connection to these files. You can change these settings 
later by choosing File > Project Settings > Assets. For more information, see Manage project 
assets on page 155.

You can also save a project as a template, and use the template to create new projects. 
Saving templates makes it easier to create projects with frequently used instruments or Mixer 
configurations, or video or surround projects, for example. Screensets can be customized for 
each template, or you can copy them between templates using the various Import Settings 
commands. For more information, see Import data and settings from other projects.

Save the current project
mm Choose File > Save.

The first time you save a new project, the Save dialog appears. In the Save dialog, you can type a 
name choose the location to save the project.
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Save the project with a different name or location
	 1	 Choose File > Save As.

	 2	 In the Save As dialog, enter a new name for the project.

	 3	 Do one of the following:

•• To save the project as a file (package) containing project assets: select the Organize my project as: 
Package button.

•• To save the project as a folder containing subfolders for project assets: select the Organize my 
project as: Folder button.

	 4	 Select the type of assets to copy to the project, the click Save.

For more information about managing project assets, see Manage project assets.

Save a copy of the project, including project assets
	 1	 Choose File > Save a Copy As. 

	 2	 In the Save As dialog, enter a new name for the project.

	 3	 Select the type of assets to copy to the project, the click Save.

For more information about managing project assets, see Manage project assets.

When you choose Save a Copy as, copies of all your recordings are saved in the project copy. You 
can use the Save a Copy As option for archiving and moving data.

Save a project as a template
mm Choose File > Save As Template (or use the corresponding key command), then enter a name.

In the Project Chooser, click My Templates to view and access templates you have created. 

You can organize your templates in folders with the Create Folder button in the Save As 
Template dialog. When all your user templates are placed in subfolders, the subfolder names are 
shown below the factory collections.

Tip:  You can add descriptive text to your templates by adding a comment to the project file in 
the Finder. The Templates dialog displays the icon assigned to a template file, making it easy to 
change if you wish. For more information on how to add a comment to a file, or change the icon 
of a file, see Mac Help. 

Revert to the last saved version of a project
If you decide you don’t want to keep your latest edits to a project, you can revert to the last 
saved version of the project.

mm Choose File > Revert to (or use the corresponding key command), then choose the last saved 
version (at the top of the list).
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Delete projects
If you no longer want to keep a project, you can delete it from your computer.

Important:  If audio files and other assets are stored in a project, they are deleted with 
the project.

Delete a project
	 1	 Locate the project in the Finder.

By default, projects are saved in the Logic subfolder in the Music folder on your computer.

	 2	 Drag the project to the Trash.

If you later decide you want to keep the project, you can drag it out of the Trash if you haven’t 
emptied the Trash. After you empty the Trash, the project cannot be recovered.

	 3	 Choose Finder > Empty Trash.
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Play and navigate projects

Play a project
You can play a project any time you’re working on it, in order to hear your latest changes. When 
you play a project, playback starts from the current position of the playhead. If Cycle mode is 
turned on, playback starts from the beginning of the cycle area.

Start playback
mm Click the Play button in the control bar (or press the Space bar).

While the project is playing, the Go to Beginning button in the control bar becomes a 
Stop button.

Stop playback
mm Click the Stop button in the control bar (or Press the Space bar).

For more information about project playback, see Control playback with the transport buttons.

Set the playhead position
The playhead is the vertical line showing the current playback position in the Tracks area and 
other time-based windows (such as the Audio Track Editor, Piano Roll Editor, and Score Editor).

Set the playhead in the ruler
mm Click a position in the lower half of the ruler.

Set the playhead position in the LCD
Do one of the following:

mm Click-hold any of the numbers in the Position display and drag vertically. 

mm Double-click either display field, and then enter a new position. 

The LCD can display the playhead position in Beats or Time format, or both, depending on which 
display mode you choose. Beats displays the playhead position in bars, beats, beat divisions, 
and ticks, while Time displays the playhead position in hours, minutes, seconds, and fractions of 
a second.

You can edit the individual divisions of the Position display by dragging, or edit the position as a 
whole by double-clicking and typing.

Set the playhead to the start of a marker
mm Click anywhere on the marker while holding down Option.
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Control playback with the transport buttons
You can use the transport buttons in the control bar to control playback, or to set the playhead 
position. You can click the buttons to activate or deactivate functions, or use the corresponding 
key commands to speed up your workflow.

The default set of transport buttons includes the Rewind, Forward, Stop, Play, and Record buttons 
to the left of the LCD, and the Cycle, Replace, Autopunch, Solo, and Click (Metronome) buttons 
to the right of the LCD. You can customize the control bar to show additional buttons for other 
functions. For more information, see Customize the control bar on page 138.

Control playback with the default transport buttons
Click any of the following:

mm Rewind/Fast Rewind button: Moves the playhead one bar to the left. Click-hold to fast rewind, or 
drag to scrub playback. Command-clicking moves the playhead to the previous marker.

mm Forward/Fast Forward button: Moves the playhead one bar to the right. Click-hold to fast forward, 
or drag to scrub playback. Command-clicking moves the playhead to the next marker.

mm Stop button: Stops playback or recording. Click a second time to move the playhead to the start 
of the project, or to the left locator position when in Cycle mode. Right-click for more stop 
options. Default key command assignment: Return.

Stop button

mm Play button: Starts playback at the playhead position, or from the left locator position when in 
Cycle mode. Right-click for more play options. Default key command assignment: Return.

mm Record button: Starts or stops recording on record-enabled tracks. Default key command 
assignment: Asterisk (*).
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Use additional transport buttons
Click any of the following:

mm Go to Beginning button: Moves the playhead to the start of the project.

Pause button

Play from Right Locator button

Play from Left Window Edge button

Go to Selection Start button

Go to Left Locator button

Capture Recording button

Play from Selection button

Play from Left Locator button

Play from Beginning button

Go to Right Locator button

Go to Position button

mm Go to Position button: Moves the playhead to a target bar or time position that you specify in the 
Go to Position dialog.

mm Go to Left Locator button: Moves the playhead to the left locator position shown in the ruler. The 
left locator defines the cycle area start point. Use the cycle area to repeatedly play, or record over, 
a section.

mm Go to Right Locator button: Moves the playhead to the right locator position shown in the ruler. 
The right locator defines the cycle area end point. Use the cycle area to repeatedly play, or record 
over, a section.

mm Go to Selection Start button: Moves the playhead to the start point of the first selected region or 
event. Default key command assignment: Shift-Return.

mm Play from Beginning button: Plays from the start of the project.

mm Play from Left Window Edge button: Plays from the leftmost visible point in the active workspace.

mm Play from Left Locator button: Plays from the left locator position shown in the ruler. The left 
locator defines the cycle area start point. Use the cycle area to repeatedly play, or record over, 
a section.

mm Play from Right Locator button: Plays from the right locator position shown in the ruler. The right 
locator defines the cycle area end point. Use the cycle area to repeatedly play, or record over, 
a section.

mm Play from Selection button: Plays from the start point of the first selected region or event. Default 
key command assignment: Shift-Return.

mm Pause button: Pauses playback or recording, until you click either the Pause or Play button.

mm Capture Recording button: Captures the most recent performance, even if Logic Pro was not in 
record mode while you were playing.
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Use transport shortcut menus
Some transport functions are only accessible from shortcut menus. Both the Stop/Go to 
Beginning button and the Play button in the control bar have shortcut menus with additional 
transport functions.

Use the Stop button transport functions
	 1	 Control-click the Stop/Go to Beginning button in the control bar.

	 2	 Choose any of the following items from the shortcut menu:

•• Stop: Stops project playback.

•• Stop and Go to Left Locator: Stops playback. The playhead moves to the left locator position.

•• Stop and Go to Last Locate Position: Stops playback. The playhead moves to the last 
locate position.

•• Jump Between Marquee and Project Start: Moves the playhead back and forth between the 
marquee start position and the project start position, when Logic Pro is stopped. Only applies 
if there is an active marquee selection.

•• Jump Between Cycle and Project Start: Moves the playhead back and forth between the cycle 
area start position and the project start position, when Logic Pro is stopped. Only applies if 
there is an active cycle area.

•• Jump Between Selected Region and Project Start: Moves the playhead back and forth between 
the start position of the first selected region and the project start position, when Logic Pro is 
stopped. Only applies if a region or folder is selected.

•• Jump Between Last Locate Position and Project Start: Moves the playhead back and forth 
between the last locate position and the project start position, when Logic Pro is stopped.

Use the Play button transport functions
	 1	 Control-click the Play button in the control bar.

	 2	 Choose any of the following items from the shortcut menu:

•• Play Marquee Selection: Starts playback within a marquee selection. Playback stops at the end 
of the selection unless Cycle mode is on.

•• Play Cycle: Starts playback from the left locator position when Cycle mode is on.

•• Play From Selected Region: Starts playback from the start of the first selected region.

•• Play From Last Locate Position: Starts playback from the last playhead position.
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Use transport key commands
Some transport functions are available as key commands. Most of these transport key commands 
have no default assignment, and need to be assigned manually. See Assign key commands.

•• Play or Stop: Starts or stops playback. Press the Space bar.

Tip:  The Space bar can be used to start or stop playback of audio files or regions in the Audio 
File Editor, Project Audio Browser, or Loop Browser, when these windows have key focus.

•• Play from Previous Bar: Starts playback at the start of the previous bar.

•• Stop or Play from Last Position: Stops playback at the current playhead position, or starts 
playback from the last playhead position, depending on the play or stop status when the 
command is used.

•• Stop and Go to Left Locator: Stops playback, and moves the playhead to the left locator position.

Note:  You can assign this command directly to the Stop button, by Control-clicking the Stop 
button and choosing the setting in the shortcut menu.

•• Go to Last Locate Position: Moves the playhead to the last position reached with a positioning 
command, or direct positioning of the playhead using the mouse or ruler.

•• Stop and Go to Last Locate Position: As above, but stops playback.

Note:  You can assign this command directly to the Stop button, by Control-clicking the Stop 
button and choosing the setting in the shortcut menu.

•• Play or Stop and Go to Last Locate Position: Starts playback at the current playhead position, 
or stops playback and moves the playhead to its last position, depending on the play or stop 
status when the command is used.

•• Stop and Go to Beginning: Stops playback and moves the playhead to the project start position.

•• Shuttle Rewind and Shuttle Forward: Repeated key presses increase the winding speed. 
Repeated presses of the opposing shuttle key slow down the shuttle speed, and eventually 
change the winding direction. Shuttle disables Cycle mode. Shuttling is halted by the 
Stop command.

•• Go to Selection End: Moves the playhead to the end of the first selected region or event in the 
active window.

Note:  There are also Go To key commands for navigating with markers. For more information, see 
Navigate using markers on page 571.
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Customize the control bar
The control bar offers a default set of buttons and other controls, providing commonly used 
options. If you need to access particular functions that aren’t part of the default set, you can 
easily customize the control bar in the following ways:

•• You can show or hide the entire control bar to maximize the amount of available space in the 
main window.

•• You can show or hide individual buttons and other controls in the control bar.

•• You can open one or more giant beats display or giant time display as a floating window.

•• You can configure it to show SMPTE time with or without SMPTE view offset.

•• You can customize the time, tempo, and clock format in Display preferences. 

Change the controls on the control bar
	 1	 Control-click the control bar, then choose Customize Control Bar from the menu.

	 2	 Add or remove individual controls by selecting their checkboxes in the dialog.

	 3	 Do one of the following:

•• Click the Cancel button to keep the previously saved control bar layout.

•• Click the OK button to make the new control layout active.

•• Click the Save As Default button to save your current layout as the default, which is then 
applied whenever you create an empty new project, open a new main window, or click the 
Restore Defaults button.

•• Click the Restore Defaults button to return to the default layout.
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Set the display mode for the LCD
The LCD has five display modes, allowing you to view the time format in either musical units 
(bars and beats) or absolute time units (minutes and seconds), independent of the time format 
of the ruler.

mm Click the icon on the left side of the LCD, then choose one of the following:

•• Beats and Project: Displays the time format in bars and beats, and displays project properties 
(tempo, key, and time signature).

•• Beats and Time: Displays the playhead position in both musical and absolute time formats.

•• Beats: Displays the playhead position in musical time format.

•• Time: Displays the playhead position in absolute time format.

•• Custom: Displays the playhead position in both musical and absolute time formats, and 
displays addition information, including the tempo, project end, left and right locator 
positions, MIDI In and MIDI Out status, and CPU and HD usage meters.

Open a giant beats display or giant time display
Do one of the following:

mm To open a giant beats display: Click the icon on the left side of the LCD, then choose Open Giant 
Beats Display.

mm To open a giant time display: Click the icon on the left side of the LCD, then choose Open Giant 
Time Display.

You can open multiple giant beats and time display windows, and resize and reposition each 
one independently.

Turn the Use SMPTE View Offset setting on or off
You can set a SMPTE offset for the project. As songs don’t always need to start precisely at bar 1, 
you can select any bar position to be played at the set SMPTE time.

mm Click the icon on the left side of the LCD, then choose Use SMPTE View Offset.
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Change the time, tempo, and clock format
	 1	 Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key command).

	 2	 Choose one of the following settings in the Display Time as pop-up menu:

•• With Bits: Subframes (SMPTE bits 0 to 79) are shown.

•• Without Bits: Subframes are not shown.

•• With Quarter Frames: Quarter frames are shown.

•• As Feet Frames, 35 mm film: The display is displayed in feet and frames, for 35mm film.

•• As Feet Frames, 16 mm film: The display is displayed in feet and frames, for 16mm film.

•• With Milliseconds: The frame fractions are displayed in milliseconds instead of SMPTE bits (also 
called subframes). Remember that this value is dependent on the frame rate: at 25 fps, a frame 
is 40 milliseconds long, at 30 fps, approximately 33 ms.

•• With Samples: Frame fractions are shown as sample values.

•• With Frames and Samples: Both fractional frame and sample values are shown.

	 3	 Select the “Zeros as spaces” checkbox if you want zero values to appear as blank spaces, rather 
than the number 0 in SMPTE time displays.

	 4	 Choose one of the following settings in the Display Tempo as pop-up menu:

•• Beats Per Minute (BPM, Maelzel): Beats per minute, to four individually adjustable decimal places.

•• BPM without Decimals: Beats per minute, with no decimal places.

•• Frames Per Click with Eights: Frames per beat with eighths. After the value, you will see fpc.

•• Frames Per Click with Decimals: Frames per beat, to four decimal places. Take care, as this display 
can easily be confused with the bpm display.

	 5	 Choose a clock format from the Clock Format pop-up menu
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Use the cycle area
You can use the cycle area to repeatedly play a particular part of a project. The cycle area 
can be used for composing, practicing a part before recording, recording multiple takes, and 
other purposes.

Left locator Right locator

Cycle area

When Cycle mode is on, the cycle area is displayed as a yellow strip in the upper part of the ruler 
(or in the center, when the secondary ruler is visible).

The left and right locators are the start and end points of the cycle area. When Cycle mode is 
turned off, the cycle area (and the locators) are no longer visible.

You can also create a skip cycle to skip a passage during playback; for example, to try out 
different transitions from one project section to another without moving regions. Skip cycle is 
also useful when editing, to leave out parts of the project that you don’t want to be affected by 
the edit.

You can add buttons to the control bar to set, go to, or start playback from the left or right 
locator position, and to swap locators (for a skip cycle). For information, see Customize the 
control bar.

Turn Cycle mode on or off
Do one of the following:

mm Click the Cycle button in the control bar (or press C).

mm Click the top part of the ruler.

Set the cycle area in the ruler
mm Drag left or right in the top part of the ruler.

The cycle area appears as a yellow strip in the ruler, and Cycle mode is automatically turned on.
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Set the locator positions in the LCD
	 1	 Click the icon on the left side of the LCD, then choose Custom.

The left and right locator positions appear in both beats and time formats in the LCD.

Left locator

Right locator

	 2	 Do one of the following:

•• Click-hold individual units of the left or right locator position, then drag vertically.

•• Double-click the left or right locator position, then enter a new position.

Set the locator positions automatically
You can set the locator positions (and thereby set the cycle area) to automatically “follow” the 
marquee selection, the currently selected region, or selected note in the MIDI region. 

mm Control-click the Cycle button  in the control bar, then click Auto Set Locators.

mm Choose any of the following from the shortcut menu:

•• By Marquee Selection: The locators (and the cycle area) are set to the borders of the marquee 
selection in the marquee stripe.

•• By Region Selection: The locators (and the cycle area) are set to the borders of the currently 
selected region.

•• By Note Selection: The locators (and the cycle area) are set to the bar in which the selected 
MIDI note appears. If the note crosses multiple bars, the locators encompass all the bars in 
which the note is located.

When Auto Set Locators is selected, the Cycle button changes to indicate that the cycle area is 
set automatically.

Set the locator positions using key commands
mm Use any of the following key commands

•• Set Locators by Regions/Events: Sets the locators at the start and end points of the selected 
regions or events.

•• Set Locators and Play: Sets the locators at the start and end points of the selected regions or 
events and starts playback.

•• Set Rounded Locators by Regions/Events: Rounds the position of the locators to the barline that 
is nearest to the beginning and end points of the selected regions or events.

•• Set Rounded Locators and Play and Set Rounded Locators and Record: Rounds the position of the 
locators to the barline that is nearest to the beginning and end points of the selected regions 
or events, and starts playback or recording.

•• Set Rounded Locators and Cycle Play and Set Rounded Locators and Cycle Record: Rounds the 
position of the locators to the barline that is nearest to the beginning and end points of the 
selected regions or events, and switches to cycle play or record mode.
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Move the cycle area
mm Grab the yellow cycle strip by the middle (the pointer turns into a hand) and drag it horizontally. 

Resize the cycle area
Do one of the following:

mm Grab the left or right edge of the cycle area to move the start or end points. 

mm Shift-click a position in the ruler.

This works even when the stripe is outside the visible range, or Cycle mode is turned off.

Create a skip cycle
	 1	 Set the cycle area to the part of the project you want to skip.

	 2	 Click the Swap Left and Right Locators button in the control bar (or use the Swap Left and Right 
Locator key command).

The cycle area changes color, indicating that it is now a skip cycle.

You can add the Swap Left and Right Locators button by customizing the control bar. For 
information, see Customize the control bar.



	 Chapter  6    Work with projects	 144

Use the Chase Events function
If you start playback in the middle of a project, some events might not be heard (such as MIDI 
notes, sustain pedal events, and pitch bend events that start before the point where playback 
begins). With the Chase Events function, Logic Pro analyzes the project to include some or all of 
these events when the project plays back.

There is a potential problem when using Chase Events with notes used to trigger a drum loop 
in a sampler. Unless you start the MIDI region precisely at the beginning of the sample loop, the 
sample will be triggered at the wrong time and will play out of sync with other regions (at least 
until the next trigger note). The problem occurs because most samplers can only play samples 
from the beginning, and can’t synchronize them to the beat when started in the middle.

Set up the Chase Events function
	 1	 Choose File > Project Settings > MIDI (or use the Open MIDI Project Settings key command), 

then click the Chase tab.

	 2	 Select the checkboxes of all events you want to include in project playback.

For more information, see Chase settings on page 892.

Avoid triggering sampler drum loops when chasing note events
	 1	 In the Track inspector, select the No Transpose parameter of your drum loop instrument.

	 2	 Deselect the In ‘No Transpose’ Instrument Channel Strips option in the Logic Pro > Project 
Settings > MIDI > Chase pane. 

These settings prevent your sampler’s drum loops from playing until they reach the next trigger 
note, whenever the project jumps to a new position.

The No Transpose parameter actually prevents transposition by the region playback parameters, 
which is also not desirable for drum sounds or loops.
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Control Logic Pro using Apple Remote
You can use your Apple Remote to control Logic Pro from a distance. A short click offers the 
following functions:

Rewind

Previous track

Play or Stop

Forward

Next track

Record

A long click offers the following functions:

Fast Rewind

Stop

Fast Forward

Note:  Apple Remote is compatible with Apple products that have a built-in Infrared (IR) receiver. 
Front Row is not available while Logic Pro is open.
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Set project properties
Project properties overview
Each Logic Pro project has properties that include the project tempo, key and time signatures, 
and more. You can set project properties when you create a project, and change them later while 
you’re working. Some project properties, such as tempo and sample rate, should be set when 
you create the project if possible, because they can affect recordings or media files you add to 
the project, creating extra work.

Set the project tempo
You can set the basic project tempo in the LCD. The tempo is displayed in beats per minute 
(bpm), ranging from 5 to 990 bpm. You can also tap the tempo using your computer keyboard.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can set the 
project tempo in the Tempo track or Tempo List.

Set the basic project tempo
Do one of the following:

mm Click the icon on the left side of the LCD and choose Beats & Project, then do one of the following:

•• Click-hold the tempo value and drag up or down.

•• Double-click the tempo value, then enter a new value in the Tempo field.

mm In the Tempo List, do one of the following:

•• Click-hold the tempo value and drag up or down.

•• Double-click the tempo value, then enter a new value in the Tempo field.

mm Open the Tempo track, then drag the tempo line up or down with the Pointer tool.

mm Press Shift-T several times at the desired tempo. 

The first time you tap the tempo, an alert appears, asking if you want to enable Tap Tempo.

For information about the Tempo List, see Tempo List overview. For information about the Tempo 
track, see Tempo track overview on page 581.
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Set the project key and scale
Each project has a key, which defines the central note to which the other notes relate. By default, 
new projects are in the key of C major. You can choose a new key when you create a project, and 
change it later while you’re working. When you add Apple Loops to your project, they match the 
key of the project. 

  When Show Advanced Tools is selected in the Advanced preferences pane, you can also add 
key signature changes in a project. Key signature changes only affect the display of MIDI notes 
in the Score Editor—they do not have an effect on MIDI or Apple Loops playback. For more 
information about key signature changes, see Time and key signatures overview.

Set the project key
mm With the playhead at the start of the project, click the icon on the left side of the LCD and choose 

Beats & Project, click the key, then choose a key from the pop-up menu. 

mm In the Score Editor, double-click a staff between the clef and time signature, then choose a key in 
the Key Signature dialog. You can also drag the key signature from the Part box to the beginning 
of the project. 

mm Click the Create Key Signature button in the Signature List. 

When you change the project’s scale type from major to minor or vice versa, in some cases the 
key may change enharmonically (for example, from Db major to C# minor). These changes follow 
common practice for printed music, and affect only the key as shown in the menu, not the pitch 
of regions in your project.
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Set the project time signature
Each project has a time signature, which defines how musical time is divided into measures and 
beats. The time signature contains two numbers separated by a slash (/), which looks similar to a 
fraction. The first number controls the number of beats in each measure, and the second number 
controls the beat value (the length of the note that gets one beat).

You can set the time signature of the project in the LCD, the Signature List, or the Signature track. 
Changing the time signature does not affect project playback, but does determine the time grid 
in the Tracks area and MIDI editors.

The division value defines the division in all position displays (such as in the editors), and forms 
the grid for various length and placement operations. The division value is normally set to 1/16 
notes, but can range in value from 1/4 to 1/192 notes. If the note value of the division is equal to 
or greater than the bar denominator, the third value of the position display is removed.

Tip:  You can use the Set Next Higher/Lower Division key command to switch to the next highest 
or lowest division.

The tempo indicator in the LCD always relates to quarter notes, even if eighth notes are chosen 
as the denominator for the time signature.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can also add 
time signature changes using the Signature List or the Signature track.

Change the time signature
Do one of the following:

mm Click the icon on the left side of the LCD and choose Beats & Project, then do one of the 
following:

•• Click-hold either of the time signature values, then drag up or down.

•• Double-click the numbers in the field, then enter a new value.

mm In the Signature List:

•• Click-hold the time signature value, then drag up or down.

•• Double-click the time signature value, then enter a new value in the field.

mm Open the Signature track, then double-click the value shown. Set the Numerator and 
Denominator values (and other settings, if you like).

For more information about time signatures, see Time and key signatures overview.
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Set the project sample rate
The project’s sample rate determines the number of samples Logic Pro uses for audio playback. 
When you record or add audio files to your project, their sample rate is matched to the project 
sample rate if the “Convert audio file sample rate when importing” project setting is active. You 
can turn on this setting in the File > Projects Settings > Assets pane.

Some audio files in your project may not match the newly selected sample rate. The playback of 
files that don’t match the project’s sample rate is slower (the file’s sample rate is higher) or faster 
(the file’s sample rate is lower) than it should be. You can match the sample rate of individual 
audio files to the project sample rate in the Project Audio Browser.

Set the project sample rate
Do one of the following:

mm Choose File > Project Settings > Audio (or use the Open Audio Project Settings key command), 
then choose a sample rate from the Sample Rate pop-up menu.

mm Click the Sample Rate display in the LCD, then choose a sample rate from the pop-up menu.

Note:  If the LCD does not show the Sample Rate display, Control-click the LCD and choose 
Customize Control Bar from the shortcut menu. Select the Sample Rate checkbox in the 
Customize Control Bar dialog.
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Match a file’s sample rate with the project sample rate
mm Use the Project Audio Browser’s Copy/Convert File(s) command (which is also available by 

Control-clicking the Project Audio Browser or using the corresponding key command), then 
replace the file in the project.

Logic Pro performs a real-time, native sample rate conversion. Any sample rate available in Logic 
Pro (via Audio > Sample Rate) can be used for the conversion—even if your audio hardware 
doesn’t support the selected sample rate.

The native software sample rate conversion function matches the sample rate of any audio 
hardware, thereby allowing the playback of projects on virtually any audio system, even if 
the hardware is—in sample rate terms—not compatible. Nothing is lost in the process. Any 
internal processing and bouncing is always performed at the original sample rate, and at the 
highest quality, even in cases where the hardware doesn’t support a particular sample rate. 
This feature allows you to work on projects originally created on high-end audio systems, with 
lower-end setups.

For example, imagine a project was created with audio hardware set to operate at 96 kHz. 
Moving this project to another computer (for example, a notebook computer) that doesn’t 
support the original project’s sample rate will result in the wrong playback speed. The native 
real-time sample rate conversion function will counteract this effect, allowing correct playback of 
the project on the portable computer, at any sample rate.

Note:  Higher sample rates not only use up more disk space, but also require more processing.
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Set the project start and end points
A project normally starts at position 1 1 1 1 (as shown in the LCD, in Bars mode or in Bars and 
Time mode). You can move the project start point to an earlier position, allowing upbeats or 
program change commands to be played before the first downbeat. You can also move the 
project end point; for example, to remove unused bars at the end of the project.

Set the project start point
mm Drag the start-of-project marker in the ruler to the left or right. 

Set the project end point
Do one of the following:

mm Drag the end-of-project marker in the ruler to the left or right. 

mm Set the value in the LCD’s numerical Project End display (by click-dragging or double-clicking the 
value).

Project End display

Note:  If the Project End display doesn’t appear in the LCD, Control-click the LCD and choose 
Customize Control Bar in the shortcut menu. Select the Tempo/Project End checkbox in the 
Customize Control Bar dialog. 

During playback, a project stops when it reaches the end-of-project marker. When recording, the 
end-of-project marker moves to accommodate the end of the recording (if recording extends 
past the current position of the marker).

Set the project playback volume
You can set the basic project playback volume by dragging the Master Volume slider in the 
control bar. The Master Volume slider controls the master channel strip in the Mixer, and acts as 
a master volume control for the overall project. This slider not only sets the playback volume of 
your project, but also affects the overall volume of your mix.

Adjust the project playback volume
mm Drag the Master Volume slider left or right.

You can also control project volume using the Master track or using the master channel strip in 
the Mixer.



	 Chapter  6    Work with projects	 152

Manage projects

Project management overview
You can manage Logic Pro projects to control where files used in the project are saved, how 
projects are organized, and perform other management functions.

A project can include various assets, which are media files and other files used in the project. By 
default, project assets are saved in the project. Assets can also be referenced from an external 
location. When you save a project, you can determine whether assets are saved in the project, or 
are referenced.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can manage 
projects in the following ways.

•• Have Logic Pro create a project folder with subfolders for different asset types when you save 
a project

•• Create and edit project alternatives for the current project

•• Access different backups, which are manually saved versions of a project

•• Clean up project files to reduce the project size by removing unneeded files

•• Consolidate assets in a project

•• Rename projects from within Logic Pro

  When Additional Options: Audio is selected in the Advanced preferences pane, additional 
options for managing projects are available, including:

•• Set an external audio recording path outside the project or project folder

•• Move files out of project
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Use project alternatives and backups
  When Show Advanced Tools is selected in the Advanced preferences pane, you can create 

alternative versions of a project, each with a unique name and different settings. Alternatives 
are saved as part of the project, and share the same assets. Alternatives for the current project 
appear in the File > Alternatives submenu.

Each time you save a project by choosing File > Save (or pressing Command-S), a backup of the 
current project alternative is saved (up to ten backups per alternative). In the Project > Revert 
to submenu, backups for the current alternative are listed in descending order from newest 
to oldest.

Create an alternative version of a project
	 1	 Choose File > Alternatives > New Alternative.

	 2	 Enter a unique name for the alternative, then click Done.

Edit project alternatives
	 1	 Choose File > Alternatives > Edit Alternatives.

	 2	 In the Edit Alternatives window, select an alternative from the list, then do either of the following:

•• To rename the alternative: Click Rename, then enter a new name.

•• To delete the alternative: Click Remove.

You cannot remove the Main alternative.

	 3	 Click Done.

Choose a different alternative
mm Choose File > Alternatives, and choose a different alternative from the list.

If you have made changes after you last saved the current alternative, a Save dialog 
appears, so that you can save your changes in the current alternative before switching to a 
different alternative.

Choose a different backup of the current alternative
	 1	 Choose File > Revert to, and choose a backup from the submenu.

	 2	 In the Revert to Backup dialog, click OK.
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Clean up projects
  When Show Advanced Tools is selected in the Advanced preferences pane, you can clean up 

a project by deleting unused or unneeded media files using the Clean Up command.

Clean up project files
	 1	 Choose File > Project Management > Clean Up.

	 2	 In the dialog that appears, select the checkboxes for the cleanup options you want to apply to 
the current project.

•• Delete Unused Files: Files not used in any project alternative are deleted from the project, and 
removed from the Project Audio Browser.

Note:  Selecting Delete Unused Files will also select Delete Backups.

•• Delete Backups: Backups for all project alternatives are deleted from the project.

•• Delete Media Browser Files: Files shared to the Media Browser are deleted from the project.

	 3	 Click OK.

	 4	 A dialog appears, showing all of the files to be deleted from the project. To keep any individual 
files from being deleted from the project, deselect the Delete checkbox for those files.

	 5	 Click OK.
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Manage project assets
When you create or save a project, you can choose whether the assets you use in your project are 
saved in the project, or referenced from their location on your computer or a connected storage 
device. Assets include audio and video files, sampler instruments and samples for the EXS24 or 
Ultrabeat, and Space Designer reverb impulse response files.

Saving projects without assets can save disk space, but as a result, the project can't access the 
referenced files when moved, unless the assets are also moved.

You can manage project assets in the Assets pane of the Logic Pro project settings. You can use 
this pane to determine which specific asset types to save in the project, and which to reference 
from their external location.

MIDI data from software instrument recordings, added loops or MIDI files, and parameter settings 
for the channel strips and plug-ins are always saved as part of a project.

Open the Assets project settings
mm Choose File > Project Settings > Assets (or use the Open Assets Project Settings key command).

•• To copy the respective file types to the project: Select any of the copy checkboxes. 

•• To automatically convert the sample rate of all imported files (with a different sample rate) to 
match the project sample rate: Select the “Convert audio file sample rate when importing” 
checkbox.

•• If you deselect the “Copy EXS samples to project folder” option, only EXS instrument files are 
copied to the project when saving, not the samples associated with the EXS instrument files.

Files are copied into the project when the project is saved. 

Once the project is saved, you can move or copy the project without losing any references to 
files in the project.

You can also create your own folder structure to save the project and different assets in 
categorized folders, or reference media files anywhere on your system. You can also specify a 
recording path for audio files outside the project, in File > Project Settings > Record > Audio 
Recording Path. For more information about Recording project settings, see Recording settings.
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Consolidate assets in a project
Using the Consolidate command, you can create a “consolidated” copy of a project, and select 
which types of assets are copied into the consolidated project.

Consolidate project assets
	 1	 Choose File > Project Management > Consolidate (or use the Consolidate Project key command). 

	 2	 Select the checkboxes for the file types you want to copy into the consolidate project, then 
click OK.

Rename projects
You can rename the currently open project without leaving Logic Pro. 

If the project contains only one alternative, and both have the same name, both are renamed.

If a project contains multiple alternatives, and all alternatives have their default names (project 
name #1, project name #2, and so on), then the project and all alternatives are renamed.

Rename the current project
	 1	 Choose File > Project Management > Rename Project.

	 2	 In the dialog that appears, enter a new name for the project.

Copy and move projects
You can copy and move projects in the Finder, using any of the standard Mac OS X 
file operations.

When copying or moving project folders, keep in mind that if the project references external 
audio files or other assets, these are not copied or moved with the project. Before copying or 
moving a project to another computer or storage device, you may want to specify that all assets 
are included in the project. For information on managing project assets, see Manage project 
assets and Consolidate assets in a project.
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Import data and settings from other projects
You can import data from another project including track content (regions and folders), plug-ins 
(including settings), sends (including level, routing, and destination channel strips), Input/Output 
assignments, automation, and track notes. 

In the All Files Browser, you can choose which data to import in the Track Import view, and 
whether to add the data to new tracks in your current project, or replace existing data.

You can also import the following project settings from another project:

•• Screensets

•• Transform sets

•• Hyper sets

•• Score sets, staff styles, text styles, and settings

•• Sync settings

•• Metronome settings

•• Record settings

•• Tuning settings

•• Audio settings

•• MIDI settings

•• Movie settings

•• Asset settings

Import data from another project
	 1	 Do one of the following:

•• Choose File > Import > Logic Projects.

•• Click the All Files tab in the Browser.

	 2	 Locate and select the project from which you want to import data.

•• If using the Import dialog, the Import button becomes active.

•• If using the Browser tab, an Import button appears at the bottom-right corner of the tab.

	 3	 Click the Import button, or double-click the project file.
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The All Files Browser updates to show a Track Import view.

	 4	 Select the data that you want to import by selecting the relevant checkboxes. You can filter 
which tracks or channel strip types are displayed using the buttons above the Track Import table.

•• Num(ber): Shows the track number. No number is displayed for channel strips that do not 
appear in the Tracks area. Folder tracks are also displayed with an entry such as 3-1, where 3 is 
the track number and 1 is the folder number. You can double-click a folder track to reveal its 
contents at the next level. Note that take folder tracks are imported with all takes and comps.

•• Name: Shows the track or channel strip name as it appears in the source project.

•• Type: Shows the track or channel strip type.

•• Content: Use to import the region or folder contents of a track. In the case of folder tracks, you 
can double-click a folder to access its individual tracks.

•• Plug-ins: Use to import any plug-ins and their settings, inserted in a channel strip. The plug-ins 
are listed in their insertion order, from the top down. For software instrument channel strips, 
instrument plug-ins are also imported.

•• Sends: Use to import any sends inserted in a channel strip, including level, routing, and all 
destination channel strips.

•• I/O: Use to import the I/O settings of a channel strip.

Note:  In the case of software instrument channel strips, importing I/O settings does not 
include the instrument plug-in. See the Plug-ins entry above.

•• Auto: Use to import track automation data.

•• Notes: Use to import track-specific notes.

Tip:  You can customize the Column view by Control-clicking the table header, then showing or 
hiding the columns. You can also change the column order by dragging the column headers. 
These settings are automatically stored with the preferences when Logic Pro is closed, and apply 
to all projects.

Tip:  Press the Right Arrow key to select all checkboxes of the selected line, or the Left Arrow key 
to deselect them.
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	 5	 Do one of the following:

•• To add the selected data to the current project: Click the Add button (or hold down Command 
while pressing the Down Arrow key).

The tracks are added below the selected track in the Tracks area.

•• To replace the data of the currently selected track with the selected data from the other project: 
Click the Replace button. 

Note:  The Replace function only works when data on a single row is selected—not with 
multiple row selections.

Import settings from another project
	 1	 Do one of the following:

•• Choose File > Project Settings > Import Project Settings (or use the corresponding key 
command, default: Option-Command-I).

•• Click the All Files tab in the Browser.

	 2	 Locate and select the project from which you want to import settings, then click Import.

Note:  If accessing the settings from the Browser tab, you also need to click the Import Project 
Settings button, which appears after you click the Import button.

	 3	 In the Import Settings window, select the settings you want to import by selecting the relevant 
checkboxes, then click Import.

The settings are imported into the active project.
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Preview projects in the Finder
Every Logic Pro project includes a preview image, so that you can view the contents of a project 
in the Finder using Quick Look, without having to open the project. The image is updated each 
time the project is saved to show the current state of the project.

Preview a project with Quick Look
Do one of the following:

mm Select a project file in the Finder, then press the Space bar.

mm Browse to a project file in the All Files Browser, then choose Quick Look from the Action 
pop-up menu.

mm Browse to a project file in the All Files Browser, Control-click the file, then choose Quick Look 
from the shortcut menu.

A thumbnail image of the selected project file is displayed in Quick Look, together with a list of 
project alternatives.

Close projects
You can close the active project when you want to stop working on it.

Close the currently active project
mm Choose File > Close Project (or press Option-Command-W). 

If you have made any changes since the last Save operation, Logic Pro prompts you to save the 
project before closing.

Important:  The Close Project without Saving key command closes the currently active project 
without saving it—and you will not be asked to do so. This command was included at the 
request of many experienced Logic Pro users. Only use it if you’re sure that this is what you want 
to do.
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View project information and reorganize memory
You can view the number of regions and other objects in a project, the number of different MIDI 
events, and the amount of memory they use, in the Project Information window.

Very rarely, a project may become corrupted due to driver or memory conflicts, or may feel 
sluggish. If corruption occurs, Logic Pro displays a warning message letting you know about the 
problem. These problems can generally be fixed in the Project Information window.

The Project Information window also provides the Reorganize Memory function that allows you 
to increase the amount of free memory, and to fix a number of potential project corruptions 
or problems.

Open the Project Information window
mm Use the Project Information key command.

Reconfigure project memory
mm Click the Reorganize Memory button in the Project Information window. 

When you reorganize memory, the current project is checked for any signs of damage, structural 
problems, and unused blocks. If any unused blocks are found, you will be able to remove these, 
and repair the project.

Note:  Project memory is also reorganized automatically after saving or opening a project. A 
common (and good) use of this feature is to free up memory after closing a project, if two or 
more projects were open prior to the Close operation. 
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Tracks overview
Tracks help you organize and control the sound of the recordings and other material in a 
project. You record and arrange audio and MIDI regions on tracks in the Tracks area. Each track is 
assigned to a channel strip in the Mixer.

A Logic Pro project can include the following track types:

•• Audio tracks: Contain audio regions from audio recordings, audio Apple Loops, and imported 
audio files.

•• Software instrument tracks: Contain MIDI regions from software instrument recordings, 
software instrument Apple Loops, and imported MIDI files.

•• Drummer tracks: Behave like software instrument tracks, but with no MIDI input. Drummer 
tracks support the Drum Kit Designer plug-in so you can add virtual drummers to your 
projects. For more information, see Drummer overview.

•• External MIDI tracks: Contain MIDI regions that send MIDI data to an external MIDI device.

•• Folder tracks: Contain folders, which are containers for multiple tracks and regions. Unlike other 
tracks, folder tracks are not assigned to a channel strip in the Mixer.

Each track has a track header located to the left of the track, which shows the track’s name and 
icon. Track headers also contain controls that you can use to mute, solo, and adjust the volume 
level and pan position of the track, and control the track in other ways.

When you create a track, you choose the track type, format, and output. You can also choose a 
patch, which controls the sound of the track.

You can use Track Stacks to organize projects with high track counts, and simplify the creation of 
audio subgroups for related tracks. There are several different types of Track Stacks, designed for 
different situations.

You can edit track parameters for the selected track in the Track inspector.

Work with tracks 7
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Additionally, there are two other track types with specific functions: global tracks, and the 
master track.

•• Global tracks: These tracks, which appear below the ruler in the Tracks area and in linear 
editors, are used to view and edit different aspects of the overall project, such as tempo, which 
affect all tracks in the project. For information about global tracks, see Global tracks overview.

•• Master track: When you show the master track, it appears below all other tracks in the Tracks 
area. For information about the master track, see Work with the master track.

Track basics

Create tracks
You add tracks to a project to hold your recordings, loops, and other material. When you add 
a track, you can choose the track type, format, input source (for audio tracks), and output, and 
create multiple tracks in one operation. The options in the New Tracks dialog vary, depending on 
the type of track you are creating. 

When you create a new track, a corresponding new channel strip is also created. The new track 
appears in the Tracks area, and the new channel strip appears in the Mixer.

Create one or more new tracks
	 1	 Click the Add Tracks button , located above the track headers.

	 2	 Select the track type in the upper part of the New Tracks dialog.

	 3	 If the Details area at the bottom is closed, click the Details disclosure triangle to open it.

	 4	 Choose the input source from the Input pop-up menu.

•• For audio tracks: Choose the input channel or channels.

•• For software instrument tracks: Choose An Instrument Plug-in.

When Show Advanced Tools is selected in the Advanced preferences pane, the Input pop-up 
menu is not available for software instrument tracks.

•• For external MIDI tracks: Choose An external MIDI or USB device, then choose the input channel 
or channels from the lower Input pop-up menu.

•• For Drummer tracks: The Input pop-up menu is not available.

Tip:  Below the Input pop-up menu, a line of text shows the current input device. To change 
the input device, click the arrow next to the text, then change the device in the Audio 
preferences pane.

	 5	 Choose the audio output and output channel (or channels) from the Output pop-up menus.

Tip:  Below the Output pop-up menu, a line of text shows the current output device. To change 
the output device, click the arrow next to the text, then change the device in the Audio 
preferences pane.
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	 6	 Do any of the following:

•• To set the number of multi-timbral parts for software instrument tracks: Select the Multi-timbral 
checkbox, then enter the number of multi-timbral or layer parts.

Multi-timbral refers to the number of different sounds a software instrument can 
play simultaneously.

•• To have the Library open automatically so you can choose a patch for the track: Select the Open 
Library checkbox.

Tip:  Deselect the Open Library checkbox if you want to add an empty track containing no 
plug-ins.

•• To turn on monitoring for audio tracks: Select the “I want to hear my instrument as I play and 
record” checkbox.

When Show Advanced Tools is selected in the Advanced preferences pane, the checkbox is 
titled Input Monitoring.

•• To record-enable audio tracks: Select the “Prepare new audio tracks for immediate recording” 
checkbox.

When Show Advanced Tools is selected in the Advanced preferences pane, the checkbox is 
titled Record Enable.

•• To create multiple tracks: Select the number in the “Number of tracks to create” field, and enter 
a new number.

	 7	 Click Create.

The new track appears in the Tracks area. If the Open Library checkbox is selected, the Library 
opens so you can choose a patch for the track.

For information about choosing patches, see Choose a patch.
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Create a track below the selected track
	 1	 Control-click the track header.

	 2	 Choose one of the following from the shortcut menu.

•• To create an audio track: choose New Audio Track.

•• To create a software instrument track: choose New Software Instrument Track.

•• To create a Drummer track: choose New Drummer Track.

•• To create an external MIDI track: choose New External MIDI Track.

A new track of the chosen type, with default settings, is created below the selected track.

When you create a Drummer track, the track contains two 16-bar regions. The Drum Kit Designer 
plug-in with a default drum kit is inserted into the track’s channel strip. For more information 
about working with Drummer tracks, see Drummer overview.

Create tracks that use existing channel strips
When you create a new track using the New Tracks dialog, a new channel strip for the track 
is also created. In some situations, however, you may want to create tracks that use existing 
channel strips.

For example, when using an EXS24 mkII with a drum kit loaded, you may want to send multiple 
tracks, with MIDI regions that trigger individual drum sounds, to the channel strip on which the 
EXS24 mkII is inserted. Having a separate track for each sound allows you to independently mute 
or solo sounds in the kit. If you use a multi-output version of the EXS24 mkII, you can process 
each sound in the drum kit with different effects.

You can also copy tracks in the Tracks area. The copied track uses the same channel strip as the 
original track, and all selected regions are moved from the original track to the copy. This allows 
you to double-track or “thicken” parts, and makes it easier to create unison voicings (an octave 
apart) software instrument (or external MIDI instrument) tracks. After copying the track, you can 
replicate or restore the copied regions on the original track.

Create a track with the same channel strip or instrument assignment
	 1	 Select the track in the Tracks area.

	 2	 Do one of the following:

•• Choose Track > Other > New Track With Same Channel (or use the corresponding key 
command).

•• Option-click the Duplicate Track button  above the track headers.

A new track is created below the selected track.

Create a track with the next channel strip or instrument assignment
mm Select the track in the Tracks area, then choose Track > Other > New Track With Next Channel (or 

use the corresponding key command).

This command creates a new track below the selected track, and assigns the next channel strip 
to it. If no next channel strip exists, one is created automatically.
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Create a new track for selected regions
mm Select the regions, then choose Track > Other > New Track For Selected Regions.

The selected regions are moved from the source track to the new track, which uses the same 
channel strip as the source track. In other words, only one channel strip is used for all tracks.

If you use this command with regions selected across several tracks, a new track is created for 
each source track. For example, if you select regions on three source tracks, three new tracks will 
be created for the regions.

Create a new track for overlapped regions
mm Select the regions, then choose Track > Other > New Track For Overlapped Regions.

New tracks are created for wholly or partly overlapped regions, which are redistributed across 
the newly created tracks. A new track is created for each overlap. All tracks use the same channel 
strip as the original track. In other words, only one channel strip is used for all tracks.

Copy a track in the Tracks area
mm Option-drag the track header up or down.

All selected regions and any automation data on the original track are copied to the new track. 
The new track has the same channel strip as the original track.

Replicate or restore regions on the original track
mm Option-drag the regions on the destination track.

Reassign tracks to different channel strips
In some situations, you may want to reassign a track to a different channel strip. For example, you 
can reassign the output of a software instrument track to another instrument channel strip, so 
that the MIDI regions on both tracks are played through the same software instrument plug-in.

Reassign a track to a different channel strip
	 1	 Control-click the track header.

	 2	 Choose Reassign Track from the shortcut menu, then choose a channel strip from the submenu. 

Globally reassign multiple tracks that share the same channel strip
mm Hold down Option when reassigning a track channel strip, then confirm the action by clicking 

the Reassign All Tracks button.

The new channel strip will be used for every track that shared the original channel strip in the 
current project (including tracks in folders). 
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In addition to reassigning tracks to channel strips, you can reassign them to either of the 
following destinations:

•• No Output: Tracks assigned as No Output send no data. This can be useful in situations in 
which you want to store data (such as SysEx) that you don’t want to send from Logic Pro.

•• Folder: This setting is used when you want the track to play a folder region. (See Folders 
overview on page 325.) Normal regions will not play on a track set up for folder playback.

Select tracks
Some track operations, such as duplicating tracks or assigning tracks to a different channel strip, 
require that you first select the track or tracks.

You can select multiple tracks. When multiple tracks are selected, the first selected track is the 
focused track. Some operations, such as choosing a patch in the Library, only affect the focused 
track when multiple tracks are selected.

Select a track
mm Click any empty part of the track header.

When you select a track, all regions on the track (or those that fall within the cycle, if Cycle mode 
is on) are selected. To select a track without changing the current region selection, Option-click 
the track.

Select the track above or below the selected track
mm Use one of the following key commands:

•• Select Previous Track

•• Select Next Track

Select multiple tracks
mm Hold down Shift as you click the track headers.

Duplicate tracks
You can duplicate a track, creating a new track below the original track with the same instrument 
and effects settings. The duplicate track is empty, and does not contain any regions.

Duplicate a track
mm Select the track, then do one of the following:

•• Click the Duplicate Track button , located above the track headers.

•• Choose Track > Other > New Track With Duplicate Settings.

To copy regions from the original to the duplicate track, Option-drag them.
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Rename tracks
When you choose a patch for a track, the track takes the name of the patch. You can rename a 
track at any time.

Rename a track
Do one of the following:

mm Double-click the name in the track header, then enter a new name for the track.

mm Control-click the track header, choose Rename Track from the shortcut menu, then enter a new 
name for the track.

Change track icons
By default, tracks use the same icon as the patch chosen for the track. You can change a track’s 
icon at any time.

Change the icon for a track
Do one of the following:

mm Control-click the icon in the track header, then choose a new icon from the shortcut menu.

mm Select the track, click the track icon in the Track inspector, then choose a new icon from the Icon 
pop-up menu.

Change track colors
By default, track colors reflect the track type. You can change the color of specific tracks, to use 
color to help visually organize the Tracks area and identify tracks in a large arrangement. Track 
colors are visible when you configure track headers to show the track color bars.

Changing the color of a track also changes the color of the corresponding channel strip in 
the Mixer.

Change the color of a track
Do one of the following:

mm Select the track, choose Track > Assign Track Color, then select a color from the Color palette.

mm Control-click the track header, choose Assign Track Color from the shortcut menu, then select a 
color from the Color palette.
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Reorder tracks in the Tracks area
You can reorder tracks in the Tracks area. Changing the order of tracks doesn’t affect the sound of 
a project, but lets you organize tracks visually to keep instruments in a particular order, or keep 
related tracks together. For example, you can keep all drum tracks together, or keep all tracks that 
double the same melody together.

  When Advanced Editing options is selected in the Advanced preferences pane, you can 
also sort tracks by choosing one of the options in the Track > Sort Tracks By menu.

Reorder tracks
mm Hold down an empty part of the track header, then drag the track up or down.

Sort tracks
mm Choose Track > Sort Tracks By, then choose an item from the submenu:

•• MIDI Channel

•• Audio Channel

•• Output Channel

•• Instrument Name

•• Track Name

•• Used or Unused
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Zoom tracks
Tracks in the Tracks area can be zoomed in conjunction with, or independent of, the Tracks area 
zoom controls (and Waveform Zoom slider). There is a default zoom setting for tracks when a 
window is first opened, which provides a compromise between visibility of text and regions, and 
working space in the Tracks area.

Zoom a track
	 1	 Move the pointer to the bottom-left corner of a track. 

The pointer changes to a pair of up- and down-pointing arrows.

	 2	 Drag vertically.

The individual track zoom factor, compared to the overall window zoom level, is shown in the 
help tag while the mouse button is held down.

Automatically zoom the selected track
mm Choose View > Auto Track Zoom from the Tracks area menu bar (or press Control-Z).

Zoom all tracks
	 1	 Move the pointer to the bottom-left corner of a track. 

The pointer changes to a pair of up- and down-pointing arrows.

	 2	 Hold down Command while dragging up or down.

Reset all tracks to the default zoom level
	 1	 Move the pointer to the bottom-left corner of a track. 

The pointer changes to a pair of up- and down-pointing arrows.

	 2	 Hold down Shift while dragging up or down.

Zoom tracks using key commands
Use any of the following key commands:

mm Individual Track Zoom In and Individual Track Zoom Out: Increases or decreases the “individual track 
zoom” factor of the selected track by one. 

mm Toggle Individual Track Zoom: Switches the selected track between its individual zoom level and 
the window zoom level. This option is useful for zooming in on a track to edit its automation 
data. After editing, use the Toggle Individual Track Zoom key command to return to the original 
zoom level. 

mm Individual Track Zoom Reset: Resets the selected track to the window zoom level.

mm Individual Track Zoom Reset for All Tracks: Resets all zoomed tracks to the window zoom level.
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Replace or double drum sounds in the Tracks area
Using drum replacement, you can replace individual drum sounds on an audio track without 
re-recording the entire track. To replace or double the drum sounds, you use an audio track 
that contains a recording of a single drum (or other percussion instrument) to create a software 
instrument track with matching MIDI trigger notes. The software instrument track plays drum 
samples using the EXS24 mkII.

Replace or double a recorded drum signal
	 1	 Select the audio track with the drum recording.

	 2	 Choose Track > Replace or Double Drum Track (or use the corresponding key command).

The following changes take place in the Tracks area:

•• All files on the selected audio track are analyzed for transients (if they have not been 
previously analyzed). The selected track is vertically zoomed.

•• A software instrument track is created below the audio track, and the EXS24 is inserted into 
the Instrument slot.

•• The Library opens with the EXS24 selected, so that you can choose the sound that best 
matches the project.

•• A MIDI region containing trigger notes based on the detected transients is created on the 
software instrument track.

•• The Drum Replacement/Doubling dialog opens.
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	 3	 In the Drum Replacement/Doubling dialog, set the following parameters:

•• Instrument pop-up menu: Choose the drum sound you want to replace or double (Kick, Snare, 
Tom, or other).

•• Mode buttons: Choose one of the following modes:

•• Replacement: The new sound replaces the original, and all regions on the original track 
are muted.

•• Doubling: The new sound is added to the original (the original sound is not muted).

•• Relative Threshold slider: Set the threshold value for transients, above which trigger notes 
are generated.

•• Prelisten button: Click to start playback of both the original (audio) and replacement (software 
instrument) track from the current playhead position. The two tracks are soloed, so all other 
tracks in the project are silent.

You may want to set the playhead or activate the cycle area to prelisten to a part of the 
project requiring special attention for drum replacement. Click Prelisten again to stop 
playback, return the playhead to the previous play position, and unsolo the two tracks.

•• Trigger Note pop-up menu: Set the pitch of the trigger notes created on the software 
instrument track. Choosing AUTO (the default setting) sets the trigger note as follows:

•• Kick = C1 (36)
•• Snare = D1 (38)
•• Tom = A1 (45)
•• other = C3 (60) and AUTO menu not available, as there is no automatic choice for 
this setting.

Note:  Any changes to the trigger note do not change the instrument setting. However, any 
changes to the instrument setting change the trigger note, either to Auto or C3 (60).

•• Timing Offset slider: Shift the position of trigger notes earlier (negative values) or later (positive 
values). The offset should normally be set to 0.0 ms (which places the MIDI trigger notes 
exactly at transient timing positions), but may need to be adjusted when using your own, or 
third-party, instruments.

•• “Set average attack time” button: Set the average offset of all regions on the source audio track.

	 4	 Click OK to confirm the action.

Clicking OK resets the vertical zoom of the original audio track, mutes its regions if you selected 
the Replacement option, and deselects the track. MIDI trigger notes for the EXS24 are created on 
the software instrument track, and the track is selected.



	 Chapter  7    Work with tracks	 173

Use the track header controls

Track header overview
Each track includes a track header that displays the track name and icon, and features a number 
of track controls. By default, these include Record Enable, Mute, and Solo buttons on all tracks, 
and for audio tracks, an Input Monitoring button.

Volume sliderSolo button

Pan knobRecord Enable buttonMute button

  When Show Advanced Tools is selected in the Advanced preferences pane, additional track 
header controls are available, including an On/Off switch, Hide buttons, and Track Number and 
Color Bars options.

You can customize the track header by showing or hiding different track header controls, to 
optimize your workflow. You can also resize the track headers to give yourself more room to work 
in the Tracks area.

Configure the track header using the shortcut menu
	 1	 Control-click the track header.

	 2	 Choose Track Header Components from the shortcut menu, then choose individual items from 
the submenu.

In addition to showing and hiding track header controls, you can set the function of the Pan 
knob in the Pan/Send Knob Function submenu.

Configure the track header using the Track Header Configuration dialog
	 1	 Open the Track Header Configuration dialog by doing one of the following:

•• Choose Track > Configure Track Header (or use the corresponding key command).

•• Control-click any track header, then choose Configure Track Header from the shortcut menu.

	 2	 Modify the track header elements in the Track Header Configuration dialog.

•• Control Surface Bars checkbox: When selected, control surface bars appear, indicating which 
tracks are accessed by control surfaces connected to your system. Each control surface can 
be assigned a different color in the Device inspector. For more information, see the Logic Pro 
Control Surfaces Support manual.

•• Track Numbers checkbox: Select to display track numbers on the left side of the track headers. 
Tracks are numbered automatically in descending order.
During playback, each track number is replaced with a small level meter showing the output 
level (for audio tracks) or velocity value (for software instrument tracks).

•• Color Bars checkbox: Select to show a color bar on the left edge of each track header.
•• Groove Track checkbox: When selected, the groove on the left edge of each track header.
•• Track Icons checkbox: Select to show track icons in the track header.
•• Names section: Use the pop-up menus in this section to determine what is displayed in the 

additional name column.
•• Buttons section: Select the checkboxes of the buttons you want to display in the track header.
•• Volume button: Select to show the volume slider/level meter in the track header.
•• Pan/Sends pop-up menu: Choose whether the Pan knob controls the pan/balance setting, or 

the level of one of the available sends, from the pop-up menu.
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	 3	 Click Done.

Horizontally resize all track headers
	 1	 Position the pointer over the line dividing the track headers from the left edge of the tracks.

The pointer changes to a Resize pointer.

	 2	 Drag the line left or right to resize the track headers.

Mute tracks 
You can silence, or mute, a track so that you don’t hear it when you play the project. Muting 
tracks is useful when you want to hear how the project sounds without the track, compare 
alternative versions of a track, or try different loops in a project.

When you mute a track using the Mute button, the channel strip to which the track is assigned 
is muted; all tracks in the project that use the same channel strip are also silenced. Plug-ins on 
the muted channel strip are still processed, however, so the system responds very quickly when 
tracks are muted or unmuted. 

You can silence individual tracks assigned to the same channel strip by turning them off.

Mute a track
mm Click the track’s Mute button  in the track header.

Mute a track when the Mute buttons are hidden
mm Use the Toggle Track Mute key command (Control-M) to mute and unmute a track.

Mute multiple tracks
mm Click-hold a Mute button , then drag the pointer up or down.

The Mute buttons of all swiped tracks switch to the same state.

You can also use the Toggle Track Mute of all Tracks of Folder key command.

Mute all tracks
mm Hold down Command while clicking the Mute button  in a track header.

All Mute buttons that match the state (muted or unmuted) of the clicked button also switch 
to its new state. For example, if you click an unmuted Mute button, all unmuted tracks are 
then muted.

Muted tracks and regions appear slightly differently in the Tracks area, depending on how they 
are muted:

•• When a track is muted using its Mute button, the regions on the track are gray, but the region 
names are in color.

•• When a track is turned off using its On/Off button, both the regions on the track and the 
region names are gray.

•• When an individual region is muted, the region and its name are gray, and a small colored dot 
precedes the name.

•• When a track is muted because another track is soloed, the regions on the track are gray, but 
the region names are in color.
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Solo tracks
You can solo a track, silencing all tracks that are not also soloed. Soloing tracks is useful when 
you want to work on a track individually, or work on a few tracks, without hearing the other 
tracks in the project.

Solo a track
mm Click the track’s Solo button  in the track header.

The Solo button turns yellow, and the Mute buttons of all unsoloed tracks flash blue. Click the 
button a second time to restore the track to its previous state.

Solo a track when the Solo buttons are hidden
mm Click the Solo button in the control bar, then click the track.

Solo multiple tracks
Do one of the following:

mm Click-hold a Solo button  in a track header, then drag the pointer up or down.

The Solo buttons of all swiped tracks switch to the same state.

mm Hold down Shift while the Solo button in the control bar is active, then click the names of the 
tracks you want to solo.

Set track volume levels
You can set the volume level of each track, to balance the relative volume of the tracks in 
your project.

Adjust a track’s volume level
mm In the track header, drag the Volume slider left to lower the volume level, or drag it right to raise 

the volume level. 

Volume slider

Note:  You might have to resize the track header in order to see the Volume slider.

mm Option-click the slider to return it to a neutral level (0 dB gain).

The level meter in a track’s Volume slider shows the output volume for the track as the project 
plays. You can watch the level meter as you record to the track to see if clipping occurs on 
the track.
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Set track pan positions
The Pan/Balance (pan is short for panorama) knob controls whether a track is heard from the 
left, right, or center of the stereo field. You can set the pan or balance position for each track in 
a project.

Mono channel strips feature a Pan knob, which determines the position of a mono signal in 
the stereo image. At the center position, the Pan knob sends equal amounts of the signal to 
both sides of the stereo image. If you turn the Pan knob to the left, more of the signal moves to 
the left.

Stereo channel strips display a Balance knob, which differs from the Pan knob in that it controls 
the relative levels of two signals (Left and Right) at the stereo outputs.

Adjust a track’s pan or balance position
mm In the track header, drag the Pan/Balance knob counterclockwise to pan to the left, or drag 

clockwise to pan to the right. The “dot” on the wheel indicates the position.

Pan/Balance knob

Note:  You might have to resize the track header in order to see the Pan/Balance knob.

mm Option-click the Pan/Balance knob to return it to the center position.

When a channel strip output is set to Surround, the Pan or Balance knob is replaced by a 
Surround Panner. For information about using surround channel strips, effects, and the surround 
panner, see Logic Pro X surround overview.

Enable tracks for recording
You can use a track’s Record Enable button to arm the track for recording.

Note:  When Show Advanced Tools is selected in the Advanced preferences pane, Record Enable 
buttons appear with the letter “R.” When Show Advanced Tools is not selected, Record Enable 
buttons appear with a circle that lights red when the track is record-enabled.

Enable a track for recording
	 1	 Click the Record Enable button in the track header.

Click the Record Enable button again to disable the track for recording.

You can also select one or more tracks with different inputs in the Tracks area, and use the 
Record Enable Track key command (default: Control-R) to enable them for recording.
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Turn on input monitoring for audio tracks
You can turn on input monitoring to monitor audio tracks that are not enabled for recording. 
This is useful for setting audio levels or practicing parts before you commit to recording. 

Tip:  You can leave input monitoring turned on before, after, and during recording. When 
input monitoring is on, the Record Enable button and the Auto Input Monitoring feature do 
not affect software monitoring—that is, you can always hear incoming audio signals. When 
you’re punch recording, however, you should use Auto Input Monitoring rather than the Input 
Monitoring buttons. For more information about Auto Input Monitoring, see Punch in and out of 
audio recordings.

Turn on input monitoring for an audio track
mm Click the Input Monitoring button (with the “I” icon) in the track header.

Click the Input Monitoring button again to turn off input monitoring for the track.

Note:  Input monitoring always involves some latency. The amount of latency depends on the 
audio hardware and the driver settings. In certain configurations, it may be best not to turn on 
input monitoring, to obtain the best possible timing. Route the signal you want to record directly 
to headphones or a monitoring amplifier—and to the audio interface inputs, for recording. 
You won’t accidentally overdrive your A/D converters, because the input level meters display a 
clipping warning if an overload occurs.

Turning off tracks
  When Show Advanced Tools is selected in the Advanced preferences pane, you can turn 

tracks off in the Tracks area. Turning off a track lets you silence a track while still hearing other 
tracks in the project assigned to the same channel strip.

When no other track is assigned to the same channel strip, turning off a track also saves 
processing power, because plug-ins on the channel strip are no longer processed. Turning a 
track off (or turning it back on) takes slightly longer than muting or unmuting the track, due to 
internal pre-processing. Unlike muting a track, turning off a track can not be automated.

Turn off a track
mm Click the On/Off switch  in the track header.

To turn the track on, click the On/Off switch again.
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Protect tracks
You can protect a track to prevent accidental changes. While a track is protected, you can’t record 
on the track, edit regions on the track, or create new regions on the track. If you want to edit the 
track, you can unprotect it, make the changes, and then protect the track again.

Protect a track
	 1	 Click the Protect button  in the track header.

If the Protect button isn’t visible in the track header, you can display it using the Track Header 
Configuration dialog.

The lock turns green to indicate that the track is protected.

	 2	 To unprotect the track, click the Protect button  again.

Protect all tracks
	 1	 Command-click the Protect button  in any track header.

The locks turn green to indicate that all tracks are protected.

To change the state of multiple tracks, click-hold the Protect button of one track, then drag the 
pointer up or down. The Protect buttons of all swiped tracks switch to the same state.

	 2	 To unprotect all tracks, Command-click the Protect button  on any track header.

If you try to make changes to a protected track, a dialog tells you that the track is locked.

Freeze tracks
  When Show Advanced Tools is selected in the Advanced preferences pane, you can freeze 

a track, to reduce the processing power needed to play the track. Freezing a track reduces its 
CPU usage to that of a high-resolution audio track with no effects plug-ins inserted, regardless 
of the number or complexity of the plug-ins used on the track. Freezing is particularly useful 
for software instrument tracks, and for audio tracks that use complex effects. Freezing is not 
available for multi-output software instruments.

When you freeze a track, the track is bounced to an audio file. The freeze file includes the plug-
ins for the track, and any track automation. While a track is frozen, the freeze file plays back in 
place of the original track. The original track and plug-ins are temporarily deactivated. Channel 
strip controls (such as track mute and solo) are available, but no track content can be edited 
(including region mute and solo, for example).

While a track is frozen, it cannot be edited. If you want to edit the track, you can unfreeze it, make 
the changes, and then freeze the track again.

Freeze is designed to circumvent very CPU-intensive processes, such as software instruments 
with a complex voice architecture, and complex plug-ins (such as reverbs, filter banks, or FFT-
based effects). If your computer can calculate all active processes in real time, freezing tracks 
is unnecessary. Freezing tracks is recommended when tracks with CPU-intensive software 
instrument or effects plug-ins are in a finalized state, or require no further changes.

By freezing tracks, you can:

•• Use extra effects plug-ins or software instruments in additional audio or software instrument 
tracks, which would normally be impossible as it would exceed the CPU-processing limits of 
your computer.

•• Play back projects created on computers with greater CPU power.
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Freeze a track
	 1	 Click the Freeze button  in the track header.

The lock turns blue to indicate that the track is ready to freeze.

	 2	 In the Track inspector, choose a Freeze mode:

•• Source Only: Freezes the track signal without any effects plug-ins. When selected, the Freeze 
button becomes solid.

Note: This Freeze mode is useful when using processor-intensive software instruments or 
flex modes.

•• Pre Fader: Freezes the track signal including all effects plug-ins. When selected, the Freeze 
button shows a dot.

	 3	 Click the Play button  in the control bar.

	 4	 To unlock the track, click the Freeze button again.

To change the freeze state of multiple tracks, click-hold the Freeze button of one track, then drag 
the pointer up or down. The Freeze buttons of all swiped tracks switch to the same state.

If you try to make changes to a frozen track, a dialog tells you that the track is frozen.

Hide tracks
  When Show Advanced Tools is selected in the Advanced preferences pane, you can hide 

tracks in the Tracks area. This is useful when you’re working on projects using a large number of 
tracks, for example. Hidden tracks play back as usual.

You can hide and unhide tracks using the menu commands in the Track menu (Hide Track, 
Unhide All Tracks, and Show Hidden Tracks), or using key commands. The first time you hide a 
track, you use the key command, after which the Hide button appears above the track headers.

Hide one or more tracks
	 1	 Click the Hide button (with the letter H) above the track headers to show the Hide buttons in the 

track headers.

	 2	 Do one of the following:

•• Click the Hide buttons in the track headers of the tracks you want to hide.

•• Control-click the track header of each track you want to hide, then choose Hide Track from the 
shortcut menu.

	 3	 Choose Track > Hide Hidden Tracks, or click the Hide button above the track headers again.

The tracks with active Hide buttons are hidden.

	 4	 To unhide the hidden tracks, choose Track > Unhide All Tracks, or click the Hide button above the 
track headers again.
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Hide or unhide a track using key commands
	 1	 Select the track.

	 2	 Press H.

To unhide the hidden track, press H again.

The following menu functions and key commands also affect the Hide Tracks feature:

•• Even when the toolbar Hide button is deactivated, you can still hide an individual track with 
the Track > Hide Track and Select Next Track command (or press Control-H).

•• The Track > Unhide All Tracks command (or the corresponding key command) will reset the 
Hide buttons of each track, making them all visible.

Note:  Hiding tracks doesn’t affect playback. You can also link the Hide functions of all tracks 
belonging to a group by selecting Hide in the Group Property Settings. (For more information 
on groups, see Grouping overview.) Keep in mind that there is no Unhide Selected Track key 
command because there is no way that you can select a hidden track.

Delete tracks
You can delete a track to remove it from the project. When you delete a track, all regions on the 
track are deleted.

Delete a track
mm Control-click the track header, then choose Delete Track from the shortcut menu.

Edit multiple tracks using slide activation
You can make edits to multiple tracks in the Tracks area simultaneously by dragging the pointer 
vertically over track header buttons (such as Solo, Mute, Hide, Protect, and Freeze) on multiple 
tracks. Slide activation is similar to running your finger across several channel strip buttons on 
good hardware mixing consoles. 

To try out slide activation in Logic Pro, click-hold the Mute button  of one track, then drag the 
pointer up or down. The Mute buttons of all swiped tracks switch to the same state. 

Simply drag over the Mute buttons of the same tracks to undo the mute.

Edit track header controls on multiple tracks
mm Click-hold a track header button on one track header, then drag the pointer up or down over 

additional tracks.

The corresponding buttons on all the swiped tracks switch to the same state.
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Work with patches in the Library

Patches overview
A patch contains the instrument, effects, and routing settings that control the sound of a track. 
When you choose a patch, those settings are applied to the currently selected track. You can try 
a different sound for the track by choosing a different patch, as long as the patch is compatible 
with the track type.

You can choose a patch in the Library when you create a track, and choose a different patch at 
any time while you’re working. The patches displayed in the Library depend on the track type. 
For example, when an audio, software instrument, or Drummer track is selected, patches for that 
track type are available.

Patches can include one or more channel strip settings, and can also contain routing information 
(auxes) and metadata (for Smart Controls and controller mapping). Patches for audio tracks can 
include default effects settings. Patches for software instrument tracks include an instrument 
plug-in as well as effects settings.

You can edit patches by changing channel strip settings, adding plug-ins, or editing plug-in 
parameters, and save your own custom patches. You can also search for patches by name in 
the Library.

For Track Stacks, the patches available in the Library vary, depending on the Track Stack type, and 
which track in the Track Stack is selected. For more information, see Track Stacks and the Library.

Note:  Channel strip settings also appear in the Library. If you have saved channel strip settings 
from a previous version of Logic Pro, they appear along with patches when the corresponding 
track type is selected.
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Choose a patch
You can view available patches for the selected track in the Library. When you create a new track, 
you can choose a patch from the Library, and choose a different patch for the selected track at 
any time.

A track can have only one patch for the length of a project, and you can only choose patches 
that match the track type of the selected track. 

Choose a patch for the selected track
	 1	 Click the Library button  in the control bar (or double-click the track header) to open 

the Library.

	 2	 Choose a patch category from the list on the left, then choose a patch from the list on the right.

You can quickly move through the patches in the list using the Up and Down Arrow keys.

After you select a new patch, you can start playing it immediately.

When you choose a patch, the left inspector channel strip shows the patch name, along with 
the instrument (for software instrument patches) and effects plug-ins the patch uses. To view 
presets for a plug-in in the Library, click the space immediately to the left of the plug-in on the 
left inspector channel strip. Select the patch name again to return the view to available patches, 
so you can choose a different one.
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Choose presets and other file types in the Library
In addition to patches, you can view and choose the following file types in the Library, when the 
corresponding item is selected:

•• Plug-in presets (.pst)

•• Channel strip settings (.cst)

•• EXS instruments (.exs)

•• Environment instruments, and programs or banks of MIDI instruments created in the Audio 
MIDI Setup utility

•• ReWire MIDI instruments, and active ReWire hosts

View presets for a plug-in in the Library
mm In the inspector, click immediately to the left of the plug-in slot on the left inspector 

channel strip.

To view patches again, click immediately to the left of the Setting pop-up menu on the left 
inspector channel strip.

Search for patches by name
You can search for patches by name in the Search field, located just below the patch icon in the 
Library. You can quickly compare the search results by selecting and playing them.

Search for a patch
	 1	 Select the track, then click the Library button  if the Library is not already open.

	 2	 Enter search text in the Search field.

Search results appear below the Search field. You can audition patches by clicking them, then 
playing your connected instrument.

Merge patch settings with the current patch
You can merge patch settings from another patch with the current patch. This has several uses: 
for example, you can merge effects with a patch while keeping the existing instrument, or 
conversely try out different instruments while preserving the existing effects setup.

The patch merging area contains buttons for four types of patch settings: MIDI effects, 
instruments, audio effects, and sends. By default, all four types are selected, in which case 
selecting a patch replaces the current patch. By deselecting some items, you can choose which 
patch settings are merged with the current patch. When you choose a different patch from the 
Library, only those settings corresponding to the selected buttons are changed, while other 
settings remain unaltered.

If you deselect the Sends button, the channel strip (or strips) in the patch can access the existing 
project auxes (or any auxes created by existing tracks/channel strips).

Open the patch merging area
mm Choose Enable Patch Merging from the Action pop-up menu at the bottom of the Library.

Choose which settings are not merged
mm Click one or more buttons to deselect those patch setting types.

Selected patch setting types are merged when you choose a different patch, while deselected 
types are kept unchanged.
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Close the patch merging area
mm Click the close box at the upper-left corner of the patch merging area.

When the patch merging area is closed, choosing a patch from the Library replaces the current 
patch (equivalent to all buttons being selected).

When the main track of a summing stack is selected, patch merging is not available.

Reset patches to their original settings
You can reset a patch to its original settings, discarding any changes you previously made.

Reset a patch to its original settings
	 1	 Select the track, then click the Library button  if the Library is not already open.

	 2	 In the Library, select the patch you want to reset from the list on the right, then click Revert.

If you want to save your changes to the patch, save the patch with a different name, then reset 
the original patch.

Save custom patches
You can save a patch’s settings in the Library and apply the settings to other instruments, or use 
them in another project.

You can delete a patch you have saved from the Library if you no longer want to use it. You can’t 
delete the sounds included with Logic Pro.

Save a patch
	 1	 Select the track, then click the Library button  if the Library is not already open.

	 2	 In the Library, select the patch you want to save, then click Save.

You can also select a new category on the left.

	 3	 In the dialog that appears, enter a name for the saved patch.

After you save a patch for the first time, a User Patches folder appears in the Library. Saved 
patches are saved to the User Patches folder. You can use them in any Logic Pro project.

Note:  If you have MainStage 2 or later installed on your computer, custom patches you save in 
MainStage appear in a MainStage Patches subfolder of the User Patches folder, and can be used 
in Logic Pro.

Delete a saved patch
	 1	 Select the track, then click the Library button  if the Library is not already open.

	 2	 In the Library, select the patch you want to delete from the list on the right, then click Delete.

Important:  After you delete a patch, it can’t be recovered for any project. Deleting a patch 
cannot be undone.



	 Chapter  7    Work with tracks	 185

Work with Track Stacks

Track Stacks overview
Track Stacks provide a convenient way to organize and control tracks, to manage projects with 
high track counts, and to create and manage audio subgroups.

There are two types of Track Stacks: folder stacks and summing stacks. Both types have a main 
track and one or more subtracks. The track header for the main track features a disclosure triangle 
that lets you show or hide the subtracks. When you close the stack, only the main track appears 
in the Tracks area.

Subtracks can include any track type: audio, software instrument (including layered and multi-
output software instruments), external MIDI instrument, or aux tracks. Folder stacks can also 
include summing stacks as subtracks.

Folder stacks
Folder stacks let you combine multiple tracks and control them as one unit, without changing 
the audio routing of the individual subtracks. When you create a folder stack, the channel strip 
assigned to the main track is called the stack master. Using the main track or the stack master 
channel strip, you can mute, solo, and adjust the volume level for the folder stack.

Main track

Subtracks

Individual subtracks in a folder stack can have Smart Controls, but the main track has no Smart 
Controls. There are no patches for the main track of a folder stack, and no patch can be saved 
when the main track is selected.

There are no regions on the main track of a folder stack, only on its subtracks. When the folder 
stack is closed, the main track displays an overview of the combined contents of all subtracks.

When you mute a folder stack using the Mute button on the main track (or stack master channel 
strip), the mute or solo state of individual subtracks is preserved, and becomes active again when 
the main track is unmuted.
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Summing stacks
Summing stacks let you combine multiple tracks and route their output to an audio subgroup. 
When you create a summing stack, the outputs from the subtracks are routed to a bus, the 
destination aux of which is assigned to the main track. When the main track is selected, you can 
mute, solo, and adjust volume and send levels for the summing stack, and add and edit plug-ins, 
affecting the sound of all the subtracks in the summing stack.

Subtracks

Main track

If a summing stack contains software instrument tracks as subtracks, you can record and play 
MIDI regions on the main track. MIDI events on the main track are played by all the software 
instrument subtracks in the summing stack. You can also record and play MIDI regions on 
individual (software instrument) subtracks. When the summing stack is closed, the main track 
displays an overview of the combined contents of all subtracks.

When the main track of a summing stack is selected, you can choose a different patch for the 
summing stack, and create your own patches. Patches for a summing stack can include the main 
track and all subtracks, along with their channel strip and plug-in settings. Logic Pro includes a 
set of factory patches designed for use with summing stacks.

The main track of a summing stack, as well as its subtracks, can have Smart Controls. Screen 
controls for the Smart Control on the main track can be mapped to channel strip or plug-in 
parameters on any of the subtracks as well as the main track.

For summing stack patches included with Logic Pro, only the main track has a Smart Control 
layout, which remains visible in the Smart Controls pane when a subtrack is selected. However, 
summing stack patches you create keep their individual Smart Control layouts for subtracks.

Summing stacks provide a convenient way to work with a multi-output software instrument 
(MOSI) and its individual outputs as a single unit. This can be used, for example, for programmed 
drum kits. You can create a summing stack for a MOSI with the MOSI channel strip on the first 
subtrack, with additional subtracks for the output aux channel strips of the MOSI stack. When 
you record and edit MIDI regions on the main track, the MIDI events are sent to the subtrack 
containing the MOSI for playback.

After you create a summing stack, you can route individual subtracks to different destinations. 
Note that if you route subtracks to a destination “outside” of the stack, those subtracks are 
no longer affected by the controls on the main track. Audio subgroups you create are saved 
as part of the summing stack, and their auxes appear as the last (bottom) subtracks in the 
summing stack.
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When a Track Stack contains a single software instrument subtrack, that subtrack appears in the 
left inspector channel strip, and its routing destination (usually the main track aux) appears in 
the right inspector channel strip when the main track is selected. Similarly, when a Track Stack 
contains a single audio subtrack (and no software instrument subtracks), that subtrack appears in 
the left inspector channel strip, and its routing destination (usually the main track aux) appears 
in the right inspector channel strip when the main track is selected. 

The master track is also a Track Stack. For more information, see Work with the master track.

Create and edit Track Stacks
  When Show Advanced Tools is selected in the Advanced preferences pane, you can create 

and edit Track Stacks. If Show Advanced Tools is unselected, existing Track Stacks in a project will 
play back, but you can’t create new ones or edit existing ones.

You create a Track Stack by selecting (adjacent or nonadjacent) tracks in the Tracks area. 
Nonadjacent tracks move so that all tracks are grouped together in the Track Stack. Both types 
of Track Stacks can contain any combination of track types as subtracks. A folder stack can also 
include summing stacks as subtracks.

You can hide the subtracks of a Track Stack to save space in the Tracks area, or show them in 
order to record or edit. You can add or remove tracks from a Track Stack, and reorder tracks in a 
Track Stack (reordering tracks doesn’t affect the sound).

After creating the summing stack, you can route individual subtracks to a different destination. 
If you do so, however, the rerouted subtracks are no longer controlled by the main track’s 
channel strip.

Create a Track Stack
	 1	 Select the tracks you want to include in the Track Stack. The selected tracks can be adjacent 

or nonadjacent.

	 2	 Do one of the following:

•• Choose Track > Create Track Stack.

•• Control-click the header of one of the selected tracks, then choose Create Track Stack from the 
shortcut menu.

	 3	 In the Track Stack dialog, do one of the following:

•• To create a folder stack: Select Folder Stack, then click OK. 

•• To create a summing stack: Select Summing Stack, then click OK. 
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Show or hide the subtracks for a Track Stack
mm Click the disclosure triangle to the left of the track icon in the main track.

To show or hide the subtracks for all track stacks in a project, Option-click the disclosure triangle 
for any track stack in the project.

Add a track to a Track Stack
mm Drag the header of the track you want to add between two of the subtracks in the Track Stack.

Note:  When you add a track to a summing stack, its routing changes to the aux assigned to the 
main track.

Reorder subtracks
mm Drag a subtrack by its header up or down inside the Track Stack.

Remove a subtrack from a Track Stack
mm Drag the subtrack outside of the Track Stack (below the last subtrack, or above the main track).

When you remove a subtrack from a summing stack, the track’s output routing changes from the 
aux used by the main track to the main outputs. 

Flatten a Track Stack
You can flatten a Track Stack, in which case the subtracks again become normal tracks.

•• When you flatten a folder stack, the main track is deleted if its volume fader is set at 0 dB 
(unity gain) and it contains no automation data.

•• When you flatten a summing stack, the audio subgrouping is retained, unless there is no audio 
processing on the main track aux (no plug-ins, volume fader set at 0 dB, Pan/Balance set to 
neutral, and no automation data). In this case, all subtracks (or their audio subgroups) are 
routed to the Stereo (or Surround) Main output, and the main track Aux is deleted.

Do one of the following:

mm Select either the main track or a subtrack, then choose Track > Flatten Track Stack from the Tracks 
area menu bar. 

mm Control-click the track header of the main track or a subtrack, then choose Flatten Track Stack 
from the shortcut menu. 
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Track Stacks and the Library
The patches available in the Library vary depending on the Track Stack type, and which track in 
the Track Stack is selected:

•• When the main track of a folder stack is selected, no patches are available in the Library, and 
patches can’t be saved.

•• When the main track of a summing stack is selected, summing stack patches of a similar type 
are available in the Library.

•• For both types of stacks, when a subtrack is selected, patches for the appropriate track type 
are available.

••  If you choose a Track Stack patch when a subtrack of a folder stack is selected, the channel 
strip setting of the first subtrack of the same type in the Track Stack is loaded.

Work with the master track
Each Logic Pro project has a master track. When you show the master track, it appears below the 
last track in the Tracks area. You can edit master volume automation on the master track, and edit 
automation for shared effects on its subtracks.

The master track is a Track Stack. For stereo projects, the main track is assigned to the stereo 
output chosen in Logic Pro > Preferences > Audio > I/O Assignments > Output, typically Output 
1-2. For surround projects (with at least one channel strip routed to surround), the main track 
is assigned to the master channel strip, which carries the surround sum processing plug-ins. 
All shared effect aux channel strips (auxes using a Bus as input, which is fed via Sends) are 
automatically added as subtracks. All output tracks in the project, and all effect auxiliary tracks 
are affected by changes to the master track.

Neither the main track nor any of the subtracks of the master track contain audio or MIDI regions, 
but they may contain automation data.

For more information about the master channel strip in the Mixer, see Channel strip types. For 
information about track automation, see Add automation to tracks.

Show the master track
mm Choose Track > Show Master Track from the Tracks area menu bar.

The master track appears below the last track in the Tracks area.

Edit the master volume automation curve
	 1	 Show the master track in the Tracks area.

	 2	 Choose View > Track Automation from the Tracks area menu bar.

	 3	 In the master track header, choose Volume from the Automation pop-up menu for the 
main track.

	 4	 Add and edit automation points on the master volume curve.
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Show or hide the subtracks for the master track
mm Click the disclosure triangle to the left of the track icon in the main track.

After you show the subtracks for the master track, you can choose shared effect parameters to 
automate, record or add automation control points, and edit the automation to control shared 
effect parameters.

You can set the basic playback volume using the Master Volume slider in the control bar. This 
slider corresponds to the master channel strip in the Mixer, and acts as a master volume control 
for the overall project. For more information, see Control the overall project volume.

Control timing with the groove track
You can set a track as a groove track, and match (synchronize) the timing of other tracks in 
the project to it. When you play the project, the timing of matched tracks adjusts to match the 
timing of the groove track.

Only one track in a project can be a groove track. You can select which tracks in the project 
match the timing of the groove track. When a track is set to match the groove track, time 
quantization is unavailable for that track.

Set the groove track
	 1	 Hold the pointer over the left edge of the header of the track you want to set as the groove track.

	 2	 Click the star that appears in the narrow rectangle on the left edge of the track header.

Match other tracks to the groove track
mm Select the Match Groove Track checkbox on the left side of each track’s header.

To prevent a track from matching the groove track, deselect the Match Groove Track checkbox.

Turn off the groove track
mm Click the star in the header of the current groove track.
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Bounce tracks and regions in place

Bounce in place overview
When you bounce tracks or regions in place, the selected tracks or regions are bounced, and the 
resulting audio files are placed at the same position as the originals in the Tracks area.

Using Bounce in Place, you can process audio, software instrument, or Drummer tracks, or the 
regions on those tracks. The audio file format of the bounce (sample rate and resolution) is 
determined by the audio recording project settings.

Bounce in Place might seem similar to the Freeze function, but there are several differences:

•• Both save CPU power by rendering all effects (or instrument) plug-ins of a track.

•• Freeze allows you to return to the original state of the tracks and their automation data, unlike 
Bounce in Place.

•• Freeze (in 32 Bit Float) safeguards against volume clipping.

Bounce a track in place
You can render one or more selected audio, software instrument, or Drummer tracks (including 
active plug-ins and automation on the tracks) to a new audio file.

Bounce one or more tracks in place
	 1	 Select the track.

	 2	 Choose File > Track in Place (or use the Bounce Track in Place key command).

	 3	 In the Bounce Track In Place dialog, define the following parameters:

•• Name field: Enter a name for the bounce file in the field. The name defaults to the region name 
of the first selected region, with the extension _bip added at the end.

•• Destination buttons: Define the track on which the bounce file is placed. You have two options:

•• New Track: Creates a new audio track below the selected track, and places the bounce file on 
that track.

•• Replace Track: Replaces the existing track, and places the bounce file on it.

•• Include Instrument Multi-Outputs checkbox: Select to include aux channel strips with multi-
output signals of the instrument in the bounce process. Otherwise, only the channel strips of 
tracks with selected regions are bounced.

•• As Additional Tracks checkbox: Select to create additional bounce files for every aux with any 
multi-output of the selected multi-output software instrument as input source.
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•• Bypass Effect Plug-ins checkbox: Select to disable all plug-ins on the source track during the 
bounce process.

•• Include Volume/Pan Automation checkbox: Select to have volume and pan automation 
performed during the bounce process, with their result influencing the bounce file. Otherwise, 
the volume and pan automation is simply copied, not performed.

•• Normalize pop-up menu: Choose between three states of normalization:

•• Off: Turns off normalization.

•• Overload Protection Only: Allows downward normalization in case of overloads—levels above 
0 dB, which would lead to clipping—but no normalization in case of lower levels.

•• On: Allows full bidirectional normalization.

•• Restore Defaults button: Click to set all parameters in the dialog to their default settings.

	 4	 Click OK to trigger an in-place bounce of the selected track or tracks.

Following the bounce in place, the original track content (all regions, and all automation data 
except for volume, pan, and sends) is lost, and the original instrument or track channel strip is 
reset. You can use the Undo command if you want to return to the pre-bounce state.

Bounce all tracks in place
You can perform an in-place bounce-and-replace for all audio, software instrument, and 
Drummer tracks in the Tracks area.

Perform an in-place bounce of all tracks
	 1	 Choose File > Bounce > And Replace All Tracks.

	 2	 You are prompted to save your project; click Yes or No, as appropriate.

	 3	 In the Bounce Replace All Tracks dialog, define the following parameters:

•• Bypass Effect Plug-ins checkbox: Select to disable all plug-ins on the source track during the 
bounce process.

•• Include Volume/Pan Automation checkbox: Select to have volume and pan automation 
performed during the bounce process, with their result influencing the bounce file. Otherwise, 
the volume and pan automation is simply copied, not performed.

•• Normalize pop-up menu: Choose between three states of normalization:

•• Off: Turns off normalization.

•• Overload Protection Only: Allows downward normalization in case of overloads—levels above 
0 dB, which would lead to clipping—but no normalization in case of lower levels.

•• On: Allows full bidirectional normalization.

	 4	 Click OK to trigger the in-place bounce-and-replace for all tracks.
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Bounce a region in place
You can render one or more selected regions on audio or software instrument tracks into a new 
audio file, including all active plug-ins and automation data.

Bounce one or more regions in place
	 1	 Select one or more regions on an audio or software instrument track.

	 2	 Do one of the following:

•• Choose File > Bounce > Regions in Place (or use the corresponding key command).

•• Control-click the selected regions, then choose Bounce Regions in Place from the 
shortcut menu.

	 3	 In the Bounce Regions In Place dialog, define the following parameters:

•• Name field: Enter a name for the bounce file in the field. The name defaults to the region name 
of the first selected region, with the extension _bip added at the end.

•• Destination buttons: Define the track on which the bounce file is placed. You have two options.

•• New Track: Creates a new audio track below the selected track, and places the bounce file on 
that track.

•• Selected Track: Places the bounce file on the selected track.

•• Source buttons: Define what happens to the source regions after bouncing. You have three 
options:

•• Leave: Leaves the source region unaltered after processing the bounce file.

•• Mute: Mutes the source region after processing the bounce file.

•• Delete: Deletes the source region from the original track after processing the bounce file.

•• Include Instrument Multi-Outputs checkbox: Select to include aux channel strips with multi-
output signals of the instrument in the bounce process. Otherwise, only the channel strips of 
tracks with selected regions are bounced.

•• Bypass Effect Plug-ins checkbox: Select to disable all plug-ins on the source track during the 
bounce process.
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•• Add Effects Tail to File checkbox: Select to continue the bounce process after the end of the 
bounce range—either to the end of the cycle or to the end of the last selected region—until 
there is no longer a signal. Otherwise, only the bounce range is bounced.

•• Add Effects Tail to Region checkbox: Select to include the entire bounce file in the bounce 
region. Otherwise, the bounce region only includes the bounce range.

•• Include Volume/Pan Automation checkbox: Select to have volume and pan automation 
performed during the bounce process, with their result influencing the bounce file. Otherwise, 
the volume and pan automation is simply copied, not performed.

•• Normalize pop-up menu: Choose between three states of normalization:

•• Off: Turns off normalization.

•• Overload Protection Only: Allows downward normalization in case of overloads—levels above 
0 dB, which would lead to clipping—but no normalization in case of lower levels.

•• On: Allows full bidirectional normalization.

•• Restore Defaults button: Click to set all parameters in the dialog to their default settings.

	 4	 Click OK to trigger an in-place bounce of the selected region or regions.

Note:  When you click OK, the settings chosen above are stored in the preferences and recalled 
when you next access the Bounce Regions in Place function.
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Export tracks and regions

Export tracks as audio files
You can export a single track (with all the regions on the track) as as audio file, or export all 
tracks (all audio, software instrument, and Drummer tracks) in a project as audio files—one 
per track.

Export a track as an audio file
	 1	 Select the track to export, then choose File > Export > Track as Audio File.

	 2	 Enter a name for the exported audio file, and browse to a location to save it.

	 3	 Choose a file format for the exported audio file from the Save Format pop-up menu.

	 4	 Choose the bit depth for the exported audio file from the Bit Depth pop-up menu.

	 5	 Set the following parameters, as necessary:

•• Multi-Output Software Instruments: For software instrument tracks with multi-output software 
instruments, choose one of the following options:

•• One File per Track: Mixes the multi-output signals with the main output into one file, for each 
multi-output software instrument track. In situations where multiple tracks use the same 
multi-output software instrument channel strip, one file is created for each track.

•• One File per Channel Strip: Creates additional files for each aux channel strip that has an 
output of the selected track’s multi-output software instrument as Input source.

•• Bypass Effect Plug-ins: Select to disable all plug-ins on the source track.

•• Include Audio Tail: Select to extend the length of the created file to include any instrument 
release and potential effect tail (reverb, delay, and so on).

•• Include Volume/Pan Automation: Select to have volume and pan automation performed 
on export, with their result influencing the created file. Otherwise, the volume and pan 
automation is simply copied, but not performed.

Note:  If you plan to use the exported regions with an external application for processing, 
mixing, or editing, exporting them with no volume and pan automation is generally desirable.

•• Normalize: Choose one of the following options:

•• Off: The exported file is not normalized.

•• Overload Protection Only: Allows downward normalization in case of overloads—levels above 
0 dB, which would lead to clipping—but no normalization in case of lower levels.

•• On: The exported file is normalized both for overloads and for Lowell levels.

	 6	 Select the Add resulting files to Project Audio Browser checkbox to add the exported file to the 
Project Audio Browser.

	 7	 Click Save.



	 Chapter  7    Work with tracks	 196

Export all tracks as audio files
	 1	 Choose File > Export > All Tracks as Audio Files.

	 2	 Enter a name for the exported audio files, and browse to a location to save them.

	 3	 Choose a file format for the exported audio files from the Save Format pop-up menu.

	 4	 Choose the bit depth for the exported audio file from the Bit Depth pop-up menu.

	 5	 Set the following parameters, as necessary:

•• Multi-Output Software Instruments: For software instrument tracks with multi-output software 
instruments, choose one of the following options:

•• One File per Track: Mixes the multi-output signals with the main output into one file, for each 
multi-output software instrument track. In situations where multiple tracks use the same 
multi-output software instrument channel strip, one file is created for each track.

•• One File per Channel Strip: Creates additional files for each aux channel strip that has a multi-
output of the selected track’s multi-output software instrument as Input source.

•• Bypass Effect Plug-ins: Select to disable all plug-ins on the source track.

•• Include Audio Tail: Select to extend the length of the created file to include any instrument 
release and potential effect tail (reverb, delay, and so on).

•• Include Volume/Pan Automation: Select to have volume and pan automation performed 
on export, with their result influencing the created file. Otherwise, the volume and pan 
automation is simply copied, but not performed.

Note:  If you plan to use the exported regions with an external application for processing, 
mixing, or editing, exporting them with no volume and pan automation is generally desirable.

•• Normalize: Choose one of the following options:

•• Off: The exported file is not normalized.

•• Overload Protection Only: Allows downward normalization in case of overloads—levels above 
0 dB, which would lead to clipping—but no normalization in case of lower levels.

•• On: The exported file is normalized both for overloads and for lower levels.

	 6	 Select the Add resulting files to Project Audio Browser checkbox to add the exported file to the 
Project Audio Browser.

	 7	 Click Save.
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Export regions as audio files
You can export an audio or MIDI region as a new audio file, to reuse in Logic Pro or use with 
another audio application.

Export an audio or MIDI region as an audio file
	 1	 Select the region in the Tracks area, then choose File > Export > Region as Audio File.

	 2	 Enter a name for the exported audio file, and browse to a location to save it.

	 3	 Choose a file format for the new audio file from the Save Format pop-up menu.

	 4	 Choose the bit depth for the new audio file from the Bit Depth pop-up menu.

	 5	 Set the following parameters, as necessary:

•• Multi-Output Software Instruments: For regions on software instrument tracks with multi-
output software instruments, choose one of the following options.

•• One File per Track: Mixes the multi-output signals with the main output into one file, for each 
multi-output software instrument track. In situations where multiple tracks use the same 
multi-output software instrument channel strip, one file is created for each track.

•• One File per Channel Strip: Creates additional files for each aux channel strip that has a multi-
output of the selected track’s multi-output software instrument as Input source.

•• Bypass Effect Plug-ins: Select to disable all plug-ins on the source track.

•• Include Audio Tail: Select to extend the length of the created file to include any instrument 
release and potential effect tail (reverb, delay, and so on).

•• Include Volume/Pan Automation: Select to have volume and pan automation performed 
on export, with their result influencing the created file. Otherwise, the volume and pan 
automation is simply copied, but not performed.

Note:  If you plan to use the exported regions with an external application for processing, 
mixing, or editing, exporting them with no volume and pan automation is generally desirable.

•• Normalize: Choose one of the following options:

•• Off: The exported file is not normalized.

•• Overload Protection Only: Allows downward normalization in case of overloads—levels above 
0 dB, which would lead to clipping—but no normalization in case of lower levels.

•• On: The exported file is normalized both for overloads and for lower levels.

	 6	 Select the Add resulting files to Project Audio Browser checkbox to add the exported file to the 
Project Audio Browser.

	 7	 Click Save.
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Move audio files used for audio regions
You can move audio files used for audio regions to a new location. This is useful if the audio files 
are saved in the project, or are referenced outside the project in multiple locations.

When you select one or more audio regions and choose Move Files, all audio files used for the 
selected regions are moved to the location you choose, both audio files stored in the project and 
audio files referenced from outside the project. 

Move audio files used for audio regions to a new location
	 1	 Select the audio regions in the Tracks area.

	 2	 Control-click one of the selected files, then choose Export > Move File(s) out of project from the 
shortcut menu.

If only audio regions from audio files referenced outside the project are selected, the command 
appears as Move File(s).

	 3	 In the Move File(s) dialog, browse to and select the new location for the files, then click Choose.

Export MIDI regions as standard MIDI files
You can export one or more MIDI regions as standard MIDI files, to play in another music 
application. If your project contains only MIDI regions, you can merge the regions and export the 
entire project as a MIDI file. Before exporting, you need to perform several steps to prepare the 
MIDI regions.

Because Standard MIDI file type 0 format files can only save a single MIDI region, you must also 
join MIDI regions you want to export as a MIDI file in file format 0. You can do this by selecting 
the regions and choosing Edit > Join (or use the Glue tool).

Prepare MIDI regions for export
	 1	 Control-click the regions, then choose MIDI > Normalize Region Parameters from the 

shortcut menu.

	 2	 Control-click the regions, then choose MIDI > Apply Quantization Destructively from the 
shortcut menu.

	 3	 Convert any aliases to region copies by choosing Functions > Region Alias > Convert Alias to a 
Copy from the Tracks area menu bar (or use the Convert Alias to a Region Copy key command).

	 4	 Convert all loops into regions by selecting the loops and choosing Convert > Convert Loops to 
Regions from the shortcut menu.

	 5	 Convert all MIDI regions on each track into a continuous MIDI region by choosing Edit > Join > 
Regions per Tracks (or use the Join Regions per Tracks key command).

	 6	 Insert all instrument MIDI settings as events by choosing Functions > Insert Instrument MIDI 
settings as Events from the Tracks area menu bar.

Export one or more MIDI regions as standard MIDI files
	 1	 Select the MIDI regions to export.

	 2	 Choose File > Export > Selection as MIDI File.

	 3	 Choose the destination directory, enter a name, then click Save. The selected MIDI regions are 
saved as a Format 1 MIDI file.

Note:  If you’re exporting MIDI files to use with a hardware sequencer, you may need to limit the 
filenames to an 8.3 character name; such as “proj0001.MID.”
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Export a single MIDI region as a Format 0 MIDI file
	 1	 Choose Logic Pro > Preferences > General, click Project Handling, then select the “‘Export MIDI 

File…’ saves single MIDI Regions as Format 0” checkbox.

	 2	 Select a single MIDI region to export.

	 3	 Choose File > Export > Selection as MIDI File.

	 4	 Choose the destination directory, enter a name, then click Save. The selected MIDI region is saved 
as a Format 0 MIDI file.

Edit track parameters
Each track has a set of parameters. The parameters available depend on the track type (some 
parameters are common to all track types, while some are specific to audio tracks or software 
instrument tracks only). You can view and edit parameters for the selected track in the Track 
inspector, located below the Region and Event inspectors.

  When Show Advanced Tools is selected in the Advanced preferences pane, additional track 
parameters are available, including Channel, Freeze Mode, Q-Reference, Delay, Flex Mode, and 
Staff Style parameters.

Edit track parameters for the selected track
In the Track inspector, do any of the following:

mm Icon button: Click-hold, then choose an icon for the track from the pop-up menu.

mm Channel: Shows the channel strip type and number for the track. The Channel parameter is 
not editable.

mm MIDI Channel pop-up menu: Choose the MIDI channel for the track output. When set to All, all 
MIDI events are sent with their original channel settings.

mm Freeze Mode pop-up menu: Choose Source Only to freeze the track signal without effect plug-ins, 
or choose Pre Fader to freeze the track with all effect plug-ins.

mm Q-Reference checkbox (audio tracks only): When selected, all regions on the track contribute their 
transients as reference points during the quantization process.

mm Flex Mode pop-up menu (audio tracks only): Choose the flex mode for the track.

Depending on which flex mode is chosen, other parameters become available below the Flex 
Mode pop-up menu.

mm Transpose pop-up menu (software instrument tracks only): Choose the transposition for the track 
in octaves.

mm Velocity value slider (software instrument tracks only): Click-hold, then drag up or down to increase 
or decrease the velocity for notes in all regions on the track.

mm Key Limit value slider (software instrument tracks only): Click-hold the lower or upper value, then 
drag up or down to change each value. The two values together define the key range; any notes 
outside this range are not played.

mm Velocity (Vel) Limit value slider (software instrument tracks only): Click-hold the lower or upper 
value, then drag up or down to change each value. The two values together define the velocity 
range; any notes with a velocity outside this range are not played.

mm Delay value slider (software instrument tracks only): Click-hold, then drag up or down to increase or 
decrease the amount of delay applied to regions on the track.
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mm No Transpose checkbox (software instrument tracks only): When selected, regions on the track are 
not transposed. (In other words, the Transpose Region parameter is ignored.) This can be useful 
for instruments assigned to drum or other samples mapped across the keyboard on a single 
MIDI channel.

mm No Reset checkbox (software instrument tracks only): When selected, no reset messages are sent to 
the track’s instrument. This can be useful when using controllers for nonmusical purposes, such 
as Mixer automation.

mm Staff Style pop-up menu (software instrument tracks only): Choose the default staff style for 
the track.
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Recording overview
In Logic Pro, you can make use of several workflow features when recording voices, acoustic 
instruments, and software instruments—including take recording, multitrack recording, and 
replace recording.

You can also use step input recording techniques, which allow you to insert MIDI notes when not 
in a real-time recording mode. And there are several advanced recording techniques available 
that will help speed up your workflow.

When it comes to audio take recording—recording multiple audio performances over the same 
section of a project—you can comp your audio recordings. This process involves selecting the 
best parts from the different performances and piecing them together into a single, master 
composite take.

Note:  If Fade Out is turned on, it will be temporarily disabled while recording, so that you can 
hear what you record.

Record audio

Before recording audio
You can record your voice, an acoustic instrument, or any other sound using your computer’s 
built-in microphone or a microphone connected to your computer.

Before you start recording audio, do the following:

•• Check hardware connections and settings, making sure that any sound source you plan to use 
in your session—microphone or mixer, for example—is connected to the audio inputs of your 
system and is working. You should also check hardware settings such as the system memory 
requirement and disk space.

•• Add an audio track, which is used to record a voice, an acoustic instrument, or any other sound 
from a microphone.

•• Choose the recording file type—AIFF, WAV, or CAF—for audio data before recording.

•• Set the audio recording path, which is only necessary if you want to save recorded audio 
outside of the project.

•• Set the project sample rate, which is the number of times per second the audio signal is 
sampled. Recording at a sample rate of 44.1 kHz is recommended for most situations.

•• Set the project bit depth, which is the number of digital bits each sample contains. Recording 
at a bit depth of 24 bits is recommended for most situations and is the default setting.

•• Set up the metronome, which plays a steady beat so you can play and record in time, or as a 
count-in before recording starts.

•• Enable software monitoring, which allows you to monitor incoming audio through any effects 
that are inserted into an armed audio track.

Record your voice or 
a musical instrument 8
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•• Check the monitoring level, which controls the playback (or monitoring) level, not the 
recording level.

•• Tune any instruments that are connected to your system, to ensure that your external 
instrument recordings are in tune with any software instruments, samples, or existing 
recordings in your project. You can access the Tuner using the Tuner button in the control bar. 
For details about the Tuner plug-in, see the Logic Pro Effects manual.

Record sound from a microphone or an electric instrument
You can record sound from a microphone (voice or acoustic instrument, for example), or from an 
electric instrument (such as an electric guitar) connected to your computer, on an audio track.

Record live audio
	 1	 Select the header of the audio or guitar/bass track you want to record to.

	 2	 Move the playhead to the point in the ruler where you want to start recording.

By default, Logic Pro includes a metronome—a steady beat to help you play in time 
while recording.

	 3	 Do one of the following:

•• If you only want Logic Pro to play a one-measure count-in before recording starts, Control-click 
the Metronome button  in the control bar, choose Metronome Settings from the shortcut 
menu, then select the “Only during count-in” checkbox.

•• Set the playhead a few beats before the point where you want the recording to begin, to give 
yourself time to start playing.

	 4	 Click the Record button  in the control bar (or press R) to start recording.

	 5	 Start singing or play your instrument.

The recording appears as a new audio region on the track as you record.

	 6	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.

  You can view the newly recorded audio region in the Project Audio Browser, when Show 
Advanced Tools is selected in the Advanced preferences pane.
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Record multiple audio takes
When you’re recording, you can record multiple versions, or takes, in quick succession. This can 
be helpful especially when you’re improvising a lead or solo part and want to capture several 
versions while you’re feeling inspired.

Later, you can preview the take recordings and choose which one you want to use in the 
project. You can also create and edit comps, by selecting the best parts from several takes and 
combining these parts into one master comp.

Record multiple audio takes
	 1	 Turn on Cycle mode by doing one of the following:

•• Click the Cycle button  in the control bar (or press C).

•• Click the top part of the ruler.

The cycle area appears as a yellow strip in the ruler.

	 2	 Adjust the cycle area by doing one of the following:

•• Drag the left or right locator.

Left locator Right locator

•• Drag vertically in the locator fields in the control bar (when Show Advanced Tools is selected 
in the Advanced preferences pane).

	 3	 Do one of the following:

•• If you only want Logic Pro to play a one-measure count-in before recording starts, Control-click 
the Metronome button  in the control bar, choose Metronome Settings from the shortcut 
menu, then select the “Only during count-in” checkbox.

•• Set the playhead a few beats before the point where you want the recording to begin, to give 
yourself time to start playing.
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	 4	 Click the Record button  in the control bar (or press R) to start recording.

Recording starts automatically at the beginning of the defined cycle area. Record as many 
cycle passes as you wish. After the second cycle pass, a take folder is created on the track. Each 
subsequent cycle pass is added to the take folder.

	 5	 Click the Stop button  in the control bar (or press the Space bar) after you finish capturing 
cycle passes.

	 6	 Open the take folder by doing one of the following:

•• Click the disclosure triangle in the upper-left corner of the take folder.

Click to open the take folder.

•• Double-click the take folder.

•• Select the take folder and press Control-F.
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Record to multiple audio tracks
You can record to more than one audio track at a time, allowing you to record several 
instruments at once—placing each instrument on a separate track, for example.

Record to multiple audio tracks simultaneously
	 1	 Set the instrument or microphone input source for each track you want to record to.

	 2	 Click the Record Enable button  in the track header of each track you want to record to.

	 3	 Move the playhead to the point in the ruler where you want to start recording.

By default, Logic Pro includes a metronome—a steady beat to help you play in time 
while recording.

	 4	 Do one of the following:

•• If you only want Logic Pro to play a one-measure count-in before recording starts, Control-click 
the Metronome button  in the control bar, choose Metronome Settings from the shortcut 
menu, then select the “Only during count-in” checkbox.

•• Set the playhead a few beats before the point where you want the recording to begin, to give 
yourself time to start playing.

	 5	 Click the Record button  in the control bar (or press R) to start recording.

	 6	 Start singing or play your instrument.

A new audio region appears on each of the record-enabled tracks.

	 7	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.
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Punch in and out of audio recordings
Punch recording is a technique you can use to overwrite a portion of a previously recorded 
track, during playback, without touching any of the recording before or after that portion. You 
punch in to interrupt playback and make the recording, then punch out to return to playback 
mode. You can choose between two punch recording modes: “Punch on the Fly” mode and 
Autopunch mode.

  Punch recording is only available when Show Advanced Tools is selected in the Advanced 
preferences pane.

Punch on the Fly mode
A useful and common recording practice is to switch in and out of recording mode while 
listening to the previously recorded material, sometimes referred to as “punching in on the 
fly.” This helps you fix mistakes or create alternate takes for a particular section. To ensure the 
transition between playing and recording occurs without any audible gaps, you must turn on 
Punch on the Fly mode.

When Punch on the Fly mode is on, recording occurs in the background from the moment 
you start playback. This means there needs to be twice the number of available channel strips 
than the number enabled for recording. A dialog appears if you exceed the number of channel 
strips needed.

Important:  It is recommended that you leave Punch on the Fly mode turned on (which it is, 
by default). You only need to turn it off if you’re recording more than the number of channel 
strips available (in a new project that’s more than 128 tracks), or if your hard disk is unable to 
accommodate recording a large number of tracks. To turn it off, choose Record > Allow Quick 
Punch-In, or Control-click the Record button, then choose Allow Quick Punch-In from the 
shortcut menu.

Autopunch mode
Autopunch describes the use of predefined punch-in and punch-out points to start and stop 
recording. One advantage is that you can concentrate on your playing, rather than on controlling 
the software. Another advantage is that you can set the starting and stopping of recordings far 
more precisely than is possible if “punching in on the fly.”

Note:  Only record-enabled tracks are affected by punch recording.

When it comes to judging punch-in and punch-out points during punch recording, you should 
turn on auto input monitoring (which it is, by default). This setting allows you to hear the input 
signal only during the actual recording; before and afterward you’ll hear the previously recorded 
audio on the track. If auto input monitoring is turned off, you will always hear the input signal.

Turn on auto input monitoring
  Do one of the following when Show Advanced Tools is selected in the Advanced preferences 

pane:

mm Choose Record > Auto Input Monitoring.

mm Control-click the Record button  in the control bar, then choose Auto Input Monitoring from 
the shortcut menu.
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Record on the fly
	 1	 Turn on Punch on the Fly mode by doing one of the following:

•• Choose Record > Allow Quick Punch-In.

•• Control-click the Record button  in the control bar, then choose Allow Quick Punch-In from 
the shortcut menu.

	 2	 Click the Play button  in the control bar, then use the Record Toggle key command at the point 
where you want to start recording.

Audio recording starts immediately.

	 3	 Click the Stop button  in the control bar, or use the Record Toggle key command a second time 
to stop recording.

If you use the latter option, recording ends, but playback continues.

Note:  You can also use the Record Toggle key command when not in Punch on the Fly mode. 
However, this will cause a delay when you switch between playback and record modes, 
accompanied by a dropout of all audio tracks.

Record in Autopunch mode
	 1	 Click the Autopunch button  in the control bar.

Note:  You can add the Autopunch button by customizing the control bar. For information, see 
Customize the control bar.

The autopunch area is indicated by a red stripe in the middle third of the ruler, with the left and 
right autopunch locators serving as punch-in and punch-out points.

Punch in locator Punch out locator

	 2	 Set the autopunch area by doing one of the following:

•• Drag the Punch In and Punch Out locators in the ruler.

•• Drag vertically in the autopunch locator fields in the control bar.

	 3	 Place the playhead at any position before the punch-in point.

	 4	 Click the Record button  in the control bar (or press R) to start recording.

	 5	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.

A region that matches the length of the autopunch area is created. Any audio input received 
before the punch-in or after the punch-out point streams through Logic Pro as usual, but is 
not recorded.
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If you want to improve a difficult part of a certain passage, you can use a combination of the 
Cycle and Autopunch functions. Cycle mode recording allows you to practice as many times 
as you like before performing the final take. On each cycle pass, only events or audio that falls 
within the area defined by the autopunch locators is recorded. This lets you make use of the 
preceding song section to “get into the groove.”

Replace audio recordings
You can record over an existing audio recording, or a portion of it, replacing the original 
recording with the new recording.

  Replace recording is only available when Show Advanced Tools is selected in the Advanced 
preferences pane.

Replace an audio recording
	 1	 Click the Replace button  in the control bar.

Note:  You can add the Replace button by customizing the control bar. For information, see 
Customize the control bar.

	 2	 Click the Record Enable button  in the track header of the track you want to record to.

	 3	 Move the playhead to the point in the ruler where you want to start recording.

By default, Logic Pro includes a metronome—a steady beat to help you play in time 
while recording.

	 4	 Do one of the following:

•• If you only want Logic Pro to play a one-measure count-in before recording starts, Control-click 
the Metronome button  in the control bar, choose Metronome Settings from the shortcut 
menu, then select the “Only during count-in” checkbox.

•• Set the playhead a few beats before the point where you want the recording to begin, to give 
yourself time to start playing.

	 5	 Click the Record button  in the control bar (or press R) to start recording.

	 6	 Start singing or play your instrument.

	 7	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.

The original recording is replaced with the new recording.
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Delete audio recordings
You can delete an audio region that was recorded before or since the current project session 
was opened.

  You can also delete an audio recording, and its related audio file in the Project Audio 
Browser, when Show Advanced Tools is selected in the Advanced preferences pane.

Delete an audio recording from the Tracks area
mm Select the audio region in the Tracks area, then press the Delete key.

The audio region is removed from the Tracks area but the audio file remains in the project.

Delete an audio recording and its related audio file from the project
mm Choose Audio File > Delete File(s) from the Project Audio Browser menu bar.

The deleted audio files are sent to the System Trash where they remain until you empty 
the Trash.
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Record software instruments

Before recording software instruments
You can connect a USB or MIDI music keyboard to your computer to play and record the 
software instruments built in to Logic Pro. You also need to add a software instrument track and 
choose a sound.

Connect a music keyboard to your computer
Do one of the following:

mm If the keyboard is a USB music keyboard, connect the USB cable from the keyboard to 
your computer.

mm If the keyboard is a standard MIDI keyboard, connect the keyboard to a MIDI interface using 
standard MIDI cables, then connect the MIDI interface to your computer.

Be sure to follow the instructions that came with the keyboard, which may include installing the 
correct driver on your computer. Check the manufacturer’s website for the latest driver software. 
If you’re using a MIDI interface, be sure to follow the instructions that came with the interface.

Add a software instrument track and choose a patch
	 1	 Do one of the following:

•• Choose Track > New Instrument Track. (If you use this method, you can skip steps 2 and 3.)

•• Choose Track > New Tracks.

•• Click the Add Tracks button  above the track headers.

	 2	 In the New Tracks dialog, select Instrument & MIDI, and make sure that An Instrument Plug-in is 
chosen as the input source from the Input pop-up menu.

	 3	 Click Create.

	 4	 Click the Library button  in the control bar.

	 5	 In the Library, select a patch category from the list on the left, then select the patch you want to 
use from the list on the right.
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Play software instruments
You can play your chosen software instrument using musical typing or the onscreen keyboard.

Play a software instrument using musical typing
	 1	 Choose Window > Show Musical Typing.

The Musical Typing window appears, showing the layout of keys used for playing notes and 
changing controller information.

	 2	 Select the software instrument track you want to play.

	 3	 Play the software instrument using the keys on your computer keyboard. Use the other keys 
shown in the window to perform the following actions:

•• To move down or up by octaves: Press Y or X.

•• To lower or raise the velocity: Press C or V.

•• To change the modulation (mod wheel) value: Press 4 through 8, or 3 to turn off modulation.

•• To bend the pitch down or up: Press 1 or 2 (the pitch is bent for as long as you press the key).

•• To turn sustain on or off (similar to using a sustain pedal): Press Tab.

As you play, the notes you play are highlighted in the Musical Typing window.

Play a software instrument using the onscreen keyboard
	 1	 Choose Window > Show Musical Typing.

The Musical Typing window appears. In the upper-left area of the window, there are two buttons 
to switch between the Musical Typing window and the onscreen keyboard.

Click to switch between Musical Typing 
and onscreen keyboard.
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	 2	 Click the Keyboard button in the upper-left area of the window.

The onscreen keyboard appears.

	 3	 To play the onscreen keyboard, click the notes on the keyboard.

You can click when the project is playing or stopped, and record by clicking during recording. 
Clicking notes lower on the keys plays the notes with higher velocity, and clicking higher plays 
them with lower velocity.

	 4	 To change the range of the onscreen keyboard, do one of the following:

Click to raise the range.Click to lower the range.

Drag the blue area, or click 
outside, to edit the range.

•• Drag the blue rectangle in the overview over the range you want to play.

•• Click an area of the overview outside the blue rectangle to move it to where you clicked.

•• Click one of the small triangles to the left and right of the keys. Clicking the left triangle lowers 
the range by an octave, and clicking the right triangle raises the range by an octave.
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Record software instruments
Before you start recording, make sure you connect a music keyboard to your computer and 
create a software instrument track to record to. You should also familiarize yourself with how to 
use musical typing and the onscreen keyboard.

Record a software instrument
	 1	 Select the software instrument track you want to record to.

	 2	 Move the playhead to the point in the ruler where you want to start recording.

By default, Logic Pro includes a metronome—a steady beat to help you play in time 
while recording.

	 3	 Do one of the following:

•• If you only want Logic Pro to play a one-measure count-in before recording starts, Control-click 
the Metronome button  in the control bar, choose Metronome Settings from the shortcut 
menu, then select the “Only during count-in” checkbox.

•• Set the playhead a few beats before the point where you want the recording to begin, to give 
yourself time to start playing.

	 4	 Click the Record button  in the control bar (or press R) to start recording.

	 5	 Use your MIDI keyboard, Musical Typing window, or onscreen keyboard to play some notes.

The recording appears as a new MIDI region on the track as you record.

	 6	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.
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Record additional software instrument takes
When you’re recording, you can record multiple versions, or takes, in quick succession. Later, you 
can preview the take recordings and choose which one you want to use in the project.

  Recording multiple MIDI takes is only possible when Show Advanced Tools is selected in the 
Advanced preferences pane.

Record multiple MIDI takes
	 1	 Do one of the following:

•• Choose Record > MIDI Recording Options > Create Take Folders.

•• Choose File > Project Settings > Recording, then choose Create Take Folders from the 
Overlapping Recordings pop-up menu.

•• Control-click the Record button  in the control bar, choose Recording Settings from 
the shortcut menu, then choose Create Take Folders from the Overlapping Recordings 
pop-up menu.

	 2	 Turn on Cycle mode by doing one of the following:

•• Click the Cycle button  in the control bar (or press C).

•• Click the top part of the ruler.

The cycle area appears as a yellow strip in the ruler.

	 3	 Adjust the cycle area by doing one of the following:

•• Drag the left or right locator.

Left locator Right locator

•• Drag vertically in the locator fields in the control bar.
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	 4	 Click the Record button  in the control bar (or press R) to start recording.

Recording starts automatically at the beginning of the defined cycle area.

	 5	 Use your MIDI keyboard, Musical Typing window, or onscreen keyboard to play some notes. 
Record as many cycle passes as you wish.

Note:  Each previously recorded take is automatically muted during recording

	 6	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.

The selected track contains a closed take folder with multiple take regions inside.

	 7	 Open the take folder by doing one of the following:

•• Click the disclosure triangle in the upper-left corner of the take folder.

•• Double-click the take folder.

•• Select the take folder and press Control-F.

Overdub software instrument recordings
Overdubbing is the process of recording a performance on top of an existing performance, 
merging them into a single region. You can use this process to add a supplementary recorded 
sound to a previously recorded performance, for example.

Overdub a software instrument recording
	 1	 Select a MIDI region.

	 2	 Click the Set Locators button in the toolbar.

Cycle mode is turned on and the left and right locators match the start and end points of the 
selected MIDI region.

	 3	 Click the Record button  in the control bar (or press R) to start recording.

Recording begins after the predefined count-in.

	 4	 Use your MIDI keyboard, Musical Typing window, or onscreen music keyboard to record a part. 
Record as many cycle passes as you wish.

	 5	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.

The end result is a single MIDI region that contains the merged performances from each cycle 
pass. However, you can also overdub a MIDI recording when not in Cycle mode.
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Record to multiple software instrument tracks
You can record to multiple software instrument tracks simultaneously.

  You can also record to multiple software instrument tracks successively (in Cycle mode) 
when Show Advanced Tools is selected in the Advanced preferences pane.

Record to multiple software instrument tracks simultaneously
	 1	 Click the Record Enable button  in the track header of each track you want to record to.

	 2	 Move the playhead to the point in the ruler where you want to start recording.

By default, Logic Pro includes a metronome—a steady beat to help you play in time 
while recording.

	 3	 Do one of the following:

•• If you only want Logic Pro to play a one-measure count-in before recording starts, Control-click 
the Metronome button  in the control bar, choose Metronome Settings from the shortcut 
menu, then select the “Only during count-in” checkbox.

•• Set the playhead a few beats before the point where you want the recording to begin, to give 
yourself time to start playing.

	 4	 Click the Record button  in the control bar (or press R) to start recording.

	 5	 Use your MIDI keyboard, Musical Typing window, or onscreen music keyboard to record a part. 
Record as many cycle passes as you wish.

A new MIDI region appears on each of the record-enabled tracks.

	 6	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.

Record to multiple software instrument tracks successively
mm To continue playing previous tracks while recording, do one of the following:

•• Choose Record > MIDI Recording Options > Create Tracks when Cycling.

•• Choose File > Project Settings > Recording, then choose Create Tracks when Cycling from the 
Overlapping Recordings pop-up menu.

•• Control-click the Record button  in the control bar, choose Recording Settings from the 
shortcut menu, then choose Create Tracks when Cycling from the Overlapping Recordings 
pop-up menu.

mm To mute all previous tracks while recording, do one of the following:

•• Choose Record > MIDI Recording Options > Create Tracks and Mute when Cycling.

•• Choose File > Project Settings > Recording, then choose Create Tracks and Mute when Cycling 
from the Overlapping Recordings pop-up menu.

•• Control-click the Record button in the control bar, choose Recording Settings from the 
shortcut menu, then choose Create Tracks and Mute when Cycling from the Overlapping 
Recordings pop-up menu.
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Replace software instrument recordings
When you’re recording, you can replace all or part of a previous performance while recording a 
new one. You do this by recording in Replace mode.

  Replace recording is only possible when Show Advanced Tools is selected in the Advanced 
preferences pane.

Record over an existing MIDI region
	 1	 Click the Replace button  in the control bar.

Note:  You can add the Replace button by customizing the control bar. For information, see 
Customize the control bar.

	 2	 Turn on Cycle mode by doing one of the following:

•• Click the Cycle button  in the control bar (or press C).

•• Click the top part of the ruler.

The cycle area appears as a yellow strip in the ruler.

	 3	 Adjust the cycle area by doing one of the following:

•• Drag the left or right locator.

Left locator Right locator

•• Drag vertically in the locator fields in the control bar.
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	 4	 Click the Record button  in the control bar (or press R) to start recording.

Recording starts automatically at the beginning of the defined cycle area.

	 5	 Use your MIDI keyboard, Musical Typing window, or onscreen music keyboard to play some 
notes. Record as many cycle passes as you wish.

	 6	 Click the Stop button  in the control bar (or press the Space bar) to stop recording.

A new MIDI region is created on top of the existing one.

	 7	 Click the Stop button in the control bar (or press the Space bar) to stop recording.

Your new recording replaces the portion of the previous material you recorded over.

Use step input recording techniques
Step input allows you to insert MIDI notes when you’re not in a real-time recording mode. You 
can use step input to create note runs that may be too fast for you to play, or to replicate sheet 
music that’s too difficult for you to play.

You can use one or more of the following for step input:

•• Musical Typing keyboard

•• Step Input keyboard

•• MIDI keyboard

  The Step Input Keyboard is only available when Show Advanced Tools is selected in the 
Advanced preferences pane.

Insert notes using musical typing
	 1	 Choose Window > Show Musical Typing.

The Musical Typing window appears, showing the layout of keys used for playing notes and 
changing controller information.

	 2	 Select the software instrument track you want to play.

	 3	 Play the software instrument using the keys on your computer keyboard. Use the other keys 
shown in the window to perform the following actions:

•• To move down or up by octaves: Press Y or X.

•• To lower or raise the velocity: Press C or V.

•• To change the modulation (mod wheel) value: Press 4 through 8, or 3 to turn off modulation.

•• To bend the pitch down or up: Press 1 or 2 (the pitch is bent for as long as you press the key).

•• To turn sustain on or off (similar to using a sustain pedal): Press Tab.
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Insert notes using the Step Input keyboard
	 1	 Open the MIDI region in the editor you want to work in.

	 2	 Move the playhead to the point where you want to insert notes.

	 3	 Choose Window > Show Step Input Keyboard.

	 4	 Do one or more of the following:

•• To insert a note of the key’s pitch: Click a key.

•• To set the length of the inserted note: Click the Note Length buttons.

•• To set the velocity of the inserted note: Click the Velocity buttons.

There are eight velocity values—represented by the traditional volume indicators ppp, pp, p, 
mp, mf, f, ff, and fff. These correspond to MIDI velocity values 16, 32, 48, 64, 80, 96, 112, and 127, 
respectively.

•• To make the next three notes you enter a triplet group: Click the Triplet button.

The rhythmic value of the triplets is based on the currently selected note value.

•• To insert a pair of complementary notes: Click the Dot button.

•• To lengthen the selected note by the selected note length value: Click the Sustain Inserted 
Notes button.

•• To correct the timing of the start of the next inserted note to the nearest bar or beat line: Click the 
Quantize button.

The positioning of the playhead is critical when you use this option.

•• To choose the MIDI channel of an inserted note: Open the Channel pop-up menu.

The channel settings of individual notes usually have no effect on the playback channel, and 
therefore the sound, of the MIDI region. The channel settings of individual notes are mainly 
used for polyphonic score display.

•• To insert notes of different pitches and lengths: Click the Chord button.

The notes are “stacked” at the same position, resulting in a chord. The playhead does not 
advance until the Chord button is clicked again (turned off). Chord mode prevents the 
playhead from moving after the insertion of a note, allowing you to insert as many notes as 
you like at the same bar position. Before you insert the last note into the chord, click the Chord 
button again to turn off Chord mode, and the playhead will advance as usual after a note 
is inserted.

Insert notes using a MIDI keyboard
mm You do this in much the same way as input via the Step Input keyboard. Instead, you press keys 

on your real-world MIDI keyboard, rather than clicking onscreen keyboard notes.
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Advanced recording techniques

Advanced recording commands
  When Show Advanced Tools is selected in the Advanced preferences pane, you can use 

several advanced commands to speed up the recording process:

•• Record/Record Toggle: Use to stop recording but to continue playback. Use it again to resume 
recording from the playhead position.

•• Record/Record Repeat: Use to delete the recording, move the playhead back to the recording 
start position, and start recording again.

•• Discard Recording and Return to Last Play Position: Use to delete the recording and move 
the playhead back to the last play position. Unlike Record/Record Repeat, you will need to 
manually begin a new recording, using any Record command.

Use advanced recording commands
Do any of the following:

mm To use Record/Record Toggle:

•• Choose Record > Record Button Options > Record/Record Toggle.

•• Control-click the Record button  in the control bar, then choose Record/Record Toggle from 
the shortcut menu.

mm To use Record/Record Repeat:

•• Choose Record > Record Button Options > Record/Record Repeat.

•• Control-click the Record button  in the control bar, then choose Record/Record Repeat from 
the shortcut menu.

mm To use Discard Recording and Return to Last Play Position: Press Command-Period (.).



	 Chapter  8    Record your voice or a musical instrument	 221

Color takes while recording
You can color take regions in an open or closed take folder, providing you with a visual reference 
while recording.

  You can also color audio takes automatically while recording, when Show Advanced Tools is 
selected in the Advanced preferences pane.

Color a take in an open or closed take folder
	 1	 Select a take.

	 2	 Open the Color palette by doing one of the following:

•• Choose View > Show Colors (or press Option-C).

•• Click the Toolbar button in the control bar to show the toolbar, then click the Colors button.

	 3	 Choose a color.

Color an audio take automatically while recording
	 1	 Open the Recording project settings by doing one of the following:

•• Choose File > Project Settings > Recording.

•• Control-click the Record button  in the control bar, then choose Recording Settings from 
the shortcut menu.

	 2	 Select the Auto-Colorize Takes checkbox.

When this setting is selected, audio take folders use the color selected in the Color palette for the 
first take, but different colors for each of the following takes in that take folder. All colors used in 
an audio take folder are selected from the same color row in the Color palette, advancing by a 
predefined number of columns after each take.
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Mark takes while recording
If you know you’ve recorded a good take and want to mark it so that you can find it again later, 
you can do so while you’re still recording.

  Marking a take while recording is only possible when Show Advanced Tools is selected in the 
Advanced preferences pane.

Mark a take while recording
mm Use the Select Previous Section for Realtime Comping key command.

This command places a tag in the current take, at the position the key command was used. All 
audio that precedes the use of the key command is tagged as a good take, and will be used in 
the final comp.

Capture your most recent performance
It’s possible to capture your most recent performance, even if Logic Pro was not recording while 
you were playing.

  Capturing a recent performance is only possible when Show Advanced Tools is selected in 
the Advanced preferences pane.

Capture a recent performance
mm Click the Capture Recording button in the control bar.
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Comp your audio recordings

Comping overview
  Comping is only possible when Show Advanced Tools is selected in the Advanced 

preferences pane.

Imagine a scenario in which you have recorded multiple performances of a vocal solo over the 
same section of a project. You can select the best parts from the different performances and 
piece them together into a single master take. This process is referred to as comping and is 
achieved by using the Quick Swipe Comping feature. You can also drag or cut the contents of 
take folders.

You can switch individual take folders between the following two editing modes, with the active 
mode determining the types of edits that you can make:

•• Quick Swipe Comping: Allows quick swipe behaviors in the take folder, allowing you to create 
and edit comps.

•• Quick Swipe Comping off: Turns off quick swipe behaviors in the take folder, allowing you to cut, 
drag, and move takes or take folders.

Turn Quick Swipe Comping mode on or off
Do one of the following:

mm Click the Quick Swipe Comping button in the upper-left corner of the take folder.

Quick Swipe Comping button 

mm Choose Quick Swipe Comping from the Take Folder pop-up menu.

Take Folder pop-up menu
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Preview take recordings
In order to create and edit comps, you first need to preview the take recordings in a take folder. 
The simplest way to preview take recordings is to open the take folder. You can then select the 
individual takes for playback. You can also select and preview takes in a closed take folder.

Open a take folder and preview the takes
	 1	 Open the take folder by doing one of the following:

•• Click the disclosure triangle in the upper-left corner of the take folder.

Click to open the take folder.

•• Double-click the take folder.

•• Select the take folder and press Control-F.

	 2	 During playback, do one of the following:

•• If the take folder is in Quick Swipe Comping mode: Click the relevant take.

•• If the take folder is not in Quick Swipe Comping mode: Option-click the header area of the 
relevant take.

Open multiple take folders
	 1	 Select multiple take folders.

	 2	 Option-click the disclosure triangle in the upper-left corner of one of the selected take folders.

Option-click to open the 
take folders.
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Preview takes in a closed take folder
mm During playback, choose a take from the Take Folder pop-up menu.

Take Folder pop-up menu

You can also use the following key commands to step through take recordings in an open or 
closed take folder:

•• Select Previous Take or Comp: Moves back through the takes or comps as listed in the take 
folder’s pop-up menu.

•• Select Next Take or Comp: Moves forward through the takes or comps as listed in the take 
folder’s pop-up menu.

Create, save, edit, and rename comps

Create and save comps
You can use quick swipe comping techniques to select the best parts from several takes, 
combining these parts into one master comp. After creating a comp, it’s a good idea to save it so 
that you can easily return to it at a later point. Any subsequent changes will automatically create 
a new comp.

Combine sections of different takes into a comp
	 1	 Do one of the following:

•• Click the Quick Swipe Comping button in the upper-left corner of the take folder, making sure 
it’s turned on.

Quick Swipe Comping button 
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•• Click the Take Folder pop-up menu in the upper-left corner of the take folder, and make sure 
Quick Swipe Comping is chosen.

	 2	 Drag across take sections with the Pointer or Pencil tool.

Selecting a section in one take automatically deselects the same section in another take.

The comp sections, located in the top lane of the take folder, reflect the combined selections 
from all takes. The vertical lines in the comp overview indicate the transitions between the 
different take sections.
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Save the current comp
mm Choose Duplicate Comp from the Take Folder pop-up menu in the upper-left corner of the 

take folder.

The current comp is saved, and added to the list of comps in the pop-up menu.

Create a comp from the current take
mm Choose Create New Comp from the Take Folder pop-up menu in the upper-left corner of the 

take folder.

The current take is saved as a new comp named Comp X: Comp X, and is added to the list of 
comps in the pop-up menu. By default, new comps are saved as Comp X: Comp X, but you can 
also rename comps.
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Edit comps
You can edit comps by changing the start or end point of take sections, by moving a selected 
comp area to the left or right, or by alternating selected comp areas between takes. You should 
save a comp before editing it. Any subsequent changes will automatically create a new comp.

Edit sections of different take regions
Do one of the following:

mm To extend a take section: Place the pointer over the start or end point of a take selection, 
then drag.

Extending a take selection (dragging the start point to the left or the end point to the right) 
shortens adjacent selections on other takes. Shortening a take selection (dragging the start point 
to the right or the end point to the left) extends adjacent selections on other takes. This ensures 
that you don’t create silence between take selections.

mm To shorten a take section: Place the pointer over the start or end point of a take selection, then 
Shift-drag.

Shortening a take selection (dragging the start point to the right or the end point to the left) 
does not extend adjacent selections on other takes. This allows you to create silence between 
take selections.
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Move a selected area to the left or right
mm Place the pointer over the center area of a take selection, then drag when the pointer changes to 

a two-headed arrow.

This action moves the selection, while at the same time extending or shortening any adjacent 
take selections.

Alternate selected areas between take lanes
mm Click an unselected area of a take to make that particular area active and part of the comp.

The same area is automatically deselected in another take. This is a quick way to compare a 
section of two different takes.
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Remove a take selection from the comp
mm Shift-click the take selection.

Remove an entire take from the comp
mm Shift-click the take’s header area.

If the take doesn’t contain any selections, all unselected areas in other takes are selected in the 
take you click.
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Rename takes and comps
You can rename both takes and comps.

Rename a take
	 1	 Choose the take you want to rename from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose Rename Take from the same pop-up menu.

	 3	 Enter the new name in the dialog that appears, then click OK.

You can also click a take with the Text tool, then enter a new name in the text field that appears.

Rename a comp
	 1	 Choose the comp you want to rename from the Take Folder pop-up menu in the upper-left 

corner of the take folder.

	 2	 Choose Rename Comp from the same pop-up menu.

	 3	 Enter the new name in the dialog that appears, then click OK.
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Delete takes and comps
You can delete takes and comps from take folders at any time. When deleted, they no longer 
appear in the take folder’s list of takes and comps. Any comp selections using deleted takes are 
also removed.

Delete a take
	 1	 Choose the take you want to delete from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Delete the take by doing one of the following:

•• Choose Delete Take from the Take Folder pop-up menu.

•• Click the take with the Eraser tool.

•• Press the Delete key.

Delete a comp
	 1	 Choose the comp you want to delete from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose Delete Comp from the Take Folder pop-up menu.
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Delete all but the currently active comp
	 1	 Choose the comp you want to keep from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose Delete all other Comps from the Take Folder pop-up menu.

All comps, with the exception of the currently active comp, are deleted. (This command is 
available only when a take folder contains more than one comp and when a comp is active.)
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Edit take regions

Edit the start and end points of take regions
You can edit the start and end points of take regions, which allows you to remove the bad part 
of an otherwise good take.

Also, after cutting a take region, you might want to resize one of the two adjacent regions. 
Resizing one of them might impact the length of the other.

Note:  To perform the following tasks, you must turn off Quick Swipe Comping mode for the 
selected take folder.

Edit a take region’s start or end point
mm Place the pointer over the lower-left or lower-right edge of the take region, then drag when you 

see the Resize pointer.

Edit a take region’s start or end point when bordered by another take region
mm Place the pointer over the top-left or top-right edge of the take region, then drag when you see 

the Junction pointer.

Extending a take region (dragging the start point to the left or the end point to the right) 
automatically shortens the adjacent take region. Shortening a take region (dragging the start 
point to the right or the end point to the left) automatically extends the adjacent take regions. 
This behavior ensures that you do not create silence between different take region sections.
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Cut take folders and take regions
You can cut take folders and take regions, creating multiple take folders or multiple take regions 
on the same take lane.

Note:  To perform the following tasks, you must turn off Quick Swipe Comping mode for the 
selected take folder.

Cut a take folder
mm Click the take folder with the Scissors tool.

The take folder is cut at the clicked position and all takes inside the take folder are also cut at 
the same position. As a result, your track lane contains multiple take folders and your take lanes 
contain multiple take regions, all of which can be edited independently.

Cut multiple take folders
mm Select multiple take folders, then click any one of them with the Scissors tool.

The take folders are cut at the clicked position and all takes inside the take folders are also cut at 
the same position. As a result, your track lanes contain multiple take folders and your take lanes 
contain multiple take regions, all of which can be edited independently.
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Cut a take region
mm Click the take region using the Scissors tool.

Multiple take regions now appear on the same take lane.

Make multiple cuts across a take region
mm Option-click the take region with the Scissors tool.

The first cut occurs at the clicked position, and all additional cuts occur at equal intervals up to 
the take region end point.

Slice a take region at comp section borders
mm Control-click the take region, then choose Slice at Comp Section Borders from the 

shortcut menu.
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Trim a take region to active comp sections
mm Control-click the take region, then choose Trim to Active Comp Sections from the shortcut menu.

Move take folders and take regions
You can move take folders and take regions—within the same take lane, between take lanes, 
and to other tracks. Whether or not you have chosen Overlap or No Overlap in the Drag pop-up 
menu, take regions inside take folders will always behave as if No Overlap is selected.

Note:  To perform the following tasks, you must turn off Quick Swipe Comping mode for the 
selected take folder.

Move a take folder or take region within its own lane
mm Drag the take folder or take region to the new position.

Move take regions between take lanes
mm Drag the take region to another take lane.

Empty take lanes are automatically removed.

Create a new take lane for a take region
mm Drag the take region onto the take folder, at a position where it will overlap with a take region in 

the currently active take.

If the dragged take region does not overlap with a take region in the currently active take, it will 
be added to the take lane of the active take. A new take lane is created directly under the take 
folder, and the take region is added as a new take.
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Manage take folder contents

Export takes and comps
You can export an active take or comp from a take folder to a new track, leaving the original take 
folder content intact.

Export an active take to a new track
	 1	 Choose the take you want to export from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose “Export active Take to New Track” from the Take Folder pop-up menu.

The active take is copied to a new track, which is created below the take folder track. The 
exported take can be made up of one or more take regions. The content of the original take 
folder remains intact.
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Export an active comp to a new track
	 1	 Choose the comp you want to export from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose “Export active Comp to New Track” from the Take Folder pop-up menu.

The active comp is copied to a new track, which is created below the take folder track. The 
content of the original take folder remains intact.
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Move takes and comps
You can move an active take or comp from a take folder to a new track, which removes the take 
or comp from the original take folder.

Move an active take to a new track
	 1	 Choose the take you want to move from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose “Move active Take to New Track” from the Take Folder pop-up menu.

The active take is moved to a new track, which is created below the take folder track. This take is 
no longer available in the original take folder.
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Move an active comp to a new track
	 1	 Choose the comp you want to move from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose “Move active Comp to New Track” from the Take Folder pop-up menu.

The active comp is moved to a new track, which is created below the take folder track. This comp 
is no longer available in the original take folder.
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Flatten and merge take folders
You can flatten a take folder, which replaces the take folder with multiple regions that represent 
the current comp selections. All take region sections not used in the current comp are deleted.

You can also flatten a take folder and merge the results. The take folder is replaced with a single 
region that represents the current comp selections. All take region sections not used in the 
current comp are deleted.

Flatten a take folder
	 1	 Choose the comp you want to keep from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose Flatten from the Take Folder pop-up menu.

The take folder is replaced with multiple regions that represent the current comp selections.
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Flatten a take folder and merge the results
	 1	 Choose the comp you want to keep from the Take Folder pop-up menu in the upper-left corner 

of the take folder.

	 2	 Choose Flatten and Merge from the Take Folder pop-up menu.

The take folder is replaced with multiple regions that represent the current comp selections. The 
new regions are then merged to create a new audio file in the Tracks area.
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Unpack take folders
You can unpack take folders using the original channel strip for all new tracks, or you can unpack 
take folders using different channel strips for each new track. Both methods replace the selected 
take folder—or take folders—with new audio tracks for each take and each comp. The first audio 
track reflects the active comp, followed by the takes and remaining comps in the order they 
appear in the take folder’s pop-up menu.

Unpack a take folder
Do one of the following:

mm Control-click the take folder header area, then choose Folder > Unpack Take Folder to Existing 
Tracks from the shortcut menu.

mm Choose Unpack from the Take Folder pop-up menu in the upper-left corner of the take folder.

The latter option affects only the selected take folder, not all selected take folders.

These commands use the original channel strip for all new tracks. All takes and comps, with the 
exception of the currently active comp, are muted. This ensures that the playback result remains 
unchanged. Any edits made to one of these tracks will be reflected in all others.
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Unpack a take folder to new tracks
Do one of the following:

mm Control-click the take folder header area, then choose Folder > Unpack Take Folder to New Tracks 
from the shortcut menu.

mm Choose Unpack to New Tracks from the Take Folder pop-up menu in the upper-left corner of the 
take folder.

The latter option affects only the selected take folder, not all selected take folders.

These commands use different channel strips for each new track, but automatically assigns the 
original channel strip setting to all of them. None of the takes or comps is muted. Edits can be 
made to each of the tracks independently.
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Pack regions into take folders
You can select multiple regions and pack them all into a single take folder. Each region appears 
as an individual take in the resulting take folder.

Note the following when packing regions into a take folder:

•• If the selected regions are located on different tracks, the newly created take folder is placed 
on the topmost track. This may change the playback result, because the take folder uses a 
single channel strip, whereas previously the tracks may have used different channel strips.

•• If the selected regions are placed one after the other on a single track, the newly created take 
folder defaults to one automatically created comp.

•• If only one region is packed into a take folder, it is selected as the take and no comp is created.

Pack selected regions into a take folder
mm Control-click the selected regions, then choose Folder > Pack Take Folder from the 

shortcut menu.
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Prerecorded media overview
Logic Pro comes with a large collection of prerecorded loops, offering a great starting point for 
many of your projects. You can start composing a song by dragging Apple Loops from the Loop 
Browser to the Tracks area. You can also use the browsers to import songs, movies, and a variety 
of other prerecorded media into your project. Combining existing loops and other media files 
provides a quick method for laying down project foundations.

•• Loop Browser: Use to add prerecorded Apple Loops to your project.

•• Media Browser: Use to import songs and movies into your project. You can also import 
GarageBand projects.

Loop Browser Media Browser

Use prerecorded media 9
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  The following browsers are only available when Show Advanced Tools is selected in the 
Advanced preferences pane:

•• Project Audio Browser: Use to add and remove audio files.

•• All Files Browser: Use to import files, search for files using advanced search criteria, and import 
data and settings from other projects.

Project Browser All Files Browser
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Import and search for media files

Import media files
The Media Browser and All Files Browser are your first port of call for browsing and previewing 
media files. Use the Media Browser to find and import songs from your iTunes library and movies 
from your Movies folder. You can use the All Files Browser to access all supported media files on 
the local hard disk, home directory, or current project folder.

  The All Files Browser is only available when Show Advanced Tools is selected in the 
Advanced preferences pane.

All Files BrowserMedia Browser

Import media files with the Media Browser

	 1	 Click the Browsers button  in the control bar, then click Media.

	 2	 Click Audio or Movies, depending on the type of media you want to import.

	 3	 Select the location or folder that contains the files you want to import.

	 4	 Click the Play button  at the bottom of the Media Browser to play songs from iTunes or preview 
movies from your Movies folder before you import them.

	 5	 Drag the files you want to import into the Tracks area.

Import media files with the All Files Browser

	 1	 Click the Browsers button  in the control bar, then click All Files (or press F).

	 2	 Click the List View button  or Column View button  to choose the view you want to use.

•• List view: Shows folders and files in a list, along with details such as name, creation date, size, 
and type. Double-click a folder to show its contents.
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•• Column view: Shows folders and contents in columns. Select a folder to show its contents.

List View Column View

	 3	 Locate the files you want to import by doing the following:

•• To change the visible contents: Click the Computer button , Home button , or Project 
button .

The Computer button shows the contents of the local hard disk, optical drive, or other storage 
media connected to your computer. The Home button shows the contents of your home 
directory. The Project button shows the contents of the current project folder.

•• To move through the folder hierarchy: Click the folders in the file path hierarchy, or use the Back 
button  or Forward button .

	 4	 Drag the files you want to import into the Tracks area.

You can also search for files by name.
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Search for media files
You can search for audio and movie files by name in the Media Browser.

You can also use the All Files Browser to search for media files by name, as well as view or clear 
recent search terms, or add search criteria that allows for a more advanced file search.

  The All Files Browser is only available when Show Advanced Tools is selected in the 
Advanced preferences pane.

Search for media files by name in the Media Browser

	 1	 Click the Browsers button  in the control bar, then click Media.

	 2	 Click Audio or Movies, depending on the type of media you want to search for.

	 3	 Enter a search term in the search field, then press Return.

	 4	 To sort the search results, click any of the column headers.

	 5	 Click the small “x” at the right side of the search field to clear the search term.

Search for media files by name in the All Files Browser

	 1	 Click the Browsers button  in the control bar, then click All Files.

	 2	 Enter a search term in the search field, then press Return.

	 3	 Speed up your search by restricting it to a particular folder or volume.

•• To change the visible contents: Click the Computer button , Home button , or Project 
button .

The Computer button shows the contents of the local hard disk, optical drive, or other storage 
media connected to your computer. The Home button shows the contents of your home 
directory. The Project button shows the contents of the current project folder.

•• To move through the folder hierarchy: Click the folders in the file path hierarchy, or use the Back 
button  or Forward button .

	 4	 To sort the search results, click any of the column headers.

	 5	 Click the small “x” at the right side of the search field to clear the search term.
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View or clear recent search terms in the All Files Browser
Do one of the following:

mm To view a recent search term: Click the magnifying glass icon at the left side of the search field, 
then choose a search term from the pop-up menu to display the results.

mm To clear a search term: Click the small “x” at the right side of the search field.

mm To clear all search terms: Click the magnifying glass icon at the left side of the search field, then 
choose Clear Search History from the pop-up menu.

And or remove search conditions in the All Files Browser
Do one of the following:

mm To add a search condition: Click the Add button (+) to the right of the search field. You can add 
additional search conditions (up to ten) by clicking the Add button (+) to the right of an existing 
condition row.

mm To remove a search condition: Click the Delete button (–) to the right of the condition row.

mm To hide search conditions: Click the Delete button (–) to the right of the search field.

All condition rows are hidden. You can restore them by clicking the Add button (+) to the right of 
the search field.
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Media file search conditions
You can define up to ten advanced search conditions when searching for media files in the All 
Files Browser.

  The All Files Browser is only available when Show Advanced Tools is selected in the 
Advanced preferences pane.

The search conditions are as follows:

First pop-up menu Second pop-up menu Additional pop-up menus/fields

Comment contains, does not contain, is, is 
not, starts with, ends with

Input field

File Type is, is not Pop-up menu, in which you can 
choose between Audio, Movie, and 
Project

Format is, is not Pop-up menu, in which you can 
choose between the following 
options: AIFF, Apple Loops, 
WAV (BWF), Apple Lossless, AAC, 
MP3, CAF, Sound Designer I, 
Sound Designer II, Logic Project, 
MIDI File, ReCycle, AAF File, and 
XML File

Note that AIFF format searches do 
not include Apple Loops.

Length is, is not, is less than, is greater than •• Numerical input field
•• Additional pop-up menu in 

which you can choose between 
seconds, minutes, and hours

Modified Date is, is not, after, before Input field

Name contains, does not contain, is, is 
not, starts with, ends with

Input field

Sample Rate is, is not, is less than, is greater than Pop-up menu, in which you can 
choose between the following 
options: 44.1 kHz, 48 kHz, 88.2 kHz, 
96 kHz, 176.4 kHz, and 192 kHz

Size is, is not, is less than, is greater than •• Input field 
•• Additional pop-up menu, in 

which you can choose between 
bytes, kilobytes, megabytes, 
gigabytes, and terabytes

Bit Depth is, is not, is less than, is greater than Pop-up menu, in which you can 
choose between 8 Bit, 16 Bit, and 
24 Bit
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Use Apple Loops in your projects

What are Apple Loops?
Apple Loops are prerecorded musical phrases or riffs you can use to easily add drum beats, 
rhythm parts, and other sounds to a project. These loops contain musical patterns that can be 
repeated over and over, and can be extended to fill any amount of time.

When you add an Apple Loop to a project, a region is created for the loop. When the project 
plays, the region plays at the project’s tempo and key. This lets you use several loops together, 
even if the loops were recorded at different speeds and in different keys.

Green and blue Apple Loops 
in the Loop Browser

There are two types of Apple Loops:

•• Audio loops (blue) are audio recordings. You can add them to audio tracks, and edit them just 
like other audio regions in the Tracks area and Audio Editor.

•• Software instrument loops (green) can be edited just like other MIDI regions, including editing 
individual notes, and can be viewed in the Piano Roll and Score Editors. You can change 
the sound of the instrument used to play the loop. You can add software instrument loops 
to software instrument tracks, and also convert them to audio loops by adding them to 
audio tracks.

Using the Loop Browser, you can find loops with the instrument, genre, and feel you want, play 
loops, and add loops to your project. You can also create a selection of your favorite loops, create 
your own loops, and customize the Loop Browser.
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Search for Apple Loops
The Loop Browser is where you find loops to add to your project. Using keywords, you can 
find loops by instrument, genre, and mood. You can also search for loops by name and refine 
your searches.

Open the Loop Browser
Do one of the following:

mm Click the Apple Loops button  in the control bar.

mm Choose View > Show Apple Loops (or press O).

Browse for loops
Do one of the following:

mm Click the Button View button , then click keyword buttons to see the matching files in the 
results list. Keywords that do not share any loops with the selected keyword are dimmed.
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mm Click the Column View button  to see a standard Mac OS X column file directory that is 
hierarchically separated into All, Favorites, Genres, Instruments, and Moods search criteria. Select 
a keyword type in the left column, select a category in the middle column, then select a keyword 
in the right column to see the matching files in the results list below.

mm Click Loops at the top of the Loop Browser, then in the pop-up menu that appears, choose the 
Jam Pack or folder with the loops you want to view.

Clear all keyword selections
mm Click the Reset button.
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Search for loops by name
mm Enter a search term in the search field, then press Return.

Search field

Cancel button

The search term can be alphabetical or numerical. Any files that match your search term are 
displayed in the results list.

View or clear recent search terms
Do one of the following:

mm To view a recent search term: Click the magnifying glass icon at the left side of the search field, 
then choose a search term from the pop-up menu to display the results.

mm To clear a search term: Click the small “x” at the right side of the search field.

mm To clear all search terms: Click the magnifying glass icon at the left side of the search field, then 
choose Clear Search History from the pop-up menu.

Play Apple Loops
After searching for loops in the Loop Browser, you can listen to the results to find the loop that 
sounds best in your project. When you listen to a loop, you can hear it by itself (solo), or play it 
together with the project.

Play a loop
	 1	 Select a loop in the results list.

The loop plays back in the project’s tempo and key.

	 2	 Drag the Volume slider at the bottom of the Loop Browser to adjust the volume of the loop 
you’re listening to.

	 3	 Choose a key from the “Play in” pop-up menu to adjust the playback key.

The loop plays to the project key by default, but you can play the loop in its original key or any 
key from C to B.

	 4	 Click the loop again to stop playing.
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Access your favorite Apple Loops
You can specify loops you use frequently as “favorites,” so you can quickly access them in 
the Loop Browser. This feature is ideal for compiling a collection of Apple Loops that you use 
regularly. The loops you choose can be replaced or added to easily as your project advances, but 
the use of favorites may form a great starting point for many of your songs.

Specify and access your favorite loops
	 1	 To specify a loop as a favorite, select the Fav(orite) checkbox for the loop in the results list.

	 2	 To access your favorites, click the Favorites button in Button view, or select Favorites in 
Column view.

Add Apple Loops to your projects
After searching for loops in the Loop Browser and finding the ones you want to use, you add 
them to your project. In the Tracks area, you can move, copy, and make other changes to 
the loops.

Add a loop to your project
Do one of the following:

mm Drag a loop to an empty area of the Tracks area, below the existing tracks.

A new track of the appropriate type (audio or software instrument) is created, and the loop is 
added to the new track.

mm Drag an audio loop (blue) to an audio track.

mm Drag a software instrument loop (green) to a software instrument track.

mm Drag a software instrument loop (green) to an audio track to convert it to an audio loop.

New projects default to a project tempo of 120 bpm or to the native tempo of the first Apple 
Loop added. When you add subsequent Apple Loops, they automatically play at the project 
tempo. When you add an Apple Loop, it’s matched to the project key. If you change the project 
key, the regions created from the loops are transposed to the new key.
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Create your own Apple Loops
You can create Apple Loops from your own audio and software instrument recordings. When 
you create an Apple Loop from a region, it’s added to the loop library and appears in the Loop 
Browser, so that you can use it in other projects.

There may be occasions when you need to reindex your Apple Loops user library—after you 
move loops from the User Loops folder to another hard disk, for example.

You can also convert ReCycle files into Apple Loops.

Create an Apple Loop
	 1	 Select an audio or software instrument region in the Tracks area.

	 2	 Do one of the following:

•• Choose File > Export > Region to Loop Library.

•• Control-click the region, then choose Add to Loop Library from the shortcut menu.

•• Drag the region into the Loop Browser.

	 3	 In the Add Region to Apple Loops Library dialog, select the text in the Name field and enter a 
new name.

	 4	 Choose the scale type for the loop from the Scale pop-up menu.

	 5	 Choose the musical genre for the loop from the Genre pop-up menu.

	 6	 Select an instrument category from the left column of the Instrument Descriptors list, then select 
an instrument from the right column.

	 7	 Click the mood buttons that fit the loop to add mood descriptors for easy searching.

	 8	 When you’re finished, click Create.

The loop is added to the Loop Browser and to the loop index. You can find it by using the 
keyword buttons or menus, or by entering the name in the search field at the bottom of the 
Loop Browser and pressing Return.
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Reindex the Apple Loops user library
mm Click Loops at the top of the Loop Browser, then choose Reindex All Loops from the 

pop-up menu.

Customize the Loop Browser
When thousands of loops are installed on your hard disks, finding a particular Apple Loop can 
be a daunting prospect. Fortunately, you can use a number of key criteria—location, scale, time 
signature—to restrict your search or browsing results. You can also sort the search results.

Restrict loops by location
mm Click Loops at the top of the Loop Browser, then in the pop-up menu that appears, choose the 

Jam Pack or folder with the loops you want to view.

If you have one or more Jam Packs installed on your computer, you can display only the loops 
from a particular Jam Pack, or only the loops included with GarageBand. If you have Apple Loops 
from third-party manufacturers installed on your computer, you can choose to display third-party 
loops only. If you have created your own Apple Loops, you can display the loops for your user 
account, or display loops shared by all users on your computer.

Restrict loops by scale
mm Choose Any, Minor, Major, Neither, or Good for Both from the Scale pop-up menu.

Restrict loops by time signature
mm Choose a time signature from the Signature pop-up menu.



	 Chapter  9    Use prerecorded media	 261

Sort Loop Browser results
mm Click any of the column headers to sort the results by that column type, in ascending or 

descending order.

•• Name column: Sorts Apple Loops by name.

•• Beats column: Sorts Apple Loops by beats.

•• Fav column: Sorts Apple Loops by Fav checkbox selection.

•• Tempo column: Sorts Apple Loops by tempo.

•• Key column: Sorts Apple Loops by key.

You can swap column positions by dragging the column header left or right, and resize column 
widths by dragging the vertical line that separates the column headers.
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Use the Project Audio Browser

Project Audio Browser overview
The Project Audio Browser shows all audio files and regions that have been added to or recorded 
in your project, whether or not they are used in the Tracks area. Regions shown in the Project 
Audio Browser that are not used in the Tracks area are indicated in red.

You can add, edit, delete, and rename audio files and regions in the Project Audio Browser. You 
can add audio files to your project by dragging them from the Project Audio Browser into the 
Tracks area, where you can edit, move, and copy them.

You can also open a separate Project Audio window.

  The Project Audio Browser is only available when Show Advanced Tools is selected in the 
Advanced preferences pane.

Open the Project Audio Browser
Do one of the following:

mm Click the Browsers button  in the control bar, then click Project.

mm Choose View > Show Browsers (or press B), then click Project.

Open a separate Project Audio window
mm Choose Window > Open Project Audio (or press Command-9).
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Add and delete audio files
When you add an audio file to your project, Logic Pro automatically creates a region that 
encompasses the entire file length. You can create as many regions as you like from the same 
audio file. There are no length limitations to regions, as long as they don’t exceed the length of 
the source audio file. Creating multiple regions from the same audio file is beneficial for many 
tasks—using different portions of a vocal take that spans the length of the project, for example.

You can delete audio regions and audio files in the Project Audio Browser. In addition to deleting 
unused audio files, you can also delete unused portions of audio files. This usually frees up a lot 
of space on the hard disk.

Import an audio file into your project
	 1	 Select an audio track in the Tracks area.

	 2	 Do one of the following:

•• Choose File > Import > Audio File.

•• Click the Import Audio button in the toolbar.

	 3	 In the Open File dialog, browse to and select the audio file that you want to add.

	 4	 Click the Play button to play the selected audio file.

The Play button becomes the Stop button. Click to stop playback.

	 5	 Click the Open button to add the file to the selected track, at the playhead position, in the 
Tracks area.

The audio file (and region) is automatically added to the Project Audio Browser.
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Add an audio file to the Project Audio Browser
	 1	 Choose Audio File > Add Audio File from the Project Audio Browser menu bar.

	 2	 Browse to and select the audio file that you want to add in the Open File dialog.

	 3	 Click the Play button to play the selected audio file.

The Play button becomes the Stop button. Click to stop playback.

	 4	 Click the Add button, followed by the Done button.

The audio file (and region) is added to the Project Audio Browser.

	 5	 Click the disclosure triangle to the left of the audio file to show the region.

The region is shown in red until it’s added to the Tracks area.

	 6	 Do one of the following to add the region to the Tracks area:

•• Drag the file onto an existing audio track.

•• Drag the file into the empty workspace in the Tracks area.

The region overview turns blue.

Create a region from an audio file in the Project Audio Browser
Do one of the following:

mm Select an audio file in the Project Audio Browser, then choose Audio File > Add Region.

mm Select an audio file in the Project Audio Browser, choose Edit > Copy (or press Command-C) in 
the main menu bar, then choose Edit > Paste (or press Command-V).

The new region appears below the existing regions in the list. Each region is assigned a unique 
numerical appendix. For example, organ.aif is the parent audio file. The automatically created 
region is simply called organ, and newly created regions are called organ.1, organ.2, and so on.

Delete a region from the Project Audio Browser
mm Select one or more regions, then press Delete.
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Delete an audio file from the project or hard disk
Do one of the following:

mm To delete an audio file from the project: Select the audio file in the Project Audio Browser, then 
press Delete.

The file is deleted from the project, but not from the hard disk.

mm To delete an audio file from the hard disk: Select the audio file in the Project Audio Browser, then 
choose Audio File > Delete File(s).

The deleted file is moved to the Trash, where it remains until you empty the Trash.

Delete sections of audio files that are no longer used in the project
	 1	 Do one of the following:

•• Select the audio files that you want to optimize in the Project Audio Browser.

•• Choose Edit > Select Used.

	 2	 Choose Audio File > Optimize File(s).

Logic Pro determines which (file) segments are not contained in any of the regions used in 
the Tracks area. These segments are deleted, and the remaining portions of the audio file are 
retained and aligned side-by-side in the file. The regions in the Project Audio Browser are 
redefined and the project is automatically saved.

Play audio files
The playback modes outlined below only apply to regions in the Project Audio Browser (when 
the window has key focus), and have no effect on project playback.

Play an entire region
	 1	 Select the region in the Project Audio Browser.

	 2	 Control-click the Prelisten button  at the bottom of the Project Audio Browser, then choose one 
of the following options from the shortcut menu:

•• Auto-select Channel Strip: The audio channel strip assigned to the selected track is used 
for playback.

•• Prelisten Channel Strip: The Environment’s Prelisten channel strip is used for playback. You can 
access the Prelisten channel strip in the Environment’s Mixer layer. It is located to the right of 
the highest-numbered audio channel strip.

	 3	 Click the Prelisten button  (or press the Space bar) to start and stop playback.

Play a region from a specific position
	 1	 Click-hold the region’s waveform display.

Playback starts at the click point.

	 2	 Release the mouse button to stop playback.
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Sort, group, and rename audio files
The Project Audio Browser lists all audio files in your project, along with information about file 
sampling rate, bit depth, format (mono/stereo), and size. Within the Project Audio Browser, you 
can sort, group, and rename your audio files.

Hide or show file information in the Project Audio Browser
mm Choose View > Show File Info from the Project Audio Browser menu bar.

Sort audio files
mm Choose one of the following from View > Files sorted by:

•• None: Sorts the audio files in the order they were loaded or recorded.

•• Name: Sorts the audio files in alphabetical order.

•• Size: Sorts the audio files by size, with larger files at the top of the list.

•• Drive: Sorts the audio files by storage medium.

•• Bit depth: Sorts the audio files by bit depth, in decreasing order.

•• File type: Sorts the audio files by file type.

Group audio files
Do one of the following:

mm Select the files you want to group, choose View > Create Group, enter a name in the Name field, 
then press Enter.

mm Select the files you want to group, then choose one of the following from View > Group Files by:

•• Location: Creates groups that are alphabetically sorted by the names of the parent folders of 
selected files. Folder names are automatically used as group names.

•• File Attributes: Creates groups based on the attributes of selected files (file type, stereo/mono, 
bit depth). Group names are displayed as a summary of the file attributes—16 bit Mono AIFF, 
for example).

•• Selection In Tracks: Creates groups based on regions selected in the Tracks area. Group names 
are based on the first of the selected regions.

Delete a group of audio files
mm Select a group, then choose View > Delete Selected Groups (or press Delete).

The audio files of deleted groups reappear at the top of the list in the Project Audio Browser.

Rename audio files
mm Double-click a filename in the list, enter a name in the Name field, then press Enter.

The audio file is renamed in all currently opened projects that use the file. Any backup files on 
the same disk drive are also renamed.
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Move, copy, and convert audio files
You can move selected audio files to another location on your computer. This is useful when you 
want to move all audio files used in a project to a new folder, for example.

You can also create copies of audio files on a different hard disk, or other storage medium. The 
source files remain in their original location, unlike the behavior when you move files.

You can also create one or more independent audio files from selected regions in the Project 
Audio Browser and Tracks area.

Move all used audio files to a new folder
	 1	 Choose Edit > Select Used from the Project Audio Browser menu bar.

All audio files that are used in the Tracks area are selected.

	 2	 Choose Audio File > Move File(s).

	 3	 Click the Move button.

	 4	 In the dialog that appears, select a folder (or create a new one), then click Save.

All audio files used in the Tracks area are saved to the selected folder. The path information for 
all open projects that use the audio files is also updated. This makes projects easier to manage 
when moving audio files. After you move files to a new location, save each open project to 
update all audio file storage references.

Copy or convert audio files
	 1	 Select one or more audio files.

	 2	 Choose Audio File > Copy/Convert File(s) from the Project Audio Browser menu bar.

	 3	 Choose settings in the “Copy/convert file as” dialog.

You can set the sample rate, bit depth, file format, stereo conversion, and dither type for the 
destination file.

	 4	 Choose the target folder for the new audio files. You can also create a new folder, by clicking the 
New Folder button.

	 5	 If you’re only copying one file, you can enter a name for the new audio file. When simultaneously 
copying several audio files, existing filenames are used for the copies derived from them. The 
Hide Extension checkbox hides or shows file extensions (.wav, .aif, and so on) in the Save As field.

	 6	 Select the “Change file reference in Project Audio” checkbox to replace the audio file used in the 
project with the copied file.

If unselected, both the copy and original audio file are shown in the Project Audio Browser.

	 7	 Click Save.



	 Chapter  9    Use prerecorded media	 268

Convert selected regions into independent audio files
	 1	 Do one of the following:

•• Choose Audio File > Save Region(s) As from the Project Audio Browser menu bar.

•• Choose Edit > Convert > Audio Region to New Audio File from the Tracks area menu bar.

•• Choose File > Export > Region as Audio File from the main menu bar.

	 2	 Choose settings in the dialog that appears.

	 3	 Choose the target folder for the new audio files. You can also create a new folder, by clicking the 
New Folder button.

	 4	 If you’re only saving one region, you can enter a name for the new audio file. The Hide Extension 
checkbox hides or shows file extensions (.wav, .aif, and so on) in the Save As field.

	 5	 Click Save.

Export and import audio region information
The Project Audio Browser provides an overview of regions that are derived from individual 
audio files. You can export this region information into the audio file, which you can then choose 
to import if using the audio file in another project. If using an audio file with saved region 
information in another project, you have the option of importing the region information into 
the project.

Export region information to an audio file
	 1	 Select the audio file in the Project Audio Browser.

	 2	 Choose Audio File > Export Region Information from the Project Audio Browser menu bar.

The current region information for that audio file in the Project Audio Browser is saved in the 
audio file. Any existing region information is overwritten.

Import region information from an audio file
	 1	 Add the audio file to another project.

	 2	 Select the audio file in the Project Audio Browser.

	 3	 Choose Audio File > Import Region Information from the Project Audio Browser menu bar.

The saved region information for that audio file is displayed in the Project Audio Browser and can 
be used in the current project.
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Import compressed audio files
You can use the Finder to import compressed audio files of the following file types into a Logic 
Pro project:

•• AIFF

•• WAV

•• AAC

•• MP3

•• Apple Lossless

The compressed audio file is added to the Tracks area, and a region that encompasses the 
complete audio file is created. Audio regions that point to compressed audio files are denoted by 
the following symbol:

Compressed audio file symbol

You can edit this region in the same way as a normal audio region in the Tracks area.

  Audio files you import from the Finder do not change to match the tempo or key of your 
project. When Show Advanced Tools is selected in the Advanced preferences pane, you can 
convert the region so that tempo changes are written into the audio file.

Import a compressed audio file
mm Drag the audio file you want to import from the Finder into the empty workspace area below the 

existing tracks.

A new audio track containing the audio region is created.

Convert a compressed audio file
Do one of the following:

mm Select the audio region pointing to the audio file in the Tracks area, then choose Edit > Convert > 
Audio Region to New Audio File from the Tracks area menu bar.

The part of the audio file spanned by the audio region is converted to a new audio file.

mm Select the audio file in the Project Audio Browser, then choose Audio File > Copy/Convert File(s) 
from the Project Audio Browser menu bar.
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Add ReCycle files to your project
ReCycle is the name of a software application from manufacturer Propellerhead, which mainly 
serves as an editing and production tool for loops—repeatedly cycled audio files, in other words. 
ReCycle uses specific file formats that can be imported, and used directly by Logic Pro. ReCycle 
files can also be converted to Apple Loops.

Note:  You need to install the REX Shared Library © Propellerhead Software when using ReCycle 
files within Logic Pro. For more information on ReCycle files, see the Propellerhead website.

Logic Pro can import the following ReCycle file formats:

•• Old ReCycle files: These files have the suffix .rcy. The abbreviation for this file type is RCSO.

•• Old ReCycle export files: These files have the suffix .rex. The abbreviation for this file type is REX.

•• ReCycle 2.0 files: These files have the suffix .rx2. The abbreviation for this file type is REX2.

Import a ReCycle file into the Tracks area
	 1	 Select the ReCycle file you want to import by doing one of the following:

•• Choose File > Import > Audio File, then choose a ReCycle file instead of an AIFF, SDII, MP3, or 
WAV audio file.

•• Shift-click an audio track with the Pencil tool, then choose a ReCycle file.

•• Drag a ReCycle file from the Finder onto an audio track.

	 2	 Choose settings in the ReCycle File Import dialog.

•• Don’t Fix: Imports the file as is. All slices of the file overlap, to match the tempo of Logic Pro.

•• Add tracks: Distributes the slices across multiple audio tracks, allowing you to adjust the 
position or delete slices freely. The Number of Audio Tracks field determines how many tracks 
are used for the distribution of the slices. These tracks are in addition to the original track that 
the ReCycle file was added to.

•• Crossfade: All slices of the file are imported to the same track, and are automatically crossfaded. 
The length of the crossfade is determined by the value (shown in milliseconds) displayed in 
the Crossfade Length field. 

•• Render into single file: This function writes all ReCycle slices into a single audio file. The current 
Logic Pro project tempo is used for the rendering process.

•• Render to Apple Loop: Imports the ReCycle file as an Apple Loops file.

	 3	 Click OK.
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If you don’t import the ReCycle file as an Apple Loops or audio file, Logic Pro creates a ReCycle 
file folder on a folder track. This folder contains slices (you can view them as miniature regions in 
the folder) of the ReCycle file at appropriate positions.

ReCycle folder

ReCycle slices

Each of these slices references the same audio file, which can be found in the Project 
Audio Browser.

Note:  If you move the ReCycle file folder to another audio track, the audio channel strip 
destination (of the track inside the folder) does not change accordingly. You need to open the 
folder and change the audio channel strip destination manually, to hear the ReCycle audio data.

Convert a ReCycle file to an Apple Loop
Do one of the following:

mm In the ReCycle File Import dialog, choose Render to Apple Loop from the Fix Method 
pop-up menu.

mm In the All Files Browser, choose Convert ReCycle Files to Apple Loops from the Action 
pop-up menu.

Copy audio regions into the Clipboard for use in ReCycle
	 1	 Select an audio region in the Tracks area.

	 2	 Choose Functions > Copy as ReCycle Loop from the Tracks area menu bar. 

The data of the selected audio region is copied into the Clipboard.

	 3	 Use the “Paste as new Document” command in ReCycle to create a new ReCycle document 
(containing the audio data selected in the Tracks area).

Note:  The size of the transferred audio region is limited to 10 MB, which should be sufficient 
for most ReCycle loops (an eight-bar stereo loop in 4/4 at 70 bpm uses approximately 5 MB, for 
example).

Paste ReCycle loops from ReCycle into the Tracks area
	 1	 Use the Copy Loop command in ReCycle.

The loop currently being edited in ReCycle is copied into the Clipboard.

	 2	 Choose Functions > Paste ReCycle Loop in the Tracks area menu bar to paste this loop into the 
Tracks area. 

The result is the same as the ReCycle file import options.
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Supported media and file formats

Media and file formats overview
Logic Pro allows you to access any digitally stored audio recordings (audio files) on your hard 
disk, in the most common Mac file formats, as well as several other formats.

Audio files imported into a Logic Pro project can be at any supported bit depth and sample 
rate. Logic Pro supports bit depths of 16, 20, and 24 bits, and sample rates of 44.1, 48, 88.2, 96, 
176.4, and 192 kHz. Logic Pro can use the file’s sample rate, or can perform a real-time sample 
rate conversion.

In addition to audio files, Logic Pro can also import MIDI and project information.

The following list describes all file formats supported by Logic Pro:

•• WAVE and AIFF Files: Wave (WAV) and Audio Interchange File Format (AIFF) audio files are 
very similar. They can be stored at different bit depths (16 and 24 bit are supported by Logic 
Pro), in mono, stereo, or surround, and at sample rates up to 192 kHz. Logic Pro also supports 
Broadcast Wave files, which can contain timestamp information. Files that provide timestamp 
information can be recognized by a clock symbol, shown alongside the audio region name in 
the Project Audio Browser. The file extension of broadcast wave files is .wav, allowing them to 
be read by any application that supports the standard wave file format. In such programs, the 
additional Broadcast Wave file information is ignored.

•• Core Audio Format Files: Core Audio Format (CAF) files are containers that support integer and 
float PCM formats, A-law, u-law, and a number of others including AAC and the Apple Lossless 
Audio Codec (ALAC). Unrestricted file sizes are possible, at high sample rates and bit depths.

•• Sound Designer Files: Sound Designer I and II (SDII) audio files are similar in structure to AIFF 
files, and can contain timestamped region information. Use of Sound Designer format files can 
make transfers between Logic Pro and Digidesign Pro Tools software more convenient.

•• MP3, Apple Lossless, and AAC Files: MP3 and AAC files contain compressed audio information. 
They are usually far smaller than equivalent WAV, AIFF, or SDII files. This reduction in file size is 
due to different encoding techniques that “throw away” some of the audio information. As a 
result, MP3 and AAC files do not sound as good as their WAV, AIFF, or SDII audio counterparts, 
depending on the source audio material. Apple Lossless files also contain compressed audio 
information. As the name suggests, the compression used (ALAC) does not discard audio 
information in the same fashion as MP3 files. The sound of the compressed audio file is 
identical to the original recording.

•• Apple Loops: Audio loops contain additional identification information: time and date, category, 
mood, key, and tempo. They also contain a number of transient markers, which break them 
down into small time slices. The main advantage of audio loops is their ability to automatically 
match the tempo and key of a Logic Pro project. Software instrument loops contain MIDI note 
information that triggers a musical phrase or riff. The motif will be played, as is, when these 
types of Apple Loops are added to an audio track. When added to a software instrument track, 
the MIDI note information can be edited, as you would with any MIDI region.

•• ReCycle Files: ReCycle (REX, RCY) files are generated in Propellerhead ReCycle software. These 
are similar to Apple Loops audio files, in that they contain a number of slices, and match the 
project tempo. When imported, a small folder that contains several regions—one for each 
slice—is created. Each of these slice regions can be handled like any audio region. ReCycle 
files, unlike Apple Loops files, do not follow the project key.

•• Standard MIDI Files: Standard MIDI files (SMF) are a standard file format used in MIDI 
sequencers. They can be read and saved in Logic Pro. SMFs may contain note, lyric, controller, 
and SysEx data. They are added to MIDI or software instrument tracks in Logic Pro.
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GarageBand projects
You can open a GarageBand project in Logic Pro just as you would open a Logic Pro project. The 
GarageBand project translates 1:1 into Logic Pro:

•• Logic Pro automatically creates the required number, and type, of tracks to mirror those used 
in the GarageBand project.

•• The project uses the tempo of the GarageBand project.

•• The initial key signature is set in accordance with the project key of the GarageBand project.

•• Software instrument parts are played by GarageBand instruments in Logic Pro. GarageBand 
instruments are automatically installed with Logic Pro. Any mixing data and effects (plus their 
settings) used by software instruments or Apple Loops–based tracks in GarageBand are also 
imported into Logic Pro.

•• The channel strip settings of GarageBand translate 1:1 into Logic Pro—with the nice 
exception that you can now access the individual plug-ins that are inserted into a GarageBand 
channel strip.

•• All channel strip objects are routed to Stereo Out (default stereo output pair), and immediately 
play out according to the Stereo Output preference chosen in the Logic Pro > Preferences > 
Audio > I/O Assignments > Output pane.

•• The two bus effects of GarageBand (Reverb and Echo) are also translated when opened in 
Logic Pro. They are replaced by the PlatinumVerb and Echo on busses 1 and 2.

Once the GarageBand project is loaded into Logic Pro, you can freely change parts, mixing levels, 
and plug-in parameters as in any Logic Pro project.

Note:  You cannot open Logic Pro projects in GarageBand, nor can you export a Logic Pro project 
in a format that can be read by GarageBand (except as an audio file).
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Final Cut Pro XML files
The Final Cut Pro XML format is used to import and export audio data between Final Cut Pro X 
and Logic Pro. The Final Cut Pro XML format supports automation data.

Export the current project as a Final Cut Pro/XML file
mm Choose File > Export > Project to Final Cut Pro/XML.

A standard dialog opens, allowing you to name the export file.

Note:  Software instrument tracks are always bounced to audio files. MIDI tracks are ignored. 
Bouncing will automatically switch to real-time mode, if necessary (such as when an I/O or 
External Instrument plug-in is used).

Import Final Cut Pro XML files
Do one of the following:

mm Choose File > Import > Final Cut Pro XML, then choose the file in the Import dialog.

mm Locate the file in the Media Browser, then double-click it.

The XML import procedure allows you to change or retain the sample rate of audio files used in 
your Final Cut Pro sequences. If you import sequences that use audio files with different sample 
rates, you are given the following options:

•• To alter the sample rate of your Logic Pro project to match all imported Final Cut Pro sequence 
audio files.

•• To retain the sample rate of your Logic Pro project. All Final Cut Pro sequence audio files that 
use a sample rate that differs from the selected one are converted.

Note:  A Final Cut Pro sequence is an arrangement of video, audio, and graphics clips, 
edit information, and effects. When combined, they create a movie. Use of XML to import 
Final Cut Pro sequences into Logic Pro allows you to exchange multiple audio tracks, with all 
positional region information, region names, and volume and pan automation data retained.

Standard MIDI files
Standard MIDI files are not specific to a particular sequencing program, hardware sequencer, or 
type of computer. They contain the following information:

•• MIDI events, including time positions and channel assignments
•• Names of the individual tracks
•• Names and positions of markers
•• Tempo changes
•• Copyright marks

Logic Pro allows you to import, open, and export Standard MIDI file formats 0 and 1:

•• Format 0 contains all data in one track.

•• Format 1 can contain multiple tracks, each with independent data.

Neither format recognizes any division of a track (into several MIDI regions, for example).

Import a MIDI file at the playhead position
Do one of the following:

mm Choose File > Import > MIDI File, then select a file in the dialog that appears.

mm Locate and select the MIDI file in the All Files Browser, then click Import.

The MIDI file is placed at the playhead position, rounded to bars.
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Import a MIDI file at the pointer position
mm Drag a MIDI file from the All Files Browser or Finder into the Tracks area.

The pointer position—when the mouse button is released—determines the position (rounded 
to the nearest bar) and destination of the first track in the imported file.

Open a MIDI file
	 1	 Choose File > Open (or use the corresponding key command, default assignment: Command-O), 

then select a MIDI file in the dialog that appears. 

Note:  If you choose the MIDI files option in the File Type pop-up menu, only MIDI files are 
displayed in the dialog. 

	 2	 If a project is loaded, a dialog asks if you want to create a new environment or copy the current 
environment for the MIDI file. Do one of the following:

•• To replicate the existing environment: Click Copy. The tracks of the MIDI file are automatically 
assigned to suitable instruments. 

•• To load the environment of the default project template: Click New.

The MIDI file is loaded as a new project that contains all MIDI events—inclusive of time positions 
and channel assignments, names of individual tracks, names and positions of markers, tempo 
changes, and copyright marks. The copyright mark is read as marker text. As a default behavior, 
Logic Pro automatically creates software instrument tracks for each MIDI track, and assigns an 
appropriate GarageBand instrument to each, when you open a MIDI file. If you want to use 
external MIDI tracks for each MIDI track, press Option while opening the MIDI file.

Prepare all MIDI regions for a Standard MIDI file export
	 1	 Select all MIDI regions by choosing Edit > Select All (or press Command-A).

	 2	 Normalize all playback parameters by Control-clicking a MIDI region, then choosing MIDI > 
Normalize Region Parameters from the shortcut menu.

	 3	 Convert all playback quantization by choosing Functions > MIDI Region Parameters > Apply 
Quantization Permanently.

	 4	 Convert all aliases into real copies by choosing Functions > Region Alias > Convert Alias to 
a Copy.

	 5	 Convert all MIDI regions on each track into a continuous MIDI region by choosing Edit > Join > 
Regions per Tracks.

Note:  Because Standard MIDI file type 0 format files can only save one MIDI region, you must 
also merge all MIDI regions into one if you want to export in file format 0. You can do this by 
choosing Edit > Join > Regions.

	 6	 Insert all instrument MIDI settings as events by choosing Functions > Insert Instrument MIDI 
settings as Events.
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Save MIDI regions as a Standard MIDI file
	 1	 Select all of the MIDI regions you want to save.

	 2	 Choose File > Export > Selection as MIDI File.

	 3	 Choose the destination directory, enter a name, then click Save. The selected MIDI regions are 
saved as a Format 1 MIDI file.

Note:  Remember that most hardware sequencers can only read MS-DOS formatted disks, so limit 
your filename to an 8.3 character name; for example, “proj0001.MID.”

Save a MIDI region in file format 0
	 1	 Select the “‘Export MIDI File…’ saves single MIDI Regions as Format 0” checkbox in the Logic Pro 

> Preferences > General > Project Handling pane.

	 2	 Select a MIDI region, then choose File > Export > Selection as MIDI File.

AAF files
AAF (Advanced Authoring Format) is used by other DAW applications such as Pro Tools. You 
can use it to import multiple audio tracks, inclusive of references to tracks, time positions, and 
volume automation.

Export the current project as an AAF file
	 1	 Choose File > Export > Project as AAF File.

	 2	 In the Save AAF File As dialog, set the following options:

•• Sample Rate: Choose 44.1 kHz, 48 kHz, 88.2 kHz, or 96 kHz.

•• Bit Depth: Choose either 16 or 24 bit.

•• File Format: Choose WAVE or AIFF.

•• Dither Type: Choose None or any of the four dither algorithms (see About dithering 
algorithms on page 725).

	 3	 Choose a location, enter a name for the file, then click OK.

The export includes all used regions, inclusive of track and position references and 
volume automation.
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Import an AAF file
Do one of the following:

mm Choose File > Import > AAF, then select a file in the dialog that appears.

mm Locate and select the AAF file in the All Files Browser, then click Open.

Open an AAF file
	 1	 Choose File > Open.

	 2	 Choose the AAF file in the Open dialog.
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Arranging overview
After adding audio, MIDI, and Drummer regions to your project (by recording, adding loops, 
using Drummer or adding media files), you build the project by arranging the regions in the 
Tracks area. As you work in the Tracks area, you can play the project at any time to hear your 
latest changes.

In the Tracks area, you can do any of the following:

•• Arrange regions in a variety of ways

•• Create and edit fades, and create automatic crossfades on audio regions

•• Remove silent passages from audio files 

•• Use folders to manage groups of tracks as a single unit

•• Use groove templates to apply the rhythmic feel of a region to other audio or MIDI regions

•• Edit region parameters in the Region inspector to control the sound of both audio and MIDI 
regions

You can also add arrangement markers to a project, and use them to organize the project into 
sections. For information about using arrangement markers, see Add arrangement markers and 
Edit arrangement markers. 

Create a song arrangement 10
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Work in the Tracks area

Tracks area overview
The Tracks area is where you arrange regions to build your project. The Tracks area, located in 
the center of the Logic Pro main window, shows a visual representation of time moving from 
left to right. You build your project by arranging regions in rows, called tracks, that run from the 
beginning to the end of the Tracks area.

At the top of the Tracks area, the ruler shows units of time in either musical format (bars and 
beats) or standard time format (minutes and seconds). You can position regions and other 
items in the Tracks area with the units on the ruler; snap regions and other items to the grid to 
precisely align them with bars, beats, or other (time) divisions; and use alignment guides to align 
them with other items in the Tracks area. You can control the result of overlapping regions and 
other edits using drag modes.

RulerPlayhead

Tracks Regions

The playhead extends from the top to the bottom of the Tracks area, and moves as the project 
plays, showing the point currently playing in the project. At the top of the playhead is a triangle 
that you can drag to move the playhead to a different part of the project, or scrub the regions in 
the Tracks area.

You can also scroll to see another part of the project, and zoom in for precise editing or zoom 
out to see more of the project.

When you open Logic Pro, the Tracks area appears in the main window. You can also open the 
Tracks area as a separate window.
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Position items using the ruler
The ruler runs horizontally across the top of the Tracks area. For projects set to use the musical 
grid, the ruler shows the time format in bars and beats; for projects that don’t use the musical 
grid, the ruler shows the standard time format of minutes and seconds. 

As the project plays, you can see the part currently playing by watching the playhead move 
across the Tracks area. When you move the playhead, or move regions or other items in the 
Tracks area, you can use the ruler to place them at the correct point in time. Alignment guides 
appear when you move regions and other items to help you align them with other items in the 
Tracks area.

When Smart Snap is chosen from the Snap pop-up menu, the units shown in the ruler reflect the 
value set in the Tracks area grid. For details about snapping items to the grid, see Snap items to 
the grid.

To set a project to use the musical grid, go to Logic Pro > Project Settings > General. You can also 
show a secondary ruler that displays the alternative time format by choosing Secondary Ruler 
from the Tracks area View menu. For more details about setting the project to use the musical 
grid, see General settings.

Snap items to the grid
The Tracks area includes a grid that helps you align regions, automation points, and other items 
with the time divisions in the ruler. When you perform any of the following actions, the items 
move according to the current Snap value:

•• Moving and resizing regions

•• Moving the playhead

•• Adjusting the cycle region

•• Dragging loops to the Tracks area

•• Moving control points in automation curves

  When Show Advanced Tools is selected in the Advanced preferences pane, the Snap pop-up 
menu is available in the Tracks area and in time-based editors, including the Piano Roll Editor 
and Audio Track Editor. Using the Snap pop-up menu, you can set the Snap value and perform 
other functions.

By default, the Snap function is relative. When you move or edit an item, it retains the same 
relative distance from its original grid position. For example, if a region is placed at position 
1.2.1.16, and you move the region two beats forward (with the Snap value set to Bar), the region 
snaps to position 2.2.1.16, not 2.1.1.1 (or 2.2.1.1). You can move items so that they align with the 
nearest grid value by choosing Snap to Absolute Value from the Snap pop-up menu.

You can show the grid in the Tracks area, to help you visualize the positions of items in the Tracks 
area relative to the Snap value.
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Set the Snap value for the Tracks area
mm Choose a value from the Snap pop-up menu in the Tracks area menu bar:

•• Smart: Edit operations snap to the nearest bar, beat, sub-beat, and so on, depending on the 
current ruler division value and the zoom level.

•• Bar: Edit operations snap to the nearest bar.

•• Beat: Edit operations snap to the nearest beat in a bar.

•• Division: Edit operations snap to the nearest division value. (This is the time signature shown in 
the LCD and the ruler.)

•• Ticks: Edit operations snap to the nearest clock tick (1/3840 of a beat).

•• Frames: Edit operations snap to the nearest SMPTE frame.

•• QF (Quarter Frames): Edit operations snap to the nearest SMPTE quarter frame.

•• Samples: Edit operations snap to the nearest sample. 

Note:  You can make sample-accurate edits only at a high zoom level. Use the Zoom slider to 
zoom in, and take advantage of the Save and Recall Zoom Setting key commands to speed up 
your workflow.

Show the grid in the Tracks area
mm Choose View > Grid from the Tracks area menu bar.

Snap to an absolute position
mm Choose Snap > Snap Regions to Absolute Value from the Tracks area menu bar.

A checkmark appears to the left of this option when it’s active. This feature works in conjunction 
with the chosen snap grid division. For example, if the Snap value is set to Bar, and Snap Regions 
to Absolute Value is active, moving a region (from position 1.2.1.16) two bars forward results in the 
region being snapped to position 2.2.1.1 rather than its relative position (2.2.1.16).

To return the Snap function to relative values, choose Snap > Snap Regions to Relative Value 
from the Tracks area menu bar.
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Override the Tracks area grid
Do one of the following:

mm Select the region (or other item), then hold down Control while dragging the item in the Tracks 
area:

•• The division value chosen in the control bar (1/16, for example) determines the editing grid 
scale at lower zoom levels (macroscopic or wide view).

•• At higher zoom levels, (microscopic or close-up view), the editing grid scales by a 
certain factor.

mm Select the region (or other item), then hold down Control and Shift while dragging the item in 
the Tracks area:

•• The editing grid switches to ticks if editing at lower zoom levels (macroscopic or wide view).

•• At higher zoom levels (microscopic or close-up view), the editing grid switches to samples.

When the Tracks area is zoomed out so that the current Snap value would result in extremely 
large movements or edits, the Snap pop-up menu is temporarily dimmed, and Smart snap is 
used instead.

When the Tracks area is zoomed in very far, and a smaller Snap value (such as Division or Frames) 
is chosen, normal mouse movements move items by larger grid units. To use the chosen Snap 
value, either zoom out or hold down Control while moving items.

Using Control-Shift breaks the 1:1 relationship between the pointer and region (or Edit tool) 
movements. This means that you may need to move the pointer a long way (horizontally) 
to make the region (or Edit tool) move one pixel. Watch the help tag for an exact 
numerical indication.
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Quantize regions 
Quantizing involves the rhythmic correction of audio or MIDI regions to a specific time grid. Any 
notes not played in time are moved to the nearest position on the grid.

You can quantize regions in the Tracks area by using the Quantize parameter in the Region 
inspector. Several advanced quantization parameters are also available in the Region inspector 
for greater control over quantization.

Before you quantize audio regions on an audio track, you must assign a flex mode to the audio 
track, and select the Flex parameter in the Region inspector for that region. For details, see Flex 
Time algorithms and parameters on page 387.

The Quantize parameter in the Region inspector applies to whole regions. If you want different 
parts of a region to have different Quantize values, you can split the region, apply different 
quantize settings to different segments, and then join them using the Join command or the 
Glue tool.

Quantize selected regions
mm Choose a value from the Quantize pop-up menu in the Region inspector.

You can also step through the available Quantize values, one at a time, with the Set Quantize 
Parameter to Next Value and Set Quantize Parameter to Previous Value key commands.

When you quantize audio regions, white lines called quantize flex markers appear over the 
selected audio regions, to indicate where audio has been time-stretched during the time 
quantization process.

The quantization grid for a MIDI region always begins at the start of the region. If the MIDI region 
is not aligned with the beginning of a bar, neither is the quantization grid.
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Important:  For MIDI regions, the chosen Quantize value affects the way notes are displayed in 
the MIDI editors. So, for example, you can see the effect of the chosen Quantize value by looking 
at the note positions in the Piano Roll Editor.

Unquantized MIDI events Quantized MIDI events

For detailed information about Quantize values and advanced Quantize parameters, see Quantize 
parameter values and Advanced quantization parameters.

Control positioning with drag modes
  When Show Advanced Tools is selected in the Advanced preferences pane, the Drag pop-up 

menu is available in the Tracks area and in time-based editors (such as the Audio Track Editor and 
Piano Roll Editor). Using drag modes, you can control the results of moving, resizing, or deleting 
regions in the Tracks area. 

Set the drag mode for the Tracks area
mm Choose one of the following modes from the Drag pop-up menu in the Tracks area menu bar:

•• Overlap: Preserves the current region borders when you drag one region over another.

•• No Overlap: When two regions overlap, the overlapped area of the left (earlier) region 
is shortened.

•• X-Fade: When two audio regions overlap, the overlapped area is crossfaded.

•• Shuffle R: Aligns regions when you move, resize, or delete them, in the following ways:

•• Move: Moving a region to the right aligns the end point of the region with the start point of 
the region that follows, so there is no space (gap) between them.

•• Resize: When you resize the left edge of a region, the preceding regions move by the change 
in length. If this causes preceding regions to move past the start of the project, the resized 
region then overlaps the preceding ones by the corresponding amount.

•• Delete: The remaining regions on the track move by the length of the deleted region.

•• Shuffle L: Aligns regions when you move, resize, or delete them, in the following ways:

•• Move: Moving a region to the left aligns the start point of the region with the end point of 
the preceding region, so there is no space (gap) between them.

•• Resize: When you resize the right edge of a region, the regions that follow move by the 
change in length.

•• Delete: The remaining regions on the track move by the length of the deleted region.
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For both Shuffle R and Shuffle L, when you drag one region over another, the regions 
switch positions.

Only one audio region at a time can be played on each track. When two audio regions on the 
same track overlap, only the later (right) region is heard.

Scrub the project
You can scrub a project to locate or listen to a sound at a particular point in time. When you 
scrub a project, you quickly audition it by moving the playhead across the Tracks area. The speed 
at which you move the playhead controls the playback speed. Scrubbing makes it easy to zero in 
on a particular drum beat or other audio event before cutting or editing a region.

You can also scrub selected audio regions. When the Scrubbing with Audio in Tracks project 
setting is active, MIDI regions are also scrubbed (whether or not they are selected). Muted tracks 
and regions are not heard, so you can control which tracks and regions you hear by muting or 
soloing them.

Scrub the project
	 1	 If necessary, zoom in or out to view the section you want to scrub.

	 2	 Click the Pause button  in the control bar.

	 3	 Grab the playhead in the Tracks area or the ruler, and move it back and forth through the parts 
of the project you want to hear, at the speed you want to scrub the section (or use the Scrub 
Rewind and Scrub Forward key commands). 

Note:  If the Pause button is not visible in the control bar, you can show it by customizing the 
control bar.

Scrub specific audio regions
mm Select the audio regions, then scrub the project.

Only the selected audio regions are heard. All unmuted MIDI regions are also heard.

Turn on scrubbing for MIDI regions
mm Choose File > Project Settings > MIDI > General > Scrubbing with Audio in Tracks.

Scrub using a MIDI controller
mm Assign any MIDI controller number to the Scrub by MIDI value (-2-) function.

With this assignment, data bytes over 64 scrub forward, and those under 64 scrub backward. For 
more information, see the Logic Pro Control Surfaces Support manual.

You can also scrub via external MIDI control (such as a control surface or keyboard controller) 
using the Scrub by MIDI value (-2-) function (available in the Controller Assignments window; see 
the Logic Pro Control Surfaces Support manual). Any MIDI controller number can be assigned to 
this function. Data bytes over 64 scrub forward, and those under 64 scrub backward.

Note:  Scrubbing is automatically made active when you split regions with the Scissors tool in the 
Tracks area, making it easier to identify the cut position.
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Scroll and zoom in the Tracks area
Depending on the size of the project and your display, you may not be able to see the entire 
project at one time. You can scroll both horizontally and vertically in the Tracks area to view other 
parts of the project.

You can zoom in to make precise edits and see more detail in the Tracks area, or zoom out to 
view more of your project. You can also zoom the amplitude of the waveforms in audio regions 
in the Tracks area.

Scroll in the Tracks area
mm To scroll horizontally, drag the horizontal scroll bar in the Tracks area menu bar. Drag left to scroll 

to an earlier part of the project, or drag right to scroll to a later part of the project.

mm If a project has more tracks than are currently visible in the Tracks area, a vertical scroll bar 
appears along the right edge of the Tracks area. Drag the scroll bar up or down to see the 
other tracks.

Zoom in the Tracks area
mm Drag the horizontal and vertical zoom sliders, located in the Tracks area menu bar. Drag the 

horizontal slider left to zoom out for a wider view, or drag it right to zoom in for a close-up view. 
Drag the vertical slider up for a wider view (more tracks), or drag it down for a close-up view 
(fewer tracks).

If the Tracks area grid value is set to Automatic, the units shown on the ruler change when you 
zoom in or out.

Zoom audio waveforms
mm Click-hold the Waveform Zoom button in the Tracks area menu bar, then drag the slider vertically 

to zoom in or out.

You can speed up your workflow by using the Save and Recall Zoom Setting key commands. If 
your computer has a trackpad that supports gestures, you can also scroll and zoom in the Tracks 
area using gestures.
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Customize the toolbar
The toolbar offers a variety of buttons and other controls for working with regions in the Tracks 
area, as well as other functions. The default set of buttons provides the most commonly used 
options for most users. If you find that you need to access particular functions that are not part 
of the default set, you can customize the toolbar by adding additional controls, or removing 
existing controls.

Change the controls on the toolbar
	 1	 Control-click the toolbar, then choose Customize Toolbar from the shortcut menu.

	 2	 Add or remove individual controls by selecting their checkboxes in the Customize dialog.

	 3	 Choose the appropriate option, as follows:

•• Click Cancel to keep the previously saved toolbar layout.

•• Click OK to activate the new control layout.

•• Click Save As Default to save your current layout as the default, which is then applied 
whenever you create an empty new project, open a new main window, or click the 
Restore Defaults button.

•• Click Restore Defaults to return to the default layout.
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Arrange regions in the Tracks area

Regions overview
Regions are the building blocks of a project. Each time you record an instrument, drag an Apple 
Loop to the Tracks area, or add a media file, a region containing the music from the recording, 
loop, or media file is created. Regions appear as rounded rectangles in the Tracks area. 

You can arrange and edit the following types of regions in the Tracks area:

•• Audio regions from audio recordings, audio Apple Loops, and imported audio files on audio 
tracks

•• MIDI regions from software instrument (and external MIDI instrument) recordings, software 
instrument Apple Loops, and imported MIDI files on software instrument tracks

•• Drummer regions generated on Drummer tracks

You can edit regions in the Tracks area in several ways. For example, you can:

•• Select regions

•• Cut, copy, and paste regions

•• Move regions to another track or to another point in the Tracks area

•• Loop regions

•• Shift the playback position of regions to create subtle changes in the rhythmic feel

•• Resize regions to change how long they play

•• Time stretch regions to change the relative distance between notes and other events

•• Split and join regions

•• Demix MIDI regions

•• Create aliases of MIDI regions and clone audio regions

•• Change the color of regions

•• Convert audio regions to EXS sample zones

•• Delete regions

•• Edit region parameters in the Region inspector
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Select regions in the Tracks area
To perform some edits on regions, you must first select the regions. You can select one or 
multiple regions, select regions on different tracks, and quickly select muted regions, overlapped 
regions, or regions meeting other criteria. Selected regions appear brighter in the Tracks area 
than unselected regions.

Select a region
mm Click the region in the Tracks area.

Select multiple regions
Do one of the following:

mm Hold down Shift as you click the regions in the Tracks area.

mm Drag around the regions to enclose them.

Select all regions in a track
mm Click the track header.

Select all regions in a project
mm Choose Edit > Select > All from the Tracks area menu bar.

Select regions meeting specific criteria
Choose any of the following from the Tracks area Edit menu:

mm To select all following regions in the project: Choose Select All Following.

mm To select all following regions on the same track: Choose Select All Following of Same Track.

mm To select all regions between the left and right locators: Choose Select Inside Locators.

mm To select all empty regions in the project: Choose Select Empty Regions.

mm To select all overlapped regions: Choose Select Overlapped Regions.

mm To select all muted regions in the project: Choose Select Muted Regions.

mm To select all regions with the same color: Choose Select Equal Colored Regions.
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Select parts of regions in the Tracks area
You can select and edit parts of one or more regions, using the Marquee tool or the marquee 
stripe:

•• Marquee tool: Use to select and edit region parts (parts of audio and MIDI regions) by dragging 
across them; looks like a crosshair

Marquee tool

•• Marquee stripe: A thin stripe shown at the top of the ruler

Marquee stripe

Only the part of the region inside the marquee is selected, letting you select inside, or across 
portions of, regions. You can perform most edits, such as moving, cutting, copying, and deleting, 
in the selected area. After editing, the selected area becomes a new, separate region. The 
marquee selection uses the current Tracks area Snap value.

If you play a project after making a marquee selection, playback starts at the left edge of the 
selection, and ends at the right edge. If you create a marquee selection while the project is 
playing, playback continues past the end of the selection.

If you start recording after making a marquee selection, Autopunch mode is activated, and the 
marquee selection is replaced by the punch locators. All tracks within the marquee selection are 
record-enabled, and all other tracks are record-disabled.

Select parts of regions using the Marquee tool
mm Select the Marquee tool, then drag in the Tracks area to select parts of one or more regions.

Select parts of regions using the marquee stripe
	 1	 Choose View > Marquee Ruler from the Tracks area menu bar.

	 2	 Drag in the thin marquee stripe area of the ruler to select parts of one or more regions (also 
shown on selected tracks).

Add or remove individual tracks from the selection
mm Shift-click the track headers of the tracks you want to add or remove.
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Change the selection start or end point
Do one of the following:

mm Using the Marquee tool: Hold down Shift, then click in the Tracks area to change the selection in 
any direction.

mm Using any marquee selection:

•• Hold down Shift while using the Left Arrow key or Right Arrow key to move the marquee 
start point.

You can also use the Toggle Previous (or Next) Region/Event, or set Marquee Start to Previous 
(or Next) Transient key commands.

•• Use the Left Arrow key or Right Arrow key to change the selection end points.

You can also use the Select Previous (or Next) Region/Event, or set Marquee End to Previous 
(or Next) Transient key commands, depending on the type of region selected.

Move the entire selection
Do one of the following:

mm Press Shift–Home (the default Select First, or Shift Marquee Selection Left key command).

mm Press Shift–End (the default Select Last, or Shift Marquee Selection Right key command).

Snap to the finest possible resolution in the current snap mode
mm Hold down Control and Shift while making the selection.

This action snaps the selection to ticks or samples when editing MIDI or audio regions, 
depending on the current zoom level. See Snap items to the grid.

Snap to the division value shown in the LCD
mm Hold down Control while making the selection.

This action snaps items to the current division value when editing MIDI or audio regions, 
depending on the current zoom level. See Snap items to the grid.

Set locators with a marquee selection
mm Control-click the marquee stripe, then choose Set Locators by Regions/Events/Marquee from the 

shortcut menu.

This action sets the locators to the marquee selection boundaries, rather than the whole region.

Split regions at the selection border
mm Control-click the marquee stripe, then choose Split Regions/Events at Locators or Marquee 

Selection from the shortcut menu.

When you edit automation data that is spanned by a marquee selection, two control points are 
automatically created at the left edge, and two at the right edge, of the selection. This lets you 
quickly define and create automation data by converting the marquee selection into automation 
control points.
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Cut, copy, and paste regions in the Tracks area
You can cut or copy regions in the Tracks area, and paste them at a different position. You can 
also paste a copied region at the same time position, to quickly double the region for use on 
another track.

Cut a region
mm Select the region, then choose Edit > Cut (or press Command-X). 

Copy a region
Do one of the following:

mm Select the region in the Tracks area, then choose Edit > Copy (or press Command-C).

mm Option-drag the region.

When you copy an audio region, a new region is automatically created in the Project Audio 
Browser. The new region retains the name of the original, with a sequential number added. For 
example, for a region named MyLoop, the first copy is MyLoop.1, the second copy is MyLoop.2, 
and so on.

Paste the region
mm Move the playhead to the point in the Tracks area where you want the region to start, then 

choose Edit > Paste (or press Command-V).

Paste a region at the same position as the copied region
mm Select the track you want to paste the region into, then choose Edit > Paste at Original Position 

(or use the corresponding key command).

The copied region is pasted into the selected track, at the same position as the source region. 
This is useful if you want to copy a region to the same spot on a different track, to independently 
process or thicken the part, for example. This function is also ideal for creating layered MIDI or 
instrument parts.

Paste multiple copies of a region
	 1	 Select the region.

	 2	 Choose Edit > Repeat Regions from the Tracks area menu bar.

	 3	 Enter the number of copies to paste in the Number of Copies field.

	 4	 To have the copies snap to a particular grid value, choose a grid value from the Adjustment 
pop-up menu.

	 5	 To paste the copies as regions, select As Copies.

	 6	 To paste the copies as clones (for audio regions) or aliases (for MIDI regions), select As Aliases 
or Clones.
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Move regions in the Tracks area
You can move regions to a different point in the same track, or move them to another track of 
the same type. You can move an audio region to another audio track, for example, but not to a 
software instrument track, or vice versa. You can also move regions between open Tracks area 
windows, or between different open projects.

When you move a region, it snaps to the nearest position on the Tracks area grid, using the 
current Snap value. You can override the grid by holding down Control while dragging regions to 
move them in steps of one division, or by holding down both Control and Shift while dragging 
to move them by single ticks or samples (depending on the zoom setting). 

You can also nudge regions (move them in small increments) left or right using key commands. 
To nudge regions, you first set the nudge value, then move selected regions by this value. 
Alternatively, you can nudge regions by a set value.

Tip:  You can also move and resize regions numerically by opening an Event Float window. For 
more information, see Event Float window.

Move a region
Do any of the following:

mm Drag a region left or right in the Tracks area to move it to a new point in the same track.

mm Drag an audio region up or down in the Tracks area to another audio track.

mm Drag a MIDI region up or down in the Tracks area to another software instrument track.

Move a region to the current playhead position
mm Select the region, then use the Move Region/Event to Playhead Position (Pickup Clock) 

key command.

If more than one region is selected, all subsequent regions are moved. For audio regions, the 
region anchor is placed at the current playhead position. See Project Audio Browser overview

Move an audio region back to its recorded position
mm Select the audio region, then choose Edit > Move > To Recorded Position.

This command only works for timestamped audio files, such as those recorded in the current 
project, and imported Broadcast Wave or SDII files. Timestamped files are indicated by a clock 
symbol in the Project Audio Browser.

Move regions to the selected track
mm Select the regions, then choose Edit > Move > To Selected Track. The regions are moved to the 

selected track, keeping their existing time positions.

Set the nudge value
Use one of the following key commands:

mm Set Nudge Value to Tick

mm Set Nudge Value to Division

mm Set Nudge Value to Beat

mm Set Nudge Value to Bar

mm Set Nudge Value to SMPTE Frame

mm Set Nudge Value to 0.5 SMPTE Frame

mm Set Nudge Value to 5 SMPTE Frames
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mm Set Nudge Value to Sample

mm Set Nudge Value to 1 ms

mm Set Nudge Value to 10 ms

Nudge regions by the nudge value 
	 1	 Select the regions you want to move.

	 2	 Hold down Option and press the Left or Right Arrow key.

Nudge regions by a set value
Use one of the following key commands:

mm Nudge Region/Event Position Right by SMPTE Frame

mm Nudge Region/Event Position Left by SMPTE Frame

mm Nudge Region/Event Position Right by 1/2 SMPTE Frame

mm Nudge Region/Event Position Left by 1/2 SMPTE Frame

mm Nudge Region/Event Position Right by 5 SMPTE Frames

mm Nudge Region/Event Position Left by 5 SMPTE Frames

mm Nudge Region/Event Position Right by SMPTE Bit

mm Nudge Region/Event Position Left by SMPTE Bit

mm Nudge Region/Event Position Right by Tick

mm Nudge Region/Event Position Left by Tick

mm Nudge Region/Event Position Right by Division

mm Nudge Region/Event Position Left by Division

mm Nudge Region/Event Position Right by Beat

mm Nudge Region/Event Position Left by Beat

mm Nudge Region/Event Position Right by Bar

mm Nudge Region/Event Position Left by Bar

mm Nudge Region/Event Position Right by Nudge Value

mm Nudge Region/Event Position Left by Nudge Value

mm Nudge Region/Event Position Right by Sample

mm Nudge Region/Event Position Left by Sample

mm Nudge Region/Event Position Right by 1 ms

mm Nudge Region/Event Position Left by 1 ms

mm Nudge Region/Event Position Right by 10 ms

mm Nudge Region/Event Position Left by 10 ms

You can limit the movement of regions to either the horizontal or vertical axis by selecting 
the Logic Pro > Preferences > General > Editing > Limit Dragging to One Direction In Tracks 
checkbox. If you initially move a region left or right, movement is limited to the horizontal axis. 
If you want to move it between tracks, release the mouse button, reselect the region, then drag 
it up or down. While this preference is selected, you can override it by holding down Shift when 
moving regions.
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Add or remove gaps in an arrangement
Sometimes you may want to remove an entire passage from a project—for example, you may 
want to remove the regions of all tracks between bars 17 and 20, so that all regions (and bar 
changes, tempo changes, and global score symbols) from bar 21 on are moved four bars to the 
left, closing the gap left by removing the four bars.

Alternatively, you may want to insert some empty bars in the middle of a project, to create space 
for another chorus, verse, or bridge, for example. As with the previous example, all existing tempo 
changes and so on are moved accordingly (to the right by the number of inserted bars).

You can limit changes to only selected regions. If you do this, rather than moving all regions 
within a project section, you are asked if you want to move global events such as bar changes, 
tempo changes, and score symbols. This global edit is performed on all regions, when used.

Note:  The toolbar features a number of section-editing buttons that can be used to perform 
some of the operations described below. When these buttons are used, the operation affects 
all regions that fall between the locators, regardless of which regions in the area are selected. 
To perform these operations on selected regions within the locators, use the appropriate key 
command after selecting the regions.

Insert a gap between regions using the locators (the cycle length)
	 1	 Set the left and right locator positions by doing one of the following:

•• Drag from left to right across a portion of the ruler.

•• Set the values in the locator fields in the LCD.

	 2	 Select the regions you want to move by the cycle length. If no selection is made, all regions that 
fall between the locators are affected.

Clicking the Insert Silence button in the toolbar also affects all regions that fall between 
the locators.

	 3	 Choose Edit > Cut/Insert Time > Insert Silence Between Locators (or use the corresponding key 
command).

•• For selected regions that are longer than the cycle length: Regions are cut at the left locator 
position; the second region (newly created from the cut) is moved to the right of the right 
locator position, creating a gap between the regions.

•• For selected regions that fall wholly within the locators: Regions that began at the left locator 
position now begin at the right locator position.

•• For a combination of partially and wholly selected regions that fall within the locators: The 
encompassed section is cut, and moved to the right locator position.
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Remove gaps between regions
	 1	 Select the regions.

	 2	 Do one of the following:

•• Choose Edit > Move > Shuffle Left within Selection (or use the corresponding key command).

The first selected region on each track remains unchanged, and all subsequent regions are 
moved to the left:

•• Choose Edit > Move > Shuffle Right within Selection (or use the corresponding key command).

The first selected region on each track is moved to the right, and all subsequent regions 
remain unchanged.
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Remove a section of an arrangement using the locators
	 1	 Set the locators to span the section you want to remove (bars 5 to 8, for example).

	 2	 Do one of the following:

•• To cut all regions that fall between the locators: Click the Cut Section button in the toolbar, or 
choose Edit > Cut/Insert Time > Snip: Cut Section Between Locators.

•• To cut selected regions that fall between the locators:  use the Snip: Cut Section Between Locators 
(Selection) key command).

Any regions that span the cycle area (for example, a 16-bar region that starts at bar 1 and ends at 
the start of bar 17) are cut.

The section between the locators (bars 5 to 8) is deleted from all selected regions. (In fact, it is 
copied to the Clipboard and removed from the arrangement.) 

All regions to the right of the right locator are moved to the left by the length of the cycle 
(4 bars), including newly created regions that result from the operation. 

In the case of the 16-bar region example, from above, it would be cut into two regions:

•• One would span bars 1 to 4.

•• The other would now be an 8-bar region that is placed from bar 5 to the start of bar 13.

Tip:  The Snip command is ideal for situations in which you want to remove an entire section of 
your arrangement, such as a chorus.

Insert a cut section into your arrangement
	 1	 Set the locators to span the section you want to remove (bars 5 to 8, for example).

	 2	 Do one of the following:

•• To cut all regions that fall between the locators: Click the Cut Section button in the toolbar, or 
choose Edit > Cut/Insert Time > Snip: Cut Section Between Locators.

•• To cut selected regions that fall between the locators:  (or use the Snip: Cut Section Between 
Locators (Selection) key command).

	 3	 Set the playhead to the position where you want to insert the cut section.

	 4	 Either click the Insert Section button in the toolbar (to affect all tracks, regardless of selection), or 
choose Edit > Cut/Insert Time > Splice: Insert Snipped Section at Playhead.

All selected regions are cut at the left locator, and a passage of one cycle length is inserted. 
Regions currently in the Clipboard are then pasted at the playhead position.

Tip:  The Splice command is perfect when you want to insert a part (a chorus, for example) 
at another point in your arrangement. To guarantee all tracks are shifted, including tempo, 
time signature changes, and markers, make sure you select everything beforehand (using 
Command-A or Shift-I).
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Repeat a section of your arrangement using the locators
	 1	 Set the locators to span the section you want to repeat (bars 5 to 8, for example).

	 2	 Select the regions that you want to repeat. If no selection is made (or if you use the Repeat 
Section button in the toolbar), all regions that fall between the locators are affected.

	 3	 Choose Edit > Cut/Insert Time > Snip: Repeat Section Between Locators (or use the 
corresponding key command).

The portions of all regions that are wholly or partially encompassed by the locators are copied 
and pasted starting at the right locator position.

You can also move, copy, and delete sections of a project using arrangement markers. For more 
information, see Add arrangement markers.
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Shift the playback position of regions in the Tracks area
You can shift the playback position of regions on a track using the Delay parameter. Positive 
values shift regions ahead in time (laid-back playing style or dragging), while negative values 
shift regions back in time for a pre-delay (driving or rushing the music). The Delay value is shown 
in both ticks and milliseconds.

Shift the playback position of selected regions on a track
	 1	 Select the regions.

	 2	 In the Region inspector, do one of the following:

•• Click the left area of the Delay parameter, then drag up or down to set the value.

•• Click-hold the right area of the Delay parameter, then choose a value from the Delay 
pop-up menu.

The Delay parameter in the Region inspector is mainly intended for creative musical purposes, 
such as rhythmically offsetting regions. It can also be used to fix timing problems in cases such 
as the following:

•• The attack phase of the sound is too slow. A good musician will automatically compensate for 
this by playing the notes slightly early. With very slow sounds, you may need a pre-delay of 
over 100 ms to even them out.

•• The sound generator is reacting too slowly to the incoming note on messages. Older multi-
timbral sound generators often take tens of milliseconds before outputting a voice.

•• The delay in output is not constant, as it is dependent on the order of notes arriving at the 
external MIDI sound generator. You should therefore try pre-delaying rhythmically important 
tracks by as little as one tick—it can work wonders on timing.
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Loop regions in the Tracks area
You can loop regions so that they play repeatedly, and extend them to fill any amount of musical 
time in the Tracks area. When you play the project, the region repeats the number of times you 
have extended (looped) it.

You can also loop a region that has been resized. When you loop a resized region, only the visible 
portion of the region repeats when you play the project. If you add silence by lengthening a 
region, the silence is included in each repetition when you loop it.

Loop a region
	 1	 Place the pointer over the upper-right edge of the region.

The pointer becomes a Loop pointer.

Loop pointer

	 2	 Drag the right edge of the region until it aligns with the point where you want it to stop playing.

As you drag the edge of the region, “notches” appear at the top and bottom of the region, 
showing the beginning and end of each complete repetition.

Loop a region continuously
mm Select the region, then select the Loop checkbox in the Region inspector.

The region loops continuously until the start of the next region in the track, or until the end of 
the project. You can unloop the region by deselecting the Loop checkbox, or by pressing L again.

Note:  Deselecting the Loop parameter resets the manually created loop length. The next time 
the Loop parameter is used, the region is repeated until it either encounters another region in 
the same track, or reaches the end of the project (or folder).

Convert loops into aliases or clones
mm Select the original region, then choose Edit > Convert > Loops to Aliases (or use the Convert 

Loops to Aliases key command).

Software instrument loop repeats are converted into aliases. Audio loop repeats are converted 
into cloned audio regions. As such, any alterations to the length of the original region affect all 
aliases and cloned regions. For information about aliases and cloned regions, see Create aliases 
of MIDI regions in the Tracks area and Clone audio regions in the Tracks area.
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Resize regions in the Tracks area
You can shorten both audio and MIDI regions so that only part of the region plays. You can 
lengthen MIDI regions to add silence to the beginning or end of the region. In addition, you can 
resize the common edge of two adjacent regions to control the transition between them.

You can also move and resize regions numerically by opening an Event Float window. For more 
information, see Event Float window.

Resize a region
	 1	 Move the pointer over the lower-right edge of the region.

	 2	 When the Resize pointer appears, drag the region to shorten or lengthen it.

Resize pointer

Resize two adjacent regions
	 1	 Select the Pointer or Pencil tool, then place the pointer over the upper edge where two adjacent 

regions meet.

The pointer changes to the Junction pointer. 

Note:  If there is a gap between the regions, the Loop tool is shown when you move the pointer 
over the upper-right corner of the earlier region.

	 2	 Drag left or right.

Both regions are resized accordingly, with no gaps between them.

Resize selected regions to the same absolute length
mm Hold down Option-Shift while resizing the regions with the Pointer tool.

Resize selected region start or end points to the playhead position
Do one of the following:

mm Use the Set Region/Event/Marquee Start to Playhead Position key command.

mm Use the Set Region/Event/Marquee End to Playhead Position key command.

For audio regions, using the Set Region/Event/Marquee Start to Playhead Position key command 
also moves the anchor point to the playhead position.

Remove overlaps between regions
	 1	 Select the overlapping regions, or select all regions on the track by clicking the track header.

	 2	 Choose Edit > Trim > Remove Overlaps (or use the corresponding key command).

Where the selected regions overlap, the length of the left (earlier) region is reduced to remove 
the overlap.
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Lengthen regions to remove gaps between them
	 1	 Select the regions you want to lengthen.

	 2	 Choose Edit > Trim > Region End to Next Region (or use the corresponding key command).

The selected regions are lengthened to end at the start point of the next region on the track.

Lengthen selected regions between locators
	 1	 Set the left and right locator positions by doing one of the following:

•• Drag from left to right across the upper part of the ruler. 

•• Set the value in the locator fields in the LCD.

	 2	 Select the regions within the locator boundaries. 

You can quickly select all regions inside the locators by choosing Edit > Select > All 
Inside Locators.

	 3	 Choose Edit > Trim > Fill within Locators (or use the corresponding key command).

All selected regions within the locator boundaries are lengthened, closing the gaps between 
them. On each track, the last region within the locator boundaries is not lengthened.
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Mute and solo regions in the Tracks area
You can mute one or more regions in the Tracks area to exclude them from playback. You can 
also solo individual regions, to hear them in isolation, and lock the solo status of regions.

Mute individual regions
Do one of the following:

mm Select the Mute tool, then click the regions you want to mute.

mm Select the regions, then select the Mute checkbox in the Region inspector.

mm Select the regions, then press M.

Muted regions appear gray in the Tracks area, for easy identification.

Unmute muted regions
Do one of the following:

mm Select the Mute tool, then click the muted regions.

mm Select the muted regions, then deselect the Mute checkbox in the Region inspector.

mm Select the muted regions, then press M.

Solo individual regions
	 1	 Click-hold the region you want to solo with the Solo tool.

The region plays in isolation from the pointer position until you release the mouse button.

You can solo multiple regions by clicking them, then click-holding one of the selected regions 
with the Solo tool. Playback starts from the position of the pointer until you release the 
mouse button.

Solo regions using the Solo button
	 1	 Click the Solo button in the control bar (or press S).

	 2	 Select the regions you want to solo.

	 3	 While the project is playing, you can Shift-click additional regions to hear them. Select a soloed 
region (or Shift-click multiple soloed regions) to unsolo them.

	 4	 When you’re finished, click the Solo button (or press S) again.
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Lock the solo status of regions
	 1	 Option-click the Solo button in the control bar (or press Option-S).

	 2	 Select the regions you want to solo.

Selecting regions while the project plays does not affect their solo status.

	 3	 When you’re finished, click the Solo button (or press S) again.

Muted tracks and regions appear slightly differently in the Tracks area, depending on how they 
are muted:

•• When a track is muted using its Mute button, the regions on the track are gray, but the region 
names are in color.

•• When a track is turned off using its On/Off button, both the regions on the track and the 
region names are gray.

•• When an individual region is muted, the region and its name are gray, and a small colored dot 
precedes the name.

•• When a track is muted because another track is soloed, the regions on the track are gray, but 
the region names are in color.

Time stretch regions in the Tracks area
When you resize regions, the position of notes and other events in the regions does not change. 
Alternatively, you can time stretch regions to shorten or lengthen the relative distance between 
events in the regions. Expanding regions increases the distance (the amount of time) between 
events in the regions, while compressing regions decreases the distance.

For example, you can make a region play in half time by stretching it to twice its original length, 
or play in double time by shortening it to half its original length.

You can also time stretch individual notes, chords, and other items in audio regions using Flex 
Time. For more information, see Flex Time and Pitch overview.

Time stretch MIDI regions
mm Option-drag the left or right edge of one or more MIDI regions. 

The events within the region are stretched or compressed, proportionately, by the amount that 
the MIDI region is altered in length.

Time stretch or compress audio regions
mm Option-drag the right edge of an audio region.

This action stretches or compresses the audio by the amount that the region is altered in length, 
and replaces the original region with a new PCM audio file (in the original file format, or AIFF, if 
the original was not PCM).

Time stretching is limited to the value of the current Tracks area grid setting (in the Snap pop-up 
menu).
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Choose the audio time stretching algorithm
mm Choose Edit > Time Stretch > Time Stretching Algorithm, then choose an algorithm from 

the submenu.

•• Universal (default): This high-quality algorithm is able to handle any kind of audio material 
and is generally recommended for most time-stretching tasks. The following two algorithms 
can, however, deliver better results in cases where the audio material exactly matches the 
outlined specifications.

•• Complex: Choose this algorithm to obtain natural-sounding results when time-stretching 
complex musical material—orchestral music or final mixes.

•• Percussive: Perfectly maintains the timing of rhythmic material, making it a good choice for 
drum loops and percussive, nonharmonic signals. In comparison to the Beats Only algorithm, 
the Percussive algorithm is better suited for percussive material that has been processed 
through a reverb (or contains a long tail). This may also apply to percussive playing styles, such 
as staccato electric piano or clavinet parts. Beats Only may be the better alternative for dry 
drum recordings.

•• Version 5 (Legacy): Inherited from Logic 5, this algorithm can be used on most types of 
audio material. It imparts a particular color on processed audio, which may be a useful 
creative option.

•• Any Material (Legacy): Can handle most types of audio material.

•• Monophonic: (Legacy) A specialized algorithm for monophonic material—an individual voice, 
or brass or woodwind instrument, for example.

•• Pads (Legacy): Use on polyphonic material with harmonic content—choirs or string sections 
are good examples.

•• Rhythmic Material (Legacy): Use on rhythmic material—can be drums and percussion, but less 
obviously rhythm guitar, clavinet, and piano comp parts.

•• Beats Only (Legacy): Perfectly maintains the timing of percussive material. This algorithm 
should be your first choice for all kinds of dry drum loops.
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Split regions in the Tracks area
You can split a region in the Tracks area, and use the split segments of the region in different 
places in the Tracks area.

When you split a MIDI region, any notes at the split point are shortened to that point. If notes in 
a split MIDI region overlap other notes by more than a 1/16 note, a dialog appears, asking if you 
want to keep, shorten, or split the notes. 

Split regions at the playhead position
	 1	 In the Tracks area, select the region or regions you want to split.

	 2	 Move the playhead over the point where you want to split the regions, then choose Edit > Split > 
Regions at Playhead.

The selected region is split into two regions at the playhead position. Only the selected region 
is split, even if a region on another track is under the playhead as well. If multiple regions are 
selected and are under the playhead, they are all split.

Tip:  To cut at the nearest bar, use the Split Regions/Events by Rounded Playhead Position 
key command.

Split regions using the Scissors tool
	 1	 Select the regions you want to split.

	 2	 Select the Scissors tool, then click-hold the regions you want to split. 

The help tag shows the current split position.

	 3	 Release the mouse button.

All selected regions are cut at the position shown in the help tag. 

When selecting a cut point with the Scissors tool, you can move backward and forward in steps 
of one division. The grid is based on the Snap pop-up menu setting. 
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Split regions at the locator positions
	 1	 Set the left and right locator positions. 

	 2	 Select the regions you want to divide within the locator boundaries. 

	 3	 Choose Edit > Split > Region(s) by Locators (or use the Split Regions/Events by Locators or 
Marquee Selection key command).

All selected regions located wholly, or partly, between the locators are cut at the left and right 
locator positions. All regions created between the locator positions as a result of the Split 
operation are then automatically selected.

Tip:  You can achieve the same effect by defining a cycle with the pointer in the ruler, while 
holding down Command. 

Split a region into portions of equal length
mm Hold down Option while cutting a region with the Scissors tool.

A plus sign appears next to the Scissors tool.

The selected region is cut into several pieces—each the same length as the first segment.

For example, to divide a 16-bar region into eight 2-bar regions, cut the region at the start of bar 
3, while holding down Option.
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Handle overlapping notes in split MIDI regions
If any notes in a split MIDI region overlap other notes by more than a 1/16 note, a dialog appears, 
asking if you want to keep, shorten, or split the notes.

mm In the dialog, do one of the following:

•• Click Keep to leave all notes unaltered. The MIDI region is cut as intended, but there may be 
notes in the left half (earlier region) that are much longer than the MIDI region containing 
them. Such notes play normally, unless Clip Length is activated. (See Shift the playback 
position of regions in the Tracks area on page 299.)

•• Click Shorten to truncate all overlapping notes, so that they end at the point where the 
original MIDI region was split.

•• Click Split to split overlapping notes across the two MIDI regions; two notes are created, with 
the same pitch and velocity as the original, and with the same total length as the original note.

You can split an audio recording into segments based on amplitude levels using the Audio 
> Strip Silence function in the toolbar. For details, see Remove silent passages in the Strip 
Silence Window.

Demix MIDI regions in the Tracks area
You can split, or demix, a MIDI region (or a standard MIDI file of format 1 or 0) into separate 
regions by event channels or by note pitch.

Split MIDI regions by event channels
	 1	 Select the MIDI regions you want to split.

	 2	 Do one of the following:

•• Choose Edit > Separate MIDI Events > by Event Channel from the Tracks area menu bar (or use 
the Separate MIDI Region by MIDI Channel key command).

•• Control-click the MIDI region, then choose MIDI > Separate by MIDI Channel from the 
shortcut menu.

A separate MIDI region is created for every MIDI channel found, containing all matching 
events. Each region is created on a track with an instrument channel that matches the MIDI 
channel. If no such tracks exist, new tracks are created for each channel.

Split MIDI regions by note pitch
	 1	 Select the MIDI regions you want to split.

	 2	 Do one of the following:

•• Choose Edit > Separate MIDI Events > by Note Pitch from the Tracks area menu bar (or use the 
Separate MIDI Region by Note Pitch key command).

•• Control-click the MIDI region, then choose MIDI > Separate by Note Pitch from the 
shortcut menu.

A separate MIDI region is created for every note number found. A track is created for each new 
MIDI region, assigned to the same channel strip as the original MIDI region.

This feature is especially useful for separating drum parts that have been recorded into Logic Pro 
from a drum machine where all notes are on the same MIDI channel. Each note region can then 
be assigned to another channel strip, or perhaps some can be deleted, to thin out the original 
drum pattern.
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Join regions in the Tracks area
You can join untransposed audio regions, and join MIDI regions. Regions from audio Apple 
Loops, and audio regions that have been transposed, can’t be joined.

When joining audio regions, the regions must be adjacent to each other on the same track. If you 
join segments of compressed audio files, the files are converted to AIFF format. Audio regions are 
joined nondestructively. Logic Pro creates a new file for the joined audio (called a mixdown) that 
replaces the original regions. The new audio file is stored on your hard disk and is added to the 
Project Audio Browser.

Join one or more regions
mm Select the regions, then choose Edit > Join > Regions.

Join regions with the Glue tool
	 1	 Select the Glue tool.

Glue tool

	 2	 Do one of the following:

•• Select multiple regions by dragging, then click them with the Glue tool.

•• Shift-click regions with the Glue tool.

Join regions per track
	 1	 Select the regions you want to join on each track. Shift-clicking, dragging to select, or 

Command-A may be useful for this step. 

	 2	 Choose Edit > Join > Regions per Tracks (or use the Merge Regions per Tracks key command).

The selected regions on each track are joined into a single region on that track. For example, if 
you select regions on four different tracks, and then choose Edit > Join > Regions per Tracks, a 
single region is created on each of the tracks from the regions selected on that track.
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MIDI regions must be on the same track or on adjacent tracks. When you join MIDI regions, the 
joined region takes the name (and track) of the first original region. If the Transposition, Velocity, 
and Dynamics region parameters are different for the selected regions, they are normalized 
before being joined. (This means that all parameter values are written as data changes for each 
region. The parameters of the joined MIDI region are all set to neutral (default) values.)

No mixdown
If several (mono or stereo) regions on the same track are from the same original region, and in 
the same relative positions, no mixdown occurs. In this case, a single region is created.

No mixdown occurs when you join two regions on tracks that are panned to opposite sides, as 
the two resulting mixdown files would be identical to the original audio files (in the areas used 
for the regions). 

If several overlapping audio regions on a track are selected, no mixdown occurs. You are asked 
to create a new audio file, which takes the name of the first region on the track. The selected 
regions are then mixed together, with no changes to volume, and without clip scanning.

Genuine mixdown with Clipscan
If you combine audio regions from two or more tracks, the current pan and volume values for 
the individual tracks define the pan and volume settings in the new audio file.

If you want to combine both sides of a stereo audio file (a mono channel on each of two tracks), 
first set the pan controls of the component mono sides to hard left and hard right, respectively.

Following the digital clipping scan (Clipscan) and completion of the mixdown, Logic Pro replaces 
the previously selected regions with one region that contains the entire mixed-down audio file. 

You can use the Edit > Undo function (Command-Z) to restore the original audio regions, if you 
change your mind about the mixdown. If you do so, you are asked if you want to keep, or delete, 
the newly created mixed audio file. If you keep it, it remains in the Project Audio Browser, and 
can be further used and processed.

During a mixdown, the 32-bit resolution Clipscan function ensures that the highest possible level 
is maintained, without clipping.
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Audio crossfades in Digital Mixdown
Digital Mixdown supports crossfades between selected regions.

The Crossfade parameters are defined by choosingLogic Pro > Preferences > Audio > General (or 
using the Audio Crossfade Options for Merge key command).

There are two faders:

•• Crossfade Time [ms]: The length of the entire crossfade. To turn off the crossfade, set this value 
to 0.

•• Crossfade Curve: To obtain a linear crossfade, set this value to 0. Other values (positive 
or negative), produce various exponential fades. The fade-outs and fade-ins are always 
symmetrical, to avoid deviations in level. The preset values are Time = 0 ms, Curve = 0 (linear).
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Create aliases of MIDI regions in the Tracks area
You can create an alias for a MIDI region or a folder. An alias is a reference to a region, and looks 
similar to a normal region in the Tracks area. If you alter the original region, all aliases of the 
region are similarly altered.

Aliases can be useful when you want to repeat a phrase or riff in different parts of an 
arrangement. If you make changes to the original region after creating aliases from it, the 
changes apply to all its aliases throughout the project. If you want to edit one of the aliases 
without changing the others, you can turn that alias into an independent region (a region copy) 
and edit it independently.

Aliases do have some differences from their “parent” region: you can give each alias its own 
name, and edit region parameters for each alias independently.

Alias names appear in italics to distinguish them from normal regions. If you name an alias, its 
parent region name is shown below the alias name (provided that the zoom level is adequate). 

Any changes made to the parent region name appear on all its aliases. 

Create an alias
Do one of the following:

mm Option-Shift-drag the region to the position where you want the alias to start.

mm Select the track you want to create the alias on, position the playhead, select the region you 
want to create an alias from, then choose Functions > Region Alias > Make Alias (or use the Make 
Alias key command).

You can also use the Repeat Regions command.

If several regions are selected, their relative time and track positions are retained. The selected 
track is the destination track for the first region along the Tracks area.

Reassign an alias
You can assign a new original region to an existing alias. This is exceptionally handy for arranging 
tasks where the structure is right, but the part is wrong. You can copy a region to a new track, 
create an alias, mute the existing region, and click Play, or use the far simpler method below:

	 1	 Select both the alias and the intended new original region.

	 2	 Choose Functions > Region Alias > Re-Assign Alias (or use the Reassign Alias key command).

Search for an original region or alias
If you forget where the original is for a certain alias, you can search for it. Do one of the following: 

mm Select the alias, then choose MIDI > Alias > Select Original (or use the Find Original of Alias key 
command).

mm Choose Functions > Region Alias > Select Aliases of Region.
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Convert aliases from deleted source regions
If you delete a source region that one or more aliases was derived from, Logic Pro asks if you 
want to convert the aliases to independent MIDI regions, or keep the aliases. Do one of the 
following:

mm To cancel the procedure: Click Cancel.

mm To change all alias MIDI regions into real copies: Click Convert.

mm To delete the parent region, and retain all (orphaned) alias regions: Click Keep. Although such 
orphan aliases serve no useful purpose, Logic Pro doesn’t automatically delete them, in case you 
decide to reassign them to new originals at a later stage.

Select and delete all orphan aliases
If your project file contains unneeded aliases, you can quickly tidy up by selecting and deleting 
all orphan aliases.

mm Choose Functions > Region Alias > Select Orphan Aliases (or use the corresponding key 
command).

mm Choose Functions > Region Alias > Delete Orphan Aliases (or use the corresponding key 
command).

Convert an alias to a normal region
You can create a real region from an alias; its contents are identical to those of the original 
region referenced by the alias, but its playback parameters are those of the alias. After it’s been 
converted to a real region, you can edit it (or the original parent region), without affecting the 
new real region.

You can also double-click an alias to open a dialog that asks whether you want to create and edit 
a real copy, or edit the original.

If you double-click an alias to edit it, Logic Pro assumes that you either want to edit the original, 
or turn the alias into a real region. You are asked whether you want to create and edit a real copy, 
or to edit the original.

mm Choose Functions > Region Alias > Convert to Region Copy from the Tracks area menu bar (or 
use the Convert Alias to a Region Copy key command)
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Clone audio regions in the Tracks area
You can clone audio regions in the Tracks area. Cloning an audio region is similar to creating an 
alias of a MIDI region; the clone doesn’t contain any audio data, but is only a reference to the 
original, and any changes to the original apply to its clones.

Clone a region
mm Hold Option-Shift while dragging an audio region. 

When you adjust the start or end point of any of the cloned regions, all other cloned regions are 
adjusted in the same way.

Convert cloned regions to independent regions
mm Select a group of cloned regions and choose Edit > Convert > Audio Region to New Region from 

the Tracks area menu bar. 

After you make the cloned regions independent, altering the start or end point of one cloned 
region will not affect the others.

Convert multiple regions into audio files
	 1	 Select the regions you want to convert.

	 2	 Choose Edit > Convert > Audio Region to New Audio File (or press Option-Command-F).

	 3	 In the dialog that appears, set the sample rate, bit depth, file format, stereo conversion, and 
dither type for the converted audio files.

The new audio files are created in the same folder as the original audio file. The files are also 
added to the Project Audio Browser, and all references to these new regions are changed to 
correspond with the newly created files.

These newly created files can be edited independently, allowing you to reverse, time stretch, and 
more, without affecting other regions based on the same original file.
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Change the color of regions in the Tracks area
You can change the color of regions to identify sections of your arrangement, distinguish 
between track types, or for other uses. Newly recorded or added regions use the color of the 
track channel strip.

Change the color of one or more regions
	 1	 Select the region or regions.

Note:  If you select all regions on a particular track, and no regions on other tracks are selected, 
coloring them alters the hue of all selected regions. This also changes the color of the selected 
track’s channel strip.

	 2	 Control click one of the selected regions, then choose Name and Color > Show/Hide Colors from 
the shortcut menu.

	 3	 Click a color.

Set regions to match the track color
	 1	 Select the regions you want to change. 

If all regions are on a single track, click the track’s header to select all regions.

	 2	 Choose Functions > Color Regions by Track Color from the Tracks area menu bar.

The colors of all selected regions are replaced with the colors of the corresponding track 
channel strips.

Tip:  This feature is handy after copying or moving regions between tracks, when you may find 
that the Tracks area resembles a patchwork quilt.
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Convert audio regions to EXS sample zones
You can convert one or more regions or tracks into one-note/one-sample zones of a new EXS 
instrument. This EXS instrument is set up on a new software instrument track, which contains 
trigger notes to play the zones at their original positions.

Convert audio regions to sample zones on a new sampler track
	 1	 Select the audio regions you want to convert in the Tracks area.

	 2	 Control-click one of the selected regions, then choose Convert > Convert Regions to New 
Sampler Track from the shortcut menu.

	 3	 Choose whether you want to create zones from regions or transient markers:

•• Regions: Converts the entire selected region, or regions, into an EXS zone.

•• Transient Markers: Converts only those sections between transient markers into an EXS zone.

Note:  If you create zones from transient markers, a transient detection process is performed 
on the audio region or regions, if not previously done.

	 4	 Enter the EXS instrument name in the text field. The default is the name of the first 
region selected.

	 5	 Choose settings from the Trigger Note Range pop-up menus—the lowest and highest note for 
the one-note zones created in the new sampler instrument.

	 6	 Click OK to perform the conversion.

A new software instrument track is created, below the selected track, on which the EXS24 is 
inserted. MIDI regions with ascending trigger notes are created on this track. The new track and 
regions are selected, while the processed regions are muted and deselected.

Note:  The EXS samples are saved to the project only if the File > Project Settings > Assets > 
“Copy EXS samples into project” setting is turned on. The EXS instrument is saved to the project, 
regardless of this setting. 
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Delete regions in the Tracks area
You can delete one or more regions if you don’t want to use them in your project. When you 
delete a region, you can move the regions that follow in the track to fill in the empty space left 
by the deleted region.

When you delete an audio region that you have recorded since opening the project, a dialog 
appears, asking if you also want to delete the corresponding audio file. This dialog does not 
appear for imported audio files, to assure that you do not accidentally delete recordings used in 
other projects.

Delete a region
mm Select one or more regions, then choose Edit > Delete (or press the Delete key).

You can also delete regions using the Eraser tool.

Delete a region and move all regions that follow
mm Select one or more regions, then choose Edit > Delete and Move.

Delete all selected regions, and automatically select the next one
	 1	 Select the region or regions you want to delete. 

	 2	 Use the Delete and Select Next Region/Event key command.

All selected regions are deleted, and the next region is automatically selected.

Restore deleted regions
mm Choose Edit > Undo History, then click the appropriate step.

Restoring audio and MIDI regions deleted from the Tracks area involves somewhat different 
procedures. When you delete an audio region from the Tracks area, it remains in the Project 
Audio Browser. You can restore it to the Tracks area by adding it from the Project Audio Browser. 
Both audio and MIDI regions can be restored using the Undo history.
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Create fades and crossfades on audio regions

Create fades
You can fade in the beginning of audio regions, and fade out the end of audio regions (including 
audio Apple Loops).

Fades are only visible if you are zoomed in enough to see the waveform in the audio region. 
You can create a fade using either the Fade tool or the Fade In and Fade Out parameters in the 
Region inspector.

Create a fade-in or fade-out with the Fade tool
	 1	 Select the Fade tool.

Fade tool

	 2	 Do one of the following:

•• Drag over the start or end point of an audio region.

A fade-in or fade-out is created. The length of the fade drag area determines the length of the 
fade, so a longer drag area results in a longer fade time, and a shorter drag area, a quick fade.

•• Drag over the end point of one audio region and the start point of the region that follows.

This technique works even if the two sections don’t directly adjoin each other.

With the Fade tool selected, you can edit fades on regions after you make them.

Create a fade-in or fade-out using the Region inspector
	 1	 Select one or more regions.

	 2	 Set the value for the Fade In or Fade Out setting in the Region inspector by dragging the pointer 
vertically, or double-clicking and entering a value.
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Fades created using the Fade tool and the Region inspector are interactive. After you create a 
fade using the Fade tool, for example, you can adjust the fade using the Region inspector Fade In 
or Fade Out parameters.

Edit fades
You can change the length of a fade, the fade curve shape, the fade type, and the fade 
playback speed.

You can also choose between four different fade types in the Region inspector.

Edit the length of a fade
Do one of the following:

mm Drag over the start or end point of a fade with the Fade tool.

mm Select a region, then edit the Fade In or Fade Out value in the Region inspector.

Adjust the fade curve shape
Do one of the following:

mm Drag the fade curve with the Fade tool.

mm Select a region, then edit the Curve value in the Region inspector.

In the example below, a positive curve is shown for both the fade-in and fade-out.

In this next example, a negative curve is shown for the fade-in, and a linear fade (no curve) is 
shown for the fade-out.
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Change the fade type
mm In the Region inspector, choose a fade type from the Fade Out pop-up menu.

•• Out: Creates a standard fade-out whenever the Fade tool or Fade parameter is used.

•• X (Crossfade): Crossfades the selected region with the following region when you use the Fade 
tool or Fade parameter.

•• EqP (Equal Power Crossfade): Results in an Equal Power crossfade. This minimizes volume dips 
between audio regions, resulting in a more even crossfade between regions that may be 
slightly different in level.

•• X S (S-Curved Crossfade): Delivers an S-curved crossfade. The fade curve, as the name suggests, 
is S shaped.

The last three items in the pop-up menu can only be applied to two consecutive regions. Also 
note that the Fade In (and corresponding Curve) parameters are made redundant when any of 
the X, EqP, or X S options are chosen.

Change the playback speed of a fade
Do one of the following:

mm For a fade in, choose the Speed Up parameter, and modify the value.

mm For a fade out, choose the Slow Down parameter, and modify the value.

Logic Pro offers Speed Up and Slow Down parameters in the Region inspector, which you can 
use to speed up or slow down the playback speed of fades. These parameters share pop-up 
menus with the Fade In and Fade parameters.
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Create automatic crossfades
Logic Pro can automatically create crossfades on overlapping audio regions on a track to 
smoothly segue between adjacent (or overlapping) audio regions.

Turn on automatic crossfades
mm Choose the X-Fade setting from the Drag pop-up menu in the Tracks area menu bar. (See Control 

positioning with drag modes on page 284.)

You can also create crossfades manually—as well as fade-ins and fade-outs—using the Fade tool, 
the Fade parameters in the Region inspector, or the shortcut menu of an existing fade area. For 
information, see Create fades and Edit fades.

You can simultaneously adjust the fade parameters for all selected audio regions.

Note:  The Fade parameters are nondestructive, unlike the fade functions available in the Audio 
File Editor, which change the original audio file. 

Delete fades
You can delete a fade with a menu command, with the Fade tool, or by modifying the 
parameters in the Region inspector.

Delete a fade
Do one of the following:

mm Control-click an existing fade area, then choose Remove Fade from the shortcut menu.

mm Option-click an existing fade area with the Fade tool.

mm Set the Fade In or Fade Out parameter in the Region inspector to 0.
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Remove silent passages from audio files

Remove silent passages in the Strip Silence Window
You can remove silent passages from audio regions in the Strip Silence window. The basic 
process is simple: all amplitude values below a threshold level are removed, and new regions are 
created from the remaining passages.

The parameters of the Strip Silence window are:

•• Threshold: Use to define the amplitude level that a passage must exceed, in order to be 
defined as a region. In terms of the number and length of regions created by the process, 
this is the most important parameter. As a general rule: a higher Threshold value leads to 
numerous short regions. Low values create fewer large regions.

•• Minimum Time to accept as Silence: Use to define the length of time that a section must be 
below the Threshold value, before it is considered a gap. Very small values tend to increase the 
number of regions, because even short dips in amplitude are interpreted as silence. Higher 
values prevent sections of audio from being interrupted by fluctuating amplitudes. 

•• Pre Attack-Time: Use to add a defined amount of pre-roll to the beginning of all regions 
created by the Strip Silence process. High threshold values prevent any amplitudes with slower 
attack times from being chopped. This function is useful for nonpercussive material such as 
vocals, wind instruments, strings, and so on. Overlaps are permitted—the pre-delayed start 
point of a region can extend back to the end of the previous region—but only if the Threshold 
value is not exceeded. The Pre Attack Time doesn’t affect the anchor position, which means the 
absolute position of the audio data (in the project) is retained.

•• Post Release-Time: Use to define an automatic release time for the end points of all regions, 
avoiding abrupt cutoffs to amplitudes that fade out gradually (particularly if you have set 
a high Threshold value); for example, cymbals, open hi-hats, snares with long reverb tails, 
vocals, and so on. This parameter does not allow overlaps, which means that region end 
points cannot extend beyond the start point of the following region. The Post Release Time 
doesn’t affect the anchor position, which means the absolute position of the audio data (in the 
project) is retained.

•• Search Zero Crossings: Select this checkbox to automatically snap the region start and end 
points to the nearest waveform zero crossings.
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Open the Strip Silence window
mm In the Project Audio Browser, Control-click an audio region, then choose Strip Silence from the 

shortcut menu.

Remove silent passages from the selected region
	 1	 Set parameters in the Strip Silence window.

Note:  Depending on the material in the audio file, all parameters can affect the number and 
division of regions. Try different values to see what produces the best result. The graphic display 
of the region updates to show the result of your changes.

	 2	 Click OK. 

If you selected a region that is used in the Tracks area, a dialog asks if you want to replace the 
region in the Tracks area with the new regions.

	 3	 Do one of the following:

•• To replace the region in the Tracks area with regions created by the Strip Silence function: Click 
Replace or press Return. This ensures that the relative timing of the individual audio segments 
remains unaltered.

•• To have the regions appear only in the Project Audio Browser: Click No. You can add regions 
manually from the Project Audio Browser.

To learn about different uses for Strip Silence, see Uses for Strip Silence.
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Uses for Strip Silence
You can use Strip Silence for a variety of different situations.

Remove background noises
The most common use for Strip Silence is simulation of the classic noise gate effect. When used 
on long recordings with numerous gaps—such as vocals or instrumental solos—you can obtain 
better results by setting a low threshold value. Background noise is removed, without affecting 
the main signal.

•• For short percussive regions (drum loops), you can simulate time compression/expansion by 
simply altering the tempo.

•• You can even quantize the individual segments in an audio recording.

Create segments of spoken recordings
You can use Strip Silence to divide long spoken passages into several convenient segments, like 
sentences, words, or syllables. For film synchronization or jingles, you can move or reposition the 
speech segments by simply dragging them around in the Tracks area.

Tempo changes allow you to simulate a time compression or expansion effect, as the syllables 
automatically move closer together, or farther apart.

Create segments for drum loops
Dividing drum loops into small segments is a good way to perfectly synchronize them. For 
example, in audio passages where the bass drum and snare are completely separate, you can 
often use Strip Silence to isolate each individual beat.

Optimize synchronization
Different computers, different synchronization sources (internal or SMPTE code), different tape 
machines, and—in theory—different samplers or hard disk recording systems will exhibit slight 
variations in clock speed. Changing just one component can lead to a loss of synchronization 
between recorded audio material and MIDI. This is particularly applicable to long audio regions. 

This is another situation where the Strip Silence function can help, by creating several shorter 
audio regions, with more trigger points between the audio and MIDI events.

For example, you can use this method to roughly split up a whole audio file, and then divide the 
new regions, using different parameters. The new regions can then be processed again with the 
Strip Silence function.

Optimize files and regions
You can use Strip Silence to automatically create regions from an audio file that contains silent 
passages, such as a single vocal take that runs the length of a project. The unused regions 
or portions of the audio file can be deleted, saving hard disk space, and simplifying (file and) 
region management.

Use Strip Silence to extract audio files
Many sample library discs (CD or DVD) contain thousands of audio recordings stored as AIFF 
or WAV files. Strip Silence can be used to split these into individual regions, which can be used 
directly in the Tracks area. Regions can also be converted into individual audio files (samples), 
which can be used in the EXS24 mkII.
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Work with folders

Folders overview
A folder is a region that can contain other regions, similar to a folder in the Finder that can 
contain different files. You can generally edit a folder in the same ways you edit a MIDI region.

A folder can be thought of as an arrangement within an arrangement. A folder can contain as 
many tracks (with their regions) as needed. When a folder is closed, it looks like a MIDI region in 
the Tracks area:

When open, a folder looks just like the Tracks area for a project:

The track containing the folder doesn’t have a channel strip. Its track header shows a folder icon 
in place of an instrument icon.

If you drag a folder to a software instrument track, all MIDI regions in the folder are played 
by that instrument. This can be useful if the folder contains tracks for a given instrument or 
instrument type, such as a drum kit, string sound, or brass section, for example. This provides 
a quick way of listening to a string arrangement if some of the intended sound sources 
are unavailable.

Similarly, an entire project could itself be a folder, appearing as a gray beam in the Tracks area. 
In this way, you could arrange several projects for a concert. Another possible use might be to 
store different arrangements of a project in different folders, allowing you to switch between 
them rapidly.

You can also use folders to represent song sections such as verses and choruses, for example. You 
can nest folders within other folders, with no limit to the number of levels you can create.
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Pack and unpack folders
You can pack selected regions into a folder, or create an empty folder and add regions to it.

Pack regions into a folder
mm Select the regions, then choose Functions > Folder > Pack Folder from the Tracks area menu bar.

If the selected regions are all on the same track, the folder is created on that track. If the regions 
are located on different tracks, a new folder track is created.

Note:  When moving a folder with a single content track between tracks of the same type, the 
folder contents play using the channel strip of the hosting track.

Create an empty folder
mm With no regions selected in the Tracks area, choose Functions > Folder > Pack Folder from the 

Tracks area menu bar.

The new, empty folder contains tracks assigned to all channel strips from the current level.

Unpack a folder
	 1	 Select the folder.

	 2	 Do one of the following:

•• Choose Functions > Folder > Unpack Folder to New Tracks from the Tracks area menu bar.

Logic Pro creates new tracks on the same level that the folder was located on (below the 
former folder track). 

•• Choose Functions > Folder > Unpack Folder to Existing Tracks from the Tracks area menu bar 
(or use the “Unpack Folder to Existing Tracks” key command).

The regions contained within the folder are placed on tracks assigned to appropriate 
channel strips.
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Open and close folders
After you have packed a folder, you can open it to make changes.

There are several ways to distinguish whether you are inside a folder, or viewing the entire 
project in the Tracks area:

•• In the Tracks area (outside the folder), the folder itself is visible on a track, the Logic Pro main 
window title bar shows the project name, and the Display Level button  is dimmed.

•• When inside a folder, the folder track can’t be seen, the main window title bar shows the 
project name followed by the folder name (for example; Untitled: Chorus Folder), and the 
Display Level button is available.

Open a folder
Do one of the following:

mm Double-click the folder.

mm Select the folder you want to open, then use the Go Into Folder or Region key command.

If a MIDI region, rather than a folder, is selected when you use the key command, the Piano Roll 
Editor opens.

Double-clicking the header of a folder track opens the Mixer. 

Close a folder
Do one of the following:

mm Double-click the background of the Tracks area (or use the Go Out of Folder or Region key 
command).

mm Click the Display Level button  in the Tracks area menu bar. The help tag shows Leave Folder.

You move up one display level, and the contents of the Tracks area (showing the closed folder) 
are visible.
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Add and remove regions from folders
You can easily add and remove regions from a folder. This is useful as you experiment with your 
arrangement, and find that you need to add or remove parts.

Add regions to a folder
mm At the top level of the Tracks area hierarchy (outside the folder), drag the regions onto the folder, 

at the desired position.

If the folder doesn’t already contain a track that uses the same channel as the source region, 
Logic Pro creates one. If it does contain a track using the same channel, the track uses this 
channel. When you enter the folder, you see the dragged regions at the drop position.

Remove regions from a folder
	 1	 Open a second Tracks area window by choosing Window > Open Tracks, or use the Open Tracks 

key command (Command-1).

	 2	 In one of the two windows, open the folder containing the regions you want to remove.

	 3	 Drag the regions into the Tracks area in the other window.

You can also cut a region from a folder, using the Edit > Cut command to transfer the region to 
the Clipboard. You can then copy the region to the position where you want it to appear in the 
Tracks area using the Edit > Paste command.
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Create alias folders
You can create a copy of a folder that contains aliases (of MIDI regions) and clones (of audio 
regions) in the original folder. Then you can use the copied folder as an alternative mix folder, 
by muting regions, and editing instrument or playback parameters, for example. You can quickly 
switch between different arrangement versions simply by muting and soloing different folders.

Create an alias folder
mm Hold down Shift and Option as you drag the folder to the position where you want the alias 

to start.
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Work with groove templates

Create groove templates
You can create quantization grids, called groove templates, based on the rhythms of audio or 
MIDI regions. Groove templates make it possible to capture the small timing deviations that give 
a region its “feel,” and apply that feel to other audio or MIDI regions. You can even take the feel 
from an audio region and apply it to a MIDI region—helping a MIDI clavinet part to sit well with 
a funk guitar Apple Loop, for example.

You can also select multiple regions to create a groove template, and all of them will contribute 
their transients or notes to the new groove template. When there are multiple transients or 
MIDI notes around the same musical position, however, only the first will be evaluated for the 
groove template.

Tip:  Two-bar MIDI regions work particularly well for groove templates, but you can use MIDI 
regions of any length. Make sure that the source MIDI region actually contains a note at every 
desired quantization value.

Create a groove template
	 1	 Select the audio or MIDI region or regions you want to create a groove template from.

If you select multiple regions, the transients or notes from all the selected regions are used for 
the groove template. When there are multiple transients or MIDI notes around the same musical 
position, however, only the first will be evaluated for the groove template.)

	 2	 In the Region inspector, choose a quantization value from the Quantize pop-up menu.

	 3	 Open the Quantize pop-up menu again, and choose Make Groove Template (or use the 
corresponding key command).
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The groove template, with the default name of the selected region, appears near the bottom of 
the Quantize pop-up menu, and the Quantize parameter of the parent region is set to it.

This function transforms the exact timing of transient markers or notes in the selected audio or 
MIDI region into a groove template that can be accessed, and used, like any value in the Quantize 
pop-up menu.

Important:  The source audio or MIDI region used for a groove template must remain in your 
project if you want to use the groove template. If you delete the source region from the project, 
the groove template is not removed from the Quantize pop-up menu, but it can no longer be 
used. Choosing the groove template from the Quantize pop-up menu produces no effect.

Remove groove templates from the Quantize pop-up menu
	 1	 In the Region inspector, open the Quantize pop-up menu of any region, and choose the 

groove template.

	 2	 Open the Quantize pop-up menu again and choose “Remove Groove Template from List” (or use 
the corresponding key command).

The selected source region is deleted from the list of possible quantization templates, removing 
it from the Quantize pop-up menu. The region is not removed.

Without changing the actual quantization of that region (or of any other region that may use 
that groove template), the previously selected groove template is deleted, and the region is set 
to the Quantize value “off (3840).”

Share a groove template between projects
	 1	 Copy or create your source regions in one project.

	 2	 Name these regions with the Text tool.

	 3	 Open the Quantize pop-up menu, then choose Make Groove Template for each source region (or 
use the corresponding key command).

	 4	 Pack all of these regions into a folder (and rename the folder Grooves, for example).

	 5	 Choose File > Save As Template.

Use this template as your project starting point whenever you want to access these 
quantization templates.
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Import groove templates
You can import third-party groove templates, such as the DNA Groove Templates made by the 
Canadian firm WC Music Research.

Import third-party groove templates
	 1	 Choose File > Import > Other.

	 2	 Choose “DNA Groove Template files” from the Open File pop-up menu, select the file you want to 
import, then click Import.

The groove templates are added as MIDI regions on the selected track.

	 3	 To add the groove templates to the Quantize pop-up menu, select a groove template and then 
choose Make Groove Template from the Quantize pop-up menu of the Region inspector.

Note:  The quantization templates are saved with the project and can be used, even when the 
project is played on a computer that doesn’t have the corresponding DNA Groove Templates on 
its hard disk.
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Edit region parameters

Region inspector
You can view and edit region parameters in the Region inspector, located in the upper part 
of the inspector. When a single region is selected, the title bar of the Region inspector shows 
the region name; when multiple regions are selected, the title bar shows the number of 
selected regions.

The Region inspector shows parameters for the selected region or regions, including Quantize 
and other parameters. Some parameters are available for only audio or MIDI regions, while others 
are shared. There are additional advanced quantization parameters that you can view and edit by 
clicking the More disclosure triangle.

You can also open the Region inspector in a separate floating window.

  When Show Advanced Tools is selected in the Advanced preferences pane, additional 
parameters appear in the lower part of the Region inspector. You can view and edit these 
parameters by clicking the More disclosure triangle.

Open the Region inspector in a separate window
mm Choose Window > Open Region Inspector Float.

Shared region parameters
You can edit the following common parameters for both audio and MIDI regions:

•• Quantize: All note events contained in the MIDI region are time corrected to the (quantize) 
grid format chosen in the pop-up menu. For information on choosing the Quantize parameter 
value, see Quantize parameter values.

•• Q-Swing: This percentage value alters the position of every second point in the current 
quantization grid. Values over 50% delay the beats, and values under 50% pre-delay them. The 
most practical settings fall between 50% and 75%, imparting a swing feel to strictly quantized 
(or tightly played) audio or MIDI regions. For information about Q-Swing and other advanced 
quantization parameters, see Advanced quantization parameters.

•• Loop: The playback of all region types can be continuously repeated by selecting the Loop 
checkbox, or by using the Loop tool. (See Loop regions in the Tracks area on page 300.) 

•• Delay: The playback of all region types can be delayed (positive values) or advanced (negative 
values) by ticks, or by milliseconds. (For more information, see Shift the playback position of 
regions in the Tracks area on page 299.)

•• Advanced Quantization: Q-Strength: This percentage value determines how far a note is shifted 
toward the nearest grid position. 100% results in full quantization; 0% leaves the note at its 
recorded position.
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•• Advanced Quantization: Q-Range: Q-Range is a very musical quantization method that requires 
a certain amount of technical musical prowess. It’s ideal for recordings that already have the 
right groove, but are too hurried or laid back in places. It allows you to retain the original feel, 
but positions the rhythmic center precisely in the groove. A value of 0 means that every note 
is quantized. If you enter negative Q-Range values, only notes that fall outside the set range 
are moved to ideal quantization grid positions, while notes closer to an ideal position remain 
unquantized. This moves the most poorly played notes (those outside the range) to perfect 
timing positions on the quantization grid, or at least toward these positions, depending on the 
Q-Strength setting.

MIDI region defaults
If no region is selected, the upper line of the Region inspector displays MIDI Thru. Any live MIDI 
input (in stop mode, as well as during recording or playback) is played with the settings chosen 
here. When you record a new MIDI region, the settings in the inspector are carried across to 
the new region’s Region inspector. The MIDI Thru inspector can be viewed as an adjustable 
default inspector.

The MIDI Thru parameters can be adjusted when no regions are selected. Click an empty part of 
the Tracks area to deselect all regions.

Note:  The Set Track and MIDI Thru Parameters by Region/Folder key command allows you to set 
the MIDI Thru parameters to match those of a selected MIDI region. This action also selects the 
region’s track.

Editing several regions simultaneously
If several regions are selected, the number of selected regions is displayed, in place of a region 
name. If you alter any region parameter, all selected regions are affected. If a given parameter 
is set differently in the individual regions, an asterisk (*) appears in the parameter field. You can 
alter this parameter for all selected regions, and the value differential will be retained (relative 
alteration). If you want to set all selected regions to the same value, hold down Option-Shift 
while changing the value (absolute alteration). 
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Quantize parameter values
You can quantize selected audio or MIDI regions (including a mixed region selection) using 
the Quantize parameter in the Region inspector. This parameter determines the division of the 
quantization grid.

Important:  The Quantize parameter is nondestructive. It adjusts the playback positions of notes 
in MIDI regions when Logic Pro is in playback or record mode. The original positions are kept in 
the regions, so you can go back to the original timing.

The values of the Quantize parameter in the Region inspector are grouped in the following 
categories:

•• No quantization: The off setting plays the notes at the finest possible timing resolution: 1/3840 
note, which is unquantized playback, for practical purposes.

•• Normal quantization: The 1/1-Note, 1/2-Note, 1/4-Note, 1/8-Note, 1/16-Note, 1/32-Note, and 1/64-
Note settings quantize the MIDI region to the equivalent note value. 

•• Triplet quantization: The Triplet settings quantize the MIDI region to triplet note values. The 
equivalent values are shown in parenthesis.

•• Swing quantization: The 1/16 Swing A-F settings delay the position of every second point in the 
quantization grid by a fixed percentage. You can also manually alter the swing factor of any 
Quantize value.

•• Odd quantization: The 5-Tuplet/4 is quarter quintuplets (1 bar = 5 beats), 5-Tuplet/8 is eighth 
quintuplets (1 bar = 10 beats), 7- Tuplet is septuplets (1 bar = 7 beats), and 9-Tuplet setting 
denotes novetuplets (1 bar = 9 beats).

•• Mixed quantization: These combine ‘straight’ and tuplet values of 1/16 and 1/18. Mixed 
quantization always applies to both note values, and requires greater playing precision 
when recording.

The Swing settings delay the position of every second point in the quantization grid by a fixed 
percentage, as follows:

Quantize setting Swing percentage

Swing F 71%

Swing E 66%

Swing D 62%

Swing C 58%

Swing B 54%

Swing A 50%
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Advanced quantization parameters
  When Show Advanced Tools is selected in the Advanced preferences pane, you can quantize 

regions with greater precision using the advanced quantization parameters in the Region 
inspector. Using the advanced parameters, you can apply a swing or other quantize feel to MIDI 
regions. Not all advanced quantization parameters are available for audio regions.

Advanced quantization parameters in the Region inspector include the following:

In the Region inspector, the Q-Swing field is located below the Quantize pop-up menu. The other 
advanced quantization parameters are available by clicking the More disclosure triangle. They 
can be applied to any quantization value (except “off”).

•• Q-Swing: Alters the position of every second point in the current quantization grid. Values over 
50% delay the beats; values under 50% pre-delay (advance) them. The most practical settings 
are between 50% and 75%, which give a swing feel to strictly quantized (or tightly played) 
regions.

•• Q-Strength: Determines how far a note or transient marker is shifted toward the nearest grid 
position. A value of 100% results in full quantization, and 0% leaves the note or transient 
marker at its recorded position.

•• Q-Range: Q-Range is ideal for recordings that already have the right groove but are too hurried 
or laid back in places. It lets you retain the original feel, but positions the rhythmic center 
precisely in the groove. A value of 0 means that every note or transient marker is quantized. 
Negative Q-Range values move only notes or transient markers that fall outside the set range 
to ideal quantization grid positions, while those closer to an ideal position are not quantized. 
In this case, the most poorly played notes or transient markers—those outside the range—
are moved to perfect timing positions on the quantization grid (or closer to these positions, 
depending on the Q-Strength setting). 

Tip:  To obtain the best Q-Range results, use a low, even Quantize value, such as 1/4 note. Set 
the Q-Range parameter to compensate for the maximum error in the recording.

•• Q-Flam: Spreads out notes with the same time position, such as chords. Positive values 
produce an ascending (upward) arpeggio, negative values a descending (downward) arpeggio. 
The position of the first note (either the bottom or top note) is unaltered.

•• Q-Velocity: Determines how much the velocity values of quantized notes are affected by the 
velocity values of a template MIDI region. At a value of 0%, the notes retain their original 
velocity. At 100%, they adopt the velocity values of the template. Negative values alter the 
velocity, making the deviation from the template even greater.
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•• Q-Length: Determines how the lengths of quantized notes are affected by the equivalent note 
lengths (notes at the same position) of a template MIDI region. A value of 0% has no effect, 
whereas at 100% the notes adopt the exact note lengths of the template region. Negative 
values alter note lengths further, resulting in a more significant deviation from the template.

Audio region parameters
The following parameters are only available for audio regions in the Region inspector.

Some audio region parameters are different for standard audio regions than for Apple Loops. 
The Fade and Gain parameters are available for standard audio regions but not for Apple Loops, 
and the Transposition and Follow Tempo parameters are available for Apple Loops, but not for 
standard audio regions.

•• Gain: Adjusts the volume of individual audio regions by the chosen amount.

•• Fade In/Speed Up: Use to switch between Fade In and Speed Up parameters, where you apply 
fade values for volume and playback, respectively.

•• Curve: Adjusts the fade-in curve shape.

•• Fade/Slow Down: Use to switch between Fade Out and Slow Down parameters, where you 
apply fade values for volume and playback, respectively.

•• Curve: Adjusts the fade-out curve shape.

•• Transposition: Adjusts the pitch of the Apple Loops up or down by the chosen amount.

•• Follow Tempo: This parameter (on by default) allows Apple Loops to follow the project tempo.
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MIDI region parameters
The following parameters are available for MIDI regions (and software instrument Apple Loops) 
in the Region inspector.

The MIDI region parameters also apply to folders, and globally affect all MIDI regions within 
the folder.

•• Transposition: All note events contained in the MIDI region are transposed up or down by the 
selected amount during playback. Even complete folders can be instantly transposed in this 
way. If several individual MIDI regions within the folder have already been transposed, the 
relative differences between them are retained.

If you want to transpose by octaves, click the arrows to the right of the Transposition 
parameter. A pop-up menu opens that allows direct octave transpositions.

To guard against drum notes and so on being transposed, an instrument channel’s inspector 
contains a No Transpose checkbox. If you select this option, the Transpose parameter is 
ignored in all MIDI regions played by this channel strip (including instrument Apple Loops 
added to tracks routed to instrument channels).

•• Velocity: All notes in the relevant MIDI region are offset by the selected value. Positive values 
add to the originally recorded velocity, and negative ones subtract from it, although naturally 
it is impossible to go outside the limits defined by the MIDI Standard (0–127). If you select a 
velocity offset that exceeds the maximum or minimum possible value for a particular note, 
that note will play at the extreme possible range. For example, a setting of +20 will cause a 
note with a velocity of 120 to play at 127.

•• Dynamics: This parameter also affects the velocity values of notes, but instead of adding or 
subtracting a fixed amount, the differences between soft and loud notes (the dynamics) are 
increased or decreased. This works in a similar way to a compressor or expander. Values above 
100% expand the dynamics, thereby increasing the difference between loud and soft, while 
values below 100% compress the dynamics, reducing the differences between loud and soft.

The Fixed setting causes all notes to be transmitted at a velocity value of 64. When used 
in conjunction with the Velocity parameter (see above), it’s possible to set any fixed 
velocity value.

•• Gate Time: The term gate time stems from analog synthesizers, and refers to the time between 
pressing and releasing a key. This parameter affects the absolute note duration or length, 
which can be different from the musical note value. The practical effect is to make notes in the 
region more staccato or legato. The parameter range is related to the original note lengths. 
Fix produces extreme staccato. Values below 100% shorten the notes. Values above 100% 
lengthen the notes. The “legato” setting produces a completely legato effect for all notes, no 
matter what their original lengths, eliminating all space between notes in the affected region.

•• Clip Length: This function lets you alter the length of the last notes in a region directly from the 
Tracks area, by adjusting the length of the MIDI region. When turned on, any notes sounding 
when the region ends are abruptly cut off. When turned off, notes are played to their normal 
end point, regardless of where the region ends.

•• Score: The point of this function is mainly to prevent the score display of particular regions—
namely those that only contain MIDI events that can’t be displayed in the score, such as 
controller or SysEx data. When turned off, the MIDI region is not displayed in the score at all.

•• Advanced Quantization: Q-Flam: Notes with the same time position (chords) are spread out 
by this parameter. Positive values produce an ascending (upward) arpeggio; negative values 
a descending (downward) arpeggio. The position of the first note (either the bottom or top 
note, assuming all notes start at the same position) in the arpeggio is unaltered.
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•• Advanced Quantization: Q-Velocity: This parameter (expressed as a percentage) determines 
the amount that the velocity values of quantized notes are affected by the velocity values 
of a template MIDI region. At a value of 0%, the notes retain their original velocity. At 100%, 
they adopt the velocity values of the template. Negative values alter the velocity, making the 
deviation from the template even greater.

•• Advanced Quantization: Q-Length: This parameter (also expressed as a percentage value) 
determines how the lengths of quantized notes are affected by the equivalent note lengths 
(notes at the same position) of a template MIDI region. A value of 0% has no effect, while at 
100%, the notes adopt the exact note lengths of the template region. Negative values alter 
note lengths further, resulting in a more significant deviation from the template.

Normalize MIDI region parameters
You can normalize the MIDI region parameter settings of all selected MIDI regions and folders 
with the MIDI > Region Parameters > Normalize Region Parameters command. 

This means that all settings are actually written as data, and playback parameters revert to 
normal values. The audible result remains the same. The Loop parameter and extended MIDI 
region parameters are not affected. Use of this function is effectively like saying “make these 
MIDI region/instrument parameter values permanent.” In most circumstances, it’s better not to 
do this, as leaving the original data untouched provides more flexibility. This includes unlimited 
opportunities to change your mind about MIDI region edits.

Normalize and MIDI channels
Like the Merge function and the Glue tool, the Normalize function is intelligent in the way it 
handles stored MIDI channel numbers. If all stored events have the same MIDI channel number, 
the channel is changed to that of the instrument assigned to the current track. If the events are 
on different channels, Logic Pro asks whether or not you want to convert the event channels.

The following Normalize options are also available in the MIDI > Region Parameters menu:

•• Normalize without Channel: Leaves the stored channel number untouched.

•• Normalize without Channel & Delay: Leaves the stored channel number and Delay 
parameters untouched.

If the playback instrument has a channel setting of All, or you’re dealing with a completely 
different type of Environment object (a channel splitter used as A-Playback, for example), the 
stored MIDI channel numbers are also unaffected by the usual Normalize function.

Note:  If you’re editing MIDI regions that appear as notation on a polyphonic staff style, it’s 
recommended that you use the Normalize without Channel function, as the event channel is 
used to assign notes to individual polyphonic voices in the Score Editor.
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Audio Track Editor overview
The Audio Track Editor shows a close-up view of part of an audio track in the Tracks area, 
displaying the audio waveform of the regions on the track in a time grid.

In the Audio Track Editor, you can move and trim audio regions, split and join them, and edit 
them in other ways. You can scroll and zoom the Audio Track Editor, and zoom the amplitude of 
the waveforms in audio regions. Edits you make in the Audio Track Editor are nondestructive, so 
you can always return to your original recordings.

You can also quantize and edit the pitch of audio material in the Audio Track Editor using Flex 
Pitch. For more information, see Edit the pitch of audio in the Audio Track Editor. 

  When Show Advanced Tools is selected in the Advanced preferences pane, you can edit the 
timing of audio material in the Audio Track Editor using Flex Time. For more information, see Flex 
Time and Pitch overview and Quantize the timing of audio regions in the Audio Track Editor.

Open the Audio Track Editor
Do one of the following:

mm Select an audio track in the Tracks area, then click the Editors button .

mm Select an audio track in the Tracks area, then choose View > Show Editors.

mm Double-click an audio region to open it in the Audio Track Editor.

The Audio Track Editor opens below the Tracks area. Along the top of the Audio Track Editor is 
a ruler showing time divisions, and a menu bar with local menus, tools, and other controls. The 
main area of the Audio Track Editor shows the audio waveform of the regions in the selected 
audio track.

Vertically resize the Audio Track Editor
mm Place the pointer in the bar at the top of the Audio Track Editor, and drag upward.

Drag downward to make the Audio Track Editor smaller again.

Edit audio regions in the 
Audio Track Editor 11
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Zoom the Audio Track Editor horizontally
mm Drag the zoom slider in the Audio Track Editor menu bar left or right.

Zoom audio waveforms
mm Click-hold the Waveform Zoom button in the Audio Track Editor menu bar, then drag the slider 

vertically to zoom the amplitude in or out.

Close the Audio Track Editor
mm Click the Editors button in the control bar.

Select audio regions in the Audio Track Editor
You can select one or more regions in the Audio Track Editor, and select regions meeting 
certain criteria.

Select a region
mm Click a region in the Audio Track Editor.

Select multiple regions
Do one of the following:

mm Hold down Shift as you click the regions.

mm Drag across the regions.

Select the previous or next region on the track
Do one of the following:

mm To select the previous region: Choose Edit > Select > Select Previous Region.

mm To select the next region: Choose Edit > Select > Select Next Region.

Select all following regions on the track
mm Choose Edit > Select > All Following of Same Track.

Select all regions on the track
mm Click the track header in the Tracks area.

Cut, copy, and paste audio regions in the Audio Track Editor
You can cut or copy an audio region or region segment in the Audio Track Editor and paste the 
copy at a different time position.

Cut an audio region
mm Select the region, then choose Edit > Cut (or press Delete).

Copy an audio region
Do one of the following:

mm Option-drag the region.

When you Option-drag an audio region so that it overlaps another region, the overlapped part of 
the region is cut.

mm Select the region, then choose Edit > Copy.

Paste an audio region
mm Place the playhead at the point where you want to paste the region, then choose Edit > Paste.
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Move audio regions in the Audio Track Editor
You can move an audio region or region segment in the Audio Track Editor so that it plays back 
in a different time position.

Move an audio region
mm Drag the region horizontally.

When you move an audio region so that it overlaps another region, the overlapped part of the 
region is cut.

Trim audio regions in the Audio Track Editor
You can trim an audio region in the Audio Track Editor to remove part of the beginning or end of 
the region. 

Trim an audio region
	 1	 Place the pointer over the lower-left or lower-right edge of the region.

The pointer changes to a trim pointer.

	 2	 Drag the pointer to remove the part you want to trim. As you drag, the help tag shows the 
region length and the amount by which it is trimmed.
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Split and join audio regions in the Audio Track Editor
You can split an audio region into segments in the Audio Track Editor, and move the segments so 
that they play back at a different point in time. 

You can also join regions or region segments from audio recordings into a single region. Regions 
from audio Apple Loops, and audio regions that have been transposed can’t be joined. 

To be joined, audio regions must be adjacent to each other on the same track. If you join 
segments of compressed audio files, the files are converted, by default, to PCM format (the file 
type is set in the Audio > General preferences pane).

Split an audio region
mm Select the Scissors tool, then click the point where you want to split the region.

You can scrub regions to find the point where you want to cut by dragging across the regions 
with the Scissors tool. You can also split regions by selecting them in the Tracks area, then 
selecting Edit > Split > Regions at Playhead.

Before moving or deleting a segment of a split audio region, click the region to select it.

Join regions or region segments
	 1	 Select the regions or region segments.

	 2	 Do one of the following:

•• Choose Edit > Join > Regions.

•• Select the Glue tool, then Shift-click the selected regions.

Snap edits to zero crossings in the Audio Track Editor
  When Show Advanced Tools is selected in the Advanced preferences pane, you can snap 

edits you make in the Audio Track Editor to zero crossings. Making edits, such as trimming 
or splitting audio regions, snap to zero crossings helps ensure that no “click” or other noise is 
produced at the edit position.

Set edits to snap to zero crossings
mm Choose Edit > Snap Edits to Zero Crossings from the Audio Track Editor menu bar.
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Delete audio regions in the Audio Track Editor
You can delete audio regions in the Audio Track Editor. When you delete a region, it's also 
deleted from the Tracks area, and from the project (but not from the Project Audio Browser).

Delete an audio region
	 1	 Select the region or regions you want to delete in the Audio Track Editor.

	 2	 Choose Edit > Delete (or press Delete).
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Piano Roll Editor overview
The Piano Roll Editor shows the notes in a MIDI region as colored bars in a time grid. Horizontal 
lines show the time position, while vertical lines indicate pitch. A keyboard along the left edge of 
the Piano Roll Editor provides a reference for the pitches of notes. The info display in the Piano 
Roll Editor menu bar shows the note name and time position under the pointer.

The Piano Roll Editor can display the MIDI regions on a track, in a folder, or on multiple tracks in 
the project. (See View multiple MIDI regions in the Piano Roll Editor on page 361.)

MIDI note event

You can open the Piano Roll Editor as a pane in the main window, or as a separate, 
resizable window.

Open the Piano Roll Editor 
Do one of the following:

mm Select a software instrument (or external MIDI instrument) track or a MIDI region, then click the 
Editors button .

mm Select a software instrument (or external MIDI instrument) track or a MIDI region, then choose 
View > Show Editors.

mm Double-click a MIDI region (if Piano Roll is chosen from the Logic Pro > Preferences > General > 
Editing > Double-Clicking a MIDI Region Opens pop-up menu).

The Piano Roll Editor opens below the Tracks area. On the left are controls for quantizing the 
timing and pitch of MIDI regions, adjusting their pitch, and editing the velocity of MIDI notes. 
Along the top of the Piano Roll Editor is a ruler showing time divisions, and a menu bar with 
local menus, tools, and other controls. The header shows the name of the selected region (or the 
number of regions, if more than one is selected).

Edit MIDI regions in the 
Piano Roll Editor 12
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Open the Piano Roll Editor as a separate window
Do one of the following:

mm Choose Window > Open Piano Roll, or use the Open Piano Roll key command (Command-6).

mm Drag the Piano Roll Editor by its title out of the main window.

Vertically resize the Piano Roll Editor
mm Place the pointer in the bar at the top of the editor, then drag upward.

Drag downward to make the editor smaller again.

Hide or show the local Piano Roll Editor inspector
mm To hide the Piano Roll Editor inspector: Choose Hide Local Inspector from the Piano Roll Editor 

View menu.

mm To show the Piano Roll Editor inspector: Choose Show Local inspector from the Piano Roll Editor 
View menu.

Close the Piano Roll Editor
mm Click the Editors button .
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Add and edit notes in the Piano Roll Editor

Add notes in the Piano Roll Editor
You can add notes with the pointer in the Piano Roll Editor, to replace a deleted note or to add 
a note to a chord or region. You can also add notes with your computer keyboard. For more 
information, see Use step input recording techniques.

Tip:  The info display in the Piano Roll Editor menu bar shows the note name and time position 
under the pointer. Watch the info display as you add notes with the pointer to ensure that you 
add them at the correct position.

Add a note
Do one of the following:

mm Control-click the Piano Roll Editor background, then choose Create Note from the shortcut menu.

mm Select the Pencil tool, then click the start position for the note.

The newly created note’s length, velocity, and channel match that of the previously created or 
edited note event. When you start a new project, the default values are a length of 240 ticks, a 
velocity of 80, and MIDI channel 1.

Note:  When you create a note using the Pencil tool, you can edit the length of notes on the fly. 
Simply hold down the mouse button and drag left or right.

Add a note of a specific length
mm Select the Pencil tool, click the start position for the note, then drag right or left.

A help tag shows the length change in real time.

Finer adjustments can be made by holding down Option or Control while altering the note 
length (see Snap items to the Piano Roll Editor grid on page 349).

Duplicate an existing note at another position or pitch
	 1	 Do one of the following:

•• Control-click the original note, then choose Define as Default Note from the shortcut menu.

•• Click the original note with the Pencil tool.

Note:  Editing an existing note also defines it as the default note.

	 2	 Click a position in the Piano Roll Editor background with the Pencil tool.

The new note’s length, velocity, and channel are the same as the default note.
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Select notes in the Piano Roll Editor
You must select note events before you can edit them. You can select notes by clicking, Shift-
clicking, dragging to make a marquee selection, and using the keyboard at the left edge of the 
Piano Roll Editor.

Select a note
mm Click the note.

Select a range of notes
mm Shift-click the notes, or drag to enclose them. 

The Piano Roll Editor header shows the number of selected notes, along with the region name. 
When multiple overlapping notes are selected, the Piano Roll Editor header shows the chord 
name. When no notes are selected, the header shows the name of the most recently selected 
MIDI region, or the number of regions selected.

Select all notes of the same pitch in a MIDI region
mm Click the key on the keyboard at the left edge of the Piano Roll Editor.

To select all notes for a range of pitches, Shift-click or drag over a range of keys on the keyboard. 

This is similar to selecting all regions on a track by clicking the track name.

Select a region
mm Click a region in the Piano Roll Editor.

Select multiple regions
Do one of the following:

mm Hold down Shift as you click the regions.

mm Drag across the regions.

Select the previous or next event in the region
Do one of the following:

mm To select the previous event: Choose Edit > Select > Previous Event.

mm To select the next event: Choose Edit > Select > Next Event.

Select all following events on the track
mm Choose Edit > Select > All Following.

Select all regions on the track
mm Click the track header in the Tracks area.
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Snap items to the Piano Roll Editor grid
The Piano Roll Editor has a grid, similar to the Tracks area grid.   When Show Advanced Tools 
is selected in the Advanced preferences pane, you can set the Snap value for the Piano Roll grid, 
independent from the Snap value for the Tracks area grid.

The Snap pop-up menu setting applies to moving, copying, cutting, and resizing note events; 
moving, adding, and resizing markers; and setting the cycle area. You can snap notes and other 
items using either relative or absolute positioning, and can temporarily override the snap grid, 
allowing finer edits and adjustments.

Set the Snap value for the Piano Roll Editor grid
mm Choose a value from the Snap pop-up menu in the Piano Roll Editor menu bar:

•• Smart: Edit operations snap to the nearest bar, beat, sub-beat, and so on, depending on the 
current ruler division value and the zoom level.

•• Bar: Edit operations snap to the nearest bar.

•• Beat: Edit operations snap to the nearest beat in a bar.

•• Division: Edit operations snap to the nearest division (this is the time signature shown in the 
LCD and ruler).

•• Ticks: Edit operations snap to the nearest clock tick (1/3840 of a beat).

•• Frames: Edit operations snap to the nearest SMPTE frame.

By default, the Snap functionality is relative, so that when you move notes or other items, they 
retain their relative distance from their original position. You can override relative positioning 
with the Snap to Absolute Value option.

Snap to an absolute position
mm Choose Snap to Absolute Value from the Snap pop-up menu. 

When Snap to Absolute Value is active, moving an event moves it to the exact grid position, not 
a relative position. For example, from position 1.2.1.16 to around bar 2 results in it being snapped 
to the beginning of the bar (position 2.1.1.1), rather than its relative position (2.2.1.16). Absolute 
positioning is useful when you want notes to fall exactly on the beat, but it can result in a more 
mechanical rhythmic feel.moving an event 
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Override the snap grid
Do one of the following:

mm Hold down Control while performing the editing operation.

The division value chosen in the LCD (1/16, for example) determines the editing grid scale.

mm Hold down Control-Shift while performing the editing operation.

The editing grid switches to ticks.

For more information about snapping items to the grid, see Snap items to the grid.

Move notes in the Piano Roll Editor
You can move selected notes in the Piano Roll Editor to change their time position. When you 
move notes, they move according to the current Snap value for the Piano Roll Editor.

When you drag a note, a help tag shows its current time position and pitch. Its deviation from 
the starting pitch is shown as a positive or negative value.

You can also move notes using an Event Float window. For information, see Event Float window.

Tip:  The info display in the Piano Roll Editor menu bar shows the note name and time position 
under the pointer. Watch the info display as you move notes to ensure that you move them to 
the correct position.

Move notes 
mm Select one or more notes, then drag left or right.

Move notes in finer increments
	 1	 Select the notes.

	 2	 Hold down Control, then drag the notes to the new position. 

The drag resolution depends on the current Snap value and zoom level (see Snap items to the 
Piano Roll Editor grid on page 349).

Alternatively, you can press Control-Shift as you drag to move the notes in tick steps, overriding 
the Snap value.

Limit dragging to one direction
	 1	 Choose Logic Pro > Preferences > General (or use the Open General Preferences key command).

	 2	 Click the Editing tab, then select the Limit Dragging to One Direction In Piano Roll and 
Score checkbox.
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This option helps you avoid accidentally transposing notes when moving them horizontally, 
or changing their time position when moving them vertically. The initial direction—vertical or 
horizontal—restricts movement to this plane while the mouse button is pressed. Release the 
mouse button and click the event to move in the other direction.

Move notes using key commands
Use any of the following key commands:

mm Nudge Region/Event Position Right by SMPTE Frame

mm Nudge Region/Event Position Left by SMPTE Frame

mm Nudge Region/Event Position Right by 1/2 SMPTE Frame

mm Nudge Region/Event Position Left by 1/2 SMPTE Frame

mm Nudge Region/Event Position Right by 5 SMPTE Frames

mm Nudge Region/Event Position Left by 5 SMPTE Frames

mm Nudge Region/Event Position Right by SMPTE Bit

mm Nudge Region/Event Position Left by SMPTE Bit

mm Nudge Region/Event Position Right by Tick

mm Nudge Region/Event Position Left by Tick

mm Nudge Region/Event Position Right by Division

mm Nudge Region/Event Position Left by Division

mm Nudge Region/Event Position Right by Beat

mm Nudge Region/Event Position Left by Beat

mm Nudge Region/Event Position Right by Bar

mm Nudge Region/Event Position Left by Bar

mm Nudge Region/Event Position Right by Nudge Value

mm Nudge Region/Event Position Left by Nudge Value

mm Nudge Region/Event Position Right by Sample

mm Nudge Region/Event Position Left by Sample

mm Nudge Region/Event Position Right by 1 ms

mm Nudge Region/Event Position Left by 1 ms

mm Nudge Region/Event Position Right by 10 ms

mm Nudge Region/Event Position Left by 10 ms

The selected events are shifted one step right or left, by the unit defined in the particular 
key command.

Move other MIDI data along with notes
mm Choose the Include Non-Note MIDI Events setting from the Piano Roll Editor Functions menu to 

tie other data (such as pitch-bend, modulation, aftertouch, or poly pressure) in a region to the 
region’s notes.
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Copy notes in the Piano Roll Editor
There are a number of ways to copy or move notes in the Piano Roll Editor. In addition to Option-
dragging or using the Copy and Paste menu commands, there are advanced Copy and Move 
operations such as directly swapping events, or merging a group of notes from one section of a 
region to the same region, or another region.

Copy notes
Do one of the following:

mm Option-drag notes to a new position.

Tip:  You can Option-drag notes between two Piano Roll Editor windows (showing different 
regions, for example), or even between the Piano Roll Editor windows of different projects.

mm Use any of the following Clipboard commands:

•• Edit > Cut (or Command-X) to move notes into the Clipboard.

•• Edit > Copy (or Command-C) to copy notes into the Clipboard.

•• Edit > Paste (or Command-V) to paste notes at the current playhead position, at their 
original pitch.

Copy or move a range of MIDI events
	 1	 Define the area that you want to move or copy using the left and right locators. 

	 2	 If you want to copy or move the events to another track, select the track you want to copy the 
events to.

	 3	 Set the playhead to the insert position.

	 4	 Choose Functions > Copy MIDI Events.

	 5	 In the Copy MIDI Events dialog, choose settings, then click OK.

•• Mode pop-up menu: Choose one of the following options:

•• Copy Merge: The copied data is blended with any data present at the destination position.

•• Copy Replace: The data at the destination position is deleted, and replaced with the 
copied data.

•• Copy Insert: All data at the destination position is moved to the right, by the length of the 
source area.

•• Move Merge, Move Replace, Move Insert: These three modes work similarly to the Copy modes, 
but actually move the selected events, removing them from their original positions. 
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•• Rotate: The source events are moved to the destination position. The data that was 
previously at the destination position, and the data that falls between the source and 
destination positions, are all moved toward the source position. This rotates the data around 
a central pivot point (halfway between the source and destination positions).

•• Direct Swap: Exchanges the source data with data of the same length, starting at the target 
position. This allows you to swap the notes in bar 1 of a four-bar MIDI region with the notes 
in bar 3 of the same region, for example.

•• Remove: Removes the MIDI data from the source region, but leaves the region at its original 
position. 

•• Left Locator and Right Locator: Allow you to edit the source area you defined with the left and 
right locators.

•• Destination: Defines the destination position independently of the playhead position.

•• Number of Copies: Defines the number of copies.

•• Create new Region: When selected, a new MIDI region is created at the destination position. It 
contains the copied (or moved) events.

Change the pitch of notes in the Piano Roll Editor
You can change the pitch of selected notes in the Piano Roll Editor. Changing the pitch lets you 
transpose parts to a different key or harmonize a melodic line.

When you drag a note, its current position and pitch are shown in a help tag. The deviation from 
the starting pitch is shown in semitone steps at the bottom left of the help tag. The starting 
pitch appears in the info display of the Piano Roll Editor.

Change the pitch of notes
mm Drag notes up or down to a new pitch.

You can use the keyboard at the left edge of the Piano Roll Editor as a guide when 
dragging notes.
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Resize notes in the Piano Roll Editor
You can resize notes in the Piano Roll Editor to change their length (duration). Notes can be 
resized from either their start or end point using the Pointer, Finger, or Pencil tool.

There are a number of commands in the Edit > Trim submenu in the Piano Roll Editor menu bar 
to change the length of selected notes, in relation to notes surrounding or overlapping them. 
They can be very useful for tidying up the start and end points of notes.

Resize a note
mm Drag either the left or right edge of the note horizontally, using the Pointer, Finger, or Pencil tool.

A help tag appears while you drag, showing the length of the note.

Tip:  It can sometimes be difficult to grab the edge of very short notes. You can use the Finger 
tool, which allows you to grab notes anywhere to alter their length, or zoom in for a closer view. 

Resize multiple notes
mm Select the notes, then drag either edge of one of the selected notes.

The relative differences between the lengths of the selected notes are maintained.

Set the same end point for selected notes
mm Hold down Shift while altering the length of one of the selected notes. 

Make selected notes the same length
mm Hold down Option-Shift while dragging one of several selected notes.

Set the start or end point of notes to the playhead position
Use one of the following key commands:

mm Set Region/Event/Marquee Start to Playhead Position 

mm Set Region/Event/Marquee End to Playhead Position 

Remove note overlaps
	 1	 Select the notes you want to edit.

	 2	 Choose one of the following commands in the Edit > Trim submenu in the Piano Roll Editor 
menu bar:

•• Note to Remove Overlaps with Selected

•• Note to Remove Overlaps with Adjacent

•• Note to Remove Overlaps with Repeated
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Make notes legato
	 1	 Select the notes you want to edit.

	 2	 Choose one of the following commands in the Edit > Trim submenu in the Piano Roll Editor 
menu bar:

•• Note Start to Playhead

•• Note End to Playhead

•• Note End to Selected Notes

•• Note End to Following Notes

Convert sustain pedal events to note lengths
mm Choose Functions > Convert Sustain Pedal to Note Length in the Piano Roll Editor menu bar. 

All sustain pedal events (controller #64) used on selected note events are analyzed, and the note 
events are actually increased in length. This increase matches the controller #64 (sustain pedal) 
off message position. 

The pedal events (controller #64 on and off) are erased after use of this command.
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Edit note velocity in the Piano Roll Editor
Each note in the Piano Roll Editor displays a horizontal line. The length of the line relative 
to the overall length of the note shows the note’s velocity. Velocity indicates how hard the 
key was struck when the note was played, which usually corresponds to the note’s loudness 
(the MIDI velocity range is from 0–127, with 127 being the loudest). Velocity can also control 
other synthesizer parameters, such as filter resonance or cutoff, alone or in conjunction with 
volume level.

You can also display velocity using different colors, by choosing View > Set Note Color > By 
Velocity from the Piano Roll Editor menu bar. When this command is chosen, higher velocity 
notes appear in warmer colors, and lower velocity notes appear in cooler colors.

Low velocityHigh velocity

Color coding makes it easy to see the velocity of individual notes, and to see the overall range 
of velocities in a MIDI region. As you change the velocity of the notes, their color changes in 
real time.

For more information about color assignments in the Piano Roll Editor, see Change the color of 
notes in the Piano Roll Editor on page 359.

Edit the velocity of notes
Do one of the following:

mm Select one or more notes, then drag the Velocity slider in the Piano Roll Editor header left 
or right.

mm Drag over a note vertically with the Velocity tool.

A help tag showing the note velocity updates as you drag. The line inside the note also updates 
to show the velocity change.

If the MIDI Out button in the Piano Roll Editor menu bar is active, the note sounds as you drag.

When you edit the velocity of multiple notes, the relative differences in their velocity values are 
retained. If the velocity value of any of the selected notes reaches the minimum or maximum 
value (0 or 127), none of the notes can be adjusted further.

You can override this behavior by holding down Option while dragging. This allows you to 
continue altering the velocity values until the selected note reaches the minimum or maximum 
value. By overriding, the velocity relationship of this note to the other notes is altered.

Assign the same velocity value to selected notes
mm Hold down Option-Shift while dragging one of the notes with the Velocity tool.
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Quantize the timing of notes in the Piano Roll Editor
You can quantize, or automatically correct, the timing of individual MIDI notes in the Piano Roll 
Editor. This is useful when regions in the track contain the right notes, but are not perfectly in 
time with the project. When you quantize the timing, items are adjusted to the selected note 
value. You can quantize the timing of regions with drums, single-note instruments, and chordal 
or polyphonic instruments.

The Time Quantize controls quantize notes and other items nondestructively, for playback only. 
The original timing is never lost, and can be recalled by setting the value to off.

Quantize the timing of notes in a MIDI region
	 1	 Double-click a region in the software instrument track that you want to quantize to open it in 

the Piano Roll Editor.

	 2	 Select the regions you want to quantize, or select individual notes you want to quantize in 
a region.

	 3	 From the Time Quantize pop-up menu, choose the note value you want to use to quantize the 
timing of the selected items.

	 4	 To set the degree of quantization, drag the Strength slider left or right.

	 5	 To set the degree of swing, drag the Swing slider left or right.

Quantize note timing with the Quantize tool
	 1	 Click-hold a note, or a selected group of notes, with the Quantize tool to open the Quantize 

shortcut menu.

	 2	 Choose a quantization value.

Select and quantize multiple notes
mm Drag across notes with the Quantize tool to select them.

The selected notes are quantized using the most recently selected (or active) Quantize value.

You can also quantize MIDI regions in the Region inspector. For information, see Shared region 
parameters, Quantize parameter values, and Advanced quantization parameters.
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Quantize the pitch of notes in the Piano Roll Editor
You can quantize the pitch of notes in MIDI regions to a particular scale or key. This is especially 
useful when you want to reuse a repeating pattern of notes, but transpose them to a 
different key.

Quantize the pitch of notes in a MIDI region
	 1	 Select the notes you want to quantize.

	 2	 Choose the scale and key from the Scale Quantize pop-up menus.

For more information about Flex editing, see Flex Time and Pitch overview.

Lock the position of events in the Piano Roll Editor
Sometimes you may want to protect some events in MIDI regions from being moved; for 
example, when they are synchronized to visual events in a movie. You may have already created 
the music for the scene, but are then asked to increase the tempo to match several cuts of 
different camera angles in the corridor. Changing the tempo will move the events, resulting in 
their being out-of-sync. Instead, you can lock the events to an absolute (SMPTE) time position, to 
protect their position and keep them in sync with the tempo.

  To lock the time position of events, Advanced Editing Options must first be selected in the 
Advanced preferences pane.

Lock the position of one or more selected events
mm Choose Functions > Lock SMPTE Position in the Piano Roll Editor menu bar (or use the 

corresponding key command).

This command ensures that events that fall at a particular absolute time position—1 hour, 
3 minutes, 15 seconds, 12 frames, for example—remain at this exact position regardless of 
tempo changes.

Unprotect protected events
mm Choose Functions > Unlock SMPTE Position in the Piano Roll Editor menu bar (or use the 

corresponding key command).
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Mute notes in the Piano Roll Editor
You can mute individual notes in the Piano Roll Editor, letting you experiment with different note 
choices in a melody, or different chord voicings, for example.

Mute or unmute notes
Do one of the following:

mm Click one or more notes with the Mute tool.

mm Select the notes, then click one of the selected notes with the Mute tool.

Muted notes are shown without color.

The Select Muted Regions/Events key command is also available in the Piano Roll Editor. You can 
use it to select all muted notes in a MIDI region.

Mute or unmute all notes of a particular pitch
mm Click a piano key in the keyboard at the left of the Piano Roll Editor with the Mute tool.

This action mutes or unmutes all notes of the clicked pitch in the MIDI region, and is useful 
for muting the hi-hats in a MIDI region that is triggering an entire drum kit, for example. For 
information about assigning tools, see Assign tools.

Change the color of notes in the Piano Roll Editor
You can change the color of notes in the Piano Roll Editor to display note velocity, region colors, 
or MIDI channel colors. By default, notes correspond to the region color.

Change the color of notes
Do one of the following:

mm Choose View > Set Note Color in the Piano Roll Editor menu bar, then choose an option from 
the submenu.

•• Velocity Colors: Colors notes to show their MIDI note velocity.

•• Region Colors: Colors notes to correspond with the MIDI region.

•• MIDI Channel Colors: Colors notes to correspond with the MIDI channel.

mm Control-click the Piano Roll Editor background, then choose a color assignment from the 
shortcut menu.
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Delete notes in the Piano Roll Editor
You can delete notes from MIDI regions, and delete notes meeting certain criteria.

Delete one or more notes
Do one of the following:

mm Select the notes, then press Delete.

mm Select the notes, then click one of the selected notes with the Eraser tool. 

mm Select the Eraser tool, then click the notes you want to delete. 

Delete similar or equal events
	 1	 Select one of the notes you want to delete.

	 2	 Choose Edit > Select > Select Similar Events or Edit > Select > Select Equal Events (notes of the 
same pitch, for example) from the Piano Roll Editor menu bar, then delete the selected events by 
pressing Delete.

You can also delete events by choosing Edit > Delete MIDI Events from the Piano Roll Editor 
menu bar, then choosing an option from the submenu.

Delete doubled events
mm Choose Edit > Delete MIDI Events > Duplicates from the Piano Roll Editor menu bar, or use the 

Delete Duplicated Events key command (D).

Any events occurring twice or more at the same position (and pitch) are deleted, allowing one 
to remain. This is true regardless of whether the duplicates have different velocity, aftertouch, or 
controller values. Events on different MIDI channels are not considered duplicates.

The “same time position” includes two notes that are output simultaneously because of the 
current quantization setting.

Delete events inside or outside the locators
	 1	 Set the left and right locator positions.

	 2	 Choose one of the following from the Piano Roll Editor menu bar:

•• Functions > Delete MIDI Events > Inside Locators

•• Functions > Delete MIDI Events > Outside Locators

When copying events or reducing the length of MIDI regions, events can sometimes end up 
outside the limits of a MIDI region. These technically still belong to the MIDI region, although 
they won’t be played or heard. 

Delete events outside the MIDI region
mm Choose Edit > Delete MIDI Events > Outside Region Borders from the Piano Roll Editor menu bar.

Delete unselected events within the selection
mm Choose Edit > Delete MIDI Events > Unselected Within Selection from the Piano Roll Editor 

menu bar.

All unselected notes between the start of the first selected note and the end of the last selected 
note are deleted.
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Delete all selected events and select the next one
	 1	 Select the event you want to delete. 

	 2	 Use the Delete and Select Next Region/Event key command. 

View multiple MIDI regions in the Piano Roll Editor
You can view the contents of several selected MIDI regions, all MIDI regions in a folder, or all MIDI 
regions in a project using Link modes.

When multiple MIDI regions are displayed in the Piano Roll Editor, you can freely select note 
events from different MIDI regions, and edit them. A help tag indicates the number of selected 
events and their parent MIDI regions. For example, 8/2 means that eight notes are selected from 
two MIDI regions.

View the contents of multiple MIDI regions
mm Shift-click multiple MIDI regions in the Tracks area.

Notes from all of the selected regions appear in the Piano Roll Editor. The start point of each MIDI 
region is indicated by a vertical line of the same color as the MIDI region itself.

Display the parent MIDI region of a note
mm Double-click a note event to display the contents of its parent MIDI region (the region that 

contains the note). 
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Split chords in the Piano Roll Editor
The following functions let you divide chords by pitch and assign notes to different MIDI channel 
by pitch.

Select the top or bottom note of selected chords
Do one of the following:

mm Choose Edit > Select > Highest Notes from the Piano Roll Editor menu bar to select the highest 
notes in the chords.

mm Choose Edit > Select > Lowest Notes to select the lowest notes in the chords. 

These commands can be useful for separating a melody from its accompanying chords, or 
separating a bass line, for example. Once separated, the lowest notes can be cut and pasted into 
a region on a different track.

Note:  Highest Notes and Lowest Notes only select the notes, so they can be used in conjunction 
with any of the editing commands, such as Cut, to move a voice into another MIDI region. 

Assign notes to different MIDI channels by pitch
	 1	 Select the notes you want to reassign by clicking keys on the keyboard along the left edge of the 

Piano Roll Editor. 

•• Shift-click to select multiple keys.

•• Drag across the keyboard to select a range of contiguous pitches.

	 2	 Choose Functions > Set MIDI Channel to Voice Number from the Piano Roll Editor menu bar.

Logic Pro assigns MIDI channel numbers (in ascending order) to individual note pitches in the 
selected MIDI region. The highest note pitch in each chord is assigned as MIDI channel 1, the 
next note down in each chord channel 2, and so on. 

Note:  The use of these commands results in changes to the MIDI region, which will contain 
information spread across multiple MIDI channels, following the operation. 

After using the Set MIDI Channel to Voice Number function, you can create a new MIDI region for 
each note by using the Edit > Separate MIDI Events > By Event Channel menu command in the 
Tracks area. Each region created from this process can then be assigned to a different track (and 
channel), allowing different instruments to be assigned for each voice.
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Use MIDI Draw in the Piano Roll Editor
You can create and edit MIDI controller information directly in the Piano Roll Editor. Working 
with controller information can be easier when you can see the notes that will be affected. For 
information about using MIDI Draw, see Use MIDI Draw.

View and create controller events
	 1	 Open a MIDI Draw display in the Piano Roll Editor by doing one of the following:

•• Choose a MIDI Draw command from the View menu in the Piano Roll Editor menu bar.

•• Click the MIDI Draw button  at the lower-left corner of the Piano Roll Editor, then choose a 
MIDI controller from the Controller pop-up menu on the left. 

The selected controller type (volume, for example) is shown in a gray field below the Piano Roll 
Editor grid.

	 2	 Click at different points in the gray area to create MIDI Draw control points. 

A connecting line is automatically created between the control points.

Resize the MIDI Draw area
mm Grab and vertically move the dividing line that separates the MIDI Draw area from the Piano Roll 

Editor grid.

You can also perform MIDI Draw edits in the Step Editor. For information about working in the 
Step Editor, see Step Editor overview on page 422.
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Open the Event List or Score Editor from the Piano Roll Editor
The Piano Roll Editor provides quick access to the Event List and Score Editor. 

Quickly open the Event List
mm Double-click a note in the Piano Roll Editor. 

The Event List appears in the List Editors area to the right of the Tracks area. If it’s already open, 
the contents of the parent region (of the note selected in the Piano Roll Editor) are displayed.

Note:  If the Piano Roll Editor is displayed as a separate window, double-clicking an event opens a 
separate Event List window.

Quickly open the Score Editor
mm Option-double-click an event in the Piano Roll Editor.

The Score Editor opens in a new window. The Piano Roll Editor remains docked in the editing 
area of the Tracks area.
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Drummer overview
Drummer allows you to add a virtual drummer to your project, using a Drummer track. You can 
choose drummers from different genres—Alternative, Rock, Songwriter, and R&B. Each drummer 
comes with its own drum kit and a distinct playing style. You can change the drummer’s playing 
style in the Drummer Editor.

Note:  To edit Drummer regions in the Piano Roll Editor, Event List, or Step Editor, you first need to 
convert them to MIDI regions.

The Drummer Editor lets you choose between different presets, tweak the generated pattern 
using various settings, or have Drummer regions follow the rhythm of another track in 
the project.

You can further influence the sound of the drums by choosing patches in the Library, or by 
exchanging drums and editing the settings of individual kit pieces in Drum Kit Designer.

You can only have one Drummer track per project.

Drummer track Drummer regions

Drummer Editor

When you add a Drummer track to your project, a drummer and a default patch associated 
with that drummer is loaded. The default patch is based on a stereo mixdown of the full, multi-
miked drum kit mix. These patches are optimized for performance and recommended while 
using the Drummer Editor to compose and edit the drum performance. Once you’re happy 
with a drummer’s performance and want to fine-tune the actual drum kit mix, you can replace 
the stereo mixdown with the original producer patch (Producer Kit), offering full access to all 
mix options.

Add a Drummer track
	 1	 Do one of the following:

•• Choose Track > New Drummer Track. (If you use this method, you can skip steps 2 and 3.)

•• Choose Track > New Tracks (or press Option-Command-N).

•• Click the Add Tracks button  above the track headers.

Add a drummer to your project 13
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	 2	 In the New Tracks dialog, select the Drummer track.

	 3	 Click Create.

•• If the project does not have arrangement markers: A Drummer track containing two 8-bar 
regions is created. Two different presets associated with the drummer are loaded to the 
two regions.

•• If the project has arrangement markers: A Drummer track containing as many regions as there 
are arrangement markers is created. The length and name of the Drummer regions correspond 
to the existing arrangement markers.

Create an additional region on a Drummer track
mm Control-click an empty area of the Drummer track, then choose Create Drummer Region from 

the shortcut menu.

A new 8-bar region is created at the downbeat that precedes the clicked position. However, if 
an arrangement marker exists at this position, the region will match the length and name of 
the marker.

Fill the entire Drummer track with regions
mm Control-click an empty area of the Drummer track, then choose Populate with Drummer Regions 

from the shortcut menu.

The Drummer track is filled with regions up to the project end point. Gaps are filled with 8-bar 
regions as much as possible, without overwriting existing regions. Any gaps smaller than one bar 
will not be filled; the expectation is that such gaps were created for short pauses, for example. If 
an arrangement track exists, as many regions as there are arrangement markers are created, with 
the length and name of the regions corresponding to the markers.
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Work in the Drummer Editor

Drummer Editor overview
The content of Drummer regions can be edited in a dedicated Drummer Editor.

The left side of the Drummer Editor offers track-based settings. You can choose drum genres and 
drummers, whose sound and playing style are applied to all content on the Drummer track.

The right side of the editor offers region-based settings, which influence the complexity, 
loudness, and other aspects of selected Drummer regions. You can choose and create presets for 
Drummer regions. Presets offer a quick way to browse predefined, region-based Drummer Editor 
settings, including kit piece pattern variations and fill settings.

Note:  Drummer regions can be edited in the Tracks area in much the same way as you would 
edit MIDI regions, with the exception of region overlapping. When overlapping, Drummer regions 
always use the No Overlap drag mode.

Open the Drummer Editor
Do one of the following:

mm Double-click a Drummer region on a Drummer track.

mm Select one or more Drummer regions on a Drummer track, then click the Editors button  in 
the control bar.

mm Select a Drummer track, then click the Editors button .

The Drummer Editor opens below the Tracks area.
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Choose genres and drummers
Each genre comes with a number of drummers who have their own drum kit and distinct 
playing style.

When you add a Drummer track to the project, a default genre and drummer is loaded, along 
with a default patch associated with the drummer. You can change the genre and the drummer, 
with these changes influencing all regions on the track. If you change a drummer, a new patch 
is loaded, which means that the drum kit as well as the kit mix is replaced with that of the new 
drummer. However, it’s possible to choose a new drummer without loading a new patch, or to 
choose a new drummer without changing any region settings you have made on the track.

Note:  Some drummers are only available after you download additional content.

Choose a genre and drummer
	 1	 Choose a genre from the Genre pop-up menu.

You can choose between Rock, Alternative, Songwriter, and R&B.

The available drummers for the chosen genre appear.

	 2	 Click a drummer.
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A character card appears, showing a description of the drummer’s playing style, and the name of 
the predefined patch that is loaded.

	 3	 Do either of the following:

•• To choose another drummer: Click the drummer to return to the drummer overview page.

Click to choose another 
drummer.

Click to choose another 
genre.

•• To choose another genre: Choose a different genre from the Genre pop-up menu.

Choose a drummer without changing the current patch
mm Hold down Option while choosing a drummer.

Choose a drummer without changing region settings on the track
mm Choose Keep settings when changing drummers from the Action pop-up menu in the 

presets area.
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Choose drummer presets
After choosing a genre and drummer you can choose from a collection of drummer-specific 
presets in the Drummer Editor. Presets offer a quick way to browse predefined, region-based 
Drummer Editor settings, including kit piece pattern variations and fill settings. You can use the 
default settings, or you can edit them and save your own presets. User presets can be deleted, 
but factory presets cannot.

Whenever you choose a different preset, or edit settings for the current one, you can play back 
the selected region to hear the changes. You can also play back a subtly different version of the 
selected region without editing any the region settings.

Play the selected region using the current preset
mm Click the Play button in the ruler at the top of the editor.

Play button

Play a subtly different version of the selected region (without editing region settings)
Do one of the following:

mm In the Drummer Editor: Choose Refresh region from the Action pop-up menu in the presets area.

mm In the Tracks area: Control-click the Drummer region, then choose Edit > Refresh Region from the 
shortcut menu.
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Choose a different preset
mm Click a preset on the left side of the editor.

The region settings on the right side of the editor update to reflect the chosen preset and the 
selected region in the Tracks area is regenerated.

Save a modified user preset
mm Choose Save preset from the Action pop-up menu in the presets area, then enter a name for the 

user preset.

Delete a user preset
mm Choose Delete preset from the Action pop-up menu in the presets area.

Recall the default preset
mm Choose Recall default preset from the Action pop-up menu in the presets area.
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Edit the drummer’s performance
There are a number of settings in the Drummer Editor that affect the drummer’s playing style. 
These settings are located to the right of the presets area.

You can edit the complexity and loudness of the performance, mute and unmute drum kit 
pieces, and choose whether a pattern is played on the toms, cymbals, or hi-hat. The percussion 
icons can be used to turn on different instruments, and you can choose between different 
variations for the drum and percussion pieces. You also have the option to play half time or 
double time for kick and snare.

Adjust the complexity and loudness of a preset
mm Reposition the puck in the XY pad.

The farther right you place the puck, the more complex the sound becomes; the higher you 
place the puck, the louder the sound plays.

Choose a pattern variation for a drum or percussion instrument
Do any of the following:

mm For Tambourine, Shaker, and Handclap: Click an instrument, then drag the Percussion slider or 
choose an increment.
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mm For Cymbals, Toms, and Hi-Hat: Click a kit piece, then drag the kit piece slider or choose 
an increment.

mm For Kick and Snare: Drag the Kick & Snare slider or choose an increment.

Mute or unmute a drum or percussion instrument
Do either of the following:

mm To include the piece in the performance: Click the piece so that it’s selected, or unmuted.

Unmuted piece

Muted piece

mm To remove a piece from the performance: Click the piece so that it’s dimmed, or muted.

Use a half time or double time variation for kick and snare
mm Choose 1/2 or 2x at the right end of the Kick & Snare slider.

Edit other performance settings
Do any of the following:
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mm Drag the Fills knob downward to reduce, or upward to increase, the number and length of fills.

You can click the lock to prevent any changes to the fills setting when switching presets 
or drummers.

mm Drag the Swing knob vertically to adjust the shuffle feel of the currently playing pattern.

You can click the lock to prevent any changes to the swing setting when switching presets 
or drummers.

mm Click the Details button to reveal the following knobs:

•• Drag the Feel knob to the right to have the drummer play ahead of the beat or to the left to 
play behind the beat, or sloppy.

•• Drag the Ghost Notes knob to adjust the level of ghost notes—syncopated snare and kick 
hits—in the beat.
Note:  The presence of ghost notes depends on the chosen drummer and the 
complexity setting.

•• Drag the Hi-Hat knob to adjust the degree to which the Hi-Hat is opened and closed during 
the drum performance.
Note:  This is only relevant if the hi-hat is selected in the drum kit representation.

Any changes or selections you make in the Drummer Editor affect only the selected region, not 
the entire track. The selected region is regenerated in the following situations:

•• Region timing is changed when adjusting the Swing and Fills knobs.
•• Fills are regenerated when adjusting the XY pad or the Fills knob.
•• Accents and systems are regenerated when adjusting the XY pad or the kit piece variations.
•• Percussion is regenerated when adjusting the XY pad or the percussion variations.

You can also refresh the selected region, without editing any region settings, to play back a 
subtly different version.
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Follow the rhythm of another track
You can have the kick and snare portions of a Drummer region follow another track so that the 
beat Drummer plays is influenced by the rhythm of the content of another instrument. You may 
find, for example, that it makes more musical sense to have the chorus beat influenced by a 
guitar track, while the rest of the song follows a bass track. You can set this option on a region 
basis, which means that each Drummer region can follow a different track.

The following types of audio material are best suited to lending their structure to Drummer 
regions:

•• Audio files recorded using monophonic, polyphonic, or percussive instruments.

•• Audio files containing notes played on the same beat—no overlapping chord notes.

•• Audio files recorded without distortion, overdrive, compressor, or modulation effects.

Note:  Before choosing an audio track, you should analyze its audio content for tempo or adjust 
the timing of audio material.

Have a Drummer region follow the rhythm of another track
	 1	 Select a Drummer region in the Tracks area.

	 2	 Select the Follow Rhythm checkbox in the Drummer Editor.

Because this behavior has an effect on the Kick and Snare portion of the beat, the Kick & Snare 
pattern variation slider changes to the Follow Track pop-up menu.

Follow Rhythm checkbox

Follow Track pop-up menu

	 3	 Choose a track from the Follow Track pop-up menu.

As with other track types, you can also match the timing of a Drummer track to the groove track. 
For details, see Control timing with the groove track.
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Work with Producer Kits
When you add a Drummer track to your project, a drummer and a default patch associated 
with that drummer is loaded. The default patch is based on a stereo mixdown of the full, multi-
miked drum kit mix. These patches are optimized for performance.The original producer patch 
(Producer Kit) offers full access to all mix options.

Important:  When using Producer Kits, make sure that plug-in latency compensation is set to All 
in General Audio preferences. This ensures phase-coherent playback of all channel strips in the 
multi-miked drum kit mix.

For live playing, it’s recommended that you use the stereo mixdown patches or the Unmixed+ 
producer patch in the Library. While some of the patches can contain latency-inducing plug-
ins, you can compensate for this by turning on Low Latency mode. To do so, click the Low 
Latency Mode button in the control bar or select the Low Latency Mode checkbox in General 
Audio preferences.

Note:  Producer Kits are only available after you download additional content.
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Access Producer Kits
mm Click the Library button  in the control bar, then select the Producer Kits patch category.

Producer Kits are identified in the Library by a “+” at the end of the patch name. There is an 
original producer patch for each stereo mixdown patch.

Choosing a Producer Kit gives you full access to all 15 individual drum mic channel strips and any 
effect plug-ins and routings. You also have access to additional mic and room sound settings, and 
additional drum replacement pieces, in Drum Kit Designer.

Producer Kit Stereo Mixdown Kit
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Use Drum Kit Designer

Drum Kit Designer overview
Drum Kit Designer is a software instrument plug-in that lets you build custom drum kits from a 
wide selection of drum sounds. It also provides controls that change sound characteristics for 
each piece in your kit. Further settings allow you to use different microphones and rooms to 
enhance Producer Kits.

Drum Kit Designer’s interface is divided into the following main areas.

Exchange panel Edit panel

Drum Kit

•• Drum kit: Click a drum kit piece to play its sound and to open the Edit panel and the Exchange 
panel if exchange pieces are available for that drum type.

•• Exchange panel: Shows all drums that are available for exchange (you may need to scroll).

•• Edit panel: Shows settings that change sound characteristics.
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Open Drum Kit Designer
Do one of the following:

mm In the Drummer Editor: Click the plug-in button (shows the default patch associated with the 
drummer) at the bottom of the drummer’s card.

mm In the inspector or Mixer: Click Drum Kit Designer in the Drummer track’s respective channel 
strip slot.

Play drums and adjust kit piece settings
Drum Kit Designer shows a 3D representation of the drum kit for the currently loaded patch or 
plug-in setting.

For all kits, you can play the drums; edit the pitch, sustain, and volume of each drum kit piece; 
and exchange the kick and snare drums. When working with Producer Kits, you can additionally 
exchange toms, cymbals, and hi-hat. Producer Kits also let you turn different microphones, such 
as overheads or room mics, on or off.

Note:  Producer Kits and some drums are only available after you download additional content.

Drum Kit Designer also provides additional settings for adjusting the gain of other instrument 
pieces, such as the shaker, cowbell, and so on.

Play a drum
mm Click a drum.

The first time you click any drum after opening the plug-in, one or two panels open. You can 
exchange individual drums in the Exchange panel to the left, and edit individual kit piece 
settings in the Edit panel to the right.
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Adjust kit piece settings (all Kits)
	 1	 Click a drum.

The Edit panel opens to the right.

•• Toms: Click the tab for the tom you want to edit, or click the All tab to adjust the tone of 
all toms.

•• Cymbals: Click the tab for the crash cymbal you want to edit, or click the All tab to adjust the 
tone of both crash cymbals. The ride cymbal can be edited directly.

•• Kicks and snares: There are no tabs, so make your adjustments with the controls.

	 2	 Do any of the following to adjust settings:

•• To adjust the pitch: Drag the Tune knob vertically, or double-click the field and enter a 
new value.

•• To adjust the amount of damping: Drag the Dampen knob vertically, or double-click the field 
and enter a new value.

•• To adjust the volume: Drag the Gain knob vertically, or double-click the field and enter a 
new value.

	 3	 Click anywhere in the plug-in window background to close the panels.
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Adjust mic settings (Producer Kits only)
In the Edit panel, do any of the following:

mm To include the sound in the mic of the other kit pieces: Turn the Leak switch on.

This turns microphone bleed on or off, where the sound of a kit piece is picked up by the 
different mics from other kit pieces.

mm To include the kit piece’s overhead mic in the sound: Turn the Overheads switch on.

This turns the overhead mic for the selected kit piece on or off.

mm To choose between two different room microphone setups: Choose between rooms A and B. You can 
also turn the room microphones off.

Rooms A and B determine which room mic setup is used with the kit piece.

Adjust the volume of other percussion instruments
	 1	 Click the disclosure triangle at the bottom-left corner of the plug-in window to show 

additional settings.

	 2	 Drag the slider (or drag vertically in the field) to adjust the volume of the corresponding 
instrument:

•• Shaker Gain

•• Tambourine Gain

•• Claps Gain

•• Cowbell Gain

•• Sticks Gain
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Exchange drums
In Drum Kit Designer, you can produce different sounds by exchanging drums. For all kits, you 
can exchange the kick and snare drums. When working with Producer Kits, you can additionally 
exchange toms, cymbals, and hi-hat.

Note:  Producer Kits and some drums are only available after you download additional content.

Exchange a drum
	 1	 Click a drum.

The Exchange panel opens to the left if exchange pieces are available for that kit piece.

	 2	 Click the Info button of a selected kit piece to view its description.

	 3	 Click the kit piece that you want to exchange in the Exchange panel. You may need to scroll in 
order to find the one you want to use.

The piece is exchanged and the respective drum sound is loaded.

Note:  The toms and crash cymbals can only be exchanged as a group.

	 4	 Click anywhere in the plug-in window background to close the panels.

Map Drum Kit Designer to external hardware controllers
Drum Kit Designer is compatible with the GM standard. You can also choose GM+, which 
maps the keyboard ModWheel for Hi-Hat control. This means that you can use the 
keyboard ModWheel to adjust the degree to which the Hi-Hat opens and closes during the 
drum performance.

Drum Kit Designer is also compatible with the V-Drum standard.

Map to external hardware controllers
	 1	 Click the disclosure triangle at the bottom-left corner of the plug-in window to show 

additional settings.

	 2	 Choose one of the following from the Input Mapping pop-up menu:

•• GM

•• GM + ModWheel controls HiHat opening level

•• V-Drum

For details on how drum sounds are remapped when different modes are chosen, see the Logic 
Pro Instruments manual.
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Convert Drummer regions to MIDI regions
You edit Drummer regions in a dedicated Drummer Editor. To edit them in the Piano Roll Editor, 
Event List, or Step Editor, you first need to convert them to MIDI regions.

After converting a Drummer region to a MIDI region, you can convert it back to a Drummer 
region at a later point. However, any MIDI edits you made to the region will be lost.

Note:  Drummer regions can be edited in the Tracks area in much the same way as you would 
edit MIDI regions, with the exception of region overlapping. When overlapping, Drummer regions 
always use the No Overlap drag mode.

Convert a Drummer region to a regular MIDI region
Do one of the following:

mm Control-click the Drummer region, then choose Convert > Convert to MIDI Region from the 
shortcut menu.

The Drummer region is converted to a MIDI region, but the region remains on the 
Drummer track.

mm Drag the Drummer region to another existing track.

The Drummer region is converted to a MIDI region.

The resulting MIDI region behaves just like any other MIDI region. You can edit it in the Piano Roll 
Editor, Event List, or Step Editor.

Convert a regular MIDI region back into a Drummer region
Do one of the following:

mm If the region is on the Drummer track: Control-click the MIDI region, then choose Convert > Convert 
to Drummer Region from the shortcut menu.

mm If the region is on another track: Drag the MIDI region to the Drummer track.

The resulting Drummer region will not contain any MIDI edits you may have made.
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Flex Time and Pitch overview
Flex Time—similar to what is often referred to as elastic audio in other applications—greatly 
simplifies the process of editing the timing of audio material. You can compress or expand 
the time between specified points in an audio region without the need for more traditional 
processes like cutting, nudging, and crossfading.

You edit the timing of audio material by choosing a Flex Time algorithm. When you choose 
an algorithm, the contents of the audio track are analyzed for transients, or significant peaks, 
and any detected transients are marked in the audio regions. You then edit the timing using 
flex markers. When you move a flex marker, the audio on either side of it is time compressed 
or expanded. The initial boundaries within which this is done are determined by the 
transient markers.

Flex Pitch allows you to quantize and edit the pitch of audio material. You edit the pitch of audio 
material by choosing the Flex Pitch algorithm. The contents of the audio track are analyzed for 
pitch using a pitch detection process, and the results are plotted on a pitch curve.

You can edit the timing of audio in the Tracks area and the pitch in the Audio Track Editor.

  Flex Time is also available in the Audio Track Editor and Flex Pitch in the Tracks area, when 
Show Advanced Tools is selected in the Advanced preferences pane.

Turn on flex in the Tracks area
	 1	 Do one of the following:

•• Choose Edit > Show Flex Pitch/Time from the Tracks area menu bar (or press Command-F).

•• Click the Flex button  in the Tracks area menu bar.

A Flex button and Flex pop-up menu appear in the track header of each audio track.

Flex buttonFlex button

Flex pop-up menu

	 2	 Click the Flex button  in the track header of the audio track you want to edit.

The Flex pop-up menu is now available for use.

Edit the timing and pitch of audio 14
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	 3	 Choose Flex Pitch or one of the Flex Time algorithms from the Flex pop-up menu.

Turn on flex in the Audio Track Editor
	 1	 Open the Audio Track Editor by doing one of the following:

•• Select an audio track in the Tracks area, then choose View > Show Editors.

•• Select an audio track in the Tracks area, then click the Editors button  in the control bar.

•• Double-click an audio region.

	 2	 Click the Flex button  in the Audio Track Editor menu bar (or press Command-F).

Note:  Click the Audio Track Editor’s workspace before using the key command, to make sure that 
the Audio Track Editor has key focus.

A Flex pop-up menu appears to the right of the Flex button in the Audio Track Editor menu bar.

	 3	 Choose Flex Pitch or one of the Flex Time algorithms from the Flex pop-up menu.

Assign the same flex algorithm to all audio tracks
mm In the Tracks area or Audio Track Editor, hold down Shift while choosing a flex algorithm from the 

Flex pop-up menu.
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Isolate individual regions from the flex editing process
mm Select an audio region or take region, then deselect the Flex checkbox in the Region inspector.

All flex editing properties on the region or take region are disabled, but not deleted, and the 
region plays at its original speed.

Flex checkbox
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Edit the timing of audio

Flex Time algorithms and parameters
Flex Time algorithms are track-based settings that determine how the timing or pitch of your 
audio material will be altered—using time compression or expansion, manipulating invisibly 
sliced segments, or speeding up or slowing down the material. You can choose an algorithm 
based on the type of audio material you’re working with. Each algorithm comes with its own 
individual parameters, located in the Track inspector.

You can also have Logic Pro choose the most suitable Flex Time algorithm based on an 
automatic analysis of your audio material.

  Flex options are only available in the Track inspector when Show Advanced Tools is selected 
in the Advanced preferences pane.

Flex pop-up menu

Flex parameters

Note:  When you choose a flex algorithm for a track, the Freeze Mode parameter in the Track 
inspector switches from Pre Fader to Source Only. This freezes the track signal without any effects 
plug-ins. For details, see Freeze tracks.

Have Logic Pro choose a Flex Time algorithm
mm In the Tracks area or Audio Track Editor, choose Flex Time - Automatic from the Flex 

pop-up menu.

The resulting algorithm is chosen as follows:

•• Monophonic for monophonic audio material—bass line, for example

•• Slicing for percussive, non-tonal audio material—drums, for example

•• Polyphonic for chords, or complex material—mixes, for example

Use the Slicing algorithm
mm Choose Flex Time - Slicing from the Flex pop-up menu.

Slicing cuts the audio material at transient markers, then shifts the audio while playing each 
slice at its original speed. No time compression or expansion is applied to the shifted audio. Any 
gaps that occur as a result of shifting the audio can be filled using the decay function. Slicing is a 
good choice for drums and percussion and comes with the following parameters:

•• Fill Gaps: Turns the decay function on or off, allowing you to fill any gaps that occur between 
sounds as a result of shifting the audio.

•• Decay: Sets the decay time between sounds, because no time stretching takes place to 
compensate for the gaps.

•• Slice Length: Shortens each slice by a percentage value. Shortening slices can be helpful for 
removing unwanted pre-attack sounds from the following slice, or to create a gated effect.
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You can also slice an audio region at transient marker positions, splitting it into multiple regions. 
You do this by Control-clicking the audio region, then choosing Slice at Transient Markers from 
the shortcut menu.

Use the Rhythmic algorithm
mm Choose Flex Time - Rhythmic from the Flex pop-up menu.

Rhythmic time stretches the material, looping audio between slices in order to fill any gaps. 
This algorithm is most suitable for material such as rhythmic guitars, keyboard parts, and 
Apple Loops. Rhythmic comes with the following parameters:

•• Loop Length: Sets the length of the looped section at the end of a slice that is used for 
time expansion.

•• Decay: Defines a decay value for the looped area.

•• Loop Offset: Allows you to move the looped area up to 100 ms to the left, preventing pre-
attack sounds from the following transient to appear in the looped and crossfaded area.

Use the Monophonic algorithm
mm Choose Flex Time - Monophonic from the Flex pop-up menu.

Monophonic is designed to be used on melodic instruments only playing a single note at a time, 
and is therefore good for solo vocals and monophonic solo instruments—melody and bass lines, 
for example. When you use this flex algorithm, your recording should be relatively dry, without 
audible reverberation. Otherwise, you may want to try using Polyphonic. Monophonic comes 
with a single parameter:

•• Percussive: Preserves the area around transient markers to protect the percussive part of the 
sound. If selected, allows better timing for all kinds of percussive monophonic tonal material, 
such as plucked strings (guitar, bass) or tonal percussion. If unselected, prevents glitches on 
transient markers in nonpercussive tonal material, such as bowed strings or wind instruments.

Use the Polyphonic algorithm
mm Choose Flex Time - Polyphonic from the Flex pop-up menu.

Polyphonic time stretches material based on a process called phase vocoding—a process that 
uses phase information to time stretch an audio signal without touching its pitch. It is the most 
processor intensive of all the flex algorithms, but it delivers high sonic quality with suitable 
polyphonic material. It’s recommended for complex polyphonic material and is good for all kinds 
of chords—such as guitar, piano, and choir—and also complex mixes. Polyphonic comes with a 
single parameter:

•• Complex: Enables more internal transients in the audio material.

Use the Tempophone algorithm
mm Choose Flex Time - Tempophone (FX) from the Flex pop-up menu.

Tempophone emulates the effect of an historical tape-based time-stretching device known as 
a tempophone, and results in a mechanical sound with many artifacts similar to those produced 
with granular synthesis techniques. Tempophone is intended to be used creatively for special 
effects and comes with the following parameters:

•• Grain Size: Sets the size of the grains that are played or repeated in their original speed and 
crossfaded to create time compression or expansion.

•• Crossfade: Adjusts the crossfade length from 0.00, which produces hard artifacts, to the full 
grain length of 1.00, which tends to sound softer.
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Use the Speed algorithm
mm Choose Flex Time - Speed (FX) from the Flex pop-up menu.

Speed time stretches material by playing the source material faster or slower, including pitch 
change. Because of the pitch shifting, this flex algorithm is mainly useful for percussive material, 
but it can be used on all material for interesting creative effects.

Time stretch using flex markers
In the Tracks area, you edit the timing of audio material using flex markers. After adding flex 
markers to an audio region, you use them to time stretch—compress or expand—the audio 
material. The boundaries within which this is done are determined by the preceding and 
following flex markers, or the region start and end positions if there are no preceding and 
following flex markers.

You can also use transients in other audio regions as reference points, when dragging a flex 
marker in an audio region.

  Flex Time is also available in the Audio Track Editor, when Show Advanced Tools is selected in 
the Advanced preferences pane.

Time stretch audio using a flex marker
	 1	 Choose a Flex Time algorithm for the track.

	 2	 Add a flex marker by doing one of the following:

•• Place the pointer over or beside a transient marker in the upper half of the waveform body 
(note how the pointer changes), then click.

A flex marker is added on top of the transient marker.

•• Place the pointer in the upper half of the waveform body where there is no transient marker 
(note how the pointer changes), then click.

A flex marker is added at the clicked position.
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	 3	 Do one of the following:

•• Drag the flex marker to the left.

The audio material is time compressed up to the preceding flex marker, the preceding tempo 
marker, or the region start position. The audio material is time expanded up to the following 
flex marker or the following tempo marker (which can also be the region end position).

If you move the flex marker to the left and it crosses a previous flex marker, the previous flex 
marker jumps back to the previous transient marker. This allows you to extend the Flex Time 
editing range to the left. The same behavior occurs if a flex marker crosses a tempo marker.

•• Drag the flex marker to the right.

The audio material is time expanded up to the preceding flex marker, the preceding tempo 
marker, or the region start position. The audio material is time compressed up to the following 
flex marker or the following tempo marker (which can also be the region end position).

If you move the flex marker to the right and it crosses a following flex marker, the following 
flex marker jumps forward to the next transient marker. This allows you to extend the 
Flex Time editing range to the right. The same behavior occurs if a flex marker crosses a 
tempo marker.

Snap a flex marker to a transient in another region
	 1	 Click-hold the flex marker, then drag the pointer up or down over an adjacent track.

A yellow guideline appears in the audio region on the adjacent track as you move from transient 
to transient.

	 2	 Release the mouse button to snap the flex marker to the highlighted transient marker.
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Add multiple flex markers to an audio region
Do one of the following:

mm Place the pointer over or beside a transient marker in the lower half of the waveform body (note 
how the pointer changes), then click.

Three flex markers are added: on the transient marker, on the previous transient marker, and on 
the following transient marker.

mm Place the pointer in the lower half of the waveform body where there is no transient marker 
(note how the pointer changes), then click.

Three flex markers are added: at the clicked position, on the previous transient marker, and on 
the following transient marker.
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Time stretch using marquee selections
In the Tracks area, you can edit the timing of audio material using the Marquee tool in 
combination with flex markers.

  Flex Time is also available in the Audio Track Editor, when Show Advanced Tools is selected in 
the Advanced preferences pane.

Time stretch audio using a marquee selection
	 1	 Using the Marquee tool, drag in the Tracks area to select part of a region.

	 2	 Using the Pointer tool, do one of the following:

•• Click in the upper half of the marquee selection.

Four flex markers are added: two at the marquee borders and two outside the marquee 
selection, at the previous and next transient markers.

•• Click in the lower half of the marquee selection.

Three flex markers are added: one at the clicked position and two at the marquee borders.

	 3	 Drag the marquee selection in either direction.
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Time stretch using the Flex tool
The Flex tool gives you quick access to basic Flex Time editing functionality, without having 
to turn on Flex view. When you click a region with the Flex tool for the first time, a transient 
detection process is performed on the audio material and the most suitable flex algorithm 
is chosen.

You use the Flex tool in the Tracks area to grab points in the region’s waveform and move them. 
The waveform’s movement is restricted by transient markers on either side of the place you 
begin dragging. To extend the editing area, drag beyond these transients and the boundary will 
extend to the next or previous transient.

Time stretch audio using the Flex tool
Do one of the following:

mm Place the Flex tool over the region body, then drag when you see the following pointer:

Three flex markers are added: on the transient marker, on the previous transient marker, and on 
the following transient marker.

You are compressing or expanding the audio material between the middle flex marker and the 
other two.

mm Place the Flex tool over the region body, then drag when you see the following pointer:

Three flex markers are added: at the clicked position, on the previous transient marker, and on 
the following transient marker.

You are compressing or expanding the audio material between the middle flex marker and the 
other two.

mm Make a selection in the region with the Marquee tool, then drag the selection using the Flex tool.

Four flex markers are added: two at the marquee borders and two outside the marquee 
selection, at the previous and next transient markers.

You can edit the time position of the audio material between the first and second flex markers or 
between the third and fourth flex markers. Nothing happens to the audio material between the 
second and third flex markers.
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Delete, reset, and move flex markers
When you delete a flex marker, any time changes that occurred in the area around the flex 
marker are either removed—resetting the audio material to its original position—or reset 
according to the time-stretching offset of the previous flex marker or region start position and 
the following flex marker or region end position.

You can delete only those flex markers that were manually added or all flex edits that were 
carried out on the audio file, which includes audio quantization.

You can also change the position of a flex marker in an audio region without changing the 
timing of the audio material before or after the flex marker.

  Flex Time is also available in the Audio Track Editor, when Show Advanced Tools is selected in 
the Advanced preferences pane.

Delete a flex marker from an audio region
Do one of the following:

mm Place the pointer over the flex marker, then click the “x” symbol in the region header.

mm Double-click the flex marker.

mm Drag across the flex marker with the Eraser tool.

Important:  Use the Eraser tool in the body of the waveform only. Using it in the region header 
deletes the entire region.

mm Control-click the flex marker, then choose Delete Flex Marker from the shortcut menu.

Delete multiple flex markers from an audio region
mm Drag across multiple flex markers with the Eraser tool.

Important:  Use the Eraser tool in the body of the waveform only. Using it in the region header 
deletes the entire region.

Delete all manually added flex markers from an audio region
mm Control-click the region background, then choose Reset Manual Flex Edits from the 

shortcut menu.

Reset a region to its original length
mm Control-click the region background, then choose Reset All Flex Edits from the shortcut menu.

All flex markers are deleted, including any that were placed automatically—during the audio 
quantization process, for example.

Move a flex marker to a neutral position
mm Control-click the flex marker, then choose Set To Neutral Position from the shortcut menu.

The flex marker moves to the same position the audio sample would have moved to if the flex 
marker had been deleted.
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Move a flex marker without time stretching
mm Hold down Option while you drag the flex marker.
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Edit the pitch of audio

Flex Pitch algorithm and parameters
Flex Pitch is a track-based setting that determines how the pitch of your audio material will be 
altered. The algorithm comes with two parameters, located in the Track inspector.

  Flex options are only available in the Track inspector when Show Advanced Tools is selected 
in the Advanced preferences pane.

Flex pop-up menu

Flex parameters

Note:  When you choose a flex algorithm for a track, the Freeze Mode parameter in the Track 
inspector switches from Pre Fader to Source Only. This freezes the track signal without any effects 
plug-ins. For details, see Freeze tracks.

Use the Flex Pitch algorithm
mm Choose Flex Pitch from the Flex pop-up menu.

Flex Pitch includes the following parameters:

•• Formant Track: Determines the interval at which formants are tracked along the signal.

•• Formant Shift: Determines how formants adjust to pitch shifts. When set to 0, formants are 
adjusted together with pitch shifts.

Edit the pitch of audio in the Audio Track Editor
When you choose Flex Pitch for a track in the Audio Track Editor, any sections of audio on that 
track that are identified as individual notes are displayed like notes in the Piano Roll Editor. In 
the Audio Track Editor, you can edit the pitch, time position, and length of notes in much the 
same way as you would in the Piano Roll Editor. You can also cut notes and merge multiple notes 
into one.

Each individual note in the Audio Track Editor contains “hotspots,” which you can use to edit 
pitch, vibrato, gain, and other parameters.

  Flex Pitch is also available in the Tracks area, when Show Advanced Tools is selected in the 
Advanced preferences pane.
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Change the pitch of a note
mm Drag a note vertically in the editor.

Move a note
mm Drag a note horizontally in the editor.

Resize a note
mm Drag the left or right edge of a note.



	 Chapter  14    Edit the timing and pitch of audio	 398

Split a note
mm Click a note with the Scissors tool.

Merge two or more notes
mm Select two or more notes, then click with the Glue tool.

Edit the parameters of a note using “hotspots”
mm Select a note, then do any of the following:

•• To edit the pitch drift at the start of the note: Drag the upper-left hotspot vertically.

•• To edit the vibrato: Drag the upper-mid hotspot vertically.

•• To edit the pitch drift at the end of the note: Drag the upper-right hotspot vertically.

•• To edit the gain: Drag the lower-left hotspot vertically.

•• To edit the fine pitch: Drag the lower-mid hotspot vertically.

•• To edit the formant shift: Drag the lower-right hotspot vertically.
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Edit the pitch of audio in the Tracks area
When you choose Flex Pitch for a track in the Tracks area, the pitch deviation of individual notes 
from their perfect semitone is shown as bars overlaying the audio waveform in the background.

•• The horizontal zero line represents the perfect pitch.

•• Upward bars represent sharp notes.

•• Downward bars represent flat notes.

•• The horizontal size of bars represents the length of detected notes.

•• The vertical display range is ±0.50 cents.

If you want to move notes in time, you should use the Audio Track Editor.

  Flex Pitch is only available in the Tracks area, when Show Advanced Tools is selected in the 
Advanced preferences pane.

Adjust the pitch of a note within the current semitone (between +0.50 and –0.50 cents/
semitone)

mm Drag the bar toward the zero line.

You can adjust the pitch within the range ±0.50 cents.

Adjust the pitch of a note to the next lower or higher semitone (beyond +0.50 and –0.50 
cents/semitone)

mm Drag the part of the bar on the zero line away from the line.

Set one or more notes to the perfect pitch
Do one of the following:

mm Control-click an individual bar, then choose Set to Perfect Pitch from the shortcut menu.

mm Control-click the audio region, then choose Set all to Perfect Pitch from the shortcut menu.

Reset one or more notes to their original value
Do one of the following:

mm Double-click the bar.

mm Control-click an individual bar, then choose Set to Original Pitch from the shortcut menu.

mm Control-click the audio region, then choose Set All to Original Pitch from the shortcut menu.
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Quantize the timing of audio regions in the Audio Track Editor
When Flex Pitch is turned on in the Audio Track Editor, you can quantize, or automatically correct, 
the timing of regions on an audio track. This is especially useful when regions on the track 
contain the right notes but are not perfectly in time with the project tempo.

When you quantize the timing, selected regions on the selected track are adjusted to the 
selected note value. You can quantize the timing of regions with drums, single-note instruments, 
and chordal or polyphonic instruments.

Quantize the timing of regions on an audio track
	 1	 To turn on Flex Pitch, click the Flex button  in the Audio Track Editor menu bar.

	 2	 Choose Flex Pitch from the Flex pop-up menu in the Audio Track Editor menu bar.

	 3	 Select the regions you want to quantize.

	 4	 Choose the note value to use as the basis for timing quantization from the Time Quantize 
pop-up menu.

Time Quantize pop-up menu

Strength slider

	 5	 Drag the Strength slider to the left to decrease the strength of quantization.

For more information about Flex editing, see Flex Time and Pitch overview.
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Quantize the pitch of notes in the Audio Track Editor
When Flex Pitch is turned on in the Audio Track Editor, you can quantize, or automatically correct, 
the pitch of notes on an audio track. This is especially useful when you record audio regions that 
have the right “feel” and timing but are not perfectly in tune.

When you quantize the pitch, selected notes on the track are adjusted. Quantizing the pitch can 
produce accurate results only for single-note (monophonic) audio regions, so be sure the track 
does not include regions with chords or unpitched sounds.

By default, notes are adjusted to the closest note on the chromatic (12-note) scale. You can also 
quantize regions to the notes of a particular key or scale.

Quantize the pitch of notes on an audio track
	 1	 To turn on Flex Pitch, click the Flex button  in the Audio Track Editor menu bar.

	 2	 Choose Flex Pitch from the Flex pop-up menu in the Audio Track Editor menu bar.

	 3	 Select the notes you want to quantize.

	 4	 Drag the Pitch Correction slider to the right to increase the amount of tuning adjustment, or 
drag it left to decrease the amount of adjustment.

	 5	 To quantize the pitch of notes to a particular scale, choose the scale and key (major or minor) 
from the Scale Quantize pop-up menus.

Pitch Correction slider

For more information about Flex editing, see Flex Time and Pitch overview.
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Change the gain of audio regions in the Audio Track Editor
When Flex Pitch is turned on in the Audio Track Editor, you can adjust the gain of individual 
audio regions from –30 to +30 decibels.

Adjust the gain of an audio region
	 1	 To turn on Flex Pitch, click the Flex button  in the Audio Track Editor menu bar.

	 2	 Choose Flex Pitch from the Flex pop-up menu in the Audio Track Editor menu bar.

	 3	 Select the regions you want to adjust in the Audio Track Editor.

	 4	 Drag the Gain slider in the Audio Track Editor inspector horizontally to adjust the gain.

Gain slider

For more information about Flex editing, see Flex Time and Pitch overview
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Use Varispeed to alter the speed and pitch of audio
Varispeed provides a way to speed up or slow down the entire project, similar to the original 
varispeed feature of tape machines. The most practical use for this option is checking how a 
project might sound at a faster or slower tempo, and for practicing or recording a performance 
at a lower speed.

In Logic Pro, you can speed up or slow down a project between −50 percent and +100 percent, 
which is between 50 percent and 200 percent of the original tempo.

  Varispeed is only available when Show Advanced Tools is selected in the Advanced 
preferences pane.

Turn Varispeed on or off
mm Click the Varispeed button in the control bar.

Note:  If you don’t see the Varispeed button in the control bar, Control-click the control bar, 
choose Customize Control Bar and Display from the shortcut menu, choose Custom from the 
LCD pop-up menu, then select the Varispeed checkbox.

When Varispeed is turned on, the button and display glow orange.

Choose a Varispeed mode
mm Click the upper part of the Varispeed display in the control bar, then choose one of the following:

•• Speed Only: Use to pitch shift the master output signal to balance the pitch change caused by 
varispeed. Only the speed changes, not the pitch.

•• Varispeed (Speed and Pitch): Use to emulate classic tape varispeed, where the pitch changes to 
reflect the speed change.

•• Varispeed and MIDI: Use to emulate classic tape varispeed and simultaneously transpose non-
drum MIDI tracks, quantized to semitones.
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Change the unit of measurement and adjust the value
	 1	 Click the unit of measurement (%, bpm, st, Hz) in the lower part of the Varispeed display in the 

control bar, then choose one of the following:

•• Percentage (%): Displays the unit of measurement according to percentage.

•• Resulting Tempo (bpm): Displays the resulting tempo, dependent on the current tempo, which 
changes along with any tempo changes in the project.

Note:  The Tempo display in the control bar always shows the original tempo value.

•• Detune (st): Displays the unit of measurement according to pitch change.

•• Tuning Reference (Hz): Displays the unit of measurement according to tuning reference.

	 2	 Drag vertically on the value to adjust it, or double-click and enter a new value.
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Advanced Logic Pro editors
Logic Pro includes several advanced editing windows that you can use to process and 
manipulate audio or MIDI information in unique ways. 

  The advanced Logic Pro editors are available when   Show Advanced Tools is selected in 
the Advanced preferences pane. To access the Audio File Editor, you need to select the Show 
Advanced Tools checkbox and the Audio checkbox in the Advanced preferences pane.

•• Event List: The Event List shows MIDI events or regions as an alphanumerical list. All available 
event or region values can be edited. See Event List overview.

•• Step Editor: The Step Editor shows MIDI events as steps—positioned on lanes that resemble 
the tracks shown in the main window. See Step Editor overview.

•• Audio File Editor: The Audio File Editor lets you make precise adjustments to audio files, remove 
pops and clicks in audio material, set sample-accurate crossover points for looped playback, 
correct phase cancellation errors, and more. See Audio File Editor overview.

•• MIDI Transform window: The MIDI Transform window is a processing utility that transforms 
MIDI events into different types of events, or events with different values. See MIDI Transform 
window overview.

Advanced edit features 15
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Event List

Event List overview
The Event List is the most powerful, flexible, and complete MIDI editor in Logic Pro. All MIDI 
event types are displayed as an alphanumerical list in the Event List. All aspects of events—start 
and end points, length, channel, and values—can be altered in this area. You can view all events 
in a region, and can filter the list to restrict this view to one or more event types, such as notes, 
pitch bend events, or both, for example. This makes the selection and editing of events faster 
and simpler.

All functions and options are shown at the top of the Event List area. The events themselves are 
shown in the list below.

Open the Event List as a tab in the Logic Pro main window
mm Click the List Editors button  in the control bar, then click the Event tab (or use the Toggle 

Event List key command, default assignment: E).

Open the Event List as a separate window
mm Choose Window > Open Event List (or use the Open Event List key command, default 

assignment: Command-0).
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Event List display options

View events and regions in the Event List
By default, the Event List shows all events in the selected MIDI region.

The Event List can also display a list of all regions (and folders) in the Logic Pro main window.

View the events within a region in an open Event List window
mm Click the name of the region with the Pointer tool. 

The Event List can’t show the events of a multiple region selection. The Event List behaves as 
follows:

•• The events of the last selected region are displayed (this also applies when selecting multiple 
regions with Shift-click).

•• The events of the first selected region are displayed when a marquee selection is made.

View a list of regions (and folders)
mm Click the Display Level button at the top-left corner of the Event List window. 

This button is only accessible when the Event List is showing the contents of a region (it’s 
showing events, in other words).
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Filter event types
When viewing events in a selected MIDI region, you can use the event type buttons to filter what 
is shown. These buttons show or hide specific event types from the list below, thus limiting the 
view to events that you want to edit.

As a practical example of where these event type buttons could be used: Imagine a drum part 
that you have recorded. You have found that every High Tom note event (D2) shares a frequency 
with another instrument track, and is lost in the mix. Filter the view so that only note events 
are visible, select one of the High Tom events, then use the Select Equal Regions/Events key 
command, default assignment: Shift-E. All note events with a value of D2 are selected, allowing 
you to simultaneously change them to the Mid Tom sound (B1), for example.

Important:  All selection and editing functions performed in the Event List only affect the 
displayed events, protecting any invisible events from changes you may make.

Filter the display of events
	 1	 Click the event type buttons that match the event types you want to hide or display (Notes, Pitch 

Bend, and so on).

Events that match the active (illuminated) buttons are shown in the list. Events that match the 
inactive (dark) buttons are hidden.

Show additional information in the filtered display
The Event List is normally restricted to one line per event. When the Additional Info button is on, 
however, all information stored along with the event is also shown.

This is particularly important for editing SysEx messages. When examining note events in the 
Event List, you will also notice Rel Vel (release velocity or note off messages). 

mm Click the Additional Info button to show all information stored with an event.

Score layout information is also included in the list when additional info is shown. You can edit 
this in the Event List, but it is more efficient to perform such operations in the Score Editor.
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View events outside the display area
You will often find that the number of events shown in the list exceeds the amount of screen 
space. The list scrolls automatically when you click the Play button in the control bar, and the 
event at (or nearest to) the playhead position during playback is indicated by a white line.

Playhead position

View events outside the display area
Do one of the following:

mm Use the event type buttons to filter the list, thus reducing the number of displayed events.

mm Drag the scroll bar at the right of the list area.

mm Choose Navigate > Scroll to Selection (or use the corresponding key command).

Note:  When a marquee selection is active, using this key command moves the visible section of 
the edit window to mirror the marquee selection.

Select and create events in the Event List

Select events in the Event List
You can use any of the standard selection techniques in the Event List: individual selection by 
clicking events, multiple selection by dragging, or both of these (without altering the previous 
selection), in conjunction with the Shift key.

Tip:  When selecting events with the Pointer tool, you should click the event name in the Status 
column, to avoid any unintentional parameter alterations.

Right-click in the Event List to open a shortcut menu that contains selection, editing, and other 
commands. Use these commands to accelerate your workflow.

Note:  The right-click shortcut menu can only be accessed if the Right Mouse Button: Opens 
Shortcut Menu option is chosen in Logic Pro > Preferences > General > Editing.

Select an event, and navigate the list, with the arrow keys
mm Press the Left Arrow key to select the previous event, or the Right Arrow key to select the next 

event. Hold the respective arrow key to scroll through the list.

Note:  If the MIDI Out button (Output button) is on (it’s on by default), every newly selected event 
is played. This allows you to scroll (or play) through the list and audibly monitor events as they 
are selected.
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Select multiple events with the arrow keys
mm Hold Shift and press the Left or Right Arrow key. Keep both Shift and the arrow key held down to 

select multiple events.

Refine your event selection
Use the event type buttons to filter the list of displayed events and speed up your workflow.

mm Click any of the event type buttons alone, or in conjunction with, specific selection commands 
available in the Edit > Select menu or as key commands. These include:

•• All (default key command assignment: Command-A): Selects all visible events.

•• All Following (default key command assignment: Shift-F): Selects all events after (below) the 
currently selected event.

Note:  When a marquee selection is active, using this key command extends the marquee 
selection—over all tracks within a marquee selection—to the project end point.

•• All Following of Same Pitch (default key command assignment: Option-Shift-F): Selects all events 
of the same pitch that follow the currently selected note event.

Note:  When a marquee selection is active, using this key command extends the marquee 
selection—over all tracks within a marquee selection—to the project end point.

•• All Inside Locators (default key command assignment: Shift-L): Selects all events that fall within 
the locator boundaries.

Note:  When a marquee selection is active, using this key command sets the marquee selection 
to match the locators.

•• Invert Selection (default key command assignment: Shift-I): Selects all unselected events.

•• Muted Events (default key command assignment: Shift-M): Selects all muted events. This selection 
command is usually a precursor for deletion (Delete).

•• Overlapped Events: Selects all events that overlap one another. This is usually the end of one 
event, and the start of the following event.

•• Equal Colored Events (default key command assignment: Shift-C): Selects all equal colored events.

•• Equal Events (default key command assignment: Shift-E): Selects identical events (same event 
type and value).

•• Similar Events (default key command assignment: Shift-S): Selects all C#3 note events, 
for example.

•• Same MIDI Channel (default key command assignment: Shift-H): Selects events on the same 
MIDI channel.

•• Same Subposition (default key command assignment: Shift-P): Selects events that start at the 
same position.

•• Highest Notes (default key command assignment: Shift-Up Arrow): Selects note events that are 
higher in pitch than the selected note event.

•• Lowest Notes (default key command assignment: Shift-Down Arrow): Selects note events that are 
lower in pitch than the selected note event.

•• Previous Event (default key command assignment: Left Arrow): Selects the event that precedes 
the selected event.

•• Next Event (default key command assignment: Right Arrow): Selects the event that follows the 
selected event.

•• Deselect All (default key command assignment: Shift-Command-A): Deselects all events.

•• Deselect Outside Locators: Deselects all events outside the locator borders.
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Create events in the Event List
The Event List accepts real-time and step recording of MIDI events, as described in Recording 
overview on page 201. Similar to the other MIDI editors, you can also create events directly in the 
Event List.

You can also perform advanced Copy and Move operations within the Event List. These 
commands allow you to directly swap events, or to merge a group of notes from one section of 
a region to the same, or another, region. For more information, see Copy notes in the Piano Roll 
Editor on page 352.

Add an event manually
	 1	 Move the playhead to the insert position. 

The current playhead position is used as the insert position if it’s not moved.

	 2	 Choose an event type from the Event Type pop-up menu. 

	 3	 Click the Add Event button (+).

The event is added at the playhead position, and is automatically selected.

Important:  Events can only be created in an existing region. If no region is selected, or exists, on 
the selected track, an alert appears.

Duplicate an existing event
This operation is useful for creating a copy of an event with a different value. For example, 
creating one or more notes of a particular length and velocity at the same position as another 
note lets you change the Pitch (Num column) of the duplicate notes to create a chord, or a new 
chord voicing.

	 1	 Control-click the original (source) event name in the Status column, then choose Copy Event 
(default key command: Command-C) in the shortcut menu.

	 2	 Control-click the original (source) event name in the Status column, then choose Paste Event 
(default key command: Command-V) in the shortcut menu.

	 3	 Enter the position for the duplicate event in the input box that appears. If you press Return, the 
original event position is used for the copied event.

Add one or more events from the Clipboard
	 1	 Copy an event from another editor, then choose Edit > Paste (default key command 

assignment: Command-V). 

	 2	 Enter a destination position for the first event in the input box that appears. If you press Return, 
the original position of the first event is retained and used. The relative positions of other copied 
events are maintained.

Important:  The position input box is unique to the Event List. Pasted events are not 
automatically added at the playhead position, as is the case in the graphical editors. 
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Edit events in the Event List

Edit events overview
The Event List Position, Status, Ch(annel), Num(ber), Val(ue), and Length/Info columns display 
all details of all event types. In most cases, you can directly edit the data displayed (with the 
exception of the Status column, which indicates the event type). 

Not all columns are used for every type of event. For example, system exclusive messages are 
not MIDI-channel specific, so the Channel column is unused. Channel and polyphonic pressure 
messages have no length, so the Length/Info column is blank.

In some instances, clicking the information in the Number or Value column opens a pop-up 
menu, allowing you to choose an option. For example, clicking the Number column of a MIDI 
controller event (Control is shown in the Status column) opens a pop-up menu of numbered and 
named standard MIDI controller types. These include Controller numbers 3 = Solo, 7 = Volume, 
10 = Pan, and so on.

Details about the different event types, the parameters shown in the columns, and the impact of 
changes—on both the event itself and other columns—are found in these sections:

•• Note events

•• Control change events

•• Pitch bend events

•• Program change events

•• Aftertouch events

•• Poly pressure events

•• SysEx events

•• Meta events
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Change the position and length of events
The units shown in the Event List Position and Length/Info columns represent bars, beats, 
divisions, and ticks (or SMPTE time, when View > Show Event Position and Length as Time is 
active). Counting begins at 1 for each unit (first bar, first beat, first division, first tick: 1 1 1 1), and 
continues until it is carried over to the next largest unit.

Numerical input starts from the left (which means you can enter the bar number only, and press 
Return, if you want to move an event to the beginning of a specific bar, when entering a value). 
The units can be separated by either spaces, dots, or commas, allowing you to type 3.2.2.2 or 3, 2, 
2, 2 or 3 space 2 space 2 space 2.

Move an event in time
Do one of the following:

mm Double-click the position indicator (in the Position column), then enter a new value. Press Return 
to exit the field.

mm Drag the specific position unit vertically. Release the mouse button when you’re finished. 

If another editor, such as the Piano Roll Editor, is open, you see the note event move as you 
change the value. As soon as you alter the position of an event, the list is automatically re-sorted. 
The currently selected event remains highlighted.

Change the length of an event
Do one of the following:

mm Double-click the length/info indicator (in the Length/Info column), then enter a new value. Press 
Return to exit the field.

mm Drag the specific length/info unit vertically. Release the mouse button when you are finished. 

Changes to the Event List value are immediately shown in other open editors, such as the Piano 
Roll Editor.

Note:  The minimum possible length is one tick, because you can’t simultaneously switch a note 
(or other event) on and off.

Change the appearance of the Position and Length columns
mm Not every project is bar/beat oriented. Choose one of the following View menu commands 

to make changing the position and length of events easier when working with film or video, 
for example.

•• View > Show Event Position and Length as Time: Displays the position and length columns in 
SMPTE units.

•• View > Length as Absolute Position: Use to make the length display show the absolute position 
of the note off event, rather than its length from the note on position.

•• View > Relative Position: If active, the event positions don’t refer to their absolute location 
within the project, but to their relative positions within the MIDI region (their distance from 
the start of the MIDI region).
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Protect the position of events
There are situations when you will want to protect certain events from being moved. For 
example, several note events may be used to trigger footstep samples that match an actor 
walking down a corridor, in a movie soundtrack. 

You have already created the music for this scene, but have been asked to increase the tempo to 
match several cuts of different camera angles in the corridor. A change in the project tempo will 
move the events, resulting in out-of-sync footsteps. Logic Pro X has a feature that preserves the 
absolute time position of events.

  The protect and unprotect functions are available only when   Show Advanced Tools is 
selected in the Advanced preferences pane.

Protect the position of one or more selected events
mm Choose Functions > Lock SMPTE Position (or use the corresponding key command).

This function ensures that events that fall at a particular absolute time position—1 hour, 
3 minutes, 15 seconds, 12 frames, for example—remain at this position when tempo changes 
are made.

Unprotect the position of one or more events
mm Choose Functions > Unlock SMPTE Position (or use the corresponding key command).

Change event values
You can change the event values shown in the Event List Value, Number, and Channel columns 
by using the mouse as a slider or with text input. You can not directly alter the event type in the 
Status column.

You can also rename regions or folders, but not events.

Alter the event type
Do one of the following:

mm Choose Functions > MIDI Transform, then choose a preset. 

The MIDI Transform window opens, allowing you to transform the event. For more information, 
see MIDI Transform window overview on page 467.

mm Add an event of the new type, then delete the original event.

Override the maximum or minimum value limitation
If a parameter of one of several selected events is altered, it affects the same parameter in all 
events within the selection group. When you alter parameter values in a group of selected 
events, the relative differences between parameter values remain unchanged.

Parameter values can only be altered until the (same) parameter value of one of the selected 
events has reached its maximum or minimum value.

mm Option-drag the value. 

This technique allows you to continue altering a parameter value in a multiple selection, even 
when one of the selected events has reached its maximum or minimum value. 
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Set a parameter to the same value for all selected events
mm Hold Shift-Option while dragging the value.

Note:  It’s possible to select different event types, and simultaneously alter the Number or Value 
parameter. However, this can lead to unexpected results. It’s recommended that you use the 
event type buttons to hide non-matching event types. The enhanced selection functions may 
also be useful when creating or editing groups of events.

Mute and delete regions and events
The Mute and Delete functions go hand in hand, because you will often want to remove events 
you have muted.

Mute or unmute one or more selected note events
mm Select one or more note events, then choose Functions > Mute Selected Events on/off (default 

key command assignment: M).

A dot appears in the Status column of muted note events.

The Edit > Select > Muted Events command is also available in the Event List. It can be used to 
quickly select and delete all muted events.

Delete events
Do one of the following:

mm Select the events, then press Delete.

mm Choose one of the commands in the Edit > Delete MIDI Events menu.

•• Duplicates (default key command assignment: D): Erases all duplicate events.

•• Inside or Outside Locators: Erases all MIDI events inside/outside the locators.

•• Outside Region Boundaries: Erases all MIDI events that fall completely outside the region 
borders, which can happen when regions are resized.

•• Unselected Within Selection: Erases all unselected MIDI events within a selection, such as 
between locators.
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Event Types

Note events
Note events are used to trigger (play) software instruments and external MIDI sound modules 
or keyboards.

•• Ch(annel): MIDI channel of a note from 1 to 16.

•• Num(ber): MIDI note number (or pitch). The range is from C −2 (note #0) to G8 (note 
#127). Middle C is note #60. It’s known as C3 in MIDI terminology. On some keyboards and 
synthesizer modules (notably those made by Korg and Roland), the note range is from C −1 
(note #0) to G9 (#127). Middle C is called C4 on such devices. The Display Middle C As pop-up 
menu in the Logic Pro > Preferences > Display pane allows you to alter the display to match 
your device.

•• Val(ue): Velocity of a note from 1 to 127. The zero value (0) acts as a note off message, and 
cannot be used.

•• Length/Info: Length of the note. Although MIDI can only transfer note on or note off messages, 
Logic Pro X stores the position and length of all notes, which makes them easier to access 
musically. The note off message is generated automatically during playback.

If the edited MIDI region is played through a mapped instrument, the names defined for each 
individual note appear in the Status column. A small note symbol to the left of each name aids in 
identifying these named events as note events.
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View and change note release velocity data
You can edit the release velocity of a note event when the Additional Info button is on. 

mm Click the Additional Info button (only available in Filter mode).

Control change events
Control change events are used to transfer MIDI controller information (modulation, sustain, 
volume, and pan, for example) to software instruments or external MIDI keyboards and modules.

•• Ch(annel): MIDI channel of an event from 1 to 16.

•• Num(ber): The number of the controller. Each MIDI controller (such as the modulation wheel 
or sustain pedal) is assigned a specific Continuous Controller (CC) number (CC#1 or CC#64, 
respectively). This can vary from device to device. Several controllers (apart from the two 
above) are defined in the same way by most manufacturers; these standardized controllers 
include volume (CC#7) and pan (CC#10).

•• Val(ue): Value of the controller. Continuous controllers have a range of 0 to 127. Switch 
controllers (CC#64–CC#90) transfer two states: off (val = 0) and on (any value between 1 and 
127).

•• Length/Info: Shows the name of standardized controllers defined in the MIDI Specification.

Pitch bend events
Pitch bend events are used to continuously vary the pitch. They are usually generated by a 
centered pitch bend wheel or joystick on your keyboard.

•• Ch(annel): MIDI channel of an event from 1 to 16.

•• Num(ber): Fine pitch bend division (LSB: Least Significant Byte). Many keyboards transmit 
a value of 0. If the pitch bend wheel has an 8-bit resolution, you see values of 0 or 64 in 
this column.

•• Val(ue): The effective pitch value (MSB: Most Significant Byte), ranging from 0 to 127. A value of 
64 corresponds to the half-way setting of the wheel.

•• Length/Info: The 14-bit value is displayed in this column as a decimal figure ranging from −8192 
to 8191 (if your keyboard transmits 14-bit pitch bend data). The value in this column can be 
edited in the usual ways.
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Program change events
Program change events transmitted to connected MIDI devices are used for patch (preset or 
setting) selection. These may be sounds in a synthesizer, programs in an effects unit, or snapshots 
in an automated mixing desk, for example.

•• Ch(annel): MIDI channel of an event from 1 to 16.

•• Num(ber): Bank select. Normally you will see this symbol (-), which indicates no bank select 
message will be sent. If you assign a number between 0 and 126, a bank select event is sent 
before the program change event.

Bank select lets you address different sound banks (preset, internal, card, and so on) of 
connected MIDI keyboards and modules. The synthesizer must be able to recognize controller 
32 as bank select, but this standard is not used by all manufacturers.

If you have problems with bank select, check your synthesizer’s manual to see whether, and 
how, it responds to bank select commands.

•• Val(ue): A program number between 0 and 127. 

•• Some manufacturers (such as Yamaha) number the programs in their devices from 1 to 128, 
not 0 to 127. If you have devices that follow this numbering protocol, you need to subtract 
1 from the program number shown on the device itself, when adding or altering a program 
change event.

•• Other manufacturers use various methods of dividing internal memory locations into groups 
(or banks) and sounds. The most common is divisions into 8 groups of 8 sounds, each 
numbered 1 to 8. These devices respond to program numbers 0 to 63 by addressing storage 
locations 11 to 88. The instruction manuals for these devices should contain conversion 
tables to assist you.

Note:  You can change the type of bank select messages sent by Logic Pro, if necessary for your 
devices. For more information, see Custom bank selects on page 784.

Aftertouch events
Aftertouch (or channel pressure) events are generated by a mechanical pressure sensor beneath 
some MIDI keyboards. These events can be used to modulate the synthesizer sound. All note 
events on a particular MIDI channel are affected. This means that applying pressure to one note 
in a held chord affects all notes in the chord.

•• Ch(annel): MIDI channel of an event from 1 to 16.

•• Num(ber): This column is unused, as aftertouch events only have one data byte.

•• Val(ue): Displays the amount of pressure on the keyboard (0 to 127).
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Poly pressure events
Poly(phonic) pressure events are generated by mechanical pressure sensors beneath each 
individual key on some MIDI keyboards. The resulting sound modulation only affects the 
particular note that is pressed harder (after the initial keystrike). Only a few keyboards offer 
this capability.

•• Ch(annel): MIDI channel of an event from 1 to 16.

•• Num(ber): Displays the MIDI note name (C3, G4, and so on).

•• Val(ue): Displays the amount of pressure on the key (0 to 127).

SysEx events
System exclusive data (SysEx) is unique to individual MIDI devices. You can record these events 
by using the dump utilities of your synthesizers, which lets you save patch information, or other 
data, outside the MIDI device (in a project or MIDI file). The arrows in front and behind EOX are 
used to add or remove bytes.

WARNING:  Editing SysEx events requires a thorough understanding of the data format used by 
the MIDI device. Incorrect edits can lead to the corruption, or loss, of sound or other data.

You can choose whether SysEx data is displayed in hexadecimal or decimal format in the Event 
List or the SysEx fader editors. Hexadecimal digits are preceded by a $ symbol in Logic Pro.

View SysEx data in hexadecimal format
mm Choose View > SysEx in Hex Format.

For more information on manually programming a SysEx message, see Work with SysEx faders on 
page 799.
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Meta events
Meta events are control messages that are specific to Logic Pro. They are used to automate 
certain functions, and to organize and arrange Score Editor elements (particular notation 
symbols and formatting) that can’t be represented by MIDI events.

The value in the Number column determines the meta event function, and the value in the Value 
column determines the value that is sent. You should only ever insert and edit the following 
column values in the Event List.

•• Ch(annel): MIDI channel of an event from 1 to 16.

•• Num = 47 (Send Byte to MIDI): This sends the track instrument any byte value (Val) between 0 
and 255 ($00-$FF). As a usage example of this meta event: If you send 246 as the byte, this is 
equivalent to a MIDI tuning request message. The display will show Send Byte $F6. Only use 
this meta event if you know what you’re doing—if you don’t, your sound modules and synths 
may start to behave very oddly. 

•• Num = 48 (Switch Fader): This sends MIDI events to a particular output number (Val) on a cable 
switcher. You first need to connect a cable between a track instrument and the cable switcher 
in question. For details about cable switchers, see Cable switchers on page 797.

•• Num = 49 (Go to screenset): This event selects a screenset. Val determines the screenset number. 

•• Num = 50 (Project Select): This event switches projects on a MIDI data filer or player. Val 
determines the stored project number. 

•• Num = 51 (Go to Marker): When this event is sent, playback jumps to another marker. Val 
determines the marker number. 

•• Num = 52: This meta event stops playback.

Meta events can also be generated by fader objects in the Environment. See 
Environment overview.
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Event Float window
The Event Float window provides information on the currently selected event (or region), and 
can be compared with a single line of the Event List. You can edit the following parameters in 
this window.

•• The start point of the selected event or region in bars, beats, divisions, and ticks, or SMPTE time

•• The type or name of the selected event or region

•• The recorded MIDI channel and first data byte (if an event), the name of notes, and the second 
data byte (if it exists for the event type)

•• The length of the selected event or region in bars, beats, divisions, and ticks, or SMPTE time

Open an Event Float window
mm Choose Window > Show Event Float (or use the Toggle Event Float key command, default 

assignment: Option-E).

Switch the Event Float window between SMPTE time and the bar/beat display
Do one of the following:

mm Open the Project Settings > General tab, then click “Project Type: Use musical grid” to show the 
time format in bars and beats. Click the checkbox a second time to clear it (unchecked), which 
displays the time format in minutes and seconds.

mm Choose View > Show Event Position and Length as Time in the Event List. This only applies when 
“Use musical grid” is active.
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Step Editor

Step Editor overview
The Step Editor is a graphical editor that can be used to create or edit MIDI note and controller 
data. You can use the Step Editor to view and edit different MIDI event types, shown as vertical 
beams—or steps—along a timeline within a region. 

StepLane Set pop-up menu

LaneLane inspector

•• Step: Each beam, called a step, represents a MIDI event. The value of the event is denoted by 
the beam height, providing an at-a-glance view of one, or dozens, of different events and their 
values. For more information, see Create steps in the Step Editor on page 426 and Change step 
values in the Step Editor.

•• Lane: Each MIDI event type, be it a note or MIDI controller, is arranged from top to bottom in 
horizontal lanes much like the track lanes shown in the Tracks area. The type of event shown, 
and controlled, on each lane is freely configurable. You do this by setting Lane parameters (for 
each lane) in the inspector. For more information, see Lane parameters overview on page 433.

•• Lane inspector: Use to alter the settings of the selected lane. For more information, see Use the 
Lane inspector on page 436.

•• Lane Set pop-up menu: You can save groups of lanes (several lanes that you have defined) 
as Lane Sets. You access these from the Lane Set pop-up menu in the inspector. For more 
information, see Use Lane Sets on page 439.

Open the Step Editor as a pane
mm Click the Editors button in the control bar, then click the Step Editor button (or use the Toggle 

Step Editor key command, default assignment: Y).
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Open the Step Editor as a separate window
Do one of the following:

mm Choose Window > Open Step Editor (or use the Open Step Editor key command, default 
assignment: Command-5).

mm Drag the Step Editor button, which changes to the Step Editor window as you drag it.
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Create and edit steps in the Step Editor

Change the grid and step display
The Grid parameter in the Lane inspector is important when creating event steps. Newly created 
events are automatically added at grid positions. This makes it easy to create a drum pattern, 
with 4 divisions on one lane, 8 divisions on another lane, and 16 divisions on another lane, 
assigned to kick, snare, and hi-hat sounds, for example.

Define the grid value for the selected lane
mm Choose a grid type from the Grid pop-up menu in the inspector.

Steps that you add snap automatically to the nearest grid position. The positions of existing 
steps are not affected.

Tip:  When editing or constructing complex rhythm patterns, it can be useful to create several 
lanes (see Create lanes on page 433) for one drum note, each with a different quantization grid. 
For example, if there are two lanes for a snare drum, one with a 1/16 and the other with a 1/96 
grid, you can use the Pencil tool to add individual hits in the coarser grid, and drum rolls in the 
finer grid.

You can change the appearance of event steps to make event creation and editing easier.
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Set the width of event steps
mm Choose a pen width value in the inspector.

The exact step position is always aligned with the left edge of the step, regardless of the 
beam width.

When you set the Pen Width parameter to Note Length, note event steps are displayed at their 
actual length. The Status parameter must be set to Note for this to work.

Change the style of step beams
mm Choose a setting from the Style pop-up menu. 

•• No Frames: Shows the value of the event as a colored beam.

•• Framed Values: Shows a hollow frame that is the full height of the lane. The value of the event 
is displayed as a colored beam within the frame.

Framed Value event

No Frame event
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Create steps in the Step Editor
The Step Editor provides several unique methods for creating and editing MIDI events. In some 
situations, manual entry of MIDI note and controller events is more efficient than performing and 
recording them. One example would be the creation of 1/16 note hi-hats in a region when the 
tempo is 180 bpm, which would be difficult to play.

You can also record events with a MIDI keyboard, and then refine your performances in the 
Step Editor.

Add a step
	 1	 Select the Pencil tool.

	 2	 Command-click a time position on the appropriate lane.

	 3	 Drag up or down to alter the event value before you release the mouse button. 

Add multiple steps
mm With the Pencil tool, Command-drag horizontally over the time position on the appropriate lane. 

This action results in a freehand curve of new events that follows the (vertical and horizontal) 
Pencil tool movements in the lane.
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Edit multiple steps in a linear fashion
	 1	 Select the Line tool.

	 2	 Command-click a position on the lane. 

A help tag appears, showing the exact position and event (step) value in the top line.

	 3	 Move the mouse to the end point of the line. This can be to the right or left. 

As you move the mouse, you see a line trailing behind the Line tool, with the exact position and 
event value shown in a help tag.

	 4	 Click the end point to change the values of several event beams, aligned along the line.

Create or alter a linear series of steps in sections
	 1	 Select the Line tool.

	 2	 Command-click a position on the appropriate lane. 

A help tag appears, showing the exact position and event value in the top line.

	 3	 Move the mouse to the end point of the line (to the right or left). 

As you move the mouse, you see a line trailing behind the Line tool, with the exact position and 
event value shown in a help tag.

	 4	 Command-click the end point.

Another line is immediately drawn from the end point of the original line. 
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Create new events when other events already exist in a lane
	 1	 Select the Line tool.

	 2	 Click a position on the appropriate lane. 

A help tag appears, showing the exact position and event value in the top line.

	 3	 Move the mouse to the end point of the line (to the right or left). 

As you move the mouse, you see a line trailing behind the Line tool, with the exact position and 
event value shown in a help tag.

	 4	 Option-click the end point.

The values of existing events in the area between the line start and end points are aligned 
along the line (creating a crescendo, for example). New events are created at every (unoccupied) 
grid value.

Assign a fixed step value
You can assign a fixed value when creating event steps. When enabled, the Fix Value item in 
the Lane Set pop-up menu prevents any event value from being altered with the Pointer or 
Pencil tool.

This is ideal when adding steps with the Pencil tool, as all are assigned the value of the 
previously selected event. This allows you to draw a succession of events with the same value, 
such as a row of 1/16 note hi-hats, for example.

	 1	 Choose Fix Value in the Lane Set pop-up menu.

	 2	 Click any existing event with the Pencil tool to use its value as a preset. 

In Fix Value mode, it’s impossible to alter an event value by clicking it.

Note:  When adding events with the Line tool in Fix Value mode, the preset value is always used 
as the starting value of the line.
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Select steps in the Step Editor
You can use any of the usual selection techniques in the Step Editor, with the 
following variations.

Select individual steps
mm Hold Shift, then click the steps in a lane.

Select several contiguous steps
mm Hold Shift, then drag to select the steps in a lane.

Take care to avoid clicking any steps. If you click or drag with the unmodified Pointer tool, the 
selected event values are changed, so make sure you hold down Shift.

Select all steps on a lane
mm Click the lane name. 

Select all steps on multiple lanes
mm Shift-click the lane names. 

Delete steps in the Step Editor
You can use any of the standard deletion techniques to delete events in the Step Editor.

Delete a step
Do one of the following:

mm Click the step with the Eraser tool.

mm Click the step, then press Delete.

Delete several contiguous steps in a lane
mm Drag across the steps you want to delete with the Eraser tool.

Delete several noncontiguous steps
mm Shift-click the steps you want to remove, then press Delete.

Delete similar or equal steps
	 1	 Select one of the steps you want to delete.

	 2	 Use the Select Similar Regions/Events (Shift-S) or Select Equal Regions/Events (Shift-E) key 
command, then press Delete.

You can also delete events by choosing one of the Delete MIDI Events commands from the Step 
Editor menu bar. For more information, see Delete notes in the Piano Roll Editor on page 360.
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Restore deleted steps in the Step Editor
Accidental deletions of one or more events, a change of mind, or an editing mistake are 
inevitable parts of song creation. Fortunately, you can backtrack your edits easily in Logic Pro. You 
also have the option of re-creating an event with the Pencil tool.

Undo the last edit or deletion
mm Choose Edit > Undo (default key command: Command-Z) immediately after making the error.

Undo or redo multiple steps
	 1	 Choose Edit > Undo History. 

The Undo History window appears. The most recent edit (at the bottom of the list) is highlighted.

	 2	 Click any entry to undo or redo all edits between the clicked and highlighted entries. 

Important:  A Redo list is not displayed until an Undo operation has been performed.

The Redo list appears below the Undo items. The first item that can be redone is indicated by 
gray text.

Undo or redo an isolated edit operation
	 1	 Command-click the edit operation you want to change. 

A warning dialog appears.

	 2	 Click Apply to undo or redo the edit operation. Click Cancel if you change your mind.

When the operation is applied, an isolated edit is undone or redone without influencing all edit 
operations between the clicked and highlighted (most recent) entries.

Change step values in the Step Editor
Steps can be altered individually or as a group. When adjusted as a group, the absolute 
differences between event values remain constant. 

Alter individual step values
mm Grab the step beam (with the Pointer or Pencil tool), then drag vertically. 

The current value is shown in a help tag as you drag.

Alter several contiguous step values
mm Drag across the steps with the Pointer tool. Vertical movements affect the value of each step.

The current value is shown in a help tag as you drag across each event.

Alter the values of multiple steps
	 1	 Use any selection technique to select the steps you want to edit.

	 2	 Grab one of the grouped (and highlighted) steps, then drag vertically. 

The values of all steps are adjusted. If any of the beams in the group reaches the maximum or 
minimum value, you can’t go any farther in that direction.
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Move and copy steps in the Step Editor
Steps can be moved or copied to other positions in the same, or other, lanes. When moved or 
copied between lanes, the event values are retained, but are converted to the target event type. 
For example, moving several steps from the volume lane into the pan lane results in the volume 
lane step values being used for pan position changes.

Move selected steps
mm Hold down Shift, then drag the selected steps to the new position and lane. 

As you drag, a help tag displays the position, event type, and value (if applicable).

Move steps with key commands
mm Assign and use the following key commands to move one or more steps. The selected events are 

shifted one unit (referred to in the command) to the right (+1) or left (−1).

•• Nudge Region/Event Position Right by SMPTE Frame

•• Nudge Region/Event Position Left by SMPTE Frame

•• Nudge Region/Event Position Right by 1/2 SMPTE Frame

•• Nudge Region/Event Position Left by 1/2 SMPTE Frame

•• Nudge Region/Event Position Right by 5 SMPTE Frames

•• Nudge Region/Event Position Left by 5 SMPTE Frames

•• Nudge Region/Event Position Right by SMPTE Bit

•• Nudge Region/Event Position Left by SMPTE Bit

•• Nudge Region/Event Position Right by Tick

•• Nudge Region/Event Position Left by Tick

•• Nudge Region/Event Position Right by Division

•• Nudge Region/Event Position Left by Division

•• Nudge Region/Event Position Right by Beat

•• Nudge Region/Event Position Left by Beat

•• Nudge Region/Event Position Right by Bar

•• Nudge Region/Event Position Left by Bar

•• Nudge Region/Event Position Right by Nudge Value

•• Nudge Region/Event Position Left by Nudge Value

•• Nudge Region/Event Position Right by Sample

•• Nudge Region/Event Position Left by Sample

•• Nudge Region/Event Position Right by 1 ms

•• Nudge Region/Event Position Left by 1 ms

•• Nudge Region/Event Position Right by 10 ms

•• Nudge Region/Event Position Left by 10 ms

Copy selected steps
mm Hold down Option, then drag the selected steps to the new position and lane. 

As you drag, a help tag displays the position, event type, and value (if applicable).
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Copy and move steps with the Clipboard
mm You can also use the Clipboard to copy and move steps (events):

•• To copy events into the Clipboard: Choose Edit > Copy (or press Command-C).

•• To move events into the Clipboard: Choose Edit > Cut (or press Command-X).

•• To paste the events at the current playhead position, inclusive of their original values: Choose Edit 
> Paste (or press Command-V).

You can also perform advanced Copy and Move operations in the Step Editor. These allow you to 
directly swap steps, or to merge a group of events from one section of a region to the same, or 
another, region. For more information on common editing functions, see Copy notes in the Piano 
Roll Editor on page 352.

Protect the position of steps
There are times when you will want to protect certain steps from being moved. For example, 
several note events may be used to trigger footstep samples that match an actor walking 
down a corridor in a video soundtrack. You have already created the music for this scene, but 
have been asked to increase the tempo to match several cuts of different camera angles in the 
corridor. Any change to the project tempo will move the events, resulting in out-of-sync footstep 
samples. To circumvent this problem, Logic Pro has a feature that preserves the absolute time 
position of events.

  The protect and unprotect functions are available only when   Show Advanced Tools is 
selected in the Advanced preferences pane.

Protect the position of one or more selected steps
mm Choose Functions > Lock SMPTE Position (or use the corresponding key command). Events 

that fall at a particular absolute time position—1 hour, 3 minutes, 15 seconds, 12 frames, for 
example—will remain at this position when tempo changes are made.

Unprotect the position of one or more selected steps
mm Choose Functions > Unlock SMPTE Position (or use the corresponding key command).
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Lane parameters

Lane parameters overview
The Lane parameters determine the event type shown on each lane. Events are shown as vertical 
beams (steps) on each lane, aligned with a particular time position in the ruler.

You can use the Lane parameters to change the way beams are displayed (see Change the grid 
and step display on page 424). You can also alter the grid resolution for each lane in a Lane Set, 
which is useful when creating drum patterns. You adjust the height and horizontal size of the 
lanes with the zoom sliders.

You select a lane (and its parameters) by clicking the lane name with the Pointer or Pencil tool.

You can view and change Lane parameters in the inspector (see Use the Lane inspector on 
page 436).

Select multiple lanes
You can make simultaneous changes to the parameters of several selected lanes (for more 
information, see Use the Lane inspector on page 436).

mm Shift-click each lane name with the Pointer or Pencil tool. 

Create lanes
You can create new lanes, and set corresponding Lane parameters, in several ways.

Create a new lane
	 1	 Select a lane by clicking one of the names shown. 

The selected lane is highlighted.

	 2	 Choose Lanes > Create Lane (default key command: Option-Command-N). 

A new lane is created. The original lane, and all subsequent lanes, are moved down. The new lane 
parameters are identical to those of the originally selected lane.

	 3	 Adjust the parameters of the new lane in the inspector.

Create one or more specific lane types
You can use the Auto Define feature to automatically create lanes for specific event types in 
your project.

	 1	 Choose Auto Define from the Lane Set pop-up menu (or use the Toggle Auto Define key 
command, default assignment: Control-A).

	 2	 Open the Event List window, then click the events you want to create new lanes for.

The clicked events are added as lanes in the Lane Set.

	 3	 Repeat the second step to add more event types to your Lane Set.

If the Lane Set already contains a matching lane type (for a particular note pitch, as an example), 
Logic Pro will not create a superfluous lane. The existing lane is moved into the visible area of the 
Step Editor in this situation.

Note:  Make sure that you deselect Auto Define immediately after completing your input.
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Create lanes for all event types in a region
	 1	 Select the region.

	 2	 Choose Lanes > Create Multiple Lanes (or use the corresponding key command). 

	 3	 In the dialog that appears, click the All button to confirm that you want to create lanes for all 
types of events in the region.

Tip:  It’s a good idea to create a new Lane Set before creating a group of new lanes. For more 
information, see Use Lane Sets on page 439. 

Edit Lane parameters
You can copy, delete, reorganize, and convert lanes and their associated parameters when 
creating Lane Sets.

Tip:  Use the Select Next Step Lane or Select Previous Step Lane key commands to rapidly move 
between lanes.

Copy a set of Lane parameters between two Lane Sets
	 1	 Click the name of the lane you want to copy.

	 2	 Choose Lanes > Copy Lane (default key command: Control-C). 

	 3	 Switch to the destination Lane Set by choosing the Lane Set name in the pop-up menu at the 
top of the inspector.

	 4	 Choose Lanes > Paste Lane (default key command: Control-V).

Delete lanes
mm Select one or more lanes, then choose Lanes > Delete Lane (default key command: 

Control-Delete).

Rearrange the order of lanes
mm Grab the name of the lane that you want to move, then drag it (vertically) to the new position.
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Convert all events on a lane to another event type
You can redefine a lane (along with all event steps on the lane). The values of the events are 
retained, but the event type is changed.

	 1	 Click the name of the lane you want to convert.

All steps on the lane are selected.

	 2	 Do one of the following:

•• Choose Lanes > Convert Lane (or use the corresponding key command).

•• Double-click the name column of the lane that you want to convert.

	 3	 Choose settings in the Convert dialog.

In the Convert pane on the left, you can see the parameters of the selected lane. The “to” pane 
lets you set the parameters of the target lane. The current settings (of the source lane) are used 
as default values for the target lane.

Select the Quantize Events checkbox to quantize step positions to the grid value chosen in the 
right pane. If any delay value is shown on the right, this is taken into account by the quantization.

If you open the Convert dialog, change the grid value in the area on the right, and select the 
Quantize Steps checkbox (and make no further alterations), the step positions of the selected 
lane are quantized.

	 4	 Click Convert.
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Use the Lane inspector
You use the Lane inspector to change the parameters of the selected lane. The most important 
parameters are Status and First Data Byte. The Status parameter sets the event type for the 
selected lane. The First Data Byte parameter (shown as “Number” in the image) sets the value for 
the chosen event type. The appearance of the First Data Byte parameter changes when different 
event types are chosen. 

First Data Byte checkbox 
and pop-up menu

Name a lane
The name of the selected lane is shown beside the disclosure triangle in the inspector. This is 
mirrored in the Name column in the Step Editor. 

mm Select the name to open a text field, enter a name, then press Return.

Note:  If you define a named MIDI controller, or a note from a mapped instrument in the Status 
and First Data Byte parameter lines, the relevant name is automatically shown. Changing a note 
name in the inspector also alters the corresponding note name in the mapped instrument.

Delay or advance all steps on the selected lane
The inspector’s Delay parameter is very useful for drum programming (flams, for example), as 
only individual event types or note numbers are affected. It’s also useful for tightening up or 
sliding notes in a region, without resorting to quantization.

mm Set the Delay parameter to the value you want to use. 

Position changes are immediately reflected by the steps in the lane. New events (inserted when a 
grid was active) are offset from the grid positions by the Delay parameter value.

Tip:  In general, you should transmit controller data slightly before or after note events, to 
improve the timing of notes. In other words, place controllers before (use a negative delay value) 
the grid positions of the notes lying exactly on the grid positions.

Change the length of new steps
mm Drag the Length parameter values vertically to change the length of events (this primarily 

applies to note events) to be added, measured in divisions (the left number), and ticks (the right 
number).

You should avoid the use of small tick values because many MIDI devices do not respond quickly 
enough when note on/note off messages are sent in quick succession, resulting in no note 
being heard.
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Set the MIDI channel number for a lane
	 1	 Select the MIDI channel checkbox.

•• If selected, the display is restricted to events on the set channel.

•• If unselected, the Channel parameter is ignored, and matching events on all channels 
are displayed.

	 2	 Choose a MIDI channel number from the pop-up menu to the right of the Channel parameter.

Simultaneously change the parameters of multiple lanes
Just as you can adjust the parameters for several MIDI regions at once, you can set the 
parameters of several lanes simultaneously.

Do one of the following:

mm Hold Shift, then click several lanes in the Name column.

mm Choose Lanes > Select All Lanes, then deselect lanes you don’t want to change by 
Shift-clicking them.

Any alterations you make in the inspector affect all selected lanes.

Change the event type
The event status determines the type of event controlled by each lane.

mm Drag the event type shown beside the Status parameter vertically to choose one of the 
following:

•• Fader: Defines a fader event lane. Fader event data can be used to control any possible 
parameter (except channel volume and pan that use controllers). Fader data can also be used 
to create meta events.

•• Meta: Defines a meta event lane. Meta events are internal Logic Pro commands that can 
perform tasks such as screenset switching.

•• Note: Defines a lane for a particular note pitch (useful for drum programming).

•• Control: Defines a MIDI controller lane.

•• C-Press (Channel Pressure): Defines a lane for channel pressure (also known as aftertouch), a 
feature of many synthesizers that adds vibrato, for example, when you press down on MIDI 
keyboard keys that are already held.

•• P-Press (Polyphonic Pressure): As above, but each note can be independently modulated.

•• Program Change: Defines a lane that is used to create and send MIDI program change events, 
allowing you to switch between sounds (electric piano and clavinet, for example) midway 
through a region.

•• Pitch Bend: Defines a lane for pitch bend information.

Important:  The chosen Status parameter value (event type) directly affects the behavior (and 
appearance) of the First Data Byte parameter. For example, if Note is chosen as the Status 
parameter type, you can use First Data Byte to determine the pitch (MIDI note number) of the 
selected lane. If the MIDI region is played by a mapped instrument, a pop-up menu of input note 
names (drum sound names) appears here.
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Show the first data byte and set a value
The First Data Byte checkbox and pop-up menu are shown at the bottom of the inspector.

First Data Byte checkbox 
and pop-up menu

The name of the First Data Byte parameter reflects the chosen Status parameter, as follows:

•• Fader, Meta, Control, Program: A number is shown as the first data byte.

•• Note, P-Press: Pitch is shown as the first data byte.

•• C-Press and PitchBd: The first data byte is dimmed, as it has no function.

	 1	 Select the First Data Byte checkbox to show the defined first data byte. Select the box a second 
time (unselected) to hide the first data byte. In the case of note events, the velocity values of all 
notes (regardless of pitch) are displayed in the relevant lane.

	 2	 Choose a value from the First Data Byte pop-up menu. The choices shown in the pop-up menu 
depend on the parameter shown in the Status line:

•• If Control is chosen in the Status line, the First Data Byte pop-up menu determines the 
controller type (controller number).

•• If Meta or Fader is chosen in the Status line, the First Data Byte pop-up menu determines the 
meta or fader event type (meta or fader message number).

•• If channel aftertouch (C-Press), or program change events (Program) is chosen in the Status 
line, the First Data Byte parameter setting is ignored and the first data byte is displayed as a 
beam height.

•• When pitch bend data (PitchBd) is chosen in the Status line, the First Data Byte parameter 
setting is also ignored because both data bytes are used to display the beam height.
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Use Lane Sets
You can store a combination of lanes as a Lane Set. When a Lane Set is saved, the vertical zoom 
setting of the Step Editor is stored. You can save as many Lane Sets as required in each project.

The Lane Set functions let you limit the Step Editor display to only the required MIDI event types. 
For example, imagine you have recorded a synthesizer lead MIDI region. You could create a Lane 
Set that contains individual lanes for each note pitch in the region. Drag each note event step 
vertically to adjust its level. Within the same Lane Set, you could create two more lanes to control 
the lead synthesizer’s filter cutoff and resonance parameters, allowing you to create or precisely 
edit filter changes.

The Step Editor provides two default Lane Sets: MIDI Controls and GM Drum Kit.

•• MIDI Controls: Provides lanes for Volume, Pan, Modulation, and several other commonly used 
controller types.

•• GM Drum Kit: Provides lanes that match the note names of the General MIDI (GM) drum map. 
This option lets you draw note events (steps) for drum parts, and is similar to the use of 
pattern-based drum machines, where each beat is manually entered on a grid. You can use 
this Lane Set for any instrument type.

Switch between Lane Sets
You can switch the Step Editor display to show particular event types by loading an existing 
Lane Set.

mm Choose a Lane Set from the Lane Set pop-up menu in the inspector.

Create a Lane Set
Do one of the following:

mm Choose Lanes > New Lane Set from the Step Editor menu bar (or use the Lane Set pop-up menu, 
or corresponding key command).

The new Lane Set contains a default lane for the Volume controller (#7). Any changes you make, 
such as adding or changing lanes or lane parameters, or adjusting the vertical zoom setting, are 
automatically stored in the current Lane Set.

mm Choose Lanes > New Lane Set for Current Events (or use the Lane Set pop-up menu, or 
corresponding key command) to create a new Lane Set, consisting of the currently selected 
event types. 
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Create a Lane Set for a GM drum kit
General MIDI has an established keyboard assignment pattern (a MIDI note map) for drum and 
percussion sounds. This mapping standard is often followed in non-GM, GS, or XG compliant 
sound modules, samplers, and synthesizers. In some cases, however, you will need to make a 
few changes.

As the Step Editor is ideally suited for creating and editing drum kits, you may want to create a 
Lane Set that is specifically tailored for your drum sets, including the correct drum names and 
hi-hat modes. 

mm Choose Lanes > New Lane Set for GM Drums from the Step Editor menu bar (or use the Lane Set 
pop-up menu, or corresponding key command).

You can change the names, positioning, and hi-hat modes of each drum or percussion lane in 
the Lane Set. See Use the Lane inspector on page 436, for information on renaming each drum 
sound in your kit, if it doesn’t match the GM mapping standard.

Define a hi-hat group
In hi-hat mode, lanes can be grouped together. Only one event from grouped lanes can be 
played at any ruler position. This function is typically used to prevent different hi-hat notes (open, 
closed, pedal) from being inserted at the same time position. This mirrors the real-world behavior 
of hi-hats, which can’t be simultaneously opened and closed.

	 1	 Click the dot shown to the left of a lane name (Open HH, for example).

	 2	 Click the dot shown to the left of other (vertically adjacent) lane names (Ped HH, for example).

A dotted line links the two lanes in the left edge of the column.

	 3	 Click the dots of each lane to turn off hi-hat mode. 

All lanes in a hi-hat group must be vertically adjacent to each other. To group several events in 
nonadjacent lanes, move the lanes by dragging the names up or down the Step Editor window.

If you add an event to any lane in a hi-hat group, all existing events at this time position are 
deleted. 

You can create as many hi-hat groups as needed in a Lane Set, but each group must be 
separated by at least one lane that does not belong to a hi-hat group.

Rename a Lane Set
mm Choose Rename Lane Set in the Lane Set pop-up menu. Enter a new name, then press Return.
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Clear the current Lane Set
Clearing a Lane Set resets a Lane Set to its default, containing a single lane for the 
Volume controller.

Do one of the following:

mm Choose Lanes > Clear Lane Set from the Step Editor menu bar (or use the corresponding key 
command).

mm Choose Clear Lane Set from the Lane Set pop-up menu in the inspector.

Delete the current Lane Set
Do one of the following:

mm Choose Lanes > Delete Lane Set from the Step Editor menu bar (or use the corresponding key 
command).

mm Choose Delete Lane Set from the Lane Set pop-up menu in the inspector.
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Audio File Editor

Audio File Editor overview
Most day-to-day audio editing tasks are performed in the main window and Audio Track Editor. 
The Audio File Editor is useful for removing pops and clicks in audio material, setting accurate 
crossover points for looped playback, correcting phase cancellation errors, and more.

You use the Audio File Editor to work with transient markers that indicate significant points—or 
transients—in an audio file. The audio on a track is analyzed for transients the first time you 
enable that track for Flex Time editing. Any detected transients in the file are marked.

Important:  Most edits and functions performed in the Audio File Editor are destructive. This 
means the actual data of audio files is changed. Although you can undo edits and processing 
commands, you should work with copies of your audio files, rather than the originals.

Open the Audio File Editor
Do one of the following:

mm Click an audio track header, click the Editors button in the control bar, then click File.

mm Select an audio region in the main window, then choose Open Audio File Editor from the 
Window menu.

mm Option-double-click an audio region in the Project Audio Browser.

Audio File Editor interface

Audio File Editor interface overview
The Audio File Editor contains the following elements.

Waveform display

Region area

PlayheadAnchor

Amplitude scale

RulerInfo displayCycle button

Prelisten button

Transient Editing Mode button

•• Waveform overview: Shows a miniature view of the entire audio waveform. Click different parts 
to focus them in the waveform display underneath.

•• Waveform display: Shows a detailed view of the waveform area selected in the 
waveform overview.

•• Transient Editing Mode button: Analyzes the audio file for transient events, and marks them. You 
can increase or decrease the number of events detected using the +/– buttons.

•• Catch Playhead button: Reflects the current playback position.
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•• Tool menus: Choose two tools from the pop-up menus. The second (alternate) tool is chosen 
with the Option key.

•• Play button: Starts and stops playback of the selected file, region, or loop.

•• Cycle button: Loops playback of the selected area.

•• Zoom sliders: Drag to adjust the vertical and horizontal zoom level.

•• Info display: Shows the start point and length of the selected area.

•• Ruler: Shows the position of the region in the project. If you have not yet added the audio file 
to your song, the position marker lines are dotted, indicating no time connection exists.

•• Region marker: Indicates the length of the region. Edit this beam to adjust the region length.

•• Anchor: Indicates the absolute start point of the audio file.

•• Amplitude scale: Indicates the amplitude of the audio waveform as a percentage or in 
sample units.

Change the waveform display
You can switch the waveform from its usual view to one that shows the structure of the recorded 
digital data. This view is useful when you are eliminating clicks and pops from your recordings, 
for example.

Normal waveform display
Waveform displayed as 
sample bits

Display the waveform as sample bits
mm Choose View > Show as Sample & Hold from the Audio File Editor menu bar. 

Note:  You need to zoom the waveform display to high magnification levels to see sample bits.
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Change the waveform amplitude scale
You can customize the waveform’s amplitude scale (plotted along the vertical axis), so that it’s 
displayed in percentage units or sample units.

Percentage units Sample units

Display the amplitude scale in percentage units
mm Choose View > Amplitude Percentage from the Audio File Editor menu bar.

Display the amplitude scale in sample units
mm Choose View > Amplitude Sample Value from the Audio File Editor menu bar.

Tip:  You can also open the amplitude scale shortcut menu by Control-clicking the waveform 
amplitude scale itself.

Change the ruler display
There are two display modes for the Audio File Editor ruler.

•• Absolute mode: References the time axis of the project.

•• Relative mode: References the beginning of the audio file.

You can also customize the ruler so that it’s displayed in samples, Min:Sec:Ms, SMPTE Time, or 
Bars/Beats.

The scale units in the ruler are displayed with solid white lines when you view the time scale 
according to its absolute position. When you view the time scale according to its relative 
position, the scale units are dotted (indicating that no time connection exists).
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Use relative display mode
Do one of the following:

mm Open the Audio File Editor from the Project Audio Browser (double-click the region in the Project 
Audio Browser).

mm Choose Content from the Audio File Editor’s View > Link submenu, then select a region in the 
Project Audio Browser.

The start position of the section is automatically assigned to the 0 value, or a value of 1 1 1 1 if 
set to Bars/Beats. The scale unit lines are dotted.

Use absolute display mode
Do one of the following:

mm Open the Audio File Editor in the Logic Pro main window.

mm Choose Content from the Audio File Editor’s View > Link submenu, then select a region in the 
main window.

Time is measured from the start of the project and is assigned a value of 0, or a value of 1 1 1 1 if 
set to Bars/Beats. In this mode, the absolute (project) time is shown in the ruler.

Change the Audio File Editor ruler time scale
mm Choose one of the following scaling units from the Audio File Editor’s View menu:

•• Samples: Displays the number of sample words.

•• Min:Sec:Ms: Displays the absolute scale in hours, minutes, seconds, and milliseconds.

•• SMPTE Time: Displays the SMPTE scale in hours, minutes, seconds, and frames.

•• Bars/Beats: Displays the scale in bars, beats, divisions, and ticks—just like the ruler in 
other windows.

Tip:  You can also access these options via a shortcut menu by Control-clicking the ruler.
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Play audio files in the Audio File Editor
There are a number of playback options in the Audio File Editor. Playback of audio files in the 
Audio File Editor occurs independently of the project playhead position. To hear the audio file in 
the context of your arrangement, you should use the control bar buttons.

The Mixer’s Prelisten channel strip is used for monitoring in the Audio File Editor. You can access 
the Prelisten channel strip by clicking the All button in the Mixer menu bar. The Prelisten channel 
strip is located to the right of the highest-numbered audio channel strip.

Important:  Some audio interface hardware can layer direct current (DC) over the audio signal. 
This results in a vertical shift of the waveform position that can be clearly seen in the Audio 
File Editor. It can also cause crackling sounds at the start and end of the audio region during 
playback. Choose Functions > Remove DC Offset to center the waveform around the zero 
amplitude line.

Audio File Editor playback key commands
You can use the following key commands to enhance your playback options:

•• Play/Stop All: Plays back the whole audio file, regardless of the selected area.

•• Play/Stop Region: Toggles between playback of the region start and end points—regardless of 
the selected area. 

•• Play/Stop Region to Anchor and Play/Stop Region from Anchor: Allow you to check the region 
anchor position by listening to the parts just before and after the anchor.

Control playback with the Prelisten button
	 1	 Control-click the Prelisten button, then choose an option from the shortcut menu:

•• Auto-select Channel Strip: Plays the region displayed in the Audio File Editor through the audio 
channel strip assigned to the region’s source track (shown in the main window).

•• Prelisten Channel Strip: Plays back using the Prelisten channel strip. You can access the 
Prelisten channel strip in the Environment’s Mixer layer. It’s located to the right of the highest-
numbered audio channel strip.

	 2	 Click the Prelisten button (or use the Play/Stop Selection key command, default 
assignment: Space bar) to start playback.

	 3	 Click the Prelisten button (or use the Play/Stop Selection key command, default 
assignment: Space bar) to stop playback.

Control playback with the ruler
mm Double-click the ruler at the point where you want playback to begin. A second double-click 

stops playback.
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Control playback with the waveform overview
Do one of the following:

mm Click-hold at the point where you want playback to begin. The pointer turns into a Prelisten icon. 
Release the mouse button to stop playback.

mm Double-click at the point where you want playback to begin.

Scrub audio
mm Click-hold the ruler and move the pointer. 

Audio playback follows the speed and direction of your pointer. This technique helps you to 
quickly locate a particular position within an audio file.

Repeat the selected area continuously
	 1	 Click the Cycle button. 

	 2	 Click the Prelisten button (or use the Play/Stop Selection key command, default 
assignment: Space bar).

You can change the start and end points of the selected area during looped playback, to create 
a perfect drum loop cycle, for example. When you’re satisfied with the loop, you can make the 
selected area a new region.
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Navigate audio files in the Audio File Editor
You can use the Audio File Editor navigation features to move to specific parts of an audio file, 
making selection and editing simpler, faster, and more accurate.

Clicking the waveform overview displays the selected area (surrounding the playhead position) 
in the waveform display. The scroll bars and zoom controls are used in the same way as in 
other windows.

Use Edit menu navigation commands
Choose one of the following Edit > “Go to” menu commands to quickly navigate to a specific 
position in an audio file.

mm Selection Start (default key command: Control-Shift–Left Arrow)

mm Selection End (default key command: Control-Shift–Right Arrow)

mm Region Start (default key command: Control–Left Arrow)

mm Region End (default key command: Control–Right Arrow)

mm Region Anchor (default key command: Control–Down Arrow)

mm Previous Transient (default key command: Command–Left Arrow)

mm Next Transient (default key command: Command–Right Arrow)

Navigate to the loudest point in an audio file
The Audio File Editor includes a feature that scans a selected audio file for its loudest point. When 
it locates the loudest point, it positions the playhead at this point in the waveform display.

mm Choose Functions > Search Peak (default key command: Shift-P).

Navigate to silent passages in an audio file
You can scan a selected audio file, or a selection, for sections containing silence. When the Audio 
File Editor locates sections containing silence, it moves the playhead to the start point of the first 
silent section.

mm Choose Functions > Search Silence (default key command: Shift-S).

This command can be used repeatedly to select and remove, or to modify, silent sections in your 
audio files.



	 Chapter  15    Advanced edit features	 449

Make selections in the Audio File Editor

Make basic selections
Editing and processing audio in the Audio File Editor are possible only after you select an 
area within the waveform display. Any editing or processing you perform will only affect the 
selected area.

The start point and length of the currently selected area are shown in the info display—above 
the waveform overview. The format of the information is based on the setting chosen in the View 
menu. For more information, see Change the ruler display on page 444.

Info display

Use the basic selection techniques outlined below to select an entire audio file, or part of an 
audio file, for editing or processing.

For tips about accelerating the selection process, see Navigate audio files in the Audio File 
Editor on page 448.

Select the entire audio file
mm Choose Edit > Select All (default key command: Command-A).



	 Chapter  15    Advanced edit features	 450

Select a section of an audio file
mm Click-hold the start or end of the area you want to select in the waveform display, then drag to 

the right or left.

The start point and length are displayed (as sample words) in a help tag while you make 
your selection.

Extend an existing selection area
Do one of the following:

mm Choose Edit > Select All Previous (or use the corresponding key command).

mm Choose Edit > Select All Following (or use the corresponding key command).

Define the selected area using a region
mm Select a region in the Browser or main window, then choose Edit > Region → Selection.

This function is useful if you want to reselect the entire region for cycled playback—after 
performing a number of edits, for example.

The reverse can also be done, allowing you to redefine the length of an existing region by 
choosing Edit > Selection → Region.

You can modify selections by changing their start or end point, or you can move the entire 
selected area completely.

Note:  If you choose Edit > Snap Edits to Zero Crossings, any length adjustments to audio region 
start or end points will snap to the nearest zero-crossing point of the waveform.
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Change the start or end point of an existing selection
Do one of the following:

mm Shift-click in the waveform display to move the start or end point. 

mm Shift-click-drag the start or end point of the selected area in the waveform display.

Using either method, the proximity of your click—to the start or end of the selected area—
determines whether you change the start or end point boundary. The closest one wins.

Tip:  If you hold down Option-Shift, the more distant selection boundary is changed (rather than 
the nearer).

Move the selected area
mm Option-click in the waveform display (the pointer turns into a two-headed arrow), then drag to 

move the whole selection, without changing its length.
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Use transient markers to make selections
You can use transient markers to select part of an audio file for editing purposes.

Note:  To do this, you first need to turn on Transient Editing mode in the Audio File Editor. For 
more information, see Use transient markers to edit on page 455.

Select a section of an audio file between two transient markers
mm Double-click the area of the waveform display between the two transient markers.

Use transient marker menu commands
mm Choose Edit > Set from the Audio File Editor menu bar to use the following commands:

•• Selection Start to Previous Transient: The selection start is extended to the left, up to the 
preceding transient marker.

•• Selection Start to Next Transient: The selection start is shortened to the right, up to the following 
transient marker.

•• Selection End to Previous Transient: The selection end is shortened to the left, up to the 
preceding transient marker.

•• Selection End to Next Transient: The selection end is extended to the right, up to the following 
transient marker.

•• Selection Start and End to Previous Transient: The selection start and end are both moved to the 
left, up to the preceding transient marker.

•• Selection Start and End to Next Transient: The selection start and end are both moved to the 
right, up to the following transient marker.

•• Selection Start and End to Previous Transient and Play: The selection start and end are both 
moved to the left, up to the preceding transient marker, then playback begins.

•• Selection Start and End to Next Transient and Play: The selection start and end are both moved 
to the right, up to the following transient marker, then playback begins.
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•• Region Anchor to Previous Transient: The region anchor is moved to the left, up to the preceding 
transient marker.

•• Region Anchor to Next Transient: The region anchor is moved to the right, up to the following 
transient marker.

Use a selection to set the project tempo
Just like automatic tempo matching functions in the main window, you can set the project 
tempo to match the current locator positions and selected area in the Audio File Editor.

Although this operation is similar to the one described in Match the tempo to an audio 
region on page 592, it applies only to the selected area of the audio file in the Audio File Editor, 
rather than to the overall length of the region.

Use an audio file selection and locators to set the project tempo
	 1	 Click-hold the start or end of the area you want to select in the waveform display, then drag to 

the right or left.

	 2	 Adjust the locator positions in the control bar or ruler, if necessary.

	 3	 Choose Functions > Adjust Tempo by Selection and Locators.

The project tempo changes in accordance with the current locator positions and selected area in 
the Audio File Editor.
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Edit and process audio in the Audio File Editor

Audio File Editor edit commands
The Audio File Editor includes several standard audio editing and processing commands 
and functions.

When you have selected an area of an audio file, you can use the Cut, Copy, Paste, and Delete 
commands in the Edit menu to cut, copy, paste, or remove the selected area.

Edit menu commands
•• Cut: Cuts a selected passage out of an audio file, and copies it to the Clipboard. All audio 

sections that follow move forward—toward the start point of the audio file—to fill the gap.

•• Copy: Copies a selected passage to the Clipboard, leaving the selected area in its original 
location. Unlike the other Edit menu commands, the Copy command is nondestructive.

•• Paste: Inserts the contents of the Clipboard at the clicked position. All audio data that follows 
the paste (insert) point is moved back—toward the end of the audio file—to make room for 
the Clipboard contents.

WARNING:  Anything selected at the time of the paste is deleted—replaced by the 
Clipboard contents.

•• Delete: Erases the selection, without placing it in the Clipboard. A gap is left in the audio file.

•• Delete and Move: Erases the selection, without placing it in the Clipboard. All data beyond the 
deleted passage is moved forward—toward the start point of the audio file—to fill the gap.

Most audio editing and processing activities in the Audio File Editor are destructive. Destructive 
activities modify the data of the original audio file, rather than make changes to playback 
parameters. You can, however, use the Undo feature (see Undo edit steps on page 464).

Tip:  Although you can undo edits and processing commands, you should work with copies of 
your audio files, rather than the originals. For details about creating and restoring backups in the 
Audio File Editor, see Perform manual backups on page 464.

You can use key commands to perform destructive sample editing functions. When doing so, you 
will be asked to confirm your actions before making any changes and overwriting the original 
audio file. You can bypass this safety feature.

Turn off the key command warning
mm Choose Preferences > Audio > Audio File Editor, then deselect the “Warning before processing 

function by key command” checkbox.
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Use transient markers to edit
You can use transient markers to edit selected areas of an audio file, or the entire file, in the 
Audio File Editor. You can also add or move transient markers within audio files. You do all of 
these tasks in Transient Editing mode.

Note:  When you’re working in Transient Editing mode, the Command-click tool changes its 
default value, from the Hand tool to the Pencil tool.

Turn on Transient Editing mode
Do one of the following:

mm Choose View > Transient Editing Mode from the Audio File Editor menu bar (or use the Toggle 
Transient Editing Mode key command).

mm Click the Transient Editing Mode button in the Audio File Editor.

When you turn on Transient Editing mode, the audio file is analyzed for transient events, and all 
detected transients are marked in the audio file.

Detected transients

The level of transient detection confidence is based on the clarity of the transients. If an audio 
file does not have clear, sharp transients, transients will be detected with a lower level of 
confidence. You can display more or fewer transients by using the Plus and Minus (+/−) buttons.
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•• Plus button (+): Increases the number of transients in the selected area of the audio file, or 
across the entire audio file. You can also use the Increase Number of Transients key command, 
default assignment: Command-Plus (+).

•• Minus button (−): Decreases the number of transients in the selected area of the audio file, or 
across the entire audio file. You can also use the Decrease Number of Transients key command, 
default assignment: Command-Minus (−).

Create a transient marker in an audio file
mm Click the waveform display with the Pencil tool.

A transient detection process is started for the audio material around the clicked position, and 
the transient with the highest energy becomes valid and is marked. If no transient is found in the 
catch area, a transient marker is created at the clicked position.

Move a transient marker in an audio file
mm Drag an existing transient marker to another position.

Note:  The new position may or may not snap to zero crossings, depending on whether or not 
Snap Edits to Zero Crossings is chosen in the Edit menu. You can also Control-click to open a 
shortcut menu and choose Snap Edits to Zero Crossings.
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Delete transient markers from an audio file
Do one of the following:

mm Double-click individual markers with the Pointer or Pencil tool.

mm Click individual markers with the Eraser tool.

mm Drag over multiple markers with the Eraser tool.

mm Select an area of the audio file and press the Delete key.

All transient markers in the selected area are deleted.

Note:  Transient markers are not actually deleted. Instead, their display threshold is set to 
maximum, making them invalid. You can revalidate a transient marker using the Plus button (+). 

Detect transient markers in an audio file
mm In the Audio FIle Editor, choose Audio File > Detect Transients (or use the Detect Transients of 

Audio File key command).

Transients are detected across the audio file, overwriting (after you confirm the action) any 
manually added or edited transients.

Note:  You can also detect transients in factory audio Apple Loops. A copy of the loop is saved in 
the project’s Audio Files folder.
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Use the Audio File Editor Pencil tool
You can use the Pencil tool to correct clicks and pops in your audio, by drawing in the waveform 
display. 

You may find it useful to change the view of the waveform so that it shows the data structure. 
For more information, see Change the waveform display on page 443.

Correct pops and clicks with the Pencil tool
	 1	 Navigate to the section of the waveform you want to correct.

Tip:  Pops and clicks are often the loudest part of an audio file, so you may find the Functions > 
Search Peak command useful when looking for them.

	 2	 Use the zoom sliders to magnify that section of the waveform, then use the Pointer tool to scrub 
the audio around the pop or click. 

This action will help you identify exactly where you need to draw.

	 3	 Select the Pencil tool and drag from left to right (including up or down movements) to draw in a 
new shape for the waveform spike. 

The edges of drawn sections are automatically smoothed.

Press Option to affect both sides of stereo waveforms.

As long as the mouse button is held down, the drawn waveform can be replaced by the original 
waveform, by moving the pointer to the left.
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Trim or silence audio files
You use the Trim function to edit areas of the audio file that are not selected. It’s useful for 
removing unimportant passages—generally silence—from the start and end of your audio files. 
Trim can also be used to remove portions of audio files that are not used by regions.

You can use the Silence command to set all amplitude values to 0, rather than removing (with 
Cut, Delete, or Trim) all data from the selected area of an audio file. This function is generally used 
to silence unwanted background noise in quiet passages.

Trim all unselected portions of an audio file
mm Choose Functions > Trim from the Audio File Editor menu bar (default key command: Control-T).

Important:  Make sure the areas you are about to trim (delete) do not contain any regions that 
you may need. Regions outside the selected area will be lost. Portions of regions that fall partly 
outside the selected area are also removed, resulting in a length reduction of the region. If any 
such regions are being used in the main window, a warning dialog will give you the option of 
canceling the Trim operation.

Silence the selected area of an audio file
mm Choose Functions > Silence from the Audio File Editor menu bar (default key command: 

Control-Delete).

Set audio file levels
You can use the Change Gain command to change the level of an audio file in the Audio File 
Editor. Typically used on an entire audio file, this command can also be used to boost portions 
of it.

Raise or lower the level of the selected audio file (or area) by a specific amount
	 1	 Choose Functions > Change Gain from the Audio File Editor menu bar.

	 2	 Choose your settings in the Change Gain dialog:

•• Set the required level change in the Change Relative fields by clicking the up or down arrows, 
or by directly entering values, in either field. You can use the percentage or decibel field to 
indicate the amount of increase or decrease you prefer.

•• Click the Search Maximum button to search for the peak level. This automatically sets a 
value that is used to alter the level of the audio file. The Results in Absolute fields display the 
maximum level that will be achieved by changing the gain—by the amount shown in the 
Change Relative fields.

	 3	 Click Change to perform the gain change.

Important:  You should never make a gain change that results in a value over 100%, because this 
will result in digital clipping.
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Normalize audio files
Normalization is a process that raises the maximum level of a digital signal to a specified 
amount—typically to its highest possible level without introducing distortion.

In the Audio File Editor, you can set the maximum level (as a percentage or in decibels) in one 
of the “Peak at” fields in the Function Settings window (choose Functions > Settings or click the 
Settings button in the Normalize dialog).

These settings are automatically stored in Logic Pro preferences when the application is closed, 
and they apply to all projects.

Tip:  You should not choose 100% (0 dB) in these fields, as this may result in clipping if you 
need to increase the gain (with an EQ, for example) of the overall signal later in the production 
process. A good rule of thumb is to reserve 3 to 6 dB of headroom or more, to allow for further 
audio processing tasks, such as mixing and effects processing.

Normalize the selected area of an audio file
mm Choose Functions > Normalize from the Audio File Editor menu bar (default key 

command: Control-N).

Logic Pro X locates the point with the highest volume in the selected area, and determines how 
far it is from the maximum possible level. The level of the selected area is then raised by this 
amount. The dynamic relationships of sample levels within the audio passage remain unaltered. 

Tip:  The start and end points for the section being normalized should generally not fall within a 
continuous section of audio, as this will result in abrupt increases in volume after normalization. 
The start and end points should therefore be located in sections that occur just after, or before, 
musical gaps.
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Fade audio files
You can destructively fade in or out on an entire audio file, or a selected area in the Audio File 
Editor. Your changes are written to the file.

•• Fade In: Volume is set to 0 at the start point of the selected area, and the fade in occurs over 
the length of the selection.

•• Fade Out: Volume is set to 0 at the end point of the selected area, and the fade out occurs over 
the length of the selection.

The fade in or fade out time is determined by the selected area within the audio file.

Create a fade in or fade out
	 1	 Select a section of the audio file to determine the length of the fade in or fade out area. 

	 2	 Do one of the following:

•• To create a fade in: Choose Functions > Fade In from the Audio File Editor menu bar (default 
key command: Control-I).

•• To fade passages out automatically: Choose Functions > Fade Out from the Audio File Editor 
menu bar (default key command: Control-O).

Tip:  If you use the Silence function (see Trim or silence audio files on page 459) to remove 
unwanted background noise from silent passages, small jumps in volume can sometimes 
occur at the silence start and end points. If this happens, zoom in and select a small area 
surrounding—just before and after—the start point of the signal, then use the Fade In function.
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Adjust the fade curves
	 1	 Choose Functions > Settings from the Audio File Editor menu bar to open the Function 

Settings window.

	 2	 Edit the Curve value to change the shape of the fade in or fade out curve.

	 3	 Select the S Curve checkboxes if you want to create S-shaped curves.

These settings are automatically stored in Logic Pro X preferences when the application is closed, 
and they apply to all projects.

Tip:  The Fade tool in the main window offers a flexible, nondestructive fade option. For more 
information, see Create fades on page 318.
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Audio File Editor Reverse commands
The Reverse command is most commonly used on an entire audio file—to reverse a cymbal 
sound, for example. It can also be used as a creative option on selected portions of audio files. 
For example, the reverb tail at the end of a file can be reversed, copied, and pasted to the 
beginning of the file.

The Invert command is useful for correcting phase cancellation errors, or when several out-of-
tune signals (or several signals processed through chorus effects) are to be mixed down to mono. 

Tip:  You can also use the Invert function to decode mono/stereo recordings, but it’s easier to use 
the Direction Mixer plug-in for this task. For more information about this plug-in, see Logic Pro 
Effects Help.

Reverse the selected area of an audio file
mm Choose Functions > Reverse from the Audio File Editor menu bar (default key 

command: Shift-Control-R).

Reverse the phase of all selected audio material
mm Choose Functions > Invert from the Audio File Editor menu bar (or use the corresponding key 

command).

All negative amplitude values become positive, and vice versa. 

Note:  This doesn’t audibly change the file, if heard in isolation.

Audio File Editor Loop commands
The Audio File Editor Loop commands, available from the Edit menu, are ideal for use with the 
EXS24 mkII sampler. For details about the EXS24 mkII, see Logic Pro Instruments Help.

You can also use these functions to generate audio files that contain the loop settings in the file 
header. This allows you to make full use of these files in any application that can read the loop 
information in the file header.

Use the Audio File Editor Loop commands
	 1	 Choose either of the following commands from the Edit menu:

•• Sample Loop → Selection: The loop area (defined by the loop start and end points) is used to 
select a portion of the overall audio file.

•• Selection → Sample Loop: The selected area is used to set the loop start and end points.

	 2	 Choose Edit > Write Sample Loop to Audio File.

The new loop values are written to the file header.
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Undo edit steps
Most Audio File Editor functions are destructive, changing the files stored on your hard disk. 
However, you can use the Undo feature if things do not go your way.

Compare (or undo) your edits with the original audio file
mm Choose Edit > Undo (default key command: Command-Z).

Cancel a destructive edit that is in progress
mm Press Command-Period (.).

The audio file will be retained in its original state, even if it appears that a portion of the editing 
function has occurred.

You can configure the Audio File Editor’s Undo function in the Preferences > Audio > Audio File 
Editor pane. For more information, see Audio File Editor preferences on page 858.

Perform manual backups
Although the Undo History and standard Undo functions are available, try to get in the 
habit of creating backups before processing or editing. This provides a safety copy of your 
audio recordings in case something unexpected happens, due to a processing error or other 
unforeseen event.

You can make manual backups of the file you’re editing, or replace it with a backup version at 
any time, using a variety of functions.

Duplicate the audio file you’re working on
mm Choose Audio File > Create Backup from the Audio File Editor menu bar (default key 

command: Control-B).

A copy of the audio file (with the extension .dup) is created in the same folder as the source file.

Revert to a backup file
mm Choose Audio File > Revert to Backup from the Audio File Editor menu bar (default key 

command: Control-Option-Command-B).

This function completely replaces the current audio file with the backup (provided one exists).

Important:  You cannot reverse this function with Undo.
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Save a copy with a different name to a specific location
	 1	 Choose Audio File > Save A Copy As from the Audio File Editor menu bar.

	 2	 Choose your settings in the Save A Copy As dialog:

You can set the sample rate, bit depth, file format, stereo conversion, and dither type for the 
destination file. The dialog also features an “Add resulting files to Project Audio” option, allowing 
you to add the file to the Project Audio Browser, following the save.

	 3	 Browse to the location (such as a hard disk and folder) where you want to store the audio file, 
then enter a name for the audio file in the Save As field.

	 4	 Click Save.

Save the selected area as a new audio file
mm Choose Audio File > Save Selection As from the Audio File Editor menu bar (default key 

command: Shift-Command-S).

The Save Selection As dialog includes the same file conversion choices as the Save A Copy 
As dialog.
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Use an external sample editor
You can configure Logic Pro to open an audio region or file in an external sample editing 
application. 

Use an external sample editing application
	 1	 Open Audio preferences by doing one of the following:

•• Choose Preferences > Audio (or use the Open Audio Preferences key command).

•• Click the Preferences button in the control bar, then choose Audio from the pop-up menu.

	 2	 Click the Sample Editor tab, then click the Macintosh HD field beside External Sample Editor.

In the dialog, browse for the application, then click Choose.

Open a selected audio file in the external sample editor
mm Choose Options > Audio > “Open in [external sample editor]” (or use the corresponding key 

command).

The external sample editor opens, allowing you to perform edits on the audio file.

Transfer audio edited in the external sample editor back to Logic Pro
mm Save the file in the external sample editor, then switch back to Logic Pro.

The edited audio will be updated in the Browser and main window, if regions based on the audio 
file are in use.
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MIDI Transform window

MIDI Transform window overview
The MIDI Transform window is so-named because it transforms MIDI events—based on 
conditions, operations, and values you choose—into different types of events, or events with 
different values.

The MIDI Transform window is a powerful tool for edits that would otherwise be impossible (or 
tedious). For example, imagine an orchestral project that has been sent to you for editing. The 
individual violin and viola parts were recorded with a different string library. Two hundred MIDI 
regions contain aftertouch information that introduces an unpleasant pitch modulation, and 
some sample layer switching artifacts when played with your string samples. After looking at this 
aftertouch information, you discover that only a small range of values is causing the problem. 
Your options: edit your sampler instruments, manually remove all aftertouch information (region 
by region, or globally, thus losing the performance benefits that the aftertouch information 
provides), or alter the problematic values in the MIDI Transform window.

A number of preset transform sets are available for many common editing tasks. These may be 
all you’ll ever require, but should the need arise, you can create and save your own transform 
sets, and recall them later.

Tip:  The Environment contains a similar transformer object that you can use for real-time 
transformations of MIDI events. See Transformer objects overview on page 815.

Open the MIDI Transform window
Do one of the following:

mm Choose Window > Transform (or use the Open Transform key command, default 
assignment: Command-4).

mm If you want to transform events that you have selected in one of the MIDI editors, choose a preset 
from the Functions > Transform submenu.

Note:  You can choose the Window > Transform command while you are in a MIDI editor, but will 
need to manually select a preset.
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Use transform sets
The Presets pop-up menu is shown at the top-left corner of the MIDI Transform window. The 
first 17 items in the menu are write-protected preset templates for common editing tasks, 
such as creating crescendos or fixing note lengths. For more information, see MIDI Transform 
window presets.

You can temporarily change the used parameters of a preset, but all changes are discarded when 
you exit the preset.

Depending on your needs, it may be worthwhile to create your own transform sets. These can 
be configured and saved as part of a project. (Doing this in your template projects makes your 
transform sets available in all projects.) Your transform sets are shown at the bottom of the 
Presets pop-up menu.

Use a transform preset
	 1	 Select the MIDI regions or events that you want to transform.

	 2	 Choose a transform set from the Presets pop-up menu. For more information, see MIDI Transform 
window presets.

	 3	 In the Mode pop-up menu, choose how you want to transform the selected events within the 
regions. 

	 4	 Set the selection conditions.

	 5	 Define the operations you want to perform.

Note:  You can deselect the “Hide unused parameters” checkbox (turn it off) to show all 
conditions and operations, allowing you to make more advanced choices.

	 6	 Do one of the following:

•• To select all events that meet the selection conditions: Click Select Only. The events will not 
be transformed. You can use this option to refine your selection, and make sure that your 
conditions only affect the events that you truly want to transform.

•• To transform all selected events, in accordance with the operations settings: Click Operate Only. 
(The selection conditions have no effect.) This is useful if you want to edit events that you’ve 
already selected manually.

•• To select all events that match the conditions, and transform them according to the operations 
settings: Click Select and Operate.

Note:  The number of selected regions and events (that match the conditions) are displayed 
above the selection and operation buttons.



	 Chapter  15    Advanced edit features	 469

Create a user transform set
	 1	 Choose Create Initialized User Set from the Presets pop-up menu. 

	 2	 Set conditions and operations.

	 3	 Select the “Hide unused parameters” checkbox. This helps to avoid changes to conditions and 
operations that aren’t required for (or may disturb) your transform set.

	 4	 Click New Parameter Set (Number) in the Presets pop-up menu. Enter a new name for your 
transform set.

This transform set now appears at the bottom of the Presets list in all MIDI Transform windows 
for this project. You should consider saving your user transform sets in one or more template 
projects. This way, they will always be available to you in all future projects.

Tip:  Renaming an existing transform set creates a new transform set that is identical to the 
original. The existing (source) transform set is retained.

Import all transform sets from another project
You can import transform sets from other projects, allowing fast access to a transform preset 
you created earlier. This function is also useful for adding existing transform sets to new 
template projects.

	 1	 Choose File > Project Settings > Import Project Settings (default key 
command: Option-Command-I).

	 2	 Browse to, and select, the project that contains the transform sets you want to import.

	 3	 Click the Import button, then choose the transform sets you want to import into the current 
project. 

The names of imported transform sets are retained, and added to the bottom of the Presets list.

	 4	 Click the Import button.
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MIDI Transform window presets
The table below describes the operations performed by the MIDI Transform window presets.

Preset Operation

Random Pitch Sets a random pitch for note events. Change the Pitch condition values to 
alter your selection range.

Random Velocity Sets a random velocity for note events. Change the Velocity condition 
values to alter your selection range.

Random Pitch, Velocity, Length Sets a random pitch, velocity, and length for note events. Change the 
Pitch, Velocity, and Length condition values to alter your selection ranges.

Crescendo Used to gradually increase the velocities of a group of notes from low to 
high values (or vice versa—decrescendo or diminuendo). 

•• Select the area (Position column) that contains the note events that 
you want to perform a crescendo on.

•• Set the velocity values in the Operations area, ranging from 1 to 127.
•• If you want a less dynamic crescendo, set a smaller value range.
•• To perform a diminuendo, set a higher value in the top Velocity field, 

and a lower value in the bottom field.

Scale 14 Bit PitchBd Scales pitch bend data, keeping the 14-bit information intact. The length 
of pitch bend events is expressed as a decimal value ranging from −8192 
to 8191, and this is the 14-bit information that is retained.

•• Choose the multiplication factor for the fine pitch bend (LSB) and 
effective pitch values (MSB) in the top value field shown in the 
Operations area.

•• Set the (14 bit) value in the lower field, which is then added to the 
scaled (multiplied) events.

Double Speed Doubles the tempo by halving event positions and lengths. By default, 
the Div(ision) value fields for the Position and Length operations are set 
to 2.0000. This preset is a useful creative option for drum regions. Change 
the values in both fields to 4.000 to quadruple the tempo.

Half Speed Halves the tempo by doubling event positions and lengths. The Mul(tiply) 
value fields for the Position and Length operations are set to 2.0000 by 
default. Set both Mul operation value fields to 1.5000 to reduce the tempo 
by approximately 30%.

Humanize Adds a random value to the position, velocity, and length of selected note 
events. This preset is useful on rhythmic parts, such as clavinet, piano, 
drum, and percussion. It can add life to strictly quantized material, or 
manually entered notes.

Alter the values for Position, Velocity, or Length to increase or decrease the 
random factor for each of these event parameters.

Reverse Position Reverses the positions of events (usually notes) within a section. Change 
the Position condition values to alter your selection range.

Reverse Pitch Inverts the pitch of all note events. Change the Flip operation value to 
set a pivot point note number, around which note event pitches will be 
reversed.

Transposition Transposes all note events. 

•• Change the Add operation value to the required amount (in semitone 
steps).

•• Set a negative value in the field for a downward transposition.
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Preset Operation

Exponential Velocity Alters the scaling of the velocity curve. This preset is useful for software 
or MIDI instrument parts. Velocity is often used to control both the initial 
volume of instruments and to trigger filter envelopes, making the sound 
brighter or darker. Transforming regions can be faster than changing 
velocity scaling or filter parameters of your MIDI or software instruments.

Change the Velocity value field in the Operations area to change the 
velocity curve. This is reflected in the map area.

Velocity Limiter Limits the velocity to a maximum value. This is useful for transforming 
instrument parts that are too strident, by limiting the velocity. Change the 
Max operation field value to limit the velocity to a maximum value. This is 
reflected in the map area.

Fixed Note Length Creates constant note lengths. Useful on many instruments, particularly 
drums and other rhythmic parts, such as pianos, clavinets, and basses.

Change the Length value field in the Operations area to resize all selected 
events to the chosen length. Both shorter and longer events are changed 
to match the specified length value.

Maximum Note Length Sets the maximum length of all note events. Change the Length value 
field in the Operations area to define the maximum note length. Existing 
notes that are shorter than the length defined in the Length field retain 
their lengths. Events that are longer than the defined value are reduced in 
length.

Minimum Note Length Sets the minimum note length. Change the Min value field in the 
Operations area to define the minimum note length. Existing note lengths 
that are longer than the length defined in the Min field retain their 
lengths. Note events that are shorter than the defined value are increased 
in length.

Quantize Note Length Change the Length value field in the Operations area to define the length 
that note end positions are quantized to.
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MIDI Transform window parameters

MIDI Transform window parameters overview
The MIDI Transform window includes the following parameters and elements that can be used 
to process your MIDI data. For more information, see MIDI Transform window examples on 
page 478.

Preset pop-up menu

Operations area

Mode pop-up menu Selection Conditions area

Map

These parameters globally affect the MIDI Transform window appearance and operating mode.

Global parameters
•• Presets pop-up menu: Choose one of the transform presets or one of your own transform sets. 

•• Mode pop-up menu: Choose one of the following options to determine how events 
are transformed.

•• Apply operations to selected events: Applies the operations to all selected events. The selected 
events are determined by the selection conditions.

•• Apply operations and delete unselected events: Transforms the selected events, and deletes 
all unselected events. Only events that match the selection conditions remain after 
the transform operation. This mode allows you to use the MIDI Transform window as a 
programmable filter, where only events that match the conditions survive.

•• Delete selected events: Deletes selected events. This mode allows you to use the MIDI 
Transform window as a programmable erase function. All events that match the conditions 
are deleted, and all other events remain unchanged. The operation settings are irrelevant in 
this mode.

•• Copy selected events, then apply operations: Retains the selected events in their original form, 
copies them, and applies the operations. 

•• “Hide unused parameters” checkbox: Hides all unused menus in the Selection Conditions and 
Operations areas. This provides a better overview of the settings in use. It also prevents you 
from making accidental alterations.
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Set selection conditions
You can define conditions that determine which events are selected for transform operations. 
This is done in the Selection Conditions area of the MIDI Transform window. Each column 
represents a different MIDI event parameter.

The condition is considered to be fulfilled when an event matches the defined effective range, 
and values, of all event parameters. These ranges and values are determined in the pop-up 
menus and fields found under each of the event parameter columns.

Selection conditions
•• Position: Determines the time position of the event, referenced to the start point of the MIDI 

region (not the start point of the project).

•• Status: Determines the event type.

•• Channel: Recorded MIDI channel of the event

•• Data Byte 1/Pitch: First data byte (controller number) or note pitch

•• Data Byte 2/Velocity: Second data byte (controller value) or note velocity

Note:  The parameters displayed in the Data Byte fields are dependent on the Status pop-up 
menu setting. Certain Status pop-up menu settings will not show the Data Byte fields at all.

•• Length: Length of the note or event

•• Subposition: Time position of the event, within a bar

Choose the event type
mm Open the Status pop-up menu to determine which events will be selected. You have a choice of 

two settings:

•• All: All event types fulfill the condition.

•• “=”: An additional pop-up menu is displayed (below the Status pop-up menu), where you can 
define the event type. These include note, poly pressure, control change, program change, 
channel pressure, pitch bend, meta, and fader. 

Set all other selection conditions
mm Open the pop-up menus (in each column that is needed) to define the selection criteria for 

events. One or two value fields appear below the pop-up menu, unless Map is chosen. You can 
assign one of the following value conditions for each of the parameter columns:

•• “=”: The event must be equal to the value in the field, for the condition to be fulfilled. For 
example, only note C#3 events will meet the condition.

•• Unequal: The event must not be equal to the value in the field, for the condition to be fulfilled. 
All events that are not C#3 will meet the condition, for example.

•• Smaller/Equal (<=): The event value must be less than, or equal to, the value in the field (a note 
velocity less than, or equal to 98, for example) for the condition to be fulfilled. 

•• Larger/Equal (>=): The event value must be larger than, or equal to, the value in the field (a 
note pitch higher than, or equal to C#3, for example), for the condition to be fulfilled.

•• Inside: The event must fall within the value range (of event positions or note pitches, for 
example) of both fields, for the condition to be fulfilled.

•• Outside: The event must be outside the value range (of event positions or note pitches, for 
example) of both fields, for the condition to be fulfilled.
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•• Map: Most conditions are numerical relationships, and the condition is met if the incoming 
MIDI event value satisfies the condition. The last condition, Map, works a little differently. Two 
numerical parameters are specified, and the incoming value is first converted by the map, to 
create a mapped value. The mapped value is then compared with the two parameters to see if 
it falls inside them. Incoming events with a mapped value that falls within the range will fulfill 
the condition—all other events will not fulfill the condition. For more information, see Use the 
map on page 476. 

Set the values for a selection condition
mm Use the mouse as a slider, or enter a value directly into the field. 

Set operations parameters
The Operations area is used to define the changes you want to make to events that meet the 
selection conditions. As with the selection condition pop-up menus, you choose an operation in 
the appropriate event parameter columns. One or two value fields may appear, depending on 
the chosen operation. 

Define the operation for the status event parameter column
mm Open the pop-up menu, then choose one of the following operations for the Status condition:

•• Thru: The event type passes through unaltered.

•• Fix: The event type is altered. Choose a new event type in the pop-up menu that appears 
below the Status Operations pop-up menu. Choices include fader, meta, note, poly pressure, 
control change, program change, channel pressure, or pitch bend. This effectively converts one 
type of event to another.

Note:  When you convert note events, two events are created: one for the note on event, and 
one for the note off event.

•• MapSet: Choosing this setting means that events that match the Status condition (note events, 
for example) are used to control the map of a subsequent operation—in the Channel, Data 
Byte 1, Data Byte 2, and Length columns.

•• The Data Byte 1 value selects the position in the map.

•• The Data Byte 2 value determines the value at this map position.

Internally, Logic Pro sends a meta event pair: #123 for the position, and #122 for the value at 
this position. These types of meta events can also be created in other ways.
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Define the operation for all other event parameter columns
mm Choose one of the following operations for the Channel, First or Second Data Byte, and Length 

columns (as required). One or more value fields will appear below the respective operations 
pop-up menus.

•• Thru: The event passes through unaltered.

•• Fix: Fixes the event parameter to the set value. You could use this to set the pitch of all note 
events to a specific note value, making it easy to convert a bass groove into a hi-hat pattern, 
for example.

•• Add: Adds the value to events. For example, a value of 8 could be added to all incoming note 
velocity events, thus making the notes louder.

•• Sub: Subtracts the value from events. You could use this to reduce all controller 10 (Pan) events, 
thereby narrowing the stereo spread of an electric piano part, for example.

•• Min: Parameter values lower than the defined value are replaced (by this value). Larger 
parameter values are not altered. You could use this to replace all note velocity messages 
below 45, thereby reducing the dynamic range of a MIDI region—or put another way, making 
the soft notes louder.

•• Max: Parameter values that exceed the set value are replaced by it. Smaller event parameter 
values remain unaltered. This could be used to restrict filter resonance modulation events 
above a value of 100, for example, resulting in a softer filter sound.

•• Flip: All parameter values that match the conditions are reversed around a pivot point (the 
value defined here). Events above this value are moved by the same distance below it, and 
vice versa. For example, you could move a note from E3 to G#2, if the pivot point value was 
set to C3. Effectively, the E3 event, which is 4 (pitch) values above the C3 pivot point is flipped 
to 4 values below (G#2). This can also be used to reverse selected note positions around a 
particular bar or beat, as another example.

•• Mul: The parameter value is multiplied by the set value (accurate to four decimal places). The 
effect, and use, of this operation is best illustrated by the Half Speed preset.

•• Div: The parameter value is divided by the set value (accurate to four decimal places). The 
effect, and use, of this operation is best illustrated by the Double Speed preset.

•• Scale: The parameter value is multiplied by the top value, and the bottom value is then added. 
This is a combination of Mul and Add. If you enter a negative number here, values can be 
subtracted from—rather than added to—the value resulting from the multiplication.

•• Range: Parameter values outside the set value range are replaced by the values of the (range) 
limits (combination of Min and Max).

•• Random: Random values are generated within the set limits.

•• +-Rand.: A random value between zero and the set value (positive or negative) is added.

•• Reverse: The parameter value is reversed within its value range (no value can be set here).

•• Quantize: The parameter value is quantized to a multiple of the set value.

•• Qua & Min: Like Quantize, but the quantization does not fall below the set value (a 
combination of the Quantize and Min functions, with the same set value).

•• Expon.: The parameter value is scaled exponentially. The extreme values (0 and 127) remain 
unaltered. The set value determines the shape of the curve. Positive values result in the 
exponential scaling of data (increasing input values remain lower for longer, and then rise 
quickly), and negative values result in the logarithmic scaling of data (decreasing input values 
remain higher for longer, and then drop off more quickly).
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•• Crescendo: This only works if the Inside Position selection condition is selected (crescendos 
need start and end points). Crescendo creates a smooth alteration of the current parameters, 
between the set value boundaries.

•• Rel.Cres: This only works if the Inside Position selection condition is selected. The effect is 
similar to that achieved by Crescendo, but the previous values of the parameters being 
altered are taken into account when the crescendo is created, preserving the relative feel of 
the original.

•• Use Map: The set map will be used when this operation is selected. For more information, see 
Use the map on page 476.

Set the values for an operation
mm Use the mouse as a slider, or enter a value directly into the field. 

Use the map
The map display contains 128 vertical bars that reflect the full MIDI value range (from 0 to 127), 
and provide a visual overview of the transformation.

Each bar represents a particular MIDI value that can be mapped to a different value. The type of 
event, and operations, are determined in the Selection Conditions and Operations areas.

•• The map is visible only when chosen in one of the Operations pop-up menus. Appropriate 
selection conditions must also be set, or the map does not appear.

•• The map is universal, which means that it remaps one MIDI value to another.

•• The map does not know what type of MIDI data is sent to it. It only affects the value of 
the data.

This means that one map can be used to simultaneously alter the pitch, velocity, and length 
values of incoming note events, for example.

Map usage example
•• Each of the bars could represent a MIDI note number (from 0 to 127) value.

•• By default, there is a 1:1 relationship for each bar, where value 1 = value 1, value 15 = value 15, 
and so on, throughout the 128 bars. Applying this to MIDI note numbers, bar 60 = C3 (middle 
C), bar 61 would represent C#3, bar 62 = D3, and so on.

The default and mapped values are shown in the two fields at the lower left of the map area. 

•• You can alter these values directly in the fields, or by dragging any of the bars vertically. As you 
do so using either method, the corresponding field or bar is updated.

•• If you alter the bar 60 (middle C) value to show 72 in the “mapped to” field, this value is 
remapped accordingly when the Transform operation is applied. 

This results in all MIDI note number 60 messages being transformed into MIDI note number 72 
messages (effectively transposing all C3 notes to C4).
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Exchange parameter values
You can reroute the value of each of the three event parameters—Channel, Data Byte 1, and 
Data Byte 2—to the value of a different parameter from this group. 

Replace the source (Condition value) with the target parameter value
mm Click the dots on the lines between the Selection Conditions and Operations areas.

Repeated clicks cycle between different targets.

Note:  The value is exchanged before the operation is performed.



	 Chapter  15    Advanced edit features	 478

MIDI Transform window examples
This section provides several usage examples for the MIDI Transform window. 

Add a mod wheel controller event (#1) with a value that matches the note’s velocity
	 1	 Choose the following settings in the MIDI Transform window:

•• Mode pop-up menu: Copy selected events, then apply operations.

•• Selection Conditions area: Set Status to Note.

•• Operations area:

•• Set Position to Add, then enter a value of 1 in the field below it. 

•• Set Status to Fix, then choose Control in the pop-up menu below it.

•• Set Pitch to Fix, then enter a value of 1 in the field below it. This means “the first data byte 
receives the value of 1” (the first data byte defines the controller number for controller 
events, and mod wheel events happen to be #1).

Note:  When you convert MIDI note events to controller events, two controller events are 
created: one for the note on event, and one for the note off event.

	 2	 Click Select and Operate.

If you analyze these settings, you’ll see that all note events are selected for operation. A copy of 
each is made, then moved one tick later than the original, and converted to CC#1 (mod wheel), 
with a value that corresponds to the velocity of the original note. This is because the second data 
byte (Vel) is left unaltered.

The automatic offset by one tick after each note start point and end point avoids potential 
conflicts with the source note events.

Create a transform set that fixes all note velocities to a defined amount
	 1	 Choose Create Initialized User Set from the Presets pop-up menu. 

	 2	 Set the Status pop-up menu in the Selection Conditions area to “=.” 

	 3	 Choose Note from the pop-up menu below.

	 4	 Choose the Fix setting in the Velocity pop-up menu of the Operations area.

	 5	 Change the amount to 127 in the field below the Velocity pop-up menu.
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Convert MIDI note events to MIDI controller 1 events
	 1	 Choose the following settings in the MIDI Transform window:

•• Mode pop-up menu: Apply operations to selected events.

•• Selection Conditions area: Set Status to Note.

•• Operations area:

•• Set Status to Fix, then choose Control in the pop-up menu below it.

•• Set Pitch to Fix, then enter a value of 1 in the field below it.

Note:  When you convert MIDI note events to controller events, two controller events are 
created: one for the note on event, and one for the note off event. 

	 2	 Click Select and Operate.
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Randomly change the pitch of MIDI note events
	 1	 Choose the following settings in the MIDI Transform window:

•• Mode pop-up menu: Apply operations to selected events.

•• Selection Conditions area: Set Status to Note.

•• Operations area: Set Pitch to +-Random, and set the max deviation from the root note in the 
field below. If you set a value of 12, you’ll achieve a deviation of one octave up and one down 
(two octaves, around the root note, in other words).

	 2	 Click Select and Operate.

Tip:  To restrict the randomness to one direction—up or down, as opposed to both—use the 
other Random Option, which limits the range that notes fall into.

Make note selections for edit operations
	 1	 Choose the following settings in the MIDI Transform window:

•• Selection Conditions area:

•• Set Status to Note.

•• Set Position to Inside, then choose the range.

	 2	 Click the Select Only button.

All notes in the defined range are selected for you to cut, move, or otherwise modify.
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Delete volume events (MIDI CC#7) from a MIDI region
	 1	 Choose the following settings in the MIDI Transform window:

•• Mode pop-up menu: Delete Selected Events.

•• Selection Conditions area:

•• Set Status to Control.

•• Set Data Byte 1 to a value of 7.

	 2	 Click Select and Operate.

Delete all controller events from a region
	 1	 Choose the following settings in the MIDI Transform window:

•• Mode pop-up menu: Delete selected events.

•• Selection Conditions area: Set Status to Control.

	 2	 Select the MIDI region you want to transform, then click Select and Operate.
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Create an ascending pitch pattern from notes of one pitch
	 1	 Choose the following settings in the MIDI Transform window:

•• Mode pop-up menu: Apply operations to selected events.

•• Selection Conditions area:

•• Set Status to Note.

•• Set Position to Inside, then define the range. (Cresc. only works if the Inside Position 
selection condition is chosen, as crescendos need start and end points.) 

•• Operations area: Set Pitch to Cresc., then enter a value of D0 and G6 in the fields below. 

	 2	 Click Select and Operate.

Experiment with the Double Speed preset in the Step Editor
This example assumes that a 4/4 kick, snare, hi-hat, and other percussion sounds region is being 
viewed in the Step Editor.

	 1	 Click the Name column of one of the drum sounds.

All note events of a particular pitch in the region are selected.

	 2	 Change the Length field to a value that does not match the Position field, or vice versa.

	 3	 Repeat the steps with other drum or percussion sounds.

This can lead to interesting polyrhythms you may not have thought of.

The example illustrates the use of the same Transform operation multiple times on the same 
region. You can also combine different transform presets to achieve an end result, by using them 
one after the other.
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Mixing overview
When you mix a project, you balance the different parts and blend them into a cohesive whole. 
You can also add effects to alter the sound, use routing and grouping to control the signal flow, 
and use automation to create dynamic changes in your project over time. You do this in the 
Mixer, which opens below the Tracks area or as a separate window.

Although there are no rules for mixing—except those learned from experience and a good 
ear—mixing typically involves the following steps. You may find yourself moving back and forth 
between steps as you work on the mix.

•• Set channel strip volume levels to balance different instruments.

•• Set channel strip pan, or balance, positions to place instruments in the stereo field.

•• Add and adjust effects and instruments to change the sound characteristics of a track or the 
overall project.

•• Control signal flow to create subgroups, route a signal to multiple destinations, or process 
sounds individually.

•• Create changes over time using automation curves on an individual track or the master track.

In the process of mixing, you will find different ways to accelerate and simplify your workflow, 
by muting and soloing channel strips, working with channel strip groups, and customizing 
the Mixer.

  You can also choose between different Mixer views when Show Advanced Tools is selected in 
the Advanced preferences pane, displaying only those channel strips that you actually need for 
the mixing task at hand.

Open the Mixer in the main window
Do one of the following:

mm Click the Mixer button  in the control bar.

mm Choose View > Show Mixer (or press X).

Open the Mixer as a separate window
mm Choose Window > Open Mixer (or press Command-2).

Mix a project 16
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Choose a different Mixer view
Do any of the following:

mm Click the Single button to show the signal flow of the channel strip that corresponds to the 
selected track in the Tracks area.

mm Click the Tracks button to show the signal flow of all channel strips that correspond to tracks 
used in the Tracks area.

mm Click the All button to show the signal flow of all channel strips available in the project.

Note:  Aux and output channel strips are examples of channel strips that don’t have a 
corresponding track in the Tracks area. You can, however, create tracks for such channel strips by 
choosing Options > Create Tracks for Selected Channel Strips from the Mixer menu bar.

mm Use the Cycle Through Mixer Modes key command.

You can also perform some basic mixing tasks in the Tracks area.
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Mixer channel strips

Channel strip types
You use channel strips to process audio or MIDI information that is routed from tracks. The Mixer 
shows all channel strips in your project, including track channel strips, auxiliary and output 
channel strips, and the master channel strip.

  You can filter channel strips by type when Show Advanced Tools is selected in the Advanced 
preferences pane, displaying only those channel strips that you need for the task at hand.

Audio channel strips

Instrument channel strips MIDI channel strip

Output channel strip

Aux channel strips Aux channel strips Master channel strip

•• Audio channel strips: Used to control the playback and recording of audio signals on audio 
tracks. All data on the audio track is automatically routed to the audio channel strip assigned 
in the track list.

•• Instrument channel strips: Used to control software instruments. Software instruments are 
inserted via the channel strip’s Instrument slot. The instrument channel strip can then be 
driven by a recorded MIDI region, or by playing your MIDI keyboard.

•• Aux (Auxiliary) channel strips: Used for a variety of signal-routing purposes. Aux channel strips 
are used to set up send returns, where a channel strip signal is routed to an aux channel strip 
for effects processing. They are also used for grouping and for distributing a signal to multiple 
destinations via sends.

•• Output channel strips: Represent the physical audio outputs of your audio interface. They are 
used to adjust the overall level and stereo balance—or pan position, in the case of mono 
output channel strips—of all audio, instrument, or aux channel strips routed to them. The 
number of available output channel strips is determined by the audio interface in use.

•• Master channel strip: Used as a global volume control for all output channel strips. The 
master channel strip changes the gain of all output channel strips without affecting the level 
relationships between them. This is helpful as a proportional output volume control and is 
particularly useful in Logic Pro surround format where you can use it to create fades in the 
complete surround mix.
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•• MIDI channel strips: Used to control external MIDI tracks. MIDI data on these tracks is routed to 
a MIDI output port and channel, for control of MIDI sound modules and keyboards.

Note:  Bus and input channel strips are included for compatibility with earlier versions of Logic 
Pro. Signal routing and other bus channel strip functions are now handled by aux channel strips. 
Audio hardware inputs are now handled by audio channel strips.

Filter channel strips by type
Do one of the following:

mm Click a filter button to show or hide the channel strip type.

Channel strip filter buttons

mm Option-click a filter button to show that channel strip type; all other channel strip types 
are hidden.
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Channel strip controls
Each channel strip has a set of controls, which varies according to channel strip type. You can 
adjust the channel strip volume and pan position, mute and solo channel strips, add and adjust 
effects, and send the output to auxiliary or output channel strips.

Solo buttonMute button

Bounce button
Record Enable button
Input Monitoring button
Level meter

Volume fader

Peak level display

Pan/Balance knob

Automation Mode button
Group slot
Output slot

Send slot
Send Level knob

Audio Effect slot

Input/Instrument slot
MIDI Effect slot
EQ display
Gain Reduction meter

Setting button

Format button

•• Setting button: Use to load, browse, or save channel strip settings for the selected track. These 
settings represent the entire routing configuration of a single channel strip, including plug-ins 
and their settings.

•• Input/Instrument slot: Choose the channel strip’s input source—the input source that your 
microphone or instrument is connected to.

•• Audio Effect slot: Inserts an audio effect into the channel strip. Use effects to alter signals in 
real time.

•• Send slot: Routes the signal to an aux channel strip. The Send Level knob that appears 
defines the amount of signal to route. Use sends to process effects for multiple signals at the 
same time.

•• Send Level knob: Controls the amount of signal sent to an aux channel strip. Use sends to 
process effects for multiple signals at the same time.

•• Output slot: Choose the channel strip’s output destination—where the channel strip signal is 
sent to.

•• Pan/Balance knob: Sets the channel strip signal’s position. On mono channel strips, it controls 
the signal’s left/right position. On stereo channel strips, it controls the balance between the 
left and right signals.

•• Peak level display: Updates during playback to show the highest peak level reached. A red 
display indicates signal clipping.
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•• Volume display: Shows the playback volume.

•• Volume fader: Adjusts the playback volume of the channel strip signal.

•• Level meter: Shows the level of the input signal—when playing an instrument or singing, for 
example. Amber and yellow signals are safe. Red indicates signal clipping.

•• Mute button: Removes the signal from the overall composition so that it can’t be heard.

•• Solo button: Isolates the signal from the overall composition so that it can be heard alone.

•• (Input) Format button: Switches the channel strip input format between Mono and Stereo. 
Click-hold to choose Left, Right, or Surround format.

•• Dim button: Turns on Dim Volume mode. This sets the playback volume to the Dim value set in 
the Logic Pro > Preferences > Audio > General pane.

  When Show Advanced Tools is selected in the Advanced preferences pane, the following 
additional controls become available:

•• Gain Reduction meter: Displays the gain reduction of the first Compressor or Silver Compressor 
plug-in in the channel strip. If neither is inserted, the meter should display the gain reduction 
of an inserted Limiter or Adaptive Limiter plug-in.

•• EQ display: Double-click to insert a Channel EQ into the first unused Insert slot, or to open 
the topmost inserted Channel or Linear Phase EQ. Use EQ effects to shape an audio signal by 
adjusting specific frequency range levels.

•• MIDI Effect slot: Insert a MIDI effect into the channel strip.

•• Group slot: Controls a channel strip’s group assignment. Use the Group Settings window to 
define which parameters are controlled for the entire group at once.

•• Automation Mode button: Sets how channel strip and plug-in changes are handled during 
recording and playback.

•• Input Monitoring button: Allows you to hear incoming audio on audio tracks that aren’t armed 
for recording. Use to set audio levels or to practice parts before recording.

•• Record Enable button: Arms the track or channel strip for recording.

•• Bounce button: Bounces the output of any output channel strip to an audio file.
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Set channel strip volume and check levels

Peak level display and signal clipping
The peak level display is a numerical display located above the level meter. It updates during 
playback to show the peak level reached, after the entire signal has been played through to the 
end, and provides a guide that should be used to set the Volume fader.

Peak level display showing 
signal clipping

Volume fader

Level meter

Signal clipping occurs when a signal that is too loud is fed through the output channel strip, 
thereby exceeding the limit of what can be accurately reproduced, resulting in distorted sound. 
The value shown in the peak level display lights red when the signal clips. This part of the peak 
level display is called the clipping indicator.

Note:  It’s not an issue if individual channel strips show evidence of clipping, as long as the 
output channel strip—the summed level of all channel strips in the signal flow—does not 
indicate clipping.

To avoid clipping, you need to bring down the Volume fader by the same value that is shown in 
red in the peak level display. For more information, see Set channel strip volume levels.

Avoid clipping
	 1	 Observe the value shown in the peak level display.

Peak level display

Volume fader

Level meter

In the figure, 1.7 dB is shown in the peak level display when the Volume fader is set to 2.2 dB.

	 2	 Drag the Volume fader down to a value of 0.5 or so.

Tip:  You may find, however, that a Volume fader value of −1.2 sounds best in the context of the 
overall mix, and clips only once (by 0.3 dB) during playback. If this is the case, it’s nothing to 
worry about. Use your ears rather than your eyes as a guide.
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Reset all clipping indicators
mm Click any clipping indicator (or use the Clear Overload Flag in Audio Channel Display key 

command).

Set channel strip volume levels
You can set the volume level of each channel strip independently, balancing the relative volume 
of the tracks in your project. You can also quickly switch between two different volume levels on 
a channel strip.

Set a channel strip’s volume level
Do one of the following:

mm Drag the Volume fader up or down.

Volume fader

Level meter

mm Option-click the Volume fader to return it to a neutral level (0 dB gain).

mm Hold down Shift while dragging the Volume fader to change the volume level in 
finer increments.

The level meter, located to the right of the Volume fader, shows the channel strip output volume 
as the project plays. When you record, watch the level meter to make sure the channel strip 
volume is not too high.
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Set, and switch between, two different volume levels
	 1	 Select an audio channel strip.

	 2	 Drag the Volume fader to the level you want.

	 3	 Use the Toggle Level of Audio Channel Strips key command.

Note that the channel strip’s Volume fader is all the way down.

	 4	 Drag the Volume fader to a different level.

The Toggle Level of Audio Channel Strips key command now toggles between the two volume 
levels. It does so for all channel strips of the same type at once, allowing you to create two 
different mixes from one set of channel strips.

You can use the following key commands to quickly switch between two different volume levels 
on a channel strip:

•• Toggle Level of Audio Channel Strips

•• Toggle Level of Auxiliary Channel Strips

•• Toggle Level of Output Channel Strips

•• Toggle Level of Input Channel Strips

•• Toggle Level of Bus Channel Strips
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Check channel strip levels
All channel strips feature a segmented level meter that shows the playback or input monitoring 
level. The input monitoring level is shown when you arm an audio track in preparation 
for recording.

Peak level display showing 
signal clipping

Volume fader

Level meter

The colors of the level meter segments provide an at-a-glance overview of individual channel 
strip monitoring levels:

•• Amber and yellow: These signals are safe, and will not clip the channel strip output.

•• Red: These signals are considered “hot” levels, but the occasional peak is nothing to worry 
about unless the clipping indicator is continually or regularly lit.

For more information about signal clipping, see Peak level display and signal clipping.

Change the level meter scale
You can customize the level meter using two different scales, when Show Advanced Tools is 
selected in the Advanced preferences pane.

	 1	 Choose Logic Pro > Preferences > Display.

	 2	 Click the Mixer tab, then choose a value from the Scale pop-up menu.

•• Exponential: Provides higher display resolution in the upper level meter range.

•• Sectional dB-linear: Provides the best possible display resolution across the entire level 
meter range.
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Set channel strip input formats
The channel input format determines the mono, stereo, or surround state of the channel strip. 
The symbol on the button indicates the current state as follows:

SurroundRightLeftStereoMono

•• Mono: One circle represents a mono input format. The level meter shows a single column.

•• Stereo: Two interlocked circles represent a stereo input format. The level meter divides into two 
independent columns when a stereo input format is chosen.

•• Left: Two circles, with the left one filled, indicate a left channel input format. Only the left 
channel of a stereo audio file is played back. The level meter shows a single column.

•• Right: Two circles, with the right one filled, indicate a right channel input format. Only the right 
channel of a stereo audio file is played back. The level meter shows a single column.

•• Surround: Five circles indicate the surround channel input format. The level meter divides 
into multiple linked columns (the number matches the project surround format) when the 
surround input format is chosen.

Set the channel strip input format
Do one of the following:

mm Click the Format button to switch between mono and stereo input format.

mm Click-hold the Format button, then choose an input format from the pop-up menu.
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Set channel strip pan or balance positions
Instead of having instruments compete with one another in a mix, you can separate elements by 
positioning audio and instruments in the stereo mix from left to right. Typically, you want to have 
the most important tracks (lead vocals, solo instruments, drums, bass) positioned in the center 
of the mix, and have other tracks (rhythm instruments, instruments doubling the melody) to the 
sides. In general, most of the mix should be close to the center, with tracks panned far to the 
sides only for an unusual effect.

The Pan (short for panorama) knob defines whether a track is heard from the left, right, or center 
of the stereo field. You can set the pan position for each track in a project.

•• Mono channel strips feature a Pan knob, which determines the position of a signal in the 
stereo image. At the center pan position, the channel strip sends equal amounts of the signal 
to both sides of the stereo image. If you were to increase the pan position on the left side and 
decrease it on the right, the sound would move to the left.

•• Stereo channel strips feature a Balance knob, which differs from the Pan knob in that it 
controls the relative levels of two signals (Left and Right) at their outputs.

Pan knob

Balance knob

Set a channel strip’s pan (or balance) position
Do one of the following:

mm Drag the channel strip’s Pan knob vertically or horizontally.

mm Option-click the Pan knob to return it to the center position.

mm Hold down Shift while you drag the knob to change the pan position in finer increments.

When a channel strip output is set to Surround, the Pan or Balance knob is replaced by a 
Surround knob.
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Mute and solo channel strips
You can silence (mute) a channel strip so that you don’t hear it when you play the project. 
Muting channel strips is useful when you want to compare how the project sounds with and 
without the target track, compare alternative versions of a track, or try different loops in a project.

You can also listen to a channel strip signal alone (solo), silencing all other channel strips. Soloing 
channel strips is useful when you want to work on a track or region individually; for example, 
when you’re editing regions on the track, re-recording a part, or adjusting volume curves.

Mute a channel strip
mm Click the channel strip’s Mute button.

The Mute button turns blue. Click the button a second time to restore the channel strip to its 
previous level.

Solo a channel strip
mm Click the channel strip’s Solo button.

The Solo button turns yellow. The Mute buttons of all unsoloed channel strips will flash blue, 
with the exception of external MIDI channel strips.

Solo a channel strip when another channel strip is already soloed
mm Option-click an unsoloed channel strip.

This action solos the selected channel strip and unsoloes any other channel strip.

Disable the solo state of one or more channel strips
Do one of the following:

mm Click an active Solo button.

mm Option-click any active Solo button. The solo state of all channel strips is deactivated.
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Make a channel strip solo-safe
mm Control-click an inactive Solo button.

A red slash across the Solo button indicates that the channel strip is solo-safe. The channel strip 
will not mute when you solo another channel strip. Control-click again to deactivate the channel 
strip’s solo-safe state.
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Work with plug-ins

Plug-ins overview
Plug-ins can be broken down into the following categories:

•• Audio effects: Can be inserted in audio, instrument, aux, and output channel strips. Logic Pro 
offers a range of digital signal processing (DSP) effects and processors that are used to color or 
tonally shape existing audio recordings, software instruments, and external audio sources—in 
real time.

•• MIDI effects: Can only be inserted in instrument channel strips. Logic Pro offers easy access to 
real-time MIDI processing formerly only possible via the Environment.

•• Software instruments: Can only be inserted in instrument channel strips. Logic Pro offers a 
range of software-based instruments that include innovative synthesizers, a powerful sampler, 
and authentic re-creations of vintage instruments, that can be used in real time.

•• GarageBand instruments: Can only be inserted in instrument channel strips. GarageBand 
instruments are accessed by holding down Option when clicking an Instrument slot.

Add, remove, move, and copy plug-ins
You can add plug-ins, replace a plug-in with a different one, and remove plug-ins from a channel 
strip. You can also move, copy, and bypass plug-ins.

Add a MIDI effect plug-in
Do one of the following:

mm Click the MIDI Effect slot, then choose a plug-in from the pop-up menu.

mm Place the pointer above or below an occupied MIDI Effect slot, click the green line that appears, 
then choose a plug-in from the pop-up menu.
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Add an audio effect plug-in
Do one of the following:

mm Click an Audio Effect slot, then choose a plug-in from the pop-up menu.

The last visible empty Audio Effect slot in a channel strip is shown at half its height; use it in the 
same way.

mm Option-click an Audio Effect slot.

You can now choose legacy plug-ins from the pop-up menu.

Add an instrument plug-in
Do one of the following:

mm Click the Instrument slot, then choose a plug-in from the pop-up menu.
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mm Option-click an Instrument slot.

You can now choose legacy plug-ins from the pop-up menu.

Replace a plug-in
mm Place the pointer over the plug-in slot, click the pull-down arrows that appear to the right, then 

choose a plug-in to replace the existing one.

Remove a plug-in
mm Place the pointer over the plug-in slot, click the pull-down arrows that appear to the right, then 

choose No Plug-in from the pop-up menu.

Move a plug-in
mm Drag the plug-in up or down in the channel strip, or to another channel strip.

For guidance, use the colored line that appears when moving the plug-in.

Copy a plug-in
mm Hold down Option and drag the plug-in to an unused slot.
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Bypass a plug-in
If you want to deactivate a plug-in, but don’t want to remove it from the channel strip, you can 
bypass it. Bypassed plug-ins don’t drain system resources.

Do one of the following:

mm Place the pointer over the plug-in slot, then click the Bypass button that appears to the left.

mm Click the center area of the plug-in slot to open the plug-in window, then click the Bypass button 
at the left side of the plug-in window header.

The plug-in slot turns gray, indicating that the plug-in is bypassed.

Use the Channel EQ
The Channel EQ is an audio effect, like any other. In most mixing situations, it’s used as the first 
effect on a channel strip, allowing you to sculpt the sound of the channel strip signal before 
applying other effects.

Add a Channel EQ
Do one of the following:

mm If Audio Effect slot 1 is not used: Double-click the EQ area.

The Channel EQ is inserted in the first Audio Effect slot and the EQ area changes to a thumbnail 
view of the Channel EQ display.

mm If Audio Effect slot 1 is used: Option–double-click the EQ area.

The Channel EQ is inserted as the first plug-in, all existing plug-ins are moved one slot down, and 
any existing automation data is redirected.

mm If Audio Effect slot 1 is used: Double-click the EQ area.

The Channel EQ is inserted in the next available (unused) slot.
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Work in the plug-in window
You edit plug-in parameters in the plug-in window, which opens automatically when you insert 
a plug-in.

Note:  You can turn off this behavior by deselecting the “Open plug-in window on insertion” 
checkbox in the Logic Pro > Preferences > Display > Mixer pane.

The header area at the top of a plug-in window is common to all plug-ins. You can use it to 
adjust the size of the window, link plug-in windows when more than one is open, switch the 
plug-in parameter view, and route side chain signals.

Some plug-ins have additional parameters that don’t appear in the main plug-in window. In this 
case, a disclosure triangle appears at the bottom-left corner of the plug-in window.

Open a plug-in window (when it’s closed)
mm Click the center area of the plug-in slot.

Close a plug-in window
mm Click the close button at the top-left corner of the plug-in window.

Hide or show the plug-in window header
mm Click the icon at the top-right corner of the plug-in window.

Adjust the size of a plug-in window
Do one of the following:

mm Drag any corner of the plug-in window.

mm Choose a window size from the plug-in window’s View menu.

Both of these scalings apply to individual plug-ins.
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Switch the plug-in parameter view
mm Choose Editor or Controls from the plug-in window’s View pop-up menu.

Editor view shows the plug-in’s graphical interface, if it offers one. Controls view displays all 
plug-in functions as a set of horizontal sliders, with numerical fields to the left of each parameter. 
These fields are used for both the display and entry of data.

Link or unlink plug-in windows
mm Click the Link button to the right of the plug-in window header.

When linked, a single plug-in window is used to display all open plug-ins. Each time you open a 
new plug-in, the window updates to reflect the newly chosen plug-in.

Route an instrument channel strip as the side chain signal
	 1	 Click the instrument channel strip’s Send slot, then choose an unused bus from the 

pop-up menu.

An aux channel strip is created.

	 2	 Click-hold the Output slot of the aux channel strip, then choose No Output from the 
pop-up menu.

The output signal of the aux channel strip, which you don’t want to hear, is turned off.

	 3	 Open the plug-in from the instrument channel strip.

	 4	 Choose the newly created aux channel strip from the plug-in’s Side Chain pop-up menu.

The plug-in processes the audio of the aux channel strip chosen in the Side Chain pop-up menu, 
and not the audio of the instrument channel strip that the plug-in is inserted into.
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Hide or show additional parameters (if available for the plug-in)
mm Click the disclosure triangle at the bottom-left corner of the plug-in window.

Work with plug-in settings
Plug-in settings are stored with the project file and are automatically recalled the next time 
the project is opened. In the plug-in window, you can load, copy and paste, compare, save, 
create default, and delete plug-in settings. You can also load, save, and delete plug-in settings in 
the Library.

Load a plug-in setting
Do one of the following:

mm In the plug-in window, do one of the following:

•• Open the Settings pop-up menu, then choose a setting from the submenus.

•• Open the Settings pop-up menu, click Load Setting, then choose a setting in the dialog 
that appears.

mm In the Library, click the effect or instrument slot of the relevant channel strip, browse the plug-in 
presets in the Library, then choose the preset you want to add.

Choose the next or previous plug-in setting
Do one of the following:

mm In the plug-in window, do one of the following:

•• Click the left arrow to choose the previous setting, or the right arrow to choose the 
next setting.

•• Open the Settings pop-up menu, then choose Next Setting or Previous Setting.

mm Use the following key commands:

•• Next Plug-in Setting

•• Previous Plug-in Setting

•• Next Plug-in Setting or EXS Instrument

•• Previous Plug-in Setting or EXS Instrument

•• Next Channel Strip or Plug-in Setting or EXS Instrument

•• Previous Channel Strip or Plug-in Setting or EXS Instrument
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Compare edited plug-in parameters with the original setting
You can audition your audio or instrument track through two variations of a plug-in.

	 1	 Adjust any of the plug-in parameters.

The Compare button turns blue, indicating that you have made changes, but have not saved the 
edited settings in the project.

	 2	 Click the Compare button to listen to the setting that was originally saved with the project.

The Compare button turns black.

	 3	 Click the Compare button again to switch back to the edited plug-in setting.

The Compare button again turns blue.

Copy and paste a plug-in setting
	 1	 To copy the plug-in setting, do one of the following:

•• Click the Copy button in the plug-in window header.

•• Open the Settings pop-up menu in the plug-in window, then choose Copy Setting.

All parameter settings are copied into a plug-in settings Clipboard, which is independent of the 
global Clipboard.

	 2	 To paste the plug-in setting, do one of the following:

•• Click the Paste button in the plug-in window header.

•• Open the Settings pop-up menu in the plug-in window, then choose Paste Setting.

Reset a plug-in setting
mm In the plug-in window, open the Settings pop-up menu, then choose Reset Setting.

Save a plug-in setting
Do one of the following:

mm In the plug-in window, do one of the following:

•• Open the Settings pop-up menu, then choose Save Setting. This command overwrites the 
existing plug-in setting.

•• Open the Settings pop-up menu, then choose Save Setting As. Name and save the new 
setting. You can also create a folder location, which must be in the associated plug-in folder.

mm In the Library, click the Save button.

Create a default plug-in setting
mm In the plug-in window, open the Settings pop-up menu, then choose Save Setting As Default.

This setting will be loaded whenever that plug-in type is opened. You can also revert to this user 
default setting at any point by choosing Recall Default Setting from the Settings pop-up menu.

Delete a plug-in setting
Do one of the following:

mm In the plug-in window, open the Settings pop-up menu, then choose Delete Setting.

mm In the Library, click the Delete button.
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Work with plug-in latencies
Audio processed through plug-ins is subject to small timing delays, known as latency. For 
example, a software instrument running inside Logic Pro will only have an output latency, 
because it’s generated inside the application. An audio recording that is being monitored in real 
time will have both an input and an output latency. These two values are summed, resulting in 
an overall monitoring latency figure. Each further process—such as the use of an effect plug-in, 
for example—will also add an amount of latency, which is combined with the input and output 
latency figure, depending on whether a software instrument or audio channel strip is in use.

In Logic Pro, you can compensate for internal latencies introduced by plug-ins, ensuring that all 
track and channel strip output is perfectly synchronized.

You can also turn plug-in latency compensation on or off, for audio and software instrument 
tracks or for all channels (audio, instrument, aux, output, and ReWire). When this setting is turned 
on, Logic Pro compensates for latency introduced by plug-ins, ensuring that audio routed 
through them is synchronized with all other audio. This is achieved by calculating the amount 
of latency caused by plug-ins, and then delaying audio streams by an appropriate amount—or 
shifting instrument and audio tracks forward in time.

Turn on Low Latency mode
Do one of the following:

mm Click the Low Latency Mode button in the control bar.

mm Select the Low Latency Mode checkbox in General Audio preferences.

Plug-ins will be bypassed to ensure that the maximum delay that can occur across the entire 
signal flow (of the current track’s signal path) remains under the Limit slider value in General 
Audio preferences.

The sound may change when you turn on Low Latency mode. Depending on the plug-ins in 
use, the change in sound can be anything from subtle to dramatic. If plug-ins being used do not 
exceed the total latency limit, there will be no audible difference.

Turn on plug-in latency compensation
mm Choose an option from the Compensation pop-up menu in General Audio preferences.

•• If latency-inducing plug-ins are inserted into audio or instrument channel strips, Logic Pro 
automatically shifts these tracks forward in time. The advantage of this method is that other 
channel strips (that do not contain latency-inducing plug-ins) do not need to be delayed.

•• If latency-inducing plug-ins are inserted into aux or output channel strips (or ReWire channels, 
if used), Logic Pro delays all other audio streams by an appropriate amount.

•• With plug-in latency compensation set to All, Logic Pro shifts the bass track forward by 10 ms, 
thus synchronizing the bass and drum tracks. Logic Pro will then delay both streams routed 
to the output channel by 30 ms, aligning them with the guitar tracks. The aux channel strip 
that the vocals are streamed to is also delayed by 15 ms, aligning it with the drum and guitar 
streams (in other words, the 15 ms delay is increased to 30 ms). The precise calculations 
required for each stream are handled automatically.
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Use the Audio Units Manager
Logic Pro uses the Apple Audio Units Validation Tool to ensure that only plug-ins that fully 
comply with the Audio Units specification are used in Logic Pro. This minimizes problems that 
may be caused by third-party Audio Units plug-ins. The Audio Units validation process takes 
place automatically when Logic Pro is first opened, when an updated version of Logic Pro is 
installed, and when you install new Audio Units plug-ins, or update existing ones. The results of 
the validation scan are shown in the Compatibility column of the Audio Units Manager window.

  The Audio Units Manager is only available when Show Advanced Tools is selected in the 
Advanced preferences pane.

Any Audio Units plug-ins that fail the validation test can be manually enabled in the Audio Units 
Manager window. You can also disable Audio Units plug-ins that you don’t want to use, even if 
they pass the validation scan.

Click the Reset & Rescan Selection button to rescan a selection of plug-ins after installing plug-
ins/updaters or moving components in the Finder, while Logic Pro or the Audio Units Manager 
is open. They will be activated automatically, if they pass the validation scan. Note: If you press 
Control-Shift while opening Logic Pro, the Audio Units Safe mode will be used. Only plug-ins that 
pass the validation test will be available; manually activated plug-ins that failed the validation 
test will not be available.

Open the Audio Units Manager
mm Choose Logic Pro > Preferences > Audio Units Manager.

Manually enable plug-ins that fail the validation test
mm Select the plug-in’s checkbox in the Use column to enable it.

You should be aware that these plug-ins can cause problems. If you encounter problems with 
manually-enabled failed plug-ins, click the Disable Failed Audio Units button.

Enable or disable a plug-in manually
mm Deselect the corresponding checkbox to disable the plug-in.

Disable a plug-in
mm Deselect the plug-in’s corresponding checkbox in the Use column.
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Work with channel strip settings
Channel strip settings (CST files) are specific to each channel strip type. Instrument channel strips 
feature a number of instrument settings, separated into instrument, GarageBand, and Jam Pack 
categories. Audio channel strips offer effect routings optimized for particular instrument, vocal, 
and other processing tasks. Similarly, output and auxiliary channel strips provide channel strip 
settings for particular mastering or sweetening processes.

You can load, copy, paste, reset, save, and delete channel strip settings in a channel strip. You can 
also access channel strip settings in the Library.

Load a channel strip setting
mm Click the Setting button at the top of the channel strip, then choose a setting from the 

pop-up menu.

Choose the next or previous channel strip setting
mm Click the Setting button at the top of the channel strip, then choose Next or Previous Channel 

Strip Setting from the pop-up menu.

Copy or paste a channel strip setting
mm Click the Setting button at the top of the channel strip, then choose Copy or Paste Channel Strip 

Setting from the pop-up menu.

Reset a channel strip setting
mm Click the Setting button at the top of the channel strip, then choose Reset Channel Strip from the 

pop-up menu.

Save a channel strip setting
	 1	 Click the Setting button at the top of the channel strip, then choose “Save Channel Strip Setting 

as” from the pop-up menu.

	 2	 In the dialog that appears, select the appropriate folder, enter a name for the channel strip 
setting, and click Save.

Delete a channel strip setting
mm Click the Setting button at the top of the channel strip, then choose Delete Channel Strip Setting 

from the pop-up menu.
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Control channel strip signal flow in the Mixer

Route audio via insert effects
When a plug-in is inserted directly into a channel strip, it is termed an insert effect. The channel 
strip’s entire signal is processed by the effect plug-in. This behavior is suitable for equalizers or 
dynamic effects, such as compressors. If you have enough processing capacity, you can use up to 
15 insert effects on each channel strip.

When multiple effect plug-ins are routed to a channel strip via inserts, they are said to be routed 
in series. In this type of configuration, the output of one effect is added to the incoming signal 
and becomes the input of the next effect in the chain. The image below illustrates this process.

On this channel strip, the effect 
plug-ins (Compressor, Channel EQ, 
Chorus) are routed in series.
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Route audio via send effects
You use send effects when you want to isolate effect plug-ins from a channel strip’s signal flow, or 
when you want to use the same effect on more than one channel strip. By creating a send, you 
split the channel strip’s signal. The channel strip’s main signal continues its route to the chosen 
output. The other part of the signal is routed down a parallel path, via a bus to an aux channel 
strip. You use the Send Level knob to control the amount of signal that is sent via the bus. This is 
known as parallel routing. You can route the signal back into the main signal flow at a later point, 
or you can output the signal from the aux channel strip.

The primary advantage of this approach over routing via insert effects is efficiency. This method 
allows multiple channel strips to be processed by one inserted effect, which saves vast amounts 
of processing power (and time) when compared to the alternative of inserting the same effect 
directly into multiple channel strips. Another bonus is that you can quickly switch between wet 
and dry versions of all channel strips that are sent to an aux channel strip, by simply bypassing 
the effect on the aux. Similarly, you can completely change the effects configuration for multiple 
sent channel strips by choosing different effects for the aux channel strip.

The following image illustrates a channel strip routed to multiple aux channel strips via sends—
with reverb, chorus, and delay effects assigned to aux channel strips 1, 2, and 3, respectively. 

The effect plug-ins 
(Reverb, Delay, Pitch 
Shifter) are assigned to 
aux channel strips 1, 2, 
and 3.

On this channel strip, the 
plug-ins are routed in parallel, 
via sends.

The channel strip’s signal is split and routed to three separate effects, one on each aux channel 
strip. These three independent signals are then sent back from the respective aux channel strips 
and combined into an output stream from the original channel strip. You can create up to eight 
sends on each audio, instrument, or aux channel strip.
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Use aux channel strips

Aux channel strips overview
Aux channel strips can be used to create subgroups, to submix, to route a signal to multiple 
destinations, and as additional destination channels for multi-output instruments. Typically, you 
create aux channel strips as you need them. There are three ways to do this:

•• An aux channel strip is created automatically when a send assignment is made from a 
channel strip, except when the chosen bus is already in use as an input source on another 
channel strip.

•• When a multi-output instrument such as the EXS24 mkII is inserted into an instrument channel 
strip, several aux channel strip assignments are made “behind the scenes.” You then must 
create the required number of aux channel strips by clicking the Add button (+) at the bottom 
of the instrument channel strip. Each time you click it, a new aux channel strip is created (and 
automatically assigned to particular instrument outputs).

•• You can also create aux channel strips by choosing Options > Create New Auxiliary Channel 
Strip from the Mixer menu bar.

Create mix subgroups
You can group several channel strips and route them via a single bus to a single aux channel 
strip. This provides you with one set of controls over the entire group.

For example, say your mix contains multiple drum tracks that you want to manage using a single 
set of channel strip controls, or you want to put a compressor across the whole drum kit. You can 
do this by sending each of the drum tracks to the same bus, which in turn sends their signals 
to the same aux channel strip. You might then route your vocal tracks to a second aux channel 
strip, providing a separate group control for these channel strips. Finally, you have the option to 
output both subgroups (drums and vocals) to the same destination or to separate destinations.

Note:  There are some similarities between using aux channel strips as subgroups and working 
with channel strip groups. You can control the group/subgroup properties from one set of 
channel strip controls. However, Mixer groups are used to control channel strip group properties, 
and not the signal flow.

Create a subgroup using an aux channel strip
	 1	 Select multiple channel strips by doing one of the following:

•• Shift-click the channel strips you want to group.

•• Drag over the background of the channel strips (drag horizontally across multiple channel 
strips over the word Inserts, or I/O text, for example). 

	 2	 Click-hold the Output slot of a selected channel strip, then choose a bus from the pop-up menu.

The Output slots of all selected channel strips reflect the chosen bus. A new aux channel strip 
is created, except when the chosen bus is already in use as an input source on another channel 
strip. Its Input slot contains the channel strip signal flow coming via the chosen bus.

	 3	 Click-hold the Output slot of the aux channel strip, then choose the output destination for the 
main mix.

	 4	 Use the aux channel strip controls to process the submix—adding inserts, setting volume and 
pan, and so on.



	 Chapter  16    Mix a project	 511

Send signals to multiple destinations
You can route a signal to several output destinations, using aux channel strips.

For example, you might have a main signal with the output destination set to external speakers. 
At the same time, you want to hear the signal as a separate headphone mix, including some 
additional effects. To do this, you would set up two separate output destinations for your signal, 
with the aux channel strips controlling the headphone mix, including the additional effects.

Output a single channel strip to two destinations
	 1	 Click-hold the channel strip’s Output slot, then choose the main output destination for the mix, 

such as speakers.

	 2	 Click-hold the channel strip’s Send slot, then choose the bus to send the separate signal to.

An aux channel strip is created automatically. Your chosen bus is reflected in the aux channel 
strip’s Input slot. 

	 3	 Click-hold the aux channel strip’s Output slot, then choose the second output destination for the 
mix, such as headphones.

Your signal flow is now routed to two separate output destinations. The main signal flow to the 
speakers is heard in its “dry” state. The second signal flow—via a bus to the aux channel strip, and 
output to headphones—can be modified and heard in its “wet” state.

Use multi-output instruments
There are two reasons to use multi-output instruments in your mix:

•• To process each sound individually in a drum kit, for example, with different effects

•• To route the different software instrument outputs to different outputs on your audio interface

Logic Pro supports the multiple outputs of Drum Kit Designer, the EXS24 mkII, Ultrabeat, and all 
Audio Unit instruments. One or more multi-output options may be displayed in addition to the 
mono and stereo versions shown in the plug-in pop-up menu of the Instrument slot.

Note:  Not all instruments offer multi-output options.
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Insert and set up a multi-output instrument
	 1	 Click-hold the respective Instrument slot, then choose the multi-output instance from the 

pop-up menu.

The first two outputs of a multi-output instrument are always played back as a stereo pair by the 
instrument channel strip that the plug-in is inserted into. Additional outputs (3 and 4, 5 and 6, 
and so on) are accessed via aux channel strips.

	 2	 In the plug-in window, set up the output routing for individual sounds or samples. This is 
generally done using a pop-up menu with entries such as Main, 3-4, 5-6, and so on.

	 3	 In the Mixer, click the Add button (+) of the instrument channel strip that you inserted the multi-
output instrument into.

Note:  The Add button (+) appears only on multi-output instrument channel strips.
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An aux channel strip is created to the right of the multi-output instrument channel strip. Use this 
new channel strip to isolate and route a sound for independent mixing and processing.

	 4	 Repeatedly click the Add button (+) to create more aux channel strips, for all stereo or mono 
outputs available to the instrument plug-in.

You should create only as many aux channel strips as are required for the number of outputs 
used by the multi-output instrument.

After you create the first aux channel strip for your multi-output instrument, a Delete button (–) 
appears beside the Add button (+).

Click the Delete button (–) to remove aux channel strips.
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Use output channel strips
By default, a project contains one output channel strip that takes the signal from all the 
individual tracks in the project. You add additional output channel strips to assign submixes, or 
to prevent them from being controlled by the master channel strip.

When using output channel strips in this way, you can’t apply any further send effects to the 
signal flow, as you would using aux channel strips. You can, however, control settings and insert 
effect plug-ins using the individual controls of the output channel strip.

Unlike aux channel 
strips, output channel 
strips do not have Send 
slots.

In some cases, you might want to prevent individual output channel strips from being controlled 
by the master channel strip—outputs used as send effects to external hardware devices, for 
example. Simply make such output channel strips solo-safe and they won’t be affected by the 
master channel strip.

The Insert slots of output channel strips allow signal processing during the mastering process, 
as well as during normal playback. Typical mastering tools are the compressors, de-essers, and 
equalizers. Due to technical reasons, you can only use plug-ins that don’t require mono to stereo 
conversions. In other words, you can use stereo to stereo plug-ins on stereo output channel 
strips, and mono to mono plug-ins on mono output channel strips. Surround (or multi-mono) 
versions of plug-ins can be used on mono or stereo output channel strips. Mono to multi-mono 
variants can be used on mono output channel strips. Stereo to surround, stereo to multi-mono, 
and true surround versions of plug-ins are accessible in stereo output channel strips.
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Define a channel strip’s stereo output
In Logic Pro, you can choose the physical output pair on which the stereo output is played. By 
default, it’s played on Stereo Output (Output 1-2). However, you can easily change the stereo 
output preference—if you’re exchanging projects with another studio that uses a different 
output pair, for example.

You can also define the output pair for individual channel strips in the Mixer.

Define the stereo output for a channel strip 
	 1	 Choose Logic Pro > Preferences > Audio.

	 2	 Click the I/O Assignments tab, then the Output tab.

	 3	 Choose an output pair from the Output pop-up menu in the Stereo section.

The Mirroring checkbox becomes available for all chosen output pairs, with the exception of 
Output 1-2.

	 4	 Do one of the following:

•• Deselect the Mirroring checkbox to have the output signal routed to the chosen output pair 
(Output 3-4, for example).

•• Select the Mirroring checkbox to have the output signal routed to the chosen output pair 
(Output 3-4, for example), as well as to the physical outputs (Output 1-2). This is useful when 
feeding the signal to a second pair of monitors, for example.

Define the output pair for a channel strip
mm Click-hold the channel strip’s Output slot, then choose an output pair from the pop-up menu.

Define a channel strip’s mono output
You can define a channel strip’s mono output setting directly from the channel strip’s 
Output slot.

Define the mono output for a channel strip
mm Click-hold the channel strip’s Output slot, then choose a mono output from the pop-up menu.
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Work with channel strip groups in the Mixer

Grouping overview
  The channel strip grouping feature is only available when Show Advanced Tools is selected 

in the Advanced preferences pane.

Prior to mixing, you may find it useful to define some logical channel strip groups. You could, for 
example, group all drum channel strips under one drum group. This would allow you to control 
the group meters (volume, pan, and so on) using a single control, while still maintaining the 
relative parameter values of each channel strip. You can have a maximum of 32 groups and a 
channel strip can be a member of multiple groups.

You can also use aux channel strips for grouping purposes, but the emphasis is on controlling 
channel strip signal flow.

Group inspector
You use the Group inspector to define the behavior of each channel strip group. It contains the 
following settings:

•• “Groups active” checkbox: Enables or disables all groups and group controls. Turn off this setting 
to edit track parameters outside of all groups. Press Command-G to do so when the Group 
Settings window is closed.

•• On checkbox: Enables or disables a particular group. Turn off this setting to edit track 
parameters outside of the specified group.

•• Name field: Shows the group name, which you can create or edit by double-clicking.

•• H checkbox: When selected, hides all tracks belonging to the group. If the Hide Track buttons of 
grouped tracks are in different states, the H checkbox displays “–”.

•• Editing (Selection) checkbox: When selected, selecting a region in the Tracks area selects the 
same horizontal region range of all tracks in the group.

•• Phase-Locked Audio checkbox: Defines whether an edit group is phase-locked or independent 
when quantizing audio.

•• Automation Mode checkbox: When selected, changing the automation mode of one track 
changes the automation mode of all tracks in the group.
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•• Volume checkbox: When selected, changing the Volume fader of one track changes the 
volume level of all tracks in the group. The channel strips continue to maintain their relative 
volume levels.

•• Mute checkbox: When selected, changing the mute state of one track changes the mute state 
of all tracks in the group.

•• Input checkbox: When selected, changing the input state of one track changes the input state 
of all tracks in the group.

•• Pan checkbox: When selected, changing the Pan knob of one track changes the Pan knob of all 
tracks in the group. The channel strips continue to maintain their relative pan positions.

•• Solo checkbox: When selected, changing the solo state of one track changes the solo state of 
all tracks in the group.

•• Record checkbox: When selected, changing the record-enabled state of one track changes the 
record-enabled state of all tracks in the group. Multiple channel strips can be simultaneously 
record enabled only if they use different inputs.

•• Send 1 to 8 checkboxes: When selected, links the Send Level knobs individually for Send slots 1 
to 8, while still maintaining the relative positions between them.

•• Color checkbox: When selected, changing the color of one track assigns this color to all tracks 
in the group.

•• Track Zoom checkbox: When selected, zooming a region in the Tracks area zooms the regions of 
all tracks in the group.

•• Hide Track (H) checkbox: When selected, selecting the Hide Track button of a grouped track 
selects the Hide Track buttons of all tracks in the group.

Open the Group inspector
Do one of the following:

mm Double-click the header area of the Group inspector.

mm Click the Group inspector’s disclosure triangle.

mm Click the Group slot of a channel strip, then choose Open Group Settings from the pop-up menu.

mm Choose Mix > Show Groups.

Open the Group inspector as a floating area
mm Drag the Group inspector out of the inspector.
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Edit channel strip group membership
You can add a channel strip to, or remove a channel strip from, single or multiple groups. You 
can also temporarily disable all group parameter links—applying a Group Clutch—to change the 
volume of an individual channel strip, for example.

Add a channel strip to a group
mm Click the channel strip’s Group slot, then choose a group from the pop-up menu.

Add a channel strip to multiple groups
mm Click the channel strip’s Group slot, then hold down Shift while choosing a group from the 

pop-up menu.

Quickly add the most recent group setting to another channel strip
mm Hold down Option and click the channel strip’s Group slot.

The most recently accessed group setting—including overlapping groups—is applied to the 
current channel strip.

Remove a channel strip from a group
mm Click the Group slot, then choose the group that you want to remove the channel strip from.

Remove a channel strip from all groups
mm Click the Group slot, then choose No Group.

Disable all groups
Do one of the following:

mm Choose Mix > Disable Groups (or press Command-G).

mm Choose Options > Disable Groups from the Mixer menu bar.

mm Deselect the “Groups active” checkbox in the Group Settings window.

While Group Clutch is active, all Group slots change color, from yellow (normal) to a light gray (all 
groups temporarily disabled).



	 Chapter  16    Mix a project	 519

Automate groups
When you automate your mix functions (volume, pan, mute, and so on), any channel strip 
group member can act as the mix automation master for that group. When you use that group 
member to write an automation parameter value, it’s also written for the other group members, 
depending on their automation mode.

The data is written individually for each channel strip. As a result, you can disable the group later 
without affecting the automation of any group member, and you can edit or change channel 
strips individually when they are removed from the group.

For full details about automation, see Automation overview.

Surround panning in the Mixer
You can mixdown in several surround formats, even if your audio hardware offers only two 
outputs. Because it would be difficult to mix or record in surround format without being able 
to hear the result, it’s best not to select this option if you’re monitoring or mixing through 
stereo speakers. All audio, instrument, and aux channel strips can be individually set to different 
surround formats.

  Surround panning is available when Surround is selected in the Advanced 
preferences pane.

Set a channel strip’s output to surround
mm Click-hold the channel strip’s Output slot, then choose Output > Surround from the 

pop-up menu.

The Surround Panner control replaces the Pan knob. The loudspeakers are represented by dots, 
and the pan position is indicated by a green dot that can be dragged.

For full details about using the surround feature, see Logic Pro X surround overview.
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Binaural panning in the Mixer

Binaural panning overview
An important part of mixing audio signals is the placement of individual sound sources at 
different spatial positions. Most common recording and mixing techniques simply send a given 
signal at different levels to the available loudspeakers—two for stereo, or more for quadraphonic 
or surround setups—to create a virtual sound stage.

This approach is somewhat flawed, however, as human beings are able to locate sound 
sources at different positions with just two ears. Virtually all spatial information for all sounds is 
included in the two signals arriving at the two eardrums. From these signals, human beings can 
determine characteristics such as inter-aural time, level differences, and—based on the listening 
experience—information about the spatial origin of the sounds being heard. Are they coming 
from in front or behind, from the left or right, from above or below? This ability to perceive 
where a sound originates from is referred to as binaural hearing.

In theory, the spatial positioning of any sonic experience can be reproduced during playback, so 
no special techniques need to be employed during recording. There is, however, one drawback to 
this approach: every person has differently shaped ears and different body and head proportions, 
all of which influence the way sound signals arrive at the eardrum—not to mention aspects such 
as hearing loss, subjective responses to the sounds being heard, and so on. Given these physical 
differences, each person listening to the same sound source, while standing or sitting in the 
same position, will hear slightly different binaural signals.

Therefore, perfect reproduction would only be possible if you could make a recording with tiny 
microphones placed inside your auditory canals. Because this is impractical, binaural hearing 
has been emulated in sound laboratories by using mannequin heads with built-in microphones. 
This approach has led to binaural recordings to fit the average person, which are more or less 
compatible with the way most people hear.

Playback of binaural recordings is best suited to headphones, ideally combined with signal 
conditioning (processing) that ensures the signals are accurately reproduced. Given a specialized 
listening environment, it’s also possible to reproduce these signals with loudspeakers, utilizing a 
process known as crosstalk cancellation.

As you are unlikely to have the technology required to make binaural recordings, your best 
chance of simulating binaural signals is by processing the sound signal on playback. This is 
known as the head-related transfer function (HRTF), which approximates the change that a signal 
undergoes on its way from the source to the eardrum.
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Use the Binaural Panner
  The Binaural Panner is available when Surround is selected in the Advanced 

preferences pane.

By setting the channel strip’s output to Binaural, you can use the Binaural Panner to position 
the signals on the panning plane. The signal that results from using the Binaural Panner is best 
suited for headphone playback. You can, however, process the Binaural Panner output using 
the Binaural Post-Processing plug-in, which allows you to play back the binaural pan effect 
through loudspeakers.

You control the panning effect in the Binaural Panner by positioning the panning pucks on the 
panning plane at the top of the window, and by adjusting some additional parameters. These are 
the window’s main elements:

Pucks

Panning plane

3D image

Size field

Mode buttons

Doppler button

Click to show the Extended 
parameters.

•• Angle, Elevation, Distance: Information fields that adjust automatically when changes are made 
to the puck positions.

•• Spread: Information field that adjusts automatically when changes are made to the puck 
positions. You can also interact directly with it by dragging its numerical value. (Making 
changes here also affects the left and right puck positions.)

•• Panning plane: Area for positioning the signals—using the pucks—in the stereo image.

•• Pucks: Used for positioning the signals on the panning plane—pan and direction.

•• 3D image: Represents the resulting position of the audio signal. This is purely a visual aid, and 
cannot be interacted with directly.

•• Mode buttons: Determine the virtual shape of the panning plane, which can be planar 
or spherical.

•• Size field: Determines the size of the plane or sphere, expressed as the radius of the 
circular plane.

•• Doppler button: Turns on or off the Doppler effect—a change in the pitch of a signal perceived 
by a person who is moving relative to the source of the signal.

•• Extended parameters: Click the disclosure triangle to reveal additional parameters for 
headphone playback and Planar mode.
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Open the Binaural Panner
	 1	 Click-hold the channel strip’s Output slot (on mono or stereo channels), then choose Binaural 

from the pop-up menu.

The Binaural Pan control replaces the Pan knob.

	 2	 Double-click the Binaural Pan control to open the Binaural Panner.

Control the binaural pan position
	 1	 Drag the left or right puck (panning pucks) to make the stereo image wider or narrower. 

The pucks also work on a second axis—up and down—relative to the third puck.

	 2	 Drag the third puck (the direction puck) to determine the forward and backward direction.

As you adjust the direction puck, the two panning pucks move accordingly. The Angle, Elevation, 
Distance, and Spread values also change.

	 3	 Select the Mode (virtual shape) of the planning plane:

•• If set to Planar, the panning results are shown on a flat circular plane. 
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•• If set to Spherical, the results are placed on a virtual sphere. If it helps, imagine the sphere as a 
virtual head. When the direction puck is placed in the top half of the circular plane, the sound 
is in front of the listener. As the direction puck is moved toward the lower half of the plane, the 
sound passes up, and over your head, and ends up behind you.

	 4	 Set the size of the plane or sphere by doing one of the following:

•• Drag the Size field value up or down.

•• Double-click the Size field, then enter a new value.

•• Option-click the Size field to reset it to its default value (1.50m).

	 5	 Click the Doppler button to turn on or off the Doppler effect.

	 6	 Select the Diffuse-Field Compensation checkbox in the Extended Parameters area to ensure a 
neutral sound for headphone playback, utilizing diffuse-field compensation. 

Note:  When using multiple Binaural Panners on several channel strips, turn this option off and 
route the output of the Binaural Panners to an aux channel strip, in which you insert the Binaural 
Post-Processing plug-in. The Binaural Post-Processing plug-in allows you to apply diffuse-field 
compensation to all Binaural Panner outputs at once, saving CPU power.

	 7	 If in Planar mode, use the Extended Parameters sliders to control the vertical offset and tilt of the 
circular plane. Watch the 3D image when changing them to get a clear idea of their functions. 
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Use the Binaural Post-Processing plug-in
The Binaural Post-Processing plug-in is available in aux and output channel strips. This plug-in 
allows you to apply various compensation modes on a stereo bus or output, through which 
several, or all, binaural signals are routed. This saves CPU power and makes it easy to switch 
between compensation modes.

For full details about this plug-in, see the Logic Pro Effects manual.
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Work with MIDI channel strips in the Mixer

MIDI channel strips overview
MIDI channel strips in the Mixer work as remote controls for the mixing parameters of your MIDI-
controlled sound modules and synthesizers, such as volume and pan.

Program

Assign 1 to 5

Bank

•• Program buttons: Use to select a sound by name. Click one to open a pop-up menu that 
contains either GM sound names (the default setting) or sound names created or imported by 
the user. Each channel strip has its own pop-up menu, whose content can vary depending on 
the Bank number selected in the Bank fields.

•• Bank fields: If your sound source “understands” bank select events, you can choose the bank 
number for each of the MIDI channel strips. The lower value sends controller value 32, and the 
upper value sends controller value 0; this is for MIDI instruments that have 127 x 127 banks. 
You can use several different bank select formats (see Custom bank selects on page 784) 
if your device does not use the standard controller 0/32 messages. Remember that not all 
synthesizers support bank select events.

•• Assign 1 to 5: Display up to five knobs that you can freely assign to any MIDI controller number.

View the MIDI channel strip controls (if hidden)
mm Choose View > MIDI Channel Strip Components from the Mixer menu bar, then choose 

a component.

The basic channel strip controls, such as volume, pan, and mute, are always shown on MIDI 
channel strips.
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Adjust elements of MIDI channel strips
On MIDI channel strips, you can adjust the volume level and pan position, control MIDI data 
transmission, and assign controller data.

Adjust the volume of a MIDI channel strip
mm Drag the Volume fader up or down. 

Controller #7 is sent via your MIDI interface.

Set the pan position of a sound
mm Drag the Pan knob vertically.

Controller #10 is sent via your MIDI interface.

Stop or start the sending of MIDI data from the MIDI channel strip
mm Click the Mute button.

When the Mute button is on, the MIDI channel strip stops sending MIDI data.

Assign a controller to one of the knobs
You can use each of the Assign 1 to 5 knobs to send MIDI controller data to the external MIDI 
instrument, allowing you to remotely control parameters such as volume, pan, and chorus.

	 1	 Click the label above the knob.

	 2	 Choose a controller from the pop-up menu.

Save and restore MIDI channel strip settings
MIDI channel strip settings in the Mixer directly affect the Track inspector. The current settings of 
all channel strips are saved with the project.

If the active settings of your sound module are not maintained when you switch it off (some 
devices reset to default values), any Logic Pro Mixer settings that affect the unit will be lost. 
Fortunately, Logic Pro Mixer settings are automatically restored and transmitted to all MIDI 
devices when you reload the project. If this doesn’t happen—due to MIDI communication issues 
with some devices, for example—you can manually resend the MIDI channel strip settings.

Resend the MIDI channel strip settings
mm Choose Options > Send All MIDI Mixer Data from the Mixer menu bar.
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Customize the Mixer

Change the Mixer view
When the number of channel strips in the Mixer exceeds the amount of available space, you can 
change the Mixer view.

You can use the Single, Tracks, or All button to display only those channel strips that you need 
for the task at hand, or filter channel strips by type, using the channel strip filter buttons. You also 
have the option of working with narrow channel strips or hiding the legend that appears on the 
left side of the Mixer.

Switch between narrow and wide channel strips
Do either of the following:

mm Click the Narrow Channel Strips button to reduce the width of channel strips.

mm Click the Wide Channel Strips button to increase the width of channel strips.

Hide or show the Mixer legend
mm Choose View > Hide Legend from the Mixer menu bar.

Choose View > Show Legend to show it again.

Navigate within the Mixer
You can quickly move to the next or previous channel strip in the Mixer using the following key 
commands:

•• Select Next (Right) Channel Strip (or press the Right Arrow key)

•• Select Previous (Left) Channel Strip (or press the Left Arrow key)

When multiple channel strip types are visible in the Mixer, you can choose a command to jump 
to a particular channel strip type. This feature is useful when your Mixer view contains dozens, or 
hundreds, of channel strips.

Navigate to a specific channel strip type
mm Choose View > Scroll To from the Mixer menu bar, then choose a channel strip type from the 

pop-up menu.
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View channel strips linked to folder tracks
A folder track in the Tracks area is represented by a channel strip in the Mixer.

Note:  Make sure that View > Folder Tracks is chosen from the Mixer menu bar.

Folder track

Enter a folder
Do one of the following:

mm Double-click the folder track in the Mixer.

mm Double-click the folder region in the Tracks area.

mm Select the folder, then use the Go Into Folder or Region key command.

The Mixer now displays only those channel strips that are in the folder track.

Exit the folder
Do one of the following:

mm Click the Display Level button  at the left side of the Mixer or Tracks area.

mm Double-click the Tracks area background.

mm Use the Go Out of Folder or Region key command.

The Mixer now displays all channel strips, including the folder channel strip.
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Add track notes
You can view, add, edit, and delete track notes in the Mixer.

You can also access track notes in the Note Pad. In the Mixer, you can’t change the text format 
and you can’t view or edit any text after the first line break.

Access notes in the Mixer
Do one of the following:

mm Choose View > Channel Strip Components > Notes from the Mixer menu bar.

mm Control-click the Mixer, then choose Track Notes from the shortcut menu.

Add, edit, or delete track notes in the Mixer
mm Double-click the Notes area, then add or delete text.

The track notes in the Main window’s Note Pad are also updated accordingly.

View control surface bars
You can see which tracks are accessed by control surfaces connected to your system.

View control surface bars in the Mixer
Do one of the following:

mm Choose View > Channel Strip Components > Control Surface Bars from the Mixer menu bar.

mm Control-click the Mixer, then choose Control Surface Bars from the shortcut menu.

Link control surfaces to the Mixer
You can have control surface groups follow changes in the Mixer, including changes to the 
Mixer view.

Link control surfaces to the Mixer
mm Choose View > Link Control Surfaces from the Mixer menu bar.
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Use the I/O Labels window
You can use the I/O Labels window to define names for all channel strip Input, Output, and Send 
menu items, which can be used in place of defaults such as “Input 1” or “Output 8.”

Open the I/O Labels window
Do one of the following:

mm Choose Mix > I/O Labels.

mm Choose Options > I/O Labels from the Mixer menu bar.

Choose a device from the Device pop-up menu, if you have multiple audio interfaces. I/O labels 
can be individually defined for each hardware driver type, but are valid for all projects. These 
labels are stored in a separate file, located in the ~/Library/Application Support/Logic folder. The 
file is called “IOLabels xxx” (where xxx is the name of the hardware type).

Edit the labels for Input, Output, and Send slots
	 1	 Select the button in the User column.

	 2	 Double-click the “-” in the Long (name) column, enter a new name, then press Return.

	 3	 Repeat the process for the Short (name) column.

The short name is used in the Send slots.

Revert to default labels
Do one of the following:

mm Click the corresponding button in the Channel column.

mm Choose one of the following from the Reset pop-up menu:

•• Reset All Labels

•• Reset Input Labels

•• Reset Output Labels

•• Reset Bus Labels

Use the labels provided by the hardware driver
mm Click the corresponding button in the Provided by Driver column.
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Adjust channel strips when recording or playing
You can adjust channel strip controls when recording or playing your project, but you first need 
to prevent the track selection from changing.

Prevent the track selection from changing when recording
mm Make sure Options > Change Track in Record Mode is not chosen in the Mixer menu bar.

Prevent the track selection from changing when playing your project
mm Make sure Options > Change Track in Play Mode is not chosen in the Mixer menu bar.

Work with ReWire applications
Logic Pro acts as a host for ReWire applications such as Propellerhead Reason. When such 
applications are open alongside Logic Pro, synchronized audio information is routed out of them 
into aux channel strips in the Mixer, where it can be combined with other tracks, run through 
effects, and bounced to new audio files.

Important:  Start Logic Pro first, then start your ReWire application.

In addition to routing the outputs of ReWire applications into Logic Pro, you can also directly 
play, record, and play back the software instruments available in these programs. Propellerhead 
Reason, for example, is the software equivalent of a rack of synthesizers and samplers.

You can directly play each synthesizer in the Reason rack, and can record these parts as MIDI 
regions on Logic Pro tracks, much as you would with internal, or external MIDI, instruments in 
Logic Pro.

Access a ReWire instrument
	 1	 Select an external MIDI track in the Tracks area.

	 2	 Double-click the ReWire application in the Library (Reason, for example).

The ReWire application opens and a list of all available ReWire instruments appears in the Library.

	 3	 Select an instrument in the Library.

Manually set up an aux channel strip for ReWire use
	 1	 Click the Mixer button  in the control bar.

	 2	 Choose Options > Create New Auxiliary Channel Strip from the Mixer menu bar.

	 3	 Repeat step 2 to create as many aux channel strips as required.

	 4	 Choose the ReWire channel from the Input slot of the relevant aux channel strip.

You can also define the ReWire playback behavior.
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Automation overview
Automation refers to recording, editing, and playing back the movements of faders, knobs, 
and switches. Using automation, you can create changes over time to volume, pan, and other 
settings. You can add automation to all track types.

Each track in your project has automation curves for volume and pan, and you can add curves to 
automate plug-in settings. To create changes over time, you do the following:

•• Show the track automation curve you want to work on.

•• Choose an automation mode.

•• Add automation control points to the curve at the start and end points for the change you 
want, then adjust the control points.

You can also snap automation to positions in the grid, edit automation in the Automation Event 
List, and use MIDI Draw to automate MIDI region events.

Automate mix and effects settings 17
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Show track automation curves
Before you can add control points to a track’s automation curves, you need to show the track’s 
curves. Automation curves are displayed on top of audio and MIDI regions across the track, 
running the length of the project. Automation is represented by colored curves and points.

After you show the track’s curves, you can choose which parameter you want to work with—
Volume fader, Pan knob, or any other track parameter. You can work with multiple parameters on 
the same track, or you can work in separate subtracks, which appear below the main track.

Show automation curves for a track
	 1	 Do one of the following:

•• Choose Mix > Show Automation (or press A).

•• Click the Automation button  in the Tracks area menu bar.

An Automation button , an Automation Parameter pop-up menu, and an Automation 
Mode pop-up menu appear in each track header. You can choose the parameter you want 
to automate—Volume fader, Pan knob, or any other track parameter—from the Automation 
Parameter pop-up menu.

Track Automation button

Automation Parameter 
pop-up menu

Automation Mode 
pop-up menu

	 2	 Click the Track Automation button  in the track header.

Any existing automation is displayed on the track. You can now choose an automation mode 
from the Automation Mode pop-up menu.

Show or hide automation curves for individual tracks
mm Click the Track Automation button  in the track header.

When you hide automation curves, they are not deleted, just hidden.
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Choose the parameter you want to automate
Do one of the following:

mm Choose a parameter from the Automation Parameter pop-up menu in the track header.

Automation Parameter 
pop-up menu

mm Control-click the track lane, then choose an automation parameter from the shortcut menu 
that appears.

Volume, pan, solo, and mute are shown in the pop-up menu. A submenu is also shown for each 
plug-in on the track. These are numbered and named after the slot position and plug-in: 1 EXS24, 
for example.

Show multiple parameter curves on automation subtracks
	 1	 Click the disclosure triangle at the lower left of a track header.

	 2	 Choose the parameter that you want to automate from the Automation Parameter pop-up menu 
in the track header.

	 3	 To add additional subtracks, click the “+” that appears when you place the pointer over the 
track header.

All additional automation subtracks are revealed. Each additional subtrack is set to an 
automation parameter type that’s already recorded but not currently shown. The active 
automation parameter remains on the main track.



	 Chapter  17    Automate mix and effects settings	 535

Add, remove, and reorder automation subtracks
Do any of the following:

mm To add a subtrack: Place the pointer over the subtrack header, then click the “+” that appears.

mm To remove a subtrack: Place the pointer over the subtrack header, then click the “x” that appears.

The selected subtrack is removed without deleting its automation.

mm To reorder subtracks: Drag the subtrack up or down.

Tip:  You may find it easier to work with automation curves at a higher zoom level. To do so, drag 
the lower edge of the track header downward.
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Choose automation modes
Automation modes determine how automation tracks are treated. Automation is either off, being 
read, or being written. You can independently set the automation mode for each track.

•• Off: Hides any automation that exists on the track, without deleting it.
•• Read: Plays back all automation that exists on the track. If volume data exists, for example, the 

Volume fader will move during playback, following the prerecorded automation on the track. 
You can’t change the value of the chosen automation parameter by moving controls when in 
Read mode.

•• Touch: Plays back automation in the same way as Read mode. You can modify the value of the 
chosen automation parameter by moving controls in Touch mode. After the fader or knob is 
released, the parameter follows existing automation on the track.

•• Latch: Works like Touch mode, but after the fader or knob is released, the new parameter value 
replaces existing automation on the track.

•• Write: Erases existing automation on the track as the playhead passes over it. Records the new 
control movement or deletes the existing data if you do nothing.

Set the automation mode for a track
mm Show the track’s automation curves, then choose a mode from the Automation Mode pop-up 

menu in the track header or the track’s channel strip.

Set the same automation mode for selected tracks
Do one of the following:

mm Shift-click track headers to select them, then choose a mode from the Automation Mode pop-up 
menu in one of the track headers.

mm Shift-click channel strips in the Mixer to select them, then choose a mode from the Automation 
Mode pop-up menu in one of the selected channel strips.

Set the automation modes using key commands
You can set the automation mode using the following key commands:

mm Toggle Current Track Automation Off/Read

mm Set Current Track to Automation Read

mm Toggle Current Track Automation Touch/Read

mm Toggle Current Track Automation Latch/Read

mm Toggle Current Track Automation Write/Read

mm Set All Tracks to Automation Off

mm Set All Tracks to Automation Read

mm Set All Tracks to Automation Touch

mm Set All Tracks to Automation Latch

mm Set All Tracks to Automation Write
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Add automation to tracks

Add and adjust control points
To create changes over time to volume, pan, and effects settings, you add control points to a 
track’s automation curve at different places, and then adjust the control points so the value of 
the setting changes. You can adjust control points by moving them up or down to a new value, 
or by moving them left or right to a new point in the timeline. Numerical values are displayed 
alongside each control point.You can also add control points at selection area or region borders.

Add one or more control points to an automation curve
Do any of the following:

mm To add a control point to an empty automation curve: Click anywhere in the automation track.

This adds a control point at the project start position, using the current fader value.

mm To add a control point to an existing automation curve, do any of the following:

•• Click the automation curve.

•• Double-click an empty area of the automation track.

•• Click on or outside the automation curve with the Pencil tool.

All of these actions add a control point at the clicked position.

Adjust control points
Do any of the following:

mm Drag a control point up or down to change its value.

mm Drag a control point left or right to move it to a different point in the timeline. Use the ruler to 
make sure control points are aligned with a beat or measure.

Add control points at marquee borders
  You can do the following when Show Advanced Tools is selected in the Advanced 

preferences pane:

mm Drag across a region with the Marquee tool, then click the region selection with the Pencil.

Add control points at region borders
  You can do either of the following when Show Advanced Tools is selected in the Advanced 

preferences pane:

mm To add one control point at each region border: Select the region, then choose Mix > Create 
Automation > Create 1 Automation Point at Region Borders.

mm To add two control points at each region border: Select the region, then choose Mix > Create 
Automation > Create 2 Automation Points at Region Borders.
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Adjust a range of control points
You can adjust the automation data for an entire track in one go. If the track is part of a group, 
and if the relevant settings are selected in the group inspector, the track automation data across 
all tracks in the group will adjust accordingly. However, the relative parameter values of each 
track are maintained.

You use the trim behavior in the track header to adjust control points for:

•• An entire track

•• A partial selection (marquee) across a track

•• Multiple selected tracks

•• Multiple selected subtracks

Adjust a range of control points
mm After making your selection, place the pointer over the numerical display in the track header (the 

parameter value changes to Trim), then drag vertically to change the value (the offset or trim 
amount).

Tip:  If the Trim field is not visible, position the pointer over the line dividing the track headers 
from the left edge of the tracks, then (when you see the Resize pointer) drag the line left or right 
to resize the track headers.

When you release the mouse button, the numerical display reverts to showing the value of the 
active automation parameter at the playhead position.

Record live automation
When either Touch, Latch, or Write mode is active, you can record automation in record or 
playback mode. Whatever you touch or move is recorded, based on the chosen mode. When not 
recording or playing, the modes are ignored, and no data is written if a control is moved.

You have the following Write options for track automation:

•• Move any fader or control on the selected channel strip with the automation mode set to 
Touch, Latch, or Write. In real-world usage, you’ll rarely (if ever) use the destructive Write mode, 
which erases all automation. The standard Write modes are Touch and Latch.

•• Choose a parameter from the Automation Parameter pop-up menu in the track header, then 
adjust the numerical display in the track header, with one of the modes turned on.

•• Move the faders or knobs of a connected hardware controller, with one of the modes 
turned on.

•• Use the Pointer or Pencil tool to draw your automation curve.

You can specify the mode that the application switches to after a Write operation has been 
performed using the Automation Preferences pane.
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Select, copy, move, and delete automation

Select, copy, and move automation
After you create control points and curves, you can easily change things to meet your needs. You 
can copy automation within a track or between tracks and can move automation within a track. 
When moving regions, you can choose whether or not to move any existing automation with it.

  You can only use the Automation Curve tool to bend automation curves when Show 
Advanced Tools is selected in the Advanced preferences pane.

Select automation
mm Drag any selection of control points and curves.

Copy automation within a track
mm Select the points or curves you want to copy, then Option-drag the selection to a different 

location on the track.

Any existing points in the target location are deleted.

Copy automation between tracks
	 1	 Hold down Shift while dragging a selection within the automation area.

	 2	 Choose Edit > Copy (or use the corresponding key command).

	 3	 Select the track you want to copy the automation to.

	 4	 Choose Edit > Paste (or use the corresponding key command).

Move automation
Do one of the following:

mm Select the points or curves you want to move, then drag them horizontally or vertically.

mm Hold down Control while dragging control points or curves. This technique allows fine 
adjustment of the point or curve value.

Any existing points in the target location are deleted.

Move regions with or without automation
mm Choose one of the following Move Automation with Regions options in the Preferences > 

Automation pane:

•• Never: Does not move automation when you move regions.

•• Always: Always moves automation when you move regions. The automation area 
encompassed by the region boundaries is moved.

•• Ask: A dialog prompts you to move the automation—or leave it where it is—whenever you 
move a region.

mm Control-click the track lane, then choose one of the following options from the shortcut menu 
that appears:

•• Never move Automation with Regions

•• Always move Automation with Regions

•• Ask to move Automation with Regions
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Move a region selection with its automation
	 1	 Drag across the region with the Marquee tool.

	 2	 Choose Edit > Copy from the Tracks area menu bar.

	 3	 Select the track you want to copy the automation data to, then move the playhead to the 
insertion point.

	 4	 Choose Edit > Paste from the Tracks area menu bar.

The region selection, along with its automation, is copied to the target track at the 
playhead position.

Bend an automation curve
Do one of the following:

mm Drag an automation curve with the Automation Curve tool.

mm Hold down Control-Shift while dragging an automation curve with the Pointer tool.

Delete automation
You can delete individual control points, multiple control points, or use a number of commands 
to delete automation across tracks.

  The commands to delete automation are only available when Show Advanced Tools is 
selected in the Advanced preferences pane.

Delete a single control point
mm Double-click the control point.

mm Select the control point, then press Delete.

mm Drag across the control point with the Eraser tool.

Delete multiple control points
mm Select multiple control points, then press Delete.

Important:  Make sure that no regions are selected, or they will also be deleted.

Delete automation using commands
mm Choose one of the following options from Mix > Delete Automation:

•• Delete Visible Automation on Selected Track: Removes automation for the active 
automation parameter.

•• Delete All Automation on Selected Track: Removes all automation from the selected track.

•• Delete Orphaned Automation on Selected Track: Removes all orphaned automation from the 
selected track. Automation can become orphaned when copied between tracks.

•• Delete All Automation: Removes all automation from all tracks.
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Snap automation to grid positions
You can snap track automation to grid positions.

  When snapping is available, and Show Advanced Tools is selected in the Advanced 
preferences pane, you can also offset automation, by moving it slightly forward or backward in 
time. Offsetting automation compensates for any audio hardware latencies, excessive processor 
loads, or plug-in delays.

Snap control points to the chosen Snap grid value
mm Choose Snap Automation to Absolute Values from the Snap pop-up menu.

mm Control-click the track lane, then choose Snap Automation from the shortcut menu that appears.

Automation edits snap to the value chosen in the Snap pop-up menu.

Offset automation when Snap Automation is active
	 1	 Choose Automation Snap Offset from the Snap pop-up menu.

	 2	 Adjust the Snap Offset parameter in tick values (can be positive or negative).

All automation, on all tracks (or regions containing MIDI Draw automation), is offset by the 
chosen number of ticks.
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Edit automation in the Automation Event List
  When Show Advanced Tools is selected in the Advanced preferences pane, you can edit 

automation in a dedicated Automation Event List window.

Open the Automation Event List window
mm Use the Automation Event List key command.

Edit track automation
mm Edit individual events in position, length, value, and so on.

Write track automation with external controllers
Logic Pro provides support for a number of dedicated control surfaces that make writing and 
editing track automation fast, efficient, and easy. Depending on the facilities available, you can 
simultaneously write automation for several channels, or multiple plug-in parameters. Any 
MIDI controller—such as the modulation wheel, or a front panel slider or knob on your MIDI 
keyboard—can be used to write automation. You can use one such controller for all automation 
writing duties, or you can assign individual controllers (if available on your MIDI keyboard) to 
different parameters.

The Automation Quick Access feature makes track automation extremely fast and simple if you 
only have one hardware MIDI controller available—one fader on your MIDI keyboard, or just the 
modulation wheel, for example. You can use this single hardware controller to automate the 
currently active automation parameter of the selected track in the main window.

Set up Automation Quick Access
	 1	 Choose Logic Pro > Preferences, or press Command-Comma (,), then choose Automation.

In the Automation pane, Automation Quick Access is turned off by default.

	 2	 Click the On button in the Automation Quick Access section.

A dialog prompts you to assign a controller.

	 3	 Click the Assign button and slowly move the hardware controller that you want to use for 
Automation Quick Access. Make sure that it’s moved through its entire range.

	 4	 Confirm your selection by clicking the Done button below the Off/On buttons in the Automation 
Quick Access section.
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The Done button changes into a Learn Message button. Clicking the Learn Message button 
allows you to assign a new controller for Automation Quick Access. Clicking the Edit button 
opens the Controller Assignments window, where you can assign the controller manually. See 
the Logic Pro Control Surfaces Support manual for more information. Once set up, you will have 
hardware control over the active automation parameter on the current track.

Tip:  If you choose the modulation wheel for Automation Quick Access, you might want to switch 
between using it for Automation Quick Access and normal modulation wheel duties—as MIDI 
controller 1. This is quickly done using the Toggle Automation Quick Access key command (or 
pressing Control-Option-Command-A).

Use MIDI Draw
MIDI Draw works much like track automation, with a couple of key differences. MIDI Draw is 
restricted to MIDI regions. It uses MIDI controller values, rather than the internal meta events 
used by the track automation system, which are represented as curves between control points.

You can edit control points and curves in a similar way to track automation. You can record 
MIDI controller events in real time on MIDI tracks, or use MIDI Draw to create and edit controller 
events in the Tracks area, Piano Roll Editor, and Score Editor.

  MIDI Draw is only available in the Score Editor when Show Advanced Tools is selected in the 
Advanced preferences pane.

You can also use the Step Editor, which is built specifically for MIDI controller editing, providing 
more precision and flexibility than the available MIDI Draw options.

Turn MIDI Draw on
Do one of the following:

mm In the Tracks area: Choose View > MIDI Draw from the Tracks area menu bar, then choose an 
event type.

mm In the Piano Roll or Score Editor: Click the MIDI Draw button.
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A MIDI Draw area is displayed below the editing area. You can choose event types from the MIDI 
Draw pop-up menu to the left of the MIDI Draw area.

Turn MIDI Draw off
mm Choose View > MIDI Draw > Off from the Tracks area menu bar.

Set the MIDI channel
mm Choose View > MIDI Draw > Channel from the Tracks area menu bar, then select a 

channel number.

Define other MIDI controllers
	 1	 Choose View > MIDI Draw > Other from the Tracks area menu bar.

	 2	 Select the controller number and the MIDI channel in the MIDI Draw window.

Set the MIDI Draw parameters automatically
mm Choose View > MIDI Draw > Autodefine from the Tracks area menu bar.

Autodefine mode sets the MIDI Draw parameters automatically, making the first event in the 
region visible.
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Smart Controls overview
Smart Controls let you control the sound of the selected track using a set of onscreen controls. 
Smart Controls can control both channel strip and plug-in parameters, including software 
instruments (on software instrument tracks) and effects (on audio, software instrument, and 
Drummer tracks). Smart Controls provide a quicker alternative to opening plug-in windows and 
adjusting individual parameters.

Each Smart Control has a set of screen controls. Adjusting a single screen control can change one 
or more parameters for the track’s channel strip, instrument, and effect plug-ins. Screen controls 
are labeled to help you understand which aspect of the sound each one affects.

Smart Controls typically include EQ or tone controls, reverb and other effect controls, and 
controls specific to the type of track or instrument. For example, the Smart Control for a 
synthesizer might include screen controls for choosing the waveform and adjusting the 
resonance and filter cutoff, while one for a string instrument might include controls for changing 
the articulation.

To work with Smart Controls, you open the Smart Controls pane.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can change 
the layout for a Smart Control, map screen controls and edit mappings, rename screen controls, 
and assign external controllers to screen controls in the Smart Control inspector.

Open the Smart Controls pane in the main window

mm Select a track, then click the Smart Controls button .

Open the Smart Controls as a separate window
mm Choose Window > Open Smart Controls.

Use Smart Controls 18
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Choose a Smart Control layout
Each Smart Control features a layout, with a background graphic and a set of screen controls in a 
defined order. Each layout is designed for a particular type of instrument or track. If the selected 
track doesn’t contain plug-ins, an empty layout is displayed.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can choose 
a different layout for the current Smart Control to change the number or arrangement of screen 
controls. In the Layout menu, you can choose between layouts suited to the selected Smart 
Control, along with a Factory Layouts submenu containing additional layouts. You can also have 
Logic Pro automatically choose an appropriate layout.

For Track Stacks, you can choose a layout for the main track of a summing stack, but not for the 
main track of a folder stack. Subtracks for both folder stacks and summing stacks can have their 
own Smart Control layout. 

When a subtrack of a summing stack is selected, an additional Main Track Smart Controls item 
appears in the Layout menu. Choosing this item shows the layout for the main track of the 
summing stack, rather than a separate layout for the subtrack. Adjusting any screen controls 
switches focus to the main track of the summing stack.

Choose a different layout for the current Smart Control
	 1	 In the Smart Controls pane, click the Inspector button  in the Smart Controls menu bar.

The Smart Control inspector opens, showing additional parameters for the Smart Control.

	 2	 Click the name of the current layout at the top of the Smart Control inspector, then choose a 
new layout from the Layout pop-up menu.

To have Logic Pro choose an appropriate layout, choose Automatic Smart Controls.
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Map screen controls automatically
When you choose Automatic Smart Controls as the layout, all screen controls are mapped 
automatically. You can also automatically map screen controls for a Smart Control for which you 
have chosen a layout, in which case Logic Pro determines an appropriate mapping for the screen 
controls. 

Automatic mapping is useful when you have added plug-ins to an empty channel strip, for tracks 
with Apple Loops, and with projects created in previous versions of Logic Pro.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can 
automatically map all screen controls in the current Smart Control, or only unmapped screen 
controls. In order to map screen controls, the Smart Control (and the track) must have at least 
one plug-in inserted.

Apply automatic mapping to a Smart Control
	 1	 In the Smart Controls pane, click the Inspector button  in the Smart Controls menu bar.

	 2	 In the Parameter Mapping area, click-hold a mapping, then choose one of the following:

•• To map all screen controls: Choose Map all Controls.

•• To map only unmapped screen controls: Choose Map all unmapped Controls.
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Map screen controls to channel strip and plug-in parameters
  When Show Advanced Tools is selected in the Advanced preferences pane, you can map 

screen controls to channel strip and plug-in parameters for the selected track. Each screen 
control can be mapped to one or more channel strip or plug-in parameters for the selected track. 
Parameter mappings are saved with the patch.

You can map screen controls using either the Learn process, or the Parameter pop-up menu in 
the Smart Control inspector. When you map a screen control, it jumps to the mapped parameter 
value. Only one screen control can be selected at a time.

You can copy and paste mappings, which is useful for sharing mappings between different 
screen controls of the same patch. When two tracks have identical plug-ins, mappings can also 
be copied from the Smart Control on one track and pasted to the Smart Control on the other 
track (in which case they control the corresponding parameters for the track on which they are 
pasted). 

Map a screen control using the Learn button
	 1	 In the Smart Controls pane, click the the Inspector button  in the Smart Controls menu bar.

	 2	 Select a screen control.

	 3	 In the Smart Control inspector, click the Parameter Mapping disclosure triangle.

The Parameter Mapping area opens. When an unmapped screen control (or no screen control) is 
selected, the Name field shows Unmapped. When you select a mapped screen control, the Name 
field shows the name of the parameter.

	 4	 Click the Learn button.

	 5	 Click the channel strip or plug-in parameter to which you want to map the screen control.

	 6	 To map additional screen controls, select another screen control, then click a parameter.

	 7	 When you’re finished mapping screen controls, click the Learn button again to end the Learn 
process. 
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Map a screen control using the Parameter Mapping pop-up menu
	 1	 In the Smart Controls pane, click the the Inspector button  in the Smart Controls menu bar.

	 2	 Select a screen control.

	 3	 In the Smart Control inspector, click the Parameter Mapping disclosure triangle.

	 4	 In the Parameter Mapping area, click the parameter name (if the screen control is already 
mapped) or the word Unmapped, then choose a channel strip or plug-in parameter from the 
Parameter Mapping pop-up menu.

Add a mapping
	 1	 In the Smart Controls pane, click the the Inspector button  in the Smart Controls menu bar.

	 2	 Select a screen control.

	 3	 In the Smart Control inspector, click a mapping, then choose Add Mapping from the Parameter 
Mapping pop-up menu.

	 4	 Choose the parameter for the added mapping, either using the Learn process or the Parameter 
Mapping pop-up menu.

Open the plug-in window for a mapping
	 1	 In the Smart Controls pane, click the the Inspector button  in the Smart Controls menu bar.

	 2	 Select a screen control.

	 3	 In the Smart Control inspector, click the Parameter Mapping disclosure triangle.

	 4	 Do one of the following:

•• Click the plug-in icon  next to the name of the mapping.

•• Control-click the screen control, then choose Open Plug-in Window from the shortcut menu.

Copy a mapping
	 1	 In the Smart Controls pane, click the Inspector button  in the Smart Controls menu bar.

	 2	 Select the screen control.

	 3	 In the Smart Control inspector, click a mapping, then choose Copy Mapping from the Parameter 
Mapping pop-up menu.

	 4	 Click a different parameter name, then choose Paste Mapping.

The copied parameter replaces the selected one.
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Copy all mappings for a screen control
	 1	 In the Smart Controls pane, click the Inspector button  in the Smart Controls menu bar.

	 2	 Select the screen control.

	 3	 In the Smart Control inspector, click a mapping, then choose Copy All Mappings from the 
Parameter Mapping pop-up menu.

	 4	 Click any parameter name, then choose Paste Mappings.

The copied parameters replace the existing ones.

Reorder mappings for a screen control
If a screen control has multiple mappings, a handle, indicated by three dots, appears on the left 
edge of each mapping in the Smart Control inspector, so that you can reorder mappings in the 
list. The screen control values are determined by the topmost mapping.

	 1	 In the Smart Controls pane, click the Inspector button  in the Smart Controls menu bar.

	 2	 Select the screen control.

	 3	 In the Smart Control inspector, drag a mapping up or down by its handle.

Handle

Delete a mapping
	 1	 In the Smart Controls pane, click the Inspector button  in the Smart Controls menu bar.

	 2	 Select the screen control.

	 3	 In the Smart Control inspector, click a mapping, then choose Delete Mapping from the Parameter 
Mapping pop-up menu.

After you map a screen control, you can edit mapping parameters, and scale parameter values 
using parameter mapping graphs. You can also map screen controls automatically.
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Edit mapping parameters
  When Show Advanced Tools is selected in the Advanced preferences pane, you can set the 

maximum and minimum range values and invert the range for the selected parameter mapping 
in the Parameter Mapping area of the Smart Control inspector. Each mapping can have its own 
values, including multiple mappings for the same screen control.

You can also scale input values using the parameter mapping graphs.

Edit mapping parameters for the selected screen control
Do any of the following:

mm To set the maximum (high) value for the mapped parameter: Drag the Range Max value slider.

mm To set the minimum (low) value for the mapped parameter: Drag the Range Min value slider. 

mm To invert all values between the maximum and minimum value: Select the Invert Range checkbox.

Scale values using parameter mapping graphs
Each parameter mapping has a Parameter graph.   When Show Advanced Tools is selected in 
the Advanced preferences pane, you can edit the graph to remap (or scale) input values from the 
screen control to different output values. The graph includes a series of preset curves that you 
can apply. The graph for one mapped parameter can be copied and pasted to another mapped 
parameter. You can also invert the range of values, or reset the graph.

Open the Parameter graph
mm In the Parameter Mapping area of the Smart Control inspector, click the Scaling: Open button.

The Parameter graph window opens. The title of the graph window shows the parameter name.

The graph shows the range of input values on the horizontal (x) axis, moving from left to right, 
and the range of output values on the vertical (y) axis, moving from bottom to top.

In the graph window, you have several ways of working: you can edit the graph curve directly, 
set the graph to use one of the predefined curves, or change the minimum and maximum range 
values for the graph.
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Edit the graph
	 1	 Do any of the following:

•• Click a curve button (in the upper-left part of the window) to use one of the preset curves.

•• Click the curve at the location where you want to add a control point, then drag the control 
point to the desired value. Drag horizontally to change the input value, or vertically to change 
the output value.

As you drag, the current values of the control point appear next to the pointer.

•• Double-click the curve at the location where you want to add a control point, then edit the 
values for the control point.

•• Option-click any part of the curve (except a control point), then drag the dotted part of the 
curve to make the curve nonlinear.

•• Click Invert to invert the values of the curve.

•• Click Reset to reset the graph to its original (default) values.

	 2	 Continue adding and adjusting points until you’re happy with the result.

	 3	 When you're finished, click the close button at the upper-left corner of the graph window.

Copy the graph
mm Click the Copy button on the right side of the graph window.

Paste a copied graph
mm Click the Paste button on the right side of the graph window.

Save a custom graph preset
	 1	 Click the Presets button at the bottom of the graph window.

	 2	 Click Add to Presets.

	 3	 Enter a name for the preset, then click Save.

The current graph curve is saved as a preset.

Open the plug-in window for a screen control
For screen controls that are mapped to a plug-in, you can open the plug-in window used by the 
screen control from within the Smart Controls pane.

Open the plug-in window for a mapped screen control
Do one of the following:

mm In the Smart Controls pane, Control-click the screen control, then choose Open Plug-in Window 
from the shortcut menu.

If the screen control is mapped to multiple plug-ins, the plug-in windows for all of the mapped 
plug-ins open.

mm Open the Smart Control inspector, then click the Plug-in Window button  in the Parameter 
Mapping row for a mapping.
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Rename a screen control
When you map a screen control, it takes the name of the parameter to which it is mapped (in the 
case of multiple mappings, the first mapped parameter). The screen control name appears in the 
Smart Control inspector above the Parameter Mapping area. 

  When Show Advanced Tools is selected in the Advanced preferences pane, you can change 
the name in the Smart Control inspector.

Change the name of a screen control
	 1	 In the Smart Controls pane, click the Inspector button  in the Smart Controls menu bar.

	 2	 Select the screen control.

	 3	 In the Smart Control inspector, select the name, then enter a new name for the screen control.

Assign hardware controls to screen controls
To use Smart Controls with a MIDI controller, you assign hardware controls on the controller 
(faders, knobs, buttons, drum pads, pedals, and other controls) to screen controls. After you 
assign a hardware control to a screen control, the screen control receives the MIDI messages 
from the hardware control.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can assign 
hardware controls to screen controls using the Learn process, which is similar to learning 
controller assignments for a control surface. Only one screen control can be selected at a time, 
and each screen control can have only one assignment. When you assign a hardware control, it 
keeps the assignment for all Logic Pro projects, until you reassign it.

Assign an external hardware control using the Learn button
	 1	 In the Smart Controls pane, click the Inspector button  in the Smart Controls menu bar.

	 2	 Select a screen control.

	 3	 Click the External Assignment disclosure triangle.

The External Assignment area opens. If the selected screen control currently has no assignment, 
the Name field shows Unassigned. If the selected screen control has an assignment, the Name 
field shows the name of the assignment. 

	 4	 Click the Learn button.

	 5	 On your MIDI device, move the control you want to assign.

	 6	 While the Learn process is active, you can learn additional controller assignments by selecting 
another screen control and moving the hardware control you want to assign to it.

	 7	 When you're finished assigning controls, click the Learn button again to end the Learn process.
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Compare an edited Smart Control with its saved settings
While you’re working with a Smart Control, you may want to compare your edits to the saved 
settings to hear how your changes affect the sound. The Compare function only compares 
changes to parameters to which screen controls are mapped; other parameter changes are not 
included in the comparison.

Compare your edits to the saved Smart Control settings
mm Click the Compare button in the Smart Controls menu bar.

To return to the edited version, click the Compare button again.

Use the Arpeggiator with a Smart Control
You can use the Arpeggiator MIDI plug-in with the Smart Controls on a software instrument 
track. When you turn on the Arpeggiator, chords you play on the keyboard are arpeggiated, or 
played one note at a time rather than simultaneously.

After you turn on the Arpeggiator, the Arpeggiator pop-up menu appears in the menu bar. You 
can choose an Arpeggiator preset and adjust Arpeggiator settings, including note order, note 
range, and octave range from the Arpeggiator pop-up menu. You can also open the Arpeggiator 
MIDI plug-in window to make further changes.

Turn on the Arpeggiator
mm Click the Arpeggiator button  in the Smart Controls menu bar. 

The Arpeggiator pop-up menu appears in the menu bar.

Choose an Arpeggiator preset
mm Choose a preset from the Arpeggiator pop-up menu in the Smart Controls menu bar.

Adjust Arpeggiator settings
In the Arpeggiator pop-up menu, do any of the following:

mm Choose Note Order, then choose the direction of arpeggiated notes from the submenu.

mm Choose Note Range, then choose a note value for arpeggiated notes, based on the tempo of 
the song.

mm Choose Octave Range, then choose how many octaves the arpeggio covers.

Open the Arpeggiator MIDI plug-in
mm Choose Open Arpeggiator from the Arpeggiator pop-up menu in the Smart Controls menu bar.

For full details about using the Arpeggiator MIDI plug-in, see the MIDI plug-ins section of the 
Logic Pro Instruments manual.
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Automate screen control movements
You can automate the movements of screen controls, just as you can automate plug-in 
parameters. When you automate a screen control, the actual screen control movements, rather 
than underlying parameter values, are written.

 Automation for multi-mapped screen controls is retained even when the underlying plug-in is 
changed or removed. However, if all of the plug-ins to which the screen control is mapped are 
removed, the automation is deleted.

Automate movements of a screen control
	 1	 Choose the automation mode for the track as described in Choose automation modes.

	 2	 Record screen control movements as described in Record live automation.
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Global changes overview
In addition to working with individual tracks, regions, and channel strips, you can manipulate 
different aspects of an overall project.

•• You can control the overall project volume using the Master Volume slider, the master track, or 
the master channel strip.

•• You can tag different parts of a project, then select and edit those parts, using markers.

•• You can organize a project into sections, and quickly rearrange those sections, using 
arrangement markers.

•• You can add time signature changes that affect the ruler and the Score Editor display.

•• You can add key signature changes that affect the Score Editor display.

•• You can control the project tempo by adding tempo changes, which affect project playback.

•• You can transpose parts of a project to different keys. Transposition affects playback of MIDI 
regions and Apple Loops in the project, and can also apply to audio regions.

•• You map notes not in a strict tempo with beats in the ruler using beat mapping.

Logic Pro features several ways to control aspects of the overall project. A set of global tracks 
(including the Marker track, Arrangement track, Signature track, Tempo track, Transposition track, 
and Beat Mapping track) is available in the Tracks area and various editors. For video projects, you 
can use the Movie track to view frames of the video while you work with the project.

You can also add effects to output or aux tracks, and automate effects and other parameters on 
output or aux tracks, which can affect the overall project.

For information about using the master track, see Work with the master track. For information 
about the master channel strip, see Channel strip types. For information about automating 
project parameters, see Automation overview.

Make global changes to a project 19
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Use the global tracks

Global tracks overview
Logic Pro includes a set of global tracks that you can use to control different aspects of the 
overall project. You can show global tracks in the Tracks area and in the time-based editors 
(including the Audio Track Editor, Piano Roll Editor, and Step Editor). When you show the global 
tracks, they appear below the ruler for that particular area.

By default, the following global tracks are available:

•• Arrangement track: Contains arrangement markers, which you can move, copy, and edit to 
quickly reorganize a project. For more information, see Add arrangement markers and Edit 
arrangement markers.

•• Movie track: Displays frames of a QuickTime movie as thumbnails that are synchronized with 
the ruler, for use in film scoring. Cuts in the movie can be detected automatically and marked. 
For more information, see About the Movie track.

  When Show Advanced Tools is selected in the Advanced preferences pane, the following 
additional global tracks are available:

•• Marker track: Contains markers, which are used to label bar positions and parts of the project. 
Their length, text, and color can be edited freely. For more information, see Markers overview.

•• Signature track: Contains the basic time and key signatures of the project, along with any 
signature changes. For more information, see Time and key signatures overview.

•• Transposition track: Contains transposition events used to transpose parts of a project up or 
down in pitch. Transposition affects MIDI regions and Apple Loops, and can also affect audio 
regions. For more information, see Transposition overview.

•• Tempo track: Contains the project tempo, and all tempo changes in the project. For more 
information, see Tempo track overview.

•• Beat Mapping track: Use to adjust the tempo to follow recordings that do not follow a strict 
tempo, without changing the rhythmic feel of the recordings. For more information, see Beat 
mapping overview.

Show and hide global tracks
Global tracks can be displayed in the Tracks area and in the time-based editors (including the 
Audio Track Editor, Piano Roll Editor, and Step Editor). In each window, global tracks appear below 
the ruler. You can select which global tracks to display, and resize and reorder global tracks. By 
default, the Arrangement, Marker, Signature, and Tempo tracks are visible when you show the 
global tracks.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can configure 
global tracks:

Show or hide the global tracks
Do one of the following:

mm Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global Tracks key 
command (G).

mm Click the Global Tracks button . 

In the Tracks area, the Global Tracks button appears above the track headers. In the editors, it 
appears on the left side of the editor.
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Show or hide individual global tracks
Do one of the following:

mm Choose Track > Global Tracks, then choose specific tracks from the submenu.

mm Control-click anywhere in the global tracks header area, then choose specific tracks from the 
shortcut menu.

Tip:  You can show or hide the Marker track by clicking the Marker track button  above the 
track headers.

Choose which global tracks are displayed
Do one of the following:

mm Choose Track > Global Tracks > Configure Global Tracks, then select the 
corresponding checkboxes.

mm Control-click anywhere on a global track, choose Configure Global Tracks from the shortcut 
menu, then select the corresponding checkboxes.

The tracks you select in the Global Tracks Configuration dialog only affect the active window.

You can also assign and use any of the following Show/Hide key commands for each individual 
ruler track: Marker, Transposition, Signature, Tempo, Beat Mapping, and Movie. The key commands 
work directly, without having to open the Global Tracks Configuration dialog.

Tip:  Click the Enable All or Disable All buttons to show or hide all global tracks, or use their 
corresponding key commands—Show All Global Tracks and Hide All Global Tracks.
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Resize and reorder global tracks
You can resize the entire global tracks area, and resize global tracks individually. You can also 
change the order of global tracks.

Resize the overall global tracks area
mm Position the pointer over the line separating the global tracks from the Tracks area (or editor) 

workspace, then drag up or down.

Resize individual global tracks
mm Position the pointer over the lower dividing line for the global track, then drag up or down.

Change the order of global tracks
mm Grab the header of the global track, then drag up or down. 

The display order of global tracks is saved independently for each window. 

If the Protect buttons are visible (View > Configure Track Header > Protect Buttons), you can 
prevent unintentional changes to individual global tracks by clicking the corresponding Protect 
button. 
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Work with markers

Markers overview
You can use markers to tag different parts of a project, and quickly select the parts for playback, 
arranging, and editing. Markers can help you organize your project, and also act as storage areas 
for locator positions. 

There are several ways to create and edit markers in Logic Pro. You can view and edit markers in 
the following work areas:

•• Marker track: Displays markers as rectangular sections. You can select, copy, move, or resize 
markers in the Marker track.

•• Marker List: Displays marker names, bar position, and length information in a scrollable, 
editable list. The Marker List is available when Show Advanced Tools is selected in the 
Advanced preferences pane.

•• Marker Text area and Marker Text window: Display marker text. You can type and edit comments 
or other text that is saved with the marker.
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Show the Marker track
Do one of the following:

mm Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global Tracks key 
command (G).

mm Click the Global Tracks button .

mm Click the Marker Track button .

If the Marker track is not visible, Control-click anywhere in the global tracks header area, then 
choose Marker in the dialog that appears. For more information, see Show and hide global 
tracks on page 557.

Open the Marker List in the main window
mm Click the List Editors button  in the control bar, then click the Marker button.

Open the Marker List as a separate window 
Do one of the following:

mm Choose Navigate > Open Marker List.

mm Drag the Marker List out of the main window.

Open the Marker Text window
Do one of the following:

mm Choose Navigate > Open Marker Text.

mm Option-double-click any marker in the Marker track with the Pointer tool. The clicked marker is 
selected in the list.

The Marker Text window is also available at the bottom of the Marker List, where it’s called the 
Marker Text area.

Tip:  Many marker-related commands can be accessed by Control-clicking in the Marker track or 
Marker List, when the Right Mouse Button: Opens Shortcut Menu pop-up menu option is chosen 
in the Logic Pro > Preferences > General > Editing pane.
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Create markers
You can create a marker at any position in your project. When you create a marker, it can be 
rounded to the nearest quarter note, to the nearest bar, or not rounded.

You can use the Create Marker key commands to add markers during playback.

Create a marker rounded to the nearest quarter note
In the Marker track, do one of the following:

mm Place the playhead at the position where you want to create a marker, then click the Create 
Marker button .

mm Select the Pencil tool, then click where you want to create a marker.

Create a marker rounded to the nearest bar
Do one of the following:

mm In the Marker List: Choose Options > Create.

mm In any workspace: Use the Create Marker key command.

A marker is created at the playhead postion (if the playhead is aligned with a bar) or at the next 
bar position (if the playhead is between two bars). If a marker already exists at a bar position (or 
up to a quarter note before or after it), no new marker is created.

The length of the marker automatically extends to the start point of the next marker, or to the 
end of the project or folder, if no ensuing markers exist.

Create a marker without rounding
Do one of the following:

mm In the Marker List: Choose Options > Create Without Rounding.

mm In any workspace: Use the Create Marker without rounding key command. 

Create a marker at a rounded playhead position
mm In the Marker List, click the Create Marker button .

Create a marker and set its position
mm In the Marker List, click in the Marker List area with the Pencil tool, then enter a position in the 

Position field.
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Create markers at the positions of all selected regions
Do one of the following:

mm In the Marker track: Click-hold the word Marker, then choose Create Markers From Regions from 
the shortcut menu.

mm In any working area: Use the Create Marker by Regions key command.

Markers created in these ways are automatically assigned the names, bar position, length, and 
color of the regions they are derived from.

Create a marker corresponding to the cycle area 
mm Drag the cycle area to the Marker track.
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Edit markers
You can copy and move markers, adjust their lengths, and color them. You can also change the 
appearance of marker text in the Marker Text window (or area).

Copy a marker
Do one of the following:

mm In the Marker track: Option-drag the marker.

You can also copy a marker, move the playhead to the position where you want to paste the 
copy, and then paste it.

mm In the Marker List: Use the Copy (Command-C) and Paste (Command-V) commands.

Move a marker to a new position
Do one of the following:

mm In the Marker track: Drag the marker left or right to a new position. 

mm In the Marker List: Use the pointer as a slider in the Position field, or double-click a position value 
and enter a new value.

Note:  The increments by which markers can be moved in the Marker track depend on the 
horizontal zoom level of the Tracks area and the Snap pop-up menu setting. Watch the help tag 
for precise feedback on movements. If you need to adjust markers in finer increments, use the 
Marker List.
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Protect the position of selected markers
There are times when you may want to protect markers from being moved. Logic Pro has a 
feature that preserves the absolute time position of events.

mm Choose Options > Lock SMPTE Position in the Marker List (or use the corresponding key 
command).

This command locks (fixes) the time position of markers, and a lock symbol is displayed at the 
beginning of the marker name.

These markers always retain their absolute time position: if the project tempo is changed, the bar 
positions will change to keep the markers at the same time positions.

Tip:  You can also lock and unlock the time positions of markers from the Region menu in the 
Tracks area, and the Functions menu in the Piano Roll Editor and Step Editor, if you turn on the 
display of global tracks.

Unprotect the position of selected markers
mm Choose Options > Unlock SMPTE Position in the Marker List (or use the corresponding key 

command).

Note:  You cannot unlock the time position of scene markers. See Use movie scene markers on 
page 834.
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Change the length of a marker
Do one of the following:

mm In the Marker track: Place the pointer over the left or right edge of the marker. When the pointer 
changes to a Resize pointer, drag the marker edge to the new position. 

mm In the Marker List: Use the pointer as a slider in the Position field, or double-click a position value 
and enter a new value. 

Markers cannot overlap. The edge of one marker cannot be dragged over another marker.

Adjust a marker to fit the cycle area
mm Drag the cycle area onto a marker in the Marker track. 

Dragging the cycle area in the ruler is limited to either horizontal or vertical movements. This 
ensures that you do not accidentally:

•• Move the cycle when creating markers (by dragging the cycle into the lower third of the ruler 
or into the Marker track)

•• Create markers when moving the cycle 

Tip:  When you hold down Shift after click-holding the cycle, the cycle can be moved horizontally, 
and then dragged to a marker in one go. When you hold down Shift before clicking the cycle, the 
nearest cycle border is set to the clicked position.

Color a marker
	 1	 Choose View > Show Colors to open the Color palette.

	 2	 Select the marker in the Marker track, then click a color in the Color palette. 

When you select a dark color, the marker text is automatically shown in an inverse color.
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Change the appearance of marker text
	 1	 Double-click the marker text you want to change. 

	 2	 Click the Font button in either the Marker Text window or the Marker Text area.

	 3	 Choose settings in the Font window.

The text in the Marker Text window changes to match the settings. The text in the Marker track is 
not affected.
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Rename markers
Newly created markers (except markers derived from regions) are named “Marker <number>,” 
where “<number>” reflects the order in which the marker appears along the ruler (resulting in 
“Marker 1,” “Marker 2,” and so on). This numbering depends on the order of all markers in the 
project, including markers that have been renamed.

Markers can be renamed in the Marker track, in the Marker Text area of the Marker List, or in 
the Marker Text window. The length of the name displayed in the Marker track and Marker List 
depends on available screen space, or the position of the marker that follows. 

Create and name a marker
mm Hold Control-Option-Command while clicking the desired position in the Marker track, enter the 

marker name in the field that appears, then press Return. 

If the Marker track isn’t visible, you can create and name a marker by Control-Shift-Command-
double-clicking the ruler.

Rename a marker in the Marker track
	 1	 Do one of the following:

•• Double-click the marker. 

•• Click the marker with the Text tool. 

•• Choose Options > Marker > Rename Marker.

	 2	 Enter the new name.
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Edit a marker name in the Marker List
	 1	 Do one of the following:

•• Select the marker name and click the Marker Text Edit button.

•• Select the marker name and double-click in the Marker Text area.

•• Double-click the marker in the Marker Name column.

	 2	 Enter the new marker name in the Marker Text area.

Edit a marker name in the Marker Text window
	 1	 Select the marker in the Marker List.

	 2	 Do one of the following:

•• Click the Marker Text Edit button.

•• Double-click in the Marker Text area.

	 3	 Enter the new marker name in the Marker Text area.
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The first portion of text in the window is used as the marker name. 

All text below the first paragraph is also displayed in the Marker track, if space allows. (You can 
resize the Marker track to view all text.) This space can be used for musical or technical notes, for 
example. In this scenario, the marker color appears only in the title line, with the remaining text 
displayed white on gray.

Note:  If you use the Return key to create paragraphs in the Marker Text area, the first paragraph 
of the text is displayed in a separate title line (of the marker) in the Marker track.
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Navigate using markers
You can navigate through your project using markers. This is useful when you want to quickly 
jump to, and edit, regions or events at a specific position in your project, for example.

Move the playhead to a marker
Do one of the following:

mm Hold down Option and click the marker in the Marker track.

mm Use the Go to Marker Number 1 to 20 key commands (20 different commands). 

The marker numbers in these commands refer to the (serial) order of all markers in the project. 
By default, when you create a marker, the name shows the marker number.

mm Use the Go to Marker key command to open a window where you can enter any marker number. 

The playhead moves to the beginning of the chosen marker.

Move to the next or previous marker
mm Use the Go to Previous Marker and Go to Next Marker key commands.

The locators are set to the beginning and end points of the selected marker. 

Create a cycle from a marker
Do one of the following:

mm Drag the marker into the upper part of the ruler.

This action sets the cycle area to the position and length of the marker.

mm Select the marker, then use one of the following key commands:

•• Set Locators by Marker and Enable Cycle

•• Set Locators by Previous Marker and Enable Cycle

•• Set Locators by Next Marker and Enable Cycle
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Use marker sets
  When Show Advanced Tools is selected in the Advanced preferences pane, you can create 

marker sets, and choose between different marker sets in a project. Only markers that are part of 
the current set appear in the Marker track and Marker List. When you create new markers, they 
become part of the current marker set. 

Creating different marker sets lets you use markers for different purposes (such as identifying 
sections, adding performance notes, and preserving production information) in the same project.

Create a marker set
mm In the Marker List, choose New Set from the Marker Set pop-up menu.

When you create a new marker set, previously added markers are no longer visible in the Marker 
track or Marker List. When you create new markers, they become part of the current marker set.

Rename a marker set
	 1	 Select the marker set, then choose Rename Set from the Marker Set pop-up menu.

	 2	 Enter a new name for the marker set, then click OK.

Choose a marker set
mm In the Marker List, choose a set from the Marker Set pop-up menu.

When you choose a marker set, only markers that are part of the set appear in the Marker track 
and Marker List.

Delete a marker set
mm Select the marker set, then choose Delete Set from the Marker Set pop-up menu.

Customize how markers appear in the Marker List
There are two display options for marker position and length in the Marker List. You can switch 
between bar positions and time positions, and between actual (relative) length and (absolute) 
display of the marker’s end position (shown as a bar position).

Switch the marker display between bar positions and time positions
mm Choose View > Show Event Position and Length as Time.

Switch the marker length display between relative length and the marker’s absolute end bar 
position

mm Choose View > Length as Absolute Position.
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Use marker information from imported audio files 
When you record or bounce an audio file, the current Marker List is added to the file. In some 
situations, you may want to import marker information from an audio file that was recorded in a 
different project.

Import marker information from an audio file
mm Choose Navigate > Other > Import Marker from Audio File.

You can also export the current Marker List within the borders of any selected audio region to an 
audio file. However, you should first remove any marker information that exists in the audio file.

Remove marker information from an audio file
mm Choose Navigate > Other > Remove Marker from Audio File.

You can then export the current marker information to the audio file.

Export marker information to an audio file
mm Choose Navigate > Other > Export Marker to Audio File.

Delete markers
You can delete markers at any time. After you delete a marker, it no longer appears in the ruler, 
Marker track, Marker List, or Marker Text window. 

Delete markers
In the Marker track or Marker List, do one of the following:

mm Select the markers, then choose Edit > Delete (or press Delete).

mm Control-click the marker, then choose Delete Marker.

mm Click the markers with the Eraser tool.
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Build a project with arrangement markers

Add arrangement markers
You can add arrangement markers to a project to create different sections, such as an intro, 
verse, and chorus, and then move the sections in the Tracks area to quickly rearrange the 
project. Arrangement markers can be particularly useful when you have added some material 
(recordings, loops, or media files) to the project and want to try out different arrangements.

By default, arrangement markers are eight bars long. The first arrangement marker begins at 
the start of the project. Each additional arrangement marker you add starts at the end of the 
previous one, with no space between. Arrangement markers are most useful if you add them to 
every section of the project, so that you can rearrange the entire project.

You add and edit arrangement markers in the arrangement track, which appears at the top of 
the Tracks area. When you add an arrangement marker, it is eight bars long. You can resize it 
to cover the section of the project you want it to include, and rename it to reflect its place in 
the project.

Show the arrangement track
Do one of the following:

mm Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global Tracks key 
command (G).

mm Click the Global Tracks button .

Add an arrangement marker
mm Click the Add Marker button (+) in the arrangement track.

Arrangement track

Arrangement marker

The arrangement marker appears at the start of the project, or at the end of the last existing 
arrangement marker.

Resize an arrangement marker
mm Drag the right edge of the arrangement marker left or right.

Rename an arrangement marker
Do one of the following:

mm Click the the name of the selected arrangement marker, then choose a name from the 
shortcut menu.

mm Double-click the marker (except on the name), then enter a new name.
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Edit arrangement markers
After you add arrangement markers to the arrangement track, you can use them to rearrange 
your project. You can select arrangement markers, move and copy them, replace them, and 
delete them from the arrangement track.

When you move or copy an arrangement marker, all of the regions in that section of the project 
are moved or copied, including the markers on every track in the section, and the control points 
on every automation curve in the section. If any tracks in the project are locked, you should 
unlock them before editing the arrangement markers in the project.

Select an arrangement marker
mm In the arrangement track, click the arrangement marker.

To select multiple arrangement markers, Shift-click them.

You can’t select noncontiguous arrangement markers.

Move an arrangement marker
mm Drag the arrangement marker to a new position in the arrangement track.

When you move an arrangement marker between two existing arrangement markers, the marker 
to the right moves right to make room for the new marker. When you drag one arrangement 
marker directly over another one in the arrangement track, the two markers switch places (all 
their content is swapped).

Copy an arrangement marker
mm Option-drag the arrangement marker to the position where you want to place the copy.

When you place the copy between two existing arrangement markers, the marker to the right 
moves right to make room for the copied marker.

Replace an arrangement marker
mm Command-drag an arrangement marker directly over another one.

Delete an arrangement marker together with its regions
mm Select the arrangement marker, then press Delete to delete the regions in the Tracks area below 

the arrangement marker so it is empty. Press Delete again to delete the arrangement marker.

Important:  In case you accidentally delete regions that you want to keep, use Undo to 
restore them.

When you move or delete an arrangement marker, the sections to the right move left to fill the 
deleted section, closing up the empty space.
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Work with time and key signatures

Time and key signatures overview
Time and key signatures are global events that affect all tracks in a project. When you create a 
new project, you can set the time and key signature in the Project Chooser. You can view time 
and key signatures in the Signature track, the Signature List, and the Score Editor, and add and 
edit signature changes in a variety of ways.

The initial time signature and key signature are project properties. For information on setting the 
initial time and key signature, see Project properties overview.

  The Signature List is available when Show Advanced Tools is selected in the Advanced 
preferences pane.

Time signatures
Time signatures determine the number of beats in each bar (as shown in the ruler), and so define 
the editing grid in the Tracks area and the time-based editors (including the Audio Track Editor, 
Piano Roll Editor, and Step Editor). Time signature changes do not affect the playback of audio or 
MIDI regions.

In addition to the ruler, time signatures affect the score display. All functions that rely on the 
chosen time signature and bar positions (such as MIDI metronome click or Transform window 
functions) are affected if bar positions are used to restrict a function to a certain part of 
the project.

Key signatures
When you create a project, the key signature defaults to C major, unless you choose a different 
key signature. The initial key signature affects the playback of Apple Loops in the project. Key 
signature changes affect the display of MIDI notes in the Score Editor, but do not have an effect 
on MIDI playback.

You can add any number of key signature changes to a project. When you add a key signature 
change, it changes the key from the insertion point forward, until the next key signature change 
is reached. 

You can store up to nine signature sets, which are reflected in the Signature track, Signature List, 
and Signature window. 

Show the Signature track
Do one of the following:

mm Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global Tracks key 
command (G).

mm Click the Global Tracks button .

By default, the global Arrangement, Marker, Signature, and Tempo tracks are visible when you 
show the global tracks in the Tracks area (or an editor). If the Signature track is not visible, 
Control-click anywhere in the global tracks header area, then select Signature in the dialog that 
appears. For more information, see Show and hide global tracks on page 557.

Note:  The Signature track must be visible—and must not be protected—in order to select and 
copy signatures.
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Open the Signature List
Do one of the following:

mm Click the List Editors button , then click Signature.

mm Shift-double-click in the Signature track.

The Signature List displays time and key signatures in a numerical list, and also displays global 
score symbols such as repeat signs, double bar lines, and so on.

Create time signature changes
When you create a new project, by default it has one time signature that lasts for the entire 
project. 

  When Show Advanced Tools is selected in the Advanced preferences pane, you can add time 
signature changes to a project in the Signature List, Signature track, or Score Editor. 

Create a time signature change
Do one of the following:

mm Place the playhead at the target time position, then drag the numerals in the Signature section 
of the LCD to set the new time signature.

mm Click the Add Signature button  in the Signature List, then edit the values in the Time 
Signature dialog.

mm In the Score Editor, drag the time signature symbol from the Part box to the target time position.

mm Click the target time position in the Signature track with the Pencil tool, then edit the values in 
the Time Signature dialog. 

•• You can enter beat groups for compound time signatures in the Beat Grouping field. The 
total number of beats in the bar is calculated by the sum in this field. For example, entering 
the numbers 223, becomes “2+2+3.” The sum is displayed as the numerator unless the Print 
Compound Signature checkbox is selected. Beat Grouping affects the way in which notes are 
beamed together (in both cases).

•• You can also change the automatic beaming in normal time signatures. In 4/4-time “1+1+1+1” 
produces four beamed groups (one for every beat), instead of the two groups displayed as 
a default.

•• Select the Hide Signature checkbox to hide a time signature change in the score printout. 
The signature is still displayed onscreen, but is crossed out, and won’t be included in the 
calculation of spacing between notes and symbols. As a result, signatures may overlap notes 
on the screen, but not in the printout. This can be used for notating cadenza-like passages, 
which contain more notes than would normally fit the time signature.
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Create key signature changes
When you create a new project, by default it has one key signature that lasts for the 
entire project.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can add key 
signature changes to a project in the Signature List, Signature track, or Score Editor. 

Create a key signature change
Do one of the following:

mm Click the word Time in the Signature List and choose Key from the pop-up menu, then click the 
Add Signature button . 

mm Click a position in the Signature track’s key signature area with the Pencil tool, then choose a key 
in the Key Signature dialog. 

You may need to expand the Signature track until you see separate areas for time and key 
signature changes.

In the Key Signature dialog, you can enable the use of double flats and sharps by deselecting the 
“Disable bb, x” checkbox.

mm In the Score Editor, double-click a staff between the clef and time signature, then choose a key 
in the Key Signature dialog. You can also drag the key signature from the Part box to the target 
time position. 

Edit time and key signatures
  When Show Advanced Tools is selected in the Advanced preferences pane, you can select 

time and key signatures in the Signature track, Signature List, or Score Editor by clicking them, or 
Shift-clicking to select multiple signatures.

In the Signature track, you can also select multiple signatures in conjunction with regions. 
This is useful when you want to copy or move complete parts of a song (along with signature 
changes). You can select parts of the project to copy or move using the Edit > Select All Inside 
Locators command.

Note:  When a marquee selection is active, using this command sets the marquee selection to 
match the locators.

You can copy time signatures and key signatures in the Signature track or Signature List. You can 
also copy all time and key signatures from one project to another. Subsequent signatures are 
inserted at bar positions that correspond to their original distance from the first copied signature.

Edit the signature value
mm In the Signature track (or the Score Editor), double-click a time or key signature, then edit the 

signature in the (Time or Key) Signature dialog.

Move a signature
mm In the Signature track, select a time or key signature and drag it to a new position.
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Split a signature
mm In the Signature track, use the Scissors tool to cut bars. For example, to divide one 5/4 measure 

into a 3/4 and a 2/4 measure, cut the measure at the fourth beat.

If you make a cut in the middle of a bar—in a section where the time signature doesn’t 
change—two corresponding shorter measures are inserted, with the original time signature 
resuming after the cut.

Merge signatures
mm In the Signature track, Shift-click the signatures with the Glue tool.

Copy signatures in a project using drag and drop
mm In the Signature track, Option-drag the signature to the target time position. 

Copy signatures in a project using the Clipboard
	 1	 Select the time and key signatures in the Signature track or Signature List.

	 2	 Choose Edit > Copy (or press Command-C).

	 3	 Do one of the following:

•• In the Signature track: Move the playhead to the insert position, then choose Edit > Paste (or 
press Command-V).

•• In the Signature List: Choose Edit > Paste (or press Command-V), enter a bar value in the 
Position field, then press Return.

Copy signatures between projects
	 1	 Select signatures in the Signature track or Signature List.

	 2	 Choose Edit > Copy (or press Command-C). 

All signature changes of the source project are copied to the Clipboard.

	 3	 Switch to the target project.

	 4	 Make the Signature track or Signature List active, then choose Edit > Paste (or press 
Command-V). 

The copied meter changes are pasted into the target project. 

Delete signatures
You can delete time and key signature changes in a project, but you can’t delete the initial time 
and key signature.

Delete a signature
Do one of the following:

mm Select the signature in the Signature track, Signature List, or Score Editor, then choose Edit > 
Delete (or press Delete). 

Tip:  To erase all time signature events, select a signature, choose Edit > Select Similar Objects, 
then press Delete. 

mm Click the signature with the Eraser tool in the Signature track, Signature List, or Score Editor. 
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Use signature sets
  When Show Advanced Tools is selected in the Advanced preferences pane, you can create 

signature sets, and choose between different marker sets in a project. Only signatures that are 
part of the current set appear in the Signature track and Signature List. When you create new 
signatures, they become part of the current signature set. 

Create a signature set
mm In the Signature List, choose New Set from the Signature Set pop-up menu.

When you create a new signature set, previously added signature changes are no longer visible 
in the Signature track or Signature List. When you create new signatures, they become part of 
the current signature set. The initial time and key signature are always visible.

Rename a signature set
	 1	 Select the signature set, then choose Rename Set from the Signature Set pop-up menu.

	 2	 Enter a new name for the signature set, then click OK.

Choose a signature set
mm In the Signature List, choose a set from the Signature Set pop-up menu.

When you choose a signature set, only signature changes that are part of the set appear in the 
Signature track and Signature List.

Delete a signature set
mm Select the signature set, then choose Delete Set from the Signature Set pop-up menu.
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Work with tempo

Tempo overview
Every project has a tempo, which is expressed in beats per minute (bpm). You can set the tempo 
in the Project Chooser when you create a project, and change it later while you are working. You 
can set the project tempo in the LCD in the control bar. By default, the tempo for new projects is 
120 bpm.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can add 
tempo changes, and control the tempo of a Logic Pro project in a variety of ways, including:

•• Create tempo changes using the Tempo track, the Tempo List, or Beat Detection

•• Match audio recordings to the project tempo, or match the tempo to an audio region

•• Record tempo changes in Logic Pro

  When Advanced Editing options is selected in the Advanced preferences pane, you can 
use the Tempo Operations window and Tempo Interpreter window for more complex control of 
the project tempo. When Advanced MIDI Options is selected, you can control tempo changes 
using the tempo fader in the Environment.

Create tempo changes with the Tempo track

Tempo track overview
  When Show Advanced Tools is selected in the Advanced preferences pane, you can add and 

edit tempo changes in the Tempo track. The Tempo track is available in the Tracks area, Piano Roll 
Editor, Step Editor, and Score Editor. 

In the Tempo track, tempo changes are represented by tempo control points. You create tempo 
changes by adding control points and editing their values. You can expand the Tempo track to 
give yourself more room to work, and adjust the range of values for the Tempo track. 

The Tempo track also determines the relationship between incoming timecode and the current 
playhead position, for projects using timecode.

Because Beat Mapping can create changes in the Tempo track, altering existing tempo changes 
or creating new tempo changes, you should avoid making changes in the Tempo track after 
using Beat Mapping functions. Doing so will defeat the timing derived from the Beat Mapping 
functions. For more information about the Beat Mapping track, see Beat mapping overview on 
page 601.
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Show the Tempo track
Do one of the following:

mm Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global Tracks key 
command (G).

mm Click the Global Tracks button .

If the Tempo track is not visible, Control-click anywhere in the global tracks header area, then 
select Tempo in the dialog than appears. For more information, see Show and hide global 
tracks on page 557.

Adjust the range of the Tempo track
Do one of the following:

mm Grab the maximum and minimum values in the tempo scale and drag vertically.

mm Double-click either value and enter a numerical value in the field.
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Add and edit tempo control points
In the Tempo track, tempo changes appear as tempo control points. You create tempo changes 
by adding control points, then editing their values. You can move and copy control points, create 
tempo curves, and edit control points in other ways.

Add a tempo control point
Do one of the following:

mm Double-click the target time position with the Pointer tool.

mm Click the target time position with the Pencil tool. 

When using the Pencil tool, watch the help tag, and don’t release the mouse button until it 
shows the intended tempo and position. No help tag appears when you double-click with the 
Pointer tool.

mm To set the tempo numerically, hold down Control-Option-Command and click the target time 
position, enter the bpm value in the field that appears, then press Return. 

Change the value of a tempo control point
mm Drag the control point up or down. A help tag displays the tempo value.

You can also drag the line connecting two control points, changing the values of both 
control points.

To change the value in finer increments, hold down Shift while dragging a control point.

Note:  To prevent unintentional changes, control points are restricted to either vertical or 
horizontal movement. You can change either the value of a tempo change event or the position 
of a tempo change event, but not both at once. 

Create a constant tempo across multiple tempo control points
mm Select multiple control points, Control-click the selected control points, then choose Replace By 

Average from the shortcut menu.

Delete a tempo control point
Do one of the following:

mm Select the control point, by either clicking it or the line to the right of it, then choose Edit > 
Delete (or press the Delete key). 

mm Double-click the control point with the Pointer tool.

mm Click the control point with the Eraser tool. 



	 Chapter  19    Make global changes to a project	 584

Move and copy tempo control points
You can move and copy tempo control points in a number of ways:

Move a tempo control point in time
mm Drag the control point left or right.

Move the selected tempo control point to the current playhead position
mm Use the Move Region/Event to Playhead Position (Pickup Clock) key command.

Move the selected tempo control point, replacing the previous one 
mm Control-click a control point, then choose Extend Left from the shortcut menu.

The selected tempo control point is moved left to the position of the previous one, which 
it replaces.

Note:  This menu item is not available for the first tempo control point.

Copy a tempo control point
Do one of the following:

mm Hold down Option while dragging a control point.

mm Use the standard Copy and Paste operations (via the Edit menu or the corresponding key 
command). The control point is pasted at the playhead position. 

If you copy multiple control points using Copy and Paste, the first control point is pasted at the 
playhead position.

Copy or move multiple tempo control points
mm Shift-click or drag to select (while holding down Control), then drag all control points to the 

target position.

Note:  Any tempo control points at the target positions are replaced by the moved or 
copied ones.

Copy tempo changes from a passage
	 1	 Set the locators to the passage containing the correct tempo change.

	 2	 Choose Edit > Select Inside Locators.

Note:  When a marquee selection is active, using this key command sets the marquee selection 
to match the locators.

	 3	 Copy the tempo control points to the Clipboard (Command-C).

	 4	 Deselect all tempo control points (by clicking the background).

	 5	 Paste the tempo control points from the Clipboard (Command-V).

	 6	 By default, the first control point is pasted at the current playhead position, but this can be 
changed. A Position field appears alongside the first pasted control point, allowing you to alter 
the bar position. If the first control point is not at the start of the bar in the passage, be sure to 
alter the bar number, and leave the beat, sub-beat, and frame or tick values unaltered.

	 7	 Press Return. 

The copied tempo changes are selected, and you can undo the operation if necessary.
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Create tempo curves in the Tempo track
You can create a continuous transition, or tempo curve, between two tempi using a tempo curve. 

Create a tempo curve between two tempi
	 1	 Select the two tempo control points.

	 2	 Click-hold and drag the tip of the right angle line (the corner) above or below the second control 
point. 

A curve or diagonal line results (a Move Curve Node help tag is shown), which can be dragged—
horizontally or vertically—to alter the curve shape. The process is similar to drawing track 
automation curves with the pointer.

Change the resolution of a tempo curve
mm Choose a value from the Resolution pop-up menu in the Tempo track to define the number of 

tempo changes that are actually performed when using curves.

When set to 1/16, there are four tempo changes per quarter note; 1/1 only generates one tempo 
change per bar, which will result in a more abrupt transition. A different resolution can be 
defined for each tempo curve.

Delete a tempo curve
mm Click the curve node (at the tip of the right angle) with the Eraser tool, or double-click it with the 

Pointer tool.
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Use the Tempo List

Tempo List overview
  When Show Advanced Tools is selected in the Advanced preferences pane, you can view and 

edit tempo changes in the Tempo List. You can open the Tempo List in the main window, or as a 
separate window.

Open the Tempo List in the main window 
mm Click the List Editors button  in the control bar, then click Tempo.

Open the Tempo List as a separate window
mm Drag the Tempo List out from the main window.

Create and edit tempo changes in the Tempo List
The layout and functions of the Tempo List are similar to those of the Event List. Below are the 
most important Tempo List operations. For information on general Event List operations, see 
Event List overview on page 406.

Creating a tempo curve can lead to the creation of numerous tempo change events. These 
tempo change events can be viewed in the Tempo List.

Create a tempo change in the Tempo List
	 1	 Move the playhead to the position where you want to add the tempo change event.

	 2	 In the Tempo List, click the Add Tempo button .

A tempo change event (which uses the current project tempo value) appears. You can alter the 
value in the Tempo column.

Change the position of a tempo change
mm Drag any of the position numbers up or down, or double-click in the Position or SMPTE column 

and enter a new position.
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Move the selected tempo change event to the current playhead position
mm Use the Move Region/Event to Playhead Position (Pickup Clock) key command.

Display additional events in the Tempo List
mm Click the Additional Info button.

All tempo change events, including those located on the tempo curve, are displayed in the 
Tempo List.

Delete a tempo change event in the Tempo List
Do one of the following:

mm Click the tempo change event with the Eraser tool.

mm Select the tempo change event, then choose Edit > Delete (or press Delete). 

Use tempo sets
  When Show Advanced Tools is selected in the Advanced preferences pane, you can create 

tempo sets, and choose between different tempo sets in a project. Only tempo changes that are 
part of the current set appear in the Tempo track and Tempo List. When you create new tempo 
changes, they become part of the current tempo set. 

Create a tempo set
mm In the Tempo List, choose New Set from the Tempo Set pop-up menu.

When you create a new tempo set, previously added tempo changes are no longer visible in 
the Tempo track or Tempo List. When you create new tempo changes, they become part of the 
current tempo set. The initial tempo is always visible.

Rename a tempo set
	 1	 Select the tempo set, then choose Rename Set from the Tempo Set pop-up menu.

	 2	 Enter a new name for the tempo set, then click OK.

Choose a tempo set
mm In the Tempo List, choose a set from the Tempo Set pop-up menu.

When you choose a tempo set, only tempo changes that are part of the set appear in the Tempo 
track and Tempo List.

Delete a tempo set
mm Select the tempo set, then choose Delete Set from the Tempo Set pop-up menu.
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Create tempo changes using Beat Detection
  When Advanced Editing options is selected in the Advanced preferences pane, you can 

use Beat Detection to find the average tempo of one or more selected audio or MIDI regions. 

The Beat Detection process detects up to five tempi across the selected regions, and displays 
the reliability of each estimate, from highest (most reliable) to lowest (least reliable). The highest 
value is selected by default. You can adjust the average tempo value using a multiplier, divisor, or 
decimal rounding, and choose how and where to apply the tempo change.

Adjust the tempo of regions using Beat Detection
	 1	 Select one or more regions in the Tracks area.

	 2	 Choose Edit > Tempo > Adjust Tempo using Beat Detection (or use the corresponding key 
command).

The selected regions are analyzed; the results appear in a dialog that looks similar to 
the following.
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	 3	 Set the following parameters, as required.

•• Create Tempo Change: Select one of the following options:

•• Globally: Uses the resulting tempo across the project.

•• At Selection Start and End: Uses the resulting tempo from the region selection start point up 
to the selection end point, then changes back to the previously valid tempo.

•• At Selection Start Only: Uses the resulting tempo up to any previously existing tempo change 
that follows the region selection end point, or to the project end if no tempo changes exist.

•• Nudge Regions to Beat: Select this checkbox to nudge the regions equally until the first 
transient of the first region falls precisely on a whole beat of the ruler. The nudge direction is 
either left or right, whichever results in the smaller movement range.

	 4	 Click the Advanced Options disclosure triangle and set the following parameters, as required:

•• Adjust Value By: Define a ratio (multiplier and divisor) for the selected detection result. A ratio 
of 2:1 multiplies the value by two, while a ratio of 1:2 divides the value by two.

•• Rounding: Choose one of the following rounding values: Integer, 1 Decimal, 2 Decimals, 3 
Decimals, or Off. This value is used to modify the Resulting Tempo value.

	 5	 Click the Prelisten button to preview playback using the Resulting Tempo value.

	 6	 Click OK to perform the tempo adjustment (according to the above settings), or Cancel to cancel 
the procedure.
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Match audio recordings to the project tempo
The length of imported audio regions is linked to the project tempo. If you add a tempo change 
at a particular ruler position, the length of regions changes, starting from that position. The 
playback speed of the imported regions doesn’t change, but all MIDI regions will be out of sync 
with all audio regions. Audio regions that are lengthened (by increasing the tempo) may overlap 
subsequent regions on the same track, with the result that the overlapped parts of the regions 
are not heard. All audio region loop lengths (set with the Inspector Loop parameter in the 
inspector) change, resulting in irregular loops and rhythmic conflicts between tracks.

The following audio files automatically match the project tempo and will follow any tempo 
changes made in the global Tempo track.

•• Audio recordings made in Logic Pro (7.0 and later)

Note:  If you drag a file recorded in one project to another project using the Finder, the file 
does not follow the project tempo. However, files copied between two projects are able to 
follow the project tempo.

•• Apple Loops

•• Audio regions on tracks for which Flex Time is turned on

•• Audio bounces made in Logic Pro (7.0 and later)

Note:  Bounce files can only follow the project tempo if the “Add resulting files to Project Audio 
Browser” option is selected in the Bounce dialog when the file is bounced or exported.

•• Audio files exported from Logic Pro (7.0 and later)

Note:  Exported files can only follow the project tempo if the “Add resulting files to Project 
Audio Browser” option is selected in the Export dialog when the file is bounced or exported.

Imported ReCycle files can also follow the project tempo. (See Add ReCycle files to your 
project on page 270.)

Audio files that follow the project tempo (and first key signature) are flagged with the Follow 
Tempo symbol, in both the Tracks area and the Project Audio Browser.

Follow Tempo symbol Follow Tempo symbol

All other imported audio files require adjustment of either the region or the project tempo.

You can set an audio region to follow the project tempo, or convert a region to an Apple Loop. 
For more information about Apple Loops, see What are Apple Loops?
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Make audio recordings follow the project tempo
mm Select the audio region in the Tracks area, then select the Follow Tempo and Pitch checkbox in 

the Region inspector.

The Follow Tempo and Pitch checkbox is synchronized for all regions that make use of the same 
audio file.

Convert a selected audio region to an Apple Loop
mm Choose Functions > Open in Apple Loops Utility from the Tracks area menu bar. 

In the Apple Loops Utility, you can set transients for the file, and add search tags for genre, 
instrument, and other descriptors.
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Match the tempo to an audio region
You can adjust the project’s tempo to match the tempo of an audio region. The length of the 
region remains constant, and the tempo changes to match the region.

For example, imagine you have imported a one-bar drum loop that doesn’t match your project 
tempo. The drum loop adapts to your project tempo, becoming shorter or longer than one bar. 
You can set the project tempo to match the original tempo of the drum loop, using the Adjust 
Tempo using Region Length and Locators command.

The Adjust Tempo using Region Length and Locators command adjusts the project tempo by 
creating a tempo change event at the start point of the selected audio region. This ensures that 
the length of the selected audio region matches exactly the distance between the locators.

Match the project tempo to an audio region
	 1	 In the Tracks area, select the audio region to which you want to match the project tempo.

	 2	 Control-click the Cycle button in the control bar, and make sure the Auto Set Locators by Region 
Selection option is not selected.

	 3	 Set the left and right locator positions in the ruler.

The locator range should closely match the length of the region—usually to the nearest bar.

	 4	 Choose Edit > Tempo > Adjust Tempo using Region Length and Locators. 

A dialog asks if you want to change the tempo of the entire project, or create a tempo change 
for the section of the project occupied by the selected region. 

	 5	 Do one of the following:

•• To adjust the tempo of the complete project to the audio region: Click Globally.

•• To create a tempo change that spans the length of the audio region: Click Create.

The project tempo is recalculated to conform with the audio length (and locators).
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Use tempo information from audio files
When you record or bounce an audio file, the current Tempo List is added to the file. You can 
then use the saved tempo information for importing or exporting purposes.

In some situations, you may want to import tempo information from an audio file that was 
recorded in a different project. The tempo of the selected audio file is used in place of the project 
tempo, but only within the borders (start and end points) of that file in the Tracks area.

For example, if you have an audio recording containing slight tempo variations, how do you 
get it to follow the tempo of your current project? First, beat map the track to associate beats 
in the region with the project tempo (see Beat mapping overview on page 601), then remove 
the tempo information from the audio file. As a final step, export the current project tempo 
information to the audio file.

Import tempo information from an audio file
mm Choose Edit > Tempo > Import Tempo Information from Audio File.

You can also export the current tempo value within the borders (start and end points) of a 
selected audio file in the Tracks area. However, you should first remove any tempo information 
that exists in the audio file.

Remove tempo information from an audio file
mm Choose Edit > Tempo > Remove Tempo Information from Audio File.

You can then export the current tempo information to the audio file.

Export tempo information to an audio file
mm Choose Edit > Tempo > Export Tempo Information to Audio File.

Record tempo changes in Logic Pro
All tempo changes made when Logic Pro is in record mode are stored as tempo change events 
on the Tempo track. You can record tempo changes with an external MIDI controller, the 
Environment tempo fader, or external synchronization signals. You can edit recorded tempo 
change events in the Tempo track or using one of the tempo editors—Tempo List, Tempo 
Operations window, Tempo Interpreter window, or tempo fader.

Turn on tempo change recording
	 1	 Open the Recording project settings by doing one of the following:

•• Choose File > Project Settings > Recording, or use the Open Recording Project Settings key 
command, Option-Asterisk (*).

•• Control-click the Record button  in the control bar, then choose Recording Settings from 
the pop-up menu.

	 2	 Select the “Allow tempo change recording” checkbox.
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Use Tempo Operations

Tempo Operations overview

  When Advanced Editing options is selected in the Advanced preferences pane, you can 
use the Tempo Operations window for greater control of the project tempo.

You use Tempo Operations to create tempo changes, and edit existing tempo changes. The 
window automatically displays the area you’ve selected for editing. Changes are displayed 
graphically in real time, as the tempo curve is processed, so you can see the results of your edits. 

Open the Tempo Operations window
mm Choose Edit > Tempo > Tempo Operations (or use the Open Tempo Operations key command).

Create and edit tempo changes in the Tempo Operations window
You can create tempo changes in the Tempo Operations window using the following operations:

•• Create Tempo Curve: Lets you create numerous tempo change events with just a few 
parameters, and provides a smooth overall change in tempo.

•• Create Constant Tempo: Creates a constant tempo in the selected area. The default setting 
assigns an average tempo for the selected project section (based on existing tempo change 
events).

•• Scale Existing Tempo: Alters existing tempo changes proportionally (scales them). This allows 
you to speed up an entire project section, without losing the relationships between any 
subsequent tempo changes within the area. Scaling is done by percentage.

•• Stretch Existing Tempo Curve: Stretches or compresses an existing tempo curve.

•• Thin Out Existing Tempo Changes: Reduces the number of tempo changes in the selected area.

•• Randomize Tempo: Adds random tempo changes based on the parameters you specify.
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Create a tempo change in the Tempo Operations window
	 1	 In the Tempo Operations window, choose Operation > Create Tempo Curve.

	 2	 Use the Position or Time field to define the area that the tempo change should take place 
across: the left field sets the curve start point and the right field, the curve end point.

	 3	 Enter start and end tempos in the Tempo line.

	 4	 Select a curve type.

Three kinds of tempo curves are available from the Curve Type pop-up menu. Each of these 
offers a Curvature parameter (the field to the right of the Curve Type pop-up menu), which 
determines if the tempo should speed up or slow down, depending on whether positive or 
negative curvature values are entered.

	 5	 Adjust the Curvature parameter.

	 6	 Alter the concentration of graphical tempo change events with the Density parameter.

Values of 1/8 and finer should be used only if really necessary (with very slow or fast tempo 
changes, for example). Don’t select a resolution higher than 1/8 or finer, just to make the curve 
look smoother. This results in an unnecessary amount of processing, and the creation of more 
tempo change events than are needed.

As you change the values, the displayed tempo curve (which is calculated from the tempo 
settings you’ve made) is shown in red.

Note:  The “Continue with new Tempo” checkbox determines whether the original tempo 
resumes after the tempo curve ends (unselected), or the new tempo (the last tempo change 
event in the curve) is maintained (selected). 

	 7	 Click Apply when you're done. 

Create a constant tempo curve
mm In the Tempo Operations window, choose Operation > Create Tempo Curve, then do one of the 

following:

•• To remove all tempo variations between two points without changing the SMPTE time for the 
rightmost position: Click the Apply button.

•• To retain the new tempo or return to the initial tempo: Select the “Continue with new Tempo” 
checkbox.

Scale tempo changes
	 1	 In the Tempo Operations window, choose Operation > Scale Existing Tempo Changes.

	 2	 Adjust the scaling percentage using the Scale value slider.

Positive percentage values speed up sections, and negative ones slow them down.

Stretch tempo curves
	 1	 In the Tempo Operations window, choose Operation > Stretch Existing Tempo Changes.

	 2	 Define the start point for tempo changes using the Position or Time parameter.

	 3	 Do one of the following:

•• Enter the new end point of the tempo curve as a bar position or SMPTE value.

•• Set a Stretch value for the tempo curve (as a percentage).
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Thin out (reduce) tempo changes
mm In the Tempo Operations window, choose Operation > Thin Out Existing Tempo Changes.

The Position or Time field defines the start and end points of the area to be processed. Density 
determines the number of tempo change events that remain per bar after processing. You can 
select values between one tempo change event per bar (1/1) and 32 per bar (1/32).

Randomize tempo changes
	 1	 In the Tempo Operations window, choose Operation > Randomize Tempo.

	 2	 Define the start and end points for tempo changes using the Position or Time parameter.

	 3	 Determine the amount of deviation from the current tempo, in beats per minute (bpm) using the 
Randomize parameter.

	 4	 Define how often the new tempo change events occur using the Density parameter. You can 
select values between one per bar (1/1), and 32 times per bar (1/32).

Use the Tempo Interpreter
  When Advanced Editing options is selected in the Advanced preferences pane, you can 

use the controls in the Tempo Interpreter window for greater control of the project tempo.

You use the Tap Tempo command to generate tempo timing events by tapping a key on a 
computer or USB keyboard. You can define the values for Tap Tempo using the Tempo Interpreter. 
The parameters that control how Logic Pro responds to Tap Tempo commands can be found in 
the Tempo Interpreter window. 

Turn on Manual Synchronization mode
Do one of the following:

mm Choose File > Project Settings > Synchronization > General, then choose Manual in the Sync 
Mode pop-up menu.

mm Select the “Auto enable external sync” checkbox (on by default) in the Project Settings > 
Synchronization > General pane. 

If Logic Pro “hears” a Tap Tempo command, it automatically follows this tempo.

Set the tempo values in the Tempo Interpreter window
	 1	 Choose Edit > Tempo > Tempo Interpreter (or use the Open Tempo Interpreter key command).

	 2	 In the Tempo Interpreter window, adjust any of the following:

•• Tap Step: Sets the note value that Logic Pro assigns to manual taps. You achieve the best 
results with larger, rather than smaller, values. 1/4 note usually works well.

•• Window: Determines the time span (or window) within which tap notes can be entered (set 
in ticks, or 1/3840 note). Only taps made within this time window are used to determine the 
tempo. Any taps outside it are ignored.

•• The narrower the window, the more effectively Logic Pro is able to withstand the influence 
(on the tempo) of any taps that fall between the note values—set with the Tap Step 
parameter. 

•• The larger the window, the easier it becomes to create drastic tempo changes.

•• If you set the window parameter to 0, the tap window disappears altogether, and all taps 
are accepted as tempo-determining information. Logic Pro also comes to a halt, if taps are 
not generated.
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•• Tempo Response: Sets the sensitivity to tempo changes: the larger the value, the greater the 
sensitivity. You should set this value to 4, for most situations. If you find that your tap timing 
is imprecise, but want Logic Pro to play at a relatively constant tempo, reduce this value to 2 
or so.

•• Max. Tempo Change: Use this parameter to set the maximum tempo change possible per tap 
(in bpm). To obtain the most regular, or even tempo curve, follow this rule: set the smallest 
possible value (in other words, only as large as necessary).

•• Tap Count-In: Sets the number of taps used as a count-in. Logic Pro starts following the tempo 
on the first tap after the count-in taps.

•• Smoothing: Turning on this function smooths out jumps in tempo, resulting from incoming 
taps (which could prove useful when using Logic Pro live). You should turn it off if you want 
Logic Pro to follow your taps precisely and quickly.

•• Tempo Recording: Creates a tempo list that follows your taps, when in record mode. This option 
should normally be turned off.

•• Pre and Post: Determine which tap signals are displayed:

•• Pre: Displays every incoming tap.

•• Post: Displays every accepted tap that occurs within the time window (as defined by the 
Window parameter), or close to, or on, a tap step.

The Pre/Post tap signals flash yellow if the taps are within the allowed range, and red if they 
are out of range.

Note:  Only the selected software instrument track, and all external MIDI tracks, can play when the 
Tempo Interpreter window is open.
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Control tempo changes with the tempo fader
  When Advanced MIDI Options is selected in the Advanced preferences pane, you can 

create a real-time tempo fader in the Environment window by choosing New > Fader > Specials 
> Tempo Control. This fader can control the project tempo (using Meta event #100). There is no 
need to connect this fader to anything, unless you want to record its output.

A tempo fader has a range of possible values from 50 to 177 bpm. External MIDI data can be 
used to control it, with an input value of 0 resulting in a tempo of 50, and an input value of 127 
resulting in a tempo of 177.

If you place a tempo fader between the Physical Input and Sequencer Input objects in the 
Environment, you can:

•• Record tempo changes

•• Control the tempo with any desired MIDI event types

This way, new Tempo track data can be recorded intelligently. The original tempo data is only 
erased in areas that actually contain tempo changes.

If a tempo fader is moved during playback or recording, all data defined in the Tempo List is 
turned off, until you stop playback or recording.

Movements of a tempo fader are ignored when external SMPTE sync is active. A tempo fader can 
therefore be used to deactivate the sync reference during playback or recording, if you wish.

For more information about create meta event faders in the Environment, see Meta event faders.

Note:  The tempo fader’s inspector displays pitch bend events as the Input definition (by default). 
This allows control of the project tempo with your keyboard’s pitch bend wheel.
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Work with transposition

Transposition overview
  When Show Advanced Tools is selected in the Advanced preferences pane, you can you can 

transpose (change the playback pitch of ) MIDI regions and Apple Loops in a project over time 
using the Transposition track. The Transposition track contains control points for pitch changes 
(transposition events). The project transposes at the position of the control point, and remains at 
the new transposition value until the next control point.

Transposition affects both audio and software instrument Apple Loops (except drum loops, and 
other Apple Loops with no defined key) as well as MIDI regions. Audio regions other than audio 
Apple Loops are not transposed.

The zero position of the Transposition track is determined by the current key signature in 
the Signature track. If the key signature changes during a project, the zero position of the 
Transposition track changes accordingly.

Transposition works nondestructively, and transposed MIDI notes return to their original values 
when the Transposition value is reset to zero (0). For example, starting with a C3 note event 
in a MIDI region, adding a control point with a value of +2 changes the note event to a D3. If 
you change the control point to a different value, the note is transposed by the corresponding 
amount. When you change the control point so that the transposition value = 0, the note returns 
to a C3. Similarly, if you copy a region to different parts of the project with different transposition 
values, the notes in the region change by the corresponding amount.

When you add or edit a transposition control point, only existing MIDI events in a project are 
transposed. MIDI events recorded or created afterward are not affected.

If the No Transpose checkbox is selected in the Track inspector, MIDI events (including instrument 
Apple Loops) are not transposed for that track.
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Show the Transposition track
	 1	 Do one of the following:

•• Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global Tracks key 
command (G).

•• Click the Global Tracks button . In the Tracks area, the Global Tracks button appears above 
the track headers; in the editors, it appears on the left side of the editor.

	 2	 Control-click anywhere in the global tracks header area, then select Show Transposition in the 
dialog that appears.

Add and edit transposition control points
You control transposition by adding and editing transposition control points in the Transposition 
track. Working with transposition control points is similar to working with automation control 
points in the Tracks area.

Add a transposition control point
Do one of the following:

mm Click a position in the Transposition track with the Pencil tool.

mm Hold down Control-Option-Command, click a position in the Transposition track, enter a 
transposition value in the field, then press Return.

A transposition control point is added, set to the value you entered.

Change the value of a transposition control point
mm Drag the control point up or down to a new value.

As you move the control point, a help tag appears, showing the current transposition value.

Delete a transposition control point
Do one of the following:

mm Click the control point with the Pointer tool, then press the Delete key.

mm Click the control point with the Eraser tool.

Transposition events can be copied using the standard Copy and Paste operations or by 
dragging them while holding Option.

You can also copy or move multiple transposition events simultaneously, which can be useful for 
repeated project sections.
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Work with beat mapping

Beat mapping overview
  When Show Advanced Tools is selected in the Advanced preferences pane, you can access 

the Beat Mapping track. Beat mapping lets you map notes that don’t follow a strict tempo with 
beats in the ruler. When you play the project, the project tempo adjusts so that the beat-mapped 
notes are aligned with beats in the ruler. 

Beat mapping has the following uses:

•• The metronome click reflects the beat-mapped tempo when you make subsequent recordings.

•• You can apply Quantize functions to newly recorded regions.

•• Loops adjust their timing to the beat-mapped tempo.

•• The timing of MIDI regions recorded to the beat-mapped tempo appears in a musically 
meaningful way in the Score Editor.

•• MIDI regions subsequently created using step input follow the beat-mapped tempo, resulting 
in a more natural, less mechanical rhythmic feel.

Beat mapping involves two steps: first, you graphically connect notes to ruler positions in the 
Beat Mapping track. A tempo change event is inserted at each of these ruler positions, so that 
the notes align with musically meaningful time positions in the ruler, although their absolute 
time position is unchanged. A beat-mapped project contains the same tempo variations as the 
original recording.

In the upper part of the Beat Mapping track, a ruler shows the same time divisions (bars, beats, 
and subdivisions) as those that appear in the LCD (and also depend on the current zoom level). 

The following sections describe beat mapping in the Tracks area. Beat mapping is also available 
in the Piano Roll Editor, Score Editor, and Step Editor. When working in these editors, you can see 
the corresponding (beat-mapped) notes as you work, which can speed your workflow.

Show the Beat Mapping track
	 1	 Do one of the following:

•• Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global Tracks key 
command (G).

•• Click the Global Tracks button . In the Tracks area, the Global Tracks button appears above 
the track headers; in the editors, it appears on the left side of the editor.

	 2	 Control-click anywhere in the global tracks header area, then select Beat Mapping in the dialog 
that appears.
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Use beat mapping on MIDI regions
You can beat map MIDI regions to adjust the project tempo so that freely recorded notes in the 
regions align with beats in the ruler. 

Apply beat mapping to MIDI regions
	 1	 Select the regions that you want to use for beat mapping.

A representation of the selected regions appears in the Beat Mapping track.

Tip:  You may want to zoom in to work more precisely.

	 2	 In the Beat Mapping track, click the first (leftmost) ruler position that you want to associate with 
a MIDI note.

A vertical line appears at the clicked ruler position.

	 3	 Drag the bottom part of the line so it aligns with the beginning of the note you want to map to 
the ruler position.

The line adjusts to match the beginning of the note. If the Tempo track is displayed, a Tempo 
change appears at the ruler position.

Logic Pro automatically inserts a tempo change, which appears in the Tempo track.

	 4	 Moving from left to right, beat map the subsequent notes in the selected regions, repeating the 
same steps.

	 5	 To connect a ruler position to a position in the region where no note exists, hold down Control 
while drawing the connecting line. This allows the line to snap to any subdivision, even where 
there is no note event.

	 6	 To erase a beat mapping, double-click it with the Eraser tool, or select it and press the Delete key. 

	 7	 To erase all beat mappings, click anywhere in the header of the Beat Mapping track (except on 
the controls) to select all data in the track, then press the Delete key.

When using the Delete key, be careful not to accidentally delete other selected events or regions. 
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Use beat mapping on audio regions
Beat mapping audio regions works similarly to beat mapping MIDI regions. If the audio regions 
don’t contain tempo information, they must be analyzed to find transients (short amplitude 
peaks, usually at rhythmically prominent positions), which can be mapped to a ruler position, 
before you can use them for beat mapping.

Transients appear as blue vertical lines in the lower part of the Beat Mapping track, aligned to 
peaks in the audio waveform. If no transients are visible on the selected audio regions when you 
open the Beat Mapping track, analyze the regions before applying beat mapping.

Detect transients in audio regions
mm Select the regions to analyze, then click the title “Beat Mapping” in the Beat Mapping track and 

choose Analyze Transients from the shortcut menu.

After the regions are analyzed, the transients appear as blue vertical lines in the lower part of the 
Beat Mapping track.

Tip:  It may be difficult to identify transients if the waveform overview is too small. If transients 
are hard to see, click the Waveform Zoom button in the Tracks area menu bar to visually resize 
the waveform in the Beat Mapping track.

The remaining steps for beat mapping audio regions are the same as for MIDI regions. To follow 
those steps, see Use beat mapping on MIDI regions on page 602.
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There are a number of ways to improve the beat mapping accuracy of audio regions. When you 
choose Analyze Transients, those transients above a certain threshold are displayed. You can 
adjust the threshold using the Minus and Plus (–/+) buttons in the Beat Mapping track.

Increasing the number of transients can be useful when beat mapping regions with less distinct 
accents—such as soft drums in a loud mix. However, a high setting can result in extraneous 
transients, with no real meaning for the rhythmic structure, being displayed. In general, it’s better 
to begin with a lower setting, and move to a higher setting only if transients are missing for 
obvious rhythmic elements in the music.

Sometimes, your MIDI recordings may contain note events that fall on musically meaningful 
positions, and should not be affected by beat mapping applied to audio recordings. In this 
case, you can choose the Protect MIDI option to keep existing MIDI events at their current ruler 
positions when beat mapping audio regions.

You can also make beat mapping easier by moving one or multiple selected audio regions, so 
that the first transient marker in any of the regions is located on the nearest whole beat position.

Change the threshold of transients displayed
Do one of the following:

mm To decrease the number of transients displayed: Click the Minus button (−) in the header of the 
Beat Mapping track.

mm To increase the number of transients displayed: Click the Plus button (+) in the header of the Beat 
Mapping track.

Protect MIDI events from being beat mapped
mm Click the title “Beat Mapping” in the Beat Mapping track, then choose Protect MIDI from the 

shortcut menu.

Move the first transient marker in a region selection to the nearest whole beat position
mm Control-click the beat mapping header, then choose Move Selection with First Transient to 

Nearest Beat from the shortcut menu (or use the corresponding key command).

The first transient marker in the region selection is moved to the nearest whole beat position, 
with all selected regions moving with it.
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Automatically beat map regions
Logic Pro can automatically beat map audio or MIDI regions using the Beats from Region 
command. You can select the note value to use for automatic mapping, and select the 
beat-mapping algorithm.

Apply automatic beat mapping
	 1	 Select the region you want to beat map.

	 2	 Click the title “Beat Mapping” in the Beat Mapping track, and choose Beats from Region from the 
shortcut menu.

	 3	 In the Set Beats by Guide Region(s) dialog, choose the note value to use for beat mapping in the 
Note Value pop-up menu.

The note value defines the timing resolution used to create the map.

	 4	 Select one of the following algorithms:

•• Tolerate missing or additional events: Only tempo-relevant transients are used for beat 
mapping (based on the project time signature). This avoids drastic tempo changes, which are 
usually undesirable.

Note:  This algorithm gives the best results when used with material with a regular beat, and 
a fairly constant tempo. However, it can also be used with material that features changing 
rhythmic divisions, and some degree of tempo change.

•• Use exactly all existing events: Every detected transient is used for beat mapping. For usable 
results, the regions should have an event for each tempo-significant transient.

	 5	 Click OK to perform the automatic beat-mapping process.

Regions with more complex or irregular musical patterns may not initially produce useful results 
with automatic beat mapping. If your first attempt produces an alert saying that the required 
tempo would be too low, undo the beat mapping, then set the first downbeat manually before 
choosing Beats from Region. If the alert reappears, undo again, and set both the first and 
second downbeat manually before choosing Beats from Region. If this method fails, you can 
record a MIDI region containing synchronized regular notes, and use this as a guide region for 
beat mapping.

For information about mapping regions manually, see Use beat mapping on MIDI regions and 
Use beat mapping on audio regions.

Apply beat mapping to audio material containing tempo changes
	 1	 Cut the audio material at the precise position of each tempo change.

	 2	 Lock the SMPTE position of each audio region.

	 3	 Select the first region and perform the automatic beat-mapping process as already described.

	 4	 Continue with the remaining audio regions.
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Control the overall project volume
You can control the overall playback volume of a project using the Master Volume slider in the 
control bar, the master track in the Tracks area, and the master channel strip in the Mixer. Each 
acts as a master volume control for the overall project, and also affects the overall volume of the 
project mix. These controls don’t affect the playback volume of external MIDI channel strips.

The Master Volume slider, master track, and master channel strip are connected, so that changes 
to one affect the other two as well. If automation data exists on the master track, the Master 
fader moves to show the volume changes when you play the project. 

Generally speaking, you should adjust the output volume to a level high enough to eliminate 
background noise, but not high enough to cause clipping. You can check for clipping by 
watching the clipping indicators in the master level meter.

For information about the master track, see Work with the master track. For information about 
automating track parameters, see Automation overview. For details about working with the 
master channel strip in the Mixer, see Channel strip types.

Adjust the overall project volume
Do one of the following:

mm In the control bar, drag the Master Volume slider left or right.

Option-click the slider to return it to a neutral value (0 dB gain).

mm In the Tracks area, drag the volume slider on the header of the master track.

If the master track is hidden, choose Track > Show Master Track.

mm In the Mixer, drag the Master fader up or down.
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Notation overview
You can view MIDI regions in software instrument (and external MIDI instrument) tracks as music 
notation in the Score Editor. Notes and other musical events are displayed as standard notation, 
along with common symbols such as time and key signature, bar lines, and clef signs. You can 
add and edit notes, add sustain pedal markings and other symbols, and print the score.

The Score Editor provides visual quantization so that you can control the display of note values 
without altering the timing of your recordings, and change the displayed musical key without 
altering the playback of your MIDI recordings.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can control 
many additional aspects of music notation. You can:

•• View and edit multiple tracks in a score, displayed in a linear scrolling view, “wrapped” view, or 
multi-page view

•• Add notes and symbols from the Part box, including dynamics, phrase markings, and other 
symbols

•• Add lyrics and other text such as section markers and performance indications

•• Use additional tools (the Pointer, Pencil, Eraser, Text, Layout, Zoom, Voice Separation, and Solo 
tools) in the Score Editor

•• Edit region parameters in the Region inspector to control how regions appear in the score

•• Use staff styles to control the display of rests, stems, ties, and beams, and adjust the size of and 
space between staffs. You can choose different staff styles or customize and create your own 
staff styles to use in your scores.

•• Define different instrument groups using score sets to create full scores, parts, and lead sheets

•• Edit the overall score layout, including numbers, names, and spacing

•• Share the score by printing it or exporting it to a PDF file

View and edit music notation 20
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  When Additional Score Options is selected in the Advanced preferences pane, you can 
access the following options for more specialized notation projects. You can:

•• Add and edit staff styles for individual MIDI regions

•• Access additional choices in the Staff Style window (for mapped instruments and TAB)

•• Create Part box sets with your own combinations of score symbol groups for easy access

•• Access additional symbols from the Part box, including tablature and guitar performance 
symbols

•• Create and edit chord grids for guitar or other instruments, using standard or open tunings

•• Access additional tools from the Score Editor Tool menu.

•• Access additional Score preferences and Score project settings

Work in the Score Editor

Score Editor overview
The Score Editor can display a single MIDI region or software instrument track. In the Score Editor, 
each track appears as a separate staff. Notes, rests, and other musical events in the MIDI regions 
on the track are displayed in standard musical notation.

  When Show Advanced Tools is selected in the Advanced preferences pane, the Score Editor 
can display multiple tracks containing MIDI regions, and display every instrument track in 
the project.

Event inspector Region inspector

Part box

The Score Editor menu bar includes Layout, Edit, Functions, and View pop-up menus; Display 
Level, View, MIDI Draw, MIDI In, MIDI Out, and Catch buttons; Tool menus; and a zoom slider.
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The Score inspector, located to the left of the score display, includes the following areas that you 
use to control various aspects of the score:

•• Region inspector: Control visual quantization and other display settings for regions in the score.

•• Event inspector: Control appearance and position settings for individual notes and other items 
in the score.

•• Part box: Select notes and other symbols to add to the score.

•• Inspector channel strips: Control volume, pan, and other mixing functions for the selected track 
and its output.

You can view the Score Editor in the Logic Pro main window, or as a separate, resizable window.

Open the Score Editor
Do one of the following:

mm Click a track header, click the Editors button  in the control bar, then click Score.

mm Select a MIDI region in the Tracks area, click the Editors button in the control bar, then click Score 
(or press N).

mm Double-click a MIDI region (if Logic Pro > Preferences > General > Editing > “Double-clicking a 
MIDI region opens” is set to Score).

Open the Score Editor as a separate window
Do one of the following:

mm Choose Window > Score (or press Command-3).

mm Drag the Score Editor by its title out of the main window.

mm Hold down Option and double-click any event in the Piano Roll Editor.

Show or hide the local Score Editor inspector
mm To show the Score Editor inspector: Choose View > Show Local Inspector from the Score Editor 

menu bar.

mm To hide the Score Editor inspector: Choose View > Hide Local Inspector from the Score Editor 
menu bar.

The following MIDI regions are not displayed in the Score Editor: Muted MIDI regions (if Hide 
Muted Regions is selected in File > Project Settings > Score Global), MIDI regions on muted 
tracks (if Hide Muted Tracks is selected in File > Project Settings > Score Global), and MIDI regions 
for which the Score parameter is turned off in the Region inspector.
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View tracks as music notation in the Score Editor
The Score Editor displays MIDI regions on software instrument (and external MIDI instrument) 
tracks as music notation, including notes, rests, key and time signature, and clef signs. Bar lines 
show the division between measures. Gaps between regions are filled in to display a continuous 
staff. If the track contains software instrument Apple Loops, notation is displayed for each loop 
iteration, but only the original region of the loop can be edited.

The Score Editor has three views, optimized for different kinds of work:

•• Linear view: Shows a single software instrument track in a continuous, horizontally scrolling 
view. Linear view is the standard view for editing the score.

•• Wrapped view: Shows one or more tracks in a lead sheet–style, line-wrapped view. 

•• Page view: Shows the full score on facing pages. Page view displays as many pages as possible 
(depending on the size of the Score Editor window and current zoom level). You can work on 
the score layout and print the full score in Page view.

You can also move through display levels, to view a MIDI region, a track, multiple tracks in a 
folder, or all tracks in the project.

View a track in the Score Editor
Do one of the following:

mm Click a track header, click the Editors button in the control bar, then click Score.

mm Click a track header, choose View > Show Editors, then click Score.

Change the Score Editor view
Do one of the following:

mm Click the Linear View button  to display a single track in a continuous, scrolling horizontal view.

mm Click the Wrapped View button  to display the selected track or tracks in a line-wrapped, lead 
sheet–style view.

mm Click the Page View button  to display the full score on facing pages, including headers, 
margins, and other layout features.

You can also change the view using the View > View Mode menu commands in the Score Editor 
menu bar.
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Set the Link mode for the Score Editor
mm To set the Link mode to :click the link button to Same Level: click the Link button in the Score Editor 

menu bar.

mm To set the Link mode to :click the link button to Content: double-click the Link button in the Score 
Editor menu bar.

For more information about using Link modes, see Control window relationships using 
Link mode.

Move through score display levels
mm To show a single track: Double-click the staff of that track (or select the track in the Tracks area).

mm To move to the next higher display level: Click the Display Level button  in the Score Editor 
menu bar.

mm To show all software instrument tracks in the project: Double-click the background of the 
Score Editor.

When viewing the score in Linear view, the following controls appear in the Score Editor 
inspector to the left of the score display (when Show Local Inspector is chosen in the Score View 
pop-up menu):

•• Insert pop-up menu: Choose the note value for notes to insert.

•• Time Quantize pop-up menu (with Strength and Swing buttons): Quantize the timing of notes.

•• Scale Quantize pop-up menu (with Strength and Swing buttons): Transpose notes to a 
different key.

•• Velocity: Change the velocity value of selected notes.

In addition, the Grid pop-up menu appears in the Score Editor menu bar, so you can set the 
visual quantization of notes in the Score Editor.
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Position items graphically in the Score Editor
You can position items graphically to improve the readability of your score (creating space for a 
grace note, for example). There are three ways to position items:

•• Using the Layout tool: The Layout tool is used to graphically move events in the Score Editor, in 
order to optimize the display without altering the timing of MIDI events.

•• Using the Event inspector: You can change the graphical position of Score Editor symbols and 
text in the Event inspector by editing the Vertical Position and Horizontal Position parameters.

•• Using key commands: You can use key commands to move any score symbol that can be 
positioned independently of notes or staffs, as well as text events and chord symbols. These 
functions don’t alter the bar position of the affected symbols and text events. They alter the 
Horizontal Position and Vertical Position parameters by ±1.

Position items using the Layout tool
mm Select the Layout tool, then drag notes, symbols, text, or other items.

Layout tool

•• When you move symbol or text objects with the Layout tool, the bar position is retained. The 
Horizontal Position and Vertical Position parameters, however, are changed (as indicated in the 
help tag during the process).

•• You can only edit the horizontal position of a note in relation to its bar position using 
the Layout tool, not its vertical position. Dragging the note to the right or left changes 
the displayed distance from the adjacent notes or rests. The bar position (and playback) 
is unaltered.

Note:  The bar position determines playback timing, as this is the actual MIDI event position. 
Remember that the Score Editor is primarily designed to deliver notation, and that most (but not 
all) editing functions are graphical, rather than physical, in nature.

Position items using the Event inspector
	 1	 Select the item or items you want to position graphically.

	 2	 Enter the value for the vertical position in the Vertical Pos.: field. A value of 0 means a position 
exactly on the top line of the staff, in most cases. Positive values are above, negative values 
below it. In staff styles with more than one staff, the Staff parameter determines the staff that the 
Vertical Position parameter refers to. 

	 3	 Enter the value for the horizontal position in the Horizontal Pos.: field. The value determines the 
horizontal offset of the object’s bar position. A value of 0 corresponds to the left edge of a note, 
at that particular position.

Position items using key commands
mm  Use any of the following key commands:

•• To move the vertical position up by 1: Use the Nudge Position Up key command.

•• To move the vertical position down by 1: Use the Nudge Position Down key command.

•• To move the horizontal position left by 1: Use the Nudge Position Left key command.

•• To move the horizontal position right by 1: Use the Nudge Position Right key command.

•• To adjust a number of selected symbols to the same height above (or below) the staff: Use the 
Align Object Positions Vertically key command.
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Tip:  To adjust a number of selected symbols to the same height above (or below) the staff, use 
the Align Object Positions Vertically key command.

Move and copy items in the Score Editor
In addition to moving and copying items using the pointer, you can also use the Layout tool, key 
commands, and Copy and Paste commands.

Move and copy items using the Layout tool
Remember that you can unintentionally change a symbol’s bar position with the Pointer tool. To 
limit changes to an event’s vertical and horizontal position, without changing the bar position, 
use the Layout tool to move and copy items in the Score Editor. See Position items graphically in 
the Score Editor on page 612. 

Move items with key commands
The Nudge Region/Event Position section of the Key Commands window contains a group 
of key commands that can be used to move selected objects along the time axis. The Nudge 
commands most useful for score work are those that nudge region or events left or right by bar, 
beat, or division.

Copy and paste items via the Clipboard
When you copy items via the Clipboard, the first item is pasted at the target time position. 
Subsequent items retain their position relative to the first object. You can simultaneously paste 
the Clipboard contents into several regions, at the original position.

When you paste (or paste multiple) items from the Clipboard, the position of the first inserted 
event is automatically quantized, in accordance with the current division value (set in the LCD). 
For example, if the current bar position is 4.1.1.37, and the division value is set to 1/16, the pasted 
object is inserted at position 4.1.1.1. If you want to preserve the unquantized timing, use another 
method to copy and paste the items.

Move a note or symbol with the pointer
mm Select one or more notes or symbols, then drag to the new position. 

Copy a note or symbol with the pointer
mm Select one or more notes or symbols, hold down Option, then drag to the new position.

While you drag, a help tag shows the operation (drag or copy), the difference from the original 
position (transpose and time shift), and the current pointer position (bar position and, for notes, 
pitch).

You can simultaneously move or copy items from different regions or staffs. Each event is moved 
or copied to its new position, within its original MIDI region.

Note:  You can’t use the Option-drag method to copy or move events between MIDI regions in 
the Score Editor. You can, however, copy and paste between regions and staffs.

Restrict movement to one direction (vertical or horizontal)
mm Hold down Shift while dragging.

There is also a general preference for this constraint: Logic Pro > Preferences > General > Editing 
> Limit Dragging to One Direction In: Piano Roll and Score.
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Move items using key commands
mm Use any of the following:

•• To move the selected notes forward or backward one bar: Use Nudge Region/Event Position Left 
by Bar and Nudge Region/Event Position Right by Bar.

•• To move the selected notes forward or backward one beat.Use Nudge Region/Event Position Left 
by Beat and Nudge Region/Event Position Right by Beat.

•• To move the selected events forward or backward one division step (as set in the LCD): Use Nudge 
Region/Event Position Left by Division and Nudge Region/Event Position Right by Division.

Paste the Clipboard contents into several regions
	 1	 Select all targeted regions (either in the Tracks area or Score Editor) by Shift-clicking the staffs/

regions, or dragging to select adjacent regions.

The Region inspector title indicates the number of selected regions.

	 2	 Choose Edit > Paste Multiple (or use the Paste Multiple key command.) 

Copy an entire musical passage to the same time position in another region
You can use the Paste at Original Position and Paste Multiple at Original Position commands to 
quickly copy passages from one MIDI region to another, at the same time position. No insert 
position is required, and no automatic insert quantization takes place.

	 1	 Select the notes and symbols of the passage.

	 2	 Select the staff you want to paste the passage to.

	 3	 Choose Edit > Paste at Original Position (or use the Paste at Original Position key command).

The notes and symbols are pasted at the position they were originally copied from, regardless of 
the current playhead position.

The Paste Multiple at Original key command works in a similar way, but allows you to paste a 
musical passage to the staffs of other instruments. You need to select all destination staffs before 
using the Paste Multiple command.

You can use these commands in combination with the Select Similar function, to quickly copy all 
dynamic symbols from one staff into other staffs or instruments, for example.

Moving items in time is affected by the display quantization grid (Quantize) setting. If a hybrid 
Quantize value is selected (16, 24 for example), the grid corresponds to the duple value (16, in 
this example).

•• If note positions are not aligned with the time grid (because they were recorded in real time), 
their relative offset is retained when they are moved or copied.

•• You can move or copy unquantized passages within the Score Editor, without losing the 
original feel of the performance.

The following types of symbols cannot be copied or moved in the Score Editor:

•• Global symbols, such as repeat signs, time and key signature changes—except in the 
Signature List and Signature track—and global text elements (headers and so on). (For 
additional information, see Time and key signatures overview on page 576.)

•• Symbols directly attached to notes, such as accents, fermatas, note heads, and so on.
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Resize notes and symbols in the Score Editor
You can change the size of notes, as well as most score symbols, using the Resize tool (located in 
the Score Editor Tool menu). 

Resize tool

Resize a note or score symbol
mm Grab the item with the Resize tool, and move the pointer up or down. 

Reset a note or symbol to its original size
mm Double-click the item with the Resize tool, then click OK in the dialog. 

Note:  Resizing notes does not affect MIDI playback, only the notes’ visual appearance.

Adjust the vertical headroom of the score display
You can adjust the vertical headroom, or the amount of blank space at the top and bottom of 
the score display. This can be helpful when there are notes with ledger lines extending above or 
below the staff, or chords, symbols, or text above or below the staff.

Adjust the vertical headroom at the top or bottom of the score
	 1	 Place the pointer at the top or bottom edge of the score display.

The pointer changes to a pair of up-and-down pointing arrows.

	 2	 Drag up or down to adjust the vertical headroom.

Repeat events in the Score Editor
The Repeat Events command is especially useful for copying complete bars (or multiple copies), 
without setting any bar positions. 

Copy a bar that begins with a rest on the first beat
	 1	 Select the notes and symbols you want to repeat.

	 2	 Choose Edit > Repeat Events (or use the Repeat Regions/Events key command).

	 3	 In the Repeat Regions/Events dialog, insert the number of copies to create, choose Bar from the 
Adjustment pop-up menu, then click OK.

For more information on the Repeat Events command, see Cut, copy, and paste regions in the 
Tracks area on page 292.
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Insert items in multiple regions
You can add notes and symbols from the Part box into all currently selected regions, at the same 
position. This technique allows you to insert notes, symbols, and even text elements into several 
regions at once. 

When multiple regions are selected, the top line of the Event inspector shows the number of 
selected staffs (regions).

Note:  Key changes, signature changes, and global signs can’t be inserted into individual staffs.

Insert an item in multiple regions
	 1	 In the Tracks area or Score Editor, select the regions into which you want to insert the item.

	 2	 Hold down Shift, and do one of the following:

•• Drag the item from the Part box into one of the regions at the position where you want to 
add it.

•• Click in one of the regions with the Pencil tool at the position where you want to add the item.

Edit multiple items in the Score Editor
When multiple items are selected in the Score Editor, the title of the Event inspector indicates the 
number of selected items. If the selection is limited to only notes, chords, or text objects, the title 
also indicates the type of item selected.

If parameter fields are visible while multiple events are selected, their values can be edited 
simultaneously. The “*” value in a parameter field indicates that the selected items have different 
values. In this case, there are two options for editing these values: Relative change (preserving 
relative differences between parameter values) and Absolute change (setting all parameters to 
an equal value).

You can set the vertical and horizontal position of all selected items to the same value, using any 
of the following key commands:

•• Align Object Positions Vertically

•• Align Object Positions Horizontally

•• Align Object Positions (affects both parameters)

These key commands set all items to the value of the first selected item. If only one item is 
selected, a dialog asks if the parameters of all similar objects should be set to the same value. 
This technique is very useful for aligning lyrics and chord symbols, for example.

Change the relative values of multiple items
Do one of the following:

mm Grab the “*” with the pointer, then use the pointer as a slider.

The value shown during this process belongs to the first of the selected objects. The other 
objects are altered by the same amount (while retaining their relative values). 

mm Double-click the value, then insert the change (a number with a plus or minus in front of it) in 
the entry field.
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Change multiple items to the same absolute value
mm Hold down Option while grabbing the “*” with the pointer, then use the pointer as a slider.

As soon as you move the pointer, the parameter is set to the same value for all selected objects. 
This allows you to set all notes of a chord to the same length or velocity, or set all selected 
objects to the same height (Vertical Pos), for example.

Select multiple regions in the Score Editor
  When Additional Score Options is selected in the Advanced preferences pane, you 

can select multiple regions in the Score Editor either from the Region inspector or in the 
score display.

Select more than one region in the Score Editor
mm Click an instrument name in the column between the parameters and score, to select all regions 

for that track (including regions on different tracks that are assigned to the same software 
instrument channel), at the current display level.

Note:  The instrument name column is displayed only if View > Instrument Names is selected. 

Display and edit aliases in the Score Editor
You can use alias regions to mirror existing MIDI regions or folders at different positions in 
the score. An alias points to the original MIDI region or folder from which it was made. For 
information about using aliases, see Create aliases of MIDI regions in the Tracks area.

Aliases are displayed in the Score Editor, and when you print the score. You can assign a staff style 
to an alias different from the one assigned to the original region—for example, if you double 
a unison melody on several instruments with different transpositions (such as a saxophone or 
brass choir). (For information on staff styles, see Staff styles overview on page 684.)

You can allow direct editing of the notes and symbols in an alias. Editing an alias changes the 
original MIDI region (and all aliases created from it). If Allow Alias Editing is turned off and you try 
to edit an alias, a dialog appears, asking if you want to either enable editing of aliases or create 
a copy of the region. If you choose to create a copy, you can edit the notes independently of the 
original MIDI region.

Show or hide aliases in the Score Editor
mm In File > Project Settings > Score > Global, select or deselect the Show Alias/Loops checkbox.

Allow editing of aliases in the Score Editor
mm In File > Project Settings > Score > Global, select or deselect the Allow Alias/Loop 

Editing checkbox.
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Add notes to the score
In general, you add notes to a score by recording on software instrument tracks, as described 
in Record software instruments. You can record directly in the Score Editor following the same 
procedure as in the Tracks area, with one exception: rather than clicking a track header, you click 
the staff for the track.

There are two alternative ways to add notes to a score: using the pointer, and using step input.

Step input lets you add notes from a music keyboard or your computer keyboard. You can input 
notes and other symbols, such as rests. Step input differs from real-time recording in that you 
select rhythmic values for notes you want to enter, then select the pitch, rather than playing 
notes in real time. As with real-time recording, you start by selecting the staff for the track you 
want to work on. If there are no MIDI regions on the track, you must add a MIDI region before 
starting to add notes. For information about step input recording, see Use step input recording 
techniques. 

You can add notes directly using the pointer. While viewing a score in Linear view, you can 
choose note values from the Insert pop-up menu in the local Score inspector. 

  When Advanced Score Options is selected in the Advanced preferences pane, you can also 
add notes and other symbols from the Part box.

Add notes using the pointer
Do one of the following:

mm  Choose a note value from the Insert pop-up menu in the local Score Editor inspector, then 
Command-click at the point where you want to add a note.

The Insert pop-up menu is available when Show Advanced Tools is not selected in the Advanced 
preferences pane.

mm  Click a note in the Part box, then Command-click at the point where you want to add the note. 

The Part box is available in the inspector when Show Advanced Tools is selected in the Advanced 
preferences pane.

You can create a new, empty region by Command-clicking in a software instrument track.

Prepare for step input
	 1	 In the Region inspector, edit the following display settings for the selected track or region:

•• Turn off Interpretation. (See Change the syncopation or interpretation of notes.)

•• Set the Quantize parameter to the smallest note value that you plan to insert. (See Quantize 
the timing of notes in the Score Editor.)

	 2	 Option-click the staff at the point where you want to begin adding notes. A help tag shows the 
pointer position while the mouse button is pressed.

This function is especially helpful in Page view, where no ruler is displayed.

Note:  You can only set the playhead position when playback is stopped.



	 Chapter  20    View and edit music notation	 619

Add notes and symbols from the Part box

Part box overview
  When Show Advanced Tools is selected in the Advanced preferences pane, you can add 

notes and other symbols from the Part box in the inspector. The Part box contains a complete 
collection of score symbols, arranged in groups. You can control which symbols are displayed in 
the Part box, reorder symbol groups, and open the Part box as a separate, floating window.

The Part box includes the following types of symbols:

•• Notes and rests

•• Key and time signature symbols

•• Clef signs

•• Slurs and crescendo/decrescendo symbols

•• Note heads

•• Accents, bowing marks, fermatas, and other symbols that apply to specific notes

•• Phrasing marks

•• Trills and other ornaments, tremolo symbols

•• Sustain pedal markings

•• Bar lines, repeat signs, and Segno and Coda markings

•• Lyrics and text

•• Chord symbols

•• Chord grids and tablature symbols

•• Page and line break symbols

Open the Part box

	 1	 With the Score Editor open, click the Inspector button  in the control bar.

	 2	 If the Part box is closed, click its disclosure triangle in the inspector to open it.

Open the Part box as a separate window
mm Drag the Part box out by its title bar.

Close the Part box
mm Click the disclosure triangle for the Part box in the inspector.
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View score symbols in the Part box
The Part box displays score symbols arranged in groups. You can show and hide symbol groups 
by selecting or deselecting the group buttons at the top of the Part box, and reorder the groups 
in the Part box. 

  When Additional Score Options is selected in the Advanced preferences pane, you can 
create score symbol sets to display different symbol groups in a particular order.

View Part box symbol groups
mm Click a symbol group’s button at the top of the Part box to view the symbols for that group.

Click a button again to deselect its group. 

The corresponding group appears in the Part box, below other selected symbol groups.

Reorder symbol groups in the Part box
mm Drag a symbol group up or down by the handle on its left side.

Display all symbol groups
mm Click the All button.

View symbol groups in a floating window
	 1	 Drag the Part box out by its title bar.

	 2	 Click the buttons for the symbol groups you want to display.

You can open multiple floating Part box windows, and display different score symbols in each 
one. Selecting a symbol in a floating Part box window updates the selection in all other Part box 
windows, until you deselect the symbol, close the window in which it was selected, or select a 
symbol in another floating Part box window.
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Select score symbols using key commands
Use any of the following key commands to select score symbols or groups in a floating Part box 
window:

mm Next Part Box Symbol

mm Previous Part Box Symbol

mm Next Part Box Group

mm Previous Part Box Group

Choose a score symbol set
mm Click-hold the name of the current score symbol set in the Part box title, then choose a set from 

the Part Box Sets pop-up menu.

Create a new score symbol set
mm Click-hold the name of the current score symbol set in the Part box title, then choose New Set 

from the Part Box Sets pop-up menu.

Rename a score symbol set
	 1	 Click-hold the name of the current score symbol set in the Part box title, then choose Rename 

Set from the Part Box Sets pop-up menu.

	 2	 Enter a new name for the score symbol set.

Delete the current score symbol set
mm Click-hold the name of the current score symbol set in the Part box title, then choose Delete Set 

from the Part Box Sets pop-up menu.

Show the inspector channel strips below the Part box
The inspector channel strips appear below the Part box in the Score inspector. Depending on the 
size of the Score Editor and how many groups appear in the Part box, it may not be visible.

mm Click the disclosure triangle to close the Part box, and, if necessary, other inspectors in the 
Score inspector.
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Select score symbols in the Part box
There are several ways to select score symbols in the Part box. You can select symbols directly by 
clicking, or select them using the button for the Part box group. Some symbols can be selected 
using key commands.

Select a score symbol
	 1	 If the symbol isn’t visible, click the button for the corresponding Part box group at the top of the 

Part box.

	 2	 Click the symbol.

Select note symbols using key commands
mm Use any of the following (unassigned) key commands:

•• Partbox: 1/1 Note

•• Partbox: 1/2 Note

•• Partbox: 1/4 Note

•• Partbox: 1/8 Note

•• Partbox: 1/16 Note

•• Partbox: 1/32 Note

Select triplet and dotted note symbols using key commands
Do any of the following:

mm Press a note selection key command twice to select the corresponding triple note value.

mm Three times selects the dotted note value.

mm Four times returns to the original note value.

Select adjacent symbols or groups using key commands
Use any of the following key commands:

mm To select the object to the left of the currently selected symbol: Use Previous Partbox Symbol.

mm To select the symbol to the right of the currently selected symbol: Use Next Partbox Symbol.

mm To select the group above the currently selected one: Use Previous Partbox Group.

mm To select the group below the currently selected one: Use Next Partbox Group. 

The most recently selected object within each group is retained when switching 
between groups.

Note:  As the group display can be reordered, the current display order of groups determines the 
previous and next group. 
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Add notes and rests from the Part box
In addition to using real-time recording and step input, you can add notes to a score directly 
from the Part box. When you add notes to the score, they are added to the region as MIDI events, 
and sound when you play the project.

Logic Pro automatically displays rests in regions in the Score Editor, based on the current 
Quantize display setting. You can also add rests manually, and change the appearance of rests in 
a score.

Add notes from the Part box
	 1	 If the Notes section of the Part box isn’t visible, click the Notes button in the Part box.

	 2	 Select the note value you want to add, then do one of the following:

•• Drag it to the score at the point where you want to add it.

•• Select the Pencil tool from the Tool menu, then click the point in the score where you want to 
add the note.

A help tag appears while the mouse button is held down to help you place notes in the 
correct position.

Add a rest
	 1	 If the Rests section of the Part box isn’t visible, click the Rests button in the Part box.

	 2	 Drag a rest from the Part box to the place in the score where you want to add it, or use the 
Pencil tool.

Add a multiple bar rest
	 1	 If the Rests section of the Part box isn’t visible, click the Rests button in the Part box.

	 2	 Drag a multiple bar rest from the Part box to the place in the score where you want to add it, or 
use the Pencil tool.

By default, the multiple bar rest fills the number of empty bars until the next note event. You can 
change the length of the multiple bar rest, and also change the type (modern or church).

	 3	 Double-click the multiple bar rest (with the Pointer tool).

	 4	 In the dialog, deselect Auto Length, then enter the number of bars you want the rest to show.

	 5	 To change the type of multiple bar rest, select one of the Type buttons in the dialog.
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Add key and time signature changes
The Score Editor displays the key signature and time signature for the project, as well as any key 
or time signature changes you make using the Signature track or Signature List. You can change 
the key and time signature, and add key and time signature changes in the Score Editor. Key and 
time signatures are global events that affect all tracks in your project.

In order to select and copy signatures, the Signature track must be visible, and must not 
be protected.

Key signature changes
Key signature changes (you make in the Score Editor) affect only the display of notes in the Score 
Editor—they have no effect on MIDI playback. Changing the initial key signature for a project, 
however, does affect the playback of Apple Loops.

You can add any number of key signature changes to a project. When you add a key signature 
change, the new key signature changes the key from the insertion point forward, until the next 
key signature change is reached (if one exists).

You can store up to nine signature alternatives, which are reflected in the Signature track, 
Signature List, and Signature window.

Key signatures inserted in the Score Editor (or global Signature track or Signature List) affect all 
instruments on all display levels. This is reflected both visually and in MIDI playback.

The display of key signatures and key signature changes depends on:

•• The Score project settings in the Clefs & Signatures pane (see Clefs & Signatures settings).

•• The Key parameter in the Staff Style window (see Staff Style window).

Time signature changes
The time signature determines the number of beats in a bar, so changing the time signature 
affects how barlines appear in the score. Functions that depend on the chosen time signature 
and bar positions (such as MIDI metronome click or Transform window functions) are affected if 
bar positions are used to restrict a function to a certain part of the project.

Add a key signature change in the Score Editor
	 1	 If the Key Signatures section of the Part box isn’t visible, click the Key Signature button in the 

Part box.

	 2	 Drag a key signature from the Part box to the place in the score where you want to add it, or use 
the Pencil tool.

Change the key signature in Linear view
mm Click the key signature, then choose a new key signature in the Key Signature dialog.

Change the key signature in Wrapped view and Page view
	 1	 Control-click the key signature.

If there is no visible key signature (key of C/A minor), Control-click between the clef and the 
time signature.

	 2	 Choose Edit Key Signature from the shortcut menu.

	 3	 Choose a value from the Key pop-up menu.

	 4	 Click either the Major or Minor button, then click OK.
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Add a time signature change in the Score Editor
	 1	 If the Time Signatures section of the Part box isn’t visible, click the Time Signature button in the 

Part box.

	 2	 Do one of the following:

•• Drag one of the defined time signatures from the Part box to the place in the score where you 
want to add it.

•• Drag one of the undefined time signature symbols (A/B or A+B/C) to the place in the score 
where you want to add it, then, in the Time Signature dialog, enter the numbers for the 
Number of Beats and Note Value in their respective fields.

Change the time signature in Linear view
mm Click the time signature, then change the time signature in the Time Signature dialog.

Change the time signature in Wrapped view and Page view
	 1	 Control-click the time signature.

	 2	 Choose Edit Time Signature from the shortcut menu.

	 3	 Enter a value for the Number of Beats, choose a value from the Note Value pop-up menu, then 
click OK.

Detailed information about key and time signatures can be found in Time and key 
signatures overview.



	 Chapter  20    View and edit music notation	 626

Change the clef sign
Each staff style has a default clef sign. In general, you should choose a staff style with the clef you 
want the part or staff to use for most of the score. For information about choosing staff styles, see 
Work with staff styles.

You can add clef changes to the score to improve readibility; for example, when the notes of an 
instrument normally written in one clef move into a different range that would require many 
ledger lines in the original clef. 

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add a clef sign from the Part box
	 1	 If the Clefs section of the Part box isn’t visible, click the Clefs button in the Part box.

	 2	 Drag a clef sign from the Part box to the place in the part or score where you want to add it.

Change the clef sign in Wrapped view or Page view
	 1	 Control-click the clef sign.

	 2	 Choose Select Clef from the shortcut menu.

	 3	 Click the clef sign, then click OK (or double-click the clef sign).

Change the size of secondary clefs
	 1	 Open the Clefs and Signatures project settings by doing one of the following:

•• Choose Layout > Clefs and Signatures (or use the Settings: Clefs and Signatures key 
command).

•• Choose File > Project Settings > Score (or use the corresponding key command), then click the 
Clefs and Signatures tab.

	 2	 Choose a value in the Smaller Clef Changes pop-up menu.

All clefs, except the first one in every staff, will be reduced in size, depending on the value chosen 
here. This happens regardless of whether the clef changes are the result of a different staff style 
in the same staff, or clefs inserted from the Part box.
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Add dynamic marks, slurs, and crescendi
Dynamic marks indicate the dynamic level at which a performer should play a musical phrase 
or section. You can add dynamic marks such as p (piano), ff (fortissimo), and sfz (sforzando). 
Dynamic marks are visual symbols only, and don’t affect the volume of notes during playback.

You can add slurs to indicate notes that should be played legato, and add dynamic crescendo 
and descrendo symbols (sometimes called hairpins). After adding these symbols, you can adjust 
their length to indicate which notes they apply to. These symbols are visual symbols only, and 
have no effect on playback.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add a dynamic symbol
	 1	 If the Dynamics section of the Part box isn’t visible, click the Dynamics button in the Part box.

	 2	 Drag a dynamic symbol from the Part box to the place in the score where you want to add it.

Add a slur 
	 1	 If the Slurs and Crescendi section of the Part box isn’t visible, click the Slurs and Crescendi button 

in the Part box.

	 2	 Drag a slur from the Part box to the place in the score where you want it to start (the left edge).

The slur remains selected, and small black square handles appear along its length.

	 3	 Drag the handles to reshape the slur.

Add a crescendo (or decrescendo) 
	 1	 If the Slurs and Crescendi section of the Part box isn’t visible, click the Slurs and Crescendi button 

in the Part box.

	 2	 Drag a crescendo from the Part box to the place in the score where you want it to start (the left 
edge).

The crescendo remains selected, and small black square handles appear at its end points.

	 3	 Drag the handles to extend the crescendo to the place where you want it to end (the right 
edge).
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Change the appearance of note heads
Logic Pro offers a wide variety of note heads for percussion notation, harmonics, and other uses. 
You can change note heads by dragging a note head from the Part box into the score. Note 
heads are visual symbols only and have no effect on project playback.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Change a note head
	 1	 If the Note Heads section of the Part box isn’t visible, click the Note Heads button in the Part box.

	 2	 Do one of the following:

•• To change a single note head: Drag a note head from the Part box onto the note.

•• To change multiple note heads: Select multiple notes, then drag a note head from the Part box 
onto the selected notes.

•• To return altered notes to a standard note head: Select the notes, then drag the black, round 
note head from the Part box onto the altered notes.

•• To make a note head invisible in the printed score: Drag the gray note head onto the note.

The note is displayed with a gray note head onscreen, allowing further edits. Nothing but the 
stem is visible in the printout. You can combine this feature with the Note Attributes > Stem > 
Hide command to completely hide these notes in the printed score.

You can also change the appearance of note heads from the Attributes submenu of the local 
Functions menu.

Add accents and other symbols to notes
The Part box includes symbols such as accents, fermatas, phrasing marks, bow markings, and 
others that apply to a single note, over which the symbol appears. (Trills are in a separate 
section).

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add an accent or other symbol to a note
	 1	 If the Accents section of the Part box isn’t visible, click the Accents button in the Part box.

	 2	 Do one of the following:

•• To add a symbol to a single note: Drag a symbol from the Part box onto the note.

•• To add symbols to multiple notes: Select multiple notes, then drag a symbol from the Part box 
onto the selected notes.
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Add trills, ornaments, and tremolo symbols
The Part box includes symbols for trills and other ornaments, arpeggios, and tremolo playing. 
These symbols can be placed anywhere in a score and are not attached to specific notes. This 
Part box group also contains accidental symbols that are mainly intended to be used with the 
trill symbols. These accidentals are purely visual, and do not affect the MIDI playback of notes.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add a trill or tremolo symbol
	 1	 If the Trills section of the Part box isn’t visible, click the Trills button in the Part box.

	 2	 Drag a symbol from the Part box to the position in the score where you want to add it.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add sustain pedal markings
Piano parts can display sustain pedal down and up markings in the Score Editor. When you open 
a MIDI region with Sustain data (MIDI controller #64, sustain pedal on and off) in the Score Editor, 
the Sustain data appears as pedal markings. Adding pedal markings to the score makes the 
affected notes sustain (that is, the MIDI playback is affected). These pedal markings are the only 
score symbols apart from notes that directly represent MIDI events.

Logic Pro intelligently inserts the on (pedal down) or off (pedal up) version of the symbol, 
depending on the last preceding pedal symbol on the staff (a sustain off always follows a sustain 
on, and vice versa).

Add pedal symbols from the Insert pop-up menu
mm Choose Ped from the Insert pop-up menu in the Score Editor inspector, then Command-click at 

the point where you want to add the pedal down symbol, and drag to the point where you want 
to add the pedal up symbol.

Add sustain pedal symbols from the Part box
	 1	 If the Pedal section of the Part box isn’t visible, click the Pedal button in the Part box.

	 2	 Drag a pedal symbol from the Part box to the place in the score where you want to add it.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.
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Add chord symbols
You can quickly add chord symbols to a score. Chord symbols include the root note and chord 
quality, and can also include extensions (added notes) and a non-root bass note (sometimes 
called a slash chord, because the bass note is indicated by a diagonal slash).

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add a chord symbol
	 1	 If the Chord section of the Part box isn’t visible, click the Chord button in the Part box.

	 2	 Do one of the following:

•• Drag the chord symbol from the Part box to the position in the score where you want to 
add it.

•• Select the chord symbol in the Part box, then click a position in the score with the Text tool.

•• Select any text symbol in the Part box, then Option-click a position in the score with the 
Text tool.

Note: Watch the help tag to make sure you insert chord symbols at the correct bar position.

	 3	 Enter the text for the chord symbol:

•• Enter the root note and the chord quality, then any extensions.

•• To add a bass note, type a slash, then the bass note.

•• After you enter a number, everything following it is placed in the upper extension line. If 
you write “G7(b9/b13),” the whole “7(b9/b13)” is placed in the upper line, and the lower line 
remains blank.

•• If you enter letters before a number (FMAJ7/9, for example), the letters appear in the lower 
line, and everything following the first number, in the upper line.

•• You can override the automatic placement by entering a comma: everything before the 
comma is placed in the lower line, and everything after it, in the upper line. Only one comma 
can be used. 

•• You can type a space to create additional horizontal space between the root and 
the extension.

•• While the chord symbol is selected in the score, you can reposition it by dragging horizontally 
or vertically.

	 4	 To enter another chord symbol, press Tab, then repeat steps 1 through 3. The insertion point 
moves to the position of the next (displayed) note or rest. Enter the desired chord and repeat the 
process to add chord symbols to the score.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.
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Add chord grids and tablature symbols
  When Additional Score Options is selected in the Advanced preferences pane, you can 

create and edit chord grids. For information about creating and editing chord grids, see Chord 
grids overview.

Logic Pro includes a large library of chord grids, using both standard tuning and a variety of 
alternative tunings. The Part box also features a variety of tablature symbols that you can add to 
your score, including ties, slides, bends, hammer-ons and pull-offs, and tab and slide markings.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add a chord grid
	 1	 If the Chord & Tablature section of the Part box isn’t visible, click the Chord button in the 

Part box.

	 2	 Do one of the following:

•• Drag a chord grid symbol from the Part box into the score.

•• Choose a chord grid symbol in the Part box, then click a position in the score with the 
Pencil tool.

The Chord Grid Selector pane of the Chord Grid Library opens.

	 3	 Select the chord grid you want to add, then click OK.

While the chord grid is selected in the score, you can reposition it by dragging horizontally 
or vertically.

Add a tablature symbol
	 1	 If the Chord & Tablature section of the Part box isn’t visible, click the Chord button in the 

Part box.

	 2	 Do one of the following:

•• Drag a symbol from the Part box into the score.

•• Choose a symbol in the Part box, then click a position in the score with the Pencil tool.

You can also display regions as tablature using the appropriate staff style. For information about 
choosing staff styles, see Staff styles overview.
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Add bar lines, repeat signs, and coda signs
You can add bar lines, repeat signs, coda signs, and other symbols at the beginning or end of 
a bar, or at any visible bar position (where a note or rest is displayed). These symbols are only 
visual, and have no effect on MIDI playback.

These are global symbols that are displayed in all staffs, at all display levels. When added to a 
score, bar lines and repeat signs (except for first and second ending signs) replace the regular 
bar line.

The one- or two-bar repeat symbols replace all notes and rests in the corresponding bars; all 
other symbols remain visible. Hidden notes can still be heard, so MIDI playback is not affected. 
These signs can be moved only in the Event List or Event Float window.

When a double repeat sign is positioned at a line break, it is automatically displayed as two back-
to-back repeat signs, one at the end of the line, and one at the beginning of the next line.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add a bar line, repeat sign, or coda sign
	 1	 If the Bars and Repeats section of the Part box isn’t visible, click the Bars and Repeats button in 

the Part box.

	 2	 Drag a symbol from the Part box to the place in the score where you want to add it.

Delete an added bar line or repeat sign
mm Click the symbol with the Eraser tool.

Add a first or second ending symbol
	 1	 Drag the symbol from the Part box to the place in the score where you want to add it.

After you add a repeat ending symbol, you can edit the ending number. The default text is “1.” 
and “2.” To accept the defaults, press Return. Alternatively, enter any text into these brackets. The 
bracket that defaults to “2.” is open—without a vertical end line, like the “1.” ending.

	 2	 If necessary, move the symbol to the correct position by dragging its upper-left corner.

	 3	 Adjust the length of the symbol by dragging its right end.

	 4	 You can delete a repeat ending by selecting it, then pressing the Delete key.

First and second endings are only displayed on staffs with bar lines that aren’t connected to the 
staff above. The Alternate Repeat Symbols (for the whole project) option in File > Project Settings 
> Score > Global activates a real book–style display of repeat signs.
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Add page and line break symbols
You can add page and line break symbols (and No Page Break and No Line Break events) from 
the Part box. Once added to the score, they cannot be moved automatically (when you alter the 
Layout project settings, resize the window, and so on).

You can overrule the Page Break, Line Break, No Page Break, and No Line Break events with the 
Layout tool.

Line breaks and individual staff margins can be determined for each score set, and also for each 
of the extracted parts. For more information, see Line and page breaks.

The Part box is available when Show Advanced Tools is selected in Logic Pro 
Advanced preferences.

Add a line break symbol
mm Drag a Line Break symbol from the Part box to the score.

Add a page break symbol
mm Drag a Page Break symbol from the Part box to the score.

Add a line or page break using the shortcut menu
	 1	 Control-click a bar line.

	 2	 Choose a line or page break setting from the shortcut menu.
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Edit notes in the Score Editor

Select notes in the Score Editor
Before you can perform some edits to notes in the Score Editor, you need to select them.

Select a note
Do one of the following:

mm Click the note head.

mm Select multiple notes by Shift-clicking or by dragging around the notes to enclose them.

Select all notes
mm Choose Edit > Select All (or press Command-A).

All visible notes are selected.

Select all notes following the currently selected note
mm Choose Edit > Select All Following.

Select all following notes of the same pitch as the currently selected note
mm Choose Edit > Select All Following of Same Pitch.

Move and copy notes in the Score Editor
You can move notes in the Score Editor to change the position in time where they start to 
play back.

Move notes in the Score Editor
mm  Select one or more notes, then drag left or right.

Copy notes in the Score Editor
mm Option-drag the note head to a new position.

mm Select one or more notes, then choose Edit > Copy (or press Command-C).

When you choose Edit > Paste (or press Command-V), the note is pasted at the 
playhead position.
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Change a note’s pitch, duration, and velocity
You can change the pitch and duration (length) of selected notes in the Score Editor, as well as 
their MIDI velocity. The Velocity value signifies how hard the key was struck when the note was 
recorded. It often corresponds to the volume of the note when played back, but can control 
other parameters as well.

Change a note’s pitch
mm Select one or more notes, then do one of the following:

•• Drag the notes up or down.

•• Edit the Pitch value in the Event inspector.

•• Use the Event Transpose +1 or the Event Transpose –1 key command.

Change a note’s length
mm Select one or more notes, then do one of the following:

•• Edit the Length parameter in the Event inspector (shown as bars, beats, and ticks).

•• Use one of the Nudge Region/Event Length key commands. 

•• Drag the right edge of the duration bar for the note horizontally to shorten or lengthen 
the note.

You can show duration bars for selected notes or for all notes by choosing the corresponding 
menu item in the Score Editor’s View > Duration Bars submenu.

Change a note’s velocity
Do one of the following:

mm Select a note, then hold down Command while dragging up or down.

mm Select one or more notes, then edit the Velocity setting in the Event inspector.

mm Select one or more notes with the Velocity tool, then move the pointer up or down.

mm In Linear view, select one or more notes, then drag the Velocity slider in the Score Editor 
inspector left or right.

The Velocity value appears in a help tag as you edit it. You can also hear the change, if the MIDI 
Out button  is activated.
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Quantize the timing of notes in the Score Editor
You can quantize, or automatically correct, the timing of individual MIDI notes in the Score Editor. 
This is useful when regions in the track contain the right notes, but are not perfectly in time 
with the project. When you quantize the timing, items are adjusted to the selected note value. 
You can quantize the timing of regions with drums, single-note instruments, and chordal or 
polyphonic instruments.

The Time Quantize controls quantize notes and other items nondestructively, for playback only. 
The original timing is never lost, and can be recalled by setting the value to off. 

Time quantization in the Score Editor works in the same way as time quantization in the Piano 
Roll Editor. In the Score Editor, you can also visually quantize the display of notes (independent of 
their MIDI time quantization) in the Region inspector. For information about visual quantization, 
see Quantize.

Quantize the timing of MIDI notes in the Score Editor
	 1	 In the Score Editor, select the notes you want to quantize.

	 2	 From the Time Quantize pop-up menu, choose the note value you want to use to quantize the 
timing of the selected items.

	 3	 To set the degree of quantization, drag the Strength slider left or right.

	 4	 To set the degree of swing, drag the Swing slider left or right.
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Edit attributes of individual notes

Note attributes overview
You can control the appearance of individual notes in the Score Editor using note attributes. Note 
attributes include note size and position, accidentals, stems, beaming, and interpretation. Using 
note attributes, you can enhance the readability of the score and add performance information.

There are three ways to change note attributes: in the Note Attributes window, using the 
Functions > Attributes submenu, or using key commands. You can change attributes for a group 
of selected notes in the Attributes submenu (and with corresponding key commands), but can 
change attributes for only one note in the Note Attributes window. You can also change some 
note attributes via the Part box, and with tools.

  When Additional Score Options is selected in the Advanced preferences pane, additional 
note attributes, including accidental type, note heads, stem position, and syncopation are 
available in the Note Attributes dialog and the Note Attributes shortcut menu.

Change note attributes
Do one of the following:

mm Select one or more notes, then choose an option from the Score Editor’s Functions > 
Attributes submenu.

mm Control-click a note head, choose Attributes from the shortcut menu, then choose the specific 
attribute from the submenu.

mm Double-click a note head to open the Note Attributes window. 

To open the Note Attributes window by double-clicking, make sure the Note Attributes setting 
is chosen in the “Double-click note to open” pop-up menu of the Logic Pro > Preferences > 
Score window.
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Change note heads

  When Additional Score Options is selected in the Advanced preferences pane, you can 
choose note heads to use for a variety of specific situations, such as percussion parts, harmonics, 
tremolo, and for other special conditions.

Change note head attributes
Do one of the following:

mm Drag a note head from the Part box to the note you want to change.

mm Double-click a note, then choose a note head from the Note Head pop-up menu in the Note 
Attributes window.

For more information about dragging note heads from the Part box, see Change the appearance 
of note heads.

Change the size and horizontal position of notes
The default note size is set with the Size parameter in the Staff Style window. You can change the 
size of individual notes, and also change their horizontal position in the score.

Change a note’s size
Do one of the following:

mm Drag the note upward (increase) or downward (decrease) with the Resize tool.

mm Double-click a note, then choose a size from the Size pop-up menu in the Note 
Attributes window.

Change a note’s horizontal position
Do one of the following:

mm Drag the note horizontally with the Layout tool.

mm Double-click a note, then choose a value from the Horizontal Position pop-up menu in the Note 
Attributes window.
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Change the display and position of accidentals
By default, the display of accidentals depends on the chosen key signature. Using note attributes, 
you can change flats to sharps, and vice versa. For information about setting the key signature, 
see Add key and time signature changes.

  When Additional Score Options is selected in the Advanced preferences pane, additional 
options for changing note accidentals become available.

The Accidental Position attribute defines the deviation from the Acc./Note Distance value, chosen 
in Logic Pro > Project Settings > Score > Layout.

Change the display of accidentals
Do one of the following:

mm In the Note Attributes window, choose a value from the Enharmonic Shift or Accidental Type 
pop-up menu (see list of settings below).

mm Choose Functions > Note Attributes > Accidentals from the Score Editor menu bar, then choose 
one of the following display options:

•• Default Accidental: The display of accidentals depends on the chosen key signature. 

•• Enharmonic Shift#: Converts G flat to F sharp, or F to E sharp, for example.

•• Enharmonic Shiftb: Converts D sharp to E flat, or B to C flat, for example.

•• Flats To Sharps: Similar to Enharmonic Shift #, but leaves notes without flats unaltered (useful 
for multiple selection).

•• Sharps To Flats: Similar to Enharmonic Shift b, but leaves notes without sharps unaltered (useful 
for multiple selection).

•• Force Accidental: Forces the display of accidentals (and naturals).

•• Hide Accidental: Displays the note without accidentals (MIDI playback is not affected).

•• Guide Accidental: Forces the display of the accidentals (and naturals) in parentheses.

mm Control-click a note head, choose Attributes > Accidentals from the shortcut menu, then choose 
an option from the submenu.

mm Use one of the following key commands:

•• Default Accidentals

•• Enharmonic Shift: #

•• Enharmonic Shift: b

•• Flats To Sharps

•• Sharps To Flats

•• Force Accidental

•• Hide Accidental

•• Guide Accidental

Change the distance between the accidental and the note
mm Double-click a note, then choose a value from the Accidental Position pop-up menu in the Note 

Attributes window.
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Change stem direction, length, and beaming
By default, a note’s stem direction and length depend on the setting in the Staff Style window. 
You can change these attributes to improve readibility; for example, to group notes meant to be 
played as a voice in a polyphonic passage.

The beaming of notes depends on the chosen time signature, the Beat Grouping setting in the 
Time Signature dialog, and the staff style’s Beam parameter. You can change the beaming of 
individual notes to improve readibility by clarifying the rhythmic structure or phrasing of notes.

  When Additional Score Options is selected in the Advanced preferences pane, additional 
options for changing note attributes become available.

Change a note’s stem direction and length
Do one of the following:

mm Double-click a note, then choose a value from the Stem Direction pop-up menu in the Note 
Attributes window.

Note:  The stem length cannot be changed in the Note Attributes window.

mm Choose Functions > Note Attributes > Stems from the Score Editor menu bar, then choose one of 
the following options:

•• Default: The stem direction is set in accordance with the default (staff style) setting.

•• Up: Forces the note’s stem upward.

•• Down: Forces the note’s stem downward. 

•• Hide: Hides a note’s stem, and the corresponding beam or flag.

•• Stem Position: Default: Uses the default setting.

•• Stem Position: Center: Moves the stem to the center.

•• Stem Position: Side: Moves the stem to the side.

•• Stem Position: Automatic: Moves the stem to the side.

•• Stem End: Default Length: Uses the default setting.

•• Stem End: Move Up: Moves the stem end upward. Depending on the direction, this shortens or 
lengthens the stem.

•• Stem End: Move Down: As above, but moves the stem end downward.

mm Control-click a note head, choose Attributes > Stems from the shortcut menu, then choose an 
option from the submenu.

mm Use one of the following key commands:

•• Stems: Default

•• Stems: Up

•• Stems: Down

•• Stems: Hide

•• Stem End: Default Length

•• Stem End: Move Up

•• Stem End: Move Down
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Change the beaming of selected notes
Do one of the following:

mm Choose Functions > Note Attributes > Beaming from the Score Editor menu bar, then choose 
one of the following:

•• Beam Selected Notes: Forces a beam to the following note.

•• Unbeam Selected Notes: Interrupts the beam to the following note.

•• Default Beams: Uses the default setting.

mm Control-click a note head, choose Attributes > Beaming from the shortcut menu, then choose an 
option from the submenu.

mm Use one of the following key commands:

•• Beam Selected Notes

•• Unbeam Selected Notes

•• Default Beams

Change the voice or staff assignment

  When Additional Score Options is selected in the Advanced preferences pane, you 
can change the voice or staff assignment of selected notes for cross staff beaming. For more 
information about cross staff beaming, see Beam notes across staffs.

Change the voice or staff assignment for selected notes
Do one of the following:

mm Choose one of the following from the Score Editor’s Functions > Note Attributes > Ties submenu:

•• Default Staff: Moves the selected notes to the appropriate staff according to their 
voice assignment.

•• Staff Above Voice: Moves the selected notes to the staff above the assigned voice.

•• Staff Below Voice: Moves the selected notes to the staff below the assigned voice.

mm Control-click a note head, choose Attributes > Voice/Staff Assignment from the shortcut menu, 
then choose an option from the submenu.

Change the direction of ties
By default, the tie direction is set as part of the staff style for the track (or region). You can 
manually change the direction of ties for individual notes to improve readability.

Change a note’s tie direction
Do one of the following:

mm Choose a setting from the Score Editor’s Functions > Note Attributes > Ties submenu.

mm Double-click a note, then choose a tie direction from the Tie Direction pop-up menu in the Note 
Attributes window.

mm Control-click a note head, choose Attributes > Ties from the shortcut menu, then choose an 
option from the submenu.

mm Use one of the following key commands:

•• Ties: default

•• Ties: up

•• Ties: down
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Change the syncopation or interpretation of notes
By default, note syncopation and interpretation match the settings chosen in the Region 
inspector. You can change interpretation settings for individual notes to improve readability. 

  When Additional Score Options is selected in the Advanced preferences pane, you can 
change syncopation settings for individual notes.

Change a note’s Syncopation setting
Do one of the following:

mm Choose a setting from the Score Editor’s Functions > Note Attributes > Syncopation submenu.

mm Double-click a note, then choose a setting from the Syncopation pop-up menu in the Note 
Attributes window.

mm Control-click a note head, choose Attributes > Syncopation from the shortcut menu, then choose 
an option from the submenu.

mm Use one of the following key commands:

•• Default Syncopation 

•• Force Syncopation

•• Defeat Syncopation

Change a note’s Interpretation setting
Do one of the following:

mm Choose a setting from the Score Editor’s Note Attributes > Interpretation submenu.

mm Double-click a note, then choose a setting from the Interpretation pop-up menu in the Note 
Attributes window.

mm Control-click a note head, choose Attributes > Interpretation from the shortcut menu, then 
choose an entry from the submenu.

mm Use one of the following key commands:

•• Default Interpretation

•• Force Interpretation

•• Defeat Interpretation
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Change the independent status of notes

  When Additional Score Options is selected in the Advanced preferences pane, you can 
display notes in the score as independent notes and edit their independent status. 

Independent notes are not tied to a rhythmic position in the staff, and can be moved freely. This 
can be used to add grace notes, for example, and for other purposes.

Change the independent status of a note
Do one of the following:

mm Choose Functions > Note Attributes > Independent from the Score Editor menu bar, then choose 
one of the following settings:

•• Independent Grace: The note is displayed as a single (independent) grace note.
•• Independent: The note is displayed independent of the rhythmic context.
•• Not Independent: The note is displayed in the regular rhythmic context.

mm Control-click a note head, choose Attributes > Independent from the shortcut menu, then 
choose an option from the submenu.

mm Use one of the following key commands:

•• Not Independent
•• Independent
•• Independent Grace

Change the color of notes

  When Additional Score Options is selected in the Advanced preferences pane, you can 
assign different colors to individual notes, using the available colors in the three color palettes.

Assign a color to a note
Do one of the folllowing:

mm Select the note, then choose Functions > Note Attributes > Colors from the Score Editor menu 
bar, and choose a color.

mm Control-click a note head, choose Attributes > Colors from the shortcut menu, then choose an 
option from the submenu.

You can also turn on the Velocity or Pitch Color mode in the Colors submenu. Pitch colors 
can be diatonically or chromatically mapped. Note that velocity colors match particular MIDI 
velocity ranges.

You can edit the 16 color options of the Score Editor’s Functions > Attributes submenu, the 
velocity colors, and the pitch colors in Logic Pro > Project Settings > Score > Color. For more 
information, see Score settings on page 894.

Note:  As note attributes, these settings have priority over the staff style settings, but they only 
apply if the Color mode is set to Normal in the Score Editor’s View > Colors submenu.

Reset note attributes
You can reset all note attributes to their default settings if you decide you don’t want to keep 
your changes. When resetting note attributes, be aware that all symbols directly attached to 
notes (accents, fermatas, jazz symbols, and so on) are deleted. 

Reset note attribute settings
mm Choose the Score Editor’s Functions > Note Attributes > Reset All Attributes option (or use the 

Reset Note Attributes key command).

mm Control-click a note head, then choose Attributes > Reset All Attributes from the shortcut menu.
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Restrict note input to a diatonic key
If you’re working in a diatonic key (major, minor, or modal), using the Diatonic Input feature can 
help you quickly add notes. This feature restricts note input to the notes of the current key.)

Turn on Diatonic Input
mm Choose Edit > Diatonic Insert from the Score Editor menu bar.

Notes can be altered chromatically, after they have been inserted.

Note:  If you protect (lock) your screensets, this function’s setting is also locked.

Control the appearance of tied notes
Ties display the underlying rhythmic divisions of notes held over several beats, for easier 
readability. Notes connected with a tie represent a single MIDI note event.

Ties are displayed automatically according to the length of the MIDI note and the rhythmic 
divisions of the score (time signature). If you don’t like the way a tied note is displayed, you can 
change the display by inserting a user rest at the position you want to see a graphic note. You 
can’t add ties to notes manually. 

Create tied notes
	 1	 Insert a note with a value shorter than the one you want it to have.

	 2	 Do one of the following:

•• Change the note length in the Event inspector, the Event List, or the Event Float window.

•• Use the note’s duration bar to graphically edit the note length.

Tip:  For information about using duration bars, see Display duration bars on page 713 and 
Change the length of duration bars on page 713.

Change the display of tied notes with a user rest
mm Insert a short rest following the tied note. 

The length of the rest is not important, but you should use a shorter one (an eighth note rest), if 
possible. Watch the help tag for exact positioning. After the rest is inserted, it’s no longer visible 
in the score display, but the note display changes accordingly. 

Note:  If you want to delete or change the position of an invisible user rest, use the Event List.

Change the direction of a tie
mm Choose a setting from the Score Editor’s Functions > Note Attributes > Ties submenu.
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Create and edit tuplets
You can add and edit tuplets—groups of notes evenly divided over a specific rhythmic value—in 
the Score Editor. The most common tuplet is the triplet (a group of three notes that typically 
occupies the space of two or four notes). 

The symbol for tuplets is grouped together with the symbols for triplets in the Notes group in 
the Part box. 

N-tuplet symbol

In some cases, you need to choose an appropriate display Quantize value in the Region 
inspector. See Quantize on page 678.) You use the N-tuplet object for the display of other tuplets.

Change how a tuplet is displayed
	 1	 Drag the N-tuplet symbol from the Part box onto the first note. 

The target note must be indicated in the help tag before you release the mouse button. The 
Tuplet window opens.

Set the appropriate parameters in the Tuplet window:

•• Tuplet number of notes: Set the number of tuplet notes in the upper-left field.

•• Tuplet time value: Set the time value in which the tuplets occur in the upper-right 
numerical field.

•• Tuplet note value: Choose the note value of the tuplets (1/8, 1/16, 1/32, and so on) from the 
pop-up menu.

•• Hide bracket: Select to hide the bracket over the tuplets.

•• Hide numbers: When selected, the tuplet number will not be printed. It will be displayed in 
parentheses, to allow further edits to the N-tuplet.

•• Show note value: Select to have the N-tuplet display also contain the note value (the lower 
number).



	 Chapter  20    View and edit music notation	 646

•• Direction: Choose the direction of the bracket and number, or choose Auto to have the tuplet 
use the staff style for the track or region.

•• Allow double values: When selected, N-tuplets can contain note values that are twice as long as 
the regular tuplet value. 

•• Allow half values: When selected, N-tuplets can contain note values that are half the length of 
the regular tuplet value. 

Tip:  Most parameter changes in the Tuplet dialog are reflected in the graphic at the top of 
the dialog.

	 2	 Click OK.

In the score, the above example would look like this:

Insert tuplets with the pointer
	 1	 Insert the first note where you want it to appear in the score.

	 2	 Drag the N-tuplet symbol onto it. 

If you hold down Option as you insert the N-tuplet symbol, the most recently inserted N-tuplet 
settings are used, without the dialog opening.

	 3	 Define the settings in the Tuplet window.

The display initially shows a series of rests, the number of which corresponds to the N-tuplet 
value. You can insert other notes at these rest positions. To do so, select a note value that 
approximately matches the length of the desired N-tuplet notes.

The method described above also allows you to create N-tuplets that contain rests or syncopated 
note values (double length).

Tip:  If you want an N-tuplet to begin with a rest, you first need to insert a user rest from the Part 
box, then drag the N-tuplet symbol onto the rest. Automatically displayed rests cannot function 
as starting points for N-tuplets.

Make tuplets play with legato phrasing
	 1	 Select the tuplet (or other) notes.

	 2	 Choose Functions > Note Events > Note Force Legato (selected/any) from the Score Editor menu 
bar, or use the corresponding key command.

Edit tuplets
mm Double-click the N-tuplet number, then define settings in the Tuplet window. 

Delete a tuplet
Do one of the following:

mm Click the tuplet number with the Eraser tool.

mm Double-click the N-tuplet number, then click the Delete button in the Tuplet window. 
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Use tuplets to override display quantization
You can override the display quantization value by using hidden tuplets. For example, if you want 
to display a single 32nd–note run in a MIDI region that otherwise contains eighth notes or longer 
values, you can set the Quantize value in the Region inspector to 1/8, and then drag the N-tuplet 
symbol onto the first note of the 32nd figure. In the Tuplet dialog, use the 8:8/32 setting, with 
“Hide brackets” and “Hide numbers” selected. The number (8) appears onscreen, but not when 
you print the score.

Although this is not the normal use of tuplets, it’s a handy way to force the display of runs of 
shorter note values with a display Quantize value set for longer note values.

Add grace notes and independent notes
  When Additional Score Options is selected in the Advanced preferences pane, you can add 

grace notes and other independent notes to a score. Independent notes are notes that aren’t 
included in the automatic rhythmic (and graphic) display calculation of a measure, but are still 
played back via MIDI.

Independent note

Independent grace note

•• Independent: Displayed at their original length, as long as they are binary or dotted note 
values that can be displayed as a single (not tied) note. After insertion, you can change the 
stem direction, enharmonic interpretation, accidental distance, and note head, using the Note 
Attributes functions. For more information, see Note attributes overview on page 637.

•• Independent grace: Always displayed as miniature eighth notes, with a slash across the stem, 
and a tie. The tie direction, stem direction, enharmonic interpretation, accidental distance, and 
note head can be changed.

Both types of independent notes appear only as single notes, without beams.

Convert notes to independent notes
mm Select the notes, then choose Functions > Note Attributes > Independent > Independent from 

the Score Editor menu bar, or use the corresponding key command. 

Choose Functions > Note Attributes > Independent > Not Independent to convert independent 
notes back to regular notes.

Convert notes to grace notes
mm Select the notes, then choose Functions > Note Attributes > Independent > Independent Grace 

from the Score Editor menu bar, or use the corresponding key command. 

Choose Functions > Note Attributes > Independent > Not Independent to convert independent 
notes back to regular notes.
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Insert an independent note directly
mm Hold down Option while selecting a note in the Part box, then drag it to the desired position.

Grace notes cannot be inserted directly. They need to be created by converting regular or 
independent notes.

Important:  In most situations, you will need to create additional space between the grace note 
and the note it’s associated with. The best way to do this is with the Layout tool, which can 
be used to move the main note away from the grace note. For information, see Position items 
graphically in the Score Editor on page 612.

Tip:  If you want to create beamed grace notes, try using a polyphonic staff style with no rests 
displayed for the second voice. Assign the grace notes to the second voice, and resize them with 
the Resize tool. See Add and delete staffs or voices on page 691 for more information on staff 
styles. 

Delete notes in the Score Editor
You can delete notes and other items displayed in the Score Editor. Events such as MIDI 
controller events or pitch bend data are not deleted, even if you delete the notes the events 
were recorded with.

Delete a note or other item in the Score Editor
Do one of the following:

mm Select the item, then choose Edit > Delete (or press the Delete key). 

mm Click the item with the Eraser tool.

Repeat signs and special bar lines cannot be selected, and can only be deleted with the 
Eraser tool.
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Add lyrics and text

Lyrics and text overview
When you’re scoring a song for solo voice or for a vocal ensemble, you can add lyrics, which 
are automatically aligned to notes in the score. Other types of text, such as dynamics and other 
performance indications, can also be added to the score. You can add and edit text in the Score 
Editor, and precisely control the position of text in the score.

The Score Editor includes automatic text for song name, date, and other information; you can 
also add global text that appears in both the full score and in each individual part.

Add lyrics
You can add lyrics aligned to notes in the score using the lyric object in the Part box, which 
also lets you add lyrics for multiple verses. After adding lyrics, you can adjust their vertical and 
horizontal position for better readability.

If you’re working with multiple staffs, be careful to add lyrics to the correct MIDI region. It’s 
recommended that you insert lyrics in Linear Score view and single MIDI region display mode—
especially when inserting more than one verse. Linear Score view also makes it easier to select 
several lyric objects by dragging, to change their positions, for example.

Add lyrics to a score
	 1	 Do one of the following:

•• Drag the lyric object below the first note of the melody.

•• Select the lyric object in the Part box, then click the position of the first note with the Text tool.

Note:  Watch the help tag. Each lyric object must be at the same bar position as the note it 
belongs to (taking display quantization into account).

	 2	 Enter the text for the first note, then press Tab (not Return) to automatically move the insertion 
point to the next note.

If a note is displayed as several tied notes, press Shift-Tab to move the insertion point to the next 
tied note. This method allows you to write several syllables below one longer note, and lets you 
enter all lyrics in one operation, although each syllable is saved as an independent lyric object.

	 3	 To convert standard text to lyrics, select the text, then select the Lyric checkbox in the Text 
Event inspector.
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Add lyrics for multiple verses
	 1	 Add lyrics for the first verse (as described in the previous task).

	 2	 Drag a second lyric object to the same note position below the lyric object for the first verse, and 
enter the second verse.

	 3	 Repeat the process for any additional verses.

As long as you enter lyrics continuously and do not leave this mode, all lyric objects for the 
second verse stay at the same height as the initial object—in this case, the first word of the 
second verse.

Quickly align multiple lyric objects
You can use this method to quickly align sequential Lyric text objects for the same verse, but not 
for different verses. Doing so would set them all to the same height.

	 1	 Select the lyric objects you want to align.

To select all lyric objects, select one lyric object, then choose Edit > Select Similar Objects.

	 2	 Use the Align Object Positions Vertically key command.

Convert standard text to lyrics
mm Select the text, then select the Lyric checkbox in the Text Event inspector.
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Add and edit text

Add text
You can use text objects in the Part box to add standard text (text other than lyrics, automatic 
text, or global text). The basic functions for moving the pointer, deleting parts of the text, and so 
on, are the same as they are for most text-editing applications.

You can also use text objects (with a music symbol font) to add and position music symbols 
anywhere in the score, free of the rhythmic constraints of MIDI notes.

Add text to the score
	 1	 Select a text object in the Part box.

	 2	 Do one of the following:

•• Drag the text object where you want it to appear in the score. 

•• Select the Text tool (or use the Set Text Tool key command), then click the position where you 
want the text to appear. 

An insertion point appears at the target position. (If you choose one of the automatic text 
objects, the corresponding text for that object is inserted automatically.)

Text tool

	 3	 Enter your text. 

As long as you’re in Text Entry mode (indicated by the blinking insertion point), you can click any 
position in the text field. You can select parts of the text by dragging the pointer in the text field, 
and cut, copy, and paste text. Press Return, or click anywhere outside the text field, to exit Text 
Entry mode.
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Each text object (except text in the header, or at or outside the page margins) is saved as a meta 
event in a particular MIDI region, at a specific bar position. This position is displayed in the help 
tag as you insert the text object. Text events are also displayed in the Event List, allowing you to 
change their position, but not the text itself. 

Score text event

Tip:  You can simultaneously add text to several staffs. This is handy if you want to insert the text 
“accelerando al fine,” for example, into all instruments. You can enter text into several staffs at 
once just as you can other objects. For more information, see Insert items in multiple regions on 
page 616.

Edit text
In general, you edit text objects in the same way as other objects. If a text object is selected, you 
can set its parameters in the Event inspector.

You edit standard text in a text object the same way you edit text in a text-editing program. You 
can also change font settings for standard text in the Fonts window.

Edit standard text in a score
	 1	 Do one of the following:

•• Click the text with the Text tool.

•• Double-click the text with the Pointer tool.

	 2	 Edit the selected text.

Change font settings
	 1	 Select the text you want to change.

	 2	 Choose Functions > Text Attributes > Fonts from the Score Editor menu bar, then choose settings 
in the Fonts window.
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Edit event parameters for text objects
You can edit event parameters for a text object in the Event inspector, including the staff 
number, text style, text alignment, vertical and horizontal position, and whether or not the text is 
lyric text.

Edit text event parameters
	 1	 Select the text you want to change.

	 2	 In the Event inspector, do any of the following:

•• To change the staff for the text object: Drag the Staff number up or down. (This is only relevant 
for multiple staff styles.)

•• To convert the text to lyric text: Select the Lyric checkbox.

•• To change the text style: Choose a different text style from the Staff Style pop-up menu.

•• To change the text alignment: Choose a different text alignment from the Align pop-up menu.

•• To change the position of the text object in the score: Drag the Vertical Pos and Horizontal Pos 
numbers up or down.

Use text styles
You control the appearance of text in the Score Editor using text styles. A text style contains a set 
of text attributes, such as font, size, and style, which you can apply to text objects. You can also 
create your own text styles, and import them from other Logic Pro projects.

You apply, edit, and create text styles in the Text Styles window, which lists all the text styles in 
the current project. Default text styles appear at the top of the list, followed by user-created text 
styles. Each line shows the name and an example of the text style. Double-clicking the Example 
line opens the Font window, where you can edit both the default and user text styles. Any fonts 
installed on your system can be used.

User text styles are saved with the project file, allowing them to be different for each project. 

The default text styles have been designed for specific text elements, and are automatically 
assigned when inserted. 

•• Plain Text: The default setting for regular text.

•• Page Numbers, Bar Numbers, Instrument Names: Used for automatic page and bar numbering, 
and display of instrument names (see Numbers & Names settings on page 897). These styles 
can also be edited in File > Project Settings > Score > Numbers & Names. Changes in either 
window automatically update the settings in the other window, and affect the entire project.

•• Tuplets: Used for triplet and other tuplet numbers.

•• Repeat Endings: Used for anything written into the repeat ending boxes (usually just numbers, 
but text can also be entered).

•• Chord Root, Chord Extension: Used for the display of chord symbols. The Root covers the root 
and (optional) extra bass note in chord symbols. The Chord Extension is used for everything 
else. 

•• Multiple Rests: Used for the number above multiple rests.

•• Tablature: Used for the display of fret numbers in guitar tablature.

•• Tempo Symbols: Used for the display of numbers in tempo symbols.

•• Octave Symbols: Used for the display of octave symbols.

•• Note Heads: Used for the display of note heads.

•• Guitar Grid Fingerings: Used for the display of guitar grid fingerings.
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•• Guitar Markings: Used for the display of guitar markings.

•• Fingerings: Used for the display of fingering markings.

Open the Text Styles window
mm Choose Layout > Text Styles from the Score Editor menu bar.

Apply a text style to a text object
mm Select the text object, then choose a text style from the Style pop-up menu in the Event 

inspector. 

Create a new text style
mm Choose New > New Text Style in the Text Styles window.

A new line appears below the bottom text style entry, where you can define the attributes of the 
new text style. The names of any new style can be edited in the text field, which opens when you 
double-click the name of the text style.

Import text styles from another project
	 1	 Do one of the following:

•• Choose File > Project Settings > Import Project Settings.

•• Click the Browsers button  in the control bar, then click All Files.

	 2	 Navigate to and select the project whose styles you want to use, then click the Import button.

Note:  If accessing the settings from the All Files Browser, you also need to click the Import 
Project Settings button, which appears after you click the Import button.

	 3	 In the Import Settings window, select the Text Styles checkbox, then click the Import button.

Text style settings are imported into the active project.

Add automatic text
The text group in the Part box contains four objects you can use to add the display level, 
instrument name, project name, and date. The corresponding text is automatically displayed at 
the position you place the object:

•• REGION: Displays the name of the current display level. This can be a MIDI region, a folder, or 
even the name of the project file (on the highest level). 

•• INSTR (Instrument): Displays the name of the currently displayed instrument or score set. For 
more information, see Score sets overview on page 701. 

•• SONG: Displays the name of the project file.

•• DATE: Displays the current date (at the time of printout).

Automatic text objects can be inserted as both global text (in the margin areas), or as text 
objects related to a bar position (in one of the staffs or regions). For example, you can insert the 
INSTR object as a global object to display the name of the current score set on all pages. The 
appearance, and exact positioning, of these objects can be set in the Event inspector.

Add an automatic text object
mm Drag a REGION, INST, SONG, or DATE text object from the Part box to the score.



	 Chapter  20    View and edit music notation	 655

Add global text
Score sets determine which software instrument tracks are included in the score display. Each 
project can contain as many score sets as required. For more information on score sets, see Score 
sets overview on page 701.

Global text objects appear in all score sets of a project (score, parts, and so on), although they’re 
inserted just once.

Unlike regular text objects, the position of global text does not relate to bar positions, but 
is defined as a graphic position on the page. Global text can be inserted and viewed only in 
Page view. A common example of a global text object is a song name, commonly placed in the 
page header.

Add a global text object
mm Drag a text object from the Part box to one of the following areas of the page:

•• In the header space (set in Layout > Global Format).

•• Outside, or directly on, any of the page margin lines.

Text objects inserted in one of these areas automatically become global text objects.

After you add global text to one of the margin areas, you can move it anywhere on the page.
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Position global text
Do one of the following:

mm To move global text objects vertically only: Use the Pointer tool.

mm To move global text objects both vertically and horizontally: Hold down Shift, then use the Pointer 
tool; or use the Layout tool.

When a global text object is selected, the Event inspector contains the following additional 
parameters:

•• Align pop-up menu: Although alignments relating to bar positions are shown in the pop-up 
menu, you can’t choose them here.

•• Pages pop-up menu: Defines the pages that the global text object is displayed on. You can 
choose between the following options:

•• 1: The text will only be displayed on the first page.

•• 2: The text will be displayed on all pages except the first one.

•• Odd: The text will be displayed on all pages with odd numbers.

•• Even: The text will be displayed on all pages with even numbers.

•• All: The text will be displayed on all pages.

•• Zone pop-up menu: The margin area that the text belongs to or is associated with. You can 
choose between Top, Header, Side, Footer, and Bottom. 
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Work with chord grids

Chord grids overview
  When Show Advanced Tools is selected in the Advanced preferences pane, you can 

add chord grid symbols from the Part box. Logic Pro includes a large library of chord grids, in 
standard tuning and in a variety of alternative tunings.

You can review and edit existing chord grid libraries and chord grids, as well as create your own, 
in the Chord Grid Library.

The Chord Grid Library window contains three panes: the Instrument Editor, Chord Grid Selector, 
and Chord Grid Editor. The Instrument Editor may not be available, depending on which method 
you use to open the Chord Grid Library.

Open the Chord Grid Library
Do one of the following:

mm Choose Logic Pro > Preferences > Chord Grid Library.

mm Choose Layout > Chord Grid Library from the Score Editor menu bar.

mm Drag a chord grid symbol from the Part box into the score.

mm Double-click an existing chord grid symbol in the score.
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Instrument Editor
You use the Instrument Editor pane to view, create, and edit instrument tunings and chord grid 
libraries. You can also import and export chord grid libraries. 

The Instrument Editor pane includes the following parameters:

•• Name column: Displays the instrument tuning name. Double-click to edit.

•• Library column: Displays the chord grid library name. Double-click to edit.

•• Tuning column: Displays the instrument tuning.

•• Strings column: Displays the number of strings.

•• Chords column: Displays the total number of chords.

•• Basic Chords column: Displays the number of basic chords.

•• Import button: Click to import a library to the Instrument Editor.

•• Export button: Click to export a library from the Instrument Editor.

•• Delete button: Click to delete a tuning or library from the Instrument Editor.

•• Create button: Click to create a library in the Instrument Editor.

Note:  The Instrument Editor tab is only available if you open the Chord Grid Library from 
Logic Pro preferences or from the Layout menu, not when dragging or double-clicking a chord 
grid symbol.

For information about creating and editing chord grid libraries, see Create, rename, and delete 
chord grid libraries. For information about importing and exporting chord grid libraries, see 
Import and export chord grid libraries.
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Chord Grid Selector
You can select and filter individual chord grids from your instrument tunings and chord grid 
libraries in the Chord Grid Selector.

The Chord Grid Selector includes the following parameters:

Instrument parameters
•• Name pop-up menu: Choose the name of the instrument tuning you want to use.

•• Tuning field: Displays the default tuning for the chosen instrument.

•• Number of Strings field: Displays the default number of strings for the chosen instrument.

•• Capo pop-up menu: Choose the fret on which to place the Capo. Choose 0 to play at the 
original chord, 1 to place a Capo on the first fret, and so on.

Filter parameters
•• Root Note pop-up menu: Filter the chord grids according to root note.

•• Bass Note pop-up menu: Filter the chord grids according to bass note.

•• Chord Type pop-up menu: Filter the chord grids according to chord type.

•• Difficulty pop-up menu: Filter the chord grids according to difficulty.

•• Favorites checkbox: Filter the chord grids according to those tagged as favorites.

•• Library pop-up menu: Filter the chord grids according to library (those libraries that are linked 
to the chosen tuning).

•• No Transpositions checkbox: Filter the chord grids according to transposition.

View parameters
•• Number of Frets pop-up menu: Choose the number of frets (four, five, or six) to be shown in the 

chord grids.

•• Left-Handed checkbox: Change the chord grid display to suit left-handed users.
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Other parameters
•• Playback button: Click to listen to a selected chord grid.

•• Action pop-up menu: Choose how the chord grid strings are played back and at what tempo.

•• Chord: All strings are played back simultaneously.

•• Arpeggio Up, Arpeggio Down: Each string is played back one after the other.

•• Slow, Medium, Fast: Choose the playback tempo.

•• Delete button: Click to delete a non-factory chord grid.

•• New button: Click to create a new chord grid. The Chord Grid Editor pane opens and shows an 
empty chord grid.

•• Edit button: Click to edit a selected chord grid. The Chord Grid Editor pane opens and shows 
the selected chord grid.

Note:  This same edit action can be triggered by double-clicking a chord grid in the Chord 
Grid Selector.

For information about inserting and editing chord grids, see Insert and edit chord grids in the 
Score Editor.
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Chord Grid Editor
  When Additional Score Options is selected in the Advanced preferences pane, you can 

create and edit chord grids in the Chord Grid Editor.

The Chord Grid Editor includes the following parameters:

Instrument parameters
•• Name pop-up menu: Choose the instrument tuning in which to add or replace the chord grid.

•• Tuning field: Displays the default tuning for the chosen instrument.

•• Number of Strings field: Displays the default number of strings for the chosen instrument.

•• Capo pop-up menu: Choose the fret on which to place the Capo. Choose 0 for no Capo, 1 to 
place a Capo on the first fret, and so on.

Chord parameters
•• Name field: Enter a name for the chord grid.

•• Root Note pop-up menu: Choose a root note for the chord grid.

•• Bass Note pop-up menu: Choose a bass note for the chord grid.

•• Chord Type pop-up menu: Choose a chord type for the chord grid.

•• Difficulty pop-up menu: Choose a difficulty level for the chord grid.

•• Favorite checkbox: Add the chord grid to your favorites.

•• Highest Fret pop-up menu: Choose the highest fret for the chord grid.

View parameters
•• Number of Frets pop-up menu: Choose the number of frets (four, five, or six) to be shown in the 

chord grids.

•• Left-Handed checkbox: Change the chord grid display to suit left-handed users.
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Other parameters
•• Playback button: Click to hear a preview of the chord grid.

•• Action pop-up menu: Choose how the chord grid preview is played and at what tempo.

•• Chord: All strings are played simultaneously.

•• Arpeggio Up, Arpeggio Down: The chord is played as an arpeggio, one string at a time.

Arpeggio Up plays the strings from lowest to highest, while Arpeggio Down plays the strings 
from highest to lowest.

•• Slow, Medium, Fast: Choose the playback tempo.

•• Reset/Clear button: Click the Reset button to set the chord grid back to its original state 
(showing either open strings, a new chord grid, or the selected chord grid) within the Chord 
Grid Selector pane. Click the Clear button to clear the chord grid, providing you with a clean 
template to work on.

•• Target Library pop-up menu: Choose the library in which to add the new or edited chord grid.

•• Replace button: Click to replace an existing chord grid.

•• Add button: Click to add a chord grid to your chosen library.

Open the Chord Grid Editor
Do one of the following:

mm Drag a chord grid symbol from the Part box into the score display.

mm Choose a chord grid symbol in the Part box, then click within the Score Editor with the 
Pencil tool.

mm Choose Layout > Chord Grid Library from the Score Editor menu bar, then click the Chord Grid 
Editor tab.

For information about creating and editing custom chord grids, see Create custom chord grids in 
the Chord Grid Editor.
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Insert and edit chord grids in the Score Editor
There are several ways to insert chord grids into your score.

Insert a chord grid symbol
	 1	 Do one of the following:

•• Drag a chord grid symbol from the Part box into the score.

•• Choose a chord grid symbol in the Part box, then click in the Score Editor with the Pencil tool.

Either technique opens the Chord Grid Selector pane in the Chord Grid Library.

	 2	 Select a chord grid, then click OK.

Change the scale of a chord grid
After inserting chord grids in your score, you can edit their size and position accordingly.

mm Control-click a chord grid symbol, then choose one of the following from the shortcut menu:

•• Scale: reduced

•• Scale: normal

•• Scale: enlarged
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The scaling values are based on the Grid scaling and Chord scaling settings in the File > Project 
Settings > Score > Chords & Grids pane.

Align selected chord grids vertically
mm Select multiple chord grids, Control-click any one of them, then choose Align Object 

Positions Vertically.

The selected chord grid symbols are aligned vertically.

Align all chord grids vertically
	 1	 Control-click a chord grid, then choose Align Object Positions Vertically.

	 2	 You’re asked if you want to align all similar objects to this one. Click OK.

All chord grids are aligned vertically.

Copy an existing chord grid
mm Hold down Option while dragging an existing chord grid, then release it when you reach the 

desired position.
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Hide the chord name
You have the option to hide or show the chord name on a chord grid.

mm Control-click a chord grid, then choose Hide Chord Name from the shortcut menu.

Modify the chord of an existing chord grid
mm Double-click the chord grid, choose another in the Chord Grid Selector, then click OK.
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Create custom chord grids in the Chord Grid Editor

Create and edit chord grids

  When Additional Score Options is selected in the Advanced preferences pane, you can 
create and edit chord grids in the Chord Grid Editor. You have many options when creating new 
chord grids from scratch, or when modifying existing chord grids.

Create a new chord grid in the Chord Grid Editor
	 1	 Click the Clear button in the Chord Grid Editor pane.

The chord grid display is cleared, allowing you to create a new one from scratch.

Note:  Clicking the Clear button changes it to the Reset button.

	 2	 Set the Chord and View parameters to suit your needs.

	 3	 Click the Add button.

The Chord Grid Selector pane opens, with the new chord grid added to your chosen library.

Edit an existing chord grid in the Chord Grid Editor
	 1	 Double-click a chord grid in the Chord Grid Selector pane.

The chord grid opens in the Chord Grid Editor pane.

	 2	 Set the Chord and View parameters to suit your needs.

	 3	 Click the Add or Replace button.

The Chord Grid Selector pane opens, with the edited chord grid added or replaced in your 
chosen library.

Display higher positions (frets) in the chord grid
mm Click 1st to open a pop-up menu, then choose another fret number.
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Add and edit fingering dots
You can add, edit, and delete fingering dots on a chord grid.

Add a fingering dot
mm Click the string and fret.

A black dot is created.

Move an existing fingering dot
Do one of the following:

mm Click another fret on the same string.

mm Drag the dot to a new fret position.



	 Chapter  20    View and edit music notation	 668

Set the finger number for a fingering dot
mm Control-click a dot, then choose a number between 0 and 5.

Add an optional fingering dot
Do one of the following:

mm Option-click a string to create an optional dot. If another real dot exists on the same string, the 
real dot remains.

mm Option-click an existing dot to change it to an optional dot. An empty string is shown as a result.
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Delete a fingering dot
Do one of the following:

mm Select a dot so that it turns green, then press the Delete key.

mm Click the area at the top of the string.

The result is the same using either approach: the string is open.
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Add and edit barres
A barre shows where the performer places his or her finger over several strings at the same fret. 
You can add, edit, and delete barres on a chord grid.

Add a barre
Do one of the following:

mm Drag the left or right edge of an existing dot to the right or left.

mm Place the pointer over a string, then drag to the left or right.

Move a barre
mm Drag the barre to a new fret position.
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Delete a barre
mm Select a barre so that it turns green, then press the Delete key.

Mute strings in a chord grid
You can show muted and unmuted open strings on a chord grid.

Mute a string
mm Click the area at the top of the string.

The string is muted.
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Unmute a string
mm Click the area at the top of the string.

The string is open.
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Create, rename, and delete chord grid libraries
You can create a new chord grid library for an existing instrument tuning, or for a new 
instrument tuning. You do this from the Instrument Editor pane in the Chord Grid Library.

Create a new chord grid library for an existing instrument tuning
	 1	 Open the Instrument Editor pane by doing one of the following:

•• Choose Logic Pro > Preferences > Chord Grid Library, then click the Instrument Editor tab.

•• Choose Layout > Chord Grid Library from the Score Editor menu bar, then click the Instrument 
Editor tab.

	 2	 Click the Create button.

	 3	 In the Create Library dialog, define the following parameters:

•• Library Name field: Enter a name for the chord grid library.

•• Tuning pop-up menu: Choose the instrument tuning in which you want to add the library.

•• Number of Strings pop-up menu: Leave this at the default setting.
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	 4	 Click Create to add the new chord grid library to the chosen instrument tuning.

Create a new chord grid library for a new instrument tuning
	 1	 Open the Instrument Editor pane by doing one of the following:

•• Choose Logic Pro > Preferences > Chord Grid Library, then click the Instrument Editor tab.

•• Choose Layout > Chord Grid Library from the Score Editor, then click the Instrument Editor tab.

	 2	 Click the Create button.

	 3	 In the Create Library dialog, define the following parameters:

•• Library Name field: Enter a name for the chord grid library.

•• Tuning pop-up menu: Leave this at the default setting.

•• Number of Strings pop-up menu: Choose the number of strings.

	 4	 Click Create to add a new instrument tuning, also containing the newly created chord 
grid library.

Rename a chord grid library
mm Double-click the name in the Library column, then enter a new name.

Delete an instrument tuning or chord grid library
mm Select the instrument tuning or chord grid library that you want to delete, then click the 

Delete button.

If you select an instrument tuning, the entire tuning and its chord grid libraries are deleted. If you 
select a chord grid library, only that library is deleted (unless it’s the only library within a tuning; 
then the instrument tuning is also deleted).
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Import and export chord grid libraries
You can import and export chord grid libraries from the Instrument Editor pane.

Import a chord grid library
	 1	 Open the Instrument Editor pane by doing one of the following:

•• Choose Logic Pro > Preferences > Chord Grid Library, then click the Instrument Editor tab.

•• Choose Layout > Chord Grid Library from the Score Editor menu bar, then click the Instrument 
Editor tab.

	 2	 Click the Import button.

	 3	 Browse to the location of the library you want to import.
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Export a chord grid library
	 1	 Open the Instrument Editor pane by doing one of the following:

•• Choose Logic Pro > Preferences > Chord Grid Library, then click the Instrument Editor tab.

•• Choose Layout > Chord Grid Library from the Score Editor menu bar, then click the Instrument 
Editor tab.

	 2	 Select the library you want to export.

	 3	 Click the Export button.

	 4	 Enter a name for the library, and browse to the location in which to save it.

	 5	 Click Save.
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Edit score region parameters

Score region parameters overview
Score region parameters let you control different aspects of how regions appear in the score. 
They affect the display of notes and other events, but have no effect on the sound or playback of 
the project.

  When Additional Score Options is selected in the Advanced preferences pane, you can 
edit score region parameters for the selected region or regions in the Region inspector, when 
the Score Editor has key focus. The Region inspector shows the name of the selected region; or, 
when multiple regions are selected, the number of selected regions. When multiple regions have 
different values for any of their parameters, a “*” is displayed in the corresponding parameter line. 
If you change this value, all selected regions are set to the same value for that parameter.

The following sections describe individual score region parameters in the order they appear in 
the Region inspector.

•• Style

•• Quantize

•• Interpretation

•• Syncopation

•• No Overlap

•• Max Dots

•• Score

Style
You choose the staff style for the selected track (and when Additional Score Options is selected, 
for selected regions) from the Staff Style pop-up menu. For information about using staff styles, 
see Staff styles overview.
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Quantize
The Quantize parameter applies visual quantization to notes, setting the shortest note value that 
can be displayed.

Note:  When Show Advanced Tools is not selected in the Advanced preferences pane, the Grid 
pop-up menu appears in the Score Editor menu bar. You can set the visual quantization for the 
Score Editor using the Grid pop-up menu.

For example, a note with a short note value, such as a 32nd note, can only be displayed at its 
original length if Quantize is set to 32 or shorter. If Quantize is set to 8, the 32nd note is displayed 
as an eighth note (the shortest note value displayed at that Quantize setting).

Settings in the Quantize pop-up menu that display a single value, such as 8, 16, or 128, represent 
the minimum displayed note value for that Quantize setting. For settings that display a pair of 
values, the first value represents the minimum note value for duple rhythms, and the second 
value displays the minimum note value for triple rhythms (or triplet figures in a duple-rhythm 
context). Following is a list of the triple Quantize settings and their corresponding note values.

Quantize setting Corresponding note value

3 1/2-note triplets

6 1/4-note triplets

12 1/8-note triplets

24 1/16-note triplets

48 1/32-note triplets

96 1/64-note triplets

192 1/128-note triplets

384 1/256-note triplets

When a single-value setting is used, automatic triplets are not displayed at all (except for triplets 
inserted with the pointer, using an N-tuplet object). 

Important:  The Quantize parameter must be set to a triple quantization value to enable the 
automatic display of triplets.

You can override the Quantize value for a group of notes using tuplets; see Create and edit 
tuplets on page 645.
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The Quantize pop-up menu also includes a Default setting for new MIDI regions, which can only 
be set with the Insert Defaults setting; not for existing regions. If Default is chosen, the Quantize 
setting of new MIDI regions is dependent on the current division value in the LCD. If the division 
value in the LCD is a duple value (such as 4, 8, or 16), the Quantize value is set to that note value 
plus the next highest triple value (such as 6, 12, or 24). If the division value is a triple value, the 
Quantize value is set to that value plus the duple value that is divisible by that (triple) value.

For example, a global division value of 1/8 results in an 8,12 Quantize setting for new regions; a 
value of 1/12 becomes a 4,12 Quantize value; a value of 1/16 results in a Quantize value of 16,24, 
1/24 in 8,24, and so on.

Note:  If a particular Quantize value has already been set in the Insert Defaults, all new regions 
use this value, regardless of the division value in the LCD. You can change any of these values at 
any time.

For swing notation, use 8,12 for the Quantize parameter to display eighth-note triplets and 
also display two uneven notes on one beat as regular eighth notes. For double-time passages 
containing sixteenth notes, you can either cut the MIDI region containing the double-time 
passage (in the Tracks area) and assign it a higher Quantize value with the double-time note 
value, or use hidden N-tuplets for the sixteenth notes. For more information, see Create and edit 
tuplets on page 645.

For swing sixteenth notes (shuffle funk, hip hop, and so on), the same principle applies. In this 
case, choose 16,24 as the Quantize parameter.

You can fix the display quantization of all MIDI events in the projects using the Score Editor’s 
Functions > Quantization > Fix displayed Note Positions and Fix displayed Note Positions and 
Durations commands. These commands may be useful for exporting projects (complete with 
display Quantize settings) to other notation programs that don’t feature display quantization. The 
commands are also available from the shortcut menu when you Control-click notes in the score.

Set the visual quantization value
mm Choose a value from the Quantize pop-up menu in the Region inspector.
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Interpretation
Music notation is meant as a guide to performance, and rhythmic values are often not notated 
with metronomic precision. The Interpretation setting helps you produce a more readable score 
from real-time recordings. You should usually turn it off when adding notes via step input or with 
the pointer.

If Interpretation is turned on, notes are generally displayed with longer length values than their 
actual length, to avoid having many short rests. Short notes on a downbeat in 4/4 time, for 
example, are displayed as quarter notes. The score becomes slightly less precise, but is easier 
to read.

If Interpretation is turned off, note lengths are displayed as closely as possible to their real values, 
as determined by the Quantize value. In the following example, the same MIDI region is shown 
twice, the first with Interpretation turned off, the second with it turned on:

You can use note attributes to use Interpretation on individual notes, overriding the Region 
inspector setting. For more information, see Change the syncopation or interpretation of 
notes on page 642.

Turn interpretation on or off
mm Select or deselect the Interpretation checkbox in the Region inspector.
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Syncopation
Syncopation involves rhythmic patterns that go “against” the normal rhythm as defined by the 
time signature. The Syncopation setting helps you produce a cleaner-looking score by displaying 
syncopated notes with fewer ties or subdivisions.

If Syncopation is turned on, each note is displayed graphically as a single note when possible 
(rather than as several tied notes), regardless of its rhythmic position. If it can’t be displayed as a 
single note, the note is divided into the minimum possible number of notes, connected by ties. 
In some cases, the display of syncopated notes also depends on the Max Dots setting—see Max 
Dots on page 683.

The following example shows the same two bars displayed differently, the first with Syncopation 
turned off, then with it turned on:

Syncopation can also be turned on and off for individual notes, independent of the Region 
inspector setting, using note attributes. For more information, see Change the syncopation or 
interpretation of notes on page 642.

If the Syncopation setting produces unwanted results, you can change the graphic display of 
notes connected with ties by adding a short user rest from the Part box at the bar position 
where you want the tie subdivided. Once the rest is inserted, it disappears, but the note display 
changes. The inserted rest can only be seen and edited in the Event List. This trick works for all 
notes, not just syncopated ones. (See Use tuplets to override display quantization on page 647.) 
In polyphonic staff styles, the MIDI channel of the rest and the corresponding note must 
be identical.

Turn syncopation on or off
mm Select or deselect the Syncopation checkbox in the Region inspector.
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No Overlap
The No Overlap setting simplifies the display of overlapping notes. No Overlap prevents the 
display of overlapping notes in melodies played with an exaggerated legato by shortening 
the displayed note length to the beginning of the next note. Notes beginning simultaneously 
(intervals or chords) are displayed with the length of the shortest note in the chord.

When No Overlap is turned off, the score display shows the lengths of overlapping notes 
precisely (at the current Quantize value). This can be more useful to accurately notate chords, but 
may be harder to read, particularly for melodic passages.

No Overlap works for monophonic, but not polyphonic, staff styles—see Staff styles overview on 
page 684 for details.

The first example shows a region with No Overlap turned off:

The second example shows the same region with No Overlap turned on:

No Overlap should only be turned off when the precise display of overlapping notes is more 
important than producing a smooth melodic line:

Although you can’t see that all notes continue to sound here, the result looks like this if No 
Overlap is turned off:

The solution typically involves turning on No Overlap and using sustain pedal markings. Pedal 
markings are automatically displayed if notes are recorded in real time with a MIDI keyboard and 
sustain pedal.

Show or hide overlapping notes
mm Select or deselect the No Overlap checkbox in the Region inspector.
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Max Dots
The Max Dots parameter affects the rhythmic display of dotted notes (notes that are one-and-
one-half times as long as the equivalent undotted note value) by controlling the maximum 
number of dots that can be displayed. This makes the display of such notes less metronomically 
precise, but makes the score more readable. By default, the number of Max Dots is 1.

Unwanted dotted notes or rests can be changed by inserting user rests (which remain invisible, if 
notes). See Use tuplets to override display quantization on page 647 for information on changing 
the way notes with ties are displayed).

Set the maximum number of dots 
In the Region inspector, do one of the following:

mm Drag the Max Dots value up or down.

mm Double-click the Max Dots value, then enter a new value.

Score
The Score parameter in the Region inspector controls whether the selected track appears in the 
score. If the Score checkbox is unselected, the selected track is not displayed in the score. This 
lets you exclude certain tracks from the score display—for example, those that only contain MIDI 
events that can’t be displayed in the score, such as controller or SysEx data. 

Exclude selected tracks from the score display
mm In the Region inspector, deselect the Score checkbox.

You may need to click the More disclosure triangle to see the Score checkbox.

Select the Score checkbox to have the tracks appear in the score display.

Edit default parameters for new regions
New MIDI regions created by recording, or with the Pencil tool, include a default set of region 
parameters (and event parameters). You can view and edit these defaults when no staff (no 
region) is selected in the Score Editor. The defaults remain as set until you quit Logic Pro, but can 
be changed at any time.

You can edit the default region (and event) parameters, except for the Staff Style parameter, 
which is separate for each track, and is set in the bottom line of the Track inspector. After you 
edit the defaults, all new regions will use the new default settings. If Quantize is set to “default,” 
the display Quantize setting of newly recorded or created regions matches the division value 
shown in the LCD.

Edit region and event parameter default values
	 1	 Click an empty area of the Score Editor background (so that no region is selected).

	 2	 Edit any of the parameter values in the Region inspector (except the Style parameter) or the 
Event inspector.
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Work with staff styles

Staff styles overview
Using staff styles, you can control the display of clefs, rests, stems, ties, and beams, change the 
displayed transposition, and adjust the staff size and space between staffs. You can choose from 
a variety of predefined staff styles or customize and create your own staff styles to use in your 
scores. Staff styles affect the visual display of the score, but have no effect on MIDI playback.

Staff styles are saved as part of the project, so you can use different staff styles in different 
projects. You can import frequently used staff styles into other projects to speed up your 
workflow. 

You can assign staff styles in the Region inspector, and edit staff styles in the Staff Style window. 

  When Show Advanced Tools is selected in the Advanced preferences pane, you can assign 

staff styles to tracks in your project and edit staff styles.  When Additional Score Options is 
selected, you can also assign styles to individual regions.

Tip:  Create a template project with the staff styles and other score settings that you use 
frequently, so they are all available when you start a new project.

Assign staff styles to tracks
You can assign a different staff style to each track in the score. Changing staff styles allows 
you to control the display of individual staffs in the score, and quickly create parts for 
transposing instruments.

Each track has a default staff style, which appears in the Staff Style pop-up menu in the Region 
inspector. When you start working on a new project, or create a project template, you can 
change this setting for tracks that will use a specific staff style, so that regions recorded on these 
tracks are displayed with the correct staff style with no further editing.

If you choose Auto Style from the Staff Style pop-up menu, the track is assigned a staff style that 
fits the range of notes in the regions on the track. For example, if the regions consist of notes 
played below middle C, a Bass staff style is assigned to the track. Two-handed parts (with notes 
both above and below middle C) are assigned a Piano staff style.

Note:  Auto Style can only be chosen in the Region inspector, and does not appear in the list of 
staff styles in the Score Editor Region inspector.

  When Show Advanced Tools is selected in the Advanced preferences pane, you can assign 
staff styles to tracks in your project and edit staff styles. 

  When Additional Score Options is selected in the Advanced preferences pane, you can 
assign staff styles to individual MIDI regions as well as to tracks, allowing you to use multiple 
styles on a single staff. This can be used to alternate between fully notated passages and 
“improvised” passages using only beat slashes and chord symbols, for example. 



	 Chapter  20    View and edit music notation	 685

Assign a staff style to a track
Do one of the following:

mm Click the staff in the Score Editor, then choose a staff style from the Staff Style pop-up menu in 
the Region inspector.

You can select multiple tracks, and assign the same staff style to all selected tracks.

mm In Linear view, click the clef on the staff, then choose a staff style from the shortcut menu.

Set the track to determine the staff style automatically
	 1	 In the Tracks area, select one or more tracks.

	 2	 In the Region inspector, choose Staff Style > Auto Style.

Assign a staff style to a selected MIDI region
mm Select the region in the Score Editor, then choose a staff style from the Staff Style pop-up menu 

in the Region inspector.
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Staff Style window
You view and edit staff style parameters in the Staff Style window. The upper part of the window 
shows a list of available staff styles, with a visual representation of the selected staff style. The 
lower part shows the staffs that are used for the selected staff style, with parameters for each 
staff. The voices used for each staff are listed to the right. 

Menu bar Style overview

Staff parameters Voice parameters Assign parameters

The main elements of the window include:

•• Menu bar: Contains the local New, Edit, and View menus, and the View buttons to hide or show 
different parts of the Staff Style window.

•• Style overview: Shows a list of available staff styles with the type, number of voices, and other 
parameters for each listed staff style, and a graphical representation of the selected style that 
updates to reflect your edits to the style.

•• Staff parameters: Shows the parameters for each staff in the selected staff style. Parameters for 
each staff are shown as one row. 

•• Voice parameters: Shows the parameters for independent voices. Parameters for each voice are 
shown as one row. Each voice can be displayed as a rhythmically independent, polyphonic 
passage in the music. A voice can consist of as many simultaneous notes (chords) as needed.

•• Assign parameters: Shows the parameters for assigning notes to different voices. Every staff 
can contain up to 16 independent voices, but each voice can be displayed on only one staff. 
(Consequently, a staff style must contain at least as many voices as staffs.)

You can show the entire Staff Style window, or only part of the window, using the View buttons 
on the right side of the menu bar.

Open the Staff Style window
Do one of the following:

mm Choose Layout > Staff Styles (or use the Show/Hide Staff Style Window key command).

mm Double-click a staff in the score.
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Change the view for the Staff Style window
Do one of the following:

mm To show only the style overview (upper part of the window): Click the left View button.

mm To show the complete contents (both parts) of the window: Click the center View button.

mm To show only the staff and voice parameters (lower part of the window): Click the right View button.

Create and duplicate staff styles
In the Staff Style window, you can create new staff styles, or duplicate an existing style to use as a 
starting point for a new one.

Create a single staff style
	 1	 Choose New > Single Staff Style.

	 2	 In the Staff Style window, edit the parameters for the new staff style.

Create a dual staff style
	 1	 Choose New > Dual Staff Style.

	 2	 In the Staff Style window, edit the parameters for the new staff style.

Duplicate a staff style
Do one of the following:

mm Choose New > Duplicate Style.

mm Option-drag a staff style in the style overview up or down.
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Edit staff styles
In the Staff Style window, you can edit various staff style parameters. In the style overview, you 
can edit the style type, size, transpose, and range parameters.

Edit staff style parameters
In the style overview, do any of the following:

mm To rename a staff style: Double-click the name and enter a new name. 

mm To choose a different staff style type: Click-hold the type, then choose a different type from the 
pop-up menu.

mm To change the size: Drag the size value up or down.

For staff styles with multiple staffs, the size value shows “–” if the sizes of the staffs are not equal.

mm To change the transposition: Click-hold the transpose value, then choose a different value from the 
pop-up menu. 

For staff styles with multiple staffs, the transpose value shows “–” if the staffs have different 
transposition values.

mm To change the note range: Drag the Lo and Hi values up or down.

mm To set the appearance of brackets and bar lines: You can only edit this parameter for styles with 
multiple staffs: it lets you determine which staffs are bracketed (two bracket types are available) 
or connected by bar lines (only at the beginning of each staff line, or at every bar line).
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If a staff style consists of more than two staffs, the brackets and bar lines can be set to connect 
only certain parts of the overall staff style—they can be interrupted in between staffs. If you want 
to delete any connections, grab the symbol at its end (bottom), and drag it up, until it disappears.

The voices value in the style overview is determined by the number of voices in the staff style. 
This can be changed in the Voice parameters section, but not in the style overview.

Edit staff, voice, and assign parameters for a staff style
After you set the number of voices and staffs in a staff style, you can edit the Staff and Voice 
parameters for the selected staff style in the lower part of the Staff Style window, and edit Assign 
parameters for each voice in a staff style. When you change a staff style, all tracks using that staff 
style are affected. 

You can edit the following Staff, Voice, and Assign parameters in the Staff Style window:

•• For all staffs: Choose the clef, show or hide the key signature, set the distance to the next 
(higher and lower) staffs, set the staff size, set the number of voices in the staff, and set the 
display transposition.

•• For polyphonic, multiple staff styles: Edit the configuration of brackets and bar lines that 
connect the staffs.

•• For each voice: Control the display of rests, stem direction, tie direction, direction of N-tuplet 
brackets and numbers, beaming, note color, and note head type.

•• Assign parameters for each voice: Set the MIDI channel assignment and definition of a split 
point pitch, for separation of the different voices.

Edit Staff parameters for the selected staff style
In the Staff section of the Staff Style window, do any of the following:

mm Change the clef: Choose a clef from the Clef pop-up menu. In addition to the standard clefs, there 
are some additional options:

•• Drum.0 to Drum.8: Staffs with 0 to 8 lines and a neutral percussion clef. The relationship of 
MIDI note pitches to the top line of all staffs corresponds to the top line in a regular bass clef 
(A2). No accidentals are displayed in these drum staffs. Drum.0 also omits any ledger lines. 
These clefs are often used in mapped drum styles, where the vertical position of a note on the 
staff doesn’t correspond to pitch, but is determined by different drum map parameters. See 
Use drum notation with mapped staff styles on page 697 for more information on mapped 
drum styles.

•• no clef.0 to no clef.8: Like the Drum.0 to Drum.8 staffs, but without a clef.

•• TAB Guitar and TAB Bass: Twelve different options for displaying notes as guitar or bass 
tablature. Tablature tuning sets are defined and edited in the Tablature window (Layout > 
Guitar Tablature).

mm Show or hide the key signatureA: Select the Key checkbox for the staff.

When the Key checkbox is unselected, the staff is displayed without a key signature. Accidentals 
are placed directly beside all affected notes. This can be used, for example, for transposed French 
horn parts, which are sometimes written without a key signature.

mm Change the distance to adjacent staffs: Drag the upper and lower space values up or down. The 
upper value controls the space above staffs, and the lower value controls the space below staffs. 
For the top and bottom staffs in a full score, this controls the page margins.
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Tip:  You can also change the vertical distance above the staff directly in the score, by dragging 
the staff up or down (at the clef ). The distance below the staff can also be edited in the score, but 
only for the bottom staff in the score display (or for a single staff). You drag the bottom line of 
the score display with the pointer.

mm Change the staff size: Drag the size value up or down. 

The Size parameter sets the size of the staff, and the notes and symbols (including slurs and ties) 
displayed on the staff. There are 16 sizes available (0–15). Here are some size recommendations:

•• For regular instrument parts and lead sheets, use size 7 or 8. 

•• The staff size you should use in full scores depends on the number of staffs in the score, 
and the size and format of the paper being used. When using A4 or US letter paper: full 
orchestra: 2, big band: 3, wind quintet: 4.

Note:  The size of all staffs in a score set can also be affected by the Scale parameter in the Score 
Sets window. (See Score sets overview on page 701.) This makes it possible to use the same sizes 
for both the whole score, and parts of a piece.

mm Change the display transposition: Drag the transpose value up or down in semitones.

Display transposition does not affect playback of notes, but only how they appear in the score. 
If a staff contains chord symbols, these are also transposed accordingly. If the Automatic Key 
Transposition project setting, in the Clefs & Signatures pane, is turned on (which is the default), 
key signatures are also transposed.

Edit voice parameters for the selected staff style
In the Voice section of the Staff Style window, do any of the following:

mm Change how rests are displayed: Choose a value from the Rest pop-up menu. Automatic display 
of rests can be turned off (by choosing Hide), or set to display beat slashes instead of rests (by 
choosing Slash). This is useful for rhythm section parts, and improvised solos. In this situation, 
the number of slashes per bar is determined by the nominator in the time signature (4 slashes 
in 4/4-time, 6 slashes in 6/8-time, and so on). Inserted notes and symbols are still displayed, but 
automatic rests are shown only if shorter than one beat. You can insert user rests manually, to 
replace individual beat slashes, if needed.

mm Set the stem direction: Choose a value from the Stem pop-up menu. The default setting is Auto. 
Up or Down forces all stems, regardless of pitch, in the corresponding direction. Hide makes all 
stems (and beams and flags) invisible.

mm Set the stem position: Choose a value from the Stem Pos. pop-up menu.

mm Set the vertical direction for ties: Choose a value from the Tie pop-up menu. The default setting is 
Auto. Up or Down forces all ties in the corresponding direction.

mm Set the direction for tuplet brackets and numbers: Choose a value from the Tuplet pop-up menu. 
The default setting is Auto. Up or Down forces all N-tuplet brackets and numbers in the 
corresponding direction. Hide prevents the automatic display of triplet brackets and numbers. 
In this situation, the numbers are still displayed in brackets on the screen, to allow edits to these 
triplets. These bracketed numbers do not appear, however, on the printout.

If you set this parameter to Hide, you can still make particular triplets visible: double-click the 
bracketed number (3) to open a tuplet dialog. If you close this dialog by clicking OK, you convert 
the automatically displayed triplet to a forced triplet, which is displayed in accordance with the 
parameters set in the dialog.



	 Chapter  20    View and edit music notation	 691

mm Set the appearance of beams: Choose a value from the Beam pop-up menu. The default Slant 
setting allows slanted beams. Horiz. only allows horizontal beams. Vocal prevents the display of 
beams, as is typical in classical vocal parts, where notes are only displayed with flags.

mm Set the color for notes: Choose a value from the Color pop-up palette. The color options are Black 
(“---”), Pitch, Velocity, and the 16 colors of the Color palette. (See Colors settings on page 910.)

These settings only affect regions if the View > Colors > Normal item is chosen in the Score 
Editor (the default setting).

mm Set the appearance of note heads: Choose a value from the Head pop-up menu. You can display 
note heads as normal, show note names or finger names, or hide the note heads completely.

  The Stem Pos. and Color parameters are available when Additional Score Options is 
selected in the Advanced preferences pane.

Edit assign parameters for the selected staff style
In the Assign section of the Staff Style window, do any of the following:

mm Set the MIDI channel assignment for a voice: Drag the chan value up or down.

mm Set the split point between voices: Drag the split value up or down.

For complete information about the Chan and Split parameters of the Staff Style window, see 
Assign notes to voices and staffs on page 693

Add and delete staffs or voices
You can add staffs to a staff style, allowing you to create a two-staff piano style from a single-staff 
style, for example.

A staff can display multiple independent melodic lines, called voices. Some predefined staff styles 
display only a single voice, while others can display multiple voices (these are called polyphonic). 
You can choose polyphonic staff styles to display multiple voices (for choirs or polyphonic 
instruments), and can add voices to a staff style to display independent lines. Theoretically, a staff 
style can display up to 16 independent voices (but this may not be readable).

You can also duplicate staffs or voices.

Add a staff to a staff style
mm Click the Add Staff button (+) in the Staff section of the Staff Style window.

A new staff is added below the selected staff. If no staff is selected, the staff is added above the 
first (highest) staff in the staff style.

Add a voice to a staff style
mm Click the Add Voice button (+) in the Voice section of the Staff Style window.

A new voice is added below the selected voice. If no voice is selected, the voice is added above 
the first (highest) voice in the staff. If a staff is selected, the voice is added above the first (highest) 
voice in the staff.

Delete a voice or staff from a staff style
mm Select the voice or staff in the Staff Style window, then press Delete (or choose Edit > Delete).

When you delete a staff, all the staff’s voices are deleted.

Each staff is represented by an ID number. The ID numbers are assigned automatically and 
cannot be changed. 
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Copy and paste staffs or voices
In the Staff Style window, you can copy and paste staffs in a staff style, and also copy and paste 
voices in a staff.

Copy and paste staffs in a staff style
	 1	 In the Staff section of the Staff Style window, select the staff.

	 2	 Choose Edit > Copy from the Staff Style window menu bar (or press Command-C).

	 3	 Choose Edit > Paste from the Staff Style window menu bar (or press Command-V).

The copied staff is pasted above the selected staff. If no staff is selected, the copied staff is pasted 
below the last (lowest) staff in the staff style.

Copy and paste voices in a staff
	 1	 In the Voice section of the Staff Style window, select the voice.

	 2	 Choose Edit > Copy from the Staff Style window menu bar (or press Command-C).

	 3	 Choose Edit > Paste from the Staff Style window menu bar (or press Command-V).

The copied voice is pasted above the selected voice. If no voice is selected, the copied voice is 
pasted below the last (lowest) voice in the staff. If a different staff is selected, the copied voice is 
added is pasted below the last (lowest) voice in the selected staff.

Copy staff styles between projects
You can copy staff styles that you use frequently to other projects. You can import all staff styles 
from another project, or copy only selected staff styles.

Import all staff styles from another project
	 1	 Do one of the following:

•• Choose File > Project Settings > Import Project Settings.

•• Click the Browsers button  in the control bar, then click All Files.

	 2	 Navigate to and select the project file, then click the Import button.

Note:  If accessing the settings from the All Files Browser, you also need to click the Import 
Settings button, which appears after you click the Import button.

	 3	 In the Import Settings window, select the Staff Styles checkbox (and deselect all other settings 
that you don’t want to import), then click the Import button.

All staff styles from the other project are imported into the current one.

Copy selected staff styles from another project
	 1	 In the project that contains the staff styles you want to copy, open the Staff Style window. (Single 

view is displayed.)

	 2	 Double-click in the space below the Staff Style parameters to display a listing of all staff styles.

	 3	 Select the staff styles you want to copy, then choose Edit > Copy (or press Command-C).

	 4	 Open the Staff Style window in the target project, then choose Edit > Paste (or 
press Command-V).

Note:  If you copy a MIDI region from one project to another, and the staff style used by the 
original MIDI region doesn’t exist in the target project file, it is automatically copied, along with 
the MIDI region.
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Delete staff styles
You can delete staff styles in the Staff Style window in both Single view and List view. In LIst view 
you can select and delete several staff styles simultaneously.

Delete the current staff style in Single view
mm Choose New > Delete Style.

Delete multiple staff styles in List view
mm Shift-click the staff styles you want to remove, then choose Edit > Delete (or press the Delete 

key).

Tip:  In List view, you can use the Edit > Select Unused command, to select all staff styles that are 
currently not assigned to any regions or track instruments in the project.

Assign notes to voices and staffs
For staff styles with multiple staffs or voices, you can control which staff or voice a note is 
displayed on. You can assign notes to voices by defining a split point, or by assigning each voice 
to a separate MIDI channel.

When you use a split point to separate voices, the split point and all notes above it are displayed 
on the upper voice, while all notes below the split point are displayed on the lower voice. This is 
useful when there is a clear division in pitch between the two voices; for example, in a piano staff 
style when each hand plays in only one clef (treble or bass).

In cases where the division between voices needs to be more flexible, you can separate voices 
by assigning each voice to a different MIDI channel. This allows voices to cross while still being 
displayed independently. Notes not assigned to any MIDI channel are not displayed, allowing you 
to “hide” notes from display (such as improvised parts or trill notes, for example). This does not 
affect playback, but only the display of notes in the score (the playback channel is determined by 
the setting in the Track inspector).

If you record polyphonic voices separately in real time, you can set your keyboard or MIDI 
controller to the appropriate MIDI channel for each voice when you record, saving you from 
having to edit the channels afterward.

You can automatically split notes between two voices using the “Auto split notes in multi staff 
chord styles” Score preference. By turning on this preference, notes you play using a polyphonic 
staff style are automatically assigned MIDI channels matching the staff style’s voice assignments. 
Notes at, and above, the split point are assigned the channel of the first voice. Notes below are 
assigned the second voice’s channel. This creates a usable voice assignment, which you can 
edit later.

Using the Voice Separation tool, you can draw a separation line between notes on a staff to 
assign them to the predefined MIDI channels of the voices.

Voice Separation tool

Separate voices by split point
mm Choose a note pitch for the voice in the Staff Style window’s Split column. 
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Separate voices by MIDI channel
mm Assign a MIDI channel to each voice in the Staff Style window’s Chan column.

When you use MIDI channels to assign notes to staffs or voices:

•• You can edit the MIDI channel in the same way you do all other events, by selecting the events 
and changing the MIDI channel in the Event inspector or the Event List.

•• You can quickly change the MIDI channel of selected note events with the Event Channel 
+1 and Event Channel −1 key commands. These can be especially useful when used in 
combination with the Select Next Region/Event, or Set Marquee End to Next Transient key 
command and the Select Previous Region/Event, or set Marquee End to Previous Transient key 
command, which allow you to move the selection from note to note.

You can also use Score Editor functions designed to speed up the process of changing the MIDI 
channel settings of notes, in order to assign them to the specific voices. These include the Auto 
Split preference and the Voice Separation tool. 

Split previously recorded regions by MIDI channel
	 1	 Select the region.

	 2	 Choose Functions > Note Events > Assign MIDI Channels based on Score Split from the Score 
Editor menu bar (or use the corresponding key command). 

The region’s notes are assigned to voices in the staff style, according to the Auto Split pitch in the 
Score preferences.

Assign notes to MIDI channels using the Voice Separation tool
	 1	 Select the Voice Separation tool, then draw a line (between notes) where you want to separate 

the voices. 

Notes below the line are moved to the MIDI channel below their current assignment.

	 2	 If you make a mistake, move the pointer back slightly to the left.

The separation line is erased to the right of the tool, allowing you to try again.
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Add notes to a polyphonic staff style
You can “explode” polyphonic parts, displaying all voices on separate staffs, regardless of staff 
style settings. (Other voice parameters remain valid.) This makes it easier to add notes using 
the pointer.

If you add a note to a staff style that uses MIDI channels for voice separation, it’s automatically 
assigned the corresponding MIDI channel (of the staff that you add the note to). When you’re 
finished adding notes, turn off the Explode Polyphony setting so all voices are displayed correctly 
in one staff. 

If you add notes to a polyphonic staff without turning on the Explode Polyphony setting, the 
notes are assigned the MIDI channel set in the Insert Defaults of the Event inspector (but only if 
that channel is used by one of the voices in the staff).

Display polyphonic parts on separate staffs
mm Choose View > Explode Polyphony from the Score Editor menu bar (or use the corresponding 

key command).

Change the staff assignment of score symbols
In addition to notes, most other score symbols can be assigned to a particular staff in a multiple-
staff staff style. The Event inspector includes a Staff parameter where you can set the staff for 
these symbols.

Change the staff for a score symbol
	 1	 Select the symbol in the score.

You might need to use the Layout tool to select the symbol.

	 2	 In the Event inspector, drag the Staff number up or down to change the staff for the 
selected symbol.

Beam notes across staffs
Music for keyboard instruments, and other instruments notated on multiple staffs, can contain 
passages where notes on different staffs (played by the left and right hand, for example) are 
connected with a beam, to clarify that the musical phrase continues across the staffs.

In the Score Editor, only notes belonging to the same voice can be connected with beams. By 
default, notes of the same voice are normally all displayed on the same staff. Using the Score 
Editor’s Staff Assignment commands, you can display notes of the same voice on different staffs.

For example, the following image depicts a piano passage using the Piano staff style featuring 
two MIDI channels (1 and 2). The notes in the upper staff belong to voice one (MIDI channel 1). 
The notes in the lower staff belong to voice two (MIDI channel 2).

Using the Voice/Staff Assignment commands in the Score Editor’s Functions menu, you can place 
the right-hand notes falling below middle C in the bass staff, but maintain the beaming. 
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Before using the Voice/Staff Assignment commands, make sure that all the notes you want to 
connect with beams use the same MIDI channel (and all notes you want to appear in the other 
staff, not connected by beams, use another MIDI channel). Select notes one by one and view 
their MIDI channel assignment in the Event inspector.

Beam notes across different staffs
	 1	 If necessary, change the voice assignments for the notes that you want to connect with beams 

by doing one of the following:

•• Draw a line below the notes with the Voice Separation tool.

•• Select all notes, then, in the Event inspector, change their MIDI channel to match that of the 
upper voice.

The notes appear in the upper staff, possibly with multiple ledger lines.

	 2	 Select the notes you want to connect with a beam, then choose Functions > Note Attributes 
> Beaming > Beam Selected from the Score Editor menu bar (or use the corresponding key 
command).

	 3	 Select the notes to display in the bottom staff, then choose Functions > Note Attributes > Voice/
Staff Assignment > Staff Below Voice (or use the corresponding key command). 

The selected notes are moved down to the lower staff, but are still part of the upper voice.

In the reverse situation, where notes continue above the bass staff, with ledger lines, you would 
follow the opposite procedure: assign all notes to the lower voice, then move some notes to the 
upper staff by choosing Note Attributes > Voice/Staff Assignment > Staff Above Voice from the 
Score Editor menu bar.

	 4	 To display all selected notes in their original staff, choose Note Attributes > Voice/Staff 
Assignment > Default Staff from the Score Editor menu bar. 

Note:  By default, rests are displayed according to the Rest settings for the staff style. In the cross 
staff beaming example described above, however, most (or all) notes belong to the voice of the 
top staff, and the lower staff will contain rests—some even at positions occupied by notes. To 
avoid this situation, choose a staff style where the automatic display of rests is turned off for the 
bottom staff’s voice, then add rests manually from the Part box.



	 Chapter  20    View and edit music notation	 697

Use drum notation with mapped staff styles
In MIDI regions assigned to drum instruments, each MIDI note usually triggers a different sound. 
When viewed using a regular staff style, the notes have no apparent relationship to the sounds 
you hear. You can display these regions as a readable drum part with special drum note heads, 
using mapped instruments and mapped staff styles.

  When Additional Score Options is selected in the Advanced preferences pane, you can 
create and edit mapped staff styles. Mapped staff styles allow you to assign individual voices to 
drum groups, which use specific drum note heads to display note events. You can define the 
respective drum note head shapes in a Mapped Instrument window. 

The best way to create drum notation for an existing region is to open the Score Editor to view 
the MIDI region, and also open the Mapped Instrument window and the Staff Style window. This 
way, you can directly see how parameter changes affect the score display. 

Before defining the details of a mapped staff style, you should set up all drum groups, note head 
shapes, and relative note position parameters in the Mapped Instrument window. 
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Create a mapped staff style for drum notation
	 1	 Create a mapped instrument in the Environment, then double-click its icon. For details about 

creating mapped instruments, see Mapped instrument objects overview on page 781.

The Mapped Instrument window opens. Its default settings correspond to the General MIDI 
drum note assignments, but they can be edited.

In the columns to the far right are three parameters relevant to notation.

	 2	 In the Head pop-up menu, choose the shape of the note head for notes triggered by this 
particular pitch. 

A note must be assigned to a drum group to be displayed in a mapped staff style. If it’s not, it 
won’t be visible.

	 3	 In the Group pop-up menu, choose a drum group.

Some of the groups are predefined for the most commonly used drum sounds (Kick, Snare, 
Hi-Hat, Toms, Cymbals, and so on). 

Note:  If you want to define a new drum group for another instrument sound (such as 
tambourine), choose New Group from the pop-up menu, then double-click the entry to name 
the new drum group.

	 4	 Set the Rel. Pos. (Relative Position) parameter. 

The Relative Position parameter assigns the note to a line in the staff. The note position is relative 
to the top line of the staff. Integer values make the note fall on a line; fractional values result in a 
note position between two lines.

Note:  Positions can also be influenced in the Staff Style window, but this affects all notes of a 
particular drum group.

These options allow you to have two different MIDI notes (different bass drum sounds, for 
example) displayed in the same way in the score, or on the same line, but with different 
note heads.
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	 5	 Create a new mapped staff style by choosing New > Mapped Style in the Staff Style window, and 
inserting all staffs, voices, and drum groups as described above, and in Staff styles overview on 
page 684.

•• Staff section: Everything is identical to unmapped staff styles (with the exception of the missing 
Transpose and Key parameters, which wouldn’t make sense here).

•• Voice section: Below Voice (in the top header line), is a separate Voice column, where the 
different voices are numbered automatically. The staff style shown above contains one staff 
with five independent voices. 

•• Horizontal lines: Display the Staffs-Voices-Drum Groups hierarchy, indicating the 
borders between these elements. Each drum group belongs to the voice at the same 
horizontal position.

•• Pos parameter: Affects the vertical positioning of all notes in the corresponding drum group. 
The value shown here is an offset that is added to, or subtracted from, the relative positions (if 
defined for individual notes in the Mapped Instrument window).

Mapped staff style names are preceded by the # character in the Staff Style window. 

If you’re using several software instruments with different drum assignments, you can create a 
separate drum map for each instrument (in the Mapped Instrument window). The list of drum 
groups, however, is the same for all instruments in a project. This allows you to display different 
drum tracks with the same mapped staff style. All snare drums, for example, will be displayed in 
the same way.
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Predefined staff styles
A variety of predefined staff styles is available in the Score Editor. The following table lists each 
staff style with its Clef and Transposition parameters. 

Staff style Clef Transposition

Bass Bass clef -

Lead Sheet Treble clef -

Piano (two staffs) Treble/Bass clef -

Treble Treble clef -

Treble −8 Treble (−8) clef +1 octave

Treble +8 Treble (+8) clef −1 octave

Alto Sax Treble clef Eb (+9) 

Baritone Sax Bass clef Eb (+21)

Contrabass Bass (−8) clef +1 octave

Guitar Tablature display -

Guitar Mix (Tablature display and 
one staff)

Tablature display/Treble (−8) clef -

Guitar Mix 2 Treble (−8) clef/Tablature display -

Horn in Eb Treble clef Eb (−3)

Horn in F Treble clef F (+7)

Organ 1/1/5 (3 staffs) Treble/Bass/Bass clef -

Organ 1/3/5 (3 staffs) Treble/Bass/Bass clef -

Organ 1/3+4/5 (3 staffs) Treble/Bass/Bass clef -

Organ 1+2/3/5 (3 staffs) Treble/Bass/Bass clef -

Organ 1+2/3+4/5 (3 staffs) Treble/Bass/Bass clef -

Piano 1/3 (2 staffs) Treble/Bass clef -

Piano 1/3+4 (2 staffs) Treble/Bass clef -

Piano 1+2/3 (2 staffs) Treble/Bass clef -

Piano 1+2/3+4 (2 staffs) Treble/Bass clef -

Piccolo Treble clef −1 octave

Soprano Sax Treble clef Bb (+2)

Tenor Sax Treble clef Bb (+14)

Trumpet in A Treble clef A (+3)

Trumpet in Bb Treble clef Bb (+2)

Viola Alto clef -

Violoncello Bass clef -

# Drums Percussion Clef Mapped
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Create scores and parts using score sets

Score sets overview
You can use score sets to control which software instrument tracks appear in the score. Each 
project can contain as many score sets as needed. Score sets let you:

•• Produce a full score for a project together with individual parts

•• Reorder software instrument tracks in the score, independent of their order in the Tracks area

•• Provide a name (and, optionally, a short name) for each software instrument track displayed in 
the score, and when the score is printed.

•• Control which staffs are connected by brackets or bar lines

•• Exclude tracks from being displayed in the score (for example, tracks that only contain MIDI 
controller data)

•• Reduce or enlarge all staffs in each staff set using the Scale parameter, which allows you to use 
the same staff styles for the printout of full scores and individual parts

•• Select from two different parameter sets (Score or Part) for page margins, header space height, 
vertical distance between staff systems, and the maximum number of bars per line

You create and edit score sets in the Score Sets window.

Open the Score Sets window
mm Choose Layout > Score Sets from the Score Editor menu bar (or use the Show/Hide Score Sets 

Window key command).

If the All Instruments score set is chosen when you open the Score Editor, a warning indicates 
that this score set cannot be edited.
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Choose score sets
You can view available score sets and instruments in the Filter pop-up menu in the inspector. 
For new projects, the only available score set is All Instruments, which displays all instruments 
(depending on the display level). 

Choose a score set
mm Choose a score set from the Filter pop-up menu at the top of the inspector.

The display of a score set depends on the display mode. Because Content Link and Content 
Catch display only one region at a time, it’s usually best to set the Link mode to Off, once the 
desired score set is fully displayed. If only one MIDI region is displayed, double-click below the 
staff, which displays the full score; then set the Link mode to Off. For information about Link 
mode, see Control window relationships using Link mode.

Tip:  You can open multiple Score Editor windows, each showing different display levels and 
different score sets.

Create and delete score sets
When you open a Score Editor window while several regions are selected in the Tracks area, 
Logic Pro automatically creates a score set containing the instruments of the selected regions. 
You can also create a score set in the Score Sets window. Score sets you create are saved with 
the project.

Create an empty score set
mm Choose New > New Empty Set in the Score Sets window.

You can insert instruments into the empty score set, one at a time.

Create a copy of the selected score set
mm Choose New > Duplicate Set in the Score Sets window.

Create a score set for selected instruments
	 1	 Select at least one MIDI region for all software instrument tracks you want to include in the 

score set.

	 2	 Choose Layout > Create Score Set from Selection (or use the corresponding key command) in 
the Score Editor. 

A new score set is created and displayed, which consists of all instruments used by the currently 
selected MIDI regions. Score sets created this way are automatically named after the instruments 
they contain.
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Create a score set containing all software instrument tracks in the Tracks area
mm Choose New > New Complete Set in the Score Sets window. 

If several instruments or staffs use the same MIDI sound for playback (with the same MIDI 
channel on the same MIDI instrument), and you want to display these staffs with different 
instrument names in the score, you need to create a separate track instrument for each staff, in 
the Tracks area.

Delete a score set
mm Select the score set in the Score Sets window, then choose New > Delete Set.

Edit score set parameters
You can edit parameters for new and existing score sets in the Score Sets window.

Edit parameters for the selected score set
Do any of the following:

mm To rename the score set: Double-click the name in the left column of the Score Sets window, then 
enter a new name in the field. 

mm To place the insert mark: Click the narrow column to the left, or make multiple selection marks by 
dragging vertically. 

mm Instrument: This column shows which instruments are included in the score set, and their 
(vertical) order of appearance in the score. Track instrument icons are also displayed in this 
column, at the highest zoom level.

mm To set the full name: Click the Full Name column to open a name field. By default, the name of the 
track instrument is used for the instrument name in the score. To change the name, select the 
default “@(reference)” text, and enter a new name.

Region parameters for instrument names are set in the Numbers & Names pane of the Score 
project settings. (See Numbers & Names settings on page 897.)
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mm To set the short name: Click the Short Name column to open a field where you can enter the 
short name. The short name for each instrument is used if Short Names is chosen in the Project 
Settings > Score, Numbers & Names > 1st Staff and Other Staves pop-up menus. 

mm To set which staffs are connected by brackets and bar lines: Drag vertically in the appropriate 
column, until you see the appropriate display. You can define which staffs in the score set are 
connected by brackets or bar lines (either at the beginning of each staff, or throughout), in the 
last four columns.

Brackets and bar lines can also be interrupted between staffs, allowing you to form groups of 
connected instruments in a score. If you want to delete a line or bracket, grab the corresponding 
symbol at its end point (bottom), and drag it upward, until it disappears. You can use the same 
method to shorten lines.

Bar line connections can also be edited directly in the score. Click the upper end of a bar line to 
connect it to the next (higher) staff. Repeating the procedure disconnects the bar lines.

Change the instruments in a score set
You can add instruments to a score set, replace an existing instrument with a different one, and 
change the order of instruments.

Add an instrument to a score set
Do one of the following:

mm Set the insert mark where you want to add an instrument, then choose New > Add 
Instrument Entry.

mm Double-click below the instrument list.

Replace an instrument in a score set
mm Click-hold the name of the instrument you want to replace in the Instrument column, then 

choose an instrument from the pop-up menu.

Reorder instruments in a score set
	 1	 Select the instrument you want to move by clicking in the margin to the left of the 

instrument name.

	 2	 Cut or copy the instrument.

	 3	 Click in the margin to the left of the instrument list at the point where you want to add the 
instrument, then paste the instrument.
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Resize score sets
You can resize a score set to between 50 and 200 percent of its original size. Scaling affects the 
staffs in the score, the distance between staffs, all symbols associated with staffs (notes, rests, 
and other symbols), text (including lyrics), and the thickness of slurs and ties. Scaling doesn’t 
affect global text objects (header text, or text inserted outside the margins) and text such as 
page numbers.

Scaling also doesn’t affect instrument parts that are created by extracting parts (as described 
below; see Extract parts from the score on page 706). This lets you use the same staff styles for 
both full scores and parts. In extracted parts, the staffs appear at their original size; in the full 
score, their size is defined by the Scale parameter.

Scale a score set
mm Select the score set in the Score Sets window, then set the Scale parameter to a new value.

Note:  Because the All Instruments score set can’t be edited (and therefore, can’t be scaled), you 
must create a dedicated score set for the full score, in most cases.

Create separate layouts for a full score and parts
You can define separate layout parameters for a full score and its parts, then choose which 
parameters a score set uses.

Create separate layout parameters for a full score and parts
	 1	 Open the Global Score project settings by choosing File > Project Settings > Score (or use the 

Open Score Project Settings key command), then click the Global tab.

The Global pane offers separate page layout parameters for score and parts. 

	 2	 Edit the score and part layout parameters, including the top, bottom, left, and right margins; 
header space; line distance; and maximum number of bars per line. 

Choose the layout parameters used by a score set
mm In the Score Sets window, choose either Score or Parts from the Format pop-up menu. 

For the default All Instruments score set, the Score format is used, except when a single region is 
displayed. In this case, the Parts format is used.
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Extract parts from the score
You can quickly extract a single instrument from the score, instead of creating a score set for 
every instrument in order to produce parts. 

Using this method, only the track instrument names are used as instrument names in the 
score. So, if you use this method to print your parts, you see the real instrument names of the 
instruments as displayed in the Tracks area.

Extract an instrument part
mm Option-click the Score Set pop-up menu at the top of the inspector, then choose the instrument 

from the list.

Import score sets from other projects
You can import score sets from other projects.

Import score sets from another project
	 1	 Do one of the following:

•• Choose File > Project Settings > Import Project Settings (or use the corresponding key 
command).

•• Click the All Files tab in the Browser.

	 2	 Navigate to and select the project file, then click the Import button.

Note:  If using the All Files Browser, you also need to click the Import Settings button, which 
appears after you click the Import button.

	 3	 In the Import Settings window, select the Score Sets checkbox (and deselect all other settings 
that you don’t want to import), then click the Import button.

All score sets are imported from another project into the current project.
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Edit the score layout

Score layout overview
Once you’ve added notes and symbols to your score, and edited individual staffs, the next 
step is to refine the overall score layout. This process typically involves repositioning staffs, as 
well as adjusting the number of bars per line, setting page margins, and changing other Score 
project settings.

When editing the score layout, it’s recommended that you work in Page view, which displays 
as many facing score pages as possible, depending on the size of the Score Editor window and 
current zoom level.

You can choose different page display options that are useful for various printing or layout tasks 
in Page view. The page display options include:

•• Print View: Shows the score as it will be printed. Print view can only be turned on when Page 
view is active.

•• Show Margins: Displays page margins onscreen. These are not printed.

•• Show Pages in Pairs: Shows facing pages of the score. This setting depends on the zoom 
settings and Scale region parameter.

•• Show Page Rulers: Displays horizontal and vertical rulers that makes precise layout tasks easier.

Switch to Page view
mm Do one of the following:

•• Choose View > Page View from the Score Editor menu bar.

•• Click the Page View button  in the Score Editor menu bar.

Change page display options
mm Choose View > Page Display Options from the Score Editor menu bar, then choose 

display options.

To choose page display options, you must be in Page view.

Jump to a specific page of the score
	 1	 In Page view, choose View > Go to Page from the Score Editor menu bar.

	 2	 Enter the page number, then click OK.

The playhead is automatically set to the beginning of the selected page, unless the sequencer is 
running when you click OK. In this situation, Catch mode is turned off.

You should use Linear Score view for editing, as screen redraws are much faster, especially on 
slower computers. 
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Edit line breaks
You can set line breaks individually for each score set, and also for each extracted part. Line 
breaks are saved with the project.

By default, Logic Pro creates automatic line breaks based on the Spacing and Maximum Bars/Line 
settings in the Global Score project settings. You can override automatic line breaks using the 
Layout tool in Page view, and can also create line breaks by adding a Line Break symbol from the 
Part box in any view.

For example, if the Global Score project setting for Maximum Bars/Line is 6, you can move 
additional bars into a line using the Layout tool. Any unedited lines will still contain no more 
than six bars. The full number of bars is only displayed if the spacing settings are low enough to 
allow the proper display of that many bars.

For information about the Global project settings, see Global Score settings. For information 
about adding line break symbols, see Add page and line break symbols.

Note:  If you drag more bars into a line than would be displayed using the automatic line break 
function, overlapping notes and symbols may result.

Move a bar up or down to the previous or next staff
mm In Page view, grab the bar (or bars) with the Layout tool and drag it down (the pointer changes 

to a hand with a downward-pointing thumb), then release the mouse button.

The bar is moved to the next staff system, and the remaining bars in the line are distributed 
evenly over the entire width of the page. 

You can also move the first bars of a staff upward into the preceding staff, by dragging them up 
with the Layout tool.
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Edit line breaks using the shortcut menu
	 1	 Control-click a bar line.

	 2	 Choose a setting from the shortcut menu to add or delete a line break, or return to the default 
line break.

When you move a bar with the Layout tool, all manually edited line breaks in subsequent lines 
are deleted, and automatic line breaks are recalculated from that line downward. If you want 
to avoid having later lines recalculated, hold down Option while moving the bars with the 
Layout tool. This limits the line break to the staff systems you are editing; other staff systems 
are unchanged.

Line and page breaks
You can set page breaks individually for each score set, and also for each extracted part. Page 
breaks are saved with the project. For information, see Add page and line break symbols.

When you add a Page Break symbol from the Part box, all bars following the page break are 
moved to the following page. Bars on both preceding and following pages are automatically 
adjusted in accordance with the Score project settings (discussed in the Edit line breaks on 
page 708 section). All staffs in the score are affected.

Edit local margins
You can move the left and right margins of each individual staff system with the Layout tool, 
so they don’t align horizontally with the page margins. Local margins are saved as part of the 
current score set, allowing different settings for each score set.

Move the left or right margin of a staff system
	 1	 In Page view, choose the following settings from the Score Editor’s View > Page Display Options 

submenu:

•• Print View

•• Show Margins

	 2	 Click-hold (with the Layout tool) a little inside the beginning or end of the staff, then drag to the 
left or right.

During this process, Left or Right Staff Margin appears in the help tag.

Note:  When altering margins, the number of bars per line adapts automatically (unless you have 
manually adjusted line breaks beforehand). If the line is shortened, bars may be moved down 
to the next line, depending on the Spacing parameters in the Global pane of the Score project 
settings. (See Global Score settings on page 894.)

Realign an edited margin with the other staffs
mm Double-click at the end (or beginning) of the margin with the Layout tool. 

Delete all line breaks and edited margins in the current score set
mm Choose Layout > Reset Line Layout from the Score Editor menu bar.
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Change the margin and header values
You can change the Margin and Header Space project settings directly in Page Print view.

Change the margin and header space values
	 1	 In Page view, choose the following settings from the Score Editor’s View > Page Display Options 

submenu:

•• Print View

•• Show Margins

	 2	 Change the margin values by dragging the orange lines.

	 3	 Change the header space value by dragging the purple line. 

Only the currently displayed setting (full score or part) is affected.

Use external symbol fonts
You can use an external (third-party) symbol font such as the Sonata font from Adobe, the 
Jazzfont, or the Swingfont (not included with Logic Pro) for the display and printout of notes and 
symbols, instead of the internal Logic Pro score font. The external font must be properly installed 
on your computer.

Use an external symbol font in the Score Editor
mm Choose Logic Pro > Preferences > Score > “Use external symbol font (if available),” then choose 

the font you want to use from the pop-up menu.
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Share the completed score
When you’re ready, you can print the score, save it as a PDF file, or export as an image using the 
Camera tool. The last method is most helpful if you want to export only a section of the score. 
Whichever method you choose, the printed score is identical to the Score Editor’s Page view 
display, except for the following items that are visible onscreen, but not printed:

•• The dashed lines that represent page and header margins, and borders between staff systems

•• The pointer and the playhead

•• Colors for page margins and staff lines of selected MIDI regions

•• Hidden time signature changes

•• Hidden note heads (displayed in gray on the screen) and their ties

•• Hidden bar lines (displayed as gray lines on the screen)

•• Hidden N-tuplet numbers

Print the score
	 1	 Choose the appropriate paper size and format in the File > Page Setup window.

	 2	 Make sure that the Score Editor (with the intended Print view) is the active window.

	 3	 Choose File > Print (or press Command-P).

A dialog appears from which you can choose available options, such as which page numbers you 
want to print, the number of copies, and whether to “print” to (Save as) a PDF file. (The options 
may vary slightly for different printers.)

	 4	 Choose the options you want to use, then click the Print button.

Export the score to a graphics file
	 1	 Choose one of the following Camera Tool settings in the Logic Pro > Preferences > Score pane:

•• Clipboard: The image is copied to the Clipboard so it can be pasted directly into other 
applications, without saving it as a separate file.

•• PDF file: The image is saved as a PDF file. In the dialog that appears, enter a filename and path 
(when the Camera tool is used to take a snapshot of the score).

	 2	 Make sure you’re viewing the score in Page view, then select the Camera tool.

	 3	 Drag across the part of the score section you want to export. A selection rectangle appears as 
you drag.

As soon as you release the mouse button, a PDF file of the selected area is created (or the 
selection is copied to the Clipboard, depending on the Camera Tool setting you chose).

When doing layout work that requires precision, such as positioning symbols and text elements, 
it’s recommended that you work at high zoom levels. You can easily switch back and forth 
between a normal and enlarged view of the display using the Zoom tool (or drag to select while 
holding down Control, to enlarge the selected area).
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Customize the Score Editor

Choose a color mode
The settings in the Score Editor’s View > Colors menu determine the color mode for the active 
Score Editor window. These settings have priority over all other color settings.

Choose the color mode for the Score Editor
mm Choose one of the following from the View > Colors submenu in the Score Editor menu bar:

•• Normal: Colors are assigned in accordance with the color settings in staff styles and note 
attributes. As long as these settings haven’t been changed in new projects, the result is a 
regular black-and-white printout, and black notes on a yellow background onscreen.

•• Show Pitch: Applies colors in accordance with note pitches. The colors of notes can be edited 
in the Functions > Note Attributes > Colors window. This window also allows you to determine 
whether notes with accidentals match the color of those without accidentals, or if each note in 
the chromatic scale has its own color.

•• Show Velocity: Applies eight different colors, in accordance with MIDI velocity. These colors can 
also be edited in the Layout > Colors window.

•• Show Voice Assignment: Assigns different colors to different voices. This setting only makes 
sense in staff styles that contain more than one voice. This mode employs the colors of 
the User Palette, which can also be found and edited in the Layout > Colors window, or by 
opening File > Project Settings > Score > Colors.

•• Force Black & White: Does exactly what the name implies. This mode is useful when color 
options have been used in staff styles, or have been assigned to notes using note attributes, 
but you want to print a black-and-white score.

Show or hide folder contents
If the current display level allows more than one MIDI region to be viewed simultaneously (linked 
or unlinked), the View > Explode Folders setting lets you display, and print, the contents of 
different display (folder) levels simultaneously. 

If the current display level contains folders, their contents are also displayed in the score.

Note:  If this setting is not selected, folders appear as gray beams in Linear Score view, and aren’t 
shown at all in Page view.

Show folder contents in the score
mm Choose View > Explode Folders from the Score Editor menu bar.

Display global tracks
In Linear view, you can display global tracks in the Score Editor. You choose which global track 
types are shown in the Score Editor, independent of those shown in the Tracks area.

Show global tracks in the Score Editor
mm Choose View > Global Tracks from the Score Editor menu bar.
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Display instrument names
Use the Show Instrument Names setting to show the names of (used) track instruments, to the 
left of the score display.

Display instrument names in the Score Editor
mm Choose View > Show Instrument Names from the Score Editor menu bar.

Display duration bars
You can show a graphical representation of a note’s duration by displaying duration bars in the 
Score Editor.

Display duration bars in the Score Editor
mm Choose View > Duration Bars in the Score Editor, then choose one of the following display 

modes:

•• Off: No duration bars are displayed.

•• Selected Notes: Duration bars are displayed for selected notes only.

Note:  Duration bars for selected notes are displayed according to the Selection Color setting 
in Logic Pro > Preferences > Score.

•• All Notes: Duration bars are displayed for all notes in the score.

Note:  You can also use the Toggle Duration Bar Display key command, which toggles between 
Off and the last selected display mode.

Change the length of duration bars
When duration bars are displayed in the Score Editor, you can change their length.

Change the length of a duration bar
mm Place the pointer over the end point of the duration bar, then drag horizontally when the pointer 

turns into the length change icon.
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Display guide lines
You can show an object’s exact time position by displaying guide lines in the Score Editor. Guide 
lines show exactly the relation of symbols, staves, and time positions).

Display guide lines in the Score Editor
mm Choose View > Guides in the Score Editor menu bar, then choose one of the following display 

modes:

•• Off: No guides are displayed.

•• Dragged Objects: Guides are displayed while objects are dragged.

•• Selected Objects: Guides are displayed for selected objects only.

Note:  Guide lines for selected notes are displayed according to the Selection Color setting in 
Logic Pro > Preferences > Score.

•• All Objects: Guides are displayed for all objects.

Note:  You can also use the Toggle Guide Lines Display key command, which toggles between All 
Objects and the last selected display mode.
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Sharing overview
Logic Pro provides a variety of options you can use to distribute your projects.

You can:

•• Bounce a project to an audio file in a variety of file formats.

•• Burn a project to a CD or DVD

•• Share a project to iTunes

•• Share a project to the Media Browser to use in other applications

•• Share a project to your SoundCloud account

•• Export an AAF file for use with Avid Pro Tools

•• Export a project as an XML file for use with Final Cut Pro

•• Export a score as a MusicXML file for use with music notation applications

Bounce a project

Bounce a project to an audio file
You can render, or bounce, a project to a single audio file or to multiple audio files. A project 
can be bounced to several different file formats simultaneously, and a surround project can be 
bounced to a set of surround audio files.

Projects can be bounced either in real time or offline (which is typically faster). All parameters, 
effects, and automation on the unmuted tracks in the project are recorded as part of the bounce 
file. 

The format (stereo, mono, or surround) of the resulting bounce file (or files) depends on the 
format of the output channel strip. Output 1-2 is the default output channel strip used for 
bounces, and produces a stereo audio file. When the output channel strip is set to mono, a mono 
audio file is generated.

Bounce files can be reused in Logic Pro, saving processing resources by replacing or bypassing 
multiple regions, instruments, and effects. Bounces can also be used with other music 
applications and devices, sent to mastering facilities, posted on the Internet (on a webpage, or in 
the iTunes Store, for example), added to an iTunes playlist, or uploaded to a mobile device such 
as an iPod.

Share projects 21
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Bounce the current project to an audio file
	 1	 In the Tracks area or the Mixer, make sure that the tracks you want to include in the bounce are 

routed to the main output (Output 1-2) and are not muted.

If your project has multiple output channel strips, you can bounce only the tracks routed to a 
specific output channel strip using the Bnce button on that channel strip. For information about 
configuring output channel strips, see Use output channel strips.

	 2	 Choose File > Bounce > Project.

	 3	 In the Bounce dialog, select one or more destination formats in the Destination area.

	 4	 When you select a destination format, bounce options for that format appear to the right of the 
Destination area. For each selected destination format, choose bounce options.

	 5	 To limit the bounce to only part of the project, adjust the Start and End value sliders. You can 
click the up and down arrows, or click one of the numerals and enter a new value.

If Cycle mode is on when you choose File > Bounce, only the part of the project enclosed by the 
cycle area is bounced. You can adjust the Start and End value sliders to change what part of the 
project is bounced. For more information on setting the bounce range, see Set the bounce range.

Tip:  To avoid having reverb and other effect tails cut off at the end of the project, set the end 
position of the bounce a little bit past the end of the last region.

	 6	 Set the bounce mode by selecting one of the two Mode buttons:

•• Realtime: Performs the bounce in real time. Use this setting when you want to bounce audio 
and software instrument tracks, or external MIDI sound sources that are routed to the Mixer 
via aux channels.

•• Offline: Bouncing offline can be faster than real time for more complex projects, and can 
perform bounces not possible in real time (because they might exceed the processing power 
of your computer).

Only internal sources (audio or software instrument tracks) can be bounced offline; not MIDI 
tracks or audio channel inputs. Offline bouncing is available only for output channels of 
devices using native (Core Audio) audio drivers; not for DSP-based audio hardware (which can 
be bounced only in real time.) Other software applications that are routed to the Mixer via 
ReWire can be bounced offline.

	 7	 For additional control over effect tails, select either of the following Mode options:

•• Bounce 2nd Cycle Pass: The bounce process takes two repetitions of the cycle range into 
account, with the creation of the bounce file starting at the second repetition. This is useful if 
you want effect tails (from the first cycle pass) to be added to the start of the bounce file.

•• Include Audio Tail: The bounce file is extended as far as necessary to include any instrument 
release and effect tail.

Note:  Some plug-ins, including plug-ins used for mastering and the test oscillator plug-in, can 
add noise to the signal. Include Audio Tail should not be selected when using these plug-ins, as 
the resulting bounce file would be too long.

	 8	 Choose a normalization setting from the Normalize pop-up menu:

•• Off: No normalization is applied.

•• Overload Protection Only: Downward normalization takes place only for overloads (levels above 
0 dB, which would lead to clipping), but no normalization takes place for lower levels.

•• On: The project (incoming audio) is scanned for the highest amplitude peak, then the level is 
increased so that the peak is at the maximum possible level (without clipping).

	 9	 To add PCM, MP3, or M4A bounce files to the Project Audio tab, select Add to Project.
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	 10	 Click Bounce.

Depending on the length and complexity of the project, the bounce process may take a few 
moments to complete.

Set the bounce filename and location
By default, the name of the bounce file matches the selected output channel strip (Output 1-2, if 
the project was bounced using the File > Bounce command.) Bounce files are saved by default to 
the ~/Music/Logic/Bounces folder, but you can specify a new location. The new location is used 
for subsequent bounces.

When you bounce a project, you can change the name and choose a different location to save 
the bounce file (or files).

	 1	 To rename the bounce file, enter a new name in the Save As field.

	 2	 Browse to the location where you want to save the bounce file. You can click the New Folder 
button in the lower-left corner of the Bounce window to create a new folder at any location.

	 3	 Click Bounce.

When you bounce to multiple destination files, all the resulting files are saved in the chosen 
folder. All files have the same filename, but with the appropriate file extensions (.aiff, .mp3, .m4a, 
and so on).

You can also bounce individual tracks in place, or bounce all tracks in place.

Another option is to burn a project to a CD or DVD at the same time you bounce the project.
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Burn a project to a CD or DVD
In addition to bouncing a project to an audio file, you can burn the project to a CD or DVD (in 
DVD-Audio format). Logic Pro can directly burn Red Book audio to blank CDs or burn DVD-Audio 
to blank DVDs. You can bounce to one or more audio formats and burn the project to disc at the 
same time.

Burn the current project to a CD or DVD
	 1	 In the Tracks area or the Mixer, make sure that the tracks you want to include are routed to the 

main output (Output 1-2) and are not muted.

If your project has multiple output (channel strips), you can select any of the outputs to bounce 
only the tracks routed to those outputs. For information about output channel strips, see Use 
output channel strips.

	 2	 Choose File > Bounce > Project.

	 3	 In the Bounce dialog, select Burn to CD/DVD as one of the destination formats in the 
Destination area.

Note:  Selecting Burn to CD/DVD automatically disables the PCM > Surround and Split Stereo 
options, because CD or DVD-Audio makes use only of interleaved stereo files.

	 4	 Choose one of the following options from the Mode pop-up menu:

•• CDDA: Burns the project to a CD. If the selected sample rate (chosen in the PCM pane) is 
higher than 44.1 kHz, a copy of the bounced PCM file is created (with an automatic sample 
rate conversion to 44.1 kHz) before encoding. This conversion takes place because the CD 
Audio format (Red Book) does not support sampling rates higher than 44.1 kHz.

•• DVDA: Burns the project to a DVD. Any sample rate up to 192 kHz can be used for stereo files, 
and up to 48 kHz for surround files.

The Media Status field shows whether or not a disc is inserted in the chosen disc burner. Make 
sure you insert a disc before burning.
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	 5	 Set burn options by selecting either of the following Mode checkboxes:

•• Simulate write only: This option simulates a CD/DVD burn, but doesn’t write data to the blank 
media. This option can be used either alone or in conjunction with the “Write as multi-session” 
option (if burning a CD).

•• Write as multi-session: This option is only available when CDDA is chosen in the Mode pop-up 
menu. This option lets you add a data session to the same CD at a later date—to add the 
project folder, for example.

	 6	 Choose the built-in optical disc drive or another disc burner connected to your computer from 
the Device pop-up menu.

	 7	 Choose the write speed for the disc burner from the Speed pop-up menu.

The first time you open the Speed pop-up menu, Logic Pro queries the disc burner for available 
speeds. This can take a few moments.

	 8	 Choose a dithering algorithm from the Dithering pop-up menu. For details on dithering options, 
see About dithering algorithms.

Note:  If you attempt to switch the PCM Resolution to 16 Bit when in DVDA burn mode, DVD 
burning is automatically disabled (following a warning).

	 9	 To limit the bounce to only part of the project, adjust the Start and End value sliders.

You can click the up and down arrows, or click one of the numerals and enter a new value.

By default, the entire project is bounced. If Cycle mode is on when you choose File > Bounce, 
only the part of the project section inside the cycle area is bounced. You can adjust the Start and 
End value sliders to change what part of the project is bounced. For more information on setting 
the bounce range, see Set the bounce range.

	 10	 Choose a normalization setting from the Normalize pop-up menu:

•• Off: No normalization is applied.

•• Overload Protection Only: Downward normalization takes place only for overloads (levels above 
0 dB, which would lead to clipping), but no normalization takes place for lower levels.

•• On: The project (incoming audio) is scanned for the highest amplitude peak, then the level is 
increased so that the peak is at the maximum possible level (without clipping).

	 11	 Click the Bounce and Burn button.
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Set the disk filename
By default, the name of the burned disk matches the selected output channel strip (Output 1-2, if 
the project was bounced using the File > Bounce > Project command.) When you burn a project, 
you can change the filename for the disk.

mm To change the filename, enter a new name in the Save As field, then click Save.

When you bounce to multiple destination files, all the resulting files are saved in the chosen 
folder. All files have the same filename, but with the appropriate file extensions (.aiff, .mp3, .m4a, 
and so on).

Set the bounce range
By default, when you bounce a project (by choosing File > Bounce > Project), the entire project 
from start to end is bounced. You can bounce only part of a project by setting the bounce range 
before performing a bounce. There are several ways to set the bounce range.

Set the bounce range
Do one of the following:

mm Turn on Cycle mode. When Cycle mode is on, the bounce range matches the locator positions.

mm Select one or more regions in the Tracks area. The bounce range matches the selected area.

mm In the Bounce dialog, adjust the Start and End positions. When you open the Bounce dialog, the 
Start and End positions match the bounce range (or the length of the project, if no regions are 
selected and Cycle mode is off).
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Set bounce options

PCM bounce options
When you select PCM in the Destination area of the Bounce dialog, the following options are 
available:

•• File format pop-up menu: Choose the PCM file format (AIFF, Broadcast Wave, or CAF). PCM 
files can be automatically added to the Project Audio Browser by selecting the Add to 
Project checkbox.

•• Resolution pop-up menu: Define the resolution of the bounce file. The options are 16 Bit (for CD 
delivery), 8 Bit (for multimedia productions,) or 24 Bit (for mastering to DVD).

•• Sample Rate pop-up menu: Choose the sample rate for your bounce file. Options range from 
11,025 to 192,000 Hz, including the three most commonly used sample rates: 44,100 (CD-DA), 
48,000 (DAT), and 96,000 (DVD).

•• File Type pop-up menu: Choose either Split (for use in Digidesign Pro Tools), or Interleaved (for 
further use in Logic Pro or with CD writing software).
Note:  Choosing Split disables Burn to CD/DVD, if it’s chosen in the Destination area.

•• Dithering pop-up menu: Dithering is recommended when bouncing 24-bit recordings into 
16-bit files. For details on dithering options, see About dithering algorithms.

•• Surround Bounce checkbox: Available when Additional Surround Options is selected in the 
Advanced preferences pane. Select this checkbox to bounce all outputs in the project 
surround format (File > Project Settings > Audio > Surround Format).
All surround outputs are bounced simultaneously, regardless of which output channel’s 
Bounce button is clicked (or if the Bounce window was opened via File > Bounce). Each 
surround channel is bounced to a separate file. 

The Logic Pro > Preferences > Audio > I/O Assignments pane gives you access to the 
surround settings.

•• You set the stereo and surround output formats in the Output pane.

•• The Bounce Extensions pane displays the extensions that are added to the filenames 
resulting from a stereo or surround bounce. Select the various fields to edit the extensions.

•• You set the stereo and surround input formats in the Input pane.

Note:  Selecting the Surround Bounce option deselects the MP3, M4A: AAC, and Burn 
checkboxes in the Destination pane if they’re selected.

•• Add to Project checkbox: Adds the bounced PCM file to the Project Audio Browser.
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MP3 bounce options
You can bounce projects to MP3 (MPEG-2, Audio Layer 3) format files. The MP3 format was 
developed by the Fraunhofer Institute, and allows high compression rates while maintaining 
reasonable audio quality. MP3 is a widely used standard for audio file exchange over the Internet.

Because the MP3 file format involves a loss of audio quality, you shouldn’t use MP3 files during 
production if you have access to the same audio data in non-lossy formats such as AIFF or WAV.

Bounced PCM files are also used for encoding to MP3/M4A: AAC. Note that this occurs before 
dithering takes place. 

Note:  The MP3 format doesn’t support sampling rates higher than 48 kHz. If the selected sample 
rate is higher than 48 kHz, a temporary copy of the PCM file (with a 48 kHz sample rate) is 
created before the project is bounced to MP3 format. If PCM is unselected in the Destination 
area of the Bounce dialog, a temporary PCM file is created and used as a source for bouncing to 
MP3 or M4A: AAC, or for burning to a CD (depending on which options are selected).

Selecting the MP3 option in the Destination area automatically disables the PCM > Surround 
option. This is because the MP3 format doesn’t support surround. However, Split Stereo format is 
possible, even if the encoded MP3 file is set to Joint Stereo mode.

When you click MP3 in the Destination area, the following options are available:

•• Bit Rate (Mono/Stereo) pop-up menus: MP3 bit rates are available between 32 kbps and 
320 kbps, but default to 80 kbps mono, and 160 kbps stereo. These rates offer acceptable 
quality and good file compression.

For enhanced audio quality, you can choose:

•• 96 kbps for mono streams

•• 192 kbps for stereo streams

You can choose higher rates, but the quality improvement afforded by bit rates above 
96/192 kbps is nominal. Note that the higher the bit rate, the larger the file size of the bounce 
file will be.

•• Use Variable Bit Rate Encoding (VBR) checkbox: Variable Bit Rate encoding compresses simpler 
passages more heavily than passages that are (more) harmonically rich, generally resulting in 
better quality MP3 files.
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Because not all media players can accurately decode VBR-encoded files, this option is off by 
default. If you know that your target listeners can decode VBR-encoded files, you can turn this 
option on.

•• Quality pop-up menu: Keep this set to Highest (the default) whenever possible. Reducing the 
quality shortens the conversion process, but at the expense of audio quality.

•• “Use best encoding” checkbox: Like the Quality parameter, if you deselect this option, you 
shorten the time needed to bounce the file at the price of audio quality. This should always be 
selected, unless conversion time is an issue.

•• “Filter frequencies below 10 Hz” checkbox: When this option is selected, frequencies below 10 Hz 
(which usually aren’t reproduced by speakers, and aren’t audible to human ears at any rate) 
are removed. This leaves slightly more data bandwidth for the frequencies that are audible, 
resulting in an improvement of the perceived quality. Only deselect this option if you’re 
experimenting with subsonic test tones.

•• Stereo Mode pop-up menu: Choose Joint Stereo or Normal stereo mode. Depending on the 
original file, these settings may (or may not) offer any audible difference. Experiment with both 
settings to see which provides better results.

•• “Write ID3 tags” checkbox: Writes ID3 tags to the file.

•• ID3 Settings button: Opens a dialog where you can edit and configure ID3 tags.

To edit an ID3 tag, double-click any of the Content column fields to the right of the 
corresponding ID3 Frame column entry, and enter your text.

Select the “Use default values” checkbox to display default settings for certain Content 
columns, such as the Project Title and Tempo (Beats Per Minute) columns. Selecting “Use 
default values” also sets the Initial Key column to the first entry shown in the Signature track. 
(This defaults to C if no key has been set for the project). 
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M4A: AAC bounce options
When you click M4A: AAC in the Destination area of the Bounce dialog, the following options are 
available:

•• Encoding pop-up menu: Choose Advanced Audio Codec (AAC) or Apple Lossless to set the 
encoding for your .m4a (commonly referred to as MP4) file. While both encoding algorithms 
provide high-quality audio, the AAC format uses a higher compression ratio, resulting in 
smaller file sizes.

Choosing the M4A: AAC option in the Destination area disables PCM > Surround. Split Stereo is 
still available.

If the selected sample rate is higher than 48 kHz, a copy of the bounced PCM file is created 
(with an automatic sample rate conversion to 48 kHz) before encoding. This conversion takes 
place because the M4A: AAC format does not support sampling rates higher than 48 kHz.

•• Bit Rate pop-up menu: Choose a rate between 16 kbps and 320 kbps.

Note:  This parameter is only available when the AAC codec is chosen.

•• “Encode with variable bit rate (VBR)” checkbox: Variable Bit Rate encoding compresses simpler 
passages more heavily than passages that are (more) harmonically rich, generally resulting in 
better quality files.

Because not all media players can accurately decode VBR-encoded files, this option is off by 
default. If you know that your target listeners can decode VBR-encoded files, you can turn this 
option on.
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About dithering algorithms
Logic Pro includes the professional POWr (Psychoacoustically Optimized Wordlength Reduction) 
and UV22HR dither algorithms, designed to convert 24-bit recordings to 16-bit files (as required 
for CD burning, for example). Dithering can be used when:

•• Burning audio files to a CD

•• Bouncing audio files to disk

•• Exporting AAF files (See Export a project as an AAF file on page 728.)

The following dithering options are available in the Bounce dialog:

•• None: No dithering is applied.

•• POWr #1 (Dithering): A special dithering curve is used to minimize quantization noise.

•• POWr #2 (Noise Shaping): Additional noise shaping is used over a wide frequency range, which 
can extend the dynamic range of the bounce file by 5–10 dB.

•• POWr #3 (Noise Shaping): Additional, optimized noise shaping is used, which can extend the 
dynamic range by 20 dB within the 2–4 kHz range (the range in which human hearing is most 
sensitive).

Note:  Noise Shaping minimizes the side effects caused by bit reduction (downsampling), 
by moving the quantization noise spectrum to the frequency range above 10 kHz (the 
least sensitive part of the range of human hearing). This process is technically known as 
spectral displacement.

•• UV22HR: Allows for the best possible sound resolution when bouncing 24-bit recordings into 
16-bit files.

The dithering algorithm that sounds best depends on the audio material, and also your personal 
taste. Audition the audio material to be dithered with each of the algorithms to determine the 
best setting. In some cases, you may find that the best results are achieved by using no dithering 
at all.

Important:  Avoid dithering the same audio signal multiple times.
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Share projects to iTunes
You can share a project to your iTunes library to play in iTunes, add to a playlist, or sync to a 
mobile device such as an iPhone or iPad. Projects can be shared to iTunes as uncompressed AIFF 
audio files or as compressed audio files with various quality levels.

Share a project to your iTunes library:
	 1	 Choose File > Share > To iTunes.

	 2	 To rename the shared file, select the name in the Title field, then enter a new name.

	 3	 Type artist, composer, and album information for the shared file in the respective text fields.

	 4	 Choose the quality level for the shared file from the Quality pop-up menu.

	 5	 Click Share.

When you share a project to iTunes, the entire project, from the beginning to the end of the last 
region, is exported. Any silence at the beginning or end of the project is trimmed. If Cycle mode 
is on when you share the project, the part of the project between the start and end of the cycle 
region is exported.

The shared project appears in the iTunes library, where you can add it to playlists, convert it, or 
burn it to a CD. The format of the shared project is determined by the iTunes import settings.

Share projects to the Media Browser
You can share Logic Pro projects to the Media Browser, where you can view and open them in 
other Apple applications, including iMovie and Final Cut Pro.

Share a project to the Media Browser
	 1	 Choose File > Share > To Media Browser.

	 2	 To rename the shared file, select the name in the File name field, then enter a new name.

	 3	 Choose the quality setting for the shared file from the Quality pop-up menu.

	 4	 Click Share.

The entire project, from the beginning to the end of the last region, is exported. Any silence at 
the beginning or end of the project is trimmed. If Cycle mode is on when you share the project, 
the part of the project between the start and end of the cycle region is exported.

To view the shared file in the Media Browser, click the project (if the project has multiple 
alternatives, click the project alternative from which you shared the project.) The shared file 
appears in the results list at the bottom of the Media Browser. Any bounced projects also appear 
in the Media Browser.



	 Chapter  21    Share projects	 727

Share projects to SoundCloud
If you have a SoundCloud account, you can share a project to SoundCloud directly from Logic 
Pro. You can choose the quality and visibility level for the shared project, set permissions, and 
also send an email to notify others that the project is available. 

Share a project to your SoundCloud account
	 1	 Choose File > Share > To SoundCloud.

	 2	 If you aren’t currently logged in to your SoundCloud account, enter your email address and 
password, then click Connect.

Alternatively, you can log in to your Facebook account.

	 3	 In the Share to SoundCloud dialog, do the following:

•• To sign in to a different SoundCloud account, click Change, then enter the login information 
for the account.

•• To share the current project, select Bounce as the Source.

•• To share an audio file, select File as the Source, click Browse, then browse to the location of 
the file.

•• Type title, artist, composer, and album information for the project in the respective text fields.

Projects must have a title in the Title field. The remaining information is optional.

•• Choose the quality level for the project from the Quality pop-up menu.

•• Choose the visibility level for the project from the Visibility pop-up menu.

•• Set download and streaming permissions for the project in the Permissions section.

	 4	 Click Share.

To return to Logic Pro without sharing the project, click Close.
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Export projects

Export a project as an AAF file
AAF (Advanced Authoring Format) is used by other music production applications such as 
Pro Tools. You can use it to import multiple audio tracks, inclusive of references to tracks, time 
positions, and volume automation.

Export the current project as an AAF file
	 1	 Choose File > Export > Project as AAF file (or use the Export Project as AAF File key command).

	 2	 In the Save AAF File As dialog, choose the following pop-up menu options:

•• Sample Rate: Choose 44.1 kHz, 48 kHz, 88.2 kHz, or 96 kHz.

•• Bit Depth: Choose either 16 or 24 bit.

•• File Format: Choose WAVE or AIFF.

•• Dither Type: Choose one of the dithering algorithms (see About dithering algorithms).

	 3	 Choose a location, enter a name for the file, then click OK.

The export includes all used regions, inclusive of track and position references, and 
volume automation.

Export a project as a Final Cut Pro XML file
The Final Cut Pro XML format is used to import and export audio data between Final Cut Pro and 
Logic Pro. The Final Cut Pro XML format supports automation data.

Export the current project as a Final Cut Pro XML file
	 1	 Choose File > Export > Project to Final Cut Pro/XML.

	 2	 In the Export dialog, type a name for the exported file and browse to a location to save it.

	 3	 To include the video file in the exported XML, select the “Include video in export” checkbox.

	 4	 To export the file as a Final Cut compound clip, select the “Export as Final Cut Compound Clip” 
checkbox.

	 5	 Click Save.

Note:  When you export to Final Cut Pro XML, audio software instrument tracks are bounced to 
audio files, but MIDI tracks are ignored. Bouncing will automatically switch to real-time mode, if 
necessary (such as when an I/O or External Instrument plug-in is used).

Export a project as MusicXML
MusicXML is an XML-based music notation file format, supported by many notation and music 
OCR applications and some music production applications. You can freely redistribute the 
MusicXML DTDs and XSDs used with MusicXML under the MusicXML Public License.

Many scorewriting programs (including Finale, Sibelius, and MuseScore) and Music OCR 
programs (including SmartScore and PhotoScore) can open and display MusicXML files. Some 
music sequencer programs (including Cubase, SONAR, and Rosegarden) can also open these files.

Export a score project in MusicXML format
mm Choose File > Export > Score as MusicXML.
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Logic Pro X surround overview
Logic Pro X offers extensive surround processing and mixing functions for all major surround 
formats. 

  Logic Pro X surround features are available when   Show Advanced Tools is selected in the 
Advanced preferences pane.

All audio signals can be positionally mixed, allowing you to place them anywhere in the surround 
field. See Surround Panner overview and Surround master channel strip.

You can insert surround plug-ins into audio and instrument channel strips, which can be routed 
to surround auxes or outputs. Logic Pro X includes a number of surround and multichannel 
effects and instruments. See Surround effects and Multichannel effects overview.

Logic Pro X records incoming multichannel audio as interleaved multichannel files, when 
creating a surround project. Imported split multichannel files are converted automatically.

You can also upmix or downmix non-matching signals (mono to multi-mono, or stereo to 
surround, for example), allowing you to use any audio material in your surround projects. In most 
cases, upmixing or downmixing is automatic, but it can be performed manually, if required. See 
Down Mixer plug-in.

You can bounce multichannel projects as split and interleaved surround files. See Bounce 
surround audio files.

Logic Pro X does not encode or decode surround files. You can use the Compressor application, 
available in the Mac App Store, to encode surround files.

To work with surround in Logic Pro X, you need an audio interface that has the number of output 
channels required by the chosen surround format; for example, six outputs if the 5.1 surround 
format is used. You will also need the same number of speakers (and appropriate amplification) 
to hear the channels when mixing. See Surround formats overview.

Surround in Logic Pro X 22
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Set up Logic Pro X for surround

Set surround preferences
Before you can create a project in surround, you need to specify which outputs of your interface 
are connected to which speaker. If you’re recording in surround, you also need to specify the 
inputs of your audio interface. 

These configurations are made in the Output and Input panes of the Audio > I/O Assignment 
preferences. The I/O Assignments tab features three subtabs: Output, Bounce Extensions, and 
Input. All three tabs are linked, but can be adjusted independently.

Note:  In all but the rarest circumstances, the default settings for each surround format should 
meet your needs.

Open the I/O Assignment preferences
mm Choose Logic Pro > Preferences > Audio, then click the I/O Assignments tab (or use the Open 

Surround Preferences key command).

Set the output or input surround channel assignment
	 1	 Click either the Output or Input tab.

	 2	 Choose the surround format you want to work in from the “Show as” pop-up menu.

This action automatically sets the input and output channel pop-up menus in both the Output 
and Input tabs.
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Note:  The surround format chosen here only alters the layout/routing of channels to speakers 
in the I/O Assignments tab. The actual project surround format is determined in the Project 
settings. See Set the project surround format.

Choose which speakers the Logic Pro outputs are sent to
Do one of the following:

mm In the Output tab, choose the output of your audio interface from each of the active pop-up 
menus: Left, Center, Right, and so on.

If you want to work on, or create, a surround project on a computer that is not equipped for 
surround playback, choose outputs that don’t exist for your hardware. These are shown in 
parentheses—for example, (Output 17) or (Output 32).

mm In the Output tab, click one of the three Initialize buttons below the “Show as” pop-up menu.

•• Default: Activates the default setup of Logic Pro. For example, for the 5.1 format, output 1 is 
routed to the left speaker, output 2 to the right one, output 3 is assigned to left surround, 
output 4 to right surround, output 5 to the center speaker, and output 6 to the LFE channel. 

•• ITU: Assigns the International Telecommunications Union standard, used by 
many professionals.

•• WG 4: Uses the WG4 standard, set by the DVD Forum for DVD-Audio. 

Choose which inputs are used for each surround channel
Do one of the following:

mm Choose the input of your audio interface from each of the active pop-up menus: Left, Center, 
Right, and so on.
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mm Click one of the three Initialize buttons below the “Show as” pop-up menu.

•• Default: Activates the default setup of Logic Pro. For example, for the 5.1 format, input 1 is 
routed to the left speaker, input 2 to the right one, input 3 is assigned to left surround, input 4 
to right surround, input 5 to the center speaker, and input 6 to the LFE channel. 

•• ITU: Assigns the International Telecommunications Union standard, used by 
many professionals.

•• WG 4: Uses the WG4 standard, set by the DVD Forum for DVD-Audio. 

Change the bounce extensions
	 1	 Click the Bounce Extensions tab.

	 2	 Enter a new extension name in any of the active fields.

For example, the default left extension “.L” could be renamed “.Left,” or the left surround 
extension “.Ls” could be changed to “.LSurr.” Don’t forget the period before the extension.

If you change your mind, click the Reset Extensions button to revert to default entries.

Note:  Changing the extension has no impact on the files—it simply makes them easier to 
identify. If you find the defaults clear enough, there’s no need to change them.
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Set the project surround format
You choose the surround format you want to use for a project in the Audio project settings. By 
default, a new project is set to 5.1.

Choose the project surround format
	 1	 Choose File > Project Settings > Audio (or use the Open Audio Project Settings key command, 

default assignment: Option-U).

	 2	 Choose a format from the Surround Format pop-up menu.

Tip:  Save a project that has been set up for surround format work as a template. This way 
you won’t have to set the surround format every time you want to create a new surround 
project. Start with the included templates, modify them as necessary, and save them as your 
own templates.

Set the channel strip input format
The channel input format determines the mono, stereo, or surround status of the channel strip.

The symbol on the button indicates the current status as follows:

SurroundRightLeftStereoMono

•• Mono: One circle represents a mono input format. The level meter shows a single column.

•• Stereo: Two interlocked circles represent a stereo input format. The level meter divides into two 
independent columns when a stereo input format is chosen.

•• Left: Two circles, with the left one filled, indicate a left channel input format. Only the left 
channel of a stereo audio file is played back. The level meter shows a single column.

•• Right: Two circles, with the right one filled, indicate a right channel input format. Only the right 
channel of a stereo audio file is played back. The level meter shows a single column.

•• Surround: Five circles indicate the surround channel input format. The level meter divides 
into multiple linked columns (the number matches the project surround format) when the 
surround input format is chosen.
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Choose the channel strip input format
mm Click-hold the button directly below the EQ graphic on the channel strip, then choose an input 

format from the pop-up menu.

Set the channel strip output format
Logic Pro X can automatically determine the output format of specific channel strip types. You 
can override the automatic choices by manually setting the output; otherwise, the channel strip 
output formats follow these rules:

•• Audio channel strips: The channel strip of an empty audio track is automatically set to the 
format of the first audio file added to it. If you add an audio file to a track assigned to a 
different output format (adding a stereo file to a track routed to a surround output, for 
example), the audio file is automatically upmixed or downmixed to match the output format 
of the channel strip.

Note:  The highest possible surround format is determined by the project surround format. See 
Set the project surround format.

•• Instrument channel strips: Instrument channel strips automatically adopt the channel format of 
the inserted instrument.

•• If you insert a stereo instrument, the channel strip output will be stereo.

•• If you insert a surround instance of a software instrument (ES2 or Sculpture, for example), 
the channel strip output will match the project surround format.

•• Aux channel strips: Automatically created aux channel strips adopt the format of their input 
source (if a stereo channel is routed to an aux channel strip, the aux will be stereo). If you 
manually change the output format of an aux channel strip, Logic Pro automatically:

•• Inserts a Surround Balancer or a mono/stereo to surround panner, if you are changing 
the output of an aux from mono to stereo or mono/stereo to surround. See Surround 
Panner overview.

•• Downmixes the signal to the required format.

If you don’t want to work with the automatic settings, you can manually set the output of all 
audio, instrument, aux, and output channel strips to the chosen project surround format.
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Set a channel strip output format to surround
mm Click-hold the Output slot of the channel strip, then choose Output > Surround from the 

pop-up menu.

The Pan control of the channel strip is replaced by a two-dimensional Surround control. The 
loudspeakers are represented by colored dots and the pan position is indicated by a white dot 
that can be moved. For more information, see Surround Panner overview.

Set the output format of multiple channel strips to surround
	 1	 Select all channel strips that you want to set to surround output.

	 2	 Click-hold the Output slot of one of the selected channel strips, then choose Output > Surround 
from the pop-up menu.
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Change the order of surround level meters
You can determine the order of channels in surround (multichannel) level meters. You can 
choose the following options.

Channel 
order

Meter 1 Meter 2 Meter 3 Meter 4 Meter 5 Meter 6

Internal Left Right L Surround R Surround Center LFE

ITU Left Right Center LFE L Surround R Surround

Centered L Surround Left Center Right R Surround LFE

LCR Grouped Left Center Right L Surround R Surround LFE

Change the multichannel level meter order
	 1	 Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key command).

	 2	 Click the Mixer tab, then choose an option from the Channel Order pop-up menu in the Level 
Meters area.

Note:  The setting you choose here does not apply to metering plug-ins, such as Levelmeter 
or Multimeter.
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Logic Pro X surround features

Surround Panner

Surround Panner overview
You use the Surround Panner to place track output signals at specific speaker positions. 
You can use the Surround Panner directly in a channel strip, but it is better to open it in a 
separate window.

It is possible to open multiple Surround Panner windows simultaneously, and to save them in 
screensets. The Surround Panner window also provides a Link button. Click this button to update 
the Surround Panner window so that it reflects the surround mode and current settings of the 
selected channel strip.

The Surround Panner has three operation modes, depending on the channel strip input format. It 
provides different parameters when used in mono to surround and stereo to surround channels. 
When used on surround to surround channels, it acts as a Surround Balancer control. For more 
information, see Surround Panner parameters.

Open the Surround Panner window
mm Double-click the Surround Panner control of a channel strip.

The Surround Panner window provides a magnified view of the channel strip’s Surround Panner, 
and contains additional parameters.



	 Chapter  22    Surround in Logic Pro X	 738

Use the Surround Panner on mono input channel strips
If the source input is set to mono, the Mono-to-Surround Panner appears. For more information, 
see Set the channel strip input format.

The graphical surround field at the top of the Mono-to-Surround Panner window controls the 
surround routing of the input signal to speaker outputs. The level sliders and fields below the 
surround field provide independent control of the Center and LFE channel levels. The extended 
parameters allow you to precisely control the separation between channels.

mm Use the parameters to change the diversity and angle, to change the output format, or to change 
channel separation values.

Use the Surround Panner on stereo input channel strips
If the source input is set to stereo, the Stereo-to-Surround Panner appears. For more information, 
see Set the channel strip input format.

The Stereo-to-Surround Panner is similar to the Mono-to-Surround Panner, but features three pan 
pucks: a puck for the L(eft) signal, a puck for the R(ight) signal, and a third puck, which controls 
both the L and R pucks as a group. It also offers a Spread field in the upper-right corner, which 
controls the stereo width of the signal. 
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Do any of the following:

mm Move the L or R puck in the surround field to move the second puck in a symmetrical fashion.

mm Drag the third puck to move both the L and R pucks, while maintaining a given spread.

•• Left/right movement changes the angle of both.

•• Up/down movement changes the diversity.

The circular bars around the panner indicate which speakers will carry the respective signal 
source; the closer to the center a puck is moved, the wider the corresponding bar gets (the 
greater the diversity, in other words).

Use the Surround Balancer on surround input channel strips
If the source input is set to surround, the Surround Panner acts as a Surround Balancer control. 
For more information, see Set the channel strip input format.

Source channels are passed on to their respective output channels without any cross-panning or 
mixing. The pan control is represented by a single puck, which affects the multichannel source 
signal as a whole.

The separation parameters are not available in this Surround Panner mode.

mm Drag the puck to change relative volume balance of the source signal.
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Surround Panner parameters
The Surround Panner features a set of common parameters, regardless of the channel strip 
input format.

Click the disclosure triangle at the lower-left corner of the Surround Panner window to display 
the extended parameters.

Note:  The extended parameters are not available in the Surround Balancer.

Surround field

Level controls

Extended parameters

Common Surround Panner parameters
•• Surround Field: The surround field consists of the following:

•• Two real-time display fields, for angle and diversity. You can directly interact with these fields 
by dragging.

•• A circular grid, comprised of four concentric circles, divided into eight 45-degree segments. 
The outer circle represents the minimum amount of diversity. The center circle represents 
maximum diversity.

•• A further circle encloses the grid. This is the Diversity/Angle display. As the diversity/angle 
changes, a portion of the diversity display is highlighted.

•• A square may be overlaid on the grid. This indicates the separation point between left and 
right channels, and also front and rear (surround) channels. Drag the corners or edges of this 
separation square or use the sliders in the lower section of the Surround Panner window to 
change values.

•• A number of speaker icons surrounds the circular grid. Click the icons to turn the respective 
channels on or off, thus changing the channel surround output format.

•• Drag the blue dot to control signal routing (surround position in relation) to the speaker 
outputs. Movement of the blue dot is modified with these functions:

•• Hold Command to lock diversity.

•• Hold Command-Option to lock the angle.

•• Option-click the blue dot to reset angle and diversity.

•• Center Level slider: Drag the Center Level slider or field to set the volume relationship of the 
(front) center channel—typically used for dialogue in film and TV productions.
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•• LFE Level slider: Drag the LFE Level slider or field to control the volume of the LFE output. 
The abbreviation stands for Low Frequency Enhancement or Low Frequency Effects, as the LFE 
output is most commonly sent to a subwoofer channel. The use of a subwoofer speaker is 
not mandatory.

Tip:  If you want only low frequency signals to reach the output, insert a multi-mono surround 
EQ into the surround master channel strip. Use this to set the LFE (or subwoofer) output. A 
cutoff frequency of 120 Hz is standard for most surround applications. For more information, 
see Surround master channel strip.

•• Separation Controls: Drag the sliders in the lower section of the Surround Panner window to 
determine the amount of separation between channels. As you change these parameters 
away from values of 1.00, the separation square changes (to a trapezoid or rectangle) in the 
surround field, providing visual feedback on how the channel is being affected.

•• Separation XF: Applies to the Left and Right (front) channels. Reducing Separation from 1.00 
down to 0.00 mixes the right signal into the left channel, and vice versa, until both channels 
output a mono signal.

•• Separation XR: Applies to the Left and Right Surround (rear) channels. Works as above, for the 
surround speakers.

•• Separation Y: Affects the mix relationship of the front and rear channels (in front or behind 
the listening position, in other words). It mixes the Left/Left Surround and Right/Right 
Surround channels. When Separation Y is set to 0.00, the front and rear channels output 
in mono.

The separation square is visible if the extended parameter section is open. If the extended 
parameter section is closed, it remains visible if any of the separation values do not equal 1.00. 
It also stays visible when the default values are reached by editing the square graphically. 
Closing the extended parameter section (with all separation values at 100%) makes the square 
disappear. You can Option-click the value field or sliders shown in the extended parameters (or 
on the separation square lines) to reset them to default values.

Note:  In 7.1 ITU surround formats, the Separation of Left Middle and Right Middle is 
determined by the average separation value of the Front and Rear channels. 

•• Level Compensation pop-up menu: Select the surround pan law for stereo to surround and 
mono to surround channels.

•• Unity gain at speaker: The default setting for mono to surround and stereo to surround 
channels. All new projects and projects imported from Logic Pro 9.1.7 follow this pan law.

A mono signal panned hard left of a stereo output with X dB gain will do the same if panned 
hard left with a mono to surround panner. A stereo signal panned hard left and right with X 
dB gain will do the same if panned hard left and right with a stereo to surround panner.

•• Unity gain at mid-point: This was the default setting used for Logic Pro versions 9.1.4 to 9.1.6. 
Projects imported from these Logic Pro versions will adopt the Legacy pan law. You can 
choose a different pan law from a dialog or this pop-up menu.

•• Legacy (Pre Logic 9.1.4): This was the default setting used for Logic Pro versions 8.x to 9.1.3. 
Projects imported from these Logic Pro versions will adopt the Legacy pan law. You can 
choose a different pan law from a dialog or this pop-up menu.
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Surround effects
Logic Pro X offers a number of surround effect plug-ins, and also includes surround versions 
of the Sculpture and ES2 synthesizers. Your Audio Units instruments and effects may also work 
in surround.

Important:  The project surround format determines the surround format of plug-ins. For more 
information, see Set the project surround format.

Insert a surround effect plug-in
	 1	 Set the channel strip’s output to Surround. For more information, see Set the channel strip 

output format.

	 2	 Click any Insert slot, then navigate to the Mono → Surround (on mono channels), Stereo → 
Surround (on stereo channels), or Surround version (on surround channels) of the plug-in you 
want to use.

For example, on a stereo format channel strip, navigate to Delay > Delay Designer > Stereo → 5.1 
(ITU 775). If the project surround format is set to 7.1 (SDDS), the Plug-in pop-up menu of a stereo 
channel strip is displayed as follows: Delay > Delay Designer > Stereo → 7.1 (SDDS).

Tip:  It’s possible to release the pointer on the plug-in name, instead of navigating all the way 
through the hierarchy to the channel format. The plug-in opens automatically using the default 
channel strip format.

Insert plug-ins that do not match the channel format
mm Option-click a channel strip Insert slot.

The Plug-in pop-up menu displays all available formats for the plug-in, rather than being 
limited to the matching format. Any down- or upmixing that may be necessary will 
happen automatically.

•• The default format of software instruments is stereo (if available). Mono and the project 
surround format are offered as additional formats.

•• The default format of effects plug-ins is the current channel strip format (at the insert point in 
the signal path). 

•• All plug-in format variations (based on the current channel strip input format, and all available 
plug-in output formats) are offered, up to the maximum allowed by the project surround 
format. 

Note:  This applies only if the output of the channel strip is already routed to a surround bus 
or output.

•• Logic Pro effects plug-ins can also be operated in a multi-mono configuration, based on the 
project surround format.

Logic Pro X automatically performs surround downmixes and upmixes whenever the format of 
the input and output channels don’t match. For example, if you insert a quadraphonic plug-in into 
a 5.1 bus, Logic Pro X performs a downmix from 5.1 to Quad, followed by an upmix back to 5.1.
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Multichannel effects

Multichannel effects overview
Effects that are not available as true surround effects can be inserted as multichannel effects 
in surround channels. Logic Pro X matches the surround format of a channel by automatically 
providing the required number of stereo and mono instances of the plug-in.

Multichannel effect plug-ins have an advanced plug-in header.

The plug-in header can include a tab for each effect instance, an LFE tab, and a Configuration tab. 
For more information, see Multichannel effects Configuration tab.

The effect tab labels indicate if effect instances are loaded in stereo or mono. Channels joined 
with a “-” are loaded as a stereo instance. Channels separated with a “|” are mono.

•• L-R|Ls-Rs|C: Denotes left/right stereo, left/right surround stereo, mono center.

•• L-R|Rs|C (a separate left surround tab is shown): Denotes left/right stereo, mono right surround, 
mono center.

•• LR, C, and Ls-Rs shown on three separate tabs: Denotes left/right stereo, center mono, left/right 
surround in stereo.

Each effect tab addresses a discrete effect unit for each channel (or channel pair). Each tab can 
have different parameter settings.

Click each tab to change plug-in parameters for the LR tab, the C tab, the Ls-Rs tab, and the LFE 
tab. The parameter values of each tab are memorized when you save a plug-in setting.

Side chains and surround effects
When inserting a side chain–capable plug-in, the side chain source (selected in the plug-in 
header) is routed to all surround instances.

The detection circuits of grouped plug-in instances are linked, and react as one unit. This ensures 
that the spatial surround image is not skewed or deformed.

Note:  This is also true when no side chain input is selected. In this case, the group’s combined 
individual inputs are used to feed the linked detection circuit—effectively acting like a side 
chain source.
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Multichannel effects Configuration tab
The Configuration tab determines how parameter changes affect the plug-in instances.

When a multichannel plug-in is first inserted into a surround channel, it is automatically 
preconfigured to match the channel surround format, and to make the best use of the plug-in’s 
capabilities. For example, a plug-in with mono and stereo capabilities is inserted into a 5.1 bus. It 
is preconfigured as two stereo pairs, with the addition of a mono center and mono LFE channel. 
The necessary links and tabs are created automatically.

Link menu

Bypass button

Configuration tab parameters
•• Link menu: Determines which effects are linked. If you link effects, parameter changes apply to 

all effects in the linked group. You can choose between three groups: A, B, and C. Channels set 
to none (“-”) operate independently. Each group features its own tab. When you link channels, 
keep the following in mind:

•• If you link two channels as a stereo pair, the left channel is always assigned as the master.

•• If one or more channels are added to an existing group, the new members adopt the values 
of the group.

•• If you assign several channels to an unused group, the setting of the (front) left channel is 
used for all group members.

•• Bypass button: Click to bypass the channel: it is routed around the effect. This is useful when 
individual channels should be exempt from processing by a particular plug-in.

Note:  If the Bypass button of a grouped channel is clicked, all channels in the group are 
routed around the effect.
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Surround master channel strip
When you set the output of a channel strip to surround, a surround master channel strip 
is automatically created in the Mixer. The surround master channel strip processes signals 
routed to the outputs configured in the Surround preferences. For more information, see Set 
surround preferences.

You can insert surround effect plug-ins into the master channel strip. You can also use the Down 
Mixer plug-in to quickly switch between input formats.

Important:  As soon as the surround master channel strip appears, the Insert slots of the 
individual output channels are hidden, and any existing effects in the Insert slots (of output 
channel strips) are no longer processed. Logic Pro X remembers the insert configuration, so 
when you remove all surround outputs, the original output channel configuration is restored.
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Down Mixer plug-in
You can use the Down Mixer plug-in to adjust the input format of the surround master channel 
strip. You can do this to quickly check the surround mix in stereo, for example.

Channel mapping, panning, and mixing are handled behind-the-scenes. You do, however, have 
some control over the mix:

Down Mixer parameters
•• Dest Format pop-up menu: Choose the surround destination format: To Quad, To LCRS, 

To Stereo.

•• Level sliders: Control the respective channel levels. 

Note:  The number, and names, of sliders depends on the chosen plug-in format.
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Bounce surround audio files
Bouncing a surround mix can create a single interleaved file, or it can create multiple audio 
files—one per channel—when Split is chosen as the file type.

When multiple files are created, each file is identified by a unique extension.

Note:  Use the Bounce Extensions preference tab to define filename extensions that will be 
added to the files resulting from a surround bounce. For more information, see Set surround 
preferences on page 730.

Perform a surround bounce to CDDA (CD Digital Audio)
	 1	 Do one of the following:

•• Choose File > Bounce > Project or Section (or use the corresponding key command).

•• Click the Bounce button at the bottom-right corner of any output (or the surround master) 
channel strip.

All outputs selected in the surround settings are bounced simultaneously, regardless of which 
output channel strip Bounce button is clicked.

	 2	 Select the Surround Bounce checkbox, below the Dithering pop-up menu in the Bounce window.

	 3	 Select other bounce settings, as required.

	 4	 Click the Bounce button.

Note:  You can’t use the Bounce command to create compressed surround files (AAC, MP3). If you 
click a compressed format checkbox, a dialog appears, indicating that a compressed surround (or 
split stereo) bounce is not possible.

Perform a surround bounce to DVD-A
Logic Pro can burn a surround mix of the current project to a DVD-A (DVD-Audio) disc. This can 
be:

•• As many as 6 channels (5.1) at 24-bit depth, and 48 kHz sampling rate

•• High definition stereo at 24-bit depth, and 192 kHz sampling rate 

	 1	 Do one of the following:

•• Choose File > Bounce > Project or Section (or use the corresponding key command).

•• Click the Bounce button in the bottom-right corner of any output (or the surround master) 
channel strip.

All outputs selected in the surround settings will be bounced simultaneously, regardless of 
which output channel strip Bounce button is clicked.

	 2	 Select the Burn to CD / DVD checkbox in the Destination pane.

A dialog indicates that you will need to change settings. Click Proceed.

	 3	 Choose DVD-A from the Mode pop-up menu.

	 4	 Choose other bounce settings, as required.

	 5	 Click the Bounce & Burn button.

For more information about bouncing, see Bounce a project to an audio file on page 715.
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Additional surround information

Surround formats overview
Logic Pro X supports the following surround formats:

Quadraphonic surround format
The quadraphonic surround format consists of four full-bandwidth channels, arranged as 
front left and right and rear left and right (left surround and right surround). It is an old format 
used for music delivery. Mike Oldfield’s “Tubular Bells” is probably the most popular release in 
this format.
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LCRS surround format
LCRS stands for left, center, right, and surround channel. This is the original Dolby Pro Logic format. 
The surround channel (placed directly behind the listener) is a bandwidth-limited (the treble 
content is reduced) monophonic channel.
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5.1 (ITU 775) surround format
5.1 (ITU 775) is used for a few surround standards. This is the most common of the surround 
formats, and is the one you are most likely to use. The 5.1 channels are left, center, right, left 
surround (left rear), right surround (right rear), and LFE. 
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6.1 (ES/EX) surround format
The 6.1 (ES/EX) format is used for Dolby Digital EX or DTS ES. The 6.1 channels are left, center, 
right, left surround, surround (rear center), right surround, and LFE. 
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7.1 (3/4.1) surround format
7.1 (3/4.1) uses the same speaker configuration as 5.1, but adds two additional side channels (left 
mid and right mid), placed directly to the left and right of the listening position. It is designed for 
a big cinema, in other words.
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7.1 (SDDS—Sony Dynamic Digital Sound) surround format
7.1 (SDDS—Sony Dynamic Digital Sound) adds two additional speakers to 5.1 (left center and 
right center). As with the other 7.1 format, this is designed for use in a large cinema, equipped 
with Sony decoding and playback hardware.
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Surround format channel distribution
The following table provides details on the channels used by each of the supported 
surround formats.

Surround format Channels used

Quadraphonic L - R - Ls - Rs

LCRS (Pro Logic) L - C - R - S

5.1 (ITU 775) L - C - R - Ls - Rs - LFE

6.1 (ES/EX) L - C - R - Ls - S - Rs - LFE

7.1 (3/4.1) L - C - R - Lm - Rm - Ls - Rs - LFE

7.1 (SDDS) L - Lc - C - Rc - R - Ls - Rs - LFE

Table key
•• L = (Front) Left

•• Lc = Left Center

•• C = Center

•• Rc = Right Center

•• R = (Front) Right

•• Lm = Left Mid

•• Rm = Right Mid

•• Ls = Left Surround (Rear Left)

•• S = Surround (Rear Center)

•• Rs = Right Surround (Rear Right)

•• LFE = Low Frequency Effects

Surround bounce file encoders
Logic Pro X surround bounces are not encoded. Surround bounce files can be encoded in the 
Compressor application, available in the Mac App Store, or with dedicated hardware devices and 
other software.

Common surround encoded formats include:

•• Dolby Digital: Dolby Digital (also known as AC3) includes the LFE channel. It is a compressed 
format, commonly used for DVDs and digital terrestrial or satellite TV broadcasts. It is also 
widely used for computer game soundtracks.

•• Dolby Digital True HD: An uncompressed (or minimally compressed) high bit-rate format, 
commonly used for Blu-ray discs and high definition digital terrestrial or satellite 
TV broadcasts.

•• SACD: Super Audio Compact Disc: The Sony-Philips version of DVD-A. SACD audio is stored in a 
format called Direct Stream Digital, which has a sampling rate of 2.8224 MHz. SACD discs must 
contain a stereo mix, but usually also offer a 5.1 mix (although this is optional).

•• Pro Logic II: Pro Logic II uses two full-range rear channels, unlike the original Pro Logic (LCRS) 
format. It does not, however, use the LFE channel. In other words, this is a 5.0 format, so simply 
disable the LFE channel in Logic Pro X if you want to deliver a Pro Logic II soundtrack.

•• DTS (Digital Theater Systems): Soundtracks generally sound better than Dolby Digital EX 
equivalents because they use a 3:1 compression ratio, whereas Dolby uses a 12:1 ratio. Less 
compression means more storage space is required on the delivery medium.
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•• DTS HD Master Audio: An uncompressed (or minimally compressed) high bit-rate format, 
commonly used for Blu-ray discs and high definition digital terrestrial or satellite 
TV broadcasts.

Speaker placement, timing, and levels

Speaker placement
The physical positioning of speakers is key to creating mixes that translate well to other surround 
playback systems. Because the 5.1 format is the most widely used, this section covers 5.1 speaker 
placement. Much of this information can be applied to the other formats.

Front speakers
The International Telecommunications Union (ITU) 5.1 surround definition states that front 
speakers should be arranged left, center, and right, with the angle between the left or right 
and center speakers being 30 degrees. A narrower angle of 22.5 degrees is suggested for use in 
cinematic systems where the left and right speakers should be within four degrees of the edge 
of the screen.

In the studio, you should use the wider 30-degree angle, even if scoring for film. Use of this angle 
allows stereo signals to be auditioned correctly using the left and right speakers, without moving 
them each time you switch between stereo and surround mixes.

The three front speakers—left, center, and right—should be placed in an arc (not a straight line) 
at an equal distance from your listening position. The center speaker should be set back slightly 
from an imaginary line drawn between the left and right speakers. If this isn’t practical, don’t 
place the center speaker closer to the listening position than the left and right speakers. All three 
speakers should be at the same height—at ear level.

If possible, your listening environment should also include a position where the left and 
right speakers are at an angle of 45 to 60 degrees from the ideal central “viewing” position. 
An angle close to 45 degrees is preferred if watching movies, as it approximates the way film 
soundtracks are mixed and monitored. A wider angle, with the left and right speakers farther 
apart, is recommended if your system is principally used for listening to music, rather than 
watching movies.

It’s not essential to have a full surround setup in the studio. If you have a home theater system, 
make your surround mix in the studio, then listen to or watch it in your theater room.
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Surround speakers
The rear speakers (surround channels) should ideally be placed at the same distance from your 
listening position as the front speakers, at an angle of 110 degrees from the front center speaker. 
This angle is a compromise between producing an all-encompassing sound stage (at 90 degrees) 
and the best rear-quadrant imaging (at 135 degrees).

The surround speakers should be placed alongside and slightly to the rear of (but not directly 
behind) the listening position, well above ear level, to help minimize localization effects. They 
should be aimed across the listening area, not directly at the listening position.

This positioning creates a broad surround sound field throughout the listening area, 
approximating cinema speaker systems. If the speakers are placed too far forward, the rearward 
effect will be insufficient. If the speakers are too far back, the surround information won’t be 
integrated with the overall sound field. Experiment with placement and angles until the surround 
sound field seems to encompass you, rather than come from behind you.

If your studio doesn’t have walls in the perfect place to mount surround speakers, try placing 
them on stands above ear level. If you need to wall-mount the speakers, place them well above 
ear level, and try aiming them at each other, toward the front, or to reflect off the side walls.

LFE speaker
The LFE is a discrete effect channel for low frequencies (explosions, avalanches) in film and 
TV soundtracks. In surround music mixes, LFE is used as a low frequency channel for certain 
instruments (bass drum or electric basses placed on the center with a frequency divider that 
sends lower frequencies to the LFE speaker.

Bass frequencies travel much slower than higher frequencies, and are less directional. Ideally, 
you should place the LFE speaker (often, a subwoofer) in a central position in front of the 
listening position.
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Speaker timing and levels
Most people with undamaged hearing can identify where a sound is coming from: to the left, 
right, in front, or behind them. Certain sounds, however, are very difficult to “position” in relation 
to the listening position. For example:

•• A gunshot or car backfiring is hard to place because the sound is both loud and quick. You 
may initially be able to tell that it came from your left or right but not where, specifically, to 
the left or right it came from. This is because early reflections (reverberations) rapidly build up 
and diffuse, making them hard to discern, directionally, from the initial sound peak.

•• Aircraft jet engines are a low rumble that is hard to place until the plane flies directly 
overhead. When it does, the volume of the sound, and the higher frequencies of the jet 
engines, enable you to hear it moving from left to right or front to back.

Some sounds are easier to place:

•• Trucks, cars, and motorbikes generate a constant combination of low- and high-frequency 
sound, allowing you to track their movement.

•• Individual human voices are sounds that people are most familiar with, and contain a lot of 
high-frequency content.

In a surround playback system, you need to set different levels and different delay times for each 
speaker. This allows you to compensate for latency perceived at the listening position, which 
affects your ability to correctly “place” where sounds are coming from.

Level—in particular—can alter your perception of how close a sound is, so you should ideally 
set the same level for the front left and right speakers. These speakers are usually used for 
incidental music/effects tracks and the main score of a film, and also often carry an amount of 
the dialogue track.

The center speaker is typically used for dialogue and incidental music/effects tracks. Its level 
should be similar to the left and right speakers, but can be increased to enhance the intelligibility 
of dialogue.

You should aim to have the sound from all front speakers arriving at the listening position at the 
same time.

You should set the levels of surround speakers and the subwoofer (LFE) to be immersive, and 
part of the surround stage, rather than “additions” to the front speakers. In general, surround 
speakers (and the subwoofer) are used for surround effects, main score, and incidental music/
effects tracks.

Also critical for the surround and subwoofer channels is the delay time. Assuming that the levels 
of all speakers are suitable, the timing of the surround (and LFE) speakers may seem slightly 
“out” in comparison to the front speakers. Most surround amplifiers allow you to negatively or 
positively adjust the delay of these speakers.

The surround encoding process—performed in Compressor, available in the Mac App Store—
writes “surround encode flags” for the surround speakers, depending on the chosen format. 
These flags are understood by surround decoders (AV receivers, decoding software, or surround 
amplifiers).

There is no need to set slight delays between tracks when working in Logic Pro X. The surround 
encode flags are designed to handle this.
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Environment overview
The Environment refers to the virtual environment of Logic Pro inside your computer. It provides 
a virtual view of your MIDI studio, giving you complete control over your MIDI setup, and 
includes the following objects.

•• Physical Input and Sequencer Input objects: Represent the physical MIDI inputs of your MIDI 
interface and the Logic Pro input.

•• Instrument objects: Virtual representations of each MIDI device (synthesizers and samplers, for 
example) in your MIDI rig.

•• Faders, knobs, switches, and other objects: Used to create new data, or to control and modify the 
MIDI signal flow in real time.

It’s not essential to know about—or even open—the Environment in order to make music with 
the Logic Pro instruments or your external MIDI sound generators and keyboards. When you 
create new instrument or external MIDI tracks, Logic Pro automatically generates Mixer channel 
strips, and also creates and configures any Environment objects that are needed for basic input 
and output.

Note:  This is also true of audio channel strips (and other channel strip types, such as aux and 
output channel strips), but you will rarely need to access these objects in the Environment, as 
you have full control over these channel strips in the Mixer.

  The Environment is only available when Additional MIDI Options is selected in the Advanced 
preferences pane.

Work in the Environment 23
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Open the Environment window
Do one of the following:

mm Choose Window > Open MIDI Environment (or press Command-8).

mm Use the Toggle Environment key command to do one of the following:

•• Open an Environment window.

•• Bring an open Environment window to the front.

•• Close an Environment window, if it’s the active window.

Common object parameters
Each Environment object has several parameters that control its behavior. You can view and 
change these parameters in the Object inspector, shown in the Environment when an object 
is selected.

The following parameters are shared by all object types:

•• Name: Appears next to the disclosure triangle and can be edited by clicking. You can also edit 
the name by clicking the object with the Text tool.

•• Icon: Represents the object in the Environment and main window, and can be changed 
by clicking.

•• Assignable checkbox: Makes the object visible in the Reassign Track shortcut menu in the Tracks 
area. (See Reassign tracks to different channel strips on page 166.) This is useful for instrument 
objects, but can also be useful for other objects such as touch tracks and chord memorizers.

Show or hide the Object inspector
Do one of the following:

mm Click the disclosure triangle in the upper-left corner of the Object inspector.

mm Choose View > Hide/Show Inspector (or press I).
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Work with Environment layers

Environment layers overview
The Environment can quickly fill up with a large number of objects. To keep things organized, 
you can assign objects to different display levels, referred to as layers. Think of layers as being 
different, partial views of the overall Environment. You can easily connect objects between 
different layers.

The distribution of objects across different layers has no effect on their functionality—it’s 
simply a better way to organize objects. The name of the current layer is shown in the Layer 
pop-up menu.

Layer pop-up menu

The position and existence of the first two layers—All Objects and Global Objects—is protected, 
and they cannot be deleted.

•• All Objects: This layer displays all objects in the Environment. The objects in this layer are 
normally shown as a list. To switch to the selected object’s layer, choose Options > Go to Layer 
of Object in the Environment menu bar.

•• Global Objects: In this layer, you can place objects that you want to be visible in all layers. These 
objects appear at the same position in all layers. Try to assign as few objects as possible to this 
layer, due to the onscreen clutter that global objects can create.
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Create, name, delete, and switch layers
You can create, name, delete, and switch layers in the Environment.

Create a layer
Do one of the following:

mm Choose Options > Layer > Create Layer.

mm Choose Create Layer from the Layer pop-up menu.

A new, empty layer called (unnamed) is inserted above the currently selected layer.

Name a layer
	 1	 Choose Rename Layer from the Layer pop-up menu.

	 2	 Enter a new name, then click OK.

Delete a layer
	 1	 Do one of the following:

•• Choose Options > Layer > Delete Layer.

•• Choose Delete Layer from the Layer pop-up menu.

An alert warns against the accidental deletion of all objects in the layer.

	 2	 Click Delete to confirm the deletion.

Switch between layers
mm Choose a layer from the Layer pop-up menu.

Switch back to the most recently opened layer
mm Choose Options > Go to Previous Layer.
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Work with Environment objects

Tools in the Environment
You can use the Pointer, Pencil, and Eraser tools to select, create, and delete objects in 
the Environment.

The following tools are also available:

•• Text tool: Click an object with the Text tool to rename it.

•• MIDI Thru tool: Click an object with the MIDI Thru tool to assign the object to the selected track 
in the main window.

Add and delete objects
You can add and delete objects in the Environment using menu commands or tools.

Add an object
Do one of the following:

mm Choose an object type from the New menu in the Environment menu bar.

The object is added to the current layer.

mm Click a layer background with the Pencil tool.

A new instrument object is created.

Delete an object
Do one of the following:

mm Select all objects you want to delete, then choose Edit > Delete in the Environment menu bar (or 
press Delete).

mm Click the object with the Eraser tool.

Move and copy objects
You can move and copy objects within a layer or between layers, using a variety of techniques.

Move an object by dragging
Do one of the following:

mm Grab the icon, name, or positioning bar to the right of the object (in the case of keyboard and 
fader objects, for example), then drag it to a new position in the layer.

mm Hold down Shift, then drag the object to a new position in the layer (beneficial in the case of 
keyboard and fader objects, for example).

Note:  Remember to first deselect any other selected objects by clicking the layer background, to 
avoid moving them as well.
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Move objects between layers by dragging
	 1	 Open a second Environment window (Window > Open MIDI Environment) that displays the 

target layer.

	 2	 Select the objects you want to move in the first Environment window, then drag them into the 
second window.

Move objects between layers using the Layer pop-up menu
	 1	 Select the objects you want to move.

	 2	 Hold down Option, then choose a layer from the Layer pop-up menu.

The selected objects are moved to the chosen layer.

Move objects between layers using the Clipboard
	 1	 Select the objects you want to move.

	 2	 Choose Edit > Cut from the Environment menu bar (or press Command-X).

	 3	 Choose a destination layer from the Layer pop-up menu.

	 4	 Click the layer background to make sure that no objects are selected.

	 5	 Choose Edit > Paste from the Environment menu bar (or press Command-V).

Note:  If any objects are selected when you try to paste objects to the current layer, a dialog asks 
if you want to replace the current selection. If you press Return or click Replace, the selected 
objects are replaced by the objects in the Clipboard. The existing cabling remains intact.

Copy an object by dragging
mm Option-drag the object with the Pointer tool.

Copy objects between layers by dragging
	 1	 Open a second Environment window (Window > Open MIDI Environment) that displays the 

target layer.

	 2	 Select the objects you want to copy in the first Environment window, hold down Option, then 
drag the objects into the second window.

Copy objects between layers using the Clipboard
	 1	 Select the objects you want to copy and choose Edit > Copy from the Environment menu bar (or 

press Command-C).

	 2	 Choose a destination layer from the Layer pop-up menu.

	 3	 Click the layer background to make sure that no objects are selected.

	 4	 Choose Edit > Paste from the Environment menu bar (or press Command-V).

Cabling is preserved, so groups of objects copied this way are connected in the same way as the 
originals. When you copy a single object, only its output cables are preserved.

Note:  If any objects are selected when you try to paste objects to the current layer, a dialog asks 
if you want to replace the current selection. If you press Return or click Replace, the selected 
objects are replaced by the objects in the Clipboard. The existing cabling remains intact.
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Adjust the position and size of objects
Objects can be freely placed, which allows for flexibility, but can lead to overlaps or 
misalignments—particularly when pasting between layers. Fortunately, you can quickly clean up 
object positions.

Snap objects to a grid
mm Choose View > Snap Positions from the Environment menu bar.

The objects are aligned to an invisible grid.

It’s useful to leave this setting turned on, but you should turn it off if you want to manually move 
an object by a few pixels.

Align selected objects horizontally or vertically
mm Choose Options > Clean up > Align Objects.

The upper-left object stays where it is. The position of the next object determines whether the 
objects are aligned in a row or a column. If it’s to the right of the upper-left object, all objects are 
aligned horizontally (in a row). If it’s below the upper-left object, all objects are aligned vertically 
(in a column).

Align selected objects to the invisible grid
mm Choose Options > Clean up > Positions by Grid.

Align objects using key commands
mm Use the following key commands to move selected objects one pixel in the relevant direction, 

even when the grid is turned on:

•• Object move left

•• Object move right 

•• Object move up

•• Object move down

Resize an object
mm Drag the object’s bottom-right corner.

Resize a selected object to its default value
mm Choose Options > Clean up > Size by Default.

Resize selected objects using key commands
mm Use the following key commands to decrease or increase the width or height of selected objects 

by 1 pixel:

•• Object Width −1 Pixel 

•• Object Width +1 Pixel 

•• Object Height −1 Pixel

•• Object Height +1 Pixel
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Use advanced selection commands
You can move and copy objects faster and more easily using the following commands from the 
Environment’s Edit menu:

•• Select Used Instruments: Selects all objects that are assigned to the selected track in the main 
window, or are connected to such objects via cables.

•• Select Unused Instruments: Selects all objects that are neither used in the main window, nor 
connected to any such objects via cables.

•• Select Cable Destination: Highlights the destination object of a selected cable connection. This 
is particularly useful when:

•• The destination object is on a different layer. You can use the function to select and display 
the destination object (and layer).

•• You can locate the destination object of a source object in the list display (View > By Text), 
because selecting the source object also selects its cable connections.

This function allows you to follow the cabling from one (serially cabled) object to the next. If 
several objects are connected in parallel, or several cable connections are selected, the path of 
the upper cable is followed.

•• Select Cable Origin: Highlights the source (or origin) object of a selected cable connection. This 
is particularly useful for troubleshooting, or when you want to make changes to a number of 
serially cabled objects (by changing the original).

•• Invert Selection: Changes the status of any selected objects in the current layer, just as in the 
main window and editors.
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Create your MIDI signal path

MIDI signal path overview
Before any MIDI events received at your computer’s MIDI inputs can be recorded by Logic Pro, 
there must be a connection between two Environment objects:

•• Physical Input object: Represents the MIDI In port or ports of your MIDI interface.

•• Sequencer Input object: Represents the door into Logic Pro for incoming MIDI events.

In Logic Pro, incoming MIDI events (that arrive at the Sequencer Input object) are always directed 
to the selected track in the main window, where they can be recorded into a MIDI region.

The events played by the MIDI region are mixed with incoming events (if any), and sent to the 
Environment object that the track is routed to. From here, the events are directed to a MIDI 
output (see Assign direct output connections on page 765).

You can insert objects into the signal path between the Physical Input object and the Sequencer 
Input object if you wish—a MIDI monitor object, which allows you to see incoming MIDI events, 
for example.

You can also insert objects between the track and its destination object, enabling other 
Environment processing. The track itself is not represented by an Environment object, but 
you can use the Reassign Track shortcut menu to route the track’s output to an Environment 
object—a MIDI region on a software instrument track routed to a mapped instrument object, 
for example.
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Insert an object between the track and its destination object
	 1	 In the Environment, choose New > Mapped Instrument.

	 2	 In the Tracks area, Control-click the track header to open the Reassign Track shortcut menu, then 
browse to the mapped instrument.

	 3	 In the Environment, cable the mapped instrument to software instrument channel strip 1.
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Assign direct output connections
You can assign a direct output connection to a physical MIDI output from any of the following 
object types:

•• Instrument 

•• Multi-instrument

•• Mapped instrument

•• Touch tracks

•• GM mixer

•• MIDI metronome click

Any object with a direct output assignment is indicated by a white triangle to its right. The 
triangle is hollow when there is no direct assignment.

Object with direct output 
assignment

Object without direct output 
assignment

Assign a direct output connection
mm Choose a MIDI output from the Port pop-up menu in the Object inspector.

The Port pop-up menu lists all MIDI outputs, including the following options:

•• Off: Disables the connection to the MIDI interface port.

•• All: Routes the object’s output to all available MIDI ports—useful if the device is sending a 
pulse, for example.
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Cable Environment objects
The cabling between Environment objects provides control over the entire MIDI signal path. A 
cable is normally shown as a gray or colored line between a source and destination object.

Cables are assigned the same color as the source object, which makes following the signal path 
much easier. You can, however, turn off cable coloring, and render them in gray with the View > 
Colored Cables option.

Objects always have an (invisible) input on the left, and an output on the right. The output of an 
object is shown as a small triangle, pointing to the right.

Connect two objects by dragging
	 1	 Click-hold the triangle of the source object.

The pointer turns into a plug (patch cord) that represents a cable connection coming from the 
object’s output.

	 2	 Move the plug over the destination object, then release the mouse button when the object 
is highlighted.

A cable connection is created between the two objects.

If the source object has already been directly assigned to a MIDI output port, a dialog asks if you 
want to replace the direct assignment. You have three options:

•• Cancel: The connection is not made, and the direct output assignment of the source object 
remains intact.

•• No: The connection is made, but the direct output assignment remains intact. This means that 
the source object is connected to two destinations—one to another object via the cable, and 
one via the direct output assignment.

•• Remove: The connection is made, and the direct output assignment is removed. This is 
the default selection, because you generally won’t want an object connected to two 
different destinations.
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Connect two objects using menu commands
	 1	 Option-click the triangle of the source object.

	 2	 In the Reassign Track shortcut menu, browse to the layer that the destination object is in, then 
choose the object name.

A cable connection is created between the two objects. This method is ideal for creating 
connections between layers, but can also be useful when a large number of closely spaced 
objects exists in a single layer.

You can also open a second Environment window (showing the destination layer), and connect 
the objects graphically between the windows.

A cable connection to another layer looks like this:

Remove a cable connection
Do one of the following:

mm Click the cable with the Eraser tool.

mm Select the cable, then press Delete.

mm Drag the cable over the triangle of the source object.

mm Choose Edit > Clear Cables only to remove the selected cables, without clearing any objects that 
happen to be selected.

This is useful when you want to clear all cables leading to, or from, one or more objects, due to 
the fact that selecting objects also selects all associated cable connections.
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Make multiple cable connections
There is no limit to the number of cables that you can plug in to a destination object. All MIDI 
signals are mixed at the object’s input.

Make multiple output connections from an object
	 1	 Connect the object to a destination object.

Once an output from an object is used (cabled to another object), another output triangle 
automatically appears.

	 2	 Use the second output triangle to create a second cable connection to another 
destination object.

Once this is done, a third output triangle appears, and so on.

Some objects have special outputs, and can’t be connected this way. One example is channel 
splitter objects, which feature several (functionally different) outputs. Other special objects 
include cable switchers and physical input objects. With these objects, each output can only be 
used once.

Route the signal of special object outputs to several destinations
	 1	 Create a monitor object by choosing New > Monitor.

	 2	 Plug the cable from the desired object output into the monitor object.

	 3	 Create a cable from the monitor object to as many other destinations as you wish.

The monitor object allows you to view the MIDI events flowing through it.

Connect several cables to a common destination
	 1	 Select the cables.

Tip:  If the cables are already connected to a common destination, the simplest way to do this is 
to select the destination object.

	 2	 Drag one of the cables to a new destination object.

You’re asked if you want to connect all selected cables to the new destination.

	 3	 Click Connect, or press Return.
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Cable objects in series and in parallel
You can cable objects in series and in parallel. Cabling objects in series is useful for quickly 
connecting groups of faders that are used to control a MIDI mixing console, for example.

Cable a group of objects in series
mm Select the objects you want to cable, then choose Options > Cable serially.

The objects are cabled in series, starting with the upper-left object.

Cable a group of the same object type to a common destination
	 1	 Cable one of the source objects to the destination.

	 2	 Select the destination object, then choose Edit > Copy.

	 3	 Select the other objects you want to connect to the same destination, then choose Options > 
Apply Buffer Template to > Cable(s).

You can also copy more complex cabling configurations this way. Just make sure that the object 
types in the group that you want to copy match the object types in the group that you apply the 
buffer template to.
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Exchange Environments

Exchanging Environments overview
One of the main advantages of the Environment is that it lets you customize Logic Pro to fully 
control your MIDI studio. This can, however, present a problem when you share projects with 
other musicians, or use different studio setups. It also presents a problem when you return to 
older projects after you’ve changed your studio. Logic Pro offers several functions to make these 
transitions as easy as possible.

Whenever you want to exchange Environments between projects, there is a source project 
containing the desired Environment, and a destination project with an Environment that you 
want to change. The destination Environment must be in memory, and must be the active 
project (one of its windows must be active). The source project can also be in memory, or it can 
be a file on your hard disk (or any other media). Keep the following in mind:

•• If there are two projects in memory, Logic Pro assumes the active project is the destination, 
and the other project is the source.

•• If there are more than two projects in memory, Logic Pro assumes the active project is the 
destination, and the most recently active of the other projects is the source.

•• If there is only one project in memory, Logic Pro opens an Open dialog, allowing you to select 
the source project.

Import Environments
You import an Environment into Logic Pro using an Environment patch. A single-purpose 
Environment patch might be an editor for a specific piece of MIDI equipment, an Environment 
for a single MIDI processing task (such as a MIDI LFO), or a complex arpeggiator/delay 
line configuration.

Import an Environment patch contained in a single layer
mm Choose Options > Import Environment > Layer, then choose a layer in the dialog that appears.

This layer—including all objects in the layer—is inserted in the destination project, at the same 
layer position (the same place in the Layer pop-up menu) that it occupied in the source project. 
Any existing layers are shifted as needed.

You can also move Environment objects (including cabling) between projects by dragging, or by 
copying and pasting. To make this even simpler, you can combine the objects into a macro.

Import an Environment patch spread across several Environment layers
mm Choose Options > Import Environment > Merge.

All Environment objects from the source project are added to the Environment of the 
destination project. Merged objects are placed in the same layer as their source, which can 
create a mess if objects already occupy that layer in the destination project. To avoid this issue, 
create blank layers (in the destination project) at the same layer positions of the source project, 
before importing.

When importing an Environment patch in this way, be careful of the following:

•• If unique objects in the Environment, like the Physical Input and Sequencer Input objects, are 
imported, they will replace their counterparts in the destination Environment and any cables 
leading into them will be lost. It’s best to temporarily delete these from the source Environment 
before importing.

•• When you import an object, all objects cabled from the imported object are also imported.
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Update and swap Environments
You can update an Environment if you have only added objects to it, but not deleted anything. 
Only the new objects will be imported; the older objects (along with their cabling and track 
assignments) will remain in place.

Logic Pro offers several options for swapping the Environment of one MIDI setup with the 
Environment of another.

Update an Environment
mm Choose Options > Import Environment > Update.

Swap an Environment
Do one of the following:

mm Choose Options > Import Environment > Replace by Port MIDI/Channel.

All objects in the destination project are replaced with objects that reference the same port and 
MIDI channel strip in the source project.

mm Choose Options > Import Environment > Replace by Name.

All objects in the destination project are replaced with objects of the same name in the 
source project.

mm Choose Options > Import Environment > Total Replace.

The destination project’s Environment is replaced completely with the source project’s 
Environment. If you use this option, you’ll have plenty of work to do, including reassigning main 
window tracks to objects, but sometimes it’s the only way.

Note:  This complex task involves a lot of guesswork on the part of Logic Pro, and the results 
almost always require some manual fine-tuning on your part.
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Replace Environments
The most flexible (but also most time-consuming) method of exchanging Environments is to 
manually choose whether each Environment object is kept, deleted, or replaced. If you choose to 
replace an object, you must also define the replacement object.

Replace an Environment using custom choices
	 1	 Choose Options > Import Environment > Custom from the Environment menu bar.

	 2	 Choose the destination project.

An Environment window listing all objects in the destination Environment is shown in a column 
on the left, and the chosen action for each object is shown in a column on the right.

	 3	 Do one of the following: 

•• Select items in the list, then choose the replacement object from a pop-up menu. This pop-up 
menu includes all objects in the track list of the source project.

•• Choose Import > Import Environment using current Assignment from the destination 
Environment menu bar, then choose one of the following:

•• Import > Assign as ‘Keep’: Objects are unaltered.

•• Import > Assign as ‘Delete’: Objects are deleted.

•• Import > Assign by Identical: Objects are assigned to objects from the source project that 
match the type, icon, name, port, and MIDI channel. Objects with the same Unique ID 
have priority.

•• Import > Assign by Unique ID: Objects are assigned to objects from the source project with 
the same Unique ID. This option is useful for updating an Environment when objects have 
only been added. 

•• Import > Assign by Port/MIDI Channel: Objects are replaced by objects with the same Port/
MIDI channel. If a match can’t be found for an object, an object set to Port 0 and the same 
MIDI channel is assigned. If a match still can’t be found, an object with the same MIDI 
channel is assigned.

•• Import > Assign by Name: Objects are replaced by objects with the most similar name. (At 
least 80 percent of the name must be the same.)

•• Import > Assign by Icon/Name: As above, except the object icons must also match.
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Customize the Environment
You can customize the appearance of the Environment by creating more onscreen space, 
displaying objects graphically or as a list, hiding or coloring cables, or using a mini Environment 
window that floats on top of other windows.

Hide or show the inspector
mm Choose View > Hide/Show Inspector (or press I).

This command hides the inspector—the Layer pop-up menu and Object inspector—making 
more room for the Environment’s workspace.

View objects graphically or as a list
mm Choose View > By Text from the Environment menu bar.

This command switches the view between the graphical display of objects and a list. Cables are 
not shown in the list display.

Hide or show cables
mm Choose View > Cables from the Environment menu bar.

In addition to hiding or showing cables between objects, this view also hides or shows the 
positioning bar (used for moving and resizing) to the right of some object types.

Tip:  You can prevent the accidental alteration of the position, size, and cable connections of all 
objects by choosing View > Protect Cabling/Positions.

If the cabling and object positions are protected, and the cables are hidden, the background 
color changes. This usually looks better for virtual mixing desks and fader setups.

View colored cables
mm Choose View > Colored Cables from the Environment menu bar.

Cable colors are derived from the color of the source object—the object that the cable runs 
from, into another object.

Assign a color to the selected object
mm Choose View > Show Colors from the main window’s menu bar (or press Option-C), then click a 

color in the Color palette.

Double-click any color in the palette to open the Colors window, where you can define custom 
colors. These color edits are stored in the preferences file, and are available for all projects. The 
color of an Environment object is used as the default color for any newly created region in the 
main window.
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View a frameless Environment window
There may be times when you want to have access to particular Environment objects while 
working in the main window—buttons that are used to control a tape machine, for example. 
Instead of opening an Environment window each time, you can create a mini window that floats 
on top of other windows.

	 1	 Do one of the following:

•• Choose Options > Layer > Create Layer.

•• Choose Create Layer from the Layer pop-up menu.

	 2	 Create the objects, cable them if necessary, then adjust their parameters as needed.

	 3	 Reposition the objects, then resize the Environment window so that it’s just large enough to 
accommodate the objects.

	 4	 Choose View > Frameless Floating Window from the Environment menu bar.

A mini Environment window is created, which floats above other windows.

	 5	 Position the window, then press Shift-L to lock it as a screenset.

	 6	 Choose this screenset to access the tape controls whenever you need them.
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Environment objects reference

Standard instrument objects

Standard instrument objects overview
Logic Pro provides standard instrument objects to handle MIDI devices that only use one MIDI 
channel—typically, older synthesizers, MIDI-controlled effect units, or drum machines. Standard 
instruments transmit MIDI data on a single MIDI channel.

Create a standard instrument
Do one of the following:

mm Choose New > Instrument.

mm Click the Environment background with the Pencil tool.
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Standard instrument parameters
Standard instruments have the following parameters:

•• Port pop-up menu: Use to set a direct connection to one of your MIDI output ports. Remember 
that you can also cable an instrument object directly to (or from) other Environment objects, 
allowing MIDI processing.

•• Channel pop-up menu: Sets the MIDI channel for the instrument’s output. If you set this 
parameter to All, all events are sent with their original channel settings.

•• Program, Volume, and Pan: Transmit program changes, volume controller (#7), and pan 
controller (#10) data.

No data is sent until you select the corresponding checkbox. If the box is already selected, any 
value alterations are sent immediately. The values are also sent whenever you select the track 
while holding down Option.

Beneath the Program parameter is the Bank parameter. If your MIDI sound source recognizes 
bank select messages (check the device manual), you can switch between sound banks. If your 
sound source responds to the standard Bank Select message (Controller #32), you can use this 
parameter directly. If not, you can define your own bank select commands.

•• Transposition pop-up menu: Defines the number of semitones that all note events are 
transposed by, on output. Negative values transpose downward.

•• Velocity field: Use to increase or decrease the note on velocities of all note events, by an 
amount between –99 and 99.

•• Key Limit field: The two note values of the Key Limit parameter define a pitch range. All notes 
outside this range are ignored by the instrument when it plays a MIDI region. In other words, 
this range of notes will not be played.

•• Vel Limit field: The two values of the Vel Lim parameter define a velocity range. All notes with a 
velocity that falls outside this range are not played by the instrument.
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•• Delay pop-up menu: Causes all MIDI events to be sent early or late, allowing you to compensate 
for any differences in reaction time between your various MIDI devices. Use the Delay 
parameter (in the Track inspector) to create rhythmic delay effects, as this allows longer 
delay times.

•• No Transpose checkbox: If selected, all regions on any tracks played by this instrument object 
are protected from transposition. In other words, the Transpose Region parameter is ignored. 
This is very useful for instruments assigned to drum or other samples—mapped across the 
keyboard on a single MIDI channel—as transposition will trigger different sounds (rather than 
pitches) in these instruments.

•• No Reset checkbox: If selected, no reset messages are sent to the instrument. This can be useful 
if controllers are being used for nonmusical purposes, such as when using the instrument 
object for Mixer automation tasks. The Logic Pro > Preferences > MIDI > Reset Messages 
settings determine which reset messages are sent. These messages are not sent to No 
Reset instruments.

•• Style pop-up menu: Can be set to any of the available staff styles. Whenever a region is created 
on one of the instrument’s tracks, it’s assigned the staff style displayed here. If the Auto style 
is chosen (the default), Logic Pro picks an appropriate style based on the pitch range of the 
notes in the region. For more information on staff styles, see Staff styles overview on page 684.
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Multi-instrument objects

Multi-instrument objects overview
A multi-instrument is like a collection of 16 standard instruments in one package.

You will generally use multi-instrument objects to address multi-timbral hardware synthesizers or 
samplers. A multi-timbral sound module is one that can receive on several MIDI channels at once, 
playing back a different sound on each channel simultaneously. 

As most modern MIDI devices are multi-timbral, the multi-instrument will probably be the most 
commonly used instrument object in your Environment.

The multi-instrument object parameters are a shorter set of the standard instrument object 
parameters (see Common object parameters on page 756). The settings you make in the multi-
instrument’s Track inspector apply globally to all subchannels.

Create a new multi-instrument object
mm Choose New > Multi-Instrument.

View the multi-instrument’s Track inspector
mm Click the icon at the top of the multi-instrument object.

The whole multi-instrument object is selected, allowing you to set the Port parameter, 
for example.
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Multi-Instrument window
Double-clicking a multi-instrument opens the Multi-Instrument window. It contains the following 
areas:

•• Device Name and Short Device Name fields: At the top-left corner of the window, you can enter 
the full name of the multi-instrument in the Device Name field. You can also enter a short 
name for the multi-instrument in the Short Device Name field. This short name is used in the 
main window track list, when the program name is displayed.

Depending on whether or not you have activated the subchannel’s Program parameter, the 
following information appears in the track list of the Tracks area:

•• The name of the multi-instrument and channel number (if the parameter is not activated)

•• The short name, channel number, and program name (if the parameter is activated)

•• Program Names area: There are 128 program names in the Multi-Instrument window. A total of 
15 banks of 128 program names is available. There are several ways to enter program names:

•• Double-click the name (via the text field).

•• Copy (via the Clipboard) from a different multi-instrument, or from a word-processing 
program. The Clipboard functions for a whole sound bank are available in the Options 
pop-up menu. 

•• First, copy the program numbers or General MIDI names to the Clipboard, and add them to a 
word-processing document. 

•• You can then edit the names and copy the whole section back again.

•• If you want to use program numbers instead of names, choose Init Names as Numbers from 
the Options pop-up menu.

•• If you want to use General MIDI program names, choose Init General MIDI Names. If the 
Use GM Drum Program Names for Channel 10 checkbox, at the bottom of the window, is 
activated, the standard GM drum set names are shown in the Program pop-up menu of the 
inspector for subchannel 10.

If the Program box in the selected subchannel’s inspector has a checkmark in it, you can send 
a program change message by selecting a program name in the Multi-Instrument window.
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•• Bank pop-up menu: The Bank pop-up menu allows you to choose one of 15 available 
sound banks (0 to 14). The top item—“No Bank specified. Names of Bank 0 used”—can be 
used if your sound generator does not understand bank select messages, or only has 128 
sound programs.

•• Bank 0 is always initialized. 

•• The first time you choose one of the banks numbered 1 to 14, you are asked whether or not 
you want to initialize this bank. 

•• For banks that are not initialized, the names of the equivalent program numbers from bank 
0 are used.

Note:  You should only initialize additional banks if you want to enter program names for those 
banks, because each initialized bank uses more memory.

•• Bank Message pop-up menu: The Bank Message pop-up menu allows you to define the MIDI 
events that are sent when you switch between the banks of the multi-instrument.

Different bank select formats are used by different MIDI instrument manufacturers. Refer to 
your MIDI instrument’s manual to see whether or not it supports bank select messages, and if 
so, what format it uses. 

With modern synths, there’s a good chance the format will match one of the top items in the 
menu: either controller #32 or controller #0. There are also presets to accommodate several of 
the more common types of synths. If your synth doesn’t use one of the formats listed, you can 
define your own bank select messages (see Custom bank selects on page 784).

Work with subchannels
Each of the 16 standard instruments in a multi-instrument provides a separate MIDI channel—
mirroring the 16 MIDI channels—and is therefore called a subchannel. The multi-instrument’s 
interface includes a numbered square (button) for each subchannel. Clicking a numbered square 
selects the corresponding subchannel, and displays its parameters in the Object inspector.

Each subchannel has a complete set of instrument parameters, identical to those for standard 
instruments. For details, see Standard instrument parameters on page 776.

The only parameter you can’t change is the MIDI channel. If you attempt to change the MIDI 
channel, you’re asked to select another subchannel, or select the multi-instrument itself to 
change the common driver destination. You can, however, change the channel in the Track 
inspector to any subchannel of the multi-instrument, and the track will be assigned to the 
selected subchannel. This allows you to redirect the (regions on the) track to another subchannel, 
making it easy to play multiple parts with a particular channel/sound.

Note:  If you change the Output port parameter of any subchannel, the entire multi-instrument 
and all other subchannels are affected.

As with any other Environment object, you can prevent subchannels from appearing in the 
Reassign Track shortcut menu in the Tracks area by deselecting the Assignable checkbox in 
the Object inspector. The button for the subchannel appears with a diagonal line through it 
when deactivated.
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In the above image, subchannel 1 is selected, subchannels 1 to 8 are activated, and subchannels 
9 to 16 have been removed from the Reassign Track shortcut menu.

Connect the output of an object directly to the input of a subchannel
mm Option-click the source object’s output triangle, then choose the subchannel in the Reassign 

Track shortcut menu. (See Cable Environment objects on page 766.)

You can’t drag a cable to a subchannel. Any dragged cables can only be connected to the entire 
multi-instrument object, not one of its subchannels.

Mapped instrument objects

Mapped instrument objects overview
A mapped instrument is particularly useful for drum instruments or any drum-mode MIDI device. 
A drum-mode device has different sounds assigned to different MIDI notes, but only uses a 
single MIDI channel; for example, a drum kit loaded into the EXS24 mkII, or MIDI channel 10 of a 
GM-compliant sound module, or a drum machine.

A mapped instrument is used just like a standard instrument, but each individual input note can 
be:

•• Named (snare, hi-hat, and so on)

•• Mapped to an output note 

•• Given a velocity offset

•• Assigned its own MIDI channel

•• Sent to one of up to 16 output cables (This allows you to create a single instrument that 
addresses multiple sound sources.)

•• Given its own notation parameters: note head shape, relative vertical position in the staff, and 
drum group assignment (See Use drum notation with mapped staff styles on page 697.)

The mapped instrument’s parameters are a subset of the standard instrument parameters. The 
missing settings are available on a note-by-note basis in the Mapped Instrument window. For 
details, see Common object parameters on page 756.

Create a new mapped instrument
mm Choose New > Mapped Instrument.
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Mapped Instrument window
The Mapped Instrument window opens when you double-click a mapped instrument icon or 
create a new mapped instrument. The rows correspond to input notes, and the columns contain 
the various parameters available for each note.

•• Keyboard (Selecting Notes): The keyboard on the left represents the input notes, which can be 
played by clicking them. You can also select individual notes or note ranges by dragging the 
mouse over the notes you want to use. To select multiple notes, Shift-click them. Any value 
alterations apply to all selected notes.

•• Input Name: In the first column, you can click the input note name (E6, for example), and enter 
a name of up to 12 characters. Press Return or click outside the field to confirm the new name.

You can initialize the names of the selected notes to:

•• Pitch descriptions (C#3, for example) by choosing Initialize > Names as Notes.

•• The names of GM Standard drum sounds by choosing Initialize > Names as General MIDI.

If a MIDI region (on a track routed to a mapped instrument object) is displayed in the Piano 
Roll Editor, the names of the notes being played appear on the vertical keyboard.

•• Output Note: This column is used to set the output note. This is done by either:

•• Double-clicking the note description and editing the text

•• Dragging the beam to the right of the output note name 

MIDI notes are sent while the value is being changed, allowing you to hear what you’re doing. 
Use the Initialize > Output Notes command to match the output notes of the selected pitches 
to the input note pitches.
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•• Velocity: Use to set a velocity offset that is added to, or subtracted from, the velocity of the 
incoming note. Drag the number vertically to create a velocity offset. You can also click the 
specific point on the beam.

To reset all velocity offsets to 0 (no offset), choose Initialize > Output Velocities.

•• Channel: Use to set the MIDI channel of individual notes. This lets you play individual sounds 
from different drum sets in the same sound generator. You will normally use the Base setting, 
which means that the notes are sent on the channel set in the mapped instrument’s inspector. 
If you choose All in the inspector, the channel information of the incoming notes is used. This 
is useful if you want to place the mapped instrument after a multi-instrument or standard 
instrument in the signal path.

To set all selected notes to Base, choose Initialize > Output Channels.

•• Cabling Mapped Instruments: You can send individual notes from a mapped instrument object 
to (up to) 16 different output cables, allowing you to play sounds from different sound sources. 
If you select a cable that doesn’t exist, the note won’t be sent out. The Initialize > Output 
Cables command resets all cables to #1 (the top outlet of the mapped instrument).

•• Notation Parameters: The last three columns define the notation parameters of 
individual notes.

•• Head: Use to change the note head.

•• Rel. Pos.: Use to alter the relative position of the note on the staff. The pitch isn’t altered; only 
the vertical positioning of the note head on a staff in the Score Editor. Drag vertically to alter 
the note position.

•• Group: As the mapped instrument object is typically used for percussion instruments, click-
holding the Group field opens a pop-up menu of grouped drum families: Kick, Snare, and so 
on. MIDI sound modules can have drum sounds mapped across 127 possible notes, which 
would result in an interesting staff (to say the least). Assign several related percussion sounds 
(tom drums, for example) to the Toms group to place all related sounds on a single staff line. 
As with the relative position, the pitch of grouped notes is not affected by grouping them 
on a single line.

To neutralize the settings of the Head, Rel. Pos., and Group parameters, choose Initialize > 
Score Parameters.
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Custom bank selects
Logic Pro provides 16 bank numbers (0 to 15) for each standard instrument, multi-instrument 
(including subchannels), or mapped instrument object. You can create custom lists, consisting of 
as many events (of any kind, even SysEx) as you like, for each of these banks.

Whenever you change the bank manually, or send a standard bank change message from Logic 
Pro, the entire list for that bank is transmitted to your sound module.

Set up custom bank select messages
	 1	 Select the instrument you want to define bank select messages for. 

	 2	 Choose Options > Define Custom Bank Messages. 

A window similar to the Event List opens, with a single, default bank select message for banks 0 
to 15. (The default used is a MIDI controller #0 message, with a value equal to the bank number.)

You can create MIDI events here as you would in the Event List, by cutting, copying, inserting, 
and editing. (See Edit events overview on page 412.) The only difference is that you enter a bank 
number, rather than a time position.

The letter in parentheses next to the bank number allows you to control the order of 
transmission when a bank select requires more than one message.

If there are no events defined for a particular bank, a standard bank select message is sent for 
that bank.

For bank messages that need a channel (MIDI controller messages, for example), the channel of 
the instrument is used. This feature is especially useful for multi-instruments, as you only need 
to create one set of bank messages for all 16 subchannels. If an instrument’s channel is set to All, 
channel 1 is used.

The custom bank select information becomes part of the instrument, and is automatically copied 
with it, if you replicate the instrument object.
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Touch track objects

Touch track objects overview
You use a touch tracks object to trigger MIDI regions or folders with single notes. This function 
can be used to create a new arrangement in real time, ideal for live performances.

You can’t use touch tracks to trigger audio. Any references to regions mean folders and MIDI 
regions, not audio regions. Despite this limitation, you could conceivably load your audio regions 
(as files) into the EXS24 mkII, and trigger it with a touch tracks object.

Here are some things to remember:

•• Only the touch tracks input has meaning—trigger notes must appear here. Although the 
object features an output triangle, it has no use, as events never appear here.

•• MIDI regions and folders triggered by touch tracks play exactly as they would from the main 
window: they play back through the instruments assigned to their tracks.

•• Logic Pro must be open for touch tracks to work.

Create a touch tracks object
Do one of the following:

mm Choose New > Touch Tracks from the Environment menu bar.

mm Drag a MIDI region or folder from the Tracks area into the Environment.

Use a touch tracks object
Do one of the following:

mm Assign the touch tracks object to a track.

mm Place the touch tracks object anywhere in the MIDI signal path.
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Touch Tracks window
Double-clicking a touch tracks object opens the Touch Tracks window.

This window is similar to the Mapped Instrument window. The input note is selected via the 
keyboard on the left, and the output region assignment and parameters are set in the columns 
of the corresponding row. For details about mapped instruments, see Mapped instrument 
objects overview on page 781.

A vertical gray line means that the setting is the same as the line above. If you change a vertical 
gray line that is above another vertical gray line, the lower one changes to display its previous 
value. (It’s no longer the same as the line above.)

•• Region Note Assignment: Dragging a MIDI region or folder into the Environment automatically 
creates a touch tracks object. All notes (initially) trigger this region. Middle C plays the region 
or folder at its original pitch, and all other notes transpose it, relative to middle C.

In the Input Name column, you can see the input notes, and to the right, in the Region/Folder 
column, the names of the assigned regions or folders. On the vertical keyboard to the left, you 
can select individual notes or pitch ranges by dragging across several keys. If you then drag a 
MIDI region or folder from the main window, it will only be assigned to the selected note (or 
note range).

•• Group: Groups behave as they do in the Step Editor. When you trigger a region, any other 
(currently playing) region in the same group stops. The Off setting means that the region is 
not assigned to any group.

•• Transpos (Transposition): When you drag a region to a key in the Touch Tracks window, that key 
triggers the region at its original pitch (without transposition). If you want to transpose the 
region, you can set the amount in the Transposition column.

If a key range is selected when you drag the region into the Touch Tracks window, incremental 
transpositions are set automatically for adjacent keys (within the key range).

When you create a touch tracks object by dragging a region into the Environment, C3 triggers 
the region at its normal pitch, and all other keys trigger it (transposed relative to C3).

•• Velocity: In the Velocity column, you can set the sensitivity of regions to the velocity value 
of the trigger note: by 100% (very sensitive), 50% (somewhat sensitive), or off (not velocity 
sensitive).
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•• Trigger Modes: The Trigger column determines how region playback is handled:

•• Multi: Playing the trigger note starts the region. Playing it again restarts the region, without 
stopping playback of the originally triggered version.

•• Single: Playing the trigger note once starts the region. Playing it again stops playback, and 
restarts the region.

•• Gate: The region plays until the trigger note is released (or until the region ends).

•• Gate Loop: The region loops until the trigger note is released.

•• Toggle: Playing the trigger note starts the region. Playing it again stops playback.

•• Toggle Loop: Playing the trigger note starts region looping. Playing it again stops playback.

•• Start: This column allows you to quantize region start and stop. Free means no quantization. 
The Next 1/16, Next 1/4, or Next 1/1 settings start or stop the region at the next 1/16 or 1/4 
note, or at the beginning of the next bar, when a trigger note is played.

•• Delay: Use this column to assign a delay to the region start point. The delay is set on the right 
side of the column in ticks, or on the left side in note values. You can use both Delay and Start 
to make regions start at any position in the measure. For example: Set Start to 1/1 and Delay 
to 480 ticks to start playback at the second 8th note in the measure.
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Fader objects

Fader objects overview
Faders come in different forms (knobs, sliders, numerical, and buttons). You use faders to send 
MIDI events by clicking or dragging them. Fader objects respond to incoming MIDI events.

Create a new fader
mm Choose New > Fader.

A submenu appears, in which you select a style of fader. There’s also a submenu at the bottom 
named Special, which you use to select various special fader types (cable switcher, meta-fader, 
and so on).

The style of a fader determines its onscreen appearance—fader, button, or knob, for example—
and how it responds to the mouse (drag, click, or double-click and enter a number).

Horizontal fader

Vertical fader Button

Knob

The auto style fader—the default style if you create a fader with a key command—changes 
styles as you alter its shape and size. 

The type of fader determines what events the fader sends out and responds to. In two cases, 
however, the fader doesn’t send out events at all:

•• The cable switcher routes events to its different outputs. Clicking a cable switcher object 
makes it step sequentially through the outputs.

•• The alias assigner changes the references (to an original, or parent object) of fader aliases.

In general, a fader’s style is completely independent of its type. A cable switcher can look like 
a button, a knob can send out MIDI or meta or SysEx events, and so on. The one exception is 
the vector style fader—these behave in a special way, by sending out two (or four, in special 
cases) messages at a time, depending on the mouse location within their 2-dimensional, 
vector window.
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Use faders
Normally, you grab the surface of a fader and drag it vertically or horizontally, depending 
on its style. When using the fader itself as a slider, you may notice that values jump in larger 
increments, depending on the size of the fader and dragging speed. You can also change values 
in single steps by dragging the slider or knob while holding down the Control key.

Some of the fader styles have numerical displays. In these cases, double-click in the numerical 
field and enter a value. When you drag any of the sliders or knobs, the series of values that are 
sent out depends on the fader size and scrolling speed—not every consecutive value is sent out 
at smaller sizes. If you drag slowly in the numerical field, however, you’ll send consecutive values.

Knobs can be dragged either vertically or horizontally.

Buttons only send two values, the lowest and highest of their range set in the Object inspector. 
You change a button’s state by clicking it.

The default appearance of the text fader is like a value field that can be scrolled. Double-click to 
open a window and enter text for each menu position. Select the Behaves as Menu checkbox to 
use the text fader as a pop-up menu.

A vector fader allows you to scroll in two directions, and sends out two values: one 
corresponding to the vertical position, and the other to the horizontal position.

Play back fader movements
As with the channel strips in the Mixer, you can record fader object movements to tracks, and 
play them back.

You don’t need any special cabling to record the data generated by a fader. All data generated by 
faders is recorded on the selected track when Logic Pro is in record or record/pause mode.

Any fader will react to incoming events that match its Input definition. The fader must, of course, 
be in the MIDI signal path. Typically, you would accomplish this by cabling the track instrument 
into the fader. 

For fader object automation tasks, however, it’s useful to create a new (standard) instrument for 
the sole purpose of fader automation. Make sure that the instrument:

•• Has no direct MIDI output

•• Uses the Channel setting All

•• Is connected to the first fader in any chain of serially cabled faders (if cabled this way)
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Work with object groups
When building a virtual mixing desk or synthesizer layout in the Environment, you often 
need to work with large groups of fader objects that have the same size, regular spacing, or a 
similar definition.

To save time on the definition and alignment of these groups, you can choose (one or more) 
objects as prototypes (templates) by copying them into the Clipboard. (Choose Edit > Copy.) You 
can then apply certain characteristics of these template objects to selected objects.

Transfer the size of the prototypes to the selected objects
mm Choose Options > Apply Buffer Template to > Size.

Transfer the alignment template of selected objects
mm Choose Options > Apply Buffer Template to > Position.

The selected target objects are positioned at the top-left corner of the Environment layer, in 
accordance with the layout of the template.

The Options > Apply Buffer Template to > Position and Size command combines both of the 
above functions.

•• Definition: The following describes the definition characteristics that can be transferred to 
selected objects.

•• The Options > Apply Buffer Template to > Definition function transfers the parameters of a 
copied template to all selected objects. If several templates of the same type are available, 
the one that is closest in size is used.

•• The Options > Apply Buffer Template to > “Definition, channel increment” increases the 
channel number from object to object, beginning with the top-left object. It’s not necessary 
for the selected objects to have the same Input or Output definition as the template.

•• The Options > Apply Buffer Template to > “Definition, number increment” increases the first 
data byte of the definition (controller number, for example).

•• Cabling Serially: The Options > “Cable serially” function connects all selected objects in series, 
beginning with the object at the top left.

•• Names with Numbers: If you name one object in a selected group of objects with a name that 
ends in a numeral, the remaining objects will adopt the name, but with sequentially increasing 
numbers. For example, selecting several objects and naming one of them “Object 1” results in 
the ensuing objects being renamed “Object 2,” “Object 3,” “Object 4,” and so on.
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Fader styles
A fader’s style is shown in the line under the icon. It can be changed by selecting the current 
style name and choosing a new style from the pop-up menu.

Remember that a fader’s style does not usually affect its function—you can select the most 
convenient style for the intended use of the object.

Some of the fader styles are described below.

•• Vertical/Mute: This is exactly like the Vertical 4 fader style, with an added Mute button.

When you click the Mute button, the fader sends an event (with a value of 0) that matches the 
Output definition.

•• The fader’s movements are not sent while the Mute button is on.

•• The current fader value is sent when you turn the Mute button off.

•• Buttons: Button style faders can only send two possible values: the minimum (off) and 
maximum (on) values of their range. If the minimum and maximum range parameters are set 
to the same value, the button sends this value each time it is clicked.

•• Text: Text faders function like numerical faders, but can display text for each of the 128 possible 
MIDI values (0 to 127). Double-clicking the surface of a text fader opens the Text Fader window.

•• Click a position in this window to send the corresponding fader value. (This is similar to 
selecting programs by name in the Multi-Instrument window.)
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•• Double-click a position in the window to enter new text. By default, when you create a text 
style fader, the text positions contain numerical values. You can use this feature to create 
numerical style faders with colored backgrounds.

You can modify the following parameters in the Text Fader window:

•• Options pop-up menu: Provides Cut, Copy, and Paste functions. You can use these operations 
to transfer the entire list of names to a text editor, for more convenient editing.

•• Empty lines (and lines that only contain spaces) are ignored.

•• If you want to insert blank positions in the list, use Option–Space bar.

•• Behave as Menu checkbox: Makes the text fader act like a pop-up menu. When unselected, 
the text fader acts like a scrolling menu.

•• Text Fader Range: Determines the number of names that can be entered into a text style 
fader object. If you set a text style fader’s range to 0, 1 you can only enter two values.

You should always set the minimum necessary range for a text fader, as this saves memory. 
In any case, remember that the first name corresponds to the lowest value in the range (not 
necessarily 0), and the last name corresponds to the highest value (not necessarily 127).

If you force a text fader to a value outside its range (with MIDI input) it displays “---” for values 
below its range and “+++” for values above. The one exception is when the fader’s range is 0, 1; 
in this case, all values above 1 display the name for value 1.
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Fader functions: MIDI events
Each fader has an Input definition and an Output definition. 

•• Input definition: Determines the types of MIDI events that can remotely control the fader.

•• Output definition: Determines the types of MIDI events the fader sends out.

A fader can, therefore, convert one type of MIDI event to another. Most MIDI events consist of 
three bytes:

•• The first byte indicates the type and channel of the MIDI event (a note on channel 3, for 
example).

•• The second byte indicates the first data value (the pitch of a note event, for example).

•• The third byte indicates the second data value (the velocity of a note event, for example).

A few MIDI events—program change and aftertouch—only use two bytes. Faders and 
transformers always provide for three bytes, with the second byte being discarded when these 
special, 2-byte messages are received.

Fader parameters are provided for setting the message type, MIDI channel, and the first data 
value. Note that the message type and MIDI channel are actually combined in the resulting MIDI 
event. The second data value is determined by the fader setting, or if the fader is being remotely 
MIDI-controlled, by the incoming MIDI event.

The following are used to define the Input and Output parameters:

•• Output (or Input): Defines the event type.

•• Channel (1 to 16): Defines the MIDI channel of the event.

•• -1- (0 to 127): Defines the first data byte of the event. In some cases, such as pitch bend, this is 
an actual data value. In other cases, such as MIDI controllers, this indicates the controller type 
(volume, pan, and so on). In other cases, such as aftertouch, this byte is unused.

The -1- parameter options are described here, including how the fader position affects them (for 
both the Input and Output definitions):

•• Note On: The -1- parameter sets the pitch, and the fader position sets the velocity. This is most 
useful as an Input definition, for trapping specific notes and converting them to other MIDI 
events, or simply monitoring their velocity. If you move a fader with an Output definition set 
to Note On, a note off MIDI event immediately follows the note on. This might be useful for 
creating onscreen drum pads from button style faders, for example. 

•• P-Press: The -1- parameter sets the pitch, and the fader position sets the amount of Poly 
Pressure (key pressure or polyphonic aftertouch). 

•• Control: The -1- parameter sets the MIDI controller number (the controller type), and the fader 
position sets the controller value. The controller type can actually be selected by name, via the 
pop-up menu that appears when you click-hold the -1- parameter.

•• Program Change: The -1- parameter is ignored. The fader position determines the 
program number.

•• C-Press: The -1- parameter is ignored. The fader position sets the channel pressure 
(monophonic aftertouch) amount.

•• PitchBd: The -1- parameter sets the pitch bend LSB, and the fader position sets the MSB. 
Typically, you would set the -1- parameter to 0, and use the fader to control the coarse pitch 
bend amount. A -1- setting of 0, and a fader position of 64, results in no pitch bend.

SysEx and Switcher/Meta are special functions of the faders.
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Fader functions: range, value as
The following parameters determine the minimum and maximum values of a fader, and how the 
fader displays these values:

•• Range: Contains two numbers—the left one sets the lowest possible fader value, and the right 
one sets the highest. Note that these limits can be exceeded by MIDI remote control. When 
the fader style is a button, the range determines the in and out position values of the button.

For text style faders, the first name always corresponds to the low end of the range, and 
subsequent names correspond to incremental range values, up to the top range. The number 
of names that can be entered into the window is limited by the range.

•• Value as: Determines the way that numerical values are displayed by the fader:

•• Number: The fader value is displayed as a number (0 to 127).

•• Pan: Fader value 64 is displayed as 0; smaller values appear as negative numbers and larger 
values as positive numbers (–64 to 63).

•• Hz, Octave, dB, ms: These display formats are tailored to various DSP functions.

•• bpm: An offset of 50 is added to the fader value. This displays the correct tempo settings for 
the Special > Tempo Control fader.

If none of the above formats is suitable, consider using a text style fader, and entering 
the display values you want as text. Examples include percentages, note names, and 
program names.

Fader functions: filter
This parameter provides various filtering options for MIDI events:

•• Off: All incoming MIDI events are allowed to pass through. All events that match the input 
definition are converted, in accordance with the output definition.

•• Other: All MIDI events that don’t correspond to the input definition are filtered. All events 
that match the input definition are converted in accordance with the output definition, and 
allowed to pass through.

•• Match: All MIDI events that match the input definition are filtered; all others are allowed 
to pass.

•• All: All incoming MIDI events are filtered.

•• Thru: All MIDI events coming from the Physical Input object are filtered. This is the same as 
turning off all events coming from Logic Pro (from regions or the Environment).

Use this filter mode to prevent MIDI feedback by blocking incoming MIDI events from being 
sent back out.

•• Shot: When the fader is moved with the mouse, only the final value (the value when the 
mouse button is released) is sent.

•• 14 Bit: The result of using this filter setting depends on how it’s used.

•• Used in conjunction with pitch bend, 2-byte (fine-tuning) pitch bend events are allowed.

•• Used with controller messages, the fader sends two MIDI controller messages: one for the 
MSB (Most Significant Byte) and one for the LSB (Least Significant Byte).

Note:  The fader’s Input and Output definitions must be the same or the 14 Bit setting will not 
work. 

For controllers, the MSB uses the Input definition controller number, and the LSB uses 
the controller number 32 or higher. This conforms to the MIDI standard for sending 14-bit 
controller data.
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When this filter setting is chosen, the fader’s Range can be set to a maximum value of 16,383. 
A fader value of 8192 represents no pitch bend.

•• Feedback: When the Feedback parameter is turned off (unselected), the fader automatically 
prevents feedback loops resulting from circular cabling. (The fader remembers when a specific 
MIDI event has passed through it and will not allow it to pass through again.) 

In some instances, you may want to enable feedback—to allow a MIDI event to change a cable 
switcher’s position after it has passed through the switch, for example. Selecting the Feedback 
checkbox will allow this behavior.

Vector fader
Vector faders function like joysticks. They can be moved in two dimensions: up and down and 
left and right. Each dimension generates its own MIDI events, so each time you change the 
position of the crosshair with the mouse, two MIDI events are sent.

Most faders have Input and Output definitions, which determine the MIDI events sent by the 
fader (Output), and those it reacts to (Input). (See Fader functions: range, value as on page 794.)

For vector faders, Input and Output definitions are replaced with Vert and Horz definitions, which 
determine the MIDI events that correspond to vertical and horizontal motion. If corresponding 
MIDI events are received by the vector style fader, its crosshair display updates accordingly.

If you set a vector fader’s Vert and Horz definitions to the same MIDI event (the same MIDI 
controller and channel), the vector fader sends out the same MIDI event each time the 
crosshair is moved, but on four consecutive MIDI channels, starting with the channel set in the 
Vert definition.

•• Upper-left for the lowest channel (channel 3, for example)

•• Upper-right (channel 4)

•• Lower-left (channel 5)

•• Lower-right (channel 6)
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The values of these MIDI events correspond to the proximity of the crosshair to the vector fader’s 
four corners:

•• In the center, all channels receive a value of 32. 

•• At the corners, the corresponding channel receives a value of 127 and all remaining channels 
receive a value of 0 (if using the default range of 0 to 127). 

If you alter the range, the center and corners behave differently, with the four values always 
totaling 125.

Special faders overview
The Environment provides a number of special fader objects that are built specifically to perform 
certain functions.

Cable switchers, alias assigners, and meta messages are types of faders that do not generate MIDI 
events. They share the same Output definition type, either Switch or Meta, depending on the 
current -1- value setting:

•• If the -1- value is 48, the fader is a cable switcher.

•• If the -1- value is 46, the fader is an alias assigner.

•• If the -1- value is any other value, the fader sends out meta messages of a type that 
corresponds to the -1- value.

Create a cable switcher
Do one of the following:

mm Choose New > Fader > Specials > Cable Switcher.

mm Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to 48.

Create an alias assigner
Do one of the following:

mm Choose New > Fader > Specials > Alias Assigner.

mm Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to 46.

Create a meta type fader
Do one of the following:

mm Choose it from the New > Fader > Specials menu.

mm Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to the desired 
meta event number.
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Cable switchers
Cable switcher objects route events, rather than generate them. Any kind of MIDI or meta event 
can be routed by a cable switcher. The only exception is events that match the cable switcher’s 
Input definition. These events will change the switch position (the routing), rather than pass 
through the cable switcher.

A cable switcher can be assigned to any fader style. It’s practical to use the text fader style, as 
it allows you to label the switcher’s various routes. Use Auto Style to actually display the switch 
routing, as shown above.

A cable switcher can have up to 128 separate cable outputs—a new output is generated each 
time an existing output is cabled to another object. You can click an auto style cable switcher to 
step through the outlets (including the last, uncabled one). 

Incoming events that match the cable switcher’s Input definition change the switch position to 
that of the incoming data value. (If the data value is greater than the number of switch positions, 
the last, uncabled outlet is selected.) 

Data values of 126 and 127 have a special effect.

•• An event with a value of 127 increases the output number. If you’re on the switcher’s last 
output when this event is received, you’ll jump back to the first output. This is just like clicking 
the fader.

•• An event with a value of 126 decreases the output number. If you’re on the switcher’s first 
output when this event is received, you’ll jump to the last output.
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Meta event faders
Meta faders generate special meta events, which are used to control certain Logic Pro functions, 
but have no MIDI meaning, and are never sent to the MIDI output.

In some cases—Go to Screenset, Go to Project, and so on—you don’t need to cable meta 
faders into another object for them to work. You can use cabling to process meta events in the 
Environment, and alter their effect.

However in the majority of cases—Set fader range minimum, Bang!, Set transformer operation 
minimum, and so on—the meta fader must be cabled to the object being affected.

The following is a summary of the currently implemented meta events that can be generated by 
faders:

Meta event Controlled function

46 Assign Alias

49 Go to Screenset

50 Go to Project

51 Go to Marker

52 Stop Playback

96 Set fader range minimum

97 Set fader range maximum

98 Set the fader value without sending

99 Bang! Causes the fader to resend its current value. 
The bang data value can be used to make the 
fader increment-without-rollover (127), decrement-
without-rollover (125), increment-with-rollover (123) 
or decrement-with-rollover (121). Use values one less 
than those shown to have the bang passed through 
to all connected faders.

100 Tempo Control

122 Set transformer map value for the currently selected 
map position

123 Select transformer map position

124 Set transformer condition maximum (bottom) 
parameter, if any. (This applies to all conditions not set 
to All.)

125 Set transformer condition minimum (top) parameter, 
if any. (This applies to all conditions not set to All.)

126 Set transformer operation maximum (bottom) 
parameter, if any. (This applies to all operations not set 
to Thru.)

127 Set transformer operation minimum (top) parameter, 
if any. (This applies to all operations not set to Thru.)

For more information about meta events 122 to 127, see Use meta events to control condition 
and operation values on page 818.
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Work with SysEx faders
The SysEx fader type is slightly different from other fader types. It is primarily designed to 
send MIDI System Exclusive (SysEx) messages—messages that are exclusive to individual 
manufacturers’ MIDI devices—whenever a specified fader is moved or controlled remotely. You 
enter the messages that you want to send in a window that resembles the Event List.

Note:  SysEx faders can actually be used for any kind of MIDI event, making them useful for 
sending ordered batches of messages, such as Mixer or control panel snapshots, with one click of 
the mouse.

Open the SysEx Fader Editor window
mm Select the fader, then choose SysEx from either the Output or Input pop-up menu in 

the inspector.

The SysEx Fader Editor window opens automatically.

You can also specify SysEx as an Input definition, but this has limited usefulness because the 
incoming message (presumably SysEx) must be very short in order to be recognized. (Because 
SysEx messages can be of any length, Logic Pro must break them into small packets to avoid 
interrupting other MIDI activities.)

An important thing to remember about the SysEx fader is that only selected events will have 
their value altered by the fader value when the SysEx fader window is closed. Events that are not 
selected will be sent exactly as they appear in the window.

For SysEx messages, you can determine:

•• The bytes that are altered

•• The format (MSB/LSB, BCD, nibbles, and so on) of the value

You can also specify a checksum format, if necessary.
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Work with SysEx messages
There are several ways to enter SysEx messages in the SysEx Fader Editor window.

Teach the fader to learn a SysEx string
	 1	 Click the MIDI In button at the top-right corner of the window.

	 2	 Alter the parameter on your device.

The corresponding SysEx message is displayed. You can also enter SysEx messages in the SysEx 
fader window by typing the SysEx string into the Event List. (Check your MIDI device manual for 
SysEx documentation.)

Manually enter SysEx strings
mm Choose Syst. Exclusive from the Event Type pop-up menu, then click the Add Event button.

Event Type pop-up menuAdd Event button

A generic SysEx message appears.

•• The first data byte in the top line (directly after the word SysEx in the Num column) is 
the manufacturer’s ID. This may be several data bytes long (as there are more than 128 
manufacturers of MIDI devices).

•• The manufacturer’s ID is usually followed by a device type ID, an individual device ID, a data 
type ID (which could be several bytes) and, if necessary, the number of the multi-timbral 
subchannel, and the identification number or numbers of the sound parameters plus the value 
of the sound parameter. There are no uniform standards that apply here. 

•• Data bytes are normally input as decimal numbers. To enter them in hex, place a $ in 
front of values when you type them. Choose View > SysEx in Hex Format to see all values 
in hexadecimal.

•• The last data byte (the EOX indicating the end of the SysEx message) is entered automatically 
by Logic Pro. The number of data bytes in the SysEx message can be decreased or increased 
by clicking the Plus and Minus buttons before and after the word EOX.
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Although you can have any number of messages (of any kind) in the SysEx fader’s Event List, 
there is only one fader value, and all selected messages adopt this value.

You can use a similar method to create any kind of MIDI or meta event in the SysEx fader 
window. Command-clicking any of the eight event type buttons (Note, Program Number, Pitch 
Bend, Controller, Channel Pressure, Poly Pressure, SysEx, and Meta Event) creates a new event of 
that type. Meta events can be created by using the expanded view button, featuring the 0’s and 
1’s on its face.

The terms SUM (for the checksum) and VAL (for the fader value) being sent are displayed within 
the SysEx string. 

Set the checksum and value of a SysEx event
	 1	 Select the events you want to alter.

	 2	 Choose options from the Checksum and Value pop-up menus (found in the lower-right corner of 
the window) to set the format of these bytes.

•• Checksum Format: A checksum can be created in any of the following formats:

•• Roland

•• Yamaha

•• Regular Checksum

•• 2’s complement

•• 1’s complement

If you don’t know which one works with your MIDI device, try “off” (= no checksum) first or “2’s 
complement.”

•• Value Byte Position: Position allows you to determine the position of the value byte. This 
position is specified in bytes, counted from the end of the message: “last” refers to the position 
directly before the EOX byte, “Last-1” indicates the byte before that, and so on. Auto ensures 
that the value byte is inserted at the last position in the SysEx string if no checksum was 
selected, or—if a checksum value was entered—that the value is inserted as the second-
to-last byte.
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•• Value Byte Format: The following table outlines the resulting data format of the value option 
you send: (The unused bits of the transfer in nibbles (X in 0XXXNNNN) are sent with the 
information at the relevant positions of the SysEx strings. If you want to transfer these deleted 
bits, you need to enter zeros in the SysEx string.)

Value option Result

Auto The value is sent as one byte if the value range 
maximum is 127 or less. If the maximum is higher 
than 127, the value is sent as two bytes, the MSB (most 
significant byte) first.

One Byte The value is sent as one byte.

MSB/LSB The value is sent in two bytes, with the MSB (most 
significant byte) first.

LSB/MSB The value is sent in two bytes, with the LSB (least 
significant byte) first.

BCD 4 LSB The value is sent as Binary Coded Decimal in four 
bytes, in the order 1, 10, 100, 1000.

BCD 4 MSB The value is sent as Binary Coded Decimal in four 
bytes, in the order 1000, 100, 10, 1.

2 Nibbles L The value is sent in two nibbles, with the least 
significant nibble first.

3 Nibbles L The value is sent in three nibbles, with the least 
significant nibble first.

4 Nibbles L The value is sent in four nibbles, with the least 
significant nibble first.

2 Nibbles M The value is sent in two nibbles, with the most 
significant nibble first.

3 Nibbles M The value is sent in three nibbles, with the most 
significant nibble first.

4 Nibbles M The value is sent in four nibbles, with the most 
significant nibble first.

2 ASCII M The value is sent in two nibbles, the most significant 
nibble first; the nibbles are sent in ASCII format for 
the hex value. For example, the value $7F (= 127 in 
decimal) will be transmitted as a 7 and F.

3 ASCII M Same as 2 ASCII M, but in 3 nibbles.

4 ASCII M Same as 2 ASCII M, but in 4 nibbles.
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Special functions
There are several behaviors and commands that enhance the use of fader objects.

•• Temporarily grouping faders: If you drag to select or Shift-click to select several faders and move 
one of them, all selected faders move proportionately.

As long as all faders remain selected, their relative positions are retained (even after one or 
more of the faders has reached its minimum or maximum position).

•• Option-dragging any fader in the group changes all values in a linear fashion. (The absolute 
value differences are maintained.)

•• Shift-Option-dragging any fader in the group changes all faders to the same value.

•• Sending fader values: Choose Options > Send All Fader Values (or use the Send All Current 
Fader Values key command) to make all fader objects send their current values. Choose 
Options > Send Selected Fader Values to make all selected fader objects send their 
current values.

Use of these commands in conjunction with the Record/Pause mode allows you to record 
a snapshot of all current fader positions. This is especially useful for virtual mixing desks, or 
synthesizer panels.

The File > Project Settings > MIDI > General > “Send After Loading Project: All fader values” 
option automatically sends all fader values after a project is loaded.

•• Resetting fader values: Choose Options > Reset Selected Faders to set all selected fader values 
to zero, and transmit the data.
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Alias objects

Alias objects overview
You can create an alias of any Environment object, and it will behave exactly like the original.

In the case of faders, the alias has its own value, which can be different from the value of 
the original object. This is particularly useful when using text faders, as they consume a lot 
of memory. If you need several text faders of the same name, make several aliases of one 
original object.

Aliases can be reassigned with meta events. You use a special fader, known as the alias assigner, 
which works like the cable switcher, to accomplish this.

Create an alias of any object
mm Select the object, then choose New > Alias.

Create an alias assigner
mm Choose New > Fader > Specials > Alias Assigner. 

A meta fader, with a -1- definition set to 46, is created.

To use the alias assigner, cable its top output to the alias, and cable subsequent outputs to the 
various originals that you want to assign to the alias. If you set the alias assigner’s maximum 
range to match the number of originals and its minimum range to 1, you can then connect the 
next cable to a new alias, and subsequent cables to originals for the alias. In this way, the alias 
assigner can be used to assign multiple aliases simultaneously. 

One situation in which you might use an alias assigner is when switching a delay line alias 
between different originals (different delay line objects), each set to different delay times. This 
method is one of several ways to provide MIDI control over delay time.

If you copy an alias, you create a new alias of the same original. If you select and copy both an 
alias and its original, you create a copy of the original with its own, separate alias.
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Alias parameters
Aliases share the parameters of their parent (original) objects, but they also have their own, 
special parameters:

•• Reference pop-up menu: Use to select the original on which the alias is based.

•• Channel field: Rechannelizes all events (except fader events), leaving the alias to the selected 
channel. If the Channel setting is All, existing channelized events are not changed.

For faders, the Channel parameter causes the alias to act as if the original fader’s Input and 
Output definitions are both set to the specified channel. (An All setting results in no change.)

•• Share Name and Share Size: When selected, the alias shares the size and name of the original. If 
unselected, it can be resized and given its own name.

Ornament objects
Ornaments are simply solid backgrounds behind other Environment objects. An ornament never 
covers other objects, so you can select multiple objects by dragging them without selecting the 
ornament itself.

Create an ornament
mm Choose New > Ornament. 
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GM mixer objects

GM mixer objects overview
The GM mixer is a collection of 16 fader modules, configured to emulate a virtual mixing desk 
for 16 MIDI channels. Each module includes controls for volume, mute, preset, and bank, and four 
assignable knobs (one of which is typically used for pan). There are optional controls for standard 
XG and GS effects.

Create a new GM mixer
mm Choose New > GM Mixer. 

The GM mixer is intended for controlling the 16 channels of a MIDI device which conforms to the 
GM, XG, or GS standard. This includes the GM set of 128 program names (with variation banks for 
XG or GS), MSB/LSB bank select messages, and standard controller names (#1 for mod wheel, #2 
for breath, #7 for volume, #10 for pan, #11 for expression, and so on).
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GM mixer parameters
Most of the GM mixer’s setup is done in the Logic Pro Mixer, but there are also a few parameters 
in the GM Mixer’s inspector:

•• Port pop-up menu: Sets the GM mixer’s direct MIDI output connection.

•• Channel pop-up menu: Determines the channel number of the lowest GM mixer module. You 
can use this (coupled with resizing the GM mixer) to create sub-mixers for any continuous 
string of MIDI channels (1 to 4, for example).

•• Legend checkbox: Turns the display of the legend along the left edge of the GM mixer off and 
on. The legend indicates what the rows of controls do, and is also used to set the function 
of the top four rows of knobs. After the GM mixer is set up, you can hide the legend to 
save space.

•• Bank checkbox: Hides or shows the bank MSB/LSB display at the bottom of the GM mixer. 
You can save space by hiding the bank display, unless you need to select program 
banks numerically.
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Work with the GM mixer channel strips
The MIDI channel strips work as a remote control for the mixing parameters of the controlled 
sound modules and synthesizers (volume and pan, for example).

•• If your sound source understands bank select events, you can choose the bank number 
with the Bank parameter field at the bottom of each channel strip (only visible if the Bank 
parameter in the Object inspector is selected). Remember that not all synthesizers support 
bank select events. You can use several different bank select formats (see Mapped instrument 
objects overview on page 781).

•• The Program button allows you to select a sound by name. Click it to open a pop-up menu 
that contains all GM sound names. Each channel has its own pop-up menu.

•• The Volume fader controls the output level of a MIDI channel. Adjusting it sends controller 7 
via your MIDI interface.

•• The Mute button switches the volume of the channel between zero and the current Volume 
fader position. In practice, this means that if the button is selected, the channel is muted. If you 
deselect the button, the current Volume fader position (and value) is used.

•• You can assign any controller to each of the knobs.

•• In addition to the GM Standard, there are extended standards created by Roland (GS) and 
Yamaha (XG). GS and XG mode allow you to select different effect programs, and to control the 
level of the reverb and chorus effects.

•• The Reset button transmits a GS On or XG On command, and resets all controllers to neutral 
positions. This allows you to reset all connected sound modules to their standard settings, and 
begin a mix from scratch.

Adjust the output level of a channel strip
mm Drag the Volume fader up or down.

Mute or unmute a channel strip
mm Click the Mute button.

Assign a controller to one of the knobs
	 1	 Click the label next to the knob.

	 2	 Choose the controller you want from the pop-up menu that appears.

Display the GS or XG effects
mm Open the Logic Pro Mixer, then choose GS/XG Effect Controls from the Mixer menu bar.

The GS/XG configuration control is displayed in the upper-right corner of the Mixer, allowing you 
to select different effect programs.

Configure GS or XG effects
	 1	 Choose the standard you want from the first pop-up menu in the upper-right corner of the Logic 

Pro Mixer. 

Depending on your selection, the controllers for the extended effects appear.

	 2	 Choose the reverb or chorus effect from the second pop-up menu.

	 3	 Program the reverb or delay time by double-clicking the Time parameter, then entering a value 
in the input field.
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MMC record buttons objects
The MMC record buttons object allows you to control the record-enable state of external MMC-
compatible recording devices. (See MIDI Machine Control on page 842.)

Create an MMC record buttons object
mm Choose New > MMC Record buttons.

You can resize the object to determine the layout and number of track record buttons.

Select the Extra checkbox in the inspector to display the “V TC A1 A2” extra tracks:

•• V for Video

•• TC for Timecode 

•• A1 for Aux Track 1 (or A) 

•• A2 for Aux Track 2 (or B)

Keyboard objects
You can use a keyboard object to create notes with the mouse. A keyboard object also displays 
all notes passing through it. In this sense, you can think of it as a real-time, MIDI note on monitor. 
Although you can record the output of the keyboard in Logic Pro, its main purpose is for testing 
and monitoring in the Environment.

Keyboards have the following parameters:

•• Channel field: Sets the MIDI channel for the keyboard’s output.

•• Velocity field: Determines a fixed velocity value for all notes.

•• Lowest field: Defines the octave of the lowest note on the keyboard object. You can resize the 
keyboard to control its range above the lowest note.

Create a keyboard object
mm Choose New > Keyboard.
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Monitor objects
A monitor object displays all events (MIDI and meta) passing through it. It remembers the last 32 
events, with the newest events shown at the bottom of the list. You can resize it to show from 1 
to 32 events. Clicking anywhere in the body of the monitor clears all events.

Monitors are useful as both testing and branching devices. When coupled with objects that have 
functionally different outputs (channel splitters and mapped instruments, for example), monitor 
objects can be used to attach more than one output cable to the same function.

Create a monitor object
mm Choose New > Monitor.
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Macro objects

Macro objects overview
Macros are not actually Environment objects. Rather, they are collections of other Environment 
objects and their cabling. Macros have a lot in common with standard Environment objects; you 
can connect cables to and from them, they can be resized, they have their own parameters and 
icons, they can be chosen as destinations in the track list, and they can be copied or dragged 
between Environment layers and between projects.

Macros are limited in size. The limit depends on the memory usage of the individual objects 
within the macro—typically between 100 and 200 objects.

You can nest macros, which means that a macro can contain other macros as objects.

Macros have the following parameters:

•• Auto Fader checkbox: If you select a group of faders and create a macro from them, selecting 
this box makes them behave as if they were cabled serially.

•• Show All checkbox: Determines which objects remain visible when integrated into a macro. 
When selected, all objects are visible (assuming the macro is not resized to hide some of 
them). When unselected, only fader, monitors, ornament, and keyboard objects are visible. You 
can select or unselect this checkbox at any time.

•• No Reset checkbox: When selected, the macro is prevented from responding to reset messages 
(set in Logic Pro > Preferences > MIDI > Reset Messages).

•• Protected checkbox: Select to protect a macro. Protected macros cannot be unpacked, so make 
sure you’ve made a copy of the objects and cabling before creating a protected macro.

Create a new macro
mm Select all Environment objects that you want to include, then choose New > Macro.

Logic Pro encloses all selected objects in a frame with a gray background. 

If some of the objects selected when a macro is being created have cables leading to unselected 
objects, these cables are deleted when the macro is created. A warning notifies you of this 
behavior. In this situation, the macro is made from a copy of the original selection of objects, and 
the original collection of objects remains unchanged. 

Unpack a macro
mm Double-click any empty (blank) section of the macro object.

The macro reverts back to its component objects and cables.
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Define a macro’s input and output
Because a macro is a collection of objects, individual objects need to be specified as the macro’s 
input and output. This can be done in two ways: by name or by default.

•• If you name one object Macro-In and another Macro-Out, these will automatically become the 
macro’s input and output.

•• If there is no object named Macro-In, the upper-leftmost object becomes the macro’s input.

•• If there is no object named Macro-Out, the lower-rightmost object becomes the 
macro’s output.

Cables leading into the macro deliver events to the macro’s input object, and cables leading from 
the macro carry events leaving the macro’s output object.
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Arpeggiator objects

Arpeggiator objects overview
An arpeggiator object turns chords into arpeggios. It plays the currently held notes—
individually—in a selectable pattern (up, down, random, and so on), and at a selectable speed 
that ranges between whole notes and 768th notes.

An arpeggiator features parameters for direction, velocity, speed (Resolution), note length, start 
quantize (Snap), repeats, octaves, and velocity offset (Crescendo). All parameters can be MIDI 
controlled in real time, which adds immensely to its versatility.

To use an arpeggiator object, you must place it in the MIDI signal path, and Logic Pro must be 
open. (For technical reasons, the arpeggiator resets on cycle jumps.) 

Typically, you would assign an arpeggiator to a track, and cable its output to an instrument. You 
can, of course, insert it where needed in the MIDI signal path. 

Once set up, you can use the arpeggiator with live MIDI input, or for MIDI region playback. You 
can also record the output of the arpeggiator by cabling it into the Sequencer Input object. If 
you do this, be sure you either record to a no output track, or break the arpeggiator’s connection 
to a MIDI output. 

Create a new arpeggiator
mm Choose New > Arpeggiator.
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Arpeggiator parameters
Arpeggiators have the following parameters:

•• Direction pop-up menu: Determines the direction of the arpeggiated chord. You can choose 
between the following settings:

•• Up: Lowest note to highest note

•• Down: Highest note to lowest note

•• Up/Down: Up and down; highest and lowest notes repeat.

•• Auto: Up or down, depending on whether the second chord note arrived before, or after, the 
first chord note.

•• Up/Down2: Up and down; highest and lowest notes don’t repeat.

•• Random: Notes play in random order.

•• All: All notes play at once (useful when Repeat is on).

•• Velocity field: Determines the velocity values of the arpeggiated notes. You can choose 
between the following settings:

•• 1 to 127: Fixed velocities

•• Original: The velocities of the recorded notes are retained.

•• Random: Random velocities between 1 and the original value

•• Key Limit field: Defines the pitch range for the chord arpeggiation. Any chord notes outside this 
range are passed directly to the output. This is useful when you want to solo above, or play a 
bass line below an arpeggiated chord.

•• Resolution pop-up menu: Sets the rhythmic note value (the speed in note divisions) of the 
arpeggio. The None setting deactivates the arpeggiator.

•• Length pop-up menu: Defines the length of the arpeggiated notes. The Original setting retains 
the length of incoming (or recorded) notes.

•• Snap to pop-up menu: Unless this value is set to None, the arpeggiator waits for Logic Pro 
to reach the next indicated note division before starting the arpeggio. This is useful for 
rhythmically synchronizing the arpeggio with other MIDI data.

•• Repeat checkbox: Selecting this option continues the arpeggio for as long as the chord is held 
down. If the option is unselected, the arpeggio only plays through once.

•• Octaves field: The arpeggio can be repeated over 1 to 10 octaves.

•• Crescendo field: The velocity value set here is added every time the arpeggio is repeated (if the 
Repeat parameter is on).
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•• Controller Base field: All ten parameters of the arpeggiator object can be controlled with 
MIDI continuous controller events. The Controller Base parameter determines the controller 
number for the first parameter (Direction). The other parameters are controlled by subsequent 
controller numbers. 

When Controller Base is set to Off, MIDI control of the arpeggiator is disabled.

Transformer objects

Transformer objects overview
You can use a transformer object to select, filter, and alter MIDI events in real time. Transformers 
can also process meta events, as long as they aren’t the meta events that affect transformers. 
These particular meta events change the transformer, rather than being processed by it. For more 
information, see Use meta events to control condition and operation values on page 818.

Create a new transformer object
mm Choose New > Transformer.

How the transformer object works
A transformer object checks whether or not an incoming event matches certain conditions. If it 
does, then certain operations are carried out.

Events that do not meet the conditions may pass unchanged to the output, or may be discarded.

The transformer can also make copies of matching events before altering them, and can split the 
selected (matching) events from the unselected ones, via its two top cables.

You must place the transformer in the MIDI signal path in order to use it. 

Alter the output of an instrument
	 1	 Cable the instrument output into the transformer (removing the instrument’s internal port 

assignment in the process). 

	 2	 Choose New > Instrument to create a new instrument, and assign it to the appropriate MIDI 
output port. 

	 3	 Cable the output of the transformer object into this newly created instrument (which, in essence, 
is simply acting as a MIDI output port).
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Configure a transformer object
Double-clicking a transformer icon opens the Transformer window, where you can set the 
conditions and operations.

•• Mode pop-up menu: Defines how a transformer handles MIDI events. You can choose between 
the following operation modes:

•• Apply operation and let non-matching events pass thru: MIDI events that match the condition 
are processed. MIDI events that don’t conform to the condition are passed through.

•• Apply operation and filter non-matching events: MIDI events that conform to the condition are 
processed. MIDI events that don’t conform to the condition are not passed through.

•• Filter matching events: All MIDI events that match the condition are filtered out. MIDI events 
that don’t conform to the condition are passed through.

•• Copy matching events and apply operation: All MIDI events that conform to the condition are 
copied, and the copy is processed. The original and transformed copy (plus any MIDI events 
that don’t conform to the condition) are passed through. The unchanged original is parsed 
(processed) before the transformed copy.

•• Copy matching events and apply operation (reverse order): This is the same as above, except 
the original is parsed after the processed copy. You might want to use this when converting 
note events to pan controllers, for example. This causes the pan message to be sent before 
the note. (Many synths don’t alter the pan position of notes that are currently playing.)

•• Condition splitter (true → top cable): Events that match the conditions are altered by the 
operations, and sent to a transformer’s top output. Events that don’t match the conditions 
are sent, unaltered, to a transformer’s second output. Don’t use the other outputs as nothing 
ever appears there.

•• Alternating split: Events entering the transformer are alternated between the top two outlets. 
No conditions or operations apply.
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•• SysEx mapper (data byte 1 → position, data byte 2 → value): This transformer mode is used 
to create and edit SysEx messages. The Transformer window operations are replaced by 
value fields that allow you to enter the structure of the SysEX message including its length, 
whether or not a checksum is required, and the values of bytes you don’t want to change in 
real time.

In the Conditions area, you select the type of MIDI event that will affect the data bytes in the 
SysEx message. (Typically, you’ll use MIDI controller events.) Incoming MIDI events will then 
change the SysEx message data bytes, according to the following rules:

•• The data byte 1 value sets the position of the data byte.

•• The data byte 2 value sets the value of the data byte.

•• Channel 1: The changed SysEx message is sent.

•• Channel 2: The changed SysEx message is not sent.

•• Channel 3: The unchanged SysEx message is sent.

•• Channels 4 to 16: No meaning (reserved for future use).

The “Filter non-matching” checkbox prevents incoming MIDI events (that don’t control the 
SysEx message) from being passed through. Typically, you’ll want this feature turned on, to 
prevent interloping controller data from invading the SysEx data stream.

•• Track automation splitter (true → to cable): If the condition matches, incoming events are sent 
to the track automation of the object connected to the top cable of the transformer, after 
passing through the Operation field. With the appropriate Operation field settings, incoming 
MIDI data is transformed into Fader event data, allowing the automation of any possible 
parameter of the connected Mixer channel strip. Exception: Channel volume and channel 
pan use Control events.

•• Define conditions and operations: The conditions and operations are the same as those found 
in the Transform window. For more information, see MIDI Transform window overview on 
page 467. The only differences arise from the fact that a transformer object works in real time 
and therefore position and note length have no useful meaning.

•• Edit pitch bend events: A transformer object can process 14-bit pitch bend events, which 
contain two discrete data bytes: if byte 1 is changed (by addition or scaling with the -1- 
operation), the change also affects the second byte. Set the Data Byte 2 operation to Thru to 
ensure that 14-bit pitch bend data is processed properly.
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Use meta events to control condition and operation values
You can control the values of any transformer conditions or operations by using meta events. 
Meta events are internal Logic Pro messages—their form is similar to MIDI controller events, 
but they have no MIDI meaning, they never leave Logic Pro, and they control internal Logic Pro 
parameters. 

Like MIDI controller events, meta events have two data values: the first one indicates the type of 
meta event (49 to 127, but not all are used), and the second one is the event value (0 to 127).

Meta events 122 to 127 affect transformer parameters.

•• Meta event #127 sets the first (top) operation value.

•• Meta event #126 sets the second (bottom) operation value (if available).

•• Meta event #125 sets the first (top) condition value.

•• Meta event #124 sets the second (bottom) condition value (if available).

Note:  Transformers can also process meta events, as long as they are not the meta events listed 
above. 

Note that all numerical condition and operation parameters used (conditions not set to All and 
operations not set to Thru) will be affected by the same meta event. The status condition and 
operation are not affected by meta events. 

If you want to set numerical parameters individually, or leave some fixed, use separate 
transformers in series.

•• Meta event #123 sets the transformer map position. 

•• Meta event #122 sets the transformer map value for the current map position. (Use meta event 
#123 to set the position first.)

Note:  You can use a transformer’s Map Set operation to create these two meta events 
simultaneously. When the operation status is set to Map Set, the Data Byte 1 parameter specifies 
the map position, and the Data Byte 2 parameter specifies the map value at that position. (A 
meta event #122 is sent with the Data Byte 1 value, followed by a meta event #123 with the Data 
Byte 2 value.)

You can create meta events with a fader object, you can transform MIDI events into meta events 
with a transformer, and you can add meta events to a MIDI region from the Event List. When you 
use a fader, set the Output definition to meta, then set the Data Byte 1 value to the meta event 
number. 

You can remotely control any fader by changing its Input definition, allowing you to use faders 
(as well as other transformers) to convert MIDI events to meta events for the remote control 
of transformers.
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Delay line objects

Delay line objects overview
A delay line object repeats (echoes) MIDI events passing through it, at intervals ranging from one 
tick to 256 whole notes.

Create a new delay line object
mm Choose New > Delay Line.

As with the arpeggiator, you need to place a delay line object in the MIDI signal path, and Logic 
Pro must be in playback mode. The echoes of each incoming event are sent, sequentially, to 
each cabled output of the delay line object: event 1 to cable 1, event 2 to cable 2, and so on. 
Obviously, if only one cable is connected, then all events are sent to that output.

The delay line can send up to 99 repeats, at intervals ranging from one tick to 256 whole notes. 
You can also suppress the original note events. 

Delay line parameters
Delay line objects have the following parameters:

•• Thru Original checkbox: If selected, the original events are passed thru. If unselected, the 
original events are suppressed (which means that only the echoes will be heard).

•• Repeats field: Defines the number of event repeats. The 0 setting turns the delay line off.

•• Delay field: The delay time between the individual repeats. The left value is in divisions, and the 
right value in ticks.

•• Transposition pop-up menu: Defines the transposition of note events per repeat.

•• Velocity field: Defines the change in the velocity values of note events per repeat.
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Voice limiter objects

Voice limiter objects overview
A voice limiter object restricts the number of MIDI notes (1 to 32) that can be held 
simultaneously. It does this by note stealing—newly arriving notes cause (some of the) currently 
held notes to be turned off, once the voice limit is reached.

Create a new voice limiter
mm Choose New > Voice Limiter.

Normally, you assign a voice limiter to a track, and cable its output to the instrument object that 
you want to voice limit. Alternatively, you can cable it between the instrument object that you 
want to voice limit and an instrument object used to represent a MIDI Out port.

Voice limiter parameters
Voice limiter objects have the following parameters:

•• Voices field: Determines the maximum number of voices that can be played simultaneously.

•• Priority pop-up menu: Determines which notes are stolen (turned off) when the number of held 
notes exceeds the limit (determined by the Voices parameter).

•• Last: The earliest notes (those played first) are turned off first.

•• Top: The lowest (pitched) notes are turned off first.

•• Bottom: The highest (pitched) notes are turned off first.

•• VelOn-Min field: Determines the velocity value of the MIDI notes. You can define a fixed velocity 
from 1 to 127.
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Channel splitter objects
A channel splitter routes MIDI events by channel. Every MIDI event received at the channel 
splitter input is automatically routed to the output that corresponds to its MIDI channel. If no 
cable is connected to the corresponding output channel strip, the event is rerouted to the SUM 
output (at the top).

Create a new channel splitter object
mm Choose New > Channel Splitter.

Chord memorizer objects

Chord memorizer objects overview
A chord memorizer maps individual notes to chords. You can assign one chord to each pitch 
class (to C, C#, D, and so on).

The octave of the incoming note determines the octave of the resulting chord. A chord can 
have 0–12 notes in it. (Zero and one-note chords can be useful for creating scale-filters and 
scale-correctors).

The easiest way to use a chord memorizer is to connect its output to the instrument that you 
want to play the chords through, and assign it to a track. You can, of course, place it anywhere 
else in the MIDI signal path.

Create a new chord memorizer
mm Choose New > Chord Memorizer.
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Chord memorizer parameters
Chord memorizer objects have the following parameters:

•• Channel field: All chord notes are sent to the defined channel.

•• Key Limit field: Notes within this range are mapped to chords. Notes outside the range are 
passed through unaltered.

•• Transposition pop-up menu: The output chords are transposed by the amount set here. For 
example, if you map C to a chord consisting of CEG, and set Transposition to 1, then C is 
mapped to C#FG#.

•• Key field: The entire chord map is transposed by the amount set here. For example, if you map 
C to CEG, and set Key to 1, then C# is mapped to C#FG#.

•• Cable Split checkbox: Select to send all notes triggered by a chord assignment to different 
chord memorizer object outputs (different cables).

Chord Memorizer window
Double-clicking a chord memorizer opens the Chord Memorizer window, where you can set up 
chord definitions.

The top keyboard is used to input and display the incoming note, and the lower keyboard 
is used to input and display the assigned chords. Notes can be entered with the mouse, or a 
MIDI keyboard.

Remember to only use notes that fall within the key limit range on the top keyboard. Also 
remember that you can only define one chord for each of the 12 pitch classes (C, C#, D, and so 
on). If necessary, you can use more than one chord memorizer object to define more chord types 
for each pitch class.
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Enter chords using the mouse
	 1	 Click the input note on the top keyboard. 

All notes in the associated chord are inverted on the bottom keyboard.

	 2	 Click notes on the bottom keyboard until the inverted notes of the desired chord are shown. 

You don’t need to stay within the same octave as the input note.

When you’ve entered the notes for your chord, select another input note (on the top keyboard), 
or close the Chord Memorizer window.

Enter chords using your MIDI keyboard
	 1	 Play the input note.

	 2	 Select the Listen checkbox in the Chord Memorizer window.

The lower keyboard is inverted, indicating its readiness to record.

	 3	 Play the notes of the desired chord. 

You can play them one at a time, or as a chord. If you make a mistake, deselect the Listen 
checkbox, then select it again to start over.

When you’ve entered the notes for your chord, deselect the Listen checkbox and play a new 
input note, or close the Chord Memorizer window.
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Physical input objects
The physical input object represents the physical inputs of your MIDI interface. You can only have 
one of these objects in the Environment.

The physical input object receives MIDI signals from the inputs of the MIDI interface or interfaces 
connected to your computer. This object has a total of 65 outputs.

The outputs follow the input assignment of all connected MIDI interfaces. The top output (SUM) 
carries the MIDI events for all individual outputs that are not cabled separately. 

Remote control events are intercepted at the physical input object, and are not passed through 
to its outputs. Because of this interception, remote control events will not reach the Environment, 
or be recorded on main window tracks. 

Create a physical input object
mm Choose New > Physical Input.

To make use of an existing object, drag it into the relevant layer. This does not affect its cabling.
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Sequencer input objects
The sequencer input object represents the MIDI input of Logic Pro. You can only have one of 
these objects in the Environment.

MIDI events arrive at main window tracks through the sequencer input object. If nothing is 
cabled into the sequencer input object, nothing can be recorded in Logic Pro.

Typically, the physical input object is cabled directly to the sequencer input object but other 
objects can be inserted between them. Candidates include a monitor, keyboard, or cable 
switcher object (feeding various processors such as an arpeggiator, a delay line, and so on). 

You can also cable the output of simple or complex Environment processes into the sequencer 
input object, in order to record the processed signal.

By default, the sequencer input object records on the MIDI channel (or channels) that the 
keyboard or MIDI controller (which is sending the MIDI events) is set to. 

If you turn on the sequencer input object’s Channelize parameter, the MIDI channel assigned to 
the MIDI object (of the selected track) is used, and recorded. This effectively means that if your 
keyboard is set to MIDI channel 7, and the track object is set to MIDI channel 3, all incoming data 
is channelized to (and recorded on) MIDI channel 3.

Create a sequencer input object
mm Choose New > Sequencer Input.

To make use of an existing object, drag it to the relevant layer. This does not affect its cabling.
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MIDI click objects
The MIDI click object is used to create note events at bar, beat, and division intervals. These can 
be sent to either a MIDI port or the internal speaker.

Each project can have only one MIDI click object. You only need to create a MIDI click object if 
the one that existed when the project was created has been deleted.

Create a MIDI click object
mm Choose New > MIDI Metronome Click.

Turn the MIDI click on or off
mm Click the Metronome button in the Logic Pro control bar.

You can access Metronome project settings by Control-clicking the Metronome button and 
choosing Metronome Settings from the shortcut menu. In this pane, you can set the MIDI click 
to play during playback or recording. The pane mirrors the settings of the MIDI click Object 
inspector: checkboxes for Bar, Beat, and Division allow you to generate note events separately for 
bars, beats, and divisions; the Channel, Note, and Velocity parameters define the MIDI channel, 
note number, and velocity of generated notes; the MIDI Port parameter allows you to set a direct 
output port for the metronome. See Metronome settings on page 882 for details.
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ReWire objects
You can use ReWire objects to send MIDI data to ReWire-compatible applications and their 
software instruments. To connect to a ReWire-compatible software instrument, first open Logic 
Pro and then the ReWire application. When shutting down, first quit the ReWire application, then 
Logic Pro. You can use the Library to create ReWire objects automatically.

Apart from common parameters, the Rewire object offers three settings:

•• Device pop-up menu: This setting refers to the ReWire application or applications that Logic Pro 
can connect to. If one or more ReWire applications is open, the Device parameter displays the 
names of these applications.

•• Bus pop-up menu: Use to choose the ReWire bus from all available ReWire busses. If a 
ReWire application provides bus names, they are shown. If using Reason, the names of the 
instruments available in the Reason Rack are shown from Bus 6 upward, in place of numbers.

•• Channel pop-up menu: Sets the MIDI channel of the ReWire object.

Manually create a ReWire object in the Environment
mm Choose New > ReWire.
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Channel strip objects

Channel strip objects overview
The Environment’s channel strip object is the building block of the Environment’s Mixer layer, 
the Logic Pro Mixer, and the inspector’s channel strips. For details about channel strip types, see 
Channel strip types on page 485.

Mixer layer channel strip object

Inspector channel strip object Mixer channel strip object

The audio and software instrument tracks you see in the main window are actually routed to 
channel strip objects on the Environment Mixer layer.

The Mixer channel strips and inspector channel strips are simply remote controls for the 
underlying channel strip objects in the Environment Mixer layer. Their inclusion in these other 
windows makes your workflow faster and easier.

The inspector channel strips contain a reduced parameter set of the corresponding channel 
strip objects in the Environment. The channel strips shown in the Mixer window are more 
configurable, but the only place you can access all channel strip options is the Environment 
Mixer layer.

Important:  If File > Project Settings > Audio > Automatic Management of Channel Strip objects 
is active (it’s on by default), you cannot create channel strips in the Environment. This setting, 
when active, means that use of the track and channel strip creation options in the main window 
will automatically create a corresponding channel strip object in the Environment (and therefore, 
remote control channel strips in the Mixer and inspector).

In a general music-making sense, you don’t need to access the underlying channel strips shown 
in the Environment. In fact, the only time you will open the Environment Mixer layer is when you 
need to reconfigure channel strips at a system level, rerouting them to different audio hardware, 
or perhaps to other applications.

Although channel strip objects aren’t part of the MIDI signal flow, they still allow MIDI messages 
to control aspects of audio and software instrument playback in Logic Pro. Any MIDI object can 
be cabled into a channel strip object, thereby feeding control data into it.
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Channel strip parameters
When you click a channel strip of any type (audio, software instrument, aux, output, master, input, 
or bus), the following common parameters are accessible:

•• Assignable checkbox: Makes the channel strip assignable from the Reassign Track shortcut 
menu in the Tracks area; Control-click the track header.

•• Device pop-up menu: Click the visible device name (Core Audio, for example) to reassign the 
selected channel strips to a different hardware device.

•• Channel pop-up menu: Click the visible channel name (Audio 1, for example), and choose 
the channel strip type from the submenus. This is how you can reassign a (newly created or 
existing) channel strip object (an audio channel strip is the default for new objects) to other 
channel strip types. You can choose from:

•• Audio: The default channel strip type, used as the destination for audio tracks.

•• Input: Primarily retained for compatibility with projects created in earlier versions of 
Logic Pro.

•• Aux: Auxiliary channel strip, used as send returns for all channel strips (via Sends), as 
subgroup channels, and as individual output destinations for multichannel software 
instruments (EXS24 mkII, for example).

•• Instrument: Used as the destination for (software) instrument tracks.

•• Output: Represents the physical outputs of your audio interface. You can choose either mono 
or stereo (paired) outputs. 

•• Bus: Primarily retained for compatibility with projects created in earlier versions of Logic Pro. 
The functions of bus objects are now performed with (the more flexible) aux channel strips 
in Logic Pro.

•• Master: Only one master channel strip can exist in a project. This is the master volume 
control for all channel strip types (except external MIDI channel strips).

•• MIDI Channel pop-up menu: Choose a MIDI channel that can be used to control the 
channel strip.

•• Q-Reference checkbox: Allows you to use the transients of regions on tracks that reference the 
channel strip for audio quantization, if part of an Edit Group.

•• Flex Mode pop-up menu: Choose a flex algorithm that can be used to process the audio 
material on the selected channel strip.

•• Show checkboxes: Select the corresponding checkbox to show EQs, Inserts, Sends, and I/Os on 
the selected channel strip or strips.
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Input channel strip
You can only create input channel strip objects in the Environment. In general, you will not need 
to do so, as all audio hardware inputs are automatically seen by audio channel strips, and can be 
monitored and recorded. 

Input channel strips are primarily included for compatibility with earlier versions of Logic Pro, 
and for use with certain audio hardware devices. The input channel strip allows you to directly 
route and control signals from your audio hardware’s inputs. Once an input channel strip is 
assigned to an audio channel strip, it can be monitored and recorded directly into Logic Pro, 
along with its effects plug-ins.

The signal is processed, inclusive of plug-ins, even while Logic Pro is not in playback mode. In 
other words, input channel strips can behave just like external hardware processors. Aux sends 
can be used pre or post fader.

Input channel strips can be used as live inputs that can stream audio signals from external 
sources (such as MIDI synthesizers and sound modules) into a stereo mix (by bouncing an output 
channel strip).

Note:  An alternative to using input channel strips in this way is the use of the I/O plug-in; you 
can also click the Input Monitoring button on an audio channel strip and choose the input or 
inputs you want to monitor or record via the Input slot.

Bus channel strip
You can only create bus channel strip objects in the Environment. In general, you will not need to 
do so, as all audio bussing (send/return routing via the Send slots of channel strips) is handled by 
aux channel strips.

Bus channel strips are primarily included for compatibility with earlier versions of Logic Pro, and 
for use with certain audio hardware devices.

Note:  File > Project Settings > Audio > Automatic Management of Channel Strip Objects must 
be unselected if you want to create input channel strips. (It’s on by default.)

Prelisten channel strip
The Environment’s Prelisten channel strip is used for monitoring in the Project Audio Browser 
and in the Audio File Editor. It’s created automatically in each project—you can find it to the 
right of the highest-numbered audio channel strip.
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Video and synchronization overview
Logic Pro X provides features that let you create or edit the soundtrack of any video or film 
project. See Add a movie to your project and Work with absolute time code.

Logic Pro X supports most synchronization protocols, allowing you to work with synchronized 
external video or film editing and playback hardware, or with video files stored on a locally 
attached or networked hard drive. Logic Pro X can act as the master synchronization device 
or as a synchronization slave to another device. It works best as the master device. See 
Synchronization overview and External synchronization.

  Logic Pro X Project video preferences are available when Advanced tools and additional 
options is selected in the Advanced preferences pane.

Use movies in Logic Pro X

Add a movie to your project
You can view a QuickTime movie file synchronously with your project, making film and TV 
scoring quick and easy. Although you can’t record or edit video directly in Logic Pro X, you can 
replace the soundtrack of a video file with music, Foley, and dialogue arranged in your project.

You can open a QuickTime movie in a separate Movie window and can also display the single 
frames of a QuickTime movie in the global Video track. 

When a movie is opened in a project, the upper part of the inspector shows a closed Movie area, 
which can be opened by clicking the disclosure triangle.

Movie playback follows the playhead position, and vice versa, in the Movie inspector area and in 
the Movie window. 

Video and synchronization 24
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Note:  You will need a fast processor to ensure smooth movie playback. If you want to record 
and edit your own QuickTime movie from a video recorder or digital camera, you may need 
specialized hardware.

Open a Movie window in Logic Pro X
Do one of the following:

mm Choose File > Open Movie (or use the corresponding key command, default 
assignment: Option-Command-O).

mm Open the Movie pop-up menu in the global Movie track header, then choose Open Movie.

mm Click any position on the Video track with the Pencil tool.

mm Click the Media button in the control bar, then click the Movies button and choose the movie file.

The movie opens in the floating Movie window, in its correct aspect ratio.

Note:  Only one QuickTime movie can be opened in a project. If you use the Open Movie 
command in a project that already contains a movie, a Movie window reopens with the same 
video clip. This is particularly useful if you want to open the video clip in a different screenset. If 
you choose the command while the Movie window is open, a dialog appears, allowing you to 
choose a new movie file.

Remove a movie from a project
Do one of the following:

mm Choose File > Movie > Remove Movie (or use the corresponding key command).

mm Open the Movie pop-up menu in the global Movie track header, then choose Remove Movie.

All references to the movie are deleted from the project. 
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Use the Movie window
You can drag the slider at the bottom of the Movie window or use the QuickTime transport 
buttons to navigate to any position in a video file. The Logic Pro X playhead will then “chase” 
to the corresponding project position. All QuickTime transport functions interact with those of 
Logic Pro X.

Resize the Movie window
Do one of the following:

mm Drag its lower-right corner.

mm Control-click the movie, then choose one of the following image formats from the 
shortcut menu.

•• 0.5 Size: Reduces the movie to half its original size.

•• Original Size: Displays the movie at its original size. 

•• 2x Size: Expands the movie to twice its original size.

•• 3x Size: Expands the movie to three times its original size.

•• Fullscreen: Expands the Movie window to fill the full screen. 

•• Keep Aspect Ratio: If selected, the proportions of the image are retained when the Movie 
window is resized.

•• Center: Places the video image in the center of your screen.
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About the Movie track
The global Movie track displays the opened QuickTime movie as thumbnails. If the Movie track is 
not visible, see Show and hide global tracks.

The number of frames displayed on the Movie track depends on both the track height and 
the zoom level of the window. All frames are aligned left, with only the very last frame aligned 
to the right. This guarantees that you can always see at least the first and last frames of video, 
independent of the current zoom level. Given the left alignment of all frames (except the last), 
the left margin of a frame is always displayed at the exact position of that particular frame.

Movie track settings can be adjusted in the Movie preferences window. See Movie preferences.

Use movie scene markers
Scene markers are SMPTE-locked markers: they remain at the same absolute time position, 
regardless of tempo changes, and are automatically deleted if the current movie is removed from 
the project. Scene markers are identified by a filmstrip icon.

You can use the Create Movie Scene Markers function to search the movie for significant content 
changes (scene cuts), and automatically generate scene markers for each of them.

The Create Movie Scene Markers function uses a fixed threshold value, which works well for most 
types of movies: cartoons, real life, CGI, and so on.
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Search a movie for scene cuts
mm Choose a movie range from the Navigate > Other > Create Movie Scene Markers submenu.

Search a movie for scene cuts using the Auto Range setting
The Auto Range setting follows the decision path outlined below, when determining which part 
of the movie will be evaluated:

•• Marquee selection

•• Cycled project part

•• Selected regions

•• All—if none of the above criteria is met

Do one of the following:

mm Open the Movie pop-up menu in the global Movie track header, then choose Create Marker Set 
from Scene Cuts.

mm Use the Create Scene Markers (Auto Range) key command.

Remove individual scene markers
Do one of the following:

mm Choose an option from the Navigate > Other > Remove Movie Scene Markers submenu.

mm Use the Remove Scene Markers (Auto Range) key command.

mm Open the Marker List, select the scene marker, then choose Edit > Cut or Edit > Delete from the 
Marker List Edit menu (or use the corresponding key commands).

Remove all scene markers or marker sets
Do one of the following:

mm Choose Remove All Scene Markers from the Navigate > Other > Remove Movie Scene 
Markers submenu.

Note:  This command does not remove the marker set; only the markers in the set.

mm Open the Marker pop-up menu in the global Marker track header, then choose Marker Sets > 
Delete Set.

mm Open the Marker List, then choose Marker Sets > Delete Set in the Marker Set pop-up menu.

Convert a scene marker to a normal marker
mm Open the Marker List, select the scene marker, then choose Options > Convert to 

Standard Marker.

Convert a normal marker to a scene marker
mm Select the marker in the Marker List, then choose Options > Convert to Scene Marker. 
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Use movie audio tracks
Once a movie has been opened in a project, you can use the Import Audio from Movie or 
Export Audio to Movie command, found in the File menu. After the audio has been imported, 
you can change the video dialogue, Foley, and music with Logic Pro X audio processing and 
editing features.

You can export audio from the part of your project that is encompassed by the movie to the 
movie file itself, effectively overwriting the original movie soundtrack. This is useful for sending a 
preliminary mix of your soundtrack to other members of the production team, for example.

You can adjust the audio level and output device in the Video project settings. See Movie 
settings on page 911.

Import audio from a QuickTime movie into your project
	 1	 Select the audio track or tracks you want to use.

	 2	 Do one of the following:

•• Choose File > Movie > Import Audio from Movie (or use the corresponding key command).

•• Control-click anywhere in the Movie track, then choose Import Audio from Movie from the 
shortcut menu.

	 3	 Click the required checkboxes in the dialog, then click OK.

The selected audio tracks are bounced to one or more audio files, and placed in the Project 
Audio Browser. A new audio track is created for each movie audio track (when “On separate 
tracks” is chosen in the dialog), and the imported audio from the movie is added to the track (or 
tracks). The movie name is retained and used for the resulting audio file (or files).

Export your project audio to a QuickTime movie
	 1	 Do one of the following:

•• Choose File > Movie > Export Audio to Movie (or use the corresponding key command).

•• Control-click anywhere in the Movie track, then choose Import Audio from Movie from the 
shortcut menu.

	 2	 In the dialog, choose a preset format from the Presets pop-up menu.

	 3	 Click the Advanced button to specify the Audio Format, Sample Rate, and Bit Depth from the 
respective pop-up menus.
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	 4	 Enter a name and target folder for the movie, then click Save.

A bounce or write dialog appears. The movie is exported to the selected folder, and contains all 
selected audio tracks, as well as the part of your project that is encompassed by the start and 
end points of the movie. 

Create and edit soundtracks

Soundtracks overview
Creating a new video soundtrack is similar to working with any Logic Pro X project. You can 
import or record audio and instrument parts, arrange them, process them with effects, and mix 
your music, dialogue, and sound effects (known as Foley) in stereo or a surround format.

You can also import an existing movie soundtrack, edit or enhance it in Logic Pro X, and then 
export your audio back to the movie file. See Use movie audio tracks.

The key difference when working with video or film is the need for synchronicity between what 
is seen and what is heard. Logic Pro X supports several synchronization protocols that let you 
work with video at all standard frame rates. See Synchronization overview.

You can use video files stored on a locally attached or networked hard drive, or work with 
synchronized external video or film editing and playback hardware. 

Working with disk-based video is preferable because you can see the video in Logic Pro X and 
don’t have to wait for hardware to “catch up” when moving from one scene to another. The 
imported video and Logic Pro X are “frame-locked” when you move through your project or 
video with either the Logic Pro X or QuickTime transport and navigation controls. See Add a 
movie to your project.

QuickTime video is embedded with an internal SMPTE (Society of Motion Picture and Television 
Engineers) timecode. SMPTE timecode is an absolute timecode that covers a 24-hour period. It 
displays hours, minutes, seconds, frames, and subframes. Logic Pro X recognizes SMPTE timecode 
and converts it to MTC (MIDI Time Code). MTC is the MIDI equivalent of SMPTE timecode. 
Different video frame rates are automatically interpreted by Logic Pro X. See MTC interpretation.

Work with absolute time code
The production process for video, film, or TV commercials is different from music production. 
Synchronization is always used, unlike in music production, where it is not always required. You 
need to work in absolute time: hours, minutes, seconds, and frames, rather than in bars and 
beats. Edits to the video, including changes to scene length, additional cuts, the use of slow 
or fast motion, and dialogue changes (or “redos”) are among the many situations that you will 
encounter when creating or editing a soundtrack.

The Event List is ideal for precise placement of timing-critical events such as footsteps or 
dialogue in a video soundtrack. It also allows you to change event lengths, which is useful if 
frames are removed during the video editing phase of production. In linear editing windows, the 
ruler can display absolute (SMPTE) time or bars and beats (or both).

When working with synchronized video, you will want music, sound effects, and dialogue to play 
at a specific time, rather than at a particular bar position.

If the tempo of your soundtrack needs to be altered at a later stage, the absolute time location 
of events that have already been positioned will change. The Lock SMPTE Position function 
prevents this from happening. You can SMPTE-lock individual events in the Event List or entire 
regions. All events inside locked regions are SMPTE-locked.
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  The Lock (and Unlock) SMPTE Position function is available only when Advanced tools and 
additional options is selected in the Advanced preferences pane.

You can use the Pickup Clock (Move Event to Playhead Position) key command to move a 
selected event, such as a note, a tempo event, or a region, to the current playhead position.

If you want a particular bar in the project to coincide with a specific time position, you can 
change the tempo of the preceding passage.

Change the Event List display to time units
mm Choose View > Show Event Position and Length as Time to display all event positions and 

lengths as absolute (SMPTE) times, rather than bar/beat values.

Lock a region or event to its current time position
	 1	 Select the region or event.

	 2	 Do one of the following:

•• In the Main window, Event List, Step Editor, or Piano Roll Editor, choose Functions > Lock 
SMPTE Position.

•• Use the Lock SMPTE Position key command.

Regions or events locked to a (SMPTE) time position display a small padlock icon in front of 
their name.

Note:  Copies of locked regions or events do not preserve their locked status, whether copied or 
pasted via the Clipboard, or by Option-dragging.

Unlock the time position of a locked region or event
	 1	 Select the region or event.

	 2	 Do one of the following:

•• In the Main window, Event List, Hyper Editor, or Piano Roll Editor, choose Functions > Unlock 
SMPTE Position.

•• Use the Unlock SMPTE Position key command.

All selected regions or events that were locked to a (SMPTE) time position are now fixed to their 
current bar position. This means that tempo changes will affect their position. The padlock icon 
in front of the name disappears.

Move a region or event to a frame
	 1	 Set the playhead position to the desired time, such as a specific movie frame in the Video track, 

for example. 

Note:  In addition to the usual position commands, you can use the Rewind One Frame and 
Forward One Frame key commands to move one frame backward or forward.

	 2	 Select the region or event that you want to place at this time position.

	 3	 Use the Pickup Clock (Move Event to Playhead Position) key command to align the start point of 
the region or event with this time position.

The Pickup Clock & Select Next Event key command selects the next region or event, after the 
first region or event is moved. 

Note:  When using Pickup Clock with audio regions, it is the region anchor—not the region start 
point—that is moved to the playhead position.
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Position a bar to a specific time
	 1	 Open the Tempo List. See Tempo List overview on page 586.

	 2	 Create a tempo event at the target bar position.

	 3	 Set a time position for this tempo event in the (SMPTE) Position column.

The preceding tempo event is automatically adjusted, to generate the correct bar and time 
position for the inserted tempo event.

	 4	 If you want to keep the same tempo for the following passage, delete the tempo event 
you inserted.

Logic Pro X synchronization

Synchronization overview
Logic Pro X supports most synchronization protocols, allowing you to synchronize it with 
external hardware and software. Logic Pro X can act as the master synchronization device or as a 
synchronization slave to another device.

  The Lock (and Unlock) SMPTE Position function is available only when   Show Advanced 
Tools is selected in the Advanced preferences pane.

In all synchronization situations, regardless of the simplicity or complexity of your studio 
configuration, the following rules apply:

•• There can be only one synchronization master.

•• The synchronization master sends timecode information (synchronization signals) to one or 
more synchronization slaves.

Important:  In most cases, you will need to manually set each synchronization-capable device—
including Logic Pro X itself—to act as master or slave. If you don’t do this, there will be multiple 
master devices in your system, which will result in synchronization errors.

Supported synchronization protocols
•• MIDI Time Code (MTC): Translates a SMPTE timecode signal into a MIDI standard timecode 

signal. See MTC interpretation.

•• MIDI Clock: Short MIDI message for clock signals. Used to provide a timing pulse between 
MIDI devices.

•• Logic Pro Xcan send MIDI Clock signals to synchronize external devices.

•• Logic Pro Xcan not receive MIDI Clock synchronization signals.

•• SMPTE timecode: An audio signal that is translated into MTC by some MIDI interfaces, such as 
the Unitor8.

•• Word Clock: A signal that is carried by all digital audio interface formats: ADAT, FireWire Audio, 
S/P-DIF, AES-EBU, T-DIF, and others. Used to maintain the timing integrity of sample words 
in audio signals that are transmitted digitally between Logic Pro X and external hardware or 
software. See Audio Synchronization settings.

•• ReWire: Logic Pro X can act as a ReWire host. It acts as the master synchronization source for 
ReWire-enabled applications such as Reason and Ableton Live. See ReWire objects.

Tip:  Logic Pro X also supports manual or “human” sync, when slaved. This is not a synchronization 
protocol per se, but enables Logic Pro X to follow tempo changes in real time. As an example, it 
could chase a live drummer. See Use the Tempo Interpreter on page 596.
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External synchronization
When you first open Logic Pro X, it is in Internal Sync (master) mode. The control bar Sync button, 
if visible, is not activated.

When Logic Pro X is running as a synchronized slave, the control bar Sync button is activated.

You can use the Sync button to turn external synchronization on or off at any time, without 
changing the selected synchronization source. This allows you to temporarily disengage Logic 
Pro X (running as a slave) from an external synchronization master device and could prove 
useful, for example, if you need to quickly edit a MIDI region while the external synchronization 
source—tape machine, VTR, and so on—is still running.

You can use the Sync button shortcut menu to choose a synchronization source.

Note:  The control bar Sync button is not displayed by default.

View the control bar Sync button
	 1	 Control-click the control bar, then choose Customize Control Bar from the shortcut menu.

	 2	 Select the Sync checkbox toward the bottom of the Modes and Functions column, then click OK.

Synchronize Logic Pro X
mm Click the control bar Sync button to synchronize Logic Pro to the chosen synchronization source.

Open synchronization settings with the Sync button shortcut menu
mm Control-click the control bar Sync button to open a shortcut menu, then do one of the following:

•• Set the type of external synchronization (a synchronization source). Choose from:

•• Internal Sync

•• SMPTE Sync (MTC)

•• Manual Sync (Tempo Interpreter)

•• Auto Sync In

•• Determine if MMC commands should or should not be transmitted when using the Logic Pro 
X control bar buttons. MMC commands are used for remote control of MIDI-controlled tape 
machines. See MIDI Machine Control on page 842.

•• Open the Synchronization settings. See General Synchronization settings.

•• Open the tempo editors. See Tempo overview on page 581.

View the frame rate of incoming MIDI timecode
mm Click the upper (MIDI In) section of the MIDI Activity display while receiving an external 

synchronization signal.
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MTC interpretation
The MIDI standard supports four of the seven commonly used timecode formats: the 30 fps and 
29.97 fps (frames per second) formats are not differentiated in the MIDI specification.

Logic Pro X needs to determine the intended format of incoming MTC (MIDI Time Code) and 
interprets it as follows:

•• 23.976 fps is interpreted as 24 fps.

•• 24 fps is interpreted as 24 fps.

•• 25 fps is interpreted as 25 fps.

•• 29.97 fps is interpreted as 29.97 fps.

•• 29.97 fps drop frame is interpreted as 29.97 drop fps.

•• 30 fps drop frame is interpreted as 29.97 drop fps.

•• 30 fps is interpreted as 29.97 fps. 

Note:  MIDI Time Code (MTC) is the MIDI equivalent of the audio-based SMPTE (Society of Motion 
Picture and Television Engineers) timecode format.

Manually set a frame rate
mm Choose a frame rate in the File > Project Settings > Synchronization > General > Frame Rate 

pop-up menu. This setting overrides the automatic detection and interpretation of frame rates.
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MIDI Machine Control
MMC (MIDI Machine Control) is a set of MIDI commands that Logic Pro X uses to control the 
transport functions of any MMC-capable tape machine. The recording process can also be 
controlled and automated from Logic Pro X via MMC. 

The tape machine provides a SMPTE signal that Logic Pro X uses as a synchronization source—
with Logic Pro X as the slave.

You control connected devices from Logic Pro X by using the control bar and navigation 
functions, including direct positioning and cycle jumps. Dragging the playhead sends a 
continuous stream of MMC Locate commands until you release the mouse button.

Important:  Logic Pro X needs to wait for the connected device to finish rewinding or forwarding.

Turn on MMC
Do one of the following:

mm Control-click the control bar Sync button, then choose the MIDI Machine Control (MMC) setting 
in the shortcut menu. 

mm Choose File > Project Settings > Synchronization, then select the Transmit MMC checkbox in the 
MIDI tab.

Set up a MMC tape machine for recording in Logic Pro X
Logic Pro X supports up to 64 MMC tracks, allowing devices such as the ADAT to be operated 
with MIDI Machine Control.

Each track can act as a tape control track.

	 1	 Create an instrument track.

	 2	 Option-click the instrument icon in the Track inspector, then select the MMC icon from the 
Others category.

The MMC icon is the only icon that actually affects the way a track behaves. All other icons are 
purely graphical in nature.

You only need to create one instrument with the MMC icon. This instrument can be assigned to 
as many tracks as required for control of (each track on) your external recorder.

Tip:  It is recommended that you group tape control tracks in a folder. Tape control tracks must 
be placed at the top of the track list. If you pack tape control tracks into a folder, this folder must 
be the top track in the list.
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Switch the record-enabled state of one or more MMC tape tracks
When a tape track is selected, the corresponding track on the tape machine switches to a record-
enabled state, and deactivates the record-enabled state of all other tracks. You can also do any of 
the following:

mm Shift-click multiple tracks to select and record-enable several tracks on the tape machine.

mm Control-Shift-click any track to individually toggle the record-enabled state for each track of the 
tape machine: selected tracks are switched on, and unselected tracks are switched off.

mm Control-click a track to switch all other tracks out of record-enabled mode.

mm Use of the Record Toggle key command switches the record-enabled state of the selected track 
(or tracks).

Make a MMC recording with Logic Pro X
	 1	 Select a tape track to switch the corresponding track on the tape machine to a record-

enabled state. Hold Shift while clicking multiple tracks to select and record-enable several tape 
machine tracks.

	 2	 If you like, you can set locators, and use the Autopunch function, to control MMC devices. The 
tape machine enters record mode at the Punch In locator position, and stops recording at the 
Punch Out locator position. This step is optional.

	 3	 Click the Record button to send the record strobe command to the tape machine. The following 
happens:

•• Logic Pro X enters MIDI record mode, and sends an MMC Play command to the tape machine.

•• The tape machine sends timecode. Logic Pro X will start recording only when it receives 
timecode from the MMC device.

	 4	 Click the Stop button to end the recording on the tape machine. Use the Stop command twice 
to rewind to the project start point. The following happens:

•• Logic Pro X automatically creates an empty MIDI region on the tape track. This indicates a 
recording take on the tape machine, and applies to all MMC recordings, including Autopunch 
recordings. If you record-enable several tape tracks (by Shift-clicking), the corresponding 
number of empty regions is created. If a MIDI region with an identical start point already exists 
on a tape track, no new MIDI region is created on that track. This avoids overlapping regions.

Tip:  You should finish all MMC-controlled recordings with the Stop button or Space bar. 
Some tape machines react differently to a series of MMC Record commands, which can result 
in Logic Pro X showing a track as recording, when the tape is actually playing back (or the 
opposite situation).

You can also use the Environment MMC Record to record-enable tracks on your tape machine 
with Logic Pro X. See MMC record buttons objects on page 809.
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Synchronization problems and solutions
Due to the number of synchronization types available, and different implementations by various 
manufacturers, you may experience timing issues when using Logic Pro X synchronously 
with other devices or applications. This table describes common synchronization problems 
and solutions.

Problem Solution

Digital synchronization error If Logic Pro X is synchronized to external word clock (Audio Sync 
Mode: External or Free), make sure that a valid digital signal is always 
available. 

If you see a “Sample Rate xxx kHz recognized” error message, the clock 
source device (DAT machine, for example) connected to your audio 
hardware’s digital input may not transmit Word Clock in stop or pause 
mode (or has switched itself off).

Poor or no synchronization to an 
external tape machine

Create a new project, then make a new recording in Logic Pro X of the 
audio on tape. 

If an old recording on tape was not properly synchronized to timecode, 
you won’t be able to use it. When trying to synchronize to tape, there is 
one key rule: the playback situation must be identical to the recording 
situation.

MIDI and audio are not 
synchronized

Open the File > Project Settings > Synchronization > Audio tab and 
choose MTC Continuous or MTC Trigger + Auto Speed Detection mode in 
the Core Audio pop-up menu.

If your audio hardware doesn’t support either mode, you should cut 
extremely long regions into shorter sections.

MIDI and SMPTE are not 
synchronized

Check all frame rate settings. The frame rates of all connected devices 
must be identical, including the timecode on the tape machine, the 
synchronizer, and Logic Pro X itself.

Some synchronizers encode the wrong frame rate in MTC. In this situation, 
open the Tempo Editor, turn off the Detect option, and set the correct 
frame rate manually.
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Logic Pro preferences

Logic Pro preferences overview
In Logic Pro, you can define and modify preferences that apply to all projects. You do this in 
the Preferences window. These preferences are automatically saved whenever you quit the 
application. A general preference file, named com.apple.logic10.plist, is found in the ~/Library/
Preferences folder. A separate preference file for control surfaces, named com.apple.logic.pro.
cs, is stored in the same location. You can’t edit either file directly. Any changes must be made in 
Logic Pro. If you delete a preference file, a new one is created the next time you open Logic Pro. 
All preferences will be reset to their default values.

  When Show Advanced Tools is selected in Advanced preferences, you can reset preferences 
to their default values manually.

In some instances, you’ll see a button in the Preferences window that links to related settings 
in the Project Settings window, and vice versa. Both the Preferences window and the Project 
Settings window can be visible at the same time.

Open Logic Pro preferences
mm Choose Logic Pro > Preferences, or press Command-Comma (,), then choose the name of the 

pane that you want to open.

Tip:  You can also access some preferences using local menus (in the Score Editor, for example), 
buttons in the control bar, or shortcut menus.

Reset all Logic Pro preferences (except for key commands)
mm Choose Logic Pro > Preferences > Initialize All Except Key Commands.

Preferences, project settings, and 
key commands 25
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General preferences

Project Handling preferences
The Project Handling pane contains the following project startup and template preferences:

•• Startup Action pop-up menu: Defines what happens when Logic Pro is opened.

•• Do Nothing: Nothing happens when Logic Pro is opened; you need to create a new project, 
or open an existing project or template.

•• Open Most Recent Project: Opens the project you were working on when you last closed 
Logic Pro.

•• Open Existing Project: Shows the Open dialog, which you can use to browse for an 
existing project.

•• Create New Project from Template: Opens the Templates dialog.

•• Create New Empty Project: Opens an empty project with the New Tracks dialog, which you 
use to specify the type and number of new tracks to add.

•• Create New Project using Default Template: Opens the default template and the Save As 
dialog, which you use to name and save your project.

•• Ask: Opens a Startup dialog, offering each of the above options.

•• Default Template field: Displays the full path and name of the default template or project.

  When Show Advanced Tools is selected in Advanced preferences, the following is available:

•• “Export MIDI File saves single MIDI Regions as Format 0” checkbox: If only one MIDI region is 
selected when you use the File > Export > Selection as MIDI File command, the contents of 
the region are saved in MIDI file format 0. This file format is guaranteed to be compatible with 
every MIDI file player.

  When Advanced Editing is selected in Advanced preferences, the following is available:

•• “When opening a project, ask to ‘Close current project(s)?’” checkbox: If selected and you open 
a new project before closing the old one, a dialog asks whether or not the current project 
should be closed. If unselected, you aren’t prompted and the current project remains open.
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Editing preferences
The Editing pane contains the following preferences:

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Number of Undo Steps slider: Determines the number of undo steps.

•• Add ‘Last Edit Function’ to region name checkbox: When selected, adds a description of the edit 
operation (cutting, for example) to the name of the region, or resulting regions.

•• “‘Living Groove’ connection” checkbox: When selected, editing an original region also 
alters any quantization template derived from that region. When unselected, the groove 
template remains as created. This allows you to edit the region without affecting the 
quantization template.

•• “Select regions on track selection” checkbox: When selected, selecting a track automatically 
selects all regions on the track lane (or regions within the cycle or autopunch area, if Cycle or 
Autopunch mode is on). When unselected, selecting a track will not select regions on the track 
lane. In this case:

•• Option-clicking the track header or associated channel strip continues to select the track 
and all associated regions.

•• Option-Shift-clicking adds the selected track’s regions to the current selection.

•• Pointer Tool in Tracks Provides: “Fade Tool click zones” checkbox: When selected, placing the 
pointer over the upper-left and upper-right edges of a region activates the Fade pointer. The 
Loop pointer can still be accessed in these click zones by holding down Option.

•• Pointer Tool in Tracks Provides: “Marquee Tool click zones” checkbox: When selected, placing the 
pointer over the lower half of a region (with the exception of the lower-left and lower-right 
edges) activates the Marquee pointer.

•• Limit Dragging to One Direction In: Piano Roll and Score checkbox: When selected, you can only 
move notes in one direction (horizontally or vertically) when editing in the Piano Roll or 
Score Editor. This means that a note may be either transposed, or moved in time, but not both 
at once.

Note:  Press Shift while dragging in the editor to quickly switch between the two behaviors.

•• Limit Dragging to One Direction In: Tracks checkbox: When selected, you can only move regions 
(including folders) in one direction in the Tracks area. This is similar to the previous option.

Note:  Press Shift while dragging in the Tracks area to quickly switch between the 
two behaviors.
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•• Double-clicking a MIDI Region Opens pop-up menu: Determines which editor opens when you 
double-click a MIDI region in the Tracks area.

•• Score: Opens the Score Editor.

•• Event List: Opens the Event List.

•• Piano Roll: Opens the Piano Roll Editor.

•• Step Editor: Opens the Step Editor.

  When Advanced Editing is selected in Advanced preferences, the following are available:

•• “SmartLoop handling of Scissors and ‘Split by Playhead’” checkbox: Determines how Logic Pro 
handles the cutting of looped regions.

•• When selected, you can cut a region’s looped area (using the Scissors or Marquee tool, 
or Split by Playhead command). Logic Pro automatically creates regions after—and, if 
necessary, before—the cut, ensuring that these areas remain identical. This allows you to 
split looped regions without altering playback in the looped area.

•• When unselected, you can’t cut a region’s looped area. Cutting the looped region itself turns 
off the Loop setting in the Region inspector.

•• Right Mouse Button pop-up menu: Determines the right mouse button behavior (assuming you 
have a suitable mouse).

•• Is Assignable to a Tool: Displays a third Tool menu (Right-click Tool menu) to the right of the 
Left-click and Command-click Tool menus. Choose the appropriate menu item to assign to 
the tool, which is available when the right mouse button is pressed while editing.

•• Opens Tool Menu: Opens the Tool menu with the Pointer tool (and not the currently selected 
tool) located under the pointer. Simply choose the tool you want by clicking it. When the 
Tool menu is open, you can also use the key shown next to a tool to select it.

•• Opens Shortcut Menu: Displays a menu that offers a number of area-specific selection and 
editing commands.

•• Opens Tool and Shortcut Menu: Opens both the Tool and shortcut menus.
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Cycle preferences

  Cycle preferences are only available when Advanced Editing is selected in 
Advanced preferences.

•• Cycle Pre-Processing pop-up menu: Processes a cycle jump slightly before its actual position, in 
order to ensure a smooth cycle jump (from the end point to the start point of the cycle). You 
can change the pre-processing time. A value of 1/96 (chosen by default) should be suitable for 
most uses.

•• Smooth Cycle Algorithm checkbox: Improves the timing of cycle jumps, making it easier to set 
the length of sample loops while in Cycle mode. This is somewhat mitigated through the use 
of Apple Loops. If your computer has a very slow processor, this setting reduces the processing 
requirements for graphics operations. In general, you want to keep this selected whenever 
possible, especially if you’re working in a style that involves frequent cycling of musical 
sections. If you find that your cycled sections are not as smooth as you’d like (assuming that 
your loops are actually perfect), you might achieve better results by deselecting this checkbox.
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Catch preferences
  Catch preferences are only available when Show Advanced Tools is selected in 

Advanced preferences.

•• “Catch when Logic starts” checkbox: Turns on the Catch function automatically, in all windows, 
whenever you start playback (including paused playback).

•• “Catch when moving playhead” checkbox: Turns on the Catch function automatically whenever 
you move the playhead. This makes it easier to perform edits, as moving the playhead in the 
Tracks area is reflected in the open editor, and vice versa.

•• “Catch content by position if Catch and Link are enabled” checkbox: If the Catch button is turned 
on and Content Link is selected in the local View menu, the contents of the region at the 
current playhead position are shown. If turned off, the window view still follows the playhead 
position within the displayed region, but doesn’t update to show the contents of subsequent 
regions as the playhead passes them (in playback or record mode).
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Audio preferences

Devices preferences
Logic Pro automatically recognizes any installed Core Audio hardware, and uses the default 
settings as defined in the Audio MIDI Setup utility (Applications/Utilities/Audio MIDI Setup). 
However, you may want to optimize the settings for your individual hardware setup, particularly 
if you use several audio interfaces or a multiple input/output device.

The Devices pane contains the following preferences:

•• Core Audio Enabled checkbox: Enables the Core Audio driver.

•• System Memory Requirement display: Indicates the amount of free RAM required, outside of 
memory assigned to Logic Pro. The requirement value changes as you alter the preferences 
within this pane.

•• Output Device pop-up menu: Use to choose between any installed Core Audio device, including 
the internal sound hardware. This also includes aggregate audio devices, consisting of several 
audio interfaces. See the Audio MIDI Setup Help for information on aggregate devices.

•• Input Device pop-up menu: Use to choose between any installed Core Audio device, including 
the internal sound hardware. This also includes aggregate audio devices, consisting of several 
audio interfaces. See the Audio MIDI Setup Help for information on aggregate devices.

Note:  When setting an output device that also provides inputs, the Input Device pop-up menu 
changes accordingly. If choosing a different input device, you’ll be advised to use a common 
Word Clock for both audio devices, in order to ensure the best sound quality.

•• I/O Buffer Size pop-up menu: Determines the size of the buffer used by the audio hardware for 
both input and output. The smaller the buffer size, the less latency you will encounter when 
monitoring while recording, or using software instruments.

Some points to note:

•• As the value is reduced, a higher strain is placed on your computer’s processor or processors.

•• There may be a point where the selected I/O buffer size is too small for your computer, 
and begins to affect playback. This usually takes the form of clicks, pops, and crackles in 
your audio.

•• You should aim for the lowest possible I/O buffer size value that doesn’t introduce clicks, 
pops, and crackles in your audio.
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Tip:  If you find that a higher I/O buffer size setting provides suitably low latency during record 
monitoring and software instrument playback, you should use it. This will minimize the impact 
on your computer’s processor or processors.

•• Resulting (Roundtrip/Output) Latency display: Displays the resulting roundtrip and output 
latency for the I/O buffer size.

•• 24-Bit Recording checkbox: When selected, Logic Pro can record 24-bit files. 20- or 24-bit 
recordings offer a significant improvement in the available dynamic range, but require high-
quality peripheral components such as microphones and pre-amps, not to mention high-
quality analog-to-digital/digital-to-analog converters. 20- and 24-bit files use one-and-a-half 
times the disk space of comparable 16-bit files.

Note:  Selecting this option only makes sense if you’re using a 20- or 24-bit interface.

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Recording Delay slider: Delays the recording of audio by a certain fixed value, helping you to 
compensate for any information delays that are caused by the audio driver.

Note:  You should not normally need to touch this setting.

•• Software Monitoring checkbox: Turns software monitoring on (default) or off. In most situations, 
you should leave it on.

Note:  When Software Monitoring is on, the audio signal is processed via software, and a 
certain amount of audible delay (commonly referred to as latency) is inevitable. 

If you’re listening to the recorded signal through your mixing console, or your audio interface 
supports hardware monitoring, you should turn this option off.

•• “Enable input monitoring only on focused track” checkbox: Turns software monitoring on 
(default) or off for the focused track in the Tracks area. This allows you to hear incoming audio, 
during playback or recording, for the selected track only.

•• “Input monitoring level for record-enabled channel strips” checkbox: Allows the use of an 
independent monitoring level for record-enabled audio channel strips. This is off by default. 
After record-enabling a track, you can adjust the fader to the level you like. The original level 
will be restored when you deselect the Record Enable button.

Note:  Adjustments to the fader do not affect the recording level; they only affect the 
monitoring level.

•• Process Buffer Range pop-up menu: Determines the size of the buffer used to compute mixes 
and effects. You can choose between Small, Medium, and Large buffer sizes.

Note:  Larger buffer sizes increase latency. Depending on the speed of the processor, buffer 
sizes that are too small might compromise real-time audio processing.

•• ReWire Behavior pop-up menu: Configures the ReWire behavior when sending MIDI data to a 
ReWire-compatible software instrument. You can choose between:

•• Playback mode: Use when playing back MIDI tracks via ReWire. This setting requires less 
processing power.

•• Live mode: Use when playing a ReWire instrument live. This setting uses more processing 
resources, but has lower latency.
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•• Maximum Scrub Speed pop-up menu: Sets the maximum scrubbing speed.

•• Normal: The normal playback speed is used for scrubbing.

•• Double: The scrubbing playback speed is twice as fast.

•• Scrub Response pop-up menu: Sets the reaction time for audio scrubbing. You can choose 
between Slow, Normal, Fast, and Faster.

General Audio preferences
The General Audio pane contains the following preferences:

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• “Display audio engine overload message” checkbox: When selected, displays an alert message in 
an overload situation. Otherwise, playback will simply stop without displaying an alert.

•• Recording File Type pop-up menu: Determines the file type for recorded audio.

•• AIFF: Cannot handle audio file recordings larger than 2 GB.

•• WAVE (BWF): The most common audio format on Windows PC computers. Files are stored as 
Broadcast Wave files, which contain timestamp information in the file header. The WAV file 
format cannot handle audio file recordings larger than 4 GB.

•• CAF: Choose this setting if you’re going to record files larger than 4 GB.

•• DIM Level slider: Sets a discrete level for the Dim function. You can set a dim level from 0 dB 
to –30 dB. The level chosen here is used when the Dim button is activated from the Master 
channel strip.

•• Plug-in Latency Compensation pop-up menu: Plug-in latency compensation (also called plug-in 
delay compensation) is useful for software effects plug-ins, and is particularly important for 
DSP (digital signal processing) accelerator hardware (for example, TC PowerCore and Universal 
Audio UAD1). It compensates for audio delays that can be introduced when using plug-ins.

Use the pop-up menu to activate plug-in latency compensation for either:

•• Audio and software instrument tracks

•• All (audio, instrument, auxiliary, and output channel strips)

You can also turn off compensation entirely.



	 Chapter  25    Preferences, project settings, and key commands	 854

•• Low Latency Mode checkbox and Limit slider: You need to select the Low Latency Mode 
checkbox in order to turn on Low Latency mode and use the Limit slider. The Limit slider lets 
you determine a maximum amount of allowable delay that can be caused by plug-ins when 
Low Latency mode is turned on (by clicking the Low Latency Mode button in the control bar). 
In Low Latency mode, plug-ins are bypassed to ensure that all delays (across the entire signal 
flow of the current track) remain under the Limit slider value. This is useful when you want to 
play a software instrument with several latency-inducing plug-ins inserted in the channel.

•• Crossfade Time slider: Determines a default time value for all crossfade operations in the 
Tracks area.

•• Crossfade Curve slider: Determines a global curve type for all crossfade operations in the 
Tracks area.

  When Advanced Editing is selected in Advanced preferences, the following is available:

•• Sample Accurate Automation pop-up menu: As the name implies, sample-accurate automation 
is the most precise type of automation, but it’s very processor intensive. It places higher 
overheads on system resources, which may affect performance (depending on the nature of 
your projects, and available computing power). This is most likely to happen during heavy 
project sections where a lot of software instruments and effects are in use. Logic Pro offers 
three settings:

•• Off: Minimal overhead on computer performance for automation playback. Automation is 
less precise when this setting is active.

•• Volume, Pan, Sends: Only these parameters are automated with sample accuracy.

•• Volume, Pan, Sends, Plug-in Parameters: All of these parameters are automated with sample 
accuracy. Not all Audio Units plug-ins can be automated in this way.
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Output preferences
The Output pane consists of the following preferences:

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Stereo Output pop-up menu: Sets the physical output pair on which the stereo output is played.

•• Mirroring checkbox: Becomes available for all chosen output pairs, with the exception of 
Output 1–2. Deselect to have the output signal routed to the chosen output pair (Output 3–4, 
for example). Select the checkbox to have the output signal routed to the chosen output pair 
(Output 3–4, for example), as well as to the physical outputs (Output 1–2).

  When Additional Surround Options is selected in Advanced preferences, the following are 
available:

•• Surround Show As pop-up menu: Sets the surround format. The choice you make automatically 
updates the remaining pop-up menus in the Output pane.

•• Surround Initialize buttons: Choose between the default setup of Logic Pro, the ITU 
(International Telecommunications Union) standard, and the WG-4 standard.
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Bounce Extensions preferences
The Bounce Extensions pane consists of the following preferences:

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Stereo Left and Right fields: Sets the bounce extension.

  When Additional Surround Options is selected in Advanced preferences, the following are 
available:

•• Surround Show As pop-up menu: Sets the surround format. The choice you make automatically 
updates the remaining pop-up menus in the Bounce Extensions pane.

•• Surround Initialize button: Resets the bounce extension to its default value.
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Input preferences

  Input preferences are only available when Additional Surround Options is selected in 
Advanced preferences.

•• Surround Show As pop-up menu: Sets the surround format. The choice you make automatically 
updates the remaining pop-up menus in the Input pane.

•• Surround Initialize buttons: Choose between the default setup of Logic Pro, the ITU 
(International Telecommunications Union) standard, and the WG-4 standard.
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Audio File Editor preferences

  Audio File Editor preferences are only available when Additional Audio Options is selected 
in Advanced preferences.

•• “Warning before processing function by key command” checkbox: When selected, provides a 
warning before carrying out a destructive edit in the Sample Editor when you use a key 
command. This gives you the opportunity to cancel the edit before altering the data.

•• “Clear Undo History when closing project” checkbox: When selected, deletes the Undo History 
automatically when you close the project.

•• “Record selection changes in Undo History” checkbox: Select this option if you want to undo and 
redo changes to selected areas in the Sample Editor.

•• “Record Normalize operations in Undo History” checkbox: Deselect if you don’t want to create 
undo files when the Normalize function is used.

•• Number of Undo Steps field: Determines the maximum number of undo steps that are retained.

•• External Sample Editor chooser: Lets you choose an external application for sample 
editing operations.
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MP3 preferences
  MP3 preferences are only available when Show Advanced Tools is selected in 

Advanced preferences.

•• Bit Rate (Mono/Stereo) pop-up menus: You can choose bit rates between 32 kbps and 320 kbps, 
but the defaults are 80 kbps mono and 160 kbps stereo. These rates offer acceptable quality 
and good file compression. If you can afford the increased file size, you should choose 96 kbps 
for mono and 192 kbps for stereo streams. These settings will deliver better audio quality. You 
can choose even higher rates, but the quality of improvement in bit rates above 96/192 kbps 
is minimal.

•• Use Variable Bit Rate Encoding (VBR) checkbox: Variable Bit Rate (VBR) encoding compresses 
simpler passages more heavily than harmonically rich passages, generally resulting in better-
quality MP3s. Unfortunately, not all MP3 players can accurately decode VBR-encoded MP3s, 
which is why this option is unselected by default. If you know that the audience for your MP3 
files can decode VBR-encoded MP3s, you can select this option.

•• Quality pop-up menu: Keep this set to Highest whenever possible. Reducing the quality 
accelerates the conversion process, but at the expense of audio quality. This option is only 
accessible when the Use Variable Bit Rate Encoding (VBR) checkbox is selected.

•• Use Best Encoding checkbox: Like the Quality checkbox, if you deselect this option, you will 
gain encoding speed at the price of audio quality. This should always be left selected, unless 
conversion time is an issue.

•• Filter Frequencies Below 10 Hz checkbox: When selected, frequencies below 10 Hz (which 
are usually not reproduced by speakers, and aren’t audible to human ears at any rate) are 
removed. This leaves slightly more data bandwidth for the frequencies that humans can 
hear, resulting in an improvement in perceived quality. Only deselect this option if you’re 
experimenting with subsonic test tones, or exporting MP3s for whales.

•• Stereo Mode pop-up menu: Choose between Joint Stereo or Normal Stereo. Depending on the 
original file, these settings may or may not offer any audible difference. Experiment with both 
settings to determine your preference.
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Reset preferences
  Reset preferences are only available when Show Advanced Tools is selected in 

Advanced preferences.

You can use Reset preferences to send reset messages of a specified type to all active instrument 
channels. This can be useful if you’re encountering hung notes, or are finding that controller 
settings are incorrect when in Cycle mode (or when returning to the beginning of a section or 
the project start point).

•• “Control 64 off (Sustain)” checkbox: Sends “Control 64 off (Sustain)” reset messages.

•• “Control 1 (Modulation) to zero” checkbox: Sends “Control 1 (Modulation) to zero” reset messages.

•• “Pitch Bend to center position” checkbox: Sends “Pitch Bend to center position” reset messages.
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MIDI preferences

General MIDI preferences
  General MIDI preferences are only available when Show Advanced Tools is selected in 

Advanced preferences.

•• “External stop message ends recording” checkbox: If you’re using external synchronization and 
the timecode stops while recording, record mode is turned off. If this checkbox is unselected, 
Logic Pro stops, but remains in record mode (record mode is paused).

•• Reset All MIDI Drivers button: Resets all MIDI drivers. This can help if you experience MIDI 
communication problems.
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Reset Messages preferences

  MIDI Reset Messages are only available when Additional MIDI Options is selected in 
Advanced preferences.

MIDI Reset Messages preferences are included for compatibility with older MIDI hardware. 
All selected checkboxes will send a reset message, for the selected controller type, to all MIDI 
outputs. This reset message is sent on cycle jumps and when playback begins. However, Logic 
Pro handles MIDI reset messages automatically and intelligently, so you should generally make 
sure that all of these options are unselected—which they are, by default.
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Sync preferences
The Sync pane contains the following preferences:

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• All MIDI Output: Delay field: Delays or advances the MIDI output for all ports, so you can 
compensate for any timing differences between MIDI tracks and audio or software 
instrument tracks.

•• MIDI Clock: “Allow to send Song Position Pointer while playing” checkbox: Song Position Pointer 
(SPP) data is not normally sent while the sequencer is in playback mode. (This is in accordance 
with the MIDI Standard.) If selected, this option allows Logic Pro to send SPP data while the 
sequencer is running. The advantage is that external devices can also follow Logic Pro in Cycle 
mode. If your external devices cannot process SPP, you should deselect this option. If your 
devices can follow MTC (MIDI Time Code), you should leave this option unselected (default), 
and use the MTC functions of Logic Pro.

•• MTC Pickup Delay field: This should generally be set to zero, to ensure the quickest possible 
pickup time while Logic Pro is in MTC (MIDI Time Code) Sync mode. There are, however, 
some devices that seem to transmit imprecise MTC commands when first started. As a result, 
synchronization may be unreliable, and there could be an offset every time synchronization 
is established. In such situations, you can set a delay time before incoming MTC is picked up. 
Essentially, Logic Pro will ignore the incoming MTC commands that occur in this time period. A 
(frame) value of 25 to 30 corresponds to a delay of about one second, depending on the frame 
rate. Use when synchronizing to hard disk recorders and other devices, if synchronization 
doesn’t appear to be consistent.

•• Delay MTC transmission by field: Delays the transmission of MIDI timecode. Negative values 
result in MTC being transmitted earlier, allowing you to compensate for any reaction delays (to 
incoming MIDI timecode) in external MTC slave devices.

•• Transmit locate commands when: “Pressing Stop twice” checkbox: Allows transmission of MMC 
Locate commands when the Stop command is pressed twice (using the Stop button in the 
control bar, or using the Stop key command).

•• Transmit locate commands when: “Dragging regions or events” checkbox: If this option is selected 
and Logic Pro is stopped (not in playback or record mode), MMC Locate commands are sent 
with the position of a region that is dragged in the Tracks area. 
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  When Additional MIDI Options is selected in Advanced preferences, the following are 
available:

•• MMC Uses pop-up menu: Choose between the following settings:

•• MMC standard messages: The MIDI MMC specification is strictly followed.

•• Old Fostex format: The old Fostex format is used for MIDI Machine Control.

•• Output ID (Transport) checkbox: The All checkbox sends MMC to all ports. The field to the right 
allows you to specify an output port ID.

•• Input ID (Transport) checkbox: The All checkbox sends MMC to all ports. The field to the right 
allows you to specify an input port ID.

•• “Transmit record-enable commands for audio tracks” checkbox: If this option is selected, MMC 
Record Enable/Disable commands are also sent when audio tracks are record enabled or 
disabled. In addition, any received MMC Record Enable commands will set the record-enabled 
state of audio tracks.
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Display preferences

General Display preferences
  General Display preferences are only available when Show Advanced Tools is selected in 

Advanced preferences.

•• “Large local window menus” checkbox: When selected, local menu items are displayed in a 
larger font.

•• “Large inspectors” checkbox: When selected, inspector settings are displayed in a larger font.

•• “Wide playhead” checkbox: When selected, a thicker playhead is used in all windows.

•• Show Help Tags checkbox: When selected, help tags appear throughout Logic Pro. When you 
hold the pointer over interface elements and tools, a small pop-up description (or value) of the 
item appears onscreen. When editing, the function name, region or event name or number, 
position, and parameter values are shown.

•• “Show default values” checkbox: When selected, default values for parameters are displayed in 
help tags. This makes it easier to determine the amount of variance from the default value.

•• “Show icons in New Tracks dialog” checkbox: When selected, an icon-style New Tracks dialog 
is shown when you click the Add Tracks button . Otherwise, a text-style New Tracks dialog 
is displayed.

•• “Display Middle C as” pop-up menu: This pop-up menu affects the description of notes in the 
editors. The bottom C on a five-octave keyboard (note # 36) is labeled C1, and middle C (note 
# 60) is labeled C3. According to this standard, the lowest MIDI note (note # 0) is called C–2. 
This is the official standard used by most manufacturers. Use of the C3 (Yamaha) setting will 
set Logic Pro to this standard mode. If you select the C4 (Roland) setting, the bottom C on a 
five-octave keyboard is labeled C2, and middle C is labeled as C4. In this standard, the lowest 
MIDI note is C–1.

•• “Display Time as” pop-up menu: Use to customize the Time display in the control bar.

•• “Display Tempo as” pop-up menu: Use to customize the Tempo display in the control bar.

•• Clock Format pop-up menu: Use to customize the Beats display in the control bar.
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Mixer Display preferences
  Mixer Display preferences are only available when Show Advanced Tools is selected in 

Advanced preferences.

•• “Open plug-in window on insertion” checkbox: When selected, the window of a plug-in opens 
automatically after it’s inserted in the appropriate channel strip slot.

•• Level Meters Scale pop-up menu: Switches level meters between an Exponential scale and a 
Sectional dB-linear scale.

•• Exponential: Provides higher display resolution in the upper range of the meter. 

•• Sectional dB-linear: Provides the best possible display resolution across the entire level range.

•• Level Meters Channel Order pop-up menu: Determines the order of channels in multichannel 
(surround) level meters.
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Score preferences
The Score pane contains the following preferences:

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• “Double-click to open” pop-up menu: Determines the window that opens when you double-click 
a note head: Note Attributes, Event List, Piano Roll Editor, or Step Editor.

•• “Use external symbol font (if available)” checkbox: Allows the use of external fonts in the score.

•• Choose Font pop-up menu: Choose from any installed scoring (symbol) fonts, such as the 
Sonata font.

•• “Auto split notes in multi staff chord styles” checkbox and “Split notes at” slider: The “Auto split 
notes in multi staff chord styles” preference is only relevant if the chosen default staff style (on 
the recording track) is polyphonic, and is using MIDI channels for voice assignment. In this 
situation, newly recorded notes are automatically saved with the different MIDI channels used 
in the corresponding staff style. They are allocated as per the split point set with the “Split 
notes At” preference.

  When Additional Score Options is selected in Advanced preferences, the following are 
available:

•• “Show region selection colored” checkbox: If this option is selected, the staff lines of the currently 
selected MIDI region are displayed in color. All other regions are displayed with black staff 
lines. This can be useful when changing the display parameters of regions, as the parameters 
in the Region inspector only affect the currently selected regions. If this option is unselected, 
all staffs are displayed in black, whether selected or not.

•• “Display distance values in inches” checkbox: This setting relates to the measurement units in the 
project settings and page rulers (Page Score view only), which can be in inches or centimeters. 
If not selected, the Page Score view defaults to centimeters.

•• Selection Color button: Choose the color of selected objects in the Score Editor. A Reset button 
also provides quick access to the default color (if it has been changed).

•• Camera Tool: Write to buttons: Choose either the Clipboard or a PDF File as the destination for 
image exports with the Camera tool.
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Movie preferences
  Movie preferences are only available when Show Advanced Tools is selected in 

Advanced preferences.

•• “Movie to project” slider: Fine-tunes the start point of a movie.

•• Cache Resolution pop-up menu: Defines the resolution of the thumbnails kept in the temporary 
internal memory (cache). Higher resolutions display more detail, but take up more space in 
the cache.

•• Maximum Cache Size slider: Defines the amount of memory reserved for the thumbnail cache. 
Forty megabytes is recommended for medium resolution. For higher resolutions choose a 
higher value. This section of reserved memory will only be occupied when actual movie data 
is displayed.

•• “Lock movie window when changing screensets” checkbox: When selected, the Movie window 
stays in its current user-defined position, and playback continues, when changing screensets.
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Automation preferences
  Automation preferences are only available when Show Advanced Tools is selected in 

Advanced preferences.

•• “Move automation with regions” pop-up menu: Determines what happens to track automation 
data when you move regions.

•• Never: Does not move automation when you move regions.

•• Always: Always moves automation when you move regions. The automation data area 
encompassed by the region boundaries is moved.

•• Ask: A dialog prompts you to move the automation data—or leave it where it is—whenever 
you move a region.

•• “Include trails, if possible” checkbox: When selected, includes the automation trails of regions 
(automation parameter movements in the empty space that follows a region) with all Copy or 
Move actions that are performed via the Clipboard or graphical editing.

•• Snap Offset field: Allows a specific number of ticks to be added to, or subtracted from, the 
current snapped position of all automation data (as set in the Snap pop-up menu in the Tracks 
area).

•• Ramp Time field: Determines the time required by a parameter to return to its previously 
recorded setting.

•• “‘Write’ mode changes to” pop-up menu: Determines the mode that faders automatically switch 
to once track automation data recording has been completed.

•• “Write automation for” checkboxes: Determine the types of track automation data that can be 
written in Touch, Latch, and Write modes.

•• Automation Quick Access buttons: These preferences are discussed in detail in the Automation 
Quick Access section.
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Control Surfaces preferences
  General Control Surfaces and Help Tags preferences are only available when Additional 

Control Surfaces Options is selected in Advanced preferences.

These preferences are discussed in detail in the Logic Pro Control Surfaces Support manual.
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Advanced preferences
  When Show Advanced Tools is selected in Advanced preferences, you have access to a 

number of advanced features and additional options.

For details, see Work with advanced tools and additional options.
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Project settings

Project settings overview
In Logic Pro, you can define and modify settings that apply to individual projects. You do this 
in the Project Settings window. These settings are automatically saved with each project, which 
means that different projects can have different settings. You can save your preferred settings 
in a default template, which can be used to automatically create a new project when you open 
Logic Pro. You can also import project settings from other projects.

In some instances, you’ll see a button in the Project Settings window that links to related settings 
in the Preferences window, and vice versa. Both the Project Settings window and the Preferences 
window can be visible at the same time.

Open project settings
mm Choose File > Project Settings, then choose the name of the pane that you want to open.

Tip:  You can access some project settings using local menus (in the Score Editor, for example), 
buttons in the control bar, or shortcut menus.

General settings
  When Show Advanced Tools is selected in Advanced preferences, you can use the musical 

grid setting to determine the view option for the ruler, and whether or not tempo information is 
written into recorded audio files.

•• Use musical grid checkbox: When selected, the ruler is set to bars and beats, and tempo 
information is recorded into audio files. When unselected, the ruler is set to time, and tempo 
information is not recorded into audio files.
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Synchronization settings

General Synchronization settings
  General Synchronization settings are only available when Show Advanced Tools is selected in 

Advanced preferences.

General Synchronization settings are used when running Logic Pro as a slave—when Logic Pro is 
being controlled by another device.

•• Sync Mode pop-up menu: Defines the master (timecode type) that Logic Pro is synchronized to.

•• Internal: Selects the internal timer of Logic Pro, with Logic Pro running as the master. External 
devices can be synchronized via MIDI Clock or MTC.

•• MTC: Selects MIDI Time Code mode, with Logic Pro running as a slave. MIDI timecode can 
either arrive at a MIDI In port, or be generated by a MIDI interface that translates it from 
incoming SMPTE timecode—the Unitor8, for example.

•• Manual: Selects Tempo Interpreter mode, with Logic Pro running as a slave to impulses that 
are recognized as valid beats by the Tempo Interpreter. The parameters that control how 
Logic Pro responds to Tap Tempo commands can be found in the Tempo Interpreter window.

•• “Auto-enable External Sync and Tap Tempo” checkbox: When selected, Logic Pro runs as the 
master (Internal sync mode), until it receives a synchronization signal—either in the form of 
MTC, or from the Tempo Interpreter.

Logic Pro automatically locks to the first synchronization signal it receives.

Important:  Make sure that different synchronization signals don’t arrive simultaneously; 
remember that there can only be one timecode master.
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•• Frame Rate pop-up menu: Defines the frame rate (in fps, frames per second), which applies to 
both transmitted and received timecode.

Note:  In drop frame formats, certain frames are left out. (This follows a regular pattern.) To 
distinguish between formats, those without dropped frames are sometimes referred to as NDF 
or non–drop frame.

•• 24 fps: Film, high definition video

•• 25 fps: PAL video/television broadcasts

•• 30 fps (drop frame): NTSC video/television broadcast; rarely used

•• 30 fps: High definition video; early black-and-white NTSC video; an older rate that is rarely 
used today

•• 29.97 fps (drop frame): NTSC video/television broadcasts

•• 29.97 fps: Standard definition NTSC

•• 23.976 fps: 24 fps running at 99.9%, which facilitates easier transfer of film to NTSC video

•• “Auto detect format of MTC” checkbox: When selected (recommended), the incoming timecode 
is analyzed and the correct frame rate set automatically.

Note that it’s not possible to automatically distinguish between the 29.97 and 30 fps MTC 
frame rates:

•• The MTC standard does not allow a distinction.

•• A measured rate of 30 fps could also be 29.97 fps timecode running too fast, and vice versa.

Logic Pro automatically interprets frame rates of “approximately 30 fps” as either 29.97 (drop 
frame) or 30 fps (non-drop frame), depending on whether or not the drop frame format 
is used. This interpretation will usually be correct, because these two formats are used as 
a standard.

The “Auto detect format of MTC” option only switches to 29.97 (drop frame) or 30 fps (non-
drop frame) if one of the other conventional formats was previously set. If you want to 
synchronize Logic Pro to one of these nonconventional frame rates, you need to define the 
format manually. This setting will not be altered by the “Auto detect format of MTC” function.

•• Validate MTC pop-up menu: Specifies how often Logic Pro checks for incoming timecode, in 
order to ensure synchronization integrity. In general, you should leave this option on the 
“always” setting.

There are some devices that generate timecode pulses that may require a specific number of 
frames to be set, in order to maintain synchronization. The “never, Jam Sync” setting basically 
sets Logic Pro to freewheel if the synchronization signal is lost. In other words, Logic Pro will 
run on its own internal clock (at the most recently received tempo) if the synchronization 
pulse is lost. This approach ensures that recording will continue, even if the incoming timing 
pulse fails.

•• Bar Position plays at SMPTE value fields: Defines the SMPTE offset for the project. As songs don’t 
always need to start precisely at bar 1, you can select any bar position to be played at the set 
SMPTE time.

The default is Bar Position: 1 1 1 1 plays as SMPTE 01:00:00:00. 

The SMPTE offset of 01:00:00:00 (one hour) is normally used, because it allows you to pre-roll 
an amount of timecode.

•• Enable Separate SMPTE View Offset checkbox: Shows the absolute time from the start of the 
project in the time display, rather than the actual SMPTE time.
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•• Bar Position displayed as SMPTE value fields: These fields become available if you select the 
Enable Separate SMPTE View Offset checkbox. Choose Bar Position 1 1 1 1 displayed as SMPTE 
00:00:00:00 (preset). If necessary, you can set other view offset values here.

The Tempo List always shows the real SMPTE time, never the SMPTE View Offset. The SMPTE 
View Offset is used in all other windows (including the control bar).

Tip:  It’s common practice in many video (and audio) post-production houses to set a one-hour 
SMPTE offset (01:00:00:00). This avoids a problem commonly referred to as midnight, where a 
pre-roll passes through SMPTE time 00:00:00:00, which causes issues with some tape machines 
(such as the ADAT).
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Audio Synchronization settings
You can use Audio Synchronization settings to keep your audio and MIDI tracks synchronized.

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• MTC slider: Shows the deviation between the incoming MTC and its nominal frame rate. 
If the deviation is significant, make sure that the correct frame rate is set in the General 
Synchronization pane. If in doubt, set the frame rate to 24 fps and select “Auto detect format 
of MTC” in the General pane. If the frame rate is correct, you can use this display to adjust 
the tape speed of the master machine to the nominal value (the same speed used when the 
timecode was recorded). Adjust the varipitch control on the master machine, until the slider 
is centered.

•• Sample Rate slider: Shows the deviation of the sample rate from its nominal value. Note that 
some audio hardware does not allow any variation in the sample rate.

•• Deviation slider: Shows the current phase deviation of the Word Clock from the timecode 
master—in other words, the deviation between audio and MIDI. Varying timecode signals 
shown in this display indicate how Logic Pro regulates the sample rate of the hardware when 
in MTC Continuous sync mode. Even large timecode variations result in no deviation between 
audio and MIDI synchronization. Your audio hardware must be capable of continuously 
variable sample rates for this to function. Small deviations between audio and MIDI are 
unavoidable, because MIDI can (and should) follow the timecode master directly.

Note:  The real-time sample rate conversion feature of Logic Pro allows it to follow an external 
MTC signal (MTC Continuous), while maintaining the correct audio playback pitch and speed. 
This feature even works when recording in MTC-slave mode.
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  When Additional Audio Options is selected in Advanced preferences, the following is 
available:

•• Core Audio pop-up menu: Defines how your Core Audio hardware is synchronized to an 
external timecode master.

•• MTC Continuous: Audio regions are started in sync, and the sample rate is continuously 
regulated to match variations in the timecode master signal. Even very long audio regions 
stay in sync in this mode.

•• MTC Trigger + Auto Speed Detection: Similar to MTC Trigger (see below), but the tempo of the 
timecode master is constantly monitored while Logic Pro is running. The next time you start 
Logic Pro, it will use an adapted sample rate. This mode keeps long regions in better sync 
with the timecode master, although not as closely as MTC Continuous. It does, however, use 
a constant sample rate, which is not affected by variations in the timecode master signal.

•• MTC Trigger: Audio regions are started in sync, but are then played at a constant sample 
rate, regardless of any variations in the timecode master signal. Logic Pro always uses the 
set nominal sample rate (44.1, 48, 88.2, 96, 192 kHz). This mode is suitable when it is vital to 
retain the absolute pitch of a recording. If the speed of the timecode master deviates from 
the nominal value, you may need to split long audio regions into shorter sections.

•• External or Free:Logic Pro has no influence on the sample rate. The audio hardware is 
responsible for ensuring that the position and sample rate of audio regions match. This 
mode is only advisable if you are sure that the Word Clock and timecode master are running 
in sync—by using an external SMPTE or Word Clock synchronizer, for example.
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MIDI Synchronization settings
 MIDI Synchronization settings are only available when Show Advanced Tools is selected in 

Advanced preferences.

You can use these settings to synchronize external slave devices to Logic Pro, which acts as 
the master.

•• Transmit MIDI Clock: Destination 1 checkbox: Activates MIDI Clock transmission.

Every time you start playback, a Song Position Pointer (SPP) message is also sent. Because 
not all devices can process SPP, the MIDI system real-time Continue message is also sent. The 
exception is when you start at position 1 1 1 1. In this situation, the real-time Start message 
is sent.

MIDI Clock can easily be sent with other normal MIDI events (notes and controllers, for 
example). When using multi-port MIDI interfaces (such as the Unitor8), better timing is 
achieved by sending MIDI Clock to All ports, rather than to several individual ports.

If MIDI Clock is transmitted to all ports, the events are only sent once from the computer to 
the interface. If you address individual ports, one event needs to be sent for each port, placing 
a higher strain on the bandwidth of all ports.

•• Transmit MIDI Clock: Destination 1 pop-up menu: Determines the first discrete MIDI output port 
for the MIDI Clock signal.

•• Transmit MIDI Clock: Destination 2 checkbox: Activates MIDI Clock transmission.

•• Transmit MIDI Clock: Destination 2 pop-up menu: Determines the second discrete MIDI output 
port for the MIDI Clock signal.

•• “Delay transmission by” slider: Use to delay the transmission of MIDI Clock signals. Negative 
values mean that the MIDI Clock signal is transmitted earlier. This allows you to compensate 
for any reaction delays in external MIDI Clock slaves.

•• Transmit MTC checkbox: Activates the transmission of MIDI timecode.

•• Transmit MTC pop-up menu: Determines the MIDI output port for the MTC signal.

Note:  If you can avoid it, you shouldn’t send MTC to all ports, as it’s very data intensive. If 
possible, use a MIDI port that isn’t being used for anything else.
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•• Transmit MMC checkbox: Select this checkbox to allow transmission of MIDI Machine Control. 
These commands are then sent whenever you operate the transport functions (Start, Stop, 
Rewind, and so on) of Logic Pro.

MMC is normally used when Logic Pro is running as a slave to an external master (such as 
an ADAT), and you want to control the external master’s transport functions from Logic Pro. 
Logic Pro therefore acts as MMC master and MTC slave simultaneously. If you want to use the 
external master’s transport controls, you don’t need to use MMC. In this situation, Logic Pro 
follows the MTC master as a slave. You can also use MMC to record-enable tracks on the MMC 
slave device.

•• Listen to MMC Input checkbox: Select this checkbox to control Logic Pro by MMC (MIDI Machine 
Control) and so-called Full Frame Messages.

Logic Pro recognizes these commands when listening to MMC Input:

•• Play

•• Deferred Play

•• Stop

Deferred Play is a special command for mechanically slow synchronization slaves such as reel-
based tape recorders. Rather than having the machine play immediately, it is asked to reach 
the desired SMPTE position before playback is started. There is no noticeable difference in the 
response of Logic Pro to the Play and Deferred Play commands, as Logic Pro can start playback 
at any position almost instantly.

Logic Pro ignores these messages when incoming external MTC (MIDI Time Code) commands 
are detected.

Logic Pro also obeys Full Frame Messages, and sets the playhead to a new location, without 
starting playback. Once again, incoming MTC data has higher priority, if conflicting information 
is received.

Some synchronizers send Full Frame Messages (instead of MTC) to locate the slave device 
(Logic Pro in this case) to a new position, without implicitly starting playback. This is useful 
when in Slow Shuttle or Single Frame Advance mode with video machines, because the slave 
device is perfectly located, without being in playback mode.
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Unitor Synchronization settings

  Unitor Synchronization settings are only available when Advanced Editing is selected in 
Advanced preferences.

You can use these settings to edit the major synchronization parameters for the Unitor8 
MIDI interface.

•• SMPTE Mode buttons: You can instruct the Unitor8 to read or write SMPTE data.

•• Read: Select to read SMPTE data.

•• Generate: Select to write SMPTE data.

•• SMPTE Mode Refresh checkbox: Activates Refresh mode, where fresh timecode is generated, in 
sync with received timecode. Refresh mode works with both VITC and LTC (see below). You 
should always use Refresh mode whenever you need to copy an LTC track, because you can’t 
directly copy LTC without a considerable loss of quality. When copying entire multitrack tapes, 
you should patch all tracks directly, but refresh the timecode track via the Unitor8.

Note:  You should only use Refresh mode if you are copying timecode.

•• SMPTE Type buttons: Define the SMPTE format that you want to use.

•• LTC: Longitudinal (also called Linear) Time Code is written to a tape track.

•• VITC: Vertical Interval (or Vertically Integrated) Time Code is written invisibly to a videotape.

•• Off: No timecode is written.

•• Freewheel slider: You can set the freewheel time (in frames) for LTC and VITC. The freewheel 
parameter affects the SMPTE reader, and specifies how long the synchronizer continues 
transferring MTC to the sequencer, after timecode ceases to be read.

Long freewheel times can maintain synchronization, even if there are dropouts in the 
timecode, but they also increase the reaction time of Logic Pro after the timecode master 
stops. In practice, you should set a value that is as large as necessary (for sustained operation), 
and as small as possible (to reduce waiting times).
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•• TV Format pop-up menu: Defines the television format for timecode burn-in.

•• PAL: The video format used in Europe, South America, most Asian and African countries, and 
Oceania. If you’re working with video in SECAM format (used in France and French-speaking 
nations in Africa), choose PAL.

•• NTSC: The video format used in the U.S., Central America, Japan, and Canada.

•• VITC Line 1 and VITC Line 2 pop-up menus: VITC is written into two lines of the video picture, 
which are normally invisible. The lines should not be adjacent, and are usually situated 
between 12 and 20.

If the Scan option is selected, the VITC lines are automatically recognized. You should only 
enter the lines manually if there are problems with Scan mode.

•• Visible Timecode Display: Size pop-up menu: Sets the size of the timecode counter window, 
which is burned in to the video picture.

•• Visible Timecode Display: Style pop-up menu: Sets the style of the timecode counter window, 
which is burned in to the video picture.

•• Horizontal Position and Vertical Position sliders: Sets the position of the timecode counter 
window, which is burned in to the video picture.
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Metronome settings
The Metronome project settings combine all parameters for speaker click, MIDI click, and 
Klopfgeist—a virtual metronome sound source. Klopfgeist can be used in addition to, or in place 
of, the speaker and MIDI click sources.

Note:  Klopfgeist is a software instrument found in the Plug-in pop-up menu of instrument 
channel strips. Klopfgeist is inserted into instrument channel 256 by default. Logic Pro 
automatically creates instrument channel 256 (and inserts Klopfgeist) when the Software Click 
Instrument (Klopfgeist) checkbox is selected. Theoretically, any other Logic Pro or third-party 
software instrument could be used as a metronome sound source on instrument channel 256. 
For full details about Klopfgeist, see the Logic Pro Instruments manual.

•• “Click while recording” checkbox: The metronome is automatically turned on for recording. This 
is the same as clicking the Metronome button in the control bar during recording.

•• “Only during count-in” checkbox: The metronome is only audible during the project count-in, 
and is then turned off.

•• “Click while playing” checkbox: The metronome is automatically turned on for playback. This is 
the same as clicking the Metronome button in the control bar during playback.

•• Polyphonic Clicks checkbox: The metronome sends notes, as defined for bars, beats, and 
divisions. For example, two or three notes may be sent simultaneously at the beginning of 
each measure. If this option is unselected, the metronome only transmits one note at a time.

•• Audio Click (Klopfgeist) checkbox: Turns the Klopfgeist metronome on or off.

•• Note fields: Defines the note number of generated notes.

•• Velocity fields: Defines the velocity of generated notes.

•• Tonality slider: Changes the sound of the virtual metronome from a short click to a pitched 
percussion sound, similar to a wood block or claves.

•• Volume slider: Sets the output level of the virtual click sound.

•• Output pop-up menu: If the audio hardware used by Logic Pro offers more than two outputs, 
this pop-up menu allows you to route the Klopfgeist metronome sound to a different set of 
hardware outputs.
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  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Bar checkbox: Generates separate note events for bars.

•• Beat checkbox: Generates separate note events for beats.

•• Division checkbox: Generates separate note events for divisions.

•• Channel fields: Defines the MIDI channel of generated notes.

•• Note fields: Defines the note number of generated notes.

•• Velocity fields: Defines the velocity of generated notes.

•• MIDI Port pop-up menu: Choose a direct MIDI output port (or all ports) for the metronome.
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Recording settings
You can use Recording settings to determine how Logic Pro responds while in record mode.

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• When Beginning buttons: Use to choose between a count-in or pre-roll period when starting 
to record.

•• Count-in: When selected, you can use the “Count-in” pop-up menu to set the count-in period 
that precedes a recording.

•• Record pre-roll: When selected, you can set a pre-roll time in seconds and milliseconds. When 
recording, this value is deducted from the current project position.

•• “Count-in” pop-up menu: Sets the count-in period that precedes a recording.

•• None: The recording begins with no count-in.

•• x Bar: The recording begins with a count-in of between 1 Bar and 6 Bars (chosen from the 
pop-up menu).

•• x/4: The count-in’s time signature can be set here. These settings are useful when the 
count-in falls across a bar change.

•• “Allow tempo change recording” checkbox: All tempo changes made while in record mode 
are recorded.

•• Auto-colorize takes checkbox: When selected, take folders use the color chosen from the Color 
palette for the first take recording, but different colors for each of the following recorded takes 
in that take folder. All colors used in a take folder are chosen from the same color row in the 
Color palette, advancing by a predefined number of columns after each take.

•• MIDI: Overlapping Recordings pop-up menu: Sets the behavior when your MIDI 
recordings overlap.

•• Create Take Folders: A new take folder is created when recording over an existing MIDI region.

•• Join with Selected Regions: Newly recorded data is merged with all selected regions, to form a 
single region. This takes place after each recording is completed.

•• Join when Cycling: When recording in Cycle mode, this function merges the data recorded in 
all cycle passes into a single region. If not in Cycle mode, each newly recorded MIDI region 
will be independent (not merged).
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•• Create Tracks when Cycling: When recording in Cycle mode, this function automatically 
creates a new take track for each cycle repetition. Each previous track plays while 
you’re recording.

•• Create Tracks and Mute when Cycling: When recording in Cycle mode, this function 
automatically creates a new take track for each cycle repetition. Each previous track is muted 
while recording.

•• “Auto demix by channel if multitrack recording” checkbox: This setting switches between the 
Layer Recording and Multi-Player Recording modes.

  When Additional Audio Options is selected in Advanced preferences, the following is 
available:

•• Audio Recording Path buttons: Use to set or reset the audio recording path.

•• Set: Allows you to select or create a recording folder outside of the project.

•• Project: Resets the recording path back to the project.

  When Additional MIDI Options is selected in Advanced preferences, the following is 
available:

•• “MIDI data reduction” checkbox: Controller events are thinned out during recording, to 
reduce the data load on the MIDI bus during playback. This improves the timing of dense 
arrangements when using interfaces with only a few MIDI ports. The function actually reduces 
the duration of controller events, using an intelligent algorithm which retains the value at the 
end of a series of controller messages.
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Tuning settings

Tuning overview
The 12-tone scale used in Western music is a development that took centuries. Hidden in 
between those 12 notes are a number of other microtones—different frequency intervals 
between tones.

To explain, look at the harmonic series: Imagine that you have a starting (or fundamental) 
frequency of 100 Hz (100 vibrations per second). The first harmonic is double that, or 200 Hz. 
The second harmonic is found at 300 Hz, the third at 400 Hz, and so on. Musically speaking, 
when the frequency doubles, pitch increases by exactly one octave (in the 12-tone system). The 
second harmonic (300 Hz) is exactly one octave—and a pure fifth—higher than the fundamental 
frequency (100 Hz).

From this, you could assume that tuning an instrument so that each fifth is pure would be the 
way to go. In doing so, you would expect a perfectly tuned scale, as you worked your way from C 
through to the C above or below.

The following table provides a summary of the various calculations.

Note Frequency (Hz) Notes

C 100 x 1.5 divided by 2.

C# 106.7871 Divide by 2 to stay in octave.

D 112.5 Divide by 2 to stay in octave.

D# 120.1355 Divide by 2 to stay in octave.

E 126.5625 Divide by 2 to stay in octave.

F (E#) 135.1524

F# 142.3828 Divide by 2 to stay in octave.

G 150 x 1.5 divided by 2.

G# 160.1807

A 168.75

A# 180.2032

B 189.8438

C 202.7287

As you can see from the table, although the laws of physics dictate that the octave above C 
(100 Hz) is C (at 200 Hz), the practical exercise of a (C to C) circle of perfectly tuned fifths results 
in a C at 202.7287 Hz. This is not a mathematical error. If this were a real instrument, the results 
would be clear. As a workaround, choose between the following options:

•• Each fifth is perfectly tuned, with octaves out of tune.

•• Each octave is perfectly tuned, with the final fifth (F to C) out of tune. 

Detuned octaves are more noticeable to the ears, so your choice should be obvious.
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The comma and equal temperament
The difference between a perfectly tuned octave and the octave resulting from a tuned circle of 
fifths is known as the comma. Over the centuries, numerous approaches have been tried to solve 
this mystery, resulting in a range of scales (before arriving at equal temperament—the 12-tone 
scale). Other historical temperaments that have been devised emphasize different aspects of 
harmonic quality. Each compromises in some way or another. Some maximize pure thirds (Mean 
Tone) while others emphasize pure fifths at the expense of the thirds (Kirnberger III, for example). 
Every temperament has its own character, and a given piece of music may sound fine in one 
key but awful in another. Transposing a piece to a new key can completely change its character. 
Careful attention must be paid to the selection of temperaments for authentic performances 
of historic keyboard music. The wrong choice could result in an unsatisfactory and historically 
inaccurate musical experience.

Equal temperament takes the tuning error (the comma), and spreads it equally between each 
step of a chromatic scale. The result is actually a scale of equally mistuned intervals, with no 
interval grossly out of tune, but none in perfect tune. Equal temperament has become the de 
facto standard for two main reasons:

•• Convenience: Retuning an instrument to a temperament that is better suited for a particular 
piece of music is a hassle. Many instruments are not capable of being alternately tuned—
fretted string instruments, for example.

•• Portability: All Western musical pieces can be performed (adequately) on an instrument tuned 
to equal temperament. Obviously, some of the nuances may be missing in pieces that were 
originally performed in another temperament. 

Hermode Tuning
Hermode Tuning automatically controls the tuning of electronic keyboard instruments (or 
the Logic Pro software instruments) during a musical performance. In order to create clear 
frequencies for every fifth and third interval in all possible chord and interval progressions, a 
keyboard instrument would require far more than 12 keys per octave. Hermode Tuning can help 
with this problem: it retains the pitch relationship between keys and notes, while correcting the 
individual notes of electronic instruments, ensuring a high degree of tonal purity. This process 
makes up to 50 finely graded frequencies available per note, while retaining compatibility with 
the fixed tuning system of 12 notes per octave.

Frequency correction takes place on the basis of analyzed chord structures. The positions of 
individual notes in each chord are analyzed, and the sum of each note’s distance to the tempered 
tuning scale is zeroed. In critical cases, different compensation functions help to minimize the 
degree of retuning, at the expense of absolute purity, if necessary. For example:

•• The notes C, E, and G form a C Major chord.

•• To harmonically tune these, the third (the E) needs to be tuned 14 cents higher (a cent is 
1/100th of a tempered semitone) and the fifth (the G), needs to be 2 cents higher.

It should be noted that Hermode Tuning is dynamic, not static. It is continuously adjusted in 
accordance with the musical content. This is done because, as an alternative to tempered, or 
normal, tuning, fifth and third intervals can also be tuned to ideal frequency ratios: the fifth to a 
ratio of 3:2, the major third to 5:4. Major triads will then sound strong. With clean (scaled) tuning, 
Hermode Tuning changes the frequencies to values that are partly higher or partly lower.
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Settings
Logic Pro includes a real-time tuning system, for use with the included software instruments. You 
can configure the tuning system in the Tuning settings.

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Software Instrument Pitch: Tune slider: Determines the global tuning of all software instruments. 
The default is concert pitch A (440 Hz). Detuning is in cent (1/100th of a semitone) steps.

•• Software Instrument Scale: Equal Tempered: Disables any tuning, and uses an equal 
tempered scale.

•• Software Instrument Scale: User: Allows you to detune (move away) each semitone in steps. 
Drag vertically in each semitone box until you reach the value you want, or double-click in a 
box and enter a value. Click the Reset button to reset all of your tuning adjustments to their 
default values.

•• Software Instrument Scale: Hermode Tuning (HMT): Because all tuning requirements can’t be 
satisfied simultaneously with any one Hermode Tuning setting, this setting allows you to set 
different Hermode Tuning modes and degrees of effect.

  When Advanced Editing is selected in Advanced preferences, the following are available:

•• Software Instrument Scale: Fixed: Activates a number of fixed tuning scales and keys. Fixed 
Tuning mode tunes musical keys (to different degrees) for scaled tuning systems, and delivers 
a key signature character. When playing mostly white keys (in the Pure setting, and with C as 
the root key), C major is the main focus, and tuning is scaled to that chord. An A major chord 
that is played immediately after a C major (and is therefore subject to C major scaled tuning) 
is affected somewhat by the scaled tuning effect, but will not sound completely tempered. If 
you normally play polyphonic music, this mode (when using the Pure setting) will sound most 
pleasing to your ears. The Fixed Tuning scales are ideal for a number of Baroque and Medieval 
instruments and styles of music.

•• Fixed: Type pop-up menu: Offers the most important historic tuning scales, as well as a 
few others.

•• Fixed: Root Key pop-up menu: Allows you to choose a global key (C-B) for the chosen scale. This 
provides an easy way to reference the chosen scale to any root note.
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•• User: Stretch Upper slider: Determines the deviation (from the equal tempered scale) in the 
treble end of the sound. The higher the value, the farther down the low notes are tuned. A 
setting of 0 results in an equal tempered scale tuning.

•• User: Stretch Lower slider: Determines the deviation (from the equal tempered scale) in the bass 
end of the sound. The higher the value, the farther down the low notes are tuned. A setting of 
0 results in an equal tempered scale tuning.

•• User: Root Key pop-up menu: Allows you to choose a global key (C-B) for the chosen scale. This 
provides an easy way to reference the chosen scale to any root note.

•• Hermode Tuning: Type pop-up menu: Allows you to set different Hermode Tuning modes.

•• Classic (3/5-all): This mode provides a broad and regular tuning of pure 5ths and 3rds. In 
cases of conflict, the degree of purity is temporarily reduced. This mode can be used for 
all types of music. The value of the Depth parameter indicates the degree of the 5th and 
3rd purity. A setting of 100% determines maximum purity. A 10% value is the lowest purity 
setting. Off sets the tuning to an equal tempered scale.

•• Pop/Jazz (3/5/7-all): 5ths, 3rds, and 7ths are changed in this mode. It’s great for Pop and Jazz 
styles, especially when using sustained chords. It’s less suitable for polyphonic music, as the 
detuning of the natural 7th is significant. This mode should always be used with a Depth of 
90% or 100%, as other values will render the natural 7th acoustically ineffective.

•• Baroque (3/5-adaptive): This mode tunes pure 5ths and 3rds (with changing characteristics). 
In tonal music, with a clear harmonic center, the middle chords are tuned very purely, 
whereas more distant chords are tuned with less purity. If the harmonic center becomes 
unclear, all chords are tuned with equal purity. As with the other mode parameters, a Depth 
value of 100% determines the highest purity, and a value of 10%, the lowest purity. 

•• Hermode Tuning: Depth slider: Allows you to set degrees of effect between 0% and 100%.
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Audio settings
Audio settings are used to determine the audio behavior in Logic Pro.

•• Sample Rate pop-up menu: Use to choose the sample rate for the project.

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• “Playback pre-roll” checkbox: When selected, all start commands force Logic Pro to start 
playback a little earlier (shifted to the left). The exact pre-roll value depends on the current 
delay compensation value for plug-ins. This option ensures that transients that fall exactly 
on the start position are played back correctly. If this option is unselected, transients that fall 
precisely on the start position can be missed, or seem to fade in.

•• Pan Law pop-up menu: Signals panned to the center position may sound louder than signals 
panned hard left or right. The Pan Law value determines the amount of volume reduction on 
signals that are panned to the center position. You can choose from the following settings:

•• 0 dB: With no change to the volume level, signals will seem louder when panned to the 
center position, in comparison with extreme left or right pan positions.

•• –3 dB: A full scale signal (0 dBfs) will have a level of –3 dB when panned to the 
center position.

•• –3 dB compensated: A full scale signal (0 dBfs) will have a level of 0 dB when panned to the 
center position (or +3 dB when panned to extreme left or right positions).

•• Apply Pan Law Compensation to Stereo Balancers checkbox: Applies Pan Law compensation to 
Stereo Balance controls.

Note:  For compatibility purposes, this checkbox is selected by default when older projects 
are opened.

  When Additional Surround Options is selected in Advanced preferences, the following is 
available:

•• Surround Format pop-up menu: Use to choose the surround format for the project.

  When Advanced Editing is selected in Advanced preferences, the following are available:

•• “Automatic management of channel strip objects” checkbox: Makes the creation and 
management of tracks and channel strips a transparent experience. You should only 
deselect this setting when you need to make manual changes to channel strips in the 
Environment window.

•• “Automatic naming of channel strip objects” checkbox: Allows the automatic naming of channel 
strips according to the last loaded setting (CST, SI PST, or EXS Instrument—whichever was 
loaded last), until the user enters a channel strip name manually (in the track header, channel 
strip, Mixer, or Environment).
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MIDI settings

General MIDI settings
The General pane of the MIDI project settings contains the following settings:

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Send After Loading Project: “Scrubbing with audio in Tracks area” checkbox: Select if you want to 
simultaneously scrub MIDI and audio regions in the Main window.

•• Instrument Without MIDI Thru Function pop-up menu: The instrument selected here will not pass 
events through the computer when the instrument is assigned to the selected track. Normally, 
you would set the No Output instrument here (chosen by default).

If your master keyboard doesn’t have a Local Off setting, you can use this feature to avoid 
unwanted note doubling when recording:

•• With multi-timbral sound sources, assign the instrument (usually channel 1) that plays the 
part that is heard when playing with the computer turned off.

•• With mono timbral sound sources, assign the instrument that represents the sound-
generating part of your master keyboard.

In either case, you should turn down the volume control of your master keyboard whenever 
you’re recording tracks for any other instrument.

It’s possible to disable MIDI Thru for any MIDI track in the Main window, by simply disabling 
the Record Enable button beside the track name.

  When Additional MIDI Options is selected in Advanced preferences, the following are 
available:

•• Send After Loading Project: “Used instrument MIDI settings” checkbox: Sends the active instrument 
MIDI settings automatically after loading a project.

•• Send After Loading Project: “All fader values” checkbox: Sends all Environment fader values 
automatically, once a project is loaded.

•• “SysEx with MIDI Thru function” checkbox: Incoming SysEx messages are passed through the 
computer to the MIDI outputs, along with other MIDI data. This is particularly important when 
using hardware programmers, as you can immediately monitor parameter changes to the 
synthesizer you’re editing.

If you want to record SysEx dumps, do not select this checkbox. It rarely makes sense to divert 
dumps through the computer unless you want to record a dump and simultaneously transmit 
it to a second device of the same type.
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Input Filter settings
  Input Filter settings are only available when Show Advanced Tools is selected in 

Advanced preferences.

For information on the individual checkboxes, see Edit events overview.

Chase settings
  MIDI Chase settings are only available when Show Advanced Tools is selected in 

Advanced preferences.

If you start playback in the middle of a project, some events might not be heard (such as notes, 
sustain pedal events, and pitch bend events that start before the point where playback begins). 
Using the Chase Events function, you can have Logic Pro analyze the project and include some 
or all of these events when the project plays back.

•• Notes checkbox: Any notes due to start playing at the playback start point will be sent.

•• Notes: Sustained checkbox: Any notes that are still playing at the playback start point (due to a 
sustain pedal event) will be sent.

•• Notes: In ‘No Transpose’ Instrument Channel Strips checkbox: Instrument channel strips 
(particularly drums) can be assigned No Transpose status in the inspector. This is a 
playback parameter that is ignored if the region containing the instrument notes is started 
midway through.

•• Program Change checkbox: Any program changes in regions that fall across the playback start 
point will be sent.
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•• Pitch Bend checkbox: Pitch bend events that immediately precede the playback start point will 
be sent.

•• Control Changes, 0-15, 64-71, and All Other checkboxes: Select to search for continuous 
controllers 0 to 15, continuous switch controllers 64 to 71, or all other controllers.

•• Aftertouch checkbox: Looks for monophonic (channel) aftertouch messages.

•• Polyphonic Aftertouch checkbox: Scans for polyphonic aftertouch messages.

•• System Exclusive checkbox: Transmits the most recent SysEx message before the playback 
start point.

•• Text Meta Events checkbox: Transmits the most recent Text Meta Event message before the 
playback start point.

•• “Chase separate channels in ‘All Channels’ instruments” checkbox: Multi-instruments (found 
in the Environment) have a global channel, and can have up to 16 MIDI subchannels. 
Select this option to scan for events on each MIDI subchannel, rather than the global 
multi-instrument channel.

•• Chase on Cycle Jump checkbox: Scans for, and sends, all event types if the cycle start and end 
points fall across regions.

•• Chase on Cycle Jump: Notes checkbox: Limits cycle jump scan to note events.

•• “Send full MIDI reset before chasing” checkbox: Sends a MIDI reset message before chasing, 
ensuring that all MIDI devices being triggered are set to their defaults.
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Score settings

Global Score settings
Global Score settings define global formatting options such as page margins, note spacing, bars 
per line, and more.

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Top, Bottom, Left, and Right Margin fields: These values show the margin distances (in cm or 
inch) to the outer border of the printable area on the page. A “Top Margin 0.0 inches” value 
means that printing will start as close to the top of the paper as the selected printer driver will 
allow. This also means that the size of the printable area can vary between printers, although 
the difference should be minimal.

Margins are only visible in Page Print view, where they are displayed as orange lines (are not 
printed) on the screen. You can also change margins directly in the score by dragging them 
with the Pointer or Layout tool.

•• Add Bracket Space checkbox: Creates additional space between the left margin line and the 
beginning of staffs, for braces and brackets. If unselected, staffs are aligned directly along the 
left margin line.

•• Alternating Margins checkbox: If selected, the left and right page margin settings are swapped 
on every second page. This can be useful if a score is going to be bound as a book: the 
inner margin usually needs to be a little bigger than the outer one. It’s also possible that the 
opposite might be preferable, in cases where extra space is needed for remarks that may be 
added to the score at a later date.

•• Header Space field: Defines the height reserved for headers, between the top margin of the first 
page and the top margin of the first staff on the page (as per the assigned staff style).

Note:  Text objects inserted directly into this area automatically become global text elements, 
and are displayed as headers in all score sets (full scores and parts).

You can also be change this value directly in the score, by dragging the purple line above the 
first staff.
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•• Line Distance field: Defines additional vertical distance between staff systems (single, multiple, 
or bracketed staffs can constitute a system) on the same page. It applies to full scores, as well 
as single staff parts.

•• Maximum Bars/Line field: This parameter can be useful when using small spacing values (see 
below), to prevent too many bars from being displayed on one line. The number set here limits 
the number of bars that can be displayed per line.

Note:  This setting can be overridden when using the Layout tool to change line breaks.

•• Constant Spacing field: Determines the amount of horizontal distance between notes, affecting 
the distance from note to note, regardless of rhythmic value.

•• Proportional Spacing field: Determines the amount of horizontal distance between notes, 
taking the note durations into consideration.

If you only use Proportional Spacing (and set Constant Spacing to 0), every bar receives the 
same amount of horizontal space. A whole note uses as much space as four quarter notes. In 
the opposite situation (high constant value, proportional value set to 0), the distance from one 
note to the next is always the same, regardless of note duration. A half note takes the same 
amount of space as an eighth note. Other factors, such as accidentals, ties, and so on, are also 
considered for note distance calculations.

•• Slash Spacing field: This is the distance parameter for slashes (used in staff styles that display 
beat slashes instead of automatic rests), and is especially important when inserting notes into 
staffs that display slashes. For example, musical styles such as funk use a lot of sixteenth notes, 
so you are likely to choose a higher slash distance than you would for music that doesn’t 
go beyond eighth notes. This way, the proper relationships between notes and passages 
(containing only slashes and chord symbols) can be maintained.

•• Beaming Slant Factor, Minimum Slant, and Maximum Slant fields: These three parameters affect 
the slant angle of beams. As with the Spacing parameters, these parameters work together. 
Appropriate settings need to be found by trying different combinations. The final settings will 
vary, depending on the style of the music and on personal preference.

•• Beaming Slant Factor: Determines the general amount of beam slanting, in relation to the 
intervals of the notes connected by beams.

•• Minimum Slant: Determines the minimum interval of notes that causes beams to be slanted.

•• Maximum Slant: Determines the maximum beaming slant angle.

These parameters work relative to a particular scoring situation, which is why no explicit 
settings can be given. Again, it’s essential to try different combinations when working on the 
final layout of a piece.

•• Default Pedal Position field: Determines the vertical position of automatic pedal symbols (those 
created when you use the MIDI sustain pedal during a real-time recording). If set to zero, 
recorded MIDI sustain pedal events are hidden in the score. Pedal marks that you manually 
insert from the Part box are not affected by this parameter.

•• “’Open’ single staffs” checkbox: Displays single staffs without vertical lines at their start point 
(left side of the clef ).

•• “Justify last staff” checkbox: Lengthens the last line (the last staff system, in full scores) to the 
right page margin.

•• “Alternate repeat symbols” checkbox: If selected, all repeat signs in the project are displayed with 
real book-style brackets.

•• “Hide muted notes” checkbox: Excludes muted notes from the score display. If unselected, 
muted notes are displayed in the score, even though they won’t be heard during 
MIDI playback.
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•• “Hide muted regions” checkbox: Excludes muted regions from the score display. If unselected, 
muted regions are displayed in the score, even though they won’t be heard during 
MIDI playback.

•• “Hide muted tracks” checkbox: Excludes muted tracks from the score display. If unselected, 
muted tracks are displayed in the score, even though they won’t be heard during 
MIDI playback.

  When Additional Score Options is selected in Advanced preferences, the following are 
available:

•• “Allow alias/loop editing” checkbox: Switches alias/loop editing on or off.

•• “Fill gaps” checkbox: Fills gaps between regions to display a continuous staff. 

•• Breve pop-up menu: Choose between four different shapes of breve notes, as well as the 
default no breve setting (which disables any breve notes).



	 Chapter  25    Preferences, project settings, and key commands	 897

Numbers & Names settings
  Score Numbers and Names settings are only available when Show Advanced Tools is 

selected in Advanced preferences.

These settings affect the automatic display of page numbers, bar numbers, and instrument 
names in the score.

Page Numbers settings
•• Page Numbers checkbox: Select to turn on the display of page number parameters.

•• Horizontal Position pop-up menu: Alters the horizontal alignment on the page.

•• Alternating: Alternating, beginning on the right side

•• Left, Right, or Centered: Self-explanatory

•• Rev. Alternating: Alternating, beginning on the left side

•• Vertical Position pop-up menu: Alters the vertical alignment on the page. You can choose either 
Top or Bottom.

•• Page Offset field: This value is added to each actual page number, for display purposes. This 
setting can be useful when writing a piece consisting of several parts, which are saved as 
separate project files. To retain continuous page numbers throughout the score, set this 
parameter to the number of pages contained in all preceding parts (project files).

•• Horizontal Distance field: The horizontal distance from the outermost printing position on the 
page. This is only relevant for page numbers with the Horizontal Position parameter set to 
Alternating or Rev. Alternating. 

•• Vertical Distance field: The vertical distance to the highest or lowest printing position on the 
page (depending on whether Vertical Position is set to Top or Bottom).

•• Hide 1st Page Number checkbox: Prevents the display (and printout) of the page number on the 
first page. (All others are displayed and printed.)

•• Prefix checkbox: Select to enter text that will be displayed with every page number.
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For example, if you use the prefix Page, the word Page, followed by a space and the actual 
page number, is displayed on each page. This means that page three will display Page 3. If you 
want the page number in the middle of the prefix, you need to use the # symbol as a variable 
for the page number. For example, “- pg.# -” on the second page prints as “- pg.2 -.”

You can also use the following text symbols to include automatically generated text in the 
prefix:

•• “\ i” for the score set name

•• “\ n” for the project (file) name

•• “\ s” for the name of the currently shown display level, which can be the MIDI region or 
folder name (or even the project name, on the highest level)

•• “\ d” for the current date (at the time of printout)

Bar Numbers settings
•• Bar Numbers checkbox: Select to turn on the display of bar number parameters.

•• Horizontal Position pop-up menu: Choose either At Bar Line or At Bar Center.

•• Vertical Position field: The height above the staff. If a negative value is set here, the bar numbers 
are placed below the staff.

•• Step field: This value controls the interval (in bars) between the display of bar numbers. A value 
of 4, for example, results in bar numbers at the first, fifth, ninth bar, and so on. If you only want 
bar numbers to be displayed at the beginning of each staff line, set this parameter to 0.

•• Bar Offset field: This value is added to all actual bar numbers, for display.

•• Start With field: Automatic numbering begins at the bar indicated here.

•• Hide Bar Numbers in Linear View checkbox: Linear view refers to non-Page Score view.

•• “Follow staff size” checkbox: Displays bar numbers according to staff size.

•• “Count multiple rests” checkbox: Displays the first and last bar number below multiple rests. This 
makes sense if a negative Vertical Position value is chosen, causing bar numbers to be shown 
below staffs.

•• “Show at double bars” checkbox: Displays bar numbers at every double bar line and repeat sign, 
independent of the chosen Step setting. For example, if Step is set to 0 (and Double Bars is 
activated) bar numbers are displayed at the beginning of each staff line, and above or below 
all double bar lines and repeat signs.

•• “Top/bottom staff only” checkbox: In full scores, the bar number is only displayed above the top 
staff, if this option is selected. (A negative Vertical Position value results in the number being 
shown below the bottom staff.)

Instrument Names settings
•• Instrument Names checkbox: Select to turn on the display of instrument name parameters.

•• Position pop-up menu: Choose from Above Staffs or Beside Staffs.

•• Align pop-up menu: Refers to the space preceding staffs. Choose either Left (at the left margin) 
or Right (at the right margin).

•• 1st Staff pop-up menu: Choose one of the following to display the instrument name at the first 
staff: No Names, Short Names, or Full Names.

•• Other Staffs pop-up menu: As above, for other staffs.
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Tablature settings

  Score Tablature settings are only available when Additional Score Options is selected in 
Advanced preferences.

Guitar tablature is an alternative method of notating music for fretted string instruments—
especially for guitar and electric bass—but also for other fretted instruments, with four to 
six strings (or courses of strings). In this system, the horizontal lines represent the strings of 
the instrument. Notes are always written on the line/string at which they are played. The fret 
numbers are shown instead of regular note heads. Logic Pro automatically converts notes into 
tablature, if a staff style containing a Clef parameter set to one of these tuning sets is used. The 
exact characteristics of these tuning sets are determined in the Tablature pane.

Twelve different tuning sets can be defined. Each of them corresponds to one line in this pane. 
The regular guitar and bass tunings are already included as defaults (first line and last five lines), 
as are some of the more common guitar tunings. 

Tuning set parameters
•• Name field: Double-click to change the name in the text field.

•• Strings pop-up menu: Choose the number of strings (between 3 and 16).

Note:  Up to eight strings are shown directly within the pane. If more than eight are selected, 
you can move the visible section by clicking the arrows, or dragging the scroller.

•• Assign pop-up menu: Select the method for automatically assigning notes to strings.

•• 1 to 16 fields: Double-click to type, or drag vertically to select, the pitch that the open strings 
are tuned to.
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Common parameters
•• Head Style button group: Choose one of the four head styles:

•• Numbers only

•• Numbers in circle

•• Circle 1/1, 1/2 notes only

•• Black and white (1/1, 1/2 notes) circles

•• Bass String buttons: Click to determine the display of the lowest string. It may be the same as 
other strings, or slightly thicker.

•• Up- and Down Strum buttons: Click to change the style of the Up- and Down Strum objects 
displayed in the Chord Grid and Tablature Markings Part box.

TAB Markings parameters
•• Palm Mute field: Customize the name, font, and size of the Palm Mute object in the Chord Grid 

and Tablature Markings Part box.

•• Let Ring field: Customize the name, font, and size of the Let Ring object in the Chord Grid and 
Tablature Markings Part box.

•• Slap field: Customize the name, font, and size of the Slap object in the Chord Grid and 
Tablature Markings Part box.

•• Line pop-up menu: Adjust the line: solid, dashed, or dotted.

Determine the string assignment
As most notes can be played at different positions (frets) on different strings, the Assign 
parameter in the Tablature pane performs an essential role. In most cases, the MIDI channels 
of the individual notes determine the string assignment. The MIDI channel parameter of an 
individual note has no impact on MIDI playback. The playback channel is determined in the Track 
inspector, found in the Main window.

mm Click in the Assign column (for the corresponding Tuning Set), and choose from the following 
string assignment options:

•• Pitch

Logic Pro assigns each note to the string on which it is playable, at the lowest possible 
position. In order to influence the string assignment, there is a rule (in Pitch mode only) that a 
note’s fret position cannot be lower than its MIDI channel. 

This method is generally used when notes are recorded from a MIDI keyboard:

•• An A3 (on MIDI channel 1) is displayed on the second fret of the G string. If you want the 
note to be displayed at a higher position (to correctly display the proper fingering of a 
passage), you need to set its channel to 3 or higher. This means that the fret position cannot 
be lower than 3, so the note will be displayed at the D string’s seventh fret. 

•• If the channel is between 8 and 12, the A3 is assigned to the A string on the 12th fret, and to 
the low E string (17th fret) for channels 13 to 16. 

If you want to force even higher positions, you need to use one of the other 
assignment modes.

•• Channel

In this mode, the number of the string (1 to 6, counted from the lowest string) corresponds to 
the MIDI channel. Channels 7 to 16 are assigned to the highest string. 
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•• Inv. Channel

Like Channel, but counted from the highest string (1) to the lowest (6 and above). This way of 
numbering the strings is generally used in traditional guitar tablature.

Note:  As most Guitar-to-MIDI Converters send notes (played on different strings) on different 
MIDI channels, the Channel and Inv. Channel modes are suitable if you’re using a MIDI guitar 
to record MIDI regions. The tablature notation is displayed exactly as the music was played 
during recording. 

•• Inv. Ch–1 and Inv. Ch–2

These modes should be used when recording and notating electric bass parts with Guitar-to-
MIDI Converters. 

•• “−1” is designed for five-string bass (with an additional high B string).

•• “−2” is designed for four-string bass.

The principle is the same as Inv. Channel mode, but the number of the MIDI channel is 
reduced by 1 or 2, in order to properly convert the channels for bass string assignment.

The string assignment for a four-string bass will be 3 to 6, and 2 to 6 (counted from highest 
to lowest string in both cases) for a five-string bass, just as with guitar strings that sound one 
octave higher. Notes on channel 1 will be assigned to the highest string.
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Chords & Grids settings

  Chords and Grids settings are only available when Additional Score Options is selected in 
Advanced preferences.

Chord settings
•• Root Font field: Defines the font for the chord symbol’s root note.

•• Extension Font field: Defines the font for the chord symbol’s extensions.

•• “Follow staff size” checkbox: Displays chord symbols according to staff size.

•• Slash Note Position pop-up menu: Defines the position of the slash note.

•• Accidental Scale field: Changes the accidental size, in relation to the font size setting: positive 
values result in an increased size, negative values in a diminished size of chord 
symbol accidentals.

•• Language pop-up menu: Choose between seven chord symbol languages.

•• Alignment pop-up menu: Determines the general horizontal alignment of chord symbols—with 
an Align parameter set to def (default)—in relation to their bar position.

Grid settings
•• Font field: Sets the general grid font.

•• Grid Scaling: Reduced field: Sets the size of the first chord grid when added in the Score Editor.

•• Grid Scaling: Normal field: Sets the size of the second chord grid when added in the 
Score Editor.

•• Grid Scaling: Enlarged field: Sets the size of the third chord grid when added in the Score Editor.

•• Chord Scaling: Reduced field: Sets the size of the chord on the first chord grid when added in 
the Score Editor.

•• Chord Scaling: Normal field: Sets the size of the chord on the second chord grid when added in 
the Score Editor.

•• Chord Scaling: Enlarged field: Sets the size of the chord on the third chord grid when added in 
the Score Editor.
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•• Show Fingering checkboxes: Select to show the fingering numbers on the chord grid symbols in 
the Score Editor.

•• Minimum Number of Frets field: Defines the number of frets (four, five, or six) on chord grids.

•• Barre buttons: Define the Barre style on chord grids, whether Tie or Block.

•• Thumb buttons: Define the representation of the Thumb fingering marking on chord grids. It 
can be represented by a 5 or a T.

•• Left-Handed checkbox: Changes the chord grid orientation for a left-handed user.
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Clefs & Signatures settings

  Clefs & Signatures settings are only available when Additional Score Options is selected in 
Advanced preferences.

Clefs settings
•• Clefs pop-up menu: Choose between the following clef display parameters: Every Staff, First 

Staff on Every Page, First Staff on Page 1, and Hide All.

•• “Display warnings at line breaks” checkbox: Causes warning clef changes to be displayed at the 
end of a staff or staff system (if the actual change is at the beginning of the subsequent staff or 
staff system).

•• Smaller Clef Changes pop-up menu: Clef changes (whether caused by a change of staff style, or 
by a new clef inserted from the Part box) can be displayed at a smaller size than the clefs at 
the beginning of staffs, depending on this setting.

Key and Time Signatures settings
•• Key Signatures pop-up menu: Choose between the following key signature display 

parameters: Every Staff, First Staff on Every Page, First Staff on Page 1, and Hide All.

•• “Display warnings at line breaks” checkbox: Displays a warning if key signature changes occur 
at the end of a staff or staff system (if the actual change is at the beginning of the subsequent 
staff or staff system).

•• “Automatic key transposition” checkbox: Enables the automatic transposition of key signatures in 
transposing staff styles. It is usually selected. An exception is for the notation of atonal music. If 
unselected, all sharps and flats are displayed directly with the notes.

Note:  There is a similar option in the Staff Style window (Key parameter), which allows 
you to turn off the key signature for individual staff styles, or even for individual staffs in 
multistaff styles.
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•• “Minimize transposed accidentals” checkbox: Allows the use of enharmonically changed key 
signatures, if this results in a signature with fewer accidentals. For example, if a piece is written 
in B major (5 sharps), the Bb instruments are notated in Db major (5 flats) instead of C# major 
(7 sharps).

Note:  Logic Pro does not display key signatures with more than seven flats or sharps, whether 
or not this option is selected.

•• “Show naturals” checkbox: Select this checkbox to display naturals at key signature changes, 
where preceding accidentals are no longer valid (when changing from E major to G major, or 
to C minor, for example).

•• “Show grace note accidentals” checkbox: If selected, courtesy accidentals are automatically 
displayed. This means wherever a diatonic note is altered by an accidental, another accidental 
(a natural symbol, in many cases) is displayed when that note appears (unaltered) in a 
subsequent bar.

•• Time Signatures pop-up menu: Choose between the following time signature display 
parameters: Every Staff, First Staff on Every Page, First Staff on Page 1, and Hide All.

•• “Display warnings at line breaks” checkbox: Displays a warning if time signature changes occur 
at the end of a staff or staff system (if the actual change is at the beginning of the subsequent 
staff or staff system).

•• Size pop-up menu: Alters the appearance of the meter (often much larger, for conducting 
purposes) on the staff. It is expressed as regular and percentage values. Single systems will 
show both numbers (4/4, for example) on the system. Double systems will show the upper 
number on the upper system, and the lower number on the lower system.

•• “Hide bar lines” checkbox: Use to hide all bar lines, which can be useful for educational material, 
Gregorian plain chant notation, and other special situations.

Note:  Only automatically displayed bar lines are hidden, so it’s still possible to insert bar lines 
from the Part box, including the regular bar line, which will be displayed and printed.

Octave Symbols settings
•• +8, –8, 0, +15, –15 fields: Use to edit the text string (and text formatting) of the different octave 

symbols. Click in the appropriate field, and enter the text.

•• “Follow staff size” checkbox: Displays octave symbols according to staff size.

•• Line pop-up menu: Choose an option to adjust the line: solid, dashed, or dotted.



	 Chapter  25    Preferences, project settings, and key commands	 906

Layout settings

  Score Layout settings are only available when Additional Score Options is selected in 
Advanced preferences.

You can use these settings to define a number of display settings for the whole project, such as 
staff line thickness, stem length, and distance between notes and ties, or notes and dots.

Line Thickness settings
•• Line Thickness parameters: This group of parameters determines the line thickness of the 

following objects: staff lines, stems, ledger lines, bar lines, repeat and end lines, tuplet brackets, 
text boxes (for boxed text styles), crescendi/decrescendi (also affects line objects and arrows), 
ties, and slurs.

Note:  If you have a high-resolution printer, try to use smaller line thickness settings (2, or 
maybe even 1). Smaller staff lines, in particular, look much better. The other parameter settings 
are more a matter of personal preference. These changes are only visible at high zoom levels 
on the screen. To really judge the results, try some printouts with different settings. The Slur 
and Tie Thickness parameters are affected by the Scale parameter in score sets, and the Size 
parameter in staff styles.
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Spacing settings
•• Bar Start Spacing and Bar End Spacing fields: Change the relative distance between the first 

and last note of a bar, and the preceding or subsequent bar line. Keep in mind that changing 
the default settings of these parameters only makes sense if rather extreme values have been 
chosen for the general Spacing parameters in the Global Score pane.

•• Dot to Note Distance and Dot to Dot Distance fields: Determine the distance between the note 
heads and dots, for dotted notes. Dot/Dot Distance refers to double dotted notes.

•• Accidental to Note Distance field: Use to globally alter the horizontal distance of accidentals 
from the corresponding note heads. The default setting should only be changed if very small 
values are used for the Spacing parameters, which results in a tiny distance between notes. 
This global setting can also be combined with the Accidental Distance parameter of individual 
notes, in the Note Attributes window.

•• Accidental to Accidental Distance field: Use to globally alter the horizontal distance between 
several accidentals, in chords.

Others settings
•• Stem Length field: Determines the default setting for stem length.

•• Horizontal Tie Position and Vertical Tie Position fields: Determine the distances between note 
heads and related ties (which are displayed automatically).

•• Factory Defaults button: Click to reset all parameters to their default settings.



	 Chapter  25    Preferences, project settings, and key commands	 908

MIDI Meaning settings

  Score MIDI Meaning settings are only available when Additional Score Options is selected 
in Advanced preferences.

These settings determine if, and to what extent, the insertion of the listed symbols affects the 
MIDI playback of notes (that these symbols are attached to).

The above symbols change the MIDI output of all notes they are attached to. The following two 
parameters can be determined for each symbol:

•• Velocity: This value is added to, or subtracted from, the original velocity value of the 
corresponding note.

•• Length: The original note length is shortened by the percentage chosen here. This only affects 
the playback of the note, not the score display. The note length change can be seen in the 
Event inspector or in the Event List.

The MIDI Meaning functions are most useful when you’re inserting notes with the mouse. This 
makes it possible to work as if writing music on paper.

•• First, you write/insert the notes. They will all have the same velocity, and identical rhythmic 
note values will have exactly the same length.

•• Accents and phrasing marks are then attached to some of the notes, which change the 
velocity and (playback) length of these notes.

This technique makes playback sound much more realistic and alive.

The default settings in the MIDI Meaning pane (in new projects) are 0 for velocity, and 100% (no 
change) for length. If you don’t change these values, the symbols remain purely graphical, and 
don’t affect MIDI playback. If you record your regions in real time (using a keyboard), it’s better to 
use these default settings, as the notes probably already sound the way you want them to.
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Important:  If you do use MIDI Meaning, you need to adjust the settings before you begin to 
insert accents and so on. This is because the settings have no influence on accents and phrasing 
marks that have already been inserted.

Once set, the velocity and length of notes will be changed as soon as you attach one of these 
symbols to a note. When you delete the symbol, note velocity and length are reset to their 
initial values.
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Colors settings

  Score Colors settings are only available when Additional Score Options is selected in 
Advanced preferences.

Pitch Colors settings
•• Pitch Colors Type buttons: Each note of the octave is assigned a color. They are arranged like 

piano keys. You have the following two choices when it comes to pitch color:

•• Diatonic: Allows you to use 7 different colors.

•• Chromatic: Allows you to use 12 different colors.

•• Pitch Color buttons: Click any color to open the standard Colors window and change that 
particular color.

Velocity Colors settings
•• Velocity Color buttons: These eight colors are applied in accordance with the MIDI velocity of 

notes, from left (minimum) to right (maximum). Click any color to open the standard Colors 
window and change that particular color.

Note Color Options settings
•• Accidentals checkbox: Determines whether accidentals are displayed in color (according to 

their note associations), or in black.

•• Dots checkbox: Determines whether dots are displayed in color (according to their note 
associations), or in black.

•• Ties checkbox: Determines whether ties are displayed in color (according to their note 
associations), or in black.

•• Rests checkbox: Determines whether rests are displayed in color (according to their note 
associations), or in black. Rest colors only apply to user rests, which are mainly used in 
polyphonic staff styles.
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User Palette settings
•• User Palette Color buttons: These colors can be freely edited and named. Click any color to open 

the standard Colors window and change that particular color. Double-click the text boxes to 
edit the names. These names are displayed as color options in different color selection menus 
(staff styles, note attributes).

Other settings
•• Factory Defaults button: Click to reset any changes you made in the Colors pane.

Movie settings
Movie settings are used to determine the movie offset, volume, and tempo value.

  When Show Advanced Tools is selected in Advanced preferences, the following are available:

•• Movie Start field: You can enter the SMPTE offset value directly in the Movie Start field. This is 
independent of the SMPTE offset for the project, and allows you to work from bar one (1 1 1 1 
in the control bar), even if the video timecode—at a particular point in the video—is several 
minutes into the movie file. Put simply, this makes your life easier when creating a soundtrack 
for all, or part, of a movie file. You can fine-tune the offset of internal and external video in 
Video preferences, which affect all projects.

•• Movie Volume slider: Sets the level of the audio track.

  When Advanced Editing is selected in Advanced preferences, the following are available:

•• Follow Tempo checkbox: Makes the movie run at the set tempo value (see Basis Tempo field) 
until it receives a tempo change message from the Tempo track.

•• Basis Tempo field: Sets a tempo value for the movie.
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Assets settings
  Assets settings are only available when Show Advanced Tools is selected in 

Advanced preferences.

The project assets refer to all audio files, EXS instruments, and other data associated with the 
project. Ideally, you should save all project assets with the project file, but on certain occasions 
you may prefer not to.

You can choose to copy the following assets into the project package:
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Key commands

Key commands overview
You can perform nearly every Logic Pro function with a key command, greatly accelerating 
your workflow.

You can use the Key Commands window to browse, import, and save key command sets, as well 
as to assign Logic Pro functions that you use most often to computer keyboard keys. There are 
also a number of functions that are only available as key commands. Some of these may not 
have a default key command assignment. In those cases, you’ll need to create a suitable key 
command, in order to make use of the function.

  You can only access the Key Commands window when Show Advanced Tools is selected in 
Advanced preferences.

Open the Key Commands window
Do one of the following:

mm Choose Logic Pro > Key Commands > Edit (or press Option-K).

mm Hold down Control while choosing a menu command.

The Key Commands window opens with the respective command selected.

Reset all key command assignments
Resetting will cause you to lose your existing key command assignments, so be sure to create a 
copy of your key commands file before doing so.

mm Choose Options > Initialize all Key Commands in the Key Commands window.
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Browse, import, and save key commands
You can browse or search for key commands in the Key Commands window.

You can also switch between key command sets, or import and export them. This is particularly 
useful if you need to work temporarily on another user’s Logic Pro system, because you can use 
your personal key assignments without altering the settings of the other system.

Browse key commands
Do one of the following:

mm Click the disclosure triangle beside a key command group to show its contents.

mm Choose Options > Expand All to show the contents of all key command groups.

When you expand key command groups, your key command selection may no longer be visible. 
You can quickly return to the selected key command by choosing Options > Scroll to Selection.

Search for a key command
mm Enter a search term in the search field.

You can click the small “x” at the right side of the search field to clear the search term. Click 
the magnifying glass icon at the left side of the search field to choose a search term from the 
pop-up menu.

Choose a key command set
Do one of the following:

mm Choose Logic Pro > Key Commands > Presets.

mm Choose Options > Presets in the Key Commands window.

All key command sets saved in the ~/Library/Application Support/Logic/Key Commands folder 
are displayed, allowing you to quickly switch between key command sets.

Import a key command set
mm Choose Options > Import Key Commands in the Key Commands window.

You can import key command sets from any folder location using the dialog that appears.
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Save a key command set
mm Choose Options > Export Key Commands.

You can save the current key command assignments to any location using the dialog that 
appears. You should do this whenever you make changes to your personal key command set. The 
default location is ~/Library/Application Support/Logic/Key Commands.
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Assign key commands
You can assign particular computer keyboard keys to Logic Pro functions and control 
surface messages to particular commands—effectively teaching Logic Pro to understand 
these messages.

Assign a function to a key
	 1	 Select a command in the Command column.

	 2	 Click the Learn by Key Label button.

	 3	 Press the relevant keyboard key, along with the modifier key or keys—Shift, Control, Option, 
Command.

	 4	 If the key command assignment is already used, an alert appears. You have the following options:

•• Cancel: Click Cancel if you don’t want to change the existing assignment.

•• Replace: Click Replace if you want to replace the existing assignment with the 
selected function.

•• OK: Click OK if you want to assign the key command combination to the selected function, 
while retaining the existing key command or function.

	 5	 Click the Learn by Key Label button again.

If you use the Learn by Key Label function and assign a number key, the key command will be 
used whether you use the alphanumeric keyboard or the numeric keyboard.

To define two separate key commands, use the Learn by Key Position function.
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Learn a controller assignment
	 1	 Click the Learn New Assignment button.

	 2	 Select the command in the Command column.

	 3	 Send a MIDI message from your controller.

The Assignments field displays the learned assignment, showing one or all of the following:

•• The name of the control surface—or the MIDI string, if the assignment is from an unsupported 
control surface

•• The name of the control

•• The zone and mode that the assignment belongs to

The Learn New Assignment button becomes unavailable when the entire message has been 
received. This avoids reception of further messages that may be sent by the device when you 
release the button.
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Delete a key command or controller assignment
Do one of the following:

mm To delete a key command assignment: Select the relevant command in the Command column, 
then click the Delete button.

mm To delete a controller assignment: Select the relevant command in the Command column, then 
click the Delete Assignment button.
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Print key commands
You can print a list of the currently visible key command assignments by copying and pasting 
them using the Clipboard.

Print a key command list
	 1	 Choose Options > Copy Key Commands to Clipboard in the Key Commands window.

The currently visible key command assignments are copied to the Clipboard as text.

	 2	 Paste the results into any word processor, format the results, then print the list.
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