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Preface

Welcome to Final Cut Pro

This preface covers the following:
• About Final Cut Pro (p. 27)
• About the Final Cut Pro Documentation (p. 28)
• Additional Resources (p. 28)
The first choice of professional editors worldwide, Final Cut Pro delivers high-performance
digital nonlinear editing, native support for virtually any video format, and
professional-level extensibility and interoperability. Its workflow extends through the
other Final Cut Studio applications and Final Cut Server for even more power. Whether
you’re working solo or collaborating with a team, Final Cut Pro gives you the creative
options and technical control that you need.

About Final Cut Pro
Final Cut Pro is the hub of Final Cut Studio, with powerful capabilities for working with
the other Final Cut Studio applications.
Final Cut Pro lets you edit everything from uncompressed standard definition video to
HDV, DVCPRO HD, and uncompressed high definition video—as well as Panasonic P2
and Sony XDCAM HD tapeless formats. You can mix and match a wide range of formats
and even frame rates in the open format Timeline. Final Cut Pro includes a complete set
of professional editing and trimming tools that let you work quickly, with a full range of
customization options to give you flexibility and control. Also included are powerful
multicamera editing tools that allow you to view and cut video from multiple sources in
real time.
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About the Final Cut Pro Documentation
Final Cut Pro comes with various documents that will help you get started as well as
provide detailed information about the application.
• Exploring Final Cut Pro: The Exploring Final Cut Pro manual presents the basics of
Final Cut Pro in an easy, approachable way. Each chapter presents major features and
guides you in trying things out. A PDF version of the printed manual is available in
Final Cut Pro Help (in Final Cut Pro, choose Help > Exploring Final Cut Pro).
• Final Cut Pro 7 User Manual: This is a comprehensive document that describes the
Final Cut Pro interface, commands, and menus and gives step-by-step instructions for
creating Final Cut Pro projects and for accomplishing specific tasks. It is written for
users of all levels of experience. The user manual is available in Final Cut Pro Help (in
Final Cut Pro, choose Help > Final Cut Pro Help).
• Professional Formats and Workflows: The Professional Formats and Workflows document
covers how to use digital cinema, high definition, and broadcast formats (such as
DVCPRO HD, HDV, AVC-Intra, Sony XDCAM, REDCODE, and Apple ProRes) and devices
(such as Sony Video Disk Units and Panasonic P2 cards) with Final Cut Pro. The
Professional Formats and Workflows document is available in Final Cut Pro Help (in
Final Cut Pro, choose Help > Final Cut Pro Help).

Additional Resources
Along with the documentation that comes with Final Cut Pro, there are a variety of other
resources you can use to find out more about Final Cut Pro.
Final Cut Pro Website
For general information and updates, as well as the latest news on Final Cut Pro, go to:
• http://www.apple.com/finalcutstudio/finalcutpro
Apple Service and Support Websites
For software updates and answers to the most frequently asked questions for all Apple
products, go to the general Apple Support webpage. You’ll also have access to product
specifications, reference documentation, and Apple and third-party product technical
articles.
• http://www.apple.com/support
For software updates, documentation, discussion forums, and answers to the most
frequently asked questions for Final Cut Pro, go to:
• http://www.apple.com/support/finalcutpro
For discussion forums for all Apple products from around the world, where you can search
for an answer, post your question, or answer other users’ questions, go to:
• http://discussions.apple.com
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Preface

Welcome to Final Cut Pro

About the Post-Production
Workflow

1

This chapter covers the following:
• The Industry Workflow (p. 29)
• The Post-Production Workflow (p. 30)
No matter what your project, Final Cut Studio is the cornerstone of your post-production
workflow. This section covers the post-production workflow in general terms. For more
detailed information, see Final Cut Studio Workflows, available at
http://documentation.apple.com/en/finalcutstudio/workflows.

The Industry Workflow
Before you start editing, it’s helpful to consider how post-production fits into the overall
moviemaking workflow. Even though no two movie projects follow exactly the same
steps, there is a common workflow that almost every project adheres to. From conception
to completion, the basic steps to complete a film or video project are described below.
Stage 1: Scripting
Scripting is where the movie is conceived and written.
Stage 2: Preproduction
This is where budgeting, casting, location scouting, equipment and format selection, and
storyboarding take place.
Stage 3: Production
Production is where you create your footage, capturing performances using video or film
cameras, as well as audio recorders. Lighting, cinematography, acting, and directing all
come together to create the elements used to tell your story or deliver your message.
For practical reasons, scenes are usually shot out of order, which means they have to be
properly arranged during editing.

29

Stage 4: Post-Production
Post-production is where you organize and assemble your production footage, putting
scenes in proper order, selecting the best takes, and eliminating unnecessary elements.
Production sound is synchronized (with the picture), edited, sometimes rerecorded, and
mixed. Music is composed and added. Footage is color-corrected and special effects are
created. The final movie is output to tape, film, or some other high-quality media format.
Stage 5: Distribution
Distribution is when you release a movie for viewing. This may involve theater screenings,
video and DVD releases, festival submissions, or web delivery.

The Post-Production Workflow
The post-production phase begins with the raw source footage and ends with a completed
movie, ready for making distribution copies. As technology evolves, post-production
continues to proliferate into an increasing variety of jobs and tasks. Where there was once
a single editor who was responsible for the majority of the post-production process, there
may now be a whole special effects team, an audio department, a colorist (responsible
for color correction), and a number of assistant editors keeping track of all the footage.
Final Cut Pro is at the heart of the post-production pipeline, allowing you to organize and
assemble media from multiple sources into a finished product.
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Here is an overview of the basic Final Cut Pro post-production workflow. As you begin
your project, remember that there are no hard and fast rules for editing. Different editors
have different working styles and, given the same source material, no two editors will
cut the same finished program. The workflow described here offers just one example of
how you might approach a typical project.
Industry Workflow

Final Cut Pro
Post-Production Workflow

Scripting

Planning

Preproduction

Setting Up

Production

Ingesting

Post-Production

Editing

Distribution

Mixing Audio

Adding Effects

Outputting

Stage 1: Planning
Planning is where you choose your basic workflow, such as offline and online editing (for
projects with a lot of media) or editing the uncompressed footage (for shorter projects
with quick turnaround times); choose input and output formats; and plan for equipment
requirements (such as hard disk space), timecode and sync requirements, effects shots
and color correction, audio mixing requirements, and so on.
Planning for post-production primarily means preparing for each of the upcoming
post-production phases: choosing input and output formats; acquiring your original
footage, music, and graphics; deciding on a logging and capturing method; choosing an
editing strategy; and planning the scope of effects you will be adding so you can determine
how much time and support you will need to dedicate to them.
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Stage 2: Setting Up
In this phase, you set up your editing system by installing and connecting the hardware
you need, as well as configuring your software. For example, before logging and ingesting,
you need to connect your computer either to the video and audio from your camcorder
or VTR (video tape recorder) or to a device containing your file-based media. You also
need to make sure that the correct presets are chosen within Final Cut Pro, so that
Final Cut Pro knows what video and audio formats you are capturing and what kind of
device control you’re using. (Device control allows Final Cut Pro to remotely control video
and audio devices.)
Depending on the format and device you are using, setup can be fairly simple (as it is
with DV formats) or more complex. For example, if you are working with an uncompressed
video format, you need to install a third-party video interface in your computer, as well
as a serial port adapter to communicate with the deck.
For more information, see the various chapters on setup, starting with “Connecting DV
Video Equipment.”
Stage 3: Ingesting
Ingesting is a general term for capturing, transferring, or importing video, audio, still
images, and metadata to your computer’s hard disk, which creates media files. You can
ingest media files at any time, although most footage should be ingested before you
start editing.
Logging is the process of identifying which shots you want to ingest for editing. While
you log, you can add scene and shot descriptions, logging notes, and markers. Logging
also helps you become familiar with your footage before you begin editing.
The order in which you log and ingest your footage is up to you. There are several possible
workflows, depending upon your work style, the needs of your project, and the availability
of footage. You can log all or most clips before batch ingesting them (in an automated
way), or you can log and then ingest each clip individually. You can also log clips after
ingesting your footage to a hard disk.
For more information, see “Overview of Capturing Tape-Based Media,” “Overview of
Transferring File-Based Media,” and “Importing Media Files into Your Project.”
Stage 4: Editing
The editing process involves taking the video and audio you’ve captured, along with any
music or graphics you’ve imported, and arranging these raw materials into a final edited
sequence of clips. Most editors start with a rough cut, where they quickly arrange all of
the clips for a movie in sequence. Once that’s finished, they work on fine-tuning, subtly
adjusting the edit points between clips and refining the pacing of each cut. Basic audio
editing and synchronizing are also part of this process, as well as adding transitions, such
as fades and dissolves.
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Often, the type of project you’re working on determines your method of editing. For
example, documentary editing, in which the script often evolves in parallel with the
editing, is quite different from commercial television and film editing, in which there is
already a finished script to provide an order for clips.
Stage 5: Mixing Audio
Once your movie is edited and the picture is “locked,” meaning the duration of the movie
is fixed and you no longer intend to change any of the edits, you can begin working more
extensively on your audio. This involves:
• Cleaning up the dialogue with more detailed audio editing, balancing audio levels, and
applying equalization
• Adding sound effects, music, and voiceover on additional audio tracks in the sequence
• Mixing the levels of all the different clips together to create a balanced sound mix
You can use Final Cut Pro for each of these processes. For more information, see “Audio
Fundamentals.”
Note: You can also sweeten your audio with another audio application, perhaps even at
another facility. To export your movie audio, see “Exporting Audio for Mixing in Other
Applications.”
Stage 6: Adding Effects
Creating effects tends to be more time-consuming than cuts-only editing, so it’s good to
focus on basic edits first and work on effects when the timing of your project is finalized.
Effects are any enhancements you want to make to your footage, such as color correction,
special transitions, animation, still or motion graphics, multilayered images (compositing),
and titles. Final Cut Pro has a wide variety of video and audio filters, each with parameters
that you can keyframe to adjust over time in your sequence. You can also create
professional titles and motion graphics in Motion.
Stage 7: Finishing and Outputting
Once editing is finished, effects are added, and the final audio mix is complete, you can
output your movie to videotape or export your sequence to Compressor or send it to
Color for finishing. You can also use Share to quickly create and deliver output media
files in iPod, iPhone, Apple TV, MobileMe, DVD, Blu-ray Disc, and YouTube formats.
• To output to tape, follow the standard procedures for using the Print to Video command.
For more information, see “Preparing to Output to Tape.”
• For more information about sending to Color, see the Color User Manual, available in
Color Help.
• For more information about Share, see “Using Share.”
• For more information about Compressor, see the Compressor User Manual, available in
Compressor Help.
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If you need to finish your project on a different editing workstation, you can export your
project to an interchange file format such as Edit Decision List (EDL) or Final Cut Pro XML
Interchange Format. You may need to output on another system if you work with
uncompressed video, do lots of real-time effects processing, or require specialized video
monitoring. For more information, see “Using Final Cut Pro XML and QuickTime Metadata.”
You can also refer to “Offline and Online Editing.”
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Video Formats and Timecode

2

This chapter covers the following:
• About Nonlinear and Nondestructive Editing (p. 35)
• Video Formats Compatible with Final Cut Pro (p. 35)
• Audio Formats Compatible with Final Cut Pro (p. 37)
• Video Format Basics (p. 37)
• About Timecode (p. 39)
Before you begin editing, you need to decide what video format you will use to capture,
edit, and output. The format you choose determines your post-production workflow.

About Nonlinear and Nondestructive Editing
In the past, video editing was a time-consuming process. With linear editing, video editors
had to edit everything onto a tape sequentially, one shot after another, from the beginning
to the end. If you wanted to insert a series of shots in the middle of your edit, you had
to reedit everything forward from that point.
Final Cut Pro lets you do nonlinear, nondestructive editing. Unlike traditional tape-to-tape
editing, Final Cut Pro stores all of your footage on a hard disk, allowing you to access any
frame of your footage instantaneously. Without the constraints of linear editing, you are
free to combine shots in different orders and change their durations until you arrive at
the exact sequence you want. Video and audio effects, such as scaling, position, rotation,
speed changes, and multiple layers can also be applied and played back in real time. No
matter how you process your footage, the underlying media is never touched. This is
known as nondestructive editing, because all of the changes and effects you apply to your
footage never affect the media itself.

Video Formats Compatible with Final Cut Pro
Long before editing begins, the most basic decision you need to make is which format
to shoot with. The format you choose affects the equipment needed for editorial work,
as well as how the finished product will look.
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Final Cut Pro uses QuickTime technology, allowing you to use almost any digital video
format available. This flexibility ensures that your Final Cut Pro editing system always
works with the latest video formats.
• DV editing: Final Cut Pro supports DV video natively, using your computer’s built-in
FireWire port for capture and output. DVCAM, DVCPRO, DVCPRO 50, and DVCPRO HD
are also natively supported. Therefore, your system requires no additional hardware to
edit DV material on your computer. You can capture, edit, and output exactly the same
data that is recorded on tape, resulting in no quality loss.
• Broadcast, high definition (HD), and digital cinema video formats: Final Cut Pro supports
the latest broadcast, HD, and digital cinema formats. With appropriate equipment, you
can ingest, edit, and output standard definition (SD), HD, and digital cinema formats
such as Digital Betacam, HDV, D-5 HD, HDCAM, MPEG IMX (D-10), XDCAM HD/EX/HD422,
AVC-Intra, Apple ProRes, and DPX image sequences. Final Cut Pro also supports ingest
and editing of the REDCODE and AVC-Intra formats, and output from those formats as
Apple ProRes and DPX image sequences.
• Project interchange: Support for project interchange formats allows Final Cut Pro to
integrate into existing broadcast and post-production systems. Final Cut Pro is
compatible with formats such as EDL, OMF, and the Final Cut Pro XML Interchange
Format. For more information, see “Importing and Exporting EDLs.” You can also refer
to “Exporting Audio for Mixing in Other Applications.” For information on the
Final Cut Pro XML Interchange Format, see “Using Final Cut Pro XML and QuickTime
Metadata.”
• QuickTime-compatible files: Because Final Cut Pro uses QuickTime technology, almost
any QuickTime-compatible file format can be imported and exported. This allows you
to import files created in video editing, motion graphics, and photo editing applications.
For a list of all formats that you can import, see “Learning About QuickTime.”

Using Multiple Video Formats in a Sequence
A mixed-format sequence is a sequence containing clips whose media files don’t match
the sequence format. For example, a DV sequence containing HDV footage is a
mixed-format sequence. Final Cut Pro can play sequence clips in real time even when the
clips’ settings don’t match those of the sequence. Any number of formats can be combined
together in a single sequence. For more information, see “Working with Mixed-Format
Sequences.”

Offline and Online Editing
Final Cut Pro allows you to edit low-resolution copies of your media until you are ready
to finish at high quality. For example, you can edit your movie on a portable computer
using low-resolution footage and then reconnect your project clips to high-resolution
media for finishing and output. For more information, see “Offline and Online Editing.”

36

Chapter 2 Video Formats and Timecode

Audio Formats Compatible with Final Cut Pro
You can use a variety of audio formats with Final Cut Pro, including audio files transferred
from digital recorders, captured from tape, imported from audio CDs, or provided by
musicians and sound designers. Final Cut Pro is compatible with audio files with sample
rates as high as 96 kHz and a bit depth of 24 bits. You can work with most audio devices,
such as audio CD players, DAT machines, digital multitrack recorders, or audio from
videotape. For more information, see “Capturing Audio from Tape” and “About Importing
Audio Files.”

Video Format Basics
Most video formats are described by the following characteristics:
• Standard
• Image dimensions and aspect ratio
• Frame rate
• Scanning method
For a more thorough explanation of video formats, see “Video Formats.”

Video Standards
A number of video standards have emerged over the years. Standard definition (SD) video
formats have been used for broadcast television from the 1950s to the present. These
include NTSC, PAL, and SECAM regional video standards, with each used in certain
countries and regions of the world.
• NTSC (National Television Systems Committee): The television and video standard used
in most of the Americas, Taiwan, Japan, and Korea.
• PAL (Phase Alternating Line): The television and video standard used in most of Europe,
Brazil, Algeria, and China.
• SECAM: A video standard that is based on PAL and used in countries such as France,
Poland, Haiti, and Vietnam. SECAM is not supported by Final Cut Pro. However, editing
work is usually done in PAL and converted to SECAM for broadcasting.
Important: When you are specifying your initial settings, make sure you choose an Easy
Setup that corresponds to your country’s video standard. (An Easy Setup is a collection
of settings that determines how Final Cut Pro works with your editing system.) For more
information, see “Opening Final Cut Pro and Choosing Your Initial Settings.”
Originally, all these formats were analog. Analog video uses a signal that consists of a
constantly varying voltage level, called a waveform, that represents video and audio
information. Analog signals must be digitized, or captured, for use by Final Cut Pro. VHS
and Betacam SP are both analog tape formats.
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More recently, digital SD video formats were introduced, as well as digital high definition
(HD) video formats. Most consumer camcorders today record SD digital video (such as
DV), and professional cameras may record SD, HD, or digital cinema video.

Image Dimensions and Aspect Ratio
The horizontal and vertical pixel dimensions of your format determine the frame size and
aspect ratio. For example, SD NTSC video is 720 pixels wide and 486 pixels tall. HD video
is either 1280 x 720 or 1920 x 1080, and is usually referred to by the vertical dimension
(for example, 720 or 1080) and the frame rate. In addition, Final Cut Pro refers to interlaced
HD formats according to their field rate rather than frame rate; for example, 1080i60
(59.94 fields per second) rather than 1080i30 (29.97 frames per second). Digital cinema
formats are generally referred to using their horizontal dimension as either 2K, 3K, or 4K,
shorthand for at least 2,000 pixels, 3,000 pixels, or 4,000 pixels wide.
The aspect ratio of a video frame is the width with respect to the height. SD video has
an aspect ratio of 4:3, while HD video uses 16:9. Digital cinema formats use the 16:9 aspect
ratio as well as closely related film-based aspect ratios.
Note: You may notice that 1280/720 or 1920/1080 is equivalent to 16:9, while 720/480
is not equivalent to 4:3. This is because SD digital video uses pixels that are rectangular,
not square. For more information, see “Video Formats.”

Frame Rate
The frame rate of your video determines how quickly frames are recorded and played
back. The higher the number of frames per second (fps), the less noticeably the image
flickers on screen. There are several common frame rates in use:
• 24 fps: Film, certain HD formats, and certain SD formats use this frame rate. This may
also be 23.98 fps for compatibility with NTSC video.
• 25 fps: SD PAL, HD PAL
• 29.97 fps: SD NTSC, HD NTSC (720p30, 1080p30, and 1080i60)
• 50 fps: 720p HD
• 59.94 fps: 720p HD
• 60 fps: 720p HD
For more information, see “Frame Rate and Timecode.”

Scanning Method
Video frames are composed of individual lines, scanned from the top of the screen to the
bottom. Lines may be scanned progressively (one line at a time), or interlaced (every
other line during one scan, and then the alternate lines on a subsequent scan). For more
information, see “Video Formats.”
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About Timecode
Timecode is a signal recorded with your video that uniquely identifies each frame on
tape. When you capture video or audio in Final Cut Pro, you also capture the timecode
signal, which is displayed in Final Cut Pro when you play back your clips. Timecode allows
you to recapture your footage from tape and always get the same frames. Final Cut Pro
uses SMPTE timecode (developed by the Society of Motion Picture and Television
Engineers), which is represented in hours, minutes, seconds, and frames, using the
following format:
SMPTE timecode

01:32:15:28
Hours

Minutes

Seconds

Frames

In Final Cut Pro, timecode is used for synchronization between video and audio clip items,
project interchange (such as Edit Decision Lists), and recapturing clips from tape. When
you play clips, Final Cut Pro displays the media file timecode. Timecode also allows you
to navigate through your sequences, and see how long your edit is.
For more information about timecode, see “Working with Timecode.”

About Drop Frame and Non-Drop Frame Timecode
With the exception of timecode used with NTSC video, all video formats use non-drop
frame timecode, which simply counts at the frame rate of the video itself. For example,
PAL video runs at 25 fps, and it uses 25 fps timecode.
When working with NTSC video, you have the option to use drop frame timecode to
compensate for the fact that NTSC video has a frame rate of 29.97 fps, while the timecode
runs at 30 fps. Timecode can only be represented by whole numbers, so drop frame
timecode periodically skips numbers so that the timecode count and the amount of actual
time passed stays in sync. This way, the timecode count matches the the number of hours,
minutes, and seconds that it takes for your video footage to play. NTSC video can use
either drop frame or non-drop frame timecode.
Important: No video frames are dropped when you use drop frame timecode. Only the
associated timecode numbers are skipped.
Here is how to determine the type of timecode used in Final Cut Pro:
• Non-drop frame timecode has a colon (:) between the seconds and frames fields, and
no numbers are dropped from the counter.
01:16:59:29, 01:17:00:00
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• Drop frame timecode has a semicolon (;) between the seconds and frames fields, and
two timecode numbers are skipped from the frames counter each minute (except every
tenth minute).
01:16:59;29, 01:17:00;02
A clip’s timecode comes directly from its media files. To set sequence timecode, you can
use the Drop Frame checkbox in the Timeline Options pane of Sequence Settings. For
more information, see “Changing Timeline Display Options.”

How Drop Frame Timecode Works
When you use drop frame timecode, numbers :00 and :01 are skipped at the beginning
of each minute, unless the minute number is exactly divisible by 10. The dropped numbers
do not appear in the timecode fields in Final Cut Pro because they’ve been dropped and
are not on your tape.
If you’re entering timecode to navigate and inadvertently type a timecode number that
doesn’t exist in drop frame timecode, Final Cut Pro automatically moves forward to the
next available timecode number.
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Understanding Projects, Clips, and
Sequences

3

This chapter covers the following:
• The Building Blocks of Projects (p. 41)
• Working with Projects (p. 45)
• About the Connection Between Clips and Media Files (p. 48)
• Filenaming Considerations (p. 50)
The basic elements in Final Cut Pro are projects, clips, and sequences. Once you learn
what these are and how you can use them, you can begin working in Final Cut Pro.

The Building Blocks of Projects
Media files, clips, and sequences are the elements that provide the main foundation for
your work in Final Cut Pro. You use projects and bins to organize these elements in your
program.

What Are Media Files?
Media files are the raw materials you use to create your movie. A media file is a video,
audio, or graphics file on your hard disk that contains footage captured from videotape
or originally created on your computer. Since media files—especially video files—tend
to be quite large, projects that use a lot of footage require one or more high-capacity
hard disks.
Many media files contain multiple tracks. For example, a typical DV media file has a video
track, audio track, and timecode track. In a Final Cut Pro sequence, you can work with
these media tracks together or separately.
Before you can edit in Final Cut Pro, you need to capture media files from a video deck
or camcorder to your hard disk. For more information about capturing media files, see
“Overview of Capturing Tape-Based Media.”
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What Are Clips?
Once you have media files on your hard disk, you need a way of working with them in
Final Cut Pro. A clip is the most fundamental object in Final Cut Pro. Clips represent your
media, but they are not the media files themselves. A clip points to, or connects to, a
video, audio, or graphics media file on your hard disk. (For more information on the
relationship between media files and clips, see “About the Connection Between Clips and
Media Files.”)
Project

Clip

Clip

Clip

Media files on your hard disk

Clips allow you to easily cut, trim, rearrange, and sort your media without manipulating
it directly. You manage and organize your clips in the Browser. The three kinds of clips
you’ll see most often are video, audio, and graphics clips, but there are other kinds of
clips that can be stored within a project, such as a generator clip (a clip whose media is
generated within Final Cut Pro). You can also subdivide a clip into separate pieces, called
subclips, to further organize your footage.
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What Are Sequences?
A sequence is a container for editing clips together in chronological order. The editing
process involves deciding which video and audio clip items to put in your sequence, what
order the clips should go in, and how long each clip should be. Sequences are created
in the Browser. To edit clips into a sequence, you open a sequence in the Timeline from
the Browser.
Project
Sequence
Clip

Clip

Clip

A sequence contains one or more video and audio tracks, which are empty when first
created. When you edit a clip into a sequence, you copy the clip’s individual clip items to
the sequence. For example, if you drag a clip that contains one video and two audio
tracks to the Timeline, a video clip item is placed in a video track in the Timeline, and two
audio clip items are placed in two audio tracks. In a sequence, you can move any clip
item to any track, allowing you to arrange the contents of your media files however you
want.

What Are Projects?
A project contains all of the clips and sequences you use while editing your movie. Once
you create or open a project, it appears as a tab in the Browser. There’s no limit to the
number of items, including clips and sequences, that can be stored in your project in the
Browser.
A project file acts as a sort of database for tracking the aspects of your edited movie:
• Video, audio, and still image clips
• Comments, descriptions, and log notes for all your clips
• Sequences of edited clips
• Motion and filter parameters
• Audio mixing levels
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• Bins, or folders within a project in the Browser, for organizing elements such as clips
and sequences
Project
Video clip
Audio clip
Still image

ABC

Sequence

To start working in Final Cut Pro, you must have a project open in the Browser. For more
information, see “Browser Basics.” You can have multiple projects open at the same time,
each represented by its own tab in the Browser.
Note: A project does not contain any media at all, which keeps it small and portable.
Even though project files refer to your media files, the media is not actually stored in the
project. By separating the structure of your project from the associated media, your project
can easily be archived or transferred to another computer, and it can be opened even if
none of the media files can be located. Compared to media files, project files are relatively
small and portable. You can make regular backup copies of your project without filling
your hard disk.

What Are Bins?
A bin is a folder within a project that can contain clips and sequences, as well as other
items used in your project, such as transitions and effects. You use bins to organize these
elements, sort them, add comments, rename items, and so on. Bins help you to design
a logical structure for your projects, making your clips easier to manage.
Project
Bin 1
Clip

Clip

Clip

Clip

Clip Clip Clip

Bin 2

Clip
Clip
Clip
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Sequence 1

Clip Clip Clip
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You can create separate bins for organizing clips by movie scene, source tape, or any
other category. You can organize bins hierarchically and open them in their own windows.
You can even put bins inside other bins. There is no limit to the number of bins you can
have in your project, or the number of items you can store in each bin.
Bins exist only in project files. Changes you make to the contents of a bin, such as deleting,
moving, and renaming clips or renaming the bin itself, have no effect on the original
media files stored on your computer’s hard disk. If you delete a clip from a bin, the clip’s
media file is not deleted from the hard disk. Likewise, creating a new bin does not create
a new folder on your hard disk.

Working with Projects
How you use and organize your projects depends on the scope of your movie as well as
your particular organizational style. These factors also affect your decision to use one or
more sequences in your project.

Organizing Your Projects
Typically, you create a new project file for each movie you work on, regardless of its
duration. For example, if you’re working on a documentary about a bicycle manufacturing
company, you would create a project for it. If you’re also working on an industrial training
video about how to fix bicycles, that would be a second, separate project. Both projects
could conceivably refer to some of the same media, but they are completely independent
structures, each with its own clips, bins, and sequences.
Very large movie projects, such as feature films and documentaries with high shooting
ratios (meaning most of the footage shot during production will not be used in the final
movie), may contain thousands of clips. Although the number of clips and sequences
you can store in a project is theoretically unlimited, Final Cut Pro may take longer to
search, sort, and update if there are too many clips. If you find that managing your project
is becoming difficult, you can always break one project into several for the early editing
stages.

Using More Than One Sequence in a Project
For some projects, it makes sense to use several different sequences within the project.
You can use sequences in several ways, including:
• Sequences as scenes: Break a movie into a series of separate sequences for each scene.
• Sequences as versions: Edit different versions of the same movie, with each as its own
sequence. Examples are a television commercial with several alternative sound mixes,
or a documentary cut to feature film length as well as broadcast television length.
• Sequences for special effects: This allows you to separate elaborate effects shots in
separate sequences so you can render them separately.
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Creating and Saving Projects
When you create a new project in Final Cut Pro, a new blank sequence is automatically
created and named Sequence 1. You can change the sequence name to better reflect its
content or the type of program you’ll be working on. The settings for the new sequence
are determined by your current Easy Setup. (To check your current Easy Setup, choose
Final Cut Pro > Easy Setup.) For more information, see “Audio/Video Settings and Easy
Setups.”
Note: When you open Final Cut Pro for the first time, there are some initial settings you
must specify before you can create and save projects. For more information, see
“Connecting DV Video Equipment.”

µ

To create a new project
Choose File > New Project.
A new, untitled project appears in the Browser with an empty sequence. You can name
the project when you save it.
This is your new project.

A new sequence is
automatically created
when you create a
new project.

To save a project
1 Click the project’s tab in the Browser
2 Choose File > Save Project (or press Command-S).
3 If you haven’t named the project yet, a dialog appears. Enter a name and choose a location
for the project, then click Save.
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µ

To save all open projects
Choose File > Save All (or press Option-S).
If you haven’t named a project yet, a dialog appears where you can enter a name and
choose a location for the project.

Opening and Closing Projects
You can open and work on more than one project at a time. When you finish working
and quit Final Cut Pro, a message appears for each open project, asking if you want to
save your changes. The next time you open Final Cut Pro, all projects that were open at
the end of your last session open automatically. You can have multiple projects open at
the same time, each represented by its own tab in the Browser.
To open a project
1 Choose File > Open.
2 Locate and select the project file, then click Open.
If you created the project in a previous version of Final Cut Pro, you’ll be asked if you want
to update your project. For more information, see “Backing Up and Restoring Projects.”
To close a project
1 Click the project’s tab to bring it to the front.
2 Do one of the following:
• Choose File > Close Project (or press Control-W).
• Control-click the project’s tab, then choose Close Tab from the shortcut menu that
appears.
Control-click the tab and
choose Close Tab.

Chapter 3 Understanding Projects, Clips, and Sequences

47

3 If you’ve modified the project and haven’t saved it, a message asks if you want to save
changes to the project. Click Yes to save the project.

µ

To switch between several open projects
In the Browser, click a project’s tab.
To switch between
projects, click a
project’s tab.

µ

To close all open projects
Close the Browser.
Any project that has its own window (because you dragged the project’s tab out of the
Browser) remains open.

About the Connection Between Clips and Media Files
Clips are not to be confused with the media files you captured to your computer’s hard
disk. A clip refers to a media file on your computer’s hard disk, but the clip is not the
media file itself. Clips usually reference all of the content within a media file, but you can
also create subclips that reference only part of a media file, or merged clips that refer to
several media files at once.
A Final Cut Pro clip refers to its media file via the clip property called Source, which
describes the location of the media file in the form of a directory path. For example, the
directory path for a clip’s media file might look like this:
/MyScratchDisk/Capture Scratch/MyProject/MyMediaFile
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Note: Every file on your hard disk can be located by its directory path. A directory path
describes where a file is located within the file and folder hierarchy of the operating
system.
To see a clip’s Source property
1 Select a clip in the Browser by clicking it.
2 Choose Edit > Item Properties > Format (or press Command-9).
The Item Properties window appears.
3 Look at the directory path in the clip’s Source field.
4 If you can’t see the complete directory path, you can do one of the following:
• Drag the right edge of the column heading to the right to increase the column width.
• Move the pointer over the directory path in the Source field, then wait until a tooltip
appears showing the complete directory path.

Relationship Between Source Tapes, Media Files, and Clips
The relationship between source tapes, media files, and clips is described below.
• Source tape: An original videotape from your production.
• Media file: A QuickTime movie file created by capturing video, audio, and timecode
from the source tape to a computer hard disk. This is a copy of the original footage.
• Clip: An object in a Final Cut Pro project that represents a media file on the scratch
disk. A clip connects to a media file, but it isn’t the media file itself. If you delete a clip,
the media file remains intact on the scratch disk. If you delete the media file, the clip
remains in the project, but it is no longer connected to its media. You can create clips
by importing or dragging media files to the Final Cut Pro Browser.

Reconnecting Clips to Media Files
If you modify, move, or delete your media files on disk, the clips in your project lose the
connection to the media files and they become offline clips. In this case, the word offline
refers to the fact that a clip’s media file has become unavailable.
To create an offline clip (without a corresponding media file)
Do one of the following:

µ
µ

Choose File > New > Offline Clip.
Create a clip by clicking the Log button in the Log and Capture window.
For more information, see “Logging from Tape.”
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An offline clip has a red slash through its icon in the Browser. In the Timeline, an offline
clip appears white (when you play back your sequence in the Canvas, offline clips display
a “Media Offline” message). To view these clips properly in your project, you need to
reconnect the clips to their corresponding media files at their new locations on disk. This
reestablishes the connection between the clips and their media files.
Offline clips
in the Timeline

Offline clips
in the Browser

Final Cut Pro allows you to reconnect clips to media files in whatever way suits your
project. For example, you can work on one project on two different editing systems that
both contain the same media files. When you transfer the project from one system to
another, you can easily reconnect the project clips to the local media files. For more
information on reconnecting offline clips, see “Reconnecting Clips and Offline Media.”

Filenaming Considerations
Proper filenaming is one of the most critical aspects of media and project management.
When you capture your media files, consider how and where your files may be used in
the future. Naming your files simply and consistently makes it easier to share media
among multiple editors, transfer projects to other editing systems, move files across a
network, and properly restore archived projects. The following sections present several
issues to consider when naming project files and media files.

Avoiding Special Characters
The most conservative filenaming conventions provide the most cross-platform
compatibility. This means that your filenames will work in different operating systems,
such as Windows, Mac OS X and other UNIX operating systems, and Mac OS 9. You also
need to consider filenaming when you transfer files via the Internet, where you can never
be certain what computer platform your files may be stored on, even if temporarily.
Most special characters should be avoided. Here are some suggested conservative
filenaming guidelines for maximum cross-platform compatibility:
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Avoid

Example characters

Reasons

File separators

: (colon)
/ (forward-slash)
\ (backward-slash)

You cannot use colons (:) in the names of files and
folders because Mac OS 9 (Classic) uses this
character to separate directories in pathnames. In
addition, some applications may not allow you to
use slashes (/) in the names of items.
These characters are directory separators for
Mac OS 9, Mac OS X, and DOS (Windows)
respectively.

Special characters not
included in your native
alphabet

¢™

These characters may not be supported or may
be difficult to work with when exported to certain
file formats, such as EDL, OMF, or XML.

Punctuation marks,
parentheses, quotation
marks, brackets, and
operators

.,[]{}()!;"'*?<>|

These characters are often used in scripting and
programming languages.

White space characters
such as spaces, tabs,
new lines, and carriage
returns (the last two are
uncommon)

White space is handled differently in different
programming languages and operating systems,
so certain processing scripts and applications may
treat your files differently than expected. The most
conservative filenames avoid all use of whitespace
characters, and use the (underscore) _ character
instead.

Restricting Length of Filenames
Although current file systems such as HFS+ (used by Mac OS X) allow you to create
filenames with a 255-character limit, you may want to limit your filename length if you
intend to transfer your files to other operating systems. Earlier versions of the Mac OS
allow only 31-character filenames, and if you want to include a file extension (such as
.fcp, .mov, or .aif ), you need to shorten your Mac OS 9-compatible filenames to 27
characters.
For EDL files, which may be stored on DOS-compatible disks, you should limit your
filenames to eight characters plus a three-character file extension (.EDL).

Using Filename Extensions
Mac OS X and other operating systems can use file extensions when determining which
application to open a file with, or what method of transfer to use for a network transfer.
If you intend to transfer your media or project files to non-Mac computer platforms, you
should use standard file extensions for your files. Some common file extensions include
.mov (QuickTime movie file), .xml (XML file), .zip (ZIP compressed archive file), .aif (AIFF
audio file), .wav (WAVE audio file), .psd (Photoshop graphics file), .jpg (JPEG graphics file),
and .png (TIFF graphics file).
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Adding Times and Dates to Final Cut Pro Project Names
When you make a backup copy of your project file, adding the date to the project name
helps identify the file among the other saved versions. If you add dates to a filename,
avoid using special characters like the slash (/), since that may be interpreted by Mac OS X
as a file separator.
The Final Cut Pro autosave feature appends the date and time in the following format:
ProjectName_03-21-09_1744. The filename here is a backup of a project called ProjectName.
The date is March 21, 2004, and it was saved at 5:44 PM. Note that the name includes no
white space. This filenaming convention is simple, consistent, and easily identifies the
order in which the project files were created. (For more information about this feature,
see “Backing Up and Restoring Projects.”

Using Multiple Hard Disks
If you have multiple hard disks and partitions, or volumes, that have similar names, they
may cause problems during the capture process. Each hard disk should have a name that
doesn’t contain the entire name of another disk or partition.
• Avoid filenames such as: “Media” and “Media 1”
• Create filenames such as: “Zeus” and “Apollo”
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Overview of the Final Cut Pro
Interface

4

This chapter covers the following:
• Basics of Working in the Final Cut Pro Interface (p. 53)
• Using Keyboard Shortcuts, Buttons, and Shortcut Menus (p. 55)
• Customizing the Interface (p. 57)
• Undoing and Redoing Changes (p. 62)
• Entering Timecode for Navigation Purposes (p. 63)
The Final Cut Pro interface has four main windows and a Tool palette.

Basics of Working in the Final Cut Pro Interface
There are four main windows in Final Cut Pro that you use while you are making your
movie. You may want to open Final Cut Pro so you can view these windows and familiarize
yourself with them.
Note: If you’re opening Final Cut Pro for the first time, you’re prompted to choose an
Easy Setup (a collection of settings that determines how Final Cut Pro works with your
editing system) and a scratch disk (the hard disk where you’ll store your captured media
files). For more information about these settings, see “Opening Final Cut Pro and Choosing
Your Initial Settings.”

µ

To open Final Cut Pro
In the Finder, double-click the Final Cut Pro icon in the Applications folder.
You can also add the Final Cut Pro icon to the Dock for easier access. For more information,
see Mac Help.
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You see these windows when you open a sequence with clips already in it. These windows
are covered in more detail in the chapters that follow.
Browser: This is where
you organize the media
in your project.

Viewer: Used for previewing
and preparing source clips for
editing, as well as for adjusting
filters and motion parameters.
Canvas: Allows you
to view your edited
sequence, as well
as perform a variety
of editing functions.
Works in parallel with
the Timeline.
Audio meters: These
floating meters let you
monitor audio levels.

Tool palette: This
contains tools for
selecting, navigating,
performing edits, and
manipulating items.
Timeline: This displays
sequences.

Before working in a window in Final Cut Pro, you must make sure it’s the currently selected
(or “active”) window. Otherwise, your actions and commands might trigger actions in
another window.
Important: Menu commands and keyboard shortcuts apply to the active window.

µ

To determine the active window
Look for the highlighted title bar.
To make a window active
Do one of the following:

µ
µ

Click anywhere in the window.
Press one of the following keyboard shortcuts:
• Browser: Command-4
• Viewer: Command-1
• Timeline: Command-3
• Canvas: Command-2
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• Audio meters: Option-4
Note: There is no keyboard shortcut to open the Tool palette.

µ

Choose Window, then in the submenu, choose the window you want to display.

Using Keyboard Shortcuts, Buttons, and Shortcut Menus
Final Cut Pro offers several methods for performing commands. You can choose commands
from the menu bar at the top of the screen or from contextual shortcut menus, or you
can use keyboard shortcuts to perform many commands. Most people work fastest using
keyboard shortcuts; others prefer to use shortcut menus or the mouse to access commands
in the menu bar. Experiment to find out which method best suits your editing style.
You can also create shortcut buttons that appear at the top of each window in the
window’s button bar. Learning about these basic interface elements will enable you to
work faster and more efficiently.

Using Keyboard Shortcuts
Keyboard shortcuts let you perform commands in Final Cut Pro by using the keyboard
instead of by pointing and clicking. These shortcuts can help you work more efficiently.
For example, to create a new sequence, you press Command-N; to zoom in, you press
Command–Equal Sign (=).
Note: The default keyboard shortcuts for tasks are presented throughout this
documentation, as well as in menu commands and tooltips. Tooltips appear when you
move the pointer over a control in Final Cut Pro and show the name of the control, as
well as the current shortcut key(s) assigned to that control.
Final Cut Pro allows you to change the default keyboard shortcuts to better suit your
needs. For example, if your style of editing requires a particular set of commands that
isn’t readily available by default, you can modify the default keyboard layout with your
own set of commands. You can also create different keyboard layouts for different tasks.
For example, you may find it useful to create different keyboard layouts for editing, color
correction, multicamera editing, and audio mixing.
For more information on how to customize keyboard layouts in Final Cut Pro, see
“Customizing the Interface.”
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Using Button Bars
You can create shortcut buttons and place them in the button bar along the top of the
main windows in Final Cut Pro—the Browser, Viewer, Canvas, Timeline, and any Tool
Bench windows. (The Tool Bench is a specialized window containing tabs for specific
tasks, such as the Audio Mixer.) You can then click any of the shortcut buttons in the
button bar to perform commands, instead of using keyboard shortcuts or menus.
Button bar in the
Browser with several
shortcut buttons

For more information on using and customizing button bars, see “Customizing the
Interface.”

Using Shortcut Menus
Shortcut menus (also called contextual menus) are available in nearly every section of
every window and offer a quick way to perform various tasks. The commands available
in a shortcut menu depend on the location of the pointer. For example, a shortcut menu
in the Browser shows options different from those available in a shortcut menu in the
Timeline.
To view and use a shortcut menu
1 Press the Control key and click an item (this is called Control-clicking), or Control-click an
area in a window in Final Cut Pro.
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2 In the shortcut menu that appears, choose the command you want, then release the
mouse button.

Note: If you have a multibutton mouse, clicking the right mouse button is the same as
Control-clicking by default.

Learning Commands by Using Tooltips
When you move the pointer over a control in Final Cut Pro, a small box called a tooltip
appears with a description of the control. Next to the description is the keyboard shortcut
for using the control. You can turn tooltips off and on in the General tab of the User
Preferences window.

This tooltip appears
when the pointer
is over the Play button
in the Viewer.

To turn on tooltips in Final Cut Pro
1 Choose Final Cut Pro > User Preferences.
2 In the General tab, select Show Tooltips.

Customizing the Interface
Final Cut Pro allows you to customize the interface in several ways. You can rearrange
windows and move them to suit your needs and work style or you can use various window
layouts provided by Final Cut Pro. You can also position the Dock in the Mac OS X interface
so that it takes up less room or is hidden.
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Moving and Resizing Windows
All open windows in Final Cut Pro—the Browser, Viewer, Canvas, Timeline, and Tool
Bench—can be individually moved and resized to suit both your working style and the
task at hand, even across multiple monitors. When all windows are arranged together on
a single monitor, you can drag the border between any aligned group of adjacent windows
to quickly resize all the windows at the same time.

Pointer between
two windows
Pointer between three
or more windows

µ

To resize windows in Final Cut Pro
Drag the border in the desired direction to resize the appropriate windows.
The windows on either side of the border are resized accordingly.
Any border between two windows in Final Cut Pro can be dragged. When borders line
up, such as the tops of the Browser and Timeline, they act as a single border—resizing
one window resizes the other as well. See “Moving and Resizing Final Cut Pro Windows”
for more information.

58

Chapter 4 Overview of the Final Cut Pro Interface

Working with Tabs and Tabbed Windows
The Viewer and Browser contain tabs that let you access different functions. The Browser
also contains tabs for open projects. Tabs in the Timeline and Canvas represent open
sequences.
The Browser contains
tabs for open projects
and effects.

The Viewer contains tabs
that specify functions
within clips.
The Canvas contains
a tab for each
open sequence.

Like the Canvas, the
Timeline contains a tab
for each open sequence.

µ

To make a tab active
Click the tab.
To close a tab
Do one of the following:

µ
µ
µ

Click the tab to make it the frontmost tab, then choose File > Close Tab.
Control-click the tab, then choose Close Tab from the shortcut menu.
Click a tab to make it the frontmost tab, then press Control-W.
When multiple tabs appear in a Timeline or Canvas window, you can have Final Cut Pro
close all the tabs except the active one.
To close all tabs except the active one in the Timeline or Canvas window
Do one of the following:

µ

Click the tab you want to keep open to make it the frontmost tab, then choose File >
Close Other Tabs.
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µ

Control-click the tab, then choose Close Other Tabs from the shortcut menu.
In the Browser, you can also close all open bins that are represented as tabs.

µ

To close all bin tabs in the Browser window
Control-click a bin tab, then choose Close All Bins from the shortcut menu.
To switch between tabs of the active window
Do one of the following:

µ
µ

To select the previous tab, press Command–Shift–Left Bracket ([).
To select the next tab, press Command–Shift–Right Bracket (]).
When multiple tabs appear in a window, you can reorder them by dragging a tab left or
right to a different position in the top of the window. When you hold the pointer over a
tab, a tooltip appears showing the location of the tab in the hierarchy of tabs. You can
also assign colors to tabs that represent bins and sequences by assigning a colored label
to the bin or sequence icon in the Browser. For more information about assigning labels,
see “Using Labels to Organize Your Clips.”
You can drag tabs out of their main, or parent, windows so they appear in a separate
window. This is useful when you are working on more than one sequence or project at
a time.

µ

To make a tab appear in its own window
Drag the tab out of its parent window (Browser, Viewer, Canvas, or Timeline).
The Effects tab is
dragged out of the
Browser and appears
in its own window.
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µ

To put a tab back in its original window
Drag the tab to the title bar of its parent window.
Drag the tab to the title
bar of the original
window to put it back.

Moving Windows
There are several ways you can move windows in Final Cut Pro. You can move a window
by clicking its title bar, and then dragging it to a new position and releasing the mouse
button. You can also hold down the Command and Option keys, and then click anywhere
in a window and drag it to a new position.

Using Different Window Layouts
Final Cut Pro comes with a set of predefined window layouts. These layouts determine
the size and location of the four main windows in Final Cut Pro (the Browser, Viewer,
Canvas, and Timeline), along with the Tool palette and audio meters. Some window
layouts include additional windows, such as the Tool Bench. Choose a layout that
maximizes your screen space in the best way for your source material, editing function,
screen resolution, and monitor type.

µ

To choose a window layout
Choose Window > Arrange, then choose an option from the submenu.
If none of the existing layouts meets your needs, you can create and save additional
window layouts that you’ve arranged yourself. See “Customizing Window Layouts” for
more information.
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Showing and Positioning the Dock
When you use Final Cut Pro, your screen space may be limited by the presence of the
Dock. You can make the Dock smaller so it takes up less room on the screen. You can
also hide the Dock, so it only appears when you move the pointer over its (hidden)
position. Another option is to position the Dock somewhere else on the screen. The
default is on the bottom, but you can also choose to place it on the left or right side of
the screen.
Decide how you think you’ll work best, then modify the Dock settings. You can then
rearrange the windows in Final Cut Pro to accommodate the position of the Dock.
To arrange Final Cut Pro windows and make room for the Dock
1 If you prefer, change the position of the Dock.
For specific information on changing the way the Dock looks and works, see Mac Help.
(In the Finder, choose Help > Mac Help.)
2 In Final Cut Pro, choose Window > Arrange, then choose your preferred layout from the
submenu.
The windows are rearranged to take into account the position of the Dock.

Undoing and Redoing Changes
You can undo changes you make in your projects, sequences, and clips. This is helpful if
you make a change you don’t like and want to revert to an earlier version. You can also
redo actions that you have undone.
By default, you can undo 10 of your previous changes. You can set Final Cut Pro to undo
up to 99 changes. The more levels of Undo you select, the more memory is needed. For
more information on modifying the number of changes to undo, see “Choosing Settings
and Preferences.”
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µ

To undo a change
Choose Edit > Undo (or press Command-Z).

µ

To redo a change
Choose Edit > Redo (or press Command-Shift-Z).
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Entering Timecode for Navigation Purposes
Timecode is a signal recorded with your video that uniquely identifies each frame on
tape. Timecode also allows you to navigate through your sequences to a specific point
in time.

Current Timecode field
in the Canvas

When you enter timecode in a field, such as the Current Timecode field in the Viewer,
Canvas, or Timeline, you don’t need to enter all of the separator characters (such as
colons); Final Cut Pro automatically adds them for you after each set of two digits.
For example, if you enter 01221419, Final Cut Pro interprets it as 01:22:14:19. This stands
for 1 hour, 22 minutes, 14 seconds, and 19 frames.
If you enter a partial number, Final Cut Pro interprets it with the rightmost pair of numbers
as frames and puts each successive pair of numbers to the left in the remaining seconds,
minutes, and hours areas. Numbers you omit default to 00.
For example, if you enter 1419, Final Cut Pro interprets it as 00:00:14:19.
However, if the rightmost pair of numbers is not a valid frame number, then the entire
number entered is interpreted as absolute frames.
For example, suppose the frame rate of your clip is 25 fps. If you enter 124, Final Cut Pro
interprets this as 01:24 (1 second and 24 frames). However, if you enter 125, or 199,
Final Cut Pro interprets these as 125 frames or 199 frames, respectively. This is because
the frame counter cannot be higher than 24 when you use 25 fps timecode. Since a
number like 01:99 is not a valid timecode number, the entire value is interpreted as
absolute frames.
For more information about using timecode, see “About Timecode” and “Working with
Timecode.”
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Browser Basics

5

This chapter covers the following:
• How You Use the Browser (p. 65)
• Learning About the Browser (p. 66)
• Working in the Browser (p. 67)
• Using Columns in the Browser (p. 71)
• Customizing the Browser Display (p. 73)
The Browser is where you organize all of the clips in your project.

How You Use the Browser
The Browser is a powerful tool used to organize your project’s clips. In the Browser, you
can sort, rename, and rearrange hundreds of clips in a multitude of ways. You can also
customize how the Browser displays information about clips to suit your preferred work
habits.
You can think of the Browser as a way of viewing and manipulating your clips as if they
were in a database or spreadsheet. Each row represents a clip or sequence, and each
column represents a property field containing information about that clip or sequence.
Note: For more information about the basic organizational elements of
Final Cut Pro—media files, clips, sequences, bins, and projects—and how they relate to
the Browser, see “Understanding Projects, Clips, and Sequences.”
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Learning About the Browser
You can view items in the Browser in different ways. When the Browser displays items in
list view, all items appear in a sorted list.
Each tab represents
a project or an open bin.
You can also access
effects through
the Browser.

Columns display
clip properties.

Bins help you organize
clips in your projects.

Sequence

You can also view items in the Browser in icon view, which lets you easily see items by
type. For video clips, you see a frame of video to help you distinguish the contents.
Project

Sequence

Clip

Bin

For more information about viewing items in the Browser in list view or icon view, see
“Customizing the Browser Display.”
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Working in the Browser
Before you can work in the Browser, it must be the currently selected, or active, window.
Otherwise, any commands or keyboard shortcuts you use may perform the wrong
operations.
To make the Browser window active
Do one of the following:

µ
µ

Click anywhere in the Browser.
Press Command-4.

Creating Sequences
Before you can begin editing clips into a sequence, you must create a sequence.
To create a new sequence
1 Click in the Browser to make it the active window.
2 Choose File > New > Sequence (or press Command-N).
If no project is currently open, Final Cut Pro creates a new untitled project and creates a
new sequence within it.

Selecting Items in the Browser
You can select and modify individual clips, or many clips at once.

µ

To select a single clip
Click an item.

A selected clip
is highlighted
in the Browser.
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To select a group of adjacent clips
Do one of the following:

µ

Select an item, press and hold down the Shift key, then click the last item.

The first and last items
are selected, along with
all items in between.

µ

Drag over multiple clips.

Drag across multiple
items to select them.
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µ

To select multiple, nonadjacent clips
Press and hold down the Command key while clicking multiple items.

Select the first clip.
Then press the
Command key while
selecting other clips.

Navigating Within the Browser Using the Keyboard
You can navigate to items in the Browser in various ways, depending on whether you
are viewing items in list view or icon view. (See “Customizing the Browser Display.”)
To navigate within the Browser
Do one of the following:

µ

Press the Up Arrow and Down Arrow keys to move up and down in a list of items in list
view or move vertically between items in icon view.

µ

Press the Right Arrow and Left Arrow keys to move horizontally between items in icon
view.

µ
µ

Press the Tab key to move between items alphabetically.
Type the first few letters of an item’s name.

Copying and Deleting Items in the Browser
Copying or duplicating a clip creates an affiliate clip, which is a clip that shares properties
with the original clip, ormaster clip. For more information about master-affiliate clip
relationships, see “Working with Master and Affiliate Clips.”
To copy an item
Do one of the following:

µ

Select an item, choose Edit > Copy, then choose Edit > Paste.
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µ

Select the item, then hold down the Option key while you drag the item to a new bin or
to the Name column heading.
Hold down the Option
key while you drag
the item to a new
bin or to the Name
column heading.

µ

Press Option-D to duplicate the selected item.

To duplicate a master clip, creating a new master clip instead of an affiliate clip
1 Select a clip in the Browser.
2 Do one of the following:
• Choose Modify > Duplicate as New Master Clip.
• Control-click the clip, then choose Duplicate as New Master Clip from the shortcut
menu.

µ

To delete a clip, sequence, or bin from a project
Select the item, then press Delete.
Note: Deleting a clip from a project does not delete that clip’s media file from your hard
disk, nor does it delete any other affiliated clips, including sequence clips. When deleting
a master clip, however, Final Cut Pro warns you that affiliated clips will lose the master
clip they refer to. Deleting a master clip turns all affiliated clips into master clips (in the
Browser) or independent clips (in sequences).

Renaming Clips, Sequences, and Bins
You can rename items within Final Cut Pro. Renaming clips does not change the names
of media files on your disk.
To rename clips, sequences, and bins within Final Cut Pro
1 Select the clip, sequence, or bin.
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2 Click the item’s name, type a new name, then press Return or Enter.

Enter a new name
for the item
in the Name field.

Renaming a clip automatically renames all affiliated clips in the current project, because
there is only a single Name property shared between a master clip and all of its affiliate
clips. This affects all clips in the Browser and in all sequences within your project. For
more information on master and affiliate clips, see “Working with Master and Affiliate
Clips.”
Note: Master-affiliate clip relationships exist only within a project, not across multiple
projects.

Using Columns in the Browser
In list view, the Browser’s scrollable columns provide information about your clips and
their associated media files.

Use the vertical
scroll bar to navigate
and view all of the
clips and sequences
in your project.

Use the horizontal
scroll bar to navigate
and view all of the
columns in list view.
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The Browser can display many columns of information at once. You can customize the
Browser to display only the columns you want, as well as rearrange columns and change
their width. The Name column cannot be hidden, and always appears at the far left.
Information in Browser columns is based on the following:
• The item properties of a clip
• The clip settings you selected when your clips were logged and captured
• A clip’s media file properties such as image dimensions and frame rate
• The sequence settings of an individual sequence (the selected sequence preset)
You can change properties in some columns directly in the Browser by clicking or
Control-clicking within the column, and then choosing an option from the shortcut menu.
You can also modify these properties in the Item Properties window for a clip. For more
information, see “Working with Projects, Clips, and Sequences.”
Other properties, such as the frame size or video rate, are determined by the capture
preset you used to capture the clip’s media file. See “Capture Settings and Presets.”
Tip: If a field in the Browser contains more text than fits within the field or column, you
view the complete information by moving the pointer over the field and then waiting
for several seconds. A tooltip appears with the full text of the entry.

Viewing Columns in Standard or Logging Formats
There are two default column layouts included with Final Cut Pro: standard and logging.
You can customize both layouts for particular projects. You can also create and save your
own column layouts.
• Standard Columns: Choose this option to see most of a clip’s properties.
• Logging Columns: Choose this option when logging clips, so you can focus on clips’
logging properties (such as Media Start, Media End, Duration, and Reel) and the Browser
isn’t cluttered with other information.
You can customize both column layouts, displaying, hiding, and reordering columns in
any way you like. Any modifications you make are remembered for the column layout
you’re using for that project. New projects you create use the default column layouts.
Note: For a description of column information, see “Elements of a Final Cut Pro Project.”

µ

To switch between standard and logging columns
Control-click any column heading in the Browser, then choose Standard Columns or
Logging Columns from the shortcut menu.

Creating Custom Column Layouts
You can create your own column layouts, based on your preferred arrangement of
columns. For more information, see “Saving and Using Custom Column Layouts.”
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Customizing the Browser Display
There are various ways you can display items in the Browser, depending on your needs
and work style. You can display items in list or icon (thumbnail) view, choose columns
you want to show or hide, and choose the frame you see for a clip in icon (thumbnail)
view.

Choosing Views in the Browser
You can view items in the Browser in list view or icon view. List view provides detailed
clip information in columns; clips within bins appear hierarchically, allowing you to reveal
or hide the contents of a bin.

List view (default)

If you want to organize your clips visually, you can set the Browser to display your clips
as icons. There are three icon view sizes—small, medium, and large. When you choose
an icon view, items are rearranged in a grid. The large icon view is particularly useful
when using larger (20-inch or greater viewable area) monitors.

Small icon view

Medium icon view

Large icon view

To display Browser items as icons or in a list
Do one of the following:

µ
µ

Choose View > Browser Items, then choose an option from the submenu.
Control-click in the Name column (or any place in the tab other than an icon), then choose
a view option from the shortcut menu.
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µ

Press Shift-H to toggle through all four views.

Working with the Browser in List View
When items are displayed as a list, the Browser displays information about the items in
columns. You can customize these columns in several ways. You can:
• Rearrange, resize, hide, and show individual columns
• Display, hide, and scrub (move) through thumbnails of clips
• Change the Master Comment or Comment column headings

µ

To rearrange a column
Drag the column heading to the new location.

As you drag a column,
the pointer changes
to a rectangle.

µ

To resize a column
Drag the right edge of the column heading to the desired width.

The pointer between
two columns changes
to a Resize pointer,
indicating a column
can be resized.

µ
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To hide a column
Control-click the column heading, then choose Hide Column from the shortcut menu.
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Note: You can’t hide the Name column; it’s always displayed.

Control-click a column
heading, then choose
Hide Column.

µ

To display a hidden column
Control-click the column heading to the right of where you want to display the column,
then choose the column you want to display from the shortcut menu.

Control-click a column
heading, then choose
the column you want
to display.
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µ

To display thumbnails
Control-click any column heading other than Name, then choose Show Thumbnail from
the shortcut menu.

Control-click a column
heading, then choose
Show Thumbnail.

A thumbnail column appears with images for all video clips.

Thumbnails appear
as small images
of your video clips.

When thumbnails are displayed, the image shown is the first frame of the clip or the In
point of the clip, if one is set. You can scrub through a thumbnail by dragging in the
image, but the frame shown in the Browser always reverts to the Media Start or In point
of the clip.
You can change the starting image (called the poster frame) if you want to display another
frame in the thumbnail. For more information, see “Setting the Poster Frame.”

µ
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To hide thumbnails
Control-click the Thumbnail column heading, then choose Hide Column from the shortcut
menu.
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µ

To scrub, or move, through a thumbnail
Drag the thumbnail image in the direction you want to view.

The thumbnail you’re
scrubbing through
is highlighted.

Note: You can also scrub through clips that are displayed in large icon view. See “Scrubbing
Through Clips in Icon View.”
To change the name of the Master Comment or Comment column heading
1 Control-click a Comment column heading, then choose Edit Heading from the shortcut
menu.

Control-click a Comment
column heading, then
choose Edit Heading.
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2 Type a new name in the column’s Name field, then press Return.

Enter the new
column name.

The Master Comment and Comment column headings are the only column headings
you can change. Once you customize the name of a Comment column, it remains changed
in that project file, even if you hide it. New projects you create use the default names.
If you want to change several Comment headings at once, use the Project Properties
window. For more information, see “Working with Projects, Clips, and Sequences.”
Note: You can change the name of a Master Comment column. For example, you can
change “Master Comment 1” to “Director’s Notes.” But when you export this data (or
reimport it into Final Cut Pro), the column will always retain its original name; for example,
“Master Comment 1.”
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Working with the Browser in Icon View
In large, medium, or small icon view, you arrange your clips graphically in the Browser.
Video clips are displayed as a thumbnail of the starting frame of video, audio clips are
displayed as a speaker, and bins are indicated by a folder icon. If a video clip has an audio
track, a small speaker icon appears inside the clip’s thumbnail.
Video clip with audio

Thumbnails of clips
in icon view

Audio clip

You can use different views for open Browser windows and tabs. For example, you can
keep the main tab of your project in the Browser in list view for organizational purposes,
but open bins in their own windows or tabs using large icon view to quickly identify clips
visually.
Scrubbing Through Clips in Icon View
In large icon view, you can scrub through video clips to see their content. You can also
scrub through thumbnails of clips displayed in list view. (See “Working with the Browser
in List View.”) However, you don’t have all of the options you have in large icon view.
Note: You can’t scrub through clips in small icon view.
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To scrub through clips in large icon view
1 Do one of the following:
• Select the Scrub tool in the Tool palette.

Selection tool

Scrub tool

Note: When the Scrub tool is selected, you can hold down the Shift or Command key
to temporarily make the Selection tool active to select, open, or move clips.
• Select the Selection tool in the Tool palette, then press Shift-Control to temporarily
make the Scrub tool active.
2 Drag the Scrub tool over the thumbnail.

Move right to scrub
forward; move left
to scrub backward.

Automatically Arranging Clips in Icon View
When you’re in icon view in the Browser, you can organize clip icons however you want.
You can use the Arrange commands to automatically arrange your icons from left to right,
either in alphabetical order or by duration, within the current width of the Browser or
bin window. This is useful if the Browser or a bin window has overlapping icons or if you
find yourself constantly scrolling to see icons.
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To arrange items in the Browser into rows in icon view
Do one of the following:

µ
µ

Choose View > Arrange > by Name or by Duration.
Control-click in an empty area of the Browser, then choose Arrange by Name or Arrange
by Duration from the shortcut menu.

Before using the
Arrange command

After using the
Arrange command

Setting the Poster Frame
The poster frame is the picture that represents a clip in icon view in the Browser. When
you look at clips in the Browser in large icon view or when you show the Thumbnail
column in list view, the icon or thumbnail picture you see reflects either the In point for
that clip (or the first frame of the clip if no In point has been set), or the poster frame you
set for the clip in the Browser.
Poster frames are useful if you want to identify a clip visually in the Browser using a specific
image, and can be especially useful if you’re working with a lot of clips or subclips with
similar imagery. Any frame of a clip can be its poster frame.
To set the poster frame of a clip in the Viewer
1 Double-click a clip in the Browser to open it in the Viewer.
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2 In the Viewer, navigate to the frame you want to use as the poster frame for the clip.
3 Choose Mark > Set Poster Frame (or press Control-P).

µ

To set the poster frame in the Browser in large icon view
Scrub through a clip until you get to the frame you want, press and hold down the Control
key, then release the mouse button.

Original poster frame
(before scrubbing)

The poster frame is now
set to the frame you
scrubbed to.

Saving and Using Custom Column Layouts
You can create customized column layouts and save them for easy access at any time.
For example, some editors prefer to have the Master Comment 1 column after the Name
column, so they don’t have to scroll to that column all the time to review the assistant
editor’s notes. The custom column layouts you save are displayed in the shortcut menu
that appears when you Control-click any column heading in the Browser (except the
Name column).
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To save a custom column layout
1 Rearrange the Browser columns the way you want them to appear.
Note: The Name column always appears on the far left and cannot be moved.
2 Control-click any column heading, then choose Save Column Layout from the shortcut
menu.
3 In the Save dialog, choose where you want to save the layout, change its name if you
like, then click Save.
Custom column layout files are saved by default to the following folder location:
/Users/username/Library/Preferences/Final Cut Pro User Data/Column Layouts/

µ

To open a custom column layout
Control-click any column heading in the Browser except Name, then choose a custom
layout from the shortcut menu.
If you have placed column layouts in a location other than the default folder mentioned
above, you need to open them using the Load Column Layout command in the shortcut
menu.

To open a custom column layout that is not in the default location
1 Control-click any column heading in the Browser except Name, then choose Load Column
Layout from the shortcut menu.
2 In the Choose a File dialog, navigate to the location where the column layout is stored,
select it, then click Choose.
Tip: You can also save and use custom column layouts in the Find Results window,
following the same instructions you use for the Browser. Any custom column layouts
created in the Browser can be used in the Find Results window, and vice versa.
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Viewer Basics

6

This chapter covers the following:
• How You Can Use the Viewer (p. 85)
• Opening a Clip in the Viewer (p. 86)
• Learning About the Viewer (p. 87)
• Tabs in the Viewer (p. 90)
• Transport Controls in the Viewer (p. 92)
• Playhead Controls in the Viewer (p. 93)
• Marking Controls in the Viewer (p. 95)
• Zoom and View Pop-Up Menus in the Viewer (p. 96)
• Playhead Sync Pop-Up Menu (p. 99)
• Recent Clips and Generator Pop-Up Menus (p. 100)
The Viewer is used for viewing a clip’s media and preparing clips before editing them
into a sequence.

How You Can Use the Viewer
The Viewer is extremely versatile. You can use the Viewer to:
• Define In and Out edit points for clips before editing them into a sequence
• Adjust audio levels and panning in the Audio tab
• Open clips within sequences to adjust durations, In and Out points, and filter parameters
Note: Changes you make to a clip opened from a sequence are applied to the clip only
in that sequence. If you make changes to a clip opened from the Browser, the changes
appear only in the clip in the Browser.
• Add filters to clips and adjust filters applied to clips
• Adjust the motion parameters of clips to modify or animate such parameters as Scale,
Rotation, Cropping, and Opacity
• Adjust generator clip controls
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Generators are special clips that can be generated by Final Cut Pro, so they don’t require
source media. Final Cut Pro has generators that create color mattes, text of different
types, gradients, color bars, and white noise. For more information, see “Using Generator
Clips.”
• Open a transition, such as a dissolve or a wipe, from an edited sequence for detailed
editing
For more information, see “Adding Transitions.”
Before you can work in the Viewer, it must be the currently selected, or active, window.
Otherwise, any commands or keyboard shortcuts you use may perform the wrong
operations. To display the Viewer (if it’s not open already), you must open a clip from the
Browser or the Timeline. See “Opening a Clip in the Viewer.”
To make the Viewer window active
Do one of the following:

µ
µ
µ

Click the Viewer.
Press Command-1. (Press this again to close the Viewer.)
Press Q to switch between the Viewer and the Canvas.

Opening a Clip in the Viewer
The Viewer is where you look at source clips from the Browser before editing them into
a sequence. You can also open clips that are already in a sequence in order to adjust
durations, In and Out points, and filter parameters. There are a variety of ways to open
clips in the Viewer. You can choose the method that you find most convenient.
Tip: You can tell whether a clip in the Viewer has been opened from the Browser or from
a sequence in the Timeline. Sprocket holes appear in the scrubber bar for clips opened
from a sequence. You can also tell the origin of the clip from the name of the clip in the
Viewer title bar.
To open a clip in the Viewer from the Browser
Do one of the following:

µ
µ
µ
µ
µ

In the Browser, select the clip, then choose View > Clip.
In the Browser, Control-click the clip, then choose Open in Viewer from the shortcut menu.
In the Browser, double-click the clip.
Drag the clip from the Browser to the Viewer.
In the Browser, select the clip and press Return.
Note: In the Browser, pressing Enter is different from pressing Return. Pressing Enter
allows you to rename the clip.
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µ

In the Viewer, select a clip name from the Recent Clips pop-up menu in the lower-right
area of the window.
To open a sequence clip in the Viewer from the Timeline or Canvas
Do one of the following:

µ
µ

In the Timeline, double-click the clip.
In the Timeline or Canvas, move the playhead over the clip, then press Return or Enter.
The clip on the lowest-numbered track with Auto Select turned on is opened in the
Viewer.

µ
µ

In the Timeline, select the clip and press Return or Enter.
Drag the clip from the Timeline to the Viewer.
Sprocket holes
indicate that this
is a sequence clip.

Learning About the Viewer
The following is a quick summary of the Viewer controls. For a more detailed description
of Viewer controls, see the sections starting with “Tabs in the Viewer.”
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Controls in the Top Part of the Viewer
The top part of the Viewer has the following controls.
Clip name and the
project it’s in

Tabs

Current Timecode field
View pop-up menu
Playhead Sync
pop-up menu
Image display area

Timecode
Duration field

Zoom
pop-up menu

• Tabs: There are five tabs that can be shown in the Viewer—Video, Audio, Filters, Motion,
and Controls—each providing certain editing functions. For more details, see “Tabs in
the Viewer.”
• Timecode Duration field: This field shows the current duration between the clip In and
Out points. You can change the duration here, which automatically adjusts the clip Out
point.
• Zoom pop-up menu: This pop-up menu lets you enlarge or shrink the image that appears
in the Viewer.
• Playhead Sync pop-up menu: This pop-up menu gives you options for locking the
movement of the playheads in the Viewer and the Canvas together in different ways
while scrubbing through clips. For more information, see “Matching Frames and
Playhead Synchronization.”
• View pop-up menu: The View pop-up menu allows you to control display options such
as timecode and marker overlays, as well as the background color for transparent pixels.
• Current Timecode field: This field displays the timecode of the frame at the current
position of the playhead. You can enter timecode numbers here to navigate to a new
position in the clip.
• Image display area: This is the area of the Viewer where you can see the video from
your sequence play back.
• Scrubber bar: The scrubber bar represents the entire duration of a clip. You can click
anywhere in the scrubber bar to automatically move the playhead to that location.
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Controls in the Bottom part of the Viewer
The bottom part of the Viewer has the following controls.
Shuttle control
In point
Playhead

Out point
Marker
Scrubber bar
Jog control
Generator pop-up menu
Marking
controls

Transport
controls

Recent Clips
pop-up menu

• Jog and shuttle controls: You use the jog and shuttle controls to navigate within your
clip, much like traditional VTR controls.
• Marking controls: You use the marking controls to set edit points (In and Out points)
and add markers and keyframes to your clips.
• Playhead: The position of the playhead corresponds to the currently displayed frame.
You can move the playhead to go to different parts of a clip.
• Transport controls: You use these controls to play clips and move the playhead within
clips and sequences.
• In point and Out point: In and Out points allow you to define a specific portion of a clip
to include in a sequence. A clip In point marks the first frame of a clip to be edited into
a sequence. A clip Out point specifies the last frame of the clip to be used. For more
information, see “Setting Edit Points for Clips and Sequences.”
• Recent Clips pop-up menu: This pop-up menu allows you to open recently used clips in
the Viewer for modifying and editing into your sequence.
• Generator pop-up menu: You use this pop-up menu to select and open generators in
the Viewer for modifying and editing into your sequence. Generators are special clips
that can be generated by Final Cut Pro; for example, they can be used to create color
mattes and text of different types.
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Tabs in the Viewer
Each tab in the Viewer provides a specific set of editing functions: Video, Audio, Filters,
Motion, and Controls. You can drag tabs out of the Viewer so they appear in separate
windows. This is useful, for example, if you want to adjust filter or generator parameters
while watching the results in the Video tab.

Video Tab
The video tab lets you view a clip’s video media, set In and Out points, and add markers
and keyframes. This tab appears when you open a clip that includes video clip items. This
tab is shown by default. (See “Learning About the Viewer.”)

Audio Tabs
Audio tabs display audio waveforms for audio clip items. If your clip has audio items, each
audio item opens in its own Audio tab. (If you open an audio-only clip, you only see Audio
tabs with no accompanying Video tab.) Clips in Final Cut Pro may have up to 24 audio
items.
An Audio tab may represent a single (mono) audio item or a stereo pair of audio items.
Stereo audio items appear together in a single tab, while mono audio items appear
separately in individual tabs. Controls in each Audio tab allow you to change the audio
level and the stereo panning parameters, creating keyframes if necessary to adjust levels
over time. You can also use an Audio tab to set In and Out points, markers, and keyframes
for audio clips. To learn more, see “Audio Editing Basics.”

90

Chapter 6 Viewer Basics

Filters Tab
You use this tab to adjust parameters for any video or audio filters you’ve applied to a
clip. You can also set keyframes to adjust filter parameters over time. For more information
on video filters, see “Using Video Filters.” For more information on audio filters, see “Using
Audio Filters.”

Motion Tab
Every clip with a video clip item, whether it’s a video, still image, or generator clip, has
the same motion parameters: Scale, Rotation, Center, Anchor Point, and additional
attributes such as Crop, Distort, Opacity, Drop Shadow, Motion Blur, and Speed. The
Motion tab allows you to adjust these parameters of a clip.
You can create motion effects by setting keyframes for motion parameters over time. For
more information, see “Changing Motion Parameters.” Also refer to “Adjusting Parameters
for Keyframed Effects.”
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Controls Tab
You use the Controls tab to change the parameters for generator clips, such as the font
and text size in a Text generator, or the size of a Circle Shape generator. The Controls tab
appears only when a generator is open in the Viewer. For additional information, see
“Using Generator Clips.”

Transport Controls in the Viewer
Transport (or playback) controls let you play clips in the Viewer. (The same controls also
appear in the Log and Capture and Edit to Tape windows.) These controls play clips at
100 percent (or 1x) speed. There are keyboard shortcuts for each control.
Go to Previous Edit

Go to Next Edit
Play Around
Current Frame
Play
Play In to Out

• Play (Space bar): Plays your clip from the current location of the playhead. Clicking it
again stops playback.
• Play In to Out (Shift–Vertical Bar): Moves the playhead to the current In point of a clip
and plays forward from that point to the Out point.
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• Play Around Current Frame (Backslash): Plays the selected clip “around” the current
playhead position. When you click this button, the playback begins before the playhead
position based on the value in the Preview Pre-roll field in the Editing tab of the User
Preferences window. Playback continues through the original position of the playhead,
and then continues for the amount of time set in the Preview Post-roll field in User
Preferences. When you stop playback, the playhead jumps back to its original position.
For more information, see “Choosing Settings and Preferences.”
• Go to Previous Edit (Up Arrow) and Go to Next Edit (Down Arrow): When you have a Browser
clip open in the Viewer, these controls navigate between the In, Out, and Media Start
and End points of the clip. When you have a sequence open, these buttons let you
navigate between sequence edit points; sequence In and Out points are skipped over.

Playhead Controls in the Viewer
The playhead lets you navigate through and locate different parts of a clip quickly and
easily.
Playhead

Inactive video
Scrubber bar

Shuttle control

Jog control

Playhead and Scrubber Bar in the Viewer
The playhead shows the location of the currently displayed frame within the current clip.
The scrubber bar runs along the entire width of the Viewer, below the video image. To
scrub through a clip, drag the playhead across the scrubber bar. You can click anywhere
in the scrubber bar to instantly move the playhead to that location.
The playhead’s movement in the scrubber bar is affected by whether “snapping” is turned
on. When snapping is on, the playhead “snaps,” or moves directly, to any markers, In
points, or Out points in the scrubber bar when it gets close to them. (To turn snapping
on or off, choose View > Snapping, or press the N key.)

µ

To move the playhead to the next In or Out point, or Media End
Press the Down Arrow key.

µ

To move the playhead to the previous In or Out point, or Media Start
Press the Up Arrow key.

µ

To move the playhead to the beginning of your clip
Press Home on your keyboard.
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µ

To move the playhead to the end of your clip
Press End on your keyboard.

Jog Control in the Viewer
To move forward or backward in your clip very precisely, use the jog control. The jog
control allows you to move the playhead as if you were actually moving it with your hand,
with a one-to-one correspondence between the motion of your mouse and the playhead’s
motion. This control is useful for carefully locating a specific frame (for instance, if you’re
trimming an edit). For more information, see “Jogging Through a Clip or Sequence.”

µ

To move the playhead backward, one frame at a time
Press the Left Arrow key.

µ

To move the playhead forward, one frame at a time
Press the Right Arrow key.

µ

To move the playhead one second at a time
Hold down the Shift key and press the Left Arrow or Right Arrow key.

Shuttle Control in the Viewer
This control lets you quickly play through clips at different speeds, in fast and slow motion.
It also shifts the pitch of audio as it plays at varying speeds. In slow motion, this can make
it easier to locate specific words and sounds for editing.
Drag the slider to the right to fast-forward and to the left to rewind. Playback speed varies
depending on the distance of the slider from the center of the control. When the slider
is green, playback speed is normal (or 100 percent speed). The further away from the
center you move, the faster the playback speed. The keyboard equivalents of the shuttle
control are the J, K, and L keys. For more information, see “Shuttling Through a Clip or
Sequence.”
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Marking Controls in the Viewer
Marking controls let you set In and Out points, add markers and keyframes, and navigate
to matching frames in master or affiliate clips. (This is called performing a match frame.)
There are keyboard shortcuts for each control.
Show Match Frame

Add Marker
Mark In
Mark Out
Add Motion Keyframe
Mark Clip

• Show Match Frame (F): When you click this button, Final Cut Pro searches the current
sequence for the same frame shown in the Viewer. Specifically, Final Cut Pro looks for
any sequence clips that are affiliated with the clip in the Viewer. If the frame shown in
the Viewer is used in the current sequence, the Canvas/Timeline playhead is positioned
to that frame. The result is that you see the same frame in both the Viewer and the
Canvas, but the clip you see in the Canvas is actually an affiliate of the clip in the Viewer.
This is useful if you want to see where you have already used a particular frame in your
sequence.
Each time you click the Show Match Frame button, Final Cut Pro navigates to the next
occurrence of that frame in the sequence. To make sure you find the first occurrence
of the frame, you can move the Canvas/Timeline playhead to the start of the sequence.
For a more comprehensive discussion of the Match Frame controls, see “Matching
Frames and Playhead Synchronization.”
• Mark Clip (X): Click to set In and Out points at the boundaries of the clip.
• Add Motion Keyframe (Control-K): Click to add a keyframe to the current clip at the
position of the playhead for clip parameters such as Scale, Rotate, Crop, Distort, and
so on. By default, this button sets keyframes for all clip motion parameters at once. To
add keyframes for individual parameters, Control-click this button and choose a
parameter from the shortcut menu. For more information, see “Adjusting Parameters
for Keyframed Effects.”
• Add Marker (M): Click to add a marker at the current playhead position. While editing,
you can use markers to make notes about important points in your sequence, such as
areas to change, potential edit points, or sync points. For more information, see “Using
Markers.”
Important: If a clip is selected in the Timeline, and the playhead touches that clip, a
marker is added to the sequence clip, not the sequence.
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• Mark In (I): Click to set the In point at the current position of the playhead.
• Mark Out (O): Click to set the Out point at the current position of the playhead.

Zoom and View Pop-Up Menus in the Viewer
The two pop-up menus near the top of the Viewer let you quickly select the magnification
level and a viewing format to control the way media in the Viewer is displayed.
Note: These menus also appear in the Canvas, and the options are the same.
• Zoom pop-up menu: Choose a magnification level from this pop-up menu. Your choice
affects only the display size of the image; it doesn’t affect the scaling or frame size of
the footage in the Viewer. You can also change the magnification level by pressing
Command–Equal Sign (=) to zoom in and Command-Hyphen (-) to zoom out.

Zoom pop-up menu

When playing back media with the Viewer scaled to 100 percent, both fields of interlaced
video are displayed. If the Viewer is scaled to anything other than 100 percent and
you’re displaying a DV clip, only one field is shown during playback or while scrubbing
through the clip. When playing back media captured with a third-party video interface,
some interfaces display both fields regardless of the scale of the Viewer, which may
result in visible artifacts in the picture. These are display artifacts only, and do not exist
in the video signal output to tape.
Important: Clips may not play back smoothly if you zoom in on them so far that part
of the image is obscured, and you see scroll bars to the right and below the Viewer
windows. Other windows blocking the Viewer will also affect playback. Choosing a
window layout or pressing Shift-Z are easy ways to remedy playback quality in this
situation.
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Besides simply choosing a magnification level, you can choose one of the following:
• Fit to Window: Increases or decreases the size of your media’s image to match any
size of the Viewer window. You can also do this by clicking the Viewer to make it
active, and then pressing Shift-Z (Zoom to Fit).

Before

After

• Fit All: This is similar to the Fit to Window command, but this command takes into
account clips whose borders extend beyond the current Viewer boundaries.

Before
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• Correct for Aspect Ratio: Displays non-square pixel images as square pixels so they
look correct on your computer screen. Standard definition (SD) video equipment
displays video using non-square pixels, whereas computer monitors display video
with square pixels. Because of the difference in the shape of the pixels, the same
video image looks different on each kind of monitor. Final Cut Pro can simulate how
your images will look on a video monitor using the computer’s display, so that your
video images look correct as you edit. This does not permanently affect your picture;
it’s only for display purposes. Final Cut Pro always displays video in Production
aperture display mode. For more information about aperture display modes, see
“About QuickTime Aperture Display Modes.”

Displaying native, non-square pixels

Display pixel as square

• View pop-up menu: You can choose various options from this pop-up menu for how
you view your clips and sequences in the Viewer.

View pop-up menu

Note: None of these view options affect either rendered output or material sent to
tape. They only affect display in Final Cut Pro.
• Image, Image+Wireframe, or Wireframe mode: Image is the default, and simply shows
the video of your clip or sequence as it plays back. Image+Wireframe is useful when
you’re using motion effects or compositing. Each video layer in the Viewer has a
bounding box with handles (or a wireframe) that can be used to adjust that clip’s
size, rotation, and position. Wireframe mode shows only the bounding box and
handles of each clip in your sequence, without the corresponding image. For more
information on using motion effects, see “Changing Motion Parameters.” You can
also refer to “Adjusting Parameters for Keyframed Effects.” For information on
compositing, see “Compositing and Layering.”
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• Overlays: Final Cut Pro provides translucent visual cues, called overlays, that help you
easily recognize certain parts of your edit in the Viewer, such as the markers and In
and Out points of clips in your sequence. To view overlays such as title safe and
timecode overlays, you need to turn on this option.
• Title safe and action safe overlays: These overlays show you the boundaries within
which you need to keep your graphics and text so they’ll appear when the sequence
is played back on television. For more information, see “Creating Titles.”
• Timecode overlays: These overlays display the source timecode for clips and are
color-coded to show which items are in sync. For more information, see “About
Timecode Overlays and Sync Color Coding.”
• Excess luma: This overlay indicates whether the luma levels of your footage are
acceptable for broadcast. For more information, see “About Color Correction.”
• RGB, Alpha, or Alpha+RGB: When you’re compositing, it can sometimes be handy to
have a quick look at the alpha channel of your clip. The alpha channel defines areas
of transparency, and can change if various filters are applied. Viewing your sequence
with the Alpha or Alpha+RGB option selected shows you exactly which areas of your
image have transparency. Additional controls are available in the View menu for
viewing the individual Red, Green, and Blue channels. If the image display area in
the Viewer is all black or all white, it may be because the Canvas is set to view only
the alpha channel instead of the RGB channels. Try changing the channel view to
RGB to solve this problem.
• Black, White, Checkerboard: When working with clips that have an alpha channel, you
can choose different backgrounds to make it easier to see which areas of your picture
are transparent. For example, translucent clips or generated text may be more visible
if you choose a background that emphasizes them, such as Checkerboard 1 or 2. You
can also view Red, Green, and Blue background colors using the View menu.

Playhead Sync Pop-Up Menu
You can lock the Viewer playhead to the Canvas/Timeline playhead so that they move
together while scrubbing through clips.
Note: This menu also appears in the Canvas, and the options are the same.

Playhead Sync pop-up
menu in the Viewer
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The following playhead sync modes are available from the Playhead Sync pop-up menu:
• Sync Off: The Viewer and Canvas playheads move independently of each another. This
is the default behavior.
• Open: As the playhead moves through your sequence, the clip that appears at the
current position of the playhead is automatically opened in the Viewer. Playhead sync
between the Viewer and Canvas is maintained so the same frame is always open in
both windows. This method is useful when you need to quickly adjust filters for a
number of clips in a sequence, such as for color correction. Multiclip playback mode
also turns on this playhead sync mode, so you can view multiple camera angles in the
Viewer while you watch the active angle in the Canvas.
• Gang: This mode allows you to establish an arbitrary synchronization between the
Viewer and Canvas/Timeline playheads. Each time you choose this mode, the current
position of each playhead is used to set the sync relationship. For more information
on ganging, see “Matching Frames and Playhead Synchronization.”

Recent Clips and Generator Pop-Up Menus
The two pop-up menus near the lower-right corner of the Viewer let you quickly choose
source clips and generators.

Generator
pop-up menu
Recent Clips
pop-up menu
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Recent Clips Pop-Up Menu
This pop-up menu shows recently used clips. A clip is not added to this list when first
opened in the Viewer, only when another clip replaces it. The last clip that was replaced
in the Viewer appears at the top of the list. By default, the maximum number of clips that
appear in this list is ten, but you can change this number. For more information, see
“Choosing Settings and Preferences.”
The clip replaced most
recently is at the top of
the list.

Generator Pop-Up Menu
Use this pop-up menu to create a generator clip, such as bars and tone, text, black, a
color matte, or a gradient. A generator clip appears in the Viewer; you can then customize
it using the Controls tab. For more information, see “Using Generator Clips.”
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Canvas Basics

7

This chapter covers the following:
• How You Use the Canvas (p. 103)
• Opening, Selecting, and Closing Sequences in the Canvas (p. 104)
• Learning About the Canvas (p. 105)
• Editing Controls in the Canvas (p. 107)
• Transport Controls in the Canvas (p. 109)
• Playhead Controls in the Canvas (p. 110)
• Marking Controls in the Canvas (p. 112)
• Zoom and View Pop-Up Menus in the Canvas (p. 113)
• Playhead Sync Pop-Up Menu in the Canvas (p. 113)
The Canvas provides an environment for viewing your edited sequence, and works in
tandem with the Timeline while you edit.

How You Use the Canvas
In Final Cut Pro, the Canvas is the equivalent of a record monitor in a tape-to-tape editing
suite; it displays the video and audio of your edited sequence during playback.
When you open a new sequence, it appears simultaneously in tabs in both the Canvas
and the Timeline. The Canvas playhead mirrors the position of the Timeline playhead,
and the Canvas displays the frame at the playhead’s current position in an open sequence.
If you move the Timeline’s playhead, the frame displayed in the Canvas changes
accordingly. If you make a change in the Canvas, it’s reflected in the Timeline.
The controls in the Canvas are similar to those in the Viewer, but instead of navigating
and playing back individual clips, the controls in the Canvas navigate the entire sequence
currently open in the Timeline.
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Before you can work in the Canvas, it must be the currently selected, or active, window.
Otherwise, any commands or keyboard shortcuts you use may perform the wrong
operations. To display the Canvas, you must open a sequence from the Browser (see
“Opening, Selecting, and Closing Sequences in the Canvas” for more information).
Note: Most of the commands you use in the Canvas also work in the Timeline.
To make the Canvas window active
Do one of the following:

µ
µ
µ

Click the Canvas.
Press Command-2.
Press Q to switch between the Viewer and the Canvas.

Opening, Selecting, and Closing Sequences in the Canvas
Sequences are represented by tabs in the Canvas and Timeline. All controls and commands
in the Canvas affect only the sequence in the foreground.
To open a sequence in the Canvas
Do one of the following:

µ
µ

Select the sequence in the Browser, then choose View > Sequence in Editor.

µ
µ

Double-click a sequence in the Browser.

Control-click the sequence in the Browser, then choose Open Timeline from the shortcut
menu.
Select the sequence in the Browser, then press Return.
If you have more than one sequence open in the Canvas, the tab in front is the active
sequence.

µ

To make a sequence active in the Canvas
Click a sequence’s tab to bring it to the front.
To close a sequence in the Canvas
Do one of the following:

µ
µ
µ

Click a sequence’s tab to bring it to the front, then choose File > Close Tab.
Control-click the tab, then choose Close Tab from the shortcut menu.
Click a sequence’s tab to bring it to the front, then press Control-W.
When you close the tab of a sequence in the Canvas, its corresponding tab in the Timeline
also closes.
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Learning About the Canvas
The following is a summary of the controls in the Canvas.
Controls in the Top Part of the Canvas
The top part of the Canvas has the following controls.
Tab for the
open sequence
Timecode Duration field

Name of the currently
selected sequence
and the project it’s in

Current Timecode field
View pop-up menu
Playhead Sync
pop-up menu

Image display area

Zoom pop-up menu

• Tabs: Each tab in the Canvas represents an open sequence, and has a corresponding
tab in the Timeline.
• Timecode Duration field: This field shows the current duration between the sequence
In and Out points. You can change the duration here, which automatically adjusts the
sequence Out point.
• Zoom pop-up menu: This pop-up menu lets you enlarge or shrink the image that appears
in the Canvas. Choose a zoom level of 100 percent to see the image in full quality.
When you resize the window, you can also change the zoom level. However, when
resizing the window, it’s possible to resize the window to a zoom level that appears to
be 100 percent, but is actually slightly above or below 100 percent, displaying a less
than full-quality image. To ensure a full-quality display, choose 100 percent from the
Zoom pop-up menu. You can also assign the 100 percent zoom level to a custom
keyboard command and use it to quickly reset the zoom level to 100 percent.
• Playhead Sync pop-up menu: The Playhead Sync pop-up menu gives you options for
locking the movement of the playheads in the Viewer and the Canvas together in
different ways while scrubbing through clips. For more information, see “Matching
Frames and Playhead Synchronization.”
• View pop-up menu: This pop-up menu allows you to control display options such as
timecode and marker overlays, as well as the background color for transparent pixels.
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• Current Timecode field: This field displays the timecode of the frame at the current
position of the playhead. You can enter timecode numbers here to navigate to a new
position in your sequence.
• Image display area: This is the area of the Canvas where you can see the video from
your sequence play back.
Controls in the Bottom Part of the Canvas
The bottom part of the Canvas has the following controls.
Jog control
In point
Playhead

Out point

Scrubber bar

Shuttle control

Edit buttons

Transport
controls

Sequence marking
controls

• Jog and shuttle controls: These controls let you navigate more precisely within your
sequence.
• Editing controls: The edit buttons and the Edit Overlay allow you to perform different
kinds of edits when you add the clip in the Viewer to your sequence.
• In point and Out point: You can set sequence In and sequence Out points in the Canvas
or Timeline. You can use these as placement points to determine where clips are placed
in the Timeline destination tracks when you’re doing three-point editing. For more
information, see “Setting Edit Points for Clips and Sequences.”
• Playhead: The position of the playhead corresponds to the currently displayed frame.
You can move the playhead to go to different parts of a sequence.
• Transport controls: You use these controls to play a sequence and to move the playhead
within your sequence. The position of the playhead corresponds to the currently
displayed frame.
• Sequence marking controls: These controls are used to add sequence In and Out points,
markers, and keyframes.
• Scrubber bar: The scrubber bar represents the entire duration of a sequence. You can
click anywhere in the scrubber bar to automatically move the playhead to that location.
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Editing Controls in the Canvas
You can perform five basic types of edits in the Canvas to place a clip displayed in the
Viewer into the current sequence. The clip is placed in the Timeline according to the In
and Out points set in the clip and the sequence, following the rules of three-point editing.
The basic edit types are:
• Overwrite: Replaces the clip items in the destination sequence track with the clip in
the Viewer.
• Insert: Pushes clip items in the sequence forward to accommodate the clip from the
Viewer.
• Replace: Replaces the clip item beneath the Canvas/Timeline playhead with the clip in
the Viewer, using the playhead position in both windows as a synchronization point.
• Fit to Fill: Speeds up or slows down the clip in the Viewer to fit between the In and Out
points set in the Canvas and Timeline.
• Superimpose: Edits the clip in the Viewer into a track above the sequence clip that
intersects the playhead.
Variations of overwrite and insert edits, called overwrite with transition and insert with
transition, add the default transition when you perform the edit. This allows you to perform
transitions such as dissolves in a single move. These edits are covered in much more
detail in “Three-Point Editing.”
You can use the Canvas editing controls to perform edits. Once you’ve marked a clip in
the Viewer with In and Out points defining how much of that clip you want to use, you
can use the Edit Overlay or the edit buttons at the bottom of the Canvas to perform the
edit.
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Edit Overlay
The Edit Overlay appears only when you drag clips from the Browser or Viewer to the
image area of the Canvas. The Edit Overlay appears translucently over the image currently
in the Canvas.
Drag a clip to the
image display area
of the Canvas.

The Edit Overlay appears
with its seven sections.

There are seven sections in the Edit Overlay. If you simply drag your clip to the image
display area to the left of the Edit Overlay, an overwrite edit is performed. To perform any
of the other edits, drag your clip to the overlay area for the edit you wish to perform.
You’ll know that the clip you’re dragging is over a specific overlay when a colored outline
appears around the border of the overlay.

Edit Buttons in the Canvas
Instead of dragging clips to the Canvas, you can click one of the edit buttons to edit the
clip in the Viewer into your sequence. (You can also drag clips to the edit buttons to
perform the same edits.)

Insert

Click the disclosure
button to display the
additional edit buttons
(shown on the right).

Overwrite

Overwrite with Transition
Insert with Transition

Replace
Superimpose
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Transport Controls in the Canvas
Transport (or playback) controls let you play sequences in the Canvas, as well as move
the playhead in the Timeline. These controls play clips and sequences at 100 percent (or
1x) speed. There are keyboard shortcuts for each control.
Go to Previous Edit

Go to Next Edit
Play Around
Current Frame
Play
Play In to Out

Note: Similar controls also appear in the Viewer, Log and Capture, and Edit to Tape
windows.
• Play (Space bar): Plays your sequence from the current location of the playhead. Clicking
it again stops playback.
• Play In to Out (Shift-Vertical Bar): Moves the playhead to the current In point of a
sequence and plays forward from that point to the Out point.
• Play Around Current Frame (Backslash): Plays the selected sequence “around” the current
playhead position. When you click this button, playback begins before the playhead
position based on the value in the Preview Pre-roll field in the Editing tab of the User
Preferences window. Playback continues through the original position of the playhead,
and then continues for the amount of time specified in the Preview Post-roll field. When
you stop playback, the playhead jumps back to its original position. For more
information, see “Choosing Settings and Preferences.”
• Go to Previous Edit (Up Arrow) and Go to Next Edit (Down Arrow): These controls are
primarily used for quickly navigating from one edit point to the next in the Canvas. The
Go to Previous Edit and Go to Next Edit buttons move the playhead to the previous
and next edit points in the sequence, relative to the current playhead position. If you
have In and Out points set in your sequence, the Go to Previous Edit and Go to Next
Edit buttons navigate to these points as well.
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Playhead Controls in the Canvas
The Canvas provides a number of controls for moving the playhead in a sequence quickly
and easily.
Inactive video

Inactive video

Playhead

Scrubber bar

Jog control

Shuttle control

Playhead and Scrubber Bar in the Canvas
The playhead shows the location of the currently displayed frame within the current
sequence. The scrubber bar runs along the entire width of the Canvas, below the video
image. To scrub through a sequence, drag the playhead across the scrubber bar. You can
click anywhere in the scrubber bar to instantly move the playhead to that location.
The playhead’s movement in the scrubber bar is affected by whether “snapping” is turned
on. When snapping is on, the playhead “snaps,” or moves directly, to any markers, In
points, or Out points in the scrubber bar when it gets close to them. (To turn snapping
on or off, choose View > Snapping, or press the N key.)

µ

To move the playhead to the beginning of your sequence
Press Home on your keyboard.

µ

To move the playhead to the end of your sequence
Press End on your keyboard.
To move the playhead to the next edit point
Do one of the following:

µ
µ
µ

Choose Mark > Next > Edit (or press Shift-E).
Click the Go to Next Edit button.
Press the Down Arrow key.
Final Cut Pro looks for the next edit, In point, or Out point. If overlays are turned on in
the View menu, an L-shaped icon appears in the Canvas, indicating whether you are on
an In or Out point.
To move the playhead to the previous edit point
Do one of the following:

µ
µ
µ
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Choose Mark > Previous > Edit (or press Option-E).
Click the Go to Previous Edit button.
Press the Up Arrow key.
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Final Cut Pro looks for the previous edit, In point, or Out point. If overlays are turned on
in the View menu, an L-shaped icon appears in the Canvas, indicating whether you are
on an In or Out point.
To move the playhead to sequence markers
Do one of the following:

µ

Control-click in the Current Timecode field in either the Timeline or the Canvas, then
choose a marker from the shortcut menu.

µ
µ

Press Shift–Down Arrow to move to the next marker to the right of the playhead.
Press Shift–Up Arrow to move to the next marker to the left of the playhead.
The playhead moves to that marker. If overlays are turned on in the View menu, the
marker is displayed in the Canvas. For more information on setting markers in the Timeline,
see “Using Markers.”

Jog Control in the Canvas
To move forward or backward in your sequence very precisely, use the jog control. The
jog control allows you to move the playhead in the Canvas as if you were actually moving
it with your hand, with a one-to-one correspondence between the motion of your mouse
and the playhead’s motion. This control is useful for carefully locating a specific frame
(for instance, if you’re trimming an edit).

Shuttle Control in the Canvas
This control lets you quickly play through sequences at different speeds, in fast and slow
motion. It also shifts the pitch of audio as it plays at varying speeds. In slow motion, this
can make it easier to locate specific words and sounds for editing.
Drag the slider to the right to fast-forward and to the left to rewind. Playback speed varies
depending on the distance of the slider from the center of the control. When the slider
is green, playback speed is normal (or 100 percent speed). The further away from the
center you move, the faster the playback speed. The keyboard equivalents of the shuttle
control are the J, K, and L keys. For more information, see “Shuttling Through a Clip or
Sequence.”
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Marking Controls in the Canvas
Marking controls let you set In and Out points, add markers and keyframes, and navigate
to matching frames in master or affiliate clips. (This is called performing a match frame.)
There are keyboard shortcuts for each control.
Mark Clip

Show Match Frame
Mark In
Mark Out

Add Motion Keyframe
Add Marker

• Mark In (I): Click to set the In point at the current position of the playhead.
• Mark Out (O): Click to set the Out point at the current position of the playhead.
• Add Marker (M): Click to add a marker at the current playhead position. While editing,
you can use markers to make notes about important points in your sequence, such as
areas to change, potential edit points, or sync points. Markers can be added to sequences
in the Canvas and Timeline. For more information, see “Using Markers.”
Important: If a clip is selected in the Timeline, and the playhead touches that clip, a
marker is added to the sequence clip, not the sequence.
• Add Motion Keyframe (Control-K): Click to add a keyframe to the current clip at the
position of the playhead. This button adds keyframes for clip parameters such as Scale,
Rotate, Crop, Distort, and so on.
By default, this button sets keyframes for all motion parameters at once. To add
keyframes for individual motion parameters, Control-click this button and choose a
motion parameter from the shortcut menu. For more information, see “Adjusting
Parameters for Keyframed Effects.”
• Show Match Frame (F): When you click this button, the frame you see in the Canvas
appears in the Viewer. Specifically, the master clip for the sequence clip that intersects
the Canvas/Timeline playhead is opened in the Viewer. The Viewer playhead is set to
the frame shown in the Canvas, and the In and Out points for the sequence clip are
set in the master clip in the Viewer. This allows you to easily get back to the master
clip for any affiliate clip, in case you want to use the footage for another purpose, or if
you want to see the original video and audio clip items of the master clip. For a more
comprehensive discussion of the Match Frame controls, see “Matching Frames and
Playhead Synchronization.”
• Mark Clip (X): Click to set In and Out points at the boundaries of the clip that currently
intersects the Canvas/Timeline playhead. The clip on the lowest-numbered track with
Auto Select turned on is used.
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Zoom and View Pop-Up Menus in the Canvas
The two pop-up menus near the top of the Canvas let you quickly select the magnification
level and a viewing format to control the way media in the Canvas is displayed. These
menus are also present in the Viewer, and the options are the same. For details, see “Zoom
and View Pop-Up Menus in the Viewer” in the Viewer Basics chapter.

View pop-up menu

Zoom pop-up menu

Playhead Sync Pop-Up Menu in the Canvas
You can lock the Viewer playhead to the Canvas/Timeline playhead so that both playheads
move together while scrubbing through clips. This menu is also present in the Viewer,
and the options are the same. For details, see “Playhead Sync Pop-Up Menu in the Canvas.”
Playhead Sync pop-up
menu in the Canvas
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Navigating and Using Timecode in
the Viewer and Canvas

8

This chapter covers the following:
• Navigating in the Viewer and Canvas (p. 115)
• Working with Timecode in the Viewer and Canvas (p. 121)
While the Viewer and Canvas serve different purposes, navigating and working with
timecode are nearly the same in both windows.

Navigating in the Viewer and Canvas
Aside from using the transport controls, there are numerous ways to move around within
clips and sequences in Final Cut Pro. You can navigate more quickly using the specialized
jog and shuttle controls, moving through your media at slower or faster speeds. You can
also enter absolute or relative timecode values directly into timecode fields to move the
playhead within your clips and sequences. All of these methods work with external video
enabled, and external video output will be continuously updated.

How the Viewer and Canvas Are Different
Although the Viewer and Canvas windows are very similar in appearance and use many
of the same controls, the video displayed in the Canvas is not the same as that in the
Viewer. In the Viewer, you open and play clips in preparation for editing, while the Canvas
shows video from a sequence in the Timeline. You can think of the Viewer as the source
monitor and the Canvas as the record monitor from a traditional tape-to-tape editing
system.
For information about controls in the Viewer, see “Viewer Basics.” For information about
controls in the Canvas, see “Canvas Basics.”

Playing Clips and Sequences
You use the transport controls in the Viewer and Canvas to play forward, backward,
between In and Out points, one frame at a time, or loop playback. You can also move
around within clips and sequences by jogging, shuttling, and scrubbing, and by entering
timecode numbers.
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To play a clip in the Viewer or a sequence in the Canvas
1 Open a clip in the Viewer or make the Canvas or Timeline active.
2 Do one of the following:
• Choose Mark > Play > Forward (or press L).
• Click the Play button.
• Press the Space bar.
To stop playback, press the Space bar or click the Play button again.
You can navigate backward at 1x (normal) speed, for instance, if you want to search for
precise locations to set your In and Out points.
To play media in reverse
1 Open a clip in the Viewer or make the Canvas or Timeline active.
2 Do one of the following:
• Choose Mark > Play > Play Reverse (or press J).
• Shift-click the Play button.
• Press Shift-Space bar.
Once you set In and Out points for a clip to define what part you want to use in your
sequence, you may want to review the In and Out points. You can use the Play In to Out
feature so that playback starts precisely at the In point and stops at the Out point, to
make sure that the edit points are exact. This is useful if you’re editing dialogue and you
want to make sure you’re cutting on the proper sound at each of your edit points. You
may also want to use this feature if you’re matching action and want to make sure you’re
starting and ending at the right frames.
To play a clip or sequence between In and Out points
1 Open a clip in the Viewer or make the Canvas or Timeline active.
2 Do one of the following:
• Choose Mark > Play > In to Out, or press Shift-Backslash (\).
• Click the Play In to Out button.
If you want to preview how the cut you’ve made at the Out point will play, you can play
to the Out point. This is useful because it quickly shows you if you’ve left out a frame, or
if you need to shave off more frames. For example, if you’re editing dialogue, you can
make sure you cut out on the very last frame of a pause at the end of an “s” sound, while
leaving out an “i” sound that follows in the actor’s next sentence.
To play a clip from the current position of the playhead to the Out point
1 Open a clip in the Viewer or make the Canvas or Timeline active.
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2 Do one of the following:
• Choose Mark > Play > To Out (or press Shift-P).
• Command-click the Play button.
You can also play around the current playhead position. This is useful if you want to watch
the outgoing and incoming media around an edit point, perhaps to decide how you want
to trim one side or the other.
To play a clip around the current playhead position
1 Open a clip in the Viewer or make the Canvas or Timeline active.
2 Do one of the following:
• Choose Mark > Play > Around, or press Shift-Backslash (\).
• Click Play Around Current Frame.
Note: The amount of video played depends on the pre-roll and post-roll settings in the
Editing tab of the User Preferences window. For more information, see “Choosing Settings
and Preferences.”
You can also play every frame of a clip. This is useful for getting a preview of a clip or
sequence with effects applied, without rendering first. While the clip won’t play back at
1x (normal) speed (it plays back somewhat more slowly, depending on the number of
effects applied and on the data rate of the clip), every frame plays back, with no frames
dropped.
To play every frame of a clip
1 Open a clip in the Viewer or make the Canvas or Timeline active.
2 Choose Mark > Play > Every Frame, or press Option-Backslash (\) or Option-P.

Scrubbing, or Moving, Through a Clip or Sequence
The scrubber bar represents the entire duration of the clip that’s open in the Viewer and
the entire duration of a sequence that’s open in the Canvas. Dragging the playhead in
the scrubber bar lets you scrub through your clip or sequence, with a one-to-one
correspondence between the movement of your mouse and the playhead’s movement
through the clip or sequence.
This is the fastest way to move through a clip or sequence in order to find the point you
want. How quickly you can move through the clip or sequence depends on the duration
of the clip or sequence. In a short clip or sequence, moving the mouse a given distance
in the scrubber bar will move through less footage than in a clip or sequence of lengthy
duration.
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As you scrub through your clip or sequence, audio also plays back more quickly, but it
doesn’t play back smoothly—it will seem to stutter (not speed up) as individual audio
samples are skipped. This is normal. For smooth playback of audio at speeds under 1x,
use the shuttle control instead.

µ

To scrub through a clip or sequence
Drag the playhead along the scrubber bar.
To move around, drag
the playhead along the
scrubber bar.

You can also use the scrubber bar to jump to a different part of your clip or sequence
instantly, without playing all the footage between the previous location of the playhead
and the new location.

µ

To jump to a new location in the scrubber bar
Click the desired location in the scrubber bar.

Shuttling Through a Clip or Sequence
While using the scrubber bar is a great way to quickly navigate to different parts of your
clip or sequence, sometimes you want to play through your clip or sequence smoothly
at varying speeds as you make decisions about where to place your edit points. The
shuttle control gives you this kind of smooth control, playing back your video and audio
at various speeds in either direction, much as the shuttle of a video deck does.
In particular, the shuttle control is useful for playing back at less than 1x speed. As the
audio slows down, it’s sometimes easier to distinguish individual words, and to set your
In and Out points more accurately.
The shuttle control can play your clip or sequence at five speeds in each direction: 1/4x,
1/2x, 1x, 2x, and 4x. The shuttle control snaps to the closest available speed. When the
shuttle control is at 1x speed, or 100 percent, the slider turns green.

µ
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To play clips or sequences at varying speeds using the shuttle control
Drag the shuttle slider to the left or right.
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Dragging to the right moves the clip or sequence forward; dragging to the left moves
the clip or sequence in reverse. The farther you drag the slider from the center, the faster
the clip or sequence plays in that direction.

Drag to the right to play
forward; drag to the left
to play in reverse.

You can also use the J, K, and L keys on your keyboard to shuttle through your clip. When
you use the keyboard shortcuts, the only speed available under 1x is 1/3x. However, you
can use the keyboard commands to speed playback up to eight times normal speed,
faster than you can play back using the shuttle control.

Moves through
reverse speeds

Pause

Moves through
forward speeds

µ

To begin forward playback at normal (1x) speed
Press L.

µ

To begin reverse playback at normal (1x) speed
Press J.

µ

To pause playback
Press K.

µ

To double the current playback speed
Press L or J again.
You can play back up to eight times normal speed, switching from 1x to 2x to 4x to 8x
normal speed (pressing either key a total of four times).
Pressing the key for playback in the opposite direction halves the playback speed, slowing
playback in that direction down until it reaches 1x playback. Playback then begins doubling
in reverse, starting from 1x.

µ

To immediately reverse the playback direction
Press K to pause, then press the key for the direction you want.
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µ

To move the playhead one frame at a time
Hold down the K key, then press J or L.

µ

To move the playhead at below 1/3x speed
Hold down the K key, then press and hold down J or L.
Note: When using keyboard shortcuts for device control, the speed of forward (L) and
reverse (J) may differ depending on your video equipment.

Jogging Through a Clip or Sequence
To move through a clip or sequence more precisely, you can use the jog control. The jog
control offers a one-to-one correspondence between the mouse and the playhead’s
movement, but also provides frame-by-frame accuracy that’s not dependent on the
duration of the clip or sequence. It’s a good tool to use to play through a section of a clip
or sequence very slowly, looking for the right frame to cut on.

µ

To move forward or backward using the jog control
Drag the jog control to the left or to the right.
The playhead moves with a one-to-one correspondence to the movement of your mouse.
Moving your mouse slowly moves the playhead slowly, even frame by frame. Moving the
mouse faster moves the playhead faster. If you stop dragging, the playhead stops instantly.

To move precisely
through a clip, drag
the jog control.

You can also move the playhead one frame at a time or one second at a time, by using
the arrow keys on the keyboard.
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µ

To move forward one frame at a time
Press the Right Arrow key.

µ

To move back one frame at a time
Press the Left Arrow key.

µ

To move forward one second at a time
Press Shift while you press the Right Arrow key.

µ

To move backward one second at a time
Press Shift while you press the Left Arrow key.
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Looping Playback
Normally, playback of a clip or sequence starts at the current playhead position and stops
at the end of the clip or sequence. If you turn on looped playback, the clip or sequence
plays over and over again until you stop playback.
When looped playback is turned on:
• Using Play In to Out loops playback only between your two edit points.
• Playing in reverse loops playback from the end of your clip to the beginning.
• In all other playback modes, playback always starts over from the beginning of the clip.
Note: When you loop playback, there is a split-second pause at the end of your clip or
sequence before the next loop starts. For this reason, enabling looped playback to loop
a sequence during output to tape from the Canvas might not give you the results you
want. For more information on outputting to tape, see “Printing to Video and Output
from the Timeline.”

µ

To turn on looped playback
Choose View > Loop Playback (or press Control-L).
If it’s already turned on, you’ll see a checkmark next to the command in the menu.

µ

To turn off looped playback
Choose View > Loop Playback (or press Control-L) again, so that the checkmark next to
the menu item disappears.

Working with Timecode in the Viewer and Canvas
Two fields display timecode in the Viewer and Canvas: Timecode Duration and Current
Timecode.

Current Timecode field
in the Canvas
Timecode Duration field
in the Canvas

• Timecode Duration field: This field shows the current duration between the clip In and
Out points. You can change the duration here, which automatically adjusts the clip Out
point.
• Current Timecode field: This field displays the timecode of the frame at the current
position of the playhead. You can enter absolute or relative timecode numbers here
to navigate to a new position in the clip.
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Note: Clicking the icon to the left of each field highlights the entire field so you can enter
new numbers.
Control-clicking the Timecode Duration and Current Timecode fields displays a shortcut
menu that lets you select the following timecode display options:
• Non-drop frame timecode, drop frame timecode, feet+frames, or frames: The menu item
in boldface indicates the type of timecode currently specified in that sequence’s settings.
Changing the timecode display in the Canvas does not alter that sequence’s settings.
Drop frame timecode is only available for clips with a frame rate of 29.97 fps. PAL clips
do not have drop frame timecode display as an option. The feet+frames option is useful
when you are editing a film project.
For more information on timecode, see “Working with Timecode.” For more information
about editing film, see the documentation that came with Cinema Tools.

Navigating with Timecode in the Viewer and Canvas
You can move the playhead around in a clip or sequence by entering a new timecode
number in the Current Timecode field.
• To move to a particular frame in your clip or sequence, enter a complete (or absolute)
timecode number.
• To move the playhead forward or backward a precise number of hours, minutes, seconds,
and frames from the current position, enter a relative number.
• To move the playhead relative to its current position, type a minus sign (-) or a plus
sign (+) and the timecode value outside the Current Timecode field. (To type a minus
sign, press Hyphen or press the Minus Sign key on the numeric keypad. To type a plus
sign, press Shift-Plus Sign or press the Plus Sign key on the numeric keypad.
To avoid typing zeroes when moving by larger amounts, use one of the following
characters instead: period, comma, plus sign, minus sign, colon, semicolon, and ampersand.
For example:
• To move to timecode 00:00:03:00, type “3.” (3 and a period). The period is automatically
interpreted by Final Cut Pro as 00 in the frames field.
• To move to 00:03:00:00 from the previous position, type “3..” (3 and two periods). These
periods insert 00 into both the frames and seconds fields.
• Type “3...” to move to 03:00:00:00.
You can also enter values in the Timecode Duration field to adjust the duration of a clip.
To move the playhead in a clip or sequence by entering a value in the Current Timecode
field
1 Do one of the following:
• Double-click a clip to open it in the Viewer.

122

Chapter 8 Navigating and Using Timecode in the Viewer and Canvas

• Make the Canvas active.
2 Click the Current Timecode field (or the icon to the left of it) to highlight the field.
3 Enter a new timecode value, then press Return.
Instead of moving the playhead to an absolute timecode number, you can move it relative
to its current position by pressing the + and - keys. For example, to move the playhead
15 frames forward from the current position, type “+15”. To move the playhead 1 minute
and 20 frames back from the current position, type “-01.20” (the period automatically
adds 00 to the seconds field).

µ

To move the playhead forward relative to its current position
Enter + (plus), then a timecode value.

µ

To move the playhead back
Enter - (minus), then a timecode value.
For example, if you type +1612, the playhead moves ahead 16 seconds and 12 frames.
To move the playhead back by 16 seconds and 12 frames, you would type -1612. To move
back 5 minutes, 20 seconds, and 10 frames, you would type -52010.

To move the playhead by typing outside the Current Timecode field
1 Do one of the following:
• Double-click a clip to open it in the Viewer.
• Make the Canvas active.
2 Type a new timecode value, then press Return.
Even though the Current Timecode field isn’t selected, the timecode value you type
appears in this field. The playhead moves to the location of the new timecode value, and
the new timecode value is shown in the Current Timecode field.
For more information about timecode, see “Working with Timecode.”

Dragging Timecode Values
You can drag timecode values from one timecode field to another, or from columns in
the Browser to timecode fields in the Log and Capture window. This can be especially
helpful for quickly relogging a clip when you want to change its In or Out point in the
Log and Capture window. For more information, see “Logging from Tape.”

µ

To drag a timecode value from one field to another
Hold down the Option key while you drag a timecode value from a timecode field or
column in the Browser to any other timecode field.
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About Timecode Overlays and Sync Color Coding
In the Viewer, timecode overlays display the source timecode for each clip item. In the
Canvas, timecode overlays provide a powerful way to see the sync relationship between
clip items stacked in multiple tracks. You can see the source timecode track of each clip
item in each track at the current playhead position.
Timecode overlays, like other overlays, don’t appear during playback; you’ll only see
overlays when playback is paused. You can turn timecode overlays on and off
independently in the Viewer and the Canvas.
Timecode overlays are useful in a variety of situations:
• When matching video clips with audio clips that were recorded on separate devices
but with identical timecode, you can use timecode overlays to make sure that both
clips are numerically in sync.
• When you’re searching for a range of media that a client has requested by timecode
numbers, timecode overlays can help you quickly find what you’re looking for.
• If you’re performing complex trimming operations, being able to see the timecode as
you move the playhead in the Timeline can help you figure out the durations and
offsets you need to trim with.
• Timecode overlays can also help you spot-check your sequence when you’re preparing
for EDL (Edit Decision List) output.
Viewing Timecode Overlays
Timecode overlay display is overridden by the Show Overlays command in the View
menu. If you turn on timecode overlays and then turn off Show Overlays (so there is no
checkmark next to it in the View menu), this also turns off the timecode overlays.
To view timecode overlays
1 Make the Viewer, Canvas, or Timeline active, depending on where you want to see the
timecode overlays.
Note: Overlays in the Viewer can be set independently from those in the Canvas.
2 Choose View > Show Overlays, so there’s a checkmark next to it.
3 Choose View > Show Timecode Overlays (or press Option-Z).
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Information Displayed by Timecode Overlays
Timecode overlays give you an “at-a-glance” view of a wide variety of information about
your clip in the Viewer or sequence in the Timeline.
Shows timecode for the
In point of the current
clip or sequence.

Shows timecode for the
Out point of the current clip
or sequence.
Timecode numbers for audio
clip items at the position of
the playhead
Items that are in sync are color
coded with the same color.

Timecode numbers for
the video clip items at the
position of the playhead

• Timecode numbers of In and Out points: These appear in the upper-left and upper-right
corners of the Canvas and Viewer. If one or both of these have not been set, these
values display Not Set. In the Viewer, clip In and Out points are shown. In the Canvas,
sequence In and Out points are shown.
• Video and audio timecode numbers: In the center of the Canvas and Viewer are lists of
timecode numbers for every clip item that intersects the current position of the
playhead. The column on the left shows video and the column on the right displays
audio. Video and audio tracks start with the display of track 1.
• Video timecode numbers are preceded by V and the number of the video track.
• Audio timecode numbers are preceded by A and the number of the audio track.
Depending on the size of the window, not all tracks may be displayed. If Final Cut Pro
cannot fit all the tracks in the window, a “+” (plus) indicates that there are more clip
items whose timecode numbers aren’t displayed in the overlay.
• Color-coding of clip items in sync: Clip items’ timecode overlays are color-coded to
indicate which ones are in sync. There are 12 colors used to indicate distinct groups of
synced clip items. Whenever clip items are in sync, their listed timecode values are
highlighted with the same color. If a clip item is not in sync with any other item, it is
displayed in the standard gray timecode overlay color.
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For example, if the clip items on tracks V1, A1, and A2 all refer to the same media file,
and they all have the same timecode number at the current playhead position, the
timecode overlays for these tracks are displayed with the same color.
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Timeline Basics

9

This chapter covers the following:
• How You Use the Timeline (p. 127)
• Opening and Closing Sequences in the Timeline (p. 129)
• Learning About the Timeline (p. 130)
• Changing Timeline Display Options (p. 141)
• Navigating in the Timeline (p. 149)
• Zooming and Scrolling in the Timeline (p. 151)
The Timeline shows a graphical representation of your edited sequence, with all of that
sequence’s clips laid out in chronological order.

How You Use the Timeline
The Timeline and the Canvas display two different views of the same sequence. The
Timeline shows the chronological arrangement of clips and layered video and audio clip
items, while the Canvas provides a single view that allows you to watch your sequence
just as it will appear on a movie or television screen.
The Timeline, like the Canvas, contains tabs for all open sequences. Each sequence in the
Timeline is organized into separate video and audio tracks, which contain clip items
you’ve edited into the sequence from the Browser. Using the Timeline, you can quickly
navigate through an entire edited sequence, adding, overwriting, rearranging, and
removing clip items.
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The Timeline window below shows several items in the Timeline.
Sequence tab
Current Timecode field
In point

Playhead

Out point

This image shows the same items as they appear in the Canvas.
Sequence tab
Current Timecode field

Playhead
Out point

In point

Since the playhead in the Timeline mirrors the playhead in the Canvas, you can use the
navigation, marking, and editing controls in the Canvas to navigate in the Timeline, and
vice versa.
To make the Timeline window active
Do one of the following:

µ
µ

Click in the Timeline window.
Press Command-3.
Note: To work in the Timeline, the first thing you have to do is open a sequence. If you
don’t have any sequences in your project, you need to create one. For more information,
see “Working with Projects, Clips, and Sequences.”
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Opening and Closing Sequences in the Timeline
In the Timeline and Canvas, tabs represent sequences. Opening a sequence opens the
Timeline and the Canvas windows simultaneously (if they’re not open already). If the
Timeline and Canvas are already open, a newly opened sequence appears in its own tab
on top of any other sequence tabs.
To open a sequence in the Timeline and Canvas
Do one of the following:

µ
µ

Select the sequence in the Browser, then choose View > Sequence in Editor.

µ
µ

Double-click a sequence in the Browser.

Control-click the sequence in the Browser, then choose Open Timeline from the shortcut
menu.
Select the sequence in the Browser, then press Return.
The sequence opens in the Timeline and Canvas windows.

µ

To select a sequence in the Timeline
Click the sequence’s tab.
To close a sequence in the Timeline
Do one of the following:

µ

With the sequence’s tab selected in the Timeline, choose File > Close Tab (or press
Control-W).

µ

Control-click the sequence’s tab, then choose Close Tab from the shortcut menu.
When you close a sequence’s tab in the Timeline, the corresponding tab in the Canvas
closes, and vice versa. Closing the Canvas window closes the Timeline window. However,
closing the Timeline window by pressing Command-W does not close the Canvas window.
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Learning About the Timeline
You can view the content of your sequences in many different ways in the Timeline. Track
height, clip opacity and audio level overlays, keyframes, and many other sequence
properties can be displayed and edited in the Timeline. Each sequence has its own unique
display settings; changing the zoom setting or audio controls in one sequence doesn’t
affect another.
Each tab represents
a sequence.

Editing controls

Keyframe and
track controls

Vertical multitrack
controls

Horizontal time
controls

Sequence Tabs in the Timeline
Each tab in the Timeline represents a sequence. You can have multiple sequences open
simultaneously, each with its own tab. Controls in Final Cut Pro affect only the sequence
whose tab is in front. Clicking another sequence’s tab brings it to the front, along with
that sequence’s tab in the Canvas.
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Editing Controls
The Timeline editing controls determine which tracks are selected and turned on for
editing and playback.
Track Visibility control
Destination control

Lock Track control
Auto Select control
Source control

Locked tracks are
cross-hatched.

• Source and Destination controls: These allow you to connect (or patch) clip items of the
source clip in the Viewer to tracks in the Timeline. These controls are primarily used in
three-point editing to determine which source clip items’ tracks are edited into your
sequence, and where they are placed.
The number of available Source controls corresponds to the number of clip items of
the source clip currently open in the Viewer. For example, a typical DV clip has one
video track and two audio tracks. In this case, one video and two audio Source controls
appear in the Timeline. If, instead, you open a clip in the Viewer that has one video
item and four audio items, then one video and four audio Source controls appear in
the Timeline. For more information, see “Three-Point Editing.”
• Track Visibility control: Determines whether the contents of a track are displayed and
rendered in your sequence. When a track is disabled, it appears darkened in the Timeline,
but its contents remain in your sequence and can still be edited. When you play back
your sequence, disabled tracks don’t appear in the Canvas or on an external monitor,
nor will they be rendered or output to tape with that sequence.
Note: Render files for a track are deleted if the track is disabled. You can have
Final Cut Pro display a warning before this occurs by selecting the “Warn if visibility
change deletes render file” option in the Editing tab of the User Preferences window.
For more information, see “Choosing Settings and Preferences.”
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• Lock Track control: Prevents a track’s contents from being moved or changed in any
way. Overlays in locked tracks can also be protected by deselecting the “Pen tools can
edit locked item overlays” option in the Editing tab of the User Preferences window.
Locked tracks are cross-hatched all the way across the Timeline. Tracks can be locked
and unlocked at any time. For more information, see “Choosing Settings and
Preferences.”
• Auto Select control: Enabling the Auto Select controls of specific tracks in the Timeline
limits which tracks are affected by various functions such as copying, pasting, deleting,
the Match Frame command, and so on.
Note: You can think of In and Out points as limiting your edits in the horizontal (time)
dimension and Auto Select as limiting your edits in the vertical dimension.

Vertical Multitrack Controls
The following controls and areas affect vertically working with the tracks.
• Tracks: The main portion of the Timeline is divided into audio and video tracks, with a
divider between the two regions. You can drag the divider up or down to allocate more
room to either the video or audio half of the Timeline. Audio tracks 1 and 2 are just
underneath the divider, and all additional audio tracks continue downward. Video track
1 is just above the divider, and all additional video tracks continue upward. For more
information, see “Working with Tracks in the Timeline.”
You can change the default number of video and audio tracks in the Timeline Options
tab of the User Preferences window. For more information, see “Choosing Settings and
Preferences.”
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More tracks can be added at any time. Additional audio tracks can be used for adding
music or sound effects, or for organizational purposes. Additional video tracks can be
used for superimposing clips and compositing layers of video clips together.
Each tab represents
a sequence.

Video tracks
Divider

Audio tracks

Thumb tab
Vertical scroll bar
The unused area
provides space
to accommodate
new tracks.
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• Unused area: This is the area either above or below the outermost video and audio
tracks in your sequence. Ordinarily, this area is blank, but if you drag clips directly into
this gray area, new tracks are created to accommodate them.
• Vertical scroll bars and thumb tabs: If you have more tracks than can be displayed in
the Timeline window at one time, the scroll bars let you scroll through your video and
audio tracks separately. The thumb tabs between the audio and video track regions
can be used to define a static area that contains separate groups of audio or video
tracks with their own scroll bars.
This can come in handy when you have considerably more audio tracks than video.
You can use the thumb tabs between your audio and video scroll bars to allocate more
space to your audio tracks and less for video. For more information about creating a
static area, see “Working with Tracks in the Timeline.”

Horizontal Time Controls
The following controls and areas affect horizontally working with the tracks.
• Ruler: The ruler along the top of the Timeline represents the total duration of your
edited sequence, from the first frame to the last. The ruler can be used for reference,
to see the timecode corresponding to the location of clips in the Timeline. You can
choose to view the ruler with several different units: timecode, frames, or feet and
frames (for editing footage that originated on film).
You can also click or drag the playhead in the ruler, which works exactly like the scrubber
bar in the Canvas.
Sequences can be a maximum of twelve hours (with a sample rate of 48 kHz or lower),
or six hours (with a sample rate of 96 kHz).
Playhead

Ruler

• Playhead: The playhead displays the current frame location in a sequence. You can also
use the playhead to navigate through your sequence in the Timeline. For more
information, see “Navigating in the Timeline.”
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• Current Timecode field: Indicates the timecode position of the playhead. Typing a new
timecode number moves the playhead (as in the Viewer and Canvas).

Current Timecode field

• Zoom control: Lets you zoom in and out of the contents of your sequence in the
Timeline. Zooming in shows more detail in the ruler, and the duration between the
numbers in the ruler shrinks. Zooming out shows less detail in the ruler, but allows you
to see more of the total duration of your sequence in the Timeline. If the playhead is
visible, it stays centered when you use the Zoom control to zoom in on the Timeline.
If the playhead is not visible, the Zoom control centers the current contents of the
Timeline window instead.

Zoom control

Using the zoom keyboard shortcuts produces slightly different results. Pressing
Option-Equal Sign (=) or Option-Hyphen (-) zooms in or out of the contents of the
Timeline no matter which window in Final Cut Pro is currently active. If one or more
clips are selected, they will be the center of the zoom. Otherwise, zooming centers on
the current position of the playhead.
Note: If you want to zoom in and out around the current playhead, make sure no clips
are selected in the Timeline.
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• Zoom slider: Like the Zoom control, the Zoom slider allows you to zoom in and out of
a sequence in the Timeline. Dragging the thumb tabs on either side of the slider adjusts
both thumb tabs and leaves the visible area of the Timeline centered.

Drag the slider to scroll
through your sequence.

Pressing the Shift key and dragging one of the thumb tabs locks the opposite thumb
tab and moves the visible area of the Timeline in the direction you’re dragging. The
light gray indicators inside the scroll bar indicate one-minute increments in your
sequence, and widen or narrow depending on how far into your sequence you’ve
zoomed.
Once you’ve zoomed in to your sequence, you can scroll along the entire duration of
the sequence by dragging the center of the zoom slider.

Timeline Display Controls
There are several controls in the Timeline that can change how items in the Timeline are
displayed. For more information on these controls, see “Changing Timeline Display
Options.”
Clip Keyframes control
Track Layout
pop-up menu
Clip Overlays
control
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controls
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Audio Controls
The following controls affect vertically working with audio in the tracks.

Solo control
Mute control

Audio Controls button

• Audio Controls button: Click to display the mute and solo buttons to the left of each
audio track in the Timeline. By default, these controls are hidden.
• Mute and solo controls: Use to turn on or turn off audio playback on individual tracks
for monitoring purposes. The track strips in the Audio Mixer have corresponding mute
and solo buttons that work the same way. For more information, see “Overview of the
Audio Mixer.”
• Mute: Click to turn off audio playback for that track. The mute button affects
monitoring during playback only. Muting a track does not delete panning or audio
level keyframes for the clip items in that track, nor does it prevent fader automation.
• Solo: Click to listen only to an individual track. When you solo a track, all others are
muted except other tracks already soloed. For example, if you click the solo button
on track A1, and it’s the only track with solo selected, all other audio tracks are muted.
If you turn on the solo button on multiple tracks, all tracks with solo turned on play
back, while all other tracks are muted.
Note: Mute and solo controls affect only playback in the Timeline. They do not suspend
audio output during Print to Tape or Edit to Tape operations, or when exporting to a
movie or audio file.
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Other Miscellaneous Controls
Following are other controls within the Timeline.
Linked Selection button

Snapping button

• Snapping button: Click to turn snapping on and off. This button appears in the Timeline
button bar by default. When snapping is on, the playhead “snaps to” key areas in the
Timeline, such as the boundaries of other clip items, sequence markers, and sequence
In and Out points. This can be extremely useful when you need to quickly line up two
clips without gaps in between, or to quickly move the playhead to a marker in
preparation for an edit. You can also turn snapping on and off by choosing View >
Snapping (or by pressing N).
• Linked Selection button: Click this to turn linked selection on and off. With linked selection
on, clicking a video or audio clip item selects all other items linked to that item. If linked
selection is off, only the clip item you click is selected, even if it is linked to other items.
This is useful for editing the audio In or Out point of a clip separately from the video,
such as when doing a split edit. You can also turn linked selection on and off by choosing
Edit > Linked Selection (or by pressing Shift-L). For more information, see “Linking and
Editing Video and Audio in Sync.”
• Link indicators (within clip items): The names of linked video and audio clip items are
underlined. As long as linked selection is on, when one linked item is selected, moved,
or trimmed, all other items linked to it are affected identically.
• Labels (within clip items): If any clip items in your edited sequence in the Timeline have
been labeled, their names are highlighted in the color that matches that label. You can
choose whether clip labels are displayed in the Timeline by selecting the Show Clip
Labels option in the Track Layout pop-up menu.
• Speed indicator (within clip items): If the speed of a clip has been changed, either by
using a fit to fill edit or using the Speed item in the Modify menu, its change of speed
will be shown in parentheses after the name of the clip in the Timeline. If variable speed
has been applied, the word “Variable” appears instead.
Tip: Optional speed indicators can be displayed in the keyframe graph area to show
you the speed of clips in your sequence using tick marks. For more information on clip
keyframes, see “Changing Motion Parameters.” You can also refer to “Adjusting
Parameters for Keyframed Effects.” The spacing and color of these tick marks indicate
the speed and playback direction of your clips. For more information, see “Changing
Clip Speed.”
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• Stereo pair indicators (within clip items): Two pairs of triangles indicate that two audio
clip items are linked as a stereo pair. If you select an audio clip item that is part of a
stereo pair, the other clip item in the pair is also selected. This is useful when you are
working with stereo audio clips such as music or sound effects. For more information,
see “Audio Editing Basics.”

Speed change is shown
as a percentage.

Stereo pair indicator

Real-Time Effects and the Render Status Bar
Following are the Timeline’s real-time and render items.
• RT pop-up menu: Allows you to adjust the playback quality of real-time effects in
Final Cut Pro. Using the options in this menu, you can decide which is more important
to you—visual playback quality, or maximizing the available effects that can be played
back in real time. For more information on the options in the Real Time Effects pop-up
menu, see “Using RT Extreme.”

RT pop-up menu
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• Render status bar: This bar at the top of the Timeline indicates which parts of the
sequence have been rendered at the current render quality. The top line is for video,
the bottom for audio.
• Video render bar (upper region): Indicates the presence and render status of video
effects items.
• Audio render bar (lower region): Indicates the presence and render status of audio
effects items. Colors in the render bar above items indicate whether the items need
to be rendered. Items that don’t need to be rendered have dark gray bars above
them. For more information, see “Using RT Extreme.” You can also refer to “Rendering
and Video Processing Settings.”
The upper area indicates
the render status of
video items.

The lower area indicates
the render status of
audio items.

• Clip item render bars: Audio clip items can be rendered individually. Clip items in the
Timeline display individual render bars in the following cases:
• Audio clip items that require sample rate conversion: For example, audio clips that were
captured at 44.1 kHz but have been edited into a sequence set to 48 kHz.
• Audio clip items with filters applied: Applying one or more filters causes an audio clip
to display a render bar within the clip item itself.
For more information about clip item render bars, see “Rendering and Video Processing
Settings.”

Sequence Clips in the Timeline
Clip items in a sequence are often called sequence clips, with the item’s name displayed
at the head of the clip. If the clip item is long enough, the name is also displayed at the
end.
You can choose whether video clip items in the Timeline display thumbnails, and whether
audio clip items display audio waveforms. These options are available in the Timeline
options tab of the Sequence Settings window. (For more information, see “Sequence
Settings and Presets.”)
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Clip items can be linked so that they can be selected and edited together. This allows
you to keep clip items that came from the same Browser clip together, such as a video
clip item and a stereo pair of audio clip items. When you select a linked clip item, all the
other linked clip items are selected as well (unless the Linked Selection button is disabled).
For more information about working with linked items, see “Linking and Editing Video
and Audio in Sync.”

Changing Timeline Display Options
The default Timeline display options for new sequences are defined in the Timeline
Options tab of the User Preferences window. (For more information, see “Choosing Settings
and Preferences.”)
You can change Timeline display options for existing sequences in several places:
• Timeline Options tab of the Sequence Settings window: This tab shows all the options
available for displaying items in the Timeline. For more information, see “About Timeline
Display Options in the Sequence Settings Window.”
• Timeline display controls: These controls include the Clip Keyframes, Clip Overlays, and
Track Height controls. For more information, see “About Timeline Display Controls in
the Timeline.”
• Track layout pop-up menu: You can use this pop-up menu to change some Timeline
display options, as well as save, choose, or restore custom track layouts. For more
information, see “Timeline Display Options in the Track Layout Pop-Up Menu.”

Click here to view
the Track Layout
pop-up menu.

Track Layout
pop-up menu

About Timeline Display Options in the Sequence Settings Window
You can access almost all of the Timeline display options in the Timeline Options tab of
the Sequence Settings window. Exceptions and alternate ways of accessing the same
options are noted when possible.
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µ

To change Timeline display options in the Sequence Settings window
Select a sequence in the Browser or Timeline, choose Sequence > Sequence Settings,
then click the Timeline Options tab.

Settings in the Timeline
Options tab

General Options
These are basic display options you can change at any time. Several options, such as the
default number of video and audio tracks, are only available in the Timeline Options tab
of the User Preferences window, because these options only affect default settings for
new sequences.
• Starting Timecode: This sets the starting timecode number in the Timeline for new
sequences.
• Drop Frame: Select this option to display drop frame timecode in the Timeline (this
only applies to NTSC format video that has a frame rate of 30 fps). For more information
on drop frame and non-drop frame timecode, see “Working with Timecode.”
• Track Size: Choose a track size to set the vertical height of tracks in the Timeline. (You
can also use the Track Height controls in the Timeline.)
• Thumbnail Display: Choose how the thumbnails appear in the Timeline.
• Name: Displays only the name of the clip without thumbnail images.
• Name Plus Thumbnail: Displays the video frame at the In point of the clip and the
clip name.
• Filmstrip: Displays as many thumbnail images as possible for the current zoom level
of the Timeline.
• Audio Track Labels: Choose whether audio tracks are labeled as individual audio tracks
(A1, A2, A3, and so on) or as members of a pair (A1a and A1b, A2a and A2b, and so on).
For more information, see “Audio Editing Basics.”
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Track Display
The Track Display settings allow you to customize many aspects of how tracks appear in
the Timeline.
• Show Keyframe Overlays: Select this option to display opacity overlays (thin black lines)
over your video tracks, and audio level overlays (thin red lines) over any clips in the
audio tracks of the Timeline. These lines indicate video transparency or audio levels.
For more information, see “Adjusting Parameters for Keyframed Effects.”
You can also use the Clip Overlays control in the Timeline to show or hide overlays.
• Show Audio Waveforms: Select this option to display audio waveforms superimposed
over audio clips in the Timeline. You can also switch audio waveforms by pressing
Option-Command-W. This option is also available in the Track Layout pop-up menu in
the Timeline.

Audio waveform

Without audio
waveform
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• Show Through Edits: A through edit is an edit composed of two adjacent frames that
have the same reel number and subsequent timecode numbers. For example, if you
use the Razor Blade tool to cut a clip in half, that edit point is considered a through
edit. Select this option to display through edit indicators—two red triangles—where
they exist. This may help you discover unnecessary edit points in your sequence, which
you can then delete. This option is also available in the Track Layout pop-up menu in
the Timeline. For more information, see “Cutting Clips and Adjusting Durations.”

Through edit
indicator

• Show Duplicate Frames: Select this option to display frames that are used in your
sequence more than once. When duplicate frames are displayed and you select a clip,
you can see a list of all clips that contain the same frames as the selected clip. For more
information about working with duplicate frame indicators, see “Options for Displaying
Duplicate Frames.” You can also select this option from the Track Layout pop-up menu
in the Timeline.
• Show Audio Controls: Select this option to display the mute and solo buttons to the
left of each audio track in the Timeline. You can also use the Audio controls button in
the Timeline. For more information, see “Audio Controls.”
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Clip Keyframes
You can click the Clip Keyframes control to display the keyframe graph area—additional
space below each video and audio track in which to view and edit keyframes for effects
that are applied to your clips.
A green bar indicates
a filter has been applied
to the clip.

A blue bar indicates
a clip’s motion settings
have been altered.

Motion bar and motion
keyframe indicated by
a blue diamond
Keyframe editor

Clip Keyframes control

The spacing and color of the tick
marks indicate the speed and
direction of the clip’s playback.

This area can be divided into four optional regions showing keyframes and parameters
for motion effects, video filters, and audio filters applied to your clips. For more information
about customizing and using the keyframe graph area, see “Changing Motion Parameters.”
You can also see “Adjusting Parameters for Keyframed Effects.”
• Filters bar: If a clip has one or more video or audio filters applied, a green bar appears
in this space for the duration of that clip. If keyframes are added to a filter in a given
clip, those keyframes appear as diamonds on this bar, where they can be edited or
moved using the Selection tool.
• Motion bar: If a clip’s motion settings are modified, a blue bar appears in this space for
the duration of that clip. If keyframes are added to the motion settings for a given clip,
those keyframes appear as diamonds on the bar to which they apply, where they can
be edited or moved using the Selection tool. This bar is only available for video tracks.
• Keyframe editor: The keyframe editor shows you keyframe graph lines for motion or
filter parameters. These graphs are identical to those found in the keyframe graph area
of the Motion and Filters tabs in the Viewer. You can edit keyframes in the keyframe
editor using the Selection and Pen tools. The keyframe editor can only display the
keyframe graph line of one effect parameter at a time.
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• Speed indicators: Speed indicators show you the speed of clips in your sequence using
tick marks. The spacing and color of these tick marks indicate the speed and playback
direction of your clips. The speed indicators of clips in the Timeline update in real time
as you make variable speed adjustments to clips in your sequence, showing you exactly
how you’re altering a clip’s timing. For more information about viewing speed indicators
while making speed changes to clips in a sequence, see “Changing Clip Speed.”

About Timeline Display Controls in the Timeline
Several controls in the Timeline allow you to change the display of certain items in the
Timeline.
Clip Keyframes control

Clip Overlays
control

Track Height
controls

• Clip Keyframes control: Click this button to display the keyframe graph area—additional
space below each video and audio track in which to view and edit keyframes for effects
that are applied to your clips.
• Clip Overlays control: Click this control to display opacity overlays (thin black lines) over
your video tracks, and audio level overlays (thin red lines) over any clips in the audio
tracks of the Timeline. These lines indicate video transparency or audio levels.
• Track Height control: Use this control to switch between four track display
sizes—Reduced, Small, Medium, and Large. The current setting is highlighted in blue
and has a small dot in the center. Choosing a track height with this control resets all
tracks to the new size, overriding any custom track heights previously selected. To
preserve the relative heights of individually sized tracks while resizing all tracks, hold
down the Option key while choosing a new height with this control.
Note: When the track size is set to Reduced, neither audio waveforms nor thumbnails
are displayed.

Timeline Display Options in the Track Layout Pop-Up Menu
You can use the Track Layout pop-up menu in the Timeline to change some Timeline
display options, including:
• Track height
• Video filmstrips
• Audio waveforms
• Through edits
• Duplicate frames
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• Clip labels
This pop-up menu also allows you to save, choose, or restore custom track layouts. This
menu can hold up to 40 custom track layouts.

µ

To change Timeline display options using the Track Layout pop-up menu
Click the triangle to the right of the Track Height control, then choose an option from
the pop-up menu.

Click here to view
the Track Layout
pop-up menu.

Track Layout
pop-up menu

Options for Displaying Duplicate Frames
Indicating duplicate frames is useful primarily for movies you plan to finish on film (using
Cinema Tools) or that will be edited online in a tape-to-tape edit suite. In both instances,
it’s important to know if the same frames are being used in more than one place in the
Timeline because special measures must be taken to create these duplicate frames later.
If you can see where there are duplicate frames in advance, you can reedit your sequence
to eliminate the duplicates, if necessary.
If you use a clip more than once within a single edited sequence, the duplicated frames
are marked by the duplicate frames indicator, a colored bar appearing at the bottom of
the clip’s video item in the Timeline.

Duplicate frames
indicator
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Each separate instance of duplicated frames is color-coded differently. There are six
different colors used to indicate separate sets of duplicated frames: red, green, blue, white,
black, and purple. If there are more than six sets of duplicate frames in your sequence,
these colors are reused. In the following example, the first clip is duplicated once, as
indicated by the red duplicate frames indicator. The second clip is also duplicated once,
as indicated by the green duplicate frames indicator.

Different colors indicate
different sets of
duplicated frames.

Note: If a duplicated instance of a clip has variable speed applied to it, no duplicate frames
indicators appear.
You can adjust the parameters that determine when duplicate frames indicators appear
in the Editing tab of User Preferences. For more information, see “Choosing Settings and
Preferences.”
You can turn on or turn off duplicate frames indicators altogether by selecting Show
Duplicate Frames in the Timeline Options tab of the Sequence Settings window. For more
information, see “Sequence Settings and Presets.”
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You can Control-click a clip with duplicate frames to see a shortcut menu with the Dupe
Frames option. Choose this option to see a list of all clips that contain duplicates of the
frames in the selected clip. Each item in this list contains the number of duplicated frames,
the timecode value of the first duplicated frame, and the name of the clip that contains
the duplicates. When you select an item in this list, the playhead moves to the first
duplicated frame in the clip that corresponds to that item.

Navigating in the Timeline
There are several ways you can navigate through your sequence in the Timeline:
• Move the playhead by clicking or dragging in the ruler at the top of the Timeline
window.
Note: The playhead in the Timeline is locked to the playhead in the Canvas, and both
windows mirror each other. The Canvas displays the frame currently at the position of
the playhead in the Timeline, whether it’s playing or stopped.
• Enter a new absolute or relative timecode value in the Current Timecode field.
• Use the same shortcuts you’d use in the Canvas to navigate through and play your
edited sequence. For more information, see “Navigating in the Viewer and Canvas.”

Positioning the Playhead Using the Ruler
Moving the playhead in the Timeline ruler works in the same way as moving the playhead
in the scrubber bar in the Canvas or Viewer.
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To scrub through a sequence in the Timeline
Drag the playhead in the Timeline ruler.

Playhead

µ

To jump to a specific location in the Timeline
Click the desired location in the Timeline ruler. (You can do this while your sequence is
stopped or playing.)

Using Timecode to Navigate in the Timeline
The Current Timecode field shows the current position of the playhead. If you enter a
new timecode number, the playhead moves to that position. You can enter either absolute
or relative timecode numbers in this field. (For information on where this field is located
in the Timeline, see “Horizontal Time Controls.”)
To move the playhead to a specific location
1 Make the Timeline or Canvas active.
If you’re in the Timeline, make sure that all clips are deselected; otherwise, you will move
the selected clip to a new location. (Pressing Command-D deselects all clips.)
2 Do one of the following:
• Enter a new timecode number, then press Return to move to the frame that corresponds
to the timecode number you entered.
• Enter a minus sign (-) or a plus sign (+) and a relative timecode number, then press
Return to move forward or backward that number of frames from the current position
of the playhead. To type a minus sign, press Hyphen or press the Minus Sign key on
the numeric keypad. To type a plus sign, press Shift-Plus Sign or press the Plus Sign
key on the numeric keypad.
You do not have to select the Current Timecode field to enter a new timecode number.
If the Timeline window is active, the playhead will move to the new timecode location
in both the Timeline and Canvas, and the Current Timecode field of the Canvas will mirror
that of the Timeline.
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Zooming and Scrolling in the Timeline
Being able to navigate quickly to any point in your sequence is critical to efficient editing
and storytelling, and the ability to jump to any point in the Timeline instantly is one of
the main benefits of a nonlinear editing environment. There are many ways to navigate
through the Timeline. Learning keyboard shortcuts can save you time.

Zooming In and Out of the Timeline
There are several ways to set the zoom level you want:
• Menu commands
• Keyboard shortcuts
• Zoom slider
• Zoom control
• Zoom tools from the Tool palette
To zoom in and out of the Timeline using the Zoom slider
Do one of the following:

µ

Drag the thumb tabs on either side of the Zoom slider to adjust both ends of your view
at the same time. If the playhead is visible, it stays centered during the zoom. If the
playhead is not visible, the visible area of the Timeline stays centered.

µ

Hold down the Shift key while you drag one of the thumb tabs (on either side of the
Zoom slider) to zoom in or out of your sequence from the selected end of the Zoom
slider, while keeping the other thumb tab locked in place. This also moves the visible
area of the Timeline in the direction you’re dragging as you zoom.

Click in the space
around the slider to
scroll one length of the
Timeline window.
Scroll arrows
Playhead indicator

Zoom slider

Thumb tab

Once you’ve zoomed so far in to your sequence that you can’t see either the beginning
or ending clips in the sequence, you can use the Zoom slider as a scroll bar, to smoothly
move forward or backward to a specific section of your sequence.
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To zoom in and out of the Timeline using the Zoom control
Click or drag the Zoom control to view the Timeline at a different time scale while keeping
either the playhead or the current area of the Timeline centered. Clicking to the right of
the control zooms out to show more of your sequence; clicking to the left zooms in to
show more detail.

Drag the Zoom control
to change the Timeline
to a different time scale.

To zoom in and out of the Timeline using the Zoom tools
1 Select the Zoom In or Zoom Out tool in the Tool palette.
2 Do one of the following:
• Click in the Timeline.
• Drag to select a region to zoom in on or out of.
As you drag, the selection rectangle snaps to areas that correspond to the percentage
of zoom in the Timeline.
Clicking or dragging repeatedly increases the zoom factor. When the Timeline is zoomed
in or out to the maximum level possible, the + and - signs on the zoom tools disappear.
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Note: When the Zoom In or Zoom Out tool is selected, pressing the Option key temporarily
changes it to the opposite tool.

Drag the Zoom In tool
to expand the sequence.

This shows the above
sequence zoomed in, so
you can see more details
within the sequence.

To zoom in and out of the Timeline using menu commands or keyboard shortcuts
1 With either the Canvas or the Timeline selected, move the playhead to the position in
the Timeline where you want zooming to be centered, or select one or more clips in the
Timeline that you want to center on as you zoom in or out.
2 Do one of the following:
• Choose View > Zoom In, or press Option-Equal Sign (=).
Pressing Option-Equal Sign (=) repeatedly shows more and more detail, down to the
individual frames of your sequence.
• Choose View > Zoom Out, or press Option-Hyphen (-).
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This reduces the amount of detail but shows more of your edited sequence until the
entire sequence fits into the Timeline. You can zoom out further to reduce the scale of
your sequence in the Timeline and show more empty area to the right of it.

Before zooming in

After zooming in

The playhead remains
in the same position.

µ

To fit the entire contents of the Timeline into the available window size
Press Shift-Z.
The zoom factor changes so that the entire sequence fits into the available window size.

To fit a selected area of the Timeline into the available window size
1 Using the Selection, Group Selection, or Range Selection tool, select one or more items
in the Timeline.
2 Press Shift-Option-Z.
The zoom factor of the Timeline changes so that the selected items fit into the available
window size.
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Scrolling Horizontally Through a Zoomed-In Timeline
It’s easy to zoom far enough into your sequence that you are only seeing a small fraction
of the whole Timeline. To see another portion of your sequence, you can drag the playhead
in the Canvas to move to a new location in the Timeline. If you want to see another
portion of your sequence in the Timeline without moving the playhead, use the Zoom
slider.
The area of the horizontal scroll bar encompasses the total duration of your sequence in
the Timeline. Gray lines indicate one-minute increments, while a purple line indicates the
current position of the playhead.

Position of playhead

One-minute increment

To scroll horizontally through your edited sequence
Do one of the following:

µ

Drag the center of the Zoom slider to the left or right. The displayed area of the Timeline
moves smoothly in the direction you drag.

µ

Click the scroll arrows at either end of the scroll bar to move the displayed area in the
Timeline to the left or right.

µ

Click the scroll bar to the left or right of the Zoom slider to move the displayed area of
the Timeline by one length of the Zoom slider’s current scale.

µ

Press Shift-Page Up or Shift-Page Down to scroll left or right one length of the Timeline.
Note: If you are using a portable computer, press Function-Shift-Up Arrow or
Function-Shift-Down Arrow. The Function key is labeled “fn.”

µ

Select the Hand tool from the Tool palette (or press H) and drag the Timeline left or right.
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Scrolling Vertically Through Multiple Tracks
The tracks in the Timeline are divided by default into two regions, one for audio tracks
and one for video tracks. A divider between the two regions can be dragged up or down
to resize the regions, giving more space to either the video or audio tracks in your Timeline.

Scroll bar
Divider
Scroll bar

If you have more tracks than can be seen in the Timeline, scroll bars for the appropriate
region appear on the right side, so you can view the tracks in each region separately. For
example, you may have more audio tracks than video tracks in a documentary piece with
sophisticated sound design, or you may have more video tracks than audio tracks in a
music video with a lot of layering and motion graphics work.
To scroll vertically through the audio and video tracks in your sequence
Do one of the following:

µ

Drag the slider for the region in which you wish to scroll.
The displayed area of the Timeline moves smoothly up or down in the direction you drag.

µ
µ

Click the scroll arrows to move the displayed area of the Timeline up or down.

µ

Press Page Up or Page Down.

µ

To resize the audio and video regions
Drag the divider between the two regions up or down.

Click the scroll bar above or below the slider to move up or down by one length of the
slider’s current scale.

For more information about the static area that contains separate groups of audio or
video tracks with their own scroll bars, see “Navigating and Using Timecode in the Viewer
and Canvas.”
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Customizing the Interface

10

This chapter covers the following:
• Changing Browser and Timeline Text Size (p. 157)
• Moving and Resizing Final Cut Pro Windows (p. 157)
• Using Window Layouts (p. 159)
• Ways to Customize Keyboard Shortcuts (p. 162)
• Working with Shortcut Buttons and Button Bars (p. 171)
Final Cut Pro lets you customize the way you work with windows, rearranging them and
creating new layouts. You can also set up custom keyboard shortcuts and use shortcut
buttons to work more efficiently.

Changing Browser and Timeline Text Size
If you have difficulty reading the names of clips in the Browser or Timeline, you can adjust
the size of the text.
To change the text size in the Browser and Timeline
Do one of the following:

µ
µ

Choose View > Text Size, and then select from the available text size options.
Control-click an empty area in the Browser, then choose View > Text size from the shortcut
menu. Select one of the available text size options.

Moving and Resizing Final Cut Pro Windows
All open windows in Final Cut Pro—the Browser, Viewer, Canvas, and Timeline—can be
individually moved and resized to suit both your working style and the task at hand, even
across multiple monitors.
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Note: You can also resize and move the Tool Bench window, a window used for specialized
editing, including audio mixing and recording voiceovers.

Default Two Up layout

For example, you may want to increase the height of the Timeline while simultaneously
shrinking the size of the Viewer and Canvas to work on a sophisticated multitrack
sequence. You could also enlarge the Browser while shrinking the Timeline to perform
multicolumn searches for clips in the Browser as you edit.
Layout after making the
Browser and Timeline
larger and the Viewer
and Canvas smaller.

When you’re viewing windows arranged together on a single monitor, you can drag the
border between any aligned group of adjacent windows to quickly resize all the windows
at the same time.
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To resize multiple windows at the same time
1 Move the pointer over the border between the windows you want to resize.
The pointer changes to the Resize Window pointer.

Pointer between
two windows
Pointer between three
or more windows

2 Drag the border in the desired direction to resize the appropriate windows.
The windows on either side of the border are resized accordingly.
Any border between two windows in Final Cut Pro can be dragged. When borders line
up, such as the tops of the Browser and Timeline, they act as a single border—resizing
one window resizes the other as well.

Using Window Layouts
Final Cut Pro comes with a set of predefined window layouts. These layouts determine
the size and location of the four main windows in Final Cut Pro (the Browser, Viewer,
Canvas, and Timeline), along with the Tool palette and audio meters. Some window
layouts include additional windows, such as the Tool Bench.
Keep in mind the following about window layouts:
• The available layouts depend on the resolution of your display.
• All layouts adjust automatically to the position of the Dock. If you change the position
of the Dock, reselect your window layout to reposition the windows so they aren’t
covering the Dock.

Choosing a Window Layout
Choose a layout that maximizes your screen real estate in the best way for your source
material, editing function, screen resolution, and monitor type. For example, if you’re
doing color correction, you may want to choose the Color Correction layout. This gives
you a simultaneous display of the Tool Bench window (and use of the Video Scopes tab
for monitoring levels), the Viewer (so you can manipulate the color correction controls),
and the Canvas (to see your output).
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µ

To choose a window layout
Choose Window > Arrange, then choose an option from the submenu.
• Audio Mixing: This places the Viewer, Canvas, and Tool Bench at the top. The Tool Bench
window contains the Audio Mixer tab (you can also open the Audio Mixer by choosing
Tools > Audio Mixer). The Browser and Timeline are on the bottom, with the Tool palette
and audio meters to the right of the Timeline.
• Color Correction: This places the Viewer, Canvas, and Tool Bench at the top. The Tool
Bench window contains the Video Scopes and Frame Viewer tabs (you can also open
the Video Scopes and Frame Viewer by choosing Tools > Video Scopes and Tools >
Frame Viewer). The Browser and Timeline are on the bottom, with the Tool palette and
audio meters to the right of the Timeline.
• Multiple Edits: This layout appears only if your screen resolution is set to 1280 x 854 or
higher. This layout is useful for comparing three clips appearing in a sequence in a row
for color correction. At the top of the screen, from left to right, are the Viewer; a Tool
Bench window with a Frame Viewer tab showing the previous edit point; the Canvas;
and another Tool Bench window with a Frame Viewer tab showing the next edit point.
The Browser and Timeline are on the bottom, with the Tool palette and audio meters
to the right of the Timeline.
• Standard: This places the Browser, Viewer, and Canvas at the top and the Timeline
across the bottom. The Tool palette and audio meters are to the right of the Timeline.
• Two Up: This places the Viewer and Canvas at the top and the Browser and Timeline
on the bottom. The Tool palette and audio meters are to the right of the Timeline.

Customizing Window Layouts
If none of the existing layouts meets your needs, you can create and save additional
window layouts that you’ve arranged yourself. There are two types of window layouts
you can create:
• Custom layouts: You can create up to two layouts that are available in the Arrange
menu as Custom Layout 1 and Custom Layout 2.
• Saved layouts: You can create numerous window layouts that you name and then save
to your hard disk. Once you’ve saved a new window layout, it appears at the bottom
of the Arrange submenu of the Window menu. If you’ve saved multiple custom window
layouts, the first five appear in alphabetical order at the bottom of this menu.
Creating Custom Layouts
Two custom layouts are presented at the top of the Arrange menu and cannot be renamed.
To create a custom layout
1 Choose Apple Menu > System Preferences, click Displays, then set the desired resolution
of your computer monitor.
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The resolution you choose will become the minimum resolution for that particular window
layout.
2 In Final Cut Pro, arrange any combination of the four main windows, custom Tool Bench
windows with tool tabs, the Tool palette, and audio meters as you want them.
3 Hold down the Option key and choose Window > Arrange, then choose one of the Set
Custom Layout options.

µ

To use a custom layout
Choose Window > Arrange, then choose Custom Layout 1 or Custom Layout 2.
Saving Additional Window Layouts
If you want to save a layout for use on another computer, or name a layout yourself, you
can save layouts to your hard disk. Keep in mind the following about saving window
layouts:
• When you save a window layout, you save the state of each currently open window in
Final Cut Pro, including the number and order of all tool tabs in all open Tool Bench
windows.
• If you have two monitors connected to your computer, when you save a window layout,
the state of all Final Cut Pro windows appearing on both monitors is saved.
• The screen resolution that’s selected at the time a window layout is saved becomes
the minimum resolution at which that layout can be used.

To save a layout
1 Arrange any combination of the four main windows, custom Tool Bench windows with
tool tabs, the Tool palette, and audio meters as you want them.
If you’re using two monitors, you can arrange Final Cut Pro windows on both screens.
2 Choose Window > Arrange > Save Window Layout.
3 In the Save dialog, choose a location where you want to save the layout, enter another
name for the layout, then click Save.
Final Cut Pro defaults to the following folder location:
/Users/username/Library/Preferences/Final Cut Pro User Data/Window Layouts/.
To use a saved layout
Do one of the following:

µ
µ

Choose Window > Arrange, then choose a saved layout from the submenu.
The first five saved layouts in the Window Layouts folders can be selected using keyboard
shortcuts. By default, they are Shift-Control-(6, 7, 8, 9, 0).

To load a saved layout from your hard disk
1 Choose Window > Arrange > Load Window Layout.
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2 In the Open dialog, navigate to the location where the window layout is located, select
it, then click Open.

Ways to Customize Keyboard Shortcuts
You can customize the way you work in Final Cut Pro by setting up keyboard shortcuts
for many commands. The default keyboard shortcuts appear to the right of the command
name in menus and in tooltips.
When you customize the keyboard, you can:
• Change default keyboard shortcuts: You can customize the keyboard to override the
default keyboard shortcuts for individual commands or for the entire keyboard layout.
This lets you set up keyboard shortcuts based on your preferred set of keys and work
style. You can also set up the keyboard so that it uses the same keyboard shortcuts
used in other applications you may be familiar with.
• Load and save keyboard layouts: Once you set up your keyboard shortcuts, you can save
your keyboard layout for use in another system or for archiving (in case you have to
reinstall your software at a later point). You can also load a layout that someone else
has set up. These options are useful if you are working on multiple computers or with
several editors on a team. You can also save documents that list commands and their
keyboard equivalents, providing you with a useful online or print reference guide.
• Create shortcut buttons: You can create shortcut buttons corresponding to commands
and place them at the top of the major windows in Final Cut Pro. This lets you use a
one-button click, instead of a key combination, to perform commands in that window.
You can rearrange, organize, copy, and move buttons between windows, allowing for
even more customization of the interface.

Learning About the Keyboard Layout Window
The Keyboard Layout window allows you to view current keyboard shortcuts, set up
custom keyboard shortcuts, and search for keyboard shortcuts by function or menu item.

µ
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To open the Keyboard Layout window
Choose Tools > Keyboard Layout > Customize (or press Option-H).
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Command List Area
By default, commands are listed by menu set (such as File and Edit) and command group
function (such as Audio and Capture commands). You can also view commands
alphabetically. You can use the controls in this area to choose how to display commands
as well as how to search for them.
Disclosure triangle
Magnifying glass icon
Search field

Command list area
(shown here by menu
set and function)

• Disclosure triangle: Click to display all commands and their corresponding keyboard
shortcuts for a menu set or command group.
• Magnifying glass icon: Click to display commands alphabetically, along with their
keyboard shortcuts.
• Search field: Enter a command or key to search for.
• X icon: This icon appears on the right side of the search field only after you display
commands alphabetically. Click to display the command list by menu and function.
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Keyboard Area
The currently selected keyboard layout appears here and includes the following features.
Tabs let you choose the
modifier key to use.
This specifies the
currently selected
keyboard layout and
input type.

An icon for the default
command is shown on
each key.

Lock button

• Tabs: There are tabs at the top of the Keyboard Layout window for each modifier key
or combination of modifier keys, such as No Modifiers, cmd (Command key), shift (Shift
key), and opt (Option key). Click a tab to display the icons for commands used when a
modifier key or combination of modifier keys is pressed along with another key.
• Icons: Icons appear on each key for commands that are currently assigned to that key.
If you are unfamiliar with the icons, you can always enter a key in the command list
area to view all commands corresponding to that key.
• Lock button: Click to lock and unlock the keyboard layout so you can make and prevent
changes.
• Reset button: Click to reset all keyboard shortcuts to their original default key
combinations.
• Clear button: Click to clear all keyboard shortcuts, so they are blank. Some general
commands cannot be cleared, such as Copy and Paste. For more information, see
“Clearing and Restoring Keyboard Layouts.”

Viewing Commands in the Command List
You can choose how to view the commands in the command list area.
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µ

To view all commands alphabetically
Click the magnifying glass icon.

µ

To view commands by menu set and command group function
Click the X icon.
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Assigning Keyboard Shortcuts
Specifying shortcuts for commands is easy. You don’t have to set up the entire keyboard
with your preferred shortcuts—you can choose specific menu sets or command groups.
For example, you can specify keyboard shortcuts for all commands in the File menu or
for all render functions.
Important: Before you begin specifying keyboard shortcuts, make sure you choose the
appropriate language and input type. For more information, see “Using Different Keyboards
and Languages.”

µ

To see which commands have a key or key combination assigned to them
Enter a key or key combination in the search field.
If you press the E key,
all commands that use
that key are shown.

To assign keyboard shortcuts to commands
1 Choose Tools > Keyboard Layout > Customize.
The Keyboard Layout window appears.
2 In the Keyboard Layout window, click the Lock button in the lower-left corner.
3 Click a tab to choose a modifier key or combination of modifier keys.
The keyboard layout for commands that use that modifier key is shown.
4 If you want to create an entirely new layout, click Clear. When a message appears asking
if you want to clear the keyboard layout, click Yes.
All existing keyboard shortcuts in all tabs are cleared and the keys appear blank (no icons
are displayed).
5 In the command list area, do one of the following:
• Click a disclosure triangle to display commands within a menu set or command group.
• Click in the search field. (Commands are displayed alphabetically.)
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• Enter the name of the command in the search field. (Commands that match are
displayed automatically.)
If you enter “edit,” all
commands that include
that word are shown.

6 Click a command in the list to select it, then do one of the following:
• Press the key or key combination you want to assign as the shortcut.
• Drag the command from the list to the key on the keyboard layout that you want to
assign it to.
Note: The modifier key is already chosen by the tab selected at the top of the Keyboard
Layout window.

The keyboard shortcut
you entered appears next
to the command.

• If the key combination you set is not currently used for another command: In this case, it’s
assigned to the command you selected. The keyboard shortcut you entered now
appears next to the command in the list. The icon for that command also appears on
the appropriate key.
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• If the key combination is already used by another command: In this case, a message
appears asking if you want to reassign it. Click Yes. The keyboard shortcut you entered
now appears next to the command in the list. The icon for that command also appears
on the appropriate key.
Note: If the command already has a shortcut assigned to it, you can delete the existing
one. If you don’t, the command will have two keyboard shortcuts assigned to it.
7 When you’re finished assigning new key combinations, do one of the following to prevent
further changes:
• Click the Lock button.
• Close the Keyboard Layout window.
Note: Customized keyboard layouts are automatically saved when you close the Keyboard
Layout window.
If you like, you can reassign commands to keys in the Keyboard Layout window. However,
you cannot move commands between modifier keys (tabs). If you make mistakes as you
set up commands, or simply want to clear the command for one or two keys, see “Clearing
and Restoring Keyboard Layouts.”
To quickly reassign the keyboard shortcuts for a command
1 Choose Tools > Keyboard Layout > Customize.
The Keyboard Layout window appears.
2 In the keyboard area, drag the icon for a command from the current key to the new key.
If you drag an icon to a key that already has a command assigned to it, the new command
takes precedence and the previous command no longer has a keyboard shortcut assigned
to it.
You can also delete the keyboard shortcut for a command in the Keyboard Layout window.
This is useful if you only want to delete keyboard shortcuts for individual commands and
not the entire keyboard layout.
To delete the keyboard shortcut for a command
1 Choose Tools > Keyboard Layout > Customize.
The Keyboard Layout window appears.
2 In the keyboard area, drag the icon for a command out of the Keyboard Layout window.
For more information on clearing all keyboard shortcuts, see “Clearing and Restoring
Keyboard Layouts.”

Chapter 10 Customizing the Interface

167

Avoiding Keyboard Shortcut Conflicts
Certain keyboard shortcuts may not work in certain Final Cut Pro windows. For example,
if you press an alphanumeric key, such as J, K, or L in the Browser, the first clip beginning
with the character you pressed is selected (clips named Jacob, Katy, or Larry, for example).
This is the default behavior of the Browser, and keyboard shortcuts cannot bypass this
feature. However, in the Viewer or Canvas, pressing J, K, or L activates the transport
controls (reverse, pause, and forward, respectively). When you assign keyboard shortcuts,
consider which windows you intend to use them in. To make sure your custom keyboard
assignment works as expected, try adding one or two modifier keys to your custom
keyboard shortcut. These key combinations are less likely to be used by the built-in
features of the windows.
Additionally, keyboard shortcuts assigned by Mac OS X are unavailable in Final Cut Pro.
These keyboard shortcuts, such as Command-M (for minimizing a window), appear red
in the Keyboard Layout window of Final Cut Pro. Optional keyboard shortcuts, such as
those assigned to Exposé or Dashboard (in Mac OS X v10.4 or later), also override keyboard
shortcuts assigned in Final Cut Pro. To solve this problem, you can either adjust the
keyboard shortcuts for Exposé or change the conflicting keyboard shortcuts in the
Final Cut Pro Keyboard Layout window. For more information, see Mac Help.

Clearing and Restoring Keyboard Layouts
At any time, you can clear the keyboard layout, removing most of the commands and
their keyboard shortcuts. This is useful if you want to clear the keyboard layout you
previously set up, so you can change the commands for another project.
Note: If you don’t clear the existing layout, newly specified keyboard shortcuts are used
in addition to those keyboard shortcuts already specified (either the default keyboard
shortcuts or those you previously set up).
Some commands cannot be cleared and always use a default keyboard shortcut, including
Abort, Cancel, Clear, Copy, Cut, Minimize Window, Paste, Play, Redo, and Undo. Additional
commands that can’t be cleared are shown on pink-colored keys. If you like, you can
specify additional key combinations to use for these operations.
To clear all keyboard shortcuts
1 Choose Tools > Keyboard Layout > Customize.
The Keyboard Layout window appears.
2 Click the Lock button, then click Clear.
3 When a message appears asking if you want to clear all keyboard shortcuts, click OK.
The keyboard layout in the Keyboard Layout window now appears without any icons or
commands.
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At some point, you may decide that you want to restore all of the keyboard shortcuts to
their original default settings.
To restore the default keyboard shortcuts
1 Choose Tools > Keyboard Layout > Customize.
The Keyboard Layout window appears.
2 Click the Lock button, then click Reset.
3 When a message appears asking if you want to reset the defaults, click OK.

Saving Commands and Keyboard Shortcuts as Text Files
You can save commands and their keyboard shortcuts in a text document. These
documents serve as keyboard layout guides, available onscreen, or printed for easy
reference. You can open and reformat the text files in other programs, such as spreadsheet
or word-processing applications, to make them easier to read.
To save commands and keyboard shortcuts as a text file
1 Choose Tools > Keyboard Layout, then choose an option from the submenu:
• Save Grid as Text: Saves only those commands to which you’ve assigned keyboard
shortcuts as a tab delimited text file.
• Save Menu Commands as Text: Saves all commands from the following menus: File,
Edit, View, Mark, Modify, Sequence, Effects, Tools, and Window. (This option does not
let you save command groups, such as Compositing or Editing.)
• Save Command Groups as Text: Saves all commands from the command groups shown
in the command list area, such as Audio, Capture, Compositing, Display, and so on.
Commands are listed by command group in the same order as in the command list
area. (This option does not let you save menu sets, such as File and Edit.)
• Save All Commands as Text: Saves all commands (menu sets and command groups),
with commands listed alphabetically.
2 In the Save dialog, enter a new name for the document if you want and choose where
to save it, then click Save.
The default location where these files are stored is:
/Users/username/Library/Preferences/Final Cut Pro User Data/Keyboard Layouts/.

Saving and Loading Keyboard Layouts
You can save a keyboard layout that you customized. This is useful if you are working
with others on a project and want to use the same keyboard shortcuts for commands.
You can also load keyboard layouts that others have created.
To save a customized keyboard layout
1 Choose Tools > Keyboard Layout > Save Keyboard Layout.
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2 In the Save dialog, enter a new name for the layout if you want and choose where to
save it, then click Save.
The default name is Custom Keyboard Layout. The default location where these files are
stored is: /Users/username/Library/Preferences/Final Cut Pro User Data/Keyboard Layouts/.
3 If a file with the specified name already exists in that location, a message appears asking
if you want to replace the file. If so, click Replace; otherwise, click Cancel and rename the
file, then click Save.
When you import a custom keyboard layout, all existing shortcuts are replaced by those
in the custom keyboard layout.
To load a customized keyboard layout
1 Copy the keyboard layout file to your computer.
The default location where these files are stored is:
/Users/username/Library/Preferences/Final Cut Pro User Data/Keyboard Layouts/.
2 Choose Tools > Keyboard Layout > Load Keyboard Layout.
3 In the Choose a File dialog, navigate to the location where the keyboard layout is stored,
then click Choose.
When you open the custom Keyboard Layout window, the title bar indicates that the
layout is imported and displays the name of the layout.

Using Different Keyboards and Languages
You can set up your keyboard for use with a language and layout different from the one
it shipped with using the International pane in System Preferences. For information on
how to use a specific keyboard layout, see Mac Help.
When you customize a keyboard, the keyboard shortcuts you create apply to the currently
selected language. (The keyboard layout is also listed at the top of the Keyboard Layout
window.) If you are switching among multiple languages, make sure you choose the right
one before setting up shortcuts for commands.
Important: The physical keyboard you’re using is detected by Mac OS X as soon as you
connect it to your computer, and while you can switch between multiple languages, the
position of the key on the keyboard takes precedence over the letter that’s assigned to
that key due to the selected language. For example, if you set up the default U.S. keyboard
so the A key (three rows up and two keys in from the left) is the shortcut for a ripple
delete and then switch to another keyboard language, such as French, that key is now
the Q key, but when you press it, the keyboard shortcut remains ripple delete.
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Working with Shortcut Buttons and Button Bars
Shortcut buttons can be created and placed at the top of the main windows in
Final Cut Pro—the Browser, Viewer, Canvas, Timeline, and any Tool Bench windows. You
can then click any of these shortcut buttons in this “button bar” to perform commands,
instead of entering the key combination or using menus.
Shortcut buttons added
to the Browser

Some windows, such as the Timeline and Tool Bench, include some buttons in their
button bar by default. You can delete these buttons, if you like (see “Removing Shortcut
Buttons”).
Shortcut buttons display the icon of the command they perform, providing you with a
visual cue to their function. In addition, when you move the pointer over a shortcut
button, a tooltip for the specified command appears.
Icon for a
shortcut button

Tooltip for a
shortcut button

Note: Shortcut buttons are automatically saved when you quit Final Cut Pro. They are
not saved per project.

Adding Shortcut Buttons to a Button Bar
Button bars that you set up are automatically saved when you quit the application and
restored when you open it again. You can rearrange, copy, and drag shortcut buttons to
further customize the button bar in each window.
Note: You can add any number of shortcut buttons to the button bar; however, excess
buttons may not be visible within the window.
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To create a shortcut button in the button bar of a window
1 Make sure the window you want to add the shortcut button to is displayed. If you’re
adding a shortcut button to the Tool Bench window, make sure the tab of the feature
you want is in front.
2 Choose Tools > Button List.
The Button List window appears. This looks the same as the command list area of the
Keyboard Layout window.
Tip: You can also drag icons from the command list area or keyboard area of the Keyboard
Layout window.
3 Drag an icon from the Button List window to the window where you want the shortcut
button to appear.

A shortcut button with an icon for the specified operation now appears in the window.
As more shortcut buttons are added to the button bar, tabs in the window move to
accommodate them.
Note: You may need to resize the window to view all shortcut buttons and tabs. If the
buttons in a button bar exceed the width of the window, a dot appears on the left edge
of the button bar, indicating there are more buttons that cannot be seen. To see the
additional buttons, you need to widen the window.

µ

To use shortcut buttons to perform commands
Click the shortcut button in the button bar of the desired window.
The window containing the shortcut button does not have to be active.

Rearranging, Moving, and Copying Shortcut Buttons
New shortcut buttons are placed to the left or right of existing buttons. You can move
and copy shortcut buttons within a window and to different windows. You can also add
“spacers” between shortcut buttons to organize them in the button bar.
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µ

To rearrange shortcut buttons in a button bar
In the button bar, drag shortcut buttons where you want them to appear.

µ

To add a spacer to a button bar
Control-click the button bar, then choose Add Spacer from the shortcut menu.
Spacer added
between buttons

µ

To move spacers in a button bar
Drag the spacer where you want it to appear in the button bar.

µ

To remove a space in a button bar
Drag the spacer out of the window.

µ

To move shortcut buttons to a different window
Drag the shortcut button from one window to another window.

µ

To copy a shortcut button to a different window
Press and hold down the Option key, then drag the shortcut button from one window
to another.

Changing Shortcut Button Colors
You can change the color of individual buttons in a button bar.

µ

To change the color of a shortcut button
Control-click any shortcut button in the button bar, choose Color from the shortcut menu,
then choose a color from the submenu.
Available colors are Plain, Red, Yellow, Green, Cyan, Blue, and Purple. The default color is
Plain (gray).

Removing Shortcut Buttons
You can remove one or all shortcut buttons from a button bar at any time.
To remove a shortcut button from a button bar
Do one of the following:

µ

Control-click the shortcut button, choose Remove from the shortcut menu, then choose
Button from the submenu.

µ

Drag the shortcut button you want to delete out of the window.

µ

To remove all shortcut buttons from a button bar
Control-click any shortcut button in the button bar, choose Remove from the shortcut
menu, then choose All from the submenu.
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Note: In the case of the Timeline, which contains default shortcut buttons, choose Remove
> All / Restore Defaults from the submenu.

Saving and Using Custom Shortcut Button Bars
You can manually save the shortcut button bars that you set up in the Viewer, Canvas,
Browser, and Timeline. This is useful if you are working with others on a project and want
to use your shortcut button configuration. You can also load and use shortcut button
bars that others have created.
Important: Button bars that you set up in Tool Bench windows are saved with custom
window layouts you create.
To save a shortcut button bar
1 Do one of the following:
• Choose Tools > Button Bars > Save.
• Control-click any shortcut button in the button bar, then choose Save All Button Bars
from the shortcut menu.
2 In the Save dialog, enter a new name for the button bar and choose where to save it.
The default name is Custom Button Bars. The default location where these files are stored
is: /Users/username/Library/Preferences/Final Cut Pro User Data/Button Bars/.
3 If a file with the specified name already exists in that location, a message appears asking
if you want to replace the file. If so, click Replace; otherwise, click Cancel and rename the
file, then click Save.
To load a custom shortcut button bar
1 Copy the button bar file to your computer.
The default location where these files are stored is:
/Users/username/Library/Preferences/Final Cut Pro User Data/Button Bars/.
2 Do one of the following:
• Choose Tools > Button Bars > Load.
• Control-click anywhere in the button bar of any window, then choose Load All Button
Bars from the shortcut menu.
Note: A list of button bars that have been saved in the Button Bars folder appears only
in the Button Bar submenu, not in the shortcut menu.
3 In the Choose a File dialog, navigate to the location where the shortcut button bar is
stored, then click Choose.
The default location where these files are stored is:
/Users/username/Library/Preferences/Final Cut Pro User Data/Button Bars/.
The shortcut button bar appears at the top of the selected window.
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Note: When you restore a button bar or use a saved shortcut button bar, all existing
shortcut buttons in all windows are replaced by those you are loading.
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Connecting DV Video Equipment

11

This chapter covers the following:
• Components of a Basic Final Cut Pro Editing System (p. 177)
• Setting Up a Final Cut Pro Editing System (p. 178)
• Connecting Your Camcorder (p. 179)
• Opening Final Cut Pro and Choosing Your Initial Settings (p. 179)
• Confirming Remote Device Control Between Final Cut Pro and Your DV Device (p. 184)
• About FireWire (p. 185)
Setting up Final Cut Pro to capture DV video is as simple as connecting your camcorder
to your computer with a FireWire cable.

Components of a Basic Final Cut Pro Editing System
With a basic Final Cut Pro system, you can capture, edit, and output DV video. This basic
editing system requires the following components:
• Mac computer with Final Cut Pro installed: Your computer is the core of your editing
system.
• Scratch disk: An internal hard disk with enough capacity and speed for capturing DV
media files is required.
• DV camcorder or video deck (also called a VTR): This is used for capturing footage and
outputting finished projects back to tape.
• FireWire cable: This is used to connect your computer to the DV camcorder.

What Are Input and Output Devices?
When you capture footage, you use an input device (in this case, your camcorder or video
deck) to transfer footage to your computer. For output, you record your finished movie
on an output device (again, a camcorder or VTR). In a basic editing system, a DV camcorder
or deck serves as both an input and output device.
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Setting Up a Final Cut Pro Editing System
This section explains how to set up a basic editing system. Even if you are building a more
complex editing system, you should read about the basic setup process first. References
to more advanced information are included within each stage.
The basic process for setting up a Final Cut Pro editing system is outlined below.
Stage 1: Connecting Input and Output Devices for Capture and Output
If you are using DV video, this means connecting your DV camcorder to your computer
via a FireWire cable. For information about connecting professional and non-DV
equipment, see “Connecting Professional Video and Audio Equipment.” For information
about setting up HDV, DVCPRO HD, IMX, Panasonic P2, or XDCAM HD devices, see
Professional Formats and Workflows, available in Final Cut Pro Help.
Stage 2: Connecting an External Video Monitor and Audio Speakers
For a basic editing system, you can skip this step. However, external video and audio
monitoring are important for color correction and audio mixing because they ensure the
highest-quality picture and sound possible. For more information, see “External Video
Monitoring” and “Assigning Output Channels and External Audio Monitors.”
Stage 3: Choosing an Easy Setup to Configure Final Cut Pro
Easy Setups are software configurations specific to the format you want to capture, edit,
and output. Final Cut Pro includes Easy Setups for most editing configurations. For more
advanced information about Easy Setups, see “Device Control Settings and Presets.”
Stage 4: Choosing a Scratch Disk Location for Captured Media and Render Files
A scratch disk is a hard disk (internal or external to your computer) where Final Cut Pro
stores captured media files and temporary files (such as render files). By default,
Final Cut Pro uses the internal hard disk on which the application is installed. For advanced
options, see “Determining Your Hard Disk Storage Options.”
Stage 5: Establishing Remote Device Control Between Your Computer and Video
Deck
Once your basic system is configured, you need to make sure that Final Cut Pro can
communicate with your camcorder or VTR. Remotely controlling your deck allows you
to precisely capture footage to your scratch disk and output to tape. For advanced
information, see “Device Control Settings and Presets.”
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Connecting Your Camcorder
The following illustration demonstrates how to connect a camcorder to the FireWire port
on your computer, so that you can capture video (transfer the video from your camcorder
to your computer) and output your program back to DV tape. For more information on
FireWire, see “About FireWire.”
6-pin connector
to computer
DV camcorder
in VTR mode

FireWire
Computer
4-pin connector
to camcorder

To connect your DV camcorder or VTR to your computer
1 Connect the 4-pin connector on one end of your FireWire cable to the 4-pin FireWire port
on your camcorder.
Important: Some DV decks may use a 6-pin FireWire connector instead of a 4-pin
connector. Make sure you use a FireWire cable that matches the connector on your video
device.
2 Connect the 6-pin connector on the other end of your FireWire cable to a FireWire 400
port on your computer.
3 Turn on your VTR or camcorder, and switch it to VCR (or VTR) mode.
For information on connecting or transferring file-based media from a newer advanced
camcorder, see the documentation that came with the camcorder and refer to “Transferring
File-Based Media.”

Opening Final Cut Pro and Choosing Your Initial Settings
The first time you open Final Cut Pro after installing the software, you’re prompted to
choose an Easy Setup (a collection of settings that determines what format you want to
capture and edit) and a scratch disk (the hard disk where you’ll store your captured media
files).
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Choosing an Easy Setup
Final Cut Pro comes with predefined Easy Setups based on the most common video
formats and devices, such as DV NTSC and DV PAL. The Easy Setup you choose applies
to all new projects and sequences until you choose another Easy Setup.
If you always use the same type of camcorder or video deck, you may never have to
change your Easy Setup. If you do change the device or the format you are using for
capture and output, you should choose a matching Easy Setup.
To choose an Easy Setup
1 Choose Final Cut Pro > Easy Setup.
Note: If this is the first time you’ve opened Final Cut Pro, the Easy Setup window appears
automatically after the application opens.
2 From the Format pop-up menu, choose a format that matches the footage you want to
work with. You can select one of the following:
• A video system, such as NTSC, PAL, or high definition (HD)
• A specific codec, such as DV or HDV
3 Click the Use pop-up menu to see all of the Easy Setups related to your choice in the
Format pop-up menu.
You can further refine the list by choosing a specific frame rate from the Rate pop-up
menu.
4 Choose an Easy Setup from the Use pop-up menu.
Choose a format and
a frame rate to reduce
the number of Easy
Setups shown in the
Use pop-up menu.

Choose an Easy Setup
from the Use pop-up
menu.
A summary of your
selected Easy Setup
appears below the
pop-up menu.
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Note: Make sure you choose a device control preset that uses FireWire so Final Cut Pro
can control your camcorder or deck. Both the DV-NTSC and DV-PAL Easy Setups use a
FireWire device control preset. For more information, see “Device Control Settings and
Presets.”
5 Click Setup.
The corresponding capture, sequence, and device control presets are loaded, as well as
A/V device settings.
The selected Easy Setup applies to all new projects and sequences. Settings for existing
sequences do not change. For additional information about Easy Setups, see “Audio/Video
Settings and Easy Setups.”
If this is the first time you’re setting up Final Cut Pro, you’ll now need to specify your
scratch disk.

Specifying Scratch Disks
A scratch disk is a hard disk, internal or external to your computer, where Final Cut Pro
stores captured digital video and audio, as well as rendered media files created during
editing. (Rendering is the process of creating temporary video and audio render files for
portions of your sequence that Final Cut Pro cannot play in real time.) By default,
Final Cut Pro uses the hard disk on which the application is installed.
You use the Scratch Disks tab in the System Settings window to choose where you want
to save the video and audio files that you capture and the render and cache files that
Final Cut Pro creates. You can also specify other settings related to the size of captured
and exported files and the minimum available space allowed on scratch disks.
To specify one or more scratch disks and associated settings
1 Choose Final Cut Pro > System Settings, then click the Scratch Disks tab.
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If this is the first time you’ve opened Final Cut Pro, this window appears automatically
after you’ve chosen an Easy Setup.

2 To specify a disk or a folder on a hard disk as a scratch disk:
a Click Set.
b In the dialog that appears, locate and select the disk you want to use.
Only connected external disks or installed internal disks are listed. If your hard disk
doesn’t appear, make sure that it’s connected properly and correctly initialized and
mounted. For more information, see the documentation that came with your computer,
your hard disk, or your disk-formatting software.
c Click Select (the button includes the name of the disk you selected).
The specified disk is listed next to the Set button, along with the amount of available
disk space.
3 To capture video and audio to separate files, select the Capture Audio and Video to
Separate Files checkbox.
Note: For capturing DV media, it’s usually best to leave this checkbox unselected. For
more information, see “Capturing Video and Audio Separately.”
4 Select the checkboxes corresponding to the type of files you want to store on each scratch
disk: Video Capture, Audio Capture, Video Render, and Audio Render.
5 To choose a folder where Final Cut Pro will automatically save copies of your project for
backup purposes:
a Click Set next to Autosave Vault.
b In the dialog that appears, locate and find the disk you want to use, then click Choose.
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6 Specify additional settings for capturing and exporting files:
• Minimum Allowable Free Space On Scratch Disks: Enter a value to set the minimum space
you want to keep available on a scratch disk. The default value here is usually sufficient.
If you have limited scratch disk space, you may want to set this to the amount of disk
space you want available for render files. If you use most of your disk space for captured
clips, you may run out of space when rendering.
• Limit Capture/Export File Segment Size To: Select this option only if you’re capturing or
exporting clips that may be used on other systems with a file size limitation. Any files
that are larger than the limit entered here (which defaults to 2 GB) are written as separate
files, in which the end of one file contains a reference to the next (so the first file appears
to be a continuous file).
• Limit Capture Now To: This option limits the duration of media files captured using the
Capture Now command. For more information, see “Limiting the Duration of the Capture
Now Process.”
To remove a scratch disk
1 Choose Final Cut Pro > System Settings, then click the Scratch Disks tab.
2 Click Clear next to the scratch disk you no longer want to use.

About Scratch Disk Capture Order
Final Cut Pro lets you specify up to 12 scratch disks at one time. Final Cut Pro always uses
the disk with the most space first. When that disk is full, Final Cut Pro uses the disk with
the next most available space, and then the next one, and so on, until all disks are full.

When Scratch Disks Become Unavailable
Scratch disks you’ve set can become unavailable for a number of reasons: they might be
turned off, disconnected, or temporarily unmounted. Also, if the scratch disk folder you
selected has been moved, deleted, or renamed, Final Cut Pro might not be able to find
it.
When you open Final Cut Pro and one or more of your scratch disk folders cannot be
found, a dialog appears with three options:
• Quit: Lets you quit without changing the scratch disk preferences.
• Set Scratch Disks: Opens the Scratch Disks tab in the System Settings window so that
you can change the current set of scratch disks. Any disks that are missing are removed
from this list. You must choose at least one scratch disk to continue.
• Check Again: Allows you to reconnect or start up your scratch disk, wait for it to mount,
and then proceed as usual.
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Assigning Search Folders for Reconnecting Media Files
After you specify which volumes and folders you want to use to capture media, you may
want to assign these same locations as search folders for the Reconnect Files dialog. This
allows Final Cut Pro to limit its search for media files if they become offline. For more
information about assigning search folders, see “Choosing Settings and Preferences.” For
more information about the Reconnect Files dialog, see “Reconnecting Clips and Offline
Media.”

Confirming Remote Device Control Between Final Cut Pro and
Your DV Device
Device control enables communication between your deck or camcorder and Final Cut Pro,
allowing you to remotely control your video deck for capturing and output. After you
connect your camcorder or deck to your computer and choose an Easy Setup that matches
your equipment, make sure that the deck and Final Cut Pro are communicating.
To confirm the communication between your camcorder or deck and Final Cut Pro
1 Choose File > Log and Capture.
The Log and Capture window appears.
2 Press the Play button on your VTR.
If the proper connections are made from the VTR to the computer, the VTR begins playing,
and you see the following in the Log and Capture window:
• Video appears in the video preview area.
• The status message “VTR OK” appears below the video preview area.
• The transport controls (Play, Rewind, Fast-Forward, and so on) appear below the video.
If Final Cut Pro has communication problems with your DV device, try the following:
• Make sure your FireWire cable is properly connected and plugged in all the way.
• Verify that the camcorder is set to VCR mode.
• Try changing the device control preset to FireWire Basic. For more information, see
“The Differences Between Apple FireWire and FireWire Basic.”
• Quit Final Cut Pro, shut down your computer, turn your camcorder or deck off and on,
then restart your computer.
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About FireWire
FireWire (also called IEEE 1394a or i.LINK) is the consumer and professional standard for
DV-format digital video. DV devices typically use FireWire 400 connectors. There are two
kinds of FireWire 400 connectors: a 4-pin connector (typically used to connect to video
equipment such as camcorders or decks) and a 6-pin connector (used to connect to
computer equipment). However, some newer video equipment uses the 6-pin connector
and some video cards use the 4-pin connector. See your equipment’s documentation for
more information.
Final Cut Pro and a DV device can communicate remote control information using FireWire.
Typically, you use FireWire for device control when you are using a DV format such as
DV, DVCAM, DVCPRO, DVCPRO 50, or DVCPRO HD.
For more information about FireWire technology, go to the Apple FireWire website at
http://www.apple.com/firewire.

The Differences Between Apple FireWire and FireWire Basic
Video devices vary greatly in their functionality and adherence to FireWire specifications
for device control (the technology that allows Final Cut Pro to control your DV camcorder
or deck via FireWire). For this reason, there are two versions of the FireWire protocol you
can use for device control and capture in Final Cut Pro:
• Apple FireWire: This is the default.
• Apple FireWire Basic: This is a simplified device control protocol for camcorders and
decks that aren’t fully compatible with Apple FireWire. Using this protocol doesn’t affect
the quality of captured video or audio.
It may not be obvious which camcorders support the complete FireWire device control
protocol and which only understand FireWire Basic. If you’re unsure, try an Easy Setup
that uses the standard FireWire protocol first (NTSC or PAL FireWire). If you’re not able to
remotely control your camcorder or VTR using Final Cut Pro, choose an Easy Setup that
uses the FireWire Basic version of device control.

Chapter 11 Connecting DV Video Equipment

185

Connecting Professional Video and
Audio Equipment

12

This chapter covers the following:
• Components of a Professional Final Cut Pro Editing System (p. 187)
• About Video Interfaces, Signals, and Connectors (p. 191)
• Connecting Professional Video Devices (p. 197)
• Audio Interfaces (p. 202)
• Audio Connectors and Signal Formats (p. 206)
• Connecting Professional Audio Devices (p. 212)
• Connecting Remote Device Control (p. 215)
You can expand your input and output options by installing third-party video, audio, and
device control interfaces.

Components of a Professional Final Cut Pro Editing System
Final Cut Pro editing systems can be configured to meet the most demanding professional
requirements. An advanced editing system can be built by expanding the basic system
described in “Components of a Basic Final Cut Pro Editing System.”
• Mac computer with Final Cut Pro installed: Your computer is the core of your editing
system.
• Professional video and audio devices: You can use a wide variety of professional video
and audio devices for capturing footage and outputting finished projects.
• External video and audio monitors: External video and audio monitors are required for
evaluating your final image quality (especially during color correction) and listening to
your finished sound mix.
• Video and audio interfaces: Specialized interfaces are required for connecting professional
and non-FireWire devices to your editing system.
• RS-422 serial device control interfaces: Most professional devices use an RS-422 interface
for remote device control during capture and output.
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• Video, audio, and remote device control cables: A variety of cables is required for separate
video, audio, and remote device control connections. Unlike a basic DV editing system,
which uses a solitary FireWire cable to transfer video, audio, and remote control signals,
many professional configurations require a separate cable for each of these signals.
• Additional scratch disks: Because of large file sizes, one or more internal or external hard
disks, a RAID, or a connection to a storage area network (SAN) are required.

Video and Audio Input and Output Devices
An input device is used to transfer footage to your computer. For output, you record your
finished movie to an output device. Basic editing systems use a DV camcorder or deck
as both an input and output device. Professional editing systems may use multiple video
decks to capture and output to different video formats.
To connect non-FireWire devices to your computer, you also need a third-party video or
audio interface. For more information, see “Video and Audio Interfaces.”
Video Device
This is a VTR or camcorder you connect to your computer to capture and output media.
The connectors and signal format on your video device determine what kind of video
interface your computer needs to connect to your device.

Audio Device
This is a device, such as a digital audio tape (DAT) recorder or multitrack audio recorder,
that lets you capture or output audio independently from video.

External Video and Audio Monitors
In the final stages of post-production—color correction and audio mixing—external video
and audio monitors are essential to ensure the quality of your movie. Editing systems
focused on these final phases of post-production are often called finishing systems.
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External Video Monitor
When you edit your video, it’s ideal to watch it on a monitor similar to the one you will
use for the final screening. An external video monitor can display color, frame rate, and
interlaced scanning more accurately than your computer display.

If you are working on an NTSC or PAL project, you should watch it on an external video
monitor that shows the video interlaced. Your ability to color correct is limited by the
accuracy of your monitor. For more information about external video monitoring, see
“External Video Monitoring.”
External Audio Speakers
As with video, it’s important to monitor your audio so that it matches the listening
environment where the final project will be shown. Although you can use your computer’s
built-in speakers for monitoring audio, any critical audio work should be monitored on
external speakers (also called audio monitors). For more information about external audio
monitoring, see “Assigning Output Channels and External Audio Monitors.”

Video and Audio Interfaces
An interface is a device that adds physical video or audio connectors to your computer
so that you can connect your Final Cut Pro system to other professional equipment (such
as video decks and monitors).
Interfaces provide input and output connectors that aren’t included with your computer.
For example, if you want to capture uncompressed NTSC video from a Digital Betacam
deck, you need a video interface that supports SDI signal input on a standard BNC
connector. If you want to output multiple audio channels to an analog audio mixer or
digital multitrack, you need an audio interface that has XLR, 1/4" tip-ring-sleeve (TRS),
AES/EBU, or ADAT Lightpipe output connectors.
You may want to consider adding a third-party interface to your system if:
• You are digitizing video from an older analog VTR (such as a Betacam SP deck) that
does not have digital video outputs or remote control via FireWire
• You are integrating Final Cut Pro into a professional broadcast environment that requires
SDI, HD-SDI, or other non-FireWire video and audio connections
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• You need to capture, edit, and output full-resolution, uncompressed video signals
instead of DV video (which is compressed)
• You need to capture or output multiple audio channels
Third-party video and audio interfaces can be installed in one of your computer’s PCI
Express slots, connected to the USB port, or connected via FireWire (for example, the AJA
Io). For more information, see “About Video Interfaces, Signals, and Connectors” and
“Audio Interfaces.”

Using a Breakout Box with Video and Audio Interfaces
Some PCI Express cards are too small to mount all the connectors for the various input
and output signals available. In this case, a breakout box is included to provide a sturdy
housing for all of the video and audio connectors. For example, professional audio
interfaces use XLR connectors, but these are too big to be mounted directly on a PCI
Express card. Instead, a breakout box, included with the card, contains the XLR connectors.
A multipin connector on a fairly long extension cable is usually used to attach the PCI
Express card to the breakout box. The breakout box can then be mounted on a desktop
or in a standard equipment rack, making the connectors more accessible than they would
be on the back of your computer.

For instructions for connecting a breakout box to your PCI Express card, see the
documentation included with your interface. An example of a setup with a breakout box
is shown in “Connecting Professional SD Video Devices.”
Note: Some non-PCI Express interfaces have a similar “breakout box” design to fit all of
their video and audio connectors. These interfaces look similar to PCI Express card breakout
boxes, but they connect to your computer via FireWire or USB.

Scratch Disks
A scratch disk stores captured and rendered media for editing, playback, and output.
Scratch disk performance is a critical aspect of your editing system: the storage capacity
and data rate of your disks must match or exceed the requirements of the video format
you are using. For more information, see “Determining Your Hard Disk Storage Options.”
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About Video Interfaces, Signals, and Connectors
There are many types of video interfaces, signal formats, and connectors that can be used
when setting up your system.

Video Interfaces
Final Cut Pro allows you to use a wide variety of video interfaces for capture and output.
The following sections show examples of the most common types of video interfaces
available.
FireWire for DV
You can use the built-in FireWire port on your computer to capture and output to almost
any DV device, including DV, DVCAM, DVCPRO, DVCPRO 50, and DVCPRO HD devices.

In this configuration, you need only your computer and a supported DV device. For more
information, see “Connecting DV Video Equipment.”
FireWire 400
(6-pin)

Computer

FireWire 400
(4- or 6-pin)

DV VTR

FireWire for Uncompressed Digital Video
Interfaces such as the AJA Io connect to your computer via FireWire. However, instead
of transferring compressed DV signals, the AJA Io transfers an uncompressed component
4:2:2 signal via FireWire. The AJA Io has a wide range of digital and analog connectors,
as well as RS-422 device control.
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Important: Although this type of video interface uses FireWire, it is not used to connect
DV devices. If you want to capture or output DV video, you can connect your DV device
directly to the FireWire port on your computer.
FireWire 400
(6-pin)

Computer

BNC connector

AJA Io

Analog or digital VTR

PCI Express Video Interface Card
If you are using professional analog or digital formats (either standard definition or high
definition) without native FireWire connectivity, you need to purchase and install a PCI
Express video interface card to connect your video deck or camcorder to your computer.
Many PCI Express interface cards come with a breakout box where video, audio, and
perhaps even 9-pin remote connectors are located (rather than on the PCI Express card
itself ). Interface cards are also referred to as video cards or capture cards. This is not the
same as the video graphics card used to send signals to your main computer display.

PCI Express cards allow you to capture and output video with high data rates, such as
uncompressed standard definition (SD) and high definition (HD) video. PCI Express cards
are necessary for high-end applications such as compositing, online editing, and
uncompressed video editing. Many PCI Express cards have BNC or RCA connectors
mounted directly on the back of the card. In this configuration, you connect your video
equipment directly to the PCI Express card connectors on the back of your computer.
BNC
connector

Computer
(PCI card with
connectors)
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Analog or digital VTR
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Many PCI Express cards aren’t big enough to fit all of the necessary video and audio
connectors. In these situations, a breakout box is connected to the PCI Express card via
a multipin connector on a long cable, and the connectors are accessible on the breakout
box instead of the back of the PCI Express card. A breakout box is also useful because it
allows you to place the connectors somewhere more convenient than the back of your
computer, such as an equipment rack or a desktop.
BNC connector

Breakout box

Computer
(with PCI card)

Analog or digital VTR

USB Video Interface
USB video interfaces cannot support the high data rates required for professional video
use, so they are not commonly used. USB video interfaces are usually used for converting
analog video sources to a digital signal for capture.
USB

Computer

RCA connector

USB interface

Analog VTR

Video Signals and Connectors
When you capture and output, the type of video signal you use to connect your equipment
is a critical factor that goes into determining the quality of your video. Video camcorders,
decks, and monitors can use different types of signals, depending on the environment
they are intended for. Consumer equipment usually has limited video signal choices;
professional equipment gives you the greatest range of options.
For more information, see “Video Formats.”
Composite
Composite is the lowest common denominator of video signals. A composite signal runs
all color and brightness information on a single cable, resulting in lower-quality video
compared to the quality of other formats. Nearly all video devices have a composite input
and output. This format uses a single RCA or BNC connector.

Chapter 12 Connecting Professional Video and Audio Equipment

193

In professional editing environments, composite video signals are most commonly used
for troubleshooting, for menu outputs, and for low-quality preview monitoring. For
consumer and home use, composite signals are often used to connect VCRs or DVD
players to televisions.
RCA connector

BNC connector

S-Video
S-Video, also known as Y/C, is a higher-quality video signal used by high-end consumer
video equipment. The image looks sharper and has better color than a composite video
image because S-Video keeps the color and brightness information separate on two
cables. Most low-cost analog-to-digital video interfaces have S-Video as their
highest-quality video connector. Use care when working with S-video connectors; the
four delicate pins can be bent easily.
S-Video connector

Component YUV and Component RGB
Professional video equipment, such as Betacam SP decks, has component YUV (Y′CBCR)
video inputs and outputs. Component YUV separates color and brightness information
into three signals, which keeps the color quality more accurate than that of other systems.
Component YUV is as good as analog video gets. High-end consumer devices, such as
DVD players and televisions, have increasingly begun to support component YUV.
Note: Another form of component video, component RGB, is not as widespread on
professional equipment as component YUV.
Both component YUV and RGB signals use from three to five connectors. You can use
three BNC connectors, plus a fourth (typically labeled “genlock” or “house sync”) to send
a timing signal. Sync can also be embedded in the Y or G part of the signal (using three
connectors), a separate composite signal on a fourth connector, or separate H and V drive
signals (using five connectors). See your equipment’s documentation for more information.
YUV
Y, or green

CR, or red

CB, or blue

RGB

On some equipment,
you can switch between
RGB and YUV modes.

Component
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SCART
Consumer PAL equipment sometimes has a special connector called a SCART connector.
A SCART connector has multiple pins that run composite, component RGB, and stereo
audio in one bundle. SCART input or output can be broken up into individual connections
using special adapters available from video and home electronics stores.
SCART connector

FireWire 400
FireWire 400, also called IEEE 1394a or i.LINK, is the consumer and professional standard
for formats such as DV, DVCAM, DVCPRO, DVCPRO 50, DVCPRO HD, and HDV. FireWire is
an inexpensive and easy way to capture and output high-quality digital video using a
variety of camcorders and decks and is capable of data rates as high as 400 Mbps. Standard
FireWire cables can be up to 4.5 meters long.
There are two kinds of FireWire connectors: a 4-pin connector (typically found on video
equipment such as camcorders or decks) and a 6-pin connector (used for computer
equipment). However, some newer video equipment uses the 6-pin connector, and some
video interfaces use the 4-pin connector. See your equipment’s documentation for more
information.

FireWire 400 (6-pin)

FireWire 400 (4-pin)

FireWire 800
FireWire 800, also called IEEE 1394b, is the next generation of FireWire after IEEE 1394a, a
higher-bandwidth version capable of data transfer speeds of up to 800 Mbps. FireWire
800 is also capable of supporting cable distances of up to 100 meters.
9-pin-to-4-pin and 9-pin-to-6-pin FireWire 400 to FireWire 800 cables are available to
connect older devices to a FireWire 800 interface.

FireWire 800 (9-pin)

Note: FireWire 800 is commonly used to connect hard disks and other data peripherals
to your computer, but this connector is rarely used to connect video devices.
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SDI
Serial Digital Interface (SDI) is the standard for high-end, uncompressed digital video
formats such as D1, D5, and Digital Betacam. Many devices can send both video and
audio data through a single SDI connection.
BNC connector

HD-SDI
High Definition Serial Digital Interface (HD-SDI) is a higher-bandwidth version of SDI
designed for the extremely high data rates required by uncompressed HD video. Like
SDI, HD-SDI is capable of sending both video and audio through a single connection. The
following decks have HD-SDI interfaces: DVCPRO HD, D-5 HD, and HDCAM decks.
Some devices provide even higher data rates by pairing two HD-SDI channels together
(known as dual-link HD-SDI). Uncompressed HD RGB video and other digital cinema
formats can be transmitted using dual-link HD-SDI.
SDTI
Serial Digital Transport Interface (SDTI) is based on SDI, allowing native video formats to
be sent in real time within an SDI video stream. SDTI does not define a specific video
signal format but instead uses the structure of SDI to carry any kind of data. This allows
video facilities to use their existing SDI patchbays and routers to transfer other native
video formats, or transfer any kind of data. For example, some DV decks can transfer DV
via SDTI, which means native DV can be transferred long distances over existing coaxial
cable instead of via the usual FireWire connection. Other formats, such as HDCAM and
MPEG, can also be transferred via packets within an SDTI transport stream.
VGA
VGA interfaces use a 15-pin D-subminiature connector to transfer analog RGB video and
sync information between computers and computer CRT displays or video projectors.
This connector and signal format is being replaced by newer display formats such as DVI
and HDMI. However, adapters are available to convert between DVI and VGA.

VGA connector
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DVI
Digital Visual Interface (DVI) transfers full-resolution analog or digital signals between
computers or HD video devices and flat-panel displays or projectors. DVI connectors have
up to 24 pins plus 4 additional pins for analog signals. Not all devices use all pins, so read
the documentation included with your equipment before purchasing DVI cables and
making connections.

DVI connector

DVI supports single- and dual-link connections. Single-link DVI connections are limited
to 2.6 megapixels with a refresh rate of up to 60 Hz. Dual-link DVI connectors extend the
number of pixels that can be transferred per second to drive larger displays.

DVI-I (single link)

DVI-I (dual link)

DVI-D (single link)

DVI-D (dual link)

HDMI
High Definition Multimedia Interface (HDMI) supports both digital television and computer
signals and can also include multiple digital audio channels. HDMI devices are compatible
with single-link digital DVD signals via an adapter, although no audio or additional
metadata can be included. Many HD display devices and digital television set-top boxes
include HDMI connectors.
HDMI connector

Connecting Professional Video Devices
Regardless of what format or video interface you use, the same basic steps apply when
you connect a VTR or camcorder to your computer.

Connecting Professional SD Video Devices
If you’re using a format other than DV, such as Betacam SP or Digital Betacam, you need
to install a third-party video interface that supports the proper signal for the format you’re
using. Some video interfaces can digitize analog video input and output (for analog
formats like Betacam SP), while others capture video only if it is already digital. In either
case, the video interface encodes the video information using a codec, which may or may
not apply compression to the video data to make it smaller while stored on disk.
Compression settings used by video interfaces are typically controlled by software.
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Unlike DV video devices (which use a single FireWire cable), third-party interfaces send
and receive video, audio, and device control data on separate cables. For remote device
control connections on professional equipment, 9-pin (DB9) connectors are used.

A Recommended System Using a Third-Party Video Interface
To set up a system using a third-party video interface, you need the following equipment:
• Your computer and display
• A non-DV format video device (a camcorder or deck)
• Audio and video cables for your system
• A third-party capture interface installed in or connected to your computer
Note: Some third-party video interfaces have a breakout box connected to the card
with a special cable, which is included.
• A USB-to-serial adapter or internal modem serial port adapter
• An RS-422 video deck control cable
• A blackburst generator, with the appropriate cables to connect it to both your third-party
video interface and your video and audio devices

The following illustration shows a typical SD setup:

Audio
USB

RS-422 serial
USB-to-serial
adapter

PCI card

Breakout box

Amplified speakers

Audio

Video

Video
Computer

Analog
or digital VTR
Reference video

Blackburst
generator

Standard definition
monitor

Reference video

Following are basic instructions for connecting a video device to a third-party video
interface in your computer, as well as connecting remote device control.
To connect your VTR to your third-party video interface
1 Install a supported third-party PCI Express video interface in your computer or connect
a FireWire or USB video interface.
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For detailed information, see the documentation that came with your video interface and
your computer.
2 If you are using a PCI Express card video interface that came with a breakout box, connect
the breakout box to the PCI Express card using the cables provided.
3 Connect the video output of your VTR or camcorder to the video input of your video
interface.
4 Connect the audio outputs of your VTR or camcorder to the audio inputs of your video
or audio interface.
5 Connect the 9-pin remote device control cable to your deck, and to your breakout box
or serial port adapter.
For details, see “Connecting Remote Device Control.”
6 To genlock your video interface with your camcorder or deck:
a Connect one of the blackburst generator’s outputs (there should be several) to the
genlock or external sync input on your deck. (Usually you use a cable with a BNC
connector.)
b Connect another of the blackburst generator’s outputs to the genlock or external sync
connector on your video interface.
For more information, see “Synchronizing Equipment with a Blackburst Generator.”
7 Plug in and turn on your blackburst generator.
8 Turn on your deck.
9 If you’re using Final Cut Pro to control your camcorder or deck, make sure that the device
control switch on your VTR is set to Remote.
For more information, see “Confirming Remote Device Control Between Final Cut Pro and
Your Video Device.”
To configure Final Cut Pro to work with your video deck
Do one of the following:

µ

Choose Final Cut Pro > Easy Setup, then choose an Easy Setup that corresponds to the
video format and device control protocol of the device you connected. For more
information, see “Opening Final Cut Pro and Choosing Your Initial Settings.”

µ

Choose Final Cut Pro > Audio/Video Settings, then individually select capture, device
control, and sequence presets that correspond to your video device and format.
For details about customizing settings to work with your video device:
• For more information about capture settings and presets: See “Capture Settings and
Presets.”
• For more information about device control settings and presets: See “Device Control
Settings and Presets.”
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• For more information about sequence settings and presets: See “Sequence Settings and
Presets.”

Connecting Professional HD Video Devices
The steps for connecting HD devices are essentially the same as those for connecting SD
devices. For HD video, you need to have a video interface that supports HD video capture,
which is usually transferred via an HD-SDI signal. To connect equipment, follow the
instructions in “Connecting Professional SD Video Devices.”

Connecting Professional Component Analog Video Devices
The most prevalent component analog video format still in use today is Betacam SP. It is
an SD video format, but because it is analog, your video interface must have
analog-to-digital converters to digitize the analog signal before encoding it and writing
a digital media file to the computer hard disk. Unlike digital capture interfaces,
analog-to-digital interfaces often allow you to adjust luma and chroma levels (using
controls in the Log and Capture window) when you digitize. For more information about
calibrating an analog signal before digitizing it, see “Measuring and Setting Video Levels.”
The steps for connecting an analog VTR to a video interface are essentially the same as
those for connecting digital SD and HD devices. The main difference is that you need to
make three physical connections, one for each of the three analog video components:
Y, R-Y, and B-Y (also called YUV or Y′CBCR, depending on the country and the specifics of
the format). For more information, see “Video Formats.” To connect equipment, see
“Connecting Professional SD Video Devices.”

Connecting Consumer Analog Video Devices
If you want to digitize video from an analog consumer format, such as VHS or 8 mm video,
you need a video interface that has an analog composite video input. Also, older consumer
decks rarely support remote device control, which means you can’t remotely control the
deck or capture timecode from these formats. If you need the ability to recapture the
video accurately using timecode, it’s often easiest to dub (copy) the video to a digital
format like DV, or a professional format you are using for your project.
There are fairly inexpensive capture interfaces that can accept an analog composite input
and convert it to a DV video signal transferred via FireWire. Some more expensive interfaces
may also accept an analog component input.
For more information about composite video, see “Video Formats.”

Connecting Non-DV Devices to a DV Converter
You can use a DV converter to convert a device in a non-DV format, such as Betacam SP
or Digital Betacam, to DV. This allows you to capture footage using the built-in FireWire
port on your computer. However, unlike a complete DV FireWire setup, this kind of deck
still requires serial (RS-422 or RS-232) remote device control.
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This kind of setup is used mainly for low-resolution capture and offline editing. Because
Final Cut Pro can edit DV video natively, you can capture your video as if it were DV
footage, edit at DV resolution, and then recapture only the necessary media files for your
finished movie at full resolution using a third-party video interface.
Important: If you plan to recapture footage later, make sure timecode is captured
accurately. For more information about calibrating your device control and timecode,
see “Device Control Settings and Presets.”

A Recommended Non-DV-to-DV System Using Serial Device Control
You need the following equipment:
• Your computer and display
• A non-DV format playback device, such as a Betacam SP or Digital Betacam deck
• An analog-to-DV or digital-to-DV converter
Note: Some DV camcorders and VTRs can also act as an analog-to-DV converter.
• A 4- to 6-pin FireWire cable, available at an electronics store or an Apple Retail Store
• A USB-to-serial adapter or internal modem serial port adapter
• An RS-422 video deck control cable

The following illustration shows a typical non-DV-to-DV setup:

Audio
USB

RS-422 serial
USB-to-serial
adapter

Amplified speakers

Audio
FireWire
Computer

Video

Video
DV converter

Analog or digital VTR

Standard definition
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To connect your VTR to your analog-to-DV or digital-to-DV converter
1 With your DV converter turned off, connect the 6-pin connector on the FireWire cable to
the FireWire port on your computer.
2 Connect the 4-pin connector on the FireWire cable to the DV converter.
3 Connect the video output of your VTR to the video input of the DV converter.
4 Connect the audio output of your VTR to the audio input of the DV converter.
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Note: The DV converter mentioned above could possibly be a DV VTR that can convert
analog video and audio input to DV FireWire. Some decks need to be in Record mode to
allow this conversion. Other decks may not support this.
5 Connect the remote device control.
For details, see “Connecting Remote Device Control.”

Audio Interfaces
By default, Final Cut Pro uses one of the built-in audio interfaces included with your Mac
computer, such as a stereo headphone jack or a stereo speaker output. If you need to
capture audio from a professional device, you may need a separate third-party interface.

Built-in Audio Interfaces
The following audio interfaces are included with your Mac computer (though some
computer models may not include all interfaces).
Built-in Analog Audio
You can capture and output audio using the built-in audio ports on your computer. The
built-in audio interface on your computer usually uses a stereo miniplug connector. If
necessary, you can buy an adapter to connect the miniplug connector to two stereo RCA
or 1/4" tip-ring-sleeve (TRS) connectors, which can then be connected to your video or
audio device.
Stereo miniplug
connector

Computer

RCA connector (2)

Analog audio or video device

For basic mixing, you can connect the built-in audio output on your computer to a pair
of external speakers. This gives you two output channels, which can be configured for
dual mono or stereo playback.

202

Chapter 12 Connecting Professional Video and Audio Equipment

Built-in S/PDIF Digital Audio
Some computers have built-in S/PDIF optical digital ports (sometimes called TOSLINK)
that you can connect to some CD players, DAT recorders, and other digital audio devices.
TOSLINK optical
digital connector

Computer

Audio or video device

DV FireWire
If your sequence uses a DV codec, you can output audio via the FireWire port on your
computer. This allows you to use a DV deck, DV camcorder, or DV-to-analog converter
as an audio interface. In this case, you connect your FireWire cable to your DV device and
then connect the audio outputs of the DV device to external speakers or a television
monitor.

Choosing a Third-Party Audio Interface
Before you purchase a separate audio interface, consider that most third-party video
interfaces may have enough audio connectors to meet your requirements. You should
consider a separate audio interface when:
• You are trying to capture or output more audio channels than your built-in audio
interface or third-party video interface supports
• You need to capture or output in a format not supported by your existing interfaces
(for example, if you need to capture audio at a sample rate of 96 kHz but your video
interface only supports a sample rate of 48 kHz)
Benefits of a Third-Party Audio Interface
Third-party audio interfaces can provide many more features than your computer’s built-in
interfaces, such as:
• More than 2 audio channels—8 channels is common, but some interfaces have 24 or
more input and output channels
• Professional connectors such as XLR or 1/4" TRS
• High-quality analog-to-digital and digital-to-analog converters supporting sample rates
as high as 192 kHz and 24 bits per sample
• Support for analog and digital audio formats
• Stable, “jitter-free” digital audio clocks
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Tips for Selecting a Third-Party Audio Interface
When you select an audio interface, make sure it has the following:
• Connectors that match your audio equipment, such as XLR, 1/4" TRS, RCA, or TOSLINK
• Support for audio signal formats that your audio equipment uses, such as AES/EBU,
S/PDIF, or ADAT Lightpipe
• Enough audio inputs and outputs to connect your equipment
• Sample rate and bit depth at least as high as your audio equipment. For example, if
you have an audio device with a sample rate of 96 kHz and 24 bits, your audio interface
should at least match this.
Important: If you are considering purchasing an interface, make sure it supports Mac OS X
Core Audio. Final Cut Pro supports any audio interface that is compatible with Mac OS X
Core Audio.

USB Audio Interfaces
There are a wide variety of USB audio interfaces available. Most support two or four audio
channels at one time. USB audio interfaces vary in quality considerably, so take some
time to research before you purchase. The connectors on USB interfaces vary; some
interfaces have RCA connectors and others have both XLR and 1/4" TRS connectors. Very
inexpensive USB audio interfaces may have only a stereo miniplug connector.
RCA connector (2)
USB

Computer

Audio interface

Analog or digital VTR

Make sure you don’t exceed the total bandwidth of the USB bus by connecting too many
devices. USB 1.1 has a fairly low data rate, so be careful not to add too many USB items
to the bus. Also, USB hubs can potentially cause audio problems. If you are having audio
problems with a USB interface connected to a hub, try removing USB devices and
eliminating the hub from the connection.
USB 2.0 audio interfaces are also available. Because USB 2.0 devices can handle high data
rates (similar to FireWire 400), you can treat them similarly to FireWire audio interfaces.
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FireWire for Digital Audio
As an alternate to PCI Express cards, many manufacturers now offer audio interfaces that
connect to your computer’s FireWire port. These are not DV devices, but merely devices
that use FireWire as a means of transferring digital audio data. FireWire interfaces are
more convenient to switch between computers than are PCI Express cards, and they can
be used with both desktop and portable computers. A FireWire interface typically supports
ten or more inputs, and at least eight outputs.

FireWire 400
(6-pin)

Computer

XLR connector (2)

Breakout box

Analog or digital VTR

Important: Although a FireWire bus supports a very high data rate, connecting too many
devices, such as a DV video device, a FireWire hard disk, and a FireWire audio interface,
could potentially exceed the bus speed, resulting in dropped video frames or audio with
missing samples.

PCI Express Audio Interface Card
Of all the audio interfaces, PCI Express audio interfaces provide the maximum transfer
speed and can support many channels with high sample rates. Many audio interfaces
come with a separate breakout box where the audio input and output connectors are
located.
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PCI Express Audio Interface Card with Built-in Connectors
Some PCI Express audio interface cards have audio connectors attached directly to the
card. Because there is limited space on a PCI Express card to mount audio connectors,
RCA connectors are typically used.
RCA connector (2)

Computer
(PCI card with
connectors)

Audio or video device

PCI Express Audio Interface Card with Breakout Box
The majority of PCI Express audio interface cards have a breakout box with a large number
of XLR or 1/4" TRS connectors. The breakout box is attached to the PCI Express card via
a long cable with a multipin connector. The long cable allows you to place the breakout
box in a convenient location, so you can easily connect and disconnect your video and
audio devices without going behind your computer.
XLR connector (2)

Computer
(with PCI card)

Breakout box

Analog or digital VTR

Audio Connectors and Signal Formats
You can use a variety of analog and digital audio connection options and signal formats.

Analog Audio Connectors and Signal Formats
Different audio connectors are suited for different purposes. Audio connectors are often
indicative of the kind of signal they transmit. However, there are enough exceptions that
it’s important to know what kind of audio signal you are connecting, in addition to the
connector type. An important distinction is whether an audio connector carries a balanced
or an unbalanced signal.
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1/8" Mini Connectors
These are very small, unbalanced audio connectors. Many computers have 1/8" mini
inputs and outputs at –10 dBV line level, and many portable audio devices such as CD
players, iPod digital music players, and MP3 players use these connectors for headphone
outputs. Portable MiniDisc and DAT recorders often use 1/8" mini connectors for
connecting microphones.
Mono miniplug connector

Stereo miniplug connector

Note: Some Mac computers and portable audio recorders also use a connector that
combines both a stereo miniplug and a 1/8" optical digital connection (see “S/PDIF”) in
a single jack.
RCA Connectors
Most consumer equipment uses RCA connectors, which are unbalanced connectors that
usually handle -10 dBV (consumer) line levels.
RCA connector

1/4" Tip-Sleeve Connectors
1/4" tip-sleeve (TS) connectors (also called 1/4" phone connectors) with a tip and a sleeve
are unbalanced connectors often used for musical instruments like electric guitars,
keyboards, amplifiers, and so on.
1/4" tip-sleeve (TS) connector

1/4" Tip-Ring-Sleeve Connectors
Professional equipment often uses 1/4" tip-ring-sleeve (TRS) audio connectors with +4
dBu line level. 1/4" TRS connectors connect to three wires in an audio cable—hot, neutral,
and ground—and usually carry a balanced audio signal. In some situations, the three
wires may be used to send left and right (stereo) signals, making the signals unbalanced.
1/4" tip-ring-sleeve (TRS) connector

Note: Tip-sleeve and tip-ring-sleeve connectors look almost identical. Some audio devices
(especially mixers) accept a TS connector in a TRS jack, but you should always check the
equipment documentation to be sure. Remember that most 1/4" TS connectors connect
to –10 dBV line level equipment, whereas 1/4" TRS connectors usually expect a +4 dBu
line level.
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XLR Connectors
These are the most common professional audio connectors. They almost always carry a
balanced signal. Many cables use an XLR connector on one end and a 1/4" TRS connector
on the other. The signal may be microphone level (when using a microphone) or +4
dBu/dBm (professional) line level.
XLR connector

Digital Audio Connectors and Signal Formats
Although digital audio signals are completely different from analog audio signals, the
same connectors are often used for convenience. For example, an XLR connector can be
used to carry an analog audio signal or an AES/EBU digital audio signal.
AES/EBU
The AES/EBU digital audio specification was jointly developed by the Audio Engineering
Society (AES) and the European Broadcasting Union (EBU). AES/EBU audio signals typically
use XLR connectors, but 25- or 50-pin D-subminiature connectors can also be used for
multiple channels on interfaces or mixers.
Traditionally, AES/EBU sample rates were limited to 44.1 and 48 kHz at up to 24 bits per
sample. However, a “dual wire” mode allows some equipment to pair AES/EBU connectors
to increase the sample rate. Some newer devices also support “single wire” mode with
sample rates up to 192 kHz.
S/PDIF
Sony/Philips Digital Interface Format (S/PDIF) is a consumer-level variation of the AES/EBU
digital audio protocol. S/PDIF audio data can be transmitted several ways, including:
• Via coaxial cables with an RCA connector
• Via optical TOSLINK
Connectors for S/PDIF signals are found on most consumer digital equipment, such as
DAT recorders, CD players, DVD players, MiniDisc equipment, and some audio interfaces.
Dolby Digital (AC-3)
Dolby Digital (AC-3) is a compressed digital audio signal format used for transmission of
5.1-channel surround sound. Mono and stereo signals can also be carried in this format.
Typically, this audio signal is embedded within a S/PDIF signal and carried via TOSLINK
or coaxial cables with RCA connectors.
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DTS
Digital Theater System (DTS) is a compressed digital audio signal format used for
transmission of 5.1-channel surround sound. This format is primarily used in movie theaters
and on DVD releases. More recent variations of DTS support more than six channels of
audio. This audio signal is usually embedded within a S/PDIF signal and carried via TOSLINK
or coaxial cables with RCA connectors.
TOSLINK
TOSLINK is an optical digital audio format developed by the Toshiba Corporation. These
digital audio formats can be transmitted via TOSLINK optical cables and connectors:
• S/PDIF
• ADAT Lightpipe
Some Mac computers have a single interface that combines a TOSLINK connector with
an analog stereo miniplug.
TOSLINK connector

ADAT Lightpipe
ADAT Lightpipe is an eight-channel digital audio format developed by Alesis. This signal
format uses TOSLINK optical connectors. Eight channels are supported at sample rates
of 44.1 and 48 kHz using 24 bits per sample. Higher sample rates are available by pairing
channels. (This format is sometimes called sample multiplexing, or S/MUX.) For example,
a sample rate of 192 kHz is possible, but the number of channels is reduced to two.
However, not all equipment supports channel pairing and increased sample rates.
TDIF
Tascam Digital Interface (TDIF) is a signal format for transferring digital audio between
Tascam digital multitrack recorders or digital mixers. A 25-pin D-subminiature connector
is used. Eight channels are supported at sample rates of 44.1 and 48 kHz using 24 bits
per sample. Higher sample rates are available by pairing channels.

TDIF connector

About Analog Audio Levels
There are six basic kinds of analog audio levels found on most equipment:
• Microphone level: Around 50 or 60 dB less than line level. When you use a microphone,
the level is very low, requiring a preamplifier to raise the signal to line level before it
can be recorded or processed. Most audio mixers, cameras, and professional portable
recording devices have built-in preamplifiers.
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• Instrument level: Between microphone and line level, around –20 dBV or so. Guitars
and keyboards usually output at instrument level.
• Line level (consumer): Consumer line level is output at –10 dBV.
• Line level (professional): Professional line level is output at +4 dBu (or dBm in older
equipment).
• Speaker level: This signal varies considerably depending on the amplifier used, but it is
very strong compared to the others because it is used to drive speakers.
• Headphone level: This signal is like speaker level, but much lower. The sole purpose of
this signal is to drive stereo headphones.
About Units of Analog Audio Measurement
Professional audio equipment typically uses higher voltage levels than consumer
equipment, and it also measures audio on a different scale. Keep the following points in
mind when using consumer and professional audio equipment together:
• Professional analog devices measure audio using dBu (or dBm in older equipment).
0 dB on the audio meter is usually set to +4 dBu, which means optimal levels are 4 dB
greater than 0 dBu (.775 V), or 1.23 V.
• Consumer audio equipment measures audio using dBV. The optimal recording level
on a consumer device is –10 dBV, which means the levels are 10 dB less than 0 dBV
(1 V), or 0.316 V.
Therefore, the difference between an optimal professional level (+4 dBu) and consumer
level (–10 dBV) is not 14 dB, because they are using different signals. This is not necessarily
a problem, but you need to be aware of these level differences when connecting consumer
and professional audio equipment together.
About Balanced Audio Signals
Audio cables can be either balanced or unbalanced, depending on their intended use.
For long cable runs, especially when using relatively low microphone levels, a three-wire
balanced audio circuit reduces noise. Balanced audio cables use the principle of phase
cancelation to eliminate noise while maintaining the original audio signal.

210

Chapter 12 Connecting Professional Video and Audio Equipment

A balanced audio cable sends the same audio signal on two wires, but inverts the phase
of one signal by 180 degrees.

Original signal

Inverted signal
(reverse phase)

When noise is introduced into the cable, it is introduced equally to both the original and
the inverted signal.

Noise on line
(affects both signals)

When the signal arrives at its destination, the inverted signal is put back in phase and
both signals are combined. This puts the original and inverted signals back in phase, but
it causes the noise signals on each line to be out of phase.

Inverted signal
(inverted again)
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Now, both audio signals are in phase, but the noise is inverted, causing the noise to be
canceled. At the same time, the original signal gets a little stronger because it is sent on
two wires and combined. This helps compensate for the reduction in signal strength that
occurs naturally on a long cable run.

Combined signals
(noise eliminated)

Any noise introduced into the cable across its long run is almost completely eliminated
by this process.
Note: Unbalanced cables have no way of eliminating noise and are therefore not as robust
for long-distance cable runs, microphone signals, and other professional uses.

Connecting Professional Audio Devices
The steps for connecting audio playback and recording devices are similar to the steps
for connecting professional video devices. Many professional audio-only devices such as
DAT recorders and Tascam DA-88/DA-98 multitracks support remote device control and
audio insert editing.
If you plan to capture footage using separate video and audio interfaces, you may need
to set up additional synchronization between your audio device and audio interface. For
more information, see “Synchronizing Equipment with a Blackburst Generator.”

Connecting Professional Digital Audio Devices
Professional digital audio devices often use balanced XLR connectors. Each XLR connector
carries two AES/EBU digital audio channels. Connect the digital audio outputs of your
video or audio device to your audio interface (or its breakout box). If your video interface
has the appropriate connectors, you can also connect the audio outputs of your device
to the audio inputs on the video interface.
Note: Professional analog audio devices also use XLR connectors, but the signal is
incompatible with AES/EBU digital audio.

Connecting Consumer Digital Audio Devices
Consumer devices such as CD players, MiniDisc recorders, and some DAT recorders use
either an optical or RCA (coaxial) connector for S/PDIF digital audio. S/PDIF carries two
channels of digital audio, usually at a sample rate of 44.1 or 48 kHz and a bit depth of
16 bits. Connect the S/PDIF output of your audio device to the S/PDIF input on your audio
or video interface, if available.
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Connecting Professional Analog Audio Devices
Professional analog audio devices use balanced XLR or 1/4" TRS connectors for each audio
channel. Most audio interfaces that support multiple audio channels come with a breakout
box that contains all the connectors.

µ

To connect multiple analog audio channels from a VTR or audio device to a multichannel
audio interface
Connect each audio output channel on the VTR or audio device to each audio input
channel on the audio interface or corresponding breakout box, if included.

A Recommended Audio System Using a Third-Party Audio Interface
To set up a system using a third-party audio interface, you need the following equipment:
• Your computer and display
• A device-controllable audio deck, such as a DAT or multitrack deck
• Appropriate analog cables for your system
• An audio interface
Note: Some third-party PCI Express interface cards have a breakout box connected to
the card with a special cable.
• A USB-to-serial adapter or internal modem serial port adapter
• A blackburst generator, with the appropriate cables to connect it to both your third-party
audio interface and your audio deck
• An RS-422 video deck control cable

Synchronizing Equipment with a Blackburst Generator
With most professional editing systems, you capture video, audio, and timecode via
separate cables. It’s important that when you capture, the VTR and the video and audio
interfaces are synchronized via a common video timing signal. If digital audio samples
and video lines and frames are not precisely synchronized, they eventually drift apart
because they are captured at slightly different rates.
Using a common sync source is especially important when you are independently
capturing long segments of video and audio to synchronize together later. If your audio
deck and capture interface are not both receiving the same timing information, the sync
between the audio and video portions of clips might drift over time.
A blackburst generator provides a common timing signal (or clock) to lock together the
timing clocks of all devices in a system. This is sometimes referred to as external sync or
house sync because every device in an entire facility can be timed to this common
reference.
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Professional VTRs, camcorders, audio devices, and interfaces often have the ability to
accept sync signals from an external device. These connectors are labeled “genlock” (short
for generator lock), “external sync,” “reference input,” or “reference video.” On some
equipment, the normal composite video input of a device can be used to lock to external
sync.
Important: To synchronize your video or audio devices and interfaces, they must all
accept an external clock source (such as a blackburst generator).
When you genlock a deck and a video or audio capture interface, one output of the
blackburst generator should be connected to the external sync input of the video or
audio deck, and another output should be connected to the external sync input of your
audio interface.

Reference video

Blackburst
generator

Reference video

PCI card
Audio

Computer

Breakout box

Video

Analog or digital VTR

To connect your audio deck outputs to a third-party audio interface for synchronized,
genlocked audio capture
1 Install a supported audio interface card in your computer, or connect a supported audio
interface.
For more information, see the documentation that came with the audio interface and
your computer.
2 If you are using a PCI Express card audio interface that came with a breakout box, connect
the breakout box to the PCI Express card using the included cable.
3 Connect the audio outputs of your audio device to the audio inputs of your audio interface.
4 Connect the remote device control cable.
5 To genlock your audio deck to your audio or video interface:
a Connect one of the blackburst generator’s outputs (there should be several) to the
genlock or external sync input on your audio deck.
b Connect another of the blackburst generator’s outputs to the genlock or external sync
connector on your video or audio capture interface (depending on which one you are
using to capture audio).
6 Plug in and turn on your blackburst generator.
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7 If you are using a blackburst generator, choose Final Cut Pro > User Preferences, and in
the General tab of the User Preferences window, make sure that “Sync audio capture to
video source if present” is selected.
8 If you’re using Final Cut Pro to control your audio deck, make sure that the device control
switch on the equipment is set to Remote.
For more information, see “Choosing Settings and Preferences.”
9 Once your deck and video capture interface are genlocked together, you still need to
calibrate the timecode capture offset (found in the Device Control Presets tab in the
Audio/Video Settings window) prior to capture.
For more information about calibrating timecode for capture, see “Device Control Settings
and Presets.”

Connecting Remote Device Control
Device control enables communication between your VTR or camcorder and Final Cut Pro,
allowing you to remotely control your video deck for capturing and output. A VTR can
tell Final Cut Pro where a tape is currently positioned, and Final Cut Pro can tell the VTR
to cue the tape to a new position, pause, rewind, fast-forward, and even record during
output. Positional information is conveyed via timecode recorded on the tape. Also,
timecode information is sent via a device control connection. This is critical for logging,
batch capturing, and frame-accurate output to tape.

DV FireWire for Device Control
In addition to video and audio data, DV devices can transfer timecode and device control
via FireWire. This makes connecting DV devices to your computer as simple as connecting
a single FireWire cable. For more information, see “Confirming Remote Device Control
Between Final Cut Pro and Your DV Device.”

Using RS-422 Serial Remote Device Control
For professional equipment, device control data is transferred between a serial port on
your computer and a 9-pin D-subminiature (D-sub) connector on a professional video or
audio device. Mac computers have two types of serial ports: USB ports and internal modem
ports. With the appropriate adapters, either of these ports can be used to send and receive
device control information via serial RS-422 or RS-232 protocols.
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To connect a USB-to-serial adapter for remote device control between your computer
and a VTR
1 Connect a USB-to-serial adapter to a USB port on your computer.
Important: For best results, always connect a USB-to-serial adapter directly to your
computer, not to a USB hub connected to your computer.
2 Connect the 9-pin connector to your device-controllable camcorder or deck, and connect
the other end to the USB-to-serial adapter.
To connect an internal modem serial port adapter for remote device control between
your computer and a VTR
1 Install an internal modem serial port adapter in your computer’s internal modem port.
2 Connect the 9-pin connector to your device-controllable camcorder or deck, and connect
the other end to the modem serial port adapter.

Confirming Remote Device Control Between Final Cut Pro and Your
Video Device
If you are using a DV device and Final Cut Pro has communication problems with the
device, see “Confirming Remote Device Control Between Final Cut Pro and Your DV
Device.”
If Final Cut Pro has communication problems with your professional video device, try the
following:
• Make sure your 9-pin cable is properly connected and plugged in all the way.
• If you are using a USB-to-serial adapter, make sure it is properly connected and that
any necessary software drivers are installed.
• If your deck has a Local/Remote switch, make sure it’s set to Remote.
• Make sure the appropriate protocol for your device is selected in the device control
preset. (See “Device Control Settings and Presets.”)
• Quit Final Cut Pro, shut down your computer, turn your camcorder or deck off and on,
then restart your computer.

Choosing a Device Control Preset
A device control preset contains settings that define how Final Cut Pro communicates
with a particular camcorder or VTR. Before Final Cut Pro can remotely control your camera
or VTR during video capture and output, you need to choose a device control preset that
matches the device.
For example, if you are using a DV device connected via FireWire, you should choose a
FireWire NTSC or FireWire PAL device control preset. Final Cut Pro has only one device
control preset in effect at a time, but you can change it in several ways:
• Choose an Easy Setup. (Easy Setups contain device control presets.)
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• Choose a device control preset in the Log and Capture window.
• Choose a device control preset in the Audio/Video Settings window.
To choose a device control preset in the Log and Capture window
1 Choose File > Log and Capture, then click the Capture Settings tab.
2 From the Device Control pop-up menu, choose a device control preset that corresponds
to your connected device.
For an explanation of each device control preset, see “Device Control Settings and Presets.”
To choose a device control preset in the Audio/Video Settings window
1 Choose Final Cut Pro > Audio/Video Settings.
2 Do one of the following:
• In the Summary tab, choose a device control preset from the Device Control Preset
pop-up menu.
• In the Device Control Presets tab, click in the column to the left of the device control
preset you want to select.
3 Click OK.
Because an Easy Setup contains a device control preset, you can also change the device
control preset by changing the Easy Setup. However, this may also change the capture
and sequence presets.

Understanding Device Control Status Messages
At the bottom of the Log and Capture window, the device status area shows the readiness
of camcorders and decks being controlled by Final Cut Pro.

Device status

The device status area can display any of these messages:
• VTR OK: This indicates your equipment is connected and working properly.
• No Communication: This indicates one of the following:
• Final Cut Pro has not established communication with your deck or camcorder.
• Your VTR or camcorder is a non-controllable device, so it has no ability to be remotely
controlled.
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If you have a device-controllable camcorder or deck and you see this status, check to
make sure that you’re using the right FireWire or serial control cables and that they’re
connected properly. Also make sure your device is turned on.
• VTR in Local: Your device is set to work only with its built-in playback buttons. Set the
switch on your camcorder or deck from Local to Remote and you’ll be able to remotely
control the device from Final Cut Pro.
Note: Decks with serial device control have a switch that lets you choose Local or
Remote control.
• To control your deck with Final Cut Pro: Set the switch to Remote.
• To use the transport buttons on your deck to control the deck: Set the switch to Local.
• Not Threaded: This indicates that you have a camcorder or deck connected to your
computer, but there’s no tape in the deck or the tape is still loading.
• Tape Trouble: This indicates that your tape may be jamming. It’s important to
immediately stop playback and remove your tape from the deck, if possible. If you can’t
eject your tape, take your camcorder or deck to a qualified technician. For more
information, see the documentation that came with your video equipment.

Switching Device Control Presets When Changing Decks
If you have multiple video decks that you regularly capture from or output to, and each
one is a different format, you can use device control presets to easily change your device
control settings each time you use a different deck. For example, the timecode offset may
be different from one deck to another, or one deck may require more pre-roll time before
its motor stabilizes to provide a stable video signal for capture.
You can create a different device control preset for every deck you use. When you switch
decks, you can simply change the device control preset to set up quickly. For more
information, see “Device Control Settings and Presets.”
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Determining Your Hard Disk
Storage Options

13

This chapter covers the following:
• Working with Scratch Disks and Hard Disk Drives (p. 219)
• Data Rates and Storage Devices (p. 219)
• Determining How Much Space You Need (p. 221)
• Choosing a Hard Disk (p. 223)
• Types of Hard Disk Drives (p. 224)
To make the most of your Final Cut Pro editing system, you need to make appropriate
choices about hard disk selection and maintenance.

Working with Scratch Disks and Hard Disk Drives
By default, Final Cut Pro uses the hard disk on which the application is installed as your
scratch disk to store captured and render files. Ideally, you should use a hard disk other
than your main system disk as your scratch disk. Depending on how much space you
need for your media, you can have up to 12 scratch disks in your Final Cut Pro editing
system.
Important: If you have multiple hard disks and partitions, make sure they do not have
similar names, or you could encounter problems during capture. For more information,
see “Using Multiple Hard Disks.”

Data Rates and Storage Devices
The data rate of the video you capture depends on the format of the source video and
the codec you use for capture. If you are capturing low data rate video, chances are you
can use more inexpensive storage devices. If you need to capture extremely high data
rate video, you may need a faster hard disk. Here are some examples of data rates for
common capture formats:
Format

Typical data rate

OfflineRT (using Photo JPEG)

Varies between 300 and 500 KB/sec.
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Format

Typical data rate

25:1 Motion JPEG (M-JPEG)

1 MB/sec.

DV (25)
HDV (1080i)

3.6 MB/sec.

DVCPRO 50

7.2 MB/sec.

DVCPRO HD (1080i60)
DVCPRO HD (720p60)

14.4 MB/sec.

DVCPRO HD (720p24)

5.8 MB/sec.

2:1 Motion JPEG (M-JPEG)

12 MB/sec.

Uncompressed SD video

24 MB/sec.

Uncompressed 8-bit
1080 29.97i HD video

124 MB/sec.

Uncompressed 10-bit
1080 29.97i HD video

166 MB/sec.

Whatever disk drive technology you decide to use, your storage disk’s sustained transfer
speed must be fast enough to keep up with the data rate. Depending on the data rate
of the video you’re capturing, a single drive may or may not be enough.
For example, if you plan to capture uncompressed SD video at 24 megabytes per second
(MB/sec.), it’s unlikely that a single hard disk will be able to record the data fast enough.
Even if you somehow successfully get the data on disk, Final Cut Pro may drop frames
during playback or output.
If your hard disk or its connection to your computer does not support the data rate of
your video format, you need to consider three factors:
• Sustained transfer speed: This is a measurement of how fast data can be written to a
disk in MB/sec. When you use a video interface that utilizes M-JPEG compression, the
sustained transfer speed of your hard disk determines the maximum quality of the
video you can capture. Disks with a higher sustained transfer speed allow you to capture
video media files with a higher data rate, which results in higher visual quality.
• Seek time: This is a measurement of how quickly data stored on the disk can be accessed
in milliseconds (ms). Low seek times are important when playing back an edited
sequence of clips, because the disk must spend a lot of time searching for the next clip
to play.
• Spindle speed: A faster spindle speed increases a disk’s sustained transfer rate. (Typical
multimedia disks run at 7200 revolutions per minute, or rpm.) However, the faster a
hard disk runs, the more it heats up, so ventilation is important when you install disks
internally or in external enclosures.
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Note: Removable media drives such as Jaz, Zip, and CD-RW drives are not suitable for
video capture and playback because of their low data transfer rates.

Determining How Much Space You Need
The amount of disk space you need depends on the specifications of the video format
you are using for editing. In some cases, you can capture video at a lower quality (which
saves disk space) for rough editing and then recapture only what you need at higher
quality to create the finished movie. This process is known as offline/online editing. For
more information, see “Offline and Online Editing.”

Know Your Shooting Ratio
Remember that when you start editing a movie, you need to capture much more media
than you will use in the final movie. The ratio between the amount of footage you begin
with and the final duration of the movie is called the shooting ratio. When you are
estimating how much disk space you need for a project, calculate it based on the total
amount of media you plan to capture and use during editing, not the intended duration
of the final movie.

Planning for Additional Media Files
In addition to space for captured files and project files, you need extra space for render
files, graphics, movie files created in other applications (such as animations), additional
audio files, and so on. A loose rule of thumb to determine how much space you need is
to multiply the amount of space needed for your finished program by five.
Ultimately, the amount of extra space you reserve depends on how much additional
media you create during editing. For example, if you use hardly any effects, additional
render files may not be a factor. If you are using only a few graphics files and little
additional audio, these may not be a concern, either.
Keep in mind that although real-time effects don’t require additional drive space for
rendering, you still need to render the effects at high quality for final output, so at that
point you need enough disk space for render files.

Calculating Hard Disk Space Requirements
You can use the table below to estimate how much disk space you need for your project.
Video data transfer rates

30 sec.

1 min.

5 min.

10 min.

30 min.

60 min.

500 KB/sec.
OfflineRT (using Photo JPEG)

15 MB

30 MB

150 MB

300 MB

900 MB

1.8 GB

1 MB/sec.
Offline-quality M-JPEG

30 MB

60 MB

300 MB

600 MB

1.8 GB

3.6 GB
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Video data transfer rates

30 sec.

1 min.

5 min.

10 min.

30 min.

60 min.

3.6 MB/sec.
DV-format video
HDV (1080i)

108 MB

216 MB

1.08 GB

2.16 GB

6.5 GB

13 GB

6 MB/sec.
Medium-quality M-JPEG

180 MB

360 MB

1.8 GB

3.6 GB

10.8 GB

21.6 GB

11.75 MB/sec.
DVCPRO HD 1080i

352.5 MB

705 MB

3.4 GB

6.9 GB

20.7 GB

41.3 GB

12 MB/sec.
High-quality 2:1 M-JPEG

360 MB

720 MB

3.6 GB

7.2 GB

21.6 GB

43.2 GB

24 MB/sec.
Uncompressed SD video

720 MB

1.4 GB

7.2 GB

14.4 GB

43.2 GB

86.4 GB

121.5 MB/sec.
8-bit uncompressed 1080 29.97i
HD video

3.6 GB

7.3 GB

36.5 GB

72.9 GB

218.7 GB

434.4 GB

Sample Calculation for Disk Space Requirements
Suppose you want to create a music video that’s approximately four minutes long using
DV video for capture, editing, and output. Consider a shooting ratio of 15:1, meaning you
shoot 15 times more footage than you will use in the final movie.
Stage 1: Determining the Total Duration of Media Captured to Disk
15 x 4 minutes = 60 minutes
Stage 2: Determining the Data Rate Requirements for DV Media
3.6 MB/sec. video data rate x 60 seconds = 216 MB/min.
Stage 3: Calculating Disk Space Requirements for Media
60 minutes x 216 MB/min. = 12,960 MB
12,960 MB ÷ 1024 MB per GB = 12.66 GB
Stage 4: Multiplying the Final Movie Length By a Safety Margin of 5 for Extra Files
4 minutes x 216 MB/min. = 864 MB x 5 = 4320 MB
4320 MB ÷ 1024 MB per GB = 4.22 GB
Stage 5: Calculating the Total Disk Space Requirements
12.66 GB + 4.22 GB = 16.88 GB
Round your calculation up to 17 GB to be safe. This is the amount of disk space you’ll
need for this one project. If you plan to work on multiple projects at the same time,
estimate the amount for each project and add these numbers together.
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Note: These calculations are also important when planning how to archive your projects
when they are finished, though many people choose to archive only the project file and
not back up their media files. (Because the original footage is stored on tape, you can
always recapture the footage if necessary.)

Choosing a Hard Disk
The disk that contains your computer’s operating system is called the startup disk or boot
disk. In addition to the operating system, the startup disk also stores your applications
(such as Final Cut Pro), your application preferences, system settings, and documents.
Because the files on the startup disk are your most critical data, maintaining the startup
disk is vital.
Because digital media (especially high data rate video) makes your disks work harder,
you should use dedicated disks for capturing and playing back your digital video and
other media files. Consider your media disks as storage units that work long, hard hours,
while your startup disk keeps your system properly organized. If a disk is going to
malfunction, it’s better if your critical data is separate from your replaceable media files.
Depending on what kind of computer you are using, you may be able to use internal and
external hard disks to store your media files. Each has benefits and drawbacks.
Internal Disks
• May be less expensive because they don’t have external cases or require their own
power supplies
• Are inside your computer, causing less noise
• Are limited by the expansion capabilities of your computer and the heat buildup they
cause
Warning: Heat buildup in your computer can result in dropped frames during capture
and playback and can ultimately cause the failure of one or more disk drives. Consult the
documentation that came with your computer for information about the maximum
number of internal drives that can be installed.
External Disks
• Let you easily switch between projects by switching disks connected to the computer
• Let you move a project quickly from one computer system to another in a different
location
• May be more expensive because of external cases and power supplies
• May be noisy
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Types of Hard Disk Drives
Disk drive technologies have advanced quickly over recent years, making terabytes of
storage available at reasonable cost. When researching the type of hard disk storage
system appropriate for your needs, keep in mind the format and data rate of the video
you’re capturing. Depending on whether you work as an independent video editor or
collaborate with others, the amount of storage you require and the bit rate of data transfer
will be important factors to match up with your storage needs. Outlining all of the hard
disk storage technologies is beyond the scope of this documentation, but four common
choices include:
• ATA
• FireWire
• SCSI
• RAID and Fibre Channel

ATA Disk Drives
There are two kinds of ATA disks:
• Parallel (Ultra) ATA disks: These are found in Power Mac G4 computers.
• Serial ATA disks: These come with Power Mac G5 computers.
ATA disks do not offer as high a level of performance as LVD or Ultra160 SCSI disks. If you
plan to use Ultra ATA disks, make sure that:
• The sustained transfer speed is 8 MB/sec. or faster
• The average seek time is below 9 ms
• The spindle speed is at least 5400 rpm, although 7200 rpm is better
Parallel (Ultra) ATA Disks
Many editors use parallel ATA (PATA) disks (also called Ultra DMA, Ultra EIDE, and
ATA-33/66/100/133) with DV equipment. Parallel ATA disks are disks that you install
internally. Because imported DV material has a fixed data rate of approximately 3.6 MB/sec.,
high-performance parallel ATA disks typically can capture and output these streams
without difficulty. The numbers following the ATA designation indicate the maximum
data transfer rate possible for the ATA interface, not the disk drive itself. For example, an
ATA-100 interface can theoretically handle 100 MB/sec., but most disk drives do not spin
fast enough to reach this limit.
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Parallel ATA disks use 40- or 80-pin-wide ribbon cables to transfer multiple bits of data
simultaneously (in parallel), they have a cable length limit of 18 inches, and they require
five volts of power. Depending on your computer, there may be one or more parallel ATA
(or IDE) controller chips on the motherboard. Each parallel ATA channel on a computer
motherboard supports two channels, so you can connect two disk drives. However, when
both disk drives are connected, they must share the data bandwidth of the connection,
so the data rate can potentially be reduced.
Serial ATA Disks
Serial ATA (SATA) disks are newer than parallel ATA disk drives. The disk drive mechanisms
may be similar, but the interface is significantly different. The serial ATA interface has the
following characteristics:
• Serial data transfer (one bit at a time)
• 150 MB/sec. theoretical data throughput limit
• 7-pin data connection, with cable limit of 1 meter
• Operates with 250 mV
• Only one disk drive allowed per serial ATA controller chip on a computer motherboard,
so disk drives do not have to share data bandwidth

FireWire Disk Drives
Although not recommended for all systems, FireWire disk drives can be effectively used
to capture and edit projects using low data rate video clips, such as those captured using
the DV codec. However, most FireWire disk drives lack the performance of internal Ultra
ATA disk drives or of internal or external SCSI disk drives. For example, a FireWire disk
drive may not be able to support real-time playback with as many simultaneous audio
and video tracks as an internal Ultra ATA disk drive can. This can also affect the number
of simultaneous real-time effects that can be played back.
Keep the following points about FireWire drives in mind:
• FireWire disk drives are not recommended for capturing high data rate material such
as uncompressed SD or HD video.
• Certain DV camcorders cannot be connected to a computer while a FireWire disk drive
is connected simultaneously. In many cases, you can improve performance by installing
a separate FireWire PCI Express card to connect your FireWire drive.
• You may be able to improve performance by reducing the real-time video playback
data rate and the number of real-time audio tracks in the General tab of the User
Preferences window.
• You should never disconnect a FireWire disk drive prior to unmounting it from the
desktop.
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SCSI Disk Drives
Small Computer System Interface (SCSI) disk drives used to be among the fastest drives
available, although newer computers may no longer provide SCSI ports. Although no
longer highly popular, SCSI technology has been implemented in various ways over the
years, with each successive generation achieving better performance. Two fast SCSI
standards for video capture and playback are:
• Ultra2 LVD (Low Voltage Differential) SCSI: Ultra2 LVD SCSI disk drives offer fast enough
performance to capture and output video at high data rates when a single disk is
formatted as a single volume (as opposed to formatting several disks together as a disk
array).
• Ultra320 and Ultra160 SCSI: These are faster than Ultra2 LVD SCSI disks.
SCSI disks can be installed internally or connected externally. Many users prefer external
SCSI disk drives because they’re easier to move and they stay cooler. If your computer
didn’t come with a preinstalled Ultra2 LVD, Ultra160, or Ultra320 SCSI disk drive, you need
to install a SCSI card in a PCI Express slot so you can connect a SCSI disk drive externally.
A SCSI card allows you to connect up to 15 SCSI disk drives in a daisy chain, with each
disk drive connected to the one before it and the last terminated. (Some SCSI cards
support more than one channel; multiple-channel cards support 15 SCSI disks per channel.)
Use high-quality, shielded cables to prevent data errors. These cables should be as short
as possible (3 feet or less); longer cables can cause problems. You must use an active
terminator on the last disk for reliable performance.
Note: Active terminators have an indicator light that goes on when the SCSI chain is
powered.

SCSI
card

SCSI cable

SCSI cable

SCSI cable
SCSI terminator

Computer

All devices on a SCSI chain run at the speed of the slowest device. To achieve a high level
of performance, connect only Ultra2 or faster SCSI disk drives to your SCSI interface card.
Otherwise, you may impede performance and get dropped frames during capture or
playback.
Note: Many kinds of SCSI devices are slower than Ultra2 devices, including scanners and
removable storage media. You should not connect such devices to your high-performance
SCSI interface.
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Using a RAID or Disk Array
You can improve the transfer speed of individual disks by configuring multiple disk drives
in a disk array. In a Redundant Array of Independent Disks (RAID), multiple SCSI, ATA, or
FireWire disk drives are grouped together via hardware or software and treated as a single
data storage unit. This allows you to record data to multiple drives in parallel, increasing
access time significantly. You can also partition the array into multiple volumes.
Creating a disk array is necessary only if high performance is required to capture and play
back your video at the required data rate without dropping frames.
If you require rock-solid data integrity, consider purchasing a RAID. Many RAIDs record
the same data on more than one disk, so that if a drive fails, the same data can still be
retrieved from another disk. There are many RAID variations available, but one that offers
high performance for both digital video capture and data redundancy is RAID level 3.
Because they use specialized hardware, RAID level 3 systems can be more expensive, but
they should be considered whenever the safety of your media is more important than
the cost of your disks.
When you create or purchase a disk array, there are two important considerations:
• Compatibility: Make sure the software you use to create the array is compatible with
Final Cut Pro. For more information, go to the Final Cut Pro website at
http://www.apple.com/finalcutstudio/finalcutpro.
• Ventilation: If you’re creating an array yourself with an off-the-shelf drive enclosure,
make sure to allow for good ventilation. Disk arrays store information on several disks
simultaneously. If one of your disk drives fails, information on all the disks is lost. One
of the most common reasons a disk drive breaks down is overheating, so make sure
that your disks stay cool.
Important: Check the manufacturer’s specifications before buying disks to make sure the
disks offer the level of performance you need.

Fibre Channel Drive Arrays and RAIDs
Fibre Channel is a hard disk drive interface technology designed primarily for high-speed
data throughput for high-capacity storage systems, usually set up as a disk array or RAID.
Fibre Channel disk drive systems typically have performance rivaling or exceeding that
of high-performance SCSI disk arrays.
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One of the most common ways of connecting a computer to a Fibre Channel disk drive
system for video capture and output is called a point-to-point connection. A single
computer, equipped with a Fibre Channel PCI Express card, is connected to a single Fibre
Channel disk drive array. Unlike SCSI systems, Fibre Channel cables can be run extremely
long distances, up to 30 meters using copper cables and 6 miles (10 kilometers) using
optical cables.

Fibre
Channel
card

Computer

Disk array

For all its advantages, a Fibre Channel disk array requires more setup than other storage
options, making it unsuitable for portable use. Fibre Channel disk arrays usually have
extremely high capacity (potentially several terabytes of disk storage). Although this can
make them more expensive relative to other storage solutions, the cost per megabyte is
often considerably lower.

Storage Area Networks
A storage area network (SAN) such as an Apple Xsan system consists of one or more disk
arrays that are made available to multiple computer systems simultaneously. Broadcast
and post-production facilities can use an Xsan system to share a single set of media files
among multiple editing systems.
Xsan software allows an administrator to control SAN access privileges for each editing
system. For example, a capturing edit station may have read-and-write access to the SAN,
while an assistant editor station may only have read access to media files for a particular
project. An administrator may also control permissions to make sure editors capture
material only to specific folders.
Advantages of Xsan include:
• Media files are instantly accessible from multiple editing systems.
• Storage capacity and bandwidth can be scaled as needed.
• Editors can move between editing suites and continue working on the same project
without moving media files.
• Assistant editors can load, output, or archive media without disturbing an ongoing edit
session.
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• Producers can view dailies or finished sequences for approval without being in an
editing suite.
For more information, go to http://www.apple.com/xsan.
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External Video Monitoring

14

This chapter covers the following:
• Using an External Video Monitor While You Edit (p. 231)
• Using Digital Cinema Desktop Preview (p. 238)
• Compensating for Video Latency by Specifying a Frame Offset (p. 241)
• Troubleshooting External Video Monitoring Problems (p. 242)
It’s best to preview your video on an external video monitor to accurately see how your
final program will look.

Using an External Video Monitor While You Edit
If you’re producing for television broadcast or any other professional delivery format, it’s
a good idea to preview your video on an NTSC, PAL, or HD video monitor while you edit.
Color is represented differently on computer and video monitors, and computer displays
always show your video progressively scanned, even though NTSC and PAL video are
interlaced.
You need to match your video interface (analog, SDI, or HDMI) or DV device output format
to your monitor’s input format. Some combinations are not possible without purchasing
additional equipment. For example, if your video interface only has an SDI video output,
and your video monitor only has an NTSC composite input, you cannot connect the two
directly. In this case, you could:
• Purchase a monitor that supports SDI video input.
• Purchase an SDI-to-composite converter.
• Use a VTR that has an SDI input and composite output and supports converting between
input and output signals (this solution is often used with DV decks, when FireWire DV
input is converted to analog composite output).
• Purchase and install a video interface that supports composite output in addition to
SDI output.
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Consumer Video Monitors Versus Broadcast Monitors
Throughout the Final Cut Pro User Manual, a distinction is made between “video monitors”
and “broadcast monitors.” This is to differentiate between cases when any video monitor
will do and cases when only a high-quality broadcast monitor is appropriate for a given
task.
In most cases, when you want to simply monitor your video signal as it will look to the
audience, any standard NTSC or PAL video monitor is appropriate, and there are many
inexpensive models to choose from. When performing critical tasks such as color
correction, however, you should use a high-resolution broadcast monitor that can be
properly calibrated to display your signal consistently and accurately.
Broadcast monitors offer manual control over every aspect of the video signal being
displayed, including brightness, chroma, phase, and contrast. Additionally, broadcast
monitors can often display different parts of the signal using modes such as blue only
(only the blue gun traces the screen; the green and red guns are turned off ), underscan,
and H/V delay. Without these controls to accurately calibrate your broadcast monitor’s
display with the signal being output from your computer, you run the risk of making bad
color correction decisions based on an inaccurate view of your program’s picture.
For more information on how to use the controls on a broadcast monitor to calibrate
your video signal, see “Measuring and Setting Video Levels.”

Connecting Final Cut Pro to an External Video Monitor
For optimal real-time performance, your sequence or clip format should match the format
of your output device exactly, including video codec, image dimensions, and frame rate.
However, Final Cut Pro can output any video format to any video output device as long
as the frame rates of both match (the codec and image dimensions of your clip or
sequence do not have to match the format of your output device).
For example, you can preview a 720p30 HDV sequence via an NTSC DV FireWire device
connected to an external monitor. The output signal is letterboxed and downconverted
to NTSC video. You can also use a third-party interface to view any format supported by
Final Cut Pro—as long as the frame rate of your clip or sequence matches the frame rate
of your current output device.
Note: Output via HDV FireWire (native MPEG-2) is not supported for any format.

232

Chapter 14 External Video Monitoring

Connecting a DV FireWire Device to an External Monitor
A DV FireWire setup is a common Final Cut Pro configuration. A DV device (either a
camcorder, VTR, or FireWire-to-analog converter box) converts DV signals to analog video
and audio signals that are then sent to a video monitor (and to self-powered speakers
for audio monitoring). If you have a home stereo system, you can also connect the audio
output of the DV device to any available channels on the home stereo system.
Audio

FireWire
DV camcorder
in VTR mode

Composite
or S-Video

Computer

Standard definition
monitor

Amplified speakers

To connect an external NTSC or PAL monitor to your editing system
1 Connect a FireWire cable between a FireWire port on your computer and the FireWire
port on your DV device.
2 Connect the analog video outputs of the DV device to an external video monitor.
Depending on the device, the video output may be a composite or S-Video signal, using
either an RCA, a BNC, or an S-Video connector.
To preview DVCPRO HD video on an HD or SD monitor while you edit
1 Connect a FireWire cable between the FireWire port on your computer and the FireWire
port on your DVCPRO HD VTR.
2 Do one of the following.
• For downconversion and display on an SD monitor: Connect the SDI or composite video
output of your VTR to an SD monitor.
• For display on an HD monitor: Connect the HD-SDI video output of your DVCPRO HD
deck to the HD-SDI input of an HD monitor.
3 Choose View > Video Playback > DVCPRO HD.
If the DVCPRO HD device does not appear in the menu, make sure the device is connected
and turned on, then choose View > Refresh A/V Devices.
4 Choose View > External Video > All Frames (or press Command-F12).
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Connecting a Third-Party Video Interface to an External Monitor
You can use third-party video interfaces to connect a Final Cut Pro system to an external
monitor. A third-party interface may be able to transcode your sequence to one or more
of the following output formats: SDI, HD-SDI, analog component (YUV), S-Video (Y/C),
composite, HDMI, and even DV. For more information about these signal formats, see
“Connecting Professional Video and Audio Equipment.”
Some interfaces and decks can also downconvert an HD sequence to SD video output.
For example, while editing an HD sequence, you can use an appropriate third-party
interface to downconvert your HD video to a letterboxed standard definition SDI signal.
The SDI signal can be connected to an SD broadcast monitor.
Note: Make sure that the output format of your video interface and the input format of
your video monitor match. If you have a consumer monitor, it probably has only composite
analog video input, even though your video interface may support a higher-quality output
format (such as SDI or component analog).

Choosing Playback and Edit to Tape Output Settings
The settings in the A/V Devices tab of the Audio/Video Settings window determine which
video interface you use to externally monitor your video. You can choose to view external
video via FireWire (DV), a computer display (using Digital Cinema Desktop Preview), or a
third-party video interface. You can also specify a different output interface for editing
to tape versus playback while editing.
Although these settings reside in the A/V Devices tab of the Audio/Video Settings window,
you can choose a video interface from several other locations in Final Cut Pro.
• Summary tab in the Audio/Video Settings window: In this tab, you can choose video and
audio output interfaces from the corresponding pop-up menus.
• View menu: Instead of going to the Audio/Video Settings window, you can select video
and audio interfaces for external monitoring by choosing:
• View > Video Playback, and then choosing the name of the video interface
• View > Audio Playback, and then choosing the name of the audio interface
Note: When you choose an Easy Setup, the external video and audio playback settings
are automatically set for you because audio/video device settings are stored in an Easy
Setup. For more information about Easy Setups, see “Audio/Video Settings and Easy
Setups.”
To choose a video interface for external monitoring
1 Choose Final Cut Pro > Audio/Video Settings, then click the A/V Devices tab.
2 Choose the settings you want, then click OK.
For more information about the A/V Devices tab, see “About the A/V Devices Tab.”
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About the A/V Devices Tab
This section describes the features of the A/V Devices tab.

Playback Output Area
• Video pop-up menu: Choose a device to output video to.
• None: This turns off external video output. If you play clips or sequences in
Final Cut Pro, you can’t view them on your camcorder, deck, or NTSC or PAL monitor.
• Digital Cinema Desktop Preview: Depending on the number of computer displays you
have connected, there are several options. For details, see “Using Digital Cinema
Desktop Preview.”
• Apple FireWire NTSC (720 x 480): If you’re using a computer with built-in FireWire and
an NTSC device is properly connected to your computer and turned on, this option
appears. If you choose this option and you have a video monitor connected to your
DV device, your video will be displayed on it.
• Apple FireWire PAL (720 x 576): If you’re using a computer with built-in FireWire and
a PAL device is properly connected to your computer and turned on, this option
appears. If you choose this option and you have a video monitor connected to your
DV device, your video will be displayed on it.
• DVCPRO HD: If a DVCPRO HD device is connected, you can choose the DVCPRO HD
device here. The name displayed depends on the Easy Setup you currently have
selected.
• Other available video interface: If you have a third-party video interface installed, it
appears in this list. Choose the video interface to view video on a monitor that’s
connected to the interface.
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• Options button: Depending on your video interface and its associated codec, the
video frames may need to be decompressed when viewing video on an external
monitor. Click Options, then select the “Decompress after compress” checkbox. This
option is not available when using FireWire. If you’re using a third-party video
interface, check the documentation that came with it to see if you should use this
option.
• Mirror on desktop: Select this checkbox to simultaneously show video on both your
computer’s display (in the Canvas or Viewer) and an external video monitor. Some
third-party video interfaces may override this setting.
• Audio pop-up menu: Choose an audio device to output audio to. For information about
choosing audio output settings, see “Connecting Professional Video and Audio
Equipment.”
• Rendered Frames: This option may only appear when certain output devices are selected.
If you choose this option, rendered frames will be displayed on your external monitor,
as well as video that doesn’t require rendering.
Separate Output Options for Edit to Tape and Print to Video
• Different Output for Edit to Tape/Print to Video: Selecting this checkbox allows you to
redirect your program’s output to the specified video and audio interfaces whenever
the Edit to Tape or Print to Video command is used. For example, if you’re using a video
interface, you may want to preview your video using the interface’s analog outputs
during editing but output your final movie to tape using the digital SDI output.
When this option is selected, all the controls in this section become available. All controls
in this section are identical to, but independent of, those appearing in the Playback
Output area, above.
Note: If this option is not selected, your sequence video and audio are always sent to
the video and audio interfaces specified in the Playback Output area—even when the
Edit to Tape and Print to Video commands are used.
Disabling Warning Controls
• Do not show External A/V Device Warning when device not found on launch: When selected,
this option disables the “Unable to locate the external video device” dialog that appears
when Final Cut Pro is opened without a camcorder, deck, or video interface connected
or installed. Instead, Final Cut Pro finishes opening, and External Video is automatically
set to Off in the View menu. When this checkbox is selected, Final Cut Pro continues
to attempt to locate an installed video device each time it is opened, but does not
display a warning requiring user input if a video device is not found.
If the Don’t Show Again checkbox is selected in the “Unable to locate the external video
device” dialog, it is also selected in the A/V Devices tab of the Audio/Video Settings
window.
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If no video device is connected when Final Cut Pro opens, but you connect one while
Final Cut Pro is open, you will not be able to use it immediately. If the video device
does not appear in the Video Playback submenu of the View menu, make sure the
device is connected and turned on, then choose View > Refresh A/V Devices.
• Do not show warning when audio outputs are greater than audio device channels: This
option affects the Audio Outputs tab of the Sequence Settings window. If this option
is not selected, you will see a warning every time you choose more audio outputs than
are available from the currently selected audio device.
For example, if your audio device has only two audio outputs, and you configure your
sequence to have six audio outputs, a warning dialog appears when you click OK to
close the Sequence Settings window. To prevent this warning from appearing, select
this option.

Controlling When External Video Output Is Updated
Updating the external video output requires processing power. You can control how
often the external video output is updated.
To set the external display option
1 Choose View > External Video.
2 Choose an option from the submenu:
• Off: Turns off external video and audio output so nothing plays on your video monitor.
This allows you to play more real-time effects.
• All Frames: Updates every frame to the external video output. This includes scrubbing,
jogging, and playback.
• Single Frames: Updates external video output when you manually choose to display a
frame. This frees your computer’s processor to calculate more real-time effects but still
allows you to preview single frames on your external video output device. When this
option is selected, you can update the video output device by choosing View > External
Video > Show Current.
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Using Digital Cinema Desktop Preview
The Digital Cinema Desktop Preview feature allows you to preview your video using any
available computer display. If you have two computer displays, one can be used to view
the Final Cut Pro interface and the Finder while the other can be used as a dedicated
video monitor. For Final Cut Pro portable systems and other single-display systems, you
can switch between the user interface and the Digital Cinema Desktop Preview display.

USB or
FireWire
Audio interface

Amplified speakers

Graphics
card

Display
(Final Cut Pro)

Computer

Display
(Digital Cinema Desktop Preview)

Important: If you are doing critical online editing or color correction, you should use an
external CRT broadcast monitor that supports the format you are editing (NTSC, PAL, HD,
and so on), especially when your final output is interlaced video.

About Digital Cinema Desktop Preview Options
You choose the Digital Cinema Desktop Preview options in one of several locations:
• The Video Playback submenu of the View menu
• The Playback Output Video pop-up menu in the A/V Devices tab of the Audio/Video
Settings window
• The Video Playback pop-up menu in the Summary tab of the Audio/Video settings
window
There are several settings you can choose:
• Digital Cinema Desktop Preview - Main
• Digital Cinema Desktop Preview
• Digital Cinema Desktop Preview - Full-Screen
• Digital Cinema Desktop Preview - Raw

238

Chapter 14 External Video Monitoring

Note: The Main option is available on single-display systems, but the remaining options
are available only if you have two or more displays.
Digital Cinema Desktop Preview - Main
Video is shown on the main computer display (that normally shows the menu bar for
applications). This option is available at all times, regardless of how many displays you
have connected. Video presented on the main display is always shown in full-screen mode
and scaled to fit the display in at least one dimension. If the aspect ratio of the video
signal and the computer display do not match, the video on the display is letterboxed
(black on top and bottom) or pillarboxed (black on sides) as necessary. This is identical
to full-screen mode on a second display.
• Pro: You can use this format on single-display systems, such as a portable computer
editing system.
• Con: The normal computer interface is covered by the Digital Cinema Desktop Preview
display, so you can’t see Final Cut Pro when you choose to view full-screen video this
way.
Digital Cinema Desktop Preview
The video is shown at its normal scale (there is a 1:1 relationship between pixels in your
video and pixels on the display). However, if the video pixel dimensions are larger than
the dimensions of the display, the video is scaled to fit the display.
• Pro: The video always maintains proper aspect ratio and does not exhibit scaling artifacts
due to magnification.
• Con: Some formats, especially SD formats, may look very small when displayed on large
computer displays.
Digital Cinema Desktop Preview - Full-Screen
The video is scaled to maximize its size on the display. If the aspect ratio of the video
signal and the computer display do not match, the video on the display is letterboxed
(black on top and bottom) or pillarboxed (black on sides) as necessary. For example, 16:9
video shown on a 4:3 display is scaled until the width of the video matches the width of
the display, and the top and bottom are letterboxed.
• Pro: This format gives you the biggest picture possible and maintains the proper aspect
ratio.
• Con: Scaling artifacts may be noticeable when viewed up close.
Digital Cinema Desktop Preview - Raw
This mode shows your video data with as little processing as possible—there is no scaling
or pixel aspect ratio correction. For example, a 720p frame (1280 x 720) shown in RAW
mode on an 800 x 600 display only shows 800 x 600 pixels of the image. This can be useful
for engineering evaluations of the image.
• Pro: More accurate assessments of video quality can be made.
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• Con: This mode is not useful for general viewing. No scaling or pixel aspect ratio
adjustments are made, even when the video is larger than the display.

Using Digital Cinema Desktop Preview to Monitor Your Video
Unlike using a third-party video interface (or DV via FireWire), directly monitoring video
on a computer display does not introduce video latency (inherent processing delays).
Therefore, Final Cut Pro ignores the frame delay offset setting when you preview your
video on a computer display connected to a graphics card.
Tip: Regular editing commands still work when full-screen video is presented on the
main display. This means you can still set In and Out points, use the J, K, and L keys for
playback, and so on. For a list of shortcut keys, choose Tools > Keyboard Layout >
Customize.
To turn on Digital Cinema Desktop Preview
1 Choose View > Video Playback, then choose one of the available Digital Cinema Desktop
Preview options.
2 Choose View > External Video > All Frames (or press Command-F12).
3 To listen to audio in sync with video output on a computer display, make sure the audio
frame offset value is set to 0.
For information about how to set the frame offset for audio/video latency compensation,
see “Compensating for Video Latency by Specifying a Frame Offset.”
Important: Command-F12 is the default keyboard shortcut for turning external video
monitoring on and off. When full-screen video is presented on the main display, the menu
bar cannot be seen, so you need to use this keyboard shortcut.
It’s important to know how to turn off the Digital Cinema Desktop Preview option,
especially when you are using full-screen mode on the main display.
To turn off Digital Cinema Desktop Preview
Do one of the following:

µ
µ

Press Command-F12.
Press the Escape key.

Troubleshooting Digital Cinema Desktop Preview
If you experience trouble when using Digital Cinema Desktop Preview, review the
following:
• In Mac OS X System Preferences, the screen saver should be turned off (choose Apple
menu > System Preferences, click Desktop & Screen Saver, click Screen Saver, and set
the “Start screen saver” slider to Never).
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• Because of the refresh rate of LCD computer displays, 1080i60 and 720p60 material
may exhibit temporal artifacts during playback.
• Interlaced media is scanned progressively at the frame rate instead of the field rate.
Therefore, when viewing formats such as 1080i60 or SD NTSC or PAL video, both fields
are scanned simultaneously, which may result in interlacing artifacts.
• If you need to change your display resolution, do so prior to opening Final Cut Pro.
• LCD Cinema Displays have a longer decay period between each frame when compared
to lines being scanned on a CRT. At times, the same video image may be visible onscreen
for a period of up to four to seven frames.
• Turning on Digital Cinema Desktop Preview playback can reduce the number of real-time
effects available in your sequence. However, the real-time status of these effects is not
updated in the Effects menu or the Effects tab of the Browser.
• Refrain from pressing the mouse button upon initially enabling Digital Cinema Desktop
Preview (especially in Single User mode).
• Exposé is not supported with Digital Cinema Desktop Preview.
• Graphics files with a resolution of 1920 x 1200 and larger may not be displayed properly.
• Digital Cinema Desktop Preview must be turned off when performing a Print to Video
operation.
• If you do not have a second display connected to your computer, only the Digital
Cinema Desktop Preview - Main option is available.

Compensating for Video Latency by Specifying a Frame Offset
No matter what signal format you use for external monitoring, all digital video and audio
interfaces (including FireWire) introduce inherent processing delays (known as latency)
to signals sent out of the computer. External video and audio coming from the built-in
FireWire port or third-party interface may be several frames later than the video on your
computer display (in the Viewer or Canvas). The latency, or offset, between different
devices can make precise editing difficult.
By changing the frame offset value in Final Cut Pro, you can compensate for the delay
between your computer display and external video and audio outputs. Frame offset is
active only when your sequence real-time effects are handled by Final Cut Pro. For
information about specifying settings in the Effect Handling tab of the System Settings
window, see “Using RT Extreme.”
To set the frame offset between the computer display and the external video and
audio outputs
1 Choose Final Cut Pro > System Settings.
2 Click the Playback Control tab.
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3 Enter a number of frames in the Frame Offset number field.
Frame offset can be any whole number between 0 and 30. The default value is 4. For
example, if a video monitor connected to your DV camcorder shows your program four
frames later than your computer display, a frame offset of 4 will synchronize the two.
Note: Depending on your external monitor configuration, you may need to experiment
with frame offset values to synchronize the external monitor and the computer display.
4 Click OK.
5 Play your video in the Canvas or Viewer and compare the video offset between your
external monitor and your computer display.
6 If the computer display and external monitor are still not synchronized, repeat steps 1
through 5 using different frame offset values until the display and monitor are in sync.
Note: Final Cut Pro automatically compensates for latency in third-party audio cards if
proper Mac OS X Core Audio drivers are provided.

Troubleshooting External Video Monitoring Problems
If you experience problems while viewing your sequence, there are a few things you can
try.
To quickly choose a different video interface for external monitoring
Do one of the following:

µ

Choose Final Cut Pro > Audio/Video Settings. In the Summary tab, choose a video interface
(or none) from the External Video pop-up menu, then click OK.

µ

Choose View > Video Playback, then choose a video interface.
If you cannot see video on your external monitor, try the following:
• Choose View > Refresh A/V Devices to update the list of connected devices.
Note: This is especially useful if you just connected an audio or video device without
quitting Final Cut Pro.
• Choose View > External Video > All Frames (or press Command-F12).
• If you are using a third-party video interface, check the cable connections between the
video interface, breakout box (if applicable), and video monitor.
• If you are using FireWire and DV, check the FireWire connection between your computer
and VTR (or other DV FireWire device) and the cables between the DV device and the
external monitor.
• Make sure output connectors are always connected to inputs, and vice versa.
• If your monitor has multiple inputs, make sure the proper input is selected on the front
panel of the monitor or in the monitor’s onscreen menu.
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• Make sure the signal formats of your output device match the signal format of your
monitor. For example, both SDI and composite analog video can use a BNC connector,
but the signal formats are incompatible.
• If you are using a DV FireWire camcorder to convert DV to analog video, make sure the
camcorder is in VCR (or VTR) mode and that it is turned on.
• If you are using a VTR to convert video from your video interface to a format for your
video monitor, make sure you select the proper input connector on the VTR. For
example, if your VTR has both SDI and component analog video inputs, and your video
interface is connected to the VTR via an SDI connection, choose SDI input on the VTR.
You may also need to put the deck in E-to-E (electronics to electronics, or signal
passthrough) mode.

About the Display Quality of External Video
The display quality of your video depends on several factors:
• Whether you have effects applied to your clips
• Whether your clip or sequence settings match the video output device
• The video and frame rate options selected in the RT pop-up menu in the Timeline or
in the Playback Control tab of the System Settings window
Note: The Scrub High Quality option affects playback quality when your video is paused
or when you are scrubbing.
For more information, see “Using RT Extreme.”
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Overview of Capturing Tape-Based
Media

15

This chapter covers the following:
• What Are Logging and Capturing? (p. 245)
• Ways to Log and Capture Footage in Final Cut Pro (p. 245)
• The Importance of Logging (p. 248)
• Benefits of Logging (p. 249)
• Preparing to Log (p. 249)
• Additional Sources for Logging Information (p. 252)
• About Capturing Footage (p. 253)
• Are You Ready to Log and Capture? (p. 253)
You can capture taped-based media using the Log and Capture window. You can log
your tapes to create clips and then capture your clips as media files on disk.

What Are Logging and Capturing?
When a movie production wraps, the raw footage is typically delivered to the editor in
relatively lengthy tapes, or reels. During the logging process, the editor reviews each
tape, identifying the useful portions to be captured to the hard disk for editing. Timecode
In and Out points are used to identify each portion of footage to be ingested.
After logging the footage, the editor captures the regions of tape defined by the clips to
media files on disk. At the same time, Final Cut Pro creates clips in a project that represent
the captured media files on the hard disk, but they are not the actual media files.

Ways to Log and Capture Footage in Final Cut Pro
In Final Cut Pro, most logging and capturing of tape-based footage is done in the Log
and Capture window, but you can also use the Browser to add logging information to
clips after you capture. The most common logging and capturing workflows are described
below.
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Log your tapes, then batch capture using the Log and Capture window
This is the traditional method of logging and capturing. In this case, you watch your
footage by playing videotapes in a deck or camcorder connected to Final Cut Pro. You
can set In and Out points using the timecode information coming into Final Cut Pro, and
create clips that represent portions of your original videotape. After you finish logging,
you capture media for only the clips you think are necessary for your project. Capturing
the media files for many clips at once is called batch capturing.
• Logging: Use the Log Clip button in the Log and Capture window.
• Capturing: Batch capture selected clips that you think are useful for your project.
Log and capture clips one at a time, using the Log and Capture window
With this method, you log clips using a deck connected to Final Cut Pro, but you capture
each clip immediately after you log it. This is probably the most time-consuming of all
the methods because, unlike batch capturing, which is a semi-automated task, you oversee
the capture of each clip immediately after you log it.
Despite being more inefficient, this method is the most thorough and avoids any pitfalls
that may occur with automated batch capturing. If your tapes have a lot of unexpected
timecode breaks, or if you simply want to log and capture one or two clips from a tape,
you may prefer this method.
• Logging and Capturing: Use the Capture Clip button in the Log and Capture window
to log a clip to your project and capture its media file immediately afterward.
Capture entire tapes, then create subclips and log in the Browser
This method is increasingly popular because hard disk space is no longer prohibitively
expensive. Instead of choosing selected footage to transfer to your hard disk, you capture
entire tapes. Once on disk, you can break the footage into smaller subclips, add logging
information in the Browser, and delete unnecessary media from your hard disk.
• Capturing: Capture entire tapes using the Capture Now button in the Log and Capture
window.
• Logging: In the Browser, break the clip representing each tape into smaller subclips
and add logging information.
• Media management: After you create subclips, you can break large media files into
smaller media files, one for each subclip, and delete any media you don’t need for your
project. The result is that you only have media files for clips you want to use.
There are several advantages to this method:
• Capturing entire tapes causes less wear on the tapes than traditional logging because
you only have to play them back once, straight through, to transfer media files to the
hard disk.
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• Logging the media on the hard disk after capture is faster than tape-based logging
because you can access any frame instantly. You can also loop playback on a particular
shot to review it multiple times. On tape this would be much more time-consuming.
Note: If you are using an uncompressed video format, the amount of hard disk space
required to capture entire tapes may still be too high, even with the cost of hard disk
space dropping rapidly. When you are editing with uncompressed video, it can still be
more cost-effective to log your tape first, then capture selected regions.
Log in another application, import a batch list, then batch capture clips
Some editors prefer to log their footage outside of Final Cut Pro, then import a batch list
of clips to automatically batch capture.
• Logging: In a spreadsheet or database application, enter the clip name, reel name,
Media Start and End points, and other logging information, save it as a tab-delimited
text file, then import this batch list into Final Cut Pro.
• Capturing: Batch capture selected clips that you think are useful for your project.
Create clips directly in the Browser, then batch capture them
You can create clips directly in the Browser using the New Offline Clip command in the
File menu. You can enter pertinent logging information, and then batch capture the clips.
This approach is useful if you are only creating a few clips, or if you have a handwritten
list of clips that you logged somewhere else. Otherwise, creating and importing a batch
list may be faster.
• Logging: Create clips in the Browser, then add the reel number, Media Start and End
points, and any additional logging information to the various columns in the Browser.
To create new offline clips quickly, you can assign a shortcut key to the New Offline
Clip command. (See “Assigning Keyboard Shortcuts.”)
• Capturing: Batch capture the clips you created to make them online.
Log in the Log and Capture window without tapes in the camcorder or VTR
If you already have a handwritten list of clips and log notes, you can manually turn them
into clips in Final Cut Pro using the Log and Capture window. This works in the same way
as logging the tape, but no VTR is actually connected. This is an alternative to creating
offline clips directly in the Browser.
• Logging: Use the Log Clip button in the Log and Capture window.
• Capturing: Batch capture the clips you created to make them online.
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Important: Whenever you create clips from NTSC footage without a tape in your video
device, you risk entering the wrong type of timecode (drop frame instead of non-drop
frame, or vice versa) because Final Cut Pro isn’t reading timecode directly from the tape
itself. If you are manually entering timecode in the Log and Capture window, and there
is no tape in the device, make sure that the Default Timecode pop-up menu in the device
control preset you are using is set to the proper timecode. (For more information, see
“Device Control Settings and Presets.”) You can also Control-click the timecode field for
the clip In or Out point in the Log and Capture window and choose between drop frame
and non-drop frame timecode.
Import Final Cut Pro XML created in another application, then batch capture clips
The Final Cut Pro XML Interchange Format can be used to represent entire projects,
including sequences, bins, and clips. Using any XML-compliant application, you can create
an entire project in the Final Cut Pro XML Interchange Format, import the XML file, and
then batch capture the clips. This is similar to importing a batch list, but with XML you
can create not only clips, but sequences, bins, effects, and so on.
• Logging: Import the XML file into Final Cut Pro.
• Capturing: Batch capture the clips you created to make them online.

The Importance of Logging
Because of the deadline-driven nature of moviemaking, it is tempting to skip the
time-consuming preparatory steps in an effort to produce results faster. Don’t make this
mistake. The benefits of accurate logging usually come late in a project, such as in the
media management and finishing phases, when time is at a premium.
To log your tapes using Final Cut Pro, you connect your camcorder or deck to your
computer and use the Logging tab in the Log and Capture window to specify the reel
number, timecode In and Out points, and name of each clip you create.
In the Logging tab, you can also add details about each clip such as a clip description,
scene number, shot or take number, and general logging notes. You can also select a
checkbox labeled Good to identify the best of several takes. Once you have edited several
projects, you may devise your own particular rules and abbreviations for these descriptive
fields.
Each clip that you log is stored in your project, and all of the descriptive information in
the clip can be changed in the Browser or using the Item Properties window. For more
information about changing clip properties, see “Working with Projects, Clips, and
Sequences.”
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Important: When you log in Final Cut Pro, you add descriptive information to clips, not
to media files. This means that all of your logging information is stored in your project
file, not the media files on disk. If you delete your project file or clips from the Browser,
your logging information is gone forever.

Benefits of Logging
Aside from the practical matters of selecting which footage to capture to disk, logging
has many editorial benefits:
• By watching the footage, you familiarize yourself with the material of your project. The
better you know your footage, the more options you have when you’re stuck in an
editorial corner.
• Adding descriptive notes, comments, and labels to the footage helps you, and other
editors on the project, navigate large amounts of original source material.
• The first time you watch the footage is a unique occasion to view it objectively. Your
gut reactions are important to note at this time. They serve as valuable reminders of
what a first-time viewer may think of the footage long after you have seen the same
shots over and over again.
• Meticulous logging can identify problem shots early on, when there is still a chance to
fix them. For example, if there is only one take of a particular scene, and it is flawed,
the director may have an opportunity to reshoot it if informed early enough. Usually,
these discoveries should be made in production, during the review of dailies. As an
editor, you have the potential to warn the production crew of possible errors before it
is too late.
• Logging can reduce the amount of footage you capture and edit with. Editing is a
constant process of refinement and reduction of footage. When you log your footage,
you can often eliminate a large amount of footage before you start editing.

Preparing to Log
During the logging stage, you find out just how organized you really were during the
production phase. No matter how careful you were, a few things may not have been
labeled properly, or some information may be missing. Take time before you begin
post-production to get your tapes as organized as possible.
Remember that the list below is really a production checklist. However, any inconsistencies
during production should be straightened out before you start logging and capturing.
• Clearly label each of your tapes (reels) with a unique, simple name: If for any reason you
ever leave the Final Cut Pro editing environment to work on another system, simpler
reel names will cause less confusion. See “Choosing Reel Names.”
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• Use a simple clip-naming convention: Final Cut Pro can handle long clip names, but
other systems often can’t. See “Choosing Names and Logging Information for Clips.”
• Identify the audio sample rate and bit depth of your tapes: You should always log and
capture your footage with matching sample rate and bit depth settings.

Keeping Track of Footage with Reel Names and Timecode
Clips represent media files on your hard disk, but they also represent sections of your
original tapes between In and Out points. If you accidentally delete a clip’s media file on
disk, you can always recapture it from the original tape. Being able to recapture your
media from the original tapes is critical for most post-production workflows.
Final Cut Pro can identify which portion of a tape to recapture using the following clip
properties:
• Reel name: This is usually the name written on the tape label during production or just
prior to post-production.
• Media Start and End timecode: A clip’s Media Start and End timecode numbers identify
the start and end frames of the clip on your tape. Timecode is the critical link between
clips in your project, media files on disk, and the footage on your tapes.
A reel name identifies which tape a clip comes from, and timecode identifies where on
the reel a particular clip is located.
Important: If your original tapes don’t have timecode, it is impossible to accurately
recapture your tapes because Final Cut Pro has no way of ensuring that you are capturing
the exact same frames each time. For suggestions about logging and capturing footage
without timecode, see “Advanced Topics in Capturing Tape-Based Media.”

Choosing Reel Names
Older editing systems accepted three-digit reel numbers, starting at 000 and ending at
999. For maximum compatibility, this is a good naming convention to start with. Unless
you have over a thousand tapes in your project, this reel-naming convention should be
sufficient.
You can use the digits of your reel name to mean different things. For example, the first
digit can be used to represent a particular location, with space for 100 tapes per location.
100–199 could be used for tapes shot in Washington, D.C., while 200–299 could be used
for tapes shot in Los Angeles, and so on. Pick a consistent method, and if you have to
break your convention, have some numbers reserved just for this. For instance, you could
reserve 900–999 for miscellaneous tapes that don’t fit your naming convention.
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Note: Tapes recorded using professional video equipment allow the user to define the
timecode with custom hour numbers, so you can use those for your reel names. For
example, tape 001 would begin at timecode 01:00:00:00, and tape 022 would start at
timecode 22:00:00:00, and so on. Of course, this method only works if you have fewer
than 24 tapes.
Most mini-DV devices don’t allow you to set custom hour numbers, so with these devices
the best policy is to write reel names onto the tapes themselves, and to use these to
identify your tapes.
Note: If you plan on exporting an EDL, there are restrictions on the reel names you can
use. The restrictions depend on what EDL format you’re using. For more information, see
“Importing and Exporting EDLs.”
When logging, always make sure that you:
• Label your tapes with simple, unique names. If the reel names you used during
production are too long and complicated, you may want to relabel your tapes when
you start post-production, using a simpler, more consistent naming convention.
• Assign the proper reel name to each clip before you log and capture it. If a clip is
assigned the wrong reel name, Final Cut Pro asks for the wrong tape whenever you
recapture. You can change a clip’s reel name in the Browser, or by selecting the clip
and choosing Modify > Timecode. For more information, see “Working with Timecode.”

Choosing Names and Logging Information for Clips
Before you start logging clips, think about the filenaming scheme you want to use for
your project. It’s easier to edit when you have an organized naming system, especially if
there are several people working on a project at one time. This will help you avoid
duplicate clip names.
Important: Captured media files are named after the clips that are used to capture them.
You should avoid certain characters in your filenames. For more information, see
“Filenaming Considerations.”
Logging Suggestions for Projects That Are Tightly Scripted
These types of projects include narrative and educational projects or projects with scripts
that actors adhere to. Projects like this can benefit from:
• Using the Description field to name each separate shot.
• Using auto-incrementing numbers in the logging fields. Each time you log a clip, the
number at the end of a logging field is automatically incremented so you can focus on
logging the content of your footage. Use this feature to keep track of where your clips
fit into the overall script.
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• Using the Good checkbox to identify the takes you want to use while editing. Your first
impression is important, and you might forget what it was later on. When you’re ready
to start capturing your clips, you can use the Find command (or sort by the Good
column in the Browser), to select only the clips you’ve marked as good, and then capture
them, if you like.
Logging Suggestions for Documentary-Style Projects
These types of projects include not only documentaries, but any kind of project where
the majority of your material is unscripted interviews, found footage, or previously recorded
or stock material.
• Use the Prompt checkbox to enter clip names as you think of them. It’s a good idea to
identify clips by their content, as well as by where you might use them in your project.
• You can use the Notes field in the Prompt window (where you enter the name of a
logged clip) to enter the scene number where you think that clip might be placed.
Later, you can sort your clips in the Browser by the Notes column and all of your clips
will be grouped by scene number.
• Use markers, especially if you’re logging long takes. Markers can remind you, later on
when you’re editing, of sections of video that you liked.
• Feel free to log more clips than you intend to capture. Especially when editing an
unscripted piece, you never know when you’re going to need an alternate take or a
B-roll shot that you didn’t initially think you’d use. If you log all of the shots on a given
reel for reference, you can use the Good checkbox to mark the shots that you know
you want to capture right away. You can then store the other offline shots in a separate
bin for reference. If you need these shots later, it’s easy to select and batch capture
them.

Additional Sources for Logging Information
Not all logging information has to be created by the editor during post-production. Some
kinds of projects, such as feature films and episodic shows, use shooting scripts, which
break down the original screenplay into detailed scene numbers, camera angles, and so
on. This information is then translated into camera reports created by a camera assistant
during shooting. Timecode (video) or feet and frames (film) are written side by side with
notes about the shot: actor and camera positions, lighting setups, audio information,
notes about bad takes, and so on.
This information can be merged with post-production logging notes to help the editor
easily identify the reel and timecode numbers corresponding to each shot in the movie.
With the shooting script’s detailed information about scene and shot numbers and the
camera report information added to the log notes of your clips, it is much easier to
navigate your raw footage.
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If several people are logging footage on a large project, it is important that they use
similar naming conventions, and that notes are made using consistent descriptions and
shorthand. For example, everyone should use the same abbreviations, such as “CU” for
close-up, “MOS” meaning “without sound,” and so on. It doesn’t matter what conventions
you use, as long as you are consistent.

About Capturing Footage
Final Cut Pro gives you several options for capturing your footage to disk:
• Capture one clip at a time as you log in the Log and Capture window: With this approach
to capturing, you capture small sections of tape, one at a time. If you want to
meticulously define each clip before you capture it, you can set In and Out points and
add any logging information in the Capture window, and then press the Capture Clip
button. Some editors prefer to capture clips one at a time because this method avoids
any pitfalls that may occur with automated capturing. If your tapes have a lot of
unexpected timecode breaks, or if you simply want to capture one or two clips from a
tape, you may want to use this method. You usually do this to precisely control the
capture process and clip settings for each clip. See “Capturing Clips as You Log.”
• Capture an entire tape, or portions of a tape, in one pass: This capture method is popular
because hard disk space is no longer prohibitively expensive. Instead of setting In and
Out points for each clip that you want to capture, you can simply play your tape and
click the Capture Now button, and the entire tape is captured. After capture, you can
break the clip into smaller subclips and add logging information in the Browser. This
method has advantages such as causing less wear on tapes during capture and allowing
easier navigation through media that is stored on hard disk as opposed to navigating
tape-based footage. For more information, see “Capturing Entire Tapes.”
• Capture multiple clips at once (batch capture): For large projects with a lot of footage
and limited hard disk capacity, it’s usually most efficient to log all of your clips first, and
then batch capture only the clips you actually want to use in your project. When you
batch capture clips, Final Cut Pro automates the capturing process, cueing each tape
to the In point for each clip and capturing the corresponding media. If you’re capturing
from multiple reels, you need to insert new tapes when Final Cut Pro requests them.
Once you’ve logged your clips or imported a batch list, you can capture multiple clips
in the Browser at once using the Capture Batch button in the Log and Capture window.
For more information, see “Batch Capturing Clips.”

Are You Ready to Log and Capture?
Before you log and capture your footage, go through the following list to make sure you
are ready for either process.
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Stage 1: Creating a Project in Which to Log and Capture
You need a project to log clips to, as well as to edit in. When you open Final Cut Pro for
the first time, an untitled project is created by default, which you can rename to make
your own. You can also create a new project by choosing File > New Project.
Stage 2: Connecting Video and Audio Devices to Your Computer
There should be a connection from your camcorder or VTR to your computer. For more
information, see “Connecting Your Camcorder” or “Connecting Professional Video and
Audio Equipment.”
Stage 3: Choosing a Scratch Disk to Store Your Captured Files
The scratch disk is a hard disk, internal or external to your computer, where Final Cut Pro
stores captured media files and render files. For more information, see “Specifying Scratch
Disks.”
Stage 4: Selecting the Correct Easy Setup
Easy Setups are software configurations based on commonly used capture, device control,
and sequence settings. Choosing the proper Easy Setup automatically configures
Final Cut Pro so your capture preset matches your tape format, and your device properly
communicates via a device control preset. For more information, see “Choosing an Easy
Setup” and “Audio/Video Settings and Easy Setups.”
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About the Log and Capture
Window

16

This chapter covers the following:
• Opening the Log and Capture Window (p. 255)
• Controls in the Log and Capture Window (p. 256)
• Preview Area in the Log and Capture Window (p. 257)
• Logging Tab in the Log and Capture Window (p. 259)
• Clip Settings Tab in the Log and Capture Window (p. 261)
• Capture Settings Tab in the Log and Capture Window (p. 262)
• Log and Capture Buttons in the Log and Capture Window (p. 262)
You use the Log and Capture window to capture tape-based footage. The Log and Capture
window provides controls for controlling a VTR or camcorder, previewing video from
tape, setting In and Out points, logging, and capturing clips.

Opening the Log and Capture Window
The Log and Capture window provides controls for controlling a VTR or camcorder,
previewing video from tape, setting In and Out points, logging, and capturing clips.
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To open the Log and Capture window
Choose File > Log and Capture (or press Command-8).
Logging,
Clip Settings, and
Capture Settings tabs

Preview area

Log and capture buttons

Controls in the Log and Capture Window
This section describes the features and controls of the Log and Capture window.
There are several areas in the Log and Capture window.
• Preview area: On the left is the area where you view video while logging clips. This area
contains transport controls, marking controls, and timecode fields. If device control is
not turned on, the transport controls do not appear.
• Tabs: On the right are the Logging, Clip Settings, and Capture Settings tabs.
• Log and capture buttons: You use one of these buttons when you are ready to log a
clip or capture media.
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Preview Area in the Log and Capture Window
This section of the Log and Capture window lets you view video from tape while you log
and capture it. If your camcorder or deck is not on or there is no tape inserted, you see
color bars or black. The following controls appear if your camcorder or deck is on and
properly connected, and device control is turned on.
Timecode Duration field
Available space
and time

Current Timecode field

Video preview area
Jog control
Transport controls
Shuttle control

Device
status

Clip Out Point
Timecode field

Clip In Point
Timecode field

Video Preview Area in the Log and Capture Window
The following controls and displays are in the video preview area of the Log and Capture
window:
• Available space and time: Final Cut Pro displays the amount of available space on the
current scratch disk and the amount of capture time available, which depends on the
capture preset chosen in the Capture/Input pop-up menu in the Capture Settings tab.
• Device status: Shows the readiness of camcorders and decks connected to your computer
and being controlled by Final Cut Pro. If you see “VTR OK,” your equipment is connected
and working properly. If you see another message or for more information, see
“Understanding Device Control Status Messages.”
• Timecode Duration field: Displays the duration, in timecode, between the current tape
In and Out points. If you enter a duration in this field, the Out point is adjusted.
• Current Timecode field: Displays the timecode number of the current frame of your
source tape. You can enter a timecode number in this field to navigate to that timecode
point on your tape.
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Tip: You can drag timecode values to the Log and Capture timecode fields from other
timecode fields in Final Cut Pro, such as Browser columns. Hold down the Option key
while you drag a timecode value from a column in the Browser to either the Timecode
Duration or the Current Timecode field.

Transport Controls in the Log and Capture Window
If you have device control, use the transport controls to control your camcorder or deck.
These controls are similar to controls in the Viewer and Canvas, except that they control
playback of a videotape instead of a media file. For more information, see “Navigating in
the Viewer and Canvas.”
Rewind
Play In to Out

Fast Forward
Play Around
Current Frame
Stop

Play

Jog and Shuttle Controls in the Log and Capture Window
Jog and shuttle controls, similar to those in the Viewer and Canvas, are also available for
navigating through the tape. For more information, see “Navigating in the Viewer and
Canvas.”

Jog control

Shuttle control

In the Log and Capture window, you can use the J, K, and L keys for jogging and shuttling,
just as you can in the Viewer and Canvas. For more information about using the J, K, and
L keys to navigate through your clip, see “Shuttling Through a Clip or Sequence” and
“Jogging Through a Clip or Sequence.”
Note: Tape playback is not as efficient as playback from media files on your hard disk. It
takes a few seconds for a tape to cue to the proper frames or change playback direction.
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Marking Controls in the Log and Capture Window
Use these controls to set In and Out points for a clip on tape.
Clip In Point
Timecode field

Clip Out Point
Timecode field

Go to Out Point
Go to In Point

Mark In

Mark Out

• Mark In (I): This button sets the In point for a clip on tape.
• Clip In Point Timecode field: Shows the timecode value of the currently set In point.
• Go to In Point: This button causes the connected VTR to cue to the currently set In point.
• Mark Out (O): This button sets the Out point for a clip on tape.
• Clip Out Point Timecode field: Shows the timecode of the currently set Out point.
• Go to Out Point: This button causes the connected camcorder or VTR to cue to the
currently set Out point.

Logging Tab in the Log and Capture Window
Use this tab to add descriptive information to each clip that you log, such as reel name,
In and Out points, scene/take number, markers, and so on. Much of this information can
also be added later in the Browser. For more information, see “Logging a Clip.”
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Logging Bin Controls
The Logging Bin controls have the following buttons.

Up
New Bin

The Log Bin button
contains the name of the
currently selected
logging bin.

• Log Bin: This button displays the name of the bin in your project where logged clips
will be placed. There can be only one logging bin at a time, no matter how many
projects are open. When you click this button, the bin opens in its own window; if the
bin is already open, the bin’s window comes to the front.
• Up: Click to move the logging bin up a level from the currently selected one. For
example, you could switch from a bin to the bin that contains it. If the current logging
bin is at the highest level, clicking this button assigns the project itself as the logging
bin.
• New Bin: Click this button to create a new bin inside of the currently selected bin, and
set it as the logging bin.

Marker Controls in the Logging Tab
Click the disclosure triangle next to Markers to see the marker controls.
Marker In Point
Timecode field
Set Marker In

Set Marker Out

Marker Out Point
Timecode field
Marker list (after clicking
the Set Marker button)

• Marker: Enter a name or comments to go with the marker in this field. The marker name
remains until you change it.
• Set Marker: Once you’ve set the marker In and Out points, click this button to create a
new marker.
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• Set Marker In: Click this button to set a marker In point, or enter a timecode number in
this timecode field.
• Set Marker Out: Click this button to set a marker Out point, or enter a timecode number
in this timecode field.
• Update: To update a marker in the list, click to select it, make your changes, then click
Update. The marker in the list then displays the new information.
• Marker list: Displays all markers and associated information for the current clip.

Clip Settings Tab in the Log and Capture Window
Use this tab to choose which video and audio tracks you capture from tape. You can
capture video only, audio only, or both video and audio, and you can specify which audio
channels you capture. You can also adjust video levels for each clip using the Waveform
Monitor and Vectorscope; audio levels can be monitored using the audio meters. You
can also monitor the incoming audio signal by selecting the Preview option. For more
information, see “Selecting Which Tracks to Capture.”
Note: Video levels can only be adjusted for analog video interfaces.
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Capture Settings Tab in the Log and Capture Window
Use this tab to select a scratch disk for capture, a capture preset (video and audio rate,
compression settings, and frame size) and a device control preset to remotely control
your video or audio device. For more information, see “Changing Capture Settings.”

Log and Capture Buttons in the Log and Capture Window
As you log and capture, use the following log and capture buttons:

• Log Clip: Logs a single clip with the current logging information and clip settings.
• Capture Clip: Logs and captures a single clip with the current logging information, clip
settings, and capture settings.
• Capture Now: Captures the current video and audio input to a media file on disk until
you press the Escape key. No In or Out point is necessary. You can use this control to
capture an entire tape as a single media file.
• Capture Batch: Captures the selected clips in the Browser, or the clips in the currently
assigned logging bin.
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Logging from Tape

17

This chapter covers the following:
• Overview of Logging Steps (p. 263)
• Opening the Log and Capture Window (p. 265)
• Inserting a Tape in the VTR (p. 266)
• Setting a Logging Bin to Store Logged Clips (p. 267)
• Entering a Reel Name for the Current Tape (p. 268)
• Setting Clip In and Out Points (p. 269)
• Entering a Clip Name and Other Logging Information (p. 270)
• Adding Markers to Clips While Logging (p. 273)
• Selecting Which Tracks to Capture (p. 274)
• Changing Capture Settings (p. 276)
• Setting Video and Audio Levels for Analog Video (p. 277)
• Logging a Clip (p. 277)
For many editors, logging is the first phase of editing, when they identify which shots to
capture from tape. The logging information you enter at this stage serves as a guide
throughout the project.

Overview of Logging Steps
Before you begin to log, make sure that your camcorder or deck is connected to your
computer and that you’ve chosen the correct Easy Setup and specified a scratch disk. For
more information, see “Are You Ready to Log and Capture?”
If you like, you can follow the process outlined below to log your clips. If you need more
detailed information, see the sections that follow. For information about the Log and
Capture window, see “About the Log and Capture Window.”
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Stage 1: Opening the Log and Capture Window
The Log and Capture window provides controls for controlling a VTR or camcorder,
previewing video from tape, setting In and Out points, logging, and capturing clips. It
must be open before you can log and capture clips. See “Opening the Log and Capture
Window” for more information.
Stage 2: Inserting a Tape in the VTR
You need to make sure there is a proper connection between the VTR and camcorder
and Final Cut Pro. See “Inserting a Tape in the VTR” for more information.
Stage 3: Setting a Logging Bin to Store Logged Clips
When you log clips, you need to specify a logging bin where the clips are stored in your
project. See “Setting a Logging Bin to Store Logged Clips” for more information.
Stage 4: Entering a Reel Name for the Current Tape
All clips require a reel name. Make sure you enter the proper reel name before you capture.
See “Entering a Reel Name for the Current Tape” for more information.
Stage 5: Setting Clip In and Out Points
A clip to be captured is defined by In and Out points that you set as you view the footage
in Final Cut Pro. This is how you tell Final Cut Pro what part of a tape to capture. See
“Setting Clip In and Out Points” for more information.
Stage 6: Entering a Clip Name and Other Logging Information
You can enter a variety of clip properties in the Logging tab of the Log and Capture
window. See “Entering a Clip Name and Other Logging Information” for more information.
Stage 7: Adding Markers to Clips While Logging
As you log, you can set markers within clips to note significant parts for future reference.
See “Adding Markers to Clips While Logging” for more information.
Stage 8: Selecting Which Tracks to Capture
For each clip you log, you need to specify which video and audio tracks are captured to
the clip’s media file. See “Selecting Which Tracks to Capture” for more information.
Stage 9: Changing Capture Settings
If you’ve changed equipment or your Easy Setup, you may need to modify your capture
settings. See “Changing Capture Settings” for more information.
Stage 10: Setting Video and Audio Levels for Analog Video
If you are capturing from an analog source, you can adjust analog video and audio levels
for each clip in the Clip Settings tab of the Log and Capture window. See “Setting Video
and Audio Levels for Analog Video” for more information.
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Stage 11: Logging a Clip
Once you have entered basic logging information, you can log the clip, which means
adding it to your project. See “Logging a Clip” for more information.

Opening the Log and Capture Window
The Log and Capture window provides controls for controlling a VTR or camcorder,
previewing video from tape, setting In and Out points, logging, and capturing clips. It
must be open before you can log and capture clips. For more details, see “About the Log
and Capture Window.”

µ

To open the Log and Capture window
Choose File > Log and Capture (or press Command-8).
The Logging tab is active by default. To choose another tab, click it.
Once you have connected your VTR or camcorder to your computer, you can view your
video in the Preview area of the Log and Capture window, or you can connect your video
device to an external video monitor to view footage while logging.
Note: The size of the video preview area in the Log and Capture window is based on the
current height of the Canvas window.

To change the size of the video preview area in the Log and Capture window
1 Close the Log and Capture window.
2 Change the size of the Canvas to the size you want to make the video preview area.
3 Choose File > Log and Capture (or press Command-8).
The Log and Capture window opens based on the current size of the Canvas.
To monitor audio directly from your video or audio device while you log
Do one of the following:

µ
µ

Connect headphones to the headphone output of your camcorder or VTR.
Connect audio outputs from your camcorder or VTR to external speakers.

To monitor incoming audio directly from your system audio output
1 Choose File > Log and Capture (or press Command-8), then click the Clip Settings tab.
2 In the Audio area, select the Preview option.
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This option routes the incoming signal to the audio output selected in the Sound pane
of System Preferences. Each audio channel you turn on for capture is routed to a
corresponding output on your audio interface, while disabled channels are not heard. If
your audio interface has fewer audio outputs than the number of channels you are
capturing, the audio is downmixed to stereo. This does not affect your captured media
files; only the preview of audio during logging and capturing is affected.

About the Preview Disabled Message
When Final Cut Pro is not set up with the appropriate capture preset or the capture device
is not available, Final Cut Pro displays the message Preview Disabled in the Preview area.
If you see the Preview Disabled message, check that you’ve selected the correct capture
preset for your device and make sure the device is connected to your computer correctly.
If the message still appears, check with the manufacturer of your device to make sure
you have the latest device drivers installed. Installing the latest driver often eliminates
this problem.

Inserting a Tape in the VTR
You need to make sure there is a proper connection between the VTR and camcorder
and Final Cut Pro. The device status message in the Log and Capture window should read
“VTR OK.” For more information, see “Understanding Device Control Status Messages.”
When you insert a new tape in the VTR connected to your computer, Final Cut Pro alerts
you that a new tape has been placed in the deck. Make sure you check the name of the
tape before you put the tape in the deck, so you can enter the proper reel name.
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Considerations When Logging NTSC Footage
When a new DV tape is inserted into a camcorder or deck connected via FireWire to your
computer, it can take several seconds of playback for Final Cut Pro to determine whether
the tape’s timecode is drop frame or non-drop frame.
To compensate for this delay, the Default Timecode pop-up menu in the Device Control
Preset Editor allows you to specify which timecode format Final Cut Pro defaults to when
the Log and Capture window is opened. Most consumer DV camcorders record drop
frame timecode exclusively; professional DV camcorders and VTRs can record either drop
frame or non-drop frame timecode. For more information, see “Device Control Settings
and Presets.”
Note: If you are using serial device control or FireWire device control with a frame rate
other than 29.97, the default timecode format specified in your device control preset is
ignored.
If the timecode format specified in the Default Timecode pop-up menu is incorrect,
Final Cut Pro will still interpret the timecode format correctly after several seconds of
playback. For more information, see “Device Control Settings and Presets.”
If the default timecode format is incorrect and you do not allow enough time for the
proper timecode format to be detected, clips you log may have the wrong duration after
they’re captured. To be safe, let your tape play back for a few seconds before logging,
unless you are absolutely certain that the default timecode format in your device control
preset matches the timecode format on your tape.

Setting a Logging Bin to Store Logged Clips
When you log clips, you need to specify a logging bin where the clips are stored in your
project. By default, the project itself is considered to be the logging bin, but you can
create a new bin or assign any bin in your project as the logging bin.
You create and set the logging bin in the Logging tab of the Log and Capture window
or in the Browser. A slate icon appears next to the bin in the Browser to indicate that it
is the current logging bin.

µ
µ

To create and set a new logging bin in the Log and Capture window
In the Logging tab, click the New Bin button.
To set an existing bin in the Browser as the current logging bin
In the Browser, select the bin you want to use as your logging bin and do one of the
following:
• Choose File > Set Logging Bin.
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• Control-click the bin, then choose Set Logging Bin from the shortcut menu.

The slate icon appears
next to the current
logging bin.

As you log your clips, you may want to check to see how many you have or view their
names.
To open the logging bin
Do one of the following:

µ
µ
µ

In the Log and Capture window, click the Logging tab, then click the Log Bin button.
In the Browser, double-click the logging bin.
In the Browser, click the disclosure triangle next to the logging bin.

Entering a Reel Name for the Current Tape
All clips require a reel name. Make sure you enter the proper reel name before you capture.
The reel name is necessary any time you need to go back to your original tapes. This is
especially true if you need to recapture your footage from tape. For more information,
see “Choosing Reel Names.”
Important: You can change the reel name at any time, but you should get in the habit
of entering the reel name as soon as you put a new tape in the VTR or camcorder.

µ

To enter a reel name
In the Reel field, enter the number or name of the tape, then press Enter.
• To choose from a list of recent reel names: Control-click the field.
• To clear the contents: Option-click the Slate button.
• To increment the letter or number at the end of the name: Click the Slate button.
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For example, if the current reel name is 500, clicking the Slate button increments the
reel name to 501. However, if the current reel name is 500C, clicking the Slate button
increments the reel name to 500D. If the reel name is 500Z, clicking the Slate button
increments the reel name to 501A.

Enter the source tape
name here.

Slate button

To ensure compatibility with older editing systems, the safest reel names are simple,
three-digit numbers, such as 001, 244, 999, and so on. If you think there is even a slight
chance you might need to move your project to another editing system, you should use
this reel-naming convention.
Note: On many older editing systems, the term is reel number, not reel name.

Setting Clip In and Out Points
A clip to be captured is defined by In and Out points that you set as you view the footage
in Final Cut Pro. This is how you tell Final Cut Pro what part of a tape to capture. When
you log a clip, the In point you set becomes the clip’s Media Start property, and the Out
point becomes the clip’s Media End property. These properties can be seen in the Browser
and in the Item Properties window. For more information, see “Working with Projects,
Clips, and Sequences.”
To set In and Out points for a clip to be captured
1 In the Log and Capture window, navigate to the first frame of the clip you want to log
by doing one of the following:
• Use the transport controls.
• Enter a timecode value in the Current Timecode field.
For more information about controls in the Log and Capture window, see “About the Log
and Capture Window.”
2 To set the In point for the clip, do one of the following:
• Click the Mark In button.
• Press I.
3 Find the last frame of the clip you want to log, by doing one of the following:
• Use the transport controls.
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• Enter a timecode value in the Current Timecode field.
4 To set the Out point for the clip, do one of the following:
• Click the Mark Out button.
• Press O.
When you set an In or Out point, you may be off by a few frames. You can adjust the clip
In and Out points using timecode.
To adjust clip In and Out points using timecode
Do one of the following:

µ

Enter a timecode number for the In or Out point.

Enter the In point
timecode here.

µ

Enter the Out point
timecode here.

Click in the Clip In or Out point timecode field, then type + (plus) or – (minus) followed
by the number of frames or seconds you want to adjust the In or Out point.
For example, you could adjust the In point to be ten frames earlier by clicking in the Clip
In point timecode field and then typing –10. An alternative method is to batch capture
all clips with additional “handles” on the In point and Out point. Handles are media beyond
the In and Out points of a clip that provide a safety margin during capture to make sure
you get a bit of extra media in case you need it during editing. For more information
about adding handles during batch capture, see “Batch Capturing Clips.”

Entering a Clip Name and Other Logging Information
The following clip properties can be entered in the Logging tab of the Log and Capture
window, as well as adjusted later in the Browser: Name, Description, Scene, Shot/Take,
Angle, Log Note, and Good.
The clip name in the Name field is generated automatically from the Description, Scene,
Shot/Take, and Angle fields. However, only the fields whose checkboxes are selected
contribute to the clip name. Underscores in the clip name separate the content of each
automatically included field. For example, the clip name “Man Talking 3_23_4” is generated
from the Description “Man Talking,” the Scene “3,” the Shot/Take “23,” and the angle “4.”
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There are two features available to several fields:
• Slate buttons: Click the Slate button to increment the last number or letter in the field.
• If the current field doesn’t end with a number, a “1” is appended.
• If the field ends with a single character (such as “A”), the character is incremented
alphabetically (in this case, to “B”).
• Combinations of numbers and letters, such as “893z”, are incremented as well (for
example, to “894a”). Uppercase and lowercase characters are preserved.
• Checkboxes: Select a checkbox to add a field’s text to the Name field.
For more information, see “Choosing Names and Logging Information for Clips.”
To name your clip
1 Select the checkbox next to the log properties you want to include in the name of the
clip—Description, Scene, Shot/Take, and Angle.

2 Enter a brief description of the clip in the Description field. (Click the Slate button to
increment this field by 1.)
Note: After you log a clip, the last number in the Description field is automatically
incremented.
3 Enter a scene number in the Scene field. (Click the Slate button to increment this field by
1.)
4 Enter numbers for the shot and take in the Shot/Take field. (Click the Slate button to
automatically increment this field by 1.)
5 If the footage was part of a multicamera shoot, enter a camera angle number in the Angle
field. (Click the Slate button to automatically increment this field by 1.)
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µ

To clear the Description field along with the Shot/Take field
Option-click the Slate button next to the Description field.

µ

To clear the Shot/Take field
Option-click the Slate button next to the Shot/Take field.
To reset the Shot/Take and Angle fields to “01”
Do one of the following:

µ
µ

Click the Slate button next to the Scene field.
Option-click the Slate button next to the Scene field. This clears the Scene field in addition
to resetting the Shot/Take and Angle fields.
This happens no matter what the number was before (assuming a new scene will begin
at the first take).

Adding Notes and Marking Good Shots
As you are logging, you may want to add notes to the clip. If you think the current clip
is worth capturing, or if you at least want to remember that you considered it useful for
your project, you can mark it as Good. These notes and marks can help you later on as
you assemble your program.

µ

To enter logging notes for a clip
In the Log Note field, enter comments and editorial notes about the clip.
Control-click this field to choose from a list of recent Log Note comments in the current
project.

µ

To mark a clip as a good shot
Select the Good checkbox.
If you select this checkbox, a checkmark appears in the Good column of the Browser. This
is helpful if you want to log every shot on all of your tapes, but mark only a few shots for
capture. Later, in the Browser, you can use the Good property to sort and search clips.

Confirming Your Logging Information
Before you log a clip, you can choose to have Final Cut Pro confirm the clip name, Log
Note, and Good property before the clip is logged.

µ
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To have Final Cut Pro verify that the name and logging information is correct
Select the Prompt checkbox next to the Name field.
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Note: If the Prompt checkbox is unselected, Final Cut Pro logs the clip without asking
you to confirm, when you click the Log Clip button. For more information, see “Logging
a Clip.”

Adding Markers to Clips While Logging
As you log, you can set markers within clips to note significant parts for future reference.
Markers can be used for several purposes.
• Reference: Each marker can contain a name and associated note to help you identify
the content or other noteworthy information.
• Navigation: You can move the playhead from marker to marker in the Viewer and the
Timeline to quickly go to specific parts of a clip.
• Creation of subclips: You can also use markers to automatically create subclips, or parts
of a larger clip, in the Browser. For example, when you log a lengthy clip for capture,
you can arrange the markers to break the clip into smaller subclips for use while you
edit. For more information on creating subclips, see “Creating Subclips.”
You can set as many markers as you like. Markers appear in a list and can be edited and
deleted. Markers you set for clips during the logging process also appear in the Browser,
the Viewer, and the Timeline.
To add markers to a clip you are logging
1 Click the disclosure triangle next to Markers to see the marker controls.
2 Enter a name for the marker in the Marker field.
3 Find the frame where you want to set a Marker In point, by doing one of the following:
• Use the transport controls.
• Enter a timecode number in the Marker In Point Timecode field.
4 Click the Set Marker In button.
5 Find the frame where you want to set a Marker Out point, by doing one of the following:
• Use the transport controls.
• Enter a timecode in the Marker Out Point Timecode field.
6 Click the Set Marker Out button.
7 Click the Set Marker button.
When you click the Log Clip button, all the marker information in this section is saved
with the clip and the window clears.
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Selecting Which Tracks to Capture
For each clip you log, you need to specify which video and audio tracks are captured to
the clip’s media file. For example, a typical DV videotape has one video track and two
audio tracks. You can capture video only, audio only, or both video and audio. You can
also choose how many audio tracks to capture, and how they are grouped together
(mono or stereo).

To select which tracks on tape are captured
1 In the Log and Capture window, click the Clip Settings tab.
2 To capture video, select the Video checkbox.
3 To capture audio, select the Audio checkbox.

Multichannel Audio Capture Track Selection
Final Cut Pro can capture up to 24 audio tracks from a video or audio interface. Each input
on your audio interface is shown in a list in the Clip Settings tab. You can select up to 24
inputs for simultaneous capture. You can also group adjacent channels together as a
stereo pair, or leave them as mono channels. For more information about capturing
multiple audio channels, and about selecting which audio tracks are captured, see
“Multichannel Audio Channel Selection.”
If you change your mind about the audio grouping after you capture, you can make
channel grouping adjustments by choosing Modify > Clip Settings, or by relinking clip
items in the Timeline. For example, two adjacent mono channels can be regrouped as a
stereo pair. For more information, see “Dual Mono Versus Stereo Audio” and “Linking and
Editing Video and Audio in Sync.”
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Important: In Final Cut Pro 6 and later versions, each mono audio channel is captured to
a separate track in a QuickTime media file. Each stereo pair is each captured to a single
interleaved track in a QuickTime media file. In versions previous to Final Cut Pro 6, only
two-channel audio capture is supported to a single QuickTime audio track. Therefore,
older versions of Final Cut Pro can only recognize media files if you capture them with a
single stereo pair audio track.

Changing a Clip’s Track Selections After Logging
Once a clip is logged, you can override its track settings in one of two ways:
• Clip Settings command: You can change an offline clip’s track settings by choosing
Modify > Clip Settings, and then enabling different tracks for capture.
Choose to modify the
current clip’s video
settings, audio settings,
or both.
Enable or disable
video and audio tracks
for capture.

Enable or disable specific
audio tracks for capture.
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• Batch Capture dialog: If you are batch capturing clips, deselect the Use Logged Clip
Settings checkbox. In this case, individual clip settings will be overridden by the current
video and audio track selection in the Clip Settings tab of the Log and Capture window.

Make sure this option
is not selected.

Changing Capture Settings
If you’ve already specified a scratch disk and selected an Easy Setup for the setup you’re
using, you don’t need to change the capture settings. However, if you’ve changed
equipment or your Easy Setup, you may need to modify your capture settings. For more
information, see “Capture Settings and Presets.”
To choose different capture settings
1 In the Log and Capture window, click the Capture Settings tab.
2 From the Device Control pop-up menu, choose an option.
3 From the Capture/Input pop-up menu, choose an option.
4 If you need to specify a different scratch disk or add others, click Scratch Disks, choose
your options, then click OK.
For more information, see “Specifying Scratch Disks.”
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Setting Video and Audio Levels for Analog Video
If you are capturing from an analog source, you can adjust analog video and audio levels
for each clip in the Clip Settings tab of the Log and Capture window. If you are capturing
digital video, these settings usually do not apply. For example, if you are capturing DV
video via FireWire, all the video level adjustments are disabled. However, some third-party
video interfaces have specific level sliders turned on. For more information about setting
audio levels for capture, see “Adjusting Analog Audio Levels for Capture.”

Logging a Clip
Once you have entered basic logging information, you can log the clip, which means
adding it to your project. When the clip is logged, it is stored in your project’s current
logging bin.
To log a clip and add it to the current logging bin
1 In the Logging tab, do one of the following:
• Click Log Clip.
• Press F2.
2 If you selected the Prompt checkbox, a Log Clip dialog appears. Enter or change any
information for this clip, then click OK.
The clip appears in the selected logging bin. It is an offline clip because no media has
been captured for the clip yet. The clip’s Source property is empty—the clip does not yet
contain a file path to a media file.
For more information, see “Confirming Your Logging Information.”
Instead of merely logging the clip, you can also capture the media file by clicking the
Capture Clip button. In this case, a clip is added to the current logging bin, and the clip’s
media file is captured too. For more information about capturing your clips, see “Capturing
Video from Tape.”
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Logging Media Efficiently
If you’re logging a lot of material, it’s a good idea to familiarize yourself with the various
keyboard shortcuts you can use. Here’s an example of a logging workflow.
• Use the J, K, and L keys to quickly play through your tape. Press J to play the tape at
various speeds in reverse, press K to stop playback, and press L to play the tape at a
variety of speeds going forward. For more information, see “Shuttling Through a Clip
or Sequence.”
• When you’ve identified your In and Out points, press I to set the In point and press O
to set the Out point.
• Press F2 to log your clip.
• If the Prompt checkbox is selected, a dialog appears where you can enter a name, and
then press Tab to move down to the Notes field, if you like.
• Press Return or Enter to finish logging the clip.
Repeat this sequence for other clips you want to log.
Here are additional pointers for logging your material quickly:
• A new In point is automatically set at the Out point of the last logged clip.
• If you’re using the automatic naming feature and the Prompt box is unselected, the
Shot/Take field that makes up the clip’s name is automatically updated.
Tip: You can listen to your audio while you log by selecting the Preview checkbox in the
Clip Settings tab of the Log and Capture window. When this option is selected, you hear
your audio on the output selected in the Sound pane of Mac OS X System Preferences.
(In the Sound pane, click Output and select a device for sound output.)
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Capturing Video from Tape

18

This chapter covers the following:
• Capturing Clips as You Log (p. 279)
• Capturing Entire Tapes (p. 280)
• Batch Capturing Clips (p. 285)
Capturing is the process of transferring footage from your original tapes to media files
on the computer hard disk. You can then edit the media files, leaving your footage
untouched.

Capturing Clips as You Log
For more precise control over the capturing process, some editors prefer to capture each
clip as soon as they’ve logged it. You can use the Capture Clip button in the Log and
Capture window to capture the currently logged clip.
The Capture Clip option is useful in the following situations:
• For tapes with a lot of timecode breaks or video/audio settings that need individual
level adjustments per clip, the Capture Clip option gives you more control over each
clip’s settings.
• If you only have a few clips spread across several tapes, it may be faster to log and
capture each clip as you go instead of logging each tape and then batch capturing.
• As an alternative to the Capture Now option, you can set In and Out points near the
beginning and end of each tape and then capture the entire duration of the tape.
Note: The only difference between the Log Clip and Capture Clip buttons is that Log Clip
only creates a clip in your project, while Capture Clip creates a clip and also captures its
media file.
Make sure that your camcorder or deck is connected to your computer and that you’ve
chosen the correct Easy Setup and specified a scratch disk. For more information, see
“Are You Ready to Log and Capture?”
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To capture a single clip in the Log and Capture window
1 Log the clip using the instructions in “Logging from Tape.”
2 Once all of the clip information is entered, click the Capture Clip button.

Click here to
capture a clip.

3 If the Prompt checkbox is selected in the Logging tab, a Log Clip dialog appears. Enter
or change any information for this clip, then click OK.
Click the Slate button to
increment the clip name.
Click here to mark the
clip as Good.
If desired, enter
additional notes here.

Final Cut Pro rewinds the tape and captures the media file, creating a clip in the logging
bin that represents the captured media file.

Capturing Entire Tapes
If you have a lot of hard disk space, it’s often easiest to capture all your footage to your
scratch disk and log it afterward. You can then delete the media you don’t need from the
hard disk. Capture Now is also useful for capturing portions of tapes.
Once you capture your tape, you need to break your media files and clips into smaller
pieces. For details, see “Automatically Creating Subclips Using DV Start/Stop Detection.”
There are several reasons to capture entire tapes:
• Reviewing footage is easier once it is on your computer, allowing you to easily rewind
and loop sections of footage while you take notes.
• Capturing entire tapes causes less wear to the original source tapes because you only
play the tapes once while capturing instead of rewinding and fast-forwarding them
during logging and subsequent batch capturing.
• With some DV footage, Final Cut Pro can detect breaks between shots, allowing you
to create clips of each shot without setting In and Out points manually. This feature is
known as DV Start/Stop Detection.
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• For footage without timecode, you have to use Capture Now because Final Cut Pro
can’t locate In and Out points for batch capturing.
Once you capture all of your tapes, you can break these large (up to an hour or more)
clips into smaller, more manageable subclips. For instructions on creating subclips and
smaller media files from larger clips, see “Automatically Creating Subclips Using DV
Start/Stop Detection” or “Creating Subclips.”

Limiting the Duration of the Capture Now Process
When you use Capture Now, the captured media file increases in size until you manually
stop the capture process or until the Capture Now time limit is reached. This limit can be
set in the Scratch Disks tab of the System Settings window.
To set the Capture Now duration
1 Choose Final Cut Pro > System Settings, then click the Scratch Disks tab.
2 In the Limit Capture Now To field, enter the maximum duration (in minutes) that
Final Cut Pro will capture when you use Capture Now.
For example, if you have a 1-hour tape, you can set the limit to 64 minutes (60 minutes
plus 4 additional minutes to be safe), begin the Capture Now process, and then leave
and return several hours later. Instead of capturing until your scratch disk is filled,
Final Cut Pro stops capturing after 64 minutes.

Capturing an Entire Tape Using Capture Now
Make sure that your camcorder or deck is connected to your computer and that you’ve
chosen the correct Easy Setup and specified a scratch disk. For more information, see
“Are You Ready to Log and Capture?”
You do not need to set In and Out points when you use Capture Now. The In point is
determined when you press the Capture Now button, and the Out point is determined
when you press Escape, or when a maximum number of minutes that you specify is
reached.
To capture an entire tape to your scratch disk using Capture Now
1 In the Logging tab of the Log and Capture window, enter a reel name, description, and
other logging information.
For more information, see “Logging from Tape” and “About Automatic Filenaming During
Capture Now.”
Note: Since you are capturing the entire tape, some fields in the Logging tab may not
apply. You can leave those blank.
2 Click the Capture Settings tab, then click the Scratch Disks button.
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3 In the Scratch Disks dialog, select the Limit Capture Now To checkbox. Then enter a
number of minutes for the maximum duration of your tape. To be safe, you can add an
extra minute or two. You can also follow the steps in “Limiting the Duration of the Capture
Now Process.”
4 Rewind the tape to the beginning by doing one of the following:
• Press the Rewind button on your VTR or camcorder.
• Click the Rewind button in the Log and Capture window.
5 When you’re ready to begin capturing, do one of the following:
• Click the Play button.
• Press the Space bar.
6 Click the Capture Now button.
Final Cut Pro begins capturing your media file to your scratch disk.
7 Press the Escape key to stop capturing, or wait until Final Cut Pro automatically stops
because the maximum amount of time in the Limit Capture Now To field has been reached.
Once Final Cut Pro stops capturing, a clip appears in your logging bin. The new clip refers
to the media file you just captured.
8 Double-click the clip in the Browser to open it in the Viewer.
9 Review the clip briefly to see that it plays back properly, and make sure it contains all of
the tracks you wanted to capture (video, multiple audio channels, and proper timecode).
Tip: You can easily find a clip’s media file by selecting the clip in the Browser and choosing
View > Reveal in Finder.
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About Automatic Filenaming During Capture Now
Unless you enter text in the Description field, Final Cut Pro automatically names media
files (and captured clips) using the following convention: Untitled, Untitled1, Untitled2,
and so on.
If you’re capturing a clip using the Capture Now command and the currently specified
name is already taken by a clip in the current Scratch Disk folder, the letter or number at
the end of the name is incremented. For example, if you use Capture Now to capture a
clip named “Office Clips1” and there’s already a clip in that project’s Scratch Disk folder
with the same name, the name is changed to “Office Clips2.” If there is already a media
file called “Office Clips A,” the current media file is called “Office Clips B.”
Alphabetical incrementing occurs if the last letter is preceded by a separating character
such as a space, underscore, or dash. For example, “ClipName-A” is incremented to
“ClipName-B,” but “ClipNameA” is incremented to “ClipNameA1.” If the last letter in the
clip name is preceded by a number, both the number and letter are incremented. For
example, “ClipName-2Z” is followed by “ClipName-3A.”

Automatically Creating Subclips Using DV Start/Stop Detection
If you are using a DV format (DV, DVCAM, DVCPRO, DVCPRO 50, or DVCPRO HD), you may
be able to create subclips automatically from start/stop metadata that is embedded in
video frames each time you stop and start the camcorder. This DV start/stop metadata
is captured and stored in the media file. Final Cut Pro can identify the location of each
start/stop marker (sometimes referred to as an embedded flag) to automatically place
markers in a clip. These markers can then be used to create subclips.
Note: DV start/stop metadata is not timecode. It is independent time-of-day metadata
recorded within the video data of your footage. When the time-of-day information jumps
dramatically from one shot to the next, Final Cut Pro recognizes that the shot has changed
and can place a marker at that point in the clip.
To break a long DV clip into subclips based on starts and stops
1 Capture a long clip from a DV tape containing several starts and stops.
Note: If you’re capturing the contents of an entire DV tape, make sure that the “On
timecode break” pop-up menu in the General tab of the User Preferences window is set
to Make New Clip, to ensure that no timecode breaks are captured. For more information,
see “Choosing Settings and Preferences.”
2 Do one of the following:
• Select the clip in the Browser.
• Open the clip in the Viewer.
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3 With the Viewer active, choose Mark > DV Start/Stop Detect.

A marker appears in front
of every start and stop in
the clip.

Note: If you have any exceptionally long clips, you can break these up further by adding
a few more markers manually. For more information, see “Using Markers.”
4 Switch the Browser to list view and locate the clip you were working on in the Viewer.
For more information, see “Choosing Views in the Browser.”
5 Click the disclosure triangle to view the clip’s markers.

Markers for a clip

If you want to give any of the markers a more descriptive name, simply click the marker
in the Browser, then click the marker’s name to select it. You can now change the name.
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6 Drag in the Browser to select all the markers.

7 Choose Modify > Make Subclip.
Note: If you gave your markers new names, your subclips will use them.

All of the material
between the markers
you selected should
now appear as subclips.

The subclips appear in addition to the original clip with the markers. You can rename the
subclips, if you want. You can review the subclips, deleting any clips you might not need.
If you do remove unused clips, you can use the Media Manager to remove your unused
footage from disk, leaving the media for your remaining subclips alone. For more
information, see “Overview of the Media Manager.”

Batch Capturing Clips
To batch capture, your device must support remote device control and your clips must
have timecode numbers that accurately match the timecode numbers on your tape. Most
audio CD players, VHS decks, and other consumer equipment cannot be remotely
controlled and do not have timecode, so batch capturing from these devices is not
possible. For more information about device control, see “Device Control Settings and
Presets.”
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Batch capturing is useful for the following workflows:
• When you log all of your tapes first and then select some of your logged clips for capture
• When you import a batch capture list created in another application
• When you import an EDL (which becomes a sequence of clips) or a sequence from
another Final Cut Pro project, in which the clips’ media files are offline
• When you want to recapture media files using different video and audio settings (in
other words, a different capture preset). For example, during the online phase of
offline/online editing, you can recapture low-resolution media at full resolution. See
“Recapturing Clips.”

Before You Batch Capture
Batch capturing is an automated process, so make sure your settings and preferences
are correct before you start. Keep in mind the following:
• Timecode breaks: Make sure that you account for any timecode breaks when you log
your tapes. If you’re capturing from DV tapes, you should have separate reel numbers
for each section of tape where timecode was reset to 00:00:00:00 as a result of a
timecode break. For more information about logging tapes with timecode breaks, see
“Logging Tapes with Duplicate Timecode Numbers.”
• Capture preset: Make sure the capture preset you’ve specified is correct. You won’t be
able to change it once you start the batch capture. For more information, see “Device
Control Settings and Presets.”
• Scratch disk settings: Anticipate the amount of scratch disk space all of the batch
captured media requires, so you can properly set up your scratch disks. In the Log and
Capture window, click the Capture Settings tab and check the free space listed next to
the Scratch Disks button. You can compare this to the space needed in the Batch
Capture dialog.
• If you’re capturing a lot of clips and the first specified scratch disk is getting full: Make
sure you have selected additional scratch disks. This way Final Cut Pro can
automatically start writing media files to another disk and the batch capture process
won’t be interrupted.
• If you only have one scratch disk selected: Make sure that it has enough room for the
batch capture operation.
For details on specifying scratch disks, see “Specifying Scratch Disks.”
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• Clip and media filenames: When you log clips, it’s possible to accidentally create two
or more clips with the same name. However, when you batch capture, all clips in the
same folder on the same scratch disk must have unique filenames. Since clip names
are used as filenames, you need to change any duplicate clip names before you capture,
or there will be a media filename conflict during capture. Final Cut Pro handles media
filename conflicts in the following ways:
• If you set up a batch capture that includes two clips with the same name: A dialog
appears to let you change the name of one of the clips.
• If a filename used by a clip that is about to be captured is already used by another media
file on one of the selected scratch disks: A dialog appears where you can rename the
new clip, skip capturing it, or replace the old media file with the new one with the
same name.
Note: When you create clip names while capturing, make sure you avoid certain special
characters that could cause trouble later. See “Filenaming Considerations” for details.

Learning About the Batch Capture Dialog
The Batch Capture dialog provides settings and options when you are batch capturing
multiple clips at one time.
To open the Batch Capture dialog
1 Select one or more clips in the Browser.
2 Do one of the following:
• Choose File > Batch Capture (or press Control-C).
• Control-click any of the selected items in the Browser, then choose Batch Capture from
the shortcut menu.
• If the Log and Capture window is open, click the Capture Batch button in the lower-right
corner.
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The following settings are in the Batch Capture dialog.
Choose the kind of clips
you want to capture from
this pop-up menu.

Select the desired
options.
Select your capture
settings.
Summary of capture
settings

These calculations are
based on the capture
settings you specify.

• Capture pop-up menu: Lets you capture offline clips, online clips, or both. The items
that appear in this pop-up menu differ depending on whether you open the Batch
Capture dialog by clicking the Capture Batch button in the Log and Capture window
or by using the shortcut menu from within the Browser.
• When you click the Capture Batch button in the Log and Capture window: You are limited
to capturing clips inside the current logging bin.
• When you choose Batch Capture from the shortcut menu within the Browser: You can
capture any items that are selected in the Browser; you are not restricted to capturing
only from the current logging bin.
• All Items in Logging Bin/All Selected Items: Captures all clips in the current logging bin
(or all selected items in the Browser), whether or not they’ve already been captured.
If there are only offline clips, this is the only option available. If you’re recapturing
online clips to the same folder on the same scratch disk that the clips’ current media
files are stored in, the clips’ media files will be overwritten with new media files. If
you’re recapturing online clips and the currently selected scratch disk folder is different
from the one the clips’ original media files are in, the original media files are preserved,
and new media files are written to disk. After capture, the clips reference the new
media files.
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• Selected Items in Logging Bin: If you selected specific clips in your logging bin, you
can choose to capture only these. This is a good way to capture or recapture clips
from a specific reel or a limited number of clips that you isolate using the Find
command or by sorting a specific Browser column. This option is only available when
you initiate batch capturing from the Log and Capture window and you have selected
items within the current logging bin in the Browser.
• Offline Items in Logging Bin/Offline Items Only: Captures only the offline clips in the
current logging bin (or the current selection in the Browser). If there are no offline
clips available, this option doesn’t appear.
• Aborted Clips: If you stopped an earlier batch capture, you can choose to capture
just the clips that weren’t captured.
• Use Logged Clip Settings: Select this checkbox to capture all your clips using the settings
you specified for each individual clip during the logging process. If this checkbox is
unselected, all your clips will be captured using the current settings in the Clip Settings
tab of the Log and Capture window and the capture preset currently chosen in the
Capture Settings tab. This includes video and audio track selections, analog video level
settings (only available with some video interfaces), and capture preset settings such
as image dimensions, frame rate, and so on. For more information, see “Changing
Capture Settings.”
• Add Handles: Select this checkbox to capture additional frames beyond the head (In
point) and tail (Out point) of each clip captured, then enter a duration in the handle
timecode field. Handles are useful if you’ve logged your clips starting at precisely the
first and last frames that you think you want to use, but you want to capture a little bit
more media just in case you need additional frames for performing dissolves and other
transitions.
• Capture Preset pop-up menu: If the Use Logged Clip Settings checkbox is unselected,
you must choose a capture preset from the Capture Preset pop-up menu. This capture
preset is used for all media files you batch capture. A summary of the settings you
specify appears below this pop-up menu.
• Total Media Time: Lists the total time of the selected media, based on the capture
settings you specify.
• Total Disk Space: Lists the disk space needed for the captured media, based on the
capture settings you specify, as well as the space available on your scratch disk.

Batch Capturing Selected Clips
When you batch capture, you need to select clips in the Browser to capture. If no clips,
sequences, or bins are selected, the clips in the currently assigned logging bin are batch
captured when you use the Batch Capture command.
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To batch capture clips
1 In the Browser, select the clips you want to capture by doing one of the following:
• Select clips.
• Select one or more bins. (All clips in a selected bin will be captured.)
• Select one or more sequences. (All clips in a selected sequence will be captured.)
• Control-click a bin, then choose Set Logging Bin from the shortcut menu. You can
choose the entire project as the logging bin if you want to capture all the clips in your
project.
For more information, see “Selecting Items in the Browser.”
2 Do one of the following:
• Choose File > Batch Capture (or press Control-C).
• Control-click any of the selected items in the Browser, then choose Batch Capture from
the shortcut menu.
• If the Log and Capture window is open, click the Capture Batch button in the lower-right
corner.
3 In the Batch Capture dialog, choose your settings, then click OK.
For detailed information, see “Learning About the Batch Capture Dialog.”
a Choose which clips you want to capture.
b If you want, select the Use Logged Clip Settings checkbox.
c If you want, select the Add Handles checkbox and enter a duration.
d If the Use Logged Clip Settings checkbox is unselected, choose a capture preset from
the Capture Preset pop-up menu.
Important: When you finish specifying your settings, check the total disk space needed
at the bottom of the Batch Capture dialog and make sure your scratch disk has enough
space. If you need to specify additional scratch disks, see “Specifying Scratch Disks.”
4 When you’re ready to capture, click OK.
5 If there are any other clips outside of your current selection that reference the same media
files, the Additional Items Found dialog appears and you must choose an option.
For more information, see “About the Additional Items Found Dialog.”
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6 You are prompted with a list of all the reels needed for capture. Select a reel in the list,
then click Continue.

7 Insert the selected reel into your camcorder or VTR.
You need to make sure that your equipment is properly connected and turned on. For
more information, see “Connecting Your Camcorder” or “Connecting Professional Video
Devices.”
8 Final Cut Pro captures all of the clips on that reel and then prompts you to select another,
until all the clips in the batch have been captured.
Warning: If you’re capturing clips that have been captured once already, you can’t
recapture them at a frame rate that differs from the frame rate at which they were originally
captured. For example, if you capture a clip at 25 frames per second (fps), delete the clip’s
media file to make it an offline clip, and then recapture it, you must recapture the clip at
25 fps.

Stopping and Restarting the Batch Capture Process
Sometimes you need to stop a batch capture because you realize you are using the wrong
capture preset or scratch disk, or you selected the wrong clips for capture.
To stop a batch capture at any time
Do one of the following:

µ
µ

Press Esc.
Press and release the mouse button.
All clips that weren’t captured are labeled “Aborted” in the Capture column in the Browser.

To restart the batch capture process
1 Choose File > Batch Capture.
2 Follow steps 3–6 in the section “Batch Capturing Selected Clips.”
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Make sure you choose Aborted Clips from the Capture pop-up menu in the Batch Capture
dialog.

About the Additional Items Found Dialog
When you start batch capturing, Final Cut Pro verifies the master clip status of all selected
clips. If any selected clips are independent (meaning they have no master clips or are not
master clips themselves), Final Cut Pro checks all currently opened projects to see if there
are any other clips outside of your current selection that refer to the same media files.
This includes clips in other open projects, and clips in the same project that refer to the
same media files but are not in your current selection. If additional clips are found, the
Additional Items Found dialog appears.

For example, suppose you have a bin containing one sequence and twenty offline clips.
If you used some of the Browser clips in your sequence, the sequence clips refer to the
same media files as the corresponding Browser clips. If you select the sequence and
choose File > Batch Capture, the Additional Items Found dialog appears because some
of the Browser clips refer to the same media files as clips in the sequence.
If you click Add, the Browser clips that refer to the same media files as sequence clips are
added to the selected items before batch capturing starts. Each media file is captured
only once, but both Browser and sequence clips will be reconnected to the new media
files after the batch capture is complete. If you don’t click Add, only the sequence clips
are connected to the new media files, and the Browser clips remain offline (unconnected
to the new media files).
The Additional Items Found dialog contains the following options:
• Add: Click this button so Final Cut Pro automatically adds additional clips outside the
selection to your current batch capture. After capture, those clips reference the new
media files.
• Continue: Click this button to ignore the additional clips in other open projects (and
thus not reconnect them to the newly captured media files). The clips Final Cut Pro
finds are ignored and the batch capture is restricted to the clips you originally selected.
• Abort: Final Cut Pro stops the batch capture process.
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Working with Batch Lists
A batch list, also called a batch capture list, is a tab-delimited text file that contains
information about clips you want to capture and use in your project. These lists provide
a convenient alternative to logging tapes and creating clips within Final Cut Pro.
In another application, you can create a list of clips with descriptive information such as
reel name, timecode, log notes, director’s comments, and so on, and then import the list
into Final Cut Pro. The imported list becomes a group of offline clips in your project, which
you can then batch capture from the original tapes. As long as you entered accurate reel
and timecode information for each clip, the clips imported via a batch list are no different
from clips created directly in Final Cut Pro.
There are various applications you can use to create a batch list such as Numbers, FileMaker
Pro, or Microsoft Excel. You can even use text editors such as TextEdit, but it is generally
easier to use a program that keeps columns of information (such as clip name, reel name,
and timecode numbers) clearly separated. For more information, see “Creating a Batch
List.”
You can use batch lists in several ways:
• Producers and directors can create a list of clips for you to edit with and save you the
tedium of reviewing every single take.
• An editor or assistant editor can log the In and Out points of every shot and make a
note about whether the director liked each one.
• You can log material on one Final Cut Pro workstation for import and capture on another
workstation.
• You can watch your videotapes on a large projector to emulate a theater viewing
experience and take your log notes on a portable computer.

Differences Between Edit Decision Lists and Batch Lists
An Edit Decision List, or EDL, describes an entire edited sequence. After you import an
EDL into Final Cut Pro, the sequence described in the EDL is automatically created.
A batch list is a simpler list that describes only the clips used in your project, not any
chronological order or applied effects. After you import a batch list into Final Cut Pro,
your project contains a series of offline clips, one for each entry in the batch list. You then
need to recapture or relink the clips to use the media.
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Creating a Batch List
You can create a batch list using a VTR that can display timecode while you play your
tapes back (assuming your tapes or other original media have timecode) and a spreadsheet
program or word processor. Enter a reel name, Media Start, Media End, and clip name
for each clip you want to log. Save this list as a text file, and then import it into
Final Cut Pro. The result is a set of offline clips stored in your logging bin.
Using Equipment That Displays a Timecode Window
Professional VTRs (for example, Digital Betacam, Beta SP, and some DV decks) have an
option to display a timecode window superimposed over the video. More expensive VTRs
often have a separate output, labeled super (for superimpose) or monitor, dedicated to
timecode display. Less expensive decks may have only one video output and a switch or
menu option to turn the timecode window on or off.
Some VTRs are very expensive, and since watching your original footage can cause wear
and tear on your tapes, it often makes the most sense to make copies of your footage
onto a more affordable format, such as VHS or DV. You can then log your footage using
the copies, noting reel name and timecode In and Out points (Media Start and Media
End) for each clip on the tape. You can add as much additional logging information as
you want.
Creating and Logging Window Dubs
If you receive dubs (copies) of your footage on a tape format that doesn’t support remote
deck control from Final Cut Pro, you need to have the timecode “burned-in” to the video
image so you can read the timecode numbers manually. These are known as window
dubs, window burns, or timecode burn-ins. Although the burned-in timecode numbers can
be visually distracting, they provide the critical link between the timecode on the original
tapes and your log notes. VHS is a common example of an inexpensive dubbing format
that usually lacks the ability to be remotely controlled.
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Rules to Follow When Creating a Batch List
You can use any spreadsheet or word processing program to create a batch list. Because
spreadsheets are already set up to enter rows and columns of data, they are the easiest
programs to use to create batch lists. However, even a very simple program such as
TextEdit will work, as long as you use tabs instead of spaces to separate entries in your
list.

If you format your list properly according to the columns Final Cut Pro expects, importing
a batch list generated in another application is easy. Follow these rules:
• The first row of your spreadsheet or line of your word processing document must have
field headings that match exactly the column titles found in the Browser.
• You don’t need to include every column in the Browser, but you must have Name,
Media Start, Media End, and Reel column headings.
Note: In batch capture lists created for Final Cut Pro 1.2.5 or earlier, Media Start and
Media End were previously referred to as In and Out. If you’re using such a list, change
the column titles In and Out to Media Start and Media End, or your clips won’t import
properly.
• If you want the clips imported from a batch list to have drop frame timecode, make
sure the last pair of digits is preceded by a semicolon, such as 01:20:00;15.
• Each entry must be tab-delimited.
Using an Exported Final Cut Pro File as a Batch List Template
One way to guarantee a correctly formatted batch list is to export a batch list from
Final Cut Pro and use it as a guide, or template, to create your own batch list for another
project. Export a list that contains the Browser columns you want, then open the list in
a text editor or spreadsheet program. The main structure of the list is then set up for use
as a template.
Note: Batch lists always export clips using their native timecode display format. This
prevents you from exporting batch lists with alternative timecode displays, such as frame
display mode.
To export a batch list
1 Control-click in the Browser, then choose View As List from the shortcut menu.
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2 Select a project tab or open a bin in its own window.
3 Arrange columns in the Browser in the order you want information exported.
All visible columns are included in the exported batch list.
• To hide a column: Control-click the column heading, then choose Hide Column from
the shortcut menu.
• To display a hidden column: Control-click in any column heading, then choose Show
[Column name] from the shortcut menu, where Column name is the name of the hidden
column.
4 Choose File > Export > Batch List.
5 Select a location to save the file and enter a name for the list.
6 When you’re ready to export, click Save.

Importing a Batch List
You can import a batch list into Final Cut Pro and use it to capture clips to edit or to create
a sequence originally done on another editing system. The frame rate of the batch list is
determined by the currently selected sequence preset in the Audio/Video Settings window.
Note: A batch list must be a text file. In some cases, you may need to add the .txt file
extension to your filename to ensure that Final Cut Pro can import your file.
To import a batch list
1 In the Browser, open an existing bin, or create a new bin to store the offline clips and
open it.
For more information, see “Organizing Footage in the Browser.”
2 Choose File > Import > Batch List.
Note: The frame rate of the current sequence preset appears in the Import Batch List
command name. For example, if a DV NTSC preset is selected, the command is named
Import Batch List at 29.97 fps.
3 Locate the batch list, select it, then click Choose.
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The logged clips appear in the Browser as offline clips that you need to capture.

Clips from the batch list
are offline until you
capture them.

You can capture the clips all at one time by doing a batch capture. For more information,
see “Batch Capturing Clips.”
Note: Make sure you have all the source tapes associated with the batch list before starting
the capture process.
If you’re having a problem importing a batch capture list, check the format of the text
file. Final Cut Pro does not support importing RTF (Rich Text Format) text files. If you have
an RTF file you need to import, open it in a text editing application such as TextEdit and
save it as a plain text document first.
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Capturing Audio from Tape

19

This chapter covers the following:
• About Capturing Audio (p. 299)
• Capturing Audio-Only Media Files (p. 300)
• Capturing Multiple Audio Channels (p. 300)
• Adjusting Analog Audio Levels for Capture (p. 306)
• Capturing Audio from an Audio Deck Using Device Control (p. 308)
• Capturing from an Audio Device Without Device Control (p. 309)
• Capturing Synchronized Audio Independently from Video (p. 310)
Final Cut Pro allows you to capture multiple audio channels at the same time, as well as
capture audio-only media files.

About Capturing Audio
Capturing audio in Final Cut Pro is essentially the same as capturing video—you enter a
reel name, set In and Out points, log the clip, and then capture it. In most cases, you
capture audio at the same time you capture video because they are both stored on the
same tape. You can capture up to 24 audio channels at once, in either mono or stereo
groupings, and you can also capture audio-only media files from video or audio-only
devices.
If you want to import audio from audio CDs or audio files from other sound applications,
see “About Importing Audio Files.”

Preparing for Audio Capture
When capturing from an audio deck or multichannel audio device (such as a digital audio
workstation, or DAW), you need to make sure that:
• Your audio device and computer audio interface are properly connected
• Your computer’s audio interface accepts the output format of the audio device
• There are enough audio input channels on your audio interface to capture all the audio
channels from your audio device
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Most Mac computers have built-in stereo mini inputs, and some models also have optical
S/PDIF (consumer digital) stereo audio connectors.
For more information about setting up an audio interface with Final Cut Pro, see
“Connecting Professional Audio Devices.”
Important: To ensure that Final Cut Pro can accurately capture and consistently recapture
the exact same portion of the audio tape, your audio player must support remote device
control. Many professional DAT recorders and multitrack recorders support remote device
control. For more information, see “Capturing Audio from an Audio Deck Using Device
Control.”

Choosing a Method for Capturing Audio
You can capture audio with accompanying video, or independently. Audio can come
from a DV source (via the FireWire port on your computer), a third-party video interface
which includes audio inputs, or a third-party audio interface. You can also use the Voice
Over tool to record a mono audio track directly to the Timeline.

Capturing Audio-Only Media Files
If you want to capture only audio from a video or audio device, you can disable video
capture in the Clip Settings tab of the Log and Capture window.
To set Final Cut Pro to capture only audio
1 Choose File > Log and Capture (or press Command-8).
2 Click the Clip Settings tab.
3 Deselect the video checkbox, and select the audio checkbox.
For information on setting up a capture preset for capturing audio by itself, see “Capture
Settings and Presets.”
To choose a folder on your scratch disk for audio-only capture
1 In the Capture Settings tab of the Log and Capture window, click Scratch Disks.
2 Deselect the “Capture Audio and Video to Separate Files” checkbox.
When this option is disabled, audio files are captured to the Capture Scratch folder. If this
option is turned on, audio files are captured to the Audio Capture Scratch folder.

Capturing Multiple Audio Channels
Whether you are capturing audio only or video and audio together, you need to choose
which audio channels are captured and how they are grouped together. Final Cut Pro
can simultaneously capture up to 24 audio channels to a QuickTime media file, from any
of the available input channels of a single audio interface.
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Setting Up for Capturing Multiple Audio Channels
Before you capture, you need to set up your audio interface with Final Cut Pro.
To select an audio interface for capturing audio
1 Choose File > Log and Capture (or press Command-8).
2 Click the Capture Settings tab.
3 From the Capture/Input pop-up menu, choose a capture preset that contains the audio
interface you want to use.
If you have a third-party audio interface, you may need to create your own capture preset,
or modify an existing one. For more information about customizing capture presets, see
“Capture Settings and Presets.”

Multichannel Audio Channel Selection
The audio area of the Clip Settings tab allows you to select which audio channels you
want to capture, and whether each channel is grouped in a stereo pair or treated as an
independent mono channel. Each audio input control corresponds to an input on the
audio device or interface determined by your current capture preset. If you are using a
third-party audio interface, it is important that you know which output channels of your
deck are connected to the input channels of your interface.
Video and Audio Channel Options
The Settings tab has the following options.
Select this option to
enable video capture.
If no audio interface
is connected, you can
choose how many
audio inputs you want
to capture from this
pop-up menu.
Select this option
to monitor incoming
audio during logging
and capturing.

Master Gain slider
Select this option to
enable audio capture.

• Audio capture checkbox: Select this option to turn on audio capture for the current clip.
• Input Channels: When an audio interface is connected to your computer and selected
in your current capture preset, Final Cut Pro automatically detects the number of input
audio channels available. In this case, the Input Channels pop-up menu is unavailable.
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If no audio device is connected, you can choose how many audio inputs you eventually
want to capture from (once an audio interface is connected). This is helpful when you
are logging tapes without an audio device connected. Don’t select more audio inputs
than you will have available when you capture.
Note: If your audio interface is disconnected, and you log clips with more audio input
channels than your audio interface has, Final Cut Pro restricts the number of audio
channels that are captured to the number of available input channels on the interface.
For example, if you log clips with eight audio input channels, and then batch capture
those clips using an audio interface that only supports four input channels, only four
channels are captured.
• Preview: Select this option to listen to the incoming signal on the audio output selected
in the Sound pane of System Preferences. Each audio channel you enable for capture
is routed to a corresponding output on your audio interface, while disabled channels
are not heard. If your audio interface has fewer audio outputs than the number of
channels you are capturing, the audio is downmixed to two channels (mono channels
are panned to the center and stereo pairs are previewed in stereo). This does not affect
your captured media files; only the preview of audio during logging and capturing is
affected.
• Master Gain: This slider allows you to adjust the gain on all audio channels
simultaneously. You can also enter a gain or attenuation value in decibels in the
corresponding field.
Note: Not all devices support a master gain control from Final Cut Pro.
Audio Options in the Clip Settings tab
The Clips Settings tab has the following audio options.
Stereo/Mono control
Capture Audio
Channel control

Individual audio
channel meters
Clipping indicator

• Stereo/Mono control: Turning on this control tells Final Cut Pro to capture the two
corresponding audio channels as a stereo pair. When this control is turned off, you can
select one or both audio channels for capture. In this case, each channel is captured
and handled as a discrete mono channel.
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• Capture Audio Channel control: Turning on this control tells Final Cut Pro to capture the
corresponding audio channel.
• Individual channel meter: Each audio channel meter shows the current level of the audio
entering your audio interface.
Note: If the Preview option is turned on, and an audio channel is disabled for capture,
then the audio meter does not display levels.
• Clipping indicator: Each audio channel meter has a clipping indicator that lights up
when audio levels above 0 dBFS are encountered. This indicator stays lit until you stop
and start playback again.

Choosing the Audio Channels to Capture
The following section describes how to choose the audio channels to capture.
To choose which audio channels to capture
1 Make sure your audio interface is connected and selected in your current capture preset.
2 Choose File > Log and Capture (or press Command-8).
3 Click the Clip Settings tab.
4 Check that the number of input audio channels in the Input Channels pop-up menu
matches the number of channels available on your audio interface.
Note: The audio interface used for capturing is determined by the currently selected
capture preset. For more information about capture presets, see “Capture Settings and
Presets.”
5 Select which channels from your audio interface you want to capture.
Important: When you select channels in the Clip Settings tab, you are selecting input
channels on the audio interface, not on the video or audio deck itself. For easy and
consistent audio capturing, you should connect the audio outputs on your deck to the
input channels with the same numbers. For example, if you are capturing from a Digital
Betacam deck, you should connect output channels 1–4 of the deck to input channels
1–4 of your audio interface.
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6 Click the Stereo/Mono control next to any pair of audio channels that you want to capture
as a stereo pair, so it’s darkened.

Stereo/Mono control
is enabled.

Stereo/Mono control
is disabled. Audio
inputs can be selected
independently.

Dual Mono Versus Stereo Audio
If you’re using a DV camcorder, you typically record two channels of audio during
production. By default, DV camcorders use a built-in stereo microphone, with the left
side recorded on audio channel 1 and the right side recorded on audio channel 2 of the
tape. This is a stereo grouping, where channel 1 represents the sounds on the left side
and channel 2 represents sounds on the right side.
Throughout the editing process, you edit both the left and right sides of a stereo sound
at the same time. In this case, channels 1 and 2 are grouped together as a single stereo
pair.
However, if you use separate microphones to record independent sounds, such as dialogue
from two actors, you can capture each audio track so that it is independent (discrete) from
the other. These are called dual mono tracks.

How Multichannel Audio Files Are Stored on Disk
Final Cut Pro stores multichannel audio media as QuickTime media files. Each audio
channel captured is stored in its own track within a single QuickTime media file:
• Mono grouping: Each mono channel is captured to its own track in the QuickTime media
file.
• Stereo grouping: Each stereo channel is captured to a single interleaved track in the
QuickTime media file. A stereo interleaved audio track contains both left and right
audio samples.
For example, suppose you are capturing from an eight-channel audio device. The way
the audio is stored in QuickTime tracks depends on which channels you group as mono
or stereo. Here is just one example of a track layout within a multichannel QuickTime
media file:
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Audio device channels

Audio grouping chosen in Clip
Settings tab

QuickTime media file track

Channels 1 and 2

Stereo pair

1 (Stereo)

Channel 3

Mono

2 (Mono)

Channel 4

Mono

3 (Mono)

Channels 5 and 6

Stereo pair

4 (Stereo)

Channel 7

Mono

5 (Mono)

Channel 8

Mono

6 (Mono)

How Multichannel Audio Clips Appear in the Viewer
The order in which channels are grouped in the Viewer depends on the type of clip. A
master clip displays audio channel groupings in the same order they are stored in the
clip’s media file (unless the master clip was created from a sequence clip). Sequence clips’
audio channels display stereo pairs followed by mono channels, regardless of their order
in the original media file or their order in the sequence.
For example, suppose you have a surround sound multichannel audio file that contains
the following channel ordering: stereo, mono, mono, and stereo. When you import this
audio file into Final Cut Pro, the master clip’s audio channels appear in the same order
as the audio file. However, if you edit this clip into a sequence and then open the sequence
clip in the Viewer, the channels will appear as stereo, stereo, mono, and mono because
the stereo pairs are displayed first.
The Viewer has a separate tab for each stereo pair or mono clip item. The example below
shows an eight-channel sequence clip open in the Viewer. The stereo pair is displayed
first, followed by the mono clip items.
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About Capturing Multiple Audio Channels from DV Devices
DV video devices can record up to four tracks of audio, depending on the sample rate
and bit depth chosen on the camcorder. However, Final Cut Pro can only capture two
audio channels via the FireWire port of a device at a time. You need to choose or create
a capture preset that captures the DV audio channels you want. For more information
about creating or modifying a capture preset, see “Capture Settings and Presets.”
To choose which DV audio channels to capture via FireWire
1 Choose Final Cut Pro > Audio/Video Settings, then click the Capture Presets tab.
2 Click a preset you want to modify, then click Edit or Duplicate.
3 In QuickTime Audio Settings, choose DV Audio from the Device pop-up menu.
4 Choose one of the following options from the Input pop-up menu:
• If your DV tape sample rate is 48 kHz and 16 bit: First 2 channels
• If your DV tape sample rate is 32 kHz and 12 bit: Choose either First 2 channels, Second
2 channels, or Mix 4 channels.
The Mix 4 channels option mixes all four audio tracks into a single stereo pair.
5 Click OK, then click OK again.
Important: Before you begin shooting, always set your DV camcorder to record with a
sample rate of 48 kHz and a bit depth of 16.

Adjusting Analog Audio Levels for Capture
Along with the color bars at the beginning of your tape, there may also be a reference
audio tone, usually at 1 kilohertz (kHz), set to 0 decibels (dB) on an analog meter. If you’re
capturing from a master tape in which the audio has already been mixed, all of the audio
levels should have been mixed relative to the level of this reference tone.
The goal is to affect the audio signal as little as possible when you capture audio to your
scratch disk. It’s better to make audio level adjustments after you capture, because level
changes you make in Final Cut Pro are nondestructive. You can always return to the
original audio levels if necessary.
If you’re capturing audio from a tape recorded on location, reference tone at the beginning
of the tape is a good starting point for setting your levels, but chances are that the audio
will vary from shot to shot. In this case, it is important to adjust the audio gain on your
audio interface to record the best possible audio levels. You should set levels to avoid
clipping the audio during capture. Clipped audio has a crackling, distorted sound that is
unacceptable for professional work. Sometimes one setting will work for every clip on
your tape. Other times, you may find yourself adjusting the audio levels for each clip. It
all depends on how widely the audio levels vary on a given tape.
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Note: When capturing digital audio, the gain level is already set and cannot be modified.
To adjust the audio gain levels before capturing analog audio
1 In the Log and Capture window, click the Clip Settings tab.
2 Do one of the following:
• Cue your tape to the reference tone recorded at the beginning of the tape, if you’re
recording from a premixed tape that includes a reference tone.
• Cue your tape to the clip with the loudest audio signal of all the clips you want to
capture on that tape.
3 Play back your tape.
4 Verify that the levels coming from your deck match the audio input meters on your audio
interface.
5 In the Clip Settings tab of the Log and Capture window, turn on the audio channels that
you want to capture audio from.
6 Adjust the gain on each audio input of your audio interface so that the Final Cut Pro audio
meters are equivalent to the meters on your deck.
Tone on analog media formats is usually set to 0 dB (analog). You need to choose an
equivalent digital level on the Final Cut Pro audio meters. The level you choose is
dependent on the bit depth you are using to capture your audio, as well as how much
dynamic range your audio has:
• 16-bit audio: Typically, you should set a 0 dB analog tone to equal –12 dBFS digital.
• 20- or 24-bit audio: You should set a 0 dB analog tone to equal –18 or –20 dBFS.
Generic
VU meter
+7
+4
+2

Final Cut Pro
audio meters
0
−6

0

−12

−2
−4

−18
−24

−7

−36

−10

−48

−20

−66

−30

�∞

Relating 0 dB analog to −12 dB digital

For more information about bit depth, see “Audio Fundamentals.”
Important: To avoid distortion, do not allow audio levels to go higher than 0 dBFS on
the Final Cut Pro audio meters.
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About Audio Peaks
When you capture audio, clipping occurs if any part of the audio signal goes over 0 dBFS.
Because 0 dBFS is the maximum digital level possible, all levels that would have been
above 0 dBFS are set to the maximum audio level, causing clipping. Due to the nature
of digital audio recording, such clipped audio typically results in a crackly, brittle-sounding
clip that is unsuitable for use. All occurrences of clipped audio appear as 0 dBFS peaks.
Excessive peaks indicate that your audio was recorded at unsuitable levels.
Final Cut Pro alerts you when an audio channel is peaking by lighting up its peak indicator
in the Clip Settings tab of the Log and Capture window. If the peak indicator is lit, you
should reduce the gain for that channel on your audio interface.
If you have already captured a clip and it has peaks in the audio, you can either recapture
the audio at a better level or edit the audio appropriately to avoid the peaks. You can
use the Mark Audio Peaks command to identify audio peaks in clips or sequences. It’s
then up to you to decide whether to avoid using those sections of audio or rerecord
them. For detailed information about the Mark Audio Peaks command, see “Evaluating
Levels with Audio Meters.”

Capturing Audio from an Audio Deck Using Device Control
Final Cut Pro allows you to capture audio from a device-controllable audio deck such as
a professional DAT (digital audio tape) deck or a digital multitrack recorder. This is mainly
useful when capturing audio that was acquired via dual system recording, in which video
and audio were recorded simultaneously to different devices.
As with capturing video, your audio tapes must have timecode recorded on them or you
cannot set In and Out points for capture. Audio decks may be controllable if they use one
of the standard device control protocols (typically, RS-422) supported by Final Cut Pro.
If you’re planning to capture dual system audio using device control, make sure that your
audio deck is genlocked with the audio or video interface you are using for capture. For
more information on connecting a device-controllable audio deck to your computer, see
“Connecting Professional Audio Devices.” For more information on capturing synchronized
audio, see “Capture Settings and Presets.”
To capture audio from an audio-only device using device control
1 Choose File > Log and Capture (or press Command-8), then click the Capture Settings
tab.
2 Choose the appropriate device control preset from the Device Control pop-up menu.
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This will usually be one of the serial RS-422 or RS-232 device control protocols. See the
documentation that came with your audio device for information on which one to use.

Choose the appropriate
device control preset.

Make sure you choose
the appropriate audio
capture preset.

3 Choose an audio-only capture preset from the Capture/Input pop-up menu.
For more information about creating an audio-only capture preset, see “Capture Settings
and Presets.”
4 If you’re capturing audio from a device-controllable audio deck that’s genlocked to a
video capture interface connected to your computer, you need to select “Sync audio
capture to video source if present” in the General tab of the User Preferences window.
For more information, see “Choosing Settings and Preferences.”
5 To locate material on an audio tape to capture, use the controls in the Log and Capture
window. Log clips the same way you would with any device-controllable video deck.
6 To capture material from an audio tape, capture clips the same way you would with any
device-controllable video deck.
For more information, see “Capturing Video from Tape.”
7 To stop recording, or to interrupt batch capturing using device control, press Esc.
The audio clips you captured are placed in the logging bin in the Browser.

Capturing from an Audio Device Without Device Control
If your audio device does not support device control, you can manually press Play on the
audio device and click the Capture Now button in the Log and Capture window. However,
without device control, Final Cut Pro cannot receive timecode. If you capture a media file
without timecode, you will not be able to accurately recapture your footage again later.
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If you want the ability to recapture your audio again later, you need to capture from
media that has timecode using a deck that supports device control. One solution is to
dub your audio onto a tape format that has a timecode track, such as DV or Digital
Betacam. If you dub your audio to DV, make sure you use 16-bit (2-channel) audio mode
so you record at the highest possible quality. Once your audio is transferred, you can
capture your DV audio clips using FireWire and DV device control, the same way you
would capture DV video clips.
Media without timecode

DAT without
timecode

Cassette

CD

Media with timecode

DV tape

DAT with
timecode

Capturing Synchronized Audio Independently from Video
If you are editing material acquired via dual system recording, meaning that video and
audio are recorded simultaneously to different devices, you need to capture your audio
and video separately and then synchronize them together in Final Cut Pro. After capturing,
you can combine the corresponding video and audio clips into a merged clip. Merged
clips work in the same way as other clips in Final Cut Pro, but they refer to separate video
and audio media files (whereas most other clips, such as clips captured from DV tape,
refer only to a single media file that contains both video and audio). For more information
about merged clips, see “Merging Clips from Dual System Video and Audio.”
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When capturing audio from an audio-only player such as a DAT player, it is important to
precisely synchronize the sample clock of the digital audio player with the clock of your
audio interface.

USB

USB-to-serial
adapter

Serial
Device controllable
DAT deck

PCI card
Breakout box
Audio
Computer
Reference video

Blackburst
generator

Reference video

Using a common timing signal for both your audio device and capture interface is
especially important when you capture long segments of audio. If your audio deck is not
set up in this way, the sync between the audio and video of merged clips you create can
drift over time.
To capture and edit digital audio properly, make sure your footage and equipment meets
the following requirements:
• Matching timecode on videotapes and audio tapes: During production, recording the
same timecode signal for both video and audio makes it easy to synchronize video and
audio clips in post-production. If timecode doesn’t match, you can manually synchronize
your video and audio clips in the Timeline and then create merged clips.
• Remote device control: Your audio tape player needs to support device control so that
Final Cut Pro can capture audio precisely and recapture consistently.
• A video sync generator (blackburst generator): Provides a common timing signal for both
the audio tape player and the audio interface you are using to capture.
• External sync input on devices and interfaces: Ideally, your video and audio devices and
your audio interface should accept an external sync signal so that all frame rates and
audio sample rates are timed together exactly.
For more information about connecting a blackburst generator to your video and audio
equipment, see “Synchronizing Equipment with a Blackburst Generator.”
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Advanced Topics in Capturing
Tape-Based Media

20

This chapter covers the following:
• Capturing Footage Without Device Control (p. 313)
• Capturing Video and Audio Separately (p. 315)
• Recapturing Clips (p. 315)
• Avoiding Duplicate Timecode Numbers on a Single Tape (p. 316)
• Capturing Footage with Timecode Breaks (p. 318)
• Renaming Media Files After Capture (p. 322)
• Using the Media Manager After Capturing (p. 322)
This section describes some of the advanced topics and issues that an editor may
encounter when capturing footage: how to capture footage from a video source that
doesn’t permit device control, how to capture video and audio separately, how to
recapture media should it become unavailable or lost, and how to capture footage that
has timecode breaks. Also presented is information about renaming media files and ways
to use the Media Manager to process captured files.

Capturing Footage Without Device Control
If you have a video source without device control (and therefore without timecode), you
must capture video manually.

Capturing Footage That Doesn’t Have Timecode
If you capture a media file without timecode, it’s impossible to guarantee accurate
recapture of the exact same clip with the same In and Out points. If you need to recapture
these clips for any reason, such as to capture them at a higher resolution or to re-create
an archived project that no longer has the associated media files, the recaptured footage
won’t be exactly the same, and you won’t be able to automatically batch capture the
clips.
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More and more footage is acquired digitally (using DV formats, for example), and capturing
analog, non-timecoded footage is becoming increasingly rare. One way to avoid capturing
from a non-timecoded tape is to first transfer your footage to a timecoded format, such
as DV, Betacam SP, or Digital Betacam, and then capture footage from the timecoded
tape using device control. For more suggestions about transferring footage from a
non-timecoded format to a timecoded format, see “Capturing from an Audio Device
Without Device Control.” (The same concepts apply to both non-timecoded video and
audio footage).
If you have to manually capture footage without timecode or device control, make sure
you:
• Capture media at the same resolution you plan to output: Since you can’t accurately
recapture your clips with the same In and Out points (because you don’t have remote
control of the VTR and timecode precision during capture), you should capture them
at the resolution at which you plan to output your project. This way, you won’t have
to manually recapture later.
• Back up all of your non-timecoded media files: If you back up your clips’ media files, your
source material is always available for reediting. Because video clips require a lot of
disk space, you need to use a high-capacity backup format, such as streaming tape (for
example, Data DAT, Mammoth, DLT, AIT, and VXA), CD-ROM, or DVD-ROM disc.
To capture media manually
1 Press the Play button on your video device.
2 Click the Capture Now button in the Log and Capture window. When you want to stop
the capture, press Esc.
For more information, see “Capturing Footage Without Device Control.”

Using a Non-Controllable Device for Capture
When a device-controllable camcorder or deck is not available or device control is not
turned on, the Log and Capture window is simplified. It no longer has transport controls,
and only the Capture Now button is available.

If you aren’t using
device control, the Log
and Capture window
is simplified.
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The steps for capturing without device control are the same steps for capturing using
Capture Now. The only important difference is that you need to choose the device control
preset for a non-controllable device.

µ

To choose a device control preset for a non-controllable device
Click the Capture Settings tab, then choose Non-Controllable Device from the Device
Control pop-up menu.
To capture a clip without device control, see “Capturing Entire Tapes.”

Capturing Video and Audio Separately
When you capture video and audio to separate files, two media files are saved on your
hard disk, but the clips appear in your project as merged clips. Capturing your video and
audio as separate files allows you to divide the workload between two scratch disks,
maximizing the performance of each scratch disk you’re using so that you can capture
your video at the highest possible data rate. Video and audio files captured as separate
files have the same name, with “_v” appended to video files and “_a” appended to audio
files. The files are also captured to two separate folders named Capture Scratch and Audio
Capture Scratch, respectively.
To capture video and audio to separate files
1 Choose Final Cut Pro > System Settings, then click the Scratch Disks tab.
2 Select the “Capture Audio and Video to Separate Files” checkbox.
Note: For capturing DV (including DVCPRO, DVCPRO 50, and DVCPRO HD) media, it’s
usually best to leave this checkbox unselected.
3 Select the checkboxes corresponding to the type of files you want to store on each scratch
disk: Video Capture, Audio Capture, Video Render, and Audio Render.
For example, if you want to capture video and audio to separate scratch disks, choose
two different scratch disks, then select the Video Capture option on one disk and the
Audio Capture option on the other. You can also capture separate video and audio files
to the same scratch disk, assuming the combined video and audio data rates don’t exceed
your scratch disk data rate.
4 Click OK to save your scratch disk settings.

Recapturing Clips
When you recapture a clip, you capture its media file, even if it already has a media file
associated with it. There may be several reasons why you’d want to recapture clips:
• You accidentally deleted a clip’s media file.
• You captured a clip with the wrong capture preset.
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• You captured clips at a low resolution for rough, offline editing, and now want to
recapture the clips at full resolution for your final sequence.
Recapturing is essentially the same as capturing. The only notable difference is that when
you recapture, there may already be a media file associated with a clip. When you recapture
media, you can replace the clip’s existing media file, or capture a new media file to a
different location by changing the path of the scratch disk. For more information, see
“Specifying Scratch Disks.”
To recapture your clips, simply follow the batch capturing steps described in “Batch
Capturing Clips.”

Recapturing Subclips
Subclips refer to portions of media files by using virtual subclip limits. When you tell
Final Cut Pro to capture a subclip, the subclip limits are ignored, and the entire duration
of the original media file is captured.

Recapturing Merged Clips
Merged clips are powerful because they allow you to group together a video media file
and multiple independent audio files within a single clip. This is especially useful for dual
system moviemaking, where video and audio come from separate sources and are
synchronized during post-production. A merged clip is a single clip in the Browser that
keeps these independent media files synced. When you recapture the media files for a
merged clip, you may have to make several capturing passes from different video and
audio sources.
Important: Generally, it’s best if all audio files referenced by merged clips are stored on
one scratch disk (preferably in the same folder).
For more information about merged clips, see “Merging Clips from Dual System Video
and Audio.”

Avoiding Duplicate Timecode Numbers on a Single Tape
If you aren’t careful during production, you can end up with duplicate timecode numbers
on your tape. Each time the camcorder is turned off and on again, there is a potential
that the camcorder will reset the timecode counter to zero. This is especially true when
working with consumer camcorders. For logging, capturing, and media management, a
tape with the same timecode number in two or more locations is very difficult to work
with.
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If someone asks you to capture media from timecode 00:00:00:00 to 00:01:00:00 on reel
1, you assume that you should capture the first minute of the tape. But if the camcorder
was powered off and back on at some point during the shoot, the timecode counter may
have reset somewhere in the middle of the tape. This tape has two occurrences of
timecode 00:00:00:00, so which occurrence should you capture?
Worse, during logging and capturing, neither Final Cut Pro nor the VTR will necessarily
navigate to the proper timecode 00:00:00:00, because there are two. Device control uses
timecode for positioning information, and always assumes that timecode numbers increase
as the tape progresses. If the timecode starts over somewhere in the middle of the tape,
you have to manually navigate to the correct area of the tape.

Logging Tapes with Duplicate Timecode Numbers
If you have to log tapes that have duplicate timecode numbers, make sure that you
account for any timecode breaks by assigning separate reel numbers for each section of
tape where the timecode reset to 00:00:00:00.
For example, suppose you have a DV tape with footage from 00:00:00:00 to 00:30:00:00,
followed by a timecode break. You could name the first half of the tape reel 4-A, and the
second half of the tape (which goes from 00:30:00:00 through the end of the tape reel),
4-B. Clips from both reel 4-A and 4-B actually come from one physical tape labeled reel
4, but for ease of media management and clip recapturing, it helps to have a unique reel
number for each section of continuous timecode, so you are never confused about where
on the tape a particular timecode number is located.

How to Avoid Multiple Occurrences of the Same Timecode Number
Duplicate timecode numbers on a single tape can be one of the most frustrating
experiences during logging and capturing. Make sure the camera operator is aware of
these pitfalls before shooting, especially when using a consumer camcorder.
Note: A camcorder may automatically shut off after sitting idle for several minutes to
conserve battery power. One solution is to use AC power with the camcorder, though
this isn’t always practical.
Here are some techniques for avoiding reset timecode counters when shooting with
consumer DV camcorders:
• Prerecord a video signal (preferably black) on each tape before production to create a
continuous timecode signal on the entire tape: This is called blacking a tape. You can do
this in any camcorder by pressing Record with the lens cap on and the microphone
disconnected (to avoid recording any audio signals). The more professional solution is
to use a DV deck and its internal black generator. Some DV decks also allow you to
choose what timecode number your tape starts with.
• Dub your tapes so that you copy the video and audio information, but not the timecode: The
dubbed tapes become your new source tapes, and you can capture from these.
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• During production, pay attention to the position of your tape: Camcorders attempt to
create continuous timecode by quickly reading the last timecode number written on
tape. The process of generating new timecode based on the last stored timecode
number is referred to as jam syncing timecode. However, if the camcorder doesn’t see
a timecode or video signal on the tape (for example, at the beginning of a blank tape),
the timecode counter is reset to zero.
DV camcorders tend to be fairly good at finding the last timecode number on tape as
long as the camcorder has not been powered off. If the camcorder is powered off, the
best solution is to rewind the tape by a second or two so that the camcorder can jam
sync the timecode already written on tape when you start recording again. In theory,
this technique can remedy most potential timecode problems. In practice, however, it
can be difficult to always remember to rewind, or you may rewind too far and then
spend time cueing your tape to make sure you don’t record over part of the previous
shot.
One helpful tip when using this technique is to record several additional seconds well
past the end of each shot. If your camcorder is powered off and on, you can rewind a
few seconds into the previous shot without worrying that you are going to record over
important footage.

Capturing Footage with Timecode Breaks
The Final Cut Pro timecode break-detection features let you easily and cleanly capture
entire source tapes without inadvertently introducing timecode errors.

The Importance of Avoiding Timecode Breaks
As you log your footage, it’s important to avoid timecode breaks in your clips. A timecode
break is any jump in the continuous flow of timecode numbers. There are two kinds of
timecode breaks:
• Ordered timecode break: This is a nearly imperceptible gap in the timecode track of
your tape which interrupts the continuous flow of timecode but doesn’t reset the
timecode to 00:00:00:00. Ordered timecode breaks can result from turning the camcorder
off and on in the middle of a tape, or from rewinding the tape to review a section and
then pausing at the end of the last recorded shot.
• Reset timecode break: This kind of break results in the timecode track being reset to the
default timecode value. For many DV-format camcorders, this value is 00:00:00:00. A
reset timecode break can happen as a result of a tape being cued slightly past the end
of the last recorded shot before being recorded onto further, or by partially recording
over the beginning or middle of a previously recorded tape.
Note: There are also timecode gaps, when long gaps are detected with no timecode at
all.
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Since most timecode breaks happen between the end of one shot and the beginning of
another, they’re pretty easy to avoid if you log your footage one clip at a time. Still, if
Final Cut Pro captures a clip with either type of timecode break, the timecode that
Final Cut Pro captures and writes to that clip’s source file on disk will be incorrect from
the point of the break forward. Since the timecode is incorrect, you will be unable to use
that clip with any Final Cut Pro function that requires accurate timecode, such as batch
capturing, media management with the Media Manager, or EDL export.

Capturing Footage Past Timecode Hour 23
When you capture footage that spans timecode hour 23 and timecode hour 00,
Final Cut Pro handles this timecode transition as a timecode break. If you choose the
Make New Clip option from the “On timecode break” pop-up menu in the General tab
of the User Preferences window, Final Cut Pro creates two clips. The Media Start timecode
of the second clip begins shortly after the pre-roll time specified in the Editing tab of the
User Preferences window has passed. This provides sufficient pre-roll time for the VTR to
recapture the clip later while avoiding the timecode break.

How to Avoid Capturing Clips with Timecode Breaks
The “On timecode break” pop-up menu in the General tab of the User Preferences window
gives you several ways to avoid capturing clips with timecode breaks. It’s important to
set this option to suit the way you intend to capture your clips. You have several options:
• Make New Clip: This is the default option. Video that’s already been captured before
the break in timecode is saved as a single media file, with its Out point set to the frame
occurring immediately before the timecode break. Final Cut Pro then automatically
continues capturing video after the dropped timecode frame as a second media file.
When this option is selected, clips captured after timecode breaks are named with the
original name and the number of the clip. For example, if the first captured clip’s name
is “Cats Playing,” the second clip’s name is set to “Cats Playing-1.”
This is a good option to choose if you are capturing an entire tape. For example, suppose
you are capturing the entire contents of a 60-minute tape that has four timecode breaks.
Instead of restarting the capture every time a timecode break is detected, Final Cut Pro
captures all media from the tape as five clips, skipping over each timecode break and
ensuring that the timecode of all captured media is frame-accurate.
• Abort Capture: If you choose this option, Final Cut Pro stops capture immediately after
a break is detected. All media captured before the timecode break has frame-accurate
timecode and is preserved. The resulting media file is saved and its representative clip
is placed in the Browser.
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• Warn After Capture: If this option is selected, timecode breaks are reported after capture
and the media file with the timecode break is preserved. It is unwise to use such a clip
unless you have no choice, because timecode breaks result in incorrect timecode from
the timecode break forward, and will make it difficult to accurately recapture your
media.

Using the Make New Clip Option
When you choose Make New Clip from the “On timecode break” pop-up menu in the
User Preferences window, ordered and reset timecode breaks and timecode gaps are
handled in different ways. The pre-roll and post-roll values in the current device control
preset also affect how the In and Out points of the resulting clips are determined.
Ordered Timecode Breaks
When an ordered timecode break occurs, the video that’s already been captured is saved
in the logging bin in the Browser as a single clip, with its Out point at the frame occurring
immediately prior to the discontinuous timecode. Final Cut Pro then continues to capture
video after the timecode break to a second media file.
The In point of this second media file is calculated by adding the pre-roll duration to the
frame occurring immediately after the dropped timecode frame. The pre-roll duration is
taken into account so that if you ever try to recapture the clip, there is enough acceptable
video footage before the In point to allow for VTR pre-roll.
Clips captured after timecode breaks are named by combining the original name and
the number of the clip. For example, if the first captured clip’s name is “Cats Playing,” the
second clip’s name is set to “Cats Playing-1,” then “Cats Playing-2,” and so on.
Timecode break
00:01:00:00
Cats Playing clip

00:01:10:00
Pre-roll

00:01:13:00
Cats Playing-1 clip

If a timecode break occurs during the pre-roll period (before the clip’s specified In point),
Final Cut Pro moves the In point later to accommodate the currently specified pre-roll
duration from the timecode break point to the new In point. For example, when a timecode
break occurs within the default pre-roll duration of 3 seconds, the In point is moved later:
Timecode breaks
00:01:00:00
Cats Playing clip
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New In point
00:01:10:00

00:01:11:00
Pre-roll

00:01:14:00
Cats Playing-1 clip
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Each time a timecode break occurs, Final Cut Pro continues to move the In point later
until there is enough continuous timecode to accommodate the In point in addition to
the duration of the pre-roll. This ensures that you will be able to recapture the clip again
later.
Reset Timecode Breaks
Reset timecode breaks are handled differently. Since a reset timecode break results in
the timecode at the point of the break being reset to 00:00:00:00, the reel name is
incremented along with the clip name. This makes later media management much easier.
The reel number identifies which part of a tape a particular group of clips came from. For
example, if a tape with the reel name 004 is captured and a reset timecode break occurs,
the reel name for all clips captured after the timecode break is incremented with an
uppercase letter, in this case 004-B. If another reset timecode break occurs, the reel
number is incremented to 004-C, and so on.
First timecode break
00:00:00:00 00:10:33:12
Reel 004

00:00:00:00

Second timecode break
00:32:10:18

00:00:00:00

Reel 004-B

00:48:04:20
Reel 004-C

Timecode Gaps
When long gaps are detected with no timecode at all, Final Cut Pro stops capturing, saving
the media before the timecode gap as a single media file with its Out point set at the last
frame before the gap. If you performed a Capture Now operation, Final Cut Pro continues
playing through to the end of the tape, searching for more recorded video. If more video
is found, the reel name is incremented—as with a reset timecode break—and capture
continues.
10-second gap

Reel 012
Desert Scene-005

Reel 012-B
Desert Scene-006

Note: If you’re experiencing excessive timecode breaks and don’t know why, try cleaning
your camcorder or deck’s video heads. For more suggestions about how to find the causes
of timecode breaks and dropped frames during capture, see “Solving Problems.”
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Renaming Media Files After Capture
You may want to rename your clips and media files after you capture. For example, if you
use Capture Now and forget to enter a clip name, your clip and media file are named
“Untitled.” You can easily rename a clip in the Browser, but you should also make sure to
change the name of the clip’s media file to match; keeping your clip and media filenames
matched makes media management much easier.
For details about renaming clip and media filenames to match, see “Reconnecting Clips
and Offline Media.”

Using the Media Manager After Capturing
After you capture, there are several ways you can use the Media Manager to process your
media files:
• Capture media files at a lower resolution and edit your project using the low-resolution
files. Once you are finished editing, you can then use the Media Manager to duplicate
your edited sequence, deleting any unused media in the process, and recapture only
the media you need for the final sequence at full-resolution. For more information, see
“Offline and Online Editing”
• Even if you’re not planning to recapture clips later at a different data rate, you may find
yourself needing additional disk space. For example, if you have a lot of long clips that
you only use portions of, the Media Manager can help. You can use the Media Manager
to discard any unused media from your scratch disk.
• Capture an entire tape, make subclips of all the shots you want to use, and then use
the Media Manager to create smaller media files based on the subclip limits. You can
discard media for subclips you don’t want to use. If you’re using DV tapes, you can use
DV Start/Stop Detection to mark all of your takes in preparation for creating subclips.
For more information, see “Creating Subclips.”
Note: If you’re capturing an entire tape in order to follow the above workflow, it’s vital
to make sure that your tape has no timecode breaks. Make sure that Make New Clip is
selected in the “On timecode break” pop-up menu in the General tab of the User
Preferences window. For more information, see “Choosing Settings and Preferences.”
For more information about media management, see “Overview of the Media Manager.”

322

Chapter 20 Advanced Topics in Capturing Tape-Based Media

Overview of Transferring
File-Based Media

21

This chapter covers the following:
• About File-Based Media (p. 323)
• Introduction to the Log and Transfer Window (p. 324)
• File-Based Media Terminology (p. 325)
• Example File-Based Media Workflow (p. 326)
Many advanced camcorders record their media as files stored on non-tape-based media
such as hard disks or compact flash cards. You use the Log and Transfer window to view
media recorded on file-based media and transfer it to your scratch disk.

About File-Based Media
Historically, video footage has been recorded on videotape. As digital acquisition replaces
analog technology, many camcorders now record footage as files on non-tape-based
media such as hard disks, solid-state cards, and optical discs. For convenience in
terminology usage, non-tape-based media are referred to as file-based media in this
manual. Because of their nonlinear nature, file-based media provide clear advantages
over tape-based media:
• You can log clips while ingesting others at the same time. This is impossible using tape.
• File-based clips are defined at the time of recording, so it’s easy to review media. With
tape, you have to define clips manually by setting In and Out points.
• No cueing or pre-roll time is necessary for viewing and ingesting media.
• You can mount multiple volumes at the same time. With tape, you can only use one
at a time.
Today, some common file-based media formats include:
• DVCPRO HD and AVC-Intra (solid-state Panasonic P2 card)
• AVCHD (hard disk, miniDVD, Secure Digital card, and memory stick)
• Sony XDCAM, XDCAM HD (optical disc), XDCAM EX (SxS memory card)
• Sony Video Disk Unit devices (hard disk)
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Introduction to the Log and Transfer Window
Final Cut Pro can transfer file-based media into your projects as clips using the Log and
Transfer window. You can then edit the resulting clips just as you would edit clips in any
other format.

Preview area

Logging area

Transfer Queue area

The Log and Transfer window is organized into four areas:
• Browse: Provides an overview of all mounted media volumes and the clips contained
within them.
• Preview: Allows you to view media, set In and Out points, and add clips to the Transfer
Queue.
• Logging: Use this area to add descriptive information about clips before ingesting. You
can also click the Import Settings button in this area to select which video and audio
channels are ingested with each clip.
• Transfer Queue: Shows a status list of clips currently queued for ingest.
For a detailed explanation of the features and options of the Log and Transfer window,
see “About the Log and Transfer Window.”
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File-Based Media Terminology
When you transfer file-based media using the Log and Transfer window, it’s important
to know the following concepts and definitions:
• Ingest: A general term for capturing or transferring video, audio, and metadata from
one media storage system to another. Depending on the context, ingest may mean
any of the following:
• Transferring data between different computer platforms or file systems, such as
between a P2 file system and Mac OS X
• Transferring data between different storage media, such as from tape to hard disk
(also known as capturing)
• Adding media files from your local scratch disk to a nonlinear editing system to create
clips that point to the media (also called transferring)
• Converting media between different container file formats, such as from MXF files
to QuickTime files
• Transcoding video and audio data to different formats, such as from AVC-Intra 1080i
footage to Apple ProRes 422 codec 1080i footage
• Log and Transfer window plug-in: A software plug-in that extends the capabilities of
the Log and Transfer window to preview and ingest specific media formats. Final Cut Pro
includes default plug-ins for formats such as the Panasonic P2 format, but additional
plug-ins can be installed as manufacturers introduce new formats.
• Storage media: File-based media where your footage is recorded. Examples include
Panasonic P2 cards, Sony SxS cards, hard disks, Sony Professional Discs, and miniDVDs.
A single unit of storage media (such as a Panasonic P2 card or a Sony Professional Disc)
is generically called a storage media unit.
• Media device: A camcorder, deck, card reader, or other device capable of reading and
writing to file-based storage media. These devices can usually be connected to a Mac
computer via a USB or FireWire cable.
Note: External hard drives are considered media devices whose storage media is
permanently installed.
• Media volume: A media device or an equivalent disk image mounted on the Mac OS X
desktop. The Log and Transfer window displays only media volumes whose file and
directory structures are recognized by the installed Log and Transfer window plug-ins.
This may be called a volume for short.
• Disk image: A file that stores a representation of a media volume. You can create a disk
image of a mounted volume using the Log and Transfer window or built-in Mac OS X
utilities.
• Media volume name: The name of a mounted volume, disk image, or folder. If you have
write access to a media volume, you can change the volume name in the Finder.
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• Media file: A file containing one or more video or audio tracks of sample data. Media
files contain your actual footage (also called content or essence). Associated video and
audio content (for example, interview footage including both image and sound) may
be stored together in a single file or as separate files. Separated video and audio must
be associated together via a metadata file (P2 cards have an XML file for this purpose).
Many media files are stored in a general-purpose container format, such as QuickTime
or MXF, which then contains tracks or streams of video, audio, and metadata content.
AIFF, Wave, TIFF, and JPEG are also examples of types of media files.
• MXF: A media file standard for wrapping video or audio and associated metadata into
a single container file. An MXF file is similar to a QuickTime file; they are both file formats
for storing media and metadata about the media. For more information, see “About
MXF-Based Formats.”
• Metadata: Generally, secondary data describing the primary data. In the case of media,
the primary data is the video and audio samples themselves, and the metadata is
descriptive information attached to it, such as shooting time, GPS coordinates, camera
operator name, shot and take number, sample rate, video codec used, and so on.
• Proxy media file: A low-resolution copy of a media file, usually stored as an MPEG-4 file.
A proxy can be used for fast transfer and preview of footage. Not all formats record
proxy files.
• Clip: An object in Final Cut Pro that refers to—or points to—a media file on disk.
• Reel name: A property stored in each clip in your Final Cut Pro project to remind you
which media volume your clip’s original media is stored on. A clip’s reel name is
especially important when you are reingesting a clip and you need to find the volume
containing the original media.
• Spanned clip: A single clip that consists of two or more media files. Spanned clips are
created whenever you record a single shot that exceeds the capacity of your storage
media (or, in the case of P2 cards, if your media exceeds 4 GB). In this case, the camcorder
seamlessly continues recording to a new media file on the next available storage
medium. For more information, see “Viewing Spanned Clips in the Browse Area.”

Example File-Based Media Workflow
The process of transferring file-based media is similar to capturing tape-based footage
using the Log and Capture window, although it is often much faster because you avoid
the inconveniences of tape. After you record your media using a device such as a Panasonic
P2, XDCAM, or AVCHD camcorder, you can connect the device to your computer and
transfer the media into Final Cut Pro using the Log and Transfer window. Here is an
example workflow to get you started using the Log and Transfer window to transfer your
recorded media into a Final Cut Pro project.
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Stage 1: Backing Up Your File-Based Media
After a shoot, your footage is basically recorded as files, often stored in a specific hierarchy
of folders. As with any computer files, you should first back up the media onto a storage
device for safekeeping. You then always have access to your original source media should
you need to replace lost clips or conform your source media to a transcoded edit of the
media files later.
Stage 2: Choosing a Scratch Disk and Logging Bin
The scratch disk you choose in this stage is where your digital video will be captured and
edited, and where the project’s render files will be stored. The logging bin is where all
the clips that are logged or captured are stored.
Stage 3: Mounting Media Volumes on Your Computer
Depending on your camcorder or storage device, you may need to connect the device
directly to your computer using a FireWire or USB connection. See your camcorder
documentation for instructions on transferring the files to your computer.
Stage 4: Mounting Media Volumes in the Log and Transfer Window
After choosing the scratch disk and logging bin, you can begin the log and transfer process
by opening the Log and Transfer window.
Stage 5: Choosing a Destination Codec
If the format you are ingesting is not natively supported by Final Cut Pro, you need to
choose a format to transcode your media to. For more information, see
Professional Formats and Workflows, available in Final Cut Pro Help.
Stage 6: Selecting Clips and Adding Logging Information
After selecting the clips you want to transfer, you can add a variety of logging information,
including reel, shot/take and angle information, and log notes.
Stage 7: Transferring Media
In this stage, you add the clips you selected to the Transfer Queue in the Log and Transfer
window. Once the clips are in the Transfer Queue, Final Cut Pro processes the files, creating
QuickTime media files located on your scratch disk, and creating the corresponding clips
associated with those files in the logging bin.
For more information about logging file-based media, see “Logging File-Based Media.”
For step by step instructions for transferring files, see “Transferring File-Based Media.”

Understanding the Relationship Between Folders, Volumes, and Reels
There are some important differences between working with file-based media and working
with footage stored on tape. Camcorders that record file-based media usually store media
as files organized in folders. When you transfer your media to a media storage device for
your computer to read, you transfer the entire folder holding the source media.
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A typical file-based media folder may hold several types of files associated with each shot
of footage, including the video, audio, and other files such as XML files. To transfer your
media to your computer, you should transfer the entire folder that the file-based media
is recorded in. Although the folder may look like any standard folder in your Finder, it’s
recommended that you not change the contents of the folder in any way, because the
access and playback of the files often require the exact filenames and hierarchy of folders
that the camcorder originally created them with. So opening a folder of your source media
and changing filenames or sub-folder names can have unexpected results, and may make
files unusable.
After a shoot, it’s recommended that you immediately back up the folder of source media
for safekeeping. Once you have a copy made, you can then copy the folder to your
computer and ingest the media into a Final Cut Pro project.
At the point of backing up your source media folder, you can take a first critical step in
logging your media. It’s recommended that you rename the source media folder with an
easily identifiable reel name. Although there are no actual reels used with file-based
media, assigning a reel name to each source media folder creates a basic organization
for your source footage, clips, and media files that will make retrieving and accessing files
more efficient later. For more information about choosing a useful reel-naming scheme,
see “Choosing Reel Names for Folders of File-based Media.”
When you copy your source media folder to your computer, Final Cut Pro identifies this
folder as a volume. You use the Log and Transfer window to open a volume of source
media in order to transfer the media files into your project and create clips. The name of
your source media folder appears in the Volume column in the Browser area of the Log
and Transfer window. If you have applied a reel name to the source media folder, you
can check the Volume column to see the reel location of your source media.
As you log clips, Final Cut Pro uses the volume name as the reel name logged with clips
and media files. Therefore, if you have applied a reel name to your source media folder,
your source folder name, the volume name, and logged reel name are all the same. For
example, if you give a source media folder the reel name, 001 Camera 1, you can mount
the 001 Camera 1 folder as a volume and as you log clips, the reel name associated with
each clip and media file is 001 Camera 1. You then have a clear path for tracking source
footage, clips, and media files logged with the same reel name.
Note: REDCODE media requires a slightly different procedure. For more information, see
“Working with REDCODE Media” in Professional Formats and Workflows, available in
Final Cut Pro Help.
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About the Log and Transfer
Window

22

This chapter covers the following:
• Opening the Log and Transfer Window (p. 329)
• Controls in the Log and Transfer Window (p. 331)
Many new and advanced camcorders record footage as files stored on devices such as
optical discs, hard disks, and solid-state cards. You use the Log and Transfer window to
transfer file-based media into your Final Cut Pro projects. The Log and Transfer window
provides controls for previewing file-based media, setting In and Out points, logging,
and transferring clips into Final Cut Pro. You can then edit the resulting media files just
as you would edit media files in any other format.

Opening the Log and Transfer Window
The Log and Transfer window is organized into four areas:
• Browse: Provides an overview of all mounted media volumes and the clips contained
within them.
• Preview: Allows you to view footage, set In and Out points, and add clips to the Transfer
Queue.
• Logging: Use this area to add descriptive information about clips before ingesting. You
can also click the Import Settings button in this area to select which video and audio
channels are ingested with each clip.
• Transfer Queue: Shows a status list of clips currently queued for ingest.
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To open the Log and Transfer window
Choose File > Log and Transfer (or press Command-Shift-8).

Preview area

Logging area

Transfer Queue area

Note: The illustrations in this chapter show examples of the Log and Transfer window
ingesting P2 footage. The window may display slightly different features when ingesting
other video formats.
To resize areas in the Log and Transfer window
Do one of the following:

µ
µ

Drag a horizontal or vertical resize bar.
Double-click a horizontal or vertical resize bar to make the area disappear (or reappear if
it is already hidden).
Note: If you drag resize bars near the edge of the window, one or more areas may be
hidden, but the resize bars always remain visible.

Vertical resize bar and
Resize pointer

Horizontal resize bar
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Controls in the Log and Transfer Window
This section describes the features and controls of the Log and Transfer window.

Controls in the Log and Transfer Browse Area
The top of the Browse area contains several buttons and controls:
Add Volume button
Eject button

Search field

Flat List View and
Hierarchical List
View buttons
Action pop-up menu
Column headings

Mounted volume

Other Browse area controls include the following:
Media map indicator
shows how much media
has been ingested.

Folder with valid
structure
Double-click a clip
property to modify
it, or press Enter.
Click to add selected
clips to the
Transfer Queue.
Thumbnail Resize slider

• Add Volume button: Click to add a folder with a valid file-based media folder structure
for a format such as P2, AVCHD, AVC-Intra, or XDCAM. You can also drag a folder from
the Finder to the Browse area. Final Cut Pro can also mount disk images (.dmg files),
which allow you to use disk images as a convenient method of archiving.
• Eject button: Click to remove the currently selected volume or folder from the Browse
area (or press Command-Option-E). The selected volume is unmounted from the desktop
in the Finder. Folders are removed from the Browse area but are otherwise unaffected.
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• Search field: An iTunes-like search field that limits which clips are displayed. All columns
are searched for matches even if some columns are not currently displayed. For example,
if you type “DV,” clips whose names contain “DV” are displayed, but so are clips using
DV and DVCPRO codecs. You can press Command-Control-S to highlight the search
field.
The search field accepts three kinds of timecode delimiters—periods (.), semicolons (;),
and colons (:)—and does not distinguish between them during searches. For example,
you can find all clips containing “10;00” in a timecode field by entering “10.00,” “10:00,”
or “10;00.”
• List view buttons: There are two ways to view the list of clips on mounted volumes.
• Hierarchical List view: View clips grouped by volume. In this view, you can click the
disclosure triangle next to a volume name to show or hide the clips contained within.
You can also select the volume and press the Right Arrow key to open it and the Left
Arrow key to close it. By default, this view shows columns for Name, Thumbnail
Images, Media Start, and Media Duration.
• Flat List view: View clips from all mounted volumes in a single list. Each clip’s parent
volume is specified in the Volume column. This view is unique because it consolidates
spanned clips into a single item. If you are working with spanned clips, you should
usually work in this view.
• Action pop-up menu: Contains commands to modify the current selection. This is also
where you access the Log and Transfer window preferences.
• Column headings: Columns display clip properties and metadata. You can use column
headings in the following ways:
• Click a column heading to sort clips by this property. Click the column heading again
to reverse the sort order.
• Control-click and choose a column heading from the shortcut menu to show or hide
additional columns such as Format, Compressor, and Shooting Date.
• Reorder columns by dragging their headings to the left or right.
• Clip properties: Most clip properties are read-only, but you can change some properties,
such as Name, Scene, Shot, In, and Out, by double-clicking them, pressing Enter, or
pressing Return. If a clip name is selected, you can press Tab to edit the name of the
next clip in the Browse area.
Changes to clip properties are stored within the current project, but original clip
properties remain unchanged on the mounted volumes. This means that:
• Before ingesting a clip in the Log and Transfer window, you can revert back to a clip’s
original properties by Control-clicking the clip and choosing Revert to Original
Metadata from the shortcut menu.
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• While logging clips to a new project in the Log and Transfer window, you won’t see
clip property modifications that you made while logging clips in other projects. In
other words, clip properties are only stored on a per-project basis.
• Media map indicators: Indicate how much of a clip’s media has been ingested into the
current project. Before you ingest any media into a project, all the media map indicators
are empty. If you ingest a portion of media from a clip on a volume, that segment is
added to the project as a clip, and the corresponding media map indicator has a partially
filled icon. If you create a new project or close the current one, the media map indicator
for that clip appears empty again. You can click on the Media Map column to sort clips
by their ingesting state.
Media map indicators have three states:
• Empty: No media has been ingested.
• Partial: At least one frame, but not all frames, have been ingested.
• Complete: All of the media for the clip has been ingested.
• Thumbnail Resize slider: Adjust the slider to change the size of clip thumbnails. Click
the large or small thumbnail button to jump to the largest and smallest thumbnail
sizes, respectively.
• Add Selection to Queue button: Click this button to add the currently selected clips in
the Browse area to the Transfer Queue for ingest.
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Controls in the Log and Transfer Preview Area
This section of the Log and Transfer window lets you view a video file as you log and
transfer it.
Timecode Duration field

Clip name
Current Timecode field

Image display area

Transport controls

In point controls

Out point controls

• Timecode Duration field: Displays the duration, in timecode, between the current In
and Out points. If you enter a duration in this field, the Out point is adjusted.
• Current Timecode field: Displays the timecode number of the current frame of your
source file. You can enter a timecode number in this field to navigate to that timecode
point on your file.
Tip: You can drag timecode values to the Log and Transfer timecode fields from other
timecode fields in Final Cut Pro, such as Browser columns. Hold down the Option key
while you drag a timecode value from a column in the Browser to either the Timecode
Duration or the Current Timecode field.
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Transport Controls in the Log and Transfer Window
Use these buttons to control the preview of the file footage. These controls are similar
to controls in the Viewer and Canvas, except that they control playback of a file. For more
information, see “Navigating in the Viewer and Canvas.”
Rewind
Play In to Out

Fast Forward
Play Around
Current Frame
Stop

Play

Jog and Shuttle Controls in the Log and Transfer Window
Jog and shuttle controls, similar to those in the Viewer and Canvas, are also available for
navigating through the file. For more information, see “Navigating in the Viewer and
Canvas.”
Jog control

Scrubber bar

Shuttle control

In the Log and Transfer window, you can use the J, K, and L keys for jogging and shuttling,
just as you can in the Viewer and Canvas. For more information about using the J, K, and
L keys to navigate through your clip, see “Shuttling Through a Clip or Sequence” and
“Jogging Through a Clip or Sequence.”
Note: Jog and shuttle commands are disabled when working with AVCHD footage.
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Navigation and Marking Controls in the Log and Transfer Window
Use these controls to set In and Out points for a clip, navigate to the next or previous clip
in the Browse area, and add clips to the Transfer Queue.
Previous Clip
button

Scrubber bar

In and Out point markers
Next Clip button

In point
controls

Out point
controls

• Mark In (I): This button sets the In point for a clip.
• Clip In Point Timecode field: Shows the timecode value of the currently set In point.
• Go to In Point: This button moves the playhead to the currently set In point.
• Mark Out (O): This button sets the Out point for a clip.
• Clip Out Point Timecode field: Shows the timecode of the currently set Out point.
• Go to Out Point: This button moves the playhead to the currently set Out point.
• Previous Clip: Click this button to select and preview the previous clip in the Browse
area.
• Add Clip to Queue: After you’ve completed setting the In and Out points of a clip, click
this button to move the selected clip into the Transfer Queue for processing and transfer
into your Final Cut Pro logging bin.
• Next Clip: Click this button to select and preview the next clip in the Browse area.

Options in the Log and Transfer Logging Area
The Logging area provides logging options and import setting options.
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Logging Options in the Log and Transfer Window
Click the Logging button in this area to add descriptive information to each clip that you
log, such as reel name, In and Out points, scene, shot/take number, and so on. Much of
this information can also be added later in the Browser.
Autofill pop-up menu
Increment button

Logging fields

• Name Preset pop-up menu: You can use this pop-up menu to choose a naming preset
that will be applied to your clips. For more information about using name presets, see
“Automatically Naming Your Clips.”
• Logging Fields: Enter the information you want applied to a clip in the logging fields.
• Autofill pop-up menus: These pop-up menus provide a list of logging text that you’ve
used previously and allow you to choose and reuse them as needed.
• Increment button: Click to increase the last character of the logging item by one.
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Import Settings Options in the Log and Transfer Window
Use this button to choose which video and audio tracks you transfer from the selected
file. You can choose to transfer video only, audio only, or both video and audio, and you
can specify which audio channels you transfer.
Two audio channels
enabled and grouped
as a stereo pair

One mono channel
enabled

• Video checkbox: Select this checkbox to include the video track of the selected clip in
the transfer into a project. When you deselect it, the video track is not transferred.
• Audio checkbox: Select this checkbox to include the audio track of the selected clip in
the transfer into a project. When you deselect it, the audio tracks are not transferred.
• Apply to Selection button: After making selections in the Import Settings area, click this
button to apply those selections to the clip.

Controls in the Transfer Queue
The Transfer Queue shows a list of clips currently queued for ingest. The status of each
clip is shown and a progress bar indicates how much of a clip’s media has already been
ingested.
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You can pause or restart ingest at any time by clicking the Pause button or by pressing
Command-Control-Q.
Click to reveal the
current logging bin
in the Browser.

Progress bar
Pause button

Click this button
to automatically transfer
a volume’s clips as soon
as the volume
is mounted.

Thumbnail Resize slider

• Reveal Logging Bin: Click this button to reveal the current logging bin in the Browser.
• Pause button: This button starts and pauses the processing of clips in the Transfer
Queue.
• Thumbnail Resize slider: Changes the clip icon size in the Queue area.
• Automatic Transfer button: Click this button to turn on the automatic transfer of files
when a volume is mounted. When turned on, Final Cut Pro will automatically add the
files on the mounted volume to the Transfer Queue and process them using the current
logging presets and preference settings.
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Logging File-Based Media

23

This chapter covers the following:
• Preparing to Log File-Based Media (p. 341)
• Entering Logging Information (p. 343)
• Automatically Naming Your Clips (p. 345)
Logging is an important first phase of editing. The logging information you enter at this
stage serves as a guide throughout the project. For general information about the
importance and benefits of logging, see “The Importance of Logging” and “Benefits of
Logging.” For information about choosing clip names and logging information, see
“Choosing Names and Logging Information for Clips.”

Preparing to Log File-Based Media
During logging, you often find out just how organized you really were during the
production phase. No matter how careful you were, a few things may not have been
labeled properly, or some information may be missing. Take time before you begin
post-production to get your clips as organized as possible.
Remember that the list below is really a production checklist. However, any inconsistencies
during production should be straightened out before you start logging and transferring
clips.
• Clearly label folders of media files with unique, simple names: If for any reason you ever
leave the Final Cut Pro editing environment to work on another system, simpler folder
names will cause less confusion.
• Use a simple clip-naming convention: Final Cut Pro can handle long clip names, but
other systems often can’t.
• Identify the audio sample rate and bit depth of your footage: Although Final Cut Pro can
handle footage with mixed formats in the Timeline, you should make and effort to log
and transfer your footage with matching sample rate and bit depth settings.
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Choosing Reel Names for Folders of File-based Media
Its recommended that you assign reel names to your source media folders to be used by
Final Cut Pro during the logging process. Older editing systems accepted three-digit reel
numbers, starting at 000 and ending at 999. For maximum compatibility, this is a good
naming convention to start with. Unless you have more than a thousand volumes in your
project, this reel-naming convention should be sufficient.
You can use the digits of your reel name to mean different things. For example, the first
digit can be used to represent a particular location, with space for 100 volumes per
location. 100–199 could be used for volumes shot in Washington, D.C., while 200–299
could be used for volumes shot in Los Angeles, and so on. Pick a consistent method, and
if you have to break your convention, have some numbers reserved just for this. For
instance, you could reserve 900–999 for miscellaneous volumes that don’t fit your naming
convention.
Note: If you plan on exporting an EDL, there are restrictions on the reel names you can
use. The restrictions depend on what EDL format you’re using. For more information, see
“Importing and Exporting EDLs.”
When logging, always make sure that you:
• Assign your source media folders simple, unique reel names. Don’t use reel names that
are too long and complicated in order to avoid having to rename folders later during
post-production.
• Take care to assign the proper reel name to each clip as you log and transfer it. If a clip
is assigned the wrong reel name, Final Cut Pro asks for the wrong source folder if you
try to retransfer it.
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Entering Logging Information
After you’ve mounted a volume and selected a clip in the Browse area, you can enter
logging information for the selected clip.

Preview area

Logging area

Transfer Queue area

The Logging area of the Log and Transfer window provides logging fields for:
• Reel
• Clip Name
• Scene
• Shot/Take
• Angle
• Log Note
When you select a clip in the Browse area, Final Cut Pro automatically enters the reel
name (from the Volume column) and clip name (from the Name column) in the logging
fields. You can change these logging items if you want. Remember, however, that keeping
reel names and volume names the same may be critical to locating source media later.
So it’s recommended that you use the name as it appears in the Volume column as the
reel name of your source media.

Chapter 23 Logging File-Based Media

343

If you have already logged clips, previously entered logging information appears in the
pop-up menus of each field. You can open the pop-up menus and choose the logging
information you want. You can also click the Increment buttons beside a logging field to
add a number to the end of the logging information. Each time you click the Increment
button, the number increments by one.
Autofill pop-up menu
Increment button

Logging fields

You can manually enter logging information for a selected clip, creating clip names and
adding information in the logging fields as needed. You can also choose a name preset
that helps you automatically compose a clip name from the logging information you
enter and from the properties of the clip.
When you choose a name preset, Final Cut Pro shows you an example of the clip name
that will be created for the clip.
You can use name presets to quickly log multiple clips without logging them individually.
After you choose a name preset, you can drag groups of clips to the Transfer Queue and
Final Cut Pro uses the name preset to apply logging information to each clip. For example,
you can choose a name preset that specifies that clips receive a custom name with a
counter (for example, Close Up Fountain 001). As you drag a group of clips to the Transfer
Queue, Final Cut Pro applies the names Close Up Fountain 001, Close Up Fountain 002,
Close Up Fountain 003, and so on, to the subsequent clips until all the clips have been
named.
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Automatically Naming Your Clips
The names given to files by the camcorder are often difficult to distinguish. When you
transfer media and create clips in your projects, you can have Final Cut Pro use a
clip-naming convention, called a preset, that you choose or create. For example, you can
use a name format that includes a clip name that you specify, plus the reel, shot or take,
scene, and any date information that you want. You can also select from any of the clip’s
metadata listed in the Name Preset dialog.
Final Cut Pro provides a number of preset name formats, and you can also create your
own naming conventions. You choose the preset name format you want applied before
you transfer clips to the Transfer Queue. That name format is then used for all clips you
place in the Transfer Queue. The same clip name is applied to the media file transferred
to your scratch disk as to the clip in the project. A sample of the clip name appears in the
Logging area. To give other clips a different style of clip name, choose or create a different
name preset before placing the clips in the Transfer Queue. A list of the available name
presets appears in the Name Preset pop-up menu.
Final Cut Pro provides the following preset name formats:

µ

Preset name format

Example

Current Name and Clip
Date/Time

Clipname 2008-01-01 at 01_45_12

Current Name with Counter

Clipname 001 Partial Span

Clip Date/Time

2008-01-01 at 01_45_12 Partial Span

Custom Name with Counter

Custom clipname 001 Partial Span

To choose a preset name format
In the Logging area of the Log and Transport window, choose a name format from the
Name Preset pop-up menu.

Applying Valid Filenames
Proper filenaming is one of the most critical aspects of media and project management.
The following sections present several issues to consider when naming clips and their
media files, and describe how to create custom name formats.
Avoiding Special Characters
The most conservative filenaming conventions provide the most cross-platform
compatibility. This means that your filenames will work in different operating systems,
such as Mac OS X and other UNIX-based operating systems, Mac OS 9, and Windows. You
also need to consider filenaming when you transfer files via the Internet, where you can
never be certain what computer platform your files may be stored on, even if temporarily.
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Avoid

Example characters

Reasons

File separators

: (colon)
/ (slash)
\ (backslash)

You cannot use colons in the names of files and
folders because Mac OS 9 (Classic) uses this
character to separate directories in pathnames. In
addition, some applications may not allow you to
use slashes in the names of items. These characters
are directory separators for Mac OS 9, Mac OS X,
and DOS (Windows) respectively.

Special characters not
included in your native
alphabet

¢™

These characters may not be supported or may
be difficult to work with when exported to other
applications.

Punctuation marks,
parentheses, quotation
marks, brackets, and
operators

.,[]{}()!;“`*?<>|

These characters are often used in scripting and
programming languages.

White space characters
such as spaces, tabs,
new lines, and carriage
returns (the last two are
uncommon)

White space is handled differently in different
programming languages and operating systems,
so certain processing scripts and applications may
treat your files differently than expected. The most
conservative filenames avoid all use of white space
characters, and use the underscore (_) character
instead.

Creating Custom Name Formats
In addition to the preset name formats, you can create custom name formats. To create
a name format, you select the name elements you want in the Naming Presets dialog.
You can compose a name format that combines the name elements that appear in the
dialog.
To create a custom name format
1 In the Logging area of the Log and Transfer window, choose New from the Name Preset
pop-up menu.
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The Naming Presets dialog appears.

2 Click the Add (+) button to create a new name format, or select the preset name format
you want to change.
3 Drag the name elements you want into the Format field in the order you want them. You
can also add valid characters or spaces between the name elements. For more information
about valid filenaming characters, see “Avoiding Special Characters.”
4 Enter a custom name in the Custom Name field, if you want.
5 Click OK.
Your new name format now appears in the Name Preset pop-up menu.
When using a counter in your name format, you can specify the starting number and the
number of digits, from one to six, that appear in the counter. When you use a preset
name format with a counter, make sure to reset the initial starting number, if necessary.
Otherwise, on the next import Final Cut Pro will continue numbering the imported images
starting from the last number of the previous import.

µ

To reset the starting number of a counter in a name format
In the Naming Presets dialog, type 0 (zero) in the “Incrementing counter starting at” field.
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Transferring File-Based Media

24

This chapter covers the following:
• About Transferring File-Based Media (p. 350)
• Choosing a Scratch Disk and Logging Bin (p. 351)
• Mounting Media Devices (p. 351)
• Mounting Media Volumes in the Log and Transfer Window (p. 352)
• Choosing a Destination Codec (p. 353)
• Viewing Clips to Be Transferred (p. 353)
• Selecting Clips (p. 354)
• Previewing Clips (p. 355)
• Logging Clips in the Log and Transfer Window (p. 356)
• Placing Clips in the Transfer Queue (p. 358)
The process of transferring file-based media is similar to that of capturing tape-based
footage using the Log and Capture window, although it is often much faster because
you avoid the inconveniences of tape. After you record your media using a device such
as a Panasonic P2, XDCAM, or AVCHD camcorder, you can connect the device to your
computer and transfer the media into Final Cut Pro using the Log and Transfer window.
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About Transferring File-Based Media
When transferring clips from file-based media, you gain the advantage of being able to
efficiently access and work with files on a computer, as opposed to working with a
camcorder or tape device that linearly rolls through your tape. This ease of access gives
you flexibility in how you transfer media files to your hard disk as clips. You can
automatically transfer whole volumes of clips off a storage device in one batch and then
apply In and Out points and logging information to each clip later. You can work with
individual clips, setting In and Out points and logging information one by one or as
needed. And you can also transfer and log groups of clips as your editing needs and
schedule require. The workflow and steps taken to successfully ingest clips can change
to suit your editing needs. The importance of being organized and consistently logging
clips for your projects remains high, but the acquisition of your clips is easier and more
flexible.
This chapter presents the basic steps for a standard transfer of file-based media. You can
adjust your logging and transferring workflow to suit your purposes. One of the
determinants of your workflow involves the type of camcorder and video format that
your media was recorded with. Advanced camcorders, such as those that record HD or
other advanced formats that rival digital intermediate resolutions, may require the media
to be ingested using specific plug-ins, codecs, or types of transcoding to support editing
with Final Cut Pro. For more information about supported camcorders and video editing
workflows supported by Final Cut Pro, see Professional Formats and Workflows, available
in Final Cut Pro Help.
The standard workflow for transferring file-based media is outlined below. For details,
see the sections that follow.
Stage 1: Choosing a Scratch Disk and Logging Bin
See “Choosing a Scratch Disk and Logging Bin” for information about specifying where
the file-based media will be stored.
Stage 2: Mounting Media Devices
See “Mounting Media Devices” for information about mounting a media device on your
desktop.
Stage 3: Mounting Media Volumes in the Log and Transfer Window
See “Mounting Media Volumes in the Log and Transfer Window” for information about
beginning the log and transfer process by opening the Log and Transfer window.
Stage 4: Choosing a Destination Codec
See “Choosing a Destination Codec” for information about choosing the codec for your
transferred media.
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Stage 5: Viewing Clips to Be Transferred
See “Viewing Clips to Be Transferred” for information about using the Browse area to view
the contents of the mounted volumes.
Stage 6: Selecting Clips
See “Selecting Clips” for information about selecting clips to preview and log.
Stage 7: Previewing Clips
See “Previewing Clips” for information about previewing selected clips.
Stage 8: Logging Clips in the Log and Transfer Window
See “Logging Clips in the Log and Transfer Window” for information about logging
selected clips and modifying their descriptive information before transferring them.
Stage 9: Placing Clips in the Transfer Queue
See “Placing Clips in the Transfer Queue” for information about monitoring, pausing, and
restarting the transfer process.

Choosing a Scratch Disk and Logging Bin
One of the first steps in transferring file-based media is to choose the scratch disk and
logging bin where the media files and clips will be stored. The scratch disk you choose
in this stage is where your digital video will be captured and edited, and where the
project’s render files will be stored. The logging bin is where all the clips that are logged
are stored.
To choose a scratch disk and logging bin
1 Connect the storage device where you will be storing your project media.
In the Finder, the storage media should be recognized and should appear on the desktop.
2 Choose Final Cut Pro > System Settings, then click the Scratch Disks tab.
3 Choose a scratch disk to determine where ingested media will be stored.
4 In the Final Cut Pro Browser, choose a logging bin where ingested clips will be stored in
your project.

Mounting Media Devices
A file-based media device needs to be mounted on the desktop as a media volume before
you can ingest media from the device. Most media devices can be set to a special file
access mode and then connected to your computer via FireWire or USB.
For details, see the documentation included with your particular media device. You can
also mount disk images of media volumes.

Chapter 24 Transferring File-Based Media

351

Important: Make sure you unmount any volumes before you physically remove storage
media or disconnect a media device from your computer.
To unmount a volume
Do one of the following:

µ

In the Log and Transfer window, select a volume, then click the Eject button (or press
Command-Option-E).

µ

In the Finder, select the mounted volume, then choose File > Eject (or press Command-E).
After unmounting the volume, you can remove the storage media or disconnect the
media device.

Using Folders with a Valid File-Based Media Folder Structure
The Log and Transfer window can transfer media from any folder with a valid folder
structure. You can create these folders by copying them from their respective cards and
devices to your hard disk.
Important: Final Cut Pro recognizes compliant folders that include the original files and
folder organization. If you need to copy the entire contents of a file-based media device
to a hard disk, duplicate the contents without making any changes.

Mounting Media Volumes in the Log and Transfer Window
After choosing the scratch disk and logging bin and mounting your media on your
computer, you can begin the log and transfer process by opening the Log and Transfer
window.
To open the Log and Transfer window and mount the media volumes
1 Choose File > Log and Transfer (or press Command-Shift-8).
Any mounted volumes appear in the Browse area.
2 If necessary, add additional file-based media folders or disk images from the Finder by
doing one of the following:
• Click the Add Volumes button in the upper-left corner of the Browse area, choose a
folder, then click OK.
• Drag a folder from the Finder to the Browse area, then release the mouse button.
• From the Action pop-up menu in the upper-right corner of the Browse area, choose
Add Custom Path, choose a folder, then click OK.
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Choosing a Destination Codec
To select the destination codec for your transferred media, choose Preferences from the
Action pop-up menu in the Browse area. Final Cut Pro includes built-in support for P2
media and AVCHD. There are third-party plug-ins for other formats. For more information
about the format choices, plug-in downloads, and workflows for advanced file-based
camcorders supported by Final Cut Pro, see Professional Formats and Workflows, available
in Final Cut Pro Help.
If the format you are ingesting is not natively supported by Final Cut Pro (such as AVCHD
or AVC-Intra), you need to choose a format, such as an Apple ProRes codec, to transcode
your media to.

Viewing Clips to Be Transferred
The Browse area allows you to view the contents of any mounted volumes and select
clips to be transferred using the Transfer Queue. Valid volumes appear automatically in
the Browse area when you open the Log and Transfer window.
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Note: The Log and Transfer window shows all available mounted volumes and folders
that were displayed the last time the window was open.
Add Volume button
Eject button

Search field

Flat List View and
Hierarchical List
View buttons
Action pop-up menu
Column headings

Mounted volume
Media map indicator
shows how much media
has been ingested.

Folder with valid
structure
Double-click a clip
property to modify
it, or press Enter.
Click to add selected
clips to the
Transfer Queue.
Thumbnail Resize slider

Selecting Clips
You can select clips in the Browse area by clicking anywhere in the row containing the
clip’s name. You can select a range of clips by clicking one clip and then Shift-clicking a
second clip. Command-click clips to add them to or remove them from the current
selection. You can select all clips in the Browse area by choosing Edit > Select All (or
pressing Command-A). You can deselect all clips by choosing Edit > Deselect All (or
pressing Command-Shift-A).
Final Cut Pro treats the selected clips in the Browse area as a continuous entity that you
can navigate through using the transport controls in the Preview area. For example, if
you have two clips selected in the Browse area, when the playhead reaches the end of
the first selected clip, it continues playing the second clip. For more information, see
“Transport Controls in the Log and Transfer Window .”
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To select clips to preview and log
1 Select a clip in the Browse area of the Log and Transfer window to view it in the Preview
area.
2 In the Preview area, set In and Out points to identify the media you want to transfer.
Note: Some formats do not support setting In and Out points.
After selecting a clip you want to transfer, you can preview it and add a variety of logging
information, including reel, shot/take and angle information, log notes, and markers.

Previewing Clips
The Preview area allows you to view your clips.
Timecode Duration field

Clip name
Current Timecode field

Image display area

Transport controls

In point controls

Out point controls

The transport controls include the following buttons and markers.
Jog control

Scrubber bar

Shuttle control

Note: When the format of a file-based media clip doesn’t allow the use of certain features
in the Preview area, the feature controls don’t appear in the window.
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The transport, navigation, and marking controls in the Preview area work in the same
way as the controls in the Viewer and Canvas. The same keyboard shortcuts, including
the J, K, and L keys for playback, also work. Looped playback can be turned on or off by
choosing View > Loop Playback (or by pressing Control-L).
You can press the Tab key to move through the fields in the Preview and Logging areas.
For more information about the controls in the Viewer, see “Viewer Basics.”
Final Cut Pro treats all the selected clips in the Browse area as a single continuous entity
when you are jogging; shuttling; using the J, K, and L keys; or clicking the Previous Clip
and Next Clip buttons. For example, when the playhead reaches the end of a clip in the
selection, the next selected clip is opened and playback continues. However, if you enable
looped playback (by choosing View > Loop Playback or by pressing Control-L), playback
is limited to the clip that appears in the Preview area.
The Previous Clip and Next Clip buttons navigate within the range of selected clips in the
Browse area. (However, if just one clip is selected, you can navigate through all the clips.)
To move from clip to clip within the selected clips in the Browse area
Do one of the following:

µ
µ

Click the Previous Clip button (or press Command–Control–Left Arrow).
Click the Next Clip button (or press Command–Control–Right Arrow).

Logging Clips in the Log and Transfer Window
You use the Logging area to modify a clip’s reel name and other descriptive information
before transfer. Data entered here is stored with project clips after transfer.
Autofill pop-up menu
Increment button

Logging fields

The fields here are similar to the logging fields in the Log and Capture window. Press Tab
to move from field to field, and press Shift-Tab to move through fields in reverse.
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You can reset clip logging fields and metadata by Control-clicking one or more clips in
the Browse area and choosing Revert to Original Metadata from the shortcut menu. The
following clip properties are reset: Reel, Name, Scene, Shot/Take, Angle, Log Note, In, Out,
and the clip’s playhead position.

Naming Clips During Transfer
When you’re logging clips for large projects, it’s especially important to use easily
understandable clip names that also lend organization to your project. You can use
clip-naming presets to apply consistent naming to your clips. For example, you can specify
that Final Cut Pro apply clip names that include the reel, shot, scene, and angle in the
clip name, making each clip more easily identifiable later. You can create clip-naming
presets that compose names using a large variety of identifying elements, and save these
clip-name components as a preset that you can reuse whenever needed. For more
information about creating and using clip-naming presets, see “Automatically Naming
Your Clips.”

Using Autofill Cache Logging Information
Unlike the fields in the Log and Capture window, the fields in the Logging area of the
Log and Transfer window retain an autofill cache of previously logged information so
that you can enter repetitive information more quickly.
Note: Final Cut Pro adds logging information to the autofill cache only when a clip is
ingested.

µ

To enter previously logged data from the autofill cache
Choose previously entered logging data from the pop-up menu next to the logging field.

To empty the autofill cache so that previously logged data does not appear in logging
fields
1 In the upper-right corner of the Browse area, choose Preferences from the Action pop-up
menu.
2 Click Clear Logging Autofill Cache.

Incrementing Logging Fields
Most of the logging fields have an Increment button you can click to increase the value
of the last character of the clip name by one, according to the following rules:
• Any numbers at the end of a field are incremented by one.
• Any single letters at the end of a field are incremented alphabetically by one from A
to Z.
• Any single letters preceded by numbers are incremented alphabetically from A to Z.
After Z, the number increases by one and the letter starts over at A, and then the cycle
repeats.
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• A number is appended to any fields ending with multiple letters, and is incremented
by one. For example, ABC is followed by ABC1, then ABC2, and so on.

Setting Audio and Video Clip Import Settings
You can open the Import Settings pane by clicking the Import Settings button in the
Logging area. Here you can specify whether video or audio is transferred, as well as the
number and grouping of the audio channels. Audio meters display audio input levels on
enabled channels.
Note: Some formats, such as AVCHD, are automatically mixed down to stereo. For these
formats, you cannot adjust audio settings.
Two audio channels
enabled and grouped
as a stereo pair

One mono channel
enabled

When a single clip is selected in the Browse area, clip import settings are applied to that
clip.
To apply import settings to multiple clips
1 Shift-click or Command-click multiple clips in the Browse area to select them.
2 Enable video and audio channels in the Import Settings pane.
3 Click Apply to Selection, then click OK in the dialog that appears.

Placing Clips in the Transfer Queue
The Transfer Queue shows a list of clips currently queued for transfer. The status of each
clip is shown and a progress bar indicates how much of a clip’s media has already been
transferred.
You can pause or restart transfer at any time.

358

Chapter 24 Transferring File-Based Media

To pause or restart transfer of files in the Transfer Queue
Do one of the following:

µ
µ

Click the Pause button.
Press Command-Control-Q.
Click to reveal the
current logging bin
in the Browser.

Progress bar
Pause button

Click this button
to automatically transfer
a volume’s clips as soon
as the volume
is mounted.

Thumbnail Resize slider

Important: Ingesting clips always extracts your media from the original storage media
and copies it to a new QuickTime file on your scratch disk. For example, if you ingest 4 GB
of DVCPRO HD footage from a P2 folder on your hard disk, an additional 4 GB of disk
space is required for the QuickTime movie file. In cases where your source footage is
transcoded, the resulting QuickTime movie can be significantly larger than the original.

Adding Clips to the Transfer Queue for Transfer
There are many ways to add clips to the Transfer Queue.
To add clips to the Transfer Queue
Do one of the following:

µ
µ
µ

In the Browse area, select one or more clips, then click Add Selection to Queue.

µ

In the Preview area, click the Add Clip to Queue button.

Drag one or more clips from the Browse area to the Transfer Queue.
Drag a volume from the Browse area to the Transfer Queue. All clips on the volume are
added to the Transfer Queue at once.
Note: When you click the Add Clip to Queue button, only the clip that appears in the
Preview area is added to the Transfer Queue.

µ

Click in the video image in the Preview area and drag the image to the Transfer Queue.
You can also drag clips from the Log and Transfer window to your project in the Browser.
Those clips are automatically logged in the project and added to the Transfer Queue, and
their media is transferred.

Chapter 24 Transferring File-Based Media

359

Organizing Clips in the Transfer Queue
The Status column displays the transfer status of each clip in the Transfer Queue:
• Ingesting: A spinning disc indicates media is being transferred to your scratch disk.
• Paused: A still disc indicates the current clip is partially transferred.
• Error: An exclamation point indicates that ingest of the file failed. The source media for
this clip may have been unmounted or moved since the clip was added to the Transfer
Queue. Other errors, such as running out of disk space, may have occurred. You can
hold the pointer over the exclamation point to display a tooltip that identifies the error.
You can Control-click the clip that failed to ingest and use the shortcut menu to try
reingesting, or delete the clip and add it to the Transfer Queue again.
Clips are transferred one at a time in the order they appear. You can reorder clips by
dragging them above or below other clips. You can also stop the transfer of clips by
selecting them and deleting them from the Transfer Queue.

About Pausing and Stopping Transfer
Final Cut Pro does not save partially transferred media. If the Transfer Queue is in the
process of transferring a clip (or if a transfer is paused), Final Cut Pro warns you that you
will lose the partially transferred media if you do any of the following:
• Delete the clip from the Transfer Queue.
• Close the Log and Transfer window.
• Close the current Final Cut Pro project containing your logging bin.
• Quit Final Cut Pro.

Using Automatic Transfer
Final Cut Pro allows you to automatically transfer all the clips on a volume as soon as the
volume is mounted. When a volume is mounted, Final Cut Pro immediately transfers any
clips on the volume to the Transfer Queue and uses the name preset chosen from the
Name Preset pop-up menu to add logging information. Automatically transferring clips
is a convenient way of transferring many clips at once without individually adding logging
information or setting In and Out points. Final Cut Pro transfers entire clips from the
volume.

µ
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To turn automatic transfer on or off
Click the Automatic Transfer button in the Transfer Queue.
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When you’re ingesting spanned clips using the Automatic Transfer feature, it’s
recommended that you mount all the volumes that hold the different segments of a
spanned clip so that Final Cut Pro has access to the volumes it needs before you turn on
automatic transfer. If not all volumes are mounted, Final Cut Pro transfers as many
segments of the spanned clip as are available on the mounted volumes as individual
clips. You can later mount the missing volumes, complete the transfer of the missing
segments of the spanned clip, and then reassemble the spanned clip. For more information
about spanned clips, see “Viewing Spanned Clips in the Browse Area.”
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Advanced Topics in Transferring
File-Based Media

25

This chapter covers the following:
• Setting Log and Transfer Import Preferences (p. 363)
• Retransferring Clip Media (p. 364)
• Viewing Spanned Clips in the Browse Area (p. 366)
• Archiving File-Based Media from Cards (p. 368)
This section describes some of the advanced topics and issues that an editor may
encounter when transferring file-based media; for example, how to retransfer clips from
source media when transferred clips become unavailable, how to view spanned clips,
how to archive file-based media for safekeeping, and how to set log and transfer import
settings.
Many different factors are involved when transferring media from advanced camcorders,
depending on the type of camcorder. File-based camcorders now record media with
many choices of file formats, video and film workflows, and transcoding options. For
detailed information about specifically supported camcorders, video formats, and editing
workflows, see Professional Formats and Workflows, available in Final Cut Pro Help.

Setting Log and Transfer Import Preferences
The Log and Transfer window has several preferences that you can access by choosing
Preferences from the Action pop-up menu in the Browse area:
• Remove Advanced Pulldown and Duplicate Frames: This option removes advanced
pull-down and redundant (duplicate) frames recorded in formats such as DVCPRO HD.
• Clear Logging Autofill Cache: This option empties the cache of information previously
entered in each logging field.
• Log and Transfer plug-in transcode settings: For formats not natively supported by
Final Cut Pro, you can choose a format to transcode your footage to during transfer.
The Log and Transfer window plug-in for each storage media type (Panasonic P2,
AVCHD, and so on) defines which formats are not natively supported by Final Cut Pro
and which destination codecs you can transcode these formats to.
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For example, the built-in P2 AVC-Intra plug-in allows you to transcode AVC-Intra footage
to Apple ProRes 422 or Apple ProRes 422 (HQ) footage.
To choose the destination codec for non-native footage transferred in the Log and
Transfer window
1 In the Log and Transfer window, choose Preferences from the Action pop-up menu in
the upper-right corner of the Browse area.
2 In the dialog that appears, identify the plug-in and format you want to transcode, choose
a destination codec in the “Transcode to” column, then click OK.

Retransferring Clip Media
If you need to conform media for an online edit or if a clip’s media files are deleted or
lost, you can retransfer (reingest) the clip’s media from the original source volume at any
time.
Transferred clips store a media tracking identifier called a clip ID. Each clip contains a
unique clip ID number that is dedicated to only that clip and a volume ID that identifies
the clip’s volume. When you log and transfer a clip, the clip IDs are stored in the clip
within your project.
When you want to transfer a clip again, Final Cut Pro searches the current volumes in the
Log and Transfer window for a clip whose clip ID matches. If no clip has a matching clip
ID, Final Cut Pro tells you that the volume containing that clip is not mounted. Final Cut Pro
displays a dialog box that identifies the missing volumes that need to be mounted.
When retransferring spanned clips, Final Cut Pro checks that all the necessary volumes
are mounted, and, if not, you can locate them using the Missing Volumes dialog. The
missing volumes are identified by the clip IDs given to the clip segments when you initially
transferred them. Previous versions of Final Cut Pro did not assign volume IDs to spanned
clips, and if you retransfer such spanned clips with missing segments on unmounted
volumes, Final Cut Pro cannot help identify missing volumes using volume IDs. You must
locate and manually mount the necessary volumes to complete the retransfer of the
spanned clip. For more information about spanned clips, see “Viewing Spanned Clips in
the Browse Area.”

364

Chapter 25 Advanced Topics in Transferring File-Based Media

Choosing Reel Names and Understanding Volume Names
When you log clips in the Log and Transfer window, it is important to assign memorable,
meaningful reel names so that you can find volumes later for transfer. This is also especially
important when you are transferring spanned clips because a spanned clip’s media comes
from several volumes, and, by default, Final Cut Pro assigns each clip the Reel property
that includes the volume names of the spanned clip. You should try to assign a reel name
that describes each volume required for the spanned clip. For example, the reel name
10A_10B_10C could indicate that a clip requires three volumes: 10A, 10B, and 10C.
When warning you that the volume is missing, Final Cut Pro tells you the clip’s assigned
Reel property, not the volume name. Although both reel name and volume name are
important for keeping track of your clips, Final Cut Pro does not make use of them for
retransfer. Instead, Final Cut Pro searches any mounted volumes for clips that have clip
ID numbers that match the clips you want to transfer. This means you can retransfer the
clip from any volume as long as the volume contains a clip with the matching clip ID.
To retransfer media for clips created in the Log and Transfer window
1 In the Browser, select the clips whose media you want to transfer.
2 Do one of the following:
• Choose File > Batch Capture (or press Control-C).
• Make sure the Log and Transfer window is open, then drag the selected clips from the
Browser to the Transfer Queue area.
3 In the dialog that appears, specify whether you want to transfer media for all selected
clips or only clips whose media files are offline, then click OK.
If Final Cut Pro cannot find media with a matching clip ID on the currently mounted
volumes, a Reconnect dialog appears enabling you to search for and add volumes that
you need. After you’ve located all the missing volumes that contain the segments of the
clips that you want to transfer, the dialog closes and Final Cut Pro transfers the spanned
clip.
For more information about adding a volume to the Log and Transfer window, see
“Mounting Media Volumes in the Log and Transfer Window.”
Important: Because it is so easy to make archived disk images and copied folders of your
cards, you can potentially add more than one volume containing the same clip to the
Browse area in the Log and Transfer window. This can cause unexpected results, especially
when viewing or ingesting spanned clips.
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Retransferring Decode-Only Formats
Some formats, such as REDCODE or AVC-Intra, are decode-only formats. This means you
cannot encode to (or edit with) these formats and you must edit these formats with an
alternative codec, such as an Apple ProRes codec.
In an offline-online editing workflow, when you finish editing your offline sequence, you
might retransfer footage using the native format for an online edit. If you are retransferring,
it is important that you set Log and Transfer preferences to the native format (for example,
REDCODE or AVC-Intra) before using the Batch Capture feature to retransfer. You can
configure the sequence settings in a separate step. In the case of a decode-only format
such as REDCODE or AVC-Intra, the sequence format will be an alternative codec, such
as an Apple ProRes codec.
For more information about Log and Transfer preferences, see “Setting Log and Transfer
Import Preferences.” For more information about transferring specific formats (such as
REDCODE or AVC-Intra), see Professional Formats and Workflows, available in Final Cut Pro
Help.

Viewing Spanned Clips in the Browse Area
A spanned clip is created any time you record a single shot that is larger than the capacity
of the current storage media unit or when the file size exceeds that allowed by the device’s
file system. For example, when a file on a P2 card exceeds a 4 GB limit, a spanned clip is
created. When this happens, the camcorder stops recording the current media file and
begins recording a new media file on a new storage media unit. The result is a single shot
that seamlessly comprises multiple media files.
Important: To transfer or retransfer a spanned clip as a single media file, you need to
mount all the volumes necessary for the clip. Mounting separate volumes at different
times may cause Final Cut Pro to capture only individual portions of a clip when other
segments are missing.
The Browse area of the Log and Transfer window can display clips two ways: in Hierarchical
List view and Flat List view. The following example shows how a spanned clip consisting
of five clips (on five volumes) appears in both views.
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In both views, segments of a spanned clip appear separately when the spanned clip is
missing segments from other volumes. However, when a spanned clip is complete, it is
displayed differently depending on the view you choose.

Incomplete spanned clip
in Hierarchical List view

Incomplete spanned clip
in Flat List view

In Flat List view, a complete spanned clip appears as a single item in the Browse area. In
Hierarchical List view, the same spanned clip appears within each volume that contains
one of the spanned clip’s segments.

Hierarchical List view displays
multiple, identical spanned clips.

Flat List view displays a single spanned clip.

To avoid confusion, it’s usually best to use Flat List view when transferring spanned clips.
When a spanned clip is incomplete, you can transfer each segment as an individual
QuickTime media file and clip. However, when all segments of a spanned clip are available,
you can transfer all of the spanned clip’s media to a single QuickTime file.
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Tip: When logging spanned clips, assign reel names that indicate all volumes from which
a clip originated. For more information, see “Choosing Reel Names for Folders of File-based
Media.”

Archiving File-Based Media from Cards
Unlike tape, which is cheap enough to archive permanently, cards are expensive to use
for long-term file storage. Therefore, you need to erase your cards to make room for more
recording. Before you erase your cards, you should archive their contents in case you
need the media later.
You can back up a card’s media in two ways:
• Copy the folder on the card to another hard disk.
• Create a disk image of the card that you can mount later as a volume.

Archiving to a Folder
You can copy the folder of a volume directly in the Finder, or you can use the Archive to
Folder command in the Browse area of the Log and Transfer window.
To create a copy of the folder of a volume using the Log and Transfer window
1 In the Browse area, make sure the Hierarchical List View button is selected.
2 Select the volume you want to copy.
3 Do one of the following:
• Control-click the volume, then choose Archive to Folder from the shortcut menu.
• Choose Archive to Folder from the Action pop-up menu in the upper-right corner of
the Browse area.
4 Enter a name for the copied folder. By default, the name of the volume is used.

Archiving to a Disk Image
The Archive to Disk Image command produces a readable, writable disk image that is
easily stored on other hard disks or disc media and can be easily opened to access the
archived content.
To create a disk image of a card
1 In the Browse area, make sure the Hierarchical List View button is selected.
2 Select the card whose contents you want to archive.
3 Do one of the following:
• Control-click the card icon, then choose Archive to Disk Image from the shortcut menu.
• Choose Archive to Disk Image from the Action pop-up menu in the upper-right corner
of the Browse area.
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4 Enter a name for the disk image file. By default, the name of the volume is used.
Important: The name you enter here is the name of the disk image (.dmg) file, not the
name of the disk image contained within it.
To rename a mounted volume of an archived disk image
1 In the Log and Transfer window, select a volume and then choose Archive to Disk Image
from the Action pop-up menu in the Browse area.
A new disk image (.dmg) file is created on the desktop.
2 Switch to the Finder (click the Finder icon in the Dock, or press Command-Tab).
3 Double-click the new disk image you just created to mount it on the desktop.
4 Select the mounted volume on the desktop, then press Return to select the volume name.
5 Enter a new name for the mounted volume, then press Return.
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Importing Media Files into Your
Project

26

This chapter covers the following:
• What File Formats Can Be Imported? (p. 371)
• Importing Media Files (p. 372)
• About Importing Video Files (p. 375)
• About Importing Audio Files (p. 377)
• Importing Still Images and Graphics (p. 382)
• Importing Numbered Image Sequences (p. 383)
Final Cut Pro can import almost any media file that QuickTime recognizes, allowing you
to integrate different formats within a single project.

What File Formats Can Be Imported?
Importing files into Final Cut Pro for use in your sequences is fairly straightforward. You
can import various kinds of files, including video, audio, still images and graphics, and
numbered image sequences.
You can import any files that are recognized by QuickTime, including:
• Video files: QuickTime Movie, AVI, and Macromedia Flash (video only—you won’t be
able to play any audio portions).
For details about these formats, see “Learning About QuickTime.”
• Audio files: AIFF/AIFC, Sound Designer II, System 7 Sound, uLaw (AU), and WAVE.
For details about these formats, see “About Importing Audio Files.”
• Graphics and still images: BMP, FlashPix, GIF, JPEG/JFIF, MacPaint (PNTG), Photoshop
(layered), PICS, PICT, PNG, QuickTime Image File, SGI, TARGA (TGA), and TIFF.
For more information, see “Working with Freeze Frames and Still Images.”
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• Numbered image sequences: Numbered image sequences allow you to store a movie’s
frames as individual graphics files. Compositing applications, such as Shake, and film
transfer equipment often use this format. Final Cut Pro does not convert image
sequences into a single clip, but instead creates individual clips for each graphics file
you import.

How Is Importing Different from Capturing?
Importing is different from capturing in the following ways:
• Capturing: When you capture, you transfer and often convert footage from an external
video or audio device to your scratch disk.
• Importing: You import files when they are already stored on your scratch disk. Importing
media files creates clips in your project; these clips refer back to the media files on disk.
Since capturing creates media files, you can always import captured media files into your
project at any time.

Importing Media Files
You can import single files, a folder, or a group of folders. If you import a group of folders
that contain folders inside one another, Final Cut Pro imports all files in each folder and
subfolder that are in formats it recognizes; incompatible file types are ignored.
Folders imported into your project appear as bins in the Browser. If you import a group
of folders, Final Cut Pro creates bins and organizes the files in the same hierarchy as on
your hard disk. However, unlike with clips and media files, there is no further relationship
between bins and folders after you import. Changing the name or location of a bin in
your project has no effect on the folders in the Finder, and vice versa.
To import a file or folder
1 In the Browser, select a project or bin where you want to store your imported clips.
• To import files or folders into the main, or root, level of a project: Click that project’s tab.
• To import files into a bin within a project: Double-click the bin. The bin opens in a separate
window.
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For more information, see “Organizing Footage in the Browser.”
To import files at the
main level, click a
project’s tab.

To place imported files in
a bin, first open the bin
by double-clicking it.

2 Do one of the following:
• Choose File > Import, then choose File or Folder from the submenu. (To import a file,
you can also press Command-I.) Select one or more files or folders in the dialog, then
click Choose.

Select the file (or folder)
you want to import, then
click Choose.
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• Control-click in the Browser or a bin’s window, then choose Import > Files or Import >
Folder from the shortcut menu. Select a file or folder in the dialog, then click Choose.

Choose an import option,
then in the dialog that
appears, locate the file or
folder you want to
import and click Choose.

• Drag one or more files or folders from the Finder to a project tab or bin in the Browser.
This is a fast and easy way to import many files.

• You can also drag the files or folders from your desktop to the Timeline of a sequence.

Clips you drag directly
to the Timeline are
independent (they
have no master clips
in the Browser).
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Important: Dragging media files directly to a sequence in the Timeline creates
independent clips, which have no master clips in the Browser. This can make media
management more difficult later. For more information about master-affiliate clip
relationships, see “Working with Master and Affiliate Clips.”
3 Save your project.
For more information, see “Creating and Saving Projects.”

Tips When Importing
When you import media files, keep the following in mind:
• If you want to import media files from removable storage media, such as a CD, do not
import the files directly. Instead, copy the files to the folder on your scratch disk where
your other project media is stored. Clips that refer to removable media become offline
when you eject the disc.
• When importing QuickTime reference movies, the only file that will be recognized by
Final Cut Pro is the main file that contains the references (to the other associated files).
You may see error messages, such as “file unknown,” if you try to import these referenced
files.
• While not necessary, it’s a good idea to keep all of the media files used for any given
project together, for organizational purposes. When you back up or archive your project
file, you’ll also want to back up or archive any graphics, audio, or QuickTime files that
weren’t captured from tape, so they don’t get lost.
• Final Cut Pro supports both RGB and Y′CBCR (YUV) color spaces, depending on the video
codec used. When using the Y′CBCR color space, Final Cut Pro supports either 8- or
10-bit resolution.

About Importing Video Files
You can import any QuickTime-compatible media files into Final Cut Pro, but to avoid
rendering, your media files need to match your sequence settings. For example, if you
create a motion graphics title sequence in another application and then export to a
QuickTime movie for use in Final Cut Pro, make sure you export using the same settings
as the sequence into which you plan to edit the title sequence.
To export a movie file for use in your Final Cut Pro sequence
1 Check the following sequence settings of the sequence you want to edit your exported
media file into:
• Frame rate (editing timebase)
• Image dimensions
• Pixel aspect ratio
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• Video codec and quality settings
• Audio sample rate and bit depth
For details on how to do this, see “Sequence Settings and Presets.”
2 Set your QuickTime export settings to match the settings of the sequence you want to
edit your exported media file into.
To import a QuickTime movie file into Final Cut Pro, follow the steps in “Importing Media
Files.”
If any of the settings in your imported QuickTime file don’t match your sequence settings,
a red video render bar appears in the Timeline when you add that clip to the sequence.
You can check the settings of the clip by choosing Edit > Item Properties > Format.

About MXF-Based Formats
MXF is not a video format itself, but rather a format that can contain almost any kind of
video or audio media. MXF is similar to QuickTime, which is not a single video signal, but
a general media format that can contain video compressed with supported codecs, audio
with different sample rates, video with different dimensions, frame rates, and so on.
A number of video formats can be stored within MXF files. For example, a DV movie can
be stored within an MXF file. Final Cut Pro works with QuickTime media files, so you need
to convert MXF data to QuickTime before you can start editing.
Some examples of popular video formats that are stored in an MXF container include:
• IMX: A standard definition, MPEG-2, I-frame-only video format. IMX media can be stored
on a tape, hard disk, or optical disc.
• Footage on Panasonic P2 cards: P2 cards store DV, DVCPRO, DVCPRO 50, or DVCPRO
HD footage within MXF files.
• Sony XDCAM HD footage: All Sony XDCAM formats are wrapped in an MXF container
file, except XDCAM EX, which is stored in an in MPEG-4 container file.
For more information about importing these formats, see
Professional Formats and Workflows, available in Final Cut Pro Help.

Importing from a Sony VDU
Final Cut Pro allows you to import media stored on a Sony Video Disk Unit (VDU). These
hard disk–based devices are typically connected to a camcorder during production, so a
copy of your footage can be recorded directly to disk. When shooting is finished, you can
efficiently import your media from the VDU instead of your original tapes.
For more information about using this device, see Professional Formats and Workflows,
available in Final Cut Pro Help.
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About Media File Optimization
Final Cut Pro captures and writes media files to maximize the number of simultaneous
streams and real-time effects during playback. Video streams are defined in terms of the
number of simultaneous media files that can be read from your scratch disk, and do not
necessarily correspond to the number of video tracks in your sequence. For example, you
may have ten tracks in a sequence, but if the clip in the topmost track covers all the
others, only one video stream plays from the scratch disk.
In rare cases, Final Cut Pro alerts you if imported media files cannot be optimized for
multiple-stream, real-time playback. These files are perfectly fine to use in your Final Cut Pro
project. Unless you are editing with multiple uncompressed video streams that demand
maximum media file performance, you can usually leave the files as they are and continue
editing normally. Since Final Cut Pro always optimizes files when capturing, simply
recapturing should maximize the file’s performance.
Note: If you are editing standard definition DV captured in Final Cut Pro, your media files
are already optimized.
Final Cut Pro may not automatically optimize the following:
• Media files captured or created with a third-party codec not supported by Final Cut Pro
• Some media files captured in early versions of Final Cut Pro
To turn off the non-optimized media warning when importing files into Final Cut Pro
1 Choose Final Cut Pro > User Preferences.
2 Click the General tab.
3 Deselect “Warn when importing non-optimized media.”
Final Cut Pro will no longer warn you when it discovers a media file that it cannot
automatically optimize.

About Importing Audio Files
Final Cut Pro allows you to import audio files from other music and sound editing
applications, as well as audio from audio CDs.
When you import audio files into Final Cut Pro, you need to make sure that their settings
match your sequence settings. If your audio clips’ settings don’t match the sequence
settings, you can still edit with them, but Final Cut Pro does real-time conversion which
reduces overall playback performance.
For more information about digital audio, see “Audio Fundamentals.”
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What Kinds of Audio File Formats Can Be Imported?
Final Cut Pro allows you to directly import any audio file format compatible with QuickTime.
However, only uncompressed file formats should be used for editing.
Recommended Audio File Formats
For best performance, use one of the following uncompressed audio file formats when
editing in Final Cut Pro:
• AIFF or AIFC containing uncompressed audio
• WAVE or Broadcast Wave Format (BWF) containing uncompressed audio
• Sound Designer II
• Single-track or multitrack QuickTime movies containing uncompressed audio
Natively, Final Cut Pro captures to QuickTime movie files with one or more audio tracks.
Audio Formats to Avoid
The following formats and audio data formats should be avoided when editing in
Final Cut Pro because they require real-time processing for playback:
• Any file containing compressed formats such as MP3, AAC, and Apple Lossless Codec
• QuickTime movies containing compressed audio, such as MPEG-4 and H.264 files
• Multiplexed video and audio streams such as MPEG-2 program streams and DV Stream
files (This is one of the formats iMovie can create during capture.)

Choosing Audio File Sample Rate and Bit Depth
Final Cut Pro can import audio with any bit depth and sample rate supported by QuickTime
and Mac OS X Core Audio. Final Cut Pro performs real-time bit depth conversion and
sample rate conversion when your audio file settings don’t match your sequence settings.
However, less processor power is required when your audio file settings and sequence
settings match.
Common sample rates and bit depths used in the video industry are:
• 32 kHz/12-bit: Consumer mini-DV camcorders can record four channels of audio using
these settings. This is not recommended for most productions.
• 44.1 kHz/16-bit: Audio CDs and consumer DAT recorders use these audio settings.
• 48 kHz/16-bit: DV, HDV, and DVD all use these audio settings.
• 48 kHz/20-bit: Some professional video devices record natively in this format.
• 96 kHz/24-bit: These settings are becoming increasingly popular for professional sound
and music production, although most video formats still record with 48 kHz.
For more information, see “Audio Fundamentals.”
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Choosing Sequence Bit Depth
The bit depth setting in the Sequence Settings window determines the bit depth whenever
you output or export your sequence. However, sequence audio is always mixed using
32-bit floating-point values.
Note: The Aud Format column in the Browser and Item Properties window always shows
the internal mixing bit depth of a sequence, whereas the Sequence Settings window
shows the bit depth used if the sequence is exported.

Mixing Sample Rates and Using Real-Time Sample Rate Conversion
Ideally, the sample rate and bit depth of your audio files should match that of your
sequence settings. When you play a sequence in Final Cut Pro, any audio files with sample
rates that don’t match your sequence sample rate are converted in real time. This is known
as sample rate conversion, and it requires additional processing power. Clip items that
require real-time sample rate conversion appear with a green render bar within the clip
item. For more information, see “Rendering and Video Processing Settings.”
Even though Final Cut Pro can perform real-time sample rate conversion, conversions
can reduce your audio mixing and effects performance. The quality of this conversion is
controlled by the Audio Playback Quality setting in the General tab of the User Preferences
window. Higher quality conversions reduce the number of audio tracks that Final Cut Pro
can mix together in real time.
If the sample rates of all the audio in your sequence match, sample rate conversion is not
necessary and the number of audio tracks that can play in real time increases. If you are
working with someone who is creating music or audio files specifically for your project,
you can request audio files at the settings you need to match your sequence.
However, If your audio clips don’t match your sequence settings, you can improve audio
playback performance by converting your audio files to the sample rate and bit depth of
your sequence.

Converting Audio Clips to Match Sequence Settings
If you are working with preexisting audio material, such as music from audio CDs, you
need to convert the audio files so they match your sequence settings. For example, if you
plan to use a lot of sound effects or music from audio CDs (which have a sample rate of
44.1 kHz) in a DV sequence with a sample rate of 48 kHz, it’s a good idea to convert your
audio files to a sample rate of 48 kHz.
Most professional video formats, including DV, have a sample rate of 48 kHz and a bit
depth of 16 (this is often abbreviated as 48 kHz/16-bit). Since these settings are so common
for video post-production, they are used for most sequences in Final Cut Pro.
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Important: DV sequences sometimes use 32 kHz/12-bit settings, but these settings are
not recommended. As long as you don’t record your DV footage using 32 kHz/12-bit, you
should not use these settings for your sequence.
Audio files can be converted using the Export Using QuickTime Conversion command.
To convert a CD audio file so it matches your sequence settings
1 Select a sequence, then choose Sequence > Settings.
2 Check the sample rate of the sequence in the Audio Settings area of the General tab,
then click OK.
For DV sequences, the sample rate is usually 48 kHz.
3 Select an audio clip in the Browser that you want to convert to a new sample rate.
4 Choose File > Export > Using QuickTime Conversion.
5 Choose AIFF from the Format pop-up menu.
6 Click Options.
7 In the Sound section of the Movie Settings dialog, click Settings.
8 In the Rate pop-up menu, choose the sample rate of your sequence, then click OK.
Make sure the size is kept at 16-bit.
9 Click OK.
10 Choose a name and location for the new file, then click Save.
Once the conversion is complete, you need to import the new media file into Final Cut Pro.
11 In the Finder, navigate to the location of your newly converted audio media file, then
select the file and drag it into your project in the Final Cut Pro Browser.
You may want to delete the old clip in your project so you aren’t confused by two clips
with the same name.
Tip: You can also convert multiple clips at once using the Batch Export command.

Importing Broadcast Wave Files
The Broadcast Wave Format (BWF) is an extension of the WAVE file format that includes
additional metadata. Because BWF files can store timecode information, this format is
particularly popular for video post-production. Many professional audio recorders today
can record BWF files.
BWF files store only the first timecode number; the remaining timecode numbers are
calculated by Final Cut Pro. Mapping timecode to audio samples is a straightforward
process for frame rates such as 25 fps and 30 fps, but the process is more complex for
29.97 fps video. There are two complications:
• 29.97 fps video is not really 29.97 fps, but rather 30 fps x 1000/1001, or
29.9700299700299700 fps (repeating).
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• There is no fixed relationship between the number of samples and the number of
frames per second. Instead, a repeating sequence of varying samples per frame is
established, defined by SMPTE standards.
Also, there is no ratified standard to indicate or detect whether a BWF file was recorded
with drop frame or non-drop frame timecode.
To import 29.97 fps BWF files with drop frame timecode
1 Choose Final Cut Pro > User Preferences, then click the Editing tab.
2 Choose Drop from the NTSC Default Timecode pop-up menu.
If you have already imported BWF files with non-drop frame timecode and you want to
modify the timecode to drop frame, you can use the Modify Timecode command.
To modify the timecode of a BWF file to drop frame
1 In the Browser, select the audio clip whose timecode you want to modify.
2 Choose Modify > Timecode, then choose Drop Frame from the Format pop-up menu.

About Broadcast Wave File Timecode at a Video Rate of 29.97 fps
If you import the same BWF file into Final Cut Pro and other editing applications, certain
timecode numbers may be calculated differently. This section explains how Final Cut Pro
accurately calculates timecode when importing BWF files.
In Final Cut Pro, three factors affect the calculated timecode value of an imported BWF
file:
• The true frame rate of NTSC video
• Mapping audio samples to video frames
• Drop frame indicators in BWF files
The True Frame Rate of NTSC Video
Timecode calculation is fairly straightforward, with the exception of NTSC-related frame
rates. Calculating timecode for NTSC video is complicated because its true frame rate is
not simply 30 fps, nor is it 29.97 fps. The actual frame rate is 30 fps x 1000/1001, which
equals 29.9700299700299700 fps (repeating). Timecode calculated using 29.97 fps (instead
of 30 fps x 1000/1001) can be inaccurate, especially as the duration of media increases.
Final Cut Pro uses the more accurate calculation (30 x 1000/1001).
Mapping Audio Samples to Video Frames
Timecode is calculated for digital audio files by mapping a certain number of audio
samples to each video frame. When the sample rate is an integer multiple of the video
frame rate, the timecode count can be accurately mapped to the sample count. For
example, if the audio sample rate is 48,000 Hz and the video rate is 25 fps, every 1920
audio samples is equivalent to one video frame.
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However, with NTSC-related video rates, there is no simple relationship between the
number of audio samples per second and video frames per second. To avoid ambiguity,
the Society of Motion Picture and Television Engineers (SMPTE) specifies how many audio
samples should be mapped to each video frame. The number of audio samples per frame
is varied on a frame-by-frame basis to form a consistent pattern. Instead of an exact
number of samples per frame, a consistent pattern of varying samples is spread over
several frames.
When you import a BWF file, Final Cut Pro calculates timecode based on two parameters:
• The editing timebase (frame rate) of the currently selected sequence preset
• The audio sample rate of the imported BWF file
When the sequence preset frame rate is 29.97 fps and the sample rate of the BWF file is
defined in the SMPTE specification, Final Cut Pro uses the repeating frame pattern defined
in the SMPTE specification.
Drop Frame Indicators in Broadcast Wave Files
There is no ratified standard to indicate or detect whether a BWF file was recorded with
drop frame or non-drop frame timecode. Although there are several de facto ways this
information is stored, Final Cut Pro does not support reading this information. Instead,
Final Cut Pro always calculates non-drop frame timecode for BWF files. You can enforce
drop frame timecode during import or by using the Modify Timecode command. For
more information, see “Importing Broadcast Wave Files.”

Using Audio CD Tracks in Your Project
Mac OS X recognizes each track on a standard audio CD as an individual AIFF file. These
files can be copied directly from a CD to your hard disk and then imported into
Final Cut Pro without any conversion.
Files copied from an audio CD have a sample rate of 44.1 kHz and sample size (bit depth)
of 16 bits. If you’re working with a DV sequence, you can convert the sample rate using
Final Cut Pro. For more information, see “Converting Audio Clips to Match Sequence
Settings.”
Important: Do not import clips from a CD or DVD directly into Final Cut Pro. These clips
will go offline as soon as you eject the disc from the drive. Make sure you copy the files
to your hard disk before importing them.

Importing Still Images and Graphics
You can import most graphic formats supported by QuickTime into your project. The
most common ways to create or acquire still images to use in a Final Cut Pro sequence
include:
• Capturing with a digital camera
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• Scanning from a book or photograph
• Downloading from the web
Note: Be aware of copyright issues and don’t use images that you don’t have permission
to use.
• Capturing from a standard definition or high definition video camera
• Creating with a desktop publishing or graphics application
Keep in mind that the image needs to be in one of the formats supported by Final Cut Pro:
PICT, TIFF, TGA, PDF, Photoshop, or JPEG. Most of these file formats can also contain an
alpha channel. For more information about alpha channels, see “Compositing and
Layering.” For detailed information about working with still images and graphics, see
“Working with Freeze Frames and Still Images.”

Importing Numbered Image Sequences
Numbered image sequences are the lowest-common-denominator method for exchanging
video across editing and compositing platforms. Image sequences are movies, but instead
of storing all the video frames in one file (such as a QuickTime movie file), each frame is
stored in a separate, sequentially numbered file. Although QuickTime is increasingly used
to exchange video clips between platforms, image sequences are still very common.
Note: If you are exchanging media between Final Cut Pro and other post-production
applications, you should use a QuickTime file format for your movies unless there is a
particular reason not to.
Some applications may be capable of exporting only numbered image sequences. In this
case, you can use one of the following methods to import numbered image sequences
into Final Cut Pro:
• You can first use QuickTime Pro to convert a numbered image sequence into a
QuickTime movie that can be imported into Final Cut Pro and used like any other clip.
When you do this, the numbered image sequence is not used in Final Cut Pro.
• You can import all your image files into Final Cut Pro, and then edit them sequentially
into a sequence.

Converting a Numbered Image Sequence to a QuickTime Movie
You can use QuickTime Pro to convert a numbered image sequence into a QuickTime
movie. This is useful if you want to convert all your images into a single clip. You can then
import the movie into Final Cut Pro and use it the way you use any other clip.
To convert a numbered image sequence into a QuickTime movie
1 Open QuickTime Player.
2 Choose File > Open Image Sequence.
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3 Locate the first numbered file of the image sequence you want to import, then click Open.

Locate and select
the first file of your
image sequence.

Then click Open.

4 In the Image Sequence Settings dialog, choose a frame rate, then click OK.
You can choose any frame rate, but there is almost always an intended correct frame rate
based on the original format. If you aren’t sure, check with the person who generated
the image sequence to make sure you choose the proper frame rate. NTSC uses 29.97 fps,
PAL uses 25 fps, film traditionally uses 24 fps, and HD might use any of the above, as well
as 59.94 or 60 fps. For more information, see “Frame Rate and Timecode.”

Choose a frame rate
for the movie from this
pop-up menu.

Your image sequence is imported into QuickTime Player as an uncompressed video file.
5 Choose File > Save.
Note: You can also choose File > Export > QuickTime Movie. This gives you the option
to customize the dimensions and codec of the movie. For more information, see “Exporting
QuickTime Movies.”
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6 Choose a location and enter a name for the file.
If you wish, enter a name
for the file.

Choose a place to save
the file.
Choose a save option.

7 Choose an option for how you want to save the movie, then click Save.
• Save normally: If you choose this option, QuickTime Player creates a reference movie
that points to the original folder of image files. No data is actually duplicated, so the
reference movie itself is very small, takes very little hard disk space, and is quick to
create. The resulting movie file is the same as a QuickTime movie file and can be
imported into Final Cut Pro just like any other QuickTime file.
Note: Since a reference movie needs the original source material for playback, if you
give this clip to someone else, you must give them the original image files as well.
• Make movie self-contained: If you’re going to be giving this clip to someone else, the
easiest thing to do is to make it self-contained. This type of movie takes longer to save
and consumes more hard disk space than a reference movie. However, a self-contained
movie isn’t dependent on other files and is a better option for exchanging and archiving
files.
Because no compression is applied (other than any that may have been used in the
original image sequence files), the saved movie is uncompressed and may not play back
in real time. After you import the movie and edit it into a sequence, Final Cut Pro rerenders
this clip using the codec specified in your sequence settings.

Importing a Numbered Image Sequence into Final Cut Pro
You can import a numbered image sequence as a set of individual image files. This gives
you more flexibility because you have control over which files are imported and which
of those are then edited into your sequence.
To import image files from a numbered image sequence
1 Choose Final Cut Pro > User Preferences, then click the Editing tab.
2 Set the Still/Freeze Duration value to one frame (00:00:00:01).
3 Open the project where you want to import the files.
For more information, see “Opening and Closing Projects.”
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4 Import all the image files associated with the numbered image sequence you want to
use in your project.
For more information, see “Importing Media Files.”

5 Do one of the following:
• Choose File > New > Sequence.
• Control-click in the Browser, then choose New Sequence from the shortcut menu.
6 Double-click the new sequence to open it in the Timeline.
7 Select the newly imported bin with all the image clips in it, open it, and press Command-A
to select all the clips.
8 Drag the clips to the Insert section of the Edit Overlay in the Canvas.

Drag the clips
to the Insert section
of the Edit Overlay.

You can now edit this sequence into other sequences.

Making Movies from Still Images
You can use one of the methods above to create your own animations as visual elements
in your movie. You can even make a whole movie this way, although it takes patience to
create 24 or more frames for every second of your finished movie.
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Sources for still images include:
• Digital cameras (including your Aperture Libraries)
• Scanners
• Freeze frames exported from Final Cut Pro
• Hand-drawn computer graphics created with a graphics application
All of your images should be the same dimensions, and should ideally match the
dimensions of your output format (for example, NTSC DV is 720 x 480, HD is 1920 x 1080
or 1280 x 720, and so on).
After you collect a group of still image files together in one folder, name them sequentially,
such as AbstractBackground0001.jpg, AbstractBackground0002.jpg, and so on. Then
import the files into Final Cut Pro following the steps for importing a numbered image
sequence.
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This chapter covers the following:
• Using Bins to Organize Your Clips (p. 389)
• Using Labels to Organize Your Clips (p. 395)
• Sorting Items in the Browser Using Column Headings (p. 399)
• Searching for Clips in the Browser and Finder (p. 401)
After capturing media to your scratch disks, you can import clips into a project in the
Browser and then organize them to save time during editing. You can also search for
clips in various ways.

Using Bins to Organize Your Clips
You can organize the clips and sequences in a project into bins, which are similar to
folders. This creates a logical structure for your projects, making your source clips easier
to manage.

Bins help you organize
clips in your projects.
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Bins are unique to project files. Although they behave similarly to folders on your hard
disk, bins are not actually connected to folders on your hard disk in any way. Changes
you make to the contents of a bin, such as deleting, moving, and renaming clips or
renaming the bin itself, have no effect on the original files or folders on disk where the
media files are stored. If you delete a clip from a bin, its associated media file is not deleted
from your scratch disk. Likewise, creating a new bin does not create a new folder on your
disk.

Creating New Bins
You can create separate bins for different stages of your project or for different types of
footage. For example, you can create bins for each location the footage was shot in, or
you can create bins to separate your audio, video, and still image clips. You can organize
bins hierarchically and open them in their own windows. You can even put bins inside
other bins.
To add a new bin to a project
1 In the Browser, click the project tab where you want to add a bin.
2 Do one of the following:
• Choose File > New > Bin (or press Command-B).
• Control-click in the Name column, then choose New Bin from the shortcut menu.
3 Enter a name for the new bin.

Enter a name for the bin.

You can also create bins by dragging a folder from your hard disk to the Browser.
To create a bin by dragging a folder from your hard disk
1 In the Finder, select the folder you want to be a bin.
2 Drag the folder from the Finder to the Browser.
As soon as you release the folder over the Browser, a bin with the same name as the
folder is created in your project.
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Note: Dragging folders and files from the Finder to the Browser creates bin and clip
objects in your project file. However, unlike clips, which refer to media files on disk, bins
do not refer to actual folders on disk.

Opening Bins in the Browser
There are several ways you can open a bin.
To open bins in icon or list view
Do one of the following:

µ
µ

Select the bin, then press Return or Enter.
Double-click a bin.
To reveal bin contents in list view
Do one of the following:

µ

Press the Right Arrow key. Press the Right Arrow key again to select the first item in a bin.
(Press the Left Arrow key to close a bin.)

µ

Click the disclosure triangle to the left of the bin you want to open. Click it again to close
the bin.

Click the triangle to
show the contents
of a bin.

You must select a bin to navigate within it.

Opening Bins in a Separate Window or Tab
To preserve space on the screen or to avoid scrolling in the Browser, it’s useful to open
a bin in its own window or tab.
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µ

To open a bin in its own window
Double-click the bin.

The bin appears in
its own window.

The icon for this bin in
the Browser indicates
the bin is open in its
own window.

To close a bin that’s open in its own window
Do one of the following:

µ
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Control-click the bin’s tab, then choose Close Tab from the shortcut menu.
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µ
µ

Make sure the bin is the active window, then press Control-W.
Click the close button of the bin window.
For easy access to a bin, you can create a tab for it in the Browser.

µ

To open a bin as a new tab in the Browser
Hold down the Option key while double-clicking a bin in the Browser.
If multiple Browser windows are open, the tab is created in the Browser window that
contains the bin.

To turn a bin in its own window into a tab in the Browser
1 Double-click a bin to open it in its own window.
2 Drag the bin’s tab from the bin window to the top of any column heading in the Browser.
Drag the bin’s tab above
any column heading in
the Browser.

The bin now has its own
tab in the Browser.
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To close a bin’s tab
Do one of the following:

µ

Control-click the tab, then choose Close Tab from the shortcut menu.

µ
µ

Make sure the bin is the active (frontmost) tab, then press Control-W.
Drag the bin’s tab out of the Browser, then click the close button to close the bin’s window.

Moving Items Between Bins
As you work on your project, you often reorganize clips and move them into different
bins. Moving clips within bins has no effect on the original files or folders on disk where
the media files are stored.
To move items between bins in list view
Do one of the following:

µ

Select the desired items, then drag them to a bin. (The bin can be open or closed.)
Select an item to move...

...then drag it to a bin.
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µ

If the bin in which you want to move items has its own window, drag items to that bin’s
window.

You can also move
items into separate
bin windows.

µ

To move an item to the top level of a project
Drag the item to the Name column heading.

Note: If you move items between projects, the items are copied, not moved. There is no
relationship between items in different projects.

Using Labels to Organize Your Clips
In Final Cut Pro, you can assign labels to clips, bins, and sequences. You can use labels
to:
• Categorize and sort your clips
• Visually identify clips, bins, and sequences in the Browser, and clips within sequences
• Mark a group of clips that you located with the Find command
• Do any other task requiring you to organize your clips into identifiable groups
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About Label Names and Colors
The Label property has several labels, each with an associated color and name. When
you choose a label for a clip, that clip’s icon becomes the color of that label, and that
label’s name appears in the Label column for the clip. If no label is specified for a clip, the
label is set to None and there is no color associated with this item. You can change the
label names, but not the colors.
The label colors and associated default names are:
• No color: None
• Orange: Good Take
• Red: Best Take
• Blue: Alternate Shots
• Purple: Interviews
• Green: B-Roll
The names associated with the label colors above are stored in your User Preferences file,
not in your project file. For example, if you change the name of the red label to “Do Not
Use,” any clips, bins, or sequences labeled red will have the label name “Do Not Use,”
regardless of what project they are in.
Because the label properties of a clip are shared among affiliated clips, changing the label
of a clip changes the labels of all affiliated clips as well.
Note: Label assignments do not affect objects within other objects, such as clips within
bins or a sequence. For example, you may label a bin with the “Best Take” label, but the
clips within that bin can be assigned a different label.
If you click the heading of a Label column, all clips, bins, and sequences in the Browser
are sorted by label.

Assigning Labels and Setting Label Names to Help Manage Media
Each item in Final Cut Pro has two label properties: Label and Label 2. Both label properties
can be customized in different ways:
• Label: This can be one of several names and associated colors as assigned in the Labels
tab of the User Preferences window. This property affects the color of its clip, sequence,
or bin.
• Label 2: This can be any text you type in the Label 2 Browser column or Item Properties
window. This field is not limited to the various labels in the User Preferences window
for the Label property, but it also does not provide the convenient color-coding of that
property.
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Both label properties are displayed when you have Standard Columns selected in the
Browser, but you can always choose to hide or show these columns as needed. (To choose
Standard Columns, Control-click any column heading in the Browser, then choose Standard
Columns from the shortcut menu.)
To assign a label to a clip in the Browser
Do one of the following:

µ

Select a clip, choose Edit > Item Properties > Logging Info, Control-click in the Label field,
then choose a label from the shortcut menu.

These are the various
labels available.

µ
µ

Control-click in the Label column of the clip, then choose a label from the shortcut menu.
Control-click a clip, choose Label from the shortcut menu, then choose a label from the
submenu.

To assign a label to multiple clips at once
1 Select the clips you want to label in the Browser.
For information about selecting clips, see “Browser Basics.”
2 Do one of the following:
• Control-click one of the selected clips, choose Label from the shortcut menu, then
choose a label from the submenu.
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• Control-click in the Label column of one of the selected clips, then choose a label from
the shortcut menu.
Select the clips you
want to label.

Then Control-click in
the Label column and
choose a label.

To set and assign a label in the Label 2 property of a clip
Do one of the following:

µ

Select a clip, choose Edit > Item Properties > Logging Info, click in the Label 2 field and
type a label name, then click OK.

µ

Click in the Label 2 column of the clip, type a label name, then press Return or Enter.
If you’ve already specified at least one label in the Label 2 property of any clip in your
project, you can assign one of those existing labels to the Label 2 property of other clips.

µ

To assign a label in the Label 2 property of a clip
Control-click in the Label 2 column of a clip, then choose a label from the shortcut menu.
All of the labels in the Label 2 fields of the clips in your project appear in this menu.

To assign a label in the Label 2 property for multiple clips at once
1 Select the clips you want to label in the Browser.
For information about selecting clips, see “Browser Basics.”
2 Control-click in the Label 2 column of one of the selected clips, then choose a label from
the shortcut menu.

Changing Names of Labels
If you need label names that are different from the defaults, you can change them in the
User Preferences window. For example, some projects may not have any interview footage,
so you could change the default “Interview” label to a more appropriate category, such
as “Special Effects,” “Needs Color Correction,” or “Temporary Footage.”
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Keep in mind that labels usually represent fairly broad categories, since there are only
five to choose from. You can always use log notes, comments, and the Label 2 property
to further refine the descriptions and categorization of your clips.
To change the label names
1 Choose Edit > User Preferences, then click the Labels tab.
2 Click a text field to highlight it, then enter a new name for the label.

If you wish, enter
different label names.

3 When you’ve finished, click OK or press Return.

Sorting Clips by Labels
After you set labels for clips, you can sort your clips in the Browser by their labels or use
the Find command to find clips based on the label you’ve applied.

µ

To sort clips by label
Click the Label column heading.
All clips are sorted by label and alphabetically within each label name. Unlabeled clips,
marked as None, are sorted at the beginning or the end of the list, depending on the
direction of the sort order.
For more information on sorting, see “Sorting Items in the Browser Using Column
Headings”

Sorting Items in the Browser Using Column Headings
Clicking column headings in the Browser allows you to sort items by any property displayed
in list view, such as Name, Reel, Label, Timecode, and so on. By default, items are sorted
by Name. In addition to the primary sorting property, secondary, tertiary, and further
sorting refinements can be made by Shift-clicking a column heading.
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To sort items in the Browser
1 Make sure you are in list view by Control-clicking in the Browser and choosing View as
List from the shortcut menu.
2 Click a column heading to sort by it.
A black arrow indicates
the primary sort column
and the sort order.

The heading of the primary sort column contains an arrow whose direction indicates the
sort order—down for ascending (0-9, A-Z) and up for descending (Z-A, 9-0).
3 To switch between descending and ascending sort order, click the column heading.
4 To sort by secondary columns, Shift-click an additional column heading.
A light gray arrow
indicates a secondary
sort column and the
sort order.

Items are further sorted
using a secondary sort
column.

5 To switch between descending and ascending sort order in the secondary columns, click
the arrow.
If you inadvertently select the wrong secondary column or too many secondary columns,
you can clear all secondary sort columns by choosing a new primary sort column, and
then selecting any secondary sort columns.
6 To sort by tertiary columns, you can Shift-click another column heading.
You can continue to refine your sort by Shift-clicking additional column headings.
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Searching for Clips in the Browser and Finder
Final Cut Pro provides a number of options for searching for clips in the Browser. You can
also reveal a clip’s media file in the Finder.

Revealing a Clip’s Media File in the Finder
There are many situations in which you want to directly access a clip’s media file in the
Finder. In these cases, you can use the Reveal in Finder command.
To reveal a clip’s media file in the Finder
1 Select a clip in a sequence or in the Browser.
2 Do one of the following:
• Choose View > Reveal in Finder.
• Control-click the clip and choose Reveal in Finder from the shortcut menu.
The Finder becomes the frontmost application, and the clip’s media file is selected in a
Finder window.
You can also rename a clip’s media file to match the clip name, or rename a clip to match
its media file. For more information, see “Reconnecting Clips and Offline Media.”

About Search Options
You can use the Find command to search for items in a project by any property or
combination of properties. You can also limit your search to only the current project, or
you can search every open project. If you are looking for clips you haven’t included in
any of your sequences, you can limit your search to “unused media.” Or you may want
to only search for clips that are included in your sequences. Search results appear in a
separate window, called Find Results.
You can search by single item properties—the most obvious being searches by clip
name—or by several properties at once, such as clip name, reel, and label.
Tip: Searching is a good way to find all of the unused clips in your project.
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µ

To open the Find window
Make sure the Browser is the active window, then choose Edit > Find (or press
Command-F).

Search scope
Click here to specify
more search options.
Search criteria

Additional search
criteria available after
clicking the More button

Options for Defining the Scope of a Search
When you are searching for clips, you may sometimes want to search within a single bin,
while other times you may need to search every open project. The Find window allows
you to define the scope of your search.
• Search: Choose an option from this pop-up menu to specify which open projects or
folders you want to search—All Open Projects, the current open project, the Effects
tab, or a single bin.
Note: You can only search a single bin if the bin is the frontmost window. Since the
Find Results window is considered a bin, you can also limit your search within the Find
Results window if it is the active window.
• For: Choose an option from the pop-up menu to limit your search.
• All Media: Includes all clips in your project, regardless of whether or not they are
used in a sequence.
• Used or Unused: These two options refer to whether or not clips are used within
sequences in your project. You can also search within specific sequences. Final Cut Pro
considers a clip’s media file to be used if it is in a sequence. If you have used a clip
in a sequence, the assumption is that you intend to output the portion of media file
it refers to in your final edit. Any clip not used in a sequence is considered unused.
• Results: Choose how you want the search results to be shown.
• Replace Find Results: Choose this to clear and replace any previous find results with
new find results.
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• Add to Find Results: Choose this to append the results of the current search to the
contents of the Find Results window. This allows you to do several searches and
accrue the results in a single window.
Options for Defining the Criteria of a Search
The Find window allows you to specify search criteria.
• More: Click this to refine your search by adding more criteria.
• Less: Click this to remove the last search criteria item.
• Match: You can narrow or broaden your search by using multiple criteria. Choose an
option from the pop-up menu.
• All: Finds clips that match all criteria.
• Any: Finds clips that match any single criterion. If you are familiar with other database
searches, “All” refers to a Boolean “and” search, and “Any” refers to a Boolean “or”
search.
• Omit: Select this option to exclude clips that meet this criterion in your search.
• Property name pop-up menu: This pop-up menu allows you to choose a specific Browser
column or item property to search in.
• Matching pop-up menu: Choose a matching option to further refine how your criteria
are used: Starts With, Contains, Equals, Ends With, Less Than, or Greater Than.
For example, you may have some clip names that end with “birds,” while others begin
with “birds.” To find only the clips whose names end with “birds,” choose Ends With.
• Matching criteria: Enter your specific search criteria. If you are searching for clips that
contain the name “wide shot,” enter “wide shot” here.
Search Commands
The Find window also provides two options for searching—Find Next and Find
All—depending on your search needs.
• Find Next: Click this to search for the next item that matches your search criteria. Once
an item is found, it is selected in the currently open Browser. Press Command-G to
continue the search in your currently selected bin or project.
• Find All: Click this to search for all items that match your search criteria. This places all
found items into a window called Find Results.

Searching for Items in the Browser
You can search in all open projects or restrict your search to a single project, or tab, in
the Browser. You can search for one item at a time, or multiple items at once.
Searching for Single Items in the Browser
You can search for one clip at a time.
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To search for a single item in the Browser
1 Make the Browser active, then choose Edit > Find (or press Command-F).
2 Select your search options, then enter your search criteria.
For more information, see “About Search Options.”
Specify your search
criteria.

Then click here.

The above example shows a search for clips used in sequences selected in the Browser
that have the word “Copy” in their names. (If a clip has been edited into a sequence, its
media file is being used.)
3 Click Find Next.
The found item is highlighted in the Browser.
4 Press Command-G to search for the next item in the Browser that meets the search criteria.
Searching for Multiple Items in the Browser
You can also do a search to find multiple clips at once.
To search for multiple items in the Browser
1 Make the Browser active, then choose Edit > Find (or press Command-F).
2 Select your search options, then enter your search criteria.
For more information, see “About Search Options.”
Specify your search
criteria.

Then click here.

3 Click Find All.
A list of found items is displayed in the Find Results window.
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If necessary, you can restrict a search to the elements of the Find Results window. For
more information, see “Manipulating Items in the Find Results Window.”
Searching for Unused Clips in Your Project
You can search for unused clips in your project.
To search for unused clips
1 Do one of the following:
• Open your project.
• Make sure your project is the frontmost tab in the Browser.
2 Choose Edit > Find (or press Command-F).
3 Choose your project from the Search pop-up menu.
4 Choose Unused Media from the For pop-up menu and deselect the “in selected sequences”
checkbox to the right of the menu.
5 Click Find All.

A list of unused clips is
displayed in the Find
Results window.

Manipulating Items in the Find Results Window
When you do a search for multiple items, Final Cut Pro displays the list of found items in
the Find Results window. The items displayed in the Find Results window are literally
identical to the items in the Browser. They are not copies of found clips, but the clips
themselves, shown in a new context. Selecting an item in the Find Results window also
selects the item in the Browser.
By narrowing down all of the clips in your project to the results of your search, you can
conveniently do things like:
• Find all the clips that start with “Eiffel” and “Paris,” and then select all the found clips
in the Find Results window and drag them into a new bin in the Browser.
• Find all the clips from reel 002 and reel 002A, and then select the clips in the Find
Results window and drag them to a bin in the Browser labeled “002.”
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• Find all the clips with the Good property deselected (in other words, bad takes), select
the found clips in the Find Results window, and then remove those clips from the
project.
The Find Results window works in much the same way as the Browser, and you can do
many of the same operations:
• Delete found items from a project.
• Move or copy found items to another location in the Browser.
• Sort and display found items.
• Edit found items into a sequence.
• Perform additional searches and combine the results.
• Modify information in Browser columns for found clips.
For example, you can find all clips not used in your sequences (unused media) and set
the Good column to No for all clips in the Find Results window. You could also assign the
same label to all of the clips in the Find Results window.
To modify an item property for a group of found clips
1 Perform a Find All search.
See “Searching for Items in the Browser.”
2 In the Find Results window, press Command-A to select all items in the window.
3 Control-click in the column for the item property you want to modify, then choose a new
option from the shortcut menu.

Control-click in a
column, then choose
an option.

406

Chapter 27 Organizing Footage in the Browser

µ

To see where found items are in the Browser
Select the desired items in the Find Results window, then click Show in Browser.
Select items you want
to see in the Browser.

Then click here.

µ

To delete found items
Select the desired items in the Find Results window, then click Remove from Project.
Note: As with deleting any clips in the Browser, the media on your scratch disk is not
deleted. Only the clips in the project file are removed. Removing multiple clips from a
project via the Find Results window can be undone.

To search for items within the Find Results window
1 With the Find Results window active, choose Edit > Find (or press Command-F).
2 Enter your search criteria, then select search options.
For more information, see “About Search Options.”
3 Choose Add to Find Results from the Results pop-up menu.
4 Click Find All.
The new results of your search replace the previous content in the Find Results window.

Using Custom Column Layouts in the Find Results Window
You can save and use custom column layouts in the Find Results window, just as you can
in the Browser. Any custom column layouts created in the Browser also appear in the
Find Results window, and vice versa. For more information, see “Browser Basics.”
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Creating Subclips

28

This chapter covers the following:
• Learning About Subclips (p. 409)
• Techniques for Breaking Large Clips into Subclips (p. 413)
• Creating Independent Media Files from Subclips After Capturing (p. 416)
Lengthy media files can be unwieldy for editing. If you capture an entire tape as a single
media file, you can break the clip into shorter subclips. You can also break the media file
into smaller media files.

Learning About Subclips
For organizational purposes, you can break up a single large clip into several subclips.
Subclips are defined by In and Out points or markers set in the original clip prior to the
creation of subclips. New subclips automatically become their own master clips, with no
affiliation to the clip from which they were created.
Clip

Subclip

Subclips allow you to work more easily with lengthy media by breaking up a single clip
into many smaller pieces. For example, you can open a 20-minute clip comprising 15
different shots in the Viewer and divide it into 15 subclips, one for each shot.
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Final Cut Pro places new subclips in the same Browser bin as the original clip they came
from, automatically appending the word “Subclip” to the name and numbering each
successive subclip you create from a particular clip. For example, if the original clip is
named “Debra enters cafe,” the first subclip is named “Debra enters cafe Subclip,” the
second is “Debra enters cafe Subclip 2,” and so on. When a new subclip is first created,
its name is highlighted and ready to be changed.
Numbered subclips are
placed in the same bin
as the master clip.

You can rename subclips, move them into different bins, and organize them in any way
you choose. After you’ve created your subclips, you can open them in the Viewer and set
new edit points, just as you can with any other clip. The original clip remains in the
Browser, but is completely independent of your subclips. Any changes you make to a
subclip are not applied to the original clip.
To create a subclip
1 Open a clip in the Viewer.
2 Set In and Out points.
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3 Choose Modify > Make Subclip (or press Command-U).
A new subclip appears
in the Browser below the
parent clip, defined by the
In and Out points you set.

Sometimes, you may be looking for a particular frame in a subclip, and realize that although
those frames existed in the original clip, they were left out when you created the subclip.
If you’ve opened a subclip to a certain frame in the Viewer, but you’d rather find the same
frame in the original media file (perhaps to pick an In or Out point outside the subclip
limits), you can easily swap the two in the Viewer.
To open the original media file from which a subclip came
1 Open the subclip in the Viewer.
2 Find the frame you want to match.
3 Choose View > Match Frame > Source File (or press Command-Option-F).
Final Cut Pro opens the subclip’s entire media file as an independent clip in the Viewer.
The playhead is located on the same frame in the new clip as in the original subclip. To
make the independent clip in the Viewer into a master clip for editing, drag the clip from
the Viewer to the Browser.
After you’ve placed a subclip in the Timeline, you may want to identify the original parent
clip that the subclip was taken from.
To reveal a subclip’s parent clip
1 Select or position the playhead on the subclip in the Viewer or Timeline.
2 Choose View > Reveal Subclip Parent Clip
Final Cut Pro selects the parent of the subclip in the Browser.
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Note: If a subclip was created in an earlier version of Final Cut Pro, the Reveal Subclip
Parent Clip command may not work.
When you create a freeze frame from a video clip, you can have Final Cut Pro display the
original video that a freeze frame was taken from.
To open the original video clip from which a freeze frame came
1 Select or position the playhead on the freeze frame clip in the Viewer or Timeline.
2 Choose View > Match Frame > Source File (or press Command-Option-F).

Master-Affiliate Clip Relationships
When you create a new subclip, it has master clip status. When you edit the subclip into
a sequence, an affiliate subclip is created. This behavior is identical to the behavior of all
other clips with master-affiliate relationships.
When you create a new subclip, Final Cut Pro records the relationship between the subclip
and the clip that it came from, called the subclip parent clip. You can select a subclip and
reveal its subclip parent clip by choosing View > Reveal Subclip Parent Clip.
You don’t need to worry about master-affiliate relationships too much while you are
editing. These issues only become important when you are managing your media files
toward the end of a project, or when transferring your project and media files to another
editing system. For more information, see “Working with Master and Affiliate Clips.”

Removing Subclip Limits
A subclip, just like a clip, refers to a media file on your scratch disk. The difference between
a clip and a subclip is that a subclip imposes artificial limits (called subclip limits) to make
the subclip appear shorter in Final Cut Pro than the actual media file. A subclip refers to
only a portion of a media file, while a clip refers to the whole media file.
If you compare a clip and a subclip that both refer to the same media file, the only
significant difference between them is that their Media Start and Media End properties
are different. The subclip’s Media Start time may be later than the clip’s Media Start time,
or its Media End time may be earlier than the clip’s Media End time. Often, both are true.
A subclip’s artificially imposed subclip limits can be removed at any time. The subclip
becomes a normal clip that refers to the entire duration of the media file (from Media
Start to Media End).
To extend the Media Start and End points of a subclip to those of the original media
file
1 Open the subclip in the Viewer.
2 Choose Modify > Remove Subclip Limits.
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The subclip becomes a normal clip, and now references the entire source media file. The
subclip in the Browser no longer has a subclip icon, but instead a normal clip icon.
Important: When you remove a subclip’s limits, all affiliated subclips also become normal
clips.

Techniques for Breaking Large Clips into Subclips
There are a few ways you can create subclips in Final Cut Pro:
• Create markers in a clip, and then turn them into subclips.
• Create subclips manually, one at a time, by setting In and Out points in the original
clip and choosing Modify > Make Subclip.
With some kinds of video footage (mainly DV), you can also create subclips from the
start/stop data that is created by the camcorder and embedded in the video data. See
“Capturing Video from Tape.”

Turning Markers into Subclips
Once a clip has markers, you can easily turn the markers into subclips. Subclips are defined
from one marker to the next. If there is only one marker, the Out point of the subclip is
determined by the clip Out point. If you double-click a marker in the Browser, it opens a
subclip in the Viewer. For more information, see “Using Markers.”
To turn a clip’s markers into subclips
1 Click a clip’s disclosure triangle in the Browser to reveal its markers.
2 Select the markers in the clip by dragging across all of them at once, or by clicking the
first marker and then Shift-clicking the last marker.

3 Do one of the following:
• Choose Modify > Make Subclip.
• Drag the markers outside of the clip and into the Browser.
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Tip: If you are having a hard time dragging the markers out of the clip, try dragging
the markers to the Name column heading in the Browser. When you see the Name
column highlight with a rectangle, release the mouse button.
Subclips, identified by special subclip icons, are created. If you chose Modify > Make
Subclip, the markers remain in the clip after the subclips are created. If you dragged the
markers out of the clip, the markers in the clip are removed.
All of the material
between the markers
you selected should
now appear as subclips.

Tip: Subclips are named based on the marker name. To create more meaningful subclip
names, change the marker names in the Browser before creating subclips.
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How Markers Determine Subclip Durations
When you drag markers out of a clip, a subclip is created for each marker. The duration
of a subclip is determined from one marker to the next. For example, a clip with four
markers produces four subclips. The last subclip created from a marker always contains
the Media End point of the clip from which it was derived.
Subclip 1

Subclip 2

Subclip 3

Subclip 4

Media End

The duration of a subclip can also be defined by a marker with extended duration. For
more information about creating markers with duration, see “Extending a Marker’s
Duration.”
Original clip

Subclips defined by
marker boundaries

Subclips defined by markers
with extended duration

Original clip
Marker with
extended duration

Marker with
duration of 0:00

Creating Subclips Manually
If you have long clips, you can also break them into subclips manually to help you manage
your footage.
To manually break a clip into subclips
1 Open the clip in the Viewer.
2 Set In and Out points corresponding to the subclip you want to create.
3 Choose Modify > Make Subclip (or press Command-U).
A subclip appears in the Browser.
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Editing with Subclips
You can edit with subclips in the same way as with any other clips. You can even add
markers to subclips and create subclips from those. This is no different than creating
subclips from clips.
Final Cut Pro also allows you to edit directly with markers, turning them into subclips
when you release them in the Timeline. However, it’s usually best to not do this. A marker
is never a master clip, so subclips created by dragging a marker into a sequence are
independent clips. If you want to edit with subclips, you should convert markers into
subclips first. This maintains a master-affiliate relationship between the affiliate subclips
in a sequence and the master subclip in the Browser, which makes media management
easier.
For more information, see “Master-Affiliate Clip Relationships.”

Creating Independent Media Files from Subclips After Capturing
When you capture each source tape as a whole media file and then break it into smaller
subclips, you will inevitably discover a number of subclips that you don’t need for your
project. If you are trying to save disk space, you can delete portions of media files that
you know you don’t need. This process affects your media files, so it is considered to be
media management.
You can use the Media Manager to break the original media file into smaller media
files—one media file for each subclip. You can then delete the media files for any subclips
you don’t want to keep.
Important: It’s a good idea to break your media file into smaller media files before you
begin editing.
To organize subclips you want to keep and subclips you want to delete
1 In the Browser, create two bins named “Keep” and “Delete.”
2 Review each subclip by playing it in the Viewer, then move it to the Keep bin or the Delete
bin.
3 Continue watching and sorting subclips until all the subclips are in either the Keep or
Delete bin.
There are many other techniques you could use to organize your subclips, such as using
two different labels, or using the Good property for subclips you want to keep, and so
on. Use whatever method works best for you.
To delete media not referred to by selected subclips
1 Delete the master clip (the original clip that refers to the full-length media file).
2 In the Browser, select the subclips that you want to keep for use in your project.
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If you used the method above for separating subclips into Keep and Delete bins, select
the subclips in the Keep bin. These are the subclips that refer to portions of the media
file you want to keep.
3 Choose File > Media Manager.
4 Choose Use Existing from the “Media referenced by selected items” pop-up menu.
5 Select the “Delete unused media from selected clips” checkbox.
This tells Final Cut Pro to delete any portions of the media file that are not referenced by
the subclips you currently have selected in the Browser.
6 Choose Clip Names from the “Base media file names on” pop-up menu.
This option uses the names of your subclips to name the resulting media files.
7 Make sure the “Duplicate selected clips and place into a new project” checkbox is not
selected.
8 Click OK.
Because this is a destructive process (meaning some of your media will likely be deleted),
Final Cut Pro checks to see if any other clips in your project also refer to the same media
file. If so, Final Cut Pro tells you how many other clips besides the subclips you have
currently selected may be affected by deleting media. In this case, any subclips you didn’t
select originally will become offline unless you include them in your media management.
9 Choose one of the following options:
• Add: Adds the other clips to your selection so that the portions of media they represent
are also preserved along with the media of the original selected subclips. This may be
useful if you forgot to select some subclips in the Browser before you opened the Media
Manager. If a master clip for the media file still exists in the Browser, adding it to the
current selection for media management will result in no deletion of media; since the
master clip refers to all of the media, all of the media file is considered to be used.
• Continue: Go on without adding any other clips to the selection. If you are confident
that you have selected all the subclips you want to keep, choose this option.
• Abort: If you are worried that you haven’t selected all of the subclips you want to keep,
you can stop the process and start the task over from the beginning, making sure
you’ve selected the correct subclips.
Final Cut Pro warns you one final time that you are about to delete media from the hard
disk, and that this process is not recoverable. This isn’t really as bad as it sounds in most
cases, since you can always recapture footage from tape (assuming your media files
originally came from videotape).
10 Choose Continue to delete media not referenced by the currently selected subclips, or
choose Abort to stop the process, leaving your media file intact.
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If you choose Continue, a new, separate media file is created for each subclip. The original
media file that contained the contents of the entire tape is deleted. The subclips in your
project now refer to these individual media files. The subclips you originally selected
become clips in the Browser, as indicated by their icons. The subclips that you didn’t
process with the Media Manager are now offline because the original media file was
deleted.
From now on, when you need to recapture particular shots for any reason, you can capture
only the clips you need (instead of the entire duration of the tape).
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Merging Clips from Dual System
Video and Audio
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This chapter covers the following:
• Working with Dual System Video and Audio (p. 419)
• Using Synchronization Points to Create Merged Clips (p. 420)
• Duration of Merged Clips (p. 422)
• Creating Merged Clips from the Timeline (p. 423)
• Changing the Sync of Merged Clips (p. 424)
In Final Cut Pro, you can create merged clips that refer to independent video and audio
media files simultaneously, making it easy to work with them together, in sync.

Working with Dual System Video and Audio
Many movies are made by recording picture and sound separately and then syncing them
together during post-production. While this adds a level of complexity to post-production
and editing, it also gives you more independent control of picture and sound throughout.
Cinematographers can focus on capturing the images, while the production sound
recordist and microphone operator can work independently to capture the best sound.
The visible and audible clicking of the slate, along with timecode and edge code numbers,
are used to sync picture and sound together in post-production.
Dual system recording is used in productions such as:
• Big-budget video productions that record audio separately from the video, typically
using a DAT recorder.
• Film shoots; since most film cameras record only picture, audio is always recorded
separately, typically using a DAT recorder, Nagra, or hard disk recorder.
In Final Cut Pro, you can create merged clips so you can work with video and audio from
a dual system production together, in sync. Most clips refer to a single media file on disk,
and each clip item refers to a track within that single media file. In a merged clip, each
clip item can refer to a different media file on disk. For example, a merged clip
simultaneously refers to a video track in a QuickTime media file and audio tracks in one
or more separate audio files. You can merge one video clip and up to 24 audio clip items.
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When you create a merged clip from two or more clips, it becomes a new master clip,
with no affiliation to the clips from which it was created. For more information on
master-affiliate clip relationships, see “Working with Master and Affiliate Clips.”

Use Accurately Captured Media to Create Merged Clips
It’s always important to make sure that the timecode captured with your video and audio
media is accurate before creating merged clips.
When capturing audio for use in a merged clip, make sure that your audio deck is
synchronized to the same video timing signal used when capturing video. A blackburst
generator (also referred to as house sync) can be used to supply both video and audio
interfaces with a common timing signal. For more information, see “Connecting
Professional Video and Audio Equipment.”

Using Synchronization Points to Create Merged Clips
Before actually merging clips, you need to find a synchronization point between them.
There are different ways of doing this, depending on how you shot your footage:
• If the timecode of your video and audio clips isn’t identical, and you slated all your shots at
the beginning with a clapboard: You can use In points to line up all the clips you want
to merge.
• If the timecode of your video and audio clips isn’t identical, and you have one or more shots
that you tail-slated at the end: You can use Out points to line up all the clips you want
to merge.
• If the timecode of the video and audio recorders used on the shoot was synchronized: You
can use the timecode of both the video and audio clips to synchronize them.
If you have a complicated combination of syncing In and Out points, and your video and
audio clips don’t have matching, synchronized timecode, you can add auxiliary timecode
to each clip so that the clips’ sync points all fall on the same timecode number. You can
then use the auxiliary timecode track (Aux TC 1 or 2) to merge your clips. This is just like
using the main timecode track for syncing, but auxiliary timecode tracks are useful because
you keep the original timecode track intact, which is critical for recapturing your media
from the original source tapes. For more information about adding auxiliary timecode to
a clip and its media file, see “Modifying Timecode in Media Files.”
To synchronize video and audio clips using In or Out points
1 Open the video clip you want to synchronize in the Viewer.
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2 Scrub through the beginning or end of the clip and find the frame where the clapper on
top of the slate first closes.

3 Set an In point if the “clap” appears at the beginning of your clip, or an Out point if at
the end.
Note: If you decide to use an In point, you should use an In point for each clip you want
to include in the merged clip. If you don’t set an In point yourself, the first frame (Media
Start) of the clip is used instead. If you decide to synchronize by Out points, you should
use an Out point for each clip to be merged. If you don’t set an Out point yourself, the
last frame of the clip is used.
4 Open each audio clip you want to merge in the Viewer, and repeat steps 1 through 3,
identifying instead the frame of audio where you first hear the clap.
Once all your clips are synchronized, you can merge them.
To create a merged clip from two or more clips in the Browser
1 In the Browser, select all the synchronized clips you want to merge.

2 Choose Modify > Merge Clips.
3 In the New Merged Clip dialog that appears, select a method with which to synchronize
the clips: In points, Out points, Timecode, Aux Timecode 1, or Aux Timecode 2.
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4 Click OK.
A new merged clip appears in the Browser. Merged clips are named after the video clip.
Merged clips with no video are named after the topmost selected audio clip in the Browser.
In both cases, the word “Merged” is added at the end.

Duration of Merged Clips
The beginning, end, and overall duration of a merged clip depends on the method you
used to synchronize the original clips:
• If you synchronized all of the original clips using In points: The beginning of the resulting
merged clip corresponds to the In point you used, and all clips line up at that point.
The end of this merged clip corresponds to the end of the clip with the latest timecode
value.
Video
Audio
Audio

Merged clip

• If you synchronized all of the original clips using Out points: The end of the resulting
merged clip corresponds to the Out point you used, and all clips line up at that point.
The beginning of this merged clip corresponds to the beginning of the clip with the
earliest timecode value.
Video
Audio
Audio

Merged clip
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• If you synchronized all of the original clips using timecode: The beginning of the resulting
merged clip corresponds to the beginning of the clip with the earliest timecode value,
and the end of the resulting merged clip corresponds to the end of the clip with the
latest timecode value.
Video
Audio
Audio

Merged clip

Gaps appear in a particular track if one or more items in a merged clip is shorter than all
the others, but they cause no problems.

Creating Merged Clips from the Timeline
You can also create merged clips by dragging a group of linked clip items from the
Timeline to the Browser. This can be useful if you want to synchronize a group of audio
and video clips visually, changing their sync relationship and duration using the various
editing tools available in the Timeline. Viewing each clip item’s timecode in the Canvas
timecode overlays can also be helpful for synchronizing items.
To create a merged clip from two or more clips in the Timeline
1 In the Timeline, edit the clip items you want to merge into a sequence so that they overlap.
Use the Selection, Ripple Edit, and Slip tools to line them up in the sync relationship you
want.

2 Using the Selection tool, select all the clip items you’ve lined up.
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3 Choose Modify > Link (or press Command-L) to link the clip items together.

A line appears
underneath the names
of the selected clip
items to show that
they are linked.

4 Drag the linked clip items from the Timeline to the Browser.

The new merged clip
appears in the Browser.

A new merged clip appears in the Browser, named after the topmost video or audio item
in the Timeline.
Note: If you do not link the clip items you want to merge before you drag them into the
Browser, each item is individually placed in the Browser.

Changing the Sync of Merged Clips
Once a merged clip is created, the only way to modify the sync relationship of the items
within it is to make subframe adjustments. (For more information on making subframe
sync adjustments, see “Subframe Synchronization of Audio and Video.”)
To make larger changes to the sync of items within a merged clip, you must re-create it
using the original items.
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One way to re-create a merged clip quickly is to edit it into a sequence in the Timeline
and make it independent by Control-clicking it and choosing Make Independent from
the shortcut menu. Then unlink the clip items in the Timeline and make any sync changes.
Relink the clip items and drag them back into the Browser to create a new merged clip.
This method creates a new merged clip, but does not affect any instances of the previously
created merged clip that are already edited into sequences elsewhere in your project.
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Working with Projects, Clips, and
Sequences
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This chapter covers the following:
• Specifying Preferences Before You Start Editing (p. 427)
• Working with Projects (p. 428)
• Learning About the Different Types of Clips (p. 431)
• Viewing and Changing the Properties of a Clip (p. 434)
• Creating and Working with Sequences (p. 437)
A project file contains everything you need to make your completed movie: clips, bins
to organize clips, and sequences to arrange your clips into a finished movie.

Specifying Preferences Before You Start Editing
You may want to set the following general preferences before you start editing in
Final Cut Pro. The following preferences are found in the General tab of the User
Preferences window. To view them, choose Final Cut Pro > User Preferences, then click
the General tab. (For a complete description of preferences, see “Choosing Settings and
Preferences.”)
• Levels of Undo: This specifies the number of actions that can be undone (up to 99). The
default is 10. The more levels of Undo you specify, the more memory is required.
• Prompt for settings on New Sequence: By default, this option is turned off and new
sequences use the sequence settings specified in the current Easy Setup. If you turn
on this option, when you create a new sequence, a message asks you to choose a
sequence preset.
• Autosave Vault: Several autosave options let Final Cut Pro automatically save backup
copies of your opened projects at regular intervals while you work. (Your original project
files aren’t touched until you use the Save command.) You can specify how often to
save, along with the number of backup copies saved for each project. For more
information, see “Backing Up and Restoring Projects.”
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Working with Projects
Before you can even capture media, import clips into your project, and edit the clips into
one or more sequences, you need a project in which to do all of this.
Note: Creating, opening, and closing projects is described in “Understanding Projects,
Clips, and Sequences.”

Working with Multiple Projects in the Browser
You can have multiple projects open in Final Cut Pro at the same time. Each project opens
in a separate tab in the Browser.

Choosing Whether the Last Previously Opened Project Opens on Launch
By default, Final Cut Pro opens the last previously open project file (or files) when opened.
You can select whether Final Cut Pro opens with the last open project or an empty project.
To start with a default, empty project instead of the last previously open project file
1 Choose Final Cut Pro > User Preferences, then click the General tab.
2 Deselect the “Open last project on application launch” checkbox.
For more information, see “Choosing Settings and Preferences.”

Viewing and Changing the Properties of a Project
Each project has a set of properties, including global timecode display options, custom
Master Comment column names, and marker color label/visibility settings. You can change
these properties at any time.
To view or change the properties of a project
1 Click the project’s tab in the Browser, then choose Edit > Project Properties.
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2 Choose or enter your options, then click OK.
Choose a time display
option.

Use text fields to confirm
or modify text labels.
Select or deselect marker
visibility checkboxes.
You can change
the Comment column
headings shown
in the Browser.

• Time Display: Choose a global time display option for all clips in your project. Options
include timecode, feet + frames, and frames.
For details, see “Working with Timecode.”
• Reset Time Display checkbox: This is a global checkbox that updates the time display
option for all clips in your project. If this option is selected, all clips in your project are
updated to the timecode display option you chose in the Time Display pop-up menu.
This overrides custom time display options in individual clips in your project.
• Default Film Standard pop-up menu: If you are editing film using Final Cut Pro, you can
choose the format of your film here. For more information, see the documentation that
came with Cinema Tools.
• Time Mode pop-up menu: Choose whether all clips in the active project are displayed
in source time or clip time.
• View Native Speed: This is a global checkbox that changes the time display of all clips
in your project.
• Comment Column Headings: This allows you to customize the four Master Comment
property names in the active project. For example, you can change “Master Comment
1” to “Director’s Notes.”
Note: You can change the name of a Master Comment column, but when you export
this data (or reimport it into Final Cut Pro), the column will always retain its original
name; for example, “Master Comment 1.”
• Marker Visibility: Use the checkboxes to enable or disable the visibility of markers of a
particular color. Use the text fields to confirm or modify the text label for a particular
marker color/category.
For more information about marker visibility and labels, see “Marker Color Labels”
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To choose new project properties each time you create a new project
1 Choose Final Cut Pro > User Preferences (or press Option-Q).
2 Select the “Prompt for settings on New Project” option.

Backing Up and Restoring Projects
Regularly backing up your project file is an important part of the editing process. If your
media files are lost, they can easily be recaptured, but losing a project file could mean
re-creating hundreds of edit decisions made over weeks or months.
You should back up your projects on a regular schedule, regardless of what phase of the
project you are in. You can back up hourly, daily, or even weekly, depending on the scope
and pace of your project. It’s also a good idea to back up at important project milestones,
such as a completed rough edit or just before sending your project out for the final sound
mix.
What Is Contained in a Project File
Project files contain the following items and information:
• Clips, including notes, comments, labels, log notes, and other descriptive clip properties
• Bins
• Sequences
• Effects and keyframe parameters applied to clips
Note: A project file does not contain media files, including any QuickTime, audio, or
graphics files.
Returning to Saved Projects
Two commands in the File menu can be used to open previously saved files—Revert
Project and Restore Project.
• Revert Project: This command lets you return to a previous version of a project that you
saved, not one that Final Cut Pro autosaved. For more information, see “Using the Revert
Project Command.”
• Restore Project: This command lets you choose from all of the available autosaved
versions of the currently selected project, based on the time and date they were created.
For more information about the autosave feature, see “Backing Up and Restoring
Projects.”
Using the Revert Project Command
Sometimes you may make a series of changes to a project on a trial basis. What if you
don’t like those changes and want to start over with your project the way it was the last
time you saved it? You can use the Revert Project command to immediately return to
the previously saved version of a project.
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To revert to the previously saved version of a project
1 Click a project’s tab in the Browser or Timeline to make it active.
2 Choose File > Revert Project.
3 In the dialog that appears, click OK.

Automatically Saving Projects with Autosave
While you’re working, you may find it necessary to go back to an earlier version of a
project you edited: perhaps you tried an alternate cut that didn’t work, or maybe you’re
experiencing problems with your computer. The autosave feature in Final Cut Pro gives
you the option to step back to previous stages of your project, which can save you valuable
time (not to mention unnecessary headaches).
The autosave feature periodically saves a copy of each open project in a folder called the
Autosave Vault. Your original project file is not touched until you use the Save command.
You can change the location of the Autosave Vault in the Scratch Disks tab of the System
Settings window. The Restore Project command allows you to choose from all of the
available autosaved versions of the currently active project, based on the time and date
they were created.
For detailed information about using the autosave feature, see “Backing Up and Restoring
Projects.”

Learning About the Different Types of Clips
There are several kinds of clips in Final Cut Pro. You can distinguish among some clip
types, such as still images and audio, because of their unique icons. However, the icons
for other clip types are almost identical and yet the clips behave differently depending
on where they are located (such as Browser clips versus sequence clips).

Types of Clips
The following terms describe the various clips you work with in Final Cut Pro:
• Video clip: A clip containing a video item. This kind of clip may also contain audio items.
• Audio clip: A clip containing only audio items.
• Sequence clip: A clip that has been edited into a sequence. Clips in a sequence are
made of individual video and audio clip items, which may or may not be linked together
while you edit. When a sequence clip is opened in the Viewer, the scrubber bar displays
sprocket holes so you know you are working on a clip from a sequence.
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• Clip item: Clips edited into a sequence are distributed to individual tracks as clip items.
For example, when you edit a clip with one video and two audio items into the Timeline,
the sequence contains one video clip item and two audio clip items, each on a separate
track. Since these clip items came from the same clip in the Browser, they are
automatically linked together. Linking clip items together keeps them in sync while
you edit.
• Master clip: When you log, capture, or import a media file into Final Cut Pro, a master
clip is created. Master clips exist exclusively in the Browser, and they are used to manage
and reconnect multiple instances of the same footage used throughout your project.
Master clips have a number of clip properties that are shared among any copies (referred
to as affiliates) of the clip. This allows you to reconnect or change the properties of
many affiliate clips at once by changing the properties in the master clip or just one of
the affiliate clips. For more information, see “Working with Master and Affiliate Clips.”
• Affiliate clip: Any clip derived from a master clip in the Browser. Each time you edit a
clip into a sequence, Final Cut Pro creates a new instance of that clip, called an affiliate
clip because it shares properties with its master clip. This new sequence clip gets most
of its properties from the master clip.
• Subclip: A clip created to represent a limited portion of a media file. By artificially limiting
the duration of a media file, a subclip allows you to work with smaller sections of a
media file. These subclip limits can be removed at any time so you can work with the
whole clip. For example, if an original media file is 10 minutes long, the Browser clip is
also 10 minutes long. You can make a 1-minute subclip and work with the subclip as
if the media were only 1 minute long. For more information, see “Creating Subclips.”
• Subclip Parent: A clip from which a subclip has been made. Final Cut Pro provides
commands that allow you to quickly view the subclip parent of a clip in a sequence.
For more information, see “Creating Subclips.”
• Merged clip: A clip that refers to more than one media file at once. A merged clip can
refer to one video file and up to 24 separate audio files. You need to merge a video
clip with audio clips if you record picture and sound to separate devices during
production. For more information, see “Merging Clips from Dual System Video and
Audio.”
• Multiclip: Multiple clips synced together, in parallel, within a single clip. The main reason
to use a multiclip is to edit multicamera footage in real time. You can sync together
any footage you want in a multiclip, not just different camera angles. For instance,
when making a music video, you could sync three different performances of the band
playing and cut between them on the beat.
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About Offline Clips
If a media file is modified, moved, or deleted, the Final Cut Pro clip that connects to that
media file can no longer find it. In this case, the clip’s media file is said to be offline. The
clip itself is described as an offline clip.
An offline clip has a red slash through its icon in the Browser or its file in the Timeline. To
view an offline clip properly in your project, you must capture the clip again or, if the
clip’s media file is already on your disk, reconnect the clip to the corresponding source
file at the new location on disk.

For information on reconnecting offline clips, see “Reconnecting Clips and Offline Media.”
A clip is considered offline when:
• The clip’s Source property is incorrect (when there is no media file at the file path in the
Source property): This happens when a media file is modified, moved, or deleted, the
modification date of the media file is changed, or the scratch disk becomes unavailable.
• The clip’s Source property is empty: You can intentionally make clips offline by choosing
Modify > Make Offline, or you can create a new offline clip by choosing File > New >
Offline Clip. Final Cut Pro doesn’t warn you about offline clips whose Source property
is empty, because there is no media file path to check.
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Sequences as Clips
Sequences are special containers for clips arranged in chronological order. However, in
some cases, sequences can also be treated as clips. For example, you can check the Item
Properties of a sequence just as you can for a clip, and information about the sequence
shows up in the Item Property columns in the Browser. You can also edit sequences into
other sequences. This is called nesting a sequence. For more information, see “Nesting
Sequences.”

Viewing and Changing the Properties of a Clip
Each item in the Browser, such as a clip, has a set of properties. You can view all the
properties of a clip in the Item Properties window as well as in columns in the Browser.
Some properties can be changed directly in the columns of the Browser; others can be
changed in the Item Properties window.
Certain properties, such as frame size or video rate, are determined by a clip’s media file
and cannot be changed without using the Media Manager.
For a detailed table that describes all clip properties, see “Elements of a Final Cut Pro
Project.”

Changing Clip Properties in the Browser
Being able to change clip properties directly in the Browser columns is very convenient.
You don’t need to open any additional dialogs or windows unless you have a specific
reason for doing so. For example, you can clear the In or Out point of a clip, or enter a
comment in one of the Master Comment columns.
It’s just as easy to change the properties for multiple clips as it is for a single clip, although
some clip properties can only be changed one clip at a time. If you want to quickly change
many properties of a single clip, it may be easier to use the Item Properties window.
For more information, see “Viewing and Changing Clip Properties in the Item Properties
Window.”
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To change a clip’s property in a Browser column
Do one of the following:

µ

Control-click a column for the clip or sequence you want to change, then choose an
option or setting from the shortcut menu.

Control-click a column,
then choose an option
from the shortcut menu.

µ

Select a clip, click a column, then enter the new information in the text field.

Enter the new
information.

If a text field doesn’t appear when you click or Control-click a column, the property cannot
be changed directly in the Browser. You may be able to change the property in the Item
Properties window, or it may be a property you can’t modify.
Once you’ve selected one text field in a column of the Browser that can be edited, you
can press Tab to automatically select that clip’s next editable property.
You can select multiple clips and change them all at once. Some columns that allow you
to do this are the Good, Description, Pixel Aspect, Reel, and Anamorphic columns.
To change the properties of multiple clips in a Browser column
1 Select the desired clips.
For more information, see “Browser Basics.”
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2 Control-click the column of one of the selected clips, then choose a new setting or option
from the shortcut menu.

Viewing and Changing Clip Properties in the Item Properties Window
If you find yourself constantly scrolling through the Browser to find particular clip
properties, you can save yourself some time by viewing the clip’s properties in the Item
Properties window instead. The Item Properties window is also a convenient way of
viewing properties of clips that refer to multiple tracks within media files, or multiple
media files on disk—for example, merged clips and multiclips. Three tabs in this
window—Format, Timing, and Logging—allow you to view or change any clip property.
An additional Film tab is used for viewing film metadata imported from Cinema Tools.
Viewing and Modifying Clip Properties
The Item Properties window displays a detailed view of each clip’s properties in a
consistent, organized way.
To view and modify clip properties
1 Select a clip in the Browser or Timeline, or double-click a clip to open it in the Viewer.
2 Do one of the following:
• Choose Edit > Item Properties, then choose an option from the submenu (or press
Command-9).
• Control-click a clip in the Browser, then choose an option from the Item Properties
submenu in the shortcut menu.
3 In the Item Properties window, click a tab to see and modify a clip’s properties.

For detailed information about item properties, see “Elements of a Final Cut Pro Project.”
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Finding a Clip’s Media File
With the exception of internally generated clips (such as slugs or color bars), all clips have
a media file path in their Source property.
To identify the media file to which a clip refers
1 Select a clip in the Browser, then choose Edit > Item Properties > Format (or press
Command-9).
The Item Properties window appears, displaying all of the properties of the clip. The clip’s
Source property contains a file path to the clip’s media file. In some cases, the entire path
may be truncated to fit within the limits of the window.
2 Click Cancel, press Command-Period (.), or press Escape to close the Item Properties
window without making any changes.
Finding a Clip’s Start and End Timecode Values
By definition, a clip’s Media Start and Media End properties represent the first and last
frames of a media file.
To identify the start and end timecode values of a clip’s media file
1 Select a clip in the Browser and choose Edit > Item Properties > Timing (or press
Command-9, then click the Timing tab).
The Item Properties window appears, displaying all of the properties of the clip. The clip’s
Media Start and Media End properties show the starting and ending timecode numbers
of the media file, representing the first and last video frames.
2 Click OK (or press Return or Enter) to close the Item Properties window.

Changing the Properties of Affiliate Clips
Because master clips and their affiliate clips share certain properties, you need only change
the property of one of the master or affiliate clips to change that property in all of them.
For instance, if you want to change a clip’s name, it doesn’t matter whether you change
the name in the master clip or any of its affiliate clips. Since they all share the same name
property, all the clips will have the new name.
Most properties are shared between master and affiliate clips, but there are a few
exceptions. For example, In and Out points are unique to each master and affiliate clip,
so trimming one clip doesn’t affect the duration of all the other affiliated clips. For more
information about clip properties, see “Elements of a Final Cut Pro Project.”

Creating and Working with Sequences
A sequence is a container for editing clips together in chronological order. A sequence
contains one or more video and audio tracks, which are empty when first created.
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Creating and Deleting Sequences
Before you can edit content together in Final Cut Pro, you need to create a sequence to
edit it into. You can create as many new sequences as you want in a project. If you want
to delete a sequence from your project, it’s easy to do.
To create a new sequence in the current project
1 Do one of the following:
• Choose File > New > Sequence (or press Command-N).
• Control-click in the Viewer, then choose New Sequence from the shortcut menu.
A new sequence appears with the name highlighted, so you can change its name right
away.

Enter a new name
for the sequence.

2 Enter a name for the sequence, then press Enter or Return.
To have Final Cut Pro prompt you for a sequence preset each time you create a new
sequence
1 Choose Final Cut Pro > User Preferences, then click the General tab.
2 Select the “Prompt for settings on New Sequence” option.
For more information about sequence presets, see “Sequence Settings and Presets.”
To determine the default number of tracks for new sequences
1 Choose Final Cut Pro > User Preferences, then click the Timeline Options tab.
2 Under “Default Number of Tracks,” enter the default number of video and audio tracks
you want created.
To delete a sequence from the current project
1 Select the sequence you want to delete in the Browser.
2 Do one of the following:
• Choose Edit > Clear.
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• Press the Delete key.
Note: Deleting a sequence from your project does not affect the media files on disk.

Opening and Closing Sequences
You can only edit clips into a sequence when it is open in the Timeline or Canvas. When
you open a sequence, the Timeline and the Canvas open together, if they’re not open
already. If the Timeline and Canvas are already open, a newly opened sequence appears
in its own tab in front of any other sequence tabs.
To open a sequence
Do one of the following:

µ
µ
µ
µ

Select the sequence, then choose View > Sequence in Editor.
Control-click the sequence, then choose Open Timeline from the shortcut menu.
Double-click a sequence in the Browser.
Select the sequence in the Browser, then press Return.
The sequence is displayed in the Timeline and Canvas windows.
You can also treat sequences like clips and open them in the Viewer. You can mark them
with In and Out points and edit them into other sequences, or output them to tape. For
information on editing sequences into other sequences, see “Sequence-to-Sequence
Editing.”

To open a sequence in the Viewer
1 Select the sequence in the Browser.
2 Do one of the following:
• Choose View > Sequence.
• Drag the sequence icon from the Browser to the Viewer.
To open a sequence in a new Viewer window
1 Select the sequence in the Browser.
2 Choose View > Sequence in New Window.

µ

To close a sequence in the Timeline and Canvas
With the sequence tab active in the Timeline or the Canvas, choose File > Close Tab (or
press Control-W).

µ

Control-click a tab in the Timeline or Canvas, then choose Close Tab from the shortcut
menu.

µ

Press Control-W.
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When you close the tab of a sequence in the Timeline, its tab in the Canvas automatically
closes, and vice versa.
Note: If you close the Canvas by pressing Command-W, the Timeline also closes. However,
if you close the Timeline by pressing Command-W, the Canvas stays open. This allows
you to edit using only the Viewer and the Canvas, since some editors prefer to edit with
the Timeline closed.

Duplicating a Sequence
If you want to test changes to your edited sequence that are more extensive than a few
levels of Undo will permit, or if you want to create several versions of your program for
a client to review, you can duplicate your current sequence and make changes to the
duplicate. Changes you make to a duplicate of a sequence do not affect the original in
any way. You can make as many duplicate sequences as you like, renaming them in the
Browser for reference and reediting them as extensively as you want.
To duplicate a sequence
1 Select the sequence in the Browser.
2 Do one of the following:
• Choose Edit > Duplicate (or press Option-D).
• Control-click the sequence, then choose Duplicate from the shortcut menu.

Type a unique name for
the copied sequence.

3 In the Browser, enter a new name for the duplicated sequence.
Sequences are independent of each other, so changes you make to the copied sequence
do not affect the original sequence or its rendered files.
Note: When you duplicate a sequence, all clips in the new sequence are affiliated with
the same master clips as the clips in the original version of the sequence.
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Copying a Sequence into Another Project
If you have more than one project file open in the Browser, you can copy a sequence
from one project and paste it into another project.
To copy a sequence from one project into another
1 Select the sequence in the Browser.
2 Choose Edit > Copy (or press Command-C).
3 Open a new project and select its tab in the Browser.
4 Choose Edit > Paste (or press Command-V).
You can also copy a sequence into another project window by dragging.
To copy a sequence from one project to another by dragging
1 Open the second project.
This project appears as another tab in the Browser.
2 Tear away the second project tab in the Browser to make it its own window.
3 Drag the sequence from the Browser in the first project window to the Browser in the
second project.

The copied sequence appears in your first project.
To create master clips for a sequence pasted into a project
1 Select the sequence in the Browser.
2 Choose Tools > Create Master Clips.
A bin is created called “Master Clips for [sequence name],” named after the sequence.
Master clips are created for any independent clips in the sequence, and the independent
clips become affiliate clips of the new master clips. If master clips already exist for all clips
in the sequence, no bin or master clips are created.
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Nesting a Sequence
In Final Cut Pro, you can treat sequences as clips and edit them into other sequences.
This is called nesting a sequence, because you put one sequence inside of another. Nesting
sequences is a common practice when you work on small, independent sequences for a
while and then you want to quickly attach them together in another, master sequence.
Nesting sequences does create some processing overhead, and can make media
management more complicated.
For more information, see “Nesting Sequences.”

Basic Sequence and Timeline Settings
Before you began logging and capturing, you most likely chose an Easy Setup that
established your basic sequence settings and Timeline display options. An Easy Setup is
a preset group of capture, device control, sequence, external playback, and output settings
for a particular video or audio format and hardware configuration. Each Easy Setup
represents a simple workflow that maintains that same video format throughout capturing,
editing, and output. If one of the available Easy Setups describes your workflow, you
should have no need to adjust your sequence and Timeline settings. For more information,
see “Audio/Video Settings and Easy Setups.”
You can easily conform your sequence settings to the settings of the first clip you edit
into your sequence. For more information, see “Working with Mixed-Format Sequences.”
Why Would You Change Your Sequence Settings?
Although the instances are rare, there are a few situations that may prompt you to change
your sequence settings:
• You’ve imported multiple video or audio formats, and you decide to change your
sequence settings to accommodate the more dominant format in your sequence to
reduce rendering.
• You’ve changed your video interface or capturing setup, allowing you to work in the
Y′CBCR (YUV) color space rather than the RGB color space.
• You’ve added an audio output device that allows you to output multiple channels of
audio directly from Final Cut Pro.
• Your intended output format has changed.
Sequence settings such as frame size, video compressor, and audio sample rate can be
modified at any time.
Note: The one setting that may not be changed is the sequence frame rate (referred to
as the editing timebase). You can change a sequence’s frame rate (editing timebase) only
if the sequence is empty. Once a sequence contains one or more clips, you can’t change
its editing timebase. Removing all the clips from the sequence allows you to change the
sequence’s editing timebase.

442

Chapter 30 Working with Projects, Clips, and Sequences

Changing sequence settings is discussed in “Sequence Settings and Presets.”
Viewing an Existing Sequence’s Settings
All sequences have settings as soon as they are created. When you first create a sequence,
its settings are determined by the currently selected sequence preset in the Audio/Video
Settings window, which is specified by your current Easy Setup.
To view sequence settings
1 Do one of the following:
• Select a sequence in the Browser.
• Open a sequence in the Timeline.
2 Choose Sequence > Settings.
For information about changing sequence settings, see “Sequence Settings and Presets.”
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The Fundamentals of Adding Clips
to a Sequence

31

This chapter covers the following:
• Creating a Rough Edit (p. 445)
• Overview of Ways to Add Clips to a Sequence (p. 448)
• Preparing a Sequence Order in the Browser (p. 450)
Once your clips are captured and organized to your satisfaction in the Browser, you can
begin moving your content into a sequence.

Creating a Rough Edit
During the rough editing phase of your project, the overarching structure of your movie
begins to take shape. A rough edit is like an outline of your finished movie, and many
details remain to be worked out. At this point, you arrange, copy, delete, and work with
large groups of clips at once. You may even be missing footage still, but you can use
placeholder clips, such as slug or text, to note areas that need work.

Basic Steps Involved in a Rough Edit
Basic rough assembly and editing involves the following steps.
Stage 1: Adding Clips to the Sequence
Final Cut Pro allows you to add clips to your sequence in several ways. The simplest
method is to select clips in the Browser or Viewer and drag them to the Timeline. You
can also add clips to a sequence in a more precise way, setting In and Out points in both
your source clip and destination sequence, and then dragging the clip to the Canvas.
This is called three-point editing.
Stage 2: Arranging Clips
This is where you assemble the clips in the Timeline into the order you want by selecting,
moving, copying, cutting, pasting, and deleting.
Stage 3: Making Rough Adjustments to Clips in the Timeline
In the process of assembling the rough edit, you typically find you want to change the
duration of some clips, trim the heads or tails of some clips, or divide clips into smaller
pieces and reposition them.
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How Clips Appear in the Timeline
Before you begin editing and arranging clips in a sequence in the Timeline, it’s a good
idea to look at how clips are represented when they’re first edited into a sequence. When
you edit a clip into the Timeline, an affiliated copy of that clip is placed in your sequence.
The clip in the Timeline looks like this:

Video clip item

Audio clip items

An underline indicates
items that are linked.

In the example above, a clip containing one video item and two audio items was added
to the sequence. Each of these items is called a clip item.
The video clip item is placed in track V1 of the Timeline, and the two audio clip items are
placed in tracks A1 and A2, respectively. Each of these items is named after the master
clip in the Browser from which it came. All three clip items are linked together, which is
indicated by the line under each clip item name. Linking clip items together keeps the
items in sync with each other.
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Since the audio and video items of each edited clip are linked, selecting the video clip
item also selects the audio clip items, and edits you make to one are automatically made
to the others. For example, if you move a video clip item from track V1 to track V2, the
audio clip items move from tracks A1 and A2 to tracks A3 and A4.

Video clip item in V1
Audio clip items in A1
and A2

When you move a video
clip item to a new track...

...the audio clip items
move as well because
they are linked.

The video clip item is
now in V2.

Linked audio clip items
are in A3 and A4.

Video and audio clip items can be linked or unlinked at any time. For more information,
see “Linking and Editing Video and Audio in Sync.”
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Undoing and Redoing Actions
As you begin to edit in Final Cut Pro, rest easy with the knowledge that you can undo
actions you take in your projects, sequences, and clips, including editing clips into
sequences. The Undo command is helpful if you make a change you don’t like, or make
a mistake and want to revert to an earlier version. You can also redo actions that you
have undone.
By default, you can undo 10 of your previous actions before quitting Final Cut Pro. You
can set Final Cut Pro to undo up to 99 actions in the General tab of the User Preferences
window. The more levels of Undo you select, the more memory is needed to save all of
your changes. For more information on modifying the number of changes to undo, see
“Choosing Settings and Preferences.”

You can change the
number of Undo
levels here.

µ

To undo a change
Choose Edit > Undo (or press Command-Z).

µ

To redo a change
Choose Edit > Redo (or press Command-Shift-Z).

Overview of Ways to Add Clips to a Sequence
When you edit, there are two basic ways to add clips to your sequence. Once you
determine how you want to add clips, you can specify what part of each clip you want
to add. You can also add entire clips or groups of clips to your sequence for your rough
edit.
Note: You can automatically conform a sequence’s video settings to the settings of the
first clip you edit into the Timeline. For more information, see “Working with Mixed-Format
Sequences.”

Methods for Adding Clips to Sequences
There are two basic approaches to placing clips into a sequence—drag-to-Timeline editing
and three-point editing. Three-point editing can be more precise than dragging clips
directly to the Timeline, but it requires a few additional steps. In the earliest stages of
editing, you may prefer the simplicity of the drag-to-Timeline method.
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About Drag-to-Timeline Editing
The faster, less precise way of editing content into a sequence is to drag a source clip
from the Browser or the Viewer directly to tracks in the Timeline. This simple method is
discussed more in “Drag-to-Timeline Editing.”
Drag a source clip
from the Viewer...
...to a track in
the Timeline.

About Three-Point Editing
In three-point editing, you set In and Out points in both a source clip and a sequence to
determine the duration and placement of an edit. You also choose the destination
sequence tracks in which your source clip is placed. Three-point editing gets its name from
the fact that Final Cut Pro needs no more than three In and Out points in the source clip
and the destination sequence to perform the edit. Either the source clip or the sequence
has both In and Out points set, while the other has only an In or an Out point set. The
fourth edit point is inferred from the duration of the edit.
For example, if you set In and Out points in a source clip and an In point in a sequence,
the Out point in the sequence is determined by the duration of the source clip. In this
case, the sequence In point determines where the source clip is placed, and the source
clip determines the duration of the edit.
(3) Sequence
In point

(4) Sequence Out
point (inferred)

(1 and 2) Source clip
In and Out points
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However, if you set In and Out points in a sequence and an In point in your source clip,
the Out point of the source clip is determined by the duration between the sequence In
and Out points. In this case, the sequence In and Out points limit how much of the source
clip is placed in the sequence.
(3) Clip In point
(1 and 2) Sequence
In and Out points

(4) Clip Out point
(inferred)

For more details about three-point editing, see “Three-Point Editing.”

Determining What Parts of Clips You Want in Your Sequence
To specify what part of a clip you want in your sequence, you open it in the Viewer and
set In and Out points. The In point is the first frame of the clip you want to use in a
sequence, and the Out point is the last frame. For information about setting In and Out
points for clips, see “Setting Edit Points for Clips and Sequences.”
If you like, you can also add an entire clip to your sequence, without setting In or Out
points for it. For information, see “Dragging Clips to the Timeline.”
Instead of adding clips to your sequence one at a time, you can organize a group of clips
in the Browser and drag all of them to your sequence at the same time. For information
about adding groups of clips directly to your sequence, see “Preparing a Sequence Order
in the Browser.”

Preparing a Sequence Order in the Browser
You can sort clips or visually arrange them (using icon view) in the Browser and then drag
the sorted group of clips to the Canvas or Timeline to instantly edit them into your
sequence in the arranged order. It’s not necessary to arrange a sequence order of clips
in the Browser before moving them into a sequence, but the techniques described here
can save you some time.
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Sorting to Create a Sequence Order
The ability to sort by column information in the Browser (in list view) can help you quickly
organize clips into the order in which you want them to appear in your sequence.
For example, if you entered scene and shot numbers when you logged your shots, you
can sort by these two columns, and then select all of these shots to edit into your sequence
in the correct order. Or, if you want to edit your footage into a sequence in the
chronological order in which scenes were shot, you can sort by the Reel and Media Start
columns, and then drag a group of clips into your sequence.
For more information on sorting, see “Sorting Items in the Browser Using Column
Headings.”

Visually Storyboarding in the Browser
If you display your clips in icon view in the Browser, you see a thumbnail of each clip,
which provides a quick visual way to arrange the icons of your clips into a storyboard for
your sequence. If you then drag all of the arranged clips to the Canvas or Timeline, the
clips are laid out in your sequence according to their position in the Browser. You can
then adjust, or fine-tune, the content of each clip in the Timeline.
For example, a group that’s arranged like this:
1

2

4

5

3
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Goes into your sequence like this:
1

2

3

4

5

To create a storyboard in the Browser
1 Control-click in the Browser, then choose View as Large Icons from the shortcut menu.
2 Drag the clips into the order in which you want them to appear, keeping the rows of clips
relatively straight, so that Final Cut Pro can properly determine their order.
Tip: To ensure clips are placed in the Timeline in the proper order, place each subsequent
clip several pixels lower and to the right of the previous clip.

Arrange the clips in
the order you want,
from left to right and
top to bottom.

Note: If you don’t want to use the entire duration of each clip, you can set In and Out
points for each clip to specify the part you want to use (see “Setting Clip In and Out Points
in the Viewer”).
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Using Markers

32

This chapter covers the following:
• Learning About Markers (p. 453)
• Viewing Markers in the Viewer or Canvas (p. 459)
• Viewing Markers in the Browser (p. 459)
• Adding Markers in Clips and Sequences (p. 460)
• Deleting Markers in Clips and Sequences (p. 463)
• Navigating with Markers (p. 465)
• Modifying Markers (p. 466)
• Moving Markers (p. 467)
• Using the Ripple Sequence Markers Setting (p. 469)
• Editing Multiple Markers on the Same Frame (p. 469)
• Aligning Items in the Timeline by Their Markers (p. 470)
• Extending a Marker’s Duration (p. 471)
• Editing Markers into Sequences (p. 472)
• Exporting Markers with Your QuickTime Movies (p. 472)
• Exporting Marker Lists as Text (p. 473)
Markers are reference points you can place within clips or sequences to identify specific
frames. You can use them for a variety of purposes, and export them with your finished
movie.

Learning About Markers
Markers are visible points on clips and sequences that can be used for commenting,
synchronizing, editing, adding DVD chapter and compression markers, and even making
subclips. By default, markers exist only on the frame where they were created, but you
can also create markers that have a duration.
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What Can You Do with Markers?
Markers let you perform a wide variety of tasks:
• Mark several possible In or Out points for future use.
• Quickly move the playhead to a marker in a clip or sequence.
• Mark a range in a clip that you may want to use as a subclip.
• Align a clip marker to a marker in an edited sequence to match a visual or audio cue.
• Align a filter or motion keyframe to a marker for future reference.
• Align other clip markers, clip boundaries, or transition boundaries to a marker in the
Timeline.
• Divide clips into subclips using the Make Subclip command.
• Add visual notes about clips that will help you identify sections while editing.
• Use up to eight different colors of markers for a color-coded commenting system.
• Export marker data as tab-delimited text.
• Ripple sequence markers in the event of insert, ripple delete, or ripple trim edits.
You can also include markers in QuickTime movies you export. You can:
• Export chapter markers for use with QuickTime and DVD-authoring applications.
• Export compression markers for use with video compression applications.
• Export scoring markers for use with supported music and audio applications.

Differences Between Clip and Sequence Markers
You can add markers to both clips and sequences. There are differences between clip
markers and sequence markers that could affect your work.
• Clip markers appear on individual clips in the Viewer and Timeline. You can add these
markers in the Viewer or in the Timeline.
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• Sequence markers appear both in the Timeline ruler and in the Canvas scrubber bar.
You can add these markers in the Canvas or in the Timeline.
Sequence markers

Clip markers

Make sure you understand how you want to use markers in your project before you add
them. The following list points out some example uses of markers.
• Add markers to a clip when you want to remember and mark important moments in
a shot.
• Use markers to separate a long piece of footage into several subclips by adding markers
and then making them into subclips. (See “Turning Markers into Subclips”).
• You can add markers to sequences for a variety of reasons. You can mark specific points,
such as audio cues, in your sequence for reference while editing. This includes musical
beats to sync clips to. For example, if you are editing a music video, you can add a
music clip to the Timeline, click Play, and then press the M key to the beat of the music,
adding markers for each beat. Once the markers are in place, you can go back and snap
clips to the markers you created. You can nudge your clips a few frames forward or
backward if your markers are not perfectly on the beat.
• Use markers to snap the playhead or clips to a specific point when performing an edit.
• Use markers in a sequence to create points to navigate between.
• Use markers to add review comments and notes to a sequence, so that another person
on the moviemaking team can then read these comments in the sequence at the
appropriate place.
• Use markers in sequences so you can add MPEG compression markers and DVD chapter
markers.
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Types of Markers
There are several kinds of markers that you can add in Final Cut Pro.
• Note marker: This is the default marker that is created when you add a marker to a clip
or sequence.
• Chapter marker: These markers are automatically translated into DVD chapter markers
in applications such as DVD Studio Pro. A chapter marker is distinguished by the text
<CHAPTER> appearing in the Comment field of its Edit Marker window.
• Compression marker: Also known as manual compression markers, these are markers
you can add to a sequence or clip to indicate when Compressor or DVD Studio Pro
should generate an MPEG I-frame during compression. To improve MPEG compression,
you should add compression markers when there is an abrupt visual change from one
frame to the next within a clip. A compression marker is distinguished by the text
<COMPRESSION> appearing in the Comment field of its Edit Marker window in
Final Cut Pro.
• Scoring marker: These markers are used for marking important visual cues to sync music
to. They are visible when you open an exported QuickTime movie in Soundtrack Pro.
A scoring marker is distinguished by the text <SCORING> appearing in the Comment
field of its Edit Marker window.
• Audio peak marker: Any audio samples over 0 dBFS are marked when you choose Mark
> Audio Peaks > Mark. These markers show where in your clip the audio is digitally
clipping, indicating you should reduce the level at that point. You can clear audio peak
markers by choosing Mark > Audio Peaks > Clear. For more information, see “Diagnostic
Tools for Clips.”
• Long frame marker: During capture, some frames may be captured with a longer duration
than is acceptable. This can lead to playback and output problems. To mark long frames,
you can choose Tools > Long Frames > Mark. If your clip has long frames, you can try
recapturing the clip or avoid using that part of the media file. For more information,
see “Diagnostic Tools for Clips.”

Marker Colors and Labels
Markers can have up to eight different possible colors and associated text labels.
Marker Colors
Markers are available in eight different colors, with red as the default. Marker color can
be modified in the Edit Marker dialog. You can also create markers with specific colors
by pressing the Shift key and any of the number keys 1–8.
• Shift-1: Red
• Shift-2: Orange
• Shift-3: Yellow
• Shift-4: Green
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• Shift-5: Turquoise
• Shift-6: Blue
• Shift-7: Purple
• Shift-8: Pink
You can also specify or change the color of a marker with the Edit Marker dialog. For
more information, see “Modifying Markers” and “Adding Markers in Clips and Sequences.”
Default Colors for Marker Types
Some standard types of markers have default colors:
• Note markers: Red
• Chapter markers: Purple
• Compression markers: Blue
• Scoring markers: Orange
• Audio peak markers: Orange
• Long frame markers: Purple
You can always manually modify the marker color in the Edit Marker dialog. For more
information about marker types, see “Types of Markers.”
Note: Sequence and clip markers created in Final Cut Pro 6.x or earlier appear green and
pink, respectively.
Marker Color Labels
Each marker color has a text label that you can customize for a given project. For example,
you might want to rename the green label “Director’s Notes” so that the director uses
green markers when she enters her notes. Or you could rename the yellow label “Editor’s
Notes” and the editor would file his comments with yellow markers.
This labeling system can be useful in different ways:
• If your project becomes over-cluttered with markers, you can hide markers of a particular
color/label category. For more information about adjusting marker visibility in the
Project Properties dialog, see “Viewing and Changing the Properties of a Project.”
• You can use these labels when you export a markers lists as text using the Export
Markers Lists as Text feature. For example, you might open the exported
comments/notes in a spreadsheet program and sort the comments and notes according
to the information in the labels (by Director’s Notes or by Editor’s Notes). For more
information, see “Exporting Marker Lists as Text.”
To hide or show markers or to customize marker color labels
1 Choose Edit > Project Properties.
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The Project Properties dialog appears.
Choose a time display
option.

Use text fields to confirm
or modify text labels.
Select or deselect marker
visibility checkboxes.
You can change
the Comment column
headings shown
in the Browser.

2 In the Marker Visibility section, do any of the following:
• Use the checkboxes to turn on or off the visibility of markers of a particular
color/category.
• Use the text fields to confirm or modify the text label for a particular marker
color/category.
3 Click OK.
Markers will appear or be hidden based on your settings. Any marker color label
information that you entered will be exported with other marker data when you export
a markers list as text using the Export Markers Lists as Text feature.
Note: Marker color labels are also visible as tooltips in the Edit Marker dialog.
Note: Marker color labels are project-specific. Unless you set up a Final Cut Pro project
to use as a template, you will have to reenter any custom label settings for each new
project. In User Preferences, you can set Final Cut Pro to automatically remind you to
enter project settings for each new project. See “Viewing and Changing the Properties
of a Project” for more information.
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Viewing Markers in the Viewer or Canvas
Marker icons appear in the scrubber bar, as well as in overlays over the video image
whenever the playhead is positioned at a marker. For more information, see “Viewer
Basics.” You can also refer to “Canvas Basics.”

A marker overlay

Viewing Markers in the Browser
When you add a marker to a clip that you’ve opened from the Browser, that marker is
displayed in the Browser in list view.

µ

To view a clip’s markers in the Browser
Click the disclosure triangle next to a clip containing markers.

Markers within a clip

Clip markers are displayed hierarchically within the clip. You can change the name of a
marker in the Browser, and you can also create subclips from markers. For more information
about working with subclips, see “Creating Subclips.”
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Adding Markers in Clips and Sequences
You can add markers, name them, and attach comments and colors to them. The marker
names, comments, and colors appear as overlays in the Viewer, Canvas, or Timeline
whenever the frame containing the marker is displayed. You can also add further
functionality to a marker by specifying the kind of marker it is, such as a chapter marker,
compression marker, or scoring marker. Audio peak and long frame markers can only be
added by using the Mark Audio Peaks and Mark Long Frames commands, respectively.
For details, see “Types of Markers.”
Markers can be set (and modified) while a clip or sequence is playing or while the playhead
is stopped. The number of markers you can use in a clip or sequence is limited only by
the number of frames in the clip or sequence.
By default, Final Cut Pro creates a Note marker. The first marker you add is named Marker
1, the second Marker 2, and so on. The default names indicate the order in which you’ve
added them to a clip, not the chronological order in which they appear in a clip or
sequence. You can rename markers to indicate the location they mark. For more
information, see “Modifying Markers.”

Quickly Adding Markers
If you want to quickly add markers to clips or sequences, and you don’t care about the
names, you can follow these instructions. By default, Note markers are created and each
is automatically named by Final Cut Pro. If you prefer to add all of the information for a
marker when you create the marker, see “Adding Markers with Detailed Information.”
To quickly add a marker to a clip in the Viewer
1 Open the clip in the Viewer.
2 Play the clip or sequence.
3 When the playhead reaches the point you want to mark, do one of the following:
• Choose Mark > Markers > Add, or press the Grave Accent (`) key.
• Press M.
• Click the Add Marker button.

Add Marker button

• Press Shift-1 through Shift-8 to create markers with different colors. See “Marker Colors”
for more information.
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A clip marker appears. Unless you specified a different color, the marker is red.
To quickly add a marker to a sequence clip in the Timeline
1 In the Timeline, do one of the following:
• Select the clip to which you want to add a marker, then position the playhead where
you want to place the marker.
• Double-click the clip to which you want to add the marker; then, in the Viewer, position
the playhead where you want to place the marker in the clip.
2 Do one of the following:
• Choose Mark > Markers > Add, or press the Grave Accent (`) key.
• Press M.
• In the Canvas, click the Add Marker button.
• Press Shift-1 through Shift-8 to create a marker with a specific color. See “Marker Colors”
for more information.
A clip marker appears. Unless you specified a different color, the marker is red.
Note: You can add markers to sequence clips in the Timeline only if the clip is selected
and the playhead intersects the clip. If no sequence clip is selected, or the playhead
doesn’t intersect the selected sequence clip, any markers you add appear in the Timeline
ruler.
To quickly add a marker to a sequence
1 In the Timeline, position the playhead where you want to place the marker in the sequence.
Make sure no clips are selected. If the playhead is over a selected clip in the Timeline,
markers are added to the selected clip instead of to the sequence.
2 Do one of the following:
• Choose Mark > Markers > Add, or press the Grave Accent (`) key.
• Press M.
• In the Canvas, click the Add Marker button.
• Press Shift-1 through Shift-8 to create a marker with a specific color. See “Marker Colors”
for more information.
A sequence marker appears in the Timeline ruler. Unless you specified a different color,
the marker is red.

Adding Markers with Detailed Information
If you like, you can name a marker, add comments, and choose the kind of marker when
you first create it.
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To add a marker to a clip and enter information for it
1 Do one of the following:
• To add a marker to a clip in the Viewer: Open a Browser or sequence clip in the Viewer.
• To add a marker to a clip in the Timeline: Select the sequence clip to which you want to
add a marker, then position the playhead where you want to place the marker.
2 Navigate to the frame where you want to add a marker, then do one of the following:
• Choose Mark > Markers > Add, or press the Grave Accent (`) key.
• Press M.
• Click the Add Marker button in the Viewer or Canvas.
• Press Shift-1 through Shift-8 to create a marker with a specific color. See “Marker Colors”
for more information.
A clip marker appears. Unless you specified a different color, the marker is red.
3 To open the Edit Marker dialog, do one of the following:
• Press M.
• Hold down the Command key and double-click the marker.
This function is available in the Viewer, Canvas, and Timeline ruler only.
• Press the Grave Accent (`) key.
• Click the Add Marker button again.
4 In the Edit Marker dialog, do any of the following, then click OK.
• In the Name field, rename the marker.
• In the Comment field, add any information you want to include with the marker.
• Click one of the Color buttons to specify a marker color.
• Click a button to specify the kind of marker this is. The appropriate code is automatically
added to the Comment field.

Enter a name here.
Add any comments
in this field.
Choose a color label.
If you wish, click
a button to choose
the kind of marker.
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Adding Chapter, Compression, and Scoring Markers
Chapter, compression, and scoring markers can be used by external applications such as
Compressor, DVD Studio Pro, iDVD, Soundtrack Pro, and QuickTime Player. The Edit Marker
dialog lets you specify a marker as chapter, compression, or scoring. To add a chapter,
compression, or scoring marker to a sequence, follow the instructions in “Adding Markers
with Detailed Information.”
Important: Chapter, compression, and scoring markers are used only for sequences. When
you export a QuickTime movie, make sure that these markers have been added to the
sequence itself in the Canvas or in the Timeline ruler, and not to individual clips.

Deleting Markers in Clips and Sequences
You can delete markers at any time. Once they are deleted, they no longer appear in the
Browser, Viewer, Canvas, or Timeline. You can also keep a marker while removing chapter,
compression, or scoring annotations.

µ

To quickly delete specific markers by dragging them from the Viewer, Canvas, or
Timeline ruler
Hold down the Command key and drag the marker off the scrubber bar or the Timeline
ruler.

To quickly delete specific markers in the Viewer, Canvas, or Timeline ruler with the
Edit Marker dialog
1 Hold down the Command key and double-click the marker.
This function is available in the Viewer, Canvas, and Timeline ruler only.
2 Click Delete in the Edit Marker dialog.
To delete all markers in a clip in the Viewer or Timeline
1 Open the clip in the Viewer.
2 Choose Mark > Markers > Delete All, or press Control–Grave Accent (`).
To delete specific markers in a clip in the Timeline
1 Move the playhead to the marker you want to delete.
Tip: You can easily navigate to the previous or next marker by choosing Mark > Previous
> Marker or Mark > Next > Marker.
2 Do one of the following:
• Choose Mark > Markers > Delete, or press Command–Grave Accent (`).
• In the Viewer or Canvas, Option-click the Add Marker button.
• Press M or the Grave Accent (`) key to open the Edit Marker dialog, then click Delete.

Chapter 32 Using Markers

463

To delete specific markers in a clip in the Browser
1 Click the disclosure triangle next to a clip containing markers.
2 Select the markers you want to delete.
3 Do one of the following:
• Choose Edit > Clear.
• Press Delete.
To delete specific markers in a sequence
1 In the Canvas or Timeline, move the playhead to the sequence marker you want to delete.
Note: Make sure no items are selected in the Timeline.
2 Do one of the following:
• Choose Mark > Markers > Delete, or press Command–Grave Accent (`).
• In the Canvas, Option-click the Add Marker button.
• Press M or the Grave Accent (`) key to open the Edit Marker dialog, then click Delete.
To delete all markers in a sequence
1 Make the Canvas or Timeline active.
Note: Make sure no items are selected in the Timeline.
2 Choose Mark > Markers > Delete All, or press Control–Grave Accent (`).
To keep a marker but remove chapter, compression, or scoring annotations
1 Do one of the following to open the Edit Marker dialog for the marker:
• Hold down the Command key and double-click the marker.
This function is available in the Viewer, Canvas, and Timeline ruler only.
• In the Viewer, Canvas, or Timeline, move the playhead to the marker and press M or
the Accent key (`).
2 In the Comment field, delete the appropriate marker annotation text, then click OK.
• To remove a chapter marker: Delete the text <CHAPTER>.
• To remove a compression marker: Delete the text <COMPRESSION>.
• To remove a scoring marker: Delete the text <SCORING>.
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Navigating with Markers
You can navigate through your clip or sequence using the markers you’ve set. This is
useful when you want to quickly navigate to specific points in a clip or in the Timeline.
For example, you can place markers in the Timeline to mark two different frames for
matching during color correction, or place markers to quickly jump to different scenes
in a sequence.
To move the playhead to a marker in the Viewer or Canvas
Do one of the following:

µ

Control-click in the Current Timecode field, then choose a marker from the shortcut menu.

Choose a marker.

µ

Drag the playhead to the marker in the scrubber bar.
If snapping is turned on, the playhead snaps to the position of a nearby marker. When
the playhead is over a marker in the Viewer or Canvas, the marker appears darker.
To move the playhead to a clip or sequence marker in the Timeline
Do one of the following:

µ

Control-click the Timeline ruler, then choose a marker from the list of sequence and clip
markers in the shortcut menu.

Choose a marker.

µ

Drag the playhead to a sequence marker in the Timeline ruler.
If snapping is turned on, the playhead snaps to the position of a nearby marker.
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To move to the next marker (to the right)
Do one of the following:

µ
µ

Choose Mark > Next > Marker (or press Shift–Down Arrow).
Press Shift-M.
To move to the previous marker (to the left)
Do one of the following:

µ
µ

Choose Mark > Previous > Marker (or press Shift–Up Arrow).
Press Option-M.

Modifying Markers
After you add a marker, you can rename it, add information in the comment field, change
the marker color, or change the marker type. You can also add and modify markers during
playback.
To open a marker’s Edit Marker dialog
1 Stop playback if playback is in progress.
2 Do one of the following:
• Hold down the Command key and double-click the marker.
This function is available in the Viewer, Canvas, and Timeline ruler only.
• Move the playhead to the marker (see “Navigating with Markers”) and do one of the
following:
• Choose Mark > Markers > Edit.
• In the Browser, Control-click the marker, then choose Edit Marker from the shortcut
menu.
• Press M.
• Press the Grave Accent (`) key.
The Edit Marker dialog opens.
To rename a marker, add comments to a marker, or change the marker color or type
1 Open the marker’s Edit Marker dialog.
2 In the Edit Marker dialog, do any of the following, then click OK.
• In the Name field, rename the marker.
• In the Comment field, add any information you want to include with the marker.
• Click one of the Color buttons to specify a marker color.
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• Click a button to specify the type of marker.

Enter a name here.
Add any comments
in this field.
Choose a color label.
If you wish, click
a button to choose
the kind of marker.

You can add markers and modify them while playing back clips and sequences.
To add a marker and open its Edit Marker dialog during playback
Do one of the following:

µ

Press Shift-Option-M.
Without interrupting playback, a red marker is added and its Edit Marker dialog opens.

µ

Press Shift–Option–1 through 8.
Without interrupting playback, a marker with the color corresponding to the number key
is added and its Edit Marker dialog opens. For more information about marker colors and
keyboard shortcuts, see “Marker Colors.”
You can control playback while modifying a marker. (This requires special keyboard
shortcuts that do not interfere with the text editing keys.)
To control playback while the Edit Marker dialog is open
Do one of the following:

µ
µ

Press Control–Space bar to play or pause playback.
Press Command–Control–Space bar to rewind and play back.
The playback begins before the playhead position based on the value in the Preview
Pre-roll field in the Editing tab of the User Preferences window. (The default Pre-roll value
is five seconds.)

Moving Markers
You can move a marker by dragging it, by repositioning the playhead, or by entering a
different starting timecode value. Using the playhead, you can only move a marker forward,
not backward.
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µ

To move a marker by dragging it
In the Viewer or the Timeline, Command-drag the marker left or right to the new location.

To move a marker in a clip forward by repositioning the playhead
1 In the Viewer or Timeline, move the playhead to the location where you want to move
the marker.
2 Choose Mark > Markers > Reposition, or press Shift–Grave Accent (`).
Final Cut Pro moves the marker that is immediately to the left of the playhead’s current
position. Even if there are multiple markers, only the one immediately to the left of the
playhead is moved.
To move a marker in a clip by entering a new timecode value
1 In the Viewer, do one of the following:
• Hold down the Command key and double-click the marker.
This function is available in the Viewer, Canvas, and Timeline ruler only.
• Move the playhead to the marker, then do one of the following:
• Choose Mark > Markers > Edit.
• Press M.
• Click the Add Marker button.
• Press Command-Option-M to edit the nearest marker to the left.
2 In the Edit Marker dialog, enter a new start time in the Start field, then click OK.

Enter the new time here.

To move a marker in a sequence by entering a new timecode value
1 Do one of the following:
• Hold down the Command key and double-click the marker.
This function is available in the Viewer, Canvas, and Timeline ruler only.
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• In the Timeline or Canvas, move the playhead to the marker and do one of the following:
• Choose Mark > Markers > Edit.
• Press M.
• Click the Add Marker button.
2 In the Edit Marker dialog, enter a new start time in the Start field, then click OK.

Using the Ripple Sequence Markers Setting
By default, sequence markers (markers in the Timeline ruler and the Canvas scrubber bar)
ripple after any ripple edit or insert edit. After an insert edit, any sequence markers after
the insertion point ripple downstream. After a ripple delete, any sequence markers after
the last deleted frame ripple upstream.
Follow the instructions below to manually turn on or off the Ripple Sequence Markers
setting.
To turn on or off the Ripple Sequence Markers setting
Do one of the following:

µ
µ

Choose Sequence > Ripple Sequence Markers.
Select or deselect the Ripple Sequence Markers button in the Timeline button bar.

Editing Multiple Markers on the Same Frame
It is possible that two or more markers might accidentally appear on the same frame. If
this happens and you need to edit an individual marker, you can use the Choose Marker
pop-up menu to open the Edit Marker dialog for the specific marker.
To edit a specific marker if multiple markers appear on the same frame
1 Open the Edit Marker dialog for one of the markers.
For more information on opening the Edit Marker dialog, see “Modifying Markers.”
If the marker is on the same frame as other markers, a Choose Marker pop-up menu
appears above the Name field.
2 Choose the marker you want to edit from the pop-up menu.
The Edit Marker dialog for the appropriate marker appears.
3 Enter the changes in the Edit Marker dialog, then click OK.
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Aligning Items in the Timeline by Their Markers
You can move a clip item in the Timeline by dragging one of its markers. When you do
this with snapping turned on, the marker becomes the clip item’s snap point. So while
you’re dragging a clip item by one of its markers, its In and Out points won’t snap to
anything. This allows you to quickly align markers in sequence clips to one another, or
to markers in your sequence.
For example, suppose you have a sequence that contains a shot of a person dropping a
glass and an audio clip of jarring music. You can easily align these elements to a specific
point in your sequence by adding markers at the relevant points in your sequence clips,
and then dragging each sequence clip by the marker with snapping turned on.
To align markers in sequence clip items to a sequence marker
1 Add markers to important frames of individual video and audio clip items in your sequence.
2 Add a marker to the place in your sequence where you want to align your clip items.
3 Make sure snapping is turned on by doing one of the following:
• Click the Snapping button in the Timeline.
• Press N.
Snapping button
Add a sequence marker
for aligning the
sequence clip items.
Add a marker to the
video clip item.

Add markers to the
audio clip items.

4 Drag the video clip item by its marker until it snaps to the sequence marker.
5 Drag the audio clip item by its marker until it snaps to the sequence marker.
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The video and audio clip item markers are now aligned with the sequence marker.

The video and audio
clip item markers are
aligned with the
sequence marker.

Note: When you drag a clip from the Browser or Viewer with snapping turned on, the
clip’s markers will snap to other clip or sequence markers in the Timeline.

Extending a Marker’s Duration
When you create a marker in Final Cut Pro, it is only associated with a particular frame; it
doesn’t have a duration. If you wish, you can extend the duration of a marker so that it
spans multiple frames. Markers with duration can be used to precisely define subclips in
a clip. You can also use them to mark an entire area of a clip or sequence with notes, such
as for color correction or audio mixing.
To extend a marker’s duration to the playhead’s location
1 Position the playhead ahead (to the right) of the marker.
2 Choose Mark > Markers > Extend, or press Option–Grave Accent (`).
An extended duration marker appears in the scrubber bar; it looks like a marker icon with
a bar that extends along the scrubber bar.
Extended marker

To extend a marker’s duration by entering a timecode value
1 Do one of the following to open the Edit Marker dialog:
• Hold down the Command key and double-click the marker.
This function is available in the Viewer, Canvas, and Timeline ruler only.
• Move the playhead to the marker and do one of the following:
• Choose Mark > Markers > Edit.
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• Press M.
• Click the Add Marker button.
• Press Command-Option-M to edit the marker to the left.
2 In the Edit Marker dialog, enter a duration value.

Enter a marker
duration here.

An extended duration marker appears in the scrubber bar.
To shorten a marker that has a duration
1 Position the playhead within the duration of the marker.
2 Choose Mark > Markers > Extend, or press Option–Grave Accent (`).
The marker is shortened to the location of the playhead.

Editing Markers into Sequences
You can edit markers into your sequence as if they were clips. However, a marker edited
directly from the Browser into a sequence becomes an independent clip, with no affiliation
to the clip from which it came. In most cases, you should avoid this, because it can make
media management more difficult later.
For more control over markers that you want to use for editing, use the Make Subclips
command to turn markers inside a clip into new subclips. For more information, see
“Creating Subclips.”

Exporting Markers with Your QuickTime Movies
Final Cut Pro allows you to export markers in a clip or a sequence as text tracks in
QuickTime movies that you create. These markers can be used by the QuickTime Player
in a variety of different ways, and they can be used for authoring in DVD Studio Pro, iDVD,
and other applications such as Soundtrack Pro.
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For information about exporting QuickTime movies with markers, see “Exporting QuickTime
Movies.” You can also refer to “Exporting Sequences for DVD.”

Exporting Marker Lists as Text
Marker data can be exported as tab-delimited text. The saved text file can be modified
with a spreadsheet application, printed, or reformatted for use in other software.
To export marker data as text
1 Select or make active the sequence or clip containing the markers you want to export.
2 Choose File > Export > Markers List as Text.
3 In the Save dialog that appears, enter a name and destination for the exported text file.
4 Optionally, use the Export pop-up menu in the Save dialog to choose one of the following
options: All Markers, Visible Markers, DVD Studio Pro Markers, Chapter Markers,
Compression Markers, or Scoring Markers.
5 Click Save.
The exported text file includes the following fields of marker information.
• Name: Name of selected clip or sequence
• Type: Clip marker or sequence marker
• Marker name: If no name was entered in the Edit Marker dialog, this will be the
automatically generated marker number.
• Comment: Includes any default tags for standard marker types including <CHAPTER>,
<COMPRESSION>, and <SCORING>.
• Start: Timecode value
• Duration: Single frame markers will have a duration of zero.
• Color: The marker color unless you renamed the color labels for a custom commenting
or note-taking system. For more information, see “Marker Color Labels.”
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Setting Edit Points for Clips and
Sequences

33

This chapter covers the following:
• About In and Out Points (p. 475)
• Setting Clip In and Out Points in the Viewer (p. 478)
• Setting Sequence In and Out Points in the Canvas or Timeline (p. 481)
• Navigating to In and Out Points (p. 491)
• Moving In and Out Points (p. 491)
• Clearing In and Out Points (p. 493)
To specify where a clip should be placed in your sequence, and to select a section of a
clip for editing, copying, pasting, or any other operation, you set In and Out points.

About In and Out Points
In and Out points allow you to define a specific portion of a clip or sequence for editing,
deletion, copying, pasting, and so on. A clip In point marks the first frame of a clip to be
edited into a sequence. A clip Out point specifies the last frame of the clip to be used.
The areas beyond the In and Out point boundaries are called handles. Handles are
additional media that you are not using for the edit, but which may be necessary when
extra media is required, such as when you add a transition to the head or tail of a clip in
your sequence. You set In and Out points for clips in the Viewer.
You can also set sequence In and Out points in the Canvas or Timeline. You can use these
as placement points to determine where clips are placed in the Timeline when you’re
doing three-point editing.
Note: If you set an In point later than an Out point, the Out point is automatically removed.
If you set an Out point earlier than an In point, the In point is automatically removed.

Learning About the Out Point Inclusive Rule
Before you begin to set In and Out points, it’s important to understand the “Out point
inclusive” rule that Final Cut Pro follows, so you can avoid an unexpected extra frame at
your Out point.
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Out point inclusive means that when you set an Out point at the position of the playhead,
the frame that the playhead is on is included in your edit. This rule means that whenever
you set In and Out points, the minimum duration set is always one frame long. For
example, if you place the playhead on a specific frame, and then set both an In point and
an Out point, the In point is placed at the beginning of the frame and the Out point is
placed at the end, resulting in a one-frame duration. If this rule did not exist, it would be
possible to create edits with zero duration, which would be useless.
To see exactly how the Out point inclusive rule works
1 Double-click a sequence in the Browser to open it in the Timeline.
2 Choose Mark > Mark In (or press I) to set an In point in the sequence.
3 Move the playhead several seconds later in the Timeline.
4 Press Command-Equal Sign (=) to zoom in closely to the location of the playhead.
You can see that the ruler is highlighted directly after the playhead. The duration of this
highlighted area is one frame.
5 Choose Mark > Mark Out (or press O) to set an Out point in the sequence.
The Out point is placed at the end of the duration of the frame. This is because the Out
point includes the duration of the frame on which the playhead is currently positioned.
In point
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The Out point includes
the duration of the frame.
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Things to Keep in Mind When Setting an Out Point
When you want to mark the duration of a clip in a sequence, you need to remember to
set the Out point one frame earlier than you might expect, or you may also include the
first frame of the next clip. This often happens when you have snapping turned on and
you snap to clip start and end points to set In and Out points.
The Out point includes
the first frame of the
adjacent clip.

For example, if a clip in the Timeline is a shot of a playground and the next clip is a shot
of a classroom, when you move the playhead to snap to the end of the playground clip,
you see the first frame of the classroom clip in the Canvas. If you then set an Out point
and copy and paste the playground clip, you see one classroom frame at the end of the
pasted content. You probably didn’t intend to include the first frame of the classroom
shot, but it was included because of the Out point inclusive rule.
To avoid accidentally selecting the first frame of the next clip
Do one of the following:

µ

Use the Mark > Mark Clip feature (described in “Setting In and Out Points to Match a Clip
or Gap”) to place In and Out points directly on the first and last frames of the clip.
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µ

Press the Back Arrow key once before setting the Out point, so that you set it on the last
frame of the clip you want to select. When you do this, the last frame of that clip is included
with the Out point.
The Out point ends at
the last frame of the clip.

µ

Make the Canvas active, then choose View > Show Overlays. Make sure you set an Out
point when you see the overlay that indicates the end of the clip, not the start of the next
clip.

Sequence Out point
overlay

Clip Out point overlay

Setting Clip In and Out Points in the Viewer
When you set In and Out points for a clip in the Viewer, only the frames from the In point
to the Out point will be edited into your sequence. If you haven’t explicitly set an In or
Out point, Final Cut Pro uses the Media Start and the Media End points, respectively.
To set an In or Out point for a clip in the Viewer
1 Double-click the clip to open it in the Viewer.
2 Move the playhead to the location in the clip where you want to place the In or Out point.
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3 Do one of the following:
• Choose Mark > Mark In, or choose Mark > Mark Out (or press I to set an In point or
press O to set an Out point).
• Control-click in the scrubber bar, then choose Mark In or Mark Out from the shortcut
menu.

• Click the Mark In or Mark Out button.

Mark Out button (O)
Mark In button (I)

For many editors, it’s much more intuitive to set the start (In) and end (Out) points of a
clip while the clip is actually playing. This way you can set the In or Out point immediately
when you hear or see the frame you want. With Final Cut Pro, this is easy to do.
To set an In or Out point while playing a clip
1 Position the playhead at the beginning of the clip.
2 Press the Space bar or click the Play button to start playing a clip in the Viewer.
3 Do one of the following:
• Press I once to set an In point or press O once to set an Out point.
• Hold down the I or O key.
The In or Out point is set at the location of the playhead when you release the key.
• Click the Mark In or Mark Out button once.
• Position the pointer over the Mark In or Mark Out button, then hold down the mouse
button.
The In or Out point is set at the location of the playhead when you release the button.
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Specifying an Edit Point Using Timecode
After setting an In point, if you want a clip to have a specific duration, you can quickly
define an Out point relative to your In point.
To set an In or Out point for a clip in the Browser using timecode
1 Select the clip in the Browser.
2 Click the In or Out point column of the clip in the Browser, then enter a new timecode
number.
Tip: You can also make relative adjustments by adding or subtracting timecode from an
existing In or Out point. For example, you can make a clip’s Out point 1 second earlier by
clicking the clip’s Out point field in the Browser, entering “–1:00” and then pressing Enter.
To set an Out point by changing the duration of a clip
1 Double-click the clip to open it in the Viewer.
2 Use one of the methods in the previous task to set an In point.
Note: If no In point is set, the Out point is set relative to the very beginning (Media Start)
of the clip.
3 Select the Timecode Duration field and enter the duration you want.
Final Cut Pro sets the location of the Out point by adding the duration you entered to
the timecode value of the In point.

Setting In and Out Points to Include a Whole Clip
If you decide that you want to set In and Out points at the very beginning and end of
your clip (the default), it’s easy to do.
To set In and Out points at the clip Media Start and Media End (the beginning and end
of the clip)
1 Open a clip in the Viewer.
2 Do one of the following:
• Choose Mark > Mark Clip (or press X).
• Click the Mark Clip button.

Mark Clip button
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Reviewing Your Edit Points
When you’ve set the In and Out points you think you want to use, check your edit points
to make sure that you’ve included all the frames you need for the clip you’re editing.
To view your clip from its In point to its Out point
Do one of the following:

µ
µ

Choose Mark > Play > In to Out, or press Shift-Backslash (\).
Click the Play In to Out button.

To view your clip from the position of the playhead to the clip’s Out point
1 Position the playhead where you want to start viewing your clip.
2 Choose Mark > Play > To Out (or press Shift-P).
To get a quick sense of what material is around a specific point in your clip, you can use
the Play Around Current Frame option. This plays a section of your clip from before the
current frame (based on a pre-roll setting) through the amount of time specified by the
post-roll setting. (The preview pre-roll and post-roll settings are in the General tab of the
User Preferences window. To change these settings, see “Choosing Settings and
Preferences.”)
To view your clip around the position of the playhead
1 Position the playhead where you want to view your clip.
2 Do one of the following:
• Choose Mark > Play > Around, or press Backslash (\).
• Click the Play Around Current Frame button.

Setting Sequence In and Out Points in the Canvas or Timeline
Once you’ve set In and Out points for a clip in the Viewer, you need to specify an In or
Out point in your sequence before you can complete a three-point edit. (As mentioned
earlier, for faster editing, you can simply drag a clip to the Timeline without setting any
In or Out points.)
Setting In and Out points for a sequence in the Timeline is similar to setting In and Out
points for a clip in the Viewer. You can set In and Out points while the sequence is playing
or when it’s stopped. Sometimes it’s easier to set In and Out points while your program
is playing, so you can set an edit point immediately when you hear or see the frame you
want.
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You have several options when setting sequence In and Out points. Each choice has
certain ramifications, so make sure you understand the outcome when setting your In
and Out points.
• Setting no In or Out points: When no edit points are set, the playhead position is
considered the In point. The clip is placed at the playhead position in the Timeline.
• Setting only an In point: When an In point is set, that point determines where the source
clip’s In point is placed in your sequence. The sequence Out point is calculated based
on the Out point of the source clip.
• Setting only an Out point: When an Out point is set, that point determines where the
source clip’s Out point is placed in your sequence. The In point is determined by one
of the following:
• Sequence playhead: If the position of the playhead is before the sequence Out point,
the playhead is considered to be the sequence In point of the edit.
• Clip In point: If the sequence playhead is after the sequence Out point, the sequence
In point is determined by the source clip In point.
• Sequence start: If the position of the playhead is after the sequence Out point, and
neither the source clip nor the sequence has In points, the start of the sequence
determines the sequence In point of the edit.
• Setting both In and Out points: If both points are set in the sequence, the edit is restricted
to the duration between the sequence In and Out points, regardless of the duration
set in the source clip.
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When No Sequence In or Out Points Are Set
If you don’t set any In or Out points in the Canvas or Timeline, Final Cut Pro uses the
playhead as an In point to determine the outcome of your edit.
The position of the playhead
determines the In point if you
haven’t set any edit points
in the Canvas or Timeline.

The new clip starts
where the playhead
was prior to the edit.
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After the edit, the
playhead moves to
the end of the clip.
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When You Set One Sequence In or Out Point
If you set only one In or Out point, that point determines where the clip being edited
into your sequence will start or end:
• If you set a sequence In point: The In point of the source clip is placed at the sequence
In point, and the clip extends from the In point to the right for the duration of the
source clip.
In point

The new clip begins at
the In point that you set.
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• If you set a sequence Out point: The Out point of the source clip is placed at the sequence
Out point, and the clip is “backtimed” for the duration of the source clip, extending
from the Out point to the left.
Out point

The new clip ends at the
Out point that you set.
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When You Set Both Sequence In and Out Points
Setting both sequence In and Out points limits the duration of your edit to the duration
between these two points. How the source clip lines up within this duration depends on
which clip In and Out points have been set in the Viewer:
• If you set an In point for the source clip: The clip’s In point lines up with the In point in
your sequence, and the clip extends to the right for the duration defined by the
sequence In and Out points.
In and Out points are
set in the Timeline.

The new clip’s duration
is defined by the
sequence In and Out
points you set.

• If you set only an Out point for the source clip: The clip’s Out point lines up with the Out
point in the sequence, and the edit will be backtimed for the duration defined by the
sequence In and Out points.
• If you set both In and Out points for the source clip: The sequence In and Out points take
precedence. Final Cut Pro lines up the source clip’s In point with the sequence In point
in the Timeline, and the source clip’s Out point is ignored.
Note: If your source clip is not as long as the duration between the sequence In and Out
points, then you’ll get an “Insufficient content for edit” message.
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Setting Sequence In and Out Points
You can set sequence In and Out points in the Canvas or Timeline. The In and Out points
in the Canvas are the same as the ones in the Timeline—they refer to the same timecode
values and affect the same part of your sequence. If you set In and Out points in the
Timeline, they also appear in the Canvas, and vice versa.
To set In and Out points in the Canvas or Timeline
1 Make the Canvas or the Timeline active by doing one of the following:
• Click in the appropriate window.
• Press Command-2 to make the Canvas active.
• Press Command-3 to make the Timeline active.
• Press Q to switch between the Viewer and the Canvas.
2 Move the playhead to the point in your sequence where you want to place the In or Out
point.
3 Do one of the following:
• Choose Mark > Mark In or Mark > Mark out (or press I to set an In point or press O to
set an Out point).
• Control-click in the scrubber bar of the Canvas (or the ruler of the Timeline), then choose
Mark In or Mark Out from the shortcut menu.

• Click the Mark In or Mark Out button.

Mark Out button
Mark In button
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Setting In and Out Points to Match a Clip or Gap
When you want to replace one clip with another using exactly the same location and
duration in the Timeline, you can set both In and Out points simultaneously. This also
comes in handy if you want to quickly set In and Out points to fit the boundaries of a
gap in your sequence.
To set In and Out points at the beginning and end of a clip or gap in the Timeline
1 Place the Timeline playhead over a clip (or gap) in your sequence.

Move the playhead over
the clip.

Note: Make sure the clip items beneath the playhead are on the destination tracks. For
more information, see “Specifying Destination Tracks in the Timeline.”
2 Select the Auto Select control for the track (or tracks) containing the clip or gap you want
to mark.
Auto Select is enabled
for these three tracks.
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Note: If the clip items have different durations in the video and audio tracks that have
Auto-Select turned on, video clip items take precedence over audio clip items. Also, clip
items take precedence over gaps. For more information about Auto Select controls, see
“Using Auto Select to Specify Tracks for Selections.”
3 Do one of the following to set In and Out points:
• Choose Mark > Mark Clip (or press X).
• Click the Mark Clip button in the Canvas.

Mark Clip button
in the Canvas

In and Out points are set at the boundaries of the clip or gap.
In and Out points are set
at the clip’s boundaries.

Setting In and Out Points Based on a Selection in the Timeline
You can use the Final Cut Pro selection tools to select a group of whole or partial clips in
the Timeline, and then use the duration of the selection to set In and Out points using
the Mark Selection command. For more information, see “Direct Methods for Selecting
Content in a Sequence.”
Note: If you do not have contiguous items selected in the Timeline, this command sets
your In and Out points using the selected clips farthest to the left and farthest to the right
as the outer boundaries.
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To set In and Out points based on the current selection in the Timeline
1 Select clip items in the Timeline.
You can select part of a clip, several clips, or parts of several clips using the Selection,
Group Selection, or Range Selection tools. For more information on how to use these
tools, see “Finding and Selecting Content in the Timeline.”
If you want to set only video or only audio In and Out points, select only video or audio
items in the Timeline. You can also select a combination of video and audio clip items to
set split In and Out points. For more information, see “Split Edits.”

Select the desired clips
or sections.

Note: Make sure the selected clip items are on the destination tracks. For more information,
see “Specifying Destination Tracks in the Timeline.”
2 Choose Mark > Mark Selection (or press Shift-A).
In and Out points are
set for your selection.

Both In and Out points will be set using the boundaries of your selection. If the durations
of the audio and video items you select are different, you’ll see split In and Out markers.
For more information, see “Split Edits.”
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Navigating to In and Out Points
Often, you’ll want to position the playhead at the beginning or end of a specific clip,
marker, or edit point in your sequence, in preparation for the next edit. Final Cut Pro
makes it easy to jump quickly between all of the edit points in your sequence.
To move the playhead to the next edit point in your sequence
Do one of the following:

µ
µ
µ

Choose Mark > Next > Edit (or press Shift-E).
In the Canvas, click the Go to Next Edit button.
Press the Down Arrow key.
To move the playhead to the previous edit point in your sequence
Do one of the following:

µ
µ
µ

Choose Mark > Previous > Edit (or press Option-E).
In the Canvas, click the Go to Previous Edit button.
Press the Up Arrow key.
You can move the playhead directly to an In or Out point. This can be useful if you need
to make a slight adjustment to your In or Out point. Move the playhead to the edit point,
then move it by the necessary frames and set the In or Out point again at the correct
location.

µ

To move the playhead to the current In point in your sequence
Choose Mark > Go To > In Point (or press Shift-I).
To move the playhead to the current Out point in your sequence
Do one of the following:

µ
µ

Shift-click the Mark Out button in the Canvas.
Choose Mark > Go To > Out Point (or press Shift-O).

Moving In and Out Points
You can always change clip In and Out points by simply setting new ones. Here are a few
other options for changing In and Out points.
To change the location of the In or Out point
Do one of the following:

µ

Drag In or Out point markers to the left or right.
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µ

To change the Out point, enter a new timecode number in the Timecode Duration field.
Final Cut Pro calculates the new location of the Out point by adding the duration you
entered to the timecode value of the In point. If no In point is set, the Out point will be
set relative to the beginning (Media Start) of the clip.

Timecode Duration field

µ

Click the clip in the Browser, then select either the In, Out, or Duration timecode numbers
and enter new ones.

In the Browser, enter
the relevant timecode
number.

You can also change the location of both In and Out points at the same time. The duration
of the marked media doesn’t change, just the location of the In and Out points. This is
commonly referred to as slipping an edit. You can slip edit points in both the Viewer and
the Canvas or Timeline.
To slip both the In and Out points together
Do one of the following:

µ
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Hold down the Shift key, then drag the In or Out point left or right in the scrubber bar.
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Note: The pointer must be directly over the In or Out point, or the slip edit won’t work
and you will simply move the playhead.
Hold down the Shift
key, then drag the
In point or Out point
to a new location.

µ

Select the Slip tool in the Tool palette, then drag a sequence clip in the Timeline to the
left or right.

Slip tool

For more information, see “Slipping Clips in the Timeline.”

Clearing In and Out Points
If you want to eliminate one or both edit points to start over again, there are several ways
you can do so.
To clear an In point
Do one of the following:

µ
µ
µ
µ

Press Option-I.
Control-click in the scrubber bar, then choose Clear In from the shortcut menu.
Option-click the Mark In button.
In the Viewer or Canvas, drag an In point vertically off the scrubber bar, either up or down.
To clear an Out point
Do one of the following:

µ
µ
µ
µ

Press Option-O.
Control-click in the scrubber bar, then choose Clear Out from the shortcut menu.
Option-click the Mark Out button.
In the Viewer or Canvas, drag an Out point vertically off the scrubber bar, either up or
down.
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To clear both In and Out points at the same time
Do one of the following:

µ
µ
µ

Press Option-X.
Control-click in the scrubber bar, then choose Clear In and Out from the shortcut menu.
Option-click the Mark Clip button.
Note: If you set an In point later than an Out point, the Out point is automatically removed.
If you set an Out point earlier than an In point, the In point is automatically removed.
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Working with Tracks in the
Timeline

34

This chapter covers the following:
• Adding and Deleting Tracks (p. 495)
• Specifying Destination Tracks in the Timeline (p. 499)
• Locking Tracks to Prevent Edits or Changes (p. 504)
• Disabling Tracks to Hide Content During Playback (p. 505)
• Customizing Track Display in the Timeline (p. 507)
In the Timeline, you view your clips horizontally (in chronological order) and also vertically
(stacked in multiple tracks). You can add, delete, and lock tracks, and you can customize
how tracks are displayed.
Note: For information about navigating and zooming within the Timeline, see “Timeline
Basics.”

Adding and Deleting Tracks
In Final Cut Pro, sequences can have up to 99 video and 99 audio tracks. Tracks contain
clip items, which are the individual media items that make up a clip. When you edit, you
arrange individual or linked clip items in a sequence.

Adding Tracks
You can add tracks to a sequence at any time. You can add tracks one at a time, or you
can add multiple video and audio tracks at once.
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To quickly add a track to a sequence
Do one of the following:

µ

Control-click anywhere in the area above the top video track or below the bottom audio
track, then choose Add Track from the shortcut menu.

Control-click in the area
above the top video
track, then choose
Add Track.

µ

Drag a clip to the unused area above the top video track or below the bottom audio
track. Final Cut Pro adds new tracks to accommodate any audio or video this new clip
contains.

Drag a clip to the unused
area above the top
video track.

To add multiple tracks to a sequence
1 Choose Sequence > Insert Tracks.
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2 In the Insert Tracks dialog, select your options, then click OK.
Enter the number
of tracks to add.

Specify where you want
to add the tracks.

Select the types of tracks
you want to add.

• Track type: Select the appropriate checkbox to add audio and/or video tracks.
• Number of tracks: Enter the number of tracks for either video or audio. A sequence can
have a total of 99 video tracks and 99 audio tracks.
• Specify a location: Choose where you want the tracks located:
• Before Base Track: This inserts the new tracks before the first track in the Timeline.
Existing tracks and their clips will be moved up. For example, if one video track is
added before the base track of a sequence with two existing video tracks, V1 and
V2, these tracks along with their clips will be moved to V2 and V3. Track V1 is the
new, empty track.
• After Last Track: This inserts the new tracks after the last track in the Timeline. If your
last track is V2, and you add three video tracks, tracks V3, V4, and V5 are created.
When you add a single video track before a track that contains clip items, those video
clip items move up one track, but any audio items linked to them do not. This results in
an offset between the track number of that clip’s video and the track numbers of that
clip’s audio, but the clip’s audio and video are still linked and in sync.

When you add a single
video track, other video
tracks move up...

...but the audio tracks
do not.
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Deleting Tracks
You can delete tracks from a sequence at any time. You can delete tracks one at a time,
or you can delete multiple video and audio tracks at once. If you delete tracks that contain
linked clip items, only the items on the deleted track are deleted; the linked items remain.
For example, if you delete a video track, video clip items on that track are deleted, but
the linked audio clip items remain in their tracks.
Note: If you delete the wrong track, you can use the Undo command to restore it.

µ

To quickly delete a single track in a sequence
Control-click anywhere in the track header (the area to the left of each track), then choose
Delete Track from the shortcut menu.
You can also delete several empty tracks from a sequence in the Timeline.

To delete multiple empty tracks from a sequence
1 Choose Sequence > Delete Tracks.
2 Select your options for deleting tracks, then click OK.

Options appear only after
you select the type of
track you want to delete.

• Track type: Select the appropriate checkbox to delete audio and/or video tracks.
• Tracks to delete: Specify the type of track you want to delete.
• All Empty Tracks: Select this option to delete all tracks in your sequence in the Timeline
that don’t contain clip items.
• All Empty Tracks at End of Sequence: Select this option to delete all empty video tracks
above and all empty audio tracks below the outermost tracks that contain clip items.
After tracks are deleted, all remaining tracks in the sequence are renumbered.
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Specifying Destination Tracks in the Timeline
When you edit a source clip into a sequence, you need to specify the sequence tracks
where your source clip items are placed. You use the Source and Destination controls in
the Timeline to specify which sequence tracks receive clip items from the source clip.
Source and Destination controls are most often used when you perform three-point edits,
but they can also affect some aspects of drag-to-Timeline editing. For more information,
see “Three-Point Editing.”

Understanding Source and Destination Controls
The number of available Source controls corresponds to the number of clip items in the
source clip currently open in the Viewer. For example, a typical clip has one video clip
item and two audio clip items. In this case, one video and two audio Source controls
appear in the Timeline. If, instead, you open a clip in the Viewer that has one video item
and four audio items, one video and four audio Source controls appear in the Timeline.
Destination control
Source control

A maximum of one video and
twenty-four audio Source controls
appear in the Timeline, depending
on the number of clip items
currently open in the Viewer.

Timeline patch panel

Every track in your sequence has a Destination control. By assigning source clip items to
destination tracks using these controls, you determine which items from your source clip
go into which tracks when edits are performed.
Important: If you copy and paste clips, the paste destination is determined by Auto Select
controls, not Source and Destination controls. For more information, see “Using Auto
Select to Specify Tracks for Selections.”

Setting Destination Tracks
To control which sequence track a source clip item is placed in, you connect the Source
control to the corresponding Destination control. There are several different ways to do
this.
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Important: While editing, make sure that Source controls are connected to the Destination
controls for the correct tracks. If you don’t, individual video or audio items in your source
clip will end up in the wrong tracks in the Timeline.

V1, A1, and A2
are selected as
destination tracks.

To assign a source clip item to a destination track in the Timeline
Do one of the following:

µ

Control-click a Source control, then choose a new destination track from the shortcut
menu.

µ
µ
µ

Control-click a Destination control, then select a Source control to assign to it.
Drag a Source control so that it connects to a Destination control.
Click a Destination control; the nearest Source control above is assigned to it.

µ

To assign the v1 Source control to a destination video track
Press F6 and the number of the video track you want to assign as the destination track
(this works for tracks 1 through 9).

µ

To assign the a1 Source control to a destination audio track
Press F7 and the number of the audio track you want to assign as the destination track
(this works for tracks 1 through 9).

µ

To assign the a2 Source control to a destination audio track
Press F8 and the number of the audio track you want to assign as the destination track
(this works for tracks 1 through 9).
For example, to assign the a2 source clip item to sequence track A4, press F8 and then
press 4.

Changing Source and Destination Control Connections
You can change source and destination track assignments in the Timeline in several ways.
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To change Source and Destination control connections
Do one of the following:

µ
µ
µ

Control-click a Source control, then choose a track from the shortcut menu.
Control-click a Destination control, then choose a Source control from the shortcut menu.
Click a Destination control.
The first Source control above that track moves to that track.

µ

Option-click a Destination control.
The first Source control beneath that track moves to that track.

µ

Drag one Source control on top of another to switch their connections.
For example, if Source control a1 is connected to Destination control A1, and Source
control a2 is connected to Destination control A2, when you drag the a2 Source control
onto the a1 Source control, the connections are reversed (a1 is connected to A2, and a2
is connected to A1).

Disconnecting Source and Destination Controls
You can prevent specific video or audio source clip items from being edited into your
sequence by disconnecting Source and Destination controls. For example, if you disconnect
the video Source control prior to making an edit, only the audio source clip items are
edited into the Timeline.
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For example, if you want to edit the video clip item in the Viewer into your sequence,
but you don’t want the audio clip item, you can simply disconnect all of the audio Source
controls in the Timeline, leaving only the video Source and Destination controls connected.
Performing an overwrite edit adds the video portion of the selected clip to your sequence,
ignoring the source clip audio.
The v1 Source control
is connected to the V1
Destination control.

The audio Source controls
are disconnected from the
audio Destination controls.

Disconnected Source controls remain disconnected even when you open a new clip in
the Viewer. This is true even if the clip has a different number of video and audio clip
items than the previously opened clip.
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To disconnect Source and Destination controls in the Timeline
Do one of the following:

µ

Click the Source or Destination control to break the track assignment.
Connected Source
and Destination controls

Disconnected Source
and Destination controls

µ
µ
µ

Press Shift-F6 to deselect the current video destination track.
Press Shift-F7 to deselect the current audio channel 1 destination track.
Press Shift-F8 to deselect the current audio channel 2 destination track.
Note: You can also lock any track you don’t want source clip items edited into by clicking
that track’s Lock Track control, located in the track header. If a track is locked, it is ignored
as a destination track. (For more information see “Locking Tracks to Prevent Edits or
Changes.”)

Resetting Destination Tracks to the Default State
You can reset Source or Destination controls to their default state at any time. All available
Source controls are reconnected to the accompanying Destination controls. For example,
the a1 Source control is reconnected to the A1 Destination control, the a2 Source control
is reconnected to the A2 Destination control, and so on.

µ

To reset the destination track assignments to their default state
Control-click in the Timeline patch panel, then choose Reset Panel from the shortcut
menu.
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Exceptions to Normal Use of Source and Destination Controls
There are several exceptions to the way you normally use Source and Destination controls
to specify destination tracks for source clip items.
When Dragging Clips Directly to the Timeline
If you drag a clip from the Browser or Viewer directly into a specific track in the Timeline,
it is placed on that track even if that track is not a destination track. However, the currently
selected destination tracks modify this operation in two ways:
• If the video Source and Destination controls are disconnected and you drag a clip to an
audio track: No video is edited into your sequence, and vice versa.
• If you connect nonadjacent Source controls: The source clip items are edited into the
sequence using the track separation defined by the Source controls. For example, if A1
and A3 are the current audio destination tracks, a clip that you drag to your sequence
will always have one empty track between the two source audio clip items, and will
keep that one-track offset no matter which audio tracks you drag the items into.
When Using the Superimpose Edit
If you edit a clip into your sequence using a superimpose edit, it is edited into the track
above the currently selected destination track. Any clips that are already there are moved
up to a new track, creating one or more additional tracks if necessary. (Superimpose edits
are explained in “Three-Point Editing.”)
When Recording with the Voice Over Tool
The Voice Over tool records audio to the track connected to Source control a2. For more
information, see “Using the Voice Over Tool.”

Locking Tracks to Prevent Edits or Changes
If you want to set one or more tracks as temporarily “off limits” to edits or changes, you
can lock them using the Lock Track control in each track’s header. While a locked track
can be specified as a destination track, no media will be edited into a locked track. Locked
tracks appear cross-hatched in the Timeline.

µ

To lock a single track
Click the Lock Track control to the left of the track.
The icon changes to a closed lock, and a crosshatch pattern is displayed on the track. No
edits will be placed on the locked track until you unlock it.

µ
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To lock a video track using keyboard shortcuts
Press F4 and the number of the track you want to lock (for tracks 1 through 9).
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µ

To lock an audio track using keyboard shortcuts
Press F5 and the number of the track you want to lock (for tracks 1 through 9).

The track is cross-hatched
to indicate it’s locked.

The control changes
to the locked position.
Click the control again
to unlock the track.

µ

To lock all video tracks in a sequence
Press Shift-F4.

µ

To lock all audio tracks in a sequence
Press Shift-F5.

µ

To lock all other audio or video tracks except the selected track
Press Option while clicking the Lock Track control for the track you don’t want locked.

About Working with Clips on Locked Tracks
Clip items on locked tracks cannot be moved, edited, deleted, or modified in any way.
However, they can still be selected, along with any linked items in other tracks.
The Editing tab of the User Preferences window has an option called “Pen tools can edit
locked item overlays” (to view this window, choose Final Cut Pro > User Preferences). If
this option is selected, you can use the Pen, Delete Point, and Smooth Point tools to
modify the audio levels or opacity of clip items even though they’re on locked tracks.
Clip overlays only control audio levels and video opacity. No other clip parameters can
be changed when a track is locked.

Disabling Tracks to Hide Content During Playback
You can disable entire tracks to hide their contents during playback. The clips on a disabled
track are not visible or audible when you play it, nor will they render or be output to tape.
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You can still edit items on disabled tracks; they just won’t appear in the Canvas during
playback. A track can be enabled or disabled at any time. This does not permanently
affect either your sequence or the clips edited into it.
There are several reasons you may want to disable a track:
• A track contains audio that you want to temporarily turn off, while you focus on other
parts of your audio mix.
• A track contains an alternate edit of clips in your sequence that you haven’t yet
committed to using. By editing this alternate sequence into a spare video track, you
can enable and disable it as necessary, to quickly switch between two different
arrangements of clips.
• A track contains effects that you want to temporarily disable, such as superimposed
subtitles. By disabling this track, you can avoid rendering the effects before playing
back your sequence, yet you can still keep them in the Timeline.
You can also enable a single track by disabling all of the other tracks in the sequence.

µ

To disable a track
Click the Track Visibility control of the track you want to disable.
Note: If your sequence has clip items that have been rendered, a dialog appears saying
that the render files will be deleted. If you don’t need the render files, click Continue. For
more information about rendering, see “Rendering and Video Processing Settings.”

The disabled track is
dimmed and will not
appear (or be heard)
when the sequence
is played back.

Click the Track Visibility
control to disable a track.

µ

To enable a single video or audio track while disabling all others
Press Option while clicking the Track Visibility control for that track.
All other video tracks or all other audio tracks except for the one you clicked are disabled.
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Customizing Track Display in the Timeline
You can modify the way tracks are displayed in the Timeline in several ways:
• Tracks in the Timeline can be resized, either individually or collectively. For more
information, see “Resizing Timeline Tracks.”
• Clip items on video tracks can be displayed with name only, name and thumbnail frame,
or filmstrip. All video tracks in the sequence share the same display settings. If you
display the Timeline in Reduced track size view, you can’t see thumbnails. For more
information, see “Timeline Basics.”
• Audio tracks can be displayed in the Timeline with or without waveforms, and audio
tracks can be labeled as pairs (A1a & A1b, A2a & A2b) or as individually numbered tracks
(A1, A2, A3).
• You can show or hide the keyframe graph area of each track, adding additional space
below each video and audio track in which to view and edit effect parameters that are
applied to your clips. For more information on using the keyframe graph area in the
Timeline, see “Adjusting Parameters for Keyframed Effects.”
For more information about customizing Timeline display options, see “Timeline Basics.”

Resizing Timeline Tracks
You can change the size of tracks in the Timeline, either by dragging a track’s boundary
in the Timeline patch panel, or by using the Track Height control.
Resizing Tracks by Dragging
You can resize individual tracks directly in the Timeline.

µ

To resize a single video track in the Timeline
Drag the upper boundary of the track in the Timeline patch panel.
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µ

To resize a single audio track in the Timeline
Drag the lower boundary of the track in the Timeline patch panel.
Timeline patch panel

Drag a boundary
to resize a track.

µ

To resize all video or all audio tracks at once
Hold down the Option key, then drag a track boundary to resize it.
If you drag a video track boundary, all video tracks in the Timeline are resized by the same
amount. If you drag an audio track boundary, all audio tracks are resized by the same
amount.

µ

To resize both video and audio tracks at once
Hold down the Shift key, then drag any track boundary to resize it.
All tracks in the Timeline are resized by the same amount.
Resizing All Tracks Using the Track Height Control
When you use the Track Height control to resize tracks, you resize all tracks together. By
default, the Track Height control sets all tracks in the Timeline to the same size.
To resize all tracks using the Track Height control
Do one of the following:

µ

Control-click the Track Height control, then choose the track size you want from the
shortcut menu.
In a sequence that has individually customized track heights, all custom track heights are
resized to the new height.

µ
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Click the icon in the Track Height control that corresponds to the track size you want to
use.
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The selected track height is highlighted blue.

Track Height control

You can also preserve relative track sizes.

µ

To resize all tracks relative to their individual sizes
Hold down the Option key, then click the icon in the Track Height control that corresponds
to the track size you want to use.
Resizing All Tracks Using the Track Layout Pop-Up Menu
You can also use the Track Layout pop-up menu (to the right of the Track Height control)
to choose Reduced, Small, Medium, or Large track heights.

µ

To resize all tracks using the Track Layout pop-up menu
Click the disclosure triangle to the right of the Track Height control, then choose the track
size you want.

Saving Track Layouts
Once you’ve created a custom track layout for your sequence, you can save it for future
use. Saved custom track layouts appear in the Track Layout pop-up menu, and can be
applied to any sequence that’s open in the Timeline. Up to 40 custom track layouts can
appear in the menu at once.
To save a custom track layout
1 Arrange the track heights of your sequence as you want them.
2 Choose Save Track Layout from the Track Layout pop-up menu (located in the Timeline
to the right of the Track Height control).
3 In the Save dialog that appears, choose a location where you want to save the layout,
then click Save.
Note: Custom track layouts are saved by default to the following folder
location:/Users/username/Library/Preferences/Final Cut Pro User Data/Track Layouts/.
To restore a track layout from your hard disk
1 Choose Restore Track Layout from the Track Layout pop-up menu.
2 In the Open dialog that appears, navigate to the location where the track layout file is
located, select it, then click Open.
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Creating a Static Region in the Timeline
If you are working with more tracks than you can see on the screen at once, and you
spend a lot of time scrolling through multiple tracks in the Timeline, you may find it useful
to create a static region in the middle of the Timeline for tracks that you always want to
see. This region can contain video tracks, audio tracks, or both. Creating a static region
results in three total regions in the Timeline: a top, scrollable region for your excess video
tracks, a middle static region, and a bottom, scrollable region for your excess audio tracks.
You can’t scroll up or down in the static region, but it can be resized to accommodate
more or fewer tracks.
For example, if you’re working on the audio of a project with sync sound dialogue in
audio tracks 1 and 2, and multiple tracks of music, sound effects, and audio ambience in
the tracks below that, you can define a static region containing just tracks 1 and 2, leaving
the rest of your audio tracks in a lower, scrollable region. This way, your dialogue tracks
will always be visible. You can scroll up and down through your other audio tracks, editing
and making various adjustments while using the audio tracks in the static region as a
reference point.
To create a static region for video and audio tracks
1 Drag the upper thumb tab in the vertical scroll bar up to create a static area for as many
video tracks as you want to keep in the middle.
2 Drag the lower thumb tab in the vertical scroll bar down to create a static area for as
many audio tracks as you want to keep in the middle.

Drag the upper thumb
tab up to include video
tracks in the static area.
Slider
Drag the lower thumb
tab down to include
audio tracks in the
static area.

Static area

When you have a static region in the Timeline, there are two dividers: one between the
top scrollable region and the static region, and one between the static region and the
bottom scrollable region. Each divider has its own thumb tab.
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µ

µ

To resize a static region in the Timeline
Drag the dividers or thumb tabs to include tracks in (or exclude tracks from) the static
region. As the static region gets larger or smaller, the size of the other regions is adjusted
accordingly.
To move the static region up or down in the Timeline
Drag the center slider in the static region’s scroll bar to move the entire region,
automatically resizing the scrollable regions above and below the static region.

Drag the center slider to
move the static region.

µ

To eliminate video tracks from the static region
Drag the upper thumb tab of the static region down so that it overlaps the lower one,
then release the mouse button to eliminate video tracks from the static region.

µ

To eliminate audio tracks from the static region
Drag the lower thumb tab of the static region up so that it overlaps the upper one, then
release the mouse button to eliminate audio tracks from the static region.

To eliminate audio tracks,
drag this thumb tab up.
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Drag-to-Timeline Editing

35

This chapter covers the following:
• Overview of the Drag-to-Timeline Editing Process (p. 513)
• Dragging Clips to the Timeline (p. 514)
• Doing Simple Insert and Overwrite Edits in the Timeline (p. 515)
• Automatically Adding Tracks to Your Sequence While Dragging (p. 517)
Drag-to-Timeline editing is a quick, intuitive way to move clips from the Browser or Viewer
into your sequence.

Overview of the Drag-to-Timeline Editing Process
Drag-to-Timeline editing is as simple as dragging a clip from the Browser or Viewer and
placing it where you want in the Timeline. Sequence In and Out points, as well as Source
and Destination controls, are generally disregarded when you drag clips to your sequence,
making it faster and easier to place clips where you want in the Timeline.
Note: There are some situations in which Source and Destination controls affect which
clip items are dragged to the Timeline. See “Exceptions to Normal Use of Source and
Destination Controls” for details.
Drag-to-Timeline editing is most useful during the early rough editing phase, when you
are adding clips more freely to the Timeline. However, once you have an established
structure to your sequence, dragging clips to the Timeline may lack the precision you
need to fine-tune your edits.
In drag-to-Timeline editing, only two steps are involved.
Stage 1: Set clip In and Out points in the Viewer
Here you specify which part of a clip you want to place in your sequence. You do this by
opening the clip in the Viewer and setting the In and Out points (where the clip should
start and end when placed in a sequence).

513

If you want to place a whole clip or group of clips in the Timeline, you can skip this step.
For information on arranging a group of clips, see “Preparing a Sequence Order in the
Browser.”
Stage 2: Drag the clip to the Timeline
Drag one or more clips from the Browser or the Viewer to the Timeline.

Dragging Clips to the Timeline
An easy way to edit clips into your sequence is to drag them from the Browser or Viewer
to an open sequence in the Timeline.
To add part of a clip to a sequence
1 Double-click a clip in the Browser to open it in the Viewer.
2 Specify In and Out points for the clip.
For more information, see “Setting Clip In and Out Points in the Viewer.”
3 Drag the clip from the Viewer to your sequence in the Timeline.
To add an entire clip to a sequence
1 Double-click a clip in the Browser to open it in the Viewer.
2 Choose Mark > Clear In and Out (or press Option-X) to delete the clip’s In and Out points.
3 Drag the clip from the Browser to your sequence in the Timeline.
If you’ve arranged clips in the Browser according to the order you want them to appear
in your sequence (creating a storyboard), you can drag all of them to the Timeline to
quickly create a rough edit. If you want, you can also specify In and Out points for each
clip in your storyboard, and then drag them to your sequence.
To edit multiple clips into a sequence at the same time
1 Select the group of clips you want to edit into your sequence by dragging a box around
them in the Browser.

Drag to select the
clips you want to edit
into your sequence.
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For more information, see “Preparing a Sequence Order in the Browser.”
2 Drag the group of clips directly into your sequence in the Timeline.
The clips appear in your sequence according to how they’re organized in the Browser.

Doing Simple Insert and Overwrite Edits in the Timeline
When you drag clips to the Timeline, you can perform insert or overwrite edits. (For more
information about insert and overwrite edits, see “Performing the Different Types of
Edits.”) Each track in the Timeline is divided into two areas by a thin gray line. The region
of the track you drag the clip into determines whether an insert or overwrite edit is
performed.
Insert edit area
(upper third)

Overwrite edit area
(lower two-thirds)

As you move the pointer from one region of the track to the other, it changes to indicate
the type of edit—a right arrow for an insert edit and a down arrow for an overwrite edit.
Note: If you are dragging clips from the Browser, the corresponding edit button is also
highlighted in the Canvas window.
To drag a clip from the Video tab in the Viewer, click anywhere in the video picture in
the Viewer and drag. To drag a clip from the Audio tab in the Viewer, click the drag hand
and then drag.

Drag hand

Note: To drag a multiclip from the Viewer to the Canvas or Timeline, you need to hold
down the Option key while you drag in the Viewer.
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As you drag your clip into the Timeline, a two-up display appears in the Canvas to show
you the sequence In and Out points for the edit you’re performing. What appears in this
display depends on the kind of edit.
• If you’re performing an overwrite edit: The two-up display shows the frame before the
clip being edited in (on the left) and the frame immediately after it (on the right). Clip
names appear at the top of the display, and each frame’s source timecode number
appears at the bottom.
The last sequence
frame before your
incoming clip

The first sequence
frame after your
incoming clip

• If you’re performing an insert edit: The two-up display shows two adjacent frames,
because the source clip you are inserting splits the underlying clip at the point where
you insert it.
• If you’re editing a clip into an empty area of the Timeline: Both of the frames in the two-up
display are black, no matter what kind of edit you’re performing.
Note: If the Caps Lock key is engaged, the two-up display is disabled.

µ

To do an insert edit
Drag the clip to the upper third of a track in the Timeline.

Drag a clip to the upper
third of a track to do
an insert edit.
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µ

To do an overwrite edit
Drag the clip to the lower two-thirds of a track in the Timeline.

Drag a clip to the lower
two-thirds of a track to
do an overwrite edit.

Note: If you drag a sequence clip to another location within the sequence, an overwrite
edit is performed by default. To perform an insert edit instead, hold down the Option key
after you begin dragging the clip.

Automatically Adding Tracks to Your Sequence While Dragging
You can drag a source clip to the unused space above or below the current tracks to
create a new track for that clip. If you drag your clip above the tracks already in the
Timeline, you’ll create a new video track. If you drag your clips below the tracks in the
Timeline, you’ll create a new audio track.
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Clips with both audio and video clip items create both kinds of tracks by default, unless
either the video or audio Source and Destination controls are disconnected.
Dragging a clip to the
unused space above
the highest track creates
a new video track.

After edit

When you drag a source clip to a track in the Timeline, all the clip’s items are linked. The
track you drag a clip to always receives a clip item, regardless of whether its Source and
Destination controls are connected. However, additional clip items are only placed on
tracks whose Source and Destination controls are connected.
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For example, suppose you have a clip that contains a video clip item and two audio clip
items. If you drag that clip to a video track in the Timeline, the video clip item is placed
in the video track, even if the Source and Destination controls for the video track are
disconnected. Each audio clip item is placed in the corresponding Timeline audio tracks,
but only if the Source and Destination controls of those audio tracks are connected.
Video Source and
Destination controls
are disconnected.

Dragging a clip to
this track edits in
both audio and video.

Audio Source and
Destination controls
are connected.

If you connect nonadjacent Source and Destination controls, the source clip items are
edited into the sequence using the track separation defined by the Source controls. For
example, if audio tracks A1 and A3 are the current audio destination tracks, a clip that
you drag to the Timeline will always have one empty track between the two source audio
clip items, and will keep that one-track offset no matter which audio tracks you place the
items into.
For more information about Source and Destination controls, see “Exceptions to Normal
Use of Source and Destination Controls.”
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Three-Point Editing

36

This chapter covers the following:
• Understanding Three-Point Editing (p. 521)
• About Edit Types in the Edit Overlay (p. 524)
• Performing the Different Types of Edits (p. 525)
• Three-Point Editing Examples (p. 542)
When you’re adding content to a sequence with three-point editing, you only need to
set three edit points to tell Final Cut Pro what content should go where in the Timeline.

Understanding Three-Point Editing
Unlike drag-to-Timeline editing, three-point editing allows you to use both source clip
and sequence In and Out points to specify the duration of a source clip and where it
should be placed in a sequence. In most cases, only three edit points are necessary, and
the fourth edit point is inferred automatically by Final Cut Pro.

Overview of the Three-Point Editing Process
To edit content into a sequence using three-point editing, you first set edit points in your
source clip and sequence, and then you perform the edit. Three-point editing gets its
name from the fact that Final Cut Pro needs no more than three In and Out points (in the
Viewer and in the Timeline or Canvas) to determine what part of the source clip to place
in a sequence. The result of the edit is dependent on which three points are set in the
clip and in the sequence.
Note: If you set fewer than three edit points, Final Cut Pro infers In or Out points using
the playhead in the sequence and the Media Start or End times in the source clip.
Basic three-point editing follows several main steps.
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Stage 1: Setting Clip In and Out Points in the Viewer
Specify which part of a source clip you want to place in your sequence. You do this by
opening it in the Viewer and setting the In and Out points (where the clip should start
and end). If you only set an In point, the Out point will be determined by the sequence
In and Out points or the Media End time of the clip.
Stage 2: Setting Sequence In and Out Points in the Timeline or Canvas
Specify where you want the clip to appear in your sequence by setting In and Out points
in the Canvas or Timeline. If the sequence has both In and Out points set, these determine
the edit duration, regardless of the duration set in the source clip. If no In or Out points
are set, the playhead is assumed to be the In point of the edit.
For information about setting In and Out points, see the sections that follow and “Setting
Edit Points for Clips and Sequences.”
Stage 3: Specifying Destination Tracks
Choose the tracks in the Timeline where the video and audio items from your source clip
should appear.
Stage 4: Adding the Clip to the Timeline
Edit the clip into the Timeline by dragging it to the Edit Overlay in the Canvas, clicking a
Canvas edit button, or using a keyboard shortcut.
Important: Sequence In and Out points always take precedence over source clip In and
Out points. This means that if you set both In and Out points in a sequence, the duration
of the edit is determined by the In and Out points of the sequence, regardless of the In
and Out points of the source clip. This allows you to restrict the portion of your sequence
affected by your edit.

Different Ways to Do Three-Point Editing
There are several basic methods for three-point editing into a sequence: dragging a clip
to the Edit Overlay in the Canvas, using the Canvas edit buttons, or using keyboard
shortcuts. For information on the seven types of edits you can perform, see “About Edit
Types in the Edit Overlay.”
Dragging to the Edit Overlay in the Canvas
When you drag a clip from the Browser or Viewer to the image area of the Canvas, the
Edit Overlay appears. The overlay appears translucently over the image, with seven sections
corresponding to seven types of edits you can perform. Drag to a section to perform the
corresponding edit.
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Note: If you don’t drag directly to one of the overlay choices, the default edit is Overwrite,
meaning the clip overwrites anything located at its destination in the Timeline.
Drag a clip to a section
of the Edit Overlay.

Edit Overlay with its
seven sections

When you drag a clip to a specific section of the overlay, that section is outlined in its
own color. If you drag your clip to the area to the left of the Edit Overlay, an overwrite
edit is performed by default.
Using the Edit Buttons in the Canvas
With a clip open in the Viewer, you click one of the edit buttons at the bottom of the
Canvas to perform that type of edit. You can also drag a source clip to one of these
buttons. These buttons perform the same edits as the sections of the Edit Overlay.
There are initially three edit buttons shown. When you click the arrow to the right of the
three buttons, buttons for additional edit types appear. If you select one of these other
edit types, that edit becomes the default function of the third button. Tooltips identify
each of the buttons so you know which one to use.
Click the arrow next
to the third button to
display the additional
edit buttons.

Drag a clip to one of the
edit buttons.

Chapter 36 Three-Point Editing

523

Using Keyboard Shortcuts
With a clip open in the Viewer, you can also use keyboard shortcuts to perform each of
the seven types of edits. All of the keyboard shortcuts use the function keys along the
top of the keyboard. (If you forget a keyboard shortcut, position your pointer over one
of the edit buttons and pause for a moment. A tooltip appears with that button’s function,
as well as its keyboard shortcut.)
• F9: Insert edit
• Shift-F9: Insert with transition edit
• F10: Overwrite edit
• Shift-F10: Overwrite with transition edit
• F11: Replace edit
• Shift-F11: Fit to fill edit
• F12: Superimpose edit
Important: Some Mac OS X keyboard shortcuts may conflict with your Final Cut Pro
keyboard shortcuts. For more information, see “Customizing the Interface.”

About Edit Types in the Edit Overlay
There are seven choices for placing clips into your sequence for three-point edits. The
two basic edits are overwrite and insert; the other options are variations on inserting or
overwriting. You choose an edit based on how you want your source clip to fit into your
sequence, including what you want to happen to any clips that are already there.
The seven edit types are:
• Insert: When you edit a clip into your sequence using an insert edit, all sequence clips
in all unlocked tracks are cut at the In point of your edit and pushed forward in your
edited sequence by the duration of your source clip.
• Insert with transition: This is the same as an insert edit, except that the default transition
is used at the In point of the edit to transition between the previous clip and your
source clip. When you first install Final Cut Pro, the default video transition is a 1-second
cross dissolve. You can change it to anything you want, however, using the Set Default
Transition command in the Effects menu. For more information, see “Changing the
Default Transition.”
• Overwrite: When you edit a clip into your sequence using an overwrite edit, any portions
of clips that are already in the destination tracks are replaced by the source clip.
• Overwrite with transition: This is the same as an overwrite edit, except that the default
transition is used at the In point of the edit to transition between the previous clip and
your source clip.
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• Replace: A replace edit replaces a clip in your sequence with the source clip, aligning
the frame at the Viewer playhead location with the frame at the Canvas/Timeline
playhead location. This type of edit does not use In and Out points in the same way as
insert and overwrite edits. For more information, see “Performing a Replace Edit.”
• Fit to fill: This edit type changes the speed of your source clip so that its duration
matches the duration determined either by sequence In and Out points, or by the
duration of the clip in the Timeline that intersects the playhead. Unlike other edit types,
this type requires you to select four In and Out points instead of three. See “Changing
Clip Speed.”
• Superimpose: The video and audio of your source clip are automatically edited into
tracks above and below the currently selected video and audio destination tracks, using
either specified sequence In and Out points in the Timeline, or the duration of the clip
in the destination track that intersects the playhead. You can use this edit to quickly
add a video clip above another for subtitles, compositing, and so on. For more
information, see “Superimposing Clips.”

Performing the Different Types of Edits
The following section tells you how to perform the most common types of edits for adding
content to a sequence. These procedures assume that you’ve already set In and Out
points and destination tracks in the Timeline. For more information, see “Setting Edit
Points for Clips and Sequences” and “Specifying Destination Tracks in the Timeline.”

Performing an Insert Edit
An insert edit places the source clip into your sequence so that all items after the insertion
point in your sequence are moved forward (or rippled) in the Timeline, to make room for
the clip being added. No clips are removed from your sequence.
You can perform an insert edit with one or more clips. If you perform an insert edit in the
middle of an existing sequence clip, that clip is cut at the insertion point and the second
half is pushed, along with the rest of the footage to the right of the insertion point, to
the end of the newly inserted clip. Even if your destination track is empty, clips on all
other unlocked tracks are moved forward in time, from the insertion point to the right.
Insert edits cause clips in your sequence to be rippled forward.
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Before edit
B

C

After edit
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By definition, an insert edit makes your sequence longer because the duration of the
inserted clip is added to the sequence. Typically, you use insert edits when you want to
add a new shot in the beginning or the middle of your sequence. You can also use an
insert edit to interrupt the action in an existing clip with the action in the newly inserted
clip. The action in the original clip then resumes after the inserted clip.

µ

To perform an insert edit
Specify the necessary edit points and destination tracks, then do one of the following:
• Press F9.
• Drag a clip from the Viewer or Browser to the Insert section of the Edit Overlay in the
Canvas.
• Click the Insert button in the Canvas.
Insert section of the Edit
Overlay in the Canvas

Insert button
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After the edit, all clips on all unlocked tracks (including nondestination tracks) are moved
forward in time, from the playhead position to the right, to make room for the clip or
clips being inserted.

Before an insert edit

After an insert edit

New clip is inserted.

Note: By default, Sequence markers (in the Timeline ruler) will ripple with any ripple edit
or insert edit. For more information, see “Using the Ripple Sequence Markers Setting.”

Performing an Insert with Transition Edit
The insert with transition edit is a quick way to do an insert edit that includes the default
transition between your new source clip and the clip before it in your edited sequence.
When you first install Final Cut Pro, the default transition is a 1-second cross dissolve. For
more information on how to choose a new default transition, see “Changing the Default
Transition.”
An insert with transition edit is exactly the same as an ordinary insert edit, but it places
the default transition into your sequence, centered on the edit point.

D

A

B

C

Before edit
A

D

B

C

After edit

Chapter 36 Three-Point Editing

527

Important: When you perform an insert with transition edit, make sure that there is
enough media at the beginning of the new clip and at the end of the previously edited
clip to create the transition. Each source clip must have enough unused frames outside
the defined edit points to equal half the duration of the default transition.
Tip: You can also perform an insert with transition edit with multiple clips. If there are
no other clips in your sequence at the In point, the first clip will make a default transition
from black. Each successive clip will then use the default transition into the next one until
all the clips you selected are laid out in a row.

µ

To perform an insert with transition edit
Specify the necessary edit points and destination tracks, then do one of the following:
• Press Shift-F9.
• Drag the clip from the Viewer or Browser to the Insert with Transition section of the
Edit Overlay in the Canvas.
• Click the Insert with Transition button in the Canvas.
Insert with Transition
section of the Edit
Overlay in the Canvas

Insert with
Transition button
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The source clip is inserted into the sequence with the default transition.

Before an insert with transition edit
New clip is inserted
with transition.

After an insert with transition edit

Performing an Overwrite Edit
Since this is the most commonly used edit type, it occupies the biggest overlay area in
the Canvas. If you drag a clip into any part of the Canvas to the left of the Edit Overlay,
an overwrite edit is performed.
With this type of edit, the source clip overwrites any clip items starting at the sequence
In point for the duration of the source clip. No clip items are rippled forward, so the
duration of your sequence remains the same. You can perform an overwrite edit with
one or more source clips.
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After edit
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For example, if you have a sequence clip of a comedian making a joke, but there’s a long
pause after the joke while the comedian stands there waiting for a reaction, you can
overwrite the pause using a source clip of an audience laughing. To do this, you position
the playhead at the frame right after the comedian finishes telling the joke, and then
perform an overwrite edit. The pause is covered by the clip of the audience laughing.

µ

To perform an overwrite edit
Specify the necessary edit points and destination tracks, then do one of the following:
• Press F10.
• Drag the clip from the Viewer or Browser to the Overwrite section of the Edit Overlay
in the Canvas.
• Click the Overwrite button in the Canvas.
Overwrite section of
the Edit Overlay
in the Canvas

Overwrite button
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The clip overwrites all items on the destination tracks from the playhead position through
the duration of your edit. No items are moved.

Before an overwrite edit
New clip overwrites
existing clips.

After an overwrite edit

Performing an Overwrite with Transition Edit
The overwrite with transition edit is a quick way to do an overwrite edit that includes a
transition between your new source clip and the clip before it in your edited sequence.
When you first install Final Cut Pro, the default transition is a 1-second dissolve. For more
information on how to choose a new default transition, see “Changing the Default
Transition.”
An overwrite with transition edit is exactly the same as an ordinary overwrite edit, but it
places the default transition into your sequence, centered on the edit point.
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Important: When you perform an overwrite with transition edit, make sure that there is
enough media at the beginning of the new clip and at the end of the previously edited
clip to create the transition. Each source clip must have enough unused frames outside
the defined edit points to equal half the duration of the default transition.
You can also perform an overwrite with transition edit with multiple clips. Each clip will
use the default transition into the next one until all the clips you selected are laid out in
a row.

µ

To perform an overwrite with transition edit
Specify the necessary edit points and destination tracks, then do one of the following:
• Press Shift-F10.
• Drag the clip from the Viewer to the Overwrite with Transition section of the Edit Overlay
in the Canvas.
• Click the Overwrite with Transition button in the Canvas.
Overwrite with Transition
section of the Edit
Overlay in the Canvas

Overwrite with
Transition button
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The clip overwrites other items on the destination tracks for the duration of the edit, and
uses the default transition.

Before an overwrite with transition edit
New clip with transition
overwrites existing clips

After an overwrite with transition edit

Performing a Replace Edit
A replace edit is a specialized form of overwrite edit. A replace edit places the frame at
the current Viewer playhead position at the Canvas/Timeline playhead location in your
sequence. You can use a replace edit to:
• Edit a clip into your sequence so that the current frame in the Viewer is placed at the
current playhead location in your sequence
• Quickly replace an entire shot that’s already in your edited sequence
• Resynchronize a video or audio clip item with an unlinked clip item in an adjacent track
For example, if you have two clips, each of which shows a different camera angle of the
same action, you may decide you want to replace the shot currently used in the Timeline
with the other angle. You can place both the Viewer and Timeline playheads on frames
where the action matches in each shot, and then replace the sequence clip with the clip
from the Viewer.
Replace edits follow a few special rules:
• Replace edits use the current playhead positions in the Timeline and the Viewer to
place the source clip in the Timeline.
• Replace edits never use clip In and Out points specified in the Viewer. If these points
have been set, they will be ignored.
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• Replace edits only replace existing clip items in your sequence. For example, if you
perform a replace edit using a Browser clip containing video and audio items in a
segment of your sequence containing only a video clip item, only the sequence video
clip item is replaced; no additional clip items are added. To add additional clip items
during an edit, you can use an overwrite edit instead.
Note: If you do set In and Out points in the Timeline, they will be used even if they
span multiple clips, as long as there’s enough media on either side of the playhead in
your source clip.
In and Out points
spanning multiple clips

• A replace edit places the source clip into your sequence so that the frame at the position
of the playhead in the Viewer is located at the Canvas/Timeline playhead position.
Therefore, it’s important that you have enough media in your source clip to the left
and right of the playhead in the Viewer to accommodate the space you’ll be filling in
the Timeline. If you don’t, you’ll see an “Insufficient content for edit” message.
• If you perform a replace edit by dragging a clip directly from the Browser, Final Cut Pro
uses the location of the Viewer playhead from the last time that clip was open in the
Viewer. If the clip is newly imported and has never been opened in the Viewer,
Final Cut Pro uses that clip’s starting frame, since that is the default starting position
for a clip.
• You can only perform a replace edit with one clip at a time. If you select multiple clips,
only the first one will be used.
The most basic use of the replace edit is to quickly and easily replace a clip in your edited
sequence with a source clip synchronized around a similar action.
To replace an entire clip in the Timeline with a clip synchronized to a point in the
sequence
1 In the Timeline, move the playhead to a frame you want to match with a source clip.
For example, if both the sequence and source clip are shots of a person jumping, you
could move the Canvas/Timeline playhead to the first frame where the person’s feet leave
the ground.
2 Make sure that the correct Source and Destination controls are connected in the Timeline
for the clip you want to replace.
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3 Double-click the replacement source clip to open it in the Viewer, then move the Viewer
playhead to the frame you want to match in the Timeline. Do not set any edit points for
the clip in the Viewer.
For example, if both the sequence and source clip are shots of a person jumping, you
could move the Viewer playhead to the first frame where the person’s feet leave the
ground. This frame will be placed at the location of the playhead in the Timeline.
4 Do one of the following:
• Drag the clip from the Viewer to the Replace section of the Edit Overlay in the Canvas.
• Click the Replace button in the Canvas.
• Press F11.

Replace button
Replace section of
the Edit Overlay in
the Canvas

Important: Make sure that the clip in the Viewer contains enough media on either side
of the playhead to fill the duration of the clip you want to replace in the Timeline. If it
doesn’t, you’ll see an “Insufficient content for edit” message.
Another common use of the replace edit is to line up a frame in a clip that’s already in
your edited sequence with an audio cue in an adjacent clip. For example, if you have a
video clip of a man dancing and an audio clip of music in another track, you can use a
replace edit to place a different portion of the same video clip into your sequence at the
same location, aligning a frame showing a particular movement of his foot with a particular
beat of the music.
To use a replace edit to resync a video clip to an audio clip in another track
1 In the Timeline, choose Mark > Clear In and Out (or press Option-X) to delete any sequence
In and Out points.
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2 In the Timeline, find the audio cue you want to sync your video clip to, and position the
playhead there.

3 Make sure that the Source and Destination controls in the Timeline are set to the tracks
containing your video clip, and not your audio clip.

The video track should
be the only destination
track set.

4 Without moving the Timeline playhead, press the F key to perform a match frame
operation.
This opens the master clip that the video clip in your sequence came from in the Viewer,
placing the playhead in the Viewer over the same frame that was under the playhead in
the Timeline. For more information on match frame editing, see “Matching Frames Between
Sequence and Master Clips.”
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5 Move the playhead in the Viewer to the new frame that you want to align with the audio
cue that you selected in the Timeline.
6 Now that the Timeline playhead is lined up with the audio cue in your sequence and the
Viewer playhead is lined up with a video frame that you want to sync to it, perform the
edit by doing one of the following:
• Press F11.
• Drag the clip from the Viewer to the Replace section of the Edit Overlay in the Canvas.
• Click the Replace button in the Canvas.
The original video clip item in your sequence is replaced with a new copy of the clip,
which is synchronized with your audio cue.

Important: Make sure that the clip in the Viewer contains enough media on either side
of the playhead to fill the duration of the clip you want to replace in the Timeline. If it
doesn’t, you’ll see an “Insufficient content for edit” message.
If you set In and Out points in a sequence, a replace edit can overwrite more than one
clip at a time. A replace edit still works the same way: the Timeline and Viewer playheads
are used as the matching points for the edit.
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To use a replace edit with sequence In and Out points
1 In the Canvas or the Timeline, set In and Out points for the section of your sequence you
want to replace.
In and Out points define the
area you want to replace.

2 Move the playhead to the frame that you want the source clip to line up with.
This frame can be at any point between the In and Out points.
3 Make sure that the tracks containing the items you want to replace are set as destination
tracks.
4 Double-click the clip you want to use to replace the selected area (to open it in the Viewer),
then move the playhead to the frame you want to line up with the playhead in the
Timeline.
5 Do one of the following:
• Press F11.
• Drag the clip from the Viewer to the Replace section of the Edit Overlay in the Canvas.
• Click the Replace button in the Canvas.
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The selected area in the sequence is replaced by the source clip. Final Cut Pro automatically
calculates the clip duration.

Before a replace edit
New clip replaces the
selected area of the
sequence.

After a replace edit

Superimposing Clips
In some cases, you may want to place one clip directly above another clip in a different
track. This is called a superimpose edit. You can use a superimpose edit to quickly stack a
source clip on top of a clip already in your sequence. If there isn’t an available track in
your sequence, Final Cut Pro creates a new one for the source clip.
Superimpose edits obey the standard rules of three-point editing, except that if no In or
Out points have been specified in the Canvas or Timeline, the position of the playhead
in the Timeline is not used as a default In point. Instead, the clip that intersects the position
of the playhead in the current destination track provides the In and Out points for the
source clip (as it does when you use the Mark Clip command).
You can set the In and Out points in the Canvas or Timeline so that the superimpose edit
spans multiple clips, as long as there’s enough media in your source clip to cover the
specified area.
If you perform several superimpose edits in the same location, each new source clip is
edited into the video track directly above the current destination track, and all other
previously superimposed video clips are moved up one track to make room. If your
superimposed clip contains audio, the source audio is placed on new audio tracks
immediately below any occupied audio destination tracks already in your sequence.
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Likewise, if you perform a superimpose edit with several source clips at once, all of those
clips are stacked on top of one another. The first clip in your selected group is on top,
with each successive clip appearing underneath.
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After edit

To perform a superimpose edit
1 Do one of the following:
• Position the Timeline playhead over a clip above which you want to superimpose your
source clip. The beginning and end of this clip are used as edit points for your source
clip.
• Set sequence In and Out points.
2 Set an In point in the Viewer to define the starting point of the source clip you want to
edit into your sequence.
3 Do one of the following:
• Press F12.
• Drag the clip from the Viewer to the Superimpose section of the Edit Overlay in the
Canvas.
• Click the Superimpose button in the Canvas.

Superimpose button
Superimpose section
of the Edit Overlay
in the Canvas
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The clip in the Viewer is placed in the track above the destination track, starting at the
beginning of the clip that intersects the Timeline playhead, or at the sequence In point.
If there is no track above the destination track, one is created.

Before a superimpose edit

After a superimpose edit
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Three-Point Editing Examples
There are a few key things to keep in mind when you are doing three-point editing.
Edit points set

Results

• Clip In and Out points
• Sequence In point

The In point of the source clip is placed at the sequence In point,
and the duration of the edit is determined by the clip In and Out
points.

• Clip In point
• Sequence In and Out points

The In point of the source clip is placed at the In point in the
sequence, and the duration of the edit is determined by the
sequence In and Out points.

• Clip In and Out points
• Sequence Out point

The Out point of the source clip is placed at the Out point of the
sequence, and the duration of the edit is determined by the clip In
and Out points. This is known as “backtiming” an edit. You can use
this method when you want to make sure a particular frame of a
clip ends at a specific point in a sequence. For example, you can
use this method to make sure the last frame of a clip ends on a
musical beat in the Timeline.

• Clip Out point
• Sequence In and Out points

The Out point of the source clip is placed at the Out point of the
sequence, and the duration of the edit is determined by the
sequence In and Out points. If there is no sequence In point, the
Timeline playhead is used as the In point.

Example: Editing a Specific Clip into Your Sequence
The simplest way to perform an edit is to specify In and Out points for a clip in the Viewer,
and then specify the destination In point in your sequence by positioning the playhead
in the Canvas or Timeline.
To edit a specific clip into your sequence
1 Double-click a clip to open it in the Viewer. (This is your source clip.)
2 Specify In and Out points for your source clip in the Viewer.

In point
Out point
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3 In the Canvas or Timeline, move the playhead to the location in your sequence where
you want the clip to start (the sequence In point).
Move the playhead to the
location in the sequence where
you want the clip to start.

4 Now, if you do an overwrite edit, you’ll see that the duration of your clip, defined by the
In and Out points in the Viewer, has been edited into the sequence.

The new clip starts where
the playhead was.

As you can see, defining only three points—the clip In and Out points in the Viewer and
the sequence In point in the Timeline—gives you total control of the edit that’s performed.

Example: Editing a Clip into a Gap in Your Sequence
You can also do the reverse of the previous editing example. For example: You have a
gap in your edited sequence and you want to fill it with a new clip. You know where you
want the source clip to start, and you don’t particularly care where it ends. You can specify
an In point in the Viewer, and specify In and Out points in the Timeline to coincide with
the gap.
To edit a clip into a gap in your sequence
1 Double-click a clip to open it in the Viewer. (This is your source clip.)
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2 Specify an In point for the source clip in the Viewer.

In point

3 In the Timeline, move the playhead to the middle of the gap you want to fill.
Move the playhead into
the gap.

4 Choose Mark > Mark Clip (or press X) to set In and Out points around the gap.
Note: You must select the Auto Select controls for the tracks containing the gap. For
more information, see “Using Auto Select to Specify Tracks for Selections.”
In and Out points
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5 If you do an overwrite edit, you’ll see that your clip, defined by the In and Out points in
your sequence, has been edited into the sequence.

The new clip fills the gap.

Example: Backtiming a Clip into Your Sequence
Instead of editing a clip into your sequence using clip In and Out points in the Viewer
and a sequence In point in the Canvas or Timeline, you can edit clips using only an Out
point in the Canvas or Timeline. This is called backtiming a clip. You can use this method
when you want to make sure a particular frame of a clip ends at a specific point in a
sequence. In the resulting edit, your source clip’s Out point is placed at the Out point you
set in your sequence, and the rest of the clip appears in your sequence before this point,
to the left.
To edit a clip into your sequence using only an Out point in the Canvas or Timeline
1 Double-click a clip to open it in the Viewer. (This is your source clip.)
2 Specify In and Out points for the source clip in the Viewer.

In point
Out point

Chapter 36 Three-Point Editing

545

3 In the Timeline, move the playhead to the point in your edited sequence where you want
your clip to end, and set an Out point.
Set an edit point at the
location where you want
the clip to end.

4 If you do an overwrite edit, you’ll see that your clip has been edited into the sequence
so that the Out point of your clip lines up with the Out point you specified in the Timeline.
The rest of your clip has overwritten any material to the left of the Out point for the
duration defined by the In and Out points set in the Viewer.

The new clip lines up
with the Out point you
specified in the Timeline.

Example: Editing a Clip with No Specified In or Out Points into Your
Sequence
If you don’t specify In or Out points for a clip in the Viewer prior to editing, Final Cut Pro
edits in the entire clip, either to the position of the playhead or to an edit point specified
in the Canvas or Timeline.
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To edit a clip into your sequence that has no specified In or Out points
1 Double-click a clip to open it in the Viewer, but don’t set In or Out points.

No In or Out point
is set.

2 In the Timeline, move the playhead to the location in your sequence where you want the
clip to start (the sequence In point).
Move the playhead to the
location where you want
the new clip to begin.

3 Now, if you do an overwrite edit, you’ll see that the entire clip in the Viewer has been
edited into the sequence.
Since you used an overwrite edit, any clip items that were already in those tracks in the
sequence have been overwritten by the source clip.
The new clip begins
where the playhead
was located.
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The playhead moves to
the end of the new clip.
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Finding and Selecting Content in
the Timeline
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This chapter covers the following:
• Understanding What’s Currently Selected (p. 549)
• Direct Methods for Selecting Content in a Sequence (p. 551)
• Finding and Selecting Based on Search Criteria (p. 559)
• Selecting a Vertical Range Between In and Out Points (p. 561)
• Using Auto Select to Specify Tracks for Selections (p. 562)
When you want to arrange, copy, delete, or otherwise manipulate items in a sequence,
the first thing you need to do is select them.

Understanding What’s Currently Selected
Most commands in Final Cut Pro require a selection. Even when you have not explicitly
selected items in the Timeline, Final Cut Pro often has a default selection, such as the clip
currently beneath the Timeline playhead. In addition to learning different methods for
selecting items in a sequence, it’s important to understand which clips Final Cut Pro
considers to be selected when you haven’t made an explicit selection.

Identifying Selections in the Timeline
When you click a clip in the Timeline, it’s highlighted to indicate it’s selected.

The selected clip
is highlighted.
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Even if there are no clips highlighted, Final Cut Pro usually considers something in the
Timeline to be selected. This occurs in two situations:
• If no clips are highlighted and there are no In or Out points set: Clips under the current
position of the playhead are considered selected for many commands. For example, if
you choose a filter from the Effects menu, it is applied to any clips under the playhead,
even if nothing in the Timeline appears to be selected. This makes editing faster because
you don’t always need to explicitly select a clip to affect it.
• If sequence In and Out points are set and no clips are selected: Any content between the
In and Out points is selected on all tracks with Auto Select turned on. The selected area
is highlighted.

Auto Select is turned on
for these two tracks.

The highlight indicates
what is selected.

Auto Select controls are further explained in “Using Auto Select to Specify Tracks for
Selections.”

How Selections Are Prioritized in the Timeline
With the exception of editing clips into a sequence, operations in the Timeline are
prioritized in the following way:
• If clips are selected: Any operations you perform affect those clips.
• If no clips are selected: Content between In and Out points on tracks with Auto Select
turned on is considered selected.
• If no In and Out points are set: The clips under the playhead on tracks with Auto Select
turned on are considered selected for many commands.
Note: Some commands operate on the topmost video clip items, regardless of which
tracks’ Auto Select controls are turned on. The topmost clip items are the ones you see
in the Canvas, and so those are often the items you want to operate on.
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For example, if sequence In and Out points are set and a clip is selected, the next operation
is performed on the selected clip rather than the content between the In and Out points.
If you deselect the clip, the portions of clips between the In and Out points on tracks with
Auto Select turned on are affected. For more information, see “Using Auto Select to Specify
Tracks for Selections.”

Direct Methods for Selecting Content in a Sequence
As with many applications, the most basic way to select items in the Timeline is to click
them. There are different selection tools designed to help you make such selections as
easily as possible when working with a lot of material in a sequence.
The following can be selected in the Timeline:
• Clip items: Any audio, video, or graphics clip item. This includes multiple items or a
range of items.
• A range of content: A range of content (for example, parts of clips) instead of a whole
clip or group of clips.
• Transitions: Transitions such as dissolves or wipes that occur between two items in the
Timeline. You can select these in order to trim or delete them.
• Edits: The point where two items meet can be selected for further editing. This includes
the point where a clip item meets a gap.
• Gaps: The space between two clip items on the same track can be selected in order to
close it or fill it with media.
The following cannot be selected in the Timeline:
• Filter and motion bars and their keyframes: You can double-click a bar directly in the
Timeline to view filter or motion details in the Viewer. Even though you can’t select
the keyframes, you can move them by dragging them.
• Tracks: Tracks themselves can’t be selected, although the contents of tracks can be
selected using the track selection tools.

An Introduction to the Selection Tools
Several tools in the Tool palette can be used to select items.
Note: Remember that if you select an item that’s linked to another item, the linked item
is selected as well, unless you turn off the Linked Selection option. (See “Linking and
Unlinking Video and Audio Clip Items in the Timeline.”)
To select a tool
1 Move the pointer over a tool in the Tool palette, then press and hold down the mouse
button.
All of the related tools appear.
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2 Move the pointer to the tool you want to select, then release the mouse button.
The selected tool becomes the current tool in the Tool palette for that group of tools.

The selected tool
becomes the default
shown in the
Tool palette.

Click a tool
to select it.

These are the selection tools, in order of appearance:

Selection tool

• Selection: Selects individual items, such as a clip, transition, edit point, or keyframe, or
multiple items if they’re linked. The functions of this tool can be modified in a variety
of ways using keyboard shortcuts. This is the default tool.
Note: When using the Slip or Slide tool, you can temporarily turn the Slip or Slide tool
into the Selection tool by pressing the Command key for a noncontiguous selection
or the Shift key for a contiguous selection.
Edit
Selection
tool

Group
Selection
tool

Range
Selection
tool

• Edit Selection: Selects an edit point between clips. You can select edits on as many
tracks as you want, but you can only select one edit per track. When you double-click
an edit, the Trim Edit window appears so you can precisely modify several edit points
simultaneously. (For more information on using the Trim Edit window, see “Trimming
Clips Using the Trim Edit Window.”)
• Group Selection: Selects multiple contiguous items. This tool automatically selects an
entire item in the Timeline even if you only drag over a part of it. Any other items linked
to it are selected as well. Use this tool to select several clips in their entirety.
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• Range Selection: Selects a range of multiple contiguous items. This tool does not
automatically select an entire item, but only the part of the item that you drag across.
Use this tool to select only a part of a clip, or to create a selection that includes portions
of several clips.
Select Track Forward
Select Track
Backward
Select Track

Select All Tracks
Forward
Select All Tracks
Backward

• Select Track Forward: Selects all the items in a track after the selection point you click.
Selected items are ready for any group operation, such as moving or deleting. Items
linked to selected items in this track are selected also.
• Select Track Backward: Selects all the contents of the track before the selection point.
• Select Track: Selects the entire contents of a single track, as well as any items linked to
those items.
• Select All Tracks Forward: Selects all the contents of all tracks after the selection point.
• Select All Tracks Backward: Selects all the contents of all tracks before the selection
point.

Selecting Clips
Selecting individual clips is as straightforward as clicking, as long you are clicking with
the right tool. Also included here are the tricks you need to know for selecting multiple
contiguous and noncontiguous clips quickly.
Tip: When clip items are linked, but you need to select just an individual clip item, you
can temporarily prevent linked items from being selected together by pressing the Option
key while selecting. (The link status returns to the turned on state when you release the
Option key.)
Selecting an Individual Clip
This is the simplest kind of selection you can make in the Timeline.
To select an individual clip
1 Click the Selection tool in the Tool palette (or press A).
2 In the Timeline, click anywhere in a clip.
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If the Canvas is set to display overlays, a cyan blue border appears around the video image
to indicate that the clip beneath the playhead is selected. (To set the Canvas to display
overlays, choose View > Show Overlays, so there is a checkmark next to it.)

A cyan border indicates
the clip is selected.

Selecting a Group of Clips by Dragging
Sometimes the fastest way to select a group of contiguous clips is to drag a box around
them.
To select multiple whole clips by dragging
1 Do one of the following:
• Select the Group Selection tool in the Tool palette (or press the G key twice).
• Select the Selection tool in the Tool palette (or press A).
2 Drag a box around all of the clips you want to select them. Any clip you touch will be
included, even if you don’t drag across the entire clip.

Drag to select clips.

Selecting Multiple Clips
The Shift and Command keys allow you to select multiple clip items in the Timeline, either
contiguous or noncontiguous.

µ
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To select multiple noncontiguous clip items
Hold down the Command key while selecting the clip items you want using either the
Selection tool or the Group Selection tool.
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You can also Command-click a specific item again to deselect it.

Noncontiguous selection

µ

To select multiple contiguous clip items with the Selection tool
Select a clip item, then hold down the Shift key and select another clip item farther down
on the Timeline. All of the clip items between the two are selected.
• If you select two clip items on the same track: Only the items on that track (and items
linked to items on that track) are selected.
• If you select a clip item on one track and another clip item on a different track: All clip items
between those two tracks are selected as well.
You can also select a range of contiguous clip items, and then select additional
noncontiguous clip items using a combination of the instructions above.
Deselecting an Item in a Multiple Selection
Sometimes after selecting a number of clips, you want to deselect one or two of them.
For example, if you want to select all clip items on track V1 except one in the middle, it
is often easier to select all the clip items and then deselect the clip item in the middle.

To deselect an individual clip item within a selection
1 Select the Selection tool in the Tool palette (or press A).
2 Command-click the item you want to deselect.

Selecting a Range of Timeline Content
When you want to copy, cut, or move an area of content that is not specified by clip
boundaries, you can either select the area with the Range Selection tool, or use In and
Out points to make a vertical selection across tracks. For more information about using
In and Out points to select a range of content, see “Using Auto Select to Specify Tracks
for Selections.”
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To select a portion of a clip item
1 Select the Range Selection tool in the Tool palette (or press the G key three times).

Range Selection tool

2 Click a clip item where you want to start your selection, drag to the right until you reach
the end of the portion of the clip you want to select, then release the mouse button.

Drag with the Range
Selection tool to select
an entire clip and part
of a second clip.

Selecting All Clip Items on a Track
Sometimes you may find that you want to select all of the clip items on a track in order
to drag them to close a gap or to create space to accommodate new clip items in your
sequence. After selecting a track’s contents, you can perform different operations on all
the track’s items at once, such as moving, copying, or deleting them.
The track selection tools provide many additional ways of selecting some or all of the
content of one or more tracks in your sequence.
Note: When selecting the contents of a track, remember that linked items on other tracks
will also be selected if linked selection is turned on. If you don’t want to select linked
audio or video clip items, turn off linked selection first. (See “Linking and Unlinking Video
and Audio Clip Items in the Timeline.”)
To select all the clip items on a single track
1 Select the Select Track tool in the Tool palette (or press the T key three times).
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2 Click anywhere in the track. All clips in the track are selected, as well as any items linked
to those clips.

All clips in V1 are selected.

You can also select all items before or after a specified clip item. For example, if you want
to select all clip items in track V1 except for the first item, you can use the Select Track
Forward tool.
To select all clip items after a specified item on a single track
1 Select the Select Track Forward tool in the Tool palette (or press the T key).
2 Click a clip item in the Timeline.
The item you click and all items after it are selected.
To select all clip items before a specified item on a single track
1 Select the Select Track Backward tool in the Tool palette (or press the T key twice).
2 Click a clip item in the Timeline.
The item you click and all items before it are selected.
Tip: You can temporarily turn off linked selection by holding down the Option key while
clicking a clip item.

Selecting All Items on All Tracks Forward or Backward
When there are many clips in a sequence, it’s difficult to see and select many of them at
once, especially if you don’t want to zoom in and out frequently. The Select All Tracks
Forward and Select All Tracks Backward tools let you simply select all clip items before
or after a selected clip.
To select all clip items on all tracks before or after a selected clip
1 Do one of the following:
• Select the Select All Tracks Forward or Select All Tracks Backward tool in the Tool palette.
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• Press the T key four times to select the Select All Tracks Forward tool, or press the T
key five times to select the Select All Tracks Backward tool.

Select All Tracks
Forward tool

Select All Tracks
Backward tool

2 Click the first clip item on any track that you want to include in the selection.
All clip items in all tracks from the point you click onward (either forward or backward)
are selected, as well as any items linked to those items. You can select entire clip items
only; you can’t select a portion of a clip item.

Click a clip item to select
all clip items on all tracks
to the right.

Click a clip item to select
all clip items on all tracks
to the left.

Once you’ve selected a large group of clip items, you can always deselect individual clip
items by Command-clicking them with the Selection tool.
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Selecting or Deselecting All Clips in a Sequence
To move or delete all clip items, you can select them all at once. To make sure no clip
items are selected anywhere in the Timeline, you can deselect all of them.
To select every clip item in the Timeline
1 Click in the Timeline to make it active (or press Command-3).
2 Choose Edit > Select All (or press Command-A).
To deselect every clip item in the Timeline
1 Click in the Timeline to make it active (or press Command-3).
2 Choose Edit > Deselect All (or press Command-Shift-A).

Finding and Selecting Based on Search Criteria
In a large sequence you may want to locate a clip in the Timeline with a particular name,
timecode number, or marker text, but it would take a lot of effort to find it by visually
scrolling and scanning. Final Cut Pro can search your sequence for you and select clips
that meet your criteria. You can search for individual items that meet the criteria, or select
all matching items at once.
To search for clip names, marker names, marker comments, or timecode numbers in
a sequence
1 Open a sequence in the Timeline.
2 Do one of the following:
• To search for individual occurrences of an item starting at the beginning of a sequence: Press
Home to position the playhead at the start of the sequence.
Note: On a portable computer, hold down the Function (Fn) and Left Arrow keys to
position the playhead at the start of the sequence.
• To search for individual occurrences of an item after a certain point in the Timeline: Position
the playhead where you want to start the search.
• To find an item everywhere it appears in the sequence: Place the playhead anywhere in
the Timeline; in this case, you use the Find All option, so it doesn’t matter where the
playhead is positioned.
• To search a selected portion of a sequence: Set sequence In and Out points (see step 6).
3 Choose Edit > Find (or press Command-F).
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4 Enter the text or timecode number you want to search for.
Enter text or a timecode
number here.

Choose additional
search options.

5 Choose the type of item to search for from the Search pop-up menu.

• Names/Markers: Search for the text in clip names, marker names, and marker comments.
• Timecode: Search for any source or auxiliary timecode in a clip.
6 Choose which tracks to search from the Where pop-up menu.
• All Tracks: Search all tracks in the sequence.
• Auto Select Tracks: Search only tracks with Auto Select turned on.
• From In to Out: Search between the sequence In and Out points on all tracks.
7 To search, do one of the following:
• Click Find to find the item.
Final Cut Pro finds the first item that matches the selected criteria from the current
position of the playhead to the end of the sequence. It does not find clips that begin
before the position of the playhead, nor does it wrap around to the beginning of the
sequence. If a clip name is matched, the clip is selected.
• Click Find All to find all clip items that match the search criteria.
All clip items that are found are selected in the Timeline. When a marker is found, the
playhead is positioned at the nearest marker after the playhead.
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µ

To cycle through items in the Timeline that match the search criteria
Follow the steps above, then choose Edit > Find Next (or press Command-G or F3).

µ

To search for an item backward from the position of the playhead
Follow the steps above, then press Shift-F3.
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Selecting a Vertical Range Between In and Out Points
When you want to copy, move, or cut a selection of content that ranges vertically across
multiple tracks, a quick method is to select it by setting In and Out points.
To select clip items between sequence In and Out points
1 Set In and Out points in either the Canvas or the Timeline.

2 In the Timeline, turn on the Auto Select controls for tracks that contain clip items you
want to select.
For more information, see “Using Auto Select to Specify Tracks for Selections.”
3 Choose Mark > Select In to Out (or press Option-A) to select your clips.

Only the parts of clip items between the In and Out points in tracks with Auto Select
turned on are selected.
Final Cut Pro also allows you to create In and Out points from the current Timeline
selection. For more information, see “Setting In and Out Points Based on a Selection in
the Timeline.”
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Using Auto Select to Specify Tracks for Selections
Auto Select controls determine which tracks are affected by an operation. When sequence
In and Out points are defined, operations such as the Copy and Lift commands are limited
to the regions of tracks with Auto Select turned on between the Timeline In and Out
points. You can intentionally turn off Auto Select controls for tracks that you don’t want
to operate on.
As you can see in the picture below, tracks A1 and A2 are not highlighted because Auto
Select is not turned on for those tracks.
In and Out points

Auto Select is enabled for
these two tracks.

The Auto Select controls provide precise control over which part of the Timeline you cut,
copy, or delete from. For example, if you have a sequence with one video and two audio
tracks, by turning off Auto Select on audio tracks A1 and A2, you can select items on track
V1 by setting In and Out points in the Canvas or Timeline. Items in the audio tracks are
not selected.

Before deleting
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If you press the Delete key, only the items on track V1 are deleted.

After deleting; only
the selected region
is deleted.

µ

To turn on or turn off Auto Select on a track
Click the Auto Select control for the track.

Auto Select control

µ

To turn on Auto Select on one track while simultaneously turning off Auto Select on
all other tracks
Option-click the Auto Select control on the track you want single out for Auto Select. (If
Auto Select is off for all tracks, you need to Option-click the control twice.)
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If you Option-click the Auto Select control on a video track, Auto Select is turned off on
all other video tracks in the sequence. If you Option-click the Auto Select control on an
audio track, Auto Select is turned off on all other audio tracks in the sequence.
Option-clicking allows you to quickly target a single track for editing operations.

Option-click the control
for the track you want to
single out for Auto Select.

To explicitly select a region between Timeline In and Out points
1 Turn on the Auto Select controls for tracks you want to select from, and turn off the Auto
Select controls for tracks you want to exclude from your selection.
2 Set In and Out points in the Timeline.
3 Choose Mark > In to Out (or press Option-A).
The region of clips between the In and Out points on tracks with Auto Select turned on
is selected.
In some instances, the Auto Select controls are ignored:
• If no Auto Select controls are turned on : Nothing in the Timeline is automatically
highlighted, and only selected clips will be operated upon (just as in earlier versions
of Final Cut Pro).
• If you use the Selection, Range Selection, or Edit Selection tool to select clips in the
Timeline: These selections are prioritized over the region between sequence In and
Out points on tracks with Auto Select turned on.
• If you use a command that only applies to the topmost visible video clip item (such as
switching or cutting between multiclip angles, or performing match frame operations): The
clip item seen in the Canvas is affected by your command, not the clip on the
lowest-numbered track with Auto Select turned on.
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Arranging Clips in the Timeline

38

This chapter covers the following:
• Snapping to Points in the Timeline (p. 565)
• Moving Items Within the Timeline (p. 566)
• Copying and Pasting Clips in the Timeline (p. 571)
• Deleting Clips from a Sequence (p. 576)
• Finding and Closing Gaps (p. 578)
• Color-Coding Clips in the Timeline (p. 581)
After initial content has been added to the Timeline, the next part of the rough editing
phase is assembling clips into the order in which you want them to appear.

Snapping to Points in the Timeline
The Timeline is where you arrange clip items, scene by scene and shot by shot. The
snapping feature helps you line up large groups of clips without accidentally creating
gaps. To arrange content, you need to know how to move, copy, cut, paste, and delete
within a sequence.
The snapping behavior makes it easier and quicker to do things like line up a video and
an audio clip item on two tracks, or align the playhead to a particular marker. When
snapping is turned on, items you move in the Timeline, including the playhead and
selected clips, appear to jump, or “snap,” directly to certain points in the Timeline.
Several elements trigger snapping in the Timeline:
• Clip boundaries
• The playhead
• Markers
• Keyframes
• In and Out points
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When you drag the playhead or a selected clip item in the Timeline, it “snaps” to these
elements when it encounters them.
A small pair of arrows
appears above or below
the edit, marker, or
keyframe to indicate
that the playhead has
snapped to this item.

While snapping is extremely useful, it can also be a hindrance if you’re trying to move a
clip only a few frames among a series of markers and clip boundaries, and you don’t want
it to snap to any of these points. Fortunately, you can turn snapping on or off at any time,
even while you’re dragging a clip.
To turn snapping on or off
Do one of the following:

µ
µ
µ

Choose View > Snapping. (A checkmark indicates snapping is on.)
Press N (you can do this even while you’re dragging).
Click the Snapping button in the Timeline.
If the Snapping button is not in the Timeline button bar, you can add it. For more
information about customizing button bars, see “Customizing the Interface.”
Snapping affects the functions of many of the editing tools in Final Cut Pro, such as the
Ripple and Roll tools, as well as the playhead in both the Viewer and the Canvas.

Moving Items Within the Timeline
Composing a sequence usually involves plenty of arranging and rearranging of content
in the Timeline. There are a couple of ways to move clips around in the Timeline:
• The fast, visual way is to drag the clips.
• For precise, timecode-based movement, you can select the clips and enter timecode
values in the Current Timecode field.

Moving by Dragging
When dragging a clip to a new location, you can do either an overwrite or insert edit,
depending on your use of a keyboard modifier.
To move a clip to a new position by dragging (and do an overwrite edit)
1 In the Timeline, drag the clip to the new location. (The pointer looks like a down arrow.)
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2 Release the mouse button.

The arrow pointing
down indicates that
an overwrite edit will
be performed.

To move a clip to a new position by dragging (and do an insert edit)
1 In the Timeline, drag the clip to the new location.
2 Press and hold down the Option key (after you’ve started dragging the clip).
The pointer looks like a right arrow.
3 Release the mouse button.

The arrow pointing right
indicates that an insert
edit will be performed.

To move a clip to another track while keeping its horizontal position in a sequence
the same
1 In the Timeline, select the clip you want to move.
2 Press the Shift key while dragging it vertically to the new track.
The clip will be at the same timecode location, but on another track.

Moving Clips Numerically
When you want to move clip items precisely, you can move them by entering positive
or negative timecode values.
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To move an item by entering a timecode value
1 In the Timeline, select the clip item or items you want to move.
2 Type a relative timecode value for where you want the clip to be positioned.
For example, type “+48” (or simply 48) to move the item 48 frames forward. To move
48 frames backward in time, type “–48”. When you type a number, a Move field appears
above the track. You can also type a regular timecode value to move the clip to that
location in the Timeline.
Note: Don’t click in the Current Timecode field before you do this, or you’ll move the
playhead instead.

The number of
frames moved

Clip items to be moved

3 Press Return.
The clip moves to the new location if there aren’t any other clip items in the way. If there
are, you see a “Clip Collision” message indicating which track had a clip that interfered
with your edit.

Clip Collision message
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For more information about editing numerically using timecode, see “Performing Slip,
Slide, Ripple, and Roll Edits” and “Trimming Clips Using the Trim Edit Window.”

Using the Command Key to Drag More Slowly
When you’re dragging clips, edit points, or keyframes, usually the default one-to-one
correspondence between the motion of your mouse and the motion of the item you’re
dragging works just fine. However, you can drag even more precisely by pressing the
Command key to slow, or “gear down,” the dragging speed after you’ve started dragging.
For example, holding down the Command key after you’ve started dragging a clip causes
the motion of that clip in the Timeline to be much slower and more precise. This can be
helpful if the Timeline is zoomed out so that individual clips look small. It’s also useful if
you want to make very small changes to an edit point, a keyframe parameter, a volume
level, or anything else.
You can use the Command key to modify nearly any dragging operation in Final Cut Pro.

Performing Shuffle Edits
A shuffle edit (sometimes referred to as a swap edit) allows you to move a clip item to a
different position in a track without leaving a gap. When you perform a shuffle edit, you
insert a clip item from one position in your sequence to another, and all clip items before
or after the clip insertion point are rippled so that the gap left by the moved clip is filled.
Shuffle edits do not affect the length of the clips or the overall duration of your sequence,
and clips on other tracks are not affected.

A

B

C

D

Before edit
A

D

B

C

After edit

Shuffle edits may only be performed with one clip item at a time, and they can’t be
performed on clip items with transitions applied.
Tip: You may want to turn snapping on to make it easier to align the clips you are moving
(see “Snapping to Points in the Timeline”).
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To shuffle a clip item from one position to another
1 Select a clip item you want to move in the Timeline with the Selection tool.

Select the clip item
to move.

2 Drag the selected clip item to the beginning of the clip item you want to insert the
dragged clip item in front of.
If you have trouble aligning it with the edit point, press the N key to turn snapping on.
3 While continuing to hold down the mouse button, press the Option key.
The pointer turns into the Shuffle Edit pointer. The direction of the small arrow in the
Shuffle Edit pointer indicates which direction clip items will be rippled around the insertion
point of the moved item.
• If the small arrow points right: All clip items to the right of the insertion point are rippled
to the right, filling the gap where the moved clip item was previously located.

The pointer changes to
the Shuffle Edit pointer.
In this case, the small
arrow points to the
right, so all clip items
to the right of the
insertion point are
rippled to the right.

• If the small arrow points left: All clip items to the left of the insertion point are rippled
to the left, filling the gap where the moved clip item was previously located.

570

Chapter 38 Arranging Clips in the Timeline

4 Release the mouse button to place the selected clip at the insertion point.

After

Clip D moves here.

Clips A, B, and C move
right and fill the gap
left by Clip D.

Important: Shuffle edits are only possible if you move a clip item beyond the boundaries
of its original position. If you don’t move a clip item far enough, pressing the Option key
while you drag the clip item allows you to perform an insert edit, but not a shuffle edit.

Copying and Pasting Clips in the Timeline
You can use the Copy, Cut, and Paste commands (or their keyboard equivalents) to arrange
clips in a sequence. You can also copy clips by Option-dragging.

Copying Clips by Option-Dragging
Copying by Option-dragging provides a fast, visual way to duplicate a clip in a new
location. There is no need to position the playhead.
To copy a clip into another location in the Timeline by dragging
1 In the Timeline, select a clip item.
2 Hold down the Option key and drag the clip item to the new location in the Timeline.
You can also make duplicates of sequence clips by dragging them from the Timeline to
the Browser. These copies are affiliate clips that include any changes you’ve made to the
clips in the sequence.
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Modifying Selections and Commands Using the Option Key
When you’re working with clips in the Timeline, you can use the Option key to do one
of three things:
• Hold down the Option key while you select a clip to temporarily turn off linked selection
(if it’s on) or turn it on (if it’s off ).
• Hold down the Option key after an item is selected, then drag the item from its original
position to make a duplicate of that item.
• Hold down the Option key after you’ve started dragging a clip and hold it down as you
release the mouse button to perform an insert or shuffle edit (depending on where
you drag the clip in the Timeline). For more information, see “Moving Items Within the
Timeline.”
Note: If you use the Option key to modify a command and don’t see the results you
wanted, you probably held down the Option key too long or at the wrong time.
In some cases, you need to remember to release the Option key once you have achieved
the result you want. For example, you may hold down the Option key while dragging a
clip to duplicate it. Once you begin dragging the clip, however, Final Cut Pro already
intends to duplicate the clip, and now the Option key tells Final Cut Pro to perform an
insert edit. If you prefer to do an overwrite edit, you need to release the Option key.
Another situation is when you intend to duplicate a clip by pressing the Option key, but
you instead turn off linked selection and only select one clip item. To avoid this, you need
to select the clip first, release the mouse button, and then press the Option key before
dragging it to duplicate it.

Copying, Cutting, and Pasting Clips in the Timeline
When you copy and paste clip items from tracks in the Timeline, Final Cut Pro pastes
those clip items into the same tracks they were copied from unless you specify different
tracks with Auto Select controls. If no Auto Select controls are selected between the time
you copy and paste the clip items, the items are placed on the same tracks from which
they were copied.
To copy (or cut) and paste clip items within the same Timeline tracks
1 Select one or more clip items in the Timeline.
2 Do one of the following, depending on what you want:
• Copy the clip items by pressing Command-C.
• Cut the clip items by pressing Command-X.
3 Position the playhead where you want the paste to occur.
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4 Paste the clip items at the playhead location by pressing Command-V.
Copied clip items

Pasted clip items

To copy (or cut) and paste clip items from one Timeline track to another
1 Select one or more clip items in the Timeline.
2 Do one of the following, depending on what you want:
• Copy the clip items by pressing Command-C.
• Cut the clip items by pressing Command-X.

3 Option-click the Auto Select control for the track you want to paste clip items into. (If no
Auto Select Controls are turned on, Option-click twice.)
4 Position the playhead where you want the paste to occur.
5 Paste the clip items by pressing Command-V.
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The copied clip items are pasted to the tracks with Auto Select turned on, except where
no Auto Select change was made. Where no Auto Select change was made after copying,
the clip items are pasted to the original tracks. See the picture below for an example of
these results.
The V2 Auto Select
control is enabled after
copying a clip item.

The video clip item is
pasted to the track with
Auto Select enabled.

The audio clip items
are pasted to the
original tracks.
No audio Auto Select
controls are changed
after copying a clip item.

Tip: Because you can’t Option-click a pair of audio tracks at once, Option-click the
lowest-numbered audio track you want to paste into.

Example: Copying and Pasting Clip Items to Different Tracks in the
Timeline
This section shows you how you would copy and paste audio and video clip items to
different tracks in the Timeline.
To copy and paste clip items from tracks V3, A5, and A6 to tracks V2, A2, and A3
1 Select the clip items on V3, A5, and A6.
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2 Copy the clip items by pressing Command-C.

3 Position the playhead where you want to paste the items.
4 Option-click the track V2 Auto Select control.
The video clip item will now be pasted into track V2.
5 Option-click the track A2 Auto Select control to set the lowest-numbered audio paste
destination track.
The lowest-numbered audio track for pasting is now set to A2.
6 Paste the clip items by pressing Command-V.
Track V2 becomes the
pasting destination after
Auto Select is enabled.

Track A2 becomes the
pasting destination after
Auto Select is enabled.

Note: Track Source and Destination controls have no effect on copying and pasting.
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Deleting Clips from a Sequence
As you edit, you can delete items from your sequence at any time, provided that the track
you want to remove them from is not locked.
There are two ways to delete items from a sequence:
• Lift edit: Leaves a gap in the sequence.
• Ripple edit: Closes the gap from the deletion by moving all subsequent clips to the left.
Important: Removing clips from a sequence does not delete the original master clips
from the Browser, nor does it delete source media files from your hard disk. For more
information, see “Overview of the Media Manager.”

Deleting with a Lift Edit (Leaving a Gap)
Deleting with a lift edit (also called a lift delete) removes any selected items from the
sequence and leaves a gap. This is useful if you have a series of clips already edited into
your sequence and you don’t want to move them (for example, if they’re all synchronized
to a piece of music). If you want to remove one or more clips from the middle of such a
sequence, the lift delete is the best way to do so.
Selected clip
A

B

C

Before edit
Gap
A

C

After edit

To remove a clip item and leave a gap
1 Do one of the following:
• Select the clip item or range of items you want to remove using one of the selection
tools.
• Set In and Out points in the Canvas or Timeline, then make sure the Timeline is active.
Only clip items on tracks with Auto Select turned on will be deleted.
2 Turn on Auto Select for the tracks you want to affect.
3 Do one of the following:
• Choose Sequence > Lift (or press Delete).
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• Choose Edit > Cut (or press Command-X) to cut the material, if you want to paste it
somewhere else.

Selected clip items

After a lift edit, a gap
is left in the sequence.

Deleting with a Ripple Edit (Leaving No Gap)
Deleting with a ripple edit (also called a ripple delete) removes selected items from the
sequence and closes the resulting gap by moving all subsequent items on unlocked tracks
to the left. A ripple delete is useful if you want to remove one or more clip items from
your sequence but you don’t want to leave a gap. For example, if you’re assembling a
rough cut, and you decide that there’s a clip you don’t need in the middle, performing
a ripple delete will remove it and move all subsequent clips in your sequence to the left
to fill the gap. Performing a ripple delete is the opposite of performing an insert edit.
A

B

C

D

Before edit
A

C

D

After edit

To delete a clip item and close the gap left behind
1 Select the item or range of items you want to remove.
2 Do one of the following:
• Choose Sequence > Ripple Delete (or press Shift-Delete).
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• Control-click the selected clip item or items, then choose Ripple Delete from the shortcut
menu.
• Press Shift-X to cut the material, if you want to paste it somewhere else.

Selected clip items

After the ripple delete,
the clip items are
removed, with no
gap remaining.

Note: By default, Sequence markers (in the Timeline ruler) will ripple with any ripple edit
or insert edit. For more information, see “Using the Ripple Sequence Markers Setting.”

Finding and Closing Gaps
As you edit, cut, paste, and move items around in Final Cut Pro, empty spaces (called
gaps) may be left between clips in your sequence. Sometimes they are extremely small
(one or two frames), which makes them difficult to see in the Timeline. When a sequence
with gaps plays back in the Canvas, however, even tiny gaps are apparent as flashes of
black, so you don’t want to unintentionally leave them in the sequence.
There are two types of gaps:
• Track gaps: These are empty spaces between two clips in the same track.
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• Gaps: These are track gaps that occur in every single track of your sequence.

Gap
Track gap

To find gaps in a sequence
1 Move the playhead to the beginning of the sequence to start looking from the beginning.
Otherwise, you can look for gaps to the right or left of the playhead’s current position.
2 Do one of the following:
• Choose Mark > Next, then choose Gap from the submenu (or press Shift-G).
• Choose Mark > Previous, then choose Gap from the submenu (or press Option-G).
The playhead moves to the beginning of the first gap found to the right or left of the
playhead.
To find track gaps in a sequence
1 Decide which track to search and make it the destination track.
2 Do one of the following:
• Choose Mark > Next, then choose Track Gap from the submenu.
• Choose Mark > Previous, then choose Track Gap from the submenu.
The playhead moves to the beginning of the first track gap found.
To close a gap
Do one of the following:

µ

Position the playhead anywhere within the gap, then choose Sequence > Close Gap (or
press Control-G).

µ
µ

Control-click anywhere within a gap, then choose Close Gap from the shortcut menu.
Select the gap by clicking it, then press Delete.
All clips to the right of the gap move left to close the gap.
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Because this command shifts all clips to the right of the gap to the left, the command is
not available if a clip on another track overlaps this gap. (This would change the
relationship of the overlapping clip to the rest of your sequence, or change the audio-video
sync if it’s an audio clip underneath a video clip.)
If you don’t care about the sync relationship between the rest of your sequence and the
overlapping clip, you can lock tracks containing overlapping clips and then use any of
the above commands to close the track gap.
To close a track gap without affecting any other tracks in the sequence
1 Click the Lock Track control of any tracks with clips that overlap the gap you’re trying to
close.
2 Close the gap by doing one of the following:
• Position the playhead anywhere within the gap, then choose Sequence > Close Gap
(or press Control-G).
• Control-click anywhere within the gap, then choose Close Gap from the shortcut menu.
• Select the gap by clicking it, then press Delete.
To close a track gap using the Select Track Forward tool
1 Make sure snapping is turned on.
For more information, see “Snapping to Points in the Timeline.”
2 Select the Select Track Forward tool in the Tool palette.
3 Click the first clip to the right of the track gap.
All clips to the right are selected.
4 Drag the selected clips to the left until they close the gap and snap into place beside the
earlier clip.
To determine the duration of a track gap in the Timeline
1 Option-click the Auto Select control for the track with the gap.
2 Position the playhead in the gap.
3 Do one of the following:
• Choose Mark > Mark Clip (or press X).
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• Click the Mark Clip button in the Canvas.
In and Out points set
based on track gap
in V1.

Auto Select control
enabled

The track gap’s duration appears in the Timecode Duration field in the Canvas.

Color-Coding Clips in the Timeline
If you use labels to identify and sort your clips in the Browser, the clips’ names will be
highlighted in the color that matches each label. Using keyboard shortcuts, you can
change the labels of clips directly in the Timeline.
Important: Changes made to the label of any clip are also applied to all affiliated clips in
the Browser and in other sequences.
Color

Label

Keyboard Shortcut

None

None

Command-Option-1

Orange

Good Take

Command-Option-2

Red

Best Take

Command-Option-3

Blue

Alternate Take

Command-Option-4

Purple

Interviews

Command-Option-5
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Color

Label

Keyboard Shortcut

Green

B-Roll

Command-Option-6

To assign or change a label for a clip in the Timeline
1 Select one or more clips in the Timeline.
2 Press a key combination (from the table above) for the label you want to assign to the
clip items.
The color changes to reflect the new label.
For information about changing labels of clips in the Browser, see “Assigning Labels and
Setting Label Names to Help Manage Media.”
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Cutting Clips and Adjusting
Durations

39

This chapter covers the following:
• Performing Basic Cut Edits (p. 583)
• Changing the Duration of Clips in the Timeline (p. 587)
• Opening Sequence Clips in the Viewer to Change Durations (p. 587)
Once you’ve assembled clips in your sequence, you can easily cut them and adjust their
durations.

Performing Basic Cut Edits
The most basic edit is a straight cut, like the ones performed with a razor blade on a piece
of film. Basic cuts are described in this section, to help you in the rough editing process.

Cutting Clips in the Timeline
Each time you cut a clip in your sequence, it is split into two clips. You can make cuts
with the Razor Blade tool, or you can make cuts during playback by pressing Control-V.
Razor Blade All tool

Razor Blade tool

• Razor Blade: Adds an edit point to a sequence clip by cutting a single clip item, along
with any clip items linked to it in the Timeline, into two pieces. This edit point is added
at the frame of the clip item in the Timeline that you click.
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This can be useful for quickly rearranging pieces of your sequence, for deleting a section
of a clip, for applying an effect to a specific part of a clip, or for moving a piece of a clip
to the same location on another track.

Before

The Razor Blade tool lets
you cut a clip item into
two pieces.

After

584

Chapter 39 Cutting Clips and Adjusting Durations

• Razor Blade All: Cuts all clip items on all tracks at the point where you click in the
Timeline.

Before

After

The Razor Blade All tool
lets you cut clips across
all tracks.

Using the Add Edit Command to Cut Clips
The Add Edit command in the Sequence menu (Control-V) is similar to the Razor Blade
All tool, cutting all clip items in the Timeline at the current position of the playhead.
However, only clip items on tracks with Auto Select turned on are cut.
It can be very handy to use the keyboard shortcut for the Add Edit command during
playback of your sequence, so that you can make cuts as the playhead moves along the
Timeline. Each time you add an edit during playback, a red marker appears at the position
of the cut you just made. When playback stops, each of these markers is replaced by a
cut.

µ

To cut all clip items at the playhead position
Choose Sequence > Add Edit (or press Control-V).
Note: Only clip items on tracks with Auto Select turned on are cut.
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Joining Through Edits (Splicing Cut Clips Back Together)
Whenever you cut a clip item with the razor blade tool, the clip item is split into two
pieces separated by a through edit. You can’t see a through edit when you play back your
sequence in the Canvas because the frames on either side of the edit are from a continuous
section of a media file. However, you can turn on through edit indicators—two red
triangles above and below through edits—to see them in the Timeline. You can join
through edits at any time, splicing the separated clip items back into a single clip item.
Joining the two items of a through edit reduces the number of edits in your sequence
and simplifies Edit Decision Lists (EDLs). When you join two items of a through edit that
have different properties (such as different filters, different opacity or audio levels, or
different composite modes), the newly joined clip uses the properties of the item on the
left only.
To remove a through edit
Do one of the following:

µ
µ

Select a through edit in the Timeline, then press Delete.
Control-click a through edit in the Timeline, then choose Join Through Edit from the
shortcut menu.

The clip items on either side of the through edit become a single clip item.
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Changing the Duration of Clips in the Timeline
Clips are represented in the Timeline as horizontal bars within tracks. The length of the
bar represents the clip item’s duration. The beginning and end of the bar represent the
clip’s In and Out points. You can drag the beginning or end of the clip to change the
clip’s duration, right in the Timeline. As you move your pointer over a clip, the pointer
changes from an arrow (around the center of the clip) to a Resize pointer (at either the
beginning or the end of the clip).

Resize pointer
at end of clip

Box shows the changed
length of the clip and the
new duration of the clip.

Dragging the beginning
or end of a clip changes
the clip duration.

Opening Sequence Clips in the Viewer to Change Durations
You can open a sequence clip in the Viewer to adjust its duration. Any changes you make
to that clip in the Viewer modify the clip in the edited sequence. How these changes
occur also depends on the editing tool that’s selected.
To open a sequence clip in the Viewer from the Timeline for further editing
Do one of the following:

µ
µ
µ

Double-click the sequence clip in the Timeline.
Select the sequence clip, then choose View > Clip (or press Return).
Position the playhead at the In point of the clip in the Timeline (using the Up or Down
Arrow key) or anywhere within the clip in the Timeline, then press the Return key. The
clip on the lowest-numbered Auto Select-enabled track opens in the Viewer, and the
Viewer playhead is at the same frame as the one under the Timeline playhead.
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The video and audio tabs that appear in the Viewer depend on whether the clip item
you open from the Timeline is linked to other clip items, and whether linked selection is
turned on.
• If a clip item is linked to other clip items and linked selection is turned on: All items
associated with the one you’ve opened in the Viewer are also opened. Video and audio
clip items open in their own Viewer tabs.
• If linked selection is off, or items in the Timeline aren’t linked: Only the item you selected
will be opened in a tab in the Viewer.
When a sequence clip opens in the Viewer, the tab that appears in front depends on what
you clicked in the Timeline.
• If you double-clicked a video clip item: The video tab will be in front in the Viewer.
• If you double-clicked an audio clip item: The audio tab will be in front in the Viewer.
• If you double-clicked either the filter bar or the motion bar in the keyframes area of an item
in the Timeline: The corresponding Filters or Motion tab will be in front in the Viewer.
For more information, see “Creating Motion Effects in the Viewer.” You can also refer
to “Different Ways to Use Filters.”
• If you had a sequence clip already open in the Viewer with the Filters tab in front: Another
sequence clip opened in the Viewer appears with its Filters tab in front as well.
Changes made to a sequence clip apply only to that clip, and do not affect the master
clip in the Browser. You can verify that a clip opened in the Viewer is a sequence clip
instead of a Browser clip by checking that the scrubber bar displays sprocket holes, and
that the name of the clip in the Viewer has “from Sequence Name” appended to it (where
“Sequence Name” is the name of the sequence where the clip is located).
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Linking and Editing Video and
Audio in Sync

40

This chapter covers the following:
• Linked Sync Relationships Between Video and Audio Clips (p. 589)
• Linking and Unlinking Video and Audio Clip Items in the Timeline (p. 594)
• Selecting Individual Clip Items While They Are Linked (p. 597)
• Getting Clip Items Back in Sync (p. 598)
• Establishing Different Sync Relationships Between Linked Clip Items (p. 602)
• Learning About Linking Behavior in Audio Channel Pairs (p. 604)
• Synchronizing Dual System Recorded Video and Audio (p. 605)
Final Cut Pro allows you to adjust the synchronization relationship between video and
audio items in a clip. Linked clip items can be temporarily or permanently unlinked,
resynchronized, and relinked.

Linked Sync Relationships Between Video and Audio Clips
Linking helps you keep video and audio clip items in sync. Clip items from the same media
file are automatically linked to each other in the Timeline. You can also link unrelated clip
items together.
Final Cut Pro keeps track of the sync relationship between video and audio clip items of
all QuickTime media files that you’ve captured or imported into your project, as well as
the sync between merged clips.
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When video and audio clip items are linked in the Timeline:
• The names of the linked clip items are underlined to indicate that they’re linked.

The underlined clip
name indicates the link
between audio and
video items.

• As long as linked selection is on in the Timeline (the Linked Selection button in the
upper-right corner is green), clicking one clip item selects it and all the items linked to
it.
Click the Linked
Selection button
to turn linked
selection on and off.

When Linked Clips Are Moved out of Sync
When you move clip items in the Timeline, Final Cut Pro checks to see if the relationship
between linked items is still correct. If the relationship does not match, Final Cut Pro
displays out-of-sync indicators in the Timeline. Out-of-sync indicators show the offset
between the linked clip items.
Out-of-sync indicator
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Even when clip items are unlinked, Final Cut Pro keeps track of the relationship between
clip items that come from the same media file. This means that you can move those items
out of sync at any time, without worrying that you won’t be able to resynchronize them
later if you change your mind. Since merged clips contain clip items that do not come
from the same media file, out-of-sync indicators are not shown when you unlink and
move merged clip items. (For more information, see “Merging Clips from Dual System
Video and Audio.”)
An out-of-sync indicator appears whenever the following conditions occur:
• Audio and video clip items from the same media file are out of sync. Because they
come from the same media file, these items always show out-of-sync indicators, even
if they are not currently linked.
• Audio and video clip items belonging to a merged clip have been moved out of sync.
Because they come from different media files, these items only show out-of-sync
indicators if they are linked.
• Audio and video clip items have been linked together in the Timeline, and then moved
out of sync.
Audio and video clip items that have a sync relationship must be vertically overlapping
in the Timeline for out-of-sync indicators to appear when the items are moved out of
sync. No indicator appears if linked audio and video clip items are so far apart that they
no longer overlap.

Audio moved away
from video clip

If you move these items back together so that they overlap, the indicators appear again.

Audio moved back
under video clip
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This also works with multiple instances of clips from the same media file on disk. For
example: You have three items in your sequence, all from different parts of the same
media file.

If you move the audio item to the left, so that it overlaps the first video item, out-of-sync
indicators appear. The same happens if you move the audio item to the right.

What if you move all three items so that they overlap, but all are out of sync with one
another? The first two items show out-of-sync indicators relative to one another, and the
third item shows an out-of-sync indicator relative to the item it overlaps.
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Understanding Sync Relationships Between Multiple Linked Audio Items
Up to 24 audio items can be linked to a single video item in the Timeline. As a result,
some complex sync relationships may result if you slip more than one of a clip’s audio
items (for information on slip edits, see “Slipping Clips in the Timeline”). These are easily
managed using the same out-of-sync indicators described earlier.
When you create a merged clip, or link multiple items together in the Timeline, the video
item is considered the anchor item to which the sync of all other linked audio items is
compared. If you’re linking audio clip items without a video item, then the topmost audio
item in the Timeline acts as the anchor item.
In the following example, three stereo pairs of audio items are linked to a single video
item.

Moving a single pair of items out of sync results in a single out-of-sync duration, with
out-of-sync indicators with positive and negative durations in both the video and audio
items.
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If you then move a second pair of audio items out of sync by a different amount, each
audio item that is out of sync from the anchor item has an out-of-sync indicator noting
its individual offset from the anchor item—in this example, the video item. The anchor
item displays a mixed-sync indicator with no duration. This tells you that multiple linked
items are out of sync by varying amounts.

A mixed-sync indicator

Out-of-sync indicators

Linking and Unlinking Video and Audio Clip Items in the
Timeline
You can link additional clip items to already linked items, or remove items and then relink
the remaining items.

Linking Video and Audio Clip Items
When you link clip items, a sync relationship is established between those items, according
to their position in the Timeline. All linked clip items are marked in sync, and this new
sync relationship is tracked.
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To link unrelated clip items in the Timeline
1 Arrange audio and video clip items in their respective tracks so that they line up the way
you want them to.

Video and audio clip
items are not linked
together.

2 Select up to one video clip item and up to 24 audio items on different tracks in the
Timeline.

Select video and audio
clip items that you want
to link.

3 Choose Modify > Link (or press Command-L).
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Note: When you open linked items in the Viewer, each linked mono audio clip item or
stereo pair of clip items appears in an Audio tab in the Viewer.

Names of linked clip
items are underlined
in the Timeline.

Tip: Dragging linked clip items from the Timeline into the Browser creates a single merged
clip containing those items. This makes managing your media and keeping it in sync
much easier, especially if you want to use it in other sequences. For more information on
working with merged clips, see “Merging Clips from Dual System Video and Audio.”

Unlinking Video and Audio Clip Items
When you don’t want audio and video clip items to be linked in the Timeline, you can
unlink them.
To break the link between clip items
1 Select one or more linked items in the Timeline.
2 Choose Modify > Link (or press Command-L).
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Selecting Individual Clip Items While They Are Linked
Even when clip items are linked together, you may want to perform an action on only a
video or audio clip item. For example, you may want to copy just the audio, or delete just
the video. The Linked Selection option tells Final Cut Pro whether linked items are selected
together, or if clip items can be individually selected even when they are linked to other
items.
The Linked Selection
button is gray, indicating
linked selection is
turned off.

With linked selection
turned off, clicking a
clip’s video item selects
only that item.

You can turn linked selection on or off at any time.
To turn linked selection on or off
Do one of the following:

µ
µ

Press Shift-L.
Click the Linked Selection button in the upper-right corner of the Timeline.
Even if linked selection is on, you can temporarily disable it by holding down the Option
key while you select or edit a clip item. For example, if linked selection is turned on, but
you press the Option key while you click the video item of a linked clip, only the video is
selected.
To temporarily turn linked selection off while working in the Timeline
Do one of the following:

µ
µ

Hold down the Option key while selecting individual clip items.
Hold down the Option key while using the Slip, Slide, Ripple, Roll, and other tools.
When linked selection is off, holding down the Option key temporarily turns it on.
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Getting Clip Items Back in Sync
There are three ways to get clip items with out-of-sync indicators back into sync:
• Move the clip item back into sync with the Move into Sync command in the out-of-sync
indicator shortcut menu. This moves the clip item’s position in the Timeline, if possible.
• Slip the clip item back into sync with the Slip into Sync command in the out-of-sync
indicator shortcut menu. This slips the clip item’s In and Out points simultaneously,
leaving the clip position the same in the Timeline. For more information, see “Slipping
Clips in the Timeline.”
• Redefine the sync relationship between the clip items so that the current relationship
is considered to be in sync. You do this by choosing Modify > Mark in Sync.

Moving a Clip into Sync
Moving an out-of-sync clip item back into sync means repositioning the item in the
sequence so that it’s once again in sync with the video or audio anchor item to which
it’s linked. You can only move a selected item into sync if there’s enough room on the
track in which it appears. If another clip is in the way, the selected item moves as far as
it can and then a message says “Unable to put item in sync. Another item is in the way.”
To move a linked clip item into sync
Do one of the following:

µ

In the Timeline, Control-click the clip item’s out-of-sync indicator, then choose Move into
Sync from the shortcut menu.

µ

Select the clip item that is out of sync, then type the negative timecode offset value that
appears in the out-of-sync indicator and press Return.
For example, if a clip item’s out-of-sync indicator displays “4:12,” select the clip item and
enter “–4:12,” then press Return.
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If the item is an anchor item (either the sole video item among linked items, or the topmost
audio item if there is no video item), it moves into sync with the topmost out-of-sync
audio item in the group, starting on track A1 and going down. Otherwise, the selected
item moves into sync with the anchor item to which it’s linked.
Before syncing

Control-click the
out-of-sync indicator
and choose Move
into Sync.

After syncing

The anchor item is moved into
sync with the topmost audio
item to which it’s linked.

Slipping a Clip Item into Sync
This operation leaves the out-of-sync clip item in the same position in your sequence,
but slips the In and Out points within that item so that the item is in sync with the
corresponding audio or video anchor item to which it’s linked. This works in the same
way as the Slip tool. For more information, see “Slipping Clips in the Timeline.”

µ

To slip an out-of-sync clip item into sync using the out-of-sync indicator shortcut menu
In the Timeline, Control-click the out-of-sync indicator on a clip item, then choose Slip
into Sync from the shortcut menu.
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If the item is an anchor item, it slips into sync with the topmost out-of-sync audio item
in the group, starting on track A1 and going down. Otherwise, the selected item slips
into sync with the anchor item to which it’s linked.

Before syncing

After syncing

The anchor item is
slipped into sync with
the topmost audio item
to which it’s linked.

To slip an out-of-sync clip item into sync using the Slip tool
1 Select the Slip tool from the Tool palette (or press S).
2 If Linked Selection is on in the Timeline, click the Linked Selection button to turn it off.
3 Select the clip item you want to slip into sync.
You can temporarily turn the Slip tool into the Selection tool by holding down the
Command key.
4 Type the negative timecode offset value that appears in the out-of-sync indicator and
press Return. For example, if a clip item’s out-of-sync indicator displays “4:12,” select the
clip item and enter “–4:12,” then press Return.
If the clip item is an anchor item, the audio item is slipped into sync with it.

Moving or Slipping All Clip Items into Sync at Once
In cases where multiple audio items are out of sync by varying amounts from an anchor
video or audio item, you have an additional option available to manage the sync
relationships of all linked items at once.
To move all out-of-sync clip items into sync with the anchor item
1 In the Timeline, Control-click the out-of-sync indicator on the anchor clip item—either
the sole video item in a group of linked items, or the topmost audio item if there is no
video item among the linked items.
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2 Choose Move Others into Sync from the shortcut menu.

Before syncing

After syncing

To slip all out-of-sync clip items into sync with the anchor item
1 In the Timeline, Control-click the out-of-sync indicator on the anchor clip item—either
the sole video item in a group of linked items, or the topmost audio item if there is no
video item among the linked items.

Before syncing
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2 Choose Slip Others into Sync from the shortcut menu.

After syncing

Establishing Different Sync Relationships Between Linked Clip
Items
There are many reasons you might deliberately edit the video and audio items of a clip
to be out of sync with one another:
• Aligning the visuals of an actor reacting to a voice
• Reediting an actor’s audio from one take to match the visuals of a different take
• Changing the sync of ambient sound behind an image without critical audiovisual sync
points (such as dialogue)
• Performing sophisticated audio edits to sweeten an actor’s dialogue

Marking a Clip as In Sync
If you’ve moved a selected clip item out of sync deliberately and you want to permanently
change that item’s sync relationship to its corresponding linked audio or video items in
the sequence, you can use the Mark in Sync command. Final Cut Pro marks the items’
current relationship in your sequence as being in sync.
If you move one of these items out of sync again, the out-of-sync indicator shows the
number of frames to resync to the new sync point.
Note: Using Mark in Sync does not affect the original master clip in the Browser, nor does
it affect your media file on disk. It only affects the selected clip items in the Timeline.
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To mark out-of-sync clip items as in sync
1 In the Timeline, select the items that you want to mark as in sync (one video and up to
24 audio items may be marked as in sync).

Out-of-sync indicator

2 Choose Modify > Mark in Sync.
The items are now marked as in sync, although their positions in the Timeline haven’t
changed.

The out-of-sync
indicators disappear.

If you select just the audio and move it out of sync, out-of-sync indicators appear.

The out-of-sync
indicators show the
new offset, not the
original offset.

The Mark in Sync command permanently affects the sync relationship of the selected clip
items in your sequence. Once you’ve modified the sync relationship of clip items, the
only way to restore the original sync relationship is to manually move the clip items into
the old sync relationship and use the Mark in Sync command again, or to delete the clip
items and reedit a new instance of that clip into your sequence from the Browser.
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Learning About Linking Behavior in Audio Channel Pairs
In addition to linking video or audio clip items together, you can also link pairs of audio
items together in stereo pairs. Stereo linking is a specific kind of audio item linking, limited
to two audio clip items that are parallel in the Timeline.
Stereo pairs allow you to control audio levels, pan settings, and effects for two audio
items at once. Any modifications made to one item in the pair affect the other item. This
is convenient when you are working with audio such as music, stereo sound effects, or
any other audio recorded in stereo. One item of a stereo pair cannot be selected separately,
even if you turn off linked selection using the Linked Selection button.
For more information about stereo audio, see “Audio Fundamentals.”
If a clip contains two mono audio channels:
• In the Timeline: Each mono audio item is treated like any other linked item. Clicking
one item selects both items with linked selection on; with linked selection turned off,
you can select one at a time.
• In the Viewer: Each mono channel has its own tab, named Mono (a1) and Mono (a2),
Mono (a3) and Mono (a4), and so on, depending on how many channels the clip has.
Levels, pan settings, and filters applied to one mono channel are not applied to the
other.
If a clip contains a stereo pair of audio channels:
• In the Timeline: The pair is treated as a single linked item. Stereo pair items are always
the same length, and they cannot be modified or selected independently. If you select
a stereo pair of audio items in the Timeline, you must select both together, even if
linked selection is turned off.
• In the Viewer: The stereo pair appears in a single tab, called Stereo (a1a2). If multiple
stereo pairs are linked together, the numbers used by each successive stereo pair
increase, for example, Stereo (a3a4), Stereo (a5a6), and so on. The waveforms of both
audio channels are displayed in this one tab, and any levels or effects applied to one
track are automatically applied to the other.
Details on creating or separating stereo pairs are given in “Audio Editing Basics.”
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Synchronizing Dual System Recorded Video and Audio
If you are working with captured audio and video from different sources (dual system
recording), you’ll probably want to link the audio and video clips by merging them into
single clips in the Browser after syncing them. This way you can easily work with them
as single clips in the Timeline or the Browser, as if you had captured each one as a single
clip and media file. Before actually merging two or more clip items, you first need to find
a synchronization point between them. There are different ways of doing this, depending
on how you shot your footage. See “Merging Clips from Dual System Video and Audio”
for details.
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Split Edits

41

This chapter covers the following:
• Learning About Split Edits (p. 607)
• How Split Edits Look in the Viewer and Canvas (p. 608)
• Setting Up Split Edit Points in the Viewer (p. 609)
• Setting Up a Split Edit While Playing a Clip (p. 610)
• Modifying and Clearing Split Edits (p. 611)
• Split Edit Examples (p. 613)
When video and audio are cut at the same time, the edit is usually more noticeable. Split
edits help to “soften” edits by creating continuous audio beneath video edit points.

Learning About Split Edits
Final Cut Pro allows you to set separate video and audio In and Out points. These edits
are known as split edits. Split edits are useful for conversation scenes, where the video
and audio of two actors overlap. You can also use split edits to introduce the sound of a
new scene before cutting to the video.
For example: You are editing a sequence in which a man and a woman are talking to
each other. It’s common during a conversation scene to cut to the video of one person
listening while the audio from the other person continues. You use a split edit to achieve
this effect. This is how you would achieve the effect:
• Cut to the video and audio of the man talking.
• In the middle of the man talking, overwrite the video of the man talking with the video
of the woman listening, while the audio of the man talking continues.
• Once the man finishes talking, cut to the audio of the woman, now talking.
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The resulting edit would look something like this:
Video edit point

Video track

Audio tracks

Audio edit point

Split edits can be used in many different situations—in dialogue scenes, like the one
described above, when cutting to illustrative B-roll footage during an interview, or when
transitioning from one scene to another.

How Split Edits Look in the Viewer and Canvas
The scrubber bar in both the Viewer and the Canvas is divided in half by a light gray line.
The upper half of the scrubber bar contains the video In and Out points, and the lower
half contains the audio In and Out points.
When you set simple In and Out points, each pair of audio and video In and Out points
joins to form small, inward-pointing triangles.
In point

Out point
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When you set video edit points that are different from the audio edit points, as you do
for a split edit, the upper half of each triangle marks a video In or Out point, and the lower
half marks the separate audio edit point, like this:
Video In
point

Area of video
included in edit

Audio In
point

Video Out
point

Audio Out
point
Area of audio
included in edit

As with other types of edits, the Viewer scrubber bar shows edit points in your clip, while
the Canvas scrubber bar shows edit points in your sequence. The light area between each
set of edit points in the Viewer indicates which parts of the audio and video clip items in
your source clip will be cut into your sequence. The light area between each set of edit
points in the Canvas indicates where the audio and video clip items will appear in your
sequence.

Setting Up Split Edit Points in the Viewer
There are several ways you can create a split edit:
• Set separate video and audio edit points for the clip in the Viewer before you edit the
clip into the Timeline.
• Edit your clips into the Timeline with standard In and Out points, and then trim the
video or audio clip items independently by turning off linked selection. The Roll tool
is the most common tool for adjusting an edit point in the Timeline. For more
information, see “Learning About Trimming Clips.”
It is more common to edit clips into a sequence and then create split edits in the Timeline,
but there may be times when you want to set split edit points in the Viewer as well.
To set up a split edit in the Viewer
1 Double-click a clip in the Browser to open it in the Viewer.
2 Move the playhead to the location in your clip where you want to set the video In or Out
point (separate from the audio).
3 To set a video In or Out point, do one of the following:
• Choose Mark > Mark Split, then choose either Video In or Video Out from the submenu.
• Control-click in the scrubber bar, choose Mark Split from the shortcut menu, then
choose either Video In or Video Out from the submenu.
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• Press Control-I to set a video In point, or press Control-O to set a video Out point.
4 Now move the playhead to the location in your clip where you want to set your audio In
or Out point.
5 To set an audio In or Out point, do one of the following:
• Choose Mark > Mark Split, then choose either Audio In or Audio Out from the submenu.
• Control-click in the scrubber bar, choose Mark Split from the shortcut menu, then
choose either Audio In or Audio Out from the submenu.
• Press Command-Option-I to set an audio In point, or press Command-Option-O to set
an audio Out point.
The resulting combination of video and audio edit points in your scrubber bar should
look something like this:

Once you’ve set your split edit points, you can perform your edit by using an overwrite
edit or dragging directly into the Timeline.

Setting Up a Split Edit While Playing a Clip
You can mix and match simple edit points with split edit points, depending on what kind
of edit you want to do. In fact, it’s very common to first set a simple edit point, and then
change it to a split edit while your clip is still playing.
To change a simple edit to a split edit while playing a clip
1 Open a clip in the Viewer.
2 Play your clip.
3 At the frame where you want either your video or audio to start, press I to set an In point.
4 As your clip continues playing, do one of the following:
• To set a split video In point later than the audio In point, press Control-I.
• To set a split audio In point later than the video In point, press Command-Option-I.
5 As your clip continues playing, set an Out point at the new location by pressing the O
key.
6 If you want to set an additional split edit at the end of your clip, let playback continue
and do one of the following:
• To set a split video Out point, press Control-O.
• To set a split audio Out point, press Command-Option-O.
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7 Stop playback by pressing the Space bar.
Once you’ve set your split edit points, you can perform an overwrite edit or drag the clip
directly into the Timeline.
You can also set split edit points in the Timeline using the same keyboard shortcuts.

Modifying and Clearing Split Edits
If you’ve set up a split edit, but you want to adjust or remove any of the edit points, you
have a number of options.

µ

To move the In and the Out point of a split edit at the same time
Drag either the video or audio In or Out point to a new position.
By default, the video or audio edit points move together.

µ

To move either an audio or video split edit point individually
Option-drag just the split edit point you want to move.
That edit point moves independently of the others.

As you drag, a small box
displays the timecode
number you are moving
the edit point to.

To move all split edit points at once
Do one of the following:

µ
µ

Shift-drag any of the edit points.
Select the Slip tool in the Tool palette, then drag any of the edit points.

Slip tool
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The positions of the different edit points you’ve selected don’t change relative to one
another, but the selected area of your clip or sequence does. As it changes, you’ll see the
first selected frame of video updated in the Viewer, and the last frame of video updated
in the Canvas.

The Canvas displays
the frame of the new
Out point.

The Viewer displays
the updated frame of
the In point with the
new timecode value.

If you make the changes in the Timeline, you’ll see a two-up display in the Canvas, showing
the updated frames.

Two-up display
in the Canvas

To remove one or more split edit points
Do one of the following:
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µ

Choose Mark > Clear Split, then choose the edit points you want to remove from the
submenu.

µ

Control-click the split edit point, choose Clear Split from the shortcut menu, then choose
the edit point you want to remove from the submenu.

µ
µ
µ

To clear both of your split In points, press Option-I.
To clear both of your split Out points, press Option-O.
Drag a split edit point up or down out of the scrubber bar until it disappears, then release
the mouse button.
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Split Edit Examples
The result of your split edit depends on the edit points you set. This section provides
several examples of the combination of simple edit points and split edit points you might
set up, along with their results.

Example: Split Edit in the Viewer and a Simple Edit Point in the Canvas
If you set up a split edit in the Viewer and set a simple In point in the Canvas or Timeline
(or if you simply use the position of the Canvas/Timeline playhead), Final Cut Pro lines
up the earliest audio or video split edit point set in the Viewer (whichever appears first)
with the In point you’ve set in the Canvas or Timeline.
To set a split edit in the Viewer and set an In point in the Canvas or Timeline
1 Set up a split edit in the Viewer, with the audio In point preceding the video In point.
2 Set an Out point in the clip in the Viewer.

The resulting edit points
look like this.

3 Position the playhead in the Canvas or Timeline at the place where you want the audio
of your source clip to start, or set a simple In point.
In point

4 Drag the clip in the Viewer to the Overwrite section of the Edit Overlay in the Canvas.
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The resulting edit looks like this:

The audio precedes the video and begins at the sequence In point.

Example: Split Edit in the Viewer and a Single Split Edit Point in the
Canvas
If you set up a split edit in the Viewer and set a single split edit point in the Canvas or
Timeline, Final Cut Pro matches the appropriate split edit point in the Timeline to the
corresponding audio or video split edit point in the Viewer; audio to audio, or video to
video. The other, overlapping media extends before or after this edit point as necessary.
This method can be used to backtime a split edit, as well.
To set a split edit in the Viewer and set a single split edit point in the Canvas or Timeline
1 Set up a split edit in the Viewer, with the audio In point preceding the video In point.
2 Set an Out point in your clip in the Viewer.

The resulting edit points
look like this.

3 Set a single split video In point in the Canvas or Timeline at the place where you want
the video of your source clip to start.
Split video In point
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4 Drag the clip in the Viewer to the Overwrite section of the Edit Overlay in the Canvas.
The resulting edit looks like this:
Video begins at the
In point you set.

Audio precedes the video.

Example: Simple Edit in the Viewer and a Split Edit in the Canvas
If you set simple edit points in the Viewer and a split edit in the Canvas or Timeline,
Final Cut Pro lines up the In point of the clip in the Viewer with the corresponding split
audio or split video In point that you set in the Canvas or Timeline. This method can be
used to backtime a split edit, as well.
To set edit points in the Viewer and a split edit in the Canvas or Timeline
1 Set an In point in your clip in the Viewer.
2 Set an Out point in your clip in the Viewer.

The resulting edit points
look like this.
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3 Set up a split edit in the Canvas or Timeline at the place where you want your source clip
to appear.
Split edit with audio
preceding video

4 Drag the clip in the Viewer to the Overwrite section of the Edit Overlay in the Canvas.
The resulting edit looks like this:
Video begins at the
split video In point.

Audio precedes the
video and begins at
the split audio In point.
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This chapter covers the following:
• About Multiclips (p. 618)
• Multiclip Workflow (p. 619)
• Preparing Clips to Be Used as Multiclip Angles (p. 621)
• Creating Individual Multiclips (p. 622)
• Creating Multiclip Sequences (p. 626)
• Identifying and Naming Multiclips in the Browser (p. 636)
• Working with Multiclip Angles in the Viewer (p. 637)
• Editing with Multiclips in Real Time (p. 644)
• Using Keyboard Shortcuts and Shortcut Buttons for Multiclip Editing (p. 644)
• Editing Multiclips into the Timeline (p. 645)
• Switching and Cutting Between Angles (p. 646)
• Editing in Multiclip Playback Mode (p. 652)
• Applying Filters, Speed, and Motion Parameters to Multiclips (p. 654)
• Collapsing and Expanding a Multiclip (p. 656)
• Working with Multiclip Master-Affiliate Relationships (p. 657)
• Match Frame Commands Used with Multiclips (p. 658)
• Media Management and Project Interchange (p. 659)
The multiclip features in Final Cut Pro allow you to group multiple camera angle clips
together and switch or cut between them in real time.
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About Multiclips
A multiclip is a set of clips grouped together and synchronized by a common sync frame.
Each clip in a multiclip is known as an angle, and you can switch between angles as
necessary. The angle whose video and audio is seen and heard when you play your
sequence is called the active angle.
Sync point
Multiclip
Angle 1
Angle 2

Active angle

Angle 3
Angle 4

Multiclips can be used to edit footage from multicamera shoots or other synchronized
footage in real time. For example, if you shot a live concert with four different cameras,
you can synchronize the angles together into a single multiclip and cut between them
in real time.
You can also group unrelated footage together for real-time montage editing (such as
for music videos). For example, if you are editing a music video, you could add several
angles of abstract visuals and cut to those angles on specific beats of the music.
Working with multiclips in Final Cut Pro is a flexible and fluid process. While the active
angle plays in the Canvas, you can also view all angles playing simultaneously in the
Viewer. You can add or remove angles from a multiclip at any time, and easily adjust the
synchronization between angles after you have created the multiclip.
Angles appear in the
Viewer, with the active
angle highlighted.

The active angle plays
in the Canvas.

Multiclips have the following limitations and requirements:
• Clips in a multiclip are not required to have the same duration, but they must all use
the same codec, image dimensions, and frame rate.
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Important: The same capture preset should be used for all footage you plan to make
into a multiclip.
• Multiclips can be created from any clips in the Browser: video and audio clips, still
images and graphics, and even other multiclips.
• Multiclips can have a maximum of 128 angles, but only the first 16 can be played back
in real time.
• Each angle can be a clip with video and audio, video only, or audio only.
• A multiclip can have only one active video item and up to 24 active audio items at a
time.
• The number of audio items in a multiclip is determined by the angle with the highest
number of audio items.
For example, consider a multiclip that contains three angles with the following number
of items:
• Angle 1: 2 audio items
• Angle 2: 4 audio items
• Angle 3: 8 audio items
The resulting multiclip has 8 audio items. Extra empty audio items are added to angles
1 and 2 so that all angles have the same number of audio items.
• The active video and audio items can be independently switched to different angles.

Multiclip Workflow
The following steps describe the basic multiclip workflow in Final Cut Pro:
Stage 1: Shooting an Event with Multiple Cameras and Recording Appropriate Sync
Information
A multicamera shoot uses multiple cameras to record the same subject or event from
different angles and distances. The recorded tapes are known as iso reels (short for isolated
reels) because each camera angle is recorded separately.
In professional multicamera shoots, each camcorder or VTR receives the same timecode
from a master timecode generator, or you can jam sync the timecode generator of each
camera at the beginning of the shoot. If you are using consumer DV camcorders, which
cannot accept external timecode, you need to record a visual cue, such as a clapboard
closing or a camera flash, on all cameras. You can use this to synchronize the clips together
during post-production.
Stage 2: Logging and Capturing Multicamera Footage
Log and capture each tape as individual clips, or use Capture Now to capture the entire
length of each tape.
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Important: Make sure to log an angle number for each clip you capture. Final Cut Pro
uses a clip’s Angle property to determine how it is sorted within a multiclip.
If you capture entire reels using Capture Now, you can break your footage into shorter
subclips. For more information, see “Creating Subclips.”
Stage 3: Creating Multiclips, Assigning a Clip from Each Camera to a Different Angle
In the Browser, select the clips, subclips, or bins of clips that you want to group together
into a multiclip. You can create multiclips using either the Make Multiclip or the Make
Multiclip Sequence command.
• Make Multiclip: Creates one multiclip at a time, synchronizing each angle by In point
or Out point (such as the frame where the slate closes), or timecode.
• Make Multiclip Sequence: Creates many multiclips at once and places them in a new
sequence in chronological order. This command uses timecode to synchronize angles,
and gives you options for synchronizing clips that were recorded with the same
timecode, but have slightly different starting and ending timecode numbers.
When creating a multiclip, you can choose one of several methods to synchronize the
clips, such as by In point, Out point, or matching timecode. After a multiclip is created,
you can rearrange, add, and delete angles in the Viewer.
For more information, see “Working with Multiclip Angles in the Viewer.”
Stage 4: Editing Multiclips into a Sequence
Once you edit a multiclip into a sequence, you can turn on the Multiclip Playback option
to watch all angles simultaneously in the Viewer while switching or cutting to different
angles in real time in the Canvas. The Multiclip Playback option allows you to cut an entire
show as if it were live, and then fine-tune your edits in the Timeline just as you would for
any other program.
You can cut and switch between video and audio at the same time or independently.
For example, you can use the audio from angle 1 while switching the video between
angles 1–4. For more information, see “Editing with Multiclips in Real Time.”
Stage 5: Collapsing Multiclips to the Active Angle
After you have finished editing, you can collapse multiclips in the Timeline to the currently
active angle, at which point you can work with them as regular clips. This is useful when
you transfer your project to a color correctionist, effects artist, or audio engineer who
only needs to see the active angles you chose during editing. Collapsing a multiclip is
not permanent. If you need to make multiclip changes later, you can expand the multiclip
and all of the angles become available. For more information, see “Collapsing and
Expanding a Multiclip.”
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Stage 6: Outputting to Tape or Exporting to a QuickTime Movie or a Project
Interchange Format
You can output multiclip sequences to tape or export to a project interchange format,
such as an EDL, OMF, or XML file. For compatibility with other video editing systems, most
output and export formats only include the active angle. The Final Cut Pro XML Interchange
Format supports export of all multiclip angle information, while EDL and OMF files only
include information about the currently active angle of each multiclip.

Preparing Clips to Be Used as Multiclip Angles
Before you create multiclips, you must assign an angle number to each clip, or name the
clips so that Final Cut Pro can derive angle numbers automatically. Final Cut Pro looks for
angle numbers in several places, in the following order:
• Angle property of the clip: This may be a number or a letter. Final Cut Pro interprets
letters A-E as angle numbers 1–5, respectively.
• Clip name using Cinema Tools clip-naming conventions: Cinema Tools uses a standard
clip-naming convention that contains the angle name. For more information, see
“Cinema Tools Clip-Naming Conventions.”
• Reel name: For many multicamera shoots, the reel name also indicates the camera
angle. For example, on a four-camera shoot, reel names 1–4 may indicate camera angles
1–4.
• Media filename: If no other angle information is found, Final Cut Pro looks at the names
of the media files to sort angles within the multiclips.

Assigning Angle Numbers to Clips
When you create a multiclip, the selected clips’ angle numbers determine the order in
which the clips are sorted within the multiclip.
You can assign angle numbers to clips in the Log and Capture window, in the Item
Properties window, or in the Browser.
To assign an angle number to a clip
1 Select a clip in the Browser whose Angle property you want to change.
2 Choose Edit > Item Properties > Format (or press Command-9).
3 Type a number or letter in the Angle field, then click OK.
Note: Final Cut Pro supports letters A-E as camera angles.
You can also change a clip’s Angle property in the Angle column in the Browser. For
information about using Browser columns, see “Browser Basics.”
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Cinema Tools Clip-Naming Conventions
Clips created in the film industry and logged in Cinema Tools often have names such as
“C-3-A2,” which indicates that:
• “C” is the scene
• “3” is the take
• “A2” is the camera (or angle)

Deriving Clip Angle Numbers from Reel Names and Filenames
When you create a multiclip, Final Cut Pro sorts the clips you selected by the values in
their Angle properties. If a clip’s Angle property is empty, Final Cut Pro looks at the clip
name, reel name, and finally the media filename to derive angle information. Final Cut Pro
assumes the first number in the reel name or filename is an angle number.
For example, you have three clips with the following names:
• Camera3_Take2
• Camera16_Take2
• Camera17_Take2
If all three clips’ Angle properties are empty, Final Cut Pro looks at the first number in
each clip name to determine the order in which to sort the clips. In this case, Final Cut Pro
would sort the clips in the following way:
• Camera17_Take2: This clip is considered angle “1” because Final Cut Pro only derives
angles 1–16 from a clip or reel name.
• Camera3_Take2: This clip is considered angle “3.”
• Camera16_Take2: This clip is considered angle “16.”
If two or more clips have the same angle number, Final Cut Pro sorts the clips in the order
that they appeared in your Browser selection and places clips with duplicate angle
numbers after the numerically sorted clips.
If Final Cut Pro cannot determine an angle number from a clip’s Angle property, reel
name, or media filename, clips are sorted alphabetically by filename and assigned the
remaining angle numbers in ascending order.

Creating Individual Multiclips
The Make Multiclip command allows you to make one multiclip at a time, grouping several
clips together that are synchronized by In point, Out point, or timecode number.
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About the Make Multiclip Dialog
The following options are available in the Make Multiclip dialog:
Choose a clip
synchronization
option.

This column shows
the relative alignment
of each angle in
the multiclip.

This column displays the
starting timecode
number of each clip.

Include Angle checkbox

• “Synchronize using” pop-up menu: Select In Points, Out Points, or Timecode to determine
the method you want to use for synchronizing your multiclip angles. For details, see
“Synchronizing Angles in a Multiclip.”
• Include Angle checkboxes: Deselect a checkbox if you don’t want to include a clip in the
multiclip you create.
• Media Alignment column: This column shows how each clip is synchronized within the
multiclip.
• Sync Time column: This column shows the starting timecode number of each clip.
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Synchronizing Angles in a Multiclip
When you create multiclips using the Make Multiclip command, you can choose to
synchronize the clips by In points, Out points, or matching timecode numbers.
In point

Out point

Timecode
01:00:00:00
01:00:00:00
01:00:00:00
01:00:00:00

• In points: This option aligns all clips so the In point of each clip is synchronized. If you
use this method, you first need to visually identify a common sync point (such as a
clapboard closing) in each clip by setting an In point. If a clip has no In point set, the
Media Start is used.

In point of each clip

• Out points: This option aligns all clips so the Out point of each clip is synchronized.
Before you use this method, you need to establish a common sync point by setting an
Out point in each clip. This method is useful if your footage has a tail slate (a clapboard
recorded after a scene ends). If a clip has no Out point set, the Media End is used.

Out point of each clip

• Timecode: This option aligns all clips by the first timecode number in common. Normally,
you use this option with multicamera footage recorded with cameras or decks that
received the exact same timecode signal.
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This method works even if each clip has a different duration, as long as each clip has
an overlapping timecode number. For example, one clip may end at 01:00:00:00, and
a second clip may begin at 01:00:00:00, so the angles only overlap by a single frame.

Overlapping timecode
numbers

• Aux Timecode 1 or 2: These options are just like the timecode option above, but use
the Aux 1 or Aux 2 timecode track in each clip’s media file. These options are useful
when you want to synchronize via timecode, but your clips’ main timecode tracks were
not recorded in sync. Although you could modify your clips’ source timecode tracks,
it’s better not to do this because this makes recapturing media from tape impossible.
Instead, you can add an auxiliary timecode track to each clip’s media file so that the
clips align on a common timecode number.
For more information about modifying or adding timecode tracks to a clip’s media file,
see “Modifying Timecode in Media Files.”
Note: Aux 1 or Aux 2 timecode must exist in all selected items or these options are not
available.
You can use the Viewer to adjust an angle’s synchronization after you create a multiclip.
For more information, see “Resynchronizing Angles in the Viewer.”

Creating a Multiclip
Once you have clips prepared, you can group them together into a multiclip.
To create a multiclip
1 Assign angle numbers to each clip you want to include in your multiclip.
For more information, see “Deriving Clip Angle Numbers from Reel Names and Filenames.”
2 If you want to align your clips by In or Out points, open each clip in the Viewer and set
the appropriate In point or Out point.
3 In the Browser, select the clips you want to include in your multiclip.
Tip: You can also select one or more bins containing clips, or even other multiclips.
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4 Do one of the following:
• Choose Modify > Make Multiclip.
• Control-click one of the selected clips, then choose Make Multiclip from the shortcut
menu.
The Make Multiclip dialog appears, showing the angle order and relative media alignment
of the selected clips. If a clip’s Angle property is empty, Final Cut Pro looks at the reel
name or media filename to derive an angle number. See “Deriving Clip Angle Numbers
from Reel Names and Filenames” for more information.
5 Choose a synchronization method from the “Synchronize using” pop-up menu.
For more information about angle synchronization, see “Synchronizing Angles in a
Multiclip.”
6 If you don’t want to include a clip in your multiclip, deselect the checkbox next to the
clip.

This clip will not be
included when the
multiclip is created.

7 Click OK.
A new multiclip called “Multiclip N” appears in the Browser (where N is the automatically
assigned multiclip number). This number increments each time you create a new multiclip.
You can change the name of the multiclip at any time. For more information about naming
multiclips, see “Identifying and Naming Multiclips in the Browser.”

Creating Multiclip Sequences
The Make Multiclip Sequence command allows you to create multiple multiclips at the
same time. When you capture a lot of media files from a multicamera shoot, it can be
time-consuming to create multiclips one at a time using the Make Multiclip command.
When you need to make a lot of multiclips at the same time, you can use the Make
Multiclip Sequence command to create multiclips based on the starting timecode numbers
of your clips.
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Consider the following example. Suppose you recorded a soccer game with four
camcorders (each starting with the same timecode), and you captured each reel as ten
individual media files (each representing a different phase of the event). The total number
of clips in your project is 40 (4 reels x 10 media files). Instead of creating each of the ten
multiclips individually, you can select all the clips at once and use the Make Multiclip
Sequence command. A sequence containing ten multiclips is created and the multiclips
are placed in chronological order.

When Should You Use the Make Multiclip Sequence Command?
You may want to use the Make Multiclip Sequence command in the following situations:
• Whenever you have a large number of clips or subclips that you want to make into
multiclips.
• If you have footage from a professional multicamera production, in which all tapes
recorded matching timecode from a master timecode generator.
• If you have footage in which all the tapes begin with matching timecode, but some
camcorders recorded continuously while others stopped and started. As long as events
occur on each tape at the same timecode number, you can use the Make Multiclip
Sequence command.
Important: If you shot an event with camcorders that were not recording simultaneous
identical timecode, you should use the Make Multiclip command and use In or Out
points to visually synchronize each camera angle. For more information, see “Creating
Individual Multiclips.”

About the Make Multiclip Sequence Dialog
The Make Multiclip Sequence dialog works similarly to the Make Multiclip dialog, but
there are some important differences.
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The Make Multiclip Sequence command always groups clips together into multiclips
assuming that your footage has matching timecode, so that the same event is recorded
on each tape at the exact same timecode number. However, since some cameras may
not be continuously recording during the shoot, and you may not always capture media
files with exactly the same start and end timecode numbers from each reel, the Make
Multiclip Sequence dialog provides options for grouping clips using a specified range of
starting timecode numbers. This range is referred to as the timecode synchronization offset.
Timecode
Synchronization
pop-up menu
Offset value

Media Alignment column
Sync Time column

Multiclip grouping area

Clips with starting
timecode numbers
within a specified
range are grouped
together as a multiclip.

Include Angle checkbox

Shows the relative
alignment of each
angle in the currently
grouped multiclips.

• Timecode Synchronization pop-up menu and value: You can adjust the timecode
synchronization offset so that clips with slightly different starting timecode numbers
are grouped together into one multiclip. This allows you to group together clips that
have overlapping timecode numbers but not the same starting timecode number. This
may happen if you captured your clips using Capture Now, or if several of your
camcorders started later than the others.
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There are two choices for timecode synchronization:
• Use Starting Timecode/Starting timecode delta: This option allows you to set a specific
timecode offset value when your clips are grouped together as multiclip angles. For
example, if you enter 1:00 in the “Starting timecode delta” field and then click Update,
the following clips would be grouped together in a multiclip: clip A (01:00:10:00),
clip B (01:00:09:00), and clip C (01:00:11:00). Any clips that fall within this +/–1:00
range would also be grouped together, such as clip D (01:00:10:15) and clip E
(01:00:09:06).
• Use Overlapping Timecode/Minimum overlap: This option allows you to choose how
much clips’ timecode numbers must overlap to be grouped together into a multiclip.
The lower you set this percentage, the less clips’ timecode must overlap to be grouped
together. For example, if you enter 100% in the “Minimum overlap” field, multiclips
are only created with clips that have the same exact starting and ending timecode
numbers. For more information, see “Choosing a Timecode Synchronization Option.”
• Update button: Click here to update the current multiclip grouping based on the value
in the “Starting timecode delta” field. This button only appears when you select Use
Starting Timecode from the Timecode Synchronization pop-up menu.
• Automatically edit new multiclip(s) into a new sequence: If you select this option, a new
sequence with settings that match your multiclips is created. The new sequence contains
each multiclip in chronological order. This effectively re-creates the entire live event
as a sequence of multiclips.
• Include Angle checkbox: Deselect the checkbox for a clip if you don’t want to include
the clip in the multiclip you create.
• Multiclip grouping area: Your selected clips are displayed as one or more multiclips,
sorted and grouped based on the timecode of each clip. By default, if the starting
timecode numbers of two or more clips are the same, they are grouped together into
a multiclip. If a clip has a unique starting timecode number, it is grouped as its own
multiclip.
Note: You can adjust the timecode synchronization offset to group multiclips differently.
• Media Alignment column: This column shows how each clip is synchronized within the
multiclip.
• Sync Time column: This column shows the starting timecode number of each clip.

Choosing a Timecode Synchronization Option
The Make Multiclip Sequence dialog has several options, one of which is the type of
timecode synchronization you want for the sequence. For example, you have the following
two clips:
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Name

Timecode

Duration

Overlaps other
clip

Overlap duration

Clip A

01:00:00:00–02:00:00:00

01:00:00:00

01:30:00:00–02:00:00:00

00:30:00:00

Clip B

01:30:00:00–02:15:00:00

00:45:00:00

01:30:00:00–02:00:00:00

00:30:00:00

In this case, if you set the minimum overlap value to 66% (or any value lower than this),
clip B is grouped together with clip A into a single multiclip. This is because 66% of clip
B’s timecode numbers overlap clip A’s timecode numbers.

Minimum overlap
is set to 66%.

For more information, see “Creating a Multiclip Sequence.”

Creating a Multiclip Sequence
Once you have clips prepared, you can group them together into multiclips and
automatically create a multiclip sequence.
To create a multiclip sequence
1 Select multiple clips in the Browser, or select one or more bins of clips.

2 Choose Modify > Make Multiclip Sequence.
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The Make Multiclip Sequence dialog appears. Clips with the same starting timecode
numbers are grouped into multiclips, and clips with unique starting timecode numbers
are grouped into separate multiclips.

Clips with the same
starting timecode
number are grouped
together as a multiclip.

Each clip with a unique
starting timecode
number is placed in a
separate multiclip.

If your clips have different starting timecode numbers, you can adjust the timecode offset
to change how clips are grouped into multiclips.
3 Choose one of the following options from the Timecode Synchronization pop-up menu:
• Use Starting Timecode
• Use Overlapping Timecode
4 Depending on which timecode synchronization option you chose above, do one of the
following:
• Enter a value in the “Starting timecode delta” field, then click Update.
• Enter a percentage in the “Minimum overlap” field, or drag the slider.
You can also click the triangles to the left and right of the slider to increment the
percentage one whole number at a time.
The clips are shown in new multiclip groupings based on the options you chose. If the
clips are still not grouped as you want, repeat the last step.
5 Deselect the Include Angle checkbox for any angles you don’t want to include in your
multiclips.
6 Select the “Automatically edit new multiclip(s) into a new a sequence” option to create
a sequence containing your new multiclips.
7 Click OK.
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A new sequence is created that contains all of the multiclips in chronological order. The
location of the multiclips in the Timeline is based on the starting timecode number of
each multiclip.
Sequence starting
timecode is the same as
the starting timecode of
the first multiclip.

Multiclip
sequence

Multiclips placed
chronologically into
the sequence

Multiclips created using
Make Multiclip Sequence

Note: If the combined length of all the multiclips exceeds the maximum allowed sequence
length, multiple sequences are created.

Example: Creating Multiclips Using a Starting Timecode Offset
In this example, five camcorders recorded footage with consistently synchronized
timecode, but not all camcorders started at exactly the same moment. As a result, the
captured media files do not all have the same starting timecode number, even though
they show the same visual events occurring at the same timecode numbers. Some clips
are offset from each other by 1:00 (1 second) or less, while others are offset by as much
as 10:00. The goal is to create three multiclips, each containing five angles.
By adjusting the starting timecode offset value and clicking the Update button, you can
precisely control how clips are grouped together into multiclips.

632

Chapter 42 Working with Multiclips

Starting Timecode Offset Is 0:00
When the “Starting timecode delta“ field is set to 0:00, most of the clips are grouped as
individual multiclips. Only the few clips that have the exact same starting timecode
numbers are grouped together. To group more of the clips into fewer multiclips overall,
a larger timecode offset is needed.

Timecode offset
is set to 0:00.

Starting Timecode Offset Is 5:00
In this example, clips that have starting timecode numbers within a 5-second range are
grouped together. The first multiclip contains five angles, but the other multiclips are not
yet grouped properly. A larger timecode offset is required.

Timecode offset
is set to 5:00.
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Starting Timecode Offset Is 10:00
In this example, clips that have starting timecode numbers within a 10-second range are
grouped together. There are now three multiclips, each containing five angles.

Timecode offset
is set to 10:00.

Example: Creating Multiclips Using the Minimum Overlap Options
In this example, five camcorders recorded footage with consistently synchronized
timecode, but not all camcorders started at exactly the same moment. As a result, the
captured media files do not all have the same starting timecode number, even though
they show the same visual events occurring at the same timecode numbers. Some clips
are offset from each other by 1:00 (1 second) or less, while others are offset by as much
as 10:00. The goal is to create three multiclips, each containing five angles.
When you adjust the minimum overlap percentage value, the multiclip grouping is
automatically updated. When the starting timecode numbers of each group of angles
varies significantly, this method is often faster and more intuitive than the Use Starting
Timecode option.
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Minimum Overlap Is 100%
When the minimum overlap is set to 100%, only clips with exactly matching timecode
numbers are grouped together.
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Minimum Overlap Is 38%
In this example, the clips are properly grouped into multiclips when the minimum overlap
is set to 38%. Because this value is set quite low, the timecode overlap between clips only
needs to be 38% of the duration of the longest clip for the clips to be grouped together
into a multiclip. Depending on the timecode of your footage, you’ll need to set a different
value to group your clips into multiclips as you intend.

Note: With some minimum overlap percentages, the same clip may be grouped into
more than one multiclip at a time. In this case, you can either adjust the minimum overlap
to correct this, or you can simply deselect the Include Angle checkbox for any clips you
do not want to include in a multiclip.

Identifying and Naming Multiclips in the Browser
A multiclip can be identified in the Browser by its multiclip icon and the fact that its name
is italicized. The name of a multiclip appears in the following format:
ANGLE NAME [ANGLE NUMBER]-MULTICLIP NAME
A multiclip has a Name property like any other clip, but the multiclip’s active angle name
and number are added before the multiclip name. For example, consider a multiclip
named “Multiclip 1.” If the active angle is 3, and the clip contained in that angle is named
“Firefly Close Up,” the multiclip’s displayed name in the Browser is “Firefly Close Up
[3]-Multiclip 1.” If you switch to angle 4, the multiclip’s displayed name changes to “Firefly
Wide Shot [4]-Multiclip 1.“
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When you highlight a multiclip to change its name, only the name of the multiclip itself
can be changed, since the other parts of the name are added automatically.
To change the name of a multiclip
1 Click a multiclip in the Browser to select it.
2 Click the name of the multiclip.
The name of the multiclip is highlighted.
3 Type a new name for the multiclip, then press Return or Enter.

Working with Multiclip Angles in the Viewer
You can use the Viewer to display, rearrange, resynchronize, and switch between the
angles of a multiclip.

Viewing Multiclip Angles in the Viewer
When you open a multiclip in the Viewer, multiple angles are displayed simultaneously
in a grid. You can choose to view 1, 4, 9, or 16 angles at a time.
View pop-up menu

4-up view

µ

9-up view

To change the number of multiclip angles shown in the Viewer
Choose a multiclip view option from the View pop-up menu.
For example, if you want to view 9 angles at once, choose Multiclip 9-Up from the View
pop-up menu.
If your multiclip has more angles than are currently displayed, you can scroll up or down
in the Viewer using the multiclip scroll arrows that appear when you place the pointer
in the Viewer.

To scroll to view angles that are not currently visible in the Viewer
1 Move the pointer over any video in the Viewer.
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An up or down arrow (or both) appears in the Viewer.
Click the arrow to view
additional angles.

If an arrow is green, the active angle is not visible, but you can scroll to it by clicking the
arrow.
2 Click an arrow to scroll the angles up or down by one row.
The active video angle is highlighted with a blue outline, and the active audio angle is
highlighted with a green outline. If an angle doesn’t have media at the current time, or
if it is an audio-only angle, a black frame is shown for that angle. If an angle is offline, a
“Media Offline” frame is shown. The currently active audio clip items appear in the Audio
tab.

Identifying Active Video and Audio Angles
There are several ways to determine the active video and audio angles of a multiclip in
the Viewer:
• Colored outlines: The active video and audio angles are highlighted in specific colors.
• Blue: Indicates the active video angle.
• Green: Indicates the active audio angle.
• Blue and green: Indicates that the active video and audio come from the same angle.
The active video angle
has a blue outline.

The active audio angle
has a green outline.

• Playhead Sync pop-up menu: Checkmarks appear next to the active video and audio
items.

638

Chapter 42 Working with Multiclips

Viewing Multiclip Overlays
You can display information about each angle in a multiclip by turning on multiclip
overlays in the Viewer.
The following information appears when you turn on multiclip overlays:
• Angle number
• Angle’s clip name
• Timecode number for each angle frame currently displayed in the Viewer
Note: The current timecode number is always the clip’s source timecode.

µ

To turn on multiclip overlays in the Viewer
Choose Show Multiclip Overlays from the View pop-up menu.
Angle number
View pop-up menu

Angle timecode

Angle name

Multiclip overlays are only visible during scrubbing, not during playback.
Note: Title safe and standard timecode overlays are not available when a multiclip is open
in the Viewer.

Rearranging and Deleting Multiclip Angles in the Viewer
After you create a multiclip, you can rearrange the order of the angles in the Viewer or
delete angles you don’t want. However, you cannot overwrite or delete the active angle.
Important: These operations change the angle structure of the multiclip, which breaks
the multiclip master-affiliate relationships. For more information, see “Working with
Multiclip Master-Affiliate Relationships.”
To move an angle to a different position in a multiclip
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Command-click the angle you want to move and drag it over an existing angle.
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The other angles shift position to make room for the angle you are moving.

3 Release the mouse button.
The moved angle is dropped into its new position and the other angles shift to new
positions. All of the angle numbers change accordingly.
To delete an angle from a multiclip
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Command-click the angle you want to delete and drag it outside of the Viewer, then
release the mouse button.
The dragged angle is deleted from the multiclip, and the other angles shift position to
fill in the empty space.

Adding Angles to a Multiclip in the Viewer
Once you create a multiclip, you can drag clips from the Browser to the Viewer to insert
new angles or overwrite existing ones.
Important: With one exception (see below), these operations change the angle structure
of the multiclip, which breaks the multiclip master-affiliate relationships. For more
information, see “Working with Multiclip Master-Affiliate Relationships.”
When you drag a clip from the Browser to a multiclip in the Viewer and hold down the
mouse button, colored overlays appear with angle insertion and overwrite options:
• Insert New Angle
• Insert New Angle Affiliates
• Overwrite Angle
Note: The Overwrite Angle overlay does not appear when you place the pointer over the
active angle because you cannot overwrite the active angle.
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Inserting a New Angle
The Insert New Angle overlay inserts an angle only into the multiclip you are currently
inserting into. Modifying the angle structure of the multiclip breaks the relationship
between this multiclip and its master multiclip.
To insert a new angle into the current multiclip
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Drag a clip from the Browser or Timeline to one of the multiclip angles displayed in the
Viewer.
3 Continue to hold down the mouse button until the colored overlays appear in the Viewer.

Drag a clip to an angle,
then choose Insert
New Angle.

Note: If you place the pointer over the active angle, the Overwrite Angle overlay does
not appear.
4 Move the pointer over the Insert New Angle overlay, then release the mouse button.
The dragged clip becomes a new angle in the multiclip, and all subsequent angle numbers
are incremented by one.
Tip: You can add more than one angle to a multiclip at once by dragging more than one
clip to the Viewer.
Inserting a New Angle into Many Multiclips at Once
The Insert New Angle Affiliates overlay inserts an angle into all multiclips affiliated with
the one you are currently inserting into. Use this option to quickly insert a new angle into
many multiclips at once. This can be useful if you already have an edited multiclip
sequence created by switching and cutting, and you want to add a new angle to all of
the multiclips in that sequence.
For example: You are using multiclips to edit a multicamera television show in real time,
and you decide that you would like to add another angle to your multiclip. If you haven’t
started editing yet, you can probably just insert a new angle into the master multiclip.
But what if you have been editing for several days and you have hundreds of multiclips
in your sequence?
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If all of the multiclips are affiliated with a single master multiclip, you can insert a new
angle into all of the affiliated multiclips using the Insert New Angle Affiliates overlay.
To insert a new angle into all affiliated multiclips at the same time
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Drag a clip from the Browser to one of the multiclip angles displayed in the Viewer.
3 Continue to hold down the mouse button until the colored overlays appear in the Viewer.
4 Move the pointer over the Insert New Angle Affiliates overlay, then release the mouse
button.

Drag a clip to an angle,
then choose Insert New
Angle Affiliates.

The dragged clip becomes a new angle in the multiclip, as well as in all affiliated multiclips.
Overwriting an Angle
The Overwrite Angle overlay replaces an existing angle with a new clip. Modifying the
angle structure of the multiclip breaks the relationship between this multiclip and its
master multiclip. You cannot overwrite an angle for all affiliated clips at once.
To overwrite an existing multiclip angle with a different clip
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Drag a clip from the Browser or Timeline to the multiclip angle you want to replace in
the Viewer.
3 Continue to hold down the mouse button until the colored overlays appear in the Viewer.
Note: You cannot overwrite the active angle, so this overlay does not appear if you place
the pointer over the active angle.
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4 Move the pointer over the Overwrite Angle overlay, then release the mouse button.

Drag a clip to an angle,
then choose Overwrite
Angle.

The dragged clip replaces the angle in the multiclip.

Resynchronizing Angles in the Viewer
If you want to adjust the starting time of a multiclip angle relative to all the other angles,
you can scrub through a single angle in the Viewer to resynchronize it.
To adjust the relative start time of a multiclip angle
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Hold down the Control and Shift keys, then click the angle you want to adjust and drag
left or right.

Press Control and Shift
while dragging over an
angle in the Viewer.

The pointer becomes the Scrub tool. As you drag to the left or right, the video frames
jog backward or forward. A box with a positive or negative offset value also appears,
showing the number of frames you are adjusting this angle’s starting point relative to
the others.
3 Release the mouse button.
The angle is now resynchronized relative to the other angles in the multiclip. If you change
your mind, you can undo by pressing Command-Z.
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Editing with Multiclips in Real Time
Unlike traditional film and video editing, where each edit can be deliberated for as long
as necessary, live events like broadcast news and sports are edited in real time. For live
events, multiple cameras are connected to a single video switcher, which allows the
director (or technical director) to cut between camera angles, making instantaneous
editing decisions. The director usually watches all of the camera angles on a grid of
monitors, which helps when deciding which angle to switch to.
A multiclip behaves a lot like a video switcher during a live video event. A multiclip
contains multiple camera angles or other video sources, synchronized together. During
playback in the Timeline, you can switch or cut between these angles in real time, just
as you would with a video switcher during a live event. You can watch all the angles
simultaneously in the Viewer, so you can choose which angle you want to switch to next.
You can also switch or cut between angles when your sequence isn’t playing back. For
more information, see “Switching and Cutting Between Angles.”

Using Keyboard Shortcuts and Shortcut Buttons for Multiclip
Editing
To make editing more efficient, you can assign multiclip commands to custom keyboard
shortcuts in the Keyboard Layout tool. You can also add multiclip shortcut buttons to the
button bars in the Viewer, Canvas, Timeline, and so on.
You can assign the following multiclip commands to keyboard shortcuts or button bars:
• Switch Video to Angles 1–16
• Switch Video to Previous or Next Angle
• Switch Audio to Angles 1–16
• Switch Audio to Previous or Next Angle
• Cut Video to Angles 1–16
• Cut Audio to Angles 1–16
• Switch Video with Effects to Angles 1–16
• Switch Video with Effects to Previous or Next Angle
• Switch Audio with Effects to Angles 1–16
• Switch Audio with Effects to Previous or Next Angle
Tip: For a complete list of multiclip commands, choose Tools > Button List, then click the
disclosure triangle next to “Multiclip.“
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You can set any keyboard shortcuts you want for the multiclip commands in Final Cut Pro.
By default, most multiclip commands use the keys of the number pad with modifier keys
to switch and cut between multiclip angles. For more information on setting keyboard
shortcuts, see “Customizing the Interface.”
Final Cut Pro also comes with a preinstalled keyboard layout and button bars for
multicamera editing. These are usually sufficient for most multiclip editing.

µ

To load the built-in keyboard layout for multiclip (multicamera) editing
Choose Tools > Keyboard Layout > Multicamera Editing.

µ

To load the built-in button bars for multiclip editing
Choose Tools > Button Bars > Multiclip.
Note: All multiclip keyboard shortcuts and shortcut buttons can be used during playback
or scrubbing.

Editing Multiclips into the Timeline
You can edit with multiclips in the same way you edit with other clips. You can drag a
multiclip from the Browser or Viewer into the Timeline, or you can drag the multiclip to
a section of the Canvas Edit Overlay.
Note: Because clicking in the Viewer selects multiclip angles, you must hold down the
Option key if you want to drag a multiclip from the Viewer to the Timeline or Canvas to
make an edit.
To edit a multiclip from the Viewer to the Timeline or Canvas
1 Double-click a multiclip in the Browser to open it in the Viewer.
2 Set In and Out points for the multiclip in the Viewer.
3 Hold down the Option key while dragging from the Viewer to the Timeline or the Canvas
Edit Overlay.
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Switching and Cutting Between Angles
When you work with multiclips in Final Cut Pro, switching and cutting have distinct
meanings:
• Switching: This means changing the active angle of a multiclip without creating a cut.
You can switch the active angle of a multiclip in the Viewer or the Timeline.
Before the switch,
the active multiclip
angle is 1.

After the switch, the
active multiclip
angle is 4.
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• Cutting: Like switching, cutting changes the active angle of a multiclip, but an edit is
added to the multiclip at the moment you change the active angle. You can see the
results of cutting in the Timeline. When you cut from one angle to another, the result
is two multiclips in the Timeline: one before the cut point and one after.
Before the cut, the active
multiclip angle is 1.

A cut is added at the
point where the active
angle changes.

After the cut, the active
angle of the new
multiclip is 4.

Switching Angles
You can switch the active angle for a multiclip at any time, whether you are organizing
multiclips in the Viewer or playing multiclips in the Timeline. Using the Multiclip Playback
option, you can even switch angles while your multiclips play in real time.
To switch the active angle for a multiclip in the Viewer
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Do one of the following:
• Click an angle in the Viewer to make it active.
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• Choose a video or audio angle from the Playhead Sync pop-up menu in the Viewer.
• Press the assigned shortcut key to switch to the angle you want to make the active
angle.
For more information about using keyboard shortcuts for multiclip editing, see “Using
Keyboard Shortcuts and Shortcut Buttons for Multiclip Editing.”
To switch the active angle for a multiclip in the Timeline
Do one of the following:

µ

Control-click a multiclip in the Timeline, choose Active Angle from the shortcut menu,
then choose an angle from the submenu.

µ

When the playhead is over the multiclip whose angle you want to switch, press a keyboard
shortcut assigned to the Switch Video to Angle N command, where N is the angle number
you want to switch to.
If the Multiclip Playback option is turned on in the RT pop-up menu in the Timeline, you
can switch angles in real time while your sequence plays back. For more information, see
“Editing in Multiclip Playback Mode.”

Cutting Between Angles
Instead of simply switching the active angle of a multiclip in the Timeline, you can create
a cut in a multiclip whenever you change angles. You can even add edits to multiclips
during playback, allowing you to do real-time editing.
To cut to a multiclip angle using shortcut buttons or keyboard shortcuts
1 In the Browser, double-click a sequence containing multiclips to open it in the Timeline
and Canvas.
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2 Before editing, assign keyboard shortcuts to the Cut Video to Angle N commands, or add
the corresponding shortcut buttons to the button bar in the Timeline.
Cut Video to Angle
1–4 buttons

For more information about assigning keyboard shortcuts to commands or adding shortcut
buttons to the button bar, see “Customizing the Interface.”
3 Press a shortcut key or click a button in the button bar that corresponds to the angle you
want to cut to.
An edit is made to the multiclip at the current playhead location, separating it into two
multiclips. If you cut to the angle that was already active, a through edit is created.
If the Multiclip Playback option is turned on in the RT pop-up menu in the Timeline, you
can perform the same steps to cut in real time. For more information, see “Editing in
Multiclip Playback Mode.”
To make multiclip cuts in real time using the Viewer
1 In the Browser, double-click a sequence containing multiclips to open it in the Timeline
and Canvas.
2 Do the following:
• Turn on the Multiclip Playback option in the RT pop-up menu in the Timeline.
• In the Canvas or Viewer, choose the Open option from the Playhead Sync pop-up menu.
3 Press the Space bar to play the sequence.
The sequence begins playing back, with all the angles in the Viewer playing simultaneously
and the active angle playing back in the Canvas.
4 In the Viewer, click the angle that you want to cut to.
The angle you click becomes the active angle. A temporary marker is placed in the Timeline
at the cut point, and the new angle now plays in the Canvas.
5 If you want, continue adding cuts by clicking different angles in the Viewer.
6 Press the Space bar to stop playback.
When playback stops, the cuts you made are added to the multiclip.
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Switching and Cutting Video and Audio Items Separately
By default, when you switch or cut angles in a multiclip, both video and audio items of
a multiclip change together. Final Cut Pro allows you to change the active video and
audio items of a multiclip independently. This is helpful when you want to switch or cut
to a different video angle without changing the audio, or vice versa. For example: You
may need to cut video between four different camera angles, but keep dialogue audio
from angle 4 playing throughout. In this case, you need to tell Final Cut Pro to switch
only the video item, not the video and audio items together.
Note: A multiclip can have one active video item and up to 24 active audio items at a
time.
Video item

Individual audio items

When you switch video or audio independently, the results differ depending on whether
the multiclip in the Viewer is opened from the Browser or from a sequence. This is because
switching video and audio independently affects the linking relationships between video
and audio items.
• In a Browser clip: All items are always linked. Therefore, when you open a Browser
multiclip in the Viewer, all of the active audio items of the multiclip must come from
the same angle. Although you can switch video and audio items separately in a Browser
multiclip, you can’t switch individual audio items. For example, you have a 16-angle
multiclip with four audio items and you try to switch only audio item 4 to the audio in
angle 2, all four audio items switch to the audio items in angle 2.
• In a sequence multiclip: You can change each audio item independently. For example,
if you have a sequence multiclip with four audio items open in the Viewer, you can
independently cut to a new angle for audio item 4 without changing the angles for
audio items 1–3.
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However, independently switching video or audio angles breaks linking relationships
between a multiclip’s clip items in the Timeline. After you perform the switch, only the
audio item whose angle you switched remains linked to the video item.
After you switch
the active angle
for audio item 4...

These audio items are
no longer linked to
the video clip item.

...only audio item 4 is
changed, and remains
linked to the video item.

µ

To choose whether you switch or cut video, audio, or both at the same time
Choose View > Multiclip Active Tracks, then select one of the following options:
• Video + Audio: Both video and audio change at the same time.
• Video: Only video changes.
• Audio: The specified audio items change:
• All: All audio items change at once.
• A1+A2: Audio items 1 and 2 change simultaneously.
• A3+A4: Audio items 3 and 4 change simultaneously.
• A1: Only audio item 1 changes.
• A2: Only audio item 2 changes.
• AN: Only audio item N changes.
Note: The same menu items are available in the Playhead Sync pop-up menu in the
Viewer.

To switch only the video of the active multiclip angle in the Viewer
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Choose View > Multiclip Active Tracks > Video.
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You can also choose this option from the Playhead Sync pop-up menu in the Viewer.
3 Click an angle to make it active.
A blue outline highlights the active video angle.
To switch only the audio of the active multiclip angle in the Viewer
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Choose View > Multiclip Active Tracks > Audio.
You can also choose this option from the Playhead Sync pop-up menu in the Viewer.
3 Click an angle to make it active.
A green outline highlights the active audio angle.
Important: Final Cut Pro always remembers the last track switching mode you used, so
make sure you check this before you begin editing your multiclips.

Switching Angles on Locked Tracks
You cannot switch or cut a multiclip item in the Timeline if it is on a locked track. For
example, if you have a multiclip whose video clip item is placed on track V1 and you
choose View > Multiclip Active Tracks > Video and then lock track V1, you cannot switch
or cut to other video angles of that multiclip.
Furthermore, if you choose View > Multiclip Active Tracks > Video + Audio and then lock
any video or audio track in the Timeline that contains a multiclip item, you cannot switch
or cut that multiclip item.

Editing in Multiclip Playback Mode
The Multiclip Playback option allows you to switch and cut between multiclip angles in
real time. Multiclip Playback enables the following features:
• In the Canvas, you see an angle as soon as you switch or cut to it.
• In the Viewer, you see all of a multiclip’s angles playing simultaneously.
If you turn on the Open option in the Playhead Sync pop-up menu (in the Canvas or
Viewer), you can watch all of your multiclip angles playing simultaneously in the Viewer
while also seeing the results of switching and cutting in the Canvas, all in real time. When
you want to cut to a new angle, you simply click the angle in the Viewer. The active angle
switches to the angle you clicked, and a cut is added to your multiclip in the sequence.
To switch angles in real time, you can use assigned keyboard shortcuts or shortcut buttons
in the button bar.
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Note: If the Multiclip Playback option is not turned on, you can still switch and cut during
playback, but the angle in the Canvas is not updated until playback stops. Also, multiclip
angles are not played simultaneously in the Viewer. Instead, only the active angle is
played.
To set up Final Cut Pro to edit multiclips in real time
1 Choose Multiclip Playback from the RT pop-up menu in the Timeline.
This ensures that all multiclip angles play in real time in the Viewer.
Choose a multiclip view
from the View pop-up
menu.

Choose Open from the
Playhead Sync pop-up
menu.

Enable the Multiclip
Playback option in the
RT pop-up menu.
Select the active angle
in the Viewer.

2 Choose Open from the Playhead Sync pop-up menu in the Viewer or Canvas.
This option automatically opens the multiclip beneath the Timeline playhead in the
Viewer, so you can view all of its angles at once. This option and the Open playhead sync
option allow you to view all of your multiclip angles in real time while you play your
sequence.
3 Choose the number of multiclip angles you want to display in the Viewer from the View
pop-up menu.
To turn on the Multiclip Playback option
Do one of the following:

µ

Choose Final Cut Pro > System Settings, click the Playback Control tab, and then turn on
the Multiclip Playback option.
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Open a sequence that contains multiclips, then choose Multiclip Playback from the RT
pop-up menu in the Timeline.

Optimizing Real-Time Performance for Multiclip Playback
When the Multiclip Playback option is turned on, Final Cut Pro plays multiple media files
from disk at once. To improve playback performance, you can do the following:
• Use the fastest scratch disk available for your system. The speed of your scratch disk
and the data rate of your media files limit the number of streams you can play back in
real time.
• Reduce real-time playback quality in the Canvas. You can reduce playback quality in
the Canvas to improve multiclip playback performance. You can reduce both video
quality and frame rate. For more information about changing real-time playback settings,
see “Using RT Extreme.”
Note: Each angle of a multiclip in the Viewer uses the quality selected in the RT pop-up
menu in the Timeline.
• Choose dynamic real-time playback options from the RT pop-up menu. For more
information about changing real-time playback settings, see “Using RT Extreme.”
• Turn off the Show Source Angle Effects option in the View pop-up menu in the Viewer.

Viewing Multiclip Playback on an External Video Monitor
When the Multiclip Playback option is turned on, you can choose whether the Viewer or
the Canvas is displayed on an external video monitor.

µ

To see all multiclip angles displayed on your external video monitor during multiclip
playback
Choose View > Show Multiclip Angles, so that there’s a checkmark next to it.
Note: If no sequence is open, choosing the Show Multiclip Angles option has no effect.
In this case, you always see the Viewer on the external video monitor.

Applying Filters, Speed, and Motion Parameters to Multiclips
Individual angles can have filters, motion settings, and speed adjustments applied.
However, effects cannot be applied globally to a multiclip. For example, you can create
a multiclip in which each angle has an individual Color Corrector filter applied, but the
multiclip itself cannot have a Color Corrector filter applied. The Filters and Motion tabs
of a multiclip display filters and motion parameters for the active angle, not for the entire
multiclip.
Effects can be permanently applied to an angle when you create a multiclip. For example,
if you create a multiclip in which one of the selected clips has a Gaussian Blur filter applied,
that angle in the resulting multiclip will have a Gaussian Blur filter applied.
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Applying Filters to the Active Multiclip Angle
You can add video and audio filters, motion, and speed settings to a multiclip just as you
would to any other clip. However, only the multiclip’s active angle is affected.
Important: Speed changes to an angle can change the duration of a multiclip.
To apply a video or audio filter to the active multiclip angle in the Viewer
1 Double-click a multiclip in the Browser or Timeline to open it in the Viewer.
2 Drag a filter from the Effects tab of the Browser to the Viewer, or choose a filter from the
Effects menu.
The filter is applied to the active angle.
If angles in your multiclip have filters applied, you can choose whether or not you see
the filters applied in the Viewer.

µ

To see filters rendered to multiclip angles in the Viewer
Choose Render Filters in Multiclip Display from the View pop-up menu.

Angle with effects
applied

To apply a video or audio filter to the active multiclip angle in the Timeline
1 Drag a video or audio filter from the Effects tab of the Browser to the multiclip in the
Timeline.
An overlay appears with two options.
2 While continuing to hold down the mouse button, do one of the following:
• To permanently apply the filter to the active angle: Place the pointer over the Apply to
Source Angle overlay, then release the mouse button. This permanently applies the
filter to the active angle, even if you switch or cut to another angle.
• To apply the filter to the currently active angle: Place the pointer over the Apply to
Multiclip overlay, then release the mouse button. This option applies a filter to the
active angle, but the filter is not retained unless you use the Switch with Effects
commands when switching to other angles.
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Switching Angles with Effects
If you switch to a new multiclip angle, any filters, motion, or speed settings that you
added to the previously active angle are not maintained (unless you applied the effect
using the Share with Active Angle overlay). When you switch back to the previously active
angle, the effects are no longer applied. However, you can choose to switch to a new
angle and transfer the effects that were applied to the last active angle. This is called
switching with effects.
Switching with effects allows you to maintain any filters, motion, and speed parameters
you have applied.
Note: Audio levels and pan settings are not maintained when you switch angles with
effects.

µ

To switch to a new video angle while maintaining the effects of the active angle
Press the keyboard shortcut or click the shortcut button assigned to the Switch Video
with Effects to Angle N command, where N is the video angle you want to switch to.
For more information about assigning keyboard shortcuts for multiclip editing, see “Using
Keyboard Shortcuts and Shortcut Buttons for Multiclip Editing.”

µ

To switch to a new audio angle while maintaining the effects of the active angle
Press the keyboard shortcut or click the shortcut button assigned to the Switch Audio
with Effects to Angle N command, where N is the audio angle you want to switch to.
Note: Effects will not be updated for Switch with Effects operations until playback has
stopped.

Collapsing and Expanding a Multiclip
Once you have made all of your edits, you can prevent switching of angles by collapsing
a multiclip down to its active angle. When you collapse a multiclip, it is replaced by the
active angle of the multiclip. This is useful when you want to send a sequence to a color
correctionist or effects artist, and you want them to focus only on the angles you chose
during editing. Collapsing multiclips also improves performance because less video is
streaming from disk.
Collapsing a multiclip is not permanent, which means that you can expand the active
angle at any time to return to the full multiclip, even after you close and reopen a project.
To collapse one or more multiclips in the Timeline
1 Select the multiclips you want to collapse in the Timeline.
2 Do one of the following:
• Choose Modify > Collapse Multiclip(s).
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• Control-click one of the selected multiclips in the Timeline, then choose Collapse
Multiclip(s) from the shortcut menu.
The selected multiclips are collapsed to the clips of their active angles.
To expand one or more multiclips in the Timeline
1 Select the multiclips you want to expand in the Timeline.
2 Do one of the following:
• Choose Modify > Uncollapse Multiclip(s).
• Control-click one of the selected multiclips in the Timeline, then choose Uncollapse
Multiclip(s) from the shortcut menu.
The selected multiclips are expanded to the clips of their active angles.

Working with Multiclip Master-Affiliate Relationships
Multiclips have two levels of master-affiliate clip relationships:
• The relationship of each multiclip angle’s clip to its master clip
• The relationship of one or more multiclips to a master multiclip

About Angle Master-Affiliate Relationships
When you select several clips and create a multiclip, each selected clip is copied and
placed in one of the multiclip’s angles. Because each clip is copied, each is an affiliate
clip, which means the angle’s clip shares most of its properties with a master clip stored
in your project. You can reveal the master clip of the active multiclip angle by choosing
View > Reveal Master Clip, just as you would reveal the master clip of any other clip. If
you change the name of a master clip, the names of the affiliate clips within any multiclips
also change.
To reveal the master clip for the active multiclip angle
1 Select the multiclip in the Timeline or Browser, or place the Timeline playhead over the
multiclip.
2 Choose View > Reveal Master Clip (or press Shift-F).
The master clip for the active angle’s clip is selected in the Browser. If this master clip
happens to be within a multiclip, the multiclip is selected.

About Multiclip Master-Affiliate Relationships
When you create a multiclip, it is called a master multiclip. When you edit, dragging the
master multiclip to the Canvas or Timeline, a copy of the multiclip is made that shares
properties with the master multiclip. The copied clip is called an affiliate multiclip.

Chapter 42 Working with Multiclips

657

Master and affiliate multiclips share several properties:
• Multiclip name property: If you change the name of a master or affiliate multiclip, the
names of all instances of that multiclip in sequences also change. The easiest place to
change a multiclip name is in the Browser.
• Order, number, and clip of each angle: Every affiliated multiclip has the same number
of angles arranged in the same order, and the clip within each angle is the same.
If you perform an operation on a multiclip that affects its angle structure, such as adding,
deleting, or rearranging the order of multiclip angles, the modified multiclip loses its
affiliation with the original master multiclip, and a new master multiclip is automatically
created.
Note: The new master multiclip does not automatically appear in the Browser, but if you
attempt to reveal the master multiclip for a multiclip whose angles you just restructured,
Final Cut Pro asks if you want to create a master multiclip in the Browser.
Final Cut Pro allows you to insert a new angle into all affiliate multiclips with a single
action using the Insert New Angle Affiliates overlay. For more information, see “Inserting
a New Angle into Many Multiclips at Once.”
You cannot make multiclips in a sequence independent. Multiclips in a sequence are
always affiliated with a master multiclip.
To reveal an affiliate multiclip’s master multiclip in the Browser
1 Select a multiclip in a sequence or in the Browser.
2 Choose View > Reveal Master Multiclip.
The master multiclip appears in the Browser, selected. If the multiclip has no master
multiclip, Final Cut Pro asks if you want to create one.
3 Click OK to create a new master multiclip in the Browser.
The new master multiclip is selected in the Browser.

Match Frame Commands Used with Multiclips
The match frame commands in Final Cut Pro allow you to match a frame of a clip in the
Canvas or Viewer with the exact same frame of the clip’s master or affiliate clip. This works
in two ways, depending on whether you are working in the Canvas or the Viewer.
• In the Canvas: The master clip of the clip displayed in the Canvas is opened in the
Viewer, and the Viewer playhead jumps to the frame shown in the Canvas.
• In the Viewer: If the current sequence contains an affiliate clip of the clip in the Viewer,
the Canvas/Timeline playhead jumps to the frame shown in the Viewer.
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When you work with multiclips, you can choose to match to the original Browser multiclip,
or to the master clip of the multiclip’s active angle.
To match the active multiclip angle in the Canvas to its master clip
1 Move the playhead to a specific frame of the multiclip in the Timeline or Canvas.
2 Choose View > Match Frame > Master Clip (or press F).
The master clip of the multiclip’s active angle is opened in the Viewer to the same frame
as the active angle of the multiclip in the Canvas. This is a convenient way to get back to
an angle’s master clip from within a multiclip.
To match the active multiclip angle in the Canvas to its associated multiclip in the
Browser
1 Select the multiclip in the Timeline, or place the Timeline playhead over the multiclip.
2 Choose View > Match Frame > Multiclip Angle.
The multiclip in the Browser is opened in the Viewer to the same multiclip frame that
appears in the Canvas, with the active angle highlighted.
To match the active multiclip angle in the Viewer to its associated multiclip in the
Timeline
1 Double-click a multiclip in the Browser to open it in the Viewer.
2 Choose View > Match Frame >Multiclip Angle.
If the multiclip in the Viewer exists in the Timeline, and the active angle in the Viewer is
also active in the Timeline, the Timeline playhead jumps to the frame that is displayed in
the Viewer.

Media Management and Project Interchange
Multiclips are a unique aspect of Final Cut Pro, so you need to be aware of how
Final Cut Pro translates multiclips during media management or when exporting to a
project interchange file such as an EDL.

Working with Multiclips in the Media Manager
The Media Manager has an option to include all multiclip angles, so the media file for
every angle is processed. If you deselect this option, only the media file of the active angle
is processed. With multiclip sequences that use a lot of angles, deselecting this option
can significantly reduce the amount of media processed. By default, this option is not
selected, so only the media file for the active multiclip angle is processed.
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For more information about using the Media Manager, see “Overview of the Media
Manager.”

Reconnecting and Recapturing Multiclips
When a media file for a multiclip angle is offline, Final Cut Pro indicates that the entire
multiclip is offline (a red slash appears through the icon). When you view a multiclip in
the Viewer, offline angles are indicated by a “Media Offline” frame.
Reconnecting media files for angles in a multiclip is the same as reconnecting media files
for other clips. When you reconnect media files to multiclip angles, you can reconnect
angles that are offline, online, or both.
When you batch capture a multiclip, Final Cut Pro captures the media files for all angles.
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Audio Editing Basics

43

This chapter covers the following:
• The Goals of Audio Editing (p. 661)
• Using Waveform Displays to Help You Edit Audio (p. 662)
• Learning About the Audio Controls in the Viewer (p. 664)
• Editing Audio in the Viewer (p. 668)
• Editing Audio in the Timeline (p. 676)
• Creating or Separating Stereo Pairs (p. 680)
• Working with Audio at the Subframe Level (p. 682)
• Examples of Ways to Easily Edit Audio (p. 684)
Good audio edits are usually subtle and go unnoticed by the listening audience. After
you assemble your video and audio, you can edit your audio independently in the Timeline.

The Goals of Audio Editing
Most viewers are quite good at distinguishing audio changes from one clip to the next,
as well as incorrect audio/video synchronization. As you work on refining the audio in
your project, your edits will focus on eliminating these major distractions to the audience.
In particular, keep in mind three important goals.
Make sure your audio edit points aren’t noticeable
Editing audio clips in a sequence mainly involves finding good edit points that sound
natural. Audio edit points are often more effective when they are offset from the
corresponding video edits. Although you may set your initial audio and video edit points
in the same place to create a quick rough cut, editing your audio more finely may involve
changing many of your edit points to split edits. Some of those split edits may have only
a few frames offset between the audio and video edit points, but those frames will turn
an otherwise obvious cut into a much smoother transition.
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Besides making clean-sounding cuts, there are other reasons to edit the audio in your
sequence separately from the video. You can edit mistakes in dialogue, adjust the sync
of off-camera or rerecorded dialogue, or even replace the entire audio of a clip with
another take of the same audio.
For more information, see “Split Edits.”
Make sure that your video and audio clips are in sync
As you edit your audio, you may sometimes find it necessary to adjust the sync relationship
between video and audio clip items. Audiences are quick to notice when audio is out of
sync with the picture, so you need to be extra cautious when you’re editing. Here’s a
good rule of thumb: if you’re finding an audio/video sync issue distracting, your audience
probably will too. In this case, you should make adjustments.
Final Cut Pro keeps track of the sync between video and audio clip items when they come
from the same source media file, or when they have been intentionally linked together.
Red out-of-sync indicators on clip items show you exactly how far the items are out of
sync. You can establish new sync relationships by selecting the clip items and choosing
Modify > Mark in Sync.
For more information about establishing sync between video and audio clip items, see
“Linking and Editing Video and Audio in Sync.”
Minimize differences in tone and quality between audio clips in the same scene
All audio has some kind of background noise, often referred to as ambience or room tone.
Sometimes you’ll find that the audio from the different shots you’re using in the same
sequence has differences in the background ambience. For example, if you shoot a
conversation in a city park, and the shoot lasts all day, you may notice that some shots
have more traffic noise in the background because of rush hour. Assuming you don’t
want to rerecord the dialogue for the whole scene, you’ll need to edit more “rush hour”
background noise into the clips that don’t have any so that all the clips sound the same
within the same 2-minute scene. Otherwise, the traffic noise in the background will pop
in and out from one shot to the next, which will call attention to your edits and distract
the viewer. Usually, the shot with the highest ambient background noise level dictates
the ambient noise level for the entire scene.

Using Waveform Displays to Help You Edit Audio
As you work in Final Cut Pro, waveform displays can be very useful for navigating through
parts of your audio and seeing at a glance how the levels in a track indicate things like
the words and pauses in dialogue and the beats in a piece of music.
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Waveforms are displayed in the audio tabs of the Viewer.

Waveforms for a stereo
pair of audio items

You can also view waveforms in the Timeline, but you need to explicitly turn them on
(see “Displaying Waveforms in the Timeline”).

Viewing waveforms should not take precedence over listening to audio tracks during
playback. When you’re making editorial decisions, the waveform display is no substitute
for your own ear.
For example, even though a particular frame of a waveform may look like a good place
to cut into a drumbeat or a spoken word, the only way you’ll know for sure is to play
through the clip and listen carefully. Setting your edit points even a few frames too early
or too late can make a big difference, and it’s time-consuming to zoom in to and out of
a waveform display repeatedly to see a high level of detail.
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Use the J, K, and L keys to shuttle through your clips, and learn to listen for the edit points
you want. Once you have set In and Out points, you can use the Play In to Out
(Shift-Backslash) and Play to Out (Shift-P) commands to preview your edits. As you do
this, you’ll find yourself trimming one or two frames at a time and then setting new edit
points, repeating the process until you’ve found the perfect audio editing points.

Learning About the Audio Controls in the Viewer
When you click an audio tab in the Viewer, the controls at the bottom of the window are
the same as those in the Video tab. These controls allow you to navigate through your
clip, set In and Out points and markers, create split edits, and so on. The In and Out points
that you see in an audio tab are the same as the In and Out points shown in the Video
tab. Similarly, the two timecode fields in the top area of the window are the same as
those in the Video tab. For more information on those controls and fields, see “Viewer
Basics.”
More detailed instructions on using these controls and adjusting levels and pan are
described in “Mixing Audio in the Timeline and Viewer.”
Level slider
adjusts volume.

Pan slider adjusts stereo
sound placement.

Level Keyframe buttons

Pan Keyframe buttons

Audio tab controls
There are certain controls that are found only in audio tabs.
• Level slider: This slider adjusts the amplitude, or volume, of the currently selected audio
clip between +12 and –∞ dB. As you drag the slider, the number in the dB field and
the level overlay line are both updated.
You can also adjust the volume by typing a number in the dB field to the right of the
Level slider. The number you enter can include a decimal value, such as 6.23.
If there are no level keyframes in the current clip, adjusting the Level slider affects the
level of the entire clip. If there are level keyframes, using this slider will do either of the
following:
• Adjust the level of a keyframe at the current position of the playhead.
• Add a new keyframe to the level overlay and adjust it to the new level.
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A change in level between any two keyframes appears as a slope on the level overlay
line in the Audio tab of the Viewer. Changes to the level overlay in the Viewer are
mirrored by the level overlay on that clip in the Timeline.
Tip: Hold down the Command key while dragging the Level slider to adjust the audio
level with more precision.
• Level Keyframe button: The keyframe button to the right of the Level slider places a
keyframe at the current playhead location on the level overlay. You can use keyframes
to adjust the audio level of your clip over time.
• Level keyframe navigation buttons: These buttons, to the left and right of the Level
Keyframe button, allow you to move the playhead forward or backward from one
keyframe on the level overlay to the next. You can also press Shift-K or Option-K,
respectively.
• Pan slider: This slider works in two ways, depending on what kind of audio you’ve
opened in the Viewer:
• If the clip items in the audio tab are a stereo pair: This slider simultaneously adjusts the
left and right stereo placement of both tracks. The default setting of –1 sends the
left track to the left channel output and the right track to the right channel output.
A setting of 0 outputs the left and right tracks equally to both speakers, essentially
creating a mono mix. A setting of +1 swaps the channels, outputting the left track
to the right output channel and the right track to the left output channel.
• If the clip items in an audio tab are single, mono tracks: This slider lets you pan the
audio track in the current audio tab between the left and right output channels.
As with the Level slider, if there are no pan keyframes in the current clip, adjusting the
Pan slider affects the pan of the entire clip. If there are pan keyframes, using this slider
will do either of the following:
• Adjust the pan of a keyframe at the current position of the playhead.
• Add a new keyframe to the pan overlay and adjust it between the left and right
output channels.
A change in pan settings between any two keyframes appears as a slope on the pan
overlay in the audio tab of the Viewer.
• Pan Keyframe button: The keyframe button to the right of the Pan slider places a
keyframe at the current playhead location on the pan overlay. You can add keyframes
to change pan settings over time.
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• Pan keyframe navigation buttons: These buttons, to the left and right of the Pan Keyframe
button, allow you to move the playhead forward or backward from one keyframe on
the pan overlay to the next. The left button moves the playhead to the next keyframe
to the left of the playhead’s current position, and the right button moves the playhead
to the next keyframe to the right.
Pan overlay line

Waveform display area

Level overlay line

• Pan overlay line: Drag this line up or down to change the pan for this clip. If you add
keyframes to the overlay, you can create changes in pan over time.
• Waveform display area: Displays a graphical representation of the audio clip, showing
the sample values of your audio over time. If you zoom in on the waveform display,
you can see progressively more detail in your waveform. Clicking anywhere in the
waveform area moves the playhead to that frame, and dragging scrubs through the
clip.
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• Level overlay line: Drag this line up or down to change the sound level. If you add
keyframes to the overlay, you can create changes in level over time.
Reset button

Drag hand
Ruler

Zoom slider

Zoom control

• Reset button: This button deletes all marked keyframes on both the level overlay and
the pan overlay of the currently selected audio track, and resets the level and pan values
to their original captured states (0 dB for the audio level, and –1 for the pan level).
• Drag hand: Use this to drag the current audio clip to the Canvas, the Timeline, or the
Browser. This control is necessary because clicking the waveform itself moves the
playhead to the frame on which you clicked.
• Ruler: When you’re looking at the contents of an audio tab in the Viewer, you’ll see
two playheads, both of which are locked together. The normal Viewer playhead is
located in the scrubber bar below the waveform display area, but there’s also a second
playhead within the waveform display area.
The ruler above the waveform display area shows the currently displayed range of your
clip. If you zoom all the way out (press Shift-Z), this ruler shows the clip from its start
point to its end point, and the movement of the Viewer playhead in the scrubber bar
matches that of the playhead in the waveform display area.
The playhead in the waveform display area lets you move around in an audio clip with
more precision, using the waveform itself for reference as you perform edits or set
keyframes for level and pan (down to 1/100 of a frame, if necessary). Clicking anywhere
on the ruler or in the waveform display area moves the playhead to that frame in your
audio clip. You can also drag the playhead to scrub through the clip, or shuttle through
the clip using the shuttle control or the J, K, and L keys. If you hold down the Shift key
while dragging the playhead in the waveform display area, you can move the playhead
in increments of 1/100 of a frame, which lets you trim edits at a subframe level.
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The playhead in the scrubber bar works the same way it does in the Video tab of the
Viewer. The whole length of the scrubber bar represents the entire length of the audio
clip opened in the Viewer, and clicking or dragging the playhead in the scrubber bar
immediately takes you to that part of your clip.
The markers and In and Out points for your clip also appear in the ruler.
• Zoom slider: This slider lets you zoom in to and out of the waveform displayed by
dragging the thumb tabs on either side, which adjusts both thumb tabs and leaves
the visible area of the keyframe graph centered. Pressing the Shift key and dragging
one of the thumb tabs zooms in to or out of the waveform, locking the opposite thumb
tab and moving the visible area of the waveform in the direction in which you’re
dragging.
• Zoom control: Using this control, you can expand or contract the ruler, decreasing or
increasing the amount of the clip’s waveform that is displayed.

Editing Audio in the Viewer
You can use the Viewer’s audio tabs to edit the audio of a clip opened from the Browser
or Timeline. The audio tabs let you view audio waveforms, set In and Out points, markers,
and keyframes, and change volume levels and stereo pan settings.

Opening Audio Clips in the Viewer
Many clips contain both video and audio items. To look at an audio clip item, you need
to open the clip in the Viewer and then click one of the audio tabs.
To open an audio clip from the Browser
1 Do one of the following:
• Drag the clip to the Viewer.
• Double-click the clip in the Browser.
2 Select the clip and press the Return key.
3 If the clip contains both video and audio items, click one of the audio tabs in the Viewer
to see the waveform display.
For information about how the audio tabs are labeled, see “Viewing Audio Tracks in the
Viewer.”
To open an audio clip item from the Timeline
1 Do one of the following:
• Double-click an audio clip item in your sequence.
If the audio clip item is linked to other items, all of the clip items are opened in the
Viewer in separate tabs. If the audio clip item is part of a stereo pair, the stereo clip
item appears in a Stereo tab in the Viewer. Otherwise, it appears in a Mono tab.
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• Drag a clip item from your sequence to the Viewer.
2 Move the Canvas or Timeline playhead over the clip item you want to open, then press
the Return key.
Note: Make sure the track that contains the clip item is the lowest-numbered track with
Auto Select turned on.
3 If the clip contains both video and audio items, click one of the audio tabs in the Viewer
to see the waveform display.
For information about how the audio tabs are labeled, see “Viewing Audio Tracks in the
Viewer.”

Viewing Audio Tracks in the Viewer
Clips in Final Cut Pro can have up to 24 audio items. Clips with multiple audio items have
a separate tab for each mono audio item or pair of stereo audio items in the clip.
The way audio clips appear in the Viewer depends on whether they’re mono or stereo.
• If audio clip items are mono: They’re represented by individual mono tabs in the Viewer,
called Mono (a1), Mono (a2), and so on. Each mono tab displays the waveform for one
clip item, and levels applied to one are completely independent of any other. Mono
clip items are also referred to as discrete audio.
Discrete mono audio is useful when you recorded to separate channels with
independent microphones. (For example, separate lavalier and boom microphones are
often used during interviews to capture the same voice two different ways—providing
a backup audio track in case one microphone records poorly.) Using discrete audio
allows you to adjust levels and pan settings independently for each audio clip item.
You can also trim the In and Out points of each audio item separately in the Timeline.
Mono (a1) and (a2) tabs
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• If two audio clip items are linked as a stereo pair: They’re represented in a single Stereo
tab that contains the waveforms of that pair’s left and right audio channels. Level
changes applied to one item are automatically applied to the other. Editing audio as
a stereo pair is useful for intrinsically stereo material, such as music mixed in stereo and
built-in stereo camcorder audio.
Stereo audio tab

Audio track A1

Audio track A2

Zooming In to or Out of the Waveform Display Area
Navigating through audio clips in the Viewer is largely the same as navigating through
video clips in the Video tab. There are some additional features, however, that you should
be aware of.
When you navigate through a clip in the Video tab of the Viewer, you only see the frame
at the location of the playhead. Zooming in to this frame enlarges the visual image but
doesn’t change your position in time. Waveforms in an audio tab work differently. Since
they represent your entire audio clip, you can navigate through a waveform as you would
a clip in the Timeline. As you move through the waveform, you’ll notice that the playhead
in the scrubber bar under the waveform display area moves in conjunction with the
playhead in the waveform area.
The scrubber bar in the Viewer always represents the entire duration of the clip in the
Viewer. The ruler above the waveform display area, on the other hand, is not so
constrained. Using the Zoom control and the Zoom slider at the bottom of the waveform
display area, you can zoom in to and out of the waveform display area in the Viewer. This
expands and contracts the audio ruler, allowing you to see more or less detail in an audio
clip’s waveform. While the smallest unit you can see in the video track of a clip is a single
frame, you can see a clip’s audio waveform in increments as small as 1/100 of a frame.
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Note: While this section covers how to zoom in the audio tabs of the Viewer, you can
also use these instructions to zoom in to and out of waveform displays of sequence clips
in the Timeline.
Zoom control

µ

Zoom slider

To zoom in to and out of the audio waveform using the Zoom control
Click or drag the Zoom control to zoom in or out while keeping the material in the
waveform display area centered.
Clicking to the right of the control zooms out to show more of the duration of your clip;
clicking to the left zooms in to show more detail.
To zoom in to and out of the audio waveform using the Zoom slider
Do one of the following:
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Drag the thumb tabs on either side of the Zoom slider to adjust both ends of your view
at the same time.
If the playhead is visible, it stays centered during the zoom. If the playhead is not visible,
the visible area of the Timeline stays centered.

µ

Hold down the Shift key while you drag one of the thumb tabs from the selected end of
the Zoom slider, while keeping the other thumb tab locked in place.
Zooming in to and out of an audio clip’s waveform using menu commands or keyboard
shortcuts keeps the visible area of the waveform display area centered as you zoom.

To zoom in to and out of the audio waveform using keyboard shortcuts or menu
commands
1 Move the playhead to the position in the waveform display area where you want zooming
to be centered.
2 Do one of the following:
• To zoom in: Choose View > Zoom In, or press Command-Equal Sign (=).
Pressing Command-Equal Sign (=) repeatedly shows more and more detail, down to
the individual frames of your audio clip.
• To zoom out: Choose View > Zoom Out, or press Command-Hyphen (-).
Zooming out reduces the amount of detail and shows more of the audio clip’s waveform.
When the entire clip fits in the waveform display area, zooming out stops.
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Scrolling Through a Zoomed-In Audio Clip
If you zoom in to the waveform display area, you won’t be able to see all of the displayed
waveform at once. There are three ways you can navigate through a zoomed-in audio
clip:
• If you play back your audio clip and then stop playback: The waveform display area shows
the section of your audio clip that the playhead moved to.
• If you click or drag in the Viewer’s scrubber bar: The playhead and view inside the
waveform display area match the position where you clicked or dragged.
• If you want to move to another portion of the audio clip without moving the playhead: Use
the Zoom slider.
The length of the scroll bar under the waveform display area represents the total duration
of your audio clip.
Note: Although this section covers how to scroll through waveform displays in the audio
tabs of the Viewer, you can also use these instructions for scrolling through waveform
displays of sequence clips in the Timeline.
To scroll horizontally through a zoomed-in clip in the Viewer
Do one of the following:

µ

Drag the Zoom slider left or right.
The displayed area of the audio waveform moves in the direction you drag.

µ

Click the scroll arrows at either end of the scroll bar to move the displayed area of the
audio waveform incrementally to the left or right.

µ

Click inside the scroll bar to the left or right of the Zoom slider to move the displayed
area of the audio waveform by one length of the Zoom slider’s current scale.

µ

Press the Up Arrow or Down Arrow key to move the visible area of the audio waveform
between the beginning, In point, Out point, and end of your clip.

Using the J, K, and L Keys to Hear Subtle Details
When an audio clip is displayed in the Viewer, you hear a fragmented version of the sound
as you drag the playhead (or scrub through the clip). You can drag the playhead in the
ruler above the waveform in the Viewer or in the waveform display area to scrub through
the clip. This can be extremely useful for quickly navigating through a clip but will probably
not be very helpful for making detailed audio edits.
To hear audio more clearly as you move through it at different speeds, use the J, K, and
L keys to play your clip in the Viewer. Unlike the scrubber bar, which skips samples to
give the illusion of faster playback at the cost of stuttery-sounding audio, the J, K, and L
keys actually shift the pitch of the audio you’re playing back, enabling you to hear all the
subtle details of the audio at various speeds, both slower and faster than real time.
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To learn more about using the J, K, and L keys for scrubbing, see “Navigating and Using
Timecode in the Viewer and Canvas.”

Turning Off the Audio Scrubbing Sounds
As you’re editing audio, you may find the sound of scrubbing through audio distracting
when you move the playhead from one location to another. You can turn off audio
scrubbing in the Viewer so that you don’t hear any sound as you scrub through a clip.
Note: This control affects audio scrubbing in the Canvas and Timeline, as well as in the
Viewer.

µ

To turn audio scrubbing off
Choose View > Audio Scrubbing, so that there’s no checkmark next to it (or press Shift-S).
Tip: You can temporarily stop audio scrubbing by dragging the top of the playhead
(yellow triangle) as you scrub.

About Setting Edit Points for Audio
You set edit points in the audio tabs of the Viewer in the same way that you set edit
points in the Viewer’s Video tab. Whether your clips have been opened from the Browser
in preparation for editing into a sequence, or opened from a sequence in the Timeline
for trimming, edit points work the same way.
Sometimes you want to set the In and Out points of your audio at different spots from
those of your video, such as when you cut away from a visual of someone talking to show
something else while the talking voice continues on the audio track. This is called a split
edit (for more information, see “Split Edits”).

Dragging an Audio Clip to the Canvas, Browser, or Timeline
To move an audio clip from the Viewer to the Canvas, Browser, or Timeline, use the drag
hand at the top of the audio tab. (Clicking the waveform itself moves the playhead to
the frame you clicked, and does not select the clip for dragging.)

Use the drag hand to
move an audio file.
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Trimming Audio Clips in the Viewer
You can trim an audio clip to be shorter or longer. Trimming generally refers to precision
adjustments, anywhere from one frame to several seconds. For more about techniques
for trimming clips in your sequence, see “Learning About Trimming Clips.”
Note: If you want to open a sequence audio clip item in the Viewer, independently of its
linked video clip item, you need to make sure that linked selection is turned off. For more
information, see “Linking and Editing Video and Audio in Sync.”
To trim a sequence audio clip item in the Viewer
1 Turn off linked selection by doing one of the following:
• If linked selection is on, click the Linked Selection button (or press Shift-L) to turn it off.
• Hold down the Option key and click the audio item.

Linked Selection button

Audio selected
independently of video

2 Drag the audio item from the sequence to the Viewer.
The audio item opens in the Viewer by itself.
You can also double-click the audio clip item to open it in the Viewer, but you may need
to hold down the Option key to make sure that only the audio clip item is selected when
you double-click.
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The link between the audio and video in your clip has not been broken, but you can now
trim the audio independently of the video to which it’s linked.
The audio opens in
the Viewer by itself.

3 Select the Selection, Ripple, or Roll tool by clicking in the Tool palette, or by using the
appropriate keyboard shortcut.
4 Set new In and Out points as you would for any other clip.

New Out point set
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Changes you make to sequence clips in the Viewer are mirrored in the Timeline.

The Out point of audio
changes to match that
in the Viewer.

Original Out point

Editing Audio in the Timeline
After editing a number of clips into a sequence, you can further trim the audio clips
directly in the Timeline. Although you can trim audio more precisely in the Viewer,
trimming the audio in the Timeline has other advantages:
• You can see the audio item you’re trimming in relation to the rest of the clips in your
sequence.
• You can work with multiple clips in your sequence, rather than just one.
To help you work with audio clips in the Timeline more efficiently, you can customize the
appearance of audio clips in the Timeline. There are a few ways you can control how
audio is displayed in the Timeline. For example, you may want to see audio waveforms
in the Timeline, or you may want the audio tracks to appear larger so that you can see
more detail, especially for working with audio keyframes.

Displaying Waveforms in the Timeline
Final Cut Pro allows you to turn on and turn off audio waveform display in the Timeline.
To turn on audio waveform display in the Timeline
Do one of the following:
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µ

Choose Sequence > Settings, click the Timeline Options tab, then select Show Audio
Waveforms.

µ

Press Command-Option-W.
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µ

Choose Show Audio Waveforms from the Track Layout pop-up menu in the Timeline.
Click here to access
the Track Layout
pop-up menu.

Turning off audio waveforms speeds up the time it takes to redraw the clips in the Timeline,
which can improve performance, especially when you are not focused on audio editing.
You can turn audio waveforms on and off at any time by pressing Command-Option-W.

Waveform on

Waveform off

Displaying Overlays and Adjusting Track Height in the Timeline
If you want to display waveforms in the Timeline, you may want to show audio level
overlays and adjust the track height.
Track Height control

Clip Overlays control

• Clip Overlays control: You can display or hide clip overlays at any time by clicking the
Clip Overlays control at the bottom of the Timeline window. Audio level overlays appear
as thin pink lines that indicate the sound level of each audio clip item. Any keyframes
added to the levels appear as handles directly on top of the overlay. For more
information on adjusting audio levels using overlays, see “Mixing Audio in the Timeline
and Viewer.”
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• Track Height control: You can click the Track Height control to switch between four
track display sizes—Reduced, Small, Medium, and Large. The current setting is
highlighted in blue and has a small dot in the center.
Note: When the track size is set to Reduced, thumbnails and audio waveforms are not
displayed.
For more information about Timeline display options, see “Timeline Basics.”

Zooming In to and Out of Waveforms in the Timeline
There are several ways you can zoom in to and out of waveform displays in the Timeline.
Make sure you have waveform displays turned on (see “Displaying Waveforms in the
Timeline”).
You can also use the Zoom control and Zoom slider in the Timeline. These controls work
the same way they do in the audio tabs of the Viewer. For information on using these
controls, see “Zooming In to or Out of the Waveform Display Area.”
To zoom in to and out of the Timeline using the zoom tools
1 Select the Zoom In or Zoom Out tool in the Tool palette (or press Z).
2 Do one of the following:
• Click in the waveform area of a track in the Timeline.
• Drag to select a region to zoom in or out on.
Clicking or dragging repeatedly increases or decreases the zoom factor, depending on
which tool is selected. When the Timeline is zoomed in or out to the maximum level
possible, the plus (+) and minus (-) signs on the zoom tools disappear.
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Tip: Pressing the Option key with either the Zoom In or the Zoom Out tool selected
temporarily changes it to the opposite tool.
Before zooming in

Zoom In tool
After zooming in

Naming Audio Tracks
You have two choices regarding the way audio tracks are named in your sequence. Audio
track labeling can be changed in the Timeline Options tab of the Sequence Settings
window for each sequence (choose Sequence > Settings, then click the Timeline Options
tab).
• Sequential: This option labels each audio track consecutively A1, A2, A3, and so on.
Each audio track is identified individually.
• Paired: This option identifies audio tracks in pairs: A1a, A1b; A2a, A2b; A3a, A3b; and
so on. This labeling scheme is useful if you have a lot of stereo material and you want
an easy way to see the relationship between each stereo pair of tracks.
You can modify the way tracks are displayed in the Timeline in the Sequence Settings
window for a sequence. For more information on changing sequence settings, see
“Timeline Basics.”

Moving Audio Items from One Track to Another at the Same Frame
From time to time, you’ll want to move an audio clip up or down to an adjacent track,
but keep its In and Out points at the same location in your sequence. You might do this
to:
• Move a sound effect to another track to make room for another clip
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• Organize the audio clips you’ve edited into your sequence into separate dialogue,
music, and effects tracks
• Place one actor’s dialogue on one track and another actor’s dialogue on another track
To move a clip to an adjacent track without changing its position in the Timeline
1 Position the pointer over the clip in the Timeline and hold down the mouse button.
2 Hold down the Shift key.
3 Drag the clip up or down to an adjacent track.
Note: As you move the clip up and down into other tracks in the Timeline, you’ll notice
that it’s constrained from moving forward or backward in your sequence. It can only move
up and down. This works for both audio and video clips.

Using Audio Transitions to Smooth Audible Changes
Sometimes, a cut in the audio is quite noticeable despite your best efforts to find just the
right frame on which to place the edit. In these cases, you can apply a cross fade to the
edit point to try to smooth out the transition from one audio clip to the next.
Final Cut Pro comes with two audio transitions: a +3 dB cross fade (the default) and a
0 dB cross fade. Each cross fade results in a different audio level change as the transition
plays. Your choice of cross fades depends on the clips you’re transitioning between. Try
one, then try the other to see which sounds better. For information on applying transitions,
see “Adding Transitions.”

Creating or Separating Stereo Pairs
Although stereo pairs are meant to be used for intrinsically stereo audio like music or
stereo sound effects, any two clips of audio in the Timeline can be made into a stereo
pair or separated into two mono clips. This operation can only be performed in the
Timeline.
Note: Stereo pair linking is not the same as clip item linking. It is not necessary to break
the link between clip items prior to disabling stereo pairing.
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To create a stereo pair
1 Select a pair of mono audio clip items in the Timeline. (Use the Command key to select
the second item, if necessary.) If you click one item of a linked pair, the other item is also
selected.
2 Choose Modify > Stereo Pair (or press Option-L).
The stereo pair indicators appear on the selected clip items in the Timeline.

Mono clip items
(unlinked)

Mono clip items (linked).
Underlines indicate
linking.
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Stereo pair. Green arrows
indicate a stereo pair;
underlines indicate
linking.
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If the clip items you want to make into a stereo pair have different durations, the clip
items are trimmed to the region where they both overlap. The levels, pan settings, and
filters that were applied to the top clip are applied to both, and the clip attributes from
the bottom clip are ignored.

Before

Audio level overlays
(the pink lines)

Two clips that are not a
stereo pair; length and
audio levels differ.
Audio level overlay (the
same on both tracks)

After

Stereo pair indicators

Only overlapping parts
of the clips remain, and
the audio level is copied
from the top clip to
the bottom clip.

To separate a stereo pair
1 Select a stereo clip item.
2 Choose Modify > Stereo Pair, so that there’s no checkmark next to the menu item (or
press Option-L).

Working with Audio at the Subframe Level
While the smallest unit of video is a single frame, the smallest adjustable unit of audio in
Final Cut Pro is 1/100 of a frame. Audio level and pan keyframes, as well as the sync
between the video and audio tracks of a clip, can be set with an accuracy of 1/100 of a
frame.
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Viewing an Audio Clip at Single-Frame Resolution
When you’re editing an audio clip in the Viewer, you can zoom in so far that the playhead
is the width of a single video frame on the waveform. You can use this single-frame view,
along with the subframe scrubbing function in Final Cut Pro, to match the beats of musical
clips you edit together; or you can use it to set subframe keyframes to eliminate pops or
clicks that occur at the audio edit points you’ve chosen. If you do not hear audio from
the monitoring speakers while scrubbing, you may need to turn up the volume, or you
may have audio turned off (see “Turning Off the Audio Scrubbing Sounds”).

Subframe Synchronization of Audio and Video
When you’re synchronizing audio and video, audio that’s as little as 300 samples off
perfect sync can be noticeable. For this reason, Final Cut Pro allows you to resynchronize
your audio in increments of 1/100 of a frame. There are several cases in which this will
come in handy:
• When editing music clips together, it’s essential that you edit them together precisely
on the beat. Even a subtle offset can upset the rhythm.
• Video and audio that were recorded from separate sources and resynchronized on tape
may be subtly out of sync.
• Audio that was recorded with a microphone far away from the audio source might
have an offset between the video and audio, because sound moves through the air
more slowly than light.
To navigate through a clip by subframe units
1 Open a clip in the Viewer.
2 Hold down the Shift key while dragging the playhead within the duration of a single
video frame.
This allows you to move the playhead in increments of 1/100 of a frame. When you set
a new edit point in the clip, the clip’s audio item slips a fraction of a frame, establishing
a new sync relationship between the video and audio items.
To slip an audio clip item by subframe units
1 Open a clip with both video and audio items in the Viewer, then click the audio tab.
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2 Move the playhead to the In or Out point of the clip, then press Command-Equal Sign
(=) to zoom in on the audio waveform as far as possible.

A wide playhead bar in
the Viewer represents
one video frame at full
magnification.

3 Press the Shift key and position the playhead within the frame to a new point with better
sync.

4 Click the Mark In or Mark Out button.
Final Cut Pro slips the audio item in the clip by the offset from the subframe position of
the playhead to the boundary of the previous whole frame.

Examples of Ways to Easily Edit Audio
As you work with audio, you may find it helpful to read through these two examples of
ways you can fix audio issues using Final Cut Pro.
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Example: Replacing Unwanted Audio with Room Tone
As you edit dialogue, you’ll often need to cut out pieces of audio that you don’t want in
the sequence. For example, the director may have given directions in between an actor’s
lines, or the sound recordist might have bumped into something while shooting on
location for a documentary. As long as there’s no dialogue happening at the same time,
it’s pretty easy to cut out unwanted sounds. If you simply delete the sound, however,
you’ll be left with a gap in your audio that sounds artificial. Since there’s always a low
level of background noise, known as room tone, in any recording, a moment of complete
silence is jarring.
In order to edit out unwanted sections of audio without creating obvious gaps, it’s
common practice to record a certain amount of room tone during a shoot. The recordist
simply has everyone stand quietly for thirty seconds or so, and records the ambient sound
of the room. If you’ve recorded some room tone during your shoot, you can capture it
so that, as you edit, you have a long piece of “silence” that you can edit in whenever you
need to cover a gap in the location audio.
If, for some reason, room tone was not captured for a particular scene, but you have a
gap you need to fill, you can try to copy a section from another clip in the same scene
that has a pause in the dialogue, and paste it to fill the gap. If you have no pauses that
are long enough to cover your gap, you can try to copy and paste a short pause multiple
times. But there’s a chance that it will end up sounding like a loop, which will be too
noticeable. In this case, you can use the following method to obtain a long section of
room tone from a short copied pause in the dialogue.
To create a section of room tone from a short pause
1 Find the longest pause you can in the dialogue clip with the gap you need to fill, then
copy the section that contains the pause. If you’re in the Timeline, you can use the Range
Selection tool.

The long pause in your
clip is selected.

Chapter 43 Audio Editing Basics

685

2 Create a new sequence, name it “Room Tone,” and paste the audio pause into it twice.

Paste the pause section
you just copied twice
into a new sequence.

3 Select the clip containing the second pause, then choose Modify > Speed.
4 In the Speed dialog, click the Reverse checkbox to select it.

5 Play the resulting clips.
The looping sound should be gone, but if you hear a clicking at the edit point between
the two clips, you may have to add a cross fade transition between them to smooth this
out. For more information, see “Adding Transitions.”
If the looping effect is not obvious, you may want to skip the speed reversal step. You
may also need a longer section of ambient tone, or several different sections. Experiment
to see what works best.
6 Cut and paste as many pairs of these clips as you need to fill the necessary duration,
adding cross fades between each pair.
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7 Render the Room Tone sequence, then edit the sequence into the gap in your program,
just as you would a clip.

Edit the Room Tone
sequence into your
existing sequence
to fill the gap.

To replace an unwanted section of an audio clip with room tone
1 Make the tracks that contain the unwanted audio the audio destination tracks, then
disconnect the video destination track.
2 Play your clip using the J, K, and L keys, and set In and Out points right before and after
the section of audio you want to replace.

In and Out points are set to
mark the section you want to
replace with room tone.

3 Move the Canvas or Timeline playhead to the In point.
4 Drag your Room Tone sequence into the Viewer, and move the Viewer playhead to the
start of the section of room tone you want to use.
5 Set an In point in the Viewer.
6 Edit the room tone into your sequence by doing one of the following:
• Drag the Room Tone sequence from the Viewer to the Overwrite section of the Edit
Overlay in the Canvas.
• Click the Overwrite button in the Canvas.
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• Press F10.

The section of unwanted
audio is replaced with
room tone.

Example: Fixing Awkward Audio Cuts in the Timeline
Once you’ve edited a group of clips into a sequence in the Timeline, you can adjust the
edit points between audio items without affecting their corresponding video items. To
do so, you turn off linked selection. For example, suppose you’re cutting between two
people having a conversation. The first person says something, and then the second
person pauses for a moment and replies. It might look something like this:

Audio in first clip
gets cut off.

Second clip
starts quietly.

The timing of the video is what you wanted, but as the audio waveform shows, the last
syllable of the last word of dialogue in the first shot gets cut off, which sounds awkward.
To fix this, you can create a small split edit in the Timeline. (A split edit has different video
and audio In and Out points. See “Split Edits.”)
To fix an awkward audio cut in the Timeline
1 Turn off linked selection by doing one of the following:
• Click the Linked Selection button (or press Shift-L) so that it’s off.
For more information, see “Linking Video and Audio Clip Items.”
• Click the edit point between the two audio items while holding down the Option key.
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2 Select the Roll tool from the Tool palette (or press the R key).

3 Drag the audio edit point to the right so that the entire word plays at the end of the first
clip.

Now when you play through this cut, you can hear all of the words the first person is
saying, and then the second person’s reply.

Chapter 43 Audio Editing Basics

689

Performing Slip, Slide, Ripple, and
Roll Edits

44

This chapter covers the following:
• About Trimming with Slip, Slide, Ripple, and Roll Tools (p. 691)
• Sliding Clips in the Timeline (p. 692)
• Slipping Clips in the Timeline (p. 695)
• Using the Ripple Tool to Trim an Edit Without Leaving a Gap (p. 699)
• Using the Roll Tool to Change Where a Cut Occurs (p. 709)
Once your rough edit is complete, you will want to fine-tune your edit. The advanced
editing tools in Final Cut Pro allow you to make fine adjustments to clips in your sequence.

About Trimming with Slip, Slide, Ripple, and Roll Tools
The Slip, Slide, Ripple, and Roll tools are specialized tools that you can use to make fine
adjustments to the In and Out points of clips in your sequence. Fine-tuning your edits
with these tools is also referred to as trimming. For more information about trimming
tools not covered in this chapter, see “Learning About Trimming Clips” and “Trimming
Clips Using the Trim Edit Window.”
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Sliding Clips in the Timeline
Performing a slide edit allows you to move a clip’s position in the Timeline between two
other clips without creating a gap. The clip’s content and duration remain the same; only
its position in the Timeline changes. When you slide a clip, the adjacent clips get longer
and shorter to fill any gaps that would normally be created. The combined duration of
these three clips does not change, and therefore the sequence’s duration remains
unchanged as well.
A

B

C

Before edit
A

B

C

After edit

In the following example, clip B slides to the left. The slide edit changes the Out point of
clip A and the In point of Clip C, but the In and Out points of clip B stay the same. The
duration of clip B does not change, nor does the overall length of the sequence.
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Note: To slide a clip between two others, the preceding and following clips must have
handles (extra media beyond the clip In and Out points).
To perform a slide edit, you can drag a clip with the Slide tool. For precision adjustments,
you can use timecode.

You slide items using
the Slide tool.

You can also move a clip with the Selection tool, but this method may leave gaps between
clips. The Slide tool never creates gaps (with the exception of sliding the first or last clip).

Performing Slide Edits Using the Slide Tool
Selecting a clip with the Slide tool and dragging it is an easy way to perform a slide edit.
To slide a clip in the Timeline by dragging
1 Select the Slide tool in the Tool palette (or press the S key twice).
2 Select the clip, then drag it left or right.
The clip moves to a new
position in the Timeline.

As you drag, the Canvas displays the Out point frame of the clip to the left and the In
point frame of the clip to the right.
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3 Release the mouse button.
This clip is longer.

This clip is shorter.

This clip’s duration
is the same.

Performing Precise Slide Edits Numerically
If you need to slide a clip just two or three frames, using the mouse may be difficult. For
precision edits, it is much less cumbersome to slide a clip numerically.
To slide a clip in the Timeline using timecode
1 Select the Slide tool in the Tool palette (or press the S key twice).
2 Select a clip in the Timeline, or hold down the Shift key to select multiple clips. You can
also select noncontiguous clips using the Command key.
Tip: You can slide multiple clips at once. However, if one of the clips cannot be slid, none
of them are moved.
3 Do one of the following:
• To slide the clip one frame to the left: Press Left Bracket ([) or Left Angle Bracket (<).
• To slide the clip one frame to the right: Press Right Bracket (]) or Right Angle Bracket (>).
• To slide the clip a default number of frames to the left: Press Shift-Left Bracket ([) or
Shift-Left Angle Bracket (<).
• To slide the clip a default number of frames to the right: Press Shift-Right Bracket (]) or
Shift-Right Angle Bracket (>).
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• To slide the clip by a precise number of frames: Type a plus sign (+) or a minus sign (-)
and the number of frames to slide, then press Return.
The timecode entry field
shows the duration of
the slide.

Note: You can specify the default number of frames to trim by changing the MultiFrame
Trim Size setting in the General tab of the User Preferences window. (For more information,
see “Choosing Settings and Preferences.”)

Slipping Clips in the Timeline
Performing a slip edit does not change a clip’s position or duration in the Timeline, but
instead changes what portion of the clip’s media appears in the Timeline. The Slip tool
allows you to move a clip’s In and Out points simultaneously.

You slip items using
the Slip tool.

Whenever you arrange clips in the Timeline so that edit points line up with musical beats
or other fixed sync points in a sequence, you want to keep your clips in position. These
situations leave you with very little room to adjust your clip because you cannot change
the clip’s duration. You also cannot move the clip elsewhere in the Timeline, because it
would no longer be aligned with the music beats or other sync points in the sequence.
Therefore, all you can do is move both the In and Out points of the clip simultaneously,
keeping the clip’s duration fixed.
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The portion of the clip seen in the sequence changes, while its position in the sequence
stays the same. Surrounding clips are not affected, nor is the overall duration of your
sequence.
00:00:10:00
A

00:00:30:00
B

C

Before edit
00:00:17:00
A

00:00:37:00
B

C

After edit

In the example above, the slip edit changes the In and Out points of clip B, but not its
duration or position in the sequence. When the sequence plays back, a different portion
of clip B’s media is shown.
Note: To slip a clip, it must have handles on both sides, meaning that there must be
additional media available on both the head and the tail of the clip. If you are having
trouble slipping a clip, check that the clip has handles on both sides.
You can perform slip edits by dragging with the Slip tool or, for greater precision, by
using timecode.

Performing a Slip Edit Using the Slip Tool
You can perform slip edits in the Viewer or the Timeline.
To perform a slip edit in the Viewer using the Slip tool
1 Double-click a sequence clip to open it in the Viewer.
2 Select the Slip tool in the Tool palette (or press the S key).
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3 Drag either the In or Out point along the Viewer’s scrubber bar.
The duration of the
sequence clip does
not change.

The sequence clip’s In and
Out points move together.

4 Release the mouse button when the clip is positioned at a range of frames that you like.
The In and Out points move together, maintaining the clip’s duration.
5 Click the Play In to Out button, or press Shift-Backslash (\), to review the new section
between your sequence clip’s In and Out points.
The clip is automatically updated in the Timeline. The duration of the clip and the sequence
remain the same, and the surrounding clips are not affected.
To slip a clip in the Timeline using the Slip tool
1 Select the Slip tool in the Tool palette (or press the S key).
2 Click a clip, then drag it left or right.
As you drag, an outline of the entire range of that clip is shown, indicating the amount
of media available to the left and right of the current range selected in the clip.

Drag point

This box shows how far
the clip’s In and Out
points are slipping.

Entire length of media
file shown during slip
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At the same time, the Canvas displays the frames at the In point and the Out point.

3 Release the mouse button when the clip is positioned at a range of frames that you like.
The duration and location of all clips in your sequence remain the same after this operation.

4 Click the Play In to Out button, or press Shift-Backslash (\), to review the new section
between your sequence clip’s In and Out points.

Performing Precise Slip Edits Numerically
Slipping a clip by just a few frames using the mouse can be difficult. It’s much less
cumbersome to precisely slip a clip numerically.
To slip a clip in the Timeline using timecode
1 Select the Slip tool in the Tool palette (or press the S key).
2 Select a clip in the Timeline.
Note: To select multiple clips, hold down the Shift key as you select each clip.
3 Do one of the following:
• To slip the clip one frame to the right: Press Left Bracket ([) or Left Angle Bracket (<).
• To slip the clip one frame to the left: Press Right Bracket (]) or Right Angle Bracket (>).
• To slip the clip a default number of frames to the right: Press Shift-Left Bracket ([) or
Shift-Left Angle Bracket (<) .
• To slip the clip a default number of frames to the left: Press Shift-Right Bracket (]) or
Shift-Right Angle Bracket (>).
• To slip the clip by a precise number of frames: Type a plus sign (+) or a minus sign (-) and
the number of frames to slip, then press Return.
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Note: You can specify the default number of frames to trim by changing the Multi-Frame
Trim Size setting in the Editing tab of the User Preferences window. For more information,
see “Choosing Settings and Preferences.”
The timecode entry field
shows how far you are
slipping the clip.

4 Click the Play In to Out button, or press Shift-Backslash (\), to review the new section
between your sequence clip’s In and Out points.
To slip multiple clip items at once in the Timeline
1 Select the Selection tool in the Tool palette (or press A).
You can also temporarily turn the Slip tool into the Selection tool by holding down the
Command key.
2 Select multiple clip items in the Timeline.
The selected clip items can be in one or more tracks. Selected clip items do not have to
be adjacent. For example, you can hold down the Command key while clicking clip items
to make a noncontiguous selection.
3 Select the Slip tool in the Tool palette (or press S).
4 Type a positive or negative timecode number to slip all selected clip items by that amount,
then press Enter.
The selected clip items slip by the duration you enter. If one of the selected clip items
cannot be slipped, none of the items are slipped.

Using the Ripple Tool to Trim an Edit Without Leaving a Gap
A ripple edit adjusts a clip’s In or Out point, making the clip longer or shorter, without
leaving a gap in the Timeline. The change in the clip’s duration ripples outward, moving
all subsequent clips earlier or later in the Timeline. If you don’t use a ripple edit when you
change the duration of a clip, you will either leave a gap when you make a clip shorter,
or overwrite part of an existing clip if you make a clip longer. Using the Ripple tool is the
main way that you perform ripple edits, but you can also select one or more clips in the
Timeline and perform a ripple cut or ripple delete. This is when a clip is deleted and all
subsequent clips move earlier in the Timeline to fill the gap.
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A ripple edit is a one-sided edit, meaning that only an In or Out point of a single clip item
is affected. All clips following the shortened or extended clip are moved accordingly in
the Timeline, so ripple edits affect both the trimmed clip and the position of all subsequent
clips in the Timeline. This is a much more major operation than simply trimming an
individual clip’s length.
A

B

C

Before edit
A

B

C

After edit

Important: Ripple edits can be dangerous if you are trying to maintain sync between clip
items on different tracks, since all of the clip items on one track may move forward or
backward while the clip items on other tracks don’t.
To perform a ripple edit, you use the Ripple tool.

Ripple edits are done
using the Ripple tool.

Note: You can select an edit point in the Timeline when you are using the Ripple tool.
You can also open a sequence clip in the Viewer when the Ripple tool is selected by
double-clicking the clip in the Timeline.

Which Clip Items Move in the Timeline After a Ripple Edit?
Clip items with In points later in the Timeline than the edit point (or edit points) you are
adjusting will move, or ripple, after you perform a ripple edit. All other clip items remain
in the same position in the Timeline.
Take special care when performing ripple edits with complex edit point selections on
multiple tracks. To make sure you understand how an edit affects the clip items in your
sequence, you can undo (Command-Z) and redo (Command-Shift-Z) your edit several
times to compare the sequence before and after the ripple edit was performed.
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Tips for Edits Made with the Ripple Tool
Keep the following in mind when using the Ripple tool:
• If you lengthen a clip item, clip items on the same track move forward in time. Clip
items on other unlocked tracks that begin after the original location of the edit point
you are adjusting also move forward in time.
• If you shorten a clip item, clip items on the same track move backward in time, as do
clip items after the initial location of the edit you are adjusting on other unlocked tracks.
• If you can’t ripple because of a “Collision” message, it is because clip items on other
tracks can’t move back in time without bumping into other clip items.
• All tracks are affected when you use the Ripple tool. If you don’t want other tracks in
the sequence to be affected by the Ripple tool, lock those tracks (see “Locking Tracks
to Prevent Edits or Changes”).
• You can temporarily turn the Ripple tool into the Roll tool by pressing the Shift key.
Release the Shift key to return to the Ripple tool.
• While dragging, press the Command key to “gear down” and make a more precise edit.

Performing a Ripple Edit in the Timeline
When you use the Ripple tool to adjust the duration of a clip in the Timeline, always pay
attention to where Final Cut Pro previews the location of the new clip Out point. Even
when you are adjusting a clip’s In point with the Ripple tool, the location of the clip’s Out
point is what you should pay attention to.
When you adjust a clip’s In point with the Ripple tool in the Timeline, it appears that the
clip’s In point is moving in the Timeline, and that the clip’s duration is changing from
both its In and Out points. This is not true. The position of the clip’s In point in the Timeline
never changes after a ripple edit is performed. Final Cut Pro is actually showing you two
things at once:
• The duration by which the clip is being trimmed
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• The new Out point that will result from performing the ripple edit
Amount the clip’s
Out point is trimmed

Position of clips C and D
before the ripple edit

Before edit

Clip B has a
shorter duration.

Clips C and D are
positioned earlier
in the Timeline.

Sequence markers move
with the Ripple edit
when Ripple Sequence
Markers is enabled.
After edit

To do a ripple edit in the Timeline
1 Select the Ripple tool in the Tool palette (or press the R key twice).
2 Select a clip item’s In or Out point by clicking near the clip item boundary.
The Ripple tool changes direction to indicate which clip item boundary you are about to
select. If linked selection is on, the edit points of linked clip items are also selected. For
more information, see “Selecting Edits and Clips to Trim.”
3 Do one of the following:
• To lengthen or shorten the clip in the sequence: Drag the edit point. Pay attention to the
clip boundary previewed in the Timeline.
• To move the selected edit point one frame earlier in the clip: Press Left Bracket ([).
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• To move the selected edit point one frame later in the clip: Press Right Bracket (]).
• To move the selected edit point by a precise number of frames: Type a plus sign (+) or a
minus sign (-) followed by the number of frames to add or subtract from the current
edit, then press Return.
Note: You can also press Shift-Left Bracket ([) or Shift-Right Bracket (]) to move the selected
edit point five frames at a time. The number of frames can be adjusted in the Multi-Frame
Trim Size field in the Editing tab of the User Preferences window.
Edit point being trimmed

The In point of this clip
stays the same and is
not adjusted.

The Out point of this clip
is being adjusted.

While you adjust the clip with the Ripple tool, the Canvas shows a two-up display with
the Out point of the outgoing clip item on the left and the In point of the incoming clip
item on the right (see also “About the Two-Up Display in the Canvas”).
Use these two frames to decide exactly where to place the edit point.
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All clip items after the edit point move either left or right to accommodate the new
duration of your clip.
These clips move left
to fill the gap.

This clip shortens.

Note: By default, sequence markers (markers in the Timeline ruler and the Canvas scrubber
bar) ripple after any ripple edit or insert edit. For more information, see “Using the Ripple
Sequence Markers Setting.”

Performing a Ripple Edit in the Viewer
In some cases, you may want to look at the media for an entire clip before deciding at
which frame to make an edit. In this case, it can be easier to open a sequence clip in the
Viewer. As long as the Ripple tool is selected when you set an In or Out point in the
Viewer, a ripple edit is performed in the Timeline.
To do a ripple edit in the Viewer
1 Double-click a sequence clip in the Viewer.
2 Select the Ripple tool in the Tool palette (or press the R key twice).
3 Do one of the following:
• Use the transport controls or the J, K, and L keys to move the playhead in the Viewer
to a new point in your clip. Then set a new In or Out point using the Mark In and Mark
Out buttons or the I and O keys.
• Drag the In or Out point along the Viewer’s scrubber bar to a new point in your clip.
Look in the Timeline to make sure the ripple edit did what you expected, since other clips
in the Timeline move when you perform a ripple edit.
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Ripple Edits and Sync Relationships of Clip Items on Other Tracks
When you perform ripple edits, it is fairly easy to cause linked clip items across tracks to
go out of sync with each other. This usually happens when you perform a ripple edit on
one track while other tracks are locked, so the clip items on that track can’t move in sync
after the ripple edit.
For example, if you have video clip items edited to the rhythm of a music track, rippling
clips in the video track moves them out of sync with the music. In this case, you probably
shouldn’t use the Ripple tool. Instead, you can change the length of a clip item without
moving other clips in the Timeline. If you shorten the clip item, this means there will be
a gap in the video track that you need to fill, but at least all of your other clips won’t be
out of sync with the music.

Before

The clips are in sync
with markers on the
audio tracks.

After

After a ripple edit,
the sync relationship
has changed.

Final Cut Pro tries to prevent you from performing ripple edits that will cause linked clip
items to go out of sync. Final Cut Pro assumes that any overlapping clip items should
maintain the same sync relationship before and after an edit. Furthermore, a ripple edit
cannot cause any clips to overwrite other clips.
Note: In the figure above, the sequence markers (in Timeline ruler) ripple with the video
clips. The Ripple Sequence Markers setting is enabled by default. For more information
about the Ripple Sequence Markers setting, see “Using the Ripple Sequence Markers
Setting.”
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In the example below, Final Cut Pro won’t allow you to perform a ripple edit because the
second music clip in tracks A3 and A4 would either need to be shortened or would
overwrite part of the first music clip in order to stay in sync with the clip items in V1, A1,
and A2. Because the ripple edit cannot force the second music clip to overwrite the first
music clip, Final Cut Pro warns you that the ripple edit cannot be performed because
there is a clip collision on track A3 (and A4).
Although your intention is to
only ripple the selected clips...

...Final Cut Pro won’t allow the
edit because the second music
clip in tracks A3 and A4 cannot
overwrite the first music clip.

There are three ways to solve this problem:
• Lock tracks A3 and A4 so that Final Cut Pro does not attempt to ripple the second music
clip (see “Locking Tracks to Prevent Edits or Changes”).
• In addition to selecting the clip Out points in tracks V1, A1, and A2, you can also select
the first music clip’s Out points in A3 and A4.
• Instead of selecting the first music clip’s Out points, you can perform an asymmetric
edit by selecting the clip Out points in tracks V1, A1, and A2, and the second music
clip’s In points on tracks A3 and A4. This causes the first clip to be shortened from the
Out point while the second clip is shortened from its In point. For more information
about asymmetric editing, see “Asymmetrical Trimming with the Ripple Tool.”

Doing Ripple Edits on Multiple Tracks at Once
You can perform a ripple edit to edit points in multiple tracks to modify several video
and audio items simultaneously.
To perform a ripple edit on multiple tracks simultaneously
1 Do one of the following:
• Press the Command key while clicking to select multiple edit points.
• Select the Edit Selection tool in the Tool palette, then drag to select multiple edit points.
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2 Do one of the following:
• Drag one of the edit points using the Ripple tool to perform a ripple edit across all
tracks with selected edit points.
• Enter timecode values to edit numerically.

Asymmetrical Trimming with the Ripple Tool
Asymmetrical trimming allows you to simultaneously ripple edit points for clip items in
different tracks in opposite directions. For example, suppose you want to extend the Out
point of a video clip item by 2 seconds. If you do this by extending only the video clip
item, a 2-second gap is created on other tracks. If you select the In point of clip items on
other tracks and use asymmetrical trimming, you can simultaneously extend the In points
of the clip items, making them start 2 seconds earlier. The result is that the video clip
item is 2 seconds longer, and the audio clip items fill in the gap because they are 2 seconds
longer.
Asymmetrical trimming is a convenient way to create a split edit between two adjacent
sequence clips, but you can also use this feature with audio-only and video-only clip
items.
Asymmetrical trimming can be done either in the Timeline or in the Trim Edit window.
Tip: If you are doing a lot of asymmetrical trimming, you may find it helpful to turn off
linked selection by pressing Shift-L or clicking the Linked Selection button in the
upper-right corner of the Timeline. For more information about linked selection, see
“Linking and Editing Video and Audio in Sync.”
To create a split edit using asymmetrical editing
1 Select the Ripple tool.
2 Hold down the Option key, then click the Out point of a video clip to select it.
Holding down the Option key while selecting an edit point selects only that point, ignoring
any other items linked to that clip.
3 Hold down the Command key, then click the In point of an adjacent audio clip.
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Holding down the Command key while selecting an edit point allows you to add edit
points to the current selection without deselecting previously selected edit points.
Intended video
edit point

Before

Current Out point of
outgoing video clip

In point of incoming
audio clips

4 Use the Ripple tool to trim the above selection.
The video and audio edit points move in opposite directions, creating a split edit.
Audio/video synchronization is maintained in both clips.
Outgoing video clip
is trimmed shorter
from its Out point.

After
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This clip remains
the same length.

This clip remains
the same length.

Incoming audio clip
is trimmed shorter
from its In point.
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Note: In this example, Command-clicking the In point of a stereo pair of audio clip items
results in adding both audio items to the selection. You can also Command-Option-click
a single audio item to add it to the selection individually, without including other audio
items linked to it. This can be especially useful for clips in which many audio items are
linked to a single video item in the Timeline.

Using the Roll Tool to Change Where a Cut Occurs
A roll edit adjusts the Out point and In point of two adjacent clips simultaneously. If you
like where two clips are placed in the Timeline, but you want to change when the cut
point happens, you can use the Roll tool. No clips move in the Timeline as a result; only
the edit point between the two clips moves. This is a two-sided edit, meaning that two
clips’ edit points are affected simultaneously: the first clip’s Out point and the next clip’s
In point are both adjusted by a roll edit. However, no other clips in the sequence are
affected.
Note: When you perform a roll edit, the overall duration of the sequence stays the same,
but both clips change duration. One gets longer while the other gets shorter to
compensate. This means that you don’t have to worry about causing sync problems
between linked clip items on different tracks.
Using the Roll tool, you move the Out point of the outgoing clip and the In point of the
incoming clip simultaneously.
A

B

C

Before edit
A

B

C

After edit

In the example above, clip B gets shorter while clip C becomes longer, but the combined
duration of the two clips stays the same.

Roll edits are done
using the Roll tool.
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Roll edits are useful when the relative Timeline position of two clips is good, but you want
to change when the edit point occurs between them. For example, suppose your sequence
has two clips showing an Olympic diver diving into a pool from two different angles. The
first thing you need to do is adjust each clip until their edit points align on a similar action.
This is called matching on action, or a match cut. You could align the edit point in the
Timeline so that when the diver hits the water in one camera angle, the diver is also
hitting the water in the second angle. Once you have a cut point with matching action,
you can roll the edit point earlier or later to change when the edit occurs. For example,
you could roll the edit to the point where the diver is midway between the diving board
and the water.

Tips for Using the Roll Tool
There are a few tips for using the Roll tool:
• If you can’t drag any further while rolling an edit, you have reached the end of the
media on one of the two clips. Final Cut Pro displays a Media Limit message in this
case.
• With the Roll tool selected, hold down the Shift key to switch temporarily to the Ripple
tool.
• While dragging, press the Command key to “gear down” and make a more precise edit.

Rolling Edit Points in the Timeline
The easiest place to see how a roll edit affects your clips is the Timeline.
To do a roll edit in the Timeline
1 Select the Roll tool in the Tool palette (or press the R key).
2 Select an edit point between two clips.
If linked selection is on, the edit points of linked items are also selected. For more
information, see “Controls That Affect Trim Edits.”
Selected edit point
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3 Do one of the following:
• Drag the edit point left or right.
As you drag, the Canvas shows a two-up display with the Out point of the outgoing
clip on the left and the In point of the incoming clip on the right (see also “About the
Two-Up Display in the Canvas”).

• Type a plus sign (+) or a minus sign (-) followed by the number of frames to add or
subtract from the current edit, then press Return.
Edit being rolled

After the roll edit, the
outgoing clip is shorter and
the incoming clip is longer.

Chapter 44 Performing Slip, Slide, Ripple, and Roll Edits

711

To roll edit points on multiple tracks simultaneously
1 Do one of the following:
• Press the Command key while clicking to select multiple edit points.
• Select the Edit Selection tool in the Tool palette (or press the G key), then drag to select
multiple edit points.

2 Use the Roll tool to perform the roll edit across all of the tracks.

Before

After
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Doing Roll Edits in the Viewer
Final Cut Pro allows you to perform roll edits in the Viewer by setting In or Out points
while the Roll tool is selected.
To do a roll edit in the Viewer
1 Open a sequence clip in the Viewer.
2 Select the Roll tool in the Tool palette (or press the R key).
3 Do one of the following:
• Drag the In or Out point along the Viewer’s scrubber bar to roll the edit.
• Press I or O to set a new In or Out point.
Look in the Timeline to make sure the roll edit did what you expected.
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Learning About Trimming Clips

45

This chapter covers the following:
• What Is Trimming? (p. 715)
• Controls That Affect Trim Edits (p. 717)
• Selecting Edits and Clips to Trim (p. 718)
• Trimming with the Selection Tool (p. 721)
• Extending and Shortening Clips in the Timeline (p. 723)
• Trimming Clips in the Viewer (p. 724)
• Precision Editing Using Timecode (p. 726)
• Understanding Alert Messages When Trimming (p. 728)
Adjusting a clip’s duration by moving its In or Out point, or moving the edit point between
two clips, is called trimming.

What Is Trimming?
After you have roughly assembled your clips in chronological order in a sequence, you
begin to fine-tune the cut point (or edit point) between each clip. Any time you make a
clip in a sequence longer or shorter, you are trimming that clip. However, trimming
generally refers to precision adjustments (anywhere from one frame to several seconds).
If you are adjusting clip durations by much larger amounts, you are still trimming, but
you may not be in the fine-tuning phase of editing yet.
Getting an edit to work is an intuitive process, so you need to watch the results of your
trimming adjustments repeatedly as you trim. Many factors go into the decision of when
exactly you cut from one shot to the next. When you fine-tune your sequence, you are
no longer focused on the larger structure of the movie, but how each shot flows to the
next. You focus on individual edit points between clips instead of large groups of clips.
In most cases, you aim to achieve a certain visual and psychological continuity.
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You can trim edits anywhere you can adjust a sequence clip’s In and Out points—the
Timeline, the Viewer, and the Trim Edit Window, which is designed specifically for
fine-tuning edits.
• Viewer: You can open a sequence clip in the Viewer and adjust its In or Out point. This
is useful if you want to find a particular frame for your In or Out point by looking at the
clip’s entire media file. However, if you are trying to adjust edit points on two clips
simultaneously (a “two-sided” edit), the Timeline or Trim Edit window is better.
• Timeline: In the Timeline, you can roll an edit point between two clips. A roll edit adjusts
the Out point and In point of two adjacent clips simultaneously. The result is that the
edit point between the two clips moves, but no clips change position in the Timeline.
For more information, see “Using the Roll Tool to Change Where a Cut Occurs.”
You can also trim edit points in multiple tracks simultaneously. The Timeline makes it
easy to drag clip In or Out points to make a clip longer or shorter, and to quickly trim
multiple clips at once.
You can adjust the level of precision of your editing by setting the zoom level in the
Timeline. By zooming in, you can make changes all the way down to a clip’s individual
frames. If you want to trim clips by a precise number of frames or seconds, you can
enter exact timecode values for trimming. This is sometimes referred to as numeric
editing, or trimming using timecode.
• Trim Edit window: The Trim Edit window allows you to focus on a specific edit point in
the Timeline, visually trim one or more edits with precision, and preview the edit at
the same time. It combines the convenience of trimming in the Timeline with additional
options available in the Viewer. The changes you make using the Trim Edit window
only affect the clips in the Timeline.
Clips from either side of an edit point are shown, each in its own Viewer-like display.
The outgoing clip is the clip before the edit point, and the incoming clip is the clip after
the edit point.
Almost any trimming you can do in the Timeline can be done in the Trim Edit window,
including trimming multiple clip items at once. For more information, see “Trimming
Clips Using the Trim Edit Window.”
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Controls That Affect Trim Edits
Before you perform a trimming operation, make sure to check that the following controls
are set properly for the operation you need to perform.
Linked Selection
Clip items that refer to the same media file are linked together when you edit them into
the Timeline. You can also link unrelated clip items together so you can operate on them
simultaneously, keeping them in sync.
For your convenience, you can keep linked selection turned on and temporarily disable
it as necessary. You can temporarily disable linked selection by holding down the Option
key while selecting or trimming a clip item in the Timeline. This allows you to adjust one
clip item at a time, even if it is linked to others. This is a good way to create split edits,
where the audio In or Out point is different from that of the video.
Click here to turn linked
selection on and off.

Snapping
If snapping is on, when you drag an edit point in the Timeline or Viewer, it snaps to In or
Out points, markers, keyframes, the playhead, and edits on other tracks. This can help
you quickly line up edits with other items in the sequence. You can turn snapping on
and off at any time, even in the middle of dragging edits and clips. You turn snapping
on and off by choosing View > Snapping, pressing the N key, or clicking the Snapping
button in the Timeline. For more information, see “Snapping to Points in the Timeline.”
Click here to turn
snapping on and off.

Locked Tracks
Trim operations with the Ripple tool will only affect clip items on unlocked tracks. If there
are clip items on certain tracks you don’t want to change inadvertently while trimming,
you can lock these tracks in your sequence to prevent unwanted changes.
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Linked items on locked tracks aren’t affected when you move other linked clip items. For
example, if you select a video item to trim that’s linked to an audio item in a locked track,
moving the video item does not move the audio item, so they become out of sync.
For more information, see “Locking Tracks to Prevent Edits or Changes.” For information
about synchronizing clip items, see “Linking and Editing Video and Audio in Sync” and
“Tips for Edits Made with the Ripple Tool.”

Using the Command Key to “Gear Down”
The Command key is useful if you want to make very small changes to edit points or clips
in your sequence. When you drag clips or edit points to perform trimming operations,
the ratio between the motion of your mouse and the motion of the item you’re changing
is determined by the zoom level of the Viewer, Canvas, or Timeline. If you have trouble
trimming to a specific frame because you’re zoomed out too far, you can force this motion
to be a more precise one-to-one ratio (regardless of your zoom level) by pressing the
Command key after you start dragging.
For example, holding down the Command key after you start dragging an edit point with
the Roll tool makes the edit point move much more slowly as you drag.

Selecting Edits and Clips to Trim
Regardless of where you actually trim your clips, you almost always select the edit points
in the Timeline. Selecting an edit point is a lot like selecting an entire clip, except that
you are only selecting a clip’s In point or Out point, or the Out point and In point of two
adjacent clips. If linked selection is turned on, any edit points or clips that are linked to
the one you select are selected as well.

Tools for Selecting Edit Points
There are two tools in the Tool palette that can be used to select edit points in the
Timeline—the Selection tool and the Edit Selection tool.
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Selection Tool
You can select individual edit points by clicking them with the Selection tool. Select the
Selection tool by clicking it in the Tool palette or pressing the A key.

Selection tool

When you use the Selection tool
to adjust a clip’s edit point, the
icon changes to indicate it can
be used for trimming.

If you double-click an edit point using the Selection tool, the Trim Edit window appears,
showing the clips on either side of the edit point.
Edit Selection Tool
Instead of selecting individual edit points by clicking them with the Selection tool, you
can select multiple edit points (on multiple tracks) at once by using the Edit Selection
tool, designed specifically for selecting edit points. The Trim Edit window appears as soon
as you select edit points with this tool, showing the clips on either side of the edit point.
You can select the Edit Selection tool by clicking it in the Tool palette or pressing the G
key.

Edit Selection tool

Press a key when you click the Edit Selection tool to add these functions:
• Command key: Allows you to add and subtract edits from the current selection.
• Option key: Temporarily turns linked selection on if it is currently off, or off if it is currently
on.
• Shift key: Temporarily turns the Edit Selection tool into the Ripple tool, until you release
the Shift key.

Selecting Single Edit Points
A single edit point refers to a single clip item’s In point or Out point, or two adjacent clip
items’ Out and In points, respectively.
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To select a single edit point in the Timeline
Do one of the following:

µ

Select the Selection tool in the Tool palette, then click an edit point to select it in the
Timeline.
Note: You can double-click the edit point to open the edit in the Trim Edit window. See
“Trimming Clips Using the Trim Edit Window” for information.

µ
µ

Press V to select the nearest edit point.
Select the Ripple or Roll tools and then select an edit point.
For more information, see “Performing Slip, Slide, Ripple, and Roll Edits.”

µ

If an edit point is already selected, you can do the following:
• Press Single Quotation Mark (’) or the Up Arrow key to move the playhead in the Canvas
and Timeline to the next edit point, which is automatically selected.
• Press Semicolon (;) or the Down Arrow key to move the playhead in the Canvas and
Timeline to the previous edit point, which is automatically selected.

Selecting Multiple Edit Points
You can select edit points on more than one track. Only one edit point can be selected
per track.
To select multiple edit points in the Timeline
Do one of the following:

µ

Select the Selection tool in the Tool palette (or press Command-A), then Command-click
the edge of each clip.
Multiple edit points
are selected.

Note: If you have trouble selecting specific edit points with the Selection tool, you may
be zoomed out too far. Use the Zoom slider to get a more detailed view, then select your
edit again.
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µ

Select the Edit Selection tool in the Tool palette (or press Command-G), then drag to
select edit points on one or more tracks.
As you drag in the Timeline, this tool selects one edit per track. The edits don’t have to
be aligned in time. When you release the mouse button, the Trim Edit window appears.
One edit per track
is selected.

µ

Select the Ripple or Roll tool in the Tool palette, then click the edge of the clip.
Command-click to select multiple edit points. (See “Performing Slip, Slide, Ripple, and
Roll Edits” for information about the Ripple and Roll tools.)

Trimming with the Selection Tool
You can use the Selection tool to change the In or Out point of a single sequence clip,
leaving a gap. Because a gap is left, the total duration of your edited sequence is not
changed. This is important because it means this kind of trim edit doesn’t ripple clip items
out of sync with each other.
A

B

C

B

C

Before edit
Gap
A
After edit

Note: If you want to extend a clip’s In or Out point so that it overwrites an adjacent clip,
you can’t do this with the Selection tool. Instead, you can use the Roll tool, or select the
clip and drag it with the Selection or Slide tool.
Performing edits using the Selection tool is useful for filling in gaps between two clips
and for creating gaps in preparation for another editorial operation. When you trim an
edit point with the Selection tool, the Selection tool appears as a trimming tool.
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To trim a clip’s edit point in the Timeline using the Selection tool
1 Select the Selection tool in the Tool palette (or press the A key).
2 Move the pointer to the In or Out point of a clip in the Timeline.
The pointer changes to a Resize pointer.

Before

3 Drag to the left to create a gap in your sequence (by making the clip shorter) or to the
right to cover an existing gap (by making the clip longer).

As you drag to adjust
the length of a clip, the
Canvas shows the frame
at the current edit point.

After

Resulting gap

Later clips in the
sequence are unaffected.
They do not ripple to the
left to fill in the gap.

You can also achieve the same results by opening a sequence clip in the Viewer and
setting a new In or Out point. The clip changes duration in the Timeline, as long as the
new In or Out point doesn’t cause an adjacent clip to be overwritten.
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Extending and Shortening Clips in the Timeline
A convenient way to extend or shorten a clip in the Timeline is to tell Final Cut Pro to
adjust an edit point to the current position of the playhead. An extend edit moves an edit
point between two clips to the playhead position in the Timeline.
Note: Although these are often referred to as extend edits, you can just as easily shorten
clips with this method.
A
Before edit
A
After edit (extend)

A
Before edit
A
After edit (shorten)

When linked selection is disabled, extend edits are very useful for creating split edits. You
can also use extend edits to quickly line up a lot of edit points to the same position in
the Timeline. For example, to make all of the clips at the end of your movie end at exactly
the same place, you can select the last edit points in each track in the Timeline, move the
playhead to the position where you want all the clips to end, and then use an extend
edit to move all of the edit points to the playhead position at once.
To use an extend edit to change the duration of a clip in the Timeline
1 Select the edit points for the clips you want to extend using either the Selection tool or
the Edit Selection tool.
Note: To create a split edit, turn off linked selection by clicking the Linked Selection button
in the Timeline, or hold down the Option key to temporarily turn off linked selection while
you select edit points.
2 Move the playhead to the position in your sequence where you want to put the selected
edit point.

Before

3 Choose Sequence > Extend Edit (or press E).
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The selected edit point is rolled to the position of the playhead.
This clip lengthens.

This clip shortens.

After

If you selected multiple edit points for clip items in several tracks using the Edit Selection
tool, all of these clip edit points are moved to the position of the playhead.
Note: If you try to extend an edit farther than the total amount of media available in a
clip, Final Cut Pro does not extend the edit point.

Trimming Clips in the Viewer
You can trim clips in your sequence by opening them in the Viewer and adjusting the
clip In and Out points.
To open a clip in your sequence in the Viewer
Do one of the following:

µ
µ
µ

Double-click the clip in the Timeline.

µ

If the clip is in a nested sequence, hold down the Option key, then double-click the clip.

Select a clip in the Timeline, then press Return.
Double-click the clip in the Canvas. The clip currently beneath the playhead is opened
in the Viewer.
Note: If you just double-click the nested sequence, the nested sequence opens as a
sequence tab in the Canvas and Timeline, not as a clip in the Viewer.
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When a sequence clip is opened in the Viewer, the scrubber bar shows sprocket holes to
indicate that the clip is part of a larger sequence. Always check the scrubber bar in the
Viewer to make sure you are working with a clip from a sequence instead of a clip opened
from the Browser.
The title area shows the
name of the sequence
clip and includes the
name of the sequence
that contains it.

This is the Out point of
the sequence clip.

The Viewer scrubber bar
has two rows of small
dots when a sequence
clip is open.

When you open a sequence clip, it opens in the Viewer to the same frame where the
playhead is positioned in the Timeline or Canvas. If the Timeline playhead was beyond
the clip’s In or Out point, the Viewer playhead is placed on the clip’s In or Out point,
whichever was closest to the Timeline playhead.
To trim a clip in the Viewer
1 Open a clip from your sequence in the Viewer.
The scrubber bar shows virtual sprocket holes, which indicate that the clip is from your
sequence (not from the Browser).
2 Do one of the following:
• Use the transport controls or the J, K, and L keys to move the playhead in the Viewer
to a new point in your clip. Then set a new In or Out point using the Mark In and Mark
Out buttons or the I and O keys.
• Drag the In or Out point along the Viewer’s scrubber bar to a new point in your clip.
You can’t set a new edit point or drag a clip’s edit point so that it overwrites an adjacent
clip in the Timeline. If you try to, Final Cut Pro warns you that the clip you are trimming
has collided with another clip in the Timeline, and the trim edit is not performed (see
“Understanding Alert Messages When Trimming”). If you want to move a clip’s edit point
so that it overwrites an adjacent clip, you should roll the edit point between the two clips
using the Roll tool (see “Using the Roll Tool to Change Where a Cut Occurs”).
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Precision Editing Using Timecode
Most of the editing and trimming tools in the Timeline can be used numerically instead
of manually. You can select one or more clip items or edit points and then enter a positive
or negative number of frames, seconds, or even minutes or hours to adjust the position
of the clip items or edit points. This allows you to make precise adjustments, or to quickly
move clip items and edit points by specific values.

Determining What Kind of Edit Occurs When Entering Timecode Numbers
When you type a number in the Timeline, the current selections determine what kind of
edit occurs. For example, if both sides of an edit point are selected, typing “+15” rolls
both sides of the edit 15 frames forward (to the right). In this case, it doesn’t matter
whether the Roll tool or Selection tool is currently selected in the Tool palette. If an entire
clip is selected and the Slide tool is selected in the Tool palette, typing “+15” slides the
selected clip forward by 15 frames. If the Slip tool was selected instead, typing “+15”
would slip the selected clip by 15 frames.

Moving the Playhead in the Timeline Using Timecode
You can move the playhead in the Timeline using absolute timecode values (hours,
minutes, seconds, and frames) or relative timecode amounts (in which case you only need
to enter the relevant amount of information—just frames, or seconds and frames, for
example).
You can move the playhead by entering a new timecode number in the Current Timecode
field, or if no clips or edit points are currently selected, you can type a timecode number
directly in the Timeline and the playhead moves to the new position.
To avoid typing zeroes when moving by larger amounts, you can type a period as a
substitute for double zeroes (00). For example:
• To move to timecode 00:00:03:00: Type “3.” (3 and a period). The period is automatically
interpreted by Final Cut Pro as 00 in the frames field.
• To move to 00:03:00:00: Type “3..” (3 and two periods). These periods insert 00 into both
the seconds and frames fields.
• To move to 03:00:00:00: Type “3...” (3 and three periods).
Instead of moving the playhead to an absolute timecode number, you can move it relative
to its current position.
• To move the playhead 15 frames forward from the current position: Type “+15”.
• To move the playhead 1 minute and 20 frames backward from the current position: Type
“–01.20” (the period automatically adds 00 to the seconds field).
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Moving Clips Using Timecode
You can move one or more selected clips in the Timeline using timecode, even if they
are nonadjacent. However, if the resulting clip movement will cause an overwrite,
Final Cut Pro does not allow the clips to move. In this case, you can manually move the
clips.
To move a clip in your sequence using timecode
1 Select one or more clips in your sequence.
2 Do one of the following:
• To move the clips forward: Press Shift–Plus Sign (+) and type a timecode duration for
the move.
• To move the clips backward: Press Hyphen (-) and type a timecode duration for the
move.
The timecode entry field
appears when you type.

3 Press Return.

The clips move forward
by the duration entered.

Using Timecode to Trim Clips in the Viewer
If you’re trimming a clip in the Viewer, you can use timecode to navigate to a specific
frame, rather than trying to find the frame you want using the transport controls or the
J, K, and L keys. You then select the edit tool for the trimming operation you want to
perform and set a new In or Out point. For more information on navigating in the Viewer
using timecode, see “Navigating and Using Timecode in the Viewer and Canvas.”
To use timecode to set a clip’s In or Out point
1 Open a clip in the Viewer.

Chapter 45 Learning About Trimming Clips

727

2 Move the playhead by doing one of the following:
• Enter a timecode number for the frame where you want to place the new In or Out
point of the clip, then press Return.
For example, to move the In point from 02:40:30:10 to 02:40:30:27, enter “2403027”
and then press Return.
• Press Shift-I or Shift-O to move the playhead to the current In or Out point. Then enter
a relative timecode value to move the playhead.
For example, to establish a new Out point 2 seconds prior to the current Out point,
press Shift-O, then enter “–2:00” and press Return.
3 Select an edit tool in the Tool palette for the trimming operation you want to perform.
4 Do one of the following:
• Click the Mark In or Mark Out button.
• Press I to set an In point, or press O to set an Out point.
The scrubber bar in the Viewer shows the new position of the In or Out point, and the
Canvas/Timeline playhead moves to the adjusted edit point.

Understanding Alert Messages When Trimming
If you try to perform an edit that isn’t possible, Final Cut Pro displays an alert message.
Insufficient Content for Edit
This message appears when you try to perform a three-point edit (for example, when
dragging from the Browser or Viewer to the Canvas), and the source clip’s media file
doesn’t have enough frames to achieve the requested edit. Click OK to close this dialog.
For example, suppose you set sequence In and Out points to create an edit that is
10 seconds long. Next, you drag a 5-second source clip from the Browser to the Overwrite
section of the Edit Overlay in the Canvas. The “Insufficient content for edit” message
appears because the source clip does not have enough media to fill the 10-second duration
marked in the sequence.
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Media Limit
This message indicates that one of the sequence clip items you are trimming no longer
has enough media to continue trimming. This happens even though other clip items in
your selection still have additional media.

Media Limit message

For example, suppose you select the Out points of clip items on tracks V1, A1, and A2
and then roll the edit points to the right. If the clip item on V1 is shorter, a “Media Limit
on V1” message appears. You cannot roll these edit points beyond the media limits of
any of the clip items.
Clip Collision
This message appears when you try to perform an edit that might inadvertently cause
unselected clip items to overwrite others. This usually happens when you are trying to
perform a ripple edit on one track, and unselected clip items on other tracks cannot ripple
because there are other clip items in the way.
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For example, suppose you are rippling a clip item on track V1 to make it 10 seconds
shorter. In a ripple edit, all clip items that occur to the right of the edit point move left
or right by the amount you are trimming. In this case, all clip items should move 10 seconds
to the left to fill the gap. However, clip items in A1 and A2 cannot move to the left by
10 seconds because there are other clip items on those tracks that are in the way. The
Clip Collision message appears.
Clip Collision messages are important because they indicate that Final Cut Pro is making
sure that clip items in your sequence aren’t accidentally overwritten. This is especially
important when you are performing ripple edits in a small portion of your sequence and
you can’t see how clip items later in your sequence are being affected.
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Trimming Clips Using the Trim Edit
Window

46

This chapter covers the following:
• Learning About the Trim Edit Window (p. 731)
• Opening and Closing the Trim Edit Window (p. 732)
• Controls in the Trim Edit Window (p. 734)
• Using the Trim Edit Window (p. 739)
• Listening to Audio While Trimming (p. 744)
You can trim edits precisely in the Trim Edit window. As you trim, you can play back the
section of your sequence around the selected edit point to see your changes.

Learning About the Trim Edit Window
The Trim Edit window is a special environment for trimming one edit point at a time
while reviewing the complete media for both the incoming and outgoing clips. You can
also watch how your editing adjustments affect the cut point without stopping playback.
For many editors, this immediate visual feedback makes it much easier to match action
from the outgoing and incoming shots, align an edit point precisely to an audio cue, or
use the unique dynamic trimming function to instantly assign new edit points while you
play back your footage using the J, K, and L keys.

731

This window shows a two-up display, with the Out point of the outgoing clip on the left
and the In point of the incoming clip on the right. Two green bars—one at the top of
each clip—highlight which edit points the Trim Edit window will affect. Using the Trim
Edit window, you can perform a ripple edit to either side of the selected edit point, or a
roll edit to both sides. You can also slip clip In and Out points together to change what
part of the clip appears in the Timeline (see “Slipping Clips in the Timeline”).
Outgoing clip
Green bar

Incoming clip

There are four ways you can perform trim edits in this window:
• Drag the clip In and Out points in the Trim Edit window scrubber bars.
• Use the jog and shuttle controls to move the playheads on either side of the edit, and
then set new In and Out points using the Mark In and Mark Out buttons (or the I and
O keys).
• Move the playhead using the J, K, and L keys to find new Out and In points for the
selected edit point. If the dynamic trimming option is turned on, the selected edit point
moves to the new position of the playhead whenever you press K to stop playback.
• Use the Trim Forward and Trim Backward buttons (Shift-Right Bracket and Shift-Left
Bracket) to perform the selected trim operation to the outgoing and incoming clips on
either side of the edit point. The inner trim buttons trim an edit point by one frame,
whereas the outer, multi-frame trim buttons adjust edit points by a default duration
of five frames. You can perform ripple and roll edits using these buttons while the
selected edit plays back, trimming frame by frame as you watch the selected edit loop
over and over.
Note: The number of frames the multi-frame trim buttons add or subtract can be
changed in the Editing tab of the User Preferences window. For more information, see
“Choosing Settings and Preferences.”

Opening and Closing the Trim Edit Window
The Trim Edit window opens when you select edit points with certain tools. You can also
open the Trim Edit window manually at any time.
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To open the Trim Edit window
Do one of the following:

µ

Choose Sequence > Trim Edit (or press Command-7).
The playhead jumps to the closest edit point on the lowest-numbered track with Auto
Select turned on. The Trim Edit window shows the clips surrounding this edit point. By
default, both sides of the edit point are selected, so the Trim Edit window is set up to
perform a roll edit.

µ

Double-click an edit point in the Timeline with the Selection, Ripple, or Roll tool.

Double-click an edit point to
open the Trim Edit window.

The Trim Edit window displays the clips surrounding the edit point. The selected tool and
the part of the edit point you clicked determine the initial state of the green bars, which
define the kind of edit you can perform. Press the U key to switch between the Ripple
Outgoing, Roll, and Ripple Incoming trimming modes.

µ

Click an edit point or drag around one or more edit points using the Edit Selection tool.

You can also drag around
an edit point with the Edit
Selection tool to open the
Trim Edit window.

The Trim Edit window displays the clip items adjacent to the edit points you selected. If
you selected multiple edit points, the clip items located on the topmost video track are
displayed. You can change this using the Track pop-up menu.
To close the Trim Edit window
Do one of the following:

µ

Choose File > Close Window (or press Command-W).
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µ
µ

Move the playhead in the Timeline or Canvas away from the edit point.
Click anywhere in the Timeline away from an edit point to deselect all edit points in the
Timeline.

Controls in the Trim Edit Window
Before you begin using the Trim Edit window, you may want to familiarize yourself with
the controls.
Outgoing clip

Incoming clip

Current sequence timecode

Track pop-up menu
Green bar

Scrubber bar

Shuttle control

Playback controls
for the incoming clip
Jog control
Transport controls

Shuttle control
Playback controls
for the outgoing clip

Trim buttons

General Controls
The following are typical controls that you will use in the Trim Edit window.
• Current sequence timecode: Shows the timecode number of the currently viewed edit
point in the sequence. You can type a plus sign (+) or a minus sign (-) and a timecode
duration to adjust the edit forward or backward using the current mode (ripple or roll).

734

Chapter 46 Trimming Clips Using the Trim Edit Window

• Track pop-up menu: If you’ve selected multiple edit points, this pop-up menu lets you
choose the track that you want to view in the Trim Edit window. You can change the
track you’re viewing at any time.
• Green bar: Indicates what kind of trimming operation you’re about to perform:
• On the left side (over the outgoing clip): A ripple edit to the outgoing clip’s Out point
• On the right side (over the incoming clip): A ripple edit to the incoming clip’s In point
• Over both: A roll edit to the edit point between both clips
You can switch between these operations by pressing U or by clicking the relevant part
of the Trim Edit window (as described in “Trimming an Edit in the Trim Edit Window”).
• Scrubber bar: The scrubber bar runs along the entire width of each of the two viewer
areas in the Trim Edit window, below the video image. To scrub, or move, through a
clip or sequence, drag the playhead across the scrubber bar. You can also click anywhere
in the scrubber bar to instantly move the playhead to that location.
• Jog control: The jog control allows you to move the playhead as if you were actually
moving it with your hand, with a one-to-one correspondence between the motion of
your mouse and the playhead’s motion. For more information, see “Viewer Basics.” You
can also refer to “Canvas Basics.”
• Shuttle control: This control lets you quickly play through clips and sequences at different
speeds, in fast and slow motion. Drag the slider to the right to fast-forward and to the
left to rewind. Playback speed varies depending on the distance of the slider from the
center of the control. For more information, see “Viewer Basics.” You can also refer to
“Canvas Basics.”
Transport Controls
The Go to Previous Edit and Go to Next Edit buttons allow you to change which edit point
in your sequence is shown in the Trim Edit window. Other controls allow you to play back
only the edit you’re trimming to see how it works.
Go to Previous Edit

Play In to Out

Go to Next Edit

Play Around Edit Loop

Stop

• Go to Previous Edit: Click to move the previous edit point in your sequence into the
active area of the Trim Edit window.
• Play In to Out: Click to play from the beginning of the first clip to the end of the second
clip.
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• Play Around Edit Loop: Click to play from a point before the current playhead position
to a point following. The time intervals before and after the playhead position are
determined by the preview pre-roll and post-roll settings in the Editing tab of the User
Preferences window. For more information, see “Choosing Settings and Preferences.”
• Stop: Click to stop playback and position the playhead on the edit point.
• Go to Next Edit: Click to move the next edit point in your sequence into the active area
of the Trim Edit window.
Playback Controls for Individual Clips
These controls allow you to move the playhead on either side of the edit point without
modifying the edit point itself. The outgoing and incoming clips have separate playback
controls, which can also be controlled by the J, K, and L keys. The playback controls are
for viewing only; they don’t change the position of an edit point.
Important: The Space bar plays around the selected edit point in the Timeline; it does
not control playback in either side of the Trim Edit window. For more information, see
“Playing Incoming and Outgoing Clips in the Trim Edit Window.”
Play

Previous Frame

Next Frame

• Previous Frame: Use this control to jog the clip backward, one frame at a time.
• Play: Use this control to play the clip at normal speed.
• Next Frame: Use this control to jog the clip forward, one frame at a time.
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Trim Buttons
These controls let you trim clips as well as turn trimming on and off.

Trim Backward buttons

Trim Forward buttons
Dynamic Trimming
checkbox

• Trim Forward and Trim Backward: Click these buttons to add or subtract frames from
the duration between the In and Out points.
You can set the –5 and +5 buttons to trim a different number of frames by changing
the Multi-Frame Trim Size setting in the Editing tab of the User Preferences window.
The number of frames to trim can be set from 1 to 99. For more information, see
“Choosing Settings and Preferences.”
• Dynamic Trimming: Select this checkbox to turn dynamic trimming on and off, without
having to go to the User Preferences window. For more information, see “Dynamic
Trimming.”
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Outgoing Clip Area
Use these controls when trimming the outgoing clip.
Outgoing clip duration
Outgoing clip name

Current timecode
for the outgoing clip

Playhead

Mark Out button

Out point

Out Shift

• Outgoing clip duration: Displays the total time between the current In and Out points
for the outgoing clip. This value changes to reflect any trim edits.
• Current timecode for the outgoing clip: Displays the clip’s source timecode for the current
position of the playhead.
• Out Shift: Indicates the number of frames the Out point has been adjusted.
• Mark Out button: Click this button to set a new Out point for the outgoing clip at the
current playhead position. This performs a trim edit using the current mode (ripple or
roll).
• Out point: Displays the current Out point for the outgoing clip.
• Playhead: The playhead for the outgoing clip lets you locate and jump to different
parts of the clip quickly.
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Incoming Clip Area
Use these controls when trimming the incoming clip.
Incoming clip duration

Incoming clip name
Current timecode for
the incoming clip

Playhead

In Shift
In point

Mark In button

• Incoming clip duration: Displays the total time between the current In and Out points
for the incoming clip. This value changes to reflect any trim edits.
• Current timecode for the incoming clip: Displays the clip’s source timecode for the current
position of the playhead.
• In Shift: Indicates the number of frames the In point has been adjusted.
• Mark In button: Click this button to set a new In point for the incoming clip at the
current playhead position. This performs a trim edit using the current mode (ripple or
roll).
• In point: Displays the current In point for the incoming clip.
• Playhead: The playhead for the incoming clip lets you locate and move or jump to
different parts of the clip quickly.

Using the Trim Edit Window
You use the Trim Edit window to trim one or more edit points at a time. When trimming
multiple edit points at once, you can choose which edit point the Trim Edit window
displays and trim each edit point differently. If you change the type of edit you are
performing in the Trim Edit window, this change affects all of your selected edit points.
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Playing Incoming and Outgoing Clips in the Trim Edit Window
If you are performing a ripple edit in the Trim Edit window, the side of the Trim Edit
window with a highlighted green bar is controlled by the J, K, and L keys. However, if you
are performing a roll edit, both sides are highlighted. In this case, you choose whether
the outgoing or incoming clip is controlled by the J, K, and L keys by moving the pointer
over the outgoing or incoming side of the window. The Play button on the active Trim
Edit viewer is highlighted.
Important: The Space bar does not control playback on the incoming or outgoing sides
of the Trim Edit window.
To turn on playback with the J, K, and L keys in one side of the Trim Edit window
1 Move the pointer over the side you want to play.
The Play button is highlighted to indicate the side is active.
2 Use the J, K, and L keys to control playback on that side.

Dynamic Trimming
When the Dynamic Trimming checkbox is selected, the selected edit point moves to the
new position of the playhead whenever you use the J, K, or L keys. Press L to move forward,
press J to reverse playback, and press K to stop. Press J or L repeatedly to speed up and
slow down playback. Press K and either L or J together to perform slow-motion playback.
The playhead in the active Trim Edit viewer moves until you press K to stop. When playback
stops, the edit point in the active Trim Edit viewer is adjusted to the new position of the
playhead. A ripple or roll edit is performed depending on whether one side of the edit
point is selected, or both.

Trimming an Edit in the Trim Edit Window
Depending on how you like to work, you can choose one of several ways to use the Trim
Edit window.
To trim an edit point in the Trim Edit window
1 Select one or more edit points to trim using the methods described in “Opening and
Closing the Trim Edit Window.”
2 If you’re trimming multiple edit points, choose the track you want to view from the Track
pop-up menu.
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3 Choose a ripple or roll edit by doing one of the following:
• To trim the outgoing clip with a ripple left edit: Click the left image.
Trimming indicator bar
only appears above the
outgoing clip.

The pointer temporarily
turns into a Ripple tool.

• To perform a roll edit: Click the center area between the images.
Trimming indicator bar
appears over both clips.

The pointer temporarily
turns into a Roll tool.

• To trim the incoming clip with a ripple right edit: Click the right image.
Trimming indicator bar
only appears above the
incoming clip.

The pointer temporarily
turns into a Ripple tool.

• To switch between the three available trimming modes: Press the U key.
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A green bar appears above either or both sides of the edit to show you what kind of
trimming operation you’re performing.
4 Trim the edit point by doing any of the following:
• Click the trim buttons or use their keyboard equivalents to trim to the left or right using
the displayed frame increments.
• To trim backward or forward one frame: Press Left Bracket ([) or Right Bracket (]).
• To trim backward or forward five frames: Press Shift-Left Bracket ([) or Shift-Right
Bracket (]). The number of frames to trim can be customized with the Multi-Frame
Trim Size setting in the Editing tab of User Preferences. For more information, see
“Choosing Settings and Preferences.”
• Type a plus sign (+) or a minus sign (-) and the number of frames to add or subtract,
then press Return.
• Drag an edit marker in the scrubber bar to a new point in the outgoing or incoming
clip.
• Use the jog and shuttle controls to move the playhead within the outgoing or the
incoming clip. Then set a new Out point for the outgoing clip by pressing O or a new
In point for the incoming clip by pressing I.
• Use the playback controls to play the clip. Set a new Out point for the outgoing clip or
a new In point for the incoming clip.
• Use the J, K, and L keys to shuttle the playhead on either side of the edit point (you
choose which side by positioning the pointer there). As you move the pointer between
the left and right sides of the Trim Edit window, the left and right Play buttons become
highlighted. Don’t click, or you’ll change the selected trim operation.
Press L to move forward, press J to reverse playback, and press K to stop. Press J or L
repeatedly to speed up and slow down playback. Press K and either L or J together to
perform slow-motion playback.
If the Dynamic Trimming checkbox is selected, the selected edit point moves to the
new position of the playhead whenever you stop playback.
For all the above trimming methods, the In Shift and Out Shift fields show the total number
of frames that have been modified. The sequence and playhead in the Timeline
automatically update to reflect your changes.
5 Review your edit.
See “Reviewing and Playing Back Your Edits in the Trim Edit Window.”
6 To trim another edit point in the same track, use the Go to Previous Edit and Go to Next
Edit buttons to move to another edit point and display it in the Trim Edit window.
You can also select one or more edit points in the Timeline, and then go back to the Trim
Edit window to perform additional trim operations.
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7 When you have finished trimming, do one of the following:
• Move the playhead away from the edit point in the Canvas or Timeline.
• Click in the Timeline to deselect all edit points.
• Close the Trim Edit window.

Reviewing and Playing Back Your Edits in the Trim Edit Window
There are several ways you can play back your edits in the Trim Edit window, as well as
review them.
To play the edit using the transport controls
Do one of the following:

µ

Click the Play In to Out button to play from the beginning of the first clip to the end of
the second clip.

µ

Click the Play Around Edit Loop button or press the Space bar to loop the playback of
the edit. Extra frames surround your edit point, defined by the pre-roll and post-roll
settings specified in the Editing tab of the User Preferences window. For more information,
see “Choosing Settings and Preferences.”

µ

Click the Stop button to stop playback and position the playhead on the edit.
To view an individual clip in the Trim Edit window
Do one of the following:

µ
µ

Use the playback controls for the outgoing or incoming clip.
Activate the outgoing or incoming clip by moving your pointer over it. Press L to move
forward, press J to reverse playback, and press K to stop. Press J or L repeatedly to speed
up or slow down playback. Press K and either L or J together to perform slow-motion
playback.
Tip: As you use the J, K, and L keys, the audio shifts pitch smoothly rather than stuttering,
as it does when you scrub. For more information, see “Listening to Audio While Trimming.”

Slipping a Clip in the Trim Edit Window
The Slip tool changes the clip’s In and Out points simultaneously while maintaining the
clip’s duration. Surrounding clips are not affected. You can slip either of the clips displayed
in the Trim Edit window.
To slip an edit in the Trim Edit window
1 Double-click an edit point in the Timeline to open it in the Trim Edit window.
2 Do one of the following:
• Shift-drag the edit point in either scrubber bar to slip that clip.
• Select the Slip tool in the Tool palette, then drag the edit point.
As you drag, the display shows the In and Out point frames for the clip you are slipping.
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3 Release the mouse button.
4 When you’ve finished trimming, close the Trim Edit window.

Listening to Audio While Trimming
When you play back the outgoing or incoming clip in the Trim Edit window (using the J,
K, and L keys), you can choose which audio tracks you hear.
The following options are available in the Editing tab of the User Preferences window:
• Trim with Sequence Audio: With this option selected, you hear the entire audio mix
when you play back the clip on either side of the Trim Edit window. This helps you set
a new In or Out point based on audio cues in tracks where edit points aren’t selected.
This option is selected by default.
• Trim with Edit Selection Audio (Mute Others): Any audio tracks with selected edits are
played back. All others are muted.
If both options are deselected, you hear any tracks with selected edits, but clip item linking
is also taken into account. For example, if you select an edit point in V1, and the clip item
is linked to audio clip items in A1 and A2, you hear tracks A1 and A2. However, if clip
items in A1 and A2 are not linked to a clip item on V1, you won’t hear them.
Tip: In most situations, you should keep the Trim with Sequence Audio checkbox selected.
If you want to hear only specific audio tracks while trimming, select Trim with Edit Selection
Audio (Mute Others).
When you use the J, K, and L keys to play the outgoing or incoming clip, you may want
to hear all of the audio tracks in your sequence, such as music, sound effects, and
voiceover. This can be useful if you are listening for a particular audio cue to determine
when to make a cut.
To listen to all sequence audio tracks while using the J, K, and L keys in the Trim Edit
window
1 Choose Final Cut Pro > User Preferences, then click the Editing tab.
2 Select the Trim with Sequence Audio checkbox.
3 Select edit points in the Timeline and double-click them to open the Trim Edit window.
4 Move the pointer over the side of the Trim Edit window whose clip you want to play
back, then use the J, K, and L keys to play back the incoming or outgoing clip.
To hear only the selected audio tracks in the Timeline while using the J, K, and L keys
in the Trim Edit window
1 Choose Final Cut Pro > User Preferences, then click the Editing tab.
2 Select the Trim with Edit Selection Audio (Mute Others) checkbox.
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Important: Make sure the Trim with Sequence Audio checkbox is also selected.
3 Select edit points in the Timeline and double-click them to open the Trim Edit window.
4 Move the pointer over the side of the Trim Edit window whose clip you want to play
back, then use the J, K, and L keys to play back the incoming or outgoing clip.
Note: When you are working with multiple edit points in the Timeline, selecting an audio
track from the Track pop-up menu allows you to listen to only that audio track during
playback on either side of the Trim Edit window.
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This chapter covers the following:
• Learning About Transitions (p. 747)
• Adding Transitions Between Clips (p. 751)
• Moving, Copying, and Deleting Transitions (p. 757)
• Modifying Transitions in the Timeline (p. 759)
• Working with Default and Favorite Transitions (p. 762)
• Detecting Duplicate Frames over Transitions (p. 764)
• Video Transitions That Come with Final Cut Pro (p. 764)
• Using Alpha Transitions (p. 769)
You can add cross dissolves and other transitions between cuts to make your program
more interesting. You can also add a cross fade audio transition to smooth abrupt changes
in audio.

Learning About Transitions
A transition is a an effect used to change from one clip in your edited sequence to the
next. In the early days of film editing, the only transition you could immediately view was
a cut. Even the simplest transition, the dissolve, had to be specially set up in an optical
printer and sent back to the editor for viewing. The whole process was expensive and
could take several days.
Video made this process faster and easier. By mixing two video signals together, you
could watch a dissolve immediately and decide how you liked it. The more quickly you
can see how an effect will look, the more quickly you can refine it to suit your needs. Film
editors had to anticipate how transitions would look and how long they should last
without actually being able to preview them; there was never the time or budget to try
transitions during editing. It’s much easier to preview cross dissolves, fades, and other
transitions in a video system, and particularly in a nonlinear editing system. In Final Cut Pro,
you can continue to adjust a transition and preview it until you get it just right.
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Common Types of Transitions
A cut, the most basic type of transition, is a transition with no duration; when one shot
ends, another one immediately begins, without any overlap. All other transitions gradually
replace one shot with another; when one shot ends, another one gradually replaces it.
There are three very common video transitions used that occur over time: fades, cross
dissolves, and wipes.
• Fade-out: This begins with a shot at full intensity and reduces until it is gone. A fade-in
begins with a shot at no intensity and increases until it is full. These are the common
“fade to black” and “fade up (from black)” transitions.
• Cross dissolve: This involves two shots. The first shot fades out while the second shot
simultaneously fades in. During the cross dissolve, the two shots are superimposed as
they fade.
• Wipe: This is where the screen splits, moving from one side of the image to the other
to gradually reveal the next shot. It is more obvious than a fade or cross dissolve.
Final Cut Pro also comes with two audio transitions: a +3 dB cross fade (the default) and
a 0 dB cross fade.
• Cross Fade (+3 dB): Performs the same operation as Cross Fade (0 dB), but applies an
equal-power ramp to the volume level, rather than a linear ramp.
Note: An equal-power ramp uses a quarter-cycle cosine fade-out curve and a
quartercycle sine fade-in curve. As a result, the volume is maintained at a constant level
throughout the cross fade.
• Cross Fade (0 dB): Fades the first clip out, while simultaneously fading the second clip
in. This effect applies a linear ramp to the volume level. As a result, the volume level
dips in the middle of the cross fade.
Each cross fade results in a different audio level change as the transition plays. Your choice
of cross fades depends on the clips you’re transitioning between. Try one, then try the
other to see which sounds better.

Using Transitions in Your Sequences
Transitions, especially dissolves, generally give the viewer an impression of a change in
time or location. When very long transitions are used, they become more of a special
effect, useful in creating a different atmosphere in your sequence. You can use transitions
to:
• Convey the passing of time between scenes
• Fade up at the beginning of the movie or scene
• Create a montage of images
• Fade out at the end of the movie or scene
• Create motion graphic effects
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• Soften jump cuts (cuts between two different parts of the same footage)
Final Cut Pro comes with a variety of transitions you can use in your programs, but you’ll
probably use dissolves and wipes more than any others. For more information, see “Video
Transitions That Come with Final Cut Pro.”

How Transitions Appear in the Timeline
Transitions are applied between two adjacent clips in the same track of a sequence in
the Timeline. In the Timeline, a transition is displayed as an object overlapping two
adjacent clips. You can still see the cut point between the two clips. A dark gray slope in
the transition’s icon in your sequence indicates the speed, alignment, and direction of
your transition.
A transition between
two clips

The center line indicates
the original edit point
or cut.

By default, transitions have a total duration of 1 second. To change this, see “Changing
the Duration of a Transition in the Timeline.”
To apply a transition, both clips must have additional media (handles) that overlap past
the edit point.

Having Handles at Edit Points
Clips must have handles if you want to transition between them. Handles are additional
media frames before the In point and after the Out point of your clips. The first shot in a
transition (the outgoing clip) needs a handle after its Out point, while the second shot
in a transition (the incoming clip) needs a handle before its In point.
Outgoing
clip

Edit point

Incoming
Handle of
clip
incoming clip

Handle of
outgoing clip
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If the In point of your incoming clip begins on the first frame of the clip’s media file, you
have no handle at the beginning (or head) of your clip. Likewise, if the Out point of your
outgoing clip ends on the last frame of the clip’s media file, you have no handle at the
end (or tail) of your clip. If the clips don’t have enough media for the transition,
Final Cut Pro attempts to make the longest transition possible with the available clip
handles. In some cases, you may end up with transitions as short as one frame, which
may be difficult to see in the Timeline and are generally not intended or useful.

Aligning a Transition in the Timeline
You can place a transition so that it starts on, centers on, or ends on the edit point between
two clips in the Timeline. You should choose a transition alignment based on the editorial
effect you want to achieve:
• Starting on the cut: Choose this alignment if you want the last frame of the outgoing
clip to be fully visible before the transition begins.

A transition starting
on the cut

• Centered on the cut: Choose this alignment if you want the cut point between the two
clips to be the midpoint in the transition.

A transition centered
on the cut
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• Ending on the cut: Use this alignment if you want the first frame of the incoming clip
to be fully visible.

A transition ending
on the cut

Using Transitions in Projects to Be Exported as EDLs
Edit Decision Lists (EDLs) were developed for older tape-to-tape editing systems with
limited capabilities. Therefore, they can only describe a narrow range of transitions.
Typically, these transitions match standard transitions found on most broadcast video
switchers, designated by codes that have been standardized by the Society of Motion
Picture and Television Engineers (SMPTE).
Although today’s nonlinear editing systems have introduced a much wider variety of
transitions and effects, the EDL format continues to reflect the simplicity of older systems.
As a result, not everything that you can do in a Final Cut Pro sequence will show up as
expected in an exported EDL.
Keep the following in mind when creating a sequence that you may export as an EDL:
• EDLs don’t support transitions in any tracks other than V1. If you use transitions in other
tracks, they won’t appear in the EDL.
• Anything other than a cross dissolve or simple wipe is mapped to the closest
approximate SMPTE standard wipe pattern.
For more information on EDLs, see “Importing and Exporting EDLs.”

Adding Transitions Between Clips
You can add transitions when you edit a clip into the Timeline, or you can add transitions
between clips already in a sequence.

Adding Transitions with Clips You Add to the Timeline
You can choose the “Insert with Transition” or “Overwrite with Transition” options in the
Canvas Edit overlay when you edit a clip into your sequence. This adds the default
transition at the In point of the incoming clip and the Out point of the outgoing clip. The
default video transition is a 1-second cross dissolve, but you can change this if you wish
(see “Changing the Default Transition”).
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For information on performing edits with transitions, see “Performing an Insert with
Transition Edit” and “Performing an Overwrite with Transition Edit.”

Quickly Adding the Default Transition to Clips in Your Sequence
You can quickly add the default transition between two clips in your sequence. The default
video transition is a 1-second cross dissolve and the default audio transition is a +3 dB
cross fade. You can change the default transition if you wish (see “Changing the Default
Transition”).
To add the default video transition
Do one of the following:

µ

Select an edit point between two video clips or position the Canvas or Timeline playhead
at the desired edit point, then press Command-T.

Select an edit point
where you want to add
a transition.

µ

Control-click an edit point between two video clips in the Timeline, then choose Add
Transition from the shortcut menu.
The name of the current default transition appears next to the command in the shortcut
menu.
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If there are enough overlapping frames on both sides of the edit point, the selected
transition is added to your edit, centered at the edit point.
The added transition,
centered on the edit point.

To change the position of the transition, see “Changing the Alignment of a Transition in
the Timeline.”
To add the default audio transition
Do one of the following:

µ

Select an edit point between two audio clips or position the Canvas or Timeline playhead
at the desired edit point, then press Option-Command-T.

µ

Control-click an edit point between two audio clips in the Timeline, then choose Add
Transition from the shortcut menu.
The name of the current default transition appears next to the command in the shortcut
menu.
Once a transition has been applied, you can change the type of cross fade it is (0 or +3 dB)
by Control-clicking it again and choosing the appropriate transition from the shortcut
menu.

Adding Transitions to Clips in Your Sequence
You can add any type of transition, whether or not it’s the default transition, using the
Effects menu or the Effects tab in the Browser.
To add a transition from the Effects menu
1 Do one of the following:
• Click an edit point between two clips in your sequence to select it.
• Position the Canvas or Timeline playhead at the desired edit point.
• Position the Canvas or Timeline playhead on a transition that’s already been edited
into your sequence.
2 Do one of the following:
• Choose Effects > Video Transitions, choose the type of transition, then choose the
desired transition from the submenu.
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• Choose Effects > Audio Transitions, then choose the desired transition from the
submenu.
If there are enough overlapping frames on both sides of the edit point, the selected
transition is added to your edit, centered at the edit point. To reposition the transition,
see “Changing the Alignment of a Transition in the Timeline.”
Tip: All of the transitions that come with Final Cut Pro will be centered at the edit point
if applied from the Effects menu. If you add a favorite transition that you’ve customized
to appear either before or after the edit point, the transition is placed according to its
settings, provided there’s enough overlap at the selected edit point.

µ

To add a transition from the Effects tab in the Browser
Drag a transition from the Effects tab in the Browser to an edit point in the Timeline.

If there are enough overlapping frames between the two clips, you can drag the transition
to start on, center on, or end on an edit point. The transition snaps to one of these three
areas as you drag it close to the edit point. To reposition the transition, see “Changing
the Alignment of a Transition in the Timeline.”
You can limit the transition alignment to the start or end of the edit point by holding
down the Command key while you drag a transition around an edit point.

Quickly Adding Multiple Transitions to a Sequence
Instead of applying the same transition to individual edit points one by one, you can have
Final Cut Pro apply a transition multiple times to a selected range of clips. For example,
you can select a range of three clips in the Timeline and apply the same transition to all
the edit points in the range. You can also quickly reapply a different transition or a changed
transition to the same selected range. When replacing transitions this way, the replaced
transitions retain their previous length.
You can also set sequence In and Out points in the Timeline and have Final Cut Pro add
a transition to every edit point between the sequence In and Out points.
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You can apply multiple video transitions to your video tracks or multiple audio transitions
to your audio tracks. To apply a transition to multiple video edit points, select the video
track of the clips to which you want to add transitions. To add a transition to multiple
audio edit points, select the audio track of the clips to which you want to add transitions.
To add a transition multiple times to a selected range of clips
1 Drag or Shift-click to select the range of clips to which you want to add transitions.
If you are adding a video transition, drag or Shift-click the video tracks of your selection.
To add an audio transition, drag or Shift-click the audio tracks of your selection. You
cannot add transitions to non-adjacent clips, you must select a continuous range. If you
select a single clip, Final Cut Pro adds transitions to the beginning and end of the selected
clip.
2 Do one of the following:
• Choose the video transition or audio transition you want from the Effects menu.
• Open the Effects tab of the Browser and drag the video transition or audio transition
you want onto the selected range of clips. Drag to the middle of a clip in the range
(not to the end of the clip). When the clips appear selected with a brown outline, release
the mouse button to apply the transition.
Tip: An efficient way to add video transitions is to select the transition you most frequently
use as a favorite. You can then select a range of clips in the Timeline and press Command-T
to apply the transition. You can also quickly apply your favorite audio transition by pressing
Command-Option-T
If any of the edit points within the selected range have insufficient media as handles to
create the transition, a message appears telling you that a transition cannot be applied.
You can choose to cancel the procedure or have Final Cut Pro apply the transition to all
the edit points that do have sufficient media.
If you have trouble dragging the transition to the middle of a clip, try zooming in to make
positioning the pointer on the middle of the clip easier.
You can also set sequence In and Out points to specify a range of clips to which you want
to add transitions. When you set a sequence In and Out point, Final Cut Pro applies the
transition to all the edit points between the In and Out points.
To add transitions to clips by setting sequence In and Out points
1 Click in the Timeline to position the playhead where you want to set a sequence In point,
then choose Mark > Mark In (or press I) to set a sequence In point.
2 Click in the Timeline to position the playhead where you want to set a sequence Out
point, then Choose Mark > Mark Out (or press O) to set a sequence In point.
3 Choose the video transition or audio transition you want from the Effects menu.

Chapter 47 Adding Transitions

755

You can also apply multiple transitions by setting a single sequence In or Out point. When
you set an In point only, Final Cut Pro adds the transition to all edit points after the In
point to the end of the sequence. When you set an Out point only, Final Cut Pro adds
transitions to all edit points from the beginning of the sequence up to the Out point.
You can also change an existing transition and then apply the change to multiple other
transitions in a selected range.
To change a transition and apply the changes to other transitions in a selected range
1 Double-click the transition in the Timeline that you want to change.
2 Make changes to the transition when it opens in the Viewer window.
3 With a range of clips selected, drag the drag hand from the Viewer window down to the
range of selected clips.

Example: Transitioning to or from Black
A fade to black is really just a cross dissolve from a clip to black. In Final Cut Pro, you can
add black to the Timeline by adding a slug, which is a built-in Final Cut Pro video generator.
It’s often better to have an actual black clip to trim or adjust as needed. However, you
can create a cross dissolve from a clip to a gap for a similar effect.
Important: Fading to black by creating a cross dissolve from a clip to a gap works only
if there are no other video tracks with clips beneath the gap.

µ

To fade to or from black
Add a cross dissolve transition to one of the following:
• The beginning of the first clip in your sequence
• The end of the last clip in your sequence
• The beginning or end of any clip with a gap on one or both sides
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For more information, see “Adding Transitions to Clips in Your Sequence.”

If the transition starts at the
beginning of the sequence,
you’ll see a fade from black.

If the transition is placed
at the end of the last clip,
you’ll see a fade to black.

Moving, Copying, and Deleting Transitions
After you add a transition, you can move it or change its edit point. You can also copy
transitions to quickly add the same transition at another point in your sequence (then
modify its properties later, if desired). You can also delete the transition.

Moving a Transition to Another Edit Point
You can move a transition from one edit point to another. The transition is removed from
the previous edit point and located at the new edit point. If there’s already a transition
at the new edit point, it’s replaced by the new transition.

µ

To move a transition in a sequence
In the Timeline, drag a transition from its current edit point to the desired edit point.

Chapter 47 Adding Transitions

757

If there are enough overlapping frames on either side of the edit, you can drag it before
the edit point, on the edit point, or after the edit point.

Drag the transition to
the new edit point.

Copying and Pasting Transitions
To add the same transition quickly elsewhere within your sequence, you can copy and
paste a transition to other edit points. This is helpful if you’ve changed a transition’s
default settings and want to use the modified transition again. (You can also make
frequently used transitions “favorites.” For more information, see “Saving a Transition as
a Favorite.”)
To copy a transition from one edit point to another
1 Do one of the following:
• In the Timeline, select the transition you want to copy, then press Command-C.
• Control-click the transition, then choose Copy from the shortcut menu.
2 Do one of the following:
• Select the edit point where you want to add the transition, then press Command-V.
• Control-click the edit point where you want to add the transition, then choose Paste
from the shortcut menu.

µ

To copy a transition from one edit point to another by dragging it
Hold down the Option key while dragging an existing transition to another edit point.

Deleting Transitions
Transitions that you’ve added to your sequence can easily be removed.
To delete a transition from a sequence
1 Select the transition you want to remove in the Timeline.
2 Do one of the following:
• Choose Edit > Clear (or press Delete).
• Control-click the transition, then choose Cut from the shortcut menu.
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Modifying Transitions in the Timeline
Once a transition is placed on a track, you may want to alter the duration to make it longer
or shorter, or change its alignment by choosing where the transition begins relative to
the edit point between two clips. You can also replace transitions.
Note: To make very precise adjustments to transitions, you can use the Transition Editor.
For more information, see “Refining Transitions Using the Transition Editor.”

Changing the Duration of a Transition in the Timeline
You can change the duration of a transition, as long as there are enough overlapping
frames to accommodate your new duration. When you change the duration of a transition
in the Timeline, the way the duration changes depends on the alignment of the transition.
• If the transition ends on the edit point: The duration affects the clip to the left of this
point (the outgoing clip).
• If the transition is centered on the edit point: Changes in duration extend in both
directions.
• If the transition starts on the edit point: The duration affects the clip to the right of this
point (the incoming clip).
You can change the duration of a transition by dragging or by using timecode.
To change a transition’s duration in the Timeline by dragging
1 Select the Selection tool, then move the pointer to the beginning or the end of the
transition in the Timeline.

The pointer changes to the Resize
pointer, indicating that you can
drag to the duration you want.

2 Drag either side of the transition to make the duration longer or shorter.
To change a transition’s duration in the Timeline using timecode
1 Do one of the following:
• Double-click the transition in the Timeline.
• Control-click the transition in the Timeline, then choose Duration from the shortcut
menu.
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• Select the transition in the Timeline, then press Control-D.
2 In the Duration dialog, enter a new duration for the transition, then click OK.

Enter a new
duration here.

Tip: If you enter a duration that’s longer than the available amount of overlap between
these two clips, you hear an alert sound and the maximum duration possible is displayed
in the dialog. You can change the duration or click OK to use the maximum duration. A
convenient way to determine the maximum duration of a transition is to enter a high
number here, such as 9999 (in most cases, much less will do) and click OK. The maximum
duration possible appears in the dialog.

Changing the Alignment of a Transition in the Timeline
Transitions can either start on, center on, or end on an edit point. This alignment can be
changed at any time. Changing the alignment of a transition allows you to precisely
control which frames are fully visible when a transition begins or ends.
To change the alignment of a transition in a sequence
Do one of the following:

µ

In the Timeline, select the transition, choose Sequence > Transition Alignment, then
choose another alignment from the submenu.

µ
µ

Control-click a transition, then choose another alignment from the shortcut menu.
Select a transition, then do one of the following:
• To start the transition at the edit point: Press Option-1.
• To center the transition on the edit point: Press Option-2.
• To end the transition at the edit point: Press Option-3.
The transition moves to the new alignment position.

760

Chapter 47 Adding Transitions

Changing an Edit Point After Adding a Transition
Even with transitions applied, you can still trim one or both sides of the edit point (for
example, using the Ripple, Roll, Slip, or Slide tool). Both the alignment and duration of
the transition remain the same. For more information on these types of edits, see
“Performing Slip, Slide, Ripple, and Roll Edits.”

Before a roll edit

After a roll edit, with the transition moved

Note: The transition itself limits how far you can trim clips on either side of the edit point,
because the transition requires a certain amount of media on one or both sides of the
edit point.

Replacing Transitions
If you change your mind about which transition you want in an edit, it’s easy to change
it.
To swap a transition in your sequence with another
Do one of the following:

µ

Move the Timeline playhead over the transition you want to change (or click to select it),
choose Effects > Video Transitions or choose Effects > Audio Transitions, then choose
another transition from the submenu.

µ

Drag a transition from the Effects tab in the Browser onto the transition you want to
change in the Timeline.
When the pointer is over the old transition, it will be highlighted to show it’s about to be
replaced.

Chapter 47 Adding Transitions

761

Note: If you replace a transition in your sequence with a transition you’ve saved as a
favorite, the favorite transition’s duration overrides that of the transition it’s replacing.
For more on favorite transitions, see “Saving a Transition as a Favorite.”

µ

Control-click an audio transition, then choose another transition from the shortcut menu.
Since there are only two kinds of audio transitions, they both appear in this menu.

Working with Default and Favorite Transitions
Final Cut Pro comes with default transitions; a 1-second cross dissolve is the default video
transition and a +3 dB cross fade is the default audio transition. You can change the
default to be another transition, including one that you’ve customized. If you use the
same transition multiple times, you may want to consider making it a favorite, so it’s
easier to add to your sequence.

Changing the Default Transition
You can change the default transition to any transition that comes with Final Cut Pro, or
to a transition you’ve customized.
To change the default video or audio transition
1 Click the Effects tab of the Browser.
2 Click the disclosure triangle next to Video Transitions or Audio Transitions.
3 Click the disclosure triangle of the transitions bin containing the transition you want as
the default.
4 Do one of the following:
• Select a video or audio transition, then choose Effects > Set Default under the Video
Transitions or Audio Transitions section of the menu.
• Control-click a transition, then choose Set Default Transition from the shortcut menu.
The default transition appears with underlined text in the Effects tab of the Browser as
well as in the Effects menu.

Saving a Transition as a Favorite
You can save a transition as a favorite so you can quickly use it again in the future. This
is handy if you’ve customized a transition or set a transition to a specific duration. You
can name each favorite to reflect its effect, such as a modified duration. You can create
bins in the Favorites bin by dragging an existing bin from the Effects tab or the current
project tab.
To save a favorite transition
Do one of the following:

µ
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Drag a transition from a sequence in the Timeline to the Favorites bin in the Effects tab
of the Browser.
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µ

Drag a transition from the Video Transitions or Audio Transitions bin to the Favorites bin
in the Effects tab of the Browser.
The transition now
appears as a copy.

To rename a favorite transition
1 Select the transition in the Favorites bin in the Effects tab of the Browser.
2 Click the transition’s name to highlight the name field.
3 Enter a new name, then press Return.

Deleting Favorite Transitions
If you’ve added a transition as a favorite, you can delete it at any time from the Favorites
bin. If it’s a transition that comes with Final Cut Pro, it will still appear in the Video
Transitions or Audio Transitions bin.
To delete a favorite transition
1 Select the transition in the Favorites bin in the Effects tab of the Browser.
2 Select Edit > Clear (or press Delete).
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Detecting Duplicate Frames over Transitions
When Show Duplicate Frames is turned on in a sequence’s settings and a clip appears
more than once within a single edited sequence, the duplicate frames are marked by a
colored bar appearing at the bottom of the clip’s video item in the Timeline.

The red bars indicate
duplicate frames used
within a sequence.

However, if the duplicated frames fall outside the boundaries of the clip in the Timeline
or fall within a transition, a special indicator—four white dots—appears where the
duplicate frames are located. The dots can appear on either side or both sides of the
transition. The side of the transition the dots appear on indicates the clip or clips that use
duplicate frames. When you zoom out, the white dots decrease in range from four to
zero, depending on the zoom level.

The white dots indicate
duplicate frames used
in a transition.

For more information about duplicate frame detection, see “Timeline Basics.”

Video Transitions That Come with Final Cut Pro
There are numerous video transitions that ship with Final Cut Pro. The sections that follow
group the filters into various categories and then discuss what each is used for.
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3D Simulation
Transition

Result

Cross Zoom

Causes the video to zoom in on the first clip, switch to the second,
and zoom out. You can specify the center point, the amount of
magnification in the zoom, and the degree of blur applied during
the zoom.

Cube Spin

Creates a three-dimensional cube from each clip and spins it in the
direction you choose. You can also view the cube from the inside
or the outside.

Spin3D

Spins the first clip around its center point, revealing the second clip.
You can choose the angle of the spin axis.

Spinback3D

Spins the first clip around its center point until the clip is viewed
from its edge, and then switches to the second clip, which spins
into view. You can choose the angle of the spin axis.

Swing

Creates the effect of swinging the first clip in toward the viewer or
out toward the second clip, which is revealed as the swing widens.
You can choose the angle of the swing axis.

Zoom

Zooms the second clip in from a single center point to full-frame
size, over the top of the first clip. You can specify the center point
(relative to the first clip) where the zoom begins.

Dissolve
Transition

Result

Additive Dissolve

Adds the two clips so that the first clip fades out and the second
fades in.

Cross Dissolve

Blends the first clip into the second clip.
Renders with 10-bit precision if your sequence is set for 10-bit
precision in the Video Processing tab of the Sequence Settings
window.

Dip to Color Dissolve

Blends the first clip into the plain color of your choice, and then
blends the plain color into the second clip. You can adjust the speed
of the blend.

Dither Dissolve

Dissolves the first clip into the second by removing random pixels
from the first clip to reveal the second clip.

Fade In, Fade Out

Fades in the incoming clip as the outgoing clip fades out. Reveals
the track below the current track in a transition.

Non-Additive Dissolve

Compares the pixels in the two clips and displays the lighter of the
two as the first clip fades out and the second fades in.

Ripple Dissolve

Applies a pond ripple effect to the first clip, simultaneously blending
it into the second. You can choose the number of ripples, their
center point on the first clip, and their amplitude and acceleration.
You can also apply a circle highlight to the ripples.
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Iris
Transition

Result

Cross, Diamond, Oval, Point,
Rectangle, and Star

These effects are similar, but have different shapes. They all create
the impression of an iris, which contains the first clip, opening to
reveal the second. In each iris effect, you can specify the center
point around which the opening is defined and feather the edges,
which blends the edges of the clips together and gives a diffused
iris.

Map
Transition

Result

Channel Map

Maps channels from the first and second clip, or fills the channels
with black. You can invert individual channels.

Luminance Map

Maps color using the luma of a clip.

Page Peel
Transition

Result

Page Peel

Peels the first clip away to reveal the second clip. You can adjust
the appearance of the peel.

QuickTime
QuickTime includes a set of built-in video effects listed here, some of which are
implementations of standard effects defined by the Society of Motion Picture and
Television Engineers (SMPTE). For more information, visit the Apple QuickTime website
at http://www.apple.com/quicktime.
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Transition

Result

Channel Compositor

Combines two images using the alpha channels of the images to
control the blending. It provides the standard alpha blending
options and can handle pre-multiplying by any color, although
white and black are most common and often run faster.

Chroma Key

Combines two sources by replacing all the pixels of the first source
that are the specified color with the corresponding pixels of the
second source. This allows the second source to show through the
first. This appears to put the second clip behind the first clip and
make the selected color transparent.

Explode

The second clip grows from a single point, expanding outward until
it entirely covers the first clip. The center point of the explosion is
defined in the effect parameters.

Gradient Wipe

Uses a matte image to create a transition between two source
images. The transition from the first clip to the second clip occurs
first where the matte image is darkest, last where the matte image
is brightest.
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Transition

Result

Implode

The first clip shrinks down to a single point, revealing the second
clip. The center point of the implosion is defined in the effect
parameters.

Iris

The first clip opens like an iris to reveal the second clip.

Matrix Wipe

These are a series of matrix reveal type effects that take place
between two sources.

Push

One source image replaces another, both images moving at the
same time. For example, the first clip occupies the entire frame,
then the second clip pushes in from the right while the first clip
slides out to the left. Unlike the slide effect, both sources are moving.
The push effect executes from the top, right, bottom, or left.

Radial

The first clip sweeps in a radial (or semi-circular) way to reveal the
second clip.

Slide

The second clip slides onto the screen to cover the first clip. The
angle from which the second clip enters the frame is stored in a
parameter, with 0 degrees being the top of the screen.

Wipe

The first clip wipes to reveal the second clip.

Zoom

One clip zooms in or out of the other clip.

Slide
Transition

Result

Band Slide

Bands of the first clip slide in parallel directions to reveal the second
clip. You can adjust the number of bands and the slide direction.

Box Slide

Bands of the first clip slide one at a time in perpendicular directions
to reveal the second clip. You can adjust the number of bands and
the slide direction.

Center Split Slide

Reveals the underlying clip by splitting the current clip down the
center and horizontally sliding the two halves away from each other.

Multi Spin Slide

Boxes of the first clip spin and zoom out to reveal the second clip.
You can adjust the spin about the center of the first clip and the
spin about the center of the box, as well as the number of boxes.

Push Slide

The second clip pushes the first clip out of view. You can adjust the
push direction.

Spin Slide

Boxes of the first clip spin and zoom out to reveal the second clip.
You can adjust the spin about the center of the box and the number
of boxes.

Split Slide

The first clip splits at specific points and slides to reveal the second
clip. You can adjust the orientation of the split.

Swap Slide

The first (top) and the second (bottom) clips slide in opposite
directions, swap places, and slide back, revealing the second clip.
You can adjust the slide direction.
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Stretch
Transition

Result

Cross Stretch

The first clip is squeezed as the second clip stretches from the
specified edge to the opposite edge.

Squeeze

The first clip is squeezed from the opposite edges toward the center
to reveal the second clip. You can specify the squeeze orientation

Squeeze and Stretch

The first clip is squeezed from the opposite edges toward the center
and stretches in a perpendicular direction to reveal the second clip.
You can adjust the squeeze orientation.

Stretch

The second clip stretches from the specified edge over the first clip.

Wipe
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Transition

Result

Alpha Transition

Uses animated assets to define a wipe. You can create complex
transitions that are reusable and retimable. For more information,
see “Using Alpha Transitions.”

Band Wipe

Wipes a band across the first clip to reveal the second. You can
specify the number of bands and the wipe direction.

Center Wipe

A linear wipe from a specified point on the first clip reveals the
second clip. You can adjust the wipe direction.

Checker Wipe

Checkered boxes appear on the first clip to reveal the second clip.
You can adjust the number of boxes and the wipe direction.

Checkerboard Wipe

Checkered boxes wipe individually on the first clip to reveal the
second. You can adjust the number of boxes and the wipe direction.

Clock Wipe

A rotational wipe over the first clip reveals the second. You can
adjust the start and direction of the wipe and the center point of
the rotation.

Edge Wipe

A linear wipe from the edge of the first clip reveals the second clip.
You can adjust the wipe direction.

Gradient Wipe

Uses a gradient wipe image to wipe across the first clip, revealing
the second clip. You can adjust the softness of the wipe and invert
the gradient wipe image. By default, the transition wipes horizontally
from left to right. You can override this by dragging an image onto
the gradient clip well.

Inset Wipe

A rectangular wipe from the specified edge or corner of the first
clip reveals the second clip.

Jaws Wipe

A jagged-edged wipe from the center of the first clip reveals the
second clip. You can adjust the wipe direction and the shape of the
jagged edge.

Random Edge Wipe

A linear wipe with a random edge from the edge of the first clip
reveals the second clip. You can adjust the direction of the wipe
and the width of the random edge.
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Transition

Result

V Wipe

A V-shaped wipe from the specified edge of the first clip reveals
the second clip.

Venetian Blind Wipe

Bands wipe across the first clip to reveal the second. You can adjust
the angle and the number of bands.

Wrap Wipe

Bands wipe in the specified direction across the first clip to reveal
the second clip. You can specify the start and orientation of the
wipe and the number of bands.

Zigzag Wipe

Bands wipe in a zigzag pattern over the first clip to reveal the second
clip. You can specify the start and orientation of the wipe and the
number of bands.

Using Alpha Transitions
Alpha transitions are wipes with animated media assets. With alpha transitions, you can
easily create complex transitions that you can reuse and retime.
Having a logo or other visual element wipe across the screen to transition from one scene
to another is a common technique. It is possible to create this effect in a Final Cut Pro
sequence using alpha mattes, luma mattes, and a few video tracks. However, moving the
transition, duplicating it, or changing its speed can be cumbersome. Alpha transitions
make this common editing technique simple and easily reproducible.

Adding Alpha Transitions to the Timeline
You apply an alpha transition just as you would any other transition. After you apply the
alpha transition in the Timeline, you can create the specific visual effect you want by
building and modifying the transition in the Transition Editor window.
To apply an alpha transition from the Effects menu
1 Do one of the following:
• Click an edit point between two clips in your sequence to select it.
• Position the Canvas or Timeline playhead at the desired edit point.
• Position the Canvas or Timeline playhead on a transition that’s already been edited
into your sequence.
2 Choose Effects > Video Transitions > Wipe > Alpha Transition.
For more information about adding transitions, see “Adding Transitions to Clips in Your
Sequence.”
To open the Alpha transition in the Transition Editor
Do one of the following:

µ
µ

Double-click the transition.
Select the transition’s icon, then choose View > Transition in Editor.
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µ

Control-click the transition, then choose Open from the shortcut menu.

About the Alpha Transition Controls
Use the following controls to create and modify the alpha transition in the Transition
Editor window. For more information about the Transition Editor, see “Refining Transitions
Using the Transition Editor.”
Scale Transition Asset
Durations checkbox

“Clip” clip well
Clip Alpha Matte clip well
Wipe Matte clip well
Opacity slider and field
Mid-point Offset slider
and field
Reverse Transition Assets
checkbox

• “Clip” clip well: This is where you place the main element clip that wipes across the
screen revealing the next scene underneath it. This clip may or may not contain a
straight alpha channel.
• Clip Alpha Matte clip well: If the element clip that you dropped into the “Clip” clip well
does not contain an alpha channel, you can drop a clip into this clip well to create an
alpha channel from its luma values.
• Wipe Matte clip well: The actual wipe animation between the two clips in the Timeline
is determined by the luma values of the clip dropped into this clip well. Any white areas
in this clip will display the first clip. Any black areas in this clip will display the second
clip. Any levels of gray will display the appropriate mix of the two clips. The wipe
generated by this clip well is generally invisible to the viewer because it happens
underneath the main element clip. However, if you place a clip in this well only, you
can create a luma-based wipe.
• Scale Transition Asset Durations checkbox: Select this checkbox to scale the duration of
the media in the clip wells to fit the duration of the transition in the Timeline.
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Note: Lengthening or shortening the duration of the media asset may result in a possible
loss of temporal quality. You can deselect this checkbox to make sure the media assets
retain their native duration regardless of the length of the transition in the Timeline.
This may cause the media assets to be abridged if the transition in the Timeline is not
long enough.
• Reverse Transition Assets checkbox: Select this checkbox to reverse the transition.
• Opacity slider and field: Use this slider to adjust the opacity of the element clip that is
in the “Clip” clip well.
• Mid-point Offset slider and field: If there is no clip in the Wipe Matte clip well, the effect
will simply cut from the first Timeline clip to the second Timeline clip. By default, this
cut occurs at the midpoint of the transition. The Mid-point Offset parameter allows you
to roll the cut point to the left or right. This can be useful if the element clip in the
“Clip” clip well completely obscures the screen at some point other than the transition’s
center, making a background wipe unnecessary.

Creating and Modifying Alpha Transitions
You can use several different methods to create alpha transitions.
Asset Wipe Transition Using Three Clips
In this method, you drag three different elements into the three different clip wells to
create an effect in which an animated media element wipes across the screen, revealing
the next scene underneath it. This three-clip method generally ensures the best results
with alpha transitions.
To create an asset wipe transition using three clips
1 Drag the main element clip to the “Clip” clip well.

In this example image, the media element moves across the screen, essentially “wiping”
the frame from right to left.
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2 Drag the luma track matte clip to the Clip Alpha Matte clip well.

The white area in this clip should be an exact outline of the media element you added
in Step 1. White represents 100% opaque and black represents 100% transparent. Levels
of opacity can also be assigned using shades of gray.
3 Drag the wipe matte clip to the Wipe Matte clip well.

This clip determines the wipe between the two Timeline clips. Any white areas in this clip
will display the first clip. Any black areas in this clip will display the second clip.
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In the resulting effect, the media element wipes across the screen to reveal the next shot
from right to left.

Asset Wipe Transition Using Two Clips
In this technique, you drag an element clip that already contains an alpha channel into
the “Clip” clip well. This makes the track matte element in the Clip Alpha Matte clip well
unnecessary.
Note: This method requires a video codec that supports alpha channels.
To create an asset wipe transition using two clips
1 Drag the main element clip to the “Clip” clip well.

This clip contains the main media element as well as an embedded alpha channel.
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2 Drag the wipe matte clip to the Wipe Matte clip well.

This clip determines the wipe between the two Timeline clips. Any white areas in this clip
will display the first clip. Any black areas in this clip will display the second clip.
In the resulting effect, the media element wipes across the screen to reveal the next shot
from right to left.
Custom Transition Using One Clip
You can use the animated luma values of just a single clip to create complex animated
transition effects.

µ

To create a custom transition using one clip
Drag a wipe matte clip to the Wipe Matte clip well.

This clip determines the wipe between the two Timeline clips. Any white areas in this clip
will display the first clip. Any black areas in this clip will display the second clip.
Alpha Transition Using the Mid-point Offset Slider
Instead of using the wipe matte to determine the change from the first Timeline clip to
the second Timeline clip, your main media element clip could momentarily fill the frame
at some point during the transition. Using the Mid-point Offset slider, you can time the
cut from the first clip to the second clip to occur exactly at the moment the frame is filled
with the media element.
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By default, this cut between the two Timeline clips occurs at the midpoint of the transition.
The Mid-point Offset allows you to roll the cut point to the left or right.

µ

To create an alpha transition with the Mid-point Offset slider
Drag the slider so that the cut between the two Timeline clips occurs while the main
media element fills the frame.
Tip: You can use the Opacity slider to temporarily reduce the opacity of the media element
(to make it easier for you to find the cut between the two Timeline clips).

Creating Your Own Alpha Transition Elements
Use the following guidelines for best results when creating your own alpha transition
media elements.
Frame Rates
If you are creating transitions to be applied to interlaced content, create the media
elements with progressive frame rates at double the frame rate of the content. This allows
Final Cut Pro to regenerate the interlacing properly if the transition time is different from
the clip time.
If you are creating transitions to be applied to progressive content, create the media
elements at the frame rate of the content.
If you want to stretch the length (duration) of your transitions, you may want to create
them at the maximum frame rate multiple possible. For example, a transition used in a
24-frames-per-second sequence could be rendered at 96 frames per second, which would
allow you to stretch the transition to four times its native length without a loss in temporal
quality.
Media Elements with Alpha Channels
For the best results, create a second clip that works as a luma track matte for the three-clip
method. (See “Asset Wipe Transition Using Three Clips.”) If you do decide to use an
embedded alpha channel, you will get best results with transition assets that do not have
areas of semitransparency. Alpha channels should be rendered as Straight. Rendering
the alpha channel as Premultiplied will yield undesirable results. If you are rendering
assets from Motion, be sure to deselect the Premultiply Alpha checkbox in the Output
settings.
Media Elements Without Alpha Channels
Even when you are using media elements without alpha channels, it is still important
that you force the clip to render with Straight color at Millions color depth. Playing these
clips in QuickTime Player will display unexpected results, but they will composite correctly
in Final Cut Pro or any editing or compositing application.
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Refining Transitions Using the
Transition Editor

48

This chapter covers the following:
• Using the Transition Editor (p. 777)
• Applying a Modified Transition Directly to a Sequence in the Timeline (p. 785)
• Trimming Transitions and the Surrounding Clips (p. 785)
• Previewing and Rendering Transitions (p. 789)
Use the Transition Editor to precisely modify a transition and preview it before you render.

Using the Transition Editor
If you want to make more precise changes to a transition than editing in the Timeline
allows, or if you want to create custom settings for transitions that you use frequently,
you can use the Transition Editor.
The Transition Editor allows you to:
• Change the duration of a transition
• Adjust the alignment of a transition
• Trim the edit point between the two clips adjacent to the transition
• Ripple edit each clip to either side of a transition’s edit point
• Adjust the percentage of completion of a transition at its start and end points
• Reverse the direction of a transition
• Modify custom settings for a transition
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Controls in the Transition Editor
When you double-click a transition in the Timeline or the Effects tab of the Browser, a
special tab for the transition opens in the Viewer. This Transition Editor window indicates
that the transition is “loaded,” or opened, so you can view and modify the transition’s
settings.
Tab with the name
of the transition

Effects (specific
to each transition)

• Timecode Duration field: This timecode field displays the current duration of your
transition. Changing the value in this field shortens or lengthens the duration of the
applied transition up to the maximum amount of overlapping frames available at the
edit point. (To change the duration in the Timeline, see “Changing the Duration of a
Transition in the Timeline.”)

Timecode Duration field

How the duration changes depends on the alignment of the transition. If the transition
occurs before the edit point, the duration affects the clip to the left of this point, or the
outgoing clip. If the transition is centered on the edit point, changes in duration extend
in both directions. If the transition occurs after the edit point, the duration affects the
clip to the right of this point, or the incoming clip.

778

Chapter 48 Refining Transitions Using the Transition Editor

• Alignment buttons: The selected button indicates the current alignment of your
transition. You can change the alignment of a transition by clicking a button (if there
are enough overlapping frames in the direction in which you want to realign the
transition).
Alignment buttons

• Recent Clips pop-up menu: Choose from a list of recently used clips. A clip is added to
this list when another clip replaces it in the Viewer (not when the clip is opened in the
Viewer). The last clip that was replaced in the Viewer appears at the top of the list.
Recent Clips
pop-up menu

By default, the maximum number of clips shown in this list is ten; you can change this
number in the General tab of the User Preferences window. For more information, see
“Choosing Settings and Preferences.”
Once the maximum number of entries is reached, a clip is removed from the bottom
of the list each time another clip is replaced in the Viewer.
• Drag hand: If you want to apply the current transition to another edit point in your
sequence in the Timeline, you can drag this to the edit point. This is true for transitions
opened from the Browser and from a sequence in the Timeline.

Drag hand

• Ruler: The ruler displays a close-up view of the frames surrounding the transition in
your sequence. The ruler and playhead in the Transition Editor are locked to those in
the Timeline. The time scale of the ruler can be changed by using the Zoom In and
Zoom Out tools or pressing Command-Equal Sign (=) or Command-Hyphen (-).

Ruler
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• Outgoing and incoming clip handles: A transition that appears as two overlapping clips
on the same track in the Timeline is represented differently in the Transition Editor.
The outgoing clip and its Out point appear on the top track, the incoming clip and its
In point appear on the bottom track, and the transition itself appears on a track between
the two.

Outgoing clip
Incoming clip

Both the Out point of the outgoing clip and the In point of the incoming clip are handles
that you can drag to perform ripple edits, modifying the edit points of these clips in
your sequence in the Timeline. (A ripple edit adjusts the length of a clip by changing
the In or Out point of the clip. Ripple edits do not cause gaps in your edited sequence.
For more information, see “Adjusting the Length of a Clip in a Transition with a Ripple
Edit.”)
• Transition bar with start, stop, and edit handles: The transition appears as a bar with start
and end points that you can drag. Depending on the alignment of your transition, the
edit point appears to the right, in the center, or to the left of this bar.

Edit point in the center
of the transition bar

Transition bar with the
start point being moved

Dragging the transition bar from the middle results in a roll edit, which moves the edit
point between two clips in a sequence. Dragging either of the transition edges shortens
or extends the transition.
Note: A roll edit adjusts the location of an edit point shared by two clips; the Out point
of the first clip and the In point of the second clip are moved simultaneously, or rolled.
This changes the location of the edit point in the sequence, as well as the duration of
each clip. For more information, see “Using the Roll Tool to Change Where a Cut Occurs.”
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• Start and End percentages of transition: These sliders allow you to set the starting and
ending percentages of the transition’s visual effect. For example, if you are using an
edge wipe, the default starting percentage of 0 percent places the border of the wipe
all the way to the left of the image, essentially revealing all of the outgoing clip.

The start of an edge
wipe transition

Halfway through the wipe, at the edit point, the wipe is at 50 percent, placing the
border of the wipe in the middle of the picture. You can now see half of the incoming
clip to the left and half of the outgoing clip to the right.

The middle of an edge
wipe transition

At the end of the edit, with the transition finished and the default ending percentage
of 100%, the border of the wipe is all the way to the right, revealing the entire incoming
clip.

Near the end of an edge
wipe transition
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You can change the starting and ending percentages for the transition. This is an
excellent way of creating split-screen effects if you plan to export your sequence as an
EDL for import into another editing system. For more information on exporting EDLs,
see “Importing and Exporting EDLs.”
For example, you can set both the starting and ending percentages to 50 percent. At
the start of the transition, a split-screen effect is created; half of the outgoing clip and
half of the incoming clip are revealed simultaneously and throughout the duration of
the transition.

The start of the transition
in the Canvas

The start of an edge
wipe transition, where the
start percentage is 50%

When the transition is complete, the image becomes the full-screen picture of the
incoming clip.

The end of the transition
in the Canvas; the
split-screen effect is
maintained throughout
the transition.

The end of an edge
wipe transition, where the
end percentage is 50%
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• Reverse Transition button: Some transition effects have a default direction. For example,
a wipe goes from the left to the right, a clock wipe’s border travels in a clockwise
direction, and the spin 3D transition spins the outgoing clip out to the right.

Reverse Transition button

To reverse the direction of an effect, click the Reverse Transition button. If you reverse
the direction for the above examples, the wipe moves from right to left, the clock wipe
moves in a counter-clockwise direction, and the spin 3D transition spins the incoming
clip in to the left.
• Reset button: Click this button to reset all of a transition’s parameters to the default
values.

Reset button

• Custom parameters: Many transitions have additional parameters that you can use to
further customize their effect. These parameters appear below the controls for the
properties and may include such visual effects as the center point of the effect, the
width of the transition border, and the color and feathering of this border. More complex
transitions have more elaborate effects.

Displaying Clips in the Transition Editor
The way clips are displayed in the Transition Editor depends on the current thumbnail
display setting for the sequence. (For information on changing this display in the sequence
settings, see “Sequence Settings and Presets.”) You can also increase or decrease the scale
of the ruler in the Transition Editor by zooming in or out.
To zoom in on the ruler in the Transition Editor
Do one of the following:

µ

Click the Transition Editor to make it active, then choose View > Zoom In, or press
Command-Equal Sign (=).

µ

Select the Zoom In tool, then click either clip or the transition shown in the Transition
Editor.
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To zoom out of the ruler in the Transition Editor
Do one of the following:

µ

Click the Transition Editor to make it active, then choose View > Zoom Out, or press
Command-Hyphen (-).

µ

Select the Zoom Out tool, then click either clip or the transition shown in the Transition
Editor.

µ

To zoom to fit the ruler in the Transition Editor
Press Shift-Z.
This zooms the ruler to a medium size in the Transition Editor.

Opening and Modifying Transitions in the Transition Editor
When you open a transition from your sequence in the Timeline in the Transition Editor,
you can modify and trim it much more precisely than you can in the Timeline. All the
transitions that come with Final Cut Pro are different, but all of them share some essential
properties and edit points that you can modify in the Transition Editor.
• If you open a transition from a sequence in the Timeline: Changes you make immediately
alter that transition in your edited sequence.
• If you open a transition from the Effects tab of the Browser: This opens a copy of the
transition. Changes you make have no effect until you apply the modified transition
to an edit point in the Timeline or save the transition as a favorite.
To open a transition from the Timeline
Do one of the following:

µ
µ
µ

Select the transition’s icon, then choose View > Transition in Editor.
Control-click the transition, then choose Open from the shortcut menu.
Double-click the transition.
To open a copy of a transition from the Effects tab
Do one of the following:

µ
µ
µ

Control-click the transition, then choose Open Viewer from the shortcut menu.
Double-click a transition in the Effects tab.
Select a transition, then press Return.
This opens a copy of the transition. If you change settings and want to use the changed
version, you need to save it as a favorite (see “Saving a Transition as a Favorite”) or apply
it directly to an edit point in the Timeline by dragging its drag hand to an edit point. For
more information, see “Applying a Modified Transition Directly to a Sequence in the
Timeline.”
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Applying a Modified Transition Directly to a Sequence in the
Timeline
After you modify a transition’s settings in the Transition Editor, you can apply the transition
directly to an edit point in the Timeline. If you do this, the modified transition is only
saved in the Timeline. To use this transition again, make it a favorite (see “Saving a
Transition as a Favorite”) or copy it (see “Copying and Pasting Transitions”).

µ

To apply a modified transition directly to your sequence in the Timeline
Drag the transition’s drag hand to an edit point in the Timeline.

Drag the hand from
the Transition Editor
to an edit point in
your sequence.

Trimming Transitions and the Surrounding Clips
Trimming is the process of modifying the edit points of clips that are already in your
sequence. After you’ve opened a transition in your sequence in the Transition Editor, you
can fine-tune your edit. This is done using the handles on the Out point of the outgoing
clip and the In point of the incoming clip that meet to form your transition’s edit point.
Changes you make to a transition in the Transition Editor (if it’s opened from the sequence
in the Timeline and not the Browser) immediately affect this transition in your sequence.
Duration of the
outgoing clip

Handle of the
outgoing clip

Out point of the
outgoing clip
Transition end point

Transition
start point

In point of the
incoming clip

Duration of the
incoming clip
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About the Two-Up Display in the Canvas
You can drag the pointer in the Transition Editor to trim the transition and change the
duration of the transition or the actual location, or edit point, where the transition occurs
between two clips. When you do this, a dual-frame display appears in the Canvas to show
how your change affects the clips surrounding this transition.
• The frame on the left: This displays the current frame at the transition’s start point in
the outgoing clip.
• The frame on the right: This displays the current frame at the transition’s end point in
the incoming clip.
The name of each clip is at the top of each display, and the timecode for the transition’s
start or end point is visible at the bottom of each display.

The end point of the
transition in the
incoming clip
The start point of the
transition in the
outgoing clip

Trimming the Duration of a Transition
When you move the pointer to either edge of a transition in the Transition Editor, the
pointer changes to a Resize pointer. You can then change the duration of the transition,
depending on how much clip overlap is available.
To change the duration of a transition
1 Open the transition in the Transition Editor.
2 Do one of the following:
• Enter a new duration in the Timecode Duration field, then press Return.
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• Drag the beginning or end of the transition to change its length. When you do this to
a transition centered at the edit point, both sides of the transition change duration,
but the edit point itself doesn’t move.

Drag either end of the
transition to the length
you want.

Changing the Location of a Transition with a Roll Edit
If you move the pointer over the middle of a transition in the Transition Editor, the pointer
changes to the Roll tool. You can then move the edit point along with the transition to
the left or to the right, as long as there is available overlap between the outgoing and
incoming clips.
To do a roll edit, changing the location of a transition
1 Open the transition in the Transition Editor.
2 Place the pointer anywhere on the transition.
3 When the pointer changes to the Roll tool, drag the edit point and the transition to the
new location.

Using the Roll tool, drag the
edit point to a new position.

Check the two-up display in the
Canvas to help you determine
where to place the transition.
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Adjusting the Length of a Clip in a Transition with a Ripple Edit
Even when a transition is applied between two clips, you can change the duration of the
outgoing or incoming clip using the Ripple tool. Ripple edits do not cause gaps in your
edited sequence.
• Rippling the Out point of the outgoing clip: This moves the transition and the edit point
at the same time so that the outgoing clip is shortened or extended. The rest of your
edited sequence moves forward or backward to accommodate this change.
• Rippling the In point of the incoming clip: This has no effect on the location of the edit
point or the transition, but shortens or lengthens the incoming clip. All subsequent
clips are moved to the left or right so that there is no resulting gap.
When you trim the outgoing or incoming clip with the Ripple tool, the Canvas shows the
current frame of the edit point you’re dragging, along with the clip’s name and the current
timecode value of the clip, in a single-frame display. A tooltip is displayed at the location
of the pointer in the Transition Editor to show the offset between the new edit point
you’re selecting and the original edit point.
To do a ripple edit, adjusting the length of the transition
1 Open the transition in the Transition Editor.
2 Place the pointer at the Out point of the outgoing clip or at the In point of the incoming
clip.

When you do a ripple
edit, a tooltip shows the
offset between the new
and old edit points.

In the Canvas, the frame
of the new edit point
is shown.

3 When the pointer changes to the Ripple tool, drag the edit point to another frame in
your clip.
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Previewing and Rendering Transitions
Many transitions can play back in real time, depending on your system and the transition
you’re applying. Those that can’t need to be rendered. Rendering is the process of
combining your video and audio with the applied effects, such as transitions or filters,
one frame at a time. The result is a new file, called a render file, that can be played back
in real time. The render bar, above the ruler in the Timeline, indicates the render status
of all transitions you’ve edited into your sequence (as well as other items in your sequence).
Render bar

The render bar has two regions, one for video and the other for audio. Because you may
have audio transitions that need to be rendered associated with sections of video that
don’t need rendering, audio and video are kept separate.
• Upper region: Indicates the presence and render status of video effect items.
• Lower region: Indicates the presence and render status of audio effect items.
The upper area indicates
the render status of
video items.

The lower area indicates
the render status of
audio items.

Determining the Render Status of Transitions
Colors in the render bar above items indicate whether the items need to be rendered.
Items that don’t need to be rendered have dark gray bars above them. For more
information about real-time effects, see “Using RT Extreme.” For more information on
rendering, see “Rendering and Video Processing Settings.”
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Previewing Transitions Before Rendering Them
If you have to render your transitions, it’s a good idea to preview complex transitions
first. You can preview transitions while you’re modifying them or any time before rendering
them.
To preview a transition
Do one of the following:

µ

Move the playhead in the Canvas or Timeline to a frame just before your transition, then
choose Mark > Play > Every Frame (or press Option-Backslash or Option-P).
Final Cut Pro plays every frame of your transition, although not in real time.

µ

Move the playhead in the Canvas, the Timeline, or the Transition Editor over a frame of
the transition.
That frame of your transition is rendered and displayed in the Canvas, on your external
monitor, or both, depending on how your external video settings are configured.
Note: Make sure the Caps Lock key is not engaged. The Caps Lock key disables rendering.

Rendering Transitions
If you need to render your transitions, you can render all the transitions and effects in
your sequence or only selected transitions. Rendering transitions is just like rendering
clips with filters applied. For detailed information on setting up and using render quality
settings, see “Rendering and Video Processing Settings.”
To render a single transition in your sequence
1 Select a transition in the Timeline.
2 Choose Sequence > Render Selection > Both (or press Command-R).
To cancel rendering, click Cancel in the status dialog or press Esc.
To render only transitions and effects that can’t play in real time
1 Open a sequence in the Timeline.
2 Choose Sequence > Render All, and make sure Needs Render is the only option turned
on in the submenu.
3 Choose Sequence > Render All > Both.
To cancel rendering, click Cancel in the status dialog or press Esc.
To render all transitions and effects in your sequence
1 Open a sequence in the Timeline.
2 Choose Sequence > Render All > Both (or press Option-R).
To cancel rendering, click Cancel in the status dialog or press Esc.
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Sequence-to-Sequence Editing

49

This chapter covers the following:
• Methods for Editing Clips from One Sequence to Another (p. 791)
• Opening More Than One Sequence at a Time (p. 792)
• Copying Clips from One Sequence to Another (p. 792)
• Nesting Sequences (p. 795)
• Editing the Content of One Sequence into Another Without Nesting It (p. 801)
You can edit from one sequence to another, either by nesting one sequence into another,
or by actually editing the clips from one sequence to another.

Methods for Editing Clips from One Sequence to Another
Often when you’re editing, you’ll be working with more than one sequence. For example,
you may create one sequence for each scene in a movie, or use different sequences for
various versions of your project. At some point, you may need to copy clips from one
sequence to another. Copying information between sequences is fairly easy and can be
done several ways. You can also edit entire sequences into other sequences, commonly
called nesting.
There are a few different ways to add content from one sequence to another:
• Copying and pasting clips from one sequence into another
• Using three-point editing to edit clips from a sequence open in the Viewer to a
destination sequence in the Canvas or Timeline
Important: Editing clips between sequences with different dimensions, frame rates, and
codecs will apply motion parameters, such as distortion and aspect ratio adjustments, to
the resulting clips in the destination sequence. To remove these parameters, see “Reusing
Effect and Motion Parameters.”
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Opening More Than One Sequence at a Time
To copy, edit, or nest a sequence into another sequence, the destination sequence must
be open in the Timeline or Canvas. When you open a sequence, the Timeline and the
Canvas open together, if they’re not open already. If the Timeline and Canvas are already
open, a newly opened sequence appears in its own tab on top of any other sequence
tabs.
If you want to view your sequences separately, you can move each into its own window.
This eliminates the constant need to click back and forth between sequence tabs in the
Timeline. For more information, see “Overview of the Final Cut Pro Interface.”

Copying Clips from One Sequence to Another
You can quickly copy clips between sequences if you want to use the same portion of
the clip in both sequences. You can copy clips between sequences by dragging or by
using the Copy and Paste commands.
To copy clips from one sequence to another by dragging
1 Open both sequences in the Timeline.
2 Drag one sequence by its tab out of the Timeline to create a new window.
Make sure the two Timeline windows are viewable on screen and not overlapping other
windows.
3 Select one or more clips that you want to copy.
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4 Do one of the following:
• To do an insert edit: Drag the clips where you want them to appear in the other
sequence, positioning the pointer in the upper part of the track (the pointer looks like
a right arrow).
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• To do an overwrite edit: Drag the clips where you want them to appear in the other
sequence, positioning the pointer in the lower part of the track (the pointer looks like
a down arrow).

5 Release the mouse button.
The selected clips from the first sequence are copied into the second sequence.
To copy clips from one sequence to another using the Copy and Paste commands
1 Open the sequence that contains the clip or clips you want to copy.
2 In the Timeline, select one or more clips, then choose Edit > Copy (or press Command-C).
3 Open the sequence into which you want to copy the clips.
4 Make sure the Auto Select controls are turned on for the tracks you want to paste the
clips into.
For more information, see “Using Auto Select to Specify Tracks for Selections.”
If all or none of the tracks have Auto Select turned on, the clips are placed on V1, A1, and
so on (depending on how many audio clip items are pasted).
5 In the Timeline for the second sequence, do one of the following:
6 Position the playhead where you want to place the beginning of the copied clip or clips.
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7 In the Current Timecode field, enter the timecode number where you want to place the
beginning of the copied clip or clips.

8 Choose Edit > Paste (or press Command-V).

The copied clips are pasted into the second sequence.
Important: If you copy and paste clips between sequences in different projects, the
master-affiliate relationships are maintained in the projects. Master clips are also pasted
into the project and can be revealed. You cannot reveal master clips between projects,
nor match frames to master clips between projects.

Nesting Sequences
Final Cut Pro allows you to treat sequences as clips. You can open sequences in the Viewer
and set In and Out points, and you can even edit sequences into other sequences. Putting
one sequence inside another is called nesting a sequence. The sequence inside another
sequence is the nested sequence. The sequence that contains the nested sequence is
sometimes called the parent sequence.
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Nested sequences can be used in the same way as clips. You can add audio and video
filters to them, set their opacity and level overlays in the Timeline, work with their audio
in the Audio tab of the Viewer, and adjust their motion parameters in the Motion tab of
the Viewer.
Note: A sequence can’t be edited into itself.

When Do You Nest Sequences?
Nesting sequences is useful in various situations:
• You can edit a movie using multiple sequences; for example, you can create a sequence
for each scene. You can then place all of the sequences, in order, into a master sequence
and output to tape or export a QuickTime movie.
• You can also use nested sequences to reduce the amount of rendering when working
with effects. You can place all of the effects-intensive audio or video sections of your
program into separate sequences, and render them. When you then nest these
sequences into your main program sequence, you can change the In and Out points
of the nested sequences without having to rerender all of the clips inside of them.
• Another reason to nest sequences is to control the rendering order of effects used in
your project. This is useful for motion graphics work. You can apply filters to clips inside
a nested sequence, and then apply additional effects to the nested sequence itself.

Pros and Cons of Nested Sequences
Before you start using nested sequences in your project, it’s important to understand
some of the advantages and disadvantages of working with them. If you decide you don’t
want to nest a sequence, you can still edit content from one sequence to another. For
more information, see “Editing the Content of One Sequence into Another Without Nesting
It.”
Pros
• Nesting allows you to reuse an entire sequence of clips over and over. You can change
a nested sequence and the changes are reflected everywhere.
Cons
• Multiple levels of sequence nesting can take a while to display, since they require
additional processing.
• If you are exporting an EDL, nested sequences may generate confusing timecode
numbers and reel names.
• If you are exporting an OMF file, nested sequences will be mixed together and exported
as a single audio media file.
• Nested sequences make media management more complicated.
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How Many Audio Items Does a Nested Sequence Have?
When you nest one sequence inside of another, the nested sequence has only one video
item, regardless of how many video tracks it has in its own Timeline window. However,
the number of audio items that are nested is equal to the number of audio output channels
specified in the Audio Outputs tab of the Sequence Settings window for the nested
sequence.
For example, if sequence A uses a single pair of stereo audio outputs, editing it into
sequence B results in a nested clip with one video and two audio items.
However, if sequence A has six audio outputs assigned in its sequence settings, editing
it into sequence B results in a nested sequence with one video and six audio items. This
is true regardless of how the audio tracks are assigned to audio output channels in the
nested sequence. For example, if you only have two audio tracks in the Timeline of the
nested sequence, and they are assigned to audio output channels 1 and 2, the nested
sequence still has six audio items when edited into another sequence.

Nesting a Sequence Inside Another Sequence
You can edit the contents of a sequence, render it, and then edit that sequence into
another sequence. This section explains the various ways you can nest a sequence into
another sequence.
To nest a sequence that is open in the Viewer
1 Open the sequence you want to nest in the Viewer by doing one of the following:
2 Drag the sequence from the Browser to the Viewer.
3 Hold down the Option key, then double-click a sequence in the Browser (this opens it in
its own Viewer window).
4 Control-click the sequence, then choose Open in Viewer from the shortcut menu.
5 In the Viewer, set In and Out points for the source sequence.
This lets you nest all or just a part of the sequence.
6 Edit the sequence into another sequence in the Timeline as you would a clip.

µ

To nest a sequence by dragging it into another sequence
Drag the sequence from the Browser or Viewer to another sequence in the Timeline, as
you would a clip.

To copy and paste a sequence into another sequence
1 In the Browser, copy the sequence by doing one of the following:
• Select a sequence in the Browser, then choose Edit > Copy (or press Command-C).
• Control-click a sequence in the Browser, then choose Copy from the shortcut menu.
2 In the Canvas or Timeline, open the destination sequence, then move the playhead to
the location where you want to paste the nested sequence.
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3 Specify the destination tracks where you want the nested sequence to go.
4 Choose Edit > Paste (or press Command-V).
The selected sequence is now nested, or placed, into the second sequence.
You can reveal a nested sequence in the Browser by selecting the nested sequence in
the Timeline.
To reveal a nested sequence in the Browser
1 Select the nested sequence in the Timeline.
2 Choose View > Reveal Master Clip.

Making a Section of Clips into a Nested Sequence
Instead of adding a nested sequence, you can also turn an existing range of clips in a
sequence into a nested sequence using the Nest Items command.
To create a nested sequence using the Nest Items command
1 In the Timeline, select a range of clip items that you want to replace with a nested
sequence.
Note: If the clip items are linked, any items that are linked to those items in the Timeline
are also selected.

2 Choose Sequence > Nest Item(s) (or press Option-C).
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3 In the Nest Items dialog, enter a name for the new sequence into which the selected
items will be placed.

4 Choose a width and height (frame size) for the new sequence that will be created to
contain the selected clips.
You should usually use the default settings provided, since these match the sequence
that your new sequence will be nested inside.
5 To move all effects, markers, and audio levels associated with the selected clips into the
new sequence, select the Keep Effects, Markers, and Audio Levels with Clip checkbox.
6 To render all of the audio in the new sequence, select the Mixdown Audio checkbox.
This minimizes the audio processing requirements for the nested sequence. For more
information on the real-time audio rendering capabilities of Final Cut Pro, see “Rendering
and Video Processing Settings.”
7 Click OK.
All the items you selected are placed in a new sequence, and the new sequence replaces
the selected items in the Timeline.

This nested sequence
replaces the selected
clips.

Tip: If you change your mind, the nesting operation can easily be undone using the Undo
command.
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About Changing the Duration of Nested Sequences
When you first nest a sequence into another sequence (sometimes known as the parent
sequence), changes in the original nested sequence that affect its duration are reflected
in the parent sequence. For example, if you shorten a clip in the original nested sequence,
the overall sequence duration changes. As a result, the duration of the nested sequence
within the parent sequence is also shortened, and the subsequent clips in the parent
sequence are rippled to compensate for the shorter nested sequence.
This is quite helpful, since otherwise you’d end up with gaps in your parent sequence
whenever you change the length of one of your nested sequences. This is convenient
when each of your movie scenes is in a separate sequence. After you’ve edited all your
scenes together, if you decide to reedit any of the scene sequences, the changes you
make will automatically ripple items in the entire master sequence.
For example, suppose sequence B, which has a duration of 10 seconds, is nested inside
another sequence, with more clips appearing to the right of it.

Nested sequence B
inside another sequence

You open sequence B and add two more clips to the end of it, extending its duration
from 10 to 15 seconds. Once you’ve done this, all of the clips in the parent sequence that
are to the right of the nested sequence B are automatically rippled 5 seconds to the right
to accommodate the lengthening of the nested sequence B.

Adding clips to sequence B
ripples the parent sequence.
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Important: If you modify a nested sequence duration in a parent sequence, or if you
specifically set In and Out points in a sequence before you nest it into a parent sequence,
the nested sequence may no longer ripple clips in the parent sequence when you adjust
content in the nested sequence.

Editing the Content of One Sequence into Another Without
Nesting It
Instead of nesting one sequence inside another, you can simply edit the clips of a sequence
into another sequence.

Editing Sequence Content Versus Nesting
To help you understand how it works, suppose Sequence A has the following content
edited into it:

Sequence A

If you drag Sequence A into the Canvas to edit it into Sequence B, the resulting nested
sequence typically has one video track and two audio tracks (assuming Sequence A has
two audio output channels).
When nested inside
Sequence B, Sequence A
becomes one clip
in Sequence B.

Sequence B
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If you hold down the Command key while dragging Sequence A into the Canvas, you’ll
edit the clips contained within Sequence A into Sequence B. So each clip in Sequence A
is still an individual clip in Sequence B. This allows for more flexibility should you want
to make changes to any clips that are in Sequence A. However, future changes in Sequence
A have no effect on Sequence B; Sequence B does not automatically update to reflect
the changes.
Using the Command key
causes individual clips to
be copied into the
destination sequence.

Editing Clips from One Sequence into Another
This section describes how you can edit clips from one sequence into another sequence.
There are a few different methods:
• Edit content from the Viewer using the Canvas Edit Overlay or corresponding keyboard
shortcuts.
• Hold down the Command key while dragging clips directly into the Timeline.
You can drag content from the Browser to the Timeline, or use three-point editing rules.
You can also create split edits from one sequence to another.
To edit all content from one sequence into another using the Canvas Edit Overlay
1 Open your destination sequence (where the copied clips will go) in the Timeline, then
set an In point for the incoming clips by doing one of the following:
• Position the playhead in the Timeline.
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• Set an In point in the Timeline or Canvas.
Set an In point where you
want to place clips from
the source sequence.

2 If necessary, create additional tracks for each track present in the source sequence.
Important: If you don’t create additional tracks, only clips on V1, A1, and A2 will be copied
from the source sequence.
3 Hold down the Command key, then drag your source sequence (the sequence you want
to copy clips from) from the Browser or the Viewer to the Overwrite or Insert section of
the Canvas Edit overlay.

The content of the source
sequence is edited into
the currently active
sequence in the Timeline.

To edit all content from one sequence into another using keyboard shortcuts
1 Open your destination sequence (where the copied clips will go) in the Timeline, then
set an In point for the incoming clips by doing one of the following:
• Position the playhead in the Timeline.
• Set an In point in the Timeline or Canvas.
2 If necessary, create additional tracks for each track present in the source sequence.
If you don’t create additional tracks, only clips on V1, A1, and A2 will be copied from the
source sequence.
3 In the Browser, select the sequence you want to copy clips from (the source sequence).
4 Do one of the following:
• To perform an insert edit: Press Command-F9.
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• To perform an overwrite edit: Press Command-F10.
The content of the source sequence is edited into the destination sequence in the Timeline.
To edit content from one sequence into another by dragging it into the Timeline
1 In the Timeline, open the destination sequence (where the copied clips will go) by clicking
the sequence’s tab.
2 If necessary, create additional tracks for each track present in the source sequence.
Important: If you don’t create additional tracks, only clips in V1, A1, and A2 will be copied
from the source sequence.
3 Drag a sequence from either the Browser or the Viewer to the area of the Timeline you
want to edit the content into.

A highlighted area shows
where the content from the
source sequence will go.

4 Keeping the mouse button held down, press the Command key.
5 Keeping the Command key held down, release the mouse button.
The content of the sequence you dragged is edited into the currently active sequence in
the Timeline, with all clips appearing individually.

804

Chapter 49 Sequence-to-Sequence Editing

Matching Frames and Playhead
Synchronization

50

This chapter covers the following:
• Working with Sequence Clips in the Viewer (p. 805)
• Matching Frames Between Sequence and Master Clips (p. 808)
• Synchronizing the Canvas/Timeline Playhead and the Viewer Playhead (p. 811)
You can use the frame displayed in the Canvas to open the matching frame of a master
clip in the Viewer, or you can synchronize the playheads in the Canvas and Viewer to
automatically open each sequence clip in the Viewer.

Working with Sequence Clips in the Viewer
The Viewer is a versatile window used for several different purposes. In the early stages
of editing, the Viewer is used independently of the Canvas and Timeline, mostly to set In
and Out points for clips before they are edited into your sequence. In the later stages,
when you are fine-tuning, you can use the Viewer, in combination with the Canvas and
Timeline, as another way of viewing portions of your sequence.
You work with sequence clips in the Viewer to do the following:
• Precisely trim clip In and Out points. You can make most of the same clip adjustments
in the Viewer that you can in the Timeline, such as ripple, roll, and slip edits, but the
process and visual feedback are very different.
• Adjust motion and effects parameters. For example, if each sequence clip has a color
correction filter applied, you access each clip’s filter parameters by opening the sequence
clip in the Viewer and clicking the Filters tab.
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Note: Sequence clips display sprocket holes in the Viewer’s scrubber bar to indicate that
they are part of a larger sequence; Browser clips don’t display sprocket holes.
Sprocket holes
indicate that this
is a sequence clip.

Opening a Sequence Clip in the Viewer
When you open a sequence clip in the Viewer, you can work with it directly in the Viewer
instead of in the Timeline.
To open a sequence clip in the Viewer from the Timeline
Do one of the following:

µ
µ
µ

Double-click a clip in the Timeline.
Select the clip, then choose View > Clip (or press Return).
Position the playhead at the In point of the clip in the Timeline (using the Up or Down
Arrow key) or anywhere within the clip in the Timeline, then press the Return key.
The clip on the lowest-numbered Auto Select-enabled track opens in the Viewer and the
Viewer playhead is at the same frame as the one under the Timeline playhead.

To open a sequence clip in the Viewer from the Canvas or Timeline
1 Make sure no clips are selected in the Timeline by choosing Edit > Deselect All (or pressing
Shift-Command-A).
2 In the Timeline or Canvas, move the playhead to the frame you want to open in the
Viewer.
3 Do one of the following:
• Double-click the image in the Canvas.
• Press Enter or Return.
The corresponding sequence clip opens in the Viewer to the specified frame.
To open a specific sequence clip item in the Viewer
1 In the Timeline, click the Linked Selection button to turn off linked selection (if it’s on),
or hold down the Option key.
2 Double-click the clip item you want to open in the Viewer.
Only the selected clip item is opened in the Viewer. Any items linked to this clip item are
not opened in the Viewer.
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Switching Between the Viewer, Canvas, and Timeline
When you work with sequence clips in the Viewer, you can quickly switch between the
Viewer and the Canvas or Timeline. For example, opening a sequence clip in the Viewer
activates the Viewer, but you might want to open the clip in the Viewer and then play
the sequence.

µ

To switch between the Canvas and Viewer
Press the Q key.
To switch between the Viewer, Canvas, and Timeline
Do one of the following:

µ
µ
µ

To make the Viewer active, press Command-1.
To make the Canvas active, press Command-2.
To make the Timeline active, press Command-3.
Note: If you press a key combination for a window that is already active, the window
closes. Pressing the key combination again opens the window. When you close a window
by pressing the window’s key combination, the content of that window is still remembered
when you open that window again. This is different from closing a window by pressing
Command-W or clicking the close button; in these cases, the content of the window is
not remembered when you open the window again.

Using the Viewer to Adjust Sequence Clip In and Out Points
Adjusting clip In and Out points in the Timeline is very intuitive. You simply drag the
boundary of the clip to make the clip longer or shorter. However, you can also open a
sequence clip in the Viewer and set an In or Out point on the exact frame you want.
Ultimately, the results are the same whether you adjust a clip in the Viewer or the Timeline,
but there are times when one method may better help you visualize the result.
The advantage of working with sequence clips in the Viewer is that you can navigate
through the whole clip, even beyond the clip In and Out points. Making an edit in the
Viewer is a two-step process, but in some cases you may prefer the visual precision of
this approach over dragging clip boundaries in the Timeline. With this method, you always
know exactly which frames the In and Out points are set on.
In the Viewer, as well as in the Canvas and Timeline, the active tool, such as the Ripple,
Roll, or Selection tool, determines the result of the edit.
To make a ripple, roll, slip, or duration change to a sequence clip in the Viewer
1 Open the sequence clip in the Viewer.
2 Select the appropriate tool for the type of edit you want to do.
3 In the Viewer, navigate to the frame you want to use for the clip’s new In point.
4 Press I to set a new In point.
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5 Navigate to a new Out point and press O to set a new Out point.
If the new In or Out point is not accepted, check to see if Final Cut Pro displays an alert
message. Some edits are not possible because they would cause other sequence clips to
be partially overwritten or moved out of sync. For more information, see “Understanding
Alert Messages When Trimming.”

Using the Viewer to Adjust Motion and Filter Parameters
When you want to adjust effects and motion parameters for a sequence clip, you open
the clip in the Viewer to make adjustments in the Motion and Filters tabs. For more
information, see “Changing Motion Parameters.” You can also refer to “Using Video Filters.”

Matching Frames Between Sequence and Master Clips
Sequence clips, which are usually affiliate clips, have a relationship to other clips in your
project. Because of this relationship, you can tell Final Cut Pro to open the following clips
in the Viewer:
• The sequence clip’s master clip, located in the Browser
• The sequence clip’s source media file, located on disk
When Final Cut Pro opens one of these items in the Viewer, the playhead is positioned
at the exact same frame in the Viewer as in the Canvas and Timeline. This is known as a
match frame.
Important: If a sequence clip is not an affiliate clip, it is independent, so it isn’t related to
a master clip in the Browser. You can’t match an independent clip back to a master clip,
because it doesn’t have one. However, you can still match back to the original media file.
For more information about master-affiliate clip relationships, see “Working with Master
and Affiliate Clips.”
To check if a sequence clip is independent
1 Select a clip in the Timeline, or move the playhead over a clip in the Canvas or Timeline.
2 Choose View > Reveal Master Clip.
If the Reveal Master Clip menu item is dimmed, the selected sequence clip does not have
a master clip, and it is therefore independent.

Matching a Frame in the Canvas to Its Master Clip Frame
Sometimes you’ll want to view the master clip that a sequence clip came from. Here are
several reasons why:
• You want to open the original master clip without any of the motion, filter, or audio
parameters from the sequence clip. This is useful when you want to add a “fresh” copy
of the clip to your sequence.
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• You want to open the master clip with all of its video and audio items, instead of the
sequence clip, which may only be a single clip item.
For example, your sequence clip may be a video clip item that no longer has its
corresponding audio. You can get those audio clip items back by opening the video
clip item’s master clip in the Viewer. The master clip in the Viewer contains all the video
and audio items, so you can edit the audio items from the master clip back into the
sequence using a replace or overwrite edit. For details about replace edits, see
“Performing a Replace Edit.”
To match a sequence clip’s current frame to its master clip in the Viewer
1 In the Timeline or Canvas, move the playhead to the frame you want to open in the
Viewer.
2 Choose View > Match Frame > Master Clip.
The master clip for the sequence clip opens in the Viewer. The playhead in the Viewer is
set to the same frame as seen in the Canvas (thus, the frames match in the Canvas and
Viewer).
When the clip’s master clip opens in the Viewer, notice that there are no “sprocket holes”
in the scrubber bar. This is because you’re seeing the clip from the Browser, not the
sequence clip. When you view the master clip, it has the same In and Out points as the
sequence clip.

The current frame in the
Viewer matches the
frame in the Canvas.

To reveal a sequence clip’s master clip in the Browser
1 Select a clip in the Timeline, or move the playhead over a clip in the Canvas or Timeline.
2 Choose View > Reveal Master Clip (or press Shift-F).
The sequence clip’s master clip is selected in the Browser, and the Browser becomes the
active window.
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Matching a Frame in the Canvas to Its Media File Frame
There are some situations in which you may want to reveal the original media file of a
clip instead of the clip’s master clip. For example, if you are working with a subclip in the
Timeline and you want to see all of the original media (instead of only the portion defined
by the subclip limits), you can match to the original media file. This opens the entire
media file as an independent clip in the Viewer. This clip has no filters or motion
parameters applied, and has no In or Out points set.
Important: If you open a source media file in the Viewer and drag it to the Browser, a
new master clip is created. If you drag it to the Timeline or Canvas, an independent clip
is created in the sequence. This is true whenever you open a media file in the
Viewer—either by using a match frame command or by dragging a media file from the
Finder directly to the Viewer.
Independent sequence clips can cause complications during media management and
recapturing, so you should avoid editing with these clips. You should also be careful not
to unnecessarily create more than one master clip that references the same media file.
Subclips are an example of master clips that can refer to the same media file, but each
subclip refers to a different portion of the media file. Multiple master clips that refer to
the exact same parts of the same media file are usually unnecessary.
To open a sequence or Browser clip’s media file as a clip in the Viewer
1 In the Timeline, Canvas, or Viewer, move the playhead to the frame you want to open in
the Viewer.
2 Choose View > Match Frame > Source Media File.
An independent clip is created in the Viewer that refers to the media file on disk. No In
or Out points are set, but the Viewer displays the same frame as the Canvas (or the Viewer,
if you were matching frames from a clip in the Viewer).
You can have Final Cut Pro match a frame from a subclip to its parent clip in the Viewer.
To open a subclip’s parent clip in the Viewer
1 In the Timeline, Canvas, or Viewer, move the playhead to the frame of the subclip you
want to open in the Viewer.
2 Choose View > Match Frame > Subclip Parent Clip.
The subclip’s parent clip opens in the Viewer and displays the same frame as the Canvas
(or the Viewer, if you were matching frames from a clip in the Viewer).
Note: If you are working on a project created in a previous version of Final Cut Pro,
Final Cut Pro may not be able to match the subclip to the subclip parent clip. The Subclip
Parent Clip command works only for subclips created in the current version.
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Matching a Frame in the Viewer to a Clip in the Canvas or Timeline
Just as you can match a sequence clip’s frame to the same frame in its master clip, (see
“Matching a Frame in the Canvas to Its Master Clip Frame”), you can also find frames in
a sequence that match a clip open in the Viewer. This is a very powerful feature because
you can instantly check to see if footage open in the Viewer is used anywhere in the
current sequence.
To match a master clip (or any Browser clip) frame to a sequence clip in the current
sequence
1 Open a sequence in the Timeline.
2 Open a Browser clip in the Viewer and navigate to the frame you want to match in the
current sequence.
3 Choose View > Match Frame > Master Clip (or press F).
If the frame shown in the Viewer exists in an affiliate clip in the sequence, the
Canvas/Timeline playhead moves to that frame. If there are several occurrences of the
affiliate clip frame in the sequence, Final Cut Pro moves the Timeline playhead to the
nearest frame after the current playhead location.

Synchronizing the Canvas/Timeline Playhead and the Viewer
Playhead
When a sequence clip is open in the Viewer, you can keep the Viewer playhead in sync
with the Canvas/Timeline playhead. If you want to work with a sequence clip in the Viewer
instead of the Timeline, you can synchronize the Viewer and Canvas/Timeline playheads
together so you see the same frame in both windows.
Final Cut Pro has several options for synchronizing, or ganging, the Viewer and
Canvas/Timeline playheads together, so that if you move one, the other moves by the
same amount. When the playheads are synchronized, you can control the playheads from
the Viewer, Canvas, or Timeline. Playhead sync only works between the Canvas and
Timeline windows and the Viewer window.

Why Synchronize Playheads?
Reasons for using playhead sync include:
• Automatically opening sequence clips in the Viewer to quickly make filter adjustments
(for example, adjusting each sequence clip’s Color Correction filter).
• Using the Viewer as an alternative to the Trim Edit window, to look at prospective new
In and Out points for a sequence clip. Although the end result is the same, this method
provides a different experience than editing in the Timeline or the two-up view you
see in the Canvas while trimming.
• Temporarily syncing a Browser clip to a sequence, using any sync relationship you want.
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• Enabling real-time multiclip editing. When the Multiclip Playback option is selected,
the Open playhead sync option is automatically selected.

About Working with Playhead Sync
The Playhead Sync pop-up menu appears in both the Canvas and the Viewer. You can
choose only one playhead sync option at a time in Final Cut Pro, but you can do so in
either window. The playhead sync option you choose remains active until you close the
Viewer or Canvas. Once either window is closed, playhead sync is set to Sync Off.

µ

To synchronize (or gang) the Viewer and Canvas/Timeline playheads
In the Viewer or Canvas, choose an option from the Playhead Sync pop-up menu—Sync
Off, Open, or Gang.
Playhead Sync pop-up
menu in the Viewer

The playhead sync options are:
• Sync Off: Disables playhead sync. This is the default behavior.
• Open: Automatically opens the sequence clip beneath the Canvas/Timeline playhead
in the Viewer. The Viewer playhead is set to the same frame as the Canvas/Timeline
playhead. For more information, see “Using the Open Playhead Sync Option.”
• Gang: You can sync the clip in the Viewer with the sequence in the Canvas and Timeline
arbitrarily, regardless of what clips or sequences are open. You set a new sync
relationship between the Canvas/Timeline and Viewer playheads each time you choose
the Gang option from the Playhead Sync pop-up menu. For more information, see
“Using the Gang Playhead Sync Option.”

Using the Open Playhead Sync Option
The Open playhead sync option opens the sequence clip at the current location of the
Canvas/Timeline playhead in the Viewer. Navigating from one clip to the next in the
Canvas or Timeline causes the corresponding sequence clips to open in the Viewer. The
tab currently selected in the Viewer remains the selected tab, even though a new clip
has been opened in the Viewer.
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The Open ganging option is useful for making filter adjustments to multiple clips in a
sequence. For example, if you have multiple clips that have color correction filters applied
to them, you can move the playhead from clip to clip, and the Color Corrector tab changes
to the current clip’s filter settings.

Using the Gang Playhead Sync Option
You can lock the playhead in the Viewer to the playhead in the Canvas and Timeline so
that they move together while scrubbing through clips. This is known as ganging the clip
in the Viewer window to the sequence in the Canvas and Timeline windows.
When this option is selected, the offset between the current position of the
Canvas/Timeline playhead and the current position of the Viewer playhead is maintained
as both playheads move together. This mode is useful for editing operations in which
you want to set In or Out points in the Viewer using durations defined by items or markers
in the Timeline as your reference.

Example: Trimming a Browser Clip by the Duration of a Sequence Clip
The Gang playhead sync option can help you perform precise trimming operations. For
example, suppose you want to trim the Out point of a Browser clip in the Viewer by the
duration of the last sequence clip in the Timeline.
To trim a clip in the Browser by the duration of a sequence clip
1 Double-click a Browser clip to open it in the Viewer.
2 Press Shift-O to move the playhead in the Viewer to the Out point of the clip.

The Out point is the
sync point for the clip
in the Viewer.
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3 Move the Canvas/Timeline playhead to the Out point of the last clip in the sequence.

The Out point of the last
clip in the sequence is
the sync point in the
Timeline and Canvas.

4 In either the Viewer or the Canvas, choose Gang from the Playhead Sync pop-up menu.
5 Move the playhead in the Timeline to the In point of the last clip in the sequence.

The playhead is moved
to the In point of the last
clip in the sequence.

The playhead in the Viewer moves to the left by the same amount.
6 In the Viewer, press O to set a new Out point.
The clip in the Viewer is now shorter by the duration of the last clip in the sequence.
This is just one example of how you can use playhead sync relationships between the
Viewer window and the Canvas and Timeline windows.
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Working with Timecode

51

This chapter covers the following:
• About Timecode in Final Cut Pro (p. 815)
• Displaying Timecode in Final Cut Pro (p. 816)
• Modifying Timecode in Media Files (p. 822)
• Modifying Sequence Timecode (p. 825)
• Working with 60 fps Timecode (p. 827)
• Working with 24 @ 25 fps Timecode (p. 827)
• Generating Timecode Window Burns (p. 828)
Timecode provides a unique address for each video frame on your tapes. Timecode is
the vital organizational link between your original camera tapes, media files on disk, and
clips in your Final Cut Pro project.

About Timecode in Final Cut Pro
Final Cut Pro works with SMPTE standard timecode, which is displayed in the following
format:
hours:minutes:seconds:frames or HH:MM:SS:FF
Each frame on a videotape has a unique timecode number, which helps you keep track
of video frames. The frame counter (FF) changes depending on the frame rate. For example,
with 30 fps (frames per second) timecode, the frame counter counts from :00 to :29, and
then back to :00 again. The frame counter in 25 fps timecode counts from :00 to :24.
Note: Some videotapes that are recorded improperly may have the same timecode
numbers in more than one location (for example, multiple occurrences of 00:00:00:00),
which makes it hard to identify where on a tape a particular shot is located. For more
information about handling these tapes, see “Capturing Video from Tape.”
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Frame Rate Versus Timecode
The frame rate of film, videotape, or media files determines how quickly frames are
recorded or played back. Timecode (or edge code in the case of film) is a unique address
for each frame, providing easy navigation, logging, recapturing, and final Edit Decision
Lists (EDLs) that accurately refer back to original camera reels. In most cases, the frame
rate and the timecode rate are the same, but film-to-video and 24p workflows often use
media files with differing video and timecode rates.
For more information about frame rate and timecode, see “Frame Rate and Timecode.”

Displaying Timecode in Final Cut Pro
By default, when Final Cut Pro displays a clip’s timecode, it reads the timecode from the
timecode track of the clip’s media file. This timecode is permanently stored in the media
file, not in the clip, and it is referred to as the source timecode because it is the same as
the timecode from the original source tape. When you display source timecode, you see
the timecode directly from the media file timecode track.
Note: It is possible to permanently modify the timecode in a media file’s timecode track,
but in most cases this is not recommended, because the whole point of the timecode
track is that it allows you to refer back to the original videotape when necessary. If you
change the timecode in the media file, the timecode no longer corresponds to the
timecode on the original tape, making recapture difficult and project interchange files
(such as EDL and OMF files) inaccurate.

Choosing a Timecode Display Option
Final Cut Pro has the following timecode display options, although not all options are
available for all frame rates:
• Non-Drop Frame: The timecode counter counts at a consistent rate without dropping
any numbers from the count. Non-drop frame timecode is available as a display option
for every frame rate.
• Drop Frame: Frames 0 and 1 are skipped the first second of every minute, unless the
minute number is exactly divisible by 10. The dropped numbers do not appear in the
Final Cut Pro timecode fields because they’ve been dropped and are not on your tape.
Drop frame timecode is only available as a display option for 29.97 fps (NTSC) media
files.
• 60 @ 30: Displays 60 fps video with 30 fps timecode. This option is used to display
timecode for 60 fps formats (such as 720p60) using 30 fps timecode. This option matches
the timecode display on many VTRs that can play 60 fps formats (such as a DVCPRO
HD deck). Each timecode number represents a pair of video frames, with the second
frame distinguished by an asterisk (*). This option is available only for 60 and 59.94 fps
(high definition) media files.
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• Frames: Shows an absolute frame count instead of hours, minutes, seconds, and frames.
This option is available for any frame rate.
• Feet + Frames: Displays a film feet and frames counter using the default film standard
assigned in the Project Properties. To change the current film standard in your project,
choose Edit > Project Properties and select an option from the Default Film Standard
pop-up menu.
Final Cut Pro can display a clip’s timecode in several different display formats without
modifying the timecode itself. For example, for animators, an absolute frame counter
(simply called frames in Final Cut Pro), can be more helpful than SMPTE timecode. It is
simple to change the timecode display in the Viewer, Canvas, Browser, or Timeline to
show an absolute frame count instead of hours, minutes, seconds, and frames. You can
switch back to a normal timecode display at any time.
If you aren’t using NTSC footage, there is no option for drop frame timecode display
because only 30 fps timecode has a drop frame mode. PAL (25 fps) footage and 60 fps
high definition footage only have a non-drop frame display mode. Non-drop frame simply
means that the timecode counter counts at a consistent rate without dropping any
numbers from the count. You can think of “non-drop frame” to mean “normal” timecode
display. In most cases, you only have the option to display your timecode as non-drop
frame (normal timecode count) or frames (an absolute frame counter).
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To change the timecode display format
Control-click a timecode field in the Viewer, Canvas, Timeline, or Browser, then choose
one of the available timecode display options from the shortcut menu.
Important: Changing the timecode display of a clip does not modify the actual timecode
track in the media file.
Here is how to determine the type of timecode used in Final Cut Pro:
• Non-drop frame timecode has a colon (:) between the seconds and frames fields, and
no numbers are dropped from the counter.
01:16:59:29, 01:17:00:00
• Drop frame timecode has a semicolon (;) between the seconds and frames fields, and
two timecode numbers are skipped from the frames counter each minute (except every
tenth minute).
01:16:59;29, 01:17:00;02
A clip’s timecode comes directly from its media files. To set sequence timecode, you can
use the Drop Frame checkbox in the Timeline Options pane of Sequence Settings. For
more information, see “Changing Timeline Display Options.”
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Displaying Timecode Affected by Speed Changes
If you alter the speed of a clip by applying a constant or variable speed change, the frames
of the media file are no longer played at their original rate. By default, Final Cut Pro displays
the timecode in italics whenever a clip is not playing at normal speed. This option, called
View Native Speed, is selected by default.
When View Native Speed is selected, Final Cut Pro displays the clip’s source timecode
(the timecode stored in the media file’s timecode track), so you may see timecode numbers
repeated or skipped because the video frames themselves are repeated or skipped to
create the speed change.
For example, if you adjust a clip’s speed by 200%, Final Cut Pro plays the media file at
twice the normal speed, which actually means only half the frames are played (every
other frame is skipped). The timecode display shows the actual timecode number of each
frame, so the timecode numbers skip, just as the video frames do.
When View Native Speed is deselected, Final Cut Pro increments the timecode number
for every frame of the speed-adjusted clip, regardless of which frame of the media file is
shown. This timecode display has no accurate relationship to the timecode of the media
file or original source tape, but is helpful if you want to see the timecode display increment
each time you move forward or backward within the clip. When you turn off View Native
Speed, Final Cut Pro creates the illusion that every frame you see in the speed-adjusted
clip has a unique timecode number, instead of the timecode numbers incrementing
whenever a different frame from the media file is shown.
Usually, it’s best to keep View Native Speed selected because it shows you the actual
timecode number for each frame in the media file. If you want to reference a particular
frame on your source tape or in the media file, you should have View Native Speed
selected so you see the correct source timecode number associated with that frame.

Choosing Source and Auxiliary Timecode Track Display
QuickTime media files can have several timecode tracks, although they typically start with
one. The timecode track written when you first capture a media file is called the source
timecode track. You can add additional timecode tracks to the media file after you capture.
These are called auxiliary (aux) timecode tracks.
Auxiliary timecode tracks do not refer to the original timecode from your source tape,
since this is the purpose of the source timecode track. Instead, they can refer to timecode
on a different tape, such as an independent audio tape recorded at the same time as the
video. In these dual system productions (in which video and audio were recorded
separately), the timecode on the videotape and the audio tape are often not the same;
yet in post-production, you need to synchronize the video and audio media files together
to edit.
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Adding auxiliary timecode tracks to your media files allows you to add matching timecode
to both media files without removing the original source timecode—which is still
important for referring back to your original tapes.
In Final Cut Pro, you can choose which timecode track to display for each clip: source,
Aux 1, or Aux 2. Many clips only have a source timecode track, so in these cases there is
no option to display Aux 1 or Aux 2 timecode.

Clip Time Versus Source Time
In most situations, it’s best to view the source timecode track of your media file. Because
you usually need to refer back to the original source tapes at some point during your
project, Final Cut Pro displays source timecode by default. However, if you are working
with media files that have a different video frame rate and source timecode rate (such
as a 23.98 fps video rate with 30 fps timecode), you may want to display timecode that
counts at the video frame rate instead of the actual source timecode track. In Final Cut Pro,
this is known as clip time.
For example, if you are editing 23.98 fps (24p) video that came from 29.97 fps tapes, the
frame rate of your media files is 23.98 fps, but the timecode track still runs at 30 fps. To
see 24 fps timecode that matches the video frame rate, you need to display clip time.
Another example is when you are editing 24 fps clips that came from 25 fps (PAL) tapes.
In this case, you can display the original 25 fps timecode (source time) or have Final Cut Pro
display 24 fps timecode (clip time).
If your media file’s timecode track and video track have the same rate, there is no difference
between source time and clip time. To avoid confusion, you should always display source
time unless you have a specific reason to use clip time.
Important: Clip time does not accurately reflect timecode that matches back to the media
file or videotape timecode. Do not rely on clip time when trying to refer back to original
media files or tapes.

Changing Global Timecode Display Options
Timecode display settings can be globally adjusted for an entire project. For most
situations, it’s best to stick with the Final Cut Pro default settings:
• Timecode: Source Time
• View Native Speed: Enabled
Note: If you customize a particular clip’s timecode display, its display option overrides
the global timecode display option. Affiliate clips are not affected when you change the
timecode display of a master or other affiliate clip.
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To choose default timecode display options for the active project
1 In the Browser, click the tab of the project for which you want to change timecode display
settings.
2 Choose Edit > Project Properties.

3 Choose a new timecode display from the Time Display pop-up menu.
4 Click OK.
To reset the timecode display for all clips in the active project
1 In the Browser, click the tab of the project for which you want to change timecode display
settings.
2 Choose Edit > Project Properties.
3 Choose a timecode display from the Time Display pop-up menu.
4 Select the Reset Time Display checkbox.
5 Click OK.
To set all clips in the active project to display source time or clip time
1 In the Browser, click the tab of the project for which you want to change time mode
settings.
2 Choose Edit > Project Properties.
3 Choose Source Time or Clip Time from the Time Mode pop-up menu.
4 Click OK.
To change the native clip speed display mode for all clips in the active project
1 In the Browser, click the tab of the project for which you want to change time mode
settings.
2 Choose Edit > Project Properties.
3 Select or deselect the View Native Speed checkbox.
4 Click OK.
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Timecode Overlays
Timecode overlays in the Viewer and Canvas always display source time from the media
file (not clip time). Timecode overlays are not affected when clip time is selected or View
Native Speed is deselected.

µ

To view timecode overlays
Choose View > Show Timecode Overlays, so there’s a checkmark next to it (or press
Option-Z).
Each timecode overlay is colored to indicate linked video and audio clips. A plus sign (+)
next to the video or audio overlay title indicates that there are additional timecode
overlays that cannot fit. Changing the size of the Canvas or Viewer can sometimes reveal
additional timecode overlays.
Plus signs indicate
that additional
timecode overlays
are not displayed.

You can use timecode overlays to verify that video “window burn” timecode (visible
timecode in the video picture itself ) matches the source timecode of the media file.

Timecode Viewer
The resizable Timecode Viewer makes reading current timecode very easy, particularly
from a distance. The Timecode Viewer displays the timecode for either the Timeline/Canvas
or the Viewer as well as the corresponding sequence name or clip name.

µ

To open the Timecode Viewer
Choose Tools > Timecode Viewer (or press Control-T).

Determining Speed Settings in the Timecode Field
You can experiment to determine how speed settings affect the timecode view.
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To see how speed settings affect the timecode view
1 Open a clip in the Viewer.
2 Choose Modify > Speed (or press Command-J).
3 Type “25” in the Speed field, then click OK.
The clip now plays back frames from the media file at 25 percent speed. The source
timecode plays back just as slowly.
4 In the Viewer, move through the clip one frame at a time using the Left Arrow and Right
Arrow keys.
Note that the timecode numbers change once every four frames. This is because the
speed-adjusted clip holds each video frame for a duration of four frames, and the native
timecode numbers are displayed. The video frames and the timecode numbers change
only every fourth frame when viewed in the speed-adjusted clip.
5 Control-click the Current Timecode field, then choose View Native Speed from the shortcut
menu to deselect it.
Note: When View Native Speed is deselected, the timecode field is no longer italicized.
6 In the Viewer, move through the clip one frame at a time using the Left Arrow and Right
Arrow keys.
Final Cut Pro now increments the timecode at the frame rate of the clip, ignoring any
speed adjustments. This timecode is not accurate to the timecode of the media file, but
it allows you to see the timecode counter increment each time you advance a frame.
If you want to see the actual source timecode of each frame of the media file, leave View
Native Speed selected.

Modifying Timecode in Media Files
In Final Cut Pro, you can modify media file timecode in several ways:
• Individual clips can be adjusted by choosing Modify > Timecode.
• Multiple clips can be adjusted in the Browser timecode columns (such as Media Start
and Media End).
In general, choosing Modify > Timecode provides deeper control over your timecode
modifications, but the Browser allows you to modify multiple clips at once.
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Timecode modification

Using Modify > Timecode

Using Browser

Adding or deleting timecode
tracks in a media file

Allowed

Not allowed

Modifying timecode (Media
Start)

Allowed on any clip

Allowed only with offline clips
not associated with media files
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Timecode modification

Using Modify > Timecode

Using Browser

Modifying reel names (Reel, Aux
1 Reel, Aux 2 Reel)

Allowed

Allowed with alert message

Modifying timecode rate (TC
Rate)

Allowed

Allowed

Choosing source time timecode
track (TC)

Unavailable

Allowed. Control-click in the TC
field.

Viewing different timecode
display formats

Allowed

Allowed. Control-click in any
timecode field.

In the Browser (or the Item Properties window), you can only adjust Media Start and
Media End fields for offline clips that are not associated with media files (in other words,
the clip must be completely offline, which means the file path in its Source property must
be empty).
You should rarely need to adjust a media file’s source timecode track. One exception is
when you are logging (before media files have been captured) and you need to adjust
the start timecode of an offline clip. In this case, you can modify Media Start and End
timecode in the Browser columns.
Warning: Modifying or deleting your source timecode track or reel name may make
recapturing from source tapes impossible and EDLs inaccurate. Unless you have a good
reason for modifying the source timecode track, it’s best not to modify the timecode
captured from tape.

Using the Modify Timecode Command
Timecode tracks in your media files can be added, altered, and even removed in the
Modify Timecode dialog.
Each media file can have up to three timecode tracks and corresponding reel names:
• Source timecode track and reel name
• Aux 1 timecode and Aux 1 reel name
• Aux 2 timecode and Aux 2 reel name
When you select a checkbox next to a timecode track, you are adding that timecode track
to your media file. Deselecting the checkbox deletes that timecode track from the media
file.
Important: Be careful not to delete the source timecode track of your media file by
deselecting its checkbox.
Some timecode rates may not be allowed for some media files. These limitations are
based on the frame rate of the media file, since some timecode rates are unnecessary for
certain video frame rates.
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To modify the timecode of a clip’s media file
1 In the Browser, select the clip or sequence with the timecode you want to change.
2 Choose Modify > Timecode.

The Modify Timecode
dialog shows all
properties associated
with the selected clip
or sequence.

3 Verify that the settings are correct:
• Frame to Set: Choose the frame you want to alter.
• Current: Choose this to alter the timecode of the current frame in the clip or sequence.
• Starting: Choose this to change the timecode of the starting frame of the clip or
sequence.
• Source TC: Select this checkbox to add or alter the timecode of the source clip or
sequence’s media file on disk.
• Aux TC 1 and Aux TC 2: Select these checkboxes to create or change the properties of
auxiliary timecode clips or sequences.
• Reel/Roll: The reel number is displayed here. If you need to change the reel number,
enter the reel number here.
Tip: You can also change the reel number in the Browser or the Item Properties dialog.
For more information, see “Changing Clip Properties in the Browser” and “Viewing and
Changing Clip Properties in the Item Properties Window.”
• Timecode: The current timecode is displayed here. If you choose to modify the timecode,
enter the new timecode value here.
• Format: Choose Drop Frame or Non-Drop Frame from the pop-up menu.
• Rate: Choose a timecode rate from the pop-up menu.
4 Enter the new timecode value in the Timecode field.
5 Click OK to permanently change the timecode.
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Modifying Timecode in the Browser or Item Properties
Most timecode settings can be modified in the Browser or the Item Properties window,
but some fields are restricted to prevent accidental changes to many media files at once.
When you modify particular Browser columns, Final Cut Pro warns you that the media
file, not just the clip, will be affected. For more information, see “Viewing and Changing
Clip Properties in the Item Properties Window.”
The TC Rate item property (visible in both the Browser columns and the Item Properties
window) always shows the rate of the source timecode track of a clip’s media file. The
Aux 1 or Aux 2 timecode rates are never shown here. Use the TC Rate column in the
Browser to adjust the timecode rate for many clips at once. Some timecode rates are not
allowed for some video frame rates.
Note: The TC Rate property is the rate of the source timecode track in a media file. The
Vid Rate property is the rate of the video track in a media file. In many instances, these
are the same, but not always. For example, an NTSC media file has a video rate of 29.97 fps,
but a timecode rate of 30 fps.

Modifying the Timecode of Merged Clips
If you select a merged clip and choose Modify > Timecode, each item in the clip that’s
linked to a separate source media file appears in its own tab. This allows you to change
the timecode of each item in a merged clip separately. For example, a merged clip with
items from three sources has three tabs in the Modify Timecode dialog. For more
information, see “Merging Clips from Dual System Video and Audio.”
The number of tabs
indicates the number
of source items.

Modifying Sequence Timecode
The starting timecode number of a sequence can be changed in the Sequence Settings
window. You can also modify the timecode rate of the sequence (independently of the
frame rate, or editing timebase). To do this, you need to use the Modify Timecode dialog.
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Warning: It is not a good idea to choose a video frame rate (timebase) that is different
from the timecode rate for your sequence unless you have a good reason.
To adjust the starting timecode number of a sequence
1 Select a sequence in the Browser, or make a sequence active by clicking the sequence’s
tab in the Canvas or Timeline.
2 Choose Sequence > Settings.
3 In the Sequence Settings window, click the Timeline Options tab.
4 Type a new timecode number in the Starting Timecode field.
5 Click OK.
In special editing scenarios, the video frame rate (timebase) and timecode rate of a
sequence need to be different. For example, if you are editing 24 @ 25 film-to-PAL video,
you use a sequence with a video frame rate of 24 fps with a timecode track modified to
25 fps.
For more information about the 24 @ 25 PAL editing process, see “Working with 24 @
25 fps Timecode.”
To create a sequence preset in which the video frame rate (timebase) and timecode
rate are different
1 Choose Final Cut Pro > Audio/Video Settings.
2 Click the Sequence Presets tab.
3 In the list of presets, click the unlocked sequence preset you want to modify.
4 Click the Edit button to edit the selected preset, or click the Duplicate button to edit a
new copy of the selected sequence preset.
The sequence video frame rate (timebase) and timecode rate can now be set in the
Sequence Preset Editor window. By default, the timecode rate matches the video frame
rate, as indicated by the Same As Editing Timebase option in the Timecode Rate popup
menu.
5 Choose a video frame rate from the Editing Timebase pop-up menu.
6 Choose a timecode rate from the Timecode Rate pop-up menu.
Note: Not all timecode rates are available for all video frame rates (timebases).
7 Click OK to accept the changes, then click OK again to close the Audio/Video Settings
window.
The new sequence preset can be applied to existing sequences or used in Easy Setups.
If you already have a sequence for which you’d like to modify the timecode rate, you can
also use the Modify Timecode dialog. However, it’s usually best to alter the timecode rate
of a sequence before you begin editing with it.
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To modify the timecode rate of an existing sequence
1 Select a sequence in the Browser.
2 Choose Modify > Timecode.
3 Adjust, add, or remove timecode tracks as needed.

Working with 60 fps Timecode
Some high definition video formats, such as 720p60, have a video frame rate of 60 (or
59.94) fps. Final Cut Pro can display 60 fps timecode for 60 fps media files, or you can
choose to view the timecode at 30 fps, using the special 60 @ 30 timecode display option.
60 @ 30 is a timecode display option used specifically with 59.94 and 60 fps video footage.
Because 30 fps is a more universally accepted timecode rate than 60 fps, it can be useful
to view your timecode this way. Also, most DVCPRO HD VTRs display this timecode rate
when playing back 60 fps tapes. Each 60 @ 30 timecode number represents a pair of
video frames, with the second frame distinguished by an asterisk (*).
When you are using 60 @ 30 timecode, Final Cut Pro recognizes asterisks when you type
them into timecode fields. Typing a plus sign (+) followed by an asterisk (*) in 60 @ 30
mode is the same as typing “+1” in 60 fps timecode.
Note: Mapping 60 frames to 30 numbers per second is not a new concept. VITC timecode
represents each pair of fields (in other words, each frame) with a single timecode number.
Fields 1 and 2 are distinguished by an asterisk placed on field 2. 60 @ 30 timecode works
similarly.

Working with 24 @ 25 fps Timecode
Final Cut Pro has a special timecode format for editing 24 fps film that was transferred to
25 fps PAL video.
24 @ 25 timecode displays 25 fps timecode while you edit 24 fps video. This allows you
to see the actual source timecode from the 25 fps PAL videotape even though you are
editing at a frame rate of 24 fps. Editing at 24 fps is important because this is how the
final film will be projected, but 25 fps timecode is important because this accurately shows
you where each video frame comes from on the PAL videotapes. The PAL videotapes, in
turn, correspond to the original film edge code numbers. If you don’t maintain the 25 fps
timecode while editing in Final Cut Pro, you can’t accurately trace your footage back to
the original film negative to make a proper negative cut.
For more information about 24 @ 25 fps editing, see the documentation that came with
Cinema Tools.
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Generating Timecode Window Burns
If you need to create a videotape or QuickTime movie that displays timecode directly in
the image (known as a timecode window burn, or window burn for short), you can use the
Timecode Reader or Timecode Generator filters. Both are located in the Video bin inside
the Video Filters bin in the Effects tab of the Browser.
Note: In versions of Final Cut Pro earlier than 4.5, timecode reading and generation were
contained in a single filter called the Timecode Print filter. Older projects that use the
Timecode Print filter will still function properly.
• Timecode Reader: This filter generates a visible timecode counter based on the video
frame rate (timebase) of the clip or sequence to which the filter is applied.
• Timecode Generator: This filter generates a visible timecode counter independent of
the timebase and timecode format of the affected clip (or sequence). For example, you
can apply a Timecode Generator filter counting at 24 fps while the affected sequence
has a timebase of 29.97 fps.
To generate a visible timecode “window burn,” you can apply the Timecode Reader filter
to individual clips or an entire sequence. For information on applying filters to individual
clips, see “Using Video Filters.”
To apply the Timecode Reader filter to an entire sequence
1 Nest your original sequence within a second sequence with matching sequence settings.
For information about nesting sequences, see “Nesting Sequences.”
2 In the second sequence, apply the Timecode Reader filter to the nested, original sequence.
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This chapter covers the following:
• What Is Sound? (p. 829)
• Measuring Sound Intensity (p. 833)
• Signal-to-Noise Ratio (p. 835)
• Headroom and Distortion (p. 835)
• Dynamic Range and Compression (p. 836)
• Stereo Audio (p. 837)
• Digital Audio (p. 839)
To successfully create your movie soundtrack, it’s important to learn about the basic
properties of sound and digital audio.

What Is Sound?
All sounds are vibrations traveling through the air as sound waves. Sound waves are
caused by the vibrations of objects and radiate outward from their source in all directions.
A vibrating object compresses the surrounding air molecules (squeezing them closer
together) and then rarefies them (pulling them farther apart). Although the fluctuations
in air pressure travel outward from the object, the air molecules themselves stay in the
same average position. As sound travels, it reflects off objects in its path, creating further
disturbances in the surrounding air. When these changes in air pressure vibrate your
eardrum, nerve signals are sent to your brain and are interpreted as sound.
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Fundamentals of a Sound Wave
The simplest kind of sound wave is a sine wave. Pure sine waves rarely exist in the natural
world, but they are a useful place to start because all other sounds can be broken down
into combinations of sine waves. A sine wave clearly demonstrates the three fundamental
characteristics of a sound wave: frequency, amplitude, and phase.

Amplitude

+

–

Time

0

1 ms

Frequency
Frequency is the rate, or number of times per second, that a sound wave cycles from
positive to negative to positive again. Frequency is measured in cycles per second or hertz
(Hz). Humans have a range of hearing from 20 Hz (low) to 20,000 Hz (high). Frequencies
beyond this range exist, but they are inaudible to humans.
Amplitude
Amplitude (or intensity ) refers to the strength of a sound wave, which the human ear
interprets as volume or loudness. People can detect a very wide range of volumes, from
the sound of a pin dropping in a quiet room to a loud rock concert. Because the range
of human hearing is so large, audio meters use a logarithmic scale (decibels) to make the
units of measurement more manageable.
Phase
Phase compares the timing between two similar sound waves. If two periodic sound
waves of the same frequency begin at the same time, the two waves are said to be in
phase. Phase is measured in degrees from 0 to 360, where 0 degrees means both sounds
are exactly in sync (in phase) and 180 degrees means both sounds are exactly opposite
(out of phase). When two sounds that are in phase are added together, the combination
makes an even stronger result. When two sounds that are out of phase are added together,
the opposing air pressures cancel each other out, resulting in little or no sound. This is
known as phase cancelation.
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Phase cancelation can be a problem when mixing similar audio signals together, or when
original and reflected sound waves interact in a reflective room. For example, when the
left and right channels of a stereo mix are combined to create a mono mix, the signals
may suffer from phase cancelation.

Separate signals

In phase

Out of phase

Mixed signals

Frequency Spectrum of Sounds
With the exception of pure sine waves, sounds are made up of many different frequency
components vibrating at the same time. The particular characteristics of a sound are the
result of the unique combination of frequencies it contains.
Sounds contain energy in different frequency ranges, or bands. If a sound has a lot of
low-frequency energy, it has a lot of bass. The 250-4000 Hz frequency band, where humans
hear best, is described as midrange. High-frequency energy beyond the midrange is called
treble, and this adds crispness or brilliance to a sound. The graph below shows how the
sounds of different musical instruments fall within particular frequency bands.
High

4 kHz

Cymbal crash
Violin and flute

Mid

Frequency

20 kHz

Cello

300 Hz
Bass

Bass line

20 Hz
Time
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Note: Different manufacturers and mixing engineers define the ranges of these frequency
bands differently, so the numbers described above are approximate.
The human voice produces sounds that are mostly in the 250-4000 Hz range, which likely
explains why people’s ears are also the most sensitive to this range. If the dialogue in
your movie is harder to hear when you add music and sound effects, try reducing the
midrange frequencies of the nondialogue tracks using an equalizer filter. Reducing the
midrange creates a “sonic space” in which the dialogue can be heard more easily.
Musical sounds typically have a regular frequency, which the human ear hears as the
sound’s pitch. Pitch is expressed using musical notes, such as C, E flat, and F sharp. The
pitch is usually only the lowest, strongest part of the sound wave, called the fundamental
frequency. Every musical sound also has higher, softer parts called overtones or harmonics,
which occur at regular multiples of the fundamental frequency. The human ear doesn’t
hear the harmonics as distinct pitches, but rather as the tone color (also called the timbre
) of the sound, which allows the ear to distinguish one instrument or voice from another,
even when both are playing the same pitch.

Time

Fundamental

Time

First harmonic

Time

Second harmonic
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Musical sounds also typically have a volume envelope. Every note played on a musical
instrument has a distinct curve of rising and falling volume over time. Sounds produced
by some instruments, particularly drums and other percussion instruments, start at a high
volume level but quickly decrease to a much lower level and die away to silence. Sounds
produced by other instruments, for example, a violin or a trumpet, can be sustained at
the same volume level and can be raised or lowered in volume while being sustained.
This volume curve is called the sound’s envelope and acts like a signature to help the ear
recognize what instrument is producing the sound.

Percussive volume envelope

Sustained volume envelope

Measuring Sound Intensity
Human ears are remarkably sensitive to vibrations in the air. The threshold of human
hearing is around 20 microPascals (μP), which is an extremely small amount of atmospheric
pressure. At the other extreme, the loudest sound a person can withstand without pain
or ear damage is about 200,000,000 μP: for example, a loud rock concert or a nearby jet
airplane taking off.
Because the human ear can handle such a large range of intensities, measuring sound
pressure levels on a linear scale is inconvenient. For example, if the range of human
hearing were measured on a ruler, the scale would go from 1 foot (quietest) to over
3000 miles (loudest)! To make this huge range of numbers easier to work with, a
logarithmic unit—the decibel—is used. Logarithms map exponential values to a linear
scale. For example, by taking the base-ten logarithm of 10 (101) and 1,000,000,000 (109),
this large range of numbers can be written as 1-9, which is a much more convenient scale.
Because the ear responds to sound pressure logarithmically, using a logarithmic scale
corresponds to the way humans perceive loudness. Audio meters and sound measurement
equipment are specifically designed to show audio levels in decibels. Small changes at
the bottom of an audio meter may represent large changes in signal level, while small
changes toward the top may represent small changes in signal level. This makes audio
meters very different from linear measuring devices like rulers, thermometers, and
speedometers. Each unit on an audio meter represents an exponential increase in sound
pressure, but a perceived linear increase in loudness.
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Important: When you mix audio, you don’t need to worry about the mathematics behind
logarithms and decibels. Just be aware that to hear incremental increases in sound volume,
exponentially more sound pressure is required.

What Is a Decibel?
The decibel measures sound pressure or electrical pressure (voltage) levels. It is a
logarithmic unit that describes a ratio of two intensities, such as two different sound
pressures, two different voltages, and so on. A bel (named after Alexander Graham Bell)
is a base-ten logarithm of the ratio between two signals. This means that for every
additional bel on the scale, the signal represented is ten times stronger. For example, the
sound pressure level of a loud sound can be billions of times stronger than a quiet sound.
Written logarithmically, one billion (1,000,000,000 or 109) is simply 9. Decibels make the
numbers much easier to work with.
In practice, a bel is a bit too large to use for measuring sound, so a one-tenth unit called
the decibel is used instead. The reason for using decibels instead of bels is no different
from the reason for measuring shoe size in, say, centimeters instead of meters; it is a more
practical unit.
Number of decibels

Relative increase in power

0

1

1

1.26

3

2

10

10

20

100

30

1000

50

100,000

100

10,000,000,000

Decibel Units
Audio meters are labeled with decibels. Several reference levels have been used in audio
meters over the years, starting with the invention of the telephone and evolving to present
day systems. Some of these units are only applicable to older equipment. Today, most
professional equipment uses dBu, and most consumer equipment uses dBV. Digital meters
use dBFS.
• dBm: The m stands for milliwatt (mW), which is a unit for measuring electrical power.
(Power is different from electrical voltage and current, though it is related to both.)
This was the standard used in the early days of telephone technology and remained
the professional audio standard for years.
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• dBu: This reference level measures voltage instead of power, using a reference level of
0.775 volts. dBu has mostly replaced dBm on professional audio equipment. The u
stands for unloaded, because the electrical load in an audio circuit is no longer as
relevant as it was in the early days of audio equipment.
• dBV: This also uses a reference voltage like dBu, but in this case the reference level is
1 volt, which is more convenient than 0.775 volts in dBu. dBV is often used on consumer
and semiprofessional devices.
• dBFS: This scale is very different from the others because it is used for measuring digital
audio levels. FS stands for full-scale, which is used because, unlike analog audio signals
that have an optimum signal voltage, the entire range of digital values is equally
acceptable when using digital audio. 0 dBFS is the highest-possible digital audio signal
you can record without distortion. Unlike analog audio scales like dBV and dBu, there
is no headroom past 0 dBFS. For more information about digital audio metering, see
“About Audio Meters.”

Signal-to-Noise Ratio
Every electrical system produces a certain amount of low-level electrical activity called
noise. The noise floor is the level of noise inherent in a system. It is nearly impossible to
eliminate all the noise in an electrical system, but you don’t have to worry about the noise
if you record your signals significantly higher than the noise floor. If you record audio too
low, you raise the volume to hear it, which also raises the volume of the noise floor,
causing a noticeable hiss.
The more a signal is amplified, the louder the noise becomes. Therefore, it is important
to record most audio around the nominal (ideal) level of the device, which is labeled 0 dB
on an analog audio meter.
The signal-to-noise ratio, typically measured in dB, is the difference between the nominal
recording level and the noise floor of the device. For example, the signal-to-noise ratio
of an analog tape deck may be 60 dB, which means the inherent noise in the system is
60 dB lower than the ideal recording level.

Headroom and Distortion
If an audio signal is too strong, it will overdrive the audio circuit, causing the shape of the
signal to distort. In analog equipment, distortion increases gradually the more the audio
signal overdrives the circuit. For some audio recordings, this kind of distortion can add a
unique “warmth” to the recording that is difficult to achieve with digital equipment.
However, for audio post-production, the goal is to keep the signal clean and undistorted.
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0 dB on an analog meter refers to the ideal recording level, but there is some allowance
for stronger signals before distortion occurs. This safety margin is known as headroom,
meaning that the signal can occasionally go higher than the ideal recording level without
distorting. Having headroom is critical when recording, especially when the audio level
is very dynamic and unpredictable. Even though you can adjust the recording level while
you record, you can’t always anticipate quick, loud sounds. The extra headroom above
0 dB on the meter is there in case the audio abruptly becomes loud.

Dynamic Range and Compression
Dynamic range is the difference between the quietest and loudest sound in your mix. A
mix that contains quiet whispers and loud screams has a large dynamic range. A recording
of a constant drone such as an air conditioner or steady freeway traffic has very little
amplitude variation, so it has a small dynamic range.
You can actually see the dynamic range of an audio clip by looking at its waveform. For
example, two waveforms are shown below. The top one is a section from a well-known
piece of classical music. The bottom one is from a piece of electronic music. From the
widely varied shape of the waveform, you can tell that the classical piece has the greater
dynamic range.

Waveform from a well-known
classical piece

Waveform from an excerpt
of electronic music

Notice that the loud and soft parts of the classical piece vary more frequently, as compared
to the fairly consistent levels of the electronic music. The long, drawn-out part of the
waveform at the left end of the top piece is not silence—it’s actually a long, low section
of the music.
Dynamic sound has drastic volume changes. Sound can be made less dynamic by reducing,
or compressing, the loudest parts of the signal to be closer to the quiet parts. Compression
is a useful technique because it makes the sounds in your mix more equal. For example,
a train pulling into the station, a man talking, and the quiet sounds of a cricket-filled
evening are, in absolute terms, very different volumes. Because televisions and film
theaters must compete with ambient noise in the real world, it is important that the quiet
sounds are not lost.

836

Chapter 52 Audio Fundamentals

The goal is to make the quiet sounds (in this case, the crickets) louder so they can compete
with the ambient noise in the listening environment. One approach to making the crickets
louder is to simply raise the level of the entire soundtrack, but when you increase the
level of the quiet sounds, the loud sounds (such as the train) get too loud and distort.
Instead of raising the entire volume of your mix, you can compress the loud sounds so
they are closer to the quiet sounds. Once the loud sounds are quieter (and the quiet
sounds remain the same level), you can raise the overall level of the mix, bringing up the
quiet sounds without distorting the loud sounds.
When used sparingly, compression can help you bring up the overall level of your mix
to compete with noise in the listening environment. However, if you compress a signal
too far, it sounds very unnatural. For example, reducing the sound of an airplane jet
engine to the sound of a quiet forest at night and then raising the volume to maximum
would cause the noise in the forest to be amplified immensely.
Different media and genres use different levels of compression. Radio and television
commercials use compression to achieve a consistent wall of sound. If the radio or
television becomes too quiet, the audience may change the channel—a risk advertisers
and broadcasters don’t want to take. Films in theaters have a slightly wider dynamic range
because the ambient noise level of the theater is lower, so quiet sounds can remain quiet.

Stereo Audio
The human ear hears sounds in stereo, and the brain uses the subtle differences in sounds
entering the left and right ears to locate sounds in the environment. To re-create this
sonic experience, stereo recordings require two audio channels throughout the recording
and playback process. The microphones must be properly positioned to accurately capture
a stereo image, and speakers must also be spaced properly to re-create a stereo image
accurately.
If any part of the audio reproduction pathway eliminates one of the audio channels, the
stereo image will most likely be compromised. For example, if your playback system has
a CD player (two audio channels) connected to only one speaker, you will not hear the
intended stereo image.
Important: All stereo recordings require two channels, but two-channel recordings are
not necessarily stereo. For example, if you use a single-capsule microphone to record the
same signal on two tracks, you are not making a stereo recording.

Identifying Two-Channel Mono Recordings
When you are working with two-channel audio, it is important to be able to distinguish
between true stereo recordings and two tracks used to record two independent mono
channels. These are called dual mono recordings.
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Examples of dual mono recordings include:
• Two independent microphones used to record two independent sounds, such as two
different actors speaking. These microphones independently follow each actor’s voice
and are never positioned in a stereo left-right configuration. In this case, the intent is
not a stereo recording but two discrete mono channels of synchronized sound.
• Two channels with exactly the same signal. This is no different than a mono recording,
because both channels contain exactly the same information. Production audio is
sometimes recorded this way, with slightly different gain settings on each channel.
This way, if one channel distorts, you have a safety channel recorded at a lower level.
• Two completely unrelated sounds, such as dialogue on track 1 and a timecode audio
signal on track 2, or music on channel 1 and sound effects on channel 2. Conceptually,
this is not much different than recording two discrete dialogue tracks in the example
above.
The important point to remember is that if you have a two-track recording system, each
track can be used to record anything you want. If you use the two tracks to record properly
positioned left and right microphones, you can make a stereo recording. Otherwise, you
are simply making a two-channel mono recording.

Identifying Stereo Recordings
When you are trying to decide how to work with an audio clip, you need to know whether
a two-channel recording was intended to be stereo or not. Usually, the person recording
production sound will have labeled the tapes or audio files to indicate whether they were
recorded as stereo recordings or dual-channel mono recordings. However, things don’t
always go as planned, and tapes aren’t always labeled as thoroughly as they should be.
As an editor, it’s important to learn how to differentiate between the two.
Here are some tips for distinguishing stereo from dual mono recordings:
• Stereo recordings must have two independent tracks. If you have a tape with only one
track of audio, or a one-channel audio file, your audio is mono, not stereo.
Note: It is possible that a one-channel audio file is one half of a stereo pair. These are
known as split stereo files, because the left and right channels are contained in
independent files. Usually, these files are labeled accordingly: AudioFile.L and AudioFile.R
are two audio files that make up the left and right channels of a stereo sound.
• Almost all music, especially commercially available music, is mixed in stereo.
• Listen to a clip using two (stereo) speakers. If each side sounds subtly different, it is
probably stereo. If each side sounds absolutely the same, it may be a mono recording.
If each side is completely unrelated, it is a dual mono recording.
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Interleaved Versus Split Stereo Audio Files
Digital audio can send a stereo signal within a single stream by interleaving the digital
samples during transmission and deinterleaving them on playback. The way the signal
is stored is unimportant as long as the samples are properly split to left and right channels
during playback. With analog technology, the signal is not nearly as flexible.
Split stereo files are two independent audio files that work together, one for the left
channel (AudioFile.L) and one for the right channel (AudioFile.R). This mirrors the traditional
analog method of one track per channel (or in this case, one file per channel).

Digital Audio
Digital audio recording works by recording, or sampling, an electronic audio signal at
regular intervals (of time). An analog-to-digital (A/D) converter measures and stores each
sample as a numerical value that represents the audio amplitude at that particular moment.
Converting the amplitude of each sample to a binary number is called quantization. The
number of bits used for quantization is referred to as bit depth. Sample rate and bit depth
are two of the most important factors when determining the quality of a digital audio
system.

Sample Rate
The sample rate is the number of times an analog signal is measured—or sampled—per
second. You can also think of the sample rate as the number of electronic snapshots
made of the sound wave per second. Higher sample rates result in higher sound quality
because the analog waveform is more closely approximated by the discrete samples.
Which sample rate you choose to work with depends on the source material you’re
working with, the capabilities of your audio interface, and the final destination of your
audio.
For years, the digital audio sample rate standards have been 44,100 Hz (44.1 kHz) and
48 kHz. However, as technology improves, 96 kHz and even 192 kHz sample rates are
becoming common.
Audio sample rates

When used

8 kHz-22.225 kHz

These lower sample rates are used strictly for multimedia files.

32 kHz

32 kHz is generally used with 12-bit audio on DV.

44.1 kHz

This sample rate is used for music CDs and some DAT recorders.

48 kHz

Almost all digital video formats use this sample rate.

88.2 kHz

A multiple of 44.1 kHz. This is useful for high-resolution audio that
needs to be compatible with 44.1 kHz. For example, if you eventually
plan to burn an audio CD, this sample rate is a good choice.

96 kHz

A multiple of 48 kHz. This is becoming the professional standard
for audio post-production and music recording.
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Audio sample rates

When used

192 kHz

A multiple of 48 and 96 kHz, this is a very high-resolution sample
rate used mostly for professional music recording and mastering.

Bit Depth
Unlike analog signals, which have an infinite range of volume levels, digital audio samples
use binary numbers (bits) to represent the strength of each audio sample. The accuracy
of each sample is determined by its bit depth. Higher bit depths mean your audio signal
is more accurately represented when it is sampled. Most digital audio systems use a
minimum of 16 bits per sample, which can represent 65,536 possible levels (24-bit samples
can represent over 16 million possible levels).
To better understand bit depth, think of each digital audio sample as a ladder with equally
spaced rungs that climb from silence to full volume. Each rung on the ladder is a possible
volume that a sample can represent, while the spaces between rungs are in-between
volumes that a sample cannot represent.
When a sample is made, the audio level of the analog signal often falls in the spaces
between rungs. In this case, the sample must be rounded to the nearest rung. The bit
depth of a digital audio sample determines how closely the rungs are spaced. The more
rungs available (or, the less space between rungs), the more precisely the original signal
can be represented.
Quantization errors occur when a digital audio sample does not exactly match the analog
signal strength it is supposed to represent (in other words, the digital audio sample is
slightly higher or lower than the analog signal). Quantization errors are also called rounding
errors because imprecise numbers represent the original analog audio. For example,
suppose an audio signal is exactly 1.15 volts, but the analog-to-digital converter rounds
this to 1 volt because this is the closest bit value available. This rounding error causes
noise in your digital audio signal. While quantization noise may be imperceptible, it can
potentially be exacerbated by further digital processing. Always try to use the highest
bit depth possible to avoid quantization errors.
The diagram on the far right shows the highest bit depth. Therefore, the audio samples
more accurately reflect the shape of the original analog audio signal.
Analog waveform
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Audio sample

For example, a 1-bit system (a ladder with only two rungs) can represent either silence
or full volume, and nothing in between. Any audio sample that falls between these rungs
must be rounded to full volume or silence. Such a system would have absolutely no
subtlety, rounding smooth analog signals to a square-shaped waveform.

Sine

Square

When the number of bits per sample is increased, each sample can more accurately
represent the audio signal.

1-bit

2-bit

4-bit

16-bit

To avoid rounding errors, you should always use the highest bit depth your equipment
supports. Most digital video devices use 16- or 20-bit audio, so you may be limited to
one of these bit depths. However, professional audio recording devices usually support
24-bit audio, which has become the industry standard.
Bit depth

When used

32-bit floating point

Internal resolution of the Final Cut Pro Audio Mixer. This allows
audio calculations, such as fader levels and effects processing, to
be performed at very high resolution with a minimum of error,
which preserves the quality of your digital audio.

24-bit

This has become the audio industry standard for most audio
recording formats. Most professional audio interfaces and computer
audio editing systems can record with 24-bit precision.

20-bit

Used in some video formats such as Digital Betacam and audio
formats such as ADAT Type II.

16-bit

DAT recorders, Tascam DA-88 and ADAT Type I multitracks, and
audio CDs all use 16-bit samples. Many digital video formats, such
as DV, use 16-bit audio.1
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Bit depth

When used

8-bit

In the past, 8-bit audio was often used for CD-ROM and web video.
Today, 16-bit audio is usually preferred, but available bandwidth
and compatibility with your target user’s system are your chief
considerations when outputting audio for multimedia use.

1 Many consumer DV camcorders allow you to record four audio channels using 12-bit mode, but this is not
recommended for professional work.
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This chapter covers the following:
• Audio Signal Flow in Final Cut Pro (p. 843)
• Configuring Audio Outputs (p. 847)
• Creating and Saving Audio Output Presets (p. 850)
• Assigning a Default Audio Output Preset for New Sequences (p. 851)
• Assigning Tracks in the Timeline to Audio Outputs (p. 851)
• Matching Audio Outputs to Clip Items in the Timeline (p. 851)
• Assigning More Audio Outputs Than Your Hardware Supports (p. 853)
• Audio Output Export Settings (p. 853)
• Downmixing Multiple Audio Channels to a Stereo Mix (p. 854)
• Configuring External Audio Monitors (p. 857)
Final Cut Pro supports multiple output channels for audio monitoring and output to
multichannel devices.

Audio Signal Flow in Final Cut Pro
When you play a sequence, you also need to hear the audio. Audio signal flow is the path
audio takes from tracks in the Timeline to your speakers. Understanding signal flow helps
you to properly set up audio equipment for output and monitoring. Your ability to follow
the audio path also helps you to troubleshoot silent sequences or tracks that are routed
to the wrong channels on an output deck.
Here is the basic audio signal flow in Final Cut Pro:
• Audio tracks in the Timeline
• Output busses
• Hardware audio outputs
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• Speakers, devices, or exported files

Output
busses
1

1

2

2

1

Speakers

2
Timeline

Audio Tracks
Signal flow begins in the Timeline, where you can have up to 99 audio tracks. Audio tracks
contain audio clip items from clips that you have edited into your sequence. The signal
from each audio track can be routed to an output bus, and multiple audio tracks can be
assigned to the same bus.
Timeline tracks
1

Audio clip

2

Audio clip

3

Audio clip
To output busses

99

Audio clip

Busses
A track is connected to a bus. A bus allows you to mix multiple audio tracks into a single
signal. An output bus is typically connected to a hardware audio output on your computer
or audio interface. Without busses, only one track could be connected to a physical audio
output at a time, requiring you to have as many physical audio outputs as you had tracks.
For example, if you have a sequence with eight audio tracks, you can assign the output
of each track to the same bus. That bus mixes the eight audio signals together and sends
the combined signal to a hardware audio output so you can hear all eight tracks on a
single speaker.
Each bus typically corresponds to a hardware output, so busses and hardware outputs
are usually synonymous. However, you can also use output busses to group track outputs
together for mixing and grouped export. Busses can be mono or stereo and can be
connected to one or two hardware outputs, respectively.
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Note: Busses in Final Cut Pro are used for routing tracks to hardware audio outputs or
for automatic stereo downmixing. You cannot create send or auxiliary busses as you
would in other audio applications.

Hardware Outputs
Hardware outputs are the physical outputs on your audio interface or any other device
you connect your audio output busses to, such as the audio outputs of a DV deck.
Final Cut Pro supports up to 24 hardware audio outputs.
Audio
interface

Speakers

1
2
3
4
5
6
VTR
24

By default, Final Cut Pro uses the audio output device in the currently selected Easy Setup.
If you need more audio output channels or higher-quality outputs, you can connect a
third-party audio interface to your computer. For more information about audio interfaces,
see “Connecting Professional Video and Audio Equipment.” For information about choosing
an audio output device for Final Cut Pro, see “Configuring External Audio Monitors.”

Defining Output Busses by Grouping
Output busses can be grouped together as dual mono or stereo outputs.
Stereo
1

Dual
mono
2

Stereo
3

Stereo
12

1

3

5

24

2

4

6

25

Hardware outputs
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Dual Mono Output Groups
Dual mono output groups allow you to output tracks to hardware outputs discretely.
Assign a sequence track to a dual mono output whenever you want to send your audio
directly to a hardware output without pan control.
Timeline tracks
Tracks 1, 3, and 5
routed to
mono bus 1
Tracks 2, 4, and 6
routed to
mono bus 2

1

Audio clip

2

Audio clip

3

Audio clip

4

Audio clip

5

Audio clip

6

Audio clip

Bus
(dual mono)

2

1

Hardware
outputs

Stereo Output Groups
Stereo output groups allow you to use pan controls in the Audio Mixer to place track
audio within a stereo image. Stereo output groups are useful when you want to create
pan effects (such as a car passing from screen left to screen right) from mono clips or
when you want to preserve the pan settings of stereo clips.
Timeline tracks

Tracks 1–6
routed to
stereo bus

1

Audio clip

2

Audio clip

3

Audio clip

4

Audio clip

5

Audio clip

6

Audio clip

Bus
(stereo)

2

1

Hardware
outputs
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Speakers
Speakers (also called audio monitors) are devices that turn an audio signal into sound.
Your computer has built-in speakers, but you can also purchase external audio speakers
for higher-quality monitoring. Most speakers are sold in a stereo pair, but 5.1-channel
surround sound speakers (totaling six speakers) are also becoming common.

Configuring Audio Outputs
Configuring Final Cut Pro to output audio requires two basic steps:
• Stage 1: Choosing an Audio Interface for Output
• Stage 2: Choosing an Audio Output Preset

Stage 1: Choosing an Audio Interface for Output
An audio interface provides hardware outputs for connecting to speakers or external
devices such as video decks. For the purposes of this section, you can consider an audio
interface to be either the built-in audio connectors on your computer or an external
third-party device. For more information about audio interfaces, see “Connecting
Professional Video and Audio Equipment.”
You can choose an audio interface for playing audio from the Viewer, Canvas, and Timeline.
To choose an audio interface to monitor your audio or to output audio to an external
device
1 Choose Final Cut Pro > Audio/Video Settings, then click the A/V Devices tab.

Then, click here to
select options for your
audio interface.

First, choose an audio
interface here.

2 Choose an audio interface from the Audio pop-up menu. This interface is used for playing
audio from the Viewer, Canvas, and Timeline.
• Default: This option uses the output device you have selected in the Output pane of
the Sound pane of Mac OS X System Preferences (or in the Audio MIDI Setup utility). If
you want to control the audio output of Final Cut Pro from these locations, choose this
option. This is the default setting for audio output.
• Built-in Audio: This is your computer’s built-in audio interface.
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• FireWire DV: If you connect a DV camcorder or deck to your computer, this option
becomes the default setting.
• Other available audio interfaces: If you have a third-party video or audio interface
installed, it appears in this list.
Depending on your hardware, additional options may be available to configure your
audio interface.
3 Click Options, then make choices for the following:

• Channels: Choose the number of channels your audio interface can output. You can
assign sequence tracks to these channels by creating an audio output preset. For more
information, see “Creating and Saving Audio Output Presets.”
• Bit Depth: Choose a supported bit depth for the audio. Sixteen-bit audio is compatible
with most DV equipment. For high-resolution output and export, 24-bit audio is
preferred.
• Sample Rate (Hz): Choose a standard sample rate from the pop-up menu. For professional
video applications, 48 kHz is typical, though 96 kHz is becoming more popular.
4 Select or deselect the following alert message options:
• Do not show External A/V Device Warning when device not found on launch: Select this
checkbox to turn off the alert message when selected devices cannot be found during
application startup.
• Do not show warning when audio outputs are greater than audio device channels: When
selected, this option disables the following message: “The selected external audio
device does not support N outputs. Unsupported outputs will be ignored during
playback on this machine.” This message appears when you assign more audio output
channels to a sequence than the audio interface currently selected in the Audio/Video
Settings window can support. For more information about setting audio outputs, see
“Assigning More Audio Outputs Than Your Hardware Supports.”
Final Cut Pro supports “audio follows video” output switching, which means that changing
the selected video interface automatically switches the audio to the same interface (when
possible).
To turn on “audio follows video” switching for video and audio outputs
1 Choose View > Video Playback, then select a video output from the submenu.
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2 Choose View > Audio Playback > Audio Follows Video, and make sure that the option is
turned on (indicated by a checkmark).
With the Audio Follows Video option turned on, you can now select a video interface
and the corresponding audio interface or device is selected automatically.
Tip: If you don’t see your audio interface appear in the list of audio outputs, choose View
> Refresh A/V Devices, then try to select your output again.

Stage 2: Choosing an Audio Output Preset
Audio outputs define the number of hardware outputs you want to use with the tracks
in your sequence. Up to 24 audio outputs can be assigned, and each pair of outputs can
be grouped together as a stereo pair or as two independent mono channels.
Audio outputs also affect audio channel groupings when you export audio using certain
commands. For more information, see “Audio Output Export Settings.”
An audio output preset contains saved audio output bus groupings. Final Cut Pro includes
two audio output presets:
• Stereo Monitoring L+R: This is the default audio output preset. This corresponds to your
computer’s built-in headphone jack or stereo speaker output. However, you can also
use it with an external audio interface.
• 5.1 Monitoring L+R, C, LFE, Ls+Rs: This preset is used for monitoring completed
5.1-channel surround sound mixes you receive from applications such as Soundtrack Pro.
For more information, see “Matching Audio Outputs to Clip Items in the Timeline.”
If you change your audio equipment setup, you can modify your sequence’s existing
audio outputs or create a new audio output preset and assign it to your sequence.
You can choose or modify your sequence’s audio output settings in the Audio Outputs
tab of the Sequence Settings window.
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To choose an audio output preset for your sequence
1 Select a sequence in the Browser or Timeline.
2 Choose Sequence > Settings (or press Command-0), then click the Audio Outputs tab.
3 Choose an audio output preset from the Load Audio Output Preset pop-up menu, then
click OK.
To modify the audio output settings of your sequence
1 Select a sequence in the Browser or Timeline.
2 Choose Sequence > Settings (or press Command-0), then click the Audio Outputs tab.
3 Choose the number of audio channels you want to access on your audio interface from
the Outputs pop-up menu.
4 For each pair of audio channels, select Stereo to allow for panning clip items between
the pair of channels, or select Dual Mono so that each channel can be used as an individual
output.
5 Choose a downmix level for each mono output channel and stereo group.
For more information about downmix levels, see “Downmixing Multiple Audio Channels
to a Stereo Mix.”
6 Click OK.

Creating and Saving Audio Output Presets
If you need a specific audio output configuration for monitoring or output to a
multichannel deck, you can save a custom audio output preset and assign it to your
sequence.
To create a new audio output preset
1 Choose Final Cut Pro > User Preferences, then click the Audio Outputs tab.
2 Choose a preset from the Presets list, then click Edit or Duplicate.
3 In the Audio Outputs Preset Editor, enter a name and description for the preset.
4 Choose the number of audio channels you want to access on your audio interface.
5 For each pair of audio channels, choose Stereo to allow for panning clips between the
pair of channels, or choose Dual Mono so that each channel can be used as an individual
output.
6 Choose a downmix level for each mono output channel and stereo group.
For more information about downmix levels, see “Downmixing Multiple Audio Channels
to a Stereo Mix.”
7 Click OK, then click OK again.
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Assigning a Default Audio Output Preset for New Sequences
If you use a particular audio output preset regularly, you can make it the default audio
output preset for all new sequences by choosing it in the Audio Outputs tab of the User
Preferences window.
To change the default audio output preset assigned to all new sequences
1 Choose Final Cut Pro > User Preferences, then click the Audio Outputs tab.
2 Select an Audio Output preset from the Presets list by clicking in the column next to the
preset’s name.
3 Click OK.
The selected audio output preset is automatically assigned to all new sequences you
create.

Assigning Tracks in the Timeline to Audio Outputs
You can assign each track in your sequence to an audio output. Tracks can be assigned
to audio outputs in the Timeline or the Audio Mixer. For more information about assigning
audio outputs in the Audio Mixer, see “Track Visibility Area.”
To assign a sequence track to an audio output in the Timeline
1 In the Timeline, identify a track you want to assign to an audio output.
2 Control-click the Lock Track, Auto Select, or Track Visibility control; choose Audio Outputs
from the shortcut menu; then choose an output bus from the submenu.
Choose an audio output
bus from the submenu.

The track is now assigned to the audio output bus you chose.

Matching Audio Outputs to Clip Items in the Timeline
You can use the Match Audio Outputs command to automatically configure your audio
outputs to match the configuration of audio clip items in the Timeline. Using the Match
Audio Outputs command is more efficient than manually configuring outputs for mono
and stereo clip items in your sequence. For example, if you edit a six-channel audio clip
representing a 5.1-channel surround sound mix into your sequence, you can select it and
tell Final Cut Pro to assign the proper audio outputs for monitoring.
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How Audio Outputs Are Assigned Automatically
Final Cut Pro automatically configures audio output busses according to the selected
linked clip items in your sequence. This feature is often used with 5.1-channel surround
sound clips, but keep in mind that Final Cut Pro supports only the following 5.1-channel
surround sound format:
• Tracks 1 and 2: Left and right
• Track 3: Center
• Track 4: Low-frequency effects (LFE)
• Tracks 5 and 6: Left surround and right surround
Based on the clip items above, the Match Audio Outputs command would create the
following audio output bus groups: stereo 1 and 2 (left and right), mono 3 (center), mono
4 (LFE), and stereo 5 and 6 (left surround and right surround).
Here is how the sequence tracks would be assigned to the audio outputs:
• Tracks 1 and 2 (left and right): Stereo output 1 and 2
• Track 3 (center): Mono output 3
• Track 4 (LFE): Mono output 4
• Tracks 5 and 6 (left surround and right surround): Stereo output 5 and 6

Using the Match Audio Outputs Command
The Match Audio Outputs command automatically configures your audio outputs to
match the stereo and mono groupings of the selected audio clip in your sequence.
Note: In this case, the term audio clip refers to an audio clip item and all other audio clip
items linked to it.
To assign matching audio outputs to the selected audio clip in the Timeline
1 Select a single audio clip with linked audio clip items in the Timeline.
2 Choose Sequence > Match Audio Outputs, or press Option–Semicolon (;).
If the current audio outputs for the sequence do not match the configuration of the
selected audio items, Final Cut Pro warns you that your sequence outputs will be changed
to match.
Note: Final Cut Pro only supports even numbers of audio outputs. If the selected audio
clip spans an odd number of tracks (3, 5, 7, and so on), the Match Audio Outputs command
creates the next highest even number. For example, if the selected clip spans seven tracks,
eight audio outputs are created.
Your sequence audio outputs are reassigned so that the selected audio clip’s stereo items
are assigned to individual stereo output busses and the clip’s mono items are assigned
to individual mono output busses.
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Final Cut Pro also warns you if the new audio outputs exceed the number of available
hardware outputs on your computer or audio interface. You can disable this warning by
selecting the “Do not warn again” option in the warning dialog.
To verify your sequence’s new audio outputs, choose Sequence > Settings, then click the
Audio Outputs tab to see your settings.

Assigning More Audio Outputs Than Your Hardware Supports
You can assign more outputs than your current audio hardware supports, allowing you
to open sequences with multichannel output settings on computers that don’t have
professional audio interfaces connected.
If you select an audio output that exceeds the number of output channels of your audio
interface, Final Cut Pro warns you that you will not hear tracks assigned to unavailable
outputs. However, you are still allowed to use this preset. You may want to choose or
create such a preset when:
• You want to keep your project compatible with another editing system that does
support all of the audio channels in the preset. For example, you might normally work
on a system with eight audio output channels but need to edit part of your project on
a portable computer that only has a built-in stereo output.
• You want to export multiple individual AIFF files for use in another application. For
example, you can export up to 24 individual audio files from your sequence by choosing
an audio output preset with 24 output channels.

Audio Output Export Settings
When you use the Export Audio to AIFF(s) command or the Export QuickTime Movie
command, two settings affect the number and grouping of exported audio channels:
• The number of audio output busses specified in the Audio Outputs tab of the Sequence
Settings window
• The option chosen in the Config pop-up menu in the Save dialog (Export Audio to
AIFF(s) command) or the Audio Outputs tab of the Sequence Settings window (Export
QuickTime movie command)

Audio Outputs Tab of the Sequence Settings Window
The number of output busses specified in the Audio Outputs tab determines how many
QuickTime audio tracks or AIFF files are exported. However, the Config pop-up menu can
modify whether all output busses are exported individually or as a stereo mix.
Each mono output bus in your sequence is exported as an individual mono QuickTime
track or mono AIFF file. Each stereo output bus is exported as a single stereo QuickTime
track or stereo AIFF file.
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Config Pop-Up Menu
Both the Export Audio to AIFF(s) command and the Export QuickTime Movie command
use a Config pop-up menu to determine whether sequence audio output busses should
be exported individually or as a stereo downmix. However, each command has a different
Config pop-up menu in different locations:
• File > Export > QuickTime Movie: The Config pop-up menu is in the Audio Settings area
of the General tab of the Sequence Settings window. There are three options:
• Stereo Downmix: This option exports a stereo mix to a single stereo QuickTime audio
track and overrides the Downmix button in the Audio Mixer. For more information,
see “Downmixing Multiple Audio Channels to a Stereo Mix.”
• Channel Grouped: Based on your sequence’s audio output groupings, multiple stereo
and mono output busses are exported to corresponding stereo and mono QuickTime
tracks. For more information, see “Assigning Tracks in the Timeline to Audio Outputs.”
• Discrete Channels: This option exports channels in the same way as the Channel
Grouped option, but each channel in the QuickTime movie audio track is labeled as
a discrete channel, numbered according to the audio output bus that the channel
is assigned in your sequence. Use this option when you want to preserve your
sequence’s original audio output assignments in your exported QuickTime file. Note
that if you reimport a discrete-channel QuickTime file into Final Cut Pro, the resulting
clip appears to have all mono channels.
• File > Export > Audio to AIFF(s): The Config pop-up menu appears in the Save dialog
after you choose this command. There are two options:
• Stereo Downmix: This option exports a stereo mix to a single stereo AIFF audio file.
For more information, see the next section,“Downmixing Multiple Audio Channels
to a Stereo Mix.”
• Channel Grouped: Based on your sequence’s audio output groupings, multiple stereo
and mono output busses are exported to corresponding stereo and mono AIFF files.
For more information, see “Defining Output Busses by Grouping.”
For more information about exporting QuickTime movies, see “Exporting QuickTime
Movies.” For more information about exporting AIFF files, see “Exporting Audio Output
Groups to AIFF Files.”

Downmixing Multiple Audio Channels to a Stereo Mix
Even when you use multiple audio channels during editing and mixing, you may need
to create a stereo mix. Downmixing combines all audio output channels into a single
stereo output. You may want to downmix when:
• Playing back a sequence with multiple output channels on a system with only two
speakers
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• Exporting to multiple audio channels. For more information, see “Exporting Audio
Output Groups to AIFF Files” and “Exporting Multichannel QuickTime Files.”

How Downmixing to Stereo Works
When a sequence is downmixed, all output busses are mixed together in a downmix
stereo bus and then sent to outputs 1 and 2 on your audio interface. Stereo output busses
are sent to the downmix bus in stereo; mono output busses are centered in the downmix
bus.
Timeline tracks
Tracks 1 and 2
(stereo)
Tracks 3 and 4
(centered)
Tracks 5 and 6
(stereo)

1

Audio clip

2

Audio clip

3

Audio clip

4

Audio clip

5

Audio clip

6

Audio clip

Three bus groups
downmixed to
two channels

Busses

2

1

Hardware
outputs

Adjusting a Channel’s Downmix Volume
Each audio output bus has an adjustable downmix level that is applied only when you
downmix your audio. Each audio output bus’s level is attenuated (or increased) by the
number of decibels specified in the Downmix pop-up menu for the bus, in the Audio
Outputs tab of the Sequence Settings window for the current sequence.

You should use the default settings unless your stereo downmix has distortion or is too
quiet. If your downmix level exceeds 0 dBFS, you may need to attenuate the downmix
level of some of your output busses. If your downmix is too low, you can boost downmix
levels to increase output level. Typically, the more channels you are downmixing, the
more reduction is necessary for each channel to make sure the downmixed stereo signal
doesn’t exceed 0 dBFS, which would cause distortion.
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One of the main purposes of downmix level adjustments is to maintain mono channel
levels when downmixing common 5.1-channel surround sound, for which there are
industry-standard settings. After using the Match Audio Outputs command on a recognized
5.1-channel surround sound clip, industry-standard level adjustments are applied to the
audio outputs’ downmix levels. You can verify these settings in the Audio Outputs tab
of the Sequence Settings window.

Downmixing for Stereo Monitoring
Stereo downmixing allows you to listen to your sequence in stereo—even if the sequence
has multiple output channels assigned—without changing your audio output preset.

µ

To listen to a sequence with multiple output channels in stereo
Select the Downmix button in the Audio Mixer.
With Downmix selected, all audio outputs in your sequence are output as stereo whenever
they’re played back, output to tape, or written to a movie file.

Downmix button
selected

All output channels are
downmixed to a single
stereo pair.
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You can turn Downmix off at any time and your audio will be output to multiple channels
again. This is much more convenient than reassigning all of your tracks to a single stereo
channel and then reassigning your tracks to multiple outputs again.

Downmix button
deselected

All channels are output
independently.

Downmixing During Export
You can select the Downmix button to quickly export multiple audio outputs to a stereo
mix without changing your audio output presets. For more information, see “Audio Output
Export Settings.”

Configuring External Audio Monitors
The following section describes how to connect external audio speakers to your editing
system and how to make audio level adjustments in Final Cut Pro and Mac OS X.

Connecting Speakers to Your Editing System
When you add audio speakers to your editing system, you need to make sure that the
speakers are properly connected to your audio interface or built-in computer audio output
and that the interface is properly configured in Final Cut Pro.

µ

To connect self-powered speakers to your computer
Connect the main left audio output of your audio interface to the left speaker, and connect
the main right audio output of your audio interface to the right speaker.
For more information about types of audio connectors and adapters, see “Connecting
Professional Video and Audio Equipment.”
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Monitoring 5.1-Channel Surround Sound
Final Cut Pro does not support multichannel surround sound mixing capabilities or editing
of speaker assignments, but you can configure your system to monitor certain kinds of
5.1-channel surround sound audio files. If you have 5.1-channel surround sound files that
have been mixed in another audio application such as Soundtrack Pro, you can import
these files and then configure your audio outputs and hardware to monitor in surround
sound.
Important: A multichannel audio interface and speaker system with at least six channels
is required to monitor surround sound.
Timeline tracks
Tracks 1 and 2 routed
to stereo bus
Tracks 3 and 4 routed
to dual mono busses
Tracks 5 and 6 routed
to stereo bus

1

Audio clip

2

Audio clip

3

Audio clip

4

Audio clip

5

Audio clip

6

Audio clip
Stereo

Busses

6 5 4

3 2 1

Stereo

Dual mono

There are two ways of configuring your sequence audio outputs for 5.1-channel surround
sound monitoring:
• Use the 5.1 Monitoring audio preset: If you know in advance that you are going to edit
a 5.1-channel surround sound file into your sequence, you can assign the 5.1 Monitoring
audio preset to your sequence.
• Use the Match Audio Outputs command: This command automatically configures your
sequence audio outputs and track output assignments based on the currently selected
audio clip in your sequence. You can select a 5.1-channel surround sound clip in your
sequence and use the Match Audio Outputs command to automatically configure your
sequence outputs.
To configure Final Cut Pro for 5.1-channel surround sound monitoring using the Match
Audio Outputs command
1 Import a multichannel surround sound QuickTime audio file into Final Cut Pro.
Note: Final Cut Pro supports only surround sound audio files that contain the MPEG_5_1_A
QuickTime audio track tag and whose channels are ordered in the following sequence:
left and right, center, LFE, and left surround and right surround.
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2 Edit the multichannel clip into the Timeline.
In most cases, you should place the audio clip starting on track A1 in the sequence.
3 A clip with six linked clip items appears in the Timeline.
4 Choose Edit > Linked Selection, and make sure that a checkmark appears next to the
Linked Selection menu item.
5 Select the clip in the Timeline.
6 Choose Sequence > Match Audio Outputs.
7 If Final Cut Pro alerts you that your sequence’s audio outputs will change, click OK.
Final Cut Pro alerts you that your sequence’s audio outputs have changed to match the
stereo and mono groupings of the selected clip items.
8 Verify the audio output assignment of each track by Control-clicking the Lock Track control
or Auto Select control of each track and checking the audio output assignment in the
Audio Outputs submenu of the shortcut menu.
For more information, see “Assigning Tracks in the Timeline to Audio Outputs.”
9 Connect your 5.1-channel surround sound speaker system to the appropriate channels
of your audio interface.

Setting Monitoring Levels and Muting System Sound Effects
When you mix your audio, it’s important to monitor using a consistent volume setting.
If a sound is too loud in the mix, you should adjust the level of the audio in Final Cut Pro,
not the volume setting on the speakers themselves. Once you set up your audio
monitoring levels, you should not need to adjust the overall volume setting of your audio
very often.
If all of your audio is consistently too quiet or too loud, you should probably change the
overall volume setting for your speakers and then keep it at this new level. There are a
few different places to adjust the volume, including the volume knob on the speakers
themselves.
If you are using the built-in audio output of your computer, you can adjust its volume in
the Sound pane of Mac OS X System Preferences, by using the volume control keys on
the keyboard, or by using the built-in volume slider in the menu bar.
To adjust the built-in volume of your computer using the volume slider in the menu
bar
1 Open System Preferences by choosing Apple menu > System Preferences, then click
Sound.
2 In the Sound pane of System Preferences, make sure the “Show volume in menu bar”
checkbox is selected.
When the checkbox is selected, a volume icon appears in the menu bar.
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3 Adjust the volume in the menu bar.
You can also adjust the volume in the Sound pane of System Preferences.
To mute all alert and Mac OS X user interface sound effects
1 Choose Apple menu > System Preferences, then click Sound.
2 Click the Sound Effects button.
3 Deselect the “Play user interface sound effects” checkbox.
4 Deselect the “Play feedback when volume is changed” checkbox.
5 Slide the “Alert volume” slider all the way to the left.
If you are using an audio interface other than the built-in audio, you can route the alert
sound effects to the built-in speakers, but monitor Final Cut Pro audio from your audio
interface.
To route Mac OS X alert sounds and sound effects through your computer’s built-in
speakers
1 Choose Apple menu > System Preferences, then click Sound.
2 Click the Sound Effects button.
3 Choose “Built-in Audio: Internal speakers” from the “Play alerts and sound effects through”
pop-up menu.
While monitoring the audio of your program, avoid changing the volume setting of your
speakers unless it is absolutely necessary. A consistent monitoring level allows you to get
used to the average loudness you’re establishing for your mix, so that you can better
judge how well the louder and softer sections of your mix are working together.
To adjust the volume setting of your speakers, try playing a signal that represents the
average volume you want to monitor. Avoid setting speaker volume so high that it fatigues
your ears or distorts in the speakers.
Some people use the 1 kHz tone of the Bars and Tone generator to set the volume of
their speakers. However, you may find that the 1 kHz tone causes you to lower your
speaker volume more than you would for normal audio because the tone is so incessant
and your ears are particularly sensitive to this frequency. Generally, 1 kHz tones are useful
for setting levels from device to device when looking at meters, but not as helpful for
setting average listening levels.
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Tips for Choosing Speakers and an Amplifier
Professional audio engineers have to be able to trust the sound coming from their
speakers. When you mix your audio, you need audio monitors that can handle the full
range of audio intensities and frequencies. Ideally, your monitors will have a flat frequency
response from 20 Hz to 20,000 Hz (or 20 kHz). This means that they neither attenuate nor
amplify any frequencies. Flat frequency response is important for critical listening because
the speakers themselves are not “coloring” the sound.
In addition to the speaker quality itself, additional factors affect your audio monitoring
environment:
• Size and materials of the room
• Placement of the speakers within the room, such as distance from walls and angle of
speakers
• Listener position between speakers
Frequency Response and Dynamic Range
The quality of speakers varies greatly depending on their purpose as well as their price.
For example, speakers in a portable stereo or television are designed to play audio that
has already been mastered by a mixing engineer. Mastered audio such as audio CD, radio,
television, and movie sound has a compressed dynamic range (meaning levels are fairly
consistent and loud).
Speakers and amplifiers that are designed for mastered audio often intentionally emphasize
certain frequencies, as is done with the bass enhancement feature found on many systems.
This may make an audio CD sound better, but it is not recommended for mixing production
sound because you get a false impression of the audio signal. For example, if your speakers
overemphasize frequencies around 2 kHz, you may compensate during mixing by reducing
the intensity of audio around 2 kHz. If you then play your mix on a different set of speakers
with a flat frequency response, the frequencies around 2 kHz will sound too muffled.
+ dB

– dB

+ dB

20 Hz

200 Hz

1 kHz

5 kHz 20 kHz

– dB

20 Hz

200 Hz

Flat
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1 kHz
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Self-Powered Versus Passive Speakers
Speakers powered by an external amplifier are called passive speakers. When you use
separate amplifiers and passive speakers, a number of factors affect the overall frequency
response and quality of your audio. Instead of using a separate amplifier and speakers, a
simpler option is to use self-powered speakers (speakers with built-in amplifiers). These
have become increasingly popular, especially for studio monitoring and video editing.
Self-powered speakers deliver more consistent performance because both components
are designed to work together and are housed in a single enclosure. For video editing
systems, self-powered speakers are a good, easy-to-use solution. Self-powered speakers
accept line level inputs, so it’s fairly easy to connect them to your audio interface.
Amplifiers and Signal Levels for Unpowered Speakers
Unpowered speakers require signals with higher voltage than consumer and professional
equipment can provide directly. These levels are known as speaker level audio signals,
while audio devices such as tape recorders and audio mixers usually provide line level
signals. An audio amplifier boosts line level signals to speaker levels to properly drive
speakers. Wide-gauge speaker cables that can handle the higher electrical strength of
speaker levels are used to connect the amplifier to speakers. For more information about
audio signal levels, see “Connecting Professional Video and Audio Equipment.”

Setting Up a Proper Audio Monitoring Environment
Room shape and material are just as important as the quality of the speakers themselves.
Every surface in a room potentially reflects sound, and these reflections mix together
with the sound originating from the speakers. Rooms with parallel walls can create standing
waves, which are mostly low-frequency sound waves that reinforce and cancel each other
as they bounce back and forth.
Standing waves cause some frequencies to be emphasized or attenuated more than
others, depending on your listening position. When you mix in a room that creates
standing waves, you may adjust certain frequencies more than necessary. However, you
may not notice until you play back your audio in a different listening environment, in
which those frequencies may sound overbearing or nonexistent.
Tip: A much cheaper alternative to building new walls is to mount “bass traps” to the
existing walls. Bass traps help to eliminate parallel surfaces in the room and absorb
low-frequency energy.
If the material in a room is very reflective, the room sounds “brighter” because high
frequencies are easily reflected. Mounting absorbing material (such as acoustic foam) on
the walls can reduce the brightness of a room. A “dead room” is one that has very little
reflection (or reverberation ). Try to cover any reflective surfaces in your monitoring
environment.
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Speaker Placement and Listening Position
Most video editing suites use near-field monitors, which are speakers designed to be
listened to at fairly close range. Speakers should be at least a foot or two away from any
walls to prevent early reflections of sound, which combine with and muddy the original
sound.
Position the speakers as far from your listening position as they are from each other
(forming an equilateral triangle). For example, if the distance between the speakers is
6 feet, you should place yourself 6 feet from each speaker. The apparent width of the
sound stage, or stereo image, increases as the distance between the speakers increases.
However, if the two speakers get too far apart, sound information appearing in the center
(between both speakers) starts to disappear.
Using Headphones
Many people use headphones as an alternative to monitoring speakers. Headphones
provide isolation from ambient noise in the room where you are mixing, adding additional
clarity that may not be obvious in your speakers a few feet from your ears. This clarity
can be helpful for cleaning up low-level noise and pops created by misaligned edits.
However, don’t rely solely on headphones when you mix because level and pan
adjustments you make may be too subtle or delicate for the average viewer listening to
your movie on speakers a few feet away. Headphones often have a different frequency
response than full-range speakers, so if you mix using headphones your audio may sound
bass-heavy when played back on speakers.
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Evaluating Levels with Audio
Meters

54

This chapter covers the following:
• About Audio Meters (p. 865)
• Setting Proper Audio Levels (p. 870)
You use audio meters to keep levels consistent throughout your movie and to make sure
audio signals never get so high that they distort.

About Audio Meters
Audio meters display the level of your audio signal in an objective way, helping you to
set consistent levels throughout your program and ensuring that you have sufficient
headroom and dynamic range.

Average and Peak Audio Levels
Before you begin to adjust audio levels, take a closer look at an audio waveform to better
understand how it corresponds to what you hear during playback.
Peaks
Average loudness
of track

Waveform from an excerpt of electronic music

The most important distinction is the difference between an audio clip’s peaks and its
average loudness:
• Peaks: These are short, loud bursts of sound. In spoken dialogue, letters like P,T, and K
at the beginning of words can result in peaks if the person speaking is close to the
microphone. In music, peaks occur at the very beginning of sounds from percussive
instruments such as drums.
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• Average loudness: The average loudness of a clip generally determines its overall
perceived volume, and this is probably somewhat lower than the level of the peaks. In
the sample waveform, the level of average loudness appears as the densest, darkest
part around the middle. Average loudness, rather than the brief peaks, tends to influence
your decision about mixing a sound higher or lower.

Analog Versus Digital Meters
The way you set your levels with a digital meter is different from the way you set levels
on an analog meter. Compare a traditional analog audio meter with a digital audio meter:
Generic
VU meter
+7
+4
+2

Digital
audio meter
0
−6

0

−12

−2
−4

−18
−24

−7

−36

−10

−48

−20

−66

−30
dB

dBFS

A digital meter displays the sample values of a digital audio signal. The scale on the meter
is known as digital full scale, and the signal is measured in dBFS. On this scale, 0 dBFS
represents the highest possible sample value. Any samples above 0 dBFS are clipped,
distorting the original shape of the audio waveform. Once a signal is clipped, the original
shape of the waveform cannot be recovered.
0 dBFS

0 dBFS

0 dBFS

Original

Too much gain
causes clipping.

Clipping remains
after gain is reduced.

Important: Final Cut Pro can handle digital audio levels above 0 dBFS by internally using
32-bit floating-point resolution for all audio processing. However, when you export or
output to tape, the bit depth of your audio is usually reduced to 16 or 24 bits, so you still
need to be aware of the 0 dBFS limit.
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Analog 0 dB Versus Digital 0 dBFS
Even though audio is exclusively digital in Final Cut Pro, it is likely that your audio will
exist in an analog context at some point. Most digital workflows begin with microphones
and end with speakers, which are both analog devices.
On an analog meter, 0 dB is the optimal recording or output level of a device. If the voltage
is much higher, the signal may distort. If the voltage is much lower, the signal may be
lost in the noise inherent in the device. On a digital meter, 0 dBFS refers to the highest
audio level allowed before clipping.
When you look at the meters in Final Cut Pro, you need to consider how the signal level
will correspond to an analog meter. Specifically, you need to choose a point on the digital
meter that corresponds to 0 dB on an analog meter. This point is where your average
signal level should be, providing headroom for occasional peaks. Headroom is particularly
important in digital audio because any audio that goes beyond 0 dBFS during export or
output instantly clips and sounds distorted.
The level you choose for your average audio level affects the potential dynamic range of
your mix. The lower your average signal is allowed to be, the greater the difference
between the average and loudest sounds, providing a larger dynamic range. However,
you should also choose an average level that allows a significant difference between your
quietest sounds and the noise floor.
There are several common digital levels used to correspond to 0 dB on an analog meter:
• -12 dBFS: This level is often used for 16-bit audio such as DV audio, and for projects
with compressed dynamic ranges, such as those for television or radio.
• -18 or -20 dBFS: This level is more common on projects with higher dynamic range,
such as professional post-production workflows using 20- or 24-bit audio.
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About Audio Meters in Final Cut Pro
Final Cut Pro uses peak audio meters, which respond very quickly to the audio signal,
alerting you to potential peaks over 0 dBFS. The meters in Final Cut Pro display a peak
level indicator, which is a yellow line that shows recent peak levels for up to 3 seconds
(assuming a higher peak hasn’t been reached).

Yellow peak level
indicator

The peak level indicator can help you get a sense of the dynamic range of your mix
because you can compare the current levels to recent peaks. For more information about
peak meters, see “Average and Peak Audio Levels.”
There are several audio meters in Final Cut Pro:
• Input audio meters in the Clip Settings tab of the Log and Capture window. (See
“Overview of Capturing Tape-Based Media.”)
• Track meters in the Audio Mixer. (See “Track Strips Area.”)
• Master audio meters in the Audio Mixer. (See “Master Area.”)
• Floating audio meter window. (See “Floating Audio Meters.”)
Clipping Indicators
The Master audio meters and the floating audio meters have a clipping indicator that
lights up when the output signal reaches 0 dBFS. Once the clipping indicator is lit, it stays
on during playback to let you know that part of your signal clipped. The clipping indicator
also stays on after you stop playback, but it is turned off each time you start playback.
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To turn off clipping indicators during playback
Click the clipping indicators in the Master audio meters or floating audio meters.
Red clipping
indicator

Floating Audio Meters
The floating audio meters display the output levels of the Viewer or Timeline with a
simplified stereo display. If you’ve set up more than two audio outputs in the Audio
Outputs tab of the Sequence Settings window, the floating audio meters display the
highest levels of any audio outputs in either the right or left channel. The highest level
of any odd-numbered audio channel is displayed in the left meter, and the highest level
of any even-numbered audio channel is displayed in the right meter.
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Unlike the track and Master audio meters, the floating audio meters do not show levels
above 0 dBFS.

0 dBFS
Levels above
0 dBFS

Floating
audio meters

Master
audio meters

Setting Proper Audio Levels
When you work with audio, you need to make sure you set proper levels at each stage
of your production:
• Production: During this phase, you record the elements used in your movie: actors’
voices, ambient location sound, music, and so on. This is the first and most critical step
in any audio production process. Any audio recorded poorly at this phase will be difficult
to fix later in the process. There is no match for properly recorded sound, no matter
how good your audio cleanup tools are.
• Capture: Transferring your production audio to Final Cut Pro should be a transparent
process that affects your audio as little as possible. The audio levels of your source
footage and captured media files should match exactly.
• Audio peak detection: Audio that is too loud causes distortion and often cannot be
salvaged. You can find audio peaks in Final Cut Pro by using the Mark Audio Peaks
command.
• Audio gain and normalization: Before cutting and mixing multiple audio sources together,
you may need to normalize varying audio levels that are intended to match. Audio that
is too quiet should be raised to an acceptable level before mixing and output.
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• Mixing and output: During mixing and final output, you need to ensure that audio levels
are consistent compared to a reference audio level, such as audio tone. Loud parts
should be consistently loud, and quiet parts should be consistently quiet (but not so
quiet that they get lost in the noise). The dynamic range (the change in levels between
quiet and loud) should be large enough to create a varied mix, but not so large that
viewers have to constantly adjust the volume when they watch the finished movie.

Setting Levels for Capture
When you capture digital audio, you usually cannot make level adjustments because an
exact copy of the digital information is transferred to your hard disk. However, if you are
capturing analog audio using a third-party audio interface, make sure you set each input
channel so the meters in the Clip Settings tab of the Log and Capture window match the
audio meters on your video or audio device. For more information, see “Capturing Audio
from Tape.”

Detecting Audio Peaks
When you capture audio, clipping occurs if any part of the audio signal goes over 0 dBFS.
Because 0 dBFS is the maximum digital level possible, all levels that would have been
above 0 dBFS are set (clipped) at 0 dBFS. Because of the nature of digital audio recording,
such clipped audio typically results in a crackly, brittle sound. Excessive peaks indicate
that your audio was recorded at unsuitable levels.
If your program has peaks in the audio, you can either recapture the audio at a better
level or edit the audio appropriately to avoid the peaks. You can use the Mark Audio
Peaks command to identify audio peaks in your clips. It’s then up to you to decide whether
to not use those sections of audio or rerecord them.
Note: Final Cut Pro considers your clips’ audio levels when analyzing levels. For example,
if you set a clip’s audio level to +12 dB, audio peaks may be detected. However, if you
reset the audio level to 0 dB, audio peaks may no longer be detected.
To find and mark audio peaks
1 To detect peaks in a clip, do one of the following:
• Select one or more clips in the Browser.
• Open a sequence clip from the Timeline.
2 Choose Mark > Audio Peaks > Mark.
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A status window appears with a progress bar showing how much of the process is
complete. Markers are placed at each peak.
• If you selected a clip in the Browser: Markers appear for the clip and are labeled “Audio
Peak N,” where N starts at 1 and increases, depending on how many audio peaks are
detected. These markers also appear in the Viewer when the clip is opened there.

Audio peak markers
for a clip selected in
the Browser

• If you selected a clip in the Timeline: Markers appear in both the Timeline and Canvas.

Audio peak markers for
a clip in a sequence in
the Timeline

You can clear audio peak markers that were previously added, if you like.
To clear all audio peak markers in a clip
1 Select one or more clips in the Browser or Timeline.
2 Choose Mark > Audio Peaks > Clear.

Raising Audio Levels Using Audio Normalization and Gain
When you edit, your audio may come from a variety of sources, and the levels often vary.
Final Cut Pro includes a Gain audio filter that allows you to amplify (or attenuate) the level
of an audio clip far beyond the +12 dB gain available with audio level keyframes.
To amplify the audio level of clips whose levels are too low, you can manually apply the
Gain filter. The only risk with manually applying gain adjustments to a clip is that you
may amplify the audio too much, resulting in distorted audio. To guarantee that clips
with low audio levels have the optimal gain, you can normalize your audio clips using
the Apply Normalization Gain command.
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How Normalization Gain Works in Final Cut Pro
Audio normalization works by scanning audio for the peak (loudest) sample level and
then applying a Gain filter that brings the peak level to the level you request. By default
this value is 0 dBFS, the highest level possible before clipping occurs. The Gain filter raises
the overall audio level.
0 dBFS

0 dBFS

0 dBFS

Next, gain is added so the
audio peak is set to 0 dBFS.

The audio is normalized, with
the peak level set at 0 dBFS.

Peak

Peak

First, audio is scanned and
the audio peak is detected.

In most applications, audio normalization is a destructive process because it permanently
modifies audio files. Final Cut Pro applies normalization nondestructively by applying a
Gain filter to a clip instead of affecting the clip’s audio file. You can disable or remove the
Gain filter and hear the original, unmodified audio file.
To apply normalization gain to audio clip items in a sequence
1 Select one or more audio clip items in a sequence.
2 Choose Modify > Audio > Apply Normalization Gain.
The Apply Normalization Gain dialog appears.
3 In the “Normalize to” field, enter the value you want to raise each audio clip’s peak value
to, then click OK.
The dialog displays a progress bar and Final Cut Pro begins calculating the peak value
for each clip. After processing, each selected clip has its own Gain filter applied with a
gain adjustment appropriate for that clip’s normalization.
How Linked Mono and Stereo Clips Are Normalized
The Apply Normalization Gain command works differently depending on the type of clip
items selected:
• Single mono clip item or multiple linked mono clip items: A separate Gain filter is applied
to each clip item, and peaks for each clip item are calculated independently.
• Stereo clip items: A stereo Gain filter is applied to the stereo clip items, and the Gain
setting is based on the peak value across both channels.
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Reapplying Normalization Gain
Final Cut Pro searches for peak audio only between a clip’s In and Out points, not for the
entire duration of the clip’s media file. If you trim a clip’s In or Out point, new peaks may
be introduced and the Gain adjustment may no longer be appropriate. In this case, you
can easily reapply normalization gain to set an appropriate level.
Reapplying normalization gain is no different from applying normalization gain for the
first time. The only difference is that no new Gain filters are added to clips that already
have them. Instead, the values of the existing Gain filters are adjusted based on the current
audio peaks of the clips.
Choosing Normalization Gain Versus Audio Level Keyframing
The Gain filter and the Apply Normalization Gain command are best used for broad audio
level adjustments, such as when you have clips with fairly low audio levels. For subtle
level adjustments and more complex mixing, you should use audio level keyframes in
the Viewer or Timeline.
Troubleshooting Audio Normalization
There are a few issues to be aware of when you use the Gain filter and the Apply
Normalization Gain command:
• Applying gain raises the level of an audio signal, including the noise. Very quiet audio,
when normalized, may be very noisy. When possible, the best solution is to rerecord
the audio. If this is not possible, you may be able to minimize the noise using
Soundtrack Pro.
• Loud peaks in audio clips that otherwise contain low audio levels make audio
normalization more difficult to use. For example, suppose you have a clip containing
dialogue that was recorded too quietly. At the beginning of this clip, there is a brief
peak when the slate was clapped together. When you attempt to normalize the audio
of this clip, the sound of the slate is so loud that very little gain is applied. To apply
more gain, simply trim the clip until the audio peak from the slate is gone, then use
the Apply Normalization Gain command again.

What Reference Level Should You Use for Mixing and Output?
The dynamic range of your mix is dependent on the final viewing environment. For
example, movie theaters have large, relatively expensive sound systems that can reproduce
a large dynamic range. Television speakers are much smaller, and often the listening
environment has more ambient noise, so very quiet sounds may not even be noticeable
unless the overall signal is compressed and the level increased, reducing the dynamic
range.
For example, television stations normally accommodate only 6 dB between the average
loudness and the peaks. Dolby Digital feature film soundtracks, on the other hand, can
accommodate up to 20 dB between average and peak levels. This is why loud sounds in
a movie theater sound so loud: they are much louder than the average level.

874

Chapter 54 Evaluating Levels with Audio Meters

Venue

Acceptable amount of dynamic range

Theatrical Dolby Digital

20 dB

Average videotape

12 dB

Television broadcast

6 dB

When you mix your final audio, you choose a consistent reference for the average level.
When you choose the average reference level, you are actually choosing how much
additional headroom you have before your signal distorts. The higher you set the average
level, the less safety margin you have for peaks in the signal. This means that the loudest
sounds in your mix cannot be much louder than the average levels, so the mix is less
dynamic.
If you set the reference level of the Final Cut Pro floating audio meters to -20 dBFS, you
have nearly 20 dB of headroom because 0 dBFS is the digital limit for the loudest sound.
If you set the reference level in your sequence to -12 dBFS instead, you have less
headroom. Even though the average level of your audio is higher, there won’t be as much
dynamic range.
0
−6
−12
−18
−24
−36
−48
−66

Available headroom with
a reference level of –12 dBFS

How much dynamic range you allow in your audio mix depends on its ultimate destination.
If you’re editing a program for TV broadcast, a reference level of -12 dBFS is fine, because
you are only allowed 6 dB of dynamic range anyway. But if you’re working on a production
to be shown in movie theaters, consider using a reference level closer to -18 or even -20
dBFS (both of these are frequently used standards).
Remember that the ultimate goal is to ensure that audio doesn’t peak over 0 dBFS in
your mix (as displayed in the Final Cut Pro audio meters) and won’t peak over +3 dB or
so on an analog meter.
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Outputting Bars and Tone at the Head of Your Tape
When you output your program to a tape for duplication or delivery to a broadcast facility,
you’ll typically include a 1 kHz reference tone at the beginning of the tape. The level of
this tone is supposed to indicate what the average level of your audio mix is. For this
tone to be meaningful, you must mix your audio so that the average level of your mix
matches the level of the tone. Here’s why:
• If you are duplicating the tape: Most tape duplication facilities use the reference tone
at the beginning of the tape to set the audio recording levels when copying your master
tape. If your average mix levels are too quiet or too loud relative to this tone, the audio
on the copies will be either too low or distorted, respectively.
• If you’re delivering your program for broadcast: Most broadcast facilities have very
stringent requirements about what they’ll air. If your program’s audio levels are too
hot (loud) or too soft, you might run into trouble with the broadcast engineer. In the
worst cases, they’ll return your tape to you as unsuitable for broadcast and require you
to send them a new one with proper levels.

Labeling Your Tapes
If you’re outputting to a digital format, make sure you note what level your 1 kHz tone
is set to on the label of your tape. If you’re outputting to an analog format, like Betacam
SP, you’ll always set your 1 kHz tone to 0 dB.
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This chapter covers the following:
• About the Audio Mixer (p. 877)
• Controls in the Audio Mixer (p. 877)
• Using Audio Mixer Views (p. 885)
You can use the Audio Mixer to monitor audio levels for all of your sequence clips, as well
as adjust audio levels and pan settings in real time.

About the Audio Mixer
The Audio Mixer provides faders, panning sliders, and solo and mute buttons for each
track in your sequence. There are also Master meters for each audio output channel in
your sequence (determined by the audio output preset of the sequence).
As you make audio level and pan adjustments in real time, you can record these
adjustments as keyframes, allowing you to automate your mix when you play the sequence
back. You can also use a hardware control surface to control and automate multiple faders
at once. For more information, see “Using a Control Surface with the Audio Mixer.”
After you record audio level and pan keyframes, you can fine-tune them in the Timeline
or the Viewer using the Pen tool to adjust the clip overlays. For more information, see
“Changing Audio Levels in the Viewer,” “Adjusting Audio Levels in the Timeline,” and
“Panning Audio in the Timeline.”

Controls in the Audio Mixer
The controls in the Audio Mixer are comparable to those of an automated hardware
mixing console. Each audio track in the currently selected sequence (or audio track in the
Viewer) is represented by a track strip, complete with solo and mute buttons, a stereo
panning slider, a level fader, and an audio meter.
The Audio Mixer tab appears in the Tool Bench window and is divided into three areas:
• Track Visibility area
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• Track Strips area
• Master area
Additional Audio Mixer controls appear above these three main areas:
• Record Audio Keyframes button
• View buttons
• Source pop-up menu
View buttons

Record Audio
Keyframes button

Source pop-up menu

Track Visibility area

µ

Track Strips area

Master area

To open the Audio Mixer
Choose Tools > Audio Mixer (or press Option-6).

Track Visibility Area
In this area, you can choose which track strips are shown in the Audio Mixer.

µ

To show the Track Visibility area
Click the disclosure triangle in the upper-left corner of the Audio Mixer.

You can show and
hide the Track Visibility
area by clicking the
disclosure triangle.

Track Visibility controls
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The Track Visibility area includes the following controls:
• Track Visibility control: Click the Track Visibility control for a track to show or hide that
track’s track strip in the Audio Mixer. This doesn’t turn on or turn off the corresponding
audio track in your edited sequence, nor does it mute the audio played back from that
track.
• Track name: Corresponds to the audio track name listed in the currently selected
sequence in the Timeline. This name also appears at the top of the track strip for each
track.
• Output Channel shortcut menu: Control-click a track name in the Track Visibility area to
assign that audio track to one of the available audio interface output channels. These
audio output channels correspond to the external audio interface selected in the A/V
Devices tab of the Audio/Video Settings window.

Output Channel
shortcut menu

For more information on setting up the audio output channels of a sequence, see
“Assigning Output Channels and External Audio Monitors.”
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Track Strips Area
In a typical audio mixer, each channel has a corresponding channel strip with level and
pan controls. In the Final Cut Pro Audio Mixer, each track in your sequence has a
corresponding track strip with mute, solo, pan, and audio level controls. If a track’s Track
Visibility control is deselected in the Track Visibility area, its track strip does not appear
here. If an audio track is disabled in the Timeline, that track’s track strip controls are
dimmed.
Mute
button

Solo
button
Track name
Panning slider
Track audio level meter
Fader

Tip: The height of the Tool Bench window affects the displayed resolution of the faders
in the Audio Mixer. For example, if you compare the length of faders in taller and shorter
Tool Bench windows, an identical movement results in a greater level change with the
shorter fader, and a smaller level change with the longer fader. This means that you can
achieve more subtle control of a clip’s levels, if necessary, by making the Tool Bench
window taller.
The Track Strips area includes the following controls:
• Track name: Corresponds to the audio track in the current sequence (or in the Viewer).
• Mute button: Click to turn off audio playback for that track. The same mute button is
available in the Timeline. Use the mute button to quickly mute or unmute a track while
your sequence plays. For example, if you want to briefly compare what your audio mix
sounds like with and without the track, you can use the mute button while the sequence
plays.
Muting a track does not delete pan or audio level keyframes, nor does it prevent fader
automation. Muting tracks only affects playback; muted tracks are still output during
Print to Video and Edit to Tape operations, and during export to audio or movie files.
Note: To prevent a track from being output or exported, you need to disable the track
in the Timeline. For more information, see “Working with Tracks in the Timeline.”
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• Solo button: Click to mute all tracks that don’t have solo turned on. Use the solo button
to listen to a track isolated from the others. For example, if you click the solo button
on track A1, all other audio tracks are muted. If you turn on solo on A1 and A2, both
A1 and A2 play back, and all other tracks are muted.
Tip: Option-clicking a track’s solo button soloes all of the tracks. Option-clicking a solo
button that is already selected deselects all of the tracks’ solo buttons.
Soloing tracks only affects playback; soloed tracks are still output during Print to Video
and Edit to Tape operations, and during export to audio or movie files.
• Panning slider: Use to change a clip’s stereo pan. The panning slider in the Audio Mixer
works the same way as the Pan sliders in the Viewer’s audio tabs. Changes made to
the panning slider can be recorded as keyframes in the clip currently beneath the
playhead. Upon playback, the panning slider is automated by the keyframes and
animates to display the changing pan values in your program.
When you adjust the pan of a stereo audio clip from the Audio Mixer, the panning
sliders of both tracks on which the stereo pair clip appears are locked together. Any
adjustments made to one panning slider affect the other panning slider inversely.
Below the panning slider is a field that displays the exact pan value assigned to the
audio track. To adjust the panning slider numerically, enter a value in this field.
Note: If a clip is on a track that is assigned to a mono (discrete) output, the panning
slider for that track is disabled.
• Fader: Faders are vertical sliders used to adjust the audio levels of clips at the position
of the playhead. Using the fader, you can adjust the audio level of a clip from +12 dB
to -∞ dB (silence).
If the Record Audio Keyframes button is selected, changes made to a fader are recorded
as keyframes in the current clip or clips beneath the playhead. Upon playback, faders
are automated by keyframes and animate to display the changing levels.
Each fader has tick marks that indicate the current strength of the signal in decibels
(dBFS).
Below each fader is a field that displays the exact audio level setting of the fader. To
adjust the fader numerically, enter a value in this field.
• Track audio level meter: Each track in the Audio Mixer tab corresponds to a track in your
sequence (or in the Viewer) and has an individual meter with a scale from +12 dBFS to
–∞ dBFS (silence). A track audio meter shows the levels of the current audio clip item
in a track. Use these meters to make sure the average level of each clip is consistent
with similar audio material and that peaks are not above 0 dBFS.
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Note: The meters in the Audio Mixer can actually display levels above 0 dBFS because
Final Cut Pro mixes audio internally at 32-bit floating-point resolution—much higher
than the 16- or 24-bit audio in typical media files. The high mixing resolution provides
enormous headroom to prevent clipping when multiple audio tracks are mixed together.
However, you should never output a signal that exceeds 0 dBFS on the Master audio
meters.

Clipping range

Acceptable range

Acceptable range

Master Area
Using the controls in the Master area, you can mute, downmix, and adjust the audio levels
of all audio tracks at once. The controls in the Master area cannot be automated, but the
current state of all controls in the Master area is stored in each clip in your project.

µ

To show or hide the Master area
Click the disclosure triangle in the upper-right corner of the Audio Mixer tab.

Master mute button
Downmix control
Clipping indicators
Master fader
Master audio meters
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The Master area includes the following controls:
• Master mute button: Click this button to mute the entire sequence output. Like the
individual track mute buttons, the Master mute button only affects playback, not output
during Print to Video and Edit to Tape operations, or during export to audio or movie
files.
• Downmix control: When this control is selected, all output channels are mixed down
to a single stereo pair of outputs. This is useful if you need to monitor a multichannel
mix in stereo. With Downmix selected, all audio outputs in your sequence are mixed
down to stereo during playback, output to tape, or export to audio or movie files. For
more information about downmixing, see “Downmixing Multiple Audio Channels to a
Stereo Mix.”
• Master fader: A Master fader controls the level of an output bus or hardware output
after the individual track faders are applied. It has no effect on the audio level overlays
of clips in your sequence. Unlike individual track faders, the Master fader cannot be
automated.
The Master fader affects output levels during playback, output to tape, or export to a
movie file.
• Master audio meters: There is a Master audio meter for each output channel specified
in the current sequence’s Audio Outputs tab (in the Sequence Settings window). For
example, if your sequence has an audio preset that has six output channels, there are
six Master audio meters in the Audio Mixer. Each meter has a scale from +12 dBFS to
-∞ dBFS (silence). Because the Master audio meters show the final level that will be
output to your audio interface, you should make sure that no level goes above 0 dBFS.
Each Master audio meter is fed by all the tracks in the current sequence that are assigned
to a particular output channel. For example, if tracks 1, 3, 5, 7, and 9 are all assigned to
audio output channel 1, Master audio meter 1 displays the combination of all those
tracks’ audio levels mixed together.
Even though 0 dBFS is the highest audio level that you can output from Final Cut Pro,
an additional +12 dB appears at the top of the scale of the Master audio meters. This
“clipping area” allows you to see how far you’re clipping over 0 dBFS, so you know how
much you need to lower the level of your mix to avoid distortion.
Tip: You can also use the track audio meters and Master audio meters for individual
clips in the Viewer. Each clip retains both individual track levels and master levels.
Master levels for a clip can only be adjusted in the Audio Mixer, not in the Viewer itself.
• Clipping indicators: At the top of each meter is a clipping indicator that lights up when
that output channel reaches 0 dBFS. Once the clipping indicator lights up, it remains
lit until playback is stopped and restarted. Since audio clipping usually causes noticeable
digital audio distortion, this indicator lets you know which audio output clipped even
after you have stopped playback. This way, you can go back to the clips on that track
to reduce their levels.
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Note: Unlike hardware audio meters that light up only when an audio signal is playing,
the Final Cut Pro audio meters display and hold the current level whenever the playhead
in the Viewer, Timeline, or Canvas appears over an audio clip, whether playing or paused.

View Buttons
The View buttons allow you to organize the Audio Mixer into different subsets (or “banks”)
of visible track strips. For example, you might choose to create two separate views to mix
your sequence—one for viewing only music tracks and another for viewing dialogue
tracks. This is especially useful when mixing a sequence that has more audio tracks than
will fit in the Audio Mixer tab at once. Each sequence in a project stores four views.

For more information on how to use the View buttons, see “Using Audio Mixer Views.”

Record Audio Keyframes Option
When Record Audio Keyframes is selected, new keyframes are created whenever an audio
control is moved. Audio controls that can be used to create keyframes during playback
include the faders and panning sliders in the Audio Mixer, the Level and Pan sliders in
the audio tabs of the Viewer, and the faders and controls on a connected audio control
surface.

Record Audio
Keyframes button

The Record Audio Keyframes option must be selected to record real-time level and pan
automation during playback. If the Record Audio Keyframes option is not selected, changes
to the level and panning sliders only affect the overall levels of clips that have no
keyframes, or modify whatever keyframes already exist without creating new ones.
To add keyframes whenever you move an audio fader or panning slider
Do one of the following:
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µ

Click the Record Audio Keyframes button in the button bar at the top of the Audio Mixer
(in the Tool Bench window).

µ

Select the Record Audio Keyframes checkbox in the Editing tab of the User Preferences
window.
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Press Command-Shift-K.
The Record Audio Keyframes button and the checkbox in the User Preferences window
are the same control; they are just located in two different places for convenience.
Important: If the Record Audio Keyframes button is missing from the Audio Mixer button
bar, you can drag it to the button bar from the Button List. For more information about
using the Button List, see “Customizing the Interface.”

Source Pop-Up Menu
You use this pop-up menu to choose whether Canvas or Viewer audio levels are controlled
by the Audio Mixer. If you want the Audio Mixer to automatically switch between the
Canvas and Viewer depending on which window is active, choose Auto.

Using Audio Mixer Views
When you work on sequences with many audio tracks, some of the track strips in the
Audio Mixer may appear offscreen. To avoid having to constantly scroll back and forth,
you can hide the track strips of tracks you don’t immediately need to work with.
You can also create different views to organize groups of tracks in your sequence according
to their content. Using the Audio Mixer View buttons, you can save four different sets of
track configurations for each sequence in your project.
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When you first open the Audio Mixer, the default view is View 1, showing all audio tracks
in your sequence. Any tracks you show or hide using the Track Visibility controls while
View 1 is selected are remembered as View 1.
View 1 showing only
the first four audio
track strips

If you click the View 2 button and then show or hide audio track strips, that altered layout
is remembered as View 2.
View 2 showing only
the last three audio
track strips

Clicking the View 1 button restores the state of the Audio Mixer to View 1, the way it was
before you clicked the View 2 button.
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Organizing track strips this way is especially helpful if you organize your audio tracks
according to their content. For example, you could set View 1 to display only the track
strips for audio tracks in your program containing dialogue clips. View 2 could then show
only the track strips for audio tracks containing music clips, View 3 could show track strips
for tracks containing sound effects, and View 4 could show track strips for tracks containing
ambience clips. This way, you can quickly jump back and forth between related groups
of track strips as you refine your audio mix.
Note: New audio tracks added to your sequence after you’ve customized your views are
displayed by default in all four views. To hide them, you must go to each view and hide
new tracks with the corresponding Track Visibility controls.
To show or hide individual audio track strips
1 If necessary, click the disclosure triangle in the upper-left corner of the Audio Mixer to
display the Track Visibility area.
2 Click the Track Visibility control to the left of the track label for the track strip you want
to show or hide.

These tracks are hidden.

To customize and save different Audio Mixer views
1 Click the View button for the view you want to customize.
2 Click the Track Visibility controls for the track strips you want to show or hide.
The settings are remembered whenever you switch back to that view.

µ

To reset all tracks to be visible in a particular Audio Mixer view
Control-click a Track Visibility control, then choose Show All from the shortcut menu.
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Using the Audio Mixer

56

This chapter covers the following:
• Making Basic Audio Adjustments with the Audio Mixer (p. 889)
• Making Stereo Pan Adjustments with the Audio Mixer (p. 896)
• About Mixer Automation and Keyframe Recording (p. 899)
• Using a Control Surface with the Audio Mixer (p. 907)
• Controlling the Audio Mixer with a Control Surface (p. 912)
• Recording Audio Mixer Keyframes Using a Control Surface (p. 914)
You can use the faders and sliders in the Audio Mixer to quickly set audio levels and pan
for clips, or you can record keyframes to create mixer automation over time.

Making Basic Audio Adjustments with the Audio Mixer
In most cases, when editors first start working on a movie, their primary focus is on the
visuals and the content of the accompanying audio. At this early stage, adjustments are
limited to the overall levels of the audio, and not the details of the final mix. The Audio
Mixer’s mute and solo buttons, along with the track faders and panning sliders, let you
quickly manage the audio tracks and clips in your program so that you can make early
decisions about how your audio should fit together while you edit.
Note: Mute and solo buttons are used only for monitoring your audio during playback.
They are ignored during Print to Video or Edit to Tape operations, and during export to
a movie or audio file.

889

When Audio Mixer Controls Aren’t Available
There are several instances when the controls of a given track’s track strip aren’t available.
• If there is no clip on that track at the position of the playhead: The fader on that track’s
track strip is set to indicate that there is complete silence at the gap in the track. It is
not possible to adjust a given track’s fader if there is no clip at the current position of
the playhead.
• If the clip at the position of the playhead is not enabled: The result is the same as if there
were no clip on the track. Because the clip is disabled in the track, the track strip cannot
control it. You can enable or disable a clip by choosing Modify > Clip Enable.
• If that track is locked in the Timeline: The track strip for that track is unavailable, preventing
you from making changes to that track. The fader and panning slider continue to
animate, however, as audio from that track is still being output.
• If the entire track is disabled in the Timeline: The track strip for that track is dimmed,
preventing you from making changes to the track. Fader and pan automation set for
clips in that track remain untouched, however, and are preserved when you reenable
that track.

Using the Mute Button to Silence Audio Tracks
Sometimes, while monitoring your sequence audio, you may want to disable the playback
of certain audio tracks. For example, if you’re editing a section of dialogue and you want
to hear it without music, you can mute the tracks with the music clip without stopping
playback.
Muting a track does not remove audio level or pan keyframes; it simply turns off the audio
output of that track until you turn it back on. Muting a track also doesn’t delete audio
render files associated with clips on that track. A track’s mute status overrides its solo
status, so even if a track is soloed, you won’t hear it if it is muted.
Note: Mute buttons cannot be automated.
To mute one or more tracks
Do one of the following:

µ

In the Audio Mixer, click the mute button in the track strip for the track you want to
silence.
Mute button in the
Audio Mixer
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µ

In the Timeline, click the Audio Controls button to display the mute and solo buttons for
each track, then click the mute button for the audio track you want to silence.

Mute button
in the Timeline

Audio Controls button

µ

To disable mute on all tracks at once
Control-click the mute button of any track’s track strip in the Audio Mixer, then choose
Reset All Mutes from the shortcut menu.

µ

To mute the master output
In the Audio Mixer, click the Master mute button.

µ

To mute all tracks at once
Option-click any selected mute button.

Using the Solo Button to Listen to Individual Tracks
If your sequence contains several audio tracks and you want to listen to a track in isolation,
you can temporarily solo only that track. When you click a track’s solo button to solo a
track, all other tracks are automatically muted. However, if other tracks’ solo buttons are
selected, these tracks still remain soloed. If you select the solo buttons on multiple tracks,
all tracks whose solo buttons are selected play back, and all other audio tracks in your
sequence are muted.
Note: Solo buttons cannot be automated.
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To solo one or more tracks
Do one of the following:

µ

In the Audio Mixer, click the solo button in the track strip for the track you want to solo.
All tracks without solo enabled are silenced.
Solo button in
the Audio Mixer

µ

In the Timeline, click the Audio Controls button to display the mute and solo buttons for
each track, then click the solo button for the audio track you want to solo. All tracks
without solo enabled are silenced.

Solo button
in the Timeline

Audio Controls button

µ
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To disable solo on all tracks at once
Control-click the solo button of any track’s track strip in the Audio Mixer, then choose
Reset All Solos from the shortcut menu.
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Using Faders to Adjust Audio Levels
Final Cut Pro stores audio level information in clips, not in tracks. When you adjust faders
in the Audio Mixer, you affect only the clips currently beneath the playhead. This is the
same as adjusting a clip’s audio level directly in the Timeline or Viewer.

Changes made to faders
in the Audio Mixer...

...affect only the audio
clip items below the
playhead in the Timeline.

If an audio track at the position of the playhead does not contain a clip, the fader
corresponding to that track is automatically set to –∞ dB (total silence), and you are
unable to move the fader slider.
You can change the audio levels of clips in the Timeline while the sequence is playing or
while it is paused. If the Record Audio Keyframes option is turned off, adjusting a fader
level does not add keyframes but instead adjusts the audio level for the clip’s entire
duration. If the clip already has keyframes, the level is adjusted between the previous
and subsequent keyframes.
You can also select the Record Audio Keyframes checkbox in the Editing tab of the User
Preferences window.
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Adjusting Levels in Mono Versus Stereo Clips
Track faders in the Audio Mixer control each audio clip independently unless two clips
are a stereo pair.
• Mono or linked mono clips: Track faders can be adjusted independently. For example,
if you’ve captured a clip that has two actors whose dialogue was recorded
independently, one on the left channel and one on the right channel, you can control
their levels separately.
• Stereo pair clips: The faders of both audio tracks are locked together and move as one.
This is useful for stereo music clips, to ensure that level changes are consistent in both
the left and right audio channels.

To change the overall audio level of a clip using a fader
1 Make sure the clip doesn’t have any audio level keyframes already applied.
2 Make sure that the Record Audio Keyframes button in the button bar at the top of the
Audio Mixer is not selected.
3 In the Timeline, position the playhead so that it’s directly over the clip whose audio level
you want to change.

4 In the Audio Mixer, drag the track’s fader up or down to adjust the level.
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While you move the fader, the audio level field indicates the numeric value of the current
level. When you release the fader, the audio clip’s audio level overlay in the Timeline
changes to reflect the change you’ve made.

Adjust the fader
for the clip.
Audio level field

The audio level overlay
in the Timeline changes
to reflect the change
you’ve made.

To reset a fader to 0 dB
Do one of the following:

µ
µ
µ

Control-click the fader, then choose Reset from the shortcut menu.
Option-click anywhere in the fader.
To reset all faders in the Audio Mixer to 0 dB
Control-click an active track’s fader, then choose Reset All from the shortcut menu.

To change the audio level of a clip numerically
1 Make sure the clip doesn’t have any audio level keyframes already applied.
2 Make sure that the Record Audio Keyframes button in the button bar at the top of the
Audio Mixer is not selected.
3 In the Timeline, position the playhead so that it’s directly over the clip whose audio level
you want to change.
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4 In the Audio Mixer, enter a new value in the audio level field below the fader you want
to modify, then press Return.
Valid values range from +12 dB to –167 dB. Numbers smaller than –167 dB are
automatically changed to –∞ dB, or total silence.
5 Press Return.
The fader moves to reflect the new value.

Adjusting the Master Level of Your Sequence
The Master fader raises or lowers the combined output level of all the tracks in your
sequence at the same time. However, you should wait to use the Master fader until you
have set individual track levels. Once the Master audio meters show acceptable levels
throughout your mix, you can use the Master fader to increase or decrease the overall
level while retaining the same relative mix. This can be helpful in the following cases:
• Your audio mix has a good level for output to a particular video deck but is too strong
for another deck. In this case, you can easily bring down the overall level with the
Master fader.
• If you are using a lot of audio tracks, the overall mix may be too loud even when the
individual track levels are fairly low. If the individual track fader levels are all low, mixing
can be inconvenient. To keep the individual track fader levels higher without making
the overall mix too hot, you can bring down the Master fader level by several dB.
Important: You should not use the Master fader to adjust the volume setting of your
external monitoring speakers. Use the Master fader to make sure your meters show an
acceptable level. Use the volume controls on your external monitors to adjust the loudness
of your audio while you mix.
The Master fader cannot be automated.

Making Stereo Pan Adjustments with the Audio Mixer
You can control the stereo pan of clip items within audio tracks by using the panning
sliders in the Audio Mixer. Like adjustments made using audio faders, adjustments made
using a track’s panning slider affect only the clip that appears at the position of the
playhead, and these adjustments can be automated. For more information on creating
pan automation, see “About Mixer Automation and Keyframe Recording.”
For more information about working with stereo audio in Final Cut Pro, see “Stereo Audio.”

Pan Controls for Stereo and Dual Mono Audio
The way clip items are linked together and the kind of output bus assigned to a track
affects how pan controls behave in the Audio Mixer.
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Initially, you choose whether clip items are mono or stereo during capture, but you can
change this when you edit in the Timeline.
About Mono and Stereo Clip Items
Clip items may be linked in the following ways:
• Mono clip item: A mono clip item is a single audio clip item that contains one audio
channel and is not linked to any other clip items.
• Stereo pair clip items: Two clip items can be specially grouped together as a stereo pair.
Creating a stereo pair allows you to adjust the level and pan controls of both clip items
simultaneously. Clips captured as stereo are automatically added to the Timeline as a
stereo pair. For more information, see “Audio Editing Basics.”
• Linked clip items: To keep items in sync while you edit, you can link up to 24 audio clip
items (mono or stereo pair) together. Linking audio items does not change their mono
or stereo pair characteristics. Dual mono clip items are a typical output group in which
two mono clip items are linked together. For more information, see “Linking and Editing
Video and Audio in Sync.”
How Audio Outputs Affect Panning Sliders
Panning sliders can behave in three different ways, depending on the clip item linking
and the type of audio output assigned to a track. For more information about audio
outputs, see “Audio Signal Flow in Final Cut Pro.”
• Mono or stereo clip item and mono audio output: Any track assigned to a mono audio
output has its panning slider disabled.
Timeline tracks
Mono clip

To mono bus

Stereo clip

To mono bus

Stereo clip

To mono bus

• Mono clip item and stereo audio output: A track’s panning slider allows you to control
the stereo placement of the mono clip.
Timeline track
Mono clip

To stereo bus
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• Stereo clip items and stereo audio output: Level and pan controls for both clip items are
linked. You cannot independently adjust the left or right level. Changing the pan of
one of the clip items inversely adjusts the pan of the other, resulting in a gradual
swapping of the left and right audio signals.
Timeline tracks
Stereo clip

To stereo bus

Stereo clip

To stereo bus

...both panning sliders
move at the same time
in opposite directions.

When clip items linked as
a stereo pair are placed
in tracks assigned to
stereo outputs...

Changing a Clip’s Pan
You can change the pan of both stereo and mono clip items in the Audio Mixer. When
you adjust a stereo clip item’s pan, the other clip item in the pair is adjusted by an equal
and opposite amount. Mono clip items’ pan is adjusted independently.
To change the pan of an entire clip
1 Make sure the clip doesn’t have any pan keyframes already applied.
2 Make sure that the Record Audio Keyframes button in the button bar at the top of the
Audio Mixer is not selected.
3 In the Timeline, position the playhead so that it’s over the clip you want to change.
4 Drag the panning slider of the relevant track strip.
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Dragging the slider to the left pans that clip’s audio increasingly to the left channel.
Dragging it to the right pans that clip’s audio increasingly to the right channel.

µ
µ

To reset a panning slider
Hold down the Option key, then click the panning slider you want to reset.
To reset all panning sliders in the Audio Mixer
Control-click at the top of any track’s track strip, then choose Reset All Panners from the
shortcut menu.
Note: Stereo pan can also be modified in the audio tabs of the Viewer. For more
information on how to modify stereo pan in the Viewer, see “Changing the Pan of Audio
in the Viewer.”

About Mixer Automation and Keyframe Recording
Whenever you play back a sequence, the audio level and pan keyframes in the clips
control the mix automatically. This is called mixer automation and is especially important
when you have a lot of tracks in a long sequence. Audio level and pan keyframes allow
you to build up a complete audio mix by recording keyframes on just one track at a time.
With keyframes, you can orchestrate a complete mix of audio tracks by yourself, a task
that once required several people, with each person focused on a group of tracks.
There are several ways to add audio level keyframes to your clip items and modify them
in the Timeline or Viewer. You can:
• Manually add keyframes with the Pen tool
• Select the Record Audio Keyframes button in the Audio Mixer button bar, and then do
one of the following:
• Use the controls in the Audio Mixer to record fader and panning slider adjustments
in real time.
• Use a supported control surface with physical faders and pan controls. This allows
you to adjust multiple faders and panning sliders simultaneously.
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Note: Although the steps described above generally refer to using the controls in the
Audio Mixer to automate your mix one track at a time, these steps can also apply to using
a control surface. For more information about using a control surface, see “Using a Control
Surface with the Audio Mixer.”

Specifying Audio Keyframe Recording Resolution
Before you start recording keyframes using the Audio Mixer, you must define the frequency
with which Final Cut Pro records audio level and pan keyframes. Final Cut Pro can record
every subtle movement of an audio fader and panning slider or a reduced (“thinned”)
number of those keyframes.
To choose the resolution for audio keyframe recording
1 Choose Final Cut Pro > User Preferences.
2 In the Editing tab of the User Preferences window, choose an option from the Record
Audio Keyframes pop-up menu:
• All: Records the maximum number of keyframes possible while you move a track strip’s
fader or panning slider. The end result is an ultra-precise re-creation of the levels you
set using the Audio Mixer. The drawback to this option is that you might end up with
an extremely dense cluster of keyframes in the audio level overlays of the affected clips
that can be difficult to edit later. Unless you are doing very fast, precise audio mixing,
you may want to avoid this option.
• Reduced: Records only a subset of keyframe information created when you move a
track strip’s fader or panning slider. The resulting audio level or pan overlay in the
Timeline or Viewer is still a fairly accurate reproduction of the levels you set, but the
number of keyframes recorded is much smaller than when the All option is chosen.
• Peaks Only: Records only the minimum number of keyframes necessary to approximate
the levels you recorded when moving a track strip’s fader or panning slider. Keyframes
recorded using the Peaks Only option reflect only the highest and lowest levels that
were recorded. This is primarily useful when you want to record a minimum number
of keyframes to edit later in the Timeline or Viewer.

Recording Audio Level and Pan Keyframes
As long as the Record Audio Keyframes button at the top of the Audio Mixer is selected,
audio level and pan keyframes are recorded whenever a fader or panning slider is adjusted.
Keyframes can be recorded both during playback and when playback is paused.
During playback, keyframe recording begins when you position the pointer on a fader
or panning slider and press the mouse button, and recording continues until you release
the mouse button. The density of recorded keyframes depends on what you specified in
the Record Audio Keyframes pop-up menu in the Editing tab of the User Preferences
window.
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Note: Instead of using the mouse to adjust your faders, you can also use a supported
control surface to adjust multiple faders and panning sliders simultaneously.
Keyframe recording continues as long as the mouse button is held down, so it’s best to
mix groups of short, consecutive clips in a track all at once. For example, suppose you’ve
edited a dialogue sequence with multiple angles of coverage so that the dialogue spoken
by a single character is broken up into six different clips on tracks A1 and A2.

Because each clip has its own independent audio levels, to use the Audio Mixer to set
the levels for the entire group, you need to keep the mouse button held down
continuously to record keyframes as you play back all six clips. If you stop halfway through
clip 4, the audio level overlays for these clips look like this:

This is because no fader movement was detected in either clip 5 or clip 6, so the levels
were not adjusted for these clips. If this happens, it’s easy to move the playhead back to
the beginning of the section you’re working on and record any additional keyframes.
When you release the mouse button, keyframe recording ends and the fader for that
track goes back to displaying the previously set levels. The same rules apply to recording
pan information.
Important: If the Record Audio Keyframes button is not selected, no keyframes are
recorded when you move faders or panning sliders. However, you can still modify
keyframes and levels between any two keyframes.
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To record audio level or pan keyframes
1 Click the Record Audio Keyframes button in the button bar at the top of the Audio Mixer
to turn on keyframe recording.
Tip: You can click the Record Audio Keyframes button to turn keyframe recording on or
off during playback, if necessary.
2 In the Viewer or Timeline, move the playhead to the area of your sequence where you
want to begin recording keyframes.
It’s a good idea to start a few seconds before the section you’ll actually be mixing, to give
yourself time to get ready.

3 Begin playback of your sequence.
4 As your sequence plays, position the pointer over the fader or panning slider in the
relevant track strip, then hold down the mouse button to begin recording keyframes for
clips playing back in that track.

Place the pointer over
the fader slider to start
automation recording.
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5 Hold down the mouse button to continue recording keyframes, and move the fader or
panning slider to adjust the clip’s audio or pan levels in real time while playback continues.
6 When you’ve finished, release the mouse button to stop recording keyframes.
The sequence continues to play, and the fader and pan controls return to the previously
set levels.
7 If there are any other Audio Mixer controls you want to adjust at this time, repeat steps
4 through 6.
8 When you’ve finished making adjustments, stop playback.
After you finish recording automation for a track, you can move the playhead back to the
beginning to record keyframes for additional tracks. This way, you can create your audio
mix one track at a time, adding keyframes for each track until you’ve set levels for all the
clips in your sequence. Ultimately, it doesn’t matter whether you use the Audio Mixer in
real time or set levels directly in the Timeline or Viewer. You can choose whatever method
works for a particular track or clip.
Note: You can also make changes to levels in tracks you’ve already mixed. New changes
made to the fader and pan automation overwrite previously set keyframes.

Looping Playback to Mix Each Track
You can set a section of your sequence to loop so that you can mix each track without
stopping playback. As the section of your sequence loops, you can go from one track
strip fader to the next, adjusting (or overwriting) keyframes until your mix is perfect.
To record automation while your program is looping
1 Click the Record Audio Keyframes button in the button bar at the top of the Audio Mixer
to turn on keyframe recording.
Tip: You can click the Record Audio Keyframes button to turn keyframe recording on or
off during playback, if necessary.
2 In the Timeline or Canvas, set In and Out points.
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It’s a good idea to place In and Out points several seconds earlier and later than you need,
to give yourself time to manipulate the controls before reaching the boundaries of the
loop. Otherwise, you may overwrite keyframes you previously set when playback resets
to the In point.

3 Choose View > Loop Playback to turn on looped playback.
4 To begin looped playback, choose Mark > Play > In to Out, or press Shift-Backslash (\).
5 Position the pointer over any fader or panning slider you want to adjust, then press and
hold down the mouse button to begin recording keyframes.
6 Hold down the mouse button to continue recording keyframes, and move the control
you’ve selected to adjust the clip’s audio or pan levels in real time while playback
continues.
7 When you’ve finished, release the mouse button to stop keyframe recording.
The sequence continues to play, and the fader and pan controls return to previously set
levels. When playback loops, you can click another control to continue making adjustments
to clips in other tracks. You can also make changes to clips in tracks you’ve already mixed.
Note: New changes made using a track’s fader and panning slider overwrite any previous
levels.
8 When you’ve finished making adjustments, stop playback.
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If keyframe recording stops before the end of a clip, the audio or pan level of the remaining
duration of that clip depends on whether or not there were already keyframes in the clip.
• If there were no keyframes in the clip prior to recording keyframes: The audio level or pan
overlay remains at the level of the last recorded keyframe for the remaining duration
of that clip.

Playback stopped here.

• If there were keyframes in the clip prior to recording keyframes: The audio level or pan
values are interpolated from the level of the last recorded keyframe to the level of the
next keyframe.

Playback stopped here.

Modifying Recorded Keyframes
After you’ve recorded keyframes for a series of clips on a particular track, there are two
ways you can make modifications to the levels you’ve set with the Audio Mixer: by using
the Audio Mixer or by modifying keyframes in the Viewer or Timeline.
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Using the Audio Mixer to Record over Previously Existing Automation
You can use the Audio Mixer to make further changes to audio clips in your sequence
that already have audio level and pan keyframes applied. How these changes are made
depends on whether or not keyframe recording is turned on.
• If the Record Audio Keyframes button is selected: Changes you make with the Audio Mixer
during playback create a new set of keyframes, completely overwriting any previously
existing keyframes. Changes you make while playback is paused insert new keyframes
at the position of the playhead.
• If the Record Audio Keyframes button is not selected: Changes you make with the Audio
Mixer during playback do not create new keyframes. Instead, existing keyframes are
modified to match the levels set when the playhead passes over them.
Individual keyframes can be adjusted if the playhead is directly over them. If the
playhead is between two keyframes, the level of both keyframes is changed to adjust
that entire section of the overlay.
During playback, every fader and panning slider in the Audio Mixer animates, displaying
the current levels in your sequence. At any time during playback, you can adjust a fader
or panning slider to begin recording new automation or modifying existing automation.
This helps you to maintain a smooth transition from any previously recorded levels to
the new levels you’re setting.
Modifying Keyframes in the Timeline and Viewer
You can also make changes to the audio level and pan keyframes in the Timeline. By
displaying level overlays in the Timeline (click the Clip Overlays control), you can modify
the keyframes you recorded, using the Selection and Pen tools to make precise
adjustments. For more information on adjusting audio level and pan keyframes in the
Timeline, see “Adjusting Audio Levels in the Timeline” and “Panning Audio in the Timeline.”
To modify pan keyframes you’ve added using the panning sliders in the Audio Mixer
Do one of the following:

µ

Open the clip in the Viewer. Stereo pan keyframes appear on their own overlay in the
clip’s Audio tab. For more information on adjusting stereo pan keyframes in the Viewer,
see “Changing the Pan of Audio in the Viewer.”

µ

In the Timeline, click the Clip Keyframes control, then Control-click in the keyframe editor
area of an audio track and choose Pan from the shortcut menu. Pan keyframes are now
displayed in the keyframe editor for the audio tracks in the Timeline, and you can adjust
them with the Pen tool.

Deleting Audio Level and Pan Keyframes
You can easily remove level and pan automation from clips in a sequence using the
Remove Attributes command. Audio level and pan keyframes can be removed separately
or together.
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To remove keyframes using the Remove Attributes command
1 Do one of the following:
• Select one or more clips in the Timeline, then choose Edit > Remove Attributes.
• Select one or more clips in the Timeline, Control-click one of the selected clips, then
choose Remove Attributes from the shortcut menu.
2 In the Remove Attributes dialog, select Levels or Pan to delete keyframes from those
overlays.

Select one or both
of these checkboxes
to delete keyframes
from overlays.

3 When you’ve finished, click OK.
All audio level and pan keyframes are removed from the selected clip, and the audio level
is reset to 0 dB.

Using a Control Surface with the Audio Mixer
A control surface is a hardware device with faders, knobs, and buttons that can control
the Final Cut Pro Audio Mixer. You can use a supported control surface to remotely control
track faders, pan settings, mute and solo buttons, and even the transport controls in your
sequence. Control surfaces emulate traditional audio mixing consoles, giving you tactile
control over multiple faders at once.
Control surfaces send and receive MIDI data to communicate fader positions, pan knob
settings, track names, and timecode.
To set up your control surface, you need the following:
• An external MIDI interface with at least one input and output
• Mac OS X MIDI driver software that corresponds to your MIDI interface (if necessary)
• One or more supported control surfaces

Chapter 56 Using the Audio Mixer

907

What Is MIDI?
Musical Instrument Digital Interface (MIDI) is a standard protocol that allows electronic
music devices and control surfaces to send and receive performance data. This allows
you to do things such as control a synthesizer with a keyboard or control an audio mixing
application such as Final Cut Pro with a control surface.

Choosing an External MIDI Interface
There are a wide variety of MIDI interfaces available. When you select a MIDI interface,
consider the following:
• You need a MIDI interface that is compatible with Mac OS X.
• Most interfaces connect to your computer via the USB port, although some PCI and
FireWire audio interfaces include MIDI ports.
• You should purchase a MIDI interface that supports the number of control surfaces you
need, plus any additional MIDI equipment you may want to connect to your computer.

Installing a MIDI Interface
In many cases, installing a MIDI interface is as simple as connecting the interface to your
computer. If your MIDI interface does not appear in the Control Surface Configuration
dialog, the MIDI interface may require driver software. This may be included with the
MIDI interface, or you may be able to download MIDI drivers from the manufacturer’s
website. Make sure you follow the installation instructions that came with your MIDI
interface.
To set up and connect a MIDI interface to your computer
1 Install any MIDI drivers necessary for the MIDI interface.
2 Connect a USB cable between the USB port on your computer and the MIDI interface.
3 Make sure the MIDI interface is connected and turned on.

Choosing a Control Surface
Different control surfaces use slightly different communications protocols, so not all
control surfaces are compatible. Final Cut Pro supports Mackie and Logic Control control
surfaces and Mackie and Logic Control XT control surfaces.

Connecting a Control Surface
Once you have your MIDI interface connected to your computer, setting up a control
surface is simple.
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To connect your control surface to your MIDI interface
1 Connect the MIDI output port of the control surface to a MIDI input port on the MIDI
interface.
MIDI connector

2 Connect a MIDI output port on your MIDI interface to the MIDI input port on your control
surface.
3 Make sure the control surface is turned on.

Configuring Final Cut Pro to Work with a Control Surface
Once a control surface is connected to your MIDI interface, you need to establish
communication between the control surface and Final Cut Pro. You set up control surfaces
in Final Cut Pro in the Control Surface Configuration dialog.
Shift Order Left
and Shift Order Right buttons

Add and Delete buttons

Control surface
arrangement area

Summary area

• Control surface arrangement area: This area displays icons of the currently assigned
control surfaces. You can click a control surface icon to select it, and you can double-click
the icon to adjust the control surface’s settings. If you have multiple control surfaces,
you can drag their icons to rearrange their order.
The order of control surface icons affects the fader ordering on your physical control
surfaces. For more information, see “Arranging Control Surface Order.”
• Add and Delete buttons: These buttons allow you to add or remove control surfaces in
your configuration. The number of control surfaces allowed is limited to the number
of MIDI ports on your MIDI interface.
• Shift Order Left and Shift Order Right buttons: These buttons allow you to move the
selected control surface icon to rearrange its order.
• Summary area: This area displays information about the currently selected control
surface.
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Working with a Control Surface
This section explains procedures for working with a control surface.
To configure a control surface
1 Choose Tools > Control Surfaces.
The Control Surface Configuration dialog appears.
2 If there is not already a control surface icon in the control surface arrangement area, click
the Add (+) button, or press Command-Shift-Plus Sign (+).
A dialog appears with configuration settings.
3 Choose the following settings:
• The type of control surface
• The MIDI interface output port to which your control surface MIDI input is connected
• The MIDI interface input port to which your control surface MIDI output is connected
Note: Audio MIDI Setup is a utility included with Mac OS X that allows you to name
and configure the devices, instruments, and ports of your MIDI setup. The names of
external devices configured in Audio MIDI Setup appear in parentheses after the name
of each port of your MIDI interface.
4 Click OK, then click OK again to accept changes to your control surface configuration.
You can add and configure additional control surfaces using the steps above.
To change the settings for a control surface
1 Choose Tools > Control Surfaces.
The Control Surface Configuration dialog appears.
2 Double-click the control surface icon.
A dialog appears with configuration settings.
3 Change the control surface settings as needed.
4 Click OK, then click OK again to apply changes to your control surface configuration.
To delete a control surface
1 Choose Tools > Control Surfaces.
2 Do one of the following:
• Click a control surface icon, then press Command-Delete.
• Drag a control surface icon outside of the Control Surface Configuration dialog, then
release the mouse button.
• Click a control surface icon, then click the Delete (-) button.
3 Click OK.
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How Audio Mixer Tracks Correspond to Control Surface Faders
The track number assigned to a physical fader corresponds to the track strips visible in
the Audio Mixer. For example, if only tracks A1 and A8 are visible in the Audio Mixer, they
correspond to the first and second faders on your control surface.
For more information about showing and hiding track strips in the Audio Mixer, see “Track
Visibility Area.”

Arranging Control Surface Order
If you have more than one control surface configured to work in Final Cut Pro, the physical
faders are numbered so that control surfaces whose icons appear toward the left side of
the Control Surface Configuration dialog have lower-numbered faders. Control surfaces
whose icons appear toward the right side have higher-numbered faders.
Important: For proper track numbering, the order of control surface icons in the Control
Surface Configuration dialog should match the physical layout of your control surfaces.
To rearrange the order of control surface icons
1 Choose Tools > Control Surfaces.
Tracks 1–8

Tracks 9–16

Note: There must be at least two control surfaces connected if you want to rearrange
their order.
2 Do one of the following:
• Press Shift-Left Angle Bracket (<) or Shift-Right Angle Bracket (>).
• Drag a control surface icon to a new position to the left or right.
• Press the Left Arrow or Right Arrow key to select a control surface icon, then click the
Shift Order Left or Shift Order Right button to move the control surface icon.
3 Click OK.
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The control surface faders are renumbered according to their new order in the control
surface arrangement area.
Tracks 1–8

Tracks 9–16

Working with Fader Banks
If your Final Cut Pro sequence has more tracks than your control surface has faders, you
can still control the remaining faders by using another fader bank on the control surface.
Fader banks allow you to multiply the number of tracks your control surface can control
by temporarily assigning the physical faders to higher-numbered tracks.
For example, if your control surface has eight faders, the first fader bank can control the
first eight visible tracks in the Audio Mixer. The second bank can control the second group
of eight visible faders, and so on. If all tracks are visible in the Audio Mixer, the first fader
bank controls tracks 1-8, the second fader bank controls tracks 9-16, and so on.
When your sequence has more tracks than the control surface, Final Cut Pro automatically
assigns additional tracks to new fader banks. No additional configuration is necessary.

µ

To switch fader banks on your control surface
Press the Bank Left or Bank Right button on the control surface.
The previous or next fader bank is selected, allowing you to control a different range of
tracks in the Audio Mixer.
If you have multiple control surfaces configured, the fader bank button increases the
control surface track numbering by the total number of physical faders. For example, if
you have two control surfaces, each with eight faders, the first fader bank controls tracks
1-16, the second fader bank controls tracks 17-32, and so on.

Controlling the Audio Mixer with a Control Surface
After you have connected a control surface and configured Final Cut Pro to work with it,
you can use it to remotely control the faders, panning sliders, and buttons in the Audio
Mixer, giving you control over multiple tracks simultaneously, as well as more fluid, tactile
control over your audio mix. For more information about setting up a control surface,
see “Connecting a Control Surface.”
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Preparing to Use a Control Surface
A control surface can perform exactly the same actions that the Final Cut Pro Audio Mixer
is capable of. In Final Cut Pro, audio level and pan information is stored in clips, not in
tracks. When a track does not contain a clip, the corresponding track fader level is set to
–∞ dB.
Important: The Audio Mixer must be open or the control surface has no effect. To open
the Audio Mixer, choose Tools > Audio Mixer (or press Option-6).
The Audio Mixer can control audio settings in the Canvas (and Timeline) as well as the
Viewer. You can choose which window the Audio Mixer affects by choosing an option
from the Source pop-up menu in the upper-right corner of the Audio Mixer. If you choose
Auto, the Audio Mixer controls the most recently active window (Canvas or Viewer).

Adjusting Levels, Pan, Mute, and Solo Using a Control Surface
Once your control surface is properly configured, you can open a sequence and begin
mixing. Adjustments you make on the control surface are immediately reflected in the
Audio Mixer, and the reverse is also true: changes in the Audio Mixer are immediately
reflected in the control surface.
To use a control surface to mix audio in the Timeline
1 Double-click a sequence in the Browser to open it in the Timeline and Canvas.
2 Choose Tools > Audio Mixer (or press Option-6).
The Audio Mixer appears with faders corresponding to tracks in the Timeline. The
motorized faders on the control surface automatically adjust to reflect the current fader
levels in the Audio Mixer. Pan settings, mute buttons, and solo buttons are also updated
to reflect the current Audio Mixer status.
3 Adjust a fader on the control surface.
The corresponding fader slider in the Audio Mixer automatically moves to the same
position.
4 In the Audio Mixer, drag a fader slider up or down.
The corresponding motorized fader on the control surface automatically moves to the
same position.
Adjusting pan, solo, and mute controls in the Audio Mixer also updates the control surface,
and vice versa.
If your sequence has more tracks than your control surface, you can switch to the next
fader bank to control additional tracks. For more information about fader banks, see
“Working with Fader Banks.”
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Using Control Surface Transport Controls
You can remotely control playback in Final Cut Pro using the transport controls on your
control surface. The current timecode of your sequence (or clip in the Viewer) is displayed
in the Time Display readout on the control surface.
Important: The Audio Mixer must be open or the control surface transport controls have
no effect in Final Cut Pro.
The play, rewind, fast-forward, and stop buttons on the control surface work in the same
way as the transport controls in the Viewer and Canvas. You can also jog frame by frame
using the jog/scrub wheel on the control surface.

Control Surface Commands Supported by Final Cut Pro
In addition to the main functions described above, the following control surface buttons
can be used to trigger Final Cut Pro commands.
Control surface button

Final Cut Pro command

Jog/scrub wheel

Jog only

Arrow keys

Same as control surface

Function keys (F1-F8); modifier
keys (Command, Shift, Option,
Control)

Same as control surface

Save, Undo, Cancel, Enter

Same as control surface

Marker

Go to Previous Marker

Nudge

Go to Next Marker

Cycle

Home

Solo

End

Recording Audio Mixer Keyframes Using a Control Surface
Recording audio mixer automation with a control surface is identical to recording
keyframes by adjusting faders in the Audio Mixer. The only difference is that you can
control multiple faders and pan knobs simultaneously with a control surface, whereas
adjusting faders with the mouse allows you to control only one fader at a time. Using a
control surface lets you perform more nuanced mixes, adjusting multiple tracks at once.
For information about recording audio level keyframes, see “About Mixer Automation
and Keyframe Recording.”
To record audio level and pan keyframes using a control surface
1 Make sure your control surface is connected and properly configured.
2 Press Option-6 to open the Audio Mixer.
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3 Click the Record Audio Keyframes button (located in the button bar of the Tool Bench
window) to turn on keyframe recording.
4 Press the Space bar to begin playing your sequence.
5 Adjust faders and panning knobs on the control surface.
Audio level and pan keyframes are added to the clips in your sequence.
When you play back a clip or sequence, the faders in the Audio Mixer and the control
surface are automatically controlled by audio level and pan keyframes. Keyframe recording
begins when you touch the fader and finishes when you release the fader.
You can even adjust a fader to a new position while it is moving. For example, if a fader
on the control surface is slowly moving down from a 0 dB keyframe to a –60 dB keyframe,
you can move the motorized fader up to +12 dB, thereby creating new keyframes.

When you release the fader, it returns to its trajectory moving toward the –60 dB keyframe.
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Mixing Audio in the Timeline and
Viewer

57

This chapter covers the following:
• Adjusting Audio Levels in the Timeline (p. 917)
• Changing Audio Levels in the Viewer (p. 922)
• Panning Audio in the Timeline (p. 925)
• Changing the Pan of Audio in the Viewer (p. 925)
• Changing Pan for an Entire Clip (p. 926)
• Copying, Pasting, and Removing Audio Attributes (p. 927)
• Adjusting Clip Audio Levels and Pan Using Keyframes (p. 928)
You can control audio levels and pan in the Timeline and the Viewer as well as the Audio
Mixer. You can make adjustments to multiple clips at once, as well as add keyframes to
automate mixing levels over time.
For more information about the Audio Mixer, see “Overview of the Audio Mixer” and
“Using the Audio Mixer.”

Adjusting Audio Levels in the Timeline
Changing audio levels directly in the Timeline is fast and is especially useful when you
need to mix the levels of clips relative to other clips playing at the same time. For example,
if you want to raise and lower the volume of a music clip to correspond with a voiceover
recording, you can see how the narrator’s dialogue lines up with the music clips if you
turn on audio waveforms in the Timeline. That way, you can easily see exactly where you
need to set your keyframes to achieve the levels you want.
To use all the commands and tools described in this section, you need to turn on clip
overlays in the Timeline to display the audio level and pan overlays. Displaying audio
waveforms is also useful for audio mixing in the Timeline.
To display clip overlays in the Timeline
1 Open a sequence in the Timeline, then choose Sequence > Settings.
2 Click the Timeline Options tab, then select the Show Keyframe Overlays checkbox.

917

You can also select the Clip Overlays control in the Timeline.
To display audio waveforms in the Timeline
1 Open a sequence in the Timeline, then choose Sequence > Settings.
2 Click the Timeline Options tab, then select the Show Audio Waveforms checkbox.
To avoid opening the Sequence Settings window, you can also press Command-Option-W
while the Timeline is active.
To adjust the audio level of a single clip with no keyframes
1 Click the Clip Overlays control at the bottom of the Timeline to display overlays.
2 Drag the audio level overlay up or down to adjust the audio level. The overlay is a pink
line if the clip is not selected, and a green line if it is.
The pointer changes to an Adjust Line Segment pointer when it’s directly over the audio
level overlay, and a box displays the change in levels as you drag.

Audio level overlay

Clip Overlays
control

Change in audio
level

To add a keyframe to the audio level overlay of a clip in the Timeline
1 Do one of the following:
• Select the Pen tool in the Tool palette (or press the P key).
• If you’re using the Selection tool, hold down the Option key.
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2 Move the Pen tool to the point in your sequence where you want to set a keyframe, then
click the overlay to set the keyframe.

The keyframe appears as
a small diamond at the
point where you clicked.

µ

To adjust keyframes in the Timeline
Place the Selection tool directly over a keyframe, so that it turns into a crosshair pointer.
You can now adjust a single keyframe by dragging it up or down to change its level, or
from side to side to move it forward and backward in time.
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Keyboard Shortcuts for Changing Audio Keyframes
Final Cut Pro provides commands for changing the gain of audio keyframes. These
commands are not assigned as menu items. You can assign these commands to keys on
the keyboard using the standard procedures for customizing your keyboard layout. These
commands are also available as buttons that you can place in your button bar. The
commands increase or decrease the audio level of a keyframe or keyframe segment under
the playhead position in the Timeline or the Viewer. The commands are:
• Gain (Adjust) -1dB
• Gain (Adjust) -3dB
• Gain (Adjust) +1dB
• Gain (Adjust) +3dB
Placing these buttons in the button bar provides a convenient method for adjusting
keyframes precisely.
Note: When adjusting a keyframe with the Gain Adjust commands, you can position the
playhead on a keyframe to change its level, or position the playhead between two
keyframes to change the audio level of the segment between the keyframes. When using
the Pen tool to add keyframes, you can create highly accurate keyframes located between
frame boundaries. At some zoom levels, when keyframes appear closely spaced, it can
appear that the playhead is on an audio keyframe when it is actually between keyframes.
In this case, the Gain Adjust commands move the segment of the overlay between the
keyframes, instead of just the single keyframe that the playhead appears to be on. Change
the zoom level of the Timeline or Viewer to better see the location of the playhead on
keyframes.

µ
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To adjust a section of a clip’s overlay in the middle of four keyframes
Drag just that section up or down, as if you were dragging the entire overlay.

Chapter 57 Mixing Audio in the Timeline and Viewer

To delete audio level keyframes in the Timeline
Do one of the following:

µ
µ

Control-click the keyframe you want to delete, then choose Clear from the shortcut menu.

µ

With the Selection tool selected, hold down the Option key, then move the pointer to
the keyframe you want to delete. When the pointer turns into the Delete Point tool, click
to delete the keyframe.

µ

Select the Delete Point tool in the Tool palette (or press the P key twice). Place the Delete
Point tool on the keyframe you want to delete, then click to delete the keyframe.

To select a range of keyframes to modify
Use the Range Selection tool to select a group of keyframes. You can now move, delete,
or change the level of just those keyframes.

To adjust the audio level of a group of clips simultaneously
1 In the Timeline, select a group of audio clips whose levels you want to adjust.
2 Choose Modify > Levels.
3 Use the slider to adjust the audio level and choose Relative or Absolute from the pop-up
menu, then click OK.

• Relative: Adjusts each track’s audio level relative to the current level.
• Absolute: Changes all selected tracks to the value indicated in the number field next
to the slider.

Changing Audio Levels While a Sequence Is Playing
You can use keyboard shortcuts to change the audio levels of clips in a sequence while
it’s playing. Your changes affect the clip on the lowest-numbered audio track with Auto
Select turned on. The level of the clip at the current playhead position is adjusted. Use
the following shortcuts:
• To raise the level by 1 dB: Press Control–Equal Sign (=).
• To raise the level by 3 dB: Press Control–Right Bracket (]).
• To lower the level by 3 dB: Press Control–Left Bracket ([).
• To lower the level by 1 dB: Press Control–Hyphen (-).
When you use the shortcut, you hear a brief pause, and then playback resumes almost
immediately.
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Changing Audio Levels in the Viewer
You can control the audio levels and placement of sound (pan) in a clip in the Viewer
using the sliders at the top of the Audio tab, the number fields next to the sliders, or the
overlays in the middle of the waveform display area. The detail displayed in the audio
tabs of the Viewer is good for modifying keyframes recorded using the Audio Mixer.
Drag the Level slider to
change the audio level.

Level field

Pan field
Audio level overlay
Pan overlay

How these controls affect the level of your clip depends on whether or not you’ve set
keyframes for either audio level or pan.
• If no keyframes are set: Moving the sliders or entering a numeric value changes the
audio or stereo levels for the entire clip. Similarly, dragging one of the overlays changes
the audio level or pan setting for the entire clip.
• If keyframes are set: Moving the sliders or entering a numeric value modifies the value
of whatever keyframe is at the current position of the Viewer playhead. If there is no
keyframe at the current position of the playhead, one will be added. There must be at
least two keyframes on an overlay to change the audio level or pan setting from one
level to another.
Whether or not the audio item in the Viewer is a stereo pair also affects how audio level
and pan are set. Clips can have up to 24 tracks of audio, and each item can be mono or
part of a stereo pair.
• If you opened mono items: Each channel is in its own tab in the Viewer and is mixed
separately from all others.
• If you opened a stereo pair: Both waveforms appear in the same tab, named Stereo.
Adjusting the levels of one channel adjusts the levels of the other.
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As you adjust the audio level and pan of clips in Final Cut Pro, your changes can be played
back immediately. Final Cut Pro mixes the audio levels in real time, so you don’t need to
render your audio as long as your computer can handle the number of tracks you’re
working on. Real-time audio processing is covered in more detail in “Real-Time Audio
Mixing in Final Cut Pro.”
Tip: Using effects like cross fades and filters requires processing power, which reduces
the total number of tracks you can mix in real time. If you exceed the number of tracks
your computer can handle, you’ll need to render your tracks. Audio is usually rendered
much faster than video, however, so it shouldn’t take too long.
When you edit a new clip into a sequence, its level is set to 0 decibels (dB) by default.
You can change the level to be any value you like, up to +12 dB. You can use three controls
to adjust the audio level of a clip. Each of these controls is mirrored by the other controls
as you make adjustments. If no keyframes are set in the clip in the Viewer, using these
controls adjusts the level of the entire clip.

µ

To adjust the audio level using the Level slider
Drag the Level slider to the left or right.

To adjust the audio level by entering a numeric value
1 Enter a value in the Level field.
To enter a negative value, type a minus sign (-) and the number.
Enter a new value
in this field.

2 Press the Return key to apply this value to your clip.
To adjust the audio level by dragging the audio level overlay
1 Place the pointer over the audio level overlay of your clip in the waveform display area
of the Viewer (the overlay looks like a pink line, or—for stereo items—two pink lines).
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The pointer turns into an Adjust Line Segment pointer.

Adjust Line Segment
pointer

2 Drag the overlay up or down to change the level of the clip.
As you drag, a box displays the new audio level.
Tip: Hold down the Command key while you drag to “gear down” the speed at which
the level is adjusted.
To adjust the audio level by using the Modify menu
1 Select one or more clips in the Timeline, or place the Canvas or Timeline playhead over
the clip whose audio level you want to modify.
2 Choose Modify > Audio, then choose one of the Gain items from the submenu to indicate
how much you want to modify the level.
The audio level of your clip is increased or decreased from its current value by the
increment you choose. If you selected multiple clips, all clips are modified relative to their
current values.
To adjust the audio level by using keyboard shortcuts
1 Select one or more clips in the Timeline, or place the Canvas or Timeline playhead over
the clip whose audio level you want to modify.
2 Do one of the following:
• To raise the level by 1 dB: Press Control–Equal Sign (=).
• To raise the level by 3 dB: Press Control–Right Bracket (]).
• To lower the level by 3 dB: Press Control–Left Bracket ([).
• To lower the level by 1 dB: Press Control-Hyphen (-).
The audio level of your clip is increased or decreased from its current value by the
increment of the keyboard shortcut you used. If you selected multiple clips, all clips are
modified relative to their current values.
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Panning Audio in the Timeline
You can adjust the pan of one or more clips in the Timeline using the Audio item in the
Modify menu, but you can’t make as many adjustments as you can in the Viewer. Using
the menu, you can set a clip’s pan all the way to the left, all the way to the right, or in the
center of the stereo output channels.
Note: If you use this method to change the pan of a clip that’s a stereo pair, the pan
setting for both audio channels changes simultaneously. The pan setting is applied to
the uppermost channel of the stereo pair, and the lower channel is panned to the opposite
side.
To change the pan for a clip or clips
1 In the Timeline, select the clip or clips whose pan you want to change.
2 Choose Modify > Audio, then choose a pan option from the submenu.
• Pan Left: Pans audio all the way to the left stereo output.
• Pan Center: Centers audio evenly between left and right stereo outputs.
• Pan Right: Pans audio all the way to the right stereo output.

Changing the Pan of Audio in the Viewer
To adjust the stereo placement of your sound, you can change the pan of your audio
clips. The Pan slider is actually one control with two modes. What the control does depends
on what kind of audio you’ve opened in the Viewer.
• If the audio clip in the Viewer is a stereo pair: This slider lets you swap the left and right
channels. The default setting of –1 sends the left audio channel of your clip to the left
output channel and the right audio channel to the right output channel. A setting of
0 outputs the left and right audio channels equally to both speakers, essentially creating
a mono mix. A setting of +1 swaps the channels, outputting the left audio channel to
the right speaker and the right audio channel to the left speaker.
• If the audio clip in the Viewer is not a stereo pair: This slider lets you pan the audio channel
in the currently selected audio tab between the left and right channels.

Pan slider

Chapter 57 Mixing Audio in the Timeline and Viewer

925

As with the Level slider, if there are no pan keyframes in the current clip, adjusting the
Pan slider affects the pan of the entire clip. If there are pan keyframes, using this slider
will do one of the following:
• Adjust the pan of a keyframe at the current position of the playhead.
• Add a new keyframe to the pan overlay and adjust it between the left and right output
channels.
Working with keyframes is explained in more detail in “Adjusting Clip Audio Levels and
Pan Using Keyframes.”

Changing Pan for an Entire Clip
When you edit a new clip into a sequence, the default stereo value depends on what
kind of audio clip it is.
• If it’s a mono clip: Its stereo pan is centered, with a value of 0 by default. You can change
this level to whatever you like, from –1 to +1.
• If it’s a stereo pair: The pan value defaults to –1, sending the left audio track to the left
channel and the right audio track to the right channel.
You can use three controls to adjust the pan of a clip. Each of these controls is mirrored
by the other controls as you make adjustments. If no keyframes are set in the clip in the
Viewer, using these controls adjusts the pan of the entire clip.

µ

To adjust pan using the slider control
Drag the Pan slider to the left or right to adjust the stereo placement of your clip.
• For a mono item: Dragging the Pan slider left moves the audio toward the left stereo
output channel; dragging right moves it toward the right stereo output channel.
• For a stereo pair: Dragging the Pan slider left or right transposes the left and right
channels of a stereo pair clip.

To adjust pan by entering a numeric value
1 Enter a new value in the Pan field.
To enter a negative value, type a minus sign (-) and the number.
• For a mono item: Enter a value between –1 and +1. A value of –1 moves the audio all
the way to the left stereo output channel. A value of +1 moves the audio all the way
to the right stereo output channel.
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• For a stereo pair: Enter a value between –1 and +1. A value of –1 is the original left and
right stereo placement captured with your clip. A value of +1 reverses the left and right
channels.

Enter a value in this field.

2 Press Return to apply this value to your clip.
To adjust pan by dragging the pan overlay
1 In the waveform display area of the Viewer, place the pointer over the pan overlay of
your clip (the overlay looks like a purple line, or—for stereo items—two purple lines).

The pointer turns into an
Adjust Line Segment pointer.

2 Drag the overlay up or down to change the pan of your clip.

As you drag, a box
displays the new
pan value.

Copying, Pasting, and Removing Audio Attributes
The Paste Attributes command in the Edit menu is a valuable tool for selectively copying
certain attributes—such as levels and pan—from one clip to another without having to
open clips in the Viewer. This eliminates the need to repeat steps when applying identical
effects to multiple clips. For more information, see “Copying and Pasting Specific Clip
Attributes.”
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If you want to remove a clip’s attributes, including levels and pan, you can do so by using
the Remove Attributes command. For more information, see “Removing Attributes from
a Clip.”

Adjusting Clip Audio Levels and Pan Using Keyframes
Instead of setting the audio level or pan of an entire clip to the same level throughout a
clip, you can mix your levels and stereo placement dynamically, raising and lowering the
audio level or changing the stereo pan of a clip numerous times within the same clip. To
do this, you use keyframes.
Keyframes can be used throughout Final Cut Pro with any feature whose parameters can
be changed over time. Keyframes allow you to specify different audio level or pan settings
in an audio clip at different points in time. The audio level overlay in your clip automatically
adjusts from one keyframed level to another using a smooth curve.
You can also record audio level and pan automation using the Audio Mixer, which creates
keyframes. These keyframes can be adjusted by hand, directly in the Viewer or the Timeline.
Note: Unlike the visual keyframes that you can set for motion settings, the shape of audio
level and pan level curves can’t be altered.

Tools for Adjusting Keyframes
When you adjust audio levels and pan settings in the Timeline and Viewer, you mainly
use the Selection and Pen tools. The Pen tools allow you to add, move, and delete audio
level and pan keyframes in the clip overlays in the Timeline as well as in the Viewer.

Pen tool

Delete Point tool

• Pen tool: The Pen tool allows you to add keyframes to the audio level overlay (press
the P key to select the Pen tool).
• Delete Point tool: The Delete Point tool allows you to remove keyframes from the audio
level overlay (press the P key twice or hold down the Option key while you are using
the Pen tool to select the Delete Point tool).
Using the Option Key to Temporarily Enable Pen Tools
When using the Selection tool, holding down the Option key and moving the pointer
over the audio level overlay in the Timeline makes the Pen tool the active tool. This is a
fast and easy way to create keyframes to adjust your levels.
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Holding down the Option key and moving the pointer to an existing keyframe temporarily
enables the Delete Point tool, so that you can quickly delete keyframes you don’t want.
Using the Command Key to Gear Down Adjustment Speed
In Final Cut Pro, items you drag onscreen normally move at the same speed at which you
move your mouse across your work surface. When you’re dragging the audio level overlay,
this usually works just fine. However, you can drag even more precisely by holding down
the Command key after you start dragging an item.
If you hold down the Command key while dragging the audio level overlay, the overlay
moves much more slowly, and its numeric value changes in much smaller increments.
This is especially valuable when mixing levels in the Timeline, where the small height of
clips can make precise level adjustment difficult.
Note: The Command key works with nearly any dragging operation in Final Cut Pro.

Keyframe Controls in the Viewer
The keyframe controls are located next to the slider controls in the Viewer.
Level Keyframe button

Pan Keyframe button

Reset button

Keyframe button

Keyframe navigation
buttons

• Level Keyframe button: The keyframe button to the right of the Level field places a
keyframe on the audio level overlay at the current playhead location. You place
keyframes on the audio level overlay in preparation for creating a dynamic change in
the level when you’re mixing.
• Level keyframe navigation buttons: These buttons, to the left and right of the Level
Keyframe button, allow you to move the playhead forward or backward from one
keyframe on the audio level overlay to the next.
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• Pan Keyframe button: This button, to the right of the Pan slider, places a pan keyframe
at the current playhead location on the pan overlay. These keyframe markers can be
used in preparation for dynamically panning an audio clip’s output from one stereo
channel to another.
• Pan keyframe navigation buttons: These buttons, to the left and right of the Pan Keyframe
button, allow you to move the playhead forward or backward from one keyframe on
the pan overlay to the next.
• Reset button: This button deletes all marked keyframes on both the audio level overlay
and the pan overlay of the currently selected audio track and resets both to their original
values (0 dB for the audio level and –1 for the pan level).

Working with Keyframes
Until you create at least one audio level or pan keyframe in your audio clip, changes you
make affect the level or stereo placement of your entire clip. Although you need two
keyframes to do anything useful, once you set the first audio level or pan keyframe, any
changes you make to the keyframed levels anywhere else in the clip generate additional
keyframes.
To set a keyframe
Do one of the following:

µ

Move the playhead in the Viewer to the place where you want to set a keyframe, then
click the Level Keyframe or Pan Keyframe button.

A keyframe appears
at the location of
the playhead.
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µ

Select the Selection tool (or press A), then hold down the Option key and position the
pointer over the level overlay. The pointer turns into the Pen tool. Click a level overlay
with the Pen tool to add a keyframe at that point.

Pen tool

The keyframe appears as a small diamond on the overlay.
To set additional keyframes
1 Move the playhead to another point in the clip where you want to set a keyframe.
2 Do one of the following:
• Drag the Level or Pan slider to set a new keyframe at that level or value.
• Type a number in the appropriate field to set a new keyframe at that level or value.
• Click a keyframe button to add a keyframe to the audio level or pan overlay at the
overlay’s current level.
• Hold down the Option key and click an overlay with the Pen tool to add a keyframe at
that point without changing the level of the overlay. You can add as many keyframes
as you want by clicking repeatedly with the Option key held down.
The keyframe appears as a small diamond on the overlay you added it to.
To move the Viewer playhead from one keyframe to another
Do one of the following:

µ

Click the left or right Level or Pan keyframe navigation button to move the playhead to
the next keyframe to the left or right of the playhead.

µ
µ

Press Option-K to move the playhead to the next keyframe to the left of the playhead.
Press Shift-K to move the playhead to the next keyframe to the right of the playhead.
To adjust the level or pan value of a single keyframe
Do one of the following:

µ

Move the playhead to the keyframe you want to adjust, then drag the appropriate slider
to a new value.

Chapter 57 Mixing Audio in the Timeline and Viewer

931

µ

Move the playhead to the keyframe you want to adjust, type a new value in the
appropriate field, and press the Return key.

µ

Move the pointer over the keyframe you want to modify. When the pointer becomes a
crosshair pointer, drag the keyframe you want to modify.
• Dragging an audio level keyframe up raises the audio level; dragging down lowers it.
As you drag, a box shows you the current level of the keyframe.
• Dragging a pan keyframe up moves the audio toward the left stereo output channel;
dragging down moves it to the right stereo output channel. As you drag, a box shows
you the pan setting of the keyframe.
• Dragging a pan keyframe for a stereo pair vertically in the waveform display area
transposes the left and right channels of a stereo pair.

µ

To adjust a section of an overlay in the middle of four keyframes
Move the pointer over the section you want to adjust. When the pointer turns into the
Adjust Line Segment pointer, drag the section up or down to modify it. The rest of the
overlay before and after the four keyframes remains untouched.

Adjust Line Segment
pointer

µ
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To move a keyframe forward or backward in time
Place the pointer over the keyframe you want to modify. When the pointer becomes a
crosshair pointer, drag the keyframe forward or backward along the overlay.
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As you drag, a box displays the timecode duration of the change you’re making.
Keyframe being moved

To delete a keyframe
Do one of the following:

µ

Control-click the keyframe you want to delete, then choose Clear from the shortcut menu.

µ

Move the playhead to the position of the keyframe you want to delete, then click the
Level Keyframe or Pan Keyframe button to delete the keyframe.

µ

Place the pointer over the keyframe you want to delete. When it becomes a crosshair
pointer, drag the keyframe up or down out of the waveform display area. When the
pointer turns into a small trash can, release the mouse button.

Release the mouse
button when the pointer
becomes a trash can.

Chapter 57 Mixing Audio in the Timeline and Viewer

933

µ

Hold down the Option key and position the pointer over an existing keyframe. The pointer
turns into the Delete Point tool. Click an existing keyframe with the Delete Point tool to
delete that keyframe.
With the Delete Point
tool, click the keyframe
you want to delete.

µ

To delete all keyframes
Click the Reset button.
Reset button

All keyframes (both audio level and pan) are deleted, and the audio level of your clip is
reset to 0 dB.

Using Keyframes to Adjust Audio Levels
You need at least two keyframes to make any dynamic change from one audio level to
another in a clip.
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In the example above, the section of the clip to the left of the keyframes has a level of
–30 dB, and the rest of the clip to the right of the keyframes has a level of 0 dB. This is
the simplest type of level change you can make.
A more sophisticated change in levels—for example, introducing a slight boost in the
level of a few notes in a music track—requires three keyframes.

In the example above, the audio level of the clip starts at –3 dB and then rises along a
curve, peaking at +6 dB on the note that’s playing at that point. The audio level then
lowers along another curve, ending back at –3 dB.
Three keyframes allow you to boost or attenuate (lower) a section of audio along a curve,
but to make less gradual changes to longer sections of audio, you’ll need to use four.

In the example above, the audio level, instead of rising or lowering constantly, changes
from –3 dB to -26 dB during the first two keyframes and then remains constant. The final
two keyframes boost the level back to –3 dB, where it remains for the duration of the
clip.

Example: Using Keyframes in the Timeline to Automate Audio Levels
Suppose you’ve edited a music clip and a clip with voiceover narration together in your
sequence.

Chapter 57 Mixing Audio in the Timeline and Viewer

935

There are long pauses between the narrator’s lines, during which you want the music to
be the dominant audio track. So you set the overall level of your music to -4 dB, because
that’s the level at which the audio sounds best between the narrator’s lines. When the
narrator speaks, however, you want the level of the music to drop so it doesn’t compete
with the narrator for attention.
If you hold down the Option key (while the Selection tool is selected) and click the audio
level overlay of the music clip with the Pen tool, you can place groups of four keyframes
at each place where a line is spoken by the narrator.

Keyframes set

Then, releasing the Option key, you can drag the area in the middle of each group of four
keyframes down, to lower the level of the music while the narrator speaks.

Lowered level
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Finally, you’ll want to move the outside pair of each group of four keyframes outward a
bit, so the volume of the music doesn’t change too abruptly and startle the audience.
Less-steep slopes between keyframes result in more gradual fades from one audio level
to the next.

Adjust the slope of
the level change.

Example: Setting Subframe Audio Keyframes to Eliminate Clicks
Sometimes, when you find the perfect edit point for cutting a clip into your sequence,
you’ll notice a pop or click in the audio. This happens when you make a cut on an awkward
sample that just happens to occur at a frame boundary.
You can eliminate pops and clicks by setting keyframes for your audio levels to within
1/100 of a frame. Usually, changing an audio edit point by just a few hundredths of a
frame eliminates the clicking.
To set and adjust subframe audio level keyframes
1 Open the clip in the Viewer and click the Audio tab.
2 Move the playhead to the edit point that’s causing the click by pressing Shift-I or Shift-O,
or by using the Up Arrow and Down Arrow keys to move from one sequence edit point
to the next.
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3 Zoom in to the clip as far as possible.

When you’ve zoomed in
all the way, the playhead
in the Viewer is the width
of one video frame.

4 Hold down the Shift key as you drag the playhead to the exact place where the click
occurs.

5 Click the Level Keyframe button and reposition the playhead to place two keyframes at
the beginning of the click and two keyframes at the end of the click.

938

Chapter 57 Mixing Audio in the Timeline and Viewer

The two inner keyframes surround the problem samples, and the two outer keyframes
are placed a few hundredths of a frame outside of these.

The problem samples

6 Drag the part of the audio level overlay between the two inner keyframes down until the
box indicates –60 dB.

The overlay looks
something like this.

The unwanted noise should be gone, and the rest of your clip’s audio is not affected.

Example: Using Keyframes to Control Pan
Setting keyframes to change pan dynamically works the same way as setting keyframes
to change levels dynamically. You need to set at least two keyframes to effect a change
over time.
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Changing pan over time is often done to achieve stereo effects such as making a car
sound zoom from left to right, or putting a particular sound effect on one side or the
other of a stereo image. If you want the car sound effect in your edited sequence to zoom
from the left to the right to match the movement of an onscreen car, here are the steps
you would take.
To set up a dynamic stereo pan using keyframes
1 Open the car sound effect in the Viewer so you can see it in more detail.

2 Move the Viewer playhead to the beginning of the car sound effect’s waveform, right
before the car sound starts playing, and click the Pan Keyframe button to set a keyframe.
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3 Drag the Pan slider all the way to the left, so that the sound starts playing out of the left
speaker.

4 Now, move the playhead to a position after the car sound effect has finished playing.
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5 Drag the Pan slider all the way to the right, so that the sound ends playing out of the
right speaker. Because you’ve already set a keyframe for this clip, dragging the Pan slider
at another point in the clip automatically produces a new keyframe.

When you play back the clip, you’ll hear the car sound move from left to right.
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Using the Voice Over Tool

58

This chapter covers the following:
• About the Voice Over Tool (p. 943)
• Setting Up Your Computer to Record Voiceover (p. 944)
• RAM Requirements When Using the Voice Over Tool (p. 947)
• Controls in the Voice Over Tool (p. 947)
• Defining the Recording Duration and Destination Track (p. 950)
• Recording a Voiceover (p. 955)
The Voice Over tool lets you record a single audio track directly into a sequence while
you watch it. You can use the Voice Over tool to record narration, Foley effects, or any
other single-channel audio source.

About the Voice Over Tool
The Voice Over tool records directly to an audio track in the Timeline between the
sequence In and Out points. To get audio into Final Cut Pro, you can use any
Mac OS X-compatible audio interface connected to your computer’s PCI slot, FireWire
port, or USB port. You can also use the built-in audio input on your computer. While you
record, you can monitor the sequence audio using the selected playback audio device.
For more information about selecting an audio device for output, see “Configuring External
Audio Monitors.”
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About Microphones and Room Noise
The quality of your sound recording is dependent on the quality of the microphone and
preamplifier used. A microphone converts (or transduces) sound to electricity, and the
preamplifier (or preamp) boosts the tiny microphone level to line level for recording.
Condenser microphones are much more sensitive than dynamic microphones and are
usually best for voice recordings. Condenser microphones require power to operate,
whereas dynamic microphones do not. Some condenser microphones can use batteries
to provide the necessary power, and most preamplifiers can also provide “phantom
power” to the microphone via an XLR connector and cable.
Preamps are often selected because of the way they “color” the sound of the microphone,
emphasizing some frequencies over others. Analog tube preamplifiers are often used for
their warm, full sound.
Condenser microphones are usually more expensive than dynamic microphones, but
they make a big difference in vocal recordings.
A good voiceover recording requires an extremely quiet acoustic environment. Air
conditioning, noise from outside, and room reverberation can all be potential problems.
Most voiceovers are recorded in a professional studio or voiceover booth to minimize
noise.

Setting Up Your Computer to Record Voiceover
You can set up your computer to use the Voice Over tool in a studio, or you can set up
a portable computer so you can record in the field. The process for setting up your
computer to record voiceover is described in the following sections.
• Stage 1: Installing or Connecting an Audio Interface
• Stage 2: Connecting a Microphone and Microphone Preamplifier
• Stage 3: Opening the Voice Over Tool and Choosing Audio Input Settings
• Stage 4: Choosing an Audio Track and Duration for Your Voiceover
• Stage 5: Determining the Offset of Your Audio Interface
• Stage 6: Plugging In Your Headphones
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Stage 1: Installing or Connecting an Audio Interface
An audio interface can be your computer’s built-in audio port, a PCI audio card, a USB
audio device, or a DV camcorder connected via FireWire. Regardless of which audio
interface you use, it must be compatible with Mac OS X. Once your recording device is
connected, the Voice Over tool automatically detects it and adds it to the list of devices
in the Source pop-up menu. (If you connect a USB audio device, it can take up to
10 seconds for Final Cut Pro to detect it.)
Microphone

Headphones

Microphone
input

Headphone
out

USB
USB audio
interface

Portable computer

Important: If you select a DV camcorder as your recording device and External Video is
enabled in the View menu, a message appears saying that you cannot record using DV
audio. Before you can record, choose View > External Video > Off.

Stage 2: Connecting a Microphone and Microphone Preamplifier
Some audio interfaces have microphone preamplifiers built in. For more information, see
the documentation that came with the audio interface.

Stage 3: Opening the Voice Over Tool and Choosing Audio Input Settings
You need to set up the Voice Over tool to correspond to the audio equipment you’ve
connected.
To select an audio input in the Voice Over tool
1 Choose Tools > Voice Over.
2 Choose your audio interface from the Source pop-up menu.
3 Choose the audio interface input your microphone is connected to from the Input pop-up
menu.
4 Choose a sample rate that matches your sequence sample rate.
To determine the audio sample rate of your sequence, see “Sequence Settings and Presets.”
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Note: When recording, the Voice Over tool works with the Sound Manager to record in
mono mode. When you choose the audio interface input for a stereo input device, the
Voice Over tool uses only the left input channel (channel 1) of a stereo input device when
recording; the right channel is ignored. Recorded Voice Over clips, when placed on a
track assigned to a mono output bus, appear and sound at the same level as the Voice
Over recording meter displayed. However, recorded Voice Over clips, when panned to
the center on a stereo output bus, appear and sound 6 dB lower than the Voice Over
recording meter displayed.

Stage 4: Choosing an Audio Track and Duration for Your Voiceover
In the Browser, select and open the sequence to which you want to add a voiceover, then
set In and Out points where you want the voiceover to begin and end. For more
information about setting the recording duration and the destination audio track, see
“Defining the Recording Duration and Destination Track.”

Stage 5: Determining the Offset of Your Audio Interface
Every digital recording device has some latency from the time audio enters the microphone
to the time it’s processed. This latency can cause your narration to be offset by a few
frames from your video. You can adjust this offset in the Voice Over tool so that your
audio is recorded exactly in sync with your sequence. In general, USB audio interfaces
have an offset of one frame and DV camcorders have an offset of three frames. Other
interfaces may have different offsets.
To determine the offset of your audio recording device
1 In the Timeline, set the In point of your sequence at 10 seconds, then set the Out point
at 20 seconds.
2 Hold the microphone that’s connected to your audio recording device to the speaker of
your computer.
3 Choose Tools > Voice Over, then click the Record button.
(What you’re doing is recording the audio cue beeps that your computer plays back.)
Recording stops automatically and this new audio clip is placed in the Timeline.
4 In the Timeline, drag the end of the newly recorded audio clip to the right to show the
last 2 seconds of the audio recorded after the Out point.
5 Compare the position of the first frame of the final cue beep’s waveform to the position
of the Out point in the Timeline.
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To show or hide the audio clip’s waveform in the Timeline, press Command-Option-W.
20-second point

First frame of the ending
beep that occurs two
frames later

6 If there’s a difference, add this number of frames to the offset already selected, then
choose this new number from the Offset pop-up menu.
Alternatively, you can move the clip after recording it to compensate for latency.

Stage 6: Plugging In Your Headphones
Connect your headphones to the headphone port of your computer, and you’re ready
to start recording.

RAM Requirements When Using the Voice Over Tool
The Voice Over tool stores audio in RAM during recording and then writes the audio data
to the currently specified scratch disk. Make sure your system has enough RAM to
accommodate the duration of your recording. The following chart shows some sample
lengths for audio clips created with the Voice Over tool and the amount of additional
memory required.
Clip length

Memory required (approximate)

30 seconds

3 MB

1 minute

6 MB

5 minutes

30 MB

10 minutes

60 MB

30 minutes

180 MB

Controls in the Voice Over Tool
The Voice Over tool appears as a tab in the Tool Bench window.

µ

To open the Voice Over tool
Choose Tools > Voice Over.
The Tool Bench appears with the Voice Over tab.
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Tip: If you want to organize the arrangement of windows, choose Window > Arrange >
Color Correction. This places the Viewer, Canvas, and Tool Bench on the top part of the
screen as windows of equal size, and the Browser and Timeline on the bottom part of
the screen.
Review button
Record/Stop button

Discard Last Recording button
Status area
Audio destination track
and audio clip name
Input area

Headphones area

Playback and Recording Controls
The Voice Over tab offers the following playback and recording controls:
• Record/Stop: Click this button to begin the audio recording and Timeline playback.
While you’re recording, the button functions as a Stop button. Recording can also be
stopped by pressing the Esc key. If recording is stopped, the partial audio clip that was
recorded is saved to disk and placed in the Timeline.
• Review: Click this button to play back the section of the sequence you’ve defined, using
the sequence In and Out points or the position of the playhead and the end of your
sequence. This lets you preview the defined range of the Timeline while you practice
your voiceover.
• Discard Last Recording: Click this button to delete the previously recorded voiceover
clip. (This button is available only after you’ve used the Voice Over tool once.)
Important: Discarding cannot be undone.
Status Area
The following options appear in the Status area:
• Ready to Record: Indicates that the Voice Over tool is ready and waiting to be activated.
• Starting: Appears along with a progressive change in color from yellow to red during
the 5-second countdown that occurs when you first click the Record button. Audio is
actually recorded during the countdown, and the resulting clip has a 5-second handle
at the beginning.
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• Recording: Appears once you’ve started recording in the Timeline. While you’re
recording, the status area is red. Fifteen seconds before the end of your recording, you
are cued with a single audible beep. During the last 5 seconds of recording, the status
area displays a countdown from 5 to 0, accompanied by five beeps, to let you know
when the recording time is up.
• Finishing: Appears once playback comes to the end of the defined area of the Timeline.
Recording continues 2 seconds past the end of your specified Out point to prevent
your last word from being cut off.
• Saving: Appears after recording, when your clip is being saved from RAM to the currently
specified scratch disk.
Audio File Area
The following options appear in the Audio File area.

• Target: This line displays the sequence name and track number where audio recorded
with the Voice Over tool will be placed. As subsequent takes are recorded, the audio
destination track automatically moves down to the next available track.
• Name: This text field displays the name that will be used for the recorded media file
on disk. To change the audio clip name, click in this field, then enter the desired name.
As subsequent takes are recorded, this name is automatically appended with numbers.
For example, the default name of Voice Over changes to Voice Over 1 after you record
your first voiceover clip.
If the name in this field is already in use by another clip on the selected scratch disk,
an appropriate take number is automatically appended to the name. For example,
Narration is changed to Narration 1.
Input Area
The following options appear in the Input area.

• Level: This audio meter displays the input audio levels coming in via the chosen audio
interface device.
• Source: This pop-up menu lets you choose a connected Mac OS X-compatible audio
device to record your audio. For example, if you’re using a microphone connected to
an audio interface, you choose the audio interface here.
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• Offset: This pop-up menu allows you to correct for audio signal latency (delay), which
is inherent in all digital audio interfaces. Even though your voiceover performance may
be perfect, latency can cause the recorded audio to be slightly offset from the video.
Different digital audio capture devices have different amounts of latency. Typically,
most USB capture devices have a latency of one frame; most DV camcorders have a
latency of three frames.
• Input: If the audio input device you’re using has multiple inputs, this pop-up menu lets
you choose which one you use to record. If there are multiple audio devices you can
use, Final Cut Pro remembers the input you choose for each device, if you change
devices. Audio input selections made in the Voice Over tool do not affect your selected
capture preset.
• Rate: This pop-up menu lets you choose an audio sample rate supported by the audio
device selected to record your voiceover clips. It’s best to choose the audio sample rate
used in your sequence. If the selected audio device cannot support your sequence’s
sample rate, choose the next closest available sample rate. For example, if your sequence
is set to 48 kHz but your audio device doesn’t support that sample rate, choose 44.1 kHz.
• Gain: This slider allows you to adjust the recording level used by the Voice Over tool.
Headphones Area
The following options appear in the Headphones area.

• Volume: Use this slider to adjust the level of audio that plays through the headphone
port while the Voice Over tool is recording. You can also enter a value, in decibels (dB),
in the field next to the slider.
• Sound Cues: Select this checkbox to hear audible beeps that indicate the status of
recording. These include beeps at the 3-second starting phase of recording with the
Voice Over tool, and at 5 seconds prior to the end of the defined range for recording.
These sound cues play through the headphone port and are not recorded as part of
the voiceover clip.
Note: To prevent the recording microphone from picking up audio from your program,
use a pair of headphones to monitor your program’s audio when using the Voice Over
tool. Otherwise, set the Volume slider to –60 dB and deselect the Sound Cues checkbox.

Defining the Recording Duration and Destination Track
Before using the Voice Over tool, you need to specify the duration you’re recording and
the destination audio track (where clips recorded with the Voice Over tool will be placed
in your sequence).
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Setting the Recording Duration
You can define the recording duration by setting In and Out points or positioning the
playhead.
• If both In and Out points are set in the Timeline: They define the duration of the recording.
(This is the easiest method.)

• If no In point is set: The position of the playhead defines the In point, and recording
continues to the Out point.
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• If no Out point is set: The end of the sequence is used, defined by the end of the last
clip in the Timeline.

If Final Cut Pro doesn’t have enough available memory to record the duration specified,
a message appears when you click the Record button in the Voice Over tab, prompting
you to set a shorter recording duration.
Important: Depending on the duration specified, the sync of audio recorded using the
Voice Over tool may drift slightly in relation to your sequence’s other audio clips. This
varies depending on your audio interface and may be approximately one frame every
10 minutes. For the short clips you typically record as part of a narration track, this drift
won’t be noticeable.

Defining the Destination Track
Audio that you record using the Voice Over tool is placed in the audio track connected
to the a2 Source control.
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The following example shows a sequence with one video track and three audio tracks.
A video montage is edited into track V1, with accompanying music edited into tracks A1
and A2. To record to track A3, you need to connect the a2 Source control to the track A3
Destination control.

Before

Connect the a2 Source
control to the A3
Destination control.

After

The newly recorded audio clip
is placed in track A3.

If the track connected to the a2 Source control already contains audio, audio recorded
with the Voice Over tool is placed in the audio track directly below. If no audio track
currently exists below the track connected to the a2 Source control, one is created.
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In the next example, all three audio tracks already have audio edited into them, and the
a2 Source control is connected to track A3. After using the Voice Over tool, a new track
A4 is created, and the new audio clip is placed there.

Before

After

The newly recorded
audio clip

If another audio clip is already present in the audio track below the track connected to
the a2 Source control, a new audio track is inserted below this track. All previously existing
audio tracks below this are moved down to accommodate the new audio track.
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In the example below, tracks V1, A1, and A2 contain the video and audio for an interview
clip. Tracks A3 and A4 contain a stereo music clip. Suppose you connect the a2 Source
control to track A2. After using the Voice Over tool, a new audio clip is created and placed
in track A3, and the music clip is moved to tracks A4 and A5.

Before

After

The newly recorded
audio clip

Recording a Voiceover
After you’ve set up your microphone and audio interface, and the recording duration
and destination audio track are defined, you can record your voiceover. If you aren’t
satisfied with your first voiceover clip, you can record multiple takes.

Recording a Voiceover Clip
The Voice Over tool provides a number of timing cues and status messages to help you
record your voiceover.
To record a voiceover (or any other single-channel audio source)
1 Choose Tools > Voice Over.
In the Voice Over tab, the status area is green and displays “Ready to Record.”
2 Click the Record button in the Voice Over tab.
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Once you do this, several things happen before your clip is placed in the Timeline.
• Any audio within the defined duration of your sequence that requires rendering is
rendered.
• The playhead moves back 5 seconds before the specified In point, and a 5-second
pre-roll plays to prepare you for recording.
The last 3 seconds of this pre-roll are indicated by beeps to give you a timing cue. Also,
the entire duration of the pre-roll is indicated by a countdown to 0, along with a
progressive change in color from yellow to red in the status area. Even though this
countdown happens before the duration you’ve specified in the Timeline, audio is
recorded during this pre-roll to avoid cutting off the first word you say.
Note: During the 5 seconds of pre-roll, audio that occurs before the beginning of the
Timeline cannot be recorded.
3 Once the pre-roll has played, begin your voiceover.
The following things occur as your voiceover is recorded and saved:
• The status area is red and displays “Recording” to indicate that you’re recording; a bar
graph shows you how much of the specified duration still needs to be recorded.
• Fifteen seconds before the end of your recording, you are cued with a single warning
beep.
• During the last 5 seconds of recording, the status area displays a countdown from 5 to
0, and you hear five beeps to let you know your time is nearly up. The last beep is
longer and has a lower pitch.
• Recording continues 2 seconds past the end of your specified Out point to prevent
your last word from being cut off. During this time, the status area displays “Finishing.”
• The status area displays “Saving” while the audio clip is saved to the specified scratch
disk.
• Finally, the recorded clip is automatically edited into your sequence and the status area
displays “Ready to Record.”
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Recording Multiple Takes
Each time you record a clip using the Voice Over tool, the a2 destination track automatically
moves down one track. You can record multiple takes, one after the other, with the same
specified duration in the Timeline. These new audio clips are placed beneath the one
previously recorded. Recording multiple takes this way results in a stack of alternative
takes, lined up at the same In point of the sequence. This lets you edit the best parts of
multiple takes together to assemble one perfect performance.

Multiple takes of the
same voiceover

Note: When recording is finished, the newly recorded audio clip is automatically selected.
If you want to record another take, press Control-B to disable the newly recorded audio
clip so it won’t play back.
You rarely record your voiceover track in a single take, especially if it includes long stretches
of narration. Instead, you may record several takes of a voiceover track and then edit
together the best parts of each take to create your final voiceover track. You can also
isolate parts of the first take that you don’t like and rerecord just those parts.
For example, suppose you were trying to record a long piece of narration. Instead of
rerecording the same clip over and over in an attempt to get a single perfect take, record
your first take. If there is any part of it you don’t like, simply set new In and Out points
isolating that section of your recording. Then record another clip in which you narrate
just that part.
Eventually you’ll have a few different takes, each with a sentence or two from different
sections of your narration that you like the best. Combining all of the best parts of these
various takes lets you get the best overall performance for your program.
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About Audio Recorded with the Voice Over Tool
Audio is recorded during the pre- and post-roll period each time you use the Voice Over
tool, giving you extra audio for trimming at the head and tail. Each clip has a 5-second
handle at the head and a 2-second handle at the end. By definition, handles do not appear
in the sequence clip, but they are visible if you open the clip in the Viewer. In the Viewer,
you’ll see that the In and Out points for that clip match the beginning and end of the
specified recording duration. The extra handles are there if you need to extend the clip
head or tail.
Placed in Timeline

5-second
pre-roll
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In point
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Out point

2-second
post-roll

Using Audio Filters
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This chapter covers the following:
• Overview of Audio Filters (p. 960)
• Equalization Filters (p. 962)
• Gain Filter (p. 964)
• Compressor/Limiter Filter (p. 965)
• Expander/Noise Gate Filter (p. 966)
• Noise Reduction Filters (p. 966)
• Echo and Reverberation Filters (p. 968)
• Applying Filters to an Audio Clip (p. 969)
• Displaying Filter Keyframes in the Timeline (p. 971)
• Modifying and Removing Filters (p. 973)
• Automating Audio Filter Parameters with Keyframes (p. 974)
• Making Real-Time Audio Filter Adjustments (p. 978)
• Saving a Filter or Transition as a Favorite (p. 980)
• Installing Third-Party Audio Units Filters (p. 981)
Audio filters are used for a variety of purposes, from audio cleanup to special effects. Filter
parameters can be copied, pasted, automated, and adjusted in real time.
The goal of audio mixing and processing is to create a believable sonic environment that
is not distracting. Audio filters can help to remove distracting frequencies, reduce loud
sounds, and add ambience to a sonic space. Generally, filters are much better at removing
components of a mix than they are at adding something that wasn’t in the original
recording. An audio engineer with a thorough understanding of how sound works and
how filters affect sound can produce excellent results with just a few equalizer and
compression filters.
Final Cut Pro includes a set of audio filters that you can use for equalization, compression
and expansion, adding reverb, vocal cleanup, and noise removal. Final Cut Pro uses the
Mac OS X Audio Units plug-in format.
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Audio filter parameters can be adjusted in real time so you can make changes to a filter’s
settings while the clip plays back. When keyframe recording is turned on in the Audio
Mixer, Final Cut Pro records all changes you make to audio filter parameters as keyframes;
those keyframes appear in the parameter’s keyframe graph in that clip’s Filters tab in the
Viewer. For more information, see “Automating Audio Filter Parameters with Keyframes.”

Overview of Audio Filters
Filters in Final Cut Pro are always nondestructive, meaning they are applied to clips but
not to the media files themselves. You can disable or remove filters at any time, so you
can experiment without worrying about altering your media.
The most useful Final Cut Pro audio filters can be separated into five broad categories:
• Equalization (EQ)
• Gain and normalization
• Dynamics (compression and expansion)
• Noise reduction
• Echo and reverberation
Note: You can install additional third-party Audio Units plug-ins as needed.
Filter parameters can be viewed and adjusted in the Filters tab of the Viewer. Apply an
audio filter to an audio clip, then click the Filters tab. You can also double-click a filter in
the Effects tab to view its parameters in the Viewer, but you won’t be able to hear any
changes you make because the filter is not applied to a clip. For more information about
applying filters and adjusting parameters, see “Applying Filters to an Audio Clip” and
“Making Real-Time Audio Filter Adjustments.”

960

Chapter 59 Using Audio Filters

Filters can be added to any audio clip in a project. You can add filters individually or in
groups. When you add filters to a clip, they appear in the Filters tab of the Viewer when
that clip is opened in the Viewer. How they appear depends on whether the audio clip
in the Viewer is a stereo pair.
• If the audio clip in the Viewer is a stereo pair: Every filter you add is applied to both
channels equally, and only one set of controls appears.

• If the audio clip in the Viewer is not a stereo pair: Every filter you add is applied to both
channels, but each channel can have individual settings.

All filters have several controls in common.
Enable/Disable checkbox
and name of filter

Parameter disclosure triangle

Show/Hide Keyframes
pop-up menu

Reset button

• Parameter disclosure triangle: This allows you to show or hide a filter’s parameters.
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• Enable/Disable checkbox: This allows you to enable or disable filters without removing
them from the clip. You can use it to disable filters temporarily to preview a different
filter.
• Show/Hide Keyframes pop-up menu: This pop-up menu is in the Name bar, under the
Nav column. Use this pop-up menu to turn on or off the display of keyframes that
appear in blue at the top of the keyframe graph area. You can display keyframes for
an individual parameter or keyframes for a combination of parameters.
• Reset button: Resets a filter’s settings to the default values.
Each filter also has a unique set of controls. These controls usually include sliders and
number fields that let you adjust the filter’s parameters.

Sliders

Number fields

Equalization Filters
An audio equalizer allows you to increase or decrease the strength of an audio signal
within selected frequency ranges, or bands. For example, a three-band equalizer may
have a gain control for the lows, midrange, and highs, so you can change the sonic “shape”
of a sound by turning up some frequencies or reducing others. In general, it is much
better to subtract frequencies than to amplify them, as this eliminates the possibility of
distortion.
If you find that a sound is lacking “brilliance,” or high-end frequencies, try filtering out
some of the bass or midrange frequencies. The overall effect is that the high-end
frequencies are stronger than the lower-range frequencies. It’s easy to go too far when
amplifying some frequencies, so get in the habit of reducing frequencies first. Particular
kinds of sound—men’s voices, women’s voices, tape hiss, and traffic noise—all appear
at different frequencies of the audio spectrum. Equalization (EQ) filters can be used for
many things, from minimizing background noise in a recording to accentuating a narrator’s
voice over background music. EQ filters can also create effects like making a voice sound
as though it were coming through a telephone or loudspeaker (this is because telephones
and loudspeakers generally don’t reproduce the high and low frequencies, only the
midrange).

Frequency Ranges and Equalization
The entire range of human hearing, from 20 Hz to 20,000 Hz, can be broken into a spectrum
of frequency bands: low, midrange, and high.
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Note: Different devices define these ranges differently; the following ranges are
approximate.
Low Frequencies
Low frequencies range from approximately 20 Hz to 250 Hz. Audible bass frequencies
start around 20 Hz, though many speakers cannot reproduce frequencies this low. This
is an example of how audio meters can be deceiving, because the meters may show very
high signals but the speakers are not capable of making sounds that low. The lowest
frequencies are felt as well as heard and require the most power to amplify. Often,
subwoofer speakers are used just to handle the low frequencies in the mix (the 0.1 channel
in a 5.1-channel surround sound mix is a dedicated low-frequency effects channel).
If you are trying to increase the impact of sounds like kick drums or explosions, add gain
around 30 Hz or so. Filtering out 60-80 Hz removes a lot of low-end noise and rumble
from wind or microphone handling. Between 150 and 250 Hz, you can add “warmth” to
the audio signal (or subtract it).
Midrange Frequencies
Midrange frequencies range from approximately 250 Hz to 4000 Hz. Humans are most
sensitive to this part of the audio spectrum. Most of the frequencies that make speech
intelligible are in this range. You can make audio tracks stand out more in the mix by
subtly increasing the frequencies in this range. At the top of this range, around 4 kHz, is
where vocal sibilance occurs. Too much sibilance can be grating, but a little bit can make
the voice sound crisp and detailed. If your track has too much sibilance, try reducing the
4 kHz range.
High Frequencies
High frequencies range from approximately 4000 Hz to 20,000 Hz. The high end of the
frequency spectrum adds “brightness” or “brilliance” to a mix but does not affect factors
such as impact (bass) or speech intelligibility. High-end frequencies can be grating, so
don’t boost these frequencies too much.

Using Equalization Filters in Final Cut Pro
The following equalization filters are included with Final Cut Pro:
• 3 Band Equalizer
• Band Pass Filter
• DC Notch
• High Pass Filter
• High Shelf Filter
• Low Pass Filter
• Low Shelf Filter
• Notch Filter
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• Parametric Equalizer
All of the Final Cut Pro EQ filters use a combination of three controls. For example, the
Parametric Equalizer filter contains the following controls.

• Frequency: This slider lets you select the audio frequency you want to boost or attenuate.
The lowest available frequency varies from 10 Hz for the High Pass filter to 80 Hz for
the 3 Band Equalizer. The highest available frequency for all EQ filters is 20,000 Hz.
• Q: This slider adjusts the bandwidth of the filter resonance, whose frequency value has
been set with the Frequency slider.
• Gain: This setting controls how much you’ll be boosting or attenuating the specified
frequency range.

Gain Filter
Unlike other audio filters in Final Cut Pro, the Gain filter is applied automatically to selected
clips when you use the Apply Normalization Gain command.
Audio normalization amplifies an audio clip based on its peak (or loudest) value. For more
information about how to use audio normalization, see “Raising Audio Levels Using Audio
Normalization and Gain.”
The Gain filter has a single parameter (also called Gain) measured in decibel (dB) units.
When the Gain parameter value is positive, the clip audio is amplified. When the Gain
parameter value is negative, the clip’s audio is attenuated. A Gain value of 0 has no effect.
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Compressor/Limiter Filter
An audio compressor reduces dynamic range by attenuating parts of a signal above a
certain threshold. Compression is a very important tool because most listening
environments (movie theaters, home stereos, and televisions) have to compete with a
certain amount of ambient noise that must be overcome by the quietest sounds in your
mix. The problem is that if you simply bring up the level of your audio mix to make the
quiet sounds louder, the loud sounds get too loud and distort. By reducing the level of
the loud sounds, you can increase the overall level of the mix, resulting in higher levels
for the quiet parts of the mix and the same levels for the loud parts.

Before compression

After compression

A compressor monitors the incoming audio signal and reduces the signal by a specified
ratio whenever the signal is too strong (as determined by the threshold). Any audio signal
below the threshold is unaffected. Because louder parts get quieter and quiet parts stay
the same, the overall difference between quiet and loud sounds is reduced.
The Final Cut Pro Compressor/Limiter filter allows you to adjust the dynamic range of an
audio clip so that the loudest parts of a clip are reduced while the quieter parts remain
the same.
The Compressor/Limiter filter has five controls.

• Threshold: This parameter defines how loud the signal must be before the compressor
is applied. This is the most important setting you need to adjust.
• Ratio: This slider determines how much compression is applied. Don’t overdo the
compression; a little goes a long way. Too much compression can reduce the dynamic
range to a flat, unvarying signal.
• Attack Time: This setting determines how quickly the filter reacts to changes in audio
level (the default is usually acceptable, but you may want to experiment).
• Release Time: This setting defines how slowly the filter lets go of the change in audio
level that it made (again, the default should work well, but feel free to experiment).
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• Preserve Volume: This setting raises the level of the entire clip by a uniform amount to
compensate for the attenuation of the clip caused by compression.

Expander/Noise Gate Filter
An expander increases the dynamic range of an audio signal by attenuating (reducing
the gain of ) the signal when it drops below a certain level (the threshold). This has the
effect of making relatively quiet portions of the audio signal even more quiet
proportionally, so the difference between the loud and quiet parts of the audio are
increased.
An expander makes quieter portions of audio even quieter by decreasing the audio level
if it drops below a specified level. The lower a level is relative to the specified audio level
threshold, the more it is decreased, depending on the Ratio setting. An expander with a
very high ratio value is called a noise gate and is used to make the level of all sound below
the specified audio level threshold as close to silence as possible.

Unlike a compressor, which affects the loud parts of a signal, expansion affects the quiet
parts of the signal.
• Threshold: This slider defines how low the lowest portion of the clip can be before
expansion is applied. This is the first setting you’ll adjust.
• Ratio: This slider affects how much expansion is applied to boost the signal.
• Attack Time: This slider defines how quickly the filter reacts to changes in audio level
(the default is usually fine, but you may want to experiment).
• Release Time: This slider defines how slowly the filter lets go of the change it made in
the audio level (the default is usually fine, but you may want to experiment).

Noise Reduction Filters
Final Cut Pro has three noise reduction filters for use in specific situations:
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Hum Remover
The Hum Remover lets you get rid of “cycle hum” that may have been introduced into
your audio recording by power lines crossing your cables or by a shorted ground wire in
your setup. Hum from power sources generally sounds like a low buzzing and has a
frequency that corresponds to the electrical power in your country (for example, countries
in North America use 60 Hz AC power, whereas most countries in Europe use 50 Hz power).

• Frequency: This slider lets you select the frequency of hum that this filter will attempt
to remove. Different countries use different power frequencies, so you need to specify
exactly what frequency to tune out. In general, most alternating current (AC) operates
at either 50 or 60 Hz.
• Q: This slider adjusts the filter resonance around the value of the Frequency slider.
Higher Q values result in a narrower but stronger resonance, which limits the frequencies
affected by the filter. If the important elements of your recording overlap into the
frequencies that are being filtered out, you might want to narrow the range of
frequencies affected.
• Gain: This slider lets you set how much of the signal you’re attenuating. By default, it’s
set to the maximum value of –60 dB.
• Harmonics: These options allow you to attenuate additional frequencies that may be
introduced into your signal as a result of the primary cycle hum. These frequencies are
automatically derived by the filter, and you can specify up to five.

Vocal DeEsser
The Vocal DeEsser allows you to attenuate the “ess” sounds produced by an actor with
a “sibilant” voice (that is, someone whose “ess” sounds are very pronounced), or by a
microphone that accentuates high frequencies. This filter is essentially a specialized EQ
filter that reduces, but does not eliminate, these high-frequency “ess” sound components.

Vocal DePopper
The Vocal DePopper lets you attenuate the harsh “P” sounds that result from puffs of
breath bursting into the microphone. Proper miking should prevent this in the first place,
and if you have just one or two pops, you can use keyframes to reduce the level of the
frames with the pop. (See “Example: Setting Subframe Audio Keyframes to Eliminate
Clicks.”)

Chapter 59 Using Audio Filters

967

Still, if you have a clip with a lot of pops, this filter may reduce these to an acceptable
level.

Echo and Reverberation Filters
Two of the “effects” filters you’ll use most frequently are the Echo and Reverberation
filters. You can use reverberation to add the reverberation effects of a particular acoustic
space to a sound that was recorded in isolation. Be careful not to add too much
reverberation because it muddies the clarity of the sound (especially dialogue) and, more
often than not, it can sound artificial. When possible, it’s best to rerecord dialogue in the
same, or similar, environment as the original production.

Echo filter settings

Reverberation filter
settings

Both Echo and Reverberation filter settings are described below.
• Effect Mix: This slider determines how much of the “dry,” or original, sound from the
audio clip is mixed with the affected audio. By keyframing this parameter over time,
you can make it sound as if someone were walking from far away in a room (where
there would be more reverberation) toward the microphone (where there would be
less reverberation the closer they came).
• Effect Level: This slider defines how loud the reverberation or echo effect is.
• Brightness: This slider affects the quality of the reverberation or echo. Boosting this
parameter makes the effect seem more intense.
• Feedback: This slider (Echo only) affects how long the echoes produced by the filter
last. As they repeat, they’ll interact with themselves to produce a complex series of
echo effects.
• Delay Time: This slider (Echo only) lets you determine the pause, in milliseconds, between
each echo. The longer the pause, the bigger the apparent space of the environment.
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• Type: This pop-up menu (Reverberation only) lets you specify the kind of acoustic
environment the filter attempts to reproduce.

Applying Filters to an Audio Clip
Applying audio filters to clips in Final Cut Pro is easy.
To apply an audio filter to a clip in a sequence
Do one of the following:

µ

Select one or more clips in a sequence in the Timeline, choose Effects > Audio Filters,
then choose a filter from the submenu.
The filter is applied to all the clips you selected. If you selected video clips, the filter is
applied to any audio items linked to those clips.

µ

Drag an audio filter from the Effects tab of the Browser to a clip in a sequence in the
Timeline.
If you drag the audio filter to a video clip, the filter is applied to any audio items linked
to that clip.

Drag a filter from
the Browser...
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...to the Timeline.
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µ

If a sequence clip is open in the Viewer, you can:
• Choose a filter from the Audio Filters submenu of the Effects menu. The filter is applied
to the clip in the Viewer.
• Drag a filter from the Effects tab of the Browser directly to the Viewer.
If you apply more than one filter to an audio clip, the filters are applied serially. In other
words, the first audio filter is applied, and then the resulting audio signal is fed through
the next audio filter, and so on.
If you apply multiple filters to a clip, the order in which they appear in the Filters tab for
that clip in the Viewer determines how the clip sounds. Although the initial order of filters
in the tab depends on when they were applied, you can change the order at any time.
To apply multiple filters to a clip in a sequence
Do one of the following:

µ

Continue to apply more filters to the clip, one at a time, using any of the methods
described previously.

µ

Shift-click or Command-click to select multiple filters in the Effects tab of the Browser,
then drag them all to one or more selected clips in a sequence in the Timeline.
Filters are applied to clips in the order they appear in the Effects tab.

Select several filters in
the Browser...

...then drag them to
the Timeline.

Filters can also be copied, along with all of their settings, and pasted into one or more
clips in the same sequence or in another sequence.
When you copy a clip in the Timeline, you also copy all of that clip’s settings. These settings
include filters that have been applied to the clip. Instead of pasting the clip, you can paste
only that clip’s filters into other clips that you’ve selected. To do this, you use the Paste
Attributes command.
To copy filters from one clip and paste them into another
1 Select a clip in the Timeline with a filter applied to it.
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2 Copy the clip.
3 Select one or more clips in the Timeline to apply the filter to.
4 Choose Edit > Paste Attributes (or press Option-V).
5 In the Paste Attributes dialog, select these options:
• Scale Attribute Times: Shrinks or stretches the keyframes of your copied clip attributes
to fit the duration of longer clips you may paste them into.
• Audio Attributes: Determines which attributes of the audio clip are pasted.
• Filters: Applies the parameter values and keyframes you have set for all filters in the
clip you copied.

Important: Pasting attributes into clips that have different frame rates will produce
erratic results.
6 Click OK.
The filters are pasted into the clips you selected.

Displaying Filter Keyframes in the Timeline
Once a filter has been applied to an audio clip in a sequence, you can use the Clip
Keyframes control in the Timeline to show a keyframe graph area below each audio and
video track in the Timeline to view audio filters that have been applied to your clips.

µ

To view the keyframe graph area
Click the Clip Keyframes control in the lower-left corner of the Timeline.

Clip Keyframes control
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The keyframe graph area can be divided into three parts for audio tracks in the Timeline.
Keyframe editor

Audio filters bar

Speed indicator area

Keyframe Editor Resize
column allows you to
change the height of
the keyframe editor area.

• Filters bar: If a clip has one or more audio filters applied, a green bar appears in this
space for the duration of that clip. If keyframes are added to a filter in a given clip, those
keyframes appear as diamonds on this bar, where they can be edited or moved using
the Selection tool.
• Keyframe editor: The keyframe editor shows you keyframe graphs for audio filters applied
to clips in your sequence, identical to those found in the keyframe graph area of the
Motion and Filters tabs of the Viewer. You can edit the keyframes of audio filter
parameters in the keyframe editor using the Selection and Pen tools. The keyframe
editor can only display the keyframe graph of one filter parameter at a time. You can
choose the one you want to see by Control-clicking in the keyframe editor area and
choosing an audio filter parameter from the shortcut menu.
• Speed indicators: Speed indicators show you the speed of clips in your sequence using
tick marks. The spacing and color of these tick marks indicate the speed and playback
direction of your clips. For more information about viewing speed indicators while
making speed changes to clips in a sequence, see “Learning to Read Timeline Speed
Indicators.”
The keyframe graph area for audio tracks in the Timeline can be customized separately
from the keyframe graph area for video tracks.

µ
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To view the filters bar in the keyframe graph area
Control-click the Clip Keyframes control, then choose Audio > Filters Bar from the shortcut
menu.
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µ

To view the keyframe editor in the keyframe graph area
Control-click the Clip Keyframes control, then choose Audio > Keyframe Editor from the
shortcut menu.

µ

To view the speed indicators in the keyframe graph area
Control-click the Clip Keyframes control, then choose Audio > Speed Indicators from the
shortcut menu.
For more information about customizing the keyframe graph area, see “Customizing the
Keyframe Graph Area in the Timeline.”

Modifying and Removing Filters
To modify filters in a sequence, open the clip to which the filter is applied in the Viewer.
Note: Filters can be added to clips even if the clips aren’t in a sequence. If you want to
modify or remove a filter for a clip in a sequence, make sure the sequence clip is open in
the Viewer, not the master clip from the Browser.
To view a clip’s filters in the Viewer
Do one of the following:

µ
µ

If your sequence clip is already open in the Viewer, click the Filters tab.
Double-click the filters bar in the keyframe graph area of a clip in the Timeline. The clip
opens in the Viewer with the Filters tab in front.
If a sequence clip was open in the Viewer with its Filters tab in front, a new sequence clip
opened in the Viewer will also appear with its Filters tab in front.
Using the Filters tab, you can make adjustments to the parameters of individual filters.
Because filters vary widely, see “Applying Filters to an Audio Clip” for general guidelines
on how to use specific filters.
In addition to adjusting individual settings for each filter, you can also enable and disable
the filters without removing them from your clip, rearrange their order to modify their
effects, and remove them from your clips.

µ

To enable or disable a filter
Select or deselect the checkbox by the filter name in the Filters tab. If you deselect the
checkbox, the filter is disabled but not removed from the clip. This is a useful way to
preview different combinations of filters without constantly applying and removing the
same filters.
Because filters are applied serially, if you apply multiple filters to a clip, the order in which
they appear is very important. (See “Applying Filters to an Audio Clip.”)
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µ

To change the order of filters
Drag a filter in the Filters tab to change its place in the list of filters applied to a clip.
Note: To make it easier to drag the filter, click the disclosure triangle to the left of the
filter’s name to hide the filter’s parameters.
To remove a filter from a clip
Do one of the following:

µ

With a clip open in the Viewer, select a filter in the Effects tab, then choose Edit > Clear
(or press the Delete key).

µ

Click the filter category bar in the Filters tab to select all of the filters applied to a clip,
then choose Edit > Clear (or press the Delete key).

Automating Audio Filter Parameters with Keyframes
You can add keyframes for any audio filter parameter, just as you can with video filter
parameters. Unlike with video filter parameters, you can add keyframes to an audio filter
parameter during playback as long as the Record Audio Keyframes button is selected in
the Audio Mixer.

Keyframe Controls in the Filters Tab of the Viewer
To the right of each filter control is a set of keyframe controls. Like audio levels or stereo
pan, filters can be keyframed to change their effect on your clip over time.
Keyframe navigation
buttons

Keyframe graph area

Keyframe graph ruler

Keyframe graph line

Enable/Disable checkbox

Keyframe
button

Section of clip
currently used

For a detailed description of these controls, see “Viewing and Adjusting a Filter’s
Parameters.”

Adjusting Audio Filter Parameter Keyframes
You can add keyframes to audio filter parameters using the Selection and Pen tools, just
as you would for video filters.
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To set a keyframe while playback is paused
Do one of the following:

µ

Move the playhead in the keyframe graph area of the Viewer Filters tab to the time where
you want to put a keyframe, then click the keyframe button for the parameter you want
to set.
Click here to create
a keyframe for
that parameter.

µ

With the Option key held down, position the pointer over the keyframe graph line for a
parameter. When the pointer turns into a Pen tool, click to add a keyframe to the keyframe
graph line at that point.

The Pen tool lets you
add a keyframe.

The keyframe appears as a small diamond on top of the keyframe graph line.
To set additional keyframes for a parameter while playback is paused
1 Move the playhead to another point in the Filters tab’s keyframe graph area where you
want to set a keyframe.
2 Do one of the following:
• Drag the parameter slider to set a new keyframe with that value.
• Type a number in the appropriate field to set a new keyframe at that value.
• Click the appropriate keyframe button to add a keyframe to the keyframe graph line
of that parameter at the keyframe graph line’s current value.
• With the Option key held down, click anywhere on a parameter’s keyframe graph line
with the Pen tool to add a keyframe at that point without changing the value of the
keyframe graph line at that point. You can add as many keyframes as you wish by
clicking repeatedly with the Option key held down.
The new keyframe appears as a small diamond on top of the keyframe graph line.
To record keyframes for a parameter during playback
1 In the Viewer or Timeline, move the playhead to the area of your sequence where you
want to record keyframes.
It’s a good idea to start a few seconds before the section you’ll actually be mixing, to give
yourself time to get ready.
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Note: You can only record keyframes in an audio filter parameter during playback if the
Record Audio Keyframes button is selected in the Audio Mixer.
2 Begin playback of your sequence.
3 As your sequence plays, position the pointer over the relevant audio filter control in the
Filters tab of the Viewer, and hold down the mouse button to begin adjusting that
parameter.
4 When you’ve finished making a particular adjustment, release the mouse button to insert
an additional keyframe at the position of the playhead.
The sequence continues to play.
5 If there are any other audio filter parameters you want to adjust at this time, repeat steps
1 through 4.
6 When you’ve finished making adjustments, stop playback.
To move the playhead in the Viewer from one keyframe to another
Do one of the following:

µ
µ
µ

Press Option-K to move the playhead to the next keyframe to the left of the playhead.
Press Shift-K to move the playhead to the next keyframe to the right of the playhead.
Click the left or right keyframe navigation button for a parameter to move the playhead
to the next keyframe to the left or right of the current position of the playhead.
To adjust the value of a single keyframe
Do one of the following:

µ

Move the playhead to the keyframe you want to adjust, then adjust the appropriate
parameter control to set a new value.

µ

Move the playhead to the keyframe you want to adjust, type a new value in the
appropriate field, and press the Return key.

µ

Move the pointer over the keyframe you want to modify. When the pointer becomes a
crosshair pointer, drag the keyframe up or down to change its level, or left or right to
change its location.

µ

To adjust a section of a keyframe graph line in the middle of four keyframes
Move the pointer over this section of the keyframe graph line. When the pointer turns
into the Adjust Line Segment pointer, drag just that area up or down to modify it.
The rest of the keyframe graph line before and after the four keyframes remains untouched.
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µ

To move a keyframe forward or backward in time
Move the pointer over the keyframe you want to move. When the pointer becomes a
crosshair pointer, drag the keyframe forward or backward along the keyframe graph line.

As you drag, a box displays the timecode duration of the change you’re making.
To delete a keyframe
Do one of the following:

µ

Control-click the keyframe you want to delete, then choose Clear from the shortcut menu.

µ

Move the pointer over the keyframe you want to delete. When the pointer becomes a
crosshair pointer, drag the keyframe up or down out of the keyframe graph area. When
the pointer turns into a small trash can, release the mouse button.

Trash can icon

µ

Move the playhead to the keyframe you want to delete, then click that parameter’s
keyframe button to remove the keyframe.

µ

Hold down the Option key and move the pointer over an existing keyframe. When the
pointer changes to the Delete Point tool, click an existing keyframe with the Delete Point
tool to delete that keyframe.
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µ

To delete all keyframes
Click the filter’s Reset button to clear all keyframes from all parameters for that filter and
restore the parameters to the default values.
Reset button

Making Real-Time Audio Filter Adjustments
You may find it easier to make adjustments to an audio filter while the clip it’s applied
to plays. This way, you can hear how the adjustment sounds as you modify the filter’s
parameter.
To make real-time changes to an audio filter parameter
1 In the Timeline, double-click the sequence clip with the audio filter you want to modify.
The sequence clip opens in the Viewer.
2 In the Viewer, click the Filters tab to see the clip’s audio filter parameters.
3 Move the playhead to the position in your clip where you want to make a filter parameter
change.
4 Play the sequence.
5 Adjust the controls for the audio filter parameter you want to change.
You hear your changes immediately.
6 When you’ve finished making changes, stop playback.
When you release the mouse button, your change is applied to the filter parameter.

Looping Playback While Making Real-Time Filter Adjustments
Ordinarily, playing back your sequence clip in the Viewer plays back your entire clip, from
the starting position of the playhead forward. If you instead want to loop a limited section
of your clip as you adjust a filter’s parameters, you can turn on Looped Playback, set In
and Out points to determine how much of your clip plays back, and use the Play In to
Out command to loop playback.

978

Chapter 59 Using Audio Filters

To loop a section of a clip while making real-time filter adjustments
1 With your clip opened in the Viewer, set In and Out points in the keyframe graph area of
the Filters tab.
In and Out points in the
keyframe graph area

2 In the keyframe graph ruler, move the playhead to the In point.
3 Choose View > Loop Playback to turn on looped playback.
4 To loop playback, choose Mark > Play > In to Out, or press Shift-Backslash (\).
Playback loops repeatedly between the In and Out points, and you can make real-time
changes to any audio filter parameters.
To stop playback, press the Space bar or the J key, or click the Stop button in the Canvas.

Recording Audio Filter Automation
As long as the Record Audio Keyframes button at the top of the Audio Mixer is selected,
keyframes are recorded whenever an audio filter is adjusted during playback. Automation
recording begins when you position the pointer on an audio filter control and hold down
the mouse button, and recording continues until you release the mouse button. The
number of recorded keyframes depends on which option you choose from the Record
Audio Keyframes pop-up menu in the Editing tab of the User Preferences window.
To record audio filter automation
1 Choose Tools > Audio Mixer (or press Option-6).
2 Click the Record Audio Keyframes button at the top of the Audio Mixer to turn on keyframe
recording.
Tip: You can click the Record Audio Keyframes button to turn keyframe recording on or
off during playback, if necessary.
3 With your clip opened in the Viewer, move the playhead to the place in the keyframe
graph area in the Filters tab where you want to record audio filter automation.
It’s a good idea to start a few seconds before the section you’ll be mixing, to give yourself
time to get ready.
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4 Begin playback.
5 Position the pointer over the audio filter control you want to adjust, then hold down the
mouse button to begin keyframe recording.
6 Hold down the mouse button to continue recording keyframes, and move the control
you’ve selected to adjust the audio filter parameter in real time while playback continues.
7 When you’ve finished, release the mouse button to stop keyframe recording.
The sequence continues to play, and the audio filter controls return to the previously set
levels.
8 If there are any other audio filter controls you want to adjust at this time, repeat steps 3
through 7.
9 When you’ve finished making adjustments, stop playback.
After you’ve finished adjusting one audio filter control, you can move the playhead back
to the beginning to record automation for other controls. The changes you’ve already
made play back, so that you can make further adjustments in relation to those you’ve
already set. In this way, you can continue layering automation using different audio filter
controls until you’ve adjusted the filter to your satisfaction.
Note: You can also make changes to clips with filter parameters for which you’ve already
recorded keyframes. New changes made to audio filter controls overwrite previously
recorded keyframes.

Saving a Filter or Transition as a Favorite
If you’ve customized a filter with parameter settings that you know you’ll want to use
again in the future, you can save that filter as a favorite for easy access.
To make a filter a favorite
Do one of the following:

µ

In the Timeline, select the clip that has the filter applied, then choose Effects > Make
Favorite Effect (or press Option-F).

µ

Drag the filter you want to save from the Filters tab of the Viewer to the Favorites bin in
the Effects tab of the Browser.
You can apply favorites in the same way you apply any other filter. Favorite audio filters
appear in the Favorites bin in the Effects tab, and they also appear in the Audio Filters
submenu of the Effects menu.

To delete a filter saved as a favorite
1 Select the filter in the Favorites bin in the Effects tab of the Browser.
2 Choose Edit > Clear (or press Delete).
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Installing Third-Party Audio Units Filters
If you install third-party Audio Units filters, they will be available to all applications on
your computer that are capable of using them, including Final Cut Pro. You only need to
install them in one location.
Before purchasing third-party Audio Units filters for use with Final Cut Pro, check with
the third-party manufacturer to make sure the filters are compatible. Currently,
Final Cut Pro works only with Audio Units filters that are capable of accepting mono audio
as input and can output a mono signal. Also, Audio Units filters that don’t support certain
properties required by Final Cut Pro for real-time playback may require rendering before
playback.
For information on how to install third-party audio filters, see the information that came
with the filters.
Important: If you open a project that uses a filter that is not installed on your computer,
Final Cut Pro warns you that the filter is missing. If you install the filter and open
Final Cut Pro, the warning goes away. Clips that have missing filters applied still play back
in the Timeline, but the effects are missing.
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Exporting Audio for Mixing in
Other Applications

60

This chapter covers the following:
• Ways You Can Finish Your Audio (p. 983)
• Organizing Your Audio Clips for Multitrack Export (p. 984)
• About Exporting Audio Tracks to Individual Audio Files (p. 986)
• Preparing to Export Audio Tracks as Audio Files (p. 986)
• Exporting Audio Tracks as Individual Audio Files (p. 990)
• Exporting Audio Output Groups to AIFF Files (p. 991)
• Exporting Multichannel QuickTime Files (p. 995)
• Exporting OMF Audio Files (p. 995)
• Exporting Audio Clip Information to an EDL (p. 998)
• Exporting Audio for DVD (p. 999)
If you plan to send your audio to an audio post-production facility for finishing, you can
export audio tracks to standard audio formats such as AIFF or OMF.

Ways You Can Finish Your Audio
How do you plan to finish mixing your audio? This is an extremely important question,
because it affects what you’ll do to the audio in your edited sequence. Essentially, you
have two choices:
• Complete your final mix using Final Cut Pro.
• Export your audio for sweetening at an audio post-production facility.
Although Final Cut Pro is a capable audio editing environment, having your audio done
at a specialized post-production facility means you’ll have a professional audio editor and
mixer working on your soundtrack.
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Another reason to use a post-production facility is to have your audio worked on in a
room where acoustics have been specially designed for mixing. Additionally, excellent
monitoring speakers and high-quality audio equipment allow your editor to hear
everything that’s in the audio, so you can be confident that the frequencies and levels
being adjusted in your audio are accurate.
If you decide to use an outside facility, make sure that you leave the audio in your edited
sequence alone, other than editing the audio clips you want for continuity and catching
any obvious editorial fixes, such as mispronounced words. Don’t add any filters and don’t
overedit your audio (that’s the audio editor’s job). You’ll export your edited audio tracks
so that the editors at the audio facility can import the audio into their system for further
work. Any filtering, mixing, and fine editing can be done by them.
Most editors focus on the picture and dialogue tracks of their edits and lay in scratch
tracks of music, sound effects, and Foley effects for reference. They then export audio
clip information from the Timeline along with the corresponding media files. This allows
a mixing engineer, music editor, and sound designer to “sweeten” the movie soundtrack.
There are several ways to deliver your sequence’s audio tracks for audio post-production
work. You can export:
• Each sequence track as an individual audio file
• Each channel output of your sequence as an individual Audio Interchange File Format
(AIFF) file
• A multichannel audio QuickTime file
• A self-contained Open Media Format (OMF) composition (sequence) and embedded
audio media
• An Edit Decision List (EDL) and original audio source tapes
• An AC-3 audio file for DVD
Note: For information on how to export audio for DVD, see “Exporting Sequences for
DVD.”

Organizing Your Audio Clips for Multitrack Export
As you edit audio into your sequences, it’s important to keep your tracks organized. Not
only does this make it easier for you to keep your tracks straight when you edit new clips
in, it makes your job much easier when it’s time to mix your tracks and export them.
The Audio Mixer is easiest to use when you organize the audio clips in your edited
sequences based on their type. For example, put all sync-sound dialogue clips into one
group of tracks, background ambiences in another group of tracks, sound effects in
another group of tracks, and music in a different group of tracks.
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You might put one actor’s voice in track A1, and another actor’s voice in track A2. Narration
recorded with the Voice Over tool might go in track A3. Background ambience clips such
as wind and rain might go in tracks A4 and A5. Sound effects could go in tracks A6, A7,
and A8. Finally, four tracks for overlapping stereo music clips would be dedicated to tracks
A9, A10, A11, and A12.
If you’re working on a project that may be distributed to an international audience, you
should also keep your final mix separated into D, M, and E (dialogue, music, and effects)
and stems. This allows foreign distributors to dub over the voices of your actors without
losing the music, ambience, and effects that you’ve edited into your program.
Categories of audio tracks

Description

Dialogue

This includes most of the audio that was captured with your video.
Whether or not you place each character’s lines in a separate
dialogue track is between you and your audio editor.

Voiceover

Narration should be put in a separate track from dialogue, as it
probably has different EQ settings.

Music

Stereo music from any source could use up to four tracks, if you’re
doing complicated music edits or cross fades.

Ambience

Ambient tracks include background tones, atmospheric sound
effects, and possibly room tone.

Sound effects

Effects include material from effects libraries as well as effects clips
you record yourself. If you’ve edited in Foley effects, they should
occupy a separate set of audio tracks.
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About Exporting Audio Tracks to Individual Audio Files
If you have a lot of source audio in your sequence that wasn’t captured with timecode,
or if you need to export your audio to a video system that doesn’t support OMF import,
you can export each audio track to its own audio file. These files can then be imported
into a multitrack audio application. The disadvantage of this method is that it doesn’t
preserve your edit points because all of the audio clips in each track become one audio
file. Your audio editor then has to manually edit each track to get back to the original
clips. You also cannot include handles (additional media on either side of a clip) on your
audio clips this way.

Individual audio clips
in a typical sequence

Individual audio clips
have been consolidated
into single large clips
with the duration of
the sequence.

For information about getting ready to export audio tracks as individual audio files, see
“Preparing to Export Audio Tracks as Audio Files.” For information about exporting audio
tracks, see “Exporting Audio Tracks as Individual Audio Files.”

Preparing to Export Audio Tracks as Audio Files
Before you export your sequence’s audio tracks to audio files, you should make a duplicate
of your sequence to use for the export process. This leaves your original edited sequence
untouched.
• Stage 1: Making a Duplicate of Your Sequence
• Stage 2: Inserting Sync Beeps for Each Audio Track
• Stage 3: Arranging Audio Clips So They Don’t Overlap
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• Stage 4: Removing Audio Filters and Deleting Level or Pan Keyframes

Stage 1: Making a Duplicate of Your Sequence
Because you may make significant alterations to your sequence, it’s better to duplicate
the sequence and work on the copy. If you make any drastic errors, you can always return
to your original sequence.

Stage 2: Inserting Sync Beeps for Each Audio Track
Insert a one-frame sync beep at the beginning and end of each audio track in your
sequence. These beeps help audio editors synchronize picture to exported audio tracks,
much as a slate does during initial picture and sound editing. The beep before a movie
begins is also known as a two-pop because the beep occurs just 2 seconds before the
first frame of the movie appears. You may notice that when you see a movie countdown,
the last beep coincides with the number 2 in the 10-second countdown.
To create a two-pop (or sync beep)
1 Double-click a sequence in the Browser to open it in the Timeline.
If there is no space at the beginning of your sequence, you need to make room for your
two-pop.
2 In the Timeline, choose Edit > Select All (or press Command-A), then type “+200.”
All of the clip items in your sequence move forward by 2 seconds, making room for the
two-pop.
3 Choose a Bars and Tone generator from the Generator pop-up menu in the Viewer.

Choose the Bars and
Tone generator that
matches the format
you are using.
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4 Press I to mark an In point, press the Right Arrow key on the keyboard to move forward
one frame, then press O to mark an Out point.
In and Out points for
the single-frame clip

5 Drag this clip from the Viewer to the first frame of your sequence in the Timeline.
6 Option-click the video portion of the one-frame clip to select that part only.

Select the video only,
then press Delete.

7 Press Delete to delete the video portion of this clip.

Only the audio
portion remains
as your sync beep.

Note: Instead of deleting the video portion of the two-pop, you can also replace it with
a more appropriate video generator, such as a circle shape generator.
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8 Cut the stereo beep and paste it 2 seconds beyond the beginning and end of each audio
track you will export.

This shows the sync
beep at the beginning
of an audio track.

Stage 3: Arranging Audio Clips So They Don’t Overlap
When you export audio files, there is no automatic way to include “handles,” or extra
audio at the beginning and end of each audio clip. If you want extra audio before and
after the In and Out points of each audio clip, you need to manually change the In and
Out points of each audio clip in your sequence.
Note: When you add handles, be careful not to move the placement of clips in your
sequence. In some cases, you may need to move your audio clips into two adjacent tracks
to create an overlapping checkerboard pattern of audio clips that include handles.

Stage 4: Removing Audio Filters and Deleting Level or Pan Keyframes
To remove any dynamic mixing, remove all audio filters from your audio clips, flatten the
audio level overlays to 0 decibels (dB), and remove any stereo panning you may have
introduced.
To remove all audio filters and keyframes in your sequence
1 Select every audio clip in your sequence by clicking in the Timeline and pressing
Command-A.
All video clips are selected too, but you don’t need to worry about your video clips because
you are only using this sequence to export audio.
2 Control-click one of the selected clips in the Timeline, then choose Remove Attributes
from the shortcut menu.
3 In the Remove Attributes dialog, select Levels, Pan, and Filters, then click OK.
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Exporting Audio Tracks as Individual Audio Files
When you export an audio track in your sequence, the new audio file becomes a
continuous audio file the length of the sequence. All the clips in that track are merged
into a single, continuous media file.
To export a single audio track as an audio file
1 Option-click the Track Visibility control next to the audio track you want to export.
If more than one track is enabled, the enabled tracks are mixed together during export.
Option-clicking the Track Visibility control for a track disables playback for all other audio
tracks.
Make sure just the audio
track you want to export
is enabled (green).

All other tracks
are disabled.

2 Choose File > Export > Using QuickTime Conversion.
3 In the Save dialog, choose a location and enter a name for the file.
4 Choose AIFF or WAVE from the Format pop-up menu.
AIFF is the standard audio file format for Mac OS X. If you’re delivering audio files to
Windows users, you may want to use the WAVE format.
5 Click Options.
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6 In the Sound Settings dialog, choose the format, number of channels, sample rate, quality,
and sample size (bit depth), then click OK.

Choose Linear PCM.
Choose Mono.
Enter a sample rate or
choose one from this
pop-up menu.
Choose the quality level
you want.
Choose a bit depth.

Important: Avoid audio compression unless you are specifically required to use it for
multimedia projects or the web.
7 When you’re ready to export, click Save.
The name of the exported audio file defaults to the name of the sequence. If you are
exporting multiple audio tracks this way, you need to manually name each audio file with
the corresponding track number before you save it.

Exporting Audio Output Groups to AIFF Files
The Export Audio to AIFF(s) command exports an AIFF audio file for each output channel
group in your sequence. The number of audio files exported is based on the number of
mono and stereo output channels assigned to your sequence. You can set the number
of audio outputs in the Audio Outputs tab of the Sequence Settings window. Dual mono
channels are exported to two mono audio files, and a stereo channel is exported to a
single stereo audio file.
One of the primary uses of the Export Audio to AIFF(s) option is to maintain the separation
between audio tracks during export. For example, your entire sequence may have already
been mixed to a final stereo audio file, but you can also export each track grouping to a
separate AIFF file so that foreign distributors can redub the dialogue into another language
separately, without affecting the music, background audio, and sound effects.
Note: You can also export your audio to a multichannel QuickTime file. The same audio
grouping rules apply. For more information, see “Exporting QuickTime Movies.”
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In your sequence, you can assign as many tracks as you want to the same audio output
channel. For example, you can assign tracks 1-4 to audio output channel 1 (mono). The
resulting exported audio file for output channel 1 would contain a mix of audio from
tracks 1-4. You can use audio output channels to group and mix multiple audio tracks
together during export. For example, you could assign tracks 1-4 to output channel 1,
tracks 5-8 to output channel 2, and tracks 9-10 to stereo output channels 3 and 4. This is
useful for exporting stem mixes for use in a final audio mix elsewhere. For more
information about assigning multiple audio outputs, see “Assigning Output Channels
and External Audio Monitors.”

Example: Exporting 12 Tracks to Three Stereo Audio Files
Here’s a typical example illustrating how you might export multichannel audio from an
edited sequence. Suppose you’ve set up a sequence to have three stereo audio outputs
and 12 audio tracks.
The Audio Outputs tab of the Sequence Settings window would look like this:

And the sequence would look something like this:
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Each of the 12 audio tracks can be assigned to one of the three pairs of output channels.
More than one track can be assigned to the same output channel, in which case the audio
from those tracks is mixed to a single audio file during export.
In this situation, using the Export Audio to AIFF(s) option creates three separate stereo
AIFF files. Each file corresponds to an audio output pair in your sequence and contains
the combined audio from all the audio tracks in your sequence assigned to that pair,
mixed together using the levels you set. All three of these files are exactly the same
duration. These three AIFF files can then be delivered, along with your program’s video,
to any audio post-production facility for remixing and mastering, if necessary.
Note: You can also use the Export Audio to AIFF(s) option to export a stereo downmix
of your sequence audio as a single stereo AIFF file. For more information, see “Exporting
Audio to AIFF Files” and “Audio Output Export Settings.”

Automatic Filenaming During Export to AIFF Files
Each exported file is named according to the audio output it corresponds to. Stereo audio
output pairs are exported as a single stereo AIFF file. Mono audio output pairs are exported
as individual mono AIFF files. If you export audio from a sequence named Final Mix that
has two pairs of stereo and two mono audio outputs, the following four files are created:
• Final Mix_1-2.aif (stereo AIFF)
• Final Mix_3-4.aif (stereo AIFF)
• Final Mix_5.aif (mono AIFF)
• Final Mix_6.aif (mono AIFF)

Preparing to Export Audio to AIFF Files
If your edited sequence has only a single pair of audio outputs, the Export Audio to AIFF(s)
option outputs a single stereo AIFF file (or two mono AIFF files). If you want to output
multiple AIFF files, here are some things to keep in mind:
• Create audio outputs for your sequence: The Export Audio to AIFF(s) option exports as
many AIFF files as you have audio outputs assigned in your sequence—one stereo file
for each stereo output, and two mono files for each mono pair output. This is true even
if you have empty audio tracks or audio output channels that are not used by any
tracks. For more information on modifying audio outputs for a sequence, see “Assigning
Output Channels and External Audio Monitors.”
• Assign each track in your sequence to an audio output channel: By default, a new sequence
uses the default stereo audio output preset. If you want to export multiple AIFF files
from a sequence with more than two audio outputs, you need to first create additional
audio outputs in your sequence and then assign tracks to those outputs. For more
information on assigning audio tracks in a sequence to an audio output channel, see
“Assigning Output Channels and External Audio Monitors.”
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• Organize your audio clips by track: If you’re planning to export multiple stereo AIFF files,
it’s a good idea to organize the audio clips you use in your edited sequence according
to their content (dialogue, sound effects, and so on). This makes your project easier to
mix, and your output assignments more logical.

Exporting Audio to AIFF Files
Follow these steps to export AIFF files for each audio output channel in your sequence.
To export audio to AIFF files
1 Select a sequence in the Browser or open the sequence in the Timeline.
2 Choose File > Export > Audio to AIFF(s).
3 In the Save dialog, choose a location and enter a name for the file.
Tip: If you’re exporting multiple audio files, it’s a good idea to create a folder and choose
it as the location to save to.
4 Choose a sample rate, bit depth, and channel configuration from the pop-up menus.
• Rate: Lower sample rates take less bandwidth but have lower quality. Make sure your
sample rate is compatible with the audio facility you’ll be handing the files off to.
Usually, you should use the sample rate specified in your sequence settings, which
should ideally be the sample rate of the original audio media files.
• 96 kHz: This is a high-resolution sample rate that can be easily converted to 48 kHz.
• 88.2 kHz: This is a high-resolution sample rate that can be easily converted to 44.1 kHz
audio files.
• 48 kHz: DV formats and many professional video formats use this sample rate.
• 44.1 kHz: This is the sample rate of music CDs and some DAT tapes.
• 32 kHz: This corresponds to a consumer sample rate option on DV camcorders. Unless
you have a special reason, avoid this sample rate for audio export.
• Depth: Choose the bit depth used for each sample.
• 16-bit: This is the bit depth of DV formats, as well as of music CDs. If all of your original
audio media is 16-bit, and you aren’t routing multiple audio tracks to the same audio
output, choose this option.
• 24-bit: A high-resolution bit depth compatible with many third-party capture cards
and external audio interfaces. Choose this option to preserve the highest possible
quality when exporting your files, especially when some of your audio files are 24-bit,
or when you are mixing multiple audio channels together by routing them to the
same output channel.
• Config: Choose Channel Grouped (for multiple AIFF files) or Stereo Downmix. For details
about these options, see “Audio Output Export Settings.”
5 When you’re ready to export, click Save.
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Note: All audio that requires rendering is automatically rendered with a render quality
of High, regardless of the render quality setting.

Exporting Multichannel QuickTime Files
The rules for audio grouping are the same when exporting a QuickTime movie as when
exporting individual AIFF files: stereo output pairs are exported as a single stereo
QuickTime audio track, and each mono output is exported as an individual mono
QuickTime audio track.
To export your sequence to a multichannel QuickTime movie file
1 Select a sequence in the Browser or open a sequence in the Timeline.
2 Choose File > Export > QuickTime Movie.
3 In the Save dialog, choose a location and enter a name for the file.
4 Choose a sequence preset from the Setting pop-up menu.
If you want to set a particular audio sample rate or bit depth, you can also choose the
current settings of the selected sequence, or you can choose the Custom Settings option.
5 Choose Audio Only from the Include pop-up menu.
If you want to export a complete QuickTime movie that contains video as well as
multichannel audio, choose Audio and Video.
6 Select Make Movie Self-Contained.
The number of audio tracks created in the resulting QuickTime movie depends on two
areas in the Sequence Settings window. For details, see “Audio Output Export Settings.”

Exporting OMF Audio Files
Open Media Framework—or OMF—is a cross-platform file format for exchanging video
and audio sequence information between different editing systems. Avid originally
developed the OMF file format, and many editing applications have incorporated some
level of OMF import and export compatibility. Today, OMF is most often used for
transferring audio sequence, track, and clip information from video editing systems to
audio post-production applications. OMF can store far more information than traditional
EDLs, especially when it comes to audio interchange.
When you export your sequence audio as an OMF file, the resulting OMF file contains a
description of your audio edits (the clip In and Out points in the Timeline) along with the
audio media files. You can use the OMF Export command if you plan to deliver your audio
to an editor using an OMF-compatible digital audio workstation (DAW). Most audio
facilities are able to use OMF files.
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Using OMF for audio export has several important advantages:
• Exported OMF files preserve your audio clips and audio media files (with or without
handles) embedded in a single file. This allows you to open up the audio from your
sequence in another audio editing application and still have access to individual clips.
• You can export as many tracks of audio as you have in your sequence. EDL export limits
you to a maximum of four tracks of audio at a time.
• Cross fade information is included, allowing applications that import OMF files to
automatically place cross fades in the same location as in the original sequence.
• Level and pan information is included in exported OMF files.
Using OMF files, editors can send edited and synchronized audio tracks to an audio
post-production facility, maintaining the original tracks, clip In and Out points, levels,
pan, and cross fades. Audio handles can be added so that the audio editor can still trim
and add cross fades to the audio as necessary.
Note: When you import OMF files into another application, make sure the sample rate
in the application matches the sample rate of your OMF file. If the sample rates don’t
match, your audio may be out of sync after it’s imported.

Limitations of OMF Exporting in Final Cut Pro
Before you export an OMF file, consider the following limitations:
• If you have cross fades in your edit, they are exported as linear cross fades, regardless
of what kind of cross fades you use in your edited sequence. Your audio editor can
reset these to the correct type within the audio software.
How well your cross fades import into another application depends on the tool your
audio editor uses. Because some OMF importing tools do not handle cross fade objects
correctly, you have the option to leave these out when exporting your sequence as an
OMF file.
• OMF export does not include disabled audio tracks (tracks with the Track Visibility
control turned off ). Any individually disabled audio clips are also ignored.
• Speed and reverse-speed effects that have been applied to audio clips are permanently
applied to the exported audio media files.
• Nested sequences are mixed together and exported as a single audio media file.
• Audio filter information cannot be exported in OMF files.
Make sure to test your audio workflow in advance. Not all applications can import audio
level and pan information stored in an OMF file.

Exporting Sequence Audio to an OMF File
When you need to transfer your sequence audio to another audio post-production
application, you can use the Export Audio to OMF command.
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To export audio from a sequence to an OMF file
1 Select a sequence in the Browser or open a sequence in the Timeline.
2 In the Timeline, make sure that each audio track you want to export is enabled (the Track
Visibility control next to the track is green).

Make sure just the audio
tracks you want to export
are enabled (green).
Disabled tracks are
not exported.

3 Choose File > Export > Audio to OMF.
4 In the OMF Audio Export dialog, choose the options you want, then click OK.

• Rate: Choose a sample rate that suits what you’re using the audio for. All of the audio
you export has the same sample rate. If you use audio with different sample rates, it’s
converted.
• Depth: Choose 16-bit or 24-bit. If you choose 24-bit audio, make sure the application
you will use to import the OMF file supports 24-bit audio.
Note: When exporting to OMF, Final Cut Pro uses the highest quality setting regardless
of what you choose from the Audio Playback Quality pop-up menu in the General tab
of the User Preferences window.
• Handle Length: Enter a value in timecode format to add handles to the audio clips.
Handles give your audio editor the flexibility needed to fix edits. Handles of 1 to
3 seconds are typical, but it’s best to check with your audio editor.
Handles are included only when there is additional audio media outside the clip In and
Out points. When there is not enough media to create the full handle duration,
Final Cut Pro includes as much of a handle as possible.
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• Include Crossfade Transitions: Because some OMF importing tools do not handle cross
fade transitions correctly, and many sound editors prefer to create cross fades
themselves, you have the option to leave cross fades out when exporting your sequence
as an OMF file. When this checkbox is deselected, extra source media is substituted for
the duration of the cross fade being left out. How much extra source media is substituted
depends on whether the cross fade was edited before, on, or after the edit point. Extra
source media included as a result of this option is in addition to extra source media
added by the Handle Length option.
• Include Levels: Audio levels and keyframes are included in the exported OMF file. Even
if no audio level keyframes are set, the current level of each clip is exported.
• Include Pan: Pan settings and keyframes are included in the exported OMF file. Even if
no pan keyframes are set, the current pan setting of each clip is exported.
5 Choose a location and enter a name for the file.
6 When you’re ready to export, click Save.

OMF Files Have a 2-Gigabyte Limit
OMF files that you create cannot be larger than 2 gigabytes. In most cases, this should
not present a problem because 2 gigabytes will accommodate approximately 7 hours of
mono audio media (depending on the bit depth and sample rate of your audio). If your
sequence exceeds this limit, you will see a warning message before exporting begins.

Exporting Audio Clip Information to an EDL
Some audio post-production software can import Edit Decision Lists (EDLs) in the same
way as video editing applications. Importing an EDL creates audio clips (or regions) in
the audio application’s timeline, which you can then use to recapture your audio from
original source tapes. This is similar to a video online edit session, in which all clips are
recaptured at the highest quality possible. Since the engineers are recapturing all of the
audio directly from the source tapes using workstations with dedicated high-end audio
hardware, you can be assured of the highest possible quality.
EDLs can only store information for up to four audio channels, and the clips must have
been originally captured using timecode. If some of your audio doesn’t have timecode
(for example, if you imported a track from a CD), you must first transfer your music and
sound effects to a video or audio format with timecode and then edit the timecoded
clips into your sequence. If your program has more than four audio tracks, you need to
export multiple EDLs and have them collated by your audio editor.
For detailed information on exporting EDLs, see “Importing and Exporting EDLs.”
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Copying Audio to Timecoded Tapes
If you captured media files from sources without timecode—such as VHS tape, DAT tapes,
reel-to-reel tape recorders, or imported audio CDs—the resulting EDL won’t be useful
for recapturing because the EDL does not contain relevant timecode information that
refers back to the original sources. The solution is to copy all of your audio without
timecode to formats that support timecode. You should do this before you begin editing
your movie.

Media without timecode

DAT without
timecode

Cassette

CD

Media with timecode

DV tape

DAT with
timecode

Once you’ve copied all of your audio material without timecode onto formats with
timecode, you can log and capture your audio the same way you log and capture video,
knowing that all of your audio edits can now be described in an exported EDL. You treat
the new timecoded tapes as your original audio source material for the duration of the
project.

Exporting Audio for DVD
For information about exporting AC-3 audio files for authoring in DVD Studio Pro, see
“Exporting Sequences for DVD.”
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Tips for Better Audio

61

This chapter covers the following:
• Learning to Describe Sound Accurately (p. 1001)
• Efficiently Using the Frequency Spectrum (p. 1001)
• Tips for Cutting Dialogue (p. 1002)
• Tips for Cutting Music (p. 1004)
Read through the sections in this chapter for tips on cutting dialogue, cutting music, and
keeping your tracks organized.

Learning to Describe Sound Accurately
Even if you aren’t destined to be a full-time sound designer, it is important to be able to
communicate about sound with sound designers and engineers. Practice verbally
describing what you hear, but avoid abstract adjectives whenever possible. Try to be as
specific as possible. Instead of asking for “outdoor sounds,” try “crickets near dusk, and
an occasional car passing on a distant highway.” Instead of saying “city sounds,” try
“blaring horns, footsteps on pavement, and an occasional helicopter sound.” These are
the details that make a sound mix convincing.

Efficiently Using the Frequency Spectrum
It’s fairly obvious that the most important sound in the mix should have the highest level,
but there are other methods for blending without increasing loudness. Most sounds
occupy a particular frequency range, so if you mix sounds in different ranges, you can
still maintain clarity without too much level adjustment. Too many sounds in the same
range can create cacophony.
You can use equalizers to shape sound, making “holes” in the used frequency spectrum
in which you can then place other sounds. For example, if you are trying to make dialogue
in the 1-3 kHz range more audible over existing background sound, you could try filtering
the background sound to reduce the 1-3 kHz range instead of reducing the level of the
entire track. Equalization allows you to reduce the level of sounds only at selected
frequencies, making the mix clearer in that part of the spectrum.
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Tips for Cutting Dialogue
Here are some tips and tricks for taking care of routine dialogue editing problems.
Use cross fades to smooth out problem edits
If you’re having trouble finding an edit point between two audio clips that sounds smooth,
try using a transition instead of a straight cut. More information on audio transitions can
be found in “Refining Transitions Using the Transition Editor.”

Use subframe audio level keyframes to eliminate pops and clicks at edit points
If there is a popping or clicking sound that you can’t get rid of at an edit point, you can
eliminate it by opening the clip in the Viewer, setting audio level keyframes within the
frame with the clicking, and fading those few audio samples all the way down to –60 dB.
See “Example: Setting Subframe Audio Keyframes to Eliminate Clicks” for instructions.
Use keyframes to eliminate microphone pops in a voiceover recording
Although you can use the Vocal DePopper filter in extreme problem cases, if you just
have one or two pops in your audio resulting from words with the letter P, you can get
rid of them by opening the clip in the Viewer, zooming in on the P sound, and setting
four keyframes to lower the audio level and soften the sound.
Use room tone to fill in audio gaps in a scene
When you edit dialogue, any part of a scene that doesn’t have dialogue or clean source
audio should be replaced with room tone from that scene, as described in “Audio Editing
Basics.” This includes the beginning and the end of a scene, even if nobody is talking. If
room tone only happens while people are speaking, it will sound odd. The entire scene
should have the same background noise.
If someone mumbles a single word, salvage the rest of the take
If someone messes up part or all of a word, either by mumbling or swallowing it, you can
sometimes take part or all of another instance of that word, or of another word that has
the sound you need, and use it to replace part or all of the misspoken word.
For example, suppose an actor was supposed to say, “Get those cats out of that tree,”
and instead said, “Get dose cats out of that tree,” accidentally swallowing the “th” sound
in the word those. If you need to use that take, you could copy the “th” sound from the
word that and paste it over the botched beginning of the word “dose.” The change is so
small that nobody will notice the difference. The result in your sequence would look
something like this:
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When you do this kind of edit, watch out for the beginnings and endings of words.
Sometimes people run words together if they speak quickly. If you’re replacing a word
in clip 1 with the same word from clip 2, make sure the sound that comes before the new
word in clip 2 is the same as the sound that comes before the word it’s replacing in clip
1.
Cut away to another image to smooth cuts in dialogue
If you need to remove a word or phrase from someone’s speech, you can use a cutaway
shot or B-roll footage at the same point. This allows you to change the audio without
viewers noticing an obvious jump cut.
One reason shots of the interviewer are included in documentary-style programs is to
give the editor the freedom to edit the speaker’s dialogue without introducing a jump
cut in the picture. That way, if the person on camera says the same thing twice, you can
cut it out without the audience’s knowing and make the subject sound better.
You can also do this in narrative programs. If you decide to rearrange an actor’s lines by
adding or removing dialogue, you can cut to a reaction shot of the person who’s listening
to smooth your changes to the speaker’s audio.
Change the pace of off-camera dialogue
As long as the speaker is off camera, you can make other dialogue changes as well. For
example, you can easily change the pacing of what’s being said, making the sentence
sound more or less dramatic. The key is to have footage you can cut away to that will
seem plausible. An audience shot or another actor listening are two examples of plausible
cutaway shots.
Remember, if you create any gaps as a result of editing your audio, fill them in with room
tone.
Use the video from one take with the audio from another
Sometimes you’ll have multiple takes of a particular shot, each with something good in
it. For example, suppose you have a series of takes of an actor saying, “Wow! That’s a big
piece of pie!”
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Each take is shot from a slightly different angle, and there’s one visual take that you like
more than the others, even though the dialogue in it isn’t that great. In another take, the
actor said the word “wow” really well. A third take has the best version of the line “That’s
a big piece of pie!” If the actor was good and the pacing of each of these takes is roughly
the same, it’s fairly easy to combine all three clips into one good take.

Be careful when combining dialogue from different takes
People use different intonations as they speak a sentence, and it’s important to listen for
this. Sometimes, you’ll be unable to combine two sentences because they don’t sound
right together.
For example, suppose you have two clips of someone talking. In one clip the actor says,
“I’m going to throw that suitcase out the window!” In a second clip, he says, “Should I
put the box in the closet?” You want to cut from the actor to a shot of the closet when
he says “that suitcase” so you can combine the line “I’m going to throw that suitcase”
with “in the closet.” Unfortunately, the second sentence is a question, so the two pieces
of dialogue don’t really sound right together. Because the difference is jarring, you’ll have
to try something else.
Edit in sound to handle a loud background noise at an edit point
If you’re cutting from one clip to another, but there’s a loud sound right at the edit point,
such as a car or a plane passing, you can edit in sound to mask the cut. You won’t be able
to eliminate the noise, but if you take another car or plane sound effect that sounds
similar to the noise at your edit point, you can edit in just enough of the sound effect in
an adjacent audio track to complete the noise of the car or plane passing that was cut
off by your edit. You’ll need to play with the levels, mixing up the sound effect prior to
the edit point and mixing it down afterward, but you’ll be able to mask the cut so that it
sounds completely natural.
Swap onscreen sound effects with new ones using a replace edit
If you want to replace the sound of a door slamming in your source audio track with a
more dramatic door-slam sound effect, you can easily and quickly line up the new sound
effect waveform with the old one by doing a replace edit, so that the new sound is
perfectly in sync. For more information, see “Three-Point Editing.”

Tips for Cutting Music
Here are some tips for editing music in your project.
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Use the natural beginnings and endings of music clips for your edits
Instead of fading a piece of music in and out of a sequence at random points, try matching
specific parts of the music with parts of the video clips in the sequence for a dramatic
impact. Then, at the points where you need to start and end this music in your sequence,
edit in the beginning and the ending from that track, lining them up to match the rhythm
and melody of the part of the track that you’re using.
Using a music track’s natural beginning and end sounds much better than just cutting
into the middle of it, and you can usually create a series of edits using different pieces of
the same musical track to make it work.
Use subframe syncing to keep music on the beat
Since music has a consistent rhythm, inconsistencies in the rhythm caused by edits to a
music track can be painfully obvious. Since one-frame increments are rarely detailed
enough to ensure perfect sync of rhythm in a track, use subframe syncing for each segment
that you edit to make sure the edit points between two clips from the same song are in
rhythm.
Checkerboard the audio segments you’re using to create better cross fading
Instead of using cross fades to transition between two edited clips from the same music
track, edit them together across multiple tracks in your sequence:

Instead of
placing audio
tracks like
this...

...do this.

Now you can use the audio level overlay to create cross fades that are as long as you
need, creating the shape that will make the transition from one clip to the next least
noticeable.
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When you cut from a picture to music, don’t always cut on the beat
Sometimes, lining up a video edit on a significant beat in the music can have fantastic
results. Sometimes, however, it’s overused. Especially in music videos, remember to make
some cuts that don’t match the beat of the music. Otherwise, your edits will be predictable,
and ultimately tedious, to the viewer.
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Working with Soundtrack Pro and
Logic Pro

62

This chapter covers the following:
• Using Soundtrack Pro with Final Cut Pro (p. 1007)
• Sending Individual Audio Clips from Final Cut Pro to Soundtrack Pro (p. 1008)
• Creating Soundtrack Pro Multitrack Projects (p. 1013)
• Initiating Soundtrack Pro Conform with Final Cut Pro (p. 1017)
• Using Logic Pro with Final Cut Pro (p. 1019)
You can quickly process Final Cut Pro audio clips or mix your entire sequence directly in
Soundtrack Pro. You can use Logic Pro to create music scores for your Final Cut Pro projects.

Using Soundtrack Pro with Final Cut Pro
You can use Soundtrack Pro for every aspect of creating audio for a project, from multitrack
recording to advanced audio processing and mixing. For example, you can send a clip’s
media file directly from Final Cut Pro to Soundtrack Pro, modify it, and then immediately
see the changes to your clip back in Final Cut Pro. You can also batch process audio files
using AppleScript scripts created in Soundtrack Pro. However, one of the most powerful
advantages of using Soundtrack Pro is the ability to send entire sequences to
Soundtrack Pro and automatically conform them each time you make editorial changes
to a sequence in Final Cut Pro.
You can take several approaches to working with your Final Cut Pro project’s audio in
Soundtrack Pro. The method you choose depends on your situation.
• If you need to make specific changes to audio clips in your project: Final Cut Pro allows
you to open one or more clips in the Soundtrack Pro File Editor, where you can analyze
and process the audio using a variety of powerful tools.
• If you need to batch process multiple audio files: Using customizable Soundtrack Pro
scripts, you can automate repetitive audio processing tasks such as removing clicks,
adding fades, or normalizing levels.
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• If you need a complete audio post-production solution for your movie, including sound
editing, sweetening, and mixing: You can send multiple Final Cut Pro clips—or even an
entire sequence—to a Soundtrack Pro multitrack project, where you can complete your
final mix by adding additional tracks of sound effects, voiceover, and music. Both stereo
and surround sound mixing are supported.

About Soundtrack Pro Audio File Projects
A Soundtrack Pro audio file project allows you to edit and process an audio media file
nondestructively, which means you can always alter or remove all of the actions you
applied and even get back to the original state of the audio. A Soundtrack Pro audio file
project is stored in a special Mac OS X format called a package (or bundle). A Mac OS X
package appears to be a single file in the Finder but actually contains a collection of files,
such as the original audio file, render files, and the list of actions applied to your audio
file. To take advantage of nondestructive editing, you can create a Soundtrack Pro audio
file project by either saving one from Soundtrack Pro or sending a clip or clips from
Final Cut Pro to a Soundtrack Pro audio file project.

Sending Individual Audio Clips from Final Cut Pro to
Soundtrack Pro
There are three methods you can use to open a clip in the Soundtrack Pro File Editor:
• Send a clip item or items to Soundtrack Pro as a Soundtrack Pro audio file project: A
Soundtrack Pro audio file project is created for each item. This allows you to
nondestructively make changes to the audio in the Soundtrack Pro File Editor. The
original clips in Final Cut Pro are automatically reconnected to the new Soundtrack Pro
audio file projects. You have the option to copy the entire media file for each clip item,
or you can create trimmed versions with handles.
• Process a clip with a Soundtrack Pro script: The clip opens in the File Editor, the actions
in the script are performed automatically, the clip is saved with the changes, and the
File Editor moves to the background so you can continue working in Final Cut Pro. If
your clip’s media file is a standard audio or video file, you have the option to create a
new Soundtrack Pro audio file project, so as to process the file nondestructively. If you
don’t take advantage of this option, the script processes the source media destructively
(permanently). If your clip’s media file is already a Soundtrack Pro audio file project,
the changes are nondestructive.
• Open a clip’s media file destructively in the Soundtrack Pro File Editor: If you do not use a
Soundtrack Pro audio file project for editing and you save the changes to the file in its
native format, or in any flat audio file format (such as AIFF, WAVE, and so on), any
changes you make to the audio file are destructive (permanent).
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Sending Clips from Final Cut Pro to the Soundtrack Pro File Editor
When you send an audio clip from Final Cut Pro to the Soundtrack Pro File Editor, a
Soundtrack Pro audio file project is created with the file extension .stap. This file can be
edited nondestructively. The Final Cut Pro clip is reconnected to the new Soundtrack Pro
audio file project, so the original media file is not affected by what you do in the File
Editor.
You can send single clips or multiple clips to Soundtrack Pro audio file projects.
To send a single Final Cut Pro clip to the Soundtrack Pro File Editor
1 Do one of the following:
• Select the clip in either the Final Cut Pro Browser or Timeline, then choose File > Send
To > Soundtrack Pro Audio File Project.
• Control-click the clip in either the Final Cut Pro Browser or Timeline, then choose Send
To > Soundtrack Pro Audio File Project from the shortcut menu.
The Save dialog appears.

2 In the Save dialog, do the following:
• Enter a name for the Soundtrack Pro audio file project.
• Choose a location to save the Soundtrack Pro audio file project.
• Select “Send only referenced media” to copy only the used section of the media
(between the In and Out points) to the new Soundtrack Pro audio file project. This is
recommended unless you intend to edit the entire source file.
• To add media handles when the “Send only referenced media” option is selected, enter
handle durations in the In Handle and Out Handle fields.
3 Click Save.
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A Soundtrack Pro audio file project is created and opened in the Soundtrack Pro File
Editor. The Final Cut Pro clip is reconnected to the new Soundtrack Pro audio file project
instead of its original media file.
4 Modify the audio as needed.
5 Choose File > Save to save the project with the changes.
A dialog appears allowing you to choose whether the Soundtrack Pro audio file project
should include a copy of the original audio media file or simply refer to it.

6 Select one of the following options, then click OK.
• Include Source Audio: This option copies the original audio media file into the
Soundtrack Pro audio file project package. Because the audio file project has its own
copy of the original media, it is self-contained and doesn’t rely on any external audio
files. This option simplifies media management and makes it easier to transfer the audio
file project to other computers. However, this increases the project file size and therefore
requires more disk space.
• Reference Source Audio: This option creates a link to the original source audio file,
resulting in a smaller project file. However, to use this project file, you always need to
keep track of the original source audio file. If you accidentally delete the original media
file, the Soundtrack Pro audio file project can no longer play back. Select the Reference
Source Audio option only if the media is in a shared location accessible from any
computer you might use to access the Soundtrack Pro audio file project.
When you return to Final Cut Pro, the clip now connects to the new Soundtrack Pro audio
file project.
To send multiple Final Cut Pro clips to Soundtrack Pro
1 Select multiple clips in the Browser or Timeline.
2 Do one of the following:
• Choose File > Send To > Soundtrack Pro Audio File Project.
• Control-click the selection and choose Send To > Soundtrack Pro Audio File Project
from the shortcut menu.
3 In the Save dialog, choose a location to save the new Soundtrack Pro audio file projects.
4 To create a new folder, press Command-Shift-N, enter a name for the folder, then click
Create.
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5 Click OK.
6 A Soundtrack Pro audio file project is created for each clip selected in Final Cut Pro. Each
Soundtrack Pro audio file project is then opened in a File Editor tab in Soundtrack Pro.

Processing a Clip’s Media File with a Soundtrack Pro Script
When you send a Final Cut Pro clip’s media to a Soundtrack Pro script, the following steps
occur for each unique file:
• With your consent, Final Cut Pro generates a Soundtrack Pro audio file project and
replaces the clip’s media file with it.
• The audio file project or the clip’s media file opens in the Soundtrack Pro File Editor.
• The script actions are applied to the audio file project or the media file.
• The audio file project or the clip’s media file is saved with the changes.
If your clip’s media file is a standard audio or video file, you have the option to create a
new Soundtrack Pro audio file project, so that the file is processed nondestructively. If
you don’t take advantage of this option, the script processes the source media destructively
(permanently). If your clip’s media file is already a Soundtrack Pro audio file project, the
changes are nondestructive.

About Soundtrack Pro Scripts
Soundtrack Pro scripts are AppleScript droplets containing Soundtrack Pro File Editor
actions. Scripts can be created in Soundtrack Pro or a script editing application such as
Script Editor, the AppleScript application included with Mac OS X. For more information,
see the Soundtrack Pro User Manual, available in Soundtrack Pro Help.
To modify one or more clips’ media files using a Soundtrack Pro script
1 Select the clips in the Final Cut Pro Browser or Timeline.
2 Do one of the following:
• Choose File > Send To > Soundtrack Pro Script.
• Control-click the selection and choose Send To > Soundtrack Pro Script from the shortcut
menu.
3 Choose the script you want to use from the submenu.
Note: If you have not created custom Soundtrack Pro scripts and saved them to the
default Soundtrack Pro script location, no scripts appear in the submenu.
By default, a dialog appears offering to convert each clip’s media file to a Soundtrack Pro
audio file project, which allows for nondestructive editing.
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4 Select one of the following options:
• Yes: Creates a Soundtrack Pro audio file project for each clip and then prompts you for
a location to save these project files. You can create a new folder by pressing
Command-Shift-N.
• No: This option edits the files destructively, making permanent changes to the original
media files.
• Cancel: Cancels the script operation.
Soundtrack Pro opens and each clip is automatically opened, edited, saved, and closed
in the File Editor.
You can also repeat the last script you used to edit a clip, making it easy to edit several
clips with the same set of actions.

µ

To edit a clip with the last script used
Control-click the clip in the Final Cut Pro Browser or Timeline, then choose Send To > Last
Soundtrack Pro Script from the shortcut menu.

To disable the dialog that appears when you use the Send To Soundtrack Pro Script
command
1 Choose Final Cut Pro > User Preferences, then click the Editing tab.
2 Deselect the Warn on “Send to Soundtrack Pro Script” option, then click OK.

Opening a Final Cut Pro Clip’s Media File in Soundtrack Pro
You can open a Final Cut Pro clip’s media file directly in the Soundtrack Pro File Editor by
choosing the Open in Editor command, or by opening the file from the Finder.
Important: In either of these cases, if you make changes in the Soundtrack Pro File Editor
and save those changes to the original file, your changes will be destructive and
permanent. To edit nondestructively, you can save the file as a Soundtrack Pro audio file
project and import that file into Final Cut Pro.

About the Open in Editor Command
To open Final Cut Pro audio clips in Soundtrack Pro using the Open in Editor command,
choose Final Cut Pro > System Settings, then click the External Editors tab. Make sure that
Soundtrack Pro is the application set to open audio files. This ensures that Final Cut Pro
automatically opens Soundtrack Pro when you choose Open in Editor and that, when
you return to Final Cut Pro, the clip is automatically reconnected to the updated media
file. You can also choose Soundtrack Pro for editing video files if you work with a lot of
linked video and audio clip items. For more information, see “Choosing Settings and
Preferences.”
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To open a Final Cut Pro audio clip’s media file directly in the Soundtrack Pro File Editor
1 Control-click the audio clip in either the Final Cut Pro Browser or Timeline, then choose
Open in Editor from the shortcut menu.
The audio clip’s media file opens in the Soundtrack Pro File Editor.
2 In Soundtrack Pro, modify the audio as needed.
3 Choose File > Save to save the file with the changes.
The Save dialog appears. By default, the File Type pop-up menu is set to Audio File Project,
which saves the changes nondestructively. If you wish to permanently modify the original
file, choose the original file type and filename. Soundtrack Pro asks if you’re sure you want
to overwrite the file. Choose OK only if you’re sure that you no longer need your unedited
media.
4 Click Save.
5 If you saved the file with a different filename or different file type, you must manually
add the new file to your Final Cut Pro sequence.
Important: Unless you save a Soundtrack Pro audio file project, this is a destructive process
that permanently modifies the original file.

Creating Soundtrack Pro Multitrack Projects
Multitrack projects are similar to Final Cut Pro projects: they contain multiple audio tracks
in a timeline that you can use to arrange clips in sequence. Like Final Cut Pro sequences,
clips in a multitrack project refer to media files stored elsewhere, so the project file size
stays small. Multitrack projects also contain a single video track for synchronizing your
audio to picture.
You can create a Soundtrack Pro multitrack project from a selection of Final Cut Pro clips
or an entire sequence. The multitrack project opens automatically in the Soundtrack Pro
Timeline, and clips appear just as they did in your Final Cut Pro sequence, complete with
level and pan settings and cross fades. In Soundtrack Pro, you can arrange your clips, add
effects, and create a finished mix. The final mix can be exported from Soundtrack Pro and
automatically imported into Final Cut Pro in sync with your original sequence.
Note: Some information from Final Cut Pro is not included in the multitrack project, such
as pan settings for stereo pairs, generators, and effects applied to clips.

Creating a Multitrack Project from a Final Cut Pro Selection
Creating a Soundtrack Pro multitrack project from within Final Cut Pro is a simple process.
To create a multitrack project from a sequence or a group of clips
1 Select a sequence in the Final Cut Pro Browser, or select multiple clips in the Timeline.
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2 Do one of the following:
• Choose File > Send To > Soundtrack Pro Multitrack Project.
• Control-click the selection and choose Send To > Soundtrack Pro Multitrack Project.
3 In the dialog that appears, choose from the following options:
• Open in Soundtrack Pro Multitrack Editor: Select this option to open the multitrack project
in Soundtrack Pro after it is created.
• Include Background Video: Select this option to render the video in your Final Cut Pro
sequence. The Soundtrack Pro multitrack project refers to this file in its video track so
you can see your video while you edit. Select what kind of background video you want
to export:
• Fully Rendered Video (slow): Your entire sequence is rendered at full quality to a
QuickTime movie file. This option is recommended if the project is to be moved to
another computer.
• Base Layer Video (fast): Any sequence segment that requires rendering in Safe RT
mode (in other words, any segment with a red render bar) is exported without effects.
These files cannot be moved to a different computer. For more information, see “Play
Base Layer Only.”
• Save project with latest clip metadata (recommended): Select this option to ensure an
accurate change history by having Final Cut Pro automatically save the project after
the send process.
4 Enter a project name or keep the default name, then click Save.
A Soundtrack Pro multitrack project file is created with the file extension .stmp.
Note: This is a small file that refers to the media files used by your Final Cut Pro sequence
clips. Make sure those media files are available when the Soundtrack Pro multitrack project
opens.
If you selected Open in Soundtrack Pro Multitrack Editor, the multitrack project opens in
the Soundtrack Pro Timeline.
5 Modify the multitrack project as needed.
For more information about editing and mixing multitrack projects in Soundtrack Pro,
see the Soundtrack Pro User Manual, available in Soundtrack Pro Help.
6 When you finish working on the project in Soundtrack Pro, choose File > Save.
When you have followed the process described above, you can send a mixdown back to
Final Cut Pro.
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Sending a Mixdown Back to Final Cut Pro Automatically
When you create a Soundtrack Pro multitrack project from within Final Cut Pro, all of the
sequence clip information is stored in the multitrack project. When you export a mixdown
of the multitrack project in Soundtrack Pro, you can also choose to open a new copy of
the Final Cut Pro sequence that looks just like the original sequence but has additional
audio tracks that contain your mixdown.
Clip information is sent from Soundtrack Pro to Final Cut Pro using the Final Cut Pro XML
Interchange Format.
To export a mixdown and open a new copy of a Final Cut Pro sequence containing the
mixdown
1 In Soundtrack Pro, open the multitrack project you want to export.
2 Choose File > Export.
3 If you wish, you may choose options in the following pop-up menus:
• Exported Items: Choose an entire mix, or individual tracks, busses, or submixes, or some
combination thereof.
• File Type: The default (AIFF File) is appropriate for Final Cut Pro use.
• Bit Depth: Choose the setting appropriate for your Final Cut Pro project.
• Sample Rate: Choose the setting appropriate for your Final Cut Pro project.
• Preset: Optionally, you can save a preset combining all of the above settings to use for
future exports.
4 In the After Export pop-up menu, choose “Send files to Final Cut Pro sequence.”

5 Enter a name for the exported file and click Export.
Soundtrack Pro exports mixdown files from the multitrack project and adds them to a
Final Cut Pro XML file containing the original sequence. For your convenience, the audio
tracks from the original sequence are moved to other tracks and are muted.
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In Final Cut Pro, the Import XML dialog appears.

6 Use the Destination pop-up menu to choose your original project, then click OK.
A copy of your original sequence (with the name you specified in step 5) appears in the
Browser.
7 Double-click the new sequence in the Browser to open it in the Timeline.
The sequence opens with the mixdown audio correctly synchronized to your clips in the
Timeline and the original audio tracks muted.
When you want to work on the project in Soundtrack Pro again, you can reopen it from
the Final Cut Pro Timeline.
To open a Soundtrack Pro multitrack project from a mixdown clip in Final Cut Pro
1 In your Final Cut Pro sequence, Control-click the mixdown clip, then choose Open in
Editor from the shortcut menu.
Note: Make sure that the Open in Editor command is set to open audio files in
Soundtrack Pro. For details, see “About the Open in Editor Command.”
A dialog appears with the following options:
• Open Audio File: Opens the mixdown audio file in the Soundtrack Pro File Editor.
• Open Project: Opens the Soundtrack Pro multitrack project linked to the mixdown audio
file.
2 Click Open Project.
The Soundtrack Pro multitrack project linked to the mixdown audio file opens in
Soundtrack Pro.
To update a mixdown clip in your Final Cut Pro sequence
1 Follow the steps above for opening a Soundtrack Pro multitrack project file from a
mixdown clip in Final Cut Pro.
2 Once the multitrack project opens in Soundtrack Pro, make changes to the multitrack
project, then choose File > Save to save the project.
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3 Choose File > Export.
4 Save the mixdown file with the same name, in the same file format, and in the same
location as the previous mixdown file.
5 Switch to Final Cut Pro and open the sequence containing your mixdown.
The mixdown clip remains in the same location, but the media file it refers to has been
replaced by your new mixdown file, so the mixdown is now updated in Final Cut Pro.

Initiating Soundtrack Pro Conform with Final Cut Pro
One of the biggest hurdles faced by sound editors is dealing with picture changes. When
a picture editor moves clips or changes edit durations, the sound editor receives the new
edit and then must manually conform the sound mix to the new picture edit. This process
is time-consuming and it’s easy to make mistakes. Worse, manually conforming a mix
distracts a sound editor from the most important job at hand: completing the mix.

About Conforming Manually
When manually conforming a sound mix to a new picture cut, a sound editor imports
the picture editor’s new audio clips into an existing multitrack project on new tracks.
Next, the sound editor has to walk through the new edits one by one, comparing the old
placement of clips to the new ones. Clips in the old mix must be adjusted so that they
line up with new cuts in the video. Clips may also need to be deleted or added because
a shot was cut or added.

Using Soundtrack Pro Conform
Soundtrack Pro Conform makes conforming multitrack projects much more efficient. The
picture editor and sound editor can work in parallel and then use Conform to easily merge
the results of their work.
Here is how a picture editor and a sound editor might work together using Conform:
• A Final Cut Pro sequence is sent to a Soundtrack Pro multitrack project.
• Changes and edits are made in parallel to both the Final Cut Pro sequence and the
Soundtrack Pro multitrack project.
• The changed Final Cut Pro sequence is sent to a second Soundtrack Pro multitrack
project.
• The old and new multitrack projects are conformed, or merged, into a third (”result”)
project.
To initiate the process to conform a Soundtrack Pro multitrack project to changes
made to the source sequence in Final Cut Pro
1 Select a sequence in the Final Cut Pro Browser.
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2 Do one of the following:
• Choose File > Send To > Soundtrack Pro Multitrack Project.
• Control-click the selection and choose Send To > Soundtrack Pro Multitrack Project
from the shortcut menu.
3 In the dialog that appears, confirm that the “Save project with latest clip metadata
(recommended)” checkbox is selected. This ensures an accurate change history by having
Final Cut Pro automatically save the project after the sequence is sent to Soundtrack Pro.
4 Click Save.
For more information on sending sequences to Soundtrack Pro, see “Creating
Soundtrack Pro Multitrack Projects.”
Now, the sound editor and picture editor can work in parallel:
• Sound editor: Makes changes to the Soundtrack Pro multitrack project. This project is
called the original project.
• Picture editor: Makes changes to the Final Cut Pro sequence.
5 In Final Cut Pro, do one of the following:
• Choose File > Send To > Soundtrack Pro Multitrack Project.
• Control-click the selection and choose Send To > Soundtrack Pro Multitrack Project
from the shortcut menu.
6 In the dialog that appears, confirm that the “Save project with latest clip metadata
(recommended)” checkbox is selected, then enter a new name for the multitrack project
and click Save.
7 When the new multitrack project opens in Soundtrack Pro, choose File > Conform To
Project.
This initiates the conform process.

8 In the dialog that appears, select the current Soundtrack Pro audio mix in the list on the
left and the updated project, just sent from Final Cut Pro, in the list on the right, then
click Conform.
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Note: Only projects that have embedded Final Cut Pro clip metadata (projects sent from
Final Cut Pro or opened via XML documents) appear in this dialog.
The Conform tab displays various lists and information about the changes in each version
of the project. You can use the Conform tab to merge the changes from the picture editor
with the changes from the sound editor.
For complete information about using Soundtrack Pro Conform with Final Cut Pro, see
the Soundtrack Pro User Manual, available in Soundtrack Pro Help.

Using Logic Pro with Final Cut Pro
Logic Pro is a full-featured music production application that you can use to score your
Final Cut Pro project. You can easily use Logic Pro to export completed music mixdowns
and import these files into Final Cut Pro. For more complicated projects, you can use the
Final Cut Pro XML Interchange Format to transfer data between Final Cut Pro and Logic Pro.
For example, you can transfer multiple tracks complete with clips properly positioned in
the Timeline and Arrange windows, region names, and volume and pan automation data.

Importing Final Cut Pro XML Files into Logic Pro
You can export a sequence or group of clips from Final Cut Pro as an XML file and then
import the XML file into Logic Pro.
To export a Final Cut Pro sequence as an XML file
1 In the Final Cut Pro Browser, select a sequence to export.
2 Choose File > Export > XML.
3 Choose the XML format to use from the Format pop-up menu, then click OK.
The default choice is “Apple XML Interchange Format, version 4.”
4 Name the file, choose its destination, and click Save.
To import an XML file into Logic Pro
1 In Logic Pro, choose File > Import.
2 Locate the XML file, then click Choose.
The sequence’s audio opens in Logic Pro.

Exporting Final Cut Pro XML Files from Logic Pro
You can export the current song’s audio as a Final Cut Pro XML Interchange Format file
that you can then import into a Final Cut Pro project.
To export the current song in Logic Pro as an XML file
1 In Logic Pro, choose File > Export > Song to Final Cut Pro/XML.
2 Name the file, choose its destination, and click Export.
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To import an XML file into Final Cut Pro
1 In Final Cut Pro, choose File > Import > XML.
2 Locate the XML file, then click Choose.
A sequence containing the exported audio appears in the Final Cut Pro Browser.
Note: Audio instrument tracks are always bounced to audio files. MIDI tracks are ignored.
Bouncing automatically switches to real-time mode, if necessary (such as when an I/O or
External Instrument plug-in is used).
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Using Video Filters

63

This chapter covers the following:
• Different Ways to Use Filters (p. 1021)
• Applying a Filter to a Clip (p. 1022)
• Applying Multiple Filters to Clips (p. 1025)
• Viewing and Adjusting a Filter’s Parameters (p. 1026)
• Displaying Filters Bars in the Timeline (p. 1034)
• Enabling and Rearranging Filters (p. 1035)
• Copying and Pasting a Clip’s Filters (p. 1036)
• Removing Filters from Clips (p. 1036)
Once you have clips in a sequence, you can apply filters to process and modify the visual
content of your clips.

Different Ways to Use Filters
Filters allow you to modify and enhance the look of your clips. You can use filters to do
the following:
• Adjust a clip’s image quality: Use color correction filters to adjust specific qualities of
your clip, such as color, brightness and contrast, saturation, and sharpness. These filters
allow you to compensate for mistakes in exposure by adjusting the color balance and
exposure of clips after shooting. You can fine-tune the clips in your edited sequence,
making sure that the color and exposure of all the clips in a scene match as closely as
possible. You can also use color correction filters to stylize the clips in your project,
manipulating color and exposure to create specific effects. For more information, see
“Color Correction with Color.”
• Create visual effects: Certain filters, such as the Ripple or Fisheye filter, create bold visual
effects. You can apply and combine these filters to create effects ranging from spinning
your clip in simulated 3D space to blurring, rippling, and flipping a clip’s image in the
Canvas.
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• Create and manipulate transparency effects: Use filters like the Chroma Keyer or Garbage
Matte to create and manipulate the alpha channel information of clips in your project.
Key filters create alpha channels based on blue, green, white, or black areas in the
image. Other filters, such as the Widescreen and Soft Edges filters, allow you to further
manipulate the areas of transparency in a keyed clip, expanding, contracting, and
feathering the area of transparency to fine-tune the effect. Filters like the Mask Shape
and Composite Arithmetic filters generate a new alpha channel based on simple
geometric shapes or copy an alpha channel from one clip to another. For more
information, see “Keying, Mattes, and Masks.”
Final Cut Pro includes a wide selection of video filters, grouped into several categories.
For detailed information, see “Video Filters Available in Final Cut Pro.”
Third-party filters are available if you want a particular effect that isn’t built in. You can
create your own filters with the built-in FXScript effects language or modify existing filters.
For more information, go to http://developer.apple.com/documentation/appleapplications.
Like most parameters in Final Cut Pro, filter parameters can be keyframed to change their
effect on a clip over time. Keyframing filters works the same way as keyframing motion
settings. For more information, see “Adjusting Parameters for Keyframed Effects.”

Applying a Filter to a Clip
You can apply filters to clips in a sequence or to clips in the Browser, but it’s very important
to understand the distinction between these two methods.
• If you apply filters to a sequence clip: The filters are applied only to that clip. The master
clip in the Browser remains untouched.
• If you apply filters to a master clip in the Browser: Instances of that clip already in other
sequences are untouched, but if you edit the master clip into a sequence, the new filter
accompanies the clip into the sequence.
In most cases, you apply filters to individual clips in sequences, not to master clips in the
Browser. There may be occasions when you want every instance of a master clip edited
into a sequence to have the same filter applied, such as during color correction. In this
case, apply the color correction filter to the master clip in the Browser. However, filters
applied to clips are still independent of each other. If you modify the filter parameters
for a master clip, the same filter parameters in affiliate clips are not modified.
Tip: To maintain consistent filter settings across multiple clips, you can copy and paste
filter settings using the Paste Attributes command.
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To apply a filter to a clip in a sequence
Do one of the following:

µ

Select one or more clips in the Timeline, choose Effects > Video Filters, then choose a
filter from the submenus.

List of video filters

Different Blur filters

Tip: If no clip is selected in the Timeline, the filter is applied to the clip beneath the
playhead on the track with Auto Select turned on.

µ

Select one or more clips in the Timeline, then drag a filter from the Effects tab of the
Browser to one of the selected clips in the Timeline.

Drag the filter from
the Browser...

µ

...to a clip in the Timeline.

Open a sequence clip in the Viewer, then do one of the following:
• Choose Effects > Video Filters, then choose a filter from the submenus.
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• Drag a filter from the Effects tab of the Browser directly into the Viewer.
Drag the filter from
the Browser...

...to the sequence clip
in the Viewer.

You can apply a filter to an entire clip or just part of a clip.
To apply a filter to part of a clip in a sequence
1 Select the Range Selection tool in the Tool palette (or press the G key three times).

Range
Selection tool

2 In the Timeline, drag across the part of the clip to which you want to apply the filter.

Drag to select the section
of the clip to which you
want to apply the filter.

3 Do one of the following:
• Choose Effects > Video Filters, then choose a filter from the submenus.
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The filter is applied to the selected part of the clip only. When you open this clip in the
Viewer, filter Start and End points appear in the keyframe graph area of the Filters tab.

Start and End points
for the filter

• Drag a filter from the Effects tab of the Browser to the selected portion of the clip.

µ

To reposition the filter Start and End points
In the keyframe graph area, drag the Start or End point of the filter to the new time or
location.

The End point dragged
to the new time

Drag the Start or End
point to change it.

Applying Multiple Filters to Clips
You can apply one or more filters to a clip at a time. You can also add one or more filters
to multiple clips at the same time. You can add as many filters as you like to a clip. If you
apply more than one filter to a clip, the filters are applied sequentially (the first filter is
applied, and then the next filter is applied, and so on).
The order in which a clip’s video filters appear in the Filters tab of the Viewer determines
how that clip looks. For example, if you apply a Blur filter and then a Pond Ripple filter
to a clip, the clip is blurred first, and then the blurred image is rippled. If you switch the
order, the image is rippled first and then blurred.
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Once multiple filters are applied to a clip, you can change the order in which they take
effect by dragging them up and down the list in the Filters tab. For more information,
see “Enabling and Rearranging Filters.”
To apply multiple filters to a clip in a sequence
Do one of the following:

µ
µ

Apply filters to a clip one at a time (described earlier).

µ

Copy filters from one clip’s Filters tab, then paste them into another clip’s Filters tab
(regardless of whether the clip is a sequence clip from the Timeline or a master clip from
the Browser).

µ

Shift-click or Command-click to select multiple filters in the Effects tab of the Browser,
then drag them to one or more selected clips in the Timeline.

Select a filter in the Effects tab of the Browser, copy it, then paste it into the clip’s Filters
tab in the Viewer.

Select multiple filters
in the Browser.

µ

Then, drag the filters
to selected clips in
the Timeline.

Drag one or more filters from a clip’s Filters tab in the Viewer to a clip (or multiple selected
clips) in the Timeline.

Viewing and Adjusting a Filter’s Parameters
After applying filters, you can view and adjust the specific filter settings in the Filters tab.

Viewing a Filter’s Parameters
Once you apply one or more filters to a clip, you must display filter parameters before
you can adjust them.
Note: If you want to show or modify parameters for a filter applied to a clip in your
sequence, make sure that you open the sequence clip in the Viewer, rather than opening
the master clip from the Browser.
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To view the filters applied to a clip
Do one of the following:

µ
µ
µ

Open a clip in the Viewer, then click the Filters tab.
If a sequence clip is already open in the Viewer, click the Filters tab.
In the video track of a clip in the Timeline, double-click the filters bar.
The clip is opened in the Viewer with the Filters tab selected.
Note: If a sequence clip is already open in the Viewer with the Filters tab selected and
you open another sequence clip, the new clip appears with the Filters tab selected as
well.

µ

To reveal parameters for a filter
In the Filters tab, click the disclosure triangle next to the parameter.
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Controls in the Filters Tab of the Viewer
There are various controls you can use to manipulate filters in Final Cut Pro. Although
each filter has its own individual parameters and controls, all filters have some controls
in common.
Filter category bar
Name bar for the Find
Edges filter
Show/Hide Keyframes
pop-up menu
Reset button
Parameter controls
for the Stop Motion
Blur filter

Enable/Disable checkbox

Disclosure triangle

Keyframe buttons

Keyframe graph area

Current Timecode field

• Filter category bar: Video filters are listed first, then audio filters. (This is for clips with
both video and audio items.) Click the video filter category bar or the audio filter
category bar to select all the filters in that category.
• Name bar: Each filter has a name bar that contains a disclosure triangle, Enable/Disable
checkbox, and the filter’s name. Drag the name up or down to change a filter’s position
in the list. (It’s easier to do this if the filter’s controls are hidden.)
• Reset button: The Reset button is in the Name bar, under the Nav column. Click to delete
all keyframes for the corresponding parameter or parameters and reset those parameters
to their default values.
• Show/Hide Keyframes pop-up menu: This pop-up menu is in the Name bar, under the
Nav column. Use this pop-up menu to turn on or off the display of keyframes that
appear in blue at the top of the keyframe graph area. You can display keyframes for
an individual parameter or keyframes for a combination of parameters.
• Enable/Disable checkbox: Select or deselect to turn on or turn off a filter. When this
checkbox is not selected, the filter isn’t applied or rendered.
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• Disclosure triangle: Click to show and hide all of the controls for a filter.
• Parameter controls: Each filter has its own set of parameter controls.
• Current Timecode field: This field displays the position of the playhead in the keyframe
graph area. When you enter a new timecode value, the playhead moves to that time.
• Keyframe button: Click to place a keyframe for the corresponding parameter at the
playhead location in the keyframe graph, in preparation for creating a dynamic change
in an effect.
Keyframe button

Keyframe navigation
buttons

• Keyframe navigation buttons: Use to move the playhead from one keyframe to the next
on the corresponding overlay, either forward or backward.
• Keyframe graph area: The keyframe graph area shows all the keyframes and interpolated
values associated with parameters currently displayed in the Viewer.
Keyframe graph area

Keyframe graph ruler
Filter Start and
End points
Section of clip not used
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• Keyframe graph ruler: The keyframe graph ruler corresponds to the duration of the clip
or the location of a clip in a sequence:
• If a clip is opened from the Browser: The keyframe graph ruler shows the duration of
the clip itself. The playhead in the Viewer moves independently of the playhead in
the Timeline or Canvas.
• If a clip is opened from a sequence in the Timeline: The keyframe graph ruler shows
the section of the Timeline that the clip is edited into. The playhead in the Viewer is
locked to the playhead in the Timeline and the Canvas.
• Filter Start and End points: If a filter is applied to part of a clip, filter Start and End points
appear in the clip’s keyframe graph area.
• Section of clip not currently used: The frames of a clip displayed in the Viewer’s Filters
tab that are outside the duration specified by the clip’s In and Out points are darker
gray than the part of the clip in use. This helps you know where to apply keyframes.
• Zoom control: This control lets you zoom into and out of the duration displayed by the
ruler in the keyframe graph area, expanding and contracting the keyframe graph ruler
as you do so. This also keeps the area of the visible keyframe graph centered as you
zoom in or out. For more information, see “Zooming In to the Keyframe Graph Area.”

Zoom control

Zoom slider

• Zoom slider: This slider lets you zoom in to and out of the duration displayed by the
keyframe graph ruler by dragging the thumb tabs on either side, adjusting both thumb
tabs and leaving the visible area of the keyframe graph centered. Pressing the Shift key
and dragging one of the thumb tabs zooms in to or out of the keyframe graph, locking
the opposite thumb tab and moving the visible area of the keyframe graph in the
direction in which you’re dragging. For more information, see “Zooming In to the
Keyframe Graph Area.”

Using Filter Controls
Each filter has its own graphical (visual) and numeric controls, including sliders, point and
Angle controls, color controls, and clip wells. Some filters, such as the Color Corrector
3-way and Chroma Keyer, have alternative visual controls that you can use to modify their
effects. The parameters set by visual controls are mirrored in the numeric controls and
vice versa. These filters are discussed in detail in separate chapters. For more information,
see “Color Correction Filters” and “Overview of Compositing Using the Chroma Keyer
Filter.”
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Sliders
By default, sliders show only whole integer values.
Numeric value of
the slider setting

Typical slider

µ

To adjust the corresponding value to within two decimal places of precision
Hold down the Shift key while dragging a slider.

µ

To gear down a slider, allowing you to make more precise changes to the parameter
Hold down the Command key while dragging a slider.
Logarithmic Sliders
As you move the handle on a logarithmic slider, the rate of change increases faster in
one part of the slider than in other parts. The tick marks for logarithmic sliders are unevenly
spaced; where they’re closer together, the change in the parameter’s value occurs more
slowly. Final Cut Pro uses two types of logarithmic sliders:
• Logarithmic slider: This slider has tick marks closer together only on one end, indicating
that the rate of change increases faster at the other end.
• Double-sided logarithmic slider: This type of slider has tick marks closer together in the
center, indicating that the rate of change increases more slowly at the center and more
quickly at the ends.
Logarithmic slider

Double-sided
logarithmic slider
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Logarithmic sliders are useful for parameters that have a huge range of possible values,
with a particular range at the top or at the bottom being more useful than the others.
Point Control
Point controls are used to specify locations in the Canvas.
To define a new location with x and y coordinates
1 In the Filters tab of the Viewer, click the point control.

Point control

X and y coordinates

2 Move the pointer to the Canvas.
The pointer changes to the crosshair pointer in the Canvas.
3 Click anywhere in the Canvas to position a coordinate at that location.
Tip: You can also drag in the Canvas and then release the mouse button when the pointer
is at the appropriate location. If you drag instead of clicking, the values update as the
crosshair moves.
For more information about positioning clips in the Canvas, see “Using Cartesian Geometry
to Position Clips.”
Angle Control
This control specifies angles and rotations. The longer, black hand of the dial indicates
the angle. The smaller, red hand indicates how many total rotations forward or backward
are specified.

Angle control

µ
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To constrain the dial to 45-degree increments
Press the Shift key while you adjust the Angle control.
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µ

To gear down the dial’s movement for a more precise value
Press the Command key while adjusting the control.

µ

To reset the dial to its previous setting while adjusting a parameter
Drag the pointer all the way out of the effect parameter.
Color Controls
The color controls give you several ways to select a color value.
Eyedropper

Hue direction control

Color picker

Click the disclosure
triangle to display the
hue, saturation, and
brightness controls.

Hue, saturation, and
brightness controls

• Disclosure triangle: Click to display sliders and number fields corresponding to the hue,
saturation, and brightness of the range of colors available.
• Eyedropper: This tool lets you quickly select a color that’s in an image in the Viewer or
Canvas. Click the eyedropper, then click an image in the Viewer or the Canvas to pick
up that color.
• Hue direction control: If you’re keyframing changes in color, click this control to indicate
the direction on the color wheel Final Cut Pro uses to interpolate the color change.
• Color picker: Click to choose a color using the standard color picker.
• Hue, saturation, and brightness controls (H, S, and B): Hue determines which color is
chosen; saturation determines how vivid the color is. If saturation is 0, the resulting
color is always white. Brightness determines how bright or dark the color is. If brightness
is 0, the resulting color is black; if brightness is 100, the color is the lightest possible
value.
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Clip Well
Some filters, such as the Bumpmap filter, contain a clip well that allows you to use video
from any clip in your project as a parameter for the filter.

Clip well

µ

To use a clip as a parameter in a filter
Drag any clip from your project to the clip well in the Filters tab.
Tip: Final Cut Pro generators can be dragged to clip wells the same as other clips.

µ

To clear a clip that’s currently attached to a clip well
Control-click the clip well, then choose Clear from the shortcut menu.

Displaying Filters Bars in the Timeline
Once you’ve added filters to one or more clips, you can choose whether or not to display
filter indicators, or bars, in the Timeline to indicate that the clips have filters applied to
them. Filters bars are green and appear in the space below each video and audio track
in the Timeline for the duration of that clip. If keyframes are added to the filter of a clip,
those keyframes appear on top of the bar to which they apply. Filters bars can be displayed
or hidden at any time. For more information, see “Customizing the Keyframe Graph Area
in the Timeline.”

Filters bar for
a video track

Clip Keyframes control
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To show or hide filters bars
Do one of the following:

µ
µ
µ

Click the Clip Keyframes control in the Timeline.
Choose Sequence > Settings, then click the Timeline Options tab. Select or deselect the
Filters Bar checkbox in the Video column of the Clip Keyframes area.
To open a clip in the Viewer using filters bars
In the Timeline, double-click a green bar or keyframe to open that clip in the Viewer.
The Filters tab is automatically opened.
For more information about adjusting filter parameters in the Timeline, see “About the
Timeline Keyframe Graph Area.”

Enabling and Rearranging Filters
You can turn a filter on or off without removing it from a clip. This is useful for previewing
different combinations of filters without having to repeatedly apply and remove them.
You can also rearrange the order in which filters appear, to modify the way they work
together.

µ

To turn individual filters on or off
Select or deselect the checkbox next to the filter’s name.

µ

To rearrange the order of filters in the Filters tab
Drag a filter up or down in the list to change the order in which filters are applied.

Move the selected filter
up or down in the list to
change the order in which
it is applied to the clip.

Tip: Rearranging filters may be easier if you hide the filters’ parameter controls before
dragging. Click the small disclosure triangle to the left of a filter’s name to hide the filter
controls.
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Copying and Pasting a Clip’s Filters
When you copy a clip from the Timeline, you also copy all of that clip’s settings, including
filters applied to that clip. Instead of pasting duplicates of the clip you’ve copied, you can
paste only that clip’s filters into other clips by using the Paste Attributes command in the
Edit menu.
Warning: Pasting attributes into clips that have different frame rates from the copied
clip produces erratic results.
To use the Paste Attributes command to paste filters into a clip
1 Select a clip in the Timeline that has a filter (or filters) whose settings you want to copy.
2 Choose Edit > Copy.
3 Select one or more clips in the Timeline to apply the filter or filters to.
4 Do one of the following:
• Choose Edit > Paste Attributes (or press Option-V).
• Control-click the clip or clips you’ve selected in the Timeline, then choose Paste
Attributes from the shortcut menu.
5 In the Paste Attributes dialog, select the Filters checkbox under Video Attributes.

To copy a clip’s filter
settings, make sure
the Filters checkbox
is selected.

6 Select any other options, then click OK.
The parameter values and keyframes of the filters in the clip you copied from are pasted
into the selected clip or clips.

Removing Filters from Clips
You can remove one or more filters from a clip at any point in your project.
To remove a filter from a clip
Do one of the following:

µ
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Select the filter, then choose Edit > Clear.
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µ
µ
µ

Select the filter, then choose Edit > Cut.
Control-click a filter, then choose Cut from the shortcut menu.
Select the filter in the Filters tab, then press Delete.

To remove all of a clip’s video filters
1 Click the video filter category bar in the Filters tab.
2 Choose Edit > Clear (or press Delete).
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Installing and Managing Video
Effects

64

This chapter covers the following:
• Plug-in Formats Supported by Final Cut Pro (p. 1039)
• Installing Video Filters (p. 1040)
• Identifying and Organizing Video Effects (p. 1041)
• Transferring Effects Between Systems (p. 1043)
• Plug-in Restrictions and Troubleshooting (p. 1044)
Final Cut Pro includes numerous video filters for a wide range of applications. You can
also expand the capabilities of Final Cut Pro with third-party filters.

Plug-in Formats Supported by Final Cut Pro
Final Cut Pro supports two plug-in interfaces: FxPlug and FXScript (the original Final Cut Pro
plug-in format). FxPlug filters must be Universal versions to work on Intel-based Mac
computers.

About FXScript
FXScript effects are text files written in FXScript, a scripting language for creating
Final Cut Pro filters and transitions. You can create effects from scratch or, if you are new
to the FXScript language, you can copy and modify existing Final Cut Pro effects.
Using FXScript, you can create effects in any text editing application, but most people
prefer to use the built-in FXScript editor in Final Cut Pro, called FXBuilder.

µ

To open FXBuilder in Final Cut Pro
Choose Tools > FXBuilder.
For details about the FXScript scripting language and using FXBuilder, go to
http://developer.apple.com/appleapplications.
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About FxPlug
FxPlug is an image-processing plug-in architecture developed by Apple. FxPlug makes
it possible for any plug-in developer to develop hardware-accelerated effects using
technologies such as OpenGL, CoreGraphics, and CoreImage. Processor-based effects are
also supported. For more information about developing FxPlug plug-ins, go to
http://developer.apple.com/appleapplications/fxplugsdk.html.
For details on plug-ins included with Motion, see the Motion User Manual, available in
Motion Help, and “FxPlug Plug-ins.”

Installing Video Filters
During the installation of Final Cut Studio, a number of default FXScript plug-ins and
FxPlug plug-ins are installed.
You can install additional plug-ins that you create yourself or purchase from a third party.
Always follow installation instructions included with third-party plug-ins.
Final Cut Pro examines specific folders for plug-ins when the application opens. Installation
is often as simple as placing a plug-in in the correct folder on your hard disk and then
restarting Final Cut Pro.
Final Cut Pro checks more than one location for each kind of plug-in (the specific plug-in
folder locations are given in the next sections).
• A plug-in folder stored in the Library folder at the root level of the hard disk: Plug-ins installed
here are available to all users of the computer.
• A plug-in folder stored in the Library folder within a specific user’s home folder: Plug-ins
installed here are only available to that user when the user is logged in.

Installing FxPlug Plug-ins
Final Cut Pro searches the following folders for FxPlug plug-ins if the folders are present
on your system (they are typically created when installing third-party software):
• /Library/Plug-Ins/FxPlug/
• /Users/username/Library/Plug-Ins/FxPlug/
If you install an FxPlug plug-in and it does not appear in the Effects tab, make sure the
plug-in is installed in one of the folders that Final Cut Pro searches for plug-ins when
opening (see above for a list of installation locations).
If you installed the plug-in while Final Cut Pro was open, quit Final Cut Pro and then open
it again.
Final Cut Pro also searches for plug-ins in the default Motion FxPlug folder:
• /Library/Application Support/ProApps/SharedA/Plug-Ins
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Important: You should not install filters in this folder yourself.

Installing FXScript Plug-ins
FXScript plug-ins that you create yourself or purchase from a third party should be installed
in one of the following folders:
• /Library/Application Support/Final Cut Pro System Support/Plugins/
• /Users/username/Library/Preferences/Final Cut Pro User Data/Plugins/
FXScript plug-ins included with Final Cut Pro are stored within the application itself.

Loading Plug-ins from a Network Server
If properly configured by a network system administrator, Final Cut Pro checks the
following directory path for plug-ins:
• /Network/Library/Application Support/Final Cut Pro/Plugins/
For more information, see “Audio/Video Settings and Easy Setups.”

Identifying and Organizing Video Effects
Effects in Final Cut Pro are organized into categories in the Effects tab of the Browser and
the Effects menu. These categories help you quickly find the effects you are looking for.
Final Cut Pro also includes a method for limiting which effects are displayed in the
application.

Viewing Preferred Effects
There are many FxPlug effects that are equivalent (or nearly equivalent) to FXScript effects.
Generally, the names and controls of equivalent FxPlug and FXScript effects are identical
or vary only subtly. To keep track of FxPlug and FXScript effects in Final Cut Pro, you can
select which effects are displayed in both the Effects tab and the Effects menu by indicating
that they are preferred effects. For example, there is a Gaussian Blur FXScript filter included
with Final Cut Pro and a Gaussian Blur FxPlug filter included with Motion as part of
Final Cut Studio. By enabling the preferred property for only one of these filters, you can
control which Gaussian Blur plug-in is displayed in the Effects tab and the Effects menu.
Note: Preferred effects are not the same as favorite effects. Preferred effects simply indicate
which plug-ins you want to display in the Effects tab; favorite effects are saved instances
of effects with particular settings you use frequently.
The Effects tab displays three columns for identifying and keeping track of effects.
• Effect Class: Shows the kind of plug-in installed. When this property is empty, the effect
is an FXScript plug-in. If the effect is an FxPlug plug-in, the word “FxPlug” is displayed.
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• Preferred: Shows whether an effect is preferred or not. You can turn this property on
and off by clicking in the column next to the effect. You can also turn this property on
or off for multiple effects by selecting them, Control-clicking in the Preferred column
next to any of the selected effects, and then choosing Yes or No from the shortcut
menu.
• Description: Shows a brief description of the effect (if it contains one). FxPlug plug-ins
contain descriptions, but FXScript plug-ins do not.
To choose which effects are displayed in the Effects tab and the Effects menu
1 Choose Window > Effects (or press Command-5) to open the Effects tab.
2 If you wish, click in the Preferred column next to any effects you want to display.
3 Choose Effects > Effect Availability, or Control-click in an empty area of the Effects tab,
then choose one of the following menu items from the shortcut menu.
• Only Recommended Effects: Shows a list of effects recommended by Apple, minimizing
duplicate FXScript and FxPlug filters. In most cases, the FXScript plug-in is recommended.
• Only My Preferred Effects: Shows only effects whose Preferred property is turned on.
You can use this option to display a customized list of your installed plug-ins.
• All Effects: Shows all installed plug-ins.
You can also add buttons to the Browser button bar to show recommended effects,
preferred effects, or all effects. Note that these three buttons work together as a single
unit and you can select only one button at a time. You can open the Button List window
by choosing Tools > Button List.
Note: Preferred effect settings are not affected if you delete your Final Cut Pro preferences
file.

Identifying Video Filters in the Viewer
You can identify FxPlug plug-ins in the Filters tab of the Viewer by moving the pointer
over the filter name and then waiting until a tooltip appears. FxPlug plug-ins are identified
with the word “FxPlug” after the filter name.

Identifying Video Effects in the Find Results Window
If you use the Find command to search for effects, keep in mind that the Find Results
window does not display the Effect Class column, which helps to distinguish between
FXScript and FxPlug plug-ins. If you see duplicate filters in the Find Results window after
using the Find command, you can identify each effect by selecting it in the Find Results
window and then clicking Show in Browser. Final Cut Pro displays the selected filter in
the Effects tab, where you can identify the effect by looking in the Effect Class column.
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Transferring Effects Between Systems
If you have a project that uses particular FxPlug plug-ins, you need to install those plug-ins
on each machine where you want to open the project. If you open a project on a system
that does not have the necessary FxPlug plug-ins installed, Final Cut Pro warns you that
plug-ins are missing and displays the name of missing effects.
When moving projects from one system to another, be aware that the capabilities of each
computer’s graphics card may be different, limiting which FxPlug plug-ins you can render
at high resolution and high-precision YUV quality. For more information, see “Real-Time
Playback and Rendering Plug-ins.”

Real-Time Playback and Rendering Plug-ins
Final Cut Pro can process most FXScript and FxPlug plug-ins in real time, but there are a
few exceptions. For a detailed explanation of real-time processing in Final Cut Pro, see
“Using RT Extreme.”

Real-Time Playback and Rendering of FXScript Effects
FXScript plug-ins included with Final Cut Pro are optimized for real-time playback.
Rendering is required only when your computer’s processing power is exceeded.
Third-party plug-ins may require the Unlimited RT mode for playback. For more
information, see “Using RT Extreme.”

Real-Time Playback and Rendering of FxPlug Effects
Unlike FXScript plug-ins, whose performance improves only with increased RAM and
processing power, many FxPlug plug-ins achieve high performance by processing effects
with your computer’s graphics card. Upgrading your graphics card or switching to a
system with a better graphics card can improve FxPlug plug-in performance.
Using very high-resolution clips or turning on high-precision rendering in your sequence
settings may exceed the capabilities of older graphics cards. In these circumstances,
Final Cut Pro displays one of the following warnings.
• Rendering the effect in high precision requires a graphics card with more capabilities: Your
graphics card does not support high-precision rendering.
• The effect cannot be rendered in a sequence of this size with the current graphics card: Your
graphics card supports high-precision rendering, but the dimensions of the sequence
containing clips with applied FxPlug filters are too large for the graphics card.
• The effect cannot render this media at full resolution: Your graphics card has enough
memory to store the sequence dimensions, but the clip that has the applied FxPlug
filter is too large for the graphics card. In this case, the media is scaled down to a lower
resolution.
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When you enable high-precision rendering in your sequence settings, some systems with
older graphics cards may be able to play back clips with FxPlug plug-ins in real time but
may not be able to render those clips. Keep in mind that a green render status bar indicates
only the real-time playback status of a clip in the Timeline; it does not indicate whether
or not it is possible to render that clip. In these cases, turn off high-precision rendering
in the Video Processing tab of the Sequence Settings window or move your project to a
system with a more powerful graphics card.
Important: When you attempt to render sequences containing effects that cannot be
rendered, Final Cut Pro skips these segments and the color of their render status bars
does not change. However, you cannot use the Print to Video, Edit to Tape, Export
QuickTime Movie, or Export Using QuickTime Conversion commands because your system
cannot render all of the effects. You can transfer your project and its current render files
to a system with a more powerful graphics card to complete rendering.
To improve FxPlug plug-in real-time performance
Do one of the following:

µ

Hold down the Option key when scrubbing through video clips with filters applied. This
works for both FXScript and FxPlug plug-ins.

µ

Turn off the Digital Cinema Desktop Preview playback option by choosing View > External
Video > Off.

Plug-in Restrictions and Troubleshooting
The following section explains plug-in limitations you should be aware of before
incorporating plug-ins into a particular workflow.

FxPlug Plug-in Restrictions
When using FxPlug plug-ins with Final Cut Pro, the following restrictions apply:
• Onscreen controls, such as point controls that appear directly in the Viewer and Canvas,
are not supported.
• Motion allows filters to render beyond the bounds of the Canvas, but Final Cut Pro
does not. Some effects have parameters, such as Crop and Expansion Amount, that
control this behavior. These parameters will not have an effect in Final Cut Pro.
• Effects that result in subtle gradations (such as a Gradient generator or Gaussian Blur
filter) can cause colored vertical banding after rendering. This kind of banding is likely
an artifact of rendering in a low-resolution codec (such as DV) and not an issue with
the filter. Try setting your sequence settings to an Uncompressed 8- or 10-bit sequence
preset instead.
• FxPlug plug-ins that render in RGB color space may cause clipping, especially when
applied to Y′CBCR clips with high chroma or luma values. This may be particularly
noticeable when applying an FxPlug filter to a range of a clip instead of an entire clip.
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• If your computer has a graphics card with 128 MB or less of video RAM (VRAM), some
FxPlug plug-ins installed with Motion are not available in Final Cut Pro.
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Video Filters Available in
Final Cut Pro

65

This chapter covers the following:
• FXScript Plug-ins (p. 1047)
• FxPlug Plug-ins (p. 1058)
Final Cut Pro includes numerous video filters for a wide range of applications. This section
lists and describes the video filters available with Final Cut Pro.

FXScript Plug-ins
The following sections give you a short description of each type of video filter, followed
by a detailed list of available filters of that kind.

Blur Filters
Blur filters are commonly used to make stylized background graphics out of video clips.
With enough blur applied, you can turn almost any video image into a stylized blend of
colors and shapes.
Filter
Gaussian

Result
Blur1

Blurs the entire frame of a clip. A pop-up menu lets you choose
which channel to blur. You can blur one or all of the color and alpha
channels together or separately. The Radius slider lets you specify
how much to blur the clip.

Radial Blur

Creates the illusion that the image is spinning about a center point.
The Angle control allows you to adjust the maximum amount of
blur. Adjust the smoothness of the blur using the Steps slider. You
can also specify the center point in the frame about which the blur
rotates.

Wind Blur

Creates the illusion that the image is moving in a linear direction.
Use the Angle control to adjust the direction in which the blur
travels. Use the Amount slider to specify the distance between each
increment of blur. Adjust the smoothness of the blur using the Steps
slider.
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Filter

Result

Zoom Blur

Creates the illusion that the image is moving toward you or away
from you. A pop-up menu lets you choose whether the blur moves
in or out. The Radius slider determines the distance between
increments of blur, and the Steps slider determines how smooth
the blur appears.

1 Works in 32-bit floating point if your sequence is set for high-precision rendering in the Video Processing tab of the
Sequence Settings window.

Border Filters
Border filters let you create borders using the total frame of your clips.
Filter

Result

Basic Border

Draws a border around the edges of the clip and ignores any alpha
channel information associated with that clip. Use the Border slider
to adjust the width and the color controls to select the border color.

Bevel

Draws a beveled border around the edges of the clip. The Light
Angle control lets you specify the direction of the light. The Bevel
Width slider lets you adjust the width of the border, the Opacity
slider allows you to adjust the relative strength of the bevel effect
on the border, and the Light color controls let you specify the color
of the light that gives the border its beveled look.

Channel Filters
Channel filters allow you to manipulate the color and alpha channels of clips in your
sequence to create effects.
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Filter

Result

Arithmetic

Performs an arithmetic operation, blending a specific color channel
of your clip with another color. You can choose the operator used
and the channel it’s applied to from pop-up menus. The color
controls allow you to specify the color with which the channel
interacts.

Channel Blur

Allows you to apply varying amounts of blur to each of the color
and alpha channels of your clip simultaneously. Sliders let you
control how much blur is applied to each channel.

Channel Offset

Offsets the position of one or all of a clip’s channels. You can specify
the channel to be offset from the Channel pop-up menu, the
amount of offset using the Center Offset control, and the type of
edge to be used from the Edges pop-up menu.

Color Offset

Offsets the color of individual channels in the clip. Using this filter,
you can create posterizing style effects. You can invert the image
or wrap the colors. Sliders let you control the offset value for each
color channel in the clip.
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Filter

Result

Compound Arithmetic

Performs an arithmetic operation on the clip and a second specified
clip. You can choose the operator and the channel from pop-up
menus.

Invert

Inverts one or all channels of the selected clip. A Channel pop-up
menu allows you to choose which channel or channels to invert,
and the Amount slider lets you adjust the amount of inversion to
apply.

Color Correction Filters
Color correction filters let you adjust the black, white, and midtone color balance of your
clips. For detailed information on using these filters, see “Color Correction with Color.”
Filter
Broadcast

Result
Safe1

Gives you a fast method for dealing with clips that have luma,
chroma, or RGB levels that exceed the broadcast limits for video.

Color Corrector1

A basic filter for performing simple color correction. While not as
fully featured as the Color Corrector 3-way filter, it’s more likely to
be supported by real-time hardware.

Color Corrector 3-way1

Gives you more precise color control with separate adjustments to
the color balance of the blacks, midtones, and whites of your image.

Desaturate Highlights1

Lets you eliminate unwanted color that sometimes appears in the
highlights of an image when you apply one of the color correction
filters.

Desaturate Lows1

Lets you eliminate unwanted color that sometimes appears in the
blacks of an image when you apply one of the color correction
filters.

RGB Balance

Allows you to raise or lower the levels of the highlights, midtones,
and blacks of each channel—red, green, and blue—in RGB color
space individually.

RGB Limit1

Allows you to limit illegal RGB values with fine-grained control.

1 Works in 32-bit floating point if your sequence is set for high-precision rendering in the Video Processing tab of the
Sequence Settings window.

Distort Filters
The Final Cut Pro Distort filters are design-oriented filters that create texture effects.
Filter

Result

Bumpmap

Offsets pixels in a clip using the luma of a second selected image,
called the map. Use the Direction and Outset controls to define the
direction and amount of the offset, and the Luma Scale and Repeat
Edge controls to define the appearance of the offset.

Chapter 65 Video Filters Available in Final Cut Pro

1049

Filter

Result

Cylinder

Distorts the clip as if it were wrapped around a cylindrical object.
You can adjust the Radius and Center sliders to affect the
appearance of this filter, as well as select or deselect the Vertical
checkbox. The Amount slider controls the effect this filter has on
your image.

Displace

Distorts the clip by offsetting pixels using the red and green
channels. You can adjust the horizontal offset using the red channel
and the vertical offset using the green channel. Horizontal and
Vertical Scale sliders define the direction and amount of the offset;
the Luma Scale slider and Repeat Edge checkbox define the
appearance of the offset.

Fisheye

Distorts the clip as if it were bulging outward. You can adjust the
Radius and Amount sliders to change the effect, and use the Center
point control to adjust the center of the bulge.

Pond Ripple

Distorts the clip as if it were mapped onto a pond ripple. The Center
point control allows you to set the center of this effect in the frame
of your clip. You can adjust the number and size of the ripples using
the Radius, Ripple, Amplitude, Acceleration, High Light, and Decay
sliders.

Ripple

Distorts the clip in a wave pattern, both horizontally and vertically.
You can adjust both parameters independently using the Amplitude,
Wavelength, Horizontal Speed, and Vertical Speed sliders. The Repeat
Edges checkbox ensures that no black appears at the edges of the
frame.

Wave

Distorts the clip in a simple zigzag pattern, either horizontally or
vertically. You can adjust the Amplitude, Wavelength, and Speed
sliders to change the effect. The Vertical checkbox defines the
orientation of the effect. The Repeat Edges checkbox ensures that
no black appears at the edges of the frame.

Whirlpool

Distorts the clip in a swirling, whirlpool pattern. You can adjust the
Center point control. The Amount Angle control defines the rotation
of the whirlpool. The Repeat Edges checkbox ensures that no black
appears at the edges of the frame.

Image Control Filters
Image Control filters let you manipulate the levels of black, white, and color in your clips.
They can be used to correct clips with color or exposure problems or to create other,
more extreme color effects. For more detailed control over the color in your clips, use the
color correction filters.
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Filter

Result

Brightness and Contrast (Bezier)

Lets you change the brightness and contrast of a clip by –100 to
100 percent to darken or lighten the image. Brightness and contrast
affect all colors and luma values of a clip at once; if used to extremes
they can give a washed-out appearance to your clip.
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Filter

Result

Color Balance

Allows you to adjust the amounts of red, green, and blue in a clip
independently. Select whether this filter affects the highlights (bright
areas), midtones, or shadows (dark areas) of your clip. Color balance
can be used to correct for inaccurate white balance on video footage
or to create color effects.

Desaturate

Removes color from a clip by the specified amount. 100 percent
desaturation results in a grayscale image.

Gamma Correction

Changes the gamma of a clip by the specified amount. This filter
can be used to pull detail out of underexposed footage or to bring
overexposed footage down without washing out your clip.

Levels

Works similarly to the Gamma Correction filter, but allows for greater
control. You can specify a particular alpha or color channel of your
clip. Use the Input, Input Tolerance, Gamma, Output, and Output
Tolerance sliders to change the effect.

Proc Amp1

Simulates the controls available on a composite video processing
amplifier (proc amp). This filter gives you excellent control over the
black levels, white levels, chroma, and phase of your clip. The Setup
slider lets you adjust the black level of your clip. The Video slider
lets you adjust the white level. The Chroma slider allows you to cut
or boost the levels of color in your clip, and the Phase Angle control
lets you adjust the hue.

Sepia1

Tints the clip with a sepia color by default. You can adjust the
amount of tint and the brightness of tint using the Amount and
Highlight sliders. You can also select another color with the Tint
Color controls.

Tint1

Tints the clip with the specified color. Only the amount of tinting
is adjustable with this filter.

1 Works in 32-bit floating point if your sequence is set for high-precision rendering in the Video Processing tab of the
Sequence Settings window.

Key Filters
Key filters are generally used to key out background areas of video in order to isolate
foreground elements to composite against a different background. Key filters are
commonly used with the Matte Choker filter. For detailed information on applying these
filters, see “Keying, Mattes, and Masks.”
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Filter

Result

Blue and Green Screen

Keys the blue or green area of a clip and uses the selected color as
a transparency mask for compositing foreground elements against
a background scene. A View pop-up menu allows you to look at
the source of the clip (with no key applied), the matte created by
the filter, the final matted image, or a special composite of the
source, matte, and final image for reference. A Key Mode pop-up
menu allows you to choose blue, green, or a blue/green difference
as the key color. The Color Level slider lets you specify the amount
of blue or green in your clip to key out, and the Color Tolerance
slider allows you to expand the key into adjacent areas containing
other shades of the key color. The Edge Thin slider allows you to
expand or contract the matte area to try to eliminate fringing, and
the Edge Feather slider lets you blur out the edges of the matte to
create a smoother key. (Before you use these sliders, try using a
Matte Choker filter instead.) An Invert checkbox allows you to invert
the matte, making what was masked solid and what was solid
masked.

Chroma Keyer1

Allows you to create a key using any range of color you want,
including (but not limited to) the usual blue and green. You can
also fine-tune your composite by adjusting the color value,
saturation, and luma ranges used to define your key, together or
separately. For example, if you only want to perform a luma key,
you can turn off color and saturation. Even when performing a color
key, you’ll get superior results by manipulating the Color Range and
Saturation controls separately.

Color Key

Keys on any color in a clip. Color controls allow you to select a color
from your clip as the specified key color. Sometimes referred to as
chroma key.

Color Smoothing - 4:1:1
Color Smoothing - 4:2:2

Improves the quality of chroma keys and reduces diagonal
“stairstepping” that can occur in video clips with areas of
high-contrast color. Use 4:1:1 Color Smoothing with NTSC or PAL
DV-25 video sources. (The exception is PAL mini-DV/DVCAM, which
uses 4:2:0 color sampling.) Use 4:2:2 Color Smoothing for DVCPRO
50, DVCPRO HD, and 8- and 10-bit uncompressed video. To improve
the quality of your chroma key, apply the appropriate smoothing
filter to the clip you want to chroma key first. As you add additional
key filters, make sure that the Color Smoothing filter remains the
first one in the video section of the Filters tab.

Difference Matte

Compares two clips and keys out areas that are similar. A View
popup menu allows you to look at the source of the clip (with no
key applied), the matte created by the filter, the final matted image,
or a special composite of the source, matte, and final image for
reference. The Difference Layer clip well allows you to specify
another clip to compare the current image to for keying. Threshold
and Tolerance sliders let you adjust the key to try to isolate the parts
of your image that you want to keep.
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Filter

Result

Luma Key

Similar to a chroma (color) key, except that a luma key creates a
matte based on the brightest or darkest areas of an image. Keying
out a luma value works best when your clip has a large discrepancy
in exposure between the bright or dark areas in the frame that you
want to key out, and the foreground images you want to preserve.
A View pop-up menu allows you to look at the source of the clip
(with no key applied), the matte created by the filter, the final
matted image, or a special composite of the source, matte, and final
image for reference. A Key Mode pop-up menu allows you to specify
whether this filter keys out brighter, darker, similar, or dissimilar
areas of the image. A Matte pop-up menu lets you create either
alpha channel information for that clip or a high-contrast matte
image applied to the color channels of your clip, based on the matte
created by this filter.

Spill Suppressor - Blue

When you use the blue and green screen key to key out the blue
in a clip, sometimes there is residual blue fringing, referred to as
spill, around the edge of the foreground image. This filter removes
this blue fringing by desaturating the edges where the fringing
appears. This filter should always appear after a color key in the
filter list shown in the Filters tab of the Viewer. It may have a slight
effect on the color balance of your image.

Spill Suppressor - Green

Works in the same way as the Spill Suppressor - Blue filter, but on
green fringing.

1 Works in 32-bit floating point if your sequence is set for high-precision rendering in the Video Processing tab of the
Sequence Settings window.

Matte Filters
Matte filters can be used by themselves to mask out areas of a clip, or to create alpha
channel information for a clip to make a transparent border so that the clip can be
composited against other layers. Matte filters can also be used to make further adjustments
to layers with key filters applied to them. For detailed information, see “Using Mattes to
Add or Modify Alpha Channels.”
Filter

Result

Eight-Point Garbage Matte

Generates an eight-point polygon you can use to crop out portions
of a clip. Eight-point controls allow you to define the polygonal
matte. The Smooth slider rounds off the corners of the polygon to
create rounder mattes. The Choke slider allows you to expand or
contract the matte, and the Feather slider allows you to blur the
edges of the matte. The Invert checkbox reverses what’s matted
and what’s transparent, and the Hide Labels checkbox hides the
number labels, which indicate which point of the matte corresponds
to which point control of the filter.
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Filter

Result

Extract

Produces a matte around the clip, similar to a luma key. A View
pop-up menu allows you to look at the source of the clip (with no
key applied), the matte created by the filter, the final matted image,
or a special composite of the source, matte, and final image for
reference. Use the Threshold, Tolerance, and Softness sliders to
adjust the matte. The Copy Result pop-up menu allows you to copy
the luma result to the RGB or alpha channel of your clip, and the
Invert checkbox allows you to invert the result.

Four-Point Garbage Matte

Works similarly to the Eight-Point Garbage Matte, but creates a
four-point polygonal matte.

Image Mask

Takes the alpha channel or luma from another clip and uses it to
create a matte for the current clip. The Mask clip well allows you to
select the clip from which to take the alpha channel or luma values.
The Channel pop-up menu lets you choose whether to use the clip’s
alpha channel or luma level. The Invert checkbox allows you to
invert the resulting matte. This filter is especially useful for taking
custom edge masks that you can create with any image editor and
applying them to clips in your sequence that you want to matte
the edges out of. Unlike the Travel Matte composite mode, the
Image Mask filter attaches a matte to the selected clip. You can use
motion effects to move the affected clip around, and the matte
follows.

Mask Feather

Blurs the alpha channel of the clip by the amount you specify with
the Soft slider.

Mask Shape

Generates a mask shape to use to matte out the clip. You can choose
a diamond, oval, rectangle, or round rectangle from the Shape
pop-up menu. Use the Horizontal Scale and Vertical Scale sliders to
adjust the size and aspect ratio of your mask shape. The Center
point control allows you to specify the center of the mask, and an
Invert checkbox lets you reverse what’s transparent and what’s solid.

Matte Choker

Usually used in conjunction with a key filter to manipulate the edges
of the key. The Edge Thin slider in the Matte Choker is often used
instead of the Edge Thin slider in the key filter because it can
produce a more realistic result. When you use the Matte Choker,
moving the Edge Thin slider to the right gradually eats into
marginally keyed areas of a filter, eliminating fringe and smoothing
out the edges of your matte. When you move the Edge Thin slider
to the right, marginally keyed areas of a clip are expanded, spreading
out the matte and filling in holes in your foreground image that
may have been created by the key filter you’re using. Matte Chokers
always appear after the key filter in the Filters tab. Matte Chokers
are also commonly used in groups. The first Matte Choker eliminates
the fringing in the areas you want to key out, but it may create holes
in the foreground image. The second Matte Choker, applied in
reverse, fills in these holes to make the foreground image as solid
as possible. More Matte Chokers can further fine-tune your key.
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Result

Soft Edges

Blurs the four edges of the clip individually by the specified amount
to create an old-fashioned vignetting effect. Each of the four edges
of your clip can be individually adjusted using the Left, Right, Top,
and Bottom sliders. The Dither and Gaussian checkboxes are used
to modify the quality of the blurred edge, and the Invert checkbox
allows you to switch between masking out the edges and creating
a hole in your image.

Widescreen

Generates a widescreen matte in the clip to create a letterboxed
image. The Type pop-up menu allows you to adjust the aspect ratio
of the top and bottom mask using standard academy ratios. The
Offset slider lets you move the affected clip up or down in order to
display the area that’s most important. The Border slider moves the
top and bottom of the letterbox inward by up to ten pixels. The
color controls allow you to specify a border color other than black
for the letterbox, and a Feather Edges checkbox blurs the edges of
the letterbox.

Perspective Filters
Perspective filters allow you to move your clips spatially within their frames. To move a
filter spatially using the entire frame of the Canvas, use motion effects instead.
Filter

Result

Basic 3D

Creates the illusion that your clip is suspended in 3D space. You
can adjust the rotation around the x, y, and z axes using Angle
controls. The Center point control allows you to set the center of
transformation, and the Scale slider enlarges and reduces the size
of the entire affected layer. You cannot enlarge a clip past the frame
size of that clip.

Curl

Curls the clip as if it were a piece of paper. You can adjust the
direction, radius, and amount of curl. The Peel checkbox changes
the effect between curling up in a roll and peeling up like a sticker.
The Back clip well allows you to use a different clip as the back side
of the curled object.

Flop

Allows you to flop a clip horizontally, vertically, or both.

Mirror

Reflects a mirror image of the clip. Use the Reflection Center point
control to change the center of the reflection, and the Reflection
Angle control to modify the angle of the mirror effect.

Rotate

Rotates the clip by 90 degrees or by 180 degrees. Choose the angle
of rotation from the Rotate pop-up menu. This filter scales the result
to fit the frame size, distorting the clip.

Sharpen Filters
Sharpen filters manipulate the contrast of clips in a sequence to bring out more detail in
your images.
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Filter

Result

Sharpen

Increases the contrast between adjacent pixels to increase the
perception of sharpness in the image. When overused, can result
in a harsh, grainy look.

Unsharp Mask

Increases the contrast of adjacent pixels with greater control than
the Sharpen filter. You can adjust the amount, radius, and threshold
of sharpness to soften this filter’s effect.

Stylize Filters
Stylize filters can be used to create an assortment of visual effects.
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Filter

Result

Anti-alias

Blurs the high-contrast areas in the clip to soften the borders
between elements in the frame. Use the Amount slider to soften
diagonal “stair-stepping” that can occur in areas of high contrast.

Diffuse

Randomly offsets pixels in the clip to create a textured blur. The
Direction Angle control allows you to adjust the direction of
diffusion. The Radius slider adjusts how extreme the diffusion is.
The Direction pop-up menu lets you specify whether the diffusion
should be unidirectional (random on one axis), bidirectional (random
on two axes), or nondirectional (all directions). The Random
checkbox increases the amount of chaos in the effect, and the
Repeat Edges checkbox eliminates any black that might appear
around the edge of the frame.

Emboss

Produces the illusion of raised edges where there is high contrast
in the clip. The Direction Angle control allows you to specify the
direction of the emboss effect. The Depth slider lets you raise or
lower the apparent depth of the embossing. The Amount slider
controls the blend between the original clip and the emboss effect.

Find Edges

Creates an effect of extreme contrast used to outline the edges in
the clip. The Invert checkbox lets you switch between using a
light-on-dark and dark-on-light effect. The Amount slider controls
the blend between the original clip and the Find Edges effect.

Posterize

Maps the colors in the clip to a specified number of colors, creating
an image with limited color range, which produces banding in areas
of graduated color. Red, Green, and Blue sliders allow you to adjust
the amount of posterization.

Replicate

Tiles the clip to create a duplicate video wall effect. You can adjust
the number of tiles independently for the horizontal and vertical
axes, up to 16 repetitions. If the horizontal and vertical repetitions
are not the same, the repeated images appear distorted.

Solarize

Minimizes the midtones and maximizes the highlights and shadows
in the clip, like the photographic solarizing effect. This effect can
be inverted using a checkbox and adjusted using the Amount slider.
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Video Filters
Video filters are generally used to solve specific problems with clips in your sequence,
although there are design-oriented filters in this category as well.
Filter

Result

Blink

Flashes the clip on and off. You can adjust the frequency
independently using the On Duration and Off Duration sliders, and
the maximum dip in opacity using the Opacity slider.

De-Interlace

Can be used to remove the upper (odd) or lower (even) field from
an interlaced video clip. The remaining fields are interpolated to
create a whole image, with marginal softening of the image as a
result. A pop-up menu allows you to remove either the upper or
lower field. The De-Interlace filter is useful when you want to create
a still image from interlaced video clips of people or objects moving
at high speed. Since each frame of video is a combination of two
interlaced fields created sequentially over time, this can result in a
flickering image. The De-Interlace filter can also be useful if you’re
outputting a QuickTime movie for computer playback, since
computer screens display lines progressively.

Flicker

Reduces flicker caused by interlacing in still frames that have thin
vertical lines, such as title pages with small text. Three settings are
available: minimal, medium, and max. These settings allow you to
selectively trade off between the amount of flicker and the amount
of vertical softness in the resulting video image.

Shift Fields

Changes the field order of each video frame. This filter is often
applied automatically by Final Cut Pro to convert between formats
whose field order doesn’t match.

Stop Motion Blur

Blends frames in the clip. You can adjust the time, steps, opacity,
and operation used to blend the frames.

Strobe

Lowers the apparent frame rate of a clip in your sequence by
freezing the frames of the clip for a specified amount of time. The
Strobe Duration slider allows you to define the duration of each
freeze frame.

Timecode Generator

Generates a visible timecode counter independent of the timebase
and timecode format of the affected clip (or sequence). For example,
you can apply a Timecode Generator filter counting at 24 fps while
the affected sequence has a timebase of 29.97 fps.

Timecode Reader

Generates a visible timecode counter based on the frame rate
(timebase) and selected time display option of the clip or sequence
to which the filter is applied.

View Finder

Displays a simulated camcorder viewfinder overlay. Various elements
can be included, such as rec/play/pause mode (or custom text), title
safe and action safe boundaries, and a blinking lamp. You can also
adjust the text and color of the mode text.
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FxPlug Plug-ins
FxPlug plug-ins are included as part of the Final Cut Studio installation process.
Final Cut Pro may not support some FXPlug plug-ins. See “Plug-in Formats Supported by
Final Cut Pro” for more information. For more information about plug-ins available with
Motion, see the Motion User Manual, available in Motion Help.

Using the Mix Parameter
FxPlug effects in Motion and Final Cut Pro display a parameter called Mix that allows you
to blend the video image with and without the filter applied. When Mix has a value of
100 percent, only the affected image is displayed. When the value is 0 percent, the image
appears as it would without the effect. Values between 0 percent and 100 percent blend
the unaffected and affected image. You can use the Mix parameter to apply a filter in a
more subtle way, or you can set Mix parameter keyframes to fade an effect in or out.

FxPlug and FXScript Plug-ins with Similar Behavior
The following list shows Final Cut Studio FxPlug plug-ins that closely match the behavior
of existing FXScript plug-ins in Final Cut Pro, but whose names are slightly different:
FXScript (Final Cut Pro)

FxPlug (Motion)

Basic Border

Simple Border

Brightness and Contrast

Brightness

Brightness and Contrast

Contrast

Blue and Green Screen

Blue Green Screen

Spill Suppressor - Blue
Spill Suppressor - Green

Spill Suppressor

Gamma Correction

Gamma

Find Edges

Edges

For details about the FxPlug plug-ins installed with Motion, see the documentation
included with Motion.
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This chapter covers the following:
• Creating Motion Effects in the Viewer (p. 1059)
• Adjusting Parameters in the Motion Tab (p. 1060)
• Using Cartesian Geometry to Position Clips (p. 1066)
• Examples Using Motion Settings (p. 1068)
• Creating Motion Effects in the Canvas (p. 1081)
• Manipulating Images in the Canvas (p. 1082)
• Zooming In to the Canvas (p. 1083)
• Using Wireframe Handles to Transform, Scale, and Rotate (p. 1084)
• Example: Using Motion Parameters and Wireframe Handles (p. 1088)
Every video and graphics clip in a project has a set of parameters that can be edited in
the Motion tab of the Viewer. These parameters include Scale, Rotation, and Center.

Creating Motion Effects in the Viewer
Every video, graphics, and generator clip in Final Cut Pro has a set of corresponding
motion attributes, each of which contains one or more adjustable parameters. When you
change these parameters, you create a motion effect. By adjusting a clip’s motion settings,
you can change its geometry to move, shrink, enlarge, rotate, and distort the clip in nearly
any way you like, relative to your overall project. You can also adjust motion settings
graphically, by manipulating them directly in the Canvas.
Using keyframes, you can dynamically adjust motion effects over time. You can keyframe
each clip’s motion parameters to animate clips in your sequence, making them move
across the screen, rotate, and grow or shrink over time. You can also change a clip’s
opacity to make it fade in and out and dynamically adjust any applied filter effects—for
example, to make a clip go from a blur to sharp focus as a sequence plays. For details on
keyframing, see “Animating Motion Effects Using Keyframes.”
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Note: Audio parameters can be keyframed as well. For more information, see “Automating
Audio Filter Parameters with Keyframes.”

Adjusting Parameters in the Motion Tab
Motion parameters are located in the Motion tab of the Viewer. When you first edit a clip
into your sequence (assuming you didn’t change any of its motion parameters in the
Viewer), it has certain default parameter settings:
• Center, Anchor Point: 0, 0
• Scale: 100
• Rotation, Crop, Aspect Ratio, Drop Shadow, and Motion Blur: 0
• Distort: Corner points of the clip
• Opacity: 100

Working with Motion Parameters
You can use the Motion tab to view and change motion parameters for a selected clip.

µ

To view the motion parameters for a clip
Open a clip in the Viewer, then click the Motion tab.
The parameters in the Motion tab are divided into seven attribute sets. Each attribute
has its own visual and numeric parameter controls.

Basic Motion parameters

Distort attribute

µ
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To reveal parameter controls for a motion attribute
In the Motion tab, click the disclosure triangle next to the attribute.
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Drop Shadow and Motion Blur must be enabled before you can adjust their parameters.

µ

To enable the Drop Shadow or Motion Blur attribute
Select the checkbox next to Drop Shadow or Motion Blur.
Some parameters must
be enabled to use them.

Drop Shadow parameters

Motion Blur parameters

To adjust motion parameters
Do one of the following:

µ
µ
µ

Drag the slider.
Enter a new value in the number field, then press Return.
Drag the corresponding overlay in the keyframe graph.
• For settings with an Angle control: Drag the hand on the dial. The black hand indicates
the current angle of the clip; the small red hand indicates the total rotations forward
or backward.
• For settings that use x and y coordinates: Enter new coordinates in the number fields to
the right, then press Return. Some coordinate settings also have a point control; select
the control, then position the crosshair pointer at the appropriate point in the Canvas
and click.
Tip: Any motion, audio, or filter parameter can be adjusted in the keyframe graph area
of the Timeline. For more information, see “Adjusting and Deleting Keyframes.”
For more information about adjusting keyframe graphs in the Timeline, see “Working
with the Timeline Keyframe Editor.”
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Controls in the Motion Tab
The following section describes the attributes and related parameters in the Motion tab
of the Viewer.

Basic Motion parameters

Distort attribute

Keyboard Modifiers for Controls in the Motion Tab
You can use the following keyboard modifiers when using slider controls:
• To adjust the value by two decimal places of accuracy: Hold down the Shift key.
• To slow down a slider’s movement and select a more precise value: Hold down the
Command key.
You can use the following keyboard modifiers when using an Angle control (a dial):
• To constrain the dial to 45-degree increments: Hold down the Shift key.
• To slow down a dial’s movement and select a more precise value: Hold down the Command
key.
• To reset the parameter value to 0: Drag out of the dial.
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Basic Motion Parameters
The Basic Motion parameters allow you to add motion to a clip—changing the scale,
rotating a clip, moving the center point, and setting an anchor point.

Basic Motion parameters

Distort attribute

• Scale: Changes the overall size of a clip without changing its proportions.
• Rotation: Rotates a clip around its center axis without changing its shape. Clips can be
rotated plus or minus 24 rotations.
• Center: Specifies the center point of the clip, allowing you to move a clip somewhere
else in the frame. The Center parameter actually refers to the location of the clip’s
anchor point in the Canvas.
• Anchor Point: Specifies the point that is used to center a clip’s position and rotation. A
clip’s anchor point does not have to be at its center.
Crop Parameters
Change a clip’s Crop parameters to crop a clip and feather or soften the edges so that
they blend into the background when compositing.
• Left, Right, Top, Bottom: Crops the clip from the specified side. You can crop the top,
left, right, and bottom of a clip independently. Values in the number fields represent
pixels.
• Edge Feather: Applies a soft border with its outer edge at the crop line. The higher you
set the Edge Feather parameter value, the farther into your clip the feathering effect
goes.
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Distort Parameters
Change a clip’s Distort parameters to alter the rectangular shape of a clip or to give it a
different aspect ratio.
• Upper Left, Upper Right, Lower Right, Lower Left: You can change the shape of a clip by
moving each of four corner points independently of one another. The corner points
defining the relative distortion of a clip are offset relative to the center of the clip.
• Aspect Ratio: Allows you to squeeze a clip horizontally or vertically to change the ratio
of its width to its height. This parameter never increases a clip’s size. You can enter
values between –10,000 and 10,000 in the number field.
Opacity Parameter
Change a clip’s opacity to make it appear solid or with a relative transparency against a
background image.
• Opacity: Increases or decreases the transparency of a clip.
Drop Shadow Parameters
This attribute places a drop shadow behind a clip.
• Offset: Determines how far away from the clip the drop shadow falls.
• Angle: Determines which angle the drop shadow falls toward.
• Color: There are several controls you can use to determine the color of the drop shadow.
• Disclosure triangle: Click to display sliders and number fields corresponding to the
hue, saturation, and brightness (H, S, and B) of the chosen color for the drop shadow.
• Eyedropper: Lets you quickly select a color that’s in an image in the Viewer or the
Canvas. Select the eyedropper, then click an image in the Viewer or the Canvas to
pick up that color.
• Hue direction control: If you’re keyframing changes in color, click this control to
determine the direction on the color wheel Final Cut Pro uses to interpolate the color
change.
• Color picker: Click to choose a color using the standard color picker.
• Softness: Blurs the drop shadow around its edges.
• Opacity: Sets the transparency of the drop shadow.
Motion Blur Parameters
Motion blur affects any clip that has motion, whether it’s a moving subject in a video clip
or keyframed motion effects that you’ve created.
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Motion Blur allows you to create or exaggerate motion blur in ordinary video clips. For
example, if you apply motion blur to a clip in which someone is standing still and waving
an arm, the arm becomes blurred, while the rest of the image remains sharp. This happens
even though the arm waving is not a keyframed motion effect. Motion Blur also lets you
add motion blur to video clips that have none, such as computer animation that was
rendered without it.
Motion Blur can also add blur to layered clips that are moving because of keyframed
motion effects, such as animated motion along a path, rotation, changes in scale, or
distortion. This way, animated motion within Final Cut Pro can be given a more natural
look, as if the moving clips were actually recorded with a camera.
The amount of blur that appears in either case depends on the speed of the moving
subject. The faster the subject moves, the more blurred it becomes, similar to a motion
picture film or video image. The amount of blur that is added can be modified using two
parameters.
• % Blur: Affects the smoothness of the motion blur. A value of 1000 percent blurs motion
over 10 frames; a value of 100 percent blurs motion in one frame.
• Samples: Determines the detail of the applied motion blur, which is dependent upon
the speed of the motion effects applied to a clip. Additional samples appear as additional
layers of blurring. To change the number of samples, choose a number from the Samples
pop-up menu.
Tip: You can also use Motion Blur to soften the strobing effect that may appear in clips
with extremely slow motion applied to them.
Speed Parameters
The Speed parameters allow you to alter the speed of a clip to create fast- or slow-motion
effects. You can apply constant speed changes or speed changes over time. You can also
reverse the speed of a clip, making it play backward. For a detailed description of the
Speed parameters in the Motion tab, see “Using the Speed Parameter in the Motion Tab.”
For more general information about the Speed feature in Final Cut Pro, see “Changing
Clip Speed.”

Chapter 66 Changing Motion Parameters

1065

Using the Paste Attributes Command
As you composite multiple clips together in Final Cut Pro, it’s important to take advantage
of whatever shortcuts you can to eliminate steps and save time.
The Paste Attributes command in the Edit menu (with the keyboard shortcut Option-V)
is a valuable tool for selectively copying attributes from one clip to another without having
to open clips in the Viewer. It also eliminates the need to repeat steps when applying
identical effects to multiple clips. For detailed information about this command, see
“Copying and Pasting Specific Clip Attributes.”
Note: The examples in “Examples Using Motion Settings” show how you can use the
Paste Attributes command when compositing clips and creating motion effects.

Using Cartesian Geometry to Position Clips
Final Cut Pro compositing features use simple Cartesian geometry to position clips within
the frame defined by the Canvas. This makes the process of symmetrically arranging
layered clips easy and precise. Even though it’s possible to “eyeball” a lot of compositions,
a little math can go a long way, especially when you want to start creating more precise
motion effects using keyframes.
In Final Cut Pro, the center point of a layer is always relative to the center point of the
Canvas; the center point of the Canvas always has x and y coordinate values of 0, 0.

–240 pixels
Canvas center point
(0, 0)
–360 pixels

+360 pixels

+240 pixels

To position clips using their x and y coordinates, you click the Basic Motion disclosure
triangle and enter appropriate values in the Center number fields.

µ
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To move a clip to the right
Enter a positive value for the clip’s x coordinate.
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To move a clip to the left
Enter a negative value for the clip’s x coordinate.

µ

To move a clip down
Enter a positive value for the clip’s y coordinate.

µ

To move a clip up
Enter a negative value for the clip’s y coordinate.
For example, suppose the center point of the clip on track V2 is –218, –119. This puts the
clip 218 pixels to the left and 119 pixels up from the Canvas center point.

Clip center point
(–218, –119)
Y offset
(–119)
X offset
(–218)

Canvas center point
(0, 0)
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When you copy and paste these attributes to the clip on track V3, the clip appears in
exactly the same place. However, if you change its x coordinate from negative 218 to
positive 218, you put that clip’s center point 218 pixels to the right of the Canvas center
point, which moves it to the other side.

Clip center point
(+218, –119)
Y offset
(–119)
Canvas center point
(0, 0)

X offset
(+218)

Important: When you adjust a clip’s Rotation parameter, the clip is automatically rendered
using the Fastest motion filtering quality. For more information, see “How Rotation Affects
Motion Filtering Quality.”

Examples Using Motion Settings
The following two examples demonstrate how you can use motion settings to integrate
a group of clips together to create a single, multilayer broadcast design shot.

Example: Using Motion Settings to Create a Multiple Clip Layout
In this example, you’ll create a layered interview segment using the Scale, Rotation, and
Center Point parameters. This example assumes you’ve already created a new sequence
and opened it in the Timeline.
Note: This example uses a sequence created for DV clips, with a frame size of 720 x 480.
To create a layered interview segment using Scale, Rotation and Center Point
parameters
1 Open a clip in the Viewer that you want to use as a background layer (against which all
other composited layers are to appear), then edit this clip into track V1 of your sequence.
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Note: If you don’t use a background layer (such as a graphic, video clip, or Final Cut Pro
generator clip), all layered clips appear against black by default.

Initial background layer

2 Set the sequence In and Out points to be the duration of this background clip (choose
Mark > Mark Clip, or press X).

Sequence In and
Out points
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3 From the Browser, open the first clip you want to arrange in the background of your
composition, then edit it into the sequence using a superimpose edit.

A new track is created
above the current V1
video track, and your
clip is inserted into it.

4 Double-click the sequence clip you’ve just edited into the Timeline (not the background
clip) to open it in the Viewer, then click the Motion tab.

Motion settings for
this clip

Dots in the scrubber bar
indicate the clip is in
a sequence.

First, you’ll change the size of the clip so it’s smaller, and then you’ll change the rotation
so the clip is angled.
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5 Click the Basic Motion disclosure triangle to reveal the Basic Motion parameters, then
drag the Scale slider to 38 (or enter “38” in the Scale number field, then press Return).
As you drag the
Scale slider to the left,
the clip gets smaller
in the Canvas.

6 Drag the Rotation Angle control (the dial) to the left so that it reads “–28.”
A negative value rotates the clip to the left; a positive value rotates it to the right.

The change is also
reflected in the
Canvas.

This is the angle in
degrees that your
clip is rotated.

Next, you’ll change the position of this clip in the Canvas.
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7 Select the point control for the Center parameter and move the pointer to the Canvas
(the pointer changes to a crosshair), then click in the upper-left corner of the Canvas.

Point control for the
Center parameter

The change is also
reflected in the Canvas.

The new coordinates
of the clip’s center
point appear in these
number fields.

Clicking in the Canvas with the crosshair moves the x and y values of that clip’s center
point to the pixel you clicked. In this case, the first (x) coordinate reads “–218” and the
second (y) coordinate reads “–119.” You can also reposition the clip by entering these
values in the Center number fields.
Note: For more information about using basic geometry to position clips, see “Using
Cartesian Geometry to Position Clips.”
Next, you’ll add another clip to your composite.
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8 In the Timeline, specify track V2 as the current destination track (click the V2 Destination
control). Then, using a superimpose edit, edit in a second clip you want to place in the
background.

A second clip is placed in
track V3 of the sequence,
using the same In and
Out points.

Now, you want to copy all the motion settings from the first clip and selectively apply
them to this second clip.
9 Select the clip in track V2 that you resized and repositioned, then choose Edit > Copy.
Next, select the clip in track V3, then choose Edit > Paste Attributes.

Select the clip in track V3,
so you can paste
attributes into it.

The Paste Attributes dialog appears. By selecting various options in this dialog, you can
paste only the attributes you want to use from the copied clip into the currently selected
clip.
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10 Select the Basic Motion checkbox, then click OK.

This setting is the only
attribute you want
to copy.

The two clips occupy the same position in the Canvas, but the clip on track V3 takes
precedence and appears in the Canvas.

The new clip in track V3
now has the same
motion settings as the
clip in track V2.

Although you want to keep the size of this new clip the same, you want to position it in
the right corner, as a mirror image of your original clip.
11 Double-click the clip on track V3 to open it in the Viewer, then click the Motion tab.
12 In the left number field of the Center parameter (the x coordinate), delete the minus sign
(–), then press Return.

The value changes
from negative 218 to
positive 218. The results
appear immediately in
the Canvas.
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Note: The x and y coordinates of a clip in the Canvas are based on the offset between
that clip’s center point and the center point of the Canvas. See “Using Cartesian Geometry
to Position Clips” for more information.
Now, you want to make this clip rotate to the right rather than to the left.
13 Delete the minus sign (–) from the Rotation number field, then press the Return key.

The two clips are now
on opposite sides,
rotated differently.

Now that you have all your background layers set up, it’s time to edit in the foreground
clip that’s going to appear in front of these layers.
14 Using the same sequence In and Out points that you’ve been using, set the destination
track of your sequence to V3, then edit in the foreground clip using a superimpose edit.

The fourth clip is now
in your sequence.

15 Open this new clip in the Viewer, then click the Motion tab.
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16 Click the Basic Motion disclosure triangle to reveal the Basic Motion parameters, then
adjust the Scale slider to 66, so that this clip is 66 percent of its original size.
Set the Scale slider to 66.

The foreground clip
is now 66 percent of
its original size.

Now you need to move this clip down so it doesn’t obscure the clips in the background
as much. To make sure important elements in your sequence are not cut off at the edges
when you’re layering these clips, you should show the Title Safe indicators. The Title Safe
indicators show the title safe and action safe boundaries, so you can position your
composited clips and titles accordingly.
17 Choose View > Show Title Safe.
The action safe boundary
is 10 percent smaller
than the size of the
video frame.

The title safe boundary
is 20 percent smaller
than the size of the
video frame.

18 Enter “37” in the right number field of the Center parameter.
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Viewing the title safe and action safe boundaries, you see that you’re within the area that
is viewable on most television monitors.

You can now see
more of the clips in
the background.

Enter “37” here to move
the clip down 37 pixels.

Tip: Viewing title safe and action safe boundaries is especially important when creating
work that will be broadcast on television. Televisions cut off the edge of the video frame
to give the illusion that the picture takes up the entire TV screen. The amount that gets
cut off varies from manufacturer to manufacturer.

Example: Using Additional Motion Settings to Refine the Layout
In this example, the Crop, Opacity, and Drop Shadow parameter settings are changed to
further customize the sequence you created in the previous example.
To customize a sequence using the Crop, Opacity, and Drop Shadow parameters
1 Open the clip on track V4 of your sequence in the Viewer, then click the Motion tab.

Motion settings for
the clip in track V4

First, you’ll feather the edges of your foreground clip to give it a soft border.
2 Click the Crop disclosure triangle to reveal the Crop parameters.
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3 Drag the Edge Feather slider to the right until it’s set to 64.

A soft border appears
around the clip in
the Canvas.

Next, you’ll apply the same amount of feathering to the other two background clips
without opening the clips.
4 Select the foreground clip in track V4, then choose Edit > Copy.
5 Drag a box around the two background clips in tracks V3 and V2 to select both clips, then
choose Edit > Paste Attributes.
6 In the Paste Attributes dialog, select the Scale Attribute Times and Crop checkboxes,
leaving all other options unselected, then click OK.

The feathering you set
in the foreground clip
is now applied to the
background clips.

Now, you’ll make two further adjustments to the foreground clip, making it seem a bit
wider and allowing the clips in the background to be more visible.
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7 Drag the Top and Bottom sliders in the Crop attribute to the right until they are set to 5.

The resulting change
to the clip is displayed
in the Canvas.

Adjust these sliders so
the foreground clip is
slightly cropped.

Now, you’ll add a drop shadow to these three layers.
8 With the Motion tab of the foreground clip still open in the Viewer, select the checkbox
next to Drop Shadow to enable the attribute, then click the Drop Shadow disclosure
triangle. Using the appropriate controls, set the offset to 10, the angle to 135, the softness
to 23, and the opacity to 65.

Adjust the settings
for the Drop Shadow
attribute.

9 To apply these settings to the other two clips, select the clip in track V4 in the Timeline,
then choose Edit > Copy. Select the clips on tracks V2 and V3, then choose Edit > Paste
Attributes.
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10 In the Paste Attributes dialog, select the Drop Shadow checkbox, then click OK.

Both selected clips now
display a drop shadow.

Finally, you want to darken the background layer, since it’s competing with the foreground
layers.
11 Open the background clip on track V1, then click its Motion tab. Click the Opacity disclosure
triangle, then set the opacity to 50 percent.

The background clip
now appears darker in
the Canvas.

Now you have your completed composite: three clips layered, cropped, scaled, and
rotated, with edges feathered.

1080

Chapter 66 Changing Motion Parameters

Creating Motion Effects in the Canvas
Motion settings of sequence clips can also be manipulated directly in the Canvas. If you
want to adjust a clip’s motion settings in the Canvas, the Canvas must be in one of the
“wireframe” modes. When the Canvas is in Image+Wireframe or Wireframe mode, the
currently selected clip has a turquoise border that shows its scale, position, rotation,
distortion, and cropping, if any are applied. If you are in Image+Wireframe mode, you
also see the clip’s image; in Wireframe mode, unselected clips are represented by a black
background with a gray outline.

Selected clip in
Image+Wireframe mode

To put the Canvas into a wireframe mode
Do one of the following:

µ
µ

Choose View > Image+Wireframe, or choose View > Wireframe.

µ

Choose Image+Wireframe or Wireframe from the View pop-up menu at the top of the
Canvas.

Press W to put the Canvas in Image+Wireframe mode. Press W again to change to
Wireframe view. Press W a third time to return to Image mode.

Choose one of the
wireframe modes.
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Which View Should You Use?
There are several view and background options you can specify that make it easier to
work with composited layers in your sequence, specifically in the Canvas. For more
information, see “Canvas Basics.”
• Image+Wireframe: Use this option when adjusting motion effects directly in the Canvas.
• Wireframe: This option is useful if you’re working on high-resolution clips and you want
to make a lot of changes quickly, without having to wait for your image to update. The
Wireframe option is also useful for quickly previewing motion you’ve created using
keyframes (discussed in “Animating Motion Effects Using Keyframes”).
• RGB and Alpha views: You can view your sequence in the Canvas with RGB, Alpha, or
Alpha+RGB enabled. When compositing, you may want to look at the alpha channel
of your clip, which defines areas of transparency and can change if various filters are
applied. This can show you which areas of your frame are solid or transparent so you
can make sure the clip is properly set up.
• Background options: When working with clips that have an alpha channel, or with a
series of small clips that you’re compositing against a blank background, you can choose
different backgrounds to make it easier to see which areas of your composition are
transparent or in the background. For example, translucent clips or generated text may
be more visible if you choose a background that emphasizes them, such as checkerboard
1 or 2.

Manipulating Images in the Canvas
When a clip is selected in the Timeline or Canvas (and you are in a wireframe mode), there
are handles attached to the clip that allow you to perform different geometrical
manipulations. A number at the center of the selected clip shows which track the clip is
in. Shown below are the different handles on a selected clip in the Canvas.
Rotational handle

Center handle (the
number indicates that
this clip is in track V4)

Scale/Distort handle

1082

Chapter 66 Changing Motion Parameters

Using the Selection, Crop, and Distort tools in the Tool palette, you can drag a clip’s
handles directly in the Canvas to create various effects.
• Center handle: Drag this handle of a clip’s wireframe with the Selection tool to reposition
the clip in the Canvas (changing its Center setting in that clip’s Motion tab).
• Rotational handle: Drag one of these four handles with the Selection tool to rotate the
clip in the Canvas (changing its Rotation setting in that clip’s Motion tab).
• Scale/Distort handles: Drag one of the four corner points of a clip with the Selection
tool to modify its Scale setting. Drag one of these four points with the Distort tool to
move that point independently of the others (changing the appropriate Distort setting
in that clip’s Motion tab).
• Crop handles: You can also drag one of a clip’s four sides with the Crop tool to adjust
how the clip is cropped (changing the appropriate Crop setting in that clip’s Motion
tab).

Crop and Distort Tools
The Crop and Distort tools can be used to manipulate images directly in the Canvas,
instead of setting parameter values in a clip’s Motion tab.

Distort tool
Crop tool

• Crop tool: Allows you to drag each of a clip’s four sides inward to crop just that side.
You press the C key to select the Crop tool.
• Distort tool: Lets you drag each of a clip’s corner points independently, in order to
create perspective effects and other geometric distortion. You press the D key to select
the Distort tool.

Zooming In to the Canvas
In the Canvas, you can choose a magnification level to help you work with your clips as
you manipulate them. By zooming in to the Canvas, you can get a more detailed look at
your layers, which can help you make more precise positioning decisions. By zooming
out of the Canvas and making the image smaller, you can more easily move clips out of
the frame, in preparation for creating keyframed motion from the outside of the frame
to the inside.
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Note: The zoom level you specify changes the display size of the image only and doesn’t
affect the frame size of your edited sequence.
To zoom in to the Canvas
Do one of the following:

µ
µ

Choose View > Level, then choose a magnification level from the submenu.
With the Canvas active, press Command-Equal Sign (=) to zoom in; press
Command-Hyphen (-) to zoom out. The zoom increments are the same as those in the
View pop-up menu.

Magnification levels

Tip: To reset the zoom level to the current size of the Canvas, make the Canvas active,
then choose View > Level > Fit to Window (or press Shift-Z). This command also works
in the Viewer.

µ

Choose a magnification level from the View pop-up menu in the Canvas.

Using Wireframe Handles to Transform, Scale, and Rotate
In many instances, you may find that dragging the handles of a selected clip in the Canvas
is faster and more intuitive than adjusting its parameters in the Motion tab of the Viewer.
Note: You must be in Image+Wireframe or Wireframe mode to use wireframe handles.
To scale a clip
1 Select a clip in the Timeline.
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2 Select the Selection tool in the Tool palette, then do one of the following:
• To scale the clip proportionally: Drag a Scale/Distort handle.

Drag a Scale/Distort
handle to scale
proportionally.

• To scale the clip without constraining the proportions: Shift-drag a Scale/Distort handle.

Shift-drag a Scale/Distort
handle to scale in one
direction or the other.

To move a clip
1 Select a clip in the Timeline.
2 Select the Selection tool in the Tool palette, then drag the layer to a new position.

You can move a clip
partially or completely
outside the Canvas.

To rotate a clip
1 Select a clip in the Timeline.
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2 Select the Selection tool in the Tool palette, then drag any edge of the selected clip’s
border in an arc around the clip’s center point.

Drag any edge with the
Selection tool to rotate
the clip.

• The farther away from the clip’s center point you drag, the more precise control you
have over the rotation.
• To constrain rotation to 45-degree increments, hold down the Shift key while dragging.
• Continuous dragging increases the total number of rotations performed, if you’re
creating keyframed movement.

µ

To scale and rotate a clip
Command-drag a Scale/Distort handle.

Command-drag a
Scale/Distort handle to
scale and rotate the clip.

To distort the shape of a clip
1 Select a clip in the Timeline.
2 Select the Distort tool in the Tool palette, then drag a Scale/Distort handle.

Drag a Scale/Distort
handle with the Distort
tool to distort the clip.
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Tip: To shorten one side and lengthen the other side of an image, hold down the Shift
key while dragging.

Hold down the Shift key as
you drag to change all four
points simultaneously and
give the appearance of a
change in perspective.

To crop a clip
1 Select a clip in the Timeline.
2 Select the Crop tool in the Tool palette, then do one of the following:
• To crop a particular side: Drag in from the edge of the clip.

Drag an edge with the
Crop tool to crop that
side of the clip.

• To crop two sides at one time: Drag one of the corners of the wireframe.

Drag a corner with the
Crop tool to crop two
sides at once.

Chapter 66 Changing Motion Parameters

1087

• To constrain the rectangle’s aspect ratio: Hold down the Shift key while dragging a corner.

Shift-drag a corner with
the Crop tool to maintain
the aspect ratio.

Example: Using Motion Parameters and Wireframe Handles
In this example, you’ll put a graphic on the side of a building as if it were a sign. You’ll
use the Scale, Center, and Distort parameters (in the Motion tab of the Viewer) to match
the perspective of the building with the perspective of the sign, and the Selection and
Distort tools to manipulate the graphic directly in the Canvas. This example assumes
you’ve already created a new sequence and opened it in the Timeline.
Note: This example uses a sequence created for DV clips, with a frame size of 720 x 480.
To use the Scale, Center, and Distort parameters to match perspective
1 Edit a shot of a building into track V1 of your sequence.

The clip shown here
is a locked-down shot
of a building from a
three-quarter angle
(a locked-down shot is
one where the camera
does not move).
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2 Import a graphics file (such as a PICT file) of a sign into your project, then open it in the
Viewer.

This shows the graphic
you’ll place on the side
of the building.

3 In the Canvas or Timeline, position the playhead over the clip you just edited into track
V1, then set the sequence In and Out points to be the duration of the building clip (choose
Mark > Mark Clip, or press X).
Position the playhead
anywhere within the clip.

Set the In and Out points
for the duration of this clip.

4 Perform a superimpose edit to place the sign in track V2 for the duration of the shot.

The sign is now on top
of the building.

Instead of changing settings in the Motion tab, you’ll manipulate the images in the Canvas.
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5 In the Timeline, select the image, then choose Image+Wireframe from the View pop-up
menu in the Canvas.

The selected layer in
track V2 is outlined
in turquoise.

6 With the Selection tool selected, hold down the Shift key, then drag one of the corners
of the sign graphic to change its scale to match that of the building.

Scale down the size
of the sign graphic.

7 With the Selection tool, drag the center point of the sign graphic to move it so that its
position matches that of the wall.

Move the graphic so it’s
positioned entirely on
the building’s side.
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8 Select the Distort tool in the Tool palette, then drag each of the four corners of the sign
graphic until they match the perspective of the side of the building.

Use the Distort tool to
match the perspective
of the building.

Tip: To make the sign look more convincing, you can also add a subtle drop shadow by
enabling the Drop Shadow attribute in the Motion tab of the sign clip.
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Adjusting Parameters for
Keyframed Effects

67

This chapter covers the following:
• Animating Motion Effects Using Keyframes (p. 1093)
• Smoothing Keyframes with Bezier Handles (p. 1113)
• Creating Keyframed Motion Paths in the Canvas (p. 1117)
• About the Timeline Keyframe Graph Area (p. 1127)
• Customizing the Keyframe Graph Area in the Timeline (p. 1129)
Automated audio level adjustments, opacity changes between layers, shifting color values,
and spinning video clips are examples of what’s possible when using keyframes to adjust
clip parameters over time.

Animating Motion Effects Using Keyframes
The word keyframe comes from the traditional workflow in the animation industry, where
only important (key) frames of an animated sequence were drawn to sketch a character’s
motion over time. Once the keyframes were determined, an in-between artist drew all
the frames between the keyframes. With Final Cut Pro, you can set parameters to specific
values at specific times and Final Cut Pro acts as an automatic, real-time in-between artist,
calculating all the values between your keyframes.
Effects, such as opacity, position, and any other of a clip’s Motion tab settings, can be
dynamically changed over the course of your sequence using keyframes. Keyframes are
available throughout Final Cut Pro for any feature with parameters that can be changed
over time, and keyframes can be used to create sophisticated motion, filter, and
transparency effects.
Many clip parameters can be keyframed:
• Opacity
• Motion settings
• Generators
• Filters
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• Audio levels
• Pan settings
• Speed
Because you can add keyframes to filters and generators as well as motion settings, the
information presented in this chapter can also be used to modify filters and generators
(discussed in “Using Video Filters” and “Using Generator Clips”).

How Keyframing Works
You place keyframes at specific points in a clip or sequence to change parameter values
at those points. For example, if you want the last clip in your sequence to fade to black,
you set two opacity keyframes at two different times: one with the value of 100 (fully
visible) and a second with the value of 0 (fully transparent). Final Cut Pro interpolates the
values between 100 and 0, creating a smooth fade to black.
To add keyframes to a sequence clip, you can use the Canvas or Timeline, or you can
open the clip in the Viewer. If you’re keyframing motion, you set keyframes in the Motion
tab of the Viewer; if you’re keyframing filter effects, you set keyframes in the Filters tab
of the Viewer.
Note: You can also add keyframes to master clips that are opened in the Viewer from the
Browser, but these keyframed effects accompany the clip whenever it’s edited into a
sequence.
When you use two or more keyframes to change an effect over time, Final Cut Pro
automatically interpolates the values between the keyframes so that there’s a smooth
change in that parameter. For example, when you look at a clip with a change in opacity
using two keyframes, you can see the gradual change from one keyframe to the other in
the slope of the opacity overlay, as shown below in the Timeline.
First keyframe

Second keyframe
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Adding additional keyframes increases the complexity of the effect, but the area in
between each pair of keyframes in your clip is still smoothly interpolated.

Determining the Number of Keyframes to Use
The complexity of the changes in your effects depends on the number of keyframes that
you add to a clip. You need at least two keyframes in a clip to make a dynamic change
from one value in an effects parameter to another. A more sophisticated change requires
three keyframes. To isolate a keyframe change to a certain section of the entire overlay
for an effect, you need at least four keyframes.
Creating Simple Effects with Two Keyframes
The simplest thing you can do to make a change is to add two keyframes. For example,
you can change the size, or scale, of a clip by adjusting its scale from 25 percent at the
first keyframe to 75 percent at the second keyframe.

Two keyframes let you
create a basic change.
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Using Three Keyframes
With three keyframes, you can create more complex effects, such as a curved motion
path. In the example below, the position of the clip starts at the location specified by the
first keyframe, moves to the position specified by the second keyframe, and then continues
on its journey until it reaches the position specified by the third keyframe. (For more
information about creating motion paths in the Canvas, see “Creating Keyframed Motion
Paths in the Canvas.”)
Keyframe 2

Keyframe 3

Keyframe 1

Using Four or More Keyframes for Complex Effects
You can make isolated changes to sections of an overlay for an effect if you have at least
four keyframes. For example, if you have a superimposed clip that’s set at 50 percent
opacity for the duration of the clip, but you need it to go to 100 percent for 3 seconds
right in the middle, you can create four keyframes on that clip’s opacity overlay. Now you
can have the opacity level of the clip start at 50 percent, jump to 100 percent for the
duration the keyframes specify, and then drop back to 50 percent for the remaining
duration of the clip.
Using four keyframes, you
can isolate changes to specific
sections of a clip’s overlay.
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Keyframing Controls in the Viewer
You can use various controls for keyframing motion effects. Although motion effects,
filters, and generator clips have their own individual settings and controls, they use the
same controls for keyframing.

Keyframe button

Keyframe navigation
buttons

Reset button

• Keyframe button: Click to place a keyframe for the corresponding parameter in the
keyframe graph area at the current playhead location.
Note: When the playhead in the keyframe graph area is directly on a keyframe, the
keyframe button for that setting becomes a green diamond.
• Keyframe navigation buttons: Click these buttons, to the left and the right of the keyframe
button, to move the playhead from one keyframe to another.
• Reset button: Click to delete all marked keyframes and reset the parameter to its default
value.
• Keyframe graph area: Shows all the values and keyframes associated with parameters
currently displayed in the Viewer.
Keyframe graph area
Keyframe graph ruler

Section of clip
not used

Section of clip
not used
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• Keyframe graph ruler: Corresponds to the duration of the clip or the location of a clip
in a sequence:
• If a clip is opened from the Browser: The keyframe graph ruler shows the duration of
the clip itself. The playhead in the Viewer moves independently of the playhead in
the Timeline or Canvas.
• If a clip is opened from a sequence in the Timeline: The keyframe graph ruler shows
the section of the Timeline that the clip is edited into. The playhead in the Viewer is
locked to the playhead in the Timeline and the Canvas.
• Section of clip currently used: The frames of a clip in the Viewer that are outside the
duration specified by its In and Out points are dimmed so that you know where to
apply your keyframes.
• Current Timecode field: Displays the position of the playhead in the keyframe graph
area. You can enter a new timecode value to move the playhead to another position.

Current
Timecode field

Zoom control

Zoom slider

• Zoom control: Lets you zoom in to and out of the duration displayed by the ruler in
the keyframe graph area, expanding and contracting the keyframe graph ruler as you
do so. This also keeps the area of the visible keyframe graph centered as you zoom
into or out. For more information, see “Zooming In to the Keyframe Graph Area.”
• Zoom slider: Lets you zoom in to and out of the duration displayed by the keyframe
graph ruler. Drag the thumb tabs on either side of the slider to adjust both thumb tabs
and leave the visible area of the keyframe graph centered. Press the Shift key and drag
one of the thumb tabs to zoom in to or out of the keyframe graph, locking the opposite
thumb tab and moving the visible area of the Timeline in the direction in which you’re
dragging. For more information, see “Zooming In to the Keyframe Graph Area.”
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Keyframing Tools in Final Cut Pro
Three tools in the Tool palette allow you to add, modify, or remove keyframes on a
parameter’s keyframe graph line in the keyframe graph area.

Smooth Point tool
Pen Delete tool
Pen tool

• Pen: Allows you to add keyframes to a parameter in the Motion tab or Timeline keyframe
graph area by clicking in the keyframe graph area. (To select this tool, press the P key.)
• Pen Delete: Lets you delete a keyframe from a parameter by clicking the keyframe itself.
(To select this tool, press the P key twice.)
• Smooth Point: Allows you to smooth a keyframe’s interpolation by clicking the keyframe
itself. (To select this tool, press the P key three times.)

Keyboard Modifiers for the Pen Tool
To use the Pen tool most efficiently, use these keyboard modifiers:
• Hold down the Option key while the Selection tool is active to temporarily turn on the
Pen tool, then click in the keyframe graph area of the Motion tab or the Timeline to
add a keyframe at that point.
• To remove the keyframe with the Pen Delete tool, hold down the Option key and click
an existing keyframe.
In addition, you can Control-click a keyframe and choose Smooth from the shortcut
menu to add Bezier handles to the keyframe. See “Smoothing Keyframes with Bezier
Handles” for information on Bezier handles.

Setting Keyframes
Until you create at least one keyframe for a parameter of a clip, changes you make to
that parameter affect the entire duration of the clip. Once you set the first keyframe for
a parameter, additional keyframes are generated automatically when you make any
subsequent changes to that parameter anywhere else in that clip. You generally need to
set at least two keyframes to make changes or effects that are useful or noticeable.
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Note: For some parameters, you must click the parameter’s disclosure triangle to view
its keyframes in the keyframe graph area.
To better adjust and view the keyframes you’re setting, you may want to zoom in to the
keyframe graph area (see “Zooming In to the Keyframe Graph Area”).
To set a keyframe
1 Open a clip in the Viewer, then click the Motion or Filters tab.
2 In the keyframe graph area, move the playhead to the location where you want to put a
keyframe.
3 Click the keyframe button that corresponds to the parameter you are modifying.

Click the keyframe
button for a parameter
to add a keyframe
at the playhead’s
current location.
The keyframe appears
as a small diamond in
the keyframe graph area.

Tip: Any motion effect, audio parameter, or filter parameter can be adjusted in the
keyframe graph area of the Timeline.
For more information about adjusting keyframe graphs in the Timeline, see “Working
with the Timeline Keyframe Editor.”
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To set keyframes from the Viewer or Canvas
Do one of the following:

µ

To add a keyframe to all of the selected clip’s motion settings at once, click the Add
Motion Keyframe button in the Video tab of the Viewer or in the Canvas.

Add Motion Keyframe
button in the Canvas

µ

To set keyframes for a single parameter, Control-click the Add Motion Keyframe button,
then choose a parameter from the shortcut menu.

Choose a motion
parameter from the
shortcut menu.

To set a keyframe using the Pen tool
Do one of the following:

µ

Select the Pen tool in the Tool palette (or press P); then, in the appropriate tab of the
Viewer, click a parameter’s keyframe graph line (in the keyframe graph area) where you
want to add the keyframe.

µ

Hold down the Option key and click a parameter’s keyframe graph line where you want
to add the keyframe.
Tip: This is also useful for setting keyframes in the video opacity and audio level overlays
of a clip in the Timeline.
Once you’ve added at least one keyframe to a parameter, new keyframes are automatically
added whenever you move the playhead and make further adjustments. To better see
what you are doing, you may want to add more space to the keyframe graph area before
you set additional keyframes. For more information about resizing the keyframe graph
area, see “Resizing the Keyframe Graph Area.”
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To add more keyframes
1 Move the playhead to another point in the clip where you want to set a keyframe.
2 Do one of the following:
• Adjust the appropriate parameter control.
• Type a number in the appropriate number field.
• Click a parameter’s keyframe button to add a keyframe with the current value of the
parameter.
• Hold down the Option key and click a parameter’s keyframe graph line where you want
to add the keyframe.
This doesn’t change the parameter’s current value; it simply adds a keyframe with the
same value. You can add as many keyframes as you want by clicking repeatedly with the
Option key held down.

Adjusting and Deleting Keyframes
After you add keyframes to a parameter, you can adjust keyframes to produce the effect
you want. You can modify individual keyframes, interpolated values between keyframes,
or all keyframes at one time. You can also move and delete keyframes at any time.
To adjust the value of a single keyframe
Do one of the following:

µ

Move the playhead to the keyframe you want to adjust, then drag the appropriate
parameter control to a new value.

µ

Move the playhead to the keyframe you want to adjust, type a new value in the
appropriate parameter’s number field, then press Return.

µ

Move the pointer over the keyframe you want to modify (the pointer becomes a crosshair),
then drag the keyframe up or down.
• To raise the keyframe’s value: Drag the keyframe up.
• To lower the keyframe’s value: Drag the keyframe down.
As you drag, a box
shows the new value
of the keyframe.
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µ

To adjust a parameter value between two keyframes
Move the pointer over the section of the parameter’s keyframe graph line between the
two keyframes (the pointer turns into the Adjust Line Segment pointer), then drag that
area up or down to modify it.
Drag the area up or
down to adjust a section.

Note: The keyframes on either side of the adjusted section are changed simultaneously.
To adjust the values of an entire parameter with all keyframes simultaneously
1 Hold down the Shift key, then move the pointer over a parameter’s keyframe graph line
(the pointer turns into the Adjust Line Segment pointer).
2 Drag the parameter’s keyframe graph line up or down to change the value.
As you drag, a box displays the new values for the overlay.
Note: This method changes the values for that parameter over the course of your entire
clip, keeping the relative shape of the keyframes and interpolated values intact.

µ

To move a keyframe forward or backward in time
Position the pointer over the keyframe you want to move (the pointer turns into a
crosshair), then drag the keyframe forward (right) or backward (left).
As you drag, a box shows the timecode duration of the change you’re making.
To delete a keyframe
Do one of the following:

µ

Control-click the keyframe you want to remove, then choose Clear from the shortcut
menu.
Control-click a keyframe,
then choose Clear to
delete it.

µ

Move the playhead to the keyframe you want to remove, then click the keyframe button
for the corresponding parameter.

µ

Position the pointer over the keyframe you want to remove (the pointer turns into a
crosshair), then drag the keyframe out of the keyframe graph area. When the pointer
turns into a small trash can, release the mouse button.

µ

Hold down the Option key, position the pointer over the keyframe you want to remove
(the pointer turns into the Pen Delete tool), then click the keyframe.
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Note: This is also a good way to delete keyframes directly in the opacity and level overlays
of a clip in the Timeline.

µ

To delete keyframes for all of an attribute’s parameters
Click the Reset button for the appropriate attribute.

Click the Reset button
to delete all keyframes
for an attribute.

Moving Between Keyframes
As you work with keyframes, you’ll need to move to different keyframes to check your
motion effects.

µ

To move the playhead from one keyframe to another
Click the left or right keyframe navigation button for the appropriate parameter.

µ

To move left one keyframe
Press Option-K.

µ

To move right one keyframe
Press Shift-K.
Note: The keyframe navigation commands work only on tracks with Auto Select turned
on.

Resizing the Keyframe Graph Area
For precise keyframe adjustments, you can resize the display height and width of each
parameter in the keyframe graph area.
If you need more vertical space to view your keyframes in the Viewer, you can adjust the
display height of any parameter in the Filters, Controls, or Motion tab.
To adjust the display height of a parameter in the Filters, Controls, or Motion tab
1 In the keyframe graph area, move the pointer over the lower edge of the parameter
whose display height you want to adjust.
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2 When the pointer turns into a Resize pointer, drag to resize the parameter display height.
Drag up to make the parameter display height shorter, or drag down to make it taller.

Drag up to make the
parameter display
height shorter.

Drag down to make
the parameter display
height taller.

µ

To adjust the width of the keyframe graph area
Drag the lower-right corner of the Viewer to the right to adjust its width.

To temporarily work with the Motion or Filters tab in the Timeline
1 Drag the Motion or Filters tab from the Viewer to the Timeline.
The tab is now a tab within the Timeline.
2 When you’ve finished making adjustments, do one of the following:
• Control-click the tab, then choose Close Tab from the shortcut menu.
• Drag the tab back to the Viewer.
The tab reappears in the Viewer.

Zooming In to the Keyframe Graph Area
For a more detailed view of the keyframes you’re setting and adjusting, you can zoom in
to and out of the keyframe graph area in the Motion and Filters tabs in the Viewer.
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µ

To zoom using the Zoom slider
Drag the left or right thumb tab on the side of the Zoom slider. While zooming, the visible
area of the keyframe graph stays centered.
Hold down the Shift key while you drag one of the thumb tabs to zoom in to or out of
your sequence from the selected end of the Zoom slider, while keeping the other thumb
tab locked in place. This also moves the visible area of the keyframe graph in the direction
you’re dragging as you zoom.
Zoom slider

Thumb tabs on either
end of the slider

To zoom using keyboard shortcuts
1 With the keyframe graph area open, place the playhead at the location in the keyframe
graph area where you want the center of your zooming to occur.
2 Do one of the following:
• To zoom in: Press Command-Equal Sign (=).
• To zoom out: Press Command-Hyphen (-).
To zoom using the zoom tools
1 Select the Zoom In or Zoom Out tool in the Tool palette.

Zoom In tool

Zoom Out tool

2 Do one of the following:
• Click in the keyframe graph area.
• Drag to select a region to zoom in to or out of.
As you drag, the view automatically snaps to the specified percentages of zoom in the
keyframe graph area.
• Click or drag repeatedly to increase the zoom factor.
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When the keyframe graph is zoomed in or out to the maximum level possible, the plus
and minus signs on the zoom tools disappear.
With a zoom tool selected,
click in the keyframe
graph area (Zoom In tool
shown here).

Note: To temporarily switch the tool, press Option while the Zoom In or Zoom Out tool
is selected.
Once you’ve zoomed in to the keyframe graph area, you can navigate to different parts
of your clip using the Zoom slider.

µ

To scroll along the entire duration of your clip
Drag the center of the Zoom slider to the left or to the right.

µ

To change the duration of the keyframe graph ruler
Click or drag the Zoom control.
• To zoom out and show more of your sequence: Click the right side of the control.
• To zoom in and show more detail: Click the left side of the control.
Note: The current area of the keyframe graph remains centered.

Zoom control

Adjusting All Opacity Keyframes of a Clip
You can raise or lower the values for all opacity keyframes in a clip (or multiple clips) at
one time by choosing Modify > Levels (or pressing Command-Option-L). You can adjust
all opacity keyframes, either up or down, maintaining the relative positions of the
keyframes, or you can set all keyframes to a single, absolute level (effectively removing
any variations in opacity over time). You can also use this command to modify audio level
keyframes. For more information, see “Adjusting Audio Levels in the Timeline.”

Example: Using Keyframes to Make Opacity Changes
This example illustrates how you can use Final Cut Pro to dynamically adjust opacity over
time to create sophisticated multilayer effects. You’ll layer two clips and adjust a clip’s
opacity over time. The topmost clip fades in, appears superimposed above the other clip
for a few seconds, and then fades up (nearly obscuring the underlying image) before
fading away completely.
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To dynamically adjust opacity over time
1 Edit two clips of equal duration into your sequence, each in its own video track.
Note: The clip you want to appear in front should be placed in track V2; the other clip
should be placed in track V1.

Layer the clips, with one
clip in track V1 and the
other superimposed in
track V2.

2 Open the clip in track V2 in the Viewer, then click the Motion tab.
3 Click the disclosure triangle for the Opacity parameter to reveal its keyframe graph line
in the keyframe graph area.
4 To adjust the opacity of the entire clip, do one of the following:
• Drag the Opacity slider to the left until the value in the number field reads “50.”
• Type “50” in the Opacity number field, then press Return.
• Position the pointer over the Opacity keyframe graph line in the keyframe graph area;
when the pointer turns into the Adjust Line Segment pointer, drag down until the value
in the number field reads “50.”

The image in the Canvas
now shows both layers
blended together.
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5 In the Current Timecode field of the Motion tab, enter “01:00:02:00” to move the playhead.
Entering the new
timecode value
moves the playhead
to this location.

6 Click the keyframe button for the Opacity parameter to create a keyframe at the new
position of the playhead.
Because it takes at least two keyframes to create a dynamic change to a parameter over
time, you’ll need to add another keyframe.
7 Move the playhead to 01:00:03:00 on the keyframe graph ruler, then create another
keyframe.

A second keyframe is
added to the Opacity
keyframe graph line.
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8 In the keyframe graph area, move the pointer to the left of the two keyframes on the
Opacity keyframe graph line. When the pointer turns into the Adjust Line Segment pointer,
drag down until the number field reads “0.”

A segment at 50 percent
opacity results in an even
mix of both layers.

A segment at 0 percent
makes the top layer
invisible for the duration
of the segment.

The increase from
0 percent to 50 percent
causes the clip in track V2
in the Timeline to
fade up over the clip
in track V1.

The shape you’ve given to the Opacity parameter’s keyframe graph line makes the top
layer completely invisible for the first 2 seconds of playback. Over the next second it fades
up until it reaches a total opacity of 50 percent, which looks like an even mix of both
layers.
9 Move the playhead to 01:00:04:00, then add another opacity keyframe.
Because you can’t move this keyframe without causing a ramp in that segment of the
keyframe graph line, you need to add another keyframe.
10 Move the playhead to 01:00:05:00, then add another keyframe.
11 Adjust the opacity setting of this last keyframe to 100 percent.
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The shape of the Opacity parameter’s keyframe graph line leaves the opacity of the top
layer at 50 percent for 1 second, and then the topmost layer fades up to 100 percent,
completely obscuring the clip on track V1.
12 To complete this sequence, fade the topmost layer out again by adding one last keyframe.
Move the playhead to 01:00:06:00, add another keyframe, then change its opacity value
to 0.

Tip: You can also do the above steps using the opacity overlay in the Timeline. For more
information, see “Example: Keyframing Opacity in the Timeline.”

Example: Keyframing Opacity in the Timeline
There is a faster way to create the Opacity parameter keyframes you created in the previous
example. You do this by adjusting the clip’s opacity over time using the opacity overlay
in the Timeline.
To adjust a clip’s opacity over time using the opacity overlay
1 In the Timeline, edit two clips of equal duration into your sequence.
Note: The clip you want to appear in front should be placed in track V2; the other clip
should be placed in track V1.

Layer the clips, with one clip
in track V1 and the other
superimposed in track V2.

2 Select the Clip Overlays control to display the opacity and level overlays of each clip in
your sequence.
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3 Position the pointer over the opacity overlay (located directly on top of the clip on track
V2). When the pointer turns into the Adjust Line Segment pointer, drag the entire overlay
down so that the opacity value is 50 percent.

A box displays the opacity
value as you drag.

Tip: If you’re having problems getting the value of the overlay to be exactly 50, hold
down the Command key while you’re dragging to gear down the ratio between the
movement of your mouse and the change in the opacity value, enabling you to adjust
the overlay more precisely.
4 Now, use a shortcut to create all the keyframes you need on the overlay at once. Hold
down the Option key while you position the pointer on top of the opacity overlay on the
clip in track V2. When the pointer turns into the Pen tool, click the overlay to create five
keyframes at 01:00:02:00, 01:00:03:00, 01:00:04:00, 01:00:05:00, and 01:00:06:00 in the
Timeline.

Create five keyframes
at 1-second intervals.

Tip: If you’re having trouble creating the keyframes at exactly the times you want, try
zooming in to your clip in the Timeline by using one of the zoom controls, or by pressing
Command–Equal Sign (=) to zoom in to the location of the playhead.
5 Release the Option key, then drag each of the opacity overlay segments between
keyframes (or drag the keyframes themselves up or down to the values you want).
• To adjust an overlay segment using the Selection tool: Position the pointer so that it’s
directly over an overlay segment. When the pointer turns into the Adjust Line Segment
pointer, drag the segment up or down.
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• To adjust a keyframe using the Selection tool: Position the pointer so that it’s directly
over a keyframe. When the pointer turns into a crosshair, drag the keyframe up or down.

With the Selection
tool, drag a keyframe
(or segment) to
make adjustments.

Smoothing Keyframes with Bezier Handles
The keyframes of some motion settings and filter controls (but not audio levels) can be
smoothed. When you smooth a keyframe, one or more Bezier handles are “attached” to
the keyframe. These handles define the Bezier curve applied to a parameter’s interpolation
from one keyframe to the next. This allows you to modify the acceleration and deceleration
of the change from one keyframe’s value to the next. The velocity doesn’t cause the effect
to happen faster or slower; the overall speed of an effect is determined solely by the
distance from one keyframe to the next.
For example, if you space keyframes 2 seconds apart in the Rotation parameter, the
resulting rotation lasts 2 seconds. If you apply smoothing to one of the keyframes, the
total duration of the rotation remains 2 seconds, but the rate at which the clip rotates to
full speed and then slows down to a stop is different over the course of those 2 seconds.
If you move the two keyframes closer together, the rotation happens faster; if you move
the two keyframes farther apart, the rotation happens slower.

Two keyframes with
no smoothing

Bezier handle on one
side of a smoothed
keyframe

Chapter 67 Adjusting Parameters for Keyframed Effects

1113

Understanding Bezier Handles and Curves
When adjusting the Bezier handles that are attached to a smoothed clip, there are several
kinds of curves you can create, which result in different velocity rates.
• The steeper the curve of the Bezier handles in the parameter’s keyframe graph line (or
overlay), the faster the rate of change.
• The shallower the curve of the parameter’s keyframe graph line (or overlay), the slower
the rate of change.

Constant rate of change

Shallow rate of change

Steep rate of change

The kinds of curves you can apply to a keyframe depend on that keyframe’s location
relative to other keyframes on the parameter’s keyframe graph line.
One-Sided Bezier Handles
The first and last keyframes of a group have one-sided Bezier handles. These keyframes
begin and end any dynamic changes in a clip’s parameters, and therefore they accelerate
into a change and decelerate out of it.
Bezier handle
Last keyframe

First keyframe
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Two-Sided Bezier Handles
Keyframes that are in between other keyframes have two-sided Bezier handles. These
handles are normally locked together, so that the curve of a parameter’s keyframe graph
line has a smooth transition into and out of the keyframe, with no sudden changes.
Two-sided Bezier
handles for the
smoothed keyframe
between a beginning
and end keyframe

By default, if you change one of these handles, there’s an equal change to both sides of
the handle.
Lengthening one of the
handles automatically
lengthens the other.

Raising the height of the
curve on one side of the
keyframe lowers it on the
other, like a seesaw.

The link between these two handles can be suspended, however, to create different kinds
of sudden changes in the curve. You do this by holding down the Command key while
adjusting one of the handles.
Hold down the
Command key to change
the angle of a handle
independently of the
other handle.

Smoothing Keyframes
Smoothing a keyframe, or adding Bezier handles to it, makes the change from one
keyframe’s value to the next more gradual by applying a curve instead of a straight line.
The ability to apply smoothing to a parameter in Final Cut Pro depends on the kind of
keyframes a parameter uses.
• One-dimensional keyframes: Parameters that contain multiple values can’t be represented
by curved graph lines in the keyframe graph area. Instead, all values of the parameter
are represented by a single point on the graph. Examples of multidimensional
parameters are the Center and Anchor Point parameters (which have two values: x and
y) and the Color parameter for the Drop Shadow attribute (which has three values: hue,
saturation, and brightness).
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You cannot use Bezier handles to smooth these types of keyframes, because the
keyframe graph line cannot display multiple parameter values (such as x and y)
simultaneously. In the case of the Center or Anchor Point parameter, you can adjust
these values on curves directly in the Canvas.
• Two-dimensional keyframes: Parameters that contain a single value can be animated
with two-dimensional keyframes in the keyframe graph area. Keyframes in these
parameters’ keyframe graph lines can be smoothed, using Bezier handles to modify
their rate of change. Examples of parameters with only a single value are Scale, Rotation,
Aspect Ratio, and Opacity.

µ

To smooth a keyframe
Control-click the keyframe, then choose Smooth from the shortcut menu.

Choose Smooth from the
shortcut menu.

You can manipulate the velocity of change that takes place from one keyframe to the
next by adjusting the Bezier handles on the curve.

µ

To change the shape of a Bezier curve
Drag the Bezier handle on the side of a keyframe.

µ

To resize one side of a Bezier handle independently of the other
Hold down the Shift key as you drag a Bezier handle.
When you release the Shift key, the relative length of the two handles is locked to the
new unequal lengths you set.

µ

To change the angle between one side of a Bezier handle and the other
Hold down the Command key as you drag a Bezier handle.
When you release the Command key, the new relative angle of the two handles is locked
to the angle you set.
Hold down the
Command key to change
the angle of a handle
independently of the
other handle.

µ
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To change the length and the angle of one Bezier handle independently of the other
Hold down the Command and Shift keys as you drag a Bezier handle.
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When you release both keys, the new relative length and angle of the two handles are
locked.
Hold down the
Command and Shift
keys to change the
length and angle of a
handle independently
of the other handle.

Creating Keyframed Motion Paths in the Canvas
You can create motion for a clip by repositioning it and then setting keyframes to change
the clip’s Center parameter value over time. By setting enough keyframes, you can
eventually create the motion path you want.
There is an easier way, however, which can produce more sophisticated results: you set
up the motion in the Canvas using a motion path (in Image+Wireframe or Wireframe
mode). Once you set the first Center parameter keyframe for a clip in its Motion tab, all
subsequent changes made to that clip at different points in time introduce additional
center keyframes. When you create two or more center keyframes, they appear in the
Canvas along a line called the motion path.

What Are Motion Paths?
The simplest motion path is a straight line defined by two center keyframes. Once the
first keyframe is defined in the Motion tab, any time you move the Canvas or Timeline
playhead to another location and then move that clip’s wireframe somewhere else in the
Canvas, another keyframe is created automatically.

Chapter 67 Adjusting Parameters for Keyframed Effects

1117

For example, suppose you define a center keyframe for a video clip at the x and y
coordinates of –160, 100. You then move the playhead 3 seconds later in your sequence
and drag the clip by its center point to 160, –100. The result is a diagonal motion path
moving from the lower-left corner of the Canvas to the upper-right corner, shown below.
When your sequence plays, the clip moves along this path, with its anchor point following
the motion path exactly.
A simple motion path
results from the
movement of a clip from
this first center
keyframe...

...to this second center
keyframe.

As you add additional keyframes, you can create more complex paths. For example, with
the motion path above already defined, you can move the playhead to a location in
between these two keyframes. With the playhead in between these two keyframes,
moving the clip to –90, –90 adds a third keyframe to this motion path, shown next. In
this way, you can create as many keyframes as you like, changing the shape of the motion
path accordingly.
Tip: To move the playhead relative to these keyframes, you can view your clip’s keyframes
in the Motion tab of the Viewer. To view these keyframes below your clips in the Timeline,
you can click the Clip Keyframes control to display the keyframe graph area.
A third keyframe is
added, between two
existing keyframes, for
additional movement.
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A fourth keyframe,
between the three
others, changes the
motion path even more.
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Creating Motion Paths
The simplest way to make changes to a clip’s motion path is by manipulating it directly
in the Canvas while in Image+Wireframe mode.
To create a motion path
1 Open the clip you want to animate in the Viewer, then click the Motion tab.
2 In the Canvas, choose a wireframe mode from the View pop-up menu.
3 In the Viewer, Canvas, or Timeline, move the playhead to the location where you want
that clip’s motion to begin.
Note: When you open a clip from your sequence in the Viewer, all three playheads are
locked together, so it doesn’t matter which playhead you use.
4 Select the Selection tool in the Tool palette.
5 In the Canvas, drag the clip’s center point and position the clip at the starting point of
the motion path you want to create.

Starting point of
the motion path

6 Add a keyframe at the starting point.
For more information, see “Setting Keyframes.”
7 Move the playhead to the location where you want to add your next keyframe.
8 Drag the clip to the next position in the Canvas.

With the Selection tool
still selected, drag the
clip to the next position.

Final Cut Pro automatically adds a new keyframe and creates the appropriate motion
path in the Canvas. Repeat steps 7 and 8 to add as many keyframes as you need.
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Adding, Moving, and Deleting Keyframes in Motion Paths
You can edit a motion path directly in the Canvas by adding, dragging, or deleting
keyframes. The playhead doesn’t need to be over a keyframe for you to move or delete
it, nor does the playhead location prohibit you from adding additional keyframes to the
motion path using the Pen tool.
To add a keyframe to a motion path without moving the playhead
Do one of the following:

µ

Select the Pen tool in the Tool palette (or press the P key), then click anywhere on a
motion path to create a new keyframe.

µ

With the Selection tool selected, hold down the Option key to temporarily activate the
Pen tool, then click anywhere on a motion path.

µ

To move a keyframe in a motion path without moving the playhead
Using the Selection tool, drag a keyframe in a motion path anywhere in the Canvas.
Tip: You can drag a keyframe in a motion path outside the visible area of the Canvas to
move the clip offscreen. Zoom out of the Canvas to shrink the viewable area and make
this easier.
To delete a keyframe in a motion path without moving the playhead
Do one of the following:

µ
µ
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Control-click a keyframe, then choose Delete from the shortcut menu.
Select the Pen tool in the Tool palette (or press the P key), then Option-click an existing
keyframe.
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Creating Curved Motion Paths Using Bezier Handles
When you add a keyframe to a motion path, it’s a Bezier point (also known as a corner
point) by default. You can change corner points into curves by using the Smooth Point
tool to add Bezier handles to these points, smoothing the motion path that the anchor
point of the clip follows. When you use Bezier handles to create curved motion paths in
the Canvas, you won’t need to use as many keyframes to define complex motion paths.
A motion path
with keyframes as
corner points

Adding Bezier handles
creates a curved
motion path.

Bezier handles on motion paths in the Canvas work the same way as they do for keyframes
in the Motion tab, except that they affect the spatial motion of the clip, rather than the
velocity of the clip’s change over time. (To change the acceleration or deceleration of a
clip’s motion between two keyframes, you need to create separate Bezier handles in the
Center parameter in the Motion tab.)

µ

To add Bezier handles to a keyframe in a motion path
Select the Smooth Point tool in the Tool palette (or press the P key three times), then
click a corner point to add Bezier handles.
The velocity of these keyframes is automatically set to Linear, meaning that there is a
steady rate of speed as the clip moves from one keyframe to the next on the motion
path.
You can add Bezier handles to a keyframe on a motion path and change the acceleration
at the same time. For more information, see “Controlling Speed Along a Motion Path.”

µ

To change the shape of the motion path
Drag the Bezier handles on a keyframe.
If you want to create more complex motion paths, you can use modifier keys to adjust
the Bezier handles on each side of a keyframe independently of the other.

µ

To adjust curves in a motion path
Drag a Bezier handle to change the shape of its curve.
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µ

To resize one side of a Bezier handle independently of the other
Hold down the Shift key as you drag a Bezier handle. Release the Shift key to lock the
relative length of the two handles back together using the new unequal lengths you set.

Press Shift, then drag to
resize one side differently
than another.

µ

To change the angle between one side of a Bezier handle and the other
Hold down the Command key as you drag a Bezier handle. Release the Command key to
lock the new relative angle of the two handles back together.

Press Command, then
drag to change the
angle between one side
of a Bezier curve and
the other.

µ

To change the length and angle of one side of a Bezier handle independently of the
other
Hold down the Command and Shift keys as you drag a Bezier handle.

Press Command and
Shift, then drag to resize
and change the angle
of one side only.

1122

Chapter 67 Adjusting Parameters for Keyframed Effects

To remove Bezier handles from a keyframe in a motion path
Do one of the following:

µ

Control-click a keyframe with Bezier handles in the Canvas, then choose Make Corner
Point from the shortcut menu.

µ

Select the Smooth Point tool in the Tool palette (or press the P key three times), then
click a keyframe with Bezier handles.

Controlling Speed Along a Motion Path
The speed at which a clip travels along a motion path is determined by two factors:
• The spatial, or physical, distance between two keyframes in the Canvas: The farther a clip
has to travel in a given duration, the faster its apparent movement. The less distance
a clip moves, given the same amount of time, the slower it appears to go.
• The duration, or distance in time, between two keyframes in the Center parameter of a clip’s
Motion tab: Two keyframes 1 second apart result in faster motion than two keyframes
4 seconds apart.
You can modify a clip’s velocity, changing the quality of its movement. With no velocity
adjustments, clips move at full speed and then come to a full stop. This can result in
abrupt, artificial-looking motion. Final Cut Pro gives you the ability to change the velocity
of a clip’s motion over time, using velocity handles to modify the keyframes of a clip’s
motion path in the Canvas.
By adjusting a keyframe’s velocity in the Canvas, inertia can be added to a clip’s motion.
You can adjust the first keyframe of a motion path so that, instead of taking off at full
speed from a complete stop, the clip starts off slowly and then speeds up over time. These
speed changes are indicated by velocity tick marks along that clip’s motion path.
Note: In the two examples below, the motion is at a single constant speed.

Tick marks closer
together indicate
faster motion.

Tick marks farther
apart indicate
slower motion.
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To vary the acceleration of this clip along its motion path, you must first add Bezier handles
to the keyframes you want to adjust (see “Creating Curved Motion Paths Using Bezier
Handles”). A velocity handle appears as a small purple dot between the keyframe and
the end of the Bezier handle. You can then modify the velocity handle attached to each
Bezier handle for these keyframes.
Velocity handle

Velocity handle

The velocity of a clip’s motion from one keyframe to the next can be modified by dragging
the velocity handle in and out along the Bezier handle.

µ

To speed up a clip’s motion at the beginning and slow it down as it nears the next
keyframe
Drag the velocity handle in toward the selected keyframe.

Drag toward the keyframe
to speed up the motion at
the beginning and then
slow it down as it nears
the next keyframe.
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µ

To slow down a clip’s motion at the beginning and speed it up as it nears the next
keyframe
Drag the velocity handle away from the selected keyframe.

Drag away from the
keyframe to slow down
the motion of the clip at
the beginning and then
speed it up as it nears the
next keyframe.

µ

To add Bezier handles to a keyframe and change the acceleration
Control-click a keyframe, then choose an option from the shortcut menu, depending on
the kind of acceleration you want.
Two commands in the
shortcut menu let you
manipulate acceleration
on a motion path.

• Ease In/Ease Out: Bezier handles are added to the keyframe, and the velocity handle is
set for motion to begin slowly and then speed up over time as the clip moves from
that keyframe to the next one on the motion path.
• Linear: Bezier handles are added to the keyframe, and the velocity handle is set to
provide a steady rate of speed as the clip moves from that keyframe to the next one
on the motion path.
Note: Both commands create Bezier handles with the same controls.
Important: The velocity at which clips speed up into or slow down out of keyframed
motion in the Canvas has no effect on the overall speed of the clip’s motion.

Moving an Entire Motion Path in the Canvas
If you’re happy with the shape of a motion path, but you want to move it to a different
position, you can move an entire motion path for one or more selected items directly in
the Canvas.
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To move selected motion paths
1 In the Canvas, do one of the following:
• Choose View > Image+Wireframe.
• Choose View > Wireframe.
2 Hold down the Command and Shift keys, select the clip in the Canvas, then drag the clip
to move the motion path.
Don’t click a keyframe or you’ll move the keyframe itself and not the entire motion path.

The pointer changes
to a hand while you
are dragging.

Creating and Applying Motion Favorites
If there’s a particular set of keyframed motion effects that you want to use over and over
again, you can create a motion favorite. For example, suppose you’re working on a
documentary that always moves a lower third graphic with the name of the current
speaker into the video frame along a particular motion path. You can save this motion
path as a favorite so that you can apply it to all the lower third titles in your project without
having to re-create the path from scratch every time.
To create a motion favorite
1 Select a clip in the Timeline that has a series of motion effect keyframes that you want
to use as a favorite.
This clip can have as many keyframes in as many motion parameters as you want.
2 Choose Effects > Make Favorite Motion (or press Control-F).
All motion effect keyframes from that clip are saved as a motion favorite in the Favorites
bin of the Effects tab of the Browser. By default, the motion favorite has the name of the
clip the motion effect keyframes were copied from, but you can change this name.
To change the name of a motion favorite
1 Select the motion favorite in the Favorites bin of the Effects tab of the Browser.
2 Click the name of the motion favorite, type a new name, then press Return.
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When you apply a motion favorite to a clip in your sequence, it’s not like applying a filter.
There is no special object (such as a filter) that is attached to your clip. Instead, applying
a motion favorite applies all the motion effect keyframes in that favorite to the motion
parameters of the clip. These keyframes can then be further modified at any time.
To apply a motion favorite to a clip in your sequence
Do one of the following:

µ

Select one or more clips in the Timeline, choose Effects > Motion Favorites, then choose
the motion favorite you want to apply from the submenu.

µ

In the Timeline, assign the video track containing the clip to which you want to apply
the motion favorite as the destination track, then place the Timeline playhead over that
clip. Choose Effects > Motion Favorites, then choose an item from the submenu.

µ

In the Browser, drag a motion favorite from the Favorites bin of the Effects tab to a clip
in your sequence.

µ

In the Timeline, select a group of clips in your sequence, then drag a motion favorite from
the Favorites bin of the Effects tab of the Browser to this group.
Because motion favorites apply keyframes to a clip’s motion parameters, to remove the
effect from your clip you need to reset the motion parameters that were modified in that
clip’s Motion tab.
You can also remove unused motion favorites that you no longer want to appear in the
Motion Favorites submenu.

To remove a motion favorite from the Motion Favorites submenu
1 In the Browser, open the Favorites bin of the Effects tab.
2 Select the motion effect item you want to remove.
3 Choose Edit > Clear (or press Delete).

About the Timeline Keyframe Graph Area
Once motion settings have been applied to a clip in your sequence, you can use the Clip
Keyframes control in the Timeline to display a keyframe graph area below each video
and audio track to allow you to view and edit motion settings and other parameter
settings that are applied to your clips.

µ

To display the Timeline keyframe graph area
Click the Clip Keyframes control.

Clip Keyframes control
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The keyframe graph area can be divided into four parts relating to motion, filter, and
speed parameter settings applied to your clips.
Video filters bar (the
upper green bar)

Video motion bar
(the lower blue bar)

Keyframe editor

Speed indicator area

• Filters bar: If a clip has one or more video or audio filters applied, a green bar appears
in this space for the duration of that clip. If keyframes are added to a filter in a given
clip, those keyframes appear as green diamonds on this bar, where they can be edited
or moved using the Selection tool.
• Motion bar: If any of a clip’s motion parameters are modified, a blue bar appears in this
space for the duration of that clip. If keyframes are added to the motion settings for a
given clip, those keyframes appear as blue diamonds on this bar, where they can be
edited or moved using the Selection tool. Motion bars are available only for video
tracks.
• Keyframe editor: For clips with applied effects, the keyframe editor shows you motion
or filter parameters’ keyframe graph lines and keyframes. These keyframe graph lines
are identical to those found in the keyframe graph area of the Motion and Filters tabs
in the Viewer. You can edit keyframes in the keyframe editor using the Selection and
Pen tools. The keyframe editor can display the keyframe graph line of only one
parameter at a time.
Keyframe graph lines displayed in the keyframe editor are color-coded: motion
parameter graph lines are blue (matching the color of the blue motion bar), filter
parameter graph lines are green (matching the color of the green filters bar), audio
level overlays are pink, and pan overlays are purple.
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• Speed indicator area: Speed indicators show you the speed of clips in your sequence
using tick marks. The spacing and color of these tick marks indicate the speed and
playback direction of your clips. The speed indicators of clips in the Timeline update
as you make variable speed adjustments to clips in your sequence, showing you exactly
how you’re altering a clip’s timing.
For more information about viewing speed indicators while making speed changes to
clips in a sequence, see “Learning to Read Timeline Speed Indicators.”

Customizing the Keyframe Graph Area in the Timeline
Each of the four parts of the keyframe graph area can be displayed or hidden individually,
so that you can customize the Timeline view for specific tasks. Additionally, these areas
can be displayed or hidden in the video and audio tracks separately.
To selectively display the individual parts of the keyframe graph area
1 In the Timeline, Control-click the Clip Keyframes control.
2 Choose Audio or Video from the shortcut menu to select a keyframe graph area in either
kind of track.
3 From the Audio or Video submenu, choose one of the following:
• Filters Bar, Motion Bar, Keyframe Editor, or Speed Indicators: A checkmark appears to the
left of each of these areas when displayed. Choose an area to show or hide it. (The
Motion Bar option is available only for video tracks.)
• Select All: Shows all four keyframe graph areas at once.
• Select None: Hides all four keyframe graph areas.
The keyframe graph areas of each track can be individually resized so that keyframe
graphs displayed in the keyframe editor area are more detailed. The keyframe graph
area is resized separately from individual tracks.

Working with the Filters and Motion Bars
The filters and motion bars are useful for seeing at a glance the keyframes of one or more
clip parameters in the Timeline. You can choose which parameter keyframes are visible
in each bar, and you can use the Selection tool to slide these keyframes back and forth
in time.

µ

To selectively display which keyframes are visible in a motion bar
Control-click a motion bar, choose an attribute from the shortcut menu, then choose an
item from the attribute’s submenu:
• Single parameter (for example, Scale, Rotation, Center, or Anchor Point): Displays keyframes
for the selected parameter.
• Show All: Displays all keyframes associated with an attribute.
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• Hide All: Hides all keyframes associated with an attribute.

µ

To move a clip’s keyframe forward or backward in the Timeline
Use the Selection tool to drag a keyframe on a motion bar to another position on that
bar.

µ

To open a clip in the Viewer using a clip’s motion bar in the Timeline
Double-click a blue bar to open that clip in the Viewer with the Motion tab selected.

µ

To open a clip in the Viewer using a clip’s filters bar in the Timeline
Double-click a green bar to open that clip in the Viewer with the Filters tab selected.

Working with the Timeline Keyframe Editor
The keyframe editor allows you to edit the keyframe graph lines belonging to a clip’s
filter and motion parameters directly in the Timeline. It’s ideal for making adjustments
that don’t require more than one parameter to be displayed simultaneously, especially
when you want to make the adjustment in relation to other elements in the Timeline,
such as markers and superimposed clips.
To view a specific parameter’s keyframe graph line in the keyframe editor
1 Control-click the Clip Keyframes control in the Timeline, choose Video or Audio, then
choose Keyframe Editor from the submenu.
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2 Control-click in the keyframe editor area beneath the clip you want to work on, then
choose the filter or motion parameter you want to display from the shortcut menu.

µ

To resize a track’s keyframe editor area
Click in the Keyframe Editor Resize column and, with the Resize pointer, drag up or down.

Drag the Resize pointer up
or down in the Keyframe
Editor Resize column.

Making adjustments to keyframe graph lines in the Timeline keyframe editor is the same
as working in the keyframe graph area of the Filters and Motion tabs in the Viewer. For
more information on how to edit keyframe graphs, see “Adjusting and Deleting Keyframes.”
For more information on how to smooth keyframes in keyframe graphs, see “Smoothing
Keyframes with Bezier Handles.”
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Reusing Effect and Motion
Parameters

68

This chapter covers the following:
• Copying and Pasting Specific Clip Attributes (p. 1133)
• Applying Favorite Filters and Transitions (p. 1138)
If you frequently use a particular transition or filter with specific settings, you can save it
as a favorite for easy access.

Copying and Pasting Specific Clip Attributes
Clip attributes are all the parameter settings applied to a clip—for example, motion
parameter settings, audio and video filters and their parameter settings, speed parameter
settings, and so on. Copying and pasting selected clip attributes is a quick way to add
nearly any attribute to other clips in an edited sequence. You can copy motion paths,
frame cropping, and animated filter effects from one video clip to another.
Suppose you have just applied three filters and a speed setting to one clip, and you decide
that you want exactly the same effects to be applied to several other clips in the sequence.
Instead of re-creating each setting clip by clip, you can simply copy the first clip, select
the other clips, and paste only the specific settings you want into all of them
simultaneously.
When you copy a clip from the Timeline, you also copy all of its attributes. Instead of
pasting duplicates of the clip you copied with all of its attributes, you can:
• Paste specific video or audio attributes that you want into other clips in your sequence.
• Paste only the clip’s video or audio content, with none of the attributes, so that the
content of a clip is replaced. In other words, you can replace the clip but keep the
parameter settings of the original clip.
Warning: Pasting attributes between clips that have different frame rates will give you
erratic results.
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About the Paste Attributes Dialog
You select which attributes to paste by using the Paste Attributes dialog.

The following options are available in the Paste Attributes dialog.
Attributes from Master Shot
• Scale Attribute Times: Repositions the keyframes of the copied clip’s attributes to fit the
duration of longer or shorter clips you paste them into, maintaining the relative position
of keyframes. For example, suppose you copy a 5-second clip with motion effect
keyframes at the beginning, middle, and end. If you paste the motion attributes into
a 10-second clip, the three keyframes will be placed at the beginning, the middle, and
the end of the 10-second clip.
Video Attributes
• Content: Pastes the video content of the copied clip. This replaces existing video, but
not any other attributes. The copied content must have enough source material to
match the length of the clip it’s pasted into.
• Basic Motion: Applies the Basic Motion parameter values and keyframes from the clip
you copied: Scale, Rotation, Center, and Anchor Point.
• Crop: Applies the Crop parameter values and keyframes from the clip you copied: Left,
Right, Top, Bottom, and Edge Feather.
• Distort: Applies the Distort parameter values and keyframes from the clip you copied:
Upper Left, Upper Right, Lower Right, Lower Left, and Aspect Ratio.
• Opacity: Applies the Opacity parameter values and keyframes from the clip you copied.
• Drop Shadow: Applies the Drop Shadow parameter values and keyframes from the clip
you copied: Offset, Angle, Color, Softness, and Opacity.
• Motion Blur: Applies the Motion Blur parameter values and keyframes from the clip you
copied: % Blur and Samples.
• Filters: Adds the parameter values and keyframes for all filters from the clip you copied.
The pasted filters are added to any filters already existing in the clip to which you are
pasting. Existing filters are left unchanged.
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For example, suppose that two clips, Clip A and Clip B, both have a Gaussian Blur filter
applied. Clip A has a Radius parameter value of 100, and Clip B has a Radius parameter
value of 13. If you copy Clip A and then paste its filter attributes onto Clip B, Clip B now
has two Gaussian Blur filters applied. The first filter has a Radius parameter value of 13
(Clip B’s original Blur filter), and the second filter has a Radius parameter value of 100
(the filter from Clip A).
• Speed: Applies the Speed parameter settings from the clip you copied.
• Clip Settings (capture): Pastes all the capture settings from the clip you copied (the
capture settings are those in the Clip Settings tab in the Log and Capture window).
Note: This option works only if the clip receiving the pasted parameters is offline.
Audio Attributes
• Content: Pastes the audio content of the copied clip. This replaces existing audio, but
not any other attributes. The copied content must have enough source material to
match the length of the clip it’s pasted into.
• Levels: Applies all audio level values and keyframes from the clip you copied.
• Pan: Applies all stereo pan values and keyframes from the copied clip.
• Filters: Adds all audio filter parameter values and keyframes from the clip you copied.
This works identically to pasting video filters (see the description of how video filters
are pasted, above).

Copying and Pasting Clip Attributes
When you paste clip attributes into other clips, the following rules apply:
• All parameter settings in the Motion tab of the clip you paste attributes into are replaced.
• The speed parameter settings of the clip you paste into are replaced.
• Filters are added in addition to any filters already in the clip you paste into. (Existing
filters are left unchanged.)
Tip: If you plan to apply the same attributes again and again at different times, you
may find it convenient to put a copy of the clip (with the attributes you want) in a
designated bin or project tab in the Browser. That way you can easily locate the clip
and copy and paste from it.
To paste the attributes of a copied clip into another clip
1 In the Timeline, select a clip whose attributes you want to paste into another clip.
2 Choose Edit > Copy (or press Command-C) to copy the clip and its settings.
3 Select a clip or clips to paste the settings into.
4 Do one of the following:
• Choose Edit > Paste Attributes (or press Option-V).

Chapter 68 Reusing Effect and Motion Parameters

1135

• Control-click the clip or clips you’ve selected in the Timeline, then choose Paste
Attributes from the shortcut menu.
5 In the Paste Attributes dialog, select the attributes you want to apply to the selected clip
or clips.
6 If a clip you’re pasting the attributes into is longer than the clip you copied them from,
you may also want to select the Scale Attribute Times checkbox to proportionally position
all keyframes that you copied to fit the longer clip.

Removing Attributes from a Clip
If you ever want to remove particular attributes from a clip, such as motion parameter
settings, filters, and so on, you can remove the attributes by using the Remove Attributes
command. This is a convenient way to clear a lot of keyframes or filters at once.
To remove attributes from a clip
1 In the Timeline, select one or more clips whose attributes you want to remove.
2 Choose Edit > Remove Attributes.
3 In the Remove Attributes dialog, select the checkbox next to each attribute you want to
remove, then click OK.

Checkboxes are available
for all attributes that the
selected clip has applied
to it.

Reapplying the Most Recently Used Effect
Final Cut Pro remembers the last effect you applied so that you can immediately apply
it again elsewhere in your sequence. If you are applying the same video filter, transition,
or motion favorite over and over again, this can save you a lot of time.
Final Cut Pro remembers both the last effect of any category (video filter, transition, or
motion favorite), as well as the last effect within each category.
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µ

To apply the most recently used effect
Choose Effects > Last - [Name of Effect].

µ

To apply the most recently used video filter
Choose Effects > Video Filters > Last - [Name of Filter].
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µ

To apply the most recently used video transition
Choose Effects > Video Transitions > Last - [Name of Transition].

Applying Filters Across Multiple Tracks at Once
When working with multiple layers of video or audio in the Timeline, if you want to apply
a filter to a clip or region on one track, you may want the filter to apply to the clips below
and above it as well. You can make this happen automatically by first enabling Auto Select
on all the tracks to which you want the filter applied.
Although you can also apply filters to multiple clips by selecting them and then dragging
a filter from the Effects tab in the Browser, the Auto Select method has two advantages:
you don’t have to select any clips, and you have the option of applying a filter to a region
defined by In and Out points instead of whole clips.
To apply a filter across more than one track
1 In the Timeline, enable Auto Select on all the tracks to which you want the filter to be
applied.
Auto Select controls

2 Do one of the following:
• If you want the filter to apply to whole clips: Position the playhead over those clips.
• If you want the filter to apply to a specific region rather than whole clips: Set In and Out
points to define the region.
Important: Make sure that no clips are selected, as the Auto Select feature doesn’t work
if a clip is selected.
3 Choose the filter from the Effects menu.
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Applying Favorite Filters and Transitions
Often you may find yourself using the same filter or transition several times in a sequence.
Rather than manually reapplying the same filter or keyframed parameters over and over
again to multiple clips, you can save a filter or effect as a favorite and then apply it to
multiple clips instantly.
You can also save animated motion parameters, called motion favorites, and apply them
to clips whenever you need to do so. For more information about saving and using motion
favorites, see “Applying Favorite Filters and Transitions.”
Favorites can be used in different ways, such as:
• Using the same animated filter parameters again and again without re-creating
parameter keyframes
• Reusing transitions with different parameter settings or lengths
Many editors use particular durations for the transitions they add. You can create a
series of favorites that are the same transition but with different durations. To keep
track of these modified favorite transitions, you can rename each favorite to reflect its
duration. For more information about transitions, see “Adding Transitions.”
Favorite filters, transitions, and motion parameters are stored in the Favorites bin in the
Effects tab of the Browser. You can also access these favorites by choosing the relevant
Favorites submenu from the Effects menu. There are five Favorites submenus in the Effects
menu, one for each effect category: video transitions, video filters, audio transitions, audio
filters, and motion.
Within the Favorites bin in the Effects tab, you can organize your favorites into separate
bins. These bins appear as submenu items in each Favorites submenu in the Effects menu.

The Favorites bin holds
modified and frequently
used transitions and filters.
It can be organized with
sub-bins, like the Browser.

Note: For more information about saving and using motion favorites, see “Applying
Favorite Filters and Transitions.”
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Creating Favorite Filters and Transitions
The steps for creating favorite filters and transitions are essentially the same. You can
create a favorite by dragging a filter or transition from the Timeline or from the Effects
tab into the Favorites bin in the Effects tab. Although the steps below mostly describe
how to create favorite transitions, the same steps can be used to make favorite filters.
To create a favorite transition from the Effects tab
1 Select the desired transition in the Effects tab of the Browser.
2 Choose Effects > Make Favorite Effect.
The transition is copied to the Favorites bin. If you want to rename this favorite transition,
see “Organizing and Renaming Favorites.”

µ

To create a favorite transition using a transition already in a sequence
Drag a transition you’ve modified from its sequence in the Timeline to the Favorites bin
in the Effects tab of the Browser.

You can drag a modified
transition from a sequence
in the Timeline to the
Favorites bin.

To modify a transition in a sequence before making it a favorite
1 Double-click a transition in a sequence in the Timeline to open it in the Transition Editor.
2 Make any changes to the transition.
3 Drag the transition’s drag hand from the Transition Editor to the Favorites bin in the
Effects tab in the Browser, or choose Effects > Make Favorite Effect.

Drag hand in the
Transition Editor

To create a favorite filter from the Filters tab in the Viewer
1 Choose Window > Effects (or press Command-5) to make sure the Effects tab is selected.
2 Double-click a sequence or Browser clip with one or more video or audio filters applied.
The clip opens in the Viewer.
3 Click the Filters tab in the Viewer.
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4 Make any adjustments to the keyframes or values of the filter parameters.
5 Select one or more filters in the filter list by doing one of the following:
• Click the name bar of a filter.
• Shift-click two filter name bars to select a range of filters.
• Command-click multiple filter name bars to select specific filters in the filter list.
• Click the filter category bar (for video filters or audio filters) to select all filters in that
category.
6 Do one of the following:
• Choose Effects > Make Favorite Effect (or press Option-F).
• Drag the selected filters to the Favorites bin in the Effects tab.
Each selected filter appears in the Favorites bin in the Effects tab.

To save filters as favorites,
drag the selected filters
from the Filters tab in
the Viewer...

...to the Favorites bin in
the Effects tab. You can
also put favorite filters
in a sub-bin.

Organizing and Renaming Favorites
When you create a favorite, you may want to rename it, particularly if you modified it, to
help keep track of your transitions and filters.
To rename a favorite transition or filter
1 Select the transition or filter in the Effects tab of the Browser.
2 Click it again to highlight its name field.
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3 Enter a new name, then press Return.
Enter the new name for
your favorite transition.

To organize favorite transitions and filters into sub-bins
1 Click your project’s tab in the Browser.
2 Create a new bin and give it an appropriate name.
For more information, see “Organizing Footage in the Browser.”
3 Drag the Effects tab out of the Browser so it appears in its own window.
4 Drag your new bin to the Favorites bin in the Effects window.
5 Drag any transitions or filters to the new bin.
The bin now appears as an item in the Favorites submenu of the Effects menu.
Tip: You can save your filter, transition, and motion favorites directly in your project by
dragging them from the Favorites bin in the Effects tab to a bin in your project tab. This
allows you to save favorites from project to project, and to easily transfer your favorites
to other Final Cut Pro editing systems.

Applying Favorite Filters and Transitions
You can apply filters and transitions from the Favorites bin in the Effects tab just as you
would apply any other filter or transition. Transitions can be applied to edit points between
sequence clips, and one or more filters can be simultaneously applied to one or more
clips in your sequence. For more information about applying filters to clips, see “Applying
a Filter to a Clip” and “Applying Multiple Filters to Clips.” For more information about
applying transitions to edit points, see “Adding Transitions.”
Tip: You can open the Favorites bin independently of the Effects tab by choosing Window
> Favorites (or pressing Command-6).
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Changing Clip Speed

69

This chapter covers the following:
• Speed Basics (p. 1143)
• Using the Change Speed Dialogs (p. 1145)
• Using the Speed Tool (p. 1152)
• Making Speed Changes in the Timeline (p. 1155)
• Using the Speed Parameter in the Motion Tab (p. 1163)
• Performing a Fit to Fill Edit (p. 1167)
• Using Speed Settings with Multiclips (p. 1170)
You can adjust a clip’s speed parameters to create fast-motion or slow-motion effects.
You can also add speed keyframes to change the speed of a clip over time.
Final Cut Pro offers several methods of creating speed effects. You can create speed effects
using the Change Speed and Change Speed Segment dialogs, the Speed tool in the Tool
palette, the keyframe graph area of the Timeline, the Speed parameter in the Motion tab
of the Viewer, and the fit to fill edit feature.

Speed Basics
The default speed of all clips is 100 percent, but you can change a clip’s speed setting at
any time.
• Slow motion: Speed is under 100 percent.
• Fast motion: Speed is over 100 percent.
• Variable speed: Speed changes over time.
You can apply constant speed changes as you can when working with slow-motion or
fast-motion changes, or you can create variable speed changes to create sophisticated
effects.

1143

Constant Speed Changes on Entire Clips
Applying a constant speed change to an entire clip alters the entire clip’s playback speed
by the same percentage. For example, applying a speed setting of 25 percent to a clip
makes the entire clip play in slow motion. Constant speed changes are useful when you’re
altering a clip’s timing to fit a larger or smaller gap in your sequence, or when you’re
trying to achieve a consistent speed change across an entire clip (making a car seem
faster or slower, for example) or a group of clips.
Tip: If you are using a Change Speed dialog to adjust a clip to a specific duration, use the
Duration field rather than the Rate field to maximize precision. For more information, see
“About the Change Speed Dialogs.”
Constant speed changes also alter the duration of a clip. If a constant speed change
causes the duration of a clip in a sequence to become longer or shorter, all clips coming
after it ripple forward or backward according to the ripple editing rules in Final Cut Pro.
For more information about rippling clips in a sequence, see “Performing Slip, Slide, Ripple,
and Roll Edits.”
A constant speed change over an entire clip changes the duration of the clip. If you choose
50 percent speed, your clip is twice the duration; if you change speed to 200 percent,
the clip becomes half as long. For example, if you set a 10-second clip to play back at 50
percent speed, Final Cut Pro duplicates frames in the clip so that the clip becomes
20 seconds long and plays back more slowly. If you increase the clip’s speed to 200
percent, Final Cut Pro skips frames and makes the clip 5 seconds long, and it plays back
considerably faster.

10-second clip

Same clip with speed
changed to 50 percent
(now 20 seconds long)

Note: Speed settings are applied to the specific instance of the selected clip only. They
are not applied to that clip’s source media on disk and can be changed at any time. To
create an (external) media file with the applied speed effects, export the clip as a QuickTime
movie.
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Variable Speed Changes
Applying variable speed to a clip allows you to dynamically alter the speed of a clip over
time, in forward or reverse motion. Variable speed allows you to create sophisticated
effects in which subjects appear to smoothly shift across a variety of different speeds,
with hard or gradual transitions between each change. To create variable speed effects,
you create speed segments, essentially segments of a clip that begin and end with speed
keyframes.
Variable speed also allows you to create a smooth transition when going from normal
speed to fast or slow motion. These types of effects can be seen in many music videos
and broadcast commercials, and the effects can be created directly within your edited
sequences without your having to resort to an external compositing application.
Variable speed cannot be applied to the following:
• Audio
• Nested sequences
• Still images
• Multiclips

Using the Change Speed Dialogs
The Change Speed dialog (and the related Change Speed Segment dialog) are central
tools for creating speed effects such as slow motion, fast motion, and changes in the
speed of a clip over time. This section covers both the user interface (see “About the
Change Speed Dialogs”) and specific ways to apply speed effects with these dialogs (see
“Applying Speed Effects with the Change Speed Dialog”).

About the Change Speed Dialogs
You can create speed effects in an entire clip or a segment of a clip using the Change
Speed command (available in the Modify menu) or the related Change Speed Segment
command (available in a shortcut menu from the Clip Keyframes bar in the Timeline).
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Note: The Change Speed dialog affects the speed for an entire clip. The Change Speed
Segment dialog affects the speed for a single speed segment, a section of a clip between
speed keyframes.
Duration field
Rate field
Reverse checkbox
Original field
Start and End buttons
Ripple Sequence checkbox
Scale Attributes checkbox

Frame Blending checkbox

• Duration: Use the Duration field to enter a new duration for the selected clip. The clip
speed (in the Rate field) will be adjusted accordingly. For more information on the
relationship between clip duration and clip speed, see “Speed Basics.” If multiple clips
are selected, the new duration will be the duration of the first selected clip.
• Original: This read-only text field displays the current duration (before you make any
speed/duration changes).
• Rate: Use this field to enter a speed percentage for a clip or a speed segment. A value
of 100% indicates no change; in other words, the clip remains at its default speed.
Values under 100% create slow motion. Values over 100% create fast motion.
Tip: If you are using a Change Speed dialog to adjust a clip to a specific duration, use
the Duration field rather than the Rate field to maximize precision.
• Reverse checkbox: Select this checkbox to make the clip or speed segment play in
reverse, using any speed specified by the above controls. When you do this, the numbers
in the Rate field are displayed in red, to further warn you that the clip will play in reverse.
Note: Alternatively, you can enter a negative value in the Rate field to make the clip
or speed segment play in reverse. If you do this, the next time you open the Change
Speed dialog, the Reverse checkbox will be automatically selected and the value in the
Rate field will be positive rather than negative.
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• Start buttons: Use these buttons to affect the rate of change in speed at the beginning
of a clip or speed segment.
Linear From Start
Curve Centered on Start

Custom
Curve From Start

• Linear From Start button: Applies the default (constant) speed to the beginning of a
clip or speed segment.
• Curve From Start button: Applies a smooth change in speed to the beginning of a
clip or speed segment. This is a quick and simple way to add a Bezier handle to the
keyframe at the beginning of a clip or speed segment in the Speed parameter of the
Motion tab in the Viewer.
• Curve Centered on Start button: Applies a smooth change in speed starting at the end
of the previous speed segment and continuing through the beginning of the selected
speed segment. This is a quick and simple way to add a Bezier handle to the keyframe
at the beginning of a clip or speed segment in the Speed parameter of the Motion
tab in the Viewer.
• Custom button: Final Cut Pro highlights this button automatically when you adjust
the Bezier curve in the Speed parameter of the Motion tab.
• Start Length: Use this field to adjust the Bezier handle length in the Speed parameter
of the Motion tab in the Viewer. The greater the length, the more effect the setting will
have.
• End buttons: Use these buttons to affect the rate of change in speed at the end of a
clip or speed segment.
Linear to End
Curve Centered on End

Custom
Curve to End

• Linear to End button: Applies the default (constant) speed to the end of a clip or
speed segment.
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• Curve to End button: Applies a smooth change in speed to the end of a clip or speed
segment. This is a quick and simple way to add a Bezier handle to the keyframe at
the end of a clip or speed segment in the Speed parameter of the Motion tab in the
Viewer.
• Curve Centered on End button: Applies a smooth change in speed starting at the end
of the selected speed segment and continuing through the beginning of the next
speed segment. This is a quick and simple way to add a Bezier handle to the keyframe
at the end of a clip or speed segment in the Speed parameter of the Motion tab in
the Viewer.
• Custom button: Final Cut Pro highlights this button automatically when you adjust
the Bezier curve in the Speed parameter of the Motion tab.
• End Length: Use this field to adjust the Bezier handle length in the Speed parameter
of the Motion tab in the Viewer. The greater the length, the more effect the setting will
have.
• Ripple Sequence checkbox: Select this checkbox to enable automatic rippling of the
sequence when you adjust the speed/duration of a clip. Clips and markers later in the
Timeline will move with the Out point of the speed-adjusted clip to prevent a gap or
a collision in the Timeline.
All clips coming after the adjusted clip will ripple forward or backward according to
the ripple editing rules in Final Cut Pro. For more information about rippling clips in a
sequence, see “Performing Slip, Slide, Ripple, and Roll Edits.”
• Frame Blending checkbox: Select this checkbox to smooth out the apparent motion of
a clip playing back in slow motion. For more information, see “Frame Blending, Optical
Flow, and Motion Blur.”
• Scale Attributes checkbox: Select this checkbox to scale time-based clip attributes such
as markers and keyframed effects. The attributes will be distributed proportionally in
the speed-adjusted clip.
• Remove Speed button: Click this button to remove all clip speed changes and restore
a clip to its original, default speed.
Remove Speed applies to entire clips only. This button is not available in the Change
Speed Segment dialog.
Note: To remove speed changes with the ripple option, you must use the Change
Speed dialog. The ripple option is not available when you remove speed changes in
any other fashion (such as with the shortcut menu, the Speed parameter in the Motion
tab, or the Remove Attributes command).
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Applying Speed Effects with the Change Speed Dialog
Follow the steps below to create speed effects with the Change Speed dialog or the
Change Speed Segment dialog. The only difference between the Change Speed dialog
and the Change Speed Segment dialog is that the Change Speed dialog affects entire
clips, whereas the Change Speed Segment dialog affects only the section between two
keyframes.
Note: The Change Speed dialog is the quickest and easiest way to apply a constant speed
change to an entire clip.
To change the speed of an entire clip using the Change Speed dialog
1 Select one or more clips in the Timeline or the Browser.
Note: If the clips have existing speed settings, they will be replaced by the adjustments
you make in the Change Speed dialog.
2 Choose Modify > Change Speed (or press Command-J).
The Change Speed dialog appears.
Duration field
Rate field
Reverse checkbox
Original field
Start and End buttons
Ripple Sequence checkbox
Scale Attributes checkbox

Frame Blending checkbox

3 Use any of the controls in the Change Speed dialog to create the speed effect you want.
For detailed information on each of the controls, see “About the Change Speed Dialogs.”
4 Click OK.
The speed effects are applied to the clip. Depending on the settings you chose, the clip
may be extended or shortened in the Timeline, and those changes may be rippled
throughout the sequence.
Note: If maintaining video and audio sync is a priority, select both the video and the
(synced) audio and apply constant speed changes only. Applying variable speed settings
to a video clip (including speed segments, the Curve buttons in the Change Speed dialogs,
and the Curve options in the Change Speed shortcut menu) will break the link to audio
items. Audio and video sync is lost when you apply variable speed changes.
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To change the speed of an individual speed segment using the Change Speed Segment
dialog
1 Make sure both of the following are true:
• The clip is in the Timeline.
• The clip has at least one speed keyframe applied.
For more information about adding speed keyframes, see “Making Speed Changes in
the Timeline.”
2 Do one of the following to display the keyframe graph area and the speed indicator tick
marks.
• Click the Clip Keyframes control in the lower-left corner of the Timeline.
• Press Option-T.
The keyframe graph area is displayed below each clip in the Timeline. You can use this
keyframe graph area to view and edit keyframes for applied effects. By default, the
keyframe graph area includes the speed indicator tick marks. The spacing and color of
the tick marks in the speed indicator area indicate the speed and playback direction of
your clips. The speed indicators of clips in the Timeline update in real time as you make
speed adjustments to clips in your sequence, showing you how you’re altering a clip’s
timing.

Note: To have the keyframe graph area and speed indicator tick marks displayed by
default in new sequences, choose Final Cut Pro > User Preferences > Timeline Options
and select the Clip Keyframes checkbox and the Speed Indicators checkbox.
3 Control-click the speed segment (a section between two speed keyframes) that you want
to change.
4 In the resulting shortcut menu, choose Change Speed Segment.
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The Change Speed Segment dialog appears.

5 Use any of the controls in the Change Speed Segment dialog to create the speed effect
you want.
For detailed information on each of the controls, see “About the Change Speed Dialogs.”
6 Click OK.
The speed effects are applied to the speed segment.
Keep the following points in mind when you use speed keyframes and speed segments:
• Any change you make to an individual speed keyframe will alter the segments to the
left and the right of the keyframe, but it will leave all other speed segments unchanged.
• If maintaining video and audio sync is a priority, select both the video and the (synced)
audio and apply constant speed changes only. Applying variable speed settings to a
video clip (including speed segments, the Curve buttons in the Change Speed dialogs,
and the Curve options in the Change Speed shortcut menu) will break the link to audio
items. Audio and video sync is lost when you apply variable speed changes.
If you use the Change Speed Segment dialog frequently, it might be useful to create your
own keyboard shortcut or button (in a button bar) to open the Change Speed Segment
dialog.
To create a keyboard shortcut or button for opening the Change Speed Segment dialog
1 Choose Tools > Button List.
2 Enter “segment” in the search field.
The Change Speed Segment command appears.
3 Select the Change Speed Segment command.
4 Do either or both of the following:
• While the command is selected, enter a keyboard shortcut.
• Drag the command to a button bar to create a button.
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Frame Blending, Optical Flow, and Motion Blur
Duplicating frames to create slow motion can result in a strobing, jittery effect. To minimize
this, you can turn on frame blending in the Change Speed dialogs. When slow motion is
created, frame blending uses the two frames that appear to either side of duplicate frames
and creates new in-between frames that are a composite of both. When blended frames
are inserted in place of frames that have simply been duplicated, slow-motion clips appear
to play back more smoothly. Speed changes can still play back in real time with the Frame
Blending option turned on.

Original

Blended frame

Original

While clips using frame blending can play in real time at preview quality, frame blending
on a field-per-field basis is much more processor-intensive and is only performed when
the clip is either rendered or played via a third-party video interface with real-time
hardware processing that’s capable of field blending.
For the most sophisticated slow-motion effects, consider using the optical flow technology
available in the Timing controls feature in Motion and the Frame Controls feature in
Compressor. For more information, see the Motion User Manual, available in Motion Help,
and the Compressor User Manual, available in Compressor Help.

Smoothing Slow Motion Using Motion Blur
Although using frame blending is an excellent way to smooth out the apparent motion
of a slow-motion clip, extremely slow speeds such as those below 20 percent can still
result in strobing. To further minimize this effect, you can use the Motion Blur attribute
in the Motion tab.
Drag the Samples slider to the right until you achieve the amount of blur you need to
cover the strobing of your clip (the higher the Samples setting, the longer rendering
takes) and then adjust the % Blur setting until you strike a good compromise between
the sharpness of the clip and the smoothness of the motion.

Using the Speed Tool
The Speed tool provides a quick method for adjusting the speed of two adjacent clips in
the Timeline by “rolling” their shared edit point. You can also adjust the speed of a single
clip by dragging its In or Out point with the Speed tool.
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Dragging an edit point with the Speed tool slows down one clip while speeding up the
adjacent clip. No clips move in the Timeline as a result; only the edit point between the
two clips moves. This is a two-sided edit, meaning that two clips’ edit points are affected
simultaneously: the first clip’s Out point and the next clip’s In point are both adjusted.
However, no other clips in the sequence are affected.
Note: When you adjust an edit point with the Speed tool, the overall duration of the
sequence stays the same, but both clips change their speed and their duration. As with
a roll edit, one clip gets longer and the other clip gets shorter to compensate.
To adjust the speed of two adjacent clips in the Timeline using the Speed tool
1 Select the Speed tool in the Tool palette (or press SSS).
2 Select an edit point between two clips.
If linked selection is on, the edit points of linked items are also selected. For more
information, see “Controls That Affect Trim Edits.”

3 Drag the edit point left or right.
As you drag, the clips display their adjusted speeds as a percentage of their default speeds.
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In the example above, the clip on the left is being adjusted to nearly twice its original
speed while the clip on the right is being slowed to 82% of its original speed.
Additionally, the Canvas shows a two-up display with the Out point of the outgoing clip
on the left and the In point of the incoming clip on the right (see also “About the Two-Up
Display in the Canvas”).

Note: Optionally, you can hold down the Shift key as you drag. This will adjust the speed
of the clip on the selected side of the edit point and perform a roll edit on the other clip.
For more information about roll edits, see “Performing Slip, Slide, Ripple, and Roll Edits.”
The Speed tool adjusts both the video and any linked audio. However, variable speed
settings (speed segments) applied to a video clip item are not applied to the audio items
linked to it. Audio and video sync is lost when you apply a variable (segmented) speed
change.
To adjust the speed of a single clip in the Timeline using the Speed tool
1 Select the Speed tool in the Tool palette (or press SSS).
2 Select either the In point or the Out point of the clip.
If linked selection is on, the edit points of linked items are also selected. For more
information, see “Controls That Affect Trim Edits.”

3 Drag the edit point left or right.
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As you drag, the clip displays the adjusted speed as a percentage of its default (original)
speed.

Making Speed Changes in the Timeline
You can apply variable speed effects to clips using keyframes in the Timeline.
An effective way to create slow-motion and fast-motion effects is to use the keyframe
graph area of the Timeline. You can apply and adjust keyframes with the Pen tool to
create speed segments. You can slide the keyframes left or right in the keyframe graph
area to interactively create variable speed effects, or you can assign specific speed rates
to each segment. A keyframe is a special-purpose control that denotes a change in value
(in this case, a change in clip speed). For more information about keyframes, see “Adjusting
Parameters for Keyframed Effects.”
To add speed keyframes to a clip in the Timeline
1 Do one of the following to display the keyframe graph area and the speed indicator tick
marks.
• Click the Clip Keyframes control in the lower-left corner of the Timeline.
• Press Option-T.
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The keyframe graph area is displayed below each clip in the Timeline. You can use this
keyframe graph area to view and edit keyframes for applied effects.

Note: To have the keyframe graph area and speed indicator tick marks displayed by
default in new sequences, choose Final Cut Pro > User Preferences > Timeline Options
and select the Clip Keyframes checkbox and the Speed Indicators checkbox.
2 Move the pointer over the speed indicator tick marks in the keyframe graph area.
As you do this, the pointer automatically changes into the Pen tool.
3 Click in the speed indicator area where you want to add a speed keyframe.
A blue speed keyframe marker appears in the speed indicator area.

To adjust the position of speed keyframes in the Timeline
1 If there is no existing speed keyframe in the Timeline, add one.
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2 In the speed indicator area, drag a speed keyframe to the left or to the right.

The tick marks in the speed indicator area update in real time as you drag the keyframe,
showing you exactly how you’re altering a clip’s timing. The spacing and color of the tick
marks indicate the speed and playback direction of your clips. Large spaces between tick
marks indicate slow motion. Tightly spaced tick marks indicate fast motion. The red color
indicates reverse motion.
Tip: Optionally, hold down the Shift key as you drag to push or pull all trailing keyframes
in the clip item at the same time.
Keep the following points in mind when you use speed keyframes and speed segments:
• Any change you make to an individual speed keyframe will alter the segments to the
left and right of the keyframe, but it will leave all other speed segments unchanged.
• If maintaining video and audio sync is a priority, select both the video and the (synced)
audio and apply constant speed changes only. Applying variable speed settings to a
video clip (including speed segments, the Curve buttons in the Change Speed dialogs,
and the Curve options in the Change Speed shortcut menu) will break the link to audio
items. Audio and video sync is lost when you apply variable speed changes.

Adjusting Speed Segments with the Shortcut Menu
You can use the shortcut menu to adjust the speed in a particular speed segment (the
area between two speed keyframes) or in a speed keyframe.
To adjust a speed segment with the shortcut menu
1 If there is no existing speed keyframe in the Timeline, add one.
2 Control-click a speed segment (the area between two speed keyframes).
3 Choose any of the following from the resulting shortcut menu.
• Change Speed: Opens the Change Speed dialog. For more information, see “Using the
Change Speed Dialogs.”
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• Remove Speed: Removes all clip speed changes and restores a clip to its original, default
speed.
• Change Speed Segment: Opens the Change Speed Segment dialog. For more information,
see “Using the Change Speed Dialogs.”
• Add Keyframe: Inserts a speed keyframe at the point where you clicked in the speed
indicator area.
• Remove Speed Segment: Removes speed changes and restores a segment to its original,
default speed.
• Speed From Segment Start: Choose one of the options below to affect the rate of change
in speed at the beginning of a speed segment.
• Linear: Applies the default (constant) speed to the beginning of a speed segment.
• Curve From Start: Applies a smooth change in speed to the beginning of a speed
segment. This is a quick and simple way to add a Bezier handle to the keyframe at
the beginning of a speed segment in the Speed parameter of the Motion tab in the
Viewer.
• Curve Centered on Start: Applies a smooth change in speed starting at the end of the
previous speed segment and continuing through the beginning of the selected
speed segment. This is a quick and simple way to add a Bezier handle to the keyframe
at the beginning of a clip or speed segment in the Speed parameter of the Motion
tab in the Viewer.
• Speed to Segment End: Choose one of the options below to affect the rate of change
in speed at the end of a speed segment.
• Linear: Applies the default (constant) speed to the end of a speed segment.
• Curve to End: Applies a smooth change in speed to the end of a speed segment. This
is a quick and simple way to add a Bezier handle to the keyframe at the end of a
speed segment in the Speed parameter of the Motion tab in the Viewer.
• Curve Centered on End: Applies a smooth change in speed starting at the end of the
selected speed segment and continuing through the beginning of the next speed
segment. This is a quick and simple way to add a Bezier handle to the keyframe at
the end of a speed segment in the Speed parameter of the Motion tab in the Viewer.
Keep the following points in mind when you use speed keyframes and speed segments:
• Any change you make to an individual speed keyframe will alter the segments to the
left and the right of the keyframe, but it will leave all other speed segments unchanged.
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• If maintaining video and audio sync is a priority, select both the video and the (synced)
audio and apply constant speed changes only. Applying variable speed settings to a
video clip (including speed segments, the Curve buttons in the Change Speed dialogs,
and the Curve options in the Change Speed shortcut menu) will break the link to audio
items. Audio and video sync is lost when you apply variable speed changes.
To adjust a speed keyframe with the shortcut menu
1 If there is no existing speed keyframe in the Timeline, add one.
2 Control-click a speed keyframe.
3 Choose any of the following from the resulting shortcut menu.
• Change Speed: Opens the Change Speed dialog. For more information, see “Using the
Change Speed Dialogs.”
• Remove Speed: Removes all clip speed changes and restores a clip to its original, default
speed.
• Change Speed Segment: Opens the Change Speed Segment dialog. For more information,
see “Using the Change Speed Dialogs.”
• Remove Keyframe: Removes the speed keyframe that you clicked in the speed indicator
area.
• Remove Speed Segment: Removes speed changes and restores a segment to its original,
default speed.
• Speed to Keyframe: Choose one of the options below to affect the rate of change in
speed before a speed keyframe.
• Linear: Disables any speed smoothing (Bezier handle) for the keyframe.
• Curve to Keyframe: Applies a smooth change in speed before the selected keyframe.
• Curve Centered on Keyframe: Applies a smooth change in speed before and after the
selected keyframe.
• Speed From Keyframe: Choose one of the options below to affect the rate of change in
speed after a speed keyframe.
• Linear: Disables any speed smoothing (Bezier handle) for the keyframe.
• Curve From Keyframe: Applies a smooth change in speed after the selected keyframe.
• Curve Centered on Keyframe: Applies a smooth change in speed before and after the
selected keyframe.
Keep the following points in mind when you use speed keyframes and speed segments:
• Any change you make to an individual speed keyframe will alter the segments to the
left and right of the keyframe, but it will leave all other speed segments unchanged.
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• If maintaining video and audio sync is a priority, select both the video and the (synced)
audio and apply constant speed changes only. Applying variable speed settings to a
video clip (including speed segments, the Curve buttons in the Change Speed dialogs,
and the Curve options in the Change Speed shortcut menu) will break the link to audio
items. Audio and video sync is lost when you apply variable speed changes.

Learning to Read Timeline Speed Indicators
The Timeline includes speed indicators to show you the speed of clips in your sequence
using tick marks.
Note: To illustrate the examples in this section, all screen shots in the Timeline are
presented with both the motion bar and speed indicators visible.
Motion bar (blue)

Speed indicators

Clip Keyframes control

µ
µ
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To view the Timeline keyframe graph area
Select the Clip Keyframes control in the lower-left corner of the Timeline.
To view the speed indicators in the Timeline keyframe graph area
Control-click the Clip Keyframes control, then choose Video > Speed Indicators from the
shortcut menu.
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Timeline speed indicators show you the relative playback speed of clips in your sequence.
For example, suppose you have a 10-second clip in your sequence. At normal, 100 percent
speed, the Timeline speed indicators are evenly spaced, indicating that your clip is playing
forward at a constant speed.

At normal speed, the
speed indicators are
evenly spaced.

If you make a speed change to slow down a clip (setting the clip’s speed to 50 percent,
for example), the speed indicators are spaced farther apart as the clip grows longer,
indicating slower playback. If you speed up a clip (changing the speed to 200 percent,
for example), the speed indicators move closer together as the clip becomes shorter,
indicating faster playback.

Slow speed
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Fast speed
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If you make a clip play backward by selecting the Reverse checkbox in the Change Speed
dialogs, the speed indicators turn red to show that playback is going backward in time.

Reverse-speed indicators
are red.

When you make variable speed changes, the duration of the affected clip stays the same.
The Timeline speed indicators display all speed changes—fast-forward, slow motion, and
reverse—happening within the clip. In particular, because variable speed changes can
also transition smoothly from one speed to another, the spacing of the speed indicators
indicates the acceleration of the speed change.
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Using the Speed Parameter in the Motion Tab
While the various speed adjustment methods allow you to make speed adjustments to
clips quickly, you can also make very precise adjustments to a clip’s speed using the
keyframe graph in the Speed parameter in the Motion tab of the Viewer. In particular,
editing the keyframe graph is the only way to customize keyframe velocity, easing the
transition from one keyframe to another using smoothed keyframes with Bezier handles.
For more general information about settings in the Motion tab, see “Adjusting Parameters
in the Motion Tab.”

Last frame of clip
Length of clip’s media file
(in frames)

First frame of clip

• Speed % field: This field displays the speed percentage at which the clip plays back. If
a constant speed change is applied, this percentage represents the speed for the entire
clip. If speed keyframes (and speed segments) are applied, this field displays the speed
of the clip at the current playhead position.
• Speed keyframe graph area: Use this area to apply and adjust speed keyframes. You can
ease the transition from one keyframe to another using smoothed keyframes with
Bezier handles.
For specific information about the Speed keyframe graph area, see “About the Speed
Keyframe Graph Area.” For information about adding and adjusting keyframes in any
Motion tab keyframe graph area, see “Adjusting Parameters for Keyframed Effects.”

About the Speed Keyframe Graph Area
This section provides some background information on how to use the Speed keyframe
graph area.
The Y Axis
The y axis represents the frame numbers of a clip’s media file. For example, if a clip’s
media file contains 300 frames, the y axis ranges from 0 (the first media file frame) to 299
(the last media file frame).
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Note: This is true regardless of the In and Out points you set for the clip. Even if the clip
has an In point at frame 100 and an Out point at frame 200, the y axis of the clip starts
at frame 0 of the media file and goes to frame 299.
When you choose a value for the keyframe on the y axis, you are choosing a frame from
the clip’s original media file. When you drag a speed keyframe up and down on the y
axis, a tooltip appears that displays which media file frame you are assigning to that point
in time in your clip. As you move the keyframe up, you choose a later frame in your clip’s
media file; when you move the keyframe down, you choose an earlier media file frame.
The top of the y axis represents the last frame of your clip’s media file, and the bottom
represents the first frame.

Last frame of clip
Length of clip’s media file
(in frames)

First frame of clip

The X Axis
The x axis represents a clip’s playback time. Frames are always played back at the frame
rate of the clip. You can set a keyframe at any point on the x axis to specify which media
file frame you want to see at that moment in the clip.
For example, suppose you want frame 100 from a clip’s media file to appear 2 seconds
into the clip. In this case, you set a speed keyframe at 02:00 in the clip. Then you vertically
adjust this keyframe to the value 100.
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Speed and the Keyframe Graph
The following illustrations show how changes to the keyframe graph affect the speed of
a clip in the Timeline. In each graph, the vertical axis represents media time, where each
tick mark up is a successive frame of your video clip. The horizontal axis represents the
Timeline, where each tick mark represents the duration of one frame playing at the
sequence frame rate.
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Source time

• Linear time (100 percent speed): This is represented by a straight, upward-sloping diagonal
line, in which one frame of a video clip plays in the space of one frame of the Timeline.
This is real time.

Sequence time

Source time

• Slow motion (less than 100 percent speed): Slow motion is represented by a line with a
more gradual slope, in which one frame of a video clip may play over perhaps three
frames of the Timeline.
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Sequence time
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• Fast-forward (greater than 100 percent speed): Fast-forward speed can be seen as a
steeper line, in which several frames of a video clip play in the space of one frame of
the Timeline.

Sequence time
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Source time

• Freeze frame (0 percent speed): So far, all these graphs have illustrated forward-playing
clips, represented by a line that slopes upward. A freeze frame, represented by a flat
line, may also be created with the keyframe graph.

Freeze frame

Sequence time
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Source time

• Reverse speed (less than 0 percent speed, or negative speed): When a clip plays in reverse,
previous frames of the video clip are mapped to successive frames of the Timeline.
Reverse speed is represented by a line that slopes downward.

Sequence time
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Source time

• Acceleration/deceleration: Finally, the most powerful feature of the keyframe graph is
the ability to adjust the transition in a clip from one speed to another, at whatever
velocity you require. Gradual changes from one speed to another are represented by
curves. For example, a gradual transition from slow motion to fast-forward might look
like this:

Sequence time

Note: Bezier curves in the Speed parameter are constrained so that any value along the
curve is limited by the minimum and maximum values of the surrounding keyframes.
For more information on using Bezier handles to smooth keyframes, see “Smoothing
Keyframes.” For more information on working in the keyframe editor of the Timeline, see
“Working with the Timeline Keyframe Editor.”
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Making Speed Adjustments in the Speed Keyframe Graph Area
You can add speed keyframes and make precise speed adjustments in the Speed keyframe
graph area of the Motion tab.
To add a speed keyframe in the Speed keyframe graph area
1 Open the clip in the Viewer.
2 Click the Motion tab.
3 In the Speed keyframe graph area, do one of the following:
• Option-click anywhere along the line in the keyframe graph.
• Select the Pen tool from the Tool palette and click anywhere along the line in the
keyframe graph.
To adjust the position of a speed keyframe
Do one of the following:

µ
µ

Drag the keyframe up or down to choose a frame from the clip’s original media file.
Drag the keyframe left or right to set the timing for the specific frame from the clip’s
original media file.
Tip: The Speed keyframe graph area of the Motion tab can be resized vertically, allowing
you to have a more detailed view of the keyframe graph you’re editing. For more
information, see “Resizing the Keyframe Graph Area.”

To adjust the transition from one keyframe to another using Bezier handles
1 Control-click a speed keyframe.
2 Choose Smooth from the shortcut menu.
Bezier handles appear on the keyframe.
3 Drag the Bezier handles to adjust the shape of the graph line on either side of the
keyframe.
For more information on using Bezier handles to smooth keyframes, see “Smoothing
Keyframes.” For more information on working in the keyframe editor of the Timeline, see
“Working with the Timeline Keyframe Editor.”

Performing a Fit to Fill Edit
You may have different reasons for changing the speed settings. For example, you may
want to solve editorial problems in your sequence. In that case, you can do a fit to fill
edit, making a clip longer to fill more time or shorter if an action takes longer than you’d
like. You can use speed changes over time to create ramping speed changes from slow
to fast motion, and from forward to reverse.
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A fit to fill edit changes the speed of a clip in the Viewer so that its duration matches the
duration between the sequence In and Out points. Because a fit to fill edit changes the
speed of the edited clip, you may have to render it before it will play back. Also, any audio
items associated with this clip will change pitch, moving either higher or lower.
Fit to fill is the only edit type in Final Cut Pro that requires four edit points, instead of
three. You need to set In and Out points for your clip in the Viewer, as well as In and Out
points in the Canvas or Timeline, for the destination in your edited sequence. For more
information, see “Three-Point Editing.”
For example, suppose you want to replace a 5-second shot of a lizard with a 2-second
shot of a desert landscape. In this case, you can use the fit to fill edit to make the landscape
shot fit.

D
Before edit

A

B

C

A

D

C

After edit

You can also use the fit to fill edit with multiple clips. When you do so, each successive
clip selected in the Browser replaces each successive clip in your sequence using a fit to
fill edit, starting with the clip at the current position of the Timeline playhead. If you’ve
selected more clips in the Browser than you have in your sequence, you’ll see an
“Insufficient content for edit” error message.
Note: When you use the fit to fill edit, the speed setting applied to the edited clip changes
so that the clip fits the newly specified duration. These speed settings can be modified
or removed at any time.
To perform a fit to fill edit
1 Do one of the following:
• In the Canvas or Timeline, set sequence In and Out points to define the part of your
sequence you want to fill.
• Position the playhead over a clip you want to replace using a fit to fill edit. If no In and
Out points are set in the sequence, Final Cut Pro uses the clip boundaries as sequence
In and Out points.
2 Make sure that the correct destination tracks are set in the Timeline.
3 Open a clip in the Viewer.
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4 Set In and Out points to define the portion of your source clip that you want to edit into
your sequence to fill the duration set in step 1.

Set In and Out points
in the source clip.

Set In and Out points
in the sequence.

5 Do one of the following:
• Drag the clip from the Viewer to the Fit to Fill section of the Edit Overlay in the Canvas.
• Click the Fit to Fill button in the Canvas.
• Press Shift-F11.

Fit to Fill button

Fit to Fill section of
the Edit Overlay in
the Canvas
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The material in the Viewer overwrites any material already between the sequence In and
Out points you specified. The speed of the source clip changes to compensate for the
difference in duration.

Before a fit to fill edit

After a fit to fill edit

The speed of the
clip changes to fit
the specified area of
the sequence.

Using Speed Settings with Multiclips
You can apply constant speed changes to an entire multiclip (including all its component
camera angle clips).
To change the speed of an entire multiclip using the Change Speed dialog
1 Select the multiclip in the Timeline or the Browser.
Note: If the clip has existing speed settings, they will be replaced by the adjustments you
make in the Change Speed dialog.
2 Choose Modify > Change Speed (or press Command-J).
The Change Speed dialog appears.
3 Use any of the controls in the Change Speed dialog to create the speed effect you want.
For detailed information on each of the controls, see “About the Change Speed Dialogs.”
4 Click OK.
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The speed effects are applied to the multiclip. The Change Speed dialog adjusts both the
video and any linked audio. Depending on the settings you chose, the clip may be
extended or shortened in the Timeline, and those changes may be rippled throughout
the sequence.

Working with Multiclips and Speed Effects
Keep the following restrictions in mind when you work with multiclips and speed effects:
• Multiclips cannot be created from speed-modified clips.
• Multiclips allow constant speed changes only.
• When a multiclip is displayed in the Viewer, all angles reflect the speed of the active
angle.
• A standard switch between angles will remove any speed effects. To retain the speed
effect, use the Switch Video with Effect command.

You cannot apply variable speed effects (speed segments) to an entire multiclip, nor to
any of its component camera angle clips. However, you can export a clip with variable
speed effects and then import that file and add it to a multiclip.
To include a camera angle clip with a variable speed effect
1 Apply a variable speed effect to a clip.
2 Export the clip as a QuickTime movie.
3 Import the clip.
4 Add the imported clip to the multiclip.
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This chapter covers the following:
• Using Still Images and Graphics in Your Sequences (p. 1173)
• Creating Freeze Frames from a Video Clip (p. 1174)
• Exporting Still Images (p. 1175)
• Creating Graphics with the Correct Frame Size for Video (p. 1176)
• Working with Graphics Clips of Different Sizes (p. 1176)
• Bit Depth of Imported Graphics (p. 1177)
• Scaling a Graphic to Fit the Frame Size (p. 1177)
• Creating Graphics with the Correct Color Settings for Video (p. 1181)
• Choosing the Maximum White Sequence Setting (p. 1182)
• Flattening Graphics with Layers (p. 1182)
• Using Alpha Channels (p. 1183)
• Selecting Fonts and Creating Line Art for Video (p. 1183)
• Scaling Images and Video Clips to Match a Sequence (p. 1183)
• Changing the Duration of Still Images (p. 1184)
• Example: Adding Camera Motion to Still Images (p. 1185)
You can use still images and photographs in your movie to previsualize scenes, create
motion graphics, and provide visual continuity when no video is available.

Using Still Images and Graphics in Your Sequences
Still images are commonly used in motion graphics sequences, custom titles created in
another application, and illustrative graphics such as charts and diagrams. They are also
used as placeholder graphics during editing (before a finished shot is delivered to your
editing system) and as background images for multilayer compositing. For more
information about working with multiple layers of video and graphics, see “Compositing
and Layering.”
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You can also apply traditional camera stand (or motion camera) moves to a still image
(as is often done in documentaries) by setting motion effect keyframes.
You can add still images to your sequence during any phase of post-production.

Creating Freeze Frames from a Video Clip
Final Cut Pro makes it easy to create a freeze frame from a video clip. No additional media
is created on your hard disk; freeze frames are simply clips that refer to a single frame of
a media file.

Creating a Freeze Frame
You can create a freeze frame whenever you need to, whether you are viewing a clip in
the Viewer or working on a sequence in the Timeline.
To create a freeze frame from a video clip
1 Make sure the frame you want for a freeze frame is displayed in the Viewer or the Canvas.
2 Choose Modify > Make Freeze Frame (or press Shift-N).
A freeze frame clip appears in the Viewer. This clip is automatically named after the
sequence or clip that it came from, plus the timecode value from which the frame
originated.
Note: If you open another clip in the Viewer, the freeze frame clip that was previously in
the Viewer is gone.
3 To add the freeze frame to your sequence, do one of the following:
• Drag the freeze frame from the Viewer to the Canvas or the Timeline.
• Drag the frame to the Browser to create a master clip for use throughout the course
of your project.

Setting the Duration of a Freeze Frame
As with imported stills, the duration of the freeze frame image is determined by the
Still/Freeze Duration preference setting. If you want to change this duration, see “Changing
the Duration of Still Images.”

Creating Freeze Frames of Embedded Motion Projects
When you create a freeze frame of an embedded Motion project, the freeze frame clip
refers to the Motion project on disk. If you alter the source project, the freeze frame’s
image will look different.

Reconnecting Freeze Frame Clips
Freeze frame clips refer to media files the same way other clips do. If the media file is
modified, moved, or deleted, the still-image clip becomes offline, and you need to
reconnect it. For more information, see “Reconnecting Clips and Offline Media.”
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About Sequence Freeze Frames
Unlike a freeze frame of a clip, a sequence freeze frame will not update if you subsequently
change the sequence the freeze frame was created from. However, the clip media
referenced by the sequence freeze frame can still be updated and the freeze frame clip
can be reconnected. For more information, see “Reconnecting Freeze Frame Clips.”

Exporting Still Images
You can easily export a still image of the current frame displayed in the Viewer or Canvas.
You do not need to create a freeze frame clip to export a still image.
To export a frame displayed in the Viewer or Canvas as a still-image file
1 Position the playhead on the frame you want to export, then choose File > Export > Using
QuickTime Conversion.
2 In the Save dialog that appears, enter a name and choose a location for the image file.
3 Choose Still Image from the Format pop-up menu, then click Save.
For more details, see “Exporting Still Images and Image Sequences.”

Deinterlacing Still Video Images to Improve Image Quality
Standard definition (SD) video is almost always interlaced, so still images created from
SD video are interlaced, too. A single frame of interlaced video consists of two fields that
were originally captured at different moments in time. If there is a lot of motion in the
video content of a frame (such as a ball quickly moving past the camera), the two fields
contain very different visual information. When the entire frame is displayed, objects in
motion have a comblike appearance because the objects appear in two places at once.
During normal video playback, interlacing is usually not very noticeable because the fields
are scanned so quickly. However, on still images, interlacing artifacts cause some still
images to flicker or strobe on an interlaced display (such as an NTSC or PAL monitor). To
eliminate interlacing artifacts, you can apply a deinterlacing filter in Final Cut Pro before
you export a still image. (A deinterlacing filter simply removes half the lines and
interpolates the missing lines by using the remaining lines.) You can also export the image
without applying the filter and then apply a deinterlacing filter in a separate graphics
application.
Important: Final Cut Pro often displays the Viewer and Canvas deinterlaced to make the
image clearer while you are editing. To make sure you catch any potential interlacing
artifacts in still images, always watch your video on a monitor that matches your final
screening format. For example, if you plan to output your movie to an NTSC video format,
you should monitor your sequence on an external NTSC monitor. For more information
about external monitoring, see “External Video Monitoring.”
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Creating Graphics with the Correct Frame Size for Video
When you’re preparing to import graphics into Final Cut Pro, it’s important to be aware
of the implications of frame size, sequence size, and pixel aspect ratio. Ultimately, the
frame size of your output format determines the size of the graphic you create in your
graphics application.
Here are some examples:
• If you are working with NTSC DV video, your graphic needs to have the same dimensions:
720 x 480.
• If you are working with 720p HD video, your graphic needs to be 1280 x 720 to match
your sequence.

Working with Graphics Clips of Different Sizes
If you import a graphic or still image with a frame size that doesn’t match the frame size
of your edited sequence, you have two choices.
• You can resize the image, enlarging or reducing it to fit the frame size of your image.
• You can leave the image as is, in which case you’ll be able to see only a small part of
it if the image is too big, or the image will be surrounded by black if it’s too small.
If you’ve imported a high-resolution image that’s significantly larger than the frame size
of your project, Final Cut Pro allows you to take advantage of the image’s increased
resolution to create sophisticated motion effects.

3000 x 2000

Relative frame sizes of the
same image at 720 x 480
and 3000 x 2000 when
imported into Final Cut Pro

720 x 480

Important: If you try to enlarge an image that was originally shot on video, or a graphic
that is smaller than the frame size of your sequence, you’ll find that scaling it up past a
certain point creates noticeable artifacts that you may not want.
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Video Is Not 72 Dots per Inch
There is a myth in video graphic design: Because some older computer displays used 72
pixels per inch, all video created on a computer must be at this resolution. This is not true
or necessary. The dimensions of a video image are dependent only on the number of
horizontal and vertical pixels used in the image. Pixel dimensions alone determine the
resolution of a video image. You can easily test this yourself by creating two 720 x 480
images in a still graphics program, setting one image to a resolution of 300 dots per inch
(dpi) and the other to 72 dpi. Import both images into Final Cut Pro and compare the
two. They are absolutely identical. This is because video editing software does not use
the dpi setting of a graphics image.
Even though the dpi setting for your graphics is irrelevant for working with video, keep
in mind that many people may still adhere to a policy that graphics for video must be
72 dpi. To avoid confusion with other graphic designers, you can leave your video graphics
at 72 dpi. Just know that there is nothing special about this setting.

Bit Depth of Imported Graphics
Final Cut Pro can import graphics with a bit depth of up to 16 bits per pixel per color
channel, although 8 bits per color channel is the bit depth most commonly used. The
more bits used to represent color in an image, the more accurately the color is represented.
This is important when you are trying to preserve color detail in motion picture or
still-image film.

Scaling a Graphic to Fit the Frame Size
If you want your imported graphic to fit entirely into your image frame, you can select
the clip once it’s edited into the Timeline and use the Scale to Sequence command to
set the scale of the graphic so that it fits as neatly as possible into your frame size.
To scale a graphic
1 Select a clip in your sequence to rescale.
2 Choose Modify > Scale to Sequence.
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If the aspect ratio of your imported graphic doesn’t match that of your edited sequence,
the graphic will not exactly fit the dimensions of the Canvas and will therefore appear
letterboxed or pillarboxed. For more information about aspect ratios, see “Video Formats.”
• If your graphic is taller than it is wide: There are gray borders to the right and left of the
image in the Viewer and Canvas. The borders are not part of the image.

Gray borders appear
on the sides because
this image is taller than
it is wide.

• If your graphic is wider than it is tall: There are gray borders at the top and bottom of
the image in the Viewer and Canvas. The borders are not part of the image.

Understanding Digital SD Video Non-Square Pixels
When creating graphics for SD video, you need to consider the fact that the digital video
pixels are considered to be non-square (taller than wide for NTSC video, or wider than
tall for PAL video) compared to your computer graphics program that uses square pixels.
Non-square pixels are also referred to as rectangular pixels.
Note: Some computer graphics programs support non-square pixels, making it simpler
to create graphics for SD video formats like NTSC and PAL. For high definition (HD) video
formats, you can simply create square pixel graphics, which means designing graphics
with exactly the same image dimensions as your HD format.
Reconciling the difference between non-square pixels and square pixels can cause a lot
of confusion for beginning video graphic designers, but the best rules of thumb are to:
• Use a graphics application that supports non-square pixels, such as Adobe Photoshop.
In this case, you create your graphics with the proper dimensions and pixel aspect ratio
throughout the entire post-production process.
• Keep your destination video frame size in mind and follow the table in the section
“Frame Size Chart for Creating Graphics” when designing graphics in your graphics
application.
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Note: There is no accepted standard for the exact aspect ratio of non-square SD video
pixels. Different manufacturers may assume different pixel aspect ratios when designing
their software. Fortunately, these differences tend to be very small, so in many cases you
may not notice a difference between pixel aspect ratios of, say, 0.9 and 0.89.
Since every non-square video frame size has an equivalent square frame size that will
look correct in SD video, it’s easy to create your graphics with a usable frame size. The
steps below tell you how.
See “Pixel Aspect Ratios in SD Video Signals Versus Computer Displays” for more
background information on this topic.
Graphics for projects that will be output to HD video, or for video that will be played only
on computers and doesn’t use any captured SD video footage, simply need a frame size
that matches the sequence frame size. No alterations are needed.
To create graphics that look correct when output to video
1 In your graphics application, create a frame size that’s the square-pixel equivalent of the
video frame size of your sequence.
To select the correct frame size for your video format, see “Frame Size Chart for Creating
Graphics.”
2 Create your graphic.
3 Do one of the following:
• Save your image from the graphics program to your media folder on disk.
• In your graphics program, first save your image at the original dimensions with a name
such as MyGraphic_original (this is a working copy that you can always use to make
further changes). Then, rescale the graphic from the square-pixel frame size you created
it with to the non-square equivalent shown in “Frame Size Chart for Creating Graphics.”
This makes the image look distorted in your graphics application, but it will look right
when you output it to video. Save this resized graphic to the folder in which you store
your media.
4 Import your image file into Final Cut Pro.
If your imported image dimensions match any of the SD digital video formats supported
by Final Cut Pro (such as DV NTSC, PAL, or widescreen), Final Cut Pro automatically assigns
the appropriate pixel aspect ratio associated with those dimensions. If you want to change
the pixel aspect ratio, you can change the image file’s Pixel Aspect property in the Browser
column or in the clip’s Item Properties window, as described in “Working with Projects,
Clips, and Sequences.”
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Frame Size Chart for Creating Graphics
Use the chart below to determine the frame size you need for creating graphics. For
example, if you’re working in DV PAL (which has a frame size of 720 x 576), your graphic
should have a frame size of 768 x 576 to look correct on an SD video monitor.
If you are using this format

The video sequence frame size
is

Use graphics with this frame
size

CCIR 601 NTSC 4:31

720 x 486

720 x 547

CCIR 601 NTSC 16:9 anamorphic

720 x 486

853 x 486

DV NTSC 4:3

720 x 480

720 x 540

DV NTSC 16:9 anamorphic

720 x 480

853 x 480

CCIR 601/DV PAL 4:3

720 x 576

768 x 576

CCIR 601/DV PAL 16:9
anamorphic

720 x 576

1024 x 576

720p HD

1280 x 720

1280 x 720

1080i or 1080p HD

1920 x 1080

1920 x 1080

1 Refers to ITU-R BT.601.

Important: Final Cut Pro uses slightly different square-pixel image dimensions than other
video and still-image applications. For the most accurate results, you can avoid creating
and converting square-pixel images by using a graphics application that supports
non-square pixel aspect ratios. These applications allow you to create and preview your
graphics at their native resolution.

Pixel Aspect Ratios in SD Video Signals Versus Computer Displays
SD video images use pixels with a non-square (rectangular) aspect ratio, whereas computer
displays represent images using a grid of pixels with a square aspect ratio.
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Digital NTSC video

Non-square pixels

Computer display

Square pixels
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SD NTSC pixels are taller than computer pixels and SD PAL pixels are wider than computer
pixels. As a result, a 720 x 480 pixel image looks different (taller) on an NTSC video monitor
than it does on a computer display. For example, if you capture a clip of video with a
globe in the picture, export a frame, and look at this frame in a graphics application, you’ll
see something like this:
NTSC square vs. non-square pixels example

Looks right
on a video monitor

Looks wrong
on a computer display

The Viewer and the Canvas let you display non-square pixel video correctly on the
computer’s display. You can choose this option by choosing Show As Sq. Pixels from the
Zoom pop-up menu in both windows.

Pixel Aspect Ratios in HD Video
Uncompressed HD video transferred via an HD-SDI signal has pixel dimensions of either
1280 x 720 or 1920 x 1080. However, HD video recorded on tape is often horizontally
compressed to reduce the data rate. DVCPRO HD, HDV, and HDCAM are three examples
of formats whose native horizontal dimensions are squeezed. For example, 1080i60
DVCPRO HD is 1280 x 1080. 1080i50 DVCPRO HD is 1440 x 1080. Because of the discrepancy
in dimensions even within a single format, it’s usually best to create HD graphics at either
1920 x 1080 or 1280 x 720, depending on your final output format. If you are uncertain
which HD format you plan to output to, you can always be safe by creating your graphics
at the largest size possible (1920 x 1080) and then scaling down if necessary.

Creating Graphics with the Correct Color Settings for Video
You should be aware that the range of colors that can be displayed on a broadcast video
monitor is much smaller than the range that can be displayed on a computer display. For
this reason, colors that appear bright and clean on NTSC or PAL video can seem duller
when viewed on your computer display.
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If you output graphic images with colors that go outside the “legal” range for video, the
colors will appear oversaturated and may “bleed” into other parts of the image. This
distortion can be easily avoided by controlling the palette of colors you use in your
graphics program. As you create the graphics you’ll be outputting to video, resist the
temptation to use the brightest and most saturated shades of color available in your paint
program. When you’re finished with your image, use a video colors filter (if your program
has one) to make sure that all the colors in your image are in the legal broadcast range
for video.

Choosing the Maximum White Sequence Setting
When you edit a graphics clip into a sequence, if the “Process maximum white as” pop-up
menu in the Video Processing tab of the Sequence Settings window is set to White, the
brightest white in that graphic will appear at 100 percent when viewed on the Waveform
Monitor in Final Cut Pro. If your sequence is set to Super-White, the brightest white in
that graphic will appear at 109 percent when viewed on the Final Cut Pro Waveform
Monitor.
For the best visual quality, choose the maximum white sequence setting based on the
category below that best describes your situation:
• The Super-White setting should be used if you’re matching the brightness of imported
graphics (or Final Cut Pro generators) to video that was shot and captured with the
super-white luma levels that many consumer camcorders use.
• If your captured video clips were all shot with carefully controlled video equipment,
guaranteeing a maximum white level of 100 IRE in the recorded video signal, choose
White from the “Process maximum white as” pop-up menu so that the white levels of
your graphics match properly.

Flattening Graphics with Layers
Multilayer graphics can be useful for compositing and complex graphics, but most of the
time you only need a single still-image clip. If your original image file is a Photoshop file,
make sure you flatten it before you save it as media for importing into Final Cut Pro.
You may want to save two versions of the Photoshop file: the original file that retains the
independent layers (this is a working copy you keep so you can go back to make
independent layer adjustments) and a separate flattened image created by choosing File
> Save As or File > Export in your graphics application.
If you want to work with layered Photoshop files, see “Working with Layered Photoshop
Sequences.”
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Using Alpha Channels
Alpha channels are an implicit fourth channel in some graphics file formats that are used
to reveal only certain parts of your still image. Alpha channels are useful when compositing
a still image above another still or video clip in the Timeline. Make sure you save your
still-image file with the alpha channel included if you want to use the still-image file for
compositing. For more information about working with alpha channels, see “Using Video
and Graphics Clips with Alpha Channels.”

Selecting Fonts and Creating Line Art for Video
When creating line art or selecting a font to use for a broadcast video image, you should
avoid creating horizontal single-pixel lines or using fonts that are too thin. Because video
is interlaced, horizontal lines that have a height of a single pixel will flicker as the field in
which they appear alternates on and off. This causes a distracting shimmering in your
graphics, with the shimmering becoming more pronounced the closer thin areas in your
image are to horizontal. For more information, see “Installing and Choosing Fonts.”
Flickering horizontal lines can be mitigated by adding a bit of blur or anti-aliasing to your
image, causing the lines to subtly spread out over more than one line. However, the best
thing to do is to avoid single-pixel lines altogether when creating graphics for broadcast.

Scaling Images and Video Clips to Match a Sequence
Whenever you edit a still-image clip into a sequence, Final Cut Pro compares and
automatically adjusts the following properties of the image and the sequence:
• Horizontal and vertical dimensions: If the still-image dimensions are larger than the
sequence dimensions, the still image is scaled to fit in both dimensions (without
distorting the image). This means that you always see the entire still image within the
frame of the sequence.
If the graphic has smaller dimensions than the sequence, the graphic is not scaled. This
is because scaling images beyond 100 percent reduces the quality (pixels would be
magnified, which would create blocky artifacts in the image). Final Cut Pro avoids
automatically scaling clips beyond 100 percent.
• Pixel aspect ratio: If the still-image pixel aspect ratio is different from the sequence pixel
aspect ratio, Final Cut Pro adjusts the still-image clip’s Aspect Ratio parameter (located
in the Distort attribute of the clip’s Motion tab). This compensates for nonmatching
pixel aspect ratios between the still image and the sequence. The result is that the clip
does not appear distorted simply because it has a different pixel aspect ratio. Without
this automatic compensation, you would have to manually calculate how much to
compensate for nonmatching pixel aspect ratios. For more information, see “Controls
in the Motion Tab.”
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If the frame size of your graphic doesn’t match the frame size of your edited sequence
and you want to correct this, you can do so easily.
To scale an image within a sequence to exactly fit the sequence dimensions
1 Select one or more clips in the sequence.
Tip: You can also place the playhead over a clip in the Timeline without selecting any
clips.
2 Choose Modify > Scale to Sequence.
Each selected clip’s Scale parameter is set to the appropriate amount so that both
horizontal and vertical image dimensions fit within the sequence dimensions. The images
are not squeezed or stretched, but they may appear letterboxed or pillarboxed if the
aspect ratios of the image and the sequence don’t match.
Note: The Scale to Sequence command works on video clips as well as still-image clips.
If you want to zoom in to and out of an image, such as a scanned map or photograph,
you should use an image with higher resolution than the sequence. The higher the
resolution of the image, the less likely it is that you will need to scale more than 100
percent to show details. Scaling video and still images more than 100 percent creates
artifacts: individual pixels become noticeable, causing a “stair-stepping” artifact on
high-contrast diagonal lines.
Note: You can add the illusion of camera motion to still images, as is often done in
documentaries, by subtly keyframing the Scale setting (for zooming) as well as movement
of the image within the frame (Center, Anchor Point, and Rotation parameters). See
“Example: Adding Camera Motion to Still Images” for details.
To scale an imported graphic in a sequence
1 Edit the image into the sequence in the Timeline.
2 Double-click the clip in the Timeline to open it in the Viewer.
3 Click the Motion tab in the Viewer.
4 Edit the percentage value in the Scale field, or adjust the Scale slider until you find a size
you like.

Changing the Duration of Still Images
Once an image is edited into your sequence, it has a default duration of 10 seconds.
However, you may want the image to play for a longer or shorter duration. There are a
few ways to change the duration of a clip.
To change the default duration of still images
1 Choose Final Cut Pro > User Preferences, then click the Editing tab.
2 Enter a new value in the Still/Freeze Duration field.
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Note: This setting only affects graphics imported after you change this setting. Previously
imported graphics still retain the same In and Out points.
To change a clip’s duration
Do one of the following:

µ

Select a clip in the Browser, then choose Edit > Item Properties. Click the Timing tab, then
enter a value in the Duration field.

µ

In the Browser, double-click in the Duration column for a clip, then enter a new duration.
Enter a new duration in
the Duration column for
the image.

µ

Double-click a clip in the Browser to open it in the Viewer, then enter a value in the
Timecode Duration field.

Enter a new duration here.

Example: Adding Camera Motion to Still Images
You’ve probably seen documentaries that show a graceful camera pan or tilt across a still
image, sometimes slowly zooming in or out. These kinds of effects are traditionally done
with a motion control camera, which is a device that consists of a static camera and a
mobile, programmable photo table. The photo table can be programmed to move slowly
past the camera in several directions and rotate around a pivot point. These sorts of
camera moves bring life to otherwise static images, greatly enhancing movies that must
rely on archival photographs and documents to create a meaningful visual narrative.
Final Cut Pro can achieve similar effects by animating the motion parameters of a
high-resolution still image.
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Important: To create moving graphics with acceptable quality, the horizontal and vertical
dimensions of your still image must be greater than the frame size of the sequence that
contains it. If you need to set the Scale parameter of your image over 100 percent to
achieve a particular effect, your still image wasn’t created with high enough resolution.
Follow these steps to learn how to create slow zooming and panning effects with a still
image in Final Cut Pro.
Note: For more information about learning to use keyframes, see “Adjusting Parameters
for Keyframed Effects.”
• Stage 1: Preparing Your Image and Importing It into Final Cut Pro
• Stage 2: Editing the Still Image into Your Sequence
• Stage 3: Opening the Image Clip in the Motion Tab of the Viewer
• Stage 4: Preparing the Viewer and Canvas Settings
• Stage 5: Moving an Image by Changing Its Center Location

Stage 1: Preparing Your Image and Importing It into Final Cut Pro
There are two key things to be aware of before you import the image:
• Frame size: The still-image dimensions need to be significantly larger than the frame
size of your sequence, so that the still image can move about the frame without
displaying any edges.

Canvas
720 x 480
4000 x 3000
Still image

For example, a DV NTSC (4:3 aspect ratio) sequence has a frame size of 720 x 480 pixels,
so any stills used for this effect in a DV NTSC (4:3) sequence should be larger than
720 x 480. The longer you want the pan to last and the more detail you want to show,
the larger the still-image dimensions should be. Check the frame size of your sequence
and the size of the imported still image by looking at the Frame Size column in the
Browser. A good rule of thumb is to make your still image with twice the horizontal
and vertical dimensions. Using exact multiples makes it easier to make precise,
predictable adjustments to your image within the Canvas.
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If the final destination of your sequence will be SD video, then any scanned images,
digital photographs, and HD video images with higher resolution work well. Still images
from SD video aren’t recommended because you’d have to increase the size of the still
image by scaling it up, which would degrade the image quality considerably and create
artifacts in the picture.
If you’re creating graphics for camera motion effects in an HD sequence, the image
dimensions will have to be quite high. For example, doubling 1920 x 1080 results in a
graphic that is 3840 x 2160. Depending on the speed of your processor, the real-time
effects playback may be limited for these high-resolution effects.
• Flattened layers: If the still image you want to use is a layered Photoshop file, do not
import it as a layered Photoshop file because it will appear as a sequence on multiple
tracks. Instead, flatten and save the image in your graphics application before you
import it into Final Cut Pro. Make sure you save the flattened image as a copy in case
you want to make changes to the original layered graphics file.
Note: Store any imported still images on your scratch disk so that all your media files
(video, audio, and still-image) are located in one place. This makes it much easier to locate
and move or copy all the project media at once.

Stage 2: Editing the Still Image into Your Sequence
The still image appears as a clip in the Timeline.

Stage 3: Opening the Image Clip in the Motion Tab of the Viewer
You can open an image clip in the Motion tab of the Viewer.
To open the image clip in the Motion tab of the Viewer
1 Double-click the clip in the Timeline to open it in the Viewer.
2 Click the Motion tab in the Viewer, then click the Basic Motion disclosure triangle to reveal
parameters such as Scale, Rotation, and Center.
3 In the Motion tab of the Viewer, enter 100 in the Scale field.
Set the Scale parameter
to 100.
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Stage 4: Preparing the Viewer and Canvas Settings
To see the image as it will appear within the frame during playback, you need to make
a couple of adjustments. (Otherwise you may, for example, see the frame background
where you didn’t mean to show it.) You also need to switch to the wireframe view to
position the image visually.
To prepare the Viewer and Canvas settings
1 In the Canvas, choose Image+Wireframe from the View pop-up menu.

2 Choose Fit All from the Zoom pop-up menu.

Note: If your final movie will be shown on a television monitor, it’s a good idea to turn
on the Title Safe indicators as well so that you can see what will actually be visible on the
television monitor. (Choose Show Title Safe from the View pop-up menu.)

Stage 5: Moving an Image by Changing Its Center Location
The Center parameter determines where the image appears (or doesn’t appear) onscreen.
You’ll create the image movement by setting a starting and ending Center location with
keyframes. To generate the movement path for you, Final Cut Pro interpolates the position
of the image between these two points.
To position and keyframe the image
1 Move the playhead to the time when you want the image pan to start.
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2 Move the position of the image in the Canvas to the starting position of the pan.

Starting position

Add Motion
Keyframe button

3 Control-click the Add Motion Keyframe button in the Canvas, then choose Center from
the shortcut menu.

A keyframe appears in the Motion tab in the Viewer, next to the Center parameter.

Center parameter
keyframe

4 Move the playhead to the time when you want the pan to end.
5 Move the image in the Canvas to the ending position.
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You don’t need to add a keyframe this time because, once a single keyframe has been
added to a parameter, new keyframes are automatically added each time you move the
clip to a new position.
You should see a line in the Canvas indicating the interpolated motion path between the
starting and ending keyframes.

Ending keyframe

6 To see the effect, remove the wireframe in the Canvas by choosing Image from the View
pop-up menu, move the playhead to the beginning of the clip, then play the sequence.
While you may see only a rough approximation of the final motion effect, you can still
see it without rendering. To see the effect at higher resolution, render it and then play
the sequence.
Tip: If the image looks “blocky” after rendering, choose High from the RT pop-up menu
in the Timeline and render the clip again.
To create a more realistic camera move, you may also want to smooth the motion at the
beginning and the end of the motion path, so that the camera starts slowly, reaches full
speed, and then slows down as it reaches the second keyframe.
To smooth the speed at the starting and ending points of a motion path
1 Choose Mark > Previous > Keyframe until the playhead is over the starting keyframe of
your clip. (You can also press Option-K.)
If you navigate too far past the starting keyframe, you can navigate back by choosing
Mark > Next > Keyframe (or pressing Shift-K).
2 In the Canvas, Control-click the starting keyframe and choose Ease In/Ease Out from the
shortcut menu.
The keyframe now has a velocity handle.
3 Drag the velocity handle away from the starting keyframe to adjust the acceleration at
the beginning of the motion path.
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This causes the clip to start moving slowly and then ramp up to full speed.
4 Choose Mark > Next > Keyframe (or press Shift-K) to navigate to the ending keyframe of
your motion path.
5 In the Canvas, Control-click the ending keyframe and choose Ease In/Ease Out from the
shortcut menu.
6 Drag the velocity handle of the ending keyframe toward the keyframe.
This causes the clip to decelerate as it approaches the ending keyframe of the motion
path.

Drag the velocity
handle toward the
ending keyframe.
Ending keyframe

For more information about velocity handles and creating smooth motion curves, see
“Controlling Speed Along a Motion Path.”
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Compositing and Layering
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This chapter covers the following:
• Introduction to Compositing and Layering (p. 1193)
• Working with Composite Modes (p. 1198)
• Composite Modes in Final Cut Pro (p. 1200)
• Using Travel Mattes to Hide or Reveal Parts of a Clip (p. 1208)
• Working with Layered Photoshop Files (p. 1210)
• Using Video and Graphics Clips with Alpha Channels (p. 1213)
• Temporarily Excluding Clips from Playback or Output (p. 1219)
Compositing is the process of stacking and blending multiple video or graphics clips over
one another in a sequence to create multilayer motion graphics and special effects shots.

Introduction to Compositing and Layering
Compositing involves stacking two or more video or graphics clips in a sequence on
multiple video tracks. You can also scale, rotate, and reposition each clip using the controls
in the Motion tab in the Viewer. The order that clips are stacked in the Timeline determines
which images appear in front of others in the Canvas. You can have up to 99 layers, or
tracks, of clips in Final Cut Pro.

Two video clips and
one graphic are layered
in a sequence.
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Methods of Compositing
Once you’ve layered clips in the Timeline, you can adjust how each one blends with the
layers below using the following methods:
• Opacity levels: This adjusts the transparency of a clip. You can adjust the Opacity
parameter to subtly blend two or more layers together, or you can animate this
parameter over time to create fade-ins and fade-outs. For more information, see
“Adjusting Opacity Levels of Clips.”
• Composite modes: This determines how the brightness and color values of one clip
visually interact with those of clips beneath it. Composite modes are sometimes called
blending modes. For more information, see “Working with Composite Modes.”
• Alpha channels: In some cases, a graphic or video file includes an additional channel
of grayscale information that determines the transparency of the image. Unlike a simple
opacity control, an alpha channel specifies a unique transparency value for each pixel
in the image. Alpha channels can be used as masks to hide parts of an image (such as
blue-screen footage) or to create transparency that varies throughout the image. For
more information, see “Using Video and Graphics Clips with Alpha Channels.” For
information about enabling or disabling alpha channels in sequence settings, see
“Confirming Alpha Channel Status.”
As an editor, you’ll find compositing useful for creating montages, abstract images, and
titles over video. You can also use Final Cut Pro to make a rough arrangement of layers
and then export those layers to Motion or Shake for even more advanced motion graphics
and compositing effects. The more layers you have, the more creative you can get.
However, you should aim to keep your designs as simple as possible, using the minimum
number of layers necessary to achieve your visual design or effect.

Different Ways to Layer Clips in the Timeline
There are several ways you can layer clips in the Timeline.
• Create a new track in a sequence, then edit clips into the new track.
You can add one or more tracks to a sequence, depending on the effect you are creating.
For more information, see “Working with Tracks in the Timeline.”
• Drag a clip into an empty area of the Timeline, so a track is created for the new clip.
You can drag a source clip to the unused space above (or below) the current tracks to
create a new track for that clip. If you drag a clip above the tracks already in the Timeline,
you’ll create a new video track. If you drag a clip below the tracks in the Timeline, a
new audio track is created. For more information, see “Working with Tracks in the
Timeline.”
• Perform a superimpose edit.
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You can use a superimpose edit to quickly stack a source clip on top of any clips already
edited into your sequence in the Timeline in preparation for compositing. If there isn’t
an available track in your sequence, Final Cut Pro creates a new one for the source clip.
For more information, see “Three-Point Editing.”
When you layer clips, the clip in the topmost track in the Timeline is the one that appears
during playback in the Canvas. However, this is true only if:
• None of the clips is set to be transparent (by changing the Opacity parameter setting)
• None of the clips has an alpha channel
If you change the opacity level of one or more layered clips so they have some
transparency, the clips blend and you see both images combined.

Moving Clips Vertically to Another Track
When you’re compositing, you may need to move a clip vertically from one track to
another but keep its location in time in a sequence from changing. You might do this to:
• Move a video clip on top of another one so that it appears in front
• Move a clip to another track to make room for another clip being edited in
To do this, hold down the Shift key while you drag a clip up or down. For more information
about moving clips to another track without accidentally moving them forward or
backward in time, see “Arranging Clips in the Timeline.”

Adjusting Opacity Levels of Clips
Every video clip has an Opacity parameter that allows you to change the clip’s level of
transparency. When you adjust the opacity level of one or more clips, they blend to create
a single image. You can then use the resulting image as the background for another layer,
such as a text or graphics layer.

Opacity is used to blend
two clips.

There are two ways you can adjust a clip’s opacity:
• Drag the opacity overlay of a clip in the Timeline.

Chapter 71 Compositing and Layering

1195

• Open the clip in the Viewer and specify the Opacity parameter’s value in the Motion
tab.
The Opacity parameter in the Motion tab and the opacity overlay displayed in the Timeline
have identical settings. A change made to one is mirrored in the other.
When you blend multiple clips together using the Opacity parameter, it’s important to
be aware of the color range, the amount of movement, and the overall amount of contrast
and texture in the images with which you’re working. Balancing all of these qualities is
what separates a good-looking composite from a confused jumble of images and motion.
To adjust the opacity of a clip (with no keyframes) in the Timeline
1 In the Timeline, click the Clip Overlays control.

The opacity overlay can
be dragged up or down
to adjust it.

Clip Overlays control

2 Drag the opacity overlay up or down to adjust the setting.
To adjust the opacity of a clip with greater accuracy, hold down the Command key while
you drag the opacity overlay.
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Note: The overlay appears as a black line if the clip is not selected and as a white line if
the clip is selected.
The pointer changes to
the Adjust Line Segment
pointer when it’s directly
over the overlay.
The actual percentage
of opacity appears in
this box.

To adjust the opacity of a clip (with no keyframes) in the Motion tab
1 Double-click the sequence clip you want to adjust to open it in the Viewer, then click the
Motion tab.
Note: When compositing clips in a sequence, make sure that you are always working on
sequence clips and not Browser clips. For example, if you do a match frame edit or
inadvertently open a clip from the Browser, you won’t be modifying a clip in the sequence
and so you won’t see changes in the Canvas.
2 Click the disclosure triangle next to the Opacity parameter.

Opacity parameter’s
keyframe graph
Opacity parameter

Number field for the
opacity percentage
Opacity slider, with
arrows on either end
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3 Adjust the opacity by doing one of the following:
• Drag the Opacity slider to the right or left.
• Click the arrows at the right and left of the Opacity slider.
• Type a percentage in the number field.
• Adjust the Opacity parameter’s keyframe graph line.
The pointer changes to the Adjust Line Segment pointer; a box shows the percentage
of opacity as you drag the keyframe graph line.
The opacity overlay in the Timeline can also be keyframed, enabling you to dynamically
change the opacity level over time. For information on keyframing, see “Animating Motion
Effects Using Keyframes.”

Working with Composite Modes
Final Cut Pro composite modes determine how the brightness and color of one clip
visually interact with those of another clip layered beneath it in a sequence. When you
edit a clip into your sequence, it defaults to the Normal composite mode, meaning that
it is a completely opaque layer that does not blend with the layers beneath.

How Composite Modes Affect Images
Composite modes mix colors from overlapping images together based on the brightness
values within each color channel in an image. Every image consists of red, green, blue,
and alpha channels (or one luma and two chroma channels in the case of Y′CBCR
component video). Each individual channel contains a range of brightness values that
defines the intensity of each pixel in the image that uses some of that color.
The effect that each composite mode has on objects that overlap in the Canvas depends
on the range of color values within each object. The red, green, and blue channels (or
Y′CBCRchannels) within each overlapping pixel are mathematically combined to yield the
final image.
These value ranges can be described as blacks, midrange values, or whites. These regions
are loosely illustrated by the chart below.
Blacks

Midrange color values

Whites

For example, the Multiply composite mode renders color values that fall into the white
areas of an image transparent, while the black areas of the image are left alone. All
midrange color values become translucent, with colors falling into the lighter end of the
scale becoming more transparent than the colors that fall into the darker end of the scale.
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Important: Final Cut Pro composite modes work in conjunction with a clip’s Opacity
parameter. The composite mode you select determines how the color values of one clip
interact with those in the clip beneath it. Additional changes made to a clip’s opacity can
lighten or intensify this effect.

Normal composite mode,
with the opacity of the
top clip at 50 percent

Applying Composite Modes to Clips
Applying different composite modes to layered clips in a sequence is easy. The main
thing to remember is that composite modes affect the interaction between one layered
clip and whichever clip is underneath it in the sequence. Clips that are above a layered
clip using a composite mode are unaffected.
To apply a composite mode to a clip in your sequence
1 With two layered clips edited into your sequence, select the topmost clip in the Timeline.
2 Choose Modify > Composite Mode, then choose a composite mode.
See “Composite Modes in Final Cut Pro” for information on the different modes.
3 Move the playhead over these two clips to see the interaction between the two clips in
the Canvas.

In this example, the
Screen composite mode
is on the upper of two
clips; the opacity of both
clips is 100 percent.

You can quickly view or change a clip’s composite mode while working in the Timeline.
This provides a fast alternative to choosing a different composite mode from the Modify
menu.
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To view or change a clip’s composite mode
1 Control-click a clip in the Timeline, then choose Composite Mode from the shortcut menu.

All composite modes
applied to a clip have a
checkmark next to them.

2 If you want to change the clip’s composite mode, choose a new mode from the submenu.

Composite Modes in Final Cut Pro
The following section describes how composite modes affect two layers in a sequence.
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About the Examples in This Section
Most of the examples in this section combine the following two reference images to
create a third composite image. The composite image illustrates how the color values
from each image interact when using each composite mode. When examining the results,
pay particular attention to the white and black areas of the colored squares, as well as
the highlights and shadows in the monkey image. These show you how each composite
mode treats the whites and blacks in an image.
The other brighter and darker colors serve to illustrate each composite mode’s handling
of overlapping midrange color values. The yellow, gray, orange, and blue squares, in
particular, all have very different color and luma values that contrast sharply from example
to example.

Boxes clip

Monkey clip

Important: Depending on the composite mode, layer ordering may or may not be
important. Certain composite modes behave differently depending on which image is
on top.

Normal
Normal is the default composite mode for clips. When a clip uses Normal composite
mode, you can still adjust its transparency by using its Opacity parameter or an alpha
channel.

Add
Add emphasizes the whites in each overlapping image, lightening all other overlapping
colors. The color values in every overlapping pixel are added together. The result is that
all overlapping midrange color values are lightened. Blacks from either image are
transparent, while whites in either image are preserved.
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The order of two clips affected by the Add composite mode does not matter.

Suggested uses: The Add composite mode is useful for using one image to selectively add
texture to another, based on its lighter areas such as highlights. You can also use Lighten
and Screen to create variations of this effect.

Subtract
Subtract darkens all overlapping colors. Whites in the foreground image go black, while
whites in the background image invert overlapping color values in the foreground image,
creating a negative effect.
Blacks in the foreground image become transparent, while blacks in the background
image are preserved.
Overlapping midrange color values are darkened based on the color of the background
image. In areas where the background is lighter than the foreground, the background
image is darkened. In areas where the background is darker than the foreground, the
colors are inverted.
The order of two clips affected by the Subtract composite mode is important.

Boxes clip on top
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Monkey clip on top

Difference
The Difference composite mode is similar to the Subtract composite mode, except that
areas of the image that would be severely darkened by the Subtract composite mode
are colored differently.
The order of two clips affected by the Difference composite mode does not matter.

Multiply
Multiply emphasizes the darkest parts of each overlapping image, except that midrange
color values from both images are mixed together more evenly. Progressively lighter
regions of overlapping images become increasingly translucent, allowing whichever
image is darker to show through. Whites in either image allow the overlapping image to
show through completely. Blacks from both images are preserved in the resulting image.
The order of clips affected by the Multiply composite mode does not matter.

Suggested uses: The Multiply composite mode is particularly useful in situations where
you want to knock out the white areas of a foreground image and blend the rest of the
image with the colors in the background. For example, if you superimpose a scanned
sheet of handwritten text over a background image using the Multiply composite mode,
the resulting image becomes textured with the darker parts of the foreground.
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Screen
Screen emphasizes the lightest parts of each overlapping image, except that the midrange
color values of both images are mixed together more evenly.
Blacks in either image allow the overlapping image to show through completely. Darker
midrange values below a certain threshold allow more of the overlapping image to show.
Whites from both images show through in the resulting image.
The order of two clips affected by the Screen composite mode does not matter.

Suggested uses: The Screen composite mode is especially useful for knocking out the
blacks behind a foreground subject and is an alternative to using a luma key. Screen is
mainly useful when you want the rest of the foreground subject to be mixed with the
background image as well, based on its brightness. It’s good for glow and lighting effects,
and for simulating reflections. You can also use the Add and Lighten composite modes
to create variations of this effect.

Top layer

Bottom layer

Screen composite

Overlay
Whites and blacks in the foreground image become translucent and interact with the
color values of the background image, causing intensified contrast. Whites and blacks in
the background image, on the other hand, replace overlapping areas in the foreground
image.
Overlapping midrange values are mixed together differently depending on the brightness
of the background color values. Lighter background midrange values are mixed by
screening. Darker background midrange values, on the other hand, are mixed together
by multiplying.
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The visible result is that darker color values in the background image intensify overlapping
areas in the foreground image, while lighter color values in the background image wash
out overlapping areas in the foreground image.
The order of two clips affected by the Overlay composite mode is important.

Boxes clip on top

Monkey clip on top

Suggested uses: The Overlay composite mode is particularly useful for combining areas
of vivid color in two images.

Hard Light
Whites and blacks in the foreground image block overlapping areas in the background
image. Whites and blacks in the background image, on the other hand, interact with
overlapping midrange color values in the foreground image.
Overlapping midrange color values are mixed together differently depending on the
brightness of the background color values. Lighter background midrange values are
mixed by screening. Darker background midrange values, on the other hand, are mixed
together by multiplying.
The visible result is that darker color values in the background image intensify overlapping
areas in the foreground image, while lighter color values in the background image wash
out overlapping areas in the foreground image.
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The order of two clips affected by the Hard Light composite mode is important.

Boxes clip on top

Monkey clip on top

Soft Light
The Soft Light composite mode is similar to the Overlay composite mode. Whites and
blacks in the foreground image become translucent but interact with the color values of
the background image. Whites and blacks in the background image, on the other hand,
replace the overlapping areas in the foreground image. All overlapping midrange color
values are mixed together, creating a more even tinting effect than that created by the
Overlay composite mode.
The order of two clips affected by the Soft Light composite mode is important.

Boxes clip on top

Monkey clip on top

Suggested uses: The Soft Light composite mode is useful for softly tinting a background
image by mixing it with the colors in a foreground image.
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Darken
Darken emphasizes the darkest parts of each overlapping image. Whites in either image
allow the overlapping image to show through completely. Lighter midrange color values
become increasingly translucent in favor of the overlapping image, while darker midrange
color values below a certain threshold remain solid, retaining more detail.
The order of two clips affected by the Darken composite mode does not matter.

Suggested uses: The Darken composite mode is useful for using one image to add texture
to another selectively, based on its darker areas. You can also use Screen for variations
on this effect.

Lighten
Lighten emphasizes the lightest parts of each overlapping image. Every pixel in each
image is compared, and the lightest pixel from either image is preserved, so that the final
image consists of a dithered combination of the lightest pixels from each image. Whites
in both images show through in the resulting image.
The order of two clips affected by the Lighten composite mode does not matter.
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Travel Matte - Alpha
When you apply the Travel Matte - Alpha composite mode to a selected clip, the alpha
channel from the clip below is applied to the selected clip. Only two clips are required
to use this composite mode, but in most situations, you will use three layers:
• Foreground (top layer): This layer appears on top of the background layer, as seen
through the alpha channel. Apply the Travel Matte - Alpha composite mode to this
layer.
• Alpha channel (middle layer): This layer provides the alpha channel (transparency
information) for the foreground layer.
• Background (bottom layer): This optional layer appears beneath the foreground image
wherever the foreground image is masked by the alpha channel. The background can
be a single layer, or multiple layers blended with transparency or composite modes. If
no background layer exists, the Canvas displays the default Final Cut Pro background
color (checkerboard, black, white, and so on), and black appears during output and
export.

Foreground clip

Alpha channel

End result

Travel Matte - Luma
The Travel Matte - Luma composite mode does the same thing as the Travel Matte - Alpha
composite mode, but the transparency is derived from the luma information (instead of
the alpha channel) of the clip below. The luma information may be derived from a
grayscale equivalent of the RGB channels, or directly from the luma (Y′) channel in the
case of Y′CBCR video. White is equal to 100 percent transparency and black is equal to
100 percent opacity (solid).

Using Travel Mattes to Hide or Reveal Parts of a Clip
Travel mattes are useful when you want to use one clip to selectively hide or reveal part
of another. For example:
• To show parts of a video layer selectively revealed by a round spotlight shape
• To partially reveal video images playing through a title or logo graphic
• To use an imported graphic to obscure, or mask, part of a layer you don’t want to show
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Because travel mattes use information in one layer to affect another, if the alpha channel,
black, or white elements of that layer move, then the resulting matte also moves. This
movement can be a result of:
• Using a video or animation clip as your matte layer
• Moving that layer around with keyframed motion parameters
For more information, see “Creating Keyframed Motion Paths in the Canvas.”
To create a travel matte
1 Place the clip you want to have appear in the background of your composite on track V1
in the Timeline.
2 Place the clip you want to use as your matte layer on track V2, above the background
clip.
• When using the Travel Matte - Alpha mode: Make sure that the clip has a properly
formatted alpha track (see “Using Video and Graphics Clips with Alpha Channels”).
• When using the Travel Matte - Luma mode: Make sure that the black and white areas of
your clip are appropriately set—black for transparent areas, white for solid areas.

The matte clip
goes above the
background clip.

3 Place the main clip that you want masked on track V3, directly above the matte layer.

The main clip to be
masked goes above
the matte clip.

4 Select the main clip on track V3.
5 Choose Modify > Composite Mode, then choose Travel Matte - Alpha or Travel Matte Luma, depending on the clip you’re using as your matte layer on track V2.
• Alpha: Uses the clip’s alpha channel, if one exists, as the mask.
• Luma: Uses the luma, or grayscale image, of the clip as the mask.
Note: The matte clip’s RGB information won’t be seen.
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Working with Layered Photoshop Files
You can create multilayer graphics in Adobe Photoshop for use in a composited
Final Cut Pro sequence. This allows you to create a complex arrangement of separate
graphic elements and import them as a group, with their position and layer ordering
intact. Once you import layered Photoshop files, they appear as a sequence, with each
individual layer stacked. At this point, it’s easy to manipulate each layer individually to
create sophisticated composites.
You can import multilayer Photoshop files created in any version of Photoshop, but only
Photoshop 3.0 features (such as opacity, composite modes, layer order, and layer name)
are preserved during import.

Updating Photoshop Files in Adobe Photoshop
Once a layered Photoshop file is imported, you can automatically open it in Photoshop
to make further changes by:
• Choosing View > Clip in Editor
• Control-clicking the file in the Browser or Timeline and then choosing Open in Editor
from the shortcut menu
You can make changes to any of the layers and save the file. When you return to
Final Cut Pro, those changes are updated in the corresponding multilayer sequence in
your project.
Tip: While compositing, you may need to make changes to different types of clips that
you’re using. You can select separate editing applications for three types of files: still-image,
video, and audio. For more information, see “Choosing Settings and Preferences.”

Working with Layered Photoshop Sequences
When you import a layered Photoshop file into Final Cut Pro, all the layers of the source
Photoshop file are composited together with a sequence frame size identical to the
imported Photoshop file’s frame size.

An imported Photoshop
file becomes a sequence
in the Browser.
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If you want to import a layered Photoshop file as a single clip, you must flatten the image
in Photoshop and then import the file into Final Cut Pro.
The sequence Final Cut Pro creates has the same number of layers as the imported file.
The background layer becomes a clip in track V1, and each consecutive layer appears in
the same order as the layers in the original Photoshop file. If you change the order of the
video tracks, the layering order changes. If the background in the Photoshop file is
transparent, the background of the new sequence is transparent as well and defaults to
black.
A Photoshop file is a
sequence with its own
tab in the Timeline.

The background layer
becomes a clip in track
V1, with other layers in
the tracks above.

Layer opacity settings, layer modes, and layer visibility are preserved, but layer masks are
not. If a Photoshop layer mode has no corresponding compositing mode in Final Cut Pro,
that layer mode is ignored.

Don’t Add or Delete Layers from an Imported Photoshop File
Final Cut Pro keeps track of each imported Photoshop layer according to its position
relative to the bottom layer. While editing a layered Photoshop file that’s already been
imported into Final Cut Pro, it’s not a good idea, under any circumstances, to:
• Add additional layers: If you add a layer, any layer pushed above the topmost layer that
was imported into your Final Cut Pro project is ignored when you go back to
Final Cut Pro.
• Delete layers: Deleting previously imported layers can have even more unexpected
results. If you must add or remove a layer from a previously imported Photoshop file,
do this in Photoshop and then reimport the file into Final Cut Pro. For additional
information about importing layered Photoshop files, see “Importing Media Files into
Your Project.”
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Changing the Frame Rate of Layered Photoshop Sequences
When you import a layered Photoshop file, the resulting sequence has the frame rate of
the current sequence preset. For example, if you choose a DV PAL Easy Setup and then
import a layered Photoshop file, the resulting sequence has a frame rate of 25 fps.
If you want to edit this layered Photoshop sequence into a sequence with a different
frame rate, you have two choices:
• Edit the layered Photoshop sequence into the destination sequence and allow
Final Cut Pro to automatically change the frame rate of the nested sequence.
• Manually change the frame rate of the sequence before you edit it into the destination
sequence.
It’s often easier to let Final Cut Pro automatically change the frame rate of your layered
Photoshop sequence when you edit it into a sequence whose frame rate doesn’t match
that of the Photoshop sequence. If the layered Photoshop sequence does not have
affiliated copies, Final Cut Pro automatically updates the frame rate of the nested sequence
and the master layered Photoshop sequence in the Browser.
However, if other affiliate copies of the layered Photoshop sequence already exist, the
following steps happen automatically:
• A new master layered Photoshop sequence is created in the Browser.
• The frame rate of the new layered Photoshop sequence is changed to match that of
the destination sequence.
• The name of the new layered Photoshop sequence is changed to indicate its new frame
rate.
• A copy of the new master layered Photoshop sequence is edited into the destination
sequence.
To manually change the frame rate of a layered Photoshop sequence
1 Select the layered Photoshop sequence in the Browser, then choose Sequence > Settings.
2 Choose a frame rate from the Editing Timebase pop-up menu, then click OK.
If affiliate copies of this layered Photoshop sequence have already been edited into other
sequences, Final Cut Pro does not allow you to change the sequence frame rate. In this
case, you can manually create a duplicate master clip of this sequence.
To create a duplicate master clip of a layered Photoshop sequence
1 Select a layered Photoshop sequence in the Browser.
2 Choose Modify > Duplicate as New Master Clip.
A new master clip is created whose frame rate you can modify for nesting into other
sequences.
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Using Video and Graphics Clips with Alpha Channels
Ordinary video clips have three channels of information for red, green, and blue. An alpha
channel is an additional channel that defines areas of transparency in the clip or image.
If you import a QuickTime movie or a still image from another application, or a file that’s
been created by a 3D animation program, it may have an alpha channel in addition to
its color channels. An alpha channel is a grayscale channel where levels of white and
black determine varying degrees of transparency applied to the color channels during
compositing.
When you import a QuickTime movie or an image file, its alpha channel is recognized
immediately. When you edit the movie or image file into a sequence, Final Cut Pro uses
the alpha channel to composite the movie or image file against any clips appearing in
video tracks below it.
Note: Alpha channels work the same in video and still-image media files.

Foreground
graphic

Alpha
channel

Background
graphic

Final
composite

Important: When you import a clip with an alpha channel that contains no data, the clip
appears white. To display the clip properly, change the alpha channel for the clip to None
(see “Changing a Clip’s Alpha Channel Type”).

Working with Clips That Have Alpha Channels
You can edit clips that have alpha channels into your sequence as you would any other
clip, but you must make sure that a clip with an alpha channel is on a higher-numbered
video track than any clips that are supposed to be beneath it.
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For example: You have a title graphic that was created in Photoshop, so it has an alpha
channel already set up. When you import it into Final Cut Pro, the alpha channel is
recognized automatically. To create your title sequence, you edit the title graphic and a
background image into your sequence, so that the background image is on track V1 and
the title graphic is on track V2.

The alpha channel in the
graphics file makes the
areas around the text
transparent without
requiring you to change
any opacity settings.

The title graphic with the
alpha channel is in a
higher-numbered track.

Changing a Clip’s Alpha Channel Type
When you import a still image file, Final Cut Pro identifies the type of alpha channel and
sets the imported clip’s Alpha property appropriately. You should usually not change this
setting, except in rare circumstances where Final Cut Pro identifies an image alpha channel
as premultiplied black or premultiplied white and you are certain that the alpha channel
type is actually straight.
When you import a video file with an embedded alpha channel from third-party editing
and compositing applications, Final Cut Pro always sets the Alpha property to Straight.
In these cases, you can manually change or reverse the alpha channel setting if necessary.
To change a clip’s alpha channel type using the Item Properties window
1 Do one of the following:
• Select a clip in the Browser, then choose Edit > Item Properties > Format (or press
Command-9).
• Control-click a clip in the Browser, then choose Item Properties > Format from the
shortcut menu.
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The Item Properties window appears.
2 Control-click the Alpha row in the Clip column, then choose the alpha channel type from
the shortcut menu.
• None/Ignore: If a clip has no alpha channel, or if you want to turn off the alpha channel
of a clip so that it’s no longer used, you can use the None/Ignore setting.
• Straight: Typically generated by a 3D animation or compositing program, straight alpha
channels contain only the pixels rendered for an image with no background (although
the background appears black). Because of this, movies with translucent effects, such
as volumetric lighting or lens flares, appear distorted unless they’re composited with
something in the background. Movies or images with a straight alpha channel are easy
to composite and always have very clean edges when composited in a multilayer
sequence.
• Black: Also known as premultiplied with black. Most other alpha channels, especially
channels that are hand drawn in Photoshop, are premultiplied. This means that, unlike
a movie with a straight alpha channel that contains only the pixels of the foreground
image, movies with alpha channels premultiplied against black always look right, even
if they have translucent lighting effects. This is because the entire image is
precomposited against black.
• White: Also known as premultiplied with white. Works the same as the black alpha
channel, except that the clip is precomposited against white.
Tip: If necessary, you can also Control-click the Reverse Alpha row in the Clip column
and choose No or Yes from the shortcut menu.

Control-click in the Alpha
row, then choose an
alpha channel option
from the shortcut menu.

To change the alpha channel type of a clip using the Alpha Type menu item
1 Select a clip in the Timeline or open a clip in the Viewer.
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2 Choose Modify > Alpha Type, then choose a new alpha channel type from the submenu.

µ
µ

To change the alpha channel type of a clip in the Browser
Control-click in the Alpha column in the Browser, then choose a new alpha channel type
from the shortcut menu.
To reverse a clip’s alpha channel
Do one of the following:
• Select a clip in the Timeline or open a clip in the Viewer, then choose Modify > Reverse
Alpha.
• In the Browser, Control-click in the Reverse Alpha column next to the clip you want to
modify, then choose Yes from the shortcut menu.
If there is a checkmark by the Reverse Alpha menu item, the clip’s alpha channel is
being reversed. If there is no checkmark, the alpha channel is left alone.

Exchanging Media with Alpha Channels
Alpha channels are simply grayscale images or frames, where levels of white and black
determine varying degrees of transparency. If you look at a clip with an alpha channel in
the Viewer with the Alpha option selected in the View pop-up menu, you’ll see that the
solid areas of the image are represented by 100 percent white and that transparent areas
of the image are represented by 100 percent black. Lighter to darker shades of gray
indicate lesser to greater areas of transparency.
Other editing applications may use white and black differently than Final Cut Pro. If you’re
exchanging media with other editors and broadcast graphic designers, let them know
how you need clips with alpha channels to be set up for use in Final Cut Pro.

White areas are solid.
Dark areas are
transparent.

Viewing RGB and Alpha Channels in the Viewer
When you’re working in the Viewer, it can sometimes be helpful to have a quick look at
the alpha channel of your clip. The alpha channel defines areas of transparency and can
change if various filters are applied. For example, if a blue-screen clip is added to the
Viewer, and a blue-screen filter is applied to the clip, you can check to see what the alpha
channel looks like by itself by choosing View > Channels > Alpha.
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There are several channel viewing options in the View menu and the View pop-up menu
in the Viewer.
• RGB: This is the default color option; it shows the three color channels that make up
the actual video image.

• Alpha: This option represents the alpha channel as black against white, where absolute
black represents 100 percent transparency, levels of gray represent varying degrees of
transparency, and absolute white represents nontransparent areas of the picture.

• Alpha+RGB: This option lets you see a representation of the alpha channel overlaid on
top of the RGB channels that constitute the actual image of the video clip. The alpha
channel is overlaid in red, with solid red representing nontransparent areas.

The RGB and Alpha options in the View menu are most effective when used with different
backgrounds, described in “Choosing a Background.”
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To choose an alpha channel display option
Do one of the following:

µ
µ

Choose View > Channels, then choose an option from the submenu.
Choose an alpha channel display option from the View pop-up menu in the Viewer.

Alpha channel
display options
Background
display options

Choosing a Background
When working with clips that have an alpha channel, you can choose different
backgrounds that make it easier to see which areas of your picture are transparent.
Translucent clips or generated text clips may be easier to see if you choose a background
that emphasizes them, such as Checkerboard 1 or 2. If you’re compositing colored images,
a contrasting color would work better.

Translucent clips or
generated text may
be more visible if you
choose Checkerboard
1 or 2.

When a clip is rendered for export to tape, the background is always set to black. If it is
rendered for export as a QuickTime movie, the background will still appear to be black,
even if the alpha channel is exported along with the clip.
There are several backgrounds to choose from.
• Black
• White
• Checkerboard 1
• Checkerboard 2
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• Red
• Green
• Blue
Note: Red, Green, and Blue backgrounds are available from the submenu only when
choosing View > Background.
To choose a background for viewing a clip
Do one of the following:

µ
µ

Choose View > Background, then choose a background from the submenu.
Choose the background from the View pop-up menu in the Viewer.

Superimposing Video When Preparing for EDL Export
In an Edit Decision List (EDL), a Super or Key track is the equivalent of a single
superimposed video track in Final Cut Pro. EDLs can recognize only one Key track, so V2
is the only video track other than V1 that appears in an exported EDL. Transitions in track
V2 are not allowed in EDLs and are ignored. If you want to use a transition in track V2,
use keyframes in the opacity overlay to dissolve V2 up and down. (See “Importing and
Exporting EDLs.”)
The opacity overlay in the Timeline appears as the “Key Level” in your exported EDL.
Opacity keyframes, if they exist, are translated into values for the Key Level and are
calculated in the EDL in relation to the timecode of the master tape. These numbers are
for use by a video switcher. Some online systems can translate these for automatic use
by some switchers, but more commonly they are used only as notes for the editor to use
in an online session. These values and their locations appear as notes in the EDL.

Temporarily Excluding Clips from Playback or Output
In the process of fine-tuning effects in a sequence or experimenting with multilayer effects
in sequences, it can be helpful to compare how the sequence plays with and without
certain clips. In Final Cut Pro, you can exclude (rather than delete) a clip from playback.
Temporarily excluding a clip from playback and output is called disabling the clip. By
temporarily disabling specific clips, you can focus on one clip to the exclusion of clips
above or below it, or you can see how another clip would work in place of the original
without removing it.
It’s helpful to disable a clip rather than deleting it, in case you change your mind and
want to use it again later. Or, you may want to disable just the video or audio portion of
a clip, so that you can keep the video or audio available without including it in playback
or output. This is somewhat like muting channels in an audio mixer, except that you
exclude playback of clips instead of entire tracks.
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Temporarily Disabling a Single Clip
If, instead of disabling an entire track, you only want to disable a single clip temporarily,
you can do so. While a single clip is disabled, it will not be:
• Played back
• Rendered
• Output to tape with the rest of the sequence
To disable one or more clips
1 Select the clip or clips using one of the selection tools.
2 Do one of the following:
• Choose Modify > Clip Enable, so the menu item is no longer selected.
• Control-click one of the selected clips, then choose Clip Enable from the shortcut menu.
A disabled clip is dimmed in the Timeline, and its Clip Enable menu item is deselected.
To selectively disable a clip’s audio or video tracks
1 Do one of the following:
• Turn off linked selection, then select one or more audio or video items in the Timeline
using one of the selection tools.
• If linked selection is on, hold down the Option key to turn it off temporarily, then select
one or more audio or video items using one of the selection tools.
For more information about linked selection, see “Linking and Editing Video and Audio
in Sync.”
2 Do one of the following:
• Choose Modify > Clip Enable, so the menu item is no longer selected.
• Control-click one of the selected clips, then choose Clip Enable from the shortcut menu.
Individually disabled audio or video items also appear dimmed in the Timeline, although
their corresponding linked items are not dimmed.

Soloing Clips in Multitrack Sequences
When working with multiple tracks, you may find it helpful to quickly demo one clip
within a sequence to the exclusion of the clips above and below it on other tracks. This
helps you focus very closely on how one clip is working in a sequence. This feature, called
solo item, works by disabling all unselected clips in the Timeline that appear in other
tracks at the position of the playhead. In other words, any clips that overlap the “solo”
clip in time are excluded from playback.
To solo a clip
1 In the Timeline, position the playhead on the clip you want to solo.
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2 Select the clip that you want to solo.
3 Choose Sequence > Solo Selected Item(s) (or press Control-S).
All clips in other tracks that overlap the selected clip are disabled.
4 Position the playhead and play the sequence.

Overlapping clip
items on other tracks
are disabled.

Clip item with
solo enabled

µ

To reenable the disabled clips
Choose Sequence > Solo Selected Item(s) again.

Disabling and Soloing Clips and the Effect on Rendering
When working with multiple tracks in Final Cut Pro, you may find it useful to turn off or
disable some onscreen elements to focus on a particular area of detail in a sequence.
There are two main ways to temporarily solo or disable items in sequences: at the clip
level and at the track level. Depending on the type of sequence you're working on, one
method might be preferable over the other. Each has a different impact on the amount
of sequence area that will require rerendering.
Clip Enable and Solo Item
By default, visibility is enabled for items in the Timeline. (To confirm an item in the Timeline
is enabled, select it and see if Clip Enable has a checkmark in the Modify menu.) You can
choose Modify > Clip Enable to temporarily disable an item so that it will not be played
back, rendered, or output with the rest of the sequence. In most cases when you've
already rendered the sequence, disabling clips instead of whole tracks should minimize
the amount of rerendering that is required. When an item is disabled, its Timeline
representation will be darkened slightly.
When you disable a clip in a rendered sequence, only the duration of that clip requires
rerendering.
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To turn clip enabling on or off for a clip (or other item) in the Timeline
1 Select the clip in the Timeline.
2 Choose Modify > Clip Enable.
You can also use the Solo Clip command to disable the items in the tracks above and
below a selected clip so that it's isolated. In other words, you can exclude from playback
any clips that overlap the solo clip. When you solo items in a rendered sequence, only
the duration of the items that overlap the soloed items require rerendering.
To solo a clip (or other item)
1 In the Timeline, select the clip or clips that you want to solo.
2 Choose Sequence > Solo Selected Items (or press Control-S).
To turn soloing off for selected clips
1 Select the soloed clips.
2 Choose Sequence > Solo Selected Items.
Turning Track Visibility On or Off
You can disable entire tracks to hide their contents during playback. The clips on a disabled
track are not visible or audible when you play the sequence.
When you disable a track, the duration of all clips in that track require rerendering.

µ
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To disable a track
Click the Track Visibility control for the track you want to disable.
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This chapter covers the following:
• Ways to Layer and Isolate Elements in Clips (p. 1223)
• Using Keying to Isolate Foreground Elements (p. 1226)
• Overview of Compositing Using the Chroma Keyer Filter (p. 1228)
• Working with the Chroma Keyer Filter (p. 1231)
• Using Mattes to Add or Modify Alpha Channels (p. 1242)
• Using Masks to Replace or Modify Alpha Channels (p. 1245)
You can isolate specific elements of clips from the background and combine those
elements with other clips by using keying, mattes, and masks.

Ways to Layer and Isolate Elements in Clips
People have been layering visual elements together since the dawn of the movie industry.
Although digital techniques have increased the potential number of layers from two or
three to two or three thousand (and even more), the same basic principles are used. The
names vary from one industry to the next, but as film and video merge on a single digital
horizon, the terms are becoming more interchangeable.

What Are Mattes and How Can You Use Them?
Matte, or hold matte, originated with film and photography. It traditionally refers to any
opaque material that, when held in front of a camera lens, prevents certain areas of the
film from being exposed during shooting. Then, the camera can be rewound, and a matte
of the reverse shape can be used to prevent exposure on the already exposed part of the
film while the other portion is exposed. The result is two different images shot at different
times combined together in one frame.
The same principle can be used in digital applications. In the case of cameras, the mattes
are handmade, physical objects, but on a computer they can be drawn and applied
digitally.
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In Final Cut Pro, a matte is a customizable, polygonal shape used to make part of a clip
transparent. By outlining part of an image with a matte, you can turn everything outside
or inside the shape transparent. Final Cut Pro allows you to create four- and eight-point
mattes.

A four-point matte outlining
the image of the woman

The resulting image, with the
background transparent

What Is Keying and How Can You Use It?
Keying refers to the process of turning an area of consistent color or brightness in a video
clip transparent to isolate a foreground subject. The actual keying process results in the
creation of a matte, which is then automatically applied to composite an image with a
background. In television and in movies, keying is used in a variety of ways to composite
actors in front of graphics and other video clips for a variety of effects.
For example, a weather reporter on television often stands in front of a weather map.
The reporter is actually standing in front of a large blue or green screen, but the color is
made transparent (keyed out), and a map is inserted behind the person, instead.
Generating a matte signal using a color signal is referred to as chroma keying, while
generating a matte signal using a black-and-white signal is called luma keying.
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What Are Masks and How Are They Used?
A mask is an image that is used to create areas of transparency in another image. For
example, the luma in one clip can be used to create transparency in another clip. You
can also assign the alpha channel of one clip to a completely different clip. (For more
information about alpha channels, see “Alpha Channels and Key, Matte, and Mask Filters.”)
Using additional mask filters, you can further modify the resulting regions of
transparency—widening, narrowing, or feathering them as needed. Clips used to create
masks can be in motion, creating a moving area of transparency.

Alpha Channels and Key, Matte, and Mask Filters
Key, matte, and mask filters all create or modify the alpha channel of the clip to which
they’re applied. A clip’s alpha channel defines areas of transparency within that clip.
Key filters generally create new alpha channel information and are useful in situations
where the foreground subject is moving or has a complex or changing shape. For more
information about keying, see “Using Keying to Isolate Foreground Elements.”
Matte filters can create alpha channel information, but they can also be used to add to
or subtract from alpha channel information that has already been applied to the clip.
Matte filters are useful when you want to simply isolate a region of the frame, or when
you’re cutting out a static foreground object with a relatively simple shape. For more
information about using mattes, see “Using Mattes to Add or Modify Alpha Channels.”
Masks are most useful when you’re copying an alpha channel (static or in motion) from
one clip to another, although masks can also change the quality of a clip’s alpha channel,
letting you feather out edges, for example. For more information about using masks, see
“Using Masks to Replace or Modify Alpha Channels.”
For information about enabling or disabling alpha channels in sequence settings, see
“Confirming Alpha Channel Status.”
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Using Keying to Isolate Foreground Elements
There are two different methods used for keying: chroma keying and luma keying. Chroma
keying is a method of keying on a particular hue of color. Although any color can be keyed
on, the colors most frequently used for chroma keying are blue and green. Specific hues
of blue and green with particular levels of saturation have been developed that provide
the best results, and different companies have created commercially available paints,
fabrics, and papers that use these colors.
The color you use—blue or green—depends largely on the color of your foreground
subject. If you’re trying to create a key around a blue car, you probably want to use green
as your background. Another advantage of using green, when possible, is that video
formats generally preserve more information in the green component of the signal,
resulting in slightly better keys.
Luma keying is based on a particular range of luma. Black is usually used, but you can also
key on white. While keying out a white or black background may be more convenient in
certain circumstances, it may be harder to correctly isolate your foreground subject
because of shadows and highlights, which may have black or white values close to the
luma range you’re keying out.
Regardless of the keying method you use, it’s important to start out with clips that key
well. The decisions you make before and during your shoot affect how well your footage
keys. Make sure that you:
• Choose a video format with a minimum amount of compression that is ideal for shooting
and keying
• Light the background screen and foreground subject properly

Choosing an Appropriate Video Format
Ideal video clips for keying can be captured from footage in uncompressed or minimally
compressed video formats, such as Betacam SP or Digital Betacam footage digitized with
an uncompressed video capture interface, or DVCPRO 50 footage captured digitally with
no additional compression added. Compression discards color information from a clip
and can add artifacts around high-contrast edges in the picture (such as the edges
surrounding the image to be keyed). If you use compressed video to create keying effects,
you’ll frequently lose details around the edges of the keyed image, including hair,
translucent cloth, reflections, and smoke.
If you must apply compression during capture, you can still pull good keys from clips
with as much as a 2:1 compression ratio, but ideal source footage should be uncompressed.
DV footage, which is compressed with a 5:1 ratio as it’s recorded, is less than ideal. This
is because of compression artifacts that, while invisible during ordinary playback, become
apparent around the edges of your foreground subject when you start to key. However,
this doesn’t mean that you can’t key with DV footage.
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With a high-quality DV camera and good lighting, it’s possible to pull a reasonable key
using DV clips, but you cannot expect the kind of subtleties around the edges of a keyed
subject that you can get with uncompressed or minimally compressed footage. For
example, while you may be able to preserve smoke, reflections, or wisps of hair when
keying uncompressed footage, with equivalent DV footage this probably won’t be possible.
On the other hand, if your foreground subject has slicked-back hair and a crisp suit, and
if there are no translucent areas to worry about, you may be able to pull a perfectly
acceptable key.

Using Proper Lighting
The lighting you use when shooting blue- or green-screen footage plays a crucial role in
determining whether or not you’ll be able to key out the background easily.
• Blue or green background: Should be evenly lit, with no exceptionally bright areas (hot
spots) or shadows. The material you use for the background screen should be smooth,
with no bumps or wrinkles.
• Video signal: Should have a minimum of film or video grain, since the “noisiness” that
grain introduces can make it more difficult to pull a good key. Video can get grainy in
low-light situations, so the lighting on your background screen should be bright enough
that you don’t have to turn up the gain of your video camera.
• Lighting of foreground subject: Should have close to a 1:1 ratio to the lighting of the
background screen. This avoids overexposing or underexposing the background screen
when the foreground subject is correctly lit.
Once your background blue or green screen is properly lit, you should concentrate on
lighting the foreground subject to match the scene into which you’re going to
composite it. It’s especially important to make sure that the contrast between the
shadows and highlights of your subject’s lighting is correct. While you can use the
Final Cut Pro color correction filters to easily adjust the color and overall brightness of
your subject, contrast is not so easy to change. This is not to say that you need to light
your foreground subject flatly. Just make sure that the direction, quality, and contrast
of the lighting you use works for the scene your subject will inhabit.
• Distance between foreground subject and background screen: It’s a good idea to have
some distance between the foreground subject and the background screen, to reduce
the amount of colored light bouncing off the background blue or green screen and
“spilling” on the foreground subject. In general, position your subject 5 to 10 feet away
from the background screen.
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Using Video Scopes to Help Correctly Light Your Background Screen
Because the Waveform Monitor shows you all variations in brightness in the video frame
from the left to the right of the screen, you can use it to reveal hot spots in your
background screen that may be difficult to see with the naked eye. If you connect your
portable computer to a DV video camera with FireWire while you’re on the set, you can
see the brightness level across the entire blue- or green-screen background on the
Waveform Monitor’s graph. (You can also use an analog-to-DV converter to connect to
the analog output of a camera with a different format.) Hot spots appear as spikes on the
Waveform Monitor, and shadows appear as downward-pointing spikes, while shadowed
areas appear as dips.

Bright areas appear
as tiny spikes.

Shadows appear as small,
downward-pointing spikes.

With this information, you can adjust your lighting until it appears even in the graph in
the Waveform Monitor, ensuring the best possible background for keying. Once your
lighting is adjusted, you can perform an additional test by capturing a clip and then using
the Chroma Keyer filter to see how well it keys.

Overview of Compositing Using the Chroma Keyer Filter
Although you can use one of several different filters for keying, you often use more than
one filter, depending on the qualities of the video clip. In general, the process of
compositing two shots together by keying consists of seven main steps, using several
different types of filters. For more details, see “Example: Using the Chroma Keyer Filter.”
Stage 1: Starting with the Color Smoothing Filter
Apply the Color Smoothing filter to the clip that you want to key the background out of.
This filter improves the quality of chroma keys and reduces the diagonal “stair-step” look
that occurs in video clips with areas of high-contrast color.
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Use 4:1:1 Color Smoothing with NTSC or PAL DV-25 video sources. (The exception is PAL
mini-DV/DVCAM, which uses 4:2:0 color sampling.) Use 4:2:2 Color Smoothing for
DVCPRO50 and 8- and 10-bit uncompressed video.
As you add additional key filters, make sure that the Color Smoothing filter remains the
first one listed in the video section of the Filters tab.
Stage 2: Applying the Chroma Keyer Filter
Now you can apply the Chroma Keyer filter to the clip. Choose a color or level of brightness
to key on, and then make adjustments to select the range of color or brightness that
most effectively keys out the background, without eliminating the details of your
foreground subject, such as hair, fingers, or the edges of clothing. You can also use the
Thin/Spread slider to adjust the fringing that appears around your foreground subject,
but don’t use it too aggressively.
Tip: Although the Chroma Keyer filter is the fastest and easiest to use, you may find that
the Blue and Green Screen filter, in conjunction with the Matte Choker filter, can perform
a closer key on certain clips that have more subtle detail around the edges of the
foreground subject. For more information on the controls of the Blue and Green Screen
filter, see “Key Filters.”
Stage 3: Eliminating Fringing with the Matte Choker Filter
After keying out as much of the background as you can without touching the foreground
subject, apply the Matte Choker filter to eliminate any faintly remaining blue or green
fringing or pixels surrounding the edge of your foreground subject. Using the Matte
Choker filter to eliminate this fringing works similarly to using the Thin/Spread slider in
the Chroma Keyer. You may find that, for some clips, the Matte Choker filter works better
than using more aggressive settings in the Chroma Keyer, giving you a better chance of
preserving as much fine detail around the edges of your foreground subject as possible.
Drag the Edge Thin slider to the right to remove faint areas of the key color around your
foreground subject and to smooth out the rough edges of your key.
A second Matte Choker filter can also be applied to fill holes in the foreground subject
that appear as a result of aggressive settings applied to key out the background. By
dragging the Edge Thin slider to the right, you can fill in semitranslucent areas in your
foreground subject, without changing the background areas you’ve already keyed out.
For more information about the Matte Choker filter controls, see “Matte Filters.”
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Stage 4: Readjusting the Chroma Keyer Filter’s Settings
When keying, additional filters you add usually affect the overall results of previously
applied filters, so after applying the Matte Choker, you’ll probably want to readjust the
Chroma Keyer filter’s settings to take into account the effect the Matte Choker is having.
Changes you make to the Chroma Keyer filter’s settings affect what the Matte Choker
does, so go back and forth between the Chroma Keyer and Matte Choker filters until you
find a balance of settings that effectively removes the background without eating into
your foreground subject.
Stage 5: Desaturating the Key with Spill Suppressor Filters
If you have some slight color spill from the background around the edge of your
foreground subject, you can use the Enhance control of the Chroma Keyer to desaturate
the color spill so that it’s not noticeable.
If you have other regions of color spill that appear within your foreground
subject—showing through a sheer dress, for instance—you may want to use the Spill
Suppressor - Blue or Spill Suppressor - Green filter to selectively desaturate just the key
color so that it’s not noticeable. The spill suppressor filters may affect the overall color of
the foreground subject, however, so you may need to use a color correction filter to
compensate for this effect.
Stage 6: Cropping Out Elements Using the Garbage Matte Filter
If there are “unkeyable elements” other than your foreground subject that you want to
eliminate from the frame, such as props, lighting fixtures, or other undesirable objects,
you can use one of the Garbage Matte filters to remove those elements. For more
information on using Garbage Matte filters, see “Using Mattes to Add or Modify Alpha
Channels.”
Stage 7: Color Correcting the Foreground and Background Clips to Match
Even if you shot your background and foreground clips to match one another, it’s unlikely
the lighting you used matches perfectly. For this reason, it’s usually necessary to color
correct either the foreground subject or the background to make sure the two match.
For more information on color correction in Final Cut Pro, see “Using Color for Color
Correction.”
Tip: When shooting video you intend to composite together using key filters, it’s important
to make sure that the direction of the lighting matches in both the foreground and
background shots. You can color correct for color temperature, relative brightness levels,
and contrast, but lighting direction cannot be altered.
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Stage 8: Performing Additional Adjustments to the Background Layer
Finally, you should spend some time working on the appearance of the background layer.
Editing a foreground clip in front of a background clip is just the beginning. There are
numerous details you must now consider to make the shot look convincing. For example,
the foreground and background of video you shoot in the field are seldom both in focus,
so the shot may look more realistic if you put the background out of focus with a blur
filter.
You may also need to consider other strategies for making the background look suitably
distant, such as adding a translucent gradient layer to create haze over a landscape or
adjusting the appearance of the sky. Adding other keyed foreground elements can also
make your shot look more interesting and add depth to the shot you’re creating.

Working with the Chroma Keyer Filter
Despite its name, the Chroma Keyer actually uses a combination of chroma and luma
keying to achieve a good key. Using the Chroma Keyer, you can create a key using any
range of color you want, including (but not limited to) the usual blue and green. You can
also fine-tune your composite by adjusting the color value, saturation, and luma ranges
used to define your key, together or separately. For example, if you only want to perform
a luma key, you can turn off color and saturation. Even when performing a color key,
you’ll get superior results by manipulating the Color Range and Saturation controls
separately.
The Chroma Keyer filter is available in the Key bin, within the Video Filters bin in the
Effects tab of the Browser. When you add this filter to a clip, a Chroma Keyer tab appears
in the Viewer.

Specifying the Type of Controls to Use for the Chroma Keyer Filter
The Chroma Keyer has a set of visual controls, as well as standard numeric interface
controls. The visual controls are those you’ll probably use most often, but you can switch
between the two.

µ

To use the visual controls
In the Filters tab, click the Visual button next to the Chroma Keyer filter.
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The visual controls appear in the Chroma Keyer tab.

Copy Filter controls
Visual interface of
the Chroma Keyer

Note: The visual controls also include several Copy Filter controls. For detailed information
on these controls, see “Working with the Copy Filter Controls.”
To use the standard numeric controls
Do one of the following:

µ

In the Chroma Keyer tab, click the Numeric button.

In the Chroma Keyer tab,
click this button to use
the standard numeric
controls.
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µ

Click the Filters tab.

Standard numeric
interface of the
Chroma Keyer

Visual Controls in the Chroma Keyer Filter
The following controls appear in the Chroma Keyer tab in the Viewer.
Enable/Disable checkbox
Reset button

Color Range control
Select Color eyedropper
View Final/Matte/Source button
Invert Selection button
Luma control

Sliders for further adjustments
Saturation control

• Enable/Disable checkbox: Make sure there’s a checkmark in this checkbox for the controls
you want to use. This lets you add or remove color, saturation, or luma from the criteria
used to define a key.
• Reset button: Click to restore the Color Range, Saturation, and Luma controls to their
default values. Shift-click the button to reset all three controls at once.
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• Color Range control: Allows you to fine-tune the range of color that you want to key
on.
Top handles

Color gradient

Bottom handles

• Top handles: Let you select a larger or smaller range of colors that are keyed, based on
the original colors you selected with the Select Color eyedropper tool. These handles
correspond to the Width control in the Key on Chroma area of the filter’s numeric
controls.
• Color gradient: Drag left or right within the color gradient to shift the overall hue of
the color range you’ve set with the top set of handles. This corresponds to the Center
On control in the Key on Chroma area of the filter’s numeric controls.
• Bottom handles: Allow you to define the tolerance of your key. These handles correspond
to the Softness control in the Key on Chroma area of the filter’s numeric controls. Use
these handles to gently eliminate additional fringing from your key while attempting
to preserve fine detail around the edges of your foreground subject.
• Saturation control: Allows you to adjust the degree and range of saturation that
contributes to defining your key. The top and bottom handles work the same as those
in the Color Range control. Drag left or right within the gradient to move all four handles
simultaneously.
• Luma control: Lets you adjust the degree and range of luma that contributes to defining
your key. The top and bottom handles work the same as those in the Color Range
control. Drag left or right within the gradient to move all four handles simultaneously.

Select Color eyedropper
View Final/Matte/Source button
Invert Selection button

• Select Color eyedropper: When you click this button, the pointer turns into an eyedropper
you can use to select a color from a clip in the Video tab of the Viewer or in the Canvas.
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Clicking this button and then Shift-clicking with the eyedropper in the Viewer or Canvas
allows you to select another region of the background screen that wasn’t keyed out
by your first use of this control. This broadens the range of colors to be keyed out and
enlarges the keyed-out area. You can do this repeatedly to broaden the range of
keyed-out color to include shadows or highlights on the background screen, if necessary.
• View Final/Matte/Source button (the key): This button has three states: Final, Matte, and
Source.
• Final: The default state (a key against a gray background) lets you see the end result,
the effect happening within the keyed area.
• Matte: The second state (a black key against a white background) displays the key
itself as a grayscale image, so you can fine-tune the key without being distracted by
the image.
• Source: The third state (a key against a blue background) shows only the original
video image.
Important: Before you render or output video using the Chroma Keyer filter, make sure
that the View Final/Matte/Source button is in the Final state.
• Invert Selection button: Click this button to invert the key you’ve defined. For example,
if you’ve set up a key based on the color of a green car and used a grayscale copy of
the clip in the background so that the car is grayscale and the background is color,
clicking the Invert Selection button reverses the key so that you see the car in color
and the background appears in grayscale.
Three sliders at the bottom
of the Chroma Keyer let you
make further adjustments.

• Edge Thin slider: Drag this slider to make the size of the currently defined key larger or
smaller. This can help you remove unwanted edging around your subject.
• Softening slider: Use this slider to blur the edges of your key to make it blend better
with the background image. This can come in handy to soften the jagged edges that
sometimes develop when chroma keying material captured with the DV codec.
• Enhance slider: Adjust this slider to selectively eliminate any spill of the key color that
may be visible in the semitranslucent areas of your key, such as edges and holes.

Example: Using the Chroma Keyer Filter
The following example illustrates a typical use of the Chroma Keyer filter.
To apply the Chroma Keyer Filter
1 Edit the green-screen clip you want to key into the Timeline.
If you wish, you can use a superimpose edit to place the green-screen clip over a clip you
want to use as the background.
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Tip: If you edit the clip into track V2 of the Timeline, you’ll have room to insert another
clip as the new composited background.
2 Apply the Chroma Keyer filter to the green-screen clip you just edited in.
For more information, see “Applying a Filter to a Clip.”
3 In the Timeline, double-click the green-screen clip to open it in the Viewer; then, in the
Viewer, click the Chroma Keyer tab.
Note: In this example, you won’t use the numeric controls that appear in the Filters tab.
4 Click the Select Color eyedropper to pick a color in the clip to key, move the pointer to
the Canvas (it turns into an eyedropper), then click the desired key color. Choose a color
that’s fairly close to the edge of your foreground subject, so that the area near the subject
is the first area of color you key out.
The color range you select with the eyedropper becomes transparent in the clip.

Before clicking with the
eyedropper tool

After selecting the first key color
(not all of the green is keyed out)

Next, you want to expand the keyed area to include regions of the background that
weren’t immediately eliminated by the first key.
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5 Click the Select Color eyedropper, and in the Canvas, Shift-click another region of the
background you want to key out to enlarge the region of transparency.

Before selecting another range of
color with the eyedropper tool

After selecting an additional range
of color

You can perform this step as many times as you need to. The goal is to eliminate as much
of the background as you can without affecting the foreground subject. If you start
encroaching on the outline of your foreground element, you’ve gone too far and should
undo. It is not necessary to remove all the background fringe around your foreground
subject with this step; you should focus only on eliminating the major areas of the
background screen.
Tip: As you key out more and more of the background, you may find it helpful to use a
different background in the Canvas. The Checkerboard 1 and 2 backgrounds may make
it easier to see fringing areas of your picture that aren’t yet keyed out. You can also use
other background shades and colors to compare the key effect against a lighter
background.
6 If necessary, adjust the Color Range, Saturation, and Luma controls to remove more of
the key color from the background and eliminate more fringing from the foreground
layer without affecting the foreground subject.
The top handles adjust the overall range of hue, saturation, or luma keyed out, while the
bottom handles blur the difference between the range of color that’s keyed and the range
of color that isn’t.
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Note: You should remove the majority of the green screen using the top handles, but
stop at the point where there’s still some fringing around the areas of fine detail in the
foreground subject. This is the point where you should start using the bottom handles
to expand the keyed area more softly. It is not important, at this point, to completely
eliminate this fringing, only to make sure that it’s soft and translucent, rather than pixelated
and solid.
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7 Depending on how the edges of your foreground subject look, you may want to make
adjustments using the Edge Thin slider. The Edge Thin slider allows you to shrink the
alpha channel created by the Chroma Keyer to begin to eliminate the light fringing that
remains around the edges of the foreground subject.

Before adjusting
the Edge Thin slider

After dragging the
Edge Thin slider to
the right

8 An optional step at this point is to use the Softening slider to blur the edges of the
foreground subject. This is especially helpful if the edges of your foreground subject look
rough because of compression artifacts that appear as blocky edges around your
foreground subject. Don’t overdo this adjustment, as you could start to lose details in the
subject that you’re trying to preserve.

Before adjusting the
Softening slider

After dragging the Softening slider
slightly to the right
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9 If you still see light fringing at this point, or if you were forced to use settings so extreme
in the Chroma Keyer that some of your foreground subject was eaten away around the
edges, apply the Matte Choker filter. After you apply the Matte Choker filter, adjust the
Matte Choker’s Edge Thin and Edge Feather sliders. This is the point where you should
work to eliminate all the background fringing.
Moving the Edge Thin slider to the right further shrinks the alpha channel around the
foreground subject, eliminating still more fringing. Moving the Edge Thin slider to the
left expands the alpha channel, allowing you to replace areas of the foreground subject
that were lost. The Edge Feather slider allows you to blur the edges even further, if
necessary.
10 If you’re satisfied with your key, but there is some color from the background that is
spilling onto the edges of your foreground subject, go back to the Chroma Keyer tab in
the Viewer and adjust the Enhance slider to desaturate this spill so that it’s not noticeable.
Don’t move the Enhance slider too far, or you may get undesirable coloration in the edge
of your subject.
11 If there’s still more colored spill on your foreground subject that the Enhance slider didn’t
eliminate, apply the Spill Suppressor filter.
The Spill Suppressor filter desaturates color spill that may appear anywhere on the
foreground subject, not just on the edges. For example, a little of the background color
may show through translucent areas of the foreground subject, such as wispy hair or
sheer clothing. Once you’ve applied the Spill Suppressor filter to your keyed clip, adjust
the Amount slider to determine how much to desaturate the spill color in the foreground
image.
12 To eliminate any unwanted elements that didn’t get keyed out, such as rigging and lights
around your subject or the edge of the blue or green screen itself, use the Crop parameter
controls in the Motion tab of the foreground clip to cut those elements out of the picture.
If the area you need to crop is irregular, you can apply a Garbage Matte filter, instead.

The image is cropped
on both sides to remove
extraneous elements.
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13 Finally, you’re ready to insert the background image. Make sure that the clip you’re editing
into your sequence to use as the background image appears in a video track below the
foreground clip being keyed.

The background image
now appears.

The background image
is placed below the
foreground clip that
was keyed.

14 To really make the foreground and background look as if they were shot together, it may
be necessary to perform additional compositing steps such as blurring the background
to make it look out of focus, color correcting the foreground subject to have the same
color temperature as the background, or using motion effects to move the foreground
subject. Even with a successful key, these are the details that make a composite look like
a finished shot.
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Using Mattes to Add or Modify Alpha Channels
You can use the matte filters to create a new alpha channel or add to or subtract from a
clip’s existing alpha channel. Matte filters work equally well with clips that already have
an alpha channel and with clips that have alpha channels created using a key filter, such
as the Chroma Keyer.

Matte Filters Available in Final Cut Pro
There are three matte filters used most often in conjunction with the Chroma Keyer:
• Eight-Point Garbage Matte: Use this filter to create an eight-point polygonal matte. This
is useful for cropping out unwanted elements surrounding a foreground element with
a complex shape.
• Four-Point Garbage Matte: Use this filter to create a simple four-point polygonal matte.
This simplifies the process when the shape you want to remove can be encompassed
in four points.
• Matte Choker: Use this filter to eliminate any faintly remaining blue or green fringing
or pixels surrounding the edge of your foreground subject. Instead of simply shrinking
the size of the blue-screen clip’s alpha channel, however, which might result in the
accidental elimination of part of your foreground subject, the Matte Choker selectively
shrinks only those parts of the layer’s alpha channel that have a marginal degree of
transparency, such as barely keyed-out blue or green fringing.
Note: Instead of relying solely on the feathering and edge thinning controls of the
Chroma Keyer filter, you should allow some fringing when you adjust the Chroma
Keyer’s settings, so that you can more precisely eliminate fringing with the Matte Choker.

Example: Using the Four-Point Garbage Matte Filter
The following example illustrates how to use the Four-Point Garbage Matte filter to
eliminate the outside edges of a clip being keyed.
To use the Four-Point Garbage Matte Filter
1 Apply the Four-Point Garbage Matte to the clip being keyed. Open this clip in the Viewer,
then click the Filters tab.
It may be easier to see what you’re doing if you turn off the Chroma Keyer, Matte Choker,
and Spill Suppressor filters first.
2 In the Four-Point Garbage Matte filter, click the Point 1 point control.
Click the Point 1 point
control to start changing
the matte.
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3 Move the pointer to the Canvas (the pointer turns into a crosshair pointer), then click to
change the location of the matte corner defined by Point 1.

Before changing the location
of the first point

After changing the location
of the first point

4 Repeat steps 2 and 3 for the Point 2, Point 3, and Point 4 point controls, until you’ve
created a box that crops out everything outside the green screen surrounding the actor.
5 To round the four corners of the matte, adjust the Smooth slider, if necessary.

The matte, with rounded
corners

6 If necessary, adjust the Choke and Feather sliders.
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The Choke slider adjusts the overall size of the matte, without changing the shape; the
Feather slider blurs the edges of the matte.

The finished matte image

The parameters of the Garbage Matte filters can be keyframed, in the same way as the
parameters of any other filter. This can come in handy if you need to use one of the
Garbage Matte filters to crop out the outside edge of a green screen in a shot where the
camera is panning.

Example: Keyframing Garbage Mattes
In the following example, two sets of keyframes are created to compensate for a simple
pan in the clip being keyed.
To keyframe Garbage Mattes
1 With the playhead on the first frame of a clip, apply and adjust the Four-Point Garbage
Matte filter.
For more details about using this filter, see “Example: Using the Four-Point Garbage Matte
Filter.”
2 Once you’ve created the proper shape for the first frame of the clip, click the keyframe
buttons for the Point 1, Point 2, Point 3, and Point 4 parameters.

Create keyframes for
all four points.

Click keyframe buttons
to create keyframes.
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3 Move the playhead to the last frame of the clip, then readjust the Point 1, Point 2, Point
3, and Point 4 point controls to fit the new position of the green screen.

Create keyframes for all
four points.

Click point controls
to make an adjustable
crosshair appear in
the Viewer or Canvas.

Keyframes are created automatically when you make these adjustments. The change of
the matte’s shape and position is calculated for each frame in between the two sets of
keyframes you’ve created. If the motion of the camera is consistent, the position of the
matte should follow the position of the background screen. If the motion of the camera
is inconsistent, you can create more keyframes to adjust the shape and position of the
four matte points as necessary.

Using Masks to Replace or Modify Alpha Channels
The mask filters allow you to replace, contract, or expand a clip’s alpha channel. If a clip
has no alpha channel, a new one can be assigned to it using a still image or an alpha
channel copied from another clip.

Mask Filters Available in Final Cut Pro
There are several mask filters you can use to modify alpha channels in a clip:
• Mask Feather: Lets you selectively feather the edge of just the alpha channel of a clip,
making it softer, without blurring the image channels of the clip. The Mask Feather
filter works with other filters that generate alpha channel information, allowing you to
feather the edge of a mask created with the Mask Shape filter, for example.
• Image Mask: Uses the luma or alpha channel in one clip to create an alpha channel in
another. The clip used to create the alpha channel can be a still image or a QuickTime
movie. Using the Image Mask filter, you can create complex alpha channels; for example,
you can put the kind of rough border used in art photography around a video clip. The
alpha channel created with the Image Mask filter can be inverted, if necessary.
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• Mask Shape: Allows you to create an alpha channel in a clip that consists of a simple
shape—a diamond, oval, rectangle, or round rectangle. The solid part of the clip that
remains after applying the Mask Shape filter appears inside the shape that’s been
created. The vertical and horizontal scale of the shape can be altered, as can the mask’s
center. The Mask Shape filter can also be inverted to reveal areas of the clip outside
the shape.
• Soft Edges: Allows you to feather the edges of a clip. You can extend the softening of
the left, right, top, and bottom edges of the clip into the clip by different amounts. The
feathering appears as a gradient that always extends to the edge of the clip. The Soft
Edges filter overrides all other alpha channel information created by any other filters
appearing before it.

Example: Using the Image Mask and Mask Feather Filters
In the following example, a still image is used to create an alpha channel in another clip.
To use the Image Mask and Mask Feather Filters
1 Open the clip to be masked in the Viewer.
2 Choose Effects > Video Filters > Matte > Image Mask.
3 Click the Filters tab in the Viewer.

This example uses a
grayscale TIFF file, called
Border.tif, that has a
white center surrounded
by a rough black border.

4 Drag the Border.tif clip to the Mask clip well of the Image Mask filter.

Drag the clip to the
clip well.

5 Choose Luminance from the Channel pop-up menu.
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Note: When using a clip’s luma to define transparency, white is used for 100 percent
opacity, and black is used for 100 percent transparency.

The clip now has a
border that matches
the Border.tif clip.

You can further modify this new alpha channel, blurring it with the Mask Feather filter,
for example.
6 Choose Effects > Video Filters > Matte > Mask Feather to apply the Mask Feather filter to
the clip you want to blur.
7 Open this clip in the Viewer, then click the Filters tab.
8 In the Filters tab, drag the Mask Feather filter so it appears below any other filters that
may be creating or modifying the clip’s alpha channel (such as the Image Mask filter that’s
already been applied).
9 Adjust the Soft slider to soften the edge of the clip’s alpha channel.

The clip’s image remains
untouched.
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Using Generator Clips

73

This chapter covers the following:
• What Is a Generator Clip? (p. 1249)
• Different Ways to Use Generators in Your Sequence (p. 1249)
• Video and Audio Generators Available in Final Cut Pro (p. 1250)
• Creating and Adding Generators to Sequences (p. 1255)
Final Cut Pro can generate several types of clips for you to use in your sequences, including
bars and tone, placeholders, and backgrounds.

What Is a Generator Clip?
Generators behave the same as other clips, but their content is actually generated internally
in Final Cut Pro. Generators never refer to media files on the scratch disk, so they can
never be offline as can clips that refer to media files. Because generators are generated
by Final Cut Pro, their aspect ratio, dimensions, resolution, and codec are determined by
the sequence they are edited into (unlike video and audio clips, in which these
characteristics are based on the media files they refer to).

Different Ways to Use Generators in Your Sequence
In creating composites and other effects, you may find some of the Final Cut Pro generators
helpful. They allow you to very quickly add certain types of built-in clips by simply choosing
items from a menu. For example, by choosing a generator, you can:
• Add clips that have certain shapes to use as design elements, or as layers when creating
track matte effects
• Create colored and gradient background layer clips for composites
• Add a placeholder or black gap between two clips, called a slug
• Add standard SMPTE color bars and tone to use as a reference (for duplication or
broadcast purposes) or as an effect
• Create shape layers and use them to create track matte effects
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Some generators, such as the Slug, Matte, and Particle Noise generators, fill the entire
frame size of your sequence. Others, like the text filters, are created with an alpha channel
that allows your text to be quickly superimposed against an image, or against black. (See
“Creating Titles” for information about text generators.)
Generators can have filters and motion settings applied to them. For example, you can
use a Color Matte filter in conjunction with a Garbage Matte or Mask Shape filter to quickly
create a clip consisting of a shape against a transparent background. The transparent
background exists because an alpha channel has been added to the Color Matte filter.
For more information on using Matte and Mask filters, see “Keying, Mattes, and Masks.”
The parameters of some generators can be keyframed to change their appearance over
time. You add keyframes to generators in the same way you add keyframes to motion
settings and filters. For more information about how to create keyframed effects in
Final Cut Pro, see “Animating Motion Effects Using Keyframes.”

Video and Audio Generators Available in Final Cut Pro
Final Cut Pro supports both FXScript and FxPlug generators. The following tables explain
the generators available in Final Cut Pro.

Color Bars, Tone, and Other Signal Generators
You use color bar and signal generators for calibration and testing purposes. Each Bars
and Tone generator uses the image dimensions and color space intended for a particular
video system. For more information, see “Measuring and Setting Video Levels.”
Generator

Result

Bars and Tone (PAL)

Generates reference color bars and audio tone for PAL systems.

Bars and Tone (PAL Full Frame)

Generates full-frame reference color bars and audio tone for PAL
systems.

Bars and Tone (HD 1080i60)

Generates reference color bars and audio tone for 1080i60 video
systems.

Bars and Tone (HD 1080 25p/50i)

Generates reference color bars and tone for 25 or 50 fps HD video
systems.

Bars and Tone (HD 1080 25p/50i
Full Frame)

Generates full-frame reference color bars and tone for 25 or 50 fps
HD video systems.

Bars and Tone (HD 720p60)

Generates reference color bars and tone for 720p HD video systems.

More Bars and Signal

Generates test signals for external video calibration.

Matte Color and Slug
You use the Color and Slug generators to create colored backgrounds or black.
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Generator

Result

Usage information

Color (From the
Generator popup menu,
choose Matte > Color.)

Generates a frame of
solid color.

• The color controls allow you to specify the color.
• You can create colored backgrounds behind
other layered clips in a sequence.
• Color mattes can be used as containers for
special effects filters that create visual images.
In conjunction with filters such as Mask Shape,
they can be used to create different shapes as
design elements or as track matte layers.
• Other interesting effects can be obtained by
limiting these generators to shades of gray and
using them with the track matte composite
mode, or with filters that perform luma key
operations.

Slug

Generates a video clip
consisting of a black
image with an empty
pair of audio tracks.

• Slug is used primarily as a placeholder in areas
of your edit where you want to keep a gap
between two clips.

Render
You can use the Render generators to create backgrounds filled with gradient shades of
color or grays.
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Generator

Result

Usage information

Custom Gradient (From the
Generator popup menu, choose
Render > Custom Gradient.)

Generates a gradient layer that
you can customize.

• A pop-up menu allows you to
specify a linear or radial
gradient.
• The Start control allows you
to set the point in the frame
where the gradient begins.
• The Gradient Direction Angle
control defines the gradient's
direction, and a slider controls
the gradient's width.
• Two color controls let you
define the start and end
colors of the generated
gradient.
• The Dither and Gaussian
checkboxes allow you to
modify the quality of the
gradient you create.

Gradient (From the Generator
popup menu, choose Render >
Gradient.)

Generates a predefined gradient
based on a direction you choose
from the Gradient Type pop-up
menu.

• You can adjust the start and
end colors of the gradient
using color controls.
• The Dither and Gaussian
checkboxes allow you to
modify the quality of the
gradient you create.

Highlight (From the Generator
popup menu, choose Render >
Highlight.)

Generates a simulated specular
highlight band.

• The Center point control
determines the location of the
highlight, and the Highlight
Angle control defines its
angle. You can adjust the
width and softness of the
highlight with two sliders, and
the highlight and background
colors with color controls.
• The Dither and Gaussian
checkboxes allow you to
modify the quality of the
gradient you create.

Noise (From the Generator
popup menu, choose Render >
Noise.)

Generates random pixel noise,
similar to static.
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Generator

Result

Usage information
• The random noise can be
adjusted to appear in varying
levels across every channel of
the clip, including the alpha,
red, green, and blue channels,
using the appropriate slider
controls.
• You can animate the noise
with the Random checkbox
and create color static with
the Color checkbox.
• A Noise generator, when
superimposed over a video
image with a very low opacity
level, can be used to simulate
gain, similar to a film image
or clip shot with a video
camera whose gain is turned
all the way up.

Lens Flare (From the Generator
pop-up menu, choose Render >
Lens Flare.)

Reproduces the look of a lens
flare of light hitting a camera
lens. By adjusting its controls,
you can create the effect of a
lens flare in a specific location
and with different intensities and
colors.

Particle Noise (From the
Generator popup menu, choose
Render > Particle Noise.)

One of the more graphical
generators in Final Cut Pro. The
Particle Noise generator, unlike
the Noise generator, creates
random patterns of different
shapes. By adjusting its controls,
you can create all kinds of
effects.
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• You can adjust the Center
options to set the location of
the lens flare.
• You can adjust the Size slider
to set how large the shapes
are.
• You can set different colors
for four different aspects of
the flare.
• The Streak sliders let you you
set the number and
characteristics of the streaks
in the flare.
• The Ring controls allow you
to specify the characteristics
of the rings seen in the flare.
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Generator

Result

Usage information
• You can adjust the Size slider
to set how large the shapes
are.
• The Shape pop-up menu
allows you to choose what
shape to use (circle, square,
diamond, or random).
• The Soft slider lets you blur
the edges around these
shapes, and the Density slider
lets you adjust how many are
on the screen, evenly
distributing them across the
frame.
• The color controls allow you
to specify the color of the
shapes, and a Random Color
checkbox gives you the
option to make them all
different.
• The Time Lapse slider lets you
adjust the apparent frame
rate of the particle animation.

Note: When you use the Lens Flare generator, be sure to select the generator clip in the
Timeline and set the Composite mode to Add in order to make the lens flare appear
transparent on the background clip.

Shapes
You can use the Shape generators to create shapes of different colors and sizes that can
appear in backgrounds.
Generator

Result

Usage information

Shapes (From the Generator
pop-up menu, choose Shapes,
then choose the shape you want
from the submenu.)

Generates a circle, oval,
rectangle, or square, depending
on what you choose.

You can change the size, aspect,
edge softness, and color of each
shape.

•
•
•
•

Circle
Oval
Rectangle
Square

Text
You can create a variety of text titles, credits, and other types of text labels using the text
generators.
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Generator

Result

Usage information

Text (From the Generator
pop-up menu, choose Text, then
choose the type of text you want
from the submenu.)

Generates text for titles, credits,
and so on.

For more information, see
“Creating Titles.”

•
•
•
•
•
•

Crawl
Lower 3rd
Outline Text
Scrolling Text
Text
Typewriter

FxPlug Generators
When you install Motion, additional FxPlug generators are available in Final Cut Pro. For
details on generators included with Motion, see the Motion User Manual, available in
Motion Help.

Creating and Adding Generators to Sequences
All the Final Cut Pro generators can be accessed either from the Effects tab of the Browser
or from the various submenus of the Generator pop-up menu in the Viewer. This pop-up
menu is available when the Video or Audio tab is displayed in the Viewer. When you
choose a generator, it appears in the Video tab of the Viewer.
Note: With the exception of the Bars and Tone generators, generators always adopt the
frame size of the sequences they're edited into.
To create a generator and add it to a sequence
1 Do one of the following:
• Click the Video or Audio tab in the Viewer, then choose a generator from the Generator
pop-up menu.

Some generators
have submenus with
additional choices.

• In the Effects tab of the Browser, double-click a video generator.
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2 Click the Controls tab to view that generator’s parameters, and adjust the controls to suit
your purposes.
Click the Controls tab to
show the parameters of
the generator.

All generators have certain parameters that can be used to customize their effects. see
“Video and Audio Generators Available in Final Cut Pro” for more information. The most
basic controls, such as keyframe and Reset buttons, are the same as those for other effects
discussed in “Viewing and Adjusting a Filter’s Parameters.”
3 When you’ve finished adjusting the parameters, click the Video or Audio tab.
From the Viewer, you can now edit the currently open generator into your sequence, the
same as any other clip.
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Using the SmoothCam Filter

74

This chapter covers the following:
• About the SmoothCam Filter (p. 1257)
• Working with the SmoothCam Filter (p. 1258)
• Managing Media and Motion Analysis Data (p. 1268)
• Improving SmoothCam Filter Results and Troubleshooting (p. 1268)
You can smooth the motion of handheld and shaky shots by applying the SmoothCam
filter.

About the SmoothCam Filter
The SmoothCam filter reduces unwanted camera movement from your footage, such as
less-than-stable crane or jib arm moves, teetering from handheld walking shots, or
vibrations in automotive shots.

How the SmoothCam Filter Works
Unlike other filters in Final Cut Pro, the SmoothCam filter must analyze a clip’s entire
media file before the effect can be rendered or played in real time. Using the SmoothCam
filter requires two independent phases:
• Motion analysis: Pixels in successive frames are analyzed to determine the direction of
camera movement. Analysis data is stored on disk for use when calculating the effect.
• Motion compensation: During rendering or real-time playback, the SmoothCam filter
uses the motion analysis data to apply a “four-corner” transformation to each frame,
compensating for camera movement.

About Queuing and Background Processing
When you apply the SmoothCam filter to a clip, the clip is automatically submitted to the
SmoothCam Analysis processing queue, where motion analysis data is generated. The
processing queue analyzes clips in the order they are received. When analysis for one clip
in the queue is completed, analysis for the next clip begins, allowing you to submit
multiple clips at one time. A clip’s entire media file is analyzed, regardless of clip In and
Out points.
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The processing queue is a background process, which means that you can continue to
work in Final Cut Pro while your computer analyzes clips in the background. Background
processing takes over some of your computer’s processing power, so Final Cut Pro
automatically pauses the queue during playback, capture, and output. You can also
manually pause the queue when performing processor-intensive operations.
Using the SmoothCam Browser column, you can submit clips to the processing queue
without applying the SmoothCam filter. This is useful when you have a large number of
clips you want to analyze in preparation for using the SmoothCam filter.

Where Is Motion Analysis Data Stored?
By default, SmoothCam motion analysis data for a clip is stored in the same location as
the media file. However, if you do not have writing privileges to the folder where your
media is stored, motion analysis files are stored here:
• /Library/Caches/com.apple.fxmd/

Working with the SmoothCam Filter
The following sections cover the basic steps for using the SmoothCam filter.

Applying the SmoothCam Filter
The SmoothCam filter is available in both the Effects tab and the Effects menu in the
Video category. You can apply the SmoothCam filter to the current clip in the Viewer or
to one or more clips in a sequence.

µ

To apply the SmoothCam filter to a clip in the Viewer
Make sure the Viewer is the active window, then choose Effects > Video Filters > Video
> SmoothCam.

µ

To apply the SmoothCam filter to clips in the Timeline
Select one or more clips in the Timeline, then choose Effects > Video Filters > Video >
SmoothCam.
Each clip with the SmoothCam filter applied is submitted to the SmoothCam Analysis
processing queue. The Background Processes window opens and analysis begins
automatically on the first clip in the queue.
Note: The SmoothCam filter can be applied only to clips that refer to QuickTime media
files. Also, the SmoothCam filter compensates only for the original video within a
QuickTime media file; the results of filter and motion parameter settings are ignored.
Make sure filters applied to a clip are ordered so that the SmoothCam filter is applied
first.
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About Motion Analysis States
A clip’s motion must be analyzed before you can see the results of the SmoothCam filter.
You can monitor the progress of motion analysis in several locations and even stop
analysis if you need to free up computer processing power.
A clip can have one of four analysis states:
• Unanalyzed: The clip requires analysis but has not yet been analyzed for some reason.
For more information, see “Making Sure Clips Are Analyzed.”
• Analyzing: The clip is currently being analyzed in the processing queue.
• Queued for analysis: The clip has been submitted to the processing queue but has not
yet been analyzed.
• Analysis completed: The clip has a completed motion analysis file on disk.

Checking Motion Analysis Status
You can check a clip’s motion analysis status in four locations:
• Overlays in the Canvas or Viewer
• The Background Processes window
• The SmoothCam Browser column (and the SmoothCam property in the Item Properties
window)
• The empty area in the lower-left part of the Viewer Filters tab, to the right of the Current
Timecode field
Overlays in the Canvas or Viewer
An overlay in the Canvas or Viewer displays the current clip’s motion analysis status. When
analysis is complete, the status overlay for the clip is no longer displayed.

Status overlay
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The Background Processes Window
The Background Processes window displays the name, queue number, and progress of
motion analysis for each clip in the processing queue. To display the Background processes
window, choose Tools > Background Processes.
Stop button

Pause/Resume button

Number of clips in the
processing queue

The SmoothCam Browser Column
The SmoothCam clip property can be shown in a Browser column, displaying each clip’s
motion analysis status. The SmoothCam Browser column also allows you to submit clips
to the processing queue even if your clips don’t have the SmoothCam filter applied.

To display the SmoothCam Browser column in the Browser, Control-click in any column,
then choose SmoothCam from the shortcut menu.
You can also view the SmoothCam property in the Item Properties window. To display
the SmoothCam property in the Item Properties window, select a clip in the Browser or
Timeline, then choose Edit > Item Properties > Format (or press Command-9.)

Starting and Stopping SmoothCam Motion Analysis
If you want to free up processing power to work on other things, you can stop motion
analysis or temporarily pause analysis and then resume it again later. You can also submit
clips to the processing queue, regardless of whether the SmoothCam filter is applied to
them.
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To remove clips from the SmoothCam Analysis processing queue
1 Make sure the SmoothCam column is shown in the Browser.
2 Select one or more clips in the Browser.
3 Control-click in the SmoothCam column next to one of the selected clips, then choose
Stop Analysis from the shortcut menu.
Analysis for all selected clips is stopped. Analysis begins on the next clip in the queue.
Note: Motion analysis is applied to media files, not clips. Therefore, deleting a clip doesn’t
stop motion analysis for its media file.
To submit clips to the SmoothCam Analysis processing queue
1 Make sure the SmoothCam column is shown in the Browser.
2 Select one or more clips in the Browser.
3 Control-click in the SmoothCam column next to one of the selected clips, then choose
Run Analysis from the shortcut menu.
To stop motion analysis for all clips in the processing queue
1 In the Background Processes window, click the Stop button next to the progress bar.
A dialog appears asking if you are sure you want to stop analysis for all clips in the
processing queue.
2 Click Stop Task.
Incomplete motion analysis files are deleted if you stop analysis, so when you submit a
clip for analysis later, the whole clip is analyzed from the beginning.

µ

To temporarily pause motion analysis
In the Background Processes window, click the Pause/Resume button.

µ

To resume paused motion analysis
In the Background Processes window, click the Pause/Resume button.
Note: Quitting Final Cut Pro also stops the processing queue.

Analyzing All SmoothCam Clips in a Sequence
Sequence clips with the SmoothCam filter applied must be analyzed before you can see
the results of the filter. There are several ways to analyze sequence clips:
• Render a selected clip or the entire sequence: All analyzed clips are rendered, and any
unanalyzed clips are automatically submitted to the processing queue. Any clips whose
motion analysis was not complete when you started rendering are not rendered, so
you may need to render the sequence again when the remaining clips are analyzed.
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• Analyze all clips in a sequence using the SmoothCam Browser column: Sequences have a
SmoothCam property just as individual clips do. However, a sequence’s SmoothCam
property controls motion analysis for all unanalyzed clips in the sequence. Control-click
in the SmoothCam column next to the sequence whose clips you want to analyze, then
choose Run Analysis from the shortcut menu. Any sequence clip that uses the
SmoothCam filter and still needs analysis is analyzed.

Reanalyzing Clips
If necessary, you can reanalyze a clip whose status is “Analysis completed.”
To analyze a clip that already has a completed motion analysis file
1 Make sure the SmoothCam column is shown in the Browser.
2 Select one or more clips in the Browser.
3 While pressing the Option key, Control-click in the SmoothCam column next to one of
the selected clips, then choose Run Analysis from the shortcut menu.

Reprioritizing Clips in the Processing Queue
If you want to analyze a particular clip before others in the processing queue, you need
to remove any motion analysis jobs currently in the queue and then add the clip you
want to analyze.
To analyze a clip before others already in the processing queue
1 In the Background Processes window, click the Stop button next to the progress bar.
All clips are removed from the processing queue.
2 In the Browser, Control-click in any column, then choose SmoothCam from the shortcut
menu.
3 Control-click in the SmoothCam column next to the clip you want to analyze, then choose
Run Analysis from the shortcut menu.
To analyze sequence clips before other clips in the processing queue
1 In the Background Processes window, click the Stop button next to the progress bar.
All clips are removed from the processing queue.
2 Select and render the current sequence clip or the entire sequence.
Rendering unanalyzed clips with the SmoothCam filter applied automatically adds the
clips to the processing queue.
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Adjusting SmoothCam Filter Parameters
You can adjust controls for the SmoothCam filter in the Filters tab in the Viewer, just as
you would adjust parameters for any other filter. However, you cannot add keyframes to
SmoothCam filter parameters.

Scale parameters

Camera Motion
Smoothness parameters

Analysis status

About SmoothCam Filter Parameters
The SmoothCam filter parameters allow you to adjust how much camera movement the
filter compensates for and how much automatic zooming the filter applies to remove
black borders resulting from motion compensation.
Scale Parameters
You can also set Auto Scale and Actual Scale parameters:
• Auto Scale: This parameter can reduce the amount of automatic scaling applied by the
SmoothCam filter. For more information, see “Using the Auto Scale Parameter.”
• Actual Scale: This parameter is not adjustable. The value shown here is the amount of
scaling the SmoothCam filter applies to compensate for any black borders caused by
the Camera Motion Smoothness parameter settings. For more information, see “About
the Actual Scale Value.”
Camera Motion Smoothness Parameters
You can control the “steadiness” of your shot using three independent parameters:
• Translation Smooth: Left, right, up, and down movement of a shot (x and y axes)
• Rotation Smooth: Rotation around the center point of the image
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• Scale Smooth: Forward or backward camera or lens movement (z axis)
x

x

x
z

y

Translation

y

Rotation

y

Scale

Each parameter can be set to a value between 0.0 and 5.0. A value of 0.0 turns off the
parameter, and a value of 5.0 applies the strongest possible transformation. The higher
you set each parameter, the more camera motion is compensated for in that axis.
For example, if you want to remove horizontal, vertical, and rotational movement, you
should set the Translation Smooth and Rotation Smooth parameters to a value above 0.
You may need to experiment to see which values steady your shot the best.
Correcting Black Borders Around Your Clip
When the SmoothCam filter compensates for camera movement, it translates, rotates, or
scales your clip in the opposite direction, potentially causing a black border around the
edge of the clip in the Canvas. To correct for the black border, the SmoothCam filter
determines which frame in your clip requires the most scaling to remove the black borders
and then automatically scales the entire clip by that amount.

Black border

Black border

Factors That Affect SmoothCam Scaling
You can control how much the SmoothCam filter scales your clip in several ways,
depending on the effect you are trying to achieve:
• Reduce the Translation Smooth, Rotation Smooth, and Scale Smooth parameter values
so that less motion correction is applied. This means that there is less black around
your clip, so less scaling is required. Try to adjust these parameters to find a balance
between acceptable scaling and adequate motion compensation.
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• Change your clip In and Out points to limit the SmoothCam filter to a portion of the
clip without abrupt visual changes or severe camera movement. This reduces the
amount of motion compensation that the SmoothCam filter needs to apply, so less
scaling is required. For more information, see “Setting Clip In and Out Points to Improve
SmoothCam Rendering.”
• Reduce the Auto Scale parameter value to reduce scaling. Reducing the amount of
scaling will reveal black edges around your clip, but this may be acceptable in some
cases. For more information, see “Using the Auto Scale Parameter.”
About the Actual Scale Value
Too much scaling can cause your clip to appear blocky or softened, so you should try to
limit scaling of your clip as much as possible. The Actual Scale value in the SmoothCam
filter informs you of the current scaling applied to your clip. The value shown here is the
result of many factors: the amount of motion compensation the SmoothCam filter needs
to apply based on the motion analysis data, the current In and Out points, and the current
value of the Auto Scale parameter.
Important: If the SmoothCam filter requires a very large repositioning adjustment to
compensate for camera movement, the SmoothCam filter does not apply motion
compensation at all, and the Actual Scale parameter is turned off. In these cases, your
clip probably contains too much movement or too many abrupt visual changes. For more
information, see “Improving SmoothCam Filter Results.”
Using the Auto Scale Parameter
In some cases, you may prefer to reduce the automatic scaling that the SmoothCam filter
applies by lowering the value of the Auto Scale parameter. For example, you may want
to reduce scaling if:
• You know your project will be shown only on overscan monitors, so you don’t care
what’s outside of the action safe area
• You’re going to composite this clip beneath other elements, so you plan to crop the
edges anyway
• You are applying the SmoothCam filter to HD footage within an SD sequence, so you
still have plenty of leftover pixels at the edges
By default, the Auto Scale parameter is set to 1, which means the SmoothCam filter applies
the minimum scaling necessary for the clip to appear without black edges in the Canvas.
Reducing the Auto Scale parameter to a value less than 1 reduces the amount of scaling,
revealing black around the edges of the clip.
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Setting Clip In and Out Points to Improve SmoothCam Rendering
The results of the SmoothCam filter are determined by the media between a clip’s In and
Out points, so abrupt visual changes in your clip’s media may cause poor SmoothCam
filter results. You can avoid abrupt visual changes in a clip by setting clip In and Out points
to a visually stable portion of media. An easy way to define a visually stable portion of
media is to cut a single clip into smaller clips and remove segments with unwanted
movement.
Note: The SmoothCam Analysis processing queue always analyzes your clip’s entire media
file (including subclips), regardless of the In and Out points set.
Here are some cases where adjusting clip In and Out points may improve your SmoothCam
results:
• If a large object moves across the frame of an otherwise stationary shot, such as a
person walking close to the front of the camera
• Excessive camera movement during shot setup
• Large camera movement in a clip that is otherwise relatively stationary
• Clips with more than one scene, such as clips with multiple takes
For example, if your footage starts with a fast pan and then settles into a relatively stable
shot, set the clip In point after the pan is finished. Similarly, if a person walks into the
frame and blocks the camera, set an Out point in your clip before the person appears.
Remove the rapid
camera pan here.

Remove the person
blocking the camera here.

Avoiding Through Edits
Setting clip In and Out points can improve SmoothCam filter results by avoiding abrupt
visual changes, but adding a through edit to a clip with the SmoothCam filter applied
can create a jump at the edit point. For example, if you apply the SmoothCam filter to a
clip and then use the Razor Blade tool to cut that clip into two clips, the SmoothCam
filter results on each clip are different because they are based on different clip In and Out
points. This means that each clip will likely have different motion compensation applied,
and you will see this difference as a jump at the through edit point.
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Using QuickTime Reference Movies to Limit Clip Analysis
One way to limit which frames are analyzed is to create QuickTime reference movies that
contain only the portion of the clip you want to analyze.
To apply the SmoothCam filter to 20 seconds of a 15-minute clip
1 Open a clip in the Browser and set its In and Out points so the duration is 20 seconds.
2 Choose File > Export > QuickTime Movie.
3 In the Save dialog, enter a name for the QuickTime movie in the Save As field.
4 Choose Current Settings from the Settings pop-up menu.
5 Choose Audio and Video from the Include pop-up menu.
6 Make sure that the Make Movie Self-Contained checkbox is deselected.
7 Click OK.
8 Import the QuickTime reference movie you just created, then apply the SmoothCam filter
to the clip.
9 Only the media defined by the QuickTime reference movie is analyzed in the processing
queue.
For more information about exporting QuickTime movies, see “Exporting QuickTime
Movies.” You can also see “Batch Exporting Clips and Sequences.”

Rendering and Exporting Clips with the SmoothCam Filter Applied
Once the processing queue has finished analyzing a clip, you can render the clip to see
the finished effect. Clips that have the SmoothCam filter applied and whose motion
analysis files are not complete will not be rendered. If you need to make changes, adjust
the necessary SmoothCam filter parameters and render the clip again. If your computer
has sufficient processing power, you may be able play these clips in real time, especially
if you choose Unlimited RT mode.
If you try to export or use the Print to Video or Edit to Tape commands on a sequence
containing clips with incomplete motion analysis data, a window appears with three
options:
• Cancel: Cancels the Edit to Tape or Print to Video operation.
• No: Renders the SmoothCam filter only for clips whose motion analysis data is complete
and then continues with the export or output process.
• Yes: Processes any clips whose motion analysis data is not complete and then continues
with the output process.
Note: Clips with the SmoothCam filter applied may have a red render status bar when
you turn on Digital Cinema Desktop Preview, requiring you to render your clips before
playback.
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Managing Media and Motion Analysis Data
If you use the Media Manager QuickTime export commands with sequences or clips using
the SmoothCam filter, motion analysis data may not be retained.

Using the Media Manager
The Media Manager does not manage SmoothCam motion analysis files. Here are some
guidelines for using the Media Manager with clips that have the SmoothCam filter applied:
• If you choose the Copy operation in the Media Manager window, motion analysis files
are not copied with the rest of the media.
• If the Media Manager trims your media files to make them shorter, existing motion
analysis files cannot be used, so you will need to analyze these clips again.
• If you recompress a clip to another format, your motion analysis files will need to be
regenerated.

Modifying QuickTime Source Files
Whenever a media file’s modification date changes, a new motion analysis file must be
generated. A media file’s modification date can change when:
• You modify and save the file in QuickTime Player
• You use the Modify Timecode command to change timecode tracks stored in the media
file
• You change the reel name
• You recapture the clip (in this case, a new media file is created)
• You change a clip’s media file name by choosing Modify > Rename > File to Match Clip

Transferring SmoothCam Motion Analysis Data to Motion
You can retain the SmoothCam filter when sending clips from Final Cut Pro to Motion.
Motion properly accesses the motion analysis files created by Final Cut Pro so you don’t
need to analyze your clips again in Motion.

Improving SmoothCam Filter Results and Troubleshooting
When you use the SmoothCam filter, keep the following points in mind:
• The SmoothCam filter requires motion analysis data before you can see the results of
the filter.
• Certain visual characteristics in your footage can cause the SmoothCam filter to generate
unexpected results.

Making Sure Clips Are Analyzed
A clip can have an Unanalyzed status for several reasons, such as:
• You stopped the analysis for that particular clip in the SmoothCam Browser column.
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• You stopped the processing queue before the clip was analyzed.
• The processing queue is paused, so the clip has not yet been analyzed.
• You ran out of disk space before the motion analysis file could be written.

Improving SmoothCam Filter Results
The following kinds of footage can generate inaccurate motion analysis data, leading to
improper motion compensation when the clip is rendered.
Problem

Solution

A lot of motion blur—especially
in interlaced footage

Shoot progressive footage when possible and avoid rapid camera
movements.

Footage shot with a wide-angle
lens—the lens distorts the
source pixels and the
SmoothCam analysis does not
compensate for this.

Don’t use a wide-angle lens or any other filter that distorts pixels
around the edge of the frame.

3:2 pull-down, advanced
pull-down, or duplicate frames

Remove pull-down or duplicate frames before applying the
SmoothCam filter or submitting clips to the SmoothCam Analysis
processing queue.

Progressive footage converted
to interlaced footage creates
softer SmoothCam results than
original interlaced footage.

Apply the SmoothCam filter to the original progressive footage. If
you need to combine interlaced and progressive footage, create a
mixed-format sequence and use original progressive footage in
your sequence when possible.

Clips with speed changes and
the SmoothCam filter applied
don’t appear smooth when
Frame Blending is enabled.

Nest the sequence containing a clip with the SmoothCam filter
applied, then apply the speed changes and enable the Frame
Blending option for the nested sequence. For more information,
see “Frame Blending, Optical Flow, and Motion Blur.”
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Creating Titles

75

This chapter covers the following:
• How You Can Use Titles in Your Project (p. 1271)
• Installing and Choosing Fonts (p. 1272)
• Making Sure Titles Fit on TV Screens (p. 1272)
• Text Generators Available in Final Cut Pro (p. 1273)
• Creating and Adding a Title Clip (p. 1276)
• Other Options for Creating and Adding Titles (p. 1279)
Titles, including opening and closing credits and titles used in the lower part of the screen,
are important elements in your project.

How You Can Use Titles in Your Project
Titles play a critical role in movies, providing important bookends (such as opening titles
and closing credits) and conveying time and dates within the movie. Titles, especially in
the lower third of the screen, are also used in documentaries and informational video to
convey details about subjects or products onscreen. You can also add notes and
placeholders within your sequence while you edit. Subtitles can be a critical element for
movies originating in a different language.
You can create titles and credits within Final Cut Pro with text generators. Generators are
synthesized clips generated by Final Cut Pro. Generators don’t refer to any media on your
scratch disk. When you place a text generator on a track directly above another clip, the
clip on the lower track appears as the text background, sparing you the need to perform
any compositing to create that effect.
Note: After you add a text generator to your sequence, it must be rendered.
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Installing and Choosing Fonts
If there are special fonts you want to install to use in Final Cut Pro, you need to install the
TrueType version of those fonts because Final Cut Pro text generators use TrueType fonts.
(Most professionally created fonts come in both PostScript and TrueType versions.) For
information on installing fonts, see Mac Help.
DV was designed for real-world images that blend together, and it is not optimized for
rigid lines of text. In interlaced video, single-pixel lines flicker unacceptably as the field
on which they appear alternates on and off. This results in “buzzing” text that is difficult
to read.
Apply the tips below to achieve better-looking title fonts for video:
• Avoid fonts that are thin or smaller than 25 point.
• Use only sans serif fonts, such as:
• Arial
• Futura
• Gill Sans
• Helvetica
• Impact
• Use the bold font style.
• Do not use white or black as a font color.
• Reduce the opacity of the text clip to 90 percent.

Making Sure Titles Fit on TV Screens
If you plan to show your work on a TV screen or monitor at any time, you’ll want to avoid
the possibility of having your titles disappear off the edge of the frame. To do this, turn
on the Title Safe indicators before you create the title, and restrict any text you add to
the space within the title safe boundary.
Note: Because few video projectors use masking, title safe boundaries may not be
important for movies displayed with video projectors.
The title safe boundary is 20 percent smaller than the overall size of the frame, whether
you’re using NTSC or PAL. Though different manufacturers use different amounts of
overscan, the title safe boundary is guaranteed to be the minimum displayed area of your
image on television.
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Note: When working with video that has 16:9 aspect ratio, the Title Safe indicators and
Action Safe indicators also show tick marks to indicate the limits of 4:3 aspect ratio Title
Safe indicators and Action Safe indicators. Use these tick marks as guides when you want
to ensure that your media will appear correctly when shown at 4:3 aspect ratio as well.
To display the Title Safe indicators
Do one of the following:

µ
µ

Choose View > Show Title Safe, so a checkmark appears next to it.
Choose Show Title Safe from the View pop-up menu in the Viewer, so a checkmark appears
next to it.
To hide the Title Safe indicators
Do one of the following:

µ
µ

Choose View > Show Title Safe, to remove the checkmark.
Choose Show Title Safe from the View pop-up menu in the Viewer, to remove the
checkmark.
Important: If you are not able to see the title safe boundary in the Viewer or the Canvas
and you are certain that the Title Safe indicators are enabled in Final Cut Pro, make sure
your Mac OS X display preferences are set to millions of colors. Choose Apple > System
Preferences, click Displays, and then choose Millions from the Colors pop-up menu.

Text Generators Available in Final Cut Pro
The table below describes each text generator and includes tips about settings for each
generator.
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Text generator

Result

Tips for making settings

Crawl

Generates a single line of text
that moves horizontally across
the screen. You type the text you
want to animate in a text entry
field. Carriage returns are
ignored and all text appears on
a single line, like a ticker tape
display.

• You can adjust the overall
spacing of the text with the
Spacing slider, and the
location of the text as it crawls
across the screen with the
Location slider. The Direction
pop-up menu allows you to
set the direction in which the
text moves.
• By keyframing the Spacing
and Location parameters, you
can animate the width of your
text as well as its horizontal
position over time. If no
location keyframes are set, the
In and Out points of the
generator clip determine the
duration of the movement
from one edge of the screen
to the other. The longer the
clip, the slower the movement
of the crawl.

Lower 3rd

Generates text in the lower third
of the screen. This generator is
often used to identify a person
or location.

• This generator provides two
independent text lines placed
in the lower third of the
screen. It does not allow
carriage returns.
• The Tracking, Size, and
Opacity parameters can be
keyframed to create
interesting effects.
• Select the Auto Kerning
checkbox to kern your text
automatically so that the
spacing between the
individual letters of your text
is correct.

Outline Text

Generates static text with an
outline. This generator allows
carriage returns.

Chapter 75 Creating Titles

Text generator

Result

Tips for making settings
• Text Graphic and Line Graphic
clip wells allow you to fill the
text or the outline with the
image of a clip you apply,
rather than a solid color.
• You can also modify the size,
softness, color, and opacity of
the background
independently of the text.
You can use the Back Graphic
clip well to apply the image
from any clip to the
background.

Scrolling Text

Generates text that scrolls up the
screen, like credits at the end of
a movie. The Scrolling Text
generator allows carriage
returns.

Text

Creates a static element of text.
This generator allows carriage
returns.
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• The Indent slider works only
with left- or right-aligned text
and moves the entire scrolling
column to the left or right.
• The Gap Width slider works
only with center-aligned text
and lets you define a space
between two pieces of text
on a single line that are
separated by an asterisk (*).
For example, if the first line of
your scrolling text is “Sally
Grey*Director,” moving the
slider changes the gap
between “Sally Grey” and
“Director.” This is useful if you
want to create center-aligned,
two-column scrolls.
• The Fade Size slider narrows
the vertical display area of
your scrolling text in the
frame, fading the text in and
out at the bottom and the
top.
• The In and Out points of the
edited generator clip
determine the duration of the
scroll from the bottom to the
top of the screen (or vice
versa). The longer the clip, the
slower the movement of the
scroll.
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Text generator

Result

Tips for making settings
• The font, size, style,
alignment, and color of the
generated text can be
modified. These controls
modify the entire text
element at once. Tracking,
Leading, and Aspect sliders
allow you to control the
layout of the generated text
and can be keyframed to
create interesting effects.
• Select the Auto Kerning
checkbox to kern your text
automatically so that the
spacing between the
individual letters of your text
is correct. Select the Use
Subpixel checkbox to render
your text with subpixel
accuracy.

Typewriter

Generates text that appears as if
typed onto the screen, one
character at a time. This
generator allows carriage
returns.

• The Location slider moves the
text element up and down in
the frame, and the Indent
slider moves it from side to
side.
• The Pause slider increases or
decreases the amount of time
it takes for each character to
appear onscreen.

Creating and Adding a Title Clip
When you’re creating a title clip for a sequence, you can create a basic title or specify
more options, including the font, size, alignment, and more advanced options such as
automatic kerning. Once you create the title clip, you add it the same way you would
edit any clip into your sequence.
Note: Generated text clips always adopt the frame size of the sequences they’re edited
into.
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To create a title clip
1 Select a text generator by doing one of the following:
• Click the Video or Audio tab in the Viewer, then choose a text generator from the
Generator pop-up menu.

• In the Effects tab of the Browser, double-click a text generator.
See “Text Generators Available in Final Cut Pro” for detailed descriptions of the choices.
2 In the Viewer, click the Controls tab.
3 In the Text field, type the text that will appear in your movie.
Enter title text
in this field.

Reset button

Number field for the
font size

Slider for the font
size, with arrows
on either end

4 If you wish, specify additional settings.
Note: Different text generators have different controls.
• Text: Enter your title text in this field.
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• Font: Choose a font from the Font pop-up menu.
• Size: Change the font size by entering a value or dragging the slider to the left or right.
• Alignment: Choose the alignment of your title on the screen from this pop-up menu.
Your choices are Left, Center, and Right.
• Font Color: Choose the color of your font by doing one of the following:
• Disclosure triangle: Click to display sliders and number fields corresponding to the
hue, saturation, and brightness of the range of colors available.
• Eyedropper tool: Click the eyedropper, then click an image in the Viewer or the Canvas
to pick up that color.
• Color picker: Click to choose a color using the standard color picker.
• Hue, saturation, and brightness controls (H, S, and B): Hue determines which color is
chosen; saturation determines how vivid the color is. If saturation is 0, the resulting
color is always white. Brightness determines how bright or dark the color is. If
brightness is 0, the resulting color is black; if brightness is 100, the color is the lightest
possible value.
• Origin: Origin refers to the center of the text. The Origin setting determines where the
text appears within the screen. You can position the text by clicking the point control
(a round button with crosshair) and then clicking a point in the Canvas or Viewer (the
pointer becomes a crosshair pointer). Or, you can enter x and y coordinates in the Origin
number fields.
It’s often easiest to make large adjustments manually with the point control and then
fine-tune the position by making numerical changes to the number fields. The most
visual way to position the text is to tear off the Viewer tab, click the point control, and
then drag the text to position it in the Viewer.
Note: Once you release the mouse button, you have to click the point control again if
you want to make further manual adjustments.
• Tracking: Use the slider to adjust the space between letters, or enter a value in the
number field.
• Leading: Use the slider to adjust the space between lines of text, or enter a value in
the number field.
• Aspect: Use the slider to adjust the ratio of letter height to letter width for your selected
font, or enter a value in the number field.
• Auto Kerning: Select the Auto Kerning checkbox to kern your text automatically so that
the spacing between the individual letters of your text is correct.
• Use Subpixel: Select the Use Subpixel checkbox to render your text with subpixel
accuracy.
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Once you’ve created your text generator clip, you can add it to your sequence. For more
specific information, see “The Fundamentals of Adding Clips to a Sequence.”
To add the title clip to your sequence
1 In your sequence in the Timeline, set your destination track.
If you place the title clip on a track that’s above another track, the lower clip appears as
the background to the title.
2 Set the sequence or clip In and Out points.
3 Click the Video tab in the Viewer, then drag the title clip from the Viewer to the Canvas
or Timeline.

Other Options for Creating and Adding Titles
If a title you have in mind is something you can’t create with the available text generators,
you can use other methods to create titles and incorporate them into your sequence:
• Using Photoshop files or still images for titles: If a title you really want is best created in
another application such as Photoshop, you can create it there and add it to your
sequence as a still image. An easy way to bring an image file into your sequence is to
simply drag it from your desktop to a project tab or bin in the Browser. See “Working
with Freeze Frames and Still Images” for a number of useful things to consider when
importing still images and photographs into your movie.
• Using titles created in Motion: Motion supports animated LiveFonts and allows you to
create complex text animations. For more information, see the Motion documentation.
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This chapter covers the following:
• Using Motion with Final Cut Pro (p. 1281)
• Using Shake with Final Cut Pro (p. 1286)
You can add Motion projects directly to sequences in Final Cut Pro and send Final Cut Pro
sequence clips directly to a new Timeline in Motion.

Using Motion with Final Cut Pro
Integration between Motion and Final Cut Pro allows you to do the following.
• Import Motion projects into Final Cut Pro: You can add motion graphics created in Motion
directly to your Final Cut Pro sequence without rendering.
• Update embedded Motion projects in Final Cut Pro: You can immediately see changes
to a Motion project in your Final Cut Pro sequence.
• Send Final Cut Pro clips or sequences to Motion: You can create new Motion projects
based on a selection of clips or a sequence in Final Cut Pro. You can use this feature to
sketch a motion graphics sequence in Final Cut Pro and then refine it in Motion. The
new Motion project can then be embedded in your Final Cut Pro sequence.
Note: Motion can import audio included in a Final Cut Pro project, but audio in a Motion
project does not appear in Final Cut Pro.

Importing a Motion Project into Final Cut Pro
You can import Motion projects into Final Cut Pro to quickly add motion graphics, title
sequences, and animations to your sequence.
To import a Motion project into Final Cut Pro
Do one of the following:

µ
µ

Drag the Motion project from the Finder to the Final Cut Pro Browser or Timeline.
Choose File > Import > Files, then select the Motion project in the dialog that appears
and click Choose.
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Importing a Motion project into Final Cut Pro creates a Motion clip (also called an embedded
Motion project) that you can edit in the same way as any other clip in your project. A
Motion clip refers to the imported Motion project stored on disk.
Motion clips can play back in real time, although you may have to choose Unlimited RT
mode to avoid rendering. For more information, see “Unlimited RT.”
Important: Any media files for clips used in the Motion project, such as movies or still
images, need to be available on the same hard disk drive for the project to play correctly
in Final Cut Pro.

Making Changes to a Motion Clip in Final Cut Pro
While working in Final Cut Pro, you can quickly make changes to a Motion clip by opening
the clip's project file in Motion. After you save the Motion project, any changes you made
appear immediately in Final Cut Pro.
Note: This feature requires both Final Cut Pro and Motion to be installed on the same
computer.
To open a Motion project from within Final Cut Pro
Do one of the following:

µ
µ

Select the Motion clip, then choose View > Clip in Editor.
Control-click a Motion clip, then choose Open in Editor from the shortcut menu.
The Motion project opens in Motion. Once you make changes in Motion and save the
project, Final Cut Pro automatically reconnects the Motion clip to the updated project so
you can see the changes.
If you do not use the Open in Editor command in Final Cut Pro to open a Motion project,
Final Cut Pro may not automatically reconnect the Motion project if you resave it. In this
case, you will have to manually reconnect the Motion clip in Final Cut Pro to its project
file.
To make sure a Motion clip automatically reconnects to an updated Motion project
Do one of the following:

µ

Initiate the Motion project update from within Final Cut Pro by selecting the Motion clip
and choosing View > Clip in Editor.
This method informs Final Cut Pro that the Motion project may be updated, so the Motion
clip is automatically reconnected the next time you switch to Final Cut Pro.

µ

Select the Always Reconnect Externally Modified Files option in the Editing tab of the
Final Cut Pro User Preferences window.
This method tells Final Cut Pro to automatically reconnect any modified media and project
files when you switch to another application and then switch back to Final Cut Pro.
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Restrictions When Working with Motion Clips in Final Cut Pro
When working with Motion projects in Final Cut Pro, keep the following restrictions and
limitations in mind:
• The audio in a Motion project is not imported into Final Cut Pro.
• All video tracks in a Motion project appear as a single layer when imported into
Final Cut Pro as a Motion clip.
• The frame size and duration of the Motion clip are determined by the settings in the
Motion project.
• The Final Cut Pro Media Manager does not manage source media files used by a Motion
clip's project file. You need to manage your media for Motion projects separately from
your Final Cut Pro media.

Sending Final Cut Pro Clips and Sequences to Motion
You can send clips or sequences from Final Cut Pro to a new Motion project by using the
Send To > Motion Project command. This command is useful when you want to:
• Edit a rough motion graphics sequence in Final Cut Pro and then send those clips to
Motion for more complex animation
• Use Final Cut Pro to capture media files for use in Motion
Many of the clip parameters you adjust in Final Cut Pro are retained in the resulting Motion
project.
Selecting Clips or Sequences to Send to Motion
The Send To Motion Project command behaves slightly differently depending on your
selection.
• One or more Browser clips: The selected clips are sent to a new project in Motion; the
Motion Timeline remains empty and the clips appear in the Motion Media tab.
• A sequence in the Browser: A new Motion project is created with an identical track and
clip layout as your Final Cut Pro sequence.
• One or more clips in a sequence: A new Motion project is created that contains only the
clips you selected in your Final Cut Pro sequence, occupying the same position and
track layout as your original selection. This method has an additional option called
Embed Motion Content, which allows you to replace your selected sequence clips by
embedding the Motion project in their place.
To send clips or sequences from Final Cut Pro to a new Motion project
1 In Final Cut Pro, do one of the following:
• Select one or more clips in the Browser.
• Select a sequence in the Browser.
• Select one or more sequence clips in the Timeline.
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2 Choose File > Send To > Motion Project.
3 In the dialog that appears:
a Choose a location and enter a name for the new Motion project.
b If you want the new Motion project to immediately open in Motion, select Launch
Motion.
c If you used the Send To Motion Project command with sequence clips, you can select
the Embed Motion Content option, which allows you to replace the selected sequence
clips in Final Cut Pro with the Motion project you just created. For more information,
see “Sending Selected Sequence Clips from Final Cut Pro to Motion.”
4 Click Save.
A new Motion project is created. If you selected the Launch Motion option, the new
project opens in Motion. For more information about the results of sending different
kinds of selections to Motion, see the following sections.
Sending Browser Clips from Final Cut Pro to Motion
When you send Browser clips from Final Cut Pro to Motion, a new Motion project is created
with an empty Timeline and the media from each selected Final Cut Pro clip displayed in
the Motion Media tab. Use this method to quickly import media from Final Cut Pro into
an empty Motion project.
Sending a Sequence from Final Cut Pro to Motion
You can send an entire sequence, including all of its video tracks and their sequence clips,
to a Timeline in a new Motion project. Use this method to edit one or more layers in
Final Cut Pro and then add effects, animation, or text in Motion.
Sending Selected Sequence Clips from Final Cut Pro to Motion
You can send any selection of sequence clips in Final Cut Pro to a new Motion project.
Noncontiguous selections are allowed. For example, if you selected sequence clips A, B,
and D in Final Cut Pro, but you skipped clip C, the Motion Timeline would also contain
media from clips A, B, and D with a gap where clip C was located.
When you send sequence clips to Motion, several things happen:
• Final Cut Pro automatically creates a new sequence containing only the clips you
selected. You can verify that there is a new sequence by looking in the Browser.
• The contents of the new sequence are used to create a new Motion project.
• If you choose the Embed Motion Content option in the Export Selection to Motion
dialog, the new Motion project is imported into Final Cut Pro, creating a Motion clip in
the Browser. The selected sequence clips are replaced by the new Motion clip.
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About the Embed Motion Content Option
The Embed Motion Content option is available only when you send selected sequence
clips to a new Motion project. This option imports the new Motion project back into
Final Cut Pro and replaces your selected sequence clips. In effect, it converts your selection
of sequence clips into a Motion clip in a single step. For more information about working
with imported Motion projects, see “Making Changes to a Motion Clip in Final Cut Pro.”
If you don't select Embed Motion Content, the selected sequence clips are still copied
into a new sequence in the Browser, but they are not replaced and the new Motion project
is not imported into Final Cut Pro, so your original sequence remains unchanged.
What Properties Are Exported to Motion?
When you send sequence clips to Motion, the following properties are retained in the
exported Motion project.
Content type

Exported properties

Video

• Clips, with In and Out points, placed on the correct Timeline
tracks and positions
• Clip and sequence markers (called object and project markers in
Motion)
• Almost all attributes in a clip's Motion tab, including Basic Motion,
Crop, Distort, Opacity, Drop Shadow, and Speed. Any linear and
smooth Bezier keyframes are also included.
• Composite (blend) modes
• The SmoothCam filter. If applied, the filter is converted to the
Stabilize behavior with the Smooth method enabled in Motion.

Audio1

• Media
• Markers
• Levels and keyframes

1 The audio exported to Motion is not imported when you bring the Motion project back into Final Cut Pro. The audio
is only intended to be used in Motion for playback and markers. For this reason, make sure that you retain the
original audio clips in Final Cut Pro.

With the exception of the SmoothCam filter, Final Cut Pro does not send filters applied
to clips. Also, transitions and generators are not sent.

Rendering Motion Projects for Use in Final Cut Pro
If necessary, you can export a Motion project to a QuickTime movie and import it into
Final Cut Pro. This method is less flexible than importing Motion projects directly into
Final Cut Pro, so you should usually avoid this option. When you export the Motion project,
choose the Apple ProRes 4444 codec for its 10-bit 4:4:4 color space and lossless alpha
channel with real-time playback. The alpha channel makes it easy to composite the
QuickTime movie with your footage in Final Cut Pro. The Apple ProRes 4444 format will
preserve the alpha channel and the motion graphics through to the finishing stages. For
more information about Apple ProRes, see Professional Formats and Workflows, available
in Final Cut Pro Help.
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Using Shake with Final Cut Pro
Shake is a powerful visual effects application with features such as motion tracking,
rotoscoping, and node-based compositing. Final Cut Pro can send a group of clips directly
to Shake for further effects work.
For example, you can use Final Cut Pro for basic editing, setting In and Out points, and
placing clips on multiple video tracks. You can then send the edit information and the
clip's media to Shake, ready for further processing.

Sending Clips from Final Cut Pro to a Shake Script
You can send two kinds of selections to Shake from Final Cut Pro.
• An entire sequence in the Browser: All the clips in the sequence are sent to a new Shake
script.
• One or more selected clips in a sequence: Only the selected sequence clips are sent to a
new Shake script. In addition, a new placeholder QuickTime media file is created where
the final rendered Shake media will be stored. Final Cut Pro automatically creates a
new sequence containing a clip that links to the placeholder QuickTime media file.
To send one or more clips or a sequence from Final Cut Pro to Shake
1 Arrange your project's Timeline so that you are able to select only the clips you intend
to send.
2 Do one of the following:
• In the Timeline, select one or more sequence clips you want to export.
• In the Browser, select a sequence.
3 Do one of the following:
• Choose File > Send To > Shake.
• Control-click the selected clips or sequence, then choose Send To > Shake from the
shortcut menu.
4 When the Send to Shake dialog appears, select the appropriate options.
• Resulting Sequence Name: Enter a name for the new sequence that's created inside
the Final Cut Pro project file to contain the selected media when you click Export. This
applies only if you select one or more clips in the Timeline; a new sequence is not
created if you select a sequence in the Browser.
• Save as Shake Script: Enter a name and choose a location for the new Shake script to
be created.
• Save Placeholder QuickTime movie (FileOut) to: Type a name and choose a location for
the placeholder QuickTime movie that will correspond to the FileOut node in the newly
created Shake script.
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5 Select the Launch Shake checkbox if you want the newly created Shake script to open
automatically so you can start working on it.
Important: This requires Final Cut Pro and Shake to be installed on the same computer.
6 Click Export.
When you click Export, several things happen:
• If you selected sequence clips, a new sequence is created in your Final Cut Pro project
that contains a copy of all your selected clips.
• A placeholder QuickTime file is created on disk that will eventually contain the rendered
output from Shake. A clip referring to the placeholder file is created and placed on a
disabled video track at the top of the new sequence. The original media file positions
are unchanged.
• A Shake script is created on disk.

The timeRange of Scripts Generated from Final Cut Pro
The timeRange Global parameter in the Shake script that's created by the Send To Shake
command is automatically set with the appropriate range of frames for the media to
which it refers.
Important: Clicking the Auto button to update the timeRange is not recommended. This
can result in many more frames being referred to than expected, depending on the total
duration of the source media files.

How Imported Clips Are Arranged in Shake
Imported Final Cut Pro clips are arranged within a Shake script node tree using Select
and MultiLayer nodes. The way imported clips are arranged in Shake depends on whether
the clips in Final Cut Pro are arranged sequentially on a single video track or layered
vertically on several video tracks.
• Final Cut Pro clips edited sequentially on the same video track are connected to a single
Select node in Shake. The Select node places each clip in the proper Timeline position,
preserving clip In and Out points.
Note: The actual edit points for each File In node attached to the Select node are stored
within the branch parameter. The data stored within this parameter is not intended to
be editable; any attempt to do so will have unpredictable results.
• Each Final Cut Pro track that contains a clip is exported to a new Shake Select node.
• Each Select node is connected to a single MultiLayer node, which determines which
clips are in the foreground of the composition and which are in the background.
If you want to change the temporal position of clips after they are imported into Shake,
you should use the Time View tab.
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Important: Audio clips from the original QuickTime files are not imported into Shake.
Video timing changes you make in Shake can cause audio sync problems if you import
the finished Shake composite back into your original Final Cut Pro sequence.

Unsupported Media and Effects
The following items are not transferred when exporting Final Cut Pro sequences to Shake:
• QuickTime audio tracks
• Standalone audio files
• Still-image files
• Generators
• Composite modes
• Parameters in the Motion tab
• Filters
• Transitions

Sending Media from Shake Back to Final Cut Pro
When you've finished working in the Shake script that was generated from Final Cut Pro,
you need to render the originally created FileOut node. The newly rendered media file
takes the place of the placeholder QuickTime file, ready for use by the original Final Cut Pro
project.
When you reopen the Final Cut Pro project file containing the original placeholder
QuickTime file, you'll need to use the Reconnect Media command to relink the clip in
your sequence to the media that was rendered out of Shake.
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Working with Master Templates

77

This chapter covers the following:
• About Motion Template Files and Master Templates (p. 1289)
• Working with Master Templates (p. 1290)
• Modifying Master Templates (p. 1295)
• Converting a Template Clip to a Motion Project (p. 1297)
• Installing Motion Template Files for Use in Final Cut Pro (p. 1298)
Master templates created in Motion allow you to quickly customize design elements such
as titles and opening credits.

About Motion Template Files and Master Templates
Both Motion and Final Cut Pro support Motion template files, but each application uses
them in different ways:
• In Motion, a template file is a starting point for creating new projects with preexisting
animated text and graphics layers. For more information, see the Motion User Manual,
available in Motion Help.
• In Final Cut Pro, Motion template files are used as master templates from which you
can create template clips that are edited into a sequence. Each template clip retains
the same animation and behaviors as its parent master template, but parameters such
as text and video content can be customized individually for each template clip.
Master templates allow you to add professional motion graphics and titles to your
sequence, even if you've never used Motion before. For example: You want to create an
animated opening title for your Final Cut Pro sequence. A graphic designer can create
the opening in Motion and save it as a Motion template file. In Final Cut Pro, you can use
the Motion template file as a master template and edit it into your sequence. You can
change the title of your movie as often as you like by modifying the template clip's text
parameter while retaining the animated parameters provided by the graphic designer.
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But that's just the beginning. The real power of master templates becomes clear when
you have lots of titles or graphics in your sequence that need the same motion graphics
treatment. For example: You are working on a documentary that has dozens of lower
third titles, each requiring the same animated text and background treatment. In this
case, a graphic designer can create a single Motion template file for all of your lower third
titles. In Final Cut Pro, the Motion template file becomes a master template that you can
use to create multiple template clips in your sequence, each with its own custom text.
But there's still more. What if you or your graphic designer wants to alter the animation
for the lower third titles after you have edited them into your sequence? Because you
used the same master template for each lower third, each template clip is connected to
the same Motion template file. The designer can change the Motion template file, and
all the template clips in your sequence are updated immediately.

Terminology for Master Templates
The following definitions provide some shorthand for discussing the behavior of sequences
containing clips derived from master templates:
• Motion template file: A template file created and saved in Motion. This term refers to
the template file stored on disk.
• Master template: A Motion template file as it appears in Final Cut Pro. You can view
master templates in the Viewer and edit them into a sequence, creating copies called
template clips.
• Template clip: An instance of a master template edited into a sequence or copied into
the Browser. Just as normal Final Cut Pro clips refer to QuickTime media files on disk,
a template clip refers to a Motion template file on disk. When a Motion template file
is changed and saved in Motion, any template clips that refer to the template file are
updated.
• Template parameters: Special template clip parameters that you can customize directly
in Final Cut Pro using the Controls tab of the Viewer. For example, you can modify text
or video content in a template clip.

Working with Master Templates
Here is the basic workflow for using master templates in Final Cut Pro.
Stage 1: Previewing Master Templates
See “Previewing Master Templates” for information on previewing the currently installed
master templates in the Master Template Browser.
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Stage 2: Adding Master Templates to a Sequence
See “Adding Master Templates to a Sequence” for information on the different ways you
can add master templates to your sequence.
Stage 3: Customizing Template Clip Parameters in the Viewer
See “Customizing Template Clip Parameters in the Viewer” for information on customizing
a template clip after it has been added to your sequence.

Previewing Master Templates
You can preview the currently installed master templates in the Master Template Browser.

µ

To open the Master Template Browser
Choose Sequence > Add Master Template.
The Master Template Browser allows you to view preview movies of the available master
templates on your system.
Select a theme here.

Select a template here.
Choose a video format.
Preview area

Resolution, duration,
and frame rate

In the Theme list, you can select a theme to display related master templates. You can
also restrict which templates are displayed by choosing a video format such as NTSC,
PAL, or HD from the Show pop-up menu. Click a template in the Master Template area
to view it in the preview area. The template's resolution, duration, and frame rate are
displayed below the template preview area.
Important: When a Motion template file is saved in Motion, the video standard assigned
to the template is a metadata tag but does not ensure that the resolution and frame rate
correspond. Make sure that the template you choose has the resolution and frame rate
you want.

µ

To close the Master Template Browser
Click Cancel or press Esc.
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Adding Master Templates to a Sequence
You can add master templates to your sequence from four different locations within
Final Cut Pro. Try out the following methods to see which one works best for you.
• Master Template Browser: Choose Sequence > Add Master Template to open the Master
Template Browser. From this window, you can perform an overwrite, insert, or
superimpose edit to edit a master template directly into your sequence. This method
provides the most options for editing a template into your sequence and allows you
to see a preview of all the installed templates.
• Master Templates bin in the Effects tab of the Browser: Double-click a master template
to open it in the Viewer, or drag a master template to the current sequence in the
Canvas or Timeline. This is the quickest way to add multiple master templates to your
sequence, in one drag-and-drop operation.
• Generator pop-up menu in the Viewer: In the Viewer, choose Master Template from the
Generator pop-up menu, then choose a template from the submenu. This method
opens a master template in the Viewer, which you can then edit into your sequence.
• Master Templates submenu within the Effects menu: Choose Effects > Master Templates,
then choose a master template from the submenu. This method opens a master
template in the Viewer, and you can then edit the template into your sequence.
To edit a master template from the Master Template Browser into your sequence
1 In the Timeline, prepare your sequence for the type of edit you want to perform.
For example, set In and Out points and choose a destination video track. For more
information about basic video editing, see “The Fundamentals of Adding Clips to a
Sequence.”
2 Make sure the Canvas or Timeline is the active window.
3 Choose Sequence > Add Master Template.
The Master Template Browser appears.
4 In the Theme list, click the theme you want to display.
5 If you want, you can also restrict which templates are displayed in the current theme by
choosing a video format from the Show pop-up menu:
• All: Shows all templates in the theme, regardless of video standard.
• NTSC: Displays only NTSC templates (29.97 fps, 720 x 480 or 720 x 486).
• PAL: Displays only PAL templates (25 fps, 720 x 576).
• HD: Displays only HD templates (1920 x 1080 or 1280 x 720).
• Other: Displays templates that do not match NTSC, PAL, or HD standards.
6 In the Master Template area, select a master template to preview it in the preview area.
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7 To edit the selected master template into your sequence, click one of the following:
• Overwrite: A template clip is added to your sequence with an overwrite edit. The
template clip is placed at the current In point on the current destination video track.
• Insert: A template clip is added to your sequence with an insert edit. The template clip
is placed at the current In point on the current destination video track.
• Superimpose: A template clip is added to your sequence above the current destination
video track, and the template clip placement is based on the current In and Out points
or playhead position.
For more information about overwrite, insert, and superimpose edits, see “Three-Point
Editing.”
After the template clip is placed in your sequence, it is automatically opened in the Viewer
with the Controls tab active. You can now customize the template clip parameters in the
Viewer.

Customizing Template Clip Parameters in the Viewer
After editing a template clip into your sequence, you can customize its parameters. Much
like generator clip parameters, the customizable parameters for a template clip are
displayed in the Controls tab of the Viewer.
The following template clip parameters can be customized in Final Cut Pro:
• Text
• Text size
• Text tracking
• Still images or moving footage
• Position of still images and moving footage
The timing of a template clip can be adjusted by applying speed changes. For more
information, see “Changing Clip Speed.”
To open the Controls tab for a template clip in a sequence
1 In the Timeline, move the playhead over the template clip item you want to modify.
Note: This step is not necessary, but it allows you to view changes to your template in
the Canvas while you work in the Viewer.
2 Double-click the template clip item to open it in the Viewer.
3 In the Viewer, click the Controls tab.
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Tip: Holding down the Command and Option keys after you begin dragging a master
template from the Viewer to the Timeline or Canvas causes the newly created template
clip to open automatically in the Viewer with the Controls tab active. This allows you to
immediately customize the template clip parameters after the clip is edited into your
sequence. This shortcut also works for generator clips. Holding down the Command and
Option keys before dragging in a window causes the whole window to move with the
pointer. To avoid this when working with master templates, make sure to start dragging
a master template first and then hold down Command and Option.
Modifying Text
You can change text in a template clip by entering text in any available text parameters.
Note: When you create a Motion template file that uses more than one font or font style
within a Motion track, the fonts appear as expected in Final Cut Pro. However, if you make
changes to the text within a Final Cut Pro template clip, the text is limited to a single font
and font style.
Modifying Video and Still-Image Content
You can replace video footage or a still image in a template clip by dragging a clip from
the Browser to a clip well in the Controls tab of the Viewer. The template clip uses the
dragged clip's In and Out points, so you can determine where a clip begins by setting its
In point before dragging it to the clip well.
To replace video footage or a still image in a template clip
1 Open a clip in the Viewer that you want to use as a source clip in the template clip, then
set clip In and Out points if necessary.
2 Double-click a template clip to open it in the Viewer, then click the Controls tab.
3 Drag the source clip from the Browser or Timeline to a clip well in the Controls tab of the
Viewer.
Important: A clip well only uses a clip’s original media file. Any filters, motion parameters,
or speed changes applied to a clip are ignored when it is dragged to a clip well. Only
clips that refer to a single media file can be used; merged files and multiclips are not
supported.
Modifying Speed and Template Clip Timing
For simple timing adjustments, you can apply speed changes to a template clip just as
you would to any other clip item. For more information, see “Changing Clip Speed.”
For complex timing adjustments in your template animation, you can open and modify
the template file in Motion. However, if you only want to affect the motion of a specific
template clip (as opposed to all occurrences of a master template), you should use the
Open Copy in Editor command. For more information, see “Modifying Master Templates.”
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Modifying Master Templates
There are two ways you can change the basic design of template clip:
• Open in Editor command: Allows you to change a template clip's Motion template file
by opening the file and editing it in Motion. All template clips that refer to the Motion
template file in all of your projects and sequences are updated.
• Open Copy in Editor command: Allows you to make changes to a single template clip
in your sequence by making a new Motion template file only for that template clip.

Updating All Template Clips That Use the Same Master Template
If you want to change all template clips in a sequence or project that use the same master
template, you can modify the Motion template file in Motion. For example: You created
all of the lower third titles for your project using a single master template. If you want to
change a design element, such as the text color, you can modify the Motion template
file in Motion. When you switch back to Final Cut Pro, the text color of all template clips
that refer to that Motion template file is updated automatically. The parameters you
customized in Final Cut Pro, such as text and video footage, are preserved as long as you
don't remove those parameters when you edit the Motion template file.
To modify all template clips that use the same master template
1 Select a master template in the Effects tab, the Viewer, or the Timeline, then choose View
> Open in Editor.
2 The Motion template file opens in Motion.
3 In Motion, make timing and animation changes to the template file.
Note: Be careful not to delete any elements, such as text, in the Motion template file that
are used as customizable parameters in your Final Cut Pro sequences.
4 Save the Motion template file and return to Final Cut Pro.
All template clips in your project that refer to the modified Motion template file are
updated with the changes you made in Motion.
Warning: When you update a Motion template file on your local editing system, make
sure you also update the template file on all other systems that may use that template
file. If you do not update the template file on a remote system and you open your
sequence on the remote system, the older template file on that computer is displayed
instead of your updated template file.

Updating a Single Template Clip
If you want to modify only a single template clip without affecting others, Final Cut Pro
can make a copy of the template clip's Motion template file and automatically link the
template clip to the copied template file. Because the template clip in the Timeline is
now linked to the copied Motion template file, the template clip is no longer affected by
changes you make to its original Motion template file.
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To modify a single template clip in a sequence
1 Select a template clip in your sequence, then choose View > Open Copy in Editor.
A Save dialog appears.
2 Choose a location and enter a name for the copy of the Motion template file you are
creating.
By default, the template filename is the same as the original template filename, with the
word ”copy” appended. The default location is the same location as for the original
template file.
3 Click Save.
A copy of the template file is saved and then opened in Motion. The template clip in
Final Cut Pro is reconnected to the copied template file.
4 Make changes to the template file in Motion.
Important: Be careful not to delete any elements in the Motion template file that are
used as customizable parameters in your Final Cut Pro template clip. For example, if you
have custom text in your template clip, don't delete the corresponding text element in
the Motion template file.
5 Save the template file and return to Final Cut Pro.
The template clip in the Timeline is updated. No other template clips in your project are
affected, and this template clip is now linked to the copied Motion template file.

Updating and Replacing Template Clips Using Drag and Drop
You can easily replace template clips in your project with updated master templates by
dragging new master templates to existing template clips in the Timeline. For example,
in some post-production workflows, you may need to update several template clips in a
sequence with a newer version of the master template you just received from a remote
motion graphics artist.
Note: Make sure to install new Motion template files before you update template clips
in your Final Cut Pro project. For more information, see the instructions in “Installing
Motion Template Files for Use in Final Cut Pro.”
There are three methods for updating template clips:
• Link a single template clip to a newer master template.
• Link all template clips in a sequence that connect to a single master template to a
newer master template.
• Link all template clips in a project that connect to a single master template to a newer
master template.
To update a single template clip in your sequence to a newer master template
1 Open the new master template you want to use in the Viewer.
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For more information about adding master templates to a sequence, see “Adding Master
Templates to a Sequence.”
2 Keeping the mouse button held down, drag the new master template from the Viewer
or Browser to the older template clip you want to update in the Timeline.
3 Choose Replace This Template from the overlay that appears, then release the mouse
button.
The template clip beneath the pointer is now linked to the new master template, and its
appearance changes automatically. Any custom parameters, such as text and graphics,
are preserved.
To link all instances of a particular template in a sequence or project to a new master
template
1 Open the new master template you want to use in the Viewer.
See “Adding Master Templates to a Sequence.”
2 Keeping the mouse button held down, drag the new template from the Browser or Viewer
to any template clip that you want to update in the Timeline.
3 Do one of the following:
• Choose Replace All Uses of This Master Template in the Sequence from the overlay
that appears, then release the mouse button.
• Choose Replace All Uses of This Master Template in the Project from the overlay that
appears, then release the mouse button.
All template clips that were linked to the older master template are now linked to the
new template.
Important: When you link a template clip to a new master template, make sure that any
customizable parameters in the old template are also in the new master template.

Converting a Template Clip to a Motion Project
In some situations, you may want to convert a template clip in your sequence to a Motion
project clip. All the parameters you customized in the Motion template are then stored
in the Motion project file, so you can no longer make text or video changes in Final Cut Pro.
For example: You have been using a template clip and a corresponding Motion template
file for the opening title in your sequence. Now, you want to give the graphic designer
full control over every aspect of the design, including the custom text and video. In this
case, Final Cut Pro can make a new Motion project file based on the template file and
your custom content. Then the designer can make updates to the project file in Motion.
To convert a template clip to a Motion project clip
1 Control-click a template clip in your sequence, then choose Send To > Motion Project.
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2 In the dialog that appears, choose a location and enter a name for the new Motion project.
3 If you want the new Motion project to immediately open in Motion, select Launch Motion.
4 Click Save.
A Motion project file is created, based on the template file of the clip. Text and video
parameters you modified in the Controls tab of the Viewer are incorporated directly into
the new Motion project file. The original template clip is replaced with a Motion project
clip that links to the new Motion project file. If you selected the Launch Motion option,
the new project opens in Motion.

Installing Motion Template Files for Use in Final Cut Pro
When you install Final Cut Studio, you can choose to install Motion template files in any
folder you want. By default, Motion template files are stored here:
• /Library/Application Support/Final Cut Studio/Motion/Templates/
When you create your own Motion template files for use as master templates in
Final Cut Pro, Motion saves them here:
• /Users/username/Library/Application Support/Final Cut Studio/Motion/Templates/
Master templates are updated automatically each time you switch to Final Cut Pro; you
do not need to quit and reopen Final Cut Pro to see new master templates.
You can also install Motion template files on a local network to share them simultaneously
among multiple editing systems. The Motion template files should be installed here:
• /Network/Library/Application Support/Final Cut Studio/Motion/Templates/
For more information about sharing settings and files on a local network, see “Audio/Video
Settings and Easy Setups.”
For information about creating template files in Motion, see the Motion User Manual,
available in Motion Help.
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Measuring and Setting Video
Levels

78

This chapter covers the following:
• RGB Color Model (p. 1299)
• Y′CBCR Color Model (p. 1300)
• Measuring Video Levels with the Final Cut Pro Video Scopes (p. 1304)
• Preventing Illegal Broadcast Levels (p. 1315)
• Displaying Excess Luma and Chroma Levels in the Viewer and Canvas (p. 1317)
• Using the Broadcast Safe Filter (p. 1318)
• Using the RGB Limit Filter (p. 1323)
• Working with Analog Video (p. 1325)
• Using Color Bars for Video Calibration (p. 1331)
Features such as the real-time video scopes and the Broadcast Safe filter help you precisely
analyze and control video levels to maintain broadcast standards.
Before you can effectively perform color correction, you need to understand the basics
of what makes up the image of a video file. Video and graphics files can represent color
information several ways. Traditionally, computer-generated video uses RGB color
encoding, while digital video systems use Y′CBCR (sometimes known as YUV video)
encoding.

RGB Color Model
In the retina of the eye, there are three kinds of color receptors, called cone cells. The three
kinds of cone cells are sensitive to the short, medium, and long wavelengths of visible
light, respectively. The RGB color model approximates the way human vision encodes
images by using three primary color channels: red, green, and blue. Emitted light sources
such as CRT monitors, flat-panel displays, and video projectors use the RGB color model,
as do image-capturing devices such as video cameras and computers.
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The RGB color model is additive, which means the red, green, and blue channels combine
to create all the available colors in the system. When all three primary color values are
the same, the result is neutral, or grayscale. For example, if all three primary colors are 0
percent, the result is black. If all three primary colors are 100 percent (the maximum
value), the result is white.
When all three primary color channels are nearly the same strength, the result appears
neutral with a slight color cast, depending on which channel is the strongest. For example,
if the value of the red channel is higher than the value of the blue and green channels,
the result is a slightly red image. Secondary colors are combinations of two primary colors:
red plus green is yellow, green plus blue is cyan, and blue plus red is magenta.

Y′CBCR Color Model
In the RGB color model, all three channels contribute to the perception of brightness. In
the early 1950s, this was a problem when developing a three-channel color television
system that would be compatible with existing black-and-white televisions. The solution
was to encode a single channel that represented luminance—light intensity as perceived
by humans—which existing black-and-white televisions could decode. Color televisions
would receive the same luminance channel and two additional color channels that could
be decoded back into RGB color for display.

Luminance
Luminance is a measure of physical light intensity modified by the spectrum sensitivity
measured in human vision. In other words, red, green, and blue contribute to the
perception of brightness, but not equally. Since two of the cone cell types in the eye favor
light in the green portion of the spectrum, the luminance channel is weighted to mostly
represent the green color channel. This makes the luminance channel appear to have
the equivalent brightness that we see in a color image.
The Y′CBCR color model derives luminance from the Commission Internationale de
l’Eclairage (CIE) XYZ color system, in which the Y component represents luminance (X
and Z represent color components).
In video systems, a gamma adjustment is applied to the RGB color channels to make
efficient use of the bandwidth available for carrying and recording signals. The
gamma-adjusted channels are called R′G′B′, and the derived black-and-white channel is
called Y′, or luma. For more information about gamma, see “About Gamma.”
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Color Difference Channels
The color channels, CB and CR, are derived by subtracting Y from the R and B signals and
are sometimes referred to generally as B-Y and R-Y, or color difference channels. Analog
video systems such as Betacam SP use PB and PR channels, and digital video systems use
CB and CR. Each color channel format performs the same function, but the underlying
specifications are slightly different.
In digital video, the color channels are typically sampled less often than the luma channel,
reducing the video data without noticeable loss of image quality. The ratio of sampling
between the Y′CBCR channels is often written as 4:2:2, 4:1:1, and so on, depending on the
sample rates used. For more information about how color is represented in various video
formats, see “An Overview of Video Format Characteristics.”

Luma
Luma describes the brightness of video, from absolute black, through the distribution of
gray tones, all the way up to the brightest white. Luma is completely separate from the
color of your video. In fact, if you viewed the luma of a video clip by itself, you would see
a grayscale image completely devoid of color.
Luma is measured by Final Cut Pro as a digital percentage from 0 to 100, where 0
represents absolute black and 100 represents absolute white. Final Cut Pro also allows
you to see super-white levels (levels from 101 to 109 percent) if they exist in your clip.
Although super-white video levels are not considered to be broadcast-safe, many
consumer camcorders record video at these levels anyway.
0% luma

100%

109%

Super-white
Black

White

Note: In analog video, luma is measured in IRE units. These IRE measurements are irrelevant
in Final Cut Pro because it deals only with the digital signal that exists in your computer
as a straight percentage from 0 to 100 for NTSC and PAL video. For more information,
see “How Analog Video Signals Are Measured.”
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Blacks, Midtones, and Whites
In the Final Cut Pro color correction filters, most of the controls that you use to correct
your clips are divided into controls over blacks, midtones, and whites. These represent
different overlapping ranges of luma values in your image.
Blacks

Blacks make up the minimum range of luma in your clip. If you looked on a smooth
gradient from black to white, controls that affect the blacks will affect your picture in the
leftmost three-fourths of the gradient, from black to gray. The effect that controls have
over the blacks of an image starts to diminish at approximately 75 percent luma, shown
above. This excludes the brightest parts of your image.
Midtones

Midtones make up most of the gray tones of an image. On the same gradient, controls
that affect the midtones will affect the middle half of the gradient, excluding the deeply
white and black parts. The effect that controls have over the midtones of an image starts
to diminish at 25 and 75 percent luma, shown above. This excludes both the brightest
and darkest parts of your image.
Whites

Whites make up the maximum range of luma in your clip. On this gradient, controls that
affect the whites affect the rightmost half of the gradient, from gray to white. The effect
that controls have over the whites of an image starts to diminish at approximately 25
percent luma, shown above. This excludes the darkest parts of your image.
When you use controls that affect only one of these ranges, all changes made to the hue,
saturation, and luma levels of your picture happen exclusively in the area that falls within
that particular range of luma. This allows you to perform very targeted color correction
only where it’s needed, such as subtly manipulating the hue of the highlights without
touching the shadows, or vice versa.
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Chroma
Chroma describes the color values in your clips, ranging from the absence of color to the
maximum levels of color that can be represented. Chroma has two properties, hue and
saturation.
Hue
Hue describes the actual color itself, whether it’s red or green or yellow. Hue is measured
as an angle on a color wheel.
Red –13°

0°

Magenta 29°

Yellow –77°
Blue 103°

Green –151°

Cyan 167°

Saturation
Saturation describes the intensity of a color, whether it’s a bright red or a pale red. An
image that is completely desaturated has no color at all and is a grayscale image. Saturation
is also measured on a color wheel, but as the distance from the center of the wheel to
the edge.

Colors toward the outer
edge of the color wheel
are more saturated.

As you look at the color wheel, notice that it is a mix of the red, green, and blue primary
colors that make up video. In between these are the yellow, cyan, and magenta secondary
colors, which are equal mixes of the primary colors. These colors are most intense at the
outer rim of the wheel and gradually desaturate to pure white at the center, indicating
the absence of color.
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Measuring Video Levels with the Final Cut Pro Video Scopes
The Final Cut Pro video scopes work similarly to the standard scopes that you’d find in
any online or color correction suite. The scopes provide exact measurements of the luma
and chroma levels of your clips, helping you to unambiguously spot all of the hue,
saturation, and luma levels that differentiate one clip from another. This lets you make
more informed decisions about adjusting Final Cut Pro color correction filters to more
closely match one clip with another.
The following scopes are available:
• Waveform Monitor
• Vectorscope
• Histogram
• RGB Parade

Opening Video Scopes Tabs
You can open multiple Video Scopes tabs and display a different scope in each tab.
To open a Video Scopes tab in the Tool Bench window
1 Choose Tools > Video Scopes (or press Option-9).
Layout pop-up menu
View pop-up menu

The Tool Bench window
appears containing a
Video Scopes tab.

2 Choose which video scopes you want to view from the Layout pop-up menu.
3 Choose the video frame you want to analyze from the View pop-up menu.
For more information, see “Layout Options in Video Scopes Tabs.”
To open and use the Waveform Monitor and Vectorscope during log and capture, see
“Using Built-in Video Scopes During Capture.”
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Layout Options in Video Scopes Tabs
You can choose which scopes and which video source appear in each Video Scopes tab
by using the following controls:
• Layout: Use this pop-up menu to choose one of eight different combinations of single
or multiple scopes for display in the Video Scopes tab. If you choose a single scope
from the list, it takes up the entire space of the Video Scopes tab, making it easier to
see. If you choose one of the multiple-scope layouts, all displayed scopes appear at a
reduced size so that they fit into the Video Scopes tab at the same time.

• View: Use the options in the View pop-up menu to select which frame is being analyzed
in the Video Scopes tab. Choose Current Frame to analyze the current frame at the
position of the playhead in the Canvas. Other options allow you to select various edit
points that are adjacent to the playhead in the currently selected sequence. You can
also choose the frame at the position of the playhead in the Viewer. Choosing None
turns off the scopes altogether.
One way to use this feature is to pair up separate windows with Video Scopes tabs and
Frame Viewer tabs, with each pair of windows set to display different edit points in
your sequence for purposes of comparison.
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Learning to Read the Waveform Monitor
The Waveform Monitor shows you the relative levels of luma and chroma saturation in
the clip currently being examined. These values are displayed from left to right, mirroring
the relative distribution of these levels from the left to the right of the image in the frame.
Spikes and dips in the displayed waveforms correspond to hot spots and dark areas in
your picture.

This dip in the waveform
matches the position of
the dog.
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With the Waveform Monitor set to display saturation, you can compare the relative
saturation levels of two clips by comparing the thickness of their displayed waveforms.
Modifying the saturation of one clip to match that of another is simple; just adjust the
Saturation control of one of the color correction filters in one of the clips to compensate.

An image with high saturation

An image with low saturation
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Learning to Read the Vectorscope
The Vectorscope shows you the distribution of color in your image on a circular scale.
The color in your video is represented by a series of connected points that fall somewhere
within this scale. The angle around the scale represents the hue displayed, with targets
indicating the primary colors of red, green, and blue and the secondary colors of yellow,
cyan, and magenta. The distance from the center of the scale to the outer ring represents
the saturation of the color being displayed. The center of the scale represents zero
saturation, while the outer ring represents maximum saturation.

Red of clothing

Blue of background

The Vectorscope is useful for seeing, at a glance, the hue and intensity of the various
colors in your image. Once you learn to identify the colors in your clips on the graph in
the Vectorscope, you will be better able to match two images as closely as possible
because you can see where they vary. For example, the image above has points of intense
red and areas of vivid blue, which you can spot immediately on the Vectorscope. The
underwater image below contains predominantly blues, which present an entirely different
profile on the Vectorscope. Although this is an extreme comparison, by looking at various
images and studying how the Vectorscope changes you’ll learn how to spot the
information you’re looking for.

Distribution of blues
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The color targets of the Vectorscope scale match the colors in the color balance controls
of the Final Cut Pro color correction filters. If the hues of two shots you’re trying to match
don’t match, the direction and distance of their offset on the Vectorscope scale give you
an indication of which direction to move the color balance indicator to correct for this.
The Vectorscope is also helpful for identifying and correcting the flesh tones of actors in
a shot. When recorded to videotape and measured on a vectorscope, the hues of human
flesh tones, regardless of race, fall along a fairly narrow range (although the saturation
and brightness will vary). This range is identified by a special target line that indicates
the average hue of flesh tones. When there’s an actor in a shot, you’ll know whether or
not the flesh tones are reproducing accurately by checking to see if there’s an area of
color that falls loosely around the Flesh Tone line.

Flesh tones are clustered
about the Flesh Tone line.

As in the previous
image, flesh tones
appear around the
Flesh Tone line.

If the flesh tones of your actors are noticeably off, the offset between flesh colors on the
Vectorscope and the Flesh Tone line will give you an idea of how much to change the
hue to make the correction.
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Learning to Read the Histogram
The Histogram shows you the relative distribution of all luma values in the video frame
at a glance, from black to super-white (assuming the video codec you’re using supports
Y′CBCR processing). It’s really a bar graph of sorts, where the x axis represents a percentage
of luma, from 0 to 110 percent. The height of the line at each step on the scale represents
the number of pixels in the image at that percentage of luma, relative to all the other
values. For example, if you have an image with a lot of black pixels, you would expect to
see a spike in the Histogram near the luma range of 10 to 20 percent.

The height of the spike
represents the number
of pixels in the image
at this percentage
(15 percent) of luma.

The red area of the
histogram indicates pixels
in the super-white range.
The position of the spike
represents 15 percent luma.

The Histogram can be very useful for quickly comparing the luma of two clips so you can
adjust their blacks, midtones, and whites to match more closely. For example, if you were
matching an insert (or close-up) clip to the clip shown above, the overall luma levels
might have shifted because of a change in lighting or exposure. You can easily see such
differences in the Histogram and correct for them. For comparison, the image below has
a lot of whites, so the Histogram shows a cluster of values at the high end of the scale,
with a spike at 96 percent.

The spike is at
96 percent.
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The shape of the Histogram graph is also good for determining the amount of contrast
in an image. A low-contrast image has few pixels in the extreme black and white ranges,
so the Histogram shows a concentrated clump of values nearer to the center of the graph.
By comparison, a high-contrast image has a wider distribution of values across the entire
width of the Histogram and may have spikes at white and black.

Low-contrast image

High-contrast image

Learning to Read the RGB Parade Scope
The RGB Parade scope is like three side-by-side waveform monitors that display your
video as three separate red, green, and blue components. The waveforms are tinted red,
green, and blue so you can easily identify them.

High blue levels
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The RGB Parade scope is useful for comparing the relative levels of red, green, and blue
between two clips. If one clip has more blue than another, the difference shows up as an
elevated blue waveform in the one, and a depressed blue waveform in the other. In the
previous screen shot, the overall image contains quite a bit of blue. By comparison, the
shot of the couple dancing below has substantially less blue and far higher levels of red,
which can be seen immediately in the RGB Parade scope.

This image contains
much less blue than
the previous image.

Choosing Display Options for Video Scopes
Each video scope has several display options you can choose, such as brightness, color,
and standard measurement areas (called targets).

µ

To see video scope options that are currently displayed
Control-click anywhere in a video scope.
Options that are turned on, or displayed, have a checkmark next to them.

The shortcut menu in
the Waveform Monitor

Adjusting Scope and Scales Brightness
The following controls allow you to control brightness of the video scopes. Brightness
control is helpful for revealing minuscule areas that otherwise might be invisible on the
scopes.
• Display brightness: Controls the brightness of the video lines (or traces) shown on each
scope.
• Scales brightness: Controls the brightness of the grid lines (known as graticule lines on
traditional video scopes).
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To change the display or scales brightness of a video scope
1 In the Video Scopes tab, click the Display Brightness or Scales Brightness button above
the video scope readout.

Scales Brightness button
Display Brightness button

Depending on the button you click, the Display Brightness or Scales Brightness slider
appears.
2 Drag the slider to increase or decrease the brightness of the scope.
Display brightness
set low

Display brightness
set high

Additional Video Scope Display Options
You can access the following additional video scope display options by Control-clicking
within a video scope.
• Green, White, Pale, and Bright: The waveforms displayed within all the scopes can be
green or white, depending on which color you find easier to look at. Final Cut Pro
defaults to white, which is the preferred display color because it doesn’t bias the eye
toward any particular color.
Note: In the RGB Parade scope, the waveforms are tinted red, green, and blue, so these
options become Pale and Bright.
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• Saturation: This option is available in the Waveform Monitor only. With saturation
turned off, the waveforms display only the luma of the selected video signal and appear
to be a series of lines or dots. This can be useful if you’re interested solely in the relative
luma of different parts of the video frame. With saturation is turned on, these lines
expand vertically to appear as a much thicker series of waveforms. The thickness of the
waveform represents the amount of saturation in the chroma of your video clip.
Note: The color bar targets displayed in the Waveform Monitor change automatically,
depending on whether or not saturation is turned on.
• Include Black: This option is available in the Histogram only. Turning on this option
scales the Histogram’s height to include the blacks in the picture. Turning off this option
scales the height, ignoring the blacks. You may want to turn on this option if there’s a
lot of black in the clip you’re viewing, to help you get a clearer profile of all the whites
and blacks in the clip. You may turn off this option if you’re performing compositing
tasks, such as placing a small image against a black background, in which case it’s
unnecessary to view the excess black information because you know it’s there.
• Magnify: This option is available in the Vectorscope only. Turning on this option zooms
in on the inner 55 percent of the Vectorscope’s display, letting you see more detail in
images with low saturation.
• Targets: This option displays the ideal targets you use to calibrate a video signal
generated by color bars.

Using Video Scopes in Real Time
Depending on the format of your video and the processing capabilities of your computer,
the Video Scopes tab can update in real time using the same level of quality available in
previous versions of Final Cut Pro.
To turn on real-time updating in the Video Scopes tab
1 Open a sequence in the Timeline.
2 In the Timeline, choose Video Scopes Playback from the RT pop-up menu, so there is a
checkmark next to it.
Note: Using the Video Scopes Playback option requires additional processing power.
Turning on this option could result in a red render bar in the Timeline. Also, the Video
Scopes tab may not update in real time with some formats. For example, playing back
an HDV multiclip requires significant processing power, so the Video Scopes tab may not
update in real time in this situation.

Choosing Video Scope Accuracy
You can choose three levels of analysis accuracy from the RT pop-up menu in the Timeline:
• All Lines: Every pixel of every video line is analyzed, and pixel values are displayed in
the Video Scopes tab. The word “all” appears in the lower-right corner of the Video
Scopes tab.

1314

Chapter 78 Measuring and Setting Video Levels

• All Lines Except Top & Bottom: Displays every line except the top nine and bottom nine
lines, which are reserved for signals such as closed captioning. The word “most” appears
in the lower-right corner of the Video Scopes tab.
• Limited Lines (Fastest): This mode is always used during real-time playback. Accuracy
is limited to 32 lines that are evenly distributed from the top to the bottom of the action
safe area of standard definition video. This is sufficient to catch video elements whose
height equals 5 to 10 percent of the total size of your image.
Important: The accuracy level you choose here affects video scopes when the playhead
is paused or scrubbing; real-time video scope updating always uses the Limited Lines
(Fastest) option.
The lower-right corner of the Video Scopes tab indicates the scope display option selected
in the RT pop-up menu.

Video Scope Restrictions and Performance
The following list describes limitations when using the Video Scopes Playback option in
Final Cut Pro:
• You must be using a format that Final Cut Pro can process in real time. For a list of
formats that Final Cut Pro can process in real time, choose Final Cut Pro > System
Settings, then click Effect Handling.
• The View pop-up menu in the Video Scopes tab must be set to Current Frame (referring
to the Canvas) or Viewer. Options such as Current Frame w/o Filters and Previous Edit
turn off the Video Scopes Playback option.
When checking video scope accuracy, you can analyze all video lines only when playback
is stopped or when scrubbing. The Video Scopes Playback option updates the Video
Scopes tab using the Limited Lines (Fastest) option. For more information, see “Using
Video Scopes in Real Time.”

Preventing Illegal Broadcast Levels
Broadcast facilities have limits on the maximum values of luma and chroma that are
allowable for broadcast. If a video exceeds these limits, distortion can appear in the form
of colors bleeding into one another, the whites and blacks of your program washing out,
or the picture signal bleeding into the audio signal and causing audible distortion. In all
these cases, exceeding standard signal levels can result in unacceptable transmission
quality.
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For this reason, as you are performing color correction on clips in your edited sequence,
you need to make sure that the luma and chroma levels of your video stay within the
parameters referred to as broadcast-legal, or acceptable for broadcast. It is easy to
inadvertently push the levels of clips in your sequence too high, so it’s important to use
Final Cut Pro scopes and range-checking options to make sure that the luma and chroma
levels you set stay legal.

Legal Broadcast Colors
A mistake beginners often make when creating graphics for video is to use colors that
are vivid on the computer display, but have chroma and luma levels that are outside of
the “legal” range of color that can be broadcast. Broadcasters must adhere to these
specifications or risk fines from the FCC. Therefore, if you submit a tape with signals out
of specification, it may not be accepted.
Many graphics and compositing applications have a “broadcast safe” filter that you can
use to limit the color range of a graphic so that it will be broadcast properly without
distortion. However, you should use these filters only as a last resort. It’s best to be aware
of the specifications of the video signal and keep your chroma and luma values within
proper limits.
If your program has been accepted for broadcast, you can usually get a set of guidelines
specifying the broadcaster’s criteria for a legal video signal. The Corporation for Public
Broadcasting has a frequently cited set of guidelines for defining what levels of luma and
chroma are acceptable for broadcast. You will probably be in the clear with most
broadcasters if your program adheres to these guidelines, since they are fairly conservative.
Other broadcast companies publish their own guidelines.
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Displaying Excess Luma and Chroma Levels in the Viewer and
Canvas
The Final Cut Pro range-checking options (in the Range Check submenu of the View
menu) allow you to turn on zebra striping in the Viewer and Canvas to immediately warn
you of areas of your clip’s image that may stray outside the broadcast-legal range. Zebra
stripes appear as animated diagonal “marching lines” that are superimposed over illegal
areas in your picture or areas that are very near the broadcast-legal limits. Additional
icons are displayed to warn you about luma or chroma levels that fall outside the legal
range for broadcast.

Warning icon
Red zebra stripes indicate
luma above 100 percent.
Green zebra stripes
indicate luma from
90 to 100 percent.

Turning on Range Checking
Turning on one of the range-checking options gives you immediate feedback if your clips
have luma or chroma values that are too high for broadcast. These values may be caused
by the way the footage was shot or by filter adjustments that you are making.

µ

To turn on range checking
Choose View > Range Check, then choose an option from the submenu.
The Viewer and Canvas now display zebra stripes whenever illegal levels appear in your
clips.

Options in the Range Check Submenu
You can choose these options from the Range Check submenu of the View menu:
• Excess Luma: If you choose this option, red zebra stripes appear in all areas of the frame
with luma above 100 percent, and green zebra stripes appear in areas of the frame
with luma from 90 to 100 percent. A yellow exclamation point icon indicates luma
that’s too “hot.” A green checkmark indicates that all luma in the picture is legal. An
in-range icon (a green checkmark with an arrow pointed upward) indicates when luma
from 90 to 100 percent is present, with no luma over 100 percent.
• Excess Chroma: When this option is turned on, red zebra stripes appear in areas of the
frame with illegal chroma values. A yellow exclamation point icon indicates chroma
that’s too “hot.” A green checkmark indicates that all chroma in the picture is legal.
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• Both: With this option turned on, red zebra stripes indicate both areas of the frame
with luma above 100 percent and areas of the frame with illegal chroma values. If zebra
stripes appear, a yellow exclamation point icon also appears, indicating that there are
levels that are too hot.
Tip: The Excess Chroma and Both options are especially useful when using one of the
color correction filters. They warn you if you’re raising the chroma of a clip to levels
that are unacceptable for broadcast.

Using the Broadcast Safe Filter
The Broadcast Safe filter provides a quick way to reduce luma and chroma levels that
exceed the broadcast limits for NTSC, PAL, and HD video.
The easiest way to use the Broadcast Safe filter is by choosing one of the presets in the
filter’s Luma/Chroma Mode pop-up menu. The presets provide varying degrees of luma
and chroma limiting depending on the tolerance of your broadcast facility. For more
precise control, you can use the Custom preset to manually adjust the luma and chroma
saturation limits. You can also use the RGB Limiting controls to ensure that your video
levels are acceptable when converted to RGB color (for example, when your video is
displayed on a CRT monitor).

Clamping and Clipping
The Broadcast Safe filter and the RGB Limit filter (see “Using the RGB Limit Filter”) use
clamping to adjust all values above or below a certain threshold to the threshold level.
Clamping creates a waveform whose top or bottom appears flat, or clipped.
Clipping usually refers to signals that have been negatively affected by in-camera
underexposure or overexposure, color space conversion, or improper use of color
correction tools. When you shoot video, you should control your exposure to avoid
clipping. It’s best to start with a signal that doesn’t have clipping and then clamp extreme
levels as needed using a color correction filter.
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Broadcast Safe Filter Controls
The following section describes controls in the Broadcast Safe filter.
Luma/Chroma Mode
pop-up menu

Custom Luminance
Limiting controls

Custom Saturation
Limiting controls
RGB Limiting controls

Luma/Chroma Mode Pop-Up Menu
• Luma/Chroma Mode Pop-Up Menu : Choose one of the presets in this pop-up menu to
decide the maximum allowable chroma saturation. The normal setting of 120 should
work in most situations; however, more conservative settings are available.
Note: The number in the preset refers to the value of the combined luma and chroma
signals, mostly weighted toward the luma signal.

Options in the
Luma/Chroma Mode
pop-up menu

If you choose Custom from the Luma/Chroma Mode pop-up menu, you can use the
sliders in the Custom Luminance Limiting and Custom Saturation Limiting areas to
manually fine-tune clamping of luma and chroma levels. If any mode other than Custom
is chosen, the Custom Luminance Limiting and Custom Saturation Limiting sliders have
no effect.
Custom Luminance Limiting Controls
• Enable: Select or deselect the checkbox to turn on or turn off the Custom Luminance
Limiting controls.
Note: The sliders below have an effect only when this checkbox is selected.
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• Clamp Above: All luma values above this parameter value are clamped to the parameter
value. The lower you set this value, the more clipping occurs at the top of the waveform.
• Max. Output: Compresses the range of values between the Start (Threshold) and Clamp
Above values so the maximum output value is the value set here. Setting this value
higher than the Clamp Above value has no effect. Values below the Start (Threshold)
value clip the signal.
• Start (Threshold): Defines the lowest value affected by the Custom Luminance Limiting
controls.
Custom Saturation Limiting Controls
• Enable: Select or deselect the checkbox to turn on or turn off the Custom Saturation
Limiting controls.
Note: You can still adjust the sliders below, but they have an effect only when this
checkbox is selected.
• Clamp Above: All chroma values above this parameter value are clamped to the
parameter value. The lower you set this value, the more clipping occurs.
• Max. Output: Compresses the range of values between the Start (Threshold) and Clamp
Above values so the maximum output value is the value set here. Setting this value
higher than the Clamp Above value has no effect. Values below the Start (Threshold)
value clip the signal.
• Start (Threshold): Defines the lowest value affected by the Custom Saturation Limiting
controls.
• Reduce Chroma/Luma: When the combination of the luma and chroma signals is too
high and the Broadcast Safe filter can reduce either luma or chroma to make the
combined signal legal, this parameter determines how much luma and chroma are
reduced. When the slider is set to 100 (centered), the filter reduces luma and chroma
equally.
Note: The Custom Luminance Limiting and Custom Saturation Limiting controls are
effective only when you choose Custom from the Luma/Chroma Mode pop-up menu.
RGB Limiting Controls
• Enable: Select or deselect the checkbox to turn on or turn off the Max. RGB Output
Level parameter. When this parameter is enabled, any equivalent RGB values that
exceed the Max. RGB Output Level parameter value are clamped to that value. Negative
RGB values are automatically clamped to zero.
Note: Unlike the Custom Luminance Limiting and Custom Saturation Limiting controls,
this option can always be enabled, regardless of the option currently selected in the
Luma/Chroma Mode pop-up menu.
• Max. RGB Output Level: This parameter value is the maximum RGB-equivalent value
that the filter outputs.
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The Max. RGB Output Level slider goes between 75 and 125; 100 is the default setting.
If you want to reduce RGB levels, set the slider to a value below 100. If you want the
filter to tolerate higher RGB levels, set the slider to a value above 100.
For more detailed control, you can use the RGB Limit filter instead (see “Using the RGB
Limit Filter”).

About Custom Luminance Limiting and Custom Saturation Limiting
The following section gives some examples to show how the Custom Luminance Limiting
and Custom Saturation Limiting controls in the Broadcast Safe filter work.
In the following example, Max. Output parameter values between 95 and 105 are
compressed down to the range between 95 and 100. The shape of the waveform is
preserved.
Start (Threshold)

Clamp Above

Max. Output

105
100
95
90
85
Start (Threshold) = 95

Clamp Above = 105

Max. Output = 100

In the next diagram, values above 100 are clamped, removing details above a value of
100. In this case, the Max. Output parameter has no effect because its value is identical
to that of the Clamp Above parameter.
Start (Threshold)

Clamp Above

Max. Output

105
100
95
90
85
Start (Threshold) = 95

Clamp Above = 100
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In the following diagram, the Clamp Above parameter removes details above a value of
100. Then, the Max. Output parameter compresses the clamped values between 90 and
100 to the range between 90 and 95.
Start (Threshold)

Clamp Above

Max. Output

105
100
95
90
85
Start (Threshold) = 90

Clamp Above = 100

Max. Output = 95

In the following example, the Clamp Above parameter removes details above a value of
100. Then, the Max. Output parameter compresses the clamped values between 90 and
100 down to 90, resulting in a signal that is clamped at a value of 90.
Start (Threshold)

Clamp Above

Max. Output

105
100
95
90
85
Start (Threshold) = 90

Clamp Above = 100

Max. Output = 90

Applying the Broadcast Safe Filter to Nested Sequences
The Broadcast Safe filter should always be the last filter applied to a clip to make sure
other filters that can cause illegal values are corrected. However, in some cases, illegal
values may be generated because of the order in which video is processed in Final Cut Pro.
Here are the video processing steps, in order:
• Filters (filters that appear at the top of the Filters tab in the Viewer are processed first,
followed by filters that appear later)
• Motion parameters such as Scale and Rotation and attributes such as Crop and Distort
• Transitions between two clips in a track
• Compositing modes that blend one or more video clip items together
• Filters applied to the entire sequence (achieved by nesting a sequence and then
applying a filter to it)
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Motion parameters, transitions, and compositing modes can alter the results of the
Broadcast Safe filter applied to individual clips. In these cases, it’s best to create a nested
sequence and then apply the Broadcast Safe filter to the nested sequence. For more
information about nested sequences, see “Methods for Editing Clips from One Sequence
to Another.” This is also more efficient than applying the Broadcast Safe filter to every
clip in your sequence.

Using the RGB Limit Filter
The RGB Limit filter has controls to prevent illegal RGB levels while working in Y′CBCR color
space.

About Illegal RGB Levels
Most video formats are recorded, edited, and transmitted in Y′CBCR (component) color
space. Although you may never intentionally convert your footage to RGB color space, it
is fairly certain that it will become RGB at some point—most likely during display on a
television or monitor. Video is almost always converted to RGB color space within display
devices.
When you work in Y′CBCR color space, levels are either described in their native color
space or they are referred to as RGB-equivalent values, meaning the values of your Y′CBCR
video signal when it is eventually converted to RGB.
Illegal RGB levels are generally caused when certain combinations of luma and chroma
levels (in Y′CBCR color space) are converted to RGB color space. Even if both luma and
chroma levels are legal in Y′CBCR color space, the combination of these two may cause
illegal RGB levels.
Tip: The RGB Parade scope in the Video Scopes tab is useful for viewing RGB levels when
working in Y′CBCR color space. For more information, see “Learning to Read the RGB
Parade Scope.”
Legal RGB levels are usually defined as 0 percent to 100 percent, where 0 percent is the
lowest legal value and 100 percent is the highest. When Y′CBCR footage is converted to
RGB, RGB levels can be illegal in two ways: if they are below 0 percent or above 100
percent.
Note: If your video originated using a codec that is already in RGB color space (such as
the Animation codec), it is unlikely that the RGB levels are illegal.
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RGB Limit Filter Controls
The following section describes the controls in the RGB Limit filter.

Minimum RGB Limiting
controls
Maximum RGB Limiting
controls
Maximum RGB Reduction
controls

Minimum RGB Limiting Controls
• Enable: Select or deselect the checkbox to turn on or turn off RGB clamping below the
Clamp Levels Below parameter value.
• Clamp Levels Below: Set a value to define the minimum allowable RGB levels. RGB levels
below this parameter value are clamped to this value.
Maximum RGB Limiting Controls
• Enable: Select or deselect the checkbox to turn on or turn off RGB clamping above the
Clamp Levels Above parameter value.
• Clamp Levels Above: Set a value to define the maximum allowable RGB levels. RGB levels
above this parameter value are clamped to this value. For example, if your image has
RGB-equivalent levels of 115 percent, 110 percent, and 105 percent, and you set this
slider to 105 percent, the RGB levels are set to 105 percent, 105 percent, and 105 percent.
Maximum RGB Reduction Controls
• Enable: Select or deselect the checkbox to turn on or turn off chroma desaturation,
luma reduction, or both, if necessary.
• Desaturate or Darken Levels Above: Applies chroma desaturation, luma reduction, or
both, to bring RGB levels down to the value set here.

How the RGB Limit Filter Works
The RGB Limit filter processes your video in 32-bit floating-point RGB color space and
then outputs the native color space of your footage (either RGB or Y′CBCR). The high
precision of this color space minimizes quality loss in your video during processing.
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The RGB Limit filter affects only RGB-equivalent values above the Clamp Levels Above
parameter value and below the Clamp Levels Below parameter value. The filter applies
up to three stages of level reduction at a time, as necessary:
• Clamping: Levels above the Clamp Levels Above parameter value are clamped to the
parameter value. Levels below the Clamp Levels Below parameter value are clamped
to the parameter value. For example, if the Clamp Levels Above slider is set to 100
percent, all RGB levels above 100 percent are clamped to 100 percent.
• Chroma desaturation: After clamping, any pixel with an RGB level above the Desaturate
or Darken Levels Above parameter value is desaturated until the red, green, or blue
channel reaches the parameter value. Desaturation is an effect easily understood in
Y′CBCR color space: the color difference channels are merely reduced. However, in RGB
color space, desaturation is achieved by reducing the level of the color channel with
the highest level while simultaneously increasing the levels of the two channels with
lower levels. This reduces saturation while maintaining the same luma level. A pixel
with equal RGB channel levels has no saturation (in other words, the pixel is
black-and-white only—like the luma channel in Y′CBCR color space) and therefore
cannot be desaturated.
• Luma reduction: Finally, for any RGB levels that still remain above the Desaturate or
Darken Levels Above parameter value after desaturation, luma levels are reduced so
they are at the level set by the Desaturate or Darken Levels Above slider. Reducing
luma levels in RGB color space is achieved by simply reducing the levels of all three
channels simultaneously.

Working with Analog Video
If you need to output video to an analog format, make sure you understand how digital
signal levels in Final Cut Pro are translated to analog levels.

How Analog Video Signals Are Measured
Analog video is measured using IRE units. (IRE originally stood for Institute of Radio
Engineers, which has since merged into the modern IEEE organization; the measurement
is a video-specific unit of voltage.) One IRE is 7.143 millivolts, but it’s easier to remember
that an analog video signal has a range of 1 volt, which spans 140 IRE units.
Synchronization pulses, which are necessary for an analog television broadcast, are located
between -40 and 0 IRE.
PAL and Japanese NTSC systems have luma (or Y′) values between 0 IRE (black) and 100
IRE (white), although higher values are possible. Signals above 100 IRE are considered
illegal for broadcast. North American NTSC systems set black at 7.5 IRE. This extra 7.5 IRE
is called setup or pedestal (because it pushes the entire image higher on the waveform
monitor).
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How Digital Video Signals Are Measured in Final Cut Pro
The Final Cut Pro Waveform Monitor displays Y′CBCR values as percentages instead of bit
values because digital video can use 8 or 10 bits per luma sample. Using 8 bits provides
up to 256 tones from black to white, although the actual range used in Y′CBCR video is
16 (black) to 235 (white). The remaining values, 236 through 254, provide additional
headroom used to record super-white levels such as specular highlights on shiny objects.
Percentage in Final Cut Pro
Waveform Monitor

Values for 8-bit Y′CBCR

Values for 10-bit Y′CBCR

-10%

n/a

n/a

0% (black)

16

64

100% (white)

235

940

109% (super-white)

254

1019

Using an External Waveform Monitor and Vectorscope to Calibrate
Analog Video Levels
The scopes in Final Cut Pro display the digital values of your video as it exists in its captured
state, but the software scopes can’t measure input and output analog signal levels from
and to your FireWire device or third-party video interface. If you like, you can set up your
Final Cut Pro workstation with a dedicated waveform monitor and vectorscope for
measuring and adjusting video input and output more accurately.
This involves using two pieces of external video hardware:
• Processing amplifier (or “proc amp”): A proc amp provides hardware control of luma, or
video gain (brightness), chroma gain (saturation), hue, and setup (black level). By
connecting a proc amp between your analog VTR and your video interface, you can
precisely control the incoming Y′CBCR video signal.
Note: Some VTRs have a built-in proc amp.
• Hardware waveform monitor or vectorscope: Having a dedicated hardware waveform
monitor or vectorscope enables you to measure the actual analog Y′CBCR output from
your video interface.

Input A

PCI card
Input B
Analog or digital VTR
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Proc amp

Computer
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Standard definition
monitor

Waveform monitor/
vectorscope

Outputting Accurate Analog Black Levels Using DV FireWire
Outputting analog video from Final Cut Pro requires a video interface with a
digital-to-analog converter. Many third-party interfaces include analog outputs.
Alternatively, you can use a DV deck or camcorder to convert a digital signal via FireWire
to an analog signal for recording to tape. This is the same configuration you would use
to monitor DV FireWire output from Final Cut Pro on a standard video monitor.
If you output to analog tape using the built-in FireWire interface of your computer with
a consumer DV device, keep in mind that not all DV devices use the same analog black
level. Digital video always has a digital black value of 0 percent, but some DV devices
convert this value to 0 IRE and others convert this value to 7.5 IRE.
Professional video facilities are fairly stringent about keeping black setup levels at precisely
0 IRE for PAL and for NTSC in Japan, and at 7.5 IRE for NTSC in North America. If your DV
device outputs at the wrong analog black level, you may need to use a hardware proc
amp to adjust your analog video signal accordingly.
If you are outputting back to analog tape using a third-party analog video interface, you
should check the documentation that came with the video interface to determine how
to configure the video interface for the North American standard for setup (7.5 IRE) or
the Japanese standard (0 IRE). Most vendors of analog video interfaces include a software
control panel that allows you to select which black level to use. Most vendors label this
as “7.5 Setup” versus “0 Setup,” or in some cases “NTSC” versus “NTSC-J.” For more
information, see “How Analog Video Signals Are Measured.”
The following is a typical configuration for calibrating the analog black levels coming
from your digital-to-analog converter (in a DV deck or digital-to-analog converter):
• Using FireWire, Final Cut Pro outputs video with black at the industry-standard digital
value of 16 (as specified by the ITU-R BT.601-4 engineering specification for video). This
is the correct level for black for digital video.
• The analog outputs of your VTR are connected to a proc amp that you can use to adjust
the analog black level, or setup.
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• The signal from the proc amp is connected to a video monitor and then to a waveform
monitor, where you can measure to make sure the proc amp is adjusted for proper
black levels. For NTSC signals in North America, you should adjust the proc amp so that
the waveform monitor shows a black level of 7.5 IRE. For PAL and NTSC in Japan, the
output signal should be 0 IRE.

Analog video out
to recording deck
Analog
video out

FireWire

Computer

DV VTR

Analog video
through

Analog out

Proc amp

Standard definition
monitor

Waveform monitor/
vectorscope

Using Built-in Video Scopes During Capture
If you are capturing analog video footage using a third-party video interface, you can use
the Log and Capture video scopes to calibrate the video interface input settings to the
color bars at the beginning of each tape. Final Cut Pro saves individual image-control
settings with each clip you log. You can then have Final Cut Pro capture your offline clips
using these individually saved image-control settings.
Adjusting Capture Settings with the Log and Capture Video Scopes
The video scopes in the Log and Capture window include the Waveform Monitor and
the Vectorscope. If you are capturing to a Y′CBCR video format, the entire range of the
scope is displayed (from –10 percent to 109 percent). However, if you are capturing to
an RGB codec, the range is limited to 0 percent to 100 percent.
To use the built-in Log and Capture video scopes to adjust your clip settings
1 Make sure your video deck is connected to the video interface in your computer.
2 Cue the videotape to the color bars recorded at the beginning of the tape.
3 Choose File > Log and Capture, click the Clip Settings tab, then click the Video Scopes
button.
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The Waveform Monitor and Vectorscope appear below the Log and Capture window. On
the left is the Waveform Monitor, which displays the brightness levels of the color bars
within the video frame as a graph. Each “step” of the graph corresponds to one of the
color bars. The goal is to adjust the brightness and contrast so that the levels of the bars
match their ideal targets, shown in purple.

Waveform Monitor

Vectorscope

Note: Don’t worry if the graph appears to be “noisy”; this is normal for analog video
played back from tape.
4 To display the ideal targets for color bars, Control-click in the Waveform Monitor or the
Vectorscope and choose Targets from the shortcut menu.

Choose Targets from the
shortcut menu.

5 Adjust video brightness and contrast using the Waveform Monitor for reference.
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Different third-party video interfaces have different controls for adjusting the video signal
being captured.
• If your video interface uses Brightness and Contrast sliders: Make the following adjustments.
• Adjust the Brightness slider so that all of the bars in the Waveform Monitor are set
near the upper purple targets in the background.
• Adjust the Contrast slider so that the tops of the bars and the bottoms in the
Waveform Monitor are within the boundaries of the top and bottom targets.
• Continue adjusting the Brightness and Contrast sliders until there is an acceptable
range of brightness between the 100 and 0 percent targets.
• If your interface uses Black Level and White Level sliders: Make the following adjustments.
• Adjust the Black Level slider so that the third bar from the left is at the 0 percent
target toward the bottom of the Waveform Monitor.
• Adjust the White Level slider so that the second bar from the left is at the 100 percent
target at the top of the Waveform Monitor.
6 Adjust the clip’s hue and saturation using the Vectorscope for reference.
The Vectorscope is on the right and displays the color values of the different areas of the
video frame as a point graph. Each point on the circular graph represents one of the color
bars. The goal is to line up these points with their respective targets.

• Adjust the Hue slider to rotate the points around the center of the graph.
• Adjust the Saturation slider to move the points closer to or farther from the center of
the graph. If this slider is properly adjusted, each point falls within a purple target box.
Adjusting Capture Settings on Source Tapes Without Color Bars
If there are no color bars on your source tapes, you can adjust your tapes using the flesh
tones of people in the shot. As long as a person’s skin tones look accurate, chances are
the rest of the colors in that shot will look fine. To help you find the correct flesh tone, a
special marker appears in the Vectorscope to the left of the center of the Vectorscope
scale. This line indicates the hue of a person’s skin tones.
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Regardless of race, the hues of human flesh tones, when recorded to videotape and
measured on a vectorscope, fall along a fairly narrow range (although the saturation and
brightness vary).
To adjust color on source tapes using flesh tones
1 Cue your tape to a section that has a well-lit facial closeup.
2 Check to see if there’s a spike on the Vectorscope near the Flesh Tone line.
3 Adjust this spike so that it falls approximately along the Flesh Tone line. While doing so,
check the image quality of your clip on a broadcast monitor to make sure that your
adjustment is accurate.
The Flesh Tone line is only meant to be an approximation; it’s more important that the
shot look correct than that it fit this line exactly.

The Flesh Tone line is
here on the Vectorscope.

Using Color Bars for Video Calibration
When using analog devices, make sure they are calibrated for accurate brightness and
color so there’s no distortion when you capture and color correct your video.

About Color Bars
Color bars are electronically generated video signals that meet very strict specifications.
Because the luma and chroma levels are standardized, you can use color bars passing
through different components of a video system to see how each device is affecting the
signal. For example, if you record color bars that have a 100 percent white level in a
camcorder and then play the videotape back on a VTR, and if the white level output from
the VTR is only 90 percent, you know that you need to increase the luma level output of
the VTR.
NTSC and PAL each have specific color bar standards, and even within NTSC and PAL
there are several standards. When you evaluate color bars on a video scope, it is important
to know which color bar standard you are measuring, or you may make improper
adjustments. “SMPTE bars” is a commonly used standard.
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When Should You Use Color Bars?
Analog devices always need to be calibrated and adjusted, even if only by minute degrees.
This is because heat, age, noise, cable length, and many other factors subtly affect the
voltage of an analog electronic video signal, which affects the brightness and color of
the video image. Color bars provide a reference signal you can use to calibrate the output
levels of an analog device.

Using Color Bars to Adjust Brightness and Color
Broadcast video professionals use color bars to calibrate the output of analog video
devices such as:
• Playback VTRs used for capturing analog video into your editing system
• Your video editing system’s video interface analog output (for output to analog video)
• Playback VTRs used for dubbing tapes to VHS
Typically, 30 to 60 seconds of color bars is recorded at the beginning of each new
videotape shot in the field. Color bars from a professional camcorder are used to calibrate
the on-location video monitor used to watch what’s being shot, so that adjustments for
brightness or color temperature made to the camcorder are made accurately. Later, the
color bars recorded at the head of each source tape are used to calibrate the clip settings
in Final Cut Pro. If you don’t have color bars on your tape, see “Adjusting Capture Settings
on Source Tapes Without Color Bars.”
Each source tape should be individually calibrated because tapes from various camcorders
may have slightly different settings, and because even a single camcorder may have
fluctuated slightly over the course of the production.

Calibrating Video Monitors with Color Bars
Videographers don’t rely on the viewfinder of a camcorder to adjust the image being
recorded. Viewfinders and camcorder LCD displays are often too small and have color
fidelity that’s too inaccurate to ensure proper focus, brightness, and color adjustments.
Instead, a properly calibrated video monitor can be set up on location to monitor the
video during shooting.
Similarly, editors and broadcast designers shouldn’t rely on an uncalibrated monitor when
making crucial adjustments to the color and brightness of their movie footage. Instead,
it’s important to use a calibrated broadcast monitor to ensure that any adjustments made
to exposure and color quality are accurate.
Monitors are calibrated using SMPTE standard color bars. Brightness and contrast are
often adjusted by eye, using the color bars onscreen. Adjusting chroma and phase involves
using the “blue only” button found on professional video monitors. This calibration should
be done to all monitors in use, whether they’re in the field or in the editing room.
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To calibrate your monitor
1 Connect a color bar or test pattern generator to the monitor you’re using.
Alternatively, you can use one of the built-in color bar generators in Final Cut Pro. Avoid
using still-image graphics of color bars.
2 Turn on the monitor and wait at least 10 minutes for the monitor to reach a stable
operating temperature.
3 Select the appropriate input on the video monitor so that the color bars are visible on
the screen.
Near the bottom-right corner of the color bars are three black bars of varying intensities.
Each one corresponds to a different brightness value, measured in IRE. These are the
Picture Lineup Generation Equipment (PLUGE) bars, and they allow you to adjust the
brightness and contrast of a video monitor by helping you establish what absolute black
should be.
4 Turn the chroma level on the monitor all the way down.
This is a temporary adjustment that allows you to make more accurate luma adjustments.
The chroma control may also be labeled “color” or “saturation.”
5 Adjust the brightness control of your monitor to the point where you can no longer
distinguish between the two PLUGE bars on the left and the adjacent black square.
At this point, the brightest of the bars (11.5 IRE) should just barely be visible, and the two
PLUGE bars on the left (5 IRE and 7.5 IRE) should appear to be the same level of black.
Note: The brightness control adjusts the black level of your video signal by changing the
offset of the red, green, and blue signals.
6 Now, turn the contrast all the way up so that this bar becomes bright, and then turn it
back down.
The point where this bar is barely visible is the correct contrast setting for your monitor.
(The example shown below is exaggerated to demonstrate.)
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Note: The contrast control adjusts how much the RGB signals are scaled.

When monitor brightness and
contrast are properly adjusted,
this strip should barely be
visible above black.

When adjusting the contrast, also watch the white square in the lower left. If the contrast
is too high, the white square appears to “spill” into the surrounding squares. Adjust the
contrast until the luma of the white square no longer spills into surrounding squares.
7 Once you have finished adjusting luma settings, turn up the chroma control to the middle
(detent) position.
Note: Some knobs stop subtly at a default position. This is known as the detent position
of the knob.
8 Press the “blue only” button on the front of your monitor.
Note: This button is usually available only on professional monitors.
Notice how all of the different-colored bars turn into alternating light and dark ones.
• If your monitor is correctly calibrated: All the gray bars will be evenly gray, and all the
black bars evenly black.
• If the two outer gray bars don’t match: Adjust the chroma control of the monitor until
they do. Then adjust the phase control to even out the inner bars.

When the phase (similar
to hue) of the monitor is
correctly adjusted, you
should see alternating
bars of gray and black,
as shown.
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Note: NTSC and PAL video have brightness and contrast levels that are very different
from those of RGB computer displays. Broadcast video viewed on a computer display
often looks dull and dark, whereas the same video viewed on a broadcast monitor will
be bright and clear. For this reason, the color bars above are shown for reference only
and not to reflect what you should be seeing.
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This chapter covers the following:
• Why Color Correct Your Footage? (p. 1337)
• Color Correction Starts During Your Shoot (p. 1339)
• Managing Color During Post-Production (p. 1340)
• The Final Cut Pro Color Correction Process (p. 1342)
In any post-production workflow, color correction is generally one of the last steps in
finishing an edited program. Final Cut Pro color correction tools give you precise control
over the look of every clip in your project by letting you adjust the color balance, black
levels, midtone levels, and white levels of individual clips.

Why Color Correct Your Footage?
There are a number of reasons why you may want to color correct your footage:
• Make sure that key elements in your program look the way they should: Every scene of
your program has key elements that are the main focus of the viewer. In a narrative or
documentary video, the focus is probably on the people in the shot. In a commercial,
the key element is probably a product shot, such as the label of a bottle or the color
of a car. Regardless of what these key elements are, chances are you or your audience
will have certain expectations of what they should look like. You can use color correction
to make the colors reproduced by video match what was originally shot.
With people shots, one of the guiding principles of color correction is to make sure
that flesh tones on tape look the same as in real life. Regardless of race, the hues of
human flesh tones, when recorded to videotape and measured on a vectorscope, fall
along a fairly narrow range (although the saturation and brightness vary). Final Cut Pro
color correction tools allow you to make whatever adjustments are necessary to ensure
that the flesh tones of people in your final edited piece look the way they do in reality.
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• Balance all the shots in a scene to match: Most edited programs incorporate footage
from a variety of sources, shot in multiple locations over the course of many days,
weeks, or months of production. Even with the most skilled lighting and camera crews,
differences in color and exposure are bound to occur, sometimes within clips meant
to be combined into a single scene. When edited together, these changes in color and
lighting can make individual shots stand out, so the editing appears to be uneven. With
careful color correction, all the different clips that make up a scene can be balanced to
match one another so that they all look as if they’re happening at the same time and
in the same place, with the same lighting.
• Correct errors in color balance and exposure: Accidents can happen in any shoot. For
example, you may have forgotten to white balance your video camera before shooting
an interview in an office lit with fluorescent lights, resulting in footage with a greenish
tinge. Final Cut Pro color correction filters give you an exceptional degree of control
over the color balance and exposure of your clips, allowing you to fix these kinds of
mistakes. In many cases, such accidents can be minimized, if not eliminated, through
the careful application of color correction filters.
• Achieve a “look”: The process of color correction is not simply one of making all the
video in your piece match some objective model of black, white, and color tones. Color,
like sound, is a property that, when subtly mixed, can result in an additional level of
dramatic control over your program.
With color correction, you have control over whether your video has rich, saturated
colors or a more muted look. You can make your shots look warmer by pushing their
tones into the reds, or make them look cooler by bringing them into the blues. You
can decrease the contrast of your clips, pulling details out of the shadows, or increase
your contrast for a harsher look. Such subtle modifications can alter the audience’s
perception of the scene being played, changing the mood of your program. Once you
pick a look for your piece, or even for an individual scene, you can use color correction
to make sure that all of the shots in the appropriate scenes match, so that they cut
together smoothly.
• Create contrast or special effects: Color correction can also be used to create contrast
between two scenes for a more jarring effect. Imagine cutting from a lush, green jungle
scene to a harsh desert landscape that’s much more in the reds and yellows. Using
color correction, you can subtly accentuate these differences. You can also create more
extreme effects, such as manipulating colors and exposure to achieve a day-for-night
look. You can even selectively target a narrow range of colors to alter or replace only
those color values, turning a red car blue, for example.
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Color Correction Starts During Your Shoot
It’s important to remember that the process of determining the overall look of your video
begins when your scenes are lit and shot during production. To have the maximum
amount of control over your clips in post-production, you need to start out with footage
that has been exposed with your end goals in mind right from the beginning. Color
correction in post-production is no substitute for good lighting.
Optimistically, the process of color correction can be seen as extending and enhancing
the vision of the producer, director, and cinematographer or videographer as it was
originally conceived. Often, the cinematographer or videographer gets personally involved
during the color correction process to ensure that the look he or she was trying to achieve
is perfected.
At other times, the director or producer may change his or her mind regarding how the
finished piece should look. In these cases, color correction might be used to alter the
overall look of the piece (for example, making footage that was shot to look cool look
warmer, instead). While this degree of control is possible, it’s still important to start out
with clean, properly exposed footage.

Using a Chip Chart in Production
In many productions, a chip chart is placed next to the slate at the beginning of every
shot. This chart can be used during post-production to unambiguously correct each shot
so that the color balance of your images can be perfectly corrected. This then gives the
colorist a good neutral starting point for the color correction process.
Chip charts are especially useful during multicamera shoots with consumer-grade
camcorders. The white balance settings on such cameras often won’t precisely match,
even if manually adjusted. This can make cutting back and forth within a scene problematic
because you’ll be cutting from one color temperature to another. If, however, you shoot
a chip chart along with the slate at the beginning of each shot for each camera, you can
use this to color correct the footage from every camera used in the shoot, so that all your
shots match.
Example of a chip chart used
for color calibration. Chip
charts can be obtained at
a professional video store.
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Managing Color During Post-Production
The way you manage color in your program depends on whether your source video was
transferred from film or shot on tape. There are several ways to color correct a project.
The one that works for you depends on how you’re finishing your program, as well as
your project’s post-production budget.

Telecine Color Correction
If you shot your project on film but you’re editing on video, you must first use a machine,
called a telecine, to take the images from your negatives and convert them to the videotape
format of your choice prior to editing. Any colorist running this first telecine session will
be performing some level of color correction as the video is transferred, to ensure that
the editor has the most appropriate picture to work with.
The goals of color correction at this stage depend on the length of the project.
• Short projects, commercials, spots, and very short videos may get a detailed color
correction pass right away. The colorist will first calibrate the telecine’s own color
corrector to balance the whites, blacks, and color perfectly. Then the colorist, in
consultation with the cinematographer, director, or producer, will work shot by shot
to determine the look of each clip according to the needs of the project. As a result,
the editor will be working with footage that has already been corrected.
• Long-form projects such as feature-length films and longer television programs probably
won’t get a detailed color correction pass right away. Instead, the footage that is run
through the telecine will be balanced to have the best blacks, whites, and color possible,
and left at that.
In both cases, the transferred tapes are then edited the same as any other project. Once
editing has been finished and the picture is locked, a list of selected shots called a cut list
or pull list is created that details exactly which shots were used during the edit. (The shots
used during the edit are matched with the original shots using edge code numbers that
are transferred along with the video.)
Using the cut list, the post-production supervisor has the option of pulling only the film
negative that was actually used. Because this is usually a minority of the footage that was
shot, the colorist now has the time to perform a more detailed color correction pass only
on the selected footage. This is accomplished during a second telecine pass.
Although this might seem redundant, performing color correction directly from the film
negative has distinct advantages. Because film has greater latitude from black to white
than video has, a colorist working straight off the telecine has greater control of color
and exposure than one working only with videotape.
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After the second color correction pass, the color-corrected selects are reassembled to
match the original edit, and the project is mastered to tape.

Perform initial
correction pass

Edit

Color correct
shots in cut list

Reassemble
color-corrected clips

Other Advantages of Telecine Transfers
In addition to color correction, a colorist working with a telecine has many other options
available, depending on what kinds of issues may have come up during the edit.
• Using a telecine to pull the image straight off the film negative, the colorist can
reposition the image to include parts of the film image that fall outside the action safe
area of video.
• With the telecine, the image can also be enlarged optically up to 50 percent without
distortion.
• The ability to reframe shots in the telecine allows the director or producer to make
significant changes to a scene, turning a medium shot into a close-up for dramatic
effect, or moving the entire frame up to crop out a microphone that’s dipped
inadvertently into the shot.

Tape-to-Tape Color Correction
With projects shot on videotape, the color correction process tends to be a little simpler.
There is not usually much attention paid to fine-tuning the video being digitized for an
offline edit. Once you begin your online edit on a nonlinear editor (NLE), each tape is
calibrated to match the color bars at the head of the tape whenever you’re recapturing
your footage at its highest quality for final output, to ensure that the colors are correct.
If you’re doing your online edit in a tape suite, the online editor takes care of this step.
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Once the edit has been locked and the final master tape created, the tape can be taken
to an online suite capable of tape-to-tape color correction. The master tape is run through
a color corrector, and the colorist uses the tape’s master timecode to set up color correction
settings for every shot of every scene. Once this setup is complete, the entire tape is run
through the color corrector and rerecorded to another tape.

Perform
online edit

Perform color correction
pass in online suite

Output new
master tape

Color Correction in Final Cut Pro
With as much control as they afford, telecine sessions tend to be expensive, especially
for longer projects. Tape-to-tape color correction can also be expensive, but in both cases
you’re paying to work with a professional colorist who has years of experience. Color
correction requires a practiced eye and careful attention to detail, because it is this final
step that really differentiates the look of low-budget video programs from professional
broadcast TV.
With Final Cut Pro, you have professional color correction tools at your disposal. Controls
that allow automatic adjustments of blacks and whites give even the beginner a basic
starting point from which to proceed. With patience and practice, you can learn to work
with these tools to achieve sophisticated color correction right on your desktop. With a
fast enough computer or a third-party capture card with real-time processing, Final Cut Pro
color correction filters can even operate in real time, eliminating the need to render every
color-corrected clip.
You can also color correct your footage using the sophisticated features of the Color
application. For more information about transferring your footage to Color for grading,
see “Color Correction with Color.”

The Final Cut Pro Color Correction Process
As mentioned earlier, color correction has several goals. To outline the process of color
correction, this section focuses on two of those goals:
• Making the actors or key elements of your scene look the way they should
• Determining the overall look that you want for the scenes making up your movie
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Every video project consists of a series of scenes. Although scenes may differ in color and
tone—one scene taking place at night, the next one happening in the midday sun—all
the shots within a given scene should match. The goal is to make sure that the transitions
from shot to shot within a scene are smooth. If one shot is brighter or redder than the
one next to it, the result can be similar to a jump cut, distracting the viewer and making
your project look unprofessional.
The overall process of color correcting different shots in a scene to match one another
involves five stages.
Stage 1: Picking the Master Shot of a Scene to Use as the Basis for Color Correction
If you’re color correcting a scene consisting of a single shot, your job is pretty easy. All
you need to do is find the settings that work best for that one shot. Most scenes, however,
cut between a variety of different shots, such as close-ups, medium shots, and wide shots.
In every scene, there is usually a single wide shot that encompasses the entire scene,
called a master shot. Traditionally, the master shot is the first shot that is taken for a scene,
and it is used as the basis for that scene. After the master shot, you’ll typically use a series
of medium shots and close-ups. These other shots are called coverage, because they’re
often used to cover different edits made in the scene.
When you color correct a scene, you begin with the master shot, because that’s usually
the establishing shot of your scene. Using the master shot as the basis, you can then
make the colors of the coverage shots match those of the master.
Stage 2: Performing Primary Color Correction
Primary color correction refers to two basic steps that you take using one of the Final Cut Pro
color correction filters. After you apply the Color Corrector or Color Corrector 3-way filter,
you’ll perform two steps:
• Adjust the blacks and whites to maximize the contrast of your clip.
Essentially, you’re mapping the blackest black in your clip to a value of 0 and the whitest
white to a value of 100. By doing this first, you widen the range that an underexposed
image covers, or bring down overly bright (or super-white) areas of overexposed video
into the range considered to be broadcast-safe.
• Use the appropriate color balance controls of the color correction filter to make
adjustments to the balance of reds, greens, and blues in your shot.
As you make these adjustments, you’ll want to view your clip on your broadcast video
monitor as well as check the clip’s luma and chroma levels in the Video Scopes tab to
make more informed modifications.
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Stage 3: Adding Additional Color Correction as Necessary
It’s important to remember that you don’t have to do everything with a single application
of a color correction filter. For example, if you can’t get the colors in both the dimly lit
areas and the highlights of your clip right with a single filter, focus only on the dimly lit
area. You can then adjust the highlights with a second application of a color correction
filter.
The way this works is that each color correction filter has a set of Limit Effect controls
that you can use to isolate a region of your clip based on color, luma, saturation, or any
combination of the three. The Limit Effect controls work in much the same way as a
chroma or luma keyer, except that instead of keying the color out, they limit the effect
of the color correction filter to just that area. This way, you can target the green grass,
the highlights in the trees, and the red lipstick of an actor in the scene with three separate
filters, giving you an extremely fine level of control over your image.
Stage 4: Adding Other Filters to Address Specific Needs
After you’ve finished adding all the color correction filters necessary, you may find yourself
with some additional issues to resolve. Perhaps you can’t correct certain areas of your
clip without introducing unwanted color into the shadows or highlights. In this case, you
can use an additional filter, the Desaturate Highlights or Desaturate Lows filter, to correct
this quickly and easily. In another example, you may have discovered that the combination
of filters you’re using forces the chroma or luma to extend into levels illegal for broadcast.
In this situation, you can use the Broadcast Safe filter to bring down the offending parts
of the picture to acceptable levels.
Stage 5: Matching the Coverage of the Scene to the Master Shot
Once you’ve finished defining the look of the master shot in your scene, you can move
on to the rest of the shots. It’s easy to copy the settings of the color correction filters
you’re using to other pieces of the same master shot that you may have used in the same
scene. For example, if you cut back to the master shot five times in your scene, you can
simply copy the filters from the first piece of the master shot you corrected to all other
instances used in your sequence.
As you move into the coverage shots used in the scene, you’ll probably repeat stages 2
through 4 for each shot. You can compare each new shot with the master shot that you
corrected, switching back and forth rapidly to compare the look of one clip with that of
the other. By comparing the clips’ values on the video scopes, you’ll see how you need
to adjust the color correction filters you apply to make the clips’ color, blacks, and whites
match as closely as possible.
Remember, once you finish correcting one segment of a given clip, you can apply those
same settings to all other segments in that scene from the same clip. If you apply multiple
color correction filters to one clip, you can also apply them all to other clips.
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Color Correction Features

80

This chapter covers the following:
• Color Correction Features in Final Cut Pro (p. 1345)
• Using Scopes Versus Looking at an External Monitor (p. 1346)
• Window Layouts for Color Correction in Final Cut Pro (p. 1347)
Final Cut Pro includes powerful color correction features that let you analyze clips in your
project and perform color correction on them.

Color Correction Features in Final Cut Pro
You can use the following features in Final Cut Pro to help color correct your footage and
maintain proper video levels.
Measurement and Evaluation Tools
These tools are used for subjective and objective measurements of your video signal.
• External video monitoring: Viewing video on an external monitor is critical for evaluating
the visual quality of your footage during color correction. See “Using an External Video
Monitor While You Edit.”
• Video Scopes tab: The Video Scopes tab in the Tool Bench window can help you spot
illegal levels and level differences between clips so you can make precise level
adjustments. See “Measuring Video Levels with the Final Cut Pro Video Scopes.”
• Range-checking tools: Range-checking options available in the View menu allow you
to quickly spot illegal luma and chroma levels in your clips so you can fix them prior
to tape output. See “Displaying Excess Luma and Chroma Levels in the Viewer and
Canvas.”
Window Layouts and Keyboard Shortcuts
• Window layouts: Final Cut Pro includes several window layouts designed for color
correction. See “Window Layouts for Color Correction in Final Cut Pro.”
• Keyboard shortcuts: Several keyboard shortcuts speed up navigation between clips to
make matching color between adjacent shots easier. See “Finding and Selecting Content
in the Timeline.”
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• Frame Viewer windows: You can use Frame Viewer windows to compare the color of
adjacent sequence clips in a single frame. See “Comparing Two Frames in the Frame
Viewer.”
Color Correction Filters
The Color Corrector, Color Corrector 3-way, and RGB Balance filters are the main filters
you use for matching color between shots and making aesthetic color changes. The
Broadcast Safe, RGB Limit, Desaturate Highlights, and Desaturate Lows filters are used to
correct illegal video levels and to correct black and white color casts. See “Color Correction
Filters.”

Using Scopes Versus Looking at an External Monitor
There are two pieces of information that you have available to work with while performing
color correction: the readouts displayed in the Video Scopes tab, and the visual image as
displayed on your NTSC or PAL broadcast video monitor. Each has advantages and
disadvantages; you’ll want to use both equally to determine what needs to be done.
The Final Cut Pro video scopes are very good for showing you quantitative information
about the relative distribution of luma, the balance of different colors, the amount of
saturation, and the range of color that exists in your clip. This information can help you
decide how to adjust the controls of the color correction filter being used and spot details
that you may not have noticed in the picture.

The Importance of Using a Properly Calibrated Broadcast Monitor
When using Final Cut Pro color correction filters to adjust the color, blacks, and whites of
clips in your sequence, it is essential to always use a properly calibrated broadcast video
monitor to view your adjustments as you’re making them. Only an NTSC or PAL broadcast
monitor allows you to see the color and brightness of your video as it truly looks. The
image on your computer display, in comparison, does not show the color, blacks, or
whites of your video clips as they will appear during broadcast. For this reason, the color
of video on your computer display should never be used as a reference when performing
color correction.
The video monitor you use should be a professional broadcast monitor rather than a
consumer television set. Television sets have special filters that are meant to make video
coming in off the airwaves look more attractive. These filters can cause your video to look
more vivid than it really is, fooling you into making incorrect color correction adjustments.
Important: Make sure to always calibrate your broadcast video monitor to color bars, as
described in “Using Color Bars for Video Calibration.” Otherwise, you may be incorrectly
modifying the color, blacks, and whites of your clips to compensate for an incorrectly
adjusted monitor.
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Window Layouts for Color Correction in Final Cut Pro
There are two window layouts that are especially convenient for color correction in
Final Cut Pro:
• Color Correction: This layout arranges the Viewer, Canvas, and one Tool Bench window
displaying a Video Scopes tab along the top of your computer screen. The Browser and
Timeline are arranged beneath. This is a good layout for examining one clip in your
sequence at a time in the Canvas while viewing an analysis of that frame in the Video
Scopes tab and making color correction adjustments in the Viewer.
• Multiple Edits: This layout arranges four windows along the top of your computer
screen—the Viewer, a Tool Bench window showing a Frame Viewer tab, the Canvas,
and another Tool Bench window showing another Frame Viewer tab with a Video
Scopes tab in the background. The Browser and Timeline are arranged beneath. The
Multiple Edits layout is ideal for comparing adjacent clips in your sequence to one
another on your computer screen for a relative comparison.
You may also find it useful to create a custom layout of your own, depending on how
you like to work. You can open as many Tool Bench windows as you like, each with
different sets of Frame Viewer and Video Scopes tabs comparing different frames in your
sequence. For more information on using and saving window layouts in Final Cut Pro,
see “Customizing Window Layouts.”

Comparing Two Frames in the Frame Viewer
You can use the Frame Viewer to visually compare multiple frames from the same
sequence. This is particularly useful when performing a color comparison of multiple clips
in the same setting where the lighting attributes may have changed. The Frame Viewer
is a tab in the Tool Bench window. In Final Cut Pro, you can open as many Frame Viewer
tabs in as many Tool Bench windows as necessary.
In addition to comparing adjacent clips in a sequence for color correction, you can use
the Frame Viewer tab for other tasks:
• Performing a before-and-after filter adjustment: Using the Frame Viewer’s split screen,
you can compare a frame from your clip with and without a filter applied, side by side.
• Lining up horizons or the lines of a table or desk: This is especially useful when enlarging
a shot in post-production.
You can set a Frame Viewer tab to display the current frame, adjacent edit points, or the
sequence In and Out points in the Canvas and Timeline. You can also compare two frames
within a single Frame Viewer tab using the split-screen buttons. You can split the screen
either vertically or horizontally, or create a rectangular region showing the split as a
picture within a picture. You can configure the Frame Viewer to display those individual
frames that are most useful for making comparisons in your project.
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Controls in the Frame Viewer Tab
By default, the Frame Viewer tab displays the previous clip from the selected sequence.
As you play a sequence, the Frame Viewer shows the last displayed frame. When playback
is paused, the contents of the Frame Viewer are updated relative to the new position of
the playhead.
If you’ve arranged multiple Frame Viewer tabs to accomplish a specific task, you can save
your custom configuration by choosing Window > Arrange > Save Window Layout. For
more information about saving window layouts, see “Customizing Window Layouts.”

µ

To open the Frame Viewer tab
Choose Tools > Frame Viewer (or press Option-7).
Frame boundary indicator
The Frame Viewer
appears as a tab in
the Tool Bench window.

Indicates the timecode
of the frame chosen
in the Frame Viewer
pop-up menu below.
Frame boundary
indicators

Frame Viewer
pop-up menu

Split-screen buttons
Frame Viewer pop-up menu
Frame boundary indicator
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You can customize the contents of the Frame Viewer tab using the following controls:
• Frame Viewer pop-up menus: Two pop-up menus near the bottom control which two
frames are displayed in the Frame Viewer.

• None: This option is available only in the Frame Viewer pop-up menu on the right.
If you don’t want to use the split-screen feature in the Frame Viewer, choose this
option. When the None option is chosen, only the frame corresponding to the green
frame boundary indicators is displayed.
• 2nd Edit Back: Displays the frame of the Out point two edits back.
• Previous Edit: Displays the frame of the Out point one edit back.
• Current Frame: Displays the frame corresponding to the position of the playhead in
the Timeline.
• Current w/o Filters: Displays the same frame as the Current Frame option, without
filters applied to the clip. If you have several layers composited together, composite
modes are still calculated. However, all filters are turned off on all clips.
• Next Edit: Displays the frame of the In point one edit forward.
• 2nd Edit Forward: Displays the frame of the In point two edits forward.
• In Point: Displays the frame corresponding to the currently defined In point of the
sequence in the Timeline.
• Out Point: Displays the frame corresponding to the currently defined Out point of
the sequence in the Timeline.
• Frame boundary indicators: Next to each Frame Viewer pop-up menu is a green or blue
square indicator. These indicators are also located at the top of the Frame Viewer tab
and indicate the timecode values of the frames displayed from the sequence. There
are also four blue and four green frame boundary indicators at the corners of the
split-screen window that correspond to the frames chosen in the Frame Viewer pop-up
menus. The edges of the split screen can be manipulated by selecting one of the frame
boundary indicators and dragging it to a new position.
Note: By default, you won’t see two of the blue frame boundary indicators because
they are slightly off the screen.
• Split-screen buttons: These buttons allow you to quickly alternate between vertically
split and horizontally split screens.
• V-Split: Splits the screen vertically. (Click twice to switch sides.)
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• Swap: Alternates the content in each frame and switches the two Frame Viewer
pop-up menus accordingly.
• H-Split: Splits the screen horizontally. (Click twice to switch sides.)

Choosing Display Options in the Frame Viewer
The following section describes how to view and adjust split-screen displays in the Frame
Viewer.

µ

To choose a frame to display
Choose a frame to display from either the left or right Frame Viewer pop-up menu.
You can also choose Current Frame from either Frame Viewer pop-up menu to view the
frame at the position of the playhead.

µ

To turn on the split screen
Choose an edit point from both Frame Viewer pop-up menus.
Note: Clicking the V-Split, Swap, or H-Split button puts the Frame Viewer into split-screen
mode with Current w/o Filters selected in the left pop-up menu and Current Frame
selected in the right pop-up menu.

µ

To turn off the split screen
Choose None from the right Frame Viewer pop-up menu.
The edit point represented by the green frame boundary indicators is shown.
To adjust the split screen
Do one of the following:

µ

Resize the split screen by dragging a green or blue frame boundary indicator to a new
position.

µ

Move the split screen by clicking inside one of the Frame Viewer split-screen regions and
dragging it to a different location.

To move the split screen,
drag a split-screen region
to another location.

µ
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To swap the contents of two split-screen regions
Click one of the split-screen buttons to display alternative views.
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This chapter covers the following:
• The Final Cut Pro Color Correction Filters (p. 1351)
• The Color Corrector Filter (p. 1353)
• The Color Corrector 3-Way Filter (p. 1366)
• The Desaturate Highlights and Desaturate Lows Filters (p. 1381)
• RGB Balance Filter (p. 1382)
Final Cut Pro includes powerful color correction filters that you can use to grade and
adjust your footage.

The Final Cut Pro Color Correction Filters
There are a number of filters you can use to adjust the blacks, whites, and color balance
of your clips:
• Color Corrector: The Color Corrector filter is a basic filter for performing simple color
correction. While not as fully featured as the Color Corrector 3-way filter, it’s more likely
to be supported by real-time hardware.
• Color Corrector 3-way: The Color Corrector 3-way filter gives you more precise color
control with separate adjustments to the color balance of the blacks, midtones, and
whites of your image.
• Desaturate Highlights and Desaturate Lows: Sometimes, the application of one of the
color correction filters can result in unwanted color in the highlights and blacks of your
image. These two filters (which are actually the same filter with two different default
settings) let you eliminate these unwanted colors.
• RGB Balance: Allows you to raise or lower the levels of the highlights, midtones, and
blacks of each channel—red, green, and blue—in RGB color space individually.
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• Broadcast Safe and RGB Limit: The Broadcast Safe filter gives you a fast method for
dealing with clips that have luma and chroma levels that exceed the broadcast limits
for video. If you want to limit illegal RGB levels, you can use the RGB Limit controls in
the Broadcast Safe filter or you can use the RGB Limit filter. For more information, see
“Using the Broadcast Safe Filter” and “Using the RGB Limit Filter.”
All the Final Cut Pro color correction filters are located in the Color Correction bin, within
the Video Filters bin in the Effects tab of the Browser. They can be applied the same way
as any other filter. For more information, see “Using Video Filters.”
The two main color correction filters in Final Cut Pro that you’ll use to perform primary
color correction are the Color Corrector filter and the Color Corrector 3-way filter. Each
has different requirements for real-time processing; the one you use will probably depend
on the video hardware you have installed.
Once applied, color correction filters appear in the Filters tab of a clip that’s opened in
the Viewer, along with any other filters you may have added. One color correction tab
appears in the Viewer for each color correction filter you apply. Additional tabs are
numbered sequentially depending on their arrangement in the Filters tab.
A color correction
tab appears for each
color correction filter
you apply.

As with all other filters, clicking the disclosure triangle next to a filter’s name reveals a list
of controls that allow you to make various adjustments. Unlike most other filters, the
Color Corrector and Color Corrector 3-way filters have two sets of controls—numeric and
visual.

µ

To use the visual controls
In the Filters tab, click the Visual button next to the Color Corrector filter.

Click this button to
view the filter’s visual
controls tab.

To use the standard numeric controls
Do one of the following:

µ
µ
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In the Color Corrector tab, click the Numeric button.
Click the Filters tab.
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For more information about adding, adjusting, and removing filters, see “Using Video
Filters.”

Using a Trackball with the Color Corrector Filters
Additional keyboard shortcuts are available to make it easy to use a trackball to adjust
the color balance controls in the Color Corrector and Color Corrector 3-way filters. These
keyboard shortcuts work only while the mouse button (or trackball button) is pressed,
and are designed to work with the drag lock button of your trackball.
Tip: When you press the drag lock button of your trackball, the trackball button remains
pressed and continuous adjustments can be made to the color balance controls.
To work with the color balance controls while the drag lock mode of your trackball is
enabled, press Tab to move from one color balance control to the next.
If your trackball has multiple programmable buttons, you can map three other keyboard
shortcuts to them to go directly to specific color balance controls.
• Option-Control-8: Selects the Blacks control.
• Option-Control-9: Selects the Mids control.
• Option-Control-0: Selects the Whites control.

The Color Corrector Filter
The Color Corrector filter controls are deceptively easy considering the amount of power
they give you over the look of your clips. The main controls are at the top of the visual
interface tab—color balance controls and level and saturation controls.

General Controls in the Color Corrector Filter
There are several basic controls in the top-left corner of the Color Corrector filter.
Keyframe controls

Enable/Disable checkbox

Numeric button

• Numeric button (appears when viewing the visual controls): Click this button to view the
numeric controls for that filter in the Filters tab.
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• Visual button (appears when viewing the numeric controls): Click this button to view the
visual controls for that filter in the color correction tab.
• Keyframe controls: A set of three keyframe controls allows you to keyframe all of the
settings in a color correction filter at once. To keyframe individual settings of a color
correction filter, you need to use the filter’s numeric controls.
There are two ways to keyframe color correction changes over time. Using a filter’s
visual controls, you can place single keyframes that include the settings of every
parameter of the color correction filter. If you set one keyframe, move the playhead
ahead several seconds, and make further adjustments to the visual controls of the color
correction filter, Final Cut Pro automatically interpolates the change from one keyframe’s
settings to another to make the smoothest transition possible.
For more precise control, you can keyframe individual color correction parameters
directly in the Filters tab of the Viewer. For more information about keyframing filters,
see “Animating Motion Effects Using Keyframes.”
• Enable/Disable checkbox: Select or deselect this checkbox to turn on or turn off the
entire filter. This can be useful if you want to compare your clip before and after the
color correction filter has been applied. When working in the visual controls, you can
turn the filter on and off by pressing Control-1.

Copy Filter Controls in the Color Corrector Filter
The Copy Filter controls give you an easy way to copy color correction filters and filter
settings into other clips in your sequence.

Copy To 1st Clip Forward
Copy To 2nd Clip Forward
Drag Filter
Copy From 1st Clip Back
Copy From 2nd Clip Back

• Copy From 2nd Clip Back: Copies the settings from the color correction filter of the same
type that’s applied two clips behind the currently selected clip, and pastes those settings
into the current color correction filter. The new values replace any values or keyframes
that were already applied in the current filter.
If the filter being copied from is keyframed, the values from the last keyframe are applied
to the current clip. If the second clip behind the currently selected one has no color
correction filter, this control is dimmed.
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• Copy From 1st Clip Back: Copies the settings from the color correction filter of the same
type that’s applied to the clip immediately behind the currently selected clip, and pastes
those settings into the current color correction filter. The new values replace any values
or keyframes that were already applied in the current filter.
If the filter being copied from is keyframed, the values from the last keyframe are applied
to the current clip. If the first clip behind the currently selected one has no color
correction filter, this control is dimmed.
• Drag Filter: Allows you to drag a copy of the current color correction filter, with all of
its settings, and drop it onto another clip in your sequence. Click this button, then drag
the filter to another clip.
• Copy To 1st Clip Forward: Copies the settings of the current color correction filter into
the next clip in your sequence. If the current color correction filter is keyframed, the
values from the last keyframe are copied. If there is no color correction filter in the next
clip, one is applied automatically.
• Copy To 2nd Clip Forward: Copies the settings of the current color correction filter into
the second clip forward in your sequence. If the current color correction filter is
keyframed, the values from the last keyframe are copied. If there is no color correction
filter in the second clip forward, one is applied automatically.
The Copy Filter functions are also available using menu commands and keyboard
shortcuts. For additional information about using these controls, see the next section.
Working with the Copy Filter Controls
The Copy Filter controls are designed to help you color correct sequences that have
shot-reverse-shot editing. For example, suppose you want to cut from a wide shot of two
actors to a medium shot of them from a different angle, and then back to the wide shot.
Assume you also already applied a color correction filter to the first shot. A render bar
appears above that clip.
This render bar indicates
that the first clip has a
filter applied to it.
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Because the third shot in this sequence is another segment of the media used in the first
shot, it needs the same color correction settings. Use the Copy To 2nd Clip Forward button
to apply the same color correction filter with all its settings directly to the third shot in
the sequence, skipping over the second shot. Once you’ve done that, the third shot
displays a render bar, indicating that the filter has been applied.
A render bar over the
third clip indicates that
the filter was applied.

To copy color correction filter settings forward to another clip
1 Double-click a sequence clip with a color correction filter applied to open the clip in the
Viewer.
2 In the Viewer, click the Color Corrector tab.
3 Do one of the following:
• To copy the current color correction filter settings to the next clip: Click the Copy to 1st
Clip Forward button (or choose Modify > Copy Filters > To 1st Clip Forward).
• To copy the current color correction filter settings to the clip that is two clips forward: Click
the Copy to 2nd Clip Forward button (or choose Modify > Copy Filters > To 2nd Clip
Forward).
You can also copy the color correction filter settings that you’ve previously made from
another clip to the currently selected clip.
To copy color correction filter settings from a previously corrected clip
1 Double-click a sequence clip with a color correction filter applied to open the clip in the
Viewer.
2 In the Viewer, click the Color Corrector tab.
3 Do one of the following:
• To copy the current color correction filter settings from the previous clip: Click the Copy
From 1st Clip Back button (or choose Modify > Copy Filters > From 1st Clip Back).
• To copy the current color correction filter settings from the clip that is two clips previous: Click
the Copy From 2nd Clip Back button (or choose Modify > Copy Filters > From 2nd Clip
Back).
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Another way to use these controls is to select all the clips in the scene you’re working on
and then apply the color correction filter to all of them. Once you’ve done that, it’s easy
to use the Copy Filter controls to copy any color correction settings that you change from
prior clips in the sequence to current ones, and vice versa. For clips with multiple filters,
the Copy Filter controls operate by the following rules.
“Copy From” Rule
If the current clip has multiple filters and you’re copying from a clip with multiple filters,
Final Cut Pro copies from a filter with the same index number as the current one being
adjusted, if possible. For example, if the previous clip has three filters, and the current
clip has three filters, clicking the Copy From 1st Clip Back button in the Color Corrector-3
tab copies the settings from the third color correction filter in the previous clip.
If the previous clip doesn’t have the same number of filters, the Copy From buttons copy
settings from the first available color correction filter that matches the type of the current
one. If there are no color correction filters in the previous clips, these buttons are dimmed.
Current clip
Copy From
1st Clip Back
button

Previous clip
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“Copy To” Rule
If the current clip has multiple filters and you’re copying to a clip with multiple filters,
Final Cut Pro copies the current filter’s settings to a filter with the same index number in
the next clip as that of the current filter. For example, if the current clip has three filters,
and the next clip has three filters, using the Copy To 1st Clip Forward button in the Color
Corrector-2 tab copies that filter’s settings into the second color correction filter in the
next clip.
Copy To 1st Clip Forward button
Current clip

Next clip

If the clip you’re copying to doesn’t have any color correction filters, the Copy To buttons
create a new filter with these settings. If there are no clips following the current one,
these buttons are dimmed.
Menu Commands for the Copy Filter Controls
Some Copy Filter controls have equivalents in the Copy Filters submenu of the Modify
menu:
• From 2nd Clip Back
• From 1st Clip Back
• To 1st Clip Forward
• To 2nd Clip Forward

Color Balance Controls in the Color Corrector Filter
Color balance controls are color wheels that allow you to change the mix of red, green,
and blue that falls within the area of a specific range of luma in your clip. The color balance
controls act like virtual trackballs; you can drag anywhere within a color wheel to move
the color balance indicator. The Color Corrector filter has one color balance control that
affects the whites of a clip, as well as a Hue control.
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The angle of distribution of red, green, and blue in all the color balance controls
corresponds to the angles of those colors in the Vectorscope. The direction in which you
move the color balance indicator within the color wheel is matched by the mix of colors
moving in the same direction in the Vectorscope.
If you hold down the Shift key while dragging a color balance indicator, the angle of the
indicator is constrained, so that the indicator can only move out toward the edge of the
color wheel, or in toward the center. This lets you change the intensity of your color mix
without changing the distribution of hues.

Color balance indicator
path constrained by the
Shift key

Unlike other controls in Final Cut Pro, a color balance control doesn’t “gear down” when
you hold down the Command key while manipulating the color balance indicator (allowing
you to make more subtle adjustments); rather, it “gears up” the control, causing the
indicator to respond more quickly and resulting in greater changes.
Note: The Color Corrector filter is more likely to be supported by real-time hardware than
the Color Corrector 3-way filter.
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You use the controls in the Color Corrector tab to balance the whites and change hues
displayed in a clip.
Auto-Balance
eyedropper

Balance control

Hue control
Hue Reset button
Balance Reset button

The Color Corrector filter has one color balance control that lets you manipulate the
whites in a clip, as well as a Hue control. You rarely use the Balance and Hue controls
simultaneously in a single color correction operation.
• Balance control: The Balance control affects the color balance in the whites of your clip.
Drag within the color wheel to move the color balance indicator and change the mix
of red, green, and blue in the whites of your clip.
• Auto-Balance eyedropper: Clicking this eyedropper turns the pointer into an eyedropper
when it’s moved into the Video tab of the Viewer or into the Canvas. Position the tip
of the eyedropper in what is supposed to be the whitest area of your image, such as
a highlight on a white shirt, then click. The color value of the pixel you selected is
analyzed, and the Balance control is automatically adjusted to turn that pixel into white.
For example, clicking a pixel that’s slightly yellow nudges the color balance indicator
toward blue, to turn that yellow into a neutral white.
When using the Auto-Balance eyedropper, don’t select an area that’s overexposed,
such as a light source or a shiny highlight. This won’t give you the desired result. Instead,
select a properly exposed area of your picture that’s white, such as a well-lit shirt sleeve
or white wall.
Note: When color correcting a clip, using this eyedropper tool is usually the second
step you take, after first using the Auto Level controls and the Whites, Mids, and Blacks
sliders (described in the next sections) to maximize the contrast of your image.
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• Balance Reset button: Click this button to reset the Balance control to its default settings
and restore your clip to its original color mix. Holding down the Shift key while clicking
this button also resets the level and saturation controls (described in one of the next
sections) to their default settings.
• Hue control: Rotate the Hue control to change the overall hue of the affected clip.
• Hue Reset button: Click this button to reset the Hue control to its default settings and
restore your clip to its original hue. Holding down the Shift key while clicking this button
also resets the level and saturation controls (described in one of the next sections) to
their default settings.

Auto Level and Contrast Controls in the Color Corrector Filter
Using the Auto Level controls and the Whites, Mids, and Blacks sliders to maximize the
contrast of your image is usually the first step you take when color correcting a clip.
Level sliders

Auto White Level button
Auto Contrast button

Saturation slider

Auto Black Level button

• Auto White Level button: Click this button to analyze your clip and find the maximum
level of white in the frame. The Whites slider is then adjusted to move the maximum
white level to 100 percent as viewed in the Histogram.
• Auto Black Level button: Click this button to analyze your clip and find the maximum
level of black in the frame. The Blacks slider is then adjusted to move the maximum
black level of your clip to 0 percent as viewed in the Histogram.
• Auto Contrast button: Click this button to perform the functions of both the Auto White
Level and Auto Black Level buttons simultaneously.

Level and Saturation Controls in the Color Corrector Filter
The level sliders allow you to adjust the levels of the whites, midtones, and blacks in your
clip to adjust the contrast of your image. The first step when color correcting one clip to
match another is to adjust its overall luma levels to match those of the other. Only after
doing this are you able to adjust the colors appropriately and achieve the results you
want. The Saturation slider lets you increase or decrease the intensity of the color in your
image.
• Whites slider: Drag this slider to adjust the maximum level of white in the affected clip.
To move the slider in increments, click the small arrows to the right or left of the slider.
Moving the slider to the left lowers the maximum white level (letting you bring the
whites in overexposed clips down to a more acceptable level, for example).
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• Mids slider: Drag this slider to adjust the average distribution of values in between
white and black in the affected clip. To move the slider in increments, click the small
arrows to the right or left of the slider. You can use this slider to adjust the midtones
of your image, increasing or decreasing the apparent contrast of your image without
washing out the whites or blacks. For example, you could manipulate the Mids slider
to bring out detail in shadowed areas of your clip.
• Blacks slider: Drag this slider to adjust the minimum level of black in the affected clip,
deepening or reducing the level of absolute black in your image. To move the slider
in increments, click the small arrows to the right or left of the slider.
• Saturation (Sat) slider: This slider raises or lowers the overall saturation, or intensity of
color, in the affected clip. Drag the slider all the way to the left to desaturate the color
from the clip completely. This results in a grayscale image. Drag the slider to the right
to increase the saturation of color in the affected clip. To move the slider in increments,
click the small arrows to the right or left of the slider.
Note: Be very careful when raising the saturation of a clip using the Saturation slider.
It is very easy to raise the saturation too high, resulting in saturation values that are
illegal for broadcast. Never adjust the saturation of clips based on how they appear on
your computer display. NTSC and PAL video never look as vivid on a computer display
as they do on a properly calibrated broadcast video monitor, and it’s often tempting
to overcompensate when basing your adjustments on a computer display. It’s a good
idea to turn on the Excess Chroma option (in the Range Check submenu of the View
menu) to warn you when you’re boosting the saturation too much. For more
information, see “The Importance of Using a Properly Calibrated Broadcast Monitor”
and “Displaying Excess Luma and Chroma Levels in the Viewer and Canvas.”

Match Hue Controls in the Color Corrector Filter
The Match Hue controls allow you to adjust the hue of the current clip to match a similar
color in an adjacent clip in your sequence. A common example is matching the flesh
tones of an actor in two different shots with different lighting.
The Match Hue controls provide a way to adjust the color balance of the current clip,
based on a specific hue, to match a similar hue in another clip. A common example of
when you might use the Match Hue controls is when you are matching the flesh tones
of an actor in two shots that have different lighting.
The Match Hue controls do not affect the contrast of your image. Adjusting the Whites,
Blacks, and Mids level sliders to maximize the contrast in your image is still going to be
the first step in your color correction process, even when using the Match Hue controls.
Note: The Match Hue controls are intended to match similar colors to one another. They
cannot be used to match completely opposite colors.
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Using Limit Effect Controls to Control a Match Hue Correction
Color corrections made using the Match Hue controls affect a clip’s entire image, not just
the particular subject you’re matching. The resulting change to the background of your
clip may be inappropriate, even if the foreground subject is properly adjusted. In these
cases, using the Limit Effect controls may allow you to restrict the correction to the areas
where it’s needed, leaving the rest of the image alone. For more information on using
the Limit Effect controls, see “Limit Effect Controls in the Color Corrector Filter.”
The Match Hue controls work well as a starting point to help you quickly match the overall
color balance of two shots; however, you’ll probably want to further adjust the end result
by hand to achieve the exact effect you’re looking for.
Match Hue controls in
the Color Corrector filter

Match Hue eyedropper
Match Color indicator
Controls in the
Color Corrector
3-way filter

Reset Match Color button

Auto Level controls in
the Color Corrector filter

• Match Hue eyedropper: Clicking the Match Hue eyedropper turns the pointer into an
eyedropper when it’s moved into the Canvas, the Video tab of the Viewer, or a Frame
Viewer tab in a Tool Bench window. With the current clip open in the Viewer, open the
clip you want to match it to in the Canvas or in an available Frame Viewer tab.
Click the eyedropper in the color of an adjacent clip in your sequence that you’re trying
to match to the current clip. Once selected, the match color is displayed in the Match
Color indicator.
Once you’ve selected a match color, you can click the Whites, Mids, or Blacks
Auto-Balance eyedropper and then click the eyedropper in a color in the current clip
that’s supposed to be the same as the match color. Final Cut Pro automatically adjusts
the Whites, Mids, or Blacks control in an attempt to rebalance the clip to match the
color you selected with the match color.
• Match Color indicator: Displays the currently selected match color. Whichever color is
displayed by the Match Color indicator affects how the Whites, Blacks, and Mids
Auto-Balance eyedropper tools make their corrections.
• Reset Match Color button: Resets the match color to white, the default behavior of the
Whites control.
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Note: With a match color selected, the functionality of the Whites, Blacks, and Mids
controls is unaffected. Only the functionality of the Auto-Balance eyedroppers is affected
by the Match Hue controls.

Limit Effect Controls in the Color Corrector Filter
The Limit Effect controls are a group of controls in the Color Corrector filter that let you
key a specific color and apply color correction to just the areas of the picture that you’ve
keyed on.
For example, suppose you have a scene with people wearing different-colored shirts.
After the shoot, you decide you want to change the color of one of the actor’s shirts that’s
now yellow. Assuming there is nothing else in the picture with the same values of yellow,
you can use the Limit Effect controls to selectively make this change.
You can use the color value, saturation, and luma of your clip together or separately to
perform a key using the Limit Effect controls. For example, if you want to modify only the
bright areas of your picture, you can turn off both color and saturation and then perform
only a luma key.
Enable/Disable checkbox
Reset button

Color Range control
Luma control

Saturation control
Top handle

Bottom handle

• Enable/Disable checkbox: Make sure there’s a checkmark in this checkbox for the Limit
Effect controls you want to use. This lets you add or remove color, saturation, or luma
from the criteria used to define a key.
• Reset button: Click to restore the Color Range, Saturation, and Luma controls to their
default values. Shift-click the button to reset all three controls at once.
• Color Range control: Allows you to fine-tune the range of color that you want to key
on.
• Top handles: Let you select a larger or smaller range of colors that are keyed, based
on the original colors you selected with the Select Color eyedropper. These handles
correspond to the Chroma Width control in the numeric filter controls.
• Color gradient: Drag left or right within the color gradient to shift the overall hue of
the color range you’ve set with the top set of handles. This corresponds to the Chroma
Center control in the numeric filter controls.
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• Bottom handles: Allow you to define the tolerance of your key. These handles
correspond to the Chroma Softness control in the numeric filter controls.
• Saturation (Sat) control: Allows you to adjust the degree and range of saturation that
contributes to defining your key. The top and bottom handles work the same as those
in the Color Range control. Drag left or right within the gradient to move all four handles
simultaneously.
• Luma control: Allows you to adjust the degree and range of luma that contributes to
defining your key. The top and bottom handles work the same as those in the Color
Range control. Drag left or right within the gradient to move all four handles
simultaneously.
• Edge Thin slider: Allows you to modify the keyed area by shrinking or expanding it.
Using Edge Thin, you can control a noisy key, filling in small gaps and adjusting the
edge of the key to include borderline values that are otherwise difficult to get at using
the other controls.
• Softening slider: Allows you to soften the edges of the key, creating gentler transitions
between affected and unaffected parts of the image.

Select Color eyedropper
View Final/Matte/Source button
Invert Selection button

• Select Color eyedropper: When you click this eyedropper, the pointer turns into an
eyedropper you can use to select a color from a clip in the Video tab of the Viewer or
in the Canvas. Shift-clicking this eyedropper allows you to select another region of the
background screen that wasn’t keyed out by your first use of this control, thereby
broadening the range of colors to be keyed out and enlarging the keyed-out area. You
can do this repeatedly to broaden the range of keyed-out color to include shadows or
highlights on the background screen, if necessary.
• View Final/Matte/Source button: This button has three states:
• Final: The default state (a gold key against a gray background) allows you to see the
end result—the effect happening within the keyed area.
• Matte: The second state (a black key against a white background) displays the key
itself as a grayscale image, so you can fine-tune it without being distracted by the
image.
• Source: The third state (a gold key against a blue background) shows only the original
video image.
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• Invert Selection button: Click this button to invert the key you’ve defined. For example,
if you’ve set up a key based on the color of a green car and turned the desaturation all
the way down so that the car is grayscale and the background is color, clicking the
Invert Selection button makes the background turn grayscale, and the car appears in
color.

Using Multiple Filters Together with the Limit Effect Controls
You can use the Limit Effect controls to layer multiple color correction filters onto a single
clip, selectively balancing specific areas of your picture based on their color, saturation,
and luma levels. Color correction filters work serially, the same as any other filters. This
means that if two color correction filters are applied to a single clip, the second color
correction filter works on the modified output of the first filter, rather than on the original
color values of the image.
For example, if you add a filter that adjusts the color in a group of flowers but causes the
green grass in the background to look too red, a second color correction filter using the
Limit Effect controls will target the greenish red color of the grass as it has been modified,
rather than the original green values.

The Color Corrector 3-Way Filter
The Color Corrector 3-way filter gives you more subtle control over the color of your clips
than the Color Corrector filter. The controls are deceptively easy considering the amount
of power they give you over the look of your clips. The main controls are at the top of
the visual interface tab—three color balance controls and level and saturation controls.

General Controls in the Color Corrector 3-Way Filter
There are several basic controls in the top-left corner of the filter.
Keyframe controls

Enable/Disable checkbox

Numeric button

• Numeric button (appears when viewing the visual controls): Click this button to view the
numeric controls for that filter in the Filters tab.
• Visual button (appears when viewing the numeric controls): Click this button to view the
visual controls for that filter in the color correction tab.
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• Keyframe controls: A set of three keyframe controls allows you to keyframe all of the
settings in a color correction filter at once. To keyframe individual settings of a color
correction filter, you need to use the filter’s numeric controls.
There are two ways to keyframe color correction changes over time. Using a filter’s
visual controls, you can place single keyframes that include the settings of every
parameter of the color correction filter. If you set one keyframe, move the playhead
ahead several seconds, and make further adjustments to the visual controls of the color
correction filter, Final Cut Pro automatically interpolates the change from one keyframe’s
settings to another to make the smoothest transition possible.
For more precise control, you can keyframe individual color correction parameters
directly in the Filters tab of the Viewer. For more information about keyframing filters,
see “Animating Motion Effects Using Keyframes.”
• Enable/Disable checkbox: Select or deselect this checkbox to turn on or turn off the
entire filter. This can be useful if you want to compare your clip before and after the
color correction filter has been applied. When working in the visual controls, you can
turn the filter on and off by pressing Control-1.

Copy Filter Controls in the Color Corrector 3-Way Filter
The Copy Filter controls give you an easy way to copy color correction filters and filter
settings into other clips in your sequence.

Copy To 1st Clip Forward
Copy To 2nd Clip Forward
Drag Filter
Copy From 1st Clip Back
Copy From 2nd Clip Back

• Copy From 2nd Clip Back: Copies the settings from the color correction filter of the same
type that’s applied two clips behind the currently selected clip, and pastes those settings
into the current color correction filter. The new values replace any values or keyframes
that were already applied in the current filter.
If the filter being copied from is keyframed, the values from the last keyframe are applied
to the current clip. If the second clip behind the currently selected one has no color
correction filter, this control is dimmed.
• Copy From 1st Clip Back: Copies the settings from the color correction filter of the same
type that’s applied to the clip immediately behind the currently selected clip, and pastes
those settings into the current color correction filter. The new values replace any values
or keyframes that were already applied in the current filter.
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If the filter being copied from is keyframed, the values from the last keyframe are applied
to the current clip. If the first clip behind the currently selected one has no color
correction filter, this control is dimmed.
• Drag Filter: Allows you to drag a copy of the current color correction filter, with all of
its settings, and drop it onto another clip in your sequence. Click this button, then drag
the filter to another clip.
• Copy To 1st Clip Forward: Copies the settings of the current color correction filter into
the next clip in your sequence. If the current color correction filter is keyframed, the
values from the last keyframe are copied. If there is no color correction filter in the next
clip, one is applied automatically.
• Copy To 2nd Clip Forward: Copies the settings of the current color correction filter into
the second clip forward in your sequence. If the current color correction filter is
keyframed, the values from the last keyframe are copied. If there is no color correction
filter in the second clip forward, one is applied automatically.
The Copy Filter functions are also available using menu commands and keyboard
shortcuts. For additional information about using these controls, see the next section.
Working with the Copy Filter Controls
The Copy Filter controls are designed to help you color correct sequences that have
shot-reverse-shot editing. For example, suppose you want to cut from a wide shot of two
actors to a medium shot of them from a different angle, and then back to the wide shot.
Assume you also already applied a color correction filter to the first shot. A render bar
appears above that clip.
This render bar indicates
that the first clip has a
filter applied to it.
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Because the third shot in this sequence is another segment of the media used in the first
shot, it needs the same color correction settings. Use the Copy To 2nd Clip Forward button
to apply the same color correction filter with all its settings directly to the third shot in
the sequence, skipping over the second shot. Once you’ve done that, the third shot
displays a render bar, indicating that the filter has been applied.
A render bar over the
third clip indicates that
the filter was applied.

To copy color correction filter settings forward to another clip
1 Double-click a sequence clip with a color correction filter applied to open the clip in the
Viewer.
2 In the Viewer, click the Color Corrector tab.
3 Do one of the following:
• To copy the current color correction filter settings to the next clip: Click the Copy to 1st
Clip Forward button (or choose Modify > Copy Filters > To 1st Clip Forward).
• To copy the current color correction filter settings to the clip that is two clips forward: Click
the Copy to 2nd Clip Forward button (or choose Modify > Copy Filters > To 2nd Clip
Forward).
You can also copy the color correction filter settings that you’ve previously made from
another clip to the currently selected clip.
To copy color correction filter settings from a previously corrected clip
1 Double-click a sequence clip with a color correction filter applied to open the clip in the
Viewer.
2 In the Viewer, click the Color Corrector tab.
3 Do one of the following:
• To copy the current color correction filter settings from the previous clip: Click the Copy
From 1st Clip Back button (or choose Modify > Copy Filters > From 1st Clip Back).
• To copy the current color correction filter settings from the clip that is two clips previous: Click
the Copy From 2nd Clip Back button (or choose Modify > Copy Filters > From 2nd Clip
Back).
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Another way to use these controls is to select all the clips in the scene you’re working on
and then apply the color correction filter to all of them. Once you’ve done that, it’s easy
to use the Copy Filter controls to copy any color correction settings that you change from
prior clips in the sequence to current ones, and vice versa. For clips with multiple filters,
the Copy Filter controls operate by the following rules.
“Copy From” Rule
If the current clip has multiple filters and you’re copying from a clip with multiple filters,
Final Cut Pro copies from a filter with the same index number as the current one being
adjusted, if possible. For example, if the previous clip has three filters, and the current
clip has three filters, clicking the Copy From 1st Clip Back button in the Color Corrector-3
tab copies the settings from the third color correction filter in the previous clip.
If the previous clip doesn’t have the same number of filters, the Copy From buttons copy
settings from the first available color correction filter that matches the type of the current
one. If there are no color correction filters in the previous clips, these buttons are dimmed.
Current clip
Copy From
1st Clip Back
button

Previous clip
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“Copy To” Rule
If the current clip has multiple filters and you’re copying to a clip with multiple filters,
Final Cut Pro copies the current filter’s settings to a filter with the same index number in
the next clip as that of the current filter. For example, if the current clip has three filters,
and the next clip has three filters, using the Copy To 1st Clip Forward button in the Color
Corrector-2 tab copies that filter’s settings into the second color correction filter in the
next clip.
Copy To 1st Clip Forward button
Current clip

Next clip

If the clip you’re copying to doesn’t have any color correction filters, the Copy To buttons
create a new filter with these settings. If there are no clips following the current one,
these buttons are dimmed.
Menu Commands for the Copy Filter Controls
Some Copy Filter controls have equivalents in the Copy Filters submenu of the Modify
menu:
• From 2nd Clip Back
• From 1st Clip Back
• To 1st Clip Forward
• To 2nd Clip Forward

Color Balance Controls in the Color Corrector 3-Way Filter
You use the controls in the Color Corrector 3-way tab to color balance the blacks, midtones,
and whites displayed in a clip.
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Color balance controls are color wheels that allow you to change the mix of red, green,
and blue that falls within the area of a specific range of luma in your clip. The color balance
controls act like virtual trackballs; you can drag anywhere within a color wheel to move
the color balance indicator. The Color Corrector 3-way filter has three color balance
controls: one affects the blacks of a clip, the second affects the midtones, and the third
affects the whites.
The angle of distribution of red, green, and blue in all the color balance controls
corresponds to the angles of those colors in the Vectorscope. The direction in which you
move the color balance indicator within the color wheel is matched by the mix of colors
moving in the same direction in the Vectorscope.
If you hold down the Shift key while dragging a color balance indicator, the angle of the
indicator is constrained, so that the indicator can only move out toward the edge of the
color wheel, or in toward the center. This lets you change the intensity of your color mix
without changing the distribution of hues.

Color balance indicator
path constrained by the
Shift key
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Unlike other controls in Final Cut Pro, a color balance control doesn’t “gear down” when
you hold down the Command key while manipulating the color balance indicator (allowing
you to make more subtle adjustments); rather, it “gears up” the control, causing the
indicator to respond more quickly and resulting in greater changes.

Color balance controls

Blacks Reset button
Blacks Auto-Balance
eyedropper

• Blacks control: Drag in the Blacks color wheel to move the color balance indicator and
change the mix of red, green, and blue in the blacks of your clip.
• Blacks Auto-Balance eyedropper: Clicking the Blacks Auto-Balance eyedropper turns the
pointer into an eyedropper when it’s moved into the Video tab of the Viewer or into
the Canvas. Position the tip of the eyedropper in what is supposed to be the blackest
area of your image, such as the innermost shadow in a dark area of the picture, then
click. The color value of the pixel you selected is analyzed, and the Blacks control is
automatically adjusted to turn that pixel into true black.
Note: When color correcting a clip, adjusting this control is usually the second step
you take, after first using the Auto Level controls and the Blacks, Mids, and Whites
sliders (described in the next sections) to maximize the contrast of your image.
• Blacks Reset button: Click this button to reset the Blacks control to its default settings
and restore your clip to the original color mix.
• Mids control: Drag in the Mids color wheel to move the color balance indicator and
change the mix of red, green, and blue in the midtones of your clip.
Note: The areas of your picture affected by the Mids control overlap the areas affected
by the Blacks and Whites controls, so adjustments to the mids affect adjustments you
may have already made to the blacks and whites. This overlapping ensures that you
have the maximum amount of control necessary to accurately manipulate the color of
your clips.
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• Mids Auto-Balance eyedropper: Clicking the Mids Auto-Balance eyedropper turns the
pointer into an eyedropper when it’s moved into the Video tab of the Viewer or into
the Canvas. Position the tip of the eyedropper in what is supposed to be an area of
neutral gray, then click. The color value of the pixel you selected is analyzed, and the
Mids control is automatically adjusted to turn that pixel into a neutral gray.
Note: This neutral gray corresponds to the neutral gray chip on a production color
chart. If a chip chart was shot along with the slate of your clip, you can click the Mids
Auto-Balance eyedropper in this part of the chart to get an accurate reading.
• Mids Reset button: Click this button to reset the Mids control to its default settings and
restore your clip to the original color mix.
• Whites control: Drag in the Whites color wheel to move the color balance indicator and
change the mix of red, green, and blue in the whites of your clip.
• Whites Auto-Balance eyedropper: Clicking the Whites Auto-Balance eyedropper turns
the pointer into an eyedropper when it’s moved into the Video tab of the Viewer or
into the Canvas. Position the tip of the eyedropper in what is supposed to be the whitest
area of your image, such as a highlight on a white shirt, then click. The color value of
the pixel you selected is analyzed, and the Whites control is automatically adjusted to
turn that pixel into white. For example, clicking a pixel that’s slightly yellow nudges
the color balance indicator toward blue, to turn that yellow into a neutral white.
When using the Whites Auto-Balance eyedropper, don’t select an area that’s
overexposed, such as a light source or a shiny highlight. This won’t give you the result
you want. Instead, select a properly exposed area of your picture that’s white, like a
well-lit shirt sleeve or white wall.
• Whites Reset button: Click this button to reset the Whites control to its default settings
and restore your clip to the original color mix.
Note: Holding down the Shift key while clicking the Blacks Reset, Mids Reset, or Whites
Reset button resets all of the color balance, level, and saturation controls to their default
settings.
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Auto Level Controls in the Color Corrector 3-Way Filter
Using the Auto Level controls and the Whites, Mids, and Blacks sliders to maximize the
contrast of your image is usually the first step you take when color correcting a clip.
Auto Black Level button

Auto White Level button

Auto Contrast button

• Auto White Level button: Click this button to analyze your clip and find the maximum
level of white in the frame. The Whites slider is then adjusted to move the maximum
white level to 100 percent as viewed in the Histogram.
• Auto Black Level button: Click this button to analyze your clip and find the maximum
level of black in the frame. The Blacks slider is then adjusted to move the maximum
black level of your clip to 0 percent as viewed in the Histogram.
• Auto Contrast button: Click this button to perform the functions of both the Auto White
Level and Auto Black Level buttons simultaneously.
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Level and Saturation Controls in the Color Corrector 3-Way Filter
The level sliders allow you to adjust the levels of the whites, midtones, and blacks in your
clip to adjust the contrast of your image. The first step when color correcting one clip to
match another is to adjust its overall luma levels to match those of the other. Only after
doing this are you able to adjust the colors appropriately and achieve the results you
want. The Saturation slider lets you increase or decrease the intensity of the color in your
image.

Mids slider
Whites slider

Saturation slider
Match Hue eyedropper

Reset Match Color button
Match Color indicator

Blacks slider

• Blacks slider: Drag this slider to adjust the minimum level of black in the affected clip,
deepening or reducing the level of absolute black in your image. To move the slider
in increments, click the small arrows to the right or left of the slider.
• Mids slider: Drag this slider to adjust the average distribution of values in between
white and black in the affected clip. To move the slider in increments, click the small
arrows to the right or left of the slider. You can use this slider to adjust the midtones
of your image, increasing or decreasing the apparent contrast of your image without
washing out the whites or blacks. For example, you could manipulate the Mids slider
to bring out detail in the shadowed areas of your clip.
• Whites slider: Drag this slider to adjust the maximum level of white in the affected clip.
To move the slider in increments, click the small arrows to the right or left of the slider.
Moving the slider to the left lowers the maximum white level (letting you bring the
whites in overexposed clips down to a more acceptable level, for example).
• Saturation slider: This slider raises or lowers the overall saturation, or intensity of color,
in the affected clip. Drag the slider all the way to the left to desaturate the clip
completely. This results in a grayscale image. Drag the slider to the right to increase
the saturation of color in the affected clip. To move the slider in increments, click the
small arrows to the right or left of the slider.
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Note: Be very careful when raising the saturation of a clip using this slider. It is very
easy to raise the saturation too high, resulting in saturation values that are illegal for
broadcast. Never adjust the saturation of clips based on how they appear on your
computer display. NTSC and PAL video never look as vivid on a computer display as
they do on a properly calibrated broadcast video monitor, and it’s often tempting to
overcompensate when basing your adjustments on the way video looks on a computer
display. It’s a good idea to turn on the Excess Chroma option (in the Range Check
submenu of the View menu) to warn you when you’re boosting the saturation too
much. For more information, see “The Importance of Using a Properly Calibrated
Broadcast Monitor” and “Displaying Excess Luma and Chroma Levels in the Viewer and
Canvas.”

Match Hue Controls in the Color Corrector 3-Way Filter
The Match Hue controls allow you to adjust the hue of the current clip to match a similar
color in an adjacent clip of your sequence. A common example is matching the flesh
tones of an actor in two different shots with different lighting.
The Match Hue controls provide a way to adjust the color balance of the current clip,
based on a specific hue, to match a similar hue in another clip. A common example of
when you might use the Match Hue controls is when you are matching the flesh tones
of an actor in two shots that have different lighting.
The Match Hue controls do not affect the contrast of your image. Adjusting the Whites,
Blacks, and Mids level sliders to maximize the contrast in your image is still going to be
the first step in your color correction process, even when using the Match Hue controls.
Note: The Match Hue controls are intended to match similar colors to one another. They
cannot be used to match completely opposite colors.

Using Limit Effect Controls to Control a Match Hue Correction
Color corrections made using the Match Hue controls affect a clip’s entire image, not just
the particular subject you’re matching. The resulting change to the background of your
clip may be inappropriate, even if the foreground subject is properly adjusted. In these
cases, using the Limit Effect controls may allow you to restrict the correction to the areas
where it’s needed, leaving the rest of the image alone. For more information on using
the Limit Effect controls, see “Limit Effect Controls in the Color Corrector 3-Way Filter.”
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The Match Hue controls work well as a starting point to help you quickly match the overall
color balance of two shots; however, you’ll probably want to further adjust the end result
by hand to achieve the exact effect you’re looking for.
Match Hue controls in
the Color Corrector filter

Match Hue eyedropper
Match Color indicator
Controls in the
Color Corrector
3-way filter

Reset Match Color button

Auto Level controls in
the Color Corrector filter

• Match Hue eyedropper: Clicking the Match Hue eyedropper turns the pointer into an
eyedropper when it’s moved into the Canvas, the Video tab of the Viewer, or a Frame
Viewer tab in a Tool Bench window. With the current clip open in the Viewer, open the
clip you want to match it to in the Canvas or in an available Frame Viewer tab.
Click the eyedropper in the color of an adjacent clip in your sequence that you’re trying
to match to the current clip. Once selected, the match color is displayed in the Match
Color indicator.
Once you’ve selected a match color, you can click the Whites, Mids, or Blacks
Auto-Balance eyedropper and then click the eyedropper in a color in the current clip
that’s supposed to be the same as the match color. Final Cut Pro automatically adjusts
the Whites, Mids, or Blacks control in an attempt to rebalance the clip to match the
color you selected with the match color.
• Match Color indicator: Displays the currently selected match color. Whichever color is
displayed by the Match Color indicator affects how the Whites, Blacks, and Mids
Auto-Balance eyedropper tools make their corrections.
• Reset Match Color button: Resets the match color to white, the default behavior of the
Whites control.
Note: With a match color selected, the functionality of the Whites, Blacks, and Mids
controls is unaffected. Only the functionality of the Auto-Balance eyedroppers is affected
by the Match Hue controls.

Limit Effect Controls in the Color Corrector 3-Way Filter
The Limit Effect controls are a group of controls in the Color Corrector 3-way filter that
let you key a specific color and apply color correction to just the areas of the picture that
you’ve keyed on.
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For example, suppose you have a scene with people wearing different-colored shirts.
After the shoot, you decide you want to change the color of one of the actor’s shirts that’s
now yellow. Assuming there is nothing else in the picture with the same values of yellow,
you can use the Limit Effect controls to selectively make this change.
You can use the color value, saturation, and luma of your clip together or separately to
perform a key using the Limit Effect controls. For example, if you want to modify only the
bright areas of your picture, you can turn off both color and saturation and then perform
only a luma key.
Enable/Disable checkbox
Reset button

Color Range control
Luma control

Saturation control
Top handle

Bottom handle

• Enable/Disable checkbox: Make sure there’s a checkmark in this checkbox for the Limit
Effect controls you want to use. This lets you add or remove color, saturation, or luma
from the criteria used to define a key.
• Reset button: Click to restore the Color Range, Saturation, and Luma controls to their
default values. Shift-click the button to reset all three controls at once.
• Color Range control: Allows you to fine-tune the range of color that you want to key
on.
• Top handles: Let you select a larger or smaller range of colors that are keyed, based
on the original colors you selected with the Select Color eyedropper. These handles
correspond to the Chroma Width control in the numeric filter controls.
• Color gradient: Drag left or right within the color gradient to shift the overall hue of
the color range you’ve set with the top set of handles. This corresponds to the Chroma
Center control in the numeric filter controls.
• Bottom handles: Allow you to define the tolerance of your key. These handles
correspond to the Chroma Softness control in the numeric filter controls.
• Saturation (Sat) control: Allows you to adjust the degree and range of saturation that
contributes to defining your key. The top and bottom handles work the same as those
in the Color Range control. Drag left or right within the gradient to move all four handles
simultaneously.
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• Luma control: Allows you to adjust the degree and range of luma that contributes to
defining your key. The top and bottom handles work the same as those in the Color
Range control. Drag left or right within the gradient to move all four handles
simultaneously.
• Edge Thin slider: Allows you to modify the keyed area by shrinking or expanding it.
Using Edge Thin, you can control a noisy key, filling in small gaps and adjusting the
edge of the key to include borderline values that are otherwise difficult to get at using
the other controls.
• Softening slider: Allows you to soften the edges of the key, creating gentler transitions
between affected and unaffected parts of the image.

Select Color eyedropper
View Final/Matte/Source button
Invert Selection button

• Select Color eyedropper: When you click this eyedropper, the pointer turns into an
eyedropper you can use to select a color from a clip in the Video tab of the Viewer or
in the Canvas. Shift-clicking this eyedropper allows you to select another region of the
background screen that wasn’t keyed out by your first use of this control, thereby
broadening the range of colors to be keyed out and enlarging the keyed-out area. You
can do this repeatedly to broaden the range of keyed-out color to include shadows or
highlights on the background screen, if necessary.
• View Final/Matte/Source button: This button has three states:
• Final: The default state (a gold key against a gray background) allows you to see the
end result—the effect happening within the keyed area.
• Matte: The second state (a black key against a white background) displays the key
itself as a grayscale image, so you can fine-tune it without being distracted by the
image.
• Source: The third state (a gold key against a blue background) shows only the original
video image.
• Invert Selection button: Click this button to invert the key you’ve defined. For example,
if you’ve set up a key based on the color of a green car and turned the desaturation all
the way down so that the car is grayscale and the background is color, clicking the
Invert Selection button makes the background turn grayscale, and the car appears in
color.
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Using Multiple Filters Together with the Limit Effect Controls
You can use the Limit Effect controls to layer multiple color correction filters onto a single
clip, selectively balancing specific areas of your picture based on their color, saturation,
and luma levels. Color correction filters work serially, the same as any other filters. This
means that if two color correction filters are applied to a single clip, the second color
correction filter works on the modified output of the first filter, rather than on the original
color values of the image.
For example, if you add a filter that adjusts the color in a group of flowers but causes the
green grass in the background to look too red, a second color correction filter using the
Limit Effect controls will target the greenish red color of the grass as it has been modified,
rather than the original green values.

The Desaturate Highlights and Desaturate Lows Filters
Sometimes, the use of one of the Final Cut Pro color correction filters results in unwanted
colors appearing in either the highlights or shadows of your image. The Desaturate
Highlights and Desaturate Lows filters allow you to target a range of the brightest and
darkest areas of your image and desaturate them, which helps to keep the highlights and
shadows of your image free from coloration.
The Desaturate Highlights and Desaturate Lows filters are actually the same filter, but
with different default settings. If you need to desaturate the highlights and the shadows,
you can apply either filter once and then select both options.
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Desaturate Highlights and Desaturate Lows Filter Controls
The following section describes controls in the Desaturate Highlights and Desaturate
Lows filters.

Highlight Desaturation
controls

Lows Desaturation
controls

Highlight Desaturation Controls
• Enable: Allows you to turn on or turn off the Highlight Desaturation controls.
• Apply Above: Allows you to set the percentage of luma and above to desaturate.
• Softness: Adjusts the transition between the affected and unaffected areas of the picture.
• Amount of Desaturation: Determines how much to desaturate the selected highlights.
Lows Desaturation Controls
• Enable: Allows you to turn on or turn off the Lows Desaturation controls.
• Apply Below: Allows you to set the percentage of luma and below to desaturate.
• Softness: Adjusts the transition between the affected and unaffected areas of the picture.
• Amount of Desaturation: Determines how much to desaturate the selected lows.
Desaturation of 100 percent results in complete grayscale.

RGB Balance Filter
You can use the RBG Balance filter to adjust color by changing the highlights, midtones,
and blacks for a specific color channel. For example, you can change the values of
highlights in the Red channel and see the related changes in the Green and Blue channels.
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RBG Balance Filter Controls
The following section describes controls in the RGB Balance filter.

• Red Highlights: Allows you to adjust the values of the red highlights.
• Red Midtones: Allows you to adjust the values of the red midtones.
• Red Blacks: Allows you to adjust the values of the red blacks.
• Green Highlights: Allows you to adjust the values of the green highlights.
• Green Midtones: Allows you to adjust the values of the green midtones.
• Green Blacks: Allows you to adjust the values of the green blacks.
• Blue Highlights: Allows you to adjust the values of the blue highlights.
• Blue Midtones: Allows you to adjust the values of the blue midtones.
• Blue Blacks: Allows you to adjust the values of the blue blacks.
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Color Correction Examples

82

This chapter covers the following:
• Example: Using the Color Corrector Filter (p. 1386)
• Example: Using the Color Corrector 3-Way Filter (p. 1390)
• Example: Color Correcting a Three-Shot Sequence for Continuity (p. 1398)
• Example: Using the Color Corrector 3-Way Filter Match Hue Controls (p. 1404)
• Example: Using the Limit Effect Controls to Isolate a Specific Color Against Grayscale
(p. 1408)
• Example: Using the Limit Effect Controls of the Color Corrector Filter to Change a Specific
Color (p. 1409)
• Example: Using the Desaturate Highlights Filter (p. 1413)
This section provides examples of using Final Cut Pro color correction features to adjust
clips.
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Example: Using the Color Corrector Filter
The following example shows you how to use the Color Corrector filter to adjust a clip
that’s incorrectly color balanced and underexposed. This example shows a simple use of
color correction for a clip of a white cat on a white bedspread. The camera was incorrectly
white-balanced during the shoot, and the shot is also underexposed. Using the Color
Corrector filter, you can fix both these problems.

To use the Color Corrector Filter
1 Move the playhead in the Timeline over the clip you want to work on so that you can
see your changes output to video as you work.
2 Select the clip in the Timeline, then apply the Color Corrector filter to the clip.
For more information on applying filters, see “Using Video Filters.”
3 Open the clip in the Viewer by double-clicking it, or by selecting it and pressing Return.
4 Click the Color Corrector tab at the top of the Viewer to access the Color Corrector visual
controls.
Click the Color Corrector tab to
view the visual controls.

5 Choose Window > Arrange > Color Correction.
The Video Scopes tab is now displayed in the Tool Bench window. While color correcting,
it’s helpful to have the Video Scopes tab open to get a more detailed analysis of your
video as you work.
6 From the Layout pop-up menu of the Video Scopes tab, choose All to make sure that all
the scopes are available.
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Now you’re ready to begin adjusting the image.
Choose All so that
all video scopes are
available for you to use.

7 Click the Auto Contrast button to maximize the range from white to black in your clip.

Auto Contrast button

The Whites and Blacks sliders automatically adjust themselves to achieve the best numeric
distribution based on the luma levels shown in the Histogram. This gives you a starting
point from which to proceed.
8 Because the image is underexposed, adjust the Mids slider to bring more detail out of
the shadows.
Moving the Mids slider to the right moves the distribution of midtones farther to the
right, as you can see in the Histogram. Lightening this shot using the Mids slider, as
opposed to readjusting the whites, allows you to preserve the maximum amount of
available detail in the image. Otherwise, boosting the whites might result in the lighter
areas of your clip being blown out.
The Histogram reflects the
change in midtone levels.

The Waveform Monitor
reflects, the change
in midtones.

Chapter 82 Color Correction Examples

1387

Now it’s time to address the color. In the example, the white cat is tinted green because
the video camera was white-balanced incorrectly.
9 To compensate for the green tint, click the Auto-Balance eyedropper.

Click the eyedropper
near the Balance control.

Note: When this button is selected, your pointer turns into an eyedropper when you
move it into the Canvas.
10 Click the eyedropper in an area of the picture that’s supposed to be pure white.

Click in a white area
of the image, such as
the bedspread.

The Color Corrector filter automatically adjusts the Balance control to compensate for
whatever tint exists in that area of the picture. In this example, click a highlight of the
white bedspread.
Remember, don’t select an area that’s overexposed, like a light source or a shiny highlight.
This does not give you the result you want. Instead, select a properly exposed area of
your picture that’s white, like a well-lit shirt sleeve or white wall. You may have to try
several different spots to get the result you want; don’t hesitate to undo this operation
and try again if you’re not satisfied with the results of your initial selection.
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Because the picture was tinted into the blues, when you click the eyedropper in part of
the white bedspread, the color balance indicator moves into a mixture of red and yellow
to turn the whites of the image into true white.

The color balance
indicator moves to
correct the whites.

You can see the correction in the Canvas.

Before color correction

After color correction

Note: When using the Auto-Balance eyedropper, it’s important to recognize that the color
temperature of the light illuminating the white area you select will affect the hue of the
compensation that is made. For example, if the picture is lit with a combination of daylight
and tungsten sources, selecting a part of the picture illuminated by daylight will result
in compensating the overall color temperature of the image by adding more reds, whereas
selecting a part of the picture illuminated by tungsten will result in adding more blues.
In such a case, you need to simply pick the best possible compromise that looks right to
you.
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In general, using the Auto-Balance eyedropper will get you close to where you need to
be quickly and easily. However, to achieve the look you really want, you need to make
further adjustments to the Balance control by hand.
11 Click anywhere in the Balance color wheel and drag to move the color balance indicator
relative to its previous position.
Because you already used the Auto-Balance eyedropper to add more reds to compensate
for the blues that you didn’t want, this will be your starting point as you work to achieve
the particular effect you want for this scene. For example, you could drag the color balance
indicator farther into the direction of magenta in order to make the image look a bit
warmer and more inviting while preserving the corrected color balance.
Because you’re not worrying about matching this image to any other shots right now,
you can select whatever look you want. Whether you go warmer, cooler, or even into
other more surreal balances of color is purely a creative choice at this point. If you’re
going for a realistic look, however, it’s important to restrain yourself and stick to making
subtle changes.
Once you’ve achieved the color balance you want, it’s time to adjust the saturation of
your clip to complete the look of the shot.
12 Drag the Saturation slider to increase or decrease the saturation.
Be careful when you do this. A common mistake beginners make is to automatically
oversaturate shots to make them look “better.” While a highly saturated look is sometimes
appropriate, less saturation may actually improve the look of your footage. This is especially
true if you have a camcorder with artificially vivid color. In this case, it may be appropriate
to desaturate the image somewhat to keep it from looking too “hot.”
Note: As always, be careful to make adjustments to saturation only while looking at a
properly calibrated broadcast monitor. It can be very tempting to oversaturate the colors
of your clip based on the way video looks on a computer display. It’s a good idea to turn
on the Excess Chroma option (in the Range Check submenu of the View menu) to keep
yourself from inadvertently setting illegal chroma levels by boosting the saturation too
high.

Example: Using the Color Corrector 3-Way Filter
While the Color Corrector filter lets you adjust the overall color balance of a clip, the Color
Corrector 3-way filter gives you even more control by allowing you to adjust the color
balance of the shadows, midtones, and highlights individually. All three of these affected
parts of your picture overlap, allowing you to make extremely involved changes to your
picture. For additional information, see “Blacks, Midtones, and Whites.”
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The following example shows you how to use the Color Corrector 3-way filter to adjust
a clip that was both underexposed and shot with an incorrect white balance, giving it an
orange tinge.

To use the Color Corrector 3-Way filter
1 Move the playhead in the Timeline over the clip you want to work on so that you can
see your changes output to video as you work.
With an external broadcast monitor connected to your computer, and the External Video
submenu of the View menu set to All Frames, whichever frame is at the current position
of the playhead in the Canvas will be output to video.
2 Apply the Color Corrector 3-way filter to the sequence clip.
For more information on applying filters, see “Using Video Filters.”
3 Open the selected clip in the Viewer by double-clicking it, or by selecting it and pressing
Return.
4 Click the Color Corrector 3-way tab at the top of the Viewer to access the Color Corrector
3-way filter visual controls.
Click the Color Corrector
3-way tab to view the
visual controls.

5 Choose Window > Arrange > Color Correction.
The Video Scopes tab appears in the Tool Bench window. While color correcting, it’s
helpful to have the Video Scopes tab open to get a more detailed analysis of your video
as you work.
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6 From the Layout pop-up menu of the Video Scopes tab, choose All to make sure that all
the scopes are available.
Choose All so that
all video scopes are
available for you to use.

You are now ready to begin adjusting the image.
7 Click the Auto Contrast button to maximize the range from white to black in your clip.
The Blacks and Whites sliders automatically adjust themselves to achieve the best numeric
distribution based on the luma levels shown in the Histogram. This gives you a starting
point from which to proceed.

Auto Contrast button

If your image was incorrectly exposed, you can now adjust the Blacks, Mids, and Whites
sliders as necessary. As with all level controls, moving a slider to the right redistributes
the affected values farther to the right, making the affected parts of the image appear
brighter. Moving a slider to the left redistributes the affected values farther to the left,
making the affected parts of the image appear darker.
In this example, the image is underexposed, so move the Mids slider to the right to bring
more detail out of the image.

...so more detail comes
out in the image.

Move the
Mids slider to
the right...
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Tip: One of the key differences between film and video is that video preserves much
more information in the shadows of an underexposed image than film does. You might
be surprised at how much detail you can bring out of the shadows of an underexposed
video clip. On the other hand, video doesn’t preserve any information in overexposed
highlights, whereas overexposed negative film does. The picture in an overexposed film
shot can be corrected during the telecine process, so that you have the maximum amount
of information available to you when color correcting the transferred video.
Note: Unlike negative film, reversal film preserves details in dark areas, much as video
does.
Now it’s time to address the color. In the example, the image is too warm because the
video camera was color-balanced incorrectly for tungsten instead of daylight. Although
this is obvious by looking at the shot, you can see just how far off the color balance is by
looking at the cluster of color falling above and to the right of the Flesh Tone line in the
Vectorscope of the Video Scopes tab.
8 To begin to compensate for this, click the Whites Auto-Balance eyedropper.

Click the eyedropper
near the Whites control.

Note: When you click the eyedropper, your pointer turns into an eyedropper when you
move it into the Canvas.
9 Click the eyedropper in an area of the picture that’s supposed to be white. Depending
on the image, you may not necessarily want to select the purest white in the image. You
want to find an area of the image where you can see the tint, even if faintly.
Don’t select an area that’s overexposed, such as a light source or a shiny highlight. This
does not give you the appropriate result. Instead, select a properly exposed area of your
picture that’s white, such as a well-lit shirt sleeve or white wall.

Click the eyedropper in
the white background
in the rear window.

The Color Corrector 3-way filter adjusts the Whites control to compensate for whatever
tint is affecting the highlights and bright areas of your picture.
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Because the clip was tinted toward the reds, when you click the eyedropper in the white
piece of scenery outside the window, the Whites color balance indicator moves into a
mixture of blue and cyan and turns the whites of the image into true white.

The Whites color balance
indicator moves to
correct the whites.

You can see the correction in the Canvas.

Before

After

Note: When using the Whites Auto-Balance eyedropper, it’s important to recognize that
the color temperature of the light illuminating the white area you select will affect the
hue of the compensation that is made. If the picture is lit with a combination of daylight
and tungsten sources, selecting a part of the picture illuminated by daylight will result
in compensating the overall color temperature of the image by adding more reds, whereas
selecting a part of the picture illuminated by tungsten will result in adding more blues.
In such a case, you need to simply pick the best possible compromise that looks right to
you.
Next, you’ll focus on the blacks in your image, making further adjustments for more
accurate colors.
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10 Click the Blacks Auto-Balance eyedropper.

Click the eyedropper
near the Blacks control.

11 Click the eyedropper in an area of the picture that’s supposed to be neutral black.
Depending on the image, it may be more useful to pick a spot that’s a bit lighter than
pure black so that you can see the tint that’s affecting that part of the image.

Click the eyedropper in
the black of the headrest.

The Color Corrector 3-way filter adjusts the Blacks control to compensate for whatever
tint exists in the shadows of your picture. In this example, cyan is added to the blacks as
well, to compensate for the reds that exist in the shadows of the image.

Before

After

An optional step (usually if the clip you’re color correcting has a chip chart that was shot
along with the slate for that take) is to use the Mids Auto-Balance eyedropper.
12 Click the Mids Auto-Balance eyedropper, then click the eyedropper in an area of the chip
chart that’s supposed to be neutral gray.
The Color Corrector 3-way filter adjusts the Mids control to compensate for whatever tint
exists in the vast midrange of your picture.
If you don’t have a chip chart to refer to and are unsure of the neutrality of a gray in the
background, don’t worry about performing this step. You’ll generally get good results
from simply using both the Whites and Blacks Auto-Balance eyedroppers by themselves.
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After you’ve used the Auto-Balance eyedroppers to achieve a properly balanced image,
it’s time to fine-tune the color balance. To really get the look you want, you need to adjust
the various color balance controls by hand. When adjusting the color balance controls,
you always want to start by first correcting the whites and then correcting the blacks.
You’ve already performed these two steps using the Auto-Balance eyedroppers. Adjusting
the midtones now will allow you to make the most accurate correction, with the greatest
degree of control.
13 Drag anywhere within one of the color wheels to move the color balance indicator relative
to its previous position. Because you already used the Auto-Balance eyedroppers in the
whites and blacks, these positions will be your starting points if you make any further
adjustments.
In this example, drag the color balance indicator in the Mids color wheel more into a mix
of cyan and blue to give the image a cooler look, particularly in the actor’s face and the
roof of the car.

Adjust the Mids control
to add more blue.

A before-and-after comparison of this change illustrates the effect.

Before
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After

While making these adjustments, it’s a good idea to use the Flesh Tone line in the
Vectorscope to show you how accurately the color of the actor’s face is represented. As
you can see in the Vectorscope’s analysis of the “before” image, the cluster of colors about
the Flesh Tone line was still a little off. Adjusting the Mids control corrected for this.
Flesh Tone line

Before

After

Because you’re not worrying about matching this image to any other shots right now,
you can select whatever look you want. Whether you go warmer, cooler, or even into
other more surreal balances of color is purely a creative choice at this point. If you’re
going for a realistic look, however, it’s important to be restrained and stick to making
subtle changes.
Once you’ve achieved the color balance you want, it’s time to adjust the saturation of
your clip to complete the look you want.
14 Drag the Saturation slider to increase or decrease the saturation.
Be careful when you do this. A common mistake beginners make is to oversaturate shots
to make them look “better.” Although a highly saturated look is sometimes appropriate,
less saturation may actually improve the look of your footage. This is especially true if
you have a camcorder with artificially vivid color.
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In this example, the corrections applied so far have caused the image to be slightly
oversaturated. This is especially apparent in the red third of the RGB Parade scope, in the
Video Scopes tab.

Before adjusting
the saturation

After adjusting the
saturation, red levels
are slightly reduced.

Note: As always, be careful to make adjustments to saturation only while looking at a
properly calibrated broadcast monitor. It can be very tempting to mistakenly oversaturate
the colors of your clip based on the way video looks on a computer display. It’s a good
idea to turn on the Excess Chroma option (in the Range Check submenu of the View
menu) to keep yourself from inadvertently setting illegal chroma levels by boosting the
saturation too high.

Example: Color Correcting a Three-Shot Sequence for Continuity
Now that you’ve examined the specifics of using the Final Cut Pro color correction filters,
you are ready to use these filters to make a series of three shots in a scene match one
another. In the three shots shown in this example, two shots are taken from the same
clip, and one is an insert shot taken from a completely different clip.
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To color correct a three-shot sequence
1 Apply the appropriate color correction filter to all the shots in the sequence.

This makes it easy to use the Copy Filter controls to copy filter settings from one clip to
another as you make your adjustments.
2 Choose Window > Arrange > Multiple Edits to select the Multiple Edits window layout.
This is a useful layout for comparing multiple clips in a scene.

Multiple Edits layout

3 Choose Open from the Playhead Sync pop-up menu in the Viewer or Canvas (choosing
an option from the pop-up menu in either window sets both to the same playhead sync
mode).
This way, whichever clip is at the position of the playhead is automatically opened in the
Viewer. If all three clips have color correction filters applied to them and a Color Corrector
or Color Corrector 3-way tab is selected in the Viewer, the Viewer always displays the
color correction filter for the clip at the current position of the playhead.
Note: For more information about the Playhead Sync pop-up menu, see “Matching Frames
and Playhead Synchronization.”
4 In the Timeline, move the playhead to the first clip of the scene (for this example, the
master shot) to open it in the Viewer. (With the Playhead Sync pop-up menu set to Open,
the clip automatically opens in the Viewer.) Then click the color correction tab in the
Viewer to show the visual controls for that clip’s color correction filter.
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Note: Make sure that the playhead in the Timeline is over the first clip so that you can
see your adjustments output to your broadcast monitor as you make your corrections.
Move the playhead so
it’s in the first clip.

5 Perform your color correction. In this case, you’ll want to add a mix of blue and cyan to
cool down the shot of the woman on the balcony to match the tone of the shot around
the corner.

Adjust the Whites
control to add
more cyan.

Because the third shot in the sequence comes from the same clip as the first shot, you’ll
want to use exactly the same color correction settings to ensure continuity.
6 Apply the filter settings from the current clip to the third shot of the sequence using the
Copy To 2nd Clip Forward button (Control-5) or the Drag Filter button.

Copy To 2nd Clip Forward

Drag Filter
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7 In the Timeline, position the playhead over the second clip so that it opens in the Viewer.
Move the playhead so it’s
in the second clip.

There are three approaches you can take to compare the colors of the first and second
shots:
• Hold down the Control key while pressing and releasing the Up Arrow key to flip back
and forth between this clip and the first one to see the differences in color and luma
levels in the Canvas. As you do this, the image on your external video monitor updates
to show these two images. By flipping back and forth quickly, you can spot differences
in hue and contrast.
• With Final Cut Pro set to the Multiple Edits window layout, compare both clips side by
side on your computer screen. The previous clip appears in the Frame Viewer 2 tab to
the left, while the current clip appears in the Canvas. Although this won’t give you as
accurate a view of your clip as will looking at it on an external video monitor, you can
still compare the relative differences between the clips.
• Put the Frame Viewer 2 tab into split-screen mode. Clicking the V-Split or H-Split button
splits the Frame Viewer in half, by default showing the previous edit on the left or top,
and the current frame at the position of the playhead on the right or bottom. This
allows you to closely compare elements in both clips. The split screen can be freely
adjusted horizontally, vertically, or as a rectangular picture within a picture that can be
moved anywhere within the frame.

Split-screen mode

Tip: To view the contents of a Frame Viewer tab on an external video monitor, select the
Frame Viewer tab you want to view and press Shift-F12.
For more information on using the Frame Viewer, see “Comparing Two Frames in the
Frame Viewer.”
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As you compare adjacent clips in your sequence, remember to pay attention to the video
scopes. With Final Cut Pro set to the Multiple Edits layout, you can select the Video Scopes
tab in the far-right Tool Bench window.

The Multiple Edits
layout lets you easily
compare clips.

Note: The Video Scopes tab can be set to display the same choice of edit points as the
Frame Viewer tab. If you have a large enough display, you can create a custom layout
with multiple video scopes, each corresponding to a Frame Viewer tab showing the same
edit point.
Using the video scopes, you can quickly pinpoint specific differences between these shots
that may be difficult to figure out visually. For example, the Histogram and Waveform
Monitor show that the second shot is a little darker than the first. Pay particular attention
to the spike in the middle of the Histogram. By comparing the difference between the
size and location of each spike, you can adjust the level sliders to compensate.

First clip
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Second clip

Using information from the Video Scopes tab, you can adjust the Whites and Mids sliders
to make the two spikes of the Histogram match more closely, so you get comparable
luma levels. Moving one invariably results in some movement in the other, but keep
making your adjustments until the Histogram for the second shot approximates the
Histogram for the first shot.
8 With this accomplished, focus on the RGB Parade scope. It shows that the second clip
has far more blue and green than the first.

First clip

Second clip

Adding progressively more cyan to the midtones brings the hues of the two shots closer
to one another. As you adjust the Mids control, continue comparing the previous shot
and the current shot as outlined in step 7. Continue to make adjustments until the shots
match as closely as you need them to.
Note: Remember that your goal, in this case, is to balance all the shots in the scene so
that as the sequence plays, no one shot stands out from any of the others.
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Example: Using the Color Corrector 3-Way Filter Match Hue
Controls
This example shows how to use the Match Hue controls of the Color Corrector 3-way
filter to match the flesh tones of an actor in two different shots. In the first shot, the actor
is outside, and the color of the shot is correctly balanced for daylight and has a cool blue
look. In the second shot, the actor has walked inside, where the color is incorrectly
balanced for tungsten, causing it to be excessively warm and emphasizing the reds.

The Match Hue controls
let you match hues in
two different shots.

To use the Match Hue controls of the Color Corrector 3-Way filter
1 Choose Window > Arrange > Multiple Edits to select the Multiple Edits layout.
This layout makes it easiest to use the Match Hue controls.
2 Because you’re matching the colors of clip 2 to those in clip 1, apply the Color Corrector
3-way filter to clip 2.
3 Open clip 2 in the Viewer, then click the Color Corrector 3-way tab.
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As with any color correction, the first step is to adjust the contrast of clip 2 to match that
of clip 1 as closely as possible. In this case, raising the midtones by dragging the Mids
slider to the right brings out more detail in the actor’s face and matches the contrast of
clip 1 more accurately.

4 Once the contrast has been adjusted the way you want it, click the Match Hue eyedropper.

5 Move the pointer into the Frame Viewer 2 tab where clip 1 is showing. When the pointer
becomes an eyedropper, click a highlight in the actor’s face in clip 1.

Click a highlight.

Chapter 82 Color Correction Examples

1405

The Match Color indicator fills with this color to let you know it’s been selected, and either
the Whites, Mids, or Blacks Auto-Balance eyedropper is highlighted to let you know which
Auto-Balance eyedropper you should use in the next step.
Highlighted eyedropper

Match Color indicator

When selecting a match color, the level of the color you select affects how well the match
works. When matching flesh tones, choosing a highlight generally gives the best results,
but in certain circumstances you may achieve better results by choosing a midtone or
shadow.
Note: When selecting a highlight, make sure that the highlight you select is not
overexposed (for example, a reflection or surface with excessive shine), but rather
represents the lightest area of the actor’s face that accurately represents the skin tone.
6 Now, in the Color Corrector 3-way tab in the Viewer, click the highlighted Whites
Auto-Balance eyedropper.

Click the Whites
Auto-Balance
eyedropper.

The Auto-Balance eyedropper that is highlighted depends on what you selected as your
match color. If you selected a highlight, as in this example, the Whites Auto-Balance
eyedropper is highlighted, letting you know that it’s the appropriate eyedropper tool to
use. If you selected a shadow, however, the Blacks Auto-Balance eyedropper is highlighted.
Note: In general, it’s always a good idea to start by picking a match color that will highlight
either the Whites or Blacks Auto-Balance eyedropper, and make this adjustment first.
Adjust the midtones afterward, if it’s necessary to achieve the look you want.
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7 With the Whites Auto-Balance eyedropper selected, move the pointer into the Canvas
where clip 2 is displayed. When the pointer becomes an eyedropper, click a highlight in
the actor’s face in clip 2 that matches, as closely as possible, the highlight you selected
in clip 1.
Note: For best results, it’s extremely important to select an area of color in the clip being
corrected that accurately matches the level of the area of color you selected as the match
color.

Click a highlight in clip 2
that closely matches the
highlight you selected in
clip 1.

8 The Whites control adjusts, dipping into the blues to compensate for the overly warm
lighting. The color balance of clip 2 now approximates that of clip 1 much more closely.

If you’ve achieved the results you wanted, you can stop. Often, however, using the Match
Hue controls is simply the first step, and you will make other adjustments afterward.
Tip: Holding down the Shift key while adjusting the color balance control you’re working
with will lock the angle along which the color balance indicator moves, allowing you to
keep the exact hue of your adjustment the same.
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Example: Using the Limit Effect Controls to Isolate a Specific
Color Against Grayscale
This example shows you how to use the Limit Effect controls of the Color Corrector filter
to create the effect of a red bicycle against a grayscale background.

To use the Limit Effect controls to isolate a specific color
1 With the Color Corrector filter already applied, use the Limit Effect controls to isolate the
reds of the bicycle, then move the Saturation slider all the way to the left.

The reds of the bicycle
are desaturated, but the
background is left alone.

Move the Saturation
slider to the left.
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2 Click the Invert Selection button to reverse the key created by the Limit Effect controls.

Invert Selection button

The bicycle remains red
and the background
turns into various shades
of gray.

Example: Using the Limit Effect Controls of the Color Corrector
Filter to Change a Specific Color
This example shows you how to use the Limit Effect controls of the Color Corrector filter
to selectively change the color of a man’s pants from red to blue, without changing the
color of anything else in the frame.

This example shows how
to adjust the color of the
man’s pants only.
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To use the Limit Effect controls to change a specific color
1 With the Color Corrector filter already applied, click the Select Color eyedropper.

Click the Select
Color eyedropper.

2 In the Canvas, click the eyedropper in the man’s red pants to select a primary key color.
Try to pick a color value that lies somewhere between the brightest and darkest areas to
which you’re trying to limit the effect.

Click a color in the pants
to get a good starting
value of red.

The Limit Effect controls
change to include the
selected color range.

Now, you’ll make a hue adjustment so that you can see the area you’re trying to isolate.
3 To make the pants pink, rotate the Hue control toward magenta.
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You can also use the View Final/Matte/Source button (the key) to view the key itself as a
grayscale image while you make changes. Adjusting the Limit Effect controls while viewing
the color correction effect is more interactive.
Rotate the Hue control
toward the color you
want the pants to be.

The color of the affected
area is changed by
the rotation of the
Hue control.

4 To fine-tune the effect, move the top two handles of the Color Range control outward
to include more of the yellow area of the picture.
You can also widen the bottom handles to increase the tolerance of the selected color
range and include a greater range of color at the edge of the primary key color.
Drag the top handles
out to widen the range
of hues to key on.

Drag the bottom handles
out to increase the
tolerance of the key color.

If you need to readjust the range of hues between these handles, drag in the color gradient
and move the range of hues left or right in relation to the Color Range handles.
Now that you’ve selected the main key color range, you can make adjustments to the
luma to increase the amount of the picture that is affected by the key.
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5 Move the top handles in the Luma control to select a primary luma range to affect, then
adjust the bottom handles to adjust the tolerance.

The key color range
is increased.

Widen the range of luma.

6 Finally, make similar adjustments to the Saturation control to further increase the range.
You can even include the edges of the yellow shirt.

The key color range
is further increased.

Widen the range
of saturation.

Note: As you work, changes made to one control may change the effectiveness of the
others. For example, a different saturation range may work better if adjustments are also
made to the Luma control.
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Example: Using the Desaturate Highlights Filter
In this example, the use of a color correction filter to bring color detail out of the blues
of a diving clip has resulted in some unwanted reds in the bright highlights of the image.
To eliminate these unwanted reds without losing the other colors of the diver and the
background, you’ll use the Desaturate Highlights filter.

Unwanted reds in
the bubbles

Unwanted reds in
the edge highlights

To use the Desaturate Highlights filter
1 Move the Apply Above slider to the left to gradually include more of the brightest areas
of the picture in the range of what is to be desaturated.
Move the Apply Above
slider to the left to include
more bright areas.

You can see the effects of
the filter in the Canvas.

Move the Softness slider
to the right to ease
the transition.

2 Move the Softness slider to the right to ease the transition between the areas of the
picture being desaturated and the areas that are unaffected.
Depending on the range of values you’re choosing to desaturate, raising the softness can
keep this effect from looking artificial.
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Color Correction with Color
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This chapter covers the following:
• Using Color for Color Correction (p. 1415)
To work on your project in a dedicated color correction environment, you can send your
sequence to Color for professional-level color correction and grading. You can use the
Send to Color command to send your footage to Color or export your sequence to the
Final Cut Pro XML Interchange Format and import the XML file into Color.

Using Color for Color Correction
The basic stages in the Color workflow are described below.
Stage 1: Preparing Your Sequence for Working in Color
There are a couple of steps you can take to prepare your edited sequence to work in
Color more efficiently. To be safe, make a copy of your sequence before making any of
these changes.
• To simplify navigation and correction in Color, move all clips that are superimposed
for editing purposes to track V1. This does not apply to clips that are superimposed to
create a composited effect; those clips should be left alone.
• To ensure optimal performance when working in Color, it’s also a good idea to break
long sequences (such as those for feature-length projects) into approximately 22-minute
reels (the length is arbitrary, but 22 minutes is the standard length of a film reel). Each
reel should begin and end at a good cut point.
Stage 2: Preparing Your Media for Working in Color
Once you’ve prepared your sequence, you should also prepare your project’s media.
• If you’re handing your project off to someone at another facility, you may want to take
the opportunity to process your sequence using the Media Manager to trim your media
to only what’s necessary for the finished sequence.
• For the best results, you should also recapture all offline-quality media at its native
online resolution.
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• Lastly, if you want to use Color to correct clips such as generators, still images, or
imported Motion projects, you should export them as self-contained QuickTime files
and use these to replace the original clips in your sequence. If you don’t need to work
on them in Color, you can leave these clips alone. These effects clips will simply be
ignored when you send the sequence to Color, and they will reappear when you send
the project back to Final Cut Pro.
Stage 3: Sending Your Sequence to Color
If Color is installed on the same computer as Final Cut Pro, you can select the sequence
and choose File > Send To > Color. The project data is automatically transferred to Color
using XML and is converted to a Color project.
If Color is on a remote computer, you can select your sequence and choose File > Export
> XML. Copy the XML file and all of the necessary media files to a hard disk and bring it
to the Color system, then import the XML file into Color.
Stage 4: Color Correcting in Color
Use the tools in Color to color correct each clip in your sequence.
Stage 5: Sending Your Color Project Back to Final Cut Pro
After you finish working in Color, you’ll render every clip in your Color project to create
a new set of color-corrected media files. When you send the Color project back to
Final Cut Pro, the resulting sequence refers to the new color-corrected media files.
Note: You can also use an EDL to transfer clip information between Final Cut Pro and
Color; however, your functionality will be much more limited. This workflow is
recommended only for projects being reconformed and finished at 2K resolution in Color.
For detailed instructions on all of the above steps, see the Color User Manual, available in
Color Help.
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Using RT Extreme
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This chapter covers the following:
• Introduction to Real-Time Processing (p. 1417)
• Locations for Changing Real-Time Playback Settings (p. 1422)
• About Real-Time Playback Options (p. 1424)
• Still-Image Real-Time Playback (p. 1431)
• Improving Real-Time Performance (p. 1432)
• Real-Time Audio Mixing in Final Cut Pro (p. 1433)
• Choosing Real-Time Playback Versus Rendering (p. 1435)
• Supported Real-Time Playback Codecs (p. 1436)
• Using a Third-Party Video Effects Accelerator Card (p. 1437)
• Using RT Extreme for Video Output (p. 1438)
• Viewing Your Composition in the QuickView Tab (p. 1438)
RT Extreme is the real-time effects architecture that allows you to play back multiple video
layers, video and audio filters, motion effects, and other effects in real time without
needing to render them first.

Introduction to Real-Time Processing
Final Cut Pro handles real-time processing with a feature called RT Extreme. The term real
time refers to an editing system’s ability to calculate the final image while maintaining
an acceptable frame rate and visual quality. In other words, you can see the results of an
effect as soon as you play your video. Real-time processing is the opposite of rendering,
in which you have to wait for an effect to be calculated and stored on disk before you
can see the results.
For basic editing tasks, Final Cut Pro handles real-time processing automatically, keeping
you focused on the creative choices at hand. However, if you work with a lot of effects
or if you color correct video footage, you should take some time to learn the details about
the real-time architecture of Final Cut Pro.
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Being able to see your sequence play back in real time, regardless of the quality, is often
more important than seeing full-quality video. By default, Final Cut Pro attempts to
calculate video at full quality. However, it’s fairly easy to exceed your computer’s ability
to calculate effects in real time and at full quality.
To maintain your creative pace, avoid rendering, and maximize performance, Final Cut Pro
provides several real-time playback modes, such as Safe RT and Unlimited RT.
To learn about where you can change real-time playback settings, see “Locations for
Changing Real-Time Playback Settings.”
To read detailed explanations about each real-time playback mode, see “About Real-Time
Playback Options.”

Real-Time Playback Versus Rendering
For most stages of editing, reduced playback quality is more acceptable than losing the
ability to play back effects in real time. Toward the end of a project, during the “finishing”
stages such as color correction and output, you can choose to render at full quality to
ensure the best results. For more information, see “Rendering and Video Processing
Settings.”
Note: Final Cut Pro always displays real-time previews using 8-bit processing.

How Real-Time Processing Works
Consider a clip placed in a sequence. Even when no effects are applied to the clip,
Final Cut Pro and your computer must do a certain amount of work to play back the
media file associated with that clip: the hard drive must be able to read the frames of
video as fast as they need to be displayed, and the computer processor must decode
each video frame into uncompressed pixels that are then shown on your computer display.
In the past, even the most expensive computers could barely achieve the required hard
disk and processor speeds. Editors often had to install specialized video cards that could
provide the necessary processing power for playback. Today, personal computers can
easily achieve video playback and still have a lot of processing power left to spare.
How Final Cut Pro Calculates Processor Workload
You can process your video footage in a remarkable number of ways: by adding video
filters, adding motion effects such as scaling and rotation, making speed changes, adding
transitions between clips, and compositing multiple video layers. All of these effects are
really just mathematical operations performed on the pixels of your video. The more
effects you add to a clip, the more operations are required to display the results.
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Final Cut Pro analyzes a sequence to determine the processor workload required for
playback. Different portions of a sequence may require different amounts of processing.
Final Cut Pro breaks the sequence into segments and then indicates the processor
workload for each segment with a colored status bar. For more information, see “About
Render Status Bars.”

Status bars in the
Timeline indicate the
workload for each
segment; the upper bar
is for video, and the
lower bar is for audio.

For example: You edit a DV clip into a sequence. Final Cut Pro adds up the processor
“expenses” of reading the media file from your hard disk and decompressing the DV
frames. Because these processor “expenses” are fairly low, the color of the status bar over
that clip in the Timeline indicates that real-time playback is possible.
Now you add a color correction filter to a clip. Playback of this clip is now more “expensive”
for the processor because more calculations must be performed to display the result.
Final Cut Pro compares the number of required calculations to the speed of your
computer’s processor. If the processor “expenses” are low enough, the clip can still be
played in real time, even with the additional color correction filter.
Achieving Real-Time Playback When Processor Power Is Exceeded
As you add more effects to a clip, more processing power is required to play that segment
of the sequence. If too many effects are added, Final Cut Pro recognizes that the number
of calculations is too “expensive” for the processor, and the color of the status bar changes
to indicate that playback may still be in real time but no longer at full quality.
To keep your edit session moving and render-free, Final Cut Pro has several real-time
playback settings that balance playback quality with a minimum of dropped frames. For
a complete explanation of real-time playback settings, see “About Real-Time Playback
Options.”
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What Are Dropped Frames?
Dropped frames are frames that are unintentionally skipped during playback, either
because the hard disk cannot keep up with the video data rate or because the computer
processor cannot perform all of the applied effects in time. Some real-time playback
modes allow dropped frames, while others require rendering to avoid dropped frames.
Dropped frames during editing are usually tolerable. However, during output, dropped
frames are almost always unacceptable.

Identifying Which Effects Can Play Back in Real Time
The real-time status of effects can be identified in several places:
• Timeline and audio clip item render status bars
• Tooltips in render status bars
• Filter and transition names in boldface type
About Render Status Bars
The presence of a colored status bar in the Timeline indicates that a clip requires some
kind of processing. There are two render status bars above the Timeline ruler. The upper
one is for video and the lower for audio. These render bars indicate which segments of
a sequence will play in real time, the quality of playback, and which segments require
rendering.
Status bars appear near
the top of the Timeline.
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About Render Status Bar Tooltips
If you position the pointer over a render bar, a tooltip appears with information about
the real-time or render status of that section of your sequence.

A tooltip tells you the
status of a particular
section of your sequence.

Effect Names That Appear in Boldface
In both the Effects tab of the Browser and the Effects menu, video transitions and filters
that can play back in real time appear in boldface.

Real-time effects appear
in boldface.

A real-time effect appears in boldface based on:
• The video format used by the currently selected sequence. Video formats that have
higher system requirements for real-time playback result in fewer effects displayed in
boldface.
• The processing capabilities of your computer, such as the processor speed and the
amount of installed RAM
• The playback video quality and frame rate selected in the RT pop-up menu
• The external video option you have selected in the A/V Devices tab of the Audio/Video
Settings window, and whether or not it is turned on.
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• The capabilities of the currently selected video effects accelerator card (if you are using
one for real-time video processing)
Note: The number of effects that appear in boldface may change depending on the
current sequence settings and which real-time playback settings are selected.

Locations for Changing Real-Time Playback Settings
Real-time playback options can be adjusted in three locations:
• The Playback Control tab of the System Settings window
• The RT pop-up menu in the Timeline
• The Render Control tab of the Sequence Settings window
Note: The Playback Control tab and the RT pop-up menu contain many of the same
settings, so the settings are described in “About Real-Time Playback Options.”

Playback Control Tab in System Settings
The Playback Control tab is located in the System Settings window. It shows you all
real-time settings available, although some may not apply to certain sequences. Changes
you make here are applied systemwide, so they remain the same for all currently open
sequences and projects.

Many of the same
settings are found in
the RT pop-up menu
in the Timeline.

µ
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To open the Playback Control tab
Choose Final Cut Pro > System Settings, then click the Playback Control tab.
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RT Pop-Up Menu in the Timeline
This menu only shows you real-time options available for the current sequence. For
example, pull-down pattern options only appear in the RT pop-up menu under appropriate
circumstances (such as a 23.98 fps sequence with external video set to output to a 29.97 fps
format).
RT pop-up menu

Because the settings in the RT pop-up menu and the Playback Control tab are almost
identical, it is often more convenient to access the RT pop-up menu directly from the
Timeline.
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To change a real-time playback setting in the RT pop-up menu
Make sure a sequence is open in the Timeline, then choose an option from the RT pop-up
menu.

Settings in the
RT pop-up menu

Render Control Tab in Sequence Settings
Several options that affect both rendering and real-time playback can be selected in the
Render Control tab of the Sequence Settings window. These settings are adjusted per
sequence.
You can deselect any of the following options to improve real-time performance:
• Filters
• Frame Blending For Speed
However, remember to select these options if you want to render these effects.
To open the Render Control tab
1 Select a sequence or click in the Timeline window to make it active.
2 Choose Sequence > Settings, then click the Render Control tab.

About Real-Time Playback Options
The following options, most of which are available in both the RT pop-up menu and the
Playback Control tab of the System Settings window, allow you to control the quality of
real-time playback.
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Safe RT
The Safe RT mode guarantees that effects are played back at the quality and frame rate
you specify and that no frames are dropped during playback. If Final Cut Pro anticipates
that your computer won’t be able to perform all the effects calculations in real time, the
render status bar for that segment becomes red, which means you have to render before
you can play back.
Red render bars indicate
rendering is required.

Before using the Print to Video or Edit to Tape commands to output to tape, you can
switch to Safe RT mode to see how many segments require rendering.
Important: Even though the Safe RT option guarantees that no frames will be dropped
because of processor limitations, frames may still be dropped if your scratch disk cannot
maintain the necessary data rate during playback. This can be a problem if you have
multiple video streams playing from a relatively slow hard disk. In this case, the Timeline
may show a green render bar, indicating that the processor can handle the effects load,
but you may still drop frames because of slow disk performance. To solve this issue, you
can limit the acceptable real-time data rate of media playback in the General tab of the
User Preferences window. For more information, see “Choosing Settings and Preferences.”

Unlimited RT
Choosing this option tells Final Cut Pro to play as many frames as possible when your
effects exceed the processing power of your computer. Final Cut Pro does this by spending
time to process some frames in real time while skipping others completely. Unrestricted
real-time playback allows you to play more effects but increases the likelihood that your
sequence will drop frames during playback. This mode is useful for getting a real-time
preview of complex effects compositions. Embedded Motion projects can also be played
back in this mode.
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Red render bars in Safe RT mode become orange in Unlimited RT mode, indicating that
Final Cut Pro may drop frames during these segments to achieve real-time playback.
Orange status bars indicate
Unlimited RT playback.

Note: Segments that can play back without dropping frames still appear with colored
render bars as they would in Safe RT mode.
Unlimited RT mode uses the playback video quality and frame rate options you choose
in the RT pop-up menu or the Playback Control tab. However, this mode overrides the
Play Base Layer Only option and attempts to calculate all applied effects. For more
information, see “Play Base Layer Only.”
Unlimited RT performance varies greatly depending on the effects in your sequence, the
codec and data rate of your media, and the processing power of your system. Some
segments of your sequence may play back without dropping any frames, while other
sections may rarely update the Canvas.
Tip: Turning on Unlimited RT is the only way to turn on third-party FXScript filters and
transitions to play in real time, if they’re capable of doing so.

Play Base Layer Only
The Play Base Layer Only option takes a unique approach to playing back
processor-intensive segments. With this option selected, any segment that requires
rendering in Safe RT mode (in other words, any segment with a red render bar) is restricted
to original media playback, and all effects, including compositing modes, are turned off.
Here are the playback rules for the Play Base Layer Only option:
• Effects that can be played back in real time are played just as they would be in Safe RT
mode.
• If a clip has effects applied, the effects are ignored if they can’t be played in real time.
Only the underlying clip media is displayed.
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• Clips with compositing modes applied can never play back in real time, so they are
ignored and only clips on lower-numbered tracks are displayed. Of course, a clip on a
lower-numbered track that has a compositing mode applied will also be ignored.
• Transitions that cannot be played back in real time are disabled, so only the underlying
clip media is displayed.
The Play Base Layer Only option also affects audio playback. When playing over an
unrendered portion of a sequence, no effects are played back. The number of audio tracks
that play depends on whether or not you have selected the Play Base Layer Only option.
• If selected: The first two tracks of audio play back.
• If unselected: The number of audio tracks that play back is determined by the number
of real-time audio tracks you have set in the General tab of the User Preferences window.
The clip in track V1 is shown
in the Canvas without effects.
The clip in track V2 is shown
in the Canvas without effects.

Unrendered audio plays
back without effects.

This video transition is
not shown in the Canvas.

Beep When Playing Unrendered Audio
This option is available only in the Playback Control tab of the System Settings window.
When this option is selected, audio clip items that require rendering are played back as
audible beeps. This is the audio equivalent of the “Unrendered” screen you see when
your video requires rendering. If the Play Base Layer Only option is not selected, the beeps
are not heard. For more information, see “Play Base Layer Only.”
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Scrub High Quality
When this option is selected, video displayed in the Canvas is shown at full quality when
you scrub or when the video is stopped. If you deselect this option, the video quality
during scrubbing is determined by the current Playback Video Quality setting (see
“Playback Video Quality”). Deselecting this option allows you to improve responsiveness
during scrubbing, especially when using processor-intensive codecs such as HDV, or
options such as multiclip playback.

Playback Video Quality
Most codecs support more than one level of playback quality to improve real-time
performance. Some codecs support three playback quality levels—high, medium, and
low—while others support only high and low quality. Selecting a lower playback quality
can increase the number of simultaneous real-time effects you can play.
• Dynamic: This option allows Final Cut Pro to automatically change between high,
medium, and low quality as necessary to maintain real-time playback. In this case, the
quality of the video resolution can change frame by frame. For more information, see
“Multiclip Playback.”
• High: Guarantees full-frame, full-resolution video playback. Video interlacing is preserved.
• Medium: Displays every other pixel and every other line (this is known as quarter frame
resolution). Because only half the lines are shown, the video is displayed without
interlacing. Media is decompressed using a full-quality decompression algorithm.
• Low: Like the Medium quality option, displays video at quarter frame resolution.
However, your media is decompressed and displayed with a low-quality decompression
algorithm, which requires significantly less processing power.

Playback Frame Rate
The more you reduce the number of frames Final Cut Pro calculates each second, the
more effects can be calculated in real time.
• Dynamic: This option varies the displayed frame rate as necessary to achieve the
highest-quality playback with the most effects. When more processing power is required,
Final Cut Pro can reduce the frame rate to spend more time calculating fewer frames.
When few or no effects are applied, Final Cut Pro can return to playback at the full
frame rate. For more information, see “Multiclip Playback.”
• Full: Your sequence plays back at the frame rate (editing timebase) assigned in the
Sequence Settings window.
• Half: Your sequence plays back at half its assigned frame rate. For example, if the frame
rate of your sequence is 24 fps, the playback frame rate is 12 fps.
• Quarter: Your sequence plays back at a quarter of its assigned frame rate. If the frame
rate of your sequence is 24 fps, the playback frame rate is 6 fps.
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About Dynamic Real-Time Playback
To maximize the number of effects you can see during real-time playback, you can choose
to have Final Cut Pro automatically adjust the video quality, the frame rate, or both during
playback. This is called dynamic real-time playback.
Dynamic real-time playback continually adjusts video quality on a frame-by-frame basis.
Segments of a sequence that require minimal processor workload are displayed at higher
quality, and more processor-intensive segments are displayed at lower quality. Since
Final Cut Pro automatically adjusts the playback quality as necessary, you always get the
highest-quality playback possible without having to stop playback to make video quality
adjustments.
Playback video quality and frame rate are independent settings, so you can choose to
make one dynamic while keeping the other fixed. For example, if you need to see every
frame during playback, you should set the playback frame rate to Full while setting the
playback video quality to Dynamic. In this case, your sequence video quality may be
reduced during playback, but you will always see every frame. On the other hand, if you
are doing detailed compositing work that depends on high-quality video display, you
can set your sequence playback video quality to High and set your sequence frame rate
to Dynamic.
If neither frame rate nor video quality is critical, you can choose Dynamic for both playback
video quality and frame rate.

Multiclip Playback
This option allows you to watch all angles of multiclip play at once in the Viewer while
you switch or cut in real time. When this option is selected and you choose Open from
the Playhead Sync pop-up menu, multiclips in your sequence are automatically opened
in the Viewer, and all angles play back at the same time while the active angle plays in
the Canvas. For more information, see “Working with Multiclips.”

Pull-down Pattern
If your sequence has a frame rate (editing timebase) of 23.98 or 24 fps and you want to
output to an NTSC or PAL device via FireWire, you can choose one of five pull-down
insertion patterns. Pull-down insertion is a method of converting film or other progressively
scanned material to an interlaced format playing at a different frame rate. For detailed
information about pull-down patterns, see “Working with 24p Video.”
The Pull-down Pattern pop-up menu is available in the Playback Control tab of the System
Settings window. Pull-down options appear in the RT pop-up menu only when your
sequence has a frame rate of 23.98 or 24 fps and Final Cut Pro is currently set up to output
to a DV NTSC or PAL FireWire device. Some options may not be available if your computer
does not have sufficient processing power.
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The following three pull-down patterns are available when your sequence has a frame
rate of 23.98 fps and you choose 29.97 fps external video output.
• 2:3:2:3: This pattern is the most processor-intensive method of introducing pull-down
but outputs NTSC video with the least noticeable temporal artifacts. For this reason,
2:3:2:3 pull-down is generally considered to have the most acceptable quality of motion.
This pull-down pattern is also referred to as 3:2 pull-down.
• 2:3:3:2: Also known as advanced pull-down. This pattern requires less processing to
output than 2:3:2:3 pull-down because 2:3:3:2 pull-down requires recompression or
regeneration of fewer frames, but the perceived motion quality is lower than when
using 2:3:2:3 pull-down.
• 2:2:2:4: This pull-down pattern requires less processing, so it is a good choice if you
want to preview video with as many real-time effects as possible. Keep in mind that if
you choose this pull-down pattern, you won’t be able to easily remove the pull-down
later.
The following two patterns are available when your sequence has a frame rate of 24 fps
and you choose a 25 fps external video output.
• 24@25 Pull-down: In this pattern, frames 12 and 24 are pulled down for a duration of
three fields instead of two, creating a subtle stutter each half second. For 25 fps output,
this pattern has the best perceived motion quality.
• 24@25 Repeat: This pattern simply repeats every 24th frame once to fit 24 fps footage
into 25 fps. This causes a noticeable stutter every second, but requires less processing
than the 24@25 pull-down pattern because no special interlacing is required.

Gamma Correction
This pop-up menu is available only in the Playback Control tab (not the RT pop-up menu)
on older systems with graphics cards that don’t support gamma correction. If your
computer’s graphics card does not support gamma correction, you have two options:
• Accurate: High-quality gamma correction. This option is the most accurate but also
requires the most processing power.
• Approximate: Lower-quality gamma correction. This option leaves more processing
power available for real-time effects but results in less-accurate color and brightness
rendition.
For more information, see “Choosing Real-Time Playback Gamma Correction Options.”

Record Settings
When using the Print to Video and Edit to Tape commands, you can control the quality
of video being output to tape independently of the real-time playback video quality in
the Canvas and Timeline.
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Full Quality
When this option is selected, video is always output to tape at the highest quality. Areas
of your sequence that won’t play back at full resolution in real time must be rendered
prior to output.
Use Playback Settings
Final Cut Pro uses the selected real-time effects playback settings when outputting your
sequence to tape. If, as a result, your sequence will output at less than full quality, you
are warned of this prior to output. Outputting to tape at draft quality is useful for quickly
creating sample tapes of your program when you don’t have the time to render all
necessary effects first.

Video Scopes Playback
When the Video Scopes tab of the Tool Bench window is open, you can choose whether
the scopes update in real time or only when playback is stopped.

Still-Image Real-Time Playback
Still images and imported graphics can also play back in real time. The number of still
images that play back in real time depends on the size of the still cache set in the Memory
& Cache tab of the System Settings window.

You can adjust the
Still Cache slider or
enter a value to change
the number of still
images that play back
in real time.

The size of the still cache is limited by the total amount of unused physical RAM installed
in your computer. The larger the still cache, the more still images can be played back in
real time in the currently selected sequence. If another sequence is opened, the contents
of the still cache are automatically replaced with still images from the new sequence.
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Improving Real-Time Performance
If the processing demands of all applied effects exceed the capabilities of your system,
you have several options to improve real-time performance:
• Reduce the playback video quality and frame rate in the RT pop-up menu in the Timeline
or in the Playback Control tab of the System Settings window. For more information,
see “Playback Video Quality” and “Playback Frame Rate.”
• Play your sequence using the Unlimited RT mode instead of the Safe RT mode. For
more information, see “Safe RT” and “Unlimited RT.”
• Choose the Play Base Layer Only option from the RT pop-up menu. For more information,
see “Play Base Layer Only.”
• Render any clips whose render status bars indicate they can’t be played in real time
before you play them back. For more information, see “Rendering and Video Processing
Settings.”
• Turn off external video monitoring. For more information, see “External Video
Monitoring.”
• Turn off dropped frame reporting during playback. For more information, see “Reporting
Dropped Frames During Playback.”

Reporting Dropped Frames During Playback
Dropped frames during playback may indicate that your hard disk is too slow or your
video footage uses a codec too processor-intensive for your computer processor to handle.
If you plan to output your sequence to tape, you will need to resolve this issue at some
point. However, for editing purposes, you can turn off the display of the message that
appears when dropped frames occur.
To turn off the dropped frames message
1 Choose Final Cut Pro > User Preferences.
2 In the General tab, deselect the “Report dropped frames during playback” checkbox.
Note: A separate option, “Abort ETT/PTV on dropped frames,” controls whether
Final Cut Pro cancels playback if frames are dropped during Print to Video and Edit to
Tape operations. In most cases, you should keep this checkbox selected.

Factors That Affect Real-Time Performance
Many components of your computer affect its real-time performance:
• Computer processor speed and type: The faster your computer processor is, the more
real-time effects Final Cut Pro can perform. The type of processor can also make a
difference. For example, a G5 processor is more powerful than a G4 processor, and a
Core 2 Duo processor is more powerful than a Core Duo processor.
• Multiple processors: Computers with more than one processor have significant real-time
performance advantages over single-processor computers.
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• Graphics card speed and memory: Many video filters in Final Cut Pro use your computer’s
graphics card to process effects, leaving the computer processor free to perform other
tasks. A faster graphics card with more RAM allows more real-time playback.
• Level 2 and Level 3 processor cache: The sizes of a computer processor’s level 2 and 3
caches affect its real-time playback capabilities. The larger these caches are, the more
real-time performance is available.
• RAM: The more RAM you have available in your computer, the more potential real-time
performance your computer has.
• Memory bus speed: Computers with a faster memory bus allow better real-time
performance because data can be sent more quickly between RAM and the computer
processor.
• Hard disk speed: The faster your hard disk can read data, the more video data
Final Cut Pro can access in real time. With some video formats, such as uncompressed
video, hard disks may not be able to keep up with the video data rate, making real-time
playback impossible. Multiclips and multiple video layers require many video streams
to play back simultaneously. A faster hard disk allows more streams to play back
simultaneously in real time.
• Codec: Not all codecs are supported by RT Extreme, but the most commonly used ones
are. Some codecs require more processing power and RAM to play back than others.
For example, the long-GOP MPEG-2 compression used by HDV requires more RAM and
processing power to decompress than I-frame-only codecs such as DV. For more
information, see “Supported Real-Time Playback Codecs.”
• External video monitoring: Enabling output via FireWire or other video interfaces requires
additional processing power and may limit the number of effects you can play back in
real time. For more information, see “External Video Monitoring.”

Real-Time Audio Mixing in Final Cut Pro
Final Cut Pro can mix and play back multiple audio tracks in a sequence in real time, even
while you make adjustments to levels, stereo pan, and audio filters. The number of tracks
that can be played back depends on the number of filters applied to your clips and your
computer’s capabilities and settings, including:
• Your computer’s processor speed
• The seek time and sustained transfer rate of your hard disk
• The amount of RAM available to Final Cut Pro
• The Audio Playback Quality setting in the General tab of the User Preferences window
Note: For information on this setting, see “Choosing Settings and Preferences.”
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Different filters and transitions affect real-time playback to varying degrees. If Final Cut Pro
can’t mix all the tracks in a sequence in real time, you hear a series of beeps indicating
that part or all of your sequence must be rendered before being output as a final mix.
Tip: You can turn these beeps off by deselecting the Beep When Playing Unrendered
Audio checkbox in the Playback Control tab of the System Settings window.

Calculating the Number of Tracks That Can Be Played Back in Real Time
The number of tracks Final Cut Pro attempts to mix in real time is determined by the
Real-time Audio Mixing setting in the General tab of the User Preferences window. The
number of tracks you can play back in real time is largely dependent upon your hardware,
so performance will vary from system to system. Increasing the number of tracks in this
field doesn’t mean they’ll all play.
Important: If the number of tracks is set too high, you may have dropped frames during
playback.
To determine the number of tracks your system can play back in real time
1 Add a video clip with a typical data rate for your working environment to your sequence.
2 Add 16 or more audio clips at the same point in time as your video clip.
3 Choose Final Cut Pro > User Preferences, then click the General tab.
4 In the Real-time Audio Mixing field, enter the number of tracks in the sequence.
5 Make sure the “Report dropped frames during playback” checkbox is selected.
6 Click OK.
7 Play back the sequence.
If your system cannot perform real-time playback of the number of tracks in the sequence,
you see a “dropped frames” message.
8 If you have dropped frames, reduce the number of tracks in the sequence and play it
back again. Repeat this step until the sequence plays without dropped frames.
9 Set the number of tracks for the Real-time Audio Mixing option in the General tab of the
User Preferences window to the number that played back without dropped frames.
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Improving Real-Time Audio Performance
You can optimize real-time audio performance in the following ways:
• Render video effects prior to mixing: Playing real-time video effects reduces the number
of audio tracks that can be mixed in real time. While mixing the audio in your program,
you can maximize real-time mixing performance by first rendering all video effects in
your sequence, including all transitions, layered video, and filters. Video and audio
render files are maintained separately, and changes made to the audio levels in your
sequence do not affect the video effects that have already been rendered. For more
information on rendering the video effects in a sequence, see “Rendering and Video
Processing Settings.”
• Render audio filters: Even though many audio filters play in real time, unrendered filters
can reduce the number of tracks you can mix in real time. The number of audio tracks
you can play without rendering depends on how many filters are applied and how
many audio tracks you’re trying to mix at once.
To increase the number of audio tracks that can be mixed in real time in sequences
with audio filters applied, you can perform item-level rendering on individual audio
items in the Timeline. By rendering audio items with filters individually, audio and pan
levels can continue to be mixed in real time, and you can make level changes without
rerendering. For more information, see “More About Audio Render Options” and
“Rendering Audio Items in a Sequence.”
• Use the Mixdown command to prevent dropped frames: If you have a complex audio mix
with numerous clips, keyframes, filters, and transitions, the mix may start to affect the
playback of your sequence. Also, if the Audio Playback Quality setting in the General
tab of the User Preferences window is set to High, you may get dropped frames in your
audio. You can use the Mixdown command in the Sequence menu (available by
choosing Sequence > Render Only > Mixdown) to render all the audio tracks in a
sequence, along with their accompanying transitions and filters, into a single render
file. For more information, see “Using the Mixdown Command.”

Choosing Real-Time Playback Versus Rendering
Here are some practical examples of when you might use real-time playback versus
rendering during the course of editing your movie.
To monitor video or output to tape with perfect playback of all effects in a sequence
(with no dropped frames and full-resolution video)
1 In the RT pop-up menu in the Timeline, choose Safe RT, so there’s a checkmark next to
it.
The Safe RT mode ensures that effects play back at the quality level and frame rate you
specify.
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2 In the Playback Video Quality section of the RT pop-up menu, choose High, so there’s a
checkmark next to it.
This option may force you to render your effects (sections of your sequence that need to
be rendered are indicated by a red render bar in the Timeline).
3 In the Record To Tape section of the RT pop-up menu, choose Full Quality, so there’s a
checkmark next to it.
The following workflow is usually acceptable when you want to output a rough cut to
tape to present it to other people. Use this method when you want to get an idea of what
your video looks like, even if it’s not displayed perfectly.
To monitor video or output to tape regardless of the quality of effects (frames may
drop occasionally)
1 In the RT pop-up menu, choose Unlimited RT, so there’s a checkmark next to it.
2 In the Playback Video Quality section of the RT pop-up menu, choose Dynamic, so there’s
a checkmark next to it.
3 In the Playback Frame Rate section of the RT pop-up menu, choose Dynamic, so there’s
a checkmark next to it.
4 In the Record To Tape section of the RT pop-up menu, choose Use Playback Settings, so
there’s a checkmark next to it.
5 Choose File > Print to Video, or turn on your external video output and record directly
to tape from the Timeline.
For more information, see “Printing to Video and Output from the Timeline.”

Supported Real-Time Playback Codecs
RT Extreme is not capable of playing back all video codecs. The processor speed and
amount of RAM installed in your computer affect which codecs can play back in real time.
The following codecs are supported for real-time playback:
• DV, DVCAM, DVCPRO (25), DVCPRO 50, and DVCPRO HD
• IMX (30, 40, 50)
• OfflineRT (this is a Final Cut Pro preset that uses the Photo JPEG codec)
• 8- and 10-bit uncompressed 4:2:2 video formats
• HDV
• XDCAM HD, XDCAM EX, and XDCAM HD422
• AVC-Intra
• Apple Intermediate Codec (at 1280 x 720, 1440 x 1080, and 1920 x 1080)
• Apple ProRes (up to 2K)
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To see a complete list of real-time codecs supported by your system
Choose Final Cut Pro > System Settings, then click the Effect Handling tab.

Using a Third-Party Video Effects Accelerator Card
Instead of using RT Extreme, you may want to use a supported third-party video effects
accelerator card. A video effects accelerator card is a video interface card that supports
real-time effects processing and can take the place of the built-in RT Extreme effects
architecture of Final Cut Pro.
All codecs capable of real-time effects playback appear in the Effect Handling tab of the
System Settings window. The Effect Handling tab allows you to choose whether
Final Cut Pro uses RT Extreme or a supported video effects accelerator card for processing
real-time effects. For example, you could choose to have RT Extreme handle media using
the Photo JPEG codec while using a video effects accelerator card to handle DV NTSC
footage.
To choose software or hardware real-time effects processing for clips using a particular
codec
1 Choose Final Cut Pro > System Settings, then click the Effect Handling tab.

Note: The codecs you see may differ from those shown here.
2 In the pop-up menu corresponding to the codec you want to adjust, choose an effect
handling method:
• None: Choosing None turns off real-time effect handling for the selected codec.
• Final Cut Pro: This option uses RT Extreme, the built-in real-time processing engine of
Final Cut Pro.
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• Other: If a video effects accelerator card is installed that is capable of real-time effects
processing for a particular codec, it appears in this pop-up menu. Choose this option
to have the video effects accelerator card handle real-time effects processing for a
particular codec.

Using RT Extreme for Video Output
By default, Final Cut Pro renders video at full quality before you perform Edit to Tape and
Print to Video operations. However, if you simply want to output a rough draft of your
sequence, you can output with reduced quality settings. Final Cut Pro always warns you
before you output video to tape at reduced quality.
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To output reduced-quality video using Print to Video, Edit to Tape, or direct output
from the Timeline
Choose Use Playback Settings from the Record To Tape section of the RT pop-up menu
in the Timeline.
If you do not choose Use Playback Settings, Final Cut Pro always outputs at full quality.
For more information, see “Printing to Video and Output from the Timeline.”

Viewing Your Composition in the QuickView Tab
The QuickView tab provides an alternate way to view your composition outside the Canvas
as you work. It takes advantage of the ability of Final Cut Pro to cache frames of your
sequence to RAM as you play it. This is useful for fast previews of complex composites
and effects. It’s also a good way to see how your final composite looks if you are zoomed
in to the Canvas while making adjustments. For example, if you zoom in to the Canvas
to build a complex keyframed motion path, you can still view the composition in its
entirety in the QuickView tab to see how it looks.
Tip: You can add, delete, or modify a clip’s motion and filter parameters in the Viewer
and see the results update automatically in the QuickView tab, even while the clip
continues to play back. Unlike other windows in Final Cut Pro, the QuickView tab loops
playback until you stop it. For example, you can adjust a color correction filter while you
watch a clip play back.
Note: The QuickView tab is for viewing purposes only. You cannot drag clips to this tab
to perform an edit. The QuickView tab also has no effect on rendering or output from
Final Cut Pro.
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To open the QuickView tab
Choose Tools > QuickView (or press Option-8).
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Controls in the QuickView Tab
This section describes the controls in the QuickView tab (which appears in the Tool Bench
window).
Resolution pop-up menu

View pop-up menu

QuickView window

Playhead
Play button

Scrubber bar

Range slider

• Resolution pop-up menu: Choose Full, Half, or Quarter as your viewing resolution in the
QuickView tab. This setting is for display purposes only and does not affect the resolution
of your rendered program. At lower resolutions, the preview area plays back faster and
you’re able to cache a greater area of the sequence to RAM.
• View pop-up menu: This pop-up menu lets you choose the window to cache video
from.
• Auto: QuickView caches video from the Viewer or the Canvas, whichever window is
currently active.
• Viewer or Canvas: QuickView caches video from the selected window.
• None: This turns off the QuickView tab so no playback is displayed.
• Play button: Click to begin playback in the QuickView tab. You can also press the Space
bar to start and stop QuickView playback.
• Range slider: Use this slider to define the duration of your sequence that is cached by
QuickView, from 2 to 10 seconds.
Note: If both In and Out points are defined in the Timeline, this slider doesn’t appear.
• Scrubber bar and playhead: In the QuickView tab, the width of the scrubber bar
represents the total duration of video that is to be cached.
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Playback in the QuickView Tab
QuickView playback relies, in part, on the amount of memory allocated to Final Cut Pro.
Based on this allocation, Final Cut Pro caches to RAM as much of the sequence between
the In and Out points set in the Timeline as possible for accelerated playback.

If an In point is set in the Timeline but no Out point is set, Final Cut Pro caches video from
the In point through the duration specified by the Range slider for playback in the
QuickView tab.
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If neither an In nor an Out point is set in the Timeline, Final Cut Pro uses the position of
the playhead, caching half of the duration specified by the Range slider before the position
of the playhead, and half after the playhead, for playback in the QuickView tab.

Video is cached to RAM as it’s played. Once the portion of the sequence that you’ve
specified for QuickView playback has played all the way through, subsequent loops play
much faster because they’re being played back directly from RAM.
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Rendering and Video Processing
Settings

85

This chapter covers the following:
• What Is Rendering? (p. 1443)
• About Render Status Bars in the Timeline (p. 1444)
• About Item-Level Render Status Bars (p. 1447)
• The Rendering Process (p. 1447)
• About Changing Render and Video Processing Settings (p. 1456)
• Changing Settings in the Render Control Tab (p. 1456)
• Changing Settings in the Video Processing Tab (p. 1459)
• Adjusting Gamma (p. 1464)
• Managing Your Render Files (p. 1468)
• Tips for Reducing Render Time (p. 1471)
When you apply more effects to a clip than your computer can process in real time, you
need to render temporary media files to play your sequence in real time.

What Is Rendering?
Any time Final Cut Pro must perform more calculations than your computer can handle
in real time, you need to render. Rendering is the process of creating temporary video
and audio render files for segments of your sequence that Final Cut Pro cannot play in
real time. When you render a segment of your sequence, Final Cut Pro substitutes a render
file for the segment during playback. Render status bars above the ruler in the Timeline
indicate which sections can play back in real time and which segments require rendering.
Because rendering takes time away from the editing process, the goal is to render as little
as possible. For more information about real-time playback, see “Using RT Extreme.”
Rendering is generally required for:
• The use of filters, transitions, generators, or any combination of effects that exceeds
your computer’s real-time playback capabilities
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• High-quality final output. Real-time effects that play back at preview quality must
ultimately be rendered for high-quality video output.
• Video clips using codecs that Final Cut Pro can’t play in real time
• Multiple audio tracks that exceed your real-time playback limit
• Clips with audio effects that require too much processing power
• Some nested sequences, which can include layered Photoshop files

About Render Status Bars in the Timeline
Final Cut Pro shows you which segments of your sequence need to be rendered by using
render status bars in the Timeline and, in some cases, on individual audio clip items. A
segment is a continuous group of frames within a sequence that require the same kind
of real-time processing.
For example, suppose you have two clips in a sequence. The first clip has a Gaussian Blur
filter applied and the second clip has no effects applied. Final Cut Pro sees two segments
in this sequence: the clip with the Gaussian Blur filter and the clip with no effect. Adding
a transition between the two clips can potentially create a third segment that has different
processing requirements than the other two.
There are two render status bars in the Timeline above the ruler: the upper one is for
video and the lower for audio.
Render bars in the
Timeline: the upper bar
is for video, and the
lower bar is for audio.

Video Render Status Bars
The color of the video render status bar above the Timeline ruler indicates the real-time
or render status of segments in your sequence.
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Bar color

Render status

Description

Dark gray

None

No rendering is required.

Blue-gray

Rendered

The material has already been rendered.
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Bar color

Render status

Description

Dark green

Full

Indicates a real-time effect that’s capable of
playback and output to video at full quality with
no rendering required.

Green

Preview

The media does not need rendering and will play
on the computer screen in real time, but not at
full quality.

Yellow

Proxy

The effect you see during real-time playback is an
approximation (proxy) of the effect you’ve
specified. Effects indicated by yellow render bars
may ignore some filter parameter controls (for
example, Edge Softness) in order to show you a
real-time preview. To get the true final effect, you
must render these clips. The final effect is
displayed when playback is stopped or when
scrubbing. For example, you may have added a
wipe transition and set the angle to 37 degrees.
Depending on your selected effects quality,
Final Cut Pro may only be able to display the wipe
angle at 45 degrees in real time, so you see an
approximation during realtime playback. You can
still see the effect as you specified it (the 37-degree
angle) by placing the playhead over a frame of
the effect in the Canvas or Timeline, or by
rendering the effect before playing it back.

Dark yellow

Rendered Proxy

Indicates that an effect has been rendered at a
lower frame rate or quality than currently specified
in the Frame Rate and Resolution pop-up menus
in the Render Control tab of the Sequence Settings
window. These render files are preserved even if
these settings are changed back to 100 percent.
This render status bar color appears when you
render a proxy effect (see the entry above for more
information).

Orange

Unlimited

Indicates effects that exceed your computer’s
real-time playback capabilities but are enabled
anyway because Unlimited RT is selected in the
RT pop-up menu in the Timeline. Unlimited
real-time playback lets you play more effects but
increases the chances that your sequence will drop
frames during playback. This mode is useful for
getting a real-time preview of complex effects
compositions.

Red

Needs Render

The real-time capabilities of Final Cut Pro have
been exceeded and the material must be rendered
before playback or output to tape.
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Audio Render Status Bars
The color of the audio render bar above the Timeline ruler indicates whether the items
below need to be rendered.
Bar color

Render status

Description

Dark gray

None

No rendering is required.

Blue-gray

Rendered

Sections of a sequence have been rendered using
the Mixdown command.

Red

Needs Render

Sections of the Timeline contain audio items that
cannot play in real time and require rendering.
Sections of sequences needing to be rendered
play audible beeps.

Several other indicators show you the playback status of clips in your sequences:
• ”Unrendered” message in the Viewer or Canvas: When video material that requires
rendering is playing in the Viewer or Canvas, and the Play Base Layer Only option in
the RT pop-up menu in the Timeline is not selected, a blue background with the word
“Unrendered” appears, indicating that the video can’t play in real time.

When this message
appears, video won’t play
back in real time.

• Beeps in the Viewer or Canvas: When audio material that requires rendering is played
in the Viewer or Canvas, a steady beep indicates that the material can’t play in real
time. You can turn off the beeps in the Playback Control tab of the System Settings
window.
• Item-level render status bars: Audio clip items in the Timeline that require sample rate
conversion also display individual render bars (for example, audio clip items that were
captured at 44.1 kHz but have been edited into a sequence set to 48 kHz). For more
information on audio rendering and item-level render status bars, see the next section,
“About Item-Level Render Status Bars.”
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About Item-Level Render Status Bars
An audio clip item in the Timeline may display an individual render bar within the clip
item itself; this indicates that the audio clip requires resampling, or sample rate conversion,
to match the current sequence audio settings. A green render bar indicates that an audio
clip item is being resampled in real time, and a blue-gray render bar indicates that an
audio clip item has been individually rendered so that real-time audio resampling is no
longer necessary. Once an individual audio clip item is rendered, the clip item refers to
the render file instead of the original media file.
Audio render bars in the
Timeline indicate audio
tracks that have been
mixed down (all tracks
mixed together).

Blue-gray indicates that
this audio item has
been rendered.

Green indicates that
this audio item requires
sample rate conversion.

The color of the render bar in each audio clip item indicates whether that item needs
sample rate conversion. An audio clip item’s real-time playback status is not indicated.
Bar color

Description

Green

Indicates audio items that require sample rate conversion.

Blue-gray

Indicates audio items that have been individually rendered.

There are two advantages to item-level (audio clip item) rendering:
• Item-level rendering reduces the processor demands for audio, leaving more processing
power available for other effects.
• When you move the audio clip item to other tracks or locations in the Timeline, the
clip item does not lose its connection to the render file. This means you don’t have to
rerender the audio clip each time you move it.

The Rendering Process
When you are ready to render, you need to choose render quality settings for your
sequence and decide which segments you want to render.
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By default, render files are created at full quality, but you can speed up rendering by
choosing lower-quality options in the Render Control tab and the Video Processing tab
of the Sequence Settings window. For more information, see “About Changing Render
and Video Processing Settings.”

Order of Effects Rendering
When you render effects in a sequence, they’re rendered in the following order:
• The top video track (the highest-numbered track) is rendered first and then composited
onto the track below.
• Within each track, effects are rendered as follows: speed, filters, motion, motion blur,
opacity, and transitions.
You can change the order of rendering by using nested sequences. For more information,
see “Sequence-to-Sequence Editing.”

Selecting Clips for Rendering
Instead of rendering an entire sequence, it is often useful to render only selected segments.
There are several ways you can restrict which segments are rendered:
• Manually select the items you want to render: The easiest way to control what is rendered
is to select specific clips, individually or in groups, and then choose an option from the
Render Selection submenu of the Sequence menu. For more information on selecting
items in the Timeline, see “Finding and Selecting Content in the Timeline.”
• Render audio and video clip items separately: You can limit rendering to only video or
audio effects. For example, you may want to render audio effects to free up processing
resources so you can turn on real-time mixing across more audio tracks.
Note: For more information about item-level rendering for audio clips, see “More About
Audio Render Options.”
• Render items according to their render status bar: Final Cut Pro recognizes several render
status categories, indicated by the color of the render status bar above the ruler in the
Timeline. You can restrict which categories to render.
For example, while you’re editing, you may want to render only clips with effects that
can’t play back in real time. In this case, you can select the Needs Render option in the
Render Selection and Render All submenus of the Sequence menu. You also need to
turn off all the other render categories. This limits the scope of your render commands
to clips that can’t play in real time, and clips with real-time effects applied are not
rendered.
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Rendering Segments in a Sequence
Final Cut Pro has three render submenus—Render Selection, Render All, and Render
Only—that allow you to customize which segments of your sequences are rendered.
Which render command you use depends on the scope of the rendering operation you
want to perform.
You can choose to render:
• Video only, audio only, or both
• Segments with particular render status indicators
• Manually selected portions of a sequence or segments between sequence In and Out
points
• All segments in a sequence
The Render Selection and Render All submenus allow you to restrict which video and
audio render status categories are rendered.
Render Selection
If you’ve selected one or more items in the Timeline, or defined a region of the Timeline
using In and Out points, the commands in the Render Selection submenu operate only
on the selection. If nothing is selected and no In or Out points have been defined, the
entire sequence is rendered.

Video and audio
render categories
that are enabled
have a checkmark.

• Both: Renders both the video and audio of the selected region of the sequence.
• Video: Renders only the video items in the selected region of the sequence.
• Audio: Renders only the audio items in the selected region of the sequence.
You can restrict which segments are rendered by only selecting particular render status
categories. For example, if you want to render all item-level audio segments between
the sequence In and Out points, choose the Item Level option (so there’s a checkmark
next to it), deselect all the others, then choose Sequence > Render Selection > Audio.
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If you’ve added a transition or an effect to a clip and want to render just that part of the
sequence, use the Render Selection command.
To render a section of a sequence
1 Do one of the following:
• In the Timeline, select one or more clips or transitions.
• In the Timeline or Canvas, set In and Out points for the area that you want to render.
In and Out points for the
section to be rendered

2 If necessary, choose Sequence > Settings, click the Render Control tab, then choose quality
settings for rendered effects and select which effects are and are not rendered.
3 Choose Sequence > Render Selection, then choose which kinds of render segments you
want to render from the submenu.
Render status categories that are turned on have a checkmark next to them.
4 Choose Sequence > Render Selection, then choose a render command from the submenu
(Both, Video, or Audio).
5 If your project has not yet been saved, Final Cut Pro prompts you to save your project.
A status window appears showing the rendering progress. Click Cancel to stop rendering.
Note: All frames that have already been rendered remain written to disk, even if rendering
is canceled.
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Render All
The commands in the Render All submenu render all the clips in a sequence corresponding
to the selected render categories, regardless of what you have selected in the Timeline.

Video and audio
render categories
that are enabled
have a checkmark.

• Both: Renders both the video and audio of the sequence.
• Video: Renders all of the video items in the sequence.
• Audio: Renders all of the audio items in the sequence.
You can restrict which segments are rendered by only selecting particular render status
categories. For example, if you want to render all segments in your sequence that have
a red render status bar, choose the Needs Render option (so there is a checkmark next
to it), deselect all the others, then choose Sequence > Render All > Video.
To render an entire sequence
1 Do one of the following:
• In the Browser, select one or more sequences.
• Open a single sequence in the Timeline.
2 If necessary, choose Sequence > Settings, click the Render Control tab, then choose the
quality settings for rendered effects and select which effects are and are not rendered.
3 Choose Sequence > Render All, then select which kinds of render segments you want to
render from the submenu.
Render categories that are turned on have a checkmark next to them.
4 Choose Sequence > Render All > Both.
5 If your project has not yet been saved, Final Cut Pro prompts you to save your project so
a Render folder can be created.
A status window appears showing the rendering progress. Click Cancel to stop rendering.
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Note: All frames that have already been rendered remain written to disk, even if rendering
is canceled.
Render Only
The items in the Render Only submenu allow you to focus on rendering segments in a
particular render status category, such as Preview or Proxy quality. Each item in this
submenu operates either on a selected region of the Timeline or on the entire sequence,
if no selection is made.

For example, to render all segments in a sequence that have Preview render status, make
sure nothing is selected in the Timeline (choose Edit > Deselect All) and then choose
Sequence > Render Only > Preview.

Rendering Audio Items in a Sequence
The following commands allow you to render audio items when required for real-time
playback. Audio filter rendering and sample rate conversion occur at the same time.
To render individual audio items
1 Select one or more clips with transitions and filters in the Timeline.
2 Choose Sequence > Render Selection > Audio.
To render all audio items
1 Select or open a sequence in the Timeline.
2 Choose Sequence > Render All > Audio.
Note: Item-level render files are preserved even when an item is trimmed shorter, moved,
or copied and pasted, or when either individual audio items or the tracks they’re edited
into are disabled and reenabled.
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More About Audio Render Options
Two of the audio render options create render files in very specific ways.
• Item Level: Renders the audio items that need to be resampled to match the sample
rate of the sequence, as well as audio items with filters applied, as item-level render
files. Audio mixing is still done in real time, and mixing performance improves because
audio resampling and audio effects no longer consume real-time processing resources.
• Mixdown: Renders all the audio in a sequence to a single group of render files, one for
each audio output assigned to the selected sequence. This can improve playback
performance by eliminating the need for Final Cut Pro to do any real-time mixing or
audio effects playback. The Mixdown command is a nondestructive operation and
doesn’t change any of the audio clips in the sequence.
When you choose either the Item Level option in the Render Selection and Render All
submenus or the Mixdown command in the Render Only submenu, audio is rendered at
the highest quality regardless of the setting chosen in the Audio Playback Quality pop-up
menu in the General tab of the User Preferences window.

Using the Mixdown Command
Sometimes, you may have so many audio items edited into a sequence or so many filters
applied that rendering the items in your sequence doesn’t ensure real-time playback. In
this case, use the Mixdown command in the Render Only submenu of the Sequence
menu to render all audio in a sequence prior to playback or output to tape.
To mix down audio in a sequence
1 Select a sequence in the Timeline.
2 With the Timeline or Canvas active, choose Sequence > Render Only > Mixdown (or press
Command-Option-R).
A multichannel QuickTime audio file is rendered to disk so that the sequence can now
play back the render file instead of all the individual audio tracks.
Note: This command has no effect on how your clips are edited. All audio clips remain
on their own tracks in the sequence just as they were before. The Mixdown command
simply consolidates the audio in an audio render file for playback.
Once you’ve applied mixdown audio to a sequence, the Mixdown menu item is dimmed,
and a checkmark appears next to it to show that the audio in the sequence has been
rendered as a preview file. If you move any audio clips afterward, the preview file is
discarded, and the Mixdown command again becomes available in the Render Only
submenu.
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Keeping Track of Rendering Progress
The amount of rendering time depends on the type and number of effects that are
applied. When you render, a status window appears and provides you with the following
information.
• Percentage of completion: The percentage of rendering that has been completed, based
on the number of frames left to render.
• Estimated Time: The estimated time remaining to render. This value appears above the
progress bar, in seconds, minutes, hours, and so on.

Final Cut Pro bases its estimate on how long the last frame took to render and how many
frames remain to be rendered. Because different sections of your sequence may have
different effects applied, this estimate may change over time as it’s constantly updated
to reflect the clip currently being rendered.
Render files for a sequence are generated cumulatively, so you can cancel rendering and
retain what you have already rendered without having to start over.

Temporarily Disabling Rendering
Normally, Final Cut Pro attempts to calculate all the effects applied to the frame at the
current playhead position. Sometimes, especially with effects-intensive sequences, you
will want to turn off these calculations temporarily while you make changes to edits in a
sequence or to the settings of a motion effect or filter. When rendering is turned off, all
clips that require rendering (indicated by red render bars in the Timeline) do not appear
in the Viewer or Canvas. This way, you can work in the Timeline or in the Controls, Filters,
or Motion tab of the Viewer without waiting for individual frames at the position of the
playhead to render for display. Clips with real-time effects applied still appear.
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To temporarily turn off rendering
Press the Caps Lock key.
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The Viewer and Canvas both go black. A message appears at the top of both windows
saying “The Caps Lock key is on; rendering is disabled.” Press the Caps Lock key again to
turn on rendering.

This message appears
in the Viewer and Canvas
when rendering
is disabled.

Automatic Rendering While You Are Away from Your Computer
The Auto Render option allows you to take advantage of idle computer time when you’re
not editing—such as during a coffee break or lunch—to render open sequences in the
Timeline.

µ

To change Auto Render settings
Choose Final Cut Pro > User Preferences, then click the General tab.
Three options determine what parts of your opened sequences are rendered and when:
• “Start Render after” field: This number, in minutes, specifies the amount of idle time that
must pass before Final Cut Pro starts to automatically render any open sequences.
• Render pop-up menu: Choose Open Sequences from this pop-up menu to render all
open sequences in the Timeline. Choose Current Sequence to render the currently
active sequence tab in the Timeline. Choose Open Sequences Except Current to render
all open sequences except for the currently active sequence in the Timeline.
• Render RT Segments: Selecting this checkbox ensures that all sections of your sequence
that use real-time effects are also rendered. Deselecting this checkbox saves time by
ignoring sections of your sequence that are already capable of playing back in real
time.
When the number of minutes specified in the “Start Render after” field has elapsed with
no user activity, a progress dialog appears indicating the following sequence of events:
• If Autosave Vault is selected, the project is automatically saved prior to rendering.
• All selected regions of the currently active sequence are rendered.
• All sections of the Timeline with a red render bar are rendered.
• All audio with effects is rendered.
• All sections of the Timeline with yellow and orange render bars are rendered.
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• If the Render RT Segments checkbox is selected, all sections of the Timeline with a
green render bar are rendered.
• If the Render pop-up menu is set to Open Sequences, the rendering steps above (except
for saving the project) are performed for each open sequence. The project is
automatically saved after each render.

About Changing Render and Video Processing Settings
Each sequence has render options you can change in the following locations:
• Render Control tab of the Sequence Settings window: This tab allows you to choose the
video quality and frame rate of rendered files. You can decrease rendering time by
reducing image quality and frame rate.
For more information, see “Changing Settings in the Render Control Tab.”
These settings are also available in the Render Control tab of the User Preferences
window. In the User Preferences window, these settings determine the default render
settings for newly created sequences.
• Video Processing tab of the Sequence Settings window: This tab allows you to choose
color space, bit depth, maximum white level conversion, and scaling options for your
sequence.
For more information, see “Changing Settings in the Video Processing Tab.”
You can also adjust the default video processing settings in each sequence preset,
using the Sequence Preset Editor in the Audio/Video Settings window.

Changing Settings in the Render Control Tab
Each sequence has its own render and playback settings, located in the Render Control
tab of the Sequence Settings window. These settings allow you to turn on and turn off
processor-intensive video filters and frame blending. This is useful if you want to apply
filters and speed changes to clips but temporarily turn them off to avoid rendering while
you edit. You can also use this tab to reduce render quality while you work and then
return to full quality for your final render.

1456

Chapter 85 Rendering and Video Processing Settings

Note: The Render Control tabs of the User Preferences and Sequence Settings windows
have identical settings. Changes made to the Render Control tab of the User Preferences
window only affect the default settings for new sequences, whereas changes to the
Render Control tab of the Sequence Settings window affect individual sequences.

These settings are also
available in the Render
Control tab of the User
Preferences window.

Render & Playback Settings
The Render Control tab provides the following render and playback settings.
• Filters: Selecting this option allows filters to be processed during rendering or playback.
If this option is not selected, all filters are ignored.
• Frame Blending For Speed: This option only affects clips with speed settings applied. If
this option is selected, frame blending is processed during rendering or playback. If
this option is not selected, frame blending is ignored for all clips in your sequences.

Render Settings
The Render Control tab provides the following render settings.
• Frame Rate: You can use this pop-up menu to reduce the frame rate of rendered effects,
dramatically speeding up rendering at the expense of playback quality. For example,
if you’re editing at 29.97 fps and you choose 50% from the Frame Rate pop-up menu,
rendered effects in your sequence will play back at 15 fps.
• Resolution: Choose a percentage from this pop-up menu to reduce the resolution of
rendered effects, speeding up rendering at the expense of lowering playback quality.
For example, if you’re editing with a frame size of 720 x 480, choosing 50% lowers the
resolution of rendered effects to 360 x 240 and does not display interlacing. Rendered
effects play back at full frame size despite having lower resolution; however, they look
less sharp and are not interlaced.
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• Codec: This pop-up menu affects rendering of native HDV and XDCAM HD sequences.
Choose whether render files are created in the native codec of your sequence segments
or using the Apple ProRes 422 codec. Because Final Cut Pro supports mixed-format
sequences, you can play back the entire sequence, including the Apple ProRes 422
codec render files, in real time. For more information, see
Professional Formats and Workflows, available in Final Cut Pro Help.
Important: These options don’t affect real-time playback. To change the frame rate
and resolution of video playback, use the RT pop-up menu in the Timeline instead. For
more information, see “RT Pop-Up Menu in the Timeline.”
Many of these settings can also be assigned to keyboard shortcuts or buttons in the
button bar using the Keyboard Layout window, if you need to make frequent changes.
For more information, see “Customizing the Interface.”

Changing Render Settings for Sequences
If you change render settings for new or existing sequences, you will affect real-time
playback, rendering, video output, and the quality of export to QuickTime movie files.
To change the default render control settings for all new sequences
1 Choose Final Cut Pro > User Preferences.
2 Click the Render Control tab.
3 Select the settings you want, then click OK.
The settings in the Render Control tab of the User Preferences window are applied to all
new sequences you create.
To change render control settings for an existing sequence
1 Open the Sequence Settings window for a particular sequence by doing one of the
following:
• Control-click a sequence in the Browser, then choose Settings from the shortcut menu.
• Select a sequence in the Browser or Timeline, then choose Sequence > Settings.
2 Click the Render Control tab.
3 Select the settings you want, then click OK.
The new settings are applied to the selected sequence.
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Changing Settings in the Video Processing Tab
The Video Processing tab determines how clips’ media files are processed and rendered
within your sequence. This affects color space conversions, maximum white level, bit
depth, and the quality of motion parameter adjustments.
Color space and
bit depth settings

Maximum RGB white
level settings
Motion filtering quality

Rendering Y′CBCR Footage in the RGB Color Space
When super-white Y′CBCR values are converted to RGB, any values above 235 are mapped
to 255. Any variation in luma above 235 is therefore clamped, or clipped, resulting in solid
patches of white where there was once detail in the bright parts of the image. If these
RGB values are converted back to Y′CBCR, all white values of 255 are mapped to a single
value (usually 235, which is white in Y′CBCR). The newly converted white values are lower
than the white values originally captured, causing areas of the picture that had super-white
values to darken slightly and to appear flat where there was once detail in the highlights.
This is known as luma clamping. You can avoid this by editing your Y′CBCR footage natively
in the Y′CBCR color space.

Choosing RGB Versus Y′CBCR Color Space
Each color space has a certain range, or gamut, of colors that can be represented. Some
colors represented in the Y′CBCR color space cannot be represented in RGB and are said
to be out of gamut. If the color space of your media files doesn’t match the color space
of your sequence, Final Cut Pro maps the media file color values to the color space of the
sequence. In some cases, colors get “clipped” to the nearest value during conversion. This
can cause very saturated colors to become less intense and is referred to as chroma
clamping.
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Compositing in Y′CBCR and RGB Color Spaces
Many compositing operations in Final Cut Pro work the same way in Y′CBCR as they do in
RGB. However, in some cases, slightly different results may occur. This is because the
Y′CBCR and RGB color spaces are not identical, and some compositing operations that
generate highly saturated colors may show different clamping behavior in Y′CBCR than
they do in RGB.
For example, using the Add composite mode to combine 75 percent cyan and 75 percent
white will “clamp” to white in RGB, but to a bright cyan color in Y′CBCR. For this reason,
it’s important to verify the results of the composite by doing a test render in the color
space you will do the final render in.
For more information about limiting Y′CBCR and RGB values, see “Using the Broadcast
Safe Filter” and “Using the RGB Limit Filter.”

Changing Video Processing Settings
You can change video processing settings for an individual sequence, or you can change
video processing settings for a sequence preset.
To change video processing settings for an individual sequence
1 Choose Sequence > Settings, then click the Video Processing tab.
2 Select the appropriate options, then click OK.
For a detailed description of options in the Video Processing tab, see the following sections:
• “About Color Space and Bit Depth Settings”
• “Maximum RGB White Level Settings”
• “Motion Filtering Quality Pop-Up Menu”
To change the default video processing settings for a sequence preset
1 Choose Final Cut Pro > Audio/Video Settings, then click the Sequence Presets tab.
2 Double-click a sequence preset in the list of presets.
The Sequence Preset Editor window opens.
3 Click the Video Processing tab, then choose the appropriate settings.

About Color Space and Bit Depth Settings
These options determine the color space and video bit depth used for rendering and
real-time playback.
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Always Render in RGB
If your sequence uses an RGB video codec such as Photo JPEG or Animation, this option
is always selected. However, if your sequence uses a Y′CBCR codec, you can use this option
to process your footage using the RGB color space instead. For example, if you’re using
a filter that only processes in RGB color space in combination with filters that process in
Y′CBCR color space, you can make the appearance of the Y′CBCR filters more consistent
with that of the RGB filters by selecting this option. However, in most cases, you should
render using the native color space of your sequence’s codec.
Render in 8-bit YUV
Most codecs supported by Final Cut Pro use 8 bits per color sample, so this option is
usually selected by default. However, if you are doing any compositing or adding footage
with higher bit depths, you may want to use high-precision (32-bit) processing to maximize
quality.
8-bit YUV is the fastest Y′CBCR processing option, so you may want to use this during
offline editing and then switch to high-precision rendering before rendering for output.
Render 10-bit material in high-precision YUV
Use this option whenever your sequence or source footage uses a 10-bit Y′CBCR codec
such as the Apple ProRes 422 codec or an Uncompressed 10-bit codec. Several third-party
codecs also capture and output 10-bit video.
Render all YUV material in high-precision YUV
This is the highest-quality option for processing video in Final Cut Pro. This option
processes all 8- and 10-bit video at 32-bit floating point. In certain situations, such as
when applying multiple filters to a single clip or compositing several clips together, a
higher bit depth will improve the quality of the final render file even though the original
clip has only 8 bits of color information. The tradeoff is that 32-bit rendering is slower
than 8-bit rendering, so you’re essentially trading speed for quality.
Note: Selecting this option does not add quality to clips captured at 8-bit resolution when
they are output back to video; it simply improves the quality of rendered effects.
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About Bit Depth and 32-Bit Floating-Point Processing
Final Cut Pro supports high-resolution video processing of Y′CBCR sequences by performing
calculations in 32-bit floating-point number space. Compared to 8- and 10-bit integer
calculations, 32-bit floating-point numbers have an extremely high level of precision,
which helps to avoid rounding errors that can accumulate as you add more layers to a
composite or add multiple filters to a clip. In most cases, you should choose to render
your sequence using 32-bit floating-point space (called high-precision YUV ) for final
rendering before output or export.
When using the Y′CBCR color space, Final Cut Pro supports either 8- or 10-bit video media
files. To determine which color space and bit depth your video interface supports, see
the documentation that came with the interface. For more information on which filters
and transitions support 10-bit resolution, see “Video Filters Available in Final Cut Pro” and
“Refining Transitions Using the Transition Editor.”

Maximum RGB White Level Settings
When you add graphics or generator clips created in the RGB color space (for example,
imported graphics files or generator clips created with generators such as the Text
generator), the “Process Maximum White as” pop-up menu determines whether the
maximum white value of these clips should be 100 percent or 109 percent. Use this
pop-up menu to make sure the white levels of your RGB footage match those of your
Y′CBCR video. Because most still images and generators use the RGB color space and most
video footage is recorded in the Y′CBCR color space, it is important to check this pop-up
menu whenever you add graphics to your sequence.
Y′CBCR and RGB video systems assign maximum white levels to different digital codes, as
shown here with an 8-bit video example.
Description

Percentage

RGB 8-bit value

Y′CBCR 8-bit value

Super-black

-7%

n/a

1-15

Black

0%

0

16

White

100%

255

235

Super-white

109%

n/a

236-254

A 100 percent white value in Y′CBCR video is the legal limit for broadcast television and
generally corresponds to the analog broadcast legal limit of 100 IRE. However, camcorders
and decks allow white levels above this level (up to 109 percent) to avoid clipping
occasional highlights. For example, even if you set your camcorder exposure so that it
appears no level is above 100 percent, highlights from shiny objects can go beyond 100
percent. Having the extra headroom from 100 percent to 109 percent allows you to
capture these highlights without losing details in the white.
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Choosing White
If you are creating video for broadcast, you need to make sure that any Y′CBCR levels in
your sequence are reduced to 100 percent (8-bit 235, or “white”). In this case, choosing
the White option from the “Process Maximum White as” pop-up menu maps RGB white
(255) values from imported still images to 100 percent white (235) in the Y′CBCR color
space. This means that your RGB graphics will have a maximum white level of 100 percent
in Y′CBCR color space, which is the broadcast-legal limit.
Choosing Super-White
If you aren’t concerned about broadcast-legal limits and you want your imported RGB
graphics to match Y′CBCR white levels that are above 100 percent, you should choose the
Super-White option from the “Process Maximum White as” pop-up menu. In this case,
RGB white values of 255 are mapped to Y′CBCR values of 254 (109 percent). Keep in mind
that any white levels in your RGB graphics will not be broadcast-legal.

Motion Filtering Quality Pop-Up Menu
Options in this pop-up menu control the render quality of scaling, rotation, and other
effects in the Motion tab.
• Normal: This option uses standard scaling and transformation algorithms and yields
medium-quality results compared to the other options.
• Best: This option performs very high-quality motion transformations on your clips. Use
this option for final rendering before output or export.
• Fastest: This option performs fast, low-quality motion transformations on your clips.
This option improves rendering time, so it is useful when you are sketching out motion
effects.

How Rotation Affects Motion Filtering Quality
When you adjust a clip’s Rotation parameter, the clip is automatically rendered using the
Fastest setting, regardless of the option chosen from the Motion Filtering Quality pop-up
menu of the Video Processing tab of the current sequence settings. For example:
• If you adjust a clip’s Scale, Center, or Anchor Point parameter: The clip is rendered using
the motion filtering quality option chosen in the Video Processing tab of the current
sequence settings.
• If you adjust only a clip’s Rotation parameter: The clip is rendered using the Fastest
motion filtering quality setting.
• If you adjust a clip’s Rotation parameter as well as additional motion parameters: The clip
is rendered using the Fastest motion filtering quality setting because the Rotation
parameter has been adjusted.
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Adjusting Gamma
Final Cut Pro provides gamma control adjustments for RGB video and still-image formats.

About Gamma
Gamma is an implicit or explicit transfer function that maps input intensity to output
intensity, usually in a nonlinear way. The most common example is a CRT monitor, where
the brightness onscreen is less than expected based on the input voltage. If the input
voltage ranges between 0 (black) and 1 (white), one would expect a voltage of 0.5 to
generate a brightness value of about 50 percent gray on the screen, but in fact only 18
percent gray is generated. This is simply the nature of a CRT’s electron gun response to
input voltage.
The CRT applies an implicit power function in which the input signal is raised to the power
of 2.5 (V2.5). Gamma is usually defined by the value of the exponent in the power
function—in this case, 2.5.

Nonlinear Coding
Human perception of brightness is also a power function that’s nearly opposite of CRT
gamma. This means that exponential increases in physical light intensity are required to
create perceptible shifts in brightness. To take advantage of this fact when coding luma
values in a limited bit depth (such as 8 bits, or 256 codes), incoming video signals are
modified with a gamma curve so that there are more codes concentrated in the dark part
of the signal and larger code jumps as luma increases. This corresponds to the perception
of brightness and therefore uses the available bits in the most perceptually efficient way.
If luma were coded equally from black to white, you would likely see
“banding”—perceptible jumps in brightness—in the black areas, and many subtle changes
in white levels would be imperceptible.

About Gamma Correction
Gamma correction compensates for the fact that video display devices (such as televisions)
inherently convert image signals to light intensity in a nonlinear fashion, usually with an
assumed gamma value of 2.5. The ITU-R BT.709 specification recommends an in-camera
gamma correction of 1/2.2 (or 0.45). When the camera gamma correction is multiplied
by the CRT gamma (2.5/2.2), the result is an overall display gamma of 1.14, which has
slightly more contrast than a display gamma of 1.0. A display gamma of 1.1–1.2 is desired
for television viewing in dim viewing conditions.
In summary, a gamma of 2.5 is inherent in CRT displays. Gamma correction is automatically
applied in a video camera so that the video is displayed on a CRT with a bit of contrast,
and this value is usually 1/2.2.
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Choosing Real-Time Playback Gamma Correction Options
Whenever you watch your video on a computer display (such as video displayed in the
Canvas, the Viewer, or via Digital Cinema Desktop Preview), Final Cut Pro applies gamma
correction to the video to more closely approximate the way it would appear on a video
monitor.
Note: Gamma correction is not applied to external video outputs such as DV or third-party
interfaces because this correction is inherently applied by external video monitors.
If your computer’s graphics card supports gamma correction, Final Cut Pro automatically
uses the card for accurate gamma correction. If your computer has an older graphics card
that does not support gamma correction, you have two gamma correction options in the
Playback Control tab of the System Settings window.
• Accurate: High-quality gamma correction. This option is the most accurate but also
requires the most processing power.
• Approximate: Lower-quality gamma correction. This option leaves more processing
power available for real-time effects but results in less accurate color and brightness
rendition.
Tip: If your real-time performance is limited, try changing the gamma correction setting
to Approximate (if available).
To choose a gamma correction option in the current sequence
1 Open a sequence in the Timeline.
2 Choose Final Cut Pro > System Settings, then click the Playback Control tab.
3 Choose Accurate or Approximate from the Gamma Correction pop-up menu.

Changing Gamma Settings for Video and Imported Still Images
When you import certain video or still-image formats, Final Cut Pro attempts to determine
what gamma correction has already been applied to the media and stores that value in
the clip’s Gamma Level property. During playback, Final Cut Pro uses the Gamma Level
property to determine whether a clip requires gamma correction.
In general, Final Cut Pro assumes the following:
• Most RGB-encoded media (such as TIFF or the Apple Animation codec) has an implicit
gamma of 1.8. This assumption is correct for images created on a Mac computer with
display profile gamma set to 1.8. If the image file was created on a different platform,
or on a Mac computer with display profile gamma set to 2.2, you may need to adjust
the clip’s Gamma Level property to 2.2.
Because the Apple ProRes 4444 codec has been designed to work with Final Cut Pro
and has a native gamma of 2.2, it automatically eliminates potential gamma shifts.
• Y′CBCR media has an implicit gamma of 2.2. You cannot adjust the gamma of Y′CBCR
clips.
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A Common Gamma Correction Scenario
One of the most common situations that requires you to change the Gamma Level
property of a clip is when you are rendering an RGB clip within a Y′CBCR sequence.
Final Cut Pro uses QuickTime to import RGB media and always assumes that RGB media
(except Apple ProRes 4444) has a gamma of 1.8. When Final Cut Pro renders these clips
in a Y′CBCR sequence, the gamma is adjusted by a factor of 1.22 to match the 2.2 gamma
compensation required for Y′CBCR.
The problem with this default behavior is that RGB files are not always created with a
gamma of 1.8, even on Mac computers. In this case, you can adjust the gamma level of
your imported RGB clips accordingly.
Supported File Formats
Final Cut Pro supports gamma adjustment for the following file formats.
• Still images: JPEG, PNG, TIFF, SGI, PlanarRGB, MacPaint, and layered or flattened
Photoshop (PSD) files.
• QuickTime movie files: Movie files using the None or Animation codec
Adjusting Gamma in Imported Still-Image and Video Clips
There are two places to adjust gamma.
• Gamma Level pop-up menu in the Editing tab of the User Preferences window: This pop-up
menu globally determines gamma at the time media is imported.
• Gamma Level clip property in the Item Properties window or Browser column: You can
adjust the gamma of individual clips in the Browser or in the Item Properties window.
This allows you to override the global setting applied by the Gamma Level pop-up
menu in the Editing tab of the User Preferences window.

Choosing a Gamma Setting
Final Cut Pro analyzes imported still images and attempts to determine their encoding
format automatically. Sometimes this interpretation is incorrect. If imported still images
appear too light, or do not have enough contrast, then selecting Gamma Level 2.2 could
correct for this. Alternatively, if the images appear too dark or have too much contrast,
then this could be corrected by selecting Gamma Level 1.8.
To choose the gamma value applied to an imported file
1 Choose Final Cut Pro > User Preferences, then click the Editing tab.
2 Choose one of the following options from the Gamma Level pop-up menu.
• Source: This option uses QuickTime to interpret the gamma of imported media files.
• 1.8: Choose this option when importing media files created by an application in which
you specified a gamma value of 1.8, or created with Mac OS X v10.5.x or earlier.
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• 2.2: Choose this option when importing media files created on a system whose display
gamma was set to 2.2, or created by an application in which you specified a gamma
value of 2.2.
• Custom: Choose this option to enter any gamma value you wish in the Custom number
field.
Note: When you adjust the gamma of a clip within Final Cut Pro, the media file is not
modified; only the clip in the project is affected.
If you need to modify gamma for clips after importing, you can adjust the Gamma Level
property in the corresponding Browser column or in the Item Properties window. The
Gamma Level property is not shared between master and affiliate clips, so changing the
gamma for a master clip has no effect on the affiliate clips, and vice versa.
To change the Gamma Level property of a clip in the Item Properties window
1 Select a clip in the Browser or in a sequence.
2 Choose Edit > Item Properties > Format (or press Command-9).
3 Do one of the following:
• Control-click the value next to the Gamma Level property, then choose a predefined
gamma value for the clip (Source, 1.8, or 2.2) from the shortcut menu.
• Click in the Gamma Level field and enter a gamma value or type “Source,” then press
Enter.
Tip: To see how a clip’s gamma affects its brightness, try changing the Gamma Level
property of a clip while viewing the clip in the Viewer or Canvas.

µ

To view the Gamma Level column in the Browser
Control-click in any column in the Browser, then choose Show Gamma Level from the
shortcut menu.

To change the Gamma Level property of a single clip in the Browser
1 Select a clip in the Browser.
2 Click in the Gamma Level column next to the selected clip, enter a value between 0.01
and 10.00, then press Enter.
To change the Gamma Level property of multiple clips in the Browser
1 Select multiple clips in the Browser.
2 Control-click in the Gamma Level column, then choose Source, 1.8, or 2.2 from the shortcut
menu.
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Managing Your Render Files
Rendering produces render files that are actual media files stored on your hard disk, the
same as your captured media. Video and audio render files are saved to the disks you
specify in the Scratch Disks tab of the System Settings window. For more information,
see “Choosing Settings and Preferences.”
When you’re working on multiple projects or a highly complex project, render files can
accumulate very quickly. It’s important to manage your render files to maximize your disk
space.
Note: If you run out of disk space during the rendering process, a dialog appears giving
you the option to delete old render files and free up disk space.

Locating Render Files
Final Cut Pro stores video render files in a folder named Render Files. By default, this folder
is located in a folder called Final Cut Pro Documents, which is located on the specified
scratch disk. The Final Cut Pro Documents folder contains separate folders for video render
files, audio render files, captured media, and caches for waveforms and thumbnails.
Inside the Render Files folder, Final Cut Pro creates a folder for each project with render
files.

Render files for a project

Important: Do not delete render files when you’re working in the Finder. Instead, use the
Render Manager in Final Cut Pro to delete render files.
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Using the Render Manager
The Render Manager allows you to manage the render files associated with the sequences
in your projects. Render files are created whenever you render transitions, effects, or
multilayer composites in a sequence. They are stored in the scratch disk location specified
in the Scratch Disks tab of the System Settings window. For more information, see
“Choosing Settings and Preferences.”
You use the Render Manager to delete unwanted render files to free up disk space.
Periodically, you may find it useful to remove the following:
• Render files from deleted or old projects
• Unnecessary render files for existing projects
The Render Manager finds render files from both open and closed projects. You can use
the modification dates for files displayed in the Render Manager to help you determine
which files you no longer need. If you delete render files for projects you’re still working
on, you may need to rerender sections of your sequences.
Note: The Render Manager doesn’t search disks that aren’t specified as scratch disks.
In the Render Manager, render files are organized into folders by project and sequence;
filenames show whether files are video or audio render files. The Last Modified date
column shows the last time a render file was saved.
Items in the Render Manager are displayed in three groups: audio, audio mixdown
(sequence-level audio render files), and video.
To delete render files
1 Choose Tools > Render Manager.
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The Render Manager dialog appears. All projects that refer to render files on the current
render scratch disk are displayed. This includes all items in a sequence or project.
Click the disclosure
triangle next to a
project to show all
of its render files.

Each entry shows the
amount of disk space
used on the render
scratch disk.

Displays the number of
render files to be deleted
and the disk space that
will be made available.

• Disclosure triangle: Click to show items within a project or sequence.
• Projects: Click the disclosure triangle next to a project to display all sequences in the
project that contain render files on the current render scratch disk.
• Sequences: Click the disclosure triangle next to a sequence to display the render files
for video and audio.
• Type: The type of item (bin or render file).
• Size: The amount of disk space used by render files.
• Last Modified: The date the render files were last updated.
2 Click in the Remove column to delete specific render files.
• Clicking an item that includes other items, such as a project, automatically includes all
those items within it.
• Clicking a sequence selects all the render files for the sequence.
A checkmark appears next to each item you want to delete. The total amount of disk
space that will be made available is displayed at the bottom of the dialog.
3 When you’re ready to delete render files, click OK.
All files tagged for removal (with a checkmark) are deleted from the scratch disk.
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Important: Deleted render files cannot be restored with the Undo command.

Preserving Render Files
When you make changes to effects, composited media, and other edits that have already
been rendered, the render file for the affected item is no longer valid.
• If the project has been saved since the render file was created: The render file is deleted
whenever the project is saved again, or the change falls off the “Undo queue” (the
series of changes that can be reversed with the Undo command in the Edit menu).
• If the project has not been saved since the render file was created: The render file is deleted
when the new change falls off the Undo queue.
You can keep your important render files by nesting sequences.
Using Nested Sequences to Preserve Render Files
You can preserve render files for a sequence or for audio clips within a sequence by
nesting that sequence within another sequence. Nesting is particularly useful for protecting
the render files for effects-intensive clips you plan to trim frequently.
For detailed information, see “Sequence-to-Sequence Editing.”
Disabling Tracks Affects Render Files
When you disable a video or audio track in the Timeline, any render files associated with
that track are lost. If this happens, you can restore that track’s render files by using the
Undo command.

Tips for Reducing Render Time
Here are some suggestions to avoid rendering:
• Edit the majority of your project using cuts only; add only transitions, effects, or filters
that can play back in real time or that are absolutely necessary in making decisions
about your first cut. Avoiding unnecessary effects and time-consuming rendering can
help you focus on your program’s overall pacing and structure. Once your first cut is
done, you can focus on applying effects like color correction and titles.
• Use the Unlimited RT mode and dynamic real-time playback. For more information,
see “Using RT Extreme.”
• If you use effects that need to be rendered, you can get a good idea of how the clip
looks by simply scrubbing through the clip in the Timeline or Canvas to view the effect
one frame at a time.
You can also choose Mark > Play > Every Frame (or press Option-\) to play through a
clip one frame at a time, not in real time, and get a slow-motion preview of how the
effect will look.
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• When you change the In and Out points of a clip with filters applied, you may need to
rerender the adjusted areas. To avoid constantly rerendering, you can place a clip with
its applied filters into a sequence and then edit that sequence into other sequences.
This is sometimes called nesting a sequence. Because you modify the sequence In and
Out points instead of the clip within the sequence, the render file for the clip is
maintained. For detailed information about nesting clips using the Nest Items command,
see “Sequence-to-Sequence Editing.”
• Turn off filters that require rendering when you don’t need to view the effects in order
to make decisions.
• Turn off the rendering and playback of filters, frame blending, and motion blur
individually. You can also turn off filters and frame blending collectively in the Render
Control tab of the Sequence Settings window. These options can be turned on at any
time.
• Temporarily turn off rendering of clips that cannot play back in real time. This allows
you to make changes to effects-intensive sequences without having to wait for frames
at the position of the playhead to render for display in the Viewer or Canvas. For more
information, see “Temporarily Disabling Rendering.”
Here are some tips for reducing the amount of time it takes to render your sequence:
• Lower the frame rate and resolution of rendered effects in the Render Control tab of
the Sequence Settings window. This lowers the playback quality of those effects but
allows them to render substantially faster.
• Turn off certain render-intensive effects in your sequence, including filters and frame
blending. Using the options in the Render Control tab of the Sequence Settings window,
you can turn all such effects on and off in your sequence without having to turn on or
turn off each effect individually.
• Test-render short sections to evaluate an effect, rather than the entire clip or sequence.
You can always begin rendering a clip and then stop the render midway. Final Cut Pro
preserves what was rendered, so you can see how it looks without having to rerender
the entire clip.
• Render sequences while you take a break or do other work by turning on automatic
rendering in the General tab of the User Preferences window.
In this case, rendering time isn’t actually reduced, but you can make efficient use of
your time by turning your attention to other things as the computer renders your
media. For more information about the Auto Render option in the General tab of the
User Preferences window, see “Choosing Settings and Preferences.”
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Working with Mixed-Format
Sequences

86

This chapter covers the following:
• About Mixed-Format Sequences (p. 1473)
• Determining Whether Clips in a Sequence Will Play Back in Real Time (p. 1474)
• Conforming Sequence Settings to Match a Clip’s Settings (p. 1476)
• Conforming Clips to Match Sequence Settings (p. 1477)
• Mixing Frame Rates (p. 1479)
• Combining Interlaced Footage with Different Field Dominances (p. 1480)
• Mixing Footage with Different Codecs (p. 1482)
• Nesting Nonmatching Sequences (p. 1482)
• Adding Filters and Motion Effects to Mixed-Format Sequences (p. 1483)
• Combining SD and HD Video (p. 1483)
• Downconverting HD Video (p. 1483)
• Upconverting SD Video (p. 1488)
• Rendering Mixed-Format Sequences (p. 1489)
• External Monitoring and Output (p. 1489)
• Media Management and Project Interchange (p. 1490)
Final Cut Pro allows you to mix formats in the Timeline so you can combine and play back
footage with different codecs, frame rates, and image dimensions in a single sequence.

About Mixed-Format Sequences
A mixed-format sequence is a sequence containing clips whose media files don’t match
the sequence format. For example, a DV sequence containing HDV footage is a
mixed-format sequence. Final Cut Pro can play sequence clips in real time even when the
clips’ settings don’t match those of the sequence. Any number of formats can be combined
together in a single sequence.
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You can use mixed-format sequences to:
• Combine standard definition (SD) and high definition (HD) footage in one sequence
• Mix PAL and NTSC footage in a single sequence
• Work with offline-quality and full-resolution footage together
• Mix video with different aspect ratios, frame rates, or codecs in a single sequence.
This section describes time-saving features for working with mixed-format sequences
and discusses how Final Cut Pro handles settings that don’t match, such as image
dimensions, field dominance, and frame rate.

Terminology for Discussing Mixed-Format Sequences
The following definitions provide some shorthand for discussing the behavior of sequences
containing mixed formats:
• Format: The defining characteristics of a video media file—image size, frame rate, and
codec
• Native sequence: A sequence containing clips whose media files match the sequence
settings
• Mixed-format sequence: A sequence containing clips whose media files don’t match
the sequence format
• Nonmatching clip: A clip whose media file format doesn’t match the sequence format
• Real-time nonmatching clip: A nonmatching clip that plays back in real time in a
mixed-format sequence (real-time clip for short)
• Non-real-time nonmatching clip: A nonmatching clip that cannot play back in real time
and therefore must be rendered (non-real-time clip for short). In previous versions of
Final Cut Pro, all nonmatching clips were non-real-time clips.

Determining Whether Clips in a Sequence Will Play Back in Real
Time
When a sequence contains a clip whose media file format doesn’t match the sequence
format, the clip plays back in real time only if:
• The clip’s media file format and the sequence format are both supported by Final Cut Pro
real-time playback
• Both the clip and sequence have a frame rate supported by Final Cut Pro. The following
frame rates are supported: 23.98, 24, 25, 29.97, 30, 50, 59.94, and 60 fps.
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• Your computer has enough processing power to handle the real-time playback of both
the clip and sequence formats. For example, if you are using a portable computer, you
won’t be able to play back uncompressed video.

Formats That Support Real-Time Playback
For a list of formats supported by Final Cut Pro real-time processing, see the Effect Handling
tab in the System Settings window or check the list of Easy Setups included with
Final Cut Pro. For more information, see “Supported Real-Time Playback Codecs” and
“Audio/Video Settings and Easy Setups.”
Media with codecs, frame rates, or image dimensions not supported by real-time
processing in Final Cut Pro, such as MPEG-4 or H.264 media, must be rendered before it
will play back.

Viewing Clip Properties and Sequence Settings
You can quickly check clip properties and sequence settings to see if the format of a clip
and a sequence match.
To view the current format properties of clip
Do one of the following:

µ
µ
µ

Select a clip, then choose Edit > Item Properties > Format (or press Command-9).
Look at the appropriate Browser columns. For more information on working with Browser
columns, see “Browser Basics.”
To view the current sequence settings
Select a sequence, then choose Sequence > Settings (or press Command-0).
The following clip properties and sequence settings are relevant when working with
mixed formats. If any of the clip properties don’t match the corresponding sequence
settings, your sequence is a mixed-format sequence.
Clip properties

Sequence settings

Frame Size

Frame Size (Width, Height, and Aspect Ratio)

Pixel Aspect

Pixel Aspect Ratio

Anamorphic

Anamorphic 16:9

Vid Rate

Editing Timebase

Field Dominance

Field Dominance

Compressor

Compressor
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Conforming Sequence Settings to Match a Clip’s Settings
Although Final Cut Pro can play back mixed-format sequences, you should still try to
match clip and sequence settings so that less rendering is required before output. The
first time you add a clip to a sequence, Final Cut Pro can automatically conform your
sequence video settings to match the settings of the clip.

Choosing Automatic Sequence Conform Options
In the Editing tab of the User Preferences window, the “Auto conform sequence” pop-up
menu allows you to determine what happens when the first clip is added to the sequence:
• Ask: Final Cut Pro presents a dialog asking if you want to conform your sequence
settings to those of the first clip you add. Clicking Yes in this dialog conforms the
sequence settings to the current clip settings. Clicking No does not change the sequence
settings, but the clip is still added. This option is chosen by default.
• Always: The sequence settings are automatically conformed to the settings of the first
clip added. No dialog appears.
• Never: Sequence settings are never affected by the first clip added.

Rules for Automatic Sequence Conforming
When automatic sequence conforming is turned on, the following rules apply when you
add a clip to an empty sequence:
• Only video sequence settings are conformed to the clip settings; audio sequence
settings are never conformed.
• If the clip settings do not match any sequence presets, Final Cut Pro warns you that
your new sequence settings will be conformed to custom settings that may not be
compatible with your input and output devices.
• If the edited clip uses a codec that is not supported by Final Cut Pro or is not available
on your system, the sequence is not conformed to the clip settings.
• Clips copied from the Browser and pasted into a sequence can also trigger automatic
sequence conforming.
• Nesting a sequence into an empty sequence triggers automatic sequence conforming.
• Editing multiple clips into an empty sequence can trigger automatic sequence
conforming, but only when all of the edited clips have matching settings.
To automatically conform sequence settings to the settings of the first clip added to
the sequence
1 Choose File > New > Sequence (or press Command-N) to create a new sequence.
2 Double-click the new sequence to open it in the Timeline.
3 Select a clip whose settings do not match those of the sequence, then drag it to the
sequence.
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A dialog appears asking if you want to conform your sequence settings to the clip settings.
4 Do one of the following:
• Click Yes to conform the sequence settings to the clip settings. In this case, the image
dimensions, frame rate, and codec of the sequence are changed to match those of the
clip.
• Click No to leave the sequence settings as they were when you created the sequence.
In this case, your sequence now contains a clip whose settings do not match the
sequence.

Conforming Clips to Match Sequence Settings
When you edit or paste a clip into a sequence, Final Cut Pro compares the clip’s dimensions,
pixel aspect ratio, and field dominance to those settings in the sequence. If these settings
do not match, the following automatic adjustments are made to the edited clip:
• The Aspect Ratio parameter of the Distort attribute in the Motion tab is adjusted to
conform the aspect ratio of the clip to the sequence. This distortion makes clips appear
correctly when placed in a non-native sequence.
• The value of the Scale parameter in the Motion tab is lowered to fit the clip into the
sequence. This is always the case when the clip’s dimensions are larger than the
sequence’s dimensions.
• A Shift Fields filter may be added if the clip and sequence are both interlaced but the
field dominances don’t match. For more information, see “Combining Interlaced Footage
with Different Field Dominances.”

When Are Clips Automatically Conformed to a Sequence?
Most of the time, Final Cut Pro automatically conforms clips when you edit them into a
sequence. This makes it simple to mix HD and SD video with different resolutions, aspect
ratios, and field dominances. However, there are certain cases where Final Cut Pro does
not conform your clip:
• If the dimensions of the edited clip are smaller than those of the sequence, the value
of the clip’s Scale parameter is increased only if the “Always scale clips to sequence
size” option in the User Preferences window is selected.
• When you edit or paste a clip that contains Scale or Aspect Ratio parameter keyframes
into a sequence, Final Cut Pro does not change these parameter settings to fit the clip
into the sequence. This allows you to preserve any Scale or Aspect Ratio parameter
keyframes you added to your clip to create a motion effect.
To automatically conform edited or pasted clips whose image dimensions are smaller
than the sequence dimensions
1 Choose Final Cut Pro > User Preferences, then click the Editing tab.
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2 Select “Always scale clips to sequence size,” then click OK.
3 Edit one or more clips into your sequence.
Each edited clip’s Scale and Aspect Ratio parameter settings are adjusted automatically
so that the clip’s size matches the sequence dimensions.

Manually Conforming Clips to Match Sequence Settings
If a sequence clip does not have settings that match those of the sequence, you can
manually conform the clip’s settings to match the sequence settings. The following
settings can be conformed:
• Scale parameter
• Aspect Ratio parameter
• Field dominance
To conform sequence clips to the settings of the sequence
1 Select one or more sequence clips.
2 Choose Modify > Conform to Sequence.
The Scale and Aspect Ratio parameter settings of each selected clip are adjusted so the
clips appear at their native aspect ratio within the sequence dimensions. Also, a Shift
Fields filter may be applied, adjusted, or removed so that each clip’s field dominance
matches the field dominance of the sequence.
Important: The Conform to Sequence command removes any Scale or Aspect Ratio
parameter keyframes applied to the clip. If you don’t want to lose these animated
parameter settings, you should avoid using the Conform to Sequence command.

Conform to Sequence Versus Scale to Sequence
The Conform to Sequence command fits a clip into a sequence in three ways: a clip’s
Scale and Aspect Ratio parameter settings are adjusted and a Shift Fields filter is applied,
modified, or deleted. This command ensures that a clip has the proper aspect ratio and
field dominance.
The Scale to Sequence command merely adjusts the Scale parameter of a clip so that it
fits within the sequence dimensions. No aspect ratio or field dominance correction is
applied.

Choosing High-Quality Scaling Options
To ensure the highest quality, you should always choose the best scaling quality option
in your sequence settings.
To choose the best scaling quality for a sequence
1 Select a sequence in the Browser, or double-click a sequence to open it in the Timeline.
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2 Choose Sequence > Settings, then click the Video Processing tab.
3 Choose Best from the Motion Filtering Quality pop-up menu.
4 Click OK.
Tip: To decrease rendering time during your edit session, you can choose a lower-quality
motion filtering option; just remember to set the quality to Best before you output your
final sequence.

Mixing 720 x 480 Footage and 720 x 486 Footage
When you add a DV NTSC clip (720 x 480) to a Rec. 601 SD sequence (720 x 486), the DV
clip is not scaled. In most cases, the top and bottom three lines of the sequence will
appear black—the default background color of the sequence—because the DV clip does
not completely fill the 720 x 486 frame. This is considered the best approach because it
preserves the pixel aspect ratio of the DV footage and doesn’t require scaling. However,
you can also scale 720 x 480 footage to 720 x 486 footage. For more information, see
“Scaling Images and Video Clips to Match a Sequence.”

Mixing Frame Rates
Clips with any Final Cut Pro-supported frame rate can be added to a sequence and played
back in real time. Depending on whether the clip frame rate is faster or slower than that
of the sequence, Final Cut Pro skips or repeats frames of the sequence clip.
Nonmatching frame rates are handled in three ways.
• If a clip and sequence have matching frame rates: Each frame of the clip’s media file is
played back in the sequence. No frame rate conversion occurs, even when the clip and
sequence codecs don’t match. Ideally, your clip and sequence frame rates should always
match.
• If a clip’s frame rate is slower than the sequence frame rate: Final Cut Pro repeats frames
of the clip’s media file as necessary to create the appearance of playback at the sequence
frame rate. The repeating pattern is not necessarily compatible with standard pull-down
or frame duplication patterns of other formats. In cases with interlaced footage (such
as a PAL clip within an NTSC sequence), fields are sometimes doubled (instead of frames)
to avoid field stuttering.
• If a clip’s media file frame rate is faster than the sequence frame rate: Final Cut Pro drops
frames of the clip’s media file as necessary to create the appearance of playback at the
sequence frame rate. Because frames are skipped, you won’t always be able to trim
these clips with frame accuracy. In those cases, you may want to open the original clip
in the Viewer to set a specific In or Out point before editing the clip into the sequence.
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Issues When Working with Mixed Frame Rates
When you add a clip to a sequence and the frame rates don’t match, Final Cut Pro places
the clip as accurately as possible in the Timeline. However, because of the differences
between some frame rates, there may be a one-frame shift on either the In or Out point
of the clip. This is normal behavior caused by the limitations of mixed-frame-rate editing.
After you add a nonmatching clip to a sequence, always check to make sure your clip In
and Out points appear the way you want, and adjust them if necessary.
Copying and pasting clips from one sequence to another can also create mixed-frame-rate
scenarios. Frame rate errors can accrue if you repeatedly copy sequence clips to new
sequences with nonmatching frame rates. When possible, it’s always better to edit with
master clips from the Browser instead of dragging clips between sequences.
Motion has a different frame repeating and frame skipping pattern than Final Cut Pro, so
you may see different frames repeated than expected when including Motion projects
in a Final Cut Pro sequence.

Working with Subclips in Mixed-Frame-Rate Sequences
In cases where a subclip’s frame rate and a sequence’s frame rate do not match, adding
the subclip to the sequence may cause the subclip limits to be adjusted and new clip In
and Out points to be set. These adjustments ensure that the edit you perform has the
starting and ending frames you would expect.
You can verify that the subclip limits have been adjusted by comparing the following
Browser columns before and after you add a subclip to a sequence with a nonmatching
frame rate:
• Media Start
• Media End
• In
• Out
If any of these clip properties are adjusted when you perform an edit with a subclip,
Final Cut Pro displays a dialog to notify you.

Combining Interlaced Footage with Different Field Dominances
Field dominance determines the order in which fields are scanned on an interlaced
monitor (such as an NTSC, PAL, or interlaced HD monitor). If a format uses Upper (Odd)
field dominance, the first field scanned (called field 1) is made up of the odd lines in the
video frame. Lower (Even) field dominance scans the even lines first.
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Note: A clip’s Field Dominance property can also be Not Set, which means that the clip’s
media file is likely interlaced but Final Cut Pro couldn’t determine which field dominance
to set when the clip was imported. You can also manually change the field dominance
of a clip in the Browser or the Item Properties window, but you should usually do this
only if the clip’s Field Dominance property is Not Set.
If the field dominance is set incorrectly for a clip, the fields of each frame are played in
reverse order, producing a rapid stutter in which the overall video motion is forward, but
the fields of each frame are played backward.

Using the Shift Fields Filter
When you add a clip to a sequence, Final Cut Pro checks the field dominance settings of
both to see if they match. If both the clip and sequence are interlaced but use opposite
field dominance, Final Cut Pro automatically adds a Shift Fields filter to the clip so that
the clip field dominance matches the field dominance of the sequence.
Clip field dominance

Sequence field dominance

Shift direction of Shift Fields
filter

Lower (Even)

Upper (Odd)

–1

Upper (Odd)

Lower (Even)

+1

In most cases, the Shift Fields filter is applied automatically, so you rarely need to apply
this filter yourself. However, you can modify, add, or delete the Shift Fields filter just as
you can any other filter. The Shift Fields filter is located in the Effects tab and Effects menu
within the video filters Video category.

Mixing Interlaced and Progressive Footage
The scanning method of a clip or sequence is determined by its field dominance setting.
There are three possible field dominance settings that determine clip and sequence
scanning methods.
Scanning method

Field dominance setting

Progressive

None

Interlaced

Upper (Odd) Lower (Even)

Interlaced clips added to a progressive sequence are deinterlaced during playback.
Progressive clips added to an interlaced sequence are interlaced during export or output.
Note: Computer displays are inherently progressive, so you should always connect an
external video monitor when testing interlaced video issues.
For the highest quality, you can use Compressor to deinterlace interlaced footage before
editing it into a progressive sequence. For details, see the Compressor User Manual, available
in Compressor Help.
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Mixing Footage with Different Codecs
A codec, or compressor, is the algorithm used to compress video to a smaller size and
then decode the video for playback. A sequence clip whose codec doesn’t match the
sequence codec can be played back in real time as long as the following is true:
• Final Cut Pro has real-time support for both the clip and sequence codecs.
• Your computer has the processing power and disk speed to play back the clip codec
in real time.
When playing back video in the Viewer and Canvas, or via Digital Cinema Desktop Preview,
Final Cut Pro decompresses each sequence clip’s codec and shows the decoded video
on your display. However, when rendering and outputting, each sequence clip is also
recompressed into the selected sequence codec, requiring additional processing power.
Because rendering is not a real-time process, this is not an issue, but for real-time playback
to an external video device, mixed codecs can add additional processing overhead. For
more information, see “External Monitoring and Output.”
For more information about rendering mixed-format sequences, see “Rendering
Mixed-Format Sequences.”

Nesting Nonmatching Sequences
Real-time playback of nested sequences is possible under the following conditions:
• Codec, pixel aspect ratio, and anamorphic properties of nested and parent sequences
do not have to match
• All other parameters, such as image dimensions and field dominance, must match
Important: Final Cut Pro does not allow you to nest one sequence into another if their
frame rates do not match.
For example, a DVCPRO 50 NTSC sequence nested into a DV NTSC sequence plays back
in real time because both sequences have the same frame rate, image dimensions, and
field dominance.
Note: Imported Adobe Photoshop files with multiple layers become sequences in
Final Cut Pro. To avoid mixed-frame-rate sequences when nesting layered Photoshop
sequences, you can change the frame rate of the Photoshop sequence. For more
information, see “Working with Layered Photoshop Files.”
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Adding Filters and Motion Effects to Mixed-Format Sequences
You can add filters to nonmatching clips and adjust their motion parameters just as you
would in a native sequence. With the exception of different real-time processing demands
required by nonmatching clips, working with effects in a mixed-format sequence is
essentially the same as working with native sequence clips.
When adjusting parameters in the Motion tab of a sequence clip that has been scaled to
match your sequence, keep in mind that the clip already has adjusted motion parameters
that make the clip appear normal within the sequence. If you reset all of the parameters
in the Motion tab of the clip, the clip may not appear as you expect. In this case, you can
use the Scale to Sequence command to match the clip dimensions and aspect ratio to
the sequence. For more information, see “Scaling Images and Video Clips to Match a
Sequence.”

Combining SD and HD Video
Many video producers find that they need to combine HD footage with SD footage, or
combine several HD video sizes, within the same project. Converting a video format to
a higher-resolution format is called upconverting, and the reverse is called downconverting.
The process of upconverting and downconverting is not as simple as scaling a video
frame. Changes in aspect ratio (4:3 for SD and 16:9 for HD), frame rate, and scanning
method (interlaced and progressive) may also be involved.
For more information about downconverting, see “Downconverting HD Video.”
For more information about upconverting, see “Upconverting SD Video.”

Downconverting HD Video
There are several methods for downconverting HD video to SD video:
• Letterbox
• Crop
• Pan and scan
• 16:9 anamorphic

Letterboxing 16:9 Video in a 4:3 Frame
To preserve the aspect ratio of widescreen movies on a 4:3 screen, widescreen movies
are scaled until the width fits within the 4:3 frame. The remaining space at the top and
bottom of the 4:3 frame is left empty and is usually black.
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If a film or video was shot to be exclusively viewed in a widescreen venue, this technique
is usually the best approach for downconversion. However, this method makes poor use
of the already lower resolution of an SD 4:3 frame, because many lines are not used at
all.

1080 to 480

720 to 480

To letterbox a 16:9 clip within a 4:3 sequence
1 Create a sequence with a 4:3 aspect ratio. For example, choose the DV-NTSC or DV-PAL
Easy Setup and then create a new sequence.
2 Drag a clip with a 16:9 aspect ratio to the sequence.
If a dialog appears asking if you want to conform your sequence settings to your clip,
click No.
The 16:9 sequence clip is now scaled to fit in the 4:3 sequence and appears letterboxed.
For more information, see “Scaling Images and Video Clips to Match a Sequence.”
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Cropping 16:9 Video to 4:3
If you keep both 16:9 and 4:3 aspect ratios in mind during the shoot, making sure
important action stays within the 4:3 center of the 16:9 frame, you can choose to crop
your entire clip within a 4:3 frame. This method allows you to fill the whole 4:3 screen
with some portion (usually the center) of your 16:9 image.

16:9 to 4:3 crop center

16:9 frame

4:3 frame

Note: For broadcast in the UK, 16:9 images are often cropped to 14:9 and letterboxed
within a 4:3 frame (for PAL televisions). Because a 14:9 image has a less severe letterbox
(that is, smaller black bars at the top and the bottom of the frame), some viewers find
this less objectionable.
To crop and center a 16:9 clip within a 4:3 sequence
1 Follow the instructions for scaling a 16:9 clip within a 4:3 sequence in “Letterboxing 16:9
Video in a 4:3 Frame.”
The 16:9 sequence clip is now scaled to fit in the 4:3 sequence and appears letterboxed.
Now you need to scale the clip up so that the sides are cropped.
2 Double-click the sequence clip so that it opens in the Viewer, then click the Motion tab.
3 If the Basic Motion parameters are not shown, click the Basic Motion disclosure triangle.
4 While watching in the Canvas, drag the Scale slider to the right until the clip height
matches the height of the Canvas.
You can also enter the following value in the Scale field: the original value that appeared
in the Scale field multiplied by 1.33. For example, if Final Cut Pro letterboxed your clip
using a Scale value of 50, enter “66.5” (50 x 1.33) to scale the entire clip to the Canvas
height.
The sides of the clip are now cropped by the 4:3 sequence.

Chapter 86 Working with Mixed-Format Sequences

1485

Pan and Scan
The pan and scan method crops 16:9 clips within a 4:3 frame, but each clip can be uniquely
cropped to focus on a particular portion of the frame. The pan and scan method does
not necessarily refer to panning during the transfer, but rather the fact that each frame
may be cropped differently.

16:9 to 4:3 pan and scan

To crop and move a 16:9 clip within a 4:3 sequence
1 Follow the instructions for scaling a 16:9 clip within a 4:3 sequence in “Cropping 16:9
Video to 4:3.”
The sides of the clip are now cropped by the 4:3 sequence. Now you can move the clip
horizontally to focus on different parts of the frame. If you scaled the clip beyond the
height of the Canvas, you can also move the clip vertically.
2 In the Canvas, choose Image+Wireframe from the View pop-up menu.
Wireframe guides appear over the sequence clip.
3 Choose Fit to All from the Zoom pop-up menu so you can see the boundaries of the clip.
4 Make sure the Selection tool is active by clicking it in the Tool palette (or pressing A).
5 While holding down the Shift key, drag the clip in the Canvas to the left or right to select
a new framing for the clip.
Holding down the Shift key restricts movement to a single axis so you can limit your
adjustments to the horizontal axis.
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Creating Artificial Pans in 16:9 Footage
In some complex scenes with multiple characters or centers of visual activity, an artificial
camera move (a pan) can be introduced to recenter the widescreen action within the
4:3 frame.
In Final Cut Pro, you can crop and even perform simple pans by animating the Center
parameter in the Motion tab. However, unless the animation is convincing, this can be
more of a distraction than anything else. For more information on using the Motion tab
and animating parameters, see “Changing Motion Parameters” and “Animating Motion
Effects Using Keyframes.”

16:9 Anamorphic
You can use this method to preserve the 16:9 aspect ratio of HD video when scaling down
to SD video. 16:9 anamorphic video squeezes a 16:9 image within a 4:3 aspect ratio, and
the image is stretched during playback so it appears normal. Some DVD players and video
monitors have an option to unsqueeze anamorphic video.

16:9 to16:9 anamorphic

16:9

16:9 anamorphic (4:3)

To squeeze a 16:9 clip within a 16:9 anamorphic sequence
1 Create a sequence with a 16:9 anamorphic aspect ratio. For example, choose the DV-NTSC
Anamorphic or DV-PAL Anamorphic Easy Setup and then create a new sequence.
2 Drag a clip with a 16:9 aspect ratio to the sequence.
If a dialog appears asking if you want to conform your sequence settings to your clip,
click No.
The 16:9 sequence clip is now scaled to fit in the anamorphic 16:9 sequence, and the
aspect ratio of the 16:9 clip is preserved even though you are working in an SD sequence.
For more information about anamorphic video, see “Working with Anamorphic 16:9
Media.”
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Upconverting SD Video
Upconverting a 4:3 aspect ratio image to a 16:9 frame results in borders (or side panels)
on the left and right sides of the 4:3 image. This type of frame is sometimes referred to
as pillarboxed.
If the aspect ratios of the original and destination formats match (for example, 720 x 480
anamorphic footage upconverted to 1920 x 1080), you can simply scale the original video
to the destination size.
Original size

Original aspect
ratio

Destination
aspect ratio

Upconversion
method

720 x 480

4:3 (1.33)

1280 x 720,
1920 x 1080

16:9 (1.78)

Scale up and
pillarbox

720 x 480
(anamorphic)

16:9 (1.78)
squeezed

1280 x 720,
1920 x 1080

16:9 (1.78)

Scale up

1280 x 720

16:9 (1.78)

1920 x 1080

16:9 (1.78)

Scale up

Destination size

Pillarboxing 4:3 Video in a 16:9 Frame
Scaling 4:3 video to 16:9 results in black side panels on either side of the 4:3 image.

480 to 1080

Side panels
480 to 720

To pillarbox a 4:3 clip within a 16:9 sequence
1 Create a sequence with a 16:9 aspect ratio. For example, choose the DVCPRO HD - 1080i60
Easy Setup and then create a new sequence.
2 Drag a clip with a 4:3 aspect ratio to the sequence.
If a dialog appears asking if you want to conform your sequence settings to your clip,
click No.
3 If the clip is not automatically scaled up to fit the sequence, select the sequence clip and
then choose Modify > Scale to Sequence.
The 4:3 sequence clip is now scaled to fit in the 16:9 sequence and appears pillarboxed.
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For more information, see “Scaling Images and Video Clips to Match a Sequence.”

Upconverting 4:3 Anamorphic Video to 16:9 Video
4:3 anamorphic video is actually a 16:9 image squeezed into a 4:3 frame, so it can easily
be scaled to fit an HD sequence.

480 anamorphic to 1080

480 anamorphic to 720

µ

To edit 16:9 anamorphic footage into a 16:9 sequence
Follow the instructions for scaling a 4:3 clip into a 16:9 sequence in “Pillarboxing 4:3 Video
in a 16:9 Frame.” However, instead of using a normal 4:3 clip, use a 16:9 anamorphic clip.
The 16:9 anamorphic clip is now scaled to fit in the native 16:9 sequence.

Rendering Mixed-Format Sequences
For the highest-quality output, you should always render any segments of a sequence
whose render status bars indicate that they need rendering. When you use the Edit to
Tape and Print to Video commands, Final Cut Pro automatically renders these segments
for you. For more information, see “About Render Status Bars.”
In some situations, you will need to render nonmatching clips to play back your sequence.
For example, if you add an uncompressed clip or HDV clip to a DV sequence, you may
need to render the clip in the Timeline if your computer cannot play back the source
media in real time.

External Monitoring and Output
To output a sequence to an external video device, the frame rate of both the sequence
and the video device must match. However, the image dimensions and codecs can be
different. Video is properly scaled and letterboxed or pillarboxed to fit within the
dimensions of your output device.
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For example, if your computer has sufficient power, you can:
• Output an HD sequence via DV FireWire
• View a DV or OfflineRT sequence via an SDI video output on a third-party video interface
• Downconvert an HD sequence to an SD video output
Some specific examples of supported real-time video output configurations include:
• A DV NTSC sequence output to DV FireWire, where the sequence contains 1080i60
HDV and 720p30 DVCPRO HD clips
• A 1080i60 HDV sequence output to DV FireWire, where the sequence contains DV NTSC
and DVCPRO HD 720p30 clips

Media Management and Project Interchange
Working with mixed formats in a sequence can present unique media management
challenges. The following section describes limitations in the following areas when working
with mixed-format sequences:
• Using the Media Manager
• Exporting EDLs
• Using Cinema Tools

Using the Media Manager with Mixed-Format Sequences
When you process media associated with a mixed-format sequence, keep in mind that
Final Cut Pro bases most of its functions on the frame rate of the sequence, not the media
file. If you are simply using the Media Manager to copy or move a sequence and its
associated media, your media is merely duplicated. However, if you choose options such
as Delete Unused Media or Recompress, you should check your results to make sure
nonmatching image dimensions, frame rates, and codecs did not cause unexpected
results. Processing mixed-format sequence clips with speed changes through the Media
Manager may also cause unexpected results.

Exporting an EDL from a Mixed-Format Sequence
All clips in an exported EDL are assumed to have the same frame rate as the sequence.
When you export an EDL from a mixed-format sequence, source timecode In and Out
points are shown at the sequence frame rate, not the source timecode rate. As a result,
you may not be able to use an EDL exported from a mixed-format sequence for recapturing
footage.
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Working with Cinema Tools and Mixed-Format Sequences
Mixed-format sequences are not recommended for use with Cinema Tools. Mixed-format
sequence playback does not perform 3:2 pull-down removal, deinterlacing, or accurate
timecode or keycode tracking of your clips. If you are editing film-based media in
Final Cut Pro, you should use any of the suggested workflows described in the Cinema Tools
User Manual, avialable in Cinema Tools Help.
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Media Management

87

This chapter covers the following:
• What Is Media Management? (p. 1493)
• Reasons to Use Media Management (p. 1494)
• What You Need to Know to Manage Your Media (p. 1495)
• Media Management Process in Final Cut Pro (p. 1495)
• Strategies for Media Management (p. 1496)
Successful editing requires effective media management. You should pick a media
management strategy before you begin your project.

What Is Media Management?
Media management is a term used for several related tasks throughout post-production.
In general, any task that relates to processing your media is considered to be media
management, such as capturing, compressing, copying, moving, or deleting media files.
However, media management also refers to keeping track of your media files via clip
properties such as log notes, comments, scene number, shot/take number, and so on.
The flexibility and power of media management in Final Cut Pro stems from one simple
fact: a clip and its media file are treated independently. In Final Cut Pro, a more accurate
description of media management would be clip and media management. What makes
the separation of clips and media files so powerful? Here are a few examples:
• Reconnecting clips to new media files: You can create new media files for your project
at any time, and reconnect the clips in your project to the new media files.
• Direct access to your media files: You can directly access your QuickTime media files in
the Finder at any time. You can also easily create clips by dragging media files directly
into your project via the Browser. In fact, you can even edit by dragging media files
from the Finder directly into the Timeline or Canvas.
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• Logging clip information without media: You can modify clip properties such as log
notes, comments, labels, and even In and Out points without the associated media
files. This means you can organize your clips and sequences even though your current
editing system may not have the media files.
• Trading projects without media files: A Final Cut Pro project file contains clips and
sequences, but not media files. Because a project file is so small, you can email or post
your project file online. Anyone who has the corresponding media files can open the
project file and reconnect the clips to the local media files.
Making a movie is a tremendous logistical undertaking. It’s the execution of the details
that ultimately determines the quality of the finished product. What does it matter how
good the lead actress’s performance was in the third take of scene 2 if you can’t find it
among a thousand other shots? And what use is a week of fine-tune editing, frame by
frame, if the final sequence is improperly assembled by the negative cutter because of a
faulty edit decision list that you provided?
Final Cut Pro has incredibly versatile media management options, allowing you to
customize your workflow to fit the needs of your project.

Reasons to Use Media Management
Computers are very effective for sorting and organizing information, much more so than
scraps of paper and handwritten notes. This isn’t to say you should dispense with these
basic tools—most editors still use them prolifically. However, mastering management of
your media, clips, and notes in Final Cut Pro is critical for an efficient editing workflow.
• Browser: A virtual media database for sorting, categorizing, and commenting on clips.
• Find command: Allows you to quickly search a sequence or project for any clip based
on any criterion.
• Media Manager: A powerful clip and media file processor for duplicating, removing,
and recompressing media files, as well as clips and sequences in your project.
• Recapturing and reconnecting: You can recapture or reconnect clips to new media files
at any time you want. The connection between clips and media files is easy to change,
making Final Cut Pro one of the most flexible media editing systems available.
• Finder (in Mac OS X): You can sort, view, and archive media files directly in the Finder
(or QuickTime Player) because Final Cut Pro works directly with QuickTime media files.
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What You Need to Know to Manage Your Media
To effectively keep track of or manage your media, you must have a good understanding
of the following:
• The distinction between a clip and a media file, as well as the relationship between the
two
• The relationship between master and affiliate clips in a Final Cut Pro project
• How timecode works, providing a bridge between footage on tape or film to media
files on hard disk to clips in your project
• How to effectively sort and search large amounts of data, such as clips in the Browser
or in a sequence
• How to name files concisely and descriptively
• The fundamental nature of your media: frame size, aspect ratio, frame rate, codec, color
bit depth, color space, and audio sample rate and bit depth

Media Management Process in Final Cut Pro
Logging, capturing, making subclips, and processing your media are all steps in managing
your media files. Because clips are separate from media files in Final Cut Pro, you can
easily assign them to different media files throughout the course of a project. This allows
you to switch between low- and high-resolution versions of your media files, and transfer
projects to other Final Cut Pro systems without media files and quickly reconnect them.
You can also delete unused media files to save hard disk space, or recapture media files
using clips in your project.
Here is one practical example of how media management occurs throughout a project:
Stage 1: Logging and Capturing
Media files are captured from tape to hard disk. A clip which represents that media file
is simultaneously created in your project.
Stage 2: Refining Your Sequence and Managing Media
As you edit, you refine your sequence, using fewer and fewer of your media files, but
those files still take up valuable hard disk space. Once you finish your sequence, you can
remove media files (or portions of media files) you no longer need. Final Cut Pro defines
unused media as any media file not used by a sequence in your project. Final Cut Pro can
easily tell you which clips in your project are not used in any sequences, and thus which
media files are likely irrelevant to your project. You can use the Media Manager to delete
the unused media from your hard disk.
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Stage 3: Recapturing Media
Suppose you cleaned up your hard disk by having Final Cut Pro delete a lot of media files,
but you realized that there were a few clips that you had intended to include in your
sequence but hadn’t yet. At this point, these clips’ media files are offline (in this case,
deleted from the hard disk). You can’t reconnect these clips to media files because the
media files no longer exist. You need to capture the original footage to your hard disk
again. Final Cut Pro can easily do this. The clip, which still stores the tape reel number
and timecode In and Out points of the original footage on tape, holds the information
for finding and recapturing the media from tape.
Stage 4: Transferring Your Project to Another Final Cut Pro System
Clips represent media files even when the media files aren’t there. This means that the
structure of an entire edited sequence can be saved separately from its media files. At
any time, you can always tell Final Cut Pro to recapture all of a sequence’s media files,
and the movie is automatically re-created. This applies equally to a single clip whose
media file you accidentally deleted to an entire sequence of clips that has been copied
to a different Final Cut Pro editing system. Even though the clips are offline (the clips’
media files are missing) on the new system, the clips contain the vital timecode and reel
number information to recapture all the media from tape to hard disk, making it simple
to re-create the sequence.
Stage 5: Performing the Online Edit and Outputting to Tape
When you have finished with your edit, you can use the Media Manager to duplicate your
finished sequence using full-resolution settings. Each clip in this sequence has
full-resolution settings, which you can use to recapture all the necessary media to create
the final cut at full resolution. Once recapturing is complete, you can apply any necessary
color correction, titles, transitions, and so on, and then output to tape.

Strategies for Media Management
It’s a good idea to pick a strategy for media management before you begin your project.
Some important things to consider as part of your strategy are reel name conventions,
clip name conventions, working with full-resolution media versus offline media, working
with multiple editing workstations, and using a storage area network.

Reel Name Conventions
This issue affects recapturing in Final Cut Pro or any other editing system. Reel numbers
must be correct so that Final Cut Pro asks for the proper tape when you recapture media.
Some Edit Decision List (EDL) formats have strict rules for reel names, so be conservative
with your reel names if there is even a slight chance you will export an EDL for your
project. For more information about reel name limitations in EDLs, see “Reel Name
Restrictions in EDLs.”
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Clip Name Conventions
Clips can get their names in several ways. If you log clips individually, a clip name is
derived from a combination of the description, shot/take, scene, and angle properties of
a clip. However, if you create clips by importing a batch list, EDL, or Final Cut Pro XML,
you may name the clips independently of these other properties. In either case, choose
a fairly concise but descriptive name.
If you are working on a narrative, scene name and take number may be sufficient because
the shooting script provides the information you need to order your shots. However,
unplanned footage for news or documentaries requires more descriptive names.
Try to avoid special characters in clip names. This is especially important if you happen
to use the Media Manager to create new media files based on clip names.
Remember that clips in Final Cut Pro have many properties besides the Name field where
descriptive information can be added. Log notes, comments, the Mark Good property,
labels, and markers within clips can be used to describe your clips more accurately.

Media Filename Conventions
Avoid special characters for filenames. If you are logging clips in the Log and Capture
window, the name of your clip determines the name of the file, so this means you should
avoid special characters in clip names too. Don’t change media filenames directly in the
Finder, or your clips will go offline.

Working with Full-Resolution Media
You can capture and edit your media at full resolution, or you can use an offline/online
workflow where you capture and edit at low-resolution, and then recapture at full
resolution for your final edit.

Working with Multiple Editing Workstations and Trading Project Files
If you are working on the same project on multiple editing systems, you need multiple
copies of your media files. All systems can have identical copies of full-resolution media,
or some can have low-resolution media (such as portable computers) while others use
full-resolution files. Project files can be transferred from one system to another and clips
are reconnected to local media files.

Using Multiple Workstations with a Storage Area Network
Storage area networks (SANs) allow you to connect multiple computers to a centralized
media storage device, so everyone is working with exactly the same media files instead
of multiple copies. You can build a SAN using Xserve RAIDs, Apple Xsan software, and a
fibre channel card installed in each computer.
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Using Another Linear or Nonlinear System
If you plan to do final color correction, effects, and broadcast specifications on a
non–Final Cut Pro system, consider how you will deliver your sequence and media. You
need to pick a project interchange format that the online editing system recognizes. For
example, many Avid and ProTools systems recognize AAF and OMF files; other
post-production tools recognize the Final Cut Pro XML Interchange Format; and linear
tape-to-tape edit suites use EDL files. Media can be delivered on tape for recapturing into
a nonlinear system, or for editing onto the master tape in a tape-to-tape suite. In many
cases it is faster to recapture tapes than to transcode digital files from a
Final Cut Pro-compatible codec to a format the online system recognizes.
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Backing Up and Restoring Projects

88

This chapter covers the following:
• Backing Up and Restoring Projects (p. 1499)
• Archiving Completed Projects (p. 1503)
• About Updating Projects from Previous Versions of Final Cut Pro (p. 1504)
• Choosing Project Update Options (p. 1505)
Routine backups are a critical part of the editing process. If necessary, you can go back
to earlier versions of a project.

Backing Up and Restoring Projects
Final Cut Pro has several methods for backing up, reverting to, and restoring projects. If
you have made changes you don’t want to keep, or if your project file becomes corrupt
in some way, you can use these features to quickly get back to an earlier version of your
project.

Using the Revert Project Command
Sometimes you may make a series of trial changes to a project. What if you don’t like
those changes and want to start over with your project the way it was the last time you
saved it? You can use the Revert Project command to immediately return to the previously
saved state of a project.
To revert to the previously saved state of a project
1 Click a project’s tab in the Browser or Timeline to make it active.
2 Choose File > Revert Project.
3 In the dialog that appears, click OK.

Using the Autosave Feature
Autosave routinely saves copies of your project while you work. If something goes wrong
with the current version of your project, you can restore an autosaved version to quickly
pick up where you left off.
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By default, autosave files are stored in the following
location:/Users/username/Documents/Final Cut Pro Documents/Autosave Vault/.
To turn on autosave
1 Choose Final Cut Pro > User Preferences, then click the General tab.
2 Select the Autosave Vault checkbox.
3 Enter the following options:
• Save a copy every: The frequency (in minutes) that you want to autosave projects.
• Keep at most: The number of copies of a project autosaved before Final Cut Pro deletes
the oldest one.
• Maximum of: The number of open project files simultaneously autosaved. For example,
if this field is set to 25, and you have 26 project files open simultaneously, only the first
25 projects are autosaved.
4 Click OK.
To change the location of the Autosave Vault folder
1 Choose Final Cut Pro > System Settings, then click the Scratch Disks tab.
2 Click Set next to the Autosave Vault option.
3 Navigate to a folder to store autosaved files, then click Choose.
4 Click OK to accept the changes to System Settings.
A folder called Autosave Vault is created at the selected location. All autosaved copies
for a given project are stored in their own project folder within the Autosave Vault folder.

Autosave files for
one project

If you have more than one hard disk, you can routinely save your normal project file on
one disk and specify an Autosave Vault folder on the other disk. This way, if you have
trouble with one hard disk, you will still have project files on the other.
Warning: The Autosave Vault folder is not locked. If you inadvertently delete this folder
from the Finder, Final Cut Pro automatically re-creates it. However, any autosave files in
the deleted folder cannot be re-created.
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Once autosave is selected, new autosaved versions of your project are created according
to the time specified in the “Save a copy every N minutes” field. If no changes have been
made to your project since the last autosave file was created, Final Cut Pro doesn’t autosave
the project again until you make further changes. For example, if you have five projects
open and make changes to only two of them, Final Cut Pro only creates autosave files
for the two projects you changed.
Autosave files use the following naming scheme:
ProjectName_MM-DD-YY_HHMM

where ProjectName is the first 17 characters of your project.

Using a First-In, First-Out Strategy
Final Cut Pro uses a “first-in, first-out” strategy for keeping autosave files. When Final Cut Pro
reaches the limit for the number of copies created or projects saved, the oldest autosave
file is placed in the Trash (unless the oldest project is currently open) and a new autosave
file is created. If you’re working on several projects and you know that one is about to
be deleted (you’ve reached the number specified in the “Maximum of N projects” field),
you may want to make a backup copy of the earliest autosaved project folder and its
contents for future use.
The autosave feature will never delete projects or folders automatically. Instead, files that
exceed the maximum numbers of copies and projects you set in the Autosave Vault
options (in the General tab of the User Preferences window) are placed in the Trash, but
the Trash is not emptied. That is left for you to do, in case you later change your mind
about what files you want to keep.

Restoring Autosaved Projects
If you’re working on your project and decide you want to go back to an earlier autosaved
version, you can use the Restore Project command. Restore Project allows you to choose
from all of the available autosaved versions of the currently active project, based on the
time and date they were created.
For example: Your client saw the newest cut of a project and didn’t like it. If you know
that the client liked a version created on the morning of July 31, 2005, you can use the
Restore Project command to open the autosave file that was created closest to that time.
This way you can restore the project to a version that you know your client liked.
To restore a previously autosaved project
1 Click a project’s tab in the Browser or Timeline to make it active.
2 Choose File > Restore Project.
3 In the dialog that appears, choose the autosave file you want to use, then click Restore.
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The number of items in the pop-up menu for a project depends on the settings in the
Autosave Vault options in the General tab of the User Preferences window and corresponds
to the current number of autosave versions of the project in the Autosave Vault folder.

Choose the project file
you want to use.

4 When a message appears asking if you want to restore the file, click OK.
The current project in the Browser is replaced with the autosaved version of the project
you selected. Your project continues to be named by its original name and new autosave
files are added to the existing vault. Make sure you save the project by choosing File >
Save or by pressing Command-S.
You can also open an autosaved project and then work with it as a new project, different
from the original.
To restore a previously autosaved project as a new project
1 Click a project’s tab in the Browser or Timeline to make it active.
2 Choose File > Open.
3 In the dialog that appears, select the autosave file you want to use, then click Choose.
The autosave file opens as a new project with the project name and the date that the
autosave file was created.
The new restored project will save files to a new autosave vault. Make sure you save the
project by choosing File > Save or by pressing Command-S.

Opening a Project File If Your Computer Is Unexpectedly Shut Down
If your computer is abruptly shut down, you can open the most recently autosaved project
file after you restart your computer.
In this situation, you have several options:
• Open the project file and restore the latest autosaved version.
• Open the latest autosaved version of the project directly from the Finder. In this case,
Final Cut Pro treats the opened autosaved project as a completely separate project,
leaving your original project file unchanged. If you choose this approach, you should
move or copy the autosaved project file to the location where you normally store your
project files and rename it without the additional time and date suffixes added by the
autosave process.
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Archiving Completed Projects
After living and breathing a project for months or years, it may be hard to imagine you’ll
ever want to look at it or touch it again—but you never know for sure. You might get a
surprise distribution offer, but with the caveat that you shorten the project by 5 minutes.
If that happens, will you be able to resurrect the project from its individual media and
sequence components? Did you save everything you needed?
When you archive your project, you need to ask yourself, “How long will I need this
project?” This is a hard question to answer with certainty, so most people err on the side
of caution. It’s almost always better to back up more than less.
For long-term archiving, you should save both the project file and the original media
(such as the actual videotapes). As long as there is an accurate timecode relationship
between the clips in your project and the timecode on your videotapes (or film), you can
open your project and recapture your media at any time.
Depending on the duration of your original footage, the captured media files that you
used for your project are not necessarily worth archiving long-term, simply because they
are extraneous copies of your original videotapes. Also, backing up to inexpensive formats,
such as DVD-R, can be fairly time consuming. As long as you archive your project file and
you have the original videotapes available to recapture clips from, your project is
sufficiently archived.
• Project files: These are typically quite small, and many versions of a project file can be
archived on a DVD disc, CD-ROM disc, or similar storage media.
• Media files captured from tape or other timecoded sources: These files require a lot of disk
space, so it can be impractical to back them up. As long as your tapes have timecode,
you can simply store the original tapes along with the backed-up project file. If you
need to revisit your project later, you can use the timecode information in the clips of
your project file to recapture media from tape.
• Media files without timecode and files created on a computer: Graphics files, such as still
images, and motion graphics that originated on a computer should be permanently
archived on a hard disk, DVD-ROM, or similar storage media. You should also save the
original project files from the applications that you used to create these media files.
For example, if you created a motion graphics logo in Motion, you should back up the
Motion project file, as well as any non-timecoded media files associated with that
project. Non-timecoded video sources, such as video from VHS tape or audio from an
audio CD, should also be backed up, because you can’t accurately recapture this media
later.
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About Updating Projects from Previous Versions of Final Cut Pro
Almost every version of Final Cut Pro has new features that require the project format to
change. The current version of Final Cut Pro can open projects from any previous version.
For more information, see “Choosing Project Update Options.”

Before Updating Projects
Before updating projects from earlier versions of Final Cut Pro and Final Cut Express,
consider these things:
• Third-party effects scripts, or scripts that you’ve already written or customized, may
need to be modified to take full advantage of the use of Y′CBCR color space in
Final Cut Pro.
• All Final Cut Pro effects take advantage of the Y′CBCR color space. If you used any of
the effects listed below in projects created with Final Cut Pro 1.2.5 or earlier, the effects
may look slightly different when you re-create the project’s render files.
• Video Transitions: Map/Luminance Map, Wipe/Gradient Wipe
• Video Filters: Blur/Gaussian Blur, Channel/Invert, Image Control/Brightness and
Contrast, Gamma Correction, Levels, Proc Amp, Sepia, Tint, Key/Blue and Green
Screen, Color Key, Difference Matte
• Video Generators: Matte/Color
• QuickTime transitions and filters do not take advantage of the Y′CBCR color space. They
always render in RGB space.

Keeping a Copy of Your Project in an Older Format
When you open an older project, Final Cut Pro updates the format to the current version.
However, the updated project only exists within the Final Cut Pro application, not on disk,
until you save it. This means you can save a copy of the project in the current version
and still keep the older one on disk.
To keep a backup of your project in its original format
1 In the Finder, choose a project from an earlier version of Final Cut Pro, then choose File
> Duplicate (or press Command-D).
If you want, you can rename both the original or the duplicated project to indicate its
version number. For example, you can add “_v5” to the end of a project file associated
with Final Cut Pro 5.
2 Open the duplicated project in Final Cut Pro, then choose File > Save.
You can open and use projects created with earlier versions of Final Cut Pro and
Final Cut Express, but you need to specify how you want Final Cut Pro to handle the color
space in these files.
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Choosing Project Update Options
If you open an older project file, most necessary updates happen automatically. However,
Final Cut Pro asks you to choose how you want to handle updating for several improved
features such as scaling quality and HD color fidelity.
The table below shows what features were updated in specific versions of Final Cut Pro.
All features that correspond to versions newer than your project must be updated. For
example, if you open a project saved in Final Cut Pro 2, you need to update your project’s
master-affiliate relationships (Final Cut Pro 4), scaling quality, HD color accuracy, and
effects aspect ratio handling (Final Cut Pro 6). However, because a Final Cut Pro 2 project
is newer than Final Cut Pro 1.2.5, DV color accuracy is not updated.
Final Cut Pro version

Updated features

Final Cut Pro 6

Nonmatching sequence clip aspect ratios: Render files for any
sequence containing clips whose aspect ratio does not match the
sequence aspect ratio are deleted. Shift Fields filters: Incorrectly
applied or missing Shift Fields filters are updated.

Final Cut Pro 5,
Final Cut Express HD 3.5.1

Scaling quality: Best, Normal, Fastest HD color accuracy: Any HD
render files and HD sequence settings are converted to Rec. 709
color space.

Final Cut Pro 4,
Final Cut Express 2

Master-affiliate relationships: Master-affiliate clip relationships aren’t
directly updated when you open a project, but they can be applied
at any time after you update a project.

Final Cut Pro 1.2.5

DV color accuracy: Any DV render files and DV sequence settings
are converted to DV super-white levels (instead of RGB).

To update projects created in earlier versions of Final Cut Pro
1 Open a project created using an earlier version of Final Cut Pro. A message tells you that
the file’s format is outdated and asks if you want to update the format. Click Yes.

Click here to update
your project.

2 If a dialog appears with choices for update, choose from the options appropriate for the
Final Cut Pro version that you’re updating from. For information about particular versions,
see the sections listed below:
• “Updating Projects from Final Cut Pro 5 or Earlier”
• “Updating Projects from Final Cut Pro HD (version 4.5) or Earlier”
• “Updating Projects from Final Cut Pro 3.0 or Earlier”
• “Updating Projects from Final Cut Pro 1.2.1”
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Updating Projects from Final Cut Pro 5 or Earlier
Here are some things to keep in mind when updating projects created with Final Cut Pro 5
or earlier versions.
Nonmatching Sequence Clip Aspect Ratios
When you open projects created in Final Cut Pro 5 or earlier, Final Cut Pro deletes existing
render files for a sequence when the following are true:
• Your project contains a sequence whose clips have a different aspect ratio than the
sequence aspect ratio.
• The sequence clips with nonmatching aspect ratios have a filter applied that affects
the clip aspect ratio.
You can choose to delete the render files and continue to update your project or cancel
the project update, preserving your existing render files. Deleting render files cannot be
undone.
Shift Fields Filter
Projects created in versions earlier than Final Cut Pro 6 must be updated when they
contain incorrect or missing applications of the Shift Fields filter. For example, if you have
a Final Cut Pro 5 project where you edited a DV PAL clip into a standard definition (SD)
PAL sequence, Final Cut Pro 5 did not use the Shift Fields filter for combining DV and SD,
so Final Cut Pro 7 must update your project to add Shift Fields filters to clips when
necessary.
Note: In cases where you removed a Shift Fields filter from an earlier Final Cut Pro project,
Final Cut Pro 7 adds a new Shift Fields filter to any clip that needs one for proper playback.

Updating Projects from Final Cut Pro HD (version 4.5) or Earlier
Here are some things to keep in mind when updating projects created with Final Cut Pro
HD (version 4.5) or earlier versions.
Scaling Quality
Projects created in Final Cut Pro HD (version 4.5) and earlier used the Fastest option. If
you want higher quality motion transformations, you can choose Normal or Best. You
can change this setting later in the Video Processing tab of each sequence in your project.
For more information, see “Rendering and Video Processing Settings.”
Removing Existing Render Files
You have the option to delete render files when your motion transformations are updated.
If you change the quality, it is a good idea to remove the existing render files to prevent
mismatched scaling qualities in your sequences. Deleting the render files cannot be
undone.

1506

Chapter 88 Backing Up and Restoring Projects

Improved Color Accuracy When Rendering High Definition Sequences
If you open an old project containing any rendered high definition sequences, or if you
have any SD sequences containing HD source media, a dialog asks if you want to open
the project and permanently delete the existing render files. If you want to preserve the
existing render files, do not open the project in Final Cut Pro. Deleting the render files
cannot be undone.
Note: If your project only refers to SD footage (ITU-R BT. 601), this dialog does not appear.

Updating Projects from Final Cut Pro 3.0 or Earlier
Clips in projects created with Final Cut Pro 4 and later have master-affiliate clip relationships
that did not exist in earlier versions of Final Cut Pro. When an older project is imported
into Final Cut Pro, this relationship is not automatically created, but you can manually
update your project so that every sequence clip becomes affiliated with an appropriate
master clip in the Browser. For more information about creating master clips, see “About
Using Master and Affiliate Clips.”

µ

To create master-affiliate relationships for clips in an older project
After you open and update the project, choose Tools > Create Master Clips.
Master clips are created for every clip in every sequence, and placed in a bin called Master
Clips for [Project Name]. When multiple clips refer to the same media file, only one master
clip is created for those clips.

Updating Projects from Final Cut Pro 1.2.1
In Final Cut Pro 1.2.1 and earlier, sequences using the Apple DV-NTSC and DV-PAL codecs
converted Y′CBCR video to RGB video whenever rendering was required. The conversion
sometimes resulted in subtle but noticeable shifts in color or intensity. Starting with
version 1.2.5, Final Cut Pro handled color space differently; however, old projects may
still have links to older render files that exhibit the color and intensity shifts.
If you open an old project containing any rendered DV-NTSC or PAL sequences, a dialog
asks if you want to open the project and permanently delete the existing render files:
• Update sequences for improved color fidelity: This sets the maximum white value to
Super-White in the Video Processing tab of the Sequence Settings and Sequence Preset
Editor windows. All future rendering in the sequence is done in Y′CBCR in super-white.
Note: If you select this option, the “Always Render in RGB” option in the Sequence
Settings or Sequence Preset Editor window is not selected. For more information, see
“Rendering and Video Processing Settings.”
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• Remove existing render files: This deletes all render files on the scratch disk for the
sequences in this project. If you keep existing render files, the rendered media may
have color or intensity shifts. You should keep existing render files if the quality
difference is not a problem for your projects or if you need to get a project done fast
and don’t want to rerender files. If you keep existing render files and want
consistent-looking media, you’ll have to rerender the files because sequences in
previously rendered media may have color or intensity shifts.
Note: You cannot restore deleted render files with the Undo command.
Choosing these options will not rerender any material immediately. You need to open
any affected sequences and render them manually.
If you upgrade a project or sequence created in Final Cut Pro 1.2.1 and the codec used
for the sequence is not found by the system, the codec in the Sequence Settings is listed
as “Unknown” and “Always Render in RGB” is selected in the Video Processing tab. If you
want to render the sequence in Y′CBCR (YUV) color space, you need to change this
manually.
To select YUV processing in a sequence with an unknown codec
1 Choose Sequence > Settings, then click the General tab.
2 In the QuickTime Video Settings section, choose DV-NTSC or DV-PAL (whichever you are
using) from the compressor pop-up menu.
3 Click the Video Processing tab, then select the YUV rendering option you want to use for
your sequence.
Unless you are doing high-end video processing, you will probably want to select Render
in 8-bit YUV.
For more information about rendering in RGB and Y′CBCR color spaces, see “Rendering
and Video Processing Settings.”
Note: These options are available for codecs that support Y′CBCR color space.
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This chapter covers the following:
• About Clips, Media Files, and Sequences (p. 1509)
• About Icons and Project Elements in the Browser (p. 1513)
• Clip Properties (p. 1514)
When you are organizing your project and media files, it can be helpful to have a detailed
understanding of each element in a Final Cut Pro project, such as clip types and properties,
bins, sequences, and so on.

About Clips, Media Files, and Sequences
Understanding the details of Final Cut Pro project elements can help you transfer clip
and project information in and out of Final Cut Pro during logging, capturing, media
management, and project interchange.

Media Files
A QuickTime media file contains a number of tracks, typically one video track and one or
more audio tracks. When you capture or import a media file into Final Cut Pro, a clip in
the Browser is created which refers to the media file on disk. A clip has one or more clip
items, each of which corresponds to a track in the QuickTime media file. When you open
a Browser clip in the Viewer, each of these tracks appears as a separate tab, such as video,
audio channel 1, channel 2, and so on. Clips that refer exclusively to audio files are called
audio clips, and they are identified by a unique icon in the Browser.
Other common media file types you can use in Final Cut Pro are AIFF and WAVE files (for
audio) and graphics file formats supported by QuickTime, such as JPEG, Photoshop, and
TIFF.
Important: Media files are not clips, so you should avoid referring to your media files on
your scratch disk as clips.
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Types of Clips
Different types of clips are distinguished by the type of media files they refer to. For
example, an audio clip is simply a clip that represents an audio-only file on disk. However,
some clips, such as subclips, are distinguished not by the type of media files they refer
to, but how they refer to them. For example, the definition of a subclip is any clip that
refers to less than the total length of a media file. It doesn’t matter whether a subclip is
a video clip, audio clip, or merged clip.
Here is a list of clip types available in Final Cut Pro:
• Clip: Usually refers to a video file that may also include audio.
• Audio clip: Refers to an audio file. This may be a QuickTime media file that only contains
audio tracks, or an audio-only file such as an AIFF or WAVE file.
• Still-image clip: Refers to a single frame of a media file, created using the Make Freeze
Frame command in the Modify menu.
• Graphics clip: Refers to a graphics file, such as a JPEG, Photoshop (flattened), or TIFF
file.
• Generator clip: Refers to a Final Cut Pro generator, which creates media such as shapes,
colors, and bars and tone automatically. Generators do not have associated media files.
• Subclip: Refers to a portion of a media file.
• Subclip Parent: A clip from which a subclip has been made. Final Cut Pro provides
commands that allow you to quickly view the subclip parent of a clip in a sequence.
For more information, see “Creating Subclips.”
• Merged clip: Refers to a video file and one or more audio files.
• Multiclip: Groups multiple clips together as angles for real-time switching and cutting.
A subclip artificially limits the duration of a clip, to allow you to work with smaller sections
of a media file. These subclip limits can be removed at any time so you can work with
the whole clip. For example, if an original media file is ten minutes long, the Final Cut Pro
Browser clip is also ten minutes long. You can make a one-minute subclip starting at
00:02:00:00 and ending at 00:03:00:00 and work with the subclip as if the media file were
only one minute long.
A merged clip refers to more than one media file at once: one video file and multiple audio
files (up to 24 separate audio files). You can create merged clips if you record picture and
sound to separate devices during production, and therefore have separate video and
audio media files that actually comprise a single clip. You make a merged clip by selecting
a video clip and several audio clips together and choosing the Merge Clips command
from the Modify menu.
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Important: A merged clip is considered offline even if only one of its media files cannot
be found. Reconnecting and recapturing merged clips may take several passes, one for
each file.
A multiclip allows you to sync multiple clips together as angles within a single clip. The
main reason to use a multiclip is to sync multiple camera angles together so you can cut
between them in real time in the Timeline. However, you can sync any footage you want
together in a multiclip, not just different camera angles. For instance, when making a
music video, you could sync three different performances of the band playing and cut
between them on the beat.

Clips Described by Their Properties
In addition to the clip types described above, clips can be further characterized by the
following:
• Relationships to other clips: Master, affiliate, and independent clips
• Connection status to media files: Offline and online clips
• Location in a project: Browser and sequence clips
These clip characteristics can describe any type of clip. For example, clips, subclips, merged
clips, and multiclips can all be offline clips.
Clips Defined by Their Relationship to Other Clips
A master clip is the first instance of a clip imported or captured in Final Cut Pro. Master
clips exist exclusively in the Browser, and they are used to manage multiple instances of
the same footage used throughout your project. This is how it works: each time you edit
a clip into a sequence, Final Cut Pro creates a new instance of that clip. This new sequence
clip is not completely unique and self-sufficient, but actually gets most of its properties
from the master clip it came from. This clip is called an affiliate clip because it shares
properties with its master clip. Because master and affiliate clips share a single set of
properties, changing a property in one place changes it everywhere. For instance, if you
want to change a clip name, it doesn’t matter whether you change the name in the master
clip or any of its affiliate clips. Since they all share the same Name property, all the clips
now have the new name.
Most properties are shared between master and affiliate clips, but there are a few
exceptions. The properties of affiliate clips that aren’t shared (such as In and Out points)
make them useful for editing, while the shared properties (such as Name and Source)
maintain a relationship with the master clip for easier media management. For example,
In and Out points can be different in every affiliate clip so that trimming one clip doesn’t
affect the duration of all the other affiliated ones.
The following properties are not shared between master and affiliate clips:
• Comment A-B
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• In point
• Out point
• Duration
• Description
• Film Safe
• Composite mode
• Reverse Alpha
• Thumbnail
An independent clip is a sequence clip that has no master clip, so it doesn’t share properties
with any other clips. You can make a sequence clip independent at any time, although
you usually shouldn’t unless you have a specific reason to do so. Independent clips are
not updated by a master clip, so you can’t manage your media as efficiently.
Clips Defined by Media File Connection
An offline clip is any clip whose media file cannot be located, or whose Source property
is empty. When you first log clips, they are offline clips because they have no associated
media files. If the modification date of a clip’s media file changes in the Finder, or if you
delete a clip’s media file, the clip becomes an offline clip until you reconnect it.
Clips Defined by Location in Project
A Browser clip is any clip which appears in the Browser. These are typically master clips,
although they can also be affiliate clips.
A sequence clip is one or more clip items in a sequence. These are typically affiliate clips
whose master clips reside in the Browser. In some cases, sequence clips are independent,
meaning they have no master clips or other affiliated clips. You can distinguish a sequence
clip from a Browser clip when you open it in the Viewer. The row of dots (sprocket holes)
that appears in the scrubber bar of the Viewer indicates that the clip is a sequence clip.

Sequences
A sequence contains one or more video and audio tracks, which are empty when first
created. When you edit a clip into a sequence, you copy the clip’s individual clip items to
tracks in the sequence. For example, if you drag a clip that contains one video and two
audio clip items to the Timeline, a video clip item is placed in a video track in the Timeline,
and two audio clip items are placed in two audio tracks. In a sequence, you can move
any clip item to any track, allowing you to edit and arrange the contents of your media
files however you want. Clip items in a sequence (sometimes referred to as sequence clips)
are usually affiliate clips, and are often distinguished from clips in the Browser (Browser
clips), which are usually master clips.
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About Icons and Project Elements in the Browser
Icons appear next to the name of each project element in the Browser. The following
table explains what kind of Final Cut Pro project elements each icon represents.
Icon

Name

Description

Clip

A clip represents a media file. A clip is created
when a media file is captured or imported into
Final Cut Pro. This icon is also used for merged
clips (clips created by merging audio and video
clip items together).

Audio clip

A clip that refers to an audio media file such as an
AIFF, WAVE, or a QuickTime media file that
contains only audio tracks.

Multiclip

A clip that contains multiple clips grouped
together as angles. You can switch and cut
between each angle in real time.

Offline clip

A clip whose media file cannot be located on disk,
or whose media file has not yet been captured.

Subclip

A kind of clip that refers only to a portion of a
media file instead of the whole thing. Subclips
conveniently create the illusion that your media
file is shorter than it really is, so you can work with
a shorter portion of your media file. You can
remove these artificial media start and end point
limits from your subclip at any time, at which point
the subclip is simply considered a clip again,
because it refers to the entire length of the media
file.

Marker

An object that represents a single frame, or a
duration of time, in a clip (or sequence). Markers
can be used as reminders and notes in your clips
and sequences. For example, you can mark
sections that need color correction, potential edit
points, important moments of action in a scene,
beats of music, and so on. Because markers simply
denote portions of a clip (instead of the whole
clip), they can easily be converted into subclips.
Markers are shown hierarchically within the clip
they belong to.

Still Image or Freeze
Frame

A clip that refers to a graphic media file on disk,
or to a single frame in a video media file.

Video generator

A clip that generates its appearance without a
media file, used for commonly needed movie
elements such as slug (solid black), color mattes,
gradients, and titles.

Template clip

A clip connected to a Motion template file that
has custom parameters such as text and clip wells.
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Icon

Name

Description

Sequence

A container for clips edited together in
chronological order.

Bin

A container, similar to a folder, used to organize
clips, sequences, and even other bins.

Bin opened in its own
window

A bin that’s been opened as a window separate
from its project.

Locked bin

The contents of a locked bin cannot be changed.
In Final Cut Pro, the only locked bins are the ones
in the Effects tab, which contain the installed
effects. The one exception in the Effects tab is the
Favorites bin, which is not locked so you can store
your favorite effects and transitions there.

Video filter

Effects filter that can be applied to a video clip.

Video transition

Transition effect that can be applied between two
consecutive clips in a video track.

Audio filter

Effects filter that can be applied to an audio clip.

Audio transition

Transition effect that can be applied between two
consecutive clips in an audio track.

Clip Properties
A clip has many properties, or characteristics, some of which you can customize, and
some of which are automatically inherited from the media file that a clip references. Some
properties may be left blank while others are always defined. Some properties, such as
comments, log notes, and labels, are stored only within the clip object that resides in
your Final Cut Pro project file. Other properties, such as the frame dimensions and data
rate, reside in the media file itself, since they describe characteristics inherent to the
media.
Clips imported from Cinema Tools have additional film properties used for matching your
clips back to original film negatives. These properties can only be modified in the
Cinema Tools database that they refer to. For more information, see the documentation
that came with Cinema Tools.
You can view and modify clip properties in the following locations:
• Browser columns
• Item Properties dialog (choose Edit > Item Properties)
• Modify Timecode dialog (choose Modify > Timecode)
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Name of property

Description

Name

Name of the clip.
During logging, the name property is usually created automatically
from a combination of the Description, Scene, Shot/Take, and Angle
properties, which are entered in the Log and Capture window.
You can change a clip’s name in the Browser or Item Properties
window at any time. However, changing the name of a clip doesn’t
change the name of the clip’s media file on the hard disk, so be
careful when doing this as it may complicate media management
later on in your project.

Alpha

Shows how a clip’s alpha channel is handled—None/Ignore, Straight,
Black, or White. Graphics or animation files created outside
Final Cut Pro may have an alpha channel. Although Final Cut Pro
usually discerns the correct alpha channel type when you import
media files, you can change the type if necessary.

Anamorphic

A checkmark in this property indicates that the media file’s pixel
data was intended to be displayed, anamorphically (stretched wide).
You can set this property to force a clip with a 4:3 aspect ratio to
be widescreen 16:9.
For clips, this property is originally based on the capture preset
used; for sequences, it’s based on the sequence settings. You can
change this property at any time.
When you reconnect a clip to a media file, the Anamorphic property
in the media file overrides the clip property. However, if you
manually change the clip property, reconnecting to a new media
file no longer updates this property.

Angle

The camera angle number (or letter) of a clip from a multicamera
shoot. When ordering clips during multiclip creation, Final Cut Pro
uses the value in this property when available.

Aud Format

The bit depth of each audio sample (typically 16- or 24-bit integer).

Aud Rate

The audio sample rate of a sequence or a clip’s media file.

Audio

Indicates the number of mono and stereo audio clip items for a clip
and its corresponding media file. To change this property, the clip
must be offline and you must use the Clip Settings command in
the Modify menu.
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Name of property

Description

Aux TC 1-2

Aux 1 and Aux 2 are additional timecode tracks that can be created
in a QuickTime media file for any clip in your project. These
properties can be useful for synchronizing clips to related media
files without altering the source timecode of your files. For example,
when synchronizing video clips captured from Digital Betacam with
audio clips captured from DAT, the source timecode of each clip
reflects timecode that was captured from each tape. You can create
an Aux timecode track for your audio clips to reflect the source
timecode of the corresponding video clips. By using an Aux
timecode track, you don’t affect the original source timecode, which
is important if you ever need to recapture your clips from tape.
Changes made to the Aux TC 1 and 2 tracks are written to the
timecode tracks in the media file on disk. For offline clips, these
properties can be modified in the Browser or Item Properties dialog.
However, when clips are connected to media files, you can only
add, delete, or modify Aux timecode using the Modify Timecode
command.

Capture

Displays the capture state of a clip in the Batch Capture queue: Not
Yet, OK (captured already), Queued, or Aborted.

Comment A-B

Comment information that is not shared across each master and
affiliate clip (as opposed to Master Comments 1–4, which are stored
in the master clip and shared with all affiliates).

Composite

Shows the composite mode of a clip, such as Normal, Add, or Travel
Matte. This controls how the pixel values in a clip combine with the
pixel values in clips in underlying video layers, or how the clip
visually interacts with the clip on the track immediately below it.
For more information on composite modes, see “Compositing and
Layering.”

Compressor

Displays the codec used to compress a clip’s media file. For clips,
this property is based on the content stored in the clip’s media file;
for sequences, it’s based on the codec specified in the sequence’s
compressor setting.
Different codecs have different ways of compressing video and
audio clips to reduce storage requirements. When a clip is edited
into a sequence, the clip’s media file must use the same codec as
the sequence; otherwise Final Cut Pro must convert from the media
file codec to the sequence codec, which usually is so
processor-intensive that it requires rendering.

Creator

Shows the name of the application that created the clip’s media
file.

Data Rate

Shows how much data a clip’s media file requires per second of
playback. This value is displayed in megabytes per second. The data
rate of a media file is determined by its video frame rate, dimensions,
compressor, color sampling method, and audio sample rate and bit
depth. Generally, the higher the data rate, the higher the quality of
the media file. If the data rate of a clip’s media file exceeds the
capabilities of your hard disk, Final Cut Pro warns you if frames are
being dropped during playback.
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Name of property

Description

Description

Displays descriptive text about a clip (from the Description field in
the Logging tab of the Log and Capture window). This is typically
entered when logging, but you can also add to it or change it in
the Browser or Item Properties window.

Duration

Shows the duration between a clip’s In and Out points. Speed
adjustments to a clip affect a clip’s duration.

Field Dominance

For interlaced video, controls whether field 1 or field 2 is played
first. When you reconnect a clip to a media file, the Field Dominance
property in the media file overrides the clip property. However, if
you manually change the clip property, reconnecting to a new
media file no longer updates this property.

Film Safe

Intended for telecined clips being used in a program that will be
matched back to a film negative. When a clip is marked film safe,
the Media Manager trims on four or five frame boundaries
(according to the timecode) to ensure that full film frames are
preserved during the negative cut.

Frame Size

Displays the video image dimensions in pixels. For clips, this property
is based on the dimensions of the clip’s media file or capture preset
selected during logging. For sequences, frame size is based on the
sequence settings (or sequence preset chosen).

Gamma Level

Determines the gamma correction applied to still-image clips when
they are placed in sequences. Video and audio files are not affected
by this property.

Good

Identifies clips that are marked Good (indicating shots you want to
use) in the Logging tab of the Log and Capture window. Clips are
typically marked Good during logging, but you can also mark a clip
in the Browser or Item Properties window.

In

Timecode of the In point of a clip. The In point specifies the
beginning of a section of a clip or sequence used in editing.

Label

You can assign labels to clips, bins, and sequences to categorize
them. Each label has an associated color, so clips, bins, and
sequences with labels are colored by their assigned label color.
Items in the Browser actually have two label properties: Label
(described here) and Label 2. Only the Label property described
here influences the color of an item.

Label 2

You can assign a second label to clips, bins, and sequences to further
categorize them. The Label 2 property does not have an associated
color, but it does have the advantage that it is completely
customizable. You can type any text you want in the Label 2 field
of a clip, bin, or sequence. If you Control-click on the Label 2 field,
a summary of every unique Label 2 text in your project appears
here, allowing you to conveniently and consistently assign text to
a clip’s Label 2 property.
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Name of property

Description

Last Modified

Indicates the date and time a clip’s media file was modified, or the
last time a sequence was edited. In the case of clips, this information
is read directly from the modification date property of the clip’s
media file, so you can also see this information in the Finder by
selecting the file and then choosing File > Get Info.

Length

Shows the total length of a clip, regardless of clip In and Out points.
This is different from the duration of a clip, which is the number of
frames between a clip’s In and Out points. In most instances, clip
length is the same as its media file length, but there are some cases
where this is not true. For example, a still-image clip refers to a
media file with a single frame, but the clip length has a default
duration of 2 minutes. Speed adjustments to a clip affect a clip’s
length.

Log Note

This field is used for notes about your footage made during logging.
This text can be entered from the Logging tab of the Log and
Capture window, but you can also add to it or change it in the
Browser or Item Properties window.

Master

This property is checked if a clip is a master clip. You cannot modify
this property.

Master Comment 1-4

Comments can be added to clips, bins, or sequences at any time.
The Master comments are stored in a master clip and shared among
all its affiliates, so changing this property in any of the affiliated clips
updates all of them simultaneously. The name of each Master
comment can be customized to represent a particular property. For
example, you can rename “Master Comments 1” to “Director’s Notes”
or “Color Correction Status.” Custom Master Comment names are
stored on a per project basis. You can change the Master comments
text in the Browser columns or Item Properties window.
To customize Master Comment names, do one of the following:
• Choose Edit > Project Properties.
• Control-click a Master Comment heading in the Browser and
choose Edit Heading from the shortcut menu.
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Media Start

The timecode address that refers to the first frame of the media file,
and thus the first frame captured from a source tape. This timecode
value is different than the In point of the clip. Media properties are
based on the media file, while In and Out points are adjustable
points used for the purposes of editing clips into the Timeline. The
Media Start and End properties can only be changed in Final Cut Pro
if a clip is offline and the file path in the clip’s Source property is
empty. If a clip’s Source property has a file path, you cannot modify
the Media Start or End properties.

Media End

The timecode address that refers to the last frame of the media file,
and thus the Out point set during capturing from tape in the Log
and Capture window. This timecode value represents the very last
frame of a clip’s media file, not the Out point of the clip.
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Name of property

Description

Offline

A checkmark indicates a clip is offline, meaning no media file exists
in the location of the clip’s Source file path, or the clip’s Source file
path is empty. A clip is offline if its media file can’t be located, or if
media has not yet been captured for the clip (thus the clip does not
yet have a file path to point to a media file on disk).

Out

Timecode of the Out point for a clip. The Out point specifies the
end of a section of a clip or sequence used in editing.

Pixel Aspect

Displays the pixel aspect ratio of a clip’s media file. Computer
graphics formats use square pixels, while many SD and HD video
formats use non-square pixel aspect ratios, such as:
• Standard definition (SD) NTSC
• Standard definition (SD) PAL
• HDV and DVCPRO HD
When you reconnect a clip to a media file, the Pixel Aspect property
in the media file overrides the clip property. However, if you
manually change the clip property, reconnecting to a new media
file no longer updates this property.

Reel

Identifies the reel (tape) name a media file was captured from. This
is typically entered when logging in the Log and Capture window,
but you can also change it in the Browser or Item Properties window.
Because the reel property is stored in the media file, changing this
property from within Final Cut Pro modifies this value in the media
file.

Reverse Alpha

This property can be changed to Yes or No, but only has an effect
if a clip’s media file actually contains an alpha channel. Selecting
Yes displays a checkmark, indicating the alpha channel is inverted.
This is evident when layering this clip on top of others in a sequence
or when viewed independently in the Viewer. Final Cut Pro interprets
black alpha channel values as transparent and white values as
opaque. The Reverse Alpha property is not shared among affiliated
clips, so each clip has its own individual Reverse Alpha property.

Scene

This property is used to identify the scene number of a clip. You
can enter this when logging a tape in the Log and Capture window
or in the Browser or Item Properties window.

Shot/Take

This property is used to identify the shot or take number of a clip.
You can enter this when logging a tape in the Log and Capture
window or in the Browser or Item Properties window.

Size

Shows the clip’s media file size on the hard disk in megabytes (MB).
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Name of property

Description

Source

Shows the file path of the clip’s media file on disk. For example:
Scratch Disk:Capture Scratch:Dining:Interview Clip.mov. This property
is the critical connection between a clip and its media file. If a media
file changes location or name, or if its modification date changes,
the clip will no longer be able to locate it based on its Source
property’s file path, causing the clip to become offline. A clip’s
Source property may contain a file path (even if the file cannot be
located) or it may be empty (as is the case with a newly logged clip
or a clip made offline using the Make Offline command). For more
information, see “Reconnecting Clips and Offline Media.”

SmoothCam

Shows the current status of SmoothCam motion analysis.

TC

Displays which timecode track in the media file is currently being
used to display timecode for the clip in the Browser, Item Properties
window, the timecode fields of the Viewer, and the timecode
overlays in the Viewer and Canvas. For example, if a media file has
three timecode tracks, the choices would be:
• Source
• Aux 1
• Aux 2
“Source” merely indicates the primary timecode track of the media
file, and is almost always the timecode from the original source
tapes. Since most media files have only one timecode track, “Source”
is often the other choice. However, if you have added an auxiliary
timecode track to a media file (for example, with the Modify
Timecode command), you can choose to view the timecode values
stored in this track instead. You can adjust the TC value in the
Browser, Item Properties window, or by Control-clicking in the
Timecode Duration or Current Timecode field.
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Thumbnail

Displays a small, representative frame from the clip’s media file. By
default, the thumbnail is the first frame of the clip, but you can drag
to “scrub” through the clip to choose a more appropriate
representative frame, known as a poster frame. For more information,
see “Browser Basics.”

Tracks

The total number of video and audio tracks in a clip or sequence.

Type

Type of clip: Clip, subclip, multiclip, still. Also: Sequence, bin, or
effect.

Vid Rate

Shows the frame rate (timebase) in frames per second (fps). For
clips, this property is the frame rate of the media file on disk. For
sequences, the frame rate is set in the sequence’s editing timebase
field. If a sequence contains clips, the sequence’s frame rate (editing
timebase) cannot be changed (unless all clips are first removed).
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This chapter covers the following:
• About Using Master and Affiliate Clips (p. 1521)
• Shared and Unique Clip Properties (p. 1522)
• Working with Master Clips (p. 1525)
• Working with Affiliate Clips (p. 1527)
• Creating Independent Clips (p. 1528)
• Changing Independent Clips to Affiliate Clips (p. 1529)
• Modifying Master-Affiliate Clip Relationships (p. 1530)
• Moving Clips Between Projects (p. 1531)
• How Does Final Cut Pro Identify Matching Clips? (p. 1531)
• Resolving Property Differences Between Matching Clips (p. 1532)
Master-affiliate clip relationships make it easy to manage multiple uses of media files in
your project.

About Using Master and Affiliate Clips
As you edit, you may generate many copies of the same clip. For example, you may use
different segments of the same clip multiple times in one sequence. Or, if you make
multiple versions of a sequence, each sequence may contain a copy of the same clip, but
the duration of each clip may be different.
All of these clip copies refer to the same media file on disk. When it’s time to recapture,
consolidate your media, or move your footage to another system, reducing the number
of clips you need to manage can save a lot of time and disk space.
For example: You have finished editing your project and now you want to recapture the
media files for your sequence clips at high resolution. If you used the same clip many
times in your sequence, it would be a waste of time and disk space to capture the same
media file over and over for each clip copy.
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To simplify media management, Final Cut Pro uses a single master clip to control multiple
copies of a clip. The primary purpose of a master clip is to manage the relationship
between multiple copies of a clip and a single media file. The first time you import or
capture a media file, a master clip is created. Subsequently, each copy of the master clip
that you create is called an affiliate clip.
Master-affiliate clip relationships help you to:
• Keep track of which clips in your project use the same media
• Perform media management operations on one, some, or all affiliated clips
• Trace your steps from an affiliate clip in a sequence back to the unmodified master clip
Note: If you need to, you can break the relationship between affiliate clips and master
clips, turning the affiliate clips into independent clips. You generally don’t want to do this
because then you lose the benefit of a single master clip controlling all the others. There
are a few cases where independent clips can be useful, but it’s best to avoid them unless
you have a special reason.

Shared and Unique Clip Properties
All clips have properties such as Name, In point, Out point, Duration, comments, and so
on. Master clips are the objects in your project that store clip properties; affiliate clips
then refer to the properties stored in their master clip. In other words, an affiliate clip
stores very little unique information about itself and instead refers to its master clip for
almost all properties.
Master clip
Shared properties
Name and Scene
are examples of
properties stored
in the master clip
and shared with
affiliate clips.

Unique properties
In and Out points
are unique to each
master and
affiliate clip.
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Affiliate clips

Name: Apple

Name: Apple

Name: Apple

Scene: 2

Scene: 2

Scene: 2

In: 01:00:04:00

In: 01:30:22:04

In: 01:31:24:00

Out: 01:00:08:00

Out: 01:30:29:08

Out: 01:31:30:00
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For example, if you import a QuickTime movie file named Apple into Final Cut Pro, a
master clip named Apple is created in your project. Each time you edit the master clip
into a sequence, an affiliate clip is placed in the sequence and its name is also Apple.
The affiliate clip doesn’t actually store a name, but instead refers to the Name property
stored in the master clip. You can test this by changing the name of the master clip to
Orange. The names of all of the affiliate clips update simultaneously.
Because there is only one Name property shared between a master clip and its affiliates,
you can change this property either from the master clip or from any of the affiliate clips.
Regardless of where you change the Name property, all of the affiliate clips reflect the
change simultaneously.
Although master clips share most clip properties with their affiliate clips, there are a few
properties that affiliate clips do not share. Most of these properties are for editing,
trimming, or compositing. For example, each affiliate clip has its own In and Out points
so it can have a unique duration in a sequence while still referring to the same media file
via its master clip.
For more information about modifying clip properties in the Browser columns or in the
Item Properties window, see “Working with Projects, Clips, and Sequences.”

Shared Properties Stored in Master Clips
The following clip properties are stored in a master clip, and these are shared between
the master and all its affiliate clips. If you change one of these properties, it changes in
all affiliate clips.
• Source
• Name
• Offline Status
• Capture Status
• Scene
• Shot/Take
• Log Note
• Master Comments 1-4
• Label
• Label 2
• Good
• Anamorphic
• SmoothCam
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Note: Several properties stored directly in a clip’s media file are also considered to be
shared properties. For details, see “Modifiable Media File Properties.”

Media File Properties
Some clip properties are derived from the media file itself. Master clips refer to these
properties directly from the media file. Final Cut Pro caches some of the media file
information in clips in case the media file is disconnected. Affiliate clips refer to these
properties via the master clip, so they are also considered to be shared properties. Most
media file properties can only be modified in the media file, or by recapturing with
different capture settings.
• Frame Size
• Compressor
• Data Rate
• Vid Rate
• Alpha
• Aud Format
• Aud Rate
• Last Modified
• Size

Modifiable Media File Properties
The following properties are stored directly in a media file but, unlike other media file
properties, they can be modified via the clip. When you change one of these properties
in a clip, the clip’s media file is modified.
• Reel
• Media Start
• Media End
• Aux 1-2 Reel
• Aux TC 1-2
• TC
Because these properties are stored directly in your media files, you don’t risk losing vital
logging and capturing information if you delete clips in your project.
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Unique Clip Properties
The following clip properties are unique to each affiliate clip and unique to the master
clip as well. These properties are not shared. Most of these properties are properties for
editing and trimming, such as In and Out points, so that each affiliate clip can have a
unique duration in a sequence while still referring to the same media file via its master
clip.
• Comment A-B
• In point
• Out point
• Duration
• Description
• Pixel Aspect Ratio
• Film Safe
• Gamma Level
• Composite mode
• Reverse Alpha
• Thumbnail

Working with Master Clips
A master clip is created automatically when you import or capture a media file in
Final Cut Pro. All subsequent clips created from this master clip are affiliated with that
master clip.
In addition to capturing and importing clips into a project, there are several other ways
to create new master clips:
• Create a new subclip, merged clip, multiclip, or freeze frame clip: When each of these is
created, it is a master clip. When you edit with one of these clips, affiliate clips are
created from the master clip.
In all cases, newly created subclips, merged clips, and freeze frame clips have no
master-affiliate relationship to the original clips used when creating them. For example,
if you drag a group of audio and video clip items from a sequence into the Browser, a
new master merged clip is created. When you create instances of the merged clip as
you edit, affiliate merged clips are created.
• Import an EDL: This creates a sequence of affiliate clips and a bin containing the
sequence clips’ master clips. This makes media management much easier than if all
the sequence clips were independent.
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• Use the Duplicate as New Master Clip command: This allows you to duplicate a master
clip in the Browser as a new, unrelated master clip. The new master clip is unaffiliated
with the original master clip.
Important: If you have several master clips that refer to exactly the same media, make
sure you use only one of them for editing unless you have a reason to use a different
one. Keeping multiple master clips that refer to the same media file can be potentially
confusing during media management, recapturing, and reconnecting.
• Use the Make Master Clip command: This command is available in the Modify menu if
you select an affiliate clip in the Browser. It turns an affiliate clip into its own master
clip.

Implicit and Explicit Master Clips
If you have a sequence that contains a lot of copies of the same clip, all of these clips are
affiliate clips with a single master clip in the Browser. If you delete the master clip in the
Browser, your project still contains the master clip information even though the master
clip can no longer explicitly be seen in the Browser. This means that the affiliate clips still
share their properties, which are stored in the implicit (now invisible) master clip.
You shouldn’t delete master clips without a good reason, but if you do, your affiliate clips
won’t lose their property affiliations. It’s easy to make the master clip explicit by dragging
an affiliate clip from the Timeline to the Browser or by choosing View > Reveal Master
Clip with an affiliate clip selected. When Final Cut Pro does not have an explicit master
clip in the Browser to reveal, it asks if you want to create one.

How Master Clips Connect to Media Files
The connection between a master clip and its media file is the clip property called Source.
A clip refers to a media file via this property, which contains a directory path. A directory
path describes where a file is located within the file and folder hierarchy of the file system.
For example, the hard disk is the top level of the hierarchy, as all files and folders are
contained within the hard disk. The location of one of your media files might be described
like this:
/Volumes/Scratch Disk/Capture Scratch/My Project/My Media File

µ

To find a clip’s media file in the Finder
Select a clip and choose View > Reveal in Finder.

Identifying Master Clips
Master clips can exist only in the Browser; a sequence cannot contain a master clip. The
only way to identify a master clip is to view its Master Clip property, either in the Browser
or in the Item Properties window.
To view a clip’s Master Clip property
1 Select the item.
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2 Choose Edit > Item Properties > Logging Info.
If there’s a checkmark by the Master Clip property, the clip is a master clip.

Creating a Master Clip by Duplicating a Master Clip
You can intentionally duplicate a master clip to create a new, unrelated master clip, which
will then have its own affiliate clips. However, you should do this sparingly because the
main reason for a master clip is to have only one clip per project that represents a media
file on disk.
To create a new master clip by duplicating a master clip
Do one of the following:

µ
µ

Select a master clip in the Browser, then choose Modify > Duplicate as New Master Clip.
Control-click any master clip in the Browser, then choose Duplicate as New Master Clip
from the shortcut menu.
The clip is duplicated, and the new clip is an unrelated master clip.

Finding a Clip’s Master Clip
Using the Reveal Master Clip command, you can identify the master clip of any clip in
your project.
To find a clip’s master clip
1 In the Browser or Timeline, select an affiliate clip. If the Timeline is active but no clip is
selected, the clip at the position of the playhead acts as the selected clip.
2 Choose View > Reveal Master Clip.
The master clip is automatically selected in the Browser, but the way the master clip is
revealed depends on whether the Browser is in column view or icon view.
• If the Browser is in column view: All necessary bins are opened hierarchically via their
disclosure triangles to reveal the highlighted master clip.
• If the Browser is in icon view: The bin containing the clip is opened in its own Browser
window, and the master clip is highlighted.
Note: If the clip’s master clip doesn’t reside in any of the project’s bins, Final Cut Pro asks
if you want to create one. Click OK to create a new master clip. The new master clip is
selected in the Browser.

Working with Affiliate Clips
As you edit in Final Cut Pro, you create affiliate clips in any of the following ways:
• Edit a clip into a sequence: Whenever you edit a clip into a sequence, an affiliate clip is
created from the master clip.
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• Drag a sequence clip to the Browser: Assuming the dragged clip is an affiliate clip and a
master clip already exists in the new Browser, an affiliate clip is created.
• Duplicate a clip: Whenever you copy or duplicate a clip in the Browser or in a sequence,
an affiliate clip is created. (The exception to this is when you use the Duplicate as New
Master Clip command.) An affiliate clip is created when you copy a clip in one of the
following ways:
• Drag a clip from the Browser or Viewer to the Canvas.
• Drag a clip from the Browser or Viewer to the Timeline.
• Option-drag a clip in the Browser or in the Timeline.
• Copy and paste a clip in the Browser or in the Timeline.
Note: Copying an affiliate clip always produces another affiliate clip.
You can have Final Cut Pro display all affiliate clips that share the same master in the
frontmost sequence in the Timeline.
To reveal all the affiliate clips in the Timeline
1 Select the clip in the Browser, Viewer, or Timeline.
2 Choose View > Reveal Affiliated Clips in Front Most Sequence.
To create a master clip from an affiliate clip in the Browser
Do one of the following:

µ
µ

Select an affiliate clip in the Browser, then choose Modify > Make Master Clip.
Control-click an affiliate clip in the Browser, then choose Make Master Clip from the
shortcut menu.
The selected clip becomes a master clip.

µ

To create a master clip from an affiliate or independent clip in the Timeline
Drag the clip from the Timeline into the Browser.
When you drag the clip into the Browser the first time, the master clip is placed in the
Browser. If you drag the clip into the Browser again, copies of the clip are placed in the
Browser.

Creating Independent Clips
You can break the connection between an affiliate clip and its master clip to create an
independent clip. Not only are all of its properties independent, such as name, log notes,
and so on, but the independent clip now refers to its media file directly, instead of by
way of a master clip. Changes to the original master clip no longer have any effect on
the independent clip, and copying an independent clip creates another independent
clip.
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Important: Because breaking the master-affiliate clip relationship can lead to more
complex media management, you should break the relationship only when absolutely
necessary.

µ

To make a sequence clip independent
In the Timeline, Control-click an affiliate clip, then choose Make Independent Clip from
the shortcut menu.
The affiliate clip is now an independent clip. Any changes you make to this clip will not
affect the master clip, and the relationship to this clip’s media file is now managed
independently of other clips in the project.

µ

To make all clips in a sequence independent
In the Browser, select a sequence, then choose Modify > Make Sequence Clips
Independent.

Changing Independent Clips to Affiliate Clips
If you have a sequence of independent clips, you can create new master clips for them
in the Browser. This turns each independent clip into a clip affiliated with its new master
clip. There are several reasons why you may have a sequence of independent clips:
• You imported a project from Final Cut Pro 3 or earlier. In this case, all the clips in your
project are independent.
• You imported a Final Cut Pro XML Interchange Format file without master clip
information.

µ

To create a master clip from an independent clip in a sequence
Drag a clip from the sequence to the Browser to create a copy of it.
The clip in the Browser automatically becomes a master clip, and the sequence clip you
dragged becomes an affiliate of the master clip.

To create new master clips for an entire sequence of independent clips
1 Do one of the following to define the scope of the Create Master Clips operation:
• To create master clips corresponding to every clip in your project: Make sure nothing is
selected in the Browser or the Timeline.
• If you want to limit the creation of master clips to a specific group of clips or
sequences: Select those clips or sequences.
2 Choose Tools > Create Master Clips.
Every independent clip in your project becomes associated with a master clip in one of
two ways:
• If a master clip linked to the same media already exists: Independent clips that are linked
to the same source media on disk become affiliates of these preexisting master clips.
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• If no preexisting master clip matches an independent clip in your project: A new master
clip is created for each independent clip that doesn’t match a preexisting master clip.
All newly created master clips are placed in a new folder named Master clips for [Project
Name].
If independent clips affiliated with master clips have conflicting shared properties, you
are warned. For example, if two independent clips linked to the same source media file
on disk have different names or Master Comment 1 information, a dialog appears giving
you three choices:
• Cancel: Cancels the operation. No changes are made to clip affiliations in your project.
• Continue: Creates a new master clip for each independent clip that has different
properties, so that all existing property information is kept intact.
• Group: Creates a single master clip for all related independent clips. This may cause
some properties of the independent clips to be removed. For example, if one
independent clip has the name Dog and the other is named Cat, after both clips become
affiliated with a single master clip, they share the name of the master clip. If the master
clip is named Dog, both newly affiliated clips are now called Dog as well.

When Can Independent Clips Become Affiliated with Existing Master
Clips?
For an independent clip to become affiliated with a preexisting master clip when using
the Create Master Clips command, the following criteria must be met:
• The master clip must contain all tracks that are used by the independent clip.
• The master clip must contain all of the frames used by the independent clip.
Essentially, all media used by the independent clip must exist in the master clip. However,
it’s perfectly acceptable for a master clip to have more tracks or a longer duration than
an affiliate clip.

Modifying Master-Affiliate Clip Relationships
The master clip command in the Modify menu changes depending on what type of clip
you have selected. For example, if you select a master clip in the Browser, the Modify
menu contains the Duplicate as New Master Clip command.
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Type of selected clip

Modify menu command

Master clip

Duplicate as New Master Clip

Affiliate clip in Browser

Make Master Clip

Affiliate clip in sequence

Make Independent Clip
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Because this is actually one command whose behavior adjusts depending on the type
of clip selected, there is only a single button, called Make/Break Master Clip, to access
this command in the Button List and Keyboard Layout window. To determine the results
of clicking the Make/Break Master Clip button, determine which kind of clip is selected
and use the table above.

Moving Clips Between Projects
For certain workflows, you may need to create multiple projects and move clips between
the projects. In Final Cut Pro, you can move a clip by dragging it from one project tab to
another or by copying and pasting a clip.
When you move or copy a clip from one project (called the source project) to another (the
destination project), Final Cut Pro checks to see if the destination project contains a
matching master clip. There are three possible outcomes:
• Clips do not match: If the destination project doesn’t contain any clips that match the
new clip, the new clip becomes a master clip in the destination project.
• Clips match exactly: If the destination project contains a clip that exactly matches the
new clip, Final Cut Pro adds the new clip and makes it an affiliate of the master that
already exists.
• Clips match but some properties are different: If a clip from the source project matches
a master clip in the destination project but one or more properties conflict, Final Cut Pro
displays the Copy Master Clip dialog and the conflicting properties are highlighted in
red.
For information about resolving property differences between matching clips, see
“Resolving Property Differences Between Matching Clips.”

How Does Final Cut Pro Identify Matching Clips?
Internally, each master clip in a project has a unique number called a universally unique
identifier (UUID). No two clips in a project can have the same UUID. When you drag or
paste a clip from one project to another, the destination project may already contain a
clip with the same UUID as the source project clip. When the source and destination clips
have matching UUIDs, Final Cut Pro detects a match. When both clips’ properties match,
the clips match exactly. When the source and destination clips have one or more
nonmatching properties, you must choose how to resolve the differences.
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Resolving Property Differences Between Matching Clips
Suppose you are editing a project and you send a copy to an assistant editor to work on
a particular sequence. While editing, the editor modifies the Master Comment 1 and Label
properties of several clips in the sequence. When you get the project back, you drag the
newer sequence into your project and Final Cut Pro determines the following:
• The clips in the source (newer) sequence match master clips in the destination (original)
project.
• One or more of the following source and destination clip properties do not match:
• Name
• Good
• Label
• Label 2
• Log Note
• Scene
• Take
• Master Comments 1–4
Final Cut Pro displays the Copy Master Clip dialog to help you resolve the differences
between clip properties.

About the Copy Master Clip Dialog
The Copy Master Clip dialog appears when you move or copy matching clips from one
project to another project and some clip properties are not the same. This dialog contains
three options for resolving matching clips with different properties:
• Use properties from the clip you are adding to the destination project.
• Use properties from the existing clip in the destination project.
• Create a new master clip (and affiliate clips, if necessary) with the properties from the
clip you are adding.
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A fourth option, described below, allows you to apply the option you choose to all clips
added to your project.

Use Properties from the Clip You Are Adding
This option replaces a master clip’s properties in the project with the newly added clip’s
properties, and the two clips become affiliated.
Use Properties from the Existing Clip in This Project
This option ignores the added clip’s properties and leaves the destination master clip’s
properties unchanged. The two clips become affiliated.
Create a New Master Clip
This option creates a new clip in the destination project that contains all the properties
from the added clip. The original clip in the destination project is unchanged and retains
its old clip properties. Both sets of properties from the added clip and the clip in the
destination project now exist in the destination project. This is a good choice when you
want to retain properties, such as comments, from both clips.
Note: A new master clip is always created with this option, but it may not always appear
explicitly in the Browser. For more information, see “Implicit and Explicit Master Clips.”
Apply to All Added Clips with Clip Property Conflicts
If you are moving or copying multiple clips from one project to another, there may be
multiple clips with conflicting properties. To avoid checking this dialog for every occurrence
of matching clips, you can select “Apply to all added clips with clip property conflicts.”
This option handles every master clip conflict automatically using the option you selected
in the Copy Master Clip dialog.
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Using the Copy Master Clip Dialog
The options in the Copy Master Clip dialog determine the relationship between new clips
added to a project and existing clips.
To use the Copy Master Clip Dialog
1 Create two Final Cut Pro projects (in this example the projects are called Source and
Destination).
2 In the Source project, import a media file and name the resulting clip Test.
3 Select the clip and then choose Edit > Copy.
4 Click the Destination project tab, then choose Edit > Paste.
The Source and Destination projects now both contain identical master clips called Test.
5 In the Destination project, rename the clip New Name.
6 While still in the Destination project, choose Edit > Paste again.
Final Cut Pro attempts to paste the original clip, named Test, but finds a similar master
clip whose Name property does not match. The Copy Master Dialog appears.
7 Do one of the following:
• To override the Destination master clip with the pasted clip: Select “The clip you are
adding.”
• To override the pasted Source master clip with the existing Destination clip: Select “The
existing clip in this project”.
• To create a new master clip and maintain its unique properties: Select “Create a new
master clip and any necessary affiliates using properties from the clip you are adding.”
8 If you copied and pasted multiple clips from one project to another, you can also select
“Apply to all added clips with clip property conflicts.”
This option automatically handles all master clip conflicts the same way for the duration
of the operation.
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Offline and Online Editing
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This chapter covers the following:
• About Offline and Online Editing (p. 1535)
• Offline/Online Editing Workflows (p. 1537)
• Using the OfflineRT Format in Final Cut Pro (p. 1539)
• Reingesting Media at Full Quality and Full Resolution (p. 1541)
• Online Editing on Non–Final Cut Pro Editing Systems (p. 1544)
• Trading Project Files Using Email or the Internet (p. 1545)
Final Cut Pro allows you to do offline editing with reduced-quality copies of your media
files, and then reingest your footage at full quality for the final online edit.

About Offline and Online Editing
The offline/online workflow allows you to use temporary, reduced-quality copies of your
footage to edit with, and then finish your project with full-quality media. Reduced-quality
media files require less hard disk space and less computing power to process transitions
and effects. This means you can edit on an inexpensive computer or a portable computer
and then finish at full quality on another system. Once the creative cutting is complete,
the online editing phase (also referred to as the finishing phase) focuses on image quality,
color correction, proper broadcast video levels, and so on.
The two phases—offline and online editing—are connected via an Edit Decision List
(EDL), or other project interchange file, which is used to transfer all of your editing choices
from the finished reduced-quality session to the final high-quality session.

Offline Editing
Editing with reduced-quality copies of your media files allows you to fit more media on
your scratch disks and improve playback and real-time effects performance (especially
when using slower hard disks, such as in portable computers). This phase can last from
a few days to several years, depending on the scope of the project, the amount of footage,
and so on.
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Edit Decision List or Other Project Interchange File
When the edit is complete, you can export all of your edit decisions for use on another
editing system. Older editing systems use a relatively simple text format called an EDL,
while newer interchange formats, such as OMF, AAF, and the Final Cut Pro XML Interchange
Format, describe many more details of your original sequence.

Online Editing
Online editing, now better known as finishing, starts with an offline project file or a project
interchange file, which describes the media you need to reingest at full quality. Online
editing actually has very little to do with editing in the traditional sense. Timing,
storytelling, and fine-tuning your edits should be complete in the offline editing phase.
Online editing focuses on image quality, color correction, maintaining broadcast video
specifications, detailed effects work, titles, audio levels, and so on. Compared to the offline
editing phase, an online edit session goes very quickly (anywhere from a day to a week),
and generally requires more expensive equipment.
Important: It is critical that you maintain accurate timecode, reel names, and file metadata
for keeping track of where footage is located in both tape-based and file-based media.
Make sure you log clips and label tapes and other media carefully so that you can reingest
footage at any quality at a later time.

How Audio Is Handled in the Offline/Online Editing Process
The offline/online workflow tends to focus on video, but how is audio handled? Audio
has much lower data requirements than video, so audio is almost always ingested at its
native sampling rate and bit depth, even for offline editing. This means the audio is ready
for a final audio mix without reingesting.
During the offline editing phase, audio clips are synchronized with video and placed in
the sequence, and basic level adjustments are made. Once editing is finished and the
picture is locked, audio is mixed in the audio mixing and sweetening phase. You can mix
your audio in Final Cut Pro, or transfer your audio files and audio edit decisions to an
audio post-production application.
The audio mixing phase is analogous to the video online edit session: the goal is to
produce a continuous, natural-sounding mix by setting proper levels, setting panning
(locating sounds in different speakers, either for stereo or surround sound), and using
any necessary audio filters. When the audio mix is complete, you bring it to the online
edit session for an audio layback into the finished sequence (or directly onto the finished
master tape). For more information about audio mixing in Final Cut Pro, see “Audio
Fundamentals.”
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To transfer your sequence audio to an audio post-production application, you need to
export two things.
• Audio clip information: In and Out points, location in sequence, and audio levels. Some
people may simply call this an audio Edit Decision List. The audio media itself is not
included.
• Audio media files: These are the actual media files referred to by clips in your sequence.
You can export your audio edit decisions to project interchange formats such as OMF,
AAF, or the Final Cut Pro XML Interchange Format. Some audio applications can also
recognize EDLs.
Audio media files can be exported as AIFF, WAVE, Sound Designer II (SD2), or any other
QuickTime-supported audio file format.
Important: Using the OMF and AAF formats, you can export both sequence information
and media files in a single file. Although this file can be quite large, it can be convenient
to have all the audio data you need in one self-contained file. Both an EDL and a file in
Final Cut Pro XML Interchange Format contain only sequence information, not audio
media. This means that in addition to the project interchange file, you need to transfer
your audio media to the facility doing your mix.
The interchange format you choose depends on which formats your audio application
recognizes. For more information, see “Exporting Audio for Mixing in Other Applications.”

Offline/Online Editing Workflows
The offline/online editing process in Final Cut Pro consists of the following steps:
Stage 1: Setting Up and Ingesting Media at Reduced Quality
You can log and ingest your footage directly to offline-quality media files. Alternatively,
you can log and ingest your footage at full quality, and then use the Media Manager to
create reduced-quality media files for offline editing. The latter method is useful if you
want to have both full-quality and reduced-quality media for two different systems
simultaneously.
Stage 2: Editing with Offline-Quality Media Files
You edit just as you would with any other footage. Because you are using reduced-quality
footage, you can fit much more footage on your hard disk and use a portable computer
editing system.
Stage 3: Creating a Sequence for Reingesting Media at Full Quality
When you finish editing your reduced-quality sequence, you use the Media Manager to
create a copy with full-quality settings. For this step, you choose the Create Offline option
in the Media pop-up menu.
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Important: It is important to understand the difference between clips and media files
when performing this step. This option creates a new sequence with new sequence clips
at full quality, but no new media files are created. Once you have a sequence with
full-quality settings, you can reingest your media files at full quality. Also, the word offline
in the Create Offline option actually refers to creating clips whose media files are offline,
and doesn’t actually relate to the offline/online editing process. For more information,
see “Clips Described by Their Properties.”
You can restrict your new sequence clips so that only the media necessary to create your
finished edit is required, instead of the entire length of the original media files. This saves
time and disk space when you reingest.
If you are doing online editing on a non-Final Cut Pro editing system, you need to export
your sequence to a project interchange format such as an EDL, AAF, or the Final Cut Pro
XML Interchange Format. Third-party plug-ins are available for converting Final Cut Pro
projects directly to other nonlinear editing system formats.
At this stage, you also export your audio to an audio interchange format, such as OMF,
or separate audio files for audio mixing in a separate application.
Stage 4: Reingesting Necessary Media at Full Quality
You open the full-quality sequence on a Final Cut Pro editing system capable of reingesting
and finishing your project at full quality, and then ingest your footage.
Note: Post-production professionals use the term conform to describe Stages 3 and 4. In
other words, you are “conforming” the media to the highest available quality of the source
media.
Stage 5: Adding Final Color Correction, Effects, Transitions, and Titles
Once you have full-quality footage, you can use Color to accurately grade and color correct
and use Motion to add final titles and effects. At the end of this process, you render your
effects in preparation for output. Your final audio mix is created in Final Cut Pro or
Soundtrack Pro, or the audio mix is imported from a separate audio application.
Stage 6: Outputting Your Project
You output or export your final sequence as you would with any other project.
You can output your finished program to videotape or send it to Compressor for
transcoding. You can also use Share to quickly create and deliver output media files in
iPod, iPhone, Apple TV, MobileMe, DVD, Blu-ray Disc, and YouTube formats.
• For more information about outputting to tape, see “Preparing to Output to Tape.”
• For more information about sending to Color, see the Color User Manual, available in
Color Help.
• For more information about Share, see “Using Share.”
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• For more information about sending to Compressor, see the Compressor User Manual,
available in Compressor Help.

Using the OfflineRT Format in Final Cut Pro
The OfflineRT format uses video settings optimized for offline-quality, low-resolution
editing and maximum real-time effects in Final Cut Pro. Final Cut Pro includes two basic
varieties of OfflineRT settings, one for standard definition and one for high definition
formats.
• If you’re capturing NTSC or PAL video: The frame size is 320 x 240 (4:3), the codec used
is Photo JPEG, and the compression quality is 35 percent.
• If you’re using one of the sequence presets to transcode high-definition video: The frame
size is 384 x 216 (16:9), the codec used is Photo JPEG, and the compression quality is
35 percent.
In both cases, the video frames are stored progressively. The frame rate of the OfflineRT
format should always match the frame rate of your original video, or it will be impossible
to accurately reingest your original footage for online editing.
These factors greatly reduce the data rate of the video, although they also lower the
quality. You should use this format only for offline editing, with the intention of reingesting
your video at full quality and full resolution for your online edit.
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About Offline Editing with Apple ProRes
Many of the offline editing techniques described in this chapter also apply to other video
codecs and formats. In particular, the Apple ProRes 422 (Proxy) and Apple ProRes 422 (LT)
codecs provide high-quality video for offline edits of HD and digital cinema formats. For
more information about the Apple ProRes format, see Professional Formats and Workflows,
available in Final Cut Pro Help.
Keep the following points in mind when considering the Apple ProRes format for an
offline edit:
• Offline editing with Apple ProRes is done at the original frame size, frame rate, and
aspect ratio. This is particularly advantageous for projects that involve graphics or
compositing. All versions of Apple ProRes support every popular video resolution,
including 720 x 486, 720 x 576, 960 x 720, 1280 x 720, 1280 x 1080, 1440 x 1080,
1920 x 1080, 2048 x 1024, and 2048 x 1152. This allows you to perform your offline edit
at the same resolution as your source.
• Editing with Apple ProRes at the same resolution as your source requires higher data
rates and file sizes. For example, the SD data rate of the Apple ProRes 422 (Proxy) codec
is approximately three times that of the same project in the OfflineRT format, which is
320 x 240, less than 1/4 the pixels of SD. Therefore, if data storage is the most important
issue, OfflineRT would still be the lowest data rate format for the offline edit.

Setting Up and Capturing Media to an OfflineRT Format
Before you capture, you need to choose an appropriate OfflineRT format for offline-quality
editing in Final Cut Pro.

µ

To prepare your project for capturing media to an OfflineRT format
Choose an OfflineRT Easy Setup that corresponds to the standard or your original footage
(NTSC or PAL) and frame rate.
OfflineRT Easy Setups are named with the following conventions.
• Video standard: NTSC or PAL
• Frame rate: The frame rate is included in the name of an OfflineRT Easy Setup when
nonstandard frame rates are used, such as 23.98 fps for NTSC video.
• Anamorphic: Choose an anamorphic Easy Setup if you shot your original footage with
an anamorphic lens or the anamorphic (16:9) setting selected on your camcorder.
For information about choosing an Easy Setup, see “Connecting DV Video Equipment.”
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Capturing or Recompressing Media to an OfflineRT Format
Once you’ve selected the appropriate Easy Setup, you can capture OfflineRT clips using
your camcorder or deck. For more information about capturing, see “Capturing Video
from Tape.”
When your system is set up correctly, you can log and capture using device control as
usual. During capturing, video is transcoded from its original format to the OfflineRT format
and written to your scratch disk.
Alternatively, you can capture your footage at full quality and full resolution and then
transcode, or recompress it, to the appropriate OfflineRT format using the Media Manager.
For more information, see “Example: Recompressing Media Files for Editing on a Portable
Computer.”

Editing with Low-Resolution OfflineRT Media Files
You edit your OfflineRT sequence just as you would if you had ingested your footage at
full quality and full resolution.

Using Full-Resolution Graphics in a Low-Resolution, OfflineRT Sequence
Even though your OfflineRT sequence is set to small image dimensions, as you edit, you
can import and use your full-resolution still graphics in your low-resolution project.
Therefore, it’s not necessary to create your graphics with two different dimensions for
offline and online editing.
When you edit graphics into your sequence that are larger than that sequence’s frame
size, Final Cut Pro automatically resizes them to fit. For example, while working at offline
resolution, your sequence frame size is 320 x 240. If you edit in a still graphic that was
created with a frame size of 720 x 480, Final Cut Pro sets the Scale property of this graphic
(shown in the Motion tab of the Viewer) to 50 percent to fit the sequence’s 320 x 240 frame
size. Generators used in your sequence always inherit the dimensions of the sequence
they are in.
When you create your full-resolution sequence for online editing, the dimensions of your
graphics and generators are automatically set to the proper dimensions.

Reingesting Media at Full Quality and Full Resolution
Once you’ve finished editing your project, you use the “Create offline” option in the Media
Manager to create a duplicate of your edited sequence using an online-quality sequence
preset. The Media Manager is convenient because it not only creates a duplicate sequence
with new settings, but every clip in the sequence is also set to the the new settings.
Note: The Media Manager adjusts the dimensions and scale of any graphics or Final Cut Pro
generators you used to match the new sequence settings.
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To create a duplicate of your sequence with online-quality settings
1 In the Browser, select your sequence.
2 Choose File > Media Manager.
3 Choose “Create offline” from the Media pop-up menu, then choose an online-quality
sequence preset from the “Set sequences to” pop-up menu.
Note: If you want to limit the amount of media your online-quality sequence references
to media necessary for the sequence itself, make sure the “Delete unused media” checkbox
is selected. In this case, you may also want to select the Use Handles option in case you
need an extra second or two to add transitions or trim your sequence during the online
edit.

Choose “Create offline”
from this pop-up menu.

Choose an online quality
sequence preset from
this pop-up menu.

Select this option so your
new sequence clips refer
to the minimum media
necessary to create
the sequence.

4 When you’re ready, click OK.
5 In the Save dialog that appears, enter a name and choose a location for the project that
contains the duplicated, online-quality sequence; then click Save.
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You can now transfer the project containing your new sequence to a Final Cut Pro system
capable of reingesting and finishing your project at full quality and full resolution. The
sequence clips are considered offline because they are not yet connected to full-resolution
media. In this case, the term offline refers to the fact that the clips are disconnected from
media files.
For more information on using the Media Manager, see “Overview of the Media Manager.”

Which Sequence Preset Should You Choose for Your Online Edit?
The format you choose in the “Set sequences to” pop-up menu depends on the format
of your original footage and the video hardware in your online editing system. For example,
if the format of your footage is DV, you choose a corresponding DV sequence preset in
the “Set sequences to” pop-up menu. If the format of your footage is a non-DV format,
such as Digital Betacam or HDCAM, you need to choose an uncompressed sequence
preset that corresponds to your third-party video interface. Or you could choose a preset
for a high-quality version of Apple ProRes such as Apple ProRes 422 (HQ) or Apple ProRes
4444.
Third-party interfaces usually come with premade sequence presets you can install and
choose in Final Cut Pro. If your editing system doesn’t have the appropriate third-party
presets installed, you need to install them on your system. Alternatively, you can transfer
your original sequence to the online editing system (which should contain the appropriate
sequence presets) and create your final sequence for reingesting directly on that system.

Reingesting Full-Quality, Full-Resolution Media for Your Sequence
Once you create a sequence with online-quality settings, you can bring it to an online
editing system along with your original tapes or file-based media and any graphic, video,
and audio files necessary to re-create your sequence.
To recapture media from tape for your full-quality, full-resolution sequence
1 Open the project file you created that contains your duplicated sequence with
online-quality settings.
2 Select the sequence in the Browser.
3 To recapture all of the offline clips in the sequence, do one of the following:
• Choose File > Batch Capture.
• Control-click the sequence and choose Batch Capture from the shortcut menu.
• Press Control-C.
For more information, see “Capturing Video from Tape.”
To retransfer media from file-based devices for your full-quality, full-resolution sequence
1 Choose File > Log and Transfer to open the Log and Transfer window.
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2 Choose Preferences from the Action pop-up menu (the menu with the gear icon).
3 When the Import Preferences dialog appears, choose the setting in the “Transcode to”
column corresponding to the format you want to use in your online-quality sequence.
4 Open the project file you created that contains your duplicated sequence with
online-quality settings.
5 Close the Log and Transfer window when you have finished.
6 In the Browser, select the sequence with the online-quality settings.
7 To retransfer all of the offline clips in the sequence, do one of the following:
• Choose File > Batch Capture.
• Control-click the sequence and choose Batch Capture from the shortcut menu.
• Press Control-C.
For more information, see “Transferring File-Based Media.”

Adding Final Color Correction, Effects, Transitions, and Titles
An online edit session focuses on the quality of your video. A fully-equipped online edit
suite includes a video waveform monitor, a vectorscope, and a broadcast-quality monitor
to make sure your video looks as good as possible.

Output to Tape, MPEG-2 (for DVD), or a QuickTime Movie File
Once all effects are added, color correction is completed, and the final audio mix is added,
you render sections of the Timeline where necessary and then output to tape. For more
information about output to tape, see “Preparing to Output to Tape.”
Alternatively, you can export to an MPEG-2 file for DVD, a QuickTime movie file for web
output, or an image sequence for transfer to film. For more information about these
output methods, see the corresponding sections in “Exporting Sequences for DVD,”
“Exporting QuickTime Movies,” and “Exporting Still Images and Image Sequences.”

Online Editing on Non–Final Cut Pro Editing Systems
The offline/online editing workflow is the same regardless of the type of editing systems
you use for each phase. The critical step is generating a project interchange file that
correctly translates your edit decisions from one system to another. Transferring from an
offline Final Cut Pro system to an online Final Cut Pro system is easy because both systems
recognize the native Final Cut Pro project file format. However, there are situations when
you want to use a non–Final Cut Pro system for online editing, usually to take advantage
of the unique features of that system.
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Transferring your sequence to a non–Final Cut Pro system requires an intermediate project
interchange format. Some examples of non–Final Cut Pro online editing systems include
the following.
• Tape-based linear editing suites: These are traditional online suites, complete with
high-quality monitors, a waveform monitor and a vectorscope, several playback decks
and a record deck, a video switcher with effects, and a computer-based edit controller.
These systems usually only recognize EDLs, which are the oldest and most limited
project interchange format.
• Other nonlinear editing systems: These are systems similar to Final Cut Pro, such as Avid,
Media 100, and Premier Pro. These systems each recognize their own native formats,
and some also recognize the AAF format. The Final Cut Pro XML Interchange Format
can be used in conjunction with third-party plug-ins to export Final Cut Pro sequences
to the native formats of other nonlinear editing systems.
Note: Some systems recognize OMF project files, but Final Cut Pro can export only
audio information in the OMF format, so this is not an option for transferring video
editing information to another system. In Final Cut Pro, OMF is used only for audio
interchange.

Trading Project Files Using Email or the Internet
Because the connection between clips and media files is so flexible in Final Cut Pro, you
can easily transfer projects between and open projects on different Final Cut Pro editing
systems. For example, you can work with reduced-quality copies of your media on a
portable computer and then transfer your project to another editing system containing
full-quality, full-resolution copies of your media. Because a project file is small, it’s easy
to transfer it via email, a website, a thumb drive, or directly from a portable computer
hard disk to a desktop system.
You use the Media Manager to create a copy of your project without media, reducing
transfer time significantly. Keep in mind that recipients of your project need the same
media files on their systems (even if they are at a different quality or different resolution);
otherwise, they will only see offline media indicators when they open the project.
The example below shows how to make a copy of your sequence(s) with different
sequence settings (image dimensions, codec, and so on) to send to a remote collaborator.
You do not actually create any new media.
To use the Media Manager to deliver your project to another Final Cut Pro editing
system
1 Select a sequence in the Browser.
2 Choose File > Media Manager.
3 Choose “Create offline” from the Media pop-up menu.
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4 From the “Set sequences to” pop-up menu, choose the sequence preset that matches
the media on the editing system you are sending to.
5 Click OK.
6 Choose a destination and name for the new project file, then click OK.
7 Attach the new project to an email, or upload it to an accessible FTP or web server.
Some network servers may not recognize the native Final Cut Pro file format. To ensure
that the file is properly transferred, you can create and send a compressed zip archive of
your project instead.
To create a cross-platform-compatible zip archive of your project(s)
1 In the Finder, select the Final Cut Pro project file(s).
2 Control-click the project file and choose Create Archive Of from the shortcut menu.
If you create a single archive zip file, the archive file will be named after the file you
originally selected (for example, My Movie.fcp becomes My Movie.fcp.zip). If you select
multiple files, the archive file will be named Archive.zip. You can change the name after
the archive file is created, but keep the three-letter .zip extension at the end of the
filename. This will help network servers properly handle the file.
The recipient downloads, unarchives, and opens the project, and then reconnects the
sequence to local copies of the media files, which should match the settings you chose.
Portable Computer
Editing System

File
transfer

Reduced-quality
media files

Project

Project

Clip Clip Clip

Clip Clip Clip

Create offline in
Media Manager

File
transfer
Desktop
Editing System

Full-quality
media files
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Even if you aren’t sure what settings the other person’s media files are set to, you can
send the recipient your original project without using the Media Manager. When the
recipient gets the project, he or she can perform the same “Create offline” media
management operation explained above to create a project compatible with his or her
local media files.
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Reconnecting Clips and Offline
Media

92

This chapter covers the following:
• Finding Your Media Files After Capture (p. 1549)
• About the Connections Between Clips and Media Files (p. 1551)
• Renaming Media Files and Clips (p. 1552)
• How the Connection Between Clips and Media Files Can Be Broken (p. 1553)
• Making Clips Offline (p. 1554)
• Reconnecting Clips to Media Files (p. 1556)
• When Final Cut Pro Reconnects Your Clips (p. 1563)
• Reconnecting Media Files Automatically (p. 1564)
Whenever a clip’s media file is modified outside of Final Cut Pro, the connection between
the clip and the media file breaks. You can easily reconnect clips and media files whenever
you need to.

Finding Your Media Files After Capture
The most common question editors have after capturing is, Where did my media files
go? Knowing what directory Final Cut Pro stores captured media files in and being able
to quickly navigate the Mac OS X file hierarchy are two of the most important aspects of
being a successful editor.

Where Are Captured Media Files Stored?
To determine where your media files are stored, you should first check the Scratch Disks
tab of the System Settings window. In the Scratch Disks tab, the folder with the Video
Capture column selected is the folder that Final Cut Pro captures media to. However,
Final Cut Pro does not store media files directly in that folder. Instead, each time you
choose a new folder for video capture, Final Cut Pro creates several folders within that
folder:
• Capture Scratch
• Render Files
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• Audio Render Files
Final Cut Pro uses the Capture Scratch folder to store captured media files. However, it is
still one level deeper in the hierarchy than you may expect. Within the Capture Scratch
folder, Final Cut Pro creates a folder named after the project that contains the currently
selected capture bin.
For example, if you chose a scratch disk named Media, and if you are currently capturing
clips for a project named Hard to Trace, your captured media files are stored here:
/Volumes/Media/Capture Scratch/Hard to Trace/
Note: Because you can select up to 12 scratch disk folder locations, you may have to look
in several locations before you can find the disk that contains your media. However, this
is only an issue if you have the Video Capture checkbox selected for more than one scratch
disk folder in the Scratch Disks tab of the System Settings window.
To summarize, captured media files aren’t stored directly in the folder you choose as a
scratch disk folder. Instead, they are stored two levels deeper, in a folder named after the
project, inside the Capture Scratch folder.
Important: A very common mistake is to select a folder named Capture Scratch in the
Scratch Disks tab. On the surface, it seems like the right thing to do, but make sure you
don’t. Instead of selecting a Capture Scratch folder, select the parent folder of the Capture
Scratch folder. Never select the Capture Scratch folder itself; if you do, your media files
will be stored in the following location: /Volumes/Disk Name/Capture Scratch/Capture
Scratch/Project Name/.

Revealing a Clip’s Media File in the Finder
The fastest way to find a media file is to use the corresponding clip in the Browser.
To reveal a clip’s media file in the Finder
1 Select a clip in the Browser or Timeline.
2 Do one of the following:
• Choose View > Reveal in Finder.
• Control-click the clip, then choose Reveal in Finder from the shortcut menu.

Consolidating Media Files to One Folder
If you save a project with a new name part way through the capture process, media files
captured after the project is renamed are stored in a new folder. For example: You originally
captured some clips in a project called Hard to Trace, but at some point you renamed
your project Hard to Trace Version 2 and then resumed capturing clips. In this case, clips
captured before the project name change are stored here:
/Volumes/Media/Capture Scratch/Hard to Trace/
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and clips captured after the name change are stored here:
/Volumes/Media/Capture Scratch/Hard to Trace Version 2/
This can make it difficult to manage your project, especially if you want to copy the project
file and all of its corresponding media files to another system. To avoid these problems,
it’s important to pay attention to where your media is stored during capture. If you want
all of your media files to reside in one folder, you need to avoid changing the name of
your project. However, it’s common for editors to change project names as they save
versions of their work. At some point, it’s likely that you are going to capture a media file
to a folder where you don’t want it.
To consolidate media files into a single folder immediately after capture
1 In the Browser, select a clip that corresponds to one of the media files you just captured.
2 Do one of the following:
• Choose View > Reveal in Finder.
• Control-click the clip, then choose Reveal in Finder from the shortcut menu.
A Finder window opens with the media file selected.
3 Click the Final Cut Pro icon in the Dock to switch back to Final Cut Pro.
4 In the Browser, if it isn’t selected already, select the clip that corresponds to the media
file you just highlighted in the Finder.
5 Press Delete.
This removes the clip from your project, but the media file is still on the disk.
Important: Because you deleted the clip, any comments or notes applied to the clip are
now gone.
6 Switch back to the Finder and move the media file to the folder where you want to keep
all the media files associated with your project.
7 Drag the media file from its new folder in the Finder to the Browser in Final Cut Pro.
You now have the same clip as before, but it points to its media file in the proper location.
If your clip has comments and notes that you don’t want to lose by deleting the clip, you
can ignore the step where you delete the clip from the Browser. In this case, Final Cut Pro
warns you that the clip’s media file has gone “offline” when you return to the application.
You can choose to reconnect the clip’s media file, which is now in the proper location,
using the Reconnect window.

About the Connections Between Clips and Media Files
Final Cut Pro is very flexible about the connection between clips and their media files. It
is fairly easy to make a clip go offline by accidentally moving or modifying a media file
in the Finder, but it is also very easy to reconnect clips to media files.
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A clip connects to a media file via the clip’s Source property, which contains the location
of the media file as a file path. If a clip cannot locate its media file, the media file is
considered offline, and the clip is called an offline clip. An offline clip has a red slash through
its icon in the Browser:

These are offline clips.

Each time you move from Final Cut Pro to another application and then back again,
Final Cut Pro checks that the modification date of each clip’s media file has not changed,
and that they are in the expected file path. If a media file has been modified, Final Cut Pro
warns you that the media file has gone offline, and asks if you’d like to reconnect the clip.
You can choose to do this immediately, or you can do it later. If you don’t successfully
reconnect clips to their media files, the clips remain offline.

Renaming Media Files and Clips
After capturing, you may realize that you want to change some of your clip names to
more accurately reflect their content or purpose. It is easy enough to change clip names
in Final Cut Pro, but this doesn’t change your media filenames, causing potential confusion
during media management. One solution is to rename media files directly in the Finder,
but this causes your clips to become disconnected when you switch back to Final Cut Pro.
A more convenient method is to use the clip and file renaming commands in Final Cut Pro.
To rename a clip’s media file to match the clip name
1 Select one or more clips in the Browser.
2 Choose Modify > Rename > File to Match Clip.
A dialog appears, warning you that you are about to modify media files on your disk.
3 Click OK. You can also select the Do Not Show Again option so that this warning no longer
appears.
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Each media file corresponding to one of the selected clips is renamed to match the clip
name. Each media file’s file extension is preserved in the filename. For example, if you
have a media file named Music.aif that corresponds to a clip named Symphony, the media
file is renamed Symphony.aif.
Media files are not renamed in the following cases:
• If a media file is locked or if you don’t have permission to modify the file
• If changing a media filename would cause a filename conflict with an existing media
file in the same folder
• If a media file corresponds to a multiclip
Final Cut Pro attempts to rename each media file corresponding to a merged clip, but in
some cases this may not be possible.
You can also rename clips to match their corresponding media files.
To rename a clip to match its media files
1 Select one or more clips in the Browser.
2 Choose Modify > Rename > Clip to Match File.
Each selected clip is renamed to match its corresponding media file.

How the Connection Between Clips and Media Files Can Be
Broken
There are several reasons the connection between the clips in your project and your
media files on disk can break, causing the corresponding clips in your project to go offline:
• You modified your media files in any way that changes the modification date in the
Finder.
• You moved your media files to another folder.
• You renamed your media files.
• You created an offline project file with the Media Manager.
• You deleted your media files on disk. In this case, you have no option but to recapture
the media files.
When a clip in your project goes offline, any sequence render files associated with that
clip also go offline, and the Offline Files dialog appears (see “When Final Cut Pro Reconnects
Your Clips”).
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When you play back offline clips, a Media Offline message is displayed until these clips
are either reconnected or recaptured.

This type of message
appears when you play
an offline clip.

Making Clips Offline
You can deliberately make clips in your project offline. This breaks the connection between
a clip in your project and its media file on disk by removing the file path in the clip’s
Source property. Since the file path in a clip’s Source property is shared among affiliated
clips, removing this file path makes all affiliated clips offline at the same time. This is useful
if you want to delete all of your media files in preparation for recapturing at a higher data
rate (for online editing).
In addition to breaking the connection between clips and media files, you can choose to
delete the media files or keep them on your scratch disk. This is useful if you want to
delete all of your media files in preparation for recapturing at a higher data rate, or simply
to get rid of media files you no longer need because you are refining your project.
To make one or more files offline
1 In the Browser or Timeline, select the clips or sequences you want to make offline.
2 Do one of the following:
• Choose Modify > Make Offline.
• Control-click a selected item and choose Make Offline from the shortcut menu.
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3 Select an option in the Make Offline dialog, then click OK.

Click an option.

• Leave Them on the Disk: Select this option to disconnect clips from their media files but
leave the original media files on your disk. Clips are disconnected because the file path
in each clip’s Source property is cleared, so the clips no longer have a file location to
look for media files.
• Move Them to the Trash: Select this option to disconnect clips from their media files
and move the media files to the Trash. This is different from choosing to delete the
files because you must still empty the Trash to delete the files. This option lets you
consider whether you really want to permanently delete your media files (emptying
the Trash is not undoable). If you decide to keep the files, you must drag them out of
the Trash and use the Reconnect Media command, because the file path in each clip’s
Source property is cleared.
• Delete Them from the Disk: Select this option to disconnect clips from their media and
immediately delete the media files from the disk. This action is not undoable. If you
need the media files again, you have to recapture them.
4 If you choose to move or delete the files, a message tells you this action cannot be undone.
To continue, click OK.
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Differences Between Missing and Offline Media Files
Final Cut Pro considers any clip without a media file to be offline. However, the status of
the clip’s Source property determines whether Final Cut Pro continues to search for a
clip’s media file each time a project is opened.
If a clip’s Source property contains a file path and the media file cannot be found,
Final Cut Pro considers this clip’s media file to be missing, and Final Cut Pro warns you
about the missing media file each time you open the project.
If a clip’s Source property is empty, the clip is considered offline, but Final Cut Pro does
not search for the clip’s media file (since there is no path to search for). In this case, you
are not warned about missing media each time you open the project. For example, if you
simply log a clip, it does not yet have a media file associated with it, and therefore its
Source property is empty. In this case, Final Cut Pro doesn’t warn you each time you open
the project that the clip is missing its media file.
Final Cut Pro keeps track of which clips have missing media files until you explicitly request
otherwise. You can change the status of a clip from “missing” to simply offline by clearing
the clip’s Source property. You can do this several ways:
• Select the Forget option in the Offline Files dialog that appears when Final Cut Pro
detects that some clips’ media files are not in the expected location.
• Select one or more clips and choose Modify > Make Offline.

Reconnecting Clips to Media Files
Clips in your project don’t have to be offline for you to use the Reconnect Media command.
You can reconnect media files to clips in your project at any time, since all you are doing
is changing the file path stored in the clip’s Source property. Reconnecting the links
between clips and media files is the most obvious reason for doing this, but there are
other reasons to use the Reconnect Media command:
• To reconnect clips in your project to higher-resolution versions of the media files in
preparation for online editing
• To reconnect clips in your project to lower-resolution versions of the media files for
mobile editing, or to fit more media on a relatively small hard disk. This is usually known
as offline editing.
Note: The terms offline clip and offline editing are not related.
• To reconnect clips after you modify, move, or delete media files in the Finder and return
to Final Cut Pro
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About the Reconnect Files Dialog
The Reconnect Files dialog has the following features:
Click these buttons to
filter which types of clips
are displayed in the Files
To Connect list.

Choose a directory and
select this checkbox
to limit your media
file search to a single
directory.
Click this to tell
Final Cut Pro to search
the specified locations
for a clip’s media file.
Click this to manually
navigate to a clip’s
media file.
Click Connect to
reconnect all clips listed
in the Files Located area.

Files To Connect List
This area displays a list of clips organized by clip status:
• Online Files: This refers to clips that are currently referencing the appropriate media
files. You may want to reconnect these clips if you want your clips to reference a different
folder with the same media, or media captured with different settings.
• Offline Files (with a specified path): This refers to clips that contain a file path in the
Source property, but Final Cut Pro cannot locate the media file at the specified location.
• Offline Files (with an unspecified path): This refers to clips that have an empty Source
property. In this case, Final Cut Pro cannot locate the media file because no location is
specified. You need to manually reconnect these clips to their media files, if possible,
using the Locate button.
• Render Files: This refers to sequence render files that Final Cut Pro cannot locate in the
Render Files folder of your current scratch disk.
• Offline, Online, and Render buttons: You can choose to limit which items are displayed
in the Files to Connect list by clicking the offline, online, or render buttons. One or more
of these buttons may be turned off if none of the selected clips or sequences has the
corresponding clip status. For example, if you only selected online clips, the offline and
render buttons are turned off.
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Search Locations Area
This area allows you to choose which folders are searched when Final Cut Pro looks for
media files.
• Skip File: Click this button to remove the current clip highlighted in the Files to
Reconnect list. When this clip is removed, the next clip in the list is highlighted for
reconnection.
• Search Single Location checkbox: When you select this option, only the directory path
in the Search Single Location pop-up menu is searched, as well as any subfolders of
that directory path.
Selecting this option can greatly improve the speed of the search for media files,
especially when you have a lot of media files on your scratch disks or when you are
using a storage area network (SAN) such as an Xsan configuration. The fewer files and
subfolders a directory contains, the faster Final Cut Pro can search for corresponding
media files.
If this checkbox is not selected, Final Cut Pro searches all folders and volumes in the
Search Folders pop-up menu.
• Search Folders pop-up menu: When the Search Single Location checkbox is deselected,
Final Cut Pro searches all of the directories and volumes shown in this pop-up menu
in the order they appear. The pop-up menu is divided into three sections and also
includes an option to add additional search folders.
• Directories from the Search Folders tab in System Settings: These are folders set in the
Search Folders tab in the System Settings window, and they appear in the same
order. For more information about setting and removing search folders, see “Search
Folders Tab.” Additional items can be temporarily added to this list by selecting the
Add Search Location option (at the bottom of this pop-up menu).
• Current scratch disk folders: These are the disks assigned in the Scratch Disks tab in
the System Settings window. For more information, see “Connecting DV Video
Equipment.”
• Currently mounted volumes: These are the current volumes mounted on your system.
• Add Search Location: Select this option to add a folder to the end of the search folders
list. These items are added to the list in the Search Folders tab of the System Settings
window.
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Search Order and Speed in the Reconnect Files Dialog
Final Cut Pro searches folders in the order they appear in the Search Folders pop-up menu.
To make searching for media files efficient, Final Cut Pro searches designated folders
before searching entire volumes. This way, if a media file is located in a specified search
folder, Final Cut Pro never has to perform a more time-consuming search through an
entire volume. This can be especially helpful when searching for media stored an a storage
area network, such as an Xsan storage system.
In general, a directory that contains fewer files and subfolders is faster to search than a
folder higher in the directory hierarchy. However, due to the way HFS directories are
catalogued and optimized, searching an entire HFS volume may be more efficient than
searching a folder near the root level of that volume. Broad, partial-volume searches are
usually the most time-consuming searches. When you assign search folders, always select
folders as specifically as possible.
Locate and Search Buttons
You can use the following buttons:
• Locate: Click this button to manually navigate to a media file for the clip highlighted
in the Files to Connect list. This is useful if you are reconnecting a clip to a media file
whose name does not match, or when you know the location of a media file and you
want to navigate to it quickly.
In the window that opens, you can choose a media file to reconnect to, or you can
choose a folder and Final Cut Pro will search that folder for any media files that match
the name of the clip.
• Search: Click this button to start searching for media files that match the highlighted
clip. When you click this button, the Reconnect dialog opens with the matching media
file selected (if found). Media files are searched for in folders based on the order they
appear in the Search Folders pop-up menu. If the Search Single Location option is
selected, only the folder shown is searched.
Files Located List
As you match clips to corresponding media files, they appear in this list.
• Amount located: This is the number of clips currently matched to media files.
• Amount with conflicts: This is the number of clips that you have assigned to media files
in which some aspect of each clip does not match its assigned media file. For example,
if you assign a media file containing three audio tracks to a clip that expects only one
audio track, this clip is considered to have a conflict.
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Using the Reconnect Files Dialog
The Reconnect Files dialog has many options, depending on the types of clips you are
reconnecting and the number of volumes and folders you want to search for missing
media files. The task below suggests one possible workflow.
To use the Reconnect Files dialog
1 Select the clips you want to reconnect.
If you have a lot of offline clips and you want to make sure you reconnect them all, press
Command-A to select all clips in the Browser, and make sure you select the “Offline”
option in step 3.

Select the files you want
to reconnect.

2 Do one of the following:
• Choose File > Reconnect Media.
• Control-click a clip or sequence, then choose Reconnect Media from the shortcut menu.
The Reconnect Files dialog appears.
The first item in the Files to Connect list is highlighted. The currently highlighted clip is
the clip whose media file Final Cut Pro attempts to match.
3 To choose which kinds of clips appear in the Reconnect Files dialog, click the Offline,
Online, or Render button. For more information, see “About the Reconnect Files Dialog.”
4 To remove the currently highlighted clip from the Files To Connect area, click Skip File.
You may want to skip a clip if you cannot locate its media file, but you want to continue
reconnecting other clips in the list.
5 Do one of the following:
• To limit where Final Cut Pro searches for clips’ media files: Choose a directory path from
the Search Folders pop-up menu, then select the Search Single Location option.

1560

Chapter 92 Reconnecting Clips and Offline Media

• To specify that all folders in the Search Folders pop-up menu be searched: Deselect the
Search Single Location option.
6 Do one of the following:
• To have Final Cut Pro search for media files automatically: Click Search.
• To manually navigate to the location of the media file: Click Locate.
If you click Search, Final Cut Pro searches for the media file that corresponds to the clip
highlighted in the Files To Connect area. When Final Cut Pro discovers a potential
match, the Reconnect dialog appears. If Final Cut Pro cannot find a clip’s media file,
you hear an alert sound. In this case, you may want to use the Locate button to manually
search for a clip’s media file instead.

Select the file.

Deselect this option
when reconnecting a
media file whose name
has changed.

Choose an option to limit
which kinds of files you
are allowed to select.

Several options can help you find your clip.
• Show pop-up menu: If this option is set to All Files, you can select any file type in the
selected folder on your hard disk, whether or not it can be connected to a clip in
Final Cut Pro. To limit the kind of files you can select in this list, choose a file type from
the pop-up menu.
• Matched Name Only: Choose this option so Final Cut Pro restricts your selections to
media files whose names match the filename in the clip’s Source property. If you are
reconnecting to a media file whose name is different from the previous media file the
clip was connected to, or if the clip name does not match the media filename, you can
deselect this option.
Note: If no media file exists that matches the filename in the clip’s Source property,
Final Cut Pro searches for a media file whose name matches the clip name.
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• Search: Shows the path of the media file referenced to the current clip being
reconnected. If more than one match is found, you can use this pop-up menu to choose
which file you want.
• Reconnect All Files in Relative Path: Select this checkbox if you want Final Cut Pro to
automatically reconnect all remaining clips whose media files are located in this folder.
When you are reconnecting a lot of clips, this can speed up the reconnection process
considerably.
7 When the correct media file is selected, click Choose to add the media file to the Files
Located area in the Reconnect dialog.
If certain attributes of the selected media file don’t match the clip you are reconnecting,
the File Attribute Mismatch dialog appears.

Final Cut Pro warns you if the following file attributes don’t match the properties of the
clip you are reconnecting:
• Media Start and Media End timecode
• Number of video or audio tracks
• Reel name
• Frame rate
8 Click Try Again to search for a different media file to connect to the clip. Otherwise, click
Continue to reconnect the media file to the current clip, even though certain attributes
don’t match.
Clips connected to media files with mismatched attributes appear in the File Located
area in italics, and the total number of clip-media file mismatches is displayed next to
“Amount with conflicts.”
All media files located appear in a list in the Files Located area of the Reconnect dialog.
9 Using the Search or Locate button, continue to associate clips to media files until you are
ready to reconnect them.
10 Click Connect to connect all clips in the Files Located area to their media files.
You can click Connect at any time, even if there are still clips listed in the Files to Connect
list.
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When Final Cut Pro Reconnects Your Clips
In certain circumstances, Final Cut Pro checks to make sure all of the media files that
correspond to clips in your project have not been modified, and that none of the media
files are missing. Final Cut Pro checks for offline clips in the following situations:
• When you open a project file: If Final Cut Pro detects missing media files that weren’t
missing the last time you saved this project, the Offline Files window appears.
• When you switch from any application to Final Cut Pro: If you switch from your project
in Final Cut Pro to the Finder (or any other application) and modify your media files,
Final Cut Pro detects these media file modifications when you switch back. In this case,
the Offline Files window appears when you switch back to Final Cut Pro.

About the Offline Files Dialog
The Offline Files dialog appears each time you open a project whose clips’ media files
have been modified in any way. This dialog may also appear when you switch to another
application and then return to Final Cut Pro. If any media files are modified, moved, or
deleted during this time, you see the Offline Files dialog.

You can select which
media files to disregard.

The Offline Files dialog shows a summary of how many media files are missing, and what
kind they are.
• Forget Files: When you select one or more types of media in this list, Final Cut Pro
removes (or “forgets”) the file path in each clip’s Source property. Once the Source
property is empty, Final Cut Pro no longer warns you that these clips are offline.
• Media Files: Select this checkbox to clear the Source property of each offline clip. You
can always reconnect your clips to media files later.
• Render Files: Select this checkbox to tell Final Cut Pro to forget all missing render files
in your sequences. If you do not select this option, Final Cut Pro continues to warn
you that sequence render files are missing each time you open the project.
• Reconnect: Click this button to open the Reconnect dialog. This allows you to reconnect
the clips to their media files. For more information, see “Using the Reconnect Files
Dialog.”
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• Continue: Click this button to leave all specified clips offline. The file paths in the Source
properties of all clips selected in the Forget Files list are cleared. Any unselected clips
and render files continue to be considered “missing,” and Final Cut Pro warns you that
these clips’ media files cannot be found each time you open the project.

Clip Properties Replaced by Media File Settings
When you reconnect a clip to a media file, the following clip properties are replaced by
the settings in the media file:
• Anamorphic
• Pixel Aspect
• Field Dominance
However, if you manually update any of these clip properties before reconnecting,
Final Cut Pro retains your custom settings and does not update those properties via the
reconnected media file.

Reconnecting Media Files Automatically
If you process your media files outside of Final Cut Pro, Final Cut Pro detects the change
in the media file and any clips pointing to that file become offline. This can be
inconvenient, especially when you are constantly modifying media files in another
application like Motion or Soundtrack Pro.
By using the Open in Editor command, you can tell Final Cut Pro to open a clip’s media
file in a particular application and then automatically reconnect the file when you return
to Final Cut Pro. However, this method can also be inconvenient, especially if you are
making changes to Motion or Soundtrack Pro projects outside of Final Cut Pro.
If the Open in Editor command doesn’t suit your workflow, you can configure Final Cut Pro
to always reconnect modified media files in all circumstances, even if you don’t use the
Open in Editor command. This means that when you modify media files in other
applications, the clip does not go offline when you return to Final Cut Pro.
To configure Final Cut Pro to reconnect modified media files even when you don’t use
the Open in Editor command
1 Choose Final Cut Pro > User Preferences.
2 Click the Editing tab.
3 Select the Always Reconnect Externally Modified Files checkbox.
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Warning: Be cautious when you select this option, particularly in a shared environment
(such as an Xsan environment) in which media drives are shared for collaborative editing.
If you (or someone else) modifies media files in other applications, Final Cut Pro will not
notify you when clips are reconnected. For example, if someone changes the duration
of a media file in Soundtrack Pro, Final Cut Pro does not warn you that the clip duration
has changed. If you want to ensure that clips are only reconnected when you use the
Open in Editor command, deselect the Always Reconnect Externally Modified Files
checkbox.
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Overview of the Media Manager

93

This chapter covers the following:
• What Can You Do with the Media Manager? (p. 1567)
• Selecting Items to Process with the Media Manager (p. 1569)
• Settings and Options in the Media Manager Window (p. 1570)
• How the Media Manager Processes Selected Items (p. 1577)
• Limiting How Much Media Is Copied or Deleted (p. 1580)
• Media File Formats Supported by the Media Manager (p. 1582)
• About Color Space Conversion in the Media Manager (p. 1582)
The Media Manager helps you move, copy, delete, and process your project’s media files,
automatically updating the connections between clips and media files.

What Can You Do with the Media Manager?
The Media Manager can duplicate an existing project, or individual items in the project,
as well as the corresponding media files, or portions of those media files. Final Cut Pro
treats media files and clips independently, so some Media Manager options determine
how clips are modified, duplicated, or reconnected, while other options determine how
media files are processed. Most of the tasks you do in the Media Manager could be
performed manually, but it could be very time-consuming. It’s much more efficient to let
the Media Manager do this work for you.
You can use the Media Manager for the following media management tasks:
• Copy entire projects or items within projects: You can create a new project file that contains
whichever items you select in your original project file, as well as copy all of the
corresponding media files.
• Move all media files to a single folder on your scratch disk: It’s fairly common to capture
media files to more than one folder (or more than one scratch disk) during the course
of a project. You can use the Move option in the Media Manager to consolidate all of
your project’s media files to a single folder on a single scratch disk, as well as to
automatically reconnect all of the clips to their media files in the new location.
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• Delete unused portions of media from your hard disk: You can break your media files into
smaller files by using the “Delete unused media from selected items” option. This option
analyzes what portions of each media file are used by your current selection, and then
creates new media files that contain only the necessary media. You can use this option
with the Copy or Recompress option, so only a limited amount of new media is created.
If you use this option with the Move or Use Existing option, smaller media files are
created and the original files are deleted.
Note: This is a good way to free up disk space or create smaller media files from subclips
that originally refer to one large media file.
• Recompress media files with different image dimensions and compression settings: The
Recompress option in the Media Manager allows you to create copies of your media
files compressed with a different codec or frame size. For example, you can recompress
your DV media files with the OfflineRT settings in order to reduce their size for editing
on a portable computer. This is a common method for creating media files for offline
editing in Final Cut Pro.
Important: You cannot use the Recompress option to convert NTSC media to PAL, PAL
media to NTSC, or any other frame rate conversion. If you try, the frame size will change
to the new size, but the frame rate will remain the same as in the original media.
• Create a copy of a sequence for recapturing clips at full resolution (online editing): You can
use the “Create offline” option in the Media Manager to duplicate a sequence with
different video and audio settings. This option doesn’t actually create any new media
files, so the resulting sequence and its clips are offline (meaning the clips have no media
files to refer to). You can then recapture the sequence’s media files at full resolution
for the final edit. This option is typically used in preparation for online editing.
If two editors both have copies of the media files, but each uses different settings (for
example, DV on one system and OfflineRT on another), you can use this feature to
quickly exchange sequences back and forth via email or the Internet. In this situation,
only a project file containing a sequence needs to be transferred, since both editors
have their own copies of the media files. Once an editor receives a project, the clips
can be reconnected to local media files.
For more information, see “Offline and Online Editing.”

Getting Started with the Media Manager
The Media Manager has a lot of options, which makes it both powerful and complex. If
you are new to media management in Final Cut Pro, you may find it easier to learn by
trying out the examples in “Examples of How to Use the Media Manager.”
When learning how to manage your media in Final Cut Pro, it’s also important to
understand the distinctions between master and affiliate clips, media files, subclips, and
so on. For more information, see “Elements of a Final Cut Pro Project.”
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Selecting Items to Process with the Media Manager
Before you can use the Media Manager, you need to select which clips, bins, sequences,
or clip items in sequences you want to process. The items you select (and the
master-affiliate clip relationships of those items) determine which clips and media files
are processed.
Here are some examples of what you can select to process with the Media Manager:
• One or more clips in the Browser: These may be master clips, affiliate clips, or a
combination of both.
• One or more sequences: When you select a sequence in the Browser, the Media Manager
operation affects only that sequence’s clips and their corresponding media files. If the
Timeline is the active window and no clips are selected in it, then the currently selected
sequence tab is the one that is operated upon.
• One or more clip items in a sequence: If a sequence is open in the Timeline and the
Timeline is active, you can use one of the selection tools to select particular clip items.
Clip items are individual parts of a clip placed in tracks of a sequence (for example, a
video clip item and two audio clip items from a DV clip). The Media Manager operations
are then restricted to only the selected clip items within the currently active sequence.
• One or more bins: When you select a bin, the Media Manager processes all the clips and
sequences contained in that bin.
• An entire project: You can select the entire project by making the Browser the active
window, selecting the tab for your project, and then pressing Command-A to select all
items in the Browser. If the Browser is the active window and no items are selected,
the Media Manager processes every item in the project, just as if you had selected all
the items.
• Any combination of the above: The Media Manager can handle a diverse range of
selections, such as a bin and several sequences, a sequence and multiple clips in the
Browser, noncontiguous clip items in a sequence, and so on.
Important: Media files that do not have a source timecode track or reel name are never
trimmed shorter, transcoded, or made offline. This is because a media file without a reel
name and timecode may not come from a source that would allow you to recapture the
media, so Final Cut Pro errs on the side of safety so that you don’t accidentally lose any
of this media file.
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Settings and Options in the Media Manager Window
The Media Manager has a number of options, many of which affect one another. Some
options become unavailable for some operations, and in other cases, some options
become permanently turned on. When certain options are dimmed, it’s usually to ensure
that clips outside your selection don’t lose the media they need when you process your
media files.

µ

To open the Media Manager
Select items in the Browser or in a sequence, and then do one of the following:
• Choose File > Media Manager.
• Control-click a clip or sequence in the Browser or Timeline, then choose Media Manager
from the shortcut menu that appears.

Green segments
represent media files;
blue segments represent
render files.

The Project area
determines whether
or not a duplicate
project will be created.

Click here to choose
a location to store
selected items.
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Summary Area
The Summary area at the top of the Media Manager describes what operation is about
to be performed and shows how much hard disk space the resulting media requires.

Move the pointer
over a bar to view
the disk space for
the specified items.

• Original: This bar shows the total disk space used by the media files associated with
your current selection. This bar may be segmented if the media referenced by the
selected items is found on multiple disks.
• Modified: This bar displays the total disk space that will be used by the same items after
the Media Manager processes the media files. If you’re recompressing or deleting
unused media, the Modified bar is often shorter, so you can see how much disk space
the operation will save.
When you move the pointer over each section of the bar graph, a description appears
that displays the size, location, and duration of the media represented by that section.
Different colored segments represent different types of media, with media files
represented by green segments and render files represented by blue.
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Media Area
This area is where you choose what you want to do to the media files on disk that are
referenced by your selection—copy, move, recompress at a specified sequence preset,
process only existing media, or create offline clips (creates a copy of clips or sequences
with no associated media). You can also choose to include render files, delete unused
media, and add handles.
Choose what you
want to do with the
selected media.

Specify additional
options here.

• Media pop-up menu: The choices in this pop-up menu represent the main Media
Manager tasks. All other options in the Media Manager follow from the choice you
make here.
• Copy: This option copies all the selected items’ media files to the folder or disk
specified in the Media Destination path.
• Move: This option moves selected items’ media files to the location specified in the
Media Destination path.
• Recompress: This is nearly the same as the Copy option, but it allows you to
recompress the selected items’ media files using a codec different from the one they
were captured with and place them at a specified location. You choose the
recompression settings used from the “Recompress media using” pop-up menu,
which lists all sequence presets in Final Cut Pro. If no preset suits your needs, you
can choose Custom and specify your own settings in the Sequence Preset Editor
window that appears. These settings cannot be saved as a sequence preset; they are
used only for the immediate operation. When you use the Recompress option, clips’
motion attributes are changed to match the new dimensions of the sequence preset
you chose. Only QuickTime movies are recompressed; other types of files (such as
Photoshop or AIFF files) are simply copied.
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• Use Existing: This option allows you to use the currently existing media that’s linked
to the selected items. If you delete unused media using this option, the unused media
is actually deleted from your original media files, with or without handles, as specified.
Be extremely careful when choosing the “Use existing” option; the Media Manager
deletes each media file as soon as it finishes processing it. Canceling this operation
may restore the media file currently being processed, but media files that have already
been processed cannot be restored.
• Create Offline: This option is very different from the others because no media files
are created or processed, and your selection is always copied to a new project. This
option is used to make a copy of a sequence with different settings, not to copy
actual media. The main reason for this option is to copy a sequence with
low-resolution settings to a sequence with full-resolution settings which you can
then use to recapture full-resolution media. This prepares you for an online editing
session. If the duplicated sequence has a different frame size than the original, the
sequence clips’ motion attributes are adjusted proportionally so they match the new
frame size. You can choose the new settings for the copied sequence in the “Set
sequences to” pop-up menu, which lists all sequence presets in Final Cut Pro, as well
as an option to use Current Sequence Settings. You can also choose Custom to specify
your own settings in the Sequence Preset Editor window that appears. These settings
cannot be saved as a sequence preset; they are used only for the immediate operation.
• “Include render files” checkbox: Select this checkbox to include render files when using
the Copy or Move operation. This option is not available with the Recompress, Use
Existing, or Create Offline operations. This option is always selected with the Use Existing
operation.
• “Include master clips outside selection” checkbox: When you select the “Duplicate selected
items and place into a new project” option, a bin of master clips is created for all of the
clips used in the new project. This means the new project has master-affiliate
relationships, not just independent clips.
The “Include master clips outside selection” option determines how much media is
retained in the master clips of the new project.
• When this option is selected: The master clips in the new project are based on the
master clips in your current project. This means that media defined by the items you
selected before opening the Media Manager window and the media defined by the
In and Out points of your original master clips is retained when new master clips and
media files are created
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• When this option is deselected: The master clips in the new project are based only on
the media used by the items you selected before opening the Media Manager window.
Selecting this option allows you to retain not only the media for clips in your
sequences, but also media defined by your original master clip In and Out points.
When combined with the “Include affiliate clips outside selection” option, you can
retain media for all clips affiliated with your original selection, even if you did not
explicitly select all of the affiliated items. This option is always available with the
Copy, Recompress, and Create Offline operations. This option is always selected with
the Move and Use Existing operations.
• “Delete unused media” checkbox: This option allows you to delete (or not include) any
media files, or portions of media files, that aren’t referenced by your selected items.
Note: The name of this checkbox changes depending on whether you are creating a
duplicate project.
When you delete portions of media files, Final Cut Pro actually creates new media files,
one for each segment of the original media file defined by the clips or subclips you
selected. The new media files are named according to the option chosen in the “Base
media file names on” pop-up menu, and the resulting clips in your project are properly
connected to these new media files. You can use this option when you are removing
unused media files toward the end of your project, or when you want to break up a
long media file that you have broken into several subclips.
The main purpose of deleting media from your hard disk is to save space or to transfer
a consolidated version of your project to another system. However, deleting media
from your media files can be risky, because you may decide later that you want a few
extra frames to trim an edit, or you may have deleted portions of a media file that was
actually used by a clip in another sequence. To avoid deleting too much media, the
“Deleted unused media” option has several related suboptions—Use Handles and
“Include affiliate clips outside selection”—which further refine exactly what media is
deleted. These options are described below. This option works only on QuickTime files
that have timecode tracks and reel names. If you have AIFF and WAVE files in your
selection, they are copied in their entirety.
Note: This option works only on QuickTime files that have timecode tracks and reel
names. If you have AIFF and WAVE files in your selection, they are copied in their entirety.
Important: You must be extremely careful when using this option with the “Use existing”
option in the Media pop-up menu. Once media is deleted, it cannot be restored, and
this operation cannot be undone.
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• Use Handles checkbox: This option modifies the “Delete unused media” option described
above so that less media is deleted from a media file. Handles are additional footage
at the beginning and end of a clip that you keep just in case you need a few extra
frames for trimming, or you need extra footage beyond your planned In and Out points
to create a transition, such as a dissolve, to another shot. This option is available only
with the “Delete unused media” option.
Note: This option works only on QuickTime files that have timecode tracks and reel
names. If you have AIFF and Wave files in your selection, they are copied in their entirety.
• “Include affiliate clips outside selection” checkbox: This option allows you to retain media
used by all clips affiliated with your currently selected items, not just media for the
selected items. Whenever you choose a Media Manager option that can potentially
delete media, this option is automatically turned on.
Important: Because clips are affiliated by way of a master clip, you need to make sure
you also select the “Include master clips outside selection” option to retain affiliated
clips’ media.
When you select this option, the following additional media is included by the operation:
• A selected clip’s master clip media marked by an In point and Out point (or Media
Start and End points if no In or Out point is set)
• Media between affiliated clips’ In and Out points. For example, if a clip in Sequence
A refers to the first ten seconds of a media file, and an affiliate clip in Sequence B
refers to the last ten seconds of the same media file, none of the media file is deleted.
• Media referenced by any affiliate clips in other sequences, even if those sequences
weren’t originally selected
For example, if you have two affiliated clips, one in Sequence A and one in Sequence
B, they both refer to the same media file via their common master clip in the Browser.
If you select Sequence A to copy media using the Media Manager, only the media
referred to by the clip in Sequence A is copied. However, if you select the “Include
master clips outside selection” option and the “Include affiliate clips outside selection”
option, the media referred to by the affiliate clip in Sequence B is also copied, even
though you selected Sequence A for processing. Any media between the master clip’s
In and Out points is also retained.
This option is available with the Copy, Recompress, and Create Offline operations. This
option is always selected with the Move and Use Existing operations. For more
information on using this option, see “Limiting How Much Media Is Copied or Deleted.”
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• “Base media file names on” pop-up menu: This pop-up menu determines how clips are
named when they’re segmented as a result of the “Delete unused media” option. The
following media filenaming options are available:
• Existing filenames: Filenames of clips created by the Media Manager are based on
the source media files on disk. The first new media file created is named the same
as the original media file, and additional media files are named with a numerical
suffix. For example, if three new media files were created, they would be named
“Media File,” “Media File-1,” and “Media File-2.”
• Clip names: Filenames of clips created by the Media Manager are based on the names
you’ve given the clips in your project. If you have created subclips from a long media
file (such as an entire tape captured to one media file), you may have given the
subclips meaningful names. In this case, you would want to name newly created
media files based on the clip names.
Project Area
The two options in this area determine if you will create a new project and how to handle
multiclip angles.

• “Duplicate selected items and place into a new project” checkbox: This option determines
whether the specified processing will be made in a duplicate project file or in the
selected items of the project that is currently open. When you select or deselect this
option, the phrasing of many of the Media Manager options changes from “duplicated
items” to “selected items,” and the availability of some checkboxes also changes.
Creating a new project is often helpful even if only to verify which media files were
processed and how they were processed. This is especially true when you are processing
only a few items within a complex project with numerous clips and sequences. Creating
a new project that refers only to the processed media files helps to isolate the results
of the Media Manager operation.
• “Include nonactive multiclip angles” checkbox: The Media Manager has an option to
reduce multiclips to their active angle, so only the media associated with the active
angle is processed. With multiclip sequences that use a lot of angles, using this option
can significantly reduce the amount of media processed. By default, this option is
selected, so the media for all multiclip angles is processed. For more information about
multiclips, see “Working with Multiclips.”
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Media Destination Area
This area displays the location where media files are placed after copying, moving, or
recompressing. Click the Browse button to choose a different location for the media files.
This shows the location
where moved or copied
media files will be stored.
Click here to select
a location for storing
media files.

How the Media Manager Processes Selected Items
The way clips and media are handled in the Media Manager varies greatly depending on
the master-affiliate relationships between clips you originally selected, the types of clips
you selected, and the options you choose in the Media Manager.

Processing Steps in the Media Manager
You can use the Media Manager to manage clips and media in different ways. Operations
in the Media Manager are done in the following order:
• If you’re duplicating the selected items, you’re prompted for a name and location for
the new project file.
• If you’re removing unused media from existing media files, items outside the current
selection are scanned to see if they use the same media files. (Final Cut Pro looks at all
sequences and clips in all projects that are currently open.)
If any items are found, a message asks if you want to add these additional items to the
current selection, make them offline, or cancel the operation altogether.
• The destination disk is checked to see if there is enough free disk space, based on the
options you’ve selected.
If there isn’t enough free disk space, a message asks you to specify a new destination
or cancel the operation.
• If items outside your selection are found and you chose to make them offline, they are
taken offline.
• Media files are copied or moved to the selected destination.
If the “Delete unused media” option is selected, unused media is not included. If multiple
clips correspond to the same media file and they don’t overlap, each used segment of
the original media file will be written as a separate file and be named accordingly.
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For example: You originally captured a ten-minute clip and used four sections of this
clip’s media file in your project; two of them overlap and the other two don’t. In this
case, three media files are created, one from the two overlapping clips, and two more
for the remaining two clips.
Before

After

Clip

Clip

Clip-1

Clip-2

Note: The names of newly segmented media files are based on the option chosen in
the “Base media file names on” pop-up menu, using either the existing media filenames
or the names of the clips in your project.
• If the “Include master clips outside selection” option is selected, the master clips created
in your new project are defined by the media used by your selected items, as well as
by the In and Out points of the master clips in your current project. Otherwise, new
master clips are created based only on the media used by your selected items.
• If the “Include affiliate clips outside selection” option is selected along with the “Include
master clips outside selection” option, media used by any clips affiliated with your
selection is preserved. For more information on what media will be preserved, see
“Limiting How Much Media Is Copied or Deleted.”
• If you chose to include render files, they’re copied or moved to the selected media
destination.
• If you chose to create a new project, one is created and any selected clips or sequences
are copied to it. A bin of master clips is also created for any clips in your project.
• If you chose the Copy, Move, or Recompress options in the Media Manager, all items
in your original or newly created project are reconnected to the new or moved media
files on disk. If you selected the “Use existing” option, all items in your original or newly
created project are reconnected to the original media files, not copies.
Important: Media Manager operations use only the source timecode track, ignoring
the Aux 1 and Aux 2 timecode tracks. Aux 1 and 2 timecode tracks are preserved,
however, and remain in the media files that remain after the Media Manager operation
is complete.
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How Independent Clips Are Processed
Even if you don’t maintain proper master-affiliate relationships in your project by using
independent clips, the Media Manager carefully analyzes your media management
operation before it begins processing. For example, suppose you have a sequence called
Sequence A that contains several independent clips. Also suppose that there are several
master clips in the Browser that reference the same media files as the independent
sequence clips. If you tell the Media Manager to remove unused media from the
independent sequence clips, Final Cut Pro first scans the other clips in your project to
make sure no others would be affected by deleting media.
In this case, Final Cut Pro discovers that the master clips also refer to the same media files
as the independent clips in Sequence A, and a dialog appears warning you that additional
clips outside your selection refer to the same media files. You are given the option to add
the master clips to your selection before the Media Manager processes the media files.
If you include the master clips in the selection, then no media is removed from the files,
because the master clips refer to all of the media in a media file. However, if you choose
to continue with the Media Manager operation without including the master clips in the
selection, the media files are trimmed based on the length of the independent clips in
Sequence A. This is fine for the clips in Sequence A, but the master clips will no longer
have the appropriate media.

How Subclips Are Processed
When you create a subclip, you create a new master clip. A subclip is not related to the
original clip it came from. However, both the original clip and the subclip refer to the
same media file. Internally, a subclip is aware of the true Media Start and Media End points
of a media file, but it provides artificial subclip limits to make the clip seem shorter, making
it easier to work with in the Viewer and during editing.
When the Media Manager encounters a subclip, it treats the subclip like any other clip,
using the artificial Media Start and End times instead of the actual Media Start and End
times. This means you can use the “Delete unused media from selected items” option
when processing a subclip to create a smaller media file that is only the length of the
subclip.
Note: In some cases, you may want to delete the original master clip that your subclips
were created from to ensure Final Cut Pro doesn’t attempt to preserve the entire media
file referenced by the original master clip.

How Clips with Speed Adjustments Are Processed
When the Media Manager encounters a clip with a speed adjustment, all media necessary
to achieve the speed effect is preserved. For example, a clip with a speed adjustment
that makes the clip faster could have a duration of 10 seconds, but it could use 100 seconds
of media.
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Limiting How Much Media Is Copied or Deleted
When you select clips to process with the Media Manager, keep in mind that those items
may be affiliated with other clips in your project. Specifically, a master clip, which refers
to a media file on your scratch disk, may have many affiliate clips located in different
sequences. When you process your media files in the Media Manager, some options allow
you to choose how much media is processed: only the portion referred to by a single
affiliated clip, or the portion of media referred to by the selected clip, its master clip, and
all other affiliated clips.
Consider the following scenario: there is a 10-minute media file called “Crowd Shot” on
your hard disk. A master clip in the Browser refers to the entire length of the Crowd Shot
media file, and In and Out points are set somewhere in the middle of the clip. Throughout
the course of editing, you drag the Crowd Shot master clip to two different sequences
(Sequence A and Sequence B) and use different portions of the media file in each case.
This creates two clips affiliated with the master, one in each sequence. Since each affiliate
clip has different In and Out points, each one refers to a different portion of the same
media file:
• The affiliate clip in Sequence A refers to the first 10 seconds of the Crowd Shot media
file.
• The affiliate clip in Sequence B uses the last 10 seconds of the same media file.
• The master clip in the Browser has In and Out points set at 10 seconds and 20 seconds,
respectively.

Preserving Media Only for the Selected Item
You can use the Media Manager to create a copy of Sequence A along with only enough
media to re-create Sequence A (and thus ignoring any other sequences or master clips
that might reference the same media file).
To preserve media only for a selected item
1 Select Sequence A in the Browser, then choose File > Media Manager.
2 Choose Copy from the Media pop-up menu.
3 Select “Duplicate selected items and place into new project.”
4 Select “Delete unused media from selected items.”
5 Deselect “Include master clips outside the selection.” This option ignores additional media
referred to by the master clip.
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The resulting media file contains only the first ten seconds of the original media file, which
is sufficient for re-creating Sequence A, but not for re-creating the original master clip or
the clip in Sequence B.
Clip in
Sequence A

Clip in
Sequence B

Before

After

Preserving Media for the Selected Item and Its Master Clip
You can create a copy of sequence A along with enough media for the clip in Sequence
A and enough media to preserve the media In and Out points marked in the master clip.
To preserve media for the selected item and its master clip
1 Select Sequence A in the Browser, then choose File > Media Manager.
2 Choose Copy from the Media pop-up menu.
3 Select “Duplicate selected items and place into new project.”
4 Select “Delete unused media from selected items.”
5 Select “Include master clips outside the selection.” This option preserves the media referred
to by the master clip’s In and Out points, so the master clip is preserved as well as the
clip in Sequence A.
Clip in
Sequence A In

Out

Clip in
Sequence B

Before

After

Preserving Media for Selected Items, Master Clips, and Affiliated Clips
You can create a copy of Sequence A along with enough media for the clip in Sequence
A, Sequence B, and the media referred to by the master clip’s In and Out points.
To preserve media for the selected item, its master clip, and all affiliated clips
1 Select Sequence A in the Browser, then choose File > Media Manager.
2 Choose Copy from the Media pop-up menu.
3 Select “Duplicate selected items and place into new project.”
4 Select “Delete unused media from selected items.”
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5 Select “Include master clips outside the selection.” This option preserves the media referred
to by the master clip’s In and Out points, so the master clip is preserved as well as the
clip in Sequence A.
6 Select “Include affiliate clips outside selection.” This option preserves the media referred
to by all clips affiliated with the master clip, which means preserving the media referred
to by the clip in Sequence B.
Clip in
Sequence A In

Out

Clip in
Sequence B

Before

After

Media File Formats Supported by the Media Manager
The Media Manager supports most media file formats, including:
• QuickTime movie files: All Media Manager operations are supported for QuickTime movie
files with timecode tracks. Video, audio, and timecode tracks are maintained when
possible. Media trimming is supported.
• Still-image files: Still-image files can be copied and moved in their native format.
• AIFF, WAVE, and BWF files: These files can be moved and copied but they cannot be
trimmed.
• Soundtrack Pro Audio Project files and Motion projects: The Media Manager can move
and copy these files, but trimming is not supported. Any media referred to by these
project files is not moved or copied.

About Color Space Conversion in the Media Manager
Color space conversion may occur when you use the Media Manager, depending on
which task you choose from the Media pop-up menu.
• Copy: Preserves super-white values in Y′CBCR footage. This is similar to using the Export
QuickTime Movie command.
• Recompress: Clips super-white values in Y′CBCR footage, regardless of the destination
codec. This is similar to using the Export Using QuickTime Conversion command. This
option is suitable for creating offline-quality copies of your media.
• Move, Use Existing, and Create Offline: These options do not create new media, so color
space is unaffected.
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Examples of How to Use the Media
Manager

94

This chapter covers the following:
• Media Manager Workflow (p. 1583)
• Using the Media Manager (p. 1584)
• Example: Removing Unused Media from a Sequence (p. 1587)
• Example: Duplicating a Sequence and Its Corresponding Media Files (p. 1588)
• Example: Duplicating a Portion of a Sequence and Its Media Files (p. 1589)
• Example: Copying Sequences with New Settings, but Without Media Files (p. 1590)
• Example: Recompressing Media Files for Editing on a Portable Computer (p. 1592)
• Example: Removing Portions of Media Files After Creating Subclips (p. 1593)
• Example: Consolidating Media Files into One Folder (p. 1595)
• Example: Consolidating Your Project and Media Files for Archiving (p. 1596)
The best way to learn about the Media Manager is to perform some of the common tasks
described in this section.

Media Manager Workflow
There are three main stages to working with the Media Manager.
Stage 1: Selecting Clips or Sequences in Your Project
Before you can use the Media Manager, you must select items that you want the Media
Manager to process. You can select an entire project, one or more bins, individual or
multiple sequences, clip items within sequences, or clips in the Browser. Whatever you
want to do, the Media Manager needs to know what to process before it can do anything.
See the examples later in this section for some ideas on how to use the Media Manager.
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Stage 2: Choosing Options in the Media Manager Window
Once you’ve selected items in your project, open the Media Manager window and choose
options for processing your media. You can select whether clips, sequences, and so on
are duplicated into a new project, and how media is processed (moved, copied,
recompressed, deleted, and so on). Some options are unavailable, or permanently selected,
depending on what other options are selected. You can also specify a destination for
your new media files to be stored.
Stage 3: Starting the Media Management Process
After specifying your options, click OK in the Media Manager window. Final Cut Pro displays
a warning message before it performs any operation that cannot be undone. A progress
bar shows you the status of the operations as they’re performed.

Using the Media Manager
Before opening the Media Manager, you must select the items in your project that you
want to process. The Media Manager can process items for an entire project, one or more
sequences, one or more clips, or one or more clip items in a sequence.
To use the Media Manager
1 Select the items in your project that you want to process.
• To operate on your entire project: Select your project’s tab in the Browser, then press
Command-A to select every clip, sequence, and bin in your project.
Note: If no items are selected in the Browser and the Browser is the active window,
Final Cut Pro processes all the items in the current tab. This may be a bin or an entire
project.
• To operate on one or more sequences: In the Browser, select the sequences you want to
process. If the Timeline is the active window, the sequence tab that is currently selected
is the one operated upon.
• To operate on one or more clips: Select one or more clips in the Browser.
• To operate on one or more clip items in a sequence: Clip items are individual clip items
placed on tracks in a sequence. You can use one of the selection tools to select a range
of clip items to operate on.
2 Do one of the following:
• Choose File > Media Manager.
• Control-click one of the selected items, then choose Media Manager from the shortcut
menu.
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If one of the items you selected contains no media (for example, if an empty sequence
is part of your selection), a message gives you the option to continue or stop. If you
choose to continue, the items that don’t contain any media will be ignored.
A message appears
if your selection does
not contain media.

3 In the Media Manager window, choose a method for processing media files from the
Media pop-up menu.

4 Select whether or not you want to create a duplicate project that contains copies of the
selected clips, bins, and sequences.
5 Select available options to include more or less media related to your selection, and
whether or not you want to delete portions of existing media files.
For detailed information, see “Settings and Options in the Media Manager Window.”
Important: If you chose the “Use existing” option from the Media pop-up menu, be
absolutely sure that you want to perform this operation before you click OK. Once this
operation begins, media files may be deleted immediately. Canceling this operation once
it starts won’t restore them and the operation cannot be undone.
6 Click Browse to choose a destination for your newly moved or copied media files.
7 In the Choose a Folder dialog, select a location, then click Choose.
Note: The Browse button is dimmed and the above dialog does not appear if you chose
“Use existing” or “Create offline” from the Media pop-up menu in the Media Manager
window. This is because no new media files will be created or moved to a new location.
8 When you’re ready to continue, click OK.
If you chose to create a duplicate project, Final Cut Pro prompts you to choose a name
and destination for your new project file.
9 Navigate to where you want to store the items, enter a name for the file, then click Save.
Final Cut Pro scans your selected clips and sequences.
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10 If you are presented with requests for additional information, make the appropriate
selections:
• Additional Items Found dialog: When you use the Media Manager to do a potentially
destructive operation, Final Cut Pro checks all currently opened projects to see if there
are any other clips that reference the same media. If so, the Additional Items Found
dialog appears.

Decide what you want to
do, then click a button.

• Add: Click this button if you want to tell the Media Manager to consider additional
portions of media files referenced by other currently open projects.
• Continue: Click this button to continue the Media Manager operation without taking
into consideration the additional portions of media found. This may make some clips
offline in projects outside the current one.
• Abort: Click this button to stop the Media Manager operation (for example, if you
want to change your original selection).
• Confirm Media Modifications dialog: If the Media Manager is going to permanently
change or delete media files, a final message appears to let you decide if you really
want to process your media files.

Decide what you want to
do, then click a button.

A progress bar displays the state of completion of your Media Manager operation. For
information on the order of operations, see “How the Media Manager Processes Selected
Items.”

Important: Do not switch to the Finder when the Media Manager is in the middle of
processing operations. If you do, a Relink dialog may appear when you return to
Final Cut Pro. To continue, click OK and don’t relink.
If an error occurs during the selected operation, the process stops and an error message
appears.
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Example: Removing Unused Media from a Sequence
A common Media Manager operation is to remove parts of media files that are not used
in the sequence. For example, in a 30-minute sequence, the sequence clips refer to
30 minutes of media files. However, the total media referred to by these clips’ master
clips can be much more. For example, a master clip may refer to a 5-minute media file,
but when you edit it into a sequence, the affiliate clips’ In and Out points define a sequence
clip that refers to only 1 minute of the media file. Just for that one clip, there are 4 minutes
of the media file that are unused by the sequence clip. With the Media Manager, you can
easily delete the portions of media unused by the sequence clips.
Important: This process preserves media files used by any sequence or clip in all currently
open projects. For example, if two projects refer to the same media file, and they are both
open at the same time, the Media Manager preserves the media file based on its usage
in both projects.
To remove unused media from a sequence
1 In the Browser, select the sequence you want to remove footage from.
Select the sequence
you want to remove
footage from.
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2 In the Media Manager, choose the following options, then click OK.
Click here to retain
only media used in
the sequence.

Choose “Use existing”
from this pop-up menu.

If you select the Use
Handles checkbox, enter
a duration here.

Make sure this is
not selected.

Note: If the clips in your sequence are affiliated with clips in other sequences, and your
master clips have no In or Out points set (or Out points set near their Media End points),
there may not be very much media deleted.

Example: Duplicating a Sequence and Its Corresponding Media
Files
In this example, a sequence is copied to a new project, along with its corresponding
media files. The new sequence clips refer to the new media files, while the original
sequence still refers to the original media files.
For example, you may have captured an hour’s worth of media from tape, but used only
45 minutes of it in the sequence. You can duplicate the sequence and create copies of
the media files referenced by the sequence, but without the unused 15 minutes of footage.
To duplicate a sequence and its corresponding media files
1 In the Browser, select the sequence you want to duplicate.
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2 In the Media Manager, choose the following options, then click OK.
Specify these options to
include only media used
in the sequence.

Choose Copy from this
pop-up menu.

Handles are optional.

Make sure this option
is selected.

Example: Duplicating a Portion of a Sequence and Its Media
Files
The Media Manager lets you copy selected clip items in your sequence along with their
media files. This way, you can experiment with a section of your program without touching
the original sequence or its corresponding media files.
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To duplicate a portion of a sequence and its media files
1 In the Timeline, select the part of the sequence you want to duplicate.

These clip items are
selected in the sequence.

2 In the Media Manager, choose the following options, then click OK.

Choose Copy from this
pop-up menu.

Optional

Make sure this option
is selected.

Example: Copying Sequences with New Settings, but Without
Media Files
There are several situations in which you might want to create an offline copy of one or
more sequences:
• When you’re preparing to recapture media files using a different capture preset.
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• When you’re working with a remote editor who already has the media files and you
need to email the offline sequences without the media files.
To copy several sequences with new settings, but without media files
1 In the Browser, select the sequences you want to copy.

Select the sequences you
want to copy.

2 In the Media Manager, choose the following options, then click OK.
Make sure this checkbox
is selected.

Choose “Create offline”
from this pop-up menu.
Choose a sequence
preset for your
copied sequences
and associated clips.

This option is always
selected when you
choose “Create offline.”

Handles are optional.
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Note: Selecting “Include master clips outside selection” and “Include affiliate clips outside
selection” creates master clips that preserve the most media for recapturing. During rough
editing, you generally want to retain the largest possible media files, so it’s a good idea
to keep these options selected. If you are creating sequences for final editing or capturing
at high resolution, you may want to deselect these options.

Example: Recompressing Media Files for Editing on a Portable
Computer
If you need to fit a lot of media files on a relatively small hard disk, such as a portable
computer hard disk, you can recompress all your media files. This is the phase of the
offline/online workflow when you create the low-resolution, offline-quality media files
for rough editing.
This example uses the OfflineRT sequence preset, which uses the Photo JPEG codec.
Note: The Recompress option may fail with clips using codecs that rely upon temporal
compression, such as Sorenson and Cinepak. To recompress files in these codecs, you
may want to use the Batch Export feature instead.
To recompress media files for an entire project for editing on a portable computer
1 In the Browser, select all items in the project.

Press Command-A or
use the Selection tool
to select everything in
your project.
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2 In the Media Manager, choose the following options, then click OK.
Choose Recompress from
this pop-up menu.

Choose the codec
you want to use for
recompressing (you
can also create a new
preset here).

Click here to choose
a location for the
recompressed media
files. If your portable
computer is connected,
you can copy files
directly to it.

Make sure these options
are set properly.

Example: Removing Portions of Media Files After Creating
Subclips
A common logging and capturing workflow involves capturing each tape to a single
media file, breaking the master clip into subclips, and then using the Media Manager to
create individual media files for each subclip. In this example, the Media Manager creates
a media file for every subclip in your project. Portions of your media that are not referenced
by subclips are not turned into new media files, and thus unnecessary media can be
eliminated by this process.
To eliminate portions of a media file not referenced by subclips
1 In the Browser, delete the original master clip that your subclips were derived from.
Note: When you create a subclip, it becomes its own master clip. A subclip does not refer
back to the original clip it came from, but both the original clip and the new subclip refer
to the same media file.
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Because the Media Manager tries to preserve media referenced by clips in your project,
it is necessary to delete the original master clip (which refers to the entire length of the
media file) so only the subclip media will be preserved.
2 Rename your subclips with descriptive names.
When the Media Manager creates new media files, they will be named after these subclip
names.
3 Select all of the subclips that you created from the master clip you just deleted.
Important: The media for any subclips you don’t select will be lost. To be safe, you can
move all the subclips whose media you want to retain to one bin, and the subclips you
don’t want to preserve to a different bin. Then select the bin of subclips you want to
preserve.
4 Control-click one of the selected subclips, then choose Media Manager from the shortcut
menu that appears.
5 In the Media Manager, make the following selections:
Choose “Use existing”
from this pop-up menu.

Choose “clip names” from
this pop-up menu. This
option names your media
files using the descriptive
subclip names instead
of numbered variations
on the original
media filename.
Deselect this option.

Select this option.

6 Click OK.
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The Media Manager creates a new media file for each selected subclip and reconnects
each subclip to the new media file. The original media file is deleted, so any subclips not
selected become offline.

Example: Consolidating Media Files into One Folder
Sometimes the media files for a project are stored in several folders on one or more
scratch disks. This happens if you selected a different scratch disk each time you captured
media files, or when the name of the project file changes (this often happens when you
save often to different filenames). The Media Manager makes it easy for you to consolidate
all the media files for a project into one folder, without making any clips go offline.
To move all of the media files associated with one project to a single folder
1 If you want to save your media files to a new folder on your hard disk, create that folder
in the Finder.
2 In the Browser, select all items in the project.

Press Command-A or
use the Selection tool
to select everything in
your project.
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3 Make sure the Browser window is active. In the Media Manager, choose the following
options, then click OK.

Choose Move from this
pop-up menu.

Handles are optional.

Click Browse and select
your destination folder.

Make sure this is
not selected.

Files moved by the Media Manager are placed in a folder named after the project name,
which is placed in a folder called Media. The clips in your project are reconnected to the
media files in their new location.
Note: You could achieve the same results by moving files into a single folder in the Finder,
but then you would have to reconnect all of your clips to their media files manually. Using
the Media Manager makes this process more efficient, because all of your clips are
reconnected automatically after the media files are moved.

Example: Consolidating Your Project and Media Files for
Archiving
Many people like to archive their finished project files along with the corresponding
media files. In this example, you copy all the content to an archive folder, which you can
then back up on a DVD-R or other high-capacity media. After this process, you have an
additional copy of your project and its corresponding media files. The original project file
and media files are still intact.
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If you want to reduce the required disk space, you can limit your selection to individual
sequences and tell the Media Manager to copy only the parts of media files used by the
sequences. In the example that follows, all the media is copied.
To consolidate your project and media files for archiving
1 If you want to save your media files to a new folder on your hard disk, create that folder
in the Finder.
2 In the Browser, select all items in the project.

Press Command-A or
use the Selection tool
to select everything in
your project.
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3 Make sure the Browser window is still active. In the Media Manager, choose the following
options, then click OK.
(Optional) Click here so
that the parts of media
files that are not used by
your clips and sequences
are not included.

Choose Copy from this
pop-up menu.

Handles are optional.

Click Browse and select a
folder to save your new
media files.

Make sure this option
is selected.

4 In the dialog that appears, enter a project name, check that the destination folder is
correct, then click OK.
A copy of the project is placed in your specified archive folder. Copies of the project’s
media files are placed in a folder named Media.
5 To preserve media referenced by any affiliate subclips, select “Include master clips outside
selection” and “Include affiliate clips outside selection.”
These options may increase the amount of media copied. If you are trying to reduce the
amount of media you back up, deselect these options.
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Diagnostic Tools for Clips
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This chapter covers the following:
• Different Tools for Diagnosing Clips (p. 1599)
• About the Analyze Movie Command (p. 1600)
• Finding and Marking Long Frames (p. 1603)
If you need detailed information about a clip’s media file, you can use the diagnostic tools
in Final Cut Pro to analyze your media.

Different Tools for Diagnosing Clips
Final Cut Pro has the following diagnostic tools for analyzing media files:
• Analyze Movie Clip or File: These two commands allow you to examine the properties
of media files on disk, including the data rate, frame rate, frame size, and video and
audio compressors used. Both commands are identical, but each one accesses media
files differently. The Analyze Clip command works with media files referenced by clips
in your project. The Analyze File command allows you to analyze a media file that isn’t
referenced by a clip in your project. See “About the Analyze Movie Command.”
• Mark Long Frames: The frame rate of a media file determines the duration of each frame.
Long frames are frames that have a longer duration than expected based on a media
file’s frame rate, and they are often the result of a problem during capture. The Mark
Long Frames command analyzes one or more clips in the Browser or Viewer, and places
markers to indicate any long frames that are detected. You may use this command if
you have any doubt about the integrity of your clips’ media files. You can clear long
frame markers later using the Clear Long Frame Markers command. See “Finding and
Marking Long Frames.”
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• Mark Audio Peaks: Clipping occurs in captured audio if any part of the recorded signal
goes above 0 dBFS. Since 0 dBFS is the maximum digital level possible, all levels that
would peak above this are set (clipped) to 0 dBFS, because there is no higher value
possible. Excessive 0 dBFS peaks usually indicate that the audio was recorded at
unsuitable levels. The Mark Audio Peaks command analyzes one or more clips and
places markers to indicate 0 dBFS peaks that are detected. You can clear audio peak
markers later using the Clear Peak Marks command. See “Evaluating Levels with Audio
Meters.”

About the Analyze Movie Command
The Analyze Movie command is an extremely useful tool. With it, you can:
• Troubleshoot your media files: You can check the properties of your clips’ media files,
including the frame rate and data rate, and check whether the media files have any
dropped frames.
• Find the parameters of QuickTime media files: Editing is much easier when the media
file settings match the sequence settings. When you have a media file whose settings
you don’t know, you can use the Analyze Movie command to determine the media
files’ settings, and therefore what sequence settings you need to edit with that media
file into a sequence in Final Cut Pro. You can even create a sequence preset to match
these parameters to use for editing the clips.

Using the Analyze Movie Command
The Analyze Movie command displays track and media properties of a QuickTime media
file in a Movie Analysis window. For details, see “Information Reported by the Analyze
Movie Command.” The contents of this window can’t be printed from Final Cut Pro, but
you can copy and paste the contents into any text-based application, such as a word
processor or SimpleText.
To analyze any QuickTime media file on your hard disk
1 Choose Tools > Analyze Movie > File.
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2 Choose a QuickTime file on your disk that you want to analyze, then click Choose.

Locate the file you
want to analyze,
then click Choose.

To analyze a clip’s media file in your project
1 Do one of the following:
• Select one or more video or audio clips in the Browser.
• Open a video clip in the Viewer.
2 Choose Tools > Analyze Movie > Clip.
A Movie Analysis window appears, showing video, audio, and timecode track information.
If more than one clip is selected, multiple Movie Analysis windows are opened, one for
each clip.
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Information Reported by the Analyze Movie Command
The Analyze Movie command provides the following information.

File information

Video track information

Audio track information

Timecode track
information

Information for All QuickTime Files
• Filename: The name of your QuickTime file on disk.
• Duration: The total duration of the file.
• Average Data Rate: The average data rate of all tracks in the file.
Information for Files with a Video Track
• Track Number and Size: The track number of the video track (although uncommon, it
is possible for a QuickTime file to have more than one video track) and its size.
• Duration: The duration of the video track.
• Frame Size: The frame size of the video track.
• Color Depth: The color depth of the video track.
• Codec: The compression codec used by the video track.
• Frame Rate: The frame rate of the video track.
• Average Data Rate: The average data rate of the video track alone.
Information for Files with an Audio Track
• Track Number and Size: The track number of the audio track (multichannel QuickTime
files may have more than one audio track) and its size on disk.
• Duration: The duration of the audio track.
• Average Data Rate: The average data rate of the audio track alone.
• Format: The bit rate of the audio track and whether it’s stereo or mono.
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• Sample: The sampling rate of the audio track in kilohertz (kHz).
Information for Files with a Timecode Track
• Track Name: The track name of the timecode track. (Some QuickTime files may have
more than one timecode track.)
• Timecode: The starting timecode value for this clip.
• Reel: The reel name for this clip.

Finding and Marking Long Frames
Long frames are frames with nonstandard frame durations that can occur within a clip
as a result of a problem during capture. You might have long frames in your program for
several reasons. Regardless of why there are long (dropped) frames, you need to know
where they are so you can either prevent them or work around them.
A still image in a movie that’s been made to be deliberately longer than one frame is also
a long frame. Long frames of this type may occur in movies created with one of the many
QuickTime authoring programs. For example, if you use QuickTime Player to insert a still
image with a duration of more than one frame into a movie, that frame is considered a
long frame.
The Mark Long Frames command in the Tools menu identifies long frames within clips
in your program. Each selected clip is scanned, and Final Cut Pro places markers to indicate
the location of any long frames that are detected. Each marker is labeled “Long Frame
N,” where N starts at 1 and increases, depending on how many long frames are present.
If the long frame is the result of a still image in an authored QuickTime movie, that marker
will also include the duration of the long frame.
Important: If you have long frames in your program, it’s important that you find the
problem and solve it. This will prevent further headaches down the line, such as lost
audio/video sync and incorrect timecode. For more information on how to troubleshoot
your system if you experience dropped frames, see “Problems During Playback.”
To find and mark long frames
1 Do one of the following:
• Select one or more clips in the Browser.
• From the Timeline or Browser, open the clip you want to check.
2 Choose Tools > Long Frames > Mark.
A status window appears with a progress bar showing how much of the process is
complete.
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Markers are placed at each long frame. Long frame markers have an internal label, or tag,
so that Final Cut Pro can distinguish them from other markers. If you selected a clip in
the Browser, markers appear for the clip and are labeled “Long Frame N,” where N starts
at 1 and increases, depending on how many long frames are detected. These markers
also appear in the Viewer, when the clip is opened there. If you selected a clip in the
Timeline, markers appear in the Timeline.

A long frame marker
for a clip selected in
the Browser

To clear long frame markers
1 Select one or more clips in the Browser or Timeline.
2 Choose Tools > Long Frames > Clear.
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Importing and Exporting EDLs

96

This chapter covers the following:
• About EDLs (p. 1605)
• Exporting EDLs (p. 1610)
• Importing EDLs (p. 1617)
• EDL Considerations Before Capturing (p. 1620)
• EDL Considerations During Editing (p. 1623)
• Transition Wipe Codes for EDL Export (p. 1626)
Edit Decision Lists (EDLs) are useful for transferring edit information between editing
systems.

About EDLs
In the days of linear tape editing, EDLs were used to save and restore the timecode
information for each edit performed on a computer-controlled editing system. Because
timecode editing systems were expensive, many editors would perform offline edits with
window dubs (low-quality copies of original footage with timecode visually superimposed,
or burned, directly onto the image) and then create an EDL by hand for delivery to a
computer-controlled editing system for the online edit.
If you need to move a project to or from a different system or editing workstation, you
can export your project to an interchange file format such as EDL or Final Cut Pro XML
Interchange Format. For example, EDLs are commonly used in DI (digital intermediate)
workflows with Color.
You should also export your sequence to an EDL when you are transferring it to an older,
tape-to-tape system, or to a system that doesn’t recognize more recent interchange
formats (such as OMF, AAF, or the Final Cut Pro XML Interchange Format). Because EDLs
are relatively simple, they are still the lowest-common-denominator file format for
exchanging edit information between editing systems.
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Learning to Read an EDL
An EDL contains the same basic clip information as a Final Cut Pro sequence, but the
presentation is very different. Because EDLs originated with linear, tape-to-tape editing
systems, each event is described in terms of a source tape and a record (or master) tape.
Note: This section describes components of an EDL using the CMX 3600 EDL format.
Other formats may vary slightly.
In an EDL, each clip in your sequence is represented by a line of text called an event, which
has a unique event number. A clip in an EDL is defined by a source reel name and two
pairs of timecode In and Out points. The first pair of timecode numbers describes the
source tape (or clip) In and Out points. The second pair describes the timecode location
where that clip should be placed onto a master tape (or Timeline).

Event 1

Event 2 Event 3

Event 4

Event 5

EDL title

Drop frame mode
of master tape

Drop frame mode
of source tapes

Tip: To better understand how an EDL describes edit information from your sequence,
try exporting a simple sequence with just a few cuts to an EDL, and then compare your
Final Cut Pro sequence to the EDL.

Elements of an EDL
The elements of an EDL are described in the following sections.
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Title and Sequence Timecode Format
The first line of an EDL contains the title of the sequence. In NTSC sequences, the second
line displays whether the sequence timecode is drop frame or non-drop frame.
Event Number
An event number uniquely identifies each event in the EDL. An EDL event requires two
lines if more than one source is used. For example, a dissolve requires one line for the
outgoing shot and a second line for the incoming shot.
001004VC04:31:13:04 04:31:22:23 01:00:00:00 01:00:10:00
001014VD030 14:27:03:03 14:27:25:22 01:00:10:10 01:00:30:00

Reel Name
A reel name describes which source tape (or reel) the clip comes from. Final Cut Pro
assumes that clips without reel names come from non-tape sources, such as color bars,
black, or other generators. Final Cut Pro automatically designates these auxiliary sources
with the reel name AX.
Important: Make sure all clips with timecode sources have reel names before exporting
an EDL, or you won’t be able to easily re-create your sequence when you open the EDL
on another editing system.
Track Type
Each edit uses one or more tracks in the sequence. In the case of tape-to-tape editing,
this field determines which tracks are turned on on the record deck during this event.
• V: Video
• A: Audio (Some EDL formats label this 1 or 2.)
• A2: Audio 2
• AA: Both channels of audio
Video track V1 is the only video track exported. Clips on video track V2 appear as key
effect (K) over the V1. Video tracks V3 and above are ignored during EDL export.
Edit (or Transition) Type
An EDL can represent several kinds of video edits, or transitions. A cut requires a single
source, while all other types of edits require two sources, and thus two lines in an EDL.
• C: Cut. This is the simplest kind of edit.
• D: Dissolve. This transition begins with one source and dissolves to a second source.
• W: A wipe. This is followed by a wipe code that indicates the type of standard wipe.
• K: A key edit. Clips on Video track 2 can be used as the foreground (fill) layer in a
standard video key.
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A dissolve from a Final Cut Pro sequence is shown below in EDL format.

001002VC02:10:42:13 02:11:16:18 01:00:00:00 01:00:34:05

001002VD024 02:18:32:07 02:18:56:19 01:00:34:05 01:00:58:17

Transition Duration
The duration of a transition (in frames) follows the transition type. For example, D 024
indicates a 24-frame dissolve.
Source In and Out, Record In and Out
In each line of an EDL, the first pair of timecode numbers are the source In and Out points.
The second pair are the record In and Out points, which correspond to the clip’s location
in the Timeline.
Edits that use transitions such as dissolves or wipes require two lines. The first line
represents the source before the transition, and the second line is the source after the
transition.
On tape-to-tape editing systems, the tapes containing the two shots are loaded in two
video decks—VTR A and VTR B. To perform a dissolve or wipe, the edit controller plays
both decks simultaneously and uses a hardware video switcher to create the transition
effect as it’s recording on the final master tape. However, when both shots in a dissolve,
wipe, or key are on the same reel, it is impossible to perform the effect in a tape-based
editing suite. This is because the tape cannot be in both places at the same time. For a
workaround to this problem, see “Settings and Options in the EDL Import Dialog.”
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Split edits, where the video and audio have separate In and Out points, require three
lines.

SPLIT: VIDEO DELAY= 00:00:02:00

004002AAC02:18:30:07 02:18:56:19 01:00:32:05 01:00:58:17

004002VC02:18:32:07 02:18:56:19 01:00:34:05 01:00:58:17

The first line indicates which track is delayed and by how much, the second line indicates
the track (audio or video) that plays through the entire edit duration, and the third line
contains the delayed track.
Notes
An EDL can store notes, indicated by a line starting with an asterisk (*), between event
lines. Notes can be used to clarify events for the editor receiving the EDL, and can include
information that the EDL cannot store directly. For example, an EDL can’t directly store
audio levels of a clip, but the audio level can be stored in the EDL as a note. In the EDL
Export dialog, you can choose to export one of the Master Comments 1–4 or Comments
A–B.
001002AA/VC02:10:42:13 02:11:16:18 01:00:00:00 01:00:34:05

* FROM CLIP NAME:DEBRA ENTERS CAFE WS

* OPACITY LEVEL AT 02:10:45:20 IS 0.00%(REEL 002)

* OPACITY LEVEL AT 02:10:49:12 IS 100.00%(REEL 002)
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* CLIP FILTER: COLOR CORRECTOR 3-WAY

* AUDIO LEVEL AT 02:10:43:07 IS -INF DB(REEL 002 A1)

* AUDIO LEVEL AT 02:10:51:16 IS +0.00 DB(REEL 002 A1)

Limitations of EDLs
Today’s nonlinear editing systems store much more information about clips and sequences
than older tape-to-tape systems. When you export a sequence as an EDL, only the most
basic edit information is retained. To assure that your sequence is exported accurately,
it’s a good idea to keep the sequence simple. An EDL can represent only a single sequence,
not an entire project.
For the best EDL results, avoid using the following elements in your sequence:
• Nested sequences
• Clips on video tracks above V2
• Video and audio filters
• Motion and filter parameters and keyframes
• Non-SMPTE standard transitions
If you need to modify a sequence to prepare it for EDL export, duplicate the sequence
and work on the copy instead. This way you can always get back to the original sequence
if necessary. In the duplicated sequence, remove motion settings, filters, and nonstandard
transitions. Move all clips to video track V1. You can use video track V2 for superimposed
(key) effects, such as titles.
Important: If you name disks and folders with double-byte characters, Final Cut Pro may
not be able to export or import EDLs. To avoid this problem, export to or import from
disks and folders with names that do not contain double-byte characters.

Exporting EDLs
You can export an EDL from any selected sequence. You can only export one sequence
to an EDL at a time.
To export a sequence to an EDL file
1 Select a sequence in the Browser or open the sequence in the Timeline.
2 Choose File > Export > EDL.
3 Select your settings, then click OK.
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For more information, see “Settings and Options in the EDL Import Dialog.”

4 Choose a location and enter a name for the file, then click Save.
Note: If you selected the B-Reel Edits option from the “Reel conflicts” section, another
dialog may appear where you can choose a location and enter a name for a second EDL
for the B-Reel list.
If your sequence exceeds the maximum number of events for the format you specified,
Final Cut Pro creates additional EDL files.
If an error message appears, you may not be able to export an EDL in the specified format.
Try changing the options and exporting again. You may also need to simplify your
sequence further and try again.
Tip: You should also output your original sequence to tape, DVD, or QuickTime movie.
Bring this tape to your online session along with your EDL as a reference. The online
editor can use the original sequence to double-check edits and re-create effects that the
EDL left out.

Settings and Options in the EDL Export Dialog
This section describes the options in the EDL Export dialog.
EDL Title
The title entered here appears on the first line of the EDL and is limited to 60–77 characters,
depending on the EDL format. By default, the title entered here is the name of the exported
sequence.
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Note: Changing the EDL title does not change the filename of the exported EDL.
Format Pop-Up Menu
This menu allows you to choose which format your EDL is exported to. There are several
EDL file formats, each named after a particular manufacturer and model of a linear,
tape-to-tape editing system. Final Cut Pro supports the following EDL formats:
• CMX 340
• CMX 3600
• Sony 5000
• Sony 9100
• GVG 4 Plus
CMX 3600 is one of the most common EDL formats, so you should use this one unless
you have a specific reason to choose another. Check with the person receiving your EDL
to determine what format will work best.
Sorting Pop-Up Menu
This menu allows you to choose the order in which your sequence clips are sorted in the
exported EDL.
• Master, Audio Merged: Clips appear in the order in which they occur in the sequence.
Audio clips that start and end together are merged into one event line where possible.
This sorting method allows you to re-create your sequence in order of clips in the
Timeline.
• Source, Audio Merged: Clips are ordered based on their arrangement in the original
source tapes. Event number 1 has the earliest starting timecode on the
lowest–numbered reel. This sorting method allows you to re-create your sequence one
reel at a time, regardless of clip order in the Timeline.
Target Video Track Only
This option allows you to select whether or not your EDL includes keying events when
you have clips on track V2.
An EDL can only include edits that are possible with a tape-based editing system. Since
videotape formats typically have only one video track, you can choose only one video
track in your Final Cut Pro sequence.
When you select the Target Video Track Only option, Final Cut Pro uses the current
destination video track in the Timeline to determine which video track is exported to
your EDL, and no key events are created in the EDL. For example, you can export only
the clips on video track V3 by setting it to the current destination track in the Timeline.
For more information about setting destination tracks, see “Working with Tracks in the
Timeline.”
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This option is useful for exporting separate EDLs, one at a time, for each video track above
V1.
When this option is deselected, Final Cut Pro includes keying (K) events. Video track V1
is treated as the background layer and track V2 as the foreground layer of the key effect.

The following event refers to the first text generator clip in the sequence shown above.
001002VK B02:10:42:13 02:10:52:13 01:00:00:00 01:00:10:00

001GENVK000 00:00:55:00 00:00:55:00 01:00:00:00 01:00:00:00

This option does not affect audio track export.
Omit Transitions
Check this box to ignore all transitions in your sequence so the EDL contains cuts only.
This keeps your EDL as simple as possible, so transitions won’t complicate your online
session. The online editor can create the necessary transitions.
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Reel Conflicts
If you create a transition between two clips from the same reel in your sequence,
Final Cut Pro considers this to be a reel conflict, because the resulting EDL event would
be impossible to perform in a tape-based editing system. This is because in a linear editing
suite, a transition requires two video sources, but you can’t put the same tape in two
decks at the same time.

Reel conflicts can be addressed in several ways, depending on the abilities of the
tape-to-tape editing suite you are using:
B-Reel Edits
In a linear editing suite, transition events that require two different shots on the same
reel can be performed by first copying the second shot of each transition to a new tape,
called a B-reel. Final Cut Pro can automatically create a B-reel EDL, which you can use to
assemble a tape with any necessary shots. The B-reel tape is automatically assigned its
own reel name, and shots in the EDL for your main sequence are replaced with
corresponding shots on the B-reel.
TITLE: MASTER SEQUENCE BREEL1
001002AA/VC02:18:32:07 02:18:56:19 01:00:00:00 01:00:24:12
TITLE: MASTER SEQUENCE
001002VC02:10:42:13 02:11:16:18 01:00:00:00 01:00:34:05
001BREEL1VD024 02:18:32:07 02:18:56:19 01:00:34:05 01:00:58:17
* FROM CLIP NAME:DEBRA ENTERS CAFE WS
* TO CLIP NAME:DEBRA SIDEWALKING
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Pre-Read Edits
Some high-end digital video decks can actually perform transitions by using the master
tape as one of the sources. A digital VTR with the ability to pre-read video off the tape
before recording is required. Pre-read is a technical feature that allows a deck to read the
signal off tape, send it to a device for processing, and then record the processed signal
back onto the same tape in the same location. In this case, the record deck actually
becomes the source deck, or one of two source decks in the case of performing transitions.
Pre-read transitions always begin with the master deck and then dissolve to a source
deck. For example, a pre-read dissolve is performed in an online edit suite by making a
cut to the master tape signal, then dissolving to another source deck.
In the example, the first event is a cut to Reel 002. The second event is a cut to the master
tape itself, which then dissolves to Reel 002.
TITLE: MASTER SEQUENCE
001002VC02:10:42:13 02:11:17:18 01:00:00:00 01:00:35:05
002PREREADVC01:00:00:00 01:00:34:05 01:00:00:00 01:00:34:05
002002VD024 02:18:32:07 02:18:56:19 01:00:34:05 01:00:58:17
* FROM CLIP NAME:DEBRA ENTERS CAFE WS
* TO CLIP NAME:DEBRA SIDEWALKING

Important: Check with your online editor before you select this option.
Generic Edits
This option allows transitions from two places on the same source tape. You should use
this option when exporting your EDL for use in another nonlinear editing system, or if
specifically requested by your online editor. Some online editors may prefer to receive
generic transition EDLs and modify them manually.
TITLE: MASTER SEQUENCE
001002VC02:10:42:13 02:11:16:18 01:00:00:00 01:00:34:05
001002VD024 02:18:32:07 02:18:56:19 01:00:34:05 01:00:58:17
* FROM CLIP NAME:DEBRA ENTERS CAFE WS
* TO CLIP NAME:DEBRA SIDEWALKING

EDL Notes
EDL notes are useful for including details about your Final Cut Pro sequence, even though
the information can’t be used directly by the editing system that imports the EDL.
• File or Clip Names: This pop-up menu allows you to include either the file or clip names
as a note beneath each edit.
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• Comments pop-up menu: Choose one of the comments columns in the Browser (Master
Comments 1–4 or Comments A–B) to include in the EDL. This is a useful way for offline
editors to provide notes about shots to the online editor.
• Filters: Includes names of video and audio filters applied to a clip.
• Video Levels: Opacity levels of each clip, if they are not 100%. Opacity keyframes are
also included, displayed by clip timecode and percentage level. Bezier curve information
is ignored.
• Audio Levels: Audio level changes of a clip, along with keyframe timecode and relative
gain adjustment (in decibels). The audio channel (A1, A2, and so on) is specified next
to each audio level note.
• Transitions: Includes notes about the transitions used in your edit.
Master
These settings allow you to set the starting timecode number for the master tape. This
overrides the Starting Timecode field in the Timeline Options of Sequence Settings.
• Start Time: The timecode for the first edit on the master tape. This number defaults to
the starting timecode of the sequence, but you can set it to any number you want.
• Drop Frame: Defines whether the timecode on the master tape being edited to has
drop frame or non-drop frame timecode. This appears as the first element under the
title in the EDL and defaults to the type of timecode of the sequence you’re exporting.
This option is only relevant for sequences that have a timebase (frame rate) of 29.97 fps.
Audio Mapping
You can choose which audio channels in your sequence are edited to the audio tracks
of the master tape. Some EDL formats support two audio channels, and others support
four. Each track in your sequence can be mapped to any audio channel in the EDL format.
For example, you can map sequence audio tracks 2, 6, 10, and 14 to audio track 2 in the
EDL. The resulting master tape created from this EDL will have audio clips from sequence
tracks 2, 6, 10, and 14 edited onto track 2.

Reviewing an EDL
After you’ve exported an EDL, you should open the text file to compare it to your original
sequence. You can open most EDL formats directly in a text editing application.
Important: It’s best to avoid making changes to the contents of an EDL file. If you do
make changes to the EDL, make sure you don’t change the formatting (such as accidentally
adding or deleting whitespace characters such as Space, Tab, or Return characters);
otherwise, the resulting EDL may not be interpreted properly. Also, make sure you always
save the file in a plain text format (.txt), not Rich Text Format (.rtf ).
You can open an EDL in Final Cut Pro to review it. This is different from importing an EDL,
which actually translates the EDL into a new sequence.
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To open an Edit Decision List
1 Choose File > Open.
2 Locate the EDL file, select it, then click Open.

Importing EDLs
Importing EDLs into Final Cut Pro is becoming less common as more full-featured project
interchange formats are supported. However, if you are reediting a project from an older,
linear editing system, or you are having trouble exchanging sequence information using
other project interchange formats, you can use an EDL to transfer basic edit information
into Final Cut Pro.

Limitations of Importing EDLs
Not everything that can be done in another editing application shows up in an EDL
imported into Final Cut Pro. If you export an EDL from another editing application, the
following elements are excluded:
• Filters
• Motion parameters and keyframes
• Any audio tracks above the first four tracks
• Non-SMPTE standard video transitions
The above items aren’t directly part of an exported EDL, but you can export them as notes
for reference.
Important: Only one video track is included, although key events on another track may
be included also.

Importing EDLs into Final Cut Pro
You can import an EDL into Final Cut Pro to re-create an edit from another nonlinear
system or re-create an older sequence originally cut on a tape-to-tape linear system. An
imported EDL becomes an offline sequence in your project, accompanied by a bin
containing master clips which correspond to all the clips in that sequence. This bin is
named Master clips for [Sequence Name]. To re-create the sequence, you can batch capture
the master clips or select the sequence and batch capture all of its sequence clips.
Important: If you name hard disks and folders with double-byte (or 16-bit) characters
(such as characters used for the Japanese language), Final Cut Pro may not be able to
either import or export EDLs. To avoid this problem, import from or export to disks and
folders with names that do not contain double-byte characters.
To import an Edit Decision List
1 Choose File > Import > EDL.
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2 Specify your import options, then click OK.

Specify the options
you want.

3 Locate and select the EDL, then click Open.
When you import an EDL, a sequence is created in your current project tab, along with
a bin that contains master clips for the clips in the sequence.
Note: When you import a Sony 5000 EDL, the title of the created sequence is “Untitled.”

Problems Importing EDL Files
If you’re having a problem importing an EDL file, check the format of the text file.
Final Cut Pro does not support importing RTF text files. If you have an RTF file you need
to import, open it in a text editing application such as TextEdit, and save it as a plain text
document.

Settings and Options in the EDL Import Dialog
This section describes the options in the EDL Import dialog.
• Select Preset: This determines the settings of the newly created sequence and the clips
within that sequence. Usually, you should choose a sequence preset that corresponds
to the format of your source tapes that you plan to recapture from.
• Import For: Choose an option from the pop-up menu.
• Recapture: Choose this option if you’re importing an EDL from a tape-to-tape linear
editing system or a non-QuickTime standard nonlinear editing system. This makes
the recaptured clip names unique and adds handles before and after the clips during
capture. You can change the handle size.
• Reconnect: Choose this option if you already have the media files on disk and simply
want to link the sequence to them. This is useful if you’ve imported an EDL and also
transferred QuickTime media files to your editing system. This option keeps clip
names in the same order to make relinking easier. You cannot create handles if you
are reconnecting media, since no new media is being created.
• Custom: Choose this option to specify handle size and unique clip names.
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• Handle Size: Specify the number of additional frames you want to capture on either
side of each clip. You should always add handles when recapturing media from an
imported EDL because it gives you more flexibility for trimming edit points, adding
dissolves, and so on.
Note: You cannot set handles when you choose Reconnect because the media files
are already on your disk and are not being captured.
• Make File Names Unique: Select this option if you are recapturing clips so no two media
files have the same name. Deselect this option if you are reconnecting to media files
that are already on disk.

How Clips from an EDL Are Named
Clips imported from an EDL are named in one of two ways. If the EDL was exported from
a nonlinear system, the name is exported like this:
* FROM CLIP NAME: CLIP NAME HERE

where CLIP NAME HERE is the name of your clip. Final Cut Pro can recognize clip names
exported from the following nonlinear editing systems: Final Cut Pro, Media 100, and
Avid.
Important: Avid EDLs that use 24 audio tracks are not supported.
In all other cases, Final Cut Pro uses the reel name as the clip name. Dissolves and wipes
are mapped to the appropriate transitions following the basic SMPTE set. Key edits are
imported as well.
Final Cut Pro places markers in the imported sequence where errors occur.

Master Clips Created from EDLs
When an EDL is imported, a new bin is created in the Browser named Master Clips for
[Sequence Name]. This bin contains master clips corresponding to each piece of media
used by the sequence created from the EDL. Therefore, all the clips in the sequence are
affiliate clips, not independent clips. For more information about master, affiliate, and
independent clips, see “Working with Master and Affiliate Clips.”

Recapturing Clips from an Imported EDL
Unless you already have the corresponding media files on your hard disk, the offline clips
in the new sequence must be recaptured. To do this, you select the sequence or the
master clips and then batch capture. For more information, see “Capturing Video from
Tape.”
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Note: You need all the original source tapes associated with the EDL before starting the
capture process.

Clips from your imported
EDL remain offline until
you recapture them.

EDL Considerations Before Capturing
Before capturing your media files, make sure you:
• Calibrate the timecode via your device control connection.
• Label your source tapes with unique reel names.
Read the following sections for additional information that you should consider before
capturing your media files.

Maintaining Accurate Timecode
The accuracy of your captured timecode is extremely important when exporting an EDL.
If timecode of your clips is inaccurate, online edits won’t match the original offline cuts.
This can be fixed by the online editor, but you’ll lose valuable time.
Make sure you calibrate your incoming timecode so it matches the captured video stream
accurately. For information on calibrating timecode, see “Calibrating Timecode Capture
with Serial Device Control.”

Reel Name Restrictions in EDLs
If you plan to export an EDL, there are restrictions on the reel names you can use. The
restrictions depend on the EDL format you’re using.
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System

Reel name length

Reel name characters

CMX 340

1–253 characters

Numbers only

CMX 3600

8 characters

Uppercase alphabetical characters and numbers

GVG and GVG 4 Plus

6 characters

Uppercase alphabetical characters and numbers

Sony 5000

1–998 characters

Numbers only
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System

Reel name length

Reel name characters

Sony 9100

6 characters

Uppercase alphabetical characters; numbers;
underscore (_)

When you export an EDL, Final Cut Pro automatically changes reel names that aren’t
compatible with the selected EDL format.

Unique Reel Names for Each Tape and Timecode Breaks
Every tape that you capture from should have a unique reel name written on the label.
It’s crucial to enter the correct reel name in the Log and Capture window while logging
new clips to make sure Final Cut Pro requests the right tape during the batch capture
process.
With professional video equipment you can often record tapes with user-programmable
timecode. User-programmable timecode means that a videographer in the field can enter
a starting timecode number from hour 01 to hour 23, which corresponds to the reels
01–23. This reduces the chance of error when logging because the reel number
corresponds to the starting hour of the timecode on the tape. (Professionals rarely shoot
with tapes longer than one hour at a time, so there is seldom more than one hour on a
tape.) This system is only effective if you have fewer than twenty-four source tapes.
Creating your own reel names is especially important when using the mini-DV format.
Mini-DV equipment generally can’t record with user-programmable timecode. As a result,
each mini-DV tape you shoot starts at 00:00:00:00. Also, if you have a timecode break on
your tape, the timecode may reset itself to 00:00:00:00. In this case, you should use a new
reel name for each section following a timecode break on the same tape. For example,
if the first half of the tape goes from 00:00:00:00 to 00:30:00:00 and the second half of
the tape also goes from 00:00:00:00 to 00:30:00:00, you should give each section of tape
a unique reel name.
To identify a tape with timecode breaks using multiple reel names
1 Begin by labeling the tape with a simple reel name, such as 003.
2 For every timecode break on the tape, log a unique reel name, such as 003a, 003b, and
so on, as if each section were a unique tape.

Enter a reel name here.

While batch capturing, when a message appears asking for the next reel (such as reel
003b), you must manually cue the tape to the appropriate position before proceeding
with the capture.
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If you entered the wrong reel name when you logged a clip, you can change the reel
name in the Browser or in the Item Properties window.
To change a clip’s reel name in the Browser
1 Select a clip, then Control-click in the Reel column.
All reel names used in the current project appear as choices in the menu.
Note: To change the reel name for several clips at once, select multiple clips in the Browser.
2 Choose the correct reel name from the shortcut menu.

All selected clips are assigned the new reel name you choose. This information is changed
both in the clips and in the original media files stored on disk.
Important: If you change EDL formats, your reel names may no longer be correct for the
EDL format you selected. Final Cut Pro automatically replaces any incorrect reel assignment
and inserts a note in the EDL indicating the old and new reel names.

Choosing a Timecode Track Used for a Clip
When you export an EDL, the timecode used is determined by each clip’s TC property.
Ordinarily, this is the Source timecode track originally logged and captured with your
media files. If you’re using Auxiliary timecode tracks with your clips and you want to
export an EDL using the Aux 1 or Aux 2 timecode track, simply change the TC property
of the clips to Aux 1 or Aux 2.
For more information about adding or modifying timecode tracks to clips and media files,
see “Working with Timecode.”

Choosing a Sequence Frame Rate
The following sequence frame rates are supported for EDL export.
Sequence timebase (frame
rate)

Timecode rate used in EDL

29.97 fps
30 fps

30 fps

25 fps

25 fps

23.98 fps

24 fps

24 fps

24 fps
24 @ 25 fps

Note: Final Cut Pro always uses the timecode assigned in the sequence’s settings.
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EDL Considerations During Editing
While you edit, keep the following guidelines in mind to ensure successful EDL export:
• Limit the number of edits in your sequence.
• Only use transitions in track V1.
• Join through edits wherever they appear.
• Limit the number of audio tracks you use.
• Don’t rely on audio mix levels.
• Avoid nested sequences and nonstandard video transitions.
• Be careful when using still frames and speed settings.
For details, see the following sections.

Limit the Number of Edits in Your Sequence
Different EDL formats allow for different numbers of edits in your sequence. If your
sequence has more than the allowed number of edits for the selected EDL format,
Final Cut Pro automatically creates additional EDLs, depending on the number of total
events.
The following are the maximum number of edits, or events, allowed in various EDL formats.
• CMX 340, CMX 3600, and Sony 5000: 999
• Sony 9100 and GVG 4 Plus: 9999

Only Use Transitions in Track V1
A superimposed video track, or any track other than V1, is called a key track in an EDL.
Only one key track can be in an EDL, so information for V1 and V2 tracks only appears in
an exported EDL. Transitions in V2 are not allowed in EDLs and are ignored. As an
alternative, you can use opacity keyframes in V2 and export Video Level notes in your
EDL.
Opacity keyframes in the Timeline are translated into values and locations and are listed
as the Key Level in notes in the exported EDL. These values are based on the timecode
of the master tape and are used by a video switcher. Some online systems can translate
these values for automatic use by some switchers, but more commonly the values are
only used as notes for the editor working in an online session.
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Join Through Edits
A through edit is defined as two adjacent clips from the same continuous piece of a media
file. The timecode numbers of the first clip’s Out point and the second clip’s In point are
one frame apart. Unless you have a specific reason for keeping these two clips separate,
you should join the through edit to create a single clip. This reduces the number of events
in your EDL and simplifies the process of re-creating your edit with another editing system.
For more information, see “Cutting Clips and Adjusting Durations.”

Keep Track of Duplicate Frames
You can use the Final Cut Pro duplicate frames indicators to keep track of whether you
use a clip more than once within a single edited sequence. Duplicated frames are marked
by a colored bar appearing at the bottom of the clip’s video item in the Timeline.
If you have warning in advance, you can reedit your sequence to eliminate the duplicates,
if necessary. This is most important for film editing, where duplicating frames is a much
more involved process than with video.
Each separate instance of duplicated frames is color-coded differently. There are six
different colors used to indicate separate sets of duplicated frames: red, green, blue, white,
black, and purple. If there are more than six sets of duplicate frames in your sequence,
these colors are reused.
Note: If a duplicated instance of a clip has variable speed applied to it, no duplicate frames
indicator appears.
You can adjust the parameters that determine when duplicate frames indicators appear
in the Editing tab of User Preferences. For more information, see “Editing Tab.”

Limit the Number of Audio Tracks You Use
Final Cut Pro supports up to 99 tracks of audio in a sequence. However, EDLs support
only two or four tracks of audio, depending upon the EDL and video format you use.
EDL format

Number of audio tracks

CMX 340

2

CMX 3600

4

Sony 5000

2

Sony 9100

4

GVG 4 Plus

4

If your sequence has more than four tracks, you may have to export separate EDLs. A
simple way to do this is to copy your sequence and delete everything except the audio
tracks that weren’t included in the first EDL. Then export an EDL just for the remaining
audio tracks.
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Don’t Rely on Audio Mix Levels
Mixed audio levels, represented by audio overlays in the Timeline, can be exported as
notes in the EDL for the online editor to use as reference. However, most editing systems
can’t translate these notes into an automated mix.

Avoid Nested Sequences
Nested sequences, or sequences within a sequence, should not be used if you are
exporting an EDL. To prevent confusion, you can create a duplicate of your edited
sequence and simplify sections where there are nested sequences.
To replace a nested sequence with its clip content for EDL export
1 Duplicate your edited sequence.
By working with the copy, you can still get back to your original sequence if necessary.
2 Double-click the duplicated edited sequence to open it in the Timeline.
3 Option-double-click the nested sequence in the Timeline so that it opens in the Viewer.
The Viewer now contains the nested sequence and the Timeline contains the edited
sequence.
4 In the Timeline, move the playhead to the first frame of the nested sequence.
5 Press Command-F10.
This is the default keyboard shortcut for the Overwrite Sequence Content command (as
opposed to F10, which performs an overwrite into the Timeline using a nested sequence).
6 Export this sequence as an EDL.

Avoid Nonstandard Video Transitions
Final Cut Pro has many kinds of transitions, but EDLs can recognize only a subset of these
(primarily the cross dissolve and various wipes). If you use other transitions, Final Cut Pro
automatically replaces them with the closest transition type. For more information, see
“Transition Wipe Codes for EDL Export.”

Be Careful Using Still Frames and Speed Settings
If you use still frames, give all of your stills distinct reel names. It’s good to identify the
source clips that are taken from graphic stills.
Keep speed settings to even percentages for optimal results. For example, use 50% speed
rather than 57% speed. If you plan to export your EDL for a tape-based online edit, this
may be important. Some video decks work well at a certain range of speeds for either
slow or fast motion. Ask your online editor for a list of acceptable speeds. Variable speed
adjustments are not supported by most tape-to-tape systems.
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Transition Wipe Codes for EDL Export
In an EDL, each type of wipe transition shape has a unique code. This code is used to tell
a video switcher which shape to use for any given edit. Since many of the transitions in
Final Cut Pro have no equivalent in a given EDL format, all nonstandard transitions are
automatically mapped to the closest approximate SMPTE standard wipe pattern during
the EDL export process.
Note: EDLs were originally developed for older tape-to-tape editing systems with fairly
limited capabilities. Therefore, they are equipped to describe only a narrow variety of
transitions. Although today’s nonlinear editing systems have introduced a much wider
variety of transitions, the EDL format continues to reflect the simplicity of older systems.
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Final Cut Pro transition

EDL wipe number equivalent

Cross Zoom

17

Cube Spin

18

Spin3D

19

Spinback3D

20

Swing

21

Zoom

22

Additive Dissolve

0

Cross Dissolve

0

Dip to Color Dissolve

0

Dither Dissolve

0

Non-Additive Dissolve

0

Ripple Dissolve

0

Cross Iris

12

Diamond Iris

18

Oval Iris

19

Point Iris

12

Rectangle Iris

17

Star Iris

18

Channel Map

0

Luminance Map

0

Page Peel

0

Band Slide

23

Center Split Slide

12

Multi Spin Slide

1

Push Slide

1
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Final Cut Pro transition

EDL wipe number equivalent

Spin Slide

1

Split Slide

3

Swap Slide

2

Cross Stretch

1

Squeeze

3

Squeeze and Stretch

3

Stretch

3

Band Wipe

23

Center Wipe

4

Checker Wipe

23

Checkerboard Wipe

1

Clock Wipe

13

Edge Wipe

2

Gradient Wipe

0

Inset Wipe

4–11

Jaws Wipe

120

Random Edge Wipe

1

V Wipe

115

Venetian Blind Wipe

123
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Using Final Cut Pro XML and
QuickTime Metadata

97

This chapter covers the following:
• What Is the Final Cut Pro XML Interchange Format? (p. 1629)
• About XML (p. 1630)
• Overview of the Final Cut Pro XML Interchange Format (p. 1633)
• Exporting XML in Final Cut Pro (p. 1635)
• Importing XML into Final Cut Pro (p. 1636)
• Working with Metadata in QuickTime Media (p. 1637)
• Controlling Final Cut Pro with Apple Events (p. 1637)
Using the Final Cut Pro XML Interchange Format, you can generate Final Cut Pro project
files on any platform, using any software you want. You can also add, store, and modify
metadata directly in your QuickTime media files.

What Is the Final Cut Pro XML Interchange Format?
By default, Final Cut Pro saves every element of a project, such as clips, bins, and sequences,
in a project file. Although this project file is compact and efficient, you usually can’t open
it in third-party applications. What if you want to transfer all of your log notes to a
spreadsheet application, or an entire sequence along with all of your color correction
settings to another nonlinear editing application? The Final Cut Pro XML Interchange
Format was created so that every detail of your project file can be transferred to a system
that doesn’t recognize native Final Cut Pro projects.
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About XML
XML, or eXtensible Markup Language, is a markup language. Markup languages clarify
the content in a document by tagging the elements of the document. A well-known
markup language is HTML, the standard language for writing webpages. The benefit of
working with XML is that it is an open standard. The structure and rules for working with
XML documents are well documented by the World Wide Web Consortium
(http://www.w3c.org). XML is also quite simple and understandable: you can view an
XML file in any text editing application and even edit its content. Because XML is an open
standard, anyone with sufficient understanding can process an XML document into other
formats, such as plain text, HTML, or even other XML formats.

Tags and Elements
Tagging content gives the content of a document structure and specific meaning. Each
tag defines an element of the document. For example, compare the following excerpts
from a text file before and after tags have been added.
Original text file:
Coffee house wide shot
17
300
Good

Tagged document:
<clip>
<name>Coffee house wide shot</name>
<reel>17</reel>
<duration>300</duration>
<good>TRUE</good>
</clip>

In the original text file, you have to make assumptions about the meaning of the numbers
17 and 300. In the tagged document, the tags clarify that 17 is actually the reel name of
a clip and 300 is the clip duration (in frames).
In XML, elements can contain other elements. In the example above, the <clip> element
encompasses all of the other elements.
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Most markup languages have a limited set of tags and rules about how the elements can
be ordered hierarchically. For example, an HTML document can have a <p> element (this
is a paragraph element) but if you added a <sentence> element, it would not be
recognized by HTML-aware applications unless the entire HTML standard were altered.
XML was designed to be extensible—you can define any tags and hierarchical rules that
fit the data you are working with. For example, an XML file that contains store inventory
data might have elements such as <product>, <manufacturer>, <cost>, and <size>. An
XML file that contains video editing information would have very different elements, such
as <clip>, <name>, <duration>, <logginginfo>, and so on.
XML is a strict markup language, which means all tags must be closed. For example, if
your XML document contains a <clip> tag, there must be a corresponding </clip> tag
to close the element. Unclosed tags create errors.

Attributes of XML Elements
Some elements contain identifying information called attributes. In XML, an element’s
attribute looks like this:
<font color=”red”>
...
</font>

In the example above, the font element has an attribute called color, which is set to “red.”
Alternatively, you could choose to structure your XML format without attributes:
<font>
<color>red</color>
...
</font>

Just as XML tags are extensible, so are attributes. When you define the rules of your XML
file, you can allow elements to have any attributes you want. For example, in the
Final Cut Pro XML Interchange Format, every clip can have an “id” attribute so each clip
can be uniquely identified and referenced:
<clip id=”coffee house 1”>
...
</clip>
<clip id =”coffee house 2”>
...
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</clip>

Whitespace
Whitespace in a document includes multiple spaces, tab characters, carriage returns,
newline characters, and so on. An XML parser reads and processes XML tags in a document,
but ignores extra whitespace. To an XML parser, there is no difference between
<clip><name>Coffee house wide shot</name><reel>17</reel></clip>

and
<clip>
<name>Coffee house wide shot</name>
<reel>17</reel>
</clip>

Whitespace is permitted so you can make your XML file more readable without affecting
the fundamental structure or meaning.

Document Type Definitions
Before you can create an XML document, you need to define the rules of your document:
which elements (tags) can exist, which elements contain other elements, which elements
are optional or required, what attributes each element has, and so on. You define the
rules of an XML document in a Document Type Definition, or DTD. Every markup language
has a DTD so that parsers know how to verify the structure of documents. Without a DTD,
it is impossible for the parser to validate an XML document. Every XML document requires
a DTD.
If you are working with a predefined language, such as HTML or the Final Cut Pro XML
Interchange Format, the DTD has already been created for you. All you need to do is
follow the rules of the DTD to create valid Final Cut Pro XML.

Working with XML Created in Different Applications
XML documents can be used to represent almost any kind of information. Unlike languages
such as HTML, XML has no predefined elements. XML is not one format; rather, XML is
used to create specific XML-based markup languages. Just because an application supports
XML does not mean that it can recognize any kind of XML document. For example, a
database application may use an XML format with elements like <row>, <column>, and
<subtotal>, while a graphics application might store information in elements such as
<layer>, <shape>, and <color>. Even though both documents are XML, they are
incompatible because their Document Type Definitions are completely different.
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Overview of the Final Cut Pro XML Interchange Format
The Final Cut Pro XML Interchange Format was designed to describe every element in a
Final Cut Pro project in a human-readable, XML-based format. Final Cut Pro can import
and export this format, opening a world of possibilities limited only by your ability to
generate and process XML documents.
Because Final Cut Pro supports XML, you are no longer limited to creating clips, bins, and
sequences within Final Cut Pro. You can create your own Final Cut Pro projects outside
of Final Cut Pro, using any software or platform you want, as long as you generate a valid
Final Cut Pro XML file. Even if you don’t want to create Final Cut Pro XML from scratch,
you can practice working with Final Cut Pro XML by exporting a clip or sequence to an
XML file, opening it in a text editing application, making minor modifications, and then
importing the modified XML file back into Final Cut Pro.
For example, if you have 100 clips that all have “Koffee House” in the name, and you want
to change the names to “Coffee House,” you can export the clips to Final Cut Pro XML,
open the XML file in a text editing application, find “Koffee” and replace with “Coffee,”
and then import the resulting XML file back into Final Cut Pro.
You may also want to use XML when working with text generators or superimposed
graphics. For example: You have a sequence with hundreds of subtitle text generators,
and you want to subtly change the color or position of each subtitle. Manually moving
each subtitle in Final Cut Pro would be extremely time-consuming. Instead, you can export
the sequence as XML and then find and replace all of the positional parameters or color
settings at once.
These examples are only the beginning. You can also change clip In and Out points,
change the order of clips in sequences, or modify effect parameters. The more you
experiment, the more potential you will discover for modifying Final Cut Pro elements
using XML.

Main Final Cut Pro XML Elements
This section describes some of the main elements of the Final Cut Pro XML Interchange
Format. Here is an example of a simple Final Cut Pro XML file. The code below represents
a Browser clip whose media file is offline.
<?xml version=”1.0” encoding=”UTF-8”?>
<!DOCTYPE xmeml>
<xmeml version=”4”>
<clip>
<name>Coffee house wide shot</name>
<duration>362</duration>
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<rate>
<ntsc>TRUE</ntsc>
<timebase>30</timebase>
</rate>
</clip>
</xmeml>

An explanation of the sample code above follows.
Every Final Cut Pro XML file requires the first three elements:
• <?xml> element: This defines the document as an XML file. The example above shows
an <?xml> element with two attributes: version and encoding.
• <!DOCTYPE> element: Every XML document requires a Document Type Definition, or
DTD. The DTD for the Final Cut Pro XML Interchange File Format is called xmeml.
• <xmeml> element: This is the root element of every Final Cut Pro XML file. Every
document should end with a closing </xmeml> tag.
The <clip> element defines a Browser clip in Final Cut Pro. The <clip> element above
contains the following elements:
• <name> element: This is the name of the clip.
• <duration> element: This is the duration of the clip, in frames.
• <rate> element: This is the frame rate of the clip. The <rate> element contains a
<timebase> element that determines the clip’s frame rate and an <ntsc> element that
determines whether the clip frame rate is actually 29.97 fps or 30 fps.
For a complete list of Final Cut Pro XML Interchange Format elements, see the
documentation for the Final Cut Pro XML Interchange Format at
http://developer.apple.com/appleapplications.

Example: Creating an XML File and Importing It into Final Cut Pro
Final Cut Pro always exports verbose XML, which means that every element and subelement
is included. However, when you import XML, Final Cut Pro accepts sparse XML, which
means that you only need to provide a limited number of required elements: you can
create fairly terse XML, and Final Cut Pro fills in missing information with default
information.
To create an XML file and import it into a Final Cut Pro project
1 Open a text editing application such as TextEdit.
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Note: This example assumes you are using TextEdit, the built-in text editing application
that comes with Mac OS X. TextEdit is located in the Applications folder on your hard
disk.
2 If a new window doesn’t already exist, choose File > New (or press Command-N).
3 Type or copy and paste sample XML code into the new TextEdit window.
Errors in XML code will result in errors during import. Make sure you type carefully and
check your work.
4 Choose Format > Make Plain Text (or press Command-Shift-T).
This ensures that your file is saved as a plain text file, not a Rich Text Format (RTF) file. The
file extension should become .txt.
5 Choose File > Save.
6 In the Save dialog, navigate to the Desktop.
7 Name the file “example.xml,” then click Save.
If you receive a message about appending .txt to the end of the filename, click Don’t
Append.
8 Open Final Cut Pro.
9 Close any open projects, then choose File > New Project (or press Command-Shift-N).
10 Choose File > Import > XML, navigate to “example.xml,” and click Choose.
The Import XML window appears.
11 Choose the current project name from the Destination pop-up menu.
12 Leave all other settings as they are currently set, then click OK.
A new offline clip named “Coffee house wide shot” appears in the Browser.
If you receive an error message, you should reopen your XML file in TextEdit to make sure
you entered the sample code correctly. Simple typos, such as mismatched beginning and
ending tags, can cause the error “XML translation was aborted due to a critical error.”
Also, make sure your file is a plain text file, not an RTF file.

Exporting XML in Final Cut Pro
You can export clips, bins, sequences, or even an entire Final Cut Pro project as an XML
file.
When you export, Final Cut Pro updates the internal identifiers (UUIDs) of all the clips in
your project. To make sure your project matches the exported XML, Final Cut Pro saves
your project during export, unless you explicitly deselect the “Save project with latest
clip metadata (recommended)” checkbox.
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Important: If your workflow involves exporting and importing XML files, do not customize
column names in Final Cut Pro. Doing so may result in the loss of some XML metadata.
To export a Final Cut Pro element as an XML file
1 In Final Cut Pro, select the clips, bins, or sequences you want to export as XML.
2 Choose File > Export > XML.
The Export XML dialog appears. A summary of the selected elements to be exported is
shown next to the Source field.
3 Choose the version of the Final Cut Pro XML Interchange Format you want to export.
In most cases, you should choose the most recent version. You should only choose an
older version of the Final Cut Pro XML Interchange Format if:
• You need to create an XML file that is backward compatible with an older version of
Final Cut Pro
• You have XML processing code or a third-party application that only recognizes an
older version of the Final Cut Pro XML Interchange Format
4 Select the Include Master Clips Outside Selection option if you want the master clips for
a sequence to be exported within the XML file.
The Include Master Clips Outside Selection option is useful when you select a sequence
or sequence clips for export. For more information about master clips, see “Working with
Master and Affiliate Clips.”
5 If you do not want to save your project file at the same time you export XML, deselect
the “Save project with latest clip metadata (recommended)” checkbox.
6 Click OK.
7 Choose a name and destination for the XML file, then click Save.
Note: Some applications may require an .xml extension at the end of the filename, so
you may want to add this just in case.

Importing XML into Final Cut Pro
You can generate Final Cut Pro XML files with your own applications and then import
them into Final Cut Pro. When you import XML into Final Cut Pro, clips, bins, and sequences
are automatically generated within Final Cut Pro. You can import your clips into a currently
open project or into a new project.
To import an XML file into Final Cut Pro
1 In Final Cut Pro, choose File > Import > XML.
2 Navigate to the XML file on your hard disk, then click Choose.
3 In the Import XML dialog, select the options and settings appropriate to your XML file.
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The XML import options are described in detail in the Final Cut Pro XML developer
documentation. For more information, visit the Apple Applications page at the Apple
Developer Connection website at http://developer.apple.com/appleapplications.
4 Click OK.
The Importing XML Data progress bar appears as Final Cut Pro processes the XML and
generates clips, bins, or sequences from the XML file.

Working with Metadata in QuickTime Media
Final Cut Pro allows you to add, store, and remove metadata elements within QuickTime
movie files. Any metadata stored in a QuickTime movie that Final Cut Pro uses is:
• Accessible and modifiable via the Final Cut Pro XML Interchange Format
• Maintained by Media Manager Copy, Move, and Remove Unused operations
• Maintained when using the Export QuickTime Movie command
Metadata is also cached within Final Cut Pro project elements so that it is still available
via the Final Cut Pro XML Interchange Format when a media file is offline. After adding
or changing metadata within Final Cut Pro project elements, you can update metadata
in the corresponding QuickTime media files using the Reconnect Media command.
Note: Although QuickTime metadata can be stored in a QuickTime media file and cached
in a Final Cut Pro project, custom metadata is not directly accessible within Final Cut Pro
windows such as the Browser or the Item Properties window.
For more information about working with metadata within QuickTime movies, go to
http://developer.apple.com/appleapplications.

Controlling Final Cut Pro with Apple Events
Final Cut Pro responds to custom Apple events, allowing developers to write software
that can externally modify projects, clips, and sequences directly within Final Cut Pro. By
combining Apple events and the Final Cut Pro XML Interchange Format, you can easily
customize Final Cut Pro to fit your post-production pipeline. For details about custom
Apple events, go to http://developer.apple.com/appleapplications. Apple events
documentation can also be found in an appendix of the Final Cut Pro XML Interchange
Format documentation.
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Remote Previewing with iChat

98

This chapter covers the following:
• About iChat Theater Preview and Final Cut Pro (p. 1639)
• Initiating an iChat Theater Preview Session (p. 1642)
• Using iChat Theater Preview (p. 1643)
As you collaborate with post-production colleagues or clients, you can use the Final Cut Pro
iChat Theater Preview feature to screen parts of your work to remote viewers. After setting
up an iChat video session, you can use the Canvas or Viewer window to stream clips and
sequences to other iChat users for viewing. You use the standard playback and navigation
controls to play and review clips or sequences and the iChat users see them in their iChat
window.
This section explains the procedures for using iChat Theater Preview with Final Cut Pro.
For general information about using iChat , including setting up and monitoring video
chat sessions, see iChat Help. To open iChat Help, open iChat, then choose Help > iChat
Help.

About iChat Theater Preview and Final Cut Pro
During post-production, you can collaborate with colleagues working on a project or
share the results of editing decisions with others at different locations. By setting up a
video chat session with someone on a remote computer, you can initiate an iChat Theater
Preview session and have Final Cut Pro stream video to the remote user’s computer screen.
To use the iChat Theater Preview feature:
• Both the host computer playing the video and the remote computer receiving it must
have Mac OS X version 10.5 Leopard or later.
• Both computers must have iChat accounts and the remote user’s account must be
added to the host computer’s buddy list.
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• To hold a video chat session in which you and your iChat buddy can chat and see each
other, both computers must have a video camera, such as the Apple iSight, attached
or built in to the computer. If the host or remote computer doesn’t have a video camera,
you can still use Final Cut Pro to send video by inviting the remote viewer to a one-way
video chat session, but you will not be able to see or chat with the remote viewer as
you can during a video chat session with cameras.
• The host computer must have Final Cut Pro 7, although the remote computer using
iChat does not require it.
• Both computers require a network connection that is fast enough to support a video
iChat session.
During an iChat Theater Preview session, the remote user’s iChat window displays the
media being played in the host’s Viewer or Canvas window and an inset of the remote
user’s camera image, similar to the image shown below. The remote user can talk to the
host user and view the playback simultaneously.

The host user’s iChat window displays the video sent from the remote computer, and an
inset of the video being played in the Viewer or Canvas window, similar to the image
shown below. Final Cut Pro streams the video played in the host’s active Viewer or Canvas
window.
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Note: Your iChat window may look slightly different from the illustrations shown here,
depending on the version of Mac OS X that you are using on your computer.

As you host a video chat session using iChat Theater Preview, you can play clips or
sequences in the Timeline in the Canvas window. You can also open specific clips in the
Viewer and play them for the remote viewer. You can switch between displaying video
from the Viewer or Canvas by clicking the window you want to make active. You can also
have multiple Viewer windows open and use them to show a different clip or versions
of a clip. For example, you can open three Viewer windows, each holding a different
version of a clip, and then play each window one at a time for the remote viewer to
compare.
The frame displayed in the Viewer or Canvas appears in the remote viewer’s iChat window.
In Final Cut Pro, you can stop clips and reposition the playhead on specific frames to
discuss them. You can also have Final Cut Pro display the timecode of the current frame
in the remote iChat window to help you identify specific frames. If you wish, you can
control the volume of your video using the Audio Mixer. If you make another application
active other than Final Cut Pro, a pause overlay appears in the remote viewer’s iChat
window.
During an iChat Theater Preview session, the streaming of the Final Cut Pro video is
optimized for viewing in an iChat window. The video is streamed at a lower, optimized
frame rate, formatted to fit the iChat window. Overlays and warnings or messages, such
as alerts about dropped frames during playback, are turned off. During the session, the
external video, video playback, and audio playback commands are unavailable in
Final Cut Pro.
The actual video playback performance that the remote user sees can be affected by
several factors, including the speed of the network connection, the processing speed and
power of the host and client computers, and the processing power required to play back
video in a specific format.
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For optimal playback performance during an iChat video session:
• Ensure that you’re using a stable network connection with sufficient bit rate for video
iChat sessions. Refer to iChat Help for more information about setting up video chat
sessions.
• Ensure that both the host and client computers have sufficient CPU and GPU processing
power.
• On the host computer, set Final Cut Pro to use Unlimited RT mode and render segments
that require rendering for optimal playback. You can also set the playback rate to half
the standard rate to reduce the overall playback processing of Final Cut Pro. You can
also choose to lower the RT playback quality.
• On the host computer, make sure that Final Cut Pro and iChat are the only applications
open. On the client computer, make sure that iChat is the only application open.
When using Final Cut Pro to host a video chat session, it’s recommended that you turn
off or disconnect any video camcorder connected to your computer to prevent any
potential video output conflicts. If you’re having problems using iChat, you can open
iChat Preferences to check whether the video cameras are being recognized correctly by
iChat. If you’re having problems during an iChat Theater Preview session with Final Cut Pro,
it’s recommended that you check whether you can establish a standard video iChat
session to determine whether the issue is with iChat or with Final Cut Pro iChat Theater
Preview.
Note: When hosting an iChat Theater Preview session, it’s recommended that you remind
the remote viewers that their display or external monitor may not be using the same
color settings, and so there may be visual differences between the host and remote
images.

Initiating an iChat Theater Preview Session
To initiate an iChat Theater session in Final Cut Pro
1 Open iChat and sign in.
2 Open Final Cut Pro and the project that holds the video you want to preview using iChat.
3 Open the clip or sequence that you want to play for the other iChat user in the Viewer
or Canvas window. Position the playhead where you want the video playback to begin
and make the Viewer or Canvas window active.
4 Choose View > iChat Theater Preview > Start Sharing.
The iChat application becomes active so that you can invite a buddy to a video chat
session.
5 Send a video chat invitation to the iChat buddy with whom you want to share video. If
the host or remote computer doesn’t have a camera, send a one-way video iChat invitation.
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Once you’ve established a video iChat session, you’re ready to use Final Cut Pro to
broadcast your video to remote viewers.
Note: You can actually choose any of the commands in the iChat Theater Preview menu
to initiate an iChat Theater Preview session.
When both computers have cameras connected, you can also begin by first starting a
video chat session using standard iChat procedures. You open iChat and send a video
chat invitation to an iChat buddy and, when you’re ready, switch to using Final Cut Pro.
When you start the iChat Theater Preview session in Final Cut Pro, the content in the
active Canvas or Viewer window appears in the remote iChat user’s window. For
information about initiating a video iChat session and sending invitations, see iChat Help.
iChat Help provides instructions for monitoring video connections, controlling video
playback, muting video, and starting up and ending video chat sessions.

Using iChat Theater Preview
Commands for using iChat Theater Preview are located in the View menu. In addition to
choosing iChat Theater Preview commands from the View menu, you can also place iChat
Theater Preview buttons in the Canvas, Viewer, or Timeline button bars for convenient
access to the commands. If you frequently use the iChat Theater Preview feature, you’ll
find that adding the iChat Theater Preview buttons to your button bar is an easy way to
initiate and control an iChat Theater session. You can also look at the state of the buttons
in the button bar to quickly determine which features are turned on.
You can temporarily pause and resume the sharing of your video during an iChat Theater
Preview session.

µ

To pause the iChat Theater Preview session
Choose View > iChat Theater Preview > Pause Audio/Video.
When the host has paused an iChat Theater Preview session and the video chat session
is still in progress, the host audio is still being sent to the remote iChat user. To stop the
audio from being sent, choose Video > Mute from the iChat menu.

µ

To resume an iChat Theater Preview session
Choose View > iChat Theater Preview > Resume Audio/Video.
During an iChat Theater Preview session, you can turn on the display of the current
timecode on both iChat users’ screens.

µ

To turn on the display of the current timecode during an iChat Theater Preview session
Choose View > iChat Theater Preview > Show Timecode.

µ

To turn off the display of the current timecode during an iChat Theater Preview session
Choose View > iChat Theater Preview > Hide Timecode.
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When you’ve completed reviewing your clips and sequences, you stop the iChat Theater
Preview session. Final Cut Pro stops streaming video from the Viewer or Canvas window,
but does not stop the video chat session.

µ

To stop the iChat Theater Preview session
Choose View > iChat Theater Preview > Stop Sharing.
When the host has paused an iChat Theater Preview session and the video chat session
continues, remember that the host audio is still being sent to the remote iChat user. To
stop your audio from being sent, choose Video > Mute from the iChat menu bar.
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Working with Film and
Cinema Tools

99

This chapter covers the following:
• An Overview of the Film Editing Process (p. 1645)
• About Using Cinema Tools with Final Cut Pro (p. 1648)
• Creating a New Final Cut Pro Project (p. 1649)
• Importing a Telecine Log to Create a Cinema Tools Database (p. 1649)
• Batch Capturing Video from Tape (p. 1651)
• Removing 3:2 Pull-Down or Conforming 25 fps PAL to 24 fps (p. 1651)
• Synchronizing Clips with the Cinema Tools Database (p. 1654)
• Editing Clips in Final Cut Pro (p. 1656)
• Using Edge Code Overlays and Feet+Frame Rulers (p. 1656)
• Opening Final Cut Pro Clips in Cinema Tools (p. 1658)
• Exporting Film, Change, and Audio Lists (p. 1659)
You can use Final Cut Pro with Cinema Tools to edit film and 24 fps-based projects.

An Overview of the Film Editing Process
Traditionally, working with film required a lot of manual labor: making physical splices in
film, sifting through cluttered film bins, spooling reels, and meticulously labeling film
footage. To simplify this process, pioneering filmmakers looked to the digital breakthroughs
in video post-production. Many filmmakers now believe that the best approach is to
eliminate film altogether and replace it with high definition video, whose quality rivals
that of film. For those who continue working in film, they must first transfer their footage
to video before they can enjoy the benefits of digital video editing. This process of
transferring film to video, called the telecine process, is where Cinema Tools enters the
workflow. Once a video sequence is edited, an editor must go back to the original film
negative and cut it so that it matches the video. Using the information gathered during
the telecine session, Cinema Tools considerably speeds up this final conforming process.
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The following information provides an overview of the film editing process, identifying
the parts played by Final Cut Pro and Cinema Tools.

About the Telecine Process
During a telecine session, sections of film rolls are transferred to videotape or directly to
a hard disk. A computer file, known as a telecine log, keeps track of which film frames are
transferred to video.
In addition to keeping track of the film frame-to-video frame relationship, the telecine
log also contains scene and take number information, film format and speed, and, if the
audio is synchronized to the video during the telecine process, the audio timecode from
the master audio source.
About Edge Code
Both film and video record frames and produce large numbers of frames over time. Editors
and editing machines need to find frames efficiently and reliably, so film and video both
have ways to uniquely count and identify frames. Film uses edge code, which can be
KeyKode (developed by Kodak and also known as keycode) or ink numbers printed on
the edge of the film. Video uses timecode, stored in a timecode track.
Both edge code and timecode are based on simple frame counters: each time a frame
advances, the frame counter increases by one. But the similarity ends there. Edge code
equates frames with film length, so a certain number of frames equals a foot (thus the
origin of the word footage). Timecode equates frames with time—for example, in PAL
video, 25 frames equals one second.
Edge code looks like this:
KJ 29 1234 5678+02

The first eight characters (KJ 29 1234) identify the film manufacturer and include an
identification number for the film roll. The final six numbers (5678+02) actually identify
specific frame numbers. The first four numbers (5678) are the footage count (the number
of feet of film), with the last two numbers (+02) counting the frames for that foot of film
(16 frames with 4-perf 35mm, the most common film format).
Timecode looks like this:
01:24:08:14

Timecode numbers represent hours, minutes, seconds, and frames, respectively.
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About Burned-in Timecode on Video
Most telecine facilities offer the ability to permanently superimpose, or burn in, edge code
and timecode numbers over your video transfer from film. This is useful whether or not
you have a telecine log file:
• If you have a telecine log file: The burned-in numbers make it easy to verify that the
entries in the database are correct. Additionally, in cases where the video has had a 3:2
pull-down applied, letters are added after the key number to indicate the frame type.
This helps when configuring the reverse telecine process, which removes the added
frames and restores the video to its original film frame rate.
• If you don’t have a telecine log file: The burned-in numbers make it much easier to
manually enter the records in the Cinema Tools database.
If you do not have burned-in numbers, you generally have to use a list that matches up
with hole-punched film frames at the head of each clip.
A consideration regarding using video with burned-in numbers is whether the final edited
video will be shown to others. If not, having the burned-in numbers is very helpful and
they should be included. If it is going to be shown, you may want to have the telecine
facility use a 2.40:1 aspect ratio, which leaves sufficient blank space to place the numbers
without covering up any video. Alternatively, if the edited output is to be used as a clean
master, you can choose to have the burned-in numbers appear only on the first frame
of each clip.

Importing a Telecine Log to Create a Cinema Tools Database
Each time a shot is transferred from film to video during a telecine session, an entry is
made in the telecine log, containing the edge code start number and the corresponding
timecode start number on video. The ending edge code and timecode numbers are also
recorded. When you import a telecine log, Cinema Tools creates a database that tracks
the relationship between video clips in Final Cut Pro and your original film footage. As
you edit, you refine video clip start and end times. At any time, Cinema Tools can use the
information in the database to map a video clip start or end time in Final Cut Pro to the
corresponding edge code of the original film.

Exporting a Film Cut List
In basic terms, a Final Cut Pro sequence is a series of start and end timecode values from
different source tapes. A film sequence is similar: a series of start and end edge code
numbers from various film reels. When you finish editing your sequence in Final Cut Pro,
you need to generate a list of edge code start and end times, known as a cut list, so that
a film negative cutter can match the sequence you created in Final Cut Pro. As long as
you properly created a Cinema Tools database before you started editing, generating a
cut list is easy.
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About the Cinema Tools Database
A Cinema Tools database is the heart of any Final Cut Pro film editing project. The database
is similar to a spreadsheet in which each row represents a single clip shot on film and
transferred to video. Each row contains columns such as name, edge code start, edge
code end, timecode start, timecode end, film roll number, video reel number, scene
number, take number, camera information, and so on. These numbers map your
Final Cut Pro clips and media files back to the original film footage so you can create film
cut lists from video footage edited in Final Cut Pro.

About Using Cinema Tools with Final Cut Pro
You can edit most projects directly in Final Cut Pro without needing to open Cinema Tools.
When necessary, Cinema Tools may open in the background to create or update a database
file. If necessary, you can always open Cinema Tools to directly manage specific fields in
a database, such as to correct inaccurate edge code numbers.
Steps Performed from
Final Cut Pro

How Cinema Tools
Is Involved

Create a new
Final Cut Pro project

Import a log into the
Final Cut Pro project,
creating the offline clips
for capture

A new Cinema Tools
database is created

Batch capture clips

Process clips (if needed)
• Reverse telecine
• Conform (25 @ 24)

Cinema Tools
does the processing

Synchronize captured clips
with Cinema Tools database

The clips are connected to
the Cinema Tools database

Edit clips

Export lists
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Creating a New Final Cut Pro Project
In almost all cases, you will edit your film project using a 24 fps (or 23.98 fps in most
NTSC-based workflows) editing timebase. An exception is film projects shot at 24 or 25 fps
and edited at PAL’s 25 fps rate.
To create a new project in Final Cut Pro
1 Choose File > New Project.
A new project is created with the default name of Untitled Project 1.
2 Choose File > Save Project As.
A dialog appears where you can name the project and select a location to save it to.
3 Click Save.

Importing a Telecine Log to Create a Cinema Tools Database
You can import a telecine log file, which is usually either a Flex file or an Avid Log Exchange
(ALE) file, into Cinema Tools or import it directly into Final Cut Pro. (Importing the file into
Final Cut Pro requires fewer steps.) When you import the log file into Final Cut Pro:
• Offline clips are created for each telecine log entry, and each entry has all film-related
information, such as edge code and camera roll numbers, added to it. (If you import
the log file into Cinema Tools, you will have to export a batch capture file to import
into Final Cut Pro.)
The names of the clips are based on the scene and take information from the log file.
Additionally, you are able to append a camera letter to clip items if there were multiple
cameras involved in a shoot.
• You choose whether to create a new Cinema Tools database or to import the records
into an existing database.
To import a telecine log file into Final Cut Pro
1 Choose File > Import > Cinema Tools Telecine Log.
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The Import a Cinema Tools Telecine Log dialog appears.

Select the telecine log
file to import.

Choose a camera letter to
append to the imported
takes (if needed).

Lists the currently
selected database.

Choose to either create
a new database or
import the file into an
existing database.

2 Use the top half of the dialog to select the telecine log file to import.
3 To assign a camera letter to the imported records, select the “Append a camera letter”
checkbox and choose a camera letter from the pop-up menu.
4 Do one of the following:
• Click New Database to create a new Cinema Tools database to import the telecine log
file into. This opens a new dialog where you can enter a name and location for the
database, as well as configure its default settings. See the Cinema Tools User Manual,
available in Cinema Tools Help, for information on these settings. Click Save when
finished.

• Click Choose Database to open a dialog where you can select an existing database to
import the telecine log file records into. Click Open when finished.
The selected database, whether new or previously existing, is listed in the Database
field of the Import a Cinema Tools Telecine Log dialog.
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5 Click Open to import the selected telecine log file into the selected Cinema Tools database.

Batch Capturing Video from Tape
Once you have imported the telecine log file, you have offline clips in the Browser that
you need to capture. You can use standard Final Cut Pro capture methods for capturing
the clips; however, there are some special considerations you should be aware of.
• The clips may already be captured: Some telecine facilities will capture the clips for you,
delivering them as files on a disc or FireWire drive, and often will also include a
Cinema Tools database.
• Clip quality: An important decision depends on what you are going to do with the
edited video. If your goal is to go back and conform the original camera negatives
based on your edits, the quality of the video is not very important, and you can capture
your clips at a low quality, with smaller files and easier handling. If you need to show
the edited video to others, you will want to use better quality. If you intend to deliver
the edited video for primary viewing or broadcast, you will want to capture high-quality
clips. See “About Burned-in Timecode on Video” for more information.
• Hardware pull-down removal: Often the telecine process will add a 3:2 pull-down to
the video to convert the film’s 24 fps to NTSC’s 29.97 fps. To improve editing accuracy,
you need to reverse the 3:2 pull-down and restore the film’s video to its original 24 fps.
Some video interfaces include the ability to remove 3:2 pull-down during capture. If
your video interface does not support that feature, you can reverse the 3:2 pull-down
after you have finished capturing the clips.
For details about batch capturing clips, see “Capturing Video from Tape.”

Removing 3:2 Pull-Down or Conforming 25 fps PAL to 24 fps
Once you have captured the clips, you may need to process them before editing. In most
cases, you should edit clips at the same frame rate as your original footage (23.98 fps,
24 fps, or in PAL countries, sometimes 25 fps). This ensures that any film lists you export
will be accurate. It also helps with synchronizing the audio to the video clips, avoiding
having to modify its speed.
There are two common issues with your clips that you can correct while working in
Final Cut Pro:
• Removing the 3:2 pull-down added to NTSC video (a process called reverse telecine)
• Conforming 25 fps video to 24 fps for PAL projects using 24 fps film
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Standard Reverse Telecine
The telecine process adds duplicate video fields to make 24 fps film footage fit within
29.97 fps video. The film-to-NTSC video case is particularly complex: the film is slowed
from 24 to 23.98 fps during the telecine process to match the discrepancy between 30
and 29.97 fps. Simultaneously, film frames are repeated in a 3:2 pattern, resulting in
duplicate video fields. Once your video footage is captured to disk, you need to perform
a reverse telecine operation to remove the 3:2 pull-down. You can perform the reverse
telecine operation on media by choosing Tools > Cinema Tools Reverse Telecine.
Although you can initiate the reverse telecine process in Final Cut Pro, Cinema Tools
actually performs the task. If you perform reverse telecine in Cinema Tools, more options
are available than in Final Cut Pro. Final Cut Pro always uses the last settings that were
used in Cinema Tools. You should always perform reverse telecine on a clip directly in
Cinema Tools to verify the proper settings before batch processing clips using Final Cut Pro.
Important: Performing reverse telecine using Final Cut Pro modifies a clip’s original media
file—you do not have the option of creating a new media file as you do when using
Cinema Tools. Also, you must have read-and-write privileges for the media files you want
to process.
To use Final Cut Pro to start the Cinema Tools reverse telecine process
1 In the Browser, select the clips you want to process.
Note: Only files using a 29.97 fps rate will be processed.
2 Choose Tools > Cinema Tools Reverse Telecine.
Cinema Tools opens and performs the reverse telecine operation, displaying a dialog that
shows the task’s progress.

Removing Advanced Pull-Down
Advanced pull-down is an in-camera or in-deck method of embedding 23.98 fps video
within 29.97 fps video. It uses the same principles as traditional film-to-video telecine 3:2
pull-down, but it uses a slightly more complex 2:3:3:2 pattern that is more efficient for
computer editing systems to remove. Advanced pull-down is used in video recording
systems to achieve 23.98 fps within a 29.97 fps format. Film is not transferred using
advanced pull-down. Formats that support advanced pull-down include Panasonic DV,
DVCPRO, DVCPRO50, and DVCPRO HD. Because film is not involved, Cinema Tools is not
necessary when working with this kind of footage.
Note: Many of these video camcorders also have a traditional 3:2 pull-down mode. If your
goal is to edit at 23.98 fps, there is no value in using this mode because you can’t take
advantage of advanced pull-down removal in Final Cut Pro. If you accidentally shoot in
this mode and you want to remove the pull-down, you will have to use the Cinema Tools
Reverse Telecine feature.
For more information, see “Working with 24p Video.”
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Conforming 25 fps Video to 24 fps
In countries that use PAL video, film is sped up by four percent (from 24 to 25 fps) and
then transferred to PAL video. You can capture and edit the PAL footage and then deliver
a 25 fps EDL (instead of a traditional cut list) to the negative cutter, who matches the
25 fps timecode back to the original film edge codes.
However, one of the problems with the method described above is that the original audio
is four percent slower than the PAL video containing the sped-up film footage, so you
can’t match the audio to your video in Final Cut Pro. To avoid this problem, you can use
the Conform 25 to 24 command to slow your PAL video footage back to 24 fps. Unlike
reverse telecine, which must actually remove fields or frames of video, the Conform 25
to 24 command simply slows the duration of each frame by four percent so that the
footage plays back more slowly at the film’s original 24 fps rate.
To conform a 25 fps clip to 24 fps in Final Cut Pro
1 In the Browser, select one or more clips you want to conform from 25 fps to 24 fps.
2 Choose Tools > Conform 25 to 24.
The clips are conformed to 24 fps.
If any of the selected clips are not 25 fps, a warning appears stating that one or more
clips will not be processed.
Important: Conforming a clip modifies the original media file. If you need to undo the
conform process, you must use the Conform feature in Cinema Tools. Additionally, you
must have read-and-write privileges for the media files you want to conform.
About 24 @ 25 Timecode
Conforming 25 fps video to 24 fps does not alter the 25 fps timecode of your PAL footage,
so this command creates an unusual media format in which the video rate is 24 fps (the
original rate of the film) and the timecode rate is 25 fps (the original timecode numbers
from your PAL videotape). When you conform 25 fps media files to 24 fps, the media file
timecode rate is defined as 24 @ 25. You can verify the timecode rate for a clip in the TC
Rate Browser column or in the Item Properties window.
24 @ 25 timecode makes it easy to work at 24 fps but retain 25 fps timecode throughout
your edit. You can then export a 25 fps EDL that matches your PAL video footage and
therefore can be matched by a negative cutter to the original film edge code.
Note: Because the editing timebase and playback are based on 24 fps, the 25 fps timecode
no longer accurately represents the true passage of time. For example, 38 seconds of
video (as defined by its 25 fps-based timecode) will actually take 40 seconds to play.
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Creating 24 @ 25 Sequences and Easy Setups
To properly edit 24 @ 25 clips, you need to create a sequence with an editing timebase
of 24 fps and set the timecode rate of this sequence to the special 24 @ 25 option. This
option displays 25 fps timecode in your sequence as though you were editing PAL video,
but the sequence plays back at 24 fps.
There are two sequence presets designed for 24 fps PAL video:
• DV PAL 48 kHz - 24 @ 25: This preset uses a 24 fps editing timebase and 25 fps timecode.
When you export an EDL from a sequence with this sequence preset, 25 fps timecode
values are used. This method is more common and should be used when you intend
to export a 25 fps EDL for the negative cutter, instead of a cut list.
• DV PAL 48 kHz - 2: This preset does not support 24 @ 25 editing. Instead, both the
editing timebase and the sequence timecode are 24 fps. This method should only be
used when you intend to export a cut list from your 24 fps PAL project.
You can use the DV PAL 24 @ 25 Easy Setup included with Final Cut Pro, or you can create
your own 24 @ 25 sequence preset if you are working with a format other than DV.

Synchronizing Clips with the Cinema Tools Database
When you import a telecine log file into your Final Cut Pro project, a new Cinema Tools
database is created with a record for each clip. You can also add new records to an existing
database manually. In either case, once you have captured and processed clips in
Final Cut Pro, you can connect them to a Cinema Tools database using the Synchronize
with Cinema Tools command.
You can use the Synchronize with Cinema Tools command to do the following:
• Connect clips to a Cinema Tools database: Cinema Tools will automatically connect any
correctly named clip (whose name matches the scene and take entries) with its record,
as long as the record is not already connected to a clip.
• Update the film-related information that appears in Final Cut Pro: You cannot change the
film-related information, such as key numbers or telecine film speed (TK speed), in
Final Cut Pro—these changes must be made in Cinema Tools. If you change any records
in Cinema Tools, you can use the Synchronize with Cinema Tools command to update
the information in Final Cut Pro to reflect those changes.
Note: Final Cut Pro can display film-related metadata in a variety of ways, including as
columns in the Browser and as keycode and ink number values in the Viewer and
Canvas. For more information, see the Cinema Tools User Manual, available in
Cinema Tools Help.
To synchronize Final Cut Pro clips with a Cinema Tools database
1 Select the clips in the Final Cut Pro Browser that you want to synchronize with a
Cinema Tools database.
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You can select clips that are already connected to the database and need their information
updated or clips that are not yet connected to the database.
2 Choose Tools > Synchronize with Cinema Tools.
A dialog appears allowing you to configure the synchronization process.

The Database field shows the currently selected database.
3 Select the “Add new records” checkbox if you want the database to automatically have
new records added for selected clips that are not already in the database.
This checkbox must be selected when you are synchronizing with a new database.
4 Select the “Auto connect” checkbox if you want the database to automatically connect
the clips to any new records that are created in the database.
5 Do one of the following:
• If the database shown in the Database field is the correct one, click OK. The Database
field updates if you use the New Database or Choose Database button.
• Click New Database to create a new Cinema Tools database. This opens a new dialog
where you can enter a name and location for the database, as well as configure its
default settings. See the Cinema Tools User Manual for information on these settings.
Click Save when finished.

• Click Choose Database to choose an existing database. This opens a dialog where you
can select an existing database to synchronize with. Click Open when finished.
6 If you used either the New Database or Choose Database button, click OK.
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Cinema Tools first checks the database for existing records without connected clips and
attempts to match the records with clip names (based on scene and take entries). If
matches are found, Cinema Tools connects the clips to the matching records. If no
matching records are found, new records are added to the database for each clip, with
any applicable information added to each record.

Editing Clips in Final Cut Pro
When you are editing a film-based project that you intend to conform the original camera
negative to, consider the following:
• When Cinema Tools is installed, Final Cut Pro includes a variety of Easy Setups intended
to be used when editing 24 fps–based media. Most of these Easy Setups have
“Cinema Tools” in their names. (An exception is the DV PAL 24 @ 25 Easy Setup.)
Note: Most Cinema Tools Easy Setups use a frame rate of 23.98 or 24 fps. To quickly
view available Cinema Tools Easy Setups in the Easy Setup dialog, choose 23.98 or
24 fps from the Rate pop-up menu.
• Each film list is based on one of the video tracks. You choose the video track to base
the film list on in the Export Film Lists or Export XML Film Lists dialog.
• Effects and transitions in your sequence must be re-created optically or digitally on
film. You can use Final Cut Pro in the creative process to determine and demonstrate
the effects you want, but don’t spend too much time creating elaborate effects unless
you have a separate workflow in place to match these effects on film.
• You need to keep track of duplicate usages of your source material. Because you have
only one original camera negative, you need to either avoid using any of the material
more than once (including allowing for frames, known as cut handles, used by the
splicing process when conforming the negative) or create a duplicate list (“dupe list”)
to give to your lab as part of a duplicate negative order.
See the Cinema Tools User Manual, available in Cinema Tools Help, for details about all of
these editing issues.

Using Edge Code Overlays and Feet+Frame Rulers
Final Cut Pro can display edge code overlays in the Canvas and Viewer, as well as
Feet+Frame rulers in the Timeline and other timecode fields. You are not required to use
these features to edit film footage in Final Cut Pro, but they can help you feel as though
you were working with film instead of film transferred to video.

Showing Film-Related Information in the Item Properties Window
The Film tab of the Item Properties window contains the film-related information for each
clip.
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To see film-related information in the Item Properties window
1 Select the clip in the Browser.
2 Do one of the following:
• Choose Edit > Item Properties > Film.
• Control-click the clip, then choose Item Properties > Film from the shortcut menu.
• Press Command-9 to open the Item Properties window, then click the Film tab.
Note: Comments added to a record in Cinema Tools or a record in a telecine log file
appear in the Take Note row.

Showing Film-Related Information in the Browser
You can add columns to the Browser to show the specific film-related information you
require.
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To add columns to the Browser
Control-click the heading for the column before which you want to insert the new column,
then choose the column to add from the shortcut menu.
Note: Comments added to a record in Cinema Tools or a record in a telecine log file
appear in the Take Note column.

Showing Film-Related Overlays in the Viewer and Canvas
You can configure the Viewer and Canvas overlays to show a clip’s keycode and ink
numbers in addition to the timecode.
To show film-related overlays in the Viewer and Canvas
1 Click in the Viewer or Canvas to make it active.
2 Choose View > Show Overlays (or press Option-Control-W), so there is a checkmark next
to it.
3 To configure the overlay, choose View > Timecode Overlays to see a list of items you can
display. Choose an item to either display or hide it. (Checkmarks appear next to items
that are shown.)

Showing Film-Based Frame Counts
You can set a project’s timecode display format to a Feet+Frame mode, giving film editors
a more familiar way to judge project length. This setting affects the time display along
the top of the Timeline, as well as the timecode fields along the top of the Viewer and
Canvas.
To set a project to display the Feet+Frame mode
1 Select the project’s tab in the Browser.
2 Choose Edit > Project Properties.
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The Project Properties dialog appears.

3 Choose Feet+Frame from the Time Display pop-up menu.
4 Choose the film standard from the Default Film Standard pop-up menu. The film standard
defines how many frames are in a foot.
You can also individually control the timecode display of the Timeline, Viewer, and Canvas.
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To change the timecode display of the Timeline, Viewer, or Canvas
Control-click a timecode field in the window whose timecode display you want to change,
then choose the mode from the shortcut menu.
For the Viewer and Canvas, this affects both timecode fields along their tops, and in the
case of the Viewer, the timecode fields of its tabs. For the Timeline, this affects the
timecode shown along the top of the window and in the Current Timecode field. The
timecode displays in the Transition Editor and Trim Edit windows are also affected.
Important: The feet and frame values that are shown are not the same as keycode or ink
numbers. The feet and frame values always start at 0000+00 at the beginning of the
sequence or clip.
When using the Feet+Frame timecode display mode, you can enter values in the same
places you can enter timecode values. For example, you can enter a value in the Current
Timecode field of the Viewer to position the playhead in the Timeline. To ensure the
number you enter is correctly interpreted by Final Cut Pro, make sure to use one of the
following characters to separate the feet and frame values: Plus Sign (+), Ampersand (&),
Period (.), or Comma (,).

Opening Final Cut Pro Clips in Cinema Tools
You cannot directly change any items in a Cinema Tools database while in Final Cut Pro.
However, you can open a clip in Cinema Tools from Final Cut Pro to make changes to
that clip’s database record. Once you have done this, you need to synchronize that clip
with the Cinema Tools database so that the changes appear in Final Cut Pro.
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To open a clip in Cinema Tools from Final Cut Pro
1 Select a clip or a group of clips in the Browser.
2 Choose View > Open in Cinema Tools.
The clip opens in a Cinema Tools Clip window. If you selected multiple clips, each opens
in its own Clip window. Any changes you make, such as to a camera roll number, are
added to the clip’s database record.
After you have finished making the changes, you can synchronize the clips in Final Cut Pro
with the modified Cinema Tools database. See “Synchronizing Clips with the Cinema Tools
Database” for more information.

Exporting Film, Change, and Audio Lists
Once you finish editing a sequence in Final Cut Pro, you can export a film cut list or audio
edit list. Final Cut Pro sends the video timecode and clip information to Cinema Tools,
which then opens the appropriate database and maps the timecode back to corresponding
edge code numbers.

About Film Lists
A film list contains one or more lists describing your Final Cut Pro sequence in terms
relevant to a negative cutter or film optical house. The most basic list is a cut list, which
describes edge code start and end numbers for each clip and any simple effects such as
dissolves or fades. Cinema Tools can export a customized film list as a PDF file or an XML
file that you can further process however you want.

About Change Lists
Inevitably, there are changes to a movie after the picture is “locked.” When you make
last-minute changes in Final Cut Pro, you can export a change list that describes the
changes between a previous film list and your current sequence. A negative cutter can
then modify the film as necessary.

About Audio EDLs
Film lists describe only the video portion of your sequence. An audio EDL exports audio
clip start and end timecode values from your sequence. You can bring the audio EDL to
an audio post-production facility for audio cleanup and final mixing.
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How Cinema Tools Relates Final Cut Pro Sequence Clips to Database
Records
When you are creating a film list from Final Cut Pro, Cinema Tools has two methods to
relate each clip to records in a database.
• Clip name matching: The first thing Cinema Tools tries to do is match the clip name
used in a Final Cut Pro sequence to a clip name in the corresponding Cinema Tools
database. If a match is found, the clip in the database is used to supply information to
the film list. If a matching database record cannot be found based on clip name,
Cinema Tools switches to the timecode-based matching method.
• Timecode matching: If clip name matching fails, Cinema Tools tries to match a sequence
clip’s video reel number and timecode with a record in the Cinema Tools database. If
this method fails, a missing element note is made in the cut list.
This means you can get accurate film lists whether or not you connect the clips to the
Cinema Tools database. If you don’t connect clips to the database, however, you must
use care to not alter the clip’s timecode and make sure the video reel number is exactly
the same as is in the database.

Exporting a Film List
Following are the steps used to export a film list. See the Cinema Tools User Manual,
available in Cinema Tools Help, for more details and explanations of the settings in the
Export Film Lists and Export XML Film Lists dialogs.
To export a film list file
1 In the Final Cut Pro Browser or Timeline, select the sequence for which you want to create
a list.
2 Do one of the following:
• To export a PDF-format film list file: Choose File > Export > Cinema Tools Film Lists.
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The Export Film Lists dialog appears.

• To export an XML-format film list file: Choose File > Export > Cinema Tools XML Film
Lists.
The Export XML Film Lists dialog appears.

3 Configure the settings in the export dialog, then click OK.
If you expect to make changes to this Final Cut Pro sequence and want to export a change
list later, make sure to select “Save a Cinema Tools program file.” You’ll need that program
file to export a change list that compares this sequence to another version.
4 If you selected “Save a Cinema Tools program file,” enter a filename and location for it in
the dialog that appears.
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Important: Give the program file a name that clearly identifies the sequence and the
version, so that you can easily locate it later when you need to export a change list that
compares this sequence to a newer version.
5 In the next dialog that appears, enter a filename for the film list, choose a location, and
click Save.
6 In the dialog that appears, select the database file that Cinema Tools should use to produce
the lists that you have selected. (Select the database you created for source media used
in this sequence.)
A film list is generated as a file that contains all of the lists you have selected. If
Cinema Tools is unable to complete any list, messages appear in the file that indicate the
problem and guide you to a solution. See the Cinema Tools User Manual for more
information.
After exporting a film list, you should compare the edge code (key numbers or ink
numbers) in the film list to the edge code in the window burn at the In point frame of
each edit. Although it can be time-consuming to go through all of the edits and compare
the edge code numbers, it prevents the loss of time and money caused by incorrect cuts.
It’s particularly important to check the edge code numbers if you are not conforming a
workprint before cutting your negative.

Exporting a Change List
Following are the steps used to export a change list. See the Cinema Tools User Manual,
available in Cinema Tools Help, for more details and explanations of the settings in the
Export Change List dialog.
To export a change list using Final Cut Pro
1 In Final Cut Pro, select the new version of the sequence, then choose File > Export >
Cinema Tools Change List.
2 In the dialog that appears, select the program (.pgm) file that you saved when you
exported a list for the previous version of the sequence. (It contains needed information
about the previous sequence.)
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3 In the Export Change List dialog that appears, configure the settings, then click OK.

These lists provide
information about
the entire sequence.
These lists provide
information about
the changes.

When you select film lists in the Settings section of the Export Change List dialog, the
change list file will include (in addition to the selected change list options) the same
content you would get if you were exporting those lists from the Export Film Lists or
Export XML Film Lists dialog.
Note: Keep in mind that the following settings should be the same for the two sequences
you are comparing: Film Standard, Telecine Speed, and “Start with 8 seconds of leader.”
Key numbers or Ink numbers (but not both) must also be moved to the Included Columns
area of the Data Columns section. The two sequences must also have the same editing
timebase (set in Final Cut Pro).
4 In the dialog that appears, enter a filename and choose a location.
5 Click Choose Database to choose the database associated with the clips in the sequences
you are comparing. (Make sure you select the same database that was used when the
previous list was exported.)
6 Click Save.
7 If you selected “Save a Cinema Tools program file,” enter a filename and location for it in
the dialog that appears, then click Save.
Give the program file a name that clearly identifies the sequence and the version, so that
you can easily locate it later if you need to export another change list.
A change list file is generated, containing all the lists you selected in the Export Change
List dialog.
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Exporting an Audio EDL
Cinema Tools can export an audio EDL as long as its database contains accurate sound
information (an audio timecode number that corresponds to the first video frame of the
clip and the audio reel number) in each record. Because of the way audio is recorded
during the production (using dual system recording—a separate audio recorder that is
started and stopped independently of the camera), the Cinema Tools Export Audio EDL
function is available only when the project database has a record for each take (as with
scene-and-take transfers).
It is critical that the value in the Sound Timecode field in the Detail View window
correspond to the first video frame of the clip. This is typically the case when you import
the sound information from a telecine log. You can enter or verify this using the
Cinema Tools Clip window. For more information, see the Cinema Tools User Manual,
available in Cinema Tools Help.
Once you have finished editing and have added the sound timecode and reel number
information to the database, you are ready to export the audio EDL.
To export an audio EDL
1 In the Final Cut Pro Timeline or Browser, select the sequence from which you want to
export an audio EDL.
2 Choose File > Export > Cinema Tools Audio EDL.
Cinema Tools opens and its Export Audio EDL dialog appears.

3 Configure the settings in the Export Audio EDL dialog, then click OK. See the Cinema Tools
User Manual for information about the settings.
4 In the dialog that now appears, select the Cinema Tools database file to use, then click
Choose.
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Once you select the database, Cinema Tools starts matching events in the sequence to
records in the database in the following ways:
• For each edit involving a track turned on in the Export Audio EDL dialog, Cinema Tools
searches the database to see if that edit’s video clip is connected to any database
records. If not, it uses the edit’s video reel number to try to locate a record that includes
the edit’s timecode In and Out points. See the Cinema Tools User Manual for more
information about audio tracks.
• If Cinema Tools finds a suitable record, it checks whether that record includes sound
information (timecode and reel number). If so, an entry is added to the EDL and
Cinema Tools moves on to the next edit.
• Cinema Tools may not be able to match all audio edits within the sequence. This may
be due to incomplete database records or the use of audio from sources other than
the logged sound rolls. For those edits that cannot be matched back to the database,
an entry is added to the EDL using the reel and timecode information from the sequence,
with an asterisk placed by the reel name. A comment stating that no matching database
record was found is also added to the EDL entry.
Cinema Tools creates two files during the export: a CMX 3600 EDL format file and a text
file containing information about the EDL export:
• The CMX 3600 EDL format is widely used as a standard for EDL interchange and should
be acceptable at virtually all facilities.
• The text file created along with the EDL file uses the EDL’s filename with a .txt extension.
The file contains information regarding the sequence used and all the settings of the
Export Audio EDL dialog, including the number of tracks and their mapping. It also lists
any errors that occurred during the export.
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Preparing to Output to Tape

100

This chapter covers the following:
• Choosing a Videotape Format and Equipment for Output (p. 1667)
• Output Requirements (p. 1668)
• Methods for Output to Tape in Final Cut Pro (p. 1669)
• Setting Up Your Editing System to Output to Tape (p. 1671)
Tape is still the most common means of acquisition, output, and transfer for professional
projects. Final Cut Pro allows you to output sequences or clips to tape at any phase of
your project.

Choosing a Videotape Format and Equipment for Output
The tape format you choose for output affects the capture settings of your clips, your
sequence settings, and the equipment you need. Before you begin your project, try to
anticipate the format of your final master tape, as well as the format of any
work-in-progress tapes you may distribute to other people on your team.
The most common output formats include:
• DV: The DV format family includes DV, DVCAM, DVCPRO, DVCPRO 50, and DVCPRO HD.
DV formats are compressed video formats designed with nonlinear video editing in
mind. Final Cut Pro allows you to edit and output native DV signals, because a DV file
on your scratch disk is virtually identical to the same DV information on tape. When
you output DV from your computer, video and audio are combined into a DV stream,
sent to a VTR or camcorder via FireWire, and then recorded on tape.
• Uncompressed digital and professional analog video formats: These are formats such as
Betacam SP (analog), Digital Betacam, D-5, or HDCAM. VTRs for these formats support
several different video interface connections, such as component analog (Betacam SP),
SDI (Digital Betacam, D-5), and HD-SDI (HDCAM). Final Cut Pro requires a third-party
video interface to connect your computer to the input connections of the VTR. Unlike
DV, which uses the same native file format on tape and disk, the codecs used by
Final Cut Pro to store uncompressed video are not the same as the native signals
recorded on these tape formats.
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For example, if you are outputting to Digital Betacam, you should be editing with a
video codec that supports uncompressed video and is compatible with your third-party
video interface. When you output to tape, the video interface converts the
uncompressed video codec to a standard SDI signal, which enters the VTR via an SDI
input and is recorded to a Digital Betacam tape.
An uncompressed video editing system requires fast hard disks, a third-party video
interface to convert the media file format on disk to the input connection on the VTR
(for example, SDI), and a third-party device control adapter (such as a USB-to-serial port
adapter) for communication between Final Cut Pro and the VTR.
• Analog composite video output: Formats like VHS and 3/4" U-matic are still the lowest
common denominator for video distribution, even though these formats are being
replaced by DVD, DV, and QuickTime movie files (two of these aren’t even tape formats
at all!). These formats are mostly used for work-in-progress copies of your movie.
Choosing an output video format determines your equipment requirements. For example,
if you are editing DV and outputting to DV, your computer’s built-in FireWire port can
transfer video to your camcorder or deck. On the other hand, if you are editing
uncompressed video, your media files and sequence settings must use a video codec
compatible with a third-party video interface which is then connected to your VTR.

Output Requirements
Included here is a list of requirements for different types of output.
Requirements for Full-Resolution DV Output
Full-resolution DV output requires the following:
• Media files captured with a DV capture preset
• Sequence settings that match your DV capture settings
• A DV camcorder or deck with a FireWire port for transferring video, audio, and device
control data
Requirements for Full-Resolution Digital Betacam Output
Full-resolution Digital Betacam output requires the following:
• Media files captured with a high-resolution, uncompressed codec
• Sequence settings that match your clips’ capture settings (unless you want to render
your entire sequence before you output)
• A third-party video interface capable of SDI output and digital audio output
• A serial port adapter for connecting 9-pin device control to the output VTR
• A Digital Betacam deck
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Requirements for Full-Resolution Betacam SP Output
Full-resolution Betacam SP output requires the following:
• Media files captured with a high-resolution, uncompressed codec
• Sequence settings that match your clips’ capture settings
• A third-party video interface with component analog outputs (YUV) and professional
analog audio output
• A serial port adapter for connecting 9-pin device control to the output VTR
• A Betacam SP deck (Output to analog tape is becoming less common, but still necessary
in many situations. When you output to professional analog formats such as Betacam
SP, the equipment requirements are similar to what’s needed for professional digital
output.)
Requirements for VHS Output
You can output your video and audio to VHS in these ways:
• Output to a tape format compatible with your sequence, then make a copy to a VHS
tape.
• Connect your VHS deck to an analog composite output of your video interface or a
device that can automatically convert to analog composite video.

Methods for Output to Tape in Final Cut Pro
There are three main ways you can output your video from Final Cut Pro to tape:
• Edit to Tape
• Print to Video
• Record to tape directly from the Timeline
Edit to Tape
The Edit to Tape command supports both assemble and insert editing, which are two
forms of traditional videotape editing (these are not related to overwrite or insert editing
in the Timeline). The Edit to Tape command requires device control to remotely start and
stop the VTR. For more information about assemble and insert editing, see “Assemble
and Insert Editing Using Edit to Tape.”
Edit to Tape is the only command that supports insert editing. Use this option when you
are creating a master tape from a Final Cut Pro online system, when you want to replace
a single shot on a preexisting master tape, or when you want to replace specific tracks
(such as several audio tracks) on tape.
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Print to Video
In most cases, the Print to Video command doesn’t use device control, so it is useful when
your deck can’t be controlled remotely (such as a VHS deck). You can’t specify timecode
In and Out points for recording on the tape, so you can’t use this method for output to
a precise location on your tape. You also can’t choose which audio or video tracks are
recorded on tape—they are all recorded.
Note: Some camcorders and VTRs can be triggered to record automatically as soon as
you begin the Print to Video operation. You need to connect a FireWire (for DV) or RS-422
device control cable between your computer and video deck to use this option.
The Print to Video command allows you to begin recording wherever the tape is currently
cued, and without timecode accuracy. You also can’t set a precise Out point on the tape,
so there is almost always a break in the video signal on tape at the Out point after
recording. To prevent your movie from cutting off abruptly as soon as it ends, you should
include some black after your program, either by adding slug to the end of your sequence
or by including some trailing black, which is an option available in the Print to Video
dialog.
If you don’t require a precise In or Out point on the tape, then Print to Video is generally
the best option. You can even use Print to Video with a completely blank tape, since it
doesn’t require timecode or video signal information from the tape before it begins
recording. Unless you need to output your video to a specific timecode number on tape,
or replace a shot on a tape that already has video on it, Print to Video should suit your
needs.
Record to Tape Directly from the Timeline
This method allows you to record whatever signal is currently playing on your editing
system, regardless of the quality. Simply connect the video output of your computer
(FireWire or third-party video interface) to a VTR or camcorder, turn on external video
monitoring in Final Cut Pro, and press the Record button. Whatever happens in the
Timeline is recorded to tape. This is useful for recording rough cuts directly from the
Timeline or when you want to record any real-time adjustments you make in the Viewer,
Canvas, or Timeline.
This method is convenient for quick output at any time, but may display low-quality video
and unrendered sections of the Timeline. The quality of video output is based on the
real-time settings of your editing system and the current Timeline, so high-quality video
is not guaranteed. Use this method to quickly create work-in-progress tapes when you
aren’t concerned about output at the highest quality.
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Setting Up Your Editing System to Output to Tape
Before you output to tape, you need to set up your video devices and Final Cut Pro settings
and preferences. Some steps are only relevant to particular methods.
• Stage 1: Connecting Your Video Equipment
• Stage 2: Choosing Video and Audio Outputs
• Stage 3: Selecting Playback Settings
• Stage 4: Selecting Render Settings
• Stage 5: Selecting Edit to Tape and Print to Video Preferences
• Stage 6: Preparing Your Videotape with Black and Timecode
• Stage 7: Cueing the Videotape
• Stage 8: Calibrating Your Timecode
• Stage 9: Choosing Device Control and Edit Preview Settings

Stage 1: Connecting Your Video Equipment
Make sure your VTR or camcorder is connected to your computer and turned on. For
more information, see “Connecting DV Video Equipment.”
Make sure your camcorder or deck is set to VTR (sometimes labeled VCR) mode.
Final Cut Pro cannot record to video equipment that is in Camera mode. If your video
device has multiple inputs (for example TV, Line 1, and Line 2), make sure the input that’s
connected to your computer is the one that is selected.

Stage 2: Choosing Video and Audio Outputs
Make sure that the A/V devices settings of your Easy Setup match the configuration of
your external video and audio equipment.
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To view a summary of your Easy Setup
Choose Edit > Easy Setup.

Make sure the external
video and audio settings
in your Easy Setup match
the way you configured
your video equipment.
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If none of your Easy Setups matches your video and audio configuration, you can choose
the correct settings in the A/V Devices tab of the Audio/Video Settings window. For
example, if you are outputting via FireWire, choose an available FireWire output such as
Apple FireWire NTSC or PAL in the Video pop-up menu in the Playback Output section
of the A/V Devices tab.
This setting sends video out from the appropriate video output, whether it’s the FireWire
port or a third-party video interface. You can also choose an audio interface for output.
For more information on configuring custom external video settings, see “External Video
Monitoring.” For information on external audio settings, see “Connecting Professional
Video and Audio Equipment.”

Stage 3: Selecting Playback Settings
When you want to output your program to video, you can choose whether to render the
effects that won’t output at full quality in real time, or output them at the reduced quality
you’ve selected in order to avoid rendering.
Playback settings can be adjusted in the Playback Control tab of System Settings, or in
the RT pop-up menu in the Timeline. For output to tape, you can choose from the
following options in the Record pop-up menu:
• Full Quality: When this option is selected, video is always output to tape at the highest
quality. Areas of your sequence that won’t play back at full resolution in real time will
need to be rendered prior to output.
• Use Playback Settings: Final Cut Pro uses the selected real-time effects playback settings
when outputting your sequence to tape. If, as a result, your sequence will output at
less than full quality, you are warned of this prior to output. Outputting to tape at low
quality is useful for quickly creating sample tapes of your program when you don’t
have the time to render all necessary effects first.
Note: Final Cut Pro always warns you before outputting video to tape at reduced quality
when you use the Edit to Tape command.

Stage 4: Selecting Render Settings
The currently selected render quality is used to render any transitions, filters, or motion
parameters in your edited sequence, as well as any added leader or trailer elements. For
more information on render quality settings, see “Rendering and Video Processing
Settings.”
Note: Render settings can be adjusted in the Render Control tab of the current sequence.
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Stage 5: Selecting Edit to Tape and Print to Video Preferences
If you like, turn on two preferences relating to tape and playback operations.
• Abort ETT/PTV on dropped frames: If you select this option, a message appears when
any frames are dropped during playback when outputting, and Final Cut Pro immediately
stops the operation. You can choose to redo the entire output, or you can attempt a
match frame edit to output the remaining video from where the dropped frame
occurred.
Playback drops are almost always caused by a hardware setup problem. When properly
configured, Final Cut Pro should not drop frames. For information on what you can do
if Final Cut Pro reports dropped frames, see “Problems During Playback.”
• Report dropped frames during playback: If you select this option, a message appears
when any frames are dropped when outputting so you can correct the problem.
Playback drops are almost always caused by a hardware setup problem. When properly
configured, Final Cut Pro should not drop frames. For information on what you can do
if Final Cut Pro reports dropped frames, see “Problems During Playback.”

Stage 6: Preparing Your Videotape with Black and Timecode
If you plan to do insert editing and your tape is blank, your tape needs to have a signal
already recorded on it. You can prepare a tape for insert editing by blacking the tape,
which means recording control track, timecode, and a black video signal. You can also
perform insert edits on any tape with an existing control track. Having timecode on the
tape is also necessary to set In and Out points for the edit.
Most blacked tapes start at 00:58:00:00 to allow two minutes of header elements before
your program. The movie itself usually starts at 01:00:00:00. This is set in the Initialize Tape
dialog. You will see it only if your deck has a settable timecode generator. You may want
to black several tapes in advance so they are available when needed.
Note: Most consumer DV camcorders are limited to start recording at 00:00:00:00.
If you plan to do a series of insert edits to output your whole program onto tape, you
must use a tape that’s blacked from beginning to end. If you’re assemble-editing a long
program to a new tape, you don’t have to black the entire tape, but it’s a good idea to
black at least 30 seconds of the tape so there is enough timecode so you can set an In
point as well as allow for pre-roll before the In point.
To prepare a tape with black and timecode
1 Insert a videotape into your camcorder or deck.
2 Choose File > Edit to Tape.
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3 In the Edit to Tape window, click the Black and Code button.

Click this button to
black your tape.

4 If your video equipment supports timecode generation, make sure your deck is set to
accept an external timecode signal.
Note: Timecode is sent via an RS-422 serial port. This is not supported for DV FireWire.
5 Enter the starting timecode in the dialog, then click OK.
This defines the starting timecode number that appears on your tape.
6 In the Black and Code dialog, choose an option from the Settings pop-up menu, then
click OK.
Current settings are based on the sequence preset in your current Easy Setup. If you select
Custom, the Sequence Preset Editor appears and you can choose custom settings. For
more information, see “About Sequence Settings and Presets.”
7 When a message appears saying your tape will be erased and rewritten with black frames
and timecode, click OK.
The tape rewinds to the beginning and the entire tape is blacked. If your video equipment
supports timecode generation, timecode is also recorded, starting from the timecode
specified. To cancel the black and code process, press the Esc key.
This message indicates
that the black and code
process has started.

Stage 7: Cueing the Videotape
When you use the Print to Video command, or when you output directly from the Timeline,
make sure you cue the videotape to where you want to start recording.
To cue the tape
1 Use the camcorder or deck controls to cue the videotape to the point where you want
to start recording.
2 If you’re outputting to a tape that has previously recorded material on it, make sure that
the write-protection tab is in the write, or unlocked, position.
Note: If you’re using a consumer mini-DV device and you fast-forward past prerecorded
material (so there’s some blank tape between it and what you’ll output), the DV timecode
resets to 00:00:00:00.
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Stage 8: Calibrating Your Timecode
You must calibrate the timecode signal of your device before editing. This is particularly
important when you are using RS-422 device control, because video and timecode
information are coming into Final Cut Pro via independent connections. For more
information, see “Calibrating Timecode Capture with Serial Device Control.”

Stage 9: Choosing Device Control and Edit Preview Settings
If necessary, specify device control and input (“capture”) settings in the Device Settings
tab of the Edit to Tape window. You can change both of these settings by choosing an
Easy Setup that’s appropriate for your video equipment.
To choose device settings
1 In the Edit to Tape window, click the Device Settings tab.
2 Change your device control and edit preview settings.
For more information, see “Device Settings Tab.”
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Assemble and Insert Editing Using
Edit to Tape

101

This chapter covers the following:
• Overview of Tape Editing Methods (p. 1677)
• About the Edit to Tape Window (p. 1680)
• Using the Edit to Tape Window (p. 1688)
The Edit to Tape window provides precision control over output to tape. Both assemble
and insert editing modes are supported, and remote control of your video device is
required.

Overview of Tape Editing Methods
Assemble and insert editing are terms that originate from linear, tape-to-tape editing
systems. Originally, videotape was edited physically by cutting and splicing at the
boundaries of magnetic tracks on tape. This was not only cumbersome, but difficult to
do precisely because video tracks are incredibly small and can only be seen when magnetic
ink is applied to the tape. The invention of electronic editing allowed editors to edit by
copying selected portions of source tapes to a new master tape.
Three methods of electronic editing exist, each with increasing precision and quality:
• Hard (or crash) recording: This method begins laying video signal on tape as soon as
the Record button is pressed, without waiting for a pre-roll period in which the VTR
motor can get up to speed. Crash records cause breaks in the video signal. If you have
ever recorded a television show with a consumer VCR, you have performed a crash
record simply by pressing the Record button. The recording ends abruptly when you
press Stop, which causes a break in the video signal. Both “In” and “Out” points of a
crash edit cause noticeable breaks in the video signal on tape.
Note: Crash recording onto a tape is a manual process. The Edit to Tape window only
works when device control is connected and timecode is present on the videotape, so
you can’t create crash edits in this window. You can, however, create crash edits on
tape by pressing the Record button directly on your camcorder or deck, and recording
the video output of Final Cut Pro using either the Print to Video command or the direct
video output of the Timeline.
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• Assemble edits: Assemble edits use a pre-roll time before the edit In point to let the
VTR motor get up to speed and continue recording a consistent signal once the edit
begins. The result is a smooth edit at the In point. All tracks on the tape, including
video, audio, timecode, and control tracks, are replaced. The Out point of an assemble
edit ends abruptly, similar to a crash edit, because there is a discrepancy between the
timing of the newly recorded signal and the one that already existed on the tape (if
the tape wasn’t blank).
• Insert edits: Insert edits only replace selected tracks, such as the video track, or two
audio channels. The control track on the tape is never replaced, which keeps the tape
playing at the proper speed while the other tracks are replaced. Both In and Out edit
points are smooth. Professional tape-to-tape editing systems use pre-blacked videotapes
and use insert editing exclusively.

About Assemble Editing to Tape
An assemble edit records all video, audio, timecode, and control track information onto
tape starting at the In point of the edit. Whatever signal was on the tape previously is
replaced. By definition, this means there must already be some signal recorded on the
tape (even if it’s only 10 or 15 seconds at the head of the tape) so you can set an In point.
When an assemble edit stops, there is a signal break at the Out point between the new
signal and the previous signal already on tape. Thus, the In point of an assemble edit
maintains a smooth control track signal, but the Out point always has a break. Since you
can always cover up the last Out point break with the In point of a new edit, assemble
editing gets its name from the fact that it is used for quickly assembling footage together
in a linear fashion. However, you cannot replace a shot in the middle of the tape without
creating a signal break at the Out point.

About Insert Editing to Tape
An insert edit allows you to individually replace video, audio, and timecode tracks on a
tape, using In and Out points. Insert editing is frame accurate and never creates breaks
in the control track. For example, you could record new music to audio track 1 while
keeping the existing video track and audio track 2 intact. This requires a precision,
professional deck. (For more information, see “About Tracks on Videotape.”)
Note: This term is not at all related to making an insert edit in the Timeline; insert editing
is a tape-to-tape editing term that predates nonlinear editing systems.
To perform an insert edit, your tape needs to have a signal already recorded on it. You
can prepare a tape for insert editing by blacking the tape, which means recording control
track, timecode, and a black video signal. You can also perform insert edits on any tape
with an existing, unbroken control track. Having timecode on the tape is also necessary
to set In and Out points for the edit. For more information about blacking a tape using
Final Cut Pro, see “Stage 6: Preparing Your Videotape with Black and Timecode.”
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Important: DV devices do not support insert editing because the tracks are too narrow
to be precisely replaced. DVCAM and DVCPRO formats support insert editing because
they use wider tracks.

About Tracks on Videotape
Most professional videotape formats have one video track, two or more audio tracks, a
timecode track, and a control track.
About the Control Track
Unlike the other tracks on a tape, the control track serves a purely practical function: to
make sure the tape plays at exactly the same speed it was recorded at so the signal is
output correctly. A control track is a series of electronic pulses on your videotape that
the VTR follows during playback, speeding up or slowing down the capstan (motor) as
necessary for consistent playback. These pulses are almost like electronic sprocket holes
that regulate videotape playback speed.
Insert editing allows you to replace individual video, audio, or even timecode tracks,
leaving the other tracks intact. The control track is never replaced during insert editing.
When you perform an insert edit, the VTR uses the control track to play back the tape at
the proper speed while recording new video or audio tracks.
When the control track is broken, you may see the video signal jump or look unstable for
a few seconds. This happens because the VTR relies on a consistent control track to control
the speed of the deck’s motor. A missing or inconsistent control track causes the motor
to change speed drastically, which means the video signal isn’t read at the proper speed
of the tape, and so the image is not scanned properly. Control track breaks may not always
be noticeable, but they are unacceptable in a professional environment.
About the Timecode Track
Timecode is also recorded onto a separate track on non-DV tape formats. Timecode allows
your computer to control your camcorder or deck and import or export frame-accurate
video clips. When you’re using the Print to Video command, abrupt breaks can cause
subtle gaps in the timecode track. Although these happen less often than control track
breaks, they can cause problems in a professional environment.

Requirements for Assemble or Insert Editing to Tape
Before you can edit to tape:
• Your video equipment must support either FireWire or serial RS-422 remote device
control.
• Your deck must support recording; you cannot perform edits on play-only decks.
• Your camcorder or deck must support insert editing, if you wish to do that type of
editing.
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For details about the capabilities of your video equipment, check the documentation
that came with it. For more information about equipment requirements for output to
tape, see “Output Requirements.”

About the Edit to Tape Window
In most window layouts in Final Cut Pro, the Edit to Tape window appears in the same
location as the Canvas. The Edit to Tape window has three tabs:
• Video: This tab allows you to set tape In and Out points, specify tracks for insert editing,
and perform the edit to tape. See “Video Tab.”
• Mastering Settings: This tab allows you to adjust settings for elements before and after
your movie, such as black, color bars, a slate, and a countdown. See “Mastering Settings
Tab.”
• Device Settings: You can choose a device control preset that matches your VTR and a
capture preset that determines how your video is displayed in the Edit to Tape window.
These settings are set automatically whenever you choose an Easy Setup. See “Device
Settings Tab.”
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Video Tab
The Video tab allows you to control and record onto the tape in your camcorder or deck.
You can cue the tape and set In and Out points using the transport controls. Edit buttons
and track selection controls allow you to determine exactly how your edit to tape is
performed.
Timecode Duration field
Tabs

Mode pop-up menu
Black and Code button
Current Timecode field

Edit Overlay (with a
dragged clip shown)

Destination track
controls (for insert edits)
Insert Edit,
Assemble Edit, and
Preview Edit
buttons

Device status

Video Tab Controls
You can use the following Video tab controls:
• Mode: Choose Mastering or Editing.
• Mastering: This is the default mode. The mastering mode is useful if you want to
output an entire movie with leading elements such as color bars, slate, and
countdown. In mastering mode, you can only set an In point on the tape, because
the Out point is calculated based on the duration of the elements you choose in the
Mastering tab.
• Editing: In Editing mode, only the selected clip or sequence is recorded to tape. You
cannot add leader or trailer elements. You can use this mode when replacing a shot
that’s already on tape with frame accuracy, and you can also use three-point editing
between your clip or sequence and the tape. For example, you can set In and Out
points on the tape and only set an In point in your sequence.
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• Black and Code: Automatically records a black signal on a videotape, with silent audio
and continuous control and timecode tracks, from the beginning to the end of the
videotape.
• Timecode Duration: Displays the duration between the In and Out points set on the
tape.
• Current Timecode: Displays the current timecode position of the tape. If you enter a
timecode, the tape will move to that position.
• Edit Overlay: Appears when you drag a clip or sequence to the Edit to Tape window.
You can choose to perform an assemble or insert edit, or preview an insert edit.
• Edit buttons: Click to do an insert or assemble edit or preview your insert edit.
• Device status: Shows the status of the connected video equipment.
Navigation and Marking Controls
You can use the following Navigation and Marking controls:
Shuttle control
Mark In

Mark Out

Jog control
Go to Out Point
Timecode for
the In point

Timecode for
the Out point

Go to In Point

• Shuttle control: Drag the tab to the right to fast-forward and to the left to rewind the
tape. The speed depends on the distance of the tab from the center. When the tab is
green, playback speed is normal. Keyboard shortcuts are the J, K, and L keys.
• Jog control: Use this control to move forward or backward a few frames at a time on
the tape. This is useful for visually locating a specific frame. You can also press the
Forward Arrow or Back Arrow.
• Mark In: Click this button, or press I, to set the frame on your tape where recording will
start.
• Mark Out: Click this button, or press O, to set the frame on your tape where recording
will stop.
• Go to In Point: Click this button, or press Shift-I, to move the tape to the In point you
set.
• Go to Out Point: Click this button, or press Shift-O, to move the tape to the Out point
you set.
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Destination Track Controls
These controls allow you to specify which tracks on tape are edited to when performing
an insert edit. In addition to video and timecode, up to 16 audio tracks can be output to
supported video and audio decks.
Click here to enable
or disable timecode.

Choose your audio tracks
from this pop-up menu.

Click here to enable
or disable video.

Note: When you perform an assemble edit, all tracks on your recording deck are
simultaneously record-enabled and the destination track controls are turned off.
• Timecode Insert: When this control is selected, the timecode of the clip or sequence to
be output is edited to tape along with its audio and video. The timecode edited to tape
is taken from the section of the clip or sequence being output. Turn on this option only
if you want to overwrite the timecode already on the destination tape. This feature
works with devices that support serial device control protocols such as RS-422, as well
as some DVCPRO HD devices.
Important: When insert editing video and audio into an existing program on tape, you
generally want to turn off Timecode Insert in order to leave the existing timecode
unchanged.
• Video Insert: When this control is selected, the video track on tape is replaced by the
video output from your computer. Turning off this control prevents the video of your
clip or sequence from overwriting the video already on your destination tape.
• Audio Insert: This pop-up menu allows you to individually record-enable audio tracks
on tape when insert editing. The number of audio tracks available in this pop-up menu
is determined by the Audio Mapping option in the currently selected device control
preset. Unavailable audio channels are dimmed. For more information about Audio
Mapping options, see “Using the Edit to Tape Window.”
To record-enable an audio track, choose it from this pop-up menu and a checkmark
appears next to it. Choose it a second time to remove the checkmark and disable the
track.
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Sixteen audio channel indicators in the Audio Insert pop-up menu indicate which audio
tracks are record-enabled on your VTR. The color of an audio channel indicator indicates
its state.

• Yellow: The audio track is record-enabled on the connected VTR.
• Gray: The audio track is record-disabled on the connected VTR.
Transport Controls
Transport controls let you navigate through the videotape.
Rewind
Play In to Out

Fast Forward
Play Around Current
Stop

Play

• Rewind: Click this button, or press J, to rewind the videotape.
• Play In to Out: Rewinds the tape to the current In point you set and then plays forward
from that point to the Out point you set. If there is no Out point, the tape plays to the
end.
• Stop: Click this button, or press K or the Space bar, to stop the videotape.
• Play: Click this button, or press L, to play the tape.
• Play Around Current Frame: This is based on the preview pre-roll and preview post-roll
settings in the Editing tab of the User Preferences window. The tape plays from the
playhead position at the pre-roll setting and continues through the amount of time
specified by the post-roll setting.
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• Fast Forward: Moves the videotape forward. You can also press the L key repeatedly
to go through a range of speeds.

Mastering Settings Tab
You can add leader and trailer elements during both the Edit to Tape and Print to Video
operations.

µ
µ

To add leader or trailer elements when editing to tape
Choose Mastering mode and specify settings in the Mastering Settings tab of the Edit to
Tape window.
To add leader or trailer elements when using the Print to Video command
Select leader and trailer elements directly in the Print to Video dialog.
For more information about using leader and trailer elements, see “Adding Standard
Leader and Trailer Elements.”
All selected elements are output to tape in the order listed. Make sure to deselect elements
you don’t need. All element durations are specified in whole seconds.
Note: Some of these items may require rendering before you can start recording.

Select all of the elements
you want to add before
the clip or sequence.

Select trailer elements to
be added at the end of
the clip or sequence.

Choose how much of
your sequence or clip
you want to output, and
select looping options.
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Leader Elements
You can set the following leader element options:
• Color Bars: Adds color bars and a 1 kilohertz (kHz) reference tone, preset to –12 decibels
(dB). Color bars at the beginning of your tape allow the recipients to calibrate their
equipment to match the color levels and values that your system used when outputting
your program. The reference tone lets the recipients properly adjust audio levels during
playback.
For more information on creating a mix with proper levels, see “Evaluating Levels with
Audio Meters.”
When the current device control preset has a frame rate of 25 fps (PAL), you can select
the Full Frame Bars option. When you select this option, full-frame bars are output to
tape. When this option is not selected, SMPTE bars are output.
Note: If the current device control preset does not have a frame rate of 25 fps, this
option is unavailable.
• Black: Adds the specified number of seconds of black between the color bars and slate,
or at the beginning of the clip or sequence if you aren’t adding color bars.
• Slate: Adds a slate with information about your movie. Choose the slate source from
the pop-up menu. The slate can be the clip or sequence name, text you type in a field,
or a specified text, PICT, or QuickTime file on disk. A slate should contain information
such as:
• The title of your program
• Relevant production credits indicating ownership of the content (such as the producer,
director, editor, and post-production facility)
• The total run time (TRT) of your program
• The starting timecode number. This is useful if you’re using a high-end video deck
to do an insert edit of your program onto a tape with pre-striped timecode. In this
case, also indicate whether drop frame (DF) or non-drop frame (NDF) timecode is
used.
• The date on which the tape is output
• Black: Adds the specified number of seconds of black between the slate and countdown.
• Countdown: Adds a countdown before your movie. You can use the 10-second built-in
SMPTE standard countdown or choose a custom countdown. Countdowns are generally
used when you deliver a tape to a television or cable station for broadcast, or to an
audio post-production facility doing your final audio mix.
Note: If you choose a custom QuickTime file as your countdown, its duration should
conform to SMPTE specifications.
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Media Elements and Options
These are options for the clip or sequence you are outputting to tape.
• Print: You can choose to output the entire clip or sequence or just the part specified
between the In and Out points.
• Loop: Repeats the selected media for the specified number of times. A value of 1 plays
the selected media once; a value of 2 plays the selected media twice, and so on.
• Black: Adds black after each loop of your sequence or clip.
Trailer
You can set the following trailer option:
• Trailer: Adds a black trailer at the end of your sequence or clip or at the end of the last
loop of your clip or sequence. It’s good practice to put a 30-second black trailer at the
end of your tape so viewers don’t see noise as soon as your movie ends. It’s also helpful
to add a few seconds of black at the end of each edit when you are assemble editing.
This provides timecode and control track after the last frame of your output sequence
to set a new In point for a new edit.
Duration Calculator
The Duration Calculator displays the total duration of the program you are outputting,
including all of the selected leader and trailer elements and their durations. Make sure
there is sufficient time on your tape before proceeding.
• Media: Displays the duration of your source media to be output, not including leader
and trailer elements. The duration shown here depends on whether the sequence or
clip you are outputting has In or Out points set, and the choice you made in the Print
pop-up menu.
• Total: Displays the total duration of the program you are outputting, including additional
time created by looping and the duration of all selected leader and trailer elements.
Adding Standard Leader and Trailer Elements
If you’re outputting your clip or sequence for delivery to a post-production house, tape
duplication facility, or television station, there are accepted conventions for how leader
elements are placed on tape. Here is one common way to lay out elements, although
some facilities have different standards. When in doubt, ask ahead for what is preferred.
Master tape timecode

Leader element

Duration

00:58:00:00

Black

30 seconds

00:58:30:00

Color bars and tone

60 seconds

00:59:30:00

Black

10 seconds

00:59:40:00

Slate (for broadcast or audio
post facility)
Black (for dubbing)

10 seconds
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Master tape timecode

Leader element

Duration

00:59:50:00

Countdown with 2-pop

10 seconds

01:00:00:00

Program start

Duration depends on movie

After all leader elements have played, your program should start at hour 01:00:00:00,
unless you are given specific instructions otherwise.
Note: If you’re blacking tapes in advance, start the timecode at 00:58:00:00 so you can
start the leader elements at 00:58:30:00.

Device Settings Tab
The Device Settings tab is a convenient location for choosing a device control preset
that’s compatible with your output deck. You can also choose a device control preset
automatically by choosing a different Easy Setup.

If necessary, choose
device control and
capture settings from
the pop-up menus.

• Device Control: Choose a device control preset that matches your particular video
equipment. For more information, see “Device Control Settings and Presets.”
• Capture/Input: This pop-up menu is exclusively used when you show video in the Edit
to Tape window during the preview of an insert edit. This allows you to see what the
edit will look like on tape, including the video before the tape In point and video after
the tape Out point, without actually committing the edit to tape. During the pre-roll
and post-roll of the preview, you see video from tape displayed in Final Cut Pro. Between
the tape In and Out points, you see the video output from Final Cut Pro. To successfully
see video from the tape before and after the edit, you need to choose corresponding
input settings. Since preview editing involves temporary video input, capture presets
are used.
For more information about capture presets, see “Capture Settings and Presets.”
Note: Despite the name of this pop-up menu, you are not actually capturing footage.
When you preview an insert edit to tape, you’re viewing what’s already on tape during
the pre-roll and post-roll periods of the edit. The only way to preview your edits with
material before and after your edit is to view, or “capture,” material that’s on the tape.

Using the Edit to Tape Window
The following section describes how to perform an assemble or insert edit using the Edit
to Tape window.
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Performing an Assemble Edit to Tape
Assemble editing begins recording the signal on tape at the predetermined timecode In
point. For details, see “About Assemble Editing to Tape.”
If you are outputting to DVCPRO HD via FireWire, the timecode recorded to the tape can
start from the existing tape timecode or you can choose to create new timecode on the
tape based on the sequence timecode. If you choose this option, the timecode written
to tape is the same as the sequence timecode.
Important: Make sure you’ve read and followed the instructions in “Connecting DV Video
Equipment.”
To do an assemble edit
1 Choose File > Edit to Tape.

The preview option is
disabled if you are using
DV equipment.

In most layouts, the Edit to Tape window appears on top of the Canvas.
2 Choose Editing or Mastering mode from the pop-up menu in the top center of the window.
For more information about the Editing and Mastering modes, see “Video Tab.”
Choose a mode from this
pop-up menu.

3 Select a clip or sequence in the Browser.
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4 If you haven’t already done so, set In and Out points for your clip or sequence in the
Viewer, if you don’t want to output the entire clip or sequence.

If you wish, set In and
Out points for the part
you want to record.

5 In the Edit to Tape window, cue the tape where you want to start your initial edit, then
press I, click the Mark In button, or type a value and press Return.
Note: You do not need to set an Out point for an assemble edit.
6 If you are including leader elements using Mastering mode, click the Mastering Settings
tab, then select the elements you want to include before and after your sequence or clip.
For an explanation of the leader and trailer options, see “Adding Standard Leader and
Trailer Elements.”
7 To perform the assemble edit, do one of the following:
• Drag your clip or sequence from the Viewer or Browser to the Assemble section of the
Edit Overlay.
• Open your clip or sequence in the Viewer, then click the Assemble Edit button.
• Drag the clip or sequence to the Assemble Edit button.

Drag the clip or
sequence here to do
an assemble edit.

Or click the Assemble
Edit button.
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Transitions and effects that require rendering, along with any added elements, are rendered
automatically prior to output. A dialog shows you the rendering progress of your sequence
or clip. You can also choose to output unrendered real-time effects at a lower quality,
saving time by avoiding rendering. Options for choosing the quality of rendered effects
during Print to Video and Edit to Tape operations can be set in the Render Control tab
of the sequence settings and in the Real-Time (RT) pop-up menu in the Timeline. For
more information on setting these options, see “Render Control Tab.”

Note: A feedback window appears when the edit is done.
All audio that requires rendering is automatically rendered with a render quality of High,
regardless of the render quality setting.
8 To cancel an edit in progress, press Esc or click Cancel.

Performing an Insert Edit When Editing to Tape
An insert edit allows you to edit individual video or audio tracks to tape, setting
frame-accurate In and Out points. Insert editing requires tapes that already have a
prerecorded signal, such as blacked tapes. For details, see “About Insert Editing to Tape.”
Important: Make sure you’ve read and followed the instructions in “Connecting DV Video
Equipment.”
Some tape formats and VTRs, such as consumer mini-DV devices, do not support insert
editing. If your VTR or tape format is limited to assemble editing (such as a DV deck or
camcorder), then the insert editing controls in the Edit to Tape window are dimmed.
To perform an insert edit
1 Choose File > Edit to Tape.

The preview option is
disabled if you are using
DV equipment.

In most layouts, the Edit to Tape window appears on top of the Canvas.
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2 Choose Editing or Mastering mode from the pop-up menu in the top center of the window.

For more information about the Editing and Mastering modes, see “Video Tab.”
3 Select a clip or sequence in the Browser.
4 If you haven’t already done so, set In and Out points for your clip or sequence in the
Viewer, if you don’t want to output the entire clip or sequence.

Set In and Out points
for the part you want
to record.

Use three-point editing to set your In and Out points. For more information on three-point
editing, see “Three-Point Editing.”
5 Set In and Out points on your tape where you want your clip or sequence recorded.
• If you’re in Mastering mode: Use the transport controls in the Edit to Tape window to
cue the tape where you want to start your initial edit. Then press I or click the Mark In
button to set the In point. (You don’t set an Out point in this mode, because you may
include trailer elements that extend the edit duration.)

Mark In button
Timecode for the
In point on the tape
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If you’re in Editing mode: Use the transport controls in the Edit to Tape window to cue
the tape and set an In point, an Out point, or both, depending on the type of three-point
edit you’re doing.
• To set an In point: Cue the tape where you want to start your initial edit, or type a
value. Then press I or click the Mark In button.
• To set an Out point: Cue the tape where you want your clip or sequence to end, or
type a value. Then press O or click the Mark Out button.
Mark In button

Timecode for the
In point on the tape

Mark Out button

Timecode for the
Out point on the tape

6 Select the destination video and audio tracks to be edited to in the Edit to Tape window.
When performing an insert edit, you can selectively record-enable the video, audio, and
timecode tracks on tape. Destination tracks that are disabled in the Edit to Tape window
are not overwritten on the destination tape.
Click here to enable
or disable timecode.

Choose your audio tracks
from this pop-up menu.

Click here to enable
or disable video.

7 If you are including leader elements using Mastering mode, click the Mastering Settings
tab, then select the elements you want to include before and after your sequence or clip.
For an explanation of the leader and trailer options, see “Adding Standard Leader and
Trailer Elements.”
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8 To preview how your edit will appear on tape, drag your clip or sequence to the Preview
section of the Edit Overlay in the Edit to Tape window, or click the Preview Edit button.

Drag the clip or sequence
here to preview your
insert edit.
Or click the Preview
Edit button.

Previewing lets you see how your insert edit will appear on tape before you actually
record it. This is especially useful for seeing how an edit in the middle of existing footage
on tape will appear.
To cancel the preview, press Esc.
9 To edit your sequence or clip to tape, drag it from the Browser or Viewer to the Insert
section of the Edit Overlay in the Edit to Tape window or click the Insert Edit button.

Drag the clip or
sequence here to
do an insert edit.

Or click the Insert
Edit button.

Transitions and effects that require rendering, along with any leader and trailer elements,
are rendered automatically prior to output. A dialog shows you the rendering progress
of your sequence or clip. You can also choose to output unrendered real-time effects at
a lower quality, saving time by avoiding rendering. Options for choosing the quality of
rendered effects can be set in the Render Control tab of the Sequence Settings, and in
the Real-Time (RT) pop-up menu in the Timeline. For more information on setting these
options, see “Render Control Tab.”
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10 In the dialog that appears, click OK to start recording.

The videotape cues to the pre-roll point before the In point, plays until the In point is
reached, and then begins recording. To cancel an edit in progress, press Esc or click Cancel.

Using Edit to Tape to Output Multichannel Audio
Final Cut Pro is capable of outputting up to 16 tracks of audio when performing an insert
edit to tape. The number of audio tracks that can be recorded to when using the Edit to
Tape command depends on the number of audio tracks your video or audio recording
deck supports. You also need to have enough discrete outputs on your audio interface
to connect to each audio input on your deck. Assemble editing records all audio tracks
at once.
If you have a VTR or audio device that supports RS-422 remote control, you can turn on
recording of individual audio channels during output with the Edit to Tape window (also
known as insert editing).
Note: If you use a FireWire connection or the Print to Video command for output to tape,
you can skip this section.
You can record-enable individual audio channels in the Edit to Tape window by choosing
channels from the Audio Insert pop-up menu.

Audio Insert
pop-up menu

When you start the output process, Final Cut Pro sends a channel insert message that
tells the deck which channels you chose from the Audio Insert pop-up menu. However,
different decks expect audio channel information to be in different places within the
message, potentially leading to unexpected enabling or disabling of channels. To ensure
that Final Cut Pro sends audio channel insert information in the proper format, you need
to choose an audio mapping setting in your device control preset before you edit to tape.
Important: The audio mapping setting does not determine which audio channels are
inserted. Instead, it determines the format in which Final Cut Pro communicates which
audio channels to insert.
The following chart shows some common video and audio recording decks and the
appropriate audio mapping setting for each.
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Channels available for
insertion on deck

Audio mapping

Sony UVW-1800
Sony BVW-70 (Betacam SP)

2 channels

2 channels

Sony DVW-500 (Digital Betacam)
Sony HDW-2000 (HDCAM)
Panasonic AJ-SD930 (DVCPRO
50)

4 channels

4 channels

Sony MSW-2000 (IMX)
Panasonic AJ-HD3700 (D5-HD)

8 or more channels

8 channels

Tascam DA-98

8 channels

8 channels (legacy)

Sony SRW-5505 (HDCAM SR)

12 channels

12 channels

Recording device

If you are uncertain of which audio mapping setting to use for your deck, here are several
guidelines:
• 2 channels: Older decks that have only analog audio inputs (for example, Betacam SP
and U-Matic 3/4”) typically allow two channels of audio insert editing.
Note: Some Betacam SP decks have four audio channels, but channels 3 and 4 cannot
be inserted independently from the video channel (thus these decks are still considered
two-channel decks for the purpose of audio insert editing).
• 4 channels: Many professional digital video decks today (Digital Betacam, DVCPRO 50,
HDCAM) support at least four channels of audio insert editing.
• 8 channels: Some newer digital video decks (D5-HD, IMX) support eight channels of
audio insert editing.
• 8 channels (legacy): Several older audio-only decks such as the Tascam DA-98 support
eight-channel insert editing, but they communicate differently than newer digital video
decks. If you are using a Tascam DA-98 or similar device, try this option.
• 12 and 16 channels: Some high definition HDCAM SR decks support 12 channels of
audio insert editing.
To set up Final Cut Pro to output more than two channels of audio
1 Choose the third-party video or audio interface you want to use for audio output in the
A/V Devices tab of the Audio/Video Settings window, then configure its options.
For more information on selecting an audio interface in the A/V Devices tab, see
“Connecting Professional Video and Audio Equipment.”
2 Make sure that the audio outputs of your video or audio interface are physically connected
to the audio inputs of your video or audio recording device with the proper cables.
3 Configure the Audio Outputs tab (found in the Sequence Settings window) of the sequence
you want to edit to tape with the number of audio channels you want to output.
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For more information on configuring the audio outputs of sequences, see “Assigning
Output Channels and External Audio Monitors.”
4 Assign each audio track in your sequence to the proper output channel.
5 Choose a device control preset that contains an audio mapping with the same number
of audio channels as the video or audio deck you are going to output to.
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Printing to Video and Output from
the Timeline

102

This chapter covers the following:
• Different Ways You Can Output Video from the Timeline (p. 1699)
• Printing to Video (p. 1700)
• Recording from the Timeline (p. 1702)
• Outputting to VHS Tape (p. 1704)
You can output your sequence to videotape using the Print to Video command, or simply
record from the Timeline.

Different Ways You Can Output Video from the Timeline
When you’re ready to send your clip or edited sequence to videotape, you have two
options. You can use the Print to Video command or you can record directly from the
Timeline. Recording from the Timeline is the easiest option, but printing to video gives
you more control over the process and allows you to include additional elements.
• Print to Video: The Print to Video command lets you send an entire edited sequence
or clip to videotape. You can also output a section of a sequence or clip by setting In
and Out points. You can include elements on the tape such as color bars and tone, a
countdown, a slate, and a black trailer, along with your sequence or clip. You can also
loop your footage if you want to output your program multiple times on the same
tape.
Tip: You can use the Print to Video command even if your video equipment does not
have device control.
• Record from the Timeline: You can use this method at any time to record the video
output of Final Cut Pro to tape, providing a “what you see is what you get” recording
of your sequence. In this case, Final Cut Pro does not control your VTR in any way.
If you need to output your clip or sequence to tape more precisely using device control,
you can edit directly onto videotape. For more information, see “Assemble and Insert
Editing Using Edit to Tape.”
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Printing to Video
Unlike the Edit to Tape command, the Print to Video command doesn’t allow you to set
In or Out points on your tape. Instead, you manually press record whenever you want to
begin recording on tape. This is considered a crash record.
You can automatically add leader and trailer elements, such as color bars and tone, a
countdown, a slate, and a black trailer, to your movie. You can also loop your movie as
many times as you want, if you want to output your movie multiple times on the same
tape.
Tip: You can use the Print to Video command to output to any external video monitor,
regardless of whether a deck is connected. This can be useful if you want to use
Final Cut Pro to output a looping clip or sequence to an external monitor for a tradeshow
demo or video installation.

Automatically Recording with Print to Video
If you set up your VTR for remote device control (via RS-422 or FireWire), Final Cut Pro
can automatically trigger recording on your VTR when you use the Print to Video
command. This is particularly useful for camcorders that do not have an independent
VTR Record button.
You can set up a device control preset so that Final Cut Pro automatically puts your DV
camcorder or deck in Record mode before printing to video. For more information, see
“About Device Control Presets.”
To automatically start a camcorder or deck recording during Print to Video
1 Choose File > Print to Video.
2 Select the Automatically Start Recording checkbox in the Print to Video window.
3 Click OK to begin recording to tape.
Note: The Automatically Start Recording checkbox is the same as the Auto Record and
PTV checkbox shown in a device control preset.

Using the Print to Video Command
Make sure you’ve read and followed the instructions in “Preparing to Output to Tape”
before you use the Print to Video command. Make sure everything is working properly
before you start recording.

µ

To test playback
Move the playhead to the position in the Timeline where you want output to begin, then
press the Space bar to play back your clip or sequence.
If you have an external monitor connected to your video device, the clip or sequence will
play on it, as well as on your computer’s monitor.
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To print to videotape
1 Select the sequence or clip in the Browser, or open your sequence and make the Canvas
or Timeline active.
2 To output part of a sequence or clip to video, set In and Out points to designate the part
you want to record to videotape.
For more information, see “Setting Edit Points for Clips and Sequences.”
Set In and Out points,
if you wish.

3 Choose File > Print to Video.
4 Select elements you want to print along with your sequence or clip.
In this section, select
all of the options you
want to add before
the clip or sequence.

Add a trailer at the end
of the clip or sequence,
if you wish.

Use this section to add
closed captioning data
to the output video.

In this section, choose
the media you want
to print and specify
looping options
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To insert closed caption data in the output video, select the “Insert closed captioning
data from file” checkbox and click the Open button to locate the closed caption data file.
In the event that the timecode in the closed caption data file does not match the timecode
in your video, select the “Offset closed captioning data start by media in time” checkbox.
This option will reset the closed caption data to start its commands at the beginning of
video playback.
For more information about closed captions, see Final Cut Studio Workflows, available at
http://documentation.apple.com/en/finalcutstudio/workflows.
All selected elements are sent to tape in the order listed. Make sure elements you don’t
need are not selected. Some of these items may require rendering before you can start
recording. For a complete explanation of the options available, see “Mastering Settings
Tab.”
Important: Make sure there is sufficient time on your tape by using the Duration Calculator
before proceeding.
5 When you’ve finished setting options, click OK.
Transitions and effects that require rendering, along with any added elements, are rendered
automatically prior to output. You can also choose to output unrendered real-time effects
at lower quality, saving time by avoiding rendering. Options for choosing the quality of
rendered effects when using the Print to Video command can be set in the Render Control
tab of the Sequence Settings window. For more information on setting options in the
Render Control tab, see “Render Control Tab.”
Note: All audio that requires rendering is automatically rendered with a render quality
of High, regardless of the render quality setting.
6 When a message tells you to start recording, press the Record button on your camcorder
or deck. Wait a few seconds for your video device to reach a smooth recording speed,
then click OK to begin recording.
7 When playback is finished, press the Stop button on your camcorder or deck.
The last frame of your clip or edited sequence is held as a freeze frame until you stop
your recording device.

Recording from the Timeline
The easiest way to output to tape is to turn on external video output in Final Cut Pro,
play back your sequence in the Timeline, then press Record on your connected camcorder
or deck. If you want to show black before and after your program, you have to add Slug
generators to the beginning and end of your sequence, or move all the sequence clips
to the right to leave a gap before the beginning of your sequence.
Important: Make sure you’ve read and followed the instructions in “Setting Up Your
Editing System to Output to Tape.”
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To record directly from the Timeline
1 If you want to add elements before or after your program (such as showing black), add
them directly to the Timeline.
Many of these elements are available from the Generator pop-up menu. For more
information, see “Using Generator Clips.”
2 If necessary, render any unrendered effects by doing one of the following:
• Choose Sequence > Render All > Both.
• Choose Sequence > Render Selection > Both.
• Press Command-R.
For more information on additional rendering options, see “Rendering and Video
Processing Settings.”
All audio that requires rendering is automatically rendered with a render quality of High,
regardless of the render quality setting. Unrendered audio sections are output as a series
of beeps.
Tip: You can turn off the beeps by deselecting “Beep when playing back unrendered
audio” in the Playback Control tab of the System Settings window.
3 In the Timeline, move the playhead to where you want to start recording in your sequence.
Move the playhead
where you want to
start recording.

The first frame will be recorded immediately after you press Record on your camcorder
or deck. To avoid an awkward freeze frame at the beginning of your sequence, you may
want to move the playhead to an initial frame of black.
4 If you want to loop your sequence, choose View > Loop Playback so there’s a checkmark
next to it.
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When looping is turned on, your sequence will loop endlessly without stopping. There
may be a slight pause after each loop. If you need a smooth loop, use the Print to Video
command with looping turned on instead.
5 Press Record on your camcorder or deck to start recording, then wait a few seconds.
This allows your camcorder or deck to reach a smooth recording speed. Otherwise, you
could end up with unwanted video artifacts at the beginning of your tape.
6 Choose Mark > Play, then choose an option from the submenu to control how your
sequence plays back.
• In to Out: Plays back the sequence from the In point to the Out point. If you haven’t
set an In or Out point, the sequence plays from the beginning to the end.
• To Out: Plays from the current position of the playhead on the Timeline to either the
defined Out point or the end of the sequence.
• Around: Plays a specified amount of time before and after the position of the playhead,
based on the preview pre-roll and post-roll settings in the Editing tab of the User
Preferences window.
For more information about these settings, see “Editing Tab.”
• Every Frame: Plays back every frame of the sequence, whether or not rendering is
required. If there are transitions or effects in your sequence that haven’t been rendered,
your sequence will not play back in real time, but every frame will be recorded on tape.
• Forward: Plays from the current position of the playhead forward to the end of the
sequence in the Timeline.
• Reverse: Plays from the current position of the playhead back to the beginning of the
sequence in the Timeline.
7 Press the Stop button on your camcorder or deck when the sequence is finished playing
in the Timeline.
Important: The last frame in your sequence will be held as a freeze frame when playback
stops. This may be awkward if this frame is not black. To avoid this, add a Slug generator
to place black at the end of your sequence.

Outputting to VHS Tape
Although the VHS tape format is starting to be replaced by DVDs, it is still a ubiquitous
output format for work-in-progress tapes and distribution copies. There are several ways
to output to VHS tape from Final Cut Pro. Because VHS is not a digital format, and decks
rarely support device control protocols, there are no capture or sequence settings in
Final Cut Pro that correspond to the VHS format.
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One way to output to VHS is to simply output to whatever tape format corresponds to
your sequence and then make a dub from that tape to a VHS tape. The other option is
to output your digital signal to an interface that supports composite video output, such
as the AJA Io. In this scenario, the digital signal is output from the computer to the video
interface, which then converts the signal to composite analog video. The composite
analog signal can then be recorded on a VHS tape. An alternative to this method is to
use a video deck instead of a video interface to convert the digital signal from your
computer to composite analog video. For example, some DV and professional decks have
the ability to convert an incoming signal from your computer to composite analog video.
This mode is referred to as electronics-to-electronics (or E-to-E) mode, or passthrough mode.
Note: Other decks can only output to multiple video formats when a tape is playing back,
which means you have to record the signal to tape first, and then dub to VHS.
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Learning About QuickTime

103

This chapter covers the following:
• What Is QuickTime? (p. 1707)
• The QuickTime Suite of Software Applications (p. 1708)
• The QuickTime Movie File Format (p. 1708)
• Formats Supported by QuickTime (p. 1711)
• How Do You Export the Files You Need? (p. 1715)
Final Cut Pro uses QuickTime technology as a foundation for media file storage and as
an import and export method for opening multiple video, audio, and graphics file formats.

What Is QuickTime?
QuickTime is Apple’s multiplatform, multimedia technology for handling video, sound,
animation, graphics, text, interactivity, and music. As a cross-platform technology,
QuickTime can deliver content on Mac OS and Windows computers. Many applications,
including Final Cut Pro, use the powerful architecture of QuickTime to view, create, import,
and export media.
QuickTime supports most major video, audio, and graphics file formats. It works with
local disk-based media, media accessed over a network, and streams of real-time data.
QuickTime supports a wide variety of video and audio codecs and can be extended with
third-party codecs.
QuickTime technology is composed of:
• A suite of applications (most notably, QuickTime Player)
• An environment for media authoring
• A movie file format
Using an application like QuickTime Player Pro or Final Cut Pro, you can import, edit, and
export every file format that QuickTime supports. This allows you to create movies for
the web, for DVD, or for output to videotape. You can also create movies including video,
audio, text, still images, and interactive layers.
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There are various resources for learning more about QuickTime technology and
architecture.
For general information about QuickTime, go to http://www.apple.com/quicktime.
For information about QuickTime that is geared toward Apple developers, go to
http://developer.apple.com/quicktime.

The QuickTime Suite of Software Applications
When someone mentions QuickTime, people often think of the free media player
developed by Apple. However, QuickTime is much more than that. QuickTime comprises
a suite of applications that allows you to play, edit, and manipulate your media. The
QuickTime software includes:
• QuickTime Player: Apple’s free, easy-to-use application for playing, interacting with, or
viewing video, audio, virtual reality (VR), or graphics files that are compatible with
QuickTime.
• QuickTime Pro: An enhanced version of QuickTime Player that provides an abundance
of media authoring capabilities. With it, you can create movies, play movies full screen,
save files from the Internet, edit audio and video, add special effects, create slideshows,
and convert and save video, audio, and images to more than a hundred standard file
formats.
Additional QuickTime video streaming software is also available. Some of this software
is available as free downloads or already installed with Mac OS X; other components are
available for a fee. For details, go to Apple’s QuickTime website at
http://www.apple.com/quicktime.

The QuickTime Movie File Format
The QuickTime movie file format, often abbreviated to QuickTime file, is a special file format
that contains multiple tracks for storing different kinds of media. Don’t confuse this special
movie file format with other files that are simply QuickTime-compatible formats. Examples
of QuickTime-compatible file formats include AIFF, MP3, MPEG, WAVE, JPEG, and TIFF,
just to name a few. A QuickTime movie file uses a .mov file extension.
Important: Because QuickTime recognizes so many media file formats, you may notice
that a lot of media files in the Finder have a QuickTime icon, or the QuickTime Player
application may open when you double-click the icons. To be accurate, these files are
called QuickTime-compatible files, but they are not necessarily QuickTime movie files.
For example, an AIFF file is a QuickTime-compatible audio file format; it is not a QuickTime
movie file.
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How Is Information Stored in a QuickTime Movie?
QuickTime movie files store media data in separate tracks. You create a QuickTime movie
file by adding tracks that point to the media you want to use. The media may be
embedded in the file itself or in a reference movie in another file. This track architecture
is powerful and flexible, allowing you to store and synchronize multiple pieces of video
and audio media in a single file.
There are many types of tracks allowed in a QuickTime movie file. Here are a few examples
of what might be included in a QuickTime movie file used by Final Cut Pro:
• An audio track: This track contains audio media data of a certain duration, encoded
with a particular audio codec, sample rate and bit depth. The track may be mono or
contain two (stereo) or more interleaved channels of audio samples.
• A video track: This track contains video media data (a number of video frames) of a
certain duration (determined by the track’s frame rate), with particular horizontal and
vertical dimensions, and encoded with a particular video codec.
• A single still image: This track contains media for a single still image. The image data
has particular horizontal and vertical dimensions and is compressed with a particular
codec.
• A timecode track: A track that contains a number count and frame rate that corresponds
to the video frames in a video track. This track can be captured from a videotape or
created later in Final Cut Pro.
• A text track: This track contains text information that changes at specified times. A text
track could contain subtitles, or marker notes about a video or audio track.

Codecs Supported in QuickTime
Because the QuickTime file format is so flexible, practically any kind of media can be
stored in a track of its kind. However, in order to play back media stored in a track, the
QuickTime framework installed on your computer must be able to recognize the type of
compression (codec) used to encode the data.
Compression is necessary for video and audio storage on computers because the data
rates would otherwise be prohibitively high. And no matter how large computer storage
devices become, compression is still desirable because it means faster transfer time and
storing more information with less data.
The QuickTime framework libraries support a remarkable number of video and audio
codec (compressor/decompressor) algorithms. The QuickTime frameworks are extensible,
so if a company invents a codec, the company can provide a QuickTime codec to support
it. Thus, if the media in a QuickTime file is not playing back because the format or codec
of the media is not recognized, you may be able to download and install it.
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The QuickTime framework supports codecs that are commonly used today as well as
codecs that were once popular. When you go to export a QuickTime movie file, the long
list of available codecs demonstrates how extensive QuickTime codec support is. At the
same time, this list can be potentially daunting. Look for the codec you need and ignore
the rest.

Distinguishing Between File Formats and Codecs
A file’s format specifies the unique way data is stored and organized in a file, regardless
of what the content of that data represents. A codec is an algorithm that transforms
image or sound data into a more compact, albeit temporarily unintelligible form for the
purpose of compression (reducing data size for transmission or storage). The codec must
be reversed in order to see the original content of the media data.
A file format determines consistent guidelines for where information is stored and found
in a file. For example, a Microsoft Word file will always store the name of the creator in a
particular location in the file’s structure. On the other hand, a codec is specific to
media-intensive data, such as video or audio, and is used simply to reduce the data size.

Understanding Codec and File Format Naming Conventions
The distinction between file formats and codecs is often confused by shared naming
conventions. For example, MPEG-2 defines both a file format (a structure for organizing
video and audio data within media tracks) and a codec (an algorithm for encoding and
decoding video and audio data for the purposes of compression).
The following codec and file format examples may help to clarify the distinction.
• TIFF: This refers to a graphics file format. TIFF files may or may not use a codec, or type
of compression called LZW compression.
• JPEG: This is a type of compression that can be used on any still images or individual
video frames. Images encoded with JPEG compression can be stored in the JPEG file
format. QuickTime can open files in the JPEG file format as well as decode images
compressed with the JPEG codec.
• QuickTime: This refers to the QuickTime movie file format, which can contain multiple
media tracks, each containing data encoding with a number of possible codecs.
QuickTime is not a codec, but rather has the ability to present images and sound stored
with a number of codecs.
• AIFF and WAVE: These are audio file formats that contain uncompressed audio data.
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• DV: There are several DV codecs available for NTSC, PAL, and other varieties such as
DVCPRO HD. A DV camcorder uses a DV codec to turn full-resolution image data into
compressed media, which is then stored on tape. The raw data stream from tape can
be captured to your hard disk in a file format called a DV stream. Applications such as
iMovie can capture and edit DV stream files, while applications like Final Cut Pro capture
media into tracks within a QuickTime media file, allowing for more flexibility such as
adding and manipulating timecode tracks.

Time in QuickTime Movie File Tracks
Each track in a QuickTime movie file has its own playback rate and duration definition.
Usually, the rate and duration of each track are the same, or related, because the various
tracks (such as audio and video) are intended to play back in sync.
Because each track has its own independent definitions of time, you can assign a video
track a frame rate of 29.97 fps and the timecode track 23.98 fps. One example of how this
is useful is when you are editing film (24 fps) transferred to NTSC video (29.97 fps).

Formats Supported by QuickTime
QuickTime supports a lot of media formats and codecs, with many more coming all the
time. Some examples of formats and codecs supported by QuickTime follow.

Movie File Formats
File formats are the overarching structure used to store data. Different movie file formats
place video and audio media in different parts of the file, as well as the associated
metadata. The most commonly used media file formats supported by QuickTime are
described below.
AVI
AVI, or Audio Video Interleave, is a PC-compatible standard for digital video. This file type
is no longer officially supported by Microsoft, but it’s still frequently used. The AVI format
supports fewer codecs than QuickTime for video and audio and is mainly useful for
Windows delivery of video for multimedia use.
DV Stream
DV Stream files multiplex audio and video together digitally on a DV videotape. These
files are primarily for use with iMovie. Final Cut Pro converts DV streams to QuickTime
movies with independent video and audio tracks during capture.
MPEG-2
MPEG-2 is a video standard used for modern digital video format, including digital
television broadcast and DVD.
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MPEG-4
MPEG-4 is an open standard video format intended for cross-platform, Internet, and
multimedia delivery of video and audio content.
QuickTime Movie
This is a general-purpose media format that can contain multiple video, audio, text, and
other tracks. This is the native file format used by Final Cut Pro for capturing and export.

Video Codecs Supported Within Video File Formats
A video codec is an algorithm for encoding video images in space (within a frame) and
time (across multiple frames) to compress the data requirements while still producing
an acceptable image. Not all codecs are supported by all file formats.
Uncompressed (None)
This isn’t really a codec, but a way of storing QuickTime movies with no compression at
all. Since applying compression generally results in video artifacts, no compression
guarantees the highest quality. Unfortunately, it also guarantees enormous file sizes, and
they will not play back in real time on most systems.
Uncompressed movies can have an alpha channel. Alpha channels define levels of
transparency in your movie and are useful if you’re delivering an effects shot for use in
someone else’s composition. For more information on alpha channels, see “Compositing
and Layering.”
Animation
The Animation codec was developed for computer-generated imagery, which often has
large areas of uniform color and little, if any, noise. It is a lossless codec, which means it
doesn’t degrade quality or add artifacts to your video when it applies compression. For
more information, see “Video Compression.”
Video footage, which generally has more grain, noise, and variations of texture and color
than animated material, may not be compressed as much with the Animation codec as
with other methods. Because some lossless compression is better than none, this codec
is used more frequently than Uncompressed.
Note: Animation movies will not play back in real time on most systems. Animation
movies can also have an alpha channel.
DV Codecs
QuickTime supports a wide range of DV codecs, including DV NTSC and DV PAL, DVCPRO
50, and DVCPRO HD. This allows you to natively capture, edit, and play back footage from
DV camcorders without first transcoding to another format.
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Apple M-JPEG
There are two Apple M-JPEG codecs, M-JPEG A and M-JPEG B. These are variable data
rate codecs similar to the ones used by video capture cards. If you need to deliver more
heavily compressed material to keep files small, consider these codecs. M-JPEG is a “lossy”
codec (meaning visual information is permanently removed from the video frames) and
will result in artifacts in your video. The severity of these artifacts depends on the data
rate you choose.
Several video interface cards on the market can play back either M-JPEG A or M-JPEG B
in real time without rerendering the material, or, at most, doing minimal rerendering.
This makes file interchange very fast. Before you use either M-JPEG A or B, consult the
manufacturer of the capture card you’re using to find out which one you should use.
Note: Apple M-JPEG movies cannot have alpha channels.
JPEG
JPEG is similar to M-JPEG, except that the compression artifacts can be less severe at
similar data rates. JPEG movies may play back in real time on your system, depending on
your system’s capabilities and the data rate of the movie.
Note: JPEG movies cannot have alpha channels.
Third-Party Codecs
There are several manufacturers of video-editing solutions, most of whom use different
variations of the M-JPEG codec. Many make software-only QuickTime codecs that you
can install on your system, enabling you to play back movies with little or no rerendering.
For more information, contact the manufacturer of the editing system.
Note: Most third-party codecs cannot have alpha channels.

Graphics and Still-Image Formats
Here is a list of common graphics and still-image formats:
• BMP: Standard bit-mapped graphics format used on Windows computers.
• FlashPix: A format for storing digital images, especially digital photographs, developed
by Eastman Kodak Company.
• GIF: Graphic Interchange Format. A common bit-mapped graphics file format used on
the web.
• JPEG/JFIF: Joint Photographics Experts Group. A “lossy” compression file format used
for images. JFIF is JPEG File Interchange Format.
• MacPaint (PNTG): A monochrome file format used on early versions of the Mac operating
system.
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• Photo JPEG: An extremely popular file format because it can create highly compressed
yet good-looking graphics files. You can choose grayscale or color as well as the amount
of compression.
• Photoshop (PSD): You can import files created or saved in the Photoshop format, along
with multilayered Photoshop files. (For more information, see “Compositing and
Layering.”)
• PICS: A file format used on Mac OS computers for animation sequences. The format is
no longer used, in favor of QuickTime.
• PICT: A common image format used on Mac OS computers. PICT files can use any of
the standard QuickTime codecs for compression in color or grayscale.
• PNG: Portable Network Graphics. A file format for bitmapped graphic images designed
as the successor to GIF.
• QuickTime Image File (QTIF): A QuickTime container file that contains an image using
a supported QuickTime codec.
• SGI: Silicon Graphics Image file format.
• TARGA (TGA): The Targa file format. An uncompressed file format that stores images
with millions of colors. Targa files are supported by nearly every platform and media
application.
• TIFF: Common on Mac OS and Windows computers. TIFF files allow color depths from
dithered black and white to millions of colors and one form of compression.
Note: Almost all of these file formats can contain an alpha channel.

Audio File Formats
The following is a list of common audio file formats:
• AAC or .mp4: Advanced audio coding. This format is a continuation of the MP3 audio
format, improving quality while reducing file size. This audio format is commonly used
in MPEG-4 multimedia files, and can support features such as surround sound.
• AIFF/AIFC: Audio Interchange File Format. An audio format for Mac computers commonly
used for storing uncompressed, CD-quality sound (similar to WAVE files for
Windows-based PCs).
• Audio CD Data (.cdda): Compact Disc Digital Audio. Audio files stored on CD.
• MP3: Short for MPEG-1, layer 3 audio. This is a very popular format for online music
distribution.
• Sound Designer II: Sound Designer II, sometimes seen abbreviated as SD2. A monophonic
and stereophonic audio file format, originally developed by Digidesign for Mac
computers.
• System 7 Sound: An older sound format developed by Apple.
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• uLaw: File format developed by Sun that provides logarithmic encoding for a larger
dynamic range than normal 8-bit samples. Approximately equivalent to 12-bit samples,
but suffers from more noise than linear encodings.
• WAVE: The format for storing sound in files developed jointly by Microsoft and IBM.
For a complete list of all QuickTime-compatible file formats, see the documentation that
came with QuickTime Pro or visit Apple’s QuickTime website at
http://www.apple.com/quicktime.

How Do You Export the Files You Need?
There are two commands in Final Cut Pro that you use to output QuickTime content.
• Export QuickTime Movie: This command allows you to export your Final Cut Pro sequence
as a QuickTime movie, choosing from available sequence presets and including markers
for use in other applications (such as DVD Studio Pro).
• Export Using QuickTime Conversion: Choose this option to export QuickTime-compatible
file types from your clips or sequences:
• A broadcast-quality, full-resolution, uncompressed QuickTime file
• A still image
• A numbered image sequence
• A highly compressed QuickTime file for multimedia or web use
• Audio only
If you want to export a file that uses the same settings as those of your clip or sequence,
the Export QuickTime Movie command might be what you need for a quick output. For
more information, see “The Export QuickTime Movie Command.”
The Export Using QuickTime Conversion command gives you more flexibility, particularly
in terms of the type of compression and file formats supported. For more information,
see “The Export Using QuickTime Conversion Command.”

The Export QuickTime Movie Command
The Export QuickTime Movie command creates a new QuickTime movie file. You can use
this command to export Final Cut Pro clips or sequences with their current settings or
any of the sequence settings available in Final Cut Pro.
This command allows you to choose settings based on sequence presets in Final Cut Pro.
You can also choose to use the existing settings of the clip or sequence you are exporting,
or create customized settings in a custom Sequence Preset Editor. If you are exporting
using the existing settings, you can choose whether or not to recompress the frames.
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If you want to export your movie in a format that is not natively supported by Final Cut Pro,
such as a QuickTime movie file with a video codec used for the web, you should use the
Export Using QuickTime Conversion command instead. If you are exporting with the same
settings as your sequence, or if you want to convert to some other video format commonly
supported by Final Cut Pro, you should use the Export QuickTime Movie command.

The Export Using QuickTime Conversion Command
Unlike the Export QuickTime Movie command, which only exports to a QuickTime movie
file, the Export Using QuickTime Conversion command allows you to export to almost
any file format QuickTime supports, using any video and audio codec supported by that
format. Everything is customizable: image dimensions, frame rate, audio sample rate,
video codec, audio codec, and so on.
Note: Because QuickTime has extensive support for most codecs and file formats, there
may be a lot of options for some formats.
While the Export Using QuickTime Conversion command may seem advantageous, there
are times when the Export QuickTime Movie command may be better. For example,
Export Using QuickTime Conversion always recompresses your media, even if you select
the same codec, and in 8-bit only. The Export QuickTime Movie command has an option
for not recompressing frames, reducing unnecessary artifacts when exporting to the same
video codec. It is also 8-bit only. Use Export QuickTime Movie for the best quality with
10-bit codecs.
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Using Share

104

The Share feature is an easy, “one-click” way to send your work to clients, friends, and
other audiences without any advanced knowledge of transcoding, delivery file formats,
or FTP protocols. From the Share window in Final Cut Pro, you can quickly create and
deliver output media files in iPod, iPhone, Apple TV, MobileMe, DVD, Blu-ray Disc, and
YouTube formats without having to open any additional applications. Just choose Share
from the File menu, select the intended playback device or platform, and click Export.
Share supports the following output media types and related post-processing actions:
• Apple TV: Create a video file suitable for viewing on Apple TV and automatically add
the file to the iTunes library.
For more information, see “Using Share to Create Apple TV Output” and “Apple TV,
iPhone, and iPod Action Drawers.”
• Blu-ray: Create Blu-ray video and audio files and automatically burn them to a Blu-ray
disc or an AVCHD disc.
For more information, see “Using Share to Create Blu-ray Output” and “Blu-ray Action
Drawer.”
• DVD: Create MPEG-2 (.m2v) video and Dolby Digital Professional (.ac3) audio files and
automatically burn them to a standard definition DVD disc.
For more information, see “Using Share to Create DVD Output” and “DVD Action Drawer.”
• iPhone: Create an output media file suitable for iPhone playback and automatically
add the file to the iTunes library.
For more information, see “Using Share to Create iPhone Output” and “Apple TV, iPhone,
and iPod Action Drawers.”
• iPod: Create an output media file suitable for iPod playback and automatically add the
file to the iTunes library.
For more information, see “Using Share to Create iPod Output” and “Apple TV, iPhone,
and iPod Action Drawers.”
• MobileMe: Create a video file suitable for viewing in a MobileMe Gallery and
automatically upload the file to a MobileMe account.
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For more information, see “Using Share to Create MobileMe Output” and “MobileMe
Action Drawer.”
• YouTube: Create a video file suitable for viewing on YouTube and automatically upload
the file to a YouTube account.
For more information, see “Using Share to Create YouTube Output” and “YouTube
Action Drawer.”
• Apple ProRes 422: Create a QuickTime movie using the Apple ProRes 422 codec and
automatically open the file with another application, such as QuickTime Player. This
movie would be suitable for further editing in Final Cut Pro and other applications.
For more information, see “Using Share to Create Apple ProRes 422 Output” and “Apple
ProRes and QuickTime H.264 Action Drawers.”
• Apple ProRes with Alpha: Create a QuickTime movie with an embedded alpha channel
using the Apple ProRes 4444 codec, and automatically open the file with another
application, such as QuickTime Player. This movie would be suitable for further editing
in Final Cut Pro and other applications, especially workflows that require an alpha
channel.
For more information, see “Using Share to Create Apple ProRes with Alpha Output”
and “Apple ProRes and QuickTime H.264 Action Drawers.”
• QuickTime H.264: Create a QuickTime movie using the H.264 codec set to very high
quality, original frame size, and a low data rate, and automatically open the file with
another application, such as QuickTime Player. This movie would be suitable for playback
on a desktop computer.
For more information, see “Using Share to Create QuickTime H.264 Output” and “Apple
ProRes and QuickTime H.264 Action Drawers.”
• Compressor settings: Create an output media file based on any (preset) setting from
the list of settings provided by Compressor, and automatically open the file in the
appropriate media player application.
For more information, see “Using Share with Compressor.”
You can also do the following when you export via Share:
• View or adjust the status of any Share export session in the Batch Monitor application.
• Open Share export sessions in Compressor to use the advanced transcoding features
of that application.
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About the Share Window
The central tool for the Share feature is the Share window. For a given Share export
session, you can add or remove any number of outputs.

Individual outputs in the Share window include the following controls.
Output Type

Filename field

Action checkbox (present only
for some output types)

Add Output and Remove
Output buttons

Show Info button

• Destination Folder pop-up menu: Use this pop-up menu to navigate to your chosen
destination folder or open the mounted volume for the output media files.
• Choose button: Use this button to open a dialog to locate and select the destination
folder for the output media files. (This is an alternative to the Destination Folder pop-up
menu.)
• Output Type pop-up menu: Use this pop-up menu to choose the type of output media
file. The choices are Apple TV, Blu-ray, DVD, iPhone, iPod, MobileMe, YouTube,
Apple ProRes 422, Apple ProRes with Alpha, QuickTime H.264, and Other.
• Outputs: Each output represents a separate media file that will be generated from the
current selection in Final Cut Pro. For example, in Final Cut Pro, you can select a clip
and then create an iPod version, burn a DVD, and upload a copy to YouTube, all from
the same source clip, and all at the same time. For more information about creating
multiple outputs, see “Creating Multiple Outputs.”

Chapter 104 Using Share

1719

• Filename field: Share automatically enters a filename in this field for the output media
file. The first part of the filename is based on the Final Cut Pro Browser clip or sequence
name. (In the case of multiple sources, this part of the filename will be [Source].) Share
also automatically appends an output type identifier (such as “iPod” or “YouTube”) at
the end of the filename. In most cases, you can manually edit any portion of the filename
by double-clicking it.
• Output type identifier: Share automatically appends an output type identifier (such as
“iPod” or “YouTube”) at the end of each filename. You can manually edit any output
type identifier by double-clicking it.
• Action checkbox: Select this checkbox to activate any post-transcoding actions (beyond
simply creating the output media file). For more information, see “Post-Transcoding
Actions.”
• Add Output and Remove Output buttons: Click Add Output to create additional outputs.
To remove a particular output, click its Remove Output button.
• Show Info button: Click this button to display extensive details about the current setting
and the output media file. If you are exporting a group of clips or sequences and you
have selected “Export as separate sources” in the Multiple Sources dialog, you can click
this button to view information about each individual output media file.
• Cluster pop-up menu: Use the Cluster pop-up menu to choose which computer or
cluster will process the batch. The default Cluster setting is This Computer, which means
Share will not involve any other computers in completing the batch. You can choose
from any other available clusters that appear in this list. See
Distributed Processing Setup Guide, available in Compressor Help or Apple Qmaster Help,
for more details on setting up an Apple Qmaster distributed processing network.
• Send to Compressor button: Click Send to Compressor to open a batch in the Compressor
application based on all the current Share window outputs (and their applied settings).
This allows you to use the advanced transcoding features in Compressor to complete
the export session. For information about using Compressor, see the Compressor
User Manual, available in Compressor Help.
• Export button: Once you have created all the outputs you want in the Share window
and are satisfied with the settings and details of your intended output media files, you
are ready to export. You do this by clicking the Export button.

Post-Transcoding Actions
For many of the output types, additional settings are available to control actions taken
once the output media is created. The actions include uploading the clip to your YouTube
account, posting it on your MobileMe page, burning a DVD, and other similar actions,
each specific to the selected output type.
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These settings are accessed in an action drawer, which appears to the right of the Share
window when you select the action checkbox for an output type.

µ

To open the action drawer for an output
Select the action checkbox for the output you want to modify.
The action drawer opens.
Apple TV, iPhone, and iPod Action Drawers
The action drawers for Apple TV, iPhone, and iPod are identical and consist of a single
pop-up menu.

• Add to Playlist pop-up menu: Use the Add to Playlist pop-up menu to add the output
media file to a particular playlist in your iTunes media library.
Note: The first time you use Share, this pop-up menu is empty. To populate this menu
with playlists from your iTunes library, choose Refresh from the Add to Playlist pop-up
menu.
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Blu-ray Action Drawer
Use this drawer to enter information and settings for the Blu-ray disc you want to burn.

• Output Device pop-up menu: Use this pop-up menu to choose the device to format to.
The pop-up menu displays a list of your system’s suitable output devices, including
optical drives and the computer’s hard disk. Choose Hard Drive (Blu-ray) to create a
disk image (.img) file that you can burn to Blu-ray Disc media at a later time using the
Disk Utility application (available in the Utilities folder). Other settings may change
depending on the device you choose.
Note: You can also create AVCHD discs that contain HD video content and menus using
standard red laser media and a standard DVD burner. AVCHD discs can be played in
Blu-ray players that are specifically compatible with AVCHD discs. For AVCHD discs, the
average bit rate is 14.7 Mbps with a 17 Mbps maximum (compared to a 30 Mbps average
bit rate and a 34.5 Mbps maximum for Blu-ray discs). To create an AVCHD disc, choose
a DVD burner from the Output Device pop-up menu and insert a DVD disc when
prompted.
• Disc Template pop-up menu: Use this pop-up menu to choose a menu template for the
disc.
• Title field: Use this field to enter a name for the program on the disc.
• When Disc Loads pop-up menu: Use this pop-up menu to choose what happens when
the disc loads in the player.
• Show Menu: Choose this option to show the menu.
• Play Movie: Choose this option to play the movie.
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• Use Chapter Marker Text as Subtitles checkbox: Select this checkbox to have marker text
appear as subtitles. This is particularly useful if you are using the “Combine sources
into one source” and the “Add chapter markers at the beginning of each source” features
in the Multiple Sources dialog. This allows you to line up a series of clips or scenes and
identify each item with a marker text subtitle. For more information, see “About the
Multiple Sources Dialog.”
Note: Subtitles are not supported on AVCHD discs.
• Include Loop Movie Button checkbox: Select this checkbox to add a Loop Movie button
to the menu. This option is not available for all disc templates.
• Background button: Opens a dialog that lets you locate and select a background graphic.
• Logo Graphic button: Opens a dialog that lets you locate and select a logo graphic.
• Title Graphic button: Opens a dialog that lets you locate and select a title graphic.
• Main Menu and Chapter Menu preview: Use the Main Menu and Chapter Menu buttons
to display previews of the menus included with the selected template.
DVD Action Drawer
Use this drawer to enter information and settings for the DVD you want to burn.

• Output Device pop-up menu: Use this pop-up menu to choose the device to format to.
The pop-up menu displays a list of your system’s suitable output devices, including
optical drives and the computer’s hard disk. Choose Hard Drive to create a disk image
(.img) file that you can burn to DVD media at a later time using the Disk Utility
application (available in the Utilities folder). Other settings may change depending on
the device you choose.
• Disc Template pop-up menu: Use this pop-up menu to choose a menu template for the
DVD.
• Title field: Use this field to enter a name for the program on the DVD.
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• When Disc Loads pop-up menu: Use this pop-up menu to choose what happens when
the disc loads in the player.
• Show Menu: Choose this option to show the menu.
• Play Movie: Choose this option to play the movie.
• Use Chapter Marker Text as Subtitles checkbox: Select this checkbox to have marker text
appear as subtitles. This is particularly useful if you are using the “Combine sources
into one source” and the “Add chapter markers at the beginning of each source” features
in the Multiple Sources dialog. This allows you to line up a series of clips or scenes and
identify each item with a marker text subtitle. For more information, see “About the
Multiple Sources Dialog.”
• Title Graphic button: Opens a dialog that lets you locate and select a title graphic.
• Main Menu and Chapter Menu preview: Use the Main Menu and Chapter Menu buttons
to display previews of the menus included with the selected template.
MobileMe Action Drawer
Use this drawer to enter information about movies you want to publish to a MobileMe
Gallery on the web.

• User Name: Use this field to enter a MobileMe member name. Do not include “@me.com”
or “@mac.com.”
The MobileMe member name is required for successful uploading via Share.
• Password: Use this field to enter a MobileMe password.
The MobileMe password is required for successful uploading via Share.
• Title: Use this field to enter the name of the movie you are publishing.
• Description: Use this field to enter a description of the movie you are publishing.
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• “Hide Movie on my Web Gallery page” checkbox: Select this checkbox to limit viewing to
the movie you are publishing. In other words, viewers will not have access to other
items in your MobileMe Gallery.
• “Allow movies to be downloaded” checkbox: Select this checkbox to allow viewers to
download the movie you are publishing.
• “Viewable by” pop-up menu: Use this pop-up menu to control viewing access to the the
movie you are publishing.
• Everyone: Choose this option to make the movie freely available on the web.
• Only me: Choose this option to limit access to only those who know your MobileMe
member name and password.
• Edit Names and Passwords: Choose this option to open the Names and Passwords
dialog, in which you create names and passwords to restrict viewing of your published
movies. You can assign only one name and password to each movie, but you can
use the same name and password for multiple movies. Names may contain letters,
numbers, underscores, and one dot (.). Names and passwords are case sensitive.
Passwords must contain four or more characters.
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YouTube Action Drawer
Use this drawer to enter information about movies you want to publish to a YouTube
account on the web.

Important: You must complete all fields for successful uploading via Share.
• Username: Use this field to enter a YouTube user name.
• Password: Use this field to enter a YouTube password.
• Title: Use this field to enter the name of the movie you are publishing.
• Description: Use this field to enter a description of the movie you are publishing.
• Tags: Use this field to enter keywords that describe your movie. These are search terms
that your intended audience might use to find your movie on YouTube. For more
information, see YouTube Help.
• Category pop-up menu: Use this pop-up menu to choose a YouTube category for your
movie. On YouTube, a movie can belong to one of several categories (topic areas).
• “Make this movie private” checkbox: Select this checkbox to control viewing access to
the movie you are publishing. When you make a video private on YouTube, you have
the option of sharing it with a select number of people from any of the contact lists
you create for your account. See YouTube Help for more information.
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Apple ProRes and QuickTime H.264 Action Drawers
The action drawers for the two Apple ProRes outputs and the QuickTime H.264 output
are identical and consist of a single pop-up menu.

• Open With pop-up menu: Use this pop-up menu to either confirm or choose the
application that will open the output media file. The default application is
QuickTime Player.

Exporting Single Clips and Sequences with Share
The simplest way to use Share is to export a single clip or sequence to a single output
media file.
To export a single clip or sequence using Share
1 In Final Cut Pro, select the clip or sequence you want to export.
Note: For information about allowable selections for exporting, see “Making Selections
for Share Export.”
2 Choose File > Share.
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The Share window opens.

3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media file.
4 Choose an output type in the Output Type pop-up menu.
5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, select the action checkbox for the output to activate any post-transcoding
actions.
The action drawer opens.
For details of the post-transcoding actions for each output type, see “Post-Transcoding
Actions.”
7 Optionally, use the Cluster pop-up menu to choose which computer or cluster will process
the batch.
The default computer is This Computer, meaning the computer on which Final Cut Pro
is open.
8 Click Export.
The Transcoding Progress window appears and Share creates the output media files. Click
the Cancel button to stop the export process.

Making Selections for Share Export
Using Share, you can export three kinds of selections (of individual clips or sequences):
• A selected sequence in the Browser or the current sequence in the Timeline
• A selected Browser clip
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• Media between a clip’s or a sequence’s In and Out points
Share always respects any In and Out points.
For information about group selections, see “Types of Group Selections.”

Using Share with Chapter Markers
Share supports chapter markers for all output formats and devices. You can add chapter
markers to sequences and clips in Final Cut Pro and all output media files will include the
corresponding chapter markers. For information on adding chapter markers in
Final Cut Pro, see “Exporting QuickTime Movies,” “Exporting Sequences for DVD,” and
“Using Markers.”
Additionally, you can have Share automatically insert chapter markers between the clips
and sequences in a multiple selection. (This option is available only when you choose to
combine multiple sources into one source.) For more information, see “About the Multiple
Sources Dialog” and “Exporting a Single Output from a Group Selection.”

Exporting Groups of Clips and Sequences with Share
You can export groups of clips or sequences with Share.
To export a group of clips or sequences using Share
1 In Final Cut Pro, make a multiple selection by doing any of the following, in any
combination:
• Select two or more Browser clips or sequences, or both.
• Select one or more bins containing multiple clips or sequences.
See “Types of Group Selections” for more information on the possible types of selections.
Group selections have the following restrictions:
• If a group selection has items with varying frame sizes, the frame size of the first item
in the selection is applied to all items in the group.
• If you select “Combine sources into one source” in the Multiple Sources dialog:
• All items in a multiple-sequence selection must have the same frame rate (timebase).
• Multiple-clip selections can have differing frame rates, but in that case, the output
media file will have the frame rate of the first clip in the selection.
2 Choose File > Share.
The Multiple Sources dialog opens with the default setting “Export as separate sources”
selected.
Although this particular workflow does not require it, you can see more information about
the options in the Multiple Sources dialog in “About the Multiple Sources Dialog.”
3 Click OK.
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The Share window opens with a single output representing the group selection you made
in step 1.
4 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
5 Choose an output type for the group of output media files in the Output Type pop-up
menu.
For more information, see “Working with Share Output Types.”
6 Optionally, use the Filename Template to edit the formula for the names of the output
media files.
Note: In this “separate sources” case, the Filename Template displays the name token as
[Source]. This placeholder token cannot be edited or deleted. On output, this placeholder
token is replaced with the source filename.
7 Optionally, click the Show Info button to see detailed information about each output
media file.
8 Optionally, remove or add any additional outputs by clicking the Remove Output or Add
Output button.
For more information, see “Creating Multiple Outputs.”
9 Optionally, select the action checkbox for the output to activate any post-transcoding
actions.
The action drawer opens.
For details of the post-transcoding actions for each output type, see “Working with Share
Output Types.”
10 Optionally, use the Cluster pop-up menu to choose which computer or cluster will process
the batch.
The default computer is This Computer, meaning the computer on which Final Cut Pro
is open.
11 Click Export.
The Transcoding Progress window appears and Share creates the output media files. Click
the Cancel button if you want to stop the export process.

Types of Group Selections
Using Share, you can export groups of clips and sequences in the following combinations:
• A group of sequences
• A group of Browser clips
• A group of sequences and Browser clips
• A group of sequences and/or Browser clips as multiple sources
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• A group of sequences and/or Browser clips as a single source
• One or more bins in the Browser, each containing any combination of multiple clips
or sequences
Group selections have the following restrictions:
• If a group selection has items with varying frame sizes, the frame size of the first item
in the selection is applied to all items in the group.
• If you select “Combine sources into one source” in the Multiple Sources dialog:
• All items in a multiple-sequence selection must have the same frame rate (timebase).
• Multiple-clip selections can have differing frame rates, but in that case, the output
media file will have the frame rate of the first clip in the selection.

About the Multiple Sources Dialog
When Share detects that you have exported a group of clips or sequences, the Multiple
Sources dialog appears, offering the following options for your output.

• “Export as separate sources” button: Select this option to create a separate output media
file for each source clip or sequence.
• “Combine sources into one source” button: Select this option to create a single output
media file containing all source clips or sequences.
• Custom Name field: Enter a name for the output media file. (Available only when
“Combine sources into one source” is selected.)
• Total Duration field: This field displays the total running time of the output media file.
(Available only when “Combine sources into one source” is selected.)
• “Add chapter markers at the beginning of each source” checkbox: Select this option to
automatically insert chapter markers between the clips and sequences in your multiple
selection. (Available only when “Combine sources into one source” is selected.)
• “Name markers with” pop-up menu: Choose one of the following options for naming
chapter markers in the output media file. (This option pertains to the chapter markers
generated by the “Add chapter markers at the beginning of each source” checkbox.)
• Source Name: Uses the source media filename as the chapter marker name.
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• Source Number: Chapter marker names are Source 1, Source 2, Source 3, and so on.
• Chapter Number: Chapter marker names are Chapter 1, Chapter 2, Chapter 3, and so
on. If the individual sources contain previously entered chapter markers, they are
inserted between the automatically generated chapter markers in the following
fashion: Chapter 1, <Existing Chapter Marker>, <Existing Chapter Marker>, Chapter
4, <Existing Chapter Marker>, Chapter 6, and so on.

Exporting a Single Output from a Group Selection
When you export via Share, you can create a single output media file from multiple
sources. For example, you might want to create a dailies DVD containing all the takes
from one day of shooting.
To create a single output media file from multiple sources
1 In Final Cut Pro, select two or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
Group selections have the following restrictions:
• If a group selection has items with varying frame sizes, the frame size of the first item
in the selection is applied to all items in the group.
• If you select “Combine sources into one source” in the Multiple Sources dialog:
• All items in a multiple-sequence selection must have the same frame rate (timebase).
• Multiple-clip selections can have differing frame rates, but in that case, the output
media file will have the frame rate of the first clip in the selection.
2 Choose File > Share.
The Multiple Sources dialog opens with the default setting “Export as separate sources”
selected.

Although this particular workflow does not require it, you can see more information about
the options in the Multiple Sources dialog in “About the Multiple Sources Dialog.”
3 Click “Combine sources into one source.”
4 Configure the dialog using the information in “About the Multiple Sources Dialog.”
5 Click OK.
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The Share window opens with a single output representing the group selection you made
in step 1.
6 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
7 Choose an output type in the Output Type pop-up menu.
8 Confirm the output filename in the Filename field.
Optionally, you can double-click the filename to edit it.
9 Optionally, click the Show Info button to see detailed information about the output media
file.
10 Optionally, remove or add any outputs by clicking the Remove Output or Add Output
button.
For more information, see “Creating Multiple Outputs.”
11 Optionally, select the action checkbox for the output to activate any post-transcoding
actions.
The action drawer opens.
For details of the post-transcoding actions for each output type, see “Post-Transcoding
Actions.”
12 Optionally, use the Cluster pop-up menu to choose which computer or cluster will process
the batch.
The default computer is This Computer, meaning the computer on which Final Cut Pro
is open.
13 Click Export.
The Transcoding Progress window appears and Share creates the output media files. Click
the Cancel button if you want to stop the export process.

Creating Multiple Outputs
When you export via Share, you can create multiple outputs from a single source. For
example, you might want to create an iPod version, burn a DVD, and upload a copy to
YouTube, all at the same time.
To add an output in the Share window
1 In the Share window, click the Add Output (+) button on the right side of any existing
output.
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2 Use the Output Type pop-up menu in the output you just created to assign a specific
output type.

µ

To remove an output from the Share window
In the Share window, click the Remove Output (–) button on the right side of the output
you want to remove.

Remove button

Using Share with Compressor
Compressor, the professional transcoding application included in Final Cut Studio, provides
high performance and maximum control over the media conversion and encoding
workflows.
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There are two ways you can use the Share feature with Compressor:
• Use the Send to Compressor feature to open the Share export session in Compressor.
• Use the Other output type to access preexisting Compressor settings.

Sending Outputs to Compressor
You can tap the advanced transcoding features in Compressor by sending one or more
Share outputs to Compressor. Clicking the Send to Compressor button opens a batch in
Compressor based on all the current Share window outputs (and their applied settings).
This allows you to use the advanced transcoding features in Compressor to complete the
export session. You can use default Apple settings or create custom settings for future
Share exports. For information about using Compressor, see the Compressor User Manual,
available in Compressor Help.
To send one or more Share outputs to Compressor
1 Follow the steps for exporting single clips and sequences or groups of clips and sequences.
For more information, see “Exporting Single Clips and Sequences with Share” and
“Exporting Groups of Clips and Sequences with Share.”
2 In the final step, click the Send to Compressor button (instead of Export).
Compressor opens with a new batch containing the outputs from the Share window.

Using the Other Output Type to Access Compressor Settings
From within any Share export session, you can access the complete collection of over
one hundred Apple (preset) settings as well as any custom settings you create. Additionally,
you can add any Apple or custom Compressor settings or settings groups to the Share
window for future Share export sessions.
For complete instructions, see “Using Share to Create Other Output Types.”
For more information about Compressor settings, see the Compressor User Manual, available
in Compressor Help.

Working with Share Output Types
The following sections cover all the workflow details for each of the six default Share
output types as well as the Other option. In particular, the following sections describe
the steps involved in adding post-transcoding actions.

Using Share to Create Apple TV Output
Use this output to create a video file suitable for viewing on Apple TV and add the file to
the iTunes library.
To create an output media file for Apple TV
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
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See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose Apple TV.

5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, you can select the Add to iTunes Library checkbox to have Share automatically
add the output media file to an iTunes playlist.
The action drawer opens.
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Use the Add to Playlist pop-up menu to add the output media file to a particular playlist
in your iTunes media library.
Note: The first time you use Share, this pop-up menu is empty. To populate this menu
with playlists from your iTunes library, choose Refresh from the Add to Playlist pop-up
menu.
7 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process.
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create Blu-ray Output
Use this output to create H.264 video and Dolby Digital Professional (.ac3) audio files and
automatically burn them to a Blu-ray disc or an AVCHD disc.
To burn a Blu-ray disc or an AVCHD disc using H.264 video and Dolby Digital
Professional (.ac3) audio
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose Blu-ray.
5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, you can select the Create Blu-ray Disc checkbox to have Share prompt you
to insert a blank disc and then automatically burn the program to the disc.
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The action drawer opens.

If you do not select the Create Blu-ray Disc checkbox, Share writes the output media files
to the specified destination without creating a disc image.
7 Optionally, enter information in the action drawer.
For more information about these items, see “Blu-ray Action Drawer.”
8 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create DVD Output
Use this output to create MPEG-2 (.m2v) video and Dolby Digital Professional (.ac3) audio
files and automatically burn them to a standard definition DVD.
To burn a standard definition DVD using MPEG-2 (.m2v) video and Dolby Digital
Professional (.ac3) audio
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
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3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose DVD.

5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, you can select the Create DVD checkbox to have Share prompt you to insert
blank DVD media and then automatically burn the program to the DVD media.
The action drawer opens.

If you do not select the Create DVD checkbox, Share writes the output media files to the
specified destination without creating a disc image.
7 Optionally, enter information in the action drawer.
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For more information about these items, see “DVD Action Drawer.”
8 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create iPhone Output
Use this output to create an output media file suitable for iPhone playback and add the
file to the iTunes library.
To create an output media file for iPhone
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose iPhone.

5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
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6 Optionally, you can select the Add to iTunes Library checkbox to have Share automatically
add the output media file to an iTunes playlist.
The action drawer opens.

Use the Add to Playlist pop-up menu to add the output media file to a particular playlist
in your iTunes media library.
Note: The first time you use Share, this pop-up menu is empty. To populate this menu
with playlists from your iTunes library, choose Refresh from the Add to Playlist pop-up
menu.
7 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window to stop the export process.
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create iPod Output
Use this output to create an output media file suitable for iPod playback and add the file
to the iTunes library.
To create an output media file for iPod
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
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3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose iPod.

5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, you can select the Add to iTunes Library checkbox to have Share automatically
add the output media file to an iTunes playlist.
The action drawer opens.

Use the Add to Playlist pop-up menu to add the output media file to a particular playlist
in your iTunes media library.
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Note: The first time you use Share, this pop-up menu is empty. To populate this menu
with playlists from your iTunes library, choose Refresh from the Add to Playlist pop-up
menu.
7 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process.
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create MobileMe Output
Use this output to create a video file suitable for viewing in a MobileMe Gallery and upload
the file to a MobileMe account.
To publish an output media file to a MobileMe Gallery
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose MobileMe.
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5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, you can select the Publish to MobileMe checkbox to automatically upload
the output media file to a MobileMe Gallery on the web.
The action drawer opens.

7 To automatically upload the output media file to a MobileMe Gallery, enter the account
information in the appropriate fields.
For information about the fields in the MobileMe Action drawer, see “MobileMe Action
Drawer.”
Note: The MobileMe member name and password are required information for automatic
uploads.
8 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process.
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create YouTube Output
Use this output to create a video file suitable for viewing on YouTube and upload the file
to a YouTube account.
To publish an output media file on YouTube
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
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See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose YouTube.

5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, you can select the Publish to YouTube checkbox to automatically upload the
output media file to a YouTube account on the web.
The action drawer opens.
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7 To automatically upload the output media file to a YouTube account, enter the account
information in the appropriate fields.
For information about the fields in the YouTube Action drawer, see “YouTube Action
Drawer.”
Note: All fields are required in the YouTube Action drawer.
8 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process.
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create Apple ProRes 422 Output
Use this output to create a QuickTime movie using the Apple ProRes 422 codec and
automatically open the file with another application, such as QuickTime Player. This movie
would be suitable for further editing in Final Cut Pro and other applications.
To create an output media file using the Apple ProRes 422 codec
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
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4 In the Output Type pop-up menu, choose Apple ProRes 422.

5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, you can select the Open with QuickTime Player checkbox to have Share
automatically open the output media file in QuickTime Player when the export session
is complete.
The action drawer opens.

QuickTime Player is the default application.
7 Optionally, use the “Open with” pop-up menu to either confirm QuickTime Player or
choose a different application to open the output media file.
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8 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process.
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create Apple ProRes with Alpha Output
Use this output to create a QuickTime movie with an embedded alpha channel using the
Apple ProRes 4444 codec, and automatically open the file with another application, such
as QuickTime Player. This movie would be suitable for further editing in Final Cut Pro and
other applications, especially in workflows that require an alpha channel.
To create an output media file with an embedded alpha channel using the Apple
ProRes 4444 codec
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose Apple ProRes with Alpha.

5 Confirm the output filename in the Filename field.

1748

Chapter 104 Using Share

You can double-click the filename to edit it.
6 Optionally, you can select the Open with QuickTime Player checkbox to have Share
automatically open the output media file in QuickTime Player when the export session
is complete.
The action drawer opens.

QuickTime Player is the default application.
7 Optionally, use the “Open with” pop-up menu to either confirm QuickTime Player or
choose a different application to open the output media file.
8 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process.
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”

Using Share to Create QuickTime H.264 Output
Use this output to create a QuickTime movie using the H.264 codec set to very high
quality, original frame size, and a low data rate, and automatically open the file with
another application, such as QuickTime Player. This movie would be suitable for playback
on a desktop computer.
To create an output media file using the H.264 codec with very high quality, original
frame size, and a low data rate
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
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2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose QuickTime H.264.

5 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
6 Optionally, you can select the Open with QuickTime Player checkbox to have Share
automatically open the output media file in QuickTime Player when the export session
is complete.
The action drawer opens.

1750

Chapter 104 Using Share

QuickTime Player is the default application.
7 Optionally, use the “Open with” pop-up menu to either confirm QuickTime Player or
choose a different application to open the output media file.
8 Do one of the following:
• Click Export.
The Transcoding Progress window appears and the output media file is processed.
Click the Cancel button in this window if you want to stop the export process.
• Click Send to Compressor.
Compressor opens with a new batch containing the outputs from the Share window.
For more information, see “Sending Outputs to Compressor.”
Note: The QuickTime H.264 output type deinterlaces any interlaced source media.

Using Share to Create Other Output Types
Use this output to create an output media file based on any (preset) setting from the list
of settings provided by Compressor. You can customize any setting in Compressor and
save the setting for future Share export sessions.
To create an output media file based on any setting from the list of settings provided
by Compressor
1 In Final Cut Pro, select one or more Browser clips, sequences, or both.
See “Types of Group Selections” for more information on the possible types of selections.
2 Choose File > Share.
The Share window opens.
3 Use the Destination Folder pop-up menu or the Choose button to navigate to your chosen
destination folder for the output media files.
4 In the Output Type pop-up menu, choose Other.
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The Settings table opens, containing both Apple settings and any available custom
settings.

5 Do either of the following:
• Select a setting or settings group from the Settings table.
• Select any of the checkboxes in the In Menu column on the right side of the table to
add Compressor settings or settings groups to the Share window for future Share export
sessions.
6 Click OK.
The Share window opens. The Compressor setting you selected is applied to the output.
7 Confirm the output filename in the Filename field.
You can double-click the filename to edit it.
8 Click Export.
The Transcoding Progress window appears and the output media file is processed. Click
the Cancel button in this window if you want to stop the export process.
For more information about Compressor settings, see the Compressor User Manual, available
in Compressor Help.

Using Batch Monitor with Share
The Batch Monitor application lets you view or adjust the status of any Share export
session after it has been submitted for processing.
For more information about Batch Monitor, see the Batch Monitor User Manual, available
in Batch Monitor Help or Compressor Help.
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Exporting QuickTime Movies

105

This chapter covers the following:
• About the Export QuickTime Movie Command (p. 1753)
• Choosing the Type of QuickTime Movie to Export (p. 1754)
• Exporting a QuickTime Movie File (p. 1755)
• Exporting QuickTime Movies with Markers (p. 1758)
You can export your sequence to a QuickTime movie using any of the available sequence
presets. Markers can also be included for use in other applications such as DVD Studio Pro
and Soundtrack Pro.

About the Export QuickTime Movie Command
With Final Cut Pro, you can export sequences or clips as QuickTime movie files using the
Export QuickTime Movie command. This command is unique for several reasons:
• It allows you to choose video and audio settings from the installed sequence presets,
as opposed to the unlimited options available from the Export Using QuickTime
Conversion command.
• You can quickly export QuickTime reference movie files instead of self-contained media
files, significantly reducing the size of the exported file.
• If the sequence settings of the selected clip or sequence match your export settings,
you can choose not to recompress any of the media during export. This avoids
generational loss due to recompression, and makes the export process faster.
Note: The Export Using QuickTime Conversion command always recompresses your
media when it exports, even if your export settings match the settings of your selected
clip or sequence.
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Choosing the Type of QuickTime Movie to Export
You can create two kinds of QuickTime movies with the Export QuickTime Movie
command—a self-contained movie or a reference movie.
• Self-contained movie: A self-contained movie contains the video and audio media—all
of the data used to create your movie is within a single file. This single file can be safely
and easily copied to another computer without worrying that you need other files to
play it back.
• Reference movie: A reference movie is a very small file that contains pointers, or
references, to all of the captured clips used in your sequence. The actual media is
located in the original media files. If you rendered your transitions and effects before
creating the reference movie, then there are pointers to your render files as well.
Otherwise, all of your transitions and effects are rendered using the current level of
compression, and then embedded inside the resulting reference movie, increasing its
size. All audio tracks, mixing levels, cross fades, and audio filters are rendered and the
resulting stereo or mono audio tracks are embedded in the reference movie.

Reference movie

Original media files

Exporting a reference movie saves time, since you don’t have to wait for every frame of
your edited sequence to be duplicated. It also saves hard disk space, since pointers to
other files require little space. Reference movies are particularly useful when outputting
your sequence for compression using a third-party compression utility.
However, reference movies are not very useful as a means of delivering video files to
other people. If you give someone a reference movie, you must also give them the original
video files associated with that movie, which can be complicated since you may not know
where all the referenced media is stored on disk.
In general, exporting reference movies increases the risk that the movie may not play
back. Reference movies are best used when you have short-term uses for the exported
movie file, and you only plan to use them on the system you exported them to.

1754

Chapter 105 Exporting QuickTime Movies

Exporting a Self-Contained Movie Without Recompressing the Media
If you choose to export a self-contained movie, you have the option to not recompress
the media in your clip or sequence. If you deselect the Recompress All Frames option
and choose Current Settings from the Setting pop-up menu, Final Cut Pro simply copies
frames from existing media files into the new file with no recompression. This is a
convenient way to export your media without subjecting it to recompression artifacts.
However, any media that must be created from scratch, such as a transition between two
media files, must be recompressed.
Important: The option to turn off recompression is unique to the Export QuickTime Movie
command and the Batch Export command. If you choose the Export Using QuickTime
Conversion command, every frame is always recompressed.

Determining Processing Color Space During QuickTime Movie Export
The color space (RGB or Y′CBCR) used for processing during QuickTime movie export
depends on what you select before exporting:
• A sequence in the Browser, the current sequence in the Timeline, or a sequence clip: Color
space is determined by the settings in the Video Processing tab of the Sequence Settings
window.
• A clip in the Browser or Viewer: Clips in the Browser or Viewer do not have video
processing settings in the way that sequences do. When a clip’s media file and export
codec both support Y′CBCR color space, the clip is processed using Y′CBCR color space.
For example, if you export a DV clip in the Browser to a DVCPRO HD QuickTime movie,
Y′CBCR color space is used because both the original and exported formats support this
color space.
If any step of processing requires RGB processing (such as effects or the source or
destination codec), the export happens in RGB color space. This is true even if the
destination codec uses Y′CBCR color space.

Exporting a QuickTime Movie File
You can export a QuickTime movie from three kinds of selections:
• A selected sequence in the Browser or the current sequence in the Timeline
• Media between a sequence’s In and Out points
• A selected Browser clip
To export a QuickTime movie from a sequence
1 Select a sequence in the Browser, or open a sequence in the Timeline.
2 Choose Sequence > Settings.
The Sequence Settings window appears.
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3 Click the Render Control tab and select the appropriate rendering options for the output
quality you want.
For more information on these settings, see “Render Control Tab.”
4 Click OK to apply the changes you made to the sequence settings.
5 In the Timeline, do one of the following:
• Set In and Out points to define which portion of your sequence you want export.
• Clear In and Out points to export the entire sequence.
6 Choose File > Export > QuickTime Movie.
7 Choose a location and enter a name for the file.
If you want, enter a name
for the file.
Choose a location to save
the file.

Specify the settings for
the exported movie.

To create a reference
movie, make sure this
checkbox is unselected.

8 Choose the format you want to use from the Setting pop-up menu.
The settings shown here come from built-in presets.
• Current Settings: This option uses the current sequence or clip settings of the item you
selected for export.
• Other sequence presets: Choose a new sequence preset to recompress your clip or
sequence to another format and codec. For example, you may want to export a DV
sequence to an uncompressed codec for online editing.
• Custom: Choose this option to choose custom export settings using the Sequence
Preset Editor window.
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9 Choose Audio and Video, Audio Only, or Video Only from the Include pop-up menu.
Important: An audio track in a QuickTime movie file takes up disk space even if it is empty.
If your QuickTime movie doesn’t need an audio track, choose Video Only.
All audio that requires rendering is automatically rendered with a render quality of High,
regardless of the render quality setting. Even QuickTime movies that you output that
don’t have the Recompress All Frames checkbox selected will have the highest-quality
audio. For more information about how multichannel audio is exported, see “Exporting
Audio for Mixing in Other Applications.”
10 Choose which markers you want to export from the Markers pop-up menu.
For more information about the different kinds of markers you can export, see “Exporting
QuickTime Movies with Markers.”
Important: Markers within sequence clips are never exported—only markers in the
sequence itself are exported.
11 To export a QuickTime movie with all video, audio, and rendered media in a self-contained
file, select the Make Movie Self-Contained checkbox.
Leave this checkbox unselected to export a reference movie, which is a small movie that
contains pointers to audio and render files located elsewhere. For more information, see
“Choosing the Type of QuickTime Movie to Export.”
12 To recompress every frame of your clip or sequence, select the Recompress All Frames
checkbox.
Note: This option is available only if the Make Movie Self-Contained checkbox is selected.
13 When you’re ready to export, click Save.
A dialog shows you the
progress of the export.

To cancel your export, press Esc or click Cancel.
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To export a QuickTime movie from a clip in the Browser or Viewer
Follow the steps for exporting a sequence, but select a clip in the Browser or Viewer.
Note: When exporting a clip from the Browser or Viewer, there is no need to specify
settings in the Render Control tab of the Sequence Settings window (those settings apply
only to sequences and sequence clips). Also, markers are not included.
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Exporting QuickTime Movies with Markers
Final Cut Pro can export the following marker types for use in other Final Cut Studio
applications:
• Chapter markers: Chapter markers allow easy access to index points throughout a DVD,
QuickTime movie, or podcast. QuickTime Player can interpret any text track containing
time stamps as a chapter track. In some cases, the different kinds of markers you export
may be interpreted as chapters in QuickTime Player, even though they are not really
the same kind of chapter markers as those used by Compressor and DVD Studio Pro.
Compressor and DVD Studio Pro can both read chapter markers exported from
Final Cut Pro.
• Compression markers: Also known as manual compression markers—these are markers
you can add to a sequence or clip to indicate when Compressor or DVD Studio Pro
should generate an MPEG I-frame during compression. For more information, see the
documentation included with Compressor and DVD Studio Pro.
• Edit/Cut markers: Also known as automatic compression markers, these markers are
automatically generated by Final Cut Pro at each cut or transition point in a sequence.
During compression, Compressor uses these markers to generate MPEG I-frames at
these points, improving compression quality.
Note: DVD Studio Pro ignores these markers because they can interfere with GOP
alignment for multi-angle DVD video. For more information, see the documentation
included with Compressor and DVD Studio Pro.
• Scoring markers: These markers are displayed in Soundtrack Pro to indicate important
cue points for music or sound effects.
When you choose the Export QuickTime Movie command, you can choose one of the
following marker export options from the Markers pop-up menu:
• None: No markers will be exported, and your exported movie file will contain only
video, audio, and timecode tracks.
• DVD Studio Pro Markers: Chapter markers, edit/cut markers, and manually added
compression markers are exported. However, edit/cut compression markers are ignored
by DVD Studio Pro. For more information about using markers with DVD Studio Pro,
see “Adding Chapter and Compression Markers to Your Sequence.”
• Compression Markers: This option includes both edit/cut markers and compression
markers that you add manually.
• Chapter Markers: Chapter markers are exported for use in Compressor and
DVD Studio Pro.
• Audio Scoring Markers: Scoring markers are exported for use in Soundtrack Pro.
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• All Markers: The All Markers option exports each type of marker in your clip or sequence
to a separate QuickTime text track. Final Cut Studio applications can then use the
markers they need.
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Exporting Using QuickTime
Conversion

106

This chapter covers the following:
• About the Export Using QuickTime Conversion Command (p. 1761)
• Types of File Formats You Can Export with QuickTime (p. 1762)
• About Color Space Conversion (p. 1763)
• Exporting a QuickTime Movie File for Web Distribution (p. 1763)
• Configuring QuickTime Movie Settings (p. 1765)
• About QuickTime Aperture Display Modes (p. 1775)
• Exporting a DV Stream (p. 1778)
• Exporting an AVI File (p. 1779)
When you need to export video, audio, or still-image files for use in other applications,
you can use the Export Using QuickTime Conversion command to export file formats
supported by QuickTime.

About the Export Using QuickTime Conversion Command
A QuickTime-compatible file may be any kind of media file that QuickTime supports, such
as an AIFF or WAVE audio file, a graphics file or sequence of still images such as TIFF or
JPEG, an AVI or MPEG-4 movie file, or even a QuickTime movie file.
Important: Like the Export QuickTime Movie command, the Export Using QuickTime
Conversion command allows you to export QuickTime movie files, but in slightly different
ways. If you use this command to export a QuickTime movie, be aware that this command
always recompresses all video frames, even if your export settings use the same codec
as your selected sequence. For information about the Recompress All Frames option, see
“Exporting QuickTime Movies.”

What Is QuickTime and Why Do You Need to Know About It?
QuickTime is Apple’s multiplatform, multimedia technology for handling video, sound,
animation, graphics, text, interactivity, and music. For more information, see “Learning
About QuickTime.”
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Types of File Formats You Can Export with QuickTime
With the Export Using QuickTime Conversion command, you can choose to export almost
any file format that QuickTime supports, along with a wide variety of codecs and custom
parameters that each format supports. Because there are so many file formats and specific
settings, this chapter does not provide an exhaustive description of every file format and
its associated settings.
Video and Movie File Formats
• QuickTime movie file: See “Exporting a QuickTime Movie File for Web Distribution.” If
you want to export a movie that has the same settings as your sequence or clip, see
“Exporting QuickTime Movies.”
• DV Stream file: DV Stream files encode synchronized audio and video together digitally
as on a DV videotape. These files are primarily for use with iMovie. See “Exporting a DV
Stream.”
• AVI file: AVI movies are a Windows-compatible standard for digital video. See “Exporting
an AVI File.” AVI stands for Audio Video Interleave.
• FLC: An animation format, originally developed by AutoDesk. This format uses a lossless
compression technique that maintains the original quality.
Multimedia Distribution File Formats
• MPEG-4: A global multimedia standard, delivering professional-quality audio and video
streams over a wide range of bandwidths, from cell phone to broadband and beyond.
• 3G: Lets you export a file that is compatible with 3GPP (3rd Generation Partnership
Project) and 3GPP2 (3rd Generation Partnership Project 2) devices. Also supports AMC,
a popular mobile multimedia format used by KDDI subscribers in Japan that includes
MPEG-4 video, QCELP audio, and STML text. These are the standards for high-quality
multimedia on wireless devices, based on the foundation of MPEG-4.
Still-Image File Formats and Image Sequences
• Still-Image: This choice allows you to select one of many still-image file formats. See
“Exporting Still Images and Image Sequences.”
• Image Sequence: This choice allows you to select a still-image file format and export
each frame of your video as a separate file in the format you choose. See “Exporting
Image Sequences.”
Audio File Formats
For information on exporting any of these formats, see “Exporting Audio for Mixing in
Other Applications.”
• AIFF: This is the default audio format used on Mac computers. Each data byte is stored
with the most significant byte (MSB) stored first. This is known as big endian.
• WAVE: This is the standard audio format used on Windows computers. Each data byte
is stored with the least significant byte (LSB) first. This is known as little endian.
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• uLaw: This is an audio format developed for Sun computers.
• System 7 Sound: This is a sound format used on older Mac computers.

About Color Space Conversion
When you use the Export Using QuickTime Conversion command, super-white values in
Y′CBCR footage are clipped. To avoid clipping, you can use the Export QuickTime Movie
command instead. For more information, see “Determining Processing Color Space During
QuickTime Movie Export.”

Exporting a QuickTime Movie File for Web Distribution
If you need to create a self-contained movie file with the same settings as the original
media file, you should probably use the Export QuickTime Movie command (see “Exporting
QuickTime Movies”). However, if you want to export a compressed QuickTime movie file
for the web or some other means of distribution, you should use the Export Using
QuickTime Conversion command.
To export a QuickTime movie file
1 Choose Sequence > Settings, then click the Render Control tab.
2 Select the appropriate rendering options for the output quality you want.
For more information on these settings, see “Render Control Tab.”
3 Select a clip or sequence in the Browser or open a sequence in the Timeline.
4 Choose File > Export > Using QuickTime Conversion.
5 Choose a location and enter a name for the file.
6 Choose QuickTime Movie from the Format pop-up menu.
7 If you want, choose a preset compression setting from the Use pop-up menu.
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The preset compression settings use the H.264 codec and target a range of download
and streaming speeds.

Choose a preset
compression setting...
...or choose custom
video and audio settings
by clicking here.

8 To customize video, audio, and Internet streaming settings, click Options.
Click here to include
video in your exported
QuickTime file.

Click here to include
audio in your exported
QuickTime file.

Click here if your
program is to be
streamed on the Internet.

Note: Unless you are creating movies for online distribution, turn off Internet streaming
options for the best results.
For detailed information on settings, see “Configuring QuickTime Movie Settings.”
9 When you’ve finished selecting your options, click OK.
10 When you’re ready to export, click Save.
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A dialog shows you the progress of the export. To cancel your export, press Esc or click
Cancel.
Note: Whenever you use the Export Using QuickTime Conversion command, all audio
that requires rendering is automatically rendered with a render quality of High, regardless
of the render quality setting.

Configuring QuickTime Movie Settings
The settings available with the Export Using QuickTime Conversion command are identical
to the settings you use when exporting movies from QuickTime Player (when registered
as QuickTime Pro).
To view the settings available with the Export Using QuickTime Conversion command
1 Select a clip or sequence, or open a sequence in the Timeline.
2 Choose File > Export > Using QuickTime Conversion.
3 In the dialog that appears, click Options.
The Movie Settings dialog appears with video, sound, and Internet streaming options for
the exported QuickTime movies.

QuickTime Movie Video Settings
You can choose the following settings for the video track of your exported QuickTime
movie.
• Settings: Click this to adjust the compression used to export your video track.
• Filter: Click this to add and adjust additional video filters.
• Size: Click here to set a size for the movie.

Chapter 106 Exporting Using QuickTime Conversion

1765

Standard Video Compression Settings
The Standard Video Compression Settings dialog appears when you click Settings in the
Video area of the Movie Settings dialog. Depending on the codec you choose from the
Compression Type pop-up menu, various options may be available, as explained below.

Standard Video Compression Setting Dialog
• Compression Type: Select a codec from this pop-up menu to compress the video. All
the standard QuickTime, Final Cut Pro, and third-party video codecs installed on your
system are available.
Motion Area Options
The Motion area contains the following options:
• Frame Rate: Define the frame rate of your exported movie. You should always match
the frame rate of the clip or sequence you are exporting. If you want to convert your
exported clip or sequence to a different frame rate while minimizing temporal artifacts,
try using Compressor instead of the Export Using QuickTime Conversion command.
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• Key Frames: Key frames are available if your selected codec uses temporal compression.
Most video frames in close proximity have a high percentage of visual redundancy.
Compression key frames reduce data rate by only storing complete images at regular
intervals or when abrupt visual shifts occur. The remaining frames only store information
about the change, or delta, between themselves and the key frame. Increasing the
number of frames between key frames increases the amount of compression and makes
the final file size smaller.

Key frame

Delta frames

Key frame

Depending on the codec you use, the movie file’s quality, especially for clips and
sequences with a lot of motion, may decrease if there are too few key frames specified.
If there’s a lot of motion in your media file, you need key frames more often than you
do with more static footage, such as an interview sequence. A setting of one key frame
every ten frames is a good starting point.
Some video codecs allow you to insert a key frame every certain number of frames,
while other video codecs use natural key frames by scanning the whole file to detect
where the major similarities and differences occur and inserting the key frames
accordingly.
• Automatic: QuickTime adds temporal compression key frames when necessary.
• Every N frames: Temporal compression key frames are created every N frames. Because
key frames require more data to store than the in-between frames, a higher value
here results in a movie with a lower data rate.
• All: A key frame is added on every frame. This increases the data rate of the movie
significantly.
Data Rate Area options
The Data Rate Area contains the following options:
• Automatic: The selected codec adjusts the data rate of your QuickTime video
automatically.
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• Restrict to N kbits/sec: When available, you can use this field to set the number of
kilobytes per second (KB/sec.) required to deliver your media file. This setting is useful
if you have a specific bit rate (such as a DSL connection) or amount of space (on a DVD
or CD ROM). You should choose a data rate that is appropriate for your delivery medium
and set it as high as possible within your data limitations. When you set a data rate,
you override other codec quality settings because the codec compresses the file as
much as it needs to based on its data rate limit. Remember that the data rate is only
for the video track of a media file. If your media file also contains audio, you must allow
some space for that, too.
Compressor Area options
You can change the following options in the Compressor area:
• Depth: Choose a color depth. Some codecs allow you to choose between color or
grayscale, while others allow you to specify the number of colors (which corresponds
to a bit depth), such as 4, 16, 256, or millions of colors (2-, 4-, and 24-bit, respectively).
You can also specify an alpha channel for some codecs by choosing Millions of Colors+.
• Quality: Adjust the slider for the level of spatial compression you want. Some codecs
may not allow you to specify this setting.
Depending on the codec you choose, other options may be available, such as scan
mode (interlaced versus progressive) and aspect ratio. There may also be an Options
button you can click to set additional codec-specific options.
Preview Area
• Preview area: A preview image of the current frame of your clip or sequence is displayed
here. When you adjust some compressor options, the preview image is updated so you
can see how certain settings will affect your image.
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Filter Settings
These options are available when you click Filter in the Video area of the Movie Settings
dialog. QuickTime filters apply to your entire exported clip or sequence. This is different
from applying a filter within Final Cut Pro, where a filter is applied only to selected clips
or parts of a clip.
Click a disclosure triangle
to see more filters.

Adjust settings for the
filter in this area.

Select a filter in this list.

• Load: Click here to use a filter you’ve saved, such as one used in an earlier project.
• Save: Click here to save a filter’s settings, if you might use them again.
Export Size Settings
The Export Size Settings dialog appears when you click Size in the Video area of the Movie
Settings dialog. When QuickTime 7.1 or later is installed, a large number of size, scaling,
and aspect ratio options are available when you export your movie.

• Dimensions: This pop-up menu allows you to define the clean aperture size of your
exported QuickTime movie. For more information about QuickTime aperture modes,
see “About QuickTime Aperture Display Modes.”

Chapter 106 Exporting Using QuickTime Conversion

1769

Depending on the option you choose, width and height fields may also appear. The
following options are available in the Dimensions pop-up menu:
• Current: The current dimensions of your clip or sequence in the Viewer or Canvas,
respectively. You should avoid this option in most cases because it’s difficult to set
precise dimensions by scaling the Viewer or Canvas window. This option disables
the “Preserve aspect ratio using” pop-up menu.
• Compressor native: The native dimensions of the codec selected in the Compression
Type pop-up menu of the Standard Video Compression Settings dialog. Not all codecs
have native dimensions. In this case, the dimensions set in the Current option are
used. DV, DVCPRO, and DVCPRO 50 have native NTSC and PAL dimensions of 720 x 480
and 720 x 576, respectively. IMX, DVCPRO HD, HDV, and XDCAM HD codecs also have
native dimensions.
• 640 x 480 VGA, 320 x 240 QVGA, 160 x 120: These are multiples of the VGA image
dimensions with an aspect ratio of 4:3.
• 352 x 288 CIF and 176 x 144 QCIF: These are multiples of the CIF image dimensions
with an aspect ratio of 4:3 (assuming a nonsquare pixel aspect ratio). CIF and QCIF
were originally designed for use in video conferencing and for compatibility with
NTSC and PAL video.
• 768 x 576 SD: PAL digital video dimensions (assuming square pixels) with an aspect
ratio of 4:3.
• 1280 x 720 HD and 1920 x 1080 HD: High definition video dimensions (assuming
square pixels).
• NTSC 720 x 480 4:3 and 16:9: Normal and anamorphic NTSC digital video for DV,
DVCPRO, DVCPRO 50, and DVD MPEG-2.
• NTSC 720 x 486 4:3 and 16:9: Normal and anamorphic NTSC digital video complying
with the ITU-R BT. 601 specification.
• PAL 720 x 576 4:3 and 16: Normal and anamorphic PAL digital video complying with
the ITU-R BT. 601 specification.
• HD 1280 x 720 16:9: 720-line high definition video dimensions.
• HD 1440 x 1080 16:9: Subsampled 1080-line high definition video dimensions.
• HD 1920 x 1080 16:9: Full-resolution 1080-line high definition video dimensions.
• Custom: Allows you to enter any height and width you choose. This is useful when
you need specific image dimensions or special aspect ratios such as 1.85 or 2.40.
• Preserve Aspect Ratio: When the “Preserve aspect ratio using” checkbox is selected, the
aspect ratio of your source movie is preserved by choosing one of three options. In the
following examples, a 1280 x 720 (16:9) high definition sequence is shown scaled down
to 320 x 240 (4:3).
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Important: These options do not take into account the effect of pixel aspect ratio when
determining what aspect ratio to preserve. For example, if you are exporting a DVCPRO
HD sequence (960 x 720), these options preserve the aspect ratio of the pixel dimensions,
which is 4:3 (960720), not 16:9 as you would expect. For best results, always nest
sequences with nonsquare pixels into a sequence format with square pixels. In this
case, you could nest your DVCPRO HD sequence into a sequence with dimensions of
1280 x 720.

1280 x 720 (16:9)
sequence

• Letterbox: Scales your clip or sequence video to fit proportionally in the clean aperture
dimensions of your exported movie. Black bars are added on the top and bottom
(letterboxed) or left and right (pillarboxed) as necessary.

16:9 letterboxed within
320 x 240 (4:3)

• Crop: Scales and center-crops your clip or sequence video to fit in the clean aperture
dimensions of your exported movie.

16:9 cropped
to 320 x 240 (4:3)
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• Fit within dimensions: Changes the shortest dimension of the exported movie (usually
the height) so that the source sequence or clip fits within the exported movie
dimensions when scaled. For example, if your sequence dimensions are 1280 x 720
(16:9) and the exported movie dimensions are 320 x 240 (4:3), the exported movie
dimensions are changed to 320 x 180 (16:9) and the exported sequence is scaled to
these dimensions. When the “Preserve aspect ratio using” checkbox is not selected,
the sequence or clip video is stretched to fit the export movie size.

16:9 within
320 x 180 (16:9)

• Deinterlace Source Video: Select this checkbox to avoid artifacts when scaling interlaced
video formats such as standard definition NTSC (480i), PAL (576i), or 1080i video.

QuickTime Movie Sound Settings
Click Settings in the Sound area of the Movie Settings dialog to choose an audio format,
number of channels, sample rate, and additional settings. Depending on the format you
choose from the Format pop-up menu, additional settings may be available.
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Important: If there is no audio in your clip or sequence, deselect the Sound checkbox in
the Movie Settings dialog. Otherwise, blank audio tracks are created in your QuickTime
movie file, which require additional space.

• Format: To reduce file size and download bandwidth, choose a codec to compress the
audio tracks. If you’re outputting full-resolution audio, choose Linear PCM.
• Channels: Select Mono, Stereo (L R), or 2 Discrete Channels. If you’re delivering material
for the Internet, you may want to choose Mono because it cuts your audio file size in
half. Some formats support additional channel configurations.
• Rate: Choose a standard sample rate from the pop-up menu or enter a value to specify
the output rate for the audio. Lower sample rates take less bandwidth but have lower
quality.
• 8–22.225 kHz: These lower sample rates are used mainly for multimedia and web
movies to reduce file size.
• 32 kHz: A lower-quality sample rate often used on consumer DV camcorders. This
option isn’t particularly useful for exporting unless you specifically need to make a
file that is compatible with a 32 kHz device.
• 44.1 kHz: This is the sample rate of music CDs.
• 48 kHz: Most digital video formats use this sample rate.
• 96 kHz: This sample rate is common in professional audio and music production.
• 192 kHz: This sample rate is typically used by high-end audio mastering facilities.
• Show Advanced Settings: Select this checkbox to set additional options, if the selected
audio format supports this.
• Render Settings—Quality: If your sequence or clip sample rate doesn’t match your export
sample rate, this pop-up menu appears. You can choose from several quality options.
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• Linear PCM Settings: These options are only available when you choose Linear PCM
from the Format pop-up menu.
• Sample size: Choose a bit depth for your audio samples. For most situations, 16-bit
audio is the minimum bit depth you should choose, but sometimes 8-bit audio is
useful when creating small, low-quality movies for the web. If you choose 32-bit, you
have the option of using integer or floating-point values. You can also choose 64-bit,
but only if the Floating Point checkbox is selected.
• Little Endian: This refers to the way audio data bytes are ordered. Little endian byte
ordering is used when creating Windows-compatible WAVE files. Big endian order
is used when creating AIFF files.
• Floating Point: This option affects how the bits of each sample are used to represent
audio amplitudes. Floating point is available with 32-bit audio, and required when
using 64-bit audio.
• Unsigned: This option is automatically turned on when exporting 8-bit WAVE files.

Internet Streaming Settings
If you’re outputting QuickTime files for streaming over the Internet, there are three format
options in the Movie Settings dialog.
Important: If you are not exporting a QuickTime movie for web distribution, make sure
you deselect the Prepare for Internet Streaming checkbox in the Movie Settings dialog.

• Fast Start: The QuickTime movie is downloaded the same way as any other graphics
or media file. Once enough of the movie has downloaded, the movie begins to play
automatically.
• Fast Start—Compressed Header: This works the same way as Fast Start, except that the
header information is compressed, so the movie takes up less disk space. The person
downloading the file must have QuickTime 3.0 or later.
• Hinted Streaming: If the movie will be hosted with QuickTime Streaming Server software,
it begins playing within a few seconds after access. “Hinting” a QuickTime movie is the
process of defining how it’s divided into streamable pieces and storing that information
as a special track within your QuickTime file.
If you’re not sure you want this option or don’t want to do this now, you can do this
later by importing your QuickTime file into QuickTime Player Pro and applying hinting
there.
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If you choose Hinted Streaming, click Settings to specify additional export settings.
• Make Movie Self-Contained: Select this checkbox to export a QuickTime movie with
all video, audio, and render material contained in one file. Leave this checkbox
unselected to export a reference movie, which is a small movie that contains pointers
to audio and render files located elsewhere. For more information, see “Choosing
the Type of QuickTime Movie to Export.”
• Optimize Hints For Server: Select this checkbox to analyze your movie and create
hinting information that can be used to stream your movie on the Internet using
QuickTime Streaming Server.
• Track Hinter Settings: Click this to specify options for encoding and packets.
• RTP Payload Encodings: Choose the type of encoding to use.
• Packet Size Limit: Enter a value or choose an option from the pop-up menu to specify
the largest file size for a packet.
• Packet Duration Limit: Enter a value or choose an option from the pop-up menu to
specify the longest duration for a packet.
• Options: Click here to specify the sample description. In the QuickTime Settings
dialog, enter a value in the Interval field to specify the time interval for the sample.
Then specify the number of packets to send and how often to send them.

About QuickTime Aperture Display Modes
QuickTime 7.1 and later supports four aperture display modes that allow you to properly
display video with nonsquare pixels (such as DV video) in QuickTime Player and other
applications that support these modes. The four aperture display modes in QuickTime
are:
• Classic
• Clean
• Production
• Encoded Pixels
Note: Although Final Cut Pro always displays video in the Production aperture display
mode, the default setting for exported QuickTime movies is the Clean aperture display
mode.
To change the aperture display mode of a QuickTime movie
1 Make sure a QuickTime Pro registration code is entered in the Register tab of the QuickTime
pane in System Preferences.
2 Open a QuickTime movie in QuickTime Player.
3 Choose Window > Show Movie Properties.
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4 In the Properties window, select the main movie track (not the video or sound tracks).
5 Click Presentation, then choose an aperture mode from the “Conform aperture to” popup
menu.

Classic Aperture Mode
In this mode, content appears as it did in QuickTime 7 and earlier. The video track
dimensions are respected. For example, a DV NTSC track appears as 720 x 480.

Classic: no pixel aspect
ratio correction or
aperture cropping

Clean Aperture Mode
An image’s clean aperture is a region of video free from transition artifacts caused by the
encoding of the signal. This is the region of video that should be displayed.

Edge encoding artifacts
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Cropped edge
(in clean aperture mode)
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In this mode, the video track is cropped to the Clean aperture mode and scaled according
to the track’s pixel aspect ratio. For example, a 4:3 DV NTSC track appears as 640 x 480;
a 16:9 DV NTSC track appears as 853 x 480.

Clean: pixel aspect ratio
correction applied and
edges cropped

Production Aperture Mode
Content may appear differently than in QuickTime 7. The video track is not cropped to
the Clean aperture mode, but it is scaled according to the pixel aspect ratio. Use this
option when you want to see all the pixels in your video, including the edges. A 4:3 DV
NTSC track appears as 654 x 480; a 16:9 DV NTSC track appears as 873 x 480. Compare
this to the Clean aperture mode, which crops the edge-encoding pixels on the left and
right.

Production: pixel aspect
ratio correction applied
with no edge cropping

Chapter 106 Exporting Using QuickTime Conversion

1777

Encoded Pixels Aperture Mode
Content typically appears the same as in Classic aperture mode. The video track is not
cropped to the Clean aperture mode and is not scaled according to the pixel aspect ratio.
The encoded dimensions of the image description are displayed. This option is typically
used to preview rendering (where you want all pixels) in a professional application. A DV
NTSC (4:3 or 16:9) track appears as 720 x 480.

Encoded Pixels: pixels
displayed “as is,” with
no pixel aspect
ratio correction or
cropping applied

Exporting a DV Stream
A DV Stream file is just like the DV video and audio data recorded on DV tape. This file
format is used with applications such as iMovie. DV Stream files are not the same as
QuickTime movie files with separate, extensible tracks. Use the DV Stream option to make
iMovie-compatible DV Stream files.
To export a DV Stream file
1 Select a clip or sequence in the Browser, or open a sequence in the Timeline.
2 Choose File > Export > Using QuickTime Conversion.
3 Choose a location and enter a name for the file.
4 Choose DV Stream from the Format pop-up menu.
5 Choose a setting from the Use pop-up menu, based on the video standard and audio
sample rate of the selected clip or sequence.
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6 To customize settings, click Options.

• DV Format: Choose a DV format, such as DVCPRO 50, here.
• Video Format: Choose the video standard, scan mode, and aspect ratio for the exported
file.
• Audio Format: Choose your options.
• Locked: Conforms the audio tracks to the “locked audio” standard, in which the audio
and video sample clocks are synchronized.
• Rate: Choose a sample rate for the exported file from this pop-up menu. DVCPRO
and DVCPRO 50 always use locked audio with a sample rate of 48 kHz. With these
formats, these options are not adjustable.
7 When you’re ready to export, click Save.
A dialog shows you the progress of the export. To cancel your export, press Esc or click
Cancel.

Exporting an AVI File
AVI is a Windows-compatible movie file format for digital video. This file type is no longer
officially supported by Microsoft, but it’s still frequently used. The AVI format is similar to
a QuickTime movie file, but it supports fewer track types and codecs. It is useful mainly
for delivery of movie files to Windows computers or the Internet.
To export an AVI file
1 Select a clip or sequence in the Browser, or open a sequence in the Timeline.
2 Choose File > Export > Using QuickTime Conversion.
3 Choose a location and enter a name for the file.
4 Choose AVI from the Format pop-up menu.
5 Choose a setting from the Use menu.
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Each setting in this list is a predefined group of codecs and settings. If your needs are
more specific, skip ahead to step 6.

6 To customize settings, click Options.
7 Select the Video and Sound checkboxes to include both video and audio in your exported
file.
To include video in the
exported file, make sure
this is selected.

Click here to adjust the
compression settings
used for the video track.

Click here to adjust the
compression settings
used for the audio track.

To include audio in the
exported file, make sure
this is selected.

If there is no audio in your clip or sequence, make sure the Sound checkbox is not selected.
Otherwise, the blank audio tracks will take up space in your output file.
8 Click Settings in the Video area to adjust the compression settings used for the video
tracks.
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The video compression settings here are similar to the QuickTime movie file compression
settings, although fewer codecs are supported. For more details, see “Exporting QuickTime
Movies.”
9 Click Settings in the Audio area to adjust the compression settings used for the audio
tracks.
The audio compression settings here are similar to the QuickTime movie sound settings,
although different codecs and settings are supported.
10 When you’re ready to export, click Save.
A dialog shows you the progress of the export. To cancel your export, press Esc or click
Cancel.
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Exporting Sequences for DVD

107

This chapter covers the following:
• The DVD Creation Process (p. 1783)
• Adding Chapter and Compression Markers to Your Sequence (p. 1788)
• About DVD Authoring Applications (p. 1791)
• Exporting a QuickTime Movie for DVD Use (p. 1791)
• Using Compressor to Create DVD-Compliant Sources for DVD Studio Pro (p. 1792)
Making a DVD of your movie is a great way to show and distribute it. Video DVDs contain
high-quality media and can be played in most set-top DVD players, as well as most
computers with DVD playback capability.

The DVD Creation Process
iDVD and DVD Studio Pro provide the tools you need to easily create a simple, single-menu
DVD or an elaborate title including multiple menus, multiple movies, scene selections,
and slideshows.
You can also use the Share feature to quickly create and burn DVDs and Blu-ray discs,
and to create and deliver output media files in a variety of other formats. For more
information about the Share feature, see “Using Share.”
Note: You can also archive your projects and media files on a DVD-ROM disc. For that
purpose, you do not need a DVD authoring application. For more information, see “Backing
Up and Restoring Projects.”
There are four phases to creating a DVD.
Stage 1: Creating and Editing Your Source Material
In addition to the main movie created in Final Cut Pro, you can create still graphics or
short movies for use as menu backgrounds. All edits, special effects, audio fades and
mixes, and scene transitions must be created in Final Cut Pro before exporting them for
use in the DVD authoring application.
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Stage 2: Encoding Your Video and Audio to DVD-Video Compliant Formats
Video DVDs require that all video and audio conform to DVD MPEG-2 specifications. Both
iDVD and DVD Studio Pro automatically convert any media files that are not compliant.
This means that you can export a standard QuickTime movie from Final Cut Pro and
import it into your DVD authoring application, and all encoding and conversions are
handled for you automatically.
DVD Studio Pro accepts video and audio encoded by other applications, such as
Compressor. Using an application like Compressor allows you to precisely control
compression quality while maximizing use of disc space on your DVD.
Stage 3: Authoring Your DVD Title
This is the phase when you create DVD menus, tracks, and slideshows using your
DVD-compliant media assets. Both iDVD and DVD Studio Pro include templates and tools
to create professional-looking DVDs with minimal effort.
Stage 4: Building and Burning Your DVD
Once you have authored your DVD, you build (or compile) the files and then burn them
to a DVD disc. Both iDVD and DVD Studio Pro make this a one-button process.
For detailed information on preparing video and audio sources and planning your DVD,
see the documentation that came with DVD Studio Pro or iDVD.

Video for Standard DVDs
All standard DVD video must be MPEG-1 or MPEG-2 encoded, using DVD-compliant frame
dimensions, frame rates, and bit rates. Larger frame dimensions and higher bit rates result
in better video, but at the cost of larger files.
When preparing video and audio for use on DVD, always use the highest quality settings
available. Any flaws in your media can be exacerbated by MPEG compression on DVD. If
you use high-quality source materials, you’ll get high-quality results.
Here are some guidelines to help you maintain high quality:
• Capture and edit your video at the frame dimensions that you will use on the DVD
(typically 720 x 480 at 29.97 fps for NTSC or 720 x 576 at 25 fps for PAL). DVDs also
support anamorphic 16:9 video. For more information, see “Working with Anamorphic
16:9 Media.”
• When saving video material to a QuickTime movie file, you should use the native codec
of your source material. If you are creating footage from scratch, specify no compression
(which requires a lot of disk space) or use a high-quality compression codec such as
Apple ProRes 422. This provides the MPEG encoder (including those internally used by
iDVD and DVD Studio Pro and external encoders such as Compressor) the best-quality
video to start with. Recompressing already highly compressed video results in a
noticeable increase in visible compression artifacts.
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• Add compression and chapter markers in Final Cut Pro to help control the encoding
quality and make creating chapter selection menus easier. MPEG encoders, such as
Compressor, can use these markers to customize the MPEG encoding process, directing
the encoder to concentrate on those areas of the video that are the hardest to encode.
See “About MPEG-2 Video Compression” and “Adding Chapter and Compression Markers
to Your Sequence” for more information.

Video for High Definition DVDs
DVD Studio Pro includes the ability to author DVDs using high definition (HD) video
content. These DVDs support MPEG-2, HDV (an MPEG-2-based codec), and H.264 (when
encoded using Compressor). Both standard and HD image dimensions and frame rates
are supported.
Dimensions

Frame rate

Scanning method

Description

720 x 480
720 x 480
Anamorphic 16:9

29.97 fps

Interlaced

NTSC

720 x 576
720 x 576
Anamorphic 16:9

25 fps

Interlaced

PAL

1280 x 720

23.98 fps, 29.97 fps,
59.94 fps, and 50 fps

Progressive

NTSC-compatible
PAL-compatible

1440 x 1080

29.97 fps, 25 fps

Interlaced

NTSC-compatible
PAL-compatible

1920 x 1080

29.97 fps, 25 fps

Interlaced

NTSC-compatible
PAL-compatible

Note: MPEG-1 video is not supported on HD DVDs.
See the DVD Studio Pro documentation for details about HD DVD burning and playback
requirements.

HD DVD Editing Formats
There are three common HD formats used when editing HD projects in Final Cut Pro:
DVCPRO HD, uncompressed HD, and HDV. The format you use affects how you deliver
your completed footage to DVD Studio Pro.

Chapter 107 Exporting Sequences for DVD

1785

Starting with DVCPRO HD or Uncompressed Sources
Because the DVCPRO HD format and uncompressed HD video result in large file sizes,
files in these formats must be further compressed before you store them on a DVD.
DVD Studio Pro supports two formats for use in HD projects: HD MPEG-2 and H.264.
• The HD MPEG-2 format has the same basic structure as the MPEG-2 format used with
standard definition-based (SD-based) DVDs; the difference is that it uses a higher bit
rate range and supports the HD video format image dimensions.
• The H.264 format, also known as AVC or MPEG-4 part 10, uses an encoding process that
is twice as efficient as the MPEG-2 encoding process. When compared to MPEG-2
encoding, this means that with the H.264 encoder:
• You can use a lower bit rate to get the same quality, resulting in smaller files
• You can use the same bit rate and get better quality with the same file size
You can either export your DVCPRO HD-based project from Final Cut Pro using Compressor
(as described in “Using Compressor with Final Cut Pro”) or export a QuickTime movie of
the project and import it directly into DVD Studio Pro.
As with SD Final Cut Pro projects, the advantage of going through Compressor is that
you have more control over the encoding process. You can choose whether to create HD
MPEG-2 or H.264 files, and you can even use distributed encoding to reduce the amount
of time the encoding process takes. For more information, see the
Distributed Processing Setup Guide, available in Compressor Help or Apple Qmaster Help.
If you choose to import your DVCPRO HD-based QuickTime movie directly into
DVD Studio Pro, the integrated MPEG encoder automatically encodes the video using
the HD MPEG-2 format.
Starting with HDV Sources
The HDV format is based on a configuration of the MPEG-2 format that is supported by
DVD Studio Pro. This means that if you acquire and edit your video in the HDV format,
the video does not require transcoding before being used in an HD project. This not only
saves time, it also reduces the chances of artifacts being introduced into the video during
transcoding.
Important: Not all HDV formats are supported by the HD DVD specification. Some formats,
although not supported, are able to have frame doubling flags set so that they can play
correctly without having to be reencoded, whereas others must be reencoded. Specifically,
if you import HDV files using the 720p24 or 720p30 format into an NTSC HD project, they
will be set to play at 59.94 fps using frame doubling. If you import a 720p25 format into
a PAL HD project, it will play at 50 fps using frame doubling. If you import 1080p24 or
1080p25 formats, they will be transcoded by DVD Studio Pro into supported formats.
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The ability of Final Cut Pro to natively edit HDV sources makes this workflow an attractive
way to create DVD projects using HD assets.

About MPEG-2 Video Compression
MPEG-2 is an internationally accepted compression standard developed by the Motion
Picture Experts Group (MPEG). MPEG-2 allows you to create broadcast-quality video files
and was designed to support high-resolution, high-bit-rate video. It is the video
compression format used for home satellite dish systems and high-quality video titles on
DVD. All DVD players contain the hardware required for MPEG-2 playback. For more
information see “About MPEG Compression.”

Audio for DVD
In DVD Studio Pro, each DVD track can have up to eight audio streams. Each audio stream
is independent of the others—only one can play at a time. Each stream can have from
one to seven channels (as with 6.1–channel surround sound). Having multiple audio
streams allows you to include alternative language versions of the program, as well as
special features such as a spoken commentary.
Important: Do not confuse the way audio tracks in a Final Cut Pro sequence work with
the way audio streams in a DVD Studio Pro track work. A DVD player cannot mix multiple
streams together. If you want to have music playing underneath the dialogue, you must
mix the two in the audio exported from Final Cut Pro so that one audio stream contains
both the music and the dialogue.
Video DVDs support several audio formats:
• AIFF (uncompressed): Provides the highest-quality mono or stereo audio but requires
the most disc space. May cause problems with DVD tracks that contain multiple audio
streams. QuickTime, Compressor, iDVD, and DVD Studio Pro all are able to create suitable
uncompressed AIFF audio streams.
• Dolby Digital AC-3: Provides high-quality compressed audio. Supports from one to six
channels (5.1-channel surround sound), including standard stereo. Compressor includes
an AC-3 encoder.
• DTS: Provides high-quality compressed audio. Generally used only for surround sound
audio streams. Requires a third-party encoder and decoder.
• MPEG-1 Layer 2: Provides good-quality compressed audio. Generally used only for mono
or stereo audio streams. Compressor includes an MPEG-1 Layer 2 encoder.
When recording and editing audio, use a 48 kilohertz (kHz) sample rate and no
compression. This ensures the best quality whether you use the uncompressed audio on
the DVD or decide to use a supported compressed audio format.
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Important: When you create DVDs, your audio must have either a 48 kHz or 96 kHz sample
rate. If you use the 44.1 kHz sample rate found on standard audio CDs, DVD Studio Pro
and iDVD will convert your audio to the correct sample rate. Additionally, DVDs do not
support MP3-encoded audio. DVD Studio Pro and iDVD will convert any MP3 audio to
DVD-compliant uncompressed audio.

About Surround Sound Audio
Surround sound audio usually consists of six independent audio channels: front left, front
right, front center, rear left, rear right, and low-frequency effects (LFE, also known as the
subwoofer).
Mixing audio for use as surround sound is best left to specialized audio facilities that have
the required equipment and experience. Nothing can ruin a movie quite like badly done
surround sound audio. If you are using an audio post-production facility for your final
audio mix, you can use the Export Audio to OMF command to export all of the audio
from your edited sequence. For more information, see “Exporting Audio for Mixing in
Other Applications.”
If you decide to mix your own surround sound audio, you can export suitable audio files
from Final Cut Pro that an AC-3 encoder can use to create a surround sound audio stream.
One method is to export four audio files: one for the front right and left, one for the center
(usually dialogue), one for the rear right and left, and one for the LFE (usually a mix of all
of the audio channels, with the AC-3 encoder filtering out the high frequencies to include
only the low frequencies).

Adding Chapter and Compression Markers to Your Sequence
Once you have finished editing your sequence or program, you can add markers to the
sequence for use on DVD. Markers are reference points you can place within clips or
sequences that identify specific frames. There are three kinds of markers that relate to
authoring a DVD:
• Chapter markers: These allow DVD authoring applications to create a navigable chapter
list for your exported QuickTime movie. Chapter markers force the creation of MPEG
I-frames at their location, because the DVD specification requires an I-frame at each
chapter point.
• Compression markers: Also known as manual compression markers—these are markers
you can add to a sequence or clip to indicate when Compressor or DVD Studio Pro
should generate an MPEG I-frame during compression. For more information, see the
documentation included with Compressor and DVD Studio Pro.
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• Edit/Cut markers: Also known as automatic compression markers—these markers are
automatically generated by Final Cut Pro at each cut or transition point in a sequence.
During compression, Compressor uses these markers to generate MPEG I-frames at
these points, improving compression quality.
When you export a QuickTime movie, you have an option to export various kinds of
markers, including compression and chapter markers. When you choose the DVD Studio Pro
markers option, Final Cut Pro exports chapter markers, manual compression markers, and
edit/cut markers.
For details on adding and deleting markers, see “Using Markers.” For more details about
exporting markers, see “Exporting QuickTime Movies with Markers.”

More About Chapter Markers
You can add chapter markers so that DVD authoring applications can create a navigable
chapter list for your exported QuickTime movie. Chapter markers also appear in
QuickTime Player as a chapter list for jumping to specific parts of the movie using a pop-up
menu.
A chapter marker is distinguished by the text <CHAPTER> appearing in the Comment
field of its Edit Marker window. For details on adding and deleting markers, see “Using
Markers.”
When you export a movie or sequence containing at least one chapter marker, the resulting
QuickTime movie contains a text track automatically set up as a QuickTime chapter track.
Different applications use this QuickTime track in different ways:
• In QuickTime Player: A chapter track is visible from QuickTime Player as a pop-up menu
in the movie window. Choosing a chapter from this menu automatically moves the
playhead to that frame of the movie.
• In DVD authoring applications: Chapter markers are used by DVD authoring applications,
such as DVD Studio Pro and iDVD, to provide chapter navigation on a DVD.
When you add chapter markers for use by a DVD authoring application, they are subject
to the following limitations:
• No chapter marker should appear closer than 1 second to the beginning or end of your
edited sequence.
• A chapter marker should be at least 1 second away from any other chapter marker.
• A maximum of 99 chapter markers can be placed within a single program.
• When you export from a sequence, only sequence markers are exported; markers in
clips are ignored.
• When you export a clip from the Browser, the clip’s markers are exported.
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More About Compression and Edit/Cut Markers
Compression markers identify areas of abrupt visual changes in video, such as a cut from
a dark room to a bright, grassy plain. There are two kinds of compression markers:
• Compression markers: Also known as manual compression markers. These are markers
you can manually add to a sequence to ensure a particular section of video is encoded
using I-frames where you think they are necessary.
• Edit/cut markers: Also known as automatic compression markers. These markers are
automatically inserted by Final Cut Pro at all edit and transition points.
When you export a clip or sequence containing compression markers to a QuickTime
movie file, the resulting file contains a hidden text track used to store the compression
marker information.
Some video compression applications, including Compressor, are capable of using the
compression text track of your movie to optimize the placement of I-frames during the
process of MPEG-2 compression to achieve maximum playback quality.
In most cases, the edit/cut markers placed automatically by Final Cut Pro will suffice.
However, an abrupt visual change that occurs within a clip (as opposed to an abrupt
visual change caused by an intentional edit) may require a manual compression marker
for optimal compression. For example, suppose that in the middle of a long shot there
is a quick 180-degree pan from a dark jungle scene to a bright beach. The visual changes
from dark to light are dramatic, but there is no cut point in the shot for Final Cut Pro to
detect automatically. In this case, you can manually place compression markers at the
frames occurring immediately before and after the pan. Applications such as Compressor
will see these manual compression markers and place I-frames at those points in the
compressed video to minimize any compression artifacts.
A compression marker is distinguished by the text <COMPRESSION> appearing in the
Comment field of its Edit Marker window. For details on adding and deleting markers,
see “Using Markers.”
Compression markers are exported differently depending on whether you’re exporting
a sequence or a clip.
• If you’re exporting a clip in the Browser: You must place manual compression markers
in the clip for a compression track to be created. No automatic compression markers
are exported in this case.
• If you’re exporting a sequence: Final Cut Pro exports edit/cut markers for each cut,
transition, and gap that appears in your sequence. Manual compression markers are
also exported. Compression markers added to individual sequence clips are ignored.

1790

Chapter 107 Exporting Sequences for DVD

About DVD Authoring Applications
Whether you intend to use iDVD or DVD Studio Pro will affect how you export your movies
from Final Cut Pro. When you are using DVD Studio Pro, Compressor can become an
important part of the process.

Using iDVD
iDVD only imports standard QuickTime movies as video sources. This means that if you
intend to use iDVD as your DVD authoring application, you only need to export a
QuickTime movie from Final Cut Pro. iDVD automatically encodes the video and audio
sources to be DVD-compliant. The video is encoded as MPEG-2 video at a quality controlled
by a preference setting and the video length. The audio is encoded as an uncompressed
AIFF file.
For more information, see “Exporting a QuickTime Movie for DVD Use.” See the iDVD
documentation for information on importing the movie and adding it to your DVD.

Using DVD Studio Pro
DVD Studio Pro can import either standard QuickTime movies or DVD-compliant sources.
When you import standard QuickTime movies, they are automatically encoded to be
DVD-compliant. DVD Studio Pro has preferences that allow you to adjust the quality at
which your video is encoded, giving you more control of your final DVD quality than iDVD
provides. The audio is encoded as uncompressed PCM data. For information on exporting
a QuickTime movie, see “Exporting a QuickTime Movie for DVD Use.”
For the most control over your final video and audio quality, you can use applications
such as Compressor to encode your video and audio into DVD-compliant sources.
Compressor allows you to create special DVD-compliant formats such as MPEG-1 and
Dolby Digital AC-3 audio.
See the DVD Studio Pro documentation for details on supported video and audio formats
and information on importing your movies.

Exporting a QuickTime Movie for DVD Use
The process of exporting your movie as a standard QuickTime file is the same whether
you plan to use iDVD or DVD Studio Pro for creating a DVD.
To export a QuickTime movie for use in iDVD or DVD Studio Pro
1 In Final Cut Pro, choose File > Export > QuickTime Movie.
2 Configure settings in the Save dialog.
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In most cases, you will leave the Setting pop-up menu at Current Settings and include
both audio and video. If you have created any markers, choose DVD Studio Pro Markers
from the Markers pop-up menu. iDVD and DVD Studio Pro can use either self-contained
or reference movies, allowing you to decide whether to make the movie self-contained
based on other requirements (disk space and so on).
3 When you’re ready, click Save.
For more information, including detailed information on settings, see “Exporting QuickTime
Movies.”

Using Compressor to Create DVD-Compliant Sources for
DVD Studio Pro
iDVD, DVD Studio Pro, and Compressor all use the same core encoding software—each
encoder creates the same high-quality results. However, Compressor gives you full access
to all the encoder settings, whereas iDVD and DVD Studio Pro provide fewer options for
simplicity. For more information, see “Using Compressor with Final Cut Pro.” For details
about MPEG encoding settings for DVD, see the DVD Studio Pro User Manual, available in
DVD Studio Pro Help.
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Using Compressor with
Final Cut Pro

108

This chapter covers the following:
• About Compressor (p. 1793)
• Using Compressor with Final Cut Pro (p. 1794)
• Using Compressor as a Standalone Application (p. 1795)
• Sending from Final Cut Pro to Compressor (p. 1797)
• About Color Space Conversion in Compressor (p. 1798)
Compressor is a high-quality MPEG and QuickTime video encoder you can use to create
a variety of formats for DVD or web distribution.

About Compressor
Compressor is a video and audio encoding application that you can use to create media
files for online and DVD distribution. The main features in Compressor are described in
the following sections.

Video and Audio Encoding
Compressor can convert QuickTime movies to the following formats:
• For DVD: MPEG-1, MPEG-2 (both SD and HD), H.264, and AC-3 (for audio)
• For the web: MPEG-1, MPEG-4, and H.264
• For iPod: H.264
Note: The H.264 format is stored as a QuickTime movie containing an H.264 video track.

Performing Standards Conversion
Compressor includes a high-quality standards and format conversion feature that can be
used to:
• Convert a video from NTSC to PAL or vice versa with minimal frame rate artifacts.
• Create both standard definition (SD) and high definition (HD) versions of a project. For
example, you can export an HD sequence in Final Cut Pro to both HD and SD MPEG
files for HD and SD DVD releases.
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Previewing Video Output
Compressor includes a Preview window with a split screen so you can compare your
source video with the result of the effects and filters you apply to the job. The Preview
window also contains a timeline that allows you to set In and Out points for encoding.
You can also use the timeline to view and edit chapter, compression, and edit/cut markers.

Creating AC-3 Dolby Digital Audio
The Compressor AC-3 encoder is used to encode a variety of multichannel audio
configurations, such as stereo or 5.1-channel surround sound, into Dolby Digital audio
streams for use with DVD Studio Pro.

Batch Processing and Distributed Processing
You can encode movies individually or you can submit multiple movies to a batch
processing queue. Apple Qmaster, included with Compressor, reduces encoding time
with distributed processing, which distributes your video encoding tasks to multiple
computers on your local area network. Each computer needs to be configured as an
Apple Qmaster node.
Important: Distributed processing when sending to Compressor directly from Final Cut Pro
also requires each computer to have Final Cut Pro installed.
See the Compressor User Manual, available in Compressor Help, for information about
configuring computers for use in a distributed encoding process.

Compressor Droplets
Compressor Droplets are small applications you create in Compressor to perform specific
encoding tasks. If you have particular compression settings you use routinely, you can
save them as a Compressor Droplet and then drag your media files to the Droplet
whenever you want to create a compressed version of your media.
See the Compressor User Manual, available in Compressor Help, for more information on
creating and using droplets.

Using Compressor with Final Cut Pro
There are two ways you can use Compressor with Final Cut Pro:
• Using Compressor as a standalone application: Export a QuickTime movie from
Final Cut Pro and then submit the QuickTime movie to Compressor for encoding. For
more information, see “Using Compressor as a Standalone Application.”
• Send from Final Cut Pro to Compressor: This option allows Final Cut Pro to send content
directly to Compressor. For more information, see “Sending from Final Cut Pro to
Compressor.”
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Using Compressor as a Standalone Application
You can use Compressor as a standalone encoding application to submit QuickTime
movie files at any time, regardless of whether Final Cut Pro is opened.

When Should You Use Compressor as a Standalone Application?
If you want to continue using Final Cut Pro while Compressor is encoding, you can export
your Final Cut Pro clips and sequences to QuickTime movies and then submit them to
Compressor. The disadvantage of this method is that you must make an intermediate
copy of your movie. This requires extra time and, if you’re not careful, the additional
QuickTime processing step may cause some generational loss.
You can also use Compressor as a standalone application to transcode a source clip from
one standard or format to another before adding the clip to the Final Cut Pro sequence.
For example, if you want to convert a PAL clip to NTSC, you could do this directly in
Compressor without involving Final Cut Pro.

Using QuickTime Reference Movies
To use Compressor as a standalone application, you need to create QuickTime movie files
to submit to Compressor. For example, suppose you are working on a one-hour DV project
in Final Cut Pro that you want to encode to MPEG-2 for DVD authoring. Before you can
use Compressor, you need to export the entire one-hour sequence to a temporary
QuickTime movie file that you can then submit to Compressor. This temporary file takes
a lot of unnecessary disk space, so an alternative is to export a QuickTime reference movie.
QuickTime reference movies appear the same as standard QuickTime movies, but they
often take less disk space because the video track actually refers to your sequence’s
original media files when possible. The only time media is actually stored in a QuickTime
reference movie is during segments where rendering is required. Compressor processes
a QuickTime reference movie in the same way as a standalone QuickTime movie that
contains all of its media within its own video track. Exporting to QuickTime movies always
takes longer if rendering is required, but you still spare Final Cut Pro from the
time-consuming MPEG-2 compression phase.
Important: QuickTime reference movies are useful for temporary use on your local system,
but be careful not to send these movies to remote systems that don’t have all the required
media.

Creating Encoding Jobs in Compressor
To add a QuickTime movie to the Compressor encoding queue, you need to create an
encoding job. An encoding job contains a single source media file and settings for one or
more output files.
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To open Compressor
1 In the Finder, choose Go > Applications.
The frontmost Finder window displays the Applications folder on your computer.
2 Navigate to the Compressor application in the Applications folder, then double-click the
Compressor icon.
To submit a QuickTime movie to Compressor for encoding
1 Choose Job > New Job With File (or press Command-I).
2 Select a media file, then click Open.
An encoding job for the selected media file appears in the Batch window.
You can also create QuickTime movies by dragging one or more media files from the
Finder directly to the Batch window.

Applying Encoder Settings and Submitting Jobs
The steps for encoding QuickTime movies with Compressor are covered in detail in the
Compressor User Manual, available in Compressor Help. This section provides a brief
overview to get you started quickly.

µ

To select encoding settings for your job in Compressor
In Compressor, drag an appropriate setting from the Settings tab to the job in the Batch
window.
If you can’t find a setting that suits your needs, you can customize an existing setting or
create a new one. A Compressor setting defines all aspects of the conversion, such as
image dimensions, aspect ratio, encoding bit rate, frame rate, and so on.
If you want to export multiple versions of this job, you can drag additional settings from
the Settings tab to the job in the Batch window. For example, you might want to export
both AIFF and AC-3 files.

To choose where your encoded output files are saved
1 In Compressor, click the Destinations tab and then drag a destination preset to your job
in the Batch window.
By default, Compressor saves encoded files to the same location as your source media
file.
2 If you want, enter a new a name for the encoded file.
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To submit the job for encoding
Click Submit in the Batch window.
The Batch Monitor application opens and shows the encoding progress. Once encoding
is complete, you can use the encoded movie in your DVD, web, or iPod project.
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Sending from Final Cut Pro to Compressor
You can export a Browser clip or sequence directly from Final Cut Pro to Compressor by
using the Export Using Compressor command. Exporting media from Final Cut Pro to
Compressor works nearly the same as using Compressor as a standalone application. The
main difference is that Final Cut Pro renders media directly to Compressor during the
encoding process, so you don’t need to create an intermediate QuickTime movie.

When Should You Export Directly to Compressor?
The advantage of exporting a sequence to Compressor directly from Final Cut Pro is that
rendering happens as part of the transcoding process, potentially saving you time and
eliminating unwanted artifacts.
Compression and chapter markers in your Final Cut Pro sequence can be included in the
resulting compressed media files. When imported into DVD Studio Pro, the chapter markers
automatically appear in the Track Editor.
The disadvantage of this approach is that Final Cut Pro cannot be used for other tasks
until the export is finished. Depending on the length of the movie, the format you are
exporting to, and your computer’s capabilities, exporting can take a significant amount
of time.
To send a sequence or clip from Final Cut Pro to Compressor
1 In the Browser, select a sequence or clip you want to export.
If you want to export only a specific segment of a clip or sequence, set In and Out points
in your clip or sequence.
2 Choose File > Send To > Compressor.
Compressor opens and the sequence or clip you exported from Final Cut Pro appears as
a new encoding job in a Compressor Batch window.
Once your Final Cut Pro clip or sequence is set up as an encoding job in Compressor, you
can adjust settings and submit the job just as you would with any other individual
QuickTime source file in Compressor. For more information about setting up a Compressor
job for encoding, see “Applying Encoder Settings and Submitting Jobs.”
Important: The Source destination in Compressor actually results in the output media
files being placed at the root level of your startup volume. You can assign a different
destination in Compressor if needed. For more information, see the Compressor
User Manual, available in Compressor Help.
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About Color Space Conversion in Compressor
When you use the Send to Compressor command, super-white values in Y′CBCR footage
are preserved. Also, standard definition and high definition footage are processed in their
appropriate color spaces (ITU-R BT.601 and ITU-R BT.709, respectively).
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Exporting Still Images and Image
Sequences

109

This chapter covers the following:
• Determining the Image Format for Still-Image Export (p. 1799)
• Exporting a Single Still Image (p. 1800)
• Exporting Image Sequences (p. 1801)
At many points during your project, you may need to export still images of your video
for graphics, posters, the press, email, or the web.

Determining the Image Format for Still-Image Export
Final Cut Pro uses the built-in QuickTime technology in Mac OS X to export still images.
Because QuickTime supports a wide variety of graphics (still-image) formats, nearly any
graphics format you need to export is supported.
If you’re exporting images for a website, JPEG is a good option because it compresses
images to a small size but maintains fairly high quality. If you want to export images
without compression, you can export TIFF or Photoshop files.
Note: If you need to export a sequence as a numbered image sequence (a collection of
still images), you’ll go through a slightly different process than simply exporting a single
still image.
Resolution of Exported Still Images
Exported still images are 72 dpi. This number cannot be changed during export and is
irrelevant for video and computer use. If you are exporting for print and you need to
adjust the dpi setting, you can do so in a graphics application such as Adobe Photoshop.
Bit Depth of Exported Still Images
Exported still images are always exported using 8 bits per pixel per color channel. For
example, an RGB TIFF or Photoshop file uses a total of 24 bits (3 channels x 8 bits per
channel) per pixel. If an alpha channel is included, the exported file uses 32 bits per pixel
(4 channels x 8 bits per channel).
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Exporting a Single Still Image
Exporting a still image from Final Cut Pro is easy. First you create the still image, and then
you export it to the graphics file format you need.
To export a still image
1 In the Canvas or Viewer, position the playhead at the frame you want to export.

Move the playhead to
the frame you want
to export.

2 Choose File > Export > Using QuickTime Conversion.
3 Choose a location and enter a name for the file.
4 Choose Still Image from the Format pop-up menu.
5 Choose a file format from the Use pop-up menu.
Disregard the frame rate (frames per second, or fps) when exporting single still images.

Choose a setting from
the pop-up menu.

Some graphics file formats do not appear in the Use pop-up menu. If the file format you
need does not appear in the list, see step 6.
6 To select custom settings, click Options, and in the Export Image Sequence Settings
dialog, choose your settings and click OK.
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Custom settings allow you to choose any graphics file format supported by QuickTime.
You can also make particular adjustments to the compression method or color depth. In
most cases, the default values are fine, but if you need particular settings, you can adjust
the settings here. Each graphics file format has a unique set of adjustable parameters.

Choose a format.
This setting is not
relevant when exporting
still images.
Click here to set additional
options, if available.

• Format: Choose the graphics file format you want to use from the pop-up menu. Some
file formats have additional options for controlling the quality of the compression, the
color depth, and so on.
• Frames per second: This setting doesn’t apply for still images.
• Options: Click here to set options for the particular graphics file format you are exporting.
7 When you’re ready to export, click Save.

Exporting Image Sequences
You can export numbered image sequences in various formats using the Export Using
QuickTime Conversion command. If you want to export just a part of a clip or a sequence,
you can do so by setting In and Out points before exporting.
To export a numbered image sequence
1 Select a clip or sequence in the Browser or open a sequence in the Timeline.
2 Do one of the following:
• To export the entire clip or sequence: Clear all In and Out points.
• To export part of the sequence or clip: Set In and Out points.
For more information about In and Out points, see “Setting Edit Points for Clips and
Sequences.”
3 Choose File > Export > Using QuickTime Conversion.
4 Choose a location and enter a name for the file.
Note: You may want to create a new folder for the sequence of numbered image files.
5 Choose Image Sequence from the Format pop-up menu.
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6 Choose a setting from the Use pop-up menu.

Choose an export setting
from the pop-up menu.

If none of the options you need are listed in the Use pop-up menu, see step 7.
7 To select custom settings, click Options.
8 In the Export Image Sequence Settings dialog, choose your settings, then click OK.
Choose a format type
from this pop-up menu.
Enter a frame rate, or
choose an option from
the pop-up menu.

Click here to set additional
options, if available.

• Format: Choose the image format you want to use from the pop-up menu.
• Frames per second: Enter a value or choose an option from the pop-up menu for the
frame rate for the images.
• Options: Click here to set additional options, such as alternative bit depth or compression
settings, if they are available for the selected format.
9 When you’re ready to export, click Save.
A dialog shows you the progress of the export. To cancel your export, press Esc or click
Cancel.
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Each file of the image sequence is named in the form of “Filename 001.ext,” where
“Filename” is the name you gave, the number (001) is the number of the frame, and “.ext”
is the filename extension indicating the format.

A file is saved for each
frame of video.
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Batch Exporting Clips and
Sequences

110

This chapter covers the following:
• Overview of the Batch Exporting Process (p. 1805)
• Selecting Items in the Browser to Batch Export (p. 1805)
• Selecting Batch Export Settings (p. 1807)
• Doing a Batch Export (p. 1812)
• Opening Batch Exported Files in the Viewer (p. 1813)
• Redoing Batch Exports (p. 1814)
• About Color Space Conversion During Batch Exporting (p. 1815)
You can set up Final Cut Pro to export multiple clips and sequences at one time using
the Batch Export command.

Overview of the Batch Exporting Process
The Batch Export command lets you export multiple clips and sequences at one time.
This is particularly useful when you have a lot of clips or sequences to export at once, or
if you need to export the same sequence to multiple formats and settings. Items to be
exported are shown in the Export Queue window and organized into bins, each with its
own export settings. You can set up several bins with different settings so you can export
different types of files. You can also choose to export only the media between clip In and
Out points instead of the entire clip’s media file. For example, you can set up a batch
export to do the following:
• Export a sequence to several QuickTime movie files, each with different dimensions
and codec qualities.
• Export an image sequence.
• Export an audio-only media file.

Selecting Items in the Browser to Batch Export
You can select as many clips, sequences, and bins as you want to batch export.

1805

To place clips, sequences, and bins in the Export Queue
1 In the Browser, select clips, bins, and sequences you want to export.
You can select items
from more than one
open project.

Select the items you
want to export.

2 Choose File > Batch Export.
The Export Queue window appears with the selected items. A bin named Batch N is
automatically created with your selections, where N is the bin’s number.
A bin is automatically
created with the
selected items.
Items waiting to be
exported have a
Queued status.

Items selected from
different projects or
at different times are
in separate bins.

1806

Chapter 110 Batch Exporting Clips and Sequences

3 To change the name of a bin in the Export Queue, click the bin’s name once to select it,
wait a moment, then click the name a second time. Type a new name.
If you want, enter a
new name for the bin.

4 To create a new bin, choose File > New > Bin (or press Command-B).
Each bin in the Export Queue has its own export settings. You may want to reorganize
items into different bins to keep items with the same settings in the same bin.
5 To add additional items, do one of the following:
• Select additional items, then choose File > Batch Export again.
• Drag items from the Browser to a bin in the Export Queue window.
To select batch export settings, see “Selecting Batch Export Settings.”
If you don’t want to select settings now, you can close the Export Queue window. To
select export settings later, choose Window > Export Queue.
Important: Items in the Export Queue disappear after you quit Final Cut Pro. If you quit
before you batch export, you’ll have to add the items to the Export Queue again.

Selecting Batch Export Settings
Items in the Export Queue window do not have individual export settings. Instead, each
bin in the Export Queue has export settings. When you place a clip or sequence into a
bin in the Export Queue, that item is exported using the settings assigned to the bin.
You can place the same clip or sequence in as many Export Queue bins as you like. This
allows you to export the same clip or sequence with different settings or to multiple file
formats.
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You can specify export settings for a bin by selecting a bin and clicking the Settings button
or by selecting options in individual columns in the Export Queue window.
• To use the Settings button: See “Choosing Export Settings with the Settings Button.”
This is convenient because you can select all settings from one main window.
• To choose settings from columns in the Export Queue window: See “Selecting Batch Export
Settings from Columns.” This is useful when you want to change just a few settings.

Choosing Export Settings with the Settings Button
You can click the Settings button to access the Batch Export window, which allows you
to specify settings for all items in a bin.
To specify settings for batch export items using the Settings button
1 Select the bin in the Export Queue window, then click the Settings button.
Select the bin that
contains the items you
want to export.

Then click Settings.

In the Batch Export window, you can specify settings for all items in the bin.

2 Click Set Destination, then choose a location to save the exported file.
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3 Choose a QuickTime-compatible file format from the Format pop-up menu.

Choose a format here.

These are the same file format choices available when using the Export Using QuickTime
Conversion command and the Export QuickTime Movie command.
Tip: If you choose the QuickTime Movie file format, the settings available are the same
as when you use the Export QuickTime Movie command. This allows you to select whether
video, audio, or both tracks are exported, whether frames are recompressed, and whether
or not the resulting movie file is self-contained.
If you choose any other option, the options available are the same as when you use the
Export Using QuickTime Conversion command. For more information, see “Exporting
Using QuickTime Conversion” and “Exporting QuickTime Movies.”
4 Choose preset settings from the Settings pop-up menu.
The preset settings you see depend on the format you’ve selected.
Note: If you are exporting a QuickTime movie, the preset settings are the current sequence
presets available in Final Cut Pro. This is the same as when you are using the Export
QuickTime Movie command, except the option Item Settings replaces Current Settings,
and no custom settings choice is available.
If you want to export a QuickTime movie using all available QuickTime customization
settings, make sure you choose QuickTime (Custom) from the Format pop-up menu.
5 To specify additional settings, click Options (if available), then click OK.
Some formats let you choose additional options, such as bit rate. The Options button is
dimmed if no options are available. Many of these options are described in “Configuring
QuickTime Movie Settings” and “QuickTime Movie Sound Settings.”
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6 Click Set Naming Options, choose the type of file extensions you want, then click OK.
Select or deselect
checkboxes to specify
file extensions for the
exported files.

To add a custom
extension, enter it here.

• Strip Existing Extension: Specifies whether an existing extension is removed from the
base filename when the export filename is created. This is useful if you’re adding your
own extension.
• Add Custom Extension: Type a custom extension to be applied to the filename.
• Add File Type Extension: Specifies whether the default extension for the specific export
file type is automatically appended to the filename.
Typical extensions are:
• .mov: QuickTime movie files
• .pct: PICT files
• .png: TIFF files
• .wav: WAVE files
• .aif: AIFF files
7 If you chose QuickTime Movie from the Format pop-up menu, choose the tracks you want
to export from the Include pop-up menu—Audio and Video, Audio Only, or Video Only.
An empty audio track can still take up disk space. If your exported file doesn’t need an
audio track, choose Video Only.
8 If you chose QuickTime Movie from the Format pop-up menu, the Recompress All Frames
and Make Self-Contained options are available. You can select these options if you want.
For more information about these options, see “Choosing the Type of QuickTime Movie
to Export.”

Select the options
you want.
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9 Select the Use Item In/Out checkbox to export only the media between the current In
and Out points. If this is not selected, all of the media in the clip or the entire sequence
is exported.
10 Click OK.
After you specify your settings, you’re ready to export. For more information, see “Doing
a Batch Export.”

Selecting Batch Export Settings from Columns
The columns in the Export Queue window display details about each bin. You can change
export settings directly from these columns.

µ

To change batch export settings from the Export Queue window
Control-click in a column for a bin, then choose a setting from the shortcut menu.
If the message “No shortcut” appears, the information in that column cannot be changed
from the Export Queue window.

Columns in the Export Queue Window
Here is a list of the columns in the Export Queue window.
• Name: Displays the name of the item. The Name column always appears on the left.
• Type: Displays the type of item—clip, subclip, merged clip, sequence, bin, or effect.
• Status: Displays the current export status for the item. If there’s an error during export,
a message explaining the problem appears.
• Queued: An item is ready for export. This appears when an item is first added to the
Export Queue.
• Done: An item was successfully exported. These items are ignored if you start another
batch export process.
• Canceled: The export process was canceled.
• Error: This appears when a problem prevented the item from being exported
successfully.
• Base Output Filename: Lets you specify new filenames for clips and sequences. If nothing
is specified in this column, the item name is used as the output filename. Naming
options specified in the Batch Export window are also applied to the filename specified
here.
• Length: Displays the total length of the clip or sequence, regardless of In and Out points.
• Destination: The path to the folder on disk where the exported files will be saved. The
Render Files folder is used by default. To change the folder, double-click in this column.
In the dialog, choose a location to save the file.
• Format: Displays the file format used for exporting.
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• Settings: Displays the preset settings chosen for this export bin from the Settings pop-up
menu in the Batch Export window. You can Control-click to choose preset settings here
and choose options from the shortcut menu.
• Use In/Out: Make sure there is a checkmark in this column to export the sequence or
clip using the current In and Out points. If there is no checkmark in this column, all of
the media in the clip or the entire sequence is exported.
• Strip Existing Extension: Specifies whether an existing extension is removed from the
base filename when the export filename is created. This is useful if you’re adding your
own extension.
• Add Custom Extension: Type a custom extension to be applied to the filename.
• Add File Type Extension: Specifies whether the default extension for the specific export
file type is automatically appended to the filename.

Options When Exporting a QuickTime Movie
The following three options are available in the Batch Export Window only when the
exported file format is a QuickTime movie:
• Include: Specifies which tracks should be included in the exported media file—Audio
and Video, Audio Only, or Video Only.
• Recompress All Frames: This is the same option that is available when you use the Export
QuickTime Movie command. For more information, see “Exporting QuickTime Movies.”
• Make Movie Self-Contained: This is the same option that is available when you use the
Export QuickTime Movie command. For more information, see “Exporting QuickTime
Movies.”
After you specify your settings, you’re ready to export. For more information, see “Doing
a Batch Export.”

Doing a Batch Export
After you’ve selected the clips and sequences you want to export, organized them into
bins, and specified settings, you export the items as a batch.
To do a batch export
1 In the Export Queue window, select the bins you want to export.
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If you want to export all items in the Export Queue, deselect all items.
Select the bin you
want to export.

Then click Export.

2 Click Export.
A dialog shows you the progress of the export. To cancel your export, press Esc or click
Cancel. To reexport these items, see “Redoing Batch Exports.”
Once items have been exported, the message in the Status column for each exported
item changes to Done. To view exported items, see “Opening Batch Exported Files in the
Viewer.”

The status of an item
changes to Done when
it is successfully
exported.

Opening Batch Exported Files in the Viewer
After your sequences and clips have been exported, you can open them in the Viewer.

µ

To open batch exported files in the Viewer
In the Export Queue window, select an item, then click View Exported.

Chapter 110 Batch Exporting Clips and Sequences

1813

The status of the selected item must be Done.
Select an item to view.

Then click View Exported.

Each item appears in a separate Viewer window.
To add batch exported items to your project
1 In the Export Queue window, select an item that has been successfully batch exported,
then click View Exported.
The item appears in a new Viewer window.
2 Drag the item from the new Viewer window to the Browser.
A clip connected to the batch exported media file is created in the Browser.

Redoing Batch Exports
If items in the Export Queue were canceled or stopped because of errors, they can be
easily requeued.
An item’s status can be changed at any time, from Queued to Done or from Error to
Queued. For example, an item that was canceled before the export was completed can
be set back to Queued and exported again.
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To change the status of items in the Export Queue
Control-click in the Status column of the item you want to change, then choose a status
from the shortcut menu.

About Color Space Conversion During Batch Exporting
Color space conversion may occur when you use the Batch Export window, depending
on which export option you choose. All file format options except the QuickTime Movie
option use the same settings as the Export Using QuickTime Conversion command and
therefore clip super-white values in Y′CBCR footage. The QuickTime Movie option uses
the same settings as the Export QuickTime Movie command, so super-white values may
be preserved in Y′CBCR footage if you choose this option.
For more information, see “Exporting Using QuickTime Conversion” and “Exporting
QuickTime Movies.”
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Choosing Settings and Preferences

111

This chapter covers the following:
• Changing User Preferences (p. 1817)
• Changing System Settings (p. 1829)
Final Cut Pro has numerous settings and preferences that allow you to customize your
system for particular video formats and editing styles.

Changing User Preferences
A preference modifies how a particular Final Cut Pro feature behaves. Most preferences
can be turned on or off at any time, whereas others accept a value, such as the number
of Undo levels or the name of a label.
The following section describes Final Cut Pro user preferences in detail.

µ

To open the User Preferences window
Choose Final Cut Pro > User Preferences (or press Option-Q).
The General tab is open
by default.
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The User Preferences window is divided into several tabs.
Note: The Timeline Options, Render Control, and Audio Outputs tabs contain the default
preferences used when you create new sequences.
• General tab: Settings in this tab control a variety of features, such as warning dialogs
during capture, the number of Undo levels allowed, and the Autosave and Auto Render
features.
• Editing tab: This tab contains preferences useful while editing, such as trimming and
audio keyframing controls.
• Labels tab: In this tab, you can change the names associated with the different colored
labels that are available within Final Cut Pro.
• Timeline Options tab: These are the default display options used when a new sequence
is created. This is where you can change the default number of video and audio tracks
for new sequences. For more information, see “Timeline Basics.”
• Render Control tab: This tab allows you to choose the render quality of new sequences
you create. For more information, see “Rendering and Video Processing Settings.”
• Audio Outputs tab: This is where you can choose the default audio output preset used
for new sequences. If none of the audio output presets matches your audio
configuration, you can create your own custom preset in this window. For more
information, see “Assigning Output Channels and External Audio Monitors.”
Important: Once a sequence has been created, you change its settings by choosing
Sequence > Settings, not User Preferences. Settings in the User Preferences window
establish the default preferences for new sequences, not sequences that already exist.
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General Tab
This tab contains fundamental preferences relating to application launch, creation of new
projects and sequences, and automatically scheduled events such as Autosave and Auto
Render.
The General tab is open
by default.

About Audio Playback Quality
Sample rate conversion occurs when you use clips with audio sample rates that differ from
the sample rate in your sequence’s settings. If the sample rate of your media files matches
the sample rate of the sequence, this pop-up menu has no effect.
Transitions between rendered and nonrendered portions of audio clips are also affected
by the quality setting chosen in the Audio Playback Quality pop-up menu. For example,
if you choose Low quality and you play a partially rendered clip that contains a reverb,
you won’t hear the tail of the reverb when the playhead crosses the boundary from a
rendered to a nonrendered section of the sequence. However, if you choose Medium or
High quality, you hear the reverb even when crossing the render boundary.
Undo and Recent Clips Options
• Levels of Undo: Enter a value to specify the number of actions that can be undone. The
maximum number of Undo levels you can specify is 99. The default is 10. For information
on undoing an action, see “Overview of the Final Cut Pro Interface.”
• List Recent Clips: This value determines how many clip names appear in the Recent
Clips pop-up menu in the Viewer. This pop-up menu shows a list of clips that you
opened from the Browser, in the order they were opened (with the most recently
opened clip at the top of the list). The default is 10 clips, and the maximum is 20. For
more information on using the Viewer’s Recent Clips pop-up menu, see “Viewer Basics.”
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Real-Time Audio and Video Options
• Real-time Audio Mixing: Enter a number in this field to specify how many audio tracks
can be mixed in real time. The default is 8 tracks, and the maximum is 99. The maximum
number of tracks that can be mixed without having to be rendered is affected by your
computer’s processing capabilities, the number and types of filters used in your
sequence, the data transfer rate of your hard disk, and the amount of memory available
to Final Cut Pro.
• Audio Playback Quality: This pop-up menu affects the quality of sample rate conversions
(when your audio clips have a different sample rate than the sequence that contains
them) and transitions between rendered and nonrendered sections in the Timeline.
• Low (faster): This choice yields the best real-time audio performance, but the lowest
sample rate conversion quality. When the playhead moves from rendered to
nonrendered audio segments in the Timeline, there may be an audible click or a
distracting shift in levels. For basic editing, this is usually the best choice.
• Medium or High: When you start to do detailed mixing of your audio tracks, you may
want to raise the audio mixing quality to Medium or High. Higher-quality sample
rate conversions sound better, but require more processing power and thus limit
the number of simultaneous tracks you can work with in real time. Also, shifts between
rendered and nonrendered audio segments sound smoother. Final Cut Pro always
uses the highest quality setting (regardless of what is chosen in the Audio Playback
Quality pop-up menu) when rendering, mixing down audio, editing to tape, printing
to video, or exporting audio and OMF files.
• Limit real-time video to N MB/s: Final Cut Pro uses this number to limit how many video
streams can play back from your scratch disk in real time. This is useful when multiple
editing systems are sharing the same media (such as a storage area network, or SAN),
or when you have a scratch disk with a limited data rate, such as a portable computer
hard disk.
For example, suppose you try to play a sequence with six simultaneous video tracks
containing DV media, and Final Cut Pro warns you that frames were dropped during
playback. If you then try to play a sequence with five simultaneous video tracks and
no frames are dropped, you know that your scratch disk can handle no more than five
simultaneous DV video streams. Since DV has a data rate of 3.6 MB/sec., you can select
the “Limit real-time video to” option and enter 18 MB/sec. (5 x 3.6 MB/sec.) in the number
field. Now, if a sequence requires a sustained data rate of more than 18 MB/sec. for
playback, Final Cut Pro shows a red render bar over this portion of the sequence.
Note: Final Cut Pro always allows a single video stream to play, even if the data rate
limit you set is below the data rate of a single video stream. For example, if you set the
data rate limit to 1 MB/sec., Final Cut Pro would still play back a single DV video stream,
even though its data rate is 3.6 MB/sec.
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Interface Options
• Show Tooltips: Select this option to automatically display descriptions of interface
elements and their corresponding keyboard shortcuts, called tooltips. Tooltips appear
in small yellow boxes when you move the pointer over a control and pause briefly
(without clicking the control). When you move the pointer away from the control, the
tooltip disappears.
The tooltip (interface
element and keyboard
shortcut) that appears
when you place the
pointer over the Play
button in the Viewer

• Bring all windows to the front on activation: When this option is selected and Final Cut Pro
is in the background, clicking one Final Cut Pro window brings all Final Cut Pro windows
to the front at once.
• Open last project on application launch: This option determines whether Final Cut Pro
opens with a new, untitled project, or the last project or projects that were open when
you last quit the application.
Autosave Options
• Autosave Vault: The Autosave option saves a copy of each open project at regular
intervals. For more information, see “Using the Autosave Feature.”
New Project and Sequence Options
• Prompt for settings on New Project: When this option is selected, the Project Properties
window appears when you create a new project. For more information about setting
project properties, see “Working with Projects, Clips, and Sequences.”
• Prompt for settings on New Sequence: When this option is selected, a dialog appears
asking you to choose a sequence preset whenever you create a new sequence. This
can be useful if you regularly work with several different video formats. If you always
edit the same video format, you’ll probably want to deselect this option.
Capture and Playback Options
• Sync audio capture to video source if present: Select this option in the following scenarios:
• You have an audio interface that has a video genlock input, and the genlock input
is receiving a proper video signal.
• You are capturing audio media that you intend to synchronize with video, such as
sound recorded on a separate audio recorder during a film or video production. For
more information on genlocking a device-controllable audio deck, see “Connecting
Professional Video and Audio Equipment.”
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• Report dropped frames during playback: If you select this option, a message appears if
any frames are dropped during playback from the Viewer, Canvas, and Timeline, or
when outputting using Edit to Tape or Print to Video. When Final Cut Pro drops frames,
it is usually because there is a hardware or setup problem, such as scratch disks that
are too slow compared to the media data rate. For information on what you can do if
Final Cut Pro reports dropped frames, see “Problems During Playback.”
• Abort ETT/PTV on dropped frames: If this option is selected, a message appears if any
frames are dropped during playback from the Viewer, Canvas, and Timeline when
outputting using Edit to Tape or Print to Video. Dropped frames are almost always
caused by a hardware setup problem. For information on what you can do if Final Cut Pro
reports dropped frames, see “Problems During Playback.”
• Abort capture on dropped frames: When this option is selected, capture stops immediately
when a dropped frame is detected. All media captured before the dropped frame has
frame-accurate timecode and is preserved. The resulting media file is saved and a clip
for that media file is placed in the Browser.
• On timecode break: This pop-up menu gives you several ways to avoid capturing media
with timecode breaks.
• Make New Clip: With this choice, Final Cut Pro creates a new media file (and connected
clip) each time a timecode break is encountered. This is a good setting if you are
batch capturing an entire tape at once.
• Abort Capture: If this option is selected, capture is stopped whenever a timecode
break is detected. All media captured before the timecode break has frame-accurate
timecode and is preserved. The resulting media file is saved and a clip for that media
file is placed in the Browser.
• Warn After Capture: If this option is selected, only one media file is captured, even if
there are timecode breaks. Timecode breaks are reported after capture, so you can
be aware that the media file may not contain trustworthy timecode. It is unwise to
use media files with timecode breaks unless you have no choice, because you can’t
accurately recapture the media files. For more information, see “Capturing Video
from Tape.”
Text Size Options
• Browser Text Size: This pop-up menu allows you to choose how small or large text
appears in the Browser and Timeline. You can also adjust these settings by choosing
View > Text Size or Control-clicking in the Browser and choosing Text Size from the
shortcut menu.
Auto Render Option
• Auto Render: The Auto Render option allows you to take advantage of idle computer
time when you’re not editing—such as during a coffee break or lunch—to render open
sequences in the Timeline.
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For more information, see “Rendering and Video Processing Settings.”

Editing Tab
The preferences in this tab affect editing behaviors in Final Cut Pro.

Default Timing Options
• Still/Freeze Duration: This value determines the duration for imported graphics and
freeze frames you create in Final Cut Pro (when you choose Modify > Make Freeze
Frame in the Canvas or Viewer). The default duration is 10 seconds. In and Out points
are set around the middle of a clip, providing equal handles for trimming on either
side of the clip.
You can increase the length of a freeze frame clip by opening it in the Viewer and
entering a higher value in the Timecode Duration field.
Note: In Final Cut Pro, duration is the amount of time between a clip’s In and Out points,
and length refers to the time between Media Start and Media End. The default length
of a still-image or freeze frame clip is 2 minutes, whereas its duration is determined by
the Still/Freeze Duration value. However, if you set the Still/Freeze Duration value to
be greater than 2 minutes, new still images or freeze frames are created at this length
without handles.
One reason you may want to change this value is if you’re going to import an image
sequence. For example, if you set the Still/Freeze Duration value to 00:00:00:01 (one
frame), you can import an entire folder of numbered images and then place them in
a sequence.
• Preview Pre-roll: This value is used by the Play Around Current control and the Trim Edit
window to determine how much time before the playhead should be played.
• Preview Post-roll: This value is used by the Play Around Current control and the Trim
Edit window to determine how much time after the playhead should be played.
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For more information, see “Viewer Basics.” The setting is also applicable in the Trim
Edit window; see “Trimming Clips Using the Trim Edit Window.”
Dupe Detection Options
• Handle Size: This preference adds frames to the beginning and end of the clip regions
that are used for comparison, to determine whether or not to display duplicate frames
indicators. This can be used to take into account the extra frames that must be used
for physically cutting and cementing pieces of negative that are necessary for film
match-back, to prevent you from accidentally including frames that can’t really be used.
By default, this is set to 0.
In the following example, the sequence contains ten duplicate frames. Below, the
handle size setting is set to zero frames, so no additional frames are shown.

These ten frames are used
twice, so they are shown
as duplicate frames.
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When the handle size setting is set to ten frames, five additional frames on either side
of the duplicate frames are displayed.
Ten duplicate frames

Five additional frames
beyond the duplicate
frames are shown here...

...and here.

• Threshold: This allows you to set a minimum number of frames that must be duplicated
before a duplicate frames indicator appears. By default, this is set to 0 so that all
instances of duplicated frames are indicated. You can set it as high as 99 frames (3 to
4 seconds, depending on the frame rate), in which case there would have to be a
minimum of 99 consecutive duplicated frames before a duplicate frames indicator
would appear. For more information on duplicate frames indicators, see “Keep Track
of Duplicate Frames” and “Adding Transitions.”
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The example below shows a sequence that contains two instances of clip A, where ten
of the frames from Clip A are used twice.
The same ten frames
from the same media
file are used here...

...and here.

When the handle
threshold is less than
or equal to ten, the
duplicate frames
are displayed.

When handle threshold
is greater than ten, the
duplicate frames are
not indicated.

Imported Still/Video Gamma
• Gamma Level: This pop-up menu determines the default gamma setting for supported
still images and graphics that you import. During playback, Final Cut Pro uses this
gamma setting to determine whether gamma correction should be applied to the clip.
For more information, see “Rendering and Video Processing Settings.”
BWF Import
• NTSC Default Timecode: This pop-up menu determines the default timecode mode
(drop frame or non-drop frame) for imported Broadcast Wave Format (BWF) files with
an NTSC-related sample rate. For more information, see “Importing Media Files into
Your Project.”
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Trim Edit Window Options
• Dynamic Trimming: Select Dynamic Trimming to allow edit points in the Trim Edit
window to automatically follow the position of the playhead. For more information,
see “Timeline Basics.” The setting is also applicable for trimming; see “Learning About
Trimming Clips.”
• Trim with Sequence Audio: When this option is selected, you hear all sequence audio
tracks while using the J, K, and L keys on either side of the Trim Edit window.
• Trim with Edit Selection Audio (Mute Others): When this option is selected, all audio tracks
except the ones currently selected in the Timeline are muted when you use the J, K,
and L keys to play clips on either side of the Trim Edit window.
• Multi-Frame Trim Size: This value determines how many frames are trimmed when using
the Trim Back and Trim Forward buttons in the Trim Edit window or the equivalent
shortcut keys in the Timeline. The maximum number of frames allowed is 99. For more
information, see “Trimming Clips Using the Trim Edit Window.”
Visibility, Track Locking, and Audio Keyframe Options
• Warn if visibility change deletes render file: Making an entire track invisible automatically
deletes any render files associated with that track. Make sure you select this option to
see a warning before this occurs.
Note: As an alternative to hiding a track and losing its render files, you can make
individual items invisible, which preserves these render files. To find out how to disable
individual clip items, see “Compositing and Layering.”
• Record Audio Keyframes: When this option is selected, keyframes are recorded whenever
audio level, pan, or filter controls are adjusted. The pop-up menu defines how detailed
keyframe automation is when recorded using the Audio Mixer or audio filter controls.
Note: The Record Audio Keyframes button also controls this option. By default, this
button appears in the button bar of the Audio Mixer tab of the Tool Bench window.
You can choose the resolution of keyframe recording (in other words, how often audio
level and pan keyframes are added to a clip while you adjust a fader in the Audio Mixer).
For more information about recording audio keyframes, see “Using the Audio Mixer.”
• All: Records the maximum number of keyframes possible while you move a channel
strip’s fader or panning slider. The end result is a precise re-creation of the levels you
set using the Audio Mixer. The drawback to this option is that you might end up with
an extremely dense cluster of keyframes in the audio level overlays of the affected
clips that can be difficult to edit later.
• Reduced: Reduces the number of recorded keyframes that are created when you
move a channel strip’s fader or panning slider. The resulting audio level or pan overlay
in the Timeline or Viewer is an accurate reproduction of the levels you set but is
easier to edit using the Selection or Pen tool.
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• Peaks Only: Records only a minimum number of keyframes necessary to approximate
the levels you recorded when moving a channel strip’s fader or panning slider.
Keyframes recorded using the Peaks Only option reflect only the highest and lowest
levels that were recorded. This is primarily useful when you want to record a minimum
number of keyframes to edit later in the Timeline or Viewer.
• Pen tools can edit locked item overlays: If this option is selected, you can modify audio
level and video opacity keyframes in clips on locked tracks in the Timeline.
File Reconnection and Final Cut Studio Integration Options
• Always Reconnect Externally Modified Files: When this checkbox is selected, Final Cut Pro
reconnects clips to any media files that have been modified since the last time
Final Cut Pro was the active application. Select this option when you are working with
a lot of media files or projects, such as embedded Motion or Soundtrack Pro projects.
For more information, see “Reconnecting Media Files Automatically.”
• Warn on “Send to Soundtrack Pro Script”: When this checkbox is selected, Final Cut Pro
displays a dialog that allows you to decide how media files are processed when you
choose File > Send To > Soundtrack Pro Script > [script name]. For more information,
see “Working with Soundtrack Pro and Logic Pro.”
Automatic Conforming and Scaling Options
• Auto conform sequence: This pop-up menu determines whether sequence settings are
automatically conformed to the settings of the first clip added.
• Always scale clips to sequence size: Select this checkbox when you want edited clips
whose frame size is smaller than that of the current sequence to be scaled up when
you add them to the sequence.
For more information about these options, see “Working with Mixed-Format Sequences.”

Labels Tab
This tab allows you to customize the label name associated with the label colors in
Final Cut Pro. These preferences affect any project you open; they are not saved on a
per-project basis. For example, if you change the name associated with the orange label
to “Landscape shots,” any clip assigned to the orange label has this label name, regardless
of what project the clip is in. If you want to label a clip with a name that won’t change,
you can use the clip’s Label 2 property instead. For more information about working with
labels, see “Organizing Footage in the Browser.”

Timeline Options Tab
This tab is used to set default options for new sequences. This is where you set the default
number of video and audio tracks for new sequences. Once a sequence is created, you
can change display options by choosing Sequence > Settings or by using the Timeline
display controls in the lower-left corner of the Timeline. For more information, see “Timeline
Basics.”
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Render Control Tab
This tab is used to set default render options for new sequences. You can choose the
default frame rate and resolution settings used when you render items in new sequences,
and decide what kinds of effects are displayed (such as filters and speed settings). Once
a sequence is created, you can change its render control options by choosing Sequence
> Settings and clicking the Render Control tab. For more information, see “Rendering and
Video Processing Settings.”

Audio Outputs Tab
This tab is used to choose the default audio output preset for new sequences. An audio
output preset defines the number of dual mono or stereo pairs of audio outputs for your
sequence. For more information, see “Assigning Output Channels and External Audio
Monitors.”

Locating and Deleting the Preferences File
If you are having trouble with Final Cut Pro, one common troubleshooting technique is
to quit the application, delete the preferences file, and then reopen Final Cut Pro. By
default, preferences are stored in the location
/Users/username/Library/Preferences/Final Cut Pro User Data/Final Cut Pro N
Preferences.fcset (where N is the version number of the application).
If you want to bring your preferences to another editing system, you can copy or send
this preferences file to the same location on the new system.

Changing System Settings
Settings apply to capture, sequence, rendering, real time, output, hardware, and format
configurations in Final Cut Pro. Once you set up for a particular video format and device,
these settings are adjusted relatively infrequently. There are several places you can modify
settings in Final Cut Pro:
• System settings: The System Settings window covers a wide variety of settings, mainly
related to the computer setup you are using and how Final Cut Pro interacts with it.
System settings affect the fundamental components of your Final Cut Pro system, such
as scratch disk assignment, memory usage, and real-time playback options via software
or third-party hardware. For more information, see the following sections.
• Audio/Video settings and Easy Setups: For more information, see “Audio/Video Settings
and Easy Setups.”
• Sequence settings: For more information, see “Sequence Settings and Presets” and
“Timeline Basics.”

µ

To open the System Settings window
Choose Final Cut Pro > System Settings.
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The System Settings window is divided into several tabs:

• Scratch Disks tab: For details, see “Scratch Disks Tab.”
• Search Folders tab: For details, see “Search Folders Tab.”
• Memory & Cache tab: For details, see “Memory & Cache Tab.”
• Playback Control tab: For details, see “Playback Control Tab.”
• External Editors tab: For details, see “External Editors Tab.”
• Effect Handling tab: For details, see “Effect Handling Tab.”

Scratch Disks Tab
You use the Scratch Disks tab to choose where you want to save captured video and
audio media files and where to store the render, cache, and autosave files that Final Cut Pro
creates. You can also specify other settings related to the size of captured and exported
files and the minimum available space allowed on scratch disks. You can specify a
maximum of 12 scratch disks. For more information about scratch disks, see “Connecting
DV Video Equipment.”
About Waveform and Thumbnail Cache Files
Waveform and thumbnail cache files are temporary files Final Cut Pro creates when you
import media files. Neither type of file requires much hard disk space, so you can choose
to store them on your internal disk or an external scratch disk. If these files are moved or
deleted, Final Cut Pro can re-create them when you open a project file.
To set locations for the waveform and thumbnail cache files
1 In the Scratch Disks tab, click Set next to the appropriate item.
2 In the dialog that appears, locate and select the disk you want to use.
3 Click Choose.
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The specified disk is listed next to the Set button, along with the amount of available disk
space.
About Waveform Cache Files
A waveform cache file contains a waveform overview for audio in your project.
About Thumbnail Cache Files
Thumbnail cache files store small representative images of your clips that appear in the
Browser and Timeline.
The amount of space that the cache files use is determined by the Thumbnail Cache
setting in the Memory & Cache tab of the System Settings window. For more information,
see “Memory & Cache Tab.” For information about the autosave feature, see “Using the
Autosave Feature.”

Search Folders Tab
When reconnecting clips to media files, Final Cut Pro uses the folders assigned in this tab
to search for media. The folders listed here appear in the Search Folders pop-up menu
in the Reconnect Files dialog, allowing you to limit your media search to specific media
drives and folders. This is helpful when you have a large number of disks that contain
footage for multiple projects, or when you are using a storage area network (SAN).
Tip: Searching a SAN or subdirectories of an HFS Plus volume can be more time-consuming
than searching an entire HFS Plus volume, so you can speed up the search processes
performed when reconnecting media by limiting which folders Final Cut Pro searches on
your SAN.

To add or replace a search folder
1 Choose Final Cut Pro > System Settings, then click the Search Folders tab.
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2 Do one of the following:
• Click the last Set button to add a new search folder.
• Click Set next to an existing search folder to replace it.
The Choose a Folder dialog appears.
3 Navigate to the search folder you want to use in the Choose a Folder dialog, then click
Choose.
4 Click OK.
The current list of search folders appears in the Search Folders pop-up menu in the
Reconnect Files dialog.
For more information, see “Reconnecting Clips and Offline Media.”

µ

To remove a search folder
Click Clear next to the search folder you want to remove from the list.
Note: When a mounted volume is missing, Final Cut Pro displays the message “[volume
name] is missing.”

Memory & Cache Tab
The settings in this tab affect memory usage in Final Cut Pro.
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Memory Usage Settings
Use these fields to decide how much of the RAM in your computer is available for
Final Cut Pro to use. Your computer’s available RAM is defined as the amount of RAM not
used by Mac OS X and other currently open applications. By limiting the amount of RAM
Final Cut Pro uses, you can maintain the performance of Final Cut Pro by preventing
Mac OS X from using virtual memory unnecessarily. This is especially important when
multiple applications are open at the same time.
• Application: This specifies what percentage of available RAM Final Cut Pro should use.
The total amount of allocated RAM appears to the right. The minimum amount of RAM
you can allocate to Final Cut Pro is 125 MB. If the amount of available RAM is lower
than 125 MB, this slider is dimmed.
• Still Cache: This specifies the amount of RAM used to hold still images for real-time
playback. The still cache that is allocated is a percentage of the excess RAM allocated
to Final Cut Pro, so adjusting the Application slider also adjusts the amount of RAM
available to the still cache. The more RAM allocated to the still cache, the more still
frames can be played back in real time in the currently selected sequence. If another
sequence is opened, the contents of the still cache are replaced with stills from the
new sequence. If there is no excess RAM available, this slider is dimmed.
Thumbnail Cache Settings
Use these fields to set the size of your cache. The thumbnail cache stores the clip
thumbnails displayed in the Timeline and the Browser. When you choose to display
thumbnails, the thumbnail cache improves the responsiveness of the Timeline and
Browser. There are two settings you can modify:
• Disk: Enter a number in this field to specify the size of the thumbnail disk cache. You
may want to have a large thumbnail disk cache if you’re working with a large number
of clips and want to display thumbnails or if you are using the Browser’s large icon
view.
• RAM: Enter a number in this field to specify the size of the thumbnail RAM cache. You
may want to have a large thumbnail RAM cache if you’re working with a large number
of clips and want to display thumbnails or if you are using the Browser’s large icon
view.
If you often scrub thumbnails in the Browser’s large icon view, you can optimize their
playback quality by increasing the thumbnail RAM cache. To set a location for the
thumbnail cache, see “Connecting DV Video Equipment.”
Note: The thumbnail RAM cache uses part of the RAM available to other parts of
Final Cut Pro, so it shouldn’t be made too large.
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Playback Control Tab
Playback Control settings affect all sequences and projects currently open. These settings
also appear in the RT pop-up menu in the Timeline. Using these settings, you can balance
visual playback quality and maximize the available effects that can be played back in real
time. For more information, see “Using RT Extreme.”

External Editors Tab
Final Cut Pro allows you to directly open clips’ media files in other applications. This tab
allows you to assign media file types, such as still images or audio, to external applications
for editing and processing outside Final Cut Pro.
To open a clip in an external application
1 Do one of the following:
• Select a clip in the Browser or Timeline, then choose View > Clip in Editor.
• Control-click a clip in the Browser or Canvas, then choose Open in Editor from the
shortcut menu.

Final Cut Pro automatically opens the application associated with the type of media file
that you defined in the External Editors tab of the System Settings window.
2 Make the necessary revisions to the file, then save the changes in the external application.
When you return to Final Cut Pro, the clip is automatically reconnected to the updated
media file.
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In some cases, a clip’s Creator property determines what application will open it, such as
Motion clips. However, for generic media types such as audio and video, you can assign
any application you want. For example, you could set Peak DV as your audio file editor
so you could quickly make permanent changes directly to the source audio files on disk
(such as using a noise reduction filter available in that application to clean up a particularly
noisy clip). In this way you could apply effects or special sound-sweetening filters before
continuing work on your edit.
Note: If <None Set> appears next to an entry in the list, that type of clip is opened in the
same application that would open if you double-clicked the corresponding media file in
the Finder. To override the Finder default, you must specify an application to open for
each type of media clip.
To set an external editor
1 Choose Final Cut Pro > System Settings, then click the External Editors tab.
2 Click Set next to the clip type for which you want to assign an external editor.
3 In the Open dialog that appears, navigate to the location of the application you want to
use, then click Open.
The pathname appears next to the file type in the External Editors tab.

The path is shown
for the application
set to open
still-image files.

To clear an external editor
1 Choose Final Cut Pro > System Settings, then click the External Editors tab.
2 Click Clear next to the clip type from which you want to remove an external editor.
The path changes to <None Set>.

Effect Handling Tab
The Effect Handling tab allows you to assign real-time effects processing to a third-party
video effects accelerator card or to Final Cut Pro (native software processing). Each codec
that appears here can be assigned to a different video effects accelerator card or to
Final Cut Pro. For more details, see “Using RT Extreme.”
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Audio/Video Settings and Easy
Setups

112

This chapter covers the following:
• The Audio/Video Settings Window (p. 1837)
• Choosing Easy Setups (p. 1839)
• Changing Audio/Video Presets (p. 1841)
• Creating and Modifying Easy Setups (p. 1846)
• Installing and Restoring Easy Setups (p. 1850)
• Loading Settings from a Network Server (p. 1850)
Audio/Video settings allow you to customize your Final Cut Pro system to work with
particular video formats and equipment. You can also choose Easy Setups to quickly set
up your system with a single click.

The Audio/Video Settings Window
The Audio/Video Settings window establishes the video format you are working with.
You use this window to configure your editing system by choosing a video and audio
format for capturing and editing, remote device control settings, and which video and
audio devices you use for output and external monitoring.

µ

To open the Audio/Video Settings window
Choose Final Cut Pro > Audio/Video Settings.

Learning About Audio/Video Presets
You usually only need to change Audio/Video settings when you install a new video
interface, connect a new VTR, or change the format you are capturing and editing. For
example, if you connect a PAL DV camcorder for capture and output, Final Cut Pro needs
to be set up with the appropriate capture and sequence settings, such as the horizontal
and vertical dimensions of the video frame (720 x 576), the video and audio devices you
are using to capture from, the video codec (DV - PAL), and so on. Because it can be time
consuming to change each individual setting in the Audio/Video Settings window,
Final Cut Pro comes with several kinds of presets that are preconfigured to work with
common video formats and devices.
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There are several kinds of presets, each accessible from the corresponding tab in the
Audio/Video Settings window:
• Capture presets: These determine the dimensions, frame rate, codec, and interfaces
used when capturing media files to disk. This group of settings is used during capture
and usually matches the format of your source tapes. Different capture presets allow
you to quickly set up Final Cut Pro to capture a wide range of video formats. For details,
see “Capture Settings and Presets.”
• Device Control presets: These settings establish how a camcorder, VTR, or other video
or audio device communicates with Final Cut Pro via remote control protocols and
timecode. You choose a device control preset whenever you connect a video or audio
device for logging, capturing, or output. For more information, see “Device Control
Settings and Presets.”
• Sequence presets: These determine the video and audio formats of a sequence, such
as image dimensions, frame rate, codec, color space, sample rate, and bit depth. Unlike
a capture preset, which determines the format of captured (incoming) media files, a
sequence preset determines the format used during editing, which affects real-time
performance and your output format. New sequences automatically use the settings
specified in the currently selected sequence preset, but you can change a sequence’s
settings after it has been created by choosing Sequence > Settings.
Important: When your media files’ settings and sequence settings don’t match, you
usually see a red render bar in the Timeline, indicating that all the media needs to be
converted to the sequence settings before real-time playback or output. In most cases,
you’ll want to use matching capture and sequence presets so Final Cut Pro doesn’t
need to render media files just to play back. For more information, see “Sequence
Settings and Presets.”
• A/V Devices: This tab allows you to choose which video and audio interfaces you use
for external monitoring during editing and for output to tape. These settings determine
if and how you monitor external video and audio. For details, see “External Video
Monitoring.”
Note: Unlike the other tabs, the A/V Devices tab does not have a list of presets to
choose from. However, they are included with every Easy Setup.
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Viewing a Summary of the Current Presets
The Summary tab of the Audio/Video Settings window shows the currently selected
capture, sequence, and device control presets, as well as settings in the A/V Devices tab.

You can check this tab to see how your editing system is currently set up, make quick
changes to your editing system configuration by choosing a different preset, or create
an Easy Setup containing a custom combination of presets. For more information about
Easy Setups, see “Creating and Modifying Easy Setups.”

Choosing Easy Setups
You can quickly set up your editing system to work with different video formats by
choosing an Easy Setup. An Easy Setup contains a capture, sequence, and device control
preset as well as external video and audio settings from the A/V Devices tab. Choosing
an Easy Setup is faster than choosing each preset individually.
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You choose Easy Setups from the Use pop-up menu in the Easy Setup dialog. The list of
options in the Use pop-up menu can be long because of the large number of Easy Setups
included with Final Cut Pro. You can reduce the number of Easy Setups displayed in this
pop-up menu by using the Format and Rate pop-up menus.
Choose a format and a frame
rate to reduce the number of
Easy Setups shown in the Use
pop-up menu.

After you choose a
format or a frame rate,
the list of Easy Setups
in the Use pop-up menu
is shorter.

For example, if you are working with PAL DV video, you can choose DV/Panasonic DVCPRO
from the Format pop-up menu and 25 fps from the Rate pop-up menu. The Easy Setups
that appear in the Use pop-up menu are now limited to the ones that use DV and have
a frame rate of 25 fps. You could also choose PAL from the Format pop-up menu to restrict
the Easy Setups to all PAL-related formats.
To choose an Easy Setup based on format and frame rate
1 Choose Final Cut Pro > Easy Setup.
2 From the Format pop-up menu, choose a format that matches the footage you want to
work with. You can select one of the following:
• A video standard, such as NTSC, PAL, or HD
• A specific codec, such as DV, HDV, IMX, or XDCAM
3 Click the Use pop-up menu to see all of the Easy Setups related to your choice in the
Format pop-up menu.
You can further refine the list by choosing a specific frame rate from the Rate pop-up
menu.
4 Choose the Easy Setup you want, then click Setup.
The corresponding capture, sequence, and device control presets are loaded, as well as
settings in the A/V Devices tab.
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Note: If your VTR is not currently connected, you may see a warning because Final Cut Pro
does not detect the external video or audio device that the A/V device settings expect.
If you see this warning, make sure your device is connected and turned on, then click
Check Again. If you want to troubleshoot the connection to the device later, you can
ignore the warning by clicking Continue.
For more information about Easy Setups, see “Creating and Modifying Easy Setups.”

Changing Audio/Video Presets
You can easily set up your Final Cut Pro editing system by choosing an Easy Setup that
matches your video format and equipment. However, if none of the predefined Easy
Setups matches your capture, editing, or output scenario, you have several options:
• Change individual presets or the external A/V devices settings: You can choose presets
and an external video setting that work for your media and project. The newly selected
presets or external video and audio settings apply to all new projects and sequences.
• Edit an existing preset: Final Cut Pro comes with predefined presets, some of which are
locked and cannot be modified. However, you can create a new preset by duplicating
an existing one and editing it. For more information, see “Creating a New Preset.”
• Create a custom Easy Setup: If you regularly use a specific set of presets and external
A/V device settings that aren’t contained in one of the predefined Easy Setups, you can
create your own Easy Setup. For information, see “Creating and Modifying Easy Setups.”

Choosing Individual Presets
If a preset doesn’t suit your needs, you can choose another one in the Summary tab of
the Audio/Video Settings window. The preset you choose then applies to all new projects
and sequences. For example, if you’re currently using the DV-NTSC Easy Setup, the
following presets are used:
• Sequence Preset: DV NTSC 48 kHz
• Capture Preset: DV NTSC 48 kHz
• Device Control Preset: FireWire NTSC
• Playback Output Video: Apple FireWire NTSC (720 x 480)
• Playback Output Audio: FireWire DV
But suppose you switch to a video deck that doesn’t support remote device control. In
this case, you need to change the device control preset to Non-Controllable Device; the
two other presets and the external video setting remain unchanged.
To choose a different preset for your current setup
1 Choose Final Cut Pro > Audio/Video Settings.
2 In the Summary tab, choose a preset from the appropriate pop-up menu, then click OK.
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If you’re unsure which preset to choose, you can view a preset’s settings. For more
information, see “Viewing Settings in a Preset.”
If none of the existing presets matches your needs, you can create a custom preset. For
more information, see “Creating a New Preset.”
When you choose a different preset, the current Easy Setup changes to Custom Setup in
the Use pop-up menu. However, if you happen to select presets and an external video
setting that match that of another Easy Setup, Final Cut Pro shows that you have that
Easy Setup selected.
Note: The Final Cut Pro preferences file actually stores all presets and Easy Setups currently
selected for use. If your preferences file is deleted, you need to reconfigure your system
by choosing an Easy Setup or a custom combination of presets.

After you change a
preset (or external video
setting), your current
Easy Setup is customized.

Viewing Settings in a Preset
Below each pop-up menu in the Summary tab of the Audio/Video Settings window is a
brief overview of what each preset is used for. If you’re not sure which preset to choose,
you can view detailed information in the individual preset tabs.
To view settings for a preset
1 Choose Final Cut Pro > Audio/Video Settings, then click the appropriate preset tab.
2 Click a preset to see a summary of its settings.
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If you click in the far left column, you may change the current preset.
A checkmark appears next
to the current preset.

Summary of settings for
the highlighted preset

This icon indicates a
preset is locked.

Select the preset whose
settings you want to view.

Note: The presets you see may differ from those shown here.
A lock icon to the right of a preset indicates that it cannot be edited or deleted. These
are presets that came with Final Cut Pro.

Creating a New Preset
If none of the existing presets is exactly what you need or want, you can create a new
one by duplicating an existing preset and modifying the duplicated preset’s settings.
To create a new preset
1 Choose Final Cut Pro > Audio/Video Settings.
2 Click the tab for the type of preset you want to create.

Chapter 112 Audio/Video Settings and Easy Setups

1843

3 Click a preset you want to use as a starting point for creating a new preset, then click
Duplicate.

Click the preset you
want to duplicate so
it’s highlighted.

Then click Duplicate.

4 In the Preset Editor window, enter a name and description for the new preset, select the
settings you need, then click OK.

The information you
enter here becomes
the summary.

The newly created preset becomes the currently selected preset and appears in the
appropriate preset pop-up menu in the Summary tab of the Audio/Video Settings window.

The new preset
appears in the
pop-up menu.

For detailed information about settings and options for a particular kind of preset, see
one of the following:
• “About Sequence Settings and Presets”
• “About Capture Preset Settings”
• “About Device Control Presets”
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Editing a Preset
You can edit any preset that is not locked.
To edit a preset
1 Choose Final Cut Pro > Audio/Video Settings, then click the tab for the type of preset you
want to edit.
2 Click the preset you want to modify, then click Edit.

Click the preset you want
to edit.

Then click Edit.

If the preset is locked, a message appears saying a copy will be made for editing.
3 In the Preset Editor window, modify settings as needed, then click OK.
For detailed information about settings and options for a particular kind of preset, see
one of the following:
• “About Sequence Settings and Presets”
• “About Capture Preset Settings”
• “About Device Control Presets”

Deleting Presets
You may decide to delete a preset that you’ve created. Before you delete it, make sure
you aren’t using it in current projects and won’t need it for future projects.
To delete a preset you’ve created
1 Choose Final Cut Pro > Audio/Video Settings.
2 Click the appropriate preset tab.
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3 Select the preset you want to delete, then click Delete.
Click the appropriate
preset tab.

Click the preset you want
to delete.

Then click Delete.

• If the preset has a checkmark next to it designating it as the current preset: You cannot
delete it. You need to select another preset as the current preset. To do this, click the
left column next to the preset you want to make the current one.
• If a preset has a lock icon in the right column: It is locked and cannot be deleted.

Creating and Modifying Easy Setups
Final Cut Pro comes with Easy Setups for the most commonly used video formats, such
as DV, HDV, DVCPRO HD, and uncompressed 4:2:2 video. If you routinely need a particular
combination of presets, you can create a custom Easy Setup. You can also load additional
Easy Setups that aren’t automatically installed with Final Cut Pro.

Creating an Easy Setup
If you routinely use a particular group of capture, sequence, and device control presets,
you can create and save your own Easy Setup. Whenever you need those settings, you
can choose your custom Easy Setup instead of manually selecting specific settings or
choosing particular presets.
Note: By default, the Easy Setup files you create are stored in the location
/Library/Application Support/Final Cut Pro System Support/Custom Settings/.
The presets stored in the Easy Setups in this folder are displayed as unlocked items in
each preset tab in the Audio/Video Settings window.
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To create a custom Easy Setup
1 Choose Final Cut Pro > Audio/Video Settings.
2 In the Summary tab, choose the presets you want.
For more information, see “Choosing Individual Presets.” If you want to create a custom
preset, see “Creating a New Preset.”
3 Choose video and audio playback settings.
For more information, see “External Video Monitoring.”
4 Click Create Easy Setup.
5 If you want Final Cut Pro to check for device control every time you open the application,
select the checkbox labeled “Enable verification of device control in first start dialog.”
6 Enter a name and description for your new Easy Setup, then click Create.
7 Enter a filename and location if you don’t want to use the defaults.

8 Click Save.
Your new Easy Setup is automatically selected and appears in the Use pop-up menu.

Moving, Deleting, and Restoring an Easy Setup
Easy Setups that come with Final Cut Pro are located within the application itself, as well
as at /Library/Application Support/Final Cut Pro System Support/Custom Settings/.
Easy Setups stored within the application itself are locked, so you cannot modify or delete
them.
Important: If you decide to make an Easy Setup unavailable, make sure you aren’t using
it in any current projects and won’t need it for future projects. Once you remove or delete
an Easy Setup, sequences that use it will not play properly.
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To move an Easy Setup to another Final Cut Pro editing system
Copy the Easy Setup file from its stored location on your hard disk to another disk or
storage medium.

To delete a custom Easy Setup
1 Quit Final Cut Pro.
2 Drag the Final Cut Pro preferences file to the Trash.
This file is in the location /Users/username/Library/Preferences/Final Cut Pro User Data/.
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3 Locate the custom Easy Setup file you want to delete.
Files are located by default at /Library/Application Support/Final Cut Pro System
Support/Custom Settings/.
4 Drag the Easy Setup file to the Trash.
To make an Easy Setup unavailable
1 Quit Final Cut Pro.
2 Drag the Easy Setup file you want to make unavailable out of the following folder:
/Library/Application Support/Final Cut Pro System Support/Custom Settings/.
You can leave this file on your hard disk for future use or you can drag it to the Trash.
3 Drag the Final Cut Pro Preferences file to the Trash.
This file is located at /Users/username/Library/Preferences/Final Cut Pro User Data/.
If you don’t delete this preferences file, the Easy Setup will still appear in the Easy Setup
dialog and the Choose Setup window (for an initial setup).
4 Open Final Cut Pro.
5 Choose your initial setup.
The Easy Setup you made available no longer appears in the list.
For more information, see “Connecting DV Video Equipment.”

Example: Creating a Custom Preset and Easy Setup
The following example shows how to create a custom Easy Setup for capturing DV NTSC
video from a Betacam SP deck using a USB-to-serial adapter for serial device control and
a DV converter box. You can use the existing sequence and capture presets and external
video setting, but you need to create a new device control preset.
To create a custom Easy Setup for capturing DV NTSC video from a Betacam SP deck
1 Choose Final Cut Pro > Audio/Video Settings.
2 In the Summary tab, choose DV NTSC 48kHz from the Sequence Preset pop-up menu.
3 Choose DV NTSC 48kHz from the Capture Preset pop-up menu.
4 Choose Apple FireWire NTSC (720 x 480) from the Video Playback pop-up menu.
5 Click the Device Control Presets tab to create a new preset for serial device control.
a Click Duplicate to create a new preset using the current device control preset.
b In the Device Control Preset Editor, change the name to “Betacam SP Serial Device
Control.”
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c Change the description to “Use this preset when controlling your Betacam SP deck
using RS-422 serial device control.”

d Choose Sony RS-422 from the Protocol pop-up menu.
e In the Audio Mapping pop-up menu, choose the number of audio channels your deck
accepts when recording.
f Choose LTC + VITC from the Time Source pop-up menu.
g Click OK.
Eventually, you’ll need to calibrate the timecode offset for your hardware setup and enter
it in this custom device control preset to ensure frame-accurate video capture. For more
information, see “Calibrating Timecode Capture with Serial Device Control.”
6 Click the Summary tab.
The Device Control Preset pop-up menu is now set to the newly created preset, Betacam
SP Serial Device Control.

7 Click Create Easy Setup.
8 Enter a name and description for your new Easy Setup, then click Create.

9 Enter a filename and location if you don’t want to use the defaults, then click Save.
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Installing and Restoring Easy Setups
Final Cut Pro places several Easy Setup files on your hard disk during installation. If you
move any of these Easy Setups from their original location, you can restore them by
moving them back to the correct folder. If you deleted these Easy Setups, you can reinstall
them by reinstalling the Final Cut Pro software from the Final Cut Pro installation disc.
Some third-party video interfaces may include Easy Setups that support the interface
codecs. If no installer or instructions are included with the interface, you can manually
install the Easy Setups.

µ

To manually install third-party Easy Setups or restore Easy Setups that you’ve moved
Drag the Easy Setup preset files to the following folder:
/Library/Application Support/Final Cut Pro System Support/Custom Settings/
The next time you open Final Cut Pro, the Easy Setups and their presets will be available
in the Audio/Video Settings window and the Easy Setup dialog.

µ

To restore the original Easy Setups that came with Final Cut Pro
Reinstall the Final Cut Pro software from the Final Cut Studio installation disc.

Loading Settings from a Network Server
Each time Final Cut Pro is opened, it checks two local directories for Easy Setups, plug-ins,
window and keyboard layouts, button bars, and so on. The local directories that
Final Cut Pro checks are:
• /Users/username/Library/Preferences/Final Cut Pro User Data/
• /Library/Application Support/Final Cut Pro System Settings/
In addition, Final Cut Pro can also check the directory path /Network/Library/Application
Support/Final Cut Pro/ for additional settings and plug-ins. This directory path is accessible
if:
• Your computer is connected to a server using Mac OS X Server software
• Your system administrator has properly configured the accounts within your local
network so that your computer has access to the directory /Network/Library/Application
Support/Final Cut Pro/.
For more information about setting up accounts within your local network, contact your
system administrator or see the documentation included with the Mac OS X Server
software.
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This chapter covers the following:
• About Capture Preset Settings (p. 1851)
• Creating a Preset to Capture Audio Only (p. 1857)
A capture preset is a group of settings that determine how media is captured from an
external media device (such as a VTR) to a hard disk.

About Capture Preset Settings
Capture settings include frame size, aspect ratio, an anamorphic option, and QuickTime
video and audio settings. Final Cut Pro captures media to QuickTime media files. The
following section describes the settings available in the Capture Preset Editor.
To view or edit a capture preset
1 Choose Final Cut Pro > Audio/Video Settings, then click the Capture Presets tab.
2 Click the preset you want to modify, then click Edit.
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General Settings for Capture Presets
The Capture Preset Editor has the following options.
• Name: The name of the capture preset appears in the Audio/Video Settings window
in two places: the Capture Preset pop-up menu in the Summary tab, and the list of
presets in the Capture Presets tab.
• Description: This is a brief description, or summary, of what the preset is to be used for.
• Frame Size: These are the horizontal and vertical pixel dimensions of the video frame
you are capturing. You can choose a frame size from the Aspect Ratio pop-up menu.
To use a different frame size, choose Custom, then enter a frame size in the Width and
Height fields.
• Anamorphic: Select this option if you’re capturing anamorphic 16:9 media from a 4:3
video format.
• Capture Card Supports Simultaneous Play Through and Capture: Select this option if your
video interface card can display video on an external video monitor while the Log and
Capture window is open for video capture. This allows you to externally monitor your
video while it is being captured, judging its quality after it has gone through the capture
card. For more information, see the documentation that came with your card.
• Remove Advanced Pulldown and/or Duplicate Frames During Capture From FireWire
Sources: Some camcorders, such as the Panasonic DVX100 or Varicam, can record
alternate frame rates within a standard frame rate. For example, the DVX100 can record
23.98 fps video within 29.97 fps by adding an advanced 2:3:3:2 pull-down. The Varicam
can record multiple frame rates, such as 23.98 fps (720p24) by adding redundant frames
within a 59.94 fps (720p60) video signal. When this option is selected, Final Cut Pro
removes the redundant fields or frames during capture. If this option is not selected,
all the redundant frames are captured. You can remove redundant frames later by
choosing Tools > Remove Advanced Pulldown.
For more information about working with multiple frame rate video formats in
Final Cut Pro, see Professional Formats and Workflows, available in Final Cut Pro Help.
• High-Quality Video Play Through: Select this option to display DV-format video at higher
quality in the Log and Capture window.

QuickTime Video Settings for Capture Presets
Final Cut Pro uses the built-in QuickTime architecture of Mac OS X to compress incoming
video during capture.
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Choose from the following options.
• Digitizer: Choose the video interface you want to use for capture. If you’re using FireWire
but don’t have a FireWire device attached, this is set to [Missing] DV Video.
• Input: Choose the video input you want to use on the video interface. Many third-party
interfaces have multiple video inputs, including analog composite, S-Video, component
YUV (also called Y′CBCR), or SDI. FireWire DV video has only one option, so when FireWire
is chosen as the digitizer, the input pop-up menu is disabled.
• Compressor: Choose one of the codecs that comes from the manufacturer of your video
interface. If you’re using FireWire, choose a DV codec that corresponds to the
international standard (NTSC or PAL) or HD standard of your DV tape.
• Quality: Enter a percentage or adjust the slider to set the image quality of the codec
according to the documentation that came with your video interface. Lesser image
quality yields lower data rates, while higher image quality yields higher data rates. (The
quality levels will vary depending on the selected codec.) Many codecs, such as the DV
codecs, are designed to work at the highest quality setting. Unless you have a good
reason, it’s best to leave this slider in its default location.
• FPS (frames per second): Choose a value to specify the number of frames captured per
second. For a list of common frame rates, see “Video Formats.”
Note: The capture preset frame rate should match both the frame rate of your source
tapes and the editing timebase you plan to use in your edited sequences. One exception
to this rule is when capturing 25 fps video for use in a 24 fps sequence. This is a common
film workflow used in Europe. For more information, see the documentation that came
with Cinema Tools.
• Limit Data Rate: If you’re using an analog-to-digital video interface to capture, click to
select this option, then enter a numerical value in the field to define the data rate for
captured clips in kilobytes (KB) per second. You may want to look at capture presets
included with your video interface to get an idea of how this value is set.
The maximum data rate depends on the maximum throughput of your video interface
as well as the maximum sustained transfer speed of your hard disk. For more information,
see the documentation that came with your video interface or hard disk.
Note: DV has a fixed data rate and is captured digitally via FireWire, so the High Quality
option doesn’t apply to DV clips.
The data rate you specify determines the quality of your video. Here are several sample
data rates.
• Offline M-JPEG: 1 MB/sec.
• DV-format video: 3.6 MB/sec.
• Medium quality M-JPEG: 6 MB/sec.
• High quality 2:1 M-JPEG: 12 MB/sec.
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• Advanced: Click this button to set additional QuickTime video settings, if necessary for
your video hardware. For detailed information, see “Advanced QuickTime Video Settings
for Capture Presets.”

Advanced QuickTime Video Settings for Capture Presets
The QuickTime Video Settings in the Capture Preset Editor and Sequence Preset Editor
are a subset of all the possible QuickTime Video settings. In most cases, these settings
should be sufficient. However, some video interfaces and codecs have specific video
settings not shown in one of the Preset Editor windows. Clicking on the Advanced button
gives you complete access to all QuickTime video options for Source (input) and
Compression settings.
Note: Some of these settings, such as codec and quality, are identical to the settings
found in the Capture and Sequence Preset Editor windows. For example, if you choose
DV/DVCPRO - NTSC from the Compressor pop-up menu, the same codec is chosen when
you click the Advanced tab.
Compression Tab
The settings available in the Compression tab depend on the codec chosen from the
Compressor pop-up menu. There may be additional settings available for specific codecs.
Specify the settings
you want.

Click Compression.

Motion Settings
• Compression type: This pop-up menu has the same codec choices as the Compressor
pop-up menu in the QuickTime Video Settings section of the Preset Editor window.
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• Frames per second: Choose a value to specify the number of frames captured per second.
This value is the same as the FPS field in the QuickTime Video Settings section of the
Preset Editor window.
• Key frame every N frames: Even though QuickTime supports temporal compression
using keyframes and in-between frames, you should not select this option when
capturing.
• Limit data rate to N KBytes/sec.: Some codecs allow you to enter a target data rate for
your compressed QuickTime file. The codec may use a combination of spatial (per
frame) and temporal (across multiple frames) compression to try to reach your target
data rate. Be aware of your frame size and frame rate so you don’t set an impossible
goal and get disappointing quality in the visual image. This is identical to the Limit
Data Rate field in the QuickTime Video Settings section of the Preset Editor window.
Compressor Settings
• Depth: This option is not available for all codecs. Choose a color bit depth for your
video. Third-party codecs may have several options. For more information, see the
documentation that came with your video interface.
Note: The alpha channel in codecs such as Animation and Apple ProRes 4444 is optional.
If you modify the sequence settings to use one of these codecs, the alpha channel may
not be automatically enabled. For more information, see “Confirming Alpha Channel
Status.”
• Quality: This is identical to the quality slider in the QuickTime Video Settings section
of the Preset Editor window. Adjust the slider to determine the image quality for your
video. Lesser image quality yields lower data rates, while higher image quality yields
higher data rates.
Note: For DV, make sure this slider is set to Best.
• Options: This button is not available for all codecs. When available, you can click this
button to make further codec adjustments.
Source Tab
The settings available in the Source tab depend on the video interface connected to your
computer. You can choose from a list of available inputs on video interfaces connected
to your computer.

Chapter 113 Capture Settings and Presets

1855

QuickTime Audio Settings for Capture Presets
Final Cut Pro uses the built-in QuickTime architecture of Mac OS X to capture incoming
audio.

• Device: Choose the audio interface you want to use during capture. Audio interface
choices may include:
• None (If you choose None, the Input and Format pop-up menus are not available. If
you’re using FireWire but don’t have a FireWire device attached, this option is set to
“[Missing] DV Audio”.)
• Built-in Audio (the stereo mini or S/PDIF optical connector)
• DV Audio (via FireWire)
• Audio inputs on a video interface (if you have one installed)
• An audio interface (USB, FireWire, or PCI, if you have a PCI card installed)
• Input: Choose a hardware input from the currently selected audio device.
Note: For example, if you selected Built-in Audio, you can choose Microphone or Line
In. (On some computers, the S/PDIF optical connector is also an option.)
• Format: Choose an audio configuration from the list. Audio configurations in this list
are a combination of sample rate, bit depth, and number of channels. The items in this
pop-up menu depend on the audio device you select.
• Rate: Choose a standard audio sample rate that matches the sample rate of your
source tapes.
• Bit depth: Choose an audio bit depth that corresponds to your source tapes. In most
cases, this should be a minimum of 16 bits.
• Number of channels: Choose a configuration that has enough channels to support
the number of channels you want to capture. For example, the Built-in Audio interface
typically only supports two channels with a sample rate of 44.1 kHz and a bit depth
of 16. However, a PCI or FireWire interface may support several configurations, such
as 22 channels at 48 kHz/16 bit, or 11 channels at 96 kHz/24 bit, and so on. If the
sample rate of the audio on your tape does not match your capture preset,
Final Cut Pro performs a high-quality, real-time sample rate conversion. However,
you should avoid mismatching your tape and capture preset sample rate whenever
possible.
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About Capturing Multiple Audio Channels from DV Devices
DV video devices can record up to four tracks of audio, depending on the sample rate
and bit depth chosen on the camcorder. You can choose which two audio channels to
capture from the Input pop-up menu. For more information, see “Capturing Audio from
Tape.”

Finding the Maximum Data Rate When Using the Limit Data Rate Field
If you’re not sure of the maximum data rate possible for your hard disk and video interface,
try the following:
To capture your clip at increasing data rates until you reach the maximum data rate
1 Capture a video clip from tape with a data rate of 3 MB/sec.
2 If no dropped frames are reported, increase the data rate to 4 MB/sec., then recapture
the clip.
3 If still no dropped frames are reported, recapture the same clip, raising the data rate by
1 MB/sec. each time, until the clip you capture reports dropped frames.
When a message appears saying frames were dropped, you’ve reached the maximum
data rate for your equipment.

Creating a Preset to Capture Audio Only
You can configure Final Cut Pro to capture audio from a device-controllable audio player
(such as a DAT player) with timecode. This is mainly useful when capturing audio that
was acquired via dual system recording, with picture and sound recorded simultaneously
to two different devices. You may also need an audio-only capture preset for bringing in
audio that you want to use for narration, sound effects, or ambient tracks.
Note: For more information on connecting a device-controllable audio deck to your
computer, see “Connecting Professional Video and Audio Equipment.”
To create a device-controllable, audio-only capture preset
1 Choose Final Cut Pro > Audio/Video Settings, then click the Capture Presets tab.
2 Select a preset, then click Duplicate.
Final Cut Pro automatically duplicates the selected preset and opens a new Capture Preset
Editor window.
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3 In the Capture Preset Editor, adjust the following settings, then click OK.
Enter a name and
appropriate description
for your audio
capture preset.

Choose None, unless
you are genlocking
your audio to your
video interface.
Choose an audio device
from this pop-up menu.
Choose an audio
configuration from
this pop-up menu.

Choose an input
from the selected
audio device.

a If you’re synchronizing your audio deck to your computer by genlocking it to a video
capture interface, choose your video capture interface from the Digitizer pop-up menu
in the QuickTime Video Settings section. Otherwise, you can choose None.
b In the QuickTime Audio Settings section, choose an audio interface from the Device
pop-up menu. The audio capture interface can be identical to your video capture
interface, or you can use a different device.
c Choose the input on the audio interface you used to connect your audio deck from
the Input pop-up menu. (Some video and audio capture interfaces have more than
one set of audio inputs to choose from.)
d Choose an audio configuration (sample rate, bit depth, and number of channels) from
the Format pop-up menu.
If you are doing a digital transfer from your audio device to your computer, you should
choose the sample rate of your audio source. If you are digitizing audio from analog
inputs on your audio interface, choose a sample rate that matches the majority of the
media files in your project, or the sample rate of your sequence.
For detailed information about other settings in the Capture Preset Editor, see “About
Capture Preset Settings.”
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Device Control Settings and
Presets

114

This chapter covers the following:
• About Device Control Presets (p. 1859)
• Device Control Protocols Supported by Final Cut Pro (p. 1863)
• Using FireWire Device Control (p. 1864)
• Using Serial Device Control (p. 1865)
• Using a Non-Controllable Device (p. 1868)
• Troubleshooting Your Device Control Setup (p. 1868)
A device control preset communicates transport commands and timecode between
Final Cut Pro and supported camcorders and VTRs.

About Device Control Presets
A device control preset is a group of settings (protocol, connection port, frame rate and
timecode information) that define how Final Cut Pro controls a device such as a camcorder,
VTR, or audio player. Remote control communication between Final Cut Pro and your
video deck allows you to log tapes, automatically batch capture multiple clips, and output
video to specific portions of a tape. The remote device control connection is also the
interface for sending and receiving timecode information between a computer and a
video device.
In most cases, creating your own device control preset isn’t necessary. You can usually
choose a device control preset whose name matches your equipment. However, if you
want precise control over each detail of how your device and Final Cut Pro communicate,
you can adjust each device control setting and create your own custom presets.

Viewing Settings for a Device Control Preset
Settings in a device control preset are used during logging, capturing, and output to
tape.
To view or edit a device control preset
1 Choose Final Cut Pro > Audio/Video Settings, then click the Device Control Presets tab.
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2 Click the preset you want to modify, then click Edit.

Settings in the Device Control Preset Editor
The following section describes the settings in the Device Control Preset Editor.
• Name: Enter a name for the preset. This name will appear in the list of available device
control presets, available in several places in the application, such as the Log and
Capture window and whenever you create an Easy Setup.
• Description: Enter a brief description, or summary, of what the preset is to be used for.
Use this as a convenient reminder of which decks you use the preset for. This can be
particularly helpful if you are setting up a system for multiple editors and assistant
editors.
• Protocol: Choose the protocol your camcorder or deck uses. You can choose from the
most commonly implemented remote control protocols in the video industry. The two
most common are FireWire (for DV devices) and RS-422 (for almost all other professional
equipment). RS-422 uses a serial data connection.
• If you’re using FireWire: Choose Apple FireWire or Apple FireWire Basic, depending
on your connected device. The Basic version is a simplified device control protocol
for camcorders and decks that aren’t fully compatible with Apple FireWire. Choosing
the Basic protocol will not affect the video or audio quality of your captured media.
• If you’re using serial device control: Choose an option based on the equipment you’re
using. To find out which device control protocols are supported, see the
documentation that came with the equipment. For more information on serial device
control, see “Using Serial Device Control.”
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• Audio Mapping: This pop-up menu determines how many audio tracks are available in
the Audio Insert pop-up menu in the Edit to Tape window. You should choose a track
mapping that corresponds to the number of tracks available on your audio or video
deck. The options available depend on the device control protocol you’ve selected.
• If you’re using FireWire: When you’re using one of the FireWire device control presets,
the Audio Mapping pop-up menu is not available. All DV devices support two audio
tracks at 16-bit resolution, and many support up to four tracks at 12-bit resolution.
• If you’re using RS-422: Many third-party video or audio recording devices are capable
of insert editing more than two tracks of audio when using RS-422 device control.
The Audio Mapping pop-up menu does not automatically detect the number of
audio tracks your video or audio recording device is capable of recording to, so you
need to manually choose an audio mapping for your deck. Check the documentation
that came with your video or audio recording device for information on the number
of audio inputs it supports. For more information about when to use audio mapping,
see “Using Edit to Tape to Output Multichannel Audio.”
• Time Source: Some tape formats can have more than one kind of timecode track. You
can choose which track you want Final Cut Pro to read timecode from, and in the case
of LTC and VITC, you can let Final Cut Pro read either one depending on what’s available.
• LTC: Because LTC is audio, it can be interpreted by a timecode reader even when
the tape is fast-forwarding, but it can’t be read when the tape is paused or moving
extremely slowly.
• VITC: VITC can be read at very slow speeds, but it breaks up when fast-forwarding
or rewinding.
• LTC+VITC: This setting is best if your tape has both VITC and LTC. If you choose this
setting, Final Cut Pro looks at both timecodes so that accurate timecode can be read
no matter what speed the tape is playing (LTC is used for normal and high-speed
playback; VITC is used for slow motion and pause).
• Timer: A clock-based counter. This option is useful for decks that support device
control but not timecode, such as some VHS decks.
• DV Time: Choose this when capturing or outputting to a DV device.
• Port: Choose the port to which your device control cable is connected. If you’re using
DV timecode, this option is not available, because FireWire is used automatically. If
you’re using serial device control rather than DV device control, choose the port that
you have connected to your serial device control. This may be your built-in modem
port, or a USB-to-serial adapter connected to a USB port.
• Frame Rate: Choose the timecode frame rate of the video you’ll be capturing, such as
29.97 fps for NTSC, 25 fps for PAL, 59.94 fps for DVCPRO HD 720p, and so on.

Chapter 114 Device Control Settings and Presets

1861

• Default Timecode: This option affects the timecode mode (drop frame or non-drop
frame) of fields in the Log and Capture window when no device is connected, or before
a tape begins playing. Once a tape is playing, Final Cut Pro determines the timecode
mode from the tape, not this pop-up menu.
The timecode mode chosen here is useful when you log clips without a tape in your
VTR. Before you press play on the deck, Final Cut Pro doesn’t know what the timecode
mode is on the tape, so it uses the default timecode.
When no device is connected, you can change the timecode mode of the In and Out
point and Timecode Duration fields by Control-clicking these fields in the Log and
Capture window and choosing a default timecode mode.
• Use Deck Search Mechanism: Select this option to use a deck’s internal search mechanism
to cue a tape to a specific timecode value, if available. Decks with serial device control
may have this option. Do not select this option if your deck has problems moving the
playhead to a specified timecode value during capture. For more information, see the
documentation that came with your video equipment. This option is not available for
DV devices.

• Capture Offset: Because timecode and video are often captured by Final Cut Pro via
two separate channels (device control connection and video input, respectively), there
may be a small, but consistent, offset between when a video frame and a timecode
number are captured to a media file. You must calibrate your timecode by determining
its frame offset from the video and entering it in this field. For more information, see
“Determining and Entering the Timecode Offset.”
Note: This is not an issue when you capture DV video via FireWire, since both timecode
and video data are transferred via the same FireWire cable.
• Handle Size: This setting only has an affect when you batch capture clips. The value in
this field tells Final Cut Pro to automatically capture additional footage, or handles, at
the head and tail of each batch-captured clip. For more information about batch
capturing, see “Capturing Video from Tape.”
• Playback Offset: This option allows you to compensate for latency between Final Cut Pro
device control (the number in the Current Timecode field) and your video interface
output, since some video interfaces take some time to process the video signal. This
is only an issue when using separate connections for device control and video output,
such as serial RS-422 device control and a PCI video card.
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Enter a number to compensate for delays between the start of playback and the start
of recording on your deck when editing to tape. This is normally set to 0. Enter a positive
number to start playback before recording begins; enter a negative number to start
playback after recording begins.
Note: If the first frame is duplicated over several frames when you’re editing to tape,
enter the number of duplicated frames in this field to eliminate the problem.
• Pre-roll and Post-roll: Because VTRs and audio players are mechanical devices, it takes
a few seconds for the device’s motor to stabilize and reach a steady speed after starting
from a stopped or paused position. The pre-roll time sets how far in advance your
camcorder or deck starts playing back your source tape before capture or output. In
most cases, the 3 second default is sufficient. Both pre- and post-roll values are used
when you click the Play Around Current Frame button in the Log and Capture window,
and when you preview an insert edit in the Edit to Tape window before committing
the edit to tape.
• Auto Record and PTV after: Check this box to have Final Cut Pro automatically put your
DV camcorder or deck in Record mode when using the Print to Video command. Specify
the number of seconds you want Final Cut Pro to wait before going into Record mode
and printing to video (after you click OK in the Print to Video dialog). If this option is
not selected, when you print to tape, you’re prompted to insert a tape and manually
press record on the VTR. This checkbox is also available in the Print to Video dialog.

Device Control Protocols Supported by Final Cut Pro
A device control protocol defines the rules and syntax for how two devices communicate
with each other. The two connected devices must negotiate and agree upon the speed
of communication (often measured in bits per second or bauds, much like a modem), the
length of each binary word, and how different commands—such as play, rewind, and
fast-forward—are coded. Once the two devices have successfully established
communication via a remote control protocol, navigational commands, timecode, and
so on can be transferred between the device and Final Cut Pro.
To establish remote device control between a VTR or camcorder and a computer, you
need to connect a remote control cable between the device and your computer. You
also need to tell Final Cut Pro what communication protocol your device understands.
The most common methods of device control and timecode capture are:
• FireWire with DV timecode
• Serial RS-232 or RS-422 with SMPTE timecode
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The following is a list of the device control protocols you can use in Final Cut Pro. Not all
protocols are compatible with all features. See the documentation that came with your
camcorder or deck for more information on the device control specification it uses, or
visit the Final Cut Pro website at http://www.apple.com/finalcutstudio/finalcutpro.
• Apple FireWire or Apple FireWire Basic
• DVCPRO HD FireWire
• HDV 1080i50 FireWire
• HDV FireWire NTSC
• Sony RS-422
• Sony RS-232: (SVO-2100) 9.6K; (SVO-2100) 19.2K; (UVW-1400) 9.6K; (UVW-1400) 19.2K
• Sony VISCA
• Sony LANC (via Addenda RS-4/L)
• Panasonic RS-232 and RS-422
• JVC RS-232
Note: RS-422 uses serial cables that are different from RS-232 cables. For more information
on cables and their availability, see the information that came with your device. You can
buy these cables at specialty video equipment or electronics retailers.

Using FireWire Device Control
FireWire (also called IEEE 1394 or i.LINK) is a standard supported by many professional
and consumer-level camcorders and decks. FireWire transmits device control data,
timecode, video, and audio signals over a single cable. Using FireWire, you can capture
video directly from DV camcorders with a built-in FireWire port and from older analog-only
equipment using a DV converter.
Final Cut Pro also outputs video, audio, and timecode to your camcorder or deck through
the FireWire connection so you can record sequences to tape. All DV-format tapes record
DV timecode. Final Cut Pro uses this timecode when capturing footage from tape.
Video devices vary greatly in their adherence to FireWire specifications for device control.
For this reason, there are several versions of the FireWire protocol you can use for device
control and capture in Final Cut Pro:
• FireWire: This is the default.
• FireWire Basic: This is a simplified device control protocol for camcorders and decks
that aren’t compatible with the complete Apple FireWire protocol. Using this protocol
doesn’t affect the quality of captured video or audio.
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For more information about changing the FireWire protocol that Final Cut Pro uses, see
“Editing a Preset” and “About Device Control Presets.”
After you connect a camcorder or deck to your computer, switch it to VCR mode. You
can record to a camcorder from Final Cut Pro in Camera mode, but to do so, you need to
turn off device control in Final Cut Pro, which limits your control during output.

Using Serial Device Control
Nearly all professional VTRs support serial device control. Serial device control sends and
receives timecode and transport control data. A 9-pin serial connector is usually used for
serial device control. Each pin can carry a separate signal, although typically only four
pins are used (two for transmitting data, and two for receiving data).

RS-422 connector

Professional video and audio decks may use one of two serial interfaces.
• RS-232: Found on older, more inexpensive equipment. RS-232 is functionally similar
to RS-422, but it’s not used as frequently.
• RS-422: This interface tolerates greater cable lengths than RS-232. It’s more widely
used by facilities where video decks are in a room different from the editing bay.

Timecode Transferred via Serial Device Control
Final Cut Pro can use two kinds of timecode sent over a remote serial connection.
• LTC: LTC (longitudinal timecode) is recorded as an audio signal on a dedicated timecode
track.
• VITC: VITC (vertical interval timecode) is recorded as part of the video signal, using
several video lines that are normally masked by consumer televisions. Lines 16 and 18
of the vertical blanking portion of the video signal are commonly used.
Final Cut Pro can also automatically switch between LTC and VITC if they are both available:
• LTC+VITC: If you choose this setting, Final Cut Pro looks at both timecodes so that
accurate timecode can be read no matter what speed the tape is playing (LTC is used
for normal and high-speed playback; VITC is used for slow motion and pause).
For more information about LTC and VITC timecode, see “Timecode on Tape.”
To take advantage of the Edit to Tape feature (described in “Assemble and Insert Editing
Using Edit to Tape”), your video device must support insert editing. These VTRs can use
timecode In and Out points, along with defined video and audio tracks, and perform a
frame-accurate edit.
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Calibrating Timecode Capture with Serial Device Control
Unless you are capturing a DV video format via FireWire, the timecode and video signals
are sent separately from the video deck to the computer. Because the signals are separate,
they can possibly arrive at different times, which causes the wrong timecode number to
be recorded with captured video frames. You can calibrate your timecode and video
capture setup by entering the number of frames by which the timecode signals are offset
from the video into the Capture Offset field.
Note: Remember that timecode is captured via the device control connection (the RS-422
connection in most cases), and video is captured via your video capture interface. In the
case of DV formats, FireWire is conveniently used for both.
You need to calibrate the video and timecode signal every time you change decks or
cables. If you regularly switch decks, it’s a good idea to create different device control
presets, with different Capture Offset settings, for each deck you use. Because each deck
will always have the same capture offset, a set of precalibrated presets lets you quickly
change decks without having to go through the whole recalibration procedure again.
For more information on setting up your hardware for device control, see “Connecting
Professional Video and Audio Equipment.” For more information on setting up device
control presets, see “About Device Control Presets.”

Determining and Entering the Timecode Offset
You can easily determine if there is a difference between the timecode and video signals
by capturing test footage that has timecode “burned in” to the video picture information.
By comparing the numbers in the timecode track to the timecode numbers in the video
picture, you can determine the offset between them.
If there is an offset, you can calibrate your timecode and video capture setup by entering
the number of frames by which the timecode signals are offset from the video in the
Capture Offset field of the current device control preset.
To determine the timecode offset
1 Do one of the following:
• Create a window-burn (or window dub) test tape for timecode offset testing. You can
do this by transferring a tape with timecode to another tape of the same format, making
sure you connect an output that can display timecode information visually.
• Connect the monitor out (or super out) output of your VTR to the input of your video
interface. A monitor output is a dedicated output for displaying VTR status information
such as a timecode counter superimposed (or “burned-in”) over the video information.
Some VTRs don’t have a separate monitor output, but instead have an option for turning
on the deck status display and timecode information on the main output. Turn on this
option.
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2 Capture a clip of video from a tape with LTC (Longitudinal TimeCode) or VITC (Vertical
Interval TimeCode) timecode on it.
For more information, see “Capturing Video from Tape.”
3 Compare the timecode value recorded in the captured media file (in the Current Timecode
field) with the burned-in timecode on the video frame.
Current Timecode field

Burned-in timecode

If both timecode values match, then there is no offset, so no adjustment is necessary. If
the timecode values do not match, there’s an offset and you’ll need to compensate for
this to capture your video properly.
To enter a timecode offset
1 Choose Final Cut Pro > Audio/Video Settings, then click the Device Control Presets tab.
2 Make sure your current method of device control is checked, then click Edit.
If you’re using a locked preset, a new copy of the preset is created.
3 Enter a new name and description for this device control preset indicating which
camcorder or deck it is calibrated for.

Enter an appropriate
name and description
for your new preset.

Enter the capture offset
here; add a hyphen for
a negative offset.

4 Enter a number of frames in the Capture Offset field, then click OK.
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Enter a negative number if the clip’s timecode track has higher numbers than the
burned-in timecode. For example, if the clip’s Media Start timecode is 01:00:00:04, and
the first video frame has a burned-in timecode number of 01:00:00:00, enter –4 in the
Capture Offset field.
After entering the timecode offset, it’s a good idea to capture a few more clips and
compare the timecode track numbers with the burned-in timecode to determine if the
timecode offset you entered is correct.
Important: Some devices may require fractional offsets to maintain accuracy when batch
capturing over a long duration. For example, suppose that capturing a single clip using
a 2-frame offset results in an accurately captured clip, but when you batch capture ten
clips, some clips are not accurately captured. In this case, try adjusting the offset by a
fractional value (for example, 2.5 instead of 2).

Using a Non-Controllable Device
If you have a camcorder or deck without device control, you can still capture and edit
clips in Final Cut Pro. You need to start and stop your camcorder or deck manually when
you use the Log and Capture and Print to Video commands.
Once you capture a clip manually, you have virtually no chance of recapturing exactly
the same media with the same In and Out points. If you think you may need to reedit a
project that includes manually captured media files, back up the media files along with
your project file.

Troubleshooting Your Device Control Setup
Before you start the logging and capture process, make sure that your device control
hardware is properly set up.
To verify device control is properly set up
1 Do one of the following.
• If you’re using DV device control: Make sure your FireWire cables are properly connected.
• If you’re using serial device control: If Final Cut Pro is unable to communicate with your
camcorder or deck, make sure you have the correct cable for the type of device control
you’re using—RS-232 or RS-422. Also make sure that your serial port adapter
(USB-to-serial adapter or internal modem port-to-serial port adapter) is properly
connected and you installed the proper software drivers. For more information on
setting up device control hardware, see “Connecting Professional Video and Audio
Equipment.”
2 Choose a device control preset in the Audio/Video Settings window that matches your
setup.
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For more information, see “Using Serial Device Control” and “Choosing Individual Presets.”
Important: If you’re capturing your video and audio using FireWire, you should also
capture timecode via FireWire (in other words, via DV device control). FireWire is the most
convenient and accurate way for capturing timecode from a DV device.
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Sequence Settings and Presets

115

This chapter covers the following:
• What Are Sequence Settings? (p. 1871)
• About Sequence Settings and Presets (p. 1871)
• Timeline Display, Render, and Audio Output Options (p. 1877)
• Changing Sequence Settings (p. 1881)
Settings for sequences are found in several windows throughout Final Cut Pro. These
settings are used when new sequences are created.

What Are Sequence Settings?
A sequence preset is a group of settings that is used when you create a new sequence.
These settings include frame size, pixel aspect ratio, a 16:9 anamorphic option, editing
timebase (frame rate), and QuickTime video and audio settings (such as codec, audio
sample rate, and so on).
When you create a sequence, its settings are initially determined by:
• The currently selected sequence preset in the Audio/Video Settings window
• The Timeline Options, Render Control, and Audio Outputs tabs of the User Preferences
window.
After you create a sequence, you can adjust its individual settings by selecting the
sequence and choosing Sequence > Settings.
Note: The one setting that may not be changed is the sequence frame rate (referred to
as the editing timebase). You can change a sequence’s frame rate (editing timebase) only
if the sequence is empty.

About Sequence Settings and Presets
A sequence preset has two tabs: the General and Video Processing tabs.
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Note: Default Timeline, render control, and audio outputs options are available in the
User Preferences window, or after a sequence has been created by choosing Sequence
> Settings.
To view or edit a sequence preset
1 Choose Final Cut Pro > Audio/Video Settings, then click the Sequence Presets tab.
2 Click the preset you want to modify, then click Edit.

Settings in the
General tab
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General Tab for Sequences
The following is a list of General tab settings.

Settings in the
General tab

• Name: Enter a name for the preset. This name appears in the Audio/Video Settings
window in two places: the Sequence Preset pop-up menu in the Summary tab, and
the list of presets in the Sequence Presets tab.
• Description: Enter a brief description, or summary, of what the preset is to be used for.
• Frame Size: Choose the horizontal and vertical image dimensions from the Aspect Ratio
pop-up menu. To use a different frame size, choose Custom, then enter a nonconstrained
frame size in the Width and Height fields.
Note: Even if you’ll be outputting at a smaller frame size for multimedia use, it’s best
to edit your video at its full size and then scale it down later.
• Pixel Aspect Ratio: Choose a pixel aspect ratio that matches the format you are working
with. The pixel aspect ratio determines the shape of each pixel, which affects the overall
dimensions and aspect ratio of your video image.
• Square: For multimedia and uncompressed high definition video.
• NTSC - CCIR 601 / DV: For standard definition NTSC formats such as Digital Betacam,
DV, or DVD.
• PAL - CCIR 601: For standard definition PAL formats.
• HD (960x720): For 720p HD video, such as DVCPRO HD and HDV.
• HD (1280x1080): For 1080i60 HD video, such as DVCPRO HD and HDV.
• HD (1440x1080): For 1080i50 HD video, such as DVCPRO HD and HDV.
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• Anamorphic 16:9: Select this checkbox only if you’re editing standard definition
anamorphic 16:9 media. This setting only affects the way video is displayed on your
monitor and does not actually rescale your media. For more information on anamorphic
16:9 video, see “Working with Anamorphic 16:9 Media.”
• Field Dominance: Choose the field dominance of your captured video. Most video is
Upper (Odd) or Lower (Even) depending on the video capture interface you’re using.
For progressive (non-interlaced) video, set the field dominance to None. For DV NTSC
and DV PAL, always set this to Lower (Even). For more information, see “About Field
Dominance.”
• Editing Timebase (frame rate): Choose the frame rate of your sequence. For a list of
common frame rates, see “Choosing a Frame Rate.”
Important: A sequence’s timebase can be changed only if no clips have been edited
into it. If there are clips in the sequence, they must be removed before you can change
the timebase.
• Timecode Rate: This pop-up menu is available in the Sequence Preset Editor window,
but not when you choose Sequence > Settings for an existing sequence. Use this pop-up
menu to choose the timecode rate of your sequence. For most sequences, the timecode
rate should match—or be directly related to—the sequence’s editing timebase (frame
rate). For example, a 23.98 fps sequence would normally use 24 fps timecode. Unless
you have a specific reason, choose Same as Editing Timebase.
If you need to change the timecode rate of an existing sequence, select the sequence
and choose Modify > Timecode, then adjust the rate and format of your sequence’s
timecode. One of the main reasons for doing this is when editing a 24 fps sequence
while using 25 fps timecode.
Note: Some timecode rates are not available with some editing timebases.
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QuickTime Video Settings for Sequences
Final Cut Pro uses the built-in QuickTime architecture of Mac OS X to decompress, render,
and output video from your sequence. Since capturing is also handled by QuickTime,
QuickTime video settings are explained in more detail in “QuickTime Video Settings for
Capture Presets.”

Settings in the
General tab

• Compressor: Choose a codec that matches the format of your media files. Any media
file in your sequence that doesn’t use the codec specified here must be rendered.
• Quality: Enter a percentage or adjust the slider to set the image quality of the codec.
Some third-party video interfaces may recommend specific quality settings.
• Advanced: Click this button to set additional QuickTime video settings. For detailed
information, see “Advanced QuickTime Video Settings for Capture Presets.”
Note: The alpha channel in codecs such as Animation and Apple ProRes 4444 is optional.
If you modify the sequence settings to use one of these codecs, the alpha channel may
not be automatically enabled. For more information, see “Confirming Alpha Channel
Status.”
Confirming Alpha Channel Status
If your workflow involves adding or removing an alpha channel, be sure to double-check
the Depth setting for the alpha channel status.
To confirm the alpha channel status in sequence settings
1 Choose Sequence > Settings, then click the General tab.
2 In the Compressor pop-up menu, choose the alpha channel–compatible codec (Animation
or Apple ProRes 4444).
3 Click Advanced to open the Compression Settings dialog.
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4 In the Depth pop-up menu, choose one of the following.
• Millions of Colors: Choose this option if your footage does not have an alpha channel
or you wish to discard it.
• Millions of Colors+: Choose this option if your footage contains an alpha channel and
you wish to preserve it.

QuickTime Audio Settings for Sequences
Final Cut Pro uses the built-in QuickTime architecture of Mac OS X for playback and export
of your sequence audio. When you export your sequence, these audio settings are used
by default.

Settings in the
General tab

• Sample Rate: Lower sample rates take less bandwidth but have lower quality. Make
sure your sample rate is compatible with the audio facility to which you’ll be handing
off the files. Usually, you use the sample rate specified in your sequence settings, which
should ideally be the sample rate of the original audio media files.
• 32 kHz: This corresponds to a consumer sample rate option on DV camcorders. Unless
you have a special reason to use it, avoid this sample rate for audio export.
• 44.1 kHz: This is the sample rate of music CDs and some DAT tapes.
• 48 kHz: DV formats and many professional video formats use this sample rate.
• 88.2 kHz: This is a high-resolution sample rate that can be easily converted to 44.1 kHz
audio files.
• 96 kHz: This is a high-resolution sample rate that can be easily converted to 48 kHz.
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• Depth: Choose the bit depth used for each sample.
• 8-bit: This bit depth is useful for highly compressed movies created for the web.
Unless you have a specific need for 8-bit audio, you should avoid this option because
the quality is fairly low.
• 16-bit: This is the bit depth of DV, DVCAM, and DVCPRO, as well as of music CDs. If
all of your original audio media is 16-bit, and you aren’t routing multiple audio tracks
to the same audio output, choose this option.
• 24-bit: A high-resolution bit depth compatible with many third-party video and audio
interfaces. Choose this option to preserve the highest possible quality when exporting
your files, especially when some of your audio files are 24-bit, or when you are mixing
multiple audio channels together by routing them to the same output channel.
• Config: This pop-up menu works in combination with the Downmix control in the
Audio Mixer to determine how the Export QuickTime Movie command groups your
sequence audio outputs during export. There are three options:
• Stereo Downmix: This option exports a stereo mix to a single stereo QuickTime audio
track and overrides the Downmix button in the Audio Mixer.
• Channel Grouped: Based on your sequence’s audio output groupings, multiple stereo
and mono output busses are exported to corresponding stereo and mono QuickTime
tracks.
• Discrete Channels: This option exports channels in the same way as the Channel
Grouped option, but each channel in the QuickTime movie audio track is labeled as
a discrete channel, numbered according to the audio output bus that the channel
is assigned in your sequence. Use this option when you want to preserve your
sequence’s original audio output assignments in your exported QuickTime file.

Video Processing Tab for Sequences
You can change color space and motion transformation rendering options in the Video
Processing tab of the Sequence Settings window. For new sequences, you can change
default settings in the Video Processing tab of the appropriate sequence preset. For
detailed information about the settings in the Video Processing tab, see “Rendering and
Video Processing Settings.”

Timeline Display, Render, and Audio Output Options
When you create a new sequence, the Timeline display, render, and audio output settings
that are used come from the corresponding tabs in the User Preferences window. Once
a sequence is created, you can change its options by selecting the sequence and choosing
Sequence > Settings.
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Timeline Options Tab
New sequences are created using the settings in the Timeline Options tab of the User
Preferences window. Once a sequence is created, you can change Timeline display options
in several places. For more information about Timeline display settings, see “Timeline
Basics.”

Render Control Tab
New sequences are created with the settings in the Render Control tab of the User
Preferences window. Once a sequence is created, you can change render control options
by selecting the sequence and then choosing Sequence > Settings.
These settings allow you to turn on and turn off different processor-intensive effects in
Final Cut Pro, such as filters and motion blending. This is useful if you want to speed up
processing by not rendering all effects during playback, but you don’t want to remove
or individually disable these effects in the sequences of your project. These settings affect
real-time playback, rendering, video output, and QuickTime output.
You can control many of these settings by assigning keyboard shortcuts or adding buttons
to the button bar using the Keyboard Layout window. For more information on using
the Keyboard Layout window, see “Customizing the Interface.”

Render and
playback settings

Additional
render settings

Render and Playback Settings
• Filters: If this option is not selected, all filters are ignored during playback, improving
real-time performance.
• Frame Blending for Speed: If this option is selected, clips with speed adjustments are
processed with frame blending. Frame blending makes slow-motion video smoother
by synthesizing in-between frames. This requires more processing power, so you can
turn it off when you are working on a rough cut. If this option is not selected, motion
blur is ignored for all clips in your sequence.
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Render Settings
• Frame Rate: You can use this pop-up menu to reduce the frame rate of rendered
segments of a sequence, dramatically speeding up rendering but lowering playback
quality. For example, if you’re editing at 29.97 fps, and you choose 50 percent in the
Frame Rate pop-up menu, rendered effects in your sequence play back at 15 frames
per second.
• Resolution: Choose a percentage from this pop-up menu to reduce the resolution of
rendered effects, speeding up rendering but lowering playback quality. For example,
if you’re editing with a frame size of 720 x 480, choosing 50 percent lowers the resolution
of rendered effects to a non-interlaced 360 x 240. Rendered effects are still full frame,
but they have lower resolution.
• Codec: This pop-up menu affects rendering of native HDV and XDCAM HD sequences.
Choose whether render files are created in the native codec of your sequence segments
or using the Apple ProRes 422 codec. Because Final Cut Pro supports mixed-format
sequences, you can play back the entire sequence, including the Apple ProRes 422
codec render files, in real time.

Audio Outputs Tab
The settings in this tab allow you to define the number of audio output channels available
for your sequence, using whatever video or audio interface is connected to your computer.
New sequences are created with the audio output preset chosen in the User Preferences
window. Once a sequence is created, you can choose a different audio output preset by
selecting the sequence, choosing Sequence > Settings, and then clicking the Audio
Outputs tab.
By default, a stereo preset is selected, which works with the built-in audio output in your
computer, as well as with most DV camcorders and third-party video capture interfaces.
If you have a more sophisticated audio interface chosen in the A/V Devices tab of the
Audio/Video Settings window, you can create a new preset to route audio to these
additional audio output channels. For more information on choosing an external audio
interface in the Audio/Video Settings window, see “Assigning Output Channels and
External Audio Monitors.”
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Note: When you move a Final Cut Pro project file to another system along with its
sequences, those sequences retain the audio output setting with which they were originally
created, regardless of the number of audio output channels available on that system.

Settings in the
Audio Outputs tab

• Outputs pop-up menu: This pop-up menu allows you to specify the number of audio
outputs available on your external audio interface. This menu defaults to two output
channels for simple stereo output. Additional output channels can be added in pairs.
You can specify as many as 12 pairs of audio outputs, or 24 total outputs.
• Channel Settings boxes: Each pair of outputs has its own settings box, each with its own
set of controls. Adding pairs of outputs adds additional settings boxes.
• Channel number: This number defines which output channel the controls affect.
• Downmix pop-up menu: Commands in this menu determine the amount, in dB, by
which an output channel should be attenuated (lowered) or boosted (raised) when
audio is downmixed to stereo—either for output to video or as a QuickTime movie
or audio file, or when downmix is turned on in the Audio Mixer. When downmixing,
audio output channels can be modified from +10 dB to –10 dB, or turned off
altogether. For more information about setting proper downmix levels, see “Assigning
Output Channels and External Audio Monitors.”
• Stereo Grouping buttons: These buttons define whether a given pair of audio output
channels is stereo or mono. Sequence tracks assigned to stereo pairs of outputs have
pan turned on. A single downmix pop-up menu sets the downmix level for both
channels in the pair, which defaults to 0 dB. Sequence tracks assigned to dual mono
pairs of outputs have no stereo output, and the panning slider for that track is
disabled. Two downmix pop-up menus appear, one for each channel, which default
to –3 dB. For more information about how to set proper downmix levels, see
“Assigning Output Channels and External Audio Monitors.”
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Changing Sequence Settings
You can change individual settings for a sequence, such as image height or codec, or you
can change all the settings at once by loading a sequence preset (which is simply a set
of predefined sequence settings).
To view and change individual settings for a sequence
1 Select a sequence in the Browser or in the Timeline.
2 Do one of the following:
• Choose Sequence > Settings, or press Command-0 (zero).
• Control-click the sequence’s icon, then choose Settings from the shortcut menu.
3 In the Sequence Settings window, click a tab, change its settings, then click OK.

Click a tab, then change
the settings you want.

To change sequence settings using a new sequence preset
1 Select a sequence in the Browser.
2 Do one of the following:
• Choose Sequence > Settings, or press Command-0 (zero).
• Control-click the sequence’s icon, then choose Settings from the shortcut menu.
3 Click the Load Sequence Preset button.
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4 Choose a new preset from the pop-up menu in the Select Sequence Preset dialog, then
click OK.
Important: Final Cut Pro does not allow you to change the editing timebase of a sequence
once it contains clips. If you load a sequence preset with a different editing timebase, the
editing timebase remains unchanged.
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Appendix

Solving Problems

This appendix covers the following:
• Resources for Solving Problems (p. 1883)
• Solutions to Common Problems (p. 1883)
• Contacting AppleCare Support (p. 1889)
If you run into problems while working with Final Cut Pro, there are several resources you
can use to find a solution.

Resources for Solving Problems
The following resources can help you find solutions to problems:
• This appendix: This appendix includes information about some of the most frequent
issues users encounter. Problems are grouped by category.
• Release Notes: The Release Notes document, available from the Final Cut Pro Help menu,
provides up-to-date information that didn’t make it into the manual. Be sure to consult
this document as soon as you install or upgrade Final Cut Pro.
• AppleCare Knowledge Base: AppleCare Support maintains a database of common support
issues that is updated and expanded to include new issues as they arise. This is an
excellent, free resource for Final Cut Pro users. To access the AppleCare Knowledge
Base, go to the AppleCare support page at http://www.apple.com/support.
• AppleCare Support: There are a variety of support options available to Final Cut Pro
customers. For more information, see the Apple Software Service & Support Guide that
came with your Final Cut Pro documentation.

Solutions to Common Problems
The following section describes common problems and solutions in Final Cut Pro.

Problems with Video Devices
If you experience the following issues when working with video devices, try these solutions.
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Your camcorder or deck is not recognized
• Make sure your device control cable or FireWire cable is properly connected and plugged
in all the way.
• Verify that the camcorder is set to VCR mode.
• Make sure the appropriate protocol for your device is selected in the device control
preset. (See “Viewing a Summary of the Current Presets.”)
• Quit Final Cut Pro, shut down your computer, turn your camcorder or deck off and on,
then restart your computer.
You can’t control certain functions of your camcorder or deck
• Make sure your device control cable is properly connected.
• Make sure the appropriate protocol for your device is selected in the device control
preset you’re using. (See “Viewing a Summary of the Current Presets.”)
If you’re using FireWire, try changing the protocol to Apple FireWire Basic.
• If your deck has a Local/Remote switch, make sure it’s set to Remote.

Problems During Playback
This section lists problems that can occur during playback, along with possible solutions.
Video is not visible on an external NTSC or PAL monitor
• Make sure your cables are properly connected from the DV device to your computer
and from the DV device to the NTSC or PAL monitor.
• If you’re viewing your video on a camcorder that’s connected to your computer’s
FireWire port, make sure the camcorder is set to VCR mode.
• Close the Log and Capture window if it’s open.
• Make sure you choose View > External Video, then choose All Frames or Single Frames.
• Make sure you’ve selected the appropriate setting in the A/V Devices tab of the
Audio/Video Settings window. (See “Learning About Audio/Video Presets.”)
• If you’re outputting to a DV device, make sure that the clip you’re viewing is a DV
compressed clip. Choose Edit > Item Properties and make sure the Compressor setting
is the DV-NTSC or DV-PAL codec.
Your external NTSC or PAL monitor is displaying an orange frame with a message
saying that the video card is not supported for RT effects and may have insufficient
video memory or be an unsupported type
• Make sure the monitor displaying the Viewer and Canvas is connected to a video
graphics card that’s compatible with Final Cut Pro.
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The audio is not in sync with the video, or you’re experiencing dropped frames in your
video
Many audio sync issues stem from dropped frames on capture or output. Nearly all
dropped frames are caused by either incorrectly configured hardware or incorrect
preference settings. The leading causes of dropped frames are the following:
• If you’re using external speakers connected to a camcorder, deck, or third-party capture
card, and external video is set to All Frames, the video displayed on your computer’s
monitor (from the Viewer or Canvas) will not be in sync with the audio. The audio will
instead be in sync with the video that is displayed on the NTSC or PAL monitor that’s
connected to the same output device.
• If your clip or sequence is zoomed while open in the Viewer or displayed in the Canvas,
frames can be dropped. Choose Fit to Window from the View pop-up menu in the
Canvas or Viewer.
• The computer display is set to a low refresh rate. The refresh rate in the Displays pane
of System Preferences should always be set to 75 hertz (Hz) or greater. (This is not
applicable to flat-panel displays.)
• The Canvas and Viewer windows are overlapped by other windows; they should not
be.
• If more audio tracks are specified to be mixed in real time than your computer can
handle, frames can be dropped. Reducing the number of tracks in the Real-time Audio
Mixing field in the General tab of the User Preferences window will result in your having
to render your sequence, but will result in improved playback.
• Incorrect versions of Mac OS X and QuickTime can be another cause of dropped frames.
Check the Final Cut Pro website for the version of system software you should use.
• The hard disk drive you’re capturing to is inadequate for capturing video. This could
be caused by slow hard drives, incompatible drivers, or configuration issues. For more
information, see “Determining Your Hard Disk Storage Options.”
• Another source of dropped frames on capture or playback may be fragmented hard
disks. In general, it’s preferable to capture to disks that are specifically reserved for
video. To avoid fragmentation, you should avoid filling up your disks with numerous
files unrelated to the projects you’re working on.

Appendix A Solving Problems

1885

If you’re editing a long project where some clips are captured, others are deleted, and
then more are captured, and so on, even the cleanest storage volume may become
fragmented. You can diagnose this with a hard disk utility. Should your capture disks
be seriously fragmented to the point of impeding performance, you can try the following
three options:
• Quit Final Cut Pro, back up your project file, and delete all the clips from the affected
volumes. (Delete only media that can be recaptured; do not delete graphics, audio,
or project files.) Upon reopening your Final Cut Pro project, you will find that all your
video clips are now offline. Simply recapture them and performance should improve.
• Copy all the files from the fragmented volume to a blank volume with enough space.
Copying files defragments them on the volume to which they are copied. Then delete
the files from the original, fragmented volume; now you’re ready to capture more
clips to it. Upon reopening your project, Final Cut Pro automatically begins the process
of reconnecting your media.
• A more time-intensive solution is to back up your project file and then use
disk-defragmenting software to defragment your volume.
• You can also try deselecting “Mirror on desktop during Playback” in the A/V Devices
tab of the Audio/Video Settings window.
• Another potential cause of dropped frames during output is having too many sequences
open simultaneously in the Timeline. Especially with complex sequences with numerous
edits, having more than one sequence open at the same time can affect playback
performance. To resolve this, close all sequences except the one you want to output
to video.
• Another cause of dropped frames is playing sequences with numerous short edits.
Projects with a large number of short edits (for example, a video made up of several
hundred ten-frame clips) can sometimes overwhelm a hard disk’s ability to jump from
one clip to another. In this case there are two things you can try:
• Write out one single file. When rendering out using the Export QuickTime Movie
command, disable the Recompress All Frames feature to save unnecessary rendering
time.
• Another solution, particularly in the case of long sequences, is to split a single long
sequence into multiple short sequences, outputting them to tape one at a time.
After editing to tape, you don’t see the material you edited when you play back the
tape
• The Edit to Tape command requires that the sequence or clip you’re outputting be
opened in the Viewer before you click the Insert or Assemble edit buttons in the Edit
to Tape window. For more information, see “Assemble and Insert Editing Using Edit to
Tape.”
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An error message appears during capture reporting a break in the timecode
• When capturing clips for your program from source tapes that were shot in the field,
or from old source tapes that have been played to the point of wearing the media,
timecode breaks may appear, disrupting the computer’s ability to read a continuous
stream of timecode. A few timecode breaks are normal on any source tape, but these
timecode breaks should be avoided during capture whenever possible, as they can
cause audio/video sync problems and incorrect timecode in your captured clip. Incorrect
timecode can in turn cause inaccurate EDL export, and incorrect recapture of the clips
containing the breaks.
If you’re logging your source tapes manually in preparation for capture, it’s a good idea
to avoid logging clips along with the breaks that appear between shots, as these are
spots where timecode breaks frequently occur. If a timecode break appears in the
middle of a shot, it may be because the tape is worn, or because the media simply
failed on that frame.
To avoid capturing timecode breaks in any circumstances, make sure that the “On
timecode break” option in the General tab of the User Preferences window is set to
either Make New Clip or Abort Capture. For more information on the “On timecode
break” option, see “General Tab.”
• If you are experiencing excessive timecode breaks during capture, try cleaning the
heads on your camcorder or deck. Dirty heads can cause timecode breaks that don’t
actually exist on the tape.
An error message says that the servo can’t lock
• The tape transport mechanism in the camcorder or deck may not be able to synchronize
as expected and may require more time to synchronize to where the computer thinks
it is. Try increasing the pre-roll time in your device control preset. (See “Device Control
Settings and Presets.”)
• If your device is connected via FireWire, try changing the protocol from Apple FireWire
to Apple FireWire Basic in your device control preset. (See “Device Control Settings and
Presets.”)
DV video clips look fuzzy on the computer’s monitor
• Older Power Mac G4 computers cannot process and properly play back DV in real time
when playback quality is set to High. As a result, these computers display DV video at
a lower resolution in order to maintain the full frame rate of playback for DV clips. This
lower resolution results in a softer image, but no information is lost. You can see this
when the picture is stopped. Final Cut Pro can use a high-quality still frame when it
doesn’t have to maintain playback, so the picture snaps back into focus.
To view your DV media at full quality while playing at 25 or 29.97 frames per second
(fps), you’ll need to connect the FireWire output of your computer to a camcorder or
deck. The camcorder or deck will decompress the DV stream using dedicated hardware,
resulting in smooth playback of your DV media on an attached NTSC or PAL monitor.
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Note: You’ll see the same fuzzy effect with DV clips that are exported into other
applications as well. As long as the clip is compressed with DV, slower computers will
lower the resolution during playback, but the source media on disk still contains all of
the information, at the highest quality.
You’re having problems playing a reference movie
• If you encounter playback problems with a reference movie, export the media as a
self-contained movie (which includes all its media files), and not as a QuickTime reference
movie.
To do this, make sure the Make Movie Self-Contained checkbox in the Export dialog is
selected. For more information, see “Exporting a QuickTime Movie File.”
Video does not play through to the computer screen
• Make sure cables from the video device are properly connected to your computer.
• Check your QuickTime video settings in the Capture Presets tab in the Audio/Video
Settings window. For details on QuickTime source and compression settings, see
“Capture Settings and Presets.”
You experience poor playback and stuttering video when trying to edit
• Make sure you are not editing with media that uses keyframe compression, such as
Sorenson or Cinepak.
Your camcorder or deck doesn’t go to the specified timecode number or won’t perform
a command
• Make sure you selected the correct protocol in the Device Control Presets tab of the
Audio/Video Settings window. If you’re using FireWire, try using the Apple FireWire
Basic protocol.

Problems with Audio Quality
If you experience the following issues with audio quality, try these solutions.
You don’t hear audio through your camcorder speakers
• Make sure your cables are properly connected.
• If you are scrubbing audio in the Audio tab of the Viewer, increase the volume of the
computer’s audio output.
You don’t hear audio on your computer’s speakers when playing video from your
camcorder or deck
• Make sure the speaker’s cables are properly connected.
• Make sure your audio cables are properly connected.
• If you’re monitoring your audio from your computer, make sure that Mute is off, and
that the computer’s volume is adjusted to a reasonable level.
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• Make sure the Preview option is selected in the Clip Settings tab of the Log and Capture
window, and that the appropriate audio output is selected in the Sound pane of
Mac OS X System Preferences.
• Check your QuickTime audio settings in the Capture Presets tab of the Audio/Video
Settings window. For details on audio sample and source settings, see “Capture Settings
and Presets.”
Captured audio sounds distorted and crackly during capture
• During capture, make sure that you always set the Final Cut Pro sample rate to that of
your recorded source material. Mismatched sample rates can result in pops and crackles
in the audio, incorrect audio/video sync, and generally diminished sound quality. Use
32 kHz when you’re capturing media from a DV camcorder that was set to 12-bit
recording. Use 44.1 kHz when you’re capturing digital audio from certain DAT or CD
players. Use 48 kHz when you’re capturing from most digital video formats.

Other Issues
If you experience the following issues, try these solutions.
Final Cut Pro seems to be working slowly
• The amount of memory available to Final Cut Pro can make a big difference in
performance, especially with long projects. More RAM is also needed for software-based
real-time effects and long projects. You may not have enough RAM allocated to
Final Cut Pro. This can be changed in the Memory & Cache tab of the System Settings
window.
You cannot import an EDL or batch capture list
• Final Cut Pro does not support the import of RTF files. To import information from an
RTF file, you should first open the file in a text editing application such as TextEdit and
save it as a “plain text” document. The plain text version can then be imported into
Final Cut Pro.

Contacting AppleCare Support
Included in your Final Cut Pro package is documentation about the support options
available from Apple. Several levels of support are available, depending on your needs.
Whatever your issue, it’s a good idea to have the following information immediately
available. The more of this information you have ready to give to the support agents, the
faster they will be able to address your issue.
• The Support ID number that came with Final Cut Pro. This number is different from the
software serial number that is used to activate your copy of Final Cut Pro.
• The version of Mac OS X you have installed. To find the version, choose Apple menu >
About This Mac.
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• The version of Final Cut Pro you have installed, including updates if applicable. To find
the version of Final Cut Pro on your computer, choose Final Cut Pro > About
Final Cut Pro.
• The model of computer you are using.
• How much RAM is installed in your computer, and how much is available to Final Cut Pro.
To find out how much RAM is installed, choose Apple menu > About This Mac. The
amount of RAM available to Final Cut Pro can be found in the Application field in the
Memory & Cache tab of the System Settings window.
• What other third-party hardware is connected to or installed in the computer, and who
the manufacturers are. Include hard disks, video graphics cards, interfaces, and so on.
• Any third-party plug-ins or other software installed along with Final Cut Pro.
To access AppleCare Support for Final Cut Pro, go to
http://www.apple.com/support/finalcutpro.
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Appendix

Video Formats

This appendix covers the following:
• An Overview of Video Format Characteristics (p. 1891)
• Storage Medium (p. 1893)
• Video Standards (p. 1894)
• Types of Video Signals (p. 1895)
• Aspect Ratio of the Video Frame (p. 1897)
• Frame Dimensions, Number of Lines, and Resolution (p. 1899)
• Pixel Aspect Ratio (p. 1901)
• Frame Rate (p. 1902)
• Scanning Method (p. 1902)
• Color Recording Method (p. 1904)
• Video Sample Rate and Bit Depth (p. 1905)
• Video Compression (p. 1907)
• Video Formats Supported by Final Cut Pro (p. 1914)
This appendix provides a basic introduction to the characteristics of video formats and
video formats supported by Final Cut Pro. For more detailed information about
Final Cut Pro support for advanced video formats, including those used with high definition
and ultra high definition footage, see Professional Formats and Workflows, available in
Final Cut Pro Help.

An Overview of Video Format Characteristics
All video formats achieve the same basic goal: they store black-and-white or color
information as electronic lines that make up a video frame. The number of video frames
recorded per second varies depending on the video standard the format supports (for
example, NTSC formats are recorded at 29.97 fps; PAL formats are recorded at 25 fps).
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Video formats can be characterized by the following factors:
• The medium used to store the video information: This is primarily videotape, but can
also be optical disc, solid-state memory, or a hard disk. For more information, see
“Storage Medium.”
• The size of the media and the shape of the shell: For example, videotape may be 1", 1/2",
3/4", or 8 mm. Many video formats have different shell sizes for portable and studio
use, such as mini-DV (portable) and the larger DV cassettes for studio decks. For more
information, see “Tape Size, Cassette Shape, and Tape Coating.”
• The video standard supported: For example, NTSC, PAL, ATSC (HDTV 1080i or 720p),
and so on. For more information, see “Video Standards.”
• The type of electronic signal recorded on tape: In other words, the way luma
(black-and-white) and chroma (color) information are combined and recorded. For
more information, see “Types of Video Signals.”
• The aspect ratio of the video frame: The ratio of the frame width to the frame height.
For more information, see “Aspect Ratio of the Video Frame.”
• The dimensions of the video frame: The number of pixels per line, and the number of
lines per frame. For more information, see “Frame Dimensions, Number of Lines, and
Resolution.”
• The aspect ratio of the pixels: This is a subtle factor that is explained in more detail in
“Pixel Aspect Ratio.”
• The frame rate: The number of frames recorded per second. For more information, see
“Frame Rate.”
• The scanning method: Interlaced fields (two fields per frame) or progressive (one
complete frame at a time). For more information, see “Scanning Method.”
• Color recording method: RGB, component (YUV), S-Video (Y/C), or composite. For more
information, see “Color Recording Method.”
• Color sampling: For component digital formats, the ratio of color samples to
black-and-white (or luma) samples (for example, 4:4:4, 4:2:2, and 4:1:1). For more
information, see “Color Recording Method.”
• Sample rate: The number of samples per second of each video line. This is just like the
sample rate for audio, except the signals sampled are video lines, where each sample
represents light intensity instead of sound intensity. For more information, see “Video
Sample Rate and Bit Depth.”
• Bit depth: The number of bits used to store each video sample, which determines the
ability of the format to capture each sample’s (or pixel’s) light intensity precisely, and
how well subtle differences in intensity can be stored. For more information, see “Bit
Depth.”
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• Compressor (or codec): A video compressor attempts to reduce the amount of digital
data required to store each frame without compromising the quality of the image. For
more information, see “Video Compression.”

Storage Medium
Video—especially digital video—can be stored on more than just videotape. The
characteristics of the storage medium determine playback and recording capabilities. For
example, magnetic and optical disc media (such as CDs, DVDs, and hard disks) are capable
of nonlinear reading and writing, whereas videotape is inherently linear. Videotape is still
a very efficient means of storing large amounts of digital data in a small space, but other
types of media are quickly gaining ground.

Tape Size, Cassette Shape, and Tape Coating
The width of a videotape is directly related to how much information can be stored. In
analog formats, wider tape usually yields higher quality, but other factors can help reduce
tape size with minimal loss of quality. For example, Betacam SP and VHS both use 1/2"-wide
tape, but Betacam SP uses a high-quality component video recording method that keeps
luma and chroma information separate, whereas VHS uses a composite method that
mixes these signals into one, causing interference between the two. The physical
formulations of these two kinds of tape are also different, which accounts for some of
the quality difference.
The size of the cassette itself can vary as well. For example, the Betacam SP format comes
in both small and large sizes. The small tapes are used for camcorders, and the large
format is used in studio VTRs.
Aspects of the physical composition of magnetic tape, such as density of magnetic
particles, limit the data rate and track size that can be recorded on the tape. The magnetic
coating on a videotape is formulated to work with particular camcorders and VTRs. If you
choose the wrong tape coating, the tape can actually clog the video record heads of your
video equipment, leading to video signal dropouts during recording and playback. Always
read the documentation that comes with your video equipment before purchasing a
particular brand of videotape stock.

About File-Based Media
Historically, video footage has been recorded on videotape. As digital acquisition replaces
analog technology, some camcorders now record footage as files on non-tape-based
media such as hard disks, solid-state cards, and optical discs.
Today, some common file-based media formats include:
• DVCPRO HD and AVC-Intra (solid-state Panasonic P2 card)
• AVCHD (hard disk, miniDVD, Secure Digital card, and memory stick)
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• Sony XDCAM, XDCAM HD (optical disc), XDCAM EX (SxS memory card)
• Sony Video Disk Unit devices (hard disk)

Video Standards
For the last 50 years, there have been two major signal types recorded on videotape:
NTSC and PAL. With the emergence of new high definition (HD) video formats, NTSC and
PAL formats are now referred to as standard definition (SD) video formats.

Standard Definition Video
National Television Systems Committee (NTSC) is the television and video standard used
in most of the Americas, Taiwan, Japan, and Korea. Phase Alternating Line (PAL) is the
television and video standard used in most of Europe, Australia, India, Brazil, China, and
many African countries. There are several variations of both NTSC and PAL used in different
parts of the world, but these variations are not described here.
Standard

Lines per frame

Frame rates

Scanning method

NTSC

525

29.97 fps

Interlaced

PAL

625

25 fps

Interlaced

SECAM is a video standard based on PAL. It is used in France, Poland, Haiti, and Vietnam.
SECAM is strictly an analog composite video standard, so it is not used in digital video
editing. Post-production work for SECAM broadcast is usually done in PAL and later
converted to SECAM.
Note: SECAM is not supported by Final Cut Pro.
SD formats almost always have an aspect ratio of 4:3 (1.33:1).

High Definition Video
In the late 1990s, HD video formats were standardized in the United States by the
Advanced Television Standards Committee (ATSC). These HD video formats are the next
generation of broadcast and recording video formats. Unlike SD formats, which are
restricted to fixed frame rates and numbers of lines per frame, HD video provides several
options per format. Although the increased flexibility is convenient, it also makes format
interchange more complicated. Simply saying “HD video” is not enough; you need to
define the frame size, frame rate, and scanning method of your HD format.
Standard

Frame size

Frame rates (fps)

Scanning method

720p

1280 x 720

23.98, 29.97, 59.94
24, 30, 601

Progressive

25, 50
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Standard

Frame size

Frame rates (fps)

Scanning method

1080p

1920 x 1080

23.98, 29.97
24, 30
25

Progressive

1080i

1920 x 1080

25 (50i), 29.97 (59.94i),
30 (60i)

Interlaced

1 720p footage recorded at 24, 30, and 60 fps is rare. The 29.97 fps rates are more common because they are compatible
with NTSC equipment.

There are an increasing number of HD tape and file-based formats available. Most HD
formats support only a subset of the options shown in the table above, and most
camcorders and video decks do not support every combination.

Types of Video Signals
Video signals are separated into several channels for recording and transmission. There
are different methods of color channel separation, depending on the video format and
its historical origins. For example, broadcast video devices were originally designed for
black-and-white video, and color was added later. This is still evident in today’s video
formats that break image information into separate black-and-white and color information.
On the other hand, video and image processing on computers is more flexible and
developed later, so a three-color RGB model was adopted instead of a luma-chroma
model.
The luma (black-and-white channel) and chroma (color channels) information can be
recorded and transmitted several different ways in a video signal.
• RGB (Red, Green, Blue): This is the native format for most computer graphics and video
files. This signal is also used inside traditional color CRTs, video cameras, flat-panel
displays, and video projectors. Red, green, and blue signals can be combined to make
any color, as well as grayscale images ranging from black (no signal on any channel)
to white (full signal on every channel). RGB signals do not have a separate luma channel,
because black-and-white signals can be represented by equal amounts of R, G, and B
signals.
• Component YUV: This three-channel Y′CBCR signal has a luma (Y′) signal and two color
difference channels (CB and CR). (The two color difference channels have different names
depending on the particular format but serve a similar function in all formats. Some
common names for different color channels include CB, CR; R-Y, B-Y; and U, V.)
Component video was invented in the 1950s as a way of making color television signals
compatible with existing black-and-white televisions. Black-and-white televisions could
use the luma signal, and color televisions could convert Y′, CB, and CR back to RGB for
display.
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The luma signal is derived by combining R, G, and B signals in proportions similar to
the way human vision perceives those three colors. Therefore, the luma signal
approximates the way the human eye sees brightness in color images. Humans are
most sensitive to the green portion of the visible spectrum, and therefore the luma
channel mostly consists of the green channel. The color difference channels are so
named because they are derived from RGB by subtracting signals from the luma channel
for each of the color channels (for example, R-Y or B-Y).
• S-Video (Y/C): An S-Video signal is also considered a component video signal because
the luma and chroma signals are separate. However, the C signal is derived by combining
the CB and CR component signals, which reduces the quality of the color channel
compared to Y′CBCR.
• Composite: The luma (Y′) and chroma (C) signals are combined into a single composite
video signal for broadcast. The chroma signal is placed on a color subcarrier frequency
related to the main luma frequency. This method of superimposing color information
on top of the black-and-white information indicates that this format originated in the
early days of color television, when black-and-white TV compatibility was critical for
widespread adoption.
Black-and-white televisions are unaware of the color subcarrier, and so only the luma
(Y′) channel is shown. Color televisions reverse the composite process, re-creating the
Y′CBCR component signal and then the RGB signal for display. Because the chroma and
luma channels are superimposed, they do not separate perfectly, causing artifacts in
the resulting image.
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Aspect Ratio of the Video Frame
The ratio of horizontal to vertical dimensions of a film or video frame is called the aspect
ratio. Aspect ratio is independent of absolute image size or resolution.
Standard
definition
1.33:1
(4 x 3)

High definition
1.78:1
(16 x 9)

Standard cinema
1.85:1

Widescreen cinema
2.40:1

Aspect ratios can be expressed as absolute dimensions (4 x 3), a ratio (4:3), a fraction (4/3),
or as the decimal equivalent of a ratio (1.33:1, or simply 1.33). Aspect ratios are generally
expressed according to the following conventions:
• Video aspect ratios are often written as ratios, such as 4:3 for SD video or 16:9 for HD
video.
• Film aspect ratios are often written as decimal equivalents, such as 1.33, 1.85, and 2.40.
The larger the decimal number, the wider the image. An aspect ratio of 2.40 is wider
than 1.85, and 1.85 is wider than 1.33.
• Digital video resolutions are usually written as absolute pixel dimensions, such as
720 x 480, 1280 x 720, 1920 x 1080, and so on.
Below is a list of commonly used aspect ratios, mostly from the film and television industry,
plus a few others for comparison.
Aspect ratio

Medium

1.33 (4:3)

Early 35 mm film and SD television

1.37

4-perforation 35 mm camera footage (prior to projection)—also
known as “Academy” aspect ratio

1.66 (15:9)

Standard European film; masked in projector

1.78 (16:9)

HD television

1.85

Standard North American and UK film; masked in projector

Appendix B Video Formats

1897

Aspect ratio

Medium

2.40 (also referred to as 2.35 and
2.39)

Widescreen (anamorphic) film projection

Footage with different aspect ratios can be combined using a variety of techniques, as
described in the following sections.

Letterboxing
Letterboxing preserves the aspect ratio of widescreen movies on a narrower screen. The
movie is scaled until it fits within the width of the screen, resulting in blacks bars at the
top and bottom of the frame.
1.78 letterbox

2.40 letterbox

2.40 letterbox

1.33 frame

1.33 frame

1.78 frame

Pan and Scan
The pan and scan technique crops widescreen movies to fit on a narrower screen. In some
cases, artificial camera moves may even be added to show the entire content of a
widescreen frame. Pan and scan does not preserve the aspect ratio of widescreen movies.

1898

1.78 pan and scan

2.40 pan and scan

1.33 frame

1.33 frame
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Anamorphic
Anamorphic techniques use special lenses or electronics to squeeze a widescreen image
to fit in a narrower aspect ratio. During projection or playback, the squeezed image is
stretched back to its original widescreen aspect ratio.
1.78 anamorphic

2.40 anamorphic

2.40 letterbox in
1.78 anamorphic

1.33 frame

1.33 frame

1.33 frame

Anamorphic video can also be letterboxed. For example, 16:9 anamorphic DVDs may
contain letterboxed 2.40 aspect ratio footage.

Pillarboxing
Pillarboxing displays movies with a small aspect ratio on a wide screen. Black bars appear
on the left and right sides of the frame.
1.33 pillarbox

1.78 frame

Frame Dimensions, Number of Lines, and Resolution
A video frame is composed of lines. In digital video, each line is sampled to create a
number of pixels (samples) per line. The more lines per frame, the higher the image
resolution. The more pixels per line, the higher the resolution of each line.

Number of Lines
NTSC uses 525 lines, whereas PAL uses 625. In analog video, many lines are not actually
used for picture information, so the total numbers relevant for the picture are somewhat
smaller: 486 lines for NTSC and 576 lines for PAL. HD formats defined by the ATSC have
either 1080 or 720 active picture lines per frame.
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Pixels per Line
In digital video formats, each line is sampled a number of times. In an attempt to create
a single digital VTR that could digitize and record both NTSC and PAL signals, the ITU-R
BT.601 specification uses 720 samples per line for both NTSC and PAL video. Therefore,
a digital NTSC video frame is 720 pixels x 486 lines, and a PAL video frame is 720 pixels
x 576 lines.
HD video with 1080 lines uses 1920 pixels per line (1920 x 1080). HD video with 720 lines
uses 1280 pixels per line (1280 x 720). Both of these formats have an aspect ratio of 16:9.
Common video frame sizes are shown in the table below.

Width

Height

Pixel
aspect
ratio

Screen
aspect
ratio

Description

320

240

1:1

4:3

Used for web distribution or offline video editing.

640

480

1:1

4:3

An early standard for analog-to-digital video
editing, and an ATSC video specification.

7201

480

Height
greater
than
width

4:3

NTSC DV and DVD image dimensions. Also part of
the ATSC video specification.

7201

486

Height
greater
than
width

4:3

NTSC SD video dimensions used for professional
digital formats such as Digital Betacam, D-1, and
D-5.

7201

576

Width
greater
than
height

4:3

PAL SD video dimensions used for digital formats
such as Digital Betacam, D-1, and D5, as well as
DVD and DV.

1280

720

1:1

16:9

An HD video format, capable of higher frame rates
in exchange for smaller image dimensions.

1920

1080

1:1

16:9

An HD video format with very high resolution.

960

720

4:3

16:9

Some 720p formats (such as DVCPRO HD and HDV)
subsample 1280 pixels to 960 to minimize the data
rate.

1440
1280

1080

4:3
3:2

16:9

Some 1080-line formats (such as HDV and DVCPRO
HD) subsample 1920 pixels to 1440 or even 1280
to minimize the data rate.

1 In most video devices, only 704 or 708 pixels are actually used for picture information.

Note: For information on pixels per line and aspect ratios in digital cinema formats such
as REDCODE, see Professional Formats and Workflows, available in Final Cut Pro Help.
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720 x 486 Versus 720 x 480
One issue that comes up during post-production is the subtle difference between NTSC
SD formats that use 486 lines per frame (such as Digital Betacam, D-1, and D-5) and
formats that use 480 lines per frame (such as DV, DVCPRO, and DVD). Why is there this
subtle difference? The reason is simple: 480 is divisible by 16, and 486 isn’t. Divisibility by
16 is convenient for certain block-based codecs because each frame is broken into 16 x 16
pixel blocks (known as macroblocks) during compression.
The only time this should be a concern is when you are converting between a 486-line
format like Digital Betacam and a 480-line format like DVD. However, the extra six lines
are typically not visible on an analog television.

Pixel Aspect Ratio
A pixel usually refers to a physical picture element that emanates light on a video display.
But a pixel is also a term for a sample of light intensity—a piece of data for storing luma
or chroma values. When stored on tape or on hard disk, the intensity of a pixel has no
inherent shape, height, or width; it is merely a data value. For example, one pixel may
have a value of 255, and another may have a value of 150. The value of each pixel
determines the intensity of a corresponding point on a video display. In an ideal world,
all pixels would be captured and displayed as squares (equal height and width), but this
is not always the case.
The ITU-R BT.601 specification makes it possible to transmit either NTSC or PAL information
in a single signal. To achieve this goal, both NTSC and PAL video lines are sampled 720
times. In both NTSC and PAL video, the frame displayed has an aspect ratio of 4:3, yet
neither 720 x 486 nor 720 x 576 constitutes a 4:3 ratio. The solution to this problem is to
display the pixels (the samples of light intensity) taller-than-wide, or wider-than-tall, so
that they fit into a 4:3 frame. This results in the concept of “rectangular pixels”—pixels
that must be stretched or squeezed to fit in the 4:3 frame. Most SD video devices actually
use 704 or 708 pixels for picture information but stretch these pixels to 720 when recording
to tape.
None of this was obvious in the days of linear editing, when video was simply copied
from one tape to another, because the video equipment always compensated
automatically. However, as people began using computers to work with video, digital
video captured to the computer looked distorted (squashed vertically or stretched
horizontally) because the computer displayed the pixels as squares, without compensating.
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Some video formats use rectangular pixels to reduce the amount of information stored
on tape. For example, DVCPRO HD effectively records 1280 pixels per line (when using
the 720p format), but to save space on tape, the intensity of every 1.33 pixels is averaged
together (a process known as subsampling) and only 960 pixels are recorded. These pixels
are not representing a square area, but a wider, rectangular portion of each video line.
This results in a 4-to-3 reduction in the amount of information recorded on tape.
Video and image editing programs like Final Cut Pro and Photoshop must compensate
for these rectangular pixels so they appear correctly on a computer display. However,
there are several different pixel aspect ratios in use, and there is unfortunately no single
accepted standard in the industry. The exact aspect ratio used may vary slightly from one
software application to another, as well as among different third-party video interfaces.
These days, the biggest challenge comes when exchanging graphics between applications
that use different pixel aspect ratios, or when using an application that does not support
rectangular pixels with one that does. The key to a simple workflow is to use applications
that can work at the native, non-square pixel image dimensions and compensate on the
computer display. Fortunately, major video and graphics applications such as Photoshop,
After Effects, Final Cut Pro, and DVD Studio Pro can work with graphics and video at native
resolutions. This way, you are always working with the exact pixel dimensions that you
will eventually output to videotape or DVD.

Frame Rate
The frame rate of any motion picture, whether film or video, defines how often pictures
are taken per second. The higher the frame rate, the more accurately you capture moments
in time and reduce flicker during playback. To achieve double the perceived frame rate
(flicker), film projectors actually double or triple the shutter speed, even though the same
frame is repeated two or three times, respectively. This is because a faster flicker creates
more convincing motion. Video uses a similar, although more complicated, technique
called interlacing. For more information about interlacing, see “Scanning Method.” For
more details about frame rate, see “Frame Rate and Timecode.”

Scanning Method
A video frame is made of horizontal lines that are scanned from one side of a display to
the other. Progressive video scanning happens when each line of a video frame is scanned,
one after another. Interlaced scanning fills the entire frame with only half the lines, which
requires half the time, thus doubling the perceived frame rate and reducing flicker.
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About Interlaced Scanning
Frame rates lower than 40 fps can cause noticeable flicker. When NTSC and PAL were
invented, faster frame rates were not practical to implement. Interlaced scanning was
devised to create a perceived frame rate of 60 fps (NTSC) or 50 fps (PAL). Interlaced video
scans the display twice, using two fields, to complete a single frame. A single field contains
only the odd lines (1, 3, 5, 7, and so on) or the even lines (2, 4, 6, 8, and so on) of the
frame. If you could stop the video scanning process to observe a single video field, you
would see that every other line is missing, like venetian blinds or a comb.
Because the fields are changing at twice the frame rate, there is less perceived flicker than
if each frame was scanned progressively. For example, with NTSC, a field of odd lines is
scanned in 1/60 of a second and a field of even lines follows in the next 1/60 of a second,
resulting in a complete frame every 1/30 of a second.

Field 1

Field 2

Frame

About Progressive Scanning
Progressive scanning is much simpler than interlaced scanning: each line is scanned
consecutively until a complete frame is drawn. Computer displays and many recent HD
televisions use progressive scanning.
Here are some significant facts about interlaced and progressive scanning methods:
• Interlacing provides twice the perceived frame rate with only half the recording or
transmission requirements.
• Progressive scanning is preferred when interlacing artifacts (such as thin flickering
horizontal lines) would be unacceptable. Progressive images are often considered more
film-like because there are no flickering interlacing artifacts.
• Computer displays are almost always scanned progressively.
• NTSC and PAL televisions always use interlaced scanning.
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• Many HD video cameras can record progressive frames.
• Video destined for computer-only use, such as web video, should always be made
progressive.

About Field Dominance
Field dominance is an issue when recording and playing back interlaced video material.
With progressive video, there is only one way to play back a video frame: start at line 1
and scan until the end of the last line. With interlaced video, the video player must know
whether to scan the odd lines first, or the even lines. In other words, each time a frame
is displayed, which field should be displayed first, field 1 or 2? The field displayed first is
totally dependent on which field was captured by the camera and recorded first.
Each field is a snapshot in time, so if field 1 is recorded earlier in time than field 2, field 1
must be played back before field 2. If the wrong field order is chosen, each frame’s fields
play backward in time, even though each frame as a whole still moves forward. The effect
is a very noticeable stutter happening 60 (NTSC) or 50 (PAL) times a second.
Each piece of video equipment and each video format has a preferred field dominance.
This prevents you from, say, editing two field 2s back to back, and makes sure that each
field is played back in the right order.

Setting Field Dominance in Final Cut Pro
In Final Cut Pro, the field dominance of clips must match the sequence field dominance.
Otherwise, the fields stutter during playback because each pair of fields plays back in the
wrong order. For example, DV NTSC and DV PAL always have a field dominance of Lower
(Even). If you’re working in a sequence and you see that imported clips are flickering,
check to make sure the field dominance of those additional clips matches the field
dominance of your edited sequence.
Important: You need to change the Field Dominance setting of your projects and
sequences only if you change your video hardware setup.
In Final Cut Pro, there are two options for field dominance:
• Upper (field 2 is dominant, so the second field is drawn first)
• Lower (field 1 is dominant, so the first field is drawn first)
Generally, Upper is used by 640 x 480 systems, whereas Lower is most common in
professional 720 x 486 and DV 720 x 480 systems.

Color Recording Method
The color recording method of a video format may be either RGB, Y′CBCR (component),
Y/C (S-Video), or composite. The more discrete channels a format has, the higher the
quality of the image, but the more data required to store and transmit that information.
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Color recording method

Video formats

Composite

1", 3/4" U-matic, 1/2", VHS, D-2, D-3

Y/C (S-Video)

Hi-8, S-VHS

Y′CBCR (component)

Betacam SP, Digital Betacam, DVD, DV, D-1, D-5

RGB

Computer graphics and digital cinema acquisition. Although video
originates in and is displayed in this format, it is rare for tape formats
(Y′CBCR is used instead).

Today, almost all digital video formats are Y′CBCR (component). Computers typically store
image data using RGB, although many Y′CBCR (component) formats can now be processed
natively on the computer (such as DV).

Video Sample Rate and Bit Depth
The video sample rate of a digital video format determines how often the light intensity
of each video line is sampled.
Sample rate

Description

74.25 MHz

HD video luma (Y′) sample rate.

37.125 MHz

HD video chroma (CBCR) sample rate. This is half of the luma sample
rate, used for 4:2:2 HD video.

14.3 MHz

Early NTSC digital video recorders sampled video at exactly four
times the frequency of the color subcarrier signal (3.58 MHz x 4).
This is the origin of the 4 in color sample ratios such as 4:2:2.

13.5 MHz

This is the sample rate for the luma (Y′) channel for SD digital video.
This sample rate was chosen to work with both NTSC and PAL digital
video. The 4 in 4:2:2 is now represented by this sample rate.

6.75 MHz

This is the sample rate for the color difference channels in 4:2:2
video. This is half of 13.5 MHz.

Color Sample Ratio
Color sample ratio refers to the ratio of luma (Y′) samples to each color difference sample
(CB and CR). For example, 4:2:2 color sampling means that for every four pixels of Y′ data
stored, only two CR samples and two CB samples are stored. By reducing the number of
chroma samples, less color detail is recorded and less bandwidth is required for storage
and transmission. Because we are less sensitive to color detail than we are to luma detail,
subsampling the chroma signal can be considered perceptually lossless. In absolute terms,
chroma subsampling can make processes like chroma keying much more difficult.
Sample ratio

Description

4:4:4

Each R, G, and B channel, or each Y′, CB, and CR channel, is sampled
at the same rate. Maximum color detail is maintained.
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Sample ratio

Description

4:4:4:4

Full sample rate for each color channel, plus a fourth alpha channel
at the full sample rate.

4:2:2

The color channels are subsampled so that the color resolution is
halved. For example, the first pixel in a line contains Y′, CB, and CR
samples. The next pixel contains only a Y′ sample. This pattern
repeats. Most professional video formats use 4:2:2 color subsampling.

4:2:2:4

4:2:2 sample rate for each color channel, plus an alpha channel at
the full sample rate.

4:1:1

The color is subsampled so that the color resolution is quartered.
The first pixel in a line contains Y′, CB, and CR samples. The next
three pixels only contain Y′ samples. This pattern repeats.

4:2:0

This ratio indicates that the CB and CR channels are subsampled
both horizontally (as in 4:2:2) and vertically. This reduces color
resolution in both the horizontal and vertical dimensions compared
to 4:2:2, which only reduces horizontal chroma resolution.
There are several methods for locating CB and CR samples relative
to Y′ samples, yielding several different 4:2:0 formats.

The following table shows a list of color sample ratios used in various digital video formats.
Sample ratio

Video formats

4:4:4

HDCAM SR
Most RGB computer graphics files (implicit)

4:2:2

Digital Betacam, D-1, D-5, DVCPRO HD, DVCPRO 50, and HDCAM
SR

3:1:1

HDCAM

4:1:1

NTSC DV, NTSC DVCAM, and DVCPRO

4:2:0

PAL DV, PAL DVCAM, DVD, and HDV

Bit Depth
The number of bits used per sample determines how accurately the sample is stored, as
well as how much intensity variation is possible within the signal. For example, a video
signal with a bit depth of only 1 bit can have a value of either 0 or 1, resulting in only
black or white pixels. Two bits per sample results in four possible values: 00, 01, 10, or 11,
or any of four shades of gray (or some other color) per sample.
Most digital video formats use a minimum of 8 bits per color channel, or 256 gradations
of intensity. RGB images are traditionally described by the total bits used per pixel (8 bits
per channel x 3 channels = 24 bits). 32-bit RGB images usually have 24-bit color plus 8
more bits for an alpha channel.
Note: Still images using 16 bits per color channel, or 48 bits per RGB pixel, are becoming
more common. However, most video formats use 8 or 10 bits per color channel.
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Video signal bit depth is usually described per channel. For example, DV and DVCPRO
HD use 8 bits per color component (in other words, 8 bits for Y′, 8 bits for CB, and 8 bits
for CR). Other formats, such as D-5, use 10 bits per component. This provides 1024 possible
gradations instead of 256, which means much more subtle variations in intensity can be
recorded.
In fact, 8-bit Y′CBCR video does not use all 256 codes to represent picture information.
Black is stored as code 16 and white is code 235. Codes 1–15 and 236–254 are retained
for footroom and headroom, respectively. These areas allow for quick spikes in the signal
caused by filtering in analog-to-digital conversions and, in the case of white levels, can
prevent clipping for highlights that may exceed 235 (white). Levels above 235 are
sometimes referred to as super-white levels. For more information about super-white
levels, see “Rendering and Video Processing Settings.”
Internally, Final Cut Pro can do pixel calculations using 32-bit floating-point precision,
which allows for very accurate calculations without rounding errors. This leads to much
more accurate color reproduction when applying filters and compositing layers of video.
This is especially important when you are going to show your movie on film or
broadcast-quality video monitors. In Final Cut Pro, the Video Processing tab in the
Sequence Settings window allows you to choose the rendering bit depth for a sequence.
For more information, see “Rendering and Video Processing Settings.”

Perceptual Coding and Gamma
The limited number of brightness steps in 8-bit digital video requires efficient use of the
256 available codes. Because perception of brightness follows a power law function,
humans are more sensitive to absolute intensity changes in dark areas. In other words,
the amount of light required to make a perceptual shift in brightness increases
exponentially. Therefore, a gamma correction is applied to video so that the step between
each code represents a perceptual shift in brightness. Without this gamma correction,
the darker areas would appear to abruptly jump from one brightness level to the next
(“banding”) and white levels would waste many codes with imperceptible brightness
shifts. This gamma correction is reversed by video monitors so that the viewer sees the
original light intensity of the image. For more information about gamma, see “Rendering
and Video Processing Settings.”

Video Compression
Once a video signal is digital, it requires a large amount of storage space and transmission
bandwidth. To reduce the amount of data, several strategies are employed that compress
the information without negatively affecting the quality of the image. Some methods
are lossless, meaning that no data is lost, but most are lossy, meaning that information is
thrown away that can’t be retrieved.
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Some simple methods of data compression are:
• Throw away pixels at regular intervals: This essentially scales the image, or makes it
more blocky.
• Average several pixel values together (subsampling): This involves taking several adjacent
pixel values and averaging them together, resulting in a single rectangular pixel that
approximates the value of several. For more information, see “Pixel Aspect Ratio.”
• Throw away color channel information at regular intervals: This results in color sample
ratios like 4:2:2 and 4:1:1. Ideally, throwing away this color information is not noticeable
to the viewer, but it may be a problem if you are trying to do detailed color correction
or chroma keying that requires a lot of color information to start with.

Lossless Codecs
Once these basic methods have been employed, much more intensive algorithms can
be employed to reduce the amount of transmitted and stored image data. Mathematical
algorithms can be used to encode and decode each video frame. These codecs (such as
enCode and Decode) must be installed in the VTR or software you are using to play back
your video. For example, QuickTime supports many different video codecs for video
export and playback.
The simplest encoding algorithm, called run-length encoding, represents strings of
redundant values as a single value and a multiplier. For example, consider the following
bit values:
0000000000000000000000001111111111111111000000000000000000000000
Using run-length encoding on the bit values above can reduce the amount of information
to:
0 x 24, 1 x 16, 0 x 24
Or in binary:
0 [11000], 1 [10000], 0 [11000]
In the example above, the original 64 bits can be transmitted using only 18 bits.
Run-length encoding is lossless, because all the information is retained after decoding.
This technique is particularly useful for computer graphics applications, because there
are often large fields of identical colors.
Note: If each bit in the original image were to alternate between 0 and 1, run-length
encoding would not only be ineffective, it could actually make the overall data rate higher.
Each codec is designed to anticipate and compress different kinds of data patterns. For
example, a codec designed for audio compression is not useful for video compression,
which has very different data patterns.
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Lossy Codecs
Most video codecs are necessarily lossy, because it is usually impractical to store and
transmit uncompressed video signals. Even though most codecs lose some information
in the video signal, the goal is to make this information loss visually imperceptible. When
codec algorithms are developed, they are fine-tuned based on analyses of human vision
and perception. For example, if the human eye cannot differentiate between lots of subtle
variation in the red channel, a codec may throw away some of that information and
viewers may never notice.
Many formats, including JPEG and all varieties of DV, use a fairly complicated algorithm
called DCT encoding. Another method, called wavelet compression, is starting to be used
for popular codecs, such as the Apple Pixlet video codec. DVDs, modern digital television,
and formats such as HDV use MPEG-2 compression, which not only encodes single frames
(intraframe, or spatial compression) but encodes multiple frames at once (interframe, or
temporal compression) by throwing away data that is visually redundant over time.

About Uncompressed Video
Video that has no compression applied can be unwieldy, so it is only used for the
highest-quality video work, such as special effects and color correction at the last stage
of a project. Most professional projects have an offline phase that uses compressed video
and then an online, finishing phase that uses uncompressed video recaptured at full
resolution. Uncompressed video requires expensive VTRs and large, high-speed hard
disks.

About MPEG Compression
MPEG encoding is based on eliminating redundant video information, not only within a
frame but over a period of time. In a shot where there is little motion, such as an interview,
most of the video content does not change from frame to frame, and MPEG encoding
can compress the video by a huge ratio with little or no perceptible quality loss.
MPEG compression reduces video data rates in two ways:
• Spatial (intraframe) compression: Compresses individual frames.
• Temporal (interframe) compression: Compresses groups of frames together by
eliminating redundant visual data across multiple frames.
Intraframe Compression
Within a single frame, areas of similar color and texture can be coded with fewer bits than
the original, thus reducing the data rate with minimal loss in noticeable visual quality.
JPEG compression works in a similar way to compress still images. Intraframe compression
is used to create standalone video frames called I-frames (short for intraframe).
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Interframe Compression
Instead of storing complete frames, temporal compression stores only what has changed
from one frame to the next, which dramatically reduces the amount of data that needs
to be stored while still achieving high-quality images.
Groups of Pictures
MPEG formats use three types of compressed frames, organized in a group of pictures, or
GOP, to achieve interframe compression:
• I-frames: Intra (I) frames, also known as reference or key frames, contain all the necessary
data to re-create a complete image. An I-frame stands by itself without requiring data
from other frames in the GOP. Every GOP contains one I-frame, although it does not
have to be the first frame of the GOP. I-frames are the largest type of MPEG frame, but
they are faster to decompress than other kinds of MPEG frames.
• P-frames: Predicted (P) frames are encoded from a “predicted” picture based on the
closest preceding I- or P-frame. P-frames are also known as reference frames, because
neighboring B- and P-frames can refer to them. P-frames are typically much smaller
than I-frames.
• B-frames: Bi-directional (B) frames are encoded based on an interpolation from I- and
P-frames that come before and after them. B-frames require very little space, but they
can take longer to decompress because they are reliant on frames that may be reliant
on other frames. A GOP can begin with a B-frame, but it cannot end with one.
GOPs are defined by three factors: their pattern of I-, P-, and B-frames, their length, and
whether the GOP is “open” or “closed.”
GOP Pattern
A GOP pattern is defined by the ratio of P- to B-frames within a GOP. Common patterns
used for DVD are IBP and IBBP. All three frame types do not have to be used in a pattern.
For example, an IP pattern can be used. IBP and IBBP GOP patterns, in conjunction with
longer GOP lengths, encode video very efficiently. Smaller GOP patterns with shorter GOP
lengths work better with video that has quick movements, but they don’t compress the
data rate as much.
Some encoders can force I-frames to be added sporadically throughout a stream’s GOPs.
These I-frames can be placed manually during editing or automatically by an encoder
detecting abrupt visual changes such as cuts, transitions, and fast camera movements.
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GOP Length
Longer GOP lengths encode video more efficiently by reducing the number of I-frames
but are less desirable during short-duration effects such as fast transitions or quick camera
pans. MPEG video may be classified as long-GOP or short-GOP. The term long-GOP refers
to the fact that several P- and B-frames are used between I-frame intervals. At the other
end of the spectrum, short-GOP MPEG is synonymous with I-frame–only MPEG. Formats
such as IMX use I-frame–only MPEG-2, which reduces temporal artifacts and improves
editing performance. However, I-frame–only formats have a significantly higher data rate
because each frame must store enough data to be completely self-contained. Therefore,
although the decoding demands on your computer are decreased, there is a greater
demand for scratch disk speed and capacity.
Maximum GOP length depends on the specifications of the playback device. The minimum
GOP length depends on the GOP pattern. For example, an IP pattern can have a length
as short as two frames.
Here are several examples of GOP length used in common MPEG formats:
• MPEG-2 for DVD: Maximum GOP length is 18 frames for NTSC or 15 frames for PAL.
These GOP lengths can be doubled for progressive footage.
• 1080-line HDV: Uses a long-GOP structure that is 15 frames in length.
• 720-line HDV: Uses a six-frame GOP structure.
• IMX: Uses only I-frames.
Open and Closed GOPs
An open GOP allows the B-frames from one GOP to refer to an I- or P-frame in an adjacent
GOP. Open GOPs are very efficient but cannot be used for features such as multiplexed
multi-angle DVD video. A closed GOP format uses only self-contained GOPs that do not
rely on frames outside the GOP.
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The same GOP pattern can produce different results when used with an open or closed
GOP. For example, a closed GOP would start an IBBP pattern with an I-frame, whereas an
open GOP with the same pattern might start with a B-frame. In this example, starting
with a B-frame is a little more efficient because starting with an I-frame means that an
extra P-frame must be added to the end (a GOP cannot end with a B-frame).
Open GOP
(IBBP, 15 frames)
P

B

B

I

B

B

P

B

B

P

B

B

P

B

B

P

B

B

I

:03

:04

:05

:06

:07

:08

:09

:10

:11

:12

:13

:14

:15

:16

:17

:18

:19

:20

:21

Closed GOP
(IBBP, 15 frames)
I

B

B

P

B

B

P

B

B

P

B

B

P

B

P

:04

:05

:06

:07

:08

:09

:10

:11

:12

:13

:14

:15

:16

:17

:18

MPEG Containers and Streams
MPEG video and audio data are packaged into discrete data containers known as streams.
Keeping video and audio streams discrete makes it possible for playback applications to
easily switch between streams on the fly. For example, DVDs that use MPEG-2 video can
switch between multiple audio tracks and video angles as the DVD plays.
Each MPEG standard has variations, but in general, MPEG formats support two basic kinds
of streams:
• Elementary streams: These are individual video and audio data streams.
• System streams: These streams combine, or multiplex, video and audio elementary
streams together. They are also known as multiplexed streams. To play back these
streams, applications must be able to demultiplex the streams back into their elementary
streams. Some applications only have the ability to play elementary streams.

MPEG-1
MPEG-1 is the earliest format specification in the family of MPEG formats. Because of its
low bit rate, MPEG-1 has been popular for online distribution and in formats such as Video
CD (VCD). DVDs can also store MPEG-1 video, though MPEG-2 is more commonly used.
Although the MPEG-1 standard actually allows high resolutions, almost all applications
use NTSC- or PAL-compatible image dimensions at quarter resolution or lower.
Common MPEG-1 formats include 320 x 240, 352 x 240 at 29.97 fps (NTSC), and 352 x 288
at 25 fps (PAL). Maximum data rates are often limited to around 1.5 Mbps. MPEG-1 only
supports progressive-scan video.
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MPEG-1 supports three layers of audio compression, called MPEG-1 Layers 1, 2, and 3.
MPEG-1 Layer 2 audio is used in some formats such as HDV and DVD, but MPEG-1 Layer
3 (also known as MP3) is by far the most common. In fact, MP3 audio compression has
become so popular that it is usually used independently of video.
MPEG-1 elementary stream files often have extensions such as .m1v and .m1a, for video
and audio, respectively.

MPEG-2
The MPEG-2 standard made many improvements to the MPEG-1 standard, including:
• Support for interlaced video
• Higher data rates and larger frame sizes, including internationally accepted standard
definition and high definition profiles
• Two kinds of multiplexed system streams—Transport Streams (TS) for unreliable network
transmission such as broadcast digital television, and Program Streams (PS) for local,
reliable media access (such as DVD playback)
MPEG-2 categorizes video standards into MPEG-2 Profiles and MPEG-2 Levels. Profiles
define the type of MPEG encoding supported (I-, P-, and B-frames) and the color sampling
method used (4:2:0 or 4:2:2 Y′CBCR). For example, the MPEG-2 Simple Profile (SP) supports
only I and P progressive frames using 4:2:0 color sampling, whereas the High Profile (HP)
supports I, P, and B interlaced frames with 4:2:2 color sampling.
Levels define the resolution, frame rate, and bit rate of MPEG-2 video. For example, MPEG-2
Low Level (LL) is limited to MPEG-1 resolution, whereas High Level (HL) supports
1920 x 1080 HD video.
MPEG-2 formats are often described as a combination of Profiles and Levels. For example,
DVD video uses Main Profile at Main Level (MP @ ML), which defines SD NTSC and PAL
video at a maximum bit rate of 15 Mbps (though DVD limits this to 9.8 Mbps).
MPEG-2 supports the same audio layers as MPEG-1 but also includes support for
multichannel audio. MPEG-2 Part 7 also supports a more efficient audio compression
algorithm called Advanced Audio Coding, or AAC.
MPEG-2 elementary stream files often have extensions such as .m2v and .m2a, for video
and audio, respectively.

MPEG-4
MPEG-4 inherited many of the features in MPEG-1 and MPEG-2 and then added a rich set
of multimedia features such as discrete object encoding, scene description, rich metadata,
and digital rights management (DRM). Most applications support only a subset of all the
features available in MPEG-4.

Appendix B Video Formats

1913

Compared to MPEG-1 and MPEG-2, MPEG-4 video compression (known as MPEG-4 Part
2) provides superior quality at low bit rates. However, MPEG-4 supports high-resolution
video as well. For example, Sony HDCAM SR uses a form of MPEG-4 compression.
MPEG-4 Part 3 defines and enhances AAC audio originally defined in MPEG-2 Part 7. Most
applications today use the terms AAC audio and MPEG-4 audio interchangeably.

MPEG-4 Part 10, or H.264
MPEG-4 Part 10 defines a high-quality video compression algorithm called Advanced Video
Coding (AVC). This is more commonly referred to as H.264. H.264 video compression works
similarly to MPEG-1 and MPEG-2 encoding but adds many additional features to decrease
data rate while maintaining quality. Compared to MPEG-1 and MPEG-2, H.264 compression
and decompression require significant processing overhead, so this format may tax older
computer systems.

Video Formats Supported by Final Cut Pro
Final Cut Pro supports any video format that uses an installed QuickTime codec. QuickTime
natively supports codecs used by a number of video devices, such as DV, DVCPRO 50,
DVCPRO HD, HDV, and IMX devices. With these formats, the distinction between file
format and tape format is blurred, and transferring from tape to hard disk or other media
is essentially a file transfer, allowing you to edit footage natively. For more information,
see Professional Formats and Workflows, available in Final Cut Pro Help.
When you work with videotape formats such as Digital Betacam, D-5, Betacam SP, and
so on, you need a third-party video interface to connect to the SDI or analog component
video connectors on the deck. In this case, the video interface must convert the incoming
or outgoing video signal to or from a QuickTime codec. Many video interfaces come with
codecs for high-quality compressed and uncompressed editing.

DV Formats
You can easily capture and output any DV-format video via the FireWire port on your
computer. Video, audio, timecode, and device control data are all transferred via a single
FireWire cable. FireWire (also referred to as IEEE 1394 or i.LINK) is a high-speed technology
for connecting and transmitting data to and from various external devices, such as video
and audio interfaces, hard disks, and digital cameras. FireWire is supported by many
professional and consumer-level DV camcorders and decks.
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Digital format

Maker

Color sample
ratio

Compression
ratio

Recorded bit rate

DV (25)

Multiple
manufacturers

4:1:1
4:2:0 (PAL)

5:1

25 Mbps

DVCAM

Sony

4:1:1
4:2:0 (PAL)

5:1

25 Mbps
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Color sample
ratio

Compression
ratio

Recorded bit rate

Panasonic

4:1:1 (NTSC and
PAL)

5:1

25 Mbps

DVCPRO 50

Panasonic

4:2:2

3.3:1

50 Mbps

DVCPRO HD

Panasonic

4:2:2

10:1

100 Mbps

Digital format

Maker

DVCPRO (D-7)

24p Video
Formats that capture complete (progressive) video frames at 24 frames per second have
received a lot of attention lately. This is because 24p video uses the same frame rate as
film, and it scans images progressively. For example, a 24 fps, 1920 x 1080, progressively
scanned video format closely matches the resolution of a 35 mm film theater distribution
print. For the first time since the invention of television, moviemakers can choose video
instead of film without suffering significant resolution loss or having to cope with
frame-rate conversions.
There are many ways to record 24p video within other frame rates. For more information,
see “Working with 24p Video.”

High Definition Video Formats
Final Cut Pro has native support for HD formats such as HDV, DVCPRO HD, and XDCAM
HD. For other HD formats, you need an appropriate third-party capture interface and hard
disks with sufficient speed and capacity. HD formats are often defined by their vertical
resolutions (number of lines), scanning method (interlaced versus progressive), and frame
or field rate. For example, 1080i60 HD video has 1080 lines per frame, uses interlaced
scanning (indicated by the i), and scans 60 fields per second.
Scanning Methods
Most HD equipment can record both progressive and interlaced video. Typically, 1080-line
video is interlaced (1080i) and 720-line video is progressive (720p). Several 1080p formats
exist, such as 1080p24, but there are no 720-line interlaced formats. For more information,
see “About Interlaced Scanning” and “About Progressive Scanning.”
Compressed High Definition Formats
Because of the high data rate generated by HD video cameras, most HD formats compress
the image data to fit on tape. For example:
• DVCPRO HD, also generally referred to as DV-100 (in reference to its video bit rate of
100 Mbps)
• D-9 HD, an extension of the Digital S format (Digital S is designated SMPTE D9)
• D-5 HD, an extension of the D-5 format
• HDCAM and HDCAM SR
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Format

Manufacturer

Color sample
ratio

D-5 HD

Panasonic

4:2:2

8-bit
10-bit

235 Mbps

D-6

Philips, Toshiba

4:2:2

10-bit

1.2 Gbps

HDCAM

Sony

3:1:1

8-bit (internal)
10-bit (in/out)

143 Mbps

HDCAM SR

Sony

4:2:2
4:4:4

10-bit log
10-bit linear

440 Mbps (SQ)
880 Mbps (HQ)

DVCPRO HD

Panasonic

4:2:2

8-bit

115 Mbps

XDCAM HD

Sony

4:2:0

8-bit

35 Mbps (HQ)
25 Mbps (SP)
18 Mbps (LP)

XDCAM HD422

Sony

4:2:2

8-bit

50 Mbps

HDV

Sony, JVC, Canon

4:2:0

8-bit

19 Mbps (720)
25 Mbps (1080)

RGB video

n/a (computer
graphics)

4:4:4

8 bits per color
channel

1.39 Gbps (1080)
1.24 Gbps (720)

• 1080p30
• 720p60

Bit depth

Recorded data
rate

Note: The data rates shown here are approximate. For purposes of determining hard disk
capacity for capture, carefully research the details of the format you are using.
Uncompressed High Definition Formats
HD requires extremely high data rates (around 1.4 Gbps). There are no camcorder formats
currently available for recording uncompressed HD video. High-capacity, general-purpose
digital tape formats like D-6 can be used in combination with camera heads and digital
telecine machines capable of outputting uncompressed RGB and component HD video
data. High-speed disk arrays can also be used to record uncompressed HD video.

Data Rate Comparisons
The following table is useful when preparing to capture video to a particular codec on
your hard disk.
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Format

Typical data rate

OfflineRT (using Photo JPEG)

Varies from 300-500 KB/sec.

25:1 compressed M-JPEG

1 MB/sec.

DV-25

3.6 MB/sec.

DVCPRO 50

7.2 MB/sec.

2:1 compressed M-JPEG

12 MB/sec.

Uncompressed SD video

24 MB/sec.
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Format

Typical data rate

Uncompressed 8-bit 1080i
29.97 fps HD video

124 MB/sec.

Uncompressed 10-bit 1080i
29.97 fps HD video

166 MB/sec.

Note: For information on data rates in Apple ProRes variants and in digital cinema formats
such as REDCODE, see Professional Formats and Workflows, available in Final Cut Pro Help.
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Appendix

Frame Rate and Timecode

This appendix covers the following:
• What Is Frame Rate? (p. 1919)
• Understanding Flicker and Perceived Frame Rate (p. 1920)
• How Many Frames per Second Is Best? (p. 1921)
• Choosing a Frame Rate (p. 1922)
• What Is Timecode? (p. 1924)
• About Drop Frame and Non-Drop Frame Timecode (p. 1924)
• Timecode on Tape (p. 1927)
• Comparison of Various Timecode Formats (p. 1928)
This appendix explains the concepts behind frame rate, frame rate limits, and timecode
and compares various timecode formats.

What Is Frame Rate?
Think of a motion picture camera as a relentless still camera, taking many still photographs
every second. Movies create the illusion of motion by showing still images in rapid
succession. The number of images photographed per second is referred to as the frame
rate of the movie and is measured in frames per second (fps). Frame rate describes both
the speed of recording and the speed of playback. The more frames recorded per second,
the more accurately motion is documented onto the recording medium.
Recording and playback speed are usually the same, though they do not have to be. For
example, if you film a rubber ball bouncing on a sidewalk at 24 frames per second, your
movie will have 24 unique photographs of the position of the ball. However, if you film
at 100 frames per second, there are nearly four times as many photographs of the ball’s
position during the same period of time. The more frames per second, the more precisely
the exact position of the ball is documented.
Note: If you play back frames at a speed different from the original recording speed, you
can create temporal effects such as time lapse and slow motion.
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Early television systems selected frame rates based on local electrical standards to avoid
electrical interference with the picture. NTSC in North America uses 30 fps (now adjusted
to 29.97 fps for color NTSC) based on 60 Hz electrical power. PAL, used primarily in Europe,
uses 25 fps based on 50 Hz electrical mains.
Because film cameras are relatively simple compared to video cameras, they allow shooting
and playing back with a wide range of frame rates (although the standard projection
speed is 24 fps). Video formats are much less flexible, partly because of their electronic
complexity and partly because a television is designed to play video at only one frame
rate. However, as video technology evolves, many digital camcorders now offer several
frame rate choices while maintaining compatibility with existing NTSC and PAL video
systems.

60 fps
One second

24 fps

Understanding Flicker and Perceived Frame Rate
Movie screens are not constantly illuminated, although when you watch a movie in the
theater, it appears that this is the case. A film projector’s shutter actually blocks the light
to the screen when each frame advances, but your eyes momentarily retain the image
until the shutter opens again (thanks to persistence of vision).
When you close your eyes, there is a brief moment when you can still see what you were
looking at, especially if what you were looking at is quite bright compared to the
surrounding environment. This persistence of vision is so brief that you may not be
consciously aware of it, but it is this phenomenon that allows us to believe that rapidly
changing still images are moving continuously.
However, the higher the frame rate, the more film you need, the faster the projector must
operate, or the more electronic bandwidth you need (in the case of video). Early audience
perception tests with movies demonstrated that increasing the rate of flicker increased
the perception of smooth motion, even if the images themselves were not changing
during every single flicker. The perceived frame rate (or flicker rate) can be increased by
opening and closing the projector’s shutter two or three times for each film frame, creating
a less noticeable flicker onscreen. Therefore, even though movies are universally shown
at 24 fps, the projector’s shutter may open and close at 48 fps, or perhaps higher.
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Early television systems used a different approach for the same result: increased flicker
without increasing the necessary electronic bandwidth. Interlaced scanning fills a television
frame with only half the video lines of a frame (this is known as a field), and then fills in
the remaining lines (the other field). A field effectively fills the television screen with an
image, even though it is only half-resolution, and it does so in half the time it would take
to draw the full frame. The result is a perceived frame rate which is double the actual
frame rate. For NTSC, the frame rate is 29.97 fps, but the perceived frame rate (the field
rate) is 59.94 fps. This causes less flicker. PAL, which has a lower frame rate of 25 fps (or
50 fields per second) has a slightly more noticeable flicker.

How Many Frames per Second Is Best?
When recording an object in motion, there are practical reasons to limit the camera frame
rate:
• The limit of human perception: There is no reason to show more frames per second than
the viewer can perceive. The exact limit of human motion perception is still up for
scientific debate, but it is generally agreed that there is an upper threshold after which
people can’t appreciate the difference.
• Media cost and size: Film and videotape stock cost money. Higher frame rates require
more footage and are more expensive to shoot. Editing and media management
become more difficult as the amount of raw media increases.

Recording High Frame Rates for Slow-Motion Effects
Despite the increased cost and effort, there are cases where shooting higher frame rates
is useful. Slow-motion effects are created by recording hundreds of frames per second
and then playing the same frames back at a slower rate. For example, a bullet shattering
a light bulb may take only a fraction of second, seeming almost instantaneous to anyone
watching. If a camera records the light bulb a thousand times per second and then a
projector plays the frames back at 24 fps, the movie onscreen will take almost 40 times
as long (1000 fps ÷ 24 fps = 41.6 seconds). The higher the frame rate, the more temporal
(time) resolution your footage has, which means it can be slowed down to show detailed
moments that would otherwise be a blur. Shooting at high frame rates also requires more
light, because there is less time to expose each frame.

Recording Slow Frame Rates for Time-Lapse Photography
Slow frame rates are used for time-lapse photography, in which a scene is recorded
relatively slowly, perhaps one frame every second, hour, or day. This is useful when you
are trying to capture gradually changing events, such as growing plants, the movement
of clouds, or the rising and setting of the sun. When played back at standard frame rates,
events occur rapidly onscreen and otherwise undetectable patterns emerge.
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Stop-motion photography, traditional drawn animation, and computer rendering take a
similar approach. The point here is that the rate of creating a frame does not necessarily
correspond to the rate of playback. This is one of the most exciting propositions of motion
pictures and their ability to manipulate time: you can create images at whatever rate suits
you and play them back at a totally different speed.

Examples of How Different Frame Rates Are Used
Film is especially flexible in that it can be photographed and played back with a diverse
range of speeds. Some examples are:
• 1 frame per hour: Extreme time-lapse photography.
• 1 frame per minute: Time-lapse photography and stop-motion animation.
• 18 frames per second: Early motion picture films.
• 24 frames per second: Worldwide standard for movie theater film projectors.
• 48 frames per second: Slow-motion photography (because it takes twice as long to play
back in a 24 fps projector, the motion is twice as slow).
• 300+ frames per second: High-speed cameras for very slow-motion photography (often
used for miniatures to make models seem larger on screen).
• 2500+ frames per second: Very high-speed cameras for special effects such as pyrotechnic
photography and explosions.

Choosing a Frame Rate
Movies on film are almost exclusively projected at 24 fps. Television, however, does not
have an internationally accepted frame rate. In Europe and many other countries, PAL
and SECAM use 25 fps, whereas NTSC video in North America and Japan uses 29.97 fps.
Other common frame rates are usually multiples of these.
Note: Converting video formats from one frame rate to another is technically challenging,
and there are often unwanted visual side effects. This is especially true when the frame
rates do not evenly divide. For example, converting 30 fps to 60 fps is fairly easy to do,
but converting 29.97 fps to 25 fps is much more difficult. Making sure audio stays in sync
throughout the conversion is yet another challenge.
Some digital video formats support several frame rates within a single format, allowing
variable frame rate video recording and film (24 fps) compatibility.
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Frame rate

Media

Description

24 fps

Film; high definition
video

This is the universally accepted film frame rate.
Movie theaters worldwide almost always use this
frame rate. Many high definition formats can
record and play back video at this rate, though
23.98 is usually chosen instead (see below).
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Frame rate

Media

Description

23.98 (23.976) fps

Film; high definition
video with NTSC
compatibility; NTSC

This is 24 fps slowed down by 99.9% (1000/1001)
to easily transfer film to NTSC video. Many high
definition video formats (and some SD formats)
can record at this speed, and it is usually preferred
over true 24 fps because of NTSC compatibility.

25 fps

PAL; high definition
video

The European video standard. Film is sometimes
shot at 25 fps when destined for editing or
distribution on PAL video.

29.97 fps

NTSC; high definition
video

This has been the color NTSC video standard since
1953. This number is sometimes inaccurately
referred to as 30 fps.

30 fps

High definition video;
early black-and-white
NTSC video

Some high definition cameras can record at 30 fps,
as opposed to 29.97 fps. Before color was added
to NTSC video signals, the frame rate was truly
30 fps. However, this format is almost never used
today.

50 fps

PAL; high definition
video

This refers to the interlaced field rate (double the
frame rate) of PAL. Some 1080i high definition
cameras can record at this frame rate.

59.94 fps

High definition video
with NTSC compatibility

High definition cameras can record at this frame
rate, which is compatible with NTSC video. It is
also the interlaced field rate of NTSC video. This
number is sometimes referred to as 60 fps, but it
is best to use 59.94 fps unless you really mean
60 fps.

60 fps

High definition video

High definition equipment can often play and
record at this frame rate, but 59.94 fps is much
more common because of NTSC compatibility.

Important: Many people round 29.97 fps to 30 fps, but this can lead to confusion during
post-production. Today, it is still very rare to use a frame rate of 30 fps, but very common
to use 29.97 fps. When in doubt, ask people to clarify whether they really mean 30 fps,
or if they are simply rounding 29.97 fps for convenience.
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What Is Timecode?
Timecode is a signal recorded with your video that uniquely identifies every frame of
your tape using a time stamp in hours, minutes, seconds, and frames. Timecode uses the
following format:
SMPTE timecode

01:32:15:28
Hours

Minutes

Seconds

Frames

Timecode was invented in the late 1960s so that computer video editing systems could
automatically find specific frames on tape and record editing decisions that could then
be performed over and over again. The Society of Motion Picture and Television Engineers
(SMPTE) standardized several electronic timecode formats for video in 1967.
Note: Other types of address code, such as keycode and ink numbers, are used for editing
film. For more information, see the documentation that came with Cinema Tools.

About Drop Frame and Non-Drop Frame Timecode
NTSC video (black-and-white) originally had a frame rate of 30 fps, so the timecode
counted at 30 fps. However, NTSC color video (the only kind of NTSC video in use today),
has a frame rate of 29.97 fps. This subtle difference between 30 fps and 29.97 fps seems
practically negligible and, in many cases, ignoring this discrepancy is fine. But not always.
What editors needed, especially in expensive broadcast markets, was timecode that
accurately reflected the exact duration of a program on tape.
There are two types of 30 fps timecode for use with NTSC video: non-drop frame and
drop frame. Non-drop frame timecode is simple: for every frame of video, there is a
corresponding timecode number. The timecode increments without any compensation.
In almost all cases, timecode is non-drop frame. In fact, drop frame timecode only matters
in the case of NTSC video.
Drop frame timecode compensates for the fact that the NTSC format has a frame rate of
29.97 fps, which is .03 fps slower than the nearest whole number frame rate of 30 fps.
Timecode can only be represented by whole numbers, so timecode numbers are
periodically skipped in drop frame timecode. This way, the timecode number always
matches the seconds and minutes of video that have played. NTSC can use either drop
frame or non-drop frame timecode.
Important: No video frames are dropped when you use drop frame timecode. Only the
associated timecode numbers are skipped.
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You can think of drop frame timecode as being like leap years on the calendar. In the
case of leap years, an extra day is added every 4 years except when the year is divisible
by 400. This compensates for the fact that the way days are measured and the way years
are measured do not align exactly. Even though the difference is slight, an unacceptable
error accumulates over time unless regular adjustments are made to the count.

More About Drop Frame Timecode and the NTSC Frame Rate
NTSC video has a frame rate of 29.97 fps, but the timecode counts at 30 fps. To better
understand this subtle distinction, remember that the main purpose of timecode is to
uniquely label and address each video frame, not to tell time (another name for timecode
is address code).
Consider what it would be like if frames were labeled a different way, without any reference
to time. For example, if each frame had a unique address coded with five letters of the
alphabet, starting at AAAAA, AAAAB, AAAAC, and so on until ZZZZZ, editors would refer
to shots and scenes by their individual five-letter codes. A director requesting a particular
shot could look in the log notes and tell the editor to find frame ABAAA on a particular
tape.
On tape or disk, each frame lasts 1/29.97 of a second. Since there is an address affixed to
each frame, the timecode moves at the same rate as the video (29.97 fps).
Now, instead of using a five-letter code to uniquely tag each frame, consider using an
address code in the format 00:00:00:00. Remember that these numbers don’t reflect time;
they are simply unique identifiers. The first frame of NTSC video is labeled 00:00:00:00.
The 29th frame is labeled 00:00:00:29, and the 30th frame is labeled 00:00:01:00. Again,
just because a frame is labeled 00:00:01:00 does not mean that 1 second has passed. The
frame could just as easily have been named AAABD, in which case there would be no
temptation to read the label as a time value. Only the frame rate of the video can
determine how much time has passed by the 30th frame. In the case of NTSC video,
0.999 seconds have passed by frame 30. By frame 1800, 60.06 seconds have passed.

Frame count

Timecode labels
(30 fps)

Time passed
(29.97 fps)

Error between
timecode number and
real time

0

0

0

0

1

1/30 of a second

1/29.97 of a second

Negligible

30

= 30/30 of a second
= 1 second

= 30/29.97 of a second
= 1.001 seconds

0.001 seconds

60

= 60/30 of a second
= 2 seconds

= 60/29.97 of a second
= 2.002 seconds

0.002 seconds
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Error between
timecode number and
real time

Timecode labels
(30 fps)

Time passed
(29.97 fps)

1800

1800/30 of a second
= 60 seconds
= 1 minute

=1800/29.97 of a
second
= 60.06 seconds
= 1.001 minutes

0.001 minutes
0.06 seconds
1.8 frames

18,000

= 18,000/30 of a second
= 600 seconds
= 10 minutes

= 18,000/29.97 of
second
= 600.6 seconds
= 10.01 minutes

0.01 minutes
0.6 seconds
17.9 frames

108,000

= 108,000/30 of a
second
= 3600 seconds
= 1 hour

=108,000/29.97 of a
second
= 3603.6 seconds
= 1.001 hours

0.001 hours
3.6 seconds
107.89 frames

Frame count

If you edit an hour-long program on NTSC video, the 30 fps timecode indicates that the
last frame of the program is frame 108,000, labeled as timecode 01:00:00:00 (non-drop
frame). However, the table above shows that because the video actually runs at 29.97 fps
(each frame is slightly longer than if it were running at 30 fps), 1 hour has actually passed
at frame 107,892 (3.6 seconds earlier than the 30 fps timecode shows). What editors
wanted, particularly in television environments, was a method of frame addressing that
accurately reflected how much time had passed.
Drop frame timecode was invented to compensate for the discrepancy between 29.97
and 30 fps. Every minute except each tenth minute, two timecode numbers are dropped
from the timecode count. This drop frame mode of 30 fps timecode remains accurate
compared to the actual time passed, with a strange side effect that two numbers each
minute vanish from the count.

The Difference Between Frame Rate and Timecode
The frame rate of your film or video describes how rapidly frames are photographed or
played back. It refers to the physical speed of image capture and playback. Timecode is
merely a method of labeling frames with unique identifiers to easily find them again later.
It is a convenient way of giving each frame a name that can be referred to later without
having to verbally describe and visually search for it. Even though frame rate and timecode
are independent, people commonly confuse the two, which can lead to frustrating
problems in post-production. Before you start a project, be certain that you understand
the difference between these two terms.
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Timecode on Tape
There are several kinds of timecode recorded on videotape, each stored in a different
part of the video signal. LTC is stored as an audio signal, whereas VITC is stored in a line
of each video frame.
• LTC (longitudinal timecode): Is typically recorded as an audio signal on a dedicated
timecode track. You can add or change LTC on your original tapes even after they’ve
been recorded because it’s recorded on its own independent track. LTC is also used
with professional audio formats, such as DAT and other multitrack audio recorders.
Because LTC is audio, it can be interpreted by a timecode reader even when the tape
is fast-forwarding, but it can’t be read when the tape is paused or moving extremely
slowly.
• VITC (vertical interval timecode): Is recorded as part of the video signal, using several
video lines that are normally masked by consumer televisions. You can see VITC as a
series of white dots at the top of the video frame if you view the video on a professional
monitor in underscan mode. Because VITC is part of the video signal, it can only be
changed on your original tapes if you also replace the video itself, which is rarely
worthwhile. The VITC part of the video signal is not captured as part of a Final Cut Pro
clip’s video frame, but VITC can be captured directly from the device control connection.
Because VITC is part of the video signal, which most decks can show in slow motion
or even when paused, VITC can be read at very slow speeds, but it breaks up when
fast-forwarding or rewinding.
Most timecode readers can automatically switch between LTC and VITC if they are both
available. In Final Cut Pro, you can choose this setting in your device control preset:
LTC+VITC. If you choose this setting, Final Cut Pro looks at both types of timecode so that
accurate timecode can be read no matter what speed the tape is playing (LTC is used for
normal and high-speed playback; VITC is used for slow motion and pause).
LTC is most easily read when a deck is in fast-forward, and VITC is most easily read when
a deck is in slow motion. Most professional video decks can read both signals and
automatically send timecode from the one that’s clearest at any moment. The LTC and
VITC signals on most tapes are almost always identical.
Important: Video decks capable of reading both LTC and VITC usually have a switch that
lets you select whether a deck outputs one or the other, or both. Unless the VITC and LTC
signals on your tape don’t match for some reason, leave this switch set to both.
Unlike DV and professional video formats, analog tape formats don’t always have timecode
written onto them. If you’re using S-VHS or Hi-8, you need to make sure that you’re using
a device-controllable deck and, if your tapes don’t already have timecode on them, that
you post-stripe timecode onto them. For information on how to do this, see the
documentation that came with your video deck.
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Comparison of Various Timecode Formats
This table compares 24 fps, 25 fps, 30 fps non-drop frame (NDF), and 30 fps drop frame
(DF) timecode. Standard 35 mm and 16 mm feet and frame counts are also shown. Note
how the drop frame timecode numbers jump by 2 frames starting between frame count
1799 and 1800.
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Frame
count

24 frames
per 1:00

25 frames
per 1:00

30 frames
per 1:00
(NDF)

30 frames
per 1:00
(DF)

16 frames
per foot
(35 mm)

40 frames
per foot
(16 mm)

1770

00:01:13:18

00:01:10:20

00:00:59:00

00:00:59:00

0110+10

0282+38

1771

00:01:13:19

00:01:10:21

00:00:59:01

00:00:59:01

0110+11

0282+39

1772

00:01:13:20

00:01:10:22

00:00:59:02

00:00:59:02

0110+12

0283+00

1773

00:01:13:21

00:01:10:23

00:00:59:03

00:00:59:03

0110+13

0283+01

1774

00:01:13:22

00:01:10:24

00:00:59:04

00:00:59:04

0110+14

0283+02

1775

00:01:13:23

00:01:11:00

00:00:59:05

00:00:59:05

0110+15

0283+03

1776

00:01:14:00

00:01:11:01

00:00:59:06

00:00:59:06

0111+00

0285+00

1777

00:01:14:01

00:01:11:02

00:00:59:07

00:00:59:07

0111+01

0285+01

1778

00:01:14:02

00:01:11:03

00:00:59:08

00:00:59:08

0111+02

0285+02

1779

00:01:14:03

00:01:11:04

00:00:59:09

00:00:59:09

0111+03

0285+03

1780

00:01:14:04

00:01:11:05

00:00:59:10

00:00:59:10

0111+04

0285+04

1781

00:01:14:05

00:01:11:06

00:00:59:11

00:00:59:11

0111+05

0285+05

1782

00:01:14:06

00:01:11:07

00:00:59:12

00:00:59:12

0111+06

0285+06

1783

00:01:14:07

00:01:11:08

00:00:59:13

00:00:59:13

0111+07

0285+07

1784

00:01:14:08

00:01:11:09

00:00:59:14

00:00:59:14

0111+08

0285+08

1785

00:01:14:09

00:01:11:10

00:00:59:15

00:00:59:15

0111+09

0285+09

1786

00:01:14:10

00:01:11:11

00:00:59:16

00:00:59:16

0111+10

0285+10

1787

00:01:14:11

00:01:11:12

00:00:59:17

00:00:59:17

0111+11

0285+11

1788

00:01:14:12

00:01:11:13

00:00:59:18

00:00:59:18

0111+12

0285+12

1789

00:01:14:13

00:01:11:14

00:00:59:19

00:00:59:19

0111+13

0285+13

1790

00:01:14:14

00:01:11:15

00:00:59:20

00:00:59:20

0111+14

0285+14

1791

00:01:14:15

00:01:11:16

00:00:59:21

00:00:59:21

0111+15

0285+15

1792

00:01:14:16

00:01:11:17

00:00:59:22

00:00:59:22

0112+00

0285+16

1793

00:01:14:17

00:01:11:18

00:00:59:23

00:00:59:23

0112+01

0285+17

1794

00:01:14:18

00:01:11:19

00:00:59:24

00:00:59:24

0112+02

0285+18

1795

00:01:14:19

00:01:11:20

00:00:59:25

00:00:59:25

0112+03

0285+19

1796

00:01:14:20

00:01:11:21

00:00:59:26

00:00:59:26

0112+04

0285+20

1797

00:01:14:21

00:01:11:22

00:00:59:27

00:00:59:27

0112+05

0285+21
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Frame
count

24 frames
per 1:00

25 frames
per 1:00

30 frames
per 1:00
(NDF)

30 frames
per 1:00
(DF)

16 frames
per foot
(35 mm)

40 frames
per foot
(16 mm)

1798

00:01:14:22

00:01:11:23

00:00:59:28

00:00:59:28

0112+06

0285+22

1799

00:01:14:23

00:01:11:24

00:00:59:29

00:00:59:29

0112+07

0285+23

1800

00:01:15:00

00:01:12:00

00:01:00:00

00:01:00:02

0112+08

0287+20

1801

00:01:15:01

00:01:12:01

00:01:00:01

00:01:00:03

0112+09

0287+21

1802

00:01:15:02

00:01:12:02

00:01:00:02

00:01:00:04

0112+10

0287+22

1803

00:01:15:03

00:01:12:03

00:01:00:03

00:01:00:05

0112+11

0287+23

1804

00:01:15:04

00:01:12:04

00:01:00:04

00:01:00:06

0112+12

0287+24

1805

00:01:15:05

00:01:12:05

00:01:00:05

00:01:00:07

0112+13

0287+25

1806

00:01:15:06

00:01:12:06

00:01:00:06

00:01:00:08

0112+14

0287+26

1807

00:01:15:07

00:01:12:07

00:01:00:07

00:01:00:09

0112+15

0287+27

1808

00:01:15:08

00:01:12:08

00:01:00:08

00:01:00:10

0113+00

0287+28

1809

00:01:15:09

00:01:12:09

00:01:00:09

00:01:00:11

0113+01

0287+29

1810

00:01:15:10

00:01:12:10

00:01:00:10

00:01:00:12

0113+02

0287+30

1811

00:01:15:11

00:01:12:11

00:01:00:11

00:01:00:13

0113+03

0287+31

1812

00:01:15:12

00:01:12:12

00:01:00:12

00:01:00:14

0113+04

0287+32

1813

00:01:15:13

00:01:12:13

00:01:00:13

00:01:00:15

0113+05

0287+33

1814

00:01:15:14

00:01:12:14

00:01:00:14

00:01:00:16

0113+06

0287+34

1815

00:01:15:15

00:01:12:15

00:01:00:15

00:01:00:17

0113+07

0287+35

1816

00:01:15:16

00:01:12:16

00:01:00:16

00:01:00:18

0113+08

0287+36

1817

00:01:15:17

00:01:12:17

00:01:00:17

00:01:00:19

0113+09

0287+37

1818

00:01:15:18

00:01:12:18

00:01:00:18

00:01:00:20

0113+10

0287+38

1819

00:01:15:19

00:01:12:19

00:01:00:19

00:01:00:21

0113+11

0287+39

1820

00:01:15:20

00:01:12:20

00:01:00:20

00:01:00:22

0113+12

0288+00

1821

00:01:15:21

00:01:12:21

00:01:00:21

00:01:00:23

0113+13

0288+01

1822

00:01:15:22

00:01:12:22

00:01:00:22

00:01:00:24

0113+14

0288+02

1823

00:01:15:23

00:01:12:23

00:01:00:23

00:01:00:25

0113+15

0288+03

1824

00:01:16:00

00:01:12:24

00:01:00:24

00:01:00:26

0114+00

0290+00

1825

00:01:16:01

00:01:13:00

00:01:00:25

00:01:00:27

0114+01

0290+01

1826

00:01:16:02

00:01:13:01

00:01:00:26

00:01:00:28

0114+02

0290+02

1827

00:01:16:03

00:01:13:02

00:01:00:27

00:01:00:29

0114+03

0290+03

1828

00:01:16:04

00:01:13:03

00:01:00:28

00:01:01:00

0114+04

0290+04

1829

00:01:16:05

00:01:13:04

00:01:00:29

00:01:01:01

0114+05

0290+05

1830

00:01:16:06

00:01:13:05

00:01:01:00

00:01:01:02

0114+06

0290+06
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1929

1930

Frame
count

24 frames
per 1:00

25 frames
per 1:00

30 frames
per 1:00
(NDF)

30 frames
per 1:00
(DF)

16 frames
per foot
(35 mm)

40 frames
per foot
(16 mm)

1831

00:01:16:07

00:01:13:06

00:01:01:01

00:01:01:03

0114+07

0290+07

1832

00:01:16:08

00:01:13:07

00:01:01:02

00:01:01:04

0114+08

0290+08

1833

00:01:16:09

00:01:13:08

00:01:01:03

00:01:01:05

0114+09

0290+09

1834

00:01:16:10

00:01:13:09

00:01:01:04

00:01:01:06

0114+10

0290+10

1835

00:01:16:11

00:01:13:10

00:01:01:05

00:01:01:07

0114+11

0290+11

1836

00:01:16:12

00:01:13:11

00:01:01:06

00:01:01:08

0114+12

0290+12
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Appendix

Working with 24p Video

This appendix covers the following:
• What Is 24p Video? (p. 1931)
• Telecine, Pull-Down, and Reverse Telecine (p. 1932)
• Film, 24p Video, and Cinema Tools (p. 1942)
• Working with 24p NTSC Video (p. 1942)
• Using an AG-DVX100 NTSC Camcorder with Advanced Pull-Down (p. 1943)
This appendix provides information about working with 24p video.

What Is 24p Video?
The term 24p refers to 24 fps progressive-scan video. For film, this is nothing unusual, but
for video, both progressive scanning and the 24 fps frame rate are still exciting new
territory. Instead of building 24 fps video cameras that would be incompatible with
established NTSC and PAL video equipment, some new camcorders make it possible to
shoot 24p video while maintaining backward compatibility with NTSC or PAL equipment.
Some reasons to shoot 24p footage are:
• To make it easy to transfer your video to film without any frame rate conversions
• To achieve a “film look” on video, even though film was never used
• To use 24p footage as a convenient intermediate format for moving between NTSC
video, PAL video, and film
• To capture at a lower data rate than 25, 29.97, and 59.94 fps formats
Tip: When you shoot video at 24 fps, you need to avoid quick pans and tilts because they
may cause the image to stutter. This is common knowledge for film cinematographers,
but videographers new to 24 fps videography may not always be aware of this fact.

1931

24 Versus 23.98 fps
Although the term 24p implies 24 frames per second, the value 24 is usually inaccurate,
because most people working within NTSC standards actually shoot at a frame rate of
23.976 fps (commonly referred to as 23.98 fps). On the other hand, 24 fps footage
transferred to PAL, as well as most film, is recorded at exactly 24 fps.
Although it may be easier to say “24p,” keep in mind that in some cases, such as during
audio post-production, it’s critical to state the exact frame rate of your footage.

Telecine, Pull-Down, and Reverse Telecine
The following sections describe methods for embedding and extracting 24p video in
different formats. Some of these techniques are based on existing film-to-video methods,
and some are newer approaches. The basic technique for transferring film to video, called
telecine, uses a process called pull-down to map 23.98 fps film to 29.97 fps interlaced
video. Once the video is captured on disk, software can perform reverse telecine, or
reverse pull-down, to restore the original 23.98 fps film frame rate.
In progressive digital video systems such as 720p60 DVCPRO HD video, a similar process
can be performed in-camera to map 23.98 fps to 59.94 fps, but entire frames are duplicated
instead of fields. During or after capture, the duplicate frames are removed. A camcorder
or deck that performs duplicate frame insertion can add metadata (known as flags) that
inform software when to remove or ignore duplicate frames.
Note: Pull-down refers to the addition or removal of fields, not duplicate frames.

Standard 3:2 Pull-Down
Also known as 2:3:2:3 pull-down, this is the standard telecine method of transferring film
to NTSC video. The film is slowed by 0.1 percent (a factor of 1000/1001) from 24 fps to
23.98 fps, and then each film frame is transferred to interlaced video in a repeating 2:3:2:3
field pattern.

1932
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In the illustration below, film frames A, B, and D are mapped to video frames 1, 2, and 5.
However, because film frame C is split into two fields across video frames 3 and 4,
pull-down removal requires deinterlacing, which is more processor-intensive than removal
of pull-down patterns such as advanced (2:3:3:2) pull-down. Pull-down removal typically
requires manual identification of the A frame in the pattern, which you can identify visually
by moving frame by frame through your footage until you recognize the pull-down
pattern.
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A

B

A A B

B

Field Field Field
1
2
1

Field
2

C
B

C

C

D
D D D

Field Field Field Field Field Field
1
2
1
2
1
2

3:2 Pull-Down
Before (23.98 fps)

A

B C D A B C D A B C D A B C D A B C D A B

C D

A A B B B C C DDD A A B B B C C D DD A A B B B C C DD D A A B B B C C DD D A A B B B C CDDD A A B B B C CDDD

After (29.97 fps)
One second
3:2 Pull-Down Removal
Before (29.97 fps)
A A B B B C C DDD A A B B B C C D DD A A B B B C C DD D A A B B B C C DD D A A B B B C CDDD A A B B B C CDDD

A

B C D A B C D A B C D A B C D A B C D A B

After (23.98 fps)

A A B

B B

Field Field Field
1
2
1

Field Field
2
1

A

1934
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B

C

C

D D D

Field Field Field Field Field
2
1
2
1
2

C

D

C D

If you edit 3:2 pull-down footage without removing the pull-down first, you need to be
particularly careful to match the five-frame pull-down cadence at every edit. Edits with
broken cadence, such as a repeating or out-of-order frame (for example, A, B, A, B, C, D)
can confuse reverse telecine operations. In general, you should avoid editing 29.97 fps
pull-down footage. Instead, remove the pull-down of your footage first, edit at 23.98 fps,
then reinsert pull-down during output.
Several NTSC and 1080i60 HD camcorders can record using standard pull-down, though
advanced pull-down is usually recommended when recording 24p video. However, for
final playback on television or DVD, 3:2 pull-down is generally considered to have the
most acceptable quality of motion.
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2:3:3:2 Advanced Pull-Down
Camcorders such as the Panasonic AG-DVX100, the Panasonic AG-HVX200, and the Canon
XL2 use this method to store 23.98 fps video within interlaced 29.97 fps footage. Video
frames 1, 2, 4, and 5 in the pull-down pattern represent film frames A, B, C, and D.
Removing advanced pull-down is more efficient than removing standard 2:3:2:3 pull-down
because no deinterlacing is required. To remove advanced pull-down, video frame 3 in
the five-frame pattern is simply discarded during capture or ignored during playback.

1936
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A

B

A A B

B

Field Field Field
1
2
1

Field
2

C
B

C

C

D
C D D

Field Field Field Field Field Field
1
2
1
2
1
2

2:3:3:2 Pull-Down
Before (23.98 fps)

A

B C D A B C D A B C D A B C D A B C D A B

C D

A A B B B C C C DD A A B B B C C C DD A A B B B C C C D D A A B B B C C CD D A A B B B C C C DD A A B B B C C C DD

After (29.97 fps)
One second
2:3:3:2 Pull-Down Removal
Before (29.97 fps)
A A B B B C C C DD A A B B B C C C DD A A B B B C C C D D A A B B B C C CD D A A B B B C C C DD A A B B B C C C DD

A

B C D A B C D A B C D A B C D A B C D A B

C D

After (23.98 fps)

A A B

B B

Field Field Field
1
2
1

Field Field
2
1

A
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B

C C
Field
2

Field
1

C

C D D
Field Field
2
1

Field
2

D
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Another feature that makes advanced pull-down removal more efficient is the insertion
of “flags” in the video signal that can be used by software to automatically detect which
frames must be removed. This makes advanced pull-down an automatic process compared
to the manual cadence identification usually required to remove 3:2 pull-down.
Despite its efficiencies, the advanced pull-down pattern is not as aesthetically pleasing
as 3:2 pull-down. If you plan to finish your project at 23.98 fps, advanced pull-down is
usually the best choice. However, if you plan to output your final 24p project to 29.97 fps
interlaced video, you may want to add 3:2 pull-down because its pattern is considered
to be more visually appealing.

2:2:2:4 Pull-Down
This is an efficient but low-quality playback option used for previewing 23.98 fps footage
on an NTSC monitor. Few systems can reverse this kind of pull-down, so you should never
record footage with this kind of pull-down. This option is available for situations when
processing power is at a premium and your system is unable to generate 2:3:2:3 pull-down
or advanced pull-down during playback.
2:2:2:4 Pull-Down
One second
Before (23.98 fps)

A

B C D A B C D A B C D A B C D A B C D A B

C D

A A B B C C D DDD A A B B C C DD DD A A B B C C DDD D A A B B C C D DD D A A B B C C DDDD A A B B C C DDDD

After (29.97 fps)

A

1938
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B

D A A B

B

Field Field Field Field
1
1
2
1

Field
2

C
C

D

C D D D D

Field Field Field Field Field Field
1
2
1
2
1
2

720p DVCPRO HD Duplicate Frames
720p DVCPRO HD camcorders can record 24 fps footage within a 60 fps signal by
duplicating frames. The duplicate frames are usually flagged within the DVCPRO HD video
signal so applications like Final Cut Pro can automatically remove them. You can also
remove duplicate frames using a frame rate converter (such as the DVCPRO HD Frame
Rate Converter in Final Cut Pro).
The duplicate frame pattern used in 720p24 footage is similar to the standard 3:2 NTSC
telecine pull-down pattern, but there is no interlacing because 720p video is progressively
scanned.
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Note: 720p footage is almost always 23.98 fps, but true 24 fps recording is also possible
on particular camcorders.

A
A A B

B
B

C
B

C

C

D
D D D

Duplicate Frame Insertion
Before (23.98 fps)

A

B C D A B C D A B C D A B C D A B C D A B

C D

A A B B B C C DDD A A B B B C C D DD A A B B B C C DD D A A B B B C C DD D A A B B B C CDDD A A B B B C CDDD

After (29.97 fps)
One second
Duplicate Frame Removal
Before (29.97 fps)
A A B B B C C DDD A A B B B C C D DD A A B B B C C DD D A A B B B C C DD D A A B B B C CDDD A A B B B C CDDD

A

B C D A B C D A B C D A B C D A B C D A B

After (23.98 fps)

A B B

A
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B
C C

B

C

C

C

C D D

D

C D

Progressive Segmented Frame Recording
Sony CineAlta cameras can record 23.98 or true 24 fps Progressive segmented Frame
(PsF) footage on HDCAM or HDCAM SR tape. The camera records at 48 fields per second
while each progressive frame is placed on two fields, resulting in 24 fps.
One second
1

2

3

4

5

6

7

8

9

10 11 12 13 14 15 16 17 18 19 20 21 22 23 24

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
Interlaced frames

24 @ 25
True 24 fps film or video can be transferred to PAL (25 fps) by speeding up the frame rate
by 4 percent. For film editing purposes on PAL video, applications like Cinema Tools can
slow the 25 fps PAL video back to 24 fps (a process called conforming) so that sync is
maintained with the original audio.
For showing film-originated movies on PAL video, both film and audio speed are increased
by 4 percent. The speed increase is considered acceptable, although the audio must be
“pitch shifted” down to match the original. This is the most common method for
film-to-PAL transfers.
One second
1

2

3

4

5

6

7

8

9

10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 24 fps

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 1
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 1

25 fps

First frame of next second

24 @ 25 Pull-Down
This method does not change the speed of the original film. Instead, film frames 12 and
24 are pulled down for a duration of three fields instead of two, creating a subtle stutter
each half second. This pattern is technically described as 2:2:2:2:2:2:2:2:2:2:2:3 pull-down.
One second
1

2

3

4

5

6

7

8

9

10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 24 fps

1 2 3 4 5 6 7 8 9 10 11 12 12 13 14 15 16 17 18 19 20 21 22 23 24
25 fps
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 24
Repeated field
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Repeated field

1941

24 @ 25 Repeat
This method simply repeats every 24th frame once to fit 24 fps footage into 25 fps. This
causes a noticeable stutter every second but requires less processing than the 24 @ 25
pull-down pattern because no special interlacing is required. This pull-down pattern is
analogous to the NTSC 2:2:2:4 pull-down pattern in the sense that it requires the least
amount of processing power but results in the most noticeable stutter. You should use
this option for preview purposes only and avoid it for final output.
One second
1

2

3

4

5

6

7

8

9

10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 24 fps

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 24
25 fps
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 24
Repeated frame

Native 24p
Some video camcorders that record to file-based media can record at 24 or 23.98 fps. For
example, the Panasonic AG-HVX200 can record 23.98 fps footage directly. Digital cinema
cameras such as the Panavision Genesis, the Dalsa Origin, and the RED ONE can record
natively at 24 fps. Of course, film is also recorded at 24 fps.
One second
1

2

3

4

5

6

7

8

9

10 11 12 13 14 15 16 17 18 19 20 21 22 23 24

Film, 24p Video, and Cinema Tools
Cinema Tools is used mainly to edit movies shot and finished on film, or whenever film
production techniques such as separate picture and sound recording are used. To make
editing cheaper and more convenient, NTSC or PAL telecine transfers are used as
intermediate digital editing formats. Cinema Tools can remove 3:2 pull-down from 29.97 fps
telecined video or conform 25 fps telecined video back to 24 fps so you can edit at the
proper frame rate. For more information, see “Working with Film and Cinema Tools.”

Working with 24p NTSC Video
Several camcorders have the ability to emulate the telecine process by exposing and
shuttering at 23.98 fps and then adding a 2:3:2:3 pull-down when the signal is recorded
to tape at 29.97 fps. The result is NTSC-compatible video that looks similar to a film-to-video
transfer.

1942
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Note: Even though the 2:3:2:3 pull-down pattern of a film-to-tape transfer is emulated
by this process, there are many other factors that contribute to a “film look,” such as
exposure, resolution, color, depth of field, and so on.
Most camcorders use a pull-down method referred to as advanced pull-down, which has
a 2:3:3:2 pattern instead of the traditional telecine 2:3:2:3 pull-down pattern. The advantage
of this pattern is that it is more efficient for digital devices or applications (such as
Final Cut Pro) to remove and introduce than the traditional 2:3:2:3 pull-down pattern.
In Final Cut Pro, you can remove the redundant fields during or after capture. Once the
redundant fields or frames are removed, you can edit at 23.98 fps. When you have finished
editing, you can output back to 29.97 fps NTSC video by reintroducing advanced pull-down
(2:3:3:2) or traditional 2:3:2:3 pull-down. If you are outputting to film or progressive-scan
video, you don’t need to add pull-down.
Note: 1080i60 footage also uses the same 2:3:2:3 and 2:3:3:2 pull-down patterns to record
24p footage.

Using an AG-DVX100 NTSC Camcorder with Advanced
Pull-Down
The workflow for capturing and outputting 24p video using the Panasonic AG-DVX100
NTSC camera is outlined below. Other NTSC camcorders that use this advanced pull-down
method can also follow this workflow.
• Stage 1: Shooting with Advanced Pull-Down
• Stage 2: Removing Advanced Pull-Down from 24p Video During Capture
• Stage 3: Editing at 23.98 fps
• Stage 4: Outputting to 29.97 fps Video with Advanced Pull-Down

Stage 1: Shooting with Advanced Pull-Down
To shoot with advanced pull-down (23.98 fps at 29.97 fps), choose the 24p advanced
pull-down option on your camera. This creates 29.97 fps NTSC video that contains 23.98 fps
progressive frames using a 2:3:3:2 pull-down pattern.

Stage 2: Removing Advanced Pull-Down from 24p Video During Capture
Choose or create a capture preset that has the “Remove Advanced Pulldown and/or
Duplicate During Capture From FireWire Sources” checkbox selected. This checkbox is
available when you edit a capture preset in the Capture Preset Editor window (accessible
from the Capture Presets tab of the Audio/Video Settings window).
Duplicate video fields are discarded during capture, resulting in a 24p (23.98 fps) media
file on disk after capture.
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If you have already captured your video at 29.97 fps, you can remove duplicate fields
from your media file after capture.

µ

To remove 2:3:3:2 advanced pull-down from your media files after capture
Select the 29.97 fps clips in the Browser, then choose Tools > Remove Advanced Pulldown.
Your media files remain the same size, but they are set to play back at 23.98 fps. If no
advanced pull-down flags are detected, the media file remains at 29.97 fps.

Stage 3: Editing at 23.98 fps
You can edit your footage in a 23.98 fps sequence. To preview your video on an external
NTSC monitor while you are editing, you can choose one of several pull-down options
to convert the 23.98 fps video to 29.97 fps. The 2:2:2:4 option is the least
processor-intensive, but it should only be used for previewing.
For more information about real-time pull-down options, see “Using RT Extreme.”

Stage 4: Outputting to 29.97 fps Video with Advanced Pull-Down
After you finish editing your movie, you can output back to 29.97 fps NTSC video by
introducing a pull-down pattern on the FireWire output. You can choose one of several
pull-down patterns, either from the RT pop-up menu in the Timeline or in the Playback
Control tab of the System Settings window. For output back to tape, you should choose
advanced pull-down (2:3:3:2), or normal telecine pull-down (2:3:2:3).
You can also export your movie to a 23.98 fps QuickTime movie or image sequence for
delivery to a video-to-film transfer lab.
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Appendix

Working with Anamorphic 16:9
Media

This appendix covers the following:
• About Anamorphic 16:9 Media (p. 1945)
• Recording Anamorphic Video (p. 1946)
• Capturing Anamorphic Media (p. 1947)
• Changing Clip Properties for Anamorphic Media (p. 1948)
• Viewing and Editing Anamorphic Media (p. 1949)
• Specifying Sequence Settings for Anamorphic Media (p. 1949)
• Outputting Anamorphic Video to Tape (p. 1950)
• Exporting 16:9 Anamorphic Video (p. 1950)
This appendix covers working with anamorphic 16:9 media and specifying sequence
settings and output procedures for anamorphic video.

About Anamorphic 16:9 Media
The term anamorphic refers to a distorted image that appears normal when viewed with
an appropriate lens. When shooting film or video, an anamorphic lens can be used to
squeeze a wide image onto a standard 4:3 aspect ratio frame. During projection or
playback, the image must be “unsqueezed,” stretching the image back to its original
aspect ratio.

Why Use 16:9 Anamorphic Video?
16:9 anamorphic video provides NTSC and PAL compatibility but removes the 4:3 aspect
ratio limitation. Anamorphic 16:9 video is becoming less common as high definition (HD)
video becomes affordable, offering native 16:9 aspect ratio and higher resolution. However,
HD video will not completely replace SD video for many years, so you may still find yourself
working with 16:9 anamorphic footage on occasion.
16:9 anamorphic video is used for three main reasons:
• For widescreen productions using SD equipment
• For film transfers to SD DVD to maintain the original film aspect ratio

1945

• To create SD footage whose aspect ratio is compatible with 16:9 HD footage or film

Displaying 16:9 Anamorphic Video
By default, 16:9 anamorphic video displayed on an SD monitor appears horizontally
squeezed—meaning images look tall and thin. Many computer applications, monitors,
and DVD players are capable of “unsqueezing” 16:9 anamorphic video so that the image
appears as intended.

About Letterboxing
When 16:9 video is displayed on an SD 4:3 monitor, you’ll see bars at the top and bottom
of the picture because a 16:9 image cannot entirely fill a 4:3 screen. This presentation
mode is called letterboxing and is often used synonymously with the term widescreen.
Widescreen video requires letterboxing only when displayed on a 4:3 display.

16:9 video letterboxed
in a 4:3 display

Letterboxing should be used only for displaying images—not recording them. For example,
you could easily mask the top and bottom of a 4:3 camera during recording to create
letterboxed 16:9 footage, but many video lines would be wasted this way, reducing video
resolution. Similarly, after you capture 16:9 anamorphic video, you should keep it in
anamorphic mode as long as possible and avoid letterboxing the footage unless you
have to. Even during export and output, there are many devices that can properly display
16:9 anamorphic footage. For example, most DVD players can stretch your footage when
connected to a 16:9 display or letterbox footage when connected to a 4:3 display.

Recording Anamorphic Video
Anamorphic video can be acquired in one of three ways.
• Using a camera with a 16:9 CCD: A charge-coupled device (CCD) is the element of a
video camera that actually takes the image after it comes through the lens and turns
it into an electronic image. Some SD camcorders have CCDs with a 16:9 aspect ratio,
so they actually capture full-resolution 16:9 video prior to squeezing the image
anamorphically for recording.
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• Using an anamorphic lens: An anamorphic lens is a wide-angle lens that optically
distorts the 16:9 image to fit into a 4:3 frame before sending it to your camcorder’s
CCD. Because this is done optically, the result is clean and clear and takes advantage
of the full resolution of the DV frame. This method is recommended by some for users
looking for the best possible quality.
If you use an anamorphic lens, the camera does not need to be in a special mode when
recording. In the camera’s viewfinder, the image appears stretched vertically; you should
be aware that the recorded clips will only look correct on an NTSC or PAL monitor with
a 16:9 setting, or in Final Cut Pro with the Anamorphic option selected.
• Using the 16:9 Wide button found on most camcorders: Although easy and inexpensive,
this method yields lower resolution than other methods. The camcorder crops the top
and bottom of the screen and then stretches this smaller widescreen image vertically
to fit the full 4:3 aspect ratio, producing the necessary anamorphic distortion before
recording the image to tape.
Many camcorders embed information in the video signal that indicates whether or not
it was recorded in 16:9 anamorphic mode. Final Cut Pro can read this information and
automatically capture and output the video in the correct mode.

Capturing Anamorphic Media
When you capture video, Final Cut Pro uses the settings in the currently selected capture
preset. If your footage was shot anamorphically, you can select the Anamorphic 16:9
option. For more information, see “General Settings for Capture Presets.”

Make sure this
checkbox is selected
if you’re capturing
16:9 media.

Some cameras embed an anamorphic “flag” in the video signal that indicates the aspect
ratio of your footage. For example, if you press the 16:9 Wide button on a camcorder, the
DV signal recorded on tape includes the 16:9 anamorphic “flag.” During capture,
Final Cut Pro detects this and marks the resulting clip as Anamorphic 16:9. This happens
regardless of whether or not the Anamorphic 16:9 option is selected in your current
capture preset.
Footage recorded with an anamorphic lens is not flagged as 16:9 anamorphic, so
Final Cut Pro does not automatically turn on the Anamorphic property for captured clips
recorded this way.
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Tip: If you forget to select the Anamorphic 16:9 option before you capture anamorphic
media, you can turn on the Anamorphic property for clips in the Browser or the Item
Properties window.

Changing Clip Properties for Anamorphic Media
If you’ve captured anamorphic media but didn’t use a capture preset that had the
Anamorphic option turned on, you can change the Anamorphic clip property in the Item
Properties window or in the Browser. Make sure you turn on the Anamorphic property
for all clips before you begin editing.
If you’ve already added a clip to a sequence, the clip settings default to the current
sequence settings. To change the clip’s settings, you must then change the sequence
settings. For more information, see “Specifying Sequence Settings for Anamorphic Media.”
To turn on the Anamorphic property for a clip
1 Open the clip from the Browser, then choose Edit > Item Properties > Format.
2 Click in the column next to the Anamorphic property so that a checkmark appears.

If your media is
anamorphic, make sure
there’s a checkmark in
this row.

The Anamorphic column in the Browser also lets you select this option for clips and
sequences.
A checkmark in this
column denotes
anamorphic media.
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Viewing and Editing Anamorphic Media
Final Cut Pro has the ability to display 16:9 anamorphic footage at the correct aspect ratio
while you edit. Generators and transitions such as the oval and star iris are also correctly
shaped, and all motion effects automatically take the 16:9 aspect ratio into account.
When you edit anamorphic 16:9 media, the following apply:
• All non-16:9 media added to a 16:9 sequence is scaled and distorted to match the
sequence.
• In the Viewer and Canvas, the default setting is “Show as Sq. Pixels” in the Zoom pop-up
menu. This properly adjusts anamorphic 16:9 content for viewing on the computer’s
display.
• Final Cut Pro sets the anamorphic “flag” in each DV frame rendered or played back.

Specifying Sequence Settings for Anamorphic Media
When you use 16:9 anamorphic media in a sequence, you need to select the Anamorphic
option in the Sequence Settings window. There are two ways you can do this:
• Choose a sequence preset that has the Anamorphic option turned on, then create a
sequence.
• Create a sequence, then turn on the Anamorphic option for that sequence.
Make sure you turn on the Anamorphic 16:9 option before you add any clips to your
sequence. If a 16:9 clip is edited into a 4:3 sequence, the clip is scaled to fit in the 4:3 frame,
causing the clip to be letterboxed. If the sequence is then changed to 16:9 without first
removing the edited clip, the Scale and Distort parameters applied to the clip still remain.
To turn on the Anamorphic option after you’ve created a sequence
1 Open the sequence in the Timeline.
2 Choose Sequence > Settings.
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3 Select the Anamorphic 16:9 checkbox, then click OK.

Select this checkbox
to turn on the
Anamorphic option.

Outputting Anamorphic Video to Tape
When outputting an edited sequence to tape using anamorphic video, you have two
choices, depending on what kind of equipment you want to play back from.
• Output as is, with the video appearing squeezed on a 4:3 monitor: This is the preferred
option if you’re planning to play back your video on a monitor that will compensate
for the proper aspect ratio, or if you’re planning to transfer to film. High-end broadcast
monitors can rescale for 16:9 at the push of a button. Some specialty widescreen
monitors, popular with home theater enthusiasts, will do this as well. Some DVD players
can letterbox or stretch anamorphic video on playback, so you can keep your video in
native 16:9 mode.
• Letterbox your video if you’re unsure how it will be viewed: If you’re unsure who is going
to be viewing the tape and you want to guarantee undistorted playback on a standard
4:3 monitor, you can letterbox your sequence by nesting it in a 4:3 sequence. For more
information about adding 16:9 footage to a 4:3 sequence, see “Working with
Mixed-Format Sequences.”

Exporting 16:9 Anamorphic Video
Instead of outputting to tape, you may want to export your 16:9 anamorphic sequence
to a media file for online distribution or DVD authoring. Here are some common export
file formats and the commands used to create them:
• QuickTime movie: For online distribution via the Export Using QuickTime Conversion
command
• MPEG-2, MPEG-4, or H.264: For DVD or online distribution via the Export Using
Compressor command
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Unlike output to standard definition tape, which may require letterboxing to fit in a 4:3
aspect ratio, there is no need to letterbox media files because they can have any
dimensions you want (in this case, 16:9).

Calculating the Dimensions for an Exported 16:9 QuickTime Movie
The dimensions of your exported movie depend on several factors, including any file size
limitations and height or width constraints. For example, if you are producing a website
in which every movie has a width of 320 pixels, regardless of height, then the width will
determine the height. To calculate the dimensions of your movie, use the following
formula, where aspect ratio is always 16:9:
aspect ratio = pixel width/pixel height
For example, if you want the width of your movie to be 320 pixels, the formula for pixel
height looks like this:
16/9 = 320/pixel height
Or, rewritten:
pixel height = 320/1.7777
In this case, your final movie dimensions should be 320 x 180 pixels.

Exporting a 16:9 QuickTime Movie for the Web
You can export your 16:9 anamorphic sequence to a native 16:9 movie using the Export
Using QuickTime Conversion command.
To export a 16:9 anamorphic sequence to a native 16:9 QuickTime movie
1 In the Browser, select the 16:9 anamorphic sequence you want to export.
2 Choose File > Export > Using QuickTime Conversion.
3 Choose QuickTime from the Format pop-up menu, then click Options.
4 In the Movie Settings window, click Settings.
5 Choose a popular online codec from the Compression Type pop-up menu, select options
for the codec, then click OK.
For example, choose Sorenson Video 3 or MPEG-4 Video.
6 In the Movie Settings window, click Size.
7 In the Export Size Settings window, choose Custom from the Dimensions pop-up menu.
8 In the Dimensions width and height fields, enter the width and height you calculated for
your exported 16:9 movie.
For more information, see “Calculating the Dimensions for an Exported 16:9 QuickTime
Movie.”
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9 Make sure the “Preserve aspect ratio using” checkbox is unselected, then click OK.
10 In the Movie Settings window, choose audio settings, then click OK.
11 Enter a filename, choose a location to save your file, then click OK to export your movie.
12 When the movie has finished exporting, double-click the movie in the Finder to open it
in QuickTime Player and verify that its aspect ratio is 16:9.
For more information, see “Exporting Using QuickTime Conversion.”

Exporting a 16:9 Video File for DVD Distribution
You can use Compressor to export 16:9 anamorphic movies to an MPEG-2 file for DVD
authoring. To create anamorphic 16:9 MPEG-2 footage with Compressor, the setting you
use must always have an aspect ratio setting of 16:9. You can choose an aspect ratio from
the Aspect Ratio pop-up menu, located in the Video Format tab of the Encoder pane.
To export a 16:9 anamorphic sequence to a 16:9 anamorphic MPEG-2 file
1 In the Browser, select the 16:9 anamorphic sequence you want to export.
2 Choose File > Export > Using Compressor.
3 In Compressor, your sequence appears as an encoding job in a Batch window.
4 Select an MPEG-2 setting that includes “16:9” in the title and drag the setting to the
encoding job in the Batch window.
5 Click Submit to start encoding the job.
For more information, see “Using Compressor with Final Cut Pro.”
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Appendix

Using Multi-Touch Gestures with
Final Cut Pro

This appendix covers the following:
• Using Multi-Touch Gestures in the Timeline (p. 1953)
• Using Multi-Touch Gestures in the Viewer or Canvas (p. 1953)
If your computer has a Multi-Touch trackpad, you can use Multi-Touch gestures when
working with Final Cut Pro. This appendix lists the Multi-Touch gestures that you can use.
Final Cut Pro supports using Multi-Touch gestures in the Timeline, Viewer, and Canvas
windows. The gesture takes effect in the window beneath the pointer.

Using Multi-Touch Gestures in the Timeline
You can use the following gestures in the Timeline:
• Scroll (two-finger): Scrolls the Timeline left or right. This gesture is supported on all
standard trackpads and Multi-Touch trackpads, and as such is not strictly a Multi-Touch
gesture.
• Swipe (three-finger): Swipe up to move the playhead to the beginning of the sequence.
Swipe down to move the playhead to the end of the sequence. Swipe left or right to
move the playhead to the previous or next edit point.
• Pinch : Pinch closed to zoom out of the Timeline. Pinch open to zoom in to the Timeline.
• Rotate : Rotate left or right to scrub the playhead left or right.
For more information about Multi-Touch gestures, see the documentation that came
with your computer.

Using Multi-Touch Gestures in the Viewer or Canvas
You can use the following gestures in the Viewer or Canvas:
• Scroll (two-finger): Scrubs the playhead left or right. This gesture is supported on all
standard trackpads and Multi-Touch trackpads, and as such is not strictly a Multi-Touch
gesture.
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• Swipe (three-finger): Swipe up to move the playhead to the beginning of the clip or
sequence. Swipe down to move the playhead to the end of the clip or sequence. Swipe
left or right to move the playhead to the previous or next edit point.
• Pinch : Pinch closed to zoom out of the window. Pinch open to zoom in to the window.
• Rotate : Rotate left or right to scrub the playhead left or right.
For more information about Multi-Touch gestures, see the documentation that came
with your computer.
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2:2:2:4 pull-down An efficient but low-quality pull-down method, primarily useful for
previewing the output of real-time effects on an NTSC monitor. See also pull-down
insertion, pull-down pattern.
2:3:2:3 pull-down The most commonly supported pull-down pattern for NTSC devices.
This option is ideal for recording to an NTSC device such as a standard definition television,
an MPEG-2 encoding device, or a high-end finishing system. See also pull-down insertion,
pull-down pattern.
2:3:3:2 pull-down The pull-down pattern used by DV devices that support advanced
pull-down. See also pull-down insertion, pull-down pattern.
3:2 pull-down See 2:3:2:3 pull-down.
4:3 The aspect ratio for broadcast video. The ratio of the width to the height of the visible
area of the video frame, also called the picture aspect ratio, is 4:3, or 1.33.
8-bit precision For video, a bit depth at which color is sampled. 8-bit color is common
with DV and other standard definition digital formats. Some high definition acquisition
formats are also recorded with 8-bit precision.
10-bit resolution For video, a bit depth at which color is sampled. Certain standard and
high definition video capture interfaces are capable of uncompressed, 10-bit capture.
16:9 A widescreen aspect ratio for video. The ratio of the width to the height of the visible
area of the video frame, also called the picture aspect ratio, is 16:9, or 1.78. The 16:9 aspect
ratio is used for high definition video.
16-bit resolution A standard bit depth for digital audio recording and playback.
16 mm A film format for film and television presentations that has a 4:3 aspect ratio.
24 @ 25 pull-down A pull-down pattern used in Final Cut Pro when 24 fps media is sent
to a 25 fps video output. In this pattern, 12 progressive frames are displayed, followed
by 13 reinterlaced frames.
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24 @ 25 repeat A pull-down pattern used in Final Cut Pro when 24 fps media is sent to
a 25 fps video output. In this pattern, 24 progressive frames are played, and the 25th
frame is the 24th frame repeated.
24-bit resolution A bit depth used for high-quality audio playback.
32-bit floating point resolution An extremely high-resolution bit depth used for lossless
computation of audio or video data.
35 mm A standard motion picture film format. This may be cropped during projection
to create widescreen aspect ratios such as 1.66 or 1.85, or filmed and projected
anamorphically for an aspect ratio of 2.40.
65 mm A film format for shooting widescreen presentations. This format is usually printed
with a soundtrack onto 70 mm film.
70 mm A film format for widescreen projections that has a 2.2:1 aspect ratio.
180-degree rule When a new camera angle is more than 180 degrees different from the
previous camera angle, a shot with two people will appear to reverse positions onscreen.
When editing a scene with two people talking, it’s important not to cut to a shot that
crosses the 180-degree line that connects them.
action safe area The action safe area is 90 percent of the image area. Most of the time,
anything in your video image that’s outside of this area won’t be displayed on a television
screen, so any important material needs to be framed within the action safe area. See
also overscan, title safe area.
Adjust Line Segment pointer A cross-shaped pointer that appears in the Timeline and
Viewer when you move the pointer over a line that can be adjusted, such as a line segment
between keyframes. The pointer has small arrows pointing up and down, indicating the
directions in which a line can be moved.
advanced pull-down See 2:3:3:2 pull-down.
AIFF (Audio Interchange File Format) A cross-platform audio file format developed by
Apple, based on Electronic Arts IFF (Interchange File Format). Like WAVE files, AIFF files
contain “chunks” of information such as the Sound Data Chunk, which contains the actual
sample data, and the Common Chunk, which contains sample rate and bit depth
information. An extension of the AIFF format, called AIFC, can store compressed audio
data.
alignment When working with transitions, refers to whether the transition starts before
the edit point, is centered at the edit point, or ends after the edit point.
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alpha channel An image channel in addition to the R, G, and B color channels that is
used to store transparency information for compositing. Alpha channels are often 8-bit,
but some applications support 16-bit alpha channels. In Final Cut Pro, black represents
100 percent transparency, and white represents 100 percent opacity. Only certain formats,
such as Targa, TIFF, PICT, and the QuickTime Animation codec, support alpha channels.
ambience A type of sound. Ambient audio includes background room noise, traffic noise,
and atmospheric sound effects.
analog A signal that consists of a constantly varying voltage level, called a waveform,
that represents video and audio information. Analog signals must be digitized, or captured,
for use by Final Cut Pro. VHS and Betacam SP are both analog tape formats. See also
digital.
anamorphic Visuals that are shot in a widescreen format and then squeezed into a
4:3 frame size. This can be done by using a video camera’s electronics or it can be done
optically, by using an anamorphic lens.
anchor item When you first link multiple audio clip items to a video item in the Timeline,
that video item is considered the “anchor” item to which the sync of all other linked audio
items is compared. If you’re linking a group of audio items without a video item, the
topmost audio item that appears in the Timeline acts as the anchor item.
anchor point In the Motion tab, the point that is used to center changes to a clip’s
geometry when using motion effects. Any changes to the size, position, and rotation of
a clip happen relative to this anchor point. A clip’s anchor point does not have to be at
its center.
Angle control A control used to rotate a clip around its center axis without changing its
shape. Located in the Motion tab of the Viewer. In the Angle control, the black hand
indicates the current angle of the clip, and the small red hand indicates how many total
rotations forward or backward have been specified.
A-only edit An edit of the audio files or video files of the base track only.
A-roll edit An edit of clips that contain audio data from the base track or a narration.
aspect ratio A film or video frame’s width-to-height ratio on any viewing screen. The
most common aspect ratio is 4:3, used for regular television screens. An aspect ratio of
16:9 is increasingly used for high definition video. See also 16:9, 4:3.
assemble edit mode In linear systems, assemble edit mode lays down new video, audio,
and control tracks all at once. It usually requires anywhere from 3 to 5 seconds of pre-roll
before you edit to tape. In Final Cut Pro, assemble edit mode is a function that writes the
sequence or clip to tape at the designated In point, or at the current point. Assemble edit
mode usually breaks the timecode and control track at the end of the edit.
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attenuate To lower an audio signal’s level.
audio channel indicator An icon in the Edit to Tape window that indicates which audio
tracks are being output.
audio clip A media clip containing audio tracks.
audio meter A meter that lets you monitor audio output levels from your computer. You
use the audio meters in Final Cut Pro when you capture, mix, and output your program.
Audio Mixer A tab in the Tool Bench window. The Audio Mixer is the primary tool in
Final Cut Pro for mixing multiple channels of a program’s audio in real time.
audio track A track in the Timeline into which you can edit audio clip items.
Audio Units The standard real-time audio filter format for audio applications used with
Mac OS X.
Auto Render A feature that allows Final Cut Pro to render open sequences whenever a
specified number of idle minutes have passed.
average loudness The average audio level in decibels. Determines the apparent volume
of an audio signal to a listener.
averaging meter A meter that displays the average audio level. Unlike peak meters,
which always show the exact level of an audio signal including every peak, averaging
meters have weighted ballistics so that they give a more readily apparent representation
of the average loudness of an audio signal.
AVI (Audio-Video Interleaved) Microsoft’s older standard format for digital video.
axis The pitch, roll, and yaw of a camera shot determines its axis. In an edited sequence,
the axis can be used to determine visual continuity from shot to shot.
back light A light source that comes from behind and above the subject. It outlines the
subject and differentiates it from the background. Also called a rim light.
batch capture A process in which previously logged clips’ media is captured from a VTR
or camcorder to your hard disk. Remote device control is used to automatically cue source
tapes to the timecode location of each clip.
batch compression A process in which multiple clips or sequences are automatically
compressed to new media files, so you don’t have to compress each file individually.
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batch list A tab-delimited text file that contains information about offline clips that you
want to capture and use in your project. Batch lists can be exported from or imported
into your Final Cut Pro project file. After you import a batch capture list into Final Cut Pro,
your project contains a series of offline clips, one for each entry in the batch capture list.
You then need to recapture or reconnect the clips to their media.
batch recapture A process in which you recapture, at a higher resolution, the parts of
logged clips that you actually use in your sequences. Batch recapturing helps to conserve
disk space.
Betacam SP A high-end, standard definition component analog video format that supports
four tracks of analog audio.
Betacam SX A standard definition, 8-bit digital videotape recorder format with 4:2:2 color
sampling and 10:1 video compression using MPEG-2 compression. Supports four tracks
of audio with 16-bit, 48 kHz audio sampling.
Bezier curve In its simplest form, a line defined by two end points and two associated
control points, or “handles.” Pulling the control points adjusts the line into a curve. Named
after Pierre Bezier, who discovered the mathematical formula for these curves. In
Final Cut Pro, Bezier curves are used to adjust keyframed effects and to create curves in
motion paths.
Bezier handles Controls that let you modify the curve of a line segment between a handle
and the next point on either side of it. The farther a handle is dragged from its vertex
point, the more it bends or curves the line segment. Used for smoothing keyframes.
bin A container (or folder) inside the Browser that can contain clips, sequences, transitions,
effects, and generators. You use bins to organize these elements, sort them, add comments,
rename items, and so on.
black level An analog video signal’s voltage level for the color black, represented by IRE
units. Absolute black, or setup, is represented by 7.5 IRE for NTSC in the United States
and 0 IRE for NTSC in Japan and for PAL.
blue or green screening A special effects technique that allows you to derive an alpha
channel or matte from the blue or green background of a video clip in order to make it
transparent for purposes of compositing against other clips. Blue-screen technology is
what makes weather forecasters appear to be standing against an animated map, when
in reality they’re standing in front of a blue wall. Also known as chroma keying. See also
keying.
boosting The act of raising an audio level.
boundary Refers to either the In or Out point of a clip in the Timeline.
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broadcast Refers to signals intended for delivery on television, as well as network delivery
to a wide audience. Broadcasters may have strict guidelines for the signal quality of
programs for broadcast. Broadcast quality is a phrase often used when referring to these
guidelines.
broadcast legal Broadcast facilities have limits on the maximum values of luma and
chroma that are allowable for broadcast. If a video exceeds these limits, distortion can
appear, resulting in unacceptable transmission quality. You can use the Final Cut Pro
video scopes and range-checking options to make sure that the luma and chroma levels
you set stay legal.
B-roll A term used to describe alternate footage shot to intercut with the primary shots
used in a program. B-roll is frequently used for cutaway shots.
Browser The central storage area in Final Cut Pro, where you organize all of the source
material used in your project. The Browser lists all elements—video and audio clips,
graphics clips, and sequences—in a project. Each project is represented by a tab that
contains that project’s file. You can further organize your media clips within a project
using bins, which are similar to folders.
BWF (Broadcast Wave Format) An extension of the WAVE file format that includes
additional metadata such as timecode and production information.
calibrate To adjust a feature for accuracy.
Canvas In Final Cut Pro, the Canvas is the equivalent of a record monitor in a tape-to-tape
editing system. It works with the Timeline, displaying the frame at the position of the
playhead in the Timeline and showing what your edited sequence looks like when it is
played. Changes you make to a sequence in the Timeline are seen when you play back
that sequence in the Canvas. If you modify clips in the Canvas, the changes are stored
with the clips in the Timeline. You can also use the Canvas to perform edits.
capturing The process of moving NTSC or PAL video or audio from tape to a digital
format for use by Final Cut Pro. An older term for capturing is digitizing. Captured video
clips appear on the specified scratch disk as a series of QuickTime movie files. See also
digitize.
center point Defines a clip’s location in the x and y coordinate space in the Motion tab
of the Canvas.
CG Abbreviation for Character Generator. A specialized hardware device used for creating
titles.
channel 1 Typically the left audio channel in a stereo recording.
channel 2 Typically the right audio channel in a stereo recording.
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channels When used to describe video, can refer to color channels or alpha channels.
Color and transparency information for video and graphics clips is divided into individual
channels. Each individual color channel represents one of the three individual primary
colors that are combined to represent the final image. Each channel has a bit depth; most
graphics and video files have 8 bits per channel, meaning that there are 256 levels of
color or transparency for each channel.
chip chart A grayscale or color chart that is placed next to the slate at the beginning of
every shot. During post-production, the chip chart can be used to correct each shot so
that the whites, blacks, and colors can be perfectly reproduced during editing.
chroma The color information contained in a video signal, consisting of hue (phase angle),
which represents the color itself, and saturation (amplitude of the color subcarrier), which
represents the intensity of the color.
chroma keying See blue or green screening.
clip An item in a Final Cut Pro project representing video, audio, or graphics media files
on disk.
clipping Distortion occurring during the playback or recording of digital audio because
of a signal that exceeds the maximum sample value of 0 dBFS.
CMYK Abbreviation for Cyan, Magenta, Yellow, Black. The color space commonly used
for images that are printed with four-color ink on offset presses.
codec Short for compressor/decompressor, or encode/decode. A software component used
to translate video or audio from its analog uncompressed form to the digital compressed
form in which it is stored on a computer’s hard disk. DV, Photo, JPEG, and Sorenson Video
are common QuickTime video codecs. Also referred to as a compressor.
color balance Refers to the mix of red, green, and blue in a clip. In Final Cut Pro, you can
adjust the color balance of the highlights (bright areas), midtones, or shadows (dark areas)
of your clip using the Color Corrector 3-way filter.
color bars A standard color test signal displayed as columns, often accompanied by a
reference audio tone. Color bars are used to adjust the video signal of the incoming
source tape to maintain proper color from tape to computer and through to output. Color
bars are also output to a master tape so that accurate duplicates (dubs) of the tape can
be made.
color correction A process in which the color of clips used in an edited program is evened
out so that all shots in a given scene match. Color correction is generally one of the last
steps in finishing an edited program. The color correction tools in Final Cut Pro give you
precise control over the look of every clip in your project by allowing you to adjust the
color balance, black levels, midtones, and white levels of individual clips.
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color depth The possible range of colors that can be used in a movie or image. There
are generally four choices with computer graphics—8-bit (grayscale), 16-bit, and 24-bit
(millions of colors). Higher color depths provide a wider range of colors but require more
space for a given image size. Broadcast video is generally 24-bit, with 8 bits of color
information per channel. See also channels.
colorist A professional who performs color correction. The colorist, in consultation with
the cinematographer, director, or producer, works shot by shot to determine the look of
each clip according to the needs of the project.
component video A type of analog video signal in which the luma and chroma signals
are recorded separately for better video quality. Professional video equipment, such as
a Betacam SP deck, uses component Y′CBCR (also called component YUV) video inputs and
outputs. Another form of component video, component RGB, is not as widespread on
video gear as component Y′CBCR.
composite video An analog video signal that combines all chroma and luma information
into a single waveform running through a single cable. This can result in analog “artifacts,”
affecting the quality of the video signal. Nearly all video equipment has composite inputs
and outputs.
compositing A process in which two or more images are combined into a single frame.
This term can also describe the process of creating various video effects.
compression The process by which video, graphics, and audio files are reduced in size.
“Lossy” compression refers to a process of reducing video file sizes through the removal
of redundant or less noticeable image data. Lossless compression reduces file sizes by
mathematically consolidating redundant image data without discarding it. See also codec.
contrast The difference between the lightest and darkest values in an image. High-contrast
images have a large range of values from the darkest shadow to the lightest highlight.
Low-contrast images have a more narrow range of values, resulting in a “flatter” look.
coverage A series of medium shots and close-ups, taken after the master shot, all of
which cover the same material in the script. Used when shooting a scene with continuity.
These shots are called coverage because they’re often used to cover different edits made
in the scene.
crop To mask a specified amount from the total frame size of an image. You can crop
the top, left, right, and bottom of an image independently.
cut An edit in which one clip immediately follows another, with no transition effect. This
is the simplest type of edit.
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cutaway shot A shot that is related to the current subject and occurs in the same time
frame. For example, an interviewer’s reaction to what is being said in an interview is a
cutaway shot. Often, a cutaway shot is used to eliminate an unwanted visual section of
another shot. The audio usually remains continuous, helping to make the cutaway less
noticeable.
D1 A standard definition digital videotape recorder format that records an 8-bit,
uncompressed component video signal with 4:2:2 color sampling. Recorded using 19 mm
tape. Supports four tracks of audio.
D2 A standard definition digital videotape recorder format that records an 8-bit,
uncompressed composite video signal with 4Fsc color sampling. Recorded using 19 mm
tape. Supports four tracks of audio.
D3 A standard definition digital videotape recorder format that records an 8-bit,
uncompressed composite video signal with 4Fsc color sampling. Recorded using 1/2-inch
tape. Supports four tracks of audio.
D5 A standard definition digital videotape recorder format that records a 10-bit,
uncompressed component video signal with 4:2:2 color sampling. Recorded using 1/2-inch
tape. Supports four tracks of audio.
D9 Also known as Digital-S. A standard definition digital videotape recorder format that
records an 8-bit, 3.3:1 DCT-compressed component video signal with 4:2:2 color sampling.
Recorded using 1/2-inch tape. Supports four tracks of audio.
data rate The speed at which data can be transferred, often described in megabytes per
second (MB/sec.) or megabits per second (Mbps). The higher a video file’s data rate, the
higher quality it is, but the more system resources (processor speed, hard disk space, and
performance) it requires. Some codecs allow you to specify a maximum data rate for a
movie during capture.
DAW (Digital Audio Workstation) A digital editing and recording device or software
application used for editing multitrack audio for music or audio post-production.
decibel (dB) Unit of measurement for sound levels; a logarithmic scale used to describe
the loudness of sound as perceived by the human ear. (1 dB corresponds to approximately
the smallest volume change that the average human ear can perceive.) For digital audio,
dBFS is the standard decibel unit of sound level measurement. See also digital full scale.
decompression The process of creating a viewable image for playback from a compressed
video, graphics, or audio file. See also compression.
desaturate To remove color from an image. 100 percent desaturation results in a grayscale
image.
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destination track The track a particular source item is edited into in the Timeline, as
defined by the Source and Destination controls in the Timeline patch panel.
destination track controls Source and Destination controls in Timeline tracks that allow
you to specify which tracks source clip items are edited into in the Timeline.
device control Technology that allows Final Cut Pro to control an external hardware
device, such as a video deck or camera. Three protocols are used most frequently to
control video devices: serial device control via the RS-422 and RS-232 protocols, and
FireWire for DV camcorders and decks.
dialogue The recorded audio of one or more people speaking in a video clip. The
designated dialogue track in an editing project is likely to include most of the location
audio that was captured along with the video.
digital A description of data that is stored or transmitted as a sequence of 1s and 0s.
Most commonly, refers to binary data represented using electronic or electromagnetic
signals. QuickTime movie files are digital. See also analog.
Digital-8 A standard definition consumer digital video format that records a DV video
signal onto Hi-8-style tapes.
Digital Betacam A standard definition digital videotape recorder format with
approximately 2:1 video data compression and 4:2:2 color sampling. Supports four tracks
of audio with 20-bit, 48 kHz audio sampling.
digital full scale The full audio signal range that can be recorded digitally without
distortion.
Digital-S See D9.
digital video Video that can be captured, manipulated, and stored using a digital format,
such as QuickTime. A digital video camcorder, for example, is a video camera that records
images digitally on a medium such as tape. Because the signal is digital, it can be easily
transferred to your computer.
digitize To convert an analog video signal to a digital video format. A method of capturing
video. See also capturing.
disabled track A track that has been disabled using the Track Visibility control. Disabled
tracks are not output to tape or rendered into a QuickTime file for output.
disclosure triangle A small triangle you click to show or hide details in the interface.
distort To change the shape of a clip by moving a corner point independently of the
other corner points. Also, to squeeze a clip horizontally or vertically to change the ratio
of its width to its height (the aspect ratio).
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downmixing The process used to combine multiple audio channels into a single stereo
(or dual mono) pair. Also referred to as mixing down.
drop frame timecode NTSC timecode that skips ahead in time by two frame numbers
each minute, except every tenth minute, so that the timecode agrees with the actual
elapsed clock time. (Timecode numbers are skipped, but actual video frames are not
skipped.) This skipping corrects for NTSC’s actual frame rate of 29.97 fps. It corrects for
an inaccuracy of 3 seconds and 18 frames per hour in comparison to actual elapsed time
when non-drop frame timecode is used. To avoid confusion, drop frame timecode should
be avoided in film-based productions. See also non-drop frame timecode.
drop shadow An effect that creates an artificial shadow behind an image. Typically used
with graphics and text.
dual system recording A recording process in which video is captured on one recording
device and audio is recorded on another. Dual system audio must be synchronized onto
the source videotapes prior to capture, or synced with the video in Final Cut Pro.
duplicate frames indicator Colored bar that appears at the bottom of a clip’s video item
in the Timeline, indicating that frames are duplicated elsewhere in the sequence. Useful
for editing film, where duplicate frames can cause complications during the final negative
cut.
duration A clip’s duration is the length of time between the clip’s In and Out points.
DV A standard definition digital videotape recorder format that records an 8-bit, 5:1
compressed component video signal with 4:1:1 color sampling (PAL uses 4:2:0). Recorded
using 1/4-inch tape. Supports two tracks of audio with 16-bit, 48 kHz audio sampling, or
four tracks of audio with 12-bit, 32 kHz audio sampling.
DVCAM A standard definition digital videotape recorder format that records an 8-bit, 5:1
compressed component video signal with 4:1:1 color sampling (PAL uses 4:2:0). Recorded
using 1/4-inch tape. Supports two tracks of audio with 16-bit, 48 kHz audio sampling, or
four tracks of audio with 12-bit, 32 kHz audio sampling.
DVCPRO A standard definition digital videotape recorder format that records an 8-bit,
5:1 compressed component video signal using 4:1:1 color sampling (PAL uses 4:2:0).
Recorded using 1/4-inch tape. Supports two tracks of audio with 16-bit, 48 kHz audio
sampling.
DVCPRO 50 A standard definition digital videotape recorder format that records an 8-bit,
3.3:1 compressed component video signal with 4:2:2 color sampling. Recorded using
1/4-inch tape. Supports four tracks of audio with 16-bit, 48 kHz audio sampling.
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DVCPRO HD A high definition video format that records an 8-bit, compressed component
video signal with 4:2:2 color sampling. Both 720p and 1080i are supported. Includes up
to eight tracks of audio with 16-bit, 48 kHz audio sampling. Recorded using 1/4-inch tape.
The total data rate is 115 Mbps.
DVD A disc that is the size of a CD but that uses higher-density storage methods to
significantly increase its capacity. Although usually used for video distribution, DVD-ROM
discs can also be used to store computer data.
dynamic range The difference, in decibels, between the loudest and softest parts of a
recording.
editing The process of combining and arranging audio, video, effects, transitions, and
graphics in a sequence to produce a program.
edit point (1) Defines what part of a clip you want to use in an edited sequence. Edit
points include In points, which specify the beginning of a section of a clip or sequence,
and Out points, which specify the end of a section of a clip or sequence. (2) The point in
the Timeline in an edited sequence where the Out point of one clip meets the In point
of the next clip. This edit point can be selected for various operations.
Edit to Tape In Final Cut Pro, the Edit to Tape command lets you perform frame-accurate
insert and assemble edits to tape.
EDL (Edit Decision List) A text file that uses the source timecode of clips to sequentially
list all of the edits that make up a sequence. EDLs are used to move a project from one
editing application to another, or to coordinate the assembly of a program in a tape-based
online editing facility.
effects A general term used to describe all of the Final Cut Pro capabilities that go beyond
cuts-only editing. See also filters, generators, transitions.
exposure The amount of light in video or film images. Exposure affects the overall
brightness of the image as well as its perceived contrast.
extend edit An edit in which the edit point is moved to the position of the playhead in
the Timeline. It allows you to move an edit point between two clips quickly. An extend
edit overwrites any clips that come between the selected edit point and the playhead. It
does not affect the overall duration of a sequence.
eyeline match During the intercutting of shots, refers to cutting from a clip of a person
looking at something to a clip containing the object that is being looked at.
faders In the Audio Mixer, vertical sliders used to adjust the audio levels of clips at the
position of the playhead. Using the fader, you can adjust the audio level of a clip on a
smooth logarithmic scale ranging from +12 dB to –∞ dB (otherwise known as silence).
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favorite A customized effect that is used frequently. You can create favorites from most
of the effects in Final Cut Pro.
field Half of an interlaced video frame, consisting of the odd or the even scan lines.
Alternating video fields are drawn every 1/60 of a second in NTSC video to create the
perceived 30 fps video. There are two fields for every frame, an upper field and a lower
field.
filters Effects you can apply to video or audio clip items. Filters affect the visual or aural
quality of the clip to which they’re applied. For example, a video filter might change the
colors of your image, and an audio filter might add some reverberance, making actors
sound as if they’re in a huge space. In addition to using the filters that come with
Final Cut Pro, you can use third-party filters.
finishing The process of reassembling the clips used in the final edit of a program at
their highest quality. Finishing may involve recapturing offline-resolution clips at full
resolution, rerendering effects, and then outputting the final program to tape. Finishing
may also involve extra steps that were not taken in the offline edit, such as color correction.
finishing on tape The process of using the EDL from an offline edit to reassemble a
sequence from the original source tapes in an online tape-to-tape editing suite.
FireWire The trademarked Apple name for the IEEE 1394 standard. A fast and versatile
interface used to connect DV camcorders to computers. FireWire is well suited to
applications that move large amounts of data, and it can also be used to connect hard
disks, scanners, and other kinds of computer peripherals.
fit to fill edit An edit in which a clip’s speed is adjusted to fit a specified duration in a
sequence.
flesh tone A special marker in the Final Cut Pro Vectorscope that indicates an area of
appropriate range for all shades of skin color. When calibrating a tape’s color in preparation
for capture or when using one of the color corrector tapes, the flesh tone marker can be
used as a guide for adjusting the hue in order to make sure the skin tones look correct.
frame A single still image. Film and video are made up of a series of these images.
Although a film frame is a single photographic image, an interlaced video frame contains
two fields.
frame blending A process of visually averaging frames together over time to create
smoother motion. This is often useful when playing back clips in slow motion, to smooth
otherwise jerky motion.
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frequency The number of times a sound or signal vibrates each second, measured in
cycles per second, or hertz (Hz). Audio recordings are made up of a vast collection of
waveforms, using many different frequencies of sound. Each frequency in a recording is
associated with an audio pitch. For example, the note generated by each key of a piano
has a specific frequency.
gain The amount an audio or video signal is boosted. In video, this increases the white
level; in audio, this increases the volume.
gamma A curve that describes how the middle tones of an image appear. Gamma is a
nonlinear function often confused with “brightness” or “contrast.” Changing the value of
the gamma affects middle tones while leaving the whites and blacks of the image
unaltered. Gamma adjustment is often used to compensate for differences between Mac
and Windows video graphics cards and displays.
ganged The behavior of the playheads in the Viewer and Canvas when they’re locked
together, so that they move as one.
gaps Locations in a sequence where there is no media on any track. When output to
video, gaps in an edited sequence appear as black sections.
gear down To slow down a mouse operation and make it more precise by holding down
the Command key while dragging an item or control. This can be helpful when dragging
clips if, for example, the Timeline is zoomed out so that clips look small. It’s also useful
to gear down if you want to make very small changes to an edit point, a keyframe
parameter, or a volume level.
generators Clips that are synthesized by Final Cut Pro. Generators can be used as different
kinds of backgrounds, titles, and elements for visual design.
handles Extra footage beyond a clip’s In and Out points. Handles are useful if you want
to add a few more frames to account for dissolves or additional trimming.
Hand tool The Hand tool is used to scroll left or right in the Timeline by dragging.
HDCAM A high definition digital videotape recorder format that records an 8-bit, 7.1:1
DCT-compressed component video signal with 3:1:1 color sampling. Recorded using
1/2-inch tape. Supports four tracks of audio.
HDV An MPEG-2–based high definition video format that is recorded on a DV cassette
tape. HDV supports both 720p and 1080i and uses interframe (or long-GOP MPEG-2)
compression. Depending on the format, HDV has a data rate of 19 Mbps or 25 Mbps.
head clip The clip that begins a sequence.
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headroom The available range in decibels (dB) that falls in between the reference level
that is used to denote the average loudness of a mix and 0 dBFS. If you mix your project
with the reference level set to –12 dBFS, you have 12 dB of headroom available before
the signal is clipped. If the audio in a sequence has a wide dynamic range, you set the
reference level low enough to create enough headroom so that no part of the signal goes
above 0 dBFS.
Hi-8 An analog videotape format. Introduced as a higher-quality version of 8 mm. See
also Digital-8.
Histogram A video scope in Final Cut Pro that displays the relative strength of all luma
values in a video frame, from black to super-white. It is useful for comparing two clips in
order to match their brightness values more closely.
hue An attribute of color perception, also known as color phase. Red, blue, yellow, and
green are all hues.
image sequence A movie exported as a series of numbered image files, stored in a folder.
Each image file contains one frame of video. Image sequences are typically used for
exchanging files among film compositing workstations. Common image sequence file
formats include Targa, TIFF, IFF, DPX, and OpenEXR.
importing The process of bringing files of various types into a project in Final Cut Pro.
Imported files can be created in another application, captured from another device, or
brought in from another Final Cut Pro project.
IMX A standard definition, all-I-frame MPEG-2 format stored on tape, optical disc, or disk
drive. Some IMX decks can play back and convert formats such as Digital Betacam, Betacam
SX, and Betacam SP to IMX. The data rate of IMX can be set to 30, 40, or 50 Mbps.
incoming clip The clip to which a transition segues. For example, if Clip A dissolves to
Clip B, Clip B is the incoming clip.
ingesting The process of bringing media into a video system for editing. Ingesting includes
capturing tape-based media, transferring file-based media, and importing media files
stored on disk. See also capturing, importing, transferring.
In point The edit point that specifies the first frame of a clip to be edited into a sequence.
insert edit An edit in which a clip item is added to a track in the Timeline at a specified
point, moving clips (or parts of clips) after that point to the right. An insert edit does not
replace existing material.
interlaced video A scanning method that divides a video frame into two fields, each
consisting of alternating odd and even lines that are scanned at different times.
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IRE (Institute of Radio Engineers) Also refers to an analog video signal unit of
measurement for luma, established by the Institute of Radio Engineers.
ITU Abbreviation for International Telecommunications Union.
J-cut See split edit.
jog To move forward or backward through video or audio one frame at a time.
jog control A control at the bottom of the Viewer, Canvas, and Log and Capture window
that allows you to move forward or backward through audio or video as slowly as one
frame at a time. Useful for carefully locating a specific frame.
JPEG A popular image file format that lets you create highly compressed graphics files.
The amount of compression used can be varied. Less compression results in a
higher-quality image.
jump cut A cut in which an abrupt visual change occurs between two shots, with no
continuity from one to the other.
keyframe A special-purpose control that denotes a change in value in a filter or motion
parameter. When two keyframes with different values are set in Final Cut Pro, a transition
from one value to another is calculated, resulting in a dynamic change to that parameter.
For example, two center point keyframes with different values result in animated motion
for that clip.
keyframe graph Located in the Control and Filters tabs of the Viewer, the keyframe graph
displays all keyframes and parameter values of a clip’s motion and filter attributes.
keying A technique used to eliminate specific background areas of video in order to
isolate and composite specific foreground elements against a different background. See
also blue or green screening, luma key.
labels Terms such as “Best Take” and “Interview” that appear in the Label column of the
Browser. You can assign labels to clips and media to help distinguish and sort them. Each
label has an associated color that is also applied to clips.
layout Refers to the size and location of windows in Final Cut Pro. Final Cut Pro comes
with a selection of predefined layouts, and you can create and save custom layouts.
Choose a layout that maximizes your screen space in the best way for your source material,
editing focus, screen resolution, and monitor type.
L-cut See split edit.
lift edit An edit in which one or more items are deleted and a gap appears where the
deleted items existed. Does not affect other clips in the sequence.

1970

Glossary

linear editing A video editing style in which a program is edited together by copying
shots from the original source tapes to a master tape, one by one. Because the assembly
is linear, any changes in duration made to an earlier point of the tape require reassembling
the movie from that point forward. See also nonlinear editing.
link To connect video and audio clip items in the Timeline so that when one item is
selected, moved, or trimmed, all other items linked to it are affected.
linked clip A clip item that is connected to one or more other clip items, so that when
you select it you also select the associated clips. You link clip items to keep them in sync
with one another.
linked selection An option in the Timeline that, when turned on, selects all clip items
linked to the item you select. When linked selection is turned off, linked items are not
selected and edited as if they are linked, but the items remain linked together.
Linked Selection button A button in the upper-right corner of the Timeline that turns
the linked selection option on and off.
link indicators In the Timeline, lines under clip names that indicate that the clips are
linked.
locked track A track whose contents cannot be moved or changed. In the Timeline, a
locked track is distinguished by crosshatched lines across the track. You can lock or unlock
tracks at any time by clicking the Lock Track control in the Timeline.
Lock Track control The lock icon, near the beginning of tracks in the Timeline, that you
click to lock and unlock tracks. See also locked track.
log and capture In Final Cut Pro, the process of logging the clips you want to capture
and then using device control to automatically capture them in the Log and Capture
window.
Log and Capture window In Final Cut Pro, the window used to log tape-based media
and capture it for editing.
Log and Transfer window In Final Cut Pro, the window used to log file-based media and
transfer it to your editing system.
logging The process of entering detailed information about the clips that you want to
use from your source media, in preparation for ingest.
logging bin In Final Cut Pro, the specified bin where all clips that are logged or ingested
using the Log and Capture window or the Log and Transfer window are stored.
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looping A playback mode in which clips and sequences go back to the beginning
whenever the playhead reaches the end of the media. The Loop Playback command is
in the View menu.
LTC Stands for longitudinal timecode. A method of writing timecode to a dedicated
timecode or audio track of an audio or video recorder. Compare with VITC.
luma A value describing the brightness of a video image. A luma channel is a grayscale
image showing the range of brightness across the whole clip.
luma key A filter used to key out pixels of a certain luma value (or a range of luma values),
creating a matte based on the brightest or darkest area of an image. Keying out luma
values works best when your clip has a large discrepancy in exposure between the areas
that you want to key out and the foreground images you want to preserve, such as a
white title on a black background. See also keying, matte.
markers In Final Cut Pro, points of reference in clips and sequences. Markers can be
placed directly in clips, or they can be placed in sequences in the Timeline ruler.
mask An image or clip used to define areas of transparency in another clip. Similar to an
alpha channel.
master clip A clip that controls the relationship to a media file for all the clip’s affiliate
clips in your project.
Mastering mode In Final Cut Pro, a mode in the Edit to Tape window that lets you output
additional elements such as color bars and tone, a slate, and a countdown when you
output your program to tape.
master shot A wide-angle shot that encompasses the entire scene. Traditionally, this is
the first shot that is taken for a scene and is the shot used as the basis for that scene
when editing.
master tape The final tape that contains a finished program at its highest quality. Master
tapes should be suitable for duplication, broadcast, and archiving.
match frame commands The match frame commands in Final Cut Pro allow you to
quickly open a copy of a clip at the same frame.
match-on-action A cut from one shot to another with similar action in the frame; for
example, cutting from a shot of a woman opening the door outside an apartment to a
shot from the interior of the apartment of the door opening and the woman walking in.
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matte Sometimes referred to as a holdout matte. An effect that uses information in one
layer of video to affect another layer. Mattes are useful when you want to use one clip
to selectively hide or reveal part of another; for example, to reveal parts of a video layer
by a round spotlight shape. Matte filters can be used by themselves to mask out areas
of a clip or to create alpha channel information for a clip in order to make a transparent
border around the clip that can be composited against other layers.
media A generic term for elements such as movies, sounds, and pictures.
merged clip A clip that refers to more than one source media file on disk. Usually, a
merged clip refers to a video file and multiple audio files.
midtones The values in an image between absolute white and absolute black.
mini-DV cassette A small cassette used for the DV digital videotape format.
mixed-format sequence A sequence containing clips whose media files don’t match the
sequence format.
mixer automation The process of using the Audio Mixer or a control surface to record
audio level and pan keyframes.
mixing The process of adjusting the audio levels of all audio clips in an edited sequence,
including the production audio, music, sound effects, voiceovers, and additional
background ambience, to turn all of these sounds into a harmonious whole.
mono Short for monophonic. A type of sound in which audio channels are handled
discretely, or are taken from a tape and mixed together into a single track, using equal
amounts of audio channels 1 and 2. See also stereo, stereo pair.
montage A sequence in which a series of shots are arranged to create a certain mood
or theme or to denote the passage of time.
motion blur An effect that blurs any clip with keyframed motion applied to it, similar to
blurred motion recorded by a camera.
motion path Lines displayed in the Canvas showing the direction a clip will travel based
on positional keyframes applied to the clip.
Motion project file A project file saved in Motion. You can edit Motion project files
natively in Motion or add them to your Final Cut Pro projects.
MPEG (Moving Picture Experts Group) A group of compression standards for video and
audio, which includes MPEG-1, MPEG-2, and MPEG-4.
MXF (Material eXchange Format) A common media container format in the video
industry. It is not a compression scheme or specific video type, but rather a container for
storage and transmission of video, audio, and associated metadata.
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nested sequence A sequence that is edited into another sequence.
NLE Short for nonlinear editor. See also nonlinear editing.
noise floor The background noise generated by audio equipment during recording,
which inadvertently becomes a part of the recording.
non-drop frame timecode Timecode in which frames are numbered sequentially and
no frames are dropped from the count. When discussing NTSC video, the video frame
rate is actually 29.97 fps, and non-drop frame timecode is off by 3 seconds and 18 frames
per hour in comparison to actual elapsed time. See also drop frame timecode.
non-interlaced video The standard representation of images on a computer. Also referred
to as progressive scan. The monitor displays the image by drawing lines, one after another,
from top to bottom.
nonlinear editing A video editing method in which edits within a program can be changed
at any time without having to re-create the entire program. When you use a nonlinear
editing application to edit a program, all footage used is stored on a hard disk rather than
on tape. This allows random access to all video, audio, and images as you edit. See also
linear editing.
NTSC format The video standard defined by the National Television Standards Committee,
the organization that originally defined North American broadcast standards. Analog
NTSC video has 525 interlaced lines per frame, a frame rate of 29.97 fps, and a limited
color gamut. Digital NTSC video has a frame size of 720 x 486 pixels (720 x 480 for DV and
DVD), and a frame rate of 29.97 fps. See also PAL format.
NTSC legal The range of color that can be broadcast free of distortion according to the
NTSC standards.
offline Clips whose media files are currently unavailable to your project. They appear in
the Browser with a red slash through them. Clips may be offline because media files
haven’t been ingested yet or because they’ve been modified in some way. To view these
clips properly in your project, you must reingest them or reconnect them to their
corresponding media files.
offline editing The process of editing a program at a lower resolution to save on
equipment costs or to conserve hard disk space. When the edit is finished, the material
can be recaptured at a higher quality, or an EDL can be generated for re-creating the edit
on another system.
opacity The level of a clip’s transparency.
ordered timecode break A nearly imperceptible gap in the timecode track of a tape that
breaks the continuous flow of timecode but doesn’t result in the timecode being reset
to 00:00:00:00. See also timecode.

1974

Glossary

outgoing clip The clip a transition segues from. For example, if Clip A dissolves to Clip
B, Clip A is the outgoing clip.
out-of-sync indicator In the Timeline, the symbol that appears at the beginning of a clip
when a video item moves out of sync with its linked audio items, or vice versa.
Out point The edit point that specifies the last frame of a clip for use in a sequence.
output Sending video or audio signals out of your Final Cut Pro editing system to display
on a monitor or record on tape.
overscan The part of the video frame that cannot be seen on a TV or video monitor.
Broadcast video is an overscan medium, meaning that the recorded frame size is larger
than the viewable areas on a video monitor. The overscan part of the picture is usually
hidden behind the plastic bezel on the edge of a television set. While you are editing,
you can use the action safe area to indicate the approximate portion of a frame that is
hidden because of overscanning.
overwrite edit An edit in which the clip being edited into a sequence replaces frames
that are already in the sequence.
P2 (Professional Plug-in) A compact solid-state memory card designed for professional
and broadcast media gathering. Because they have no moving parts, these cards are
compact and sturdy as well as resistant to heat and cold. P2 cards typically store DV,
DVCPRO, DVCPRO 50, and DVCPRO HD media.
PAL format Acronym for Phase Alternating Line, a 25 fps (625 lines per frame) interlaced
video format used by many European countries. Digital PAL video has a frame size of
720 x 576. See also NTSC format.
Parade scope A waveform monitor mode that shows the video signal as separate red,
green, and blue waveforms. Useful for comparing the relative levels of reds, greens, and
blues between two clips, or within a single clip.
peak (1) Short, loud bursts of sound that last a fraction of a second. In spoken dialogue,
letters like P, T, and K at the beginnings of words can result in little peaks if the person
speaking is close to the microphone. (2) Occurrences of clipped audio appearing in
Final Cut Pro as 0 dBFS peaks. Excessive peaks tend to indicate that the audio was recorded
at unsuitable levels. A command in the Tools menu, Mark Audio Peaks, lets you identify
0 dBFS audio peaks in clips or sequences.
peak meter A digital audio meter that displays the absolute level of an audio signal as
it plays. So named because every peak in the signal can be accurately seen.
PCM Stands for pulse-code modulation. PCM is a method of storing or transmitting
uncompressed digital audio data.
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phase (1) In audio, the timing relationship between two identical, or similar, audio signals.
(2) In video, the timing relationship between the composite video chroma signal and the
chroma subcarrier signal that determines the hue.
PICT A still-image file format developed by Apple. PICT files can contain both vector
images and bitmapped images, as well as text and an alpha channel. PICT is a common
image format on Mac OS X computers.
pixel One dot in a video or still image. A typical medium-resolution computer screen is
1024 pixels wide and 768 pixels high. Digital video movies for the web are often 320
pixels wide and 240 pixels high.
pixel aspect ratio The width-to-height ratio for the pixels that compose an image. Pixels
on computer screens and in high definition video signals are square (1:1 ratio). Pixels in
standard definition digital video signals are non-square.
playhead A navigational element in the Viewer and Canvas scrubber bar and in the
Timeline. It corresponds to the frame displayed in the Canvas and the Viewer. You drag
the playhead to navigate through a sequence.
post-production The phase of film or video editing in which all of the production elements
are organized, assembled, and output for the distribution phase.
preset A saved group of settings, such as capture, device control, and sequence settings.
Presets determine properties such as frame rate, editing timebase, and capture interfaces.
Presets are usually defined for particular video formats and workflows and can be grouped
together into Easy Setups.
Print to Video A command in Final Cut Pro that lets you send clips or sequences to your
video or audio outputs for recording on tape.
proc amp Short for processing amplifier. A specific piece of equipment that allows you
to adjust video levels on output.
program The movie you may create in Final Cut Pro. May consist of multiple sequences
or one or more clips.
project In Final Cut Pro, the file that holds all of the elements of your movie, such as clips,
bins, and sequences. Media files are stored separately from a project file.
proxy Short for approximation. A proxy is a low-quality substitute for a real-time or
rendered effect. Final Cut Pro may generate a proxy instead of a full-quality effect to
enable real-time playback when processor-intensive effects are used.
pull-down insertion The process of adding fields and frames to convert 23.98 or 24 fps
video to NTSC or PAL video (29.97 or 25 fps, respectively).
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pull-down pattern A method of inserting frames and fields into a video stream to output
23.98 or 24 fps video to an NTSC or PAL device. See also 2:2:2:4 pull-down, 2:3:2:3
pull-down, 2:3:3:2 pull-down, 24 @ 25 pull-down, 24 @ 25 repeat.
QuickTime Cross-platform multimedia technology from Apple. Widely used for editing,
compositing, CD-ROM, web video, import and export, and more.
QuickTime Streaming The streaming media addition to the QuickTime architecture. Used
for viewing QuickTime content in real time on the web.
QuickView tab Provides an alternative way of viewing effects in a sequence outside of
the Canvas as you work. It takes advantage of the ability of Final Cut Pro to cache frames
of your sequence as you play it. This is useful for fast previews of complex composites
and effects. It’s also a good way to see how your final composite looks if you are zoomed
in to the Canvas while making adjustments.
RAID (Redundant Array of Independent Disks) A method of providing nonlinear editors
with many gigabytes (GB) of high-performance data storage by formatting a group of
hard disks to act in parallel as a single drive volume. There are different ways of creating
a RAID, but for digital video editing the most common is referred to as a Level 0 RAID. The
performance of a group of hard disks striped together as an array is much higher than
that of the individual drives.
RAM (random-access memory) A computer’s memory capacity, measured in gigabytes
(GB), which determines the amount of data the computer can process and temporarily
store at any moment.
range checking Options that turn on zebra striping to immediately warn you of areas of
a clip’s image that may stray outside of the broadcast legal range.
raw data Uncompressed data.
razor blade edit An edit in which a single clip is cut into two clips.
real-time effects Effects that can be applied to clips in an edited sequence and played
back in real time, without requiring rendering first. In Final Cut Pro, the real-time effects
architecture is known as RT Extreme.
recapture To capture a clip’s media file again. Usually done to eliminate unused material
in order to capture only the media files necessary to create your finished program at full
resolution.
record monitor In a linear editing suite, a monitor that displays the edited master tape.
A record monitor corresponds to the Canvas in Final Cut Pro.
redigitize To digitize clips again. Also referred to as recapturing.
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reel Identifies the source tape from which a clip was captured or the volume (folder)
from which file-based media was transferred. You specify a clip’s reel name or number
in the Logging tab of the Log and Capture window or in the Logging area of the Log and
Transfer window. A reel name or number is typically entered when logging, but you can
also change it in the Browser or the Item Properties window. In most file-based workflows,
Final Cut Pro uses the name of the source media folder as the reel name for the clips and
media files ingested from that folder.
render To process video and audio with any applied filters or transitions, and store the
result on disk as a render file. Effects that aren’t real time must be rendered to play back
properly. Once rendered, your sequence can be played in real time.
render files Files that Final Cut Pro generates when you render transitions and effects.
Render files are saved to the specified scratch disk.
render status bars Two slim horizontal bars, at the top of the Timeline, that indicate
which parts of the sequence need to be rendered. The top bar is for video and the bottom
for audio. Different colors indicate the render or real-time playback status of a given
section of the Timeline.
replace edit A specialized form of overwrite edit that aligns the frame at the playhead
position in the Viewer clip to the frame at the playhead position in the sequence clip,
replacing only the content of the sequence clip, even if no In or Out points are set. This
is useful for replacing clips based on matching a common visual event in the frame, such
as a slate closing or an actor’s movement.
reset timecode break A break that results in a tape’s timecode being reset to 00:00:00:00.
See also timecode.
resize edit An edit in which the duration of a clip in the Timeline is changed by moving
its In or Out point.
Resize pointer A cross-shaped pointer with small arrows pointing left and right that
indicate the directions in which an edit point can be moved. The Resize pointer appears
when you move the pointer to the boundary of a clip item or transition in the Timeline.
reverse shot A typical example of a reverse shot is a cut to the second person in a
conversation; for example, an interviewer asking the next question after the interviewee
has finished speaking.
RGB Abbreviation for Red, Green, Blue. A color space commonly used on computers, in
which each color is described by the strength of its red, green, and blue components.
This color space directly translates to the red, green, and blue phosphors used in computer
displays. The RGB color space has a very large gamut, meaning it can reproduce a very
wide range of colors. This range is typically larger than the range that can be reproduced
for broadcast.
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ripple edit An edit in which the start and end times of a range of clips on a track are
adjusted when the duration of an earlier clip is altered.
roll edit An edit that affects two clips that share an edit point. For example, if Clip A cuts
to Clip B, a roll edit simultaneously adjusts the Out point of Clip A and the In point of Clip
B by the same amount. The overall duration of the sequence stays the same.
room tone The low level of background noise that exists in any recording. In order to
edit out unwanted sections of audio without creating obvious gaps of silence, it’s common
practice to record a certain amount of extra room tone during a shoot. You can edit in
the room tone whenever you need to cover a gap that was cut in the location audio.
rotation In the Motion tab of the Viewer, the rotation value determines how many times
a clip circles around its center axis, without changing shape.
rotoscoping The process of manipulating or painting on individual frames. Usually used
to describe the act of tracing, frame by frame, a foreground element to be isolated from
the background of the frame.
rough edit The first editing pass. The rough cut is an early version of a movie that pulls
together its basic elements. Often, a rough edit is performed prior to adding transitions,
filters, and other effects.
ruler (1) The measurement bar along the top of the Timeline, which represents the total
duration of an edited sequence. Also displays the timecode corresponding to the location
of clips in the Timeline. You can move the playhead in the ruler in order to navigate
through clips in a sequence. (2) In the Transition Editor, a ruler displays a close-up view
of the frames surrounding the transition in the sequence. (3) In the Audio tab of the
Viewer, a ruler above the waveform display area shows the range of the currently displayed
clip.
sampling The process of measuring an analog signal and converting it to a digital value.
For example, the sample rate of an audio stream specifies how many samples are captured.
Higher sample rates yield higher-quality audio.
SAN (storage area network) A network that connects computer systems to a shared
storage area. The shared storage is typically a group of disk arrays (RAIDs) grouped together
and managed via software (such as Xsan).
saturation A measurement of chroma, or the intensity of color in the video signal.
scale In the Motion tab of the Viewer, an adjustable value that changes the overall size
of a clip. The proportion of the image may or may not be maintained.
scene A series of shots that take place at the same time in the same location. A series of
scenes make up a program.

Glossary

1979

scratch disk The disk or disk space you allocate in Final Cut Pro for digital video ingest
and editing, as well as for the storage of a project’s render files.
script A set of instructions that performs a specific function, similar to programming.
FXScript allows you to create custom scripts for use in Final Cut Pro. You can use FXscript
to create custom filters, transitions, and generators.
scrub To move through a clip or sequence with the aid of the playhead. Scrubbing is
used to find a particular point or frame.
scrubber bar The bar at the bottom of the Viewer and the Canvas. You can speed up or
slow down playback in forward or reverse by moving the playhead along the scrubber
bar.
Scrub tool A tool used to scrub through clips displayed when the Browser is in icon view.
SECAM (Sequential Couleur Avec Memoire) The French television standard for playback.
Similar to PAL, the playback rate is 25 fps and the frame size is 720 x 576.
Selection tool In Final Cut Pro, the default arrow-shaped pointer that allows you to select
items in the interface. For example, you use it to select a clip or edit point. You can select
the Selection tool by pressing the A key.
sequence An arranged series of video, audio, and graphics clips, edit information, and
effects edited together to create a program. A sequence can contain your entire edited
program or be limited to a single scene. Sequences can also be edited into other
sequences, referred to as nested sequences.
sequence clip A clip that has been edited into a sequence. A sequence clip is typically
an affiliate clip. See also master clip.
SGI An uncompressed image file format popular on the IRIX operating system on SGI
workstations. Stores images with millions of colors plus an alpha channel.
shortcut menu A menu you access by holding down the Control key and clicking an
item on the screen, or by pressing the right mouse button. Sometimes called a contextual
menu.
shot A segment of uninterrupted captured video. A shot is the smallest unit of a program.
shuffle edit An edit in which a clip is moved from one position in an edited sequence to
another by insertion. All clips between these two positions are moved to the left or right
to fill the space left by the clip you moved. The shuffled clips don’t change their duration,
so the overall duration of your sequence is not affected.
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shuttle To drag the slider on the shuttle control to the right to fast-forward and to the
left to rewind. Playback speed varies depending on the distance of the slider from the
center of the control.
shuttle control The slider control located at the bottom of the Viewer and the Canvas.
This control is useful for continuous playback at different speeds, in fast and slow motion.
It also shifts the pitch of audio as it plays at varying speeds.
signal-to-noise ratio The ratio between the average loudness of the subject and the
background noise in a recording. Background noise can be many things—tape hiss, the
rustle of clothes, or the rumble of traffic. It’s important that the signal-to-noise ratio of
your recorded clips be fairly high, so that actors’ voices are comprehensible and clear.
slate A small board shot at the beginning of a scene, which identifies the scene with
basic production information such as the take, date, and scene number. The slate may
also contain a chip chart to aid in color correcting the scene. A clapper provides an
audiovisual cue for synchronization of dual system recordings.
slide edit An edit in which an entire clip is moved, along with the edit points on its left
and right. The duration of the clip being moved stays the same, but the clips to the left
and to the right of it change in length to accommodate the new position of the clip. The
overall duration of the sequence and of these three clips remains the same.
slider In Final Cut Pro, an interface element that can be dragged forward or backward in
order to make an adjustment. Sliders can be found in the Motion tab of the Viewer as
well as in filters and generators applied to a clip.
slip edit An edit in which the location of both In and Out points of a sequence clip are
changed at the same time, without changing the location or duration of the clip. This is
referred to as slipping because you slip a pair of In and Out points inside the available
footage.
slug A generator in Final Cut Pro used to create black video in a sequence. A slug can be
used to represent a video clip that has not yet been placed.
SMPTE (Society of Motion Picture and Television Engineers) The organization responsible
for establishing various broadcast video standards and the SMPTE standard timecode for
video playback.
snapping A setting in the Timeline that affects the movement of the playhead. When
snapping is turned on, the playhead “snaps,” or moves directly, to markers or edit points
when it is moved close to them.
Snapping button A button in the upper-right corner of the Timeline that you click to
turn snapping on and off.
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SOT (sound on tape) Audio recorded on analog or digital video formats (audio and
video).
sound bite Typically a short excerpt from an interview clip, as used on news shows.
sound effects Specific audio material, such as the sound of a door closing or a dog
barking, from effects libraries or from clips you recorded. Sound effects can be used to
replace sounds in the location audio of a program, or to add sound that wasn’t originally
recorded.
sound recordist The individual on a film or video crew responsible for setting up the
audio recording equipment and for setting the levels and managing the audio recording
during a shoot.
soundtrack The audio that accompanies a program’s video.
Soundtrack Pro Audio File Project Also called an .stap file. This is the native file format
used by the Soundtrack Pro File Editor. Data is actually stored in a special Mac OS X format
called a package (or bundle). A Mac OS X package appears to be a single file in the Finder
but actually contains a collection of files such as the original audio file, temporary render
files, and the list of actions applied to your audio file.
Soundtrack Pro Multitrack Project Also called an .stmp file. This is the multitrack project
file format in Soundtrack Pro. As with Final Cut Pro project files, clip and Timeline
information is stored in the project file, and clips refer to media files stored elsewhere.
source media files The original files recorded on disk when ingesting tape-based media
or file-based media. The clips you use in Final Cut Pro are pointers that represent your
media files, but changes made to clips within Final Cut Pro do not affect the media files
on disk.
source monitor In a linear editing suite, a monitor that displays source tapes before
recording them to the master tape. In Final Cut Pro, the Viewer acts as the source monitor.
source tape The video and audio tapes that were originally recorded during a shoot.
Media files are captured from the source tapes, edited, and ultimately output to a final
master tape.
special effects Visual effects applied to clips and sequences, such as motion effects,
layering, and filters.
speed indicators Tick marks that display the speed of clips in a sequence. The spacing
and color of these tick marks indicate the speed and playback direction of the clips.
split edit An edit in which either the video or the audio portion of a clip ends up being
longer than the other; for example, when the sound is longer than the video at the head
of the clip, so it is heard before the video appears. Also referred to as an L-cut or J-cut.
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splits A method of delivering an audio mix of programs destined for foreign language
distribution, typically using a multitrack audio recorder. Separate mixes for dialogue,
music, and sound effects are recorded to separate pairs of audio tracks to make redubbing
the dialogue and remixing it back together easier.
static region An area in a sequence in the Timeline that you lock so that it is visible even
when you scroll to see other tracks. It can contain audio tracks, video tracks, or both.
When you create a static region, you get three regions in the Timeline: a top, scrollable
region for the other video tracks, a middle static region, and a bottom scrollable region
for the other audio tracks. You can’t scroll up or down in the static region, but you can
resize it to accommodate more or fewer tracks.
stereo, stereo pair Short for stereophonic, in which audio contains two different channels.
Items in a stereo pair are linked and are always edited together. Audio level changes are
automatically made to both channels at the same time. A pair of audio items may have
their stereo pairing turned on or turned off at any time. See also mono.
storyboard A series of pictures that summarizes the content, action, and flow of a
proposed project. When the Browser is in icon view, clips can be arranged visually, like a
storyboard. When dragged as a group into the Timeline, the clips are edited together in
the order in which they appear in the Timeline, from left to right and from top to bottom.
straight cut A cut in which both the video and audio clip items are cut at the same time.
streaming The delivery of media over a computer network.
subclip A clip that represents a portion of a clip’s media file.
Super 8 A consumer film format with a 4:3 aspect ratio.
Super 16 A film format for widescreen presentations, with a 15:9 (1.66) aspect ratio. Super
16 is frequently used when shooting a project intended to be blown up to 35 mm.
super-black Black that is darker than the levels allowed by the NTSC or ITU-R BT.601
engineering standard for video. The NTSC standard for black is 7.5 IRE in the United States,
and 0 IRE for PAL and for NTSC in Japan. For example, in the United States, 0 IRE is
considered super-black.
superimpose edit An edit in which a source clip item is placed into a track above a clip
item that’s already in the Timeline at the position of the playhead. If no In or Out points
are set in the Timeline and Canvas, the previously edited clip’s In and Out points are used
to define the duration of the incoming clip. Superimpose edits are used to overlay titles
and text onto video, as well as to create other compositing effects.
super-white White that is brighter than 100 IRE, the maximum level allowed by the ITU-R
BT.601 engineering standard for video.
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S-Video A high-quality video signal for high-end consumer video equipment. The image
looks sharper and has better color than composite video because S-Video sends the color
and brightness information separately, keeping the signals cleaner. Most low-cost
analog-to-digital video interfaces use S-Video as their highest-quality video signal. Also
known as Y/C.
swap edit See shuffle edit.
sweetening The process of creating a high-quality sound mix by polishing sound levels,
rerecording bad sections of dialogue, and recording and adding narration, music, and
sound effects.
sync The relationship between the image of a sound being made in a video clip (for
example, a person talking) and the corresponding sound in an audio clip. Maintaining
audio sync is critical when editing dialogue.
tabs In Final Cut Pro, tabs delineate projects in the Browser, sequences in the Canvas and
Timeline, and functions within the Viewer. You click a tab to open a project or go to a
specified function window, such as Video, Audio, Filters, or Motion. Tabs can also be
dragged out of the main window to create a separate window.
tail clip The last clip in a sequence, or the clip on the rightmost side when looking at an
edit point between two clips.
tape-to-tape editing suite An editing facility that uses automated switching equipment
to assemble a finished program from the original source tapes using the instructions
contained in an EDL.
TARGA An uncompressed image file format that stores images with millions of colors
plus an alpha channel. TARGA files are supported by nearly every platform and media
application.
telecine A machine that converts the images on film negatives to a videotape format. A
telecine is necessary if you shot your project on film and you want to edit it on video.
three-point editing An editing technique in which three out of four In and Out points
are set in a Browser clip and a sequence. When the edit is performed, the fourth edit
point is calculated automatically by Final Cut Pro.
thumbnail A tiny picture representing a clip. In Final Cut Pro, the thumbnail is, by default,
the first frame of a clip. You can change the frame, known as the poster frame, used as
that clip’s thumbnail by using the Scrub tool.
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thumb tabs (1) Small tabs between the audio and video scroll bars in the Timeline that
define separate groups of audio or video tracks with their own scroll bars. For example,
if you have more audio tracks than video tracks, you can use the thumb tabs between
your audio and video scroll bars to allocate more space to your audio tracks. (2) Small
tabs on either side of the Zoom slider that you drag to zoom in to or out of a sequence
in the Timeline.
TIFF (Tagged Image File Format) A widely used bitmapped graphics file format, developed
by Aldus and Microsoft, that handles monochrome, grayscale, 8- and 24-bit color. Can
have alpha channels.
timecode A signal recorded with your video that uniquely identifies each frame on tape.
The SMPTE format for timecode is hours: minutes: seconds: frames.
timecode gap An area of tape with no timecode at all. Timecode gaps usually signify the
end of all recorded material on a tape, but timecode gaps may also be caused by user
error, such as fast-forwarding too far past a section of previously recorded material and
recording additional footage. Video occurring after a timecode gap begins with a timecode
value of 00:00:00:00. See also reset timecode break.
Timeline A window in Final Cut Pro that displays a chronological view of an open
sequence. Each sequence has its own tab in the Timeline. You can use the Timeline to
edit and arrange a sequence. The order of the tracks in the Timeline determines the
layering order when you combine multiple tracks of video. Changes you make to a
sequence in the Timeline are seen when you play back that sequence in the Canvas. If
you modify clips in the Canvas, those changes can be seen in the Timeline. Note that the
Canvas and Timeline display only sequences that are currently open.
Timeline patch panel The section at the left of the Timeline containing the Audio, Source
and Destination, Track Visibility, Lock Track, and Auto Select controls.
title safe area Part of the video image that is guaranteed to be visible on all televisions.
The title safe area is the inner 80 percent of the screen. To prevent text in your video from
being hidden by the edge of a TV set, you should restrict any titles or text to the title safe
area. See also action safe area.
Tool Bench A window in Final Cut Pro that contains interface elements that you can use
to supplement information displayed in the Viewer and Canvas. The Tool Bench can
contain up to five tabs—Audio Mixer, Frame Viewer, QuickView, Video Scopes, and Voice
Over.
Tool palette A window in Final Cut Pro that contains tools for selecting, editing, zooming,
cropping, and distorting items in the Timeline. All tools in the Tool palette can also be
selected using keyboard shortcuts.
track header The area in the Timeline patch panel that contains controls for each track.
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tracks Layers in the Timeline that contain audio or video clip items in a sequence. Also
refers to the separate audio and video tracks on tape or within media files. Final Cut Pro
allows up to 99 video and 99 audio tracks to be used in a single sequence.
track strips In the Audio Mixer, each audio track in the currently selected sequence is
represented by a track strip, complete with solo and mute buttons, a stereo panning
slider, and a level fader.
Track Visibility control A control at the very beginning of each track that you click to
turn on or turn off a track. Tracks that are turned off don’t play in the Canvas or on an
external monitor, nor are they rendered or output to tape. When a track is turned off, it
appears darkened in the Timeline, but its contents remain in your sequence and you can
still edit them.
transferring The process of ingesting file-based media into a video editing system.
Transition Editor A specialized editor that appears in the Viewer when you double-click
a transition in the Timeline. You can use it to make detailed changes to a transition’s
timing and effects parameters.
transitions Effects that are applied to edit points to smooth out a change from clip to
clip. In Final Cut Pro, you can choose from a variety of video transitions, such as a dissolves
or wipes, or you can add an audio cross fade between audio clips.
Trim Edit window A window in Final Cut Pro that displays both sides of an edit point.
For example, if Clip A cuts to Clip B, the Out point of Clip A is shown on the left and the
In point of Clip B is shown on the right. You can use this window to adjust the edit point
between two clips very precisely, frame by frame.
trimming (1) Precisely adjusting and defining the In and Out points of a clip. (2) Modifying
an edit point in the Timeline by moving it earlier or later. (3) Fine-tuning an edited
sequence by making small adjustments to many edits.
two shot A scene that includes two people in the frame.
U-Matic A 3/4" analog tape format once popular for broadcast.
underscan To display the entire video frame on a video monitor, so that no part of the
frame is masked. Computers display underscan video. Some broadcast monitors have a
setting that can turn on an overscan video signal to display as underscan. See also
overscan.
variable speed Speed that varies dynamically, in forward or reverse motion, in a single
clip.
VCR Abbreviation for videocassette recorder. Generally refers to consumer equipment
used for recording video from various sources. Sometimes referred to as a VTR.
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VDU Abbreviation for Video Disk Unit. This is a FireWire disk recorder that uses a hard disk
drive as its recording media. The drive attaches directly to professional-quality DVCAM
camcorders through FireWire and is capable of recording up to 3 hours of video/audio
signals in parallel with tape recording.
Vectorscope A window in Final Cut Pro that graphically displays the color components
of a video signal, precisely showing the range of colors in a video signal and measuring
their intensity and hue. It is a specialized oscilloscope that can be used to calibrate the
color in video signals being captured from videotape, as well as to compare two clips for
purposes of color correction.
velocity The acceleration or deceleration of a clip’s motion.
velocity handle A control you use to change the velocity of a clip’s motion over time.
Dragging the velocity handle toward the selected keyframe slows down the clip’s motion
at the beginning and speeds it up as it nears the next keyframe. Dragging away from the
selected keyframe speeds up the clip’s motion at the beginning and slows it down as it
nears the next keyframe.
VHS (Video Home System) An analog videocassette recorder system designed for
consumer use.
View buttons Use to switch among three different views of the Audio Mixer. Each view
has its own set of hidden and displayed track strips.
Viewer A window in Final Cut Pro that you can use to watch individual source clips and
set In and Out points in preparation for editing them into your sequence. You can also
customize transitions, modify filters, and view and edit various effects. Clips from the
current sequence in the Timeline can be opened in the Viewer to refine edits, adjust
parameters for effects, and adjust audio volume.
videographer The person responsible for lighting and camera on a video shoot.
video scopes Tools you can use to evaluate the color and brightness values of video clips
in the Viewer, Canvas, or Timeline. Video scopes display an analysis of the video frame
located at the current playhead position.
Video Scopes tab A tab in the Tool Bench that contains the Waveform Monitor,
Vectorscope, RGB Parade scope, and Histogram.
video switcher A device with multiple video inputs that allows you to cut or transition
between several sources. Video switchers are commonly used in tape-to-tape editing
suites.
video track A track in the Timeline into which you can edit video clip items.

Glossary

1987

VITC Stands for vertical interval timecode. Timecode that is written into the video signal
on the source tapes as they’re being recorded. You can view this timecode as a series of
changing, flickering white dots and line segments in one of the scan lines above the
active picture on a monitor in underscan or pulse-cross mode. When viewed normally,
the line containing the timecode is off the top of the screen. Because it’s part of the video
signal, VITC timecode can’t be changed on your original tapes without also replacing the
video signal. See also LTC.
Voice Over tool Allows you to record audio in Final Cut Pro while simultaneously playing
back a specified section of a sequence from the Timeline. Audio can be recorded using
any Mac OS X Core Audio-compatible device, such as a USB audio capture device, a PCI
audio card, or the built-in microphone on a DV camcorder.
VTR Abbreviation for videotape recorder. Generally refers to professional equipment used
for recording video from various sources.
VU meter Short for Volume Unit meter. An analog meter for monitoring audio levels.
WAVE An audio file format based on the general-purpose RIFF format developed by
Microsoft and IBM. WAVE files contain “chunks” identified by a four-letter code. For
example, WAVE files store audio samples in a “data” chunk, and format information such
as sample rate is stored in an “fmt” chunk. WAVE files typically store uncompressed audio
using pulse-code modulation (PCM), but it is also possible to store compressed audio
samples.
Waveform Monitor A window in Final Cut Pro that displays the relative levels of brightness
and saturation in the clip currently being examined. Spikes or drops in the displayed
waveforms make it easy to see where the hot spots or dark areas are in your picture.
white balance To make adjustments to a video signal being recorded in order to
reproduce white as true white. For example, if the white in a shot is too yellow because
of incandescent lighting, white balancing adds enough blue to make the white appear
neutral.
white level An analog video signal’s amplitude for the lightest white in a picture,
represented by IRE units.
widescreen Any movie presentation that has an aspect ratio wider than 4:3. In movie
theaters, 1.85 is considered standard and 2.40 is considered widescreen. For video, 4:3 is
considered standard and 16:9 (which is almost the same aspect ratio as 1.85) is considered
widescreen. See also 16:9.
window burn Visual timecode or keycode information superimposed onto video frames.
It usually appears on a strip at the bottom or top of the frame, providing timecode
information to the editor without obscuring important details of the picture.
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wipe A transition in which a geometric or grayscale gradient is used to transition between
two clips.
wipe pattern One of several standard SMPTE wipe transitions recognized by EDLs. Because
the EDL format continues to reflect the simplicity of older systems, many Final Cut Pro
transitions have no equivalent in a given EDL format. Therefore, during the EDL export
process, these new transitions are automatically mapped to the closest approximate
SMPTE standard wipe pattern.
wireframe modes Viewer and Canvas view modes that show the outline of a clip’s video
frame. Clips in the Viewer and Canvas can be viewed in Wireframe mode or
Image+Wireframe mode.
x Refers to the x coordinate in Cartesian geometry. The x coordinate describes horizontal
placement in motion effects.
XDCAM Sony optical disc format for recording DVCAM and IMX video within MXF
container files.
XDCAM HD An extension of the Sony XDCAM format that supports high definition video
recording at three quality levels. XDCAM HD uses long-GOP MPEG-2 compression similar
to the compression used in HDV.
xmeml Abbreviation for eXtensible Media Editing Markup Language. The custom set of
markup tags used by the Final Cut Pro XML Interchange Format.
XML Abbreviation for Extensible Markup Language. XML is a method of storing information
in an easily accessible yet customizable file format. XML files are plain ASCII text files used
by Final Cut Pro for data exchange among different applications and operating systems.
Xsan Apple software for clustering multiple RAIDs together into a storage area network
(SAN). Multiple computer systems can read and write to the shared storage area
simultaneously, allowing several editors to work in parallel using the same media files.
y Refers to the y coordinate in Cartesian geometry. The y coordinate describes vertical
placement in motion effects.
Y′CBCR The color space in which many digital video formats store data. Three components
are stored for each pixel—one for luma (Y) and two for color information (CB for the blue
difference signal and CR for the red difference signal). Also referred to as YUV.
YUV See Y′CBCR.
zebra stripes Animated diagonal “marching lines” that are superimposed over areas of
an image that are very near or exceed the broadcast-legal limits. Zebra stripes are turned
on when you use the Final Cut Pro range-checking options.

Glossary

1989

zoom level The level at which the Viewer, Canvas, or Timeline is magnified. You can
adjust the level of precision of your editing by setting the zoom level. For example, by
zooming in on the Timeline, you can make changes to a clip’s individual frames. Conversely,
you can zoom all the way out to see the entire project and work on very large sections
at once.
Zoom slider The slider control that appears at the bottom of the Timeline. The Zoom
slider allows you to navigate throughout the total duration of the currently displayed
sequence; you can use the thumb tabs on the left and right of the slider to zoom in to
and out of a sequence for a more detailed view.
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