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Welcome to Logic Pro

If you are new to Logic Pro or have a limited knowledge of the 
application, this guide is for you.

Each chapter of this book presents major features and guides you in trying things out. 
Chapter 2 lets you build a basic project from scratch, while the remaining chapters take 
you through the entire production process including recording, arranging, editing, and 
mixing.

This guide assumes that you’ve installed Logic Pro on your computer. If you haven’t, see 
the Installing Your Software booklet that comes with Logic Studio.

You should also connect the music equipment that you plan to use, such as your MIDI 
keyboard, audio interface, musical instruments, or microphone, to your computer. For 
full details, see the “Setting Up Your System” chapter in the Logic Pro User Manual. (Open 
Logic Pro, choose Help > Logic Pro Help, then click Logic Pro 9:  User Manual.)
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Opening the Demo Project
While you can use your own projects to support the tasks in this guide, many of the 
tasks from Chapter 4 onward reference the contents of “The Numbers Game,” a demo 
project taken from Thievery Corporation’s fifth studio album, Radio Retaliation, and 
featuring Chuck Brown.

To open “The Numbers Game” demo project:
Open Logic Pro, then choose Help > Exploring Logic Pro Demo Project.mm

Using Key Commands
You can execute nearly every Logic Pro function with a computer keyboard shortcut, 
known as a key command. This book includes references to those key commands 
that have default computer keyboard shortcuts, using the U.S. and “U.S. with Numeric 
Keypad” keyboard presets.

You can use the Key Commands window to assign key commands to your computer 
keyboard, allowing you to suit your own working style.

To open the Key Commands window:
Choose Logic Pro > Preferences > Key Commands in the main menu bar (or press mm

Option-K).

Full details on the Key Commands window are found in the Logic Pro User Manual. 
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Building a Basic Project

This chapter gets you up and running with Logic Pro in the 
shortest possible time.

If you are new to digital music production, you can use this chapter to learn how to use 
the basic features of Logic Pro to build a simple music project from scratch.

Creating a Project
You’ll start by opening Logic Pro and creating a new project, then you’ll save it.

Open Logic Pro and create a new project:
Double-click the Logic Pro icon in your Applications folder.1	
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In the Templates dialog that appears, click the Empty Project button.2	

Empty Project button

In the New Tracks dialog, select the Software Instrument option, then click the Create 3	
button.
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Understanding Tracks and Regions
An audio track is a lane in the Arrange area that is used for the playback, recording, 
and editing of audio regions.

An audio region is a rectangular object that resides on an audio track. It can be freely 
edited and its boundaries correspond to start and end points within the underlying 
audio file it is associated with.

A software instrument track is a lane in the Arrange area that is used for the playback, 
recording, and editing of MIDI regions, which play internal software instruments.

A MIDI region is a rectangular object that resides on a software instrument track. It 
contains MIDI events—individual notes or commands—that are generally created 
with a MIDI keyboard.
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After creating a project, you can quickly save it. When you save a project, a project file 
is saved within a project folder—which can contain the project’s audio files and other 
assets (such as sample and movie files). Saving a project with assets simplifies archiving 
and exchanging projects but increases the project folder’s size.

Save the project:
Choose File > Save As in the main menu bar (or press mm Command-Shift-S), make the 
following selections in the Save As dialog, then click Save.

Type a project name.

Browse to a save location.

Ensure that the Include 
Assets and “Copy external 
audio files to project 
folder” checkboxes are 
selected.

Selecting additional 
options increases the 

project folder’s size.
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Exploring the Arrange Window
The Arrange window is the primary working window of Logic Pro. It incorporates all 
working areas and editors, including the Arrange area.

The Arrange area is the primary working space of Logic Pro. It is used to record, edit, 
and arrange the audio and MIDI regions of a project.

Your Arrange window should look similar to this:

Inspector button Media button

Transport barInspector

Editor buttons

Arrange area  
(white frame 
indicates key 
focus area)

Library tab
Toolbar
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Try This
Explore the Inspector:
Click the Inspector button to hide or show the Inspector. The Inspector shows mm

parameters for the selected working area or editor. For example, if the Arrange area 
is active (indicated by a white frame), you can set region and track parameters. Also 
shown are the channel strips that reference the selected track in the Arrange area.

Click the Score button at the bottom of the Arrange area. The Inspector now shows mm

parameters that are relevant to working in the Score Editor.

Click the Arrange area. The Inspector again shows parameters and channel strips that mm

are relevant to working in the Arrange area.

Click the disclosure triangle to the left of MIDI Thru at the top of the Inspector. This mm

shows or hides the area where you set parameters for the selected region in the 
Arrange area.

Click the disclosure triangle to the left of Inst 1 at the top of the Inspector. This shows mm

or hides the area where you set parameters for the selected track in the Arrange area.

Get to know the toolbar:
Control-click the toolbar, then choose Customize Toolbar from the shortcut menu. This mm

dialog shows the full list of functions accessible from the toolbar. You can access or 
hide certain onscreen areas, such as the Media or Lists area, or carry out key functions, 
such as zooming the track and splitting regions.
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View the editors:
Click the Sample Editor, Piano Roll, and Score buttons at the bottom of the Arrange mm

area. Clicking these buttons shows or hides the editors—where you edit audio and 
MIDI regions.

Click the Mixer button. This shows or hides the area where you mix your project.mm

Get to know the Transport bar:
Control-click the Transport bar, then choose Customize Transport Bar from the shortcut mm

menu. This dialog shows the full list of functions accessible from the Transport bar. You 
use the Transport bar to control recording and playback functions.

Explore the Media area:
Click the Media button at the top right of the Arrange window. This shows or hides the mm

Media area—where you access audio and MIDI files, either your own or prerecorded.

Click the Bin tab to reveal an area that is used for project audio file and region mm

management and conversion tasks.

Click the Loops tab to reveal an area that contains prerecorded loops for adding to mm

your project.

Click the Library tab to reveal an area that is used to handle all settings files for channel mm

strips, effects, and instruments.

Click the Browser tab to reveal an area that is used to browse, select, and manage all mm

media types supported by Logic Pro.
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Playing Instruments
You use the Library to insert an instrument, plus its effects, into a track’s channel strip. 
This allows you to play the instrument from the selected track.

Getting Ready
Click the Library tab in the Media area if the Library is not open.mm

Try This
Load an instrument (plus its effects):
Navigate through the categories and subcategories in the Library, then click any of the 1	
entries (known as settings).

The chosen instrument and its effects are loaded to the selected track’s channel strip in 
the Inspector.

Use your MIDI keyboard (or the Logic Pro Caps Lock keyboard) to play some notes.2	
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Use the Caps Lock keyboard to generate MIDI notes:
Press the Caps Lock key on your computer keyboard to reveal a virtual keyboard on 1	
the screen.

Use your computer keys as follows to generate MIDI notes:2	

Use the numeric keys to define the octave for the MIDI keyboard.ÂÂ

Use the first two rows of letter keys as counterparts for MIDI keyboard keys.ÂÂ

Use the lowest row of letter keys to set MIDI note velocity.ÂÂ

Use the Space bar for the Sustain function.ÂÂ
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Adding Apple Loops
You can start composing a song by dragging Apple Loops from the Loop Browser 
to the Arrange area. Apple Loops are prerecorded musical phrases or riffs that are 
available in a variety of instruments, genres, and moods.

There are two types of Apple Loops—Apple Loops audio files and software instrument 
Apple Loops files—and you can add them to your project in the following ways:

Add Apple Loops audio files to audio tracks. The resulting audio region on the track ÂÂ
contains the original audio recording.

Add software instrument Apple Loops files to software instrument tracks. The ÂÂ
resulting MIDI region contains the original MIDI performance, with its instrument and 
effect settings added to the track’s channel strip.

Add software instrument Apple Loops files to audio tracks. The resulting audio region ÂÂ
contains the original audio recording, without the instrument and effect settings.
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Getting Ready
Open the Loop Browser:
Click the Loops tab in the Media area, then click one of the category buttons.mm

Green labels indicate software 
instrument Apple Loops files.

Blue labels indicate Apple Loops 
audio files.

Category buttons

View buttonsReset button

Search field
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Try This
Preview Apple Loops:
Click any loop at the bottom of the tab to start playback. A second click stops playback. mm

Repeat this for different loops.

Add a software instrument Apple Loops file:
Click the Reset button in the Loops tab to reset any active category button selection.1	

Click the Rock/Blues category button, locate Classic Rock Steel 01, then drag the loop 2	
onto the Inst 1 track, aligning its start position at bar 1. 

A MIDI region is added to the track. The MIDI region contains the original MIDI 
performance, with its instrument and effect settings added to the track’s channel strip.

Effects

MIDI region

Instrument
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Search for a software instrument Apple Loops file:
Click the Reset button, type “Woody Latin Bass 01” in the Search field, then press the 1	
Return key. 

The matching file is displayed in the file list.

Search field

Search result

Drag Woody Latin Bass 01 into the empty Arrange area, to start at bar 1. 2	

A new software instrument track is created, with the loop added to it.
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Add an Apple Loops audio file to your project:
Click the All Drums button, then drag Live Edgy Drums 05 into the empty Arrange area, mm

to start at bar 1. A new audio track is created, with the original audio recording added 
to it.

Audio region

Add a software instrument Apple Loops file to an audio track:
Click the Reset button, followed by the Elec Piano button, then drag Fusion Electric mm

Piano 01 onto the existing audio track lane, directly after Live Edgy Drums 05. The 
software instrument Apple Loops file is added as an audio region, containing the 
original audio recording.

Browse Apple Loops by category:
Click the left View button to switch to Column view.1	

Click here to switch to 
Column view.
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Click the By Genres category folder, followed by Electronic in the second column, 2	
followed by Beats in the third column. 

The value in brackets indicates the number of files that fall into this subcategory 
(Beats). The files are shown at the bottom of the tab.

Tag Apple Loops as Favorites:
For any Apple Loops that you like, or wish to use again later, select the Fav (Favorites) mm

checkbox.

This adds the loop to the Favorites category, displayed whenever you click the Favorites 
button or category.
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Navigating the Project
You control navigation and playback actions with the Transport bar or Bar ruler.

Transport bar:ÂÂ

Bar ruler:ÂÂ

Bar ruler

Playhead (indicates the 
current playback position)

The Transport bar and Bar ruler are closely tied to each other, with several functions 
accessible in both. These include the Play and Stop commands, activation of Cycle 
mode, and setting the cycle length.
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Try This
Start and stop playback:
Click the Play button on the Transport bar (or press the Space bar on your computer mm

keyboard) to start playback.

Stop button Play button

Click the Stop button on the Transport bar (or press the Space bar) to stop playback.mm

Double-click the lower part of the Bar ruler to start playback from the clicked position. mm

Another double-click stops playback.

Double-click the lower part 
of the Bar ruler.
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Move the playhead:
Click the lower part of the Bar ruler to move the playhead to the clicked position.mm

Drag the playhead to a new position.mm

Press the Return key when the project is mm not playing. The playhead moves to the 
project start position.

Click the Rewind or Forward button on the Transport bar during playback.mm

Rewind button

Forward button

With each click, the playhead either jumps back to the previous bar (Rewind) or ahead 
to the next bar (Forward).
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Loop playback of a project section:
Click the shaded gray cycle area in the top part of the Bar ruler.1	

Click here to activate 
the cycle.

The cycle range is activated between the left and right locator positions.

Left locator Right locator

Drag the left or right locator in the Bar ruler to extend or shorten the cycle range.2	

Press the Space bar to start playback. 3	

The playhead continually loops playback within the cycle range.
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Setting the Project Tempo
New projects default to a project tempo of 120 bpm or to the native tempo of the first 
Apple Loops file added. When you add subsequent Apple Loops, they automatically 
play at the project tempo. You can adjust the tempo to suit the style or mood of your 
music.

Tempo display

Try This
Set the project tempo:
Press the Space bar to start playback of the project.1	

Drag the Tempo display vertically—upward for a faster tempo or downward for a 2	
slower tempo.

The project tempo changes in real time, making it easier to find the most suitable 
tempo for your project.
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Exploring the Audio Bin
The Audio Bin can be viewed as an audio file catalog for your project. Once an audio 
file has been added to your project, it appears in the Bin.

Getting Ready
Open the Bin:
Click the Bin tab at the top of the Media area (or press the B key). The two Apple Loops mm

audio files you added to the audio track in the previous section appear in the Bin.

The Info column displays audio file and region information. The horizontal bars indicate 
the overall audio file length. The colored sections of these bars indicate the location 
and size of audio regions within the audio file.

Try This
Import an audio file into the Bin:
Choose Audio File > Add Audio File, browse to a location where you’ll find an audio file, mm

click the Add button, then click the Done button. The audio file is added to the Bin.

Add an audio file to the Arrange area:
Drag the audio file you just imported from the Bin into the Arrange area.mm
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Choosing Tools
Key to selecting and altering audio and MIDI regions in the Arrange area are the tools. 
You change the currently active tool by choosing the appropriate Tool menu item. 
The pointer adopts the shape of the selected tool, making it easy to recognize. In this 
section, you’ll assign tools that can be accessed via left-clicking or Command-clicking.

Command-click Tool menu

Left-click Tool menu
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Try This
Choose a tool:
Click the Left-click Tool menu at the upper right of the Arrange area, then choose a mm

tool.

Press the Esc key mm on your computer keyboard. The Tool pop-up menu floats at the 
current pointer position. Choose a tool from the pop-up menu to make it active. Press 
the Esc key twice more to make the Pointer tool active.

Click the Command-click Tool menu at the upper right of the Arrange area, then mm

choose a tool. A second tool is assigned for use via Command-click.
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Zoom regions:
With the Zoom tool selected, drag across the Classic Rock Steel 01 region. The screen is mm

zoomed in on the selected area.

With the Zoom tool selected, click anywhere in the Arrange area background. The mm

zoom level returns to the original setting or backtracks through previous zoom steps if 
the tool was used multiple times.

If the Zoom tool is not assigned in the Tool menu, holding down the Control and Tip: 
Option keys provides quick access to the zoom in and out behaviors just described.
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Creating a Basic Arrangement
You’ll do the majority of region editing and arrangement in the Arrange area. Besides 
standard copy, cut, and paste operations, you can move, delete, loop, and resize regions, 
and more.

Try This
Move regions:
Using the default Pointer tool, drag Woody Latin Bass 01 to bar 5 and Live Edgy Drums mm

05 to bar 9.

Delete a region:
Select the Fusion Electric Piano 01 mm audio region on the audio track, then press the 
Delete key. The region is deleted from your arrangement but not from the project. Click 
the Audio Bin tab and you’ll find that the region is still there.

Loop regions:
Drag the upper-right corner of the Classic Rock Steel 01 region to the right (note the mm

Loop pointer), up to bar 9.

Loop pointer
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Drag across the other two regions to select them, then select the Loop checkbox in mm

the Inspector’s Region Parameter box. The two selected regions loop to the project end.

Loop checkbox

Region Parameter box

Press the L key to quickly loop or unloop selected regions.Tip: 
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Change the length of regions:
Drag the lower-right corner of the Woody Latin Bass 01 region from bar 9 to bar 7. The mm

looped regions are also resized in length.

Resize pointer
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Exploring a Track’s Channel Strip
A track’s content is played back through a channel strip.

Audio channel stripsÂÂ  control the playback and recording of audio signals on audio 
tracks.

Instrument channel stripsÂÂ  allow you to use and control software instruments. Software 
instrument plug-ins are inserted into the channel strip’s Instrument slot. The 
instrument channel strip can then be driven by a recorded MIDI region, or by direct 
MIDI input—playing your MIDI keyboard.

You’ll explore some of the channel strip controls that are used when playing back a 
track’s content through a channel strip.
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Getting Ready
Display a track’s channel strip:
Select any software instrument track in the Arrange area, and activate the Inspector mm

button (or press the I key).

Solo button

Mute button

Instrument slot (instrument 
channel strips only)

Insert slot

Volume fader

Pan/Balance knob
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Try This
Mute and unmute channel strips and tracks:
Click the channel strip Mute (M) button. The track Mute button is also activated.mm

Click the track Mute button (or press Control-M). The channel strip Mute button is also mm

activated.

Drag over the Mute buttons of several tracks. They are all activated in one swipe.mm

Command-click the track Mute button. The mute state of all Mute buttons is cleared.mm

Solo and unsolo channel strips and tracks:
Repeat each of the previous tasks but this time using the channel strip Solo (S) button mm

and the track Solo button (or pressing Control-S).

Adjust the volume level of a channel strip:
Drag the channel strip’s Volume fader up or down.mm

Option-click the Volume fader. The Volume fader is reset to the default value.mm

Adjust the panning or balance of a channel strip:
Drag the Pan/Balance knob vertically or horizontally.mm

Option-click the Pan/Balance knob. The Pan/Balance knob is reset to the default value.mm

Open an existing plug-in:
Double-click any used Insert slot or Instrument slot on the channel strip. The plug-in mm

window of the inserted effect opens.
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Exporting the Project
To share your music project, you can export it in various audio file formats such as MP3 
or AIFF. You can also add it directly to your iTunes library. This export process is known 
as bouncing.

Try This
Bounce your mix:
Click the Bounce button in the top right of the Arrange toolbar.1	
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In the Bounce dialog, choose your settings for MP3 file creation:2	

If the cycle is active, only the project section spanned by the cycle area is Note: 
exported. You can change this by editing the Start and End fields in the Bounce dialog.

Select the “Add to iTunes library” checkbox to add the file to your iTunes library.3	

Click the Bounce button.4	

The project section is bounced.
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Key Concepts
Project:  ÂÂ A Logic document. It contains all MIDI regions and references to the audio 
files to be played back. A project file is saved within a project folder, which can 
contain the project’s audio files and other assets (such as video and sample files). 
Saving a project with assets simplifies archiving and exchanging projects but 
increases the project folder’s size.

Audio track:  ÂÂ A lane in the Arrange area that is used for the playback, recording, and 
editing of audio regions.

Audio region:  ÂÂ A rectangular object that resides on an audio track. It can be freely 
edited, and its boundaries correspond to start and end points within the underlying 
audio file it is associated with.

Software instrument track:  ÂÂ A lane in the Arrange area that is used for the playback, 
recording, and editing of MIDI regions, which play internal software instruments.

MIDI region:  ÂÂ A rectangular object that resides on a software instrument track. It 
contains MIDI events—individual notes or commands—that are generally created 
with a MIDI keyboard.

Arrange window:  ÂÂ The primary working window of Logic Pro. It incorporates all 
working areas and editors, including the Arrange area.

Arrange area:  ÂÂ The primary working space of Logic Pro. It is used to record, edit, and 
arrange the audio and MIDI regions of a project.

Inspector:  ÂÂ Area at the left edge of the Arrange window and editors, containing the 
Parameter boxes and channel strips of the selected track.

Toolbar:  ÂÂ Area at the top of the Arrange window where you can access or hide certain 
onscreen areas or carry out key functions.



42 Chapter 2    Building a Basic Project

Editors:  ÂÂ Areas below the Arrange area where you can edit audio and MIDI regions, or 
mix your project.

Transport bar:  ÂÂ Area at the bottom of the Arrange window where you can control 
recording and playback functions.

Media area:  ÂÂ Area containing several tabs where you can access audio and MIDI files, 
either your own or prerecorded.

Bin tab:  ÂÂ Tab within the Media area that is used for project audio file and region 
management and conversion tasks.

Loops tab:  ÂÂ Tab within the Media area that contains prerecorded loops for adding to 
your project.

Library tab:  ÂÂ Tab within the Media area that is used to handle all setting files for 
channel strips, effects, and instruments.

Browser tab:  ÂÂ Tab within the Media area that is used to browse, select, and manage all 
media types supported by Logic Pro.

Instrument slot:  ÂÂ A panel on a channel strip where you insert an instrument plug-in.

Insert slot:  ÂÂ A panel on a channel strip where you insert an effect plug-in.

Bar ruler:  ÂÂ Ruler at the top of the Arrange area. It displays musical time units, including:  
bars, measures, beats, and beat divisions.

Playhead:  ÂÂ A vertical white line that indicates the current playback position in all 
horizontal, time-based windows.

Left and Right locators:  ÂÂ Locators that define the start and end points of a cycle range 
in the Bar ruler.

Cycle function:  ÂÂ A function that constantly repeats the area between the left and right 
locator positions.
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Apple Loops:  ÂÂ Prerecorded audio and MIDI-based files located in the Loop Browser.

Channel strip:  ÂÂ A virtual representation of a mixing console channel strip. Contains 
Mute and Solo buttons, Volume fader, Pan/Balance control, Insert slots, and more.

Audio channel strip:  ÂÂ Controls the playback and recording of audio signals on an audio 
track.

Instrument channel strip:  ÂÂ Allows you to use and control software instruments. 
Software instrument plug-ins are inserted into the channel strip’s Instrument slot. The 
instrument channel strip can then be driven by a recorded MIDI region or by direct 
MIDI input—playing your MIDI keyboard.
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Working with Instruments 
and Effects

Logic Pro provides a number of ways to add instruments and 
effects to your channel strips.

Channel strips contain Insert slots, which are used for inserting effects. Effects color or 
shape the tone of existing audio recordings, software instruments, and external audio 
sources in real time. Instrument channel strips also feature an Instrument slot, which is 
used for inserting instruments. Instruments are used for real-time playback in Logic Pro.

Instrument slot (instrument 
channel strips only)

Insert slots
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You can choose whether to insert effect and instrument plug-ins on an individual 
basis, directly on the channel strip’s Insert and Instrument slots, or to load channel strip 
settings. You’ll experiment with both methods in this chapter.

Adding Individual Instruments and Effects
In this section, you’ll add instrument and effects plug-ins directly on the channel strip. 

Getting Ready
Create a software instrument track and display the Inspector:
Do one of the following:1	

If you are using an existing project, click the Add (+) button above the track list, select ÂÂ
the Software Instrument option in the New Tracks dialog, then click Create.

If you want to create a new project, see Chapter 2 for details.ÂÂ

If the Inspector is not visible, click the Inspector button in the Arrange toolbar (or press 2	
the I key).
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Try This
Insert an instrument into a channel strip:
Click the Instrument slot on the left Arrange channel strip, then choose any instrument mm

from the plug-in menu. The plug-in is loaded and the window opens. Use your MIDI 
keyboard (or the Logic Pro Caps Lock keyboard; see Chapter 2) to play some notes.

Instrument slot with 
instrument plug-in loaded
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Insert an effect into a channel strip:
Click the top Insert slot on the left Arrange channel strip, then choose any effect from mm

the plug-in menu. The plug-in is loaded and the window opens.

Insert slot with effect 
plug-in loaded
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Insert an EQ into a channel strip:
Double-click the EQ area at the top of the left Arrange channel strip. A Channel EQ is mm

automatically inserted into the first available Insert slot if the top one is already used, 
which it would be if you’ve followed the previous steps.

Insert slot with 
Channel EQ loaded

EQ area

You can also Option-double-click the EQ area to insert the Channel EQ as the first plug-
in, moving all existing plug-ins one slot down.

Replace a plug-in:
Click and hold down any occupied Instrument slot or Insert slot, then choose a mm

different plug-in from the respective pop-up menu. If a plug-in window is already open, 
it updates to reflect the new plug-in. Otherwise, a new plug-in window opens.
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Remove a plug-in:
Click any occupied Instrument slot or Insert slot, then choose No Plug-in from the pop-mm

up menu. The plug-in is removed from the slot, leaving it empty.

Deactivate a plug-in without removing it:
Option-click the occupied Instrument slot or Insert slot. The slot turns from blue to gray, mm

which indicates that the plug-in is on the channel strip but no longer active.

Bypassed plug-in

Double-click the occupied Instrument slot or Insert slot, then click the Bypass button at mm

the left of the plug-in window header.

Indicates an 
active plug-in.

Indicates a 
bypassed plug-in.
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Working with Plug-in Settings
A plug-in setting is a set of plug-in parameter values that can be loaded, saved, copied, 
or pasted via the Settings menu.

Click here to access the 
Settings menu in the 
plug-in header.

Plug-in settings are stored with the project file and are automatically recalled the next 
time the project is loaded. You can change these settings individually by adjusting 
individual parameters or by loading an entire setting for the plug-in. You can also save 
and recall any changes you make to plug-in settings.

Getting Ready
Open a plug-in window (if one is not already open):
Double-click any occupied Instrument slot or Insert slot.mm
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Try This
Adjust individual plug-in settings:
Adjust individual controls in any open plug-in window.mm

Click switches or buttons to turn the parameter on or off.ÂÂ

Drag knobs vertically to adjust the parameter value.ÂÂ

Drag slider handles to adjust the parameter value.ÂÂ

Option-click a parameter to reset it to the default value.ÂÂ

Save the new plug-in settings:
Choose Save Setting As from the Settings menu, type a name for the new setting, then mm

click Save. A new entry (with the name you entered) is added to the Settings menu, just 
above the list of presets.
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Load a setting:
Choose a different setting from the list of presets at the bottom of the Settings menu.mm

Reload the setting you saved previously from the Settings menu.mm

Click the Next or Previous Setting buttons in the plug-in header. The next or previous mm

setting from the list of presets is loaded.

Previous Setting button

Next Setting button

Click any occupied Instrument slot or Insert slot. A white frame appears around the slot, mm

and the Library tab updates to display a list of settings (preset patches) for the chosen 
plug-in. Choose a different setting to load it for the selected plug-in.
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Loading Channel Strip Settings
You can load a whole chain of plug-ins using channel strip settings. When you load a 
channel strip setting to an audio channel strip, you load a chain of effects. In the case of 
instrument channel strips, you load an instrument and a chain of effects.

Channel strip settings can be accessed from the Setting button directly on the channel 
strip or from the Library tab in the Media area.

Getting Ready
Select a software instrument track and open the Library:
Select the software instrument track used in the previous section.1	

Click the Library tab in the Media area if the Library is not open.2	
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Try This
Load a channel strip setting from the Library:
Navigate through the categories and subcategories in the Library, then click any of the 1	
entries (known as settings).

The Setting button, Insert slots, and Instrument slot on the left Arrange channel strip 
are updated to reflect the channel strip setting and its effect and instrument plug-ins.

Setting button

Instrument slot

Insert slots

Use your MIDI keyboard (or the Logic Pro Caps Lock keyboard; see Chapter 2) to play 2	
some notes.
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Repeat steps 1 and 2, trying out different channel strip settings. Play some notes on 3	
your keyboard after each change of setting.

Load a channel strip setting in the Arrange channel strip:
Click and hold down the Setting button in the left Arrange channel strip, navigate mm

through the setting categories and subcategories, then click one.

The Setting button, Insert slots, and Instrument slot on the left Arrange channel strip 
are updated to reflect the channel strip setting and its effect and instrument plug-ins.
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Select the previous or next channel strip setting:
Click the Setting button in the left Arrange channel strip, then choose Previous Channel mm

Strip Setting or Next Channel Strip Setting from the pop-up menu. The Setting button, 
Insert slots, and Instrument slot on the channel strip are updated to reflect the new 
setting.

Save and recall a channel strip setting:
Navigate through the categories and subcategories in the Library, then click any of the 1	
entries.

The Setting button, Insert slots, and Instrument slot on the left Arrange channel strip 
are updated to reflect the channel strip setting and its effect and instrument plug-ins.

Click the left Arrange channel strip’s third Insert slot, then choose Amps and Pedals > 2	
Amp Designer. The Amp Designer plug-in window opens. Change some settings.

Click the channel strip’s Setting button, choose “Save Channel Strip Setting as” from the 3	
pop-up menu, type a name for the channel strip setting in the dialog, then click Save.

Click the channel strip’s Setting button, then choose a different setting from the pop-4	
up menu. 

Your channel strip setting is replaced with the new one.

Click the Setting button, then choose your previously saved channel strip setting from 5	
the pop-up menu. 

Your previously saved setting is recalled.

Reset a channel strip setting:
Click the Setting button in the left Arrange channel strip, then choose Reset Channel mm

Strip from the pop-up menu. In a single action, the channel strip setting name, the 
Instrument slot, and the Insert slots are reset to their default values.
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Key Concepts
Channel strip:  ÂÂ A virtual representation of a mixing console channel strip. Can be used 
to insert instruments and effects using the channel strip’s Instrument and Insert slots.

Instrument slot:  ÂÂ A panel on a channel strip where you insert an instrument plug-in.

Insert slot:  ÂÂ A panel on a channel strip where you insert an effect plug-in.

Effects:  ÂÂ Color or shape the tone of existing audio recordings, software instruments, 
and external audio sources, in real time.

Instruments:  ÂÂ Used for real-time playback in Logic Pro.

Channel strip setting:  ÂÂ Represents the routing of a channel strip, including all inserted 
effects or instruments (plus their settings).

Library tab:  ÂÂ Tab within the Media area that is used to handle all setting files for 
channel strips, effects, and instruments.

EQ:  ÂÂ Shortened form of equalizer. Equalizers are used to boost or cut frequencies in an 
audio signal.
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Recording and Comping Audio

You can record and comp audio directly in the Arrange area.

In this chapter, you’ll try out some basic audio recording techniques and experiment 
with take folder editing and comping.

Setting the Metronome and Count-in
As preparation for recording, you should check the metronome and count-in settings.

Metronome:  ÂÂ Produces a click in the project’s tempo that can be heard during 
recording or playback. The click makes it easier to play in time with the tempo.

Count-in:  ÂÂ Clicks heard before the start of a recording, making it easier to get into the 
project’s groove.

Try This
Set the metronome:
Control-click the Metronome button on the Transport bar, then choose Metronome 1	
Settings from the shortcut menu.

Metronome button
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In the Metronome pane, define when you want to hear the metronome click—on every 2	
bar, beat, or division—by selecting the corresponding checkboxes.

Select the “Click while recording” and “Only during count-in” checkboxes.3	

This allows you to hear a count-in of 1 bar before recording begins. If you want to 
change the default count-in setting, see the following task.
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Change the count-in:
Click the Recording button in the Project Settings window. In the Recording pane, mm

choose an option from the Count-in pop-up menu. You can record without a count-in, 
set a count-in of a specific amount of bars, or set a count-in time signature.
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Making an Audio Recording
When you make a single audio recording, an audio region that displays a graphical 
overview of the waveform is created on the selected Arrange track. 

Getting Ready
Create a new audio track:
If you’re using an existing project, click the Add (+) button above the track list, select mm

the Audio option in the New Tracks dialog, then click Create.

If you want to create a new project, see Chapter 2 for details.mm
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Set up a channel strip’s track for recording:
Click the Input slot of the left Arrange channel strip to choose the input for the 1	
connected instrument.

Insert slot

Input slot

Input Monitoring button

If you want, you can add effects that fit your instrument to the channel strip. For 2	
example, if you want to record a guitar, click the top Insert slot of the left Arrange 
channel strip, then choose Amps and Pedals > Amp Designer from the pop-up menu. 
Repeat the steps for Insert slot 2, choosing Pedalboard from the pop-up menu.

Turn on the Input Monitoring button. 3	

This allows you to hear incoming audio, even when the track is not record-enabled 
(useful for setting audio levels or practicing before recording). Play your guitar and you 
should hear it as well as see the level meters moving on the left Arrange channel strip.
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Try This
Record an audio track:
Click the selected audio track’s Record Enable button.1	

The track is ready for recording.

Click the Record button on the Transport bar to start recording. You can also press the 2	
Asterisk (*) key on keyboards with a numeric keypad, or the R key on other keyboards.

Record button

Recording will begin after the predefined count-in.

Play your instrument.3	

Click the Stop button on the Transport bar (or press the Space bar) to stop recording.4	

Stop button

The selected audio track contains a new audio region that displays a graphical 
overview of the waveform.
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Recording Audio Takes
When you record over a pre-existing region, Logic Pro creates what is called a take 
folder, which contains multiple take regions. A common scenario is when you record 
multiple passes while in Cycle mode; for example, if you are recording multiple versions 
of a solo. You can also do this by simply recording over an existing region.

Make sure that the Replace button on the Transport bar is turned Note:  off.

Replace button

Getting Ready
Create a cycle based on an existing region:
Select the audio region that you recorded in the previous section, and click the Set mm

Locators button in the Arrange toolbar. Cycle mode is turned on, with the left and right 
locators set to match the audio region start and end points.

Left locator Right locator
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Try This
Record multiple audio takes:
Press the Return key. 1	

The playhead moves to the project start position.

Press the Asterisk (*) or R key to start recording.2	

Recording begins after the predefined count-in.

Play your instrument and record as many cycle passes as you wish.3	

Press the Space bar to stop recording.4	

The selected audio track contains a take folder with multiple take regions inside.
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Exploring Take Folders
In this section, you’ll look at how to open take folders and how to choose individual 
takes for playback in your project. You’ll also listen to an original comp—the best parts 
from several take recordings combined into one master take—in the demo project.

Getting Ready
Open the demo project and set an appropriate zoom level:
Open “The Numbers Game” demo project.1	

Turn on the track Solo button for Track 1:  Chuck Vox.2	

Click anywhere in the Arrange area background to deselect all regions on Track 1:  3	
Chuck Vox, then click the take folder Chuck Vox.3 at bar 23 to select it.

Take folder

Click the Set Locators button in the Arrange toolbar to turn on Cycle mode.4	

Holding down Control-Option (which activates the Zoom tool), drag across the take 5	
folder Chuck Vox.3 on Track 1:  Chuck Vox to zoom the working area.
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Try This
Open the take folder:
Double-click the closed take folder Chuck Vox.3 on Track 1:  Chuck Vox. The take folder mm

opens, displaying two takes, Chuck Vox Alt and Chuck Vox 2, on individual lanes. Chuck 
Vox 2 is the most recent take.

Take folder

Individual takes

Listen to the current comp:
Press the Space bar to listen to the current comp selection.mm
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Choose a take region for playback:
Click the triangle in the upper-right corner of the take folder, then choose Take 1:  mm

Chuck Vox Alt from the Take Folder pop-up menu.

Click here to open the Take 
Folder pop-up menu.

The chosen take is displayed in color (the color is also reflected in the take folder) and 
the take that is not selected is displayed in gray.
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Choose Take 2:  Chuck Vox 2 from the Take Folder pop-up menu. Again, the chosen take mm

is displayed in color (the color is also reflected in the take folder) and the take that is 
not selected is displayed in gray.

Creating and Editing Comps
You can select individual take regions for playback in your project. But what if you want 
to combine selected parts of each take region for playback—the first section of Chuck 
Vox Alt followed by the end section of Chuck Vox 2, for example?

This section shows you how.

Getting Ready
You can switch take folders between two different editing modes, with the active 
editing mode determining the types of edits that can be made in the take folder. This 
section assumes that the Quick Swipe Comping mode is on, allowing you to create and 
edit comps.
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Verify the take folder’s editing mode:
Make sure that Quick Swipe Comping is active in the Take Folder pop-up menu. You mm

can also click the icon in the upper-right corner of the take folder so that it looks as 
follows:

Icon shows that Quick 
Swipe Comping mode is 
on.



72 Chapter 4    Recording and Comping Audio

Try This
Create a new comp:
With Take 2:  Chuck Vox 2 selected from the last task in the previous section, place the mm

pointer over the left edge of Chuck Vox Alt, and drag to the right, as far as bar 30. The 
selected area on Chuck Vox 2 is shortened. Playing back the project plays Chuck Vox Alt 
to bar 30, followed by the rest of Chuck Vox 2.

When you create a new comp, it is automatically added to the Comp list in the Take 
Folder menu (Comp 3 in this case).
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Save the comp:
Choose Duplicate Comp from the Take Folder pop-up menu. The current comp (Comp mm

3 in this case) is duplicated and the duplicate (Comp 4) becomes the active comp for 
any further changes.

Edit the comp:
Place the pointer over the right edge of the take region Chuck Vox 2, and drag to the mm

left, as far as bar 35. The end of Chuck Vox 2 is removed from the comp, leaving silence.
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Switch take region selections between takes:
Click the area that is not selected at the end of Chuck Vox Alt. The clicked area is mm

selected and the same area in Chuck Vox 2 is deselected.

Switch back to the saved comp:
Choose the comp you saved in an earlier task from the Take Folder pop-up menu mm

(Comp 3 in this case). The comp is reloaded along with the edits you made at that time.
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Editing Take Regions
What if you want to cut a take region into multiple sections, or move these sections 
around, or even delete them?

Next you will experiment with each of these tasks.

Getting Ready
This section assumes that the Quick Swipe Comping mode is off, allowing you to cut, 
drag, and delete take folder and take region elements.

Change the take folder’s editing mode:
Deselect Quick Swipe Comping from the Take Folder pop-up menu. You can also click mm

the icon in the upper-right corner of the take folder so that it looks as follows:

Icon shows that Quick 
Swipe Comping mode is 
off.
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Try This
Cut a take region:
Using Comp 3 from the previous section, select the Scissors tool, then click Take 2 at mm

bar 35. The take is cut at the clicked position, giving you two separate take regions on 
the same lane.

Drag a take region:
Drag the take region—the one you cut in the previous task—from bar 35 to bar 37. The mm

length of the take folder is extended up to the end point of the take region. Listen to 
the playback.

Delete a take region:
Make sure that the take region you dragged in the previous task is selected, then press mm

the Delete key.
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Managing Take Folder Contents
In this section, you’ll experiment with some commands in the Take Folder pop-up 
menu that can help with take folder management.

Try This
Export an active comp to a new track:
Using the current comp in the take folder, choose “Export active Comp to New Track” mm

from the Take Folder pop-up menu. The active comp is copied to a new track, which 
is created below the take folder track. The content of the original take folder remains 
intact.

Crossfades

Crossfades—used to create a smooth transition between two adjacent audio regions 
on a track—are visible between the take regions of the exported comp.

Using this command allows you to edit the current comp in the same way as other 
audio regions.
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Move an active comp to a new track:
Choose “Move active Comp to New Track” from the Take Folder pop-up menu. The mm

active comp is moved to a new track, which is created below the take folder track. This 
comp is no longer available in the original take folder.

You might use this option when you are ready to commit to a comp but want to keep 
all other takes and comps archived in the original take folder.

Flatten a take folder:
Choose Flatten from the Take Folder pop-up menu. The take folder is replaced with mm

multiple regions that represent the current comp selections. All take region sections 
not used in the current comp are deleted.

Use this option when you want to discard all comps and takes other than the current 
comp.

You can also use the Flatten and Merge command in the Take Folder pop-up menu to mm

replace the take folder with a single region that represents the current comp selections.

Use this option when you are ready to fully commit to the comp and don’t expect to 
make any further edits where the individual comp sections intersect.
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Key Concepts
Metronome:  ÂÂ A click in the project’s tempo that can be heard during recording or 
playback. The click makes it easier to play in time with the project’s tempo.

Count-in:  ÂÂ Clicks heard before the start of a recording, making it easier to get into the 
project’s groove.

Input slot:  ÂÂ A panel on an audio channel strip where you assign the channel strip 
input.

Insert slot:  ÂÂ A panel on a channel strip where you insert an effect plug-in.

Input Monitoring:  ÂÂ Allows you to hear incoming audio when audio tracks are playing, 
record-enabled, or recording.

Take:  ÂÂ A recording. Logic Pro allows you to create several takes, one after the other, 
without leaving record mode.

Take folder:  ÂÂ A container for multiple take recordings.

Cycle function:  ÂÂ A function that constantly repeats the area between the left and right 
locator positions.

Quick Swipe Comping:  ÂÂ The behavior of swiping across take sections to create and edit 
comps.

Drag editing:  ÂÂ The behavior of cutting, dragging, and moving take folder and take 
region elements.

Comp:  ÂÂ The result of combining selected parts of multiple takes into a single perfect 
take.
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Recording MIDI

You can use a MIDI keyboard to record MIDI in real time in 
Logic Pro.

This chapter focuses on recording options that are specific to recording MIDI in real 
time. You’ll learn how recording over the top of a previous performance can have 
different outcomes—merging recordings, replacing recordings, or creating take 
folders—depending on your recording setup. You’ll also experiment with quantization, 
a process that allows you to correct the timing of MIDI notes.

Making a MIDI Recording
MIDI recording is similar to audio recording. You play your connected MIDI keyboard 
and Logic Pro automatically records the incoming MIDI events on the record-enabled 
MIDI or software instrument track. In this chapter, you’ll only record to a software 
instrument track. Information about MIDI tracks can be found in the Logic Pro User 
Manual.

For details about setting the metronome and count-in prior to recording, see Chapter 4.
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Getting Ready
Create a new software instrument track and load a channel strip setting:
Create a new track by doing one of the following:1	

If you are using an existing project, click the Add (+) button above the track list, select ÂÂ
the Software Instrument option in the New Tracks dialog, then click Create.

If you want to create a new project, see Chapter 2 for details.ÂÂ

In the Library tab (Media area), choose a channel strip setting that you will experiment 2	
with while recording.

Instrument and effect settings are loaded to the Instrument and Insert slots on the left 
Arrange channel strip.

Make sure that your MIDI keyboard is connected.3	
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Try This
Record a software instrument part:
Click the Record button on the Transport bar to start recording. You can also press the 1	
Asterisk (*) key on keyboards with a numeric keypad, or the R key on other keyboards.

Record button

Recording begins after the predefined count-in.

Use your MIDI keyboard (or the Logic Pro Caps Lock keyboard; see Chapter 2) to play 2	
some notes.

A MIDI region appears on the software instrument track.

Click the Stop button on the Transport bar (or press the Space bar) once you’re done.3	

Stop button Play button

Click the Play button on the Transport bar (or press the Space bar) to play back the 4	
recording.
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Quantizing MIDI
If you’re not happy with the timing of your performance, you can use the Quantize 
feature to correct the timing of MIDI notes to the nearest selected musical time value. 
You do this using the Quantize pop-up menu in the Inspector’s Region Parameter box.

Getting Ready
Set an appropriate zoom level for the MIDI region:
Holding down the Option and Control keys, drag across the MIDI region you recorded mm

in the previous section.
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Try This
Correct the timing of note events:
Click the Quantize parameter in the Inspector’s Region Parameter box, and choose mm

1/16-Note from the pop-up menu. Watch how the note events change position in the 
MIDI region. This value is generally a good place to start for “duplet” based rhythms 
(dividing a beat into two even pieces).

Click the Quantize parameter in the Inspector’s Region Parameter box, then choose “off” mm

from the pop-up menu. The MIDI note events are returned to their original positions.

Click the Quantize parameter in the Inspector’s Region Parameter box, then choose mm

1/12-Note from the pop-up menu (which is the equivalent of an 8th note triplet). The 
note events move position in the MIDI region. This value is generally a good place to 
start for “triplet” based rhythms (dividing a beat into three even pieces).
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Overdub Recording MIDI
Overdubbing is the process of recording a performance in multiple passes, merging 
the performances into a single region. You’ll experiment with recording multiple MIDI 
performances on top of an existing performance.

Try This
Record over an existing MIDI region in Cycle mode:
Click the Set Locators button in the Arrange toolbar. 1	

Cycle mode is turned on and the left and right locators match the start and end points 
of the MIDI region you recorded in the previous section.

Left locator Right locator

Press the Return key while Logic Pro is not playing.2	

The playhead moves to the project start position.

Press the Asterisk (*) or R key to start recording.3	

Recording begins after the predefined count-in.

Use your MIDI keyboard (or the Logic Pro Caps Lock keyboard) to play some notes. 4	
Record as many cycle passes as you wish.

Press the Space bar to stop recording.5	
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The end result is a single MIDI region that contains the merged performances from 
each cycle pass.

You can also overdub a MIDI recording when not in Cycle mode.

To do this:
Control-click the Record button on the Transport bar, then choose Recording Settings 1	
from the shortcut menu.

In the Recording pane, choose “Merge with selected regions” from the Overlapping 2	
Recordings pop-up menu.

Repeat the recording steps from the last task, but without turning on Cycle mode.3	
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Replace Recording MIDI
Replace recording is the process of erasing all or part of a previous performance while 
recording a new one. You’ll do this by recording in Replace mode.

Try This
Record over an existing MIDI region in Replace mode:
Click the Replace button on the Transport bar.1	

Replace button

Cycle button

Make sure that Cycle mode is turned on.2	

Press the Return key while Logic Pro is not playing. 3	

The playhead moves to the project start position.

Press the Asterisk (*) or R key to start recording.4	

Recording will begin after the predefined count-in.

Use your MIDI keyboard (or the Logic Pro Caps Lock keyboard) to play some notes.5	

A new MIDI region is created on top of the existing one.

Press the Space bar to stop recording.6	

Your new recording replaces whatever portion of the previous material you recorded 
over, repeating the process for each cycle pass if recording in Cycle mode.
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Recording MIDI Takes
While you will usually want to record multiple cycle passes into a single region, take 
recording is also an option.

Take recording allows you to record over an existing performance and results in the 
creation of a take folder with each recording inside. A common scenario is when you 
are recording multiple passes in Cycle mode, but you can also do this by recording over 
an existing region.

Getting Ready
Modify the project setting for MIDI Overlapping Recordings:
Control-click the Record button on the Transport bar, then choose Recording Settings 1	
from the shortcut menu.

In the Recording pane, choose “Create take folders” from the Overlapping Recordings 2	
pop-up menu.
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Try This
Record MIDI takes:
If you want to record in Cycle mode, click the gray shaded area in the top part of the 1	
Bar ruler.

Press the Return key while Logic Pro is not playing. 2	

The playhead moves to the project start position.

Press the Asterisk (*) or R key to start recording.3	

Recording will begin after the predefined count-in.

Use your MIDI keyboard (or the Logic Pro Caps Lock keyboard) to play some notes. 4	
Record a single pass or as many cycle passes as you wish.

Press the Space bar to stop recording.5	

The selected software instrument track contains a take folder with multiple takes 
inside.

Double-click the closed take folder to view the contents, click the take you want to 6	
hear, then start playback.
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Key Concepts
Quantization:  ÂÂ The process of correcting the timing of MIDI note positions.

Quantize pop-up menu:  ÂÂ A menu in the Region Parameter box that you use to correct 
the timing of MIDI notes to the nearest selected musical time value.

MIDI region:  ÂÂ A container for MIDI events—individual MIDI notes or commands—that 
are generally created with a MIDI keyboard.

Library tab:  ÂÂ Tab within the Media area that is used to handle all setting files for 
channel strips, effects, and instruments.

Channel strip setting:  ÂÂ Represents the routing of a channel strip, including all inserted 
effects or instruments (plus their settings).

Overdubbing:  ÂÂ The process of recording a performance in multiple passes, merging 
the performances into a single region.

Cycle function:  ÂÂ A function that constantly repeats the area between the left and right 
locator positions.

Replace mode:  ÂÂ The process of erasing all or part of a previous performance while 
recording a new one.

Take:  ÂÂ A recording. Logic Pro allows you to create several takes, one after the other, 
without leaving record mode.

Take folder:  ÂÂ A container for multiple takes.
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Creating an Arrangement

You create an arrangement by dividing, copying, cropping, 
repeating, cutting, and inserting regions and region sections.

In this chapter, you’ll work with audio and MIDI regions in the Arrange area to create an 
arrangement for your song. You’ll use the following selection and navigation features.

Playhead

Cycle range

Marquee tool

Right locatorLeft locator

Marquee tool:  ÂÂ Tool used to select and edit parts of regions by dragging across them.

Cycle range:  ÂÂ Repeated section of a project, shown as a green stripe in the Bar ruler.

Left and right locators:  ÂÂ Define the start and end points of a cycle range in the Bar ruler.

Playhead:  ÂÂ Vertical white line that indicates the current playback position in all 
horizontal, time-based windows.
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Previewing the Demo Project
You can’t tackle the arrangement until you first get a feel for the content and structure 
of the song. You’ll preview the contents of the demo project using Solo mode, a mode 
in which you can select one or more tracks or regions to hear them in isolation.

Getting Ready
Open the demo project and turn on Solo mode:
Open “The Numbers Game” demo project.1	

Click the Solo button on the Transport bar (or press the S key) to turn on Solo mode.2	

Solo button

The Bar ruler is shaded in yellow, indicating that you are in Solo mode.
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Try This
Preview different tracks and regions in the project:
Click the Play button on the Transport bar (or press the Space bar) to start playback.mm

Play button

During playback, click individual track headers (or use the Up Arrow and Down Arrow mm

keys) to hear the entire track play back in Solo mode.

Click individual regions to hear them play back in Solo mode.mm

Drag across several regions to hear the region selection play back in Solo mode. Drag mm

across all the horn regions, for example.

When finished, press the S key to turn off Solo mode.mm

Mute a region:
During playback, select the Mute tool, then click any region. A second click unmutes mm

the region.

Select a region, then press the M key. Press the M key a second time to unmute the mm

region.
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Dividing Regions
You can slice any region into several parts, thus creating several individual regions. This 
allows you to move, copy, and delete parts of your arrangment.

Try This
Divide a region:
Select the Scissors tool, then click any region at the required cut position. You can also mm

do this by dragging across the region with the Scissors tool. Scrubbing allows you to 
hear the audio at the playhead position, making it easier to cut at the correct position.

Divide a region into multiple portions of equal length:
Hold down the Option key while cutting a region with the Scissors tool. The selected mm

region is cut into several pieces—each the same length as the first segment.

Divide a region using locators:
Click the shaded gray cycle area in the top part of the Bar ruler.1	

Click here to activate 
the cycle.
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The cycle range is activated between the left and right locator positions.

Right locatorLeft locator

Drag the left or right locator in the Bar ruler to extend or shorten the cycle range.2	

Select the region you want to split, then choose Region > Split > Split Regions by 3	
Locators in the local menu bar.

The section of the region located between the locators is cut at the left and right 
locator positions.

Divide a region using the playhead:
Drag the playhead to a position where you want to divide a region, select the region, mm

then choose Region > Split > Split Regions by Playhead in the local menu bar. The 
region is divided at the playhead position.

Divide a region using a marquee selection:
Hold down the Command key (which activates the Command-click tool with the mm

Marquee tool currently assigned) while dragging across a region. Click the marquee 
selection area with the Pointer tool to cut the region at the marquee borders.

Try pressing the M key on your computer keyboard instead of clicking the marquee mm

selection area, as described in the previous task. In addition to the region being 
divided, the region that was inside the boundaries of the marquee selection is muted.
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Merging Regions
You can merge two or more selected regions (of the same type—audio or MIDI) into a 
single region, making region handling much easier in your arrangement.

Try This
Merge audio regions:
Select the Glue tool, drag to select multiple audio regions, then click one of them. mm

When Logic Pro provides you with the warning that a new audio file will be created, 
click Continue.

The selected audio regions become one audio region, with silence added for any gaps 
between. A new audio file is added to the Audio Bin.

Merge MIDI regions:
Drag to select multiple MIDI regions, then click one of them. The selected MIDI regions mm

become one MIDI region, with silence added for any gaps between.
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Copying Regions
You can copy regions or region portions. This allows you to reuse entire regions, or 
portions of them, at other parts of your arrangement.

Getting Ready
Set an appropriate zoom level:
Select Track 13:  Gtr Fill, then holding down the Option and Control keys (which mm

activates the Zoom tool), drag across the “Gtr Fill” audio region.
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Try This
Copy a region section by dragging:
Using the Marquee tool, drag to select the area between bars 17 3 1 1 and 17 3 3 1.1	
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Holding down the Option key, drag the marquee selection area, release the mouse 2	
button at bar 19 4 1 1 on the same track, then release the Option key.

The marquee selection area is copied at bar 19 4 1 1.

Copy a region using edit commands:
Click the Arrange area background to remove the previous marquee selection.1	

Move the playhead to bar 20.2	

Select the newly created region Gtr Fill.5 at bar 19 4 1 1.3	

Choose Edit > Copy (or press Command-C).4	

The region is copied.
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Choose Edit > Paste (or press Command-V).5	

The region is pasted at bar 20.

Copy an entire region:
Hold down the Option key while dragging any region to another position, only mm

releasing the Option key after you release the mouse button.
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Cropping Regions
You can remove all parts of a region that fall outside the boundaries of a marquee 
selection.

Try This
Select Track 12:  Guitar Rev, then using the Marquee tool, drag to select the area 1	
between bars 65 3 1 1 and 66 3 1 1.
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Press Control-C (which activates the Crop Regions outside Locators or Marquee 2	
Selection key command).

The region parts that fall outside the boundaries of the marquee selection are cropped.
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Editing Arrange Sections
You can remove an entire passage from your arrangement, inserting it elsewhere in the 
song, or you can repeat a section of your arrangement. You’ll explore these activities 
using the demo project.

Getting Ready
Holding down the Option and Control keys (which activates the Zoom tool), mm click 
anywhere in the Arrange area background until the project returns to its original zoom 
level setting.

Try This
Repeat a section of the project:
Drag the left and right locators of an active cycle range to select the section of a mm

project you want to repeat, then choose Region > Cut/Insert Time > Repeat Section 
Between Locators in the local menu bar. The entire section that falls within the locator 
positions is repeated.

Cut a section from the project:
Drag the left and right locators of an active cycle range to select the section of a mm

project you want to remove, then choose Region > Cut/Insert Time > Snip:  Cut Section 
Between Locators in the local menu bar. The entire section that falls within the locator 
positions is removed.

Insert a section in the project:
After cutting a section from your project, move the playhead to the position where you mm

want to insert it, then choose Region > Cut/Insert Time > Splice:  Insert Snipped Section 
at Playhead in the local menu bar. The entire section is inserted at the playhead position.
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Key Concepts
Arrangement:  ÂÂ The process of organizing your musical material into a song structure.

Left and right locators:  ÂÂ Locators that define the start and end points of a cycle range 
in the Bar ruler.

Playhead:  ÂÂ A vertical white line that indicates the current playback position in all 
horizontal, time-based Logic Pro windows.

Solo mode:  ÂÂ A mode in which you can select one or more tracks or regions to hear 
them in isolation.

Marquee tool:  ÂÂ Used to select and edit parts of regions by dragging across them.

Mute tool:  ÂÂ Used to stop a region or region section from playing by clicking it.

Glue tool:  ÂÂ Used to merge regions by selecting and clicking them.

Scissors tool:  ÂÂ Used to divide a region by clicking it.
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Flex Time Editing

You can use Flex Time editing functions to edit the timing of 
single or multiple audio regions.

This chapter introduces you to the techniques used for Flex Time editing as well as 
the track-based settings that detemine how the timing of your audio will be altered. 
You’ll learn how to correct a single note or the timing of an entire region, all within the 
Arrange window.

Flex Time editing greatly simplifies the process required for altering the timing of audio 
material. It allows you to compress or stretch the time between specified points in an 
audio region without the need for more traditional processes like cutting, nudging, and 
crossfading. Though comparable to what is sometimes referred to as elastic audio in 
other applications, Flex Time editing provides unique advantages, such as the option to 
employ beat slicing methods that do not rely on time stretching algorithms.

Flex Time editing is largely dependent on a set of markers called transient markers, 
which denote significant points in an audio file. The audio on a track is analyzed for 
transients the first time you enable that track for Flex Time editing. Any detected 
transients in the file are marked with transient markers.
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You edit the timing of audio material using flex markers. When you move a flex marker, 
it time compresses or expands the area around it. The initial boundaries within which 
this is done is determined by the transient markers. You manipulate flex markers either 
in the Arrange area’s Flex view, or invisibly using the Flex tool. You can create single or 
multiple flex markers in an audio file, enabling you to manipulate the position of single 
notes or complete phrases.
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Exploring Flex View and Flex Modes
You’ll start by turning on Flex view in the Arrange area and exploring some of the 
available flex modes.

Getting Ready
Open “The Numbers Game” demo project. Track 1:  Chuck Vox is selected by default.mm

Try This
Display Flex view in the Arrange area:
Choose View > Flex View. Flex view is turned on and the Flex Mode menu is displayed mm

in the track header of Track 1:  Chuck Vox.

Flex Mode menu
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Locate the available flex modes:
Click the Flex Mode menu in the track header of Track 1:  Chuck Vox. The flex modes are mm

listed in the pop-up menu.

Click the Flex Mode parameter in the Inspector’s Track Parameter box. The flex modes mm

are listed in the pop-up menu.
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Creating and Moving Flex Markers in Flex View
You use flex markers to manually alter the timing of audio material. You can create 
single or multiple flex markers in an audio file, enabling you to manipulate whole or 
partial areas of the material by moving these flex markers.

Getting Ready
Define a cycle range for soloed playback and set an appropriate zoom level:
Click the Solo (S) button on Track 1:  Chuck Vox to solo the entire track.1	
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Click the gray shaded area in the upper part of the Bar ruler to turn on Cycle mode, 2	
then change the left and right locators in the Transport bar to 9 1 1 1 and 10 1 1 1, 
respectively.

Left locator Right locator

Holding down the Option and Control keys (which activates the Zoom tool), drag 3	
across the first region “Chuck Vox.1” on Track 1:  Chuck Vox, dragging between bars 9 
and 10 only.
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Try This
Create and drag a single flex marker:
Click the Flex Mode menu in the track header of Track 1:  Chuck Vox, then choose 1	
Monophonic from the pop-up menu.

All audio files on the track are analyzed for transients, and all detected transients are 
marked and stored in the audio files.

Transient marker

Press the Space bar to start playback.2	
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Place the pointer over the upper half of the audio region just before bar 9.3, just on top 3	
of the existing transient marker. The pointer shown here indicates an existing transient 
marker:

Click the area on top of the transient marker to create a flex marker.4	

Flex marker
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Drag the flex marker to the right, as far as bar 9 3 3 1. It should look as follows:5	

Time compressed audioTime expanded audio

The audio material to the left of the flex marker is time expanded (indicated by the 
orange color) and the audio material to the right is time compressed (indicated by 
green).

Listen to the result of this time stretching and compression.6	
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Create and drag multiple flex markers:
Place the pointer over the lower half of the audio region after bar 9 2 3 1, just on top 1	
of the existing transient marker. The pointer shown here indicates an existing transient 
marker:

Click the transient marker. 2	



Chapter 7    Flex Time Editing 117

Three flex markers are created—on the clicked transient marker, on the previous 
transient marker, and on the next transient marker:

Experiment with time compression and expansion by dragging the middle flex marker 3	
to the right or to the left.

Press the Space bar to listen to the result of this time stretching and compression.4	
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Depending on the direction you move the middle flex marker, the audio material 
between the center and right flex markers is either time compressed or expanded, and 
the same is true for the audio material between the center and left flex markers.

Time compressed audioTime expanded audio
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Creating and Moving Flex Markers with the Flex Tool
You also have access to Flex Time editing with the Flex tool. The Flex tool allows you to 
drag points in the region’s waveform and move them where you want. The waveform’s 
movement is restricted by transient markers on either side of the place you began 
dragging. To extend the editing area, drag beyond these transients and the boundary 
will extend to the next or previous transient.

Getting Ready
Turn off Flex view and select the Flex tool:
Choose View > Flex View. Flex view is turned off and all audio tracks return to their mm

default view. Select the Flex tool from the Tool menu in the Arrange area.

Flex tool
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Try This
Create and drag flex markers with the Flex tool:
Place the pointer over the audio region to the right of 9.3. You’ll know that the pointer 1	
is on top of an existing transient marker when it looks as follows:

Drag from the transient marker to the left, as far as bar 9.3. The area will look as follows:2	
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The audio material to the right of the dragged flex marker is time expanded up to the 
following flex marker. The audio material to the left of the dragged flex marker is time 
compressed up to the previous flex marker.

Press the Space bar to listen to the result of this time stretching and compression.3	

Quantizing Audio
If you’re not happy with the timing of your performance, you can use the Quantize 
feature to correct the timing of audio material to the nearest selected musical time 
value. This feature is only available for audio tracks that have been enabled for Flex 
Time editing.

To quantize audio, you use the Quantize pop-up menu in the Inspector’s Region 
Parameter box.

Click here to open the 
Quantize menu.
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Getting Ready
Make sure that Track 1:  Chuck Vox is no longer soloed by turning off its Solo button.mm

Try This
Apply quantization to a region:
Select the Tambourine region on Track 32:  Tambourine.1	

Click the Set Locators button in the Arrange toolbar, then press the Space bar to start 2	
playback.

Choose Monophonic from the track header’s Flex Mode pop-up menu.3	

During playback, choose 8C Swing from the Quantize pop-up menu.4	

Listen to the playback result.5	

Repeat steps 2 to 5 for other regions in the demo project.6	
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Key Concepts
Flex Time editing:  ÂÂ A process that allows you to edit the timing of single or multiple 
audio regions.

Flex mode:  ÂÂ A track-based setting that detemines how the timing of your audio will be 
altered.

Transient marker:  ÂÂ A marker that denotes a significant point or peak in an audio file.

Transient detection process:  ÂÂ A process that analyzes audio files for transients the first 
time you enable a track for Flex Time editing. Detected transients are marked and 
stored in the audio files.

Flex marker:  ÂÂ A marker that you drag to alter the timing of audio material.

Flex view:  ÂÂ An Arrange area view that allows you to edit the timing of audio material.

Flex tool:  ÂÂ A tool that allows you quick access to the basic Flex Time editing 
functionality, without having to turn on Flex view in the Arrange area.

Quantization:  ÂÂ The process of correcting the timing of your material.

Quantize pop-up menu:  ÂÂ A menu in the Region Parameter box that allows you to set 
the value used for quantization.
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Editing MIDI Events

You use the MIDI editors to edit the position, length, pitch, and 
velocity of MIDI events in MIDI regions.

You can edit individual MIDI events by selecting a MIDI region in the Arrange area and 
opening one of the MIDI editors. Which editor you use depends on the type of editing 
you want to carry out. In this chapter, you’ll explore some of the editors while also 
looking at the editing capabilities of the Piano Roll Editor in more depth.

Exploring the MIDI Editors
In the Piano Roll Editor, MIDI note events are represented by horizontal rectangles, 
aligned on a grid of horizontal and vertical lines. In the Score Editor, they are 
represented by traditional music notation.

Getting Ready
Open “The Numbers Game” demo project.mm
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Try This
Select a MIDI region and open the Piano Roll Editor:
Select the first MIDI region on Track 14:  Bass, and click the Piano Roll button at the mm

bottom of the Arrange area (or press the P key).

The MIDI events are represented by horizontal rectangles.

The horizontal placement of note events indicates their temporal (bar, beat, and sub-ÂÂ
beat) positioning within the region and project.

The vertical placement of note events indicates their pitch—the higher the note ÂÂ
position in the Piano Roll area, the higher the pitch.

The length of the rectangle is directly proportional to the note event length.ÂÂ
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The color of the rectangle and the horizontal line through the beam indicate the ÂÂ
velocity of the note event—how loud the note is played.

Open the Score Editor:
Click the Score button at the bottom of the Arrange area (or press the N key). The note mm

events of the selected MIDI region are displayed as traditional notation in the Score 
Editor.
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Selecting Notes
You’ll use the Pointer tool to select note events in the Piano Roll Editor.

Getting Ready
Open the Piano Roll Editor by pressing the P key.mm

Try This
Select note events:
Click any note event in the Piano Roll area. The note event is selected and is played mm

back at the same time.

Click the Piano Roll background, then drag across several note events.mm

Select note events of the same pitch:
Click one of the Piano Roll keys at the left of the Piano Roll area. All notes of the same mm

pitch are selected while also being played back.

Click a Piano Roll key to select 
all notes of the same pitch.
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Drag across a range of Piano Roll keys. All note events in the pitch range are selected.mm

Drag across the Piano Roll 
keys to select all notes of 
multiple pitches.
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Creating Notes
You’ll use the Pencil tool to create note events in the Piano Roll Editor. The Pencil tool is 
assigned to the Command-click tool in the Piano Roll Editor by default.

Try This
Create note events:
Holding down the Command key (which activates the Pencil tool), click your chosen mm

position and pitch in the Piano Roll Editor.

Click with the Pencil tool to 
create a note event.

Holding down the Command key, click an existing note event, then click your chosen mm

position and pitch in the Piano Roll Editor. A new note event is created with the same 
channel, velocity, and length as the note event you clicked.
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Editing the Position of Notes
You can move selected note events by dragging them in the Piano Roll Editor. If you 
move a note event horizontally, it is moved in time. If you move a note event vertically, 
it is transposed—moved up or down in pitch.

Try This
Move note events:
Drag any note event horizontally.mm

Drag across multiple note events to select them, then drag them to another position.mm

Copy note events:
Holding down the Option key, drag any note event horizontally, only releasing the mm

Option key after releasing the mouse button. The note event is copied.
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Change the pitch of note events:
Click any Piano Roll key to select all note events of the same pitch, then drag the note mm

events vertically. 

The pitch of the selected note events is changed.
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Editing the Length of Notes
You can edit the length of note events in the Piano Roll Editor individually or in relation 
to one another.

Try This
Change the length of a note event:
Drag the left or right edge of any note event. The event is either shortened or mm

lengthened, depending on the direction you dragged.

Select any two note events, then hold down the Shift key while dragging the right mm

edge of one of them. The same end point is set for both notes.
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Select any two note events, then hold down the Shift and Option keys while dragging mm

the right edge of one of them. The same length is set for both notes and you can resize 
them.

Select any note event, then choose Functions > Note Events > Note Force Legato mm

(selected/any) from the local menu bar. The selected note is lengthened up to the 
following note event, regardless of whether the following note is selected or not.

Select any two note events (click the first and Shift-click the second), then choose mm

Functions > Note Events > Note Force Legato (selected/selected). The selected note 
event is lengthened up to the next selected note event.
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Muting Notes
You’ll use the Mute tool to mute selected note events in the Piano Roll Editor.

Getting Ready
Select the Mute tool from the Tool menu in the Piano Roll Editor.mm

Mute tool

Try This
Mute note events:
Click any note event with the Mute tool. The note is dimmed and can no longer be mm

heard during playback.

Click with the Mute tool to 
mute the note event.

Click the note event a second time with the Mute tool to unmute it.

Drag across multiple note events, then click one of them with the Mute tool. All notes mm

in the selection are dimmed and no longer heard during playback. Click one of the 
note events a second time with the Mute tool to unmute them all.
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Click any Piano Roll key with the Mute tool. All note events of that particular pitch are mm

muted. Click the Piano Roll key a second time with the Mute tool to unmute them all.

Editing the Velocity of Notes
You’ll use the Velocity tool to edit note velocity in the Piano Roll Editor.

Both the color of the rectangle and the horizontal line through the beam indicate the 
velocity of the note event—the force at which the note is played.

Low velocity

High velocity
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Getting Ready
Select the Velocity tool from the Tool menu in the Piano Roll Editor.mm

Velocity tool

Try This
Change the velocity of note events:
Drag any note event downward with the Velocity tool. A help tag indicates the velocity mm

value of the note you have clicked, with this value decreasing as you drag downward. 
The note color changes and the horizontal line inside the beam shortens.

Drag the same note event upward, while watching the help tag, the note color, and the mm

horizontal line.
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Quantizing Notes
You use the Quantize pop-up menu in the Piano Roll Editor to assign a quantization 
value to one or more selected note events. You can also use the Quantize button to 
quantize selected events with the value chosen from the Quantize pop-up menu.

Quantize pop-up menu Quantize button

Try This
Correct the timing of note events:
Select one or more note events in the Piano Roll Editor, then choose a quantization mm

value from the Quantize pop-up menu. The selected note events map to the grid 
according to the chosen quantization value.

Select additional note events, then click the Quantize button. The selected note events mm

map to the grid according to the previously chosen quantization value.
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Key Concepts
MIDI region:  ÂÂ A container for MIDI events—individual MIDI notes or commands—that 
are generally created with a MIDI keyboard.

MIDI event:  ÂÂ Represents an individual MIDI note or command.

Piano Roll Editor:  ÂÂ Where MIDI note events are represented by horizontal rectangles, 
aligned on a grid of horizontal and vertical lines.

Score Editor:  ÂÂ Where MIDI note events are displayed as traditional music notation.

Velocity:  ÂÂ Defines the force at which a note is played.

Transposition:  ÂÂ The process of moving a note event up or down in pitch.

Cycle function:  ÂÂ A function that constantly repeats the area between the left and right 
locator positions.

Left and right locators:  ÂÂ Locators that define the start and end points of a cycle range 
in the Bar ruler.

Quantization:  ÂÂ The process of correcting the timing of your material.

Quantize pop-up menu:  ÂÂ A menu in the Piano Roll Editor that you use to correct the 
timing of MIDI notes to the nearest selected musical time value.

Quantize button:  ÂÂ A button in the Piano Roll Editor that allows you to quantize 
selected events using the value chosen in the Quantize pop-up menu.
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Mixing the Project

You use the Mixer when you want to refine the sound of each 
musical element in your project—creating a unified mix.

In this chapter, you’ll explore the Mixer, work with channel strip groups, work with send 
effects, and create submixes. When working on each of these tasks in the Mixer, you’ll 
encounter the following channel strip types:

Audio channel strips:  ÂÂ Control the playback and recording of audio signals on audio 
tracks.

Instrument channel strips:ÂÂ   Allow you to use and control software instruments. 
Software instrument plug-ins are inserted into the channel strip’s Instrument slot. The 
instrument channel strip can then be driven by a recorded MIDI region or by direct 
MIDI input—playing your MIDI keyboard.

Aux channel stripsÂÂ :  Used to set up send returns, where a channel strip signal is routed 
to an aux channel strip for effects processing. Aux channel strips are also used for 
grouping purposes and for distributing a signal to multiple destinations via sends.

Output channel stripsÂÂ :  Represent the physical audio outputs of your audio interface. 
These channel strips are used to adjust the overall volume and stereo/pan balance of 
all audio, instrument, or aux channel strips routed into them.

Master channel strip:  ÂÂ A global level control for all output channel strips. It changes the 
gain of output channel strips without affecting the level relationships between them.
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Exploring the Mixer
The Mixer provides options for changing what channel strips are being viewed and in 
what order. The default settings display all the channel strips in the order they appear 
in the Arrange area, along with the aux and output channel strips they are sending 
signals to.

Filter buttonsView buttons
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As projects grow large and more complex, you may find it useful to temporarily limit 
the number of channel strips displayed to those you need to focus on for a given task. 
You have the possibility to switch the Mixer between three different views—Single, 
Arrange, and All. You can also determine which channel strips are displayed using the 
filter buttons.

Getting Ready
Open the Mixer area in the demo project:
Open “The Numbers Game” demo project.1	

Click the Mixer button at the bottom of the Arrange area (or press the X key).2	

Try This
Customize the Mixer view using the filter buttons:
Deactivate all filter buttons except for the Inst button. Only instrument channel strips mm

are now visible in the Mixer area.

Activate the Audio button and deactivate the Inst button. Only audio channel strips are mm

now visible in the Mixer area.

Customize the Mixer using the view buttons:
Select the channel strip Chuck Vox 1, then click the Single button. Single view limits mm

the Mixer display to a single channel strip—that of the track selected in the Arrange 
area—and its signal flow.

Click the Arrange button. In Arrange view, the Mixer displays all channel strips that mm

correspond to tracks used in the Arrange window and their signal flow. In this case, 
your settings from when you last activated the Audio button, and deactivated all 
others, are still intact. The settings are saved with the view.
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Working with Channel Strip Groups
You can create a channel strip group and modify selected parameters for the entire 
group using a single control. You do this by selecting multiple channel strips and 
assigning them to a particular group from the channel strip’s Group slot.

Group slot

Volume fader

Pan control

Try This
Create a group from multiple channel strips:
Drag horizontally across channel strips 2 to 9 (over the word Inserts, or I/O text, for 1	
example) to select them.

Click the Group slot of any one of these eight channel strips, then choose Group 2 from 2	
the pop-up menu.

The group number is assigned to the channel strip Group slots and the Group Settings 
window opens automatically. The Group Settings window determines which controls 
and parameters are synced for those channel strips that make up the group.
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Double-click the Name field, type “Horns,” then press the Return key.3	

The group name is added to the group number on the channel strip Group slots.

The selected channel strips 
are all assigned to group 2: 
Horns.
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Close the Group Settings window by clicking the window’s close button.4	

Add another channel strip to the last created group:
Option-click the Group slot of channel strip 10 (another horn channel strip). The mm

channel strip is added to the previously created group 2:  Horns.

Change the settings of an active group:
Click the Group slot of channel strip 2, choose Open Group Settings from the pop-up 1	
menu, select the Solo checkbox, then close the Group Settings window.

Back in the Mixer, click the Solo button on channel strip 2.2	

All nine channel strips in Group 2:  Horns are soloed.

Modify the volume level for the group:
Drag the Volume fader of any channel strip in Group 2:  Horns. The Volume fader moves mm

for each channel strip, while maintaining the relative values between them.

Modify the Pan control for the group:
Drag the Pan control of any channel strip in Group 2:  Horns vertically or horizontally. mm

The Pan control moves for each channel strip, while maintaining the relative values 
between them.
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Adding Effects to Multiple Channel Strips
Chapter 3 discussed using Insert slots to add effects into a channel strip’s signal flow. 
But what if you want to use the same effect on more than one channel strip?

You do this using Send slots—sending the signal on each channel strip to the same 
aux channel strip, on which you add the effects.

Insert slot

Send slot

Add an effect to multiple channel strips:
Drag horizontally across channel strips 14 and 15 to select them.1	

Click the top empty Send slot of either channel strip, then choose Bus 6 from the Bus 2	
pop-up menu, for example.
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The Bus number is assigned to both Send slots, and Aux 6—an aux channel strip—is 
automatically created (only in the case of an unused Bus assignment).

Send slot

Send knob

Drag the Send knob on channel strip 14 or 15 to set the amount of signal that you want 3	
to send to Aux 6.

As you do so, the send amount value is shown on the Send slot.

Double-click either Send slot to jump directly to Aux 6.4	

Click the top empty Insert slot of Aux 6, then choose an effect from the pop-up menu.5	

Modify the volume level and pan settings for the signal on Aux 6.6	
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Creating a Submix
Another useful mixing procedure is to “submix” multiple channel strips into one aux 
channel strip. Like grouping, this makes it easy to control multiple channel strips. For 
this to work, the complete signal from each channel strip needs to be routed to an aux 
channel strip via the channel strip Output slots.

Output slot
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Try This
Create a submix:
Drag across channel strips 11 to 13 to select them all.1	

Click the Output slot on any of these channel strips, then choose Bus 7 from the Bus 2	
pop-up menu, for example.

The Bus number is assigned to the Output slot of all three channel strips, and Aux 7 is 
automatically created (only in the case of an unused Bus assignment).

Double-click any of the three Output slots to jump directly to Aux 7.3	

You now have a submix of the selected three channel strips. You can control this 4	
submix by modifying the volume level and pan settings and loading additional effects 
from Aux 7.

Routing Signals with a Multi-Output Instrument
Some software instruments allow you to isolate a sound and route it to its own aux 
channel strip where it can be independently mixed and processed. Within Logic Pro, 
you can use Ultrabeat and the EXS 24 sampler for such purposes.

Getting Ready
Select channel strip 39 in the Mixer, then click the Single button. You are provided with mm

an immediate overview of channel strip 39 and its signal flow.
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Try This
Insert and set up a multi-output instrument:
Click the Instrument slot of channel strip 39 and make sure that Ultrabeat > Multi 1	
Output is chosen.

Click the Add (+) button at the bottom of the channel strip.2	

Instrument slot with 
Ultrabeat loaded

Input slot set to UB 3–4

Add button

An aux channel strip is created with its Input slot set to UB 3-4.

Double-click the Instrument slot of channel strip 39.3	

The Ultrabeat plug-in window opens.
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Click the “out” column of the Snare entry in the plug-in window, then choose 3-4.4	

Double-click the EQ area on the aux channel strip to apply EQ.5	

Click the first Send slot of the aux channel strip, then choose Bus > Bus 2 (DrumVerb).6	

The snare signal is sent to the existing aux 2 channel strip (already set up for snare).



Chapter 9    Mixing the Project 153

Key Concepts
Mixer:  ÂÂ Interface area where you mix your project.

Audio channel strips:  ÂÂ Control the playback and recording of audio signals on audio 
tracks.

Instrument channel strips:  ÂÂ Allow you to use and control software instruments. 
Software instrument plug-ins are inserted into the channel strip’s Instrument slot.

Aux channel strips:  ÂÂ Used to set up send returns, where a channel strip signal is routed 
to an aux channel strip for effects processing. Aux channel strips are also used for 
grouping purposes and for distributing a signal to multiple destinations via sends.

Output channel strips:  ÂÂ Represent the physical audio outputs of your audio interface.

Master channel strip:  ÂÂ A global level control for all output channel strips.

Mixer View buttons:  ÂÂ Allow you to switch the Mixer between the Single, Arrange, and 
All views, limiting the Mixer view to channel strips required for the task at hand.

Mixer Filter buttons:  ÂÂ Allow you to to filter the display of specific channel strip types.

Group slot:  ÂÂ Used to control a channel strip’s group assignment.

Group Settings window:  ÂÂ Where you define the behavior of each group.

Volume fader:  ÂÂ Used to set a channel strip’s playback or monitoring volume.

Pan control:  ÂÂ Used to control the position of the signal in the stereo image.

Send slot:  ÂÂ Used to route a channel strip’s signal to an aux channel strip.

Output slot:  ÂÂ Used to set the channel strip’s output path.

Multi-Output Instrument:  ÂÂ Allows you to isolate a sound and route it to its own aux 
channel strip where it can be independently mixed and processed.
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Automating Your Mix

You can record, edit, and play back fully automated mixes in 
Logic Pro.

With the help of the Logic Pro automation features, you can automate the controls and 
parameters of channel strips and plug-ins by recording them and playing them back. 
This allows you to create complex, animated mixes—with automatic channel strip 
mutes, channel strip signals that pan from side to side, channel strip groups fading in 
or out, and much more.

In this chapter, you’ll explore how to automate the controls and parameters of channel 
strips using track automation.
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Exploring Track Automation
Track automation is displayed on a transparent gray shaded area that runs the length 
of your project.

Getting Ready
Open the demo project:
Open “The Numbers Game” demo project.mm

Try This
Display track automation:
With Track 1:  Chuck Vox selected, choose View > Track Automation in the local menu mm

bar (or press the A key). The automation lane on Track 1:  Chuck Vox is displayed, along 
with some existing volume automation data.

Track automation lane

Volume automation data
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Set the automation mode for a track:
If you cannot see the Automation Mode menu in the track header of Track 1:  Chuck 1	
Vox, drag the lower-left corner of the track header downward.

Drag here to zoom.

Automation Mode menu

This zooms the track header area, allowing you to see the Automation Mode menu.

Click the Automation Mode menu on Track 1:  Chuck Vox, then choose Read from the 2	
pop-up menu.

Automation Mode menu 
set to Read mode

Choosing Read allows you to play back all automation that exists on the track.
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Click the Play button on the Transport bar (or press the Space bar) to start playback.3	

Play button

Watch how the Volume fader in the left Arrange channel strip changes during playback. 
The volume fader follows the pre-recorded automation data on the track.

Switch between automation parameters:
Select Track 2:  Trumpet 1.1	

The automation lane on Track 2:  Trumpet 1 is displayed, along with some existing 
volume automation data.

Click the Automation Parameter menu, then choose Pan from the pop-up menu.2	

Automation Parameter 
menu

Pan automation data is shown on Track 2:  Trumpet 1.
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Using Touch and Latch Modes
You can use Touch and Latch modes to create your own automation data.

Don’t use Write mode. All automation data on a track is erased the minute Important: 
you start playback with Write mode enabled.

Try This
Create automation data using Touch mode:
Select Track 1:  Chuck Vox, click the Automation Mode menu, then choose Touch from 1	
the pop-up menu.

Press the Space bar to start playback.2	

Drag the Volume fader on the left Arrange channel strip vertically.3	

Volume fader

Release the Volume fader after a couple of bars.4	

The Volume fader follows existing automation data on the track.

Drag the Volume fader vertically when you encounter existing automation data from 5	
bar 9 onward.
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The existing automation data is overwritten.

Release the Volume fader after a couple of bars.6	

The Volume fader once again follows existing automation data on the track.

Click the Stop button on the Transport bar (or press the Space bar) to stop playback.7	

Stop button

Touch mode allows you to modify the value of the chosen automation parameter 
when automation is active. After releasing the fader or knob, the parameter follows 
existing automation data on the track.
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Create automation data using Latch mode:
Click the Automation Mode menu on Track 1:  Chuck Vox, then choose Latch from the 1	
pop-up menu.

Press the Space bar to start playback.2	

Drag the Volume fader on the left Arrange channel strip vertically.3	

Release the Volume fader after a couple of bars.4	

The Volume fader does not follow existing automation data on the track as in Touch 
mode. Instead, the Volume fader continues to remain in the position at which you 
released the mouse button.

Drag the Volume fader vertically when you encounter existing automation data from 5	
bar 9 onward.

The existing automation data is overwritten.

Release the Volume fader after a couple of bars.6	

The Volume fader once again remains in the position at which you released the mouse 
button.

Press the Space bar to start playback.7	

Latch mode works like Touch mode, but the current value replaces any existing 
automation data after you release the fader or knob.
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Creating and Editing Automation Nodes and Lines
In this section, you’ll experiment with creating and editing automation nodes and lines.

NodeLine

Try This
Create automation nodes:
Click on, or just outside, an automation line (not on a node). A new node is created.mm

Hold down the Command key (which activates the Command-click tool with the mm

Marquee tool currently assigned) while dragging across a region. Click the marquee 
selection area with the Pointer tool. A node is created at both marquee borders.

Select any region, then choose Track > Track Automation > Create Nodes at Region mm

Borders. One node is created at each end of the region.

You can also choose Track > Track Automation > Create Two Nodes at Region Borders mm

to create two nodes at each end of the region.

Edit automation nodes and lines:
Drag any of the existing automation nodes or lines vertically or horizontally.mm
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Draw in automation:
Draw automation lines and curves in the automation track with the Pencil tool.mm

 

Draw in automation data 
with the Pencil tool.

Key Concepts
Automation:  ÂÂ The ability to record, edit, and play back the movements of all knobs, 
controls, and buttons on channel strips and plug-ins.

Track automation:  ÂÂ Automation displayed on an automation track.

Automation Mode menu:  ÂÂ A track header menu on automation tracks that determines 
whether you read, touch, latch, or write automation data.

Automation Parameter menu:  ÂÂ A track header menu on automation tracks that allows 
you to choose the visible automation parameter on the track automation lane.

Read mode:  ÂÂ Automates the current track, using the existing automation data.

Touch mode:  ÂÂ Allows you to modify the value of the chosen automation parameter, 
when automation is active. After releasing the fader or knob, the parameter follows 
existing automation data on the track.

Latch mode:  ÂÂ Works like Touch mode, but the current value replaces any existing 
automation data after you release the fader or knob.
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Getting Answers

There are additional resources you can use to get answers to 
your questions about using Logic Pro.

Now that you have learned about the basic features of Logic Pro, you probably have 
more questions. You can use Logic Pro Help to find the answers you need.

Exploring Logic Pro Help
Logic Pro Help provides in-depth descriptions and instructions about the features and 
controls (the tasks you can perform) with Logic Pro.

Try This
Open the Logic Pro User Manual:
In Logic Pro, choose Help > Logic Pro Help, then click Logic Pro 9:  User Manual.mm

Open the Logic Studio Instruments manual:
In Logic Pro, choose Help > Logic Pro Help, then click Logic Studio:  Instruments.mm

Open the Logic Studio Effects manual:
In Logic Pro, choose Help > Logic Pro Help, then click Logic Studio:  Effects.mm
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Search for a specific topic that interests you:
Enter the topic of your choice in the search field at the top of the Help Viewer window. mm

Select topics from the search results list that you want to know more about.

When you search in the Logic Pro manual, the search results include relevant topics 
from the Logic Studio Instruments and Logic Studio Effects manuals as well.

Search for Apple Support information:
Choose Help > Logic Pro Help, then click Logic Pro Support. Browse topics that interest mm

you.

Read discussions on the Logic Pro forum:
Choose Help > Logic Pro Help, then click Logic Pro Discussions in the list of additional mm

resources. Browse discussion topics that interest you.

What’s Next?
You’ve now had a brief introduction to Logic Pro and a selection of its features. You can 
continue to experiment with the demo project files on your own or delete them and 
start work with your own clips. Refer to Logic Pro Help for the in-depth information you 
need.


	Logic Pro 9: Exploring Logic Pro
	Contents
	Chapter 1: Welcome to Logic Pro
	Opening the Demo Project
	Using Key Commands

	Chapter 2: Building a Basic Project
	Creating a Project
	Exploring the Arrange Window
	Playing Instruments
	Adding Apple Loops
	Navigating the Project
	Setting the Project Tempo
	Exploring the Audio Bin
	Choosing Tools
	Creating a Basic Arrangement
	Exploring a Track’s Channel Strip
	Exporting the Project
	Key Concepts

	Chapter 3: Working with Instruments and Effects
	Adding Individual Instruments and Effects
	Working with Plug-in Settings
	Loading Channel Strip Settings
	Key Concepts

	Chapter 4: Recording and Comping Audio
	Setting the Metronome and Count-in
	Making an Audio Recording
	Recording Audio Takes
	Exploring Take Folders
	Creating and Editing Comps
	Editing Take Regions
	Managing Take Folder Contents
	Key Concepts

	Chapter 5: Recording MIDI
	Making a MIDI Recording
	Quantizing MIDI
	Overdub Recording MIDI
	Replace Recording MIDI
	Recording MIDI Takes
	Key Concepts

	Chapter 6: Creating an Arrangement
	Previewing the Demo Project
	Dividing Regions
	Merging Regions
	Copying Regions
	Cropping Regions
	Editing Arrange Sections
	Key Concepts

	Chapter 7: Flex Time Editing
	Exploring Flex View and Flex Modes
	Creating and Moving Flex Markers in Flex View
	Creating and Moving Flex Markers with the Flex Tool
	Quantizing Audio
	Key Concepts

	Chapter 8: Editing MIDI Events
	Exploring the MIDI Editors
	Selecting Notes
	Creating Notes
	Editing the Position of Notes
	Editing the Length of Notes
	Muting Notes
	Editing the Velocity of Notes
	Quantizing Notes
	Key Concepts

	Chapter 9: Mixing the Project
	Exploring the Mixer
	Working with Channel Strip Groups
	Adding Effects to Multiple Channel Strips
	Creating a Submix
	Routing Signals with a Multi-Output Instrument
	Key Concepts

	Chapter 10: Automating Your Mix
	Exploring Track Automation
	Using Touch and Latch Modes
	Creating and Editing Automation Nodes and Lines
	Key Concepts

	Chapter 11: Getting Answers
	Exploring Logic Pro Help
	What’s Next?





