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Whatever you write, Pages ’09 offers an intuitive way to create 
beautiful, media-rich documents using impressive features.

To get started with Pages, just open it and choose one of the predesigned templates. 
Type over placeholder text, drag your own pictures over placeholder graphics, and 
before you know it you have a compelling letter, report, brochure, or flyer.

This user guide provides detailed instructions to help you accomplish specific tasks in 
Pages. In addition to this book, other resources are available to help you.

Online video tutorials
Video tutorials at www.apple.com/iwork/tutorials/pages provide instructions for 
performing common tasks in Pages. The first time you open Pages, a message appears 
with a link to these tutorials on the web. You can view Pages video tutorials anytime by 
choosing Help > Video Tutorials.

Pr
ef

ac
eWelcome to Pages ’09

http://www.apple.com/iwork/tutorials/pages/
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Onscreen help
Onscreen help contains detailed instructions for completing all Pages tasks. To open 
help, open Pages and choose Help > Pages Help. The first page of help also provides 
access to useful websites.

iWork website
Read the latest news and information about iWork at www.apple.com/iwork.

Support website
Find detailed information about solving problems at www.apple.com/support/pages.

Help tags
Pages provides help tags—brief text descriptions—for most onscreen items. To see a 
help tag, hold the pointer over an item for a few seconds.

http://www.apple.com/iwork/
http://www.apple.com/support/pages/
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This chapter introduces you to the windows and tools you’ll 
use in Pages.

When you create a Pages document, you first select a template to start from.

Pages Templates
When you first open the Pages application (by clicking its icon in the Dock or by 
double-clicking its icon in the Finder), the Template Chooser window presents a variety 
of document types from which to choose. 

1Pages Tools and Techniques



Pick a Word Processing or Page Layout template that best fits your purpose and 
design goals. To learn more about the distinguishing features of Word Processing and 
Page Layout templates, see “Word Processing Templates” on page 17 or “Page Layout 
Templates” on page 17. After selecting a template, click Choose to work with a new 
document based on the selected template. 

The new document contains placeholder text, placeholder images, and other items, 
which represent elements of the finished document:

Placeholder text indicates 
where you can type new 
text and how your text will 
look on the page.

Merge fields let you personalize 
documents with Address Book 
and Numbers document data.

Media placeholders 
indicate the size and 

placement of graphics in 
a document template.

The Page View control 
lets you change a 

document’s onscreen 
appearance.

The navigation controls lets you go 
to a specific page or scroll through 
the document by selection, page, 
element, or style.

ÂÂ Placeholder text shows you how your text will look on the page. If you click 
placeholder text, the entire text area is selected. When you begin typing, the 
placeholder text disappears and is replaced by what you type. To learn more, see 
“Using Placeholder Text” on page 78.

ÂÂ Media placeholders can hold images, audio files, and movies. Drag your own images, 
audio files, or movies to the placeholder. Media placeholders automatically size and 
position the image or movie. You can drag media files anywhere in a document (not 
only to a media placeholder). To learn more, see “Replacing Template Images with 
Your Own Images” on page 140.
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Many templates also contain ÂÂ merge fields. Merge fields let you easily insert names, 
phone numbers, addresses (any data you’ve defined for contacts in Address Book 
or a Numbers document) into Pages documents. This capability lets you reuse a 
document, such as a letter or contract, for multiple people by inserting person-
specific data into merge fields in the document. To learn more, see “What Are Merge 
Fields?” on page 246.

Sometimes graphics, such as watermarks or logos, appear on pages. These objects ÂÂ
are called master objects. If you cannot select an object in a template, it’s probably 
a master object. To learn more, see “Using Master Objects (Repeated Background 
Images)” on page 63.

You can drag or place objects on a page, including imported graphics, movies, and 
sound, or objects that you create within Pages, including text boxes, charts, tables, 
and shapes.

You can also insert pages that have been preformatted for the template you’re using. 
Click Pages or Sections in the toolbar and choose a template page. The new page is 
added immediately after the page where you placed the insertion point.

Word Processing Templates
Use Word Processing templates to create text-intensive documents, such as letters 
and reports.

Here are the distinguishing features of a Word Processing template: 

Text flows from one page to another. See “ÂÂ Understanding Text” on page 78 for 
more information.

You can add and edit a table of contents in your document. See “ÂÂ Using a Table of 
Contents” on page 64 for more information.

Page thumbnails are hidden by default. See “ÂÂ Viewing Thumbnails” on page 60 for 
more information.

Only a horizontal ruler is available by default. See “ÂÂ Rulers and Alignment Guides” on 
page 27 for more information.

You can also display the vertical ruler in a Word Processing template. See “Changing 
Ruler Settings” on page 96 for more information.

Word Processing templates contain floating and inline objects. For more information ÂÂ
about working with floating and inline objects, see “What Are Floating and Inline 
Objects?” on page 137.

Page Layout Templates
Use Page Layout templates to arrange images and other elements in your document.



Here are the distinguishing features of a Page Layout template: 

Page Layout templates contain floating objects such as images and text boxes that ÂÂ
can be easily moved anywhere on the page. For more information about working 
with floating objects, see “What Are Floating and Inline Objects?” on page 137.

Text in a Page Layout template must either replace placeholder text in a template ÂÂ
text box or a text box must be added to the page. See “Using Placeholder Text” on 
page 78 for more information.

Text can flow between text boxes. See “ÂÂ Linking Floating Text Boxes” on page 106 for 
more information.

Page thumbnails are shown by default. See “ÂÂ Viewing Thumbnails” on page 60 for 
more information.

Vertical and horizontal rulers are shown by default. See “ÂÂ Changing Ruler Settings” on 
page 96 for more information.

Document Viewing Aids
As you work on your document, you may want to zoom in or out to get a better view 
of what you are doing, or use other techniques for viewing the document. 

To learn about Go to

Reducing or enlarging the view of your 
document

“Zoom Levels” on page 18

Changing how document pages appear “Document Page Views” on page 19

Showing the different text areas of your 
document

“Layout View” on page 19

Viewing formatting marks in your document “Formatting Characters (Invisibles)” on page 21

Viewing the application window in full-screen 
view

“Viewing and Editing Your Document in Full 
Screen” on page 35

Zoom Levels
You can enlarge (zoom in) or reduce (zoom out) your view of a document. It’s often 
useful to reduce your view of a document so that you can see several pages at once. 

Here are ways to zoom in or out of the document:
Choose View > Zoom > Zoom In, or View > Zoom > Zoom Out.  mm

To return a document to its actual size, choose View > Zoom > Actual Size.
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Choose a magnification level from the View pop-up menu at the bottom left of the mm

window.

You can also view the application window in full-screen view, to help you work without 
distractions. To learn more, see “Viewing and Editing Your Document in Full Screen.”

To use a certain zoom level every time you open a document, choose Pages > 
Preferences, click Rulers, and then choose a zoom level from the Default Zoom pop-
up menu.

Document Page Views
You can arrange the way pages appear in the Pages window. 

To choose a way to view document pages in the Pages window:
	 1	 Click the View pop-up menu in the bottom-left corner of the window.

	 2	 Choose one of the page view options. 

One Up:  Presents the pages above and below each other.

Two Up:  Presents two pages side-by-side on the screen.

Fit Width:  Scales the document to the width of the window. You can stretch the Pages 
window to fill your screen, or make it short or narrow. Choose Fit Width to view all the 
content on side-by-side (Two Up) pages.

Fit Page:  Fills the window with a single document page.

You can also view the application window in full-screen view, to help you work without 
distractions. To learn more, see “Viewing and Editing Your Document in Full Screen.”

Layout View
In layout view you can see the outlines of the different text areas of your document, 
including headers, footers, columns, text boxes, and the document body (the main 
area of text in the document). 

In layout view document rulers and alignment guides become visible. Pages also 
displays the document ruler, which contains controls for formatting text, when you 
show a document’s layout.



To show or hide a document’s layout:
Click View in the toolbar, and then choose Show Layout or Hide Layout.mm

In the following example, you can see the page layout includes two columns at the 
top, two layout breaks, and then three columns, a floating image, and the footer area.

Two columns

Layout break

Footer

Layout break

A floating image

Three columns

A layout is part of a document in which you have defined layout margins and columns. 
As the example above illustrates, you can have multiple layouts on a single page. A 
layout break ends one layout and starts a new one with a different number of columns. 
See “Using Layouts” on page 49 for details.

The example above shows a floating image. A floating image stays where you place it 
on a page, unless you drag it to a new position. When “Object causes wrap” is selected 
in the Wrap inspector, text flows around a floating image as you type. There’s a second 
kind of image: an inline image . An inline image is an image placed so that it’s anchored 
to text. An inline image moves with the text around it. To learn how to place images so 
that they’re floating or inline, see “Working with Images” on page 138.
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Formatting Characters (Invisibles)
Each time you press the Space bar, the Tab key, or the Return key, or add a column, 
layout, page break, or section break, Pages inserts a formatting character in the 
document. These formatting marks are called invisibles because, by default, you can’t 
see them. 

Making formatting characters visible is often useful, especially when you’re formatting 
a more complex document. For example, you can change your document format by 
selecting an invisible and then pressing the Delete key to remove formatting.  

To see invisibles:
	 1	 Click View in the toolbar and choose Show Invisibles.

	 2	 To make invisibles stand out better, you can change their color. Choose Pages > 
Preferences, click General, click the Invisibles color well, and then select a color.

The table below shows what each formatting character represents. 

Invisible character Represents

 Space

 Nonbreaking space (Option-Space bar)

 Tab

 Line break (Shift-Return)

 Paragraph break (Return)

 Page break

Column break (“Defining Column Breaks” on 
page 51)

Layout break (“Defining Layout Breaks” on 
page 51)

Section break (“Creating Sections” on page 59)

Anchor point (for inline objects with text 
wrapping)

The Toolbar
The Pages toolbar gives you one-click access to many of the actions you’ll use when 
working with documents. As you work in Pages and get to know which actions you 
perform most often, you can add, remove, and rearrange toolbar buttons to suit your 
working style.  

To see a description of what a button does, hold the pointer over the button. 



The default set of toolbar buttons for a word processing document in Mac OS X v10.7 
(Lion) or later is shown below.

Add comments to 
selected text or objects.

Add text boxes, 
shapes, tables, 
and charts.Show thumbnails, 

comments, Styles drawer, 
page layout, and more.

Add preformatted 
pages.

Open the Inspector window, 
Media Browser, Colors 

window, and Fonts window.

Create an outline.

View and edit 
in full screen.

Share a copy of 
this document.

The default set of toolbar buttons for a word processing document in Mac OS X v10.6.x 
(Snow Leopard) or earlier is shown below.

Add comments 
to selected text 
or objects.

Add text boxes, 
shapes, tables, 
and charts.

Show thumbnails, 
comments, Styles 

drawer, page layout, 
and more.

Add preformatted 
pages.

Open the Inspector 
window, Media Browser, 

Colors window, and 
Fonts window.

Create an outline.

View and edit 
in full screen.

Share a copy of 
this document.

To customize the toolbar:
	 1	 Choose View > Customize Toolbar or Control-click in the toolbar, and then choose 

Customize Toolbar. The Customize Toolbar sheet appears. 

	 2	 Make changes to the toolbar as desired.

To add an item to the toolbar, drag its icon to the toolbar.

To remove an item from the toolbar, drag it out of the toolbar. 

To restore the default set of toolbar buttons, drag the default set to the toolbar. 

To make the toolbar icons smaller, select Use Small Size.  

To show only icons or only text, choose an item from the Show pop-up menu. 

To rearrange items in the toolbar, drag them. 

	 3	 Click Done. 

You can perform several toolbar customization activities without using the Customize 
Toolbar sheet:

ÂÂ To remove an item from the toolbar, press the Command key while dragging the 
item out of the toolbar. 
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You can also press the Control key while you click the item, and then choose 
Remove Item from the shortcut menu.

ÂÂ To move an item, press the Command key while dragging the item around in  
the toolbar.

To show or hide the toolbar, choose View > Show Toolbar or View > Hide Toolbar.

The Format Bar
Use the format bar, displayed beneath the toolbar, to quickly change the appearance 
of text, styles, fonts, and other elements in your document. 

The controls in the format bar vary with the object selected. To see a description of 
what a format bar control does, hold the pointer over it. 

Here’s what the format bar looks like when text is selected:

Choose a paragraph 
or character style.

Click to open the 
Styles drawer.

Change the font, font style, 
font size, and color.

Choose the line 
spacing and the 
number of columns.

Align selected text. Choose a list style.

To show or hide the format bar:
Choose View > Show Format Bar or View > Hide Format Bar.mm

The Inspector Window
You can format most elements of your document using the panes of the Inspector 
window, including text appearance, size and positioning of graphics, and much more. 

Open multiple inspector windows to make working with your document easier. For 
example, if you have the Graphic inspector and the Text inspector open, you have all 
the text and image formatting options at your fingertips as you work.  

Hold the pointer over buttons and other controls in the inspector panes to see a 
description of what the controls do.

Here are ways to open the Inspector window:
Click Inspector in the toolbar.  mm



Choose View > Show Inspector.mm

The buttons at the top of the Inspector 
window open the ten inspectors:  
Document, Layout, Wrap, Text, Graphic, 
Metrics, Table, Chart, Link, and QuickTime.

Click any of the buttons at the top of the Inspector window to display a particular 
inspector. Hold the pointer over a button to display its name. Clicking the fourth 
button from the left, for example, displays the Text inspector.

To open another Inspector window, choose View > New Inspector.mm

The Media Browser
The Media Browser provides access to all the media files in your iPhoto library, your 
iTunes library, your Aperture library, and your Movies folder. You can drag an item from 
the Media Browser to a page or to an image well in an inspector. 

Click a button to view the 
files in your iTunes library, 
your iPhoto library, your 
Aperture library, or your 
Movies folder.

Drag a file to your document.

Search for a file.

If you don’t use iPhoto or Aperture to store your photos, or iTunes for your music, or 
if you don’t keep your movies in the Movies folder, you can add other folders to the 
Media Browser so that you can access their multimedia contents in the same way.

To open the Media Browser:
Click Media in the toolbar or choose View > Show Media Browser.mm

To add another folder to the Media Browser, do any of the following:
To add a folder containing audio files, click Audio in the Media Browser, and then drag mm

the folder you want from the Finder to the Media Browser.
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To add a folder containing photos, click Photos in the Media Browser, and then drag mm

the folder you want from the Finder to the Media Browser.

To add a folder containing movies, click Movies in the Media Browser, and then drag mm

the folder you want from the Finder to the Media Browser.

The Fonts Window
Using the Mac OS X Fonts window—accessible from any application—you can change 
a font’s typeface, size, and other options. 

Create interesting 
text effects using 

these buttons.

The Action menu

Choose a typeface to 
apply to selected text.

Find fonts by typing a font 
name in the search field.

Choose a font size to 
apply to selected text.

Apply a shadow to 
selected text. Modify 
the shadow using the 
opacity, blur, offset, 
and angle controls.

Preview the selected 
typeface (you might need to 

choose Show Preview from 
the Action menu).

To open the Fonts window:
Click Fonts in the toolbar.mm

Use the Fonts window to select fonts, font sizes, and other font formatting features, 
including text shadows and strikethrough.

Here is a summary of what the text effects buttons do, from left to right:

The Text Underline pop-up menu lets you choose an underline style (such as single ÂÂ
or double).

The Text Strikethrough pop-up menu lets you choose a strikethrough style (such as ÂÂ
single or double).

The Text Color pop-up menu lets you apply a color to text.ÂÂ

The Document Color pop-up menu lets you apply a color behind a paragraph.ÂÂ

The Text Shadow button applies a shadow to selected text.ÂÂ

The Shadow Opacity, Shadow Blur, Shadow Offset, and Shadow Angle controls ÂÂ
control the appearance of the shadow.

If you don’t see the text effect buttons, choose Show Effects from the Action pop-up 
menu (looks like a gear) in the lower-left corner of the Fonts window. 



If you frequently use the Fonts window, there are techniques for saving time. To 
quickly locate fonts you frequently use, organize them into font collections. Click the 
Add (+) button to create and name a font collection, and then drag the font name 
from the Family list into the new collection.

If you like to change fonts often, leave the Fonts window open. Resize the Fonts 
window using the control in the bottom-right corner of the window, so that only the 
font families and typefaces in your selected font collection are visible.

The Colors Window
You use the Mac OS X Colors window to choose colors for text, objects, and lines. 

The color selected in the color 
wheel appears in this box. (The 
two colors in this box indicate the 
opacity is set to less than 100%.)

Use the slider to set lighter or 
darker hues in the color wheel.

Click to select a color in 
the color wheel.

Drag colors from the color box to 
store them in the color palette.

Click the search icon, 
and then click any item 
on the screen to match 

its color.

Click a button to view 
different color models.

Drag the Opacity slider 
to the left to make the 

color more transparent.

You can use the color wheel in the Colors window to select colors. The color you select 
appears in the box at the top of the Colors window. You can save that color for future 
use by placing it in the color palette. 

To apply the colors you select in the Colors window to an object on the page, select 
the object, and then place the color in the appropriate color well in an inspector pane. 
You can select a color well in one of the inspectors, and then click a color in the color 
wheel. Or you can drag a color from the color palette or color box to a color well in 
one of the inspectors.

To select a color:
	 1	 Open the Colors window by clicking the color well in the format bar and choosing 

Show Colors, or click Colors in the toolbar, or click a color well in one of the inspectors.

	 2	 Click anywhere in the color wheel. The selected color is displayed in the color box at 
the top of the Colors window.
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	 3	 To make the color lighter or darker, drag the slider on the right side of the  
Colors window.

	 4	 To make the color more transparent, drag the Opacity slider to the left or enter a 
percentage value in the Opacity field.

	 5	 To use the color palette, open it by dragging the handle at the bottom of the Colors 
window. Save a color in the palette by dragging a color from the color box to the color 
palette. To remove a color from the palette, drag a blank square to the color you want 
to remove.

	 6	 To match the color of another item on the screen, click the search icon to the left of 
the color box in the Colors window. Click the item on the screen whose color you want 
to match. The color appears in the color box. Select the item you want to color in the 
document window, and then drag the color from the color box to the item.

Rulers and Alignment Guides
As you move objects around in a document, alignment guides automatically appear to 
help you position objects on the page. See “Using Alignment Guides” on page 161 for 
details about using the alignment guides.

Rulers help you set 
margins and tabs where 
you want them. 

Blue icons on the top ruler indicate 
text indents and tab settings. Drag 
them to reset the position of text.

Gray rectangles inside 
the rulers indicate 
column margins. Drag 
the rectangles to change 
the column gutter widths.

Use the horizontal ruler to set tab stops, page margins, and column widths. You can 
also display the vertical ruler in a Word Processing template. For more information, 
see “Changing Ruler Settings” on page 96, “Setting Indents” on page 97, and “Defining 
Columns” on page 50.

The Styles Drawer
As you create a document, you may want to use a certain text style for every chapter 
title, heading, bulleted list, and body text paragraph. Each template comes with a set 
of preset styles that you can choose from. “What Are Styles?” on page 123 provides 
more details about styles. 



The Styles drawer lists and provides a preview of all the text styles in the template you 
are using, so you can create, customize, and manage styles easily. 

Select a paragraph style to 
apply it to selected paragraphs 
or the paragraph that contains 
the insertion point.

Select a character style to 
apply it to selected text or the 
word that contains the 
insertion point.

Select a list style to apply it to 
selected paragraph text or the 
paragraph that contains the 
insertion point.

Click to show and hide list and 
character styles in the drawer.

Hold down while 
you choose an 
option to create a 
new style.

Here are ways to open the Styles drawer:
Click View in the toolbar, and then choose Show Styles Drawer.mm

Click the Styles Drawer button in the format bar.mm

See “Applying Styles” on page 125 to learn how to use the Styles drawer.
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Scroll Bars, Scroll Arrows, and Thumbnails
You can use the scroll bars, Previous Page and Next Page arrows, page thumbnails, and 
the “Go to Page” button to move around in a document.

Drag the vertical 
scroller to quickly scroll 
up and down.

Click the scroll arrows to 
move forward or backward 
in small increments.

Click the Previous Page or Next 
Page arrows to navigate a page 
at a time, or click the Action 
menu to navigate by section, 
page, element, or style.

Drag the horizontal 
scroller to scroll left 
and right.

Click a thumbnail to 
display a particular page.

Click the Page button 
to switch to the 

“Go to Page” field.

Drag left or right to resize 
the thumbnail pane and 

resize thumbnails.

Here are ways to navigate through a document:
To move forward or backward in small increments, click the scroll arrows. mm

To scroll quickly, drag the vertical scroller up or down, or drag the horizontal scroller mm

from left to right.

In Mac OS X v10.7 (Lion) or later, scroll bars are displayed according to the settings in 
your Mac OS X preferences.

To move forward or backward one page at a time, click the Previous Page button mm

(looks like an up arrow) or the Next Page button (looks like a down arrow) at the 
bottom of the document window.

To navigate to the next or previous document item of your choosing, click the Action mm

menu at the bottom of the window and select a document item (such as a section, 
comment, hyperlink, or paragraph style), and then click the scroll arrows.



To go to a specific page in a document, click View in the toolbar and choose Page mm

Thumbnails. Then click in the thumbnail view to go to a particular page. You can also 
navigate to a page in a document by clicking the Page button in the lower left of the 
document window, typing the specific page number in the “Go to Page” field, and then 
pressing Return.

To show facing pages in the thumbnail view, select Facing Pages in the Document mm

inspector’s Document pane. To open the Inspector window, click Inspector in the 
toolbar, and click the Document button. 

See “Viewing Thumbnails” on page 60 for more information about using thumbnails.

If your keyboard has them, you can also use the Page Up, Page Down, Home, End, and 
arrow keys to move around.

Research and Reference Tools
Use the research and reference tools to look for files on your hard disk, review 
document information, and find word definitions or facts on selected text. 

Here are ways to access research and reference tools:
To locate files on your hard disk, select the text related to the files you wish to find and mm

choose Edit > Writing Tools > “Search in Spotlight.”

To view document information, choose Edit > Writing Tools > Show Statistics. mm

To look up word definitions quickly, select the word you wish to reference and choose mm

Edit > Writing Tools > “Look Up in Dictionary and Thesaurus.”

To research information on the Internet, select the text you wish to investigate and mm

choose Edit > Writing Tools > “Search in Google” or Edit > Writing Tools > “Search in 
Wikipedia.”

You can also Control-click the page to quickly go to the research and reference tools.

Keyboard Shortcuts and Shortcut Menus
You can use the keyboard to perform many of the Pages menu commands and tasks. 
To see a comprehensive list of keyboard shortcuts, open Pages and choose Help > 
Keyboard Shortcuts.  

Many commands are available in shortcut menus that you can access directly from the 
object you are working with. Shortcut menus are especially useful for working with 
tables and charts.
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To open a shortcut menu:
Press the Control key while you click text or an object.mm

The Warnings Window
When you import a document into a Pages document, some elements might not 
transfer as expected. The Warnings window lists any problems encountered. You 
might get warnings in other situations, such as saving a document in an earlier 
version of the application.  

If Pages experiences any problems, you’ll see a message in which you can review the 
warnings. If you choose not to review them, you can see the Document Warnings 
window at any time by choosing View > Show Document Warnings.

If you see a warning about a missing font, you can select the warning and then click 
Replace Font to choose a replacement font.

You can copy one or more warnings by selecting them in the Document Warnings 
window and choosing Edit > Copy. You can then paste the copied text into an email 
message, text file, or some other document.
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Create, open, import, password-protect, and save Pages 
documents. Learn how to edit your Pages document in full-
screen mode.

Creating a New Document
To create a new Pages document, you pick the Word Processing or Page Layout 
template that provides appropriate formatting and layout characteristics.

To create a new Pages document:
	 1	 Open Pages by clicking its icon in the Dock or by double-clicking its icon in the Finder. 

	 2	 In the Template Chooser window, select a template category in the left column to 
show related Word Processing or Page Layout templates, and then select the template 
that best matches the document you want to create.

2Creating, Opening, and Saving a 
Document
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Scan the page types available in many of the Pages templates by moving the pointer 
from right to left over a template icon in the Template Chooser. You can change 
the size of the template icons by adjusting the slider at the bottom of the Template 
Chooser window.

If you want to begin in a document without any text or media placeholders, select 
Blank under Page Layout or Word Processing.

In a Blank page layout document, text is added by inserting a text box and then typing 
in the text box. To add text to a Blank word processing document, begin typing.

	 3	 Click Choose. 

A new document opens on your screen.

If you don’t see the Template Chooser when you first open Pages, you can make it 
appear by setting a preference in Pages preferences. Choose Pages > Preferences, click 
General, and then select “For New Documents: Show Template Chooser.”

Alternatively, you can set Pages to automatically open a Blank document or the 
document template of your choice every time you open the application. Choose 
Pages > Preferences, click General, select “For New Documents: Use template,” and then 
click Choose. Select a template, and then click Choose.



Opening an Existing Document
There are several ways to open a document that was created using Pages. 

Here are ways to open a Pages document:
To open a document when you’re working in Pages, click “Open an Existing File” in the mm

Template Chooser window, select the document, and then click Open. You can also 
choose File > Open, select the document, and then click Open.  

To open a document you’ve worked with recently, choose your document from the mm

Open Recent pop-up menu at the bottom left of the Template Chooser window. 
Alternatively, you can choose File > Open Recent and choose the document from the 
submenu. 

To open a Pages document from the Finder, double-click the document icon or drag it mm

to the Pages application icon.

To open a password-protected Pages document, double-click the document icon, type mm

the document password in the Password field, and then click OK.

If you enter an incorrect password, click OK in the dialog that appears, type the correct 
document password, and then click OK.

You can open a Pages document created using an older version of Pages (from 
iWork ’05, iWork ’06, or iWork ’08). To take advantage of new features, save the 
document in Pages ’09 format. To preserve a document for use with iWork ’08, save 
it in the iWork ’08 format. See “Saving a Document as an iWork ’08 or Microsoft Word 
Document” on page 260.

If you see a message that a font or file is missing, you can still use the document. Pages 
substitutes fonts for missing fonts. To use missing fonts, quit Pages and add the fonts 
to your Fonts folder (for more information, see Mac Help). To make missing movies or 
sound files appear, add them to the document again.

Opening a Document from Another Application
You can create a new Pages document by importing a document created in another 
application, such as Microsoft Office 2007 or AppleWorks. Pages can import the 
following file formats: plain text (.txt), Rich Text Format (.rtf and .rtfd), AppleWorks 6 
word processing (.cwk), and Microsoft Word (.doc). 

As much as possible, Pages preserves the original document’s text, colors, layout, and 
other formatting options.  

From Microsoft Word, you can import styles, tables, inline and floating objects,  
charts, footnotes and endnotes, bookmarks, hyperlinks, lists, sections, change tracking, 
and more.

From AppleWorks, you can import word processing documents only.
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Here are ways to import a document:
Drag the document to the Pages application icon. A new Pages document opens, and mm

the contents of the imported document appear.

In Pages, choose File > Open, select the document, and then click Open.mm

If you can’t import a document, try opening the document in another application and 
saving it in a format Pages can read, or copy and paste the contents into an existing 
Pages document.

You can also export Pages documents to Microsoft Word (.doc), PDF, Rich Text Format 
(.rtf and .rtfd), and plain text (.txt). See “Exporting Pages Documents to Other File 
Formats” on page 256 for details.

Viewing and Editing Your Document in Full Screen
Using full-screen view lets you access controls when you need them, for a simpler view 
of your Pages document. When viewing your Pages document in full screen, you can 
make detailed and accurate changes as you write.

To edit your document in full-screen view:
	 1	 Open a Pages document.

	 2	 Choose View > Enter Full Screen, or click the Full Screen button in the Pages toolbar 
(looks like two outward-facing arrows).

Document information, such as word and page count, is displayed at the bottom of 
the screen.

	 3	 Do any of the following:

To display the format bar and menu items, move the pointer to the top of the screen. ÂÂ

To view the inspector, choose View > Show Inspector.ÂÂ

To display page thumbnails, move the pointer to the left of the screen.ÂÂ

To display document scroll bars in Mac OS X v10.6.x (Snow Leopard), move the ÂÂ
pointer to the right of the document.

In Mac OS X v10.7 (Lion) or later, scroll bars are displayed according to the settings in 
your Mac OS X preferences.



	 4	 To change the appearance of full-screen view, use the View and Background controls, 
which appear on the far right of the format bar.

To exit full-screen view, do any of the following:
Choose View > Exit Full Screen.mm

Move the pointer to the top of the screen to display the menu bar, and then click the mm

Full Screen button in the top-right corner of the screen.

Press Escape on your keyboard.mm

Your document opens in normal view, even if it was saved in full-screen view. 

Password-Protecting Your Document
When you want to restrict access to a Pages document, you can assign it a password. 
Passwords can consist of almost any combination of numerals and capital or lowercase 
letters and several of the special keyboard characters. Passwords with combinations of 
letters, numbers, and other characters are generally considered more secure.

Here are ways to manage password protection in a Pages document:
To add a password to your document, open the Document inspector, click mm

Document, and select “Require password to open” at the bottom of the inspector. 
Type the password you want to use in the fields provided, and then click Set 
Password. A lock icon appears next to the document title to indicate that your 
document is password protected.

If you want help to create an unusual or strong password, click the button with the 
key-shaped icon next to the Password field to open the Password Assistant and use 
it to help you create a password. Select a type of password in the pop-up menu, 
depending on which password characteristics are most important to you.

A password appears in the Suggestion field; its strength (“stronger” passwords are 
more difficult to break) is indicated by the length and green color of the Quality bar. If 
you like the suggested password, copy it and paste it into the Password field.

If you don’t like the suggested password, you can choose a different password from 
the Suggestion field pop-up menu, increase the password length by dragging the 
slider, or type your own.

To remove a password from your document, open your password-protected mm

document, and then deselect “Require password to open” in the Document inspector’s 
Document pane. Enter the document password to disable password protection and 
click OK.

The lock icon next to the document title is removed to indicate that your document is 
no longer password protected.

	 36		  Chapter 2    Creating, Opening, and Saving a Document



	 Chapter 2    Creating, Opening, and Saving a Document	 37

To change your document password, open the password-protected document, and mm

then click Change Password in the Document inspector’s Document pane. Enter your 
password information in the fields provided and click Change Password.

To open a password-protected Pages document, double-click the document icon, type mm

the document password in the Password field, and then click OK.

If you enter an incorrect password, click OK in the dialog that appears, type the correct 
document password, and then click OK.

Saving A Document
It’s a good idea to save your document often as you work. After you save your 
document for the first time, you can press Command-S to resave as you edit your 
document. 

If you’re running Mac OS X v10.7 (Lion) or later, Pages auto-saves your document 
frequently while you work, so that you don’t have to worry about losing changes you 
made to your document if the application closes unexpectedly. But when you press 
Command-S, a “snapshot” of the document’s current state is archived. You can return to 
this archived version of the document if you want to restore an image, setting, or text 
that you used previously and have since changed or deleted.

To save a document for the first time:
	 1	 Choose File > Save, or press Command-S.

	 2	 In the Save As field, type a name for the document.

	 3	 Choose the folder where you want to save the document from the Where pop-up menu.

If the location you want isn’t visible in the Where pop-up menu, click the disclosure 
triangle to the right of the Save As field, and then navigate to the location you want to 
save the document.

If you don’t see the Where pop-up menu, navigate to the location where you want to 
save the document.

	 4	 If you want the document to be opened using Pages in iWork ’08, select “Save copy as,” 
and then choose iWork ’08 from the pop-up menu. Or if you want the document to be 
opened using Microsoft Word, select “Save copy as,” and then choose Word Document 
from the pop-up menu.

If the document you want to save as a previous iWork version is password-protected, 
its password protection is removed.

	 5	 If you want the document to display a Quick Look in the Finder in Mac OS X v10.5 or 
later, select “Include preview in document.”

	 6	 If you or someone else will open the document on another computer, click Advanced 
Options and consider the following:



Copy audio and movies into document:  Selecting this checkbox saves audio and 
video files with the document so the files play if the document is opened on another 
computer. You might want to deselect this checkbox so that the file size will be smaller, 
but media files won’t play on another computer unless you transfer them as well.

Copy template images into document:  If you don’t select this option and you open 
the document on a computer that doesn’t have the same template installed (if you 
created your own template, for example), the document might look different.

	 7	 Click Save. 

To archive a version of a document in Mac OS X v10.7 (Lion) or later:
Choose File > “Save a Version,” or press Command-S.mm

Archived versions can only be created if you’re running Mac OS X v10.7 (Lion), or later. 
To learn about restoring archived document versions, see “Finding an Archived Version 
of a Document” on page 40.

In general, you can save Pages documents only to computers and servers that use 
Mac OS X. Pages is not compatible with Mac OS 9 computers and Windows servers 
running Services for Macintosh. If you must use a Windows computer, try using AFP 
server software available for Windows to do so.

To learn about Go to

Exporting your document in other file formats 
(including Microsoft Word, rich text format, plain 
text, and PDF)

“Exporting Pages Documents to Other File 
Formats” on page 256

Sharing your document on the web, with Mail, or 
using iWeb

“Sending Your Pages Document to iWork.com 
public beta” on page 261

“Emailing Your Pages Document” on page 264

“Sending a Pages Document to iWeb” on 
page 264

Undoing changes made to your document “Undoing Changes” on page 39

Using your own document layout and saving it as 
a template

“Saving a Document as a Template” on page 39

Creating a backup copy or multiple versions of 
your document

“Saving a Copy of a Document” on page 39

Setting your preferences to save backup versions 
of your document

“Saving a Backup Version of a Document 
Automatically” on page 40

Opening your document in outline mode “Saving a Document in Outline Mode” on page 42

Closing your document without quitting Pages “Closing a Document Without Quitting Pages” on 
page 42

Viewing word count and other document 
statistics

“Viewing Document Information” on page 43
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Undoing Changes
If you don’t want to save changes you made to your document since you opened or 
last saved it, you can undo the changes. 

Here are ways to undo changes:
To undo your most recent change, choose Edit > Undo. mm

To undo multiple changes, choose Edit > Undo multiple times. You can undo any mm

changes you made since opening the document or reverting to the last saved version.

To undo one or more Edit > Undo operations, choose Edit > Redo one or more times.mm

To undo all changes you made since the last time you saved your document, choose mm

File > “Revert to Saved,” and then click Revert.

Saving a Document as a Template
When you save a document as a template, it appears when you select My Templates in 
the Template Chooser. 

To save a document as a template:
Choose File > “Save as Template.”  mm

For information on custom templates, see “Saving a Custom Template” on page 272.

Saving a Copy of a Document
If you want to duplicate your open document, you can save it using a different name 
or location. 

To save a copy of a document in Mac OS X v10.7 (Lion) or later:
	 1	 Choose File > Duplicate.

An untitled copy of the document is created. Both copies remain open on your 
desktop for you to view or edit.

	 2	 Close the window of the untitled copy, type the document’s name, and then choose a 
location from the pop-up menu.

	 3	 Click Save.

To save a copy of a document in Mac OS X v10.6.x (Snow Leopard) or earlier:
Choose File > Save As, and then specify a name and location.mm

When the document is copied in this way, the original document is closed; the 
document that remains open on your desktop is the new copy you created. To work 
with the original version, choose File > Open Recent and choose the previous version 
from the submenu.



You can also automate creating duplicate versions of the document every time you 
save, retaining the name and location of the original, but with the words “Backup of” 
preceding the filename. See “Saving a Backup Version of a Document Automatically” on 
page 40.

Saving a Backup Version of a Document Automatically
Each time you save a document, you can automatically retain a copy of the last saved 
version. That way, if you change your mind about edits you made, you can go back to 
(revert to) the backup version of the document.

The best way to create backup versions is different, depending upon which version 
of Mac OS X you’re running. Mac OS X v10.7 (Lion) and later automatically saves a 
snapshot of your document every time you save. You can access an archive of all 
of the previous saved versions at any time. To learn about accessing and using past 
document versions in Mac OS X v10.7 (Lion), see “Finding an Archived Version of a 
Document” on page 40.

If you’re running Mac OS X v10.6.x (Snow Leopard) or earlier, you can set up Pages to 
automatically create a copy of the last saved version of your document. You may also 
find this useful if you’re running Mac OS X v10.7 (Lion), and you want to save a backup 
version of your document on another hard disk on your network.

To create an archive of previously saved versions of your document on Mac OS X 
v10.7 (Lion) or later:
Choose File > “Save a Version,” or press Command-S.mm

To create a copy of the last saved version of your document:
Choose Pages > Preferences, click General, and then select “Back up previous version mm

when saving.” 

The next time you save your document, a backup version is created in the same 
location, with “Backup of” preceding the filename. Only one version—the last saved 
version—is backed up. Every time you save the document, the old backup file is 
replaced with the new backup file.

Finding an Archived Version of a Document
If you saved archived versions of your document on Mac OS X v10.7 (Lion) or later, 
you can browse the archive to identify any earlier version that you want to restore 
or reference. After you identify the archived version that you want, you can restore it 
as a fully editable copy, or you can just extract from it any text, images, or document 
settings that you want to use again.

To browse archived versions of your document:
	 1	 Open the document for which you want to access older versions, and hold your 

pointer over the name of the document at the top of the Pages application window.
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A triangle appears.

	 2	 Click the triangle and choose Browse All Versions.

The view changes to show snapshots of all saved versions of the document receding 
against a background of stars. A timeline along the right side of the screen indicates 
when the frontmost version on the right was saved.

Past document versionsCurrent document version

Click to restore the version currently 
viewable on the right side of the screen.

Click to leave this view without 
restoring an older version.

Drag along the timeline to see 
versions saved at different times 

in the past.

	 3	 Drag the handle along the timeline to move back through time and look at older 
versions of the document.

	 4	 When you find a version that you want to inspect more closely, click its image.

The version moves to the foreground, where you can click different documents 
to view them, select items on a page, open the Inspectors, and copy objects or 
inspector settings.

	 5	 Do any of the following:

To completely restore the older version, click Restore when the version you want ÂÂ
is in the foreground. The restored document appears on your regular desktop, 
replacing the last version you were working on prior to viewing the older versions. 
(That version is then saved in the timeline, if you want to retrieve it.)



To restore only an object or inspector setting from the older version, copy the object ÂÂ
or setting by selecting it and pressing Command-C, and then click Done to return to 
your regular desktop. Paste the object or setting where it’s appropriate by pressing 
Command-V.

To compare the older version side-by-side with the current version, click  ÂÂ
Current Document.

	 6	 To return to your regular desktop, click Done.

Saving a Document in Outline Mode
If your Pages word processing document was last saved in outline mode, the 
document will open in outline mode. 

To save your word processing document in outline mode:
Open or create a word processing document, click Outline in the toolbar, and begin mm

typing. When you’ve finished typing, save your document by choosing File > Save.

The next time you open your document, the document will open in outline mode.

For more information on creating and working with a document in outline mode, see 
“Creating an Outline” on page 98.

Locking a Document So It Can’t Be Edited
If you’re running Mac OS X v10.7 (Lion) or later, you can lock your document so you 
can’t edit it by accident, when you only intend to open and view it. You can easily 
unlock the document at any time to continue editing it.

To lock a document:
	 1	 Open the document you want to lock, and hold your pointer over the name of the 

document at the top of the Pages application window.

A triangle appears.

	 2	 Click the triangle and choose Lock.

To unlock a document for editing:
Hold your pointer over the name of the document at the top of the application mm

window until the triangle appears, click the triangle, and then choose Unlock.

Closing a Document Without Quitting Pages
When you have finished working with a document, you can close it without  
quitting Pages. 

Here are ways to close documents and keep the application open:
To close the active document, choose File > Close, or click the close button in the mm

upper-left corner of the document window. 
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To close all open Pages documents, press the Option key and choose File > Close All, mm

or click the active document’s close button.

If you’ve made changes since you last saved the document, Pages prompts you to save.

Viewing Document Information
You can store information such as author name and keywords and later display that 
information, as well as statistics created automatically. 

Here are ways to work with information about a document:
To add or change descriptive information about a document (author, title, comments, mm

and keywords), click Inspector in the toolbar, click the Document button, and then 
click Info. Enter or change information in the fields in the pane.

This information is searchable using Spotlight on computers with Mac OS X version 
10.4 and later.

To display document statistics, such as number of words, pages, lines, paragraphs, mm

sections, graphics, and characters in the document, click Inspector in the toolbar, click 
the Document button, and then click Info.

A document’s word and page count are always visible at the bottom left of the 
window. To hide your document’s word count, choose Pages > Preferences, and then 
deselect “Show word count at window bottom.”

If a range of text is selected, you can specify the extent of the displayed statistics  
by choosing Selection or Document from the Range pop-up menu in the Document 
inspector.

To display a saved document’s file information, including its size, its location, and mm

the dates it was created and last modified, click Inspector in the toolbar, click the 
Document button, click Info, and then click the Show File Info button.
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Set up overall document characteristics, including margins, 
facing pages, text columns, and sections. Learn how to create 
a table of contents, footnotes, and endnotes.

Before adding content to your document, it’s a good idea to specify document 
settings, such as page orientation, page size, and page margins. Some documents 
also require changing settings for master objects (background graphics, such as 
watermarks) and facing-page attributes. You change most of these settings in the 
Document inspector and the Layout inspector.

3Working with Document Parts
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Managing Document Settings
To open the Document inspector:
Click Inspector in the toolbar, and then click the Document button. mm

Use the TOC pane to set 
up a table of contents for 

the document. 

Use the Info pane to see document 
statistics, such as word count, date, 
and keywords.

Use the Page Setup dialog to specify 
paper size and orientation.

Select the kind of note to create.

Adjust the space between notes.

Use any available font ligatures 
throughout the document.

Choose a footnote or endnote style.

Set up margins for the left, right, top, 
and bottom edges of the page. 

Select to password-protect your document.

Use automatic 
hyphenation throughout 

the document.

Select to add headers and 
footers to a document.

The Document 
inspector button

Formatting set in the Document inspector applies to the entire document.



To open the Layout inspector:
Click Inspector in the toolbar, and then click the Layout button. mm

Use the Section pane to set up page 
number, facing-page, and other 
section attributes.

Deselect to set unequal column widths.

Select a column or gutter width and 
type a new value.

Set the margins for the current layout.

Set the number 
of columns.

Select to start the 
current layout at 

the top of a page.

Set the space between 
the current layout and 

the preceding and 
following layouts.

The Layout inspector button

You use the Layout inspector to set up text column layouts. You can also control 
formatting options for document sections, such as chapters; for example, you can 
create a different first page, left page, and right page layout for each section.

Selecting Page Orientation and Size
By default, most Pages templates are created for standard paper sizes, with the text 
printed in portrait (vertical) orientation. If your document will require a different paper 
size or you want to print it in landscape (horizontal) orientation, you should set the 
paper size and orientation at the start. This way, as you work in your document, you 
will have a clearer idea of what it’s going to look like. 

“Setting the Paper Size and Orientation” on page 253 provides instructions for 
changing the page orientation and setting up paper size.

If you start with a Blank (word processing) or Blank Canvas (page layout) document, 
the templates are available in portrait and landscape orientation. 

Setting Document Margins
Every document has margins (blank space between the document’s content and the 
edges of the paper). These margins are indicated onscreen by light gray lines when 
you’re using layout view. To show layout view, click View in the toolbar, and then 
choose Show Layout. 
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The default margins for most of the Pages templates, including Blank, are set to 1 inch 
from the left and right sides of the page and 1 inch from the top and bottom. This 
means that the body text of the document will not expand outside these margins. 

To change the page margins:
	 1	 Click Inspector in the toolbar, click the Document button, and then click Document.

	 2	 Enter values in the Left, Right, Top, and Bottom fields.

If you want to set different margins in different sections of your document, you must 
use the Layout inspector. To learn about setting layout margins, see “Defining Layout 
Margins” on page 52.

If you are creating a document that will be bound, you may want your document 
margins to take into account which side of the page will go into the binding (the 
inside margin) and which will be the loose edge of each page (the outside margin). To 
do this, you must create a document with left- and right-facing pages. To read about 
this, see “Using Left- and Right-Facing Pages” on page 52.

Using Page and Line Breaks
You can insert page breaks, make a particular paragraph always start on a new page, 
make sure certain paragraphs always remain on the same page, and more.

When you insert breaks, Pages inserts a special formatting character called an 
invisible. See “Formatting Characters (Invisibles)” on page 21 for more information 
about invisibles. 

To learn about Go to

Creating a new page in your document “Inserting a Page Break” on page 47

Managing how paragraphs appear in your 
document

“Starting Paragraphs on a New Page” on page 48

“Keeping Paragraphs Together on a Page” on 
page 48

“Keeping an Entire Paragraph on the Same 
Page” on page 48

Adding a soft return and preventing single lines 
from appearing at the top or bottom of a page

“Inserting a Manual Line Break” on page 49

“Preventing Widow and Orphan Lines” on 
page 49

Inserting a Page Break
In a word processing document, you can force the page to break at a particular place 
by inserting a page break. This creates a new page within the current section that is 
ready for typing text. 



In a page layout document, you can create a new page by adding a new page to your 
document. This creates a new page in a new section that is ready to have a text box 
added for typing text.

Here are ways to insert a page break:
In a word processing document, click where you want the break to occur, and then mm

choose Insert > Page Break.  

To remove a page break, click at the beginning of the line that follows the break and 
press the Delete key.

In a page layout document, to insert a new page in your document, click Pages in the mm

toolbar and choose from the template page options available.

Starting Paragraphs on a New Page
In a word processing document, you can make a paragraph always start on a new 
page, regardless of what precedes it in a document. 

To start a paragraph on a new page:
	 1	 Select the paragraph you want to start on a new page. 

	 2	 Click Inspector in the toolbar, click the Text button, and then click More.

	 3	 Select “Paragraph starts on a new page.”

In a Blank Canvas (Page Layout) template, once a new page has been added, it’s ready 
to have a text box added for typing text.

Keeping Paragraphs Together on a Page
You can choose to make two paragraphs appear on the same page. The last line of 
the first paragraph will always remain on the same page as the beginning of the next 
paragraph, unless you insert a page or section break between them. 

This is most useful for single-line, header paragraphs that you want to keep with the 
topic paragraphs following. 

To keep paragraphs together on a page:
	 1	 Click the paragraph that you want to keep with the paragraph following it. 

	 2	 Click Inspector in the toolbar, click the Text button, and then click More.

	 3	 Select “Keep with following paragraph.”

Keeping an Entire Paragraph on the Same Page
You can make all the lines in a paragraph always appear on the same page. 

To avoid breaking a paragraph across pages:
	 1	 Click the paragraph whose lines you want to remain together. 

	 2	 Click Inspector in the toolbar, click the Text button, and then click More.
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	 3	 Select “Keep lines together.”

In a page layout document, text is contained in text boxes. For more information about 
linking text boxes, see “Linking Floating Text Boxes” on page 106.

Inserting a Manual Line Break
You can use a manual line break, also called a soft return, if you want to start a new line 
without starting a new paragraph. 

To insert a manual line break:
	 1	 Click where you want the break to occur.

	 2	 Press Return while holding down the Shift key.

Preventing Widow and Orphan Lines
You can prevent the first line of a paragraph from appearing alone at the bottom of a 
page (called a widow line) or the last line of a paragraph from appearing alone at the 
top of a page (called an orphan line). 

To prevent widow and orphan lines in a paragraph:
	 1	 Click the paragraph in which you want to prevent a widow or orphan. 

	 2	 Click Inspector in the toolbar, click the Text button, and then click More.

	 3	 Select “Prevent widow & orphan lines.”

Using Layouts
In Pages, you can vary the design in a page layout document by creating columns in text 
boxes, and in a word processing document through layouts separated by layout breaks.

For more information about working with text boxes in page layout documents, see 
“Using Text Boxes, Shapes, and Other Effects to Highlight Text” on page 104.  

In a word processing document, layouts are separated by layout breaks. A layout is 
part of a document in which you’ve defined specific column attributes and space 
around the columns, called the layout margin.

You can have multiple layouts in a section of your document, or even on a single page.

To learn about Go to

Creating columns and controlling text flow from 
one column to another

“Defining Columns” on page 50

“Defining Column Breaks” on page 51

Changing layout characteristics in a word 
processing document

“Defining Layout Breaks” on page 51

“Defining Layout Margins” on page 52



Defining Columns
Depending on the page size and column width you specify for a document, you 
can create as many as ten text columns (for example, in a standard letter size with 
landscape orientation). The space between the columns is called the gutter. 

When you type in a column and reach the end of the column, text automatically 
flows to the next column as you type. To change where a column breaks, follow the 
instructions in “Defining Column Breaks” on page 51.  

When you want to vary the number or appearance of columns at some point in a 
document, create a new layout. See “Defining Layout Breaks” on page 51 for instructions.

To format a document into multiple columns:
	 1	 Click Inspector in the toolbar, click the Layout button, click Layout, and then specify the 

number of columns you want in the Columns field. 

To type a number in the Columns field, place the insertion point inside a text area in 
your document, type the number in the Columns field, and then press Return.

	 2	 To adjust the width of all columns, double-click any value in the Column list and type a 
new number. 

To adjust the space between each column, double-click any value in the Gutter list and 
type a new number.

	 3	 To specify different widths for the columns, deselect “Equal column width.”

To adjust the width of a specific column, double-click its value in the Column list and 
type a new number. To adjust the space between adjacent columns, double-click a 
value in the Gutter list and type a new number. 

	 4	 In a word processing document, to adjust the space around the outside margins of 
columns, specify new values in the Left, Right, Before, and After fields. 

Layout margins are not adjustable in a page layout document.

	 5	 In a word processing document, to move columns to the top of the next page, select 
“Layout starts on new page.”  

You can’t select “Layout starts on new page” in a page layout document.
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	 6	 To quickly modify column width and spacing, use the document ruler. Click View in the 
toolbar, and then choose Show Rulers. Drag the left or right edges of the gray gutter 
areas in the horizontal ruler. 

The white areas in the ruler 
denote the text area within 
columns.

The gray areas denote the 
column gutters.

Note:  To quickly create as many as four columns, click the Columns pop-up menu in 
the format bar and choose the number of columns you want to use.

Defining Column Breaks
A column break ends the text flow in one column (leaving the rest of the column 
blank) and continues it in the next. 

To create a column break:
	 1	 Click after the word where you want to end the text flow.  

	 2	 Choose Insert > Column Break.

The text breaks where you placed the insertion point and continues in the next text 
column. If you insert a column break in a single-column layout, the text continues at 
the top of the next page.

When you show invisibles in your document (click View in the toolbar and choose 
Show Invisibles), a column break symbol marks the location of the column break. 

This column break symbol is a formatting character called an invisible. See “Formatting 
Characters (Invisibles)” on page 21 for more information about invisibles.

To delete a column break, click at the beginning of the line that follows the break and 
press the Delete key.

Defining Layout Breaks
In a word processing document, a layout break ends one layout and starts a new one 
in which you can define different column characteristics and different layout margins. 

Using layout breaks doesn’t affect the headers, footers, page numbering, or other 
formatting specific to the document or section. 



To insert a layout break in a word processing document:
	 1	 Place the insertion point after the word where you want to end the current layout and 

change to a new layout.

	 2	 Choose Insert > Layout Break.

A layout break is inserted and the insertion point is moved to the top of the next layout.

The layout following the break has the same formatting and number of text columns 
as the previous layout until you change it. To change the layout attributes, click 
Inspector in the toolbar and click the Layout button. In the Layout pane, set the 
number of columns, and then format them.

	 3	 To move the new layout to the top of a page, select “Layout starts on new page.”

When you show invisibles in your document (click View in the toolbar and then 
choose Show Invisibles), a layout break symbol marks the location of the layout break. 

This layout break symbol is a formatting character called an invisible. See “Formatting 
Characters (Invisibles)” on page 21 for more information about invisibles.

To delete a layout break, click at the beginning of the line that follows the break and 
press the Delete key.

Defining Layout Margins
In a word processing document, a layout margin is the space around columns in a layout. 

To change the layout margin in a word processing document:
	 1	 Click in a column.  

	 2	 Click Inspector in the toolbar, click the Layout button, and then click Layout.

	 3	 To change the outside margins of the column(s), enter values in the Left and Right 
fields under Layout Margins.

	 4	 To specify the amount of space above and below the column(s), enter values in the 
Before and After fields under Layout Margins.

The new margins can’t extend outside the page margins set for the document in the 
Document inspector.

Using Left- and Right-Facing Pages
If you intend to print a document double-sided and bind it, the document will have 
left- and right-facing pages. 
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The left and right pages of these documents usually have different inside and outside 
margins. For example, you may want the inside margins of a document that will 
be bound to be wider than the outside margins. See “Defining Margins for Facing 
Pages” on page 53 for more information. 

If your document contains sections, such as chapters, you can use different headers or 
footers for left and right pages when you want to place page numbers on the outer 
corners of each page. For more information, see “Defining Headers and Footers for 
Facing Pages” on page 53.

After you have adjusted margins and modified the headers and footers, you may want 
to review your document before printing it. See “Viewing Facing Pages” on page 54 for 
more information.

Defining Margins for Facing Pages
Use the Document inspector to set up different margins for left and right pages. 

To create different margins for left- and right-facing pages:
	 1	 Click Inspector in the toolbar, click the Document button, and then click Document. 

	 2	 Select Facing Pages.

Specify a value for the margin on 
the outside edges of the pages.

Select to set the margins 
for left- and right-facing 
pages independently.

Specify a value for the margin 
that will go into the binding.

	 3	 Set inside and outside margins. 

The inside margin is the side of left or right pages that goes into the binding. The 
outside margin is the side that is on the outside edge of left or right pages.

Defining Headers and Footers for Facing Pages
In word processing documents, if your document uses sections, you can set up 
different headers and footers for left and right pages, such as when you want the page 
number to appear on the outer edge of the footers. See “Formatting Facing Pages in a 
Section” on page 62 for information about defining sections. 

To set up headers and footers for facing pages in a section:
	 1	 Click inside the section. 

	 2	 Click Inspector in the toolbar, click the Layout inspector, and then click Section.

	 3	 Select “Left and right pages are different.”



	 4	 Deselect “Use previous headers & footers.”

	 5	 On a left page in the section, define the header and footer you want to use for all left 
pages in the section. 

See “Using Headers and Footers” on page 54 for instructions.

	 6	 On a right page in the section, define the header and footer you want to use for all 
right pages in the section.

	 7	 If you want the first page of the section to have a unique header or footer, select “First 
page is different” and define the header and footer on the first page of the section.

Viewing Facing Pages
When your document has facing pages, there are several ways to view them 
in Pages. View left and right pages in the thumbnail view or side by side in the 
document window. 

Here are ways to view facing pages:
Click View in the toolbar and choose Page Thumbnails to view facing pages in the mm

thumbnail view. 

Click the Page View control in the bottom-left corner of the window, and then mm

choose Two Up from the pop-up menu to view facing pages side by side in the main 
document window.

Using Headers and Footers
You can have the same text or graphic appear on multiple pages in a document. 
Recurring information that appears at the top of the page is called a header; at the 
bottom it’s called a footer.

You can put your own text or graphics in a header or footer, and you can use formatted 
text fields. Formatted text fields allow you to insert text that is automatically updated. 
For example, inserting the date field shows the current date whenever you open the 
document. Similarly, page number fields keep track of page numbers as you add or 
delete pages.
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To define the contents of a header or footer:
	 1	 Click View in the toolbar and choose Show Layout. 

You can see the header and footer areas at the top and bottom of the page.

	 2	 To add text or graphics to a header or footer, place the insertion point in the header or 
footer and type or paste text or graphics.

To add page numbers or other changeable values, see the instructions in “Adding Page 
Numbers and Other Changeable Values” on page 115.

Whatever you type in a header or footer is repeated on every page. If you want 
to change the header and footer text in different sections of your document, see 
“Changing Headers and Footers in a Section” on page 61.

Adding and Editing Footnotes and Endnotes
In a word processing document, you can add special marks (numbers or symbols) 
that link to notes at the bottom of a page (footnotes) or at the end of a document or 
section (endnotes). 

You can’t mix footnotes and endnotes in a document, but you can convert notes from 
one type to the other.

To learn about Go to

Adding and deleting footnotes and endnotes “Adding a Footnote” on page 55

“Adding an Endnote at the End of a 
Document” on page 56

“Adding an Endnote at the End of a Section” on 
page 56

“Deleting Footnotes and Endnotes” on page 57

Converting note types, modifying footnote and 
endnote appearance, and more

“Converting Footnotes to Endnotes and Vice 
Versa” on page 57

“Formatting Footnotes and Endnotes” on page 57

“Jumping Between a Mark and Its Related 
Footnote or Endnote” on page 57

Adding a Footnote
In a word processing document, you can add special marks in a document that link to 
notes at the bottom of the page. These notes are called footnotes.

To add a footnote:
	 1	 Click Inspector in the toolbar, click the Document button, and then click Document.

	 2	 Choose Use Footnotes from the Footnotes & Endnotes pop-up menu.

	 3	 Choose a numbering format from the Format pop-up menu.



	 4	 Choose whether footnotes are continuous or restart on each page or section from the 
Numbering pop-up menu.

	 5	 Place the insertion point in the main text flow (not in a text box, table, or other object) 
where you want the footnote mark to appear.

	 6	 Choose Insert > Footnote.

A footnote mark appears, and the insertion point moves to the corresponding 
footnote field at the bottom of the page.

	 7	 Type the footnote information. 

In addition to text, you can use inline shapes, graphics, and other objects; see “What 
Are Floating and Inline Objects?” on page 137 for instructions.

Adding an Endnote at the End of a Document
In a word processing document, you can add special marks in a document that link to 
notes at the end of the document. These notes are called document endnotes.

To add a document endnote:
	 1	 Click Inspector in the toolbar, click the Document button, and then click Document. 

	 2	 Choose Use Document Endnotes from the Footnotes & Endnotes pop-up menu.

	 3	 Choose a numbering format from the Format pop-up menu.

	 4	 Choose whether endnotes are continuous or restart on each page or section from the 
Numbering pop-up menu.

	 5	 Place the insertion point in the main text flow (not in a text box, table, or other object) 
where you want the endnote mark to appear.

	 6	 Choose Insert > Endnote.

An endnote mark appears, and the insertion point moves to the corresponding 
endnote field at the end of the document following a section break. If you don’t want 
the endnotes on a new page, delete the section break.

	 7	 Type the endnote information.

In addition to text, you can use inline shapes, graphics, and other objects; see “What 
Are Floating and Inline Objects?” on page 137 for instructions.

Adding an Endnote at the End of a Section
In a word processing document, you can add special marks in a document that link to 
notes at the end of each section. These notes are called section endnotes.

To add a section endnote:
	 1	 Click Inspector in the toolbar, click the Document button, and then click Document.

	 2	 Choose Use Section Endnotes from the Footnotes & Endnotes pop-up menu.

	 3	 Choose a numbering format from the Format pop-up menu.
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	 4	 From the Numbering pop-up menu, choose whether endnotes are continuous or 
restart on each section.

	 5	 Place the insertion point in the main text flow (not in a text box, table, or other object) 
where you want the endnote mark to appear.

	 6	 Choose Insert > Section Endnote.

An endnote mark appears, and the insertion point moves to the corresponding 
endnote field at the end of the section in which the mark appears. A line separates the 
endnotes from other information in the section.

	 7	 Type the endnote information.

In addition to text, you can use inline shapes, graphics, and other objects; see “What 
Are Floating and Inline Objects?” on page 137 for instructions.

Deleting Footnotes and Endnotes
In a word processing document, deleting footnotes and endnotes is easy. 

To delete a footnote or endnote:
Delete the mark within your document that refers to the note. mm

Converting Footnotes to Endnotes and Vice Versa
In a word processing document, you can change all the footnotes in a document 
into endnotes, or all the endnotes into footnotes. You can also convert all document 
endnotes to section endnotes and vice versa. However, you can’t mix endnotes and 
footnotes in the same document. 

To convert footnotes to endnotes and vice versa:
In the Document pane of the Document inspector, change the setting in the mm

Footnotes & Endnotes pop-up menu.  

Formatting Footnotes and Endnotes
In a word processing document, you can format footnotes, endnotes, and marks to 
change their appearance or control the amount of space between notes. 

Here are ways to format notes:
To change the appearance of notes and marks, select the note text and/or mark and mm

format it as you would any text using the Fonts window, the Text inspector, and the 
Styles drawer.  

To adjust the space between notes, in the Document pane of the Document inspector, mm

increase or decrease the number in the Space Between Notes field.

Jumping Between a Mark and Its Related Footnote or Endnote
In a word processing document, you can jump to a note from its mark or to the mark 
from a note. 



Here are ways to jump between marks and notes:
In the note, double-click the mark to jump to the location in the document where the mm

mark appears.  

In the document body, double-click the mark to jump to its note.mm

Numbering Footnotes and Endnotes
In a word processing document, you can use one of the predefined autonumbering 
styles for the mark that refers to the note. Predefined numbering styles are Arabic 
numbers (1, 2, 3), Roman numerals (i, ii, iii), and symbols (*, †, ‡). Numbering can be 
continuous through the document or restarted for each document section or page. 
For more information, see “Restarting Footnote and Section Endnote Numbering” on 
page 59. 

Instead of or in addition to using autonumbering, you can use custom marks, which 
you define yourself. See “Defining Marks for Numbering Footnotes and Endnotes” on 
page 58 and “Changing Marks for Numbering Footnotes and Endnotes” on page 58 
for more information. There’s no autonumbering for custom marks; if you use custom 
marks, you need to specify the mark you want to use every time you create a footnote 
or endnote.  

Defining Marks for Numbering Footnotes and Endnotes
In a word processing document, you can use a predefined number or symbol format 
or define your own marks. 

Here are ways to define marks:
To use a predefined number or symbol format, in the Document pane of the mm

Document inspector, choose a numbering style from the Format pop-up menu. The 
numbering style you choose will be the same throughout the document.  

To insert a custom mark, place the insertion point at the location in the document mm

where you want the mark to appear.

Click the Insert menu, and then press the Option key. Choose Custom Endnote, Custom 
Section Endnote, or Custom Footnote. What appears in the menu depends on the 
setting in the Footnotes & Endnotes pop-up menu.

In the dialog that appears, type or select a custom mark, and then click OK.

The mark appears, and the insertion point moves to the appropriate location in the 
document for you to type the note.

Changing Marks for Numbering Footnotes and Endnotes
In a word processing document, you can switch from custom mark numbering to 
predefined number formatting and vice versa. 
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Here are ways to change mark numbering styles:
To change the numbering format from predefined to custom, Control-click an endnote mm

or footnote mark, and then choose Use Custom Mark from the shortcut menu.  

In the dialog that appears, type or choose a custom mark, and then click OK. The 
custom mark replaces the predefined mark.

To change custom numbering to predefined numbering, Control-click a custom mark, mm

and then choose Use Automatic Numbering from the shortcut menu.

The mark that replaces the custom mark reflects the number format settings in the 
Document pane of the Document inspector.

Restarting Footnote and Section Endnote Numbering
If you don’t want footnote or section endnote numbering to be continuous, you can 
restart numbering on each page or for each section in a word processing document. 
Use sections to define document parts such as chapters. 

To restart endnote or footnote numbering:
Choose “Restarts on Each Page” or “Restarts for Each Section” from the Numbering pop-mm

up menu in the Document pane of the Document inspector.  

Creating Sections
Each Pages template consists of one or more predefined sections. Every time you add 
pages to the document by using the Sections (word processing) or Pages (page layout) 
button in the toolbar, you add a new section. 

In a page layout document, each page is one section. You can use the predefined 
sections as they are, or you can modify or remove them one page at a time.

In a word processing document, you can use the predefined sections as they are, or 
you can create or remove section breaks to define your own sections.

To add section breaks in word processing documents:
Place the pointer where you want the break to occur, and then choose Insert > Section mm

Break, or click Sections in the toolbar and choose an item from the list.

When you show invisibles in your document (click View in the toolbar and then choose 
Show Invisibles), a section break symbol marks the location of the section break.

The new section has the same formatting as the previous section until you change it. 
Changes you make to master objects, headers, footers, or page numbering apply only 
to the section in which you make the changes. See “Using Master Objects (Repeated 
Background Images)” on page 63 for information about master objects.



To remove a section break, click at the beginning of the line that follows the break and 
press the Delete key.

To learn about Go to

Navigating through a document and managing 
sections in it

“Viewing Thumbnails” on page 60

“Adding and Deleting Sections” on page 60

“Reorganizing Sections” on page 61

Defining section attributes such as page 
numbering, headers and footers, margins,  
and more

“Changing Headers and Footers in a Section” on 
page 61

“Restarting Page Numbering in a Section” on 
page 61

“Setting Up a Unique Format for a Section’s First 
Page” on page 62

“Formatting Facing Pages in a Section” on 
page 62

“Reusing Sections” on page 63

Viewing Thumbnails
Using thumbnail view is a good way to get an overview of your Pages document. 

Here are ways to view thumbnails:
To show the thumbnail view in a word processing document, click View in the toolbar mm

and choose Page Thumbnails. In a page layout document, thumbnails are displayed 
by default.

To hide the thumbnail view, click View in the toolbar and deselect Page Thumbnails.

To show facing pages in the thumbnail view, select Facing Pages in the Document mm

inspector’s Document pane.

To go to a specific page, click its thumbnail. The page appears in the main viewing area mm

and the page’s thumbnail is highlighted to indicate your place in the document.

You can also navigate to a page in a document by clicking the Page button in the 
lower left of the document window, typing the specific page number in the “Go to 
Page” field, and then pressing Return.

You can make the thumbnail view area wider and page thumbnails larger by adjusting 
the resize control located at the bottom right of the thumbnail column.

Adding and Deleting Sections
You can quickly add and delete sections in your Pages document using thumbnails. 

Here are ways to add and delete sections:
To delete a section and its contents, select the section in the thumbnail view, and press mm

the Delete key.
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A yellow box surrounds all the page thumbnails that are in the same section as the 
selected page.

To copy (or cut) and paste one or more sections, in the thumbnail view select the mm

sections you want to copy or cut and choose Edit > Copy or Edit > Cut.

Select the section after which you want to paste the sections, and then choose 
Edit > Paste.

You can also copy and paste one or more sections by Option-dragging selected 
sections to a new destination in the thumbnail view. As you drag, sections shift to 
make room for what you’re pasting.

To paste a copy of selected sections immediately following them, select the sections, mm

and then choose Edit > Duplicate.

Reorganizing Sections
Reorganize your Pages document effectively using thumbnails. 

Here are ways to reorganize sections:
To select one or more sections in the thumbnail view, click a page. A yellow box mm

surrounds all the page thumbnails that are in the same section as the selected page.

To select multiple adjacent sections, hold down the Shift key, and then select the first 
and last section you want.

You can also select multiple sections by dragging. Click to the left or right of a page 
thumbnail, and then drag up or down to select adjacent sections.

To move sections, select the sections, click a page thumbnail in one of the selected mm

sections, and then drag the sections to a new location in the thumbnail view. Sections 
shift to make room for your insertion as you drag.

Changing Headers and Footers in a Section
You can change headers and footers to be unique to a section. You can also change 
headers and footers within a section. 

To change headers and footers:
	 1	 Place the insertion point in the section.

	 2	 Click Inspector in the toolbar, click the Layout button, and then click Section.

	 3	 Deselect “Use previous headers and footers.”

	 4	 Type the new header or footer in the header or footer area of your document.

Restarting Page Numbering in a Section
You can start a new page-numbering scheme for a section. 



To restart page numbering in a document section:
Click in the section, select “Start at” in the Section pane of the Layout inspector, and mm

then specify the number of the first page of the section. 

Setting Up a Unique Format for a Section’s First Page
You can make the header, footer, and master objects different for the first page of  
a section. 

Make page numbering continuous 
with the previous section or enter a 
number to start renumbering pages.

Make headers and footers and master 
objects different on the first page or 
alternate pages, or continue from the 
previous section.

Make the new section begin on 
a left- or right-facing page.

Here are ways to make the first page of a section unique:
To make the headers and footers on the first page unique, click in the section, select mm

“First page is different” in the Section pane of the Layout inspector, and then change 
the header and footer, as “Using Headers and Footers” on page 54 describes.

To place a master object on the first page, follow the instructions in “mm Using Master 
Objects (Repeated Background Images)” on page 63.

Formatting Facing Pages in a Section
You can make headers, footers, master objects, and margins different on facing pages 
in a section. 

Click in the section to select it, and then format its facing pages. 

Here are ways to format facing pages in a selected section:
To put different headers and footers on alternate pages, select “Left and right pages mm

are different” in the Section pane of the Layout inspector.

To make the first page of the section always start on the left- or right-facing page, mm

choose Left Page or Right Page from the “Section starts on” pop-up menu. Otherwise, 
choose Any Page.

To place a master object on left or right pages, follow the instructions in “mm Using Master 
Objects (Repeated Background Images)” on page 63.
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To set different margins in different sections of your document, you must use the mm

Layout inspector and change the layout margins. To learn about setting layout 
margins, see “Defining Layout Margins” on page 52.

For more information about facing pages, see “Using Left- and Right-Facing Pages” on 
page 52.

Reusing Sections
You can make a section in a document reusable by adding it to the pop-up menu that 
appears when you click Pages in the toolbar. 

To reuse some or all of the pages in a section:
	 1	 Select the section in the thumbnail view. 

	 2	 Choose Format > Advanced > Capture Pages.

	 3	 In the dialog that appears, type a name for the page or pages, use the Include pop-up 
menu to indicate which pages you want to reuse, and then click OK.

The page or pages are available in the pop-up menu that appears when you click the 
Pages button in the toolbar.

Using Master Objects (Repeated Background Images)
You may want to add watermarks, logos, or other background images that appear in 
the same spot on every page of your word processing documents. These repeated 
graphics are called master objects.

If your document is divided into sections, you can put different master objects in each 
section. Within a section, you can put a different master object on the first page of the 
section and on right and left pages in the section. See “Setting Up a Unique Format 
for a Section’s First Page” on page 62 and “Formatting Facing Pages in a Section” on 
page 62 for more information.  

To add a master object to your word processing document:
	 1	 Add an object.

See “What Are Floating and Inline Objects?” on page 137 for information about 
floating objects.

	 2	 Position the object wherever you want it on the page.

	 3	 Choose Format > Advanced > “Move Object to Section Master,” and make sure that 
Format> Advanced > Make Master Objects Selectable does not have a checkmark  
next to it.

The selection handles disappear from the object, so you can no longer select it.



To edit or move a master object, you must first make master objects selectable for the 
entire document by choosing Format > Advanced > Make Master Objects Selectable 
if that option has no checkmark in front of it. Selectable master objects look different 
from other objects because they have blue selection handles.

Master objects have 
blue selection handles.

Using a Table of Contents
Using a Word Processing template, Pages can automatically generate a table 
of contents for your document. Many Word Processing templates come with a 
preformatted table of contents that you can add to your document. To add a table 
of contents to your document, see “Creating and Updating a Table of Contents” on 
page 64. 

To create a table of contents in a word processing document, you need to consistently 
use paragraph styles for headings in your document. To learn about styles, see “What 
Are Styles?” on page 123 and “Applying Styles” on page 125.

After you create a table of contents, you can format it to change its appearance. See 
“Styling a Table of Contents” on page 65 for more information.

Creating and Updating a Table of Contents
Each table of contents (TOC) you create using a Word Processing template lists only 
the content that follows it, up until the next table of contents. If you want a master 
table of contents for the entire document, it must be the only table of contents, and it 
must be at the beginning of the document. 

To update the TOC after editing a document, click any entry in the table of contents, or 
click Update Now in the TOC pane of the Document inspector. If you don’t update the 
table of contents after changing a document, it updates automatically when you close 
the document.

To create a table of contents:
	 1	 Click Inspector in the toolbar, click the Document button, and then click TOC.  
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	 2	 Select the checkboxes next to the paragraph styles whose text you want to appear 
in the table of contents. For example, if you want all the first-level headings and 
subheadings to appear in the table of contents, select the paragraph style that you 
used for first-level headings and subheadings.

Select the checkbox in the 
#’s column if you want page 
numbers to appear with 
each entry.

Click to update the table 
of contents after making 
changes to your document.

Select the paragraph 
styles whose text you 
want to appear in the 

table of contents.

Select to make all page numbers hyperlinks.

If the styles you select are not used anywhere in the document, you see a message 
that your table of contents is empty when you create the table of contents. If you 
select styles that are used very frequently in the document, your table of contents 
might be longer than you want.

	 3	 In the #’s column, select the checkboxes of those styles whose entries you want to 
include a page number.

	 4	 Place the insertion point at the beginning of the line where you want the table of 
contents to appear, and then choose Insert > “Table of Contents.”

If the Word Processing template you’re working with has a table of contents 
predefined for it, click in the page preceding where you want to insert the table of 
contents, click Sections in the toolbar, and then choose “Table of Contents.”

Styling a Table of Contents
You can change the look of text in the table of contents as you would any other text in 
a word processing document. You can also add a leader line between an entry and its 
associated page number, and you can create new TOC styles. 



To change the look of a table of contents entry:
	 1	 In the table of contents, select the entry type that you want to format, such as a first-

level heading. 

All entries of the same type are automatically selected. They cannot be  
individually selected.  

	 2	 To open the Styles drawer, click the Styles Drawer button in the format bar. 

Notice that the Styles drawer now displays a list of table of contents styles. The TOC 
style that corresponds to the selected entry is also selected.

When a table of contents 
entry is selected, the 
Styles drawer displays 
table of contents styles.

Click the arrow and 
choose whether to 
redefine the selected 
style, create a new style, 
or just rename it.

	 3	 To change the font attributes of the TOC heading, use the format bar controls. 

Other ways to change font attributes are the Fonts window, the Text inspector, and the 
Colors window.

	 4	 To create leader lines from an entry to its associated page number, select the TOC 
entry, click the tab in the Tab Stops column in the Tabs pane of the Text inspector, and 
then choose a line style from the Leader pop-up menu.

	 5	 To change the style in the Styles drawer to match the entry, click the arrow to the right 
of the style name and choose “Redefine Style from Selection.”

To create a new TOC style instead, click the arrow to the right of the style name and 
choose “Create New TOC Style from Selection,” and then type a name for the new 
style. You can also add a new style by clicking the Add (+) button at the bottom-left 
corner of the Styles drawer. In either case, type a name for the new style, and then 
select “Apply this new style on creation” if you want it to be applied immediately to the 
selected text.

	 6	 To rename the style in the Styles drawer, click the arrow next to the style name and 
choose Rename Style. Type a new name for the style.

Adding Citations and Bibliographies Using EndNote
Pages works with EndNote X2, software that lets you search and manage references 
and create bibliographies. To take advantage of these features, you must have 
EndNote X2 installed, and you must have assigned, in Endnote X2, a default library to 
open when EndNote X2 is opened. 
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Note:  If you downloaded Pages from the Mac App Store, you may need to install the 
Pages EndNote Plug-in. For details, please see the Knowledge Base article, Pages and 
EndNote Plug-in.

To add and edit a citation:
	 1	 Place the insertion point where you want the citation to appear in your document, and 

choose Insert > EndNote Citation.

EndNote X2 automatically opens, and the Find EndNote Citations window appears.

	 2	 Type text into the Find Citation field, and press Return to search your EndNote X2 
library for corresponding citations.

Narrow your search by clicking the magnifying glass in the Find Citation field and 
selecting a search option.

Sort the citations by clicking a column heading.

	 3	 Select the options for how the citations will appear in your document from the Find 
EndNote Citations window controls.

Select the Author or Year checkboxes to hide the author or year information in  
the citation.

Enter a page range in the Citation Range field to have the citation in the document 
display a page range.

Type text in the Prefix and Suffix fields that you want to appear before or after  
a citation.

Select “In Bibliography only” to add the citation to the bibliography, but not include it 
in the document.

	 4	 Select a citation from the list and click Insert. The citation is added to your document.

When you insert the first citation in your document, a bibliography is added at the end 
of your document. If your document already contains a bibliography, the bibliography 
is updated to include the new citation.

	 5	 To edit the format for citations and bibliographies, choose Edit > EndNote Citations > 
Bibliography Format, and select a bibliography style option.

You can also choose Edit > EndNote Citations > Manage Citations, and then select a 
bibliography style option from the Bibliography pop-up menu.

	 6	 To delete a citation in your document, select the citation and press Delete. 

You can also double-click the bibliography, select the citation in the Manage Citations 
window, and click Delete (–).

The citation is deleted from the document and the bibliography is updated.

http://support.apple.com/kb/TS3587
http://support.apple.com/kb/TS3587


	 7	 To delete a citation that appears only in the bibliography, choose Edit > EndNote 
Citations > Manage Citations. Select a citation in the Manage Citations window and 
click Delete (–).

The citation is deleted from the bibliography.

To add and edit a bibliography:
	 1	 Place the insertion point where you want the bibliography to appear in your 

document, and choose Insert > EndNote Bibliography.

	 2	 To edit a Bibliography, choose Edit > EndNote Citations > Bibliography, or double-click 
the Bibliography.

To change the citation and bibliography format, choose a format from the Bibliography 
pop-up menu. The bibliography format options are a set of default formats.

To update the bibliography format options, restart EndNote X2, and then restart Pages.

Note:  Only one automatically updating bibliography can exist in a document at a time. 
If a bibliography already exists in the document, an additional bibliography will be 
added as text only and won’t update when citations are added or deleted. To paste an 
automatically updating bibliography, first delete the existing bibliography, then paste.
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Use tracked changes, comments, and other Pages features 
that are useful when you review and revise documents.

Pages includes several features that are especially useful when you’re revising  
a document:

ÂÂ Track changes: View edits within a document until you decide which changes you 
want to accept or reject.

ÂÂ Comments: Like margin notes, they allow you to annotate a parts of a document 
without changing it.

ÂÂ Color and font changes: Draw attention to particular parts of a document by 
modifying color and font style. For example, color the background of several 
paragraphs orange, and then use a comment at the beginning of the document to 
ask reviewers to help complete the orange paragraphs.

This chapter focuses on tracked changes and comments. To learn about emphasizing 
text using color and font changes, see “Formatting Text Size and Appearance” on 
page 82. Instructions for using color appear in “Setting Character and Paragraph Fill 
Colors” on page 107.

4Reviewing and Revising 
Documents



Tracking Changes in Your Document
With tracked changes, you can monitor changes that you or others make to text, 
tables, floating objects, character format, or paragraph style. 

Use the tracking 
bar to manage and 
navigate changes to 
your document.

Tracked changes made 
to your document 

are highlighted in the 
page thumbnails.

Change bubbles flag edits 
made to your document.

When tracking changes, you can see:
Text that has been added, deleted, edited, or replaced in the document body, header, mm

footer, footnotes, shapes, text boxes, and table cells 

Tables, charts, and shapes that have been added or deleted inlinemm

Table cells with changes to cell type (text to number), number format (percent to mm

scientific), and cell format (cell opacity or cell background)

Table formulas and values that have been added, deleted, or editedmm

Floating objects that have been added, deleted, edited, moved, or resizedmm

Paragraph additions, deletions, or replacementsmm

Text with style changesmm

Character and paragraph formatting changesmm

New or deleted hyperlinks, Merge fields, placeholders, or bookmarksmm

An added or deleted table of contentsmm

Edits displayed in thumbnail viewmm

To learn about Go to

Starting, stopping, and pausing tracked changes “Controlling Tracked Changes” on page 72

Modifying author color, text markup, and more “Viewing Tracked Changes” on page 73

Tracking changes made to table cells “Tracking Changes in Table Cells” on page 74
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To learn about Go to

Choosing the changes you want to keep “Accepting and Rejecting Changes” on page 75

Saving a copy of your document without changes 
or comments

“Saving with Tracked Changes Off” on page 76

A Tour of Tracking Changes in a Document
The following scenario illustrates how to use tracked changes to consolidate and 
respond to changes that two reviewers, Anne and Tom, make to text in a document.

 
	 1	 With a document open, Tom turns on tracked changes by choosing  

Edit > Track Changes.

When tracked changes is on, the tracking bar is visible below the format bar.

Click to accept or reject 
selected changes.

Click arrow buttons to navigate 
between change bubbles.

Click to open the Markup 
View pop-up menu.

Click to open the 
Action menu.

Click to pause 
change tracking.

Choose how 
tracking bubbles 

are displayed.

Click to open and close the 
“Comments and Changes Pane.”

These controls help manage and navigate changes to your document. For more 
information about the tracking bar see, “Controlling Tracked Changes” on page 72.

	 2	 Tom saves the document without making changes, closes it, and emails it to Anne. This 
version of the document is the original version.

	 3	 Anne opens the document and changes some text.

Anne’s edits are displayed with change markup, and a change bar appears to the left 
of her edited text.

	 4	 To display tracking bubbles, Anne clicks View in the toolbar, and chooses “Show 
Comments and Changes Pane.”

	 5	 Anne saves the document, closes it, and emails it back to Tom.

	 6	 Tom opens the document and reads Anne’s edited version of the text.



In the following examples, you can see Tom’s original document and the edited version 
using tracked changes.

The document now displays the original text in black, and Anne’s edits appear in 
change markup.

Edited text is 
displayed in color.

Original text is 
displayed in black.

The change bubble displays 
author name, date and time, and 
type of edit.

	 7	 Tom decides he likes Anne’s revisions and clicks the checkmark in the tracking bubbles.

Click to accept changes.

Click to reject changes.

The tracking bubbles disappear. The text is no longer tracked as changed and the text 
is black.

See “Accepting and Rejecting Changes” on page 75 to learn other ways to accept and 
reject changes.

Controlling Tracked Changes
After you start tracking changes in a document, changes are tracked until you pause or 
stop tracking changes. 
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Here are ways to control tracked changes:
To start tracking changes, choose Edit > Track Changes. mm

When tracking is turned on, the tracking bar is displayed.

To pause tracking changes, click Paused in the tracking bar. To resume tracking, click mm

Tracking: On.

Pausing retains all previous changes, but doesn’t track any additional changes until 
you resume tracking.

To stop tracking changes, choose Edit > Turn Off Tracking.mm

You can also choose Turn Off Tracking from the Action menu in the tracking bar.

Select to stop 
tracking changes.

If your document has changes you haven’t yet accepted or rejected, a dialog asks you 
to cancel the operation or accept or reject the edits before continuing.

Viewing Tracked Changes
Show or hide tracking bubbles, select your author color, and more, with the tracking bar. 

Choose how edited text is 
displayed.

Here are ways to view tracked changes information:
To show or hide all tracking bubbles, click View in the toolbar, and choose “Show mm

Comments and Changes Pane” or “Hide Comments and Changes Pane.”

When the Comments and Changes pane is hidden, change bars appear next to edited 
portions of your document.

To show tracking bubbles for edits made to a specific section of text or an object, mm

select the text or object and choose “Show Only for Selection” from the Tracking 
Bubbles pop-up menu. Only the tracking bubbles associated with the selected text or 
object are displayed.

Choose how tracking 
bubbles are displayed.



To show or hide tracking bubbles for formatting edits (for example, changing text mm

from bold to italic), choose Show Formatting Bubbles from the Tracking Bubbles pop-
up menu.

To view your document using thumbnails, click the View button on the toolbar, and mm

then choose Page Thumbnails.

Tracked changes made to your document are highlighted in the page thumbnails.

To show text markup, choose View Markup from the View Markup pop-up menu. mm

When text markup is visible, edits in your document are displayed with the author 
color per markup preferences.

To hide deleted text and other deleted objects, choose View Markup Without mm

Deletions from the View Markup pop-up menu.

When deleted text and objects are hidden, a deletion indicator is displayed on the page.

When deleted text edits are visible in your document, the text deletions are displayed 
with a strikethrough.

To hide all text markup, deleted text and objects, choose View Final from the View mm

Markup pop-up menu.

To change your author name, or inserted and deleted text markup style, and deleted mm

text style, choose Preferences from the Action menu.

To choose a different author color for yourself, choose Author Color from the Action mm

menu on the tracking bar.

Tracking Changes in Table Cells
Track the changes made to cell content such as text, formulas, and inline images. You 
can also track changes to cell attributes such as the cell format, background, or opacity. 

Changes that involve adding, removing, and moving rows or columns aren’t tracked. 
In addition, changes to a cell’s borders, merging and splitting cells, and autofilling 
aren’t tracked.

Information about tracked changes is displayed and can be viewed at all times, or only 
when a change or a cell containing a change is selected.

To track changes in table cells:
	 1	 Choose Edit > Track Changes. 

The tracking bar is displayed.

	 2	 Select one or more table cells and edit the cell contents.

Table cells with tracked changes are marked with an indicator in the upper-right 
corner of the cell, in the author’s assigned color.

If multiple authors have made changes to a table cell, the cell’s indicator color is gray. 
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	 3	 To show tracking bubbles, choose View > “Show Comments and Changes Pane,” and 
then choose Show All from the Tracking Bubbles pop-up menu.

To view tracking bubbles only for one or more edited table cells, choose “Show Only 
for Selection” from the Tracking Bubbles pop-up menu, and select one or more table 
cells marked with an indicator.

Accepting and Rejecting Changes
You can accept or reject edits made to text and objects in your Pages document. 

Control-click changed text or objects to quickly accept or reject edits.

Here are ways of accepting or rejecting tracked changes:
To accept a single change, select the edited text and click the Accept button in the mm

tracking bubble or click Accept in the tracking bar. 

To reject a single change, select the edited text and click the Reject button in the mm

tracking bubble or click Reject in the tracking bar.

To accept all changes, choose Accept All Changes from the Action menu.mm

To reject all changes, choose Reject All Changes from the Action menu.mm

To accept multiple changes at once, select the text or table cells containing changes mm

you want to keep, and then click the Accept button in the tracking bar.

To reject multiple changes at once, select the text or table cells containing changes mm

you don’t want, and then click the Reject button in the tracking bar.

To select changes for review one at a time, click the up or down arrow buttons in the mm

tracking bar.

Click the arrow buttons to navigate 
between change bubbles.

Select change bubbles to review 
edits made to your document.



Saving with Tracked Changes Off
Save a “clean” copy of your document with tracked changes turned off and 
comments removed.

Saving a copy of your document with tracked changes turned off is useful when you 
want a version with all the changes accepted. For example, you want to continue to 
track changes, but want to send a “clean” copy to a reviewer so that the reviewer can’t 
see the original document content.

Select to save a “clean” 
copy of your document.

To save a document with tracked changes off:
With tracked changes on, choose “Save a Copy as Final” from the Action menu in the mm

tracking bar.

All editing changes made to this version of your document are accepted and all 
comments are removed.

Using Comments
With comments, you can annotate a document or parts of it without changing the 
document. Comments are useful for making notes to yourself, asking questions of 
reviewers, conveying editorial suggestions, and so on. 

Identify the part of the document a comment applies to by placing an insertion point 
or by selecting words or objects. The part of the document associated with a comment 
is called the comment anchor.

Click Comment to add a 
comment to your document.

Comments are displayed in the 
Comments pane and are anchored 
to part of the document.
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Here are ways to manage comments:
To add comments to your document, select some text or an object, and click mm

Comment in the toolbar or choose Insert > Comment. 

In the comment bubble that appears, type your comment. The size of the comment 
bubble resizes to accommodate your text.

To add a comment to a table cell, select the cell and click Comment in the toolbar, or mm

choose Insert > Comment. Type in the comment bubble.

To change a comment, click in the comment bubble and edit it just as you would text mm

and objects elsewhere in your document. 

You can use character and paragraph styles to modify the appearance of text  
in comments. 

To delete a comment, click the Delete button in the right corner of the comment bubble. mm

Click to delete the comment.

To view comments, click the View button in the toolbar, and then choose  mm

Show Comments. 

If comments are not visible, inserting one displays all comments. 

To view comments when you are tracking changes, choose View > “Show Comments mm

and Changes Pane.” 

To hide comments, click the View button, and then choose Hide Comments.mm

To print comments, choose File > Print while comments are visible. Printed pages are mm

adjusted to make room for the comments.

If comments are hidden, they won’t appear on the printed pages.
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Add and modify the appearance of text, including lists, in 
text boxes, table cells, and shapes.

Understanding Text
Add text by typing in a blank word processing document, replacing placeholder text, 
using text boxes and lists, placing text in shapes, and more.

To learn about working with placeholder text in templates and merge fields, see ÂÂ
“Using Placeholder Text” on page 78 and “What Are Merge Fields?” on page 246. 

To add different text styles, or create your own, see “ÂÂ What Are Styles?” on page 123.

To learn how to add new template pages, see “ÂÂ Adding New Template Pages” on 
page 80.

To delete pages from your document, see “ÂÂ Deleting Pages” on page 80.

To learn how to delete, copy, and paste text, see “ÂÂ Deleting, Copying, and Pasting 
Text” on page 81.

To add text to a text box or shape, see “ÂÂ Using Text Boxes, Shapes, and Other Effects 
to Highlight Text” on page 104.

To add text that’s formatted as a list, see “ÂÂ Creating Lists” on page 100.

To learn how to add text to table cells, see “ÂÂ Working with Text in Table Cells” on 
page 192.

Using Placeholder Text
Templates contain placeholder text, which shows you what text will look like and 
where it will be placed in the finished document. Most placeholder text appears 
in Latin (for example, lorem ipsum) in the document body, text boxes, headers, and 
elsewhere. Other predefined text, such as the title of a newsletter, appears in the 
language you’re using. 
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You click to select the placeholder text and then type your own text to replace it. The 
text you type keeps the same style and formatting as the placeholder text. If you don’t 
want to use the style and size of fonts the placeholder text uses, you can change the 
selected text by clicking the font family and font size controls in the format bar. 

Here are ways to work with placeholder text:
To add text in a main text area, click the placeholder text to highlight it, and then start mm

typing to replace it with your own text. 

When you click placeholder text in a document template, the entire text area is 
highlighted.

Placeholder text
The entire text area is 
selected when you click.

To add text inside a text box, click once to select the text box, click to select the text mm

inside the box, and begin typing. 

Text boxes are displayed when layout view is turned on. To turn layout view on, click 
View in the toolbar and choose Show Layout.

To add text to a table with placeholder text, click once to select the table, double-click mm

to select an individual cell and its placeholder text, and begin typing.  

You can also add text to table cells that don’t contain placeholder text. See “Working 
with Text in Table Cells” on page 192 for instructions.

To add text to a column, click the placeholder text in the column and begin typing. mm

You may find it easier to work with text columns if the document layout is visible. To 
show the document layout, click View in the toolbar and choose Show Layout.



Text box and table placeholder text are part of a template’s default design. To preserve 
the design, be careful not to press Delete after you select the text box or table or you’ll 
remove the placeholder from the page. If you accidentally delete a text box or table, 
press Command-Z (the shortcut for Undo).

Adding New Template Pages
Each page of a Pages template has a unique design. You can choose to use the page 
design shown when the document first opens. Or, if the page design doesn’t meet 
your needs, you can choose from additional pages designed to fit the template. 

Adding new template pages lets you quickly add pages that already contain text, 
images, tables, charts, or other formatting options you want to use. 

To add a new template page:
	 1	 Click in the section you want the new page to follow.

A section is a group of one or more pages that have the same layout, numbering, and 
other document attributes. A chapter is an example of a section.

	 2	 Click the Sections (Word Processing template) or Pages (Page Layout template) button 
in the toolbar, and choose a page type to add to your document.

Choose additional pages 
from the Sections or 
Pages pop-up menu.

See “Creating Sections” on page 59 for more information about working with sections.

Deleting Pages
There are several techniques for deleting entire pages. 

To delete a page in a word processing document, do the following:
To remove a page without deleting other pages in its section, delete all the text and mm

objects on the page. 

To delete a section and all the pages in it, click View in the toolbar, and then choose mm

Page Thumbnails. Select the section in the thumbnail view and press Delete. Pages 
confirms which pages will be deleted. Click Delete.

You can also delete a section by clicking in a paragraph in the section and choosing mm

Edit > Delete Page. Pages confirms which pages will be deleted. Click Delete.
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For more information about sections, see “Adding and Deleting Sections” on page 60.

To delete a page in a page layout document:
Click View and choose Page Thumbnails. Select the page or pages in the thumbnail mm

view you wish to remove, and press Delete. After Pages confirms which pages will be 
removed from your document, click Delete.

Selecting Text
Before you format or perform other operations on text, you need to select the text you 
want to work with. 

Here are ways to select text:
To select one or more characters, click in front of the first character and drag across the mm

characters you want to select. 

To select a word, double-click the word.mm

To select a paragraph, triple-click in the paragraph.mm

To select all text in a document, choose Edit > Select All.mm

To select blocks of text, click the start of a text block, and then click the end of another mm

text block while holding down the Shift key.

To select from the insertion point to the beginning of the paragraph, press the Up mm

Arrow key while holding down the Shift and Option keys.

To select from the insertion point to the end of the paragraph, press the Down Arrow mm

key while holding down the Shift and Option keys.

To extend the selection one character at a time, press the Left Arrow or Right Arrow mm

key while holding down the Shift key.

To extend the selection one line at a time, press the Up Arrow or Down Arrow key mm

while holding down the Shift key.

To select multiple words or blocks of text that are not next to each other, select the mm

first block of text you want, and then select additional text while holding down the 
Command key.

Deleting, Copying, and Pasting Text
The Edit menu contains commands for text editing operations. 

Here are ways to edit text:
To copy (or cut) and paste text, select the text and choose Edit > Copy or Edit > Cut. mm

Click where you want to paste the text.  

To have the copied text retain its style formatting, choose Edit > Paste.



To have the copied text take on the style formatting of the text around it, 
choose Edit > “Paste and Match Style.”

To delete text, select the text and choose Edit > Delete or press the Delete key.mm

If you accidentally delete text, choose Edit > Undo to restore it.

When you use the Copy or Cut command, the selected text is placed in a holding area 
called the Clipboard, where it remains until you choose Copy or Cut again or you turn 
off your computer. The Clipboard holds the contents of only one copy or cut operation 
at a time.

To avoid unintentionally changing a document’s format by removing formatting 
characters in addition to text, it’s a good idea to display formatting characters 
(invisibles) before cutting or deleting text. To show invisibles, click View in the toolbar, 
and then click Show Invisibles.

Formatting Text Size and Appearance
You can format text using the format bar, the Pages menus, the Text inspector, and the 
Fonts window. 

To learn about Go to

Changing text appearance “Making Text Bold, Italic, or Underlined” on 
page 83

“Adding Shadow and Strikethrough to Text” on 
page 83

“Creating Outlined Text” on page 84

“Changing Text Size” on page 84

“Making Text Subscript or Superscript” on 
page 85

“Changing Text Capitalization” on page 85

“Changing Fonts ” on page 86

“Adjusting Font Smoothing” on page 86

Adding accent marks, viewing international 
keyboard layouts, and more

“Adding Accent Marks” on page 87

“Viewing Keyboard Layouts for Other 
Languages” on page 87

“Typing Special Characters and Symbols” on 
page 88

“Using Smart Quotes” on page 89

Adjusting tracking, ligatures, baseline, and 
capitalization

“Using Advanced Typography Features” on 
page 89
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Making Text Bold, Italic, or Underlined
The format bar, Format menu, and the Fonts window make changing the 
appearance of text quick and easy. When text is selected, you can make text bold or 
italic or underlined.

Here are ways to make text bold, italic, or underlined:
To use the format bar, select some text or click where you want to type new text, and mm

then use the format bar controls to change text appearance.

Set color of text. Set text background color.

Change font typeface, 
style, and size.

Make text bold, italic, or 
underlined.

Many templates include an underline character style. To display the character styles 
defined for your document, click the Character Styles button in the format bar. Select 
the text you want to underline, and then choose the underline character style from the 
character styles displayed.

To use the Format menu, select some text, or click where you want to type new text, mm

and choose Format > Font > Bold, Italic, or Underline. 

To use the Fonts window, click Fonts in the toolbar, and then use controls in the Fonts mm

window to make text bold, italic, or underlined.

Create interesting 
text effects using 

these buttons.

The Action menu

Choose a typeface to 
apply to selected text.

Find fonts by typing a font 
name in the search field.

Choose a font size to 
apply to selected text.

Apply a shadow to 
selected text. Modify 
the shadow using the 
opacity, blur, offset, 
and angle controls.

Preview the selected 
typeface (you might need to 

choose Show Preview from 
the Action menu).

If you don’t see the text effect buttons, choose Show Effects from the Action pop-up 
menu in the lower-left corner of the Fonts window.

Adding Shadow and Strikethrough to Text
You can use the Fonts window to create and format shadows on text and mark text 
with a strikethrough line. 



Here are ways to add a strikethrough and shadows:
To add a strikethrough to selected text, click Fonts in the toolbar, click the Text mm

Strikethrough button, and choose None, Single, or Double from the pop-up menu. 

Or select text, and choose Format > Font > Strikethrough.

A strikethrough appears through the selected text in the same color as the text. To 
change the strikethrough color, choose Color from the Text Strikethrough pop-up 
menu, and then select a color in the Colors window. The strikethrough takes on the 
color you selected, but the text retains its original color.

To add a shadow to selected text, click Fonts in the toolbar, and then click the Text mm

Shadow button. 

Drag the shadow opacity slider (the first slider on the left) to the right to make the 
shadow darker.

Drag the shadow blur slider (the middle slider) to the right to make the shadow 
more diffuse.

Drag the shadow offset slider (the third slider) to the right to separate the shadow 
from the text.

Rotate the Shadow Angle wheel to set the direction of the shadow. 

To set text shadows using the Graphic inspector, see “mm Adding Shadows” on page 168 
for more information.

Many templates include a strikethrough character style. To display the character styles 
defined for your document, click the Character Styles button in the format bar. You 
can also select the text you want to strike through, and then choose the strikethrough 
character style in the Styles drawer.

Creating Outlined Text
You can change text to appear as a stenciled outline.

To create outlined text:
	 1	 Select the text you want to appear outlined, or click where you want to type new text. 

	 2	 Choose Format > Font > Outline.

Outlined text you create in Pages may look different if the document is opened in 
another application. If you plan to share a document that contains outlined text with 
people who don’t have Pages installed on their computers, export the document as a 
PDF file and then share this file with others.

Changing Text Size
You can change the point size of text to make the text larger or smaller. 

	 84		  Chapter 5    Working with Text



	 Chapter 5    Working with Text	 85

To change the size of selected text:
	 1	 Select the text you want to resize.

	 2	 To change the text size in 1-point increments, choose Format > Font > Bigger. Or 
choose Format > Font > Smaller.

To specify a precise size for selected text, click Fonts in the toolbar and use the Size 
controls in the Fonts window. See “Changing Fonts ” on page 86 for more information.

Making Text Subscript or Superscript
You can raise or lower text from its baseline. 

To make text subscript or superscript:
	 1	 Select the text you want to raise or lower, or click where you want to type new text.

	 2	 To create a subscript or superscript that has a smaller font size than the text 
it accompanies, choose Format > Font > Baseline > Subscript. Or choose 
Format > Font > Baseline > Superscript. 

To raise or lower text relative to the other text on the same line, choose Raise or Lower 
from the Baseline submenu. 

To restore text to the same baseline as the body text, choose Use Default from the 
Baseline submenu.

To specify a precise amount to raise or lower text, use the Text inspector. Click 
Inspector in the toolbar, click Text, click More, and then use the Baseline Shift controls.

You can add Subscript and Superscript icons to the toolbar. Choose View > Customize 
Toolbar, drag the icons to the toolbar, and then click Done.

Changing Text Capitalization
You can quickly make blocks of text all uppercase or lowercase or format text as a title. 

To change text capitalization: 
	 1	 Select the text you want to change, or click where you want to type new text. 

	 2	 Choose Format > Font > Capitalization and choose an option from the submenu.

All Caps:  Choose to change the text to capitals.

Small Caps:  Choose to change the text to smaller capitals with larger capitals for 
uppercase letters.

Title:  Choose to change the text to a title format, which capitalizes the first letter of 
each word.

None:  Choose to change text from all capitals to initial caps. For example, the  
first character in the first word of a sentence is capitalized, but the rest of the text  
is lowercase.



Changing Fonts 
When text is selected, quickly change font family, type, size, color, and background 
color using the controls in the format bar. 

The Fonts window gives you extensive control over fonts. Use size controls and 
typography settings to customize the appearance of your text.

To modify the font of selected text:
	 1	 Click Fonts in the toolbar.

	 2	 In the Fonts window, select a font style in the Family column, and then select the 
typeface in the Typeface column.

If you don’t see all the font families you know are installed on your computer, select All 
Fonts in the Collections column or type the name of the font you are looking for in the 
search field at the bottom of the Fonts window.

A preview of the selected font appears in the preview pane at the top of the Fonts 
window. If you don’t see a preview pane, choose Show Preview from the Action pop-
up menu in the lower-left corner of the Fonts window.

	 3	 Adjust the font size using the size slider or other size controls.

	 4	 Adjust the typography settings of the selected font by choosing Typography from the 
Action pop-up menu. In the Typography window, click the disclosure triangles to see 
and select the different typography effects that are available for the selected font.

Different fonts have different typography effects available. See “Using Advanced 
Typography Features” on page 89 for more information.

Adjusting Font Smoothing
If the fonts on your screen look fuzzy, blurry, or jagged, you may want to adjust the 
font smoothing style or change the text size at which Mac OS X starts to smooth 
fonts. Fonts may also be distorted when exporting to a PDF file. You can adjust font 
smoothing settings to smooth the fonts exported to PDF files.

To smooth the fonts on your screen:
	 1	 Open System Preferences and click Appearance.

	 2	 To turn on font smoothing in Mac OS X v10.6 or later, select “Use LCD font smoothing 
when available.”

To specify a font smoothing style in Mac OS X v10.5.7 or earlier, choose a font 
smoothing style from the “Font smoothing style” pop-up menu.

Depending on the type of display you have, you may notice only small or no 
differences between smoothing styles.

	 3	 If you plan to use small font sizes in your document, choose a point size from the “Turn 
off text smoothing for font sizes” pop-up menu. 
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When text smoothing (“antialiasing”) is on, smaller fonts can be harder to read so you 
may want to turn it off for smaller font sizes.

To learn more about font smoothing in Mac OS X, click the Help button in the lower-
right corner of the Appearance preferences window.

Adding Accent Marks
You can use the Keyboard Viewer to add accent marks to characters. The Keyboard 
Viewer shows the characters for the keyboard layout or input method selected in the 
Input menu. For example, if U.S. is chosen in the Input menu, you see the characters 
that appear on a U.S. keyboard in the Keyboard Viewer.

To add accent marks:
	 1	 Choose Show Keyboard Viewer from the Input menu on the right side of the menu bar.

The Input menu appears on the right side of your menu bar and looks like a flag or 
character. If you don't see the Input menu, go to “Viewing Keyboard Layouts for Other 
Languages” on page 87 for instructions on viewing the Input menu.

	 2	 Press Shift, Option, or Option-Shift to highlight the available accent marks in the 
Keyboard Viewer.

The accent mark keys are highlighted. Depending on your keyboard, you may not 
need to press any of the modifier keys to see the accent keys.

	 3	 Place the insertion point in your document where you want to type.

	 4	 Press the modifier key you pressed in step 2 (Shift, Option, Option-Shift, or none) and 
then press the key on your keyboard that is in the same place as the accent you see in 
the Keyboard Viewer.

	 5	 Release the modifier key, and then press the key for the character you want to accent.

For example, on a U.S. keyboard, to make é appear, press Option and E (the accent key), 
and then press E (the letter on which you want that accent to appear).

Viewing Keyboard Layouts for Other Languages
The Keyboard Viewer shows the characters for the keyboard layout or input method 
that is selected in the Input menu. For example, if U.S. is chosen in the Input menu, you 
see the characters that appear on a U.S. keyboard in the Keyboard Viewer.

You can use the Keyboard Viewer to see where characters are located on keyboards 
used for other languages if you have those fonts installed.

To access the Keyboard Viewer, the Input menu must be visible in the menu bar.

To show the Input menu:
	 1	 Choose Apple > System Preferences and do one of the following:



For Mac OS X 10.6 or later, click Language & Text, then click Input Sources, and then ÂÂ
select the checkbox next to Keyboard & Character Viewer.

For Mac OS X 10.5.7 and earlier, click International, then click Input Menu, and then ÂÂ
select the checkbox next to Keyboard Viewer.

The Input menu appears on the right side of your menu bar and looks like a flag 
or character.

	 2	 Select the checkbox next to a country's keyboard layout or input method to see the 
character layout on keyboards used in that country.

	 3	 Select the checkbox next to “Show input menu in menu bar.”

To see the keyboard layout for another language:
	 1	 Choose a language or input method from the Input menu that appears on the right 

side of the menu bar.

	 2	 Choose Show Keyboard Viewer from the Input menu.

	 3	 Press keys on your keyboard to see their location on the Keyboard Viewer. Press 
Option, Shift, and Command-Option to see accents and special characters.

	 4	 To place a character at the insertion point of your document, click the key for that 
character on the Keyboard Viewer.

Typing Special Characters and Symbols
Using the Mac OS X Characters window, you can insert special characters, such as 
mathematical symbols, letters with accent marks, arrows and other “dingbats,” and 
more. You can also use this palette to enter Japanese, Traditional Chinese, Simplified 
Chinese, and Korean characters, as well as characters from other languages. 

To insert special characters or symbols:
	 1	 Place the insertion point where you want the special character or symbol to appear.  

	 2	 Choose Edit > Special Characters to open the Characters window (or choose Characters 
from the Action pop-up menu in the lower-left corner of the Fonts window).

	 3	 Choose the type of characters you want to see from the View pop-up menu at the 
top of the Characters window. If you don’t see the View menu, click the button in the 
upper-right corner of the window to show the top portion of the window. Click this 
button again to hide the top portion of the window.

	 4	 Click an item in the list on the left to see the characters that are available in  
each category.

	 5	 Double-click the character or symbol on the right that you want to insert into your 
document, or select the character and click Insert.

If the character or symbol has variations, they appear at the bottom of the window 
when you click the Character Info triangle or Font Variation triangle at the bottom of 
the palette. Double-click one to insert it in your document.
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If the character doesn’t appear in your document, Pages may not support that character.

Using Smart Quotes
Smart quotes are opening and closing quotation marks that are curly; the opening 
quotation marks are different from the closing marks. When you don’t use smart 
quotes, the marks are straight and the opening and closing marks don’t differ. 

Smart Quotes

Straight Quotes

To use smart quotes:
Choose Pages > Preferences, click Auto-Correction, and then select “Use smart quotes.”  mm

Using Advanced Typography Features
Some fonts, such as Zapfino and Hoefler, have advanced typography features, which 
let you create different effects. If you are using a font in a text box that has different 
typography effects available, you can change many of the effects in the Font submenu 
of the Format menu. For example, you may be able to adjust the following: 

Tracking:  Place characters closer together or farther apart.

Ligature:  Use or leave out stylish flourishes between letters or at the end or beginning 
of lines that combine two or more text characters into one glyph. 

Ligature not used

Ligature used

In the Ligature submenu, choose Use Default to use ligature settings specified in the 
Typography window for the font you’re using. Choose Use None to turn off ligatures 
for selected text, or choose Use All to turn on additional ligatures for the selected text.

Advanced typography features are available in the Typography window. 

To open the Typography window:
	 1	 Click Fonts in the toolbar. 

	 2	 In the Fonts window, choose Typography from the Action pop-up menu (in the lower-
left corner).

To enable ligatures for an entire document, Click Inspector in the toolbar, click the 
Document button, click Document, and then select “Use ligatures.” To turn off ligatures 
for a specific paragraph, click in the paragraph, open the Text inspector, click More, and 
then select “Remove ligatures.”



Setting Text Alignment, Spacing, and Color
The primary tools for adjusting text attributes are the format bar and the Text 
inspector. You can make some horizontal alignment adjustments (such as centering 
text or aligning it on the left) by using the Format menu.

Color and alignment controls are also available on the format bar when text is 
selected. When text in a text box, comment, or shape is selected, you can set the color 
of text and its background, align text, and set line spacing.  

To learn about Go to

Aligning text “Aligning Text Horizontally” on page 90

“Aligning Text Vertically” on page 91

Adjusting text spacing “Setting the Spacing Between Lines of Text” on 
page 91

“Setting the Spacing Before or After a 
Paragraph” on page 92

“Adjusting the Spacing Between Characters” on 
page 93

Adjusting text color “Changing Text Color” on page 93

Aligning Text Horizontally
You can change the alignment of paragraphs in a page, column, table cell, text box, or 
shape so that text is aligned to the left or right border, centered, or aligned on both 
left and right (justified). 

Use the Alignment buttons in the format bar to quickly change the alignment of text 
in your document. To change the alignment of text, select the text, and then click the 
Alignment buttons in the format bar.

Align text horizontally.

Align text vertically.

To align text left, center, right, or justified using the Text inspector:
	 1	 Select the text you want to change.

	 2	 Click Inspector in the toolbar, click the Text button, and then click Text.

	 3	 Click one of the five horizontal alignment buttons, located to the right of the color 
well. From left to right, these buttons have the following effects.

Align Left:  Places each line of text against the left margin of the object.

Center:  Sets the center of each line of text at the center of the object.

Align Right:  Sets each line of text against the right margin of the object.
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Justify:  Spaces characters in each line so that the lines reach both the left and right 
margins of the object.

Auto Align Table Cell:  Left-justifies text and right-justifies numbers in a table cell.

The first four alignment buttons are available on the format bar when text is selected. 
The fifth horizontal alignment button is also available on the format bar when a table 
cell is selected.

You can also align text horizontally by choosing Format > Text > Align Left, Center, 
Align Right, Justify, or Auto Align Table Cell.

If you want to indent the first line of text in a paragraph or learn how to remove 
paragraph indenting, see “Setting Indents” on page 97.

Aligning Text Vertically
You can change the vertical alignment of paragraphs in a table cell, text box, or 
shape so that text is aligned to the top or bottom border or centered between top 
and bottom. 

To align text to the top, center, or bottom of a text box, table cell, or shape:
	 1	 Select the text box, table cell, or shape whose alignment you want to change.

	 2	 Click Inspector in the toolbar, click the Text button, and then click Text.

	 3	 Click one of the three vertical alignment buttons to align text to the top, middle, or 
bottom of the table cell, text box, or shape.

The vertical alignment buttons are also available on the format bar when you’re 
working with a table cell.

Setting the Spacing Between Lines of Text
You can increase or decrease the distance between lines of text. 

Use the Line Spacing control in the format bar to quickly change the distance between 
lines of text. To adjust line spacing before you start typing, click the Line Spacing 
control in the format bar. 

To change the line spacing for existing text, select the text, then change the spacing 
using the Line Spacing control in the format bar.

Click to change the amount of 
space between lines of text.

To adjust spacing using the Text inspector:
	 1	  Select the text you want to change.

	 2	 Click Inspector in the toolbar, click the Text button, and then click Text.

	 3	 Move the Line slider left to decrease spacing or right to increase it.



To specify a precise line spacing value, type a point value in the Line field, or click the 
up or down arrow next to the field.

	 4	 Choose a line spacing option from the Line spacing pop-up menu that appears when 
you click the text below the line field.

Line spacing pop-up menu
Click the text below the Line field 
and choose a line spacing option.

Line field
Type a value (or click the arrows) to specify the 
space between lines of text in a paragraph.

Standard line spacing (Single, Double, Multiple):  The space between lines is 
proportional to font size. Use this when the relative distance between ascenders 
(parts of letters that extend to the top of the line) and descenders (parts of letters that 
extend below the line) should remain fixed. Single sets line spacing to single-spaced, 
and Double sets it to double-spaced. Multiple lets you set line spacing values between 
single and double, or greater than double.

At Least:  The distance from one line to the next will never be less than the value you 
set, but it may be larger for larger fonts to prevent overlapping text lines. Use this 
when the distance between lines should remain fixed, but overlap is not desired if the 
text gets large.

Exactly:  The distance between the baselines.

Between:  The value you set increases the space between the lines, instead of 
increasing the height of the lines. By contrast, double-spacing doubles the height of 
each line.

Setting the Spacing Before or After a Paragraph
You can increase or decrease the spacing before or after paragraphs. 

Use the Line Spacing control in the format bar to quickly change the distance before 
or after paragraphs. To adjust spacing before or after paragraphs, select the text, and 
then click the Line Spacing control in the format bar. 

To adjust the amount of space before or after a paragraph:
	 1	 Select the paragraphs you want to change.

	 2	 Click Inspector in the toolbar, click the Text button, and then click Text.

	 3	 Drag the Before Paragraph or After Paragraph slider. You can also specify a precise 
value (5 pt, for example) in the text boxes.
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If the Before Paragraph or After Paragraph values for adjacent paragraphs aren’t equal, 
the higher spacing value will be used. For example, if the current paragraph’s Before 
Paragraph value is 12 points and the paragraph preceding it has an After Paragraph 
value of 14 points, the spacing between paragraphs will be 14 points.

Spacing before a paragraph does not appear if the paragraph is the paragraph in a 
text box, shape, or table cell.

To set spacing around text in boxes, shapes, and table cells, use the Inset Margin 
control, described in “Changing the Inset Margin of Text in Objects” on page 98.

Adjusting the Spacing Between Characters
You can increase or decrease the amount of space between characters. 

To adjust the amount of space between characters:
	 1	 Select the text you want to change, or click where you want to type new text. 

	 2	 Click Inspector in the toolbar, click the Text button, and then click Text.

	 3	 Drag the Character slider or specify a new percentage in the Character field.

You can also adjust the space between selected characters by choosing 
Format > Font > Tracking and choosing an option from the submenu.

Changing Text Color
You can change text color by using the format bar, the Text inspector, and the Fonts 
window. Changes you make with any of these tools override color changes already 
made with the other tools. 

Here are ways to change text color:
Click the Text Color well in the format bar. In the color matrix that appears, select a mm

color by clicking it, or click Show Colors to open the Colors window for additional 
color options.

Click Inspector in the toolbar, click the Text button, click Text, and then click the color mm

well. The Colors window opens.

Click Fonts in the toolbar, click the Document Color button in the Fonts window (the mm

fourth button from the left), and then select a color in the Colors window.

“The Colors Window” on page 26 provides instructions for using the Colors window.



Setting Tab Stops to Align Text
You can align text at specific points by setting tab stops in a document, text box, table 
cell, or shape. When you press the Tab key (or Option-Tab when you’re working in a 
table cell), the insertion point (and any text to the right of it) moves to the next tab 
stop, and text you type starts at that point. You can use the symbols on the horizontal 
ruler or the Text inspector to manage tab stops.

To learn about Go to

Adding a new tab stop “Setting a New Tab Stop” on page 94

Changing the location and type of tab stops “Changing a Tab Stop” on page 95

Removing a tab stop “Deleting a Tab Stop” on page 96

Changing the distance between tab stops “Setting the Default Distance Between Tabs” on 
page 96

Adjusting ruler preferences “Changing Ruler Settings” on page 96

Setting a New Tab Stop
You can use the horizontal ruler or the Text inspector to add a new tab stop. 

If the horizontal ruler is hidden, click View in the toolbar and choose Show Rulers. To 
learn more about adjusting your ruler preferences see “Changing Ruler Settings” on 
page 96.

Blue tab symbols appear on 
the horizontal ruler when you 
select tabbed text.

Decimal tab

Right tab

Center tab

Left tab

Here are ways to create a new tab stop:
To create a new tab stop using the horizontal ruler, click the horizontal ruler to place a mm

tab symbol where you want to set the tab stop, and then Control-click the tab symbol. 
Choose an alignment option from the shortcut menu.

Choose from among 
these tab types.

You can also double-click the tab symbol repeatedly until the type of tab you  
want appears.
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To create a new tab stop using the Text inspector, click in the document where you mm

want to create a new tab stop, click Inspector in the toolbar, and then click Tabs. Click 
the Add (+) button in the bottom-left corner of the Tabs pane. The new tab stop 
appears in the Tab Stops column.

If you want to indent a paragraph 
relative to the page margins, 
specify how far to indent it.

Set the default distance 
between tabs.

For a tab stop selected in the 
Tab Stops column, select how 
you want the text to align.

Choose a leader line for 
any tab stop selected in 
the Tab Stops column.

Add or remove tab stops from 
the column.

Set how far you want 
the first line of each 

paragraph to indent.

Type a new character 
to change the character 

used for decimal tabs.

To align text at the tab stop, select the tab stop, and then select an alignment option:

Left Tab:  Aligns the left side of text with the tab stop.

Center Tab:  Places the center of text at the tab stop.

Right Tab:  Aligns the right side of text with the tab stop.

Decimal Tab:  For numbers, aligns the decimal character (such as a period or comma) 
with the tab stop.

To change the tab stop location, double-click the tab stop in the Tab Stops column 
and type a new value.

To specify a decimal tab character for the document, type a new character in the 
Decimal Tab Character field.

To add a dashed or dotted line to the tab, choose a line style from the Leader pop-up 
menu. Otherwise, choose None.

Changing a Tab Stop
Change the location and type of tab stops using the horizontal ruler and the Text 
inspector. If the horizontal ruler is hidden, click View in the toolbar and choose Show 
Rulers. To learn more about adjusting your ruler preferences see “Changing Ruler 
Settings” on page 96. 

You can also change the decimal tab character for a document using the Text inspector.



Here are ways to change tab stops:
To move a tab stop, drag its blue tab symbol in the horizontal ruler.mm

To change the tab to a different type using the horizontal ruler, Control-click the tab mm

symbol, and choose an option from the shortcut menu. Or double-click the tab symbol 
in the ruler repeatedly until the type of tab you want appears.

To change a tab stop using the Text inspector, click Inspector in the toolbar, click the mm

Text button, and then click Tabs.

To change the tab stop location, double-click the tab stop in the Tab Stops column 
and type a new value.

To change the tab to a different type, select an Alignment option.

To change the decimal tab character for the document, type a new character in the 
Decimal Tab Character field.

To change the leader line setting, choose an option from the Leader pop-up menu.

To change the default spacing between tabs, use the Default Tabs field.

Deleting a Tab Stop
You can quickly remove a tab stop using the horizontal ruler or the Text inspector. 

Here are ways to delete a tab stop:
To delete a tab stop, drag the tab off the horizontal ruler.mm

If the horizontal ruler is hidden, click View in the toolbar and choose Show Rulers.

To delete a tab stop using the Text inspector, click Inspector in the toolbar, click the mm

Text button, and then click Tabs. Select the tab stop you want to delete in the Tab 
Stops column, and then click the Delete (–) button.

Setting the Default Distance Between Tabs
Although the default distance between tab stops is usually a half-inch, you can change 
the distance using the Text inspector. 

To change how far apart tabs are by default:
	 1	 Click Inspector in the toolbar, click the Text button, and then click Tabs.

	 2	 Use the Default Tabs field to set the default distance between tabs.

Changing Ruler Settings
You can quickly change your ruler settings in Pages Preferences. 

Here are ways to work with rulers:
To change the units of measure in the rulers, choose Pages > Preferences, click Rulers, mm

and choose an item from the Ruler Units pop-up menu.
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To display measurements as a percentage of the distance across the page, choose mm

Pages > Preferences, click Rulers, and then select “Display ruler units as percentage.”

To place the ruler’s horizontal origin point at the center of the page, choose  mm

Pages > Preferences, click Rulers, and then select “Place origin at center of ruler.”

To display the vertical ruler in a word processing document, choose  mm

Pages > Preferences, click Rulers, and then select “Enable vertical ruler in word 
processing documents.”

When you change ruler settings in Pages preferences, the new settings apply to all 
documents viewed in Pages until you change the settings again.

Setting Indents
You can modify the amount of space between the edge of a paragraph and the 
document margins. You can also adjust the amount of space between text and the 
inside border of a text box, shape, or table cell. 

To learn about Go to

Changing indentation “Setting Indents for Paragraphs” on page 97

Adjusting the space between text and the inside 
border of objects

“Changing the Inset Margin of Text in Objects” on 
page 98

Setting Indents for Paragraphs
You can use the horizontal ruler and the Text inspector to set indents for paragraphs. 

Here are ways to set indents:
To change indentation using the horizontal ruler, drag the indentation controls.mm

First-line indentation

Left indentation Right indentation

To change the right indent, drag the right indent symbol (downward blue triangle on 
the right side of the horizontal ruler) to the position where you want the right edge of 
the paragraph to end.

To change the left indent, drag the left indent symbol (downward blue triangle on the 
left side of the ruler) to where you want the left edge of the paragraph to begin. 

To change the left margin independently from the left indent, hold down the Option 
key as you drag.

To change indentation of the first line, drag the first line indent (blue rectangle) to 
where you want the first line of each paragraph to start. 



If you want the first line to remain flush with the left margin, make sure the rectangle 
aligns with the left indent symbol. 

To create a hanging indent, drag the rectangle to the left of the left indent symbol.

To set indents using the Text inspector, click Inspector in the toolbar, click the Text mm

button, and then click Tabs. Select the paragraph or paragraphs you want to change.

To set the first line indent (or overhang), specify values in the First Line and Left fields 
under Paragraph Indents. 

If you want the first line to be indented relative to the second line of text, the First Line 
value should be higher than the value in the Left field. 

If you want the first line to overhang the left side of the paragraph margin, the value in 
the First Line field should be lower than the value in the Left field.

To set off a paragraph using indentation (as when you want to include a long 
quotation in your text), enter a value in the Left field and the Right field under 
Paragraph Indents.

Changing the Inset Margin of Text in Objects
You can change the amount of space between text and the inside border of a text box, 
shape, or table cell. This measurement is called the inset margin. The amount of space 
you specify is applied equally around the text on all sides. 

To set the spacing between text and the inside border of its object:
	 1	 If there’s no insertion point in the object, select the object. (If the insertion point is 

inside the object, press Command-Return to get out of text editing mode and select 
the object.) 

	 2	 Click Inspector in the toolbar, click the Text button, and then click Text.

	 3	 Drag the Inset Margin slider to the right to increase the space between text and the 
inside border of the object, or type a number in the Inset Margin box and press Return. 
You can also click the arrows to increase and decrease space.

Specify how much space you 
want around text inside a text 
box, shape, or table cell.

Creating an Outline
In a word processing document, you can create an outline of topics and subtopics 
that’s easy to organize and view in different ways. If you already have a word 
processing document you want to turn into an outline, just click Outline in the toolbar. 
Or choose an outline template from the Template Chooser.
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To create and organize an outline:
	 1	 In a word processing document, click Outline in the toolbar or choose View > Show 

Document Outline, and then begin typing.

	 2	 Press Return to add a new outline topic.

If a topic’s text is too lengthy, click the truncation button in the format bar to display 
only the first line.

Choose the number of 
outline levels to display.

Show only the first line of 
paragraphs in an outline.

Show objects as thumbnails 
or actual size in an outline.

	 3	 Press Tab to add a subtopic. Press Return to add another subtopic.

Indent subtopics up to nine levels by pressing Tab or clicking the Promote and 
Demote buttons in the format bar.

Click to promote or demote 
outline topics or convert 
selected text to body text.

Choose paragraph and character 
styles for selected text.

	 4	 Add inline images, tables, and movies to outline topics and subtopics. To display an 
image or movie at a smaller size, choose Thumbnail from the pop-up menu in the 
format bar.

When images, tables, and movies are full size, they are editable.

	 5	 Double-click an Outline control to expand or collapse all the subtopics of a topic at 
that level.

Choose how many levels of your outline are displayed using the Levels pop-up menu 
in the format bar.

	 6	 Click an Outline control and drag it to rearrange topics and subtopics.

Drag Outline controls up or down to reorder topics within the same outline level.

Drag Outline controls left or right to promote or demote topics or subtopics to a 
different outline level.



When you move a topic, all of its subtopics move with it.

Drag outline controls to move topics and related 
subtopics in an outline, or double-click controls 
to expand or collapse outline  topics.

	 7	 To exit outline mode, click Outline in the toolbar or choose  
View > Hide Document Outline.

For information about saving your document in outline mode, see “Saving a Document 
in Outline Mode” on page 42.

The Outline controls don’t appear on printed documents. To add numbers or bullets to 
your outline, click the Styles drawer button in the format bar, and select one of the List 
style options.

Creating Lists
When you use automatic list generation, Pages automatically formats a list for you 
based on what you type. To use this feature, first choose Pages > Preferences, click 
Auto-Correction, and make sure that “Automatically detect lists” is selected. 

Pages provides preformatted bullet and numbering styles for creating simple 
or ordered lists. Bulleted and numbered lists are simple lists without the nested 
hierarchies of information like those you might see in an outline. 

To create a list:
	 1	 Place the insertion point where you want the list to begin.

	 2	 Create a list.

To create a bulleted list, press Option-8 to type a bullet (•) or a hyphen (-), a space, 
and some text, and then press Return. To learn how to format your bulleted list see 
“Formatting Bulleted Lists” on page 101.

To create a list with labels that are asterisks (*) or hyphens (-), type an asterisk or a 
hyphen, a space, and some text, and then press Return. 

To create a list with labels that are numbers, letters, or Roman numerals, type the 
number, letter, or Roman numeral; a period; a space; and some text. Then press Return. 
To learn how to format your numbered or ordered list see “Formatting Numbered 
Lists” on page 102 and “Formatting Ordered Lists” on page 103.

	 3	 To add a new topic at the current indent level, press Return.
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To move a list topic to the next lower indent level, press Tab. To move a list topic to the 
next higher level, press Shift-Tab.

To change the list level of a list topic and its subtopics, select the list topic and choose 
Format > Text, and then choose Decrease List Indent Level or Increase List Indent Level 
from the Text submenu.

To change the list level of a list topic, press Option and select the list topic, choose 
Format > Text, and then choose Decrease List Indent Level Ignoring Children or 
Increase List Indent Level Ignoring Children from the Text submenu. Only the selected 
list topic is moved.

	 4	 To end your list, press Return twice, or press Return and then press Delete.

Note:  If you’re working in a table cell and “Return key moves to next cell” is selected in 
the Table inspector, press Option-Return instead of Return.

Use these other techniques to add and indent items in your list:

To create an unbulleted or unnumbered paragraph within a topic, press Return ÂÂ
while holding down the Shift key. If you’re working in a table cell and “Return key 
moves to next cell” is selected in the Table inspector, press Control-Return instead.

To enter a new topic at the next lower indent level, click and hold a bullet or ÂÂ
number, and then drag to the right, to the left, down and to the right, or down and 
to the left.

If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table inspector, use the Indent Level controls in the List pane of the Text inspector 
to increase or decrease the indentation of list entries.

To return to regular text at the end of your list, press Return and choose No Bullets ÂÂ
from the Bullets & Numbering pop-up menu in the Text inspector. You may also 
need to adjust the indent level.

To add an existing paragraph to a numbered or ordered list, click the paragraph, ÂÂ
choose a numbering style, and click “Continue from previous.”

To start a new numbered sequence in a numbered or ordered list, click “Start at” and ÂÂ
specify the number you want the sequence to begin with.

To learn about modifying list styles, see “Modifying a Tiered List Style for Ordered 
Lists” on page 131 and “Modifying Bulleted or Numbered List Styles” on page 132.

Formatting Bulleted Lists
Although you can use automatic list generation to create a simple bulleted list, using 
the Text inspector gives you many options for formatting bulleted lists. See “Creating 
Lists” on page 100 for information about creating a list automatically. 



You can also add a bulleted list style by using the List button in the format bar. Place 
the insertion point where you want the list to begin, click the List button in the format 
bar, and then select Bullet.  

To format the bullets in a list:
	 1	 Place the insertion point where you want the list to begin. 

	 2	 Click Inspector in the toolbar, click the Text button, and then click List.

	 3	 Choose a bullet style from the Bullets & Numbering pop-up menu.

To use a typed character as a bullet, choose Text Bullets and choose a character from 
the list or type a new character in the field.

To use one of the image bullets that comes with Pages, choose Image Bullets and 
choose an image from the scrolling list.

To use your own image as a bullet, choose Custom Image and choose an image in the 
Open dialog that appears.

	 4	 To change the size of an image bullet, specify a percentage of the original image size 
in the Size field. Or, select the “Scale with text” checkbox and specify a percentage of 
the text size; this option maintains the image-to-text size ratio of the bullets even if 
you later change the font size of the text.

	 5	 To adjust the space between bullets and the left margin, use the Bullet Indent field. To 
adjust the space between bullets and text, use the Text Indent field.

	 6	 To position bullets higher or lower relative to text, use the Align field.

To learn more about formatting different list types, see “Formatting Numbered Lists” on 
page 102 and “Formatting Ordered Lists” on page 103.

To learn about modifying list styles or creating your own list style, see “Modifying a 
Tiered List Style for Ordered Lists” on page 131, “Modifying Bulleted or Numbered List 
Styles” on page 132, and “Creating New Styles” on page 126.

Formatting Numbered Lists
Although you can use automatic list generation to create a simple numbered list, using 
the Text inspector gives you many options for formatting numbered lists. See “Creating 
Lists” on page 100 for information about creating a list automatically. 

You can also choose a numbered list style in the Styles drawer. Click the Styles Drawer 
button in the format bar, and then select the list style. If you don’t see list styles in the 
Styles drawer, click the button in the lower-right corner of the drawer to make the 
styles appear.  

Here are ways to format a numbered list:
Place the insertion point where you want the list to begin, click the List button in the mm

format bar, and then choose Numbered List.
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Place the insertion point where you want the list to begin, click Inspector in the mm

toolbar, click the Text button, and then click List. Choose Numbers from the Bullets & 
Numbering pop-up menu, and then choose a numbering style from the pop-up menu 
directly below it.

To adjust the space between numbers and the left margin, use the Number Indent 
field. To adjust the space between numbers and text, use the Text Indent field.

To learn more formatting different list types, see “Formatting Bulleted Lists” on 
page 101 and “Formatting Ordered Lists” on page 103.

To learn about modifying list styles or creating your own list style, see “Modifying a 
Tiered List Style for Ordered Lists” on page 131, “Modifying Bulleted or Numbered List 
Styles” on page 132, and “Creating New Styles” on page 126.

Formatting Ordered Lists
Ordered lists provide different numbering styles for each indent level in a list, allowing 
you to create a hierarchy of information. For example: 

You can create a list using a numbering sequence as you proceed from the highest ÂÂ
level to lower levels: I, A, 1, a), (1), (a), i), (1), and (a).

You can create a legal list style, which appends an additional number or letter at ÂÂ
each lower level: 1, 1.1, 1.1.1, and so on.

You can also choose an ordered list style in the Styles drawer. Click the Styles Drawer 
button in the format bar, and then select the list style. If you don’t see list styles in the 
Styles drawer, click the List Styles button in the lower-right corner of the drawer to 
make the styles appear. 

To format an ordered list:
	 1	 Place the insertion point where you want the list to begin.

	 2	 Click Inspector in the toolbar, click the Text button, and then click List.

	 3	 To create a legal style list, choose Tiered Numbers from the Bullets & Numbering pop-
up menu. Otherwise, choose Numbers.

	 4	 Choose a numbering style from the pop-up menu directly below.

	 5	 To adjust the space between numbers and the left margin, use the Number Indent 
field. To adjust the space between numbers and text, use the Text Indent field.

To learn more about creating lists and formatting different list types, see “Creating 
Lists” on page 100, “Formatting Bulleted Lists” on page 101, and “Formatting Numbered 
Lists” on page 102.

To learn about modifying list styles or creating your own list style, see “Modifying a 
Tiered List Style for Ordered Lists” on page 131, “Modifying Bulleted or Numbered List 
Styles” on page 132, and “Creating New Styles” on page 126.



Using Text Boxes, Shapes, and Other Effects to Highlight Text
Callouts and sidebars are used to make text stand out from the main body of text in a 
document. Pages offers many ways to emphasize text:

Adding text to text boxes  ÂÂ

Adding a background (or ÂÂ fill color) to paragraphs

Adding borders and rules to textÂÂ

Formatting text in columnsÂÂ

Typing text in shapesÂÂ

You can also use table cells to hold callouts. To read about working with tables, see 
“Working with Tables” on page 176.

To learn about Go to

Adding and linking text boxes “Adding a Floating Text Box” on page 104

“Adding an Inline Text Box” on page 105

“Linking Floating Text Boxes” on page 106

Emphasizing text with color, borders, and rules “Setting Character and Paragraph Fill Colors” on 
page 107

“Adding Borders and Rules” on page 108

Adding text to columns or shapes “Presenting Text in Columns” on page 108

“Putting Text Inside a Shape” on page 109

Adding a Floating Text Box
When you add a text box as a floating text box, it’s anchored to a position on the page 
so that body text on the page flows around it. You can move the floating text box by 
selecting it and dragging it. 

To create a floating text box:
	 1	 Click Text Box in the toolbar.

A text box appears on the page. 

In a word processing document, you can also create a floating text box by converting 
an inline text box. Choose Insert > Text Box; an inline text box appears. Click the inline 
text box to select it, and then click the Floating button in the format bar.

	 2	 In the text box, double-click the highlighted placeholder text and type.

	 3	 Drag the selection handles to resize the text box and reveal any hidden text. (Or you 
can create linked text boxes so that the text flows continuously into another text box.)

To read about linked text boxes, see “Linking Floating Text Boxes” on page 106.

	 4	 When you’ve finished typing, click outside the text box. Or, to stop editing text and 
select the text box, press Command-Return.
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When you click away from a text box, its boundaries are visible only if you’re  
using layout view. To use layout view, click View in the toolbar, and then choose Show 
Layout.

	 5	 Drag the handles on the text box to change its width.

	 6	 Drag the text box to position it where you want it on the page.

	 7	 To lock the text box to the page so it doesn’t accidentally get moved as you work, 
select the text box and choose Arrange > Lock.

You can also draw a floating text box. Option-click Text Box in the toolbar, release the 
Option key, and drag the crosshair pointer across the document window to create a 
text box that’s the size you want.

To learn about changing the spacing between the text and the inside of the text box, 
see “Changing the Inset Margin of Text in Objects” on page 98.

Adding an Inline Text Box
In a word processing document, you can add an inline text box that is anchored to 
text on the page. 

To add an inline text box:
	 1	 In a word processing document, place the insertion point where you want the text box 

to appear, and choose Insert > Text Box.

An inline text box appears at the insertion point on the page. 

You can also create an inline text box by converting a floating text box. Click the Text 
Box button in the toolbar; a floating text box appears. Click the floating text box to 
select it, and then click the Inline button in the format bar.

	 2	 In the text box, double-click the highlighted placeholder text and type. 

The text box does not grow automatically if you enter too much text.

When you click away from a text box, its boundaries are visible only if you’re using 
layout view. To use layout view, click View in the toolbar, and then choose Show Layout.

	 3	 Drag the selection handles to resize the text box and reveal any hidden text.

The selection handles on the top and the left of inline text boxes are inactive. You can’t 
drag these handles to resize the text box; you resize it by dragging the active handles, 
which are solid white.

	 4	 Drag the text box to position it on the page. When the insertion point is where you 
want to place the text box, release the mouse.

To learn about changing the spacing between the text and the inside of the text box, 
see “Changing the Inset Margin of Text in Objects” on page 98.



Linking Floating Text Boxes
If the text you type doesn’t fit in a floating text box, you can create a linked text box 
so that the text flows from one text box to another. Whenever you edit or format the 
text in the first text box, the linked text box is also affected. Linked text boxes can be 
positioned separate from each other in the document. 

Here are ways to work with linked text boxes:
To create a floating text box, see “mm Adding a Floating Text Box” on page 104.

Position and resize the text box as you want, and then type text in it. 

When the text box is full, a clipping indicator appears at the bottom of the text box. 
This indicates that the text extends beyond the bottom of the box.

A clipping indicator shows 
the text extends beyond the 
text box.

Click the blue square on the 
right to link to another text 
box or create a new linked 
text box.

A blue square on the 
left indicates there are 

no text boxes linked 
before this one.

To link to another text box or create a linked text box, click the blue square on the mm

right side of the text box, and click another text box or click somewhere on the page 
(or choose Format > Text Box > Add Linked Text Box). To cancel linking, press Escape.

The new text box has a solid blue square on its left side. This indicates that this text 
box is linked to a previous one.

A solid blue square on 
the right indicates this 
text box is linked before 
another one.

A blue square indicates 
this text box is the last in 
this series.

A solid blue square on 
the left indicates this 
text box is linked to a 

previous one.

To link selected text boxes, Command-click to select the text boxes you want to link, mm

and then choose Format > Text Box > Link Selected Text Boxes. The text boxes are 
linked in the order in which you selected them.

To break the connection between linked text boxes, choose Format > Text Box > “Break mm

Connection into Text Box,” or choose Format > Text Box > “Break Connection out of 
Text Box.”
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To hide connection lines between text boxes, choose Format > Text Box > Hide mm

Connection Lines. To display connection lines between text boxes, choose Format > 
Text Box > Show Connection Lines.

To reposition the text boxes, select and drag them. The flow of the text inside the mm

boxes always follows the order in which the boxes were created, regardless of where 
you position them in the document.

To copy and paste linked text boxes, select all of them, choose Edit > Copy, and choose mm

Edit > Paste without deselecting the original text boxes. The copy is pasted directly 
over the original text boxes and is selected. Drag the selected copy to its new location.

If you copy and paste a single linked box, you will create a single unlinked text box, 
identical to the one you copied.

If a single table flows through linked text boxes, you must copy or duplicate the first 
text box in which the table appears in order to copy the table as well.

To select only the text in all the linked text boxes, select text in the first box, and then mm

press Command-A.

Setting Character and Paragraph Fill Colors
For some designs, you may want to highlight text by placing a fill color behind the 
text. When you place a character or paragraph fill color behind text, the color extends 
between the layout margins and moves with the text. 

Use the format bar controls to quickly add character or paragraph fill color to text. 
Select the text, and then click the Text or Background color well in the format bar. 

Here are ways to place a character or paragraph fill color behind text:
To use the Text inspector to add character or paragraph fill color, select the text, click mm

Inspector in the toolbar, click the Text button, and then click More. Select the Character 
or Paragraph checkbox below Background Fills, and then click the Fill color well and 
select a color in the Colors window.

Select a fill color.

Select to place a fill 
color behind text.

To use the Fonts window to add character or paragraph fill color, click Fonts in the mm

toolbar, click the Document Color button in the Fonts window (the fourth button from 
the left), and then select a color in the Colors window.

For information about the Colors window, see “The Colors Window” on page 26.



Adding Borders and Rules
Place a line above, below, or around the text in your document. Use borders and rules 
to highlight text. 

To add borders and rules to your document:
	 1	 Select the text to which you want to add borders and rules.

	 2	 Click Inspector in the toolbar, click the Text button, and then click More.

	 3	 Choose a border or rule line style (or None) from the Borders & Rules pop-up menu.

	 4	 To change the border or rule color, click the color well and select a color.

	 5	 To adjust the thickness of a border or rule, use the controls to the right of the color well.

	 6	 To insert a rule above, below, or above and below selected text, click the buttons 
under the Borders & Rules pop-up menu.

	 7	 To insert a border around selected text, click the border button under the Borders & 
Rules pop-up menu.

Click to change line color.

Click to adjust the 
thickness of a line.

Click to adjust the 
distance between 
borders and rules 
and selected text.

Click to insert a 
border around 
selected text.

Click to position rule 
with selected text.

Select a line style.

	 8	 To adjust the distance between borders or rules and selected text, use the  
Offset controls.

Presenting Text in Columns
You can organize text in a text box or a rectangular shape into columns. When text has 
filled one column, it flows into the next column. 

Use the Columns pop-up menu in the format bar to quickly divide text into columns in 
your document.

For more options, use the Layout inspector.
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To create and format columns using the Layout inspector:
	 1	 Select the text box or rectangular shape with text you want to divide into columns.

	 2	 Click Inspector in the toolbar, click the Layout button, and then click Layout.

	 3	 To indicate how many columns you want, use the Column field.

	 4	 To use equal-width columns, select “Equal column width.”

To set up different column widths, deselect “Equal column width,” double-click a 
Column value in the table, and type a new width.

	 5	 To change the distance between columns, double-click a Gutter value and change it.

Putting Text Inside a Shape
All shapes, except lines, can contain text. 

To add text to a shape:
	 1	 Place a shape where you want it on the page. 

To learn about adding shapes, see “Adding a Predrawn Shape” on page 146 and 
“Adding a Custom Shape” on page 146. 

	 2	 Double-click the shape and type the text you want. 

If the text extends beyond the border of the shape, a clipping indicator appears.

The clipping indicator 
shows that text 
extends beyond the 
borders of a shape.

	 3	 To resize the shape, select it and drag the selection handles. (If the insertion point is 
inside the shape, press Command-Return to get out of text editing mode and select 
the shape.)

You can format the text within a shape. You can also rotate a shape while keeping its 
text horizontal. After rotating the shape, choose Format > Shape > “Reset Text and 
Object Handles.”

	 4	 To add text to a shape that’s part of a group, double-click in the text area of any shape 
in the group. 

If you resize the group, everything resizes except for the text. Of course, you can still 
select text and change its font size.

See “Grouping and Ungrouping Floating Objects” on page 163 for details about 
grouping objects.



Using Hyperlinks and Bookmarks
Hyperlinks and bookmarks are used in documents that will be viewed onscreen, either 
as HTML files or as Pages documents. You can add hyperlinks to jump to another page 
or to open an email message or a webpage on the Internet. Use bookmarks to mark 
passages in the document that you want to refer to as you work. 

To learn about Go to

Using a webpage hyperlink to go to a web 
browser

“Linking to a Webpage” on page 110

Linking to a new email message with the 
specified subject and addressee

“Linking to a Preaddressed Email Message” on 
page 111

Using a bookmark hyperlink to go to another 
page in the same document

“Linking to Other Pages in a Document” on 
page 111

Creating a hyperlink to another Pages document “Linking to Another Pages Document” on 
page 112

Changing an existing hyperlink “Editing Hyperlink Text” on page 113

Linking to a Webpage
You can add a hyperlink that opens a webpage in your default web browser. 

To add hypertext that opens a webpage:
	 1	 Select the text that you want to turn into a hyperlink.

If you use text that starts with “www” or “http,” the text automatically becomes a 
hyperlink. To turn off this feature, choose Pages > Preferences, click Auto-Correction, 
and deselect “Automatically detect email and web addresses.” This setting is computer 
specific, so if the document is opened on a computer with a different setting, that 
computer’s setting is used instead.

	 2	 Click Inspector in the toolbar, click the Link button, click Hyperlink, and then select 
“Enable as a hyperlink.”

	 3	 Choose Webpage from the Link To pop-up menu.

	 4	 Type the webpage’s address in the URL field.

Type the URL that you want 
to link to.

The Link inspector button

Select to disable all 
hyperlinks so that you 

can easily edit them.
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You can also quickly create a hyperlink using the Insert menu. Place the insertion point 
somewhere in your document, and choose Insert > Hyperlink > Webpage. A link is 
added to your document and the Link inspector opens. Type the webpage’s address in 
the URL field.

Linking to a Preaddressed Email Message
You can add a hyperlink that you can click to create a preaddressed email message in 
your default mail application. 

To add hypertext that links to an email message:
	 1	 Select the text that you want to turn into a hyperlink.  

If you include an email address in a document, the text automatically becomes a 
hyperlink. To turn off this feature, choose Pages > Preferences, click Auto-Correction, 
and then deselect “Automatically detect email and web addresses.” This setting is 
computer specific, so if the document is opened on a computer with a different 
setting, that computer’s setting is used instead.

	 2	 Click Inspector in the toolbar, click the Link button, click Hyperlink, and then select 
“Enable as a hyperlink.”

	 3	 Choose Email Message from the Link To pop-up menu.

	 4	 Type the email address of the intended recipient in the To field.

	 5	 Optionally type a subject line in the Subject field.

Type the email address of 
the message recipient.

Type the message subject.

You can also quickly create a hyperlink using the Insert menu. Place an insertion point 
somewhere in your document, and choose Insert > Hyperlink > Email Message. A link 
is added to your document and the Link inspector opens. Type type the email address 
in the To field.

Linking to Other Pages in a Document
To make accessing specific pages in a document fast, you can add bookmarks and click 
a bookmark in the Link inspector to go to the bookmarked page. You can also add 
hypertext that links to the bookmarked page. 



Here are ways to use bookmarks in your document:
To create a bookmark, select the text you want to turn into a bookmark. Click Inspector mm

in the toolbar, click the Link button, click Bookmark, and then click Add (+).  

Click Name or Page to sort the 
bookmark list.

Click a bookmark to jump to it 
in the document; double-click 
it to edit its name.

Click Add or Delete to 
add new bookmarks 

or delete a bookmark 
selected in the list.

To jump to the bookmark in the document, click a bookmark in the list.mm

To change a bookmark’s name, double-click the bookmark in the list and make  mm

the change.

To sort bookmarks by name or page number, click the Name or Page column header.mm

To add new bookmarks, click the Add (+) button.mm

To delete a bookmark, select the bookmark in the list and click the Delete (–) button.mm

To add a hyperlink that links to a bookmark, select the text you want to turn into mm

the hyperlink, click Hyperlink in the Link inspector, select the “Enable as a hyperlink” 
checkbox, choose Bookmark from the Link To pop-up menu, and then choose the 
bookmark name.

Choose the 
bookmark name.

You can also quickly create a hyperlink using the Insert menu. Place an insertion point 
somewhere in your document, and choose Insert > Hyperlink > Bookmark. A link is 
added to your document and the Link inspector opens.

Linking to Another Pages Document
Create bookmarks to another Pages document using the Link inspector. 
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To link to another Pages document:
	 1	 Select the text that you want to turn into a hyperlink.

	 2	 Click Inspector in the toolbar, click the Link button, click Hyperlink, and then select 
“Enable as a hyperlink.”

	 3	 Choose Pages Document from the Link To pop-up menu.

	 4	 Click Choose, select the Pages document you wish to link to, and then click Open.

	 5	 If you’d like to link to a specific bookmark in the Pages document, choose a bookmark 
of the Pages document you are linking to from the Bookmark pop-up menu.

Editing Hyperlink Text
There are several ways to edit hyperlink text. 

Here are ways to edit hyperlink text:
To deactivate hyperlinks so that they can be edited without following the link, click mm

Inspector in the toolbar, click the Link inspector, click Hyperlink, select “Make all 
hyperlinks inactive,” and then edit text normally. 

Click outside the hyperlink text, and use the arrow keys to move the insertion point mm

into the text.

Wrapping Text Around an Inline or Floating Object
When you place an object (an image, shape, chart, and so on), you can decide how 
you want the text to wrap around it. You can choose to make the text hug the object 
tightly or loosely, or make the text stay only above and below or on one side of the 
object. To set these options, use the Wrap inspector.



You cannot wrap text around the sides of a table. 

The Wrap inspector button

Select to wrap text 
around the object using 

the buttons below.

Set the transparency percentage at which 
text can be seen through the object.

Set how much space to leave between 
the object and the surrounding text.

Click to make the text 
wrap tightly or loosely 
around the object.

Select to place an object inline with text, 
floating on the page, or in a fixed location.

Select to make 
background 

objects editable.

Here are ways to wrap text around floating and inline objects:
To wrap text using the format bar, select the object, and choose a text wrap option mm

from the Wrap pop-up menu in the format bar.

To wrap text using the Wrap inspector, select the object, click Inspector in the toolbar, mm

click the Wrap button, and then select “Object causes wrap.”

Floating object:  Click the text wrap button that shows the way you want text to wrap 
around a floating object. 

Text wraps around only right 
or left side, whichever side has 
more space.

Text wraps above and 
below the object.

Text wraps to right of object.

Text wraps to 
left of object.

Text wraps around 
the object.
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Inline object:  Click the text wrap button that shows the way you want text to wrap 
around an inline object.

Object is centered 
between lines of text.

Align objects to the right,
and wrap text around the left.

Object is aligned right 
between lines of text.

Center object, and 
wrap text around 

both sides.

Align object to the 
left, and wrap text 

around the right.

Object is aligned left 
between lines of text.

You can also use the Wrap inspector to adjust text around an inline or floating 
object. See “Adjusting Text Around an Inline or Floating Object” on page 115 for  
more information.

Adjusting Text Around an Inline or Floating Object
Use the Wrap inspector to adjust text around an inline or floating object.

Here are ways to adjust text around an inline or floating object:
To make the text wrap more tightly around an object with an alpha channel, click the mm

right Text Fit button. To make the text wrap more loosely, click the left Text Fit button.

To specify the minimum space you want to leave between the object and the mm

surrounding text, enter a value in the Extra Space field.

To set the alpha-channel percentage at which you want the text to appear through mm

the transparency, see “Removing the Background or Unwanted Elements from an 
Image” on page 143.

Text wraps more tightly around an 
object with an alpha channel.

Text wraps around the 
rectangular bounds of 

an object.

Adding Page Numbers and Other Changeable Values
You can insert values such as page numbers, page count, filename and pathname, and 
date and time in a document by using formatted text fields, which are automatically 
updated by Pages when these values change. Although values such as these are 
common in headers and footers (see “Using Headers and Footers” on page 54), you can 
insert formatted text fields anywhere in your document. 



Here are ways to insert formatted text fields:
To automatically add and format page numbers, choose Insert > Auto Page Numbers. mm

Choose where the page numbers will appear in the entire document or the current 
section, and then choose the page number alignment and format options.

To specify whether you want a page number displayed on the first page, select 
“Include number on first page.”

To add page numbers, place the insertion point where you want the page number to mm

appear, and then choose Insert > Page Number.  

To change the page number format, Control-click a page number and choose a new 
number format.

To add the total page count, place the insertion point where you want the page count mm

to appear, and then choose Insert > Page Count.

To include the total page count with each page number, such as “2 of 10,” add a page 
number, type “of,” and then choose Insert > Page Count.

To change the page count format, Control-click a page count and choose a new 
number format.

To add and format the date and time, place the insertion point where you want the mm

value to appear, and then choose Insert > Date & Time.

To change the date and time format, Control-click the date and time value, choose Edit 
Date & Time, and then choose a date and time format from the pop-up menu. If you 
want the document to always show the current date and time, select “Automatically 
update on open.”

To add the document filename, place the insertion point where you want the filename mm

to appear, and choose Insert > Filename.

To display the file directory path, double-click the filename and select “Show 
directory path.”

To display the file extension, double-click the filename and select “Always show 
filename extension.”

Using Automatic Hyphenation
By default, Pages automatically hyphenates words if they need to break at the end  
of a line. 

Here are ways to turn hyphenation on or off:
To turn hyphenation on or off for the entire document, click Inspector in the mm

toolbar, click the Document button, and then select or deselect Hyphenate (in the 
Document pane).
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To turn off hyphenation for a particular paragraph, select the paragraph, click Inspector mm

in the toolbar, click the Text button, click More, and then select “Remove hyphenation 
for paragraph.”

To turn hyphenation on or off for a word, click the word while holding down the mm

Control key, and then choose Never Hyphenate or Allow Hyphenation from the 
shortcut menu.

Turning hyphenation on or off for a word will affect every instance of that word in 
your document.

Automatically Substituting Text
Pages can be set to recognize and replace text you don’t want with text you do want. 
For example, when you type “teh,” Pages can automatically change it to “the.” 

To set up automatic text substitution:
	 1	 Choose Pages > Preferences. 

	 2	 Click Auto-Correction and make settings as desired. 

Use smart quotes:  Automatically convert single and double quotation marks to smart 
(“curly”) quotes so that opening and closing quotation marks are not identical.

Fix capitalization:  The first word in a sentence begins with a uppercase letter.

Superscript numerical suffixes:  Automatically convert the letters in “1st,” “2nd,” “3rd,” 
and so on into superscripts.

Automatically detect email and web addresses:  Set Pages to automatically detect 
that something you’ve typed is an email address or a URL. Email and web addresses 
you type automatically become hyperlinks for Mail or Safari.

Automatically detect lists:  Use automatic list generation.

Automatically use spell checker suggestions:  Automatically replace misspelled words 
if there is only one option in the spelling dictionary.

Symbol and text substitution:  Replace one or more characters with one or more 
different characters, and then use the rows in the table to define and activate specific 
substitutions. For example, when you type (c), you can have Pages automatically 
convert it to © by putting a checkmark in the On column. To add a row to the table to 
define your own substitution, click the Add (+) button. To remove a selected item, click 
the Delete (–) button.

After you specify substitution settings, they’ll apply to any text you change or add in 
any Pages document.



Inserting a Nonbreaking Space
You can insert a nonbreaking space between words to make sure that the words 
always appear in the same line of text. 

To insert a nonbreaking space:
Press the Space bar while holding down the Option key.mm

Checking for Misspelled Words
You can set the spell checker to flag spelling errors as you type, or you can check your 
entire document or selected text at any time. 

Misspelled words appear with a red dashed line below them. 

Here are ways to find misspelled words:
To check spelling as you type, choose Edit > Spelling > “Check Spelling as You Type.”mm

To turn off spell checking as you type, click Edit > Spelling > “Check Spelling as You 
Type” to deselect it (make sure the checkmark is not visible next to the command). 

To check spelling from the insertion point to the end of the document, click to place mm

the insertion point and choose Edit > Spelling > Check Spelling. To limit spell checking 
to a specific part of the document, select the text you want to check before choosing 
the command.

The first misspelled word found is highlighted. You can correct it or choose the same 
command again to continue checking the document. 

To go through the text more quickly, press Command-semicolon (;) to continue 
checking the document.

To check spelling mm and view suggestions for misspelled words, choose  
Edit > Spelling > Spelling.

The Spelling window opens, and you can use it as “Working with Spelling 
Suggestions” on page 118 describes.

To automatically accept the spelling suggestions, choose Pages > Preferences, click 
Auto-Correction, and then select “Automatically use spell checker suggestions.”

Working with Spelling Suggestions
Use the Spelling window to work with alternative spellings. 

To work with spelling suggestions:
	 1	 Choose Edit > Spelling > Spelling. 

The Spelling window opens and the first misspelled word is highlighted.
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Each language has a different spelling dictionary. To make sure that the correct 
language is selected, select the text you want to work with, click Inspector in the 
toolbar, click the Text button, and then click More. Choose a language from the 
Language pop-up menu.

	 2	 To replace the incorrect spelling in the text, double-click the correct word or spelling in 
the list of suggested corrections.

	 3	 If the correct word doesn’t appear in the list of suggested corrections but you know 
the correct spelling, select the misspelled word in the Spelling window, type the 
correct word, and click Correct.

	 4	 If the current spelling is correct and you want to leave it as it is, click Ignore or Learn. 
Use Learn if the term is one you use often and you want to add the term to the 
spelling dictionary.

If you used Learn and want to undo the effect of the Learn operation, do one of  
the following:

On Mac OS X version 10.4, type the word into the text field below the list of suggested 
corrections, and then click Forget.

On Mac OS X version 10.5, Control-click the word and choose Unlearn Spelling from 
the pop-up menu.

	 5	 If no alternative spellings appear in the list of suggested corrections on Mac OS X 
version 10.4, select the misspelled word in the Spelling window and try a  
different spelling. Click Guess to see whether new possibilities appear in the list of 
suggested corrections.

	 6	 Click Find Next and repeat steps 2 through 5 until you find no more spelling errors.

You can also hold down the Control key and click a misspelled word. From the pop-up 
menu you can choose an optional alternative spelling, click Learn, or click Ignore.



Proofreading Documents
You can set the Proofreader to flag writing errors as you type, or you can check your 
entire document or selected text at any time. 

Proofreading identifies the following types of writing errors:

Improper capitalizationÂÂ

Punctuation errors (for example, inconsistent spacing around dashes)ÂÂ

Duplicated wordsÂÂ

Overly complex word choices (for example, “eventuate” instead of “take place”)ÂÂ

Formatting errors (for example, abbreviations that should be spelled out in  ÂÂ
formal writing)

Parts-of-speech errors (for example, using “an” instead of “a”)ÂÂ

JargonÂÂ

MisspellingsÂÂ

Gender-specific expressionsÂÂ

To find writing errors:
To check writing errors as you type, choose Edit > Proofreading > “Proofread as You Type.”mm

To turn off proofreading as you type, choose Edit > Proofreading > “Proofread as  
You Type” to deselect that command (make sure the checkmark is not visible next to 
the command).

To check writing errors from the insertion point to the end of the document, click mm

to place the insertion point and choose Edit > Proofreading > Proofread. To limit 
checking to a specific part of the document, select the text you want to check before 
choosing the command.

The first error found is highlighted. You can correct it or choose the same command 
again to continue checking the document.

To check writing errors mm and view suggestions for corrections, choose Edit > 
Proofreading > Proofreader.

Finding and Replacing Text
You can find every instance of a word or phrase in your document and optionally 
change it to something else. 

Here are ways to find and replace text:
Choose Edit > Find > Find, click Simple or Advanced to set up find/replace criteria, and mm

then click a button to conduct find/replace operations. 

Simple:  In the Find field, type the text you want to find, and type any text you want to 
replace it with in the Replace field.
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Advanced:  In addition to typing Find and Replace text, you can set up additional find/
replace criteria.

Replace All:  Automatically conducts the find/replace operation without your review.

Replace:  Replaces the current selection with the replacement text.

Replace & Find:  Replaces the current selection with the replacement text and 
immediately finds the next occurrence of the Find text.

Next or Previous:  Finds the next or previous occurrence of the Find text.

Use the other commands on the Edit > Find submenu.mm

Search:  Displays search results for terms typed in the document search field.

Find Next or Find Previous:  Finds the next or previous occurrence of the current 
Find text.

Use Selection for Find:  Finds the next occurrence of the selected text.

Jump to Selection:  Displays the selected text when it’s not currently in view.

Searching for All Occurrences of Words and Phrases
You can generate a list of all occurrences of a specific word or phrase (including 
placeholder text) in your document. If you select a search result in the list, the  
page containing the matching text is displayed in the main viewing area, and the text 
is highlighted. 

Type the word or phrase.

Select an item in the resulting 
list to view where the word or 

phrase occurs in the document.

Pages searches for a match to the word or phrase in the main body text, headers and 
footers, tables, text boxes, shapes, footnotes and endnotes, and comments.

To conduct a search:
	 1	 Show and hide the search sidebar by clicking View in the toolbar and choosing Search.

	 2	 Type the word or phrase you want to search for in the search field. 

Results, with page references and some text that appears before or after the word or 
phrase, are listed as you type. 



Searches are not case sensitive, and you can’t search for invisibles. For example, you 
can’t paste the paragraph symbol into the search field and search for it.

	 3	 To view an item in the search results list on the page where it occurs, click the item. 

The page is displayed with the word or phrase highlighted.

	 4	 To edit a word or phrase selected in the search results list, double-click it or press 
Return or Enter. Type to replace the selected text, or click the text to edit it.

	 5	 To list the results of the last ten searches since opening the document, click the 
disclosure triangle in the search field and select a previous search from the list.

The results for the selected search string appear in the list.

	 6	 To list results that are case sensitive or correspond to entire words or phrases, click the 
disclosure triangle in the search field and select Match Case or Whole Words.
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Apply paragraph, character, and list styles to quickly and 
consistently change the appearance of text. Learn how to 
modify existing styles or create your own.

As you write and format your document, you may want to create different looks for 
different types of text and paragraphs. For example, you may want to have all top-
level headings use the same font, color, and line spacing, or you may want all photo 
captions to have the same look.

The simplest way to make sure that text is consistently formatted is to apply styles. 
Pages Word Processing and Page Layout templates include a variety of styles that are 
suited to the type of document you are working in. The style names, such as Heading, 
Body, or Caption, suggest where the style should be used. If you are using a template, 
you can apply the preset styles where you need them. You can also change template 
styles or create your own styles.

Applying consistent styles is important if you’re creating a table of contents in a word 
processing document. To learn more about creating a table of contents, see “Using a 
Table of Contents” on page 64.

What Are Styles?
A style is a predefined format that you can apply to text with a click of the mouse. For 
example, if your document contains a style named Chapter Heading that centers text, 
makes it bold, and increases the font size to 18 points, you can select text, open the 
Styles drawer, and then click Chapter Heading. The text automatically centers, changes 
to bold, and resizes to 18 points. 

6Working with Styles



There are three kinds of styles: 

Paragraph styles can be applied ÂÂ only to entire paragraphs (chunks of text that end 
with a carriage return), not to individual words within paragraphs. These include 
styles for headings, body text, callouts, captions, headers, and footers. Paragraph 
styles can include specifications for font, size, text color, character and line spacing, 
text shadow, background color, indentation and margins, tab settings, and more. 

If you want to create a table of contents for your word processing document, you 
need to use paragraph styles when creating headings in your document. Most 
documents will use a greater variety of paragraph styles than character or list styles.

Character styles can be applied to any group of characters, including individual ÂÂ
words or groups of words, or letters within a paragraph. Common examples of 
character styles are italic, bold, and strikethrough used to emphasize individual 
words or phrases. Character styles can be applied to text within a paragraph without 
changing its paragraph style.

To create simple lists or an outline, you can apply list styles to your text. List styles ÂÂ
automatically format your text with bullets or numbering, depending on which kind 
of list style you choose. You can also indent paragraphs as a block by changing their 
list indent level (see “Formatting Bulleted Lists” on page 101, “Formatting Numbered 
Lists” on page 102, and “Formatting Ordered Lists” on page 103). Some list styles are 
very basic, for simple lists; others, such as Harvard and Legal, allow you to create lists 
with many subtopics.

To learn about Go to

Adding, editing, and deleting styles “Applying Styles” on page 125

“Creating New Styles” on page 126

“Renaming a Style” on page 127

“Deleting a Style” on page 127

Changing the appearance of a style “Modifying Character Styles” on page 127

“Modifying Paragraph Styles” on page 129

“Modifying a Tiered List Style for Ordered Lists” on 
page 131

“Modifying Bulleted or Numbered List Styles” on 
page 132

Overriding styles and importing styles “Finding and Replacing Styles” on page 134

“Importing Styles from Another Document” on 
page 135
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Applying Styles
Select a style from the Styles drawer, or click the Paragraph, Character, or List style 
buttons in the format bar, and then select a style from the pop-up list. 

To open the Styles drawer, click the Styles Drawer button on the format bar or choose 
View > Show Styles Drawer. For more information about the Styles drawer, see “The 
Styles Drawer” on page 27.

Here are ways to apply styles:
To apply a style to one or more paragraphs, select the paragraphs you want to mm

change, or select an entire text box, table, table cell, or shape that contains text. Click 
the Paragraph Styles button in the format bar, and then choose the style you want  
to apply. 

In the Styles drawer, 
select the style you 
want to apply.

A paragraph style applies to an entire paragraph. Applying a new paragraph style to 
text that’s already been styled replaces the current paragraph or list style.

To apply a character style, select the word or words you want to change, or select an mm

entire text box, table, table cell, or shape that contains text. Click the Character Styles 
button in the format bar, and choose the style you want to apply.

A character style can be applied to selected text without affecting margins, text 
alignment, or other types of paragraph or list formatting. Additionally, character styles 
are preserved even when you change the paragraph or list style of text.

To apply a list style, place the insertion point wherever you want to begin typing mm

your list, click the List Styles button in the format bar, choose the style you want 
to apply, and then type your list, pressing Return to begin each new bulleted or 
numbered point.



A list style applies to an entire paragraph. It does not affect the appearance of text 
(such as font, text size, and so on). The appearance is governed by the underlying 
paragraph style.

If you don’t see character or list styles displayed in the Styles drawer, click the  
Show Character Styles or Show List Styles button in the bottom-right corner of the 
Styles drawer.

Click to show list styles.

Click to show character styles.

Creating New Styles
Customize the look of text by creating a new character, paragraph, or list style. 

To create a new character, paragraph, or list style:
	 1	 For character and list styles, select some text. 

For paragraph styles, click the Paragraph Styles button in the format bar, select Free 
Form at the top of the Paragraph Styles list, and then select a paragraph of text.

	 2	 Set up attributes for the selected text.

To format a paragraph style, see “Modifying Paragraph Styles” on page 129.

To format a list style, see “Modifying Bulleted or Numbered List Styles” on page 132 and 
“Modifying a Tiered List Style for Ordered Lists” on page 131.

To format a character style, see “Modifying Character Styles” on page 127.

	 3	 Hold down the Add (+) button at the bottom of the Styles drawer and choose “Create 
New Character Style from Selection,” “Create New Paragraph Style from Selection,” or 
“Create New List Style from Selection” from the pop-up menu.

Press and hold to 
create a style.

	 4	 Type a name for the new style.

	 5	 If you want to include only some of the attributes you set in the new character style, 
click the disclosure triangle below the Name field, and then select the attributes you 
want.

	 6	 If you don’t want to apply the new style to the selected text, deselect “Apply this new 
style on creation.”

	 7	 Click OK.

	 126		  Chapter 6    Working with Styles



	 Chapter 6    Working with Styles	 127

The new style is displayed in the Styles drawer and the character, list, or paragraph 
style pop-up menus in the format bar.

After you have created a style, you can set up a keyboard shortcut for it. Select the 
style in the Styles drawer, click the arrow to the right of the style and choose Hot Key, 
and then select a keyboard option. To apply the style to selected text, press the hot 
key you selected. If you want to apply the style and clear any overrides that may be 
present, hold down the Option key while pressing the hot key.

Renaming a Style
You can change the name of any style that appears in the Styles drawer. 

To rename a style:
	 1	 Click the Styles Drawer button in the format bar to open the Styles drawer. 

	 2	 Hold the pointer over the style you want to rename, and then click the arrow to the 
right of the style and choose Rename Style.

	 3	 Type a new name for the style and press Return.

Deleting a Style
When you delete a style from a document, you need to choose a different style to 
replace it. 

To delete a style:
	 1	 Click the Styles Drawer button in the format bar to open the Styles drawer.

	 2	 Hold the pointer over the style you want to delete, and then click the arrow to the 
right of the style and choose Delete Style.

	 3	 If the style you want to delete is being used in the current document, choose a style to 
replace it.

	 4	 Click OK.

Modifying Character Styles
Character styles are formatting attributes that are applied to a set of text characters 
(such as a word or a group of words or letters) without changing the style of the 
entire paragraph. Character styles define the look of the text, including font, size, color, 
character spacing, ligature usage, baseline shift, and language. 

If you can’t find a character style that meets your needs, you can modify one of the 
existing character styles.



To modify a character style:
	 1	 Click the Character Styles button in the format bar and select the character style that 

most closely matches the style you want to design, or select None.

	 2	 Type some text, and then apply some attributes.

Select a font typeface and size. For more information, see “Making Text Bold, Italic, or 
Underlined” on page 83.

Set the text color. For information about changing the color of text, see “Changing Text 
Color” on page 93.

Set the character spacing. For more information about setting character spacing, see 
“Setting Text Alignment, Spacing, and Color” on page 90.

	 3	 Use the More pane of the Text inspector to specify additional attributes.

Language:  Choose a language for spell-checking a paragraph, a range of words, or 
newly typed text that follows an insertion point. If your document includes quotations 
or sections in another language, you can choose a spelling dictionary in that language 
for checking the text of the quotations or sections. The spelling dictionary determines 
how words are spelled or hyphenated.

Remove ligatures:  A ligature is a stylish flourish between letters or at the end or 
beginning of lines. Ligatures are used by some fonts to combine two or more text 
characters into one glyph. Select this checkbox if you don’t want to use ligatures 
in a selected paragraph that has ligatures turned on. (To turn ligatures on for the 
document, select “Use ligatures” in the Document pane of the Document inspector. 
If any text is selected when you remove ligatures, the change will be applied to the 
selected text as a style override, unless you complete step 4, below.)

Baseline Shift:  A negative number places the text lower than the surrounding text. 
A positive number places the text higher than the surrounding text. Enter a number 
in the field. (If any text is selected when you set the baseline shift, the change will be 
applied to the selected text as a style override, unless you complete step 4, below.)

	 4	 In the Styles drawer, click the arrow to the right of the character style name, and then 
choose an option.

Redefine Style from Selection:  Redefines the existing character style for the whole 
document. If you choose this, your formatting changes will apply to all other instances 
of this style throughout the document.
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Create New Character Style from Selection:  This doesn’t alter the existing style, but 
creates a new style based on the formatting choices in the previous steps. If you select 
this, you can choose which attributes you want to include as part of the new character 
style. Click the disclosure triangle below the Name field in the “New character style” 
dialog, and then select the attributes you want. Type a name for the new style, and 
then click OK.

Click the disclosure 
triangle to show 

character attributes.

Click to select only those 
attributes that override the 
selected paragraph style.

Select the attributes 
to include in the new 
character style.

Modifying Paragraph Styles
Change a paragraph’s appearance, tab stops, margins, background color, page breaks, 
and more by modifying its paragraph style. 

To modify a paragraph style:
	 1	 Click the Styles Drawer button in the format bar to open the Styles drawer.

Select the paragraph style that most closely matches the style you want to design, or 
select Free Form.

	 2	 Type some text and format it to look the way you want. For information about 
formatting the look of text, see “Formatting Text Size and Appearance” on page 82.

	 3	 Set the text alignment, character and line spacing, and the spacing before and after 
the paragraph using the controls in the format bar or in the Text pane of the Text 
inspector. For more information, see “Setting Text Alignment, Spacing, and Color” on 
page 90.

	 4	 If the paragraph style requires special tab stops, set them in the Tabs pane of the Text 
inspector. For more information, see “Setting Tab Stops to Align Text” on page 94.



	 5	 If you want the paragraph style to be indented relative to the page margins, set the 
paragraph indents in the Tabs pane of the Text inspector.

Set the first-line indent.
Set the right indent 
for the paragraph.

Set the left indent for 
the paragraph.

	 6	 Click More in the Text inspector to select more formatting options.

Choose border and rules 
formatting options for 
selected text.

Select options to 
determine how the 

paragraph breaks 
across pages. Choose a language for the 

spelling dictionary to use.
Remove automatic 

hyphenation or ligatures, 
if they are selected for 

the document.
Set the text above or below 
the surrounding text.

Choose a paragraph style 
to follow the current one 
when you press Return.

Add a background 
color to a character 

or paragraph.

	 7	 In the Styles drawer, click the arrow to the right of the paragraph style name, and then 
choose an option.

Create New Paragraph Style from Selection:  This doesn’t alter the existing style, but 
creates a new style based on the formatting choices you’ve made in the previous 
steps. If you select this, type a name for the new style, and then click OK.

Redefine Style from Selection:  Redefines the existing paragraph style for the whole 
document. If you choose this, your formatting changes will apply to all other instances 
of this style throughout the document. (But any character styles that have been 
applied will not be affected.)

Revert to Defined Style:  Removes style overrides and the selected text takes on the 
default attributes of the selected style.
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Modifying a Tiered List Style for Ordered Lists
Change the look of Legal style lists by modifying the style. 

To modify a tiered list style:
	 1	 Make sure the insertion point is visible on the page, and select the Legal list style that 

best matches the one you want to design.  

	 2	 Click Inspector in the toolbar, click the Text button, and then click List.

Click to advance to the next 
list indent level.

 Select Tiered 
Numbers for a 
Legal-style list.

For each list indent level, 
choose a numbering style.

For each list indent level, set 
how far you want to indent the 
number and its associated text.

	 3	 Choose the numbering or lettering style that you want from the second pop-up menu.

	 4	 Click the right indent level arrow to advance to the second list indent level.

	 5	 Choose the numbering or lettering style that you want for the second list indent level.

	 6	 Repeat steps 4 and 5 until you have set numbering or lettering styles for up to nine list 
indent levels.

	 7	 Click the Styles Drawer button in the format bar to open the Styles drawer.

Notice that one of the list styles is highlighted. This is the style that has been applied 
to the selected text. (If the list styles are not visible, click the button at the bottom 
right of the Styles drawer.) The arrow to the right of the style name is red, indicating 
that you have applied overrides to the style by modifying it.

	 8	 Click the red arrow to the right of the list style name, and then choose an option.

Redefine Style from Selection:  Redefines the existing list style for the entire 
document. If you choose this, your formatting changes will apply to all other instances 
of this style throughout the document.

Create New List Style from Selection:  This doesn’t alter the existing style, but creates 
a new style based on your formatting choices in the previous steps. If you choose this, 
type a name for the new style, and then click OK.



Modifying Bulleted or Numbered List Styles
Change the look of bulleted or numbered lists by modifying the list style. 

To modify a bulleted or numbered list style:
	 1	 Click Inspector in the toolbar, click the Text button, and then click List. 

Click to advance to the 
next list indent level.

Adjust bullet size and 
position relative to text.

Choose bullets or 
numbering.

Select an image for 
image bullets.

Adjust bullet indentation 
relative to the first 
paragraph indent.

Set the text indent level 
relative to the bullets.

	 2	 Make sure the insertion point is visible on the page, click the List Styles button in the 
format bar, and then select the bulleted or numbered list style that best matches the 
one you want to design.

	 3	 Choose one of the following bullet or numbering styles from the Bullets & Numbering 
pop-up menu in the List pane of the Text inspector.

No Bullets:  Choose this if you don’t want visible bullets, but you want to be able to 
specify the amount of indentation for levels in an ordered list.

Text Bullets:  Choose this to use a text character as the bullet. You can select one from 
the list or type your own characters in the text field. Some fonts provide symbols that 
can be used as interesting bullets. To use them, open the Characters window (choose 
Format > Font > Show Fonts, then choose Characters from the Action pop-up menu). 
Select the bullet symbol in the Text inspector, and then double-click the symbol of 
your choice in the Characters window. Then press the Return key. 

Select a color for 
the text bullet.

For text bullets, choose 
an available character 
or type a character in 

the text field.
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Image Bullets:  Choose this to use one of the available image bullets provided by 
Pages, and then select one in the list.

For image bullets, select 
one from the list.

Custom Image:  Choose this to use your own image as a bullet. Use the Open dialog to 
locate and select the image file you want to use. (To change the image, click Choose or 
drag a new image into the well.)

Numbers:  Choose this to create a numbered list. You must also choose a numbering 
style. You can choose Arabic numerals, Roman numerals, or letters.

For numbered lists, choose 
a numbering style.

Restart numbering, or continue 
with previous numbering.

Adjust number indentation 
relative to page margin.

Adjust text indentation 
relative to the bullet.

	 4	 Format the bullets.

To increase or reduce the size of a bullet, specify a number in the Size field. Selecting 
“Scale with text” maintains the image-to-text size ratio of the bullets even if you later 
change the font size.

To position the bullet symbol higher or lower relative to the text, specify a number in 
the Align box.

To set how far the bullets are indented from the margin, specify a number in the Bullet 
Indent field. A higher number indents the list farther to the right.

To set how far text is indented from the bullet, specify a number in the Text Indent 
field. A higher number indents the text farther to the right.

	 5	 Click the Styles Drawer button in the format bar to open the Styles drawer.



Notice that one of the list styles is highlighted. This is the style that has been applied 
to the selected text. (If the list styles are not visible, click the button at the bottom of 
the Styles drawer.) The arrow to the right of the style name is red, indicating that you 
have applied overrides to the style by modifying it.

	 6	 Click the red arrow to the right of the selected style in the Styles drawer and choose 
an option.

Redefine Style from Selection:  Redefines the existing list style for the entire 
document. If you choose this, your formatting changes will apply to all other instances 
of this style throughout the document.

Create New List Style from Selection:  This doesn’t alter the existing style, but creates 
a new style based on your formatting choices. If you select this, type a name for the 
new style, and then click OK.

Finding and Replacing Styles
Most of the time you change the style of text by selecting the text and applying 
a different style. Usually you use the techniques described in “Applying Styles” on 
page 125, but you can also change styles by using a find/replace or copy/paste 
operation. 

When you make changes to individual text attributes without selecting, replacing, or 
pasting a new style, you have created a style override. For example, you create a style 
override when you use the Font command in the Format menu to apply italics to a 
paragraph of text formatted with the paragraph style named Body. The text remains 
formatted in its original style (Body), but you have applied changes (italic) on top of 
the default style attributes. 

When you select text to which you have applied style overrides, the arrow next to the 
style name in the Styles drawer is red. (The arrow next to a paragraph style name also 
appears red if you have selected text with a character or list style applied.)

When the arrow next to a style 
name is red, it means that you 
have applied changes to this 
style in the selected text.

Overrides can occur when you change the font, typeface, size, or color of text, or apply 
the text formatting options in the Text submenu of the Format menu, in the Fonts 
window, in the format bar, or in the Text inspector.

If you apply style overrides to some text and then change your mind, you can easily 
return the text to the default attributes of the paragraph style.

To copy and paste a paragraph or character style:
	 1	 Place the insertion point in a paragraph or word whose style you want to copy.
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	 2	 Choose Format > Copy Paragraph Style, or choose Format > Copy Character Style.

	 3	 Place the insertion point in a paragraph or word you want to modify, or select multiple 
paragraphs or words to modify.

	 4	 Choose Format > Paste Paragraph Style, or Format > Paste Character Style.

To copy a paragraph or character style to another Pages document, switch to the other 
document before choosing Format > Paste style.

The text takes on the new style, but its content is not altered.

To find and replace a style:
	 1	 Click an example of text that uses the style you want to change in the document. 

	 2	 Click the Styles Drawer button in the format bar to open the Styles drawer.

	 3	 In the Styles drawer, position the pointer over the name of the style that you want to 
replace and click the arrow to the right of its name.

	 4	 Choose “Select All Uses of style name.” All instances of the style in the text body 
throughout the document are selected.

To find and replace the styles in the text body plus all text boxes and shapes, choose 
Edit > Find > Find. Click Advanced to open the Advanced tab. Select the style to be 
replaced and the style to replace it with. Click Replace All.

	 5	 Select the name of the style to which you want to change the selected text.

To remove style overrides:
	 1	 Click the Styles Drawer button in the format bar to open the Styles drawer.

	 2	 Select the text you want to change.

	 3	 In the Styles drawer, click the arrow to the right of the selected style and choose 
“Revert to Defined Style” (or double-click the style name). The selected text takes on 
the default attributes of the selected style.

Importing Styles from Another Document
When you import a document from Microsoft Word, any styles it contains are imported 
into the Pages document and can then be used the same way you use any other styles 
created within Pages. 

You can import styles that have already been defined in another Pages document 
without importing the document’s content. 

To import styles from a Pages document:
	 1	 Choose Format > Import Styles.

	 2	 Select the document that contains the styles you want to import, and then click Open.



	 3	 Select the styles you want to import in the dialog. Hold down the Command key as 
you click the style names to select multiple styles, or click Select All.

	 4	 To replace styles in your document that have the same name as the styles you are 
importing, select “Replace duplicates.” 

Note that replacing a style will affect any text that uses this style. Replacing a style also 
changes the style of text in locked objects, but the text retains its original appearance.

If an imported style has the same name as a style in the open document and you do 
not select “Replace duplicates,” a number is appended to the name of the imported 
style. For example, if you import a style called Body to a document that already 
contains a Body style, the imported style will be named Body 2.

	 5	 Click OK.

You can make imported paragraph styles available by clicking the Paragraph Style 
pop-up menu in the format bar and in the Styles drawer of your document. Imported 
character and list styles will be available in the Styles drawer.

To maintain a consistent look among several documents, keep a master document that 
contains all the styles you need. When you need to change a style, change it in the 
master document and import the master document’s styles into the other documents.
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Learn how to add images, shapes, sound, and movies to your 
documents.

An object is any item you add to a document and then manipulate. Images, shapes, 
movies, text boxes, tables, and charts are all objects.

This chapter focuses on images (photographs or PDF files), shapes, sound, and movies. 
Many of the techniques covered in this chapter for placing and manipulating these 
objects can be generalized to tables, charts, and text boxes; any special formatting 
techniques for these objects are covered in other chapters.

What Are Floating and Inline Objects?
If you want an object to remain in place so that text on the page flows around it, use a 
floating object. 

Floating objects are anchored to a position on a page. Typing more text on the page, 
does not affect the position of a floating object, but you can drag a floating object to 
reposition it. Drag any of its selection handles to resize it.

Drag any of the 
selection handles to 
resize floating objects.

If you want the object embedded in text flow so it is pushed along as the text grows, 
use an inline object.

7Working with Images, Shapes, and 
Other Objects



Inline objects are embedded in the text flow. If you type more text above them, they 
are pushed along as the text grows. The selection handles on the top and left side of 
inline objects are inactive. You cannot drag these handles to resize the object; you can 
only resize it by dragging the active handles.

Active selection handle

Inactive selection handle

If you are placing a graphic or shape inside another shape, text box, or table cell, it can 
only be added as an inline object. Inline images are automatically resized to fit within 
the layout margins of the document. To move an inline object to a different position 
within the text, select it and drag it until you see the insertion point appear where you 
want to drop the object.

If you’ve added an object as one kind of object, and you want to turn it into the other 
kind of object, you can easily do so.

Here are ways to convert between floating and inline objects:
Select the floating or inline object you want to convert, and then click the Floating or mm

Inline button in the format bar.

Select the floating or inline object you want to convert, click Inspector in the toolbar, mm

click the Wrap button, and then select “Inline (moves with text)” or “Floating (doesn’t 
move with text)”.

Working with Images
Import an image as a floating object when you want it to remain in a particular place 
on a page. If you are working with a word processing document, you can import an 
image as an inline object when you want the object to flow with its surrounding text. 

Pages accepts all QuickTime-supported formats, including the following graphics file 
types:

TIFF  ÂÂ

GIFÂÂ

JPEGÂÂ

PDFÂÂ

PSDÂÂ

EPSÂÂ

PICTÂÂ

To import an image as a floating object:
Drag an image file from the Finder to the document and position it where you want it.mm
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Click Media in the toolbar, click the Photos button in the Media Browser window, select mm

the album where your picture is located, and then drag a thumbnail to position it 
where you want it.

Second, choose a source.

First, click a button to go to 
your media files. 

Third, drag an item to the 
document or to an image 
well in one of the inspectors.

Search for a file by typing 
its name here.

Command-click outside the text areas in the document so that no insertion point mm

is visible, and then choose Insert > Choose. Select the file and click Insert. Drag the 
image to position it where you want it.

To import an image as an inline object in a word processing document:
Press the Command key, and then drag an image file from the Finder to the document mm

window until you see the insertion point at the place where you want the image to 
appear. Release the image when you have placed it where you want it.

Click Media in the toolbar, click the Photos button in the Media Browser window, select mm

the album where your picture is located, press the Command key, and then drag a 
thumbnail to the document window, releasing the image when the insertion point is 
at the place where you want the image to appear.

Place the insertion point wherever you want the image to appear, choose Insert > mm

Choose, select the image file, and then click Insert.

After importing your image, you can drag it to position it wherever you want on a 
page. You can use the tools in Pages to mask (crop) an image; change its brightness, 
contrast, and other image qualities; or erase its background.



To learn how to Go to

Replace image and other placeholders in 
templates with your own objects

“Replacing Template Images with Your Own 
Images” on page 140

Mask images to get rid of unwanted parts “Masking (Cropping) Images” on page 141

Reduce the size of your document by saving only 
the used portion of masked images

“Reducing Image File Sizes” on page 142

Make parts of an image transparent in order to 
remove the image background

“Removing the Background or Unwanted 
Elements from an Image” on page 143

Improve the quality of images and create 
interesting visual effects

“Changing an Image’s Brightness, Contrast, and 
Other Settings” on page 144

Place, align, resize, and reformat images “About Manipulating, Arranging, and Changing 
the Look of Objects” on page 157

Replacing Template Images with Your Own Images
The photos you see featured in Pages templates are actually media placeholders. By 
dragging your own images to these placeholders, your media is automatically sized, 
positioned, and framed to fit the template.  

To test whether an image is a placeholder, let the pointer rest over it and see if a help 
tag appears instructing you to drag your own file to the placeholder.

Here are ways to work with media placeholders:
To replace a media placeholder with your own image, drag the image from the Media mm

Browser, the Finder, or another application to the placeholder.

To open the Media Browser, click Media in the toolbar. Click a button at the top of the 
window to look for images, audio files, or movies.

To resize or reposition your image within a media placeholder, click the Edit Mask mm

button that hovers over the image after you’ve dropped it onto the placeholder, and 
then do any of the following:

To resize your image within the placeholder, drag the resize handle above the Edit 
Mask button.

To reposition your image within the placeholder, position the pointer over the image 
(the pointer may appear as a hand), and then drag the image to position it where 
you want.

To replace an item you’ve already placed in a media placeholder, drag a new file to it. 
You don’t have to delete the old file first.

To reposition a media placeholder on a page, drag it.mm

To convert a placeholder image to an image, select the image, choose Format > mm

Advanced > Define as Media Placeholder (remove the checkmark).
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To remove a media placeholder from a page, select it and press Delete.mm

To create a media placeholder, follow the instructions in “mm Creating Placeholders in 
Custom Templates” on page 270.

Masking (Cropping) Images
You can crop images without actually changing the image files by masking the edges 
to get rid of unwanted parts or to change the outline of the image. If you don’t specify 
a shape for the mask, by default Pages uses a rectangular mask, but you can use any 
shape available in Pages, including a custom shape that you’ve created with the Draw 
tool, to mask the edges of your image.  

To mask an image:
	 1	 Import the image you want to mask.

	 2	 Depending on the mask shape you want to use, do one of the following:

To mask the image with the default rectangle shape, select it and then click the ÂÂ
Mask button in the toolbar (or choose Format > Mask).

To mask the image with a predrawn shape (for example, a circle or a star), select it ÂÂ
and choose Format > “Mask with Shape” > Shape.

To mask the image with any shape, including a custom shape, create the shape you ÂÂ
want, and then drag it over the image you want to mask. Hold down the Shift key 
and click to select both the shape and the image, and then click Mask in the toolbar 
(or choose Format > “Mask with Selected Shape”).

A mask appears over the image, and some controls appear. 

Drag the image to 
position the part you 
want to show.

Drag the slider to resize 
the image.

Click to show or hide the 
area outside the mask.

Drag the selection handles 
to resize the mask.

	 3	 To resize the image, drag the slider above the Edit Mask button.

	 4	 Refine the mask by doing any of the following:

To resize the mask, drag the selection handles on the mask shape. To constrain the ÂÂ
mask’s proportions, hold down the Shift key as you drag.

To rotate the mask, hold down the Command key as you drag a corner selection ÂÂ
handle on the mask.



	 5	 Drag the image to position the part you want to show. To move the mask, click the 
dotted edge of the mask and drag it.

	 6	 When you’re satisfied with the position and size of your image and the mask, do any of 
the following to finish:

Double-click the mask or the image.ÂÂ

Press Return.ÂÂ

Click outside the image.ÂÂ

Click Edit Mask.ÂÂ

	 7	 To resize or rotate the masked image, drag or Command-drag its selection handles.

	 8	 To change the size or position of the mask or the image within it, select the masked 
image, and then click Edit Mask.

Repeat the steps above as needed.

	 9	 To unmask the image, click Unmask in the toolbar (or choose Format > Unmask).

If you’ve masked a very large image file and you only need to use the smaller version 
in your document, you can have Pages keep only the smaller copy of the image, 
thus reducing the overall size of your document. See “Reducing Image File Sizes” on 
page 142.

Reducing Image File Sizes
If you’ve resized or masked a very large image file, and you want to save the image 
file as part of your Pages document (so that you can easily transfer it to another 
computer), but you want to keep the document size to a minimum, you can choose to 
save only the smaller (cropped or shrunk) version of the image in your document.

Before you reduce the image file size, you must save your document. For details about 
how to do this, see “Saving A Document” on page 37. 

Here are ways to reduce the size of images:
To reduce the file size of an individual image that you’ve masked or resized to a mm

smaller size, select the image and choose Format > Image > Reduce Image File Size.

To reduce the file size of all masked and resized (shrunk) images, select the images, mm

and then choose File > Reduce File Size.

Important:  After you’ve reduced the size of masked or shrunk image files, you won’t 
be able to restore them to their original size. If you later want to restore their original 
size, you must add the original image files to the document again.

Images used in image fills cannot be reduced in this way. Some types of image files 
also may not be reducible. 
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To learn about reducing the size of audio and movie files, see “Reducing the Size of 
Media Files” on page 156.

Removing the Background or Unwanted Elements from an Image
The Instant Alpha tool lets you make parts of an image transparent in order to remove 
the image background. This feature is useful for removing an unwanted background or 
other colors. 

You’ll get the best results removing solid colors with clear boundaries around them. To 
remove areas that are less distinct, select a smaller area and repeat the process.

To remove unwanted elements:
	 1	 Select the image.

	 2	 Choose Format > Instant Alpha.

	 3	 Click the color you want to make transparent, and then drag slowly over it. 

Dragging selects the contiguous 
area that uses colors similar to 
the color you click.

As you drag, the selection grows to include the contiguous area that uses similar 
colors. You can control how much of the image is selected by dragging less or more.

If you hold down the Option key while you drag, all instances of the color that you’re 
dragging over will be removed from the image.

	 4	 Repeat step 3 as many times as you like. 

Dragging more here...

...selects more of 
the image.



You can restore the parts removed from the image at any time. To revert to the 
original image, choose Format > Remove Instant Alpha. To restore parts of the image 
removed using Instant Alpha, choose Edit > Undo Instant Alpha until the parts have 
been restored.

Changing an Image’s Brightness, Contrast, and Other Settings
You can change the brightness, contrast, and other settings of images to improve their 
quality or to create interesting effects. Adjustments you make don’t affect the original 
image; they affect only the image’s appearance in Pages. 

To adjust an image:
	 1	 Select the image.

	 2	 Choose View > Show Adjust Image. 

Adjust the contrast of light 
and dark tones.

Change the color intensity.
Introduce more warmth 

or coolness. Change the amount of red 
or green tones.

Sharpen or soften 
the focus.

Adjust shadows and highlights.

Understand the relationship 
between shadows and highlights.

Change the levels of dark 
and light tones.

Restore original settings.

Adjust the lightness.

Enhance colors 
automatically.

	 3	 Use the controls to make adjustments. 

Brightness:  Changes the amount of white in the image. Dragging to the right 
increases the white in the image, making it appear brighter. 

Contrast:  Changes the difference between the light and dark areas of the image. If you 
increase contrast, the light parts get lighter and the darks get darker. If you decrease 
contrast, the difference between light and dark decreases. Dragging to the right makes 
the edges between light and dark areas more stark, and can make a photo appear 
more like an illustration. 

Saturation:  Changes the richness of color in the image. Dragging to the right makes 
the colors richer or more vibrant. 
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Temperature:  Changes the warmth or coolness of the image by adjusting the amount 
of warm tones (red) or cold tones (blue). 

Tint:  Changes the overall color cast of the image by adjusting the amount of red or 
green tones. 

Sharpness:  Sharpens or softens (blurs) the focus of the image.

Exposure:  Changes the overall lightness or darkness of the entire image. When you 
adjust exposure, every part of the image gets lighter or darker. Increasing the exposure 
of an image can also reduce its color. 

Histogram and Levels:  Describes the total color information in the image, from the 
darkest shadow on the left, to the brightest highlight on the right. The heights of the 
peaks tell you how much color information falls in a given range.  

To set the light level, drag the right slider toward the middle. Dragging the slider to 
the left narrows the range of color and can bring more clarity to the highlights. The 
position of the slider determines how much information is in the lightest part of the 
image; any information to the right of the slider is omitted from the image. You may 
want to drag the slider just to the point that the histogram line shows a noticeable 
bump, signifying that detail is available.

To set the dark level, drag the left slider toward the middle. Dragging the slider to 
the right narrows the range of color and can bring more clarity to the shadows. The 
position of the slider determines how much information is in the darkest part of the 
image; any information to the left of the slider is omitted from the image. You may 
want to drag the slider just to the point that the histogram line shows a noticeable 
bump, signifying that detail is available.

Enhance:  Automatically adjusts the image by spreading the red, green, and blue tones 
evenly across the histogram.

	 4	 To restore the original settings, click Reset Image. 

To save any changes you made, save the document. The settings at the time you save 
the document are visible anytime you open the Adjust Image window.

Creating Shapes
Pages provides a variety of predrawn shapes you can add to documents, including 
circles, rectangles with square or rounded corners, stars, “speech bubbles,” arrows, and 
more. You can also create your own custom shapes or alter the lines and contours of a 
predrawn shape.  



To learn how to Go to

Add a simple predefined shape “Adding a Predrawn Shape” on page 146

Draw your own shapes “Adding a Custom Shape” on page 146

Modify a shape’s contours “Editing Shapes” on page 147

Change the orientation, color, and shadow and 
make other changes to shapes

“About Manipulating, Arranging, and Changing 
the Look of Objects” on page 157

Adding a Predrawn Shape
You can insert predrawn shapes, such as triangles, arrows, circles, and rectangles, to 
use as simple graphics. 

Here are ways to add a predrawn shape:
To add a floating predrawn shape, click Shapes in the toolbar, and then select a shape mm

from the pop-up menu.  

To add an inline predrawn shape, place the insertion point where you want the mm

predrawn shape to appear, and choose Insert > Shape > Shape.

Hold down the Option key as you click Shapes in the toolbar, and then select a shape mm

from the pop-up menu; the pointer changes to a crosshair. Drag across the page to 
create a shape the size you want. To constrain the shape’s proportions (for example, to 
keep triangles equal on all sides), hold down the Shift key as you drag.

Drag the new shape to wherever you want it on a page. To change the shape’s 
contours, you must first make the shape editable; see “Editing Shapes” on page 147.

To learn about manipulating and aligning shapes, and changing their general object 
properties, such as color, border style (stroke), size, orientation, shadows, and more, see 
“About Manipulating, Arranging, and Changing the Look of Objects” on page 157.

Adding a Custom Shape
You can use the Draw tool to create your own shapes. 

When you first create a custom shape, it’s inserted as a floating object, but you can 
make it an inline object if you like.

To create a custom shape:
	 1	 Click Shapes in the toolbar, and then select the Draw tool (or choose Insert > Shape > 

“Draw with Pen”).  
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The pointer changes from an arrow to a small pen tip. 

	 2	 Click anywhere in your document to create the first point of the custom shape.

	 3	 Click to create more points.

Each point you add is connected to the preceding point. To delete a segment you’ve 
just created, press the Delete key. You can press Delete multiple times.

	 4	 To stop drawing and close the shape (add a solid line between the last and first 
points), click the first point.

To stop drawing and leave the shape open (no line between the last and first points) 
so that you can work with the shape again later, press the Esc (Escape) key or double-
click the last point created.

	 5	 To close or add more points to a shape that you previously left open, click once in 
the shape to select it, and then click it a second time to show its points. Do any of 
the following:

Double-click one of the two points at either end of the open segment; the pointer ÂÂ
changes to a pen tip. 

To add points, click other locations as needed.ÂÂ

When you’re ready to stop drawing and close the shape, click the point at the end of 
the open segment.

	 6	 Select the shape’s border and drag it to wherever you want it on the page.

To change the shape’s contours, you must first make the shape editable; see “Editing 
Shapes” on page 147.

To learn about manipulating and aligning shapes, and changing their general object 
properties, such as color, border style (stroke), size, orientation, shadows, and more, see 
“About Manipulating, Arranging, and Changing the Look of Objects” on page 157.

Editing Shapes
You can manipulate and reshape the points and contours of a shape you’ve  
already placed on a page. Before you can edit a shape in this way, you need to make 
it editable. 



Here are ways to make shapes editable:
To make a predrawn shape editable, select the shape and then choose mm

Format > Shape > Make Editable. 

Red points appear on the shape. Drag the points to edit the shape. Later, to edit a 
predrawn shape that has been made editable, click it twice slowly.

To make a custom shape editable, click once in the shape to select it, and then click a mm

second time to show its editing points.

To learn how to Go to

Change a shape’s contour by manipulating  
its points

“Adding, Deleting, and Moving the Editing Points 
on a Shape” on page 148

Expand or contract a curve or change its angle “Reshaping a Curve” on page 149

Change the angle between two segments or 
change the length of a segment

“Reshaping a Straight Segment” on page 150

Change one or more points into curves or curves 
into points

“Transforming Corner Points into Curved Points 
and Vice Versa” on page 150

Change the corners of a rounded rectangle “Editing a Rounded Rectangle” on page 150

Adjust the relative proportions of an arrow’s head 
and tail

“Editing Single and Double Arrows” on page 151

Adjust the corners and other aspects of a quote 
bubble or callout

“Editing a Quote Bubble or Callout” on page 151

Increase or decrease the number of points in  
a star

“Editing a Star” on page 152

Increase or decrease the number of sides in  
a polygon

“Editing a Polygon” on page 152

Manipulate color, border style, and other aspects 
of a shape

“About Manipulating, Arranging, and Changing 
the Look of Objects” on page 157

Adding, Deleting, and Moving the Editing Points on a Shape
You can fine-tune the lines and contours of a shape by adding, moving, or deleting 
its editing points. First you need to make the shape editable, as described in “Editing 
Shapes” on page 147. 
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Here are ways to manipulate a shape’s editing points:
To add a point, make the shape editable, press the Option key, and then hold the mm

pointer over the shape’s border. The pointer changes into a pen tip with a plus sign (+). 
Click the location on the border where you want to add a point, and then move the 
point if needed. 

To move a point, make the shape editable, click the point, and then drag it to another mm

location. You can move several points at the same time by holding down the Shift key 
as you click multiple points, and then dragging.

To delete a point, make the shape editable, click the point, and then press the Delete mm

key. You can delete several points at the same time by holding down the Shift key as 
you click multiple points, and then pressing Delete.

Reshaping a Curve
One way to create a unique shape is to reshape the contours of a predrawn shape. This 
technique can also be used to readjust the curves of a custom shape. 

To reshape a curve:
	 1	 Make the shape editable. To learn how, see “Editing Shapes” on page 147. 

Red points appear on the shape, indicating that you can reshape the curves at  
these points.

	 2	 Click a red point on the curve you want to reshape. Handles appear on both sides of 
the red point. 

You can also drag a point 
to modify the curve.

Drag a control handle or 
rotate one or both control 
handles to change the curve.

	 3	 To adjust the curvature, drag the red point or one of its handles.

Move the control handles clockwise or counter-clockwise. Different effects result when 
you move the handles together or independently of each other. Experiment until you 
achieve the desired effect.

To move the handles together, hold down the Option key, and then drag either handle.

To move only one handle, hold down the Command key while dragging the handle.

	 4	 For more precise control of the contour, add more editing points by holding down 
the Option key while you hold the pointer along the shape’s border. When the pointer 
takes the shape of a pen tip with a plus (+) sign, click where you want to add a new 
editing point. For more information, see “Adding, Deleting, and Moving the Editing 
Points on a Shape” on page 148.



Reshaping a Straight Segment
You can change the angle between two segments, or change the length of a segment.

To reshape a straight segment:
	 1	 Make the shape editable. To learn how, see “Editing Shapes” on page 147.  

	 2	 Click a corner point.

	 3	 To change the angle between the two attached segments, drag the point clockwise or 
counter-clockwise.

	 4	 To change the length of one of the segments, drag the point outward or inward.

	 5	 Add more editing points by holding down the Option key while you hold the pointer 
over a line. When the pointer takes the shape of a pen tip with a plus (+) sign, click 
where you want to add a new editing point. For more information, see “Adding, 
Deleting, and Moving the Editing Points on a Shape” on page 148.

Transforming Corner Points into Curved Points and Vice Versa
You can change one or more points into curves or curves into points. First you must 
make the shape editable, as “Editing Shapes” on page 147 describes. 

Here are ways to transform corner points into curved points and vice versa:
To change a corner point into a curved point, make the shape editable, and then mm

double-click the corner point. 

To change a curved point into a corner point, make the shape editable, and then mm

double-click the curved point.

To change all corner points in one or more shapes into curved points, make the shapes mm

editable, select them, and then choose Format > Shape > Smooth Path.

To change all curved points in one or more shapes into corner points, make the shapes mm

editable, select them, and then choose Format > Shape > Sharpen Path.

After a shape is editable, you can use the Smooth Path and Sharpen Path commands 
without making the shape editable again.

Editing a Rounded Rectangle
The rounded rectangle has a circular control that lets you change the corners. 

Drag to straighten or 
round the corner.
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To edit a rounded rectangle:
Select the shape, and drag its blue editing point to the left to straighten the corners, or mm

to the right to round them. 

Editing Single and Double Arrows
An arrow shape has specialized editing points with which you to adjust the relative 
proportions of the arrow’s head and tail. 

Drag to change 
the tail length.

Drag up or down to 
change the width of the 
tail. Drag left or right to 
resize the arrowhead.

To change the proportions of a single or double arrow:
Select the shape, and then do any of the following.mm

To make the arrow longer, drag one of the selection handles at its head or tail.ÂÂ

To make the entire arrow narrower or thicker, drag one of the selection handles on ÂÂ
the arrow’s bounding box near where the arrow’s head and tail meet.

To change the relative thickness of the arrow’s head and tail, place the pointer ÂÂ
over the blue editing point where the arrow’s head and tail meet. When the 
pointer’s appearance changes, drag the editing point in any direction to adjust the 
arrow’s proportions.

Editing a Quote Bubble or Callout
Quote bubbles and callouts have special editing controls. With these, you can adjust 
how square or rounded the shape’s corners are, as well as the thickness and length of 
the shape’s tail. 

To change the look of quote bubbles or callouts:
Select the shape, and then do any of the following.mm

To make the corners more square, drag the blue editing point on its widest edge ÂÂ
and drag it toward the shape’s tail. Drag away from the tail to make the corners 
more round.

To make the shape’s tail thicker or thinner, drag the blue editing point at the ÂÂ
intersection of the shape’s tail and body, inward or outward.

To make the shape’s tail longer, drag the blue editing point at the tip of the tail ÂÂ
inward or outward.



To make the shape’s body taller, shorter, wider, or narrower, drag the selection ÂÂ
handles on the shape’s bounding box.

Editing a Star
The star shape has a slider that increases or decreases the number of points in the star, 
and a blue editing point that makes the angles between the star’s points sharper or 
more obtuse. 

View the number of points 
currently in the star.

Drag to increase or 
decrease the number 
of points in the star.

Drag to change the angles 
between points in the star.

Here are ways to edit a star:
When you select a star shape, the slider appears. Drag the slider to increase or mm

decrease the number of points in the star. 

Drag the blue editing point to change the angles between points in the star.mm

Editing a Polygon
The polygon has a slider for increasing and decreasing the number of sides in  
the polygon. 

Drag to increase or 
decrease the number of 
sides in the polygon.

View the number of sides 
currently in the polygon.

To edit a polygon:
When you select the polygon, the slider appears. Drag the slider to increase or mm

decrease the number of sides in the polygon. 

Using Sound and Movies
You can add audio—a music file, a playlist from your iTunes library, or any other sound 
file—to a Pages document. You can add video that plays within a page.
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Pages accepts any QuickTime or iTunes file type, including the following:

MOV  ÂÂ

MP3ÂÂ

MPEG-4ÂÂ

AIFFÂÂ

AACÂÂ

Also note that some media files are protected under copyright law. Some downloaded 
music may be played only on the computer where the download occurred. Make  
sure the computer you are using has permission to play all the media files included in 
your document.

When you add media files to your document, make sure that they will be available 
if you transfer your document to another computer. When saving your document, 
make sure the option “Copy audio and movies into document” is selected in the Save 
window. (If you don’t see the option, click the button next to the Save field to display 
the entire Save window, and then click the Advanced Options disclosure triangle.)

To learn how to Go to

Add audio to a document “Adding a Sound File” on page 153

Add a movie “Adding a Movie File” on page 154

Add a picture frame around a movie “Placing a Picture Frame Around a Movie” on 
page 155

Specify settings that control how audio and 
movie files play

“Adjusting Media Playback Settings” on page 155

Remove unused portions of audio and movie files 
from a document

“Reducing the Size of Media Files” on page 156

Adding a Sound File
Here are ways to add sound to a document: 
Drag a sound file from the Finder anywhere onto a page or to a media placeholder. mm

The sound file is added to your document as a floating object.  

Click Media in the toolbar, choose iTunes from the pop-up menu, select a playlist, and mm

then drag a file or playlist anywhere onto a page or to a media placeholder. The sound 
file is added to your document as a floating object.

To convert a sound file from a floating object to an inline object, select a sound file mm

and click the Inline button in the format bar.

To add a sound file as an inline object, hold down the Command key and then drag mm

the file from the Finder or Media Browser until you see the insertion point where you 
want the sound file to appear. Release the thumbnail when you’ve placed it where you 
want it.



The sound file is represented on the page by a speaker icon.

Double-click the icon to play the sound file. To set up audio playback settings, see 
“Adjusting Media Playback Settings” on page 155.

When you add media files, make sure that they will be available if you transfer your 
document to another computer. When saving your document, make sure to select 
“Copy audio and movies into document” in the Save window after you choose Save or 
Save As. (If you don’t see the option, click the disclosure triangle next to the field, and 
then click Advanced Options.)

Also note that some media files are protected under copyright law. Some downloaded 
music may be played only on the computer where the download occurred. Make  
sure the computer you are using has permission to play all the media files included in 
your document.

Adding a Movie File
Here are ways to add a movie to a document: 
Drag a movie file from the Finder to a page or to a media placeholder. mm

Click Media in the toolbar, and then click Movies in the Media Browser. Select a file, and mm

then drag it to a page or to a media placeholder.

To see your movies listed in the Movies pane of the Media Browser, you must place 
them in the Movies folder, in iTunes, or in iPhoto.

Choose Insert > Choose, and then navigate to the movie file you want. Select it, and mm

then click Insert. Drag the movie to where you want it on a page.

To convert a movie file from a floating object to an inline object, select a movie file mm

and click the Inline button in the format bar.

To add a movie as an inline object, press the Command key and then drag the file mm

from the Finder or from the Movies pane of Media Browser until you see the insertion 
point where you want the movie file to appear. Release the thumbnail when you’ve 
placed it where you want it.

To learn about further adjustments you can make to control movie playback, see 
“Adjusting Media Playback Settings” on page 155.

Also note that some media files are protected under copyright law. Some downloaded 
music may be played only on the computer where the download occurred. Make  
sure the computer you are using has permission to play all the media files included in 
your document.
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When you add media files to your document, make sure that they will be available if 
you transfer your document to another computer. When saving your document, make 
sure to select “Copy audio and movies into document” in the Save window after you 
choose Save or Save As. (If you don’t see the option, click the disclosure triangle next 
to the field, and then click Advanced Options.)

Placing a Picture Frame Around a Movie
Placing a picture frame around a movie is an attractive way to display it in a document. 
To add a picture frame, you use the Stroke settings in the Graphic inspector. 

To frame a movie:
	 1	 Select it, and then click the Inspector button in the toolbar to open the Inspector 

window. Click the Graphic inspector button in the Inspector window.

	 2	 Choose Picture Frame from the Stroke pop-up menu.

	 3	 Click the picture frame that appears below the Stroke pop-up menu, and select a 
frame style.

	 4	 Drag the Scale slider or specify a percentage to set the thickness of the picture frame.

Adjusting Media Playback Settings
If you don’t want to use an entire audio file or movie in your document or you want to 
limit the playback only to certain parts, you can set this up in the QuickTime inspector. 
You can also set the movie poster frame, which is the frame that displays until the 
movie starts playing, and other playback options. 

Set the playback volume.

Set playback repeat options.

Select the frame to 
display until the movie 

begins playing.

Use these controls to view 
the movie or play sound as 
you edit your document.

The QuickTime inspector 
button

Start and stop a movie at 
particular times.

The Play, Pause, Fast-Forward, and Rewind buttons available in the QuickTime inspector 
can be used to play and preview a movie as you set the playback preferences 
described here.

To set media playback preferences:
	 1	 Click Inspector in the toolbar, and then click the QuickTime inspector button. 

	 2	 Click the movie or sound object to select it.



	 3	 If you want only part of a movie to play, set the start and stop frames or times by 
dragging the Start and Stop sliders. 

To limit playback of an audio file to only certain parts, drag the Start and Stop sliders.

	 4	 To specify which still frame movie viewers will see until the movie starts playing, drag 
the Poster Frame slider until you see the image you want.

	 5	 Choose a repeat option from the Repeat pop-up menu:

None:  Play only once.

Loop:  Repeat continuously.

Loop Back and Forth:  Play backward and forward continuously.

	 6	 To increase or decrease the playback volume, drag the Volume slider to the right  
or left.

Reducing the Size of Media Files
Including large sound and movie files in a Pages document can make the entire 
document file size very large. If you’re using only a portion of the sound or movie file 
in your document can remove the unused portions of the audio or video file to make 
the file smaller. You can choose either to reduce the size of individual media files or to 
reduce the size of all the media files in the document that are not being used in full.

Before you reduce the movie or audio files, you must save them as part of your 
document. For details about how to do this, see “Saving A Document” on page 37. 

Here are ways to reduce the file size of your document:
	 1	 To reduce the size of an individual media file in your document, select a sound or 

movie file for which you have set the Start and Stop sliders to exclude some part of 
the file, and then choose Format > Image > Reduce Media File Size.

	 2	 To reduce the size of all the media files in your document, make sure no sound, movie, 
or image file is selected, and then choose File > Reduce File Size.

After reducing the size of your sound or video file, you won’t be able to restore the file 
to its original length or listen to or view the parts that you have excluded. To restore 
the entire file, you must add the file again.

Some types of movie files may not be reducible in this way.

To learn about reducing the size of image files, see “Reducing Image File Sizes” on 
page 142.
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About Manipulating, Arranging, and Changing the Look of 
Objects
In general, the way you select, arrange, and manipulate objects in Pages works the 
same, whether you’re working with images, shapes, movies, tables, chart elements, or 
text boxes. For most objects, you use the same controls to resize and reorient them, as 
well as to add shadows, reflections, border styles (stroke), fill color or image, and more.

To learn how to Go to

Select one or more objects so you can edit them “Selecting Objects” on page 157

Copy or duplicate an object “Copying or Duplicating Objects” on page 158

Remove an object “Deleting Objects” on page 158

Arrange objects on a page, group them, and  
lock them

“Moving and Positioning Objects” on page 158

Resize objects, change their orientation,  
modify their borders, and perform other  
editing operations

“Modifying Objects” on page 164

Fill objects with a solid color, color gradients,  
or images

“Filling Objects with Colors or Images” on 
page 171

Selecting Objects
Before you can move, modify, or perform other operations on objects, you must select 
them. A selected object has handles that let you move or manipulate the object. 

Here are ways to select and deselect objects:
To select a single object, click anywhere in the object (to select an object that has no mm

fill, click the edge). 

To select several objects on a page, hold down the Shift key as you click objects. All the mm

objects must be floating, or they must all be inline.

To select all the floating objects in a document, hold down the Command key, and mm

then click anywhere outside the text areas so the insertion point isn’t visible. Press 
Command-A.

To select all the inline text and objects in a document, place the insertion point in the mm

text area and press Command-A.

To select an object that’s part of a group, you must first ungroup the objects. Select mm

the group, and then choose Arrange > Ungroup.

To deselect objects in a group of selected objects, hold down the Command key, and mm

then click objects you want to deselect.

To select a master object, first choose Format > Advanced > Make Master Objects mm

Selectable.



To select a floating object that’s behind text, place the pointer outside the text area, mm

hold down the Command key, and then drag across the page until the object’s 
selection handles appear.

Copying or Duplicating Objects
The technique you use to copy an object depends on where you want to place the 
copy. When the copy will be placed far from the original or in another document, 
copying and pasting is generally easier. When you are working with a floating object 
on a page and the copy will be near the original, duplicating is generally easier. 

Here are ways to copy objects:
To copy and paste a floating or inline object, select it, and then choose Edit > Copy. mm

Click where you want the copy to appear. Choose Edit > Paste.  

To duplicate a floating or inline object on a page, hold down the Option key while you mm

drag the object.

You can also select the object and choose Edit > Duplicate. The copy appears on top of 
the original, slightly offset. Drag the copy to the desired location.

You can’t duplicate an inline object. To duplicate an object, it must be floating on  
the page.

To copy an image between Pages documents, select the image and drag its icon from mm

the File Info field in the Metrics inspector to a page in the other Pages document.

Deleting Objects
To delete objects:
Select the object(s) and press the Delete key. mm

If you accidentally delete an object, choose Edit > Undo Delete.

Moving and Positioning Objects
The way you move an object depends on whether it’s a floating or inline object. 
Objects can be grouped together, making it easier to manipulate sets of objects, and 
locked into position to prevent them from being moved while you work. In addition, 
objects can be layered (overlapped) to create the effect of depth. 

Avoid dragging a floating or inline object by its selection handles because you may 
inadvertently resize it.

Here are ways to manipulate objects directly:
To move a floating object, click the object to select it (the selection handles appear), mm

and then drag it to a new location.

To move an inline object, click the object to select it, and then drag it until the mm

insertion point appears where you want the object in the text.
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You can also select the inline object and choose Edit > Cut. Place the insertion point 
where you want the inline object to appear, and then choose Edit > Paste.

To constrain the object’s motion to horizontal, vertical, or a 45-degree angle, start mm

dragging the object while holding down the Shift key.

To move the object in small increments, press one of the arrow keys, causing the mm

object to move a point at a time. To move the object ten points at a time, hold down 
the Shift key while pressing an arrow key.

To show the position of the object when you move it, choose Pages > Preferences, and mm

then select “Show size and position when moving objects” in the General pane.

To move text or an object inside another object, select the object and choose Edit > mm

Cut. Place the insertion point where you want the object to appear, and then choose 
Edit > Paste.

To learn how to Go to

Change the order of overlapping objects “Moving an Object Forward or Backward 
(Layering Objects)” on page 159

Add, edit, and reposition background objects “Moving an Object to the Background” on 
page 160

Align objects “Quickly Aligning Objects Relative to One 
Another” on page 160

Use alignment guides to align objects “Using Alignment Guides” on page 161

Create your own alignment guides that remain 
visible as you work

“Creating Your Own Alignment Guides” on 
page 162

Place objects precisely by using x and y 
coordinates

“Positioning Floating Objects by x and y 
Coordinates” on page 162

Set objects to remain together when you move, 
copy, or paste them

“Grouping and Ungrouping Floating Objects” on 
page 163

Join two objects with a line “Connecting Floating Objects with an Adjustable 
Line” on page 163

Lock objects in place so you don’t inadvertently 
move them

“Locking and Unlocking Floating Objects” on 
page 164

Moving an Object Forward or Backward (Layering Objects)
When floating objects overlap or when text and objects overlap, you can change the 
order of objects in the stack. 

To move a floating object in front or in back of text or another object:
	 1	 Select the object you want to move.  

	 2	 To move an object a layer at a time, choose Arrange > Bring Forward or Arrange > 
Send Backward.



	 3	 To move an object to the very top or bottom of the stack, choose Arrange > “Bring to 
Front” or Arrange > “Send to Back.”

If you’re unable to select an object, it may be a background object. For more 
information about working with background objects, see “Moving an Object to the 
Background” on page 160.

If you frequently layer objects, you can add the Front, Back, Forward, and Backward 
buttons to the toolbar to work more efficiently. To learn about customizing the toolbar, 
see “The Toolbar” on page 21.

Moving an Object to the Background
In your word processing document, you can send an object to the background to have 
it automatically become nonselectable. This enables you to move other objects and 
select text without affecting the object in the background. 

Here are ways to work with background objects:
To make an object a background object, select the object, and then choose Arrange > mm

“Send Object to Background” or select “In background” in the Wrap inspector.

To reposition or edit a background object, choose Arrange > Make Background mm

Objects Selectable or select the “Background objects are selectable” checkbox in the 
Wrap inspector, select the object, and then reposition or edit the object.

To move an object from the background to the foreground of the page, choose mm

Arrange > Make Background Objects Selectable, select the background object, and 
then choose Arrange > “Bring Background Objects to Front.” Now you can move the 
object forward or backward as “Moving an Object Forward or Backward (Layering 
Objects)” on page 159 describes.

To determine whether an object is a background object, choose Arrange > Make mm

Background Objects Selectable, and then move the pointer over the object. If the 
pointer becomes a white arrow, the object is a background object. When you  
move the pointer over an object that’s not a background object, it becomes a black 
arrow instead.

Quickly Aligning Objects Relative to One Another
You can use menu commands to quickly move objects on the same page into 
alignment or space them equally apart. First, you must select all the objects you want 
to align (hold down the Shift or Command key as you click each object to select it). 

To align selected objects:
To align the objects with each other, choose Arrange > Align Objects and then choose mm

one of the alignment options in the submenu.

Left:  Positions objects so that their left edges align vertically to the first object  
you select.
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Center:  Positions objects so that their centers align vertically to the first object  
you select.

Right:  Positions objects so that their right edges align vertically to the first object 
you select.

Top:  Positions objects so that their top edges align horizontally to the first object  
you select.

Middle:  Moves objects vertically so that their centers align horizontally to the first 
object you select.

Bottom:  Positions objects so that their bottom edges align horizontally to the first 
object you select.

To space the objects evenly on a page, choose Arrange > Distribute Objects, and then mm

choose an option from the submenu.

Horizontally:  Adjusts the horizontal spacing between objects.

Vertically:  Adjusts the vertical spacing between objects.

You can also align objects relative to one another by dragging them and using 
alignment guides to determine when the objects are correctly positioned. See “Using 
Alignment Guides” on page 161 for more information.

Using Alignment Guides
Alignment guides appear and disappear as you drag floating objects around a page, 
providing you with instant feedback about relative object position. 

These guides appear only while you’re dragging a floating object. When you let go 
of the floating object, the guides vanish. You can make alignment guides appear in 
different colors so that it’s easier to know what is coming into alignment as you move 
objects around. If you turn on alignment guides or change their color, the settings 
apply to all the documents you open in Pages.

Alignment guides aren’t visible when you print your document; they are visible only 
when you’re editing a document.

Here are ways to manage alignment guides:
To set alignment guide options, choose Pages > Preferences, and then click Rulers. mm

Select the Alignment Guides options that describe when you want alignment guides 
to appear: 

To show guides when an object’s center aligns with another object, select “Show 
guides at object center.” 

To show guides when an object’s edges align with another object, select “Show guides 
at object edges.”



To change the color of alignment guides, click the Alignment Guides color well and mm

select a color in the Colors window.

To momentarily hide guides, hold down the Command key while you drag an object.mm

Another way to align objects is to specify precise object position by using x and y 
coordinates. See “Positioning Floating Objects by x and y Coordinates” on page 162.

Creating your own alignment guides wherever you need them can also help you place 
objects. See “Creating Your Own Alignment Guides” on page 162.

Creating Your Own Alignment Guides
You can create static alignment guides to help you align floating objects on a page. 
These alignment guides do not appear and disappear as you drag floating objects, 
but remain visible while you’re working, even if you leave the page and then return to 
it later. 

To create an alignment guide:
	 1	 Click View in the toolbar, and then choose Show Rulers. 

Note:  Alignment guides can’t be created if you have an insertion point in text,  
such as the body text or header. Select a floating object or Command-click the 
document page.

	 2	 Place the pointer over a ruler and drag onto a page. An alignment guide appears.

	 3	 Drag the guide where you want it on the page.

	 4	 To remove an alignment guide that you’ve created, drag it off the edge of the page.

You can also specify x and y coordinates to place objects precisely. See “Positioning 
Floating Objects by x and y Coordinates” on page 162.

Positioning Floating Objects by x and y Coordinates
You can place floating objects precisely where you want them on a page by specifying 
spatial coordinates using the ruler measurements. 

To specify an floating object’s position by its x and y coordinates:
	 1	 Select the object you want to position. 

	 2	 Click Inspector in the toolbar, and then click the Metrics inspector button.

	 3	 Enter x and y values (in ruler measurements) in the Position fields.

The specified coordinates determine the position of the upper-left corner of the 
object’s container box. If an object is rotated, the x and y coordinates specify the 
upper-left corner of the container box of the rotated object, which may be a different 
size from the original.

The x value is measured from the left edge of the page.ÂÂ

The y value is measured from the top edge of the page.ÂÂ
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When you enter x and y coordinates for line positions in the Metrics inspector, the 
Start coordinates refer to the first endpoint you created (or the upper-left endpoint, 
if you didn’t draw the line). If you later flip or rotate the line, the Start coordinates 
continue to refer to the same endpoint.

Position a floating line on the page by specifying 
x and y coordinates for its second endpoint.

Position a floating line on the page by specifying 
x and y coordinates for its first endpoint.

Another way to align objects quickly is to use built-in alignment guides that appear as 
you drag objects around the page, or to create static alignment guides that help you 
line up objects. See “Using Alignment Guides” on page 161 and “Creating Your Own 
Alignment Guides” on page 162.

Grouping and Ungrouping Floating Objects
You can group floating objects together so that they can be moved, copied, resized, 
and oriented as a single object. 

You can edit text associated with a shape or text object in a group, but you can’t 
modify other attributes of individual objects in the group.

If you can’t select an object or a group of objects, it may be locked; you’ll need to 
unlock it. To learn how, see “Locking and Unlocking Floating Objects” on page 164.

To group objects:
Hold down the Command (or Shift) key as you select the objects you want to group, mm

and choose Arrange > Group.

To ungroup objects:
Select the group, and then choose Arrange > Ungroup. If the group is locked, unlock mm

it first.

To select an individual object that’s been grouped with others:
Click the object you want to edit once to select the group, and again to select the mm

individual object.

If clicking once doesn’t select the individual object you want, it may be nested in many 
layers of grouping. Click again until the object you want is selected.

Connecting Floating Objects with an Adjustable Line
When you want to join two floating objects with a line, the easiest way is to use a 
connection line (rather than creating a separate line as a shape). The two floating 
objects joined by a connection line remain joined even if you reposition the objects. 



To join two floating objects with a connection line:
	 1	 Hold down the Command key while you select the two objects you want to join, and 

then choose Insert > Connection Line.

A straight line appears, connecting the selected objects. You can move the object 
separately, and the connection line shrinks, stretches, and changes its position to keep 
the objects connected.

	 2	 To make the line curved, drag the white editing point near the center of the line.

If you drag the objects into different positions on a page, the curvature of the line 
adjusts to keep the objects connected.

	 3	 To create a gap between the end of the line and one of the connected objects, so that 
they aren’t actually touching, drag the blue editing point at the end of the line away 
from the object it’s touching.

The line maintains the gap between itself and the connected object as you move the 
objects around.

	 4	 To change the line color, style, thickness, or endpoints, format it using the controls in 
the format bar or Graphic inspector, as you would for any other line. For more detailed 
information about changing these attributes, see “Modifying Objects” on page 164.

Locking and Unlocking Floating Objects
You can lock floating objects to avoid inadvertently moving them as you work. Inline 
objects cannot be grouped or locked. 

After you lock individual or grouped objects, you can’t move, delete, or modify them 
in any way until you unlock them. However, a locked object can be selected, copied, or 
duplicated; when you copy or duplicate a locked object, the new object is also locked. 

To lock a floating object:
Select the objects you want to lock, and then choose Arrange > Lock.mm

To unlock a floating object:
Select the objects you want to unlock, and then choose Arrange > Unlock.mm

Modifying Objects
You can resize objects, change their orientation, modify their border styles, add 
shadows and reflections to them, and adjust their opacity. 

To learn how to Go to

Change an object’s size “Resizing Objects” on page 165

Flip or rotate an object “Flipping and Rotating Objects” on page 166

Format a border around objects “Changing the Style of Borders” on page 166
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To learn how to Go to

Place a picture frame around an object “Framing Objects” on page 167

Add shadows to create an appearance of depth “Adding Shadows” on page 168

Add a reflection that reflects vertically downward “Adding a Reflection” on page 169

Make objects more or less opaque “Adjusting Opacity” on page 170

Resizing Objects
You can resize an object by dragging its handles or typing exact dimensions. 

Here are ways to resize objects:
To resize an object by dragging, select the object and then drag one of its selection mm

handles. To resize an object in one direction, drag a side handle instead of a corner 
handle. For inline objects, only the bottom and right-side or right-corner selection 
handles can be used. 

To resize the object from its center, hold down the Option key as you drag.

To maintain an object’s proportions, hold down the Shift key as you drag. You can 
also click Inspector in the toolbar, click the Metrics button, and then select “Constrain 
proportions” before dragging.

To show the size of an object when you drag a selection handle, choose Pages > 
Preferences, and then select “Show size and position when moving objects” in the 
General pane.

To resize an object using exact proportions, select the object, click Inspector in the mm

toolbar, click the Metrics button, and then use the Width and Height controls. 

To resize several objects at once, select the objects, click Inspector in the toolbar, click mm

the Metrics button, and then type new values in the Width and Height fields.

Select the object, and then click Original Size in the Metrics inspector.mm

When you have resized a very large image file, but you only need to use the smaller 
version in your document, you can have Pages keep only a smaller copy of the image, 
thus reducing the overall size of your document. See “Reducing Image File Sizes” on 
page 142.

If you intend to greatly enlarge or reduce a graphic’s dimensions, consider converting 
it to a PDF file before bringing it into Pages. PDF files don’t lose their crispness when 
they are significantly resized. Other file types may not retain their clarity as well when 
they are enlarged or reduced.

Tip:  ∏∏ You can also convert an image on your desktop to a PDF file by using the Grab 
application. Open Grab (it’s in the Applications/Utilities folder on your hard disk). 
Choose Capture > Selection, and then select the image you want to make as a PDF. 
Choose File > Print, and then click Preview to save the image as a PDF.



Flipping and Rotating Objects
You can flip or rotate any object. For example, if you have an image of an arrow that 
you want to use in your document, but you need it to point in a different direction, 
you can reverse its direction vertically or horizontally, or point it at any angle. 

Here are ways to change an object’s orientation:
To flip an object horizontally or vertically, select the object, and then choose Arrange > mm

Flip Horizontally or Arrange > Flip Vertically.  

You can also click Inspector in the toolbar, click the Metrics button, and then use the 
Flip buttons.

To rotate an object, select the object, hold down the Command key and move the mm

pointer toward an active selection handle until it changes to a curved, double-headed 
arrow, and then drag a selection handle.

To rotate an object in 45-degree increments, hold down the Shift and Command keys 
while dragging a selection handle.

You can also click Inspector in the toolbar, click the Metrics button, and then drag the 
Rotate wheel or use the Angle controls to set the angle of the object.

To rotate a shape but keep its text horizontal, after rotating the shape choose mm

Format > Shape > “Reset Text and Object Handles.”

You can’t rotate an inline table. To rotate a table, it must be a floating object.

Changing the Style of Borders
For shapes, chart elements, and text boxes, you can choose a line style and color for 
the object’s border, or you can specify no border. You can also put a border around 
imported images. To change the borders of tables and table cells, see “Formatting 
Table Cell Borders” on page 199. 

Use the format bar to change the line style, line thickness, and line color of the border 
around one or more selected objects. Select the object, and select the line style, line 
thickness, and line color from the controls in the format bar.

You can use the Graphic inspector and the Colors window to make additional 
adjustments.

To set the border style using the Graphic inspector:
	 1	 Select the object that you want to modify. 

	 2	 Click Inspector in the toolbar, and then click the Graphic inspector button.

	 3	 Choose Line from the Stroke pop-up menu. 
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	 4	 Choose a line style from the pop-up menu. 

Enter the line thickness 
in this field.

Choose line endpoints 
from these pop-up menus.

Choose a solid line, 
dotted line, dashed line, 

or another line style.

Click the color well to 
choose a line color.

	 5	 To change the line thickness, type a value in the Stroke field (or click the arrows).

	 6	 To change the line color, click the color well and select a color.

	 7	 To give the line endpoints, such as arrowheads or circles, choose left and right 
endpoints from the pop-up menus.

Framing Objects
Enclose your text boxes, images, movies, shapes, and media placeholders with 
graphical borders, known as picture frames.

To add a picture frame:
	 1	 Select the media or media placeholder, click Inspector in the toolbar, and then click the 

Graphic button.

	 2	 Choose Picture Frame from the Stroke pop-up menu, and then click the thumbnail to 
choose one.  

Click this arrow and 
the thumbnail to 
choose a frame style.

To adjust the thickness of your frame, use the Scale slider or type a specific percentage 
in the adjacent field. (Not all picture frames can be adjusted.)



To change a picture frame:
	 1	 Select a framed object or media placeholder, click Inspector in the toolbar, and then 

click the Graphic button.

	 2	 Choose Picture Frame from the Stroke pop-up menu, and then click the arrow next to 
the thumbnail to choose a new picture frame.

To remove a picture frame:
Select the media or media placeholder, and then choose a line style (or None) from mm

the Stroke pop-up menu.

Adding Shadows
Shadows create an appearance of depth. An object’s shadow appears on any  
object behind it. You can create a variety of shadow effects, or remove the shadow 
from an object. 

To quickly add or remove a shadow, select the object and then select or deselect 
Shadow in the format bar. The Graphic inspector gives you more control over shadow 
formatting.

To add a shadow using the Graphic inspector:
	 1	 Select the object or text. 

	 2	 Click Inspector in the toolbar, and then click the Graphic button.

	 3	 Select Shadow to add a shadow to the object. Deselect Shadow to make a shadow  
go away.  

Change the shadow 
color in the color well.

Change the angle of 
the shadow with the 
Angle wheel.

Offset, Blur, and Opacity 
values change the look 
of the shadow.

Select the checkbox 
to add a shadow to a 
selected object.

	 4	 Set the angle for the shadow using the Angle controls.

	 5	 To set how far the shadow is from the object, use the Offset controls.

A high shadow offset value makes an object’s shadow appear longer and slightly 
separated from the object.
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	 6	 To adjust the softness of the shadow’s edge, use the Blur controls.

A high blur value makes the object’s shadow appear more diffuse; a low value gives 
the shadow more sharply defined edges.

	 7	 To change the shadow’s transparency, set a percentage in the Opacity field. Don’t use 
the Opacity slider at the bottom of the Graphic inspector, which changes the opacity 
of the object (not the object’s shadow).

	 8	 To change the color for the shadow, click the Shadow color well and select a color. 

This object has the default 
shadow properties.

This object’s shadow is set 
to a different angle.

This object’s shadow has 
a high offset value.

This object’s shadow has 
the lowest blur factor.

This object has a different 
shadow color.

This object’s shadow has 
a high blur factor.

Adding a Reflection
You can add a reflection to an object that reflects vertically downward. 

To quickly add or remove a reflection, select the object, and then select or deselect 
Reflection in the format bar. The Graphic inspector gives you more control over 
reflection formatting.

To add a reflection to an object using the Graphic inspector:
	 1	 Select the object. 

	 2	 Click Inspector in the toolbar, and then click the Graphic button.



	 3	 Select Reflection and drag the slider to increase or decrease the amount of reflection. 

Adjusting Opacity
You can create interesting effects by making objects more opaque or less opaque. 

When you put a low-opacity object on top of another object, for example, the bottom 
object shows through the top object. Depending on how high or low you set the 
opacity, the objects below can be highly visible, partly obscured, or completely 
blocked from view (at 100-percent opacity). 

To change an object’s opacity:
	 1	 Select the object.

	 2	 Click Inspector in the toolbar, and then click the Graphic button.

	 3	 Drag the Opacity slider or enter a percentage in the adjacent field.  

For shapes, you can set opacity for fill and stroke colors separately from object opacity. 
If you move the Opacity slider in the Colors window to modify a fill or stroke color, that 
opacity value becomes maximum object opacity. Then, when you change the object 
opacity in the Graphic inspector, you are changing it relative to the opacity you set in 
the Colors window. 

This circle is set to 100% opacity in the 
Graphic inspector. The fill color was set 
to 50% opacity in the Colors window. 
The circle’s outline was set to 100% 
opacity in the Colors window.

This circle is set to 100% 
opacity in the Graphic 
inspector.

This circle is set to 50% opacity 
in the Graphic inspector.

If you change an object’s opacity and then can’t restore the object’s fill color to 100 
percent, it may be because the opacity was set to less than 100 percent in the Colors 
window. To fix it, select the object, choose View > Show Colors, and then set the 
opacity in the Colors window to 100 percent.
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Filling Objects with Colors or Images
You can fill shapes, tables, table cells, and chart elements with a solid color, color 
gradients (colors that shade into each other), or an image. 

To learn how to Go to

Add a solid-color background to an object “Filling an Object with a Solid Color” on page 171

Add a background of colors that blend into  
each other

“Filling an Object with Blended Colors 
(Gradients)” on page 171

Place an image inside an object “Filling an Object with an Image” on page 173

Filling an Object with a Solid Color
You can fill shapes, tables, table cells, and chart elements with a solid color. 

Use the format bar to quickly add a fill color to an object. Select the object, click the 
Fill well, and then choose a color from the color matrix or click Show Colors to  
open the Colors window for more choices. Use the Opacity control to adjust the 
degree of transparency.

You can also use the Graphic inspector to fill an object with a solid color.

To change an object’s fill color using the Graphic inspector:
	 1	 Select the object.  

	 2	 Click Inspector in the toolbar, and then click the Graphic button.

	 3	 Choose Color Fill from the Fill pop-up menu.

	 4	 Click the color well below the Fill pop-up menu to open the Colors window, and then 
select a color in the Colors window.

To learn more about using the Colors window, see “The Colors Window” on page 26.

Filling an Object with Blended Colors (Gradients)
You can fill shapes, tables, table cells, and chart elements with colors that blend into 
each other, called color gradients. 

To create color gradients in an object fill, use the options in the Graphic inspector. The 
basic Gradient Fill options provide the easiest way to blend two colors in a straight 
line. The Advanced Gradient Fill options allow you to blend multiple colors in your 
gradient and to create a circular (radial) gradient.



To fill an object with a linear, two-color gradient:
	 1	 In the Graphic inspector, choose Gradient Fill from the Fill pop-up menu. 

Click the double-headed 
arrow to invert the gradient.

Flip the gradient orientation or 
set its direction by using the 
arrow buttons or the Angle 
wheel, or by typing a value.Click each color well 

to select colors.

	 2	 Click each color well and choose the colors you want to blend together in the  
Colors window.

To learn more about using the Colors window, see “The Colors Window” on page 26.

	 3	 To set a direction for the gradient, use the Angle wheel or field.

	 4	 To flip it horizontally or vertically, click the Angle arrow buttons.

	 5	 To invert the gradient, click the double-headed arrow next to the color wells.

To fill an object with a multi-color gradient:
	 1	 In the Graphic inspector, choose Advanced Gradient Fill from the Fill pop-up menu. 

	 2	 To add another color to the gradient, hold the pointer at the point just below the 
gradient strip in the inspector where you want the new color to begin. When a plus (+) 
sign appears, click to add a new color control. Add a new color control for each color 
you want to appear in your gradient.

	 3	 To change a color in the gradient, click a color control (just under the gradient strip), 
and then select a color from the Colors window. Do this for each of the colors you 
want to appear in your gradient.

	 4	 If you want to remove a color control, drag it downward and away from the inspector. 
It vanishes.

You can’t have fewer than two color controls under the gradient strip.

	 5	 To change how sharply or subtly the colors blend along the gradient, drag the blend 
point controls (on top of the gradient strip in the inspector).

	 6	 To change the direction of a linear gradient, use the Angle wheel or field.
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	 7	 To create a radial gradient, click the radial gradient button. You can further adjust the 
look of a radial gradient by doing any of the following: 

To recenter the gradient in the object, drag the small, blue, circular blend point ÂÂ
control (in the center of the gradient within your object) to where you want the 
center to be.

To change how sharply or subtly the colors blend along the gradient, drag ÂÂ
the circular blend point control, outside your object, closer or farther from the 
gradient’s center.

Experiment with the circular blend point controls attached to your object and the 
blend point controls above the gradient strip in the Graphic inspector, dragging 
them until you create the look you want.

	 8	 To invert the gradient, click the double-headed arrow next to the color wells.

Filling an Object with an Image
You can fill a shape, text box, table, table cell, chart background, or chart series with 
an image. 

To fill an object with an image:
	 1	 Select the object you want to fill with an image. 

	 2	 If the Graphic inspector isn’t open, click Inspector in the toolbar and click the  
Graphic button.

	 3	 In the Graphic inspector, choose Image Fill or Tinted Image Fill, and then choose  
an image.

You can also drag an image file from the Finder or Media Browser to the image well in 
the Graphic inspector or to a table cell or chart series.  

Use the pop-up menu to 
set the size of the image 
within the object.

To change the image, 
drag an image to the 
image well.

	 4	 Choose an image scale from the pop-up menu.

Scale to Fit:  Resizes the image to fit the object’s dimensions as well as possible. If the 
object’s shape is different from that of the original image’s, parts of the image may not 
appear; blank space may also appear around the image.



Scale to Fill:  Makes the image appear larger or smaller, sizing it to leave minimum 
space around the image, even if the object and image have different shapes. 

Stretch:  Sizes the image to fit the object’s dimensions but distorts it if the object has a 
shape different from that of the original image.

Original Size:  Places the image inside the object without altering its original 
dimensions. If the image is larger than the object, you see only a part of the image in 
the object. If the image is smaller than the object, there is blank space around it.

Tile:  Repeats the image inside the object, if the image is smaller than the object. If the 
image is larger than the object, you see only part of the image inside the object. 

Scale to Fit Stretch

Original Size

Tile (large image)

Scale to Fill

Tile (small image)

Tile (large image)

	 5	 If you chose Tinted Image Fill, click the color well (to the right of the Choose button) 
to choose a tint color. Drag the Opacity slider in the Colors window to make the tint 
darker or lighter. (If you drag the Opacity slider in the Graphic inspector, it will change 
the opacity of both the tint and the image.)  

Click to select a tint color 
for the image.

Adding Mathematical Expressions and Equations Using 
MathType
If you have MathType 6 installed, you can open it within Pages and use it to type 
mathematical expressions and equations. After you’ve created an equation in 
MathType 6, you can manipulate the equation as an image in Pages. 

To type an equation using MathType 6 within Pages:
	 1	 Place the pointer where you want the equation to appear.

	 2	 Choose Insert > MathType Equation.

MathType 6 opens and the equation “E=mc2“ appears.
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	 3	 Double-click the equation and type the equation you want, using the MathType 6 
application window and tools.

Refer to MathType 6 Help for specific instructions on how to use this product.

	 4	 When you’ve finished typing your equation, choose File > “Close and Return to Pages,” 
and then click Yes in the window that appears to save the equation.

	 5	 Drag the equation to wherever you want it on the page.

After you’ve closed MathType 6, Pages treats the equation as an object that you can 
reposition, resize, reorient, group, layer, or even mask like an image. However, if you 
mask the equation, you must unmask it in order to edit it further.

	 6	 To edit the equation, double-click it to open MathType 6 again.
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This chapter explains how to add and format tables and their 
rows and columns.

Tables help you organize, analyze, and present data.

Pages provides a wide variety of options for building and formatting tables and 
handling values of different types. You can also use special operations such as 
sorting and conditional formatting (a technique for automating the monitoring 
of cell values). To learn more about working with table cells and their content, see 
Chapter 9, “Working with Table Cells,” on page 191.

Working with Tables
Use a variety of techniques to create tables and manage their characteristics, size, and 
location.

To learn how to Go to

Insert tables “Adding a Table” on page 176

Use table tools “Using Table Tools” on page 177

Make tables larger or smaller “Resizing a Table” on page 179

Relocate tables “Moving Tables” on page 180

Apply color and other visual effects to tables “Enhancing the Appearance of Tables” on 
page 180

Convert text into a table and vice versa “Converting Text to a Table” on page 181

Share tables among iWork applications “Copying Tables Among iWork Applications” on 
page 181

Adding a Table
While some templates contain one or more predefined tables, you can add tables to 
your Pages document.  

8Using Tables
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Here are ways to add a table:
Click Table in the toolbar.mm

Choose Insert > Table.mm

To create a new table based on one cell or several adjacent cells in an existing table, mm

select the cell or cells and then drag the selection to an empty location on the page. 
Values in the original table’s cells are retained. 

See “Selecting Tables and Their Components” on page 182 to learn about cell selection 
techniques.

To draw a table on the page, hold down the Option key and click Table in the toolbar. mm

Release the Option key and move the pointer over the page until it becomes a 
crosshair. Drag to create a table of the size you want. 

As you drag, the number of rows and columns increases or decreases with the size of 
the table. To size the table from the center, press the Option key while dragging.

Using Table Tools
You can format a table and its columns, rows, cells, and cell values using various Pages 
tools. 

Here are ways to manage table characteristics:
Select a table and use the format bar to quickly format the table. “mm Selecting a Table” on 
page 182 describes how to select a table.

Arrange text in 
table cells.

Select paragraph and 
character styles.

Set the number of 
rows and columns.

Add background 
color to a cell.

Open the 
Styles drawer.

Format text in 
table cells.



Use the Table inspector to access table-specific controls, such as fields for precisely mm

controlling column width and row height, add headers and a footer, format borders, 
and more. To open the Table inspector, click Inspector in the toolbar, and then click the 
Table button.

Adjust the size of 
rows and columns.

Set the style, width, and 
color of cell borders.

Add color or an image 
to a cell.

Change the behavior of the Return key.

Control the visibility 
of header cells in 
multipage tables.

Click to open the Edit Rows 
& Columns pop-up menu.

Set the number of 
rows and columns. Add and remove a header 

row, a header column, and 
a footer row.

Use the Format pane of the Table inspector to format table cell values. For example, mm

you can display a currency symbol in cells containing monetary values.

You can also set up conditional formatting. For example, you can make a cell red when 
its value exceeds a particular number.

The comma is used as the 
thousands separator.

A $ is displayed in front of 
numbers in the cells. 

Numbers are displayed 
using two decimal places.

Select to wrap in 
selected cells.
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Use the Graphic inspector to create special visual effects, such as shadows. To open the mm

Graphic inspector, click Inspector in the toolbar and then click the Graphics button.

Access a shortcut menu by selecting a table or one or more cells and then holding mm

down the Control key as you click again.

You can also use the Edit Rows & Columns pop-up menu in the Table inspector.

Use the Formula Editor to add and edit formulas and the Function Browser to add and mm

edit functions. For more information about this topic, choose Help > “iWork Formulas 
and Functions Help” or Help > “iWork Formulas and Functions User Guide.”

Resizing a Table
You can make a table larger or smaller by dragging one of its selection handles or 
by using the Metrics inspector. You can also change the size of a table by resizing its 
columns and rows. 

Before resizing a table, you must select it, as “Selecting a Table” on page 182 describes.  

Here are ways to resize a selected table:
Drag one of the square selection handles that appear when a table is selected. For inline mm

tables in a word processing document, only the active selection handles can be used.

Drag an active selection handle to 
resize an inline or floating table.

To maintain a table’s proportions, hold down the Shift key as you drag to resize  
the table.

To resize from the table’s center, hold down the Option key as you drag.

To resize a table in one direction, drag a side handle instead of a corner handle. For 
inline tables, only the active selection handles can be used.



To resize by specifying exact dimensions, click Inspector in the toolbar, and then click mm

the Metrics button. In this pane, you can specify a new width and height, control the 
angle of rotation, and change the table’s distance from the margins.

If a table spans more than one page, you must use the Metrics inspector to resize  
the table.

To resize by adjusting the dimensions of rows and columns, see “mm Resizing Table Rows 
and Columns” on page 188.

Moving Tables
You can move a table by dragging it, or you can relocate a table using the  
Metrics inspector.  

Here are ways to move a table:
To move a floating table, select the table and drag.mm

To move an inline table, click the table to select it, and then drag it until the insertion mm

point appears where you want the table in the text.

You can also select the table and choose Edit > Cut. Place the insertion point where 
you want the table to appear, and then choose Edit > Paste.

To constrain the movement to horizontal, vertical, or 45 degrees, hold down the Shift mm

key as you drag.

To move a table more precisely, click any cell, click Inspector in the toolbar, click the mm

Metrics button, and then use the Position fields to relocate the table.

To copy a table and move the copy, hold down the Option key, press at the edge of an mm

unselected table or an entire table that’s selected, and drag.

Enhancing the Appearance of Tables
You can apply color, use images, and use other formatting techniques to enhance the 
visual appeal of your tables. 

Here are ways to enhance a table’s appearance:
You can fill the background of an entire table or individual cells with different kinds of mm

color effects or with an image. See “Filling an Object with a Solid Color” on page 171 
and “Filling an Object with an Image” on page 173 for instructions.

You can change the thickness and color of borders around a table and its cells, as mm

“Formatting Table Cell Borders” on page 199 describes.

You can adjust the attributes of text in table cells, including header and footer cells. mm

See “Formatting Text Size and Appearance” on page 82 and “Setting Text Alignment, 
Spacing, and Color” on page 90 for details.
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When you’ve created a visual effect that you want to reuse, you can copy and paste it. 
Select the table or cells whose effects you want to reuse, choose Format > Copy Table 
Style, select the table or cells you want to format, and then choose Format > Paste 
Table Style.

Converting Text to a Table
You can quickly convert text into a table and vice versa. 

Here are ways to convert between text and tables:
To convert text to a table, select the text, and choose Format > Table > “Convert Text mm

to Table.”

When Pages encounters a paragraph return, it creates a new row. When Pages 
encounters a tab stop, it creates a new column.

To convert a table to text, select the table, and choose Format > Table > “Convert mm

Table to Text.”

Copying Tables Among iWork Applications
You can copy a table from one iWork application to another.  

The table retains its appearance, data, and other attributes, but some Pages features 
aren’t supported in the other applications:

Rows or columns that are hidden in Pages aren’t visible in the other applications.ÂÂ

Comments added to Pages table cells aren’t copied.ÂÂ

To copy a table from one iWork application to another:
	 1	 Select the table you want to copy, as “Selecting a Table” on page 182 describes.

	 2	 Choose Edit > Copy.

	 3	 In the other application, set an insertion point for the copied table, and then choose 
Edit > Paste.  



Selecting Tables and Their Components
You select tables, rows, columns, table cells, and table cell borders before you work 
with them. 

To learn how to Go to

Select tables “Selecting a Table” on page 182

Select a table cell “Selecting a Table Cell” on page 182

Select a group of table cells “Selecting a Group of Table Cells” on page 183

Select a row or a column “Selecting a Row or Column in a Table” on 
page 183

Select cell borders “Selecting Table Cell Borders” on page 184

Selecting a Table
When you select a table, selection handles appear on the edges of the table.  

Here are ways to select a table:
If a cell isn’t selected, click anywhere in the table.mm

If a table cell is selected, press Command-Return, or click outside the table, and then mm

click anywhere in the table.

Selecting a Table Cell
When you select a cell, the border of the selected cell is highlighted.  

To select a single table cell:
Select the table, and then click the cell.mm

When a cell is selected, use the Tab, Return, and arrow keys to move the selection to 
an adjacent cell. Selecting “Return key moves to next cell” below Table Options in the 
Table inspector sometimes changes the effect of the Return and Tab keys.
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To select If “Return key” option is 
selected

If “Return key” option isn’t 
selected

The next cell to the right Press Tab.

If you press Tab when the last 
cell in a column is selected, a 
new column is added.

If you add or change data in the 
last column, press Tab twice to 
add a new column.

Press Tab.

If you press Tab in the last 
column, the first cell in the next 
row is selected.

If you press Tab in the last cell of 
the table, a new row is added.

The previous cell Press Shift-Tab. Press Shift-Tab.

If you press Shift-Tab in the first 
cell, the last cell is selected.

The next cell down Press Down Arrow or Return.

If you’ve been using the Tab 
key to navigate between cells, 
pressing Return selects the next 
cell down from the cell in which 
you started tabbing.

If you press Return when the 
last cell in a row is selected, a 
new row is added.

If you add or change data in the 
last cell, press Return twice to 
add a new row.

Press Down Arrow.

The next cell up Press Up Arrow or Shift-Return. Press Up Arrow or Shift-Return.

Selecting a Group of Table Cells
You can select adjacent or nonadjacent cells. 

Here are ways to select a group of cells:
To select adjacent table cells, select a single cell, and then hold down the Shift key as mm

you select adjacent cells.

You can also click a cell, press, and then drag through a range of cells.

To select nonadjacent table cells, hold down the Command key as you select cells. Use mm

Command-click to deselect a cell in the group.

Selecting a Row or Column in a Table
The fastest way to select entire rows and columns is to use the Table inspector. 

Here are ways to select rows and columns:
To select a single row or column, choose Select Row or Select Column from the Edit mm

Rows & Columns pop-up menu in the Table inspector.

You can also use the techniques described in “Selecting a Group of Table Cells.”



To select multiple rows, select two or more vertically adjacent cells before choosing mm

Select Row.

To select multiple columns, select two or more horizontally adjacent cells before mm

choosing Select Column.

Selecting Table Cell Borders
Select cell border segments when you want to format them. A single border segment is 
one side of a cell. A long border segment includes all adjacent single border segments.  

Here are ways to select border segments:
To select specific borders for multiple cells, select the table, row, column, or cells, click mm

Inspector in the toolbar, and then click the Table button. Click one of the Cell Borders 
buttons in the Table pane.

To select a border, select the table and click the border. If the table isn’t selected, mm

double-click the border.

When a table border is selected, clicking another border selects the border. Clicking 
the same border selects a segment.

To select a border segment, select the table and double-click the segment. If the table mm

isn’t selected, click a segment three times. To select (or deselect) additional segments, 
press the Shift or Command key while you click.

When a segment is selected, clicking another segment selects the segment. Clicking 
the same segment selects the border.

When a cell, border, or segment is selected, the pointer appears to straddle the border 
or segment. You can drag these pointers to move a border.

The pointer looks like this when 
it’s over a horizontal segment.

The pointer looks like this when 
it’s over a vertical segment.

Working with Rows and Columns in Tables
You can quickly add or remove rows and columns, create header rows or columns or 
footer rows, and more. 

When you insert, remove, resize, hide, or show rows or columns in a table, other 
objects on the page may be moved to avoid overlapping or to maintain relative object 
positions. To prevent automatic movement of objects, choose Pages > Preferences and 
in the General pane deselect “Automatically move objects when tables resize.”
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To learn how to Go to

Insert new rows into a table “Adding Rows to a Table” on page 185

Insert new columns into a table “Adding Columns to a Table” on page 186

Delete rows and columns “Deleting Table Rows and Columns” on page 186

Use header rows and header columns “Adding Table Header Rows or Header 
Columns” on page 187

Use footer rows “Adding Table Footer Rows” on page 188

Resize rows and columns “Resizing Table Rows and Columns” on page 188

Give every other row in a table a different 
background color

“Alternating Table Row Colors” on page 189

Sort rows in ascending or descending order using 
the value of cells in one or more columns

“Sorting Rows in a Table” on page 190

Adding Rows to a Table
You can add rows within a table or at the end of a table. 

If the table contains a footer row, rows added at the bottom of the table are added 
above the footer row.  

If all the body cells in a column above the new row contain the same formula, the 
formula is repeated in the new row. 

Here are ways to add rows:
To add a single row, select a cell, and then choose Format > Table > Add Row Above or mm

Add Row Below. 

You can also choose these commands from the Edit Rows & Columns pop-up menu in 
the Table inspector.

To add multiple rows, select the number of rows you want to add (select three rows if mm

you want to add three rows). To add rows after a particular row, make sure the bottom 
row selected is the one after which you want the new rows added; to add rows before 
a particular row, make sure the top row selected is the one before which you want the 
new rows added. Then choose one of the commands described above. 

To add a row at the end of the table, press Return while the last cell is selected.  mm

Press Return twice if you’ve just added or changed the cell value and you’re still 
editing the cell.

If “Return key moves to next cell” below Table Options in the Table inspector isn’t 
selected, press Tab instead from the last cell in the row. 

To add one or more rows at the end of a table, use the Rows controls in the Table pane mm

of the Table inspector.  



You can also add one or more columns to the right side of the table by using the 
format bar.

You can split cells into two equal rows. “mm Splitting Table Cells” on page 199 describes how.

Adding Columns to a Table
You can add new columns to a table. 

Here are ways to add columns:  
To add a single column, select a cell and then choose Format > Table > Add Column mm

Before or Add Column After. 

You can also choose these commands from the Edit Rows & Columns pop-up menu in 
the Table inspector.

To add multiple columns, select the number of columns you want to add (select three mm

columns to add three columns). To add columns after a particular column, make sure 
the rightmost column selected is the one after which you want the new columns 
added; to add columns before a particular column, make sure the leftmost column 
selected is the one before which you want the new columns added. Then choose one 
of the commands above.

You can use the Tab key to add a column to the right side of the table when “Return mm

key moves to next cell” below Table Options in the Table inspector is selected.

Press Tab once when the last cell is selected. Press Tab twice if you’ve just added or 
changed the cell value.

To add one or more columns to the right side of a table, use the Columns controls in mm

the Table pane of the Table inspector.

You can also use the format bar.

You can split cells into two equal columns. “mm Splitting Table Cells” on page 199  
explains how.

Deleting Table Rows and Columns
There are several techniques available for deleting one or more rows or columns of  
a table.  

Here are ways to delete rows or columns:
Select one or more rows or columns or a cell in a row or column, and then choose mm

Format > Table > Delete Row or Format > Table > Delete Column.

To delete one or more rows or columns, select them and then choose Delete Row or mm

Delete Column from the Edit Rows & Columns pop-up menu in the Table inspector. 
You can also access these commands by choosing Format > Table > Delete Row or 
Format > Table > Delete Column.

 You can also delete rows and columns by using the format bar controls.
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Adding Table Header Rows or Header Columns
Use header rows and columns when you want to label rows and columns. Header 
rows and columns are formatted so that they stand out from the other (body) rows 
and columns. Header rows are always directly above the topmost body row. Header 
columns are always directly to the left of the leftmost body column. 

You can use as many as five header rows and five header columns. Multiple headers 
are useful when you want to assign names to two or more header columns or header 
rows. To format a header to span rows or columns, merge the header cells, as “Merging 
Table Cells” on page 198 describes. 

If a table contains both header rows and header columns, the top left cell or cells are 
considered to be part of the header row. Header columns appear below any header rows.

If an inline table spans pages, columns, or text boxes and you want to repeat header 
rows in each, choose Format > Table > Header Rows > “Repeat Header Rows on Each 
Page.” Editing the text or changing the look of a header row in one place changes it 
consistently throughout the table.

Here are ways to add or delete header rows or header columns:
Select a table or an element in it. Click Inspector in the toolbar, click the Table button, mm

click Table, and then click the appropriate Headers & Footer button. Choose the 
number of header rows or header columns from the pop-up menu.

Select a table or an element in it, and then choose Format > Table > Header Rows or mm

Table > Header Columns. Then choose the number of header rows or header columns 
from the submenu.

If a table spans pages and you want to repeat headers at the top of each page, click mm

Inspector in the toolbar, click the Table button, click Table, click the Headers button, 
and then choose “Repeat Header Cells on Each Page.”

Header cells play an important role in making formulas in table cells easier to read 
and create. For more information about this topic, choose Help > “iWork Formulas and 
Functions Help” or Help > “iWork Formulas and Functions User Guide.”



Adding Table Footer Rows
Use footer rows when you want to draw attention to the bottom rows of a table. 
Footer rows are formatted so that they stand out from the other (body) rows. A footer 
row consists of the bottommost cell in each column. 

You can use as many as five footer rows. To format a footer to span columns, merge 
the footer cells, as “Merging Table Cells” on page 198 describes. 

Here are ways to add or delete footer rows:
Select a table or an element in it. Click Inspector in the toolbar, click the Table button, mm

click Table, and then click the appropriate Headers & Footer button. Choose the 
number of footer rows from the pop-up menu. 

Select a table or an element in it, and then choose Format > Table > Footer Rows. Then mm

choose the number of footer rows from the submenu.

Resizing Table Rows and Columns
Resize all rows and columns so they’re equal in size, or resize only specific rows and 
columns in a table.  

Here are ways to resize rows and columns:
To make all rows the same size, select the table, and then choose Format > Table > mm

Distribute Rows Evenly.

To make all columns the same size, select the table or one or more rows, and then mm

choose Format > Table > Distribute Columns Evenly. 

To resize a single row, select a cell in the row and use the Row Height field in the Table mm

pane of the Table inspector.

To resize a single column, select a cell in the column and use the Column Width field in mm

the Table pane of the Table inspector.

To make several rows the same size, select one or more cells in the rows and choose mm

Format > Table > Distribute Rows Evenly. The rows don’t have to be adjacent.

You can also use the Row Height field in the Table pane of the Table inspector.
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To make several columns the same size, select one or more cells in the columns  mm

and choose Format > Table > Distribute Columns Evenly. The columns don’t have to be 
adjacent.

You can also use the Column Width field in the Table pane of the Table inspector.

To shrink a row or column to remove unused space when cell values don’t fill their mm

cells, select a cell and select “Automatically resize to fit content” in the Table inspector.

Alternating Table Row Colors
Use a different color background for alternate rows to give a table a banded effect.  

To alternate row colors:
	 1	 Select the table or an element in it.

	 2	 Click Inspector in the toolbar and then click the Table button.

	 3	 Select Alternating Row Color.

	 4	 Click the adjacent color well to open the Colors window, and then choose a color for 
the alternate rows. See “The Colors Window” on page 26 for instructions.

	 5	 To change the fill attributes of the other rows, use the Cell Background controls in the 
Table inspector. See “Filling an Object with a Solid Color” on page 171 for instructions.



Sorting Rows in a Table
You can arrange values in some or all the cells in a column in ascending or descending 
order. Rows containing cells being sorted are reordered. Header cells aren’t sorted.  

Sorting takes into account values in hidden rows and hidden columns.

Here are ways to sort:
To sort an entire table by reordering all the cells in a column, select one of the mm

column’s cells, open the Table inspector, click Table, and then choose Sort Ascending or 
Sort Descending from the Edit Rows & Columns pop-up menu.

To sort part of a table by reordering some of the cells in a column, select the cells mm

before choosing Sort Ascending or Sort Descending.

The following table describes how different types of data are sorted in ascending or 
descending order.

Type of data Ascending order Descending order

Text aA–zZ Zz–Aa

Dates Year (earliest first), then month 
(January first), then day (1–31)

Year (most current first), then 
month (December first), then 
day (31–1)

Numbers –2, –1, 0, 1, and so on 1, 0, –1, –2, and so on

Cells containing only text,  
mixed with cells containing  
only numbers

–2, –1, 0, 1, and so on, then 
aA–zZ

Zz–Aa, then 1, 0, –1, –2, and so 
on

Cells containing a mixture of 
text and numbers

Values starting with numbers 
first (1z, 1Z, a1, A1)

Values starting with text first 
(A1, a1, 1A, 1z)

Empty cells At the bottom At the bottom

Boolean (TRUE, FALSE) Below text and above an  
empty cell

Above text
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This chapter describes how to work with table cells and 
their content.

Putting Content into Table Cells
Use a variety of techniques to add content to table cells. 

To learn how to Go to

Add, replace, copy, paste, and move table  
cell values

“Adding and Editing Table Cell Values” on 
page 191

Format and align text in table cells and use find-
and-replace and spell-checking features

“Working with Text in Table Cells” on page 192

Work with numeric table cell values “Working with Numbers in Table Cells” on 
page 193

Use autofilling to automatically repeat a cell  
value in adjacent cells

“Autofilling Table Cells” on page 193

Adding and Editing Table Cell Values
You can add, change, and delete the content in cells.  

Here are ways to add and edit values:
If the cell is empty, select it, and then type a value. “mm Selecting a Table Cell” on page 182 
describes how to select cells.

To replace specific content already in the cell, select the cell, and then select what you mm

want to replace by double-clicking; hold down the Shift key and select more content if 
you want to replace more. Type to replace the selected content.

To replace everything in the cell, select the cell and then begin typing.mm

If “Return key moves to next cell” isn’t selected in the Table inspector, you can also 
select the cell and then press Return or Enter, which selects everything in the cell, and 
then start typing.

9Working with Table Cells



To insert content within existing content, select the cell, click to set the insertion point, mm

and begin typing.

To undo changes made to a table cell since selecting the cell, press Esc.mm

To delete the content of table cells, rows, or columns, select the cells, rows, or columns mm

and then press the Delete key or choose Edit > Delete.

To delete the contents, background fill, and any style settings, choose Edit > Clear All. 
The default style is applied to the selection.

To copy, paste, and move cell values, see the instructions in “mm Copying and Moving 
Cells” on page 200.

Add formulas and functions to cells. For more information about this topic, choose mm

Help > iWork Formulas and Functions Help or Help > iWork Formulas and Functions 
User Guide.

Working with Text in Table Cells
You can control the format and alignment of text in table cells, and you can use find-
and-replace and spell-checking features.  

When you type text into a cell, Pages displays text that might be used to complete the 
cell content based on similar text elsewhere in the table. You can use the suggested 
text if it’s appropriate, or you can keep typing to override suggestions. To disable auto-
suggestions, deselect “Show auto-completion list in table columns” in the General pane 
of Pages preferences. 

Here are techniques for working with text in table cells:
To insert a line break, press Option-Return.mm

To insert a paragraph break, if “Return key moves to next cell” below Table Options in mm

the Table inspector isn’t selected, press Return. Otherwise, press Option-Return. 

To insert a tab in a table, press Option-Tab.mm

To adjust text alignment, use the alignment buttons in the format bar.mm

Align text to the left, center, right; justify text; or 
align text to the left and numbers to the right.

Align text to the top, middle, 
or bottom of cells.

The Text inspector gives you additional text formatting options (click Inspector in the 
toolbar and click the Text inspector button).

See “Setting Text Alignment, Spacing, and Color” on page 90 for more information. 

To control font attributes, use the text formatting buttons in the format bar.mm
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You can also use the Font window (click Fonts in the toolbar). 

See “Formatting Text Size and Appearance” on page 82 for additional information.

To check spelling, follow the instructions in “mm Checking for Misspelled Words” on 
page 118.

To find and optionally replace text in cells, follow the instructions in “mm Finding and 
Replacing Text” on page 120.

To avoid having Pages interpret what you type as a number, use the text format. See mm

“Using the Text Format in Table Cells” on page 207 for details.

Note:  Text strings are ignored in functions that use values to perform calculations.

Working with Numbers in Table Cells
Some table operations, such as formulas and functions that perform mathematical 
operations, depend on cells containing numeric values. 

Here are techniques for working with numbers in table cells:
In a numeric cell use only numbers (0 through 9) or one of the following characters: mm

plus sign (+), minus sign (–), left or right parenthesis ( ), forward slash (/), currency 
symbol (for example, $), percent sign (%), period (.), capital E, or lowercase e.

You can type some characters (such as %) into a cell, or you can use a cell format, as mm

“Formatting Table Cell Values for Display” on page 201 describes.

To specify a negative number, precede it with the minus sign (–).mm

When you put a number in a table cell that’s too large to display, Pages converts  
the number:

When a decimal number doesn’t fit in a cell, the number is rounded. For example, ÂÂ
1.77777777777777777777 becomes 1.77777777777778.

When a whole number doesn’t fit in a cell, the number is displayed using scientific ÂÂ
notation. For example, 77777777777777777777 becomes 7.777778E+19.

Scientific notation displays numbers using an exponent raised by the power of 10. 
The exponent is displayed following the E.

If the converted number still doesn’t fit, it’s clipped. See “Displaying Content Too Large 
for Its Table Cell” on page 194 for suggestions.

Use formulas and functions in table cells. For more information about this topic, 
choose Help > “iWork Formulas and Functions Help” or Help > “iWork Formulas and 
Functions User Guide.”

Autofilling Table Cells
With autofilling you can use the content in one or more cells to automatically add 
values to adjacent cells. 



Here are ways to autofill table cells:
To paste the content and fill of a cell into adjacent cells, select the cell and then drag mm

the Fill handle (a small circle in the cell’s lower right corner) over the cells into which 
you want to paste.

Any data, cell format, formula, or fill associated with the selected cell is pasted, but 
comments aren’t pasted. If any target cell contains data, autofilling overwrites that 
data with the value you’re repeating. 

To paste the content and fill of a cell into one or more cells in the same row or column, mm

select two or more adjacent cells and choose one of the following. 

Format > Table > Fill > Fill Right:  Assigns selected cells the value in the leftmost 
selected cell.

Format > Table > Fill > Fill Left:  Assigns selected cells the value in the rightmost 
selected cell.

Format > Table > Fill > Fill Up:  Assigns selected cells the value in the bottommost 
selected cell.

Format > Table > Fill > Fill Down:  Assigns selected cells the value in the topmost 
selected cell.

Any data, cell format, formula, or fill associated with the selected cell is pasted, but 
comments aren’t pasted. If any target cell contains data, autofilling overwrites that 
data with the value you’re repeating.

You can also add values to cells based on value patterns. For example, if a cell contains mm

a day of the week or a month, you can select the cell, and then drag to the right or 
down to add the next day of the week or month to the adjacent cell.

To create new values based on numeric patterns, select two or more cells before 
dragging. For example, if two selected cells contain 1 and 2, the values 3 and 4 are 
added when you drag through the adjacent two cells. And if two selected cells contain 
1 and 4, the values 7 and 10 are added when you drag through the adjacent two cells 
(values are incremented by 3).

Autofilling doesn’t set up an ongoing relationship among cells in the group. After 
autofilling, you can change the cells independently of each other.

Displaying Content Too Large for Its Table Cell
When a cell is too small to display all its content, a clipping indicator (a small plus sign 
in the bottom right corner of the cell) appears.  

The clipping indicator appears 
when a table cell contains more 
content than can be seen.
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You can enlarge a cell so that it displays more content, or you can let the cell’s content 
spill into adjacent blank cells.

To avoid clipping and spilling, you can set up a table so that all its cells automatically 
shrink or expand in height to accommodate content by selecting “Automatically resize 
to fit content” in the Table inspector’s Table pane.

Here are ways to handle content too large for a cell:
To let the content in a cell spill into adjacent cells, deselect Wrap Text in the Table mm

inspector’s Format pane and deselect “Automatically resize to fit content” in the  
Table pane. 

If the adjacent cells are empty, they display spilled content. But if they contain data, 
content that doesn’t fit isn’t displayed, and the clipping indicator appears.

To make content wrap instead of spill, select Wrap in the format bar or Wrap Text in 
the Table inspector’s Format pane.

To resize a column so that all of a particular cell’s value is visible, click its right border mm

and drag right, or use the Column Width controls in the Table inspector’s Table pane.

To resize a row so that all of a particular cell’s value is visible, click its bottom border mm

and drag down, or use the Row Height controls in the Table inspector.

Using Conditional Formatting to Monitor Table Cell Values
Conditional formatting changes a cell’s appearance when the cell contains a particular 
value, referred to below as a test value.  

To apply conditional formatting, you select one or more cells and then define one or 
more rules. The rules specify which visual effects to associate with cells when they 
contain the test value.

For example, you can define a rule that fills a cell with blue when it contains 0, a rule 
that displays the cell’s value as boldface black if it’s greater than 0, and a rule that fills 
the cell with red if its value is less than 0. 

Rules applied to multiple cells trigger conditional formatting when any of the cells 
contains the test value.

To learn how to Go to

Create rules “Defining Conditional Formatting Rules” on 
page 196

Remove all conditional formatting from cells, 
change rules, find cells that use the same 
conditional formatting, copy/paste conditional 
formatting between tables 

“Changing and Managing Your Conditional 
Formatting ” on page 197



Defining Conditional Formatting Rules
A conditional formatting rule is used to detect when cells contain a test value, which 
can be either a specific value that you supply or a value that matches a value currently 
in a specific table cell. The rule specifies the formatting to apply to the cells when they 
contain the test value. 

To define rules:
	 1	 Select one or more cells.

	 2	 Click Inspector in the toolbar, click the Table button, and then click Format.

	 3	 Click “Show rules”, and then choose an item from the “Choose a rule” pop-up menu.

The items in the top section of the menu apply tests to numeric values. Items in the 
middle section are for text values. The “With dates” item is for dates.

	 4	 To specify a specific test value, type it into the value field, to the right of the  
pop-up menu. 

You can also use the value in a table cell as a test value. To do so, click the small blue 
circle in the value field to display the cell reference field. 

Specify a cell reference by clicking in a table cell. You can also type a cell reference and 
press Return.

The Between item requires that you specify two test values. The formatting is applied if 
either of the numbers or any number in between them appears in the cell or cells.
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For the “With dates” item, before specifying a test value choose items from the pop-up 
menus on both sides of the test value field.

	 5	 To specify formatting to apply when cells contain the test value, click Edit.

Text color well:  Click it to select a color to apply to cell values.

Font style buttons:  Click B to show cell values in boldface, click I to show them in 
italics, click U to underline cell values, or click T to apply the strikethrough style.

Fill color well:  Click it to select a cell fill color.

As you click, the Sample box displays the effect of your selections. When you’re 
satisfied with the effect, click Done.

	 6	 To add another rule, click the Add button (+) and repeat steps 3 through 5.

If more than one rule is defined for a cell, and the cell’s value satisfies the conditions of 
multiple rules:

The text color applied is the color associated with the topmost rule with a text ÂÂ
color specified.

The font style applied is the font style associated with the topmost rule that has a ÂÂ
font style specified.

The fill color applied is the fill color associated with the topmost rule that has a fill ÂÂ
color specified.

After the text color you specify has been applied to a cell value, if you type new text 
into the cell after placing an insertion point and changing the text color in the format 
bar or the Text inspector, the new text appears in the new text color, but the existing 
text retains the color you set in the rule. 

Changing and Managing Your Conditional Formatting 
Here are techniques you can use: 
To find all the cells in a table that have the same conditional formatting rules as a mm

particular cell, select the cell, click Inspector in the toolbar, click the Table button, click 
“Show rules” in the Format pane, and then click “Select All with this Format.” Cells with 
matching rules are selected in the table. 

To remove all conditional formatting associated with cells in a table, select the cells, click mm

“Show rules” in the Format pane of the Table inspector, and then click Clear All Rules. 



To apply the same conditional formatting rules to cells in different tables, select a mm

cell whose rules you want to reuse, choose Edit > Copy, select one or more cells in a 
different table, and then choose Edit > Paste. 

To add or remove a conditional formatting rule, click the Add (+) or Delete (–) button mm

in the Conditional Format window. 

To change a rule, redefine its pop-up menu options, test values, or formatting.mm

Here are some techniques for working with test values that are specified as  
cell references: 

To delete a test value that’s a cell reference, click in the test value field and press Delete.

To replace a cell reference with a different one, click in the test value field and click a 
different cell in the same table or a different table.

To replace a textual test value with a cell reference, click in the test value field, click the 
small blue circle, and then click a table cell.

Adding Images or Color to Table Cells
You can add graphics or color to individual table cells or to an entire table.  

To add an image or color to a table cell:
	 1	 Select the cell.

	 2	 Click Inspector in the toolbar, click the Table button, and then click Table.

	 3	 To add an image, choose Image Fill from the Cell Background pop-up menu. See 
“Filling an Object with an Image” on page 173 for instructions.

	 4	 To add background color, choose Color Fill or Gradient Fill from the Cell Background 
pop-up menu. See “Filling an Object with a Solid Color” on page 171 and “Filling an 
Object with Blended Colors (Gradients)” on page 171 for more information.

Merging Table Cells
Merging table cells combines adjacent cells into one, eliminating the borders so that 
they behave as a single cell. 

To merge table cells:
	 1	 Select a group of two or more adjacent table cells. The group of cells you choose must 

form a rectangle, and they must be all body cells, all header cells, or all footer cells.

	 2	 Choose Format > Table > Merge Cells. 

You can also choose Merge Cells from the Edit Rows & Columns pop-up menu in the 
Table pane of the Table inspector.
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To unmerge cells, select a cell created by merging, and then deselect Merge Cells in 
the Format > Table submenu or in the Edit Rows & Columns pop-up menu in the Table 
pane of the Table inspector.

Here is what happens to cell content during a merger:

Merging horizontally contiguous cells containing only text or a mixture of text, ÂÂ
numbers, formatted values, and formulas joins the content from all the original cells 
as text separated by tabs. 

Merging vertically contiguous cells containing only text or a mixture of text, 
numbers, formatted values, and formulas joins the content from all the cells as text 
separated by carriage returns.

When you merge column cells, the cell background takes on the image or color that ÂÂ
was in the topmost cell. 

When you merge row cells, the cell background takes on the image or color that 
was in the leftmost cell.

When a cell containing text, a number, a formula, or a cell format is merged with an ÂÂ
empty cell, the new cell retains the content of the non-empty cell.

When a cell containing a number format is merged with an empty cell, the new cell ÂÂ
retains the number format.

Splitting Table Cells
Splitting cells divides each selected cell into two equal parts, horizontally (rows) or 
vertically (columns). Both of the new cells have identical background colors or images. 
Any text that was in the original cell remains in the topmost or leftmost cell.  

To split cells horizontally or vertically:
	 1	 Select a table cell or cells. To split an entire row or column, select all the cells in the row 

or column.

	 2	 To split cells into rows, choose Format > Table > “Split into Rows.” To split cells into 
columns, choose Format > Table > “Split into Columns.” 

You can also choose Split Rows or Split Columns from the Edit Rows & Columns pop-
up menu in the Table inspector.

	 3	 To create smaller and smaller units, repeat steps 1 and 2 for the split cells.

To rejoin split cells, merge them, as “Merging Table Cells” on page 198 describes.

Formatting Table Cell Borders
You can change the line thickness and color of table cell borders. Or you can hide the 
border of any cell.  



To format table cell borders:
	 1	 Select the cell border segments you want to format. See “Selecting Table Cell 

Borders” on page 184 for instructions.

	 2	 Use the controls in the format bar or in the Table inspector.

Stroke pop-up menu:  Lets you choose a stroke style. Choose None to hide borders.

Line thickness:  Controls the thickness of the stroke.

Color well:  Lets you choose a stroke color.

When you click the color well in the format bar, a color matrix appears. Select a 
color by clicking it in the matrix, or click Show Colors to open the Colors window for 
additional color options.

When you click the color well in the Table inspector, the Colors window opens. “The 
Colors Window” on page 26 provides instructions for using this tool.

Copying and Moving Cells
Here are ways to copy and move cells: 
To move cells within a table, to another table, or to a page, select a cell or several mm

adjacent cells, and then drag the selection (when the pointer changes to a hand) until 
any destination cells are selected. Values in the destination cells are replaced, and the 
values in the original location are removed.

To copy cells within a table, to another table, or to a page, drag selected cells while mm

holding down the Option key. Any values in the destination cells are replaced, and the 
values in the original location are retained.

You can also copy cells by selecting them, choosing Edit > Copy, selecting destination 
cells, and then choosing Edit > Paste.

You can learn more about techniques for duplicating or moving a cell that contains 
a formula. For more information about this topic, choose Help > “iWork Formulas and 
Functions Help” or Help > “iWork Formulas and Functions User Guide.”

Adding Comments to Table Cells
Use comments to record information about table cells.  

To learn more about adding comments to your Pages document, see “Using 
Comments” on page 76.

Here are ways to work with comments:
To add a comment to a cell, select the cell and click Comment in the toolbar, or choose mm

Insert > Comment. Type in the comment box.

To hide all comments, choose View > Hide Comments.  mm
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To show all comments, choose View > Show Comments.mm

To delete a comment, click the X in the upper right of the comment box.mm

To include all comments when you print, show any comments you want to print, and mm

then choose File > Print.

Formatting Table Cell Values for Display
You can apply a format to a cell to display its value in a particular way. For example, 
you can apply the currency format to cells that hold monetary values so that a 
currency symbol (such as $, £, or ¥) appears in front of numbers in the cells. 

When you use a cell format, you are setting only the display characteristics of a value. 
When the value is used in formulas, the actual value is used, not the formatted value. 
The only exception is when there are too many numbers following a decimal point, in 
which case the number is rounded.

Here are ways to work with cell formats:
You apply cell formats by selecting one or more cells and then using the Cell Format mm

pop-up menu in the Table inspector’s Format pane.

To add a value to an empty cell that has a format, select the cell and enter a value. The mm

format is applied when you leave the cell.

If you delete a value from a cell with a format, the cell’s format isn’t deleted. To delete mm

the format, apply the automatic format. To delete the value and format, choose Edit > 
Clear All.

After you define a cell format, you can associate the format with multiple cells by using mm

autofilling. See “Autofilling Table Cells” on page 193 for instructions.

Use this cell format When you want to Learn more here

automatic Automatically format  
content based on the  
characters it contains

“Using the Automatic Format in 
Table Cells” on page 202

number Format the display of a 
number’s decimal places, 
thousands separator, and 
negative values

“Using the Number Format in 
Table Cells” on page 203

currency Format the display of  
monetary values

“Using the Currency Format in 
Table Cells” on page 204



Use this cell format When you want to Learn more here

percentage Display numeric values followed 
by the % symbol

“Using the Percentage Format in 
Table Cells” on page 204

date and time Format how date and time 
values are displayed

“Using the Date and Time 
Format in Table Cells” on 
page 205

duration Format the display of week, 
day, hour, minute, second, and 
microsecond values

“Using the Duration Format in 
Table Cells” on page 205

fraction Format the display of any part 
of a value smaller than 1

“Using the Fraction Format in 
Table Cells” on page 205

numeral system Format the display of numbers 
using the conventions of a 
particular numeral system (such 
as decimal or binary)

“Using the Numeral System 
Format in Table Cells” on 
page 206

scientific Format the display of numbers 
using an exponent raised by the 
power of 10

“Using the Scientific Format in 
Table Cells” on page 206

text Display cell content exactly as 
you type it

“Using the Text Format in Table 
Cells” on page 207

custom Define your own cell format “Using Your Own Formats for 
Displaying Values in Table 
Cells” on page 207

Using the Automatic Format in Table Cells
When you add a new cell, its content is displayed using the automatic format. 

This content in a cell assigned the automatic 
format

Is formatted like this for display

A number Decimal places and commas are preserved  
as entered. 

For example, 1,000,000.008 displays as 
1,000,000.008.

A currency value Decimal places and commas are preserved  
as entered. 

For example $1,000.0075 displays as $1,000.0075. 

A date value The value is preserved as entered and treated  
as text, not as a date, in formulas.

For example, 1/1 displays as 1/1.
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This content in a cell assigned the automatic 
format

Is formatted like this for display

A Boolean value The values “true” and “false” are converted to 
“TRUE” and “FALSE.” These cells can be used in 
Boolean operations in formulas. 

A percentage value A number followed by the % sign is displayed as 
entered, and in formulas the value is treated as 
a percentage value. A space before the % sign is 
not required.

For example, you can type 5% or 5 %.

A scientific value The display format rounds the value to 2  
decimal places.

For example, 1.777E3 is displayed as 1.78+E3.

A duration value The value is preserved as entered and treated  
as text.

A fraction value The value is preserved as entered and treated  
as text. 

If a different format has been applied to a cell, you can change its format to automatic 
by selecting the cell and choosing Automatic from the Cell Formats pop-up menu in 
the Format pane of the Table inspector.

To apply the automatic format:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table button, and then click Table.

	 3	 Choose Automatic from the Cell Format pop-up menu.

Using the Number Format in Table Cells
Use the number format to format the display of a number’s decimal places, thousands 
separator, and negative values.  

To define a number format for one or more cells:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

	 3	 Choose Number from the Cell Format pop-up menu.

	 4	 To specify how many decimal places to display, use the Decimals field. If a value 
contains more decimal places than you specify, the decimal value displayed is rounded, 
not truncated. For example, if a cell is formatted to display two decimal places, the 
value 3.456 is displayed as 3.46, not 3.45.

	 5	 To specify how to display negative values, choose an entry from the pop-up menu 
adjacent to the Decimals field.



	 6	 To specify whether to use a thousands separator, select or deselect Thousands Separator.

Using the Currency Format in Table Cells
Use the currency format to format the display of monetary values.  

To define a currency format for one or more cells:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

	 3	 Choose Currency from the Cell Format pop-up menu.

	 4	 To specify a currency symbol, choose an option from the Symbol pop-up menu.

	 5	 To specify how many decimal places to display, use the Decimals field. If a value 
contains more decimal places than you specify, the decimal value displayed is rounded, 
not truncated. For example, if a cell is formatted to display two decimal places, the 
value 3.456 is displayed as 3.46, not 3.45.

	 6	 To specify how to display negative values, choose an item from the pop-up menu 
adjacent to the Decimals field.

	 7	 To specify whether to use a thousands separator, select or deselect Thousands Separator.

	 8	 To display the currency symbol at the edge of the cell, select Accounting Style.

Using the Percentage Format in Table Cells
Use the percentage format to display numeric values followed by the percent (%) symbol. 

If the value is used in a formula, its decimal number version is used. For example, a 
value that displays as 3.00% is used as 0.03 in a formula.

If you type 3% in a cell formatted using the automatic format and then apply the 
percentage format to the cell, the value displayed is 3%. However, if you type 3 in a cell 
formatted using the automatic format and then apply the percentage format to the 
cell, the value displayed is 300%.

To define a percentage format for one or more cells:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

	 3	 Choose Percentage from the Cell Format pop-up menu.

	 4	 To specify how many decimal places to display, use the Decimals field. 

If a value contains more decimal places than you specify, the decimal value displayed 
is rounded, not truncated. For example, if a cell is formatted to display two decimal 
places, the value 3.456 is displayed as 3.46, not 3.45.

	 5	 To specify how to display negative values, choose an entry from the pop-up menu 
adjacent to the Decimals field.
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	 6	 To specify whether to use a thousands separator, select or deselect Thousands Separator.

If a cell you’re formatting already contains a value, the value is assumed to be a 
decimal value, and it’s converted into a percentage. For example, 3 becomes 300%.

Using the Date and Time Format in Table Cells
Use the date and time format to display date and/or time values. 

To define a date and time format for one or more cells:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table inspector button, and then click Format.

	 3	 Choose “Date and Time” from the Cell Format pop-up menu.

	 4	 To specify how you want a date formatted, choose a format from the Date pop-up menu.

	 5	 To specify how you want a time value formatted, choose a format from the Time pop-
up menu.

Using the Duration Format in Table Cells
Use the duration format for values that describe time increments, such as weeks, days, 
hours, minutes, seconds, or milliseconds. 

To define a duration format for selected cells:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table inspector button, and then click Format.

	 3	 Choose Duration from the Cell Format pop-up menu.

	 4	 Use the Units control to select the units you want to display for a duration value. 

By default, hours, minutes, and seconds (h, m, and s) are displayed. 

To choose a single unit, drag the left or right end of the slider toward the center until 
it can get no shorter. Then click in the center of the slider and drag it over the unit you 
want to use.

To choose more than one unit, resize and drag the slider until it’s over the units you 
want to use.

	 5	 From the Format pop-up menu, choose a display format.

Using the Fraction Format in Table Cells
Use the fraction format to control the display of any part of a value smaller than 1. For 
example, 27.5 displays as 27 1/2 when the format is Halves and as 27 4/8 when the 
format is Eighths. 

To define a fraction format for selected cells:
	 1	 Select the cell or cells.



	 2	 Click Inspector in the toolbar, click the Table inspector button, and then click Format.

	 3	 Choose Fractions from the Cell Formats pop-up menu.

	 4	 Choose a display format from the Accuracy pop-up menu.

Using the Numeral System Format in Table Cells
Use the numeral system format to represent numbers using the conventions of 
numeral systems from base 2 to base 36. When you use the Base 2, 8, or 16 format, 
you can display negative values by preceding them with a minus sign or in two’s 
complement notation; negative values in all other bases are displayed using the 
minus sign. 

In this numeral system 100 displays like this –100 displays like this 
if Minus Sign is used

–100 displays like this 
if Two’s-Complement 
is used

Base 2 1100100 –1100100 10011100

Base 8 144 –144 634

Base 10 100 –100 –100

Base 16 64 –64 9C

To define a numeral system format for selected cells:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table inspector button, and then click Format.

	 3	 Choose Numeral System from the Cell Format pop-up menu.

	 4	 Use the Base field to specify the base value of the numerical system you want to use.

	 5	 Use the Places field to specify the total number of digits to display.

	 6	 If you selected Base 2, 8, or 16, select an option for displaying negative values. 

Minus Sign:  Displays negative values with a leading minus sign.

Two’s-Complement:  Displays negative values using two’s-complement notation.

Negative values in all the other numerical systems are always displayed using a 
leading minus sign.

Using the Scientific Format in Table Cells
Use the scientific format to display numbers using an exponent raised by the power of 
10. The exponent is displayed following an E. For example, the value 5.00 in scientific 
format displays as 5.00E+00. And the value 12345 displays as 1.23E+04. 

To define a scientific format for one or more cells:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table inspector button, and then click Format.
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	 3	 Choose Scientific from the Cell Format pop-up menu.

	 4	 Use the Decimals field to specify the number of decimal places to display.

Using the Text Format in Table Cells
Use the text format when you want all of a cell’s content to be treated as text, even 
when it’s a number. When a text format is applied to a cell, its value is displayed exactly 
as you type it. 

To define a text format for one or more selected cells:
	 1	 Select the cell or cells.

	 2	 Click Inspector in the toolbar, click the Table inspector button, and then click Format.

	 3	 Choose Text from the Cell Format pop-up menu.

Using Your Own Formats for Displaying Values in Table Cells
You can create your own cell formats for displaying numbers, text, and date and time 
values. Cell formats you create, called custom formats. Custom formats are also listed in 
the Cell Format pop-up menu in the Table inspector’s Format pane. 

To learn how to Go to

Define a custom number format that applies 
currency, decimal digit, and other display 
formatting to a number in a table cell 

“Creating a Custom Number Format” on page 207

“Defining the Integers Element of a Custom 
Number Format” on page 209

“Defining the Decimals Element of a Custom 
Number Format” on page 210

“Defining the Scale of a Custom Number 
Format” on page 212

Define custom number formatting that varies 
with the value of a number in a table cell

“Associating Conditions with a Custom Number 
Format” on page 214

Define a custom date/time format, which specifies 
day, month, year, hour, minute, and other aspects 
of a date/time value in a table cell 

“Creating a Custom Date/Time Format” on 
page 216

Define text you want to appear next to a value 
entered into a table cell

“Creating a Custom Text Format” on page 217

Manage the custom formats you create “Changing a Custom Cell Format” on page 218

“Reordering, Renaming, and Deleting Custom Cell 
Formats” on page 220

Creating a Custom Number Format
To define your own display format for numbers in table cells:

	 1	 Select one or more cells. 



	 2	 Choose Custom from the Cell Format pop-up menu in the Format pane of the  
Table inspector.

Format field

Drag the elements to 
the format field.

	 3	 From the Type pop-up menu, choose Number & Text.

	 4	 Define your number format by dragging the (blue) elements from the Number & Text 
Elements box into the format field above the box. 

When an element is in the format field, click its disclosure triangle and choose a 
formatting option from the pop-up menu.

Click a disclosure triangle to 
choose a formatting option.

Integers:  Add this element when you want to format digits to the left of a decimal 
point. See “Defining the Integers Element of a Custom Number Format” on page 209 
for more information.

Currency:  Add this element to display a currency symbol. To identify the symbol you 
want to use, click the Currency element’s triangle and choose a symbol. 
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Decimals:  Add this element to format how decimal digits are displayed. See “Defining 
the Decimals Element of a Custom Number Format” on page 210 for more information.

Spaces:  Use this element to control the amount of space displayed between elements. 
Click the Spaces element’s triangle and choose an option. Normal adds a standard 
space, Wide adds an em space, and Narrow adds a sixth of an em space. You can add 
more than one Spaces element to the format field with these options, but only one of 
the Spaces elements can be Flexible. Flexible left-aligns elements that precede it and 
right-aligns elements that follow it.

Scale:  Use this element to size the display value of a number. For example, you can 
display values over 100 as number of hundreds (1000 displays as 10). See “Defining the 
Scale of a Custom Number Format” on page 212 for more information.

	 5	 To display predefined text before or after any element, place an insertion point in the 
format field, and then type your text. You can click any element and use the Left Arrow 
and Right Arrow keys to place the insertion point. 

	 6	 To delete an element in the field, select it, and then press Delete. 

To move the element around in the field, drag it.

	 7	 In the Name field, type a name for your number format.

Custom format names are listed in the Cell Formats pop-up menu in the Format pane 
of the Table inspector.

	 8	 Click OK to save your number format and apply it to the selected cells.

Here’s an example of a number format:

The hyphen is a Spaces element, set to display one Normal space between the ÂÂ
currency symbol and the number.

The dollar sign is a Currency element. ÂÂ

#,### is an Integers element that displays numbers greater than 999 with a ÂÂ
thousands separator.

.## is a Decimals element.ÂÂ

When you type this number into a cell with the 
above format

The number is displayed like this

10000000 Balance: $ 10,000.000

0.95 Balance: $ 0.95

.666 Balance: $ 0.67

Defining the Integers Element of a Custom Number Format
The Integers element lets you customize the appearance of integers in a table cell. 



After adding an Integers element to a custom number format, you can select it, click its 
disclosure triangle, and use the items in its pop-up menu to customize the element’s 
display attributes. 

See “Creating a Custom Number Format” on page 207 to learn how to add an 
Integers element.

Here are ways to use the Integer element’s pop-up menu:
To show or hide the thousands separator, choose Show Separator or Hide Separator.mm

To display zeros or spaces in front of the integer when it has fewer than a particular mm

number of digits, choose “Show Zeros for Unused Digits” or “Use Spaces for Unused 
Digits.” Then increase or decrease the number of zeros or hyphens displayed in the 
format field; choose Add Digit, Remove Digit, or “Number of Digits” from the pop-up 
menu, or use the Up Arrow or Down Arrow key to set the number of digits.

When you choose This number Is displayed like this

Show Separator 10000000 10,000,000

Hide Separator 10000000 10000000

“Show Zeros for Unused Digits” 
and set “Number of Digits” to 6

100 000100

Defining the Decimals Element of a Custom Number Format
The Decimals element lets you customize the appearance of decimal digits in a table 
cell. Decimal digits are numbers that appear to the right of a decimal point. 
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After adding a Decimals element to a custom number format, you select it, click its 
disclosure triangle, and then use the items in its pop-up menu to customize the 
element’s display attributes. 

See “Creating a Custom Number Format” on page 207 to learn how to add a 
Decimals element.

Here are ways to use the Decimal element’s pop-up menu:
To display decimal digits as numbers, choose Decimals. mm

To represent unused decimal digits when their number is fewer than a particular 
number of digits, choose Show Trailing Zeros or “Use Spaces for Trailing Zeros.” Then 
increase or decrease the number of zeros or hyphens displayed in the format field; 
choose Add Digit, Remove Digit, or “Number of Digits” from the pop-up menu, or use 
the Up Arrow or Down Arrow key to set the number of digits.

If more decimal digits than the number you specify are entered into a table cell, 
they’re rounded to match your number of digits.

To display decimal digits as a fraction, choose Fractions.mm

To specify a fractional unit (for example, Quarters), click the element’s disclosure 
triangle again and choose an item from the pop-up menu.

To avoid displaying decimal digits when they’re entered into a table cell, don’t add the mm

Decimals element to the format field.

Displayed values are rounded to the nearest integer when decimal values are entered 
into a cell.



When you choose This number Is displayed like this

Decimals and Show Trailing 
Zeros, and then set “Number  
of Digits” to 6

100.975 100.975000

Fractions, and then choose “Up 
to two digits (23/24)” option

100.975 100 39/40

A space is displayed between 
the integer and the fraction 
when you add a Spaces element 
between Integers and Decimals 
elements in the format field.

Fractions, and then choose 
Quarters option

100.16 100 1/4

Defining the Scale of a Custom Number Format
The Scale element lets you display a number entered into a table cell using 
percentage, scientific notation, or other value sizing conventions. 

To use the Scale element:
	 1	 Add it as “Creating a Custom Number Format” on page 207 describes.

	 2	 Select it in the format field, click its disclosure triangle, and then choose an option.

When you apply a format that includes a scale element to a cell that already contains 
a value, the original value is preserved (it’s just displayed differently). When you apply 
the same format to an empty cell and then add a value to the cell, the actual value 
takes into account the scale you’ve specified. The following table illustrates these cases.
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For this scale option When you enter 12000 
in a table cell

The actual value is The displayed value is

Percent And later apply the 
option

1200000% 1200000

  After applying the 
option

1200000% 12000

Percent (%) And later apply the 
option

1200000% 1200000%

  After applying the 
option

12000% 12000%

Hundreds And later apply the 
option

12000 120

  After applying the 
option

12000 120

Hundreds (C) And later apply the 
option

12000 120C

  After applying the 
option

12000 120C

Thousands And later apply the 
option

12000 12

  After applying the 
option

12000 12

Thousands (K) And later apply the 
option

12000 12K

  After applying the 
option

12000 12K

Millions And later apply the 
option

12000 0

  After applying the 
option

12000 0

Millions (M) And later apply the 
option

12000 0M

  After applying the 
option

12000 0M

Billions And later apply the 
option

12000 0

  After applying the 
option

12000 0



For this scale option When you enter 12000 
in a table cell

The actual value is The displayed value is

Billions (B) And later apply the 
option

12000 0B

  After applying the 
option

12000 0B

Trillions And later apply the 
option

12000 0

  After applying the 
option

12000 0

Trillions (T) And later apply the 
option

12000 0T

  After applying the 
option

12000 0T

Scientific And later apply the 
option

12000 1E+0.4

  After applying the 
option

12000 1E+0.4

Associating Conditions with a Custom Number Format
You associate conditions with a custom number format to vary a table cell’s display 
characteristics based on what’s entered into the cell. 

Here’s a number format that has four conditions. The top condition is applied if the 
number entered doesn’t satisfy any of the other conditions.
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When you type this value into a cell with the 
above format

The value is displayed like this

15000 Due: $0015.00K

0 Paid in Full

–500 Credit: $ (0000.50K)

Account closed Note: Account closed

To create a custom number format that has conditions:
	 1	 Select one or more cells.

	 2	 Choose Custom from the Cell Format pop-up menu in the Format pane of the  
Table inspector.

	 3	 From the Type pop-up menu, choose Number & Text.

	 4	 Click the Add (+) button to the right of the format field to add a condition.

The condition you specify in the topmost field is applied if the number entered doesn’t 
satisfy any of the other conditions. Text Element conditions can only be used in this 
topmost field. To learn about Text Elements, see “Creating a Custom Text Format” on 
page 217.

	 5	 From the pop-up menu above the new format field, choose a condition item.

	 6	 Define the number format you want to apply when a number meets the condition by 
adding elements to the format field. 

See “Creating a Custom Number Format” on page 207 for information about 
interacting with the format field.



	 7	 Repeat steps 4 through 6 as needed to define all your conditions.

Note:  To remove a condition, click the Delete (–) button to the right of its format field.

	 8	 In the topmost format field, define the display format you want to use if a number 
doesn’t meet any of the conditions.

You can use the Entered Text element to display predefined text if a text value is 
entered instead of a number. See “Creating a Custom Text Format” on page 217 for 
more information.

	 9	 In the Name field, type a name for your number format, and then click OK to save it 
and apply it to selected cells.

Custom format names are listed in the Cell Formats pop-up menu n the Format pane 
of the Table inspector.

Creating a Custom Date/Time Format
To define your own display format for date and time values in table cells: 

	 1	 Select one or more cells. 

	 2	 Choose Custom from the Cell Format pop-up menu in the Format pane of the  
Table inspector.

	 3	 From the Type pop-up menu, choose Date & Time.

	 4	 Define your date/time format by dragging the (blue) elements from the Date & Time 
Elements box into the format field above the box. 

	 5	 When an element is in the format field, click its disclosure triangle and choose a 
formatting item from the pop-up menu.
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	 6	 To display predefined text before or after any element, place an insertion point in the 
format field, and then type your text. You can click any element and use the Left Arrow 
and Right Arrow keys to place the insertion point. 

	 7	 To display space between elements, place an insertion point and press the Space bar 
one or more times. 

	 8	 To delete an element in the field, select it, and then press Delete. 

To move an element around in the field, drag it.

	 9	 In the Name field, type a name for your date/time format.

Custom format names are listed in the Cell Formats pop-up menu in the Format pane 
of the Table inspector.

	 10	 Click OK to save your date/time format and apply it to the selected cells.

When you enter a date or time value into a formatted cell, the format is applied if the 
value entered contains a hyphen (-) or a slash (/).

Here’s an example:

When you type this value into a cell with the 
above format

The value is displayed like this

4/16/99 April 16 1999 falls on day 106 of the year

2-23 February 23 2008 falls on day 54 of the year

Dec. 15, 2010 Dec. 15, 2010

Creating a Custom Text Format
You can define text to display before or after a value entered into a table cell when no 
other format has been applied to the cell. 

To define text to display in table cells:
	 1	 Select one or more cells. 

	 2	 Choose Custom from the Cell Format pop-up menu in the Format pane of the  
Table inspector.

	 3	 From the Type pop-up menu, choose Number & Text.

	 4	 Drag the (blue) Entered Text element from the Date & Time Elements box into the 
empty format field above the box. (Delete any existing elements that may be in the 
field before dragging in the Entered Text element.) 



	 5	 Place an insertion point before or after the element, and then type your text, including 
spaces if required. You can click the element and use the Left Arrow and Right Arrow 
keys to place the insertion point.

When you type “Need to update address” into a field with this format, the value is 
displayed like this: Notify customer: Need to update address.

	 6	 In the Name field, type a name for your text format.

Custom format names are listed in the Cell Formats pop-up menu in the Format pane 
of the Table inspector.

	 7	 Click OK to save your text format and apply it to the selected cells.

Changing a Custom Cell Format
Here are ways to change custom formats and apply changes to table cells: 
To change the elements associated with a custom format that’s been applied to cells, mm

select the cells and click Show Format in the Format pane of the Table inspector. 

To delete an element, select the element in the format field, and then press Delete.

To add an element, drag an element into the format field.

To move an element, drag it around in the format field.

To redefine an element, click the element’s disclosure triangle, and then choose an 
option from the pop-up menu.

After making your changes, do one of the following:

To save the changed format and apply it to selected cells using the same name, click OK, 
and then click Replace.

To save the changed format as a new format and apply it to selected cells, change the 
format name, and then click OK.
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To apply the changed format to unselected table cells, select the cells and choose the 
name of the format from the Cell Formats pop-up menu in the Format pane of the 
Table inspector.

To change a custom format name and apply the change to selected cells, use the mm

custom cell format management dialog. To show the dialog, click Manage Formats in 
the custom format dialog, and then double-click the name to edit it and click OK.

When you change the name of a custom format, the previous name remains 
associated with cells to which it had been applied, and the previous name is removed 
from the list of custom formats. To associate the renamed format with these cells, 
select the cells and choose the new name from the Cell Formats pop-up menu in the 
Format pane of the Table inspector.

To create a new custom format based on the current one but with a different name mm

and apply the change to selected cells, click Show Format in the Format pane of the 
Table inspector. Edit the Name field and click OK.



Reordering, Renaming, and Deleting Custom Cell Formats
You use the cell format management dialog to manage custom cell formats. The dialog 
lists all the custom formats available in the document. 

To manage custom cell formats:
	 1	 If the custom cell format management dialog isn’t open, click Manage Formats in the 

custom format dialog.

	 2	 Do any of the following:

To rename a custom format, double-click the format and type your changes.

To reorder a custom format, select a format, and then click one of the arrows below the 
list to move it up or down in the list.

To delete a custom format, select a format, and then click the Delete (–) button below 
the list.

	 3	 Click OK to save your changes and close the dialog.
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This chapter outlines the basics of creating and formatting 
charts that you can create from your own data.

Pages provides tools for creating your own visually appealing charts to present your 
data. You can copy and paste your data from a document or type it directly into the 
Chart Data Editor to create and edit your charts right on the page. By default, the 
appearance of charts is coordinated with the template you’re using, but you can adjust 
colors, textures, shadows, labels, and more to create the look you want or to emphasize 
particular elements on your chart.

About Charts
Use a chart when you want to visually represent trends or relationships that may be 
more difficult to see when data is presented in a table. In Pages you can choose from 
a variety of 2D or 3D chart types to present your data, including pie charts, line charts, 
bar charts, column charts, and area charts, depending on which works best to make 
the point with your data, or use a mixed chart to overlay two chart types within the 
same figure. You can also graph your data in a two-dimensional scatter chart, using 
linear or logarithmic scales. 

Pages includes the following types of charts:

Kind of chart Icon

Column

2D and 3D

Stacked column

2D and 3D

Bar

2D and 3D

10Creating Charts from Data



Kind of chart Icon

Stacked bar

2D and 3D

Line

2D and 3D

Area

2D and 3D

Stacked Area

2D and 3D

Pie

2D and 3D

Scatter

Mixed

2-Axis

Example
You may want to create a chart that compares how bird populations have changed in 
two alpine sampling regions between 2007 and 2010. This data may first be presented 
in a table with rows for Region 1 and Region 2. The researcher has counted the 
number of birds in each region each year from 2007 through 2010, thus having 4 data 
points (or values) for each region. 

	 222		  Chapter 10    Creating Charts from Data



	 Chapter 10    Creating Charts from Data	 223

If you plot this data as a column chart, it shows four sets of two bars, spanning four 
years.

The chart legend denotes 
the four data series.

Each data set contains four bars, 
one from each data  series.

These two bars of the 
same color represent one 
data series.

Each bar represents 
one data point.

In this chart, Region 1 and Region 2 are called the data series because the data 
points (numbers of birds) from each region are represented by a series of columns 
of the same color, one for each year. Each column for Region 1 is set beside the 
corresponding column for Region 2, and each side-by-side set of columns is called a 
data set or category (2007 is a category, 2008 is a category, and so on). 



To give a different emphasis to your data, you can transpose the data so that data 
points are grouped by region rather than by year. In this case, the data points for each 
year are represented as a series of columns (data series; in this case each series has 
only two data points and the groups of columns for each region are categories. So 
this column chart contains two sets of four columns (data points), one category for 
Region 1 and one data set for Region 2.

The chart legend denotes 
the two data series.

Each data set contains two bars, 
one from each data  series.

These four bars of the 
same color represent one 
data series.

Each bar represents 
one data point.

Data series are represented differently in different kinds of charts: 

In ÂÂ column charts and bar charts, a data series is represented by a series of columns or 
bars in the same fill color or texture.

In a ÂÂ line chart , a data series is represented by a single line.

In an ÂÂ area chart, a data series is represented by an area shape.

In a ÂÂ pie chart, only a single data set (the first data point in each series) is represented 
on the chart (whichever is listed first in the Chart Data Editor).

In a ÂÂ scatter chart, each point on the graph is determined by both an x and a y value. 
Two columns of values are plotted as x coordinates and y coordinates on a graph 
representing the data points in a single data series.

To learn how to Go to

Create and edit a chart “Adding a New Chart and Entering Your Data” on 
page 225

Format chart titles, legends, axes, and  
other elements

“Formatting Charts” on page 228

Format pie charts, line charts, and other kinds  
of charts

“Formatting Specific Chart Types” on page 237
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Adding a New Chart and Entering Your Data
When you first create a chart, it appears on the page with placeholder data in the 
Chart Data Editor. As you replace the placeholder data, the chart is immediately 
updated to reflect your own data.

Charts can be added inline with text or floating on the page.

To create a new chart from your data:
	 1	 Place a chart on the page by doing any of the following:

To add an inline chart in a word processing document, click Charts in the  ÂÂ
toolbar and choose a chart type from the pop-up menu. Or choose  
Insert > Chart > chart type.  

In a word processing document, you can convert an inline chart to a floating chart 
and vice versa. Select the chart you wish to convert, and click the Inline or Floating 
button in the format bar.

In a page layout document, charts are floating. For more information about using 
inline and floating objects, see “What Are Floating and Inline Objects?” on page 137.

Draw a chart on the page by holding down the Option key as you click Charts in the ÂÂ
toolbar, and then choosing a chart. Release the Option key and move the pointer 
over the page until it becomes a crosshair. Drag across the page to create a chart 
that’s the size you want. To constrain the chart’s proportions, hold down the Shift 
key as you drag.

A chart appears on the page, which you can drag to move and resize, and the Chart 
Data Editor opens, filled with placeholder data. The Chart Data Editor is a window 
containing an editable table. This table doesn’t appear on your page, but you use it to 
enter your own data for the chart you’ve created.

These squares indicate 
which color represents 

each data series.

	 2	 To enter your data into the Chart Data Editor, do any of the following:

ÂÂ To edit the labels of rows and columns, double-click a label, and then type.

ÂÂ To add or edit the number in a cell, double-click it, and then type.

ÂÂ To reorder rows or columns, drag a row or column label to a new position.



ÂÂ To add rows or columns, click Add Row or Add Column to place a row above the 
selected row or a column to the left of the selected column. If no row or column is 
selected, the new row or column appears at the bottom or right edge of the table. 
(To see the new row or column, you may have to press the Return key or the Tab 
key, expand the Chart Data Editor window, or scroll.)

Alternatively, select any blank cell, type your data, and then press Return. A new row 
or column is automatically created.

ÂÂ To delete rows or columns, select the row or column label, and then press Delete.

ÂÂ To copy data from Excel, AppleWorks, or other spreadsheet applications, copy and paste 
it into the Chart Data Editor.

	 3	 To choose whether the chart’s data series are represented by rows or columns, click 
the “Row vs. Column” button in the Chart Data Editor.

This button makes the 
rows of data in the Chart 
Data Editor the data series.

This button makes the 
columns of data in the Chart 
Data Editor the data series.

To learn how to Go to

Change a chart’s type “Changing a Chart from One Type to Another” on 
page 226

Edit a chart using the Chart Data Editor “Editing Data in an Existing Chart” on page 227

Copy and paste a Numbers chart into a  
Pages document

“Updating a Chart Copied from a Numbers 
Document” on page 227

Changing a Chart from One Type to Another
You can change a chart’s type anytime you like. Some chart types, however, use the 
row and column data differently, as described below. 

To change a chart from one type to another:
	 1	 Select the chart. 

	 2	 Choose a chart type from the pop-up menu in the format bar. Or click Inspector in the 
toolbar, click the Chart button, and then choose a different chart type from the pop-up 
menu that appears when you click the chart icon in the upper left. For a table of chart 
types from which you can select, see “About Charts” on page 221.

If you switch to a pie chart, the first data point in each series is represented as a wedge.

If you switch to a scatter chart, each point in the chart requires two values. If the chart 
is based on an odd number of rows or columns, the last row or column isn’t plotted.
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If you switch to a bar, column, area, or line chart, each series in the new chart 
corresponds to a row or column in the Chart Data Editor.

If you switch to a 3D version of a chart, the Chart inspector provides controls for 
managing object depth, lighting style, and more.

Formatting you’ve applied to the chart you’re changing may not be applied to the new 
chart. For example, the color fill attribute of data point elements (bars, wedges, and so 
on) has a different default value for each type of chart. If you’ve changed a column fill 
color and then change the chart to be a bar chart, the fill color change isn’t retained. 
Depending on the type of chart, the attributes that may revert to the default styling 
are value labels and position, text style, series stroke, series shadow, series fill, data 
point symbols, and data point fills.

When you change a chart’s type and the new type has some of the same attributes, 
those attributes don’t change. Shared attributes include axes, gridlines, tick marks, 
axis labels, show minimum value, number format, borders, rotation, shadows, and 3D 
lighting style. See “Formatting Charts” on page 228 for more information.

Bar or column charts, and stacked bar or column charts, share attributes except for 
value label position. Also, bar and column charts have separate fills.

3D chart shadows are shared across chart types.

Editing Data in an Existing Chart
To edit the data in an existing chart, you must first open the Chart Data Editor and 
then enter your new data. As you edit the data, the chart is immediately updated to 
reflect the new data. 

To open the Chart Data Editor and edit the data:
	 1	 Select the chart. 

	 2	 Click Inspector in the toolbar, click the Chart button, and then click Edit Data.

You can also choose Format > Chart > Show Data Editor.

	 3	 To learn about editing the data in the Chart Data Editor, including switching the data 
series to use rows or columns, see steps 2 and 3 of “Adding a New Chart and Entering 
Your Data” on page 225.

Updating a Chart Copied from a Numbers Document
If you’ve created a chart in Numbers, you can copy it and paste it into your Pages 
document. After it’s been pasted into Pages, the chart remains linked to the data 
tables it references in Numbers. To change the chart data, open the original Numbers 
document and edit the data there, save the Numbers document, and then refresh the 
chart data in Pages.

ÂÂ To add rows or columns, click Add Row or Add Column to place a row above the 
selected row or a column to the left of the selected column. If no row or column is 
selected, the new row or column appears at the bottom or right edge of the table. 
(To see the new row or column, you may have to press the Return key or the Tab 
key, expand the Chart Data Editor window, or scroll.)

Alternatively, select any blank cell, type your data, and then press Return. A new row 
or column is automatically created.

ÂÂ To delete rows or columns, select the row or column label, and then press Delete.

ÂÂ To copy data from Excel, AppleWorks, or other spreadsheet applications, copy and paste 
it into the Chart Data Editor.

	 3	 To choose whether the chart’s data series are represented by rows or columns, click 
the “Row vs. Column” button in the Chart Data Editor.

This button makes the 
rows of data in the Chart 
Data Editor the data series.

This button makes the 
columns of data in the Chart 
Data Editor the data series.

To learn how to Go to

Change a chart’s type “Changing a Chart from One Type to Another” on 
page 226

Edit a chart using the Chart Data Editor “Editing Data in an Existing Chart” on page 227

Copy and paste a Numbers chart into a  
Pages document

“Updating a Chart Copied from a Numbers 
Document” on page 227

Changing a Chart from One Type to Another
You can change a chart’s type anytime you like. Some chart types, however, use the 
row and column data differently, as described below. 

To change a chart from one type to another:
	 1	 Select the chart. 

	 2	 Choose a chart type from the pop-up menu in the format bar. Or click Inspector in the 
toolbar, click the Chart button, and then choose a different chart type from the pop-up 
menu that appears when you click the chart icon in the upper left. For a table of chart 
types from which you can select, see “About Charts” on page 221.

If you switch to a pie chart, the first data point in each series is represented as a wedge.

If you switch to a scatter chart, each point in the chart requires two values. If the chart 
is based on an odd number of rows or columns, the last row or column isn’t plotted.



To update a chart after you’ve updated its linked Numbers table:
Select the chart on the page and click the Refresh button that appears.mm

Note:  You must save the Numbers document before copying and pasting your  
chart into your Pages document and after editing the Numbers data tables that  
the chart references.

To unlink the chart from its Numbers table:
Select the chart on the page and click Unlink.mm

After unlinking the chart, it behaves as any chart created in Pages, and must be 
updated using the Chart Data Editor

Clicking the Source link next to the Refresh button opens the Numbers document that 
the chart is linked to. (If the Source link is hidden, expand the Refresh button control 
panel by dragging its handle outward.)

Formatting Charts
Every chart you create has an associated title, chart legend, and labels that you can 
choose to show or hide in your document or change their look and placement on the 
page. You can also change the chart colors and textures, the axis scales and tick marks, 
and the data point labels within the chart. You can rotate 2D charts and adjust the 
angle and lighting style used in 3D charts. 

Many of the instructions given here provide details for performing tasks using the 
Chart inspector. But many of these task steps can also be performed using the format 
bar. The options in the format bar change, depending on what item you have selected 
on the page, always providing you with appropriate formatting options.

To learn how to Go to

Format a chart’s title, labels, and legend “Placing and Formatting a Chart’s Title and 
Legend” on page 229

“Formatting the Text of Chart Titles, Labels, and 
Legends” on page 229

Change a chart’s size and orientation “Resizing or Rotating a Chart” on page 230

Change a chart’s scale, axis marking, and labels “Formatting Chart Axes” on page 230

Change a chart’s color, texture, shadow, and other 
image qualities

“Formatting the Elements in a Chart’s Data 
Series” on page 233

Show special elements in charts “Showing Error Bars in Charts” on page 235

“Showing Trendlines in Charts” on page 236

Format pie charts, bar charts, and other specific 
chart types

“Formatting Specific Chart Types” on page 237
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Placing and Formatting a Chart’s Title and Legend
The chart title is where you can describe the subject of the chart. The chart legend 
shows which colors used in the chart represent which data series.

You can show or hide a chart’s title or legend, change the appearance of its text, 
and drag it wherever you want it to appear on the same page. To change any chart 
attribute, first select the chart.  

To place and format a selected chart’s title and legend, do any of the following:
To show the title or legend, choose View > Show Inspector, and then click the Chart mm

button. Select Show Title or Show Legend.

To give the chart a new title, select the text in the title box and type a new one.mm

To edit the labels in the legend, click Edit Data to open the Chart Data Editor, and then mm

edit the series labels in the Chart Data Editor, or select the legend and edit the text 
directly in the legend.

To format the text in the legend or title, see “mm Setting Shadows, Spacing, and Series 
Names on Bar and Column Charts” on page 241.

To add descriptive text elements to a chart, create a text box. See “Adding a Floating 
Text Box” on page 104. When you’ve finished formatting your chart, you can group the 
text box with the chart, so that the text box and chart always move together should 
you decide to move the chart. See “Grouping and Ungrouping Floating Objects” on 
page 163.

Formatting the Text of Chart Titles, Labels, and Legends
You can change the size and appearance of chart and axis titles, axis labels, data point 
labels, and legends. 

To format the text of labels and legends:
	 1	 Depending on which text you want to format, select the appropriate item: 

To format all chart titles and labels (excluding the chart legend), click the chart to 
change all the text to your font and color choices.

To format the text for all data points in one series only, select the text box for one data 
point in the series.

To format the text in an axis label, select the text.

To format the text for all series labels, select the series label box.

To change the text in a chart legend, select the legend.

	 2	 Use the format bar or the Fonts window to format the text. 



See “Formatting Text Size and Appearance” on page 82 for instructions.

Resizing or Rotating a Chart
There are several techniques for rotating 2D charts. You can’t rotate (or flip) 3D charts. 
If a 3D chart is grouped with 2D charts, you can rotate the group, but only the 2D 
charts in the group will rotate. 

Here are ways to resize or rotate a chart:
To resize a chart, select the entire chart, and then do any of the following:mm

Drag an active selection handle. Active selection handles have a black outline.  ÂÂ

The selection handles on the top of inline charts are inactive. To resize an inline 
chart, drag the active handles on the lower right side.

To maintain a chart’s proportions, hold down the Shift key as you drag to resize it.ÂÂ

To resize a chart in one direction, drag a side handle instead of a corner handle.ÂÂ

To resize by specifying exact dimensions, click Inspector in the toolbar, and then ÂÂ
click the Metrics button. You can specify a new width, height, and angle of rotation, 
and you can change the chart’s distance from the margins.

To rotate 2D charts, select the entire chart, and then do any of the following:mm

Select the chart, hold down the Command key, move the pointer toward an active ÂÂ
selection handle until it changes to a curved, double-headed arrow, and then drag a 
selection handle. 

To rotate a chart in 45-degree increments, hold down the Shift and Command keys ÂÂ
while dragging a selection handle.

Click Inspector in the toolbar, click the Metrics button, and then drag the Rotate ÂÂ
wheel or use the Angle controls to set the angle of the chart.

Pie charts can also be rotated using the Chart Inspector. See “Resizing or Rotating a 
Chart” on page 230. 

Formatting Chart Axes
In column charts, area charts, line charts, and bar charts, data points are plotted on one 
axis (the y-axis for column, area, and line charts; the x-axis for bar charts) and data sets 
are grouped on the other axis. The data point axis is called the value axis, and the data 
set axis is called the category axis.

In scatter charts, both the x and y axes are value axes. In 2-axis charts, there are two 
y axes—Value Axis (Y1) and Value Axis (Y2)—which can be formatted separately. 
For more details about 2-axis charts, see “Customizing 2-Axis and Mixed Charts” on 
page 244.
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To show or hide an axis or chart borders, set the scale (linear or log) and span of 
the value axis, or adjust grid and tick marks along the axes, make selections, and 
enter appropriate values in the Axis pane of the Chart inspector. To learn about the 
inspectors, see “The Inspector Window” on page 23.

Set the range of values that 
appear on the chart grid.

Select units for values in 
the chart.

Set attributes of labels, 
tick marks, and more.

Show or hide axes and chart 
borders (2D charts only).

Many of these formatting options are also available using the format bar. Just as with 
the Chart inspector, the options available on the format bar are always appropriate to 
the type of chart you have selected. To learn about the format bar, see “The Format 
Bar” on page 23.

To place gridlines and tick marks along the chart axes:
Choose the grid lines and tick marks you want from one or both of the Choose Axis mm

Options pop-up menus.

To format the values along the value axis, do any of the following:
To set the highest number displayed on the value axis, type a number in the Maximum mm

field under Value Axis. This value can’t be lower than the maximum value of your entire 
data set. If you don’t specify a number, the field displays the word “Auto,” and the value 
is automatically calculated based on the data.

To set the value at the origin point of the value axis, type a number in the Minimum mm

field under Value Axis. This value can’t be greater than the minimum value of your 
entire data set. If you don’t specify a number, the field displays the word “Auto,” and 
the value is automatically calculated based on the data.

To specify the number of axis markings between zero and the minimum and maximum mm

values on the value axis, specify a number in the Steps field under Value Axis.

To display the data values on the value axis, choose Show Value Labels and/or Show mm

Minimum Value from the Choose Axis Options pop-up menu under Category Axis.



To specify units for numbers on the value axis, choose an item from the Format pop-mm

up menu under Value Axis.

Number:  Displays the data point value with no units, unless you specify them. To 
specify units, type them into the Suffix field. Displays the data point value with no 
units. In the Decimals field, specify how many decimal places you want to appear. To 
display negative values preceded by a minus sign or in parentheses, choose –100 or 
(100) from the pop-up menu. Choose Separator if you want to separate the orders of 
magnitude on the left side of the decimal.

Currency:  Displays the data point value as a monetary amount. Choose the currency 
unit symbol from the Symbol pop-up menu. In the Decimals field, specify how many 
decimal places you want to appear. To display negative values preceded by a minus 
sign or in parentheses, choose –100 or (100) from the pop-up menu. Choose Separator 
if you want to separate the orders of magnitude on the left side of the decimal.

Percentage:  Displays the data point value as divided by 100. In the Decimals field, 
specify how many decimal places you want to appear. To display negative values 
preceded by a minus sign or in parentheses, choose –100 or (100) from the pop-up 
menu. Choose Separator if you want to separate the orders of magnitude on the left 
side of the decimal.

Date and Time:  Displays data point values with a date and time format.

Duration:  Displays data point values as a unit of time (for example, seconds, minutes, 
or weeks).

Fraction:  Displays data point values less than 1 as one integer over another. (If your 
values are greater than 1, you won’t see any fractional representation of your data.) 
Choose how accurately you want the fractions rounded off from the Accuracy pop-up 
menu. Choosing an item such as Halves or Quarters represents the values as a portion 
of the total pie, rounded to the nearest division you chose. 

Scientific:  Displays data point values in scientific notation, where 10 raised to a power 
is represented as E+ an integer. In the Decimals field, specify how many decimal places 
you want to appear.

Custom:  Choose a custom number format you’ve already created, or create a new one. 
See “Creating a Custom Number Format” on page 207 for more information.

To display category (data set) titles:
	 1	 Choose Show Categories from the Choose Axis Options pop-up menu under the 

Category Axis.

	 2	 To show or hide some of the category titles, do either or both of the following:
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Specify the interval at which you want category labels to appear by typing a value ÂÂ
or use the stepper in the “Label every ... categories” field. For example, a value of 2 
displays every other category title, a value of 3 displays every third category title, 
and so on.

Choose Show Last Category from the Choose Axis Options pop-up menu under ÂÂ
Category Axis if you want the title of the last category to appear.

To add or hide an axis title:
	 1	 Choose Show Title from the Choose Axis Options pop-up menu under Category Axis 

or Value Axis.

	 2	 On the chart, double-click the value title or category title that appears and type the 
title you want.

	 3	 To format the title’s text attributes, see “Formatting Text Size and Appearance” on 
page 82.

	 4	 To hide the title, choose the item again in the same pop-up menu to remove  
the checkmark. 

To set a linear, logarithmic, or percentage scale for the value axis:
Choose Linear Scale, Log Scale, or Percentage Scale from the Choose Axis Options pop-mm

up menu under Value Axis.

Percentage scales are available only for 2D stacked bar, column, and area charts; 
linear and logarithmic scales are available only for 2D charts that aren’t stacked. 3D 
charts can only use a linear scale. (For pie charts, you display values as percentages by 
choosing Show Pie Values as Percentages from the Data Point Settings pop-up menu.)

To change the color and texture of series elements, or to format data point symbols 
and value labels, use the Series pane of the Chart inspector. See “Formatting the 
Elements in a Chart’s Data Series” on page 233.

To learn about formatting options that are unique to a given chart type, see 
“Formatting Specific Chart Types” on page 237.

Formatting the Elements in a Chart’s Data Series
You can use a variety of visual effects to enhance the appearance of data series 
elements, such as bars (in column and bar charts), data point shapes (in line and 
scatter charts), and area shapes. 

Pie wedges also represent a data series, but these have special formatting 
considerations. See “Customizing the Look of Pie Charts” on page 237 to learn more.

For bar, column, and area charts, you can make formatting selections to change the 
look and style of data series shapes and symbols in the Series pane of the Chart 
inspector. To learn about the Inspector window, see “The Inspector Window” on 
page 23.



Many series formatting options are also available in the format bar. When you select 
a series element in a chart, the items in the format bar change to provide appropriate 
options for formatting chart series elements. To learn about the format bar, see “The 
Format Bar” on page 23.

To make changes to series elements, first select an element in the series you  
want to change. Most changes are made using the controls in the Series pane of the 
Chart inspector. 

To fill selected series elements with specially designed colors or textures:
	 1	 Click Inspector in the toolbar, click the Chart button, and then click Chart Colors.

	 2	 Choose a fill type (for example, 3D Texture Fills) from the first pop-up menu.

	 3	 Choose a fill collection (for example, Marble or Wood) from the second pop-up menu.

	 4	 Do one of the following:

To fill all the elements in all the data series, click Apply All. The first fill is applied to ÂÂ
elements in the first series, the second fill to elements in the second series, and so on.

To fill elements in a single data series, drag the fill to an element (bar, column, and ÂÂ
so on) in the series.

Note that these fills can’t be used for line and scatter charts. To learn about formatting 
series elements in these chart types, see “Customizing Data Point Symbols and Lines in 
Line Charts” on page 242 and “Using Scatter Charts” on page 243.

To adjust the opacity, stroke, shadow, or fill of selected series elements:
Select the element you want to change, click the Graphic inspector button, and then mm

make the adjustments you want.

When adjusting the opacity and fill, note that dragging the Opacity pager at the 
bottom of the Graphic inspector changes the opacity of the chart as a whole. To affect 
only a selected series, select it, and then adjust the opacity of the color fill, gradient fill, 
or tinted image fill, as needed. For more details, see “Adjusting Opacity” on page 170 
and “Filling an Object with a Solid Color” on page 171. 

To learn about using one of your own images as a fill, see “Filling an Object with an 
Image” on page 173.

To learn about changing the look of the line around an element, see “Changing the 
Style of Borders” on page 166.

To learn about changing shadows, see “Adding Shadows” on page 168.

To show and format data point labels for the selected series:
Click Series in the Chart inspector, and then choose Value Labels. Then do any of  mm

the following:

To position the labels, choose a label location from the Position buttons (for ÂÂ
example, Middle or Below Right).
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To specify the display format for the data values, choose an item from the Format ÂÂ
pop-up menu. Choose Custom if you want to use a custom number format you’ve 
previously set up, or if you want to create one; see “Creating a Custom Number 
Format” on page 207 for more information.

To show negative numbers preceded by a minus sign or in parentheses, choose ÂÂ
(–100) from the adjacent pop-up menu.

To specify the number of decimal places shown, type a number in the Decimals field.ÂÂ

To change the text attributes of the data point labels, see “ÂÂ Formatting Text Size and 
Appearance” on page 82.

To change the color and texture of series elements, or format data point symbols and 
value labels, use the Series pane of the Chart inspector. See “Formatting the Elements 
in a Chart’s Data Series” on page 233.

To learn about formatting options that are unique to a given chart type, see 
“Formatting Specific Chart Types” on page 237. 

Showing Error Bars in Charts
You can show error bars around data points in all 2D chart types, except for pie charts. 
Choose from different line ends and colors in the Graphic inspector. 

To show error bars for the data points in a selected series:
	 1	 In the Chart inspector, click Series, and then click Advanced at the bottom of the 

Inspector window. Then click Error Bars.

For scatter plots, you can have error bars for both data series. Set them separately by 
following the instructions for both the axes.

	 2	 From the pop-up menu, choose how you want the error bars to be displayed:

Positive and Negative:   Displays full error bars, both above and below each data point.

Positive Only:  Displays only the part of each error bar that falls above its data point.

Negative Only:  Displays only the part of each error bar that falls below its data point.

	 3	 From the second pop-up menu, choose the kind of error bar you want to display:

Fixed Value:  Displays an error bar of the same absolute value for every data point. 
Specify a value in the adjacent field.

Percentage:  Displays error bars based on a fixed percentage of each data point value. 
Specify a percentage in the adjacent field.

Standard Deviation:  Displays error bars based on the standard deviation of your data 
set. Specify the number of standard deviations in the adjacent field.

Standard Error:  Displays standard error bars.



Custom:  Lets you set error bars based on your own criteria. In the Positive field, specify 
how far above the data points you want the error bars to extend; in the Negative field, 
specify how far below the data points you want the error bars to extend.

Showing Trendlines in Charts
Trendlines are lines calculated and drawn to fit your data, according to the type of 
equation you prefer. You can display trendlines for most 2D chart types, except stacked 
bar, column, and area charts and pie charts. 

To show a trendline for the data points in a selected series:
	 1	 Select the series for which you want to show a trendline, and then click the Inspector 

button in the toolbar.

	 2	 Click the Chart button in the Inspector window, and then click Series.

	 3	 Click Advanced at the bottom of the Series pane. Then click Trendline.

	 4	 Select, from among the following, the type of equation you want to use to calculate 
the trendline:

Linear:  Produces a best-fit straight line, most useful for simple, linear data series.

Logarithmic:  Produces a best-fit curved line, most useful when values increase or 
decrease quickly, then level out.

Polynomial:  Produces a curved line that has hills and valleys to show where values 
rise or fall. Specify the order of polynomial you want to use in the Order field; order 4 
produces as many as 3 hills or valleys.

Power:  Produces a curved line for use when you want to compare measurements 
that increase at a specific rate. Power can’t be used with data that contains zero or 
negative values.

Exponential:  Produces a curved line for use when values rise or fall at increasingly 
higher rates. Exponential can’t be used with data that contains zero or negative values.

Moving Average:  Produces a trendline using the number of data points you specify in 
the Period field, averages them, and uses the average value as a trendline point.

	 5	 To see the equation that describes a trendline, select the line, and then select Show 
Equation. You can drag this equation to wherever you want it to appear on the page.

	 6	 To see the R-squared value that was used to calculate a trendline, select the line, and 
then select Show R^2 Value. You can drag this number to wherever you want it to 
appear on the page.

	 7	 To display a label for a trendline, select it, and then select Label. Type a label in the 
adjacent field.

	 8	 To change the line color or thickness, select it, and then click the Graphic button  
in the Inspector window. Make adjustments using the Stroke controls of the  
Graphic inspector.
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Formatting Specific Chart Types
Pie charts, bar and column charts, and other specific chart types have special 
formatting options.

For example, you can apply shadow to individual pie wedges, move wedges away from 
the center of the pie, use different symbols for data points along different lines in line 
charts, and more.

To learn how to Go to

Set shadows and adjust spacing between chart 
bars or columns

“Setting Shadows, Spacing, and Series Names on 
Bar and Column Charts” on page 241

Format pie charts and individual wedges in them “Customizing the Look of Pie Charts” on page 237

Format line chart elements “Customizing Data Point Symbols and Lines in 
Line Charts” on page 242

Format area charts “Showing Data Point Symbols in Area Charts” on 
page 242

Format scatter charts “Using Scatter Charts” on page 243

Format 2-axis and mixed-type charts “Customizing 2-Axis and Mixed Charts” on 
page 244

Format 3D charts “Adjusting Scene Settings for 3D Charts” on 
page 245

Customizing the Look of Pie Charts
One pie chart represents a single data set, and each wedge is one data point value in 
that set (the first data point from each data series). If the data series are in rows, only 
the first column is used in creating the chart; if the data series is in columns, only the 
first row is used in creating the chart. You can any chart data set by moving it to the 
first row or column of the table. 

To adjust the look of an individual pie wedge, you must first select the pie chart, and 
then select the wedges you want to change.

Here are ways to select pie wedges in a selected pie chart:
To select any wedge, click it.mm

To select all the wedges, select any wedge and press Command-A. mm

To select nonadjacent wedges, hold down the Command key as you select each wedge.mm

To select a continuous range of wedges, select the first wedge, and then hold down mm

the Shift key as you select the last wedge.



To learn how to Go to

Apply colors and textures to a pie chart “Adding Shadows to Pie Charts and Wedges” on 
page 240

Show series and data point labels in a pie chart “Changing Pie Chart Colors and Textures” on 
page 238

Make individual pie wedges more visually 
prominent

“Showing Labels in a Pie Chart” on page 239

Add shadows to pie charts “Separating Individual Wedges from a Pie 
Chart” on page 240

Rotate a 2D pie chart “Rotating 2D Pie Charts” on page 241

Perform other formatting “Formatting Charts” on page 228

Changing Pie Chart Colors and Textures
To change chart colors and textures:

	 1	 To fill series elements with specially designed colors or textures, click Inspector in the 
toolbar, click the Chart button, and then click Chart Colors. Choose a fill type  
(for example, 3D Texture Fills) from the first pop-up menu, and choose a fill collection 
(for example, Marble or Wood) from the second pop-up menu. Then do one of  
the following: 

To fill all the wedges, click Apply All. The first fill is applied to elements in the first series, 
the second fill to elements in the second series, and so on.

To fill a single wedge, drag the fill to the wedge.

	 2	 To adjust the opacity, stroke, shadow, and other graphical attributes of individual pie 
wedges, select the wedge you want to change, click the Graphic inspector button, and 
then make the adjustments you want.

When adjusting the opacity and fill, note that dragging the Opacity pager at the 
bottom of the Graphic inspector changes the opacity of the chart as a whole. To affect 
only a selected series, select it, and then adjust the opacity of the color fill, gradient fill, 
or tinted image fill, as needed. For more details, see “Adjusting Opacity” on page 170 
and “Filling an Object with a Solid Color” on page 171. 

To learn how to Go to

Use one of your own images as a fill “Filling an Object with an Image” on page 173

Change the look of the line around the pie  
or a wedge

“Changing the Style of Borders” on page 166

Change the shadows “Adding Shadows to Pie Charts and Wedges” on 
page 240

Change the depth qualities of a 3D pie chart “Adjusting Scene Settings for 3D Charts” on 
page 245
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Showing Labels in a Pie Chart
To show series and data point labels in pie charts, use the Chart inspector. 

To show series names or data point labels in a pie chart:
	 1	 Select the chart or individual pie wedges for which you want to show a label or  

series name. 

	 2	 Click Inspector in the toolbar, and then click the Chart button.

	 3	 Select Labels, and then drag the Position pager to place the data point label closer 
to—or farther away from—the center of the pie, or specify a value in the field to set 
the wedge’s distance from the center of the pie as a percentage of the pie’s radius.

	 4	 To display the values in a particular format, choose from the Format pop-up menu and 
adjust the options:

Number:  Displays the data point value with no units. Displays the data point value 
with no units. In the Decimals field, specify how many decimal places you want to 
appear. To display negative values preceded by a minus sign or in parentheses, choose 
–100 or (100) from the pop-up menu. Choose Separator if you want to separate the 
orders of magnitude on the left side of the decimal.

Currency:  Displays the data point value as a monetary amount. Select the currency 
unit symbol from the Symbol pop-up menu. In the Decimals field, specify how many 
decimal places you want to appear. To display negative values preceded by a minus 
sign or in parentheses, choose –100 or (100) from the pop-up menu. Choose Separator 
if you want to separate the orders of magnitude on the left side of the decimal.

Percentage:  Displays the data point value as divided by 100. In the Decimals field, 
specify how many decimal places you want to appear. To display negative values 
preceded by a minus sign or in parentheses, choose –100 or (100) from the pop-up 
menu. Choose Separator if you want to separate the orders of magnitude on the left 
side of the decimal.

Date and Time:  Displays data point values with a date and time format.

Duration:  Displays data point values as a unit of time (for example, seconds, minutes, 
or weeks).

Fraction:  Displays data point values less than 1 as one integer over another. (If your 
values are greater than 1, you won’t see any fractional representation of your data.) 
Choose how accurately you want the fractions rounded off from the Accuracy pop-up 
menu. Choosing an item such as Halves or Quarters represents the values as a portion 
of the total pie, rounded to the nearest division you selected. 

Scientific:  Displays data point values in scientific notation, where 10 raised to a power 
is represented as E+ an integer. In the Decimals field, specify how many decimal places 
you want to appear.



Custom:  Choose a custom number format you’ve already created, or create a new one. 
See “Creating a Custom Number Format” on page 207 for more information.

	 5	 To show the series name, select Show Series Name.

Separating Individual Wedges from a Pie Chart
To make pie wedges more visually prominent, you can separate them from the pie. 

Separate a pie wedge by 
using the Explode slider.

Here are ways to separate individual pie wedges:
To move a single wedge away from the center of a 2D or 3D pie chart, select it and mm

then drag it or use the Explode control in the Chart inspector. 

To separate all the wedges away from the center of a 3D pie chart, select the chart mm

before using the Explode control.

You can add a series name or data point label to distinguish individual wedges even 
further. See “Showing Labels in a Pie Chart” on page 239.

Adding Shadows to Pie Charts and Wedges
You can put shadows on individual pie wedges or on the pie as a whole. Putting 
shadows on individual wedges makes it look as if the wedges are on different layers, so 
when you add a shadow to a pie wedge, it’s generally a good idea to separate it first. 
See “Showing Labels in a Pie Chart” on page 239 for instructions. 

To add shadows:
	 1	 Select the chart or individual pie wedges. Click Inspector in the toolbar, and then click 

the Chart button. Do one of the following:

ÂÂ To add shadows to individually selected wedges, choose Individual from the Shadow 
pop-up menu.

ÂÂ To add a shadow to the chart as a whole, choose Group from the Shadow pop-up menu.

	 2	 To set shadow attributes, use the Graphic inspector. 

See “Adding Shadows” on page 168 for instructions.
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Rotating 2D Pie Charts
You can use various techniques for rotating a 2D pie chart. 

Here are ways to rotate a pie chart:
Select the chart, click Inspector in the toolbar, click the Chart button, and then use the mm

Rotation Angle wheel or field. 

Click Inspector in the toolbar, click the Metrics button, and then drag the Rotate wheel mm

or use the Angle controls to set the angle of the chart.

Select the chart, hold down the Command key and move the pointer toward an active mm

selection handle until it changes to a curved, double-headed arrow, and then drag a 
selection handle. 

To rotate the chart in 45-degree increments, hold down the Shift and Command keys mm

while dragging a selection handle or the Rotate wheel.

Setting Shadows, Spacing, and Series Names on Bar and Column 
Charts
On bar and column charts, you can adjust the distance between the sets of bars or 
columns (data sets); on charts where the data sets aren’t stacked, you can also adjust 
the distance between the bars or columns (individual data sets). You can also apply 
shadows to individual data series or to the entire chart.

On bar and column charts that are not stacked, you can also opt to show the  
series names. 

To customize bars and column charts:
	 1	 Select a bar or column chart.

	 2	 Click Inspector in the toolbar, click the Chart button, and then click Chart.

	 3	 Do any of the following:

Change the space between bars or categories:ÂÂ

To change the space between bars, type a value (or click the arrows) in the “Gap 
between bars” field.

To change the space between categories (on unstacked charts), specify a value in the 
“Gap between sets” field.

The value is the percentage of the bar thickness. Decreasing the space between 
the bars makes them thicker. You can also move the pointer near a bar edge until it 
becomes a double-headed arrow, and then drag to make the bars thicker or thinner.

Add shadows:ÂÂ

To add shadows to individual bars, choose Individual from the Shadow pop-up menu.

To add shadows to each group of bars, choose Group from the Shadow pop-up menu.



To set shadow attributes, use the Graphic inspector. See “Adding Shadows” on 
page 168 for instructions.

To show series names, in the Axis pane of the Chart inspector, choose Show Series ÂÂ
Names from the Choose Axis Options pop-up menu under Category Axis.

To learn about other formatting options, see “Formatting Charts” on page 228.

Customizing Data Point Symbols and Lines in Line Charts
In area and line charts, you can use symbols (circles, triangles, squares, and diamonds) 
to represent data points. You can also show a straight or curved line between the data 
points. 

The data points in this series 
are represented by triangles.

The data points in this series 
are represented by squares.

Here are ways to change the data point symbols and connecting line:
To change the data point symbol, select a data series (area shape or line), click mm

Inspector in the toolbar, click the Chart button, and then click Series. Choose a symbol 
from the Data Symbol pop-up menu. Adjust the size of the data point symbols by 
entering a value or using the stepper in the adjacent field.

Join points with a curve.

Choose a symbol to 
use for data points.

To join points with a curve, select a data series (line), and then choose Curve from the mm

Connect Points pop-up menu.

To change the line color, select a line, click Inspector in the toolbar, click the Graphic mm

button, and then use the Stroke controls. See “Changing the Style of Borders” on 
page 166 for instructions.

To learn about other formatting options, see “Formatting Charts” on page 228.

Showing Data Point Symbols in Area Charts
In area charts, you can use symbols (circles, triangles, squares, and diamonds) to 
represent data points. 
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To show data point symbols:
	 1	 Select a data series (area shape), click Inspector in the toolbar, click the Chart button, 

and then click Series.

	 2	 Choose a symbol from the Data Symbol pop-up menu.

	 3	 Adjust the size of the data point symbols by entering a value or using the stepper in 
the adjacent field.

To learn about other formatting options, see “Formatting Charts” on page 228.

Using Scatter Charts
Scatter charts display data differently from the other kinds of charts. They require 
at least two columns or rows of data to plot values for a single data series. To show 
multiple data series, you use additional two-column (or two-row) pairs. 

Each pair of values determines the position of one data point. The first data value in 
the pair is the x-axis of the point. The second data value is the y-axis of the point. If 
you’ve already created a chart with data points that don’t occur in pairs, and then 
you change your chart to a scatter chart, Pages may not plot the data as you expect. 
Depending on how the data is arranged in the table, it may not be possible to create 
any plot at all. Make sure you have entered x and y point values for each data series 
you want to plot before choosing to create a scatter chart.

Before you can change the look of data point symbols or lines, you must select a 
symbol or line of interest, and then open the Chart inspector. (See “The Inspector 
Window” on page 23 to learn about opening the Inspector.)

To change the look of selected data point symbols and lines, do any of the following:
Choose an item from the Data Symbol pop-up menu, and then adjust the symbol’s size mm

by entering a value or using the stepper in the adjacent field.

To connect the points of the selected series with a straight or curved line, choose an mm

item from the Connect Points pop-up menu.

To change the color of the data points or lines in your chart, select a data point or mm

line that you want to change, and then click the Graphic inspector. (Note that you can 
change the colors separately for the data points, line, and trend line, even though they 
represent the same data series.) In the Graphic inspector, click the Stroke color well, 
and then select a color from the Colors window.

To change the style and thickness of any line in your chart, select it and then choose a mm

line style in the Stroke pop-up menu. Enter a value or use the stepper in the adjacent 
field to adjust the line thickness.



To learn about showing a trend line for the selected series, see “Showing Trendlines in 
Charts” on page 236. In scatter charts, you can display error bars for both x and y axis 
measurements. To understand more about showing error bars, see “Showing Error Bars 
in Charts” on page 235.

To learn about other formatting options, see “Formatting Charts” on page 228.

Customizing 2-Axis and Mixed Charts
Charts with two axes feature a line chart superimposed upon a column or area chart 
and show a different value axis (y axis) for each chart. The axis on the left side of the 
chart belongs to the first data series listed in the Chart Data Editor, represented by a 
line and is called Value Axis (Y1). The axis on the right side of the chart belongs to the 
second data series listed in the Chart Data Editor, represented by columns and is called 
Value Axis (Y2). The Chart inspector provides controls that allow you to format each of 
the axes individually. 

Mixed-type charts present a single chart in which each of the two series can be 
represented as a different chart type. For example, one data series can be represented 
by a line while the other data series is represented by columns.

For both 2-axis and mixed charts, only a single data series can be represented by each 
chart type. Either data series can be represented as a column, line, or area chart.

This is the y axis 
for the data series 

represented by a line.

This is the y axis for the 
data series represented 
by columns.

To change a chart type in the figure:
	 1	 Select the data series for which you want to change the chart type.

	 2	 Click Inspector in the toolbar, click the Chart button, and then click Series.

	 3	 Select a chart type from the Series Type pop-up menu.

To learn about other formatting options, see “Formatting Charts” on page 228.
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Adjusting Scene Settings for 3D Charts
For 3D charts, you can change the viewing angle and the lighting angle of the chart. 

To adjust 3D scene settings:
	 1	 Select a 3D chart, click Inspector in the toolbar, click the Chart button, and then  

click Chart.

	 2	 To change the chart’s viewing angle, drag an arrowhead in the blue arrow button until 
you’ve situated the chart the way you want.

	 3	 To change the lighting angle and intensity, select an option from the Lighting Style 
pop-up menu that creates the look you want.

	 4	 To change the depth of the chart elements, drag the Chart Depth slider. Dragging to 
the right makes the chart elements appear to stretch out toward the viewer. If you 
create a very deep chart, you may have to resize the chart to fit it on the page.

	 5	 To enhance the edges on a 3D pie chart, select Show Bevel Edges.

To learn about other formatting options, see “Formatting Charts” on page 228.
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Use data stored in Address Book, vCards, and Numbers 
documents to personalize letters, envelopes, and other Pages 
documents.

Many Pages templates contain merge fields, which provide an automatic way to 
insert names, phone numbers, addresses, and other data into a document. Merge 
fields let you create a document, such as a letter or a contract, and then reuse it  
for different individuals.

What Are Merge Fields?
You can insert any data you’ve defined for contacts in Address Book or a Numbers 
document into Pages documents. You can also insert data from a virtual address card 
(vCard) that someone has sent you. This way you can reuse a letter, contract, envelope, 
or other document for multiple people. This feature is sometimes called mail merge.

When a Pages document contains merge fields, data is automatically inserted into the 
fields. Merge fields identify which Address Book, Numbers, or vCard data to insert and 
where to insert it.

A document can contain two kinds of merge fields:

A ÂÂ sender field displays information about the document’s distributor. For example, a 
letter can be formatted with a header that uses sender fields to display a company’s 
name, address, and phone number.

Pages automatically fills sender fields with data from the Address Book card that’s 
designated My Card.

A ÂÂ merge field displays data from your Address Book or Numbers document. For 
example, you can use merge fields to insert a person’s name at various locations  
in a letter.

11Personalizing Documents with 
Address Book and Numbers Data
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When you want to personalize a document for multiple recipients, you specify 
an Address Book group or select multiple individual cards, or choose a table in 
a Numbers document. Pages creates a separate version of the content for each 
Address Book contact or Numbers record. In each version of the document, the 
same sender data is used, but the merge fields are personalized. Personalized results 
can be printed or saved in a new document with a section for each contact.

To learn about Go to

Adding sender or merge data into a document “Merging Data from Address Book or a Numbers 
Document” on page 247

Modifying or creating new merge fields “Defining Your Own Merge Fields” on page 249

Choosing from over 50 merge field names to  
add to your document

“Merge Field Names” on page 250

Merging Data from Address Book or a Numbers Document
Many of the Pages templates have predefined merge fields, but you can also create 
your own merge fields, as “Defining Your Own Merge Fields” on page 249 describes. 

When a merge field has been defined in a Pages document, you can insert contact 
data into it. The original document is not affected by the merge. You can reuse the 
document for additional merges as required.

To insert sender data:
Open a document that contains sender fields, such as a letter template. Pages mm

automatically inserts data from your My Card in Address Book into the fields. If the 
card doesn’t contain data for any of the sender fields, the field label continues to  
be displayed.

If you want to use data other than the data on your My Card as sender field data, drag mm

an Address Book card or vCard to a sender field in the document. The new card’s data 
is applied to all sender fields in the document.

Numbers document data cannot be used for Sender information. mm

To insert merge data for one contact using Address Book or vCard:
	 1	 Select the contact’s Address Book card or vCard and drag it to a merge field.

The contact’s data appears in all the merge fields throughout the document. If  
the card doesn’t contain data for one of the merge fields, the field label continues to 
be displayed.

	 2	 Save or print the document if desired.

	 3	 To reuse the document with another contact’s data, select another card and drag it to 
a merge field. The new data replaces the merge field data inserted in step 1.



To insert merge data for all contacts in an Address Book group:
	 1	 Open a document that contains merge fields.

	 2	 Choose Edit > Mail Merge, and then choose a group or All from the pop-up menu.

You can also choose a group or All in Address Book and drag it to a merge field in  
the document.

	 3	 In the dialog that appears, do one of the following:

To create a new document that contains a section for each contact in the group, choose 
New Document from the pop-up menu.

To print a personalized copy of the document for each contact in the group, choose “Send 
to Printer” from the pop-up menu.

If you don’t wish to have missing contact information substituted (for example, a work 
address for a home address), deselect the checkbox.

To insert merge data for contacts in multiple cards using Address Book:
	 1	 Open a document that contains merge fields.

	 2	 Select the Address Book cards you want to use, and then drag them to a merge field. 
In the dialog that appears, do one of the following:

To create a new document that contains a section for each contact, choose New 
Document from the pop-up menu. 

To print a personalized copy of the document for each contact, choose “Send to Printer” 
from the pop-up menu.

If you don’t wish to have missing contact information substituted (for example, a work 
address for a home address), deselect the checkbox.

To insert merge data for one or more contacts using a Numbers document:
	 1	 Choose Edit > Mail Merge, and then click Numbers Document.

	 2	 Choose a Numbers document in the window that appears, and click Open.

	 3	 For each merge field, click the Target Name pop-up menu in the Merge window, and 
select a target.

	 4	 Print the document.

	 5	 To reuse the document with other Numbers data, select another Numbers document, 
and repeat steps 1 through 4.

Note:  If your document has facing pages, double-sided printing of a mail merge might 
cause one document to print on the other side of a previous document.

You can also use contact information that isn’t in Address Book or a vCard for a sender 
or merge field. For more information, see “Using Contact Data Not in Address Book or a 
vCard” on page 249.
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Using Contact Data Not in Address Book or a vCard
You can use contact information that isn’t in Address Book or a vCard for a sender or 
merge field. 

To insert data you type into merge fields:
	 1	 Click a merge field and type the data you want to use. The merge field is replaced by 

the text you type. 

	 2	 Repeat step 1 as required.

	 3	 To retain the version of the document containing all the merge fields you’ve 
eliminated, choose File > Save As to save your changed document as a new file.

If you don’t need to save your changes, simply choose Edit > Undo Typing to restore 
the original merge fields.

Defining Your Own Merge Fields
You can add a merge field to a document that can later be replaced with contact 
information from Address Book or a Numbers document. You can disable a merge 
field, change the data it uses, remove sender or merge fields, and more. 

When you need to modify a merge field or create new merge fields, you use the Merge 
pane of the Link inspector.

To create a merge field:
	 1	 Open a Pages document.

	 2	 Place the insertion point at the location where you want the Address Book field  
to appear.

	 3	 If the Link inspector isn’t open, choose Insert > Sender Field or Insert > Merge Field. 
Or, in the Merge pane of the Link inspector, click Add (+) and choose Add Merge 
Field or Add Sender Field. A placeholder for the sender or merge field is inserted and 
highlighted.



	 4	 In the Merge pane of the Link inspector, click the Target Name controls. Choose the 
category that best describes the kind of data you want inserted into the field.

If a Numbers document is selected, select the Numbers table column header that 
matches the data you want inserted.

To change a merge field:
To change a merge field from a sender field to a merge field or vice versa, delete the mm

field, and then add a new field.

To delete a merge field, select it, and then press the Delete key.mm

When a document uses an Address Book field that has work, home, or other variations, mm

you can quickly switch from one variation to another by choosing Edit > Mail Merge. 
Click to view the Merge Field table. Click Target Name, and select the variation.

To change a merge field label, click the merge field whose label you want to change, mm

type the new label, and then select the new label. If the Link inspector isn’t open, 
choose Insert > Merge Field or Insert > Sender Field. Otherwise, in the Merge pane of 
the Link inspector, click Add (+), and choose Add Merge Field or Add Sender Field. If 
the merge source is a Numbers document, select the Numbers table column header 
that matches the records you want inserted into the field.

To learn more about the merge fields that Pages supports, see “Merge Field Names” on 
page 250 for more information.

Merge Field Names
The following table summarizes the merge fields that Pages supports. The synonyms 
are alternative names you can use to add a particular merge field value.

Merge field names Field name synonyms

Prefix Name title, Name prefix

Last name Last, Surname

First name First, Given name, Forename

Suffix Name suffix, Professional suffix, Academic suffix

Nickname

Maiden name

Job title

Department Job department

Company
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Merge field names Field name synonyms

Phone (first available number)

Main phone

Work phone

Home phone

Mobile Mobile phone, Mobile telephone, Cell phone, 
Cell telephone, Cellular, Cellular phone, Cellular 
telephone

Home fax

Work fax

Pager Beeper

Other phone

Email (first available address) Email address

Work email

Home email

Other email

URL (first available URL)

Work URL

Home URL

Other URL

Birthday

AIM (first available address) IM, IM handle, IM name, IM address, Chat, Chat 
handle, Chat name, Chat address

Work AIM Work IM, Work IM handle, Work IM name, Work IM 
address, Work chat handle, Work chat name, Work 
chat address

Home AIM Home IM, Home IM handle, Home IM name, 
Home IM address, Home chat, Home chat handle, 
Home chat name, Home chat address

Other AIM Other IM, Other IM handle, Other IM name, Other 
IM address, Other chat, Other chat handle, Other 
chat name, Other chat address

Yahoo

Work Yahoo

Home Yahoo



Merge field names Field name synonyms

Other Yahoo

Address

Street address (first available street address) Street

City (first available city) Town

State (first available state)

Zip Zip code, Postal code

Country (first available country)

Work address

Work street address Work street, Work address

Work city Work town

Work state

Work zip Work zip code, Work postal code

Work country

Home Address

Home street address Home street, Home address

Home city Home town

Home state

Home zip Home zip code, Home postal code

Home country

Other address

Other street address Other street, Other address

Other city Other town

Other state

Other zip Other zip code, Other postal code

Other country

Note Notes

	 252		  Chapter 11    Personalizing Documents with Address Book and Numbers Data



		�  253

Learn the various ways you can print and share your  
Pages document. 

In addition to printing or faxing your document, you can share your document 
electronically. By exporting to other document formats, you can collaborate with 
others who use AppleWorks or Microsoft Word. You can also make your document 
available as a PDF file, attach it to an iWeb blog entry, send it in an email, or share it on 
the web.

Printing Your Document
Pages and Mac OS X provide you with tools to print all or part of your document in 
various layouts and to adjust the color of the printed document. 

To learn about Go to

Changing the paper size and page layout before 
you print

“Setting the Paper Size and Orientation” on 
page 253

“Previewing a Document Before Printing It” on 
page 254

Reviewing your document onscreen and printing 
it with comments displayed

“Printing All or Part of Your Document” on 
page 255

“Printing Comments” on page 256

Setting the Paper Size and Orientation
Before you print, you should make sure the paper size and orientation are set the way 
you want by opening the Page Setup dialog. 

To set paper size and orientation:
	 1	 Choose File > Page Setup. 

	 2	 In the Page Setup dialog, choose the printer you will use from the “Format for” pop-
up menu.

	 3	 Choose a standard paper size from the Paper Size pop-up menu.

12Printing, Sharing, and Exporting 
Your Document to Other Formats



If you want to set a custom paper size, choose Manage Custom Sizes from the pop-up 
menu. Otherwise, go to step 7.

Choose a printer to set 
its default page margins.

Create a new custom 
paper size.

Duplicate a selected paper size.

Delete a selected 
paper size.

	 4	 Click the Add (+) button, and then enter values in the Page Size fields.

Either choose your printer’s default margins from the pop-up menu, or enter your own 
values for margins in the Left, Right, Top, and Bottom fields.

If you want to change the custom size’s name, double-click the name in the list and 
enter a new name.

	 5	 Click OK.

	 6	 Choose the new paper size you named from the Paper Size pop-up menu, and then 
click OK.

	 7	 Select an orientation option using one of the buttons at the bottom of the Page 
Setup dialog.

	 8	 To make an image larger or smaller to fill more or less of the paper, type a percentage 
value into the Scale field, and then click OK.

A value less than 100% makes the image smaller; a value greater than 100% makes the 
image larger.

Previewing a Document Before Printing It
To make sure everything is laid out the way you expect, it’s a good idea to preview a 
document onscreen before you print it. 

To preview a document for printing using Mac OS X 10.4:
	 1	 Choose File > Print, and then click the Preview button in the Print dialog. 

Preview shows what individual document pages will look like when printed. It doesn’t 
show the effects of some layout options, such as borders.

	 2	 Select SoftProof at the bottom-left corner of the Preview window to take your printer’s 
capabilities into account. 
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For example, if you’re printing a color document to a black-and-white printer, selecting 
SoftProof previews the document in black and white.

	 3	 Click Print to print your document directly from the Preview window.

For information about using Preview, see Preview Help. Choose Help > Preview Help 
when the Preview window is active.

To preview a document for printing using Mac OS X 10.5 or later:
Choose File > Print. A small preview of the document appears in the Print dialog.mm

If you don’t see the document preview, click the disclosure triangle to the right of the 
Printer pop-up menu.

Use the arrows keys below the preview to scroll through the document.

Choose “Open PDF in Preview” from the PDF pop-up menu to view a full-size preview mm

of the document.

You can click Print to print your document directly from the Preview window. For 
information about using Preview, see Preview Help. Choose Help > Preview Help when 
the Preview window is active.

Printing All or Part of Your Document
You can print your entire document or a selected page range to a printer your 
computer is configured to access. 

To print a full document or a range of pages:
	 1	 Choose File > Print. 

	 2	 Choose the printer you want to use from the Printer pop-up menu. 

If you don’t see the printer you want to use, choose Add Printer from the Printer pop-
up menu.

To learn about adding a printer, search for “Adding a printer” in Mac Help. To find out 
where the printer you are using is located, pause with the pointer over the printer’s 
name when you are choosing it from the Printer pop-up menu.

	 3	 Type the number of copies you want to print in the Copies field, and then select 
Collated if you want each group of pages to print together in order before printing the 
next group. 

If you want to print a batch of page 1, then page 2, then page 3, and so on, deselect 
the checkbox.

	 4	 To print the entire document, select All next to Pages.

To print a range of pages, select From, and then type the page number of the first 
page in the From field, and the page number of the last page in the “to” field.

	 5	 Click Print.



Printing Comments
When a Pages document contains comments that you or someone else has added, you 
can print the document with comments showing.

See “Using Comments” on page 76 for more information about comments. 

To print comments:
Make the comments visible by clicking View in the toolbar and choosing Show mm

Comments, and then print your document.

If you are tracking changes in your document, click View in the toolbar, and choose 
“Show Comments and Changes Pane.”

Printed pages are adjusted to make room for the visible comments and change bubbles.

Exporting Pages Documents to Other File Formats
If you want to share your Pages documents with those who aren’t using the latest 
version of Pages, you can export your document to file formats that they may be able 
to use on their computers or other devices:

ÂÂ PDF:  You can view PDF files in iBooks, and view or print them in Preview and Safari. 
You can edit them with a PDF application. Fonts used in the Pages document are 
preserved in the PDF file.

Hyperlinks in your Pages document are exported to the PDF file. Hyperlinks are 
also created in the PDF file for table of contents entries, footnotes and endnotes, 
webpages, email addresses, and bookmarks. 

ÂÂ Microsoft Word:  You can open and edit Microsoft Word files in Microsoft Word on a 
computer running Mac OS X or Windows.

Because of text layout differences between Microsoft Word and Pages, an 
exported Word document may contain a different number of pages than its Pages 
counterpart. You may notice other differences, as well, for example, table layouts and 
some special typographic features may not be identical. Some graphics (particularly 
those using transparency) may not display as well. Charts created in Pages appear as 
MS Graph objects, which you can edit in Microsoft Word. 

ÂÂ RTF:  You can open and edit RTF files in many different word processors. RTF files 
retain most of the text formatting and graphics.

ÂÂ Plain text:  You can open and edit plain text files in many text editing applications, 
such as TextEdit. Exporting to plain text removes all document and text formatting, 
and images aren’t exported. 
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ÂÂ ePub:  You can open ePub files for reading in the iBooks application on an iPad, 
iPhone, or iPod touch, or in any ePub file reader. After you export your document to 
ePub format, you must transfer it to your device to read it in iBooks. To learn more 
about optimizing a document for ePub format, exporting it, and transferring it to 
your device, see “Creating an ePub Document to Read in iBooks” on page 257.

If your Pages document is password-protected, the password-protection is removed 
from the new file that's created upon export. However, if you export to the PDF file 
format, you can apply a new password at the time of export.

To export a document to PDF, Microsoft Word, RTF, or plain text file formats:
	 1	 Choose Share > Export.

	 2	 Select the document format that you want from the options shown across the top of 
the Export window.

If you’re exporting to PDF, you must choose an image quality (a higher image quality 
results in a larger PDF file):

Best:  Image resolutions are not scaled down.

Better:  Images are downsampled to 150 dpi. Images without transparency (alpha 
channel) are JPEG-compressed by 0.7.

Good:  Images are downsampled to 72 dpi. Images without transparency (alpha 
channel) are JPEG-compressed by 0.9.

To learn about creating a password for your PDF document, see “Password-Protecting 
Your Document” on page 36.

	 3	 Click Next.

	 4	 Type a name for the document.

	 5	 Choose where you want to save the document.

	 6	 Click Export.

To learn about creating a document that can be opened in Pages ’08, see “Saving a 
Document as an iWork ’08 or Microsoft Word Document” on page 260. To learn about 
sending a Pages document to iWeb, so you can use it in your website, see “Sending a 
Pages Document to iWeb” on page 264.

Creating an ePub Document to Read in iBooks
You can export any Pages word-processing document to the ePub file format for 
reading in an ePub reader, such as the iBooks application on the iPad, iPhone, or  
iPod touch. Documents created in page layout templates can’t be exported to the 
ePub format.



Documents exported to ePub format will look different than their Pages counterparts. 
If you want to get the best document fidelity between the Pages and ePub formats, 
style your Pages document with paragraph styles and other formatting attributes 
allowed in an ePub file. Apple provides a sample document on the Apple Support 
site that features styles and guidelines to help you create a Pages document that’s 
optimized for export to the ePub file format, which you can use as a template or a 
guide. To learn more about using paragraph styles in Pages, see the topics in the 
chapter Chapter 6, “Working with Styles,” on page 123.

To read your ePub document in iBooks on your mobile device, you must transfer the 
ePub file that you create onto your device.

To use the “ePub Best Practices” sample document:
To learn more about using the ePub format and get a better feel for how a Pages 
document might appear as a book in iBooks, it’s a good idea to download the “ePub 
Best Practices” sample document. After reading the guidelines and instructions within 
the document, you can use it as a template to create your own document. Or import 
the styles from the sample document into a new document you create.

	 1	 Download the “ePub Best Practices” sample document at the following web address: 
http://images.apple.com/support/pages/docs/ePub_Best_Practices_EN.zip

	 2	 Do either of the following:

Use the sample document as a template. 

	 a	 Create a copy of the sample document file.

	 b	 Delete the contents of the sample document copy and type in (or paste in) your 
own content.

	 c	 Apply paragraph styles as described in the “ePub Best Practices” sample document.

Import the paragraph styles from the sample document into a new or existing 
Pages document. 

	 a	 Open the Pages document to which you want to import the styles, and choose 
Format > Import Styles.

	 b	 Locate and select the ePub Best Practices sample document, and then click Open.

	 c	 Click Select All.

	 d	 Select the checkbox “Replace duplicates,” and then click OK.

	 e	 Review your document to be certain that each paragraph style from the sample 
document is appropriately applied to all blocks of text in your document, and 
correct any misapplications of the styles.

	 3	 Export the document you create to ePub format to see how it looks in iBooks.
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To prepare an existing Pages document for export to ePub format:
Documents exported to the ePub format automatically appear with page breaks 
before every chapter. A table of contents is automatically generated, which allows 
readers to jump quickly to any chapter title, heading, or subheading in the book. In 
order to create a meaningful table of contents, it’s important to apply appropriate 
styles within your document. The ePub reader uses the paragraph styles to determine 
which items should appear in the table of contents for your book.

Note:  The Pages document must have been created using a word-processing template.

	 1	 Review your document to be certain that appropriate paragraph styles are applied to 
all chapter titles, headings, and subheadings in your document.

If you want additional items to appear in the table of contents generated by the ePub 
file, make sure they are also styled with the correct paragraph style. Then open the 
Document inspector and click TOC. Select all of the paragraph styles that you want to 
appear in the TOC, and then click Update. For more information about creating a table 
of contents, see “Creating and Updating a Table of Contents” on page 64.

	 2	 Generate a table of contents in the current document, to verify that it lists only what 
you expect it to (for example, chapter titles, headings, and subheadings). Correct any 
errors by selecting or deselecting paragraph styles in the TOC view of the Document 
inspector (as described, above).

	 3	 Reformat any images, shapes, or other objects in your document to make them 
inline objects.

To learn about inline objects, see “What Are Floating and Inline Objects?.”

To export your document to ePub format:
If you have tracked changes in the document you want to export, accept or reject 
any changes and stop tracking changes before you export. Tracked changes are 
automatically accepted if no specific action is taken. (See “Accepting and Rejecting 
Changes.”)

	 1	 Choose Share > Export.

	 2	 Select “ePub” from the options shown across the top of the Export window.

	 3	 Fill out the following fields:

Title:  Type the name of the book.

Author:  Type the author’s name.

Genre:  Select a genre for the book from the pop-up menu, or type a new genre into 
the Genre field.



	 4	 Select the checkbox “Use first page as book cover image” if you want to use a 
thumbnail image of the document’s first page as the icon for this book in your iBooks 
library, and start the book’s content from the document’s second page. The cover 
image is also visible opposite the book’s table of contents. If you leave this checkbox 
deselected, the book uses the generic icon in your iBooks library.

You won’t be able to open the ePub file in Pages. The file can only be opened as a 
book in an ePub reader. In iBooks, the book font is set to the font you choose from 
within the iBooks application. All the text sizes in the book are displayed only as small, 
medium, or large, and you can select which size from within iBooks. Colors in the book 
may not be identical to those in its Pages counterpart.

To transfer your ePub document to your iPad, iPhone, or iPod touch:
	 1	 Make sure you’ve downloaded the iBooks application from the App Store onto  

your device.

	 2	 Connect your device to your computer, and then open iTunes on your computer.

	 3	 Drag the ePub file to Books, listed on the left side of the iTunes window, under Library.

	 4	 Synchronize your device with iTunes.

For information about connecting your mobile device to your computer, synchronizing 
it with iTunes, and using the iBooks application, see the documentation available for 
the device. 

Saving a Document as an iWork ’08 or Microsoft Word Document
You can save a Pages document so that users with iWork ’08 or Microsoft Word can 
open and use the document. 

To save a document for use with iWork ’08 or Microsoft Word:
	 1	 Choose File > Save As, or choose File > Save. 

	 2	 Type a new name for the document in the Save As field.

	 3	 Choose where you want to save the document.

	 4	 Select “Save a copy as,” and choose iWork ’08 or Word Document from the  
pop-up menu.

	 5	 Click Save.

Users of Pages in iWork ’08 can open and use the document, but won’t be able to use 
the new Pages ’09 features. For example:

Tracking changes to tables and floating objects isn’t supported, so those changes ÂÂ
will be accepted.

Mail merge from a Numbers document isn’t supported, so those mail merge fields ÂÂ
will export as text.

Viewing the document as an outline isn’t supported.ÂÂ
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Viewing the document in full-screen view isn’t supported.ÂÂ

Password protection for your document isn’t supported.ÂÂ

Sending Your Pages Document to iWork.com public beta
You can send your document to iWork.com and access it using any computer with 
a supported web browser, an email account, and your Apple ID. Your Apple ID is the 
same as your MobileMe subscriber name or iTunes store account ID. If you don’t have 
an Apple ID, go to https://appleid.apple.com and follow the onscreen instructions to 
get one.

When you send a document to iWork.com, you can choose from the following options:

ÂÂ Share with viewers: Invite specific viewers to add comments and notes, and 
download your document.

ÂÂ Publish on the web: Create a public web address (URL) that you can post on a 
website or elsewhere so that anyone can view your document. General viewers can’t 
view or leave comments and notes on your document.

ÂÂ Upload for private use: Send your document to iWork.com to be viewed only by 
yourself. You can choose to share with other viewers at a later time.

Important:  If you assigned your document a password, it won’t protect the document 
when it’s viewed on iWork.com. That password is only in effect when viewers 
download the password-protected document and view it on their computers. To 
password-protect the document online, you must set an online password when you 
post the document.

https://appleid.apple.com


To share a document with invited viewers:
	 1	 Open the document you want to share, and then click the Share button in the toolbar, 

or choose Share > “Share via iWork.com.”

	 2	 Type your Apple ID and password, and then click Sign In.

If you've forgotten your Apple ID or password, click Forgot Password, and then follow 
the onscreen instructions.

If it’s your first time sending a document to iWork.com, an email verification is sent to 
your email address. Click the verification link in the email, and then continue sharing.

	 3	 Select “Share with viewers.”

	 4	 In the To and Message fields, type the email addresses and a message for the people 
you want to allow access to the document.

	 5	 Type a subject if you don’t want to use the one created automatically.

	 6	 Set viewing options for your shared document. Click Show Advanced to see all of 
these options:

Leave comments: Select to allow viewers to leave comments on the document.

Download the document: Select to allow viewers to download the document.

Copy to iWork.com as: Type or choose a filename for the online document.

Download Options: Select one or more file format options in which to make the 
document available for download.

Privacy: Select to require viewers to enter a password before viewing the document 
online. Type an online password in the fields provided, and then click Set Password. Be 
sure to notify viewers of the document’s password.

You can use the Password Assistant (click the button with the key icon) to help 
you create a stronger password. To learn more about the Password Assistant, see 
“Password-Protecting Your Document” on page 36.

	 7	 Click Share.

A copy of your document is sent to iWork.com and invitations are emailed to your 
viewers. Viewers click the unique link in their email to access your document online. If 
they leave comments, their name appears on the comments.

To publish a document on the web for general viewing:
	 1	 Open the document you want to share, and then click the Share button in the toolbar, 

or choose Share > “Share via iWork.com.”

	 2	 Type your Apple ID and password, and then click Sign In.

If you've forgotten your Apple ID or password, click Forgot Password, and then follow 
the onscreen instructions.
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If it’s your first time sending a document to iWork.com, an email verification  
is sent to your email address. Click the verification link in the email, and then  
continue publishing.

	 3	 Select “Publish on the web.”

	 4	 Click Show Advanced if you want to change the online name of the document, and 
then type or choose a filename for the online document.

	 5	 Click Publish.

A copy of your document is published to iWork.com. Viewers can read your document, 
but they can’t add comments and notes to it.

	 6	 In the dialog that appears, click View Online to see your document on iWork.com.

	 7	 Click Show Public URL to see the web address for your document.

You can copy the web address and post it on a website, blog, or social networking site. 
Anyone with the web address can view your document online.

To upload a document for your private access:
	 1	 Open the document, and then click the Share button in the toolbar, or choose Share > 

“Share via iWork.com.”

	 2	 Type your Apple ID and password, and then click Sign In.

If you've forgotten your Apple ID or password, click Forgot Password, and then follow 
the onscreen instructions.

If it’s your first time sending a document to iWork.com, an email verification is sent to 
your email address. Click the verification link in the email, and then continue uploading.

	 3	 Select “Upload for private use.”

	 4	 Click Show Advanced if you want to change the online name of the document, and 
then type or choose a filename for the online document.

	 5	 Click the Upload button

A copy of your document is sent to iWork.com.

	 6	 Click View Online to see your document on iWork.com, or click OK to close the dialog.

To access all your online documents from the Shared Documents view of iWork.
com, do either of the following:
Open a document and choose Share > Show Shared Documents. If you’re not already mm

logged in, choose Share > Sign In, and then choose Show Shared Documents.

Go to mm http://www.iwork.com/ and sign in.

You can set iWork.com to notify you by email when viewers post new comments to an 
online document. For this information, and more details about using iWork.com, go to 
http://www.iwork.com/ and click Help at the bottom of the page.

http://www.iwork.com/
http://www.iwork.com/


Emailing Your Pages Document
Attach a Pages, Microsoft Word, or PDF version of your Pages document to an email. 

To email a document:
	 1	 Open your Pages document, choose Share > “Send via Mail,” and then choose Pages, 

Word, or PDF from the submenu.

Pages:  Creates a Pages version of your document.

Word:  Creates a Microsoft Word version of your document.

PDF:  Creates a PDF version of your document.

	 2	 A new mail message opens with the document version attached to it. Edit the email 
message and click Send.

Pages documents with password protection are emailed securely. Recipients are 
required to use a password to view secure documents. To learn more about password-
protecting your documents, see “Password-Protecting Your Document” on page 36.

Emailing password-protected PDFs and Microsoft Word documents isn’t supported.

Sending a Pages Document to iWeb
If you use (or intend to use) iWeb to create a website, you can send a Pages document 
directly to your iWeb blog or podcast. The document becomes an attachment that 
your website visitors can download.

To send a document to iWeb:
	 1	 Make sure you have iWeb ’08 or later installed.

	 2	 Open your Pages document and choose Share > “Send to iWeb” > PDF, or Share > 
“Send to iWeb” > Pages.

PDF:  Creates a PDF version of your document.

Pages:  Creates an archive version of your document.

	 3	 If iWeb wasn’t open, it opens, and you can choose a new or existing blog or podcast 
to attach your document to. If you have only one blog or podcast, the document is 
attached to it.

When you publish your website, visitors who subscribe to your blog or podcast will 
automatically get the latest attachments sent to their iTunes library (PDF publish only).

For more information about using iWeb to design and publish webpages, open iWeb 
and choose Help > iWeb Help.

Sending password-protected PDFs to iWeb isn’t supported.
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Create your own document templates.

This chapter assumes you are already familiar with the design and formatting features 
of Pages described in earlier chapters.

Designing a Template
The templates that come with Pages provide ideas for page designs as well as the look 
of charts, tables, and text. You can modify the following attributes of these templates 
to create your own templates: 

Page orientation ÂÂ

Page layout and section formattingÂÂ

Page marginsÂÂ

Page numberingÂÂ

Background graphics (watermarks)ÂÂ

A variety of text styles, including body text, headers, footers, callouts, and so onÂÂ

Table of contents stylesÂÂ

Bullet and numbering stylesÂÂ

Object fills and line styles for objectsÂÂ

Chart colors and stylesÂÂ

The look of tablesÂÂ

Additional template page designsÂÂ

Creating your own template can be as simple as adding your company logo to an 
existing template, but you can also add images, change placeholder text, or define 
new text styles. Or you can start with a blank document and create your own template.

13Designing Your Own Document 
Templates



To learn about Go to

Setting up a custom template’s overall 
appearance

“Setting Up a Document to Use as a Custom 
Template” on page 266

Setting default attributes for text boxes, shapes, 
tables, charts, and images

“Defining Default Attributes in a Custom 
Template” on page 267

Adding text and media placeholders “Creating Placeholders in Custom Templates” on 
page 270

Creating template sections others can add to “Adding Sections to a Custom Template” on 
page 271

Accessing your template in the Template Chooser “Saving a Custom Template” on page 272

Setting Up a Document to Use as a Custom Template
The first step in setting up a document as a template is to set up the overall size and 
shape of the document. 

Here are ways to set up general document attributes:
Set paper size and orientation. mm

Consider the paper size and orientation that will be used for the finished document. 
For example, if you are creating a template for envelopes, make sure that you have 
selected the correct envelope size (or created a custom size) before you proceed with 
further document design. To learn about setting the paper size and orientation, see 
“Setting the Paper Size and Orientation” on page 253.

Set page margins.mm

Define the body text area and header and footer text areas. If your document will 
be bound, you can set different margins for right- and left-facing pages. Document 
margins are set in the Document inspector. For more information, see “Setting 
Document Margins” on page 46.

Set up the format of headers and footers.mm

Define recurring text and graphics you want to appear at the top or bottom of pages 
in the document. See “Using Headers and Footers” on page 54 for instructions.

Place master objects.mm

Add watermarks, logos, or other background images so they appear in the same spot 
on every page of your document. See “Using Master Objects (Repeated Background 
Images)” on page 63 for details.

Add alignment guides.mm

Create alignment guides to help place floating objects in the same position on different 
pages. See “Creating Your Own Alignment Guides” on page 162 for instructions.
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Defining Default Attributes in a Custom Template
A template must have default values defined for the following document elements: 

Paragraph, character, and list styles ÂÂ

Table of contents attributesÂÂ

Text box attributesÂÂ

Shape attributesÂÂ

Table attributesÂÂ

Chart attributesÂÂ

Imported graphics attributesÂÂ

You can customize any of these for the template you are creating, or you can use the 
default settings that already exist in the template you started with (including the Blank 
and Blank Canvas templates).

You can modify an existing style or create a new style if you don’t find a paragraph, 
character, or list style with exactly the look you want. See “Creating New Styles” on 
page 126 for more information.

Consider including a formatted table of contents in your Word Processing template. 
See “Using a Table of Contents” on page 64 for information.

To learn about Go to

Setting up the default appearance for text boxes 
and shapes

“Defining Default Attributes for Text Boxes and 
Shapes” on page 267

Establishing the default number of rows, columns, 
and other attributes in a table

“Defining Default Attributes for Tables” on 
page 268

Setting up a chart type and appearance “Defining Default Attributes for Charts” on 
page 269

Setting default shadows, opacity, and other 
settings for imported graphics

“Defining Default Attributes for Imported 
Images” on page 270

Defining Default Attributes for Text Boxes and Shapes
The default attributes of text boxes and shapes determine their color, size, and 
orientation when they’re first inserted on a page. 

To define a default text box:
	 1	 Place a floating text box on the page. 

To read about placing a floating text box, see “Adding a Floating Text Box” on page 104. 

	 2	 Type text into the text box, select the text, and then set its attributes. 

To read about setting text attributes, see “Formatting Text Size and Appearance” on 
page 82.



	 3	 Select the text box, and then set its attributes. 

See “Modifying Objects” on page 164 and “Filling Objects with Colors or Images” on 
page 171 for more information.

	 4	 Set text wrapping using the Wrap inspector. 

To read about setting text wrapping, see “Wrapping Text Around an Inline or Floating 
Object” on page 113.

	 5	 Select the text box, and then choose Format > Advanced > Define Default Text Box Style.

	 6	 Delete the text box from the page.

To define a default shape:
	 1	 Place a floating shape on the page. 

To read about placing a floating shape, see “What Are Floating and Inline Objects?” on 
page 137. 

	 2	 Type text into the shape, select the text, and then set its attributes. 

To read about setting text attributes, see “Formatting Text Size and Appearance” on 
page 82.

	 3	 Select the shape, and then set its attributes. 

See “Modifying Objects” on page 164 and “Filling Objects with Colors or Images” on 
page 171 for more information.

Line length and orientation can’t be defined within a template. Line attributes such as 
color, thickness, and opacity must be set separately.

	 4	 Set text wrapping using the Wrap inspector. 

To read about setting text wrapping, see “Wrapping Text Around an Inline or Floating 
Object” on page 113.

	 5	 Select the shape, and then choose Format > Advanced > Define Default Shape Style.

	 6	 Delete the shape from the page.

Defining Default Attributes for Tables
You can set up attributes such as number of rows and columns, line styles and colors, 
text styles, and shadows for the default table. 

A table consists of distinct formatting areas, including the header row, header column, 
inside borders, and outside borders. To set default table attributes, you must apply 
each attribute to an entire formatting area. For example, if you change the formatting 
of one cell in a header row, the change will not be saved as part of the default table 
style; you need to change the formatting of all the cells in the header row.

To set default table attributes:
	 1	 Place a table on the page. 
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“Adding a Table” on page 176 tells you how.

	 2	 Select the table, and then set its attributes.

See “Resizing a Table” on page 179 if you want to change the table’s dimensions.

See “Working with Rows and Columns in Tables” on page 184 to learn about adding 
and removing columns and rows and creating header rows and columns.

See “Putting Content into Table Cells” on page 191 for information about splitting and 
merging table cells, resizing them, and formatting their borders.

See “Working with Numbers in Table Cells” on page 193 to learn about options for 
formatting cells that will contain numbers.

See “Adding Images or Color to Table Cells” on page 198 if you want to add graphics to 
the table.

	 3	 Set text wrapping around the table. 

See “Wrapping Text Around an Inline or Floating Object” on page 113 for instructions.

	 4	 Choose Format > Advanced > Define Default Table Style.

	 5	 Delete the table from the page.

Defining Default Attributes for Charts
For charts, you can set the chart (the type of chart that appears when you choose 
Insert > Chart) and the default look of each chart type. Default attributes must be set 
individually for each chart type. 

To set chart styles and placement:
	 1	 Place a chart on the page. 

See “Adding a New Chart and Entering Your Data” on page 225 for instructions.

	 2	 Select the chart, and then set its attributes.

See “About Charts” on page 221 to learn how to specify a chart type.

See “Formatting Charts” on page 228 to learn how to resize a chart, rotate it, and set 
other attributes that charts have in common.

	 3	 Set the text wrapping around the chart. 

See “Wrapping Text Around an Inline or Floating Object” on page 113 for instructions.

	 4	 Repeat steps 1 through 3 for each chart type.

	 5	 Select each chart, one at a time, and then choose Format > Advanced > “Define 
Default Style for chart type Chart.”

	 6	 Select the chart type that you want to be the first chart that appears when you choose 
Insert > Chart, and then choose Format > Advanced > “Make chart type the Default 
Chart Type.”



	 7	 Delete the charts from the page.

Defining Default Attributes for Imported Images
For imported graphics, you can set default shadows, opacity, and outline (stroke) color. 

To set default image attributes:
	 1	 Place an image on the page. 

See “Working with Images” on page 138.

	 2	 Select the image, and then set its attributes.

See “Adding Shadows” on page 168 to learn how to add a shadow.

See “Adjusting Opacity” on page 170 to learn how to adjust transparency.

See “Changing the Style of Borders” on page 166 for information about borders around 
imported images.

See “Adding a Reflection” on page 169 for information about adding reflections to 
imported images.

See “Framing Objects” on page 167 for information about adding graphical borders 
around imported images.

	 3	 Set text wrapping around the image. 

See “Wrapping Text Around an Inline or Floating Object” on page 113 for instructions.

	 4	 Choose Format > Advanced > Define Default Image Style.

	 5	 Delete the image from the page.

Creating Placeholders in Custom Templates
Placeholder text and media placeholders model the look of the finished document. 
They can also provide instructions for the person using the template. 

To create placeholder text, do one of the following:
To edit existing placeholder text, select it, and then mm

choose Format > Advanced > Enable Placeholder Text Authoring. After editing the 
text, choose Format > Advanced > Disable Placeholder Text Authoring. 

To create placeholder text from scratch, type some text on the page, and then format mm

it the way you want.

Select the text in blocks, so that template users can replace the text one block at a 
time, with placeholder text in each block providing guidance for what the user should 
type. Then choose Format > Advanced > “Define as Placeholder Text” for each block.
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When selecting blocks of text, be careful not to select the final paragraph break 
character. Doing so causes the entire paragraph to be deleted when the user begins 
typing in the placeholder text, and the new text takes on the attributes of the 
following paragraph. To see the paragraph break character as you work, click View in 
the toolbar, and then choose Show Invisibles.

To remove placeholder text, select it, and then press the Delete key.

To create a media placeholder:
	 1	 Add an image, movie, or audio file to the document. 

See “Working with Images” on page 138, “Adding a Sound File” on page 153, and 
“Adding a Movie File” on page 154 for instructions.

	 2	 Select the imported object and move it to the location where you want it in the 
document, as “Moving and Positioning Objects” on page 158 describes.

	 3	 Format the imported object, as “About Manipulating, Arranging, and Changing the 
Look of Objects” on page 157 describes.

	 4	 Select the object, and then choose Format > Advanced > “Define as Media 
Placeholder.”

To delete a media placeholder, select it, and then press the Delete key.

Adding Sections to a Custom Template
You can make your template expandable so that Word Processing template users can 
simply insert additional sections by using the Pages button in the toolbar, as described 
in “Adding New Template Pages” on page 80. 

To create template sections that users can add:
	 1	 Design a layout of one or more pages, inserting a section break at the beginning and 

end of the layout. 

	 2	 Choose Format > Advanced > Capture Pages. A dialog opens.

	 3	 Type a name for the template section.

	 4	 Choose the number of pages you want to include in the page design from the Include 
pop-up menu.

	 5	 Click OK.



	 6	 Delete the pages from your template if you don’t want them to be part of the initial 
template.

To rearrange, rename, or delete template sections you have created:
	 1	 Choose Format > Advanced > Manage Pages.

A dialog opens.

	 2	 Select a section, double-click the name, and then type new text to rename it.

	 3	 Click the up or down arrow buttons to change a section’s position in the list.

	 4	 Click the Delete (–) button to remove the section.

	 5	 Click Done when you have finished.

Saving a Custom Template
You can save your new template so that it appears in the Template Chooser. 

When a user chooses the template to create a new document, the new document 
opens in exactly the same state as when you saved it. That means you can choose to 
leave the Styles drawer open or closed; leave invisibles, rulers, and layout marks visible; 
and so on.  

To save a custom template:
	 1	 Choose File > “Save as Template.”

	 2	 Type a name for the template.

	 3	 Specify a folder in which to save your template.

By default, it will be saved in your home folder in Library/Application Support/iWork/
Pages/Templates/My Templates/ and it will appear in the My Templates pane of the 
Template Chooser.
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To save the template in a different location in your home folder, go to Library/
Application Support/iWork/Pages/Templates/ and create a new folder. The folder name 
is used as the template category in the Template Chooser.

	 4	 Click Save.

To delete a custom template, in the Finder navigate to the folder in which you saved 
the template, and drag the template to the Trash.
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background images. See master objects
bar charts

setting shadows, spacing, and series names  241
bibliographies. See EndNote application
bulleted list

adding new  100
rearranging and editing  101
See also text

C
character styles. See styles
Characters window  132
Chart Data Editor  222
Chart inspector  221
charts

adding  225
adding a chart title and a legend  229
changing from one type to another  226
editing  225
editing existing data  227
entering data  225
formatting  228
formatting a title and a legend  229
formatting axes  230
resizing  230

rotating  230
showing error bars  235
showing trendlines  236
updating from a Numbers document  227

checking spelling  118
citations. See EndNote application
closing a document  42
Colors window  26
column charts

setting shadows, spacing, and series names  241
columns

adjusting space around outside margins  52
changing width  50
defining column breaks  51
using multiple  50
See also gutters

comment anchor  76
comments

changing  76
deleting  76
formatting  76
inserting  76
printing  76
table cells  200
viewing and hiding  76

contents. See table of contents
custom templates

adding sections  271
creating image placeholders  270
creating text placeholders  270
defining default attributes for charts  269
defining default attributes for imported 

images  270
defining default attributes for tables  268
defining default attributes for text boxes and 

shapes  267
defining styles  267
designing your own  265
saving  272
setting up document to use  266
Template Chooser  272
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D
data series

adding multiple tables  233
document

creating  32
opening existing  34
password protect  36
setting margins  46
setting page orientation and size  46
viewing full screen  35
See also printing

Document inspector  45

E
EndNote application  66
endnotes

adding and editing  55
at the end of a document  56
at the end of a section  56
converting to footnotes  57
defining and changing marks used  58
deleting  57
formatting  57
jumping from mark to note  57
numbering  58
restarting numbering  59

exporting a file
as a Microsoft Word (doc) document  256
as a PDF document  256
as a plain text (txt) document  256
as a rich text format (RTF) document  256
in iWork '08 format  260
to iWeb  264

F
facing pages

defining headers and footers  62
defining margins  53, 62
using left- and right- facing pages  52
See also layout

Find & Replace dialog  120
font or file missing (error message)  31
Fonts window  25
footers. See headers and footers
footnotes

adding and editing  55
converting to endnotes  57
defining and changing marks used  58
deleting  57
formatting  57
jumping from mark to note  57
numbering  58
restarting numbering  59
See also endnotes

format bar  23

formatting characters. See invisibles
formatting charts

text of titles, labels, and legends  229
formatting text

adding accent marks  87
adding strikethrough  83
adjusting character spacing  93
adjusting line spacing  91
adjusting paragraph spacing  92
changing color  93
changing fonts  86
changing horizontal text alignment  90
changing text size and appearance  84
changing vertical text alignment  91
creating outlined  84
creating shadows  83
font smoothing  86
subscript  85
superscript  85
using smart quotes  89

H
headers and footers

adding page numbers  54
changing in sections  61
defining for facing pages  62
using  54

help tags  23
Hyperlink inspector  110
hyperlinks

editing  113
to a preaddressed email message  111
to a specific page  111
to a webpage  110

I
images

adjusting saturation  144
adjusting sharpness  144
histogram  144
masking (cropping)  141
reducing file sizes  142
removing unwanted background  143

importing a file
by dragging  34
by menu  34
file formats supported  34
from other applications  34

importing an image  138
indenting text. See formatting text
information for document searches

See also Spotlight
inline objects

converting to floating  137
using  137

inset margin (text in objects). See formatting text
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Inspector window  23
inspectors

opening multiple  23
using for formatting  23

invisibles
showing  21
symbols for  21

iWork ’05, ’06, ’08
opening documents  34
saving an iWork ’09 document as  34

iWork.com  261

K
keyboard shortcuts

using  30
viewing a list of shortcuts in help  30

L
landscape page orientation  46
layout

adding elements to  49
changing  49
defining column breaks  51
defining columns  50
defining headers and footers for facing pages  53
defining layout breaks  51
defining margins  52
defining margins for facing pages  53
inserting layout breaks  51
using different left and right pages  53
viewing facing pages  54
See also columns

Layout inspector  46
layout view  19
line breaks  49
line charts

customizing data point symbols and lines  242
linking text boxes

floating  106
See also text boxes

lists
creating  100
creating bulleted  100

logos. See master objects

M
mail merge

defining merge fields  249
inserting Address Book or Numbers data  247
merge field names  250

margins. See document
master objects

adding  63
for different sections  63
making selectable  63

MathType application  174
Media Browser  24, 152
media playback settings

adjusting  155
menus

formatting text  82
Metrics inspector  158, 179, 180
movie file

adding  154
moving through a document. See navigating

N
navigating

scrolling through pages  29
to a specific page  29

nonbreaking space
inserting  118

numbered list
rearranging and editing  102

numbering pages. See page numbers

O
objects

adding reflection  169
adding shadows  168
adjusting opacity  170
aligning  160, 161
changing the border style  166
connecting  163
copying or duplicating  158
deleting  158
filling with an image  171, 173
filling with blended color  171
filling with color  171
flipping and rotating  166
framing  155, 167
grouping and ungrouping  163
locking and unlocking  164
modifying  164
moving and positioning  158
moving forward or backward  159
moving to the background  160
reducing size of media files  156
resizing  165
selecting  157

ordered list
rearranging and editing  103

orphan and widow lines. See paragraphs
outline view

expanding and collapsing  98
rearranging a document  98
switching to  98

P
page break
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inserting  47
starting a paragraph on a new page  48

page numbers
adding  115
formatting  115
See also headers and footers

page view
choosing options  18
document page  19
layout  19

Pages Preferences  89, 96, 117
paragraph styles. See styles
paragraphs

keeping entire on the same page  48
keeping together on a page  48
preventing widow and orphan lines  49
setting indents  97

personalizing documents
defining merge fields  249
inserting merge data  247
inserting sender data  247
merge fields  250
using data not in Address Book or vCard  249

pie charts
adding shadows  240
changing colors and textures  238
separating individual wedges  240
showing labels  239

placeholders
image  140
in columns  108
tables  78
text  78

polygon shape
editing  152

portrait page orientation  46
printing

a specified page range  255
document  253
options  253
previewing before  254
with comments showing  256

proofread
as you type  120

R
ruler

showing and hiding  96
using to set indents  97

S
saving

as an iWork '08 document  260
as a template  39
backup version  40
copy of document  39

document  37
scatter charts

using  243
scroll bars and arrows  29
sections

adding and deleting  60
creating  59
defining attributes  61, 62
formatting facing pages  62
managing with thumbnail view  60, 61
restarting page numbering in  61
reusing  63

shapes
adding custom  146
adding predrawn  146
creating  145
editing  147
editing predrawn  150, 151, 152
making editable  148
manipulating points  148
reshaping a curve  149
reshaping a straight segment  150
transforming corner points into curved 

points  150
using the Draw tool  146

shortcuts
keyboard shortcuts  30
shortcut menus  30

sound file
adding  153

spelling check
as you type  118
of selected text  118
working with suggested spelling  118

Spotlight  30, 43
star shape

adding  152
styles

applying  125
copying and pasting  134
creating new character styles  126, 134
creating new paragraph styles  126
deleting  127
importing  135
modifying  127, 129, 131, 132
overriding  134
renaming  127
types available  123
See also lists

Styles Drawer  27

T
tab stops

adding and changing  94, 95
changing with the ruler  94, 95
deleting  96
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setting the default distance between  96
table cells

adding and editing content  191
adding color  198
adding images  198
associating conditions with custom number 

format  214
autofilling  193
automatic formatting  202
changing a custom cell format  218
changing conditional formatting  197
comments  200
conditional formatting  195
copying  200
creating a custom date and time format  216
creating a custom text format  217
currency formatting  204
custom number formats  207
date and time formatting  205
defining conditional formatting  196
defining the decimals element of a custom 

number format  210
defining the integers element of a custom 

format  209
defining the scale of a custom number 

format  212
displaying content too large for cell  194
duration formatting  205
formatting borders  199
formatting for display  201
formatting for displaying values  207
fraction formatting  205
managing conditional formatting  197
merging  198
moving  200
number formatting  203
numeral system formatting  206
percentage formatting  204
reordering, renaming, and deleting custom 

formats  220
scientific formatting  206
splitting  199
text formatting  207
working with numbers  193
working with text  192

Table inspector  177, 191
table of contents

adding leader lines  65
creating  64
formatting  65
updating after revisions  64

tables
adding  176
adding columns  186
adding footer rows  188
adding header columns  187

adding header rows  187
adding rows  185
adding rows and columns  184
alternating row colors  189
changing appearance  180
converting text to a table  181
copying between iWork applications  181
deleting rows and columns  186
moving  180
resizing  179
resizing rows and columns  188
selecting  182
selecting a group of table cells  183
selecting a row or column  183
selecting a table cell  182
selecting cell borders  184
sorting rows  190
table tools  177

Template Chooser. See custom templates
template pages

adding  80
deleting  80

templates
choosing  15
options  15
saving  39
skimming to view page designs  32

text
adding borders and rules  108
adding in shapes  109
copying  81
deleting  81
highlighting  107
pasting  81
selecting  81
splitting into columns  108

text boxes
defining columns  108
floating  104
inline  105
linking  106

Text inspector  23
thumbnails

See also sections
toolbar

adding an item  21
changing tool icon size  21
choosing only icons or only text for tools  21
customizing  21
default tools  21
rearranging items  21
removing items  21
restoring default tool set  21
showing and hiding  21
using the Command and Control keys to 

change  21
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tools. See toolbar
track changes

accepting and rejecting edits  75
change bubbles  73
editing with  70
in shapes  70
in table cells  74
starting, pausing, and stopping  72

typography
changing capitalization  85
characters and symbols  88

Typography window  89

U
undoing changes  39

V
vCards. See personalizing documents

W
Warnings window   31
watermarks. See master objects
widow and orphan lines. See paragraphs
word count  43
Wrap inspector  114

Z
zoom level

changing  18
View control  18
View menu  18
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