iWeb
Getting Started
Get to know iWeb and learn how
to create your own website.
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Welcome to iWeb

1

This document will help you quickly create a website
using iWeb.
If you’ve always wanted your own website but weren’t sure how to create one, iWeb is
an easy and fun way to accomplish that goal.

About iWeb
iWeb is the easiest way to create and publish great-looking websites. You see what
each webpage will look like as you work on it—you don’t have to know anything about
programming or web-authoring languages such as HTML. Use any of the special
templates in iWeb to create a professional-looking website in minutes, and then
publish your website to MobileMe with the click of a button.
iWeb makes it easy to update and manage your website. Because iWeb is integrated
with iLife, it is easy to showcase your photos or art, create a blog or podcast, and add
special features like videos, maps, and ads to your website.

What You’ll Learn
In this tutorial, you’ll learn to do the following:
Â Create a website using predesigned templates
Â Add pages for photos and photo albums
Â Start a blog (a web journal)
Â Add a link to another website
Â Add a map
Â Add an Email Me button, so that your visitors can contact you
Â Publish your website, so people can visit it
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Before You Begin
To make it easier to complete this tutorial, you might want to print it.
In many tasks shown in the tutorial (and in iWeb Help), you need to choose menu
commands, which look like this:
Choose Edit > Copy.
The first word after Choose is the name of a menu in the iWeb menu bar. The next word
(or words) indicates the item to choose from that menu.

You can stop doing the tutorial at any time by choosing iWeb > Quit iWeb, or by
clicking the red close button at the top-left corner of the iWeb window. The next time
you open iWeb, your website is exactly as you left it.
Make sure you save your work from time to time by choosing File > Save.
Have fun and experiment as much as you like. You can always undo an action by
choosing Edit > Undo as many times as necessary to remove the changes you make.
The Undo command won’t remove anything you save.

What You Need
To follow along with all the steps in the tutorial, you’ll need some photos or other
graphics files on your computer. If you don’t have any, you can still do the rest of the
steps.

Useful Terms to Know
Here are brief definitions of some of the terms you’ll see as you work with iWeb.
Â AdSense ad: A service provided by Google that enables you to place advertisements
relevant to the surrounding page content on any page in your website. You earn
revenue from Google when your website visitors click ads.
Â blog: A web-based journal that can contain text, photos, and other media. For more
information, see “Creating a Blog” on page 14.
Â browser: An application you use to visit websites. (Mac OS X comes with a browser
called Safari.)
Â Domain file: The file on your computer that contains all your iWeb website data.
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Â domain name: The root (the first part, after “http” and “www”) of your site’s web
address is its domain. For example, the domain of the site www.example.com/index
is “example.com.”
Â homepage: The first page that appears when you visit a website. Sometimes called
the start page or default page.
Â hyperlink: Text or an object you can click to initiate an action, such as going to
another webpage or opening a document. Most text hyperlinks (also called links)
look different from surrounding text (they are underlined or a different color) to
indicate that you can click them.
Â Internet: A worldwide network of computers that makes it possible for people to
communicate with one another and share information.
Â MobileMe: A membership-based Internet service provided by Apple Inc. Your
MobileMe subscription provides one-click publishing for your iWeb sites, ad-free
email services, photo and video sharing, online backup, synchronization, and much
more. For more information, visit www.me.com.
Â navigation menu: The website table of contents. The navigation menu lists pages in
your website as links that visitors can click to go to individual pages. iWeb
automatically creates a navigation menu for your website.
Â podcast: An audio or video file that is like an Internet radio or TV show. You can
produce your own podcasts and let visitors download them one by one, or they can
download new episodes automatically through a subscription.
Â RSS: A feature that enables visitors to subscribe to the contents of a website and
receive automatic updates when new blog entries, podcast episodes, or photos are
added to the site. RSS stands for “really simple syndication.” When visitors subscribe
to the site’s feed, the updates are sent to the RSS reader of their choosing.
Â URL: The website address, which you enter in a browser to go to a website. (URL
means “Uniform Resource Locator.”) A typical URL looks like this:
http://www.apple.com
Â web: The web (or World Wide Web) is all the sites, pages, text, media files, and links
that people interact with when they get on the Internet. Although it is common to
use the terms web and Internet interchangeably, the Internet is actually the hardware
and software network upon which the web is built.
Â website: A collection of individual webpages that are linked together into a website.
Websites are usually organized around a theme, an individual, or an organization.
Also called site.
Â webpage: A single page within a website. Also called page.
Â web widget: An object that embeds content from the web into any of your
webpages. For example, a Google map or a snippet from another website such as
YouTube.
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iWeb Interface
Sidebar

Navigation menu

All the websites and
webpages you create
appear here. Click a page
to display it in the
webpage canvas.

All of the pages in
the site are listed
here. Visitors click
these links to view
your webpages.

Placeholder text
and graphics
Click the placeholder
text and type your
own titles and body
text. Drag your own
graphics files over
placeholder
graphics.

Webpage canvas
Edit the webpage here.
Customize the text, add
graphics and movies, add
links, arrange items
on the page, and more.

Sidebar
As you create websites and webpages, they appear in the sidebar. Click the disclosure
triangles to show or hide pages in a site or subpages in a blog. You can rearrange
pages by dragging them in the list. You can even drag a page from one website to
another.
Webpage canvas
The webpage canvas is where you create the content for a webpage. You can drag
graphics files, movie files, and sound files to the canvas to add them to your website.
The webpage canvas has four different regions:
Â The navigation bar, which contains the navigation menu (the table of contents for
the website)
Â The header at the top of the page
Â The footer at the bottom of the page
Â The body, between the header and the footer
For more information, see “About webpage regions” in iWeb Help.
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Learn iWeb

2

This tutorial takes you step by step through the process of
creating a simple website.
Overview of Creating a Website
Plan your website.
Your first step is to decide what you want on your website. Do you want to share
photos? Write a travel journal? Display a portfolio of your work? Your website will
consist of one or more webpages that are linked together. They can contain text,
graphics, video, audio, and more.
With iWeb, it’s easy to modify, add, or remove webpages at any time, so you don’t have
to decide every detail before you begin. You may want to create multiple websites so
that you can, for example, have a personal website and a website for your business.
Create your website.
After you decide how you want to use your website, the next step is to assemble and
organize the website content. The iWeb templates make it easy to enter your text, add
photos and movies, set up links to other websites, and so on.
Publish your website on the Internet.
After you create your website, you publish it so that others can visit it. With iWeb and a
MobileMe account, this step is as easy as clicking a button.
Note: To publish your website using the instructions in this tutorial, you need at least a
free trial MobileMe subscription and enough available iDisk storage space for your
webpages, including your media (the movies, photos, and so on that you add to your
website). If you don’t have a MobileMe account, you can sign up for one (a free 60-day
trial or a paid yearly subscription) by opening System Preferences and clicking
MobileMe (or by going to www.me.com).
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If you’re not sure exactly what you want to put on your website, you can still go
through the tutorial and learn how to use iWeb. Nothing will be visible to the public
until you publish your website. Later, when you’re ready to “go live” with your website,
you can publish it.

Step 1: Plan Your Website
iWeb provides themes and templates to help you create a beautiful site with a minimum
of effort. Your website can use as many or as few of the templates as you like,
depending on the content you want on your site.
Each theme provides a different style, or “look,” for your site. A template is a page
layout designed for a specific purpose, such as a blog, a podcast, or a photo album.
Every template is available for each theme.
Each time you add a new webpage to your site, you choose the page’s theme and
template. If you decide later to change the theme for a page, you just select the page
in the sidebar and click the Theme button in the toolbar to choose a new theme.

Step 2: Create Your Website
Now that you have an idea of what you want to do, start by creating a website that
consists of one welcome page. You’ll add more pages to your website as you go
through the tutorial. You can add pages in any order; it’s easy to rearrange them or
change the theme of pages later.
To create a website:
1 Do one of the following:
Â If iWeb isn’t open, click its icon in the Dock or double-click the iWeb application icon
in your Applications folder.
Â If iWeb is already open and you don’t see the template chooser shown in step 2
below, click the Add (+) button at the bottom of the iWeb window (or choose File >
New Page).
2 In the template chooser, click one of the themes on the left.
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This tutorial uses the Modern Frame theme.
Select a page template here.

Select a website
theme here.

3 Choose a template on the right.
The Welcome template is already selected for you (the selected template has a yellow
border around it).
4 Click Choose.
Now you have your first webpage. The sidebar shows your site and a Welcome page.

Adding Your Own Text
Each template contains text boxes with placeholder text for titles, headings, and body
text. You’ll replace the text on the page with your own text; you can move, resize, or
delete text boxes to fit your content.
To replace placeholder text with your own text:
m Double-click the placeholder text and start typing.
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When you start typing, the highlighted placeholder text is replaced by what you type.

Double-click placeholder
text and type.

You can move text boxes to different locations on the page or make them larger or
smaller to accommodate more or less text.
To move or resize a text box:
1 Click the text one time to show the selection handles around the text box.
2 Click inside the text box and drag the text box to reposition it.
3 Drag a selection handle to resize the text box.
Drag one of these
handles to resize the
text box.

Experiment with adding your own text and moving and resizing text boxes. You can
always choose Edit > Undo to reverse any actions you don’t want to keep, until you
publish your website.
To see the borders of all the text boxes on the page:
m Choose View > Show Layout to see all the text boxes.

Adding Your Own Graphics
The iWeb templates include placeholder graphics that are similar to placeholder text;
they indicate the size and placement of graphics in a template.
The easiest way to add graphics, music, and movies to your website is with the
Media Browser. When you click the Media button in the toolbar, you gain instant access
to your iTunes and iPhoto libraries. You don’t need to open these applications to access
their contents.
Click this button in the toolbar
to open the Media Browser.
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To replace a placeholder graphic with a photo:
1 Click Media in the toolbar.
2 Click Photos.
3 Choose the album or Event that contains the photo you want.
4 Locate the photo in the thumbnails at the bottom of the Media Browser and drag it on
top of the placeholder graphic on your webpage.

The placeholder graphic disappears and your photo is now in place. When you click the
photo, selection handles appear so that you can resize it.
You can also drag a photo from the desktop, the iPhoto application, or a folder on your
computer and place it on top of the placeholder graphic.
Experiment with replacing placeholder graphics with your own photos, movies, or
audio files using the Media Browser.

Inserting fixed and floating objects
If you want to place an object (including photos and other graphics) in the middle of
text or somewhere that doesn’t have a placeholder graphic, there are two ways to do
it: as a fixed object or as a floating object.
Fixed objects are inserted outside of text boxes. You can drag a fixed object
anywhere on the page and it won’t affect text or be affected by text or other objects.
Floating objects are inserted within text and get pushed along as the text grows.
If you place an object inside a text box, it must be a floating object. You can wrap text
only around floating objects. For more information, see iWeb Help.

Adding Photos and Photo Albums
iWeb provides templates for pages that contain mainly photos and movies instead of
text.
Â The Photos template includes a photo grid that automatically sizes and positions
each photo as you add it and provides a placeholder caption for each photo. It also
includes a Play Slideshow button that your visitors can click to view your photos as a
slideshow.
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Â The My Albums template creates an index page for multiple photo and movie
albums. Each album is represented on the page by one of the album’s photos.
Movies are represented by their poster frames. Visitors click a photo or poster frame
to view the album or watch the movie. When visitors move their mouse over the
album, they see a mini-slideshow.
Note: You can add photos and movies to any page (not just pages created with the
Photos or My Albums templates) by simply dragging them to the page. However, only
pages created with the Photos or Movies templates can be added to the My Albums
index page.
For this tutorial, you will add a Photos page and a My Albums page to your website and
add your photos and albums to them.
To add a Photos page:
1 Click the Add (+) button (or choose File > New Page).
2 In the template chooser, select a theme in the list on the left.
3 Select Photos from the templates on the right, and then click Choose.
The new page contains a photo grid with placeholder photos.
4 If the Media Browser isn’t open, click Media in the toolbar and then click Photos.
5 Choose the Event or album that contains the photos you want to add.
6 Select the photos from the thumbnails at the bottom of the Media Browser.
You can Shift-click multiple photos or Command-click photos that aren’t next to each
other.
7 Drag the photos to the photo grid on the Photos page.
A blue line appears around the photo grid when you drag the pictures over it. When
you drop the photos on the photo grid, they replace the existing placeholder graphics.
If you drag only one photo, all the extra placeholders in the photo grid disappear. Don’t
worry, though—the next photo you drag to the photo grid will be automatically
formatted like the first one, using the same style and size. You can add up to 500
photos or movies to an album on a Photos page.
8 Click the placeholder text below each photo and type a caption.
With your photos in place, now you can adjust the layout of the photos on the photo
grid. Just drag the photos to rearrange their order.
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When you click a photo, a Photo Grid window appears. Use the settings in this window
to change the style of the frame for all the photos on the page, change the number of
columns, turn captions on or off, and more. For more information about using these
settings, see “Changing the layout of photos on a Photos template” in iWeb Help.

Change the layout of
photos on the photo grid.

Choose a frame style.

While working in iWeb, select
to view page numbers on
paginated Photos pages, or
view one scrolling page. This
setting does not affect the
visitor’s view.

If the number of photos in the photo grid exceeds the “Photos per page” setting in the
Photo Grid window, iWeb divides the photo grid into multiple pages for your photos
and adds page numbers and navigation arrows.
Page numbers and
navigation arrows appear
when there are more
photos than the “Photos
per page” setting.

Another way to organize your photos is to use the detail view. When you double-click a
photo on a Photos page, the photo is enlarged so you can see it in more detail. Click
the view buttons at the top of the detail window to see thumbnails of the photos in a
photo browser across the top. When you click a thumbnail in the photo browser, the
enlarged photo is shown below. Visitors to your website will also be able to see this
view when they click a photo on your Photos page.

Click thumbnails to see
the photo enlarged
below. Click the arrows
to see the previous or
next set of thumbnails.
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Adding Multiple Photo Albums to a Page
If you have several photo or movie albums, you can create a My Albums page to
provide a single index page for all of your albums. Instead of seeing many albums in
your website navigation menu, visitors can click the single link for your My Albums
page and instantly have access to all your albums.
When visitors to your My Albums page move their mouse over albums, they can view a
slideshow within the album frame without leaving the page. When they click the
album, the album opens and they can view the pictures in a larger slideshow.
To add a My Albums page:
1 Click the Add (+) button (or choose File > New Page).
2 In the template chooser, select a theme in the list on the left.
3 Select My Albums from the templates on the right, and then click Choose.
The new page contains an album grid with a placeholder album.
4 Drag your Photos page from the sidebar to the album grid on the My Albums page.
When you drag photo albums from the Media Browser onto the album grid, iWeb
automatically creates a Photos page for the album and adds it to the My Albums index.
To reorganize albums on a My Albums page:
m Drag the Photos pages (under My Albums in the sidebar) into the order that you want
them to appear.
Click an album to see the Media Index window, where you can set the number of
columns, adjust spacing, and make other adjustments to the layout of the page. You
can change the transition effect between photos by choosing an option from the
“Album animation” pop-up menu.

Use the Media Index
window to change the
layout and format of a
My Albums index page.

Experiment with adding photos and albums and adjusting the layout of the Photos and
My Albums pages. You can find more information in iWeb Help.

Creating a Blog
A blog is a journal that’s posted on the web for others to read. The word blog is short
for web log. When new entries are published, the previous entries are always available
in an archive. Typically, blogs are organized so that the newest entries appear first.
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iWeb provides two kinds of blog templates: Blog and Podcast. A podcast is an audio or
video file that is like an Internet radio or TV show. You can produce your own podcasts
and let visitors download them one by one, or they can download new episodes
automatically through a subscription.
You can add audio and video to both Blog and Podcast templates.
For this tutorial, you’ll add a blog to your website and learn how to add new entries
to it.
To add a blog:
1 Click the Add (+) button (or choose File > New Page).
2 In the template chooser, select a theme in the list on the left (the tutorial uses
Modern Frame).
3 Select Blog from the thumbnails on the right, and then click Choose.
The first blog entry appears with the current date.
4 Double-click the placeholder text to create your own title and body text, or to change
the date.

All of your entries
are listed here. Click
an entry to display
it below.

Drag an image, audio
file, or movie to this
media placeholder.
Type your entry
title here.

Type your blog
content here.

When you add a page using one of the blog templates (Blog or Podcast), three icons
appear in the sidebar:
Â Blog is the page that your website visitors see. It contains excerpts (the opening text)
from your most recent blog entries. Visitors can click “Read more” to see the whole
entry.
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Â Entries is where you create and manage your blog entries. Your website visitors won’t
see this page, but if they click an excerpt on the main blog page, they’ll see the full
entry.
Â Archive contains all your entries, including those that don’t appear on the main
page. The blog templates include a link to the archive on the main blog page.

This page is the one your
website visitors see. It
displays excerpts of your
most recent blog entries
and a link to the archive.

You write and edit your
entries by clicking Entries.
The archive contains
entries that don’t appear
on the main page.

To add a new blog entry:
1 In the sidebar, click Entries.
2 Click the Add Entry button.
The new entry appears below the Title list with placeholder text and graphics.
3 Double-click the placeholder text to change the title and add your own text to the
entry.
4 Drag graphics from iPhoto or elsewhere on your computer to replace the placeholder
graphics. (If the Media Browser isn’t open, click Media in the toolbar and then click
Photos to access your photos.)
If you make changes to a blog entry, such as changing the font or the background
color, you can duplicate the entry the next time you add an entry and keep the same
formatting.
To create a new entry with your own formatting:
1 In the Entries list, select the page whose format you want to duplicate.
2 Choose Edit > Duplicate.
3 Type a title for the new entry and replace the text and graphics with your new content.
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To edit existing blog entries:
m Select the entry in the Title list and make your changes in the entry below the list.

Letting Visitors Add Comments to Your Website
If you publish your site to MobileMe, you can allow website visitors to add comments
to your blog or photos. These comments are visible to anyone who visits your
website.
On blog pages, you can also allow visitors to attach files—which other visitors can
download—to their comments. To prevent automated programs from posting spam
to your site, anyone who posts a comment is first required to type a displayed word.
Make sure to delete material that is objectionable or for which you don’t own the
necessary rights. You can easily remove comments and their attachments anytime,
using iWeb or any web browser. This gives you control over the content of your
website.
For more information about visitor comments and how to manage them, see
iWeb Help.

Adding Links to Other Pages
You can put hyperlinks on your pages that visitors can click to open another website.
To add a link to another website:
1 Open the page in iWeb where you want to add the link.
2 In Safari, open the page that you want to link to.
3 Select the website URL in the address bar at the top of Safari and drag it to the
webpage canvas in iWeb.
You can also add links to open a file or a song in the iTunes Store. For more
information, see the hyperlinks topics in iWeb Help.
Links in iWeb are turned off so you can edit them without accidentally clicking them. If
you want to test your links, you can turn them on in the Link Inspector.
Link Inspector button

Select to turn text or
objects into hyperlinks.
Type the address of the
webpage here.
Turn hyperlinks on or off
while you work in iWeb.

Chapter 2 Learn iWeb

17

To make links active in iWeb:
1 Click the Inspector button in the toolbar (if you don’t see it, click the right arrow in the
toolbar and select Inspector).
2 Click the Link Inspector button, and then click Hyperlink.
3 Select the “Make hyperlinks active” checkbox.
Important: This setting doesn’t affect links on your published website; it only turns
links on or off in iWeb so you can edit and test them.
Adding an Email Me button
Websites usually have a way for visitors to contact the owner or administrator of the
site. You can add an Email Me button to any page in your website so that visitors can
contact you. When visitors click the button, they’ll see a new email message addressed
to your MobileMe email address.
If you don’t publish your site to MobileMe, the address on the Me card in Address Book
is used. If you want to use a different email address, open the Site Inspector (click the
Inspector button in the toolbar, then click the Site Inspector button) and type your
email address in the Contact Email box.

To add an Email Me button:
m Choose Insert > Button > Email Me.
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Turn Anything into a Hyperlink
In addition to creating text hyperlinks, you can make any image, photo, or shape
initiate one of the actions available in the Link To pop-up menu in the Link Inspector.
For example, you could insert an arrow shape and then make it a link that visitors can
click to go to the next page. For information about creating these kinds of hyperlinks,
see “Creating a hyperlink” in iWeb Help.

Adding a Map
You can easily add a map to your website so that, for example, customers can find your
store or friends can find your party. The map is a graphic from Google Maps.
To add a map:
1 Choose Insert > Google Map (or click Web Widgets in the toolbar and choose
Google Map).
2 In the Google Map window that appears, type the address and click Apply.
3 Double-click the map and then use the zoom controls on the map to refine the amount
of detail it shows.
4 In the Google Map window, select the checkboxes to set whether visitors to your
website will see the zoom controls and the address bubble.
5 Drag the map selection handles to resize the map.
6 Drag the map to where you want it to appear on your page.
To restore the original map view for this address, click Apply again.
For information about adding other web widgets, videos, and Google AdSense ads to
your webpages, see iWeb Help.
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Organizing Your Website
iWeb automatically creates a navigation menu—a table of contents that appears on
every page of your website. Users click a page title in the navigation menu to go to
that page.
When you add a new page to a site, iWeb automatically adds a link for it to the
navigation menu. You determine the order of items in the navigation menu by
rearranging pages in the sidebar. The navigation menu is automatically updated to
reflect the new organization.
The navigation menu is updated
automatically when you reorder
pages in the sidebar.

Drag pages in
the sidebar to
reorder them.

The first page in the sidebar is the website’s homepage and the first page that visitors
see when they visit your website. To make a different page the homepage, simply drag
it to the top of the list, just below the site name.
You can create more than one website in iWeb and they all appear in the sidebar. The
first site in the sidebar is also referred to as the start site.
Note: You can prevent a page from appearing in the navigation menu using the Page
Inspector. For more information, see “Modifying the navigation menu (table of
contents)” in iWeb Help.

Deleting Webpages and Websites
You can delete a webpage or website by selecting it in the sidebar and pressing
Delete. The webpage is automatically removed from the navigation menu and the
content is permanently deleted unless you immediately choose Edit > Undo Delete.
If you already published a website to MobileMe, deleting the site or one of its pages
in iWeb doesn’t immediately delete it from the web. The site or page is removed from
the web the next time you publish using iWeb.
A website must contain at least one page, so if you try to delete the only page in a
site, the template chooser appears. When you delete a published website and don’t
republish a site with the same site name, anyone who tries to visit the site by typing
in the URL or using a bookmark sees a message that the site couldn’t be found.
For more information, see iWeb Help.
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Renaming Your Site or Page
When you add a new website or webpage, iWeb gives it a default name. The site name
appears in your website’s URL:
http://web.me.com/YourMemberName/SiteName
The page name appears at the top of the visitor’s browser window:
The page name
appears in the
website’s URL and
at the top of the
browser window.

The site name you use
here is part of your
website’s URL.

You might want to rename your site or any of your pages to reflect their content.
Important: If you publish a site and later rename it, previously created links to your site
(such as bookmarks created by your visitors) won’t work. Be sure to notify your visitors
if you rename your site, especially your blog or podcast subscribers.
To rename a site or page:
m Double-click the name in the sidebar and type the new name.

Step 3: Publish Your Website on the Internet
Now that you have a website with one or more pages organized the way you want, you
can publish your website to MobileMe so that others can visit your site.
First, make sure you have at least a free trial MobileMe subscription. You (and others)
can access your iWeb website until the trial period expires; as soon as you become a
MobileMe member, you can publish your site again. To get a free or full MobileMe
subscription, visit www.me.com.
To publish your website to MobileMe:
m Click Publish (or choose File > “Publish to MobileMe”).
When you see the message that your site has been published, you can click Visit Site
Now to go to the site in your web browser. To send an email notifying people about
your website, click Announce.
If you purchased your own domain name (for example, www.example.com) from a
service provider, you can use that URL for websites you create with iWeb.
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To use your own domain name for a site published to MobileMe:
1 Choose File > Set Up Personal Domain.
2 On the MobileMe website, follow the onscreen instructions.
Anyone who has access to the Internet can visit your site. People who know the URL
can go directly to your website, or your website might appear as a search result. If you
don’t want your website to be visible to everyone on the Internet, you can set up your
website so that only people who know the user name and password can visit it.
To protect your site with a password:
1 If the Site Inspector isn’t open, click Inspector in the toolbar (or choose View >
Show Inspector), and then click the Site Inspector button.
2 Click Password.
Site Inspector button

3 Select the “Make my published site private” checkbox.
4 Type a user name and password in the fields.
Everyone you want to access your site uses the same user name and password.
Important: Don’t enter your MobileMe user name and password; create a name and
password that would be hard to guess. They don’t have to be real words; you could use
a combination of letters and numbers. Passwords are case-sensitive.
5 Publish your website by clicking the Publish button.
When the message appears saying that your site has been published successfully, click
Announce. The email message notifying people about your website will include the
user name and password you specified.
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Some of the features in iWeb can’t be used with any hosting service other than
MobileMe. If you publish your website to another hosting service, see “Publishing to a
server or hosting service other than MobileMe” in iWeb Help.

If You Already Have HomePage Content on Your MobileMe Site
If you have previously published webpages using HomePage, they are still
available at:
http://homepage.mac.com/YourMemberName
Websites you create in iWeb and publish to MobileMe are available at:
http://web.me.com/YourMemberName
Note: You can’t edit HomePage sites in iWeb.

Making Changes to Your Website
Most websites need to be updated from time to time. If you have a blog or published
podcasts, you will be making frequent changes. For these changes to be seen on the
Internet, you must republish your site to update the webpages.
When you click Publish (for MobileMe websites), all the sites and pages you changed
since the last time you published are published again. In other words, you can’t publish
only selected sites or pages; each time you click Publish or choose one of the Publish
commands in the File menu, your published sites will match the sites and pages in
iWeb.

Continue to Explore iWeb
Congratulations! You’ve completed the tutorial. You will probably want to further
customize your website content, add more photos and other graphics, and include
special elements such as an automatic visitor counter. As you get more comfortable
with iWeb, you might want to include other templates on your website.
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Getting More Help
There are several resources you can consult for additional help with iWeb:
Â Onscreen help: iWeb comes with a built-in help system. When iWeb is open, choose
Help > iWeb Help. When the help opens, type a word or phrase in the search field at
the top, or click a topic to get detailed instructions for completing specific tasks.
Â Video tutorials: These short videos demonstrate how to do common tasks in iWeb.
To access them, open iWeb Help, and then click “How-to videos” (available in some
languages only).
Â Help tags: Available for many onscreen items. To see a help tag, let the pointer rest
over an item for a few seconds.
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