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1 An Overview of Aperture 

Aperture is a powerful and easy-to-use digital image 
management system that can track thousands of digital 
images and provides professional-quality tools for working 
with your photos.

Aperture is a nondestructive image processing and database application that lets 
you efficiently acquire digital images, perform photo edits, adjust and retouch 
images, publish images on the web or in print, export images, and back up your 
images for safekeeping.

Before starting work, you need to understand how Aperture is used in your workflow. 
You�ll also need to find out about the basic elements used as you work with your 
images in Aperture. 

Using Aperture in Your Workflow
The following illustration shows the basic workflow steps you generally follow when 
using Aperture. Keep in mind that workflows can vary, either from person to person or 
from project to project. As you work in Aperture, you may not always proceed in strict 
linear order, and you may choose to overlap some steps.
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Elements in Aperture That Correspond to Workflow

Step 1:  Set up your Aperture system
For this beginning stage, you set up your Aperture system by connecting the hardware 
you need. For most users, it�s fairly straightforward: simply connect your camera or card 
reader to a FireWire or USB port on your computer, then turn on your computer and 
open Aperture. 

Step 2:  Acquire images and create projects
Once you�ve set up your Aperture system, you need to import your images into 
Aperture. Acquiring, or importing, images is the process of getting the images from 
your camera, a card reader, external storage media (such as a CD, DVD, or external hard 
disk drive), or folders on your computer into Aperture. You can choose to acquire many 
images, such as all the ones on a card, or selected images only. Before or during the 
import process, you have the option to create a new project to store your images. You 
can also create projects after importing, or at any stage in the process.

You can also import all or just a portion of your iPhoto Library. When you import your 
iPhoto Library, Aperture maintains the structure as well as all adjustments and 
information, also known as metadata, applied to the images.

Create projects in the
Projects panel.

Photo edit using the
Viewer...

Apply adjustments 
using the Adjustments 
Inspector.

As you photo edit, you 
can view information 
about an image using 
the Metadata Inspector.

Import images using the
Import panel.

...and the Browser.

Use the Vaults panel for 
backing up your images.



12 Chapter 1    An Overview of Aperture

 

Step 3:  Photo edit
For this stage, you�ll sort through your images and choose which images you want to 
work with and further adjust. You can add keywords, captions, or other text to your 
images to help you sort and organize them, as well as apply ratings and stack related 
images together. 

You can also group images to further organize them. You can find images using the 
Query HUD (heads-up display), a floating panel with search options. You can also create 
containers, such as folders and albums, within projects to further manage your images. 
Aperture also uses Smart Albums, which are albums that can be dynamically generated 
and updated based on specific search criteria you specify in the Query HUD. This can 
save you time and effort finding just the right images.

Step 4:  Apply adjustments
With Aperture, you can make adjustments to images, including adjusting exposure, 
levels, and white balance and eliminating red-eye. You can also crop, rotate, and resize 
images. If you want to make adjustments that involve compositing, you can easily work 
with your images in another application, known as an external editor, such as Adobe 
Photoshop; adjusted images automatically appear in Aperture when the image is saved. 
You can apply different adjustments to multiple versions of the same image.

Step 5:  Distribute your images
Aperture provides several options for distributing your images. You can print images 
directly to a printer, export images for delivery to a professional photo lab, or create a 
book of images for printing using the printing service supplied by your .Mac account. 
Aperture also includes tools that allow you to publish photos on the web and create 
online journals without having to know any HTML. You can also use slideshows to 
present work to clients or provide a background of images and music during an event. 

Step 6:  Back up your images
You can make a backup copy of your Aperture Library and store it in one or more vaults 
located on external hard disk drives�usually FireWire drives. The Library includes your 
projects, digital master files, and any versions you�ve created. 
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Elements Used in Aperture
In Aperture, you use projects, albums, and folders to organize your images as you work. 
Other important elements are the Library, used to manage your files, and the vault for 
storing backup copies of your Library. 
´ Digital master files:  The original image files imported from your camera, memory 

card, computer, or external storage media. The digital master files are never changed, 
so that the original image is preserved and can be used again.

´ Versions:  These are files used to display the master files, as well as store any changes 
you�ve made to images (such as image adjustments or changes to metadata). 

´ Projects:  Container files used to hold digital master files, versions, and albums. When 
project files are moved, the contents are moved with them.

´ Albums:  Used to organize versions. You can create albums within projects or outside 
of them. Types of albums include Smart Albums, Light Table albums, web gallery 
albums, web journal albums, and book albums.

´ Folders:  Used to organize projects and albums within projects.
´ Library:  A database that manages your files from import to image adjustments and 

final distribution. Once you import images, the Library records and tracks your digital 
master files and corresponding versions. The Library also tracks projects and albums 
you create to organize your images.

´ Managed and referenced images:  Master files stored in the Aperture Library are 
called managed images because Aperture manages the location of the images in its 
database. Managed images are physically located in the Aperture Library file in the 
Pictures folder. You can also import images into Aperture without storing the digital 
master files in the Library. Images that are not stored in the Library file are called 
referenced images. Aperture links to referenced images in their current locations on 
your hard disk, without placing them in the Aperture Library file. 

´ Vaults:  A vault holds your backed-up images and is a copy of your Library.

For details about each of these elements and how you work with them in Aperture, see 
the next few sections.

What Are Digital Master Files?
A digital master file is the original RAW, JPEG, TIFF, or PNG file that was imported into 
Aperture from your camera, a memory card, a computer, or external storage media 
such as an external hard disk drive or CD. Aperture never changes the master file, so 
you always have originals to work from. 

Important:  Digital master files�especially RAW files�tend to be quite large. Projects 
consisting of several thousand digital master files require high-capacity hard disks.

For information about importing your digital master files, see Chapter 5, �Importing 
Images,� on page 55.
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What Are Versions?
Once you have digital master files on your hard disk, you can review and make 
adjustments to your images. For example, you can change the exposure, contrast, or 
saturation, or add information to an image, such as the photographer�s name, event, 
and location. To work with images, Aperture creates a �version� of each master file that 
includes your adjustments and embedded information, and leaves the master file 
unchanged. A version refers to the master file on your hard disk, but it is not the master 
file itself. Versions store only the thumbnail image, adjustments, and embedded 
information. A full image file is not created until you are ready to print or export, saving 
valuable storage space on your hard disk.

When you create a version, several things occur:
´ Aperture reads the original master file on disk and displays it on the screen. 
´ As you make adjustments or add information to the image, Aperture uses floating-

point calculations to display the image with those changes, but the original master 
file is never changed. 

You can create as many versions of an image as you need. For example, a client may 
request color, sepia, and black-and-white versions of the same wedding shot. Instead of 
saving multiple copies of that image, as you would with other applications, you simply 
create different versions of the master file. 

Pictures  
folder 

Computer 

Aperture 
Library file 

3A 

3B 

3C 

2A 

2B 

Versions  
from  
Master 1 

Master  

Versions  
from  
Master 2 

Master  

Versions  
from  
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Master  

1A 
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1B 

1C 

1D 
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What Are Projects?
You organize your digital master files and versions using projects. A project is a 
container file consisting of up to 10,000 master files and as many versions as you like. 
You can create as many projects as you wish up to the limitations of your disk space. 
For example, you can create a new project for each of your shoots. Or if you do several 
shoots of the same subject, you may want to create a project that encompasses all of 
the shoots. Projects are essential elements because they maintain your digital master 
files and track all changes to versions.

You can easily transfer projects from one Aperture system to another. All links between 
versions and their master files are maintained when projects are transferred. This is 
particularly useful if you use a portable computer when on location or away from your 
studio, and a workstation at your studio. For more information, see �Transferring 
Projects from Another Aperture System� on page 67.

What Are Albums?
An album is a type of container in the Aperture Library that holds only versions (not 
the digital master files to which they refer). Albums help you organize images in the 
Library, making your versions easier to manage. You can create albums at the Library 
level or within a project. 

Albums created at the Library level are used to organize versions from multiple 
projects. For example, you can create an album at the Library level to consolidate your 
favorite images, known as selects, from multiple clients (each represented by a project). 
You can then publish this collection of selects on your website or export the album�s 
contents and burn them to a DVD for review by a prospective client. 

Examples of items in 
the Projects panel

Projects
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You can also create albums within projects to help you organize your images into 
relevant groups. For example, images in your Antarctica project can be divided into 
three albums: Antarctica Selects, On Land, and Underwater.

Note:  You can also place versions from other projects in an album that resides within 
a project.

There are two main types of albums, each suited to a particular function:
´ Album:  A type of folder containing image versions. You can view only the versions 

that you�ve placed in the album.
´ Smart Albums:  This type of album contains image versions as well, but the contents 

are controlled by search criteria that you specify. When you change the criteria 
associated with a particular Smart Album, the contents of the Smart Album 
automatically change. For more information about Smart Albums, see Chapter 13, 
�Grouping Images with Smart Albums,� on page 151.

Changes made to versions in albums have no effect on the original digital master files 
on your computer�s hard disk. If you delete a version from one album, the digital 
master file is not deleted from the hard disk.

Three albums created
within one project
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What Are Folders?
In Aperture, folders are used to help organize projects and albums. For example, you 
can import images into projects and then organize the projects into folders based on 
the year, such as 2002, 2003, 2004, and 2005. And if you shoot multiple projects for the 
same client, you can create a folder that contains separate projects for that client.

Note:  Folders only contain albums, projects, and other folders. 

What Is the Library?
The Aperture Library tracks every project, album, master file, and version no matter 
whether the images are stored in the Aperture Library file or in other hard disk 
locations. Aperture automatically creates a Library file in your Pictures folder the first 
time you open Aperture. You can choose to import images into your Library or have 
Aperture access them from other locations on different hard disks. The Library tracks all 
your images and the information recorded about them, as well as information about 
where backup files are stored. You can access images in the Library by clicking Library 
at the top of the Projects panel.

Projects that you transfer from other Aperture systems to your Aperture system are also 
added to the Library. And when you back up your digital master files to your vaults on 
external FireWire drives, those actions are tracked by the Aperture Library as well.

You can change the location of the Library file to a different folder or a different disk. 
You can create multiple Library files. For more information about working with multiple 
Library files, see the Aperture User Manual in the Aperture Help menu.

These folders organize
images based on what

year they were shot.
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What Are Managed Images and Referenced Images?
Aperture lets you choose how you organize your photos on disk. You can store your 
photos in the Aperture Library, or you can import images by simply linking to the 
image files in their current locations, without placing them in the Library. 

Images whose digital master files are stored in the Aperture Library are called managed 
images. These master files are stored in the Library exactly as they were in previous 
versions of Aperture. Aperture manages master image files in the Library, keeping them 
always accessible, and provides benefits such as one-click backup of digital master files 
to vaults. 

Imported images whose digital master files haven�t been placed in the Library are 
called referenced images. Using referenced images in your Aperture system can provide 
a number of substantial benefits to your photography workflow. You can incorporate 
your existing portfolio of images into Aperture without changing the current location 
of the files. Importing images by reference does not result in a duplication of your 
image files in the Aperture Library, thus saving hard disk space. You can also connect 
and disconnect hard disks holding your referenced images� master files as you need 
them. This allows you to keep master files for less-used images offline or to make 
specific types of images available for editing or adjustments as needed. Using 
referenced images in your Aperture system provides a means of building a flexible 
image management system customized to your work style.

You specify that an image will be a managed image or a referenced image when you 
import it. When importing images, you can:
´ Specify that master files be stored in the Aperture Library.
´ Import images as referenced images, so that their master files remain in their 

current locations.
´ Move or copy image files to a new location. For example, you might decide that a 

certain group of referenced image files, such as wedding photos, will always be 
placed in one hard disk location, while other groups, such as sports photos, will 
reside in a different hard disk location.

You can work with referenced images�creating versions, making adjustments, 
cropping, and adding metadata�just as you can with images whose master files are 
stored in the Library. Versions that you create from a referenced image are stored in the 
Library. In order for you to make adjustments to a version from a referenced image, the 
referenced image�s master file must be available on your hard disk or other storage 
device. For example, if you delete a referenced image�s master file in the Finder, 
Aperture no longer has access to the master file and so no longer allows you to change 
your versions or create new ones.
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To help you identify referenced images, Aperture marks referenced images with a 
badge overlay that you can display or hide. When a referenced image�s master file is 
missing or offline, its badge changes to show that the image is not accessible. For 
example, if you disconnect a hard disk that holds master files for many referenced 
images, Aperture automatically marks the referenced images in the Browser and Viewer 
as offline. If you reconnect the hard disk or other storage device later, Aperture 
accesses the master files automatically and you can work with and change their 
versions again.

You can also relocate master files, moving them out of the Library or moving referenced 
master files to different hard disk locations. If needed, you can also move referenced 
master files into the Aperture Library by choosing the Consolidate command.

You can search for images based on whether they are managed images, referenced 
images, or online or offline images. Aperture also provides robust file-management 
tools that let you quickly determine which images are offline and easily reconnect 
images that have been moved to different volumes.

What Is a Vault?
A vault is a container consisting of an exact copy of your Library. This includes your 
projects, managed digital master files, and any versions you�ve created. You can easily 
create and update a vault to back up your Library. It�s best to store your vaults on 
multiple external hard drives connected to your computer, usually via FireWire. A Vault 
Status button changes color when your vaults need updating. 

You can have as many vaults as you deem necessary. Creating more than one vault is 
useful if you work at different locations; you can always keep one vault on a FireWire 
drive onsite and another one offsite. All vaults and backup files are tracked by the Library 
so that even if you disconnect the external hard drive that contains your vault, Aperture 
will synchronize it the next time you reconnect the drive and update your vault.

All the managed master file images, versions, and all metadata, previews, and adjustment 
information associated with your images are backed up. The versions, previews, and 
metadata associated with referenced images� master files are also backed up in the vault. 
Referenced images� master files are not backed up in the vault with the Library.
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2 Setting Up an Aperture System

You can use Aperture with just your computer and display, 
or you can set up a system with two displays for extra screen 
space to view and adjust images.

This chapter provides instructions for connecting a digital camera or card reader to 
your computer and setting up a dual-display system.

Setting Up a Basic System
The following are basic instructions for connecting a digital camera or card reader to 
your computer.

Card reader Camera

Computer
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A basic Aperture system consists of the following equipment:
´ A computer and display
´ A digital camera or card reader (a FireWire card reader is strongly recommended 

because it�s faster)
´ A cable to connect your camera or card reader to your computer (typically a USB 2.0 

cable or a 4-pin-to-6-pin FireWire cable that came with your camera or card reader)

For information about setting up a computer and display, see the documentation that 
came with the computer and display.

To connect a camera or card reader to your computer:
m Connect your camera or card reader to your computer using the USB or FireWire cable 

that came with your camera or card reader.

To ensure proper setup, see the documentation that came with your camera or 
card reader.

USB 2.0 FireWire 400 (6-pin) FireWire 400 (4-pin) 
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Setting Up Your System with Two Displays
Using two displays gives you additional screen space to view and adjust images, play 
slideshows, and present your full-color, full-size images. 

Connecting a Second Display to Your Computer
You can connect two displays to the graphics card on your computer and use both 
displays at the same time. 

For connecting a second display, you�ll need the following:
´ Power adapter for the display
´ Display cable to connect the display to the graphics card on your computer

Power adapter Apple Cinema Display cable connectors 

DVI 

USB 

FireWire 

DC power 

£

d

H
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Note:  You may also need to purchase an adapter to connect the display cable to the 
graphics card on your computer.

Macintosh computers come with two possible display ports: Apple Display Connector 
(ADC) ports to connect ADC displays, and Digital Visual Interface (DVI) ports to connect 
digital displays that have DVI connectors (such as a flat-panel Apple Cinema Display).

´ If your second display is an ADC display, connect it to an available ADC display port 
on your computer, or use a DVI to ADC adapter to connect the display to a DVI 
display port.

´ If your second display is a DVI display, connect the display to an available DVI display 
port on your computer, or use an ADC to DVI adapter to connect the display to an 
ADC display port.

See the documentation that came with your computer or graphics card for more 
information on the type of display cable or adapter you need.

To connect a second display to your computer:
1 Turn off the computer.

2 Connect a display cable (and adapter, if necessary) from an available display port on 
your computer or graphics card to the display. 

Depending on your displays, you may have one or more cables to connect. Refer to the 
documentation that came with the display and your computer for detailed information.

Important:  Make sure the cables are connected firmly, or you may not be able to see 
an image on the display.

ADC to DVI adapter

ADC display port DVI display port 



Chapter 2    Setting Up an Aperture System 25

 

The following illustration shows one possible scenario for connecting two displays 
to a computer.

3 Turn on the displays (if necessary) and start up your computer.

You�ll now want to adjust your displays for proper viewing.

Apple Cinema Display 

Second Apple Cinema Display 

Power Mac G5 

DVI display port 

 ADC to DVI adapter

ADC display port 

USB ports 

DC plug 

AC plug 

FireWire 400 port 

Power 
adapter 

Power 
outlet 

DC plug 

AC plug 
Power 

adapter 

Power 
outlet 

FireWire connector 
(not used) 

£

£

d
H
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Configuring Mac OS X for Multiple Displays
If your computer is connected to two displays, you can set them up to show a 
continuous desktop that extends across both screens. This is known as extended 
desktop mode.

Because Aperture controls the second display, you must keep your computer in this 
mode for the application to operate properly. If you work in mirroring mode, where the 
same contents appear on both displays, Aperture may not work properly. 

To exit mirroring mode:
1 Choose Apple (K) menu > System Preferences.

2 Click Displays, then click Arrangement.

Note:  If the Arrangement button does not appear, click the Detect Displays button. If 
the Arrangement button still does not appear, make sure the second display is properly 
connected to your computer. For more information, see �Setting Up Your System with 
Two Displays� on page 23.

3 Deselect the Mirror Displays checkbox.

After you connect a second display, your displays may show the arrangement of the 
desktop out of order. For example, the display that shows the hard disk icon and menu 
bar is typically on the left, so that your desktop extends out to the right on the 
rightmost display.

To rearrange the position of the displays:
1 Choose Apple menu > System Preferences.

2 Click Displays, then click Arrangement. 

Note:  If the Arrangement button does not appear, click the Detect Displays button. If 
the Arrangement button still does not appear, make sure the second display is properly 
connected to your computer. For more information, see �Setting Up Your System with 
Two Displays� on page 23.
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3 Drag one of the blue rectangles, representing one of the displays, to match the 
position of the display on your desk. 

The display screens temporarily refresh to accommodate the new arrangement.

4 Drag the white rectangle to move the menu bar to the display on the left. 

The display screens temporarily refresh to accommodate the new arrangement. The 
contents of the screen may be rearranged to accommodate the new position of the 
menu bar.

The red outline indicates 
the screen of the display 
you are moving.

Drag the menu bar to the 
display on the left.
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Using Additional Hard Disk Storage and FireWire Drives
The disk that contains your computer�s operating system is called the startup disk. In 
addition to the operating system, the startup disk also stores your applications (such as 
Aperture), application preferences, system settings, documents, and image files. The 
more hard disk space you have, the more images Aperture can store. Because you�ll be 
shooting and storing many images, you should have at least one high-capacity hard disk. 

Aperture can also uses external FireWire drives to store and back up image files. These 
external drives can be �daisy-chained,� meaning that you can connect one drive to 
another and another. The first drive in the chain is connected to your computer. 
FireWire drives are �hot-swappable,� meaning that you can connect and disconnect 
them from your computer without having to shut it down first. FireWire drives are also 
a great way to add storage space if you are using Aperture on a portable computer.
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3 Learning About 
the Aperture Interface

Aperture provides an outstanding interface designed to allow 
professional photographers to efficiently import, manage, 
edit, and distribute images.

This chapter provides basic information about the Aperture main window and tells you 
how to customize your workspace layout to work more efficiently.

Basics of Working in Aperture
You may want to open Aperture so you can view the main window and familiarize 
yourself with its elements as you read.

Opening Aperture for the First Time
The first time you open Aperture, you have several choices as to what to do, depending 
on your workflow.
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To choose an option when you first open Aperture:
1 Click the button next to the option you want.

2 Click Continue.

The Aperture Main Window
This is the main window that you�ll routinely use in Aperture.

Note:  The inspectors are not shown when you first open Aperture. To show or hide the 
Inspectors panel, press I. You can also double-click an image to open the Inspectors panel.

To help you learn Aperture, you can hold the pointer over a control in Aperture and a 
small box called a tooltip appears with a description of the control. Next to the 
description is the keyboard shortcut for using the control. You can turn the display of 
tooltips on or off in the Preferences window.

Projects panel

Browser

Toolbar

Adjustments Inspector

Metadata Inspector

Viewer

Control bar

Example of a tooltip.
You can press Control-G

to switch the Browser
to grid view.
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Projects Panel
You use the Projects panel to organize your imported images using projects, folders, 
and albums. You can create webpages (photo galleries and online journals) and 
specially formatted books for printing. You can also create Smart Albums that 
automatically find and store images based on search criteria you specify (for more 
information, see Chapter 13, �Grouping Images with Smart Albums,� on page 151).

´ Projects pop-up menu:  Provides options for showing all projects, your favorites, or 
recently selected projects. You can create as many projects as you like.

´ Add to Library pop-up menu:  Provides a quick way to create new elements, such as 
projects, folders, and albums.

´ Project Action pop-up menu:  Provides options for adding or removing selected items 
from a list of favorites and exporting them.

The Projects panel is shown by default.

To hide the Projects panel:
m Choose Window > Hide Projects (or press W).

To show the Projects panel if it�s hidden:
m Choose Window > Show Projects (or press W).

For more information, see Chapter 4, �Working with Projects,� on page 49.

A project

Project Action 
pop-up menu

Add to Library 
pop-up menu

Projects pop-up menu
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Browser and Viewer
You use the Browser to display images in projects and albums. When you select an 
image in the Browser, a detailed view of the image appears in the Viewer. You can 
quickly select other images by pressing the arrow keys.

You can move, copy, and sort your images in the Browser. You can drag images from 
the Browser into other projects and albums in the Projects panel. You can also classify 
your images by applying ratings and keywords to them. 

You can display images in the Browser in grid view or list view. In grid view (shown 
above), thumbnails are displayed for every image contained in a project or album. In 
grid view you can identify your images by sight, working with the thumbnails. In list 
view, your images are listed by file information, such as filename, pixel size, file size, and 
rating. List view provides an easy way to sort your images by category. For more 
information about the Browser, see Chapter 6, �Working with Images in the Browser,� 
on page 69. 

The Viewer displays a detailed view of images selected in the Browser so you can make 
adjustments, compare similar images, and inspect images at full resolution. In the 
Viewer, you can see a magnified view of specific image details. You can also apply 
adjustments to your images in the Viewer. You can set the Viewer to display one, three, 
or multiple images at a time. For more information, see Chapter 7, �Displaying Images in 
the Viewer,� on page 83.

The Viewer displays
a detailed view of
selected images.

The Browser displays
images in a selected

project or album.
The white outline indicates 
the selected image.
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Control Bar
The control bar at the bottom of the Aperture main window has buttons that allow you 
to quickly rotate, rate, and navigate through images. There are also buttons to control 
how images are displayed and to apply keywords to your images. The control bar is 
shown by default, but you can hide it at any time. 

To hide the control bar:
m Choose Window > Hide Control Bar (or press D).

To show the control bar:
m Choose Window > Show Control Bar (or press D).

The following sections provide descriptions of each button and control in the control bar.

Display Controls

´ Viewer Mode pop-up menu:  Choose how to view your images and arrange your 
displays from this pop-up menu. For more information, see Chapter 7, �Displaying 
Images in the Viewer,� on page 83.

´ Zoom Viewer:  Click this button to move between viewing an image at actual size and 
fitting the image to the Viewer�s screen size. 

´ Show Master Image:  Click this button to see an image of the original digital master file.
´ Full Screen:  Click this button to switch to Full Screen mode. For more information, see 

Chapter 8, �Viewing Images in Full Screen Mode,� on page 93.
´ Primary Only:  Click this button to temporarily change between making metadata 

changes to all selected images or the primary selection only.

Viewer Mode
pop-up menu

Zoom Viewer
button

Show Master Image button

Primary Only 
button

Full Screen 
button
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Rotate Buttons

´ Rotate Left:  Click this button to rotate the selected image to the left.
´ Rotate Right:  Click this button to rotate the selected image to the right.

Rating Buttons

´ Reject:  Gives the selected image a Reject rating.
´ Decrease Rating:  Decreases the rating of the selected image.
´ Increase Rating:  Increases the rating of the selected image.
´ Select:  Gives the selected image a Select rating (five stars).
For more information, see Chapter 10, �Rating Images,� on page 113.

Navigation Buttons

´ Previous Image:  Click this to go to the previous image.
´ Next Image:  Click this to go to the next image.

Rotate Left button Rotate Right button

Reject button

Decrease Rating button

Select button

Increase Rating button

Previous Image button Next Image button
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Keyword Controls

´ Individual keyword buttons:  Click a keyword button to apply a preset keyword to a 
selected image or group of images. Shift-click the button to remove a keyword.

´ Keyword Preset Group pop-up menu:  Choose a preset group of keywords to display or 
edit an existing group.

´ Add Keyword field:  Enter a new keyword, then press Return. Aperture creates a new 
keyword and applies it to the selected image.

Note:  If the Adjustments and Metadata Inspectors are open, there may not be enough 
room to show the entire control bar. In that case, the keyword controls are not shown.

For more information, see Chapter 11, �Applying Keywords to Images,� on page 121.

Toolbar
The toolbar is a collection of buttons and tools located at the top of the Aperture main 
window. Buttons and tools are grouped by function. There are buttons for creating 
projects, organizing images, and configuring the Aperture workspace, as well as tools for 
applying adjustments. The toolbar is shown by default, but you can hide it at any time.

To hide the toolbar:
m Choose View > Hide Toolbar (or press Shift-T).

To show the toolbar:
m Choose View > Show Toolbar (or press Shift-T).

If you want to customize the toolbar based on your preferences, see �Customizing the 
Toolbar� on page 45.

Keyword Preset Group 
pop-up menu

Add Keyword field

Individual keyword buttons

Toolbar
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Import and Project Buttons

´

 

Import Panel:

 

  Click this button to reveal the Import panel. When you select either the 
camera, a memory card, or a mounted drive, the Import dialog appears. For more 
information, see �Import Panel� on page 41.

´

 

New Project:

 

  Click this to create a new project.
´

 

New Album:

 

  Click this to create a new album with your current image selection in it. 
´

 

New Smart Album:

 

  Click this to create a new Smart Album. For more information, see 
Chapter 13, �Grouping Images with Smart Albums,� on page 151.

´

 

New Book Album:

 

  Click this to create a new book album with your current image 
selection in it. For more information, see Chapter 20, �Creating Books,� on page 193.

´

 

New Web Gallery Album:

 

  Click this to create a new web gallery album with your 
current image selection in it. For more information, see Chapter 19, �Creating Web 
Journals and Web Galleries,� on page 183.

´

 

New Light Table Album:

 

  Click this to create a Light Table album with your current 
image selection in it. For more information, see Chapter 16, �Using the Light Table,� 
on page 163.

 

Email and Slideshow Buttons

´

 

Email:

 

  Click this to open your email program and attach selected images.
´

 

Slideshow:

 

  Click this to initiate a slideshow of the selected images.

Import Panel button

New Project
button

New Album 
button

New Light Table Album 
button

New Smart
Album button

New Book 
Album button

New Web Gallery 
Album button

Email button Slideshow button



Chapter 3    Learning About the Aperture Interface 37

 

Version Buttons

´ Duplicate Version:  Click this to create a version, or duplicate, of a selected image.
´ New Version From Master:  Click this to create a new version from a selected image�s 

digital master file.

Stacking Buttons

For details about working with stacks, see Chapter 9, �Stacking Images 
and Making Picks,� on page 105.
´ Stack:  Click this to group the selected items in a stack.
´ Stack Pick:  Click this to mark a selected image as the stack�s pick, or best image.

Adjustment Tools

´ Selection:  Use this to select projects, albums, and images. 
´ Rotate Left:  Use this to rotate an image to the left. You can use this tool to rotate an 

image displayed in the Viewer or Browser.
´ Rotate Right:  Use this to rotate an image to the right. You can use this tool to rotate 

an image displayed in the Viewer or Browser.
´ Straighten:  Use the guides to help manually straighten (or level) the selected image.
´ Crop:  Use this to crop the selected image.
´ Spot & Patch:  Removes imperfections in the image, such as sensor dust, by either 

copying the pixels around the blemish (Spot tool) or copying pixels from another 
area of the image (Patch tool).

Duplicate Version
button

New Version From 
Master button

Stack Pick buttonStack button

Selection tool Stamp tool

Rotate Left
tool

Crop tool

Lift tool

Rotate Right tool Spot & Patch tool

Straighten
tool Red Eye tool
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´ Red Eye:  Use this to correct red-eye, occurring when the subject�s retinas reflect light 
from your camera�s flash.

´ Lift:  Use this to copy a set of adjustments, including cropping and straightening, and 
metadata from a selected image.

´ Stamp:  Use this to stamp, or apply, a copied set of adjustments or metadata to one 
or several images.

Loupe and Keywords HUD Buttons

´ Loupe:  Opens the Loupe tool, which zooms in on your image.
´ Keywords HUD:  Click this to show or hide the Keywords HUD.

Adjustments Inspector and Metadata Inspector Buttons
Use these buttons to reconfigure your workspace layout. For more information, see 
�Choosing Your Workspace Layout� on page 46.

´ Adjustments Inspector:  Click this button to show or hide the Adjustments Inspector in 
the Inspectors panel.

´ Metadata Inspector:  Click this button to show or hide the Metadata Inspector in the 
Inspectors panel.

Adjustments Inspector
You can use controls in the Adjustments Inspector to apply, edit, and remove 
adjustments to a selected image, such as exposure, levels, and white balance. Controls 
in the Adjustments Inspector are grouped according to the type of image adjustment 
they perform. You can see the controls for an adjustment category by clicking its 
disclosure triangle. 

Note:  By default, the Adjustments Inspector and Metadata Inspector are shown at the 
same time. You can also show them individually in the Inspectors panel by choosing 
Window > Show Metadata or Window > Show Adjustments.

Loupe button Keywords HUD button

Keywords Inspector 
button

Adjustments Inspector
button
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To show the Adjustments Inspector, do one of the following:
m Double-click an image (or press I) to open the Inspectors panel.

m Choose Window > Show Adjustments (or press Control-A).

Press I to hide the Inspectors panel again.

If the Adjustments Inspector is open when you view your images, you can easily see a 
summary of the adjustments that have been applied by clicking the disclosure triangle 
for each adjustment. To edit an adjustment applied to an image, click the disclosure 
triangle for the adjustment and use its controls to make your changes. To remove an 
adjustment, deselect the checkbox for the adjustment. For more information, see 
Chapter 14, �An Overview of Image Adjustments,� on page 155. For in-depth explanations 
of adjustments, see Performing Image Adjustments in the Aperture Help menu.

Note:  Although you can apply initial adjustments with the Adjustments Inspector, it�s 
often more convenient to use the Adjustments HUD in Full Screen mode. For more 
information, see Chapter 8, �Viewing Images in Full Screen Mode,� on page 93. 

Click the disclosure
triangle for an
adjustment to

see its controls.

Adjustments Inspector
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Metadata Inspector
The Metadata Inspector can display an image�s caption text, keywords, version number, 
filename, and file size. You can also view EXIF (Exchangeable Image File) and IPTC 
(International Press Telecommunications Council) data associated with your image, as 
well as image keywords and other information. EXIF metadata is embedded with an 
image file by the digital camera and includes camera settings such as shutter speed, 
date and time, focal length, exposure, metering pattern, and flash information. IPTC 
information can be embedded in a digital image with most software programs used to 
edit photos, and can include a caption, the place and date a photo was taken, and 
copyright information.

You can create your own views of the types of metadata displayed with an image and 
create metadata presets that you can use to apply combinations of metadata 
repeatedly to multiple images.

Note:  By default, the Adjustments Inspector and Metadata Inspector are shown at the 
same time.

To show the Metadata Inspector, do one of the following:
m Double-click an image (or press I) to open the Inspectors panel.

m Choose Window > Show Metadata (or press Control-D).

Press I to hide the Inspectors panel again.

Metadata Inspector

Click one of these
buttons to display the

associated text.
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Additional Parts of the Aperture Interface
As you work in Aperture, you will use other panels, such as the Import and Vaults 
panels, as well as specialized panels called inspectors and HUDs. There is also a Full 
Screen mode that provides a full-screen view of your images and a Light Table feature 
that allows you to arrange images.

Import Panel
The Import panel displays a list of connected card readers and external hard disk 
drives, as well as local hard disks and mounted servers. If you want to import images 
into Aperture, you select one of these devices, and the Import dialog appears. You 
specify settings in that dialog to import images from that device to your Library or a 
selected project.

To show the Import panel, do one of the following:
m Choose Window > Show Import Panel (or press Shift-I).

m Click the Import Panel button in the toolbar.

To hide the Import panel, do one of the following:
m Choose Window > Hide Import Panel (or press Shift-I).

m Click the Import Panel button in the toolbar.

For more information, see Chapter 5, �Importing Images,� on page 55.

This list displays all locations 
from which you can currently 
import images, including internal 
disks and connected drives.

Import panel button

Import panel
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Vaults Panel
The Vaults panel is where you set the location of your vaults, which are designated 
storage areas for backup copies of your Library. Typically, an external hard disk drive, 
such as an external FireWire drive, serves as a vault.

To show the Vaults panel:
m Click the Vaults Panel button.

To hide the Vaults panel, click the Vaults Panel button again.

As you store managed images in the Library, Aperture automatically tracks which files 
have been backed up to your vault. When your vault is up to date, the Vault Status 
button appears black. When a change to at least one version occurs, such as an 
adjustment, the Vault Status button appears yellow. When Aperture determines that 
even a single master file has not been backed up, the Vault Status button appears red. 
You can have Aperture update your vaults whenever you want.

For more information, see Chapter 21, �Backing Up Your Images,� on page 201. 

HUDs 
HUDs, or heads-up displays, are collections of related controls contained in a floating 
panel. You can open and then move a HUD wherever you wish, based on your display 
setup. You can use HUDs in regular and Full Screen mode. Many of the adjustment tools 
have HUDs, which are shown when you select the tool in the toolbar. Other HUDs, such 
as the Keywords HUD and Adjustments HUD, are also available from the Window menu.

You�ll frequently use the Query HUD to search for images based on specific criteria, 
such as ratings and keywords. For more information, see Chapter 12, �Searching for 
and Displaying Images,� on page 139.

Click the Vaults Panel 
button to show or hide 
the Vaults panel.

Vaults panel
Vault Status button
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To show the Query HUD:
m Choose Edit > Find (or press Command-F).

Full Screen Mode
The Full Screen mode available in Aperture allows you to view your images on a simple 
black background, with no other interface elements shown, such as the Browser or 
Projects panel. For more information, see Chapter 8, �Viewing Images 
in Full Screen Mode,� on page 93.

Query HUD

Full Screen mode
provides a full-screen

view of images on
a simple black

background.
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Light Table
The Light Table provides an open, freeform workspace where you can arrange images. 
When you create or select a Light Table album, the Light Table appears in place of the 
Viewer. Use the Light Table to review and compare images, create mockups of 
webpages, compare color values in a selection of images before making adjustments, 
or do anything else that involves viewing and comparing your images. For detailed 
information, see Chapter 16, �Using the Light Table,� on page 163.

Configuring Your Workspace
The Aperture interface is highly configurable, and it�s easy to show and hide areas of 
the interface. Aperture also offers several workspace layouts created to accommodate 
different workflows.

Showing and Hiding Areas of the Interface
To see which areas of the interface are currently shown, look at the items in the Window 
menu (in the menu bar at the top of the screen). Many Window menu items start with 
Hide or Show so you can easily detect which ones are shown and which are hidden.
´ Show:  If you see this in front of a menu item, you can view the interface element by 

choosing the menu item. 
´ Hide:  If you see this in front of a menu item, you can hide the interface element by 

choosing the menu item. 

The Light Table
allows you to freely
view, compare, and

position images.
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Customizing the Toolbar
You can customize the toolbar based on your workflow and preferences, selecting 
which buttons to include, their arrangement, and whether or not to display a button�s 
name along with its icon. 

Note:  The adjustment tools appear as a set in a particular order and cannot be 
individually rearranged.

To customize the toolbar:
1 Do one of the following:

´ Choose View > Customize Toolbar.
´ Control-click the toolbar, then choose Customize Toolbar from the shortcut menu. 

2 In the dialog that appears, make any necessary changes:

´ To add buttons to the toolbar:  Drag a button�s icon from the dialog to the toolbar.
´ To remove buttons from the toolbar:  Drag them out of the toolbar, or Control-click the 

button you want to remove and choose Remove Item from the shortcut menu.
´ To change the order of the buttons in the toolbar:  Drag a button to a new position.
´ To set the toolbar to a default configuration:  Drag the default set of buttons and tools 

to the toolbar.
´ To control whether each button�s icon and text appear in the toolbar:  Choose Text Only, 

Icon Only, or Icon & Text from the Show pop-up menu in the lower-left corner, or 
Control-click the toolbar and choose an option from the shortcut menu. 

3 When you�ve finished configuring the toolbar, click Done.
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Choosing Your Workspace Layout

 

Aperture provides three workspace layouts for working with your images. 

Â

 

Basic layout:

 

  Used to review images, perform initial rating passes, and create and 
work with stacks of images. This workspace shows the Projects panel on the left for 
selecting projects that you want to work with. The images in a selected project 
appear in the Browser in grid view, where you can quickly select and review them. 
Images selected in the Browser appear in the Viewer above. 

Â

 

Maximize Browser layout:

 

  Use this to work with multiple projects. This workspace 
provides a large view of the Browser, simplifying the screen to make selecting and 
working with images easy. You can quickly open different projects in the Projects 
panel and review and make changes to projects as needed.

Â

 

Maximize Viewer layout: 

 

 Use this workspace layout when working with images in the 
Light Table. When you choose this workspace layout, the Viewer (or specialized 
interface elements that replace the Viewer, such as the Light Table) is enlarged to its 
maximum size.

 

To choose a layout, do one of the following:
m

 

Choose Window > Layouts, then choose the preset layout you want.

m

 

Press Command-Option and the letter corresponding to the layout you want:  S for 
Basic, B for Maximize Browser, or V for Maximize Viewer.

 

Viewing and Specifying Preferences

 

Aperture has various preferences that allow you to modify how a particular feature 
behaves. The settings you specify affect all projects you create, although most of them 
can be overridden for individual projects. Taking time to specify your preferences can 
make creating and working with your projects faster and easier.

 

To open the Preferences window:
m

 

Choose Aperture > Preferences, or press Command-comma (,).

The Preferences window appears. 
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Working Efficiently
To perform many tasks in Aperture, you can use keyboard shortcuts. The keyboard 
shortcuts let you perform actions on your computer using the keyboard instead of by 
pointing and clicking. 

For example, to create a new folder, you press Command-Shift-N; this means you hold 
down the Command key and the Shift key, and then press N. For a list of keyboard 
shortcuts, see Quick Reference in the Aperture Help menu or refer to the printed 
Aperture Quick Reference card.

Quickly Accessing Commands
You can also quickly access commands via a shortcut menu, as an alternative to using 
the menu bar at the top of the screen or pop-up menus within a window.

To view a shortcut menu:
m Position the pointer over a project or image, or in an area of the main window, then 

hold down the Control key and click. (This is called Control-clicking.)

Note:  Although accessing these shortcut menus can help you work more quickly, keep 
in mind that not all commands are available in shortcut menus.

Using the Undo Command
When you�re working in Aperture and you make a change you don�t like or didn�t mean 
to make, it can usually be undone.

To undo the previous action:
m Choose Edit > Undo (or press Command-Z).

You can choose Undo multiple times to undo a series of changes that you�ve made.

To redo an action that you have undone:
m Choose Edit > Redo (or press Command-Shift-Z).
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4 Working with Projects

Projects are one of the main building blocks used to manage 
your images in Aperture. 

This chapter covers how to create projects, as well as open them, save them as 
favorites, and delete them.

Controls in the Projects Panel
There are several controls in the Projects panel that you�ll use when working with projects.

´ Disclosure triangle:  Click this to see all items within the Library, project, or folder.
´ Projects pop-up menu:  Choose to display all projects, favorites, or recent projects.
´ Add to Library pop-up menu:  Click this to add a new item, such as a project or Smart 

Album, to the Library or selected project.
´ Project Action pop-up menu:  Click this to add the selected item to your favorites or 

remove it.

Projects pop-up menu

Project Action 
pop-up menuDisclosure triangle

Add to Library
pop-up menu
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Creating and Naming Projects
You can create projects at any time, although typically you create them when you 
import images. When you import images and no project is selected, a new project is 
created to contain those images. For more information, see Chapter 5, �Importing 
Images,� on page 55. However, you can create a new empty project at any time.

To create a new project:
1 Choose File > New Project (or press Command-N).

2 Enter the name you want for the project, then press Return.

Opening and Closing Projects
To start working in Aperture, you must have a project open. You can also open and 
work on more than one project at a time, each represented by its own tab in the 
Browser. When you finish working and quit Aperture, Aperture remembers which 
projects were open. The next time you open Aperture, all projects that were open at 
the end of your last session open automatically. 

A new, untitled
project appears in the

Projects panel.

The project now has the
name you entered.
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To open a project:
m Select the project in the Projects panel.

To open additional projects in the Browser:
m Command-click a project in the Projects panel.

The newly opened project appears in the Browser with its own tab, in front of any 
other open projects. 

To open another project in its own pane:
m Option-click a project in the Projects panel.

The newly opened project appears in the Browser in its own pane.

To switch between several open projects:
m In the Browser, click a project�s tab.

Select a project to view
its images in the Browser.

All images in the project
appear in the Browser.

Projects are identified 
by their tabs.
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To close a project:
1 Click the project�s tab to bring it to the front.

2 Do one of the following:

´ Choose File > Close Tab (or press Command-W). 
´ Click the tab�s close button.

Creating and Showing Favorite Projects
If you have certain projects that you work on most often or at the same time, you can 
make them favorites to quickly view them all at the same time.

To make a project or folder a favorite:
m In the Projects panel, select a project, then choose Add to Favorites from the Project 

Action pop-up menu.

To view favorite projects or folders:
m In the Projects panel, choose Show Favorites from the Projects pop-up menu at the 

top-left corner.

To remove a project or folder as a favorite:
m In the Projects panel, select a project, then choose Remove From Favorites from the 

Project Action pop-up menu.

Close button in a tab
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Deleting Images from Projects and Albums
Aperture allows you to delete versions separately from their digital master files. You can 
also delete a master file and all its versions in a project. If you delete a version in an 
album (not a project), its master file and related versions are not deleted.

To delete a master file and all its versions from a project:
1 Select the image, then choose File > Delete Master Image and All Versions.

A dialog appears asking if you want to continue.

2 Click the Move to Trash button.

The digital master file and all versions are deleted. If you delete a managed image file, 
the master file is removed from the Library. If you delete a referenced image file, the 
digital master file is removed from Aperture but left on your hard disk.

To delete only a version from an album:
m Select the image, then choose File > Delete Version.

The version is deleted. The digital master file and its other versions are not deleted.

Warning:  This action cannot be undone. Once you click the Move to Trash button, the 
master file is moved to the Trash. All versions and their adjustments and metadata are 
permanently deleted. To permanently remove the master files from your hard disk, 
empty the Trash.
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Deleting Items from the Projects Panel
You can also delete items from the Projects panel. When you delete an item from the 
Projects panel, the contents of the item are deleted with it. 

Note:  If you delete a project or a project within a folder, the digital master files 
contained in the project are also deleted.

To delete projects and folders:
1 Select the item, then do one of the following:

´ To delete a project:  Choose File > Delete Project (or press Command-Delete).
´ To delete a folder:  Choose File > Delete Folder (or press Command-Delete).
A dialog appears asking if you want to continue.

2 Click the Delete button.

The selected item is deleted along with its contents.

To delete an album, a Light Table album, a web gallery album, 
a web journal album, or a book album:

m Select the album, then choose File > Delete [Item], where �Item� is a type of album. 

The selected item is deleted along with its contents.

Warning:  This action cannot be undone. Once you click the Delete button, the master 
files are moved to the Trash. All versions and their adjustments and metadata are 
permanently deleted. To permanently remove the master files from your hard disk, 
empty the Trash.
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Importing Images

 

Aperture provides tools and workflow options that make it 
easy to import your images.

 

This chapter discusses how you can import images into Aperture from a variety of sources.

 

An Overview of Importing

 

When you import from a camera or card reader, Aperture places the images in a 
project. If you don•t select an existing project, a new one is created automatically. 

As Aperture imports images, it generates a version file and an image thumbnail 
corresponding to each digital master file. 

You can import digital master images directly from a camera or card reader and from 
your hard disk drives.

Camera 
Vault 

(FireWire drive) 

Import 

Back up 

Aperture Library 
(system disk) 

Importing  
to Aperture 

Digital  
master files 

Versions 

Project 

RAW 
& JPEG 
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When you import images, you can choose whether to have the digital master files 
stored in the Aperture Library or store them on your hard disk outside of the Library 
where they can be accessed as referenced images.

As you import images, you can have Aperture automatically name and record 
information about them. Aperture can assign filenames using custom naming 
conventions, as well as record metadata such as captions, keywords, dates, copyright 
and credit information, and IPTC information. You can even set Aperture to stack 
related images together, keeping bracketed shots or a series of shots taken in quick 
succession in groups that you can easily select and work with. For more information on 
stacks, see Chapter 9, �Stacking Images and Making Picks,� on page 105.

Before you import images into Aperture, it�s a good idea to plan the organization of 
your images. Eventually your image library may contain many thousands of images that 
you�ll want organized in a flexible and easy-to-manage system. 

Plan how you want to import your existing portfolio of digital images. Because you 
may have many thousands of images previously stored on disk, you need to decide 
whether you�ll import them into the Aperture Library, or import them as referenced 
images, leaving them in their current hard disk locations. You can also copy or move 
them into different hard disk locations when importing them.

As an import strategy, it�s best to try out importing images in a series of steps. Make 
trial imports of a small group of images directly from your digital camera or card 
reader. Try out the different methods for importing individual files into your system. 
Once you�re familiar with how Aperture works, you can begin setting up your image 
management system for long-term use.

File Formats You Can Import into Your Library
Aperture is a QuickTime-compatible application, so it supports standard QuickTime-
compatible still-image file formats, as well as some other file formats and file types. The 
following file types and formats can be imported:
´ GIF
´ JPEG
´ JPEG2000
´ PNG
´ PSD (8 and 16 bit)
´ RAW files from a variety of supported digital cameras
´ TIFF (8 and 16 bit)

Note:  For a list of supported digital cameras, go to http://www.apple.com/aperture.

http://www.apple.com/aperture
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Importing from Your Digital Camera or Card Reader
You can import all images from a camera or card reader into Aperture, or you can 
import selected images only. You can import your images into a new project or an 
existing project.

To import all the images from a camera or card reader into Aperture:
1 Connect your camera or card reader to your computer.

The Import panel and Import dialog appear, showing the images on the camera or card.

Note:  If iPhoto opens when you connect your camera or card reader, quit iPhoto and 
then, in Aperture, choose Aperture > Preferences. Choose Aperture from the �When a 
camera is connected� pop-up menu. Disconnect and reconnect your camera to have 
Aperture open the Import dialog.

Import dialog

Import arrow

Import panel

Import button
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2 Do one of the following:

´ If you want to import into a new, empty project:  Choose File > New Project (or press 
Command-N) to create a new project. 

Note:  You can also click the Library icon in the Projects panel, if necessary, to select 
it. When you select the Library (not a project), a new, untitled project is automatically 
created when images are imported.

´ If you want to import the images into an existing project:  Select the project. The Import 
arrow points at the currently selected project, indicating the destination for the import.

The top-left portion of the Import dialog updates, displaying where the images are 
being placed.

3 Choose a location for the imported images by doing one of the following:

´ To store imported master image files in the Aperture Library:  Choose In the Aperture 
Library from the Store Files pop-up menu.

´ To store imported master image files as referenced images in the Pictures folder on your 
hard disk:  Choose Pictures from the Store Files pop-up menu. 

´ To store imported master image files as referenced images in a location other than the 
Pictures folder:  Choose �Choose� from the Store Files pop-up menu and select the 
folder you want. Choose �No folder� from the Subfolders pop-up menu to specify 
that the files be stored as separate individual files in the selected folder. You can also 
specify that Aperture create and store your files in a hierarchy of subfolders with 
specific folder names. For more information about specifying folders to hold your 
imported images, see the Aperture User Manual in the Aperture Help menu. Choose 
whether you want the image files moved or copied to a new location by clicking the 
�Move files� or �Copy files� button. 

Make sure the Import arrow 
is pointing to the Library to 
import the images into a 
new project.

Select the project
into which you want to

import images.
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4 Choose a naming convention from the Version Name pop-up menu to specify how you 
want the images named.

For example, choose Master Filename from the Version Name pop-up menu to have your 
files stored using the current master filenames from your camera or card. Choose a name 
format from the Version Name pop-up menu to have your images stored using a 
specified name. If you choose a custom name format, enter the name you want in the 
Name Text field. You can also apply the name format to the master file as well. Choose 
Edit from the Version Name pop-up menu to define a new naming scheme. For more 
information about naming files, see the Aperture User Manual in the Aperture Help menu.

5 To add metadata to your images as they�re imported, choose a metadata preset from 
the Add Metadata From pop-up menu. 

6 With no images selected in the dialog, click the Import arrow or the Import button in 
the lower-right corner of the dialog. 

If you select images, only the selected images are imported. To reset the image 
selection so that no images are selected, click in the background beside a thumbnail.

The import process begins and an indicator appears next to the project�s name, 
showing the progress of the import. When images are imported, a dialog appears. 

7 Click Eject Card, Erase and Eject Card, or Done.

As the images appear in the Browser, you can begin working with them. Images may 
temporarily appear as gray boxes until the loading is complete.

Importing a Selection of Images
You can also import a selection of images from your camera or card reader.

To import a selection of images:
1 Connect your camera or card reader to your computer.

The Import panel and Import dialog appear, showing the images on the camera or card.

2 In the Projects panel, do one of the following:

´ Choose File > New Project (or press Command-N) to create a new project. 
´ Select an existing project to hold your images. (The Import arrow points at the 

selected project.)
The top-left portion of the Import dialog updates, displaying where the images are 
being placed.
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3 Select the images you want to import by Shift-clicking to select a range of adjacent 
images, Command-clicking to select nonadjacent images, or dragging a selection 
rectangle around the images you want.

The current number of images selected for import is displayed on the Import button in 
the lower-right corner of the dialog.

To reset the image selection so that no images are selected, click in the background 
beside a thumbnail.

If necessary, adjust the size of the thumbnails by dragging the Thumbnail Resize slider 
at the bottom of the dialog.

4 Choose a location for the imported images by doing one of the following:

´ To store imported master image files in the Aperture Library:  Choose In the Aperture 
Library from the Store Files pop-up menu.

´ To store imported master image files as referenced images in the Pictures folder on your 
hard disk:  Choose Pictures from the Store Files pop-up menu. 

´ To store imported master image files as referenced images in a location other than the 
Pictures folder:  Choose �Choose� from the Store Files pop-up menu and select the 
folder you want. Choose �No folder� from the Subfolders pop-up menu to specify 
that the files be stored as separate individual files in the selected folder. You can also 
specify that Aperture create and store your files in a hierarchy of subfolders with 
specific folder names. Choose whether you want the image files moved or copied to 
a new location by clicking the �Move files� or �Copy files� button.

5 Choose a naming convention from the Version Name pop-up menu to specify how you 
want the images named.

For example, choose Master Filename from the Version Name pop-up menu to have 
your files stored using the current master file names from your camera or card. Choose 
a name format from the Version Name pop-up menu to have your images stored using 
a specified name. If you choose a custom name format, enter the name you want in the 
Name Text field. You can also apply the name format to the master image as well. 
Choose Edit from the Version Name pop-up menu to define a new naming scheme.

6 To add metadata to your images as they�re imported, choose a metadata preset from 
the Add Metadata From pop-up menu.

Import button showing 
the number of images 
selected for import
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7 When you are satisfied with your image selection, click the Import arrow or the Import 
button in the lower-right corner of the dialog.

The import process begins and an indicator appears next to the project�s name, 
showing the progress of the import. When images are imported, a dialog appears. 

8 Click Eject Card, Erase and Eject Card, or Done.

As the images appear in the Browser, you can begin working with them. Images may 
temporarily appear as gray boxes until the loading is complete.

Importing Image Files Stored on Your Computer
You can import image files stored on your computer and other storage devices. You 
have a choice of storing imported images in the Aperture Library, importing images as 
referenced images and leaving them in their current locations, or importing images as 
referenced images and moving or copying them to a different location. 

Note:  If you have folders of images to import, you can import them using the Import 
Folders as Projects command.

You can import image files in many common image formats, including images scanned 
from nondigital sources such as film and photographic prints. Adding these image files 
to your Aperture database is as simple as navigating to the folder where they reside on 
your hard disk using the Import dialog. 

When you import images from a folder on your computer system, you have the choice 
of importing the images into a new project or an existing one.

To import image files stored on your computer�s hard disk or other storage device:
1 If the Import panel is hidden, click the Import Panel button in the toolbar to show it (or 

press Shift-I).

2 Select the disk that holds the image files you want to import.

The Import dialog appears with the file browser at the top.

Select the disk where the
images you want to
import are located.

Import Panel button
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3 In the file browser, navigate to the folder containing the image files you want to import.

When you have selected the folder containing the image files you want to import, 
image thumbnails appear in the Import dialog.

4 In the Projects panel, do one of the following:

´ Select Library to create a new, untitled project or choose File > New Project (or press 
Command-N). (The Import arrow points at the Library.)

´ Select an existing project to hold your images. (The Import arrow points at the 
selected project.)

The top-left portion of the Import dialog updates, displaying where the images are 
being placed.

5 Select the images you want to import by Shift-clicking to select a range of adjacent 
images, Command-clicking to select nonadjacent images, or dragging a selection 
rectangle around the images you want.

6 Choose a location for the imported images by doing one of the following:

´ To store imported master image files in the Aperture Library:  Choose In the Aperture 
Library from the Store Files pop-up menu.

´ To import the files as referenced images stored in their current locations on your hard 
disk:  Choose �In their current location� from the Store Files pop-up menu.

´ To store imported master image files as referenced images in the Pictures folder on your 
hard disk:  Choose Pictures from the Store Files pop-up menu. 

´ To store imported master image files as referenced images in a location other than the 
Pictures folder:  Choose �Choose� from the Store Files pop-up menu and select the 
folder you want. Choose �No folder� from the Subfolders pop-up menu to specify 
that the files be stored as separate individual files in the selected folder. You can also 
specify that Aperture create and store your files in a hierarchy of subfolders with 
specific folder names. Choose whether you want the image files moved or copied to 
a new location by clicking the �Move files� or �Copy files� button.

Select the folder of 
images you want to 
import.
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7 Choose a naming convention from the Version Name pop-up menu to specify how you 
want the images named.

For example, choose Master Filename from the Version Name pop-up menu to have 
your files stored using the current master filenames from your camera or card. Choose a 
name format from the Version Name pop-up menu to have your images stored using a 
specified name. If you choose a custom name format, enter the name you want in the 
Name Text field. You can also apply the name format to the master image as well. 
Choose Edit from the Version Name pop-up menu to define a new naming scheme.

8 To add metadata to your images as they�re imported, choose a metadata preset from 
the Add Metadata From pop-up menu. 

9 When you are satisfied with your image selection, click the Import arrow or the Import 
button in the lower-right corner of the dialog.

As the images appear in the Browser, you can begin working with them. 

Note:  If the folder contains subfolders of images and you want those imported too, 
choose File > Import > Folders as Projects.

Dragging Image Files from the Finder into a Project
You can drag image files from the Finder or desktop directly into a project. This is useful 
if you composited or created images in another application, and you want to use them 
in Aperture. You can also do this if you have image files scattered on your desktop or 
throughout folders on your system and you want to consolidate them in one place. 

To quickly import image files from the Finder into a project:
1 In the Projects panel, create a new project or select an existing project.

2 Locate the image file or files in the Finder.

3 Select the image files and drag them to the project in the Projects panel.

The import process begins and an indicator appears next to the project�s name, 
showing the progress of the import.

Drag the selected image 
files to a project.
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Importing Folders of Images from the Finder
If you�ve spent time organizing your images into a meaningful hierarchy on your 
computer and you want to keep that organization, you can import a folder of images 
as a project or drag it directly into the Projects panel. When you import a folder of 
images or drag it into the Projects panel, the folder becomes a project and any 
subfolders become albums within the project. 

To import a folder of images from the Finder using the Import command:
1 In the Projects panel, select Library.

2 Choose File > Import > Folders into a Project.

3 Select the folder of images that you want to import.

4 Choose a location for the imported images by doing one of the following:

´ To store imported master image files in the Aperture Library:  Choose In the Aperture 
Library from the Store Files pop-up menu.

´ To import the files as referenced images stored in their current locations on your hard 
disk:  Choose �In their current location� from the Store Files pop-up menu.

´ To store imported master image files as referenced images in the Pictures folder on your 
hard disk:  Choose Pictures from the Store Files pop-up menu. 

´ To store imported master image files as referenced images in a location other than the 
Pictures folder:  Choose �Choose� from the Store Files pop-up menu and select the 
folder you want. Choose �No folder� from the Subfolders pop-up menu to specify 
that the files be stored as separate individual files in the selected folder. You can also 
specify that Aperture create and store your files in a hierarchy of subfolders with 
specific folder names. Choose whether you want the image files moved or copied to 
a new location by clicking the �Move files� or �Copy files� button.

Warning:  When importing folders of images into Aperture, carefully plan how you 
want your images organized before you begin. The top-level folder containing images 
becomes a project containing all the images in the subfolders as well. This means that 
if you import a folder with thousands of images contained within its subfolders, 
Aperture will create a project with thousands of images. You can import a maximum 
of 10,000 master images into a project. If you have over 10,000 images to import into 
Aperture, consider importing the subfolders individually instead. Each subfolder will 
then become its own project.
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5 Choose a naming convention from the Version Name pop-up menu to specify how you 
want the images named.

For example, choose Master Filename from the Version Name pop-up menu to have 
your files stored using the current master filenames from your camera or card. Choose a 
name format from the Version Name pop-up menu to have your images stored using a 
specified name. If you choose a custom name format, enter the name you want in the 
Name Text field. You can also apply the name format to the master image as well. 
Choose Edit from the Version Name pop-up menu to define a new naming scheme.

6 Click Open.

The top-level folder is converted to a project. If the folder you imported contains a 
hierarchy of subfolders and images, the subfolders appear as albums. 

You can select multiple folders to import by Shift-clicking them.

When you drag folders into the Projects panel, Aperture uses the last import settings 
you specified to determine how the folders are imported and where they are stored.

To drag folders into Aperture:
1 In the Finder, locate the folder containing the images you want to import.

2 Drag the folder to the Projects panel.

The top-level folder is converted to a project. If the folder you imported contains a 
hierarchy of subfolders and images, the subfolders appear as albums.

Importing Your iPhoto Library
When you first open Aperture, a dialog appears that enables you to import your iPhoto 
Library. You can import your iPhoto Library, copying it into the Aperture Library, or you 
can simply allow Aperture to access the iPhoto Library as referenced images without 
storing it in the Aperture Library.

The organization of your iPhoto images and albums is maintained as projects in the 
Projects panel, as well as each image�s name, EXIF information, keywords, rating, and 
any applied adjustments. You cannot import slideshows, books, and Smart Albums 
from your iPhoto Library.

Note:  You must upgrade to iPhoto version 5.0.4 or later before you can import photos 
from your iPhoto Library into Aperture.

If you choose not to import your iPhoto Library right away, you can do it later. 
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To import your iPhoto Library:
1 Choose File > Import > iPhoto Library.

2 Select the iPhoto Library folder using the file browser in the Import dialog.

3 Choose a location for the imported images by doing one of the following:

´ To store imported master image files in the Aperture Library:  Choose In the Aperture 
Library from the Store Files pop-up menu.

´ To import the files as referenced images stored in their current locations on your hard 
disk:  Choose �In their current location� from the Store Files pop-up menu.

´ To store imported master image files as referenced images in the Pictures folder on your 
hard disk:  Choose Pictures from the Store Files pop-up menu. 

´ To store imported master image files as referenced images in a location other than the 
Pictures folder:  Choose �Choose� from the Store Files pop-up menu and select the 
folder you want. Choose �No folder� from the Subfolders pop-up menu to specify 
that the files be stored as separate individual files in the selected folder. You can also 
specify that Aperture create and store your files in a hierarchy of subfolders with 
specific folder names. Choose whether you want the image files moved or copied to 
a new location by clicking the �Move files� or �Copy files� button.

4 Choose a naming convention from the Version Name pop-up menu to specify how you 
want the images named.

For example, choose Master Filename from the Version Name pop-up menu to have 
your files stored using the current master filenames from your camera or card. Choose a 
name format from the Version Name pop-up menu to have your images stored using a 
specified name. If you choose a custom name format, enter the name you want in the 
Name Text field. You can also apply the name format to the master image as well. 
Choose Edit from the Version Name pop-up menu to define a new naming scheme.

5 Click Choose.

Your iPhoto Library is imported into Aperture.

If you choose to store the photos imported from your iPhoto Library in the Aperture 
Library, Aperture makes a copy of each image file and places it in the Aperture Library. 
This doubles the amount of disk space the image files occupy on your computer. To 
save space, import the photos in your iPhoto Library as referenced images. You can also 
delete images from your iPhoto Library after importing them, but you will no longer 
have access to those images within iPhoto. If you choose not to delete the images in 
your iPhoto Library, any changes you make to those images in iPhoto will not be 
reflected in the duplicate images in Aperture.

Note:  You can also import individual images or albums from your iPhoto Library.
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Transferring Projects from Another Aperture System
If you work with several computers, or work on a project with other people, you may 
find it necessary to transfer projects from one Aperture system to another. Transferring 
projects is a simple import process.

To transfer a project from one computer to another:
1 Select the project you want to transfer, then choose File > Export Project (or press 

Command-Shift-E).

2 Enter a name and choose a location for the exported project.

3 If your project contains referenced images, select the �Consolidate images into 
exported project� checkbox to transfer the original referenced images� master files as 
well as the previews and metadata as a self-contained project that another Aperture 
system can use.

If you want to transfer projects with referenced images to another computer, and don�t 
want to transfer the referenced images� master files, but would rather transfer just the 
referenced images� previews, don�t choose the �Consolidate images into exported 
project� checkbox.

4 Click Save.

The project file is exported to the location you chose.

5 Connect or network the two computers together.

For more information, see the documentation that came with the computers.

6 Open Aperture on the computer to which you want to transfer the project.

7 In the Projects panel, select Library.

8 Choose File > Import > Projects.

9 In the Import dialog, navigate to the location on the other computer where the project 
you want to transfer is stored, select the project, then click Open.

The selected project appears in the Projects panel.
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Making an Immediate Backup
After you import images into Aperture, you can make an immediate backup to ensure 
that your digital master files exist in more than one place. You do this by having 
Aperture create a new vault or update an existing vault. For more information, see 
�Updating Vaults� on page 205.

It�s a good idea to back up your images as often as possible. To protect yourself from 
the loss of image assets due to catastrophic failure, you should back up your digital 
master files as soon as you�ve finished importing them into Aperture. For detailed 
information, see Chapter 21, �Backing Up Your Images,� on page 201.
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6 Working with Images 
in the Browser

After a shoot, you may need to sort through hundreds or 
thousands of images in a project. The Browser provides 
efficient ways to deal with a large number of images. 

This chapter provides details about the Browser and how to use it to view, select, 
rearrange, rotate, and display images.

An Overview of the Browser 
When you select a project or album in the Projects panel, thumbnails of its images 
appear in the Browser. You select images in the Browser to work with them. You can 
move and rearrange the images, rotate images, make new versions, and delete images 
from the project.

´ Grid View button:  Click to display images as thumbnails.
´ List View button:  Click to display images as a text list.
´ Sorting pop-up menu:  You can choose to sort images by image date, rating, or 

keywords from this pop-up menu.
´ Sort Direction button:  Click this to sort images in ascending or descending order.
´ Query HUD button:  Click this to show the Query HUD for searching. For more 

information, see Chapter 12, �Searching for and Displaying Images,� on page 139.

Grid View button
Shuttle control

Thumbnail Resize slider

Scroll bar

Sort Direction button

Search field

Images displayed in grid
view in the Browser

List View button

Sorting pop-up menu Query HUD button



70 Chapter 6    Working with Images in the Browser

 

´ Search field:  Enter text to search for images associated with that text, such as a 
version name or keywords.

´ Shuttle control:  Drag this to shuttle continuously through images in the Browser. You 
can also use the J, K, and L keys.

´ Scroll bar:  Use this to navigate through all images in a project.
´ Thumbnail Resize slider:  Use this to increase or decrease the size of thumbnails 

displayed in grid view.

Viewing Images in the Browser
You can view images in the Browser in grid view (the default) or list view. 
´ Grid view:  Organizes thumbnails of your images in a grid pattern. Use grid view 

when it�s easiest to identify your images by sight and work with thumbnails as you 
organize, stack, and assign keywords to images.

´ List view:  Lists your images by file information. Use list view when you need to see or 
sort your images by file data such as pixel size, file size, or rating. You can also use list 
view to sort your images by any of the column categories. Click the category column 
heading to sort your images by that category.

You can also customize the information that appears with your images. For example, 
you can set your images to appear with filename, ratings, and metadata.

Images displayed in list
view in the Browser
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Working with Images in Grid View
Grid view is the Browser�s default view. Grid view provides a grid of thumbnails as a 
top-level view of your project. If your project has many images, you may want to adjust 
the size of the thumbnails to a size convenient for selecting and working with them. 
You can also use the Shuttle control or scroll bar to scroll through the images.

To switch to grid view, do one of the following:
m Choose View > Grid (or press Control-G).

m Click the Grid View button in the Browser.

To adjust thumbnail size:
m Drag the Thumbnail Resize slider to increase or decrease the size of the thumbnails.

To shuttle continuously through the images in a project, do one of the following:
m Drag the Shuttle control.

m Press J to shuttle up, press K to stop shuttling, or press L to shuttle down.

Note:  Pressing J or L multiple times increases the shuttle speed.

Working with Images in List View
Instead of displaying thumbnails, list view displays images by icon, with accompanying 
information such as image dimensions, file sizes, and dates. You can choose what type 
of information is displayed.

To switch to list view, do one of the following:
m Choose View > List (or press Control-L).

m Click the List View button in the Browser.

Grid View button

List View button
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To choose what type of information is displayed in list view:
1 Choose View > View Options (or press Command-J).

The View Options window appears.

2 In the List View Columns section, choose a display option from the Set 1 pop-up menu.

Columns in the Browser immediately change to display the information you selected.

One of the main advantages of list view is that you can quickly sort images based on a 
category of information. When you click a column heading in list view, Aperture 
reorders the images, sorting them by that category. For example, you might sort your 
images by date.

To sort images in list view by a category:
m Click the category column heading in the Browser.

When you work in list view, it may sometimes be difficult to determine the content of 
an image based on the file information. You can enlarge the thumbnail icons that 
appear in list view to give you a better look at the images.

To enlarge the thumbnail icons in list view:
m Drag the Thumbnail Resize slider to increase or decrease the size of the icons.

You can also easily rename files after importing. When you rename a file, you are 
renaming the image version, not the digital master file. The filename of the original 
master file does not change.

To rename an image version in list view:
m Select an image, double-click the image name, then enter a new name. 

Images in list view 
sorted by rating
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Adjusting the Background of the Browser
You may want to lighten or darken the background of the Browser to better view your 
thumbnails. You can darken the background from shades of gray all the way to black, 
or lighten it from gray to white.

Note:  A darker background interferes less with the colors in your image, and is good 
for performing color adjustments on your images. 

To change the background of the Browser:
1 Choose Aperture > Preferences.

2 In the Preferences window, drag the Grid View Background Brightness slider to lighten 
or darken the background, then close the window.

Navigating Through and Selecting Images
To work on images, you�ll need to review them in the Browser. You can use the arrow 
keys or menu commands to navigate to images in the Browser.

To navigate to images, do one of the following:
m Press an arrow key to move left, right, up, or down.

m In the control bar, click the Previous Image or Next Image button.

Aperture provides fast and efficient ways of selecting images, depending on your work 
style and preferences. Images you�ve selected have a white border. When you select a 
group of images, the actively selected image, called the primary selection, appears with a 
thick white border and the rest of the selected images appear with thin white borders. 

Previous Image button Next Image button

All selected images
display a thin white

border.
A thick white border surrounds 
the primary selection.
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To select a single image:
m Click the image.

To select a range of images, do one of the following:
m Click the first image in a range, then Shift-click the last image.

m Press the arrow keys to select the first image, then press Shift and the Left or Right 
Arrow key to select the last image in the range.

m Select an image in a stack, then choose Edit > Grow Selection (or press Command-E) to 
select all images in the stack.

m Select an image, then choose Edit > Select to End (or press Shift-End) to extend the 
selection to the last image in the Browser.

m Select an image, then choose Edit > Select to Beginning (or press Shift-Home) to 
extend the selection to the first image in the Browser.

m Drag a selection rectangle to select all the images that fall within the rectangle.

To select nonadjacent images:
m Command-click the images you want to select. 

Command-click the images again to deselect them.

To select all images in the Browser:
m Choose Edit > Select All (or press Command-A).

To select only the primary selection, deselecting all other images:
m Choose Edit > Reduce Selection (or press Shift-E).

To deselect the current selection and select all unselected images:
m Choose Edit > Invert Selection (or press Command-R).

To deselect all images in the Browser:
m Choose Edit > Deselect All (or press Command-Shift-A).
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Rearranging Images in the Browser
As you work with images in the Browser, you can move and rearrange images into any 
order or grouping you want. For example, you might want to keep all related images of 
a wedding event, such as the cake cutting, in close proximity to allow you to easily 
adjust them. 

You can drag images to new locations in the Browser. You can drag single images or 
selections of multiple images. When you drag images to new locations, you create a 
custom arrangement of your images; the Sorting pop-up menu changes to show the 
Custom option. Aperture records the order of your images, and any time you choose 
Custom from the Sorting pop-up menu, your images reappear in that order.

To rearrange images in the Browser:
m Drag the images you want to a new location; when the green bar appears, release the 

mouse button.

To restore a custom arrangement of your images in the Browser:
m Choose Custom from the Sorting pop-up menu.

Aperture remembers the last time you moved images and restores that arrangement.

As you drag an image to 
a new location, a green 
bar marks where the 
image will be placed.
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Rotating Images
When images are imported into a project, some may appear in an incorrect orientation, 
requiring you to rotate them right side up. The control bar provides rotate buttons for 
rotating selected images, and the toolbar contains rotate tools. You can rotate images 
individually or select a group and rotate them all at once. You can also conveniently 
select images and quickly rotate them using keyboard shortcuts.

To rotate images counterclockwise, do one of the following:
m Select an image or group of images, then choose Images > Rotate Counterclockwise, or 

press the left bracket ([) key.

m Select an image or group of images, then click the Rotate Left button in the control bar.

m Select the Rotate Left tool in the toolbar, then click an image.

To rotate images clockwise, do one of the following:
m Select an image or group of images, then choose Images > Rotate Clockwise, or press 

the right bracket (]) key.

m Select an image or group of images, then click the Rotate Right button in the control bar.

m Select the Rotate Right tool in the toolbar, then click an image.

Displaying Specific Metadata with Your Images
You can quickly display specific types of information, or embedded metadata, with 
your images. For example, you can have Aperture show the EXIF (Exchangeable Image 
File) or IPTC (International Press Telecommunications Council) data associated with 
your images. 
´ EXIF metadata:  Includes camera settings such as shutter speed, ISO setting, date and 

time, focal length, exposure, metering pattern, and flash information. 
´ IPTC metadata:  Information that can be embedded in a digital image with most 

software programs used to edit photos. Includes a caption, the place and date a 
photo was taken, and copyright information.

Rotate Left button Rotate Right button
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You use the View Options window to customize the display of information shown with 
images in the Browser.

In the Grid View section, you select the Set buttons and choose the information you 
want displayed. You can also choose where the information should appear from the 
Placement pop-up menus.

To set the display of metadata shown with images in the Browser:
1 Choose View > View Options (or press Command-J).

2 Select the Grid View checkbox.

3 Choose the metadata views you want to use from the Set 1 and Set 2 pop-up menus.

4 Choose the location where you want the metadata displayed from the Placement pop-
up menus. 

5 Click the Set 1 or Set 2 button to select the metadata view you want displayed.

6 Click Done.

To show EXIF metadata in the Metadata Inspector:
m Select an image, then press Control-E.

To show IPTC metadata in the Metadata Inspector:
m Select an image, then press Control-I.

The Browser�s metadata 
display settings appear here.
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Creating Versions of an Image
Occasionally, you may want to make copies of an image. For example, you might copy 
an image and apply different exposure settings or other adjustments, or change it for a 
specific use, such as for placement in a webpage or print book. When you copy an 
image, Aperture makes a new version of the image.

When you create a new image version, you have a choice of copying the original 
master file or the currently selected version with any changes you�ve made. For 
example, if you�ve made a series of adjustments to an image and now you�d like to start 
from the original master file and make different adjustments, you can copy the master 
file and start with a fresh, unchanged image. 

To copy the master file:
1 Select the image whose master file you want to copy.

2 Do one of the following:

´ Choose Images > New Version From Master (or press Option-G).
´ Click the New Version From Master button in the toolbar.

If you�re creating a number of image versions showing incremental changes to an 
image, you can copy the last version you made and make more changes. For example, 
if you plan to use the same cropping and exposure adjustments in multiple versions, it 
makes sense to perform those adjustments first and then make copies of the image 
version before proceeding.

To copy the selected image version:
1 Select the image you want to copy.

2 Do one of the following:

´ Choose Images > Duplicate Version (or press Option-V).
´ Click the Duplicate Version button in the toolbar.

If you create multiple versions of an image, Aperture tracks the versions within a stack. 
The stack represents all the versions of a particular image that you have created. You can 
open a stack and see the different versions you�ve created for an image. 
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To open a stack to see all the versions:
m Click the Stack button on the stack.

When a stack is open, you can select any of its image versions to display that version in 
the Viewer.

A dark gray border 
surrounds the images 
in a version stack.

Click the Stack button
on an image to show all

versions in the stack.

Understanding Image Versions
Whenever you work on an image, you are working with an image version, never the 
master file. Each time you copy an image, you create a new version. When an image 
has multiple versions, all versions are stacked together. 

Aperture keeps all your image versions together so that you can view or work with 
them whenever you wish. For example, you might open a stack and select a specific 
image version to copy. The entire stack appears in all the different projects or albums 
in which the image appears.

The instant you change a version in an album, a new version is added to the stack. 
The first image in the stack is the pick and represents the stack, and is the image 
you work with when you select the version stack in your album. You can also 
specify that one of the versions in a stack is the pick for a specific album. You can 
select the pick you want and make it the album pick, and that image appears with 
an album pick icon. The pick is specific to the album it�s in. The original pick 
remains selected in the other locations.

When you open a stack, you can reorder the image versions however you like. 
Dragging an image version to the first position makes it the pick. You can reorder, 
or promote or demote, the versions according to your needs. For more information 
about stacks, see Chapter 9, �Stacking Images and Making Picks,� on page 105.
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Copying Images and Moving Images to Different Locations
You can drag images into different projects and albums. The following kinds of files can 
be dragged directly into a project or album:
´ GIF
´ JPEG
´ JPEG2000
´ PNG
´ PSD 
´ RAW files from a variety of supported digital cameras
´ TIFF

Note:  For a list of supported digital cameras, go to http://www.apple.com/aperture.

To copy a master file into another project:
m Option-drag the image in the Browser into a different project in the Projects panel. 

To move a master file into another project, removing it from the current project:
m Drag the image into a different project. 

To copy an image version into another album:
m Drag the image version into a different album.

Working with Referenced Images
Master files for images that you import as referenced images may reside in many 
different locations on your hard disk storage devices instead of in the single location 
of your main Aperture Library file. At times you may need to determine which images 
are referenced images in order to readily locate them in the Finder. With Aperture, 
you can easily:
´ Display badge overlays that identify referenced images
´ Display a list of referenced images
´ Locate a referenced image on your hard disk

http://www.apple.com/aperture
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Identifying Referenced Images
After you import referenced images, you can identify them in the Browser by turning 
on referenced image badge overlays. Referenced images appear with badges that 
show whether their master files are currently available (online) or not found (offline).

To turn on referenced image badge overlays:
1 Choose Aperture > Preferences.

2 Select the �Badge referenced images� checkbox.

You can select and work with online referenced images using the same procedures you 
use with images whose master files reside in the Aperture Library. 

Aperture keeps track of referenced images� master files when you simply move or 
rename the files in the Finder, keeping them on the same hard disk or volume.

A referenced image appears as an offline image if the hard disk holding the referenced 
image�s master file has been disconnected from your computer system. A referenced 
image is listed as �not found� when its master file has been deleted, moved to the 
Trash, or moved from its original hard disk location to another hard disk drive and 
Aperture can�t find it. 

Displaying a List of Referenced Images
When working with numerous images in the Browser, you may need to determine 
which images have master files that reside in the Aperture Library and which are 
referenced images whose master files are located elsewhere on your hard disks.

You can select a group of images in the Browser and then have Aperture show a list of 
the referenced images within the selection and where the master files are located.

These badge overlays
indicate the images are

referenced images.

This badge overlay
indicates the image is an
offline referenced image.
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To see a list of referenced images in a selection:
1 In the Browser, select the group of images you want.

2 Choose File > Manage Referenced Files.

3 Choose File > Show Referenced Files.

The Referenced Files dialog appears.

Locating a Referenced Image on a Hard Disk
At times you may need to quickly find a referenced image�s master file on your hard 
disk to copy or move it, attach it to an email, or otherwise work with it outside of 
Aperture. You can select an image in the Browser and have Aperture display the 
image�s master file location in the Finder.

To locate a referenced image�s master file in the Finder:
1 Select the referenced image you want in the Browser.

2 Choose File > Show in Finder.

A Finder window appears, displaying the selected referenced image�s master file. 

Note:  If you open a referenced image�s master file from the Finder in another 
application, you will not see the changes or adjustments you�ve made to the image in 
Aperture. Your changes appear in versions stored in the Aperture Library, and the 
referenced image�s master file is always left unchanged. To see the adjusted photo, you 
need to export a version of it.

Shows the names of
hard disks where

referenced master
files are located.

Identifies how many master files for 
referenced images are on the hard disk, 
and how many are not found. 

Identifies the hard 
disk location of the 
referenced master files.

Displays the specific image 
and metadata to help you 
identify the image.
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7 Displaying Images in the Viewer

You can view an image in incredible detail or view several 
images at a time in the Viewer. 

This chapter provides details about the Viewer and how you can use it to view images 
in great detail when you are comparing images, making adjustments, and viewing 
images on multiple displays.

An Overview of the Viewer 
When you select images in the Browser, the Viewer immediately displays a detailed 
view of your selection. You can display one image at a time, three images at a time, or 
display a selection of multiple images. 

A detailed view of the 
selected image appears 
in the Viewer. 

The selected image 
in the Browser
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When rating or adjusting images, you can set the Viewer to compare two images at once. 
You can select an image to compare against and then display other similar or related 
images next to it for inspection. You might use the Aperture comparison feature to select 
images from a series or compare versions of adjusted images to see which is the best.

You can also set Viewer options that determine the amount of information that 
appears with each image. For example, you can display images in the Viewer with their 
keywords, ratings, and other information, such as IPTC or EXIF metadata.

Adjusting the Background of the Viewer
You may want to lighten or darken the background of the Viewer to better view your 
images. You can darken the background from shades of gray all the way to black, or 
lighten it from shades of gray to white.

To change the background of the Viewer:
1 Choose Aperture > Preferences.

2 In the Preferences window, drag the Viewer Background Brightness slider to lighten or 
darken the background, then close the window.

You can use the Viewer 
to compare two images.
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Choosing the Number of Images Displayed in the Viewer
You can specify whether the Viewer displays one image, three images, or multiple 
images at a time. If your system uses multiple displays, you can configure your primary 
and secondary displays to show single images, three images, or multiple images 
simultaneously. 

To display a single image, do one of the following:
m Choose View > Main Viewer > Primary (or press Option-R).

m Choose Primary from the Viewer Mode pop-up menu in the control bar.

When the Viewer is set to show three images at a time, Aperture displays the selected 
image in the center of the three images that appear in the Viewer.

To display three images, do one of the following:
m Choose View > Main Viewer > Three Up (or press Option-H).

m Choose Three Up from the Viewer Mode pop-up menu in the control bar.

When the Viewer is set to show multiple images, Aperture displays all selected images. 

To display multiple images, do one of the following:
m Choose View > Main Viewer > Multi (or press Option-U).

m Choose Multi from the Viewer Mode pop-up menu in the control bar.

Choose Primary from
the Viewer Mode pop-up

menu to view a single
image on the screen.
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Comparing Images
You can select an image against which to compare other images in your project or 
Library. The selected image remains on the screen as you select and display other 
images to compare against it. The comparison feature is useful for making final 
selections of the best images in a series, or comparing two versions of an image for 
correct exposure or highlights. When comparing images, you can apply ratings and 
keywords, and make adjustments to selected images. 

Comparing images involves setting a �compare� image and then viewing other images 
against the compare image. You can also compare images in Full Screen mode. For 
more information, see Chapter 8, �Viewing Images in Full Screen Mode,� on page 93.

To set the compare image:
1 Select an image.

2 Choose Edit > Set Compare Item (or press Return).

To view an image against a compare image, do one of the following:
m Select a second image.

m Navigate through the images in the Browser with the Up, Down, Left, and Right 
Arrow keys.

If you wish, you can view multiple images against the compare image. 

To view multiple images against a compare image, do one of the following:
m Command-click multiple images in the Browser.

m Hold down the Shift key while pressing the Up, Down, Left, or Right Arrow key.

When you�ve finished comparing images, you can turn this feature off.

To turn off the comparison feature and select the compare item:
m Choose Edit > Select Compare Item (or press Option-Return).

To turn off the feature and select the image you�re viewing against 
the compare item:

m Choose Edit > Clear Compare Item (or press Command-Return).

The compare image is
displayed with a yellow

border, visible in the
Viewer and Browser.

The image you want to 
examine against the 
compare image is shown 
to the right. 
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Viewing Images with the Loupe
You can use the Loupe to examine parts of an image. You position the small ring of the 
Loupe over the portion of the image you want to see, and the large ring shows a 
magnified view. It�s useful for making quick checks for dust specks, flaws, fingerprints, or 
other issues. You can use the Loupe on any image or thumbnail in the Aperture Library. 

For information about the latest enhancements to the Loupe, see New Features in the 
Aperture Help menu.

To show the Loupe, do one of the following:
m Choose View > Loupe, or press the grave accent (‘) key.

m Click the Loupe button in the toolbar.

To hide the Loupe, do any of the above again.

You can also change the size of the Loupe and increase or decrease its magnification level. 

To reduce the size of the Loupe:
m Choose View > Decrease Diameter, or press Option-Shift�hyphen (-), to decrease the 

Loupe size.

To enlarge the size of the Loupe:
m Choose View > Increase Diameter, or press Option-Shift�equal sign (=), to increase the 

Loupe�s size.

The Loupe shows a
magnified view of

whatever is beneath it.
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To increase the Loupe magnification:
m Press Command�Shift�equal sign (=).

Press these keys repeatedly to increase magnification more.

To decrease the Loupe magnification:
m Press Command-Shift-hyphen (-).

Press these keys repeatedly to decrease magnification more.

Viewing Images at Full Resolution
Most digital cameras let you save images in different formats and image sizes. Aperture 
displays your images to fit the Viewer size, providing a reduced view. If you have a large 
display or two displays, you can increase the size of the Viewer to display your images 
at sizes closer to their full-resolution size. 

A full-resolution image shows every pixel of an image. You can set Aperture to display 
your image at full resolution, even though the image may not fit within the Viewer. 
Viewing images at full resolution allows you to inspect your images using the finest 
level of detail possible.

To display a selected image at full resolution, do one of the following:
m Choose View > Zoom to Actual Size (or press Z).

m Click the Zoom Viewer button in the control bar.

Click the button again to turn off the full-resolution display.

When an image doesn�t fit within the area of the Viewer, a small, gray box appears on 
your image with a red rectangle inside, showing the portion of the image that is 
currently visible in the Viewer. You can drag the red rectangle within the gray box to 
see other parts of the image, also known as panning.

Zoom Viewer button
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To pan the full-resolution image in the Viewer, do one of the following:
m Drag the red rectangle that appears on the image.

m Hold down the Space bar and drag the image.

Viewing Images on Multiple Displays
Using the additional screen space of a second display affords an excellent platform for 
viewing and adjusting images, playing slideshows, and presenting your full-color, full-
size images to clients. For more information on setting up two displays, see 
�Connecting a Second Display to Your Computer� on page 23.

When your system uses two displays, Aperture provides two Viewers in which you can 
view multiple images. These Viewers are called the primary Viewer and secondary 
Viewer. The primary Viewer is used for displaying the Aperture application and the 
secondary Viewer for viewing images. 

You can set the secondary Viewer to display images in different ways by choosing an 
option from the Viewer Mode pop-up menu in the control bar.
´ Desktop:  Turns off the dual-display function.
´ Blank:  Sets the secondary Viewer to be a blank screen.
´ Mirror:  Displays the same images in the primary and secondary Viewers. For example, 

if you have the primary Viewer set to display three images, the secondary Viewer 
displays three images as well.

´ Alternate:  Displays the currently selected image in the secondary Viewer. The 
secondary Viewer shows only one image even when you have the primary Viewer set 
to display multiple images.

´ Span:  Splits the display of the currently selected images between the primary and 
secondary Viewers. For example, if you select seven images to view, the primary 
Viewer shows as many as fit its screen size, and the remaining images appear in the 
secondary Viewer. Thus, one Viewer might show three images and the other Viewer 
might show the remaining four of the seven. Span is also used if you want to 
compare images and show one image per display.

Drag the red rectangle 
to change your view of 
the image.
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To display the currently selected image in the secondary Viewer, 
do one of the following:

m Choose View > Secondary Viewer > Alternate (or press Option-A).

m Choose Alternate from the Viewer Mode pop-up menu in the control bar.

To display the same images in both the primary and secondary Viewers, 
do one of the following:

m Choose View > Secondary Viewer > Mirror (or press Option-M).

m Choose Mirror from the Viewer Mode pop-up menu in the control bar.

To display a selection of images across both the primary and secondary Viewers, 
do one of the following:

m Choose View > Secondary Viewer > Span (or press Option-S).

m Choose Span from the Viewer Mode pop-up menu in the control bar.

To turn off the display of images in the secondary Viewer, 
do one of the following:

m Choose View > Secondary Viewer > Blank (or press Option-B).

m Choose Blank from the Viewer Mode pop-up menu in the control bar.

To turn off the secondary Viewer function, do one of the following:
m Choose View > Secondary Viewer > Desktop (or press Option-X).

m Choose Desktop from the Viewer Mode pop-up menu in the control bar.

Choose Alternate from
the Viewer Mode pop-up

menu to display the
selected image in the

secondary Viewer.
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Displaying Metadata Associated with Images
To help identify your images as you work with them, you can set Aperture to display 
the metadata associated with images. You can display keywords, ratings, EXIF 
information, IPTC information, and more. You can specify whether the information 
appears below the image or across the bottom of the image. 

You can also specify up to two sets of predefined information displays. For example, 
one set of Viewer options can be set to show ratings only, and another set to show all 
the IPTC information associated with an image. You can then switch between sets to 
change the information that appears with your images.

The caption
and keywords are

displayed here.
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To set the display of metadata shown with images in the Viewer:
1 Choose View > View Options (or press Command-J).

2 In the View Options window, do the following:

a Select the Viewer checkbox to activate Viewer overlays.
b Choose the information you want displayed with your images from the Set 1 or Set 2 

pop-up menu.
c Choose where you want the information to appear from the Placement pop-up 

menu for the set.

3 Click Done.

The View Options
window lets you choose

how you want to
view images.
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8 Viewing Images 
in Full Screen Mode

High resolution, no distractions, and access to the tools and 
HUDs make Full Screen mode an ideal environment for 
working with your images. 

This chapter details how to use Full Screen mode as an alternate work environment when 
you want to view images only, with as little of the Aperture interface shown as possible.

An Overview of Full Screen Mode
Full Screen mode projects your images onto a simple black background and can be 
used with one or two displays. Using Full Screen mode with a dual-display system gives 
you additional space to compare and adjust images. For more information about setting 
up a dual-display system, see �Setting Up Your System with Two Displays� on page 23.

Once you�re in Full Screen mode, you can view, sort, and stack your images. You can 
also apply adjustments and keywords. When you�ve finished working with your images, 
you can use this mode to preview and proof your images. 
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Full Screen mode includes a toolbar and filmstrip to help you view, organize, and adjust 
your images. 

´ Toolbar:  Contains version and stacking buttons, as well as the full set of image 
adjustment tools. 

Note:  By default, the toolbar is hidden; to display it at the top of the screen, move 
your pointer to the top of your primary screen. 

´ Filmstrip:  Use this to move through, organize, and rate your images. You can dock 
the filmstrip on the left, right, or bottom of the screen�wherever it best suits your 
work habits. 

Note:  You can also use any of the Aperture HUDs in Full Screen mode. You can open 
the Adjustments HUD or Keywords HUD by pressing its keyboard shortcut (see �Using 
Keyboard Shortcuts in Full Screen Mode� on page 104).

Filmstrip available
in Full Screen mode

Toolbar available in 
Full Screen mode

The displayed image fills
the screen.
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Entering and Exiting Full Screen Mode
You can quickly switch between Full Screen mode and your workspace view.

To enter Full Screen mode:
m Click the Full Screen button in the control bar (or press F).

The Aperture main window disappears and your images appear in Full Screen mode.

To exit Full Screen mode, do one of the following:
m Click the Exit Full Screen button in the filmstrip (or press F).

m Press Escape.

The workspace layout you were working in before entering Full Screen mode reappears.

Using the Filmstrip in Full Screen Mode
The filmstrip in Full Screen mode is similar to the control bar in the Aperture main 
window. You can use the filmstrip�s controls to move through, rotate, view, and rate 
your images. 

Full Screen button 
in the control bar

Exit Full Screen button 
in the filmstrip

Images shown in the filmstripQuery HUD button

Scroll bar Thumbnail Resize sliderShuttle control

Search field
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Filmstrip Controls
The following controls in the filmstrip are used to view images when in Full Screen mode.
´ Shuttle control:  Click either side of this slider to rapidly scroll through your filmstrip 

images. The closer to the double arrows you click, the more rapidly the filmstrip 
moves through its images. You can also use the J, K, and L keys to shuttle through 
your images.

´ Scroll bar:  Use this to navigate through your images.
´ Thumbnail Resize slider:  Drag the slider to change the size of the image thumbnails 

shown in the filmstrip.

The following controls are displayed on the left side of the filmstrip and control the 
images shown in the filmstrip.

´ Search field:  Enter text; images that match appear in the full-screen view.
´ Query HUD button:  Opens the Query HUD. From the Query HUD, you can perform a 

quick search or create a new album to hold the contents of your search.

Rating buttons

Display controls

Rotate buttons Navigation buttons

Search field

Query HUD button
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Rotate and Navigation Buttons

´ Rotate Left:  Click this button to rotate the selected image counterclockwise.
´ Rotate Right:  Click this button to rotate the selected image clockwise.
´ Previous Image:  Click this button to display the previous image.
´ Next Image:  Click this button to display the next image.

Rating Buttons

´ Reject:  Click this button to give the selected image a Reject rating.
´ Decrease Rating:  Click this button to decrease the selected image�s rating.
´ Increase Rating:  Click this button to increase the selected image�s rating.
´ Select:  Click this button to give the selected image a Select rating.

Rotate Left Next Image 

Previous ImageRotate Right

Reject Select

Decrease
Rating

Increase 
Rating
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Display Controls

Â

 

Viewer Mode pop-up menu

 

:  Use this to choose how to view images on your display or 
displays and how to position images on each display. You can also control the filmstrip 
with this pop-up menu (see •Showing and Hiding the FilmstripŽ on page 99).

 

Note:  

 

The display settings in Full Screen mode and the display settings in the control 
bar in the Aperture main window are not shared. This allows you to have different 
display settings in each mode. For example, you can set your main display setting to 
Desktop while in the main window, and set your second display setting to Span 
while in Full Screen mode.

Â

 

Zoom Viewer:

 

  Click this button to enlarge the image to a 100% pixel-for-pixel view.

Â

 

Exit Full Screen: 

 

 Click this button to exit Full Screen mode.

Â

 

Primary Only:

 

  Click this button to temporarily change between making metadata 
changes to all selected images or the primary selection only.

 

Viewing Images in Full Screen Mode

 

You can easily view images in Full Screen mode.

 

To view an image that•s in the filmstrip:
m

 

Select an image displayed in the filmstrip. 

The image fills the screen.

 

To view more than one image at the same time, do one of the following:
m

 

Command-click images to select them.

m

 

Change your view settings in the Viewer Mode pop-up menu.

Viewer Mode
pop-up menu

Primary Only 
button

Exit Full Screen 
button

Zoom Viewer
button
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Showing and Hiding the Filmstrip
You can move the filmstrip to any location on your primary display. But there are times, 
especially when viewing an image at full resolution, that you cannot get the filmstrip 
off your image. The filmstrip includes controls that let you define when the filmstrip 
appears. You can also specify how the filmstrip fits on the screen in relation to the 
image or images you are viewing. 

There are several ways you can configure the filmstrip. You can choose to always show 
the filmstrip, show it based on image dimensions, or have Aperture automatically fit 
the images and filmstrip on your screens without overlapping.

To always show the filmstrip, do one of the following:
m Choose On from the Viewer Mode pop-up menu.

m Press Control-slash (/).

To only show the filmstrip when you move the pointer over its docked position, 
do one of the following:

m Choose Auto from the Viewer Mode pop-up menu.

m Press Control-period (.).

To have Aperture automatically fit the image and the filmstrip on the screen, 
do one of the following:

m Choose Avoid from the Viewer Mode pop-up menu.

m Press Control-V.

Aperture fits your images and the filmstrip on your screen, keeping the filmstrip and 
your images from overlapping.

Working with the Toolbar in Full Screen Mode
The toolbar displayed in Full Screen mode is very similar to the toolbar in the Aperture 
main window. 

To view the Full Screen mode toolbar:
m In Full Screen mode, move the pointer to the top of your primary screen. 
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Controls in the Full Screen Mode Toolbar
You can use the toolbar�s buttons and tools to create image versions, work with stacks, 
and make a variety of adjustments to your images.

Version Buttons

´ Duplicate Version:  Click this to create a new version of the selected image.
´ New Version From Master:  Click this to create a version from the original master file. A 

duplicate of the master file is created. 

Stacking Buttons

´ Stack Pick:  Select a stack item, then click this button to mark the image as its 
stack�s pick. 

´ Promote:  Select a stack item, then click this button to move the selected stack item 
closer to the stack�s pick.

´ Demote:  Select a stack item, then click this button to move the selected stack item 
farther from the stack�s pick.

´ Album Pick:  Select an image version to represent a stack, then click this button to 
select the image as the stack pick within the album (the stack can have a different 
pick image in another album).

´ Open All Stacks:  Click this button to open all the image stacks in the album or project 
you�re viewing.

´ Close All Stacks:  Click this button to close all the image stacks in the album or project 
you�re viewing.

Duplicate Version
button

New Version From 
Master button

Close All Stacks buttonStack Pick button

Demote 
button

Album Pick button Open All Stacks button

Promote
button
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Adjustment Tools

´ Selection tool:  Use this to select images.
´ Rotate Left tool:  Use this tool to rotate an image counterclockwise.
´ Rotate Right tool:  Use this tool to rotate an image clockwise.
´ Straighten tool:  Use this to manually rotate an image so that it�s straight in relation to 

a virtual horizon.
´ Crop tool:  Use this tool to crop an image to a constrained aspect ratio or custom 

dimension.
´ Spot & Patch tool:  Removes imperfections in the image, such as sensor dust, by either 

copying the pixels around the blemish (Spot tool) or copying pixels from another 
area of the image (Patch tool).

´ Red Eye tool:  Use this to correct red-eye, occurring when the subject�s retinas reflect 
light from your camera�s flash.

´ Lift tool:  Use this to copy a set of metadata and adjustments, including cropping and 
straightening of images, from a selected image.

´ Stamp tool:  Use this to stamp, or apply, a copied set of adjustments to one or 
several images.

Other Buttons

´ Show Master Image:  Click this to view an image of the original master file. If the image 
selected is a duplicate (usually an adjusted version), the master image still appears.

´ Always Show Toolbar:  Click this to keep the toolbar in view.
´ Loupe:  Click this to open the Loupe, which you can use to minutely examine parts of 

an image.
´ Adjustments HUD:  Click this to show or hide the Adjustments HUD.

Selection tool Stamp tool

Rotate Left
tool

Crop tool

Lift tool

Rotate Right tool Spot & Patch tool

Straighten
tool Red Eye tool

Loupe button

Show Master Image
button

Adjustments HUD 
button

Always Show
Toolbar button
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Using HUDs in Full Screen Mode 
Full Screen mode�s filmstrip and toolbar contain the most common Aperture controls 
and tools. However, you can use any of the Aperture HUDs (heads-up displays) in Full 
Screen mode. Open a HUD when you want to add keywords or use adjustment tools 
that are not in the Full Screen mode toolbar, or when it�s convenient to use controls in 
a movable panel. As you work in Full Screen mode, you�ll discover when you prefer 
using the toolbar and when you prefer using a HUD.

Keywords HUD
Use the Keywords HUD to create and organize keywords, and to add keywords to 
your images.

To open the Keywords HUD:
m Press W.

For more information about using the Keywords HUD, see Chapter 11, �Applying 
Keywords to Images,� on page 121.

HUDs are available for 
use in Full Screen mode 
and can make adjusting 
images easier.

Use the Keywords HUD
in Full Screen mode to

quickly add keywords to
your images.
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Adjustments HUD
Use the Adjustments HUD to remove flaws like red-eye, noise, and dust in your 
images; adjust exposure, levels, and white balance in your images; and straighten 
and crop your images.

To open the Adjustments HUD:
m Press H.

For more information, see Chapter 14, �An Overview of Image Adjustments,� on page 155.

Tools HUDs
Many of the adjustment tools have HUDs, and you can use all of them in Full Screen mode. 

To open any of the adjustment tool HUDs:
1 Show the Full Screen mode toolbar by moving your pointer to the top of the screen on 

your main display.

2 Select an adjustment tool in the toolbar.

If the tool you selected has a HUD, that HUD appears. For more information about 
using any of the adjustment tools and their HUDs, see Chapter 14, �An Overview 
of Image Adjustments,� on page 155.

Use the Adjustments
HUD in Full Screen mode

to remove flaws and
make adjustments to

your images.

The Crop HUD appears 
when you select the 
Crop tool in the toolbar.
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Using Keyboard Shortcuts in Full Screen Mode

 

Here are several useful keyboard shortcuts you can use in Full Screen mode:

 

Keyboard shortcut Function

 

Go to next image

Go to previous image

Shuttle filmstrip left

Stop shuttling left or right

Shuttle filmstrip right

Show Adjustments HUD

Show Keywords HUD

Show Red Eye HUD

Show Lift & Stamp HUD

Show Crop HUD

Show Spot & Patch HUD

J

K

L

H 

shift H

E 

O 

C 

X
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9 Stacking Images 
and Making Picks

Photographers frequently shoot a series of related photos 
with the aim of selecting one image for use. Aperture makes 
it easy to choose the best image out of a series.

This chapter covers the stack feature and how you can use it to select a pick image 
from a group of related photos, the remainder of which you do not intend to use.

An Overview of Stacks
A stack is a set of similar or related images from which one image will be selected for 
use. Aperture can automatically group such photos into stacks when you import them 
from a camera or memory card. You can also select images and create stacks manually.

A stack appears in the Browser as a group of images. The image that represents the 
stack, called the pick, is selected and displayed on the left. You can select any image in 
the stack as the pick, and it moves to the leftmost position in the stack. You can 
rearrange the order of images in a stack. For example, you might choose an alternate 
image and position it next to the pick. A Stack button appears in the upper-left corner 
of the pick image in the stack, indicating the number of images in the stack.

The Stack button
indicates the number of

images in the stack.

A stack with five images is 
shown expanded, or open.
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By default, a stack is shown expanded, with all images displayed. If you don�t want to 
see all the images in a stack, you can close the stack. For more information, see 
�Opening and Closing Stacks� on page 108.

Note:  You can work with stacks in the Browser in grid view or list view. Because it�s 
easier to work with stacks when you can see thumbnails of your images, this chapter 
describes working with stacks in grid view.

Creating Stacks Automatically
When you import your images, you can specify that Aperture create stacks automatically. 
For example, if you shoot a series of images in quick succession (such as at a sports 
event) or if you bracket images to allow for differences in lighting or exposure, you most 
likely will want to view those images together. Aperture can stack those images based 
on metadata recorded by the camera as the series of pictures is taken.

´ Image series:  With a series of images shot in quick succession, Aperture can 
determine the images in a sequence and group them in a single stack. For example, 
sports photographers shoot rapid bursts of images to capture actions. Based on 
timeline metadata�when a series of shots was taken and the interval between 
shots�Aperture can determine which images fall into a sequence and group them 
in stacks.

´ Bracketed shots:  These typically represent a series of three pictures with slightly 
different exposure settings. Advanced digital cameras often have options for shooting 
bracketed shots automatically. When Aperture detects a series of bracketed images, it 
designates the first image as the pick and includes the other images in the stack. 

This shows an example of
a series of images taken

in quick succession.
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To stack images automatically:
1 Choose Stacks > Auto-Stack (or press Command-Option-A).

2 In the Auto-Stack Images HUD, drag the slider to specify the maximum length of time 
for a series of shots.

As you drag the slider, the images in the Browser automatically stack themselves 
according to the length of time specified. For example, if you typically shoot a series of 
related images in a span of 10 seconds, set the slider to 10 seconds. 

3 Inspect the stacks to determine if the time interval should be shortened or lengthened. 

Creating Stacks Manually
After importing photos, you can quickly review the images and delete those that you 
see have technical or content flaws. You may then want to group the remaining images 
into stacks before rating them. Stacking images manually can help provide you with an 
initial organization and an overview of your shots, which you can then put through a 
more refined or discriminating rating pass later.

To create a stack manually:
1 In the Browser, select the images you want to stack.

For more information, see �Navigating Through and Selecting Images� on page 73.

2 Choose Stacks > Stack (or press Command-K).

Move the slider to indicate 
the maximum time span 
for a series of shots.

The Stack button
appears on the

current pick image.

The selected images are now 
stacked and have a dark gray 
line around them.
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Working with Stacks
After creating stacks, you can change the pick image and rearrange the order of the 
images in the stack however you wish.

Opening and Closing Stacks
You can close a stack and open it again whenever you wish. You may want to do this to 
free up space in the Browser. You can also close stacks to quickly reduce the number of 
images you must sort through when selecting images for a final photo edit. When a 
stack is closed, only the stack�s pick image appears in the Browser. 

To close a stack, do one of the following:
m Choose Stacks > Close Stack (or press Shift-K).

m Click the Stack button on the pick image. 

To open a stack, do one of the following:
m Choose Stacks > Open Stack (or press Shift-K).

m Click the Stack button again.

Selecting a Pick Image for a Stack
The pick image represents the stack. You can set the image you like best as the pick, or 
Aperture can set the pick automatically. When you select and stack images manually in 
the Browser, the leftmost image becomes the pick. You can change the pick whenever 
you wish. 

To select the pick, do one of the following:
m Select the image, then choose Stacks > Pick, or press Command-backslash (\).

m Drag the image you want into the pick (or leftmost) position in the stack. When you see 
a green bar appear, release the mouse button.

Only the pick image
is shown when the

stack is closed.
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Arranging Images in a Stack
It can sometimes be difficult to decide which image in the stack should be the pick. In 
many cases, images are so similar that more than one of them merit the pick position. 
For this reason, you may want to have alternate images available when presenting 
images to clients. The image next to the pick is the �alternate.�

You can change the order of images within a stack to help you choose the pick and an 
alternate. Moving an image to the left promotes it, and moving an image to the right 
demotes it. 

To promote an image in a stack, do one of the following:
m Select an image, then choose Stacks > Promote, or press Command�left bracket ([). 

m Drag the image over the image location you want until you see a green bar appear, 
then release the mouse button.

To demote an image in a stack, do one of the following:
m Select an image, then choose Stacks > Demote, or press Command�right bracket (]).

m Drag the image over the image location you want until you see a green bar appear, 
then release the mouse button.

Adding Images to and Removing Images from Stacks
You can add images to and remove images from stacks at any time. You can drag 
images in or out of a stack, as well as drag images from one stack to another.

To add an image to a stack:
m Drag the image into an expanded stack.

To remove an image from a stack, do one of the following:
m Select the image, then choose Stacks > Extract Item (or press Shift-Option-K).

m Drag the image out of an expanded stack.
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Splitting Stacks
You can split a stack into multiple stacks to refine the organization of your images. All 
images remain stacked, but they are now part of new stacks. The image selected as the 
splitting point becomes the pick for the new stack.

To split a stack:
1 In an expanded stack, select the image that you want as the first image in a new stack.

2 Choose Stacks > Split Stack (or press Option-K).

The new stack is marked with a white outline. The selected image becomes the pick of 
the new stack. 

Unstacking Images
At times you may decide to unstack a selection of images. When you do that, the 
images that were in the stack appear individually in the Browser.

To unstack a selection of images, do one of the following:
m Select a stack, then choose Stacks > Unstack (or press Command-Shift-K).

m After creating a stack, choose Edit > Undo.

Note:  When you make changes to a stack within an album, the same stack changes 
appear in the project that contains the album.

Select the image you 
want as the first image in 
the new stack.

The selected image becomes 
the pick in the new stack, which 
is marked by a white outline.
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Keyboard Shortcuts for Working with Stacks

 

Aperture provides the following keyboard shortcuts for efficiently working with stacks: 

 

Keyboard shortcut Function

 

Go to previous stack

Go to next stack

Open/Close stack

Open all stacks

Close all stacks

Create stack

Unstack

Split stack

Set stack pick

Promote stack item

Demote stack item

Extract item

page
upoption

page
downoption

shift K 

option '

option ;

K 

shift K

option K 

[ 

] 

shift option K





10

     113

10 Rating Images

Rating images is a quick and easy way to narrow down the 
number of images you intend to work with. It can also help 
you locate your best images later.

This chapter provides information about rating images and using ratings to sort and 
compare images.

An Overview of the Rating System
Aperture provides an easy-to-use rating system that allows you to quickly assign image 
ratings and use them to sort and review images. Rating is a simple process with 
powerful results. If you can easily identify 100 out of 500 images that aren�t going to 
work, removing these images reduces your workload by 20 percent. This can save you a 
considerable amount of time working on a project.

Aperture provides a system for rating images from Select to Reject. The easily 
decipherable image ratings appear on the images themselves as overlays. Positive 
ratings appear as stars; you can rate images from one to five stars, with five being the 
highest, or Select, rating. A negative, or Reject, rating appears as an X.

Stars indicate a 
positive rating.

Five stars indicate the
highest rating (Select).

An X indicates a negative 
rating (Reject).
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You can quickly review and rate images one after another with speed and efficiency. You 
can also select and rate multiple images at once. You can review and rate images in the 
Viewer, Browser, and Light Table, as well as in Full Screen mode. When you�ve finished 
rating the images, Aperture allows you to sort the images according to their ratings. 

Rating Images
Aperture provides a set of six possible image ratings indicated by white overlays that 
appear on the image. If no overlays are displayed on the image, the image is 
considered neutral or is not rated. You can rate a single image or apply a rating to 
several images at one time.

To rate an individual image:
1 Select an image in the Browser.

The image you selected appears in the Viewer.

2 Click the rating buttons in the control bar to assign a rating.

´ To assign the highest rating to the image:  Click the Select button.
´ To assign a rating of Reject:  Click the Reject button. 
´ To increase or decrease the image rating:  Click the Increase Rating or Decrease 

Rating button. 

Note:  As long as the image is still selected, you can change its rating.

3 To select the next image, press the Right or Left Arrow key or click the Previous Image 
or Next Image button in the control bar.

Reject button

Decrease Rating button

Select button

Increase Rating button
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To apply the same rating to multiple images at once:
1 Select the images you want to rate.

For more information, see �Navigating Through and Selecting Images� on page 73.

2 Click a rating button, or press the keyboard shortcut for a rating (see �Keyboard 
Shortcuts for Rating Images� on page 119).

Note:  If you�ve selected multiple images to rate and find that only one image receives a 
rating, check to see if the Primary Only button in the control bar is deselected. You can 
quickly select or deselect the Primary Only option by pressing S. 

Sorting Images by Rating
After you�ve rated your images, you can sort images according to a specific rating. For 
example, after an initial rating pass, you can choose to show only those images rated 
Select, with five stars. You can then closely inspect and further refine your selection or 
begin making adjustments to images.

Note:  Image files are not deleted when sorted by rating. They are only temporarily 
removed from view.

The rating you assign is displayed 
on all the selected images.
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To sort images by rating:
1 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ In the Browser, click the Query HUD button next to the search field.

2 Select the Rating checkbox.

3 Choose an option from the Rating pop-up menu.

4 Drag the Rating slider to specify a rating.

The Browser instantly displays only images that meet the specified rating criteria.

To view all images again (regardless of rating):
m Deselect the Rating checkbox in the Query HUD, or press Control�accent grave (‘). 

Query HUD button
in the Browser

Make sure this checkbox
is selected, then choose

an option from the
pop-up menu.

Set the slider to a rating.
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Comparing and Rating Images
For those really tough decisions, Aperture allows you to compare and rate a select 
image against close alternates. This is particularly useful when you are trying to choose 
an image from a small group of similarly composed images. 

For example, choosing the best image from a series of head shots can be difficult. Even 
in head shots captured within a short time span, the facial expressions of the subject 
can change ever so slightly. By comparing images side by side and rating them, you 
can more easily select among like images.

To compare and rate images:
1 Select the image that appears to be the best.

2 To set this image as the �compare� image, choose Edit > Set Compare Item 
(or press Return).

The compare image appears in the Viewer and the Browser with a yellow border. The 
next selected image appears with a white border immediately to the right of the 
compare image. If you want to view another image against the compare image, simply 
select it. The alternate image you selected appears to the right of the compare image 
in the Viewer.

3 If you have a second display and want to view each image on a different display, 
choose View > Secondary Viewer > Span.

The compare image has
a yellow border.

The alternate image has 
a white border.
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4 Rate your compare image by doing one of the following:

´ To assign the Select rating:  Press Option-backslash (\).
´ To increase the compare image�s rating:  Press Option�equal sign (=).
´ To decrease the compare image�s rating:  Press Option-hyphen (-).
´ To assign the Reject rating:  Press Option-9.
The rating appears as an overlay on the compare image.

5 Rate the alternate image by doing one of the following:

´ To assign the Select rating:  Press Command-5 or backslash (\).
´ To increase the image�s rating:  Press Command�equal sign (=) or equal sign (=).
´ To decrease the image�s rating:  Press Command-hyphen (-) or hyphen (-).
´ To assign the Reject rating:  Press Command-9 or 9.
The rating appears as an overlay on the alternate image.

6 Navigate to the next alternate by pressing the Left or Right Arrow key, or click the 
Previous Image or Next Image button in the control bar.

If you discover that the new selection is a better choice or has the best rating, you can 
make it the compare image by pressing Return or choosing Navigate > Set Compare 
Item. You can then review and compare your alternates against this image to confirm it 
as the best image.

The new alternate 
appears in the Browser 
with a white border.
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Keyboard Shortcuts for Rating Images
For quick and efficient rating, use the following keyboard shortcuts to apply ratings:

Keyboard shortcut Function

Increase rating

Decrease rating

Apply Reject

Apply one star

Apply two stars

Apply three stars

Apply four stars

Apply five stars

Increase the rating of the selected image and cancel the rating 
assigned to the previously rated image

Decrease the rating of the selected image and cancel the rating 
assigned to the previously rated image

Reject the selected image and cancel the rating assigned to the 
previously rated image

=or=

or

9or9

11 or

22 or

33 or

44 or

5 or5 or

shift =

shift -

shift 0
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Keyboard Shortcuts for Displaying Images 
with Specific Ratings
To quickly display images with a certain rating level or better, use the following 
keyboard shortcuts.

Important:  It�s possible to accidentally use a keyboard shortcut that performs a search, 
unexpectedly changing the number of images that appear in the Browser and Viewer. 
If this occurs, first open the Query HUD to determine if an unintentional search has 
been made. If so, press Control-6 to show all your images again, or press Control�grave 
accent (‘) to show all images that are unrated or better.

Keyboard shortcut Function

Show unrated images or better 

Show images rated one star or better

Show images rated two stars or better

Show images rated three stars or better

Show images rated four stars or better

Show images rated five stars (Select)

Show all

Show unrated images only

Show rejects only

control

1control

2control

3control

4control

5control

6control

7control

8control
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11 Applying Keywords to Images

Adding keywords to your images helps you organize your 
images and quickly locate specific images. 

This chapter provides information about adding keywords to images and using these 
keywords to help define and organize your images.

An Overview of Keywords
Keywords are descriptive words about the subject in the image that are added to 
image versions and saved as metadata. For example, a family portrait may include such 
keywords as portrait, family, father, mother, daughter, husband, wife, park, green grass, red 
sweater, smiling, smiles, Anderson, diffused light, client Select, and purchased. 

Once you have applied keywords to your images in Aperture, you can view keywords 
applied to your images as well as search for images by keywords. You can use the 
Query HUD to quickly locate images by their keywords. For more information, see 
Chapter 12, �Searching for and Displaying Images,� on page 139.

If you sell your images to image libraries, you can export the keywords as IPTC data. 
During export, Aperture embeds your keywords individually in the image file as IPTC-
compliant keyword fields. The more keywords you apply to your images, the more 
likely it is that your images will be located by potential customers. For more 
information, see Chapter 18, �Exporting Images,� on page 177.

Important:  If you are planning to export your keywords as IPTC data, make sure a 
keyword entry no more than 64 characters in length. Longer keyword phrases may not 
be displayed properly in other IPTC editors or operating systems.

There are several ways to apply keywords:
´ Using the Keywords HUD
´ Using keyword controls and presets in the control bar
´ Using the Lift and Stamp tools via the Lift & Stamp HUD
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Applying Keywords Using the Keywords HUD
Using the Keywords HUD to add keywords is the most versatile way to apply 
keywords to images. The Keywords HUD contains a library of predefined keywords 
that you can browse and search. You can also add your own keywords, as well as 
remove keywords. The Keywords HUD is automatically updated with any keywords 
you add. For example, when you enter a new keyword in the Metadata Inspector, that 
keyword also appears in the Keywords HUD. When you change a keyword, for 
example, by changing its spelling or capitalization, the keyword is updated on all 
images that have that keyword assigned.

The Keywords HUD is available for use in the Browser in grid and list views, in the Light 
Table, and in Full Screen mode. You can also use the Keywords HUD when working with 
book albums in the Book Layout Editor (see Chapter 20, �Creating Books,� on page 193) 
and when working with web gallery and web journal albums in the Webpage Editor 
(see Chapter 19, �Creating Web Journals and Web Galleries,� on page 183).

Controls in the Keywords HUD

´ Close button:  Click this to close the Keywords HUD.
´ Search field:  Enter text to search for keywords that match the text. Click the Reset 

button (with an X) to clear the field.
´ Keyword group:  A set of related keywords. Some are predefined in Aperture, but you 

can create new groups and add keywords to them. You can have keyword groups 
within other groups.

´ Disclosure triangle:  Click this next to a keyword group to view all keywords in the group.
´ Lock button:  Click the Lock button to prevent changes to the Keyword HUD.

Disclosure triangle

Close button

Search field

Keyword group

Lock button

Add Subordinate 
Keyword button

Keyword list

Remove Keyword button

Add Keyword button
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´ Add Keyword:  Click this button to add a keyword to the keyword library of the 
Keywords HUD.

´ Add Subordinate Keyword:  Click this button to add a subordinate keyword, such as a 
keyword within a keyword group.

´ Remove Keyword:  Click this button to remove one or more selected keywords.
´ Keyword list:  Displays all keywords in the keywords library of the Keywords HUD.

Using the Keywords HUD to Apply Keywords
The Keywords HUD lets you quickly apply keywords from its keyword library to one or 
more images.

To assign a keyword using the Keywords HUD:
1 Select an image or group of images in the Browser.

For more information, see �Navigating Through and Selecting Images� on page 73.

2 To show the Keywords HUD, do one of the following:

´ Choose Window > Show Keywords HUD (or press Shift-H).
´ Click the Keywords HUD button in the toolbar.
The Keywords HUD appears.

3 Do one of the following: 

´ Drag the keyword from the keyword list in the Keywords HUD to the Keyword 
column of the Browser (if you�re in list view).

Note:  Depending on your View Options, the Keyword column may not appear. For 
more information, see �Working with Images in List View� on page 71.

´ Drag a keyword from the keyword list in the Keywords HUD to the image or 
image thumbnail.

The keyword is applied to the currently selected image or group of images. To view 
keywords applied to images, see �Viewing Keywords Applied to Images� on page 136.

Drag a keyword from the
Keywords HUD...

...to an image.
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To apply multiple keywords using the Keywords HUD:
1 Select an image or group of images in the Browser.

For more information, see �Navigating Through and Selecting Images� on page 73.

2 To show the Keywords HUD, do one of the following:

´ Choose Window > Show Keywords HUD (or press Shift-H).
´ Click the Keywords HUD button in the toolbar.
The Keywords HUD appears.

3 In the keyword list area of the Keywords HUD, select the keywords you want to apply 
by doing one of the following:

´ Hold down the Shift key while pressing the Up or Down Arrow key to select 
several keywords.

´ Shift-click a group of adjacent keywords.
´ Command-click keywords that aren�t adjacent.
The selected keywords are highlighted in the keyword list.

4 Drag the keywords from the keyword list in the Keywords HUD to the image or 
image thumbnail.

The keywords are applied to the currently selected image or group of images.
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Browsing and Searching for Keywords
You can browse and search for specific keywords in the keyword library of the 
Keywords HUD.

To locate a keyword using the Keywords HUD:
1 To show the Keywords HUD, do one of the following:

´ Choose Window > Show Keywords HUD (or press Shift-H).
´ Click the Keywords HUD button in the toolbar.
The Keywords HUD appears.

2 Do one of the following:

´ Scroll up and down to review the keywords, and click the disclosure triangles to 
reveal the keywords in each keyword group.

´ Type the keyword you�re looking for in the Keywords HUD search field.

The keyword list updates to reveal all instances of the keyword you entered.

Click the disclosure
triangle next to a

keyword group to
display all the

keywords in it.

Enter a keyword in
the search field.
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Adding Keywords to the Keywords HUD
You can add new keywords to the keyword library of the Keywords HUD.

To add new keywords to the keyword library:
1 To show the Keywords HUD, do one of the following:

´ Choose Window > Show Keywords HUD (or press Shift-H).
´ Click the Keywords HUD button in the toolbar.
The Keywords HUD appears.

2 Click the Add Keyword button.

3 Type a name for the new keyword, then press Return.

A new, untitled
keyword appears in

the keyword list.

Click this button to
add a new keyword.

The new keyword is
added to the keyword

library and is sorted
alphabetically.
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To add keywords to a keyword group:
1 To show the Keywords HUD, do one of the following:

´ Choose Window > Show Keywords HUD (or press Shift-H).
´ Click the Keywords HUD button in the toolbar.
The Keywords HUD appears.

2 Select the keyword group to which you want to add a keyword.

3 Click the Add Subordinate Keyword button.

4 Type a name for the new keyword, then press Return.

The new keyword appears below the keyword group you selected and is sorted 
alphabetically within the group.

You can create new keyword categories, or groups. For example, if you added the 
keyword fish to your list, you might want to add angelfish, dolphin, tuna, and shark 
under the fish keyword so you can further define your images.

To create a new keyword group with keywords in it:
1 To show the Keywords HUD, do one of the following:

´ Choose Window > Show Keywords HUD (or press Shift-H).
´ Click the Keywords HUD button in the toolbar.
The Keywords HUD appears.

2 Click the Add Keyword button, then type a name for the new keyword group.

The new keyword is added to the keyword library and is sorted alphabetically. It 
appears already selected (highlighted).

3 Click the Add Subordinate Keyword button, type a name for a keyword you want to 
add within that keyword group, then press Return.

The first keyword you added now becomes a keyword group. The keyword you just 
added is the first keyword within that group.

4 Repeat step 3 until you�ve added all the keywords you want to the new keyword group.

Click this button to add
a keyword within a

keyword group.

A new, untitled keyword 
appears in this list within 
the keyword group.
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Removing Keywords from the Keywords HUD
After adding keywords to the keyword library of the Keywords HUD, you may decide not 
to use certain keywords. If so, you can easily remove them from the keyword library. 

To remove a keyword or keyword group from the keyword library:
1 In the Keywords HUD, select the keyword or keyword group you want to remove.

2 Click the Remove Keyword button.

Important:  Removing a keyword from the keyword library removes it from any images 
to which it�s already applied.

The selected keyword
is highlighted.

Click this button to 
remove a keyword.

The selected keyword 
is removed. The next 
keyword in the list is 
automatically selected.
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Applying Keywords Using Keyword Controls 
and Keyword Presets
One way to apply keywords is to use the keyword controls located in the control bar. 
You can add new keywords to images or apply preset keywords that are part of a 
keyword group.

About the Keyword Controls in the Control Bar
The keyword controls are located at the right side of the control bar and are typically 
shown by default. However, if there is not enough room on your screen (for example, if 
the Adjustments Inspector and Metadata Inspector are shown), they are hidden. 

To show the keyword controls in the control bar:
1 If necessary, to hide the Adjustments Inspector and Metadata Inspector, choose 

Window > Hide Inspectors (or press I).

2 Choose Window > Show Keyword Controls (or press Shift-D).

´ Keyword buttons:  These buttons display the keyword presets assigned to the 
keyboard shortcut combination Option and a number key (1 through 8) on the 
keyboard. Press Option and a number key on the keyboard (not the numeric keypad) 
to add the keyword preset to a selected image, or click a button. To remove all 
keywords, press Shift-Option-9.

´ Add Keyword field:  Type a new keyword in this field to add it to a selected image. 
If the Keywords HUD is locked, you are asked whether you want to unlock the 
Keywords HUD and add the keyword to the keyword library, or not add the keyword 
to the image.

´ Keyword Preset Group pop-up menu:  Use this to choose the keyword group you want 
displayed. The first eight keywords in the group appear on the keyword buttons.

Keyword Preset Group 
pop-up menu

Keyword buttons showing 
individual keywords assigned 
to the number keys 1�8.

Add Keyword field
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Adding a New Keyword to Images Using Keyword Controls
You can easily add a new keyword (one that�s not part of a keyword preset group) 
to one or more images.

To apply a new keyword using the keyword controls:
1 In the Browser, select an image or group of images.

For more information, see �Navigating Through and Selecting Images� on page 73.

2 In the control bar, type a descriptive word in the Add Keyword field, then press Return.

The keyword you entered is now applied to the image or group of images. To view 
keywords applied to images, see �Viewing Keywords Applied to Images� on page 136. 
For information about changing the keywords displayed, see the next section, 
�Choosing a Keyword Preset Group and Applying Its Keywords to Images.�

Choosing a Keyword Preset Group 
and Applying Its Keywords to Images
If you regularly apply the same keywords to your images, you can assign specific 
keywords to keyword buttons in the control bar and to the keyboard shortcut key 
combination Option and a number key (1 through 8) on your keyboard. Keywords 
assigned to keyword buttons in the control bar and keyboard shortcuts are referred to 
as keyword presets. This allows you to quickly assign appropriate keywords to an image 
simply by selecting an image and pressing a number key. You can use preassigned 
keyword preset groups, add new keywords to existing groups, or create a new keyword 
preset group with its own keywords.

Note:  Keyword presets cannot be assigned to keys in the numeric keypad. 

You can switch between sets, or groups, of keyword presets using the Keyword Preset 
Group pop-up menu.

Select the image to 
which you want to apply 
a new keyword.

Enter your keyword in 
this field, then press 
Return.
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To choose a keyword preset group and apply keywords to images:
1 Select an image or group of images in the Browser.

For more information, see �Navigating Through and Selecting Images� on page 73.

2 Show the keyword controls in the control bar.

For more information, see �About the Keyword Controls in the Control Bar� on page 129.

3 Choose a keyword preset group from the Keyword Preset Group pop-up menu.

The keyword presets in the control bar update according to the keyword preset group 
you chose.

4 Click the buttons for the keyword presets or press Option and the corresponding number 
keys (1 through 8) on your keyboard to apply keywords to the selected images. 

To remove the keyword, press Option-Shift and the corresponding number key. To 
remove all keywords, press Option-Shift-9.

For information about displaying keywords applied to images, see �Viewing Keywords 
Applied to Images� on page 136.

As you add images to the Aperture Library, you can create new keyword preset groups 
with new keyword presets.

Choose the keyword 
group you want to use.

The Keyword Preset Group 
pop-up menu displays your 
choice.

The keyword buttons now 
appear with keywords from 
the group you chose.
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To create a keyword preset group and assign keyword presets to it:
1 Create a new keyword preset group by doing the following:

a In the control bar, choose Edit Buttons from the Keyword Preset Group pop-up menu.

 

b In the Edit Button Sets window, click the Add (+) button.

An untitled preset group appears highlighted in the Name column.

c Type a name for the new keyword preset group, then press Return.

Choose Edit Buttons to add a 
new keyword preset group.

Click the Add button
to add a keyword

preset group.

A new, untitled preset
group appears in this list.
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2 In the Keywords Library column, select keywords you want to add to the new keyword 
preset group. To select a group of keywords, do one of the following:

´ Hold down the Shift key while pressing the Up or Down Arrow key to select 
several keywords.

´ Shift-click to select adjacent keywords.
´ Command-click to select keywords that aren�t adjacent.

3 Drag the selected keywords from the Keywords Library column to the Contents column. 

4 Drag the keywords into the order you want.

The first eight keywords will be assigned to the keyboard shortcut key combination of 
Option and a number key 1 through 8 on the keyboard, in order. 

5 After arranging the keywords, click OK.

The new keyword preset group appears in the Keyword Preset Group pop-up menu.

Note:  If the keyword preset group has fewer than eight keywords, the unassigned keys 
remain inactive.
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Applying Keywords Using the Lift & Stamp HUD
If you have several images that share many of the same keywords, you can use the Lift 
and Stamp tools to quickly apply either all or some of the keywords from one image to 
another image or group of images. Using the Lift and Stamp tools is one of the most 
efficient ways to quickly apply keywords to a large number of images. The Lift and 
Stamp tools have a corresponding HUD you can use in the Browser, Viewer, and Light 
Table, as well as in Full Screen mode.

To lift all the keywords from one image and stamp them on another image 
or group of images:

1 Select the Lift tool (or press O).

The Lift & Stamp HUD appears.

2 Select an image.

All image information, such as applied metadata, adjustments, and keywords, appears 
in the Lift & Stamp HUD.

3 Deselect all image information checkboxes except for Keywords.

Lift tool in the toolbar

All information for 
the selected image 
appears here.

Make sure the Keywords
checkbox is the only

one selected.

Click this button to apply 
the keywords to the 
second image or group 
of images.
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4 Click the Stamp button in the lower-right corner, then select another image or group 
of images.

The keywords from the first image are applied to the second image or group of images.

In many cases, you do not want to copy all keywords from one image and paste them 
onto another. For this reason, you can select specific keywords that apply to the image 
you want to stamp them on.

To stamp a reduced selection of keywords on an image or group of images:
1 Select the Lift tool (or press O).

The Lift & Stamp HUD appears.

2 Select an image.

All image information, such as applied metadata, adjustments, and keywords, appears 
in the Lift & Stamp HUD.

3 Deselect all image information checkboxes except for Keywords.

4 In the Lift & Stamp HUD, click the Keywords disclosure triangle to reveal the keywords 
from the selected image.

5 Remove any keywords you don�t want to stamp on an image or group of images by 
selecting each unwanted keyword in the list and pressing the Delete key.

Click the disclosure
triangle to reveal all

keywords applied to the
selected image.

Select the keywords you 
don�t want to stamp, 
then press Delete.
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6 Select the Stamp tool, then select an image or group of images to which to apply 
the keywords.

The reduced selection of keywords is applied to the selected image or group of images.

Viewing Keywords Applied to Images
You can view the keywords applied to an image version in several areas:
´ Metadata Inspector
´ Viewer overlays
´ Keywords column in the Browser in list view 

To view keywords using the Metadata Inspector:
1 If necessary, show the Metadata Inspector by doing one of the following:

´ Choose Window > Show Inspectors (or press I).
´ Choose Window > Show Metadata (or press Control-D).

2 Click the Keywords button at the bottom of the Metadata Inspector.

3 In the Browser, select an image.

Any keywords applied to the selected image appear in the Keyword summary area of 
the Metadata Inspector.

Stamp tool in the toolbar

Click the Keywords
button to display the

keywords applied to a
selected image.
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To view keywords using Viewer overlays:
1 Choose View > View Options (or press Command-J).

2 In the View Options window, select the Viewer checkbox.

3 Choose Caption & Keywords from the Set 1 pop-up menu.

4 Choose an option from the Placement pop-up menu for where you want the 
information displayed in relation to the image.

5 Click Done.

Make sure the Viewer
checkbox is selected.

Choose where you want the 
information displayed from 
this pop-up menu.

Choose Caption & Keywords 
from this pop-up menu.
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6 Press the Y key.

The Viewer information overlay appears, displaying the applied keywords over or below 
the image.

To view keywords in the Keywords column of the Browser: 
1 Choose View > View Options (or press Command-J).

The View Options window appears.

2 In the List View Columns section, make sure the Set 1 button is selected and that List-
Expanded is chosen from the Set 1 pop-up menu, then click Done.

3 If the Browser is not in list view, click the List View button (or press Control-L).

The Browser switches from grid view to list view. The keywords for each image appear 
in the Keywords column.

Removing Keywords from an Image
At times, you may want to remove all the keywords that you have applied to an image.

To remove all keywords from an image:
1 Select the image.

2 Press Shift-Option-9.

The captions and
keywords appear in the

area you specified.
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12 Searching for 
and Displaying Images

Aperture allows you to easily search for and gather images in 
a variety of locations. You can also perform complex searches 
as well as save your search results.

This chapter provides information about searching for images in a specific project or in 
your entire Library using the Query HUD.

An Overview of the Query HUD
As you import more and more photos into Aperture, you�ll need a way to search for 
images and display them. You can do this using the Query HUD, an easy-to-use panel 
that lets you enter specific search criteria. You can search by text, rating, keyword, date, 
IPTC information, EXIF information, export session, other metadata, file status, or a 
combination of any of the above. You can locate images across all your projects or 
search in specific projects. You can also create Smart Albums, which represent a 
gathering of images based on search criteria. For more information, see Chapter 13, 
�Grouping Images with Smart Albums,� on page 151.

The most common reason to perform a search is to display a selection of images within 
a project. As you work with a project, you may want to isolate certain images to work 
with them in some way, perhaps by adjusting them or adding keywords. By selecting a 
project folder and using the Query HUD, you can quickly display specific images, hiding 
the rest from view. 

For example, you might isolate and display only those images of a certain subject, pose, 
rating, or location. Your search doesn�t change the contents of the project; it only 
temporarily changes the images you can view. If you cancel the criteria in the Query 
HUD, all of your images appear in the Browser again.
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To open the Query HUD, do one of the following:
m Choose Edit > Find (or press Command-F).

m Click the Query HUD button (with a magnifying glass icon) beside the search field in 
the Browser. 

Controls in the Query HUD

´ Close button:  Click this to close the Query HUD.
´ Match pop-up menu:  Choose whether the image should match any of the search 

criteria or all the criteria.
´ Search field:  Enter the text you want to search for. Choose whether you want a full 

text search or a limited text search from the search field pop-up menu (with a 
magnifying glass icon). You can have Aperture search for your entered text 
throughout all the metadata associated with your images, or perform a limited text 
search that doesn�t search through your images� EXIF information. Click the search 
field�s Reset button (with an X) to clear the search field.

´ Add Filter pop-up menu:  Click this to add additional search criteria, such as date, EXIF 
and IPTC information, text, rating, and other metadata.

´ Search criteria:  Select checkboxes for categories and enter data for what you want to 
search for, such as ratings, keywords, and dates.

´ New Smart Album:  Creates a new Smart Album based on the search criteria. For more 
information, see Chapter 13, �Grouping Images with Smart Albums,� on page 151.

´ New Album With Current Images:  Creates a new album with images that match the 
current search criteria.

´ Query HUD Action pop-up menu:  Lets you create a new Light Table, book, web 
gallery, Smart Web Gallery, or web journal album with images that match the 
current search criteria.

Close button

Match pop-up menu

Add Filter pop-up menu

Search field

Search criteria

New Smart Album
button

New Album With 
Current Images button

Query HUD Action 
pop-up menu

Reset button
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Searching by Image Name, Caption, or Other Text
You can search for images using any text that you�ve associated with an image. For 
example, you might search for images based on text in an image�s caption or keywords, 
or in any other text entry. You can also search by multiple text entries.

To search for images by text:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, enter the text you want to search for in the search field.

4 Choose �any� from the Match pop-up menu, if it�s not already chosen.

The images that match the search criteria are immediately displayed in the Browser. To 
save your search results, see �Saving Your Search Results� on page 150.

To search for a list of images by multiple text entries:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, add as many text fields as you need by choosing Text from the Add 
Filter pop-up menu multiple times.

Enter the text you want 
to search for in this field.
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4 Select the Text checkboxes and enter text in each field to locate the images you want.

5 Choose �any� from the Match pop-up menu, if it�s not already chosen.

The images that match the search criteria are immediately displayed in the Browser. To 
save your search results, see �Saving Your Search Results� on page 150.

Searching by Rating
You can use the Query HUD to see all images with a certain rating. For example, you 
can search for all the images in a project that have a rating of 4. You can show images 
with a specific rating, images rated at or below a specific rating, or images rated at or 
above a rating.

To search for images by rating:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, select the Rating checkbox.

4 From the Rating pop-up menu, choose whether you want to search for images with a 
rating that is equal to, greater than or equal to, or less than or equal to the specified rating.

Select the Text
checkboxes and enter

text in each text search
field you added.

Select the Rating
checkbox.

Specify the rating level 
you want using this slider.

Choose an option from
the Rating pop-up menu.
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5 Specify the rating level by dragging the slider.

6 Choose �any� from the Match pop-up menu, if it�s not already chosen.

The images that match the search criteria are immediately displayed in the Browser. To 
save your search results, see �Saving Your Search Results� on page 150.

Searching by Keyword
You can search for and locate images by any of the keywords that you�ve assigned to 
them. You can select one or more keywords to search for. You can also specify which 
keywords an image must have to qualify as a match. For example, you can choose to 
search for images that have both silhouette and landscape as keywords, or images that 
have either silhouette or landscape as keywords.

To search for images by keyword:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, select the Keywords checkbox.

Note:  The Keywords checkbox is dimmed if no keywords have been applied to the 
images in the selected project or album.

4 Choose an option from the Keywords pop-up menu:

´ To display images that have any of the selected keywords:  Choose �contain one or more 
of the following.�

´ To see only those images that have all the keywords you selected:  Choose �contain all of 
the following.�

5 Select the checkboxes next to the keywords you want to search for.

6 Choose �any� from the Match pop-up menu, if it�s not already chosen.

Select the Keywords
checkbox. Choose an option from the 

Keywords pop-up menu.
Select the checkbox next

to each keyword you
want to search for.
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You can also search for IPTC keywords using the IPTC search options. These options 
allow you to specify searches for specific IPTC fields in a variety of ways. For example, 
you can search for any images that don�t have keywords assigned. For more 
information, see the Aperture User Manual in the Aperture Help menu.

The images that match the search criteria are immediately displayed in the Browser. To 
save your search results, see �Saving Your Search Results� on page 150.

Searching by Date
You can search for and locate images by the date they were taken. For example, you 
might locate any images taken during a trip between May 16, 2005 and May 20, 2005. 
To search for images by date, you use the Calendar search options. When the calendar 
appears, any dates that appear in bold represent dates on which new photos were taken 
as registered in the EXIF data. You can select a date or several dates in the calendar to 
search for images taken on those dates. You can also specify a range of dates. 

To search for images by date:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, select the Calendar checkbox.

4 Select the date or dates you want to search by. 

Shift-click to select a range of continuous dates; Command-click to select multiple 
noncontinuous dates.

5 Choose �any� from the Match pop-up menu, if it�s not already chosen.

The images that match the search criteria are immediately displayed in the Browser. To 
save your search results, see �Saving Your Search Results� on page 150.

Select the Calendar
checkbox.

Select the dates you
want to search by.



Chapter 12    Searching for and Displaying Images 145

 

Images that you import from sources other than cameras and card readers, such as 
JPEG or TIFF files, may not have EXIF information associated with them. However, they 
typically have a creation date assigned to the file. You can use this creation date to 
locate images using the Date search options.

To search for images by creation date:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, choose Date from the Add Filter pop-up menu.

4 Select the Date checkbox, then choose a date option from the Date pop-up menu.

5 Choose an option from the middle pop-up menu to qualify your search.

6 Enter the date you want the search based upon.

 

7 Choose �any� from the Match pop-up menu, if it�s not already chosen.

The images that match the search criteria are immediately displayed in the Browser. 
To save your search results, see �Saving Your Search Results� on page 150.

Select the Date
checkbox.

Choose a date option from 
the Date pop-up menu.

Enter a date here.

Choose how you want to 
qualify your search from 
this pop-up menu.
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Searching by IPTC Information
You can search for and locate images using any IPTC information that you�ve assigned. 
For example, you might locate any images that have IPTC keywords assigned to them. 
To search for images by IPTC information, you use the IPTC search options.

To search for images by IPTC information:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, choose IPTC from the Add Filter pop-up menu.

4 Select the IPTC checkbox, then choose the IPTC field you want to search by from the 
IPTC pop-up menu.

5 Choose an option from the middle pop-up menu to qualify your search.

6 Enter an IPTC value you want to search by in the IPTC text box.

7 Choose �any� from the Match pop-up menu, if it�s not already chosen.

The images that match the search criteria are immediately displayed in the Browser. To 
save your search results, see �Saving Your Search Results� on page 150.

Choose an IPTC field 
to search by.

Select the IPTC checkbox.

Choose how you want to 
qualify your search from 
this pop-up menu.

Enter an IPTC value here.
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Searching by EXIF Information
You can search for and locate images using any EXIF information recorded by your 
camera for your images. For example, you might locate any images that were created 
with a certain camera or at a specific exposure. To search for images by EXIF 
information, you use the EXIF search options.

To search for images by EXIF information:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, choose EXIF from the Add Filter pop-up menu.

4 Select the EXIF checkbox, then choose an EXIF field you want to search by from the 
EXIF pop-up menu.

5 Choose an option from the middle pop-up menu to qualify your search.

6 Enter the EXIF value you want to search by in the EXIF text box.

7 Choose �any� from the Match pop-up menu, if it�s not already chosen.

The images that match the search criteria are immediately displayed in the Browser. 
To save your search results, see �Saving Your Search Results� on page 150.

Choose an EXIF field 
to search by.

Select the EXIF checkbox.

Choose how you want to 
qualify your search from 
this pop-up menu.

Enter an EXIF value here.
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Searching by File Status
You can also search for images using their file status. For example, you can search for 
images that are referenced images, managed images, and online or offline images.

To search for images by file status, you use the File Status search options.

To search for images by file status:
1 In the Projects panel, select a project or an album you want to search.

2 Show the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button beside the search field in the Browser. 

3 In the Query HUD, choose File Status from the Add Filter pop-up menu, and select the 
�File status� checkbox. 

4 Deselect any checkboxes that aren�t part of your query, and choose the search criteria 
from the File Status pop-up menu.

5 Choose �any� from the Match pop-up menu, if it�s not already chosen.

Select the �File status�
checkbox.

Choose the file status you 
want to search for.
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Searching by a Combination of Criteria
You can create complex combinations of search criteria in the Query HUD. For 
example, you could search for images that have a certain keyword, and that were 
taken on a specific date.

To perform a complex search by adding search criteria options to the Query HUD:
1 In the Projects panel, select a project or an album you want to search.

2 Open the Query HUD by doing one of the following:

´ Choose Edit > Find (or press Command-F).
´ Click the Query HUD button (with a magnifying glass icon) beside the search field in 

the Browser. 

3 In the Query HUD, choose the search criteria you want to add from the Add Filter 
pop-up menu. 

4 Select the checkboxes beside the criteria you want to use and specify the search criteria.

5 Do one of the following:

´ To specify that an image must match at least one of the criteria or keywords:  Choose 
�any� from the Match pop-up menu.

´ To specify that an image must match all the criteria and keywords:  Choose �all� from the 
Match pop-up menu.

The images that match the search criteria are immediately displayed in the Browser. 
To save your search results, see the next section, �Saving Your Search Results.�

Specify your search 
criteria.

Select the checkboxes
for the items you want

to search by.
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Saving Your Search Results
When you do a search using the Query HUD, you can choose to save your results in 
several ways. You can create a new Smart Album that is automatically updated based 
on any new images you add to a project or the Library that match the search criteria. 
You can also save the search results themselves into a new album, Light Table album, 
book album, web gallery album, Smart Web Gallery Album, or web journal album. For 
more information, see Chapter 13, �Grouping Images with Smart Albums,� on page 151.

To create a Smart Album based on the search criteria:
1 Use the Query HUD to search for images based on specified criteria.

2 In the Query HUD, click New Smart Album.

A new, untitled Smart Album appears in the Projects panel. 

3 Enter the name you want for the Smart Album, then press Return.

When you add images to a project or the Library that match the search criteria, they 
are automatically added to the Smart Album.

To save your search results in an album:
1 Use the Query HUD to search for images based on specified criteria.

2 In the Query HUD, do one of the following:

´ To create a new album:  Click New Album With Current Images, enter the name you 
want for the album, then press Return.

´ To create a new Light Table, book, web gallery, Smart Web Gallery, or web journal 
album:  Choose the appropriate option from the Query HUD Action pop-up menu, 
enter the name you want for the album, then press Return.

All images that match the search criteria are placed in the new album you created.
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13 Grouping Images 
with Smart Albums

When you need to group certain types of images, either 
temporarily or permanently, you can use a Smart Album to 
gather the images. 

This chapter discusses Smart Albums and how you can use them to help dynamically 
organize your images.

An Overview of Smart Albums
Smart Albums provide you with a flexible way to organize images. They are easy to set 
up and can be extremely useful as dynamic collections of images. Unlike a standard 
album into which you manually place images, a Smart Album�s contents are controlled 
by the criteria you specify in the Query HUD associated with the album. When you 
change a Smart Album�s search criteria, the contents of the Smart Album change.

Aperture comes with a selection of predefined Smart Albums set up in the Library for 
you. For example, there are Smart Albums that gather all your select images, all images 
taken in the last week, and all images taken in the last month. When you click the 
Library disclosure triangle, you see the list of Smart Albums created for you. Select a 
Smart Album to see its contents in the Browser.

Disclosure triangle

A Library Smart Album
has this icon.
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You can also create your own Smart Albums. For example, suppose you want to create 
a Smart Album that includes the best images you took of a particular sports event. You 
select the project containing shots of the sports event, create a Smart Album, open the 
Query HUD, and search for images rated Select (five stars). All images with that rating 
immediately appear in the Smart Album. You can also choose where to search for 
images�across the entire Library or within a specific project. If you later open the 
Query HUD and change the criteria to include more images, the Smart Album is 
updated accordingly.

Collecting Images in a New Smart Album
You can collect images based on any of the information you can search for using the 
Query HUD. For example, you can create a Smart Album that gathers images based on 
a specific keyword or a combination of keywords, ratings, dates, or other metadata. You 
can narrow or broaden the Smart Album search criteria in the Query HUD at any time. 

To create a Smart Album that searches across your entire Library:
1 Select Library in the Projects panel.

2 Do one of the following:

´ Choose File > New Smart > Album (or press Command-Shift-L).
´ Choose New Smart Album from the Add to Library pop-up menu in the Projects panel. 
´ Click the New Smart Album button in the toolbar.
A new, untitled Smart Album appears in the Projects panel.

3 Rename the Smart Album by entering the name you want.

Query HUD button
Enter a new name for the

Smart Album.
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4 Click the Query HUD button (with a magnifying glass icon) to the right of the Smart 
Album to open the Query HUD.

5 In the Query HUD, specify the search criteria you want.

For more information about using the Query HUD and specifying search criteria, see 
Chapter 12, �Searching for and Displaying Images,� on page 139.

6 Click the Query HUD�s close button.

Aperture finds the images matching the specified search criteria and displays them in 
the Browser. You can now work with these versions of your images in the same way 
you work with images in any project or album.

To create a Smart Album that searches only within one project:
1 Select the project in the Projects panel.

2 Do one of the following:

´ Choose File > New Smart > Album (or press Command-Shift-L).
´ Choose New Smart Album from the Add to Library pop-up menu in the Projects panel. 
´ Click the New Smart Album button in the toolbar.
A new, untitled Smart Album appears within the project.

3 Rename the Smart Album by entering the name you want.

4 Click the Query HUD button to the right of the Smart Album to open the Query HUD.

5 In the Query HUD, specify the search criteria you want.

For more information about using the Query HUD and specifying search criteria, see 
Chapter 12, �Searching for and Displaying Images,� on page 139.

6 Click the Query HUD�s close button.
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Revising the Contents of a Smart Album
You cannot manually select individual images in a Smart Album and delete them, 
because the images are placed there automatically based on search criteria. Similarly, 
you cannot simply drag images to a Smart Album to add them. You must change the 
search criteria to change the contents of the Smart Album.

If you decide that certain images should not be in a Smart Album, you can narrow the 
search criteria to exclude images. Aperture performs a new search and revises the 
Smart Album�s contents.

To change the contents of a Smart Album by changing the search criteria:
1 In the Projects panel, click the Query HUD button to the right of the Smart Album to 

open the Query HUD.

2 Revise the search criteria in the Query HUD to eliminate or add the images you want, or 
change the keyword or rating for the image itself.

3 Click the Query HUD�s close button.

Deleting a Smart Album
You can delete a Smart Album at any time. If you�ve transferred images from a Smart 
Album to another album, the images in the other album are not deleted when you 
delete the Smart Album.

To delete a Smart Album:
1 Select the Smart Album in the Projects panel.

2 Choose File > Delete Smart Album.
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14 An Overview 
of Image Adjustments

In most cases, the adjustment controls provide everything 
you need to perfect your image. You can make image 
adjustments using the Adjustments Inspector or the 
Adjustments HUD.

This chapter provides a brief introduction to the Aperture adjustment controls. For 
in-depth explanations of Aperture adjustments, see Performing Image Adjustments in 
the Aperture Help menu. 

An Overview of Adjustments in Aperture
Adjustment controls are found in the Adjustments Inspector and the Adjustments HUD. 
The controls are the same in each. The Adjustments Inspector is shown on the right 
side of the screen. The Adjustments HUD is a floating version of the Adjustments 
Inspector that can be placed anywhere onscreen, allowing you the most flexibility in 
how you use your screen workspace.
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You can make the following adjustments to images in Aperture.

Displaying the Adjustment Controls
You can quickly display the Adjustments Inspector and the Adjustments HUD.

To view the Adjustments Inspector, do one of the following:
m Choose Window > Show Inspectors (or press I) to show the Inspectors panel.

m Choose Window > Show Adjustments (or press Control-A).

To view the Adjustments HUD, do one of the following:
m Choose Window > Show Adjustments HUD (or press H).

m Click the Adjustments HUD button in the Toolbar.

Adjustment Function

Red Eye Correction Reduces red-eye in the eyes of the subjects in your images. Used in 
conjunction with the Red Eye tool.

Spot & Patch Retouches imperfections in an image, such as sensor dust and dirt. 
Used in conjunction with the Spot & Patch tool.

Straighten Levels the image�s horizon. Used in conjunction with the 
Straighten tool.

Crop Trims the image. Used in conjunction with the Crop tool.

Levels Selectively adjusts the tonal range of an image.

Exposure Adjusts black, gray, and white tints, exposure, saturation, contrast, 
and brightness.

Highlights & Shadows Selectively adjusts the exposure in the shadows and highlights of 
an image.

Color Adjusts the color of an image.

White Balance Sets an image�s white balance by adjusting its color temperature 
and tint.

Monochrome Mixer Selectively controls the source red, green, and blue color channels 
when a color image is converted to grayscale.

Sepia Tone Changes a color image to sepia. Allows you to desaturate the color 
image to the level of sepia coloring you want.

Noise Reduction Reduces digital noise in an image.

Edge Sharpen Sharpens the image.
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Displaying Additional Adjustment Controls
The first time you view either the Adjustments Inspector or the Adjustments HUD, 
some of the adjustments, such as Exposure, Levels, and White Balance, are visible. You 
can add other adjustments to the inspector or HUD.

To add additional adjustments:
m Choose a type of adjustment from the Add Adjustments pop-up menu at the top of 

either the Adjustments Inspector or Adjustments HUD.

The new adjustment appears highlighted in both the Adjustments Inspector and the 
Adjustments HUD, if both are shown.

To see the controls for a particular adjustment, click the disclosure triangle beside the 
adjustment name. You can then make changes using the controls and see the selected 
image update to show the changes.

Feel free to explore the adjustment controls. For in-depth explanations about how to 
make adjustments, see Performing Image Adjustments in the Aperture Help menu.

Adjustment Action
pop-up menu

Add Adjustments
pop-up menu
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15 Creating Slideshow Presentations

Slideshows can do more than showcase your work. You can 
use slideshows to create atmosphere during a presentation, 
inspire participation from your audience, and evoke feeling 
in your viewers. 

This chapter reviews how to create slideshows and use them to present work to clients, 
display wedding or other event images, or provide a background of images and music 
during an event. 

An Overview of Slideshows
An Aperture slideshow provides everything you need to create a great visual display for 
your event. You can display your images across two displays, arrange your images in 
custom configurations, and create presentations with high-quality audio. You can 
choose how many images to display at once, how those images are arranged, and how 
long each image is displayed. You can also advance your images manually or set them 
to advance automatically.

Important:  To display slideshows at the best quality, you should set Aperture to create 
high-resolution previews. You can also display slideshows with good quality images 
without creating high-resolution previews. For more information about creating 
high-resolution previews, see the Aperture User Manual in the Aperture Help menu.
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Creating a Slideshow Using Presets
You can easily set up your slideshow by choosing one of the predefined slideshow 
settings provided by Aperture.

To create and play a slideshow:
1 Select a set of images by doing one of the following:

´ Select a project or album in the Projects panel.
´ Select individual images or image stacks in the Browser.

2 Choose File > Slideshow (or press Shift-S).

The Run Slideshow dialog appears.

3 Choose a type of slideshow presentation from the Slideshow Preset pop-up menu.

The slideshow presets include:

´ Dissolve:  Displays each image for 3 seconds, with a 2-second cross fade.
´ Fade through Black:  Displays each image on a black background for 3 seconds, with a 

2-second cross fade.
´ Manual:  You control this slideshow�s progression with the Right and Left Arrow keys.
´ Slow Dissolve:  Displays each image for 5.1 seconds, with a 5-second cross fade.
´ 4-Up Slow:  Successively displays four images one at a time, showing each image for 

3 seconds and then transitioning with a 2-second cross fade. The first image is 
replaced with the fifth, and so on.

´ 4-Up Fast:  Successively displays four images one at a time, showing each image for 
1 second. The first image is replaced with the fifth, and so on.

4 Click Start.

The slideshow presentation begins and plays until the last image is displayed.

Note:  If either no image or a single image is selected, the slideshow displays all images 
in the current album or project.
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Controlling a Slideshow
Once you start playing a slideshow, you can use keyboard shortcuts to control 
the slideshow.

To pause the slideshow:
m Press the Space bar.

To continue playing the slideshow:
m Press the Space bar again.

To move forward through the slideshow:
m Press the Right Arrow key.

To move backward through the slideshow:
m Press the Left Arrow key.

To stop the slideshow:
m Press Esc (Escape). The slideshow stops playing, and your Aperture workspace reappears.

Changing a Slideshow�s Images
You can change the order of your images, add new images to your slideshow, or 
remove images from your slideshow. 

Note:  A slideshow must be stopped before you can change its images. 

To reorder your slideshow�s images or add or remove images:
m Before creating the slideshow, arrange the image thumbnails in the Browser in the 

order that you want them to appear in the slideshow.

You can then play your slideshow by following the instructions in the previous section, 
�Controlling a Slideshow.� 
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16 Using the Light Table

You can use the Light Table to arrange and resize images 
in a freeform manner. 

This chapter provides information about the Light Table and how you can use it to 
review images as well as make adjustments to them.

An Overview of the Light Table
The Light Table in Aperture allows you to work with your images in much the same 
way you work with slides on a light table. You can place a selection of images in the 
Light Table for review and drag them to new positions. For example, you can arrange 
images in different combinations to see how they might look on web or book pages. 

An arrangement
of images in the

Light Table
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In the Light Table, you can easily group related images together to compare them after 
applying adjustments. You can also use the Light Table to resize images to the 
approximate sizes you�d like to see for your final output. For example, if you�re involved 
in planning images for book pages, you might create an interesting series of images in 
the sizes needed for the book page.

Creating a Light Table Album and Adding Images to It
You can create a new, empty Light Table album and drag or import images into it. 
You can also select images in a project and create a Light Table album to hold them.

To create a new, empty Light Table album:
1 In the Projects panel, select Library or the project where you want the new Light Table 

album to appear.

2 Choose New Empty Light Table from the Add to Library pop-up menu in the 
Projects panel.

A new, untitled Light Table album appears.

3 Enter a new name for the Light Table album.

You can now drag images from the Browser into the Light Table album or import 
images into it.

To create a Light Table album that holds a selection of images:
1 In the Browser, select the images you want in the Light Table album.

For more information, see �Navigating Through and Selecting Images� on page 73.

2 In the Projects panel, choose New Light Table From Selection from the Add to Library 
pop-up menu.

A new, untitled Light Table album appears with the selected images in it.

3 Enter a new name for the Light Table album.
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Adding Images to the Light Table
Adding images to the Light Table is easy; simply drag an image or a selection of images 
from the Browser to the Light Table.

To add images to the Light Table:
m Drag images from the Browser to the Light Table.

To remove an image from the Light Table:
m Select the image, then click the Put Back button.

The image disappears from the Light Table but remains available in the Browser.

If you have many images in a Light Table album, it may be difficult to remember which 
images you haven�t placed in the Light Table.

...to the Light Table.

Simply drag images from
the Browser...

Click the Put Back
button to remove a

selected image.
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To see only images in the Browser that remain unplaced:
m Click the Show Unplaced Images button.

To see the entire contents of the Light Table album in the Browser:
m Click the Show All Images button.

Moving and Resizing Images in the Light Table
You can drag images to different locations in the Light Table, trying out different 
combinations and orientations. For example, you might take a group of related images 
and arrange them to see how they�d appear on a print page. You can also enlarge or 
reduce images. After resizing an image, you can quickly reset the image back to its 
original size.

To move images in the Light Table:
m In the Light Table, select the images you want to move and drag them to a new location.

To drag an image to a location offscreen:
m Drag the image to the border of the Light Table until the screen begins to scroll. 

To change an image�s size:
1 Select the image in the Light Table.

2 Position the pointer over the image, then drag a resize handle to change the image�s size.

Show All Images button

Show Unplaced 
Images button

Move the pointer over 
the image to show resize 
handles, then drag to 
change the image�s size.
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To reset an image to its previous size, do one of the following:
m Choose Edit > Undo Resize (or press Command-Z).

m Control-click the image, then choose Reset Selected Size from the shortcut menu.

Aligning and Arranging Images in the Light Table
You can select a group of images in the Light Table and automatically align them 
according to their top, bottom, or side edges, or by their centers. You can also have 
Aperture arrange a selected group with equal space between each image.

To align selected images:
1 In the Light Table, select the images you want to align.

2 Control-click one of the images, choose Align from the shortcut menu, then choose the 
type of alignment you want from the submenu. 

 

You can also automatically group a selection of images. Aperture gathers the images 
and places them together for easy arrangement. If you wish, you can also reveal, or 
uncover, all images in a group.

To group images in the Light Table:
1 In the Light Table, select the images you want to group.

2 Control-click the selection, then choose Arrange from the shortcut menu.

The selected images are aligned according 
to the option you selected.

Choose Align from the shortcut menu, then 
choose an option from the submenu.
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To reveal images in the Light Table that are covered by other images:
1 Select the top image in the group. 

2 Click the Uncover button (or press Shift-X).

3 Select an uncovered image.

The images are regrouped, with the selected image on top.

The top image is
selected.

Click the Uncover button 
to reveal all images under 
the selected image.
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Adjusting the Light Table View
You can adjust the Light Table view to better view and work with images. This is 
particularly useful when the Light Table is larger than your screen size. You can also 
increase the area of the Light Table. 

To zoom in or out of the Light Table, do one of the following:
m Drag the Light Table Zoom slider to change the view. 

To fit the Light Table to your screen size, do one of the following:
m Click the Scale to Fit All Items button.

To change the Light Table view to 100 percent:
m Control-click in a blank portion of the Light Table, then choose Zoom to 100% from the 

shortcut menu.

To increase the area of the Light Table:
m Drag an image to the border of the grid background so that the area of the Light Table 

automatically expands.

 

Drag the Light Table Zoom 
slider to zoom in or out.

Scale to Fit All Items button

Drag an image to a 
border of the Light 
Table to expand the 
Light Table area.
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Printing a Light Table Arrangement
After arranging your images, you can print out the image arrangement for further review.

To print a Light Table arrangement:
1 Select the images in the Light Table that you want to print by dragging a selection 

rectangle around them.

2 Choose File > Print Light Table (or choose Command-Option-P).

3 In the Print dialog, choose your print options, then click Print.

For more information, see Chapter 17, �Printing Your Images,� on page 171.

Drag a selection
rectangle around the

images you want to print.
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17 Printing Your Images

Aperture makes it easy to print high-resolution images, a 
series of contact sheets, a portion of the Light Table, a web 
gallery or journal, or an entire photo book.

This chapter covers many options you have for printing images.

Settings in the Print Dialog
Using options in the Print dialog, you can print a single high-resolution print, a series of 
contact sheets, or your latest travelogue book.

To open the Print dialog:
m Select an image in the Browser, then choose File > Print Image (or press Command-P).

Copies & Pages area

Printer Selection area

Layout Options area

Border Options area

Preset Name list Preview area
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The Print dialog is divided into six areas:

Preset Name List
This column contains all presets, those that come with Aperture as well as new ones 
that you create.
´ Single Images:  Displays settings for printing a single image per page.
´ Contact Sheet:  Displays settings for printing a series of images on one or more pages.

Copies & Pages
´ Copies:  Displays the number of copies of the image to print.
´ Pages:  Prints the entire selection of images or a reduced set.

Printer Selection
´ Printer:  Displays the printer that will print the images.
´ Printer Settings:  Click this button to choose a printer and adjust its settings.
´ Paper Size:  Choose a paper size from the list of available sizes.
´ Orientation:  Choose landscape or portrait orientation, or Best Fit.
´ ColorSync Profile:  Choose a printer profile to use when printing. 
´ Black Point Compensation:  Select this checkbox to adjust the maximum black level of 

your image to fit within the capabilities or gamut of your selected printer.
´ Gamma:  Choose a gamma setting to adjust the brightness of the image so that it 

matches the display�s output as closely as possible.

Layout Options
´ Scale To pop-up menu:  When you select a single-image preset, you can use this 

pop-up menu to choose whether to fit your image to the selected paper size, print a 
specific image size, or print a custom image size. Fit Entire Image scales the image to 
be as large as possible for the paper size without cropping the image. Fill Entire Page 
makes the image fit the entire page, cropping the image if necessary. Custom allows 
you to specify the image dimensions you�d like. 

´ �Number of pages� and �Number of columns and rows� buttons:  When you select a 
contact sheet preset, select one of these options to specify the number of pages that 
you want the printed images to occupy, or the number of rows and columns of 
images on the page.

´ Metadata pop-up menu:   When you select a contact sheet preset, choose a metadata 
view to specify the metadata you want printed with your images.

´ Font Size pop-up menu:  When you select a contact sheet preset, choose the font size 
of the metadata that will be printed.

´ Print Resolution:   Type the dot-per-inch (dpi) resolution at which you want to print 
your image in the DPI field. You can also select the Use Best DPI checkbox to allow 
Aperture to calculate the best print resolution for the images for the selected printer.
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Border Options
´ Width:  Drag the slider, or enter a value in the value slider, to reduce the size of the 

image in order to create a white border around the image.
´ Show crop marks:  Select this checkbox to print a cut line.

Preview Area
This area shows how the image or images will print on the selected paper size. If there 
is more than one page, you can use the Previous Image and Next Image buttons to 
navigate through the pages.

Printing Single Images
When you want to print a single image on a single sheet of paper, you use a Single 
Images preset.

To print a single image:
1 In the Browser, select an image.

2 Choose File > Print Image (or press Command-P).

3 In the Print dialog, select a Single Images preset in the Preset Name list. 

4 After you�ve verified that all the settings in the Print dialog are correct, click Print.

Printing a Series of Images
You can print multiple images at once, each on its own sheet of paper.

To print a series of images:
1 In the Browser, select the images you want to print.

For more information, see �Navigating Through and Selecting Images� on page 73.

2 Choose File > Print Images (or press Command-P).

3 In the Print dialog, select a Single Images preset in the Preset Name list. 

4 After you�ve verified that all the settings in the Print dialog are correct, click Print.

Your images are printed, one image per page.
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Printing a Contact Sheet or Series of Contact Sheets
You can print contact sheets of your images, and Aperture does all the layout work for 
you. All you have to do is select the number of pages or columns; Aperture adjusts the 
size of the images based on your Layout Options settings.

To print contact sheets:
1 In the Browser, select the images you want to print.

2 Choose File > Print Images (or press Command-P).

3 In the Print dialog, specify the following settings:

´ Select a Contact Sheet preset in the Preset Name list.
´ Make sure the settings in the Printer Selection area are correct, such as Paper Size 

and ColorSync Profile.
´ In the Layout Options area, specify the number of pages or the number of columns 

as a basis for laying out the contact sheets.
Aperture automatically adjusts the size of images based on your Layout Options 
settings. The size of the images on the contact sheet is based on whether or not you 
choose to constrain the images within a specific number of pages. The fewer pages 
selected, the smaller the images. Similarly, if you choose columns, the more columns 
selected, the smaller the images.

´ Verify the layout of your contact sheet in the preview area.
´ For printers incapable of printing full bleeds, select the �Show crop marks� checkbox 

in the Border Options area.

4 After you�ve verified that all the settings in the Print dialog are correct, click Print.

Your contact sheet is printed. 
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Printing a Book
You can print a book to check the final format and look of it before having it printed by 
a professional printer, ordering a print book online, or distributing copies to others.

To print a book:
1 Select a book album in the Projects panel.

The book appears in the Book Layout Editor.

2 Make sure the book settings are correct, then click the Print button in the Book 
Layout Editor.

For information about the Book Layout Editor, see Chapter 20, �Creating Books,� on 
page 193.

3 In the Print dialog that appears, make sure the settings are correct, then click Print.

Your book is printed.

Creating a PDF File of a Book
You can create a PDF file of a book to store an electronic copy for use at another time 
or to send to others.

To create a PDF file of a book:
1 In the Projects panel, select a book album.

2 Choose File > Print Book (or press Command-Option-P).

3 In the Print dialog, click the Save as PDF button.

4 Enter a name for the PDF file and choose a location to save the file, then click Save.
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18 Exporting Images

Once you�ve finalized work on your images, you can use 
Aperture to export your images. You can use these files in 
another application, send them to a printing service or to 
your clients, or publish them on the web.

This chapter covers how to export your images in various sizes, formats, and file types 
for different purposes.

An Overview of Exporting Your Images
Using Aperture, you can export copies of digital master files, as well as versions that 
you�ve created. When you export versions, you can export them in JPEG, TIFF, PNG, and 
PSD file formats.

At export, you can rename files, resize and adjust images, and include metadata such 
as EXIF information, IPTC information, and keywords. You can also apply ColorSync 
profiles and watermarks to the versions you�re exporting. You can export separate 
lists of metadata for selected images as a file. You can also export digital master files 
with IPTC data stored in XMP sidecar files that can be used in other applications, such 
as Adobe Photoshop.
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Exporting Copies of Digital Master Files
When you export master files, duplicates of the files that were imported from your 
camera or other source are created; no adjustments, file modifications, or any other 
changes are exported with the file. 

To export copies of digital master files:
1 Select an image or images in the Browser.

2 Choose File > Export > Export Masters (or press Command-Shift-S).

3 Navigate to the location where you want the exported files placed.

4 Do one of the following:

´ Choose �No folder� from the Subfolder Format pop-up menu to specify that the files 
be stored as separate individual files in the selected folder. 

´ To specify that Aperture create and store your files in a hierarchy of subfolders with 
specific folder names, choose a folder preset from the Subfolder Format pop-up 
menu. For more information about specifying folders to hold your exported images, 
see the Aperture User Manual in the Aperture Help menu.

´ Enter a custom folder name in the Custom Subfolder Name field.

Choose a location for the 
exported files.

Choose a name format 
for your master files here.

Click this button 
to export files.
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5 Choose a name format for your master files from the Name Format pop-up menu.

For more information about selecting and setting up filenaming formats, see the 
Aperture User Manual in the Aperture Help menu. Aperture shows an example of the 
selected name format in the dialog.

6 To export the digital master file with an XMP sidecar file that contains the image�s IPTC 
metadata, select the �Create IPTC4XMP sidecar file� checkbox.

7 When you�re ready to export your files, click Export Masters.

Copies of the digital master files for the selected images are exported to the location 
you specified.

Exporting Image Versions
You can export image versions that you�ve created in Aperture. For example, you might 
make adjustments to images for a specific purpose and then export them for use in 
another application. You can also rename images when exporting them, make minor 
adjustments on export, add watermarks, and export images with metadata. You can 
also quickly export images to your email application to send them to others. 

When you export image versions, you can specify settings for the exported files, such 
as format, size, and filename.

To export versions of images:
1 Select an image or images in the Browser.

2 Choose File > Export > Export Versions (or press Command-Shift-E).

3 Navigate to the location where you want the exported images placed.

Choose a location for the 
exported files.

Choose an export preset 
for the exported files.

Choose a name format 
for the exported files.

Click this button to 
export the files.
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4 Choose an export preset from the Export Preset pop-up menu.

5 Do one of the following:

´ Choose �No folder� from the Subfolder Format pop-up menu to specify that the files 
be stored as separate individual files in the selected folder. 

´ To specify that Aperture create and store your files in a hierarchy of subfolders with 
specific folder names, choose a folder preset from the Subfolder Format pop-up menu.

6 Choose a name format for your files from the Name Format pop-up menu.

7 When you�re ready to export files, click Export Versions.

The dialog shows the progress of the export. The images you selected are exported to 
the location you specified.

About Export Presets
Export presets are groups of saved export settings that are configured for various 
purposes. You use them to help you quickly and easily export your images. For 
example, if you regularly send groups of photos to a stock photography house and a 
printer, you can create an export preset for each destination. Each time you need to 
export photos for the printer, you can use the preset you created specifically for that 
printer, instead of specifying those settings over and over again. Aperture comes with 
several export presets, but you can also create your own. 

Viewing the Settings for an Export Preset
Before using an export preset, whether it�s one that comes with Aperture or one that 
you created, you can view its settings to make sure they are exactly what you want.

To view the settings for an export preset:
m Choose Aperture > Presets > Image Export. 
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The Export Presets dialog appears, showing the presets available and the configurable 
export settings.

Creating an Export Preset
If none of the predefined export presets suit your needs, you can create your own 
export preset. Creating a new export preset is fairly easy, because you only have to 
copy an existing preset and then modify it. 

Important:  When you modify a duplicate of an existing preset, the original preset is not 
modified or removed.

To create a new export preset:
1 Select an image to export.

2 Choose File > Export > Export Version (or press Command-Shift-E).

3 In the dialog that appears, choose Edit from the Export Preset pop-up menu. 

The Export Presets dialog appears.

4 In the Export Preset Name list, select an export preset on which to base your new 
preset, then click the Add (+) button in the lower-left corner.

A new preset, based on the export preset you selected, appears highlighted in the 
Export Preset Name list.

5 Enter a new name for the preset, then press Return.

6 Specify the export settings you want, then click OK.

Available presets are
shown here.

The right side of the 
dialog shows the settings 
for the selected preset.
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Adding a Watermark to Exported Images
You can add an image file to your images as a watermark to discourage others from 
using your images without your permission. Watermarks are especially useful when 
applied to images posted on the web. 

To add a watermark image to your exported images:
1 Select the images you want to export.

2 Choose File > Export Versions (or press Command-Shift-E).

3 In the dialog that appears, choose Edit from the Export Preset pop-up menu. 

4 In the Export Presets dialog, select the Show Watermark checkbox.

5 Click the Choose Image button, and in the dialog that appears, navigate to the location 
of the graphic you want to use as your watermark.

6 When you�ve found the image you want to use as a watermark, click Choose.

7 Choose where you want the watermark to appear on the image from the Position 
pop-up menu.

8 If you want to adjust the opacity of the watermark, drag the Opacity slider to a 
new position.

9 When you�re satisfied with how your watermark appears in the watermark preview 
area, click OK.

10 Select a location where you want the exported images placed.

11 Click Export.

Your files are exported with the watermark you created.

Tips for Creating High-Quality Watermarks
Use the following guidelines to create high-quality watermarks for your images:
´ Save your watermark as a PSD (Photoshop) file with a transparent background.
´ Create multiple sizes of your watermark. Depending on the output size of the 

image, a properly sized watermark will appear sharper when the image is exported.
´ Once you create a watermark, save it as part of an export preset, so you can reuse it 

as often as you need.

Note:  Export presets and web export presets are independent of one another. For 
ease of use, make sure to save your watermark as part of the appropriate preset.
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19 Creating Web Journals 
and Web Galleries

In Aperture, you can easily create webpages of your images 
and post them to your .Mac account. Your clients can then 
review your work online.

This chapter reviews the two types of webpages you can produce in Aperture, and 
shows you how to create them, modify them, and then post them to the web.

An Overview of Web Galleries and Web Journals
Using Aperture, you can create two types of webpages�web journals and web 
galleries. Both are based on themes, or page designs, are easily editable, and can be 
posted to the web.
´ Web gallery:  Aperture automatically creates the appropriate number of webpages 

and populates them with the selected images. You can then adjust the pages to 
make the images appear as you want them. You can also choose the metadata 
information that appears next to each image, such as caption, name, or rating.

´ Web journal:  You manually arrange images and text on the pages. There are more 
options available with this type of webpage, allowing for more creativity.

When you open a web gallery or web journal from the Projects panel or create a new 
webpage, the Webpage Editor appears in place of the Viewer. The Webpage Editor is 
where you design your webpages, including changing the theme, or page design, 
positioning images, and adding text. 

Note:  Many of the controls are similar when working on a web gallery or web journal 
in the Webpage Editor.
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Creating and Working with Web Galleries
Web galleries offer a way to showcase your images on the web. You have a number of 
options for designing these pages. You can choose the type of information you want to 
appear with each image, such as name and rating. You can also specify the number of 
columns and rows you want on each page. 

Creating a Web Gallery
To create a web gallery, you must first create an album that holds your web gallery images. 
The easiest way to do this is to select images you want to appear in the web gallery, create 
an album, and have Aperture automatically place the images on the webpages. Aperture 
creates as many webpages as necessary to hold all of the selected images.

To create a web gallery from selected images:
1 In the Browser, select the images you want to place on your webpages.

2 In the Projects panel, choose New Web Gallery From Selection from the Add to Library 
pop-up menu.

A new, untitled web gallery album appears in the Projects panel. The Webpage Editor 
appears in place of the Viewer.

3 Rename the album.

The new album contains the selected images.

To make changes to the webpages, you use the controls in the Webpage Editor. For 
more information, see the next section, �Web Gallery Controls in the Webpage Editor.�

The Webpage Editor 
is displayed with the 
selected images.

The new album you
created appears in the

Projects panel.
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Web Gallery Controls in the Webpage Editor
The following controls are available for revising pages and images in a web gallery album.

´ Site Theme:  Click this to choose a theme, or layout, for your webpage.
´ Gallery Pages panel:  Click here to see a specific page of the web gallery.
´ Detail Images panel:  Click here to see the enlarged version of a selected image in a 

web gallery.
´ Metadata View pop-up menu:  Use this to choose the type of metadata that is 

included with each image in the webpage.
´ Columns value slider:  Use this to specify the number of columns you want on a page.
´ Rows value slider:  Use this to specify the number of rows you want on a page.
´ �Fit images within� pop-up menu:  Choose an option for how you want images to 

appear on the webpage.
´ Width value slider:  Use this to specify the column width. Click the arrows to increase 

or decrease the width, or double-click in the number field and enter a new value.
´ Height value slider:  Use this to specify the row height. Click the arrows to increase or 

decrease the height, or double-click in the number field and enter a new value.
´ Export Web Pages:  Click this button to export your webpages.
´ Publish to .Mac:  Click this button to publish your finalized webpages to your .Mac 

account. For more information, see �Posting Your Webpages to the Web� on page 191.
´ Previous Page:  Click this button to go to the previous webpage.
´ Next Page:  Click this button to go to the next webpage.

�Fit images within�
pop-up menu

Columns 
value slider

Rows 
value slider

Width value slider

Height value slider

Detail Images panel

Next Page button

Previous Page button

Gallery Pages panel

This shows how your 
images will appear on 
the web gallery page.

Export Web Pages button Publish to .Mac button

Metadata View
pop-up menu

Site Theme button
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Creating and Working with Web Journals
Web journals offer great flexibility, allowing you to manually arrange images and text 
on webpages.

Creating a Web Journal
To create a web journal, you must first create an album that holds your webpage�s 
images. The easiest way to do this is to select images you want to appear in the web 
journal and create an album. Aperture creates a web journal album that contains the 
images you selected, and the Webpage Editor appears above the Browser. The Browser 
displays the selected images, which you can then manually place on the webpages.

To create a web journal:
1 In the Browser, select the images you want to place on your webpages.

2 In the Projects panel, choose New Web Journal From Selection from the Add to Library 
pop-up menu.

A new, untitled web journal album appears in the Projects panel. The Webpage Editor 
appears in place of the Viewer.

3 Rename the album.

The selected images appear in the Browser, below the Webpage Editor. You can then 
manually add images to your web journal pages.

To make changes to the webpages, you use the controls in the Webpage Editor. For 
more information, see the next section, �Web Journal Controls in the Webpage Editor.�
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Web Journal Controls in the Webpage Editor
The following controls are available for pages and images in a web journal album.

´ Site Theme:  Click this to choose a theme, or layout, for your webpage.
´ Journal Pages panel:  Click here to see a specific page of the web journal.
´ Detail Images panel:  Click here to see the enlarged version of a selected image in a 

web gallery.
´ Add Page:  Click this to add a page to your web journal.
´ Remove Page:  Click this to remove a selected page from your web journal.
´ Page Template pop-up menu:  Use this to choose a page template, or layout.
´ Page Action pop-up menu:  Choose how to add pages to your web journal.
´ Metadata View pop-up menu:  Use this to choose the type of metadata that is 

included with each image in the webpage.
´ Add Text Box:  Click this to add a text box to the bottom of the current webpage.
´ Columns value slider:  Use this to specify the number of columns you want on a page.
´ �Fit images within� pop-up menu:  Choose an option for how you want images to 

appear on the webpage.
´ Width value slider:  Use this to specify the width of photo boxes on the page. Click the 

arrows to change the width, or double-click in the number field and enter a new value.
´ Height value slider:  Use this to specify the height of photo boxes on the page. Click the 

arrows to change the height, or double-click in the number field and enter a new value.
´ Export Web Pages:  Click this button to export your webpages.
´ Publish to .Mac:  Click this button to publish your finalized webpages to your .Mac 

account. See �Posting Your Webpages to the Web� on page 191.
´ Previous Page:  Click this button to go to the previous webpage.
´ Next Page:  Click this button to go to the next webpage.

Export Web Pages
button

Site Theme button

Metadata View
pop-up menu

Detail Images panel

Journal Pages panel

Add Page button

Page Action 
pop-up menu

Page Template 
pop-up menu

Width value slider

Height value slider

Next Page button

Previous Page button

This shows how your 
images will appear on 
the web gallery page.

�Fit images within�
pop-up menu

Columns 
value slider

Add Text Box 
button

Publish to .Mac 
button

Remove Page
button
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Working with Web Journal Pages
You can add images, text, and titles to your web journal pages, as well as add and 
remove pages.

To add images to a web journal:
1 Select the page you want to change in the Webpage Editor.

2 Select an image in the Browser, then drag it to the selected page in the Webpage Editor.

The image is added to the webpage.

To add text to web journal pages:
1 Select the page you want to change in the Webpage Editor.

2 Click the Add Text Box button to add a text box.

3 Enter your text.

To delete images or text from a web journal page:
m In the Webpage Editor, select the image or text on the webpage, then click the Remove 

button (with a minus sign) on the image or text.

To add pages to your web journal:
m In the Webpage Editor, click the Add Page (+) button.

To delete pages from your web journal:
m In the Webpage Editor, select the page you want to remove, then click the Remove 

Page (�) button.

Viewing and Navigating Your Webpages
As you modify your webpages, there are some easy ways to view and navigate through 
your pages.

To view a particular webpage:
m Use the scroll bar in the Gallery Pages panel (for a web gallery) or the Journal Pages 

panel (for a web journal) to locate the page, then click the page.

To return to the page view after viewing an enlarged image:
m Click a page in the Gallery Pages panel (for a web gallery) or the Journal Pages panel 

(for a web journal).

To see an enlarged image from a webpage, do one of the following:
m Position the pointer over the image, then click the Detail button (with an arrow).

m Click the image in the Detail Images panel.
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Changing the Appearance of Your Webpages
Aperture provides a variety of themes, or designs, you can choose for your webpages. 
The theme determines the basic design of the webpage.

To change the webpage theme:
1 At the top of the Webpage Editor, click the Site Theme button.

2 In the Choose Web Theme window, select the theme you want, then click Choose.

Your webpages now appear with the new theme.

Both types of webpages�web galleries and web journals�display thumbnail images. 
A person viewing your webpage can simply click a thumbnail to view an enlarged 
image. Once you have webpages populated with your images, you can modify the 
order and appearance of images on the webpages. 

To change the order of images:
m In the Webpage Editor, drag images to different locations.

To change the number of columns of images on the page:
m In the Webpage Editor, do one of the following:

´ Double-click the number in the Columns value slider, then enter a new number to 
increase or decrease the displayed number of columns.

´ Click the left or right arrow in the value slider.

´ Drag left or right in the value slider.

Site Theme button

Left and right arrows

Columns value slider
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To change the number of rows of images on a page in a web gallery:
m In the Webpage Editor, do one of the following:

´ Double-click the number in the Rows value slider, then enter a new number to 
increase or decrease the displayed number of rows.

´ Click the left or right arrow in the value slider.

´ Drag left or right in the value slider.

To change the size of displayed images on the webpages:
1 Choose an option from the �Fit images within� pop-up menu.

2 Increase or decrease the height of the image in pixels by doing one of the following:

´ Double-click the number in the Height value slider, then enter a new number.
´ Click the left or right arrow in the Height value slider.
´ Drag left or right in the value slider.

3 Increase or decrease the width of the image in pixels by doing one of the following:

´ Double-click the number in the Width value slider, then enter a new number.
´ Click the left or right arrow in the Width value slider.
´ Drag left or right in the value slider.

Left and right arrows

Rows value slider

Width value slider Height value slider

Choose how you want your 
images to fit on the pages 
from this pop-up menu.
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Posting Your Webpages to the Web
You can easily post your web gallery or web journal to your .Mac account.

To publish your web gallery or web journal to your .Mac account:
1 In the Webpage Editor, click Publish to .Mac. 

2 In the dialog that appears, specify the following:

´ Publish Album As:  Enter a name for the web gallery or web journal.
´ Thumbnail Image Preset pop-up menu:  Choose the quality you want for displayed 

thumbnail images.
´ Detail Image Preset pop-up menu:  Choose the quality of detail images that will appear 

when someone clicks a thumbnail.

3 When you�re ready, click Publish.

When you publish to your .Mac account, the web address of your new .Mac album 
appears in the dialog and in the web browser. 

You can select the address and press Command-C to copy the address to the Clipboard. 
You need this address to link the web gallery or journal to your .Mac homepage. 

4 Click View in Browser to see the new webpage.

The published web gallery or journal appears in your web browser.

To link your web gallery or web journal to your .Mac homepage:
1 Go to http://www.mac.com, then click the HomePage link at the top of the screen.

2 If you haven�t already done so, log in.

3 If you don�t have a menu page, create one.

4 In the Pages list, select the menu page, then click Edit.

The page category is listed to the right of the selection.

5 In the �Edit your page� section, click the Add (+) button next to an existing link to add a 
new one.

A new, empty link is created to the right of the previous link.

6 Enter a page title and brief description, then click the Edit Link button.

7 In the �Edit your links� section, click the Other Pages tab, paste the link to your web 
gallery or web journal in the Address field by pressing Command-V, then click Apply.

8 When you are ready to publish your new homepage, click the Publish button at the 
top-right corner of the screen.

http://www.mac.com
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20 Creating Books

With Aperture, you can easily create books of your images that 
you can print using a printing service provided by Apple. 

This chapter provides information about creating a book, including designing the 
pages, arranging images, and then getting a professional print copy made.

An Overview of the Book Creation Process
Aperture provides options for creating a print book to suit a variety of needs. When 
you select a book album in the Projects panel or create a new book album, the Book 
Layout Editor appears in place of the Viewer. The Book Layout Editor is where you 
design your book. 

Books are based on master page layouts and themes, or designs, that present your 
images in a standardized way. The theme you choose for your pages determines the 
basic template design of the page. You can easily add images to your book at any time. 
You can also move and resize images, as well as add text, such as narrative or captions, 
to the pages of your book. 

Place images  
on pages 

Add text to pages 

Add or remove 
pages 

• Choose theme 
• Choose size 
 

 

Create Book
• Print proof 
• Make revisions 
 

 

Proof Book
• Order book  
   via Apple 
• Create PDF 
 

Print Book



 

194 Chapter 20   

 

 Creating Books

 

 

 

Creating a Book Album

 

There are two main ways to create a book album:

Â

 

You can select a group of images and create a book album to hold the images.

Â

 

You can create a new, empty book album and then drag images from the Browser 
into the album.

 

To create a book album from a selection of images:
1

 

Select the images you want to use in the book, then do one of the following:

Â

 

Choose File > New From Selection > Book.

Â

 

In the Projects panel, choose New Book From Selection from the Add to Library 
pop-up menu.

 

2

 

In the dialog that appears, specify the following:

Â

 

Theme list:

 

  Select a theme in the list to see a preview of its design on the right.

Â

 

Book Size pop-up menu:

 

  Choose the physical size of the book.

 

3

 

When you•re ready, click Choose Theme.

A new, untitled book album appears in the Projects panel that includes the selected 
images. The Book Layout Editor appears in place of the Viewer.

 

4

 

Rename the book album.

To make changes to the book album, you use the controls in the Book Layout Editor. For 
more information, see the next section, •Controls in the Book Layout EditorŽ on page 195.

 

To create a new, empty book album:
1

 

Do one of the following:

Â

 

Choose File > New > Book.

Â

 

In the Projects panel, choose New Empty Book from the Add to Library pop-up menu.

 

2

 

In the dialog that appears, specify the following:

Â

 

Theme list:

 

  Select a theme in the list to see a preview of its design on the right.

Â

 

Book Size pop-up menu:

 

  Choose the physical size of the book.

 

3

 

When you•re ready, click Choose Theme.

A new, untitled book album appears in the Projects panel.

 

4

 

Rename the book album.

 

5

 

To add images to the empty book album, select the project that holds the images in 
the Projects panel.

The project•s images appear in the Browser.

 

6

 

Drag the images from the Browser to the book album in the Projects panel.

To make changes to the book album, you use the controls in the Book Layout Editor. For 
more information, see the next section, •Controls in the Book Layout Editor.Ž
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Controls in the Book Layout Editor

 

The Book Layout Editor is where you design the layout of pages in your book and add 
images and text to pages.

The following controls are available for revising books in the Book Layout Editor.

The Book Layout Editor 
is where you design 
your book.

Theme button Edit Layout button

Edit Content button

Pages panel

Add Pages
pop-up menu

Set Master Page 
pop-up menu

Book Action 
pop-up menu

Delete Pages button
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´ Theme:  Click this to choose a theme for your book�s pages.
´ Edit Content:  Click this to edit the text on your pages.
´ Edit Layout:  Click this to change the page layout. You can then select text, metadata, 

and photo boxes on the page and move and resize them as you like.
´ Pages panel:  Click here to see an individual page in the book.
´ Add Pages pop-up menu:  Choose an option from this pop-up menu to add a page or 

pages to the book.
´ Delete Pages:  Click this to delete the selected page or pages from your book.
´ Set Master Page pop-up menu:  Choose the master page you want to apply to a 

selected page.
´ Book Action pop-up menu:  Choose options to reflow the images in a book, add an index 

and page numbers, or add and change the look of text, metadata, and photo boxes.

´ Text Style pop-up menu:  Choose the style of text you want for a selected text box.
´ Metadata Format pop-up menu:  Choose the type of metadata you want to display 

with your images.
´ Photo Filter pop-up menu:  Choose to apply various filters to an image to change its look.

´ Add Text Box:  Click this to add a text box to the page.
´ Add Metadata Box:  Click this to add a metadata box to the page.
´ Add Photo Box:  Click this to add a photo box to the page to hold an image.
´ Send Backward:  Click this to move a selected frame backward in the stacking order 

of overlapping text or image boxes.
´ Bring Forward:  Click this to move a selected frame forward in the stacking order of 

overlapping text or image boxes.

Photo Filter 
pop-up menu

Metadata Format 
pop-up menu

Text Style
pop-up menu

Add Text Box button

Send Backward button

Bring Forward button

Add Photo Box 
button

Add Metadata
Box button



Chapter 20    Creating Books 197

 

´ Scale To Fit:  Click this to scale the display of your pages to fit the Viewer size.
´ Actual Size:  Click this to view the selected page at its actual size.
´ Display Size slider:  Drag this slider to increase or decrease the size of the page in 

the Viewer.

´ Large Hardcover:  Click this to specify your book format as a large hardcover book.
´ Large Softcover:  Click this to specify your book format as a large softcover book.
´ Show Full Spreads:  Click here to display two facing pages in the Viewer.
´ Show Single Pages:  Click this to view single pages only.

´ Print:  Click this to print book pages. 
´ Buy Book:  Click this to purchase your book from Apple�s print vendor.
´ Previous Page:  Click this to see the previous page of your book.
´ Next Page:  Click this to see the next page of your book.

Display Size slider

Scale To Fit button

Actual Size button

Large Hardcover button

Show Full Spreads 
button

Show Single Pages 
button

Large Softcover
button

Print button

Previous Page button

Next Page button

Buy Book button
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Placing Images in a Book
You can have Aperture automatically place your images in the book. Aperture creates 
as many pages as you need using a selected theme and fills them with your images. 
You can also place images manually into the book, one at a time. 

To have Aperture automatically place images:
m In the Book Layout Editor, choose Autoflow Unplaced Images from the Book Action 

pop-up menu.

To add images to the book individually:
1 In the Book Layout Editor, click the Edit Content button, if it�s not already selected.

2 Drag an image from the Browser to the Book Layout Editor and place it in a photo 
frame on the page.

Adding Pages to a Book
As you work with your book, you can add new pages one by one, either at the end of 
the book or at a specific location in the book. 

To add a single page to your book:
1 Select a page in the Pages panel where you want the page to appear.

2 Choose Add New Page from the Add Pages pop-up menu.

The new page appears in the Pages panel after the selected page.

3 With the page you added selected in the Pages panel, choose a master page from the 
Set Master Page pop-up menu.

The new page now has the page layout you selected.

Removing Pages from a Book
If you decide not to use a specific page in your book, you can remove it from your 
book. When you remove a page, its contents are also removed from the book, but the 
images in the book album remain in the Browser.

To remove a page from your book:
1 Select the page you want to remove in the Pages panel. 

2 Click the Delete Pages button, then confirm that you want to delete the page.

Edit Content button
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Resizing and Aligning Images on a Page
When you add images to a page, either manually or automatically, you can have an 
image appear at its current size or have Aperture scale the image to fill the image 
frame. You can also change the alignment of the image in a frame, making it appear 
centered or aligned on the right or left edge.

To scale the image to fit the size of the frame:
m Select the image on the page, choose Photo Box Alignment from the Book Action 

pop-up menu, then choose Scale to Fill from the submenu.

To choose an alignment for the image in the frame:
m Select the image on the page, choose Photo Box Alignment from the Book Action 

pop-up menu, then choose an alignment option from the submenu.

Adding Text to Pages
You may find that you want to add captions or narrative text to some or all of the 
pages in your book. You can easily do this using text boxes, resizing the boxes to suit 
your needs.

To add a text box to a page:
1 In the Pages panel, select the page to which you want to add text.

2 Click the Edit Layout button.

3 Click the Add Text Box button.

A new text box appears on the page.

4 Drag the new text box to the location you want.

You can resize a text box by dragging its resize handles.

5 Click the Edit Content button, then type the text within the text box.

Click the Edit Layout 
button to add or move a 
text box on the page.

Add Text Box button

Click the Edit Content
button to enter text in

the text box.
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Changing the Theme 
You choose a theme when you create your book album, but you can change the theme 
at any time. When you choose a theme, the Book Layout Editor provides a 
professionally designed set of master pages that determine how you mix text and 
images on the page. For example, you can choose among master pages that create a 
cover page, text pages, and pages with different combinations of images and text. You�ll 
find master pages provide a fast and convenient method for quickly laying out a book. 

To choose a new theme for your book:
1 In the Book Layout Editor, click the Theme button.

A dialog appears alerting you that you may lose text when you change themes.

2 Click OK.

3 In the Theme dialog, select the theme you want.

4 Click Choose Theme.

After you change the theme, Aperture updates all your pages to use the new theme. 

Ordering a Printed Book
When you�ve completed the layout of your book, you can order a printed copy.

Important:  Before you get your book printed, it�s best to print a copy and proof it to 
make sure it�s what you want.

To order a printed book:
m In the Book Layout Editor, click the Buy Book button, then follow the onscreen instructions.

Warning:  It�s possible to lose text when you change themes. If you change book 
themes, make sure to first copy the text you�ve entered into another document so 
that you have a backup copy.

Theme button
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21 Backing Up Your Images

To safeguard your photography portfolio, it�s important to 
establish a reliable backup system and back up regularly.

This chapter provides information about backing up the Library to a vault on an 
external hard disk. It also provides information about deleting vaults to free up disk 
space and restoring the Library from a vault.

An Overview of Backing Up Your Files
After you import images into Aperture and erase your camera�s memory cards, the only 
copies of your digital master files reside on your computer. Digital images recorded on 
your hard disk or other storage media can be effectively duplicated and stored for 
safekeeping. Making backup copies provides reassurance that you can easily restore 
your files should an unforeseen incident cause the loss of the files. 

When you back up your images using Aperture, a complete copy of the Library is 
made. Backups are not cumulative, which means that your last backup is the last 
complete copy of the Library. If you remove items from the Library, those items are 
removed from the vault when it is next updated. It�s best to back up the Library, or your 
portfolio of images and projects, to an external hard disk drive. You may want to keep 
one backup onsite and another one offsite. If you back up regularly, you run little risk of 
permanently losing your work.
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You can set Aperture to back up copies of the Library to a designated storage area 
called a vault. For safety and redundancy, a vault should be stored on an external hard 
disk, such as a FireWire drive. Aperture lets you create as many vaults as you deem 
necessary. For example, you may want to create one vault on an external hard disk for 
daily backups of your entire system and a second vault on another external hard disk 
that you keep offsite. As you add to the Library and create new projects, Aperture 
automatically tracks which files have been backed up to your vault. 

All the managed master file images, versions, and all metadata, previews, and adjustment 
information associated with your images are backed up. The versions, previews, and 
metadata associated with referenced images� master files are also backed up in the vault. 
Referenced images� master files are not backed up in the vault with the Library. 

Important:  Referenced images are not backed up in the vault with the Library. Because 
the digital master files for referenced images are stored outside of the Library, you must 
manage the backup and archiving of them yourself.

Although rare, mechanical failures and unexpected damage to your computer system 
can occur. And from time to time you may upgrade your equipment and need to move 
your portfolio onto your new system. Aperture allows you to easily restore the entire 
Aperture Library from your backup disks. For more information about restoring images 
and projects, see �Restoring Your Aperture System� on page 207.

Office Remote location 

Aperture Library 
(internal disk) 

Vault 
(external disk) 

Vault 
(kept offsite and 

updated regularly) 
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Controls in the Vaults Panel
You use the Vaults panel at the bottom of the Projects panel to set the location of your 
vaults and check on their status. 

To show the Vaults panel:
m Click the Vaults Panel button.

There are several controls that you�ll use when you back up and update vaults.

´ Disclosure triangle:  Click this to see the hard disk that is assigned to this vault.
´ Vault Status button:  Click this to update a vault. The color of the Vault Status button 

indicates the state of the vault:
´ Black:  The Library is up to date. 
´ Yellow:  All master files in the Library have been backed up, but a change has 

occurred to at least one version, such as an adjustment, that has not yet been 
backed up. The vault should be updated to safeguard your work.

´ Red:  At least one master file in the Library has not been backed up. The vault 
should be updated to protect against the loss of master files.

´ Update All Vaults button:  Click this to update all of your connected vaults at the 
same time.

´ Vaults Panel button:  Click this to show or hide the Vaults panel.

Disclosure triangle Vault Status button

Vault Action 
pop-up menu

Update All Vaults
button

Vaults Panel 
button
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´ Vault Action pop-up menu:  You can use this to add and remove vaults, as well as 
update a vault.

´ Disk space available:  Aperture keeps track of how much storage space is available on 
the hard disk used by a vault. Color-coded bars indicate the space used by the vault, 
unused space, and space used for other, non-Aperture files.

Creating a Vault
You can create a vault and assign a hard disk to it using the Vault Action pop-up menu. 
After you assign a disk to the vault, Aperture uses the vault to back up the entire 
Library. You can also create additional vaults and assign hard disks to them, and each 
additional vault also records a complete backup of the Library.

To create a new vault:
1 Choose Add Vault from the Vault Action pop-up menu.

2 In the Add Vault dialog, specify the following options, then click Add.

´ Type the name you want for the vault.
´ Choose where you want the vault stored from the Where pop-up menu.

3 Repeat steps 1 and 2 to create additional vaults.

Important:  To ensure preservation of your image assets, make sure to assign each vault 
to a separate external hard disk drive.

Space used by 
non-Aperture files

Unused space available
on the vault

The colored bar
represents the space

used by the vault.

Vault Action 
pop-up menu

Vaults Panel button
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To see the hard disk assigned to a vault:
m In the Vaults panel, click the disclosure triangle beside the vault name. 

You can easily see the amount of free space your vault has available next to the vault 
name. Make sure to assign enough disk space to the vault to ensure a complete backup 
of the Library and to allow the Library to grow as you import new images over time. 

Updating Vaults
You can have Aperture update your vaults at any time. You can tell which vaults need 
to be updated by the color of the Vault Status button next to each vault. You can have 
Aperture update a particular vault or all of your vaults at once.

To update all connected vaults:
1 In the Vaults panel, click the Update All Vaults button. 

2 In the dialog that appears, click Update All Vaults.

To update a specific vault:
1 Do one of the following:

´ Click the Vault Status button beside the vault name.
´ Select the vault you want to update, then choose Update Vault from the Vault Action 

pop-up menu.

2 In the dialog that appears, click Update Vault.

If you keep a backup of your system on an offsite hard disk drive, you�ll occasionally 
need to bring it in for updating. Aperture keeps track of the hard disks that have been 
disconnected from their vaults. When you reconnect a hard disk drive, Aperture 
automatically detects the hard disk, determines which vault it�s assigned to, and 
reconnects the vault. A message appears asking if you want update the hard disk with 
the latest Library information.

Click the disclosure
triangle to see which
hard disk is assigned

to the vault.
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To update the vault on an external hard disk:
1 Connect the hard disk to your computer. 

2 Do one of the following:

´ Click the Vault Status button beside the vault name.
´ Select the vault, then choose Update Vault from the Vault Action pop-up menu.

3 In the dialog that appears, click Update Vault.

Important:  Make sure to update your offsite vaults regularly to minimize potential losses.

Removing a Hard Drive from Your System
You may routinely remove a backup hard disk drive from your Aperture system and 
take it to a safe offsite location. When you disconnect a backup hard drive from your 
computer, Aperture takes the associated vault offline. When you reconnect the hard 
drive again, Aperture automatically detects the hard disk and connects it to the 
corresponding vault.

To remove a hard disk drive connected to your Aperture system, 
do one of the following:

m Click the disclosure triangle next to the vault name to display the name of the hard disk 
assigned to the vault, then click the Eject button next to the hard disk name.

m In the Finder, drag the hard disk icon for the drive to the Trash, or select the disk in the 
sidebar and click the Eject button.

Deleting a Vault Permanently
You can remove an entire vault and delete all the images on it when you need to 
reconfigure your backup system. This is particularly useful when your vault comes close 
to exceeding the capacity of the hard disk it�s located on. 

To permanently delete a vault:
1 In the Vaults panel, select the vault you want to remove.

2 Choose Remove Vault from the Vault Action pop-up menu.

A dialog appears asking if you want to remove the vault.

3 Click one of the following buttons:

´ Remove Vault:  When you click this button, Aperture no longer tracks the vault, but 
the vault�s files remain on the hard disk.

´ Remove and Delete Vault:  When you click this button, Aperture no longer tracks the 
vault, and the vault�s files are deleted from the hard disk. 
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Restoring Your Aperture System
If you buy a new computer or use another system at a different location and want 
access to the Aperture Library, you can install Aperture and then transfer the Library 
from your vault (on your backup disk) to the other computer. If you experience 
equipment failure or other unexpected events, such as fire or weather-related damage 
to your equipment, you can easily restore the entire Library to your new computer.

To restore the entire Library from an external backup disk:
1 Connect the hard disk drive containing the most up-to-date vault to your computer 

and open Aperture.

2 Choose File > Vault > Restore Library.

The Restore Library dialog appears.

3 Choose Select Source Vault from the Source Vault pop-up menu.

4 Navigate to the vault from which you want to restore, then click Select.

5 Choose Select Destination from the Library Destination pop-up menu.

6 Navigate to the location to place your Library, then click Select.

7 Click Restore, then click Restore again.
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of vaults  204

Lock button  122
locked vaults  206
Loupe button  38, 101
Loupe tool  38, 87, 101

M
.Mac accounts  183, 191

linking webpages to homepages  191
Mac OS

configuring multiple displays  26�27
magnifying

images with Loupe  87
magnifying images  33, 98
magnifying pages  197
managed images  13, 18
Manual slideshow setting  160
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master files. See digital master files
master page layouts  193, 196, 198, 200
master pixel size  148
matching search criteria  140, 141
Match pop-up menu  140, 141
Maximize Viewer layout  46
metadata

in books  196
dates  145
displaying  40, 76, 196
exporting  177
in filenames  56
finding images with  146, 147
keywords  121
lifting  38
searchable data fields  148

Metadata Format pop-up menu  196
Metadata Inspector  40, 136
Metadata pop-up menu  172
metering pattern metadata  40
migrating to new equipment  202, 207
mirroring displays  26, 89
mistakes, undoing  47
modifier keys  47
monitors. See displays
Monochrome Mixer adjustment  156
Move to Trash button  53
moving

filmstrip  99
images in Light Table  166
images to other projects or albums  80
items to Trash  53
panning images  88

multiple-criteria searches  148
multiple displays  23�27
multiple images

printing  173
rating  115
selection modes  98

multiple images in Viewer  85
multiple keywords  124
multiple selections  33
multiple stacks of images  110
multiple text fields  141

N
naming

export presets  181
files  56
Light Table albums  164
projects  50
renaming images  72
Smart Albums  152
vaults  204

narrative text  199

navigating
through book pages  197
in Browser  73
in filmstrip  97
through images  70
through slideshows  161
through webpages  188

navigation buttons  34
New Album With Current Images button  140
New Book Album button  36
New Book From Selection command  194
New Empty Album button  36
New Empty Book command  194
New Empty Light Table command  164
New Light Table Album button  36
New Light Table From Selection command  164
New Project button  36
New Smart Album button  36, 140, 152
New Version command  78
New Version From Master button  37, 78, 100
New Web Gallery Album button  36
New Web Gallery From Selection command  184
New Web Journal From Selection command  186
Next Image button  34, 73, 97
Next Page button  197
noise reduction  156
nonadjacent images, selecting  74
numbering pages  196

O
offline hard disks  206
offsite storage  205
Open All Stacks button  100
opening

projects  50
stacks  100, 108

orange borders  117
ordering books  200
organizing projects

before importing files  56
importing folders  64

orientation  172
searching for images by  148

overlapping images
on book pages  196
filmstrip and  99
in Light Table  168

overlapping text on book pages  196
overlays for ratings  114

P
page layouts  196
page numbers  196
pages

adding to books  198
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adding to or removing from books  196
aligning and resizing images on  199
navigating through  197
number to print  172
removing from books  198
text boxes  199

Pages panel  196
panning images  88
paper size settings  172
patch adjustments  37, 101, 156
Patch tool  37, 101
pausing slideshows  161
PDF files  175
Photo Box Alignment command  199
photo boxes  196, 199
Photo Filter pop-up menu  196
Photoshop files (PSD)  56, 80, 177
Pick command  108
picks

defined  105
marking images as  100
selecting  108

PNG files  13, 56, 80, 177
posting webpages to web  191
preferences  46
preset export options  179, 180
preset information display  91
preset keywords  35, 122, 129, 130
preset layouts  46
preset print settings  172, 173
preset slideshows  160
previewing printing options  173
Previous Image button  34, 73, 97
Previous Page button  197
Primary Only button  33, 98
primary selections  33, 73, 98
primary Viewer  89
Print button  197
Print dialog  170, 171
printer settings  172
printing

.Mac account printing service  193
book pages  197
books  175, 193�200
contact sheets  174
images  171�175
layout options  172
Light Table arrangements  170
metadata sets  172
multiple images  173
ordering printed books  200
single images  173
to PDF files  175
Use Best DPI  172

print resolution  172
Project Action pop-up menu  31
project buttons  36
Project Management layout  46
projects

copying and moving images between  80
creating  36, 50
defined  13, 15
deleting  54
deleting images  53
dragging image files into  63
empty  58, 59
exporting  67
favorites  52
importing images into  55, 58, 64
naming  50
opening and closing  50
organization tips  56
Projects panel functions  31
Smart Albums and  153
switching between  51
tools  36
transferring  15
transferring projects  67
in workflow  11

Projects panel  31, 54
Projects pop-up menu  31
Promote button  100
promoting images  79, 100, 109
proofing books  200
PSD files  56, 80, 177
Publish Album As option  191
publishing webpages  191
Publish to .Mac command  191
purchasing books  197, 200

Q
Query HUD

creating Smart Albums  152
date searches  144
displaying  43
EXIF data searches  147
IPTC data searches  146
keyword searches  143
multiple-criteria searches  148, 149
overview  139�140
ratings-based searches  142
saving search results  150
sorting images by ratings  116
text searches  141
in workflow  12

Query HUD Action pop-up menu  140
Query HUD button  69, 96
QuickTime-compatible file formats  56
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R
rating images

assigning ratings  114
buttons for  34
comparing images  117
finding images by ratings  142
keyboard shortcuts  118, 119
overview  113
sorting rated images  115

Rating pop-up menu  142
ratings buttons  34, 97
RAW files  56, 80

digital master files  13
rearranging display positions  26
rearranging images

on book pages  196
in Browser  75
in Light Table  166
in slideshows  161
in stacks  109
on webpages  189

Rebuild Book With All Images command  198
recovering from file losses  202
red channels  156
red-eye adjustments  156
Red Eye tool  38, 101
redoing actions  47
red rectangle symbol  88
Reduce Selection command  74
red Vault Status buttons  203
referenced images  13, 18, 80

backing up  202
displaying a list  81
identifying  81
locating  82

reflowing images in books  196
Reject button  34, 97, 114
rejecting images  34, 97, 114

compare images  118
Reject ratings  113
Remove From Favorites command  52
Remove Keyword button  123, 128
Remove Vault command  206
removing

See also deleting
book pages  198
hard disks  206
images from Light Table  165
images from slideshows  161
images from Smart Albums  154
images from stacks  109
keywords  128, 138
projects from favorites  52
vaults  206

renaming image versions  72

resetting images
in Light Table  167

resizing
fonts  172
images for printing  172
Loupe tool  87

resizing images
on book pages  199
in Light Table  166
on webpages  190

Restore Library dialog  207
retouching images  101
revealing images in Light Table  168
rolls from iPhoto Libraries  66
Rotate buttons  97
Rotate Left and Rotate Right buttons  34, 97
Rotate Left and Rotate Right tools  37, 101
rotating images

in Browser  76
in filmstrip  97
tools  34, 37, 101

rows of images on webpages  190
Rows value slider  189
Run Slideshow dialog  160

S
saturation  156
Save as PDF button  175
saving

books as PDFs  175
search results  150

Scale To Fill command  199
Scale to Fit All Items button  169
Scale to Fit button  197
Scale To pop-up menu  172
scroll bar  70, 96
search criteria

combining  148, 149
filtering by  140
matching  140
Smart Albums and  154

search criteria options  140
Search field  70, 96, 122, 140
searching  148
searching for images. See finding images
secondary Viewer  89
Select All command  74
Select button  34, 97, 114
Select Destination command  207
selecting images

for Light Table albums  164
to import  59
multiple images  74
primary selections  73
Selection tool  101
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selecting keywords to copy  135
Selection tool  37, 101
Select ratings  118
selects  15
Select to Beginning and Select to End 
commands  74
Send Backward button  196
sensor dust  156
sepia effects  156
series of images  106
Set Compare Item command  86, 117
Set Master Page pop-up menu  196, 198
settings  46
setting up systems  11, 21�28
shadow adjustments  156
shortcut menus  47
shortcuts. See keyboard shortcuts
Show All Images button  166
Show crop marks  173
Show Full Spreads button  197
Show Keyword Controls command  129
Show Master Image button  33, 101
Show Single Pages button  197
Show Unplaced Images button  166
shutter speeds  40
Shuttle control  70, 71, 96
single image printing  172
Single Images preset  173
single page view  197
sites. See webpages
Site Theme button  189
Slideshow button  36
slideshows

changing images in  161
keyboard shortcuts  161
overview  159�161

Slow Dissolve setting  160
Smart Albums

creating  36, 140, 152
defined  16
deleting  154
overview  151�152
saving search results as  150
in workflow  12

Smart Web Gallery Albums  150
softcover books  197
Sort Direction button  69
sorting images

in Browser  32, 69
by ratings  115
in list view  70, 72
in workflow  12

Sorting pop-up menu  69
source vaults  207
Span option (multiple displays)  89
Split Stack command  110

splitting stacks  110
spot adjustments  37, 101, 156
Spot tool  37, 101
Stack  37
Stack command  107
Stack Pick button  37, 100
stacks

adding and removing images  109
arranging images in  109
closing  100
creating  106
creating manually  107
keyboard shortcuts for  111
marking picks  100
opening or closing  100, 108
overview  105
picks  105
promoting and demoting images  109
selecting pick images for  108
splitting  110
tools  37
unstacking images  110

Stamp button  135
Stamp tool  38, 101, 136
star ratings  113
startup disks  28
stock ID numbers  148
stopping slideshows  161
storage space on external disks  204
straightening images  37, 101, 156
Straighten tool  37, 101
Subfolder format  178
subfolders  65
switching

between projects  51
synchronizing vaults and backup files  19
system setup  11, 21�28

T
templates for books  193
text

adding to webpages  188
in books  196
on contact sheets  172
searching for images by  141

text boxes  196, 199
Text Style pop-up menu  196
Theme button  196, 200
Theme dialog  200
theme list  194
themes

for books  193, 200
for webpages  189

Thumbnail Image Preset pop-up menu  191
Thumbnail Resize slider  70, 96



Index 221

 

thumbnails
arranging in Browser  32
creating while importing  55
in grid view  71
size of  70, 71, 72, 96
in versions  14
viewing images as  69
on webpages  191

TIFF files  13, 56, 80, 177
time

time zones  148
toolbar

customizing  45
Full Screen mode  94, 99

tools
customizing  45
toolbar buttons  35�38

tools HUDs  103
transferring

Libraries  207
projects  15, 67

U
Uncover button  168
undoing errors  47
unlocking vaults  206
Unstack command  110
unstacking images  110
Update All Vaults button  205
updating vaults  19, 42, 203, 205
USB cables  22

V
Vault Action pop-up menu  204
vaults

backing up Libraries to  202
creating  204
defined  13, 19
deleting images in  206
identifying hard disks  205
locking and unlocking  206
restoring images from  202
restoring Libraries from  207
source vaults  207
status of  42, 203
updating  205
Vaults panel  42

Vaults panel  42
Vault Status button  205, 206
Vault Status buttons  42
version names

searching for  148
version numbers  40
versions

in albums  15

copying or moving to other albums  80
creating  78�79, 100
creating while importing  55
defined  13, 14
deleting  53
duplicating  100
exporting  179
incremental versions  78
numbers  40
in projects  15
promoting or demoting  79
renaming  72
tools  37

Viewer
adjusting image view  88
background adjustments  84
comparing images in  86
full-resolution image display  88
image data in  84
keywords in  137
Loupe  87
metadata in  91
number of images in  85
overlays  92
overview  32, 83

Viewer Background Level slider  84
Viewer Mode pop-up menu  33, 89, 98
Viewer overlays  92
View Options command  72, 92, 137
View Options window  77

W
watermarks

exporting images with  177
watermarks on images  182
web galleries

creating  184
editing appearance  189
navigating and viewing  188
overview  183
posting to web  191
saving search results as  150

web gallery albums  36
web journals

adding pages  188
adding text and titles  188
creating  186
deleting pages  188
editing appearance  189
navigating and viewing  188
overview  183
posting to web  191
saving search results as  150

Webpage Editor  184, 186, 188, 191
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webpages
adding pages  188
adding text and titles  188
deleting  188
editing appearance  189
linking to .Mac homepages  191
navigating through  188
posting to web  191

white-balance adjustments  156
white borders  117
white points  156
Width value slider  190
workflow in digital photography  9�12

workspace
configuring and customizing  44�46
layout buttons  38

Y
yellow Vault Status buttons  203

Z
zooming to change image view  33, 88, 98, 169, 197
Zoom to 100% command  169
Zoom Viewer button  33, 88, 98
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