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Frequently Asked Questions 
About Aperture

 

This document answers common questions asked by new 
users about Aperture. 

Importing and Setting Up 

 

How should I go about importing my archives of digital photos into Aperture?

 

A little initial planning goes a long way toward creating an efficient and useful 
organization for your images. Before importing images, plan the number of projects 
you expect to need and how they should be organized in a hierarchy of folders, 
projects, and albums. It’s also a good idea to get used to using Aperture, learning how 
it works best for you, before importing large numbers of archive images.

Once you have a systematic plan for organizing your images, it’s probably best to 
import images from your archives on a project-by-project basis. This allows you to 
import images into the Aperture Library slowly, adjusting the organization as needed. 
You can continue to do new work and build up your image library over time. If you 
organize your images into projects as you import, you can avoid having a single project 
with thousands of images to sort through. 

If you have archive files organized in a hierarchy of folders that you want to maintain, 
you can drag the folders from the Finder into the Projects panel and Aperture imports 
the folders and images using the same hierarchy.

You should also consider the size of the files you’re importing. If you import many large 
files, such as large scanned TIFF images over 100 MB each, these images may fill up 
your hard disk quickly. You may want to consider whether importing numerous large 
files into Aperture is worth the requirements for disk space. 
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How do I transfer images stored on my laptop to my main Aperture system?

 

While in the field shooting photos, you can download your images to a PowerBook, 
where you can review and organize them in Aperture. Later, you can transfer these 
images from your PowerBook to an Aperture system in your office. It’s best to transfer 
the images by exporting them as projects from your PowerBook. You can then transfer 
the projects to your office computer and import the projects into your main Library. 
Exporting and importing your files as projects helps avoid the possibility of overwriting 
images on your main Aperture system. Carrying your entire Library on your PowerBook 
and then overwriting the Library on your main computer is not recommended.

 

Why are some of my images gray?

 

While Aperture is in the process of importing or loading images, gray boxes appear in 
the Browser in place of images. The gray boxes are only temporary and are replaced 
when the image thumbnails become available. 

 

How do I change my default settings?

 

You can change many of your default settings in the Preferences window. To see your 
current settings, choose Aperture > Preferences. Aperture also uses many default 
settings grouped as presets. You can see and modify the presets for functions like 
exporting, playing slideshows, and naming files by choosing Aperture > Presets and 
then choosing a type of preset from the submenu.

 

My computer’s hard disk doesn’t have a lot of free space to hold images. 
What should I do?

 

You can move the Library, which contains your projects and images, to a different disk. 
The Library is located by default on your computer’s hard disk. Depending on the disk 
space you expect to require over time, you may want to use a dedicated hard disk to 
hold the Library. 

To change the location of the Library, copy the Library file to a different hard disk. The 
Library file is located in the Pictures folder, with the name Aperture Library. After 
copying the file to a new location, you specify the new location in the Preferences 
window. To specify a new location for the Library, choose Aperture > Preferences, then 
click the Set button below the Library Location field, navigate to the Library file at the 
new location, and click Select. Make sure to select the Library file itself, not a folder 
holding the Library file. If you select a folder, Aperture creates a new, empty Library file 
instead of locating your copied Library file. When you quit and reopen Aperture, the 
application accesses your Library from the new location.
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Can I change the toolbar?

 

You can customize the toolbar to show the buttons and tools you use the most. For 
example, if you often change your preferences, you can add a button to the toolbar 
that opens the Preferences window. To customize your toolbar, choose 
View > Customize Toolbar. 

 

Can I change the background color of the Viewer and Browser?

 

Aperture displays images against a gray background so that you can view the true 
color in your images. You can lighten or darken the background of the Viewer and 
Browser using options in the Preferences window. To lighten or darken the background 
color of the Viewer or Browser, choose Aperture > Preferences, then drag the Viewer 
Background Level slider or the Gridview Background Level slider.

 

Does Aperture support tethered shooting?

 

Yes, you can use an Automator workflow to set up tethered shooting between your 
camera and your computer to automatically import images into Aperture. Aperture 
works with Automator to automate common tasks. For instructions on using an 
Automator workflow for tethered shooting, see http://www.apple.com/aperture.

 

Working with Projects and Images

 

How do I rearrange the Browser so I can work with two projects at once?

 

When you select a project in the Projects panel, the project’s images appear in the 
Browser. Option-click another project in the Projects panel and the Browser divides into 
two panes, showing the two projects at once.

 

How do I save the work I’ve done on my images?

 

Aperture automatically saves your changes in the Library as you work, so there is no 
Save command in the application. You should also set up a vault, a designated storage 
space for backup files, to back up the Library. When you update your vault, an exact 
duplicate of the current Library is made and stored on the hard disk that holds the 
vault. Although you don’t need to save changes to the Library, you should update your 
vault regularly to keep your backup current.

http://www.apple.com/aperture
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What’s the difference between a folder, a project, and an album?

 

You use folders to organize groups of projects and albums. For example, you might 
create folders to hold the projects you shoot for a long-term client or for a specific type 
of image, such as shots of sporting events or weddings. You can create folders at the 
top level of the Projects panel and inside projects. Folders only hold projects and 
albums; you cannot place images directly in folders. 

Projects hold your digital master files and image versions created from those files. You 
import images into projects. If a project has many images that need subdividing, you 
can create albums within a project. When you delete a project, you delete the digital 
master files that it holds. 

Albums hold only image versions, not master files. You can have as many albums within a 
project as you need. You can create albums in folders, in projects, and at the top level of 
the Projects panel. When you delete an album, only the image versions it contains are 
deleted. The corresponding digital master files (that reside in a project) are not deleted.

 

What’s a good way to organize my projects to handle large numbers of images?

 

How you organize your images depends largely on the type of photography you do. 
Because it’s more difficult to navigate through large numbers of images in a single 
project, it’s a good idea to keep images divided into many small projects and albums, 
as opposed to large projects that hold thousands of images. Organizing images in 
smaller projects and albums can make scrolling and searching for images easier.

 

Where are my digital master files?

 

When you first import an image, the digital master file is placed in a project. The 
thumbnail image that appears in the Browser is a representation of the digital master file. 
If you make changes to the image, the thumbnail displays the changes, but it also remains 
connected to the original master file. You can move a digital master file by dragging the 
thumbnail to a different project. If you drag the thumbnail to a different album, the digital 
master file stays in the same place, and only a version is copied into the album.

On your computer’s hard disk, your digital master files reside in the Aperture Library 
file. By default, this file is located in your Pictures folder (although you can specify a 
different location if you wish). You should never open your Aperture Library file in the 
Finder to access your images. If you need to use the files outside of your Aperture 
system, select and export the images you need. Opening the Library file in the Finder 
and making changes could render the Library unusable by Aperture.
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Can I delete a digital master file?

 

You can permanently delete a digital master file from the Library. For example, you 
might want to delete digital master files of images that you have designated as rejects. 
To delete the master file for an image, select the image in the Browser and choose 
File > Delete Master Image and All Versions. 

 

Important:  

 

Deleting a master file also immediately deletes all image versions based on 
the master file throughout the Library and any metadata assigned to these versions. 
You cannot retrieve versions or metadata deleted with a digital master file.

 

If I make an accidental change or delete an image or project that I want to keep, 
what should I do?

 

In most cases, you can choose the Undo command to immediately cancel your last 
action. In fact, you can choose the Undo command multiple times to undo your last 
series of actions. Aperture places deleted digital master files in the Trash. If you discover 
a deletion you did not intend to make, and the Undo command cannot recover the 
deletion, you can still recover the master file from the Trash until the Trash is emptied.

If you originally backed up your deleted digital master files, the vault may still hold 
them. If necessary, you can restore the Library from the vault. If you updated your vault 
after the deletion, the deleted digital master files are placed in a folder given your 
vault’s name and the words “Deleted Masters.” You can find the Deleted Masters folder 
in the folder that holds your vault. The Deleted Masters folder holds the deleted digital 
master files only; it does not hold any information about versions or changes to your 
files. You can open this folder and reimport the original digital master files.

 

Why can’t I rename a digital master file?

 

When you first import an image, Aperture records the original filename. You cannot select 
and change that filename in Aperture. You can change image version names at any time 
in the Metadata Inspector. When you export your files, you can assign new filenames, as 
well as choose image formats and sizes or add watermarks and metadata. To set up the 
export of your images, choose Aperture > Presets > Image Export. You can change the 
filename when you choose File > Export Version or File > Export Master. If you prefer, you 
can also change filenames before you import the files into the application.
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Can I name and number my photos when I import them?

 

You can assign version names and numbers to images when you import them. For 
example, you can name versions and give them sequential numbers such as IMG 001, 
IMG 002, IMG 003, and so on. You can also assign names that include a variety of 
information such as dates and times. 

To assign a simple version name and number to each image as it is imported, open the 
Import dialog and choose Custom Name with Counter from the Name Format pop-up 
menu. Enter the name you want in the Custom Name field. To set the numbering of your 
images to start at a specific number, choose Edit from the Name Format pop-up menu. In 
the Naming Presets dialog, select the “Incrementing counter starting at” checkbox and 
enter a starting number for your images. Choose the number of digits you want included 
in the version name from the “# of digits” pop-up menu. For example, if you want three-
digit numbers to appear, such as 001, 002, and 003, choose 3 from this pop-up menu. 

 

How do I add keywords to images?

 

There are several ways to assign keywords. You can open the Keywords HUD by 
choosing Window > Show Keywords HUD. With the Keywords HUD open, you can drag 
keywords to an image. To see the keywords assigned to images, choose View > View 
Options, select the Viewer checkbox, and choose Caption & Keywords from the Set 1 
pop-up menu. 

You can also assign keywords using the control bar. If the control bar is not shown, 
choose Window > Show Control Bar. To display the keyword controls in the control bar, 
choose Window > Show Keyword Controls (or press D).

You can also open the Metadata Inspector by choosing Window > Show Inspectors. A 
list of the currently assigned keywords appears in the Keywords text box. You can 
change or add keywords for the selected image in this box.

 

I selected several images to change, but the change only affected the first image in 
the selection. Why?

 

Aperture provides a Primary Only button in the control bar that gives you the option of 
applying changes to the primary image in a group of selected images, leaving the rest 
of the selected images unchanged. Aperture is preset to have the Primary Only feature 
turned off, which applies your changes to all the images in a selection. If you discover 
that a change was applied to only one image when you expected it to change multiple 
selected images, check to see if the Primary Only button is selected. 
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What are the keyboard shortcuts used for common procedures?

 

Aperture has many useful keyboard shortcuts. You can find a list of keyboard shortcuts 
in the Help menu. 

Here are some of the keyboard shortcuts that photographers immediately find useful:
Â

 

To rate a selected image, press backslash (\) to assign a 5-star rating, or press equal 
sign (=) or hyphen (-) to increase or decrease a rating.

Â

 

To designate an image in a stack as the pick image, select the image and press 
Command-backslash (\).

Â

 

To quickly turn on or off the display of metadata, such as ratings, filenames, or 
keywords, press Y.

Â

 

To quickly turn on or off the display of tooltips (information

 

 

 

that appears when you 
hold the pointer over an image, button, or control), press T.

Â

 

To quickly show or hide the Adjustments and Metadata Inspectors, press I. 
Â

 

To quickly show or hide the Adjustments HUD, press H. 

 

How do I change the information, such as keywords, that I’ve assigned to an image?

 

After you’ve assigned or changed metadata for an image, you can review and change it 
in the Metadata Inspector. To open the Metadata Inspector, choose Window > Show 
Inspectors. A list of metadata assigned to the currently selected image appears. You can 
change or add metadata for the selected image.

 

How do I use stacks?

 

Stacks are used to select one pick image from a group of similar images, and hide the 
other images from view. For example, if you have four shots of a model sitting in a 
particular pose and you want to choose just one image from among the four, you can 
stack the images and then choose a pick. The pick then represents the other three 
images, which you can hide by closing the stack.

If you later search for the image of the model, Aperture only locates the pick image 
because it doesn’t search within stacks for images. 

For this reason, it’s best to use stacks when you have a single image in each sequence 
that you want to use as your “select”, and one or more alternates that you don’t plan to 
use. Grouping several images that you want to use in a stack could cause you to 
overlook important images. You can use an album to group the images instead.

If you need to search within stacks, you can create a Smart Album and then select the 
Ignore Stack Groupings checkbox when you specify your search criteria.

 

How do I drag stacks to different locations?

 

Close the stack to drag an entire stack to a new location. When a stack is open, 
dragging moves the individual versions within the stack. 
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Adjusting Images

 

How do I apply the same adjustment to several images at once?

 

The Lift and Stamp tools in the toolbar are ideal for applying the same change to 
multiple images. These tools allow you to “pick up” the changes and metadata applied 
to one image and then “stamp” them onto other images. You can select multiple 
images and stamp them all at once with your changes. For more information about 
using the Lift and Stamp tools, see the 

 

Aperture

 

 

 

Getting Started 

 

manual.

 

What’s the best way to set up my office to make color adjustments?

 

The eye perceives color subjectively. It’s difficult to make changes to the colors in an 
image objectively because the brain skews the perception of colors to make them 
appear as natural as possible. For this reason, it is essential that you create a work 
environment conducive to performing color adjustments. Such an environment 
excludes extraneous colors that have the potential to throw off your eye.

Before you begin making color adjustments to your images, it’s important to pay 
attention to the following guidelines: 
Â

 

Set your display to its highest-resolution setting to give yourself the best view of 
your image.

Â

 

Make sure you are employing good color management. Color calibrate your displays 
and printers and make sure their color profiles are up to date.

Â

 

Reduce the ambient light to prevent it from skewing your perception of the colors 
on your screens. Make sure your displays are set to their brightest levels.

Â

 

If possible, paint the walls in the room a neutral gray. 
Â

 

Keep bright-colored objects to a minimum to ensure that the colors on your screens 
are not altered by colors in the rest of the room.

 

How can I improve the quality of my photos in Aperture?

 

The most important thing you can do when capturing digital images is use the 
highest-quality settings available on your camera. Once your images are imported into 
the application, Aperture does not improve or degrade the quality of your images in 
any way, because Aperture never modifies the original master files; if you use high-
quality image files, you’ll get high-quality results.

Here are some guidelines to help you maintain high-quality images:
Â

 

Capture your images using the highest-quality settings of the camera. If you are 
shooting images in JPEG format, make sure to use the least amount of compression 
possible. If you are shooting RAW images, make sure you shoot at the highest-possible 
bit depth setting.

Â

 

Focus your shots well. 
Â

 

Capture your images at the correct exposure. Although RAW images allow for close 
to 1.5 stops of latitude, it’s always better to correctly expose every image.
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Â

 

Pay attention to your environment. Make sure your camera gear is clean and in good 
working order both before and during the shoot. Dirty lenses, image sensor dust, 
and poor performance of the camera body and off-camera flash due to low battery 
power can negatively affect the quality of images.

Â

 

Get as close to your subject as safety allows. The closer you are to your subject, the 
more detail you will capture in your image.

 

Working in Full Screen Mode

 

Is there a fast way to switch between Full Screen mode and the Browser workspace?

 

Press F to turn Full Screen mode on or off. Aperture also provides a useful combination 
of Full Screen mode and the standard workspace layout in the Maximize Viewer 
workspace layout. Choose Window > Layouts > Maximize Viewer to see this workspace. 

 

Is there a way to hide the filmstrip when I’m working in Full Screen mode?

 

You can set the filmstrip to appear when the pointer is positioned over its location and 
disappear when the pointer is moved away. To do so, choose Auto from the Viewer Mode 
pop-up menu in the bottom-left corner of the filmstrip. You can also resize the filmstrip or 
drag it to a new position. You can have the filmstrip appear without overlapping the 
onscreen image by choosing Avoid from the Viewer Mode pop-up menu. 

 

How do I use Full Screen mode to do a presentation?

 

Full Screen mode is designed to give you an enlarged view and easy working access to 
your images. To present images to clients, however, it’s best to use the slideshow 
feature, which provides many advanced options for displaying images. You can control 
the display of images, choose how one image transitions to the next, how many 
images appear on the screen at a time, and even play music with your slideshow.

 

Working with Webpages and Books

 

If I change themes after working on a web gallery, web journal, or book, will I lose 
my previous work?

 

If you add images or text to a web gallery or web journal and then change themes, 
Aperture preserves your layout of images and text, fitting them into the new theme.

With books, however, it’s best to choose your theme carefully before entering text. 
It’s possible to lose text when you change themes. If you must change book themes, 
make sure to copy the text you’ve entered into another document so that you have a 
backup copy.
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Exporting and Printing

 

Can I export my images into Adobe Photoshop and get them back into Aperture?

 

Aperture provides an easy way to transfer images to another application for changes 
and then bring the revised image back into Aperture. You can specify an application as 
an external editor in the Preferences window. For example, if your image editing 
sometimes requires one or more of the specialized tools available in Adobe Photoshop, 
you can select Photoshop as your external editor. You can then select an image and 
choose Images > Open With External Editor. Aperture makes a new version of your 
image and opens it in Adobe Photoshop. After you make your changes, save the image; 
the revised version automatically reappears in Aperture. The external editor doesn’t 
change the digital master file, only the new version.

 

How do I get my image files out of Aperture?

 

When you need to deliver image files to clients, you can easily export your images from 
the Library. You can export the adjusted versions of your images or the unchanged 
digital master files. When you export versions, you can specify the file format for the 
exported image, such as JPEG, TIFF, or PSD files. You can include the metadata that was 
assigned to your images, choose filenaming conventions, assign ColorSync profiles, and 
add watermarks. To learn more about your export options, see the chapter about 
exporting in the 

 

Aperture

 

 

 

Getting Started 

 

manual.

 

What’s the best way to apply a professional-quality watermark to my images?

 

To place a nice-looking watermark on your images, create a PSD file that holds an 
image on a transparent background. You can then choose Aperture > Presets > Image 
Export to open the Export Presets dialog and select this file as a watermark image. 

 

My printed images and onsceen images don’t look the same. What should I do?

 

Color calibration between computer displays and printing equipment can require a 
complicated process of calibrating your display and using ColorSync profiles to ensure 
that the printer reproduces colors accurately. You may want to investigate purchasing 
color-calibration software and equipment. Aperture allows you to do onscreen 
proofing based on the color profile of the expected output device. For example, you 
can choose a color profile for a display, printer, or paper type and have Aperture show a 
facsimile of the end result onscreen. To use onscreen proofing, choose View > Proofing 
Profile, then choose a profile from the submenu. Turn on onscreen proofing by 
choosing View > Onscreen Proofing (so there’s a checkmark by it).



 

 

 

Backing Up

 

Should I keep my backup vault on my computer or on an external hard disk?

 

All your images are stored in the Library on your computer’s hard disk or on another 
hard disk that you’ve selected. When you create a vault, Aperture creates an exact 
duplicate of the Library on the vault’s hard disk. Make sure that the Library and vault 
use different hard disks. That way, if you have a problem with the hard disk holding the 
Library, the vault’s backup copy is safe on a different disk. 

Hard disks are sometimes divided into “partitions.” A partition is a portion of a hard disk 
that has its own name and hard disk icon, and functions similarly to a separate hard 
disk. A single hard disk may have multiple partitions. Don’t use different partitions of 
the same hard disk to hold the Library and a vault. If the partitioned hard disk has a 
problem, both the Library and the vault could be at risk.

 

When should I back up my vault?

 

It’s a good idea to back up your vault after you import new images. That way, you have 
copies of your digital master files in the Library and in the vault. It’s also a good idea to 
have more than one vault so that you have several backups of the Library. When 
Aperture updates a vault, it copies only the new and changed items to the vault and 
doesn’t update all the files that are already backed up. This makes frequent updates fast 
and easy.

 

Can a vault span two or more hard disks?

 

No, a vault is limited to the disk capacity of one hard disk drive. You can use a RAID hard 
disk array, which combines the storage capacity of several disks, to hold the Library or a 
vault, but you must use an application such as Disk Utility to set up the RAID array. 
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