
CHAPTER 1-TURNING THE MACINTOSH ON AND OFF

You'll learn how to:

- turn the Macintosh on and off

Also, you'll learn about

- the startup disk

- the Macintosh desktop

Before you begin

You should have already

- set up your Macintosh according to the instructions in the setup book that
came with your computer

- gone through the Macintosh Basics tour, supplied on disk with your computer

- read the introduction to this section of the book (page 1)

Turn Your Computer On

How you turn on your Macintosh depends on which model it is. For specific
information, go to the setup book that came with your computer.

!!  IMPORTANT: If an external hard disk or other external devices are
connected to your Macintosh, turn on those external devices before you turn
on the Macintosh.  !!

- If your Macintosh is the Macintosh LC or it does not have a separate
monitor (like the Macintosh Classic), press the on/off switch on the back of
your computer.

If the Macintosh LC monitor doesn't turn on, make sure that the monitor's
on/off switch is on. (If you don't know where the switch is, go to the manual
that came with your monitor.)

- If your computer is one of the Macintosh II models (such as the IIci or the
IIfx), press the Power On key on your keyboard.

If the monitor doesn't turn on, make sure that its on/off switch is on. (If
you don't know where the switch is, go to the manual that came with your
monitor.)

Turn Your Computer Off

Before you can turn off your computer, you need to know how to use the mouse
to choose a command from a menu. The Macintosh Basics tour lets you practice
choosing commands. If you need more practice, go through the next chapter
(Chapter 2) and then come back to this section to turn off your computer.

1.  Point to the Special menu name in the menu bar.

2.  Press and hold down the mouse button.



3.  Drag through the items in the menu until the Shut Down command is
highlighted, then release the mouse button.

- If your Macintosh does not have a separate monitor (like the Macintosh
Classic), press the on/off switch on the back of the computer when a message
on screen indicates that it's safe to do so.

- If your Macintosh is the Macintosh LC, press the on/off switch on the back
of the computer when a message on screen indicates that it's safe to do so,
and switch off the monitor as well.

- If your computer is a Macintosh II or a portable model, the computer and
the monitor turn off by themselves.

!!  IMPORTANT: If an external hard disk or other external device is connected
to your Macintosh, turn off those external devices after you turn off the
Macintosh.  !!

Turn off your computer at the end of your work day or when you know you won't
be using it for several hours.

When You Turn On Your Computer

The Macintosh looks for a startup disk, which is a disk that contains the
information it needs to "start itself up." In your case, the startup disk is
a hard disk that's inside or connected to your computer. When the Macintosh
finds a startup disk, it displays the icon shown at left and proceeds to
start itself up.

When your computer is done starting itself up, the screen displays the
Macintosh "desktop." The desktop is a field of gray (or another color) with

- a menu bar across the top (containing the names and icons of menus)

- an icon near the upper-right corner representing the startup disk

- a Trash icon near the lower-right corner

If the Macintosh doesn't find a startup disk, it displays this icon instead.
In this case, you may need to prepare a startup disk or connect one to your
computer.

If your Macintosh is the Macintosh LC or it does not have a separate monitor
(like the Macintosh Classic), press the on/off switch on the back of your
computer.

CHAPTER 2-UNDERSTANDING THE DESKTOP

You'll review how to

- use the mouse

- choose a command

- open an icon

- look at the contents of a window



- close a window

(The Macintosh Basics tour introduced you to these skills.)

You'll learn how to

- move a window

Also, you'll learn about

- using the keyboard

If you turned off the Macintosh, turn it back on now.

Use The Mouse

You use the mouse to control the movements of a pointer on screen. Usually,
the pointer is an arrow that's set at an angle.

Much of the work you do on the Macintosh uses four mouse actions: pointing,
clicking, pressing, dragging.

Point

You point to an object on screen by moving the mouse so that the pointer is
positioned on that object. When the pointer is an arrow, the very tip of the
arrow must be exactly on the object.

Practice by pointing to different objects on the Macintosh desktop, such as
the startup hard disk icon near the upper-right corner, the Trash icon near
the lower-right corner, and the Help menu icon near the right corner of the
menu bar.

Click

You click an object on screen by pressing and quickly releasing the mouse
button while the pointer is on that object.

Practice by clicking different objects on the Macintosh desktop, such as the
startup hard disk icon near the upper-right corner and the Trash icon near
the lower-right corner.

When you click an icon, it becomes highlighted (the icon is darkened), which
means that it is selected. A selected icon is the object of whatever action
you choose next.

Press

You press by holding down the mouse button without moving the mouse. Don't
bear down on the mouse itself.

Practice by pressing the menu names and menu icons in the menu bar (start
with the Apple menu icon in the left corner, through the menu names, and
across to the Help and Application menu icons in the right corner). Pressing
a menu name or icon "pulls down" the menu. Read the items in each menu you
pull down.



Drag

You drag an object on screen by pointing to that object and holding down the
mouse button while you move the mouse.

Practice by dragging the startup hard disk icon and the Trash icon around the
Macintosh desktop. Make sure you return the icons close to their original
positions.

When you drag an icon, an outline of the icon follows the pointer on the
screen. When you release the mouse button, the icon itself moves.

Choose A Command

Choosing a command involves a combination of the mouse actions you've
reviewed.

1.  Point to the Special menu name in the menu bar.

2.  Press to pull down the Special menu.

3.  Drag to the first item in the menu (the Clean Up Desktop command) so that
it is highlighted, then release the mouse button.

When you choose the Clean Up Desktop command, the startup hard disk icon and
the Trash icon return exactly to the positions they occupied when you first
turned on the computer (as long as they're already close to their original
positions).

Open An Icon

Opening an icon is your first exercise in "talking Macintosh": telling your
computer what you want it to do.

1.  Click the startup hard disk icon (unless it's been changed, it should be
named "Macintosh HD") near the upper-right corner of the screen to select it.

Make sure that the icon is highlighted (darkened), which means that it's
selected.

2.  Point to the File menu name in the menu bar.

3.  Press to pull down the File menu.

4.  Drag to the Open command (the second item in the File menu) so that it is
highlighted, then release the mouse button.

When you choose the Open command, the selected icon (in this case, the
Macintosh HD icon) opens into a window (the Macintosh HD window). The icon
itself becomes filled in with a pattern of dots, indicating that it has been
opened.

Look At The Contents Of A Window

Every window has several features that help you view the window's contents.
You can

- make the window bigger or smaller



- move any hidden contents into view

Before you work with the contents of a window, you need to make that window
the active window.

Make a window the active window

You can have several windows on screen, but only one window at a time can be
the active window.

The Macintosh HD window should already be on your Macintosh desktop. (The
window appeared when you opened the Macintosh HD icon.)

1.  Click the Trash icon near the lower-right corner of the screen to select
it.

Make sure that the icon is highlighted, which means that it's selected.

2.  Point to the File menu name in the menu bar.

3.  Press to pull down the File menu.

4.  Drag to the Open command (the second item in the File menu) so that it is
highlighted, then release the mouse button.

When you choose the Open command, the selected icon (in this case, the Trash
icon) opens into a window (the Trash window). The icon itself becomes filled
in with a pattern of dots, indicating that it has been opened.

You should now have two windows on your Macintosh desktop: the Macintosh HD
window and the Trash window. The Trash window is the active window because
you opened the Trash icon most recently.

5.  Click anywhere in the Macintosh HD window to make it the active window.

The active window is the one with solid lines across the top (the title bar),
on either side of its title. When windows overlap, the active window is the
one that's on top.

Make a window bigger or smaller

You can change a window's size by dragging its size box or by clicking its
zoom box.

1.  With the Macintosh HD window the active window, point to the size box in
the lower-right corner of the window.

2.  Drag the size box in any direction, then release the mouse button.

An outline indicates the window's new size. The outline follows the pointer
as you drag. You can drag in any direction to make the window bigger or
smaller, wider or narrower.

3.  Click the zoom box near the right end of the title bar.

The window "zooms" to a size that shows all of its contents.

4.  Click the zoom box again.



The window zooms back to its previous size (the size that you changed it to
in step 2).

Clicking the zoom box is a quick way to view as much of a window's contents
as your screen size allows.

Move the hidden contents of a window into view

Without changing the size of the window, you can view any contents that are
currently out of sight by using the window's scroll bars and scroll arrows.

1.  With the Macintosh HD window the active window, click the System Folder
to select it.

Make sure that the icon is highlighted, which means that it's selected.

2.  Point to the File menu name in the menu bar.

3.  Press to pull down the File menu.

4.  Drag to the Open command (the second item in the File menu) so that it is
highlighted, then release the mouse button.

When you choose the Open command, the selected icon (in this case, the System
Folder) opens into a window (the System Folder window).

You should now have three windows on your Macintosh desktop: the Macintosh HD
window, the Trash window, and the System Folder window. The System Folder
window is the active window because you opened the System Folder last.

5.  Point to the size box in the lower-right corner of the System Folder
window.

6.  Drag the size box diagonally to make the window smaller (about half its
current size), then release the mouse button.

The bars across the bottom (the horizontal scroll bar) and along the right
(the vertical scroll bar) of the System Folder window should now be gray,
indicating that the window has contents that you cannot see at its current
size.

7.  Press the right scroll arrow at the right end of the horizontal scroll
bar.

The contents of the window scroll past, bringing into view the icons that had
been out of sight and to the right.

The scroll box moves to the right across the bar, showing what part of the
window's contents you're looking at.

8.  Press the left scroll arrow at the left end of the horizontal scroll bar.

The contents of the window scroll past, bringing back into view the icons
that had been out of sight and to the left.

The scroll box moves to the left across the bar, showing what part of the
window's contents you're looking at.



9.  Drag the scroll box toward the middle of the horizontal scroll bar, then
release the mouse button.

Now you see the icons near the middle of the window.

10.  Press the down scroll arrow at the bottom end of the vertical scroll
bar.

The contents of the window scroll past, bringing into view the icons that had
been out of sight and toward the bottom.

The scroll box moves down along the bar.

11.  Press the up scroll arrow at the top end of the vertical scroll bar.

The contents of the window scroll past, bringing into view the icons that had
been out of sight and toward the top.

The scroll box moves up along the bar.

12.  Drag the scroll box toward the middle of the vertical scroll bar, then
release the mouse button.

Now you see the icons near the middle of the window.

!!  Remember: Changing the size of a window or moving the contents of a
window does not change its contents. The contents remain the same; only what
you see of the contents changes.  !!

Close A Window

When you no longer need to see the contents of a window, you can close it by
clicking the close box.

1.  With the System Folder window the active window, point to the close box
near the left end of the title bar.

2.  Click the close box.

The window closes, and the System Folder icon is no longer filled in with a
pattern of dots, indicating that it is not open.

You should have two windows on the Macintosh desktop: the Macintosh HD
window, which is now the active window, and the Trash window.

Move A Window

You can move a window anywhere on screen by dragging its title bar. By
changing the position and the size of windows, you can arrange windows in any
way that works best for you.

1.  Point to the title bar of the Macintosh HD window (anywhere on the title
bar except the close box or the zoom box).

2.  Drag the title bar in any direction, then release the mouse button.

When you drag a window's title bar, an outline of the window follows the
pointer on screen. When you release the mouse button, the window itself moves



to the position of the outline.

3.  Click anywhere in the Trash window to make it the active window.

4.  Point to the title bar of the Trash window (anywhere on the title bar
except the close box or the zoom box).

5.  Drag the title bar in any direction, then release the mouse button.

Notice that the Trash window, because it is the active window, stays on top
of the Macintosh HD window if the two windows overlap.

6.  Click anywhere in the Macintosh HD window to make it the active window.

7.  Close the Macintosh HD window by clicking the close box near the left end
of the window's title bar.

The window closes, and the Macintosh HD icon is no longer filled in with a
pattern of dots, indicating that it is not open.

The Trash window (the remaining window on the Macintosh desktop) becomes the
active window.

8.  Close the Trash window by choosing Close Window from the File menu.

You choose Close Window by pointing to the File menu name, pressing to pull
down the menu, dragging to the Close Window command, and, with the command
highlighted, releasing the mouse button.

Of course, you can also close the window by clicking its close box.

How To Hold The Mouse

- You can use the mouse with either hand. Most people prefer to use it with
their dominant hand (the right if they're right-handed, the left if they're
left-handed). If you want to switch mouse positions, go to the setup book
that came with your computer.

- Keep the heel of your hand on your desk. (Your arm will tire quickly if you
hold your hand up in the air.)

- Lightly rest your index and middle fingers on the mouse button.

- Make sure that the mouse cable is pointing away from you.

When you move the mouse

- Glide the mouse over the surface of your desk. Don't press down on it.

- If you run out of room on your desk as you're moving the mouse, pick it up
and put it down where there's more room. When you pick up the mouse, the
pointer on screen does not move, or does so only slightly.

When You Talk To Your Macintosh

Talking Macintosh always involves two steps:



- selecting an object on the screen, and

- choosing the action you want to perform on the object.

An icon or a window on the Macintosh desktop, text in a word-processing
program, a picture in a graphics program -- all of these are objects that you
can select.

The actions you choose to perform on a selected object are usually commands
(like the Open command), but you can also perform actions directly using the
mouse (like dragging an icon).

When you select an object, you're telling the Macintosh to act upon that
object.

Talking Macintosh is like using a very simple language with only two kinds of
words:

- nouns (the objects), and

- verbs (the actions)

and with only one rule to remember:

- First the noun, then the verb (to this object, do that action).

What's On The Desktop?

The Macintosh desktop is a field of gray (or another color) with a menu bar
across the top, an icon near the upper-right corner representing the startup
disk, and a Trash icon near the lower-right corner.

The desktop is your work space on the computer -- as the top of a wooden desk
is a work space. It gives you a familiar way of thinking about how to use the
Macintosh.

Aside from the field of gray (the "surface" of your work space), the
Macintosh desktop has icons, windows, and menus.

- Icons represent containers.

- Windows let you view the contents of containers.

- Menus offer you actions that you apply to selected containers (or their
contents).

Icons represent containers

You can think of icons as containers. Icons can contain other icons, or they
can contain information.

For example, the startup disk icon near the upper-right corner of the desktop
contains the System Folder icon. The System Folder icon contains the programs
and other files (more icons) that contain the information the Macintosh needs
to start itself up.

Several types of icons represent different types of containers.



Hard disks and floppy disks are like filing cabinets. You use disks to store
files -- programs you use and documents you create.

Shared disks are like filing cabinets containing office supplies or records
that you share with others in your work group. Your Macintosh needs to be
connected to a network before you can use shared disks.

Folders are like folders in a file drawer. You use folders to organize your
files.

Programs are files containing instructions to the computer that let you do
certain types of work.

Documents are files containing words, pictures, numbers, sounds -- whatever
you create using programs.

The Trash is a container for files that you no longer want or need.

Windows let you view the contents of containers

Windows let you see what's "inside" all of these containers. When you open a
disk icon, the window that appears shows you what's on the disk. When you
open a document icon and the document is a memo, for example, the window that
appears lets you see the memo.

Menus offer you choices

Like the menus in a restaurant, Macintosh menus let you choose. You choose
among different actions that the computer can perform on containers (icons)
or the contents of containers (words in a memo) that you've selected.

When To Use The Keyboard

You use the keyboard to type text and numbers, of course, as you would on a
typewriter. (For touch typists, Macintosh keyboards have raised dots in the
middle of the D key and the K key to help position your fingers on the home
row.)

Depending on the program you're using, you can use special keys on the
keyboard to give commands to the computer and to replace or change the effect
of certain mouse actions. Macintosh keyboards have three types of special
keys: modifier keys, arrow keys, and function keys.

Modifier keys

All Macintosh keyboards have four modifier keys: Shift, x (Command), Option,
and Control.

Pressed by itself, a modifier key does nothing. You need to press it in
combination with another key (or while using the mouse). The modifier key
"modifies" the other key or the mouse action, giving a different result.

You type a capital letter, for example, by pressing the Shift key with a
letter key. Most programs let you give commands by pressing the x key with
certain letter keys.



Arrow keys

All Macintosh keyboards have four arrow keys: Up Arrow, Down Arrow, Left
Arrow, and Right Arrow.

Many programs let you use the arrow keys as well as the mouse to control the
movements of the pointer on screen.

Function keys

Extended Macintosh keyboards have a row of function keys across the top of
the keyboard.

Some programs let you give commands, or a sequence of commands, by pressing
certain function keys.

CHAPTER 3-SETTING UP YOUR PROGRAMS

You'll learn how to

- insert a floppy disk

- initialize a disk

- copy the contents of a disk

- take a floppy disk out of its drive

- safeguard the contents of a disk

- use the Trash

You'll also learn about

- types of floppy disks

- the difference between hard disks and floppy disks

- caring for floppy disks

And you'll learn more about

- the startup disk and the System Folder

Before you begin, you need

- a new floppy disk

If you turned off the Macintosh, turn it back on.

Insert A Floppy Disk

You should be able to get floppy disks from wherever you got your Macintosh.
The 3.5-inch (86-millimeter) floppy disks that fit in your Macintosh
computer's SuperDrive come in two types: high-density and double-sided. Your
Macintosh uses either type.



Some older Macintosh models, however, do not have the SuperDrive floppy disk
drive and cannot properly use high-density disks.

1.  Write "Practice" on a blank disk label.

2.  Affix the label onto your new floppy disk.

How the label goes onto the floppy disk is apparent from the molding of the
disk's protective plastic case. Do not affix the label over the metal
shutter.

3.  Hold the disk between thumb and forefinger, with your thumb on the label
and the metal shutter pointing away from you.

4.  Push the disk into the computer's SuperDrive, label side up and metal
shutter first, until the SuperDrive pulls the disk in the rest of the way.

Initialize A Disk

Before you can use a new floppy disk, you need to prepare it so that the
computer knows where to store and retrieve information on the disk. Preparing
a disk is called initializing. Initializing a disk is like drawing the lines
on a newly paved parking lot: you don't know what fits where until you figure
out how much room you have.

1.  After you insert your practice disk into the SuperDrive, read the dialog
box that appears on screen.

2.  Depending on which dialog box appears, click Initialize or Two-Sided.
Another dialog box appears.

This dialog box gives you one last chance to cancel. It alerts you that
you're about to erase -- and therefore lose -- any information that may be on
the floppy disk. In this case, because the floppy disk is new, you have no
information to lose.

3.  Click Erase.

A third dialog box appears:

4.  Type "Practice".

If you make any typing errors, press the Delete key to backspace over them.

When you name a disk, you can type up to 27 characters, including spaces. You
cannot use a colon (:) in the name.

5.  Click OK.

The computer takes about a minute to initialize the disk. A series of
messages appears on the screen to let you know how the process is going.

When the computer is done initializing the floppy disk, the disk's icon
appears on the Macintosh desktop directly below the Macintosh HD icon (the
startup hard disk icon) near the upper-right corner.

Copy The Contents Of A Disk



Most programs you get are supplied on one or more floppy disks. You can more
efficiently use a program if you first install it on your hard disk (copy it
from its floppy disk to your hard disk).

To practice copying the contents of a floppy disk to your startup disk, use
your practice disk (even if there's nothing on it).

1.  Make sure that the Practice floppy disk icon is selected. If it isn't,
click the icon (not its name).

2.  Drag the Practice floppy disk icon to the Macintosh HD icon until both
icons are highlighted, then release the mouse button.

Both icons are highlighted when the tip of the arrow pointer reaches the
Macintosh HD icon as you drag the Practice floppy disk icon.

When you release the mouse button, the Macintosh copies the contents of the
Practice floppy disk onto Macintosh HD (your startup hard disk). The copy is
in a folder named Practice, which is now on Macintosh HD.

3.  Click the Macintosh HD icon to select it.

4.  Choose Open from the File menu.

You choose Open by pointing to the File menu name, pressing to pull down the
menu, dragging to the Open command so that it's highlighted, and releasing
the mouse button.

The Macintosh HD window appears, showing you the contents of the startup hard
disk. The contents should include a new folder called Practice, which the
computer created when it copied the contents of the Practice floppy disk to
Macintosh HD.

You may have to make the window bigger or use the scroll bars to find the
Practice folder.

5.  Click the Practice folder to select it.

6.  Choose Open from the File menu.

You choose Open by pointing to the File menu name, pressing to pull down the
menu, dragging to the Open command so that it's selected, and releasing the
mouse button.

The folder holds the contents of the floppy disk you've copied (in this case,
the folder contains nothing because there's nothing on the Practice disk).

7.  Close all the windows you have on the Macintosh desktop.

You close a window (when it's the active window) by either clicking its close
box or choosing Close Window from the File menu.

Take A Floppy Disk Out Of Its Drive

While there's only one way to insert a floppy disk into the SuperDrive,
there's more than one way to take it out. Here is the best way:



1.  Make sure that the Practice floppy disk icon is selected. If it's not
selected, click it.

2.  Eject the floppy disk by choosing Put Away from the File menu.

You choose Put Away by pointing to the File menu name, pressing to pull down
the menu, dragging to the Put Away command so that it's highlighted, and
releasing the mouse button.

Put Away puts the object you've selected back in its place (in this case, it
allows you to remove the floppy disk from the disk drive and put it away).

Safeguard The Contents Of A Disk

You can lock a disk so that its contents cannot be changed in any way. When a
disk is locked, you cannot change the files that are on it, delete any files,
or store additional files.

To practice locking and unlocking a floppy disk, use your practice disk.

1.  Hold the practice disk between thumb and forefinger, with your thumb on
the label and the metal shutter pointing away from you (as if you were going
to insert the disk into a drive).

2.  Find the square hole in the near-left corner of the floppy disk.

A moveable tab on the back side of the disk should be blocking the hole,
indicating that the disk is unlocked.

If you're using a high-density floppy disk: You'll notice an additional
square hole, across the label from the first hole. This second hole has no
moveable tab and is always open. 

3.  Turn the disk over and lock the disk by sliding the tab on the back side
of the disk so that the square hole is open.

Use your thumbnail or a push pin to move the tab.

4.  Unlock the disk by sliding the tab back so that the square hole is
blocked.

Your practice disk should be unlocked so you can use it to store files in the
next chapter.

Use the Trash

When you no longer need or want a file or folder, you throw it away by
dragging its icon to the Trash. (A file can be either a document or a
program.) Practice using the Trash by throwing away the Practice folder,
which you created when you copied the contents of your Practice disk onto
Macintosh HD.

1.  Click the Macintosh HD icon to select it.

2.  Choose Open from the File menu.

You choose Open by pointing to the File menu name, pressing to pull down the
menu, dragging to the Open command so that it's highlighted, and releasing



the mouse button.

The Macintosh HD window appears, showing you the contents of the startup hard
disk. The contents should include the Practice folder.

You may have to make the window bigger or use the scroll arrows to find the
Practice folder.

3.  Click the Practice folder icon to select it.

4.  Drag the Practice folder icon to the Trash icon until both icons are
highlighted, then release the mouse button.

Both icons are highlighted when the tip of the arrow pointer reaches the
Trash icon.

When you release the mouse button, the Practice folder "disappears" into the
Trash. When you put a file or folder in the Trash, the Trash icon bulges to
indicate that it is no longer empty.

5.  Open the Trash icon.

You open an icon by clicking it to select it and then choosing Open from the
File menu.

When you open the Trash icon, the Trash window appears. The Practice folder
you've just thrown away is in the window. Anything you put in the Trash stays
there until you empty the Trash.

You can put anything that's in the Trash back where it was by clicking it to
select it and then choosing Put Away from the File menu. (Or you can drag it
back where it was.)

6.  Choose Empty Trash from the Special menu.

A dialog box appears asking you to confirm that you want to permanently
remove the contents of the Trash. If you change your mind, you can click the
Cancel button.

Clicking OK empties the Trash, and you lose anything that's in it.

7.  Click the OK button.

Notice that the Trash icon no longer bulges, indicating that it is empty.

8.  Close the Trash window by clicking its close box.

On Your Own: Install Your Programs

If you have any disks containing programs (such as word processing or
graphics) that you plan to use on your Macintosh, install the programs now on
your hard disk. If you do not have any program disks yet, go to the next
chapter.

!!  IMPORTANT: Some programs need to be installed in a specific way, so
follow the instructions that came with each program.  !!

If a program didn't come with specific installation instructions, these



general instructions tell you how to copy the contents of a program disk to
your startup disk:

1.  Lock the program disk.

The program disk contains your master copy of the program. Locking the disk
protects its contents but doesn't keep you from copying the contents onto
another disk.

2.  Insert the program disk into the floppy disk drive.

3.  Drag the program disk icon to the Macintosh HD icon (your startup hard
disk icon) until both icons are highlighted, then release the mouse button.

Both icons are highlighted when the tip of the pointer arrow reaches the
Macintosh HD icon as you drag the program disk icon.

When you release the mouse button, a series of messages briefly appears on
screen to let you know that the computer is copying the contents of the
program floppy disk onto Macintosh HD. The copy is in a folder on Macintosh
HD with the same name as the program disk.

4.  Eject the program disk by making sure it's selected and then choosing Put
Away from the File menu.

5.  If the Macintosh HD window is not on the desktop, open the Macintosh HD
icon.

When you open the Macintosh HD icon, the Macintosh HD window appears, showing
you the contents of your startup hard disk. Among its contents is the program
folder holding the contents of the disk you've copied.

6.  Click the program folder to select it.

7.  Choose Open from the File menu.

The folder window appears, showing the contents of the program folder. The
folder has the same contents as the program disk.

8.  Look for a System Folder in the program folder.

Some program disks have a System Folder (so they can be used as startup
disks). If the program disk you've copied has a System Folder, you now have
two System Folders on Macintosh HD.

Throw away extra System Folders

Your startup disk must have only one System Folder. Whenever you copy the
contents of a program disk to your startup hard disk, check to see that you
have not copied an extra System Folder. If you have, throw away the extra
System Folder.

1.  Drag the extra System Folder to the Trash in the lower-right corner of
the screen until both icons are highlighted, then release the mouse button.

2.  Choose Empty Trash from the Special menu.

A dialog box alerts you that you're about to throw away --  permanently --



the contents of the Trash (in this case, the extra System Folder).

3.  Click OK to confirm that you want to throw away the contents of the
Trash.

4.  Close the program folder window by clicking its close box.

Why A Floppy Disk Isn't Floppy

A floppy disk is made of thin, flexible material with a magnetic coating. To
protect it and to make it easier to handle, the floppy disk itself is
enclosed in a rigid plastic case, which gives the floppy disk its "non-
floppy" character.

A metal shutter on the plastic case allows access to the floppy disk, which
carries information in the form of magnetic signals. The shutter moves out of
the way when you insert the floppy disk in a disk drive.

You can use either of two types of 3.5-inch (86-millimeter) floppy disks in
your computer's SuperDrive: high-density and double-sided.

If you use another Macintosh: Some older Macintosh computers may not have the
SuperDrive floppy disk drive and therefore cannot use high-density disks. Use
only double-sided disks on these older Macintosh computers.

High-density disks can hold 1.4 megabytes (MB) of information (about 300
typewritten pages). Double-sided disks can hold 800 kilobytes (K) of
information (about 200 typewritten pages). (One thousand twenty-four
kilobytes make a megabyte.)

Floppy disks are also called diskettes.

Floppy Disks, Hard Disks, And Startup Disks

Both floppy disks and hard disks function like filing cabinets: you store
files in them. The differences between floppy disks and hard disks are in how
much information they can store, how quickly you can retrieve information
from them, and how easily you can carry them around.

You can store much more information on a hard disk and retrieve it much
faster than you can on a floppy disk.

And while you can carry a floppy disk in your shirt pocket, a hard disk is
sealed in a hard disk drive, which is installed inside the computer or
enclosed in a plastic box that's connected to the computer.

You can tell whether a disk is a floppy disk or a hard disk by looking at its
icon on the desktop.

The disk whose icon appears near the upper-right corner is the startup disk,
which contains the information that the Macintosh uses to start itself up.

That "startup" information is contained in programs and other files that are
in the System Folder on the startup disk. The startup disk must have only one
System Folder. If it has more than one, the computer becomes confused about
where to get the information it needs to start up and run, with unpredictable
-- and undesirable -- results.



Taking Care Of Floppy Disks

Follow the instructions about care and maintenance that came with your disks.
At minimum, remember these three points:

- Keep the disks away from magnets. Information on the disks is in the form
of magnetic signals, so a magnetic field can destroy that information.
Televisions and monitors, telephones, loudspeakers, and certain kinds of
lighting fixtures all have magnets.

- Protect disks from extremes of temperature and humidity.

- Do not open the disk's metal shutter. Touching the disk inside the shutter
could damage it.

CHAPTER 4-CREATING A DOCUMENT AND SAVING YOUR WORK

You'll review how to

- open a program

- create a document in a program

- save your work

- switch programs

- close a document

(The Macintosh Basics tour disk introduced you to these skills.)

You'll also learn about

- what happens when you open a program icon

- why it's important to save your work

- the difference between application programs and system software

Before you begin, if you turned off the Macintosh, turn it back on.

Open A Program

To practice using a program to create a document and save your work, you can
use TeachText, a simple word-processing program that comes with your
computer.

1.  If you closed the Macintosh HD window, open the Macintosh HD icon.

To open the icon, click it to select it and then choose Open from the File
menu.

The Macintosh HD window appears, showing you the contents of your startup
disk. The contents include a program called TeachText.

2.  Open the TeachText icon.



To open the icon, click it to select it and then choose Open from the File
menu.

When you open the TeachText program,

- an untitled window appears

- the menu bar shows TeachText menu names

- the Application menu icon in the right corner of the menu bar becomes the
TeachText icon

The untitled window contains nothing because you haven't written anything in
it. It remains untitled until you save whatever you've written and give it a
name. The file that you create and name is called a document.

Create A Document

The untitled window is like a blank sheet of paper, a document waiting to be
created. In the upper-left corner of the empty document is a blinking
vertical line. The line is called the insertion point, because it marks the
place where the text you type will be inserted.

As you type, you use the Macintosh keyboard as you would a typewriter
keyboard, except:

- If you make a mistake, press the Delete key to backspace over it.

- Don't press the Return key when you get to the end of a line. Keep typing.
The text will continue on the next line automatically.

Type the following text:

Sailing across an unknown sea, we saw the lights of a city in the distant
horizon. Was it another strange land, with strange and cruel people speaking
different languages, eating different food, wearing different clothes? We
wished it were home.

You will be changing this text.

Save Your Work

Until you save your work, it exists only in the computer's memory -- like
thoughts that are lost unless you write them down.

1.  Choose Save from the File menu.

The dialog box that appears lets you name the document and decide where you
want the computer to store it.

2.  Type "Opening Lines".

Because the word "Untitled" is selected (it's highlighted) when the dialog
box appears, all you have to do is start typing. Whatever you type replaces
the selected text. You'll learn more about selecting text later.

3.  Click Save.



The window is now titled "Opening Lines" and the document has been stored on
Macintosh HD.

Switch Programs

The Opening Lines window is the active window and TeachText is the active
program, but TeachText is not the only program that's open.

The Finder -- the program that displays the Macintosh desktop -- is also
open, but right now it is not active. (The Finder is always open when your
Macintosh is on.)

You can have several programs open at one time (how many programs depends on
how much memory your computer has), but only one program at a time can be the
active program. The active program is the one that's "on top" of other open
programs -- just as the active window is on top of other windows.

1.  Make the Opening Lines window smaller by dragging its size box and
releasing the mouse button.

After you resize the window, you should be able to see the Macintosh HD icon
in the upper-right corner of the Macintosh desktop.

2.  Make the Finder the active program by clicking the Macintosh HD icon or
anywhere on the desktop.

The Finder becomes the active program. Notice that

- the Macintosh HD window appears on top of the Opening Lines window

- the menu bar shows Finder menu names

- the Application menu icon in the right corner of the menu bar becomes the
Finder icon

Notice the icon in the Macintosh HD window representing the document Opening
Lines, which you've just created and saved on Macintosh HD.

3.  Make the Opening Lines window active by clicking anywhere in it. It's
partially hidden by the Macintosh HD window.

The Opening Lines window comes back to the top. It's now the active window,
and TeachText becomes the active program.

You make a window active by clicking any part of it. The program that "owns"
the window becomes active as soon as the window becomes active.

4.  Make the Finder the active program by choosing Finder from the
Application menu in the right corner of the menu bar.

You choose Finder by pointing to the Application menu icon, pressing to pull
down the menu, dragging to the item "Finder" so that it's highlighted, and
then releasing the mouse button.

The Finder becomes the active program, and the Macintosh HD window becomes
the active window.

5.  Make TeachText the active program by choosing TeachText from the



Application menu.

TeachText becomes the active program, and the Opening Lines window becomes
the active window.

From the Application menu, you can choose the open program that you want to
make the active program. All open programs are listed in the Application
menu. The icon at the top of the Application menu is the icon of the active
program.

Close A Document

When you close a document, you do not close the program that you used to
create it. (Closing a program is called quitting.) The program remains open
and remains the active program until you quit the program or make another
program the active program.

1.  If the Opening Lines window is not the active window, click anywhere in
it to make it the active window.

2.  Close the Opening Lines window by clicking the close box near the left
end of the title bar, or by choosing Close from the File menu.

The Opening Lines window closes but TeachText is still the active program.
Notice that

- the menu bar still shows TeachText menu names

- the Application menu icon in the right corner of the menu bar is still the
TeachText icon

Save It Or Say So Long

You need to save your document before you turn off the computer.

Using a Macintosh may seem like using a typewriter, pencil and ledger,
paintbrush and canvas, or pen and drafting paper -- but a computer is unlike
those other tools in one important aspect: anything you create on a computer
exists only temporarily in the computer's memory until you save your work.

That is, until you tell the computer to record your creation on a disk, your
finest work is no better than a mental note --  forgotten faster than you can
turn off a switch.

Two Types Of Programs

Programs that you use to do your work on the computer are called application
programs, or applications, because they're ways of applying computer
technology to the work that you do.

Word-processing programs, for example, are applications because they enable
you to write memos, reports, papers, theses, novels -- whatever you need or
want to write. And if your work involves creating graphics, calculating
numbers, composing music, or keeping track of large amounts of data -- there
are application programs for your work as well.

Most Macintosh programs work in similar ways, so most of what you learn using
one application you can use in other applications.



Programs that the computer uses to operate, on the other hand, are called
system software (or "the operating system").

And then there's the Finder

Between you and system software is an application called the Finder, which is
the program that displays the Macintosh desktop. It's called the Finder
because, like the viewfinder in a camera, it gives you a view of all the
objects -- disks, programs, documents -- that you have in your computing work
space (your "desktop").

Using the Finder, you can tell system software what you want it to do for
you: which disks you want to use, which programs and documents you want to
open, where you want files to be stored.

CHAPTER 5-CHANGING A DOCUMENT AND PRINTING YOUR WORK

You'll learn how to

- open a document

- change a document

- choose a printer

- print a document

- quit a program

- make a backup copy of a document

You'll also learn about

- double-clicking as a way to open icons

- using keyboard shortcuts

Before you begin, make sure that your computer is connected to a printer.

A printer can be connected directly to your computer, or it can be connected
through a network.

Go to the instructions that came with your printer if you need to connect it
to your computer.

If your computer is connected to a network, find out from your network
administrator (or the person who set up your computer)

- which printer on the network you can use

- where it is on the network (its "zone," if the network has zones)

- what its name is (every printer on a network has its own name)

If you turned off the Macintosh, turn it back on.



Open A Document

When you open a document, the program that you used to create that document
becomes the active program.

1.  If you closed the Macintosh HD window, open the Macintosh HD icon.

To open the icon, click it to select it and then choose Open from the File
menu.

The Macintosh HD window appears, showing you the contents of your startup
hard disk. The contents include the TeachText program and the TeachText
document called Opening Lines, which you created previously.

2.  Open the Opening Lines icon.

You can open an icon by double-clicking it: click the icon twice in rapid
succession, without moving the pointer. Double-clicking an icon has the same
effect as selecting the icon and then choosing the Open command.

When you open Opening Lines, TeachText becomes the active program. (TeachText
is the program that you used to create Opening Lines.) Notice that

- the Opening Lines window appears

- the menu bar shows TeachText menu names

- the Application icon in the right corner of the menu bar becomes the
TeachText icon

Change A Document

The Opening Lines window shows you the text you typed previously. You will be
making some changes to the text using techniques that work in most Macintosh
programs.

Keep two things in mind:

- The insertion point -- the blinking vertical line -- is where anything you
type appears.

- The I-beam pointer replaces the arrow pointer when you're dealing with
text. You control the I-beam pointer with the mouse as you would the arrow
pointer.

1.  Locate the insertion point. It should be in the upper-left corner of the
document.

2.  Locate the I-beam pointer. If you don't see it, move the mouse slightly.
The pointer moves as the mouse moves.

Now you're ready to insert some text.

3.  Move the I-beam pointer to the immediate left of the word "an" (after
"Sailing across").

4.  Click. By clicking, you put the insertion point where you were pointing
with the I-beam pointer. Anything you type is inserted at that point.



5.  Type the words "the blackness of space, adrift in".

If you make any typing errors, press the Delete key to backspace over them.

Next, you'll change some text.

6.  Move the I-beam pointer to the immediate left of the word "lights" (after
"we saw the").

7.  Drag horizontally, selecting the word "lights", then release the mouse
button.

To drag, hold the mouse button down as you move the mouse. The selected word
is highlighted (surrounded by black or another color).

8.  With "lights" selected, type the words "clear blue".

Whatever you type replaces the text you selected. If you make any typing
errors, press the Delete key to backspace over them.

9.  Now move the I-beam pointer to the immediate left of the word "city"
(after "of a").

10.  Drag horizontally, selecting the word "city", then release the mouse
button.

11.  With "city" selected, type the word "planet".

Whatever you type replaces the text you selected.

12.  Move the I-beam pointer between the letters "n" and "t" in the word
"distant" (after "in the").

13.  Drag horizontally, selecting the letter "t" and the word "horizon", then
release the mouse button.

14.  With "t horizon" selected, type the letters "ce".

If the period is missing after "distance", type one now.

If you make any typing errors, press the Delete key to backspace over them.

Save Your Work So Far

The changes you've made so far are not part of Opening Lines until you save
them; that is, you need to tell the computer to record the changes in the
document that's stored on Macintosh HD (your startup hard disk).

Until you save them, the changes are in a very temporary, electronic state.
You could lose them if power to the computer were interrupted or if a problem
with a program caused the computer to stop working properly.

Choose Save from the File menu.

Or hold down the Command key on the keyboard as you press the S key. Pressing
Command-S is a keyboard shortcut for choosing Save from the File menu.



Save regularly, and save often.

Make More Changes To A Document

You've saved the changes you've made so far: the changes are now part of the
document that's stored on Macintosh HD. You'll be making a few more changes
before you're done.

You continue by moving some text to another place in the paragraph.

1.  Move the I-beam pointer to the immediate left of the words "We wished"
(the start of the last sentence).

2.  Click. By clicking, you put the insertion point where you were pointing
with the I-beam pointer.

3.  Move the I-beam pointer between the letter "e" in "home" and the period
at the end of the last sentence.

4.  Hold down the Shift key on your keyboard and click to select the words
"We wished it were home".

Holding down the Shift key as you click selects the text between the
insertion point and wherever you click.

5.  With "We wished it were home" selected, choose Cut from the Edit menu.

Choosing Cut removes whatever you've selected from the document and stores
the selected material in a temporary electronic space called the Clipboard.

6.  Move the I-beam pointer to the immediate left of the words "Was" (in "Was
it another strange land").

7.  Click to set the insertion point.

8.  Choose Paste from the Edit menu.

The words "We wished it were home" appear at the location of the insertion
point. When you choose Paste, the Macintosh takes whatever's in the Clipboard
and puts it in the document.

Next, you'll delete a sentence.

9.  Drag the I-beam pointer across the words "Was it another strange land" to
select them, then release the mouse button.

If the words are on two lines, drag down to the second line and release the
mouse button when the pointer is to the immediate right of the word "land".

10.  With "Was it another strange land" selected, choose Clear from the Edit
menu.

When you choose Clear, the Macintosh removes the selected text from the
document. (Pressing the Delete key once has the same effect.)

11.  Select the word "cruel" (after "strange and") by double-clicking it.

You can select a word by double-clicking it: point to it with the I-beam



pointer and click twice in rapid succession, without moving the pointer.

12.  With "cruel" selected, type "wonderful".

Whatever you type replaces the text you selected.

13.  Drag the I-beam pointer across the question mark (after "different
clothes") and the stray period at the end of the paragraph, then release the
mouse button.

14.  With the question mark and the period selected, type a period.

You may have left extra spaces or no spaces between words. If you did,
position the I-beam pointer where you need to delete or add a space, click to
set the insertion point, and press the Delete key or the Space bar as
necessary.

15.  Choose Save from the File menu (or use the keyboard shortcut 
Command-S).

Choose A Printer

Before you can print a document, you have to tell the Macintosh which printer
to use by choosing a printer in a program called the Chooser.

You don't need to choose a printer every time you print. You need to choose
one only when you want to use a printer for the first time and whenever you
decide to change printers.

How you use the Chooser depends on whether your Macintosh is connected
directly to the printer or connected to a network.

If your printer is not on a network

Make sure that you've connected the printer according to the instructions
that came with it and that you know which port you used (on the back of the
computer) to connect the printer.

1.  Choose the Chooser from the Apple menu.

The Chooser window appears.

2.  Click the icon representing the printer you want to use. Make sure the
icon is selected.

If you have a Personal LaserWriter SC, go to step 5 after you click the
Personal LaserWriter SC icon. 

3.  Click to select the icon representing the port that you used to connect
the printer.

You have two choices: the printer port or the modem port. The printer port is
automatically selected. Click the icon that matches the icon of the port (on
the back of the computer) to which you connected the printer cable.

4.  Click the word "Inactive" next to the word "AppleTalk".

5.  Close the Chooser by clicking the close box near the upper-left corner of



the Chooser window.

The Opening Lines window should now be the active window. (If it isn't, click
anywhere in it to make it the active window.)

If your printer is on a network

Find out from your network administrator (or the person who set up your
computer) which printer you can use, which zone it's in (if your network has
zones), and what its name is (every printer on a network has its own name).

1.  Choose the Chooser from the Apple menu.

The Chooser window appears.

2.  Click the word "Active" next to the word "AppleTalk".

If Active wasn't already selected, a dialog box appears. Click OK.

3.  Click the icon representing the type of printer you want to use.

4.  If you see a list of AppleTalk zones, click the zone where the printer is
located.

You may have to click the up and down scroll arrows to find the zone. The
zones are listed alphabetically.

5.  Click the name of the printer you want to use, even if it's the only one
that appears.

6.  Click the close box near the upper-left corner of the Chooser window.

If you changed printers, a dialog box appears. Click OK.

The Opening Lines window should now be the active window. (If it isn't, click
anywhere in it to make it the active window.)

Print A Document

Once a printer has been selected in the Chooser, printing becomes a two-step
process. To practice printing, use the Opening Lines document you created.

1.  Make sure that the Opening Lines window is the active window, then choose
Print from the File menu.

If the Opening Lines window is not the active window, click anywhere in it to
make it the active window.

The dialog box that appears when you choose Print offers you many options,
depending on the program and the printer you're using. You can learn more
about these options from the instructions that come with your programs and
from Macintosh Reference, Part II of this book.

2.  Click the button labeled Print.

The printer you chose prints your Opening Lines document.

Quit A Program



Quitting a program closes the program as well as any documents you may have
open that were created using that program. Quitting a program is not the same
as closing a document (which you did already). Closing a document leaves the
program open and active.

Make sure that the Opening Lines window is the active window, then choose
Quit from the File menu.

Or press the Command key and the Q key together.

If a dialog box asks whether you want to save any changes, click Save.

The Opening Lines document and the TeachText program are closed, and the
Finder, the program that displays the Macintosh desktop, becomes the active
program.

Make A Backup Copy

Storing a copy of your work on another disk is wise practice, like saving
regularly and saving often. In case a file or an entire disk is damaged, you
have a copy of the file on another disk as a backup. (It seldom happens, but
if it happens once to you, it's happened once too often.)

To practice making a backup copy, put a copy of Opening Lines on your
practice disk.

1.  Make sure your practice disk is unlocked.

A moveable tab on the back side of the case should be blocking the square
hole near the lower-left corner (when you hold the disk as if to insert it),
indicating that the disk is unlocked.

2.  Insert the practice disk in your computer's floppy disk drive.

The Practice disk icon appears on the desktop, directly below the Macintosh
HD icon.

3.  Drag the Opening Lines icon to the Practice disk icon until both icons
are highlighted, then release the mouse button.

Both icons are highlighted when the tip of the pointer arrow reaches the
Practice disk icon.

When you release the mouse button, the Macintosh copies the contents of the
Opening Lines icon to the Practice disk.

You copy an icon when you drag it to a different disk. When you drag it
elsewhere on the same disk, you are merely moving the icon.

4.  Open the Practice disk icon.

You open the Practice disk icon by clicking the icon to select it and then
choosing Open from the File menu, or you can double-click the icon.

The Practice disk window appears, showing that a backup copy of the file,
also called Opening Lines, is stored on the floppy disk.



5.  Eject the Practice disk from the disk drive.

You eject the disk by clicking the Practice disk icon to select it and then
choosing Put Away from the File menu.

Taking A Shortcut

Many commands that you choose from menus can also be given using keyboard
shortcuts. A keyboard shortcut is a combination of keys that you press at the
same time to get the same result as choosing a command from a menu. One of
the keys is always the Command key or another modifier key.

For example, instead of choosing Save from the File menu, you could press the
Command key and the S key together.

You can find out the keyboard shortcuts for commands by pressing a menu name
and looking at the commands in the menu. Any keyboard shortcuts are shown in
a column next to the commands.

CHAPTER 6-ORGANIZING YOUR WORK

You'll learn how to

- make a copy of a document

- change the name of an icon

- save another version of a document under a different name

- open a document while its program is the active program

- organize icons in a folder

- use an alias for a document or program

- create stationery

- throw away files you no longer want or need

You'll also learn about

- the difference between Save and Save As

- what an alias is

Before you begin, if your Macintosh is off, turn it back on.

Make A Copy Of A Document

In the course of your work, you'll often want to make a copy of a document so
you can preserve the original while making changes to the copy. To practice
making a copy of a document, first create a new document, as you did before.

1.  If you closed the Macintosh HD window, open the Macintosh HD icon.

To open the icon, click it to select it and then choose Open from the File
menu. Or double-click the icon.



The Macintosh HD window appears, showing you the contents of your startup
hard disk.

2.  Open the TeachText icon.

To open the icon, click it to select it and then choose Open from the File
menu. Or double-click the icon.

When you open the TeachText program,

- an untitled window appears

- the menu bar shows TeachText menu names

- the Application menu icon in the right corner of the menu bar becomes the
TeachText icon

The untitled window contains nothing because you haven't written anything in
it. It stays untitled until the first time you save your work (name the
document and store it on a disk).

3.  Type the following text:

Dear Mom and Dad,

This letter is overdue, I know, but until I sat down to write, I had no idea
how long overdue it is. Time sure flies when you don't have enough of it.

Julie and I are doing well. The dog is getting better all the time. How are
you all?

Remember:

- If you make a mistake, press the Delete key to backspace over it.

- Don't press the Return key when you get to the end of a line. Keep typing.
The text will continue on the next line automatically.

- Press the Return key only when you want to start a new paragraph.

- The insertion point -- the blinking vertical line -- is where the text you
type will appear.

- The I-beam pointer replaces the arrow pointer when you're dealing with
text. You control the I-beam pointer with the mouse as you would the arrow
pointer.

4.  Choose Save from the File menu.

The dialog box that appears lets you name the document and decide where you
want the computer to store it.

5.  Type "Letter to Parents".

Usually you need to select text or set the insertion point before you type
text. In this case, because "Untitled" is selected when the dialog box
appears, all you have to do is start typing. Whatever you type replaces the



selected text.

6.  Click Save.

The window is now titled "Letter to Parents" and the document has been stored
on Macintosh HD (your startup hard disk).

7.  Close the Letter to Parents window.

To close the window, click the close box near the left end of the title bar,
or choose Close from the File menu.

The window closes, and TeachText remains the active program.

8.  Click the Macintosh HD icon, the Macintosh HD window, or anywhere on the
desktop.

The Finder becomes the active program. Among the contents of the Macintosh HD
window is the Letter to Parents icon, representing the document you created
and saved.

9.  Locate the Letter to Parents icon in the Macintosh HD window.

You may have to make the window bigger or use the scroll arrows to find it.

10.  Click the Letter to Parents icon to select it.

11.  Choose Duplicate from the File menu.

Another icon, labeled "Letter to Parents copy", appears in the Macintosh HD
window. Notice that the icon (as well as its name) is selected and that the
Letter to Parents icon is no longer selected.

Change The Name Of An Icon

You can change the name of any icon to anything you like, using spaces,
capital and lowercase letters, numbers, and any other characters except a
colon (:). If you open the icon, you'll see that the name of its window has
also changed.

1.  Drag the "Letter to Parents copy" icon away from the original icon so
that the two icons do not overlap.

2.  Click the name (not the icon) "Letter to Parents copy" (even if the icon
is selected).

When the name is selected, it is highlighted and a box appears around it.
Notice that when you point to the selected name, the arrow pointer becomes an
I-beam pointer.

3.  With the name selected, type "Letter to Sister".

Or drag the I-beam pointer over the words "Parents copy" to select them, and
then type "Sister" to replace them.

Another way to select a word is to double-click it: click anywhere inside the
word twice in rapid succession, without moving the pointer.
Whatever you type replaces the selected text.



4.  Press the Return key.

Now you have two documents. One is a copy of the other but they have
different names. You can revise one without changing the other.

5.  Open the Letter to Sister icon.

To open the icon, click it to select it and then choose Open from the File
menu. Or double-click the icon.

TeachText becomes the active program.

6.  Drag the I-beam pointer over the words "Mom and Dad" to select them.

7.  Type "Sis".

Whatever you type replaces the selected text.

8.  Choose Save from the File menu.

9.  Choose Close from the File menu.

Or click the close box near the upper-left corner of the Letter to Sister
window. You now have two slightly different versions of your letter: one for
your parents, and the other for your sister.

TeachText remains the active program.

Save Another Version Of A Document

There is another way to make a different version of a document. You can stay
in the program you're using to create the document and save a different
version under a different name.

1.  Click the Macintosh HD icon, the Macintosh HD window, or anywhere on the
desktop.

The Finder becomes the active program.

2.  Open the Letter to Parents icon.

To open the icon, click it to select it and then choose Open from the File
menu. Or double-click the icon.

TeachText becomes the active program.

3.  Drag the I-beam pointer over the words "Mom and Dad" to select them.

4.  Type "Juan".

Whatever you type replaces the selected text.

5.  Choose Save As from the File menu. Do not choose Save.

Choosing Save would change the original letter (so that the letter to your
parents would read "Dear Juan").



Choosing Save As, in contrast, lets you create a new document based on the
original document, but including the changes you made.

The dialog box that appears lets you name the new document and decide where
you want the computer to store it. "Letter to Parents," the name of the
original document, is already selected and ready to be changed.

6.  Type "Letter to Juan".

Whatever you type replaces the selected text.

7.  Click Save.

The new document, "Letter to Juan," now appears in the active window,
replacing the original document, "Letter to Parents." Notice that the
window's title bar now says, "Letter to Juan".

The original document is set aside, unchanged (if you open it, you'll find
that the first line is still "Dear Mom and Dad").

Open A Document While Its Program Is The Active Program

You can open a document without making the Finder the active program and then
opening its icon on the Macintosh desktop. You can open a document while the
program that you used to create it remains the active program.

1.  Close the document "Letter to Juan."

Click the close box near the upper-left corner of the document window or
choose Close from the File menu.

TeachText remains the active program.

2.  Choose Open from the File menu.

The dialog box that appears lets you find the document you want to open.

3.  Click "Letter to Parents."

4.  Click the Open button.

The "Letter to Parents" document window appears.

Organize Icons In A Folder

Sooner or later, in the course of your work, you'll have too many documents
and programs to keep track of easily. The Macintosh offers numerous tools and
techniques (all of them explained in Macintosh Reference, Part II) to help
you organize your work. Creating a folder and putting files in it is the
simplest way.

1.  If "Letter to Parents" is open and TeachText is the active program,
choose Quit from the File menu.

The Finder becomes the active program.

2.  If the Macintosh HD icon is not open, open it.



The Macintosh HD window should be the active window.

3.  Choose New Folder from the File menu.

An icon named "untitled folder" appears in the Macintosh HD window. The icon,
including its name, is already selected. (The name is highlighted and has a
box around it.)

4.  Type "Letters to Family".

Whatever you type replaces the selected text. If nothing happens when you
type, click the name so that a box appears around it and then try again.

5.  Drag the Letter to Parents icon to the new folder icon until both icons
are highlighted, then release the mouse button.

6.  Drag the Letter to Sister icon to the Letters to Family folder icon until
both icons are highlighted, then release the mouse button.

The Letters to Family folder now contains Letter to Parents and Letter to
Sister. You can open the Letters to Family folder icon if you want to make
sure that they are there.

Use An Alias

As you work, you may find it handy to have the same program or document
stored in more than one folder, so you can open it quickly when you're in a
particular folder.

1.  If the Macintosh HD icon is not open, open it.

The Macintosh HD window should be the active window.

2.  Choose New Folder from the File menu.

An icon named "untitled folder" appears in the Macintosh HD window. The icon,
including its name, is already selected. (The name is highlighted and has a
box around it.)

3.  Type "October Letters".

Whatever you type replaces the selected text.

4.  Open the Letters to Family folder icon.

5.  Click the Letter to Sister icon to select it.

6.  Choose Make Alias from the File menu.

An icon named "Letter to Sister alias" appears on top of the Letter to Sister
icon. The icon and its name are already selected.

Note that the name of the alias appears in italics. The name of an alias
appears in italics so you have a way to tell which icons are aliases.

7.  Drag the Letters to Family window to the right. You should be able to see
the October Letters folder in the Macintosh HD window behind it.



8.  Drag the Letter to Sister alias to the October Letters folder in the
Macintosh HD window, then release the mouse button.

You may have to change the size and position of the Letters to Family window
so you can see both icons.

9.  Open the October Letters folder icon.

10.  Open the Letter to Sister alias icon.

The document Letter to Sister opens, and TeachText becomes the active
program.

The insertion point (the blinking vertical line) should be at the beginning
of the document, to the left of D in "Dear".

11.  Type "16 October 91" and press the Return key once.

12.  Choose Save from the File menu.

13.  Choose Close from the File menu.

The Letter to Sister document closes, and TeachText remains the active
program.

You can open the original Letter to Sister icon (in the Letters to Family
folder) and see that it is now dated 16 October 91.

Letter to Sister is now available in both the Letters to Family folder and
the October Letters folder. By keeping the original in one folder and an
alias in the other folder, you have access to the same letter from either
folder.

14.  Close all the windows on the desktop.

Create Stationery

In your work, you may find it convenient to have a document that serves as
the computer equivalent of stationery, like a memo pad or "While You Were
Out" form. Each time you need a sheet, you take one from your endless supply
of stationery and fill it in.

To practice creating stationery, create a document in TeachText that works
like a memo pad.

1.  With TeachText the active program and no TeachText window open, choose
New from the File menu.

If TeachText is not the active program, open the TeachText icon in the
Macintosh HD window, or choose TeachText from the Application menu.

An untitled TeachText window appears.

2.  Type the following text:

DATE:

TO:



FROM: [Type your name here.]

RE:

3.  Choose Save from the File menu.

The dialog box that appears lets you name the document and decide where you
want the computer to store it.

If Macintosh HD does not appear above the list, click Macintosh HD above the
Eject button. 

4.  Type "Memo Pad".

Because "Untitled" is selected when the dialog box appears, all you have to
do is start typing. Whatever you type replaces the selected text.

5.  Click Save.

The window is now titled "Memo Pad" and the document has been stored on
Macintosh HD.

6.  Close the Memo Pad document.

To close the window, click the close box near the left end of the title bar,
or choose Close from the File menu.

The window closes, and TeachText remains the active program.

7.  Click the Macintosh HD icon, the Macintosh HD window, or anywhere on the
desktop.

The Finder becomes the active program, and the Macintosh HD window becomes
the active window. Among its contents is the Memo Pad document icon.

8.  Click the Memo Pad icon to select it.

9.  Choose Get Info from the File menu.

The Info window that appears contains information on the selected icon.

10.  Click "Stationery pad" near the lower-right corner so that an X appears
in the checkbox.

Clicking "Stationery pad" converts Memo Pad from an ordinary document to a
stationery pad. When you open a stationery pad, an untitled window appears
showing a blank "form" from that stationery, or a dialog box appears asking
you to name the new document.

You cannot change the stationery pad itself unless you turn it back into a
regular document. You do this by opening the stationery pad's Info window and
clicking "Stationery pad" again to remove the X.

11.  Close the Info window.

To close the window, click the close box near the left end of the title bar,
or choose Close Window from the File menu.



Note that the Memo Pad icon has changed from an ordinary document icon to a
stationery pad icon.

On your own: Fill out some stationery

Open the Memo Pad stationery pad icon and type a short memo.

Remember to click the I-beam pointer where you want your text to appear
before you start typing. Clicking in this way sets the insertion point (the
vertical blinking line).

Choose Save from the File menu, name your memo, click the Save button, and
choose Quit from the File menu.

Note that the Memo Pad stationery icon remains in the Macintosh HD window.
The icon for the memo you created (an ordinary document icon) should also be
in the window.

Remember to turn off your Macintosh if you'll be away for more than a few
hours.

Save? -- or Save As?

Choosing Save stores the changes you've made to the active document (the
document in the active window) since you opened it or since the last time you
chose Save.

Choosing Save As, on the other hand, creates a new document that includes the
changes you've made. Save As sets aside the original document without storing
the changes (in other words, the original document remains unchanged from
when you opened it or last chose Save).

After you give the new document a name, it replaces the original document in
the active window. The title bar of the active window shows the name of the
new document.

What's An Alias?

An alias is a way to represent a program or document in any folder without
having to make a copy of the file. An alias merely "points" to the original
file that it represents, so when you open an alias, you're actually opening
the original file. Any changes you make and save are stored with the original
file, so you see them when you open any of the aliases for the original file
(you can make as many aliases for a program or document as you need).

You could make copies of a program or document and put them in separate
folders, but the copies would take up much more room on your disk than a
single copy. And if you want the copies to be always exactly alike, you'd
have to make the same changes to each copy if you make any changes to one
copy.

Using aliases instead of making copies of a program or document lets you save
space on your disks.

CHAPTER 7-LEARNING MORE ABOUT YOUR MACINTOSH

You'll learn how to



- use the Balloon Help system

- use Macintosh Reference, Part II of this book

You'll also learn about

- the contents of Macintosh Reference

It will take about 20 minutes to go through this chapter.

At the end of this chapter, you'll be ready to start learning the programs
that you intend to use on the Macintosh.

Before you begin, if you turned off the Macintosh, turn it back on.

Use Balloon Help

Balloon Help explains the function or significance of icons, menus, commands,
and other features on the Macintosh screen, using balloons similar to those
you see in comic strips. The balloon points to the object it explains.

Many Macintosh programs have Balloon Help.

1.  Point to the Help icon near the right end of the menu bar.

2.  Press to pull down the Help menu.

3.  Drag to the Show Balloons command (the second item in the Help menu) so
that it is highlighted, then release the mouse button.

After you choose Show Balloons, balloons containing explanatory text appear
next to objects that you point to on screen.

4.  To show a balloon describing the Trash, point to the Trash icon.

Except for the fact that balloons appear next to objects that you point to,
the way you work is the same: you can select icons, choose commands, and so
on.

5.  Point to the Macintosh HD icon (your startup hard disk).

A balloon appears next to the icon.

6.  Click the Macintosh HD icon to select it.

You can select the icon even with the balloon showing.

7.  Point to the File menu.

A balloon appears next to the menu name.

8.  Press to pull down the File menu.

The balloon disappears when you pull down the menu.

9.  Slowly drag to the Open command so that it is highlighted, then release
the mouse button.



Notice that a balloon appears next to a command if you pause briefly as you
drag past it.

The Macintosh HD window becomes the active window. To see more balloons, you
can point to different parts of the window and to different icons in the
window.

10.  Choose Hide Balloons from the Help menu.

To choose Hide Balloons, point to the Help icon in the menu bar, press to
pull down the Help menu, drag to the Hide Balloons command so that the
command is highlighted, and release the mouse button.

Hide Balloons and Show Balloons replace each other in the Help menu (after
you choose one, the other appears in its place).

Use Macintosh Reference

Macintosh Reference, Part II, contains all the information you need to use
your computer effectively and efficiently. Unlike Part I, which is meant to
be read from beginning to end, Part II is meant to be used like a dictionary:
you turn to it when you need to look up some information, and then you read
only that information.

To help you find the information, this book has a table of contents, an
index, a glossary, and a summary. To practice using the reference, look up a
few topics that you'll probably need to know about in the near future.

1.  Find "Cleaning the mouse" under Chapter 15 in the table of contents.

2.  Go to the page that you're referred to and read about how to clean the
mouse.

3.  Use the index to find information on erasing floppy disks.

Erasing a disk is the same as initializing. 

Several index entries refer you to the information you need.

- You could look under "disks" and find "erasing."

- You could look under "erasing" and find "disks."

- You could look under "floppy disks" and find "erasing."

4.  Go to the pages that you're referred to and read about erasing disks.

Some of the pages are about initializing disks.

5.  Find "Glossary" in the table of contents.

6.  Look up "keyboard shortcuts" in the glossary.

Using keyboard shortcuts as a way of choosing commands is explained in
Chapter 5.

What's in Macintosh Reference



Part II of Macintosh Reference has almost no information on using application
programs. Your best source of information about a particular program is the
set of books and disks that came with that program.

Macintosh Reference has detailed information on

- setting up your system software

- using hard disks and floppy disks

- organizing your files

- adapting your Macintosh to your own use

- printing

- using your Macintosh on a network

- expanding your computer system

- care and maintenance

- tips and troubleshooting

The setup book that came with your computer has information on the features
specific to your particular model.

CHAPTER 8-SETTING UP YOUR MACINTOSH SYSTEM

- Setting up your computer hardware

Arranging your office

Avoiding fatigue

Adjusting your keyboard

- Setting up your system software

Installing, reinstalling, or updating system software

Starting up with a floppy disk

- Setting up your programs

Installing a program

Working with several programs at a time

Setting Up Your Computer Hardware

For information on assembling the hardware components of your computer
system, go to the setup book that came with your Macintosh.

If you're connecting your Macintosh to a printer, a modem, an external floppy
disk drive, an external hard disk drive, or other external devices, go to the
instructions that came with the device, or see Chapter 14, "Expanding Your



Macintosh System."

If you're connecting your computer to another Macintosh or to a printer on a
network, see Chapter 13, "Using Your Macintosh on a Network."

Arranging your office

Here are some guidelines for adjusting the furniture in your office to
accommodate your physical size and shape.

- Adjust the chair so your thighs are horizontal, your feet flat on the
floor, and the backs of your knees slightly higher than the seat of your
chair. (If your chair is too high for your feet to rest on the floor, use a
footrest.)

- Use a chair that supports your lower back.

- When you use the computer keyboard, your shoulders should be relaxed. Your
upper arm and forearm should form a right angle, with your wrist and hand in
roughly a straight line.

- Arrange the monitor so the top of the screen is at or slightly below eye
level when you're sitting at the keyboard.

- Position the monitor to minimize glare and reflections on the screen from
overhead lights and windows.

- Clean your screen regularly.

A variety of accessories, including document holders, keyboard trays, and
monitor stands, may enhance your comfort while using the computer.

Avoiding fatigue

These tips should help you get the most out of your work sessions with the
computer.

- Regularly change your seated position, stand up, or stretch whenever you
start to feel tired. Research indicates that frequent "micro-breaks" are
helpful in reducing fatigue and discomfort.

- Use a soft touch on the keyboard and keep your hands and fingers relaxed.
Some computer users may develop discomfort in their hands, wrists, or arms if
they do intensive work without breaks. If you begin to develop chronic pain
and discomfort in your hands, wrists, or arms, consult your physician.

- Keep two fingers (the index and middle fingers) resting lightly on the
mouse button when you use the mouse.

- Occasionally rest your eyes. From time to time focus your eyes on a distant
object. Blink often while you work.

Adjusting your keyboard

If you bought the Apple Extended Keyboard II with your Macintosh, or if your
Macintosh Classic or Macintosh LC came with its standard keyboard, you can
adjust the angle of the keyboard so that your hands and wrists are relaxed
and you're comfortable as you type.



The Macintosh Classic or Macintosh LC standard keyboard has tabs on either
side that swing out under the keyboard, changing the angle of the keyboard on
your desk.

The Apple Extended Keyboard II has a sliding tab in the back that controls
how much a bar extends under the keyboard, changing the angle of the keyboard
on your desk.

Setting Up Your System Software

Your Macintosh cannot operate without system software -- the programs and
other files that the Macintosh needs to start itself up and to run the
application programs you use. When you turn on your Macintosh, it looks for a
disk that contains the system software (in a folder called the System
Folder). Any disk that contains the system software is a startup disk.

Almost always, the startup disk is a hard disk that's inside or connected to
your computer. A floppy disk can also be a startup disk.

If your Macintosh cannot find a startup disk, it displays an icon in the
middle of the screen.

If you see this icon, you have to install system software on your computer's
internal hard disk (or an external hard disk that you turned on before you
turned on your Macintosh).

%%%  If you've already installed system software and you see this icon, you
may need to reinstall system software. See "Starting Up With a Floppy Disk".
%%%

Installing, reinstalling, or updating system software

You use the Installer program to install, reinstall, or update system
software on a hard disk that you want to be able to use as a startup disk.

*!*!  IMPORTANT:  Before you install a new version of system software, make a
backup copy of the old version on another disk in case you need it at a later
time (to run a program that is incompatible with the new version, for
example).  *!*!

When you use the Installer to update your system software, you keep any
fonts, sounds, drivers, and other files you may have installed in addition to
standard system software. (You could throw away your current System Folder
and replace it with the newer one, but then you'd lose those special files.)

Before you begin

To install, reinstall, or update system software, you need

- an initialized hard disk

- the set of Macintosh system software disks that came with your computer or
that you purchased as a separate system software kit. The Installer program
is on the disk named Install 1.

If your Macintosh is connected to a network and you have access to the
Installer program and system software on a file server or another computer,



you don't need the system software disks. You can open the Installer program
and then follow the procedure below, beginning with step 4.

If you have a hard disk that hasn't been initialized (that is, its icon
doesn't even appear on the Macintosh desktop), go to Chapter 9, "Hard Disks
and Floppy Disks," for instructions on initializing a hard disk.

!!  Warning:  If you purchased a hard disk with the A/UX operating system
installed on it, do not initialize that disk; doing so will erase A/UX. See
the instructions that came with the A/UX operating system.  !!

Installing a standard system

The Installer program's Easy Install dialog box lets you install the standard
system software on your Macintosh.

1.  Turn off your Macintosh.

2.  Insert the Install 1 disk into the internal floppy disk drive.

If your Macintosh has two floppy disk drives, you can use either one.

3.  Turn on your Macintosh.

The Installer program opens automatically.

4.  Click OK or press the Return key on your keyboard.

The Easy Install dialog box appears.

5.  Make sure that the hard disk indicated in the box is the one you want to
install system software on. If a different disk name appears, click the
Switch Disk button until the correct disk name appears.

6.  Click Install or press the Return key on your keyboard.

The Installer begins to install system software for your Macintosh model.

7.  Follow the instructions that appear on screen.

When a disk is ejected and you see a message instructing you to insert
another system software disk, insert the disk specified.

8.  When you see a message reporting that the installation was successful,
click Quit or press the Return key to quit the Installer program.

If a message reports that installation was not successful, follow the
instructions on screen to try installing again.

9.  Click Restart in the dialog box that appears when you quit the Installer.

The Macintosh restarts using the newly installed system (or using your
current startup disk if you already have one). If you want to change your
startup disk, see "Designating a Hard Disk as the Startup Disk" in Chapter 9,
"Hard Disks and Floppy Disks."

Installing a customized system



Custom installation allows you to select the combination of system files,
drivers, and other files you want for your own specific needs. You can also
use custom installation to install or update a single system software
component or to save space on your startup disk by not installing files that
you don't need.

1.  Turn off your Macintosh.

2.  Insert the Install 1 disk into the internal floppy disk drive.

If your Macintosh has two floppy disk drives, you can use either one.

3.  Turn on your Macintosh.

The Installer program opens automatically.

4.  Click OK or press the Return key on your keyboard.

The Easy Install dialog box appears.

5.  Make sure that the hard disk indicated in the box is the one you want to
install system software on. If a different disk name appears, click the
Switch Disk button until the correct disk name appears.

6.  Click the Customize button.

The custom installation box appears. All parts of the system software are
listed, and you have a choice of standard or minimal system software for each
model of the Macintosh computer.

7.  Scroll through the list of items and hold down the Shift key as you click
the items you want to install.
If you want to install a small system to conserve space on your startup disk,
click the "Minimal software" option. 

!!  IMPORTANT:  Be sure to install the system software files that your
Macintosh uses to communicate with the printers and any other devices you
use.  !!

8.  Click Install or press the Return key on your keyboard.

The Installer begins to install system software for your Macintosh model.

9.  Follow the instructions that appear on screen.

When a disk is ejected and you see a message instructing you to insert
another system software disk, insert the disk specified.

10.  When you see a message reporting that the installation was successful,
click Quit or press the Return key to quit the Installer program.

If a message reports that installation was not successful, follow the
instructions on screen to try installing again.

11.  Click Restart in the dialog box that appears when you quit the
Installer.

Make a backup copy of the System Folder or its contents on one or more floppy



disks (or on another hard disk), and keep the disks in a safe place.

If your Macintosh is running System 6, you cannot use desk accessories and
TrueType fonts supplied with System 7. Also, you may notice extra or missing
folders on any disk that contains System 7. The contents of the System 7 disk
will appear normally when you resume running System 7. 

!!  WARNING:  Your startup disk must have only one System Folder. Having more
than one System Folder on your startup disk can cause your Macintosh to
malfunction and cause you to lose information. Use the Find command (in the
Finder's File menu) to see if there is more than one System Folder on your
hard disk. !!

Starting up with a floppy disk

You need a hard disk as the startup disk to use Macintosh system software
version 7, but if you're unable to use your hard disk, you can start up your
Macintosh by inserting the Disk Tools disk in the internal floppy disk drive
and then turning on your computer. This disk contains programs that you can
use to initialize, test, and repair disks.

If your startup hard disk has malfunctioned, see "Testing and Repairing
Disks" in Chapter 9, "Hard Disks and Floppy Disks."

Setting Up Your Programs

In addition to setup information, this section describes how to work with
more than one program at a time.

Installing a program

You can install many application programs simply by copying them from the
original disk to your hard disk. (Some programs have specific installation
procedures. See the instructions that came with your program.)

!!  IMPORTANT:  Some program disks contain a System Folder. Whenever you copy
the contents of a program disk to your startup hard disk, check that you have
not copied an extra System Folder. If you have, throw away the extra System
Folder.  !!

Put only one copy of each program on your hard disk. Having more than one
copy of the same program on the disk can lead to problems when you're running
the program.

If you want to open a program automatically when you start up your Macintosh,
go to "Specifying Which Items You Want Opened at Startup" in Chapter 11,
"Adapting Your Macintosh to Your Own Use" for instructions.

You can also put a program or an alias for it in the Apple menu, so you can
open the program more conveniently. See "Installing an Item in the Apple
Menu" in Chapter 11.

!!  Important:  Keep the original program disk in a safe place as a backup
copy. If the program on your hard disk malfunctions consistently, you can
replace it with a fresh copy from your backup disk. !!

If a program malfunctions consistently, and installing a fresh copy of the
program does not correct the problem, you may need to find out from the



software manufacturer whether the version of the program you have is
compatible with the Macintosh system software you're using. (You can often
upgrade to the latest version of a program at no charge or for a modest fee.)

Checking for computer viruses

In recent years, "viruses" -- malicious programs that damage files or erase
disks -- have become a significant problem for people who use computers. A
virus can be introduced into your Macintosh system from a disk you or someone
else puts in a disk drive, from a network device such as a file server, or
from an electronic bulletin board service.

You can use any of several virus-detection and -elimination programs to check
your Macintosh disks for viruses. Such programs are available from user
groups, computer bulletin boards, and dealers.

Even if you don't notice problems with your computer's operation or with the
information on your disks, you should check for viruses frequently if you
exchange disks or information with other users.

- Whenever you get a disk from anyone -- even if it's commercial software --
check it for viruses before using it or copying anything from it to your hard
disk.

- Check your startup disk and other disks regularly with a virus-detection
program and correct any problems it finds.

- If your Macintosh is on a network or you use a modem to connect with
information services or bulletin boards, check for viruses as often as it's
practical -- ideally, each time you copy any information from an outside
source.

- If you are part of a work group that includes a number of Macintosh users,
set up a "virus-detection station" that everyone can use to check disks (and
to copy the latest version of the virus-detection software your group uses).

- If you give information to other Macintosh users on disks or send
information electronically, make certain that there are no viruses on your
computer system before distributing the information.

- Since new viruses appear regularly, make sure you have the latest version
of any virus-detection software.

- To avoid compatibility problems, be sure to use only one virus-detection
program at a time.

Working with several programs at a time

You can keep as many programs and desk accessories open at the same time as
your computer's memory allows.

All open programs are listed in the Application menu, which appears at the
right end of the menu bar. The active program's name has a checkmark next to
it, and its icon appears in the menu bar as the Application menu icon.

Switching programs.

You switch between open programs or desk accessories by choosing their names



from the Application menu in the right end of the menu bar.

If a program's icon is dimmed in the menu, that means its windows are hidden.
You can choose it from the Application menu to display its windows.

You can also click in a window that "belongs" to an open program, or double-
click a program icon (or the icon of a document that was created in the
program) to make that program the active program.

Finding out what programs are open.

If you have several programs and windows open, you can find out which program
is active and what other programs are open by pulling down the Application
menu.

Hiding and showing windows on the desktop.

You can hide all the open windows except those of the active program by
choosing the Hide Others command in the Application menu. Though hidden, the
other windows remain available.

When the command takes effect, all windows except those belonging to the
active program are hidden.

The windows remain hidden until you switch to another open program, at which
time that program's open windows are displayed. If you want to see the
windows of all your open programs, choose Show All from the Application menu.

Changing the amount of memory a program uses.

On rare occasions you may need to increase or decrease the amount of memory a
program sets aside for itself. You might want to increase the program's
memory allocation so that you can open more documents at once, or you might
want to decrease it so that you can open more programs. You can do this by
adjusting the program's memory size in its Info window.

1.  Quit the program if it's open, then click the program's icon to select
it.

2.  Choose Get Info from the File menu.

The Info window appears.

3.  Drag across the number in the box labeled "Current size" to select it.

4.  Type the number of kilobytes (K) of memory you want the program to set
aside for itself.

Making the program smaller than the amount shown in the box labeled
"Suggested size" may cause it to work more slowly or cause other problems.

5.  Close the Info window.

If you make the allocation too small, you'll see a message asking whether you
want to make it smaller than the manufacturer's suggested minimum size.

!!  Warning:  If you set the memory allocation for a program to a size that's
smaller than the manufacturer's suggested minimum size, the program may



function improperly or not at all.  !!

CHAPTER 9-HARD DISKS AND FLOPPY DISKS

In this document:

- Initializing disks

- Erasing a disk

- Designating a hard disk as the startup disk

- Protecting the information on a disk

Locking a floppy disk

Locking a file

Backing up your files

- If you can't save files on a floppy disk

- Ejecting a disk

- Disk care

Hard disk precautions

- Testing and repairing disks

Using Disk First Aid

Testing a hard disk

Initializing Disks

Before you can use a new disk, you need to initialize it -- to prepare it so
that the computer knows where to store and retrieve information on the disk.

!!  WARNING:  You lose any information you may have on a disk when you
initialize or reinitialize it.  !!

Most hard disks designed for use with the Macintosh are already initialized
(that is, ready to store information) when they leave the factory. When new,
the 3.5-inch (86-millimeter) floppy disks that your Macintosh uses need to be
intialized.

Initializing a hard disk

If you have a hard disk that hasn't been initialized, its icon does not
appear on screen when you start up your Macintosh using another hard disk or
a floppy disk as a startup disk. (See "Expanding Your Macintosh System," if
you need instructions on connecting a hard disk to your computer. See
"Setting Up Your Macintosh System," if you need to create a startup disk.)
Make sure that you turn on the hard disk before you turn on your Macintosh.

If your hard disk's icon does not appear on screen, use the Apple HD SC Setup



program, on the system software floppy disk labeled Disk Tools, to initialize
and name the disk.

!!  WARNING:  If you purchased a hard disk with the A/UX operating system
installed on it, do not initialize that disk; doing so will erase A/UX. See
the instructions that came with the A/UX operating system.  !!

1.  Locate the Apple HD SC Setup icon and open it.

Apple HD SC Setup is on the system software floppy disk labeled Disk Tools.
If you're already using a hard disk as a startup disk, you can copy the
program to your startup disk and open the program from there.

A dialog box appears. The name of the hard disk currently selected for
initialization is shown as the "volume name." The SCSI ID number of the
selected hard disk is displayed above the Drive button. (The ID number of an
internal hard disk is 0. The ID number of an external hard disk is usually
preset to 5.)

2.  If the "volume name" or the SCSI ID number shown does not belong to the
hard disk you want to initialize, click the Drive button until the hard disk
you want to initialize is the selected hard disk.

You cannot initialize your current startup disk or the disk that the Apple HD
SC Setup program is on.

3.  When the SCSI ID number (and name, if any) of the hard disk you want to
initialize is shown, click the Initialize button.

A dialog box appears in which you must confirm or cancel your decision.

4.  Click the Init button to initialize the hard disk.

Messages appear to update you on the initialization process. If a message
reports that initialization failed, begin the process again.

5.  In the dialog box that appears asking you to name the disk, type a name
and then click OK.

6.  Click Quit when the message reports that initialization was successful.

Initializing a floppy disk

Before you can use a new floppy disk, you need to initialize it -- prepare it
so that the computer knows where to store and retrieve information on the
disk.

1.  Insert your new floppy disk into the floppy disk drive.

If you inserted a high-density disk, this dialog box appears:

If you inserted a double-sided (800K) disk, this dialog box appears:

2.  Depending on which dialog box appears, click Initialize or Two-Sided.

Another dialog box appears:

This dialog box gives you one last chance to cancel. It alerts you that



you're about to erase -- and therefore lose -- any information that may be on
the floppy disk.

3.  Click Erase.

A third dialog box appears:

4.  Type the name you want for the disk.

If you make any typing errors, press the Delete key to backspace over them.

When you name a disk, you can type up to 27 characters, including spaces. You
cannot use a colon in the name. If you don't name the disk, it will have the
name "Untitled."

5.  Click OK or press the Return key on the keyboard.

The computer takes about a minute to initialize the disk. A series of
messages appears on the screen to let you know how the process is going.

When initialization is completed, the floppy disk's icon appears on the
desktop. You can rename the disk by clicking its name and typing a new one.

Erasing A Disk

Erasing a disk actually initializes it.

!!  WARNING:  You lose any information you may have on a disk when you erase
it.  !!

1.  Click the icon of the disk you want to erase.

2.  Choose Erase Disk from the Special menu.

A dialog box appears, giving you a chance to cancel the procedure.

3.  Depending on the type of disk you're erasing, click Initialize or Two-
Sided.

Designating A Hard Disk As The Startup Disk

If you use more than one startup disk with your Macintosh, you can specify
which hard disk you want used as the startup disk the next time you turn on
your computer.

1.  Choose Control Panels from the Apple menu and then open the Startup Disk
control panel.

2.  Click the icon of the disk you want to use as the startup disk.

3.  Close the Startup Disk control panel.

When you turn on your Macintosh, it looks for a startup disk (a disk
containing a System Folder) in the following sequence:

1.  internal floppy disk drive

2.  second internal floppy drive (if any)



3.  external floppy drive (if any)

4.  startup device selected in the Startup Disk control panel (if any)

5.  internal SCSI hard disk (the computer waits a few seconds for the
internal hard disk to warm up)

6.  external SCSI hard disk (if there is more than one, it looks for the hard
disk with the greatest SCSI ID number)

7.  internal hard disk (the computer returns to this drive and waits another
few seconds)

If no startup disk is found, the computer displays a blinking question mark
in the middle of the screen.

If you want to bypass the internal hard disk as a startup disk, press
Command-Option-Shift when the computer starts up. 

!!  IMPORTANT:  If you use any external hard disks, turn them on and wait a
few seconds before you turn on your Macintosh; otherwise, the computer will
not recognize them.  !!

Protecting The Information On A Disk

You can protect all the information on a floppy disk and you can lock
individual documents and application programs. Another way to protect your
work is to keep backup copies of all your files.

The information in a locked document or on a locked disk can't be changed or
thrown away, but it can be opened or copied.

Locking a floppy disk

To lock a floppy disk:

- Slide the tab on the back side of the disk so that the square hole is open.

Use your thumbnail to move the tab, or a push pin inserted into the notch
next to the tab.

Sliding the tab back so that it covers the square hole unlocks the disk.

Locking a file

You use the Get Info command to lock a document or program. Locking a program
may affect its operation.

1.  Click the icon of the file you want to lock.

2.  Choose Get Info from the File menu.

The file's Info window appears.

3.  Click the Locked box in the lower-left corner so that an X appears in the
box.



4.  Close the Info window.

Locking folders:  You can't lock a folder, but you can lock the items in a
folder. Also, you can protect the contents of folders that you're sharing on
a network. (See "Using Your Macintosh on a Network," for more information.)

Locking an alias:  You can lock an alias, but doing so does not lock the
original file. Locking an alias merely protects it from being thrown away.

Backing up your files

You can back up the work you store on a hard disk by copying individual files
onto another disk in the usual way (dragging their icons to the icon of the
other disk). You can back up the contents of an entire floppy disk by
dragging its icon to another floppy disk icon or a hard disk icon.

You can also use a commercial backup program to copy some or all files from a
hard disk to another hard disk, to a tape drive, or to a series of floppy
disks.

If You Can't Save Files On A Floppy Disk

If you can't save files on a floppy disk, then the disk is damaged or locked,
it's too full to store more information, or the disk drive is not working
properly.

- Make sure the locking tab on the back of the disk is in the unlocked
position (so that the square hole is closed).

- If you see a message reporting that the disk is not initialized, and you
know that it has been initialized, eject the disk and carefully insert it
again. If the same message appears, the disk is probably damaged. (You may be
able to recover the information on it with Disk First Aid or a disk-recovery
program; see "Testing and Repairing Disks".)

- If you see a message reporting that the disk is full, eject that disk and
insert another that has adequate space for your document, or erase unneeded
files from the disk.

- Check the disk for obvious damage to the plastic case or the sliding metal
shutter.

- Insert a different disk and try saving again. If you can't save on the
second disk, the problem may be with the disk drive.

- Before concluding that the disk drive is the problem, save your files on a
disk in a different drive, if you have one, and then restart the Macintosh.
Try using a disk that you know is not damaged in the suspect drive. See your
service provider if you still can't save any files using that drive.

Ejecting A Disk

You can eject a floppy disk by doing one of the following:

- Click the disk icon to select it and choose Put Away from the File menu.
The icon disappears from the desktop.

- Drag the disk icon to the Trash icon. The disk icon disappears from the



desktop. (Dragging a disk to the Trash does not erase the disk's contents.)

- Click the disk icon to select it and choose Eject Disk from the Special
menu. The disk's icon remains on the desktop, but it's dimmed.

You can use the first two methods to remove a hard disk icon from the
Macintosh desktop (or to remove an icon for a disk that you're connected to
over a network).

All three methods also work with CD-ROM disks.

If you can't eject a floppy disk

The signal to eject the disk is not reaching the computer or the disk or
drive is damaged.

1.  Hold down the Command and Shift keys and press the number 1 key in the
top row of the keyboard to eject a disk in the internal drive; press Command-
Shift and the number 2 to eject a disk in an external floppy drive or the
second internal drive.

2.  If step 1 doesn't work, turn off the Macintosh. If the disk isn't
ejected, then hold down the mouse button when you turn the computer on again.

3.  If step 2 doesn't work, locate the small hole to the right of the disk
drive's opening, and carefully insert the end of a large straightened paper
clip into it. Push gently until the disk is ejected. Do not use excessive
force.

4.  If step 3 doesn't work, take the computer or disk drive to your
authorized Apple service provider to have the disk removed.

Disk Care

For information on floppy disk care, see "Setting Up Your Programs," or read
the instructions that came with your floppy disks.

Hard disk precautions

Hard disk drives are very delicate mechanisms and should be handled with
care.

- Do not roughly handle a hard disk or a computer with an internal hard disk.
Never move either when it's turned on and the hard disk drive is operating.

- Do not place your Macintosh on its side unless it is designed to operate
this way; it could damage the hard disk. See your setup book to check if your
Macintosh model can be placed on its side.

- Always keep the hard disk on a sturdy, level surface.

- Operate a hard disk at temperatures between 10 and 40 degrees Celsius (50
and 104 degrees Fahrenheit) and at a relative humidity of 20 to 80 percent.

- Do not spill any liquids on or near the drive.

- Do not expose the drive to hazardous vapors, such as those from cleaning
solvents.



Testing And Repairing Disks

Both floppy disks and hard disks can become damaged from repeated use and
handling. If you see a message reporting that a disk is damaged or
unreadable, Disk First Aid or Apple HD SC Setup (both programs are supplied
with the system software) may help diagnose and correct the problem.

If you can't start up from a hard disk or don't see its icon on the desktop,
the computer does not recognize the disk or the disk drive is not working
properly.

- If the hard disk drive is an external one, make sure it is turned on and
its cable is connected firmly, then restart the Macintosh.

- If the disk drive is an internal one, turn off the Macintosh, wait at least
10 seconds, then turn it on again.

- If the hard disk is your startup disk, start up with a different disk and,
if the disk's icon appears, reinstall the system software on the hard disk.

- If you have more than one hard disk in your Macintosh system, check the
SCSI ID number of each external hard disk and all other SCSI devices
connected to your computer. If two devices have the same ID number, or if any
external device has the ID number 7 or 0, the computer will not recognize one
of the devices.

Using Disk First Aid

You can test floppy disks and hard disks with the Disk First Aid application.
Disk First Aid also repairs some types of disk damage.

1.  Locate and open the Disk First Aid icon.

Disk First Aid is on the system software disk labeled Disk Tools.

A dialog box appears.

2.  Click the Drive or Eject button as necessary until the name of the disk
you want to test appears. You may have to insert the damaged floppy disk.

3.  Click Open or press the Return key.

The name of the disk you selected appears, and a message reports that Disk
First Aid is ready.

4.  Choose Repair Automatically from the Options menu, or click the Start
button to begin testing the disk.

5.  When testing and repair are completed, choose Quit from the File menu.

If you want to test another disk, choose Close from the File menu, then
select and open the other disk (as in step 2).

If Disk First Aid doesn't correct the problem:

- Use Disk First Aid one or two more times with the disk. Occasionally,
repeating this process corrects the problem.



- Use another disk repair or recovery utility. Some disk repair utilities let
you recover information from a damaged disk.

- Consult a technician or other specialist for help.

- Once you have recovered all the information you can, erase (reinitialize)
the disk. If reinitializing doesn't work, discard the damaged disk.

Testing a hard disk

You can test a SCSI hard disk with the Apple HD SC Setup program.

1.  Locate and open the Apple HD SC Setup icon.

Apple HD SC Setup is on the system software disk labeled Disk Tools.

A dialog box appears.

2.  Click the Drive button until the name of the disk you want to test
appears as the "volume name."

3.  Click Test.

A dialog box appears asking you to confirm that you want to test the disk.

4.  Click OK.

5.  When a dialog box appears telling you that testing is complete, click
Quit.

If the test reveals a problem, you may be able to correct it by using Disk
First Aid or another disk repair utility, or you may have to reinitialize the
disk. Consult a technician or other specialist for assistance if necessary.

CHAPTER 10-ORGANIZING YOUR FILES

In this document:

- Straightening up your files

- Using folders to organize your files

Creating and naming folders

- Saving your files where you want to

- Making items easier to find

Using an alias

Installing an item in the Apple menu

Moving an item to the desktop

- Finding a file or a folder

Finding an item by name



Finding an item by other characteristics

Finding items through a two-stage search

Uses of the Find command

- Creating a template

- Getting information about your files

Using the Info window

Using the View menu

Straightening Up Your Files

Choose the Clean Up command from the Special menu to straighten up the icons
in the active window or on the desktop. (The form of the Clean Up command
changes depending on which items are active or selected.)

Hold down the Option key while choosing Clean Up Window to arrange icons
alphabetically by name or according to the list view displayed most recently
in that window. Holding down the Option key also moves the icons to the top
left portion of the window.

Hold down the Option key while choosing Clean Up Desktop to line up icons
near the right edge of the screen.

If one or more items are selected, holding down the Shift key while choosing
the Clean Up command rearranges the selected items only.

Using Folders To Organize Your Files

Like paper filing systems, the Macintosh uses folders to store and organize
documents. You can place one folder inside another to create a hierarchy of
files that has many levels.

Creating and naming folders

Most programs let you create and name a new folder in the directory dialog
box that appears when you first save a document, or when you choose Save As
from the File menu to save another version of a document.

When you're working on the desktop (when the Finder is the active program),
you create and name a new folder as follows.

1.  With the Finder the active program, choose New Folder from the File menu.

A new folder named "untitled folder" appears in the active window (or on the
desktop if no window is active). The name is already selected.

2.  Type a name for the folder and press Return.

You move, copy, and remove folders in the same way that you do any other
icons. (See the summary, "Working on the Macintosh Desktop," for
instructions.)



Saving Your Files Where You Want To

The first time you save a document that you're creating in an application
program (or whenever you choose Save As from the File menu to create another
version of a document), a directory dialog box appears. A directory is the
list of files and folders contained in a folder or a disk.

You use the directory dialog box to name your document and decide where to
store it. Directory dialog boxes vary slightly from program to program, but
every directory dialog box has certain features.

A similar dialog box appears when you choose Open from the File menu to open
a document that was created in the program you're currently in (the "active"
program). The dialog box lets you find the document and open it.

Making Items Easier To Find

Your Macintosh offers several ways to make a file, folder, or other item easy
to find and open. You can

- create aliases for the item and put the aliases wherever it's convenient
for you

- install the item in the Apple menu

- move the item to the Macintosh desktop so that it's in plain sight

Using an alias

An alias serves as a signpost to a file, a folder, a disk, or another item
(even a shared item that you access over a network). You can make as many
aliases for an item as you want. See "Organizing Your Work," for more
information on aliases.

Creating an alias

1.  Click to select the item that you want to make an alias for.

2.  Choose Make Alias from the File menu.

The alias appears on top of the original. Its name is in italics and ends
with "alias." The name is already selected.

3.  If you wish, change the name of the alias, then move it to wherever you
want to put it.

Uses of aliases

Alias of                 Location                   Purpose

Any document or        Every part of your        Access to key information
folder that could be   filing system where       from several places 
stored in several      that item logically
places                 fits

Apple Menu             On the desktop            Easy way to put items into
Items folder                                     or take items out of the 

Apple menu



A program that         On the desktop; in        Starting the program 
must be located        the Apple menu            without opening the folder
with associated                                  or disk in which the 
files                                             original and its

associated files are 
located

A document or folder   Anywhere on your          When opened, the alias
stored on a separate   primary disk or           displays a message with
archive disk           disks                     name of the disk needed,

then opens the original 
when the disk is inserted.

A program, document,   Anywhere on your          When opened, the alias 
or folder on a file    primary disk or           automatically finds and
server                 disks                     opens its original on the 

server, essentially
creating an automatic 
server connection.

Trouble?  If you open an alias and nothing happens, or you see a message
reporting that the original file isn't available, then the alias is damaged
or the original has been deleted. Open the alias's Info window to find out
where its original is.
Locating the original of an alias

You can locate the original of an alias by opening the alias's Info window.

1.  Select the icon of the alias whose original you want to find.

2.  Choose Get Info from the File menu.

The alias's Info window appears.

3.  Click the Find Original button.

The window containing the original item opens, with the item's icon
highlighted.

If you deleted the original, you'll see a message reporting that the original
can't be found. Aliases are not deleted when the original files are deleted.

Installing An Item In The Apple Menu

You can install a file or other item in the Apple menu so you can open it by
choosing it from the menu.

1.  Open the System Folder icon and locate the Apple Menu Items folder.

2.  Locate the item you want to install in the Apple menu and drag it (or its
alias) into the Apple Menu Items folder inside the System Folder.

The item appears immediately in the Apple menu.

You remove an item from the Apple menu by opening the Apple Menu Items folder
and dragging its icon (or its alias) out of the folder.



Trouble?  If the Apple menu does not contain the items it should, make sure
that the Apple Menu Items folder is in the System Folder of your startup
disk. Also, open the Apple Menu Items folder to check that all the items that
you want in the menu are in the folder.

Moving an item to the desktop

You can make an item easy to find by dragging its icon to the desktop. The
icon stays there until you remove the disk on which the item is actually
stored.

If you've placed an icon on the desktop, you can put it back in its original
location by using the Put Away command.

1.  Click to select the item you want to put back in its original location.

2.  Choose Put Away from the File menu.

Finding A File Or A Folder

When the Finder is the active program, you can use the Find command in the
File menu to find a file or folder on any disk whose icon is on the desktop.
(The Find command cannot locate items inside the System file, such as fonts
and sounds. You must open the System file to see its contents.)

Finding an item by name

1.  Choose Find from the File menu, or press Command-F.

The dialog box that appears lets you find a file or a folder by searching for
its name.

2.  Type the name (or part of the name) of the file or folder you want to
find.

It doesn't matter whether you capitalize any letters, as long as the letters
or numbers you type are in the name of the item you're looking for.

3.  Click the Find button.

The first item that matches the name (or partial name) you typed is shown
highlighted in a Finder window. If no item is found, your Macintosh makes the
alert sound.

4.  To see the next matching item, choose Find Again from the File menu, or
press Command-G.

If no more items are found, your Macintosh makes the alert sound.

Finding an item by other characteristics

You can use the Find command to find a file or a folder by searching for its
size, its label, the date it was created or modified, or other
characteristics.

1.  Choose Find from the File menu.

The Find dialog box appears.



2.  Click the More Choices button.

The dialog box that appears lets you set different search characteristics
through pop-up menus that together form a search order.

The content of the middle pop-up menu and the text area vary according to the
item selected in the left pop-up menu.

3.  Press the pop-up menu on the left to open it, drag to choose an item, and
then release the mouse button.

4.  Press the pop-up menu in the middle to open it, drag to choose an item,
and then release the mouse button.

5.  Adjust the date, choose an item, or type text in the upper-right area of
the dialog box.

6.  Choose a search location from the pop-up menu labeled "Search."

You can choose to search all disks, a specific disk, or the active Finder
window.

7.  If you want all found items displayed at once, click the checkbox labeled
"all at once" so that an X appears.

8.  Click the Find button when you've finished setting your search
characteristics.

The first item that matches your search characteristics is shown highlighted
in a Finder window. To see the next item found, choose Find Again from the
File menu (or press Command-G).

When the items found are displayed all at once, they are shown highlighted in
one or more Finder windows.

Finding items through a two-stage search

You can use two sets of characteristics and locate the items that meet both
sets of characteristics.

1.  Choose the first set of characteristics you want to search for.

2.  Click the "all at once" box so that an X appears.

Checking "all at once" displays the items found highlighted in a list.

3.  Click the Find button.

The items found are shown highlighted in a Finder window.

4.  Choose the Find command again, before you click or take any other action.

You choose Find before taking any other action so the items located in the
first stage of the search remain highlighted.

5.  Choose the second set of characteristics you want to search for.



6.  Choose "the selected items" in the Search pop-up menu.

7.  Click Find to begin the second stage of your search.

The search is limited to the items found in the first stage, and only those
matching both sets of characteristics are highlighted.

Uses of the Find command

The Find command can help you locate files quickly, organize large quantities
of documents, and develop an efficient system for backing up and archiving
your work.

Search characteristic     Can be used to locate

Name                      1.  Files whose names you can't recall 
exactly

2.  All items for which you use a standard name, 
such as status reports or expense reports

Kind                      1.  All application programs
2.  All aliases

Size                      Large files, to make space available on a disk

Label                     All the files to which you added the same 
label (such as "top secret" )

Lock                      Locked files, to unlock them for editing

Modification date         All files changed since a certain date, for 
regular backup of new and changed files

Creation date             All files created before a certain date, for 
archiving or erasing outdated material

Creating A Template

Most documents can be saved as or converted into a stationery pad, which is a
template form of the document. The template retains the format and content it
had at the time you made it into stationery, and you can use it repeatedly as
a master for similar documents.

Many application programs let you save a document as a stationery pad when
you first save the document or choose Save As from the File menu. If the
directory dialog box that appears has a stationery pad option, you can click
it to save your new document as a template.

If the program you're using does not offer a stationery pad option, you can
use a document's Info window to create a stationery pad.

1.  Click to select the icon of the document you want to use as a template.

2.  Choose Get Info from the File menu.

3.  Click "Stationery pad" near the lower-right corner so that an X appears
in the checkbox.



Clicking "Stationery pad" converts the document from an ordinary document to
a stationery pad.

4.  Close the Info window.

The document icon has changed into a stationery pad icon.

When you open a stationery pad, an untitled window appears showing a blank
"form" from that stationery, or a dialog box appears asking you to name the
new document.

You cannot change the stationery pad itself unless you turn it back into a
regular document. You do this by opening the stationery pad's Info window and
clicking "Stationery pad" to remove the X.

Getting Information About Your Files

When you're working on the desktop, you can choose the Get Info command from
the File menu to get information about a file, such as when a document was
created or how much memory a program needs.

You can also use the View menu to see certain types of information about the
files listed in a Finder window.

Using the Info window

The Get Info command displays information about a selected item in a window.

1.  Click to select the item you want information about.

2.  Choose Get Info from the File menu, or press Command-I.

Besides getting information, you can use the Info window to lock a file (so
it can't be changed or thrown away), turn a document into a stationery pad,
change a program's memory allocation, and change the file's icon. (See
"Adapting Your Macintosh to Your Own Use," for information on the last two
procedures.)

You can type comments in the Info window and later search for them with the
Find command.

3.  Click the close box.

Using the View menu

You can use the View menu to display the contents of a window by icon or
small icon, or you can list them according to name, size, kind, date, or
label. (See "Adapting Your Macintosh to Your Own Use," for information on
using the Views control panel to change how files are listed and what
information is included.)

Windows are set to show items in the icon view. One of the list views (name,
size, kind, label, or date) is useful when you have too many files to see
easily as icons or if you want your files arranged according to a particular
attribute. For example, listing documents by the date and time of their most
recent modification makes backing up files an orderly task.

When the contents of a window are displayed as a list and you want them



arranged in another list view, you don't have to use the View menu. You can
click a column heading (such as Size or the Last Modified date) to rearrange
the list according to that heading.

See the summary, "Working on the Macintosh Desktop," for information on using
a list view to select items in different folders.

CHAPTER 11-ADAPTING YOUR MACINTOSH TO YOUR OWN USE

In this document:
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- Installing an item in the Apple menu

- Installing files in the System Folder

- Changing the items in the Label menu

- Setting the time and date

- Setting a time for the Alarm Clock to go off

Turning the alarm off

- Adjusting the way the mouse works

- Adjusting the way the keyboard works

Controlling the pointer from the keyboard

Making keyboard shortcuts easier to type

Adjusting the keyboard for very slow typing

- Setting the alert sound

Installing a sound

Removing a sound

Recording sounds

- Changing the desktop pattern

- Adjusting the blinking of a menu item

- Adjusting the blinking of the insertion point

- Changing the way the contents of windows appear

- Changing the appearance of icons

Changing an icon

Assigning a label and a color to an icon



- Changing the highlight color

- Changing the color of windows

- Displaying colors or grays

- Configuring multiple monitors

- Adjusting screen brightness

- Magnifying the screen image

- Turning off the Empty Trash warning

- Managing memory

Specifying Which Items You Want Opened At Startup

To have a file (a program or a document) open automatically when you start up
your Macintosh, drag the file's icon or its alias to the Startup Items
folder, which is inside the System Folder. Any programs or documents (or
their aliases) that you put in the Startup Items folder are opened when you
start up your Macintosh. You can have as many files open automatically as
your computer's memory allows.

If you no longer want a file to open automatically when you start up your
Macintosh, remove the file's icon or its alias from the Startup Items folder.

Installing An Item In The Apple Menu

To have a program, document, or other item appear in the Apple menu, drag the
item's icon or its alias to the Apple Menu Items folder, which is inside the
System Folder.

You remove an item from the Apple menu by opening the Apple Menu Items folder
and dragging the item's icon (or its alias) out of the folder.

Installing Files In The System Folder

Certain types of programs and other files need to be installed in the System
Folder so your Macintosh can use them as part of the system software. These
files include

- system extensions and control panels (also called INITs and CDEVs)

- files of preferences for application programs

- drivers for printers, scanners, and other devices

- sounds (instructions for installing sounds)

- fonts (see "Printing," for instructions on installing fonts)

Usually, you install these files by dragging their icons to the System Folder
icon (not the System Folder window). Sometimes these files are installed
using an installer program that comes with the files. Check the instructions
that came with the files for any specific installation procedure.



These files are stored in specific folders inside the System Folder. When you
drag a file's icon to the System Folder icon, your Macintosh recognizes which
type of file it is and stores the file in the appropriate folder.

If you drag one of these files to the System Folder window instead of the
System Folder icon, the file is not stored in the appropriate folder
automatically. Items you want in the Apple Menu Items folder or the Startup
Items folder inside the System Folder need to be dragged to either folder
directly. (See the instructions in this chapter for installing Apple menu
items and specifying the files you want opened at startup.)

Removing files from the System Folder

You remove a file from the System Folder by dragging its icon out of the
System Folder.

Depending on the external devices you use, whether or not you're on a
network, and how you use your Macintosh, you can remove the following types
of files from your System Folder if you want to conserve space on your
startup disk:

- drivers for printers or other devices you don't use (for example, the
AppleTalk ImageWriter driver)

- networking drivers, if you are not on a network (such as AppleShare
software)

- Apple menu items you don't use (you need the control panels, but you may
not need the Calculator or the Puzzle, for example)

- extra fonts, sounds, or keyboard files you have installed

Be sure you have backup copies of the files on floppy disks before you remove
them from your System Folder.

Changing The Items In The Label Menu

You can change the labels (and colors, if your monitor displays colors or
shades of gray) available in the Label menu. You make these changes in the
Labels control panel (choose Control Panels from the Apple menu and open the
Labels control panel).

To change a label, drag across it to select it and then type your new label.

To change a color:

1.  Click the color you want to change.

The color wheel dialog box appears.

2.  Click a color on the color wheel to select it.

The new color is displayed in the top half of the color square. The current
color remains in the bottom half of the square for comparison.

3.  To experiment with other colors or shades, drag the pointer around the
wheel or click at another point on the wheel.



The new color is displayed in the upper half of the color square as you drag
or click.

4.  Click OK when you have selected the color you want.

The color wheel dialog box closes.

5.  Close the Labels panel.

The labels and colors you choose remain in effect until you change them.

Setting The Time And Date

Your Macintosh has a clock that keeps track of the time and date (a battery
keeps it running when the computer is turned off).

Many programs rely on the clock to automatically enter times and dates in
documents you create or print, so sooner or later you will need to set the
clock to the current time and date.

1.  Choose Control Panels from the Apple menu.

The Control Panels window appears, showing you the different control panels
that are installed in your System Folder.

2.  Open the General Controls panel.

The General Controls window appears. The time and date adjustments are in the
lower-right corner.

3.  If you want to change the way the time is displayed (12-hour or 24-hour),
click the appropriate button.

The 12-hour format uses a.m. and p.m.; the 24-hour format does not (1:30 p.m.
is displayed as 13:30).

4.  Click the hours, minutes, or seconds in the time display to select them.

Up and down arrows appear to the right of the time display.

5.  Click the up or down arrows repeatedly until the current hour, minute, or
second appears.

6.  Repeat steps 4 and 5 as necessary to set the entire time display.

7.  Click the clock icon (above the time display) to set the current time.

8.  In the date display, click the month, day, or year to select it.

Up and down arrows appear to the right of the date display.

9.  Click the up or down arrows repeatedly until the current month, day, or
year appears.

10.  Repeat steps 8 and 9 as necessary to set the entire date display.

11.  Click the calendar icon (next to the word "Date") to set the current



date.

12.  Close the General Controls window.

You can also set the time and date in the Alarm Clock, which you open by
choosing Alarm Clock from the Apple menu.

Setting A Time For The Alarm Clock To Go Off

You can set the Alarm Clock to alert you when it's time for an appointment or
a meeting.

1.  Choose Alarm Clock from the Apple menu.

The Alarm Clock opens.

2.  Click the upward-pointing lever near the upper-right corner to expand the
Alarm Clock.

The lever points downward, and the Alarm Clock expands to its full size.

3.  Click the alarm clock icon in the lower-right corner to select it.

The alarm clock icon is highlighted when you select it. The time that appears
in the middle section is the current alarm clock setting.

4.  Click the hours, minutes, or seconds in the alarm clock setting to select
them.

Up and down arrows appear to the right of the time display.

5.  Click the up or down arrows repeatedly until the hour, minute, or second
when you want the alarm to go off appears.

6.  Repeat steps 4 and 5 as necessary.

7.  Click the button to the left of the alarm clock setting to turn the alarm
on.

When you click, the button moves up and the alarm clock icon changes to
indicate that the alarm is turned on. (Clicking again turns the alarm off.)

8.  Click the close box to close the Alarm Clock.

The alarm will not go off unless you close the Alarm Clock or click the lever
to make the alarm clock smaller, click elsewhere in the clock, or make
another window active.

Turning the alarm off

When the system clock reaches the time set for the alarm, the alert sound
plays twice (the menu bar flashes once if the speaker volume is set to zero)
and an alarm clock icon blinks over the Apple icon at the left end of the
menu bar.

To turn off the alarm, choose Alarm Clock from the Apple menu and click the
button to the left of the alarm clock setting so that the button moves down.



Adjusting The Way The Mouse Works

You can adjust two aspects of mouse operation in the Mouse control panel:
tracking, which is the relation between mouse movement on your desk and
pointer movement on the screen, and double-clicking speed.

1.  Choose Control Panels from the Apple menu.

2.  Open the Mouse control panel.

3.  Click the tracking speed you want.

If you click Fast, the pointer moves more than twice as fast as you move the
mouse. The Very Slow option is useful for drawing with the mouse or a
graphics tablet because the pointer moves at a constant speed relative to
mouse movement.

Your choice takes effect immediately and remains in effect until you choose a
different tracking option.

4.  Click the double-clicking speed you want.

You may have to adjust the double-clicking speed if your Macintosh often
interprets two clicks as a double click, or a double click as two single
clicks.

Your choice remains in effect until you choose a different double-clicking
speed.

Adjusting The Way The Keyboard Works

You can adjust the rate at which a character repeats when its key is held
down as well as the delay before the character begins repeating. You can also
change the keyboard layout.

1.  Choose Control Panels from the Apple menu.

2.  Open the Keyboard control panel.

3.  To adjust the rate at which a key repeats when it is held down, click the
button for the rate you want.

After you close the control panel, your choice remains in effect until you
change it.

4.  To adjust the delay before keys repeat, click the button for the delay
you want.

If the keys repeat when you don't want them to, you should adjust the
keyboard's sensitivity to your touch by setting a longer delay before a
character begins repeating. (If you click the Off button, the keys don't
repeat at all.)

After you close the control panel, your choice remains in effect until you
change it.

5.  To change the keyboard layout, click the name of the keyboard layout you
want to use.



Depending on which country you bought your Macintosh in, you may have a
choice of more than one keyboard layout. (Additional keyboard layouts are
available from various sources, and you install them in the System Folder as
you would fonts or sounds.)

After you close the control panel, your choice remains in effect until you
change it.

6.  Close the Keyboard control panel.

Controlling the pointer from the keyboard

With a Macintosh system software feature called Mouse Keys, you can use the
numeric keypad on the right side of the keyboard (instead of the mouse) to
control the movement of the pointer on the screen.

To turn Mouse Keys on, press Command-Shift-Clear (the Clear key is on the
numeric keypad).

To turn Mouse Keys off, press Clear.

With Mouse Keys on, you can click, drag, and perform all the usual mouse
actions from the numeric keypad. The 5 key serves as the mouse button: press
once to click; press twice to double-click. The 0 key locks the mouse button
down for dragging. The decimal point key (to the right of 0) or the 5 key
unlocks the mouse button.

You can adjust how quickly the pointer moves on the screen and how long the
delay is before the pointer starts moving when you press a mouse key. You
make these adjustments in the Easy Access control panel (choose Control
Panels from the Apple menu and open Easy Access).

Making keyboard shortcuts easier to type

With the Macintosh system software feature called Sticky Keys, you can type
keyboard shortcuts (such as Command-S for the Save command) without actually
pressing the keys simultaneously.

To turn Sticky Keys on or off, press the Shift key five times without moving
the mouse.

With Sticky Keys on, you can type a keyboard shortcut by first pressing the
modifier key (Command, Option, Control, or Shift) and then pressing the
character key. An icon in the right end of the menu bar (to the right of the
Application menu icon) changes to indicate whether Sticky Keys is on and
whether a modifier key has been pressed or locked.

You can have Sticky Keys make an alert sound when a modifier key is pressed.
You set this option in the Easy Access control panel (choose Control Panels
from the Apple menu and open Easy Access).

Adjusting the keyboard for very slow typing

The Macintosh system software feature called Slow Keys lets you type very
slowly and ignores accidental keystrokes by delaying the acceptance of the
next keystroke.



To turn Slow Keys on or off, hold down the Return key for about four seconds,
until an alert sound indicates that the feature is on or off.

You can adjust how long you want Slow Keys to delay acceptance of the next
keystroke. You can also set Slow Keys to make an audible click each time a
key is pressed. You make these adjustments in the Easy Access control panel
(choose Control Panels from the Apple menu and open Easy Access).

Setting The Alert Sound

Many programs have the Macintosh make a sound, called the alert sound, when
your attention is required or when you're giving a command or attempting an
action that the computer cannot recognize or perform at that time.

You can choose among several sounds that you want the Macintosh to make. You
can also set the sound's volume.

1.  Choose Control Panels from the Apple menu.

2.  Open the Sound control panel.

The Sound window appears. The alert sound that your computer is currently
using is already selected.

3.  Click the alert sound that you want the Macintosh to use.

When you click a sound to select it, it's played at the current volume
setting.

Your Macintosh may have sounds installed in addition to those shown here. It
may also have additional features in its Sound control panel, such as
controls for recording sounds. See "Recording Sounds" for information on
recording sounds. For information on any additional features, go to the setup
book that came with your Macintosh.

4.  Drag the slide control up or down to set the volume level.

If you want to be alerted silently:  Drag the slide control to zero. Instead
of hearing an alert sound, you'll see the menu bar flash.

5.  Close the Sound control panel.

Installing a sound

The Macintosh comes with a standard set of alert sounds. You can get
additional sounds from various sources. To install a sound, you drag its icon
to the System Folder icon (not the System Folder window). The sound is
automatically installed in the System file, where it belongs.

Once you add a sound to the System file, it is listed in the Sound control
panel.

Removing a sound

You can remove sounds in the Sound control panel. Make sure you have a backup
copy of the sounds on floppy disk before you remove them from your Macintosh
system.



1.  Choose Control Panels from the Apple menu.

2.  Open the Sound control panel.

3.  Click to select the sound you want to remove.

Make sure you select the correct sound. You cannot undo the next step.

4.  Choose Cut or Clear from the Edit menu.

5.  Close the Sound control panel.

You can also remove a sound by dragging its icon out of the System file and
out of the System Folder. If your Macintosh can record sounds, you can remove
a sound by clicking to select it and then clicking the Remove button.

Recording sounds

Some Macintosh models (such as the Macintosh LC) can accept and process sound
input. These computers come with a sound input port, to which you can connect
either a microphone (to record sounds that you create) or a phono jack
adapter (to record sounds from another audio source such as a compact disc or
an audio cassette).

You can record a sound and add it to your available alert sounds in the Sound
control panel. Make sure you've connected a microphone to your Macintosh as
described in the setup book that came with your computer.

1.  Choose Control Panels from the Apple menu.

2.  Open the Sound control panel.

The Sound control panel appears. Icons representing the available sound input
devices appear near the bottom of the window.

3.  Click the icon that represents the sound input device you want to use.

4.  Click the Add button.

A dialog box that looks like the controls of a tape recorder appears.

5.  To record your new sound, click the Record button.

Recording begins immediately; you have ten seconds to record your sound.
There is no recording volume control.

6.  Click Stop to stop recording.

7.  To listen to the sound you recorded, click Play.

8.  To save the sound you recorded, click Save.

A dialog box appears in which you name your new sound.

9.  Type a name for the sound.

10.  Click OK.



The new sound appears in the Alert Sounds list in the Sound control panel.

When you're finished recording new sounds, close the Sound control panel.

Changing The Desktop Pattern

You can change the pattern that appears on the Macintosh desktop in the
General Controls panel.

1.  Choose Control Panels from the Apple menu.

2.  Open the General Controls panel.

You can choose from a variety of patterns provided for the Macintosh desktop,
or you can create your own design by editing one of the patterns supplied. If
your Macintosh can display colors or shades of gray, you can also select your
own colors to use in the pattern.

3.  To see the patterns available, click either of the small triangles at the
top of the miniature desktop on the right side of the Desktop Pattern area.

The pattern changes each time you click.

4.  To choose a pattern, click the miniature desktop to see the new pattern
on your desktop.

The new pattern replaces the current pattern for the desktop. The desktop
pattern remains in effect until you change it.

5.  To edit a pattern, click in the square to the left of the miniature
desktop.

Each dot in the square changes color when you click it. Your changes are
displayed in the miniature desktop.

6.  To use another color, click the color in the color bar (under the words
"Desktop Pattern") to select it, then click the dots you want to change.

You can also change the color of an existing pattern by double-clicking a
color in the color bar and choosing a new color from the color wheel in the
dialog box that appears.

7.  When you've finished creating your new pattern, click in the miniature
desktop to display the pattern on your desktop.

By double-clicking in the miniature desktop, you can save the new pattern.
Otherwise it is lost when you display another pattern in the miniature
desktop.

Adjusting The Blinking Of A Menu Item

You can change the number of times a menu item blinks when it's chosen. You
make this adjustment in the General Controls panel (choose Control Panels
from the Apple menu and then open the General Controls panel).

To adjust menu blinking, click the button for the number of times you want



the menu item to blink. Clicking the Off button prevents a menu item from
blinking.

The option you selected remains in effect until you change it.

Adjusting The Blinking Of The Insertion Point

You can adjust how quickly the insertion point blinks (the insertion point
indicates where any text you type will appear). You make this adjustment in
the General Controls panel (choose Control Panels from the Apple menu and
then open the General Controls panel).

To adjust the blinking of the insertion point, click the button for the
blinking rate you want.

When you click, the insertion point in the control panel shows the rate of
blinking you selected.

The option you selected remains in effect until you change it.

Changing The Way The Contents Of Windows Appear

You can change the way the contents of Finder windows are displayed in the
different views available from the View menu (icon view, small icon view, and
the list views by name, size, kind, label, and date). You make these changes
in the Views control panel (choose Control Panels from the Apple menu and
open the Views control panel).

Use the Views control panel to change

- the font and font size used in all views (press to open the pop-up menu,
then drag to choose a font or a size)

- the arrangement of icons or small icons in icon and small icon views

- the size of icons used in list views

- what information is included in list views, including folder sizes and the
amount of available space on disk

The options you select remain in effect until you change them. (See the
summary, "Working on the Macintosh Desktop," for more information about using
windows and list views.)

Changing The Appearance Of Icons

You can customize icons by changing the icons themselves. If your Macintosh
displays color or shades of gray, you can have icons appear in a specific
color that's associated with a label.

Changing an icon



In a graphics program, you can create or copy the picture you want to use as
an icon, and then paste it into an icon's Info window.

Some icons can't be changed, including those for control panels and other
parts of the system software. Every icon fits inside a 32-pixel square. (A
pixel, or picture element, is the smallest dot you can draw on the screen.)

1.  In a graphics program, select the picture you want to use for the icon.

2.  Copy the picture by choosing Copy from the Edit menu.

3.  Switch to the Finder, then click to select the icon you want to change.

4.  Choose Get Info from the File menu.

The icon's Info window appears.

5.  Click the icon at the upper-left corner of the Info window to select it.

A box appears around the icon when it's selected. If no box appears when you
click, the icon can't be changed.

6.  Choose Paste from the Edit menu.

The picture you copied replaces the selected icon in the Info window. If the
picture is bigger than the icon, it automatically shrinks to fit.

7.  Click the close box to close the Info window.

You can change an icon back to its original by clicking the picture in the
upper-left corner of the Info window and choosing Cut from the Edit menu.

Assigning a label and a color to an icon

You can add a label and its associated color to each icon. A label is
different from the icon's name. The label is visible only when the contents
of a window are displayed as a list. The associated color is visible whenever
the Macintosh is set to display colors or grays.

Labels provide a way to group related files (choose By Label from the View
menu). If you have a color monitor, you can identify related icons by
assigning a label and its color to each group.

To assign a label and color to an icon, click the icon to select it and then
choose the label (and its color) that you want from the Label menu.

Changing The Highlight Color

If your Macintosh displays colors or shades of gray, you can change the color
your Macintosh uses to highlight selected text on the screen. You make this
adjustment in the Color control panel (choose Control Panels from the Apple
menu and open the Color control panel).



You can also use the Color control panel to change the color of window
borders (go to "Changing the Color of Windows").

1.  Press the "Highlight color" pop-up menu to open it and drag to choose a
color or choose Other.

If you choose a color, it appears in the "Sample text" box when you release
the mouse button.

If you choose Other, the color wheel dialog box appears.

2.  To change the brightness of the color wheel, drag the scroll box up or
down.

3.  Click a color on the color wheel to select it.

The new color is displayed in the top half of the color square if your
monitor is set to display 16 or more colors or grays. The current color
remains in the bottom half of the square for comparison; you can click there
to go back to it.

4.  To experiment with other colors or shades, drag the pointer around the
wheel or click at another point on the wheel.

The new color is displayed in the upper half of the color square as you drag
or click.

5.  Click OK when you have selected the color you want.

The dialog box closes. The new highlight color is displayed in the "Sample
text" box in the Color control panel.

The highlight color you specified takes effect immediately and remains in
effect until you change it.

Changing The Color Of Windows

If your Macintosh displays colors or shades of gray, you can change the color
of window borders. You make this adjustment in the Color control panel
(choose Control Panels from the Apple menu and open the Color control panel).

You can also use the Color control panel to change the color your Macintosh
uses to highlight selected text on the screen (go to "Changing the Highlight
Color").

To change the color of window borders, press the pop-up menu labeled "Window
color" to open it and then drag to choose a new color.

The color you choose takes effect immediately and remains in effect until you
change it.

Displaying Colors Or Grays



If your Macintosh displays colors or shades of gray, you can designate the
number of colors or shades of gray you want displayed. (How many colors or
shades your Macintosh can display depends on the video capability it has. See
the setup book that came with your Macintosh and the instructions that came
with your monitor for more information.)

You set the number of colors or grays in the Monitors control panel (choose
Control Panels from the Apple menu and open the Monitors control panel).

You also use the Monitors control panel to configure your monitors if you
have more than one (go to "Configuring Multiple Monitors").

1.  If you have more than one monitor, click the icon of the monitor whose
colors you want to adjust.

A dark border appears around the icon to show that it is selected.

2.  Click the Grays or the Colors button.

Some monitors can display only shades of gray, even if you click the Colors
button.

3.  Click the number of colors or shades of gray you want displayed on the
selected monitor (or click Black & White).

Your changes take effect immediately. The number of colors or shades of gray
you specified remains in effect until you change it.

If your Macintosh has built-in video (you didn't have to install a video card
in your Macintosh before you could connect a monitor), increasing the number
of colors or grays you want displayed increases the amount of memory your
Macintosh uses for its video display and decreases the amount of memory
available to run your programs. Your programs' performance may suffer as a
result. If you want to change the amount of memory set aside for video, click
the Options button in the Monitors control panel and click the appropriate
buttons in the dialog box that appears. 

Configuring Multiple Monitors

If you use more than one monitor with your Macintosh, you need to indicate
the monitors' positions and designate one as the main monitor (the one that
displays the menu bar).

You make these adjustments in the Monitors control panel (choose Control
Panels from the Apple menu and open the Monitors control panel).

You also use the Monitors control panel to set the number of colors or shades
of gray you want displayed (go to "Displaying Colors or Grays").

1.  Check the ID numbers of your monitors by clicking the Identify button.

A large number appears in the center of each monitor's screen; it corresponds
to the number of the icon in the control panel.

The ID numbers help you identify which icon belongs to which monitor.



2.  Decide which monitor is your main monitor and drag the menu bar to the
top of that monitor icon.

The menu bar snaps to the top of that monitor icon when you release the mouse
button.

If one of your monitors displays colors or shades of gray, you may want to
make it the main monitor so you can use the color capabilities of your
programs and of the Finder.

If your monitors are different sizes, you may want to make the largest one
the main monitor because some programs limit their window size to the size of
the main monitor.

3.  Drag the icons of the other monitors to their positions relative to the
main monitor.

To avoid becoming disoriented when you're using the monitors, position the
monitor icons so that they correspond to their actual positions on your desk.

The pointer can cross from one screen to another where the monitors' icons
touch in the control panel.

4.  Choose Restart from the Special menu.

The positions you specified remain in effect until you change them and
restart your computer.

Adjusting Screen Brightness

Most Macintosh models have brightness and contrast dials on the monitor or a
brightness dial on the computer itself. See the setup book that came with
your computer or the instructions that came with your monitor for more
information.

A few models do not have brightness and contrast dials. If your Macintosh
does not have such dials, you adjust screen brightness in the Brightness
control panel (choose Control Panels from the Apple menu and open the
Brightness control panel).

To adjust screen brightness in the Brightness control panel, drag the slider
control to the left or the right.

Tip:  Turn down the brightness if you'll be away from your computer for a
while. If an image is left on the screen for several hours or more, it may
begin to "burn in" and damage the screen. You can use "screen saver"
programs, available from various sources, to dim the screen automatically or
display a moving image after a set period of inactivity.

Magnifying The Screen Image

The CloseView control panel lets you magnify the image on your Macintosh
screen up to sixteen times. It is supplied on one of the Macintosh system
software disks.



CloseView is not automatically installed by the Installer program when you
install system software.

To install CloseView:

1.  Locate the CloseView control panel.

2.  Drag the CloseView icon to the System Folder icon (not the System Folder
window) on your startup disk.

3.  Choose Restart from the Special menu.

To turn CloseView on or off, press Command-Option-O.

To turn the magnification on or off, press Command-Option-X. (When CloseView
is on and the magnification is off, a rectangle on the screen indicates which
area will be magnified. You can move the rectangle by moving the pointer.)

To increase or decrease magnification, press Command-Option-Up Arrow or
Command-Option-Down Arrow.

You can set additional options in the CloseView control panel (choose Control
Panels from the Apple menu and open the CloseView control panel):

Turning Off The Empty Trash Warning

When you choose Empty Trash from the Special menu, a dialog box appears
warning you that you will not be able to recover the contents of the Trash
once it's emptied. (The warning helps you avoid throwing away items
unintentionally.)

You can turn off this warning in the Trash's Info box.

1.  Click the Trash icon to select it.

2.  Choose Get Info from the File menu.

3.  Click the checkbox labeled "Warn before emptying" to remove the X.

To turn the warning back on, click the checkbox so that an X appears.

You can also override the Empty Trash warning when it is on by holding down
the Option key when you choose the Empty Trash command.

Until you choose the Empty Trash command, items in the Trash continue to
occupy space on your disk.

Managing Memory

Occasionally you may need to make adjustments in how your Macintosh uses its
random-access memory (RAM) in order to work efficiently with large programs
or with several programs at once.



Checking memory use

You can find out how much memory your Macintosh has, how much of it is not
being used, and how much memory is being used by each program you have open.
You find this information by making the Finder the active program and
choosing About This Macintosh from the Apple menu.

Your Macintosh must have at least 2 megabytes (MB), or 2048 kilobytes (K), of
RAM to use System 7.

You can adjust how much memory a program sets aside for itself when you open
it (go to "Setting Up Your Programs", "Setting Up Your Macintosh System," for
instructions).

If you're unable to open a program or use network services such as printers
or electronic mail, you may have to quit from one or more programs to free
some memory for what you want to do. You can also restart your Macintosh to
reset the way its memory is being used.

Adjusting the disk cache

The disk cache is memory set aside to help programs work more quickly and
efficiently. The memory in the disk cache is not available for opening more
programs or documents, so the size of the disk cache affects how many files
you can have open at the same time.

The preset and maximum sizes of the disk cache depend on the amount of memory
your Macintosh has. If you often want to open more programs than memory
allows, set the disk cache to a smaller size -- such as 32K or 64K.

You set the size of the disk cache in the Memory control panel (choose
Control Panels from the Apple menu and open the Memory control panel).

To set the size of the disk cache, click the up or down arrows next to the
Cache Size box. The new size takes effect after you restart your Macintosh
and remains in effect until you change it.

Depending on your Macintosh model, you also use the Memory control panel to
adjust how virtual memory is used and to turn 32-bit addressing on or off
(see "Using Hard Disk Space as Memory" and "Turning On 32-bit Addressing").

Using hard disk space as memory

Some Macintosh models can use space on a hard disk to increase the computer's
memory. The disk space, called virtual memory, is not available for storing
information when it is being used for this purpose.

Your Macintosh should contain enough built-in memory for your regular needs -
- that is, for the programs you frequently have open simultaneously. You can
use virtual memory when you want to open additional programs or to work with
extremely large documents that can't be opened while using only the built-in
memory.



Virtual memory is more effective when you are using several small programs
simultaneously. It is less effective when using one very large program.

If your Macintosh can use virtual memory, you can adjust its use of virtual
memory in the Memory control panel (choose Control Panels from the Apple menu
and open the Memory control panel).

You also use the Memory control panel to adjust the size of the disk cache
and (depending on your Macintosh model) to turn 32-bit addressing on or off
(see "Adjusting the Disk Cache" and "Turning On 32-bit Addressing").

1.  Click the On button to turn on virtual memory.

The Select Hard Disk pop-up menu becomes active (black) when you click On.

2.  Press the pop-up menu to open it and drag to choose the hard disk on
which space will be allocated for virtual memory.

3.  Click the up and down arrows to adjust the amount of disk space to be
used as virtual memory.

The Memory control panel is preset to allot the same amount of virtual memory
as the amount of RAM installed in your Macintosh. Choosing a larger amount of
virtual memory is likely to slow the computer's performance.

It is recommended that you accept the preset size. The numbers for "Available
on disk" and "After restart" change as you adjust the amount of disk space.

4.  Choose Restart from the Special menu.

After you restart, your computer's total memory (as indicated in the window
that appears when you choose About This Macintosh from the Apple menu)
includes the virtual memory you set aside on the hard disk.

!!  IMPORTANT:  When you turn on virtual memory, the system software creates
a file named VM Storage in your System Folder (if the startup disk is used
for virtual memory) or on the desktop (if another hard disk is used for
virtual memory). This file is large -- the size of the computer's RAM and the
designated amount of virtual memory combined. For example, if your Macintosh
has 4 MB of RAM and you add 2 MB of virtual memory, the VM Storage file will
occupy 6 MB of space on your startup disk.  !!

Turning on 32-bit addressing

Some Macintosh models can use very large amounts of memory (more than 8
megabytes) by taking advantage of a feature called 32-bit addressing -- the
use of very long (32-digit) binary numbers to control the way data is
manipulated.

If your Macintosh can use 32-bit addressing, you can turn the feature on or
off in the Memory control panel (choose Control Panels from the Apple menu
and open the Memory control panel).

To turn 32-bit addressing on or off, click the appropriate buttons in the
control panel, then choose Restart from the Special menu.



You also use the Memory control panel to adjust the size of the disk cache
and (depending on your Macintosh model) to set aside hard disk space for use
as memory (see "Adjusting the Disk Cache" and "Using Hard Disk Space as
Memory").

CHAPTER 12-PRINTING

In this document:

- Before you print

Choosing a printer

Selecting Page Setup options

Updating printer drivers on networked computers

- Printing your work

Printing the contents of a window

If the printer doesn't print your document

- Printing while using the computer for other work

- Working with fonts

Outline fonts and bitmapped fonts

Installing fonts

Removing fonts

Transferring fonts to a LaserWriter printer

Finding out about available fonts

Using the LaserWriter Font Utility

Before You Print

Before you can print, your Macintosh must be connected to a printer, either
directly or over a network. See the instructions that came with your printer
if you need information about connecting it to your computer.

Then, you must tell your Macintosh which printer to use by choosing the
printer.

Choosing a printer

You tell the Macintosh which printer to use by choosing the printer in a
program called the Chooser. You don't need to choose a printer every time you
print. You need to choose one only when you're using a printer for the first
time and whenever you decide to change printers.

How you use the Chooser depends on whether your Macintosh is connected



directly to the printer or connected to a network.

If your printer is not on a network

Make sure that you've connected the printer according to the instructions
that came with it and that you know which port you used (on the back of the
computer) to connect the printer.

1.  Choose the Chooser from the Apple menu.

The Chooser window appears.

2.  Click the icon of the printer you want to use. Make sure the icon is
selected (highlighted).

If your printer's icon does not appear in the Chooser, then the appropriate
printer driver -- the program that communicates with, or "drives," the
printer -- has not been installed in your System Folder. Close the Chooser
and install the driver you need. You can use the Customize option in the
Installer program (see "Setting Up Your Macintosh System"), or you can
install the driver directly by dragging its icon into the System Folder. If
your printer is not an Apple printer, review the instructions that came with
it for information on installing its driver.

If you have a Personal LaserWriter SC, close the Chooser window after you
click the Personal LaserWriter SC icon.

3.  Click the icon representing the port that you used to connect the
printer. Make sure the icon is selected.

You have only two choices: the printer port or the modem port. Click the icon
that matches the icon of the port (on the back of the computer) to which you
connected the printer cable.

4.  Click the Inactive button next to the word "AppleTalk."

If the Inactive wasn't already selected, a dialog box appears. Click OK.

5.  Close the Chooser window.

If your printer is on a network

Find out from your network administrator (or the person who set up your
computer) which printer you can use, which zone it's in (if your network has
zones), and what its name is (every printer on a network has its own name).

1.  Choose the Chooser from the Apple menu.

The Chooser window appears.

2.  Click the Active button next to the word "AppleTalk."

If Active wasn't already selected, a dialog box appears. Click OK.

3.  Click the icon representing the type of printer you want to use.

You may have to click the up and down scroll arrows to find the icon.



If your printer's icon does not appear in the Chooser, then the appropriate
printer driver -- the program that communicates with, or "drives," the
printer -- has not been installed in your System Folder. Close the Chooser
and install the driver you need. You can use the Customize option in the
Installer program (see "Setting Up Your Macintosh System"), or you can
install the driver directly by dragging its icon into the System Folder. (If
you install the LaserWriter driver, be sure to install the PrintMonitor
program also.) If your printer is not an Apple printer, review the
instructions that came with it for information on installing its driver.

4.  If you see a list of AppleTalk zones, click the zone where the printer is
located.

You may have to click the up and down scroll arrows to find the zone. The
zones are listed alphabetically.

5.  Click the name of the printer you want to use, even if it's the only one
that appears.

6.  If you want to be able to use your Macintosh for other work while it's
printing documents, click the On button next to Background Printing.

The background printing option is available only if both the PrintMonitor
program and the LaserWriter driver have been installed in your System Folder.
(See "Printing While Using the Computer for Other Work" for information about
using PrintMonitor.)

7.  Close the Chooser.

Selecting Page Setup options

You use the Page Setup dialog box when you've selected a new printer in the
Chooser or when you want to use a different paper size or printing option.

- Choose Page Setup from the File menu and select the options you want.

When a LaserWriter printer is chosen, this Page Setup dialog box appears:

When an ImageWriter printer is chosen, this Page Setup dialog box appears:

You can choose Show Balloons from the Help menu to get descriptions of the
enhancements provided in the Options dialog box, or check your printer's
manual for details.

You'll see different options for each type of printer you use. Some programs
provide additional options. Options you set in the Page Setup dialog box
remain in effect until you change them.

Updating printer drivers on networked computers

All computers on a network that share one or more printers must have the same
version of the printer driver software that communicates with (or "drives")
the printers. When someone on the network sends a document to the printer
using a version of the printer driver that's different from the last version
the printer recognized, the printer restarts itself (which takes time and
clears any fonts from its temporary memory).

!!  IMPORTANT:  All computers on a network must have the same version of



printer drivers in their System Folders.  !!

If your Macintosh is part of a network, you or your network administrator
should update the printer drivers on any Macintosh computers on your network
that are running any system software version earlier than version 7.0. You do
not have to update other components of the system software; version 7.0
printer drivers work with earlier versions of the system software.

To update printer driver software, you use the Installer program and the
accompanying Printer Update document (both files are on one of the system
software disks that came with your computer).

You can store these files on a file server or a shared disk on the network
and install the update from there.

1.  Locate the Installer and Printer Update files (supplied on one of the
system software disks), and then open the Installer icon.

A dialog box appears, showing the printer driver icons and explaining your
installation options.

2.  Click OK.

The Easy Install dialog box appears.

3.  Make sure that the hard disk indicated in the box is the one you want to
update the printer drivers on. If a different disk name appears, click the
Switch Disk button until the correct disk name appears.

4.  If you want to install different printer drivers in addition to those
already on your disk, click the Customize button, then click the names of the
drivers you want to install.

If you want to update only the drivers that are already installed on your
disk, go to step 5.

When you click Customize, the custom installation dialog box appears, showing
a list of the printer drivers available. Press the Shift key while you click
if you want to select more than one printer driver.

5.  Click Install.

6.  Click Quit when you see a dialog box reporting that installation was
successful.

If a dialog box reports that installation was not successful, try the update
again.

Printing Your Work

The most common way to print a document is while it's open and while its
window is the active window. You can also print documents while the Finder is
the active program.

1.  Make sure that the document you want to print is in the active window.

If you're printing from the Finder, click the icon of the document you want
to print (or click several document icons while holding down the Shift key).



2.  Choose Print from the File menu, or press Command-P.

A dialog box appears, in which you can set printing options. The options vary
depending on the printer you have chosen and the program in which the
document was created.

If a LaserWriter printer is chosen in the Chooser, this dialog box appears:

Printing color or gray-scale documents:  You can print color or gray-scale
documents on any color printer that can use the LaserWriter driver. If you
print a color document on a printer that prints only in black and white, the
document will be produced in a halftone format; that is, it will be composed
of patterns of dots.

Some programs offer additional printing options, such as the order in which a
document's pages are printed. See the manuals that came with your programs
for more information on their printing features.

3.  Click the Print button in the upper-right corner.

After a moment, a status box appears. If background printing is turned on in
the Chooser, the status box disappears after a few seconds, and you can do
other work while printing continues.

Printing the contents of a window

You can print the contents of the active window when you're working in the
Finder.

1.  Make sure that the window whose contents you want to print is the active
window.

2.  Choose Print Window from the File menu.

A dialog box appears.

3.  Select the options you want.

4.  Click the Print button.

The window's contents are printed in the format currently displayed,
including items not visible on the screen.

When no window is active, you can print the contents of the Macintosh desktop
by choosing Print Desktop from the File menu.

If the printer doesn't print your document

The Print command isn't reaching the printer, the printer is getting
conflicting signals, or the printer isn't working properly.

- Check that the printer is turned on and warmed up (if it's a LaserWriter,
it should have printed a sample page).

- Check the cable connections to the printer.

- If your printer is an ImageWriter, make sure that the Select light is on.



(Press the Select button to turn the light on.) A dialog box on the screen
may inform you that the printer is not responding.

- Check that the printer (and its name, if it's a LaserWriter) is selected in
the Chooser.

- Make sure that you are using the same version of the printer driver as all
other people on your network.

- If an error message states that the printer could not print your document,
turn off the printer for at least 10 seconds, then turn it on again and wait
for the printer to warm up before trying to print again.

Printing While Using The Computer For Other Work

You can use your Macintosh for other work while you're printing on a
LaserWriter printer if the background printing option is turned on in the
Chooser. (See "Choosing a Printer" in this chapter for information about
turning on background printing.)

You can control background printing with PrintMonitor, a program that's
installed automatically when you install system software using the Installer
program's Easy Install option.

1.  After you have started printing a document, choose PrintMonitor from the
Application menu.

When background printing begins, PrintMonitor opens automatically and its
name appears in the Application menu at the right end of the menu bar.

When you choose its name from the Application menu, the PrintMonitor window
appears.

You can use PrintMonitor to

- monitor the status of printing

- cancel a document currently printing or waiting to print

- set the time you want a document to print (date and hour) or postpone a job
indefinitely

- monitor paper supply (PrintMonitor's icon blinks at the right end of the
menu bar when the printer is out of paper; you can change the notification
method with the program's Preferences command in the File menu.)

- signal when to feed paper manually (PrintMonitor's icon blinks at the right
end of the menu bar to signal that you must confirm the manual operation; you
can change this notification with the program's Preferences command in the
File menu.)

2.  Select the options you want, and then click the close box.

Working With Fonts

A font is a collection of letters, numbers, and symbols in a distinctive
typographic design.



When you install Macintosh system software, several fonts are installed in
the System file, which is in the System Folder on your startup disk. You can
install additional fonts and remove fonts.

Additional fonts are supplied on one of the system software disks. Fonts are
also available from independent manufacturers, user groups, and computer
bulletin board services.

Outline fonts and bitmapped fonts

Your Macintosh uses two types of fonts:

- outline fonts

- bitmapped fonts

Both types of fonts are installed in the System file in the System Folder of
your startup disk when you install system software.

Outline fonts (also called scalable or variable-size fonts) describe each
letter, number, or symbol as a mathematical formula that defines the
character's shape and adjusts itself to make the character's size larger or
smaller. Your Macintosh, therefore, needs only a single outline font in a
particular typeface (such as Times) to be able to print or display that
typeface in different sizes.

The outline fonts supplied with Macintosh system software are called TrueType
fonts.

When your Macintosh is running System 6, you cannot use TrueType fonts
supplied with System 7.

Bitmapped fonts (also called fixed-size fonts), on the other hand, describe
each character as a grid of black and white dots (called a bit map), which is
a rendering of the character's shape in a specific size.

Your Macintosh needs a separate bitmapped font of a typeface in each size it
prints or displays, such as 12-point Times or 10-point Helvetica.

An outline font character is like a cookie recipe that you can use to make as
big or as small a batch of cookies as you need. A bitmapped font character is
like a cookie cutter: it gives you one size -- that's all.

For information on how the system software finds the fonts it needs, see
"Getting the Best-Looking Fonts", "Tips and Troubleshooting."

Installing fonts

To install a font:

1.  Quit all programs that are open.

Pull down the Application menu to make sure that the Finder is the only open
program. Choose any other open program from the Application menu and then
choose Quit from the File menu.

2.  Locate the icon of the font you want to install and drag it to the System
Folder icon (not the System Folder window) on your startup disk.



You can click multiple font icons while holding down the Shift key to select
more than one icon.

A dialog box appears, letting you know that the fonts will be stored in the
System file, where they belong.

3.  Click OK.

Removing fonts

To remove a font:

1.  Open the System Folder on your startup disk.

2.  Locate the System file icon and open it.

3.  Locate the icon of the font you want to remove and drag it out of the
System window and out of the System Folder window.

4.  Close the System window and the System Folder window.

Transferring fonts to a LaserWriter printer

If you're using a LaserWriter printer that's equipped to handle PostScript
and you want to print using PostScript outline fonts that are not built into
your printer, you can transfer, or download, outline fonts from your System
Folder to the printer. (PostScript is a programming language that describes
the characters, symbols, and images appearing on each page of a document.)
Downloading fonts saves you printing time if you plan to print a batch of
documents that use those fonts.

When you download a font, it's stored in the printer's memory or on a hard
disk attached to the printer. You can download as many outline fonts as the
printer's memory and hard disk space allow.

You download a font using the LaserWriter Font Utility, which is supplied on
the system software disks.

1.  Locate and open the LaserWriter Font Utility icon.

2.  Choose Download Fonts from the File menu.

A dialog box appears.

3.  If the font you want to download is not listed, click the Add button to
add fonts to the list.

A directory dialog box appears, which you use to locate the fonts you want.

4.  Click the name of the font you want, then click Add.

You can press the Shift key while you click to select more than one font.

5.  When you've added all the fonts you want to download, click Done.

The directory dialog box closes and the fonts you added are listed in the



Font Utility dialog box.

6.  Click the Download button to send all the fonts in the list to the
printer or its hard disk.

A status box appears. You can click Cancel to stop the process.

7.  Click OK when the status box reports the results of downloading.

8.  Choose Quit from the File menu.

Finding out about available fonts

Most application programs have a Font menu that lists the fonts installed in
your System file, though some programs do not list them all (you can open the
System file icon, inside the System Folder, to see all the fonts stored
there).

The LaserWriter Font Utility program (supplied on the system software disks)
provides three ways to see the fonts available for printing on a LaserWriter.
You can display a list of fonts on the screen, print a catalog of fonts, or
print a set of font samples. You choose the method you want from the
LaserWriter Font Utility's File menu.

Using the LaserWriter Font Utility

While the LaserWriter Font Utility is most useful for transferring (or
downloading) fonts from your System Folder to a LaserWriter printer and
finding out about available fonts, you can also use the program to

- initialize a hard disk attached to a printer

- control whether a printer prints a sample page when you turn it on

- restart a printer

- send PostScript files to a printer

The LaserWriter Font Utility program is supplied on the system software
disks.

Initializing a hard disk attached to a printer

Some printers let you attach a hard disk so you can store fonts on it (in
addition to the fonts stored in the printer's memory). See the manuals that
came with your printer if you need information about connecting a hard disk.

1.  Open the LaserWriter Font Utility icon.

2.  Choose Initialize Printer's Disk from the File menu.

A dialog box appears.

3.  Click the Drive button until the hard disk that's shown is the one you
want to initialize.

4.  Click the Initialize button.



Turning the printer's sample page on or off

The LaserWriter prints a sample page each time it is turned on or restarted.

1.  Open the LaserWriter Font Utility icon.

2.  Choose Start Page Options from the Utilities menu.

A dialog box appears.

3.  Click the On or Off button.

4.  Click OK.

Restarting a LaserWriter printer

Restarting the printer clears its memory, removing the fonts stored there and
making room for other fonts that you may want to transfer to the printer.

1.  Open the LaserWriter Font Utility icon.

2.  Choose Restart Printer from the Utilities menu.

A dialog box appears.

3.  Click Restart.

Transferring a PostScript file to a LaserWriter

You can use the LaserWriter Font Utility to send a file in PostScript format
to a LaserWriter. (PostScript is a programming language that describes the
characters, symbols, and images in a file to be printed or displayed.)

1.  Open the LaserWriter Font Utility icon.

2.  Choose Download PostScript File from the Utilities menu.

A dialog box appears.

3.  Click the name of the file you want to download to the printer, and then
click Open (or double-click the name).

A second dialog box appears, asking you to name a file that saves a record of
the PostScript activity. This file has the preset name "PostScript Log."

4.  Type a name for the printing log, then click Save.

The file is sent to the printer and a record of the PostScript activity is
saved in the printing log.

You can open the printing log to see the sequence of PostScript commands when
the file was sent.

CHAPTER 13-USING YOUR MACINTOSH ON A NETWORK

In this document:
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Connecting to a network
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Connecting to a shared disk

Disconnecting from a shared disk
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Connecting automatically when you start up

- Working with files and folders on other computers

Creating a new folder on another computer
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- Sharing your files over the network
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- Using communications products with System 7

Using the Communications Toolbox

Using Data Access Language

What You Can Do On The Network

You can do several things with your Macintosh once it is connected to a
network:

- Gain access to information on other computers.

Working at your own computer, you can connect to other computers and gain
access to files that are stored there.

- Allow access to information on your own computer.

You can designate the contents of specific folders and hard disks on your
computer as "shared files" that other people can gain access to over the
network.

- Print documents on network printers.

You can print documents on network printers as you would on printers that are
connected directly to your computer.

- Link programs to programs on other computers.

You can link your programs to programs on other computers in order to share
features between those programs. For example, you could link a word-
processing program to a dictionary program to check the meaning and spelling
of the words in a document.

- Update files over the network automatically.

You can automatically update documents created in programs that use the
Macintosh system software's publish-and-subscribe feature (see the
documentation that came with your programs for information about this
feature).

Setting Up Your Macintosh On A Network

Before you can use your Macintosh on a network, you have to physically
connect your computer to the network, install networking software, make sure
that your computer can communicate with the network, and identify your
computer and yourself to others on the network.

If you have a network administrator, he or she may have already set up your
Macintosh on the network. Before you proceed, ask your network administrator
whether these tasks have been completed.

Connecting to a network

Your Macintosh has built-in AppleTalk networking software that allows your
computer to connect to a network quickly and easily.

If you're using a LocalTalk network (a type of AppleTalk network), then all



of the software and hardware you need is already built into your Macintosh.
You can connect your computer to the network by plugging LocalTalk-compatible
cables into the back of your computer. (See the documentation that came with
your cables if you need more information.)

If you're using an Ethernet or a Token Ring network, your Macintosh needs
both an EtherTalk or a TokenTalk expansion card installed in one of its
expansion slots and the appropriate software to communicate with the network.
(See the documentation that came with your expansion card if you need more
information.)

The EtherTalk and the TokenTalk software are provided on the system software
disks that came with your computer. If a network expansion card was already
installed in your computer when you installed system software, the software
for it was installed automatically. If you installed the expansion card after
you installed the system software, you need to install the network software
separately (see "Installing a Customized System", in "Setting Up Your
Macintosh System").

Configuring your Macintosh for a network

Before you can use the networking features of your Macintosh, you have to
take a few steps to prepare it.

Making sure AppleTalk is on.

The first time you turn on your computer after you have connected it to a
network, AppleTalk -- your computer's built-in networking software -- is
turned on automatically. But if you have turned AppleTalk off -- for example,
to connect an ImageWriter printer to your printer port -- you need to turn it
back on again.

1.  Choose the Chooser from the Apple menu.

2.  Click the Active button (in the lower-right corner of the Chooser) to
turn on AppleTalk.

3.  Close the Chooser.

AppleTalk remains on until you turn it off in the Chooser.

Selecting a network connection.

If you're using a LocalTalk network, go to the next section, "Naming Your
Macintosh and Its Owner."

If you want to use an EtherTalk or a TokenTalk network connection type or
switch between two or more types of network connections, you have to select
which connection you want in the Network control panel.

1.  Choose Control Panels from the Apple menu and double-click the Network
icon to open it.

If you can't find the Network control panel:  The Network control panel,
EtherTalk software, and TokenTalk software were installed only if you already
had an EtherTalk or a TokenTalk expansion card in your computer when you
installed the system software. If you have an expansion card installed now
and no Network control panel appears in the Control Panels folder, use the



Installer program to install EtherTalk or TokenTalk software. (See
"Installing a Customized System".) 

2.  Click the icon of the network connection you want to use.

A dialog box warns you that you may be disconnected from any network services
(such as printers or file servers) that you are using with your current
network connection. This means that you must reconnect to the network
services on the new network.

3.  Click OK.

Next, you need to select the network zone your computer will use.

4.  Double-click the icon of the network connection you chose in step 2.

5.  Click the name of the zone you want to use.

Zones are set up by a network administrator and are used to distribute the
devices on a network among groups for easier access.

6.  Click OK.

7.  Close the Network control panel.

You can now use the network connection you selected.

Naming your Macintosh and its owner.

Before you begin to use the network, you must give your Macintosh a name and
name yourself as its owner. The name you give your Macintosh appears in the
Chooser of other computers on the network so that people on the network can
gain access to files on your computer.

1.  Choose Control Panels from the Apple menu and double-click the Sharing
Setup icon to open it.

If you can't find or can't open the Sharing Setup icon:  Make sure that the
Sharing Setup icon is in the Control Panels folder, and that the File Sharing
Extension file and the Network Extension file are in the Extensions folder
inside the System Folder. Then restart your computer.

2.  Type a name in the box labeled Owner Name and press Tab.

Type the name of the primary user of this computer -- very likely, this is
you.

3.  Type your password in the box labeled Owner Password and press Tab.

Your password can be up to eight characters in length. Your password prevents
others from gaining access to your files without your permission. After you
type your password and press Tab, it is replaced by bullets (�) to help keep
your password private.

4.  Type a name for your Macintosh in the box labeled Macintosh Name.

If a name already appears in the Macintosh Name box, you can use that name or
type in a new one.



5.  Close the Sharing Setup control panel.

Your computer is now ready to be used on a network.

Gaining Access To Files On Other Computers

When your computer is connected to a network, you can retrieve and store
information on other computers, including a file server -- usually a computer
on the network with special software that allows you to access it, store
files on it, or retrieve files from it.

Files on a file server are stored on shared disks -- hard disks or CD-ROM
discs that can be accessed over the network. Private Macintosh computers (not
file servers) on your network might also have shared disks if they are
running system software version 7 and if they are using file sharing -- the
ability to share information on a private Macintosh. (See "Sharing Your Files
Over the Network".)

Before you begin

Before you attempt to retrieve or store information on the network, do the
following:

- Find out the name of the shared disk you want to access and the name of the
file server or private Macintosh that it's on.

Ask your network administrator for the name of a file server; ask the owner
of a private Macintosh for its name.

- If your network has zones, find out the name of the zone the other computer
is in.

- Find out if you are registered on the computer or if it allows guest
access.

A Macintosh owner or network administrator can limit access to files on a
shared disk. Ask the Macintosh owner or your network administrator how much
access you have to the files.

- If you're allowed access as a registered user, ask the Macintosh owner or
your network administrator for your user name and your password.

Find out exactly how your name and your password are spelled, including the
use of capital and lowercase letters in your password.

Connecting to a shared disk

1.  Choose the Chooser from the Apple menu.

The Chooser opens.

2.  Make sure that AppleTalk is active.

3.  Click the AppleShare icon in the upper-left section of the Chooser
window.

If the AppleShare icon does not appear:  Make sure that the AppleShare file



is in the Extensions folder in your System Folder.

4.  If your network has zones, click the zone in which the computer with the
shared disk you want resides.

If you do not see a box in your Chooser labeled AppleTalk Zones, skip this
step.

5.  Click the name of the computer with the shared disk that you want to use.

If the name you want isn't listed:  Make sure that you have selected the
correct zone. If the zone is correct, ask your network administrator or the
Macintosh owner if the computer is turned on. You cannot connect to a
computer that's turned off.

6.  Click OK.

A dialog box appears for you to identify yourself as a registered user or
guest.

7.  Click Guest or Registered User.

If you are a guest or if you are not certain that you are registered, click
Guest and go to step 10. If you are a registered user, click Registered User.

If the Guest option is dimmed, guests are not permitted access to this
computer.

8.  If you are a registered user, make sure your user name is displayed in
the box exactly as it is registered.

Any name that appears in the box is taken from the Owner Name in the Sharing
Setup control panel on your computer. If that name is different from your
registered user name on the computer you're connecting to (or if no name
appears in the box), type your registered user name now.

9.  Type your password.

Type your password exactly as it is registered. Capital and lowercase letters
must match.

If your password is not accepted:  Make sure that you haven't made any
typographical errors. Check that your Caps Lock key has not been pressed
inadvertently.

10.  Click OK.

11.  Select the shared disk you want to use by clicking its name.

A dimmed name indicates either that you are already connected to that shared
disk, or that you don't have access to it. If a folder or disk you want does
not appear, then you don't have access to it.

12.  Click OK.

When you click OK, the dialog box closes and the icon of the shared disk
appears on the right side of your desktop.



13.  Close the Chooser.

Disconnecting from a shared disk

When you're finished using a shared disk, you can disconnect from it in three
ways (after you've closed any open files or programs on the shared disk):

- Click to select the icon of the shared disk you want to disconnect from and
choose Put Away from the File menu.

- Drag the icon to the Trash.

- If you are finished working for the day, choose Shut Down from the Special
menu. Your computer is disconnected automatically when it is shut down.

Using an alias to connect quickly to a shared disk

You can connect to a shared disk quickly by using aliases.

1.  Connect to a shared disk.

2.  Click to select the shared disk icon.

3.  Choose Make Alias from the File menu.

An alias icon appears that has the same name as the shared disk with the word
alias appended to it. The name is selected for editing.

4.  If you wish, rename the alias, then drag it to a convenient place on your
desktop or disk.

5.  The next time you want to connect to the shared disk, open the alias you
created in step 3.

If you originally connected to the shared disk as a registered user, a dialog
box appears. Type your password.

If you connected as a guest, this dialog box does not appear.

The shared disk icon appears on your desktop.

Connecting automatically when you start up

You can set up your computer to connect automatically to shared disks
whenever you turn it on.

1.  Connect to a computer with the shared disk you want.

You see the dialog box containing a list of shared disks.

2.  Click the checkbox next to the name of a shared disk that you want to
connect to automatically.

3.  If you're connecting as a registered user, click the button that
indicates whether you want the shared disk to save your name only or both
your name and your password.

If you select Save My Name Only, you'll have to type your password when you



start up your computer. Click this option if you want to prevent unauthorized
people from gaining access to the shared disk from your computer.

If you click Save My Name and Password, your Macintosh will automatically
connect to the shared disk when it starts up.

4.  Click OK.

5.  Close the Chooser.

Working With Files And Folders On Other Computers

Once you are connected to a shared disk, you can use the files and folders on
it as you would the files and folders on your own computer. For example, you
can

- double-click a folder on the shared disk to open it

- copy a file to or from the shared disk by dragging the file icon to where
you want the copy

In some cases, you are not able to open certain items on a shared disk
because the owner of the computer that has the shared disk has restricted
access privileges to them. Access privileges determine whether you can see,
open, or modify a file or a folder on a shared disk. To find out how to check
your access privileges, see "Working With Privileges That Others Have Set" in
this chapter.

Creating a new folder on another computer

You can create a new folder on shared disks on other computers (as long as
you have the necessary access privileges). If you are connected to a computer
as a registered user, you become the owner of any folder that you create on
that computer. If you are connected as a guest, you share ownership of a
folder you create with all guests and registered users. To learn about the
access privileges you need to create a folder, see "Understanding Access
Privileges".

The icons of folders that you own have a darkened tab.

When you own a folder, you can set its access privileges to determine who can
use it and in what way. See "Using Access Privileges" for more information.

Changing your password

1.  Connect to the computer with the shared disk you want.

A dialog box appears in which you identify yourself as a registered user or
guest.

2.  Click the Set Password button.

A dialog box appears.

If a warning box tells you that you cannot change your password, your network
administrator has prevented you from being able to do so.

3.  Type your current password. Then press Tab and type a new password.



A bullet (�) appears for each letter you type. Use a password that will not
be easily guessed by someone else.

4.  Click OK.

A dialog box asks you to retype your new password to verify it. Click OK.

5.  Retype your password and click OK.

Your new password is now in effect.

Giving folder ownership to someone else

You can give away the ownership of any folder that you own. Once you do so,
the new owner controls access to the folder and can restrict your access to
it. Make sure that you have moved any files you may need to another folder
that you own before you give up ownership.

You can only give folder ownership to a registered user or registered group
on the computer to which you're connected. (See "Naming the People Who'll
Have Access to Shared Files" for more information about registered users and
registered groups.)

1.  Connect to a shared disk.

2.  Click to select a folder that you own.

3.  Choose Sharing from the File menu.

4.  In the box labeled Owner, type the name of the registered user or group
that you want to give folder ownership to.

Type the name exactly as your network administrator or the Macintosh owner
has registered it.

5.  Close the dialog box.

Another dialog box asks you to confirm that you want to change the owner of
the folder.

6.  Click OK.

The user or group that you named assumes ownership immediately.

Sharing Your Files Over The Network

You can let other people on the network gain access to files stored on your
Macintosh. For example, if you've written a report that you'd like people in
your work group to read, you can let them connect to your computer and open
the file from their own computers.

You can always control what information you share and whom you share it with:

- You can share as much or as little as you like.

- You can specify who can use the information on your computer -- one person,
a group of people, or everyone on the network.



- You can gain access to everything on your own computer from another
computer on the network.

How file sharing works

Sharing files on your computer consists of a few discrete steps that  allow
you to control exactly how you want to share information on your computer.
This section provides an overview of these steps. For detailed instructions,
continue on to subsequent sections.

- First, you turn on the file-sharing capability of your Macintosh.

- Second, you allow others to gain access to the files in designated folders
or disks (you "share" those files).

Anyone on the network can gain access to the folders and disks you've shared.
If you want to share certain files with only certain people, you continue
with the following steps:

- Third, you name the people (the registered users) whom you'll allow to gain
access to shared files on your computer.

- Fourth, for each shared folder or disk, you pick from your list of
registered users the people whom you want to have access to the folder or
disk.

- Fifth, you prevent anyone else from being able to gain access to the shared
folder or disk.

Turning file sharing on

Before you turn file sharing on, make sure that you have named your Macintosh
as described in "Naming Your Macintosh and Its Owner" earlier in this
chapter.

1.  Choose Control Panels from the Apple menu and double-click the Sharing
Setup icon to open it.

The Sharing Setup control panel opens.

2.  In the section labeled File Sharing, click the Start button.

When file sharing is turned on, the button is labeled Stop.

3.  Close the Sharing Setup control panel and the Control Panels folder.

File sharing is now turned on. You still need to select a specific folder or
disk to share over the network.

Selecting a folder or disk to share

You can share any folder or disk on your computer -- including hard disks and
CD-ROM discs (but not floppy disks). You can share up to ten folders or disks
at one time. (This number does not include the folders that are within the
folders or disks that you share.)

1.  Make sure file sharing is turned on.



2.  Select a folder, hard disk, or CD-ROM disc to share by clicking its icon.

3.  Choose Sharing from the File menu.

A window appears.

4.  Click the box labeled "Share this item and its contents" to place an X in
it.

To find out more about the access privileges checkboxes -- the ones in the
columns labeled See Folders, See Files, and Make Changes -- see "Using Access
Privileges" later in this document.

5.  Close the window and click Save in the dialog box to save your changes.

The folder or disk you shared is now considered a shared folder or shared
disk. Anyone on the network can gain access to it -- and the files and
folders inside it -- over the network.

If you shared a folder, its icon appears on your desktop with a darkened tab
and network cables connected to it.

6.  Drag any files and folders that you want to make available to the network
into your new shared folder or disk.

The files and folders that you place in the shared folder or disk become
available to the users who connect to your computer.

When people on your network are connected to a shared folder, the icon of the
folder on your desktop appears with faces in the center to indicate that it
is in use.

!!  IMPORTANT:  Copyright laws apply to sharing programs over a network as
well as to copying programs from a floppy disk. Before you put programs
inside shared folders or disks, check with any applicable licensing
agreements and follow their specifications.  !!

Making a shared folder or disk private.

To make a shared folder or disk private again, click to select the shared
disk icon, choose Sharing from the file menu, and click the "Share this item
and its contents" checkbox to remove the X. After you close the window, the
folder or disk and any files or folders inside it cannot be accessed from the
network.

Naming the people who'll have access to shared files

You can share a folder or disk only with specific people on the network. To
do so, you first have to name those people as registered users or as
belonging to a registered group, and then you have to designate a shared
folder or disk as being accessible to a specific registered user or
registered group.

Naming a registered user.

You can register as many as 100 users and groups of users combined, but the
network's performance may suffer if you name more than 50.



1.  Choose Control Panels from the Apple menu and double-click the Users &
Groups icon to open it.

The Users and Groups control panel appears. It contains at least two icons.
One (outlined in bold) represents you as the owner and primary user of your
Macintosh.

The other icon is the <Guest> icon. You use this icon to allow or disallow
guests to gain access to the shared files on your computer. (Guest access is
automatically allowed when you first turn on file sharing.)

If you don't see the bold icon:  You haven't named your Macintosh and named
yourself as its owner. See "Naming Your Macintosh and Its Owner" earlier in
this document for instructions.

2.  Choose New User from the File menu.

An icon labeled New User appears. Its name is selected for editing.

If you can't find the New User command, click anywhere in the Users & Groups
control panel to make it active.

3.  Type the name of a person on the network whom you want to make a
registered user of your computer.

Make sure that you tell the person exactly how you registered him or her as a
user.

As a registered user, that person has access to any folders or disks you
decide to share.

4.  To register more users, repeat steps 2 and 3.

To give your users passwords or to name groups of users, continue with the
next two sections. If you want to start sharing folders or disks with your
users immediately, go to "Selecting a User or Group to Share a Folder or
Disk".

Setting a user's password.

You can assign passwords for your registered users to help verify their
identities when they want to gain access to your computer.

1.  Open a user icon in the Users & Groups control panel.

A window with the name of the user appears.

2.  Type a password in the box labeled User Password, then press the Tab key.

The password can be up to eight characters long. When you finish typing the
password and press Tab, each character of the password is replaced by a
bullet to help keep that password private.

3.  Close the window and click Save in the dialog box that appears.

Naming a group of users.



You can name a group of registered users as a registered group and share a
folder or disk with the members of that group.

1.  Open the Users & Groups control panel and choose New Group from the File
menu.

An icon labeled New Group appears. The name is selected for editing.

2.  Type a name for the group.

3.  Drag the user icon of each person that you want to be a member of the
group to the new group icon.

You don't need to drag your Macintosh owner icon to the group icon because
you always have access to the entire contents of your computer (unless you
specify otherwise). Also, you don't need to include the <Guest> icon in any
group.

To allow this group of people to gain access to a shared folder or disk, go
to the section "Selecting a User or Group to Share a Folder or Disk.

Seeing who's in a group.

- To see the names of the members of the group, open the group icon.

A window opens and shows a member icon for every user that you added to the
group.

You can open any user's member icon if you want to see or change the settings
you've made for that user.

- To see the names of all of the groups that a user belongs to, open the
user's member icon or user icon.

You can double-click either the member icon that appears in the group window
or the original user icon that appears in the Users & Groups control panel. A
window opens and displays a list of all the groups that the user belongs to.

Selecting a user or group to share a folder or disk

You can give one registered user or group exclusive access to a shared folder
or disk on your computer. Make sure that file sharing is turned on and that
you have named the registered user or group as described in "Naming the
People Who'll Have Access to Shared Files" earlier in this document.

1.  Select a folder, hard disk, or CD-ROM disc to share with a user or group
by clicking its icon.

2.  Choose Sharing from the File menu.

A dialog box appears.

3.  Click the box labeled "Share this item and its contents" so an X appears.

4.  Choose a user or a group from the User/Group pop-up menu.

The User/Group pop-up menu contains the names of the users and groups that



you registered. The name you choose is displayed when you are done.

5.  To share this folder or disk with only the user or group that you've
chosen, click the bottom row of checkboxes (to the right of Everyone) to
remove the X from each box.

Only you and the user or group you've chosen now have access to this folder
or disk. For more information about access privileges and strategies to use
them, see "Using Access Privileges" later in this chapter.

6.  Close the window and click Save in the dialog box that appears.

Preventing a user or guests from accessing your computer.

You can prevent a specific user from connecting to your computer, or you can
prevent any guests from connecting.

1.  Choose Control Panels from the Apple menu and double-click the Users &
Groups icon to open it.

2.  To deny access to a specific user, open the user icon. To deny access to
guests, open the <Guest> icon.

3.  To deny access to a user, click the box labeled "Allow user to connect"
to remove the X. To deny access to all guest users, click the box labeled
"Allow guests to connect" to remove the X.

4.  Close the window and click Save in the dialog box that appears.

If you denied access to a specific user, that user can no longer access your
computer from the network as a registered user. In addition, that user is no
longer a member of any groups. If the user is currently connected, he or she
is disconnected immediately. If your Macintosh is set up to allow guest
access, that user can still connect as a guest.

If you denied access to guests, any guests currently connected are
disconnected immediately.

Removing a user's membership in a group.

1.  In the Users & Groups control panel, open the group icon that the user
belongs to.

2.  Drag the member icon for that user to the Trash.

3.  Select Empty Trash from the Special menu.

The user is no longer a member of that group.

Removing a user or group from your list of registered users.

You can remove a registered user or group at any time. When you remove a
user, that user's membership in any registered groups on your computer will
be removed.

1.  Double-click the Users & Groups icon to open it.

2.  Drag the user or group icon to the Trash.



3.  Select Empty Trash from the Special menu.

You cannot throw away the <Guest> icon or the owner icon. To prevent guest
access, see "Preventing a User or Guests From Accessing Your Computer"
earlier in this document.

Giving away ownership of a folder or disk on your computer

You can give away ownership of a shared folder or disk on your Macintosh to
another registered user or a registered group. Because you are the owner of
your Macintosh, a new owner of a folder on your computer cannot restrict your
access to it. However, the new owner can change the access privileges that
other people have to the folder or disk. If you give away ownership of a
folder or disk, make sure that you move any important folders or documents
out of it first so that no one else can see or alter those documents.

1.  Click to select the icon of a shared folder or disk.

2.  Choose Sharing from the File menu.

3.  Choose the name of a registered user, group, or <Any User> in the Owner
pop-up menu.

If you select <Any User>, then anyone on the network can change the access
privileges of the folder or disk or choose a new owner.

4.  Close the window and click Save in the dialog box that appears.

5.  Click OK again to confirm that you want to change ownership.

Turning file sharing off

You can turn off the file-sharing capability of your Macintosh at any time.
When file sharing is off, people on the network cannot access any folders or
disks on your computer, and you cannot access your computer from another
computer on the network.

If you turn file sharing back on, all of the shared folders or disks will
again be available to people on the network.

1.  Choose Control Panels from the Apple menu and open the Sharing Setup
control panel.

2.  In the section labeled File Sharing, click the Stop button.

If users are currently connected to your computer, a dialog box appears in
which you can specify a delay before file sharing is turned off. This gives
current users some time to save their work and to disconnect from your
computer.

3.  Type the number of minutes you want to elapse before file sharing is
turned off.

To disconnect users immediately, type the number 0. Otherwise, type the
number of minutes to elapse before the users are disconnected.

4.  Click OK.



File sharing is turned off after the amount of time you specify elapses.
Users who are currently connected receive warning messages so they can save
their work. If someone is using files on your Macintosh when file sharing is
turned off, any changes he or she has made and has not saved will be lost.

Monitoring file-sharing activity

When file sharing is on, you can see who is connected to your computer and
what folders or disks you've shared.

- Choose Control Panels from the Apple menu and open the File Sharing Monitor
control panel.

The File Sharing Monitor control panel opens.

A list of your shared folders and disks appears on the left side of the
window. All of the files and folders listed are accessible to network users,
unless you have restricted their access privileges.

A scrolling list of all the network users currently connected to your
Macintosh appears on the right side of the window.

Disconnecting someone who is connected to your computer.

You can disconnect users who are currently connected to your Macintosh in the
File Sharing Monitor control panel.

1.  Select the user or users that you want to disconnect.

To select more than one user, hold down the Shift key while clicking the
names of all the users you want to disconnect.

2.  Click Disconnect.

A dialog box appears.

3.  Type the number of minutes that you want to elapse before disconnection
occurs.

To disconnect a user immediately, type the number 0. Otherwise, type the
number of minutes to elapse before the user is disconnected. It's a good idea
to give people enough time to save any changes they have made to the files.

4.  Click OK.

If you typed a number greater than 0 in step 3, a box displays how much time
will elapse before the user is disconnected. The warning box disappears when
the user is disconnected. You can continue with your work in the meantime.

5.  When the designated amount of time has elapsed, close the File Sharing
Monitor.

You can't close the File Sharing Monitor until the amount of time you
specified has elapsed and the user is disconnected. However, you can open
other windows and continue with your work during that time.

Gaining access to your computer when you're away from it



You can connect to your own Macintosh from another computer on the network
and access everything on all of the hard disks or CD-ROM discs attached to
your computer. As the owner of your computer, only you have this privilege.

1.  Make sure that file sharing is turned on.

2.  Choose Control Panels from the Apple menu and double-click the Users &
Groups icon to open it.

3.  Open the owner icon (the one with the bold outline).

4.  Click the boxes labeled "Allow user to connect" and "Allow user to see
entire disk" to place an X in them if there isn't one there already.

When these boxes are checked, you can see and use everything on your hard
disks or CD-ROM discs from another computer.

To restrict the access you have from another computer, click a checkbox to
remove the X.

5.  Close the window and the Users & Groups control panel.

6.  Leave your computer turned on.

To gain access to your computer from another computer, connect to it as a
registered user. Type your owner name and password (as they appear in the
Sharing Setup control panel of your computer). Then continue the connection
process as you normally would.

If you are unable to connect to your computer:  Make sure that your computer
is turned on, that file sharing is turned on, and that you have given
yourself access privileges to connect to your computer. Also make sure that
you type your password exactly as it is entered in the Sharing Setup control
panel, including the use of capital and lowercase letters. 

Changing your password.

You can change the password you use to gain access to your own computer from
another computer.

1.  Choose Control Panels from the Apple menu and open the Sharing Setup
control panel.

2.  Type a new password in the box labeled Owner Password.

3.  Press Tab.

Each character of your password is replaced by a bullet (�) to help keep it
private.

4.  Close the Sharing Setup control panel.

Your new password is now in effect.

Using Access Privileges

When people share information over a network, network users may want to



control what other people can do with that information. For example, you
might want to let people see a file but prevent them from changing it. This
section describes how to use and work with access privileges -- the abilities
to see files and folders and make changes to them.

Before you proceed with this section, make sure you know how to share a
folder on your own computer as described in "Sharing Your Files Over the
Network" earlier in this chapter, or that you know how to connect to a shared
disk on another computer as described in "Gaining Access to Files on Other
Computers" in this chapter.

Understanding access privileges

You can set access privileges for any shared folders on your own computer and
any folders you create on a file server or on another Macintosh. In addition,
owners of other computers can set access privileges that restrict what you
can do with their shared disks.

There are three categories of people who can have access privileges to shared
disks and folders:

- The owner. The owner of a folder is the only person (or group) who can
control the access privileges of the folder. You become the owner of a folder
automatically when you create it. You can keep ownership, or give it to a
registered user or registered group on the computer. You can also give
ownership to <Any User>, which allows anyone on the network, including
guests, to modify the folder's access privileges.

- A registered user or group.

- Everyone. Privileges assigned to guests apply to everyone, since everyone
can connect to a computer as a guest (as long as guest access is allowed).

Owners, registered users, and guests can be given three types of access to
shared disks and folders:

- See Folders allows people to see the folders within a folder or disk. If
people do not have the See Folders privilege, folders within a shared folder
do not appear on their screen.

- See Files allows people to see the files within a folder or disk. If people
do not have the See Files privilege, files within the folder or disk do not
appear on their screen.

- Make Changes allows people to make changes to a folder or disk -- copy
files or folders to it, delete files or folders, or change any of its
contents.

You need different access privileges to do certain operations with items in a
shared folder or disk.

Setting access privileges to folders and disks

You can set access privileges for any shared folders or disks on your own
computer and for any folders that you own on other computers.

1.  Select the folder or disk by clicking it once.



2.  Choose Sharing from the File menu.

A window appears.

This window may be slightly different on your computer.

- If you've selected a folder that is inside a shared folder, the checkbox
labeled "Share this item and its contents" does not appear. Instead, a
checkbox labeled "Same as enclosing folder" appears.

- If you've selected a folder on another computer, the area next to the Owner
and User/Group labels will be boxes, in which you type text, and not pop-up
menus.

- If you've selected a folder on another computer and you are not its owner,
all of the checkboxes and their labels are dimmed.

3.  Choose a registered user or group to share the item with.

If the folder you've selected is on your own computer, choose from the list
of users and groups in the pop-up menu next to the label User/Group. This
menu contains the names of the registered users and groups on your computer.

If the folder you've selected is on another computer, type the name of a
registered user or group in the box next to the label User/Group. You must
type the name exactly as it is registered on the computer you're connected
to.

4.  To give access privileges to yourself, to a registered user, or to
everyone, click the appropriate checkbox to place an X in it.

- To set privileges for the folders within this folder or disk, place an X in
the box labeled "Make all currently enclosed folders like this one." When you
place an X in this box, the access privileges for the folders inside this
folder or disk are the same as this folder or disk's access privileges. You
can change the access privileges for an enclosing folder at any time.

If you use this feature for an item that contains a large number of folders,
such as a CD-ROM disc, this action could take a few minutes to complete.

- To prevent anyone on the network -- including yourself --  from moving,
deleting, or renaming this folder, place an X in the box labeled "Can't be
removed, renamed, or deleted." You can use this checkbox to ensure that a
folder stays where you leave it.

- To give this folder the same privileges as the folder or disk enclosing it,
place an X in the checkbox labeled "Same as enclosing folder." This checkbox
only appears for folders that are inside shared folders. When you move a
folder that has this box checked to another folder, its access privileges
change to reflect those of its new enclosing folder.

5.  When you're finished setting access privileges, close the Sharing window
and then click Save in the dialog box that appears.

The access privileges go into effect immediately.

Access privilege strategies.



You can combine access privilege settings in any way you like. Some useful
configurations follow.

- Allow everyone on the network all access privileges.

When guest access is allowed on the computer storing a shared folder or disk,
everyone on the network can open, read, and change the files and folders
inside it.

- Keep a folder or disk private. To keep a folder or disk on your own
computer private, do not share the folder. To keep a folder that you own on
another computer private, use these settings. You have full access but no one
else can open, use, or even see its contents.

- Allow access by one other person or group. This set of privileges allows
only you -- the owner of the folder or disk -- and the registered user or
group that you have named to gain access to a shared folder or disk.

- Keep a folder private but allow others to place files or folders in it.
People on the network can deposit files or folders into a folder but cannot
see, remove, or change its contents. (This configuration is sometimes called
a drop box.)

- Set up a folder as a bulletin board. People can open and read the files in
a folder but cannot change them.

Working with privileges that others have set.

When you are using the By Icon or By Small Icon view, the appearance of
shared folders changes to indicate the kinds of access you have to that
folder.

A darkened tab indicates that you are the owner of the folder and you can set
its access privileges. Shared folders on your own computer have this darkened
tab. Folders that you own on other computers also have the darkened tab.

A plain tab indicates that you can open and use the folder. Folders on your
own computer have a plain tab when they have not been shared. Folders on
other computers that have this icon indicate that you do have some privileges
to the folders, although you are not their owner.

A folder with a strap around it indicates that you do not have any access
privileges to this folder. This icon does not appear on your own computer.

A strapped folder with an arrow indicates that you can put files or folders
into this folder, but you cannot open it or use any files or folders within
it. This icon does not appear on your own computer.

Checking your access privileges.

When you open a folder on another computer on the network, icons are
displayed under the title bar of the folder window that indicate the
privileges that you do not have to the folder.

Linking Programs Over The Network

Some of the programs available for your Macintosh can exchange information
directly with other programs. For example, one program might be able to



instruct another program to perform a specific action, such as adding a row
to a spreadsheet or changing the font size of a paragraph.

Programs implement program linking in various ways and not all programs have
this capability. See the documentation that came with your programs for more
information.

Linking to a program on another computer

You can only link to programs that have been shared by the owners of the
computers on which the programs reside.

1.  Within your program, choose the menu command that allows you to link
programs.

The menu location and command name differ from program to program. A dialog
box opens that you use to find the program on the network that you want to
link to.

2.  If your network has zones, select the zone of the Macintosh you want to
connect to in the lower-left corner of the dialog box.

3.  Select the Macintosh you want to connect to in the upper-left section of
the dialog box.

4.  Select the program you want to link to.

5.  Click OK.

In most cases, a dialog box appears, where you identify yourself as a guest
or a registered user.

6.  Click Guest or Registered User.

If you are a guest or if you are not certain that you are registered, click
Guest and go on to step 9. If you are a registered user, click Registered
User.

If the Guest option is dimmed, guests are not permitted access to this
computer.

7.  If you are a registered user, make sure that the name shown in the box
labeled Name is the exact name that is registered.

If the name is not your user name, type your user name exactly as it is
registered.

8.  Type your password, exactly as it is registered (including capital and
lowercase letters).

9.  Click OK.

The two programs are now linked.

Disconnecting a program link.

To disconnect a link you established to a program on another computer, quit
the program from which you created the link.



Allowing other people to link to your programs

You can allow people on the network to link their programs to programs on
your computer.

How program linking works.

You can allow other users to link to programs on your computer by taking a
few discrete steps.

- First, you turn on program linking.

- Second, you make a specific program available for linking by sharing it.

- Third, you either allow guest access to the shared program or name the
specific people whom you want to be able to link programs to the shared
program.

When you've completed these three steps, other people can link their programs
with programs on your computer.

Turning program linking on

When you turn program linking on, you let others on the network connect to
your computer for the purpose of linking programs. Before you turn program
linking on, make sure that AppleTalk is active (in the Chooser) and that you
have named your Macintosh (see "Naming Your Macintosh and Its Owner" earlier
in this document).

1.  Choose Control Panels from the Apple menu and double-click the Sharing
Setup icon to open it.

2.  In the section labeled Program Linking, click the Start button.

Program linking starts up. When program linking is established, the button
changes to Stop (click the Stop button when you want to turn program linking
off).

3.  Close the Sharing Setup control panel.

Once program linking is turned on, you must identify specific programs for
linking before network users can link to them.

Selecting a program for linking.

A network user cannot link to your program unless you have specifically
shared it first.

1.  Select a program on your computer that features program linking by
clicking the program's icon.

Check the documentation that came with the program to make sure that it has
this capability. If the program is open, you have to quit from it before you
can share it.

2.  Choose Sharing from the File menu.



The Sharing dialog box appears.

3.  Click the box labeled "Allow remote program linking" to place an X in it
(if there isn't one in it already).

If the checkbox is dimmed, the program you have selected does not allow
program linking, so you cannot share it.

4.  Close the window.

After the window closes, programs on other computers can link to your program
as long as your computer is turned on, program linking is turned on, and the
program is running.

Allowing guests to link to your programs.

You can let everyone on the network link programs to your shared programs.

1.  Choose Control Panels from the Apple menu and double-click the Users &
Groups icon to open it.

2.  Double-click the <Guest> icon.

3.  Click the box labeled "Allow guest to link to programs on this Macintosh"
to place an X in it (if there isn't one in it already).

4.  Close the dialog box.

Guest users can now link programs to any of the programs on your computer
that you have shared.

Naming specific users to link to your programs.

You can identify the registered users and groups you want to allow to link to
your programs. (See "Naming the People Who'll Have Access to Shared Files"
earlier in this document for information about naming registered users and
groups.)

1.  Choose Control Panels from the Apple menu and double-click the Users &
Groups icon to open it.

2.  Open the icon of a user whom you want to link programs with.

3.  Click the box labeled "Allow user to link to programs on this Macintosh"
to place an X in it (if there isn't one in it already).

4.  Close the window and click Save in the dialog box that appears.

5.  To give more registered users access to your programs, repeat steps 2
through 4.

Using Communications Products With System 7

Using the Communications Toolbox

If you have already installed the Communications Toolbox with Macintosh
system software version 6.0 or later, read the following guidelines to use
the Communications Toolbox with Macintosh system software version 7.0.



Consult the manual that came with the program that uses the Communications
Toolbox for detailed information about how to use it.

- Do not install the Communications Toolbox. The Communications Toolbox has
been integrated into system software version 7.0.

- With versions of system software prior to System 7,  communications tools
were placed in a Communications folder in your System Folder. To use
communications tools with System 7, drag them to the Extensions folder in
your System Folder.

- Wherever a program or its documentation refers to the "Communications
Folder," substitute "Extensions Folder."

Using Data Access Language

If you used Data Access Language (DAL) with Macintosh system software version
6.0 or later, follow the steps below to use it with Macintosh system software
version 7.0. For detailed information about using your DAL application
program, consult the manual that came with it.

To use programs that search for the "hosts.CL1" file, do the following:

1.  Make a copy of the DAL Preferences file that is in the Preferences folder
in the System Folder.

2.  Rename the duplicate file: Hosts.CL1.

3.  Move the renamed file outside the Preferences folder but inside the
System Folder.

4.  Use your program as you normally do. Whenever you make changes to one of
these files, you must update the duplicate file.

CHAPTER 14-EXPANDING YOUR MACINTOSH SYSTEM

In this document

- Connecting hard disks and other SCSI devices

Installing a device driver

Setting the SCSI ID number

Attaching a SCSI device

- Connecting a printer

- Connecting a modem

- Connecting an external floppy disk drive

- Connecting a trackball or other ADB device

- Connecting headphones or speakers

- Connecting a microphone



- Connecting additional monitors

- Installing expansion cards

NuBus power requirements

- Expanding memory

Connecting Hard Disks And Other SCSI Devices

Every Macintosh computer has a socket, or port, for connecting devices that
use the Small Computer System Interface (SCSI, pronounced "skuh-zee"). The
SCSI port permits high-speed communication between the computer and the
device. The SCSI icon appears above the port on the computer's back panel.

!!  Important:  Follow the instructions in this section and the instructions
that came with your hard disk or other SCSI device when connecting it to your
Macintosh.  !!

SCSI devices commonly used with the Macintosh include hard disks, CD-ROM
drives, scanners, printers, and tape backup drives.

By connecting SCSI devices to one another (in a "daisy chain"), you can have
up to seven such devices, including an internal hard disk, connected to your
Macintosh. Each device must have its own, unique ID number.

Setting up a SCSI device to use with your Macintosh involves

- installing any necessary device drivers

- setting the device's SCSI ID number

- physically attaching the device to your Macintosh

Installing a device driver

To install a device driver:

- Drag the device driver icon to the System Folder on your startup disk.

Any device drivers needed for a SCSI device are usually on a floppy disk that
comes with the device. (If no device drivers come with the device, then it
doesn't need any.) You may have to restart your Macintosh to activate the
device driver, which the computer needs to communicate with -- or "drive" --
the device.

Setting the SCSI ID number

See the instructions that came with your SCSI device for information on
setting its SCSI ID number.

!!  WARNING:  Each SCSI device connected to your Macintosh must have its own,
unique ID number between 1 and 6 so that your computer can distinguish it
from other attached SCSI devices. Using two or more devices with the same ID
number can cause them to malfunction. You could lose data as a result.  !!

Give greater ID numbers to the devices you use more often. Your Macintosh



uses the numbers to set priorities when it communicates with its SCSI devices
(the greater a device's ID number, the higher its priority).

If you have an Apple SCSI device, set the SCSI ID number as follows:

1.  Make sure the device is switched off.

2.  Choose a number between 1 and 6 that hasn't been assigned to any other
SCSI device connected to your Macintosh.

Each device in a chain of SCSI devices connected to your computer must have
its own ID number that distinguishes it from other devices in the chain. The
ID number must be between 1 and 6 (if you have an internal hard disk, its ID
number is preset to 0, and your Macintosh itself has the ID number 7).

3.  Insert a straightened paper clip into the small hole directly below the
ID number indicator (usually on the back panel of the SCSI device). The small
hole gives you access to the ID number switch.

4.  Push the ID number switch repeatedly until the number you want appears in
the ID number indicator.

Attaching a SCSI device

To connect a SCSI device to your Macintosh:

1.  Turn off your Macintosh.

2.  Make sure the SCSI device is switched off.

!!  WARNING:  Do not connect or disconnect any device while the device or
your Macintosh is turned on. Doing so could damage the device, your computer,
or both.  !!

3.  Make sure the device has its own, unique ID number between 1 and 6.

4.  Use a SCSI cable to connect the device either to the SCSI port or to the
last SCSI device already in the chain.

If the device is the first one in the SCSI chain (or the only one you're
connecting), use a SCSI system cable to connect it to the SCSI port.

If the device is not the first one in the chain, use a SCSI peripheral
interface cable to connect it to the last SCSI device already in the chain.

!!  IMPORTANT:  The total length of a SCSI chain should not exceed 6 meters
(20 feet).  !!

5.  Make sure that the first device and the last device in the SCSI chain
each have a terminator and that no other external SCSI device has one.

To ensure accurate transmission of information, a terminator must be at each
end of a SCSI chain.

An internal hard disk, which is always the first device in the chain, has a
built-in terminator. The Macintosh Classic, Macintosh LC, and Macintosh IIfx
have built-in terminators (whether or not they have internal hard disks).



- If you have an internal hard disk, or if your Macintosh has a built-in
terminator, you only have to make sure that the last device in the chain has
a terminator and that no other external SCSI device has a terminator.

- If you do not have an internal hard disk or a Macintosh with a built-in
terminator and are connecting your Macintosh to two or more external SCSI
devices, you need terminators in the first device and the last device, and
none in between.

- If you're connecting your Macintosh to a single SCSI device (whether or not
you have an internal hard disk), make sure the device has a terminator.

If you have a Macintosh IIfx, use the black cable terminator that came with
your computer. Do not use any other terminators with or instead of the black
cable terminator. Also, you or your authorized service provider should
disconnect or remove any other terminators built into your SCSI devices.
Using terminators other than or in addition to the black cable terminator may
cause your SCSI devices to malfunction, and you may lose data as a result.

A SCSI device may have a built-in terminator. If a device that's at the end
of the SCSI chain does not have a built-in terminator, you need to attach an
external cable terminator to it.

To find out if your SCSI device has a built-in terminator, go to the
instructions that came with the device. (External SCSI devices from Apple
Computer do not have built-in terminators.) Have your authorized Apple
service provider remove any extra built-in terminators. You can attach or
remove cable terminators yourself.

!!  IMPORTANT:  Always turn on any external SCSI devices connected to your
Macintosh before turning on the computer itself. Otherwise, your computer
cannot recognize the SCSI devices.  !!

Check the setup book that came with your Macintosh for any additional
information on connecting SCSI devices.

Connecting A Printer

Every Macintosh has a printer port, which you use to connect a printer to
your computer.

The printer port accepts either a direct cable connection (to printers such
as the ImageWriter II) or a network cable connection (to printers such as the
LaserWriter IINT). Certain printers (such as the Personal LaserWriter SC) are
connected through the SCSI port as a SCSI device.

Follow the instructions that came with your printer when connecting it to
your Macintosh.

A printer can also be connected to the modem port. You use the Chooser
program to indicate the port you used to connect your printer. (See
"Printing," for more information.)

Connecting A Modem

Every Macintosh has a modem port, which you use to connect an external modem
to your computer. (A modem is a device that allows your computer to
communicate with other computers over standard telephone lines).



Follow the instructions that came with your modem when connecting it to your
Macintosh.

You can connect a modem to the printer port (if you're not using it for a
printer), but your Macintosh gives the modem port priority over the printer
port when it checks for data transfer activity. This priority better ensures
that any communications link your computer establishes through the modem
remains intact.

Connecting An External Floppy Disk Drive

Some Macintosh computers have a disk drive port, which you use to connect an
external floppy disk drive.

Follow the instructions that came with your external floppy disk drive when
connecting it to your Macintosh.

If your Macintosh does not have a disk drive port, you can buy an external
floppy disk drive that attaches to the SCSI port.

Connecting A Trackball Or Other ADB Device

Every Macintosh computer has at least one Apple Desktop Bus (ADB) port, which
you use to connect the mouse, the keyboard, and other input devices such as a
trackball, a bar-code reader, or a graphics tablet.

By connecting ADB devices to one another (in a "daisy chain"), you can have
up to three such devices connected to a single ADB port. The exact number
depends on how much power the devices require.

!!  IMPORTANT:   The total power used by all Apple Desktop Bus devices
connected to your Macintosh must not exceed 500 milliamperes (mA).
Information about the power requirements of your mouse and keyboard are in
the setup book that came with your Macintosh. See the instructions that came
with any other ADB device if you need information on its power requirements.
!!

Connecting Headphones Or Speakers

Every Macintosh computer has a sound output port, which you use to connect
speakers, an amplifier, headphones, or other audio output devices to your
computer. The sound output port accepts a standard stereo miniplug, like that
used to attach headphones to a portable stereo audio cassette player.

Connecting A Microphone

Certain Macintosh models (such as the Macintosh LC) have a sound input port,
which you use to connect a microphone or other sound source to your computer.
The sound input port accepts a standard miniplug.

See the setup book that came with your Macintosh for additional information
on the sound input port.

See "Adapting Your Macintosh to Your Own Use," for information about
recording sound on your Macintosh.

Connecting Additional Monitors



Most Macintosh computers accept video cards that let you connect additional
monitors. Your first monitor may be built-in (as in the Macintosh Classic),
connected to a built-in video port (as in the Macintosh IIci), or connected
to a video card installed in a NuBus slot (as in the Macintosh IIfx). See the
setup book that came with your computer for information on installing video
cards.

When you set up additional monitors:

- Make sure that the ventilation openings on the computer and the monitor are
clear and unobstructed.

- Some large monitors cannot safely be placed on top of the Macintosh. Check
the instructions that came with the monitor for setup information.

- If there is interference on your screens or on a television or radio near
your Macintosh, move the affected equipment farther apart.

See "Adapting Your Macintosh to Your Own Use," for information on configuring
multiple monitors in the Monitors control panel.

Installing Expansion Cards

All Macintosh computers except the Macintosh Classic accept printed circuit
boards (called cards) for video and graphics applications, networking and
communications, additional processing power, and other purposes. The cards
fit into connectors, called expansion slots, inside the computer.

!!  IMPORTANT:  See your setup book for information on installing expansion
cards. Some cards may need to be installed by an authorized Apple service
provider.  !!

Like all electronic components, expansion cards generate heat. If you install
several cards in your Macintosh, leave as much room as possible between cards
and between cards and other internal components.

Macintosh expansion slots come in two types:

- NuBus slots, which accept NuBus expansion cards

- Processor-direct (or memory cache) slots

All Macintosh II models have at least one NuBus slot. (An optional slot
adapter is required in the Macintosh IIsi.) In the models that have a
processor-direct or memory cache slot (such as the Macintosh LC and the
Macintosh IIci), only one such slot is available.

!!  WARNING:  Install an expansion card only in the slot designed to accept
it. Failure to do so could damage the card and your computer. NuBus cards fit
in any NuBus slot, but a processor-direct or memory-cache card is often
designed only for a specific Macintosh model.  !!

NuBus power requirements

The combined power consumption of all installed NuBus cards must not exceed
the limits specified for your Macintosh model. If you have two or three NuBus
cards installed or are concerned about the amount of power consumed by a



particular card, make sure that your NuBus cards' power consumption is within
specified limits.

1.  Find out the power consumption (in amperes) of each NuBus card you have
installed by checking its technical specifications.

NuBus cards draw power from three types of current:

- +5 volt

- +12 volt

- -12 volt

2.  Calculate the total power consumption in each type of current of all
installed NuBus cards.

3.  Find out the maximum power consumption for all NuBus cards specified for
your Macintosh by checking the setup book that came with your computer.

!!  WARNING:  Do not exceed the maximum power consumption for all NuBus cards
specified for your computer. Doing so could damage your cards, your
Macintosh, or both.  !!

Expanding Memory

The random-access memory (RAM) in your Macintosh can be expanded by adding
Single In-Line Memory modules (or SIMMs) to those already installed or
exchanging installed modules for ones that have greater storage capacity.
(Some Macintosh models also accept memory expansion through the installation
of a memory card.)

Make sure that SIMMs you purchase for memory expansion are the correct ones
for your Macintosh. See the setup book that came with your computer for more
information.

!!  WARNING:  Memory expansion on the main circuit board should be installed
only by an authorized Apple service provider or other qualified technician.
Modification of the circuit board by anyone except a qualified technician
voids your warranty and could damage your computer.  !!

CHAPTER 15-CARE AND MAINTENANCE
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Cleaning the mouse
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Handling System Components

Follow these guidelines when setting up and using your Macintosh computer and
its components:

- Handle all components with care.

- Place components on a sturdy, flat surface.

- Carefully follow all setup instructions.

- Always hold a cable by its connector (the plug, not the cord) when
connecting or disconnecting it.

- Never force a connector into a port. If connector and port do not join with
reasonable ease, they probably do not match. Make sure that the connector
matches the port and that you have positioned the connector correctly in
relation to the port.

- Turn off your Macintosh and all its components before connecting or
disconnecting any cables to add or remove any component. Failure to do so
could seriously damage your equipment.

- Take care not to spill any food or liquid on the computer, keyboard, mouse,
or other components. If you do, turn your Macintosh off immediately and
unplug it before cleaning up the spill. Depending on what you spilled and how
much of it got into your equipment, you may have to bring your equipment to
an authorized Apple service provider.

!!  WARNING:  Plug the power cords for the Macintosh and its components only
into three-prong, grounded outlets. The computer's grounding-type plug is a
safety feature. Do not defeat the purpose of this plug. Disconnect the power
plug if it becomes frayed or otherwise damaged.  !!

Monitor

Follow these procedures whether your Macintosh has a built-in or a separate
monitor:

- Turn down the screen brightness control if you leave the Macintosh turned
on for extended periods. If the brightness is not turned down, the image on
the screen could "burn in" and damage the screen.

You can also use a "screen saver" program, which dims or varies the image on
the screen when the Macintosh has been idle for a specified period of time.
These programs are available from independent suppliers and user groups.

- Make sure that the ventilation openings on the computer and the monitor are
clear and unobstructed.



- Some large monitors cannot safely be placed on top of the Macintosh. Check
the instructions that came with the monitor for setup information.

- If there is interference on the monitor's screen or on a television or
radio near your Macintosh, move the affected equipment farther away.

Keyboard

Take care not to spill any liquid on the keyboard. If you do, turn off your
Macintosh immediately.

- If you spill liquid that is thin and clear, unplug the keyboard, turn it
upside down to let the liquid drain out, and let it dry for 24 hours at room
temperature. If, after you take these steps, the keyboard doesn't work, take
it to your authorized Apple service provider for repair.

- If you spill liquid that is greasy, sweet, or sticky, unplug the keyboard
and take it to your authorized Apple service provider for repair.

Floppy disks and drives

Store disks at temperatures between 50° F and 125° F.

Don't use an eraser on a disk label.

Keep disks dry.

Don't touch the exposed part of the disk behind the metal shutter.

Keep disks away from magnets.

Avoid exposing disks to extremely hot temperatures.

Power supply

The power supply in your Macintosh is a high-voltage component and should not
be opened for any reason, even when the computer is off. If the power supply
needs service, contact your authorized Apple dealer or service provider.

Cleaning System Components

To clean the outside of your Macintosh and its components:

- Use a damp, soft, lint-free cloth to clean the computer's exterior. Avoid
getting moisture in any openings.

- Don't use aerosol sprays, solvents, or abrasives.

- To clean the screen, put household glass cleaner on a soft cloth and wipe
the screen. Don't spray the cleaner directly on the screen, because the
liquid might drip into the monitor or computer.

Cleaning the mouse

The mouse contains a small ball that must roll smoothly for the mouse to work
properly. You can keep this ball free of dirt and grease by using the mouse
on a clean, lint-free surface and cleaning it occasionally.



You need a few cotton swabs, alcohol, and a clean, soft, lint-free cloth.

1.  Turn off your Macintosh.

2.  Turn the mouse upside down and remove the plastic ring on the bottom that
holds the ball.

The plastic ring comes in two types. You remove one by turning it
counterclockwise; you remove the other by pulling the ring downward until it
pops out.

3.  Turn the mouse right side up with one hand and catch the ring and the
ball with your other hand.

4.  Clean the three small rollers inside the mouse with a cotton swab
moistened with alcohol.

Rotate the rollers to clean all around them.

5.  Wipe the mouse ball with a clean, soft, dry, and lint-free cloth.

Don't use any liquid to clean the ball.

6.  Gently blow into the mouse case to remove any dust that has collected
there.

7.  Put the ball and the ring back in place.

Maintaining The Proper Operating Environment

In general, any conditions in which you are reasonably comfortable should be
fine for your Macintosh.

- See the setup book that came with your computer to find out the range of
temperature and humidity that your Macintosh is designed to operate within.

- Protect the Macintosh and its components from direct sunlight and rain or
other moisture.

- Keep all ventilation openings clear and unobstructed. Without proper air
circulation, components can overheat, causing damage or unreliable operation.

Changing The Clock Battery

Every Macintosh computer has a clock that runs continuously. When the
computer is turned off, a battery keeps the clock running.

If your clock begins to keep time inaccurately, have your authorized Apple
service provider replace the battery.

Service And Support

To help you get the best performance from your system, Apple Computer has
established authorized Apple dealers who offer full support. If you need
answers to technical questions or information about product updates, your
authorized Apple dealer can help you. Apple's technical support organization
backs each dealer and international technical support group via an AppleLink
network, a state-of-the-art on-line electronic information service, to ensure



prompt, reliable assistance.

Your dealer has the latest information on new hardware and software products
as well as product updates. If you wish to upgrade your system, your dealer
can help you select compatible components.

If your product requires service, your local authorized Apple dealer is
trained and ready to support you. Apple provides factory-quality parts and
the latest available diagnostic equipment to the more than three thousand
authorized Apple service centers throughout the world. Apple guarantees parts
and warranty labor. (Regulations in each country determine the length of
warranty. Some restrictions may apply, depending on the country of original
purchase.)

If for some reason you cannot return to the authorized dealer from whom you
purchased your system, go to the nearest service location. For the location
nearest you, in the United States or Canada, call or write to one of the
following:

Apple Computer, Inc.
Customer Relations
20525 Mariani Avenue
Cupertino, CA 95014-6299
U.S.A.
800-538-9696

Apple Canada, Inc.
7495 Birchmount Road
Markham, Ontario, L3R5G2
Canada
800-268-7796 or
800-268-7637

For locations in other countries, either call the Apple headquarters in your
country or write to the United States address given above.

Apple also offers service plans designed to meet your needs. One of these is
the AppleCare Service Agreement (available in the United States, Canada, and
Australia only), which extends full warranty coverage up to three years. Your
AppleCare contract will be honored at any participating authorized Apple
dealer within the country of purchase -- an added benefit if you relocate.
Local service means time saved in getting your Apple system back to work.

You can purchase AppleCare at any time, but it's a good idea to purchase it
with your system, or at least before your warranty has expired, to avoid an
inspection at your own expense.

CHAPTER 16-TIPS AND TROUBLESHOOTING
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- When you run into trouble



Take your time

Start over

Rebuild your desktop regularly

Solutions to common problems

Getting The Best-looking Fonts

To have fonts look their best on the screen, install bitmapped fonts in the
sizes you use most often. And for the closest match between displayed fonts
and printed fonts, install the corresponding bitmapped fonts when you install
PostScript outline fonts.

Your Macintosh looks for either outline fonts or bitmapped fonts to use
depending on

- whether the font is displayed on the screen or printed on a printer, and

- whether (if the font is printed) the printer is equipped to handle
PostScript (a programming language that describes the characters, symbols,
and images appearing on each page of a document)

When you print a document on a PostScript printer (such as the LaserWriter
IINT), the system software looks for the fonts you use in the following
places, in order:

1.  PostScript outline fonts in the printer's permanent memory (ROM)

2.  PostScript outline fonts in the printer's temporary memory (RAM)

3.  PostScript outline fonts in any hard disk connected to the printer

4.  PostScript outline fonts in your System Folder

5.  TrueType outline fonts in your System Folder

6.  bitmapped fonts in your System Folder in the correct size

7.  bitmapped fonts in your System Folder in a different size that can be
reduced or magnified to roughly approximate the correct size

When you print a document on a printer that does not recognize PostScript
(such as the Personal LaserWriter SC), and when the Macintosh displays fonts
on the screen, the system software looks for the fonts as follows:

1.  bitmapped fonts in your System Folder in the correct size

2.  TrueType outline fonts in your System Folder

3.  bitmapped fonts in your System Folder in a different size that can be
reduced or magnified to roughly approximate the correct size

Taking A "Snapshot" Of The Screen

You can capture the image on the screen by pressing Command-Shift-3. The
image is saved as a graphics file, which can be opened in many programs that



handle graphics (including the TeachText program that's supplied with the
system software).

The graphics files are named "Picture 1," "Picture 2," and so on. The number
of screen images you can take is limited only by available disk space.

When You Run Into Trouble

For specific troubleshooting information related to a particular procedure,
go to the chapter that describes the procedure.

Take your time

When you see an error message, you don't have to take action immediately. The
message stays on the screen until you click the OK button or turn off the
Macintosh.

To help diagnose and correct the problem, gather as much information about
the situation as you can before starting over:

- Make a note of exactly what you were doing when the problem occurred. Write
down the message on the screen and its ID number (if any) as well as the
programs you were using and the names of any items you know have been added
to the System Folder since the system software was installed. (This
information will help a service person diagnose the problem should you need
to take the computer to your authorized Apple dealer for repair.)

- Check the screen for any clues. Is a menu selected? What programs and
document icons are open? Note anything else that seems relevant.

- If you were typing text and were not able to save it before the problem
occurred, you can write down the parts of the text still visible on the
screen so that some of your work will be easy to replace.

- Ask other Macintosh users about the problem you're having; they may have a
solution for it.

Start over

Often you can eliminate a problem simply by clearing the computer's memory
and starting over.

If you can, save any open documents before restarting the Macintosh. If your
system is "frozen" and does not respond to any input, or if you have a "bomb"
message on the screen, saving may not be possible. You can try pressing
Command-Option-Esc to quit the program in use when the problem occurred; if
this works, you can then save the documents open in other programs before
restarting.

To restart your Macintosh, try the following steps:

1.  If you can, choose Restart from the Special menu or from the dialog box
that's on screen.

2.  If you can't choose Restart, hold down the Command and Control keys while
you press the Power On key.

3.  If nothing happens, look for the reset and interrupt switches on the



front or side of your Macintosh and press the reset switch (the one marked
with a triangle).

Not all Macintosh models have reset and interrupt switches, which are usually
installed as a unit when the computer is first set up.

Pressing the reset switch is like turning the power switch off and on. (The
interrupt switch is intended for use by programmers who have debugging
software installed.)

4.  If pressing the reset switch does nothing or if your Macintosh does not
have a reset switch, turn off your computer using the power switch, wait at
least 10 seconds, then turn it on again.

5.  If the power switch doesn't turn off the computer, unplug your Macintosh.

If you suspect that the problem is with a peripheral device, such as a
printer or external hard disk, turn it off for 10 seconds or more, then turn
it on again and restart the Macintosh.

Rebuild your desktop regularly

A process known as "rebuilding the desktop" helps your Macintosh keep track
of data on your startup disks.

- To rebuild the desktop of a startup disk, hold down the Option and Command
keys while starting up your computer. Keep holding down the keys until you
see a message asking whether you want to rebuild the desktop. Click OK.

- Rebuild the desktop of your startup disks once a month or so.

Solutions to common problems

The computer is turned on but the screen is dark.

The Macintosh or the monitor is not getting power, or the screen is adjusted
too dark.

- Check that the power cord is plugged in and firmly connected to the
computer and that the electrical outlet has power.

- If you have a separate monitor, check that the monitor is turned on.

- Check the screen's brightness control and turn it up if necessary.

- If you use a screen saver program, press a key or move the mouse to turn
off the screen saver.

When you start up, an icon appears in the middle of the screen and the
desktop doesn't appear.

The system software is not installed on your hard disk or your hard disk is
not working properly.

When you turn on the Macintosh, one of these icons appears in the middle of
the screen:

- The "happy Macintosh" icon indicates that your Macintosh has found a



startup disk (which has the system software installed in the System Folder)
and is starting up.

- The disk icon with a blinking question mark indicates that your Macintosh
cannot find a startup disk. If you inserted a floppy disk, or if you have a
hard disk installed, your Macintosh doesn't recognize that disk as a startup
disk.

Use the system software disk labeled Disk Tools to start up your Macintosh.
(See "Starting Up With a Floppy Disk" in, "Setting Up Your Macintosh System,"
and "Testing and Repairing Disks", "Hard Disks and Floppy Disks," for
instructions on starting up with a floppy disk and repairing damaged disks.)

- The disk icon with an X appears when your Macintosh ejects a floppy disk
that is not a startup disk.

- The "sad Macintosh" icon appears when your Macintosh cannot start up
because of a problem with the system software or possibly the computer
hardware.

Eject any floppy disks by turning off the computer and then holding down the
mouse button while you turn the computer on again. Try starting up with a
different startup disk. If the "sad Macintosh" icon appears again, see your
service provider.

The pointer doesn't move when you move the mouse.

The mouse is not connected properly or its signals are not reaching the
computer.

- Turn off the computer using the power switch, then check that the mouse
cable is connected properly.

- Clean the mouse. (See "Care and Maintenance.")

- Restart the Macintosh with a different startup disk. If the pointer still
doesn't move, consult your service provider.

Typing on the keyboard produces nothing on the screen.

The insertion point hasn't been set, no text is selected, the keyboard is not
connected properly, or its signals are not reaching the computer.

- Make sure the program you want to type in is the active program.

- Place the pointer in the active window and click to set an insertion point
or drag to select text (if applicable).

- Turn off the computer, then check that the keyboard cable is connected
properly at both ends.

- If the connections are secure and typing still yields no results, shut down
and turn off the Macintosh, then unplug the keyboard cable. Connect the cable
to the other Apple Desktop Bus port on the computer and the other ADB port on
the keyboard. (You may have to unplug the mouse to do this.) If typing still
shows nothing on the screen, the problem is most likely in the keyboard
itself.



- Restart the Macintosh with a different startup disk. If typing still
doesn't produce text on the screen, see your service provider.

A dialog box with a bomb appears.

Your system has a software problem.

- Write down what you were doing when the message appeared, and write down
the number on the message, if there is one.

- Restart your Macintosh (see "Start Over" earlier in this document).

- Check the startup disk and program you were using when the message
appeared. Make sure that all programs, desk accessories, and system
extensions you're using are compatible with the system software. Reinstalling
the system software may correct the problem.

- Sometimes incompatible system extensions or control panels can cause system
software problems. Restart while holding down the Shift key; this disables
all system extensions. If startup is normal with this method, then remove all
extensions and put them back into the System Folder one at a time, starting
up after you add each extension. This procedure should identify any
incompatible extensions.

The pointer "freezes" on the screen.

Your system has a software problem.

- Press Command-Option-Esc to close the program in use when the problem
occurred. If this works, you can then save the documents open in other
programs before restarting.

- Restart your Macintosh (see "Start Over" earlier in this document).

- Check the startup disk and program you were using when the message
appeared. Make sure that all programs, desk accessories, and system
extensions you're using are compatible with the system software. Reinstalling
the system software may correct the problem.

Your program quits unexpectedly.

The program needs more memory than your Macintosh has available, or the
program requires a floating-point unit (FPU) and your Macintosh doesn't have
one.

- Quit from the programs that you have open and then open the program you
want to use, or restart your Macintosh.

- Check the documentation that came with the program to find out if the
program requires a Macintosh with an FPU, and check the setup book that came
with your Macintosh to find out if your computer is equipped with an FPU, or
if an FPU can be installed. Consult your authorized service provider for
information about installing an FPU in your computer.

CHAPTER 17-WORKING ON THE MACINTOSH DESKTOP

In this document:



- Using the mouse

- Working with icons

- Working with windows

- Working with menus

- Keyboard shortcuts in the Finder and in directory dialog boxes

- Working with disks

- Working with programs

Using The Mouse

Point.

- Point to an object on screen by moving the mouse so that the pointer is
over that object.

When the pointer is an arrow, the tip of the arrow must be over the object.

Click.

- Click an object on screen by pressing and quickly releasing the mouse
button while the pointer is over that object.

Clicking an object selects it.

Drag.

- Drag an object on screen by pointing to that object and holding down the
mouse button while you move the mouse.

Dragging an object from one disk to another copies it, dragging an object
from one place to another on a single disk moves it within that disk without
making a copy, and dragging an object to the Trash throws it away.

Press.

- Press by holding down the mouse button without moving the mouse.

Pressing a menu name opens the menu.

Double-click.

- Double-click an object on screen by pointing to the object and clicking
twice in rapid succession, without moving the mouse.

Double-clicking is a common shortcut for opening an icon or the selected item
in a directory dialog box.

Shift-click.

- Hold down the Shift key while clicking.



Shift-clicking is a way to select more than one icon or item in a list.

Working With Icons

Icons on the Macintosh desktop represent disks (floppy disks and hard disks)
and files (programs and documents). When you open an icon, its window
appears, showing you what's "inside" the disk or file.

Selecting icons

To do this              Take these steps
----------------------------------------
Select an icon           Click the icon.

Deselect an icon         Click anywhere except the selected icon.

Select multiple icons    While holding down the Shift key, click each icon.

Deselect an icon in a    While holding down the Shift key, click 
group of selected icons  the icon.

Select multiple icons    1. Place the pointer at one corner of the 
that are near each other    group of icons.

2. Drag diagonally to select the icons, the
release the mouse button.

Select contiguous icons  1. Place the pointer to the left of the top icon 
in a list                   or the bottom icon.

2. Drag up or down the list, releasing the mouse 
button when the pointer is left of the last 
icon.

Select text in an icon's  1. Click the icon's name to select it.
name                      2. Place the pointer at one end of the text

to be selected.
3. Drag to select the text, then release the 

mouse button.

Opening an icon

You open an icon by selecting it and choosing Open from the File menu or
using the keyboard shortcut Command-O or Command-Down Arrow. Or you can
double-click the icon.

Moving, copying, and renaming an icon

To do this                     Take these steps
-----------------------------------------------
Move an icon                   Drag the icon to where you want it.

Copy an icon onto              Drag the icon to the icon of the other disk 
(or to another disk            an icon or window that belongs to that 
disk).

Copy an icon on the            1. Click the icon to select it.
same disk                      2. Choose Duplicate from the File menu, or 

press x-D.
3. If you wish, rename the icon and drag it 



to a new location.
You can also make a copy by holding down 
the Option key while you drag the file's 
icon to where you want the copy.

Rename an icon                 1. Select the icon's name by clicking the 
name (not the icon).

2. Type a new name and press the Return key.

Storing icons in a folder

Drag the icons to the folder until both the icons and the folder are
selected, and then release the mouse button.

Removing an icon

You remove an icon from the desktop or any Finder window by dragging it to
the Trash. To erase the contents of the icon from your disk, you choose the
Empty Trash command from the Special menu.

The Trash displays a warning before its contents are discarded. You can't
throw away a locked file or an item that's currently in use.

Working With Windows

A window appears when you open an icon to show you what's "inside" the icon.

Making a window the active window

You make a window active by clicking inside it. You may have to move or
resize other windows if the one you want to make active is covered by other
windows. You can also make a window active by clicking its icon (even though
it's dimmed) and choosing Open from the File menu, or by double-clicking the
dimmed icon.

Moving a window and changing its size

To do this             Take these steps
---------------------------------------
Move a window          Drag the window's title bar (at the top of the 

window) to the new location.

Resize a window        Drag the size box (in the lower-right corner).

Or click the zoom box (in the upper-right corner).

Close a window         Click the close box (in the upper-left corner).
Or choose Close from the File menu.
Or press Command-W.

Scrolling through the contents of a window

- Click the up, down, left, or right scroll arrow.

- Click the vertical or horizontal scroll bar (when it's gray).

- Drag the vertical or horizontal scroll box along its scroll bar.



Opening higher-level folder windows

You can open a higher-level folder window (whose contents include the active
window) from a pop-up menu in the active window's title.

1.  Hold down the Command key as you press the active window's title.

A pop-up menu of the higher-level folders (and disk) appears.

2.  Drag to choose a higher-level folder (or the disk), and then release the
mouse button.

The folder (or disk) window you chose appears as the active window.

If you hold down the Option key as well as the Command key, the old window
closes when the new window appears.

Using the outline form in list views

Any list view you choose from the View menu (that is, any view except the
icon and small icon views) shows the contents of the active window in outline
form. You can see the contents of a folder without opening the folder in its
own window.

Click the triangle next to a folder name to display or hide the folder's
contents in the active window.

If you double-click a folder, it opens in its own window, and its outline
view closes.

Shortcuts:  When a folder is selected in an outline view, pressing Command-
Right Arrow displays the list of its contents and Command-Left Arrow hides
the list of its contents. 

Working With Menus

Macintosh menus come in two types: pull-down menus and pop-up menus. The
menus in the menu bar are pull-down menus.

Pop-up menus often appear in dialog boxes that you use to set options or
preferences. You can recognize a pop-up menu by a small solid triangle,
pointing down, next to its name. The name shows the current option or
preference.

Choosing an item from a menu

To choose a command from a menu, point to the menu name, press to "pull down"
or "pop up" the menu, drag to the item you want to choose so that it's
highlighted, and then release the mouse button.

Choosing an item from a submenu

Some menu items are submenus. A submenu name has a small solid triangle next
to it, pointing to the right. The submenu opens when the submenu name is
highlighted.

To choose an item in a submenu:



1.  Point to the menu name and press to pull down or pop up the menu.

2.  Drag to the menu item so that the submenu appears.

3.  Drag sideways to the submenu, drag down to the submenu item you want to
choose so that it's highlighted, and then release the mouse button.

Keyboard Shortcuts In The Finder And In Directory Dialog Boxes

Key                  Action
---------------------------
Up, Down, Left,      Selects the next item in the direction of the 
or Right Arrow key   arrow

Tab key              Selects the next item alphabetically (except in a 
directory dialog box and the Chooser)

Character            Selects the first item whose name begins with 
key (a, b, c . . .)  that character (or the character following 

closest to it in the alphabet)

Command-Down Arrow   Opens the selected icon

Command-Option-Down  Opens the selected icon and closes the current folder
Arrow

Command-Up Arrow     Opens the folder that contains the current folder

Command-Option-Up    Opens the folder that contains the current folder and 
Arrow                closes the current folder

Return or Enter      In the Finder: Selects the selected icon's name for 
editing or saves the edited name

In a dialog box: the same as clicking the 
button with the bold outline around it

Working With Disks

See "Hard Disks and Floppy Disks," for more information about using disks.

Inserting a floppy disk

1.  Hold the disk between thumb and forefinger, with the label facing upward
and the metal shutter pointing away from you.

2.  Gently push the disk into the floppy disk drive, label side up and metal
shutter first, until the disk drive pulls the disk in the rest of the way.

Copying the contents of a disk

1.  Click the disk icon to select it.

2.  Drag the disk icon to the icon that represents the disk where you want
the copy made until both disk icons are selected.

3.  Release the mouse button.



Respond to any messages that appear by clicking the appropriate buttons.

Removing a floppy disk from the disk drive

1.  Click the disk icon to select it.

2.  Choose Put Away from the File menu.

3.  When the floppy disk drive ejects the disk, remove it from the disk
drive.

You can also drag the disk icon to the Trash. This action ejects the disk; it
does not erase the disk.

Locking and unlocking a floppy disk

1.  Hold the disk between thumb and forefinger, with the label facing upward
and the metal shutter pointing away from you (as if you were going to insert
the disk into a drive).

2.  Find the square hole in the lower-left corner of the floppy disk.

3.  Lock the disk by sliding the tab on the back side of the disk so that the
square hole is open.

Unlock the disk by sliding the tab back so that the square hole is blocked.

Working With Programs

For specific information about a particular program, go to the manuals that
came with the program.

Saving your work

- Choose Save from the File menu, or hold down the Command key as you press
the S key.

Switching programs

- Click anywhere in a window to make it the active window and its program the
active program.

You can also choose the program from the Application menu.

Closing a document

- Click the close box of the document window near the left end of the title
bar, or choose Close from the File menu.

Respond to any messages that appear by clicking the appropriate buttons.

Quitting a program

- Choose Quit from the File menu, or hold down the Command key as you press
the Q key.

Respond to any messages that appear by clicking the appropriate buttons.



Backing up your files

1.  Click to select the icon of the document or program you want to back up.

2.  Drag the icon to the disk icon where you want to store the backup copy
until both icons are selected, then release the mouse button.

Respond to any messages that appear by clicking the appropriate buttons.

Making a copy of a file

1.  Click to select the file icon.

2.  Choose Duplicate from the File menu.

Saving another version of a document

1.  Open the document.

2.  Make the changes you want in the new version.

3.  Choose Save As from the File menu.

4.  Type the name of the new version.

5.  Click Save.

KEYBOARDS AND CHARACTER SETS

"Typing Non-English Characters and Special Symbols" is at the end of this
document.

Macintosh Classic And Macintosh LC Standard Keyboard 

For instructions on adjusting the height of this keyboard, go to �Setting Up
Your Macintosh System.�

Apple Keyboard 

This keyboard has no height adjustment.

Apple Extended Keyboard II

A reversible plastic template that comes with this keyboard fits over the row
of function keys. You can label the function keys by writing on the template
(in pencil, not pen or marker).

For instructions on adjusting the height of this keyboard, go to "Setting Up
Your Macintosh System."



Typing Non-English Characters And Special Symbols

You can type a variety of non-English characters (with diacritical marks) and
special symbols by pressing the modifier keys (such as Shift, Option, and
Control) in combination with certain letter and number keys.

The Key Caps program, which is installed with the system software, shows you
the characters produced when you type certain keys and key combinations in
the fonts you have (choose Key Caps from the Apple menu, then choose the font
from the Key Caps menu).

To type a character with a diacritical mark (such as an acute accent or an
umlaut), you press the Option key with a specific letter key, then you type
the character.

Diacritical mark                    Key combination
---------------------------------------------------
Grave accent ( ` )                  Option-`, then type the character
Acute accent ( ´ )                  Option-e, then type the character
Circumflex (^)                      Option-i, then type the character
Tilde (~)                           Option-n, then type the character
Umlaut ( ¨ )                        Option-u, then type the character 
The letter c with a cedilla (ç)     Option-c

If the character appears after the diacritical mark (rather than with it),
then the marked character is not available in the font you're using. 

CHAPTER 19-EXCHANGING FILES WITH MS-DOS AND APPLE II COMPUTERS

Disk capacity is the same for Macintosh and MS-DOS high-density disks.

Apple File Exchange is a file format conversion program that is supplied on
the system software floppy disks. The program and three special translator
files are stored in the Apple File Exchange Folder.

You can use the program to initialize a disk in MS-DOS or ProDOS (Apple II)
format and convert files to and from MS-DOS or ProDOS. (Apple File Exchange
cannot open converted files; you need to use an application program that
recognizes the converted files to open them.)

Initializing A Disk In MS-DOS Or ProDOS Format

1.  Locate the Apple File Exchange icon and open it.

Apple File Exchange is supplied on the system software disks.

The program's window opens. The contents of the active window are listed on
the left side and an empty box appears on the right side.

2.  Place a blank disk in your floppy disk drive.

A dialog box appears, reporting that the program can't read the disk and
asking if you want to initialize it. This dialog box shows the names of
formats available in Apple File Exchange, including Macintosh, MS-DOS, and
ProDos.



(You can initialize a disk that is not blank by inserting it, clicking the
Drive button until its name appears in the window, and choosing Erase Disk
from the File menu.)

3.  Click MS-DOS or ProDOS.

4.  If necessary, click the capacity (in K) of the disk you inserted.

If you want to initialize a high-density disk in MS-DOS format, 1440K is the
only option and is already selected. If you inserted a double-sided disk,
click 720K.

5.  Click the Initialize button.

When initialization is completed, a dialog box appears, asking you to name
the disk.

6.  Type a name for the disk, then click OK.

MS-DOS file names can have up to eight characters, followed by an optional
period and up to three characters.

The dialog box closes, and the name of the disk you initialized appears,
above an empty window. This disk's icon doesn't appear on your Macintosh
screen (because the Macintosh cannot recognize a disk in MS-DOS or ProDOS
format).

7.  Choose Quit from the File menu when you are finished using Apple File
Exchange.

Apple File Exchange cannot initialize a high-density disk in 720K format, nor
can it read a double-sided disk that has been initialized in the high-density
(1.4 MB) format.

5.25-inch disks:   Some Macintosh models can use an external 5.25-inch floppy
disk drive that can read files from MS-DOS disks. An internal adapter or
expansion card is required to connect a 5.25-inch disk drive to the
Macintosh. Apple File Exchange can translate files from these disks and store
files on them.

Converting Files To And From MS-DOS Or ProDOS Format

Apple File Exchange provides two methods of file conversion --  text and
binary. You use text translation for text files, and binary translation for
other files.

In addition, Apple File Exchange can use special translator files designed to
convert files into formats that specific programs can use. One of these
special translator files is provided with Apple File Exchange: DCA-
RFT/MacWrite, which converts documents between MacWrite format for the
Macintosh and Document Content Architecture/Revisable Form Text format (used
by many word-processing programs) for MS-DOS.

Follow these steps to translate a file:

1.  Locate the Apple File Exchange icon and open it.



Apple File Exchange is supplied on the system software disks.

The program's window opens. The contents of the active window are listed on
the left side and an empty box appears on the right side.

2.  Insert the floppy disk that contains the files you want to translate.

3.  Use the Open, Drive, and Eject buttons to display the files you want to
translate and the disk or folder where you want to store the translated
files.

4.  Click the names of the files or folders you want to translate.

To select multiple files or folders, hold down the Shift key and click each
name. You may have to scroll to locate the names of some files or folders.

The appropriate translation menus (one for translating from Macintosh format
and another for translating to Macintosh format) appear on the menu bar when
you select either MS-DOS or ProDOS files.

5.  Open the translation menu you want by pressing its name.

6.  Make sure that the translators for the types of files you've selected
have checkmarks; if not, choose them so that checkmarks appear next to them.

An active translator has a checkmark. The default translator has a diamond
(indicating that it's always active). Choosing an active translator makes it
inactive.

7.  Compare the size of the files or folders selected for translation with
the space available on the destination disk.

The total space required appears between the lists; the space available on
the destination disk appears below its name.

If the size of the selected items is greater than the space available on the
destination disk, deselect some of the items (by Shift-clicking them), remove
some files on the destination disk (using the Remove button), or change to
another destination disk (using the Eject button).

8.  Click the Translate button.

If Apple File Exchange finds two or more active translators --  other than
Text or Default -- capable of translating a selected file, it presents a
dialog box asking you to select the translator you want.

If the names of files or folders on the destination disk are the same as
those of files or folders being translated, Apple File Exchange presents a
dialog box asking you to rename the file being translated.

If a translator requires you to select options before a file is translated,
it presents a dialog box in which you select the options.

9.  Respond to any dialog boxes presented by selecting a translator, renaming
the file, or selecting options.

The selected files or folders are translated. Messages report the status of
copying.



If Macintosh files are being translated into MS-DOS files, the names of
translated files may be shortened to conform to the naming conventions of MS-
DOS.

10.  When all translations are finished, choose Quit from the File menu.

Converting MS-DOS files on a file server:  Some file servers can store
information created by both Macintosh computers and MS-DOS computers. For
example, the AppleShare PC program allows MS-DOS computers to store and
translate files on an AppleShare file server. Consult your authorized Apple
dealer or representative for more information about using a file server and
MS-DOS files.

Other File-conversion Options

Apple File Exchange's File menu provides several other options to assist you
with file conversions.

More information about Apple File Exchange options.

To see explanations of the translators Apple File Exchange uses, choose About
the Apple File Exchange from the Apple menu. Select a translator in the list
that appears, then click the About button for information about that item.
(Click Done to return to the program's window.)


